Joomla CMS: Page principale

Joomla CMS 4.2.2
Documentation des API du CMS Joomla en version 4.2.2
Joomla CMS Documentation

Service de documentation des API de Joomla

Capture de la documentation en ligne des API Joomla au format PHPdoc via Doxygen Retrouvez la documentation et les schémas d'héritage des classes du CMS et du Framework Joomla.

Utilisez le moteur de recherche en haut à droite si vous recherchez une classe particulière
ou accèdez directement aux informations suivantes :

Listes des API par types :

Index des Classes PHP Joomla
Schémas d'héritage des Classes PHP Joomla
Membres des Classes PHP Joomla (méthodes et propriétés)
Recherche des Classes PHP Joomla via la liste des fichiers PHP

Retrouvez les autres API de Joomla au format HTML et CHM sur le site api.joomla.fr

Autres sites de l'AFUJ et de la communauté Joomla!

Association AFUJ (Association Francophone des Utilisateurs de Joomla)

  • forum.joomla.fr Développeurs : Forum d'aide des développeurs Joomla Francophone
  • www.joomla.fr : Portail Joomla france
  • www.afuj.fr : Side des adhérents de l'AFUJ
  • Wiki docs.joomla.org (FR) : site d'information des développeurs Joomla Francophone
Ce site d'API et les autres services présents sont édités par l'AFUJ (Association Francophone des Utilisateurs de Joomla).
Le nom Joomla!® est utilisé sous license limitée de Open Source Matters, le propriétaire mondial de la marque de commerce.
AFUJ.fr n'est ni affilié à Open Source Matters ou au projet Joomla!® ni approuvé par eux.

  • Documentation et API générés le 26/09/2022 par l'équipe www.joomla.fr de l'AFUJ avec la solution doxygen


Joomla CMS: Liste des éléments obsolètes

Liste des éléments obsolètes
Global(e) AbstractMenu::getInstance ($client, $options=array())
5.0 Use the MenuFactoryInterface from the container instead
Global(e) AbstractWebApplication::__get ($name)
3.0 This is a B/C proxy for deprecated read accesses
Global(e) ActionlogsHelper::getLogContentTypeParams ($context)
5.0 Use the action log config model instead
Classe Adapter
5.0 Will be removed without replacement
Classe AdapterInstance
5.0 Will be removed without replacement
Global(e) AdministratorApplication::getRouter ($name='administrator', array $options=array())
5.0 Inject the router or load it from the dependency injection container
Global(e) AdministratorApplication::purgeMessages ()
5.0 Purge the messages through the model
Global(e) AdminModel::editAssociations ($data)
5.0 It is handled by regular save method now.
Global(e) Aes::__construct ($key, $strength=128, $mode='cbc', $priority='openssl')
5.0 $strength will be removed
Global(e) Algorithms::getAlgorithm (int $identifier)
Will be removed in v3.0. Please use the Manager or the ManagerFactory
Global(e) Algorithms::getAlgorithms ()
Will be removed in v3.0. Please use the Manager or the ManagerFactory
Classe AndroidKeyAttestationStatementSupport
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Classe AndroidKeyAttestationStatementSupport
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Global(e) ApiApplication::getApiRouter ()
5.0 Inject the router or load it from the dependency injection container
Global(e) ArticleModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) ArticleModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) ArticlesLatestHelper::getList (Registry $params, ArticlesModel $model)
5.0 Use the none static function getArticles
Global(e) ArticlesNewsHelper::getList (&$params)
5.0 Use the none static function getArticles
Global(e) Assert::isTraversable ($value, $message='')
use "isIterable" or "isInstanceOf" instead
Global(e) Assert::thatNullOr ($value, $defaultMessage=null, string $defaultPropertyPath=null)
In favour of Assert::thatNullOr($value, $defaultMessage = null, $defaultPropertyPath = null)
Global(e) AuthenticationHelper::getTwoFactorMethods ()
4.2.0 Will be removed in 5.0.
Classe BannersHelper
5.0 Use instead
Global(e) BaseController::addModelPath ($path, $prefix='')
5.0 See ::getInstance
Global(e) BaseController::getInstance ($prefix, $config=array())
5.0 Get the controller through the MVCFactory instead
Global(e) BaseDatabaseModel::__construct ($config=array(), MVCFactoryInterface $factory=null)
5.0 Database instance is injected through the setter function, subclasses should not use the db instance in constructor anymore
Global(e) BaseDatabaseModel::__get ($name)
5.0 Use getDatabase() instead of directly accessing _db
Global(e) BaseDatabaseModel::getDbo ()
5.0 Use getDatabase() instead
Global(e) BaseDatabaseModel::setDbo (DatabaseInterface $db=null)
5.0 Use setDatabase() instead
Global(e) BaseModel::addIncludePath ($path='', $prefix='')
5.0 See LegacyModelLoaderTrait
Classe BaseSigner
This class will be removed on v4
Classe Basic
This class will be removed on v4
Global(e) BasicButton::fetchButton ($type='Basic')
5.0 Use render() instead.
Global(e) Behavior::combobox ()
5.0 Use the script directly
Global(e) Behavior::core ()
5.0 Use Joomla::enable();
Global(e) Behavior::formvalidator ()
5.0 Use the script directly
Global(e) Behavior::highlighter (array $terms, $start='highlighter-start', $end='highlighter-end', $className='highlight', $tag='span')
5.0 Use the script directly
Global(e) Behavior::keepalive ()
5.0 Use Joomla::enable();
Global(e) Behavior::multiselect ($id='adminForm')
5.0 Use the script directly
Global(e) BigInteger::parse (string $number, int $base=10)
will be removed in version 0.9 - use fromBase() instead
Global(e) BigInteger::powerMod ($exp, $mod)
Use modPow() instead.
Global(e) Bootstrap::framework ($debug=null)
5.0
Global(e) Bootup::filterRequestInputs (int $normalization_form=::NFC, string $leading_combining='◌')
Global(e) Bootup::filterRequestUri ($uri=null, bool $exit=true)
Global(e) Builder::canOnlyBeUsedBy ($audience, $replicateAsHeader=false)
This method has been wrongly added and doesn't exist on v4
Global(e) Builder::set ($name, $value)
This method will be removed on v4
Global(e) Builder::setAudience ($audience, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setExpiration ($expiration, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setHeader ($name, $value)
This method will be removed on v4
Global(e) Builder::setId ($id, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setIssuedAt ($issuedAt, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setIssuer ($issuer, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setNotBefore ($notBefore, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::setSubject ($subject, $replicateAsHeader=false)
This method will be removed on v4
Global(e) Builder::sign (Signer $signer, $key)
This method will be removed on v4
Global(e) Builder::unsign ()
This method will be removed on v4
Global(e) Builder::with ($name, $value)
This method has been wrongly added and doesn't exist on v4
Global(e) Cache::getInstance ($type='output', $options=array())
5.0 Use the cache controller factory instead
Global(e) CacheController::addIncludePath ($path='')
5.0 Use the cache controller factory instead
Global(e) CacheController::getInstance ($type='output', $options=array())
5.0 Use the cache controller factory instead
Global(e) Categories::getInstance ($extension, $options=array())
5.0 Use the ComponentInterface to get the categories
Classe CategoriesHelper
5.0 Use instead
Global(e) CategoryModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Classe Cli
5.0 Use the joomla/console package instead
Global(e) Cli::__construct (array $source=null, array $options=array())
5.0 Use the joomla/console package instead
Global(e) Cli::parseArguments ()
5.0 Use the joomla/console package instead
Global(e) Cli::serialize ()
5.0 Use the joomla/console package instead
Global(e) Cli::unserialize ($input)
5.0 Use the joomla/console package instead
Classe CliApplication
5.0 Use the ConsoleApplication instead
Global(e) CliApplication::__get ($name)
5.0 This is a B/C proxy for deprecated read accesses
Global(e) CliApplication::getInstance ($name=null)
5.0 Load the app through the container
Global(e) CliApplication::isCli ()
5.0 Will be removed without replacements
Classe CliInput
5.0 Use the joomla/console package instead
Classe CliOutput
5.0 Use the joomla/console package instead
Global(e) CMSApplication::getCfg ($varname, $default=null)
5.0 Use get() instead
Global(e) CMSApplication::getInstance ($name=null, $prefix='', Container $container=null)
5.0 Use getContainer()->get($name) instead
Global(e) CMSApplication::getRouter ($name=null, array $options=array())
5.0 Inject the router or load it from the dependency injection container
Global(e) CMSApplication::hasUserConfiguredTwoFactorAuthentication ()
4.2.0 Will be removed in 5.0 without replacement.
Global(e) CMSApplication::isCli ()
5.0 Will be removed without replacements
Global(e) CMSApplication::isTwoFactorAuthenticationRequired ()
4.2.0 Will be removed in 5.0 without replacement.
Global(e) CMSApplication::route ()
5.0 Implement the route functionality in the extending class, this here will be removed without replacement
Global(e) CMSApplicationInterface::isCli ()
5.0 Will be removed without replacements
Classe CMSObject
4.0.0 Use or instead.
Global(e) CMSObject::__toString ()
3.1.4 Classes should provide their own __toString() implementation.
Global(e) CMSObject::getError ($i=null, $toString=true)
3.1.4 JError has been deprecated
Global(e) CMSObject::getErrors ()
3.1.4 JError has been deprecated
Global(e) CMSObject::setError ($error)
3.1.4 JError has been deprecated
Global(e) CMSWebApplicationInterface::getRouter ($name=null, array $options=array())
5.0 Inject the router or load it from the dependency injection container
Classe ColorProcessor
5.0 Use the joomla/console package instead
Classe ColorStyle
5.0 Use the joomla/console package instead
Global(e) ComponentRecord::__get ($name)
5.0 Access the item parameters through the getParams() method
Global(e) ComponentRecord::__set ($name, $value)
5.0 Set the item parameters through the setParams() method
Global(e) ConfirmButton::fetchButton ($type='Confirm', $msg='', $name='', $text='', $task='', $list=true, $hideMenu=false)
5.0 Use render() instead.
Global(e) ConsoleApplication::__get ($name)
5.0 This is a B/C proxy for deprecated read accesses
Global(e) ConsoleApplication::getRouter ($name=null, array $options=array())
5.0 Inject the router or load it from the dependency injection container
Global(e) ConsoleApplication::isCli ()
5.0 Will be removed without replacements
Classe ContactHelper
5.0 Use instead
Global(e) Container::exists ($key)
3.0 Use ContainerInterface::has() instead
Classe ContentHelper
5.0 Use instead
Classe ContenthistoryHelper
5.0 Use instead
Classe Cookie
5.0 Use Joomla instead
Global(e) Cookie::__construct (array $source=null, array $options=array())
5.0 Use Joomla instead
Global(e) Cookie::set ($name, $value, $expire=0, $path='', $domain='', $secure=false, $httpOnly=false)
5.0 Use Joomla instead
Global(e) CronExpression::factory (string $expression, FieldFactoryInterface $fieldFactory=null)
since version 3.0.2, use __construct instead.
Global(e) CronExpression::YEAR
Classe CryptoCipher
5.0 Without replacement use SodiumCipher
Global(e) CustomButton::fetchButton ($type='Custom', $html='', $id='custom')
5.0 Use render() instead.
Global(e) DatabaseDriver::__get ($name)
3.0 This is a B/C proxy since $this->name was previously public
Global(e) DatabaseDriver::getInstance (array $options=[])
3.0 Use DatabaseFactory::getDriver() instead
Global(e) DatabaseDriver::quoteNameStr ($strArr)
2.0 Use quoteNameString instead
Global(e) DatabaseDriver::setQuery ($query, $offset=0, $limit=0)

3.0 Use LimitableInterface::setLimit() instead}

3.0 Use LimitableInterface::setLimit() instead}

Global(e) DatabaseInterface::setQuery ($query, $offset=0, $limit=0)

3.0 Use LimitableInterface::setLimit() instead}

3.0 Use LimitableInterface::setLimit() instead}

Global(e) DatabaseQuery::castAsChar ($value)
3.0 Use $query->castAs('CHAR', $value)
Global(e) DatabaseQuery::dump ()
3.0 Deprecated without replacement
Global(e) DataCollector::formatBytes ($size, $precision=2)
Global(e) DataCollector::formatDuration ($seconds)
Global(e) DataCollector::formatVar ($var)
Global(e) Dispatcher::addEvent (EventInterface $event)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::clearEvents ()
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::countEvents ()
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::getDefaultEvent (string $name)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::getEvent ($name, $default=null)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::getEvents ()
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::hasEvent ($event)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::removeEvent ($event)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::setEvent (EventInterface $event)
3.0 Default event objects will no longer be supported
Global(e) Dispatcher::triggerEvent ($event)
3.0 Use dispatch() instead.
Global(e) Document::addScript ($url, $options=array(), $attribs=array())
5.0 Use WebAssetManager
Global(e) Document::addScriptDeclaration ($content, $type='text/javascript')
5.0 Use WebAssetManager
Global(e) Document::addStyleDeclaration ($content, $type='text/css')
5.0 Use WebAssetManager
Global(e) Document::addStyleSheet ($url, $options=array(), $attribs=array())
5.0 Use WebAssetManager
Global(e) Document::getInstance ($type='html', $attributes=array())
5.0 Use the instead
Classe EqualsTo
This class will be removed on v4
Global(e) Event::stop ()
3.0 Use stopPropogation instead
Classe EventAwareInterface
5.0 This interface will be removed as the Joomla 3.x compatibility layer will be removed
Global(e) EventAwareInterface::triggerEvent ($eventName, $args=[])
5.0
Global(e) ExceptionsCollector::addException (Exception $e)
in favor on addThrowable
Global(e) ExceptionsCollector::formatExceptionData (Exception $e)
in favor on formatThrowableData
Classe ExtensionHelper
4.0 Replace class with a non static methods for better testing
Classe Factory
This class will be removed on v4
Global(e) Factory::createConfig ($file, $type='PHP', $namespace='')
5.0 Use the configuration object within the application.
Global(e) Factory::createDbo ()
5.0 Use the database service in the DI container
Global(e) Factory::createDocument ()
5.0 Load the document service from the dependency injection container or via $app->getDocument()
Global(e) Factory::createLanguage ()
5.0 Load the language service from the dependency injection container or via $app->getLanguage()
Global(e) Factory::getCache ($group='', $handler='callback', $storage=null)
5.0 Use the cache controller factory instead
Global(e) Factory::getConfig ($file=null, $type='PHP', $namespace='')
5.0 Use the configuration object within the application.
Global(e) Factory::getDbo ()
5.0 Load the database service from the dependency injection container
Global(e) Factory::getDocument ()
5.0 Load the document service from the dependency injection container or via $app->getDocument()
Global(e) Factory::getLanguage ()
5.0 Load the language service from the dependency injection container or via $app->getLanguage()
Global(e) Factory::getSession (array $options=array())
5.0 Load the session service from the dependency injection container or via $app->getSession()
Global(e) Factory::getUser ($id=null)
5.0 Load the user service from the dependency injection container or via $app->getIdentity()
Classe FidoU2FAttestationStatementSupport
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Classe FidoU2FAttestationStatementSupport
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Global(e) FieldModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Classe FieldsHelper
5.0 Use instead
Classe Files
5.0 Use Joomla instead
Global(e) Files::__construct (array $source=null, array $options=array())
5.0 Use Joomla instead
Global(e) Files::decodeData (array $data)
5.0 Use Joomla instead
Global(e) Files::get ($name, $default=null, $filter='cmd')
5.0 Use Joomla instead
Global(e) Files::set ($name, $value)
5.0 Use Joomla instead
Global(e) FilterModel::cleanCache ($group='com_finder', $clientId=0)
5.0 No longer used.
Classe FinderHelperLanguage
5.0 Use instead
Classe FinderHelperRoute
5.0 Use instead
Global(e) Form::getInstance ($name, $data=null, $options=[], $replace=true, $xpath=false)
5.0 Use the FormFactory service from the container
Classe FormBehavior
5.0 Without replacement
Global(e) FormController::editAssociations ()
5.0 It is handled by regular save method now.
Classe GreaterOrEqualsTo
This class will be removed on v4
Global(e) GroupModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) HelpButton::fetchButton ($type='Help', $ref='', $com=false, $override=null, $component=null)
5.0 Use render() instead.
Global(e) Helper::strlen (?string $string)
since Symfony 5.3
Global(e) Helper::strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
since Symfony 5.3
Global(e) HelperSet::getCommand ()
since Symfony 5.4
Global(e) HelperSet::setCommand (Command $command=null)
since Symfony 5.4
Global(e) HTMLHelper::addIncludePath ($path='')
5.0 Use the service registry instead
Global(e) HTMLHelper::extract ($key)
5.0 Use the service registry instead
Global(e) HTMLHelper::register ($key, callable $function)
5.0 Use the service registry instead
Global(e) HTMLHelper::unregister ($key)
5.0 Use the service registry instead
Classe Inflector
Global(e) Inflector::addPluraliseRule ($data)
3.0 Use Doctrine::rules() instead.
Global(e) Inflector::addSingulariseRule ($data)
3.0 Use Doctrine::rules() instead.
Global(e) Inflector::addWord ($singular, $plural='')
3.0 Use Doctrine::rules() instead.
Global(e) Inflector::camelize (string $word)
Global(e) Inflector::getInstance ($new=false)
3.0 Use static methods without a class instance instead.
Global(e) Inflector::pluralize (string $word)
Global(e) Inflector::reset ()
Global(e) Inflector::rules (string $type, iterable $rules, bool $reset=false)
Global(e) Inflector::singularize (string $word)
Global(e) Inflector::tableize (string $word)
Global(e) Inflector::toPlural ($word)
3.0 Use Doctrine::pluralize() instead.
Global(e) Inflector::toSingular ($word)
3.0 Use Doctrine::singularize() instead.
Global(e) Inflector::ucwords (string $string, string $delimiters=" \\\B-")
Global(e) InlinehelpButton::fetchButton ( $type='Inlinehelp', string $targetClass='hide-aware-inline-help', string $text='JINLINEHELP', string $icon='fa fa-question-circle', string $buttonClass='btn btn-info')
5.0 Use render() instead.
Global(e) Input::__construct ($source=null, array $options=array())
5.0 Use Joomla instead
Global(e) Input::__get ($name)
5.0 Use Joomla instead
Global(e) Input::getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
5.0 Use Joomla instead
Global(e) Input::getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)
5.0 Use Joomla instead
Global(e) Input::unserialize ($input)
5.0 Use Joomla instead
Global(e) InputFilter::decode ($source)
This method will be removed once support for PHP 5.3 is discontinued.
Global(e) InstalledVersions::getRawData ()
Use getAllRawData() instead which returns all datasets for all autoloaders present in the process. getRawData only returns the first dataset loaded, which may not be what you expect.
Global(e) InstallerAdapter::__get ($name)
5.0 Use getDatabase() instead of directly accessing db
Classe InstallerHelper
5.0 Use instead
Global(e) ItemModel::cleanCache ($group=null, $clientId=0)
5.0 No Longer Used.
Classe JHtmlIcon
5.0 Use the class instead
Global(e) JHtmlIcon::create ($category, $params, $attribs=array(), $legacy=false)
5.0 Use the class instead
Global(e) JHtmlIcon::edit ($article, $params, $attribs=array(), $legacy=false)
5.0 Use the class instead
Global(e) JHtmlIcon::print_popup ($article, $params, $attribs=array(), $legacy=false)
5.0 Use the class instead
Global(e) JHtmlIcon::print_screen ($article, $params, $attribs=array(), $legacy=false)

for 4.0

for 4.0

5.0 Use the class instead

Global(e) jimport ($path, $base=null)
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.
Global(e) JLoader::discover ($classPrefix, $parentPath, $force=true, $recurse=false)
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.
Global(e) JLoader::import ($key, $base=null)
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.
Global(e) JLoader::loadByPsr4 ($class)
5.0 Use JLoader::loadByPsr instead
Global(e) JLoader::register ($class, $path, $force=true)
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.
Global(e) Joomla::CMS::Application::triggerEvent ($eventName, $args=[])
5.0
Global(e) Joomla::CMS::MVC::Model::DatabaseAwareTrait
5.0 Use the trait from the database package
Global(e) Joomla::CMS::MVC::Model::getDbo ()
5.0 Use the trait from the database package
Global(e) Joomla::CMS::MVC::Model::setDbo (DatabaseInterface $db=null)
5.0 Use the trait from the database package
Espace de nommage Joomla

5.0 Use instead

5.0 without replacement

Global(e) Jquery::framework ($noConflict=true, $debug=null, $migrate=false)
5.0 Use Joomla::useAsset();
Classe Json
5.0 Use Joomla instead
Global(e) Json::__construct (array $source=null, array $options=array())
5.0 Use Joomla instead
Global(e) Json::getRaw ()
5.0 Use Joomla instead
Global(e) Key::getContent ()
This method is no longer part of the public interface
Global(e) Key::getPassphrase ()
This method is no longer part of the public interface
Classe Keychain
Since we've removed OpenSSL from ECDSA there's no reason to use this class
Global(e) Language::getInstance ($lang, $debug=false)
5.0 Use the language factory instead
Global(e) LanguageModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) LanguagesModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) LdapAuthenticator::createAuthenticatedToken (PassportInterface $passport, string $firewallName)
since Symfony 5.4, use createToken() instead
Classe LdapClient
The joomla/ldap package is deprecated
Classe LesserOrEqualsTo
This class will be removed on v4
Classe LimitableInterface
3.0 Capabilities will be required in Joomla
Global(e) LinkButton::fetchButton ($type='Link', $name='back', $text='', $url=null)
5.0 Use render() instead.
Classe LocalFileReference
Use ::file() instead
Global(e) Manager::getAlgorithms ()
Will be removed in v3.0. Please use all() instead
Classe Mcrypt
4.0.0 will be removed in 5.0.0
Classe MD5Handler
5.0 Support for MD5 hashed passwords will be removed
Global(e) MenuModel::cleanCache ($group=null, $clientId=0)
5.0 No Longer used.
Global(e) MenusController::resync ()
5.0 Will be removed without replacement as it was only used for the 1.5 to 1.6 upgrade
Classe MenusHelper
5.0 Use instead
Global(e) ModuleModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) Modules::positionList ($clientId=0)
5.0 Will be removed with no replacement
Classe ModulesHelper
5.0 Use instead
Classe MtRandGenerator
The mt_rand() function is not a reliable source of randomness. The default RandomBytesGenerator, which uses the random_bytes() function, is recommended as the safest and most reliable source of randomness. This generator will be removed in ramsey/uuid 4.0.0. http://php.net/mt_rand
Classe NewsfeedsHelper
5.0 Use instead
Classe NewsfeedsHelperRoute
5.0 Use Joomla instead
Global(e) Normalizer::NONE
since ICU 56 and removed in PHP 8
Classe OpenSslGenerator
The openssl_random_pseudo_bytes() function is not a reliable source of randomness. The default RandomBytesGenerator, which uses the random_bytes() function, is recommended as the safest and most reliable source of randomness. This generator will be removed in ramsey/uuid 4.0.0. http://php.net/openssl_random_pseudo_bytes
Global(e) OptionsResolverIntrospector::getDeprecationMessage (string $option)
since Symfony 5.1, use "getDeprecation()" instead.
Global(e) Pathway::getInstance ($client)
5.0 Get the instance from the application, eg. $application->getPathway()
Global(e) PharStreamWrapper::resolveAssertable ()
Use Manager::instance() directly
Classe PHPassHandler
5.0 Support for PHPass hashed passwords will be removed
Global(e) PlgEditorTinymce::$_basePath
5.0
Global(e) PlgSystemDebug::logger (LogEntry $entry)
5.0 Use Log::add(LogEntry $entry);
Global(e) PluginModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Classe PluginsHelper
5.0 Use instead
Classe PreparableInterface
3.0 Capabilities will be required in Joomla
Classe ProcessorInterface
5.0 Use the joomla/console package instead
Global(e) ProfileModel::getTwofactorform ($userId=null)
4.2.0 Will be removed in 5.0.
Global(e) PublicKeyCredentialSource::createFromPublicKeyCredential (PublicKeyCredential $publicKeyCredential, string $userHandle)
Deprecated since v2.1. Will be removed in v3.0. Please use response from the credential source returned by the AuthenticatorAttestationResponseValidator after "check" method
Global(e) QueryHelper::buildVotingQuery ($params=null)
5.0 Deprecated without replacement, not used in core
Classe RedirectHelper
5.0 Use instead
Global(e) RelativeDistinguishedName::fromBinary (&$binaryData, &$offsetIndex=0)
this function is not yet implemented! Feel free to submit a pull request on github
Classe Response
5.0 Use Joomla instead
Global(e) Response::__get ($name)
3.0 Access data via the PSR-7 ResponseInterface instead
Global(e) RouteHelper::getTagRoute ($id)
5.0.0 Use getComponentTagRoute() instead
Global(e) RouteHelper::getTagsRoute ()
5.0.0
Global(e) Router::getInstance ($client, $options=array())
5.0 Inject the router or load it from the dependency injection container
Classe RSA
Please use either RSAPSS or RSAPKCS1 depending on the padding mode
Global(e) RSA::signWithPKCS15 (RSAKey $key, string $message, string $hash)
Please use openssl_sign
Global(e) RSA::verifyWithPKCS15 (RSAKey $key, string $message, string $signature, string $hash)
Please use openssl_sign
Global(e) SeparatorButton::fetchButton ()
5.0 Use render() instead.
Classe Server
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Classe Server
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.
Global(e) Session::getInstance ()
5.0 Load the session service from the dependency injection container or via $app->getSession()
Global(e) Signature::__toString ()
This method has been removed from the public API in v4
Global(e) SignedIntegerObject::createFromGmpValue (GMP $value)
Deprecated since v1.1 and will be removed in v2.0. Please use "create" or "createFromString" instead
Global(e) SiteApplication::getRouter ($name='site', array $options=array())
5.0 Inject the router or load it from the dependency injection container
Classe SodiumRandomGenerator
As of PHP 7.2.0, the libsodium extension is bundled with PHP, and the random_bytes() PHP function is now the recommended method for generating random byes. The default RandomBytesGenerator uses the random_bytes() function. This generator will be removed in ramsey/uuid 4.0.0. https://paragonie.com/book/pecl-libsodium
Classe SortableList
5.0 Sortable List will be deprecated in favour of a new dragula script in 4.0
Global(e) SortableList::sortable ($tableId, $formId, $sortDir='asc', $saveOrderingUrl=null, $proceedSaveOrderButton=true, $nestedList=false)
5.0 In Joomla 4 call JHtml::_('draggablelist.draggable') and add a class of js-draggable to the tbody element of the table
Global(e) StandardButton::fetchButton ($type='Standard', $name='', $text='', $task='', $list=true, $formId=null)
5.0 Use render() instead.
Classe Stdout
5.0 Use the joomla/console package instead
Global(e) StringController::_getArray ()
2.0 Use getArray instead.
Global(e) StyleModel::cleanCache ($group=null, $clientId=0)
5.0 No longer used.
Global(e) Table::addIncludePath ($path=null)
5.0 Should not be used anymore as tables are loaded through the MvcFactory
Global(e) Table::getInstance ($type, $prefix='JTable', $config=array())
5.0 Use the MvcFactory instead
Global(e) Tag::ajaxfield ($selector='#jform_tags', $allowCustom=true)
5.0 Without replacement
Classe TagsHelperRoute
5.0 Use instead
Classe TemplateHelper
5.0 Use instead
Global(e) Templates::thumb ($template, $clientId=0)
5.0 The argument $template should be object and $clientId will be removed
Global(e) Templates::thumbModal ($template, $clientId=0)
5.0 The argument $template should be object and $clientId will be removed
Classe TemplatesHelper
5.0 Use instead
Global(e) Token::__toString ()
This method has been removed from the interface in v4.0
Global(e) Token::getClaim ($name, $default=null)
This method has been removed from the interface in v4.0
Global(e) Token::getClaims ()
This method has been removed from the interface in v4.0
Global(e) Token::getHeader ($name, $default=null)
This method has been removed from the interface in v4.0
Global(e) Token::getHeaders ()
This method has been removed from the interface in v4.0
Global(e) Token::getPayload ()
This method has been removed from the interface in v4.0
Global(e) Token::hasClaim ($name)
This method has been removed from the interface in v4.0
Global(e) Token::hasHeader ($name)
This method has been removed from the interface in v4.0
Global(e) Token::validate (ValidationData $data)
This method has been removed from the interface in v4.0
Global(e) Token::verify (Signer $signer, $key)
This method has been removed from the interface in v4.0
Global(e) Toolbar::addButtonPath ($path)
5.0 ToolbarButton classes should be autoloaded
Global(e) Toolbar::getButtonPath ()
5.0 ToolbarButton classes should be autoloaded
Global(e) Toolbar::getInstance ($name='toolbar')
5.0 Use the ToolbarFactoryInterface instead
Global(e) ToolbarButton::fetchButton ()
5.0 Use render() instead.
Global(e) ToolbarHelper::custom ($task='', $icon='', $iconOver='', $alt='', $listSelect=true, $formId=null)
5.0
Classe TraceableTwigEnvironment
Classe TraceableTwigTemplate
Classe TransportInterface
5.0 Implement Joomla instead
Classe TwigCollector
use DebugBar instead
Classe TwigProfileCollector
Use \Debugbar\Bridge\NamespacedTwigProfileCollector instead for Twig 2.x and 3.x
Global(e) UnsignedIntegerObject::createFromGmpValue (GMP $value)
Deprecated since v1.1 and will be removed in v2.0. Please use "create" or "createFromString" instead
Global(e) UpdateModel::createRestorationFile ($basename=null)
5.0
Global(e) User::getInstance ($identifier=0)
5.0 Load the user service from the dependency injection container or via $app->getIdentity()
Global(e) UserModel::generateOteps ($userId, $count=10)
4.2.0 Wil be removed in 5.0.
Global(e) UserModel::getOtpConfig ($userId=null)
4.2.0 Will be removed in 5.0
Global(e) UserModel::getOtpConfigEncryptionKey ()
4.2.0 Will be removed in 5.0
Global(e) UserModel::getTwofactorform ($userId=null)
4.2.0 Will be removed in 5.0.
Global(e) UserModel::isValidOtep ($userId, $otep, $otpConfig=null)
4.2.0 Will be removed in 5.0
Global(e) UserModel::isValidSecretKey ($userId, $secretKey, $options=array())
4.2.0 Will be removed in 5.0. MFA validation is done in the captive login.
Global(e) UserModel::setOtpConfig ($userId, $otpConfig)
4.2.0 Will be removed in 5.0
Classe UsersHelper
5.0 Use instead
Global(e) UsersHelper::getContexts ()
5.0 Use ::getContexts() instead.
Global(e) UsersHelper::getTwoFactorMethods ()
4.2.0 Will be removed in 5.0
Global(e) UsersHelper::validateSection ($section)
5.0 Use ::validateSection() instead.
Classe UsersHelperDebug
5.0 Use instead
Classe Validatable
This interface will be removed on v4
Classe ValidationData
This component has been removed from the interface in v4.0
Global(e) WebApplication::getInstance ($name=null)
5.0 Use getContainer()->get($name) instead
Global(e) WebApplication::loadSession (Session $session=null)
5.0 The session should be injected as a service.
Classe WincacheStorage
5.0 WinCache is abandoned and not supported from PHP 8 onwards
Global(e) WincacheStorage::clean ($group, $mode=null)
5.0
Global(e) WincacheStorage::contains ($id, $group)
5.0
Global(e) WincacheStorage::gc ()
5.0
Global(e) WincacheStorage::get ($id, $group, $checkTime=true)
5.0
Global(e) WincacheStorage::getAll ()
5.0
Global(e) WincacheStorage::isSupported ()
5.0
Global(e) WincacheStorage::remove ($id, $group)
5.0
Global(e) WincacheStorage::store ($id, $group, $data)
5.0
Classe Xml
5.0 Use the joomla/console package instead
Global(e) Zend::Diactoros::createUploadedFile (array $spec)
Use Laminas instead
Global(e) Zend::Diactoros::marshalHeadersFromSapi (array $server)
Use Laminas instead
Global(e) Zend::Diactoros::marshalMethodFromSapi (array $server)
Use Laminas instead
Global(e) Zend::Diactoros::marshalProtocolVersionFromSapi (array $server)
Use Laminas instead
Global(e) Zend::Diactoros::marshalUriFromSapi (array $server, array $headers)
Use Laminas instead
Global(e) Zend::Diactoros::normalizeServer (array $server, callable $apacheRequestHeaderCallback=null)
Use Laminas instead
Global(e) Zend::Diactoros::normalizeUploadedFiles (array $files)
Use Laminas instead
Global(e) Zend::Diactoros::parseCookieHeader ($cookieHeader)
Use Laminas instead


Joomla CMS: Liste des espaces de nommage

Liste des espaces de nommage
Liste de tous les espaces de nommage avec une brève description:
[Niveau de détails 123456]
N AES
▶N Algo26
▶N IdnaConvert
N EncodingHelper
N Exception
N NamePrep
N Punycode
N TranscodeUnicode
N ANSI
N ASN1
N Assert
N AsymmetricKey
N BadConfigurationException
N BadDecryptionException
N BadModeException
N Base
N Base64Url
N BCMath
N bcmath_compat
N BigInteger
N Binary
N BlockCipher
N Blowfish
▶N Brick
▶N Math
N Exception
▶N Internal
N Calculator
▶N CBOR
N OtherObject
N Tag
N ChaCha20
N Common
▶N Composer
N Autoload
N CaBundle
N ConnectionClosedException
▶N Cose
▶N Algorithm
N Mac
▶N Signature
N ECDSA
N EdDSA
N RSA
N Key
N Cron
▶N DebugBar
▶N Bridge
N SwiftMailer
N Twig
▶N DataCollector
N PDO
▶N DataFormatter
N VarDumper
N Storage
▶N Defuse
▶N Crypto
N Exception
N DES
N DH
▶N Doctrine
▶N Common
N Inflector
▶N Inflector
▶N Rules
N English
N French
N NorwegianBokmal
N Portuguese
N Spanish
N Turkish
N DSA
N EC
N Engine
N Engines
▶N enshrined
▶N svgSanitize
N data
N ElementReference
N Exceptions
▶N FG
▶N ASN1
N Composite
N Exception
N Universal
N Utility
▶N X509
N CSR
N SAN
▶N Fig
N Link
N FileNotFoundException
N Functions
N GMP
N Hash
▶N Http
N Message
N IdnaConvert
N InconsistentSetupException
N InsufficientSetupException
▶N Joomla
N Admin
N Administrator
N API
N Api
▶N Application
N Controller
N Event
N Exception
N Web
▶N Archive
N Exception
▶N Authentication
N Exception
N Password
N Strategies
N Cli
▶N CMS
▶N Access
N Exception
N Adapter
▶N Application
▶N CLI
▶N Output
N Processor
N Exception
N Association
▶N Authentication
N Password
N Autoload
N Button
▶N Cache
N Controller
N Exception
N Storage
▶N Captcha
N Google
N Categories
N Changelog
N Client
▶N Component
N Exception
▶N Router
N Rules
▶N Console
N Loader
▶N Crypt
N Cipher
N Date
N Dispatcher
▶N Document
N Feed
N Opensearch
▶N Renderer
N Feed
N Html
N Editor
▶N Encrypt
N AES
N Environment
▶N Error
N JsonApi
N Renderer
▶N Event
N Model
N MultiFactor
▶N Plugin
▶N System
N Webauthn
N QuickIcon
N Result
N Table
N View
N WebAsset
N Workflow
N Exception
▶N Extension
▶N Service
N Provider
▶N Feed
▶N Parser
N Rss
N Fields
▶N Filesystem
N Streams
N Support
N Filter
▶N Form
N Field
N Filter
N Rule
N Help
N Helper
▶N HTML
N Helpers
▶N Http
N Transport
▶N Image
N Exception
N Filter
N Input
▶N Installation
N Application
N Controller
▶N Error
N Renderer
▶N Form
▶N Field
N Installation
N Rule
N Helper
N Model
N Response
N Router
▶N Service
N Provider
▶N View
N Error
N Preinstall
N Remove
N Setup
▶N Installer
N Adapter
N Manifest
N Language
N Layout
▶N Log
N Logger
▶N Mail
N Exception
N Menu
N Microdata
▶N MVC
▶N Controller
N Exception
N Factory
N Model
▶N View
N Event
N Object
N Pagination
N Pathway
N Plugin
N Profiler
N Response
▶N Router
N Exception
▶N Schema
N ChangeItem
▶N Serializer
N Events
▶N Service
N Provider
▶N Session
N EventListener
N Exception
N Storage
N String
N Table
N Tag
▶N Toolbar
N Button
N Tree
N UCM
▶N Updater
N Adapter
N Uri
N User
N Utility
N Versioning
▶N WebAsset
N AssetItem
N Exception
N Workflow
▶N Component
▶N Actionlogs
▶N Administrator
N Controller
N Field
N Helper
N Model
N Plugin
▶N View
N Actionlogs
▶N Admin
▶N Administrator
N Controller
N Dispatcher
N Extension
N Model
▶N Service
N HTML
▶N View
N Help
N Sysinfo
▶N Associations
▶N Administrator
N Controller
N Dispatcher
▶N Field
N Modal
N Helper
N Model
▶N View
N Association
N Associations
▶N Banners
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N Html
N Table
▶N View
N Banner
N Banners
N Client
N Clients
N Download
N Tracks
▶N Api
N Controller
▶N View
N Banners
N Clients
▶N Site
N Controller
N Helper
N Model
N Service
▶N Cache
▶N Administrator
N Controller
N Model
▶N View
N Cache
▶N Categories
▶N Administrator
N Controller
N Dispatcher
N Extension
▶N Field
N Modal
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Categories
N Category
▶N Api
N Controller
▶N View
N Categories
▶N Checkin
▶N Administrator
N Controller
N Model
▶N View
N Checkin
▶N Config
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N View
N Application
N Component
▶N Api
N Controller
▶N View
N Application
N Component
▶N Site
N Controller
N Dispatcher
N Model
N Service
▶N View
N Config
N Modules
N Templates
▶N Contact
▶N Administrator
N Controller
N Extension
▶N Field
N Modal
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Contact
N Contacts
▶N Api
N Controller
N Serializer
▶N View
N Contacts
▶N Site
N Controller
N Dispatcher
N Helper
N Model
N Rule
N Service
▶N View
N Categories
N Category
N Contact
N Featured
N Form
▶N Content
▶N Administrator
N Controller
▶N Event
N Model
N Extension
▶N Field
N Modal
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Article
N Articles
N Featured
▶N Api
N Controller
N Helper
N Serializer
▶N View
N Articles
▶N Site
N Controller
N Dispatcher
N Helper
N Model
N Service
▶N View
N Archive
N Article
N Categories
N Category
N Featured
N Form
▶N Contenthistory
▶N Administrator
N Controller
N Dispatcher
N Helper
N Model
▶N View
N Compare
N History
N Preview
▶N Api
N Controller
▶N View
N History
▶N Site
N Controller
N Dispatcher
▶N Cpanel
▶N Administrator
N Controller
N Dispatcher
▶N View
N Cpanel
▶N Fields
▶N Administrator
N Controller
N Dispatcher
N Extension
N Field
N Helper
N Model
N Plugin
N Table
▶N View
N Field
N Fields
N Group
N Groups
▶N Api
N Controller
▶N View
N Fields
N Groups
▶N Site
N Controller
N Dispatcher
▶N Finder
▶N Administrator
N Controller
N Extension
N Field
N Helper
▶N Indexer
N Language
N Parser
N Model
N Response
▶N Service
N HTML
N Table
▶N View
N Filter
N Filters
N Index
N Indexer
N Maps
N Searches
N Statistics
▶N Site
N Controller
N Helper
N Model
N Service
▶N View
N Search
▶N Installer
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Database
N Discover
N Install
N Installer
N Languages
N Manage
N Update
N Updatesite
N Updatesites
N Warnings
▶N Api
N Controller
▶N View
N Manage
▶N Joomlaupdate
▶N Administrator
N Controller
N Dispatcher
N Model
▶N View
N Joomlaupdate
N Update
N Upload
▶N Languages
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
▶N View
N Installed
N Language
N Languages
N Multilangstatus
N Override
N Overrides
▶N Api
N Controller
▶N View
N Languages
N Overrides
N Strings
▶N Login
▶N Administrator
N Controller
N Dispatcher
N Model
▶N View
N Login
▶N Mails
▶N Administrator
N Controller
N Helper
N Model
N Table
▶N View
N Template
N Templates
▶N Media
▶N Administrator
N Adapter
N Controller
N Dispatcher
N Event
N Exception
N Model
N Plugin
N Provider
▶N View
N File
N Media
▶N Api
N Controller
N Model
▶N View
N Adapters
N Media
▶N Site
N Dispatcher
▶N Menus
▶N Administrator
N Controller
N Extension
▶N Field
N Modal
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Item
N Items
N Menu
N Menus
N Menutypes
▶N Api
N Controller
▶N View
N Items
N Menus
▶N Site
N Dispatcher
▶N Messages
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Config
N Message
N Messages
▶N Api
N Controller
▶N View
N Messages
▶N Modules
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
▶N View
N Module
N Modules
N Select
▶N Api
N Controller
▶N View
N Modules
▶N Site
N Controller
N Dispatcher
▶N Newsfeeds
▶N Administrator
N Controller
N Extension
▶N Field
N Modal
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Newsfeed
N Newsfeeds
▶N Api
N Controller
N Serializer
▶N View
N Feeds
▶N Site
N Controller
N Helper
N Model
N Service
▶N View
N Categories
N Category
N Newsfeed
▶N Plugins
▶N Administrator
N Controller
N Field
N Helper
N Model
▶N View
N Plugin
N Plugins
▶N Api
N Controller
▶N View
N Plugins
▶N Postinstall
▶N Administrator
N Controller
N Helper
N Model
▶N View
N Messages
▶N Privacy
▶N Administrator
N Controller
N Dispatcher
N Export
N Extension
N Field
N Helper
N Model
N Plugin
N Removal
▶N Service
N HTML
N Table
▶N View
N Capabilities
N Consents
N Export
N Request
N Requests
▶N Api
N Controller
▶N View
N Consents
N Requests
▶N Site
N Controller
N Model
N Service
▶N View
N Confirm
N Remind
N Request
▶N Redirect
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Link
N Links
▶N Api
N Controller
▶N View
N Redirect
▶N Scheduler
▶N Administrator
N Controller
N Event
N Extension
N Field
N Helper
N Model
N Rule
N Scheduler
N Table
N Task
N Traits
▶N View
N Select
N Task
N Tasks
▶N Tags
▶N Administrator
N Controller
N Extension
N Model
N Table
▶N View
N Tag
N Tags
▶N Api
N Controller
▶N View
N Tags
▶N Site
N Controller
N Helper
N Model
N Service
▶N View
N Tag
N Tags
▶N Templates
▶N Administrator
N Controller
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Style
N Styles
N Template
N Templates
▶N Api
N Controller
▶N View
N Styles
▶N Users
▶N Administrator
N Controller
N DataShape
N Dispatcher
N Extension
N Field
N Helper
N Model
▶N Service
N HTML
N Table
▶N View
N Captive
N Debuggroup
N Debuguser
N Group
N Groups
N Level
N Levels
N Mail
N Method
N Methods
N Note
N Notes
N User
N Users
▶N Api
N Controller
▶N View
N Groups
N Levels
N Users
▶N Site
N Controller
N Model
N Rule
N Service
▶N View
N Captive
N Login
N Method
N Methods
N Profile
N Registration
N Remind
N Reset
▶N Workflow
▶N Administrator
N Controller
N Dispatcher
N Field
N Helper
N Model
N Table
▶N View
N Stage
N Stages
N Transition
N Transitions
N Workflow
N Workflows
▶N Wrapper
▶N Administrator
N Extension
▶N Site
N Controller
N Service
▶N View
N Wrapper
▶N Console
N Command
N Descriptor
N Event
N Exception
N Helper
N Loader
▶N Crypt
N Cipher
N Exception
N Data
▶N Database
N Command
N Event
N Exception
N Monitor
N Mysql
N Mysqli
N Pdo
N Pgsql
N Query
N Service
N Sqlazure
N Sqlite
N Sqlsrv
▶N DI
N Exception
▶N Event
N Command
▶N Filesystem
N Clients
N Exception
N Stream
N Support
N Filter
▶N Http
N Exception
N Transport
N Input
N Installation
N Language
N Ldap
N Menus
▶N Module
▶N ArticlesArchive
▶N Site
N Helper
▶N ArticlesCategories
▶N Site
N Helper
▶N ArticlesCategory
▶N Site
N Helper
▶N ArticlesLatest
▶N Site
N Dispatcher
N Helper
▶N ArticlesNews
▶N Site
N Dispatcher
N Helper
▶N ArticlesPopular
▶N Site
N Helper
▶N Banners
▶N Site
N Helper
▶N Breadcrumbs
▶N Site
N Helper
▶N Feed
▶N Administrator
N Helper
▶N Site
N Helper
▶N Finder
▶N Site
N Helper
▶N Languages
▶N Site
N Helper
▶N Latest
▶N Administrator
N Helper
▶N LatestActions
▶N Administrator
N Helper
▶N Logged
▶N Administrator
N Helper
▶N Login
▶N Administrator
N Helper
▶N Site
N Helper
▶N Menu
▶N Administrator
N Menu
▶N Site
N Helper
▶N Popular
▶N Administrator
N Helper
▶N PrivacyDashboard
▶N Administrator
N Helper
▶N PrivacyStatus
▶N Administrator
N Helper
▶N Quickicon
▶N Administrator
N Dispatcher
N Event
N Helper
▶N RandomImage
▶N Site
N Helper
▶N RelatedItems
▶N Site
N Helper
▶N Sampledata
▶N Administrator
N Helper
▶N Stats
▶N Site
N Helper
▶N StatsAdmin
▶N Administrator
N Helper
▶N Submenu
▶N Administrator
N Menu
▶N Syndicate
▶N Site
N Helper
▶N TagsPopular
▶N Site
N Helper
▶N TagsSimilar
▶N Site
N Helper
▶N UsersLatest
▶N Site
N Helper
▶N Version
▶N Administrator
N Helper
▶N Whosonline
▶N Site
N Helper
▶N Wrapper
▶N Site
N Helper
N Modules
N OAuth1
N OAuth2
▶N Plugin
▶N Actionlog
▶N Joomla
N Extension
▶N ApiAuthentication
▶N Basic
N Extension
▶N Token
N Extension
▶N Behaviour
▶N Taggable
N Extension
▶N Versionable
N Extension
▶N Content
▶N ConfirmConsent
N Field
▶N Editors
▶N CodeMirror
N Field
▶N TinyMCE
N Field
N PluginTraits
▶N Filesystem
▶N Local
N Adapter
▶N Multifactorauth
▶N Email
N Extension
▶N Fixed
N Extension
▶N Totp
N Extension
▶N Webauthn
N Extension
N Helper
N Hotfix
▶N Yubikey
N Extension
▶N Quickicon
▶N Joomlaupdate
N Extension
▶N System
▶N Cache
N Extension
▶N Debug
N DataCollector
N Storage
▶N PrivacyConsent
N Field
▶N Shortcut
N Extension
▶N Stats
N Field
▶N Webauthn
N Extension
N Field
N Hotfix
N PluginTraits
▶N Task
▶N Checkfiles
N Extension
▶N DemoTasks
N Extension
▶N Requests
N Extension
▶N SiteStatus
N Extension
▶N User
▶N Profile
N Field
▶N Terms
N Field
▶N Token
N Field
N Plugins
N Privacy
N Redirect
▶N Registry
N Format
▶N Router
N Command
N Exception
▶N Session
N Command
N Exception
N Handler
N Storage
N Validator
N Site
N String
N Tags
N Templates
N Uri
N Users
N Utilities
▶N Jose
▶N Component
▶N Core
N Util
▶N Signature
▶N Algorithm
N Util
N Serializer
N KoblitzPrime
▶N Laminas
▶N Diactoros
N Exception
N Request
N Response
N ZendFrameworkBridge
▶N Lcobucci
N Clock
▶N JWT
N Claim
N Encoding
N Parsing
▶N Signer
N Ecdsa
N Hmac
N Key
N Rsa
N Token
▶N Validation
N Constraint
N Math
▶N Negotiation
N Exception
N NoKeyLoadedException
N NoSupportedAlgorithmsException
▶N Nyholm
▶N Psr7
N Factory
▶N ParagonIE
N ConstantTime
▶N Sodium
▶N Core
N ChaCha20
▶N Curve25519
N Ge
N Poly1305
N PHP
N PHP32
▶N PHPMailer
N PHPMailer
▶N phpseclib3
▶N Common
N Functions
▶N Crypt
▶N Common
▶N Formats
N Keys
N Signature
N Traits
▶N DH
▶N Formats
N Keys
▶N DSA
▶N Formats
N Keys
N Signature
▶N EC
N BaseCurves
N Curves
▶N Formats
N Keys
N Signature
▶N RSA
▶N Formats
N Keys
N Exception
▶N File
▶N ASN1
N Maps
▶N Math
▶N BigInteger
▶N Engines
▶N BCMath
N Reductions
N GMP
▶N PHP
N Reductions
N BinaryField
▶N Common
N FiniteField
N PrimeField
▶N Net
N SFTP
▶N System
▶N SSH
N Agent
▶N Common
N Traits
N Prime
▶N Psr
N Container
▶N Http
N Client
N Message
N Link
N Log
N PublicKeyLoader
▶N Ramsey
▶N Uuid
N Builder
N Codec
▶N Converter
N Number
N Time
N Exception
N Generator
▶N Provider
N Node
N Time
N Random
N RC2
N RC4
▶N ReCaptcha
N RequestMethod
N Rijndael
N RSA
N Salsa20
N SFTP
N Sodium
N SSH
N SSH2
N StreamCipher
▶N Symfony
▶N Component
▶N Console
N Attribute
N CI
N Command
N CommandLoader
▶N Completion
N Output
N DependencyInjection
N Descriptor
N Event
N EventListener
N Exception
N Formatter
N Helper
N Input
N Logger
N Output
N Question
N SignalRegistry
N Style
▶N Tester
N Constraint
▶N ErrorHandler
N Error
N ErrorEnhancer
N ErrorRenderer
N Exception
N Internal
▶N Ldap
▶N Adapter
N ExtLdap
N Exception
N Security
▶N OptionsResolver
N Debug
N Exception
▶N String
N Exception
N Inflector
N Slugger
▶N VarDumper
N Caster
N Cloner
▶N Command
N Descriptor
▶N Dumper
N ContextProvider
N Exception
N Server
N Test
▶N WebLink
N EventListener
▶N Yaml
N Command
N Exception
N Tag
▶N Contracts
▶N Service
N Attribute
N Test
▶N Polyfill
N Ctype
N Iconv
▶N Intl
N Grapheme
N Normalizer
N Mbstring
N Php72
N Php73
N Php80
▶N Tobscure
▶N JsonApi
▶N Exception
N Handler
N TripleDES
N Twofish
▶N TYPO3
▶N PharStreamWrapper
N Interceptor
N Phar
N Resolver
N UnableToConnectException
N UnsupportedAlgorithmException
N UnsupportedCurveException
N UnsupportedFormatException
N UnsupportedOperationException
N utf8
▶N voku
N helper
▶N Wamania
▶N Snowball
N Stemmer
▶N Webauthn
N AttestationStatement
N AuthenticationExtensions
N MetadataService
N TokenBinding
N TrustPath
N Util
▶N Webmozart
N Assert
N X509
▶N Zend
N Diactoros


Joomla CMS: Référence de l'espace de nommage AES

Référence de l'espace de nommage AES

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2008 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of AES. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Algo26

Espaces de nommage
Référence de l'espace de nommage Algo26

Espaces de nommage

IdnaConvert


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert

  • Algo26
  • IdnaConvert
Espaces de nommage | Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert

Espaces de nommage

EncodingHelper
Exception
NamePrep
Punycode
TranscodeUnicode

Structures de données

class | AbstractIdnaConvert
interface | IdnaConvertInterface
class | ToIdn
class | ToUnicode


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert\EncodingHelper

  • Algo26
  • IdnaConvert
  • EncodingHelper
Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert\EncodingHelper

Structures de données

interface | EncodingHelperInterface
class | FromUtf8
class | ToUtf8


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert\Exception

  • Algo26
  • IdnaConvert
  • Exception
Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert\Exception

Structures de données

class | AlreadyPunycodeException
class | InvalidCharacterException
class | InvalidIdnVersionException


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert\NamePrep

  • Algo26
  • IdnaConvert
  • NamePrep
Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert\NamePrep

Structures de données

class | NamePrep
class | NamePrepData2003
class | NamePrepData2008
interface | NamePrepDataInterface
interface | NamePrepInterface


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert\Punycode

  • Algo26
  • IdnaConvert
  • Punycode
Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert\Punycode

Structures de données

class | AbstractPunycode
class | FromPunycode
interface | PunycodeInterface
class | ToPunycode


Joomla CMS: Référence de l'espace de nommage Algo26\IdnaConvert\TranscodeUnicode

  • Algo26
  • IdnaConvert
  • TranscodeUnicode
Structures de données
Référence de l'espace de nommage Algo26\IdnaConvert\TranscodeUnicode

Structures de données

class | TranscodeUnicode
interface | TranscodeUnicodeInterface


Joomla CMS: Référence de l'espace de nommage ANSI

Référence de l'espace de nommage ANSI

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2012 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP ANSI Decoder Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage ASN1

Référence de l'espace de nommage ASN1

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2012 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License ASN.1 Raw Element An ASN.1 ANY mapping will return an ASN1 object. Use of this object will also bypass the normal encoding rules in ASN1::encodeDER() Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net AccessDescription Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AdministrationDomainName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AlgorithmIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AnotherName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Attribute Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Attributes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AttributeType Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AttributeTypeAndValue Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AttributeValue Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AuthorityInfoAccessSyntax Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public AuthorityKeyIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public BaseDistance Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public BasicConstraints Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public BuiltInDomainDefinedAttribute Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public BuiltInDomainDefinedAttributes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public BuiltInStandardAttributes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Certificate Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificateIssuer Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificateList Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificatePolicies Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificateSerialNumber Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificationRequest Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertificationRequestInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CertPolicyId Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Characteristic_two Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CountryName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CPSuri Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CRLDistributionPoints Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CRLNumber Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public CRLReason Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Curve Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DHParameter Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DigestInfo from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DirectoryString Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DisplayText Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DistributionPoint Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DistributionPointName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSAParams Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSAPrivateKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSAPublicKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DssSigValue Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EcdsaSigValue Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ECParameters ECParameters ::= CHOICE { namedCurve OBJECT IDENTIFIER – implicitCurve NULL – specifiedCurve SpecifiedECDomain } – implicitCurve and specifiedCurve MUST NOT be used in PKIX. – Details for SpecifiedECDomain can be found in [X9.62]. – Any future additions to this CHOICE should be coordinated – with ANSI X9. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ECPoint Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ECPrivateKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EDIPartyName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EncryptedData Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EncryptedPrivateKeyInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Extension A certificate using system MUST reject the certificate if it encounters a critical extension it does not recognize; however, a non-critical extension may be ignored if it is not recognized. http://tools.ietf.org/html/rfc5280#section-4.2 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ExtensionAttribute Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ExtensionAttributes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Extensions Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ExtKeyUsageSyntax Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public FieldElement Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public FieldID Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public GeneralName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public GeneralNames Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public GeneralSubtree Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public GeneralSubtrees Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public HashAglorithm Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public HoldInstructionCode Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public InvalidityDate Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public IssuerAltName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public IssuingDistributionPoint Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public KeyIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public KeyPurposeId Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public KeyUsage Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public MaskGenAglorithm Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Name Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public NameConstraints Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public netscape_ca_policy_url Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public netscape_cert_type mapping is from http://www.mozilla.org/projects/security/pki/nss/tech-notes/tn3.html Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public netscape_comment Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public NetworkAddress Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public NoticeReference Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public NumericUserIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OneAsymmetricKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ORAddress Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OrganizationalUnitNames Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OrganizationName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OtherPrimeInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OtherPrimeInfos Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PBEParameter from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PBES2params from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PBKDF2params from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PBMAC1params from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Pentanomial Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PersonalName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS9String Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PolicyInformation Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PolicyMappings Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PolicyQualifierId Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PolicyQualifierInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PostalAddress Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Prime_p Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PrivateDomainName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PrivateKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PrivateKeyInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PrivateKeyUsagePeriod Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PublicKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PublicKeyAndChallenge Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PublicKeyInfo this format is not formally defined anywhere but is none-the-less the form you get when you do "openssl rsa -in private.pem -outform PEM -pubout" Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RC2CBCParameter from https://tools.ietf.org/html/rfc2898#appendix-A.3 Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RDNSequence In practice, RDNs containing multiple name-value pairs (called "multivalued RDNs") are rare, but they can be useful at times when either there is no unique attribute in the entry or you want to ensure that the entry's DN contains some useful identifying information. https://www.opends.org/wiki/page/DefinitionRelativeDistinguishedName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ReasonFlags Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RelativeDistinguishedName In practice, RDNs containing multiple name-value pairs (called "multivalued RDNs") are rare, but they can be useful at times when either there is no unique attribute in the entry or you want to ensure that the entry's DN contains some useful identifying information. https://www.opends.org/wiki/page/DefinitionRelativeDistinguishedName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RevokedCertificate Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RSAPrivateKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RSAPublicKey Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public RSASSA_PSS_params Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SignedPublicKeyAndChallenge Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SpecifiedECDomain Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SubjectAltName Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SubjectDirectoryAttributes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SubjectInfoAccessSyntax Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SubjectPublicKeyInfo Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public TBSCertificate Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public TBSCertList Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public TerminalIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Time Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Trinomial Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public UniqueIdentifier Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public UserNotice Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Validity Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Pure-PHP ASN.1 Parser Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Assert

Structures de données | Fonctions
Référence de l'espace de nommage Assert

Structures de données

class | Assert
class | Assertion
class | AssertionChain
interface | AssertionFailedException
class | InvalidArgumentException
class | LazyAssertion
class | LazyAssertionException

Fonctions

that ($value, $defaultMessage=null, string $defaultPropertyPath=null)
thatAll ($values, $defaultMessage=null, string $defaultPropertyPath=null)
thatNullOr ($value, $defaultMessage=null, string $defaultPropertyPath=null)
lazy ()

Description détaillée

Assert

LICENSE

This source file is subject to the MIT license that is bundled with this package in the file LICENSE.txt. If you did not receive a copy of the license and are unable to obtain it through the world-wide-web, please send an email to konta.nosp@m.kt@b.nosp@m.eberl.nosp@m.ei.d.nosp@m.e so I can send you a copy immediately.

Documentation des fonctions

◆ lazy()

Assert\lazy ( )

Create a lazy assertion object.

Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

Référencé par OptionsResolver\clear(), OptionsResolver\offsetGet(), OptionsResolver\remove(), et OptionsResolver\setDefault().

◆ that()

Assert\that | ( |  | $value,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

Références $value.

Référencé par ServerDumpCommand\configure(), LazyAssertion\that(), thatAll(), et thatNullOr().

◆ thatAll()

Assert\thatAll | ( |  | $values,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |

Start validation on a set of values, returns AssertionChain.

Paramètres
mixed | $values
string | callable | null | $defaultMessage
string | $defaultPropertyPath
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

◆ thatNullOr()

Assert\thatNullOr | ( |  | $value,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |

Start validation and allow NULL, returns AssertionChain.

Paramètres
mixed | $value
string | callable | null | $defaultMessage
string | $defaultPropertyPath
Obsolète:
In favour of Assert::thatNullOr($value, $defaultMessage = null, $defaultPropertyPath = null)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

Références $value.


Joomla CMS: Référence de l'espace de nommage AsymmetricKey

Référence de l'espace de nommage AsymmetricKey

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Base Class for all asymmetric cipher classes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage BadConfigurationException

Référence de l'espace de nommage BadConfigurationException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License BadConfigurationException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage BadDecryptionException

Référence de l'espace de nommage BadDecryptionException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License BadDecryptionException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage BadModeException

Référence de l'espace de nommage BadModeException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License BadModeException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Base

Référence de l'espace de nommage Base

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Base Class for all * cipher classes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m


Joomla CMS: Référence de l'espace de nommage Base64Url

Structures de données
Référence de l'espace de nommage Base64Url

Structures de données

class Base64Url


Joomla CMS: Référence de l'espace de nommage BCMath

Référence de l'espace de nommage BCMath

Description détaillée

Built-In BCMath Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

OpenSSL Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

BCMath Engine.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage bcmath_compat

Structures de données
Référence de l'espace de nommage bcmath_compat

Structures de données

class BCMath

Description détaillée

BCMath Emulation Class

PHP version 5 and 7

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2019 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License


Joomla CMS: Référence de l'espace de nommage BigInteger

Référence de l'espace de nommage BigInteger

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2017 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2017 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP arbitrary precision integer arithmetic library. Supports base-2, base-10, base-16, and base-256 numbers. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Binary

Référence de l'espace de nommage Binary

Description détaillée

Curves over y^2 + x*y = x^3 + a*x^2 + b

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage BlockCipher

Référence de l'espace de nommage BlockCipher

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Base Class for all block cipher classes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Blowfish

Référence de l'espace de nommage Blowfish

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of Blowfish. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m public


Joomla CMS: Référence de l'espace de nommage Brick

Espaces de nommage
Référence de l'espace de nommage Brick

Espaces de nommage

Math


Joomla CMS: Référence de l'espace de nommage Brick\Math

  • Brick
  • Math
Espaces de nommage | Structures de données
Référence de l'espace de nommage Brick\Math

Espaces de nommage

Exception
Internal

Structures de données

class | BigDecimal
class | BigInteger
class | BigNumber
class | BigRational
class | RoundingMode


Joomla CMS: Référence de l'espace de nommage Brick\Math\Exception

  • Brick
  • Math
  • Exception
Structures de données
Référence de l'espace de nommage Brick\Math\Exception

Structures de données

class | DivisionByZeroException
class | IntegerOverflowException
class | MathException
class | NegativeNumberException
class | NumberFormatException
class | RoundingNecessaryException


Joomla CMS: Référence de l'espace de nommage Brick\Math\Internal

  • Brick
  • Math
  • Internal
Espaces de nommage | Structures de données
Référence de l'espace de nommage Brick\Math\Internal

Espaces de nommage

Calculator

Structures de données

class Calculator


Joomla CMS: Référence de l'espace de nommage Brick\Math\Internal\Calculator

  • Brick
  • Math
  • Internal
  • Calculator
Structures de données
Référence de l'espace de nommage Brick\Math\Internal\Calculator

Structures de données

class | BcMathCalculator
class | GmpCalculator
class | NativeCalculator


Joomla CMS: Référence de l'espace de nommage CBOR

Espaces de nommage | Structures de données
Référence de l'espace de nommage CBOR

Espaces de nommage

OtherObject
Tag

Structures de données

class | AbstractCBORObject
class | ByteStringObject
class | ByteStringWithChunkObject
interface | CBORObject
class | Decoder
class | InfiniteListObject
class | InfiniteMapObject
class | LengthCalculator
class | ListObject
class | MapItem
class | MapObject
class | OtherObject
class | SignedIntegerObject
interface | Stream
class | StringStream
class | TagObject
class | TextStringObject
class | TextStringWithChunkObject
class | UnsignedIntegerObject
class | Utils


Joomla CMS: Référence de l'espace de nommage CBOR\OtherObject

  • CBOR
  • OtherObject
Structures de données
Référence de l'espace de nommage CBOR\OtherObject

Structures de données

class | BreakObject
class | DoublePrecisionFloatObject
class | FalseObject
class | GenericObject
class | HalfPrecisionFloatObject
class | NullObject
class | OtherObjectManager
class | SimpleObject
class | SinglePrecisionFloatObject
class | TrueObject
class | UndefinedObject


Joomla CMS: Référence de l'espace de nommage CBOR\Tag

  • CBOR
  • Tag
Structures de données
Référence de l'espace de nommage CBOR\Tag

Structures de données

class | Base16EncodingTag
class | Base64EncodingTag
class | Base64UrlEncodingTag
class | BigFloatTag
class | DecimalFractionTag
class | EpochTag
class | GenericTag
class | NegativeBigIntegerTag
class | PositiveBigIntegerTag
class | TagObjectManager
class | TimestampTag


Joomla CMS: Référence de l'espace de nommage ChaCha20

Référence de l'espace de nommage ChaCha20

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2019 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of ChaCha20. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Common

Référence de l'espace de nommage Common

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License OpenSSH Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net PuTTY Formatted Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Raw Signature Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2009 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net PrivateKey interface Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PublicKey interface Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Fingerprint Trait for Private Keys Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Password Protected Trait for Private Keys Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public ASN1 Signature Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public SSH2 Signature Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PublicKeyLoader Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Composer

Espaces de nommage | Structures de données
Référence de l'espace de nommage Composer

Espaces de nommage

Autoload
CaBundle

Structures de données

class InstalledVersions


Joomla CMS: Référence de l'espace de nommage Composer\Autoload

  • Composer
  • Autoload
Structures de données | Fonctions
Référence de l'espace de nommage Composer\Autoload

Structures de données

class | ClassLoader
class | ComposerStaticInit2399d40fc48ada3450e844df0430bf2f

Fonctions

includeFile ($file)

Documentation des fonctions

◆ includeFile()

Composer\Autoload\includeFile ( $file )
private

Scope isolated include.

Prevents access to $this/self from included files.

Paramètres
string $file
Renvoie
void

Référencé par ClassLoader\loadClass().


Joomla CMS: Référence de l'espace de nommage Composer\CaBundle

  • Composer
  • CaBundle
Structures de données
Référence de l'espace de nommage Composer\CaBundle

Structures de données

class CaBundle


Joomla CMS: Référence de l'espace de nommage ConnectionClosedException

Référence de l'espace de nommage ConnectionClosedException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License ConnectionClosedException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Cose

Espaces de nommage | Structures de données
Référence de l'espace de nommage Cose

Espaces de nommage

Algorithm
Key

Structures de données

class | Algorithms
class | Verifier


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm

  • Cose
  • Algorithm
Espaces de nommage | Structures de données
Référence de l'espace de nommage Cose\Algorithm

Espaces de nommage

Mac
Signature

Structures de données

interface | Algorithm
class | Manager
class | ManagerFactory


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm\Mac

  • Cose
  • Algorithm
  • Mac
Structures de données
Référence de l'espace de nommage Cose\Algorithm\Mac

Structures de données

class | Hmac
class | HS256
class | HS256Truncated64
class | HS384
class | HS512
interface | Mac


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm\Signature

  • Cose
  • Algorithm
  • Signature
Espaces de nommage | Structures de données
Référence de l'espace de nommage Cose\Algorithm\Signature

Espaces de nommage

ECDSA
EdDSA
RSA

Structures de données

interface Signature


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm\Signature\ECDSA

  • Cose
  • Algorithm
  • Signature
  • ECDSA
Structures de données
Référence de l'espace de nommage Cose\Algorithm\Signature\ECDSA

Structures de données

class | ECDSA
class | ECSignature
class | ES256
class | ES256K
class | ES384
class | ES512


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm\Signature\EdDSA

  • Cose
  • Algorithm
  • Signature
  • EdDSA
Structures de données
Référence de l'espace de nommage Cose\Algorithm\Signature\EdDSA

Structures de données

class | Ed25519
class | ED256
class | ED512
class | EdDSA


Joomla CMS: Référence de l'espace de nommage Cose\Algorithm\Signature\RSA

  • Cose
  • Algorithm
  • Signature
  • RSA
Structures de données
Référence de l'espace de nommage Cose\Algorithm\Signature\RSA

Structures de données

class | PS256
class | PS384
class | PS512
class | PSSRSA
class | RS1
class | RS256
class | RS384
class | RS512
class | RSA


Joomla CMS: Référence de l'espace de nommage Cose\Key

  • Cose
  • Key
Structures de données
Référence de l'espace de nommage Cose\Key

Structures de données

class | Ec2Key
class | Key
class | OkpKey
class | RsaKey
class | SymmetricKey


Joomla CMS: Référence de l'espace de nommage Cron

Structures de données
Référence de l'espace de nommage Cron

Structures de données

class | AbstractField
class | CronExpression
class | DayOfMonthField
class | DayOfWeekField
class | FieldFactory
interface | FieldFactoryInterface
interface | FieldInterface
class | HoursField
class | MinutesField
class | MonthField


Joomla CMS: Référence de l'espace de nommage DebugBar

Espaces de nommage | Structures de données
Référence de l'espace de nommage DebugBar

Espaces de nommage

Bridge
DataCollector
DataFormatter
Storage

Structures de données

class | DebugBar
class | DebugBarException
interface | HttpDriverInterface
class | JavascriptRenderer
class | OpenHandler
class | PhpHttpDriver
class | RequestIdGenerator
interface | RequestIdGeneratorInterface
class | StandardDebugBar

Description détaillée

Class TimeableTwigExtensionProfiler

Extends Twig_Extension_Profiler to add rendering times to the TimeDataCollector


Joomla CMS: Référence de l'espace de nommage DebugBar\Bridge

  • DebugBar
  • Bridge
Espaces de nommage | Structures de données
Référence de l'espace de nommage DebugBar\Bridge

Espaces de nommage

SwiftMailer
Twig

Structures de données

class | CacheCacheCollector
class | DoctrineCollector
class | MonologCollector
class | NamespacedTwigProfileCollector
class | Propel2Collector
class | PropelCollector
class | SlimCollector
class | TwigProfileCollector


Joomla CMS: Référence de l'espace de nommage DebugBar\Bridge\SwiftMailer

  • DebugBar
  • Bridge
  • SwiftMailer
Structures de données
Référence de l'espace de nommage DebugBar\Bridge\SwiftMailer

Structures de données

class | SwiftLogCollector
class | SwiftMailCollector


Joomla CMS: Référence de l'espace de nommage DebugBar\Bridge\Twig

  • DebugBar
  • Bridge
  • Twig
Structures de données
Référence de l'espace de nommage DebugBar\Bridge\Twig

Structures de données

class | TimeableTwigExtensionProfiler
class | TraceableTwigEnvironment
class | TraceableTwigTemplate
class | TwigCollector


Joomla CMS: Référence de l'espace de nommage DebugBar\DataCollector

  • DebugBar
  • DataCollector
Espaces de nommage | Structures de données
Référence de l'espace de nommage DebugBar\DataCollector

Espaces de nommage

PDO

Structures de données

class | AggregatedCollector
interface | AssetProvider
class | ConfigCollector
class | DataCollector
interface | DataCollectorInterface
class | ExceptionsCollector
class | LocalizationCollector
class | MemoryCollector
interface | MessagesAggregateInterface
class | MessagesCollector
class | PhpInfoCollector
interface | Renderable
class | RequestDataCollector
class | TimeDataCollector


Joomla CMS: Référence de l'espace de nommage DebugBar\DataCollector\PDO

  • DebugBar
  • DataCollector
  • PDO
Structures de données
Référence de l'espace de nommage DebugBar\DataCollector\PDO

Structures de données

class | PDOCollector
class | TraceablePDO
class | TraceablePDOStatement
class | TracedStatement


Joomla CMS: Référence de l'espace de nommage DebugBar\DataFormatter

  • DebugBar
  • DataFormatter
Espaces de nommage | Structures de données
Référence de l'espace de nommage DebugBar\DataFormatter

Espaces de nommage

VarDumper

Structures de données

class | DataFormatter
interface | DataFormatterInterface
class | DebugBarVarDumper


Joomla CMS: Référence de l'espace de nommage DebugBar\DataFormatter\VarDumper

  • DebugBar
  • DataFormatter
  • VarDumper
Structures de données
Référence de l'espace de nommage DebugBar\DataFormatter\VarDumper

Structures de données

class | DebugBarHtmlDumper
class | SeekingData


Joomla CMS: Référence de l'espace de nommage DebugBar\Storage

  • DebugBar
  • Storage
Structures de données
Référence de l'espace de nommage DebugBar\Storage

Structures de données

class | FileStorage
class | MemcachedStorage
class | PdoStorage
class | RedisStorage
interface | StorageInterface


Joomla CMS: Référence de l'espace de nommage Defuse

Espaces de nommage
Référence de l'espace de nommage Defuse

Espaces de nommage

Crypto

Description détaillée

Class DerivedKeys


Joomla CMS: Référence de l'espace de nommage Defuse\Crypto

  • Defuse
  • Crypto
Espaces de nommage | Structures de données
Référence de l'espace de nommage Defuse\Crypto

Espaces de nommage

Exception

Structures de données

class | Core
class | Crypto
class | DerivedKeys
class | Encoding
class | File
class | Key
class | KeyOrPassword
class | KeyProtectedByPassword
class | RuntimeTests


Joomla CMS: Référence de l'espace de nommage Defuse\Crypto\Exception

  • Defuse
  • Crypto
  • Exception
Structures de données
Référence de l'espace de nommage Defuse\Crypto\Exception

Structures de données

class | BadFormatException
class | CryptoException
class | EnvironmentIsBrokenException
class | IOException
class | WrongKeyOrModifiedCiphertextException


Joomla CMS: Référence de l'espace de nommage DES

Référence de l'espace de nommage DES

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of DES. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage DH

Référence de l'espace de nommage DH

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License "PKCS1" Formatted DH Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted DH Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DH Parameters Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DH Private Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DH Public Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Pure-PHP (EC)DH implementation Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Doctrine

Espaces de nommage
Référence de l'espace de nommage Doctrine

Espaces de nommage

Common
Inflector


Joomla CMS: Référence de l'espace de nommage Doctrine\Common

  • Doctrine
  • Common
Espaces de nommage
Référence de l'espace de nommage Doctrine\Common

Espaces de nommage

Inflector


Joomla CMS: Référence de l'espace de nommage Doctrine\Common\Inflector

  • Doctrine
  • Common
  • Inflector
Structures de données
Référence de l'espace de nommage Doctrine\Common\Inflector

Structures de données

class Inflector


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector

  • Doctrine
  • Inflector
Espaces de nommage | Structures de données
Référence de l'espace de nommage Doctrine\Inflector

Espaces de nommage

Rules

Structures de données

class | CachedWordInflector
class | GenericLanguageInflectorFactory
class | Inflector
class | InflectorFactory
class | Language
interface | LanguageInflectorFactory
class | NoopWordInflector
class | RulesetInflector
interface | WordInflector


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules

  • Doctrine
  • Inflector
  • Rules
Espaces de nommage | Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules

Espaces de nommage

English
French
NorwegianBokmal
Portuguese
Spanish
Turkish

Structures de données

class | Pattern
class | Patterns
class | Ruleset
class | Substitution
class | Substitutions
class | Transformation
class | Transformations
class | Word


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\English

  • Doctrine
  • Inflector
  • Rules
  • English
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\English

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\French

  • Doctrine
  • Inflector
  • Rules
  • French
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\French

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\NorwegianBokmal

  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\NorwegianBokmal

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\Portuguese

  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\Portuguese

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\Spanish

  • Doctrine
  • Inflector
  • Rules
  • Spanish
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\Spanish

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage Doctrine\Inflector\Rules\Turkish

  • Doctrine
  • Inflector
  • Rules
  • Turkish
Structures de données
Référence de l'espace de nommage Doctrine\Inflector\Rules\Turkish

Structures de données

class | Inflectible
class | InflectorFactory
class | Rules
class | Uninflected


Joomla CMS: Référence de l'espace de nommage DSA

Référence de l'espace de nommage DSA

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License OpenSSH Formatted DSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted DSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PuTTY Formatted DSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Raw DSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public XML Formatted DSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Raw DSA Signature Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSA Parameters Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSA Private Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public DSA Public Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Pure-PHP FIPS 186-4 compliant implementation of DSA. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage EC

Référence de l'espace de nommage EC

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2017 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2019 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://pear.php.net/package/Math_BigInteger Curves over y^2 = x^3 + a*x + x Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2017 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Jim Wiggint on terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2017 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://pear.php.net/package/Math_BigInteger Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Generic EC Key Parsing Helper functions Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public libsodium Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Montgomery Curve Private Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Montgomery Public Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OpenSSH Formatted EC Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public "PKCS1" (RFC5915) Formatted EC Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted EC Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PuTTY Formatted EC Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public XML Formatted EC Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Raw DSA Signature Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EC Parameters Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EC Private Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public EC Public Key Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Pure-PHP implementation of EC. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Engine

Référence de l'espace de nommage Engine

Description détaillée

Base Engine.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Engines

Référence de l'espace de nommage Engines

Description détaillée

OpenSSL Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage enshrined

Espaces de nommage
Référence de l'espace de nommage enshrined

Espaces de nommage

svgSanitize

Description détaillée

Class AllowedAttributes

Class AllowedTags

Class AttributeInterface

Interface TagInterface

Class Sanitizer


Joomla CMS: Référence de l'espace de nommage enshrined\svgSanitize

  • enshrined
  • svgSanitize
Espaces de nommage | Structures de données
Référence de l'espace de nommage enshrined\svgSanitize

Espaces de nommage

data
ElementReference
Exceptions

Structures de données

class | Helper
class | Sanitizer


Joomla CMS: Référence de l'espace de nommage enshrined\svgSanitize\data

  • enshrined
  • svgSanitize
  • data
Structures de données
Référence de l'espace de nommage enshrined\svgSanitize\data

Structures de données

class | AllowedAttributes
class | AllowedTags
interface | AttributeInterface
interface | TagInterface
class | XPath


Joomla CMS: Référence de l'espace de nommage enshrined\svgSanitize\ElementReference

  • enshrined
  • svgSanitize
  • ElementReference
Structures de données
Référence de l'espace de nommage enshrined\svgSanitize\ElementReference

Structures de données

class | Resolver
class | Subject
class | Usage


Joomla CMS: Référence de l'espace de nommage enshrined\svgSanitize\Exceptions

  • enshrined
  • svgSanitize
  • Exceptions
Structures de données
Référence de l'espace de nommage enshrined\svgSanitize\Exceptions

Structures de données

class NestingException


Joomla CMS: Référence de l'espace de nommage FG

Espaces de nommage
Référence de l'espace de nommage FG

Espaces de nommage

ASN1
Utility
X509

Description détaillée

Class BigInteger Utility class to remove dependence on a single large number library. Not intended for external use, this class only implements the functionality needed throughout this project.

Instances are immutable, all operations return a new instance with the result.

Class BigIntegerBcmath Integer representation of big numbers using the bcmath library to perform large operations.

Class BigIntegerGmp Integer representation of big numbers using the GMP extension to perform operations.


Joomla CMS: Référence de l'espace de nommage FG\ASN1

  • FG
  • ASN1
Espaces de nommage | Structures de données
Référence de l'espace de nommage FG\ASN1

Espaces de nommage

Composite
Exception
Universal

Structures de données

class | AbstractString
class | AbstractTime
class | ASNObject
class | Base128
class | Construct
class | ExplicitlyTaggedObject
class | Identifier
class | OID
interface | Parsable
class | TemplateParser
class | UnknownConstructedObject
class | UnknownObject


Joomla CMS: Référence de l'espace de nommage FG\ASN1\Composite

  • FG
  • ASN1
  • Composite
Structures de données
Référence de l'espace de nommage FG\ASN1\Composite

Structures de données

class | AttributeTypeAndValue
class | RDNString
class | RelativeDistinguishedName


Joomla CMS: Référence de l'espace de nommage FG\ASN1\Exception

  • FG
  • ASN1
  • Exception
Structures de données
Référence de l'espace de nommage FG\ASN1\Exception

Structures de données

class | NotImplementedException
class | ParserException


Joomla CMS: Référence de l'espace de nommage FG\ASN1\Universal

  • FG
  • ASN1
  • Universal
Structures de données
Référence de l'espace de nommage FG\ASN1\Universal

Structures de données

class | BitString
class | BMPString
class | Boolean
class | CharacterString
class | Enumerated
class | GeneralizedTime
class | GeneralString
class | GraphicString
class | IA5String
class | Integer
class | NullObject
class | NumericString
class | ObjectDescriptor
class | ObjectIdentifier
class | OctetString
class | PrintableString
class | RelativeObjectIdentifier
class | Sequence
class | Set
class | T61String
class | UniversalString
class | UTCTime
class | UTF8String
class | VisibleString


Joomla CMS: Référence de l'espace de nommage FG\Utility

  • FG
  • Utility
Structures de données
Référence de l'espace de nommage FG\Utility

Structures de données

class | BigInteger
class | BigIntegerBcmath
class | BigIntegerGmp


Joomla CMS: Référence de l'espace de nommage FG\X509

  • FG
  • X509
Espaces de nommage | Structures de données
Référence de l'espace de nommage FG\X509

Espaces de nommage

CSR
SAN

Structures de données

class | AlgorithmIdentifier
class | CertificateExtensions
class | CertificateSubject
class | PrivateKey
class | PublicKey


Joomla CMS: Référence de l'espace de nommage FG\X509\CSR

  • FG
  • X509
  • CSR
Structures de données
Référence de l'espace de nommage FG\X509\CSR

Structures de données

class | Attributes
class | CSR


Joomla CMS: Référence de l'espace de nommage FG\X509\SAN

  • FG
  • X509
  • SAN
Structures de données
Référence de l'espace de nommage FG\X509\SAN

Structures de données

class | DNSName
class | IPAddress
class | SubjectAlternativeNames


Joomla CMS: Référence de l'espace de nommage Fig

Espaces de nommage
Référence de l'espace de nommage Fig

Espaces de nommage

Link


Joomla CMS: Référence de l'espace de nommage Fig\Link

  • Fig
  • Link
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Fig\Link

Structures de données

class | GenericLinkProvider
class | Link
interface | Relations

Fonctions

withLink (LinkInterface $link)
withoutLink (LinkInterface $link)
getLinks ()
getLinksByRel ($rel)
getHref ()
isTemplated ()
getRels ()
getAttributes ()

Variables

trait | EvolvableLinkProviderTrait
trait | EvolvableLinkTrait
trait | LinkProviderTrait
trait | LinkTrait
$href = ''
$rel = []
$attributes = []

Documentation des fonctions

◆ getAttributes()

Fig\Link\getAttributes ( )

{}

Références Fig\Link\$attributes.

Référencé par Command\getDefaultDescription(), Command\getDefaultName(), et Sanitizer\setAllowedAttrs().

◆ getHref()

Fig\Link\getHref ( )

{}

Références Fig\Link\$href.

◆ getLinks()

Fig\Link\getLinks ( )

{}

Référencé par Document\preloadAssets().

◆ getLinksByRel()

Fig\Link\getLinksByRel ( $rel )

{}

Références $link, et Fig\Link\$rel.

◆ getRels()

Fig\Link\getRels ( )

{}

◆ isTemplated()

Fig\Link\isTemplated ( )

{}

◆ withLink()

Fig\Link\withLink ( LinkInterface $link )

{}

Références $link, et $this.

Référencé par PreloadManager\link().

◆ withoutLink()

Fig\Link\withoutLink ( LinkInterface $link )

{}

Références $link, et $this.

Documentation des variables

◆ $attributes

$attributes = []
private

Référencé par Fig\Link\getAttributes().

◆ $href

$href = ''
private

Référencé par Link\__construct(), et Fig\Link\getHref().

◆ $rel

$rel = []
private

Référencé par Link\__construct(), et Fig\Link\getLinksByRel().

◆ EvolvableLinkProviderTrait

trait EvolvableLinkProviderTrait
Valeur initiale :
{
use LinkProviderTrait
Fig\Link\LinkProviderTrait
trait LinkProviderTrait
Definition: LinkProviderTrait.php:15

Class EvolvableLinkProviderTrait

◆ EvolvableLinkTrait

trait EvolvableLinkTrait
Valeur initiale :
{
use LinkTrait
Fig\Link\LinkTrait
trait LinkTrait
Definition: LinkTrait.php:13

Class EvolvableLinkTrait

◆ LinkProviderTrait

trait LinkProviderTrait
Valeur initiale :
{
private $links = []

Class LinkProviderTrait

◆ LinkTrait

trait LinkTrait
Valeur initiale :
{
use TemplatedHrefTrait

Class LinkTrait

LinkInterface


Joomla CMS: Référence de l'espace de nommage FileNotFoundException

Référence de l'espace de nommage FileNotFoundException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License FileNotFoundException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Functions

Référence de l'espace de nommage Functions

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2016 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Common String Functions Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage GMP

Référence de l'espace de nommage GMP

Description détaillée

GMP Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

GMP Engine.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Hash

Référence de l'espace de nommage Hash

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton
Auteur
Andreas Fischer bantu.nosp@m.@php.nosp@m.bb.co.nosp@m.m
Copyright
2015 Andreas Fischer http://www.opensource.org/licenses/mit-license.html MIT License Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net Andreas Fischer bantu.nosp@m.@php.nosp@m.bb.co.nosp@m.m public


Joomla CMS: Référence de l'espace de nommage Http

Espaces de nommage
Référence de l'espace de nommage Http

Espaces de nommage

Message


Joomla CMS: Référence de l'espace de nommage Http\Message

  • Http
  • Message
Structures de données
Référence de l'espace de nommage Http\Message

Structures de données

interface | MessageFactory
interface | RequestFactory
interface | ResponseFactory
interface | StreamFactory
interface | UriFactory


Joomla CMS: Référence de l'espace de nommage IdnaConvert

Référence de l'espace de nommage IdnaConvert

Description détaillée

Converts between various flavours of Unicode representations like UCS-4 or UTF-8 Supported schemes:

  • UCS-4 Little Endian / Big Endian / Array (partially)
  • UTF-16 Little Endian / Big Endian (not yet)
  • UTF-8
  • UTF-7
  • UTF-7 IMAP (modified UTF-7)
Auteur
Matthias Sommerfeld matth.nosp@m.ias..nosp@m.somme.nosp@m.rfel.nosp@m.d@alg.nosp@m.o26..nosp@m.de
Copyright
2003-2019 algo26 Beratungs GmbH, Berlin, https://www.algo26.de


Joomla CMS: Référence de l'espace de nommage InconsistentSetupException

Référence de l'espace de nommage InconsistentSetupException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License InconsistentSetupException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage InsufficientSetupException

Référence de l'espace de nommage InsufficientSetupException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License InsufficientSetupException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Joomla

Espaces de nommage
Référence de l'espace de nommage Joomla

Espaces de nommage

Admin
Administrator
API
Api
Application
Archive
Authentication
Cli
CMS
Component
Console
Crypt
Data
Database
DI
Event
Filesystem
Filter
Http
Input
Installation
Language
Ldap
Menus
Module
Modules
OAuth1
OAuth2
Plugin
Plugins
Privacy
Redirect
Registry
Router
Session
Site
String
Tags
Templates
Uri
Users
Utilities


Joomla CMS: Référence de l'espace de nommage Joomla\Admin

  • Joomla
  • Admin
Référence de l'espace de nommage Joomla\Admin

Description détaillée

Layout

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Administrator

  • Joomla
  • Administrator
Référence de l'espace de nommage Joomla\Administrator

Description détaillée

com_actionlogs

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_actionlogs

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_actionlogs

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

This file contains post-installation message handling for notifying users of a change in the default .htaccess and web.config files.

com_admin

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt

This file contains post-installation message handling for notifying users of a change in the default .htaccess file regarding hardening against XSS in SVG's

com_admin

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

This file contains post-installation message handling for the checks if the installation is affected by the issue with content languages access in 3.4.0

com_admin

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

This file contains post-installation message handling for the checking minimum PHP version support

com_admin

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

This file contains post-installation message handling for notifying users of a change in the default textfilter settings

com_admin

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_admin

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_admin

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_ajax

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_associations

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_associations

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_banners

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cache

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cache

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cache

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cache

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_categories

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_checkin

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_checkin

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_checkin

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_checkin

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_checkin

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_contact

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_content

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_contenthistory

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cpanel

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cpanel

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_cpanel

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_fields

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_finder

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

com_finder

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

The Greek stemmer was adapted for Joomla! 4 by Nicholas K. Dionysopoulos nicho.nosp@m.las@.nosp@m.akeeb.nosp@m.abac.nosp@m.kup.c.nosp@m.om. This is derivative work, based on the Greek stemmer for Drupal, see https://github.com/magaras/greek_stemmer/blob/master/mod_stemmer.php

com_finder

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_installer

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Installer Update Sites Controller

com_installer

Depuis
3.4

com_installer

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_joomlaupdate

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_joomlaupdate

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Important Notes:

  • Unlike other files, this file requires multiple namespace declarations in order to overload core classes during the update process
  • Also unlike other files, the normal constant defined checks must be within the global namespace declaration and can't be outside of it

com_joomlaupdate

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_joomlaupdate

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_joomlaupdate

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_joomlaupdate

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_joomlaupdate

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_login

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_login

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_login

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_login

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_login

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_mails

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_media

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_menus

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Menus HTML helper class.

com_menus

Depuis
1.7

com_menus

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_modules

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_newsfeeds

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_plugins

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_postinstall

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_postinstall

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_postinstall

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_postinstall

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_postinstall

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_redirect

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

A dropdown containing all valid HTTP 1.1 response codes.

com_redirect

Depuis
3.4

com_redirect

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_scheduler

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_templates

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_users

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_users

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_workflow

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_workflow

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_workflow

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_workflow

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Depuis
4.0.0

com_wrapper

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_wrapper

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_custom

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_feed

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_frontend

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_latest

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_latest

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_latestactions

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_logged

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_logged

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_logged

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_logged

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_login

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_login

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_logsupport

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_loginsupport

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_messages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_multilangstatus

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_popular

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_popular

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_post_installation_messages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_privacy_dashboard

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_privacy_status

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_privacy_status

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_quickicon

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_quickicon

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_quickicon

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_sampledata

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_stats_admin

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_submenu

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_submenu

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_submenu

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_title

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_title

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_toolbar

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_toolbar

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_user

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_user

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_version

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Templates.Atum

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Templates.Atum

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Depuis
4.0.0

Templates.Atum

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Depuis
4.0.0

Templates.Atum

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Templates.Atum

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Module chrome for rendering the module in a submenu

Templates.Atum

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Depuis
4.0.0

Template.system

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Template.system

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_latest

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_news

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\API

  • Joomla
  • API
Référence de l'espace de nommage Joomla\API

Description détaillée

com_media

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_categories

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_installer

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_languages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_messages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_plugins

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_redirect

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_templates

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Api

  • Joomla
  • Api
Référence de l'espace de nommage Joomla\Api

Description détaillée

com_content

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Application

  • Joomla
  • Application
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\Application

Espaces de nommage

Controller
Event
Exception
Web

Structures de données

class | AbstractApplication
class | AbstractWebApplication
class | ApplicationEvents
interface | ApplicationInterface
interface | ConfigurationAwareApplicationInterface
interface | SessionAwareWebApplicationInterface
class | WebApplication
interface | WebApplicationInterface

Fonctions

getInput ()
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)

Variables

trait SessionAwareWebApplicationTrait

Description détaillée

Part of the Joomla Framework Application Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ checkToken()

Joomla\Application\checkToken ( $method = 'post' )

Checks for a form token in the request.

Paramètres
string $method The request method in which to look for the token key.
Renvoie
boolean
Depuis
2.0.0

Références $method, Joomla\Application\getFormToken(), Joomla\Application\getInput(), et Joomla\Application\getSession().

Référencé par MessageController\action(), LinksController\activate(), UsersController\activate(), TagController\batch(), GroupController\batch(), BannerController\batch(), NewsfeedController\batch(), LinksController\batch(), UserController\batch(), FieldController\batch(), ModuleController\batch(), MailController\cancel(), AssociationController\cancel(), ItemController\cancel(), OverrideController\cancel(), ProfileController\cancel(), FormController\cancel(), UpdateController\captive(), UsersController\changeBlock(), AdminController\checkin(), AssociationsController\clean(), TemplateController\createFile(), OverridesController\delete(), DisplayController\delete(), LevelController\delete(), AdminController\delete(), UpdatesitesController\delete(), MethodController\delete(), TemplateController\delete(), DisplayController\display(), StylesController\duplicate(), ModulesController\duplicate(), LinksController\duplicateUrls(), MenuController\exportXml(), HistoryController\keep(), UserController\login(), DisplayController\login(), DisplayController\logout(), UserController\logout(), PlgSystemDebug\onAjaxDebug(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSampledataBlog\onAjaxSampledataApplyStep2(), PlgSampledataMultilang\onAjaxSampledataApplyStep3(), PlgSampledataMultilang\onAjaxSampledataApplyStep4(), PlgSampledataMultilang\onAjaxSampledataApplyStep5(), PlgSampledataMultilang\onAjaxSampledataApplyStep6(), PlgSampledataMultilang\onAjaxSampledataApplyStep7(), IndexController\optimise(), TemplateController\overrides(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), AssociationsController\purge(), DisplayController\purge(), ActionlogsController\purge(), LinksController\purge(), UpdatesitesController\rebuild(), AdminController\reorder(), PlgSystemSchedulerunner\runTestCron(), AdminController\runTransition(), ConfigController\save(), StyleController\save(), TemplatesController\save(), OverrideController\save(), ModuleController\save(), FormController\save(), AdminController\saveorder(), AdminController\saveOrderAjax(), MailController\send(), InstalledController\setDefault(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), ItemController\setType(), ContactController\submit(), InstalledController\switchAdminLanguage(), TemplateController\uploadFile(), et ArticleController\vote().

◆ getFormToken()

Joomla\Application\getFormToken ( $forceNew = false )

Method to determine a hash for anti-spoofing variable names

Paramètres
boolean $forceNew If true, force a new token to be created
Renvoie
string Hashed var name
Depuis
2.0.0

Références Joomla\Application\getSession().

Référencé par Session\checkToken(), Joomla\Application\checkToken(), PlgSystemDebug\onAfterRespond(), PlgButtonMenu\onDisplay(), PlgButtonContact\onDisplay(), PlgButtonModule\onDisplay(), PlgButtonArticle\onDisplay(), PlgButtonFields\onDisplay(), PlgQuickiconPrivacyCheck\onGetIcons(), PlgQuickiconExtensionupdate\onGetIcons(), et PlgQuickiconOverrideCheck\onGetIcons().

◆ getInput()

Joomla\Application\getInput ( )
abstract

Method to get the application input object.

Renvoie
Input
Depuis
2.0.0

Gets the input instance used by the last execution of the command or application.

Renvoie
InputInterface

Références Symfony\Component\Console\Tester\$input.

Référencé par CliApplication\__get(), ConsoleApplication\__get(), FormField\__get(), Joomla\Application\checkToken(), ContenttypeField\getInput(), FieldcontextsField\getInput(), WorkflowcontextsField\getInput(), PrivacyField\getInput(), TermsField\getInput(), SectionField\getInput(), JoomlatokenField\getInput(), MenuOrderingField\getInput(), ModulepositionField\getInput(), ConsentBoxField\getInput(), et FormField\renderField().

◆ getSession()

Joomla\Application\getSession ( )

Method to get the application session object.

Renvoie
SessionInterface The session object
Depuis
2.0.0

Références class, et null.

Référencé par CMSApplication\checkSession(), Joomla\Application\checkToken(), SessionCollector\collect(), Joomla\Application\getFormToken(), CMSApplication\getMessageQueue(), CMSApplication\getUserState(), InstallationApplication\initialiseApp(), PlgUserJoomla\onUserLogout(), CMSApplication\redirect(), ServiceProviderInterface\register(), et CMSApplication\setUserState().

◆ setSession()

Joomla\Application\setSession ( SessionInterface $session )

Sets the session for the application to use, if required.

Paramètres
SessionInterface $session A session object.
Renvoie
$this
Depuis
2.0.0

Références $this.

Documentation des variables

◆ SessionAwareWebApplicationTrait

trait SessionAwareWebApplicationTrait
Valeur initiale :
{
protected $session

Trait which helps implementing Joomla\Application\SessionAwareWebApplicationInterface in a web application class.

Depuis
2.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\Application\Controller

  • Joomla
  • Application
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Application\Controller

Structures de données

class | ContainerControllerResolver
class | ControllerResolver
interface | ControllerResolverInterface

Description détaillée

Part of the Joomla Framework Application Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Application\Event

  • Joomla
  • Application
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Application\Event

Structures de données

class | ApplicationErrorEvent
class | ApplicationEvent

Description détaillée

Part of the Joomla Framework Application Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Application\Exception

  • Joomla
  • Application
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Application\Exception

Structures de données

class UnableToWriteBody

Description détaillée

Part of the Joomla Framework Application Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Application\Web

  • Joomla
  • Application
  • Web
Structures de données
Référence de l'espace de nommage Joomla\Application\Web

Structures de données

class WebClient

Description détaillée

Part of the Joomla Framework Application Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Archive

  • Joomla
  • Archive
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Archive

Espaces de nommage

Exception

Structures de données

class | Archive
class | Bzip2
interface | ExtractableInterface
class | Gzip
class | Tar
class | Zip

Description détaillée

Part of the Joomla Framework Archive Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Archive\Exception

  • Joomla
  • Archive
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Archive\Exception

Structures de données

class | UnknownArchiveException
class | UnsupportedArchiveException

Description détaillée

Part of the Joomla Framework Archive Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Authentication

  • Joomla
  • Authentication
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Authentication

Espaces de nommage

Exception
Password
Strategies

Structures de données

class | AbstractUsernamePasswordAuthenticationStrategy
class | Authentication
interface | AuthenticationStrategyInterface

Description détaillée

Part of the Joomla Framework Authentication Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Authentication\Exception

  • Joomla
  • Authentication
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Authentication\Exception

Structures de données

class UnsupportedPasswordHandlerException

Description détaillée

Part of the Joomla Framework Authentication Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Authentication\Password

  • Joomla
  • Authentication
  • Password
Structures de données
Référence de l'espace de nommage Joomla\Authentication\Password

Structures de données

class | Argon2idHandler
class | Argon2iHandler
class | BCryptHandler
interface | HandlerInterface

Description détaillée

Part of the Joomla Framework Authentication Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Authentication\Strategies

  • Joomla
  • Authentication
  • Strategies
Structures de données
Référence de l'espace de nommage Joomla\Authentication\Strategies

Structures de données

class | DatabaseStrategy
class | LocalStrategy

Description détaillée

Part of the Joomla Framework Authentication Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Cli

  • Joomla
  • Cli
Référence de l'espace de nommage Joomla\Cli

Description détaillée

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS

  • Joomla
  • CMS
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS

Espaces de nommage

Access
Adapter
Application
Association
Authentication
Autoload
Button
Cache
Captcha
Categories
Changelog
Client
Component
Console
Crypt
Date
Dispatcher
Document
Editor
Encrypt
Environment
Error
Event
Exception
Extension
Feed
Fields
Filesystem
Filter
Form
Help
Helper
HTML
Http
Image
Input
Installation
Installer
Language
Layout
Log
Mail
Menu
Microdata
MVC
Object
Pagination
Pathway
Plugin
Profiler
Response
Router
Schema
Serializer
Service
Session
String
Table
Tag
Toolbar
Tree
UCM
Updater
Uri
User
Utility
Versioning
WebAsset
Workflow

Structures de données

class | Factory
class | Version

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Access

  • Joomla
  • CMS
  • Access
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Access

Espaces de nommage

Exception

Structures de données

class | Access
class | Rule
class | Rules

Description détaillée

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Access\Exception

  • Joomla
  • CMS
  • Access
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Access\Exception

Structures de données

class | AuthenticationFailed
class | NotAllowed

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Adapter

  • Joomla
  • CMS
  • Adapter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Adapter

Structures de données

class | Adapter
class | AdapterInstance

Description détaillée

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Application

  • Joomla
  • CMS
  • Application
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Application

Espaces de nommage

CLI
Exception

Structures de données

class | AdministratorApplication
class | ApiApplication
class | ApplicationHelper
class | BaseApplication
class | CliApplication
class | CMSApplication
interface | CMSApplicationInterface
interface | CMSWebApplicationInterface
class | ConsoleApplication
class | DaemonApplication
interface | EventAwareInterface
class | SiteApplication
class | WebApplication

Fonctions

getDispatcher ()
getLogger ()
registerEvent ($event, callable $handler)
triggerEvent ($eventName, $args=[])
getIdentity ()
loadIdentity (User $identity=null)
setUserFactory (UserFactoryInterface $userFactory)

Variables

trait | EventAware
trait | IdentityAware
$userFactory

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getDispatcher()

Joomla\CMS\Application\getDispatcher ( )
abstract

Get the event dispatcher.

Renvoie
DispatcherInterface
Depuis
4.0.0
Exceptions

Référencé par Captcha\__construct(), Editor\__construct(), Table\__construct(), PlgEditorNone\_displayButtons(), Captcha\_load(), Editor\_loadEditor(), Table\bind(), Table\check(), Table\checkIn(), Table\checkOut(), WebAssetRegistry\dispatchAssetChanged(), AbstractApplication\dispatchEvent(), AbstractView\dispatchEvent(), BaseDatabaseModel\dispatchEvent(), DatabaseDriver\dispatchEvent(), PlgEditorCodemirror\displayButtons(), Editor\getButtons(), Table\hit(), Shortcut\initialize(), Table\load(), Table\move(), Table\publish(), Joomla\CMS\Application\registerEvent(), CMSPlugin\registerLegacyListener(), CMSPlugin\registerListener(), ModuleHelper\renderRawModule(), Table\reorder(), Table\reset(), Application\runCommand(), MVCFactory\setDispatcherOnObject(), Nested\store(), Joomla\CMS\Application\triggerEvent(), et TaskTable\unlock().

◆ getIdentity()

Joomla\CMS\Application\getIdentity ( )

Get the application identity.

Renvoie
User
Depuis
4.0.0

Référencé par HtmlView\addToolbar(), WebApplication\afterSessionStart(), CMSApplication\checkSession(), AdministratorApplication\getTemplate(), AdministratorApplication\login(), Joomla\Plugin\System\Webauthn\PluginTraits\mustDisplayButton(), et PlgFieldsMedia\onCustomFieldsPrepareDom().

◆ getLogger()

Joomla\CMS\Application\getLogger ( )
abstract

Get the logger.

Renvoie
LoggerInterface
Depuis
4.0.0

Référencé par AdministratorApplication\getTemplate(), WebApplication\loadSession(), CMSApplication\login(), et Joomla\CMS\Application\triggerEvent().

◆ loadIdentity()

Joomla\CMS\Application\loadIdentity ( User $identity = null )

Allows the application to load a custom or default identity.

Paramètres
User $identity An optional identity object. If omitted, a null user object is created.
Renvoie
$this
Depuis
4.0.0

Références $this.

Référencé par WebApplication\afterSessionStart().

◆ registerEvent()

Joomla\CMS\Application\registerEvent | ( |  | $event,
 |  | callable | $handler
 | ) |  |

Registers a handler to a particular event group.

Paramètres
string | $event | The event name.
callable | $handler | The handler, a function or an instance of an event object.
Renvoie
$this
Depuis
4.0.0

Références $this, et Joomla\CMS\Application\getDispatcher().

◆ setUserFactory()

Joomla\CMS\Application\setUserFactory ( UserFactoryInterface $userFactory )

Set the user factory to use.

Paramètres
UserFactoryInterface $userFactory The user factory to use
Renvoie
void
Depuis
4.0.0

Références Joomla\CMS\Application\$userFactory.

◆ triggerEvent()

Joomla\CMS\Application\triggerEvent | ( | $eventName,
 |  | $args = []
 | ) |

Calls all handlers associated with an event group.

This is a legacy method, implementing old-style (Joomla! 3.x) plugin calls. It's best to go directly through the Dispatcher and handle the returned EventInterface object instead of going through this method. This method is deprecated and will be removed in Joomla! 5.x.

This method will only return the 'result' argument of the event

Paramètres
string | $eventName | The event name.
array | Event | $args | An array of arguments or an Event object (optional).
Renvoie
array An array of results from each function call. Note this will be an empty array if no dispatcher is set.
Depuis
4.0.0
Exceptions

Références $className, $result, $this, elseif, Joomla\CMS\Application\getDispatcher(), Joomla\CMS\Event\getEventClassByEventName(), et Joomla\CMS\Application\getLogger().

Référencé par AdministratorApplication\dispatch(), SiteApplication\dispatch(), ApiApplication\dispatch(), WebApplication\execute(), CliApplication\execute(), DaemonApplication\execute(), CMSApplication\initialiseApp(), CMSApplication\login(), CMSApplication\logout(), DaemonApplication\postFork(), CMSApplication\render(), AdministratorApplication\route(), SiteApplication\route(), et CMSApplication\route().

Documentation des variables

◆ $userFactory

$userFactory
private

Référencé par Basic\__construct(), Icon\__construct(), Token\__construct(), et Joomla\CMS\Application\setUserFactory().

◆ EventAware

trait EventAware
Valeur initiale :
{
use CoreEventAware
CoreEventAware

Trait for application classes which dispatch events

Depuis
4.0.0

◆ IdentityAware

trait IdentityAware
Valeur initiale :
{
protected $identity

Trait for application classes which are identity (user) aware

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Application\CLI

  • Joomla
  • CMS
  • Application
  • CLI
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Application\CLI

Espaces de nommage

Output

Structures de données

class | CliInput
class | CliOutput
class | ColorStyle

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Application\CLI\Output

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Application\CLI\Output

Espaces de nommage

Processor

Structures de données

class | Stdout
class | Xml

Description détaillée

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Application\CLI\Output\Processor

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
  • Processor
Structures de données
Référence de l'espace de nommage Joomla\CMS\Application\CLI\Output\Processor

Structures de données

class | ColorProcessor
interface | ProcessorInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Application\Exception

  • Joomla
  • CMS
  • Application
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Application\Exception

Structures de données

class NotAcceptable

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Association

  • Joomla
  • CMS
  • Association
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Association

Structures de données

class | AssociationExtensionHelper
interface | AssociationExtensionInterface
interface | AssociationServiceInterface

Fonctions

getAssociationsExtension ()
setAssociationExtension (AssociationExtensionInterface $associationExtension)

Variables

trait AssociationServiceTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getAssociationsExtension()

Joomla\CMS\Association\getAssociationsExtension ( )

Returns the associations extension helper class.

Renvoie
AssociationExtensionInterface
Depuis
4.0.0

◆ setAssociationExtension()

Joomla\CMS\Association\setAssociationExtension ( AssociationExtensionInterface $associationExtension )

The association extension.

Paramètres
AssociationExtensionInterface $associationExtension The extension
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ AssociationServiceTrait

trait AssociationServiceTrait
Valeur initiale :
{
private $associationExtension = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Trait to implement AssociationServiceInterface

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Authentication

  • Joomla
  • CMS
  • Authentication
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Authentication

Espaces de nommage

Password

Structures de données

class | Authentication
class | AuthenticationResponse
interface | ProviderAwareAuthenticationPluginInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
Copyright (C) 2022 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Authentication\Password

  • Joomla
  • CMS
  • Authentication
  • Password
Structures de données
Référence de l'espace de nommage Joomla\CMS\Authentication\Password

Structures de données

class | Argon2idHandler
class | Argon2iHandler
class | BCryptHandler
class | ChainedHandler
interface | CheckIfRehashNeededHandlerInterface
class | MD5Handler
class | PHPassHandler

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Autoload

  • Joomla
  • CMS
  • Autoload
Structures de données
Référence de l'espace de nommage Joomla\CMS\Autoload

Structures de données

class ClassLoader

Description détaillée

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Button

  • Joomla
  • CMS
  • Button
Structures de données
Référence de l'espace de nommage Joomla\CMS\Button

Structures de données

class | ActionButton
class | FeaturedButton
class | PublishedButton
class | TransitionButton

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Cache

  • Joomla
  • CMS
  • Cache
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Cache

Espaces de nommage

Controller
Exception
Storage

Structures de données

class | Cache
class | CacheController
class | CacheControllerFactory
interface | CacheControllerFactoryAwareInterface
interface | CacheControllerFactoryInterface
class | CacheStorage

Fonctions

getCacheControllerFactory ()
setCacheControllerFactory (CacheControllerFactoryInterface $cacheControllerFactory=null)

Variables

trait CacheControllerFactoryAwareTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getCacheControllerFactory()

Joomla\CMS\Cache\getCacheControllerFactory ( )
protected

Get the CacheControllerFactoryInterface.

Renvoie
CacheControllerFactoryInterface
Depuis
4.2.0

Références class, et Factory\getContainer().

Référencé par MenuFactory\createMenu(), Factory\createRenderer(), et MVCFactory\setCacheControllerOnObject().

◆ setCacheControllerFactory()

Joomla\CMS\Cache\setCacheControllerFactory ( CacheControllerFactoryInterface $cacheControllerFactory = null )

Set the cache controller factory to use.

Paramètres
CacheControllerFactoryInterface $cacheControllerFactory The cache controller factory to use.
Renvoie
void
Depuis
4.2.0

Documentation des variables

◆ CacheControllerFactoryAwareTrait

trait CacheControllerFactoryAwareTrait
Valeur initiale :
{
private $cacheControllerFactory

Defines the trait for a CacheControllerFactoryInterface Aware Class.

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Cache\Controller

  • Joomla
  • CMS
  • Cache
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\CMS\Cache\Controller

Structures de données

class | CallbackController
class | OutputController
class | PageController
class | ViewController

Description détaillée

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Cache\Exception

  • Joomla
  • CMS
  • Cache
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Cache\Exception

Structures de données

class | CacheConnectingException
interface | CacheExceptionInterface
class | UnsupportedCacheException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Cache\Storage

  • Joomla
  • CMS
  • Cache
  • Storage
Structures de données
Référence de l'espace de nommage Joomla\CMS\Cache\Storage

Structures de données

class | ApcuStorage
class | CacheStorageHelper
class | FileStorage
class | MemcachedStorage
class | RedisStorage
class | WincacheStorage

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Captcha

  • Joomla
  • CMS
  • Captcha
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Captcha

Espaces de nommage

Google

Structures de données

class Captcha

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Captcha\Google

  • Joomla
  • CMS
  • Captcha
  • Google
Structures de données
Référence de l'espace de nommage Joomla\CMS\Captcha\Google

Structures de données

class HttpBridgePostRequestMethod

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Categories

  • Joomla
  • CMS
  • Categories
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Categories

Structures de données

class | Categories
class | CategoryFactory
interface | CategoryFactoryInterface
interface | CategoryInterface
class | CategoryNode
interface | CategoryServiceInterface
class | SectionNotFoundException

Fonctions

getCategory (array $options=[], $section='')
setCategoryFactory (CategoryFactoryInterface $categoryFactory)
countItems (array $items, string $section)
prepareForm (Form $form, $data)
getTableNameForSection (string $section=null)
getStateColumnForSection (string $section=null)

Variables

trait CategoryServiceTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ countItems()

Joomla\CMS\Categories\countItems | ( | array | $items,
 |  | string | $section
 | ) |  |

Adds Count Items for Category Manager.

Paramètres

Références $config, $items, ContentHelper\countRelations(), Joomla\CMS\Categories\getStateColumnForSection(), et Joomla\CMS\Categories\getTableNameForSection().

Référencé par LegacyComponent\countItems(), WorkflowsModel\getItems(), TagsModel\getItems(), et CategoriesModel\getItems().

◆ getCategory()

Joomla\CMS\Categories\getCategory | ( | array | $options = [],
 |  |  | $section = ''
 | ) |  |

Returns the category service.

Paramètres
array | $options | The options
string | $section | The section
Renvoie
CategoryInterface
Depuis
4.0.0
Exceptions
SectionNotFoundException

Références $options, et $section.

Référencé par CategoryModel\getChildren(), CategoryModel\getItems(), CategoryModel\getLeftSibling(), CategoryModel\getParent(), et CategoryModel\getRightSibling().

◆ getStateColumnForSection()

Joomla\CMS\Categories\getStateColumnForSection ( string $section = null )
protected

Returns the state column for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Référencé par Joomla\CMS\Categories\countItems().

◆ getTableNameForSection()

Joomla\CMS\Categories\getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Références null.

Référencé par Joomla\CMS\Categories\countItems().

◆ prepareForm()

Joomla\CMS\Categories\prepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Prepares the category form

Paramètres
Form | $form | The form to change
array | object | $data | The form data
Renvoie
void

Référencé par PlgSystemFields\onContentPrepareForm().

◆ setCategoryFactory()

Joomla\CMS\Categories\setCategoryFactory ( CategoryFactoryInterface $categoryFactory )

Sets the internal category factory.

Paramètres
CategoryFactoryInterface $categoryFactory The categories factory
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ CategoryServiceTrait

trait CategoryServiceTrait
Valeur initiale :
{
private $categoryFactory

Trait for component categories service.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Changelog

  • Joomla
  • CMS
  • Changelog
Structures de données
Référence de l'espace de nommage Joomla\CMS\Changelog

Structures de données

class Changelog

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Client

  • Joomla
  • CMS
  • Client
Structures de données
Référence de l'espace de nommage Joomla\CMS\Client

Structures de données

class | ClientHelper
class | FtpClient

Description détaillée

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Component

  • Joomla
  • CMS
  • Component
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Component

Espaces de nommage

Exception
Router

Structures de données

class | ComponentHelper
class | ComponentRecord

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Component\Exception

  • Joomla
  • CMS
  • Component
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Component\Exception

Structures de données

class MissingComponentException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Component\Router

  • Joomla
  • CMS
  • Component
  • Router
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Component\Router

Espaces de nommage

Rules

Structures de données

class | RouterBase
class | RouterFactory
interface | RouterFactoryInterface
interface | RouterInterface
class | RouterLegacy
interface | RouterServiceInterface
class | RouterView
class | RouterViewConfiguration

Fonctions

createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
setRouterFactory (RouterFactoryInterface $routerFactory)

Variables

trait RouterServiceTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ createRouter()

Joomla\CMS\Component\Router\createRouter | ( | CMSApplicationInterface | $application,
 |  | AbstractMenu | $menu
 | ) |  |

Returns the router.

Paramètres
CMSApplicationInterface | $application | The application object
AbstractMenu | $menu | The menu object to work with
Renvoie
RouterInterface
Depuis
4.0.0

Références $menu.

◆ setRouterFactory()

Joomla\CMS\Component\Router\setRouterFactory ( RouterFactoryInterface $routerFactory )

The router factory.

Paramètres
RouterFactoryInterface $routerFactory The router factory
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ RouterServiceTrait

trait RouterServiceTrait
Valeur initiale :
{
private $routerFactory = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Trait to implement AssociationServiceInterface

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Component\Router\Rules

  • Joomla
  • CMS
  • Component
  • Router
  • Rules
Structures de données
Référence de l'espace de nommage Joomla\CMS\Component\Router\Rules

Structures de données

class | MenuRules
class | NomenuRules
interface | RulesInterface
class | StandardRules

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Console

  • Joomla
  • CMS
  • Console
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Console

Espaces de nommage

Loader

Structures de données

class | AddUserCommand
class | AddUserToGroupCommand
class | ChangeUserPasswordCommand
class | CheckJoomlaUpdatesCommand
class | CheckUpdatesCommand
class | CleanCacheCommand
class | DeleteUserCommand
class | ExtensionDiscoverCommand
class | ExtensionDiscoverInstallCommand
class | ExtensionDiscoverListCommand
class | ExtensionInstallCommand
class | ExtensionRemoveCommand
class | ExtensionsListCommand
class | FinderIndexCommand
class | GetConfigurationCommand
class | ListUserCommand
class | RemoveOldFilesCommand
class | RemoveUserFromGroupCommand
class | SessionGcCommand
class | SessionMetadataGcCommand
class | SetConfigurationCommand
class | SiteDownCommand
class | SiteUpCommand
class | TasksListCommand
class | TasksRunCommand
class | TasksStateCommand
class | UpdateCoreCommand

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! CLI

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System.

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Console\Loader

  • Joomla
  • CMS
  • Console
  • Loader
Structures de données
Référence de l'espace de nommage Joomla\CMS\Console\Loader

Structures de données

class | WritableContainerLoader
interface | WritableLoaderInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Crypt

  • Joomla
  • CMS
  • Crypt
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Crypt

Espaces de nommage

Cipher

Structures de données

class Crypt

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Crypt\Cipher

  • Joomla
  • CMS
  • Crypt
  • Cipher
Structures de données
Référence de l'espace de nommage Joomla\CMS\Crypt\Cipher

Structures de données

class | CryptoCipher
class | SodiumCipher

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Date

  • Joomla
  • CMS
  • Date
Structures de données
Référence de l'espace de nommage Joomla\CMS\Date

Structures de données

class Date

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Dispatcher

  • Joomla
  • CMS
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\CMS\Dispatcher

Structures de données

class | AbstractModuleDispatcher
class | ApiDispatcher
class | ComponentDispatcher
class | ComponentDispatcherFactory
interface | ComponentDispatcherFactoryInterface
class | Dispatcher
interface | DispatcherInterface
class | LegacyComponentDispatcher
class | ModuleDispatcher
class | ModuleDispatcherFactory
interface | ModuleDispatcherFactoryInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document

  • Joomla
  • CMS
  • Document
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Document

Espaces de nommage

Feed
Opensearch
Renderer

Structures de données

class | Document
class | DocumentRenderer
class | ErrorDocument
class | Factory
interface | FactoryInterface
class | FeedDocument
class | HtmlDocument
class | ImageDocument
class | JsonapiDocument
class | JsonDocument
class | OpensearchDocument
class | PreloadManager
interface | PreloadManagerInterface
class | RawDocument
interface | RendererInterface
class | XmlDocument

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document\Feed

  • Joomla
  • CMS
  • Document
  • Feed
Structures de données
Référence de l'espace de nommage Joomla\CMS\Document\Feed

Structures de données

class | FeedEnclosure
class | FeedImage
class | FeedItem

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document\Opensearch

  • Joomla
  • CMS
  • Document
  • Opensearch
Structures de données
Référence de l'espace de nommage Joomla\CMS\Document\Opensearch

Structures de données

class | OpensearchImage
class | OpensearchUrl

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document\Renderer

  • Joomla
  • CMS
  • Document
  • Renderer
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Document\Renderer

Espaces de nommage

Feed
Html


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document\Renderer\Feed

  • Joomla
  • CMS
  • Document
  • Renderer
  • Feed
Structures de données
Référence de l'espace de nommage Joomla\CMS\Document\Renderer\Feed

Structures de données

class | AtomRenderer
class | RssRenderer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Document\Renderer\Html

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
Structures de données
Référence de l'espace de nommage Joomla\CMS\Document\Renderer\Html

Structures de données

class | ComponentRenderer
class | HeadRenderer
class | MessageRenderer
class | MetasRenderer
class | ModuleRenderer
class | ModulesRenderer
class | ScriptsRenderer
class | StylesRenderer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Editor

  • Joomla
  • CMS
  • Editor
Structures de données
Référence de l'espace de nommage Joomla\CMS\Editor

Structures de données

class Editor

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Encrypt

  • Joomla
  • CMS
  • Encrypt
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Encrypt

Espaces de nommage

AES

Structures de données

class | Aes
class | Base32
class | Randval
interface | RandValInterface
class | Totp

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Note
This file has been modified by the Joomla! Project and no longer reflects the original work of its author.

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Encrypt\AES

  • Joomla
  • CMS
  • Encrypt
  • AES
Structures de données
Référence de l'espace de nommage Joomla\CMS\Encrypt\AES

Structures de données

class | AbstractAES
interface | AesInterface
class | Mcrypt
class | OpenSSL

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Environment

  • Joomla
  • CMS
  • Environment
Structures de données
Référence de l'espace de nommage Joomla\CMS\Environment

Structures de données

class Browser

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Error

  • Joomla
  • CMS
  • Error
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Error

Espaces de nommage

JsonApi
Renderer

Structures de données

class | AbstractRenderer
interface | RendererInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Error\JsonApi

  • Joomla
  • CMS
  • Error
  • JsonApi
Structures de données
Référence de l'espace de nommage Joomla\CMS\Error\JsonApi

Structures de données

class | AuthenticationFailedExceptionHandler
class | CheckinCheckoutExceptionHandler
class | InvalidParameterExceptionHandler
class | InvalidRouteExceptionHandler
class | NotAcceptableExceptionHandler
class | NotAllowedExceptionHandler
class | ResourceNotFoundExceptionHandler
class | SaveExceptionHandler
class | SendEmailExceptionHandler

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Error\Renderer

  • Joomla
  • CMS
  • Error
  • Renderer
Structures de données
Référence de l'espace de nommage Joomla\CMS\Error\Renderer

Structures de données

class | CliRenderer
class | FeedRenderer
class | HtmlRenderer
class | JsonapiRenderer
class | JsonRenderer
class | XmlRenderer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event

  • Joomla
  • CMS
  • Event
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Event

Espaces de nommage

Model
MultiFactor
Plugin
QuickIcon
Result
Table
View
WebAsset
Workflow

Structures de données

class | AbstractEvent
class | AbstractImmutableEvent
class | AfterExtensionBootEvent
class | BeforeExtensionBootEvent
class | ErrorEvent
class | GenericEvent

Fonctions

trait static getEventClassByEventName (string $eventName)

Variables

trait CoreEventAware

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getEventClassByEventName()

trait static Joomla\CMS\Event\getEventClassByEventName ( string $eventName )
staticprotected

Get the concrete event class name for the given event name.

This method falls back to the generic Joomla class if the event name is unknown to this trait.

Paramètres
string $eventName The event name
Renvoie
string The event class name
Depuis
4.2.0

Références class.

Référencé par AbstractEvent\create(), et Joomla\CMS\Application\triggerEvent().

Documentation des variables

◆ CoreEventAware

trait CoreEventAware
Valeur initiale :
{
private static $eventNameToConcreteClass = [
'onBeforeBatch' => BeforeBatchEvent::class,
'onGetIcon' => GetIconEvent::class
class
< div id="<?php echo $id; ?> class
Definition: dropdown.php:46

Returns the most suitable event class for a Joomla core event name

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Model

  • Joomla
  • CMS
  • Event
  • Model
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\Model

Structures de données

class BeforeBatchEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\MultiFactor

  • Joomla
  • CMS
  • Event
  • MultiFactor
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\MultiFactor

Structures de données

class | BeforeDisplayMethods
class | Callback
class | Captive
class | GetMethod
class | GetSetup
class | NotifyActionLog
class | SaveSetup
class | Validate

Description détaillée

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Plugin

  • Joomla
  • CMS
  • Event
  • Plugin
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Event\Plugin

Espaces de nommage

System


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Plugin\System

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Event\Plugin\System

Espaces de nommage

Webauthn


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Plugin\System\Webauthn

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\Plugin\System\Webauthn

Structures de données

class | Ajax
class | AjaxChallenge
class | AjaxCreate
class | AjaxDelete
class | AjaxInitCreate
class | AjaxLogin
class | AjaxSaveLabel

Description détaillée

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\QuickIcon

  • Joomla
  • CMS
  • Event
  • QuickIcon
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\QuickIcon

Structures de données

class GetIconEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Result

  • Joomla
  • CMS
  • Event
  • Result
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Event\Result

Structures de données

interface ResultAwareInterface

Fonctions

addResult ($data)
setResult (array $value)
typeCheckResult ($data)

Variables

trait | ResultAware
trait | ResultTypeArrayAware
$resultIsFalseable = false
trait | ResultTypeBooleanAware
trait | ResultTypeFloatAware
trait | ResultTypeIntegerAware
trait | ResultTypeNumericAware
trait | ResultTypeObjectAware
$resultAcceptableClasses = []
trait | ResultTypeStringAware

Description détaillée

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ addResult()

Joomla\CMS\Event\Result\addResult ( $data )

Appends data to the result array of the event.

Paramètres
mixed $data What to add to the result array.
Renvoie
void
Depuis
4.2.0

Références $data, $this, class, et Joomla\CMS\Event\Result\typeCheckResult().

Référencé par Joomla\CMS\Event\Result\setResult().

◆ setResult()

Joomla\CMS\Event\Result\setResult ( array $value )
protected

Handle setting the result argument directly.

This method serves a dual purpose: backwards compatibility and enforcing the use of addResult.

When $this->preventSetArgumentResult is false it acts as a backwards compatibility shim for event handlers expecting generic event classes instead of the concrete Events implemented in this package. This allows the migration to concrete event classes throughout the lifetime of Joomla 4.x.

When $this->preventSetArgumentResult is false (which will always be the case on Joomla 5.0) it will throw a BadMethodCallException if the developer tries to call setArgument('result', ...) instead of going through the addResult() method.

Paramètres
array $value The new result array.
Renvoie
array
Depuis
4.2.0

Références $value, et Joomla\CMS\Event\Result\addResult().

◆ typeCheckResult()

typeCheckResult ( $data )

Checks the type of the data being appended to the result argument.

Paramètres
mixed $data The data to type check
Renvoie
void
Exceptions
InvalidArgumentException

Références $data, et null.

Référencé par Joomla\CMS\Event\Result\addResult().

Documentation des variables

◆ $resultAcceptableClasses

$resultAcceptableClasses = []
protected

◆ $resultIsFalseable

$resultIsFalseable = false
protected

◆ ResultAware

trait ResultAware
Valeur initiale :
{
protected $preventSetArgumentResult = false

This Trait partially implements the ResultAwareInterface for mutable and immutable events.

You must additionally implement the typeCheckResult method or use one of the ResultType*Aware traits in your Event handler.

Depuis
4.2.0

◆ ResultTypeArrayAware

trait ResultTypeArrayAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of an Array type.

Depuis
4.2.0

◆ ResultTypeBooleanAware

trait ResultTypeBooleanAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of a Boolean type.

Depuis
4.2.0

◆ ResultTypeFloatAware

trait ResultTypeFloatAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of a Float type.

Depuis
4.2.0

◆ ResultTypeIntegerAware

trait ResultTypeIntegerAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of an Integer type.

Depuis
4.2.0

◆ ResultTypeNumericAware

trait ResultTypeNumericAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of a Numeric type.

Depuis
4.2.0

◆ ResultTypeObjectAware

trait ResultTypeObjectAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of an object type.

If you do not set a list of acceptable result classes any PHP object will satisfy this type check.

Depuis
4.2.0

◆ ResultTypeStringAware

trait ResultTypeStringAware
Valeur initiale :
{
protected $resultIsNullable = false

This Trait partially implements the ResultAwareInterface for type checking.

Events using this Trait (and the ResultAware trait) will expect event handlers to set results of a String type.

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Table

  • Joomla
  • CMS
  • Event
  • Table
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\Table

Structures de données

class | AbstractEvent
class | AfterBindEvent
class | AfterCheckinEvent
class | AfterCheckoutEvent
class | AfterDeleteEvent
class | AfterHitEvent
class | AfterLoadEvent
class | AfterMoveEvent
class | AfterPublishEvent
class | AfterReorderEvent
class | AfterResetEvent
class | AfterStoreEvent
class | BeforeBindEvent
class | BeforeCheckinEvent
class | BeforeCheckoutEvent
class | BeforeDeleteEvent
class | BeforeHitEvent
class | BeforeLoadEvent
class | BeforeMoveEvent
class | BeforePublishEvent
class | BeforeReorderEvent
class | BeforeResetEvent
class | BeforeStoreEvent
class | CheckEvent
class | ObjectCreateEvent
class | SetNewTagsEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\View

  • Joomla
  • CMS
  • Event
  • View
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\View

Structures de données

class DisplayEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\WebAsset

  • Joomla
  • CMS
  • Event
  • WebAsset
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\WebAsset

Structures de données

class | AbstractEvent
class | WebAssetRegistryAssetChanged

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Event\Workflow

  • Joomla
  • CMS
  • Event
  • Workflow
Structures de données
Référence de l'espace de nommage Joomla\CMS\Event\Workflow

Structures de données

class | AbstractEvent
class | WorkflowFunctionalityUsedEvent
class | WorkflowTransitionEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Exception

  • Joomla
  • CMS
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Exception

Structures de données

class ExceptionHandler

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Extension

  • Joomla
  • CMS
  • Extension
Espaces de nommage | Structures de données | Variables
Référence de l'espace de nommage Joomla\CMS\Extension

Espaces de nommage

Service

Structures de données

interface | BootableExtensionInterface
class | Component
interface | ComponentInterface
class | DummyPlugin
class | ExtensionHelper
interface | ExtensionManagerInterface
class | LegacyComponent
class | Module
interface | ModuleInterface
class | MVCComponent
interface | PluginInterface

Variables

trait ExtensionManagerTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des variables

◆ ExtensionManagerTrait

trait ExtensionManagerTrait

Trait for classes which can load extensions

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Extension\Service

  • Joomla
  • CMS
  • Extension
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Extension\Service

Espaces de nommage

Provider


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Extension\Service\Provider

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
Structures de données
Référence de l'espace de nommage Joomla\CMS\Extension\Service\Provider

Structures de données

class | CategoryFactory
class | ComponentDispatcherFactory
class | HelperFactory
class | Module
class | ModuleDispatcherFactory
class | MVCFactory
class | RouterFactory

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Feed

  • Joomla
  • CMS
  • Feed
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Feed

Espaces de nommage

Parser

Structures de données

class | Feed
class | FeedEntry
class | FeedFactory
class | FeedLink
class | FeedParser
class | FeedPerson

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Feed\Parser

  • Joomla
  • CMS
  • Feed
  • Parser
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Feed\Parser

Espaces de nommage

Rss

Structures de données

class | AtomParser
interface | NamespaceParserInterface
class | RssParser

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Feed\Parser\Rss

  • Joomla
  • CMS
  • Feed
  • Parser
  • Rss
Structures de données
Référence de l'espace de nommage Joomla\CMS\Feed\Parser\Rss

Structures de données

class | ItunesRssParser
class | MediaRssParser

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Fields

  • Joomla
  • CMS
  • Fields
Structures de données
Référence de l'espace de nommage Joomla\CMS\Fields

Structures de données

interface FieldsServiceInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Filesystem

  • Joomla
  • CMS
  • Filesystem
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Filesystem

Espaces de nommage

Streams
Support

Structures de données

class | File
class | FilesystemHelper
class | Folder
class | Patcher
class | Path
class | Stream

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Filesystem\Streams

  • Joomla
  • CMS
  • Filesystem
  • Streams
Structures de données
Référence de l'espace de nommage Joomla\CMS\Filesystem\Streams

Structures de données

class StreamString

Description détaillée

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Filesystem\Support

  • Joomla
  • CMS
  • Filesystem
  • Support
Structures de données
Référence de l'espace de nommage Joomla\CMS\Filesystem\Support

Structures de données

class StringController

Description détaillée

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Filter

  • Joomla
  • CMS
  • Filter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Filter

Structures de données

class | InputFilter
class | OutputFilter

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Form

  • Joomla
  • CMS
  • Form
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Form

Espaces de nommage

Field
Filter
Rule

Structures de données

class | Form
class | FormFactory
interface | FormFactoryAwareInterface
interface | FormFactoryInterface
class | FormField
interface | FormFilterInterface
class | FormHelper
class | FormRule

Fonctions

getFormFactory ()
setFormFactory (FormFactoryInterface $formFactory=null)

Variables

trait FormFactoryAwareTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Remove phpcs exception with deprecated constant JCOMPAT_UNICODE_PROPERTIES :disable PSR1.Files.SideEffects

Documentation des fonctions

◆ getFormFactory()

Joomla\CMS\Form\getFormFactory ( )
abstract

Get the FormFactoryInterface.

Renvoie
FormFactoryInterface
Depuis
4.0.0
Exceptions

Référencé par Joomla\CMS\MVC\Model\loadForm(), et MVCFactory\setFormFactoryOnObject().

◆ setFormFactory()

Joomla\CMS\Form\setFormFactory ( FormFactoryInterface $formFactory = null )

Set the form factory to use.

Paramètres
FormFactoryInterface $formFactory The form factory to use.
Renvoie
$this
Depuis
4.0.0

Références $this.

Référencé par FormModel\__construct(), et FormController\__construct().

Documentation des variables

◆ FormFactoryAwareTrait

trait FormFactoryAwareTrait
Valeur initiale :
{
private $formFactory

Defines the trait for a FormFactoryInterface Aware Class.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Form\Field

  • Joomla
  • CMS
  • Form
  • Field
Structures de données
Référence de l'espace de nommage Joomla\CMS\Form\Field

Structures de données

class | AccessiblemediaField
class | AccesslevelField
class | AliastagField
class | AuthorField
class | CachehandlerField
class | CalendarField
class | CaptchaField
class | CategoryField
class | CheckboxesField
class | CheckboxField
class | ChromestyleField
class | ColorField
class | ComboField
class | ComponentlayoutField
class | ComponentsField
class | ContenthistoryField
class | ContentlanguageField
class | ContenttypeField
class | DatabaseconnectionField
class | EditorField
class | EmailField
class | FileField
class | FilelistField
class | FolderlistField
class | FrontendlanguageField
class | GroupedlistField
class | HeadertagField
class | HiddenField
class | ImagelistField
class | IntegerField
class | LanguageField
class | LastvisitdaterangeField
class | LimitboxField
class | ListField
class | MediaField
class | MenuField
class | MenuitemField
class | MeterField
class | ModulelayoutField
class | ModuleorderField
class | ModulepositionField
class | ModuletagField
class | NoteField
class | NumberField
class | OrderingField
class | PasswordField
class | PluginsField
class | PluginstatusField
class | PredefinedlistField
class | RadiobasicField
class | RadioField
class | RangeField
class | RedirectStatusField
class | RegistrationdaterangeField
class | RulesField
class | SessionhandlerField
class | SpacerField
class | SqlField
class | StatusField
class | SubformField
class | TagField
class | TelephoneField
class | TemplatestyleField
class | TextareaField
class | TextField
class | TimeField
class | TimezoneField
class | TransitionField
class | UrlField
class | UseractiveField
class | UserField
class | UsergrouplistField
class | UserstateField
class | WorkflowComponentSectionsField
class | WorkflowconditionField
class | WorkflowstageField

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Form\Filter

  • Joomla
  • CMS
  • Form
  • Filter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Form\Filter

Structures de données

class | IntarrayFilter
class | RawFilter
class | RulesFilter
class | SafehtmlFilter
class | TelFilter
class | UnsetFilter
class | UrlFilter

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Form\Rule

  • Joomla
  • CMS
  • Form
  • Rule
Structures de données
Référence de l'espace de nommage Joomla\CMS\Form\Rule

Structures de données

class | BooleanRule
class | CalendarRule
class | CaptchaRule
class | ColorRule
class | CssIdentifierRule
class | CssIdentifierSubstringRule
class | EmailRule
class | EqualsRule
class | ExistsRule
class | FilePathRule
class | FolderPathExistsRule
class | ModuleLayoutRule
class | NotequalsRule
class | NumberRule
class | OptionsRule
class | PasswordRule
class | RulesRule
class | SubformRule
class | TelRule
class | TimeRule
class | UrlRule
class | UserIdRule
class | UsernameRule

Description détaillée

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Help

  • Joomla
  • CMS
  • Help
Structures de données
Référence de l'espace de nommage Joomla\CMS\Help

Structures de données

class Help

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Helper

  • Joomla
  • CMS
  • Helper
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Helper

Structures de données

class | AuthenticationHelper
class | CMSHelper
class | ContentHelper
class | HelperFactory
interface | HelperFactoryAwareInterface
interface | HelperFactoryInterface
class | LibraryHelper
class | MediaHelper
class | ModuleHelper
class | RouteHelper
class | TagsHelper
class | UserGroupsHelper

Fonctions

getHelperFactory ()
setHelperFactory (HelperFactory $helperFactory)

Variables

trait HelperFactoryAwareTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getHelperFactory()

Joomla\CMS\Helper\getHelperFactory ( )

Get the HelperFactory.

Renvoie
HelperFactory
Depuis
4.2.0
Exceptions

Références $helper.

Référencé par Dispatcher\getLayoutData().

◆ setHelperFactory()

Joomla\CMS\Helper\setHelperFactory ( HelperFactory $helperFactory )

Sets the helper factory to use.

Paramètres
HelperFactory $helperFactory The helper factory to use.
Renvoie
void
Depuis
4.2.0

Documentation des variables

◆ HelperFactoryAwareTrait

trait HelperFactoryAwareTrait
Valeur initiale :
{
private $helperFactory

Defines the trait for a HelperFactory Aware Class.

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\HTML

  • Joomla
  • CMS
  • HTML
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\HTML

Espaces de nommage

Helpers

Structures de données

class | HTMLHelper
class | Registry

Fonctions

getRegistry ()
setRegistry (Registry $registry=null)

Variables

trait HTMLRegistryAwareTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getRegistry()

Joomla\CMS\HTML\getRegistry ( )

Get the registry.

Renvoie
Registry
Depuis
4.0.0
Exceptions

Référencé par CategoriesComponent\boot(), LanguagesComponent\boot(), MessagesComponent\boot(), ModulesComponent\boot(), RedirectComponent\boot(), TemplatesComponent\boot(), InstallerComponent\boot(), PrivacyComponent\boot(), AdminComponent\boot(), MenusComponent\boot(), UsersComponent\boot(), FinderComponent\boot(), BannersComponent\boot(), NewsfeedsComponent\boot(), ContactComponent\boot(), ContentComponent\boot(), et WebAssetManager\getManagerState().

◆ setRegistry()

Joomla\CMS\HTML\setRegistry ( Registry $registry = null )

Set the registry to use.

Paramètres
Registry $registry The registry
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ HTMLRegistryAwareTrait

trait HTMLRegistryAwareTrait
Valeur initiale :
{
private $registry

Defines the trait for a HTML Registry aware class.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\HTML\Helpers

  • Joomla
  • CMS
  • HTML
  • Helpers
Structures de données
Référence de l'espace de nommage Joomla\CMS\HTML\Helpers

Structures de données

class | Access
class | ActionsDropdown
class | AdminLanguage
class | Behavior
class | Bootstrap
class | Category
class | Content
class | ContentLanguage
class | Date
class | Debug
class | DraggableList
class | Dropdown
class | Email
class | Form
class | FormBehavior
class | Grid
class | Icons
class | JGrid
class | Jquery
class | Links
class | ListHelper
class | Menu
class | Number
class | SearchTools
class | Select
class | Sidebar
class | SortableList
class | StringHelper
class | Tag
class | Telephone
class | UiTab
class | User
class | WorkflowStage

Description détaillée

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Http

  • Joomla
  • CMS
  • Http
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Http

Espaces de nommage

Transport

Structures de données

class | Http
class | HttpFactory
class | Response
interface | TransportInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Http\Transport

  • Joomla
  • CMS
  • Http
  • Transport
Structures de données
Référence de l'espace de nommage Joomla\CMS\Http\Transport

Structures de données

class | CurlTransport
class | SocketTransport
class | StreamTransport

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Image

  • Joomla
  • CMS
  • Image
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Image

Espaces de nommage

Exception
Filter

Structures de données

class | Image
class | ImageFilter

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Image\Exception

  • Joomla
  • CMS
  • Image
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Image\Exception

Structures de données

class UnparsableImageException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Image\Filter

  • Joomla
  • CMS
  • Image
  • Filter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Image\Filter

Structures de données

class | Backgroundfill
class | Brightness
class | Contrast
class | Edgedetect
class | Emboss
class | Grayscale
class | Negate
class | Sketchy
class | Smooth

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Input

  • Joomla
  • CMS
  • Input
Structures de données
Référence de l'espace de nommage Joomla\CMS\Input

Structures de données

class | Cli
class | Cookie
class | Files
class | Input
class | Json

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation

  • Joomla
  • CMS
  • Installation
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Installation

Espaces de nommage

Application
Controller
Error
Form
Helper
Model
Response
Router
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Application

  • Joomla
  • CMS
  • Installation
  • Application
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Application

Structures de données

class InstallationApplication


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Controller

  • Joomla
  • CMS
  • Installation
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Controller

Structures de données

class | DisplayController
class | InstallationController
class | JSONController
class | LanguageController


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Error

  • Joomla
  • CMS
  • Installation
  • Error
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Installation\Error

Espaces de nommage

Renderer


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Error\Renderer

  • Joomla
  • CMS
  • Installation
  • Error
  • Renderer
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Error\Renderer

Structures de données

class JsonRenderer


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Form

  • Joomla
  • CMS
  • Installation
  • Form
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Installation\Form

Espaces de nommage

Field
Rule


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Form\Field

  • Joomla
  • CMS
  • Installation
  • Form
  • Field
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Installation\Form\Field

Espaces de nommage

Installation


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Form\Field\Installation

  • Joomla
  • CMS
  • Installation
  • Form
  • Field
  • Installation
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Form\Field\Installation

Structures de données

class | LanguageField
class | PrefixField


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Form\Rule

  • Joomla
  • CMS
  • Installation
  • Form
  • Rule
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Form\Rule

Structures de données

class | PrefixRule
class | UsernameRule


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Helper

  • Joomla
  • CMS
  • Installation
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Helper

Structures de données

class DatabaseHelper


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Model

  • Joomla
  • CMS
  • Installation
  • Model
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Model

Structures de données

class | BaseInstallationModel
class | ChecksModel
class | CleanupModel
class | ConfigurationModel
class | DatabaseModel
class | LanguagesModel
class | SetupModel


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Response

  • Joomla
  • CMS
  • Installation
  • Response
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Response

Structures de données

class JsonResponse


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Router

  • Joomla
  • CMS
  • Installation
  • Router
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Router

Structures de données

class InstallationRouter


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Service

  • Joomla
  • CMS
  • Installation
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Installation\Service

Espaces de nommage

Provider


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\Service\Provider

  • Joomla
  • CMS
  • Installation
  • Service
  • Provider
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\Service\Provider

Structures de données

class Application


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\View

  • Joomla
  • CMS
  • Installation
  • View
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\View

Espaces de nommage

Error
Preinstall
Remove
Setup

Structures de données

class DefaultView


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\View\Error

  • Joomla
  • CMS
  • Installation
  • View
  • Error
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\View\Error

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\View\Preinstall

  • Joomla
  • CMS
  • Installation
  • View
  • Preinstall
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\View\Preinstall

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\View\Remove

  • Joomla
  • CMS
  • Installation
  • View
  • Remove
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\View\Remove

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installation\View\Setup

  • Joomla
  • CMS
  • Installation
  • View
  • Setup
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installation\View\Setup

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installer

  • Joomla
  • CMS
  • Installer
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Installer

Espaces de nommage

Adapter
Manifest

Structures de données

class | Installer
class | InstallerAdapter
class | InstallerExtension
class | InstallerHelper
class | InstallerScript
interface | InstallerScriptInterface
class | LegacyInstallerScript
class | Manifest

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installer\Adapter

  • Joomla
  • CMS
  • Installer
  • Adapter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installer\Adapter

Structures de données

class | ComponentAdapter
class | FileAdapter
class | LanguageAdapter
class | LibraryAdapter
class | ModuleAdapter
class | PackageAdapter
class | PluginAdapter
class | TemplateAdapter

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Installer\Manifest

  • Joomla
  • CMS
  • Installer
  • Manifest
Structures de données
Référence de l'espace de nommage Joomla\CMS\Installer\Manifest

Structures de données

class | LibraryManifest
class | PackageManifest

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Language

  • Joomla
  • CMS
  • Language
Structures de données
Référence de l'espace de nommage Joomla\CMS\Language

Structures de données

class | Associations
class | CachingLanguageFactory
class | Language
class | LanguageFactory
interface | LanguageFactoryInterface
class | LanguageHelper
class | Multilanguage
class | Text
class | Transliterate

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Layout

  • Joomla
  • CMS
  • Layout
Structures de données
Référence de l'espace de nommage Joomla\CMS\Layout

Structures de données

class | BaseLayout
class | FileLayout
class | LayoutHelper
interface | LayoutInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Log

  • Joomla
  • CMS
  • Log
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Log

Espaces de nommage

Logger

Structures de données

class | DelegatingPsrLogger
class | Log
class | LogEntry
class | Logger
class | LoggerRegistry

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Log\Logger

  • Joomla
  • CMS
  • Log
  • Logger
Structures de données
Référence de l'espace de nommage Joomla\CMS\Log\Logger

Structures de données

class | CallbackLogger
class | DatabaseLogger
class | EchoLogger
class | FormattedtextLogger
class | InMemoryLogger
class | MessagequeueLogger
class | SyslogLogger
class | W3cLogger

Description détaillée

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Mail

  • Joomla
  • CMS
  • Mail
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Mail

Espaces de nommage

Exception

Structures de données

class | Mail
class | MailHelper
class | MailTemplate

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Mail\Exception

  • Joomla
  • CMS
  • Mail
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Mail\Exception

Structures de données

class MailDisabledException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Menu

  • Joomla
  • CMS
  • Menu
Structures de données
Référence de l'espace de nommage Joomla\CMS\Menu

Structures de données

class | AbstractMenu
class | AdministratorMenu
class | AdministratorMenuItem
class | MenuFactory
interface | MenuFactoryInterface
class | MenuItem
class | SiteMenu

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Microdata

  • Joomla
  • CMS
  • Microdata
Structures de données
Référence de l'espace de nommage Joomla\CMS\Microdata

Structures de données

class Microdata

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC

  • Joomla
  • CMS
  • MVC
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\MVC

Espaces de nommage

Controller
Factory
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\Controller

  • Joomla
  • CMS
  • MVC
  • Controller
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\MVC\Controller

Espaces de nommage

Exception

Structures de données

class | AdminController
class | ApiController
class | BaseController
interface | ControllerInterface
class | FormController

Description détaillée

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\Controller\Exception

  • Joomla
  • CMS
  • MVC
  • Controller
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\MVC\Controller\Exception

Structures de données

class | CheckinCheckout
class | ResourceNotFound
class | Save
class | SendEmail

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\Factory

  • Joomla
  • CMS
  • MVC
  • Factory
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\MVC\Factory

Structures de données

class | ApiMVCFactory
class | LegacyFactory
class | MVCFactory
interface | MVCFactoryInterface
interface | MVCFactoryServiceInterface

Fonctions

getMVCFactory ()
setMVCFactory (MVCFactoryInterface $mvcFactory)

Variables

trait | MVCFactoryAwareTrait
trait | MVCFactoryServiceTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getMVCFactory()

getMVCFactory ( )
protected

Returns the MVC factory.

Renvoie
MVCFactoryInterface
Depuis
4.0.0
Exceptions

Référencé par BaseDatabaseModel\_createTable(), BaseDatabaseModel\getTable(), et Joomla\CMS\Workflow\isWorkflowActive().

◆ setMVCFactory()

setMVCFactory ( MVCFactoryInterface $mvcFactory )

Set the MVC factory.

Paramètres
MVCFactoryInterface $mvcFactory The MVC factory
Renvoie
void
Depuis
4.0.0

The MVC Factory.

Paramètres
MVCFactoryInterface $mvcFactory The factory
Renvoie
void
Depuis
4.0.0

Référencé par BaseDatabaseModel\__construct().

Documentation des variables

◆ MVCFactoryAwareTrait

trait MVCFactoryAwareTrait
Valeur initiale :
{
private $mvcFactory

MVCFactory aware trait.

Depuis
4.0.0

◆ MVCFactoryServiceTrait

trait MVCFactoryServiceTrait
Valeur initiale :
{
private $mvcFactory

Defines the trait for a MVC factory service class.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\Model

  • Joomla
  • CMS
  • MVC
  • Model
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\MVC\Model

Structures de données

class | AdminModel
class | BaseDatabaseModel
class | BaseModel
interface | DatabaseModelInterface
class | FormModel
interface | FormModelInterface
class | ItemModel
interface | ItemModelInterface
class | ListModel
interface | ListModelInterface
interface | ModelInterface
interface | StatefulModelInterface
interface | WorkflowModelInterface

Fonctions

getDbo ()
setDbo (DatabaseInterface $db=null)
loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=null)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
getFormFactory ()
getState ($property=null, $default=null)
setState ($property, $value=null)
populateState ()
setUpWorkflow ($extension)
enableWorkflowBatch ()
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
batchWorkflowStage (int $value, array $pks, array $contexts)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
importWorkflowPlugins ()
addTransitionField (Form $form, $data)
getStageForNewItem (Form $form, $data)

Variables

trait | DatabaseAwareTrait
trait | FormBehaviorTrait
trait | StateBehaviorTrait
$state = null
trait | WorkflowBehaviorTrait
$section = ''
$workflowEnabled = false
$workflow

Description détaillée

Joomla! Content Management System

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ addTransitionField()

Joomla\CMS\MVC\Model\addTransitionField | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Adds a transition field to the form. Can be overwritten by the child class if not needed

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
Renvoie
void
Depuis
4.0.0

Références $assoc, $data, $extension, $field, $form, $id, $key, extension, et Joomla\CMS\MVC\Model\getStageForNewItem().

Référencé par Joomla\CMS\MVC\Model\workflowPreprocessForm().

◆ batchWorkflowStage()

Joomla\CMS\MVC\Model\batchWorkflowStage | ( | int | $value,
 |  | array | $pks,
 |  | array | $contexts
 | ) |  |

Batch change workflow stage or current.

Paramètres
integer | $value | The workflow stage ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
mixed An array of new IDs on success, boolean false on failure.
Depuis
4.0.0

Références $this, $user, $value, Joomla\CMS\MVC\Model\$workflow, Text\_(), Factory\getApplication(), et Text\sprintf().

◆ enableWorkflowBatch()

Joomla\CMS\MVC\Model\enableWorkflowBatch ( )
protected

Add the workflow batch to the command list. Can be overwritten bei the child class

Renvoie
void
Depuis
4.0.0

Références $this.

Référencé par Joomla\CMS\MVC\Model\setUpWorkflow().

◆ executeTransition()

Joomla\CMS\MVC\Model\executeTransition | ( | array | $pks,
 |  | int | $transitionId
 | ) |  |

Runs transition for item.

Paramètres
array | $pks | Id of items to execute the transition
integer | $transitionId | Id of transition
Renvoie
boolean
Depuis
4.0.0

Références $app, $result, Text\_(), et Factory\getApplication().

Référencé par Joomla\CMS\MVC\Model\workflowAfterSave().

◆ getDbo()

Joomla\CMS\MVC\Model\getDbo ( )

Get the database driver.

Renvoie
DatabaseInterface The database driver.
Depuis
4.0.0
Exceptions

Référencé par BaseDatabaseModel\__get(), BaseDatabaseModel\_createTable(), TransitionTable\_getAssetName(), StageTable\_getAssetName(), TransitionTable\_getAssetParentId(), GroupTable\_getAssetParentId(), StageTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), BaseDatabaseModel\_getList(), BaseDatabaseModel\_getListCount(), admin_postinstall_languageaccess340_condition(), MfaTable\afterDelete(), UpdateModel\applyUpdateSite(), AdminModel\batchCopy(), Usergroup\check(), LinkTable\check(), StageTable\check(), WorkflowTable\check(), JoomlaInstallerScript\clearStatsCache(), JoomlaInstallerScript\convertTablesToUtf8mb4(), HtmlDocument\countMenuChildren(), MenuTable\delete(), StageTable\delete(), WorkflowTable\delete(), CoreContent\delete(), MenuType\delete(), AdminModel\delete(), CoreContent\deleteByContentId(), JoomlaInstallerScript\dropUtf8ConversionTable(), UpdateModel\finaliseUpgrade(), FieldTable\getAssetId(), UpdateModel\getCheckForSelfUpdate(), AssociationsHelper\getLanguagefilterPluginId(), ContentHelper\getLanguageId(), ListModel\getListQuery(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), MfaTable\getNumRecords(), UpdateModel\getUpdateInformation(), Updater\getUpdateSites(), UpdateModel\getUpdateSitesInfo(), httpheaders_postinstall_action(), UpdateModel\isTemplateActive(), PlgContentPagenavigation\onContentBeforeDisplay(), JoomlaInstallerScript\postflight(), UpdateModel\purge(), AdminModel\save(), Language\store(), ContentType\store(), ContactTable\store(), ContentHistory\store(), MenuType\store(), FilterTable\store(), TagTable\store(), Menu\store(), WorkflowTable\store(), StageTable\store(), Category\store(), Content\store(), CoreContent\storeUcmBase(), MfaTable\switchDefaultRecord(), JoomlaInstallerScript\uninstallEosPlugin(), JoomlaInstallerScript\updateContentTypes(), JoomlaInstallerScript\updateDatabase(), JoomlaInstallerScript\updateDatabaseMysql(), et JoomlaInstallerScript\updateManifestCaches().

◆ getFormFactory()

Joomla\CMS\MVC\Model\getFormFactory ( )
abstract

Get the FormFactoryInterface.

Renvoie
FormFactoryInterface
Depuis
4.0.0
Exceptions

Référencé par Joomla\CMS\MVC\Model\loadForm(), et MVCFactory\setFormFactoryOnObject().

◆ getStageForNewItem()

Joomla\CMS\MVC\Model\getStageForNewItem | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Try to load a workflow stage for newly created items which does not have a workflow assigned yet. If the category is not the carrier, overwrite it on your model and deliver your own carrier.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
Renvoie
boolean|integer An integer, holding the stage ID or false
Depuis
4.0.0

Références $data, $field, $form, null, et value.

Référencé par Joomla\CMS\MVC\Model\addTransitionField(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ getState()

Joomla\CMS\MVC\Model\getState | ( | $property = null,
 |  | $default = null
 | ) |

Method to get state variables.

Paramètres
string | $property | Optional parameter name
mixed | $default | Optional default value
Renvoie
mixed The property where specified, the state object where omitted
Depuis
4.0.0

Références $default, null, et Joomla\CMS\MVC\Model\populateState().

Référencé par InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), TasksModel\_getList(), ContactModel\buildContactExtendedData(), AdminModel\checkin(), TemplateModel\checkNewName(), AdminModel\checkout(), TemplateModel\child(), TemplateModel\cleanup(), BannerModel\click(), TemplateModel\copy(), TemplateModel\copyStyles(), TracksModel\delete(), OverridesModel\delete(), MediumModel\delete(), TemplateModel\fixTemplateName(), UserModel\getAssignedGroups(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), TracksModel\getBaseName(), CategoryModel\getCategory(), TracksModel\getCategoryName(), CategoryModel\getChildren(), InstalledModel\getClient(), TracksModel\getClientName(), ComponentModel\getComponent(), TracksModel\getContent(), ProfileModel\getData(), CacheModel\getData(), InstalledModel\getData(), DebuguserModel\getDebugActions(), DebuggroupModel\getDebugActions(), ModulesModel\getEmptyStateQuery(), CategoriesModel\getEmptyStateQuery(), TracksModel\getFileType(), FilterModel\getFilter(), WorkflowsModel\getFilterForm(), TransitionsModel\getFilterForm(), FieldsModel\getFilterForm(), MenutypesModel\getFolders(), OverrideModel\getForm(), FormModel\getForm(), ComponentModel\getForm(), GroupModel\getForm(), ContactModel\getForm(), MenuModel\getForm(), TaskModel\getForm(), CategoryModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), ItemModel\getForm(), DebuggroupModel\getGroup(), AdapterModel\getItem(), MediumModel\getItem(), ConfigModel\getItem(), NewsfeedModel\getItem(), ArticleModel\getItem(), FormModel\getItem(), OverrideModel\getItem(), UserModel\getItem(), LanguageModel\getItem(), TagModel\getItem(), MessageModel\getItem(), MenuModel\getItem(), TemplateModel\getItem(), PluginModel\getItem(), ContactModel\getItem(), CategoryModel\getItem(), StyleModel\getItem(), GroupModel\getItem(), FieldModel\getItem(), ItemModel\getItem(), ModuleModel\getItem(), AdminModel\getItem(), MediaModel\getItems(), DebuguserModel\getItems(), DebuggroupModel\getItems(), PositionsModel\getItems(), FeaturedModel\getItems(), CategoryModel\getItems(), SelectModel\getItems(), UsersModel\getItems(), CheckinModel\getItems(), ListModel\getItems(), BannersModel\getItems(), TagsModel\getItems(), CategoriesModel\getItems(), ArticlesModel\getItems(), LanguagesModel\getLanguages(), RequestsModel\getListQuery(), FiltersModel\getListQuery(), ConsentsModel\getListQuery(), SuggestionsModel\getListQuery(), NotesModel\getListQuery(), FeaturedModel\getListQuery(), SelectModel\getListQuery(), ActionlogsModel\getListQuery(), ArchiveModel\getListQuery(), TracksModel\getListQuery(), DiscoverModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), LevelsModel\getListQuery(), SearchesModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), TemplatesModel\getListQuery(), StylesModel\getListQuery(), GroupsModel\getListQuery(), StagesModel\getListQuery(), TransitionsModel\getListQuery(), SearchModel\getListQuery(), LinksModel\getListQuery(), FieldsModel\getListQuery(), TagModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), MenusModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), MapsModel\getListQuery(), IndexModel\getListQuery(), DebuguserModel\getListQuery(), PluginsModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), HistoryModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), ActionlogsModel\getLogsForItem(), TemplateModel\getMaster(), TracksModel\getMimeType(), MenusModel\getModMenuId(), ItemModel\getModules(), InstalledModel\getOption(), OverridesModel\getOverrides(), MethodModel\getPageTitle(), CacheModel\getPagination(), ListModel\getPagination(), FormModel\getReturnPage(), Indexer\getSignature(), TemplateModel\getSource(), ListModel\getStart(), ArticlesModel\getStart(), SelectModel\getStoreId(), ClientsModel\getStoreId(), SearchesModel\getStoreId(), TasksModel\getStoreId(), LevelsModel\getStoreId(), MessagesModel\getStoreId(), PluginsModel\getStoreId(), StylesModel\getStoreId(), GroupsModel\getStoreId(), FiltersModel\getStoreId(), CacheModel\getStoreId(), LinksModel\getStoreId(), FieldsModel\getStoreId(), ContactsModel\getStoreId(), RequestsModel\getStoreId(), NewsfeedsModel\getStoreId(), TagsModel\getStoreId(), SuggestionsModel\getStoreId(), ConsentsModel\getStoreId(), InstalledModel\getStoreId(), UsersModel\getStoreId(), AssociationsModel\getStoreId(), CategoriesModel\getStoreId(), FeaturedModel\getStoreId(), ModulesModel\getStoreId(), DebuggroupModel\getStoreId(), DebuguserModel\getStoreId(), NotesModel\getStoreId(), TemplatesModel\getStoreId(), ArticlesModel\getStoreId(), ItemsModel\getStoreId(), LanguagesModel\getStoreId(), BannersModel\getStoreId(), MapsModel\getStoreId(), IndexModel\getStoreId(), SearchModel\getStoreId(), ListModel\getStoreId(), UpdatesitesModel\getStoreId(), TemplateModel\getTemplate(), TemplateModel\getTemplateList(), MenutypesModel\getTypeOptionsByComponent(), MenutypesModel\getTypeOptionsFromLayouts(), TemplateModel\getUpdatedList(), DebuguserModel\getUser(), NotesModel\getUser(), StagesModel\getWorkflow(), TransitionsModel\getWorkflow(), NewsfeedModel\hit(), ArticleModel\hit(), ContactModel\hit(), CategoryModel\hit(), Indexer\index(), DownloadModel\loadFormData(), NoteModel\loadFormData(), ComponentModel\loadFormData(), NewsfeedModel\loadFormData(), BannerModel\loadFormData(), ContactModel\loadFormData(), ListModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), Adapter\onBeforeIndex(), Adapter\onBuildIndex(), Adapter\onStartIndex(), ModulesModel\preprocessForm(), PluginModel\preprocessForm(), FormModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ItemsModel\preprocessForm(), ModuleModel\preprocessForm(), ItemModel\preprocessForm(), PublishedButton\render(), FeaturedButton\render(), ActionButton\render(), LevelsModel\reorder(), WorkflowModel\save(), StageModel\save(), MediumModel\save(), FieldModel\save(), ConfigModel\save(), OverrideModel\save(), TransitionModel\save(), LanguageModel\save(), UserModel\save(), MenuModel\save(), ProfileModel\save(), TemplateModel\save(), RequestModel\save(), StyleModel\save(), CategoryModel\save(), TaskModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), ModulesModel\translate(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ importWorkflowPlugins()

Joomla\CMS\MVC\Model\importWorkflowPlugins ( )
protected

Import the Workflow plugins.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
Renvoie
void

Références PluginHelper\importPlugin().

Référencé par Joomla\CMS\MVC\Model\workflowBeforeSave(), Joomla\CMS\MVC\Model\workflowBeforeStageChange(), Joomla\CMS\MVC\Model\workflowCleanupBatchMove(), et Joomla\CMS\MVC\Model\workflowPreprocessForm().

◆ loadForm()

Joomla\CMS\MVC\Model\loadForm | ( | $name,
 |  | $source = null,
 |  | $options = array(),
 |  | $clear = false,
 |  | $xpath = null
 | ) |
protected

Method to get a form object.

Paramètres
string | $name | The name of the form.
string | $source | The form source. Can be XML string if file flag is set to false.
array | $options | Optional array of options for the form creation.
boolean | $clear | Optional argument to force load a new form.
string | $xpath | An optional xpath to search for the fields.
Renvoie
Form
Voir également
Form
Depuis
4.0.0
Exceptions

Références $data, $form, $hash, $name, $options, Form\addFieldPath(), Form\addFormPath(), class, Factory\getContainer(), Joomla\CMS\MVC\Model\getFormFactory(), ArrayHelper\getValue(), Joomla\CMS\MVC\Model\loadFormData(), et Joomla\CMS\MVC\Model\preprocessForm().

Référencé par ListModel\getFilterForm(), AssociationModel\getForm(), FileModel\getForm(), OverrideModel\getForm(), LoginModel\getForm(), MailModel\getForm(), ResetModel\getForm(), NoteModel\getForm(), UpdatesiteModel\getForm(), TemplatesModel\getForm(), ModulesModel\getForm(), DownloadModel\getForm(), LinkModel\getForm(), RequestModel\getForm(), ApplicationModel\getForm(), ComponentModel\getForm(), TemplateModel\getForm(), PluginModel\getForm(), ClientModel\getForm(), GroupModel\getForm(), FilterModel\getForm(), ConfigModel\getForm(), NewsfeedModel\getForm(), ProfileModel\getForm(), UserModel\getForm(), RemindModel\getForm(), LanguageModel\getForm(), WorkflowModel\getForm(), TagModel\getForm(), TaskModel\getForm(), MenuModel\getForm(), ContactModel\getForm(), ConfirmModel\getForm(), LevelModel\getForm(), BannerModel\getForm(), MessageModel\getForm(), StageModel\getForm(), TransitionModel\getForm(), CategoryModel\getForm(), StyleModel\getForm(), RegistrationModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), ItemModel\getForm(), ModuleModel\getForm(), ResetModel\getResetCompleteForm(), et ResetModel\getResetConfirmForm().

◆ loadFormData()

Joomla\CMS\MVC\Model\loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
4.0.0

Référencé par ProfileModel\getForm(), ItemModel\getForm(), UpdateModel\getForm(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), et PluginsModel\loadFormData().

◆ populateState()

Joomla\CMS\MVC\Model\populateState ( )
protected

Method to auto-populate the state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the configuration flag to ignore the request is set.

Renvoie
void
Note
Calling getState in this method will result in recursion.
Depuis
4.0.0

Référencé par Joomla\CMS\MVC\Model\getState(), StageModel\populateState(), TransitionModel\populateState(), WorkflowModel\populateState(), ArchiveModel\populateState(), MenutypesModel\populateState(), MessageModel\populateState(), SearchesModel\populateState(), InstallModel\populateState(), ClientsModel\populateState(), PositionsModel\populateState(), StagesModel\populateState(), StylesModel\populateState(), LevelsModel\populateState(), CheckinModel\populateState(), TransitionsModel\populateState(), TemplatesModel\populateState(), DiscoverModel\populateState(), MessagesModel\populateState(), WorkflowsModel\populateState(), PluginsModel\populateState(), ActionlogsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), TracksModel\populateState(), ManageModel\populateState(), FeaturedModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), NewsfeedsModel\populateState(), FieldsModel\populateState(), GroupsModel\populateState(), ItemsModel\populateState(), CacheModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), InstalledModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ArticlesModel\populateState(), FiltersModel\populateState(), NoteModel\populateState(), RequestsModel\populateState(), ConsentsModel\populateState(), OverridesModel\populateState(), GroupModel\populateState(), MenusModel\populateState(), NotesModel\populateState(), PluginModel\populateState(), LanguagesModel\populateState(), DatabaseModel\populateState(), BannersModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), IndexModel\populateState(), TemplateModel\populateState(), TasksModel\populateState(), et UpdatesitesModel\populateState().

◆ preprocessData()

Joomla\CMS\MVC\Model\preprocessData | ( |  | $context,
 |  | & | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the data.

Paramètres
string | $context | The context identifier.
mixed | &$data | The data to be processed. It gets altered directly.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
4.0.0

Références $context, $data, Factory\getApplication(), et PluginHelper\importPlugin().

Référencé par ConfigModel\getItem(), LoginModel\loadFormData(), MailModel\loadFormData(), UpdatesiteModel\loadFormData(), OverrideModel\loadFormData(), DownloadModel\loadFormData(), NoteModel\loadFormData(), LinkModel\loadFormData(), ClientModel\loadFormData(), FilterModel\loadFormData(), PluginModel\loadFormData(), NewsfeedModel\loadFormData(), LanguageModel\loadFormData(), ProfileModel\loadFormData(), UserModel\loadFormData(), MenuModel\loadFormData(), TagModel\loadFormData(), LevelModel\loadFormData(), BannerModel\loadFormData(), MessageModel\loadFormData(), ContactModel\loadFormData(), TemplateModel\loadFormData(), GroupModel\loadFormData(), StyleModel\loadFormData(), CategoryModel\loadFormData(), RegistrationModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), et FieldModel\loadFormData().

◆ preprocessForm()

Joomla\CMS\MVC\Model\preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Voir également
FormField
Depuis
4.0.0
Exceptions

Références $data, $form, Factory\getApplication(), et PluginHelper\importPlugin().

Référencé par TemplatesModel\getForm(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), RemindModel\preprocessForm(), ModulesModel\preprocessForm(), MailModel\preprocessForm(), TemplatesModel\preprocessForm(), LoginModel\preprocessForm(), ResetModel\preprocessForm(), ProfileModel\preprocessForm(), UserModel\preprocessForm(), FormModel\preprocessForm(), LevelModel\preprocessForm(), WorkflowModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), TransitionModel\preprocessForm(), BannerModel\preprocessForm(), StageModel\preprocessForm(), RegistrationModel\preprocessForm(), NewsfeedModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ModuleModel\preprocessForm(), TaskModel\preprocessForm(), FieldModel\preprocessForm(), ArticleModel\preprocessForm(), et ItemModel\preprocessForm().

◆ setDbo()

Joomla\CMS\MVC\Model\setDbo ( DatabaseInterface $db = null )

Set the database driver.

Paramètres
DatabaseInterface $db The database driver.
Renvoie
void
Depuis
4.0.0
Obsolète:
5.0 Use the trait from the database package

Références $db.

Référencé par BaseDatabaseModel\__construct().

◆ setState()

Joomla\CMS\MVC\Model\setState | ( | $property,
 |  | $value = null
 | ) |

Method to set state variables.

Paramètres
string | $property | The name of the property
mixed | $value | The value of the property to set or null
Renvoie
mixed The previous value of the property or null if not set
Depuis
4.0.0

Références $value, et null.

Référencé par InstallerModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), DiscoverModel\discover_install(), DatabaseModel\fetchSchemaCache(), PluginModel\getForm(), GroupModel\getForm(), ProfileModel\getForm(), CategoryModel\getForm(), StyleModel\getForm(), FieldModel\getForm(), ItemModel\getForm(), ModuleModel\getForm(), ItemModel\getItem(), PositionsModel\getItems(), FeaturedModel\getItems(), BannersModel\getItems(), TagsModel\getListQuery(), InstallModel\install(), UpdateModel\install(), ItemModel\loadFormData(), Adapter\onBuildIndex(), Adapter\onStartIndex(), LoginModel\populateState(), StageModel\populateState(), TransitionModel\populateState(), WorkflowModel\populateState(), ConfigModel\populateState(), DownloadModel\populateState(), SelectModel\populateState(), MessagesModel\populateState(), NewsfeedModel\populateState(), ArchiveModel\populateState(), ArticleModel\populateState(), MessageModel\populateState(), SearchesModel\populateState(), InstallModel\populateState(), ClientsModel\populateState(), PositionsModel\populateState(), StagesModel\populateState(), StylesModel\populateState(), LevelsModel\populateState(), TemplatesModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), WorkflowsModel\populateState(), PluginsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), TracksModel\populateState(), ManageModel\populateState(), FeaturedModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), TagModel\populateState(), LanguageModel\populateState(), NewsfeedsModel\populateState(), FieldsModel\populateState(), GroupsModel\populateState(), CacheModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), StyleModel\populateState(), InstalledModel\populateState(), MenuModel\populateState(), CapabilitiesModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ModuleModel\populateState(), ArticlesModel\populateState(), FiltersModel\populateState(), NoteModel\populateState(), ResetModel\populateState(), RequestsModel\populateState(), SuggestionsModel\populateState(), ConsentsModel\populateState(), OverridesModel\populateState(), CategoryModel\populateState(), FormModel\populateState(), RemindModel\populateState(), RemoveModel\populateState(), GroupModel\populateState(), OverrideModel\populateState(), MenusModel\populateState(), ConfirmModel\populateState(), ProfileModel\populateState(), PluginModel\populateState(), TaskModel\populateState(), RequestModel\populateState(), LanguagesModel\populateState(), DatabaseModel\populateState(), BannersModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), ExportModel\populateState(), SearchModel\populateState(), IndexModel\populateState(), TemplateModel\populateState(), RegistrationModel\populateState(), UpdatesitesModel\populateState(), ListModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), AdminModel\populateState(), ManageModel\remove(), LanguageModel\save(), UserModel\save(), MenuModel\save(), MessageModel\save(), TemplateModel\save(), StyleModel\save(), CategoryModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), et UpdateModel\update().

◆ setUpWorkflow()

Joomla\CMS\MVC\Model\setUpWorkflow ( $extension )

Set Up the workflow

Paramètres
string $extension The option and section separated by.
Renvoie
void
Depuis
4.0.0

Références $extension, $params, $parts, Joomla\CMS\MVC\Model\enableWorkflowBatch(), extension, et ComponentHelper\getParams().

Référencé par ArticleModel\__construct().

◆ workflowAfterSave()

Joomla\CMS\MVC\Model\workflowAfterSave ( $data )

Executing of relevant workflow methods

Renvoie
void
Depuis
4.0.0

Références $data, $extension, $form, $id, $path, Form\addFieldPath(), Form\addFormPath(), Path\check(), Joomla\CMS\MVC\Model\executeTransition(), Joomla\CMS\MVC\Model\getStageForNewItem(), Joomla\CMS\MVC\Model\getState(), et JPATH_BASE.

◆ workflowBeforeSave()

Joomla\CMS\MVC\Model\workflowBeforeSave ( )

Preparation of workflow data/plugins

Renvoie
void
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\importWorkflowPlugins().

◆ workflowBeforeStageChange()

Joomla\CMS\MVC\Model\workflowBeforeStageChange ( )

Let plugins access stage change events

Renvoie
void
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\importWorkflowPlugins().

Référencé par ArticleModel\featured(), et ArticleModel\publish().

◆ workflowCleanupBatchMove()

Joomla\CMS\MVC\Model\workflowCleanupBatchMove | ( | $oldId,
 |  | $newId
 | ) |

Batch change workflow stage or current.

Paramètres
integer | $oldId | The ID of the item copied from
integer | $newId | The ID of the new item
Renvoie
null
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\importWorkflowPlugins().

Référencé par ArticleModel\cleanupPostBatchCopy().

◆ workflowPreprocessForm()

Joomla\CMS\MVC\Model\workflowPreprocessForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
Renvoie
void
Depuis
4.0.0
Voir également
FormField

Références $data, Joomla\CMS\MVC\Model\addTransitionField(), et Joomla\CMS\MVC\Model\importWorkflowPlugins().

Référencé par ArticleModel\preprocessForm().

Documentation des variables

◆ $section

$section = ''
protected

◆ $state

$state = null
protected

◆ $workflow

$workflow
protected

Référencé par PlgContentJoomla\_canDeleteStage(), TransitionTable\_getAssetName(), StageTable\_getAssetName(), TransitionTable\_getAssetParentId(), StageTable\_getAssetParentId(), PlgSampledataMultilang\addArticle(), Joomla\CMS\MVC\Model\batchWorkflowStage(), HtmlView\display(), PlgWorkflowPublishing\enhanceTransitionForm(), TransitionModel\getWorkflow(), Menu\preprocess(), CssMenu\preprocess(), StageModel\save(), et TransitionModel\save().

◆ $workflowEnabled

$workflowEnabled = false
protected

◆ DatabaseAwareTrait

trait DatabaseAwareTrait
Valeur initiale :
{
protected $_db

Database aware trait.

Depuis
4.0.0
Obsolète:
5.0 Use the trait from the database package

◆ FormBehaviorTrait

trait FormBehaviorTrait
Valeur initiale :
{
protected $_forms = array()

Trait which supports form behavior.

Depuis
4.0.0

◆ StateBehaviorTrait

trait StateBehaviorTrait
Valeur initiale :
{
protected $__state_set = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Trait which supports state behavior

Depuis
4.0.0

◆ WorkflowBehaviorTrait

trait WorkflowBehaviorTrait
Valeur initiale :
{
protected $extension = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80
$extension
$extension
Definition: administrator/components/com_categories/tmpl/categories/default.php:29

Trait which supports state behavior

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\View

  • Joomla
  • CMS
  • MVC
  • View
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\MVC\View

Espaces de nommage

Event

Structures de données

class | AbstractView
class | CategoriesView
class | CategoryFeedView
class | CategoryView
class | FormView
class | GenericDataException
class | HtmlView
class | JsonApiView
class | JsonView
class | ListView
interface | ViewInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\MVC\View\Event

  • Joomla
  • CMS
  • MVC
  • View
  • Event
Structures de données
Référence de l'espace de nommage Joomla\CMS\MVC\View\Event

Structures de données

class OnGetApiFields

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Object

  • Joomla
  • CMS
  • Object
Structures de données
Référence de l'espace de nommage Joomla\CMS\Object

Structures de données

class CMSObject

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Pagination

  • Joomla
  • CMS
  • Pagination
Structures de données
Référence de l'espace de nommage Joomla\CMS\Pagination

Structures de données

class | Pagination
class | PaginationObject

Description détaillée

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Pathway

  • Joomla
  • CMS
  • Pathway
Structures de données
Référence de l'espace de nommage Joomla\CMS\Pathway

Structures de données

class | Pathway
class | SitePathway

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Plugin

  • Joomla
  • CMS
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\CMS\Plugin

Structures de données

class | CMSPlugin
class | PluginHelper

Description détaillée

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Profiler

  • Joomla
  • CMS
  • Profiler
Structures de données
Référence de l'espace de nommage Joomla\CMS\Profiler

Structures de données

class Profiler

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Response

  • Joomla
  • CMS
  • Response
Structures de données
Référence de l'espace de nommage Joomla\CMS\Response

Structures de données

class JsonResponse

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Router

  • Joomla
  • CMS
  • Router
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Router

Espaces de nommage

Exception

Structures de données

class | AdministratorRouter
class | ApiRouter
class | Route
class | Router
class | SiteRouter
interface | SiteRouterAwareInterface

Fonctions

getSiteRouter ()
setSiteRouter (SiteRouter $router)

Variables

trait SiteRouterAwareTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getSiteRouter()

Joomla\CMS\Router\getSiteRouter ( )

Get the site router.

Renvoie
SiteRouter
Depuis
4.2.0
Exceptions

Référencé par HtmlView\display(), et MVCFactory\setRouterOnObject().

◆ setSiteRouter()

Joomla\CMS\Router\setSiteRouter ( SiteRouter $router )

Set the router to use.

Paramètres
SiteRouter $router The router to use.
Renvoie
void
Depuis
4.2.0

Documentation des variables

◆ SiteRouterAwareTrait

trait SiteRouterAwareTrait
Valeur initiale :
{
private $router

Defines the trait for a Site Router Aware Class.

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Router\Exception

  • Joomla
  • CMS
  • Router
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Router\Exception

Structures de données

class RouteNotFoundException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Schema

  • Joomla
  • CMS
  • Schema
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Schema

Espaces de nommage

ChangeItem

Structures de données

class | ChangeItem
class | ChangeSet

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Schema\ChangeItem

  • Joomla
  • CMS
  • Schema
  • ChangeItem
Structures de données
Référence de l'espace de nommage Joomla\CMS\Schema\ChangeItem

Structures de données

class | MysqlChangeItem
class | PostgresqlChangeItem
class | SqlsrvChangeItem

Description détaillée

Joomla! Content Management System

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Serializer

  • Joomla
  • CMS
  • Serializer
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Serializer

Espaces de nommage

Events

Structures de données

class JoomlaSerializer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Serializer\Events

  • Joomla
  • CMS
  • Serializer
  • Events
Structures de données
Référence de l'espace de nommage Joomla\CMS\Serializer\Events

Structures de données

class | OnGetApiAttributes
class | OnGetApiRelation

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Service

  • Joomla
  • CMS
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\CMS\Service

Espaces de nommage

Provider


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Service\Provider

  • Joomla
  • CMS
  • Service
  • Provider
Structures de données
Référence de l'espace de nommage Joomla\CMS\Service\Provider

Structures de données

class | Application
class | Authentication
class | CacheController
class | Config
class | Console
class | Database
class | Dispatcher
class | Document
class | Form
class | HTMLRegistry
class | Language
class | Logger
class | Menu
class | Pathway
class | Router
class | Session
class | Toolbar
class | User
class | WebAssetRegistry

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Session

  • Joomla
  • CMS
  • Session
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Session

Espaces de nommage

EventListener
Exception
Storage

Structures de données

class | MetadataManager
class | Session
class | SessionFactory
class | SessionManager

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
Copyright (C) 2005 - 2020 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Session\EventListener

  • Joomla
  • CMS
  • Session
  • EventListener
Structures de données
Référence de l'espace de nommage Joomla\CMS\Session\EventListener

Structures de données

class MetadataManagerListener

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Session\Exception

  • Joomla
  • CMS
  • Session
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\Session\Exception

Structures de données

class UnsupportedStorageException

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Session\Storage

  • Joomla
  • CMS
  • Session
  • Storage
Structures de données
Référence de l'espace de nommage Joomla\CMS\Session\Storage

Structures de données

class JoomlaStorage

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\String

  • Joomla
  • CMS
  • String
Structures de données
Référence de l'espace de nommage Joomla\CMS\String

Structures de données

class PunycodeHelper

Description détaillée

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Table

  • Joomla
  • CMS
  • Table
Structures de données
Référence de l'espace de nommage Joomla\CMS\Table

Structures de données

class | Asset
class | Category
class | Content
class | ContentHistory
class | ContentType
class | CoreContent
class | Extension
class | Language
class | Menu
class | MenuType
class | Module
class | Nested
class | Table
interface | TableInterface
class | Ucm
class | Update
class | UpdateSite
class | User
class | Usergroup
class | ViewLevel

Description détaillée

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Tag

  • Joomla
  • CMS
  • Tag
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Tag

Structures de données

interface | TaggableTableInterface
interface | TagServiceInterface

Fonctions

getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Variables

trait TaggableTableTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ clearTagsHelper()

Joomla\CMS\Tag\clearTagsHelper ( )

Clears the tags helper

Renvoie
void
Depuis
4.0.0

Références null.

◆ getTagsHelper()

Joomla\CMS\Tag\getTagsHelper ( )

Get the tags helper

Renvoie
TagsHelper The tags helper object
Depuis
4.0.0

◆ setTagsHelper()

Joomla\CMS\Tag\setTagsHelper ( TagsHelper $tagsHelper )

Set the tags helper

Paramètres
TagsHelper $tagsHelper The tags helper to be set
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ TaggableTableTrait

trait TaggableTableTrait
Valeur initiale :
{
public $tagsHelper

Defines the trait for a Taggable Table Class.

Depuis
3.10.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Toolbar

  • Joomla
  • CMS
  • Toolbar
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Toolbar

Espaces de nommage

Button

Structures de données

class | ContainerAwareToolbarFactory
class | Toolbar
class | ToolbarButton
interface | ToolbarFactoryInterface
class | ToolbarHelper

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Toolbar\Button

  • Joomla
  • CMS
  • Toolbar
  • Button
Structures de données
Référence de l'espace de nommage Joomla\CMS\Toolbar\Button

Structures de données

class | AbstractGroupButton
class | BasicButton
class | ConfirmButton
class | CustomButton
class | DropdownButton
class | HelpButton
class | InlinehelpButton
class | LinkButton
class | PopupButton
class | SeparatorButton
class | StandardButton

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Tree

  • Joomla
  • CMS
  • Tree
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Tree

Structures de données

interface | ImmutableNodeInterface
interface | NodeInterface

Fonctions

& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)
setParent (NodeInterface $parent)
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)

Variables

trait | ImmutableNodeTrait
$_children = array()
$_leftSibling = null
$_rightSibling = null
trait | NodeTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ addChild()

Joomla\CMS\Tree\addChild ( NodeInterface $child )

Add child to this node

If the child already has a parent, the link is unset

Paramètres
NodeInterface $child The child to be added.
Renvoie
void
Depuis
4.0.0

Références $this, et NodeInterface\setParent().

◆ getChildren()

& Joomla\CMS\Tree\getChildren ( $recursive = false )

Get the children of this node

Paramètres
boolean $recursive False by default
Renvoie
NodeInterface[] The children
Depuis
4.0.0

Références Joomla\CMS\Tree\$_children, et $items.

Référencé par CategoryNode\getNumItems().

◆ getParent()

Joomla\CMS\Tree\getParent ( )

Get the parent of this node

Renvoie
NodeInterface|null
Depuis
4.0.0

Référencé par Joomla\CMS\Tree\getRoot(), et Joomla\CMS\Tree\hasParent().

◆ getRoot()

Joomla\CMS\Tree\getRoot ( )

Get the root of the tree

Renvoie
ImmutableNodeInterface
Depuis
4.0.0

Références $root, $this, et Joomla\CMS\Tree\getParent().

◆ getSibling()

Joomla\CMS\Tree\getSibling ( $right = true )

Returns the right or left sibling of a node

Paramètres
boolean $right If set to false, returns the left sibling
Renvoie
NodeInterface|null NodeInterface object of the sibling.
Depuis
4.0.0

Références Joomla\CMS\Tree\$_leftSibling, et Joomla\CMS\Tree\$_rightSibling.

◆ hasChildren()

Joomla\CMS\Tree\hasChildren ( )

Test if this node has children

Renvoie
boolean True if there is a child
Depuis
4.0.0

◆ hasParent()

Joomla\CMS\Tree\hasParent ( )

Test if this node has a parent

Renvoie
boolean True if there is a parent
Depuis
4.0.0

Références Joomla\CMS\Tree\getParent(), et null.

◆ removeChild()

Joomla\CMS\Tree\removeChild ( NodeInterface $child )

Remove a specific child

Paramètres
NodeInterface $child Child to remove
Renvoie
void
Depuis
4.0.0

Références $key.

◆ setParent()

Joomla\CMS\Tree\setParent ( NodeInterface $parent )

Set the parent of this node

If the node already has a parent, the link is unset

Paramètres
NodeInterface | null $parent NodeInterface for the parent to be set or null
Renvoie
void
Depuis
4.0.0

Références $key, et $this.

◆ setSibling()

Joomla\CMS\Tree\setSibling | ( | NodeInterface | $sibling,
 |  |  | $right = true
 | ) |  |

Function to set the left or right sibling of a node

Paramètres
NodeInterface | $sibling | NodeInterface object for the sibling
boolean | $right | If set to false, the sibling is the left one
Renvoie
void
Depuis
4.0.0

Documentation des variables

◆ $_children

$_children = array()
protected

Référencé par Joomla\CMS\Tree\getChildren(), CategoryNode\getChildren(), et CategoryModel\getChildren().

◆ $_leftSibling

$_leftSibling = null
protected

Référencé par Joomla\CMS\Tree\getSibling(), et CategoryNode\getSibling().

◆ $_rightSibling

$_rightSibling = null
protected

Référencé par Joomla\CMS\Tree\getSibling(), et CategoryNode\getSibling().

◆ ImmutableNodeTrait

trait ImmutableNodeTrait
Valeur initiale :
{
protected $_parent = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Defines the trait for an Immutable Node Class.

Depuis
4.0.0

◆ NodeTrait

trait NodeTrait
Valeur initiale :
{
use ImmutableNodeTrait
Joomla\CMS\Tree\ImmutableNodeTrait
trait ImmutableNodeTrait
Definition: ImmutableNodeTrait.php:22

Defines the trait for a Node Interface Trait Class.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\UCM

  • Joomla
  • CMS
  • UCM
Structures de données
Référence de l'espace de nommage Joomla\CMS\UCM

Structures de données

interface | UCM
class | UCMBase
class | UCMContent
class | UCMType

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Updater

  • Joomla
  • CMS
  • Updater
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\Updater

Espaces de nommage

Adapter

Structures de données

class | DownloadSource
class | Update
class | UpdateAdapter
class | Updater

Description détaillée

Joomla! Content Management System

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Updater\Adapter

  • Joomla
  • CMS
  • Updater
  • Adapter
Structures de données
Référence de l'espace de nommage Joomla\CMS\Updater\Adapter

Structures de données

class | CollectionAdapter
class | ExtensionAdapter

Description détaillée

Joomla! Content Management System

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Uri

  • Joomla
  • CMS
  • Uri
Structures de données
Référence de l'espace de nommage Joomla\CMS\Uri

Structures de données

class Uri

Description détaillée

Joomla! Content Management System

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\User

  • Joomla
  • CMS
  • User
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\User

Structures de données

interface | CurrentUserInterface
class | User
class | UserFactory
interface | UserFactoryInterface
class | UserHelper

Fonctions

getCurrentUser ()
setCurrentUser (User $currentUser)

Variables

trait CurrentUserTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Documentation des fonctions

◆ getCurrentUser()

Joomla\CMS\User\getCurrentUser ( )
protected

Returns the current user, if none is set the identity of the global app is returned. This will change in 5.0 and an empty user will be returned.

Renvoie
User
Depuis
4.2.0

Références Factory\getApplication(), et Factory\getUser().

Référencé par HtmlView\addToolbar(), FormModel\checkin(), FormModel\checkout(), HtmlView\display(), HtmlView\getTagsTitle(), HtmlView\prepareDocument(), HtmlView\prepareToolbar(), et HtmlView\toolbar().

◆ setCurrentUser()

Joomla\CMS\User\setCurrentUser ( User $currentUser )

Sets the current user.

Paramètres
User $currentUser The current user object
Renvoie
void
Depuis
4.2.0

Documentation des variables

◆ CurrentUserTrait

trait CurrentUserTrait
Valeur initiale :
{
private $currentUser

Trait for classes which require a user to work with.

Depuis
4.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Utility

  • Joomla
  • CMS
  • Utility
Structures de données
Référence de l'espace de nommage Joomla\CMS\Utility

Structures de données

class | BufferStreamHandler
class | Utility

Description détaillée

Joomla! Content Management System

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Remove phpcs exception with deprecated autoloading BufferStreamHandler::stream_register(); :disable PSR1.Files.SideEffects

Joomla! Content Management System

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Versioning

  • Joomla
  • CMS
  • Versioning
Structures de données
Référence de l'espace de nommage Joomla\CMS\Versioning

Structures de données

interface | VersionableTableInterface
class | Versioning

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\WebAsset

  • Joomla
  • CMS
  • WebAsset
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\CMS\WebAsset

Espaces de nommage

AssetItem
Exception

Structures de données

interface | WebAssetAttachBehaviorInterface
class | WebAssetItem
interface | WebAssetItemInterface
class | WebAssetManager
interface | WebAssetManagerInterface
class | WebAssetRegistry
interface | WebAssetRegistryInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\WebAsset\AssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
Structures de données
Référence de l'espace de nommage Joomla\CMS\WebAsset\AssetItem

Structures de données

class | CoreAssetItem
class | FormValidateAssetItem
class | KeepaliveAssetItem
class | LangActiveAssetItem
class | TableColumnsAssetItem

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\WebAsset\Exception

  • Joomla
  • CMS
  • WebAsset
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\CMS\WebAsset\Exception

Structures de données

class | InvalidActionException
class | UnknownAssetException
class | UnsatisfiedDependencyException
interface | WebAssetExceptionInterface

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\CMS\Workflow

  • Joomla
  • CMS
  • Workflow
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\CMS\Workflow

Structures de données

class | Workflow
interface | WorkflowServiceInterface

Fonctions

supportFunctionality ($functionality, $context)
isFunctionalityUsed ($functionality, $extension)
getModelName ($context)
static getConditions (string $extension)
isWorkflowActive ($context)

Variables

trait WorkflowServiceTrait

Description détaillée

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Joomla! Content Management System

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getConditions()

static Joomla\CMS\Workflow\getConditions ( string $extension )
static

Returns an array of possible conditions for the component.

Paramètres
string $extension The component and section separated by ".".
Renvoie
array
Depuis
4.0.0

Références Workflow\CONDITION_NAMES.

◆ getModelName()

Joomla\CMS\Workflow\getModelName ( $context )

Returns the model name, based on the context

Paramètres
string $context The context of the workflow
Renvoie
boolean
Depuis
4.0.0

Références $context, et $parts.

Référencé par Joomla\CMS\Workflow\isWorkflowActive().

◆ isFunctionalityUsed()

Joomla\CMS\Workflow\isFunctionalityUsed | ( | $functionality,
 |  | $extension
 | ) |

Check if the functionality is used by a plugin

Paramètres
string | $functionality | The functionality
string | $extension | The extension
Renvoie
boolean
Exceptions

Références $app, $extension, $this, AbstractEvent\create(), et Factory\getApplication().

◆ isWorkflowActive()

Joomla\CMS\Workflow\isWorkflowActive ( $context )

Check if the workflow is active

Paramètres
string $context The context of the workflow
Renvoie
boolean

Références $component, $config, $context, $model, $parts, Factory\getApplication(), Joomla\CMS\Workflow\getModelName(), Joomla\CMS\MVC\Factory\getMVCFactory(), et ComponentHelper\getParams().

◆ supportFunctionality()

Joomla\CMS\Workflow\supportFunctionality | ( | $functionality,
 |  | $context
 | ) |

Check if the functionality is supported by the component The variable $supportFunctionality has the following structure [ 'core.featured' => [ 'com_content.article', ], 'core.state' => [ 'com_content.article', ], ]

Paramètres
string | $functionality | The functionality
string | $context | The context of the functionality
Renvoie
boolean

Références $context.

Référencé par PlgWorkflowFeaturing\isSupported(), et PlgWorkflowPublishing\isSupported().

Documentation des variables

◆ WorkflowServiceTrait

trait WorkflowServiceTrait
Valeur initiale :
{
abstract public function getMVCFactory(): MVCFactoryInterface
Joomla\CMS\MVC\Factory\getMVCFactory
getMVCFactory()
Definition: MVCFactoryAwareTrait.php:39

Trait for component workflow service.

Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\Component

  • Joomla
  • Component
Espaces de nommage
Référence de l'espace de nommage Joomla\Component

Espaces de nommage

Actionlogs
Admin
Associations
Banners
Cache
Categories
Checkin
Config
Contact
Content
Contenthistory
Cpanel
Fields
Finder
Installer
Joomlaupdate
Languages
Login
Mails
Media
Menus
Messages
Modules
Newsfeeds
Plugins
Postinstall
Privacy
Redirect
Scheduler
Tags
Templates
Users
Workflow
Wrapper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs

  • Joomla
  • Component
  • Actionlogs
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Actionlogs

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator

  • Joomla
  • Component
  • Actionlogs
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator

Espaces de nommage

Controller
Field
Helper
Model
Plugin
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Controller

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Controller

Structures de données

class | ActionlogsController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Field

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Field

Structures de données

class | ExtensionField
class | LogcreatorField
class | LogsdaterangeField
class | LogtypeField
class | PlugininfoField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Helper

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Helper

Structures de données

class ActionlogsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Model

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Model

Structures de données

class | ActionlogConfigModel
class | ActionlogModel
class | ActionlogsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Plugin

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\Plugin

Structures de données

class ActionLogPlugin


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\View

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\View

Espaces de nommage

Actionlogs


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\View\Actionlogs

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • View
  • Actionlogs
Structures de données
Référence de l'espace de nommage Joomla\Component\Actionlogs\Administrator\View\Actionlogs

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin

  • Joomla
  • Component
  • Admin
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Admin

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator

  • Joomla
  • Component
  • Admin
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Admin\Administrator

Espaces de nommage

Controller
Dispatcher
Extension
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Controller

  • Joomla
  • Component
  • Admin
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Dispatcher

  • Joomla
  • Component
  • Admin
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Extension

  • Joomla
  • Component
  • Admin
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Extension

Structures de données

class AdminComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Model

  • Joomla
  • Component
  • Admin
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Model

Structures de données

class | HelpModel
class | SysinfoModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Service

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Service\HTML

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\Service\HTML

Structures de données

class | Configuration
class | Directory
class | PhpSetting
class | System


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View

Espaces de nommage

Help
Sysinfo


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View\Help

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Help
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View\Help

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View\Sysinfo

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Sysinfo
Structures de données
Référence de l'espace de nommage Joomla\Component\Admin\Administrator\View\Sysinfo

Structures de données

class | HtmlView
class | JsonView
class | TextView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations

  • Joomla
  • Component
  • Associations
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Associations

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator

  • Joomla
  • Component
  • Associations
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Associations\Administrator

Espaces de nommage

Controller
Dispatcher
Field
Helper
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Controller

  • Joomla
  • Component
  • Associations
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Controller

Structures de données

class | AssociationController
class | AssociationsController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Dispatcher

  • Joomla
  • Component
  • Associations
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Field

  • Joomla
  • Component
  • Associations
  • Administrator
  • Field
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Field

Espaces de nommage

Modal

Structures de données

class | ItemlanguageField
class | ItemtypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Field\Modal

  • Joomla
  • Component
  • Associations
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Field\Modal

Structures de données

class AssociationField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Helper

  • Joomla
  • Component
  • Associations
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Helper

Structures de données

class AssociationsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Model

  • Joomla
  • Component
  • Associations
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\Model

Structures de données

class | AssociationModel
class | AssociationsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View

  • Joomla
  • Component
  • Associations
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View

Espaces de nommage

Association
Associations


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View\Association

  • Joomla
  • Component
  • Associations
  • Administrator
  • View
  • Association
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View\Association

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View\Associations

  • Joomla
  • Component
  • Associations
  • Administrator
  • View
  • Associations
Structures de données
Référence de l'espace de nommage Joomla\Component\Associations\Administrator\View\Associations

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners

  • Joomla
  • Component
  • Banners
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator

  • Joomla
  • Component
  • Banners
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Controller

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Controller

Structures de données

class | BannerController
class | BannersController
class | ClientController
class | ClientsController
class | DisplayController
class | TracksController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Extension

  • Joomla
  • Component
  • Banners
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Extension

Structures de données

class BannersComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Field

  • Joomla
  • Component
  • Banners
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Field

Structures de données

class | BannerclientField
class | ClicksField
class | ImpmadeField
class | ImptotalField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Helper

  • Joomla
  • Component
  • Banners
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Helper

Structures de données

class BannersHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Model

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Model

Structures de données

class | BannerModel
class | BannersModel
class | ClientModel
class | ClientsModel
class | DownloadModel
class | TracksModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Service

  • Joomla
  • Component
  • Banners
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Service

Espaces de nommage

Html


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Service\Html

  • Joomla
  • Component
  • Banners
  • Administrator
  • Service
  • Html
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Service\Html

Structures de données

class Banner


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Table

  • Joomla
  • Component
  • Banners
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\Table

Structures de données

class | BannerTable
class | ClientTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View

Espaces de nommage

Banner
Banners
Client
Clients
Download
Tracks


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Banner

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Banner
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Banner

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Banners

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Banners
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Banners

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Client

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Client
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Client

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Clients

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Clients
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Clients

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Download

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Download
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Download

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Tracks

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Tracks
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Administrator\View\Tracks

Structures de données

class | HtmlView
class | RawView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Api

  • Joomla
  • Component
  • Banners
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Api\Controller

  • Joomla
  • Component
  • Banners
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Api\Controller

Structures de données

class | BannersController
class | ClientsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Api\View

  • Joomla
  • Component
  • Banners
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Api\View

Espaces de nommage

Banners
Clients


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Api\View\Banners

  • Joomla
  • Component
  • Banners
  • Api
  • View
  • Banners
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Api\View\Banners

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Api\View\Clients

  • Joomla
  • Component
  • Banners
  • Api
  • View
  • Clients
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Api\View\Clients

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Site

  • Joomla
  • Component
  • Banners
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Banners\Site

Espaces de nommage

Controller
Helper
Model
Service


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Site\Controller

  • Joomla
  • Component
  • Banners
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Site\Helper

  • Joomla
  • Component
  • Banners
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Site\Helper

Structures de données

class BannerHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Site\Model

  • Joomla
  • Component
  • Banners
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Site\Model

Structures de données

class | BannerModel
class | BannersModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Banners\Site\Service

  • Joomla
  • Component
  • Banners
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Banners\Site\Service

Structures de données

class | Category
class | Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache

  • Joomla
  • Component
  • Cache
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cache

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache\Administrator

  • Joomla
  • Component
  • Cache
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cache\Administrator

Espaces de nommage

Controller
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache\Administrator\Controller

  • Joomla
  • Component
  • Cache
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Cache\Administrator\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache\Administrator\Model

  • Joomla
  • Component
  • Cache
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Cache\Administrator\Model

Structures de données

class CacheModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache\Administrator\View

  • Joomla
  • Component
  • Cache
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cache\Administrator\View

Espaces de nommage

Cache


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cache\Administrator\View\Cache

  • Joomla
  • Component
  • Cache
  • Administrator
  • View
  • Cache
Structures de données
Référence de l'espace de nommage Joomla\Component\Cache\Administrator\View\Cache

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories

  • Joomla
  • Component
  • Categories
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator

  • Joomla
  • Component
  • Categories
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories\Administrator

Espaces de nommage

Controller
Dispatcher
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Controller

  • Joomla
  • Component
  • Categories
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Controller

Structures de données

class | AjaxController
class | CategoriesController
class | CategoryController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Dispatcher

  • Joomla
  • Component
  • Categories
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Extension

  • Joomla
  • Component
  • Categories
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Extension

Structures de données

class CategoriesComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Field

  • Joomla
  • Component
  • Categories
  • Administrator
  • Field
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Field

Espaces de nommage

Modal

Structures de données

class | CategoryeditField
class | ComponentsCategoryField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Field\Modal

  • Joomla
  • Component
  • Categories
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Field\Modal

Structures de données

class CategoryField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Helper

  • Joomla
  • Component
  • Categories
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Helper

Structures de données

class | CategoriesHelper
class | CategoryAssociationHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Model

  • Joomla
  • Component
  • Categories
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Model

Structures de données

class | CategoriesModel
class | CategoryModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Service

  • Joomla
  • Component
  • Categories
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Service\HTML

  • Joomla
  • Component
  • Categories
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Service\HTML

Structures de données

class AdministratorService


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Table

  • Joomla
  • Component
  • Categories
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\Table

Structures de données

class CategoryTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View

  • Joomla
  • Component
  • Categories
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View

Espaces de nommage

Categories
Category


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View\Categories

  • Joomla
  • Component
  • Categories
  • Administrator
  • View
  • Categories
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View\Categories

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View\Category

  • Joomla
  • Component
  • Categories
  • Administrator
  • View
  • Category
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Administrator\View\Category

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Api

  • Joomla
  • Component
  • Categories
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Api\Controller

  • Joomla
  • Component
  • Categories
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Api\Controller

Structures de données

class CategoriesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Api\View

  • Joomla
  • Component
  • Categories
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Categories\Api\View

Espaces de nommage

Categories


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Categories\Api\View\Categories

  • Joomla
  • Component
  • Categories
  • Api
  • View
  • Categories
Structures de données
Référence de l'espace de nommage Joomla\Component\Categories\Api\View\Categories

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin

  • Joomla
  • Component
  • Checkin
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Checkin

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin\Administrator

  • Joomla
  • Component
  • Checkin
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Checkin\Administrator

Espaces de nommage

Controller
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\Controller

  • Joomla
  • Component
  • Checkin
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\Model

  • Joomla
  • Component
  • Checkin
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\Model

Structures de données

class CheckinModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\View

  • Joomla
  • Component
  • Checkin
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\View

Espaces de nommage

Checkin


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\View\Checkin

  • Joomla
  • Component
  • Checkin
  • Administrator
  • View
  • Checkin
Structures de données
Référence de l'espace de nommage Joomla\Component\Checkin\Administrator\View\Checkin

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config

  • Joomla
  • Component
  • Config
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator

  • Joomla
  • Component
  • Config
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\Controller

  • Joomla
  • Component
  • Config
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\Controller

Structures de données

class | ApplicationController
class | ComponentController
class | DisplayController
class | RequestController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\Extension

  • Joomla
  • Component
  • Config
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\Extension

Structures de données

class ConfigComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\Field

  • Joomla
  • Component
  • Config
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\Field

Structures de données

class | ConfigComponentsField
class | FiltersField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\Helper

  • Joomla
  • Component
  • Config
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\Helper

Structures de données

class ConfigHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\Model

  • Joomla
  • Component
  • Config
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\Model

Structures de données

class | ApplicationModel
class | ComponentModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\View

  • Joomla
  • Component
  • Config
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Administrator\View

Espaces de nommage

Application
Component


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\View\Application

  • Joomla
  • Component
  • Config
  • Administrator
  • View
  • Application
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\View\Application

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Administrator\View\Component

  • Joomla
  • Component
  • Config
  • Administrator
  • View
  • Component
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Administrator\View\Component

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Api

  • Joomla
  • Component
  • Config
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Api\Controller

  • Joomla
  • Component
  • Config
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Api\Controller

Structures de données

class | ApplicationController
class | ComponentController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Api\View

  • Joomla
  • Component
  • Config
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Api\View

Espaces de nommage

Application
Component


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Api\View\Application

  • Joomla
  • Component
  • Config
  • Api
  • View
  • Application
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Api\View\Application

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Api\View\Component

  • Joomla
  • Component
  • Config
  • Api
  • View
  • Component
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Api\View\Component

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site

  • Joomla
  • Component
  • Config
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Site

Espaces de nommage

Controller
Dispatcher
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\Controller

  • Joomla
  • Component
  • Config
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\Controller

Structures de données

class | ConfigController
class | DisplayController
class | ModulesController
class | TemplatesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\Dispatcher

  • Joomla
  • Component
  • Config
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\Model

  • Joomla
  • Component
  • Config
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\Model

Structures de données

class | ConfigModel
class | FormModel
class | ModulesModel
class | TemplatesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\Service

  • Joomla
  • Component
  • Config
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\View

  • Joomla
  • Component
  • Config
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Config\Site\View

Espaces de nommage

Config
Modules
Templates


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\View\Config

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Config
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\View\Config

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\View\Modules

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Modules
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\View\Modules

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Config\Site\View\Templates

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Templates
Structures de données
Référence de l'espace de nommage Joomla\Component\Config\Site\View\Templates

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact

  • Joomla
  • Component
  • Contact
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator

  • Joomla
  • Component
  • Contact
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Controller

  • Joomla
  • Component
  • Contact
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Controller

Structures de données

class | AjaxController
class | ContactController
class | ContactsController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Extension

  • Joomla
  • Component
  • Contact
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Extension

Structures de données

class ContactComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Field

  • Joomla
  • Component
  • Contact
  • Administrator
  • Field
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Field

Espaces de nommage

Modal


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Field\Modal

  • Joomla
  • Component
  • Contact
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Field\Modal

Structures de données

class ContactField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Helper

  • Joomla
  • Component
  • Contact
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Helper

Structures de données

class | AssociationsHelper
class | ContactHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Model

  • Joomla
  • Component
  • Contact
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Model

Structures de données

class | ContactModel
class | ContactsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Service

  • Joomla
  • Component
  • Contact
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Service\HTML

  • Joomla
  • Component
  • Contact
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Service\HTML

Structures de données

class | AdministratorService
class | Icon


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Table

  • Joomla
  • Component
  • Contact
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\Table

Structures de données

class ContactTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View

  • Joomla
  • Component
  • Contact
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View

Espaces de nommage

Contact
Contacts


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View\Contact

  • Joomla
  • Component
  • Contact
  • Administrator
  • View
  • Contact
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View\Contact

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View\Contacts

  • Joomla
  • Component
  • Contact
  • Administrator
  • View
  • Contacts
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Administrator\View\Contacts

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Api

  • Joomla
  • Component
  • Contact
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Api

Espaces de nommage

Controller
Serializer
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Api\Controller

  • Joomla
  • Component
  • Contact
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Api\Controller

Structures de données

class ContactController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Api\Serializer

  • Joomla
  • Component
  • Contact
  • Api
  • Serializer
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Api\Serializer

Structures de données

class ContactSerializer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Api\View

  • Joomla
  • Component
  • Contact
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Api\View

Espaces de nommage

Contacts


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Api\View\Contacts

  • Joomla
  • Component
  • Contact
  • Api
  • View
  • Contacts
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Api\View\Contacts

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site

  • Joomla
  • Component
  • Contact
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Site

Espaces de nommage

Controller
Dispatcher
Helper
Model
Rule
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Controller

  • Joomla
  • Component
  • Contact
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Controller

Structures de données

class | ContactController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Dispatcher

  • Joomla
  • Component
  • Contact
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Helper

  • Joomla
  • Component
  • Contact
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Helper

Structures de données

class | AssociationHelper
class | RouteHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Model

  • Joomla
  • Component
  • Contact
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Model

Structures de données

class | CategoriesModel
class | CategoryModel
class | ContactModel
class | FeaturedModel
class | FormModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Rule

  • Joomla
  • Component
  • Contact
  • Site
  • Rule
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Rule

Structures de données

class | ContactEmailMessageRule
class | ContactEmailRule
class | ContactEmailSubjectRule


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\Service

  • Joomla
  • Component
  • Contact
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\Service

Structures de données

class | Category
class | Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View

  • Joomla
  • Component
  • Contact
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contact\Site\View

Espaces de nommage

Categories
Category
Contact
Featured
Form


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Categories

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Categories
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Categories

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Category

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Category
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Category

Structures de données

class | FeedView
class | HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Contact

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Contact
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Contact

Structures de données

class | HtmlView
class | VcfView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Featured

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Featured
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Featured

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Form

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Form
Structures de données
Référence de l'espace de nommage Joomla\Component\Contact\Site\View\Form

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content

  • Joomla
  • Component
  • Content
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator

  • Joomla
  • Component
  • Content
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Administrator

Espaces de nommage

Controller
Event
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Controller

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Controller

Structures de données

class | AjaxController
class | ArticleController
class | ArticlesController
class | DisplayController
class | FeaturedController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Event

  • Joomla
  • Component
  • Content
  • Administrator
  • Event
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Event

Espaces de nommage

Model


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Event\Model

  • Joomla
  • Component
  • Content
  • Administrator
  • Event
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Event\Model

Structures de données

class FeatureEvent

Description détaillée

Joomla! Content Management System

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Extension

  • Joomla
  • Component
  • Content
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Extension

Structures de données

class ContentComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Field

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Field

Espaces de nommage

Modal

Structures de données

class | AssocField
class | VotelistField
class | VoteradioField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Field\Modal

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Field\Modal

Structures de données

class ArticleField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Helper

  • Joomla
  • Component
  • Content
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Helper

Structures de données

class | AssociationsHelper
class | ContentHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Model

  • Joomla
  • Component
  • Content
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Model

Structures de données

class | ArticleModel
class | ArticlesModel
class | FeaturedModel
class | FeatureModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Service

  • Joomla
  • Component
  • Content
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Service\HTML

  • Joomla
  • Component
  • Content
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Service\HTML

Structures de données

class | AdministratorService
class | Icon


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\Table

  • Joomla
  • Component
  • Content
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\Table

Structures de données

class | ArticleTable
class | FeaturedTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\View

  • Joomla
  • Component
  • Content
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Administrator\View

Espaces de nommage

Article
Articles
Featured


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Article

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Article
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Article

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Articles

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Articles
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Articles

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Featured

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Featured
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Administrator\View\Featured

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api

  • Joomla
  • Component
  • Content
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Api

Espaces de nommage

Controller
Helper
Serializer
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api\Controller

  • Joomla
  • Component
  • Content
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Api\Controller

Structures de données

class ArticlesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api\Helper

  • Joomla
  • Component
  • Content
  • Api
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Api\Helper

Structures de données

class ContentHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api\Serializer

  • Joomla
  • Component
  • Content
  • Api
  • Serializer
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Api\Serializer

Structures de données

class ContentSerializer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api\View

  • Joomla
  • Component
  • Content
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Api\View

Espaces de nommage

Articles


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Api\View\Articles

  • Joomla
  • Component
  • Content
  • Api
  • View
  • Articles
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Api\View\Articles

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site

  • Joomla
  • Component
  • Content
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Site

Espaces de nommage

Controller
Dispatcher
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\Controller

  • Joomla
  • Component
  • Content
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\Controller

Structures de données

class | ArticleController
class | DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\Dispatcher

  • Joomla
  • Component
  • Content
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\Helper

  • Joomla
  • Component
  • Content
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\Helper

Structures de données

class | AssociationHelper
class | QueryHelper
class | RouteHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\Model

  • Joomla
  • Component
  • Content
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\Model

Structures de données

class | ArchiveModel
class | ArticleModel
class | ArticlesModel
class | CategoriesModel
class | CategoryModel
class | FeaturedModel
class | FormModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\Service

  • Joomla
  • Component
  • Content
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\Service

Structures de données

class | Category
class | Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View

  • Joomla
  • Component
  • Content
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Content\Site\View

Espaces de nommage

Archive
Article
Categories
Category
Featured
Form


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Archive

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Archive
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Archive

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Article

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Article
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Article

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Categories

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Categories
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Categories

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Category

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Category
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Category

Structures de données

class | FeedView
class | HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Featured

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Featured
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Featured

Structures de données

class | FeedView
class | HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Content\Site\View\Form

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Form
Structures de données
Référence de l'espace de nommage Joomla\Component\Content\Site\View\Form

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory

  • Joomla
  • Component
  • Contenthistory
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator

  • Joomla
  • Component
  • Contenthistory
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator

Espaces de nommage

Controller
Dispatcher
Helper
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Controller

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Controller

Structures de données

class | DisplayController
class | HistoryController
class | PreviewController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Dispatcher

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Helper

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Helper

Structures de données

class ContenthistoryHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Model

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\Model

Structures de données

class | CompareModel
class | HistoryModel
class | PreviewModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View

Espaces de nommage

Compare
History
Preview


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\Compare

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • Compare
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\Compare

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\History

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • History
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\History

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\Preview

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • Preview
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Administrator\View\Preview

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Api

  • Joomla
  • Component
  • Contenthistory
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\Controller

  • Joomla
  • Component
  • Contenthistory
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\Controller

Structures de données

class HistoryController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\View

  • Joomla
  • Component
  • Contenthistory
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\View

Espaces de nommage

History


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\View\History

  • Joomla
  • Component
  • Contenthistory
  • Api
  • View
  • History
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Api\View\History

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Site

  • Joomla
  • Component
  • Contenthistory
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Contenthistory\Site

Espaces de nommage

Controller
Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Site\Controller

  • Joomla
  • Component
  • Contenthistory
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Contenthistory\Site\Dispatcher

  • Joomla
  • Component
  • Contenthistory
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Contenthistory\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel

  • Joomla
  • Component
  • Cpanel
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cpanel

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator

  • Joomla
  • Component
  • Cpanel
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator

Espaces de nommage

Controller
Dispatcher
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\Controller

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\Dispatcher

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\View

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\View

Espaces de nommage

Cpanel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\View\Cpanel

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • View
  • Cpanel
Structures de données
Référence de l'espace de nommage Joomla\Component\Cpanel\Administrator\View\Cpanel

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields

  • Joomla
  • Component
  • Fields
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator

  • Joomla
  • Component
  • Fields
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields\Administrator

Espaces de nommage

Controller
Dispatcher
Extension
Field
Helper
Model
Plugin
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Controller

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Controller

Structures de données

class | DisplayController
class | FieldController
class | FieldsController
class | GroupController
class | GroupsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Dispatcher

  • Joomla
  • Component
  • Fields
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Extension

  • Joomla
  • Component
  • Fields
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Extension

Structures de données

class FieldsComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Field

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Field

Structures de données

class | ComponentsFieldgroupField
class | ComponentsFieldsField
class | FieldcontextsField
class | FieldgroupsField
class | FieldLayoutField
class | SectionField
class | SubfieldsField
class | TypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Helper

  • Joomla
  • Component
  • Fields
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Helper

Structures de données

class FieldsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Model

  • Joomla
  • Component
  • Fields
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Model

Structures de données

class | FieldModel
class | FieldsModel
class | GroupModel
class | GroupsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Plugin

  • Joomla
  • Component
  • Fields
  • Administrator
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Plugin

Structures de données

class | FieldsListPlugin
class | FieldsPlugin


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Table

  • Joomla
  • Component
  • Fields
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\Table

Structures de données

class | FieldTable
class | GroupTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View

Espaces de nommage

Field
Fields
Group
Groups


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Field

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Field

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Fields

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Fields
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Fields

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Group

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Group
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Group

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Groups

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Groups
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Administrator\View\Groups

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Api

  • Joomla
  • Component
  • Fields
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Api\Controller

  • Joomla
  • Component
  • Fields
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Api\Controller

Structures de données

class | FieldsController
class | GroupsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Api\View

  • Joomla
  • Component
  • Fields
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields\Api\View

Espaces de nommage

Fields
Groups


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Api\View\Fields

  • Joomla
  • Component
  • Fields
  • Api
  • View
  • Fields
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Api\View\Fields

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Api\View\Groups

  • Joomla
  • Component
  • Fields
  • Api
  • View
  • Groups
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Api\View\Groups

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Site

  • Joomla
  • Component
  • Fields
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Fields\Site

Espaces de nommage

Controller
Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Site\Controller

  • Joomla
  • Component
  • Fields
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Fields\Site\Dispatcher

  • Joomla
  • Component
  • Fields
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Fields\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder

  • Joomla
  • Component
  • Finder
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder

Espaces de nommage

Administrator
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator

  • Joomla
  • Component
  • Finder
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Indexer
Model
Response
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Controller

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Controller

Structures de données

class | DisplayController
class | FilterController
class | FiltersController
class | IndexController
class | IndexerController
class | MapsController
class | SearchesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Extension

  • Joomla
  • Component
  • Finder
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Extension

Structures de données

class FinderComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Field

  • Joomla
  • Component
  • Finder
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Field

Structures de données

class | BranchesField
class | ContentmapField
class | ContenttypesField
class | SearchfilterField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Helper

  • Joomla
  • Component
  • Finder
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Helper

Structures de données

class | FinderHelper
class | LanguageHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer

Espaces de nommage

Language
Parser

Structures de données

class | Adapter
class | Helper
class | Indexer
class | Language
class | Parser
class | Query
class | Result
class | Taxonomy
class | Token


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer\Language

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Language
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer\Language

Structures de données

class | El
class | Zh


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer\Parser

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Parser
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Indexer\Parser

Structures de données

class | Html
class | Rtf
class | Txt


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Model

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Model

Structures de données

class | FilterModel
class | FiltersModel
class | IndexerModel
class | IndexModel
class | MapsModel
class | SearchesModel
class | StatisticsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Response

  • Joomla
  • Component
  • Finder
  • Administrator
  • Response
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Response

Structures de données

class Response


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Service

  • Joomla
  • Component
  • Finder
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Service\HTML

  • Joomla
  • Component
  • Finder
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Service\HTML

Structures de données

class | Filter
class | Finder
class | Query


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Table

  • Joomla
  • Component
  • Finder
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\Table

Structures de données

class | FilterTable
class | LinkTable
class | MapTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View

Espaces de nommage

Filter
Filters
Index
Indexer
Maps
Searches
Statistics


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Filter

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Filter
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Filter

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Filters

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Filters
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Filters

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Index

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Index
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Index

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Indexer

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Indexer
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Indexer

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Maps

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Maps
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Maps

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Searches

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Searches
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Searches

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Statistics

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Statistics
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Administrator\View\Statistics

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site

  • Joomla
  • Component
  • Finder
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder\Site

Espaces de nommage

Controller
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\Controller

  • Joomla
  • Component
  • Finder
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Site\Controller

Structures de données

class | DisplayController
class | SuggestionsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\Helper

  • Joomla
  • Component
  • Finder
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Site\Helper

Structures de données

class | FinderHelper
class | RouteHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\Model

  • Joomla
  • Component
  • Finder
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Site\Model

Structures de données

class | SearchModel
class | SuggestionsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\Service

  • Joomla
  • Component
  • Finder
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\View

  • Joomla
  • Component
  • Finder
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Finder\Site\View

Espaces de nommage

Search


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Finder\Site\View\Search

  • Joomla
  • Component
  • Finder
  • Site
  • View
  • Search
Structures de données
Référence de l'espace de nommage Joomla\Component\Finder\Site\View\Search

Structures de données

class | FeedView
class | HtmlView
class | OpensearchView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer

  • Joomla
  • Component
  • Installer
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator

  • Joomla
  • Component
  • Installer
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Controller

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Controller

Structures de données

class | DatabaseController
class | DiscoverController
class | DisplayController
class | InstallController
class | ManageController
class | UpdateController
class | UpdatesiteController
class | UpdatesitesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Extension

  • Joomla
  • Component
  • Installer
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Extension

Structures de données

class InstallerComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Field

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Field

Structures de données

class | ExtensionstatusField
class | FolderField
class | LocationField
class | PackageField
class | TypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Helper

  • Joomla
  • Component
  • Installer
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Helper

Structures de données

class InstallerHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Model

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Model

Structures de données

class | DatabaseModel
class | DiscoverModel
class | InstallerModel
class | InstallModel
class | LanguagesModel
class | ManageModel
class | UpdateModel
class | UpdatesiteModel
class | UpdatesitesModel
class | WarningsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Service

  • Joomla
  • Component
  • Installer
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Service\HTML

  • Joomla
  • Component
  • Installer
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Service\HTML

Structures de données

class | Manage
class | Updatesites


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Table

  • Joomla
  • Component
  • Installer
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\Table

Structures de données

class UpdatesiteTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View

Espaces de nommage

Database
Discover
Install
Installer
Languages
Manage
Update
Updatesite
Updatesites
Warnings


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Database

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Database
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Database

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Discover

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Discover
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Discover

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Install

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Install
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Install

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Installer

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Installer
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Installer

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Languages

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Languages
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Languages

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Manage

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Manage
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Manage

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Update

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Update
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Update

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Updatesite

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Updatesite
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Updatesite

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Updatesites

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Updatesites
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Updatesites

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Warnings

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Warnings
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Administrator\View\Warnings

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Api

  • Joomla
  • Component
  • Installer
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Api\Controller

  • Joomla
  • Component
  • Installer
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Api\Controller

Structures de données

class ManageController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Api\View

  • Joomla
  • Component
  • Installer
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Installer\Api\View

Espaces de nommage

Manage


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Installer\Api\View\Manage

  • Joomla
  • Component
  • Installer
  • Api
  • View
  • Manage
Structures de données
Référence de l'espace de nommage Joomla\Component\Installer\Api\View\Manage

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate

  • Joomla
  • Component
  • Joomlaupdate
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Joomlaupdate

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator

Espaces de nommage

Controller
Dispatcher
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Controller

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Controller

Structures de données

class | DisplayController
class | UpdateController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Dispatcher

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Model

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\Model

Structures de données

class UpdateModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View

Espaces de nommage

Joomlaupdate
Update
Upload


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Joomlaupdate

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Joomlaupdate
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Joomlaupdate

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Update

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Update
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Update

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Upload

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Upload
Structures de données
Référence de l'espace de nommage Joomla\Component\Joomlaupdate\Administrator\View\Upload

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages

  • Joomla
  • Component
  • Languages
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator

  • Joomla
  • Component
  • Languages
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Controller

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Controller

Structures de données

class | DisplayController
class | InstalledController
class | LanguageController
class | LanguagesController
class | OverrideController
class | OverridesController
class | StringsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Extension

  • Joomla
  • Component
  • Languages
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Extension

Structures de données

class LanguagesComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Field

  • Joomla
  • Component
  • Languages
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Field

Structures de données

class LanguageclientField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Helper

  • Joomla
  • Component
  • Languages
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Helper

Structures de données

class | LanguagesHelper
class | MultilangstatusHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Model

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Model

Structures de données

class | InstalledModel
class | LanguageModel
class | LanguagesModel
class | OverrideModel
class | OverridesModel
class | StringsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Service

  • Joomla
  • Component
  • Languages
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Service\HTML

  • Joomla
  • Component
  • Languages
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\Service\HTML

Structures de données

class Languages


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View

Espaces de nommage

Installed
Language
Languages
Multilangstatus
Override
Overrides


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Installed

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Installed
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Installed

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Language

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Language
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Language

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Languages

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Languages
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Languages

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Multilangstatus

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Multilangstatus
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Multilangstatus

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Override

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Override
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Override

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Overrides

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Overrides
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Administrator\View\Overrides

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api

  • Joomla
  • Component
  • Languages
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api\Controller

  • Joomla
  • Component
  • Languages
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Api\Controller

Structures de données

class | LanguagesController
class | OverridesController
class | StringsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api\View

  • Joomla
  • Component
  • Languages
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Languages\Api\View

Espaces de nommage

Languages
Overrides
Strings


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Languages

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Languages
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Languages

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Overrides

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Overrides
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Overrides

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Strings

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Strings
Structures de données
Référence de l'espace de nommage Joomla\Component\Languages\Api\View\Strings

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login

  • Joomla
  • Component
  • Login
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Login

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator

  • Joomla
  • Component
  • Login
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Login\Administrator

Espaces de nommage

Controller
Dispatcher
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator\Controller

  • Joomla
  • Component
  • Login
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Login\Administrator\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator\Dispatcher

  • Joomla
  • Component
  • Login
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Login\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator\Model

  • Joomla
  • Component
  • Login
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Login\Administrator\Model

Structures de données

class LoginModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator\View

  • Joomla
  • Component
  • Login
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Login\Administrator\View

Espaces de nommage

Login


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Login\Administrator\View\Login

  • Joomla
  • Component
  • Login
  • Administrator
  • View
  • Login
Structures de données
Référence de l'espace de nommage Joomla\Component\Login\Administrator\View\Login

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails

  • Joomla
  • Component
  • Mails
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Mails

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator

  • Joomla
  • Component
  • Mails
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Mails\Administrator

Espaces de nommage

Controller
Helper
Model
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Controller

  • Joomla
  • Component
  • Mails
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Controller

Structures de données

class | DisplayController
class | TemplateController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Helper

  • Joomla
  • Component
  • Mails
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Helper

Structures de données

class MailsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Model

  • Joomla
  • Component
  • Mails
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Model

Structures de données

class | TemplateModel
class | TemplatesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Table

  • Joomla
  • Component
  • Mails
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\Table

Structures de données

class TemplateTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View

  • Joomla
  • Component
  • Mails
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View

Espaces de nommage

Template
Templates


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View\Template

  • Joomla
  • Component
  • Mails
  • Administrator
  • View
  • Template
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View\Template

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View\Templates

  • Joomla
  • Component
  • Mails
  • Administrator
  • View
  • Templates
Structures de données
Référence de l'espace de nommage Joomla\Component\Mails\Administrator\View\Templates

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media

  • Joomla
  • Component
  • Media
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator

  • Joomla
  • Component
  • Media
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media\Administrator

Espaces de nommage

Adapter
Controller
Dispatcher
Event
Exception
Model
Plugin
Provider
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Adapter

  • Joomla
  • Component
  • Media
  • Administrator
  • Adapter
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Adapter

Structures de données

interface AdapterInterface


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Controller

  • Joomla
  • Component
  • Media
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Controller

Structures de données

class | ApiController
class | DisplayController
class | PluginController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Dispatcher

  • Joomla
  • Component
  • Media
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Event

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Event

Structures de données

class | AbstractMediaItemValidationEvent
class | FetchMediaItemEvent
class | FetchMediaItemsEvent
class | FetchMediaItemUrlEvent
class | MediaProviderEvent
class | OAuthCallbackEvent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Exception

  • Joomla
  • Component
  • Media
  • Administrator
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Exception

Structures de données

class | FileExistsException
class | FileNotFoundException
class | InvalidPathException


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Model

  • Joomla
  • Component
  • Media
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Model

Structures de données

class | ApiModel
class | FileModel
class | MediaModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Plugin

  • Joomla
  • Component
  • Media
  • Administrator
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Plugin

Structures de données

class MediaActionPlugin


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\Provider

  • Joomla
  • Component
  • Media
  • Administrator
  • Provider
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\Component\Media\Administrator\Provider

Structures de données

interface | ProviderInterface
class | ProviderManager

Fonctions

getProviderManager ()
getProvider (string $id)
getAdapter (string $name)
resolveAdapterAndPath (string $path)
getDefaultAdapterName ()

Variables

trait ProviderManagerHelperTrait
$defaultAdapterName = null

Documentation des fonctions

◆ getAdapter()

Joomla\Component\Media\Administrator\Provider\getAdapter ( string $name )

Return an adapter for the given name.

Renvoie
AdapterInterface
Exceptions

Références Joomla\Component\Media\Administrator\Provider\getProviderManager().

Référencé par ApiModel\copy(), ApiModel\createFile(), ApiModel\createFolder(), ApiModel\delete(), ApiController\deleteFiles(), Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName(), ApiModel\getFile(), ApiModel\getFiles(), ApiController\getFiles(), AdapterModel\getItem(), ApiModel\getUrl(), ApiModel\move(), ApiController\postFiles(), ApiController\putFiles(), ApiModel\search(), et ApiModel\updateFile().

◆ getDefaultAdapterName()

Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName ( )
protected

Returns the default adapter name.

Renvoie
string|null
Exceptions

Références Joomla\Component\Media\Administrator\Provider\$defaultAdapterName, Joomla\Component\Media\Administrator\Provider\getAdapter(), ComponentHelper\getParams(), Joomla\Component\Media\Administrator\Provider\getProvider(), Joomla\Component\Media\Administrator\Provider\getProviderManager(), et null.

Référencé par Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath().

◆ getProvider()

Joomla\Component\Media\Administrator\Provider\getProvider ( string $id )

Returns a provider for the given id.

Renvoie
ProviderInterface
Exceptions

Références Joomla\Component\Media\Administrator\Provider\getProviderManager().

Référencé par ProviderManager\getAdapter(), Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName(), et AdapterModel\getItem().

◆ getProviderManager()

Joomla\Component\Media\Administrator\Provider\getProviderManager ( )

Return a provider manager.

Renvoie
ProviderManager
Depuis
4.1.0

Références Factory\getApplication(), et PluginHelper\importPlugin().

Référencé par Joomla\Component\Media\Administrator\Provider\getAdapter(), Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName(), AdaptersModel\getItems(), Joomla\Component\Media\Administrator\Provider\getProvider(), et MediaModel\getProviders().

◆ resolveAdapterAndPath()

Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath ( string $path )
protected

Returns an array with the adapter name as key and the path of the file.

Renvoie
array
Exceptions

Références $parts, $path, $result, Text\_(), et Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName().

Référencé par MediumModel\delete(), MediumModel\getItem(), MediaModel\getItems(), et MediumModel\save().

Documentation des variables

◆ $defaultAdapterName

$defaultAdapterName = null
private

Référencé par Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName().

◆ ProviderManagerHelperTrait

trait ProviderManagerHelperTrait
Valeur initiale :
{
private $providerManager = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Trait for classes that need adapters.

Depuis
4.1.0


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\View

  • Joomla
  • Component
  • Media
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media\Administrator\View

Espaces de nommage

File
Media


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\View\File

  • Joomla
  • Component
  • Media
  • Administrator
  • View
  • File
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\View\File

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Administrator\View\Media

  • Joomla
  • Component
  • Media
  • Administrator
  • View
  • Media
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Administrator\View\Media

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api

  • Joomla
  • Component
  • Media
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media\Api

Espaces de nommage

Controller
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api\Controller

  • Joomla
  • Component
  • Media
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Api\Controller

Structures de données

class | AdaptersController
class | MediaController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api\Model

  • Joomla
  • Component
  • Media
  • Api
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Api\Model

Structures de données

class | AdapterModel
class | AdaptersModel
class | MediaModel
class | MediumModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api\View

  • Joomla
  • Component
  • Media
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media\Api\View

Espaces de nommage

Adapters
Media


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api\View\Adapters

  • Joomla
  • Component
  • Media
  • Api
  • View
  • Adapters
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Api\View\Adapters

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Api\View\Media

  • Joomla
  • Component
  • Media
  • Api
  • View
  • Media
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Api\View\Media

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Site

  • Joomla
  • Component
  • Media
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Media\Site

Espaces de nommage

Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Media\Site\Dispatcher

  • Joomla
  • Component
  • Media
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Media\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus

  • Joomla
  • Component
  • Menus
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator

  • Joomla
  • Component
  • Menus
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Controller

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Controller

Structures de données

class | AjaxController
class | DisplayController
class | ItemController
class | ItemsController
class | MenuController
class | MenusController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Extension

  • Joomla
  • Component
  • Menus
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Extension

Structures de données

class MenusComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Field

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Field

Espaces de nommage

Modal

Structures de données

class | MenuItemByTypeField
class | MenuOrderingField
class | MenuParentField
class | MenuPresetField
class | MenutypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Field\Modal

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Field\Modal

Structures de données

class MenuField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Helper

  • Joomla
  • Component
  • Menus
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Helper

Structures de données

class | AssociationsHelper
class | MenusHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Model

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Model

Structures de données

class | ItemModel
class | ItemsModel
class | MenuModel
class | MenusModel
class | MenutypesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Service

  • Joomla
  • Component
  • Menus
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Service\HTML

  • Joomla
  • Component
  • Menus
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Service\HTML

Structures de données

class Menus


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Table

  • Joomla
  • Component
  • Menus
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\Table

Structures de données

class | MenuTable
class | MenuTypeTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View

Espaces de nommage

Item
Items
Menu
Menus
Menutypes


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Item

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Item
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Item

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Items

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Items
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Items

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menu

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menu
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menu

Structures de données

class | HtmlView
class | XmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menus

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menus
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menus

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menutypes

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menutypes
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Administrator\View\Menutypes

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Api

  • Joomla
  • Component
  • Menus
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Api\Controller

  • Joomla
  • Component
  • Menus
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Api\Controller

Structures de données

class | ItemsController
class | MenusController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Api\View

  • Joomla
  • Component
  • Menus
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Api\View

Espaces de nommage

Items
Menus


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Api\View\Items

  • Joomla
  • Component
  • Menus
  • Api
  • View
  • Items
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Api\View\Items

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Api\View\Menus

  • Joomla
  • Component
  • Menus
  • Api
  • View
  • Menus
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Api\View\Menus

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Site

  • Joomla
  • Component
  • Menus
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Menus\Site

Espaces de nommage

Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Menus\Site\Dispatcher

  • Joomla
  • Component
  • Menus
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Menus\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages

  • Joomla
  • Component
  • Messages
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator

  • Joomla
  • Component
  • Messages
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Controller

  • Joomla
  • Component
  • Messages
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Controller

Structures de données

class | ConfigController
class | DisplayController
class | MessageController
class | MessagesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Extension

  • Joomla
  • Component
  • Messages
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Extension

Structures de données

class MessagesComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Field

  • Joomla
  • Component
  • Messages
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Field

Structures de données

class | MessageStatesField
class | UserMessagesField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Helper

  • Joomla
  • Component
  • Messages
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Helper

Structures de données

class MessagesHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Model

  • Joomla
  • Component
  • Messages
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Model

Structures de données

class | ConfigModel
class | MessageModel
class | MessagesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Service

  • Joomla
  • Component
  • Messages
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Service\HTML

  • Joomla
  • Component
  • Messages
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Service\HTML

Structures de données

class Messages


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Table

  • Joomla
  • Component
  • Messages
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\Table

Structures de données

class MessageTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View

Espaces de nommage

Config
Message
Messages


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Config

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Config
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Config

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Message

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Message
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Message

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Messages

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Messages
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Administrator\View\Messages

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Api

  • Joomla
  • Component
  • Messages
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Api\Controller

  • Joomla
  • Component
  • Messages
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Api\Controller

Structures de données

class MessagesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Api\View

  • Joomla
  • Component
  • Messages
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Messages\Api\View

Espaces de nommage

Messages


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Messages\Api\View\Messages

  • Joomla
  • Component
  • Messages
  • Api
  • View
  • Messages
Structures de données
Référence de l'espace de nommage Joomla\Component\Messages\Api\View\Messages

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules

  • Joomla
  • Component
  • Modules
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator

  • Joomla
  • Component
  • Modules
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Controller

  • Joomla
  • Component
  • Modules
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Controller

Structures de données

class | DisplayController
class | ModuleController
class | ModulesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Extension

  • Joomla
  • Component
  • Modules
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Extension

Structures de données

class ModulesComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Field

  • Joomla
  • Component
  • Modules
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Field

Structures de données

class | ModulesModuleField
class | ModulesPositioneditField
class | ModulesPositionField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Helper

  • Joomla
  • Component
  • Modules
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Helper

Structures de données

class ModulesHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Model

  • Joomla
  • Component
  • Modules
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Model

Structures de données

class | ModuleModel
class | ModulesModel
class | PositionsModel
class | SelectModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Service

  • Joomla
  • Component
  • Modules
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Service\HTML

  • Joomla
  • Component
  • Modules
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\Service\HTML

Structures de données

class Modules


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View

Espaces de nommage

Module
Modules
Select


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Module

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Module
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Module

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Modules

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Modules
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Modules

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Select

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Select
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Administrator\View\Select

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Api

  • Joomla
  • Component
  • Modules
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Api\Controller

  • Joomla
  • Component
  • Modules
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Api\Controller

Structures de données

class ModulesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Api\View

  • Joomla
  • Component
  • Modules
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Api\View

Espaces de nommage

Modules


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Api\View\Modules

  • Joomla
  • Component
  • Modules
  • Api
  • View
  • Modules
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Api\View\Modules

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Site

  • Joomla
  • Component
  • Modules
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Modules\Site

Espaces de nommage

Controller
Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Site\Controller

  • Joomla
  • Component
  • Modules
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Modules\Site\Dispatcher

  • Joomla
  • Component
  • Modules
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Modules\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds

  • Joomla
  • Component
  • Newsfeeds
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Controller

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Controller

Structures de données

class | AjaxController
class | DisplayController
class | NewsfeedController
class | NewsfeedsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Extension

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Extension

Structures de données

class NewsfeedsComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Field

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Field
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Field

Espaces de nommage

Modal

Structures de données

class NewsfeedsField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Field\Modal

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Field
  • Modal
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Field\Modal

Structures de données

class NewsfeedField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Helper

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Helper

Structures de données

class | AssociationsHelper
class | NewsfeedsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Model

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Model

Structures de données

class | NewsfeedModel
class | NewsfeedsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Service

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Service\HTML

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Service\HTML

Structures de données

class AdministratorService


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Table

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\Table

Structures de données

class NewsfeedTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View

Espaces de nommage

Newsfeed
Newsfeeds


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View\Newsfeed

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • View
  • Newsfeed
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View\Newsfeed

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View\Newsfeeds

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • View
  • Newsfeeds
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Administrator\View\Newsfeeds

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api

  • Joomla
  • Component
  • Newsfeeds
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api

Espaces de nommage

Controller
Serializer
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\Controller

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\Controller

Structures de données

class FeedsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\Serializer

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • Serializer
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\Serializer

Structures de données

class NewsfeedSerializer

Description détaillée

Joomla! Content Management System

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\View

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\View

Espaces de nommage

Feeds


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\View\Feeds

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • View
  • Feeds
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Api\View\Feeds

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site

  • Joomla
  • Component
  • Newsfeeds
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site

Espaces de nommage

Controller
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Controller

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Helper

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Helper

Structures de données

class | AssociationHelper
class | RouteHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Model

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Model

Structures de données

class | CategoriesModel
class | CategoryModel
class | NewsfeedModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Service

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\Service

Structures de données

class | Category
class | Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View

Espaces de nommage

Categories
Category
Newsfeed


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Categories

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Categories
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Categories

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Category

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Category
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Category

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Newsfeed

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Newsfeed
Structures de données
Référence de l'espace de nommage Joomla\Component\Newsfeeds\Site\View\Newsfeed

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins

  • Joomla
  • Component
  • Plugins
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Plugins

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator

  • Joomla
  • Component
  • Plugins
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator

Espaces de nommage

Controller
Field
Helper
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Controller

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Controller

Structures de données

class | DisplayController
class | PluginController
class | PluginsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Field

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Field

Structures de données

class | PluginElementField
class | PluginorderingField
class | PluginTypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Helper

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Helper

Structures de données

class PluginsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Model

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\Model

Structures de données

class | PluginModel
class | PluginsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View

  • Joomla
  • Component
  • Plugins
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View

Espaces de nommage

Plugin
Plugins


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View\Plugin

  • Joomla
  • Component
  • Plugins
  • Administrator
  • View
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View\Plugin

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View\Plugins

  • Joomla
  • Component
  • Plugins
  • Administrator
  • View
  • Plugins
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Administrator\View\Plugins

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Api

  • Joomla
  • Component
  • Plugins
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Plugins\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Api\Controller

  • Joomla
  • Component
  • Plugins
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Api\Controller

Structures de données

class PluginsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Api\View

  • Joomla
  • Component
  • Plugins
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Plugins\Api\View

Espaces de nommage

Plugins


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Plugins\Api\View\Plugins

  • Joomla
  • Component
  • Plugins
  • Api
  • View
  • Plugins
Structures de données
Référence de l'espace de nommage Joomla\Component\Plugins\Api\View\Plugins

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall

  • Joomla
  • Component
  • Postinstall
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Postinstall

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator

  • Joomla
  • Component
  • Postinstall
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator

Espaces de nommage

Controller
Helper
Model
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Controller

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Controller

Structures de données

class | DisplayController
class | MessageController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Helper

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Helper

Structures de données

class PostinstallHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Model

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\Model

Structures de données

class MessagesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\View

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\View

Espaces de nommage

Messages


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\View\Messages

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • View
  • Messages
Structures de données
Référence de l'espace de nommage Joomla\Component\Postinstall\Administrator\View\Messages

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy

  • Joomla
  • Component
  • Privacy
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator

  • Joomla
  • Component
  • Privacy
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator

Espaces de nommage

Controller
Dispatcher
Export
Extension
Field
Helper
Model
Plugin
Removal
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Controller

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Controller

Structures de données

class | ConsentsController
class | DisplayController
class | RequestController
class | RequestsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Dispatcher

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Export

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Export
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Export

Structures de données

class | Domain
class | Field
class | Item


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Extension

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Extension

Structures de données

class PrivacyComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Field

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Field

Structures de données

class | RequeststatusField
class | RequesttypeField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Helper

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Helper

Structures de données

class PrivacyHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Model

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Model

Structures de données

class | CapabilitiesModel
class | ConsentsModel
class | ExportModel
class | RemoveModel
class | RequestModel
class | RequestsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Plugin

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Plugin
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Plugin

Structures de données

class PrivacyPlugin


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Removal

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Removal
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Removal

Structures de données

class Status


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Service

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Service\HTML

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Service\HTML

Structures de données

class Privacy


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Table

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\Table

Structures de données

class | ConsentTable
class | RequestTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View

Espaces de nommage

Capabilities
Consents
Export
Request
Requests


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Capabilities

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Capabilities
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Capabilities

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Consents

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Consents
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Consents

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Export

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Export
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Export

Structures de données

class XmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Request

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Request
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Request

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Requests

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Requests
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Administrator\View\Requests

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Api

  • Joomla
  • Component
  • Privacy
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Api\Controller

  • Joomla
  • Component
  • Privacy
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Api\Controller

Structures de données

class | ConsentsController
class | RequestsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Api\View

  • Joomla
  • Component
  • Privacy
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Api\View

Espaces de nommage

Consents
Requests


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Api\View\Consents

  • Joomla
  • Component
  • Privacy
  • Api
  • View
  • Consents
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Api\View\Consents

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Api\View\Requests

  • Joomla
  • Component
  • Privacy
  • Api
  • View
  • Requests
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Api\View\Requests

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site

  • Joomla
  • Component
  • Privacy
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Site

Espaces de nommage

Controller
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\Controller

  • Joomla
  • Component
  • Privacy
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\Controller

Structures de données

class | DisplayController
class | RequestController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\Model

  • Joomla
  • Component
  • Privacy
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\Model

Structures de données

class | ConfirmModel
class | RemindModel
class | RequestModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\Service

  • Joomla
  • Component
  • Privacy
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\View

  • Joomla
  • Component
  • Privacy
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Privacy\Site\View

Espaces de nommage

Confirm
Remind
Request


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Confirm

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Confirm
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Confirm

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Remind

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Remind
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Remind

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Request

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Request
Structures de données
Référence de l'espace de nommage Joomla\Component\Privacy\Site\View\Request

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect

  • Joomla
  • Component
  • Redirect
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator

  • Joomla
  • Component
  • Redirect
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Controller

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Controller

Structures de données

class | DisplayController
class | LinkController
class | LinksController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Extension

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Extension

Structures de données

class RedirectComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Field

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Field

Structures de données

class RedirectField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Helper

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Helper

Structures de données

class RedirectHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Model

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Model

Structures de données

class | LinkModel
class | LinksModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Service

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Service\HTML

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Service\HTML

Structures de données

class Redirect


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Table

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\Table

Structures de données

class LinkTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View

  • Joomla
  • Component
  • Redirect
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View

Espaces de nommage

Link
Links


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View\Link

  • Joomla
  • Component
  • Redirect
  • Administrator
  • View
  • Link
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View\Link

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View\Links

  • Joomla
  • Component
  • Redirect
  • Administrator
  • View
  • Links
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Administrator\View\Links

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Api

  • Joomla
  • Component
  • Redirect
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Api\Controller

  • Joomla
  • Component
  • Redirect
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Api\Controller

Structures de données

class RedirectController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Api\View

  • Joomla
  • Component
  • Redirect
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Redirect\Api\View

Espaces de nommage

Redirect


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Redirect\Api\View\Redirect

  • Joomla
  • Component
  • Redirect
  • Api
  • View
  • Redirect
Structures de données
Référence de l'espace de nommage Joomla\Component\Redirect\Api\View\Redirect

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler

  • Joomla
  • Component
  • Scheduler
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Scheduler

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator

  • Joomla
  • Component
  • Scheduler
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator

Espaces de nommage

Controller
Event
Extension
Field
Helper
Model
Rule
Scheduler
Table
Task
Traits
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Controller

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Controller

Structures de données

class | DisplayController
class | TaskController
class | TasksController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Event

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Event

Structures de données

class ExecuteTaskEvent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Extension

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Extension

Structures de données

class SchedulerComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Field

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Field

Structures de données

class | CronField
class | ExecutionRuleField
class | IntervalField
class | TaskStateField
class | TaskTypeField
class | WebcronLinkField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Helper

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Helper

Structures de données

class | ExecRuleHelper
class | SchedulerHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Model

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Model

Structures de données

class | SelectModel
class | TaskModel
class | TasksModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Rule

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Rule
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Rule

Structures de données

class ExecutionRulesRule


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Scheduler

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Scheduler
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Scheduler

Structures de données

class Scheduler


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Table

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Table

Structures de données

class TaskTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Task

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Task
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Task

Structures de données

class | Status
class | Task
class | TaskOption
class | TaskOptions


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Traits

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Traits
Fonctions | Variables
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\Traits

Fonctions

startRoutine (ExecuteTaskEvent $event)
endRoutine (ExecuteTaskEvent $event, int $exitCode)
advertiseRoutines (EventInterface $event)
getRoutineId (Form $form, $data)
logTask (string $message, string $priority='info')
standardRoutineHandler (ExecuteTaskEvent $event)

Variables

trait TaskPluginTrait

Documentation des fonctions

◆ advertiseRoutines()

Joomla\Component\Scheduler\Administrator\Traits\advertiseRoutines ( EventInterface $event )

Advertise the task routines supported by the plugin. This method should be mapped to the onTaskOptionsList, enabling the plugin to advertise its routines without any custom logic.
Note: This method expects the TASKS_MAP class constant to have relevant information.

Paramètres
EventInterface $event onTaskOptionsList Event
Renvoie
void
Depuis
4.1.0

Références $options, $subject, et EventInterface\getArgument().

◆ endRoutine()

Joomla\Component\Scheduler\Administrator\Traits\endRoutine | ( | ExecuteTaskEvent | $event,
 |  | int | $exitCode
 | ) |  |
protected

Set information to {

Voir également
$snapshot} when ending a routine. This information includes the routine exit code and timing information.
Paramètres
ExecuteTaskEvent | $event | The event
?int | $exitCode The task exit code
Renvoie
void
Depuis
4.1.0
Exceptions

Références $this, Status\OK, et ExecuteTaskEvent\setResult().

Référencé par SiteStatus\alterSiteStatus(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ getRoutineId()

Joomla\Component\Scheduler\Administrator\Traits\getRoutineId | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Get the relevant task routine ID in the context of a form event, e.g., the onContentPrepareForm event.

Paramètres
Form | $form | The form
mixed | $data | The data
Renvoie
string
Depuis
4.1.0
Exceptions

Références $app, $data, $form, Factory\getApplication(), et ArrayHelper\getValue().

◆ logTask()

Joomla\Component\Scheduler\Administrator\Traits\logTask | ( | string | $message,
 |  | string | $priority = 'info'
 | ) |  |
protected

Add a log message to the task log.

Paramètres
string | $message | The log message
string | $priority | The log message priority
Renvoie
void
Depuis
4.1.0
Exceptions

Références $app, $category, $message, Text\_(), Log\add(), Log\DEBUG, Log\ERROR, Factory\getApplication(), Log\INFO, JPATH_ADMINISTRATOR, Log\NOTICE, et Log\WARNING.

Référencé par SiteStatus\alterSiteStatus(), Checkfiles\checkImages(), Requests\makeGetRequest(), DemoTasks\sleep(), Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler(), DemoTasks\stressMemory(), DemoTasks\stressMemoryRemoveLimit(), et SiteStatus\writeConfigFile().

◆ standardRoutineHandler()

Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler ( ExecuteTaskEvent $event )

Handler for standard task routines. Standard routines are mapped to valid class methods 'method' through static::TASKS_MAP. These methods are expected to take a single argument (the Event) and return an integer return status (see {

Voir également
Status}). For a plugin that maps each of its task routines to valid methods and does not need non-standard handling, this method can be mapped to the onExecuteTask event through {
SubscriberInterface::getSubscribedEvents()}, which would allow it to then check if the event wants to execute a routine offered by the parent plugin, call the routine and do some other housework without any code in the parent classes.
Compatible routine method signature: ({
ExecuteTaskEvent::class}, ...): int
Paramètres
ExecuteTaskEvent $event The onExecuteTask event.
Renvoie
void
Depuis
4.1.0
Exceptions

Closure to validate a status against {

Voir également
Status}
Depuis
4.1.0

Références $method, $methodName, Symfony\Component\Console\Tester\$statusCode, $this, class, Joomla\Component\Scheduler\Administrator\Traits\endRoutine(), ExecuteTaskEvent\getRoutineId(), Status\INVALID_EXIT, Joomla\Component\Scheduler\Administrator\Traits\logTask(), Status\NO_EXIT, Status\NO_RUN, et Joomla\Component\Scheduler\Administrator\Traits\startRoutine().

◆ startRoutine()

Joomla\Component\Scheduler\Administrator\Traits\startRoutine ( ExecuteTaskEvent $event )
protected

Set information to {

Voir également
$snapshot} when initializing a routine.
Paramètres
ExecuteTaskEvent $event The onExecuteTask event.
Renvoie
void
Depuis
4.1.0

Références $this, AbstractEvent\getArgument(), et Status\RUNNING.

Référencé par SiteStatus\alterSiteStatus(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

Documentation des variables

◆ TaskPluginTrait

trait TaskPluginTrait
Valeur initiale :
{
protected $snapshot = []

Utility trait for plugins that offer com_scheduler compatible task routines. This trait defines a lot of handy methods that make it really simple to support task routines in a J4.x plugin. This trait includes standard methods to broadcast routines {

Voir également
TaskPluginTrait::advertiseRoutines()}, enhance task forms {
TaskPluginTrait::enhanceTaskItemForm()} and call routines {
TaskPluginTrait::standardRoutineHandler()}. With standard cookie-cutter behaviour, a task plugin may only need to include this trait, and define methods corresponding to each routine along with the TASKS_MAP class constant to declare supported routines and related properties.
Depuis
4.1.0


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View

Espaces de nommage

Select
Task
Tasks


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Select

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Select
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Select

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Task

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Task
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Task

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Tasks

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Tasks
Structures de données
Référence de l'espace de nommage Joomla\Component\Scheduler\Administrator\View\Tasks

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags

  • Joomla
  • Component
  • Tags
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator

  • Joomla
  • Component
  • Tags
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Administrator

Espaces de nommage

Controller
Extension
Model
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Controller

  • Joomla
  • Component
  • Tags
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Controller

Structures de données

class | DisplayController
class | TagController
class | TagsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Extension

  • Joomla
  • Component
  • Tags
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Extension

Structures de données

class TagsComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Model

  • Joomla
  • Component
  • Tags
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Model

Structures de données

class | TagModel
class | TagsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Table

  • Joomla
  • Component
  • Tags
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\Table

Structures de données

class TagTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View

  • Joomla
  • Component
  • Tags
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View

Espaces de nommage

Tag
Tags


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View\Tag

  • Joomla
  • Component
  • Tags
  • Administrator
  • View
  • Tag
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View\Tag

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View\Tags

  • Joomla
  • Component
  • Tags
  • Administrator
  • View
  • Tags
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Administrator\View\Tags

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Api

  • Joomla
  • Component
  • Tags
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Api\Controller

  • Joomla
  • Component
  • Tags
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Api\Controller

Structures de données

class TagsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Api\View

  • Joomla
  • Component
  • Tags
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Api\View

Espaces de nommage

Tags


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Api\View\Tags

  • Joomla
  • Component
  • Tags
  • Api
  • View
  • Tags
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Api\View\Tags

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site

  • Joomla
  • Component
  • Tags
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Site

Espaces de nommage

Controller
Helper
Model
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\Controller

  • Joomla
  • Component
  • Tags
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\Controller

Structures de données

class | DisplayController
class | TagsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\Helper

  • Joomla
  • Component
  • Tags
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\Helper

Structures de données

class RouteHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\Model

  • Joomla
  • Component
  • Tags
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\Model

Structures de données

class | TagModel
class | TagsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\Service

  • Joomla
  • Component
  • Tags
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\View

  • Joomla
  • Component
  • Tags
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Tags\Site\View

Espaces de nommage

Tag
Tags


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\View\Tag

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tag
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\View\Tag

Structures de données

class | FeedView
class | HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Tags\Site\View\Tags

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tags
Structures de données
Référence de l'espace de nommage Joomla\Component\Tags\Site\View\Tags

Structures de données

class | FeedView
class | HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates

  • Joomla
  • Component
  • Templates
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates

Espaces de nommage

Administrator
Api


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator

  • Joomla
  • Component
  • Templates
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates\Administrator

Espaces de nommage

Controller
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Controller

  • Joomla
  • Component
  • Templates
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Controller

Structures de données

class | DisplayController
class | StyleController
class | StylesController
class | TemplateController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Extension

  • Joomla
  • Component
  • Templates
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Extension

Structures de données

class TemplatesComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Field

  • Joomla
  • Component
  • Templates
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Field

Structures de données

class | TemplatelocationField
class | TemplatenameField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Helper

  • Joomla
  • Component
  • Templates
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Helper

Structures de données

class | TemplateHelper
class | TemplatesHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Model

  • Joomla
  • Component
  • Templates
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Model

Structures de données

class | StyleModel
class | StylesModel
class | TemplateModel
class | TemplatesModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Service

  • Joomla
  • Component
  • Templates
  • Administrator
  • Service
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Service

Espaces de nommage

HTML


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Service\HTML

  • Joomla
  • Component
  • Templates
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Service\HTML

Structures de données

class Templates


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Table

  • Joomla
  • Component
  • Templates
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\Table

Structures de données

class StyleTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View

Espaces de nommage

Style
Styles
Template
Templates


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Style

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Style
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Style

Structures de données

class | HtmlView
class | JsonView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Styles

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Styles
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Styles

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Template

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Template
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Template

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Templates

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Templates
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Administrator\View\Templates

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Api

  • Joomla
  • Component
  • Templates
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Api\Controller

  • Joomla
  • Component
  • Templates
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Api\Controller

Structures de données

class StylesController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Api\View

  • Joomla
  • Component
  • Templates
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Templates\Api\View

Espaces de nommage

Styles


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Templates\Api\View\Styles

  • Joomla
  • Component
  • Templates
  • Api
  • View
  • Styles
Structures de données
Référence de l'espace de nommage Joomla\Component\Templates\Api\View\Styles

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users

  • Joomla
  • Component
  • Users
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users

Espaces de nommage

Administrator
Api
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator

  • Joomla
  • Component
  • Users
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Administrator

Espaces de nommage

Controller
DataShape
Dispatcher
Extension
Field
Helper
Model
Service
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Controller

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Controller

Structures de données

class | CallbackController
class | CaptiveController
class | DisplayController
class | GroupController
class | GroupsController
class | LevelController
class | LevelsController
class | MailController
class | MethodController
class | MethodsController
class | NoteController
class | NotesController
class | UserController
class | UsersController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\DataShape

  • Joomla
  • Component
  • Users
  • Administrator
  • DataShape
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\DataShape

Structures de données

class | CaptiveRenderOptions
class | DataShapeObject
class | MethodDescriptor
class | SetupRenderOptions


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Dispatcher

  • Joomla
  • Component
  • Users
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Extension

  • Joomla
  • Component
  • Users
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Extension

Structures de données

class UsersComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Field

  • Joomla
  • Component
  • Users
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Field

Structures de données

class | GroupparentField
class | LevelsField
class | ModulesPositionField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Helper

  • Joomla
  • Component
  • Users
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Helper

Structures de données

class | DebugHelper
class | Mfa
class | UsersHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Model

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Model

Structures de données

class | BackupcodesModel
class | CaptiveModel
class | DebuggroupModel
class | DebuguserModel
class | GroupModel
class | GroupsModel
class | LevelModel
class | LevelsModel
class | MailModel
class | MethodModel
class | MethodsModel
class | NoteModel
class | NotesModel
class | UserModel
class | UsersModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Service

  • Joomla
  • Component
  • Users
  • Administrator
  • Service
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Service

Espaces de nommage

HTML

Structures de données

class Encrypt


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Service\HTML

  • Joomla
  • Component
  • Users
  • Administrator
  • Service
  • HTML
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Service\HTML

Structures de données

class Users


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\Table

  • Joomla
  • Component
  • Users
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\Table

Structures de données

class | MfaTable
class | NoteTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View

  • Joomla
  • Component
  • Users
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View

Espaces de nommage

Captive
Debuggroup
Debuguser
Group
Groups
Level
Levels
Mail
Method
Methods
Note
Notes
User
Users


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Captive

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Captive
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Captive

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Debuggroup

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Debuggroup
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Debuggroup

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Debuguser

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Debuguser
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Debuguser

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Group

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Group
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Group

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Groups

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Groups
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Groups

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Level

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Level
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Level

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Levels

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Levels
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Levels

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Mail

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Mail
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Mail

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Method

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Method
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Method

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Methods

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Methods
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Methods

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Note

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Note
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Note

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Notes

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Notes
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Notes

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\User

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • User
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\User

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Users

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Users
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Administrator\View\Users

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api

  • Joomla
  • Component
  • Users
  • Api
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Api

Espaces de nommage

Controller
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api\Controller

  • Joomla
  • Component
  • Users
  • Api
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Api\Controller

Structures de données

class | GroupsController
class | LevelsController
class | UsersController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api\View

  • Joomla
  • Component
  • Users
  • Api
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Api\View

Espaces de nommage

Groups
Levels
Users


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api\View\Groups

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Groups
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Api\View\Groups

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api\View\Levels

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Levels
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Api\View\Levels

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Api\View\Users

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Users
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Api\View\Users

Structures de données

class JsonapiView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site

  • Joomla
  • Component
  • Users
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Site

Espaces de nommage

Controller
Model
Rule
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\Controller

  • Joomla
  • Component
  • Users
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\Controller

Structures de données

class | CallbackController
class | CaptiveController
class | DisplayController
class | MethodController
class | MethodsController
class | ProfileController
class | RegistrationController
class | RemindController
class | ResetController
class | UserController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\Model

  • Joomla
  • Component
  • Users
  • Site
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\Model

Structures de données

class | BackupcodesModel
class | CaptiveModel
class | LoginModel
class | MethodModel
class | MethodsModel
class | ProfileModel
class | RegistrationModel
class | RemindModel
class | ResetModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\Rule

  • Joomla
  • Component
  • Users
  • Site
  • Rule
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\Rule

Structures de données

class | LoginUniqueFieldRule
class | LogoutUniqueFieldRule


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\Service

  • Joomla
  • Component
  • Users
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View

  • Joomla
  • Component
  • Users
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Users\Site\View

Espaces de nommage

Captive
Login
Method
Methods
Profile
Registration
Remind
Reset


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Captive

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Captive
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Captive

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Login

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Login
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Login

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Method

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Method
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Method

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Methods

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Methods
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Methods

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Profile

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Profile
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Profile

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Registration

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Registration
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Registration

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Remind

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Remind
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Remind

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Users\Site\View\Reset

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Reset
Structures de données
Référence de l'espace de nommage Joomla\Component\Users\Site\View\Reset

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow

  • Joomla
  • Component
  • Workflow
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Workflow

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator

  • Joomla
  • Component
  • Workflow
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator

Espaces de nommage

Controller
Dispatcher
Field
Helper
Model
Table
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Controller

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Controller

Structures de données

class | DisplayController
class | StageController
class | StagesController
class | TransitionController
class | TransitionsController
class | WorkflowController
class | WorkflowsController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Dispatcher

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Field

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Field

Structures de données

class | ComponentsWorkflowField
class | WorkflowcontextsField


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Helper

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Helper

Structures de données

class | StageHelper
class | WorkflowHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Model

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Model

Structures de données

class | StageModel
class | StagesModel
class | TransitionModel
class | TransitionsModel
class | WorkflowModel
class | WorkflowsModel


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Table

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Table
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\Table

Structures de données

class | StageTable
class | TransitionTable
class | WorkflowTable


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View

Espaces de nommage

Stage
Stages
Transition
Transitions
Workflow
Workflows


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Stage

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Stage
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Stage

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Stages

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Stages
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Stages

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Transition

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Transition
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Transition

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Transitions

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Transitions
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Transitions

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Workflow

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Workflow
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Workflow

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Workflows

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Workflows
Structures de données
Référence de l'espace de nommage Joomla\Component\Workflow\Administrator\View\Workflows

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper

  • Joomla
  • Component
  • Wrapper
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Wrapper

Espaces de nommage

Administrator
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Administrator

  • Joomla
  • Component
  • Wrapper
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Wrapper\Administrator

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Administrator\Extension

  • Joomla
  • Component
  • Wrapper
  • Administrator
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Component\Wrapper\Administrator\Extension

Structures de données

class WrapperComponent


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Site

  • Joomla
  • Component
  • Wrapper
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Wrapper\Site

Espaces de nommage

Controller
Service
View


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Site\Controller

  • Joomla
  • Component
  • Wrapper
  • Site
  • Controller
Structures de données
Référence de l'espace de nommage Joomla\Component\Wrapper\Site\Controller

Structures de données

class DisplayController


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Site\Service

  • Joomla
  • Component
  • Wrapper
  • Site
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Component\Wrapper\Site\Service

Structures de données

class Router


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Site\View

  • Joomla
  • Component
  • Wrapper
  • Site
  • View
Espaces de nommage
Référence de l'espace de nommage Joomla\Component\Wrapper\Site\View

Espaces de nommage

Wrapper


Joomla CMS: Référence de l'espace de nommage Joomla\Component\Wrapper\Site\View\Wrapper

  • Joomla
  • Component
  • Wrapper
  • Site
  • View
  • Wrapper
Structures de données
Référence de l'espace de nommage Joomla\Component\Wrapper\Site\View\Wrapper

Structures de données

class HtmlView


Joomla CMS: Référence de l'espace de nommage Joomla\Console

  • Joomla
  • Console
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Console

Espaces de nommage

Command
Descriptor
Event
Exception
Helper
Loader

Structures de données

class | Application
class | ConsoleEvents

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Command

  • Joomla
  • Console
  • Command
Structures de données
Référence de l'espace de nommage Joomla\Console\Command

Structures de données

class | AbstractCommand
class | HelpCommand
class | ListCommand

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Descriptor

  • Joomla
  • Console
  • Descriptor
Structures de données
Référence de l'espace de nommage Joomla\Console\Descriptor

Structures de données

class | ApplicationDescription
class | TextDescriptor

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Event

  • Joomla
  • Console
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Console\Event

Structures de données

class | ApplicationErrorEvent
class | BeforeCommandExecuteEvent
class | CommandErrorEvent
class | ConsoleEvent
class | TerminateEvent

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Exception

  • Joomla
  • Console
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Console\Exception

Structures de données

class NamespaceNotFoundException

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Helper

  • Joomla
  • Console
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Console\Helper

Structures de données

class DescriptorHelper

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Console\Loader

  • Joomla
  • Console
  • Loader
Structures de données
Référence de l'espace de nommage Joomla\Console\Loader

Structures de données

class | ContainerLoader
interface | LoaderInterface

Description détaillée

Part of the Joomla Framework Console Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Crypt

  • Joomla
  • Crypt
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Crypt

Espaces de nommage

Cipher
Exception

Structures de données

interface | CipherInterface
class | Crypt
class | Key

Description détaillée

Part of the Joomla Framework Crypt Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Crypt\Cipher

  • Joomla
  • Crypt
  • Cipher
Structures de données
Référence de l'espace de nommage Joomla\Crypt\Cipher

Structures de données

class | Crypto
class | OpenSSL
class | Sodium

Description détaillée

Part of the Joomla Framework Crypt Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Crypt\Exception

  • Joomla
  • Crypt
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Crypt\Exception

Structures de données

interface | CryptExceptionInterface
class | DecryptionException
class | EncryptionException
class | InvalidKeyException
class | InvalidKeyTypeException
class | UnsupportedCipherException

Description détaillée

Part of the Joomla Framework Crypt Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Data

  • Joomla
  • Data
Structures de données
Référence de l'espace de nommage Joomla\Data

Structures de données

class | DataObject
class | DataSet
interface | DumpableInterface

Description détaillée

Part of the Joomla Framework Data Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database

  • Joomla
  • Database
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\Database

Espaces de nommage

Command
Event
Exception
Monitor
Mysql
Mysqli
Pdo
Pgsql
Query
Service
Sqlazure
Sqlite
Sqlsrv

Structures de données

interface | DatabaseAwareInterface
class | DatabaseDriver
class | DatabaseEvents
class | DatabaseExporter
class | DatabaseFactory
class | DatabaseImporter
interface | DatabaseInterface
class | DatabaseIterator
class | DatabaseQuery
class | FetchMode
class | FetchOrientation
class | ParameterType
interface | QueryInterface
interface | QueryMonitorInterface
interface | StatementInterface
interface | UTF8MB4SupportInterface

Fonctions

getDatabase ()
setDatabase (DatabaseInterface $db)

Variables

trait DatabaseAwareTrait

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2022 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getDatabase()

Joomla\Database\getDatabase ( )
protected

Get the database.

Renvoie
DatabaseInterface
Depuis
2.1.0
Exceptions
DatabaseNotFoundException May be thrown if the database has not been set.

Références $this.

Référencé par InstallerAdapter\__get(), ComponentAdapter\_buildAdminMenus(), CategoryModel\_buildContentOrderBy(), PackageAdapter\_getExtensionId(), InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), TasksModel\_getList(), MapsModel\_getListCount(), Categories\_load(), ModuleAdapter\_rollback_menu(), ModuleAdapter\_rollback_module(), ComponentAdapter\_updateMenus(), Installer\abort(), RegistrationModel\activate(), LinkModel\activate(), ActionlogModel\addLog(), MessagesModel\addPostInstallationMessage(), UpdateModel\applyUpdateSite(), MessagesModel\archiveMessage(), ItemModel\batchCopy(), ModuleModel\batchCopy(), CategoryModel\batchCopy(), CategoryModel\batchFlipordering(), ItemModel\batchMove(), CategoryModel\batchMove(), LinksModel\batchProcess(), UserModel\batchReset(), UserModel\batchUser(), ContactModel\buildContactExtendedData(), LevelModel\canDelete(), FieldModel\checkDefaultValue(), LibraryAdapter\checkExtensionInFilesystem(), DiscoverModel\checkExtensions(), CheckinModel\checkin(), TemplateModel\checkNewName(), AssociationsModel\clean(), Installer\cleanDiscoveredExtension(), ArticleModel\cleanupPostBatchCopy(), FieldModel\cleanupValues(), BannerModel\click(), Banner\clientlist(), PackageAdapter\copyBaseFiles(), TemplateModel\copyStyles(), WorkflowsModel\countItems(), ArticlesModel\countItemsByMonth(), CategoryFactory\createCategory(), PluginAdapter\createExtensionRoot(), FormFactory\createForm(), MenuFactory\createMenu(), MVCFactory\createModel(), MVCFactory\createTable(), UpdatesitesModel\delete(), TracksModel\delete(), ModuleModel\delete(), ActionlogsModel\delete(), FieldModel\delete(), ArticleModel\delete(), MethodsModel\deleteAll(), DiscoverModel\discover(), DiscoverModel\discover_install(), ListUserCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), ExtensionRemoveCommand\doExecute(), ModuleModel\duplicate(), LinkModel\duplicateUrls(), FileAdapter\extensionExistsInSystem(), ContactModel\featured(), ArticleModel\featured(), DatabaseModel\fetchSchemaCache(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), UpdateModel\finaliseUpgrade(), DatabaseModel\fix(), DatabaseModel\fixDefaultTextFilters(), DatabaseModel\fixSchemaVersion(), DatabaseModel\fixUpdateVersion(), StyleModel\getAdminTemplate(), ExtensionsListCommand\getAllExtensionsFromDB(), TemplateModel\getAllTemplateStyles(), ConsentBoxField\getAssignedArticleUrl(), ConsentBoxField\getAssignedMenuItemUrl(), TracksModel\getCategoryName(), BannersModel\getCategoryOrders(), UpdateModel\getCheckForSelfUpdate(), TracksModel\getClientName(), MessagesModel\getComponentOptions(), StatisticsModel\getData(), ApplicationModel\getData(), BaseDatabaseModel\getDbo(), ConsoleApplication\getDefaultCommands(), DatabaseModel\getDefaultTextFilters(), UpdateModel\getDisabledUpdateSites(), EditorField\getEditor(), DiscoverModel\getEmptyStateQuery(), TagsModel\getEmptyStateQuery(), MapsModel\getEmptyStateQuery(), ModulesModel\getEmptyStateQuery(), CategoriesModel\getEmptyStateQuery(), UpdateModel\getEmptyStateQuery(), MenuModel\getExtensionElementsForMenuItems(), MessagesModel\getExtensionName(), TemplatesModel\getExtensions(), FieldModel\getFieldValues(), TransitionsModel\getFilterForm(), TransitionModel\getForm(), TemplateModel\getForm(), DebuggroupModel\getGroup(), AddUserCommand\getGroupId(), AddUserToGroupCommand\getGroupId(), RemoveUserFromGroupCommand\getGroupId(), MenuField\getGroups(), UserMessagesField\getGroups(), ContentmapField\getGroups(), WorkflowstageField\getGroups(), TemplatestyleField\getGroups(), AddUserToGroupCommand\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), RemoveUserFromGroupCommand\getGroups(), FieldsModel\getGroups(), HelperFactory\getHelper(), SysinfoModel\getInfo(), PlugininfoField\getInput(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), RulesField\getInput(), CalendarField\getInput(), ConfigModel\getItem(), MessagesModel\getItem(), NewsfeedModel\getItem(), UpdatesiteModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), FieldModel\getItem(), ArticleModel\getItem(), ModuleModel\getItem(), MenusModel\getItems(), TemplatesModel\getItems(), LanguagesModel\getItems(), PositionsModel\getItems(), UsersModel\getItems(), CheckinModel\getItems(), ClientsModel\getItems(), UpdatesitesModel\getJoomlaUpdateSitesIds(), TosField\getLabel(), LanguagesModel\getLanguageList(), PrivacyField\getLayoutData(), TermsField\getLayoutData(), RequestsModel\getListQuery(), FiltersModel\getListQuery(), ConsentsModel\getListQuery(), SuggestionsModel\getListQuery(), NotesModel\getListQuery(), SelectModel\getListQuery(), ActionlogsModel\getListQuery(), ArchiveModel\getListQuery(), TracksModel\getListQuery(), FeaturedModel\getListQuery(), DiscoverModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), LevelsModel\getListQuery(), SearchesModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), TemplatesModel\getListQuery(), StylesModel\getListQuery(), StagesModel\getListQuery(), GroupsModel\getListQuery(), TransitionsModel\getListQuery(), SearchModel\getListQuery(), LinksModel\getListQuery(), FieldsModel\getListQuery(), TagModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), MenusModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), MapsModel\getListQuery(), IndexModel\getListQuery(), DebuguserModel\getListQuery(), PluginsModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), HistoryModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), ActionlogConfigModel\getLogContentTypeParams(), ActionlogsModel\getLogDataAsIterator(), ActionlogsModel\getLogDataQuery(), ActionlogsModel\getLogsData(), ActionlogsModel\getLogsForItem(), ItemsModel\getMenu(), LoginModel\getMenuLanguage(), MenusModel\getMissingModuleLanguages(), MenusModel\getModMenuId(), MenuModel\getModules(), ItemModel\getModules(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), RequestsModel\getNumberUrgentRequests(), FieldgroupsField\getOptions(), FrontendlanguageField\getOptions(), ComponentsField\getOptions(), AliastagField\getOptions(), NewsfeedsField\getOptions(), SearchfilterField\getOptions(), ComponentsCategoryField\getOptions(), MenuParentField\getOptions(), ExtensionField\getOptions(), ConfigComponentsField\getOptions(), LogtypeField\getOptions(), MenuOrderingField\getOptions(), ComponentsWorkflowField\getOptions(), AuthorField\getOptions(), ContenttypesField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), LogcreatorField\getOptions(), ContenttypeField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), SqlField\getOptions(), IndexModel\getPluginState(), TemplateModel\getPreview(), PluginorderingField\getQuery(), OrderingField\getQuery(), StagesModel\getReorderConditions(), TransitionsModel\getReorderConditions(), GroupModel\getReorderConditions(), WorkflowModel\getReorderConditions(), BannerModel\getReorderConditions(), CategoryModel\getReorderConditions(), PluginModel\getReorderConditions(), NewsfeedModel\getReorderConditions(), ContactModel\getReorderConditions(), FieldModel\getReorderConditions(), ItemModel\getReorderConditions(), ArticleModel\getReorderConditions(), ModuleModel\getReorderConditions(), DatabaseModel\getSchemaVersion(), LanguageAdapter\getSefString(), StyleModel\getSiteTemplates(), ArchiveModel\getSlugColumn(), TaskModel\getTask(), TemplateModel\getTemplate(), TemplateModel\getTemplateList(), ChromestyleField\getTemplates(), Query\getTokenData(), Token\getTokenSeedForUser(), FilterModel\getTotal(), IndexModel\getTotalIndexed(), ArticlesModel\getTransitions(), MenutypesModel\getTypeOptions(), TemplateModel\getUpdatedList(), UpdateModel\getUpdateInformation(), LanguagesModel\getUpdateSite(), UpdateModel\getUpdateSitesInfo(), UsersModel\getUserDisplayedGroups(), FiltersField\getUserGroups(), AddUserCommand\getUserGroups(), AddUserToGroupCommand\getUserId(), RegistrationModel\getUserIdFromToken(), ItemModel\getViewLevels(), ArchiveModel\getYears(), MessagesModel\hideMessages(), BannersModel\impress(), LanguagesModel\install(), ConsentsModel\invalidate(), ConsentsModel\invalidateAll(), UpdateModel\isTemplateActive(), Token\isTokenEnabledForUser(), Installer\loadAdapter(), ManageModel\loadChangelog(), Form\loadField(), Finder\mapslist(), Joomla\onAfterCheckin(), Joomla\onContentChangeState(), Basic\onUserAuthenticate(), Joomla\onUserLoginFailure(), TemplateAdapter\parseQueries(), Installer\parseSchemaUpdates(), GroupsModel\populateExtraData(), ArchiveModel\populateState(), FeaturedModel\populateState(), SearchModel\populateState(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ContactModel\prepareTable(), PluginModel\preprocessForm(), FormModel\preprocessForm(), ExtensionDiscoverInstallCommand\processDiscover(), Query\processDynamicTaxonomy(), SqlField\processQuery(), RemindModel\processRemindRequest(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processStaticTaxonomy(), UpdatesitesModel\publish(), ManageModel\publish(), TemplateModel\publish(), LinksModel\purge(), MessagesModel\purge(), OverridesModel\purge(), DiscoverModel\purge(), UpdateModel\purge(), IndexModel\purge(), ActionlogsModel\purge(), MapsModel\purge(), AssociationsModel\purge(), UpdatesitesModel\rebuild(), ItemModel\rebuild(), StringsModel\refresh(), RegistrationModel\register(), ManageModel\remove(), PackageAdapter\removeExtensionFiles(), MessagesModel\republishMessage(), SearchesModel\reset(), MessagesModel\resetMessages(), LanguageAdapter\resetUserLanguage(), FieldModel\save(), ConfigModel\save(), UpdatesiteModel\save(), ApplicationModel\save(), StyleModel\save(), CategoryModel\save(), ItemModel\save(), StringsModel\search(), Filter\select(), MailModel\send(), ActionlogModel\sendNotificationEmails(), FieldModel\setFieldValue(), MethodsModel\setFlag(), StyleModel\setHome(), Installer\setSchemaVersion(), TemplateAdapter\setupUninstall(), ComponentAdapter\setupUpdates(), Filter\slider(), ArticleModel\storeVote(), ExistsRule\test(), UsernameRule\test(), UserIdRule\test(), EmailRule\test(), Finder\typeslist(), MessagesModel\unpublishMessage(), StyleModel\unsetHome(), UpdateModel\update(), TemplatesModel\updated(), RequestModel\validate(), et FormField\validate().

◆ setDatabase()

Joomla\Database\setDatabase ( DatabaseInterface $db )

Set the database.

Paramètres
DatabaseInterface $db The database.
Renvoie
void
Depuis
2.1.0

Références $db.

Référencé par CredentialRepository\__construct(), ListUserCommand\__construct(), ExtensionDiscoverInstallCommand\__construct(), ExtensionsListCommand\__construct(), DeleteUserCommand\__construct(), Adapter\__construct(), AddUserToGroupCommand\__construct(), RemoveUserFromGroupCommand\__construct(), BaseDatabaseModel\__construct(), ExtensionRemoveCommand\__construct(), AddUserCommand\__construct(), InstallerAdapter\__construct(), Query\__construct(), et BaseDatabaseModel\setDbo().

Documentation des variables

◆ DatabaseAwareTrait

trait DatabaseAwareTrait
Valeur initiale :
{
private $databaseAwareTraitDatabase

Defines the trait for a Database Aware Class.

Depuis
2.1.0


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Command

  • Joomla
  • Database
  • Command
Structures de données
Référence de l'espace de nommage Joomla\Database\Command

Structures de données

class | ExportCommand
class | ImportCommand

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Event

  • Joomla
  • Database
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Database\Event

Structures de données

class ConnectionEvent

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Exception

  • Joomla
  • Database
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Database\Exception

Structures de données

class | ConnectionFailureException
class | DatabaseNotFoundException
class | ExecutionFailureException
class | PrepareStatementFailureException
class | QueryTypeAlreadyDefinedException
class | UnknownTypeException
class | UnsupportedAdapterException

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2022 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Monitor

  • Joomla
  • Database
  • Monitor
Structures de données
Référence de l'espace de nommage Joomla\Database\Monitor

Structures de données

class | ChainedMonitor
class | DebugMonitor
class | LoggingMonitor

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Mysql

  • Joomla
  • Database
  • Mysql
Structures de données
Référence de l'espace de nommage Joomla\Database\Mysql

Structures de données

class | MysqlDriver
class | MysqlExporter
class | MysqlImporter
class | MysqlQuery

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Mysqli

  • Joomla
  • Database
  • Mysqli
Structures de données
Référence de l'espace de nommage Joomla\Database\Mysqli

Structures de données

class | MysqliDriver
class | MysqliExporter
class | MysqliImporter
class | MysqliQuery
class | MysqliStatement

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Pdo

  • Joomla
  • Database
  • Pdo
Structures de données
Référence de l'espace de nommage Joomla\Database\Pdo

Structures de données

class | PdoDriver
class | PdoQuery
class | PdoStatement

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Pgsql

  • Joomla
  • Database
  • Pgsql
Structures de données
Référence de l'espace de nommage Joomla\Database\Pgsql

Structures de données

class | PgsqlDriver
class | PgsqlExporter
class | PgsqlImporter
class | PgsqlQuery

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Query

  • Joomla
  • Database
  • Query
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\Database\Query

Structures de données

interface | LimitableInterface
interface | PreparableInterface
class | QueryElement

Fonctions

regexp ($value)
rand ()
findInSet ($value, $set)
selectRowNumber ($orderBy, $orderColumnAlias)
castAs (string $type, string $value, ?string $length=null)
__toString ()
clear ($clause=null)
concatenate ($values, $separator=null)
currentTimestamp ()
forUpdate ($tableName, $glue=',')
forShare ($tableName, $glue=',')
groupConcat ($expression, $separator=',')
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
noWait ()
limit ($limit=0)
offset ($offset=0)
returning ($pkCol)
processLimit ($query, $limit, $offset=0)
dateAdd ($date, $interval, $datePart)

Variables

trait | MysqlQueryBuilder
trait | PostgresqlQueryBuilder
$forShare
$noWait
$limit
$offset
$returning

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ __toString()

Joomla\Database\Query\__toString ( )

Magic function to convert the query to a string, only for PostgreSQL specific queries

Renvoie
string The completed query.
Depuis
2.0.0

Références $query, $this, elseif, Joomla\Database\Query\forShare(), Joomla\Database\Query\forUpdate(), Joomla\Database\Query\limit(), Joomla\Database\Query\noWait(), null, Joomla\Database\Query\offset(), Joomla\Database\Query\processLimit(), Joomla\Database\Query\returning(), et Joomla\Database\Query\selectRowNumber().

Référencé par SqliteQuery\__toString(), OtherObject\__toString(), ByteStringWithChunkObject\__toString(), TextStringWithChunkObject\__toString(), SignedIntegerObject\__toString(), UnsignedIntegerObject\__toString(), TagObject\__toString(), SqlsrvQuery\__toString(), InfiniteListObject\__toString(), InfiniteMapObject\__toString(), ByteStringObject\__toString(), TextStringObject\__toString(), MapObject\__toString(), ListObject\__toString(), et EC\__toString().

◆ castAs()

castAs | ( | string | $type,
 |  | string | $value,
 |  | ?string | $length = null
 | ) |  |

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAs('CHAR', 'a'));

Paramètres
string | $type | The type of string to cast as.
string | $value | The value to cast as a char.
string | $length | The value to cast as a char.
Renvoie
string SQL statement to cast the value as a char type.
Depuis
1.0

Références $type, et $value.

Référencé par SqlsrvQuery\castAs().

◆ clear()

Joomla\Database\Query\clear ( $clause = null )

Clear data from the query or a specific clause of the query.

Paramètres
string $clause Optionally, the name of the clause to clear, or nothing to clear the whole query.
Renvoie
$this
Depuis
2.0.0

Références $this, Joomla\Database\Query\forShare(), Joomla\Database\Query\forUpdate(), Joomla\Database\Query\limit(), Joomla\Database\Query\noWait(), null, Joomla\Database\Query\offset(), et Joomla\Database\Query\returning().

Référencé par Session\clear().

◆ concatenate()

Joomla\Database\Query\concatenate | ( | $values,
 |  | $separator = null
 | ) |

Concatenates an array of column names or values.

Usage: $query->select($query->concatenate(array('a', 'b')));

Paramètres
string[] | $values An array of values to concatenate.
string | null | $separator | As separator to place between each value.
Renvoie
string The concatenated values.
Depuis
2.0.0

Références $separator, et null.

◆ currentTimestamp()

Joomla\Database\Query\currentTimestamp ( )

Gets the current date and time.

Renvoie
string Return string used in query to obtain
Depuis
2.0.0

◆ dateAdd()

Joomla\Database\Query\dateAdd | ( | $date,
 |  | $interval,
 |  | $datePart
 | ) |

Add to the current date and time.

Usage: $query->select($query->dateAdd());

Prefixing the interval with a - (negative sign) will cause subtraction to be used.

Paramètres
string | $date | The db quoted string representation of the date to add to
string | $interval | The string representation of the appropriate number of units
string | $datePart | The part of the date to perform the addition on
Renvoie
string The string with the appropriate sql for addition of dates
Depuis
2.0.0 http://www.postgresql.org/docs/9.0/static/functions-datetime.html.

Références $date.

◆ day()

Joomla\Database\Query\day ( $date )

Used to get a string to extract day from date column.

Usage: $query->select($query->day($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing day to be extracted.
Renvoie
string Returns string to extract day from a date.
Depuis
2.0.0

Références $date.

◆ findInSet()

findInSet | ( | $value,
 |  | $set
 | ) |

Find a value in a varchar used like a set.

Ensure that the value is an integer before passing to the method.

Usage: $query->findInSet((int) $parent->id, 'a.assigned_cat_ids')

Paramètres
string | $value | The value to search for.
string | $set | The set of values.
Renvoie
string A representation of the MySQL find_in_set() function for the driver.
Depuis
2.0.0

Références $value.

◆ forShare()

Joomla\Database\Query\forShare | ( | $tableName,
 |  | $glue = ','
 | ) |

Sets the FOR SHARE lock on select's output row

Paramètres
string | $tableName | The table to lock
string | $glue | The glue by which to join the conditions. Defaults to ',' .
Renvoie
$this
Depuis
2.0.0

Références $this, et null.

Référencé par Joomla\Database\Query\__toString(), et Joomla\Database\Query\clear().

◆ forUpdate()

Joomla\Database\Query\forUpdate | ( | $tableName,
 |  | $glue = ','
 | ) |

Sets the FOR UPDATE lock on select's output row

Paramètres
string | $tableName | The table to lock
string | $glue | The glue by which to join the conditions. Defaults to ',' .
Renvoie
$this
Depuis
2.0.0

Références $this, et null.

Référencé par Joomla\Database\Query\__toString(), et Joomla\Database\Query\clear().

◆ groupConcat()

Joomla\Database\Query\groupConcat | ( | $expression,
 |  | $separator = ','
 | ) |

Aggregate function to get input values concatenated into a string, separated by delimiter

Usage: $query->groupConcat('id', ',');

Paramètres
string | $expression | The expression to apply concatenation to, this may be a column name or complex SQL statement.
string | $separator | The delimiter of each concatenated value
Renvoie
string Input values concatenated into a string, separated by delimiter
Depuis
2.0.0

Références $separator.

◆ hour()

Joomla\Database\Query\hour ( $date )

Used to get a string to extract hour from date column.

Usage: $query->select($query->hour($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing hour to be extracted.
Renvoie
string Returns string to extract hour from a date.
Depuis
2.0.0

Références $date.

◆ limit()

Joomla\Database\Query\limit ( $limit = 0 )

Set the LIMIT clause to the query

Paramètres
integer $limit Number of rows to return
Renvoie
$this
Depuis
2.0.0

Références Joomla\Database\Query\$limit, $this, et null.

Référencé par SourceContextProvider\__construct(), Pagination\__construct(), SqliteQuery\__toString(), SqlsrvQuery\__toString(), Joomla\Database\Query\__toString(), DatabaseQuery\__toString(), Pagination\_buildDataObject(), Joomla\Database\Query\clear(), DatabaseQuery\clear(), PdoDriver\connected(), SourceContextProvider\getContext(), Pagination\getListFooter(), Pagination\getPagesLinks(), Pagination\getPaginationLinks(), Pagination\getPaginationPages(), DatabaseQuery\setLimit(), et DatabaseDriver\setQuery().

◆ minute()

Joomla\Database\Query\minute ( $date )

Used to get a string to extract minute from date column.

Usage: $query->select($query->minute($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing minute to be extracted.
Renvoie
string Returns string to extract minute from a date.
Depuis
2.0.0

Références $date.

◆ month()

Joomla\Database\Query\month ( $date )

Used to get a string to extract month from date column.

Usage: $query->select($query->month($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing month to be extracted.
Renvoie
string Returns string to extract month from a date.
Depuis
2.0.0

Références $date.

◆ noWait()

Joomla\Database\Query\noWait ( )

Sets the NOWAIT lock on select's output row

Renvoie
$this
Depuis
2.0.0

Références $this, et null.

Référencé par Joomla\Database\Query\__toString(), et Joomla\Database\Query\clear().

◆ offset()

Joomla\Database\Query\offset ( $offset = 0 )

Set the OFFSET clause to the query

Paramètres
integer $offset An integer for skipping rows
Renvoie
$this
Depuis
2.0.0

Références Joomla\Database\Query\$offset, $this, et null.

Référencé par ParserException\__construct(), RelativeStream\__construct(), SqliteQuery\__toString(), SqlsrvQuery\__toString(), Joomla\Database\Query\__toString(), DatabaseQuery\__toString(), Parser\cleanup(), Joomla\Database\Query\clear(), DatabaseQuery\clear(), PdoDriver\connected(), Parser\doParse(), Parser\isCurrentLineLastLineInDocument(), Parser\parse(), RelativeStream\seek(), DatabaseQuery\setLimit(), et DatabaseDriver\setQuery().

◆ processLimit()

Joomla\Database\Query\processLimit | ( | $query,
 |  | $limit,
 |  | $offset = 0
 | ) |

Method to modify a query already in string format with the needed additions to make the query limited to a particular number of results, or start at a particular offset.

Paramètres
string | $query | The query in string format
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
string
Depuis
2.0.0

Références Joomla\Database\Query\$limit, Joomla\Database\Query\$offset, et $query.

Référencé par Joomla\Database\Query\__toString().

◆ rand()

rand ( )

Get the function to return a random floating-point value

Usage: $query->rand();

Renvoie
string
Depuis
2.0.0

Référencé par ArticlesCategoryHelper\getList().

◆ regexp()

regexp ( $value )

Get the regular expression operator

Usage: $query->where('field ' . $query->regexp($search));

Paramètres
string $value The regex pattern.
Renvoie
string
Depuis
2.0.0

Références $value.

◆ returning()

Joomla\Database\Query\returning ( $pkCol )

Add the RETURNING element to INSERT INTO statement.

Paramètres
mixed $pkCol The name of the primary key column.
Renvoie
$this
Depuis
2.0.0

Références $this, et null.

Référencé par Joomla\Database\Query\__toString(), et Joomla\Database\Query\clear().

◆ second()

Joomla\Database\Query\second ( $date )

Used to get a string to extract seconds from date column.

Usage: $query->select($query->second($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing second to be extracted.
Renvoie
string Returns string to extract second from a date.
Depuis
2.0.0

Références $date.

◆ selectRowNumber()

Joomla\Database\Query\selectRowNumber | ( | $orderBy,
 |  | $orderColumnAlias
 | ) |

Return the number of the current row.

Usage: $query->select('id'); $query->selectRowNumber('ordering,publish_up DESC', 'new_ordering'); $query->from('#__content');

Paramètres
string | $orderBy | An expression of ordering for window function.
string | $orderColumnAlias | An alias for new ordering column.
Renvoie
$this
Depuis
2.0.0
Exceptions

Référencé par Joomla\Database\Query\__toString().

◆ year()

Joomla\Database\Query\year ( $date )

Used to get a string to extract year from date column.

Usage: $query->select($query->year($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing year to be extracted.
Renvoie
string Returns string to extract year from a date.
Depuis
2.0.0

Références $date.

Documentation des variables

◆ $forShare

$forShare
protected

◆ $limit

$limit
protected

Référencé par Joomla\Database\Query\limit(), et Joomla\Database\Query\processLimit().

◆ $noWait

$noWait
protected

◆ $offset

$offset
protected

Référencé par Pagination\_buildDataObject(), Stream\_stream_seek(), Tobscure\JsonApi\addPaginationLink(), Tobscure\JsonApi\addPaginationLinks(), AbstractString\after(), AbstractString\afterLast(), ASN1\asn1map(), PHPMailer\base64EncodeWrapMB(), AbstractString\before(), AbstractString\beforeLast(), ActionlogsModel\buildDateRange(), UsersModel\buildDateRange(), ByteString\bytesAt(), QuestionHelper\cloneInputStream(), CodePointString\codePointsAt(), SymmetricKey\decrypt(), HtmlView\display(), JsonapiView\displayList(), ASN1\encode_der(), CalendarField\filter(), FileStorage\find(), RedisStorage\find(), MemcachedStorage\find(), OpenHandler\find(), PdoStorage\find(), OutputFormatter\formatAndWrap(), SFTP\get(), Totp\getCode(), Adapter\getItems(), TagsModel\getListQuery(), Parameters\getOffset(), AbstractField\getRangeForExpression(), Grapheme\grapheme_position(), Grapheme\grapheme_stripos(), Grapheme\grapheme_strpos(), Grapheme\grapheme_strripos(), Grapheme\grapheme_strrpos(), Iconv\iconv_strpos(), CodePointString\indexOf(), UnicodeString\indexOf(), ByteString\indexOf(), AbstractString\indexOf(), CodePointString\indexOfLast(), UnicodeString\indexOfLast(), ByteString\indexOfLast(), AbstractString\indexOfLast(), PuTTY\load(), DatabaseDriver\loadColumn(), ByteString\match(), Mbstring\mb_stripos(), Mbstring\mb_strpos(), Mbstring\mb_strripos(), Mbstring\mb_strrpos(), Nested\moveByReference(), Joomla\Database\Query\offset(), Construct\offsetExists(), ParagonIE_Sodium_Core_Curve25519_Fe\offsetExists(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetExists(), Collection\offsetExists(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetExists(), ParagonIE_Sodium_Core32_Curve25519_Fe\offsetExists(), DataShapeObject\offsetExists(), Feed\offsetExists(), Registry\offsetExists(), DataSet\offsetExists(), Construct\offsetGet(), Collection\offsetGet(), ParagonIE_Sodium_Core_Curve25519_Fe\offsetGet(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetGet(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetGet(), DataShapeObject\offsetGet(), Feed\offsetGet(), Registry\offsetGet(), DataSet\offsetGet(), ParagonIE_Sodium_Core_Curve25519_Fe\offsetSet(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetSet(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetSet(), Construct\offsetSet(), ParagonIE_Sodium_Core32_Curve25519_Fe\offsetSet(), Collection\offsetSet(), DataShapeObject\offsetSet(), Feed\offsetSet(), Registry\offsetSet(), DataSet\offsetSet(), Construct\offsetUnset(), ParagonIE_Sodium_Core_Curve25519_Fe\offsetUnset(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetUnset(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetUnset(), Collection\offsetUnset(), ParagonIE_Sodium_Core32_Curve25519_Fe\offsetUnset(), Feed\offsetUnset(), Registry\offsetUnset(), DataSet\offsetUnset(), Adapter\onBuildIndex(), Hash\poly(), NewsfeedModel\populateState(), TagsModel\populateState(), ArticleModel\populateState(), TagModel\populateState(), Iconv\pregOffset(), Query\processDates(), Joomla\Database\Query\processLimit(), Query\processString(), SFTP\put(), Zip\readZipInfo(), Html\removeBlocks(), Image\resize(), PrivateKey\rsaes_oaep_decrypt(), Image\sanitizeOffset(), Stem\search(), Stream\seek(), BufferStreamHandler\seek_cur(), BufferStreamHandler\seek_end(), BufferStreamHandler\seek_set(), DatabaseDriver\setQuery(), Application\splitStringByWidth(), Buffer\stream_seek(), BufferStreamHandler\stream_seek(), StringWrapper\stream_seek(), StreamString\stream_seek(), PharStreamWrapper\stream_seek(), StringHelper\strpos(), StringHelper\strrpos(), StringHelper\substr(), StringHelper\truncate(), ParagonIE_Sodium_Core32_BLAKE2b\update(), ParagonIE_Sodium_Core_BLAKE2b\update(), utf8_byte_position(), utf8_strpos(), utf8_strrpos(), et utf8_substr().

◆ $returning

$returning
protected

Référencé par ApcuStorage\lock(), FileStorage\lock(), Cache\lock(), et MemcachedStorage\lock().

◆ MysqlQueryBuilder

trait MysqlQueryBuilder

Trait for MySQL Query Building.

Depuis
2.0.0

◆ PostgresqlQueryBuilder

trait PostgresqlQueryBuilder
Valeur initiale :
{
protected $forUpdate

Trait for PostgreSQL Query Building.

Depuis
2.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Service

  • Joomla
  • Database
  • Service
Structures de données
Référence de l'espace de nommage Joomla\Database\Service

Structures de données

class DatabaseProvider

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Sqlazure

  • Joomla
  • Database
  • Sqlazure
Structures de données
Référence de l'espace de nommage Joomla\Database\Sqlazure

Structures de données

class | SqlazureDriver
class | SqlazureQuery

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Sqlite

  • Joomla
  • Database
  • Sqlite
Structures de données
Référence de l'espace de nommage Joomla\Database\Sqlite

Structures de données

class | SqliteDriver
class | SqliteQuery

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Database\Sqlsrv

  • Joomla
  • Database
  • Sqlsrv
Structures de données
Référence de l'espace de nommage Joomla\Database\Sqlsrv

Structures de données

class | SqlsrvQuery
class | SqlsrvStatement

Description détaillée

Part of the Joomla Framework Database Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\DI

  • Joomla
  • DI
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\DI

Espaces de nommage

Exception

Structures de données

class | Container
interface | ContainerAwareInterface
class | ContainerResource
interface | ServiceProviderInterface

Fonctions

getContainer ()
setContainer (Container $container)

Variables

trait ContainerAwareTrait

Description détaillée

Part of the Joomla Framework DI Package

Copyright
Copyright (C) 2013 - 2018 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getContainer()

Joomla\DI\getContainer ( )
protected

Get the DI container.

Renvoie
Container
Depuis
1.2
Exceptions
ContainerNotFoundException May be thrown if the container has not been set.

Références $container, et $this.

Référencé par JoomlaInstallerScript\addUserAuthProviderColumn(), CMSApplication\checkSession(), Factory\createDocument(), Factory\createLanguage(), InstallationApplication\executeController(), JoomlaInstallerScript\fixTemplateMode(), ApiApplication\getApiRouter(), Factory\getCache(), Factory\getDbo(), Document\getInstance(), CMSApplication\getMenu(), CMSApplication\getPathway(), SessionGcCommand\getSessionService(), Installer\loadAdapter(), InstallationApplication\loadDocument(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSystemLanguageFilter\onAfterInitialise(), PlgUserJoomla\onUserAfterSave(), PlgSystemLanguageFilter\onUserLogin(), PlgWorkflowNotification\onWorkflowAfterTransition(), SiteApplication\route(), et InstallerAdapter\setupScriptfile().

◆ setContainer()

Joomla\DI\setContainer ( Container $container )

Set the DI container.

Paramètres
Container $container The DI container.
Renvoie
$this
Depuis
1.2

Références $container, et $this.

Référencé par CliApplication\__construct(), ConsoleApplication\__construct(), et CMSApplication\__construct().

Documentation des variables

◆ ContainerAwareTrait

trait ContainerAwareTrait
Valeur initiale :
{
private $container
$container
$container
Definition: administrator/includes/app.php:38

Defines the trait for a Container Aware Class.

Depuis
1.2


Joomla CMS: Référence de l'espace de nommage Joomla\DI\Exception

  • Joomla
  • DI
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\DI\Exception

Structures de données

class | ContainerNotFoundException
class | DependencyResolutionException
class | KeyNotFoundException
class | ProtectedKeyException

Description détaillée

Part of the Joomla Framework DI Package

Copyright
Copyright (C) 2013 - 2018 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Event

  • Joomla
  • Event
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Joomla\Event

Espaces de nommage

Command

Structures de données

class | AbstractEvent
class | Dispatcher
interface | DispatcherAwareInterface
interface | DispatcherInterface
class | Event
class | EventImmutable
interface | EventInterface
class | LazyServiceEventListener
class | ListenersPriorityQueue
class | Priority
interface | SubscriberInterface

Fonctions

getDispatcher ()
setDispatcher (DispatcherInterface $dispatcher)

Variables

trait DispatcherAwareTrait

Description détaillée

Part of the Joomla Framework Event Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Documentation des fonctions

◆ getDispatcher()

Joomla\Event\getDispatcher ( )
abstract

Get the event dispatcher.

Renvoie
DispatcherInterface
Depuis
1.2.0
Exceptions

Référencé par Captcha\__construct(), Editor\__construct(), Table\__construct(), PlgEditorNone\_displayButtons(), Captcha\_load(), Editor\_loadEditor(), Table\bind(), Table\check(), Table\checkIn(), Table\checkOut(), WebAssetRegistry\dispatchAssetChanged(), AbstractApplication\dispatchEvent(), AbstractView\dispatchEvent(), BaseDatabaseModel\dispatchEvent(), DatabaseDriver\dispatchEvent(), PlgEditorCodemirror\displayButtons(), Editor\getButtons(), Table\hit(), Shortcut\initialize(), Table\load(), Table\move(), Table\publish(), Joomla\CMS\Application\registerEvent(), CMSPlugin\registerLegacyListener(), CMSPlugin\registerListener(), ModuleHelper\renderRawModule(), Table\reorder(), Table\reset(), Application\runCommand(), MVCFactory\setDispatcherOnObject(), Nested\store(), Joomla\CMS\Application\triggerEvent(), et TaskTable\unlock().

◆ setDispatcher()

Joomla\Event\setDispatcher ( DispatcherInterface $dispatcher )

Set the dispatcher to use.

Paramètres
DispatcherInterface $dispatcher The dispatcher to use.
Renvoie
$this
Depuis
1.2.0

Références $this.

Référencé par Captcha\__construct(), Editor\__construct(), CMSPlugin\__construct(), Authentication\__construct(), WebAssetRegistry\__construct(), CliApplication\__construct(), ConsoleApplication\__construct(), Table\__construct(), et Nested\store().

Documentation des variables

◆ DispatcherAwareTrait

trait DispatcherAwareTrait
Valeur initiale :
{
private $dispatcher

Defines the trait for a Dispatcher Aware Class.

Depuis
1.2.0


Joomla CMS: Référence de l'espace de nommage Joomla\Event\Command

  • Joomla
  • Event
  • Command
Structures de données
Référence de l'espace de nommage Joomla\Event\Command

Structures de données

class DebugEventDispatcherCommand

Description détaillée

Part of the Joomla Framework Event Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filesystem

  • Joomla
  • Filesystem
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Filesystem

Espaces de nommage

Clients
Exception
Stream
Support

Structures de données

class | Buffer
class | File
class | Folder
class | Helper
class | Patcher
class | Path
class | Stream

Description détaillée

Part of the Joomla Framework Filesystem Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filesystem\Clients

  • Joomla
  • Filesystem
  • Clients
Structures de données
Référence de l'espace de nommage Joomla\Filesystem\Clients

Structures de données

class FtpClient

Description détaillée

Part of the Joomla Framework Filesystem Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filesystem\Exception

  • Joomla
  • Filesystem
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Filesystem\Exception

Structures de données

class FilesystemException

Description détaillée

Part of the Joomla Framework Filesystem Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filesystem\Stream

  • Joomla
  • Filesystem
  • Stream
Structures de données
Référence de l'espace de nommage Joomla\Filesystem\Stream

Structures de données

class StringWrapper

Description détaillée

Part of the Joomla Framework Filesystem Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filesystem\Support

  • Joomla
  • Filesystem
  • Support
Structures de données
Référence de l'espace de nommage Joomla\Filesystem\Support

Structures de données

class StringController

Description détaillée

Part of the Joomla Framework Filesystem Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Filter

  • Joomla
  • Filter
Structures de données
Référence de l'espace de nommage Joomla\Filter

Structures de données

class | InputFilter
class | OutputFilter

Description détaillée

Part of the Joomla Framework Filter Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Http

  • Joomla
  • Http
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Http

Espaces de nommage

Exception
Transport

Structures de données

class | AbstractTransport
class | Http
class | HttpFactory
class | Response
interface | TransportInterface

Description détaillée

Part of the Joomla Framework Http Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Http\Exception

  • Joomla
  • Http
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Http\Exception

Structures de données

class | InvalidResponseCodeException
class | UnexpectedResponseException

Description détaillée

Part of the Joomla Framework Http Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Http\Transport

  • Joomla
  • Http
  • Transport
Structures de données
Référence de l'espace de nommage Joomla\Http\Transport

Structures de données

class | Curl
class | Socket
class | Stream

Description détaillée

Part of the Joomla Framework Http Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Input

  • Joomla
  • Input
Structures de données
Référence de l'espace de nommage Joomla\Input

Structures de données

class | Cookie
class | Files
class | Input
class | Json

Description détaillée

Part of the Joomla Framework Input Package

Copyright
Copyright (C) 2005 - 2022 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Installation

  • Joomla
  • Installation
Référence de l'espace de nommage Joomla\Installation

Description détaillée

Application

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Application

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Application

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Controller

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Error

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Model

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Model

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Model

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Response

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Service

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

View

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

View

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Language

  • Joomla
  • Language
Référence de l'espace de nommage Joomla\Language

Description détaillée

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable Squiz.Classes.ValidClassName.NotCamelCaps

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable Squiz.Classes.ValidClassName.NotCamelCaps

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Ldap

  • Joomla
  • Ldap
Structures de données
Référence de l'espace de nommage Joomla\Ldap

Structures de données

class LdapClient

Description détaillée

Part of the Joomla Framework LDAP Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Menus

  • Joomla
  • Menus
Référence de l'espace de nommage Joomla\Menus

Description détaillée

Webservices.Menus

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Module

  • Joomla
  • Module
Espaces de nommage
Référence de l'espace de nommage Joomla\Module

Espaces de nommage

ArticlesArchive
ArticlesCategories
ArticlesCategory
ArticlesLatest
ArticlesNews
ArticlesPopular
Banners
Breadcrumbs
Feed
Finder
Languages
Latest
LatestActions
Logged
Login
Menu
Popular
PrivacyDashboard
PrivacyStatus
Quickicon
RandomImage
RelatedItems
Sampledata
Stats
StatsAdmin
Submenu
Syndicate
TagsPopular
TagsSimilar
UsersLatest
Version
Whosonline
Wrapper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesArchive

  • Joomla
  • Module
  • ArticlesArchive
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesArchive

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesArchive\Site

  • Joomla
  • Module
  • ArticlesArchive
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesArchive\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesArchive\Site\Helper

  • Joomla
  • Module
  • ArticlesArchive
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesArchive\Site\Helper

Structures de données

class ArticlesArchiveHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategories

  • Joomla
  • Module
  • ArticlesCategories
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesCategories

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategories\Site

  • Joomla
  • Module
  • ArticlesCategories
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesCategories\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategories\Site\Helper

  • Joomla
  • Module
  • ArticlesCategories
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesCategories\Site\Helper

Structures de données

class ArticlesCategoriesHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategory

  • Joomla
  • Module
  • ArticlesCategory
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesCategory

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategory\Site

  • Joomla
  • Module
  • ArticlesCategory
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesCategory\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesCategory\Site\Helper

  • Joomla
  • Module
  • ArticlesCategory
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesCategory\Site\Helper

Structures de données

class ArticlesCategoryHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesLatest

  • Joomla
  • Module
  • ArticlesLatest
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesLatest

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site

  • Joomla
  • Module
  • ArticlesLatest
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site

Espaces de nommage

Dispatcher
Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site\Dispatcher

  • Joomla
  • Module
  • ArticlesLatest
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site\Helper

  • Joomla
  • Module
  • ArticlesLatest
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesLatest\Site\Helper

Structures de données

class ArticlesLatestHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesNews

  • Joomla
  • Module
  • ArticlesNews
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesNews

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site

  • Joomla
  • Module
  • ArticlesNews
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site

Espaces de nommage

Dispatcher
Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site\Dispatcher

  • Joomla
  • Module
  • ArticlesNews
  • Site
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site\Helper

  • Joomla
  • Module
  • ArticlesNews
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesNews\Site\Helper

Structures de données

class ArticlesNewsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesPopular

  • Joomla
  • Module
  • ArticlesPopular
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesPopular

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesPopular\Site

  • Joomla
  • Module
  • ArticlesPopular
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\ArticlesPopular\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\ArticlesPopular\Site\Helper

  • Joomla
  • Module
  • ArticlesPopular
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\ArticlesPopular\Site\Helper

Structures de données

class ArticlesPopularHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Banners

  • Joomla
  • Module
  • Banners
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Banners

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Banners\Site

  • Joomla
  • Module
  • Banners
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Banners\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Banners\Site\Helper

  • Joomla
  • Module
  • Banners
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Banners\Site\Helper

Structures de données

class BannersHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Breadcrumbs

  • Joomla
  • Module
  • Breadcrumbs
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Breadcrumbs

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Breadcrumbs\Site

  • Joomla
  • Module
  • Breadcrumbs
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Breadcrumbs\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Breadcrumbs\Site\Helper

  • Joomla
  • Module
  • Breadcrumbs
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Breadcrumbs\Site\Helper

Structures de données

class BreadcrumbsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Feed

  • Joomla
  • Module
  • Feed
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Feed

Espaces de nommage

Administrator
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Feed\Administrator

  • Joomla
  • Module
  • Feed
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Feed\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Feed\Administrator\Helper

  • Joomla
  • Module
  • Feed
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Feed\Administrator\Helper

Structures de données

class FeedHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Feed\Site

  • Joomla
  • Module
  • Feed
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Feed\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Feed\Site\Helper

  • Joomla
  • Module
  • Feed
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Feed\Site\Helper

Structures de données

class FeedHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Finder

  • Joomla
  • Module
  • Finder
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Finder

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Finder\Site

  • Joomla
  • Module
  • Finder
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Finder\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Finder\Site\Helper

  • Joomla
  • Module
  • Finder
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Finder\Site\Helper

Structures de données

class FinderHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Languages

  • Joomla
  • Module
  • Languages
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Languages

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Languages\Site

  • Joomla
  • Module
  • Languages
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Languages\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Languages\Site\Helper

  • Joomla
  • Module
  • Languages
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Languages\Site\Helper

Structures de données

class LanguagesHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Latest

  • Joomla
  • Module
  • Latest
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Latest

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Latest\Administrator

  • Joomla
  • Module
  • Latest
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Latest\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Latest\Administrator\Helper

  • Joomla
  • Module
  • Latest
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Latest\Administrator\Helper

Structures de données

class LatestHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\LatestActions

  • Joomla
  • Module
  • LatestActions
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\LatestActions

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\LatestActions\Administrator

  • Joomla
  • Module
  • LatestActions
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\LatestActions\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\LatestActions\Administrator\Helper

  • Joomla
  • Module
  • LatestActions
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\LatestActions\Administrator\Helper

Structures de données

class LatestActionsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Logged

  • Joomla
  • Module
  • Logged
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Logged

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Logged\Administrator

  • Joomla
  • Module
  • Logged
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Logged\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Logged\Administrator\Helper

  • Joomla
  • Module
  • Logged
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Logged\Administrator\Helper

Structures de données

class LoggedHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Login

  • Joomla
  • Module
  • Login
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Login

Espaces de nommage

Administrator
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Login\Administrator

  • Joomla
  • Module
  • Login
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Login\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Login\Administrator\Helper

  • Joomla
  • Module
  • Login
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Login\Administrator\Helper

Structures de données

class LoginHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Login\Site

  • Joomla
  • Module
  • Login
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Login\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Login\Site\Helper

  • Joomla
  • Module
  • Login
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Login\Site\Helper

Structures de données

class LoginHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Menu

  • Joomla
  • Module
  • Menu
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Menu

Espaces de nommage

Administrator
Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Menu\Administrator

  • Joomla
  • Module
  • Menu
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Menu\Administrator

Espaces de nommage

Menu


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Menu\Administrator\Menu

  • Joomla
  • Module
  • Menu
  • Administrator
  • Menu
Structures de données
Référence de l'espace de nommage Joomla\Module\Menu\Administrator\Menu

Structures de données

class CssMenu


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Menu\Site

  • Joomla
  • Module
  • Menu
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Menu\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Menu\Site\Helper

  • Joomla
  • Module
  • Menu
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Menu\Site\Helper

Structures de données

class MenuHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Popular

  • Joomla
  • Module
  • Popular
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Popular

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Popular\Administrator

  • Joomla
  • Module
  • Popular
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Popular\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Popular\Administrator\Helper

  • Joomla
  • Module
  • Popular
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Popular\Administrator\Helper

Structures de données

class PopularHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyDashboard

  • Joomla
  • Module
  • PrivacyDashboard
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\PrivacyDashboard

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyDashboard\Administrator

  • Joomla
  • Module
  • PrivacyDashboard
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\PrivacyDashboard\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyDashboard\Administrator\Helper

  • Joomla
  • Module
  • PrivacyDashboard
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\PrivacyDashboard\Administrator\Helper

Structures de données

class PrivacyDashboardHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyStatus

  • Joomla
  • Module
  • PrivacyStatus
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\PrivacyStatus

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyStatus\Administrator

  • Joomla
  • Module
  • PrivacyStatus
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\PrivacyStatus\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\PrivacyStatus\Administrator\Helper

  • Joomla
  • Module
  • PrivacyStatus
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\PrivacyStatus\Administrator\Helper

Structures de données

class PrivacyStatusHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Quickicon

  • Joomla
  • Module
  • Quickicon
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Quickicon

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator

  • Joomla
  • Module
  • Quickicon
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator

Espaces de nommage

Dispatcher
Event
Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Dispatcher

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Dispatcher
Structures de données
Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Dispatcher

Structures de données

class Dispatcher


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Event

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Event
Structures de données
Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Event

Structures de données

class QuickIconsEvent


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Helper

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Quickicon\Administrator\Helper

Structures de données

class QuickIconHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RandomImage

  • Joomla
  • Module
  • RandomImage
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\RandomImage

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RandomImage\Site

  • Joomla
  • Module
  • RandomImage
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\RandomImage\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RandomImage\Site\Helper

  • Joomla
  • Module
  • RandomImage
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\RandomImage\Site\Helper

Structures de données

class RandomImageHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RelatedItems

  • Joomla
  • Module
  • RelatedItems
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\RelatedItems

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RelatedItems\Site

  • Joomla
  • Module
  • RelatedItems
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\RelatedItems\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\RelatedItems\Site\Helper

  • Joomla
  • Module
  • RelatedItems
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\RelatedItems\Site\Helper

Structures de données

class RelatedItemsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Sampledata

  • Joomla
  • Module
  • Sampledata
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Sampledata

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Sampledata\Administrator

  • Joomla
  • Module
  • Sampledata
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Sampledata\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Sampledata\Administrator\Helper

  • Joomla
  • Module
  • Sampledata
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Sampledata\Administrator\Helper

Structures de données

class SampledataHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Stats

  • Joomla
  • Module
  • Stats
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Stats

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Stats\Site

  • Joomla
  • Module
  • Stats
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Stats\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Stats\Site\Helper

  • Joomla
  • Module
  • Stats
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Stats\Site\Helper

Structures de données

class StatsHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\StatsAdmin

  • Joomla
  • Module
  • StatsAdmin
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\StatsAdmin

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\StatsAdmin\Administrator

  • Joomla
  • Module
  • StatsAdmin
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\StatsAdmin\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\StatsAdmin\Administrator\Helper

  • Joomla
  • Module
  • StatsAdmin
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\StatsAdmin\Administrator\Helper

Structures de données

class StatsAdminHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Submenu

  • Joomla
  • Module
  • Submenu
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Submenu

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Submenu\Administrator

  • Joomla
  • Module
  • Submenu
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Submenu\Administrator

Espaces de nommage

Menu


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Submenu\Administrator\Menu

  • Joomla
  • Module
  • Submenu
  • Administrator
  • Menu
Structures de données
Référence de l'espace de nommage Joomla\Module\Submenu\Administrator\Menu

Structures de données

class Menu


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Syndicate

  • Joomla
  • Module
  • Syndicate
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Syndicate

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Syndicate\Site

  • Joomla
  • Module
  • Syndicate
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Syndicate\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Syndicate\Site\Helper

  • Joomla
  • Module
  • Syndicate
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Syndicate\Site\Helper

Structures de données

class SyndicateHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsPopular

  • Joomla
  • Module
  • TagsPopular
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\TagsPopular

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsPopular\Site

  • Joomla
  • Module
  • TagsPopular
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\TagsPopular\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsPopular\Site\Helper

  • Joomla
  • Module
  • TagsPopular
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\TagsPopular\Site\Helper

Structures de données

class TagsPopularHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsSimilar

  • Joomla
  • Module
  • TagsSimilar
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\TagsSimilar

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsSimilar\Site

  • Joomla
  • Module
  • TagsSimilar
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\TagsSimilar\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\TagsSimilar\Site\Helper

  • Joomla
  • Module
  • TagsSimilar
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\TagsSimilar\Site\Helper

Structures de données

class TagsSimilarHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\UsersLatest

  • Joomla
  • Module
  • UsersLatest
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\UsersLatest

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\UsersLatest\Site

  • Joomla
  • Module
  • UsersLatest
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\UsersLatest\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\UsersLatest\Site\Helper

  • Joomla
  • Module
  • UsersLatest
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\UsersLatest\Site\Helper

Structures de données

class UsersLatestHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Version

  • Joomla
  • Module
  • Version
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Version

Espaces de nommage

Administrator


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Version\Administrator

  • Joomla
  • Module
  • Version
  • Administrator
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Version\Administrator

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Version\Administrator\Helper

  • Joomla
  • Module
  • Version
  • Administrator
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Version\Administrator\Helper

Structures de données

class VersionHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Whosonline

  • Joomla
  • Module
  • Whosonline
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Whosonline

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Whosonline\Site

  • Joomla
  • Module
  • Whosonline
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Whosonline\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Whosonline\Site\Helper

  • Joomla
  • Module
  • Whosonline
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Whosonline\Site\Helper

Structures de données

class WhosonlineHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Wrapper

  • Joomla
  • Module
  • Wrapper
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Wrapper

Espaces de nommage

Site


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Wrapper\Site

  • Joomla
  • Module
  • Wrapper
  • Site
Espaces de nommage
Référence de l'espace de nommage Joomla\Module\Wrapper\Site

Espaces de nommage

Helper


Joomla CMS: Référence de l'espace de nommage Joomla\Module\Wrapper\Site\Helper

  • Joomla
  • Module
  • Wrapper
  • Site
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Module\Wrapper\Site\Helper

Structures de données

class WrapperHelper


Joomla CMS: Référence de l'espace de nommage Joomla\Modules

  • Joomla
  • Modules
Référence de l'espace de nommage Joomla\Modules

Description détaillée

Webservices.Modules

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\OAuth1

  • Joomla
  • OAuth1
Structures de données
Référence de l'espace de nommage Joomla\OAuth1

Structures de données

class Client

Description détaillée

Part of the Joomla Framework OAuth1 Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\OAuth2

  • Joomla
  • OAuth2
Structures de données
Référence de l'espace de nommage Joomla\OAuth2

Structures de données

class Client

Description détaillée

Part of the Joomla Framework OAuth2 Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin

  • Joomla
  • Plugin
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin

Espaces de nommage

Actionlog
ApiAuthentication
Behaviour
Content
Editors
Filesystem
Multifactorauth
Quickicon
System
Task
User

Description détaillée

Editors.tinymce

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Editors.tinymce

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.privacyconsent

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.webauthn

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

User.terms

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Actionlog.joomla

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Actionlog.joomla

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Apiauthentication.basic

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Apiauthentication.basic

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Apiauthentication.token

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Apiauthentication.token

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Authentication.cookie

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Authentication.joomla

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Authentication.ldap

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Behaviour.taggable

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Behaviour.taggable

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Behaviour.versionable

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Behaviour.versionable

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Captcha

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Captcha

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable Squiz.Classes.ValidClassName.NotCamelCaps

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.confirmconsent

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.confirmconsent

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Content.Contact

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.emailcloak

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.Fields

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.finder

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.joomla

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.loadmodule

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.pagebreak

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.pagebreak

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Content.pagenavigation

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Content.pagenavigation

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Content.vote

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Content.vote

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors.codemirror

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors.codemirror

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Editors.codemirror

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Supports an HTML select list of fonts

Editors.codemirror

Depuis
3.4

Editors.none

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Form Field class for the TinyMCE editor.

Editors.tinymce

Depuis
3.7.0

Editors.tinymce

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Generates the list of directories available for drag and drop upload.

Editors.tinymce

Depuis
3.7.0

Editors.tinymce

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.article

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.contact

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.fields

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.image

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.menu

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.module

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.pagebreak

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Editors-xtd.readmore

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Extension.Finder

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Extension.Joomla

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Extension.Joomla

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Calendar

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Calendar

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Checkboxes

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Checkboxes

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Color

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Color

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Editor

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Editor

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Imagelist

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Imagelist

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Integer

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Integer

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.List

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.List

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Media

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Media

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Radio

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Radio

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Sql

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Sql

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Subform

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Subform

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Text

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Text

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Textarea

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Textarea

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.URL

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.URL

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.User

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.User

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Fields.Usergrouplist

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Fields.Usergrouplist

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

FileSystem.Local

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Filesystem.Local

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Finder.Categories

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Finder.Contacts

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Finder.Content

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Finder.Newsfeeds

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Finder.Tags

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Installer.folderInstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Installer.folderinstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Installer.override

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Installer.packageInstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Installer.packageinstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Installer.urlinstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Installer.urlinstaller

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Installer.Webinstaller

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Installer.webinstaller

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Media-Action.crop

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Media-Action.resize

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Media-Action.rotate

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Multifactorauth.email

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Multifactorauth.fixed

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Multifactorauth.totp

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Multifactorauth.webauthn

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Multifactorauth.webauthn

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2014-2019 Spomky-Labs This software may be modified and distributed under the terms of the MIT license. See libraries/vendor/web-auth/webauthn-lib/LICENSE

Multifactorauth.yubikey

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Privacy.actionlogs

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Privacy.consents

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Privacy.contact

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Privacy.content

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Privacy.message

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Privacy.user

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Quickicon.Downloadkey

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Quickicon.Extensionupdate

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Quickicon.Joomlaupdate

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Quickicon.Joomlaupdate

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Quickicon.Overridecheck

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Quickicon.phpversioncheck

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Quickicon.privacycheck

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Sampledata.Blog

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Sampledata.Multilang

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.accessibility

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.cache

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Debug

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.Debug

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Debug

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Debug

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Fields

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.Highlight

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.HttpHeaders

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.HttpHeaders

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.jooa11y

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.languagecode

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.languagefilter

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.log

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.logout

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.logrotation

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.privacyconsent

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.privacyconsent

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.redirect

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.remember

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.ScheduleRunner

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.sef

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.sessiongc

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.shortcut

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.skipto

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.stats

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.stats

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.stats

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.updatenotification

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.updatenotification

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

System.Webauthn

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Webauthn

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Webauthn

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org MIT; see libraries/vendor/web-auth/webauthn-lib/LICENSE

Task.CheckFiles

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.DemoTasks

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.requests

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.SiteStatus

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

User.contactcreator

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

User.joomla

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

User.profile

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

User.profile

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

User.terms

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

User.terms

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

User.token

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

User.token

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Banners

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Config

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Contact

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Content

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Installer

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Languages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Media

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Webservices.Messages

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Newsfeeds

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Webservices.Plugins

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Workflow.Featuring

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Workflow.Notification

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Workflow.Publishing

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Actionlog

  • Joomla
  • Plugin
  • Actionlog
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Actionlog

Espaces de nommage

Joomla


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Actionlog\Joomla

  • Joomla
  • Plugin
  • Actionlog
  • Joomla
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Actionlog\Joomla

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Actionlog\Joomla\Extension

  • Joomla
  • Plugin
  • Actionlog
  • Joomla
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Actionlog\Joomla\Extension

Structures de données

class Joomla


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication

  • Joomla
  • Plugin
  • ApiAuthentication
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication

Espaces de nommage

Basic
Token


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Basic

  • Joomla
  • Plugin
  • ApiAuthentication
  • Basic
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Basic

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Basic\Extension

  • Joomla
  • Plugin
  • ApiAuthentication
  • Basic
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Basic\Extension

Structures de données

class Basic


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Token

  • Joomla
  • Plugin
  • ApiAuthentication
  • Token
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Token

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Token\Extension

  • Joomla
  • Plugin
  • ApiAuthentication
  • Token
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\ApiAuthentication\Token\Extension

Structures de données

class Token


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Behaviour

  • Joomla
  • Plugin
  • Behaviour
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Behaviour

Espaces de nommage

Taggable
Versionable


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Behaviour\Taggable

  • Joomla
  • Plugin
  • Behaviour
  • Taggable
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Behaviour\Taggable

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Behaviour\Taggable\Extension

  • Joomla
  • Plugin
  • Behaviour
  • Taggable
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Behaviour\Taggable\Extension

Structures de données

class Taggable


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Behaviour\Versionable

  • Joomla
  • Plugin
  • Behaviour
  • Versionable
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Behaviour\Versionable

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Behaviour\Versionable\Extension

  • Joomla
  • Plugin
  • Behaviour
  • Versionable
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Behaviour\Versionable\Extension

Structures de données

class Versionable


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Content

  • Joomla
  • Plugin
  • Content
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Content

Espaces de nommage

ConfirmConsent


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Content\ConfirmConsent

  • Joomla
  • Plugin
  • Content
  • ConfirmConsent
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Content\ConfirmConsent

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Content\ConfirmConsent\Field

  • Joomla
  • Plugin
  • Content
  • ConfirmConsent
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Content\ConfirmConsent\Field

Structures de données

class ConsentBoxField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors

  • Joomla
  • Plugin
  • Editors
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Editors

Espaces de nommage

CodeMirror
TinyMCE


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors\CodeMirror

  • Joomla
  • Plugin
  • Editors
  • CodeMirror
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Editors\CodeMirror

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors\CodeMirror\Field

  • Joomla
  • Plugin
  • Editors
  • CodeMirror
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Editors\CodeMirror\Field

Structures de données

class FontsField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE

Espaces de nommage

Field
PluginTraits


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE\Field

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE\Field

Structures de données

class | TemplatesListField
class | TinymcebuilderField
class | UploaddirsField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE\PluginTraits

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
  • PluginTraits
Fonctions | Variables
Référence de l'espace de nommage Joomla\Plugin\Editors\TinyMCE\PluginTraits

Fonctions

onDisplay ( $name, $content, $width, $height, $col, $row, $buttons=true, $id=null, $asset=null, $author=null, $params=[])
includeRelativeFiles ($folder, $file)
static resolveFileUrl ($path='')

Variables

trait | DisplayTrait
trait | ResolveFiles

Documentation des fonctions

◆ includeRelativeFiles()

Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles | ( | $folder,
 |  | $file
 | ) |
protected

Compute the file paths to be included

Paramètres
string | $folder | Folder name to search in (i.e. images, css, js).
string | $file | Path to file.
Renvoie
array files to be included.
Depuis
4.1.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $template, File\getExt(), JDEBUG, JPATH_ROOT, Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), Uri\root(), et File\stripExt().

Référencé par HTMLHelper\image(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), HTMLHelper\script(), et HTMLHelper\stylesheet().

◆ onDisplay()

Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay | ( | $name,
 |  | $content,
 |  | $width,
 |  | $height,
 |  | $col,
 |  | $row,
 |  | $buttons = true,
 |  | $id = null,
 |  | $asset = null,
 |  | $author = null,
 |  | $params = []
 | ) |

Display the editor area.

Paramètres
string | $name | The name of the editor area.
string | $content | The content of the field.
string | $width | The width of the editor area.
string | $height | The height of the editor area.
int | $col | The number of columns for the editor area.
int | $row | The number of rows for the editor area.
boolean | $buttons | True and the editor buttons will be displayed.
string | $id | An optional ID for the textarea. If not supplied the name is used.
string | $asset | The object asset
object | $author | The author.
array | $params | Associative array of editor parameters.
Renvoie
string

If URL, just pass it to $content_css else, assume it is a file name in the current template folder

Predefine group as: Set 0: for Administrator, Editor, Super Users (4,7,8) Set 1: for Registered, Manager (2,6), all else are public

Références $buttons, $content, $description, $doc, $editor, $height, $id, $language, $name, $options, $params, $path, $title, $toolbar, $user, $val, $width, Text\_(), HTMLHelper\_(), Uri\base(), elseif, Folder\exists(), false, Folder\files(), Session\getFormToken(), InputFilter\getInstance(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), JDEBUG, JPATH_ROOT, null, LayoutHelper\render(), Uri\root(), et Text\script().

◆ resolveFileUrl()

static Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl ( $path = '' )
staticprotected

Method that searches if file exists in given path and returns the relative path. If a minified version exists it will be preferred.

Paramètres
string $path The actual path of the file
Renvoie
string The relative path of the file
Depuis
4.1.0

Références $path, $position, JDEBUG, JPATH_ROOT, et Uri\root().

Référencé par Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles().

Documentation des variables

◆ DisplayTrait

trait DisplayTrait
Valeur initiale :
{
use GlobalFilters

Handles the onDisplay event for the TinyMCE editor.

Depuis
4.1.0

◆ ResolveFiles

trait ResolveFiles
Valeur initiale :
{
use ActiveSiteTemplate

Handles the editor.css files.

Depuis
4.1.0


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Filesystem

  • Joomla
  • Plugin
  • Filesystem
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Filesystem

Espaces de nommage

Local


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Filesystem\Local

  • Joomla
  • Plugin
  • Filesystem
  • Local
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Filesystem\Local

Espaces de nommage

Adapter


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Filesystem\Local\Adapter

  • Joomla
  • Plugin
  • Filesystem
  • Local
  • Adapter
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Filesystem\Local\Adapter

Structures de données

class LocalAdapter


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth

  • Joomla
  • Plugin
  • Multifactorauth
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth

Espaces de nommage

Email
Fixed
Totp
Webauthn
Yubikey


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Email

  • Joomla
  • Plugin
  • Multifactorauth
  • Email
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Email

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Email\Extension

  • Joomla
  • Plugin
  • Multifactorauth
  • Email
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Email\Extension

Structures de données

class Email


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Fixed

  • Joomla
  • Plugin
  • Multifactorauth
  • Fixed
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Fixed

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Fixed\Extension

  • Joomla
  • Plugin
  • Multifactorauth
  • Fixed
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Fixed\Extension

Structures de données

class Fixed


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Totp

  • Joomla
  • Plugin
  • Multifactorauth
  • Totp
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Totp

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Totp\Extension

  • Joomla
  • Plugin
  • Multifactorauth
  • Totp
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Totp\Extension

Structures de données

class Totp


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn

Espaces de nommage

Extension
Helper
Hotfix

Structures de données

class CredentialRepository


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Extension

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Extension

Structures de données

class Webauthn


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Helper

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Helper
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Helper

Structures de données

class Credentials


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Hotfix

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Hotfix
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Webauthn\Hotfix

Structures de données

class | AndroidKeyAttestationStatementSupport
class | FidoU2FAttestationStatementSupport
class | Server


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Yubikey

  • Joomla
  • Plugin
  • Multifactorauth
  • Yubikey
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Yubikey

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Yubikey\Extension

  • Joomla
  • Plugin
  • Multifactorauth
  • Yubikey
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Multifactorauth\Yubikey\Extension

Structures de données

class Yubikey


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Quickicon

  • Joomla
  • Plugin
  • Quickicon
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Quickicon

Espaces de nommage

Joomlaupdate


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Quickicon\Joomlaupdate

  • Joomla
  • Plugin
  • Quickicon
  • Joomlaupdate
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Quickicon\Joomlaupdate

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Quickicon\Joomlaupdate\Extension

  • Joomla
  • Plugin
  • Quickicon
  • Joomlaupdate
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Quickicon\Joomlaupdate\Extension

Structures de données

class Joomlaupdate


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System

  • Joomla
  • Plugin
  • System
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\System

Espaces de nommage

Cache
Debug
PrivacyConsent
Shortcut
Stats
Webauthn


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Cache

  • Joomla
  • Plugin
  • System
  • Cache
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\System\Cache

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Cache\Extension

  • Joomla
  • Plugin
  • System
  • Cache
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Cache\Extension

Structures de données

class Cache


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Debug

  • Joomla
  • Plugin
  • System
  • Debug
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Debug

Espaces de nommage

DataCollector
Storage

Structures de données

class | AbstractDataCollector
class | DataFormatter
class | JavascriptRenderer
class | JoomlaHttpDriver


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Debug\DataCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Debug\DataCollector

Structures de données

class | InfoCollector
class | LanguageErrorsCollector
class | LanguageFilesCollector
class | LanguageStringsCollector
class | ProfileCollector
class | QueryCollector
class | SessionCollector

Description détaillée

This file is part of the DebugBar package.

Copyright
(c) 2013 Maxime Bouroumeau-Fuseau For the full copyright and license information, please view the LICENSE file that was distributed with this source code.


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Debug\Storage

  • Joomla
  • Plugin
  • System
  • Debug
  • Storage
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Debug\Storage

Structures de données

class FileStorage


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\PrivacyConsent

  • Joomla
  • Plugin
  • System
  • PrivacyConsent
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\System\PrivacyConsent

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\PrivacyConsent\Field

  • Joomla
  • Plugin
  • System
  • PrivacyConsent
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\PrivacyConsent\Field

Structures de données

class PrivacyField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Shortcut

  • Joomla
  • Plugin
  • System
  • Shortcut
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\System\Shortcut

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Shortcut\Extension

  • Joomla
  • Plugin
  • System
  • Shortcut
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Shortcut\Extension

Structures de données

class Shortcut


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Stats

  • Joomla
  • Plugin
  • System
  • Stats
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\System\Stats

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Stats\Field

  • Joomla
  • Plugin
  • System
  • Stats
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Stats\Field

Structures de données

class | AbstractStatsField
class | DataField
class | UniqueidField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Webauthn

  • Joomla
  • Plugin
  • System
  • Webauthn
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Webauthn

Espaces de nommage

Extension
Field
Hotfix
PluginTraits

Structures de données

class | Authentication
class | CredentialRepository
class | MetadataRepository


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Extension

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Extension

Structures de données

class Webauthn


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Field

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Field

Structures de données

class WebauthnField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Hotfix

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Hotfix
Structures de données
Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\Hotfix

Structures de données

class | AndroidKeyAttestationStatementSupport
class | FidoU2FAttestationStatementSupport
class | Server


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\PluginTraits

  • Joomla
  • Plugin
  • System
  • Webauthn
  • PluginTraits
Fonctions | Variables
Référence de l'espace de nommage Joomla\Plugin\System\Webauthn\PluginTraits

Fonctions

mustDisplayButton ()
getUserFromData ($data)
canEditUser (?User $user=null)

Variables

trait | AdditionalLoginButtons
$injectedCSSandJS = false
trait | UserProfileFields

Documentation des fonctions

◆ canEditUser()

Joomla\Plugin\System\Webauthn\PluginTraits\canEditUser ( ?User $user = null )
private

Is the current user allowed to edit the WebAuthn configuration of $user?

To do so I must either be editing my own account OR I have to be a Super User.

Paramètres
?User $user The user you want to know if we're allowed to edit
Renvoie
boolean
Depuis
4.2.0

Références $user.

◆ getUserFromData()

Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData ( $data )
private

Get the user object based on the ID found in the provided user form data

Paramètres
array | object | null $data The user form data
Renvoie
User|null A user object or null if no match is found
Exceptions
Exception
Depuis
4.0.0

Références $data, $id, $user, class, elseif, Factory\getApplication(), Factory\getContainer(), et null.

◆ mustDisplayButton()

Joomla\Plugin\System\Webauthn\PluginTraits\mustDisplayButton ( )
private

Should I allow this plugin to add a WebAuthn login button?

Renvoie
boolean
Depuis
4.0.0

Do not add a WebAuthn login button if we are already logged in

Only display a button on HTML output

WebAuthn only works on HTTPS. This is a security-related limitation of the W3C Web Authentication specification, not an issue with this plugin :)

Références $document, Joomla\CMS\Application\getIdentity(), Uri\getInstance(), et null.

Documentation des variables

◆ $injectedCSSandJS

$injectedCSSandJS = false
private

◆ AdditionalLoginButtons

trait AdditionalLoginButtons
Valeur initiale :
{
protected $allowButtonDisplay = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Inserts Webauthn buttons into login modules

Depuis
4.0.0

◆ UserProfileFields

trait UserProfileFields
Valeur initiale :
{
private static $userFromFormData = null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

Add extra fields in the User Profile page.

This class only injects the custom form fields. The actual interface is rendered through JFormFieldWebauthn.

Voir également
JFormFieldWebauthn::getInput()
Depuis
4.0.0


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task

  • Joomla
  • Plugin
  • Task
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Task

Espaces de nommage

Checkfiles
DemoTasks
Requests
SiteStatus


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\Checkfiles

  • Joomla
  • Plugin
  • Task
  • Checkfiles
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Task\Checkfiles

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\Checkfiles\Extension

  • Joomla
  • Plugin
  • Task
  • Checkfiles
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Task\Checkfiles\Extension

Structures de données

class Checkfiles


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\DemoTasks

  • Joomla
  • Plugin
  • Task
  • DemoTasks
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Task\DemoTasks

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\DemoTasks\Extension

  • Joomla
  • Plugin
  • Task
  • DemoTasks
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Task\DemoTasks\Extension

Structures de données

class DemoTasks


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\Requests

  • Joomla
  • Plugin
  • Task
  • Requests
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Task\Requests

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\Requests\Extension

  • Joomla
  • Plugin
  • Task
  • Requests
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Task\Requests\Extension

Structures de données

class Requests


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\SiteStatus

  • Joomla
  • Plugin
  • Task
  • SiteStatus
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\Task\SiteStatus

Espaces de nommage

Extension


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\Task\SiteStatus\Extension

  • Joomla
  • Plugin
  • Task
  • SiteStatus
  • Extension
Structures de données
Référence de l'espace de nommage Joomla\Plugin\Task\SiteStatus\Extension

Structures de données

class SiteStatus


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User

  • Joomla
  • Plugin
  • User
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\User

Espaces de nommage

Profile
Terms
Token


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Profile

  • Joomla
  • Plugin
  • User
  • Profile
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\User\Profile

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Profile\Field

  • Joomla
  • Plugin
  • User
  • Profile
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\User\Profile\Field

Structures de données

class TosField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Terms

  • Joomla
  • Plugin
  • User
  • Terms
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\User\Terms

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Terms\Field

  • Joomla
  • Plugin
  • User
  • Terms
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\User\Terms\Field

Structures de données

class TermsField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Token

  • Joomla
  • Plugin
  • User
  • Token
Espaces de nommage
Référence de l'espace de nommage Joomla\Plugin\User\Token

Espaces de nommage

Field


Joomla CMS: Référence de l'espace de nommage Joomla\Plugin\User\Token\Field

  • Joomla
  • Plugin
  • User
  • Token
  • Field
Structures de données
Référence de l'espace de nommage Joomla\Plugin\User\Token\Field

Structures de données

class JoomlatokenField


Joomla CMS: Référence de l'espace de nommage Joomla\Plugins

  • Joomla
  • Plugins
Référence de l'espace de nommage Joomla\Plugins

Description détaillée

System.actionlogs

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

System.Tasknotification

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Task.CheckFiles

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.DemoTasks

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.Requests

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Task.SiteStatus

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\Privacy

  • Joomla
  • Privacy
Référence de l'espace de nommage Joomla\Privacy

Description détaillée

Webservices.Privacy

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Redirect

  • Joomla
  • Redirect
Référence de l'espace de nommage Joomla\Redirect

Description détaillée

Webservices.Redirect

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Registry

  • Joomla
  • Registry
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Registry

Espaces de nommage

Format

Structures de données

class | Factory
interface | FormatInterface
class | Registry

Description détaillée

Part of the Joomla Framework Registry Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Registry\Format

  • Joomla
  • Registry
  • Format
Structures de données
Référence de l'espace de nommage Joomla\Registry\Format

Structures de données

class | Ini
class | Json
class | Php
class | Xml
class | Yaml

Description détaillée

Part of the Joomla Framework Registry Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Router

  • Joomla
  • Router
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Router

Espaces de nommage

Command
Exception

Structures de données

class | ResolvedRoute
class | Route
class | Router
interface | RouterInterface

Description détaillée

Part of the Joomla Framework Router Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Router\Command

  • Joomla
  • Router
  • Command
Structures de données
Référence de l'espace de nommage Joomla\Router\Command

Structures de données

class DebugRouterCommand

Description détaillée

Part of the Joomla Framework Router Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Router\Exception

  • Joomla
  • Router
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Router\Exception

Structures de données

class | MethodNotAllowedException
class | RouteNotFoundException

Description détaillée

Part of the Joomla Framework Router Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session

  • Joomla
  • Session
Espaces de nommage | Structures de données
Référence de l'espace de nommage Joomla\Session

Espaces de nommage

Command
Exception
Handler
Storage
Validator

Structures de données

interface | HandlerInterface
class | Session
class | SessionEvent
class | SessionEvents
interface | SessionInterface
class | SessionState
interface | StorageInterface
interface | ValidatorInterface

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session\Command

  • Joomla
  • Session
  • Command
Structures de données
Référence de l'espace de nommage Joomla\Session\Command

Structures de données

class CreateSessionTableCommand

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session\Exception

  • Joomla
  • Session
  • Exception
Structures de données
Référence de l'espace de nommage Joomla\Session\Exception

Structures de données

class | CreateSessionTableException
class | InvalidSessionException
class | UnsupportedDatabaseDriverException

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session\Handler

  • Joomla
  • Session
  • Handler
Structures de données
Référence de l'espace de nommage Joomla\Session\Handler

Structures de données

class | ApcuHandler
class | DatabaseHandler
class | FilesystemHandler
class | MemcachedHandler
class | RedisHandler
class | WincacheHandler

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session\Storage

  • Joomla
  • Session
  • Storage
Structures de données
Référence de l'espace de nommage Joomla\Session\Storage

Structures de données

class | NativeStorage
class | RuntimeStorage

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Session\Validator

  • Joomla
  • Session
  • Validator
Structures de données
Référence de l'espace de nommage Joomla\Session\Validator

Structures de données

class | AddressValidator
class | ForwardedValidator

Description détaillée

Part of the Joomla Framework Session Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Site

  • Joomla
  • Site
Référence de l'espace de nommage Joomla\Site

Description détaillée

com_contact

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_ajax

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_banners

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_config

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

Contact Component Route Helper

com_contact

Depuis
1.5
Obsolète:
5.0 Use instead

com_contact

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Contact Component Route Helper

com_contact

Depuis
1.5

com_contact

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Single item model for a contact

com_contact

Depuis
1.5

com_contact

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contact

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_content

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_content

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_contenthistory

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_fields

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_finder

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_finder

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_media

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_menus

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_modules

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_newsfeeds

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_newsfeeds

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_privacy

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace

com_tags

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_tags

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_users

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_wrapper

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_wrapper

Copyright
(C) 2008 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

com_wrapper

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

html5 (chosen html5 tag and font header tags)

Layout

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Module chrome that wraps the module in a table

Layout

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2016 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt
Obsolète:
5.0 without replacement

Layout

Copyright
(C) 2014 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2015 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Layout

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_archive

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_archive

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_categories

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_category

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_category

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_latest

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_latest

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_news

Copyright
(C) 2022 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_news

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_news

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_popular

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_popular

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_articles_popular

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_banners

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_banners

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_breadcrumbs

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_breadcrumbs

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_custom

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_feed

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_feed

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_finder

Copyright
(C) 2011 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_footer

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_footer

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_languages

Copyright
(C) 2010 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_login

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_login

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2021 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2012 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_random_image

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_random_image

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_related_items

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_related_items

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_stats

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_stats

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_syndicate

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_tags_popular

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_tags_similar

Copyright
(C) 2013 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_users_latest

Copyright
(C) 2009 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_whosonline

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_whosonline

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_whosonline

Copyright
(C) 2018 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_wrapper

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_wrapper

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Templates.cassiopeia

Copyright
(C) 2017 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Templates.cassiopeia

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_custom

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

mod_menu

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Template.system

Copyright
(C) 2005 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Template.system

Copyright
(C) 2006 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Template.system

Copyright
(C) 2020 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

Template.system

Copyright
(C) 2007 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt


Joomla CMS: Référence de l'espace de nommage Joomla\String

  • Joomla
  • String
Structures de données
Référence de l'espace de nommage Joomla\String

Structures de données

class | Inflector
class | Normalise
class | StringHelper

Description détaillée

Part of the Joomla Framework String Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Tags

  • Joomla
  • Tags
Référence de l'espace de nommage Joomla\Tags

Description détaillée

Webservices.Tags

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Templates

  • Joomla
  • Templates
Référence de l'espace de nommage Joomla\Templates

Description détaillée

Webservices.Templates

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Uri

  • Joomla
  • Uri
Structures de données
Référence de l'espace de nommage Joomla\Uri

Structures de données

class | AbstractUri
class | Uri
class | UriHelper
class | UriImmutable
interface | UriInterface

Description détaillée

Part of the Joomla Framework Uri Package

Copyright
Copyright (C) 2005 - 2022 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE


Joomla CMS: Référence de l'espace de nommage Joomla\Users

  • Joomla
  • Users
Référence de l'espace de nommage Joomla\Users

Description détaillée

Webservices.Users

Copyright
(C) 2019 Open Source Matters, Inc. https://www.joomla.org GNU General Public License version 2 or later; see LICENSE.txt

:disable PSR1.Classes.ClassDeclaration.MissingNamespace


Joomla CMS: Référence de l'espace de nommage Joomla\Utilities

  • Joomla
  • Utilities
Structures de données
Référence de l'espace de nommage Joomla\Utilities

Structures de données

class | ArrayHelper
class | IpHelper

Description détaillée

Part of the Joomla Framework Utilities Package

Copyright
Copyright (C) 2005 - 2021 Open Source Matters, Inc. All rights reserved. GNU General Public License version 2 or later; see LICENSE

Part of the Joomla Framework Utilities Package

Copyright
Copyright (C) 2010-2016 Nicholas K. Dionysopoulos / Akeeba Ltd. All rights reserved. GNU General Public License version 2 or later; see LICENSE.txt
Note
This file has been modified by the Joomla! Project and no longer reflects the original work of its author.


Joomla CMS: Référence de l'espace de nommage Jose

Espaces de nommage
Référence de l'espace de nommage Jose

Espaces de nommage

Component


Joomla CMS: Référence de l'espace de nommage Jose\Component

  • Jose
  • Component
Espaces de nommage
Référence de l'espace de nommage Jose\Component

Espaces de nommage

Core
Signature


Joomla CMS: Référence de l'espace de nommage Jose\Component\Core

  • Jose
  • Component
  • Core
Espaces de nommage | Structures de données
Référence de l'espace de nommage Jose\Component\Core

Espaces de nommage

Util

Structures de données

interface | Algorithm
class | AlgorithmManager
class | AlgorithmManagerFactory
class | JWK
class | JWKSet
interface | JWT


Joomla CMS: Référence de l'espace de nommage Jose\Component\Core\Util

  • Jose
  • Component
  • Core
  • Util
Structures de données
Référence de l'espace de nommage Jose\Component\Core\Util

Structures de données

class | BigInteger
class | ECKey
class | ECSignature
class | Hash
class | JsonConverter
class | KeyChecker
class | RSAKey


Joomla CMS: Référence de l'espace de nommage Jose\Component\Signature

  • Jose
  • Component
  • Signature
Espaces de nommage | Structures de données
Référence de l'espace de nommage Jose\Component\Signature

Espaces de nommage

Algorithm
Serializer

Structures de données

class | JWS
class | JWSBuilder
class | JWSBuilderFactory
class | JWSLoader
class | JWSLoaderFactory
class | JWSTokenSupport
class | JWSVerifier
class | JWSVerifierFactory
class | Signature


Joomla CMS: Référence de l'espace de nommage Jose\Component\Signature\Algorithm

  • Jose
  • Component
  • Signature
  • Algorithm
Espaces de nommage | Structures de données
Référence de l'espace de nommage Jose\Component\Signature\Algorithm

Espaces de nommage

Util

Structures de données

class | ECDSA
class | EdDSA
class | ES256
class | ES256K
class | ES384
class | ES512
class | HMAC
class | HS1
class | HS256
class | HS256_64
class | HS384
class | HS512
interface | MacAlgorithm
class | None
class | PS256
class | PS384
class | PS512
class | RS1
class | RS256
class | RS384
class | RS512
class | RSA
class | RSAPKCS1
class | RSAPSS
interface | SignatureAlgorithm


Joomla CMS: Référence de l'espace de nommage Jose\Component\Signature\Algorithm\Util

  • Jose
  • Component
  • Signature
  • Algorithm
  • Util
Structures de données
Référence de l'espace de nommage Jose\Component\Signature\Algorithm\Util

Structures de données

class RSA


Joomla CMS: Référence de l'espace de nommage Jose\Component\Signature\Serializer

  • Jose
  • Component
  • Signature
  • Serializer
Structures de données
Référence de l'espace de nommage Jose\Component\Signature\Serializer

Structures de données

class | CompactSerializer
class | JSONFlattenedSerializer
class | JSONGeneralSerializer
interface | JWSSerializer
class | JWSSerializerManager
class | JWSSerializerManagerFactory
class | Serializer


Joomla CMS: Référence de l'espace de nommage KoblitzPrime

Référence de l'espace de nommage KoblitzPrime

Description détaillée

Curves over y^2 = x^3 + b

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Laminas

Espaces de nommage
Référence de l'espace de nommage Laminas

Espaces de nommage

Diactoros
ZendFrameworkBridge


Joomla CMS: Référence de l'espace de nommage Laminas\Diactoros

  • Laminas
  • Diactoros
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Laminas\Diactoros

Espaces de nommage

Exception
Request
Response

Structures de données

class | AbstractSerializer
class | CallbackStream
class | ConfigProvider
class | HeaderSecurity
class | Module
class | PhpInputStream
class | RelativeStream
class | Request
class | RequestFactory
class | Response
class | ResponseFactory
class | ServerRequest
class | ServerRequestFactory
class | Stream
class | StreamFactory
class | UploadedFile
class | UploadedFileFactory
class | Uri
class | UriFactory

Fonctions

createUploadedFile (array $spec)
marshalHeadersFromSapi (array $server)
marshalMethodFromSapi (array $server)
marshalProtocolVersionFromSapi (array $server)
marshalUriFromSapi (array $server, array $headers)
normalizeServer (array $server, callable $apacheRequestHeaderCallback=null)
normalizeUploadedFiles (array $files)
parseCookieHeader ($cookieHeader)
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($header)
getHeader ($header)
getHeaderLine ($name)
withHeader ($header, $value)
withAddedHeader ($header, $value)
withoutHeader ($header)
getBody ()
withBody (StreamInterface $body)
getStream ($stream, string $modeIfNotInstance)
setHeaders (array $originalHeaders)
validateProtocolVersion ($version)
filterHeaderValue ($values)
assertHeader ($name)
initialize ( $uri=null, string $method=null, $body='php://memory', array $headers=[])
createUri ($uri)
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
setMethod ($method)
getHostFromUri ()

Variables

trait | MessageTrait
$headerNames = []
$protocol = '1.1'
$stream
trait | RequestTrait
$method = 'GET'
$requestTarget
$uri

Documentation des fonctions

◆ assertHeader()

Laminas\Diactoros\assertHeader ( $name )
private

Ensure header name and values are valid.

Paramètres
string $name
Exceptions
Exception

Références $name, et HeaderSecurity\assertValidName().

Référencé par Laminas\Diactoros\setHeaders(), Laminas\Diactoros\withAddedHeader(), et Laminas\Diactoros\withHeader().

◆ createUploadedFile()

Laminas\Diactoros\createUploadedFile ( array $spec )

Create an uploaded file instance from an array of values.

Paramètres
array $spec A single $_FILES entry.
Exceptions
Exception

Références null.

Référencé par Laminas\Diactoros\normalizeUploadedFiles().

◆ createUri()

Laminas\Diactoros\createUri ( $uri )
private

Create and return a URI instance.

If $uri is a already a UriInterface instance, returns it.

If $uri is a string, passes it to the Uri constructor to return an instance.

If $uri is null, creates and returns an emptyUri` instance.

Otherwise, it raises an exception.

Paramètres
null | string | UriInterface $uri
Exceptions
Exception

Références Laminas\Diactoros\$uri, et null.

Référencé par Router\build(), et Laminas\Diactoros\initialize().

◆ filterHeaderValue()

Laminas\Diactoros\filterHeaderValue ( $values )
private
Paramètres
mixed $values
Renvoie
string[]

Références $value, et HeaderSecurity\assertValid().

Référencé par Laminas\Diactoros\setHeaders(), Laminas\Diactoros\withAddedHeader(), et Laminas\Diactoros\withHeader().

◆ getBody()

Laminas\Diactoros\getBody ( )

Gets the body of the message.

Renvoie
StreamInterface Returns the body as a stream.

Références Laminas\Diactoros\$stream.

Référencé par Cache\onAfterRespond(), et CMSApplication\toString().

◆ getHeader()

Laminas\Diactoros\getHeader ( $header )

Retrieves a message header value by the given case-insensitive name.

This method returns an array of all the header values of the given case-insensitive header name.

If the header does not appear in the message, this method MUST return an empty array.

Paramètres
string $header Case-insensitive header field name.
Renvoie
string[] An array of string values as provided for the given header. If the header does not appear in the message, this method MUST return an empty array.

Références $header, et Laminas\Diactoros\hasHeader().

Référencé par Laminas\Diactoros\getHeaderLine().

◆ getHeaderLine()

Laminas\Diactoros\getHeaderLine ( $name )

Retrieves a comma-separated string of the values for a single header.

This method returns all of the header values of the given case-insensitive header name as a string concatenated together using a comma.

NOTE: Not all header values may be appropriately represented using comma concatenation. For such headers, use getHeader() instead and supply your own delimiter when concatenating.

If the header does not appear in the message, this method MUST return an empty string.

Paramètres
string $name Case-insensitive header field name.
Renvoie
string A string of values as provided for the given header concatenated together using a comma. If the header does not appear in the message, this method MUST return an empty string.

Références $name, $value, et Laminas\Diactoros\getHeader().

◆ getHeaders()

Laminas\Diactoros\getHeaders ( )

Retrieves all message headers.

The keys represent the header name as it will be sent over the wire, and each value is an array of strings associated with the header.

// Represent the headers as a string
foreach ($message->getHeaders() as $name => $values) {
    echo $name . ": " . implode(", ", $values);
}

// Emit headers iteratively:
foreach ($message->getHeaders() as $name => $values) {
    foreach ($values as $value) {
        header(sprintf('%s: %s', $name, $value), false);
    }
}
Renvoie
array Returns an associative array of the message's headers. Each key MUST be a header name, and each value MUST be an array of strings.

◆ getHostFromUri()

Laminas\Diactoros\getHostFromUri ( )
private

Retrieve the host from the URI instance

Référencé par Request\getHeader(), Request\getHeaders(), et Laminas\Diactoros\initialize().

◆ getMethod()

Laminas\Diactoros\getMethod ( )

Retrieves the HTTP method of the request.

Renvoie
string Returns the request method.

Références Laminas\Diactoros\$method.

◆ getProtocolVersion()

Laminas\Diactoros\getProtocolVersion ( )

Retrieves the HTTP protocol version as a string.

The string MUST contain only the HTTP version number (e.g., "1.1", "1.0").

Renvoie
string HTTP protocol version.

Références Laminas\Diactoros\$protocol.

◆ getRequestTarget()

Laminas\Diactoros\getRequestTarget ( )

Retrieves the message's request target.

Retrieves the message's request-target either as it will appear (for clients), as it appeared at request (for servers), or as it was specified for the instance (see withRequestTarget()).

In most cases, this will be the origin-form of the composed URI, unless a value was provided to the concrete implementation (see withRequestTarget() below).

If no URI is available, and no request-target has been specifically provided, this method MUST return the string "/".

Références Laminas\Diactoros\$requestTarget, $target, et null.

◆ getStream()

Laminas\Diactoros\getStream | ( |  | $stream,
 |  | string | $modeIfNotInstance
 | ) |  |
private

Références Laminas\Diactoros\$stream.

Référencé par Response\__construct(), et Laminas\Diactoros\initialize().

◆ getUri()

Laminas\Diactoros\getUri ( )

Retrieves the URI instance.

This method MUST return a UriInterface instance.

UriInterface Returns a UriInterface instance representing the URI of the request, if any.

Références Laminas\Diactoros\$uri.

◆ hasHeader()

Laminas\Diactoros\hasHeader ( $header )

Checks if a header exists by the given case-insensitive name.

Paramètres
string $header Case-insensitive header name.
Renvoie
bool Returns true if any header names match the given header name using a case-insensitive string comparison. Returns false if no matching header name is found in the message.

Références $header.

Référencé par Laminas\Diactoros\getHeader(), Laminas\Diactoros\initialize(), AbstractWebApplication\respond(), Laminas\Diactoros\withAddedHeader(), Laminas\Diactoros\withoutHeader(), et Laminas\Diactoros\withUri().

◆ initialize()

Laminas\Diactoros\initialize | ( |  | $uri = null,
 |  | string | $method = null,
 |  |  | $body = 'php://memory',
 |  | array | $headers = []
 | ) |  |
private

Initialize request state.

Used by constructors.

Paramètres
null | string | UriInterface | $uri | URI for the request, if any.
null | string | $method | HTTP method for the request, if any.
string | resource | StreamInterface | $body | Message body, if any.
array | $headers | Headers for the message, if any.
Exceptions
Exception

Références Laminas\Diactoros\$method, Laminas\Diactoros\$uri, Laminas\Diactoros\createUri(), Laminas\Diactoros\getHostFromUri(), Laminas\Diactoros\getStream(), Laminas\Diactoros\hasHeader(), null, Laminas\Diactoros\setHeaders(), et Laminas\Diactoros\setMethod().

Référencé par Request\__construct(), Encrypt\__construct(), ServerRequest\__construct(), Engine\__construct(), PHP32\initialize(), PHP64\initialize(), et Inline\parse().

◆ marshalHeadersFromSapi()

Laminas\Diactoros\marshalHeadersFromSapi ( array $server )
Paramètres
array $server Values obtained from the SAPI (generally $_SERVER).
Renvoie
array Header/value pairs

Références $key, $name, et $value.

Référencé par ServerRequestFactory\fromGlobals().

◆ marshalMethodFromSapi()

Laminas\Diactoros\marshalMethodFromSapi ( array $server )

Retrieve the request method from the SAPI parameters.

Référencé par ServerRequestFactory\fromGlobals().

◆ marshalProtocolVersionFromSapi()

Laminas\Diactoros\marshalProtocolVersionFromSapi ( array $server )

Return HTTP protocol version (X.Y) as discovered within a $_SERVER array.

Exceptions
Exception

Références UnrecognizedProtocolVersionException\forVersion().

Référencé par ServerRequestFactory\fromGlobals().

◆ marshalUriFromSapi()

Laminas\Diactoros\marshalUriFromSapi | ( | array | $server,
 |  | array | $headers
 | ) |  |

Marshal a Uri instance based on the values presnt in the $_SERVER array and headers.

Paramètres
array | $server | SAPI parameters
array | $headers | HTTP request headers

Retrieve a header value from an array of headers using a case-insensitive lookup.

Paramètres
array | $headers | Key/value header pairs
mixed | $default | Default value to return if header not found
Renvoie
mixed

Marshal the host and port from HTTP headers and/or the PHP environment.

Renvoie
array Array of two items, host and port, in that order (can be passed to a list() operation).
Paramètres
string | array $host
Renvoie
array Array of two items, host and port, in that order (can be passed to a list() operation).
array Array of two items, host and port, in that order (can be passed to a list() operation).

Detect the path for the request

Looks at a variety of criteria in order to attempt to autodetect the base request path, including:

  • IIS7 UrlRewrite environment
  • REQUEST_URI
  • ORIG_PATH_INFO

From Laminas class

Références $default, $header, $name, $path, $query, Laminas\Diactoros\$uri, $value, elseif, et null.

Référencé par ServerRequestFactory\fromGlobals().

◆ normalizeServer()

Laminas\Diactoros\normalizeServer | ( | array | $server,
 |  | callable | $apacheRequestHeaderCallback = null
 | ) |  |

Marshal the $_SERVER array

Pre-processes and returns the $_SERVER superglobal. In particularly, it attempts to detect the Authorization header, which is often not aggregated correctly under various SAPI/httpd combinations.

Paramètres
null | callable $apacheRequestHeaderCallback Callback that can be used to retrieve Apache request headers. This defaults to apache_request_headers under the Apache mod_php.
Renvoie
array Either $server verbatim, or with an added HTTP_AUTHORIZATION header.

Références null.

Référencé par ServerRequestFactory\fromGlobals().

◆ normalizeUploadedFiles()

Laminas\Diactoros\normalizeUploadedFiles ( array $files )

Normalize uploaded files

Transforms each value into an UploadedFile instance, and ensures that nested arrays are normalized.

Renvoie
UploadedFileInterface[]
Exceptions
Exception

Traverse a nested tree of uploaded file specifications.

Paramètres
string[]|array[] | $tmpNameTree
int[]|array[] | $sizeTree
int[]|array[] | $errorTree
string[]|array[]|null | $nameTree
string[]|array[]|null | $typeTree
Renvoie
UploadedFile[]|array[]

Normalize an array of file specifications.

Loops through all nested files (as determined by receiving an array to the tmp_name key of a $_FILES specification) and returns a normalized array of UploadedFile instances.

This function normalizes a $_FILES array representing a nested set of uploaded files as produced by the php-fpm SAPI, CGI SAPI, or mod_php SAPI.

Paramètres
array $files
Renvoie
UploadedFile[]

Références $key, $value, Laminas\Diactoros\createUploadedFile(), et null.

Référencé par ServerRequestFactory\fromGlobals().

◆ parseCookieHeader()

Laminas\Diactoros\parseCookieHeader ( $cookieHeader )

Parse a cookie header according to RFC 6265.

PHP will replace special characters in cookie names, which results in other cookies not being available due to overwriting. Thus, the server request should take the cookies from the request header instead.

Paramètres
string $cookieHeader A string cookie header value.
Renvoie
array key/value cookie pairs.

Référencé par ServerRequestFactory\fromGlobals().

◆ setHeaders()

Laminas\Diactoros\setHeaders ( array $originalHeaders )
private

Filter a set of headers to ensure they are in the correct internal format.

Used by message constructors to allow setting all initial headers at once.

Paramètres
array $originalHeaders Headers to filter.

Références $header, Laminas\Diactoros\$headerNames, $value, Laminas\Diactoros\assertHeader(), et Laminas\Diactoros\filterHeaderValue().

Référencé par Response\__construct(), Laminas\Diactoros\initialize(), et SerializerErrorRenderer\render().

◆ setMethod()

Laminas\Diactoros\setMethod ( $method )
private

Set and validate the HTTP method

Paramètres
string $method
Exceptions
Exception

Références Laminas\Diactoros\$method, et method.

Référencé par Laminas\Diactoros\initialize().

◆ validateProtocolVersion()

Laminas\Diactoros\validateProtocolVersion ( $version )
private

Validate the HTTP protocol version

Paramètres
string $version
Exceptions
Exception

Références $version.

Référencé par Laminas\Diactoros\withProtocolVersion().

◆ withAddedHeader()

Laminas\Diactoros\withAddedHeader | ( | $header,
 |  | $value
 | ) |

Return an instance with the specified header appended with the given value.

Existing values for the specified header will be maintained. The new value(s) will be appended to the existing list. If the header did not exist previously, it will be added.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new header and/or value.

Paramètres
string | $header | Case-insensitive header field name to add.
string|string[] | $value Header value(s).
Renvoie
static
Exceptions
Exception

Références $header, $this, $value, Laminas\Diactoros\assertHeader(), Laminas\Diactoros\filterHeaderValue(), Laminas\Diactoros\hasHeader(), et Laminas\Diactoros\withHeader().

◆ withBody()

Laminas\Diactoros\withBody ( StreamInterface $body )

Return an instance with the specified message body.

The body MUST be a StreamInterface object.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return a new instance that has the new body stream.

Paramètres
StreamInterface $body Body.
Renvoie
static
Exceptions
Exception

Références $this.

Référencé par AbstractWebApplication\appendBody(), AbstractWebApplication\prependBody(), et AbstractWebApplication\setBody().

◆ withHeader()

Laminas\Diactoros\withHeader | ( | $header,
 |  | $value
 | ) |

Return an instance with the provided header, replacing any existing values of any headers with the same case-insensitive name.

While header names are case-insensitive, the casing of the header will be preserved by this function, and returned from getHeaders().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new and/or updated header and value.

Paramètres
string | $header | Case-insensitive header field name.
string|string[] | $value Header value(s).
Renvoie
static
Exceptions
Exception

Références $header, $this, $value, Laminas\Diactoros\assertHeader(), et Laminas\Diactoros\filterHeaderValue().

Référencé par Laminas\Diactoros\withAddedHeader().

◆ withMethod()

Laminas\Diactoros\withMethod ( $method )

Return an instance with the provided HTTP method.

While HTTP method names are typically all uppercase characters, HTTP method names are case-sensitive and thus implementations SHOULD NOT modify the given string.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the changed request method.

Paramètres
string $method Case-insensitive method.
Exceptions
Exception

Références Laminas\Diactoros\$method, et $this.

◆ withoutHeader()

Laminas\Diactoros\withoutHeader ( $header )

Return an instance without the specified header.

Header resolution MUST be done without case-sensitivity.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that removes the named header.

Paramètres
string $header Case-insensitive header field name to remove.
Renvoie
static

Références $header, $this, et Laminas\Diactoros\hasHeader().

◆ withProtocolVersion()

Laminas\Diactoros\withProtocolVersion ( $version )

Return an instance with the specified HTTP protocol version.

The version string MUST contain only the HTTP version number (e.g., "1.1", "1.0").

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new protocol version.

Paramètres
string $version HTTP protocol version
Renvoie
static

Références $this, $version, et Laminas\Diactoros\validateProtocolVersion().

◆ withRequestTarget()

Laminas\Diactoros\withRequestTarget ( $requestTarget )

Create a new instance with a specific request-target.

If the request needs a non-origin-form request-target — e.g., for specifying an absolute-form, authority-form, or asterisk-form — this method may be used to create an instance with the specified request-target, verbatim.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return a new instance that has the changed request target.

(for the various request-target forms allowed in request messages) string $requestTarget Exception if the request target is invalid.

Références Laminas\Diactoros\$requestTarget, et $this.

◆ withUri()

Laminas\Diactoros\withUri | ( | UriInterface | $uri,
 |  |  | $preserveHost = false
 | ) |  |

Returns an instance with the provided URI.

This method will update the Host header of the returned request by default if the URI contains a host component. If the URI does not contain a host component, any pre-existing Host header will be carried over to the returned request.

You can opt-in to preserving the original state of the Host header by setting $preserveHost to true. When $preserveHost is set to true, the returned request will not update the Host header of the returned message – even if the message contains no Host header. This means that a call to ‘getHeader('Host’)on the original request MUST equal the return value of a call togetHeader('Host')` on the returned request.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new UriInterface instance.

UriInterface $uri New request URI to use. bool $preserveHost Preserve the original state of the Host header.

Références $header, $this, Laminas\Diactoros\$uri, et Laminas\Diactoros\hasHeader().

Documentation des variables

◆ $headerNames

$headerNames = []
protected

Référencé par Laminas\Diactoros\setHeaders().

◆ $method

$method = 'GET'
private

Référencé par Request\__construct(), ServerRequest\__construct(), RequestFactory\createRequest(), ServerRequestFactory\createServerRequest(), ArraySerializer\fromArray(), Serializer\fromStream(), Laminas\Diactoros\getMethod(), Laminas\Diactoros\initialize(), Laminas\Diactoros\setMethod(), et Laminas\Diactoros\withMethod().

◆ $protocol

$protocol = '1.1'
private

Référencé par ServerRequest\__construct(), UrlFilter\filter(), Laminas\Diactoros\getProtocolVersion(), et Stream\register().

◆ $requestTarget

$requestTarget
private

Référencé par Serializer\createUriFromRequestTarget(), ArraySerializer\fromArray(), Serializer\fromStream(), Laminas\Diactoros\getRequestTarget(), et Laminas\Diactoros\withRequestTarget().

◆ $stream

$stream
private

Référencé par FeedParser\__construct(), Stream\_getFilename(), File\append(), AbstractWebApplication\appendBody(), QuestionHelper\ask(), ResourceCaster\castStream(), ResourceCaster\castStreamContext(), AuthenticatorAssertionResponseValidator\check(), Path\clean(), Folder\copy(), File\copy(), Symfony\Component\Console\Tester\createStream(), UploadedFileFactory\createUploadedFile(), Decoder\decode(), Serializer\fromStream(), Serializer\fromString(), Laminas\Diactoros\getBody(), AbstractSerializer\getLine(), DumpServer\getMessages(), TPMAttestationStatementSupport\getParameters(), Serializer\getRequestLine(), Serializer\getStatusLine(), Laminas\Diactoros\getStream(), CliDumper\hasColorSupport(), AttestationObjectLoader\load(), File\move(), Folder\move(), AbstractWebApplication\prependBody(), Decoder\process(), Decoder\processFinite(), Decoder\processInfinite(), Stream\request(), StreamTransport\request(), Php72\sapi_windows_vt100_support(), AbstractWebApplication\setBody(), AbstractSerializer\splitStream(), Php72\stream_isatty(), File\upload(), et File\write().

◆ $uri

$uri
private

Référencé par Request\__construct(), RedirectResponse\__construct(), ServerRequest\__construct(), Uri\__construct(), RequestFactory\createRequest(), ServerRequestFactory\createServerRequest(), UriFactory\createUri(), Laminas\Diactoros\createUri(), Uri\createUriString(), ArraySerializer\fromArray(), Serializer\fromStream(), Laminas\Diactoros\getUri(), Laminas\Diactoros\initialize(), Laminas\Diactoros\marshalUriFromSapi(), Uri\parseUri(), et Laminas\Diactoros\withUri().

◆ MessageTrait

trait MessageTrait
Valeur initiale :
{
protected $headers = []

Trait implementing the various methods defined in MessageInterface.

Voir également
https://github.com/php-fig/http-message/tree/master/src/MessageInterface.php

◆ RequestTrait

trait RequestTrait
Valeur initiale :
{
use MessageTrait
MessageTrait

Trait with common request behaviors.

Server and client-side requests differ slightly in how the Host header is handled; on client-side, it should be calculated on-the-fly from the composed URI (if present), while on server-side, it will be calculated from the environment. As such, this trait exists to provide the common code between both client-side and server-side requests, and each can then use the headers functionality required by their implementations.


Joomla CMS: Référence de l'espace de nommage Laminas\Diactoros\Exception

  • Laminas
  • Diactoros
  • Exception
Structures de données
Référence de l'espace de nommage Laminas\Diactoros\Exception

Structures de données

class | DeserializationException
interface | ExceptionInterface
class | InvalidArgumentException
class | InvalidStreamPointerPositionException
class | SerializationException
class | UnreadableStreamException
class | UnrecognizedProtocolVersionException
class | UnrewindableStreamException
class | UnseekableStreamException
class | UntellableStreamException
class | UnwritableStreamException
class | UploadedFileAlreadyMovedException
class | UploadedFileErrorException


Joomla CMS: Référence de l'espace de nommage Laminas\Diactoros\Request

  • Laminas
  • Diactoros
  • Request
Structures de données
Référence de l'espace de nommage Laminas\Diactoros\Request

Structures de données

class | ArraySerializer
class | Serializer


Joomla CMS: Référence de l'espace de nommage Laminas\Diactoros\Response

  • Laminas
  • Diactoros
  • Response
Structures de données
Référence de l'espace de nommage Laminas\Diactoros\Response

Structures de données

class | ArraySerializer
class | EmptyResponse
class | HtmlResponse
class | JsonResponse
class | RedirectResponse
class | Serializer
class | TextResponse
class | XmlResponse


Joomla CMS: Référence de l'espace de nommage Laminas\ZendFrameworkBridge

  • Laminas
  • ZendFrameworkBridge
Structures de données
Référence de l'espace de nommage Laminas\ZendFrameworkBridge

Structures de données

class | Autoloader
class | ConfigPostProcessor
class | Module
class | Replacements
class | RewriteRules

Description détaillée

Voir également
https://github.com/laminas/laminas-zendframework-bridge for the canonical source repository
Copyright
https://github.com/laminas/laminas-zendframework-bridge/blob/master/COPYRIGHT.md https://github.com/laminas/laminas-zendframework-bridge/blob/master/LICENSE.md New BSD License


Joomla CMS: Référence de l'espace de nommage Lcobucci

Espaces de nommage
Référence de l'espace de nommage Lcobucci

Espaces de nommage

Clock
JWT


Joomla CMS: Référence de l'espace de nommage Lcobucci\Clock

  • Lcobucci
  • Clock
Référence de l'espace de nommage Lcobucci\Clock


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT

  • Lcobucci
  • JWT
Espaces de nommage | Structures de données
Référence de l'espace de nommage Lcobucci\JWT

Espaces de nommage

Claim
Encoding
Parsing
Signer
Token
Validation

Structures de données

class | Builder
interface | Claim
class | Configuration
class | Parser
class | Signature
interface | Signer
class | Token
class | ValidationData
interface | Validator

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Claim

  • Lcobucci
  • JWT
  • Claim
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Claim

Structures de données

class | Basic
class | EqualsTo
class | Factory
class | GreaterOrEqualsTo
class | LesserOrEqualsTo
interface | Validatable

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Encoding

  • Lcobucci
  • JWT
  • Encoding
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Encoding

Structures de données

class | CannotDecodeContent
class | CannotEncodeContent


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Parsing

  • Lcobucci
  • JWT
  • Parsing
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Parsing

Structures de données

class | Decoder
class | Encoder

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Signer

  • Lcobucci
  • JWT
  • Signer
Espaces de nommage | Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Signer

Espaces de nommage

Ecdsa
Hmac
Key
Rsa

Structures de données

class | BaseSigner
class | CannotSignPayload
class | Ecdsa
class | Hmac
class | InvalidKeyProvided
class | Key
class | Keychain
class | None
class | OpenSSL
class | Rsa

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Signer\Ecdsa

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Signer\Ecdsa

Structures de données

class | ConversionFailed
class | MultibyteStringConverter
class | Sha256
class | Sha384
class | Sha512
interface | SignatureConverter

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Signer\Hmac

  • Lcobucci
  • JWT
  • Signer
  • Hmac
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Signer\Hmac

Structures de données

class | Sha256
class | Sha384
class | Sha512

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Signer\Key

  • Lcobucci
  • JWT
  • Signer
  • Key
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Signer\Key

Structures de données

class | InMemory
class | LocalFileReference


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Signer\Rsa

  • Lcobucci
  • JWT
  • Signer
  • Rsa
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Signer\Rsa

Structures de données

class | Sha256
class | Sha384
class | Sha512

Description détaillée

This file is part of Lcobucci, a simple library to handle JWT and JWS

http://opensource.org/licenses/BSD-3-Clause BSD-3-Clause


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Token

  • Lcobucci
  • JWT
  • Token
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Token

Structures de données

class | DataSet
class | InvalidTokenStructure
class | RegisteredClaimGiven
interface | RegisteredClaims
class | UnsupportedHeaderFound


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Validation

  • Lcobucci
  • JWT
  • Validation
Espaces de nommage | Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Validation

Espaces de nommage

Constraint

Structures de données

interface | Constraint
class | ConstraintViolation
class | NoConstraintsGiven
class | RequiredConstraintsViolated
class | Validator


Joomla CMS: Référence de l'espace de nommage Lcobucci\JWT\Validation\Constraint

  • Lcobucci
  • JWT
  • Validation
  • Constraint
Structures de données
Référence de l'espace de nommage Lcobucci\JWT\Validation\Constraint

Structures de données

class | IdentifiedBy
class | IssuedBy
class | LeewayCannotBeNegative
class | PermittedFor
class | RelatedTo
class | SignedWith
class | ValidAt


Joomla CMS: Référence de l'espace de nommage Math

Référence de l'espace de nommage Math

Description détaillée

Binary Finite Fields

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Finite Field Integer

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Finite Fields

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Prime Finite Fields

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Negotiation

Espaces de nommage | Structures de données
Référence de l'espace de nommage Negotiation

Espaces de nommage

Exception

Structures de données

class | AbstractNegotiator
class | Accept
class | AcceptCharset
class | AcceptEncoding
interface | AcceptHeader
class | AcceptLanguage
class | AcceptMatch
class | BaseAccept
class | CharsetNegotiator
class | EncodingNegotiator
class | LanguageNegotiator
class | Negotiator


Joomla CMS: Référence de l'espace de nommage Negotiation\Exception

  • Negotiation
  • Exception
Structures de données
Référence de l'espace de nommage Negotiation\Exception

Structures de données

interface | Exception
class | InvalidArgument
class | InvalidHeader
class | InvalidLanguage
class | InvalidMediaType


Joomla CMS: Référence de l'espace de nommage NoKeyLoadedException

Référence de l'espace de nommage NoKeyLoadedException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License NoKeyLoadedException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage NoSupportedAlgorithmsException

Référence de l'espace de nommage NoSupportedAlgorithmsException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License NoSupportedAlgorithmsException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Nyholm

Espaces de nommage
Référence de l'espace de nommage Nyholm

Espaces de nommage

Psr7


Joomla CMS: Référence de l'espace de nommage Nyholm\Psr7

  • Nyholm
  • Psr7
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Nyholm\Psr7

Espaces de nommage

Factory

Structures de données

class | Request
class | Response
class | ServerRequest
class | Stream
class | UploadedFile
class | Uri

Fonctions

getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($header)
getHeader ($header)
getHeaderLine ($header)
withHeader ($header, $value)
withAddedHeader ($header, $value)
withoutHeader ($header)
getBody ()
withBody (StreamInterface $body)
setHeaders (array $headers)
validateAndTrimHeader ($header, $values)
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
updateHostFromUri ()

Variables

trait | MessageTrait
$headerNames = []
$protocol = '1.1'
$stream
trait | RequestTrait
$requestTarget
$uri

Documentation des fonctions

◆ getBody()

Nyholm\Psr7\getBody ( )

Références Nyholm\Psr7\$stream, Stream\create(), et null.

◆ getHeader()

Nyholm\Psr7\getHeader ( $header )

Références $header.

Référencé par Nyholm\Psr7\getHeaderLine().

◆ getHeaderLine()

Nyholm\Psr7\getHeaderLine ( $header )

Références $header, et Nyholm\Psr7\getHeader().

◆ getHeaders()

Nyholm\Psr7\getHeaders ( )

◆ getMethod()

Nyholm\Psr7\getMethod ( )

Références $method.

◆ getProtocolVersion()

Nyholm\Psr7\getProtocolVersion ( )

Références Nyholm\Psr7\$protocol.

◆ getRequestTarget()

Nyholm\Psr7\getRequestTarget ( )

Références Nyholm\Psr7\$requestTarget, $target, et null.

◆ getUri()

Nyholm\Psr7\getUri ( )

Références Nyholm\Psr7\$uri.

◆ hasHeader()

Nyholm\Psr7\hasHeader ( $header )

Références $header.

Référencé par Nyholm\Psr7\withUri().

◆ setHeaders()

Nyholm\Psr7\setHeaders ( array $headers )
private

Références $header, $value, et Nyholm\Psr7\validateAndTrimHeader().

Référencé par Request\__construct(), Response\__construct(), et ServerRequest\__construct().

◆ updateHostFromUri()

Nyholm\Psr7\updateHostFromUri ( )
private

Références $header, et null.

Référencé par Request\__construct(), et ServerRequest\__construct().

◆ validateAndTrimHeader()

Nyholm\Psr7\validateAndTrimHeader | ( | $header,
 |  | $values
 | ) |
private

Make sure the header complies with RFC 7230.

Header names must be a non-empty string consisting of token characters.

Header values must be strings consisting of visible characters with all optional leading and trailing whitespace stripped. This method will always strip such optional whitespace. Note that the method does not allow folding whitespace within the values as this was deprecated for almost all instances by the RFC.

header-field = field-name ":" OWS field-value OWS field-name = 1*( "!" / "#" / "$" / "%" / "&" / "'" / "*" / "+" / "-" / "." / "^" / "_" / "`" / "|" / "~" / x30-39 / ( x41-5A / x61-7A ) ) OWS = *( SP / HTAB ) field-value = *( ( x21-7E / x80-FF ) [ 1*( SP / HTAB ) ( x21-7E / x80-FF ) ] )

Voir également
https://tools.ietf.org/html/rfc7230#section-3.2.4

Références $header.

Référencé par Nyholm\Psr7\setHeaders(), et Nyholm\Psr7\withHeader().

◆ withAddedHeader()

Nyholm\Psr7\withAddedHeader | ( | $header,
 |  | $value
 | ) |

Références $header, $this, et $value.

◆ withBody()

Nyholm\Psr7\withBody ( StreamInterface $body )

Références $this.

◆ withHeader()

Nyholm\Psr7\withHeader | ( | $header,
 |  | $value
 | ) |

Références $header, $this, $value, et Nyholm\Psr7\validateAndTrimHeader().

◆ withMethod()

Nyholm\Psr7\withMethod ( $method )

Références $method, et $this.

◆ withoutHeader()

Nyholm\Psr7\withoutHeader ( $header )

Références $header, et $this.

◆ withProtocolVersion()

Nyholm\Psr7\withProtocolVersion ( $version )

Références $this, et $version.

◆ withRequestTarget()

Nyholm\Psr7\withRequestTarget ( $requestTarget )

Références Nyholm\Psr7\$requestTarget, et $this.

◆ withUri()

Nyholm\Psr7\withUri | ( | UriInterface | $uri,
 |  |  | $preserveHost = false
 | ) |  |

Références $this, Nyholm\Psr7\$uri, et Nyholm\Psr7\hasHeader().

Documentation des variables

◆ $headerNames

$headerNames = []
private

◆ $protocol

$protocol = '1.1'
private

Référencé par Nyholm\Psr7\getProtocolVersion().

◆ $requestTarget

$requestTarget
private

Référencé par Nyholm\Psr7\getRequestTarget(), et Nyholm\Psr7\withRequestTarget().

◆ $stream

$stream
private

Référencé par Psr17Factory\createUploadedFile(), et Nyholm\Psr7\getBody().

◆ $uri

$uri
private

Référencé par Request\__construct(), ServerRequest\__construct(), Uri\__construct(), Psr17Factory\createRequest(), HttplugFactory\createRequest(), Psr17Factory\createServerRequest(), HttplugFactory\createUri(), Psr17Factory\createUri(), Uri\createUriString(), Nyholm\Psr7\getUri(), et Nyholm\Psr7\withUri().

◆ MessageTrait

trait MessageTrait
Valeur initiale :
{
private $headers = []

Trait implementing functionality common to requests and responses.

Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

◆ RequestTrait

trait RequestTrait
Valeur initiale :
{
private $method
$method
$method
Definition: administrator/components/com_users/tmpl/method/edit.php:29
Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se


Joomla CMS: Référence de l'espace de nommage Nyholm\Psr7\Factory

  • Nyholm
  • Psr7
  • Factory
Structures de données
Référence de l'espace de nommage Nyholm\Psr7\Factory

Structures de données

class | HttplugFactory
class | Psr17Factory


Joomla CMS: Référence de l'espace de nommage ParagonIE

Espaces de nommage
Référence de l'espace de nommage ParagonIE

Espaces de nommage

ConstantTime
Sodium

Description détaillée

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base32 [A-Z][2-7]

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base32Hex [0-9][A-V]

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base64 [A-Z][a-z][0-9]+/

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base64DotSlash ./[A-Z][a-z][0-9]

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base64DotSlashOrdered ./[0-9][A-Z][a-z]

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Base64UrlSafe [A-Z][a-z][0-9]-_

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Binary

Binary string operators that don't choke on mbstring.func_overload

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Interface EncoderInterface

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Encoding

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class Hex

Copyright (c) 2016 - 2022 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. Class RFC4648

This class conforms strictly to the RFC


Joomla CMS: Référence de l'espace de nommage ParagonIE\ConstantTime

  • ParagonIE
  • ConstantTime
Structures de données
Référence de l'espace de nommage ParagonIE\ConstantTime

Structures de données

class | Base32
class | Base32Hex
class | Base64
class | Base64DotSlash
class | Base64DotSlashOrdered
class | Base64UrlSafe
class | Binary
interface | EncoderInterface
class | Encoding
class | Hex
class | RFC4648


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium

  • ParagonIE
  • Sodium
Espaces de nommage | Structures de données
Référence de l'espace de nommage ParagonIE\Sodium

Espaces de nommage

Core

Structures de données

class | Compat
class | Crypto
class | File


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium\Core

  • ParagonIE
  • Sodium
  • Core
Espaces de nommage | Structures de données
Référence de l'espace de nommage ParagonIE\Sodium\Core

Espaces de nommage

ChaCha20
Curve25519
Poly1305

Structures de données

class | BLAKE2b
class | ChaCha20
class | Curve25519
class | Ed25519
class | HChaCha20
class | HSalsa20
class | Poly1305
class | Salsa20
class | SipHash
class | Util
class | X25519
class | XChaCha20
class | Xsalsa20


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium\Core\ChaCha20

  • ParagonIE
  • Sodium
  • Core
  • ChaCha20
Structures de données
Référence de l'espace de nommage ParagonIE\Sodium\Core\ChaCha20

Structures de données

class | Ctx
class | IetfCtx


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium\Core\Curve25519

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
Espaces de nommage | Structures de données
Référence de l'espace de nommage ParagonIE\Sodium\Core\Curve25519

Espaces de nommage

Ge

Structures de données

class | Fe
class | H


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium\Core\Curve25519\Ge

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
Structures de données
Référence de l'espace de nommage ParagonIE\Sodium\Core\Curve25519\Ge

Structures de données

class | Cached
class | P1p1
class | P2
class | P3
class | Precomp


Joomla CMS: Référence de l'espace de nommage ParagonIE\Sodium\Core\Poly1305

  • ParagonIE
  • Sodium
  • Core
  • Poly1305
Structures de données
Référence de l'espace de nommage ParagonIE\Sodium\Core\Poly1305

Structures de données

class State


Joomla CMS: Référence de l'espace de nommage PHP

Référence de l'espace de nommage PHP

Description détaillée

Sliding Window Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Default Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Barrett Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Montgomery Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

OpenSSL Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Classic Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Dynamic Barrett Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Montgomery Modular Exponentiation Engine with interleaved multiplication

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PHP Power Of Two Modular Exponentiation Engine

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Pure-PHP Engine.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Pure-PHP 64-bit Engine.

Uses 64-bit integers if int size is 8 bits

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage PHP32

Référence de l'espace de nommage PHP32

Description détaillée

Pure-PHP 32-bit Engine.

Uses 64-bit floats if int size is 4 bits

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage PHPMailer

Espaces de nommage
Référence de l'espace de nommage PHPMailer

Espaces de nommage

PHPMailer


Joomla CMS: Référence de l'espace de nommage PHPMailer\PHPMailer

  • PHPMailer
  • PHPMailer
Structures de données
Référence de l'espace de nommage PHPMailer\PHPMailer

Structures de données

class | Exception
class | OAuth
interface | OAuthTokenProvider
class | PHPMailer
class | POP3
class | SMTP

Description détaillée

PHPMailer Exception class. PHP Version 5.5.

Voir également
https://github.com/PHPMailer/PHPMailer/ The PHPMailer GitHub project
Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et
Brent R. Matzelle (original founder)
Copyright
2012 - 2020 Marcus Bointon
2010 - 2012 Jim Jagielski
2004 - 2009 Andy Prevost http://www.gnu.org/copyleft/lesser.html GNU Lesser General Public License
Note
This program is distributed in the hope that it will be useful - WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

PHPMailer - PHP email creation and transport class. PHP Version 5.5.

Voir également
https://github.com/PHPMailer/PHPMailer/ The PHPMailer GitHub project
Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et
Brent R. Matzelle (original founder)
Copyright
2012 - 2020 Marcus Bointon
2010 - 2012 Jim Jagielski
2004 - 2009 Andy Prevost http://www.gnu.org/copyleft/lesser.html GNU Lesser General Public License
Note
This program is distributed in the hope that it will be useful - WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

PHPMailer POP-Before-SMTP Authentication Class. PHP Version 5.5.

Voir également
https://github.com/PHPMailer/PHPMailer/ The PHPMailer GitHub project
Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et
Brent R. Matzelle (original founder)
Copyright
2012 - 2020 Marcus Bointon
2010 - 2012 Jim Jagielski
2004 - 2009 Andy Prevost http://www.gnu.org/copyleft/lesser.html GNU Lesser General Public License
Note
This program is distributed in the hope that it will be useful - WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

PHPMailer RFC821 SMTP email transport class. PHP Version 5.5.

Voir également
https://github.com/PHPMailer/PHPMailer/ The PHPMailer GitHub project
Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et
Brent R. Matzelle (original founder)
Copyright
2012 - 2020 Marcus Bointon
2010 - 2012 Jim Jagielski
2004 - 2009 Andy Prevost http://www.gnu.org/copyleft/lesser.html GNU Lesser General Public License
Note
This program is distributed in the hope that it will be useful - WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Joomla CMS: Référence de l'espace de nommage phpseclib3

Espaces de nommage
Référence de l'espace de nommage phpseclib3

Espaces de nommage

Common
Crypt
Exception
File
Math
Net
System


Joomla CMS: Référence de l'espace de nommage phpseclib3\Common

  • phpseclib3
  • Common
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Common

Espaces de nommage

Functions


Joomla CMS: Référence de l'espace de nommage phpseclib3\Common\Functions

  • phpseclib3
  • Common
  • Functions
Structures de données
Référence de l'espace de nommage phpseclib3\Common\Functions

Structures de données

class Strings


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt

  • phpseclib3
  • Crypt
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt

Espaces de nommage

Common
DH
DSA
EC
RSA

Structures de données

class | AES
class | Blowfish
class | ChaCha20
class | DES
class | DH
class | DSA
class | EC
class | Hash
class | PublicKeyLoader
class | Random
class | RC2
class | RC4
class | Rijndael
class | RSA
class | Salsa20
class | TripleDES
class | Twofish

Description détaillée

Pure-PHP implementation of Rijndael.

Uses mcrypt, if available/possible, and an internal implementation, otherwise.

PHP version 5

If setBlockLength() isn't called, it'll be assumed to be 128 bits. If setKeyLength() isn't called, it'll be calculated from setKey(). ie. if the key is 128-bits, the key length will be 128-bits. If it's 136-bits it'll be null-padded to 192-bits and 192 bits will be the key length until setKey() is called, again, at which point, it'll be recalculated.

Not all Rijndael implementations may support 160-bits or 224-bits as the block length / key length. mcrypt, for example, does not. AES, itself, only supports block lengths of 128 and key lengths of 128, 192, and 256. Rijndael-ammended.pdf#page=10 defines the algorithm for block lengths of 192 and 256 but not for block lengths / key lengths of 160 and 224. Indeed, 160 and 224 are first defined as valid key / block lengths in Rijndael-ammended.pdf#page=44: Extensions: Other block and Cipher Key lengths. Note: Use of 160/224-bit Keys must be explicitly set by setKeyLength(160) respectively setKeyLength(224).

{


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\Common

  • phpseclib3
  • Crypt
  • Common
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\Common

Espaces de nommage

Formats
Traits

Structures de données

class | AsymmetricKey
class | BlockCipher
interface | PrivateKey
interface | PublicKey
class | StreamCipher
class | SymmetricKey


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats

  • phpseclib3
  • Crypt
  • Common
  • Formats
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats

Espaces de nommage

Keys
Signature


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats\Keys

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats\Keys

Structures de données

class | OpenSSH
class | PKCS
class | PKCS1
class | PKCS8
class | PuTTY


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats\Signature

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Signature
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\Common\Formats\Signature

Structures de données

class Raw


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\Common\Traits

  • phpseclib3
  • Crypt
  • Common
  • Traits
Fonctions | Variables
Référence de l'espace de nommage phpseclib3\Crypt\Common\Traits

Fonctions

withPassword ($password=false)

Variables

trait PasswordProtected

Documentation des fonctions

◆ withPassword()

phpseclib3\Crypt\Common\Traits\withPassword ( $password = false )

Sets the password

Private keys can be encrypted with a password. To unset the password, pass in the empty string or false. Or rather, pass in $password such that empty($password) && !is_string($password) is true.

Voir également
self::createKey()
self::load() public
Paramètres
string | bool $password

Références $password, et $this.

Documentation des variables

◆ PasswordProtected

trait PasswordProtected
Valeur initiale :
{
private $password = false
$password
$password
Definition: administrator/components/com_joomlaupdate/tmpl/update/default.php:43


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DH

  • phpseclib3
  • Crypt
  • DH
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\DH

Espaces de nommage

Formats

Structures de données

class | Parameters
class | PrivateKey
class | PublicKey


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DH\Formats

  • phpseclib3
  • Crypt
  • DH
  • Formats
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Crypt\DH\Formats

Espaces de nommage

Keys


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DH\Formats\Keys

  • phpseclib3
  • Crypt
  • DH
  • Formats
  • Keys
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\DH\Formats\Keys

Structures de données

class | PKCS1
class | PKCS8


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DSA

  • phpseclib3
  • Crypt
  • DSA
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\DSA

Espaces de nommage

Formats

Structures de données

class | Parameters
class | PrivateKey
class | PublicKey


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats

  • phpseclib3
  • Crypt
  • DSA
  • Formats
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats

Espaces de nommage

Keys
Signature


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats\Keys

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats\Keys

Structures de données

class | OpenSSH
class | PKCS1
class | PKCS8
class | PuTTY
class | Raw
class | XML


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats\Signature

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Signature
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\DSA\Formats\Signature

Structures de données

class | ASN1
class | Raw
class | SSH2


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC

  • phpseclib3
  • Crypt
  • EC
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\EC

Espaces de nommage

BaseCurves
Curves
Formats

Structures de données

class | Parameters
class | PrivateKey
class | PublicKey


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC\BaseCurves

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\EC\BaseCurves

Structures de données

class | Base
class | Binary
class | KoblitzPrime
class | Montgomery
class | Prime
class | TwistedEdwards


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC\Curves

  • phpseclib3
  • Crypt
  • EC
  • Curves
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\EC\Curves

Structures de données

class | brainpoolP160r1
class | brainpoolP160t1
class | brainpoolP192r1
class | brainpoolP192t1
class | brainpoolP224r1
class | brainpoolP224t1
class | brainpoolP256r1
class | brainpoolP256t1
class | brainpoolP320r1
class | brainpoolP320t1
class | brainpoolP384r1
class | brainpoolP384t1
class | brainpoolP512r1
class | brainpoolP512t1
class | Curve25519
class | Curve448
class | Ed25519
class | Ed448
class | nistb233
class | nistb409
class | nistk163
class | nistk233
class | nistk283
class | nistk409
class | nistp192
class | nistp224
class | nistp256
class | nistp384
class | nistp521
class | nistt571
class | prime192v1
class | prime192v2
class | prime192v3
class | prime239v1
class | prime239v2
class | prime239v3
class | prime256v1
class | secp112r1
class | secp112r2
class | secp128r1
class | secp128r2
class | secp160k1
class | secp160r1
class | secp160r2
class | secp192k1
class | secp192r1
class | secp224k1
class | secp224r1
class | secp256k1
class | secp256r1
class | secp384r1
class | secp521r1
class | sect113r1
class | sect113r2
class | sect131r1
class | sect131r2
class | sect163k1
class | sect163r1
class | sect163r2
class | sect193r1
class | sect193r2
class | sect233k1
class | sect233r1
class | sect239k1
class | sect283k1
class | sect283r1
class | sect409k1
class | sect409r1
class | sect571k1
class | sect571r1


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats

  • phpseclib3
  • Crypt
  • EC
  • Formats
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats

Espaces de nommage

Keys
Signature


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats\Keys

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Fonctions | Variables
Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats\Keys

Structures de données

class | libsodium
class | MontgomeryPrivate
class | MontgomeryPublic
class | OpenSSH
class | PKCS1
class | PKCS8
class | PuTTY
class | XML

Fonctions

static | initialize_static_variables ()
static | setImplicitCurve (BaseCurve $curve)
static | loadCurveByParam (array $params)
static | extractPoint ($str, BaseCurve $curve)
static | encodeParameters (BaseCurve $curve, $returnArray=false, array $options=[])
static | useSpecifiedCurve ()
static | useNamedCurve ()

Variables

trait | Common
static | $childOIDsLoaded = false
static | $useNamedCurves = true

Documentation des fonctions

◆ encodeParameters()

static phpseclib3\Crypt\EC\Formats\Keys\encodeParameters | ( | BaseCurve | $curve,
 |  |  | $returnArray = false,
 |  | array | $options = []
 | ) |  |
staticprivate

Encode Parameters

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve
bool | $returnArray | optional
array | $options | optional
Renvoie
string|false

Références $b, $class, EC\$curve, $data, $name, $options, $params, phpseclib3\Crypt\EC\Formats\Keys\$useNamedCurves, EC\$x, __DIR__, ASN1\encodeDER(), et ECParameters\MAP.

Référencé par XML\encodeXMLParameters(), PKCS1\load(), PKCS1\saveParameters(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), et PKCS8\savePublicKey().

◆ extractPoint()

static phpseclib3\Crypt\EC\Formats\Keys\extractPoint | ( |  | $str,
 |  | BaseCurve | $curve
 | ) |  |
static

Extract points from a string

Supports both compressed and uncompressed points

Paramètres
string | $str
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve
Renvoie
object[]

Références EC\$curve, $val, EC\$x, EncoderInterface\encode(), et Strings\shift().

Référencé par libsodium\load(), OpenSSH\load(), PKCS1\load(), XML\load(), PKCS8\load(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), XML\loadCurveByParam(), PKCS8\loadEdDSA(), PrivateKey\multiply(), et PublicKey\verify().

◆ initialize_static_variables()

static phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables ( )
staticprivate

Initialize static variables

Références ASN1\loadOIDs().

Référencé par AsymmetricKey\__construct(), BigInteger\__construct(), AsymmetricKey\addFileFormat(), EC\createKey(), DSA\createKey(), DSA\createParameters(), OpenSSH\getAlias(), BigInteger\getEngine(), AsymmetricKey\getSupportedKeyFormats(), RSA\initialize_static_variables(), PKCS1\load(), XML\load(), PKCS8\load(), PSS\load(), AsymmetricKey\load(), AsymmetricKey\loadFormat(), PKCS8\preParse(), BigInteger\random(), BigInteger\randomPrime(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), PSS\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), PKCS8\savePublicKey(), PSS\savePublicKey(), XML\savePublicKey(), PKCS8\wrapPrivateKey(), et PKCS8\wrapPublicKey().

◆ loadCurveByParam()

static phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam ( array $params )
staticprotected

Returns an instance of based on the curve parameters

Paramètres
array $params
Renvoie
|false

Références EC\$curve, $data, $params, $temp, ASN1\asn1map(), ASN1\decodeBER(), EncoderInterface\encode(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), et AsymmetricKey\toString().

Référencé par OpenSSH\load(), PKCS1\load(), XML\load(), et PKCS8\load().

◆ setImplicitCurve()

static phpseclib3\Crypt\EC\Formats\Keys\setImplicitCurve ( BaseCurve $curve )
static

Explicitly set the curve

If the key contains an implicit curve phpseclib needs the curve to be explicitly provided

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base $curve

Références EC\$curve.

◆ useNamedCurve()

static phpseclib3\Crypt\EC\Formats\Keys\useNamedCurve ( )
static

Use Named Curve

A named curve does not include any parameters. It is up to the EC parameters to know what the coefficients, the base points, etc, are from the name of the curve. A named curve is a more concise way of representing a curve

Références phpseclib3\Crypt\EC\Formats\Keys\$useNamedCurves.

◆ useSpecifiedCurve()

static phpseclib3\Crypt\EC\Formats\Keys\useSpecifiedCurve ( )
static

Use Specified Curve

A specified curve has all the coefficients, the base points, etc, explicitely included. A specified curve is a more verbose way of representing a curve

Références phpseclib3\Crypt\EC\Formats\Keys\$useNamedCurves.

Référencé par EC\getCurve().

Documentation des variables

◆ $childOIDsLoaded

$childOIDsLoaded = false
staticprotected

Référencé par PKCS8\initialize_static_variables().

◆ $useNamedCurves

$useNamedCurves = true
staticprivate

Référencé par phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), phpseclib3\Crypt\EC\Formats\Keys\useNamedCurve(), et phpseclib3\Crypt\EC\Formats\Keys\useSpecifiedCurve().

◆ Common

trait Common
Valeur initiale :
{
private static $curveOIDs = []


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats\Signature

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Signature
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\EC\Formats\Signature

Structures de données

class | ASN1
class | Raw
class | SSH2


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\RSA

  • phpseclib3
  • Crypt
  • RSA
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\RSA

Espaces de nommage

Formats

Structures de données

class | PrivateKey
class | PublicKey


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\RSA\Formats

  • phpseclib3
  • Crypt
  • RSA
  • Formats
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Crypt\RSA\Formats

Espaces de nommage

Keys


Joomla CMS: Référence de l'espace de nommage phpseclib3\Crypt\RSA\Formats\Keys

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données
Référence de l'espace de nommage phpseclib3\Crypt\RSA\Formats\Keys

Structures de données

class | MSBLOB
class | OpenSSH
class | PKCS1
class | PKCS8
class | PSS
class | PuTTY
class | Raw
class | XML


Joomla CMS: Référence de l'espace de nommage phpseclib3\Exception

  • phpseclib3
  • Exception
Structures de données
Référence de l'espace de nommage phpseclib3\Exception

Structures de données

class | BadConfigurationException
class | BadDecryptionException
class | BadModeException
class | ConnectionClosedException
class | FileNotFoundException
class | InconsistentSetupException
class | InsufficientSetupException
class | NoKeyLoadedException
class | NoSupportedAlgorithmsException
class | UnableToConnectException
class | UnsupportedAlgorithmException
class | UnsupportedCurveException
class | UnsupportedFormatException
class | UnsupportedOperationException


Joomla CMS: Référence de l'espace de nommage phpseclib3\File

  • phpseclib3
  • File
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\File

Espaces de nommage

ASN1

Structures de données

class | ANSI
class | ASN1
class | X509


Joomla CMS: Référence de l'espace de nommage phpseclib3\File\ASN1

  • phpseclib3
  • File
  • ASN1
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\File\ASN1

Espaces de nommage

Maps

Structures de données

class Element


Joomla CMS: Référence de l'espace de nommage phpseclib3\File\ASN1\Maps

  • phpseclib3
  • File
  • ASN1
  • Maps
Structures de données
Référence de l'espace de nommage phpseclib3\File\ASN1\Maps

Structures de données

class | AccessDescription
class | AdministrationDomainName
class | AlgorithmIdentifier
class | AnotherName
class | Attribute
class | Attributes
class | AttributeType
class | AttributeTypeAndValue
class | AttributeValue
class | AuthorityInfoAccessSyntax
class | AuthorityKeyIdentifier
class | BaseDistance
class | BasicConstraints
class | BuiltInDomainDefinedAttribute
class | BuiltInDomainDefinedAttributes
class | BuiltInStandardAttributes
class | Certificate
class | CertificateIssuer
class | CertificateList
class | CertificatePolicies
class | CertificateSerialNumber
class | CertificationRequest
class | CertificationRequestInfo
class | CertPolicyId
class | Characteristic_two
class | CountryName
class | CPSuri
class | CRLDistributionPoints
class | CRLNumber
class | CRLReason
class | Curve
class | DHParameter
class | DigestInfo
class | DirectoryString
class | DisplayText
class | DistributionPoint
class | DistributionPointName
class | DSAParams
class | DSAPrivateKey
class | DSAPublicKey
class | DssSigValue
class | EcdsaSigValue
class | ECParameters
class | ECPoint
class | ECPrivateKey
class | EDIPartyName
class | EncryptedData
class | EncryptedPrivateKeyInfo
class | Extension
class | ExtensionAttribute
class | ExtensionAttributes
class | Extensions
class | ExtKeyUsageSyntax
class | FieldElement
class | FieldID
class | GeneralName
class | GeneralNames
class | GeneralSubtree
class | GeneralSubtrees
class | HashAlgorithm
class | HoldInstructionCode
class | InvalidityDate
class | IssuerAltName
class | IssuingDistributionPoint
class | KeyIdentifier
class | KeyPurposeId
class | KeyUsage
class | MaskGenAlgorithm
class | Name
class | NameConstraints
class | netscape_ca_policy_url
class | netscape_cert_type
class | netscape_comment
class | NetworkAddress
class | NoticeReference
class | NumericUserIdentifier
class | OneAsymmetricKey
class | ORAddress
class | OrganizationalUnitNames
class | OrganizationName
class | OtherPrimeInfo
class | OtherPrimeInfos
class | PBEParameter
class | PBES2params
class | PBKDF2params
class | PBMAC1params
class | Pentanomial
class | PersonalName
class | PKCS9String
class | PolicyInformation
class | PolicyMappings
class | PolicyQualifierId
class | PolicyQualifierInfo
class | PostalAddress
class | Prime_p
class | PrivateDomainName
class | PrivateKey
class | PrivateKeyInfo
class | PrivateKeyUsagePeriod
class | PublicKey
class | PublicKeyAndChallenge
class | PublicKeyInfo
class | RC2CBCParameter
class | RDNSequence
class | ReasonFlags
class | RelativeDistinguishedName
class | RevokedCertificate
class | RSAPrivateKey
class | RSAPublicKey
class | RSASSA_PSS_params
class | SignedPublicKeyAndChallenge
class | SpecifiedECDomain
class | SubjectAltName
class | SubjectDirectoryAttributes
class | SubjectInfoAccessSyntax
class | SubjectPublicKeyInfo
class | TBSCertificate
class | TBSCertList
class | TerminalIdentifier
class | Time
class | Trinomial
class | UniqueIdentifier
class | UserNotice
class | Validity


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math

  • phpseclib3
  • Math
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Math

Espaces de nommage

BigInteger
BinaryField
Common
PrimeField

Structures de données

class | BigInteger
class | BinaryField
class | PrimeField


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger

  • phpseclib3
  • Math
  • BigInteger
Espaces de nommage
Référence de l'espace de nommage phpseclib3\Math\BigInteger

Espaces de nommage

Engines


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines

  • phpseclib3
  • Math
  • BigInteger
  • Engines
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines

Espaces de nommage

BCMath
GMP
PHP

Structures de données

class | BCMath
class | Engine
class | GMP
class | OpenSSL
class | PHP
class | PHP32
class | PHP64


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\BCMath

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\BCMath

Espaces de nommage

Reductions

Structures de données

class | Base
class | BuiltIn
class | DefaultEngine
class | OpenSSL


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\BCMath\Reductions

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\BCMath\Reductions

Structures de données

class | Barrett
class | EvalBarrett


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\GMP

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • GMP
Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\GMP

Structures de données

class DefaultEngine


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\PHP

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\PHP

Espaces de nommage

Reductions

Structures de données

class | Base
class | DefaultEngine
class | Montgomery
class | OpenSSL


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\PHP\Reductions

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données
Référence de l'espace de nommage phpseclib3\Math\BigInteger\Engines\PHP\Reductions

Structures de données

class | Barrett
class | Classic
class | EvalBarrett
class | Montgomery
class | MontgomeryMult
class | PowerOfTwo


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\BinaryField

  • phpseclib3
  • Math
  • BinaryField
Structures de données
Référence de l'espace de nommage phpseclib3\Math\BinaryField

Structures de données

class Integer


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\Common

  • phpseclib3
  • Math
  • Common
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Math\Common

Espaces de nommage

FiniteField

Structures de données

class FiniteField


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\Common\FiniteField

  • phpseclib3
  • Math
  • Common
  • FiniteField
Structures de données
Référence de l'espace de nommage phpseclib3\Math\Common\FiniteField

Structures de données

class Integer


Joomla CMS: Référence de l'espace de nommage phpseclib3\Math\PrimeField

  • phpseclib3
  • Math
  • PrimeField
Structures de données
Référence de l'espace de nommage phpseclib3\Math\PrimeField

Structures de données

class Integer


Joomla CMS: Référence de l'espace de nommage phpseclib3\Net

  • phpseclib3
  • Net
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\Net

Espaces de nommage

SFTP

Structures de données

class | SFTP
class | SSH2


Joomla CMS: Référence de l'espace de nommage phpseclib3\Net\SFTP

  • phpseclib3
  • Net
  • SFTP
Structures de données
Référence de l'espace de nommage phpseclib3\Net\SFTP

Structures de données

class Stream


Joomla CMS: Référence de l'espace de nommage phpseclib3\System

  • phpseclib3
  • System
Espaces de nommage
Référence de l'espace de nommage phpseclib3\System

Espaces de nommage

SSH


Joomla CMS: Référence de l'espace de nommage phpseclib3\System\SSH

  • phpseclib3
  • System
  • SSH
Espaces de nommage | Structures de données
Référence de l'espace de nommage phpseclib3\System\SSH

Espaces de nommage

Agent
Common

Structures de données

class Agent

Description détaillée

Pure-PHP ssh-agent client.

{


Joomla CMS: Référence de l'espace de nommage phpseclib3\System\SSH\Agent

  • phpseclib3
  • System
  • SSH
  • Agent
Structures de données
Référence de l'espace de nommage phpseclib3\System\SSH\Agent

Structures de données

class Identity

Description détaillée

Pure-PHP ssh-agent client.

{


Joomla CMS: Référence de l'espace de nommage phpseclib3\System\SSH\Common

  • phpseclib3
  • System
  • SSH
  • Common
Espaces de nommage
Référence de l'espace de nommage phpseclib3\System\SSH\Common

Espaces de nommage

Traits


Joomla CMS: Référence de l'espace de nommage phpseclib3\System\SSH\Common\Traits

  • phpseclib3
  • System
  • SSH
  • Common
  • Traits
Référence de l'espace de nommage phpseclib3\System\SSH\Common\Traits


Joomla CMS: Référence de l'espace de nommage Prime

Référence de l'espace de nommage Prime

Description détaillée

Base

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Curves over y^2 = x^3 + a*x + b

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Curves over a*x^2 + y^2 = 1 + d*x^2*y^2

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Psr

Espaces de nommage
Référence de l'espace de nommage Psr

Espaces de nommage

Container
Http
Link
Log


Joomla CMS: Référence de l'espace de nommage Psr\Container

  • Psr
  • Container
Structures de données
Référence de l'espace de nommage Psr\Container

Structures de données

interface | ContainerExceptionInterface
interface | ContainerInterface
interface | NotFoundExceptionInterface


Joomla CMS: Référence de l'espace de nommage Psr\Http

  • Psr
  • Http
Espaces de nommage
Référence de l'espace de nommage Psr\Http

Espaces de nommage

Client
Message


Joomla CMS: Référence de l'espace de nommage Psr\Http\Client

  • Psr
  • Http
  • Client
Structures de données
Référence de l'espace de nommage Psr\Http\Client

Structures de données

interface | ClientExceptionInterface
interface | ClientInterface
interface | NetworkExceptionInterface
interface | RequestExceptionInterface


Joomla CMS: Référence de l'espace de nommage Psr\Http\Message

  • Psr
  • Http
  • Message
Structures de données
Référence de l'espace de nommage Psr\Http\Message

Structures de données

interface | MessageInterface
interface | RequestFactoryInterface
interface | RequestInterface
interface | ResponseFactoryInterface
interface | ResponseInterface
interface | ServerRequestFactoryInterface
interface | ServerRequestInterface
interface | StreamFactoryInterface
interface | StreamInterface
interface | UploadedFileFactoryInterface
interface | UploadedFileInterface
interface | UriFactoryInterface
interface | UriInterface


Joomla CMS: Référence de l'espace de nommage Psr\Link

  • Psr
  • Link
Structures de données
Référence de l'espace de nommage Psr\Link

Structures de données

interface | EvolvableLinkInterface
interface | EvolvableLinkProviderInterface
interface | LinkInterface
interface | LinkProviderInterface


Joomla CMS: Référence de l'espace de nommage Psr\Log

  • Psr
  • Log
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Psr\Log

Structures de données

class | AbstractLogger
class | InvalidArgumentException
interface | LoggerAwareInterface
interface | LoggerInterface
class | LogLevel
class | NullLogger

Fonctions

setLogger (LoggerInterface $logger)

Variables

trait | LoggerAwareTrait
trait | LoggerTrait

Documentation des fonctions

◆ setLogger()

Psr\Log\setLogger ( LoggerInterface $logger )

Sets a logger.

Paramètres
LoggerInterface $logger

Référencé par PropelCollector\__construct(), et Task\__construct().

Documentation des variables

◆ LoggerAwareTrait

trait LoggerAwareTrait
Valeur initiale :
{
protected $logger

Basic Implementation of LoggerAwareInterface.

◆ LoggerTrait

trait LoggerTrait

This is a simple Logger trait that classes unable to extend AbstractLogger (because they extend another class, etc) can include.

It simply delegates all log-level-specific methods to the log method to reduce boilerplate code that a simple Logger that does the same thing with messages regardless of the error level has to implement.


Joomla CMS: Référence de l'espace de nommage PublicKeyLoader

Référence de l'espace de nommage PublicKeyLoader

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2009 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net


Joomla CMS: Référence de l'espace de nommage Ramsey

Espaces de nommage
Référence de l'espace de nommage Ramsey

Espaces de nommage

Uuid


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid

  • Ramsey
  • Uuid
Espaces de nommage | Structures de données | Fonctions
Référence de l'espace de nommage Ramsey\Uuid

Espaces de nommage

Builder
Codec
Converter
Exception
Generator
Provider

Structures de données

class | BinaryUtils
class | DegradedUuid
class | FeatureSet
class | Uuid
class | UuidFactory
interface | UuidFactoryInterface
interface | UuidInterface

Fonctions

v1 ($node=null, $clockSeq=null)
v3 ($ns, $name)
v4 ()
v5 ($ns, $name)

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub This file is part of the ramsey/uuid library For the full copyright and license information, please view the LICENSE file that was distributed with this source code. Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT

Documentation des fonctions

◆ v1()

Ramsey\Uuid\v1 | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID from a host ID, sequence number, and the current time.

Paramètres
int | string | null | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | null | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
string
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Références Uuid\uuid1().

◆ v3()

Ramsey\Uuid\v3 | ( | $ns,
 |  | $name
 | ) |

Generate a version 3 UUID based on the MD5 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
string
Exceptions
InvalidUuidStringException

Références $name, et Uuid\uuid3().

◆ v4()

Ramsey\Uuid\v4 ( )

Generate a version 4 (random) UUID.

Renvoie
string
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception

Références Uuid\uuid4().

◆ v5()

Ramsey\Uuid\v5 | ( | $ns,
 |  | $name
 | ) |

Generate a version 5 UUID based on the SHA-1 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
string
Exceptions
InvalidUuidStringException

Références $name, et Uuid\uuid5().


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Builder

  • Ramsey
  • Uuid
  • Builder
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Builder

Structures de données

class | DefaultUuidBuilder
class | DegradedUuidBuilder
interface | UuidBuilderInterface

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Codec

  • Ramsey
  • Uuid
  • Codec
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Codec

Structures de données

interface | CodecInterface
class | GuidStringCodec
class | OrderedTimeCodec
class | StringCodec
class | TimestampFirstCombCodec
class | TimestampLastCombCodec

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Converter

  • Ramsey
  • Uuid
  • Converter
Espaces de nommage | Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Converter

Espaces de nommage

Number
Time

Structures de données

interface | NumberConverterInterface
interface | TimeConverterInterface

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Converter\Number

  • Ramsey
  • Uuid
  • Converter
  • Number
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Converter\Number

Structures de données

class | BigNumberConverter
class | DegradedNumberConverter

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Converter\Time

  • Ramsey
  • Uuid
  • Converter
  • Time
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Converter\Time

Structures de données

class | BigNumberTimeConverter
class | DegradedTimeConverter
class | PhpTimeConverter

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Exception

  • Ramsey
  • Uuid
  • Exception
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Exception

Structures de données

class | InvalidUuidStringException
class | UnsatisfiedDependencyException
class | UnsupportedOperationException

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Generator

  • Ramsey
  • Uuid
  • Generator
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Generator

Structures de données

class | CombGenerator
class | DefaultTimeGenerator
class | MtRandGenerator
class | OpenSslGenerator
class | PeclUuidRandomGenerator
class | PeclUuidTimeGenerator
class | RandomBytesGenerator
class | RandomGeneratorFactory
interface | RandomGeneratorInterface
class | RandomLibAdapter
class | SodiumRandomGenerator
class | TimeGeneratorFactory
interface | TimeGeneratorInterface

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Provider

  • Ramsey
  • Uuid
  • Provider
Espaces de nommage | Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Provider

Espaces de nommage

Node
Time

Structures de données

interface | NodeProviderInterface
interface | TimeProviderInterface

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Provider\Node

  • Ramsey
  • Uuid
  • Provider
  • Node
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Provider\Node

Structures de données

class | FallbackNodeProvider
class | RandomNodeProvider
class | SystemNodeProvider

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Ramsey\Uuid\Provider\Time

  • Ramsey
  • Uuid
  • Provider
  • Time
Structures de données
Référence de l'espace de nommage Ramsey\Uuid\Provider\Time

Structures de données

class | FixedTimeProvider
class | SystemTimeProvider

Description détaillée

This file is part of the ramsey/uuid library

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.

Copyright
Copyright (c) Ben Ramsey ben@b.nosp@m.enra.nosp@m.msey..nosp@m.com http://opensource.org/licenses/MIT MIT Documentation https://packagist.org/packages/ramsey/uuid Packagist https://github.com/ramsey/uuid GitHub


Joomla CMS: Référence de l'espace de nommage Random

Référence de l'espace de nommage Random

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP Random Number Generator Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage RC2

Référence de l'espace de nommage RC2

Description détaillée

Auteur
Patrick Monnerat pm@da.nosp@m.tasp.nosp@m.here..nosp@m.ch http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of RC2. public


Joomla CMS: Référence de l'espace de nommage RC4

Référence de l'espace de nommage RC4

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of RC4. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage ReCaptcha

Espaces de nommage | Structures de données
Référence de l'espace de nommage ReCaptcha

Espaces de nommage

RequestMethod

Structures de données

class | ReCaptcha
interface | RequestMethod
class | RequestParameters
class | Response

Description détaillée

This is a PHP library that handles calling reCAPTCHA.

BSD 3-Clause License

Copyright
(c) 2019, Google Inc. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Joomla CMS: Référence de l'espace de nommage ReCaptcha\RequestMethod

  • ReCaptcha
  • RequestMethod
Structures de données
Référence de l'espace de nommage ReCaptcha\RequestMethod

Structures de données

class | Curl
class | CurlPost
class | Post
class | Socket
class | SocketPost

Description détaillée

This is a PHP library that handles calling reCAPTCHA.

BSD 3-Clause License

Copyright
(c) 2019, Google Inc. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Joomla CMS: Référence de l'espace de nommage Rijndael

Référence de l'espace de nommage Rijndael

Description détaillée

Pure-PHP implementation of Rijndael.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage RSA

Référence de l'espace de nommage RSA

Description détaillée

PKCS1 Formatted Key Handler

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

PKCS#1 Formatted DSA Key Handler

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Microsoft BLOB Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public OpenSSH Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#1 Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PKCS#8 Formatted RSA-PSS Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public PuTTY Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Raw RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public XML Formatted RSA Key Handler Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2009 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Pure-PHP PKCS#1 compliant implementation of RSA. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Salsa20

Référence de l'espace de nommage Salsa20

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2019 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of Salsa20. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage SFTP

Référence de l'espace de nommage SFTP

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2013 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License SFTP Stream Wrapper Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net 2009 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License http://phpseclib.sourceforge.net Pure-PHP implementations of SFTP. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Sodium

Variables
Référence de l'espace de nommage Sodium

Variables

const | CRYPTO_AEAD_AES256GCM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_KEYBYTES
const | CRYPTO_AEAD_AES256GCM_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NSECBYTES
const | CRYPTO_AEAD_AES256GCM_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NPUBBYTES
const | CRYPTO_AEAD_AES256GCM_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_ABYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_ABYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES
const | CRYPTO_AUTH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_BYTES
const | CRYPTO_AUTH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_KEYBYTES
const | CRYPTO_BOX_SEALBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEALBYTES
const | CRYPTO_BOX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SECRETKEYBYTES
const | CRYPTO_BOX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_PUBLICKEYBYTES
const | CRYPTO_BOX_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_KEYPAIRBYTES
const | CRYPTO_BOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_MACBYTES
const | CRYPTO_BOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_NONCEBYTES
const | CRYPTO_BOX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEEDBYTES
const | CRYPTO_KX_BYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_BYTES
const | CRYPTO_KX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SEEDBYTES
const | CRYPTO_KX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_PUBLICKEYBYTES
const | CRYPTO_KX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SECRETKEYBYTES
const | CRYPTO_GENERICHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES
const | CRYPTO_GENERICHASH_BYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MIN
const | CRYPTO_GENERICHASH_BYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MAX
const | CRYPTO_GENERICHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES
const | CRYPTO_GENERICHASH_KEYBYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MIN
const | CRYPTO_GENERICHASH_KEYBYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MAX
const | CRYPTO_SCALARMULT_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_BYTES
const | CRYPTO_SCALARMULT_SCALARBYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_SCALARBYTES
const | CRYPTO_SHORTHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_BYTES
const | CRYPTO_SHORTHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_KEYBYTES
const | CRYPTO_SECRETBOX_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_KEYBYTES
const | CRYPTO_SECRETBOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_MACBYTES
const | CRYPTO_SECRETBOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_NONCEBYTES
const | CRYPTO_SIGN_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_BYTES
const | CRYPTO_SIGN_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SEEDBYTES
const | CRYPTO_SIGN_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_PUBLICKEYBYTES
const | CRYPTO_SIGN_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SECRETKEYBYTES
const | CRYPTO_SIGN_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_KEYPAIRBYTES
const | CRYPTO_STREAM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_KEYBYTES
const | CRYPTO_STREAM_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_NONCEBYTES

Documentation des variables

◆ CRYPTO_AEAD_AES256GCM_ABYTES

const CRYPTO_AEAD_AES256GCM_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_ABYTES

◆ CRYPTO_AEAD_AES256GCM_KEYBYTES

const CRYPTO_AEAD_AES256GCM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_encrypt(), et ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_keygen().

◆ CRYPTO_AEAD_AES256GCM_NPUBBYTES

const CRYPTO_AEAD_AES256GCM_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NPUBBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_encrypt().

◆ CRYPTO_AEAD_AES256GCM_NSECBYTES

const CRYPTO_AEAD_AES256GCM_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NSECBYTES

◆ CRYPTO_AEAD_CHACHA20POLY1305_ABYTES

const CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_ABYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), et ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt().

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_keygen().

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt(), et ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_encrypt().

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES

◆ CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_encrypt(), et ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_keygen().

◆ CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), et ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_encrypt().

◆ CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES

◆ CRYPTO_AUTH_BYTES

const CRYPTO_AUTH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_BYTES

Référencé par ParagonIE_Sodium_Compat\crypto_auth_verify().

◆ CRYPTO_AUTH_KEYBYTES

const CRYPTO_AUTH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_auth(), ParagonIE_Sodium_Compat\crypto_auth_keygen(), et ParagonIE_Sodium_Compat\crypto_auth_verify().

◆ CRYPTO_BOX_KEYPAIRBYTES

const CRYPTO_BOX_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_KEYPAIRBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_box(), ParagonIE_Sodium_Compat\crypto_box_open(), ParagonIE_Sodium_Compat\crypto_box_publickey(), ParagonIE_Sodium_Compat\crypto_box_seal_open(), et ParagonIE_Sodium_Compat\crypto_box_secretkey().

◆ CRYPTO_BOX_MACBYTES

const CRYPTO_BOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_MACBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_box_open().

◆ CRYPTO_BOX_NONCEBYTES

const CRYPTO_BOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_NONCEBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_box(), et ParagonIE_Sodium_Compat\crypto_box_open().

◆ CRYPTO_BOX_PUBLICKEYBYTES

const CRYPTO_BOX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_PUBLICKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_box_seal(), ParagonIE_Sodium_Compat\crypto_kx(), et ParagonIE_Sodium_Compat\crypto_scalarmult().

◆ CRYPTO_BOX_SEALBYTES

const CRYPTO_BOX_SEALBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEALBYTES

◆ CRYPTO_BOX_SECRETKEYBYTES

const CRYPTO_BOX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SECRETKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_box_publickey_from_secretkey(), ParagonIE_Sodium_Compat\crypto_kx(), ParagonIE_Sodium_Compat\crypto_scalarmult(), et ParagonIE_Sodium_Compat\crypto_scalarmult_base().

◆ CRYPTO_BOX_SEEDBYTES

const CRYPTO_BOX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEEDBYTES

◆ CRYPTO_GENERICHASH_BYTES

const CRYPTO_GENERICHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES

◆ CRYPTO_GENERICHASH_BYTES_MAX

const CRYPTO_GENERICHASH_BYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MAX

◆ CRYPTO_GENERICHASH_BYTES_MIN

const CRYPTO_GENERICHASH_BYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MIN

◆ CRYPTO_GENERICHASH_KEYBYTES

const CRYPTO_GENERICHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_generichash_keygen().

◆ CRYPTO_GENERICHASH_KEYBYTES_MAX

const CRYPTO_GENERICHASH_KEYBYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MAX

Référencé par ParagonIE_Sodium_Compat\crypto_generichash(), ParagonIE_Sodium_Compat\crypto_generichash_init(), et ParagonIE_Sodium_Compat\crypto_generichash_init_salt_personal().

◆ CRYPTO_GENERICHASH_KEYBYTES_MIN

const CRYPTO_GENERICHASH_KEYBYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MIN

Référencé par ParagonIE_Sodium_Compat\crypto_generichash(), et ParagonIE_Sodium_Compat\crypto_generichash_init().

◆ CRYPTO_KX_BYTES

const CRYPTO_KX_BYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_BYTES

◆ CRYPTO_KX_PUBLICKEYBYTES

const CRYPTO_KX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_PUBLICKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_kx_client_session_keys(), ParagonIE_Sodium_Compat\crypto_kx_publickey(), et ParagonIE_Sodium_Compat\crypto_kx_server_session_keys().

◆ CRYPTO_KX_SECRETKEYBYTES

const CRYPTO_KX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SECRETKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_kx_keypair(), ParagonIE_Sodium_Compat\crypto_kx_publickey(), ParagonIE_Sodium_Compat\crypto_kx_secretkey(), et ParagonIE_Sodium_Compat\crypto_kx_seed_keypair().

◆ CRYPTO_KX_SEEDBYTES

const CRYPTO_KX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SEEDBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_kx_seed_keypair().

◆ CRYPTO_SCALARMULT_BYTES

const CRYPTO_SCALARMULT_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_BYTES

◆ CRYPTO_SCALARMULT_SCALARBYTES

const CRYPTO_SCALARMULT_SCALARBYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_SCALARBYTES

◆ CRYPTO_SECRETBOX_KEYBYTES

const CRYPTO_SECRETBOX_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_secretbox(), ParagonIE_Sodium_Compat\crypto_secretbox_keygen(), ParagonIE_Sodium_Compat\crypto_secretbox_open(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305(), et ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305_open().

◆ CRYPTO_SECRETBOX_MACBYTES

const CRYPTO_SECRETBOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_MACBYTES

◆ CRYPTO_SECRETBOX_NONCEBYTES

const CRYPTO_SECRETBOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_NONCEBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_secretbox(), ParagonIE_Sodium_Compat\crypto_secretbox_open(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305(), et ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305_open().

◆ CRYPTO_SHORTHASH_BYTES

const CRYPTO_SHORTHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_BYTES

◆ CRYPTO_SHORTHASH_KEYBYTES

const CRYPTO_SHORTHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_shorthash(), et ParagonIE_Sodium_Compat\crypto_shorthash_keygen().

◆ CRYPTO_SIGN_BYTES

const CRYPTO_SIGN_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_BYTES

Référencé par ParagonIE_Sodium_Compat\crypto_sign_open(), et ParagonIE_Sodium_Compat\crypto_sign_verify_detached().

◆ CRYPTO_SIGN_KEYPAIRBYTES

const CRYPTO_SIGN_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_KEYPAIRBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_sign_publickey(), et ParagonIE_Sodium_Compat\crypto_sign_secretkey().

◆ CRYPTO_SIGN_PUBLICKEYBYTES

const CRYPTO_SIGN_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_PUBLICKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_sign_ed25519_pk_to_curve25519(), ParagonIE_Sodium_Compat\crypto_sign_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_sign_open(), et ParagonIE_Sodium_Compat\crypto_sign_verify_detached().

◆ CRYPTO_SIGN_SECRETKEYBYTES

const CRYPTO_SIGN_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SECRETKEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_sign(), ParagonIE_Sodium_Compat\crypto_sign_detached(), ParagonIE_Sodium_Compat\crypto_sign_keypair_from_secretkey_and_publickey(), et ParagonIE_Sodium_Compat\crypto_sign_publickey_from_secretkey().

◆ CRYPTO_SIGN_SEEDBYTES

const CRYPTO_SIGN_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SEEDBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_sign_ed25519_sk_to_curve25519().

◆ CRYPTO_STREAM_KEYBYTES

const CRYPTO_STREAM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_KEYBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_stream(), ParagonIE_Sodium_Compat\crypto_stream_keygen(), et ParagonIE_Sodium_Compat\crypto_stream_xor().

◆ CRYPTO_STREAM_NONCEBYTES

const CRYPTO_STREAM_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_NONCEBYTES

Référencé par ParagonIE_Sodium_Compat\crypto_stream(), et ParagonIE_Sodium_Compat\crypto_stream_xor().


Joomla CMS: Référence de l'espace de nommage SSH

Référence de l'espace de nommage SSH

Description détaillée

Pure-PHP ssh-agent client identity object

Instantiation should only be performed by class. This could be thought of as implementing an interface that phpseclib3 implements. ie. maybe a Net_SSH_Auth_PublicKey interface or something. The methods in this interface would be getPublicKey and sign since those are the methods phpseclib looks for to perform public key authentication.

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net internal

Pure-PHP ssh-agent client identity factory

requestIdentities() method pumps out objects

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License ReadBytes trait Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage SSH2

Référence de l'espace de nommage SSH2

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of SSHv2. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage StreamCipher

Référence de l'espace de nommage StreamCipher

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Base Class for all stream cipher classes Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage Symfony

Espaces de nommage
Référence de l'espace de nommage Symfony

Espaces de nommage

Component
Contracts
Polyfill


Joomla CMS: Référence de l'espace de nommage Symfony\Component

  • Symfony
  • Component
Espaces de nommage
Référence de l'espace de nommage Symfony\Component

Espaces de nommage

Console
ErrorHandler
Ldap
OptionsResolver
String
VarDumper
WebLink
Yaml


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console

  • Symfony
  • Component
  • Console
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\Console

Espaces de nommage

Attribute
CI
Command
CommandLoader
Completion
DependencyInjection
Descriptor
Event
EventListener
Exception
Formatter
Helper
Input
Logger
Output
Question
SignalRegistry
Style
Tester

Structures de données

class | Application
class | Color
class | ConsoleEvents
class | Cursor
class | SingleCommandApplication
class | Terminal


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Attribute

  • Symfony
  • Component
  • Console
  • Attribute
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Attribute

Structures de données

class AsCommand


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\CI

  • Symfony
  • Component
  • Console
  • CI
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\CI

Structures de données

class GithubActionReporter


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Command

  • Symfony
  • Component
  • Console
  • Command
Structures de données | Fonctions | Variables
Référence de l'espace de nommage Symfony\Component\Console\Command

Structures de données

class | Command
class | CompleteCommand
class | DumpCompletionCommand
class | HelpCommand
class | LazyCommand
class | ListCommand
interface | SignalableCommandInterface

Fonctions

lock (string $name=null, bool $blocking=false)
release ()

Variables

trait LockableTrait

Documentation des fonctions

◆ lock()

Symfony\Component\Console\Command\lock | ( | string | $name = null,
 |  | bool | $blocking = false
 | ) |  |
private

Locks a command.

Références Command\$name, class, Command\getName(), et null.

Référencé par PasswordField\getLayoutData(), Symfony\Component\Console\Command\release(), et PasswordField\setup().

◆ release()

Symfony\Component\Console\Command\release ( )
private

Releases the command lock if there is one.

Références Symfony\Component\Console\Command\lock(), et null.

Référencé par InstallerScript\preflight().

Documentation des variables

◆ LockableTrait

trait LockableTrait
Valeur initiale :
{
private $lock

Basic lock feature for commands.

Auteur
Geoffrey Brier geoff.nosp@m.rey..nosp@m.brier.nosp@m.@gma.nosp@m.il.co.nosp@m.m


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\CommandLoader

  • Symfony
  • Component
  • Console
  • CommandLoader
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\CommandLoader

Structures de données

interface | CommandLoaderInterface
class | ContainerCommandLoader
class | FactoryCommandLoader


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Completion

  • Symfony
  • Component
  • Console
  • Completion
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Completion

Espaces de nommage

Output

Structures de données

class | CompletionInput
class | CompletionSuggestions
class | Suggestion


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Completion\Output

  • Symfony
  • Component
  • Console
  • Completion
  • Output
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Completion\Output

Structures de données

class | BashCompletionOutput
interface | CompletionOutputInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\DependencyInjection

  • Symfony
  • Component
  • Console
  • DependencyInjection
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\DependencyInjection

Structures de données

class AddConsoleCommandPass


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Descriptor

  • Symfony
  • Component
  • Console
  • Descriptor
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Descriptor

Structures de données

class | ApplicationDescription
class | Descriptor
interface | DescriptorInterface
class | JsonDescriptor
class | MarkdownDescriptor
class | TextDescriptor
class | XmlDescriptor


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Event

  • Symfony
  • Component
  • Console
  • Event
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Event

Structures de données

class | ConsoleCommandEvent
class | ConsoleErrorEvent
class | ConsoleEvent
class | ConsoleSignalEvent
class | ConsoleTerminateEvent


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\EventListener

  • Symfony
  • Component
  • Console
  • EventListener
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\EventListener

Structures de données

class ErrorListener


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Exception

  • Symfony
  • Component
  • Console
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Exception

Structures de données

class | CommandNotFoundException
interface | ExceptionInterface
class | InvalidArgumentException
class | InvalidOptionException
class | LogicException
class | MissingInputException
class | NamespaceNotFoundException
class | RuntimeException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Formatter

  • Symfony
  • Component
  • Console
  • Formatter
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Formatter

Structures de données

class | NullOutputFormatter
class | NullOutputFormatterStyle
class | OutputFormatter
interface | OutputFormatterInterface
class | OutputFormatterStyle
interface | OutputFormatterStyleInterface
class | OutputFormatterStyleStack
interface | WrappableOutputFormatterInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Helper

  • Symfony
  • Component
  • Console
  • Helper
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Helper

Structures de données

class | DebugFormatterHelper
class | DescriptorHelper
class | Dumper
class | FormatterHelper
class | Helper
interface | HelperInterface
class | HelperSet
class | InputAwareHelper
class | ProcessHelper
class | ProgressBar
class | ProgressIndicator
class | QuestionHelper
class | SymfonyQuestionHelper
class | Table
class | TableCell
class | TableCellStyle
class | TableRows
class | TableSeparator
class | TableStyle


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Input

  • Symfony
  • Component
  • Console
  • Input
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Input

Structures de données

class | ArgvInput
class | ArrayInput
class | Input
class | InputArgument
interface | InputAwareInterface
class | InputDefinition
interface | InputInterface
class | InputOption
interface | StreamableInputInterface
class | StringInput


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Logger

  • Symfony
  • Component
  • Console
  • Logger
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Logger

Structures de données

class ConsoleLogger


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Output

  • Symfony
  • Component
  • Console
  • Output
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Output

Structures de données

class | BufferedOutput
class | ConsoleOutput
interface | ConsoleOutputInterface
class | ConsoleSectionOutput
class | NullOutput
class | Output
interface | OutputInterface
class | StreamOutput
class | TrimmedBufferOutput


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Question

  • Symfony
  • Component
  • Console
  • Question
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Question

Structures de données

class | ChoiceQuestion
class | ConfirmationQuestion
class | Question


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\SignalRegistry

  • Symfony
  • Component
  • Console
  • SignalRegistry
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\SignalRegistry

Structures de données

class SignalRegistry


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Style

  • Symfony
  • Component
  • Console
  • Style
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Style

Structures de données

class | OutputStyle
interface | StyleInterface
class | SymfonyStyle


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Tester

  • Symfony
  • Component
  • Console
  • Tester
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Symfony\Component\Console\Tester

Espaces de nommage

Constraint

Structures de données

class | ApplicationTester
class | CommandCompletionTester
class | CommandTester

Fonctions

getDisplay (bool $normalize=false)
getErrorOutput (bool $normalize=false)
getInput ()
getOutput ()
getStatusCode ()
assertCommandIsSuccessful (string $message='')
setInputs (array $inputs)
initOutput (array $options)
static createStream (array $inputs)

Variables

trait TesterTrait
$inputs = []
$captureStreamsIndependently = false
$input
$statusCode

Documentation des fonctions

◆ assertCommandIsSuccessful()

Symfony\Component\Console\Tester\assertCommandIsSuccessful ( string $message = '' )

Références $message.

◆ createStream()

static Symfony\Component\Console\Tester\createStream ( array $inputs )
staticprivate
Renvoie
resource

Références Symfony\Component\Console\Tester\$input, Symfony\Component\Console\Tester\$inputs, et Laminas\Diactoros\$stream.

Référencé par CommandTester\execute(), et ApplicationTester\run().

◆ getDisplay()

Symfony\Component\Console\Tester\getDisplay ( bool $normalize = false )

Gets the display returned by the last execution of the command or application.

Exceptions

Références $display, et null.

◆ getErrorOutput()

Symfony\Component\Console\Tester\getErrorOutput ( bool $normalize = false )

Gets the output written to STDERR by the application.

Paramètres
bool $normalize Whether to normalize end of lines to
or not
Renvoie
string

Références $display.

◆ getInput()

Symfony\Component\Console\Tester\getInput ( )
abstract

Gets the input instance used by the last execution of the command or application.

Renvoie
InputInterface

Références Symfony\Component\Console\Tester\$input.

Référencé par CliApplication\__get(), ConsoleApplication\__get(), FormField\__get(), Joomla\Application\checkToken(), ContenttypeField\getInput(), FieldcontextsField\getInput(), WorkflowcontextsField\getInput(), PrivacyField\getInput(), TermsField\getInput(), SectionField\getInput(), JoomlatokenField\getInput(), MenuOrderingField\getInput(), ModulepositionField\getInput(), ConsentBoxField\getInput(), et FormField\renderField().

◆ getOutput()

Symfony\Component\Console\Tester\getOutput ( )

Gets the output instance used by the last execution of the command or application.

Renvoie
OutputInterface

Références $output.

Référencé par CliApplication\out().

◆ getStatusCode()

Symfony\Component\Console\Tester\getStatusCode ( )

Gets the status code returned by the last execution of the command or application.

Exceptions

Références Symfony\Component\Console\Tester\$statusCode, et null.

Référencé par AbstractWebApplication\respond().

◆ initOutput()

Symfony\Component\Console\Tester\initOutput ( array $options )
private

Initializes the output property.

Available options:

  • decorated: Sets the output decorated flag
  • verbosity: Sets the output verbosity flag
  • capture_stderr_separately: Make output of stdOut and stdErr separately available

Références $options, null, et OutputInterface\VERBOSITY_NORMAL.

Référencé par CommandTester\execute(), et ApplicationTester\run().

◆ setInputs()

Symfony\Component\Console\Tester\setInputs ( array $inputs )

Sets the user inputs.

Paramètres
array $inputs An array of strings representing each input passed to the command input stream
Renvoie
$this

Références Symfony\Component\Console\Tester\$inputs, et $this.

Documentation des variables

◆ $captureStreamsIndependently

$captureStreamsIndependently = false
private

◆ $input

$input
private

Référencé par CommandCompletionTester\complete(), Symfony\Component\Console\Tester\createStream(), CommandTester\execute(), Symfony\Component\Console\Tester\getInput(), et ApplicationTester\run().

◆ $inputs

$inputs = []
private

Référencé par Symfony\Component\Console\Tester\createStream(), Cli\serialize(), et Symfony\Component\Console\Tester\setInputs().

◆ $statusCode

$statusCode
private

Référencé par HttplugFactory\createResponse(), SocketTransport\getResponse(), Socket\getResponse(), StreamTransport\getResponse(), CurlTransport\getResponse(), Stream\getResponse(), Curl\getResponse(), Symfony\Component\Console\Tester\getStatusCode(), HtmlErrorRenderer\renderException(), Command\run(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ TesterTrait

trait TesterTrait
Valeur initiale :
{
private $output
$output
if(empty($fields)) $output
Definition: com_fields/layouts/fields/render.php:47
Auteur
Amrouche Hamza hamza.nosp@m..sim.nosp@m.perfi.nosp@m.t@gm.nosp@m.ail.c.nosp@m.om


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Console\Tester\Constraint

  • Symfony
  • Component
  • Console
  • Tester
  • Constraint
Structures de données
Référence de l'espace de nommage Symfony\Component\Console\Tester\Constraint

Structures de données

class CommandIsSuccessful


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler

  • Symfony
  • Component
  • ErrorHandler
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler

Espaces de nommage

Error
ErrorEnhancer
ErrorRenderer
Exception
Internal

Structures de données

class | BufferingLogger
class | Debug
class | DebugClassLoader
class | ErrorHandler
class | ThrowableUtils


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler\Error

  • Symfony
  • Component
  • ErrorHandler
  • Error
Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler\Error

Structures de données

class | ClassNotFoundError
class | FatalError
class | OutOfMemoryError
class | UndefinedFunctionError
class | UndefinedMethodError


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler\ErrorEnhancer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorEnhancer
Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler\ErrorEnhancer

Structures de données

class | ClassNotFoundErrorEnhancer
interface | ErrorEnhancerInterface
class | UndefinedFunctionErrorEnhancer
class | UndefinedMethodErrorEnhancer


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler\ErrorRenderer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorRenderer
Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler\ErrorRenderer

Structures de données

class | CliErrorRenderer
interface | ErrorRendererInterface
class | HtmlErrorRenderer
class | SerializerErrorRenderer


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler\Exception

  • Symfony
  • Component
  • ErrorHandler
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler\Exception

Structures de données

class | FlattenException
class | SilencedErrorContext


Joomla CMS: Référence de l'espace de nommage Symfony\Component\ErrorHandler\Internal

  • Symfony
  • Component
  • ErrorHandler
  • Internal
Structures de données
Référence de l'espace de nommage Symfony\Component\ErrorHandler\Internal

Structures de données

class TentativeTypes


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Ldap

  • Symfony
  • Component
  • Ldap
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\Ldap

Espaces de nommage

Adapter
Exception
Security

Structures de données

class | Entry
class | Ldap
interface | LdapInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Ldap\Adapter

  • Symfony
  • Component
  • Ldap
  • Adapter
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\Ldap\Adapter

Espaces de nommage

ExtLdap

Structures de données

class | AbstractConnection
class | AbstractQuery
interface | AdapterInterface
interface | CollectionInterface
interface | ConnectionInterface
interface | EntryManagerInterface
interface | QueryInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Ldap\Adapter\ExtLdap

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
Structures de données
Référence de l'espace de nommage Symfony\Component\Ldap\Adapter\ExtLdap

Structures de données

class | Adapter
class | Collection
class | Connection
class | ConnectionOptions
class | EntryManager
class | Query
class | UpdateOperation


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Ldap\Exception

  • Symfony
  • Component
  • Ldap
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\Ldap\Exception

Structures de données

class | AlreadyExistsException
class | ConnectionException
class | ConnectionTimeoutException
class | DriverNotFoundException
interface | ExceptionInterface
class | InvalidCredentialsException
class | LdapException
class | NotBoundException
class | UpdateOperationException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Ldap\Security

  • Symfony
  • Component
  • Ldap
  • Security
Structures de données
Référence de l'espace de nommage Symfony\Component\Ldap\Security

Structures de données

class | CheckLdapCredentialsListener
class | LdapAuthenticator
class | LdapBadge
class | LdapUser
class | LdapUserProvider


Joomla CMS: Référence de l'espace de nommage Symfony\Component\OptionsResolver

  • Symfony
  • Component
  • OptionsResolver
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\OptionsResolver

Espaces de nommage

Debug
Exception

Structures de données

class | OptionConfigurator
interface | Options
class | OptionsResolver


Joomla CMS: Référence de l'espace de nommage Symfony\Component\OptionsResolver\Debug

  • Symfony
  • Component
  • OptionsResolver
  • Debug
Structures de données
Référence de l'espace de nommage Symfony\Component\OptionsResolver\Debug

Structures de données

class OptionsResolverIntrospector


Joomla CMS: Référence de l'espace de nommage Symfony\Component\OptionsResolver\Exception

  • Symfony
  • Component
  • OptionsResolver
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\OptionsResolver\Exception

Structures de données

class | AccessException
interface | ExceptionInterface
class | InvalidArgumentException
class | InvalidOptionsException
class | MissingOptionsException
class | NoConfigurationException
class | NoSuchOptionException
class | OptionDefinitionException
class | UndefinedOptionsException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\String

  • Symfony
  • Component
  • String
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\String

Espaces de nommage

Exception
Inflector
Slugger

Structures de données

class | AbstractString
class | AbstractUnicodeString
class | ByteString
class | CodePointString
class | LazyString
class | UnicodeString


Joomla CMS: Référence de l'espace de nommage Symfony\Component\String\Exception

  • Symfony
  • Component
  • String
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\String\Exception

Structures de données

interface | ExceptionInterface
class | InvalidArgumentException
class | RuntimeException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\String\Inflector

  • Symfony
  • Component
  • String
  • Inflector
Structures de données
Référence de l'espace de nommage Symfony\Component\String\Inflector

Structures de données

class | EnglishInflector
class | FrenchInflector
interface | InflectorInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\String\Slugger

  • Symfony
  • Component
  • String
  • Slugger
Structures de données
Référence de l'espace de nommage Symfony\Component\String\Slugger

Structures de données

class | AsciiSlugger
interface | SluggerInterface


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper

  • Symfony
  • Component
  • VarDumper
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper

Espaces de nommage

Caster
Cloner
Command
Dumper
Exception
Server
Test

Structures de données

class VarDumper


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Caster

  • Symfony
  • Component
  • VarDumper
  • Caster
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Caster

Structures de données

class | AmqpCaster
class | ArgsStub
class | Caster
class | ClassStub
class | ConstStub
class | CutArrayStub
class | CutStub
class | DateCaster
class | DoctrineCaster
class | DOMCaster
class | DsCaster
class | DsPairStub
class | EnumStub
class | ExceptionCaster
class | FiberCaster
class | FrameStub
class | GmpCaster
class | ImagineCaster
class | ImgStub
class | IntlCaster
class | LinkStub
class | MemcachedCaster
class | MysqliCaster
class | PdoCaster
class | PgSqlCaster
class | ProxyManagerCaster
class | RdKafkaCaster
class | RedisCaster
class | ReflectionCaster
class | ResourceCaster
class | SplCaster
class | StubCaster
class | SymfonyCaster
class | TraceStub
class | UuidCaster
class | XmlReaderCaster
class | XmlResourceCaster


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Cloner

  • Symfony
  • Component
  • VarDumper
  • Cloner
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Cloner

Structures de données

class | AbstractCloner
interface | ClonerInterface
class | Cursor
class | Data
interface | DumperInterface
class | Stub
class | VarCloner


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Command

  • Symfony
  • Component
  • VarDumper
  • Command
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Command

Espaces de nommage

Descriptor

Structures de données

class ServerDumpCommand


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Command\Descriptor

  • Symfony
  • Component
  • VarDumper
  • Command
  • Descriptor
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Command\Descriptor

Structures de données

class | CliDescriptor
interface | DumpDescriptorInterface
class | HtmlDescriptor


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Dumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
Espaces de nommage | Structures de données | Fonctions
Référence de l'espace de nommage Symfony\Component\VarDumper\Dumper

Espaces de nommage

ContextProvider

Structures de données

class | AbstractDumper
class | CliDumper
class | ContextualizedDumper
interface | DataDumperInterface
class | HtmlDumper
class | ServerDumper

Fonctions

esc (string $str)

Documentation des fonctions

◆ esc()

Symfony\Component\VarDumper\Dumper\esc ( string $str )

Référencé par HtmlDumper\style().


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Dumper\ContextProvider

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextProvider
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Dumper\ContextProvider

Structures de données

class | CliContextProvider
interface | ContextProviderInterface
class | RequestContextProvider
class | SourceContextProvider


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Exception

  • Symfony
  • Component
  • VarDumper
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Exception

Structures de données

class ThrowingCasterException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Server

  • Symfony
  • Component
  • VarDumper
  • Server
Structures de données
Référence de l'espace de nommage Symfony\Component\VarDumper\Server

Structures de données

class | Connection
class | DumpServer


Joomla CMS: Référence de l'espace de nommage Symfony\Component\VarDumper\Test

  • Symfony
  • Component
  • VarDumper
  • Test
Fonctions | Variables
Référence de l'espace de nommage Symfony\Component\VarDumper\Test

Fonctions

trait setUpVarDumper (array $casters, int $flags=null)
tearDownVarDumper ()
assertDumpEquals ($expected, $data, int $filter=0, string $message='')
assertDumpMatchesFormat ($expected, $data, int $filter=0, string $message='')
getDump ($data, $key=null, int $filter=0)
prepareExpectation ($expected, int $filter)

Variables

trait VarDumperTestTrait

Documentation des fonctions

◆ assertDumpEquals()

Symfony\Component\VarDumper\Test\assertDumpEquals | ( |  | $expected,
 |  |  | $data,
 |  | int | $filter = 0,
 |  | string | $message = ''
 | ) |  |

Références $data, $message, Symfony\Component\VarDumper\Test\getDump(), null, et Symfony\Component\VarDumper\Test\prepareExpectation().

◆ assertDumpMatchesFormat()

Symfony\Component\VarDumper\Test\assertDumpMatchesFormat | ( |  | $expected,
 |  |  | $data,
 |  | int | $filter = 0,
 |  | string | $message = ''
 | ) |  |

Références $data, $message, Symfony\Component\VarDumper\Test\getDump(), null, et Symfony\Component\VarDumper\Test\prepareExpectation().

◆ getDump()

Symfony\Component\VarDumper\Test\getDump | ( |  | $data,
 |  |  | $key = null,
 |  | int | $filter = 0
 | ) |  |
protected

Références $data, $key, AbstractDumper\DUMP_COMMA_SEPARATOR, AbstractDumper\DUMP_LIGHT_ARRAY, AbstractDumper\DUMP_STRING_LENGTH, et null.

Référencé par Symfony\Component\VarDumper\Test\assertDumpEquals(), Symfony\Component\VarDumper\Test\assertDumpMatchesFormat(), et Symfony\Component\VarDumper\Test\prepareExpectation().

◆ prepareExpectation()

Symfony\Component\VarDumper\Test\prepareExpectation | ( |  | $expected,
 |  | int | $filter
 | ) |  |
private

Références Symfony\Component\VarDumper\Test\getDump(), et null.

Référencé par Symfony\Component\VarDumper\Test\assertDumpEquals(), et Symfony\Component\VarDumper\Test\assertDumpMatchesFormat().

◆ setUpVarDumper()

trait Symfony\Component\VarDumper\Test\setUpVarDumper | ( | array | $casters,
 |  | int | $flags = null
 | ) |  |
protected

◆ tearDownVarDumper()

Symfony\Component\VarDumper\Test\tearDownVarDumper ( )
protected

Références null.

Documentation des variables

◆ VarDumperTestTrait

trait VarDumperTestTrait
Valeur initiale :
{
private $varDumperConfig = [
'casters' => [],
'flags' => null
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80
Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com


Joomla CMS: Référence de l'espace de nommage Symfony\Component\WebLink

  • Symfony
  • Component
  • WebLink
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\WebLink

Espaces de nommage

EventListener

Structures de données

class | GenericLinkProvider
class | HttpHeaderSerializer
class | Link


Joomla CMS: Référence de l'espace de nommage Symfony\Component\WebLink\EventListener

  • Symfony
  • Component
  • WebLink
  • EventListener
Structures de données
Référence de l'espace de nommage Symfony\Component\WebLink\EventListener

Structures de données

class AddLinkHeaderListener


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Yaml

  • Symfony
  • Component
  • Yaml
Espaces de nommage | Structures de données
Référence de l'espace de nommage Symfony\Component\Yaml

Espaces de nommage

Command
Exception
Tag

Structures de données

class | Dumper
class | Escaper
class | Inline
class | Parser
class | Unescaper
class | Yaml


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Yaml\Command

  • Symfony
  • Component
  • Yaml
  • Command
Structures de données
Référence de l'espace de nommage Symfony\Component\Yaml\Command

Structures de données

class LintCommand


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Yaml\Exception

  • Symfony
  • Component
  • Yaml
  • Exception
Structures de données
Référence de l'espace de nommage Symfony\Component\Yaml\Exception

Structures de données

class | DumpException
interface | ExceptionInterface
class | ParseException
class | RuntimeException


Joomla CMS: Référence de l'espace de nommage Symfony\Component\Yaml\Tag

  • Symfony
  • Component
  • Yaml
  • Tag
Structures de données
Référence de l'espace de nommage Symfony\Component\Yaml\Tag

Structures de données

class TaggedValue


Joomla CMS: Référence de l'espace de nommage Symfony\Contracts

  • Symfony
  • Contracts
Espaces de nommage
Référence de l'espace de nommage Symfony\Contracts

Espaces de nommage

Service


Joomla CMS: Référence de l'espace de nommage Symfony\Contracts\Service

  • Symfony
  • Contracts
  • Service
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Symfony\Contracts\Service

Espaces de nommage

Attribute
Test

Structures de données

interface | ResetInterface
interface | ServiceProviderInterface
interface | ServiceSubscriberInterface

Fonctions

__construct (array $factories)
has (string $id)
get (string $id)
getProvidedServices ()
createNotFoundException (string $id)
createCircularReferenceException (string $id, array $path)
static getSubscribedServices ()
setContainer (ContainerInterface $container)

Variables

trait | ServiceLocatorTrait
$loading = []
$providedTypes
trait | ServiceSubscriberTrait

Documentation des fonctions

◆ __construct()

Symfony\Contracts\Service\__construct ( array $factories )
Paramètres
callable[] $factories

Référencé par FromPunycode\__construct(), Accept\__construct(), AcceptLanguage\__construct(), XPath\__construct(), ObjectDescriptor\__construct(), ParserException\__construct(), AlgorithmIdentifier\__construct(), ToPunycode\__construct(), UploadedFileAlreadyMovedException\__construct(), InvalidStreamPointerPositionException\__construct(), DNSName\__construct(), ClassNotFoundError\__construct(), UndefinedFunctionError\__construct(), UndefinedMethodError\__construct(), NullObject\__construct(), BreakObject\__construct(), FalseObject\__construct(), TrueObject\__construct(), UndefinedObject\__construct(), NestingException\__construct(), TableSeparator\__construct(), SymmetricKey\__construct(), ThrowingCasterException\__construct(), AttributeTypeAndValue\__construct(), FatalError\__construct(), RDNString\__construct(), RelativeDistinguishedName\__construct(), IA5String\__construct(), CutArrayStub\__construct(), ParagonIE_Sodium_Core_ChaCha20_IetfCtx\__construct(), UnknownConstructedObject\__construct(), OtherObject\__construct(), PrivateKey\__construct(), PublicKey\__construct(), PublicKeyCredentialRpEntity\__construct(), ParagonIE_Sodium_Core32_ChaCha20_IetfCtx\__construct(), UnsupportedCipherException\__construct(), ConsoleSignalEvent\__construct(), ArgsStub\__construct(), ExtensionOutputError\__construct(), InvalidKeyTypeException\__construct(), Cookie\__construct(), EmptyResponse\__construct(), PrepareStatementFailureException\__construct(), TrimmedBufferOutput\__construct(), ConnectionFailureException\__construct(), ConsoleTerminateEvent\__construct(), DecimalFractionTag\__construct(), ByteStringWithChunkObject\__construct(), AuthenticatorAttestationResponse\__construct(), TextStringWithChunkObject\__construct(), ConfirmationQuestion\__construct(), ConsoleErrorEvent\__construct(), InvalidParameterException\__construct(), BigFloatTag\__construct(), CertificateExtensions\__construct(), FilesystemException\__construct(), SignedIntegerObject\__construct(), CommandNotFoundException\__construct(), UnsignedIntegerObject\__construct(), ByteStringObject\__construct(), PublicKeyCredentialUserEntity\__construct(), ArrayInput\__construct(), RawDocument\__construct(), TagObject\__construct(), TextStringObject\__construct(), Ucm\__construct(), BitString\__construct(), ParseException\__construct(), FeaturedModel\__construct(), RouteNotFoundException\__construct(), ImageDocument\__construct(), Callback\__construct(), PhpInputStream\__construct(), PublicKeyCredential\__construct(), Category\__construct(), ChoiceQuestion\__construct(), GeneralizedTime\__construct(), InfiniteListObject\__construct(), InfiniteMapObject\__construct(), ConsoleSectionOutput\__construct(), Language\__construct(), ContentType\__construct(), LastvisitdaterangeField\__construct(), MissingComponentException\__construct(), FeaturedTable\__construct(), FetchMediaItemEvent\__construct(), FetchMediaItemsEvent\__construct(), Files\__construct(), StringInput\__construct(), UpdateSite\__construct(), ViewLevel\__construct(), InvalidArgumentException\__construct(), MethodNotAllowedException\__construct(), ClientsModel\__construct(), Usergroup\__construct(), WorkflowFunctionalityUsedEvent\__construct(), WorkflowTransitionEvent\__construct(), OkpKey\__construct(), ExecuteTaskEvent\__construct(), ExecutionFailureException\__construct(), FeatureEvent\__construct(), FetchMediaItemUrlEvent\__construct(), SessionEvent\__construct(), BannersModel\__construct(), BaseInstallationModel\__construct(), UnsupportedArchiveException\__construct(), BeforeBatchEvent\__construct(), Json\__construct(), MenuType\__construct(), MessageTable\__construct(), DisplayEvent\__construct(), RequestsModel\__construct(), SearchesModel\__construct(), FiltersModel\__construct(), StagesModel\__construct(), AfterDeleteEvent\__construct(), StyleTable\__construct(), GetMethod\__construct(), TemplatesModel\__construct(), TransitionsModel\__construct(), AfterStoreEvent\__construct(), ConnectionEvent\__construct(), BeforeCheckinEvent\__construct(), WebAssetRegistryAssetChanged\__construct(), WorkflowsModel\__construct(), JavascriptRenderer\__construct(), BeforeDeleteEvent\__construct(), BeforeDisplayMethods\__construct(), ApplicationEvent\__construct(), MapTable\__construct(), AfterLoadEvent\__construct(), Query\__construct(), AfterReorderEvent\__construct(), Router\__construct(), RsaKey\__construct(), AuthenticatorAssertionResponse\__construct(), TimeableTwigExtensionProfiler\__construct(), BeforeBindEvent\__construct(), ConsentsModel\__construct(), ContactsModel\__construct(), BeforeCheckoutEvent\__construct(), LangActiveAssetItem\__construct(), BeforeLoadEvent\__construct(), ApplicationErrorEvent\__construct(), LinksModel\__construct(), BeforeStoreEvent\__construct(), MessagesModel\__construct(), CertificateSubject\__construct(), SetNewTagsEvent\__construct(), TerminateEvent\__construct(), UnexpectedResponseException\__construct(), LazyAssertionException\__construct(), BeforePublishEvent\__construct(), BeforeReorderEvent\__construct(), MenusModel\__construct(), MonologCollector\__construct(), NotesModel\__construct(), OverridesModel\__construct(), ConsoleOutput\__construct(), PositionsModel\__construct(), RedirectResponse\__construct(), AfterMoveEvent\__construct(), AjaxInitCreate\__construct(), ConsentTable\__construct(), InstallationController\__construct(), InstallerModel\__construct(), StylesModel\__construct(), BeforeMoveEvent\__construct(), MapObject\__construct(), ModulesModel\__construct(), NewsfeedsModel\__construct(), EchoLogger\__construct(), CacheCacheCollector\__construct(), Captive\__construct(), PluginsModel\__construct(), TagsModel\__construct(), GetSetup\__construct(), CompleteCommand\__construct(), TransitionButton\__construct(), JsonDocument\__construct(), ListObject\__construct(), MapsModel\__construct(), MediumModel\__construct(), DiscoverModel\__construct(), Update\__construct(), AssociationsModel\__construct(), SaveSetup\__construct(), StreamOutput\__construct(), TemplateTable\__construct(), TemplatesController\__construct(), ConfigController\__construct(), LevelsModel\__construct(), LinkTable\__construct(), DebuguserModel\__construct(), AbstractImmutableEvent\__construct(), CallbackController\__construct(), Session\__construct(), FieldsModel\__construct(), UpdatesiteTable\__construct(), Validate\__construct(), W3cLogger\__construct(), ItemsModel\__construct(), JsonapiDocument\__construct(), ContactsController\__construct(), DebuggroupModel\__construct(), Module\__construct(), CheckinModel\__construct(), NoteTable\__construct(), ArticlesModel\__construct(), PublicKeyCredentialRequestOptions\__construct(), StreamCipher\__construct(), GetIconEvent\__construct(), ClientTable\__construct(), ComponentController\__construct(), ItemsController\__construct(), LanguageModel\__construct(), ManageController\__construct(), DebugEventDispatcherCommand\__construct(), PlgExtensionNamespacemap\__construct(), ApplicationController\__construct(), ArticlesController\__construct(), XmlResponse\__construct(), EventImmutable\__construct(), CallbackLogger\__construct(), GroupModel\__construct(), StageTable\__construct(), AbstractModuleDispatcher\__construct(), WorkflowTable\__construct(), ApiRouter\__construct(), ModulesController\__construct(), DistantSingleMetadata\__construct(), OnGetApiAttributes\__construct(), TemplateController\__construct(), GroupTable\__construct(), HistoryModel\__construct(), HtmlResponse\__construct(), BeforeCommandExecuteEvent\__construct(), TextResponse\__construct(), LintCommand\__construct(), ManageModel\__construct(), ArgvInput\__construct(), ArticleController\__construct(), Menu\__construct(), ServerDumpCommand\__construct(), CommandErrorEvent\__construct(), UpdatesitesModel\__construct(), ConsoleEvent\__construct(), ActionlogsModel\__construct(), LanguagesModel\__construct(), OnGetApiRelation\__construct(), RedisStorage\__construct(), SelectModel\__construct(), SymfonyStyle\__construct(), TasksModel\__construct(), FieldTable\__construct(), XmlDocument\__construct(), LocalStrategy\__construct(), DayOfWeekField\__construct(), TracksModel\__construct(), MethodsController\__construct(), MemcachedStorage\__construct(), InMemoryLogger\__construct(), BannersController\__construct(), GroupsModel\__construct(), PlgContentVote\__construct(), PlgSystemLogout\__construct(), MediaModel\__construct(), DebugRouterCommand\__construct(), UpdateModel\__construct(), CategoriesModel\__construct(), FileStorage\__construct(), BannerTable\__construct(), Basic\__construct(), CreateSessionTableCommand\__construct(), NotifyActionLog\__construct(), CaptiveController\__construct(), RequestTable\__construct(), UsersController\__construct(), ExportCommand\__construct(), UseractiveField\__construct(), UsersModel\__construct(), UpdatesitesController\__construct(), UriImmutable\__construct(), Content\__construct(), MethodController\__construct(), ActionlogsController\__construct(), CategoryController\__construct(), ContentHistory\__construct(), TransitionTable\__construct(), PlgSystemActionLogs\__construct(), TagTable\__construct(), UCMContent\__construct(), FilterTable\__construct(), ImportCommand\__construct(), CoreContent\__construct(), ProfileModel\__construct(), UserModel\__construct(), HtmlView\__construct(), SyslogLogger\__construct(), ListUserCommand\__construct(), DisplayController\__construct(), ErrorDocument\__construct(), Ec2Key\__construct(), User\__construct(), RegistrationdaterangeField\__construct(), Extension\__construct(), MailDisabledException\__construct(), FormModel\__construct(), InfoCollector\__construct(), TagModel\__construct(), NewsfeedTable\__construct(), LogsdaterangeField\__construct(), DatabaseStrategy\__construct(), WorkflowsController\__construct(), WorkflowController\__construct(), ComponentDispatcher\__construct(), RegistrationModel\__construct(), GroupController\__construct(), ContactTable\__construct(), InstallationApplication\__construct(), PublicKeyCredentialCreationOptions\__construct(), CacheModel\__construct(), FieldController\__construct(), Input\__construct(), SessionMetadataGcCommand\__construct(), PluginModel\__construct(), JsonView\__construct(), IndexModel\__construct(), GMP\__construct(), Asset\__construct(), StageController\__construct(), TransitionController\__construct(), BCMath\__construct(), OpensearchDocument\__construct(), ExtensionDiscoverInstallCommand\__construct(), TagField\__construct(), CliDumper\__construct(), InputFilter\__construct(), SiteMenu\__construct(), OnGetApiFields\__construct(), InstalledModel\__construct(), ProfileCollector\__construct(), PdoDriver\__construct(), ApiApplication\__construct(), ExtensionsListCommand\__construct(), PgsqlDriver\__construct(), AdministratorApplication\__construct(), DatabaseModel\__construct(), AdminController\__construct(), TransitionsController\__construct(), StagesController\__construct(), StyleModel\__construct(), Joomlaupdate\__construct(), JsonResponse\__construct(), SiteApplication\__construct(), DeleteUserCommand\__construct(), Token\__construct(), Versionable\__construct(), TaskTable\__construct(), Joomla\__construct(), PHP\__construct(), MfaTable\__construct(), WebApplication\__construct(), FormattedtextLogger\__construct(), Updater\__construct(), AddUserToGroupCommand\__construct(), RemoveUserFromGroupCommand\__construct(), BaseDatabaseModel\__construct(), QueryCollector\__construct(), Checkfiles\__construct(), CategoryModel\__construct(), JsonApiView\__construct(), ModuleModel\__construct(), FormView\__construct(), FormController\__construct(), FieldModel\__construct(), DatabaseLogger\__construct(), Date\__construct(), Cache\__construct(), Requests\__construct(), ApiController\__construct(), MysqliDriver\__construct(), MysqlDriver\__construct(), ArticleModel\__construct(), ExtensionRemoveCommand\__construct(), UpdateCoreCommand\__construct(), SiteStatus\__construct(), PlgSystemLanguageFilter\__construct(), Webauthn\__construct(), AddUserCommand\__construct(), CliApplication\__construct(), AbstractEvent\__construct(), ListView\__construct(), DaemonApplication\__construct(), ConsoleApplication\__construct(), TaskModel\__construct(), JsonapiView\__construct(), FinderIndexCommand\__construct(), HtmlDocument\__construct(), ListModel\__construct(), Adapter\__construct(), PlgSystemHttpHeaders\__construct(), TripleDES\__construct(), Table\__construct(), CMSApplication\__construct(), Installer\__construct(), Rijndael\__construct(), FeedDocument\__construct(), AbstractWebApplication\__construct(), Application\__construct(), AdminModel\__construct(), EC\__construct(), DSA\__construct(), RC2\__construct(), Blowfish\__construct(), SFTP\__construct(), Twofish\__construct(), RSA\__construct(), DES\__construct(), et PasswordHash\PasswordHash().

◆ createCircularReferenceException()

Symfony\Contracts\Service\createCircularReferenceException | ( | string | $id,
 |  | array | $path
 | ) |  |
private

Références $id, et $path.

Référencé par Symfony\Contracts\Service\get().

◆ createNotFoundException()

Symfony\Contracts\Service\createNotFoundException ( string $id )
private

Références $id, $last, et $message.

Référencé par Symfony\Contracts\Service\get().

◆ get()

Symfony\Contracts\Service\get ( string $id )

{}

Renvoie
mixed

Références $id, $this, Symfony\Contracts\Service\createCircularReferenceException(), et Symfony\Contracts\Service\createNotFoundException().

Référencé par AbstractView\get(), et Session\get().

◆ getProvidedServices()

Symfony\Contracts\Service\getProvidedServices ( )

{}

Références $name, Symfony\Contracts\Service\$providedTypes, $type, et null.

◆ getSubscribedServices()

static Symfony\Contracts\Service\getSubscribedServices ( )
static

{}

Références $method, class, et null.

◆ has()

Symfony\Contracts\Service\has ( string $id )

{}

Renvoie
bool

Références $id.

Référencé par WritableContainerLoader\get(), CollectedClientData\get(), UserGroupsHelper\get(), Session\get(), Factory\getDbo(), Pathway\getInstance(), Router\getInstance(), BaseController\getInstance(), Table\getInstance(), CMSApplication\getPathway(), AbstractRenderer\getRenderer(), SessionGcCommand\getSessionService(), Session\has(), Installer\loadAdapter(), UserGroupsHelper\populateGroupData(), PublicKeyCredentialDescriptorCollection\remove(), et QuestionHelper\writeError().

◆ setContainer()

Symfony\Contracts\Service\setContainer ( ContainerInterface $container )
Renvoie
ContainerInterface|null

Références $container, class, et null.

Documentation des variables

◆ $loading

$loading = []
private

◆ $providedTypes

$providedTypes
private

Référencé par Symfony\Contracts\Service\getProvidedServices().

◆ ServiceLocatorTrait

trait ServiceLocatorTrait
Valeur initiale :
{
private $factories

A trait to help implement ServiceProviderInterface.

Auteur
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Référencé par ServiceLocatorTest\getServiceLocator().

◆ ServiceSubscriberTrait

trait ServiceSubscriberTrait
Valeur initiale :
{
protected $container
$container
$container
Definition: administrator/includes/app.php:38

Implementation of ServiceSubscriberInterface that determines subscribed services from method return types. Service ids are available as "ClassName::methodName".

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m


Joomla CMS: Référence de l'espace de nommage Symfony\Contracts\Service\Attribute

  • Symfony
  • Contracts
  • Service
  • Attribute
Structures de données
Référence de l'espace de nommage Symfony\Contracts\Service\Attribute

Structures de données

class | Required
class | SubscribedService


Joomla CMS: Référence de l'espace de nommage Symfony\Contracts\Service\Test

  • Symfony
  • Contracts
  • Service
  • Test
Structures de données
Référence de l'espace de nommage Symfony\Contracts\Service\Test

Structures de données

class ServiceLocatorTest


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill

  • Symfony
  • Polyfill
Espaces de nommage
Référence de l'espace de nommage Symfony\Polyfill

Espaces de nommage

Ctype
Iconv
Intl
Mbstring
Php72
Php73
Php80


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Ctype

  • Symfony
  • Polyfill
  • Ctype
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Ctype

Structures de données

class Ctype


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Iconv

  • Symfony
  • Polyfill
  • Iconv
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Iconv

Structures de données

class Iconv


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Intl

  • Symfony
  • Polyfill
  • Intl
Espaces de nommage
Référence de l'espace de nommage Symfony\Polyfill\Intl

Espaces de nommage

Grapheme
Normalizer


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Intl\Grapheme

  • Symfony
  • Polyfill
  • Intl
  • Grapheme
Structures de données | Variables
Référence de l'espace de nommage Symfony\Polyfill\Intl\Grapheme

Structures de données

class Grapheme

Variables

const SYMFONY_GRAPHEME_CLUSTER_RX ((float) \PCRE_VERSION < 10 ? (float) \PCRE_VERSION >= 8.32 : (float) \PCRE_VERSION >= 10.39) ? '\X' : Grapheme::GRAPHEME_CLUSTER_RX

Documentation des variables

◆ SYMFONY_GRAPHEME_CLUSTER_RX

const SYMFONY_GRAPHEME_CLUSTER_RX ((float) \PCRE_VERSION < 10 ? (float) \PCRE_VERSION >= 8.32 : (float) \PCRE_VERSION >= 10.39) ? '\X' : Grapheme::GRAPHEME_CLUSTER_RX

Référencé par Grapheme\grapheme_extract(), Grapheme\grapheme_strlen(), et Grapheme\grapheme_substr().


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Intl\Normalizer

  • Symfony
  • Polyfill
  • Intl
  • Normalizer
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Intl\Normalizer

Structures de données

class Normalizer


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Mbstring

  • Symfony
  • Polyfill
  • Mbstring
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Mbstring

Structures de données

class Mbstring


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Php72

  • Symfony
  • Polyfill
  • Php72
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Php72

Structures de données

class Php72


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Php73

  • Symfony
  • Polyfill
  • Php73
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Php73

Structures de données

class Php73


Joomla CMS: Référence de l'espace de nommage Symfony\Polyfill\Php80

  • Symfony
  • Polyfill
  • Php80
Structures de données
Référence de l'espace de nommage Symfony\Polyfill\Php80

Structures de données

class | Php80
class | PhpToken


Joomla CMS: Référence de l'espace de nommage Tobscure

Espaces de nommage
Référence de l'espace de nommage Tobscure

Espaces de nommage

JsonApi


Joomla CMS: Référence de l'espace de nommage Tobscure\JsonApi

  • Tobscure
  • JsonApi
Espaces de nommage | Structures de données | Fonctions | Variables
Référence de l'espace de nommage Tobscure\JsonApi

Espaces de nommage

Exception

Structures de données

class | AbstractSerializer
class | Collection
class | Document
interface | ElementInterface
class | ErrorHandler
class | Parameters
class | Relationship
class | Resource
interface | SerializerInterface
class | Util

Fonctions

getLinks ()
setLinks (array $links)
addLink ($key, $value)
addPaginationLinks ($url, array $queryParams, $offset, $limit, $total=null)
addPaginationLink ($name, $url, array $queryParams, $offset, $limit)
getMeta ()
setMeta (array $meta)
addMeta ($key, $value)

Variables

trait | LinksTrait
trait | MetaTrait

Documentation des fonctions

◆ addLink()

Tobscure\JsonApi\addLink | ( | $key,
 |  | $value
 | ) |

Add a link.

Paramètres
string | $key
string | $value
Renvoie
$this

Références $key, $this, et $value.

Référencé par Tobscure\JsonApi\addPaginationLink(), ContentSerializer\category(), ContactSerializer\category(), NewsfeedSerializer\category(), ContentSerializer\createdBy(), NewsfeedSerializer\createdBy(), ContactSerializer\createdBy(), ContentSerializer\languageAssociations(), ContactSerializer\languageAssociations(), NewsfeedSerializer\languageAssociations(), ContentSerializer\modifiedBy(), NewsfeedSerializer\modifiedBy(), ContactSerializer\modifiedBy(), et ContactSerializer\userId().

◆ addMeta()

Tobscure\JsonApi\addMeta | ( | $key,
 |  | $value
 | ) |

Add meta data.

Paramètres
string | $key
string | $value
Renvoie
$this

Références $key, $this, et $value.

◆ addPaginationLink()

Tobscure\JsonApi\addPaginationLink | ( |  | $name,
 |  |  | $url,
 |  | array | $queryParams,
 |  |  | $offset,
 |  |  | $limit
 | ) |  |
protected

Add a pagination link.

Paramètres
string | $name | The name of the link.
string | $url | The base URL for pagination links.
array | $queryParams | The query params provided in the request.
int | $offset | The offset to link to.
int | $limit | The current limit.
Renvoie
void

Références $limit, $name, Joomla\Database\Query\$offset, $url, et Tobscure\JsonApi\addLink().

Référencé par Tobscure\JsonApi\addPaginationLinks().

◆ addPaginationLinks()

Tobscure\JsonApi\addPaginationLinks | ( |  | $url,
 |  | array | $queryParams,
 |  |  | $offset,
 |  |  | $limit,
 |  |  | $total = null
 | ) |  |

Add pagination links (first, prev, next, and last).

Paramètres
string | $url | The base URL for pagination links.
array | $queryParams | The query params provided in the request.
int | $offset | The current offset.
int | $limit | The current limit.
int | null | $total | The total number of results, or null if unknown.
Renvoie
void

Références $limit, Joomla\Database\Query\$offset, $total, $url, Tobscure\JsonApi\addPaginationLink(), et null.

◆ getLinks()

Tobscure\JsonApi\getLinks ( )

Get the links.

Renvoie
array

◆ getMeta()

Tobscure\JsonApi\getMeta ( )

Get the meta.

Renvoie
array

◆ setLinks()

Tobscure\JsonApi\setLinks ( array $links )

Set the links.

Paramètres
array $links
Renvoie
$this

Références $this.

◆ setMeta()

Tobscure\JsonApi\setMeta ( array $meta )

Set the meta data array.

Paramètres
array $meta
Renvoie
$this

Références $this.

Documentation des variables

◆ LinksTrait

trait LinksTrait
Valeur initiale :
{
protected $links

◆ MetaTrait

trait MetaTrait
Valeur initiale :
{
protected $meta


Joomla CMS: Référence de l'espace de nommage Tobscure\JsonApi\Exception

  • Tobscure
  • JsonApi
  • Exception
Espaces de nommage | Structures de données
Référence de l'espace de nommage Tobscure\JsonApi\Exception

Espaces de nommage

Handler

Structures de données

class InvalidParameterException


Joomla CMS: Référence de l'espace de nommage Tobscure\JsonApi\Exception\Handler

  • Tobscure
  • JsonApi
  • Exception
  • Handler
Structures de données
Référence de l'espace de nommage Tobscure\JsonApi\Exception\Handler

Structures de données

interface | ExceptionHandlerInterface
class | FallbackExceptionHandler
class | InvalidParameterExceptionHandler
class | ResponseBag


Joomla CMS: Référence de l'espace de nommage TripleDES

Référence de l'espace de nommage TripleDES

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of Triple DES. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Twofish

Référence de l'espace de nommage Twofish

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m
Copyright
2007 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP implementation of Twofish. Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net Hans-Juergen Petrich petri.nosp@m.ch@t.nosp@m.ronic.nosp@m.-med.nosp@m.ia.co.nosp@m.m public


Joomla CMS: Référence de l'espace de nommage TYPO3

Espaces de nommage
Référence de l'espace de nommage TYPO3

Espaces de nommage

PharStreamWrapper


Joomla CMS: Référence de l'espace de nommage TYPO3\PharStreamWrapper

  • TYPO3
  • PharStreamWrapper
Espaces de nommage | Structures de données
Référence de l'espace de nommage TYPO3\PharStreamWrapper

Espaces de nommage

Interceptor
Phar
Resolver

Structures de données

interface | Assertable
class | Behavior
interface | Collectable
class | Exception
class | Helper
class | Manager
class | PharStreamWrapper
interface | Resolvable


Joomla CMS: Référence de l'espace de nommage TYPO3\PharStreamWrapper\Interceptor

  • TYPO3
  • PharStreamWrapper
  • Interceptor
Structures de données
Référence de l'espace de nommage TYPO3\PharStreamWrapper\Interceptor

Structures de données

class | ConjunctionInterceptor
class | PharExtensionInterceptor
class | PharMetaDataInterceptor


Joomla CMS: Référence de l'espace de nommage TYPO3\PharStreamWrapper\Phar

  • TYPO3
  • PharStreamWrapper
  • Phar
Structures de données
Référence de l'espace de nommage TYPO3\PharStreamWrapper\Phar

Structures de données

class | Container
class | DeserializationException
class | Manifest
class | Reader
class | ReaderException
class | Stub


Joomla CMS: Référence de l'espace de nommage TYPO3\PharStreamWrapper\Resolver

  • TYPO3
  • PharStreamWrapper
  • Resolver
Structures de données
Référence de l'espace de nommage TYPO3\PharStreamWrapper\Resolver

Structures de données

class | PharInvocation
class | PharInvocationCollection
class | PharInvocationResolver


Joomla CMS: Référence de l'espace de nommage UnableToConnectException

Référence de l'espace de nommage UnableToConnectException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License UnableToConnectException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage UnsupportedAlgorithmException

Référence de l'espace de nommage UnsupportedAlgorithmException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License UnsupportedAlgorithmException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage UnsupportedCurveException

Référence de l'espace de nommage UnsupportedCurveException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License UnsupportedCurveException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage UnsupportedFormatException

Référence de l'espace de nommage UnsupportedFormatException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License UnsupportedFormatException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage UnsupportedOperationException

Référence de l'espace de nommage UnsupportedOperationException

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2015 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License UnsupportedOperationException Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net


Joomla CMS: Référence de l'espace de nommage utf8

Référence de l'espace de nommage utf8

Description détaillée

Define UTF8_CORE as required Wrapper round mb_strlen Assumes you have mb_internal_encoding to UTF-8 already Note: this function does not count bad bytes in the string - these are simply ignored

Paramètres
string UTF-8 string
Renvoie
int number of UTF-8 characters in string

Assumes mbstring internal encoding is set to UTF-8 Wrapper around mb_strpos Find position of first occurrence of a string

Paramètres
string | haystack
string | needle (you should validate this with utf8_is_valid)
integer | offset in characters (from left)
Renvoie
mixed integer position or FALSE on failure

Assumes mbstring internal encoding is set to UTF-8 Wrapper around mb_strrpos Find position of last occurrence of a char in a string

Paramètres
string | haystack
string | needle (you should validate this with utf8_is_valid)
integer | (optional) offset (from left)
Renvoie
mixed integer position or FALSE on failure

Assumes mbstring internal encoding is set to UTF-8 Wrapper around mb_substr Return part of a string given character offset (and optionally length)

Paramètres
string
integer | number of UTF-8 characters offset (from left)
integer | (optional) length in UTF-8 characters from offset
Renvoie
mixed string or FALSE if failure

Assumes mbstring internal encoding is set to UTF-8 Wrapper around mb_strtolower Make a string lowercase Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings

Paramètres
string
Renvoie
mixed either string in lowercase or FALSE is UTF-8 invalid

Assumes mbstring internal encoding is set to UTF-8 Wrapper around mb_strtoupper Make a string uppercase Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings

Paramètres
string
Renvoie
mixed either string in lowercase or FALSE is UTF-8 invalid

Define UTF8_CORE as required Unicode aware replacement for strlen(). Returns the number of characters in the string (not the number of bytes), replacing multibyte characters with a single byte equivalent utf8_decode() converts characters that are not in ISO-8859-1 to '?', which, for the purpose of counting, is alright - It's much faster than iconv_strlen Note: this function does not count bad UTF-8 bytes in the string

  • these are simply ignored
    Auteur
    <chernyshevsky at="" hotmail="" dot="" com>=""> http://www.php.net/manual/en/function.utf8-decode.php string UTF-8 string int number of UTF-8 characters in string UTF-8 aware alternative to strpos Find position of first occurrence of a string Note: This will get alot slower if offset is used Note: requires utf8_strlen amd utf8_substr to be loaded string haystack string needle (you should validate this with utf8_is_valid) integer offset in characters (from left) mixed integer position or FALSE on failure http://www.php.net/strpos utf8_strlen utf8_substr UTF-8 aware alternative to strrpos Find position of last occurrence of a char in a string Note: This will get alot slower if offset is used Note: requires utf8_substr and utf8_strlen to be loaded string haystack string needle (you should validate this with utf8_is_valid) integer (optional) offset (from left) mixed integer position or FALSE on failure http://www.php.net/strrpos utf8_substr utf8_strlen UTF-8 aware alternative to substr Return part of a string given character offset (and optionally length) Note arguments: comparied to substr - if offset or length are not integers, this version will not complain but rather massages them into an integer. Note on returned values: substr documentation states false can be returned in some cases (e.g. offset > string length) mb_substr never returns false, it will return an empty string instead. This adopts the mb_substr approach Note on implementation: PCRE only supports repetitions of less than 65536, in order to accept up to MAXINT values for offset and length, we'll repeat a group of 65535 characters when needed. Note on implementation: calculating the number of characters in the string is a relatively expensive operation, so we only carry it out when necessary. It isn't necessary for +ve offsets and no specified length Chris Smithchris.nosp@m.@jal.nosp@m.akai..nosp@m.co.u.nosp@m.k string integer number of UTF-8 characters offset (from left) integer (optional) length in UTF-8 characters from offset mixed string or FALSE if failure UTF-8 aware alternative to strtolower Make a string lowercase Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings Note: requires utf8_to_unicode and utf8_from_unicode Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g string mixed either string in lowercase or FALSE is UTF-8 invalid http://www.php.net/strtolower utf8_to_unicode utf8_from_unicode http://www.unicode.org/reports/tr21/tr21-5.html http://dev.splitbrain.org/view/darcs/dokuwiki/inc/utf8.php UTF-8 aware alternative to strtoupper Make a string uppercase Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings Note: requires utf8_to_unicode and utf8_from_unicode Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g string mixed either string in lowercase or FALSE is UTF-8 invalid http://www.php.net/strtoupper utf8_to_unicode utf8_from_unicode http://www.unicode.org/reports/tr21/tr21-5.html http://dev.splitbrain.org/view/darcs/dokuwiki/inc/utf8.php UTF-8 aware alternative to str_ireplace Case-insensitive version of str_replace Note: requires utf8_strtolower Note: it's not fast and gets slower if $search / $replace is array Notes: it's based on the assumption that the lower and uppercase versions of a UTF-8 character will have the same length in bytes which is currently true given the hash table to strtolower string string http://www.php.net/str_ireplace utf8_strtolower Replacement for str_pad. $padStr may contain multi-byte characters. Oliver Saunders <oliver (a) osinternetservices.com> string $input int $length string $padStr int $type ( same constants as str_pad ) string http://www.php.net/str_pad utf8_substr UTF-8 aware alternative to str_split Convert a string to an array Note: requires utf8_strlen to be loaded string UTF-8 encoded int number to characters to split string by string characters in string reverses http://www.php.net/str_split utf8_strlen UTF-8 aware alternative to strcasecmp A case insensivite string comparison Note: requires utf8_strtolower string string int http://www.php.net/strcasecmp utf8_strtolower UTF-8 aware alternative to strcspn Find length of initial segment not matching mask Note: requires utf8_strlen and utf8_substr (if start, length are used) string int http://www.php.net/strcspn utf8_strlen UTF-8 aware alternative to stristr Find first occurrence of a string using case insensitive comparison Note: requires utf8_strtolower string string int http://www.php.net/strcasecmp utf8_strtolower UTF-8 aware alternative to strrev Reverse a string string UTF-8 encoded string characters in string reverses http://www.php.net/strrev UTF-8 aware alternative to strspn Find length of initial segment matching mask Note: requires utf8_strlen and utf8_substr (if start, length are used) string int http://www.php.net/strspn UTF-8 aware replacement for ltrim() Note: you only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise ltrim will work normally on a UTF-8 string Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g http://www.php.net/ltrim http://dev.splitbrain.org/view/darcs/dokuwiki/inc/utf8.php string UTF-8 aware replacement for rtrim() Note: you only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise rtrim will work normally on a UTF-8 string Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g http://www.php.net/rtrim http://dev.splitbrain.org/view/darcs/dokuwiki/inc/utf8.php string UTF-8 aware replacement for trim() Note: you only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise trim will work normally on a UTF-8 string Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g http://www.php.net/trim http://dev.splitbrain.org/view/darcs/dokuwiki/inc/utf8.php string UTF-8 aware alternative to ucfirst Make a string's first character uppercase Note: requires utf8_strtoupper string string with first character as upper case (if applicable) http://www.php.net/ucfirst utf8_strtoupper UTF-8 aware alternative to ucwords Uppercase the first character of each word in a string Note: requires utf8_substr_replace and utf8_strtoupper string string with first char of each word uppercase http://www.php.net/ucwords Callback function for preg_replace_callback call in utf8_ucwords You don't need to call this yourself array of matches corresponding to a single word string with first char of the word in uppercase utf8_ucwords utf8_strtoupper This is the dynamic loader for the library. It checks whether you have the mbstring extension available and includes relevant files on that basis, falling back to the native (as in written in PHP) version if mbstring is unavailabe. It's probably easiest to use this, if you don't want to understand the dependencies involved, in conjunction with PHP versions etc. At the same time, you might get better performance by managing loading yourself. The smartest way to do this, bearing in mind performance, is probably to "load on demand" - i.e. just before you use these functions in your code, load the version you need. It makes sure the the following functions are available; utf8_strlen, utf8_strpos, utf8_strrpos, utf8_substr, utf8_strtolower, utf8_strtoupper Other functions in the ./native directory depend on these six functions being available Tools to help with ASCII in UTF-8 Tests whether a string contains only 7bit ASCII bytes. You might use this to conditionally check whether a string needs handling as UTF-8 or not, potentially offering performance benefits by using the native PHP equivalent if it's just ASCII e.g.; if ( utf8_is_ascii($someString) ) { // It's just ASCII - use the native PHP version $someString = strtolower($someString); } else { $someString = utf8_strtolower($someString); } string boolean TRUE if it's all ASCII utf8_is_ascii_ctrl Tests whether a string contains only 7bit ASCII bytes with device control codes omitted. The device control codes can be found on the second table here: http://www.w3schools.com/tags/ref_ascii.asp string boolean TRUE if it's all ASCII without device control codes utf8_is_ascii Strip out all non-7bit ASCII bytes If you need to transmit a string to system which you know can only support 7bit ASCII, you could use this function. string string with non ASCII bytes removed utf8_strip_non_ascii_ctrl Strip out all non 7bit ASCII bytes and ASCII device control codes. For a list of ASCII device control codes see the 2nd table here: http://www.w3schools.com/tags/ref_ascii.asp string boolean TRUE if it's all ASCII Replace accented UTF-8 characters by unaccented ASCII-7 "equivalents". The purpose of this function is to replace characters commonly found in Latin alphabets with something more or less equivalent from the ASCII range. This can be useful for converting a UTF-8 to something ready for a filename, for example. Following the use of this function, you would probably also pass the string through utf8_strip_non_ascii to clean out any other non-ASCII chars Use the optional parameter to just deaccent lower ($case = -1) or upper ($case = 1) letters. Default is to deaccent both cases ($case = 0) For a more complete implementation of transliteration, see the utf8_to_ascii package available from the phputf8 project downloads: http://prdownloads.sourceforge.net/phputf8 string UTF-8 string int (optional) -1 lowercase only, +1 uppercase only, 1 both cases string UTF-8 with accented characters replaced by ASCII chars string accented chars replaced with ascii equivalents Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g Tools for locating / replacing bad bytes in UTF-8 strings The Original Code is Mozilla Communicator client code. The Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by the Initial Developer are Copyright (C) 1998 the Initial Developer. All Rights Reserved. Ported to PHP by Henri Sivonen (http://hsivonen.iki.fi) Slight modifications to fit with phputf8 library by Harry Fuecks (hfuecks gmail com) http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUTF8ToUnicode.cpp http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUnicodeToUTF8.cpp http://hsivonen.iki.fi/php-utf8/ utf8_is_valid Locates the first bad byte in a UTF-8 string returning it's byte index in the string PCRE Pattern to locate bad bytes in a UTF-8 string Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 string mixed integer byte index or FALSE if no bad found Locates all bad bytes in a UTF-8 string and returns a list of their byte index in the string PCRE Pattern to locate bad bytes in a UTF-8 string Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 string mixed array of integers or FALSE if no bad found Strips out any bad bytes from a UTF-8 string and returns the rest PCRE Pattern to locate bad bytes in a UTF-8 string Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 string string Replace bad bytes with an alternative character - ASCII character recommended is replacement char PCRE Pattern to locate bad bytes in a UTF-8 string Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 string to search string to replace bad bytes with (defaults to '?') - use ASCII string Return code from utf8_bad_identify() when a five octet sequence is detected. Note: 5 octets sequences are valid UTF-8 but are not supported by Unicode so do not represent a useful character utf8_bad_identify Return code from utf8_bad_identify() when a six octet sequence is detected. Note: 6 octets sequences are valid UTF-8 but are not supported by Unicode so do not represent a useful character utf8_bad_identify Return code from utf8_bad_identify(). Invalid octet for use as start of multi-byte UTF-8 sequence utf8_bad_identify Return code from utf8_bad_identify(). From Unicode 3.1, non-shortest form is illegal utf8_bad_identify Return code from utf8_bad_identify(). From Unicode 3.2, surrogate characters are illegal utf8_bad_identify Return code from utf8_bad_identify(). Codepoints outside the Unicode range are illegal utf8_bad_identify Return code from utf8_bad_identify(). Incomplete multi-octet sequence Note: this is kind of a "catch-all" utf8_bad_identify Reports on the type of bad byte found in a UTF-8 string. Returns a status code on the first bad byte found Joomla modification - As of PHP 7.4, curly brace access has been deprecated. As a result this function has been modified to use square brace syntax See https://github.com/php/php-src/commit/d574df63dc375f5fc9202ce5afde23f866b6450a for additional references hsivo.nosp@m.nen@.nosp@m.iki.f.nosp@m.i string UTF-8 encoded string mixed integer constant describing problem or FALSE if valid UTF-8 utf8_bad_explain http://hsivonen.iki.fi/php-utf8/ Takes a return code from utf8_bad_identify() are returns a message (in English) explaining what the problem is. int return code from utf8_bad_identify mixed string message or FALSE if return code unknown utf8_bad_identify PCRE Regular expressions for UTF-8. Note this file is not actually used by the rest of the library but these regular expressions can be useful to have available. http://www.w3.org/International/questions/qa-forms-utf-8 PCRE Pattern to check a UTF-8 string is valid Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 PCRE Pattern to match single UTF-8 characters Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 PCRE Pattern to locate bad bytes in a UTF-8 string Comes from W3 FAQ: Multilingual Forms Note: modified to include full ASCII range including control chars http://www.w3.org/International/questions/qa-forms-utf-8 Locate a byte index given a UTF-8 character index Given a string and a character index in the string, in terms of the UTF-8 character position, returns the byte index of that character. Can be useful when you want to PHP's native string functions but we warned, locating the byte can be expensive Takes variable number of parameters - first must be the search string then 1 to n UTF-8 character positions to obtain byte indexes for - it is more efficient to search the string for multiple characters at once, than make repeated calls to this function Chris Smithchris.nosp@m.@jal.nosp@m.akai..nosp@m.co.u.nosp@m.k string string to locate index in int (n times) mixed - int if only one input int, array if more boolean TRUE if it's all ASCII Given a string and any byte index, returns the byte index of the start of the current UTF-8 character, relative to supplied position. If the current character begins at the same place as the supplied byte index, that byte index will be returned. Otherwise this function will step backwards, looking for the index where current UTF-8 character begins Chris Smithchris.nosp@m.@jal.nosp@m.akai..nosp@m.co.u.nosp@m.k string int byte index in the string int byte index of start of next UTF-8 character Given a string and any byte index, returns the byte index of the start of the next UTF-8 character, relative to supplied position. If the next character begins at the same place as the supplied byte index, that byte index will be returned. Chris Smithchris.nosp@m.@jal.nosp@m.akai..nosp@m.co.u.nosp@m.k string int byte index in the string int byte index of start of next UTF-8 character Utilities for processing "special" characters in UTF-8. "Special" largely means anything which would be regarded as a non-word character, like ASCII control characters and punctuation. This has a "Roman" bias - it would be unaware of modern Chinese "punctuation" characters for example. Note: requires utils/unicode.php to be loaded utf8_is_valid Used internally. Builds a PCRE pattern from the $UTF8_SPECIAL_CHARS array defined in this file The $UTF8_SPECIAL_CHARS should contain all special characters (non-letter/non-digit) defined in the various local charsets - it's not a complete list of non-alphanum characters in UTF-8. It's not perfect but should match most cases of special chars. This function adds the control chars 0x00 to 0x19 to the array of special chars (they are not included in $UTF8_SPECIAL_CHARS) string utf8_from_unicode utf8_is_word_chars utf8_strip_specials Checks a string for whether it contains only word characters. This is logically equivalent to the PCRE meta character. Note that this is not a 100% guarantee that the string only contains alpha / numeric characters but just that common non-alphanumeric are not in the string, including ASCII device control characters. string to check boolean TRUE if the string only contains word characters utf8_specials_pattern Removes special characters (nonalphanumeric) from a UTF-8 string This can be useful as a helper for sanitizing a string for use as something like a file name or a unique identifier. Be warned though it does not handle all possible non-alphanumeric characters and is not intended is some kind of security / injection filter. Andreas Gohr andi@.nosp@m.spli.nosp@m.tbrai.nosp@m.n.or.nosp@m.g string $string The UTF8 string to strip of special chars string (optional) $repl Replace special with this string string with common non-alphanumeric characters removed utf8_specials_pattern Tools for conversion between UTF-8 and unicode The Original Code is Mozilla Communicator client code. The Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by the Initial Developer are Copyright (C) 1998 the Initial Developer. All Rights Reserved. Ported to PHP by Henri Sivonen (http://hsivonen.iki.fi) Slight modifications to fit with phputf8 library by Harry Fuecks (hfuecks gmail com) http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUTF8ToUnicode.cpp http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUnicodeToUTF8.cpp http://hsivonen.iki.fi/php-utf8/ Takes an UTF-8 string and returns an array of ints representing the Unicode characters. Astral planes are supported ie. the ints in the output can be > 0xFFFF. Occurrances of the BOM are ignored. Surrogates are not allowed. Returns false if the input string isn't a valid UTF-8 octet sequence and raises a PHP error at level E_USER_WARNING Note: this function has been modified slightly in this library to trigger errors on encountering bad bytes Joomla modification - As of PHP 7.4, curly brace access has been deprecated. As a result this function has been modified to use square brace syntax See https://github.com/php/php-src/commit/d574df63dc375f5fc9202ce5afde23f866b6450a for additional references hsivo.nosp@m.nen@.nosp@m.iki.f.nosp@m.i string UTF-8 encoded string mixed array of unicode code points or FALSE if UTF-8 invalid utf8_from_unicode http://hsivonen.iki.fi/php-utf8/ Takes an array of ints representing the Unicode characters and returns a UTF-8 string. Astral planes are supported ie. the ints in the input can be > 0xFFFF. Occurrances of the BOM are ignored. Surrogates are not allowed. Returns false if the input array contains ints that represent surrogates or are outside the Unicode range and raises a PHP error at level E_USER_WARNING Note: this function has been modified slightly in this library to use output buffering to concatenate the UTF-8 string (faster) as well as reference the array by it's keys array of unicode code points representing a string mixed UTF-8 string or FALSE if array contains invalid code points hsivo.nosp@m.nen@.nosp@m.iki.f.nosp@m.i utf8_to_unicode http://hsivonen.iki.fi/php-utf8/ Tools for validing a UTF-8 string is well formed. The Original Code is Mozilla Communicator client code. The Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by the Initial Developer are Copyright (C) 1998 the Initial Developer. All Rights Reserved. Ported to PHP by Henri Sivonen (http://hsivonen.iki.fi) Slight modifications to fit with phputf8 library by Harry Fuecks (hfuecks gmail com) http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUTF8ToUnicode.cpp http://lxr.mozilla.org/seamonkey/source/intl/uconv/src/nsUnicodeToUTF8.cpp http://hsivonen.iki.fi/php-utf8/ Tests a string as to whether it's valid UTF-8 and supported by the Unicode standard Note: this function has been modified to simple return true or false hsivo.nosp@m.nen@.nosp@m.iki.f.nosp@m.i string UTF-8 encoded string boolean true if valid http://hsivonen.iki.fi/php-utf8/ utf8_compliant Tests whether a string complies as UTF-8. This will be much faster than utf8_is_valid but will pass five and six octet UTF-8 sequences, which are not supported by Unicode and so cannot be displayed correctly in a browser. In other words it is not as strict as utf8_is_valid but it's faster. If you use is to validate user input, you place yourself at the risk that attackers will be able to inject 5 and 6 byte sequences (which may or may not be a significant risk, depending on what you are are doing) utf8_is_valid http://www.php.net/manual/en/reference.pcre.pattern.modifiers.php#54805 string UTF-8 string to check boolean TRUE if string is valid UTF-8


Joomla CMS: Référence de l'espace de nommage voku

Espaces de nommage
Référence de l'espace de nommage voku

Espaces de nommage

helper


Joomla CMS: Référence de l'espace de nommage voku\helper

  • voku
  • helper
Structures de données
Référence de l'espace de nommage voku\helper

Structures de données

class | ASCII
class | Bootup


Joomla CMS: Référence de l'espace de nommage Wamania

Espaces de nommage
Référence de l'espace de nommage Wamania

Espaces de nommage

Snowball


Joomla CMS: Référence de l'espace de nommage Wamania\Snowball

  • Wamania
  • Snowball
Espaces de nommage | Structures de données
Référence de l'espace de nommage Wamania\Snowball

Espaces de nommage

Stemmer

Structures de données

class | NotFoundException
class | StemmerFactory
class | StemmerManager


Joomla CMS: Référence de l'espace de nommage Wamania\Snowball\Stemmer

  • Wamania
  • Snowball
  • Stemmer
Structures de données
Référence de l'espace de nommage Wamania\Snowball\Stemmer

Structures de données

class | Catalan
class | Danish
class | Dutch
class | English
class | Finnish
class | French
class | German
class | Italian
class | Norwegian
class | Portuguese
class | Romanian
class | Russian
class | Spanish
class | Stem
interface | Stemmer
class | Swedish

Description détaillée

Finnish Snowball Stemmer.

Auteur
msaari mikko.nosp@m.@mik.nosp@m.kosaa.nosp@m.ri.f.nosp@m.i


Joomla CMS: Référence de l'espace de nommage Webauthn

Espaces de nommage | Structures de données
Référence de l'espace de nommage Webauthn

Espaces de nommage

AttestationStatement
AuthenticationExtensions
MetadataService
TokenBinding
TrustPath
Util

Structures de données

class | AttestedCredentialData
class | AuthenticatorAssertionResponse
class | AuthenticatorAssertionResponseValidator
class | AuthenticatorAttestationResponse
class | AuthenticatorAttestationResponseValidator
class | AuthenticatorData
class | AuthenticatorResponse
class | AuthenticatorSelectionCriteria
class | CertificateToolbox
class | CollectedClientData
class | Credential
class | PublicKeyCredential
class | PublicKeyCredentialCreationOptions
class | PublicKeyCredentialDescriptor
class | PublicKeyCredentialDescriptorCollection
class | PublicKeyCredentialEntity
class | PublicKeyCredentialLoader
class | PublicKeyCredentialOptions
class | PublicKeyCredentialParameters
class | PublicKeyCredentialRequestOptions
class | PublicKeyCredentialRpEntity
class | PublicKeyCredentialSource
interface | PublicKeyCredentialSourceRepository
class | PublicKeyCredentialUserEntity
class | Server
class | StringStream


Joomla CMS: Référence de l'espace de nommage Webauthn\AttestationStatement

  • Webauthn
  • AttestationStatement
Structures de données
Référence de l'espace de nommage Webauthn\AttestationStatement

Structures de données

class | AndroidKeyAttestationStatementSupport
class | AndroidSafetyNetAttestationStatementSupport
class | AttestationObject
class | AttestationObjectLoader
class | AttestationStatement
interface | AttestationStatementSupport
class | AttestationStatementSupportManager
class | FidoU2FAttestationStatementSupport
class | NoneAttestationStatementSupport
class | PackedAttestationStatementSupport
class | TPMAttestationStatementSupport


Joomla CMS: Référence de l'espace de nommage Webauthn\AuthenticationExtensions

  • Webauthn
  • AuthenticationExtensions
Structures de données
Référence de l'espace de nommage Webauthn\AuthenticationExtensions

Structures de données

class | AuthenticationExtension
class | AuthenticationExtensionsClientInputs
class | AuthenticationExtensionsClientOutputs
class | AuthenticationExtensionsClientOutputsLoader
interface | ExtensionOutputChecker
class | ExtensionOutputCheckerHandler
class | ExtensionOutputError


Joomla CMS: Référence de l'espace de nommage Webauthn\MetadataService

  • Webauthn
  • MetadataService
Structures de données
Référence de l'espace de nommage Webauthn\MetadataService

Structures de données

class | AuthenticatorStatus
class | BiometricAccuracyDescriptor
class | BiometricStatusReport
class | CodeAccuracyDescriptor
class | DisplayPNGCharacteristicsDescriptor
class | DistantSingleMetadata
class | DistantSingleMetadataFactory
class | EcdaaTrustAnchor
class | ExtensionDescriptor
class | MetadataService
class | MetadataServiceFactory
class | MetadataStatement
class | MetadataStatementFetcher
interface | MetadataStatementRepository
class | MetadataTOCPayload
class | MetadataTOCPayloadEntry
class | PatternAccuracyDescriptor
class | RgbPaletteEntry
class | RogueListEntry
class | SimpleMetadataStatementRepository
class | SingleMetadata
class | StatusReport
class | VerificationMethodANDCombinations
class | VerificationMethodDescriptor
class | Version


Joomla CMS: Référence de l'espace de nommage Webauthn\TokenBinding

  • Webauthn
  • TokenBinding
Structures de données
Référence de l'espace de nommage Webauthn\TokenBinding

Structures de données

class | IgnoreTokenBindingHandler
class | TokenBinding
interface | TokenBindingHandler
class | TokenBindingNotSupportedHandler


Joomla CMS: Référence de l'espace de nommage Webauthn\TrustPath

  • Webauthn
  • TrustPath
Structures de données
Référence de l'espace de nommage Webauthn\TrustPath

Structures de données

class | CertificateTrustPath
class | EcdaaKeyIdTrustPath
class | EmptyTrustPath
interface | TrustPath
class | TrustPathLoader


Joomla CMS: Référence de l'espace de nommage Webauthn\Util

  • Webauthn
  • Util
Structures de données
Référence de l'espace de nommage Webauthn\Util

Structures de données

class CoseSignatureFixer


Joomla CMS: Référence de l'espace de nommage Webmozart

Espaces de nommage
Référence de l'espace de nommage Webmozart

Espaces de nommage

Assert


Joomla CMS: Référence de l'espace de nommage Webmozart\Assert

  • Webmozart
  • Assert
Structures de données
Référence de l'espace de nommage Webmozart\Assert

Structures de données

class | Assert
class | InvalidArgumentException

Description détaillée

provides type inference and auto-completion for magic static methods of Assert.


Joomla CMS: Référence de l'espace de nommage X509

Référence de l'espace de nommage X509

Description détaillée

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net
Copyright
2012 Jim Wigginton http://www.opensource.org/licenses/mit-license.html MIT License Pure-PHP X.509 Parser Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public


Joomla CMS: Référence de l'espace de nommage Zend

Espaces de nommage
Référence de l'espace de nommage Zend

Espaces de nommage

Diactoros


Joomla CMS: Référence de l'espace de nommage Zend\Diactoros

  • Zend
  • Diactoros
Fonctions
Référence de l'espace de nommage Zend\Diactoros

Fonctions

createUploadedFile (array $spec)
marshalHeadersFromSapi (array $server)
marshalMethodFromSapi (array $server)
marshalProtocolVersionFromSapi (array $server)
marshalUriFromSapi (array $server, array $headers)
normalizeServer (array $server, callable $apacheRequestHeaderCallback=null)
normalizeUploadedFiles (array $files)
parseCookieHeader ($cookieHeader)

Documentation des fonctions

◆ createUploadedFile()

Zend\Diactoros\createUploadedFile ( array $spec )
Obsolète:
Use Laminas instead

◆ marshalHeadersFromSapi()

Zend\Diactoros\marshalHeadersFromSapi ( array $server )
Obsolète:
Use Laminas instead

◆ marshalMethodFromSapi()

Zend\Diactoros\marshalMethodFromSapi ( array $server )
Obsolète:
Use Laminas instead

◆ marshalProtocolVersionFromSapi()

Zend\Diactoros\marshalProtocolVersionFromSapi ( array $server )
Obsolète:
Use Laminas instead

◆ marshalUriFromSapi()

Zend\Diactoros\marshalUriFromSapi | ( | array | $server,
 |  | array | $headers
 | ) |  |
Obsolète:
Use Laminas instead

◆ normalizeServer()

Zend\Diactoros\normalizeServer | ( | array | $server,
 |  | callable | $apacheRequestHeaderCallback = null
 | ) |  |
Obsolète:
Use Laminas instead

◆ normalizeUploadedFiles()

Zend\Diactoros\normalizeUploadedFiles ( array $files )
Obsolète:
Use Laminas instead

◆ parseCookieHeader()

Zend\Diactoros\parseCookieHeader ( $cookieHeader )
Obsolète:
Use Laminas instead


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- $ -

  • $_children : Joomla\CMS\Tree
  • $_leftSibling : Joomla\CMS\Tree
  • $_rightSibling : Joomla\CMS\Tree
  • $attributes : Fig\Link
  • $captureStreamsIndependently : Symfony\Component\Console\Tester
  • $childOIDsLoaded : phpseclib3\Crypt\EC\Formats\Keys
  • $defaultAdapterName : Joomla\Component\Media\Administrator\Provider
  • $forShare : Joomla\Database\Query
  • $headerNames : Laminas\Diactoros , Nyholm\Psr7
  • $href : Fig\Link
  • $injectedCSSandJS : Joomla\Plugin\System\Webauthn\PluginTraits
  • $input : Symfony\Component\Console\Tester
  • $inputs : Symfony\Component\Console\Tester
  • $limit : Joomla\Database\Query
  • $loading : Symfony\Contracts\Service
  • $method : Laminas\Diactoros
  • $noWait : Joomla\Database\Query
  • $offset : Joomla\Database\Query
  • $protocol : Laminas\Diactoros , Nyholm\Psr7
  • $providedTypes : Symfony\Contracts\Service
  • $rel : Fig\Link
  • $requestTarget : Laminas\Diactoros , Nyholm\Psr7
  • $resultAcceptableClasses : Joomla\CMS\Event\Result
  • $resultIsFalseable : Joomla\CMS\Event\Result
  • $returning : Joomla\Database\Query
  • $section : Joomla\CMS\MVC\Model
  • $state : Joomla\CMS\MVC\Model
  • $statusCode : Symfony\Component\Console\Tester
  • $stream : Laminas\Diactoros , Nyholm\Psr7
  • $uri : Laminas\Diactoros , Nyholm\Psr7
  • $useNamedCurves : phpseclib3\Crypt\EC\Formats\Keys
  • $userFactory : Joomla\CMS\Application
  • $workflow : Joomla\CMS\MVC\Model
  • $workflowEnabled : Joomla\CMS\MVC\Model


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- _ -

  • __construct() : Symfony\Contracts\Service
  • __toString() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- a -

  • addChild() : Joomla\CMS\Tree
  • AdditionalLoginButtons : Joomla\Plugin\System\Webauthn\PluginTraits
  • addLink() : Tobscure\JsonApi
  • addMeta() : Tobscure\JsonApi
  • addPaginationLink() : Tobscure\JsonApi
  • addPaginationLinks() : Tobscure\JsonApi
  • addResult() : Joomla\CMS\Event\Result
  • addTransitionField() : Joomla\CMS\MVC\Model
  • advertiseRoutines() : Joomla\Component\Scheduler\Administrator\Traits
  • assertCommandIsSuccessful() : Symfony\Component\Console\Tester
  • assertDumpEquals() : Symfony\Component\VarDumper\Test
  • assertDumpMatchesFormat() : Symfony\Component\VarDumper\Test
  • assertHeader() : Laminas\Diactoros
  • AssociationServiceTrait : Joomla\CMS\Association


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- b -

  • batchWorkflowStage() : Joomla\CMS\MVC\Model


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- c -

  • CacheControllerFactoryAwareTrait : Joomla\CMS\Cache
  • canEditUser() : Joomla\Plugin\System\Webauthn\PluginTraits
  • castAs() : Joomla\Database\Query
  • CategoryServiceTrait : Joomla\CMS\Categories
  • checkToken() : Joomla\Application
  • clear() : Joomla\Database\Query
  • clearTagsHelper() : Joomla\CMS\Tag
  • Common : phpseclib3\Crypt\EC\Formats\Keys
  • concatenate() : Joomla\Database\Query
  • ContainerAwareTrait : Joomla\DI
  • CoreEventAware : Joomla\CMS\Event
  • countItems() : Joomla\CMS\Categories
  • createCircularReferenceException() : Symfony\Contracts\Service
  • createNotFoundException() : Symfony\Contracts\Service
  • createRouter() : Joomla\CMS\Component\Router
  • createStream() : Symfony\Component\Console\Tester
  • createUploadedFile() : Laminas\Diactoros , Zend\Diactoros
  • createUri() : Laminas\Diactoros
  • CRYPTO_AEAD_AES256GCM_ABYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_KEYBYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_NPUBBYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_NSECBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : Sodium
  • CRYPTO_AUTH_BYTES : Sodium
  • CRYPTO_AUTH_KEYBYTES : Sodium
  • CRYPTO_BOX_KEYPAIRBYTES : Sodium
  • CRYPTO_BOX_MACBYTES : Sodium
  • CRYPTO_BOX_NONCEBYTES : Sodium
  • CRYPTO_BOX_PUBLICKEYBYTES : Sodium
  • CRYPTO_BOX_SEALBYTES : Sodium
  • CRYPTO_BOX_SECRETKEYBYTES : Sodium
  • CRYPTO_BOX_SEEDBYTES : Sodium
  • CRYPTO_GENERICHASH_BYTES : Sodium
  • CRYPTO_GENERICHASH_BYTES_MAX : Sodium
  • CRYPTO_GENERICHASH_BYTES_MIN : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES_MAX : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES_MIN : Sodium
  • CRYPTO_KX_BYTES : Sodium
  • CRYPTO_KX_PUBLICKEYBYTES : Sodium
  • CRYPTO_KX_SECRETKEYBYTES : Sodium
  • CRYPTO_KX_SEEDBYTES : Sodium
  • CRYPTO_SCALARMULT_BYTES : Sodium
  • CRYPTO_SCALARMULT_SCALARBYTES : Sodium
  • CRYPTO_SECRETBOX_KEYBYTES : Sodium
  • CRYPTO_SECRETBOX_MACBYTES : Sodium
  • CRYPTO_SECRETBOX_NONCEBYTES : Sodium
  • CRYPTO_SHORTHASH_BYTES : Sodium
  • CRYPTO_SHORTHASH_KEYBYTES : Sodium
  • CRYPTO_SIGN_BYTES : Sodium
  • CRYPTO_SIGN_KEYPAIRBYTES : Sodium
  • CRYPTO_SIGN_PUBLICKEYBYTES : Sodium
  • CRYPTO_SIGN_SECRETKEYBYTES : Sodium
  • CRYPTO_SIGN_SEEDBYTES : Sodium
  • CRYPTO_STREAM_KEYBYTES : Sodium
  • CRYPTO_STREAM_NONCEBYTES : Sodium
  • currentTimestamp() : Joomla\Database\Query
  • CurrentUserTrait : Joomla\CMS\User


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- d -

  • DatabaseAwareTrait : Joomla\CMS\MVC\Model , Joomla\Database
  • dateAdd() : Joomla\Database\Query
  • day() : Joomla\Database\Query
  • DispatcherAwareTrait : Joomla\Event
  • DisplayTrait : Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- e -

  • enableWorkflowBatch() : Joomla\CMS\MVC\Model
  • encodeParameters() : phpseclib3\Crypt\EC\Formats\Keys
  • endRoutine() : Joomla\Component\Scheduler\Administrator\Traits
  • esc() : Symfony\Component\VarDumper\Dumper
  • EventAware : Joomla\CMS\Application
  • EvolvableLinkProviderTrait : Fig\Link
  • EvolvableLinkTrait : Fig\Link
  • executeTransition() : Joomla\CMS\MVC\Model
  • ExtensionManagerTrait : Joomla\CMS\Extension
  • extractPoint() : phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- f -

  • filterHeaderValue() : Laminas\Diactoros
  • findInSet() : Joomla\Database\Query
  • FormBehaviorTrait : Joomla\CMS\MVC\Model
  • FormFactoryAwareTrait : Joomla\CMS\Form
  • forShare() : Joomla\Database\Query
  • forUpdate() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- g -

  • get() : Symfony\Contracts\Service
  • getAdapter() : Joomla\Component\Media\Administrator\Provider
  • getAssociationsExtension() : Joomla\CMS\Association
  • getAttributes() : Fig\Link
  • getBody() : Laminas\Diactoros , Nyholm\Psr7
  • getCacheControllerFactory() : Joomla\CMS\Cache
  • getCategory() : Joomla\CMS\Categories
  • getChildren() : Joomla\CMS\Tree
  • getConditions() : Joomla\CMS\Workflow
  • getContainer() : Joomla\DI
  • getCurrentUser() : Joomla\CMS\User
  • getDatabase() : Joomla\Database
  • getDbo() : Joomla\CMS\MVC\Model
  • getDefaultAdapterName() : Joomla\Component\Media\Administrator\Provider
  • getDispatcher() : Joomla\CMS\Application , Joomla\Event
  • getDisplay() : Symfony\Component\Console\Tester
  • getDump() : Symfony\Component\VarDumper\Test
  • getErrorOutput() : Symfony\Component\Console\Tester
  • getEventClassByEventName() : Joomla\CMS\Event
  • getFormFactory() : Joomla\CMS\Form , Joomla\CMS\MVC\Model
  • getFormToken() : Joomla\Application
  • getHeader() : Laminas\Diactoros , Nyholm\Psr7
  • getHeaderLine() : Laminas\Diactoros , Nyholm\Psr7
  • getHeaders() : Laminas\Diactoros , Nyholm\Psr7
  • getHelperFactory() : Joomla\CMS\Helper
  • getHostFromUri() : Laminas\Diactoros
  • getHref() : Fig\Link
  • getIdentity() : Joomla\CMS\Application
  • getInput() : Joomla\Application , Symfony\Component\Console\Tester
  • getLinks() : Fig\Link , Tobscure\JsonApi
  • getLinksByRel() : Fig\Link
  • getLogger() : Joomla\CMS\Application
  • getMeta() : Tobscure\JsonApi
  • getMethod() : Laminas\Diactoros , Nyholm\Psr7
  • getModelName() : Joomla\CMS\Workflow
  • getMVCFactory() : Joomla\CMS\MVC\Factory
  • getOutput() : Symfony\Component\Console\Tester
  • getParent() : Joomla\CMS\Tree
  • getProtocolVersion() : Laminas\Diactoros , Nyholm\Psr7
  • getProvidedServices() : Symfony\Contracts\Service
  • getProvider() : Joomla\Component\Media\Administrator\Provider
  • getProviderManager() : Joomla\Component\Media\Administrator\Provider
  • getRegistry() : Joomla\CMS\HTML
  • getRels() : Fig\Link
  • getRequestTarget() : Laminas\Diactoros , Nyholm\Psr7
  • getRoot() : Joomla\CMS\Tree
  • getRoutineId() : Joomla\Component\Scheduler\Administrator\Traits
  • getSession() : Joomla\Application
  • getSibling() : Joomla\CMS\Tree
  • getSiteRouter() : Joomla\CMS\Router
  • getStageForNewItem() : Joomla\CMS\MVC\Model
  • getState() : Joomla\CMS\MVC\Model
  • getStateColumnForSection() : Joomla\CMS\Categories
  • getStatusCode() : Symfony\Component\Console\Tester
  • getStream() : Laminas\Diactoros
  • getSubscribedServices() : Symfony\Contracts\Service
  • getTableNameForSection() : Joomla\CMS\Categories
  • getTagsHelper() : Joomla\CMS\Tag
  • getUri() : Laminas\Diactoros , Nyholm\Psr7
  • getUserFromData() : Joomla\Plugin\System\Webauthn\PluginTraits
  • groupConcat() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- h -

  • has() : Symfony\Contracts\Service
  • hasChildren() : Joomla\CMS\Tree
  • hasHeader() : Laminas\Diactoros , Nyholm\Psr7
  • hasParent() : Joomla\CMS\Tree
  • HelperFactoryAwareTrait : Joomla\CMS\Helper
  • hour() : Joomla\Database\Query
  • HTMLRegistryAwareTrait : Joomla\CMS\HTML


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- i -

  • IdentityAware : Joomla\CMS\Application
  • ImmutableNodeTrait : Joomla\CMS\Tree
  • importWorkflowPlugins() : Joomla\CMS\MVC\Model
  • includeFile() : Composer\Autoload
  • includeRelativeFiles() : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • initialize() : Laminas\Diactoros
  • initialize_static_variables() : phpseclib3\Crypt\EC\Formats\Keys
  • initOutput() : Symfony\Component\Console\Tester
  • isFunctionalityUsed() : Joomla\CMS\Workflow
  • isTemplated() : Fig\Link
  • isWorkflowActive() : Joomla\CMS\Workflow


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- l -

  • lazy() : Assert
  • limit() : Joomla\Database\Query
  • LinkProviderTrait : Fig\Link
  • LinksTrait : Tobscure\JsonApi
  • LinkTrait : Fig\Link
  • loadCurveByParam() : phpseclib3\Crypt\EC\Formats\Keys
  • loadForm() : Joomla\CMS\MVC\Model
  • loadFormData() : Joomla\CMS\MVC\Model
  • loadIdentity() : Joomla\CMS\Application
  • lock() : Symfony\Component\Console\Command
  • LockableTrait : Symfony\Component\Console\Command
  • LoggerAwareTrait : Psr\Log
  • LoggerTrait : Psr\Log
  • logTask() : Joomla\Component\Scheduler\Administrator\Traits


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- m -

  • marshalHeadersFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalMethodFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalProtocolVersionFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalUriFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • MessageTrait : Laminas\Diactoros , Nyholm\Psr7
  • MetaTrait : Tobscure\JsonApi
  • minute() : Joomla\Database\Query
  • month() : Joomla\Database\Query
  • mustDisplayButton() : Joomla\Plugin\System\Webauthn\PluginTraits
  • MVCFactoryAwareTrait : Joomla\CMS\MVC\Factory
  • MVCFactoryServiceTrait : Joomla\CMS\MVC\Factory
  • MysqlQueryBuilder : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- n -

  • NodeTrait : Joomla\CMS\Tree
  • normalizeServer() : Laminas\Diactoros , Zend\Diactoros
  • normalizeUploadedFiles() : Laminas\Diactoros , Zend\Diactoros
  • noWait() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- o -

  • offset() : Joomla\Database\Query
  • onDisplay() : Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- p -

  • parseCookieHeader() : Laminas\Diactoros , Zend\Diactoros
  • PasswordProtected : phpseclib3\Crypt\Common\Traits
  • populateState() : Joomla\CMS\MVC\Model
  • PostgresqlQueryBuilder : Joomla\Database\Query
  • prepareExpectation() : Symfony\Component\VarDumper\Test
  • prepareForm() : Joomla\CMS\Categories
  • preprocessData() : Joomla\CMS\MVC\Model
  • preprocessForm() : Joomla\CMS\MVC\Model
  • processLimit() : Joomla\Database\Query
  • ProviderManagerHelperTrait : Joomla\Component\Media\Administrator\Provider


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- r -

  • rand() : Joomla\Database\Query
  • regexp() : Joomla\Database\Query
  • registerEvent() : Joomla\CMS\Application
  • release() : Symfony\Component\Console\Command
  • removeChild() : Joomla\CMS\Tree
  • RequestTrait : Laminas\Diactoros , Nyholm\Psr7
  • resolveAdapterAndPath() : Joomla\Component\Media\Administrator\Provider
  • ResolveFiles : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • resolveFileUrl() : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • ResultAware : Joomla\CMS\Event\Result
  • ResultTypeArrayAware : Joomla\CMS\Event\Result
  • ResultTypeBooleanAware : Joomla\CMS\Event\Result
  • ResultTypeFloatAware : Joomla\CMS\Event\Result
  • ResultTypeIntegerAware : Joomla\CMS\Event\Result
  • ResultTypeNumericAware : Joomla\CMS\Event\Result
  • ResultTypeObjectAware : Joomla\CMS\Event\Result
  • ResultTypeStringAware : Joomla\CMS\Event\Result
  • returning() : Joomla\Database\Query
  • RouterServiceTrait : Joomla\CMS\Component\Router


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- s -

  • second() : Joomla\Database\Query
  • selectRowNumber() : Joomla\Database\Query
  • ServiceLocatorTrait : Symfony\Contracts\Service
  • ServiceSubscriberTrait : Symfony\Contracts\Service
  • SessionAwareWebApplicationTrait : Joomla\Application
  • setAssociationExtension() : Joomla\CMS\Association
  • setCacheControllerFactory() : Joomla\CMS\Cache
  • setCategoryFactory() : Joomla\CMS\Categories
  • setContainer() : Joomla\DI , Symfony\Contracts\Service
  • setCurrentUser() : Joomla\CMS\User
  • setDatabase() : Joomla\Database
  • setDbo() : Joomla\CMS\MVC\Model
  • setDispatcher() : Joomla\Event
  • setFormFactory() : Joomla\CMS\Form
  • setHeaders() : Laminas\Diactoros , Nyholm\Psr7
  • setHelperFactory() : Joomla\CMS\Helper
  • setImplicitCurve() : phpseclib3\Crypt\EC\Formats\Keys
  • setInputs() : Symfony\Component\Console\Tester
  • setLinks() : Tobscure\JsonApi
  • setLogger() : Psr\Log
  • setMeta() : Tobscure\JsonApi
  • setMethod() : Laminas\Diactoros
  • setMVCFactory() : Joomla\CMS\MVC\Factory
  • setParent() : Joomla\CMS\Tree
  • setRegistry() : Joomla\CMS\HTML
  • setResult() : Joomla\CMS\Event\Result
  • setRouterFactory() : Joomla\CMS\Component\Router
  • setSession() : Joomla\Application
  • setSibling() : Joomla\CMS\Tree
  • setSiteRouter() : Joomla\CMS\Router
  • setState() : Joomla\CMS\MVC\Model
  • setTagsHelper() : Joomla\CMS\Tag
  • setUpVarDumper() : Symfony\Component\VarDumper\Test
  • setUpWorkflow() : Joomla\CMS\MVC\Model
  • setUserFactory() : Joomla\CMS\Application
  • SiteRouterAwareTrait : Joomla\CMS\Router
  • standardRoutineHandler() : Joomla\Component\Scheduler\Administrator\Traits
  • startRoutine() : Joomla\Component\Scheduler\Administrator\Traits
  • StateBehaviorTrait : Joomla\CMS\MVC\Model
  • supportFunctionality() : Joomla\CMS\Workflow
  • SYMFONY_GRAPHEME_CLUSTER_RX : Symfony\Polyfill\Intl\Grapheme


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- t -

  • TaggableTableTrait : Joomla\CMS\Tag
  • TaskPluginTrait : Joomla\Component\Scheduler\Administrator\Traits
  • tearDownVarDumper() : Symfony\Component\VarDumper\Test
  • TesterTrait : Symfony\Component\Console\Tester
  • that() : Assert
  • thatAll() : Assert
  • thatNullOr() : Assert
  • triggerEvent() : Joomla\CMS\Application
  • typeCheckResult() : Joomla\CMS\Event\Result


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- u -

  • updateHostFromUri() : Nyholm\Psr7
  • useNamedCurve() : phpseclib3\Crypt\EC\Formats\Keys
  • UserProfileFields : Joomla\Plugin\System\Webauthn\PluginTraits
  • useSpecifiedCurve() : phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- v -

  • v1() : Ramsey\Uuid
  • v3() : Ramsey\Uuid
  • v4() : Ramsey\Uuid
  • v5() : Ramsey\Uuid
  • validateAndTrimHeader() : Nyholm\Psr7
  • validateProtocolVersion() : Laminas\Diactoros
  • VarDumperTestTrait : Symfony\Component\VarDumper\Test


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- w -

  • withAddedHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withBody() : Laminas\Diactoros , Nyholm\Psr7
  • withHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withLink() : Fig\Link
  • withMethod() : Laminas\Diactoros , Nyholm\Psr7
  • withoutHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withoutLink() : Fig\Link
  • withPassword() : phpseclib3\Crypt\Common\Traits
  • withProtocolVersion() : Laminas\Diactoros , Nyholm\Psr7
  • withRequestTarget() : Laminas\Diactoros , Nyholm\Psr7
  • withUri() : Laminas\Diactoros , Nyholm\Psr7
  • workflowAfterSave() : Joomla\CMS\MVC\Model
  • workflowBeforeSave() : Joomla\CMS\MVC\Model
  • workflowBeforeStageChange() : Joomla\CMS\MVC\Model
  • WorkflowBehaviorTrait : Joomla\CMS\MVC\Model
  • workflowCleanupBatchMove() : Joomla\CMS\MVC\Model
  • workflowPreprocessForm() : Joomla\CMS\MVC\Model
  • WorkflowServiceTrait : Joomla\CMS\Workflow


Joomla CMS: Membres de l'espace de nommage

Liste de tous les membres des espaces de nommage avec des liens vers la documentation de namespace de chaque membre :

- y -

  • year() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- _ -

  • __construct() : Symfony\Contracts\Service
  • __toString() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- a -

  • addChild() : Joomla\CMS\Tree
  • addLink() : Tobscure\JsonApi
  • addMeta() : Tobscure\JsonApi
  • addPaginationLink() : Tobscure\JsonApi
  • addPaginationLinks() : Tobscure\JsonApi
  • addResult() : Joomla\CMS\Event\Result
  • addTransitionField() : Joomla\CMS\MVC\Model
  • advertiseRoutines() : Joomla\Component\Scheduler\Administrator\Traits
  • assertCommandIsSuccessful() : Symfony\Component\Console\Tester
  • assertDumpEquals() : Symfony\Component\VarDumper\Test
  • assertDumpMatchesFormat() : Symfony\Component\VarDumper\Test
  • assertHeader() : Laminas\Diactoros


Joomla CMS: Membres de l'espace de nommage

- b -

  • batchWorkflowStage() : Joomla\CMS\MVC\Model


Joomla CMS: Membres de l'espace de nommage

- c -

  • canEditUser() : Joomla\Plugin\System\Webauthn\PluginTraits
  • castAs() : Joomla\Database\Query
  • checkToken() : Joomla\Application
  • clear() : Joomla\Database\Query
  • clearTagsHelper() : Joomla\CMS\Tag
  • concatenate() : Joomla\Database\Query
  • countItems() : Joomla\CMS\Categories
  • createCircularReferenceException() : Symfony\Contracts\Service
  • createNotFoundException() : Symfony\Contracts\Service
  • createRouter() : Joomla\CMS\Component\Router
  • createStream() : Symfony\Component\Console\Tester
  • createUploadedFile() : Laminas\Diactoros , Zend\Diactoros
  • createUri() : Laminas\Diactoros
  • currentTimestamp() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- d -

  • dateAdd() : Joomla\Database\Query
  • day() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- e -

  • enableWorkflowBatch() : Joomla\CMS\MVC\Model
  • encodeParameters() : phpseclib3\Crypt\EC\Formats\Keys
  • endRoutine() : Joomla\Component\Scheduler\Administrator\Traits
  • esc() : Symfony\Component\VarDumper\Dumper
  • executeTransition() : Joomla\CMS\MVC\Model
  • extractPoint() : phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Membres de l'espace de nommage

- f -

  • filterHeaderValue() : Laminas\Diactoros
  • findInSet() : Joomla\Database\Query
  • forShare() : Joomla\Database\Query
  • forUpdate() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- g -

  • get() : Symfony\Contracts\Service
  • getAdapter() : Joomla\Component\Media\Administrator\Provider
  • getAssociationsExtension() : Joomla\CMS\Association
  • getAttributes() : Fig\Link
  • getBody() : Laminas\Diactoros , Nyholm\Psr7
  • getCacheControllerFactory() : Joomla\CMS\Cache
  • getCategory() : Joomla\CMS\Categories
  • getChildren() : Joomla\CMS\Tree
  • getConditions() : Joomla\CMS\Workflow
  • getContainer() : Joomla\DI
  • getCurrentUser() : Joomla\CMS\User
  • getDatabase() : Joomla\Database
  • getDbo() : Joomla\CMS\MVC\Model
  • getDefaultAdapterName() : Joomla\Component\Media\Administrator\Provider
  • getDispatcher() : Joomla\CMS\Application , Joomla\Event
  • getDisplay() : Symfony\Component\Console\Tester
  • getDump() : Symfony\Component\VarDumper\Test
  • getErrorOutput() : Symfony\Component\Console\Tester
  • getEventClassByEventName() : Joomla\CMS\Event
  • getFormFactory() : Joomla\CMS\Form , Joomla\CMS\MVC\Model
  • getFormToken() : Joomla\Application
  • getHeader() : Laminas\Diactoros , Nyholm\Psr7
  • getHeaderLine() : Laminas\Diactoros , Nyholm\Psr7
  • getHeaders() : Laminas\Diactoros , Nyholm\Psr7
  • getHelperFactory() : Joomla\CMS\Helper
  • getHostFromUri() : Laminas\Diactoros
  • getHref() : Fig\Link
  • getIdentity() : Joomla\CMS\Application
  • getInput() : Joomla\Application , Symfony\Component\Console\Tester
  • getLinks() : Fig\Link , Tobscure\JsonApi
  • getLinksByRel() : Fig\Link
  • getLogger() : Joomla\CMS\Application
  • getMeta() : Tobscure\JsonApi
  • getMethod() : Laminas\Diactoros , Nyholm\Psr7
  • getModelName() : Joomla\CMS\Workflow
  • getMVCFactory() : Joomla\CMS\MVC\Factory
  • getOutput() : Symfony\Component\Console\Tester
  • getParent() : Joomla\CMS\Tree
  • getProtocolVersion() : Laminas\Diactoros , Nyholm\Psr7
  • getProvidedServices() : Symfony\Contracts\Service
  • getProvider() : Joomla\Component\Media\Administrator\Provider
  • getProviderManager() : Joomla\Component\Media\Administrator\Provider
  • getRegistry() : Joomla\CMS\HTML
  • getRels() : Fig\Link
  • getRequestTarget() : Laminas\Diactoros , Nyholm\Psr7
  • getRoot() : Joomla\CMS\Tree
  • getRoutineId() : Joomla\Component\Scheduler\Administrator\Traits
  • getSession() : Joomla\Application
  • getSibling() : Joomla\CMS\Tree
  • getSiteRouter() : Joomla\CMS\Router
  • getStageForNewItem() : Joomla\CMS\MVC\Model
  • getState() : Joomla\CMS\MVC\Model
  • getStateColumnForSection() : Joomla\CMS\Categories
  • getStatusCode() : Symfony\Component\Console\Tester
  • getStream() : Laminas\Diactoros
  • getSubscribedServices() : Symfony\Contracts\Service
  • getTableNameForSection() : Joomla\CMS\Categories
  • getTagsHelper() : Joomla\CMS\Tag
  • getUri() : Laminas\Diactoros , Nyholm\Psr7
  • getUserFromData() : Joomla\Plugin\System\Webauthn\PluginTraits
  • groupConcat() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- h -

  • has() : Symfony\Contracts\Service
  • hasChildren() : Joomla\CMS\Tree
  • hasHeader() : Laminas\Diactoros , Nyholm\Psr7
  • hasParent() : Joomla\CMS\Tree
  • hour() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- i -

  • importWorkflowPlugins() : Joomla\CMS\MVC\Model
  • includeFile() : Composer\Autoload
  • includeRelativeFiles() : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • initialize() : Laminas\Diactoros
  • initialize_static_variables() : phpseclib3\Crypt\EC\Formats\Keys
  • initOutput() : Symfony\Component\Console\Tester
  • isFunctionalityUsed() : Joomla\CMS\Workflow
  • isTemplated() : Fig\Link
  • isWorkflowActive() : Joomla\CMS\Workflow


Joomla CMS: Membres de l'espace de nommage

- l -

  • lazy() : Assert
  • limit() : Joomla\Database\Query
  • loadCurveByParam() : phpseclib3\Crypt\EC\Formats\Keys
  • loadForm() : Joomla\CMS\MVC\Model
  • loadFormData() : Joomla\CMS\MVC\Model
  • loadIdentity() : Joomla\CMS\Application
  • lock() : Symfony\Component\Console\Command
  • logTask() : Joomla\Component\Scheduler\Administrator\Traits


Joomla CMS: Membres de l'espace de nommage

- m -

  • marshalHeadersFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalMethodFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalProtocolVersionFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • marshalUriFromSapi() : Laminas\Diactoros , Zend\Diactoros
  • minute() : Joomla\Database\Query
  • month() : Joomla\Database\Query
  • mustDisplayButton() : Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Membres de l'espace de nommage

- n -

  • normalizeServer() : Laminas\Diactoros , Zend\Diactoros
  • normalizeUploadedFiles() : Laminas\Diactoros , Zend\Diactoros
  • noWait() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- o -

  • offset() : Joomla\Database\Query
  • onDisplay() : Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Membres de l'espace de nommage

- p -

  • parseCookieHeader() : Laminas\Diactoros , Zend\Diactoros
  • populateState() : Joomla\CMS\MVC\Model
  • prepareExpectation() : Symfony\Component\VarDumper\Test
  • prepareForm() : Joomla\CMS\Categories
  • preprocessData() : Joomla\CMS\MVC\Model
  • preprocessForm() : Joomla\CMS\MVC\Model
  • processLimit() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- r -

  • rand() : Joomla\Database\Query
  • regexp() : Joomla\Database\Query
  • registerEvent() : Joomla\CMS\Application
  • release() : Symfony\Component\Console\Command
  • removeChild() : Joomla\CMS\Tree
  • resolveAdapterAndPath() : Joomla\Component\Media\Administrator\Provider
  • resolveFileUrl() : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • returning() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- s -

  • second() : Joomla\Database\Query
  • selectRowNumber() : Joomla\Database\Query
  • setAssociationExtension() : Joomla\CMS\Association
  • setCacheControllerFactory() : Joomla\CMS\Cache
  • setCategoryFactory() : Joomla\CMS\Categories
  • setContainer() : Joomla\DI , Symfony\Contracts\Service
  • setCurrentUser() : Joomla\CMS\User
  • setDatabase() : Joomla\Database
  • setDbo() : Joomla\CMS\MVC\Model
  • setDispatcher() : Joomla\Event
  • setFormFactory() : Joomla\CMS\Form
  • setHeaders() : Laminas\Diactoros , Nyholm\Psr7
  • setHelperFactory() : Joomla\CMS\Helper
  • setImplicitCurve() : phpseclib3\Crypt\EC\Formats\Keys
  • setInputs() : Symfony\Component\Console\Tester
  • setLinks() : Tobscure\JsonApi
  • setLogger() : Psr\Log
  • setMeta() : Tobscure\JsonApi
  • setMethod() : Laminas\Diactoros
  • setMVCFactory() : Joomla\CMS\MVC\Factory
  • setParent() : Joomla\CMS\Tree
  • setRegistry() : Joomla\CMS\HTML
  • setResult() : Joomla\CMS\Event\Result
  • setRouterFactory() : Joomla\CMS\Component\Router
  • setSession() : Joomla\Application
  • setSibling() : Joomla\CMS\Tree
  • setSiteRouter() : Joomla\CMS\Router
  • setState() : Joomla\CMS\MVC\Model
  • setTagsHelper() : Joomla\CMS\Tag
  • setUpVarDumper() : Symfony\Component\VarDumper\Test
  • setUpWorkflow() : Joomla\CMS\MVC\Model
  • setUserFactory() : Joomla\CMS\Application
  • standardRoutineHandler() : Joomla\Component\Scheduler\Administrator\Traits
  • startRoutine() : Joomla\Component\Scheduler\Administrator\Traits
  • supportFunctionality() : Joomla\CMS\Workflow


Joomla CMS: Membres de l'espace de nommage

- t -

  • tearDownVarDumper() : Symfony\Component\VarDumper\Test
  • that() : Assert
  • thatAll() : Assert
  • thatNullOr() : Assert
  • triggerEvent() : Joomla\CMS\Application
  • typeCheckResult() : Joomla\CMS\Event\Result


Joomla CMS: Membres de l'espace de nommage

- u -

  • updateHostFromUri() : Nyholm\Psr7
  • useNamedCurve() : phpseclib3\Crypt\EC\Formats\Keys
  • useSpecifiedCurve() : phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Membres de l'espace de nommage

- v -

  • v1() : Ramsey\Uuid
  • v3() : Ramsey\Uuid
  • v4() : Ramsey\Uuid
  • v5() : Ramsey\Uuid
  • validateAndTrimHeader() : Nyholm\Psr7
  • validateProtocolVersion() : Laminas\Diactoros


Joomla CMS: Membres de l'espace de nommage

- w -

  • withAddedHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withBody() : Laminas\Diactoros , Nyholm\Psr7
  • withHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withLink() : Fig\Link
  • withMethod() : Laminas\Diactoros , Nyholm\Psr7
  • withoutHeader() : Laminas\Diactoros , Nyholm\Psr7
  • withoutLink() : Fig\Link
  • withPassword() : phpseclib3\Crypt\Common\Traits
  • withProtocolVersion() : Laminas\Diactoros , Nyholm\Psr7
  • withRequestTarget() : Laminas\Diactoros , Nyholm\Psr7
  • withUri() : Laminas\Diactoros , Nyholm\Psr7
  • workflowAfterSave() : Joomla\CMS\MVC\Model
  • workflowBeforeSave() : Joomla\CMS\MVC\Model
  • workflowBeforeStageChange() : Joomla\CMS\MVC\Model
  • workflowCleanupBatchMove() : Joomla\CMS\MVC\Model
  • workflowPreprocessForm() : Joomla\CMS\MVC\Model


Joomla CMS: Membres de l'espace de nommage

- y -

  • year() : Joomla\Database\Query


Joomla CMS: Membres de l'espace de nommage

- $ -

  • $_children : Joomla\CMS\Tree
  • $_leftSibling : Joomla\CMS\Tree
  • $_rightSibling : Joomla\CMS\Tree
  • $attributes : Fig\Link
  • $captureStreamsIndependently : Symfony\Component\Console\Tester
  • $childOIDsLoaded : phpseclib3\Crypt\EC\Formats\Keys
  • $defaultAdapterName : Joomla\Component\Media\Administrator\Provider
  • $forShare : Joomla\Database\Query
  • $headerNames : Laminas\Diactoros , Nyholm\Psr7
  • $href : Fig\Link
  • $injectedCSSandJS : Joomla\Plugin\System\Webauthn\PluginTraits
  • $input : Symfony\Component\Console\Tester
  • $inputs : Symfony\Component\Console\Tester
  • $limit : Joomla\Database\Query
  • $loading : Symfony\Contracts\Service
  • $method : Laminas\Diactoros
  • $noWait : Joomla\Database\Query
  • $offset : Joomla\Database\Query
  • $protocol : Laminas\Diactoros , Nyholm\Psr7
  • $providedTypes : Symfony\Contracts\Service
  • $rel : Fig\Link
  • $requestTarget : Laminas\Diactoros , Nyholm\Psr7
  • $resultAcceptableClasses : Joomla\CMS\Event\Result
  • $resultIsFalseable : Joomla\CMS\Event\Result
  • $returning : Joomla\Database\Query
  • $section : Joomla\CMS\MVC\Model
  • $state : Joomla\CMS\MVC\Model
  • $statusCode : Symfony\Component\Console\Tester
  • $stream : Laminas\Diactoros , Nyholm\Psr7
  • $uri : Laminas\Diactoros , Nyholm\Psr7
  • $useNamedCurves : phpseclib3\Crypt\EC\Formats\Keys
  • $userFactory : Joomla\CMS\Application
  • $workflow : Joomla\CMS\MVC\Model
  • $workflowEnabled : Joomla\CMS\MVC\Model

- a -

  • AdditionalLoginButtons : Joomla\Plugin\System\Webauthn\PluginTraits
  • AssociationServiceTrait : Joomla\CMS\Association

- c -

  • CacheControllerFactoryAwareTrait : Joomla\CMS\Cache
  • CategoryServiceTrait : Joomla\CMS\Categories
  • Common : phpseclib3\Crypt\EC\Formats\Keys
  • ContainerAwareTrait : Joomla\DI
  • CoreEventAware : Joomla\CMS\Event
  • CRYPTO_AEAD_AES256GCM_ABYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_KEYBYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_NPUBBYTES : Sodium
  • CRYPTO_AEAD_AES256GCM_NSECBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : Sodium
  • CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : Sodium
  • CRYPTO_AUTH_BYTES : Sodium
  • CRYPTO_AUTH_KEYBYTES : Sodium
  • CRYPTO_BOX_KEYPAIRBYTES : Sodium
  • CRYPTO_BOX_MACBYTES : Sodium
  • CRYPTO_BOX_NONCEBYTES : Sodium
  • CRYPTO_BOX_PUBLICKEYBYTES : Sodium
  • CRYPTO_BOX_SEALBYTES : Sodium
  • CRYPTO_BOX_SECRETKEYBYTES : Sodium
  • CRYPTO_BOX_SEEDBYTES : Sodium
  • CRYPTO_GENERICHASH_BYTES : Sodium
  • CRYPTO_GENERICHASH_BYTES_MAX : Sodium
  • CRYPTO_GENERICHASH_BYTES_MIN : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES_MAX : Sodium
  • CRYPTO_GENERICHASH_KEYBYTES_MIN : Sodium
  • CRYPTO_KX_BYTES : Sodium
  • CRYPTO_KX_PUBLICKEYBYTES : Sodium
  • CRYPTO_KX_SECRETKEYBYTES : Sodium
  • CRYPTO_KX_SEEDBYTES : Sodium
  • CRYPTO_SCALARMULT_BYTES : Sodium
  • CRYPTO_SCALARMULT_SCALARBYTES : Sodium
  • CRYPTO_SECRETBOX_KEYBYTES : Sodium
  • CRYPTO_SECRETBOX_MACBYTES : Sodium
  • CRYPTO_SECRETBOX_NONCEBYTES : Sodium
  • CRYPTO_SHORTHASH_BYTES : Sodium
  • CRYPTO_SHORTHASH_KEYBYTES : Sodium
  • CRYPTO_SIGN_BYTES : Sodium
  • CRYPTO_SIGN_KEYPAIRBYTES : Sodium
  • CRYPTO_SIGN_PUBLICKEYBYTES : Sodium
  • CRYPTO_SIGN_SECRETKEYBYTES : Sodium
  • CRYPTO_SIGN_SEEDBYTES : Sodium
  • CRYPTO_STREAM_KEYBYTES : Sodium
  • CRYPTO_STREAM_NONCEBYTES : Sodium
  • CurrentUserTrait : Joomla\CMS\User

- d -

  • DatabaseAwareTrait : Joomla\CMS\MVC\Model , Joomla\Database
  • DispatcherAwareTrait : Joomla\Event
  • DisplayTrait : Joomla\Plugin\Editors\TinyMCE\PluginTraits

- e -

  • EventAware : Joomla\CMS\Application
  • EvolvableLinkProviderTrait : Fig\Link
  • EvolvableLinkTrait : Fig\Link
  • ExtensionManagerTrait : Joomla\CMS\Extension

- f -

  • FormBehaviorTrait : Joomla\CMS\MVC\Model
  • FormFactoryAwareTrait : Joomla\CMS\Form

- h -

  • HelperFactoryAwareTrait : Joomla\CMS\Helper
  • HTMLRegistryAwareTrait : Joomla\CMS\HTML

- i -

  • IdentityAware : Joomla\CMS\Application
  • ImmutableNodeTrait : Joomla\CMS\Tree

- l -

  • LinkProviderTrait : Fig\Link
  • LinksTrait : Tobscure\JsonApi
  • LinkTrait : Fig\Link
  • LockableTrait : Symfony\Component\Console\Command
  • LoggerAwareTrait : Psr\Log
  • LoggerTrait : Psr\Log

- m -

  • MessageTrait : Laminas\Diactoros , Nyholm\Psr7
  • MetaTrait : Tobscure\JsonApi
  • MVCFactoryAwareTrait : Joomla\CMS\MVC\Factory
  • MVCFactoryServiceTrait : Joomla\CMS\MVC\Factory
  • MysqlQueryBuilder : Joomla\Database\Query

- n -

  • NodeTrait : Joomla\CMS\Tree

- p -

  • PasswordProtected : phpseclib3\Crypt\Common\Traits
  • PostgresqlQueryBuilder : Joomla\Database\Query
  • ProviderManagerHelperTrait : Joomla\Component\Media\Administrator\Provider

- r -

  • RequestTrait : Laminas\Diactoros , Nyholm\Psr7
  • ResolveFiles : Joomla\Plugin\Editors\TinyMCE\PluginTraits
  • ResultAware : Joomla\CMS\Event\Result
  • ResultTypeArrayAware : Joomla\CMS\Event\Result
  • ResultTypeBooleanAware : Joomla\CMS\Event\Result
  • ResultTypeFloatAware : Joomla\CMS\Event\Result
  • ResultTypeIntegerAware : Joomla\CMS\Event\Result
  • ResultTypeNumericAware : Joomla\CMS\Event\Result
  • ResultTypeObjectAware : Joomla\CMS\Event\Result
  • ResultTypeStringAware : Joomla\CMS\Event\Result
  • RouterServiceTrait : Joomla\CMS\Component\Router

- s -

  • ServiceLocatorTrait : Symfony\Contracts\Service
  • ServiceSubscriberTrait : Symfony\Contracts\Service
  • SessionAwareWebApplicationTrait : Joomla\Application
  • SiteRouterAwareTrait : Joomla\CMS\Router
  • StateBehaviorTrait : Joomla\CMS\MVC\Model
  • SYMFONY_GRAPHEME_CLUSTER_RX : Symfony\Polyfill\Intl\Grapheme

- t -

  • TaggableTableTrait : Joomla\CMS\Tag
  • TaskPluginTrait : Joomla\Component\Scheduler\Administrator\Traits
  • TesterTrait : Symfony\Component\Console\Tester

- u -

  • UserProfileFields : Joomla\Plugin\System\Webauthn\PluginTraits

- v -

  • VarDumperTestTrait : Symfony\Component\VarDumper\Test

- w -

  • WorkflowBehaviorTrait : Joomla\CMS\MVC\Model
  • WorkflowServiceTrait : Joomla\CMS\Workflow


Joomla CMS: Structures de données

Structures de données
Liste des structures de données avec une brève description :
[Niveau de détails 1234567]
▶N Algo26
▶N IdnaConvert
▶N EncodingHelper
C EncodingHelperInterface
C FromUtf8
C ToUtf8
▶N Exception
C AlreadyPunycodeException
C InvalidCharacterException
C InvalidIdnVersionException
▶N NamePrep
C NamePrep
C NamePrepData2003
C NamePrepData2008
C NamePrepDataInterface
C NamePrepInterface
▶N Punycode
C AbstractPunycode
C FromPunycode
C PunycodeInterface
C ToPunycode
▶N TranscodeUnicode
C TranscodeUnicode
C TranscodeUnicodeInterface
C AbstractIdnaConvert
C IdnaConvertInterface
C ToIdn
C ToUnicode
▶N Assert
C Assert
C Assertion
C AssertionChain
C AssertionFailedException
C InvalidArgumentException
C LazyAssertion
C LazyAssertionException
▶N Base64Url
C Base64Url
▶N bcmath_compat
C BCMath
▶N Brick
▶N Math
▶N Exception
C DivisionByZeroException
C IntegerOverflowException
C MathException
C NegativeNumberException
C NumberFormatException
C RoundingNecessaryException
▶N Internal
▶N Calculator
C BcMathCalculator
C GmpCalculator
C NativeCalculator
C Calculator
C BigDecimal
C BigInteger
C BigNumber
C BigRational
C RoundingMode
▶N CBOR
▶N OtherObject
C BreakObject
C DoublePrecisionFloatObject
C FalseObject
C GenericObject
C HalfPrecisionFloatObject
C NullObject
C OtherObjectManager
C SimpleObject
C SinglePrecisionFloatObject
C TrueObject
C UndefinedObject
▶N Tag
C Base16EncodingTag
C Base64EncodingTag
C Base64UrlEncodingTag
C BigFloatTag
C DecimalFractionTag
C EpochTag
C GenericTag
C NegativeBigIntegerTag
C PositiveBigIntegerTag
C TagObjectManager
C TimestampTag
C AbstractCBORObject
C ByteStringObject
C ByteStringWithChunkObject
C CBORObject
C Decoder
C InfiniteListObject
C InfiniteMapObject
C LengthCalculator
C ListObject
C MapItem
C MapObject
C OtherObject
C SignedIntegerObject
C Stream
C StringStream
C TagObject
C TextStringObject
C TextStringWithChunkObject
C UnsignedIntegerObject
C Utils
▶N Composer
▶N Autoload
C ClassLoader
C ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
▶N CaBundle
C CaBundle
C InstalledVersions
▶N Cose
▶N Algorithm
▶N Mac
C Hmac
C HS256
C HS256Truncated64
C HS384
C HS512
C Mac
▶N Signature
▶N ECDSA
C ECDSA
C ECSignature
C ES256
C ES256K
C ES384
C ES512
▶N EdDSA
C Ed25519
C ED256
C ED512
C EdDSA
▶N RSA
C PS256
C PS384
C PS512
C PSSRSA
C RS1
C RS256
C RS384
C RS512
C RSA
C Signature
C Algorithm
C Manager
C ManagerFactory
▶N Key
C Ec2Key
C Key
C OkpKey
C RsaKey
C SymmetricKey
C Algorithms
C Verifier
▶N Cron
C AbstractField
C CronExpression
C DayOfMonthField
C DayOfWeekField
C FieldFactory
C FieldFactoryInterface
C FieldInterface
C HoursField
C MinutesField
C MonthField
▶N DebugBar
▶N Bridge
▶N SwiftMailer
C SwiftLogCollector
C SwiftMailCollector
▶N Twig
C TimeableTwigExtensionProfiler
C TraceableTwigEnvironment
C TraceableTwigTemplate
C TwigCollector
C CacheCacheCollector
C DoctrineCollector
C MonologCollector
C NamespacedTwigProfileCollector
C Propel2Collector
C PropelCollector
C SlimCollector
C TwigProfileCollector
▶N DataCollector
▶N PDO
C PDOCollector
C TraceablePDO
C TraceablePDOStatement
C TracedStatement
C AggregatedCollector
C AssetProvider
C ConfigCollector
C DataCollector
C DataCollectorInterface
C ExceptionsCollector
C LocalizationCollector
C MemoryCollector
C MessagesAggregateInterface
C MessagesCollector
C PhpInfoCollector
C Renderable
C RequestDataCollector
C TimeDataCollector
▶N DataFormatter
▶N VarDumper
C DebugBarHtmlDumper
C SeekingData
C DataFormatter
C DataFormatterInterface
C DebugBarVarDumper
▶N Storage
C FileStorage
C MemcachedStorage
C PdoStorage
C RedisStorage
C StorageInterface
C DebugBar
C DebugBarException
C HttpDriverInterface
C JavascriptRenderer
C OpenHandler
C PhpHttpDriver
C RequestIdGenerator
C RequestIdGeneratorInterface
C StandardDebugBar
▶N Defuse
▶N Crypto
▶N Exception
C BadFormatException
C CryptoException
C EnvironmentIsBrokenException
C IOException
C WrongKeyOrModifiedCiphertextException
C Core
C Crypto
C DerivedKeys
C Encoding
C File
C Key
C KeyOrPassword
C KeyProtectedByPassword
C RuntimeTests
▶N Doctrine
▶N Common
▶N Inflector
C Inflector
▶N Inflector
▶N Rules
▶N English
C Inflectible
C InflectorFactory
C Rules
C Uninflected
▶N French
C Inflectible
C InflectorFactory
C Rules
C Uninflected
▶N NorwegianBokmal
C Inflectible
C InflectorFactory
C Rules
C Uninflected
▶N Portuguese
C Inflectible
C InflectorFactory
C Rules
C Uninflected
▶N Spanish
C Inflectible
C InflectorFactory
C Rules
C Uninflected
▶N Turkish
C Inflectible
C InflectorFactory
C Rules
C Uninflected
C Pattern
C Patterns
C Ruleset
C Substitution
C Substitutions
C Transformation
C Transformations
C Word
C CachedWordInflector
C GenericLanguageInflectorFactory
C Inflector
C InflectorFactory
C Language
C LanguageInflectorFactory
C NoopWordInflector
C RulesetInflector
C WordInflector
▶N enshrined
▶N svgSanitize
▶N data
C AllowedAttributes
C AllowedTags
C AttributeInterface
C TagInterface
C XPath
▶N ElementReference
C Resolver
C Subject
C Usage
▶N Exceptions
C NestingException
C Helper
C Sanitizer
▶N FG
▶N ASN1
▶N Composite
C AttributeTypeAndValue
C RDNString
C RelativeDistinguishedName
▶N Exception
C NotImplementedException
C ParserException
▶N Universal
C BitString
C BMPString
C Boolean
C CharacterString
C Enumerated
C GeneralizedTime
C GeneralString
C GraphicString
C IA5String
C Integer
C NullObject
C NumericString
C ObjectDescriptor
C ObjectIdentifier
C OctetString
C PrintableString
C RelativeObjectIdentifier
C Sequence
C Set
C T61String
C UniversalString
C UTCTime
C UTF8String
C VisibleString
C AbstractString
C AbstractTime
C ASNObject
C Base128
C Construct
C ExplicitlyTaggedObject
C Identifier
C OID
C Parsable
C TemplateParser
C UnknownConstructedObject
C UnknownObject
▶N Utility
C BigInteger
C BigIntegerBcmath
C BigIntegerGmp
▶N X509
▶N CSR
C Attributes
C CSR
▶N SAN
C DNSName
C IPAddress
C SubjectAlternativeNames
C AlgorithmIdentifier
C CertificateExtensions
C CertificateSubject
C PrivateKey
C PublicKey
▶N Fig
▶N Link
C GenericLinkProvider
C Link
C Relations
▶N Http
▶N Message
C MessageFactory
C RequestFactory
C ResponseFactory
C StreamFactory
C UriFactory
▶N Joomla
▶N Application
▶N Controller
C ContainerControllerResolver
C ControllerResolver
C ControllerResolverInterface
▶N Event
C ApplicationErrorEvent
C ApplicationEvent
▶N Exception
C UnableToWriteBody
▶N Web
C WebClient
C AbstractApplication
C AbstractWebApplication
C ApplicationEvents
C ApplicationInterface
C ConfigurationAwareApplicationInterface
C SessionAwareWebApplicationInterface
C WebApplication
C WebApplicationInterface
▶N Archive
▶N Exception
C UnknownArchiveException
C UnsupportedArchiveException
C Archive
C Bzip2
C ExtractableInterface
C Gzip
C Tar
C Zip
▶N Authentication
▶N Exception
C UnsupportedPasswordHandlerException
▶N Password
C Argon2idHandler
C Argon2iHandler
C BCryptHandler
C HandlerInterface
▶N Strategies
C DatabaseStrategy
C LocalStrategy
C AbstractUsernamePasswordAuthenticationStrategy
C Authentication
C AuthenticationStrategyInterface
▶N CMS
▶N Access
▶N Exception
C AuthenticationFailed
C NotAllowed
C Access
C Rule
C Rules
▶N Adapter
C Adapter
C AdapterInstance
▶N Application
▶N CLI
▶N Output
▶N Processor
C ColorProcessor
C ProcessorInterface
C Stdout
C Xml
C CliInput
C CliOutput
C ColorStyle
▶N Exception
C NotAcceptable
C AdministratorApplication
C ApiApplication
C ApplicationHelper
C BaseApplication
C CliApplication
C CMSApplication
C CMSApplicationInterface
C CMSWebApplicationInterface
C ConsoleApplication
C DaemonApplication
C EventAwareInterface
C SiteApplication
C WebApplication
▶N Association
C AssociationExtensionHelper
C AssociationExtensionInterface
C AssociationServiceInterface
▶N Authentication
▶N Password
C Argon2idHandler
C Argon2iHandler
C BCryptHandler
C ChainedHandler
C CheckIfRehashNeededHandlerInterface
C MD5Handler
C PHPassHandler
C Authentication
C AuthenticationResponse
C ProviderAwareAuthenticationPluginInterface
▶N Autoload
C ClassLoader
▶N Button
C ActionButton
C FeaturedButton
C PublishedButton
C TransitionButton
▶N Cache
▶N Controller
C CallbackController
C OutputController
C PageController
C ViewController
▶N Exception
C CacheConnectingException
C CacheExceptionInterface
C UnsupportedCacheException
▶N Storage
C ApcuStorage
C CacheStorageHelper
C FileStorage
C MemcachedStorage
C RedisStorage
C WincacheStorage
C Cache
C CacheController
C CacheControllerFactory
C CacheControllerFactoryAwareInterface
C CacheControllerFactoryInterface
C CacheStorage
▶N Captcha
▶N Google
C HttpBridgePostRequestMethod
C Captcha
▶N Categories
C Categories
C CategoryFactory
C CategoryFactoryInterface
C CategoryInterface
C CategoryNode
C CategoryServiceInterface
C SectionNotFoundException
▶N Changelog
C Changelog
▶N Client
C ClientHelper
C FtpClient
▶N Component
▶N Exception
C MissingComponentException
▶N Router
▶N Rules
C MenuRules
C NomenuRules
C RulesInterface
C StandardRules
C RouterBase
C RouterFactory
C RouterFactoryInterface
C RouterInterface
C RouterLegacy
C RouterServiceInterface
C RouterView
C RouterViewConfiguration
C ComponentHelper
C ComponentRecord
▶N Console
▶N Loader
C WritableContainerLoader
C WritableLoaderInterface
C AddUserCommand
C AddUserToGroupCommand
C ChangeUserPasswordCommand
C CheckJoomlaUpdatesCommand
C CheckUpdatesCommand
C CleanCacheCommand
C DeleteUserCommand
C ExtensionDiscoverCommand
C ExtensionDiscoverInstallCommand
C ExtensionDiscoverListCommand
C ExtensionInstallCommand
C ExtensionRemoveCommand
C ExtensionsListCommand
C FinderIndexCommand
C GetConfigurationCommand
C ListUserCommand
C RemoveOldFilesCommand
C RemoveUserFromGroupCommand
C SessionGcCommand
C SessionMetadataGcCommand
C SetConfigurationCommand
C SiteDownCommand
C SiteUpCommand
C TasksListCommand
C TasksRunCommand
C TasksStateCommand
C UpdateCoreCommand
▶N Crypt
▶N Cipher
C CryptoCipher
C SodiumCipher
C Crypt
▶N Date
C Date
▶N Dispatcher
C AbstractModuleDispatcher
C ApiDispatcher
C ComponentDispatcher
C ComponentDispatcherFactory
C ComponentDispatcherFactoryInterface
C Dispatcher
C DispatcherInterface
C LegacyComponentDispatcher
C ModuleDispatcher
C ModuleDispatcherFactory
C ModuleDispatcherFactoryInterface
▶N Document
▶N Feed
C FeedEnclosure
C FeedImage
C FeedItem
▶N Opensearch
C OpensearchImage
C OpensearchUrl
▶N Renderer
▶N Feed
C AtomRenderer
C RssRenderer
▶N Html
C ComponentRenderer
C HeadRenderer
C MessageRenderer
C MetasRenderer
C ModuleRenderer
C ModulesRenderer
C ScriptsRenderer
C StylesRenderer
C Document
C DocumentRenderer
C ErrorDocument
C Factory
C FactoryInterface
C FeedDocument
C HtmlDocument
C ImageDocument
C JsonapiDocument
C JsonDocument
C OpensearchDocument
C PreloadManager
C PreloadManagerInterface
C RawDocument
C RendererInterface
C XmlDocument
▶N Editor
C Editor
▶N Encrypt
▶N AES
C AbstractAES
C AesInterface
C Mcrypt
C OpenSSL
C Aes
C Base32
C Randval
C RandValInterface
C Totp
▶N Environment
C Browser
▶N Error
▶N JsonApi
C AuthenticationFailedExceptionHandler
C CheckinCheckoutExceptionHandler
C InvalidParameterExceptionHandler
C InvalidRouteExceptionHandler
C NotAcceptableExceptionHandler
C NotAllowedExceptionHandler
C ResourceNotFoundExceptionHandler
C SaveExceptionHandler
C SendEmailExceptionHandler
▶N Renderer
C CliRenderer
C FeedRenderer
C HtmlRenderer
C JsonapiRenderer
C JsonRenderer
C XmlRenderer
C AbstractRenderer
C RendererInterface
▶N Event
▶N Model
C BeforeBatchEvent
▶N MultiFactor
C BeforeDisplayMethods
C Callback
C Captive
C GetMethod
C GetSetup
C NotifyActionLog
C SaveSetup
C Validate
▶N Plugin
▶N System
▶N Webauthn
C Ajax
C AjaxChallenge
C AjaxCreate
C AjaxDelete
C AjaxInitCreate
C AjaxLogin
C AjaxSaveLabel
▶N QuickIcon
C GetIconEvent
▶N Result
C ResultAwareInterface
▶N Table
C AbstractEvent
C AfterBindEvent
C AfterCheckinEvent
C AfterCheckoutEvent
C AfterDeleteEvent
C AfterHitEvent
C AfterLoadEvent
C AfterMoveEvent
C AfterPublishEvent
C AfterReorderEvent
C AfterResetEvent
C AfterStoreEvent
C BeforeBindEvent
C BeforeCheckinEvent
C BeforeCheckoutEvent
C BeforeDeleteEvent
C BeforeHitEvent
C BeforeLoadEvent
C BeforeMoveEvent
C BeforePublishEvent
C BeforeReorderEvent
C BeforeResetEvent
C BeforeStoreEvent
C CheckEvent
C ObjectCreateEvent
C SetNewTagsEvent
▶N View
C DisplayEvent
▶N WebAsset
C AbstractEvent
C WebAssetRegistryAssetChanged
▶N Workflow
C AbstractEvent
C WorkflowFunctionalityUsedEvent
C WorkflowTransitionEvent
C AbstractEvent
C AbstractImmutableEvent
C AfterExtensionBootEvent
C BeforeExtensionBootEvent
C ErrorEvent
C GenericEvent
▶N Exception
C ExceptionHandler
▶N Extension
▶N Service
▶N Provider
C CategoryFactory
C ComponentDispatcherFactory
C HelperFactory
C Module
C ModuleDispatcherFactory
C MVCFactory
C RouterFactory
C BootableExtensionInterface
C Component
C ComponentInterface
C DummyPlugin
C ExtensionHelper
C ExtensionManagerInterface
C LegacyComponent
C Module
C ModuleInterface
C MVCComponent
C PluginInterface
▶N Feed
▶N Parser
▶N Rss
C ItunesRssParser
C MediaRssParser
C AtomParser
C NamespaceParserInterface
C RssParser
C Feed
C FeedEntry
C FeedFactory
C FeedLink
C FeedParser
C FeedPerson
▶N Fields
C FieldsServiceInterface
▶N Filesystem
▶N Streams
C StreamString
▶N Support
C StringController
C File
C FilesystemHelper
C Folder
C Patcher
C Path
C Stream
▶N Filter
C InputFilter
C OutputFilter
▶N Form
▶N Field
C AccessiblemediaField
C AccesslevelField
C AliastagField
C AuthorField
C CachehandlerField
C CalendarField
C CaptchaField
C CategoryField
C CheckboxesField
C CheckboxField
C ChromestyleField
C ColorField
C ComboField
C ComponentlayoutField
C ComponentsField
C ContenthistoryField
C ContentlanguageField
C ContenttypeField
C DatabaseconnectionField
C EditorField
C EmailField
C FileField
C FilelistField
C FolderlistField
C FrontendlanguageField
C GroupedlistField
C HeadertagField
C HiddenField
C ImagelistField
C IntegerField
C LanguageField
C LastvisitdaterangeField
C LimitboxField
C ListField
C MediaField
C MenuField
C MenuitemField
C MeterField
C ModulelayoutField
C ModuleorderField
C ModulepositionField
C ModuletagField
C NoteField
C NumberField
C OrderingField
C PasswordField
C PluginsField
C PluginstatusField
C PredefinedlistField
C RadiobasicField
C RadioField
C RangeField
C RedirectStatusField
C RegistrationdaterangeField
C RulesField
C SessionhandlerField
C SpacerField
C SqlField
C StatusField
C SubformField
C TagField
C TelephoneField
C TemplatestyleField
C TextareaField
C TextField
C TimeField
C TimezoneField
C TransitionField
C UrlField
C UseractiveField
C UserField
C UsergrouplistField
C UserstateField
C WorkflowComponentSectionsField
C WorkflowconditionField
C WorkflowstageField
▶N Filter
C IntarrayFilter
C RawFilter
C RulesFilter
C SafehtmlFilter
C TelFilter
C UnsetFilter
C UrlFilter
▶N Rule
C BooleanRule
C CalendarRule
C CaptchaRule
C ColorRule
C CssIdentifierRule
C CssIdentifierSubstringRule
C EmailRule
C EqualsRule
C ExistsRule
C FilePathRule
C FolderPathExistsRule
C ModuleLayoutRule
C NotequalsRule
C NumberRule
C OptionsRule
C PasswordRule
C RulesRule
C SubformRule
C TelRule
C TimeRule
C UrlRule
C UserIdRule
C UsernameRule
C Form
C FormFactory
C FormFactoryAwareInterface
C FormFactoryInterface
C FormField
C FormFilterInterface
C FormHelper
C FormRule
▶N Help
C Help
▶N Helper
C AuthenticationHelper
C CMSHelper
C ContentHelper
C HelperFactory
C HelperFactoryAwareInterface
C HelperFactoryInterface
C LibraryHelper
C MediaHelper
C ModuleHelper
C RouteHelper
C TagsHelper
C UserGroupsHelper
▶N HTML
▶N Helpers
C Access
C ActionsDropdown
C AdminLanguage
C Behavior
C Bootstrap
C Category
C Content
C ContentLanguage
C Date
C Debug
C DraggableList
C Dropdown
C Email
C Form
C FormBehavior
C Grid
C Icons
C JGrid
C Jquery
C Links
C ListHelper
C Menu
C Number
C SearchTools
C Select
C Sidebar
C SortableList
C StringHelper
C Tag
C Telephone
C UiTab
C User
C WorkflowStage
C HTMLHelper
C Registry
▶N Http
▶N Transport
C CurlTransport
C SocketTransport
C StreamTransport
C Http
C HttpFactory
C Response
C TransportInterface
▶N Image
▶N Exception
C UnparsableImageException
▶N Filter
C Backgroundfill
C Brightness
C Contrast
C Edgedetect
C Emboss
C Grayscale
C Negate
C Sketchy
C Smooth
C Image
C ImageFilter
▶N Input
C Cli
C Cookie
C Files
C Input
C Json
▶N Installation
▶N Application
C InstallationApplication
▶N Controller
C DisplayController
C InstallationController
C JSONController
C LanguageController
▶N Error
▶N Renderer
C JsonRenderer
▶N Form
▶N Field
▶N Installation
C LanguageField
C PrefixField
▶N Rule
C PrefixRule
C UsernameRule
▶N Helper
C DatabaseHelper
▶N Model
C BaseInstallationModel
C ChecksModel
C CleanupModel
C ConfigurationModel
C DatabaseModel
C LanguagesModel
C SetupModel
▶N Response
C JsonResponse
▶N Router
C InstallationRouter
▶N Service
▶N Provider
C Application
▶N View
▶N Error
C HtmlView
▶N Preinstall
C HtmlView
▶N Remove
C HtmlView
▶N Setup
C HtmlView
C DefaultView
▶N Installer
▶N Adapter
C ComponentAdapter
C FileAdapter
C LanguageAdapter
C LibraryAdapter
C ModuleAdapter
C PackageAdapter
C PluginAdapter
C TemplateAdapter
▶N Manifest
C LibraryManifest
C PackageManifest
C Installer
C InstallerAdapter
C InstallerExtension
C InstallerHelper
C InstallerScript
C InstallerScriptInterface
C LegacyInstallerScript
C Manifest
▶N Language
C Associations
C CachingLanguageFactory
C Language
C LanguageFactory
C LanguageFactoryInterface
C LanguageHelper
C Multilanguage
C Text
C Transliterate
▶N Layout
C BaseLayout
C FileLayout
C LayoutHelper
C LayoutInterface
▶N Log
▶N Logger
C CallbackLogger
C DatabaseLogger
C EchoLogger
C FormattedtextLogger
C InMemoryLogger
C MessagequeueLogger
C SyslogLogger
C W3cLogger
C DelegatingPsrLogger
C Log
C LogEntry
C Logger
C LoggerRegistry
▶N Mail
▶N Exception
C MailDisabledException
C Mail
C MailHelper
C MailTemplate
▶N Menu
C AbstractMenu
C AdministratorMenu
C AdministratorMenuItem
C MenuFactory
C MenuFactoryInterface
C MenuItem
C SiteMenu
▶N Microdata
C Microdata
▶N MVC
▶N Controller
▶N Exception
C CheckinCheckout
C ResourceNotFound
C Save
C SendEmail
C AdminController
C ApiController
C BaseController
C ControllerInterface
C FormController
▶N Factory
C ApiMVCFactory
C LegacyFactory
C MVCFactory
C MVCFactoryInterface
C MVCFactoryServiceInterface
▶N Model
C AdminModel
C BaseDatabaseModel
C BaseModel
C DatabaseModelInterface
C FormModel
C FormModelInterface
C ItemModel
C ItemModelInterface
C ListModel
C ListModelInterface
C ModelInterface
C StatefulModelInterface
C WorkflowModelInterface
▶N View
▶N Event
C OnGetApiFields
C AbstractView
C CategoriesView
C CategoryFeedView
C CategoryView
C FormView
C GenericDataException
C HtmlView
C JsonApiView
C JsonView
C ListView
C ViewInterface
▶N Object
C CMSObject
▶N Pagination
C Pagination
C PaginationObject
▶N Pathway
C Pathway
C SitePathway
▶N Plugin
C CMSPlugin
C PluginHelper
▶N Profiler
C Profiler
▶N Response
C JsonResponse
▶N Router
▶N Exception
C RouteNotFoundException
C AdministratorRouter
C ApiRouter
C Route
C Router
C SiteRouter
C SiteRouterAwareInterface
▶N Schema
▶N ChangeItem
C MysqlChangeItem
C PostgresqlChangeItem
C SqlsrvChangeItem
C ChangeItem
C ChangeSet
▶N Serializer
▶N Events
C OnGetApiAttributes
C OnGetApiRelation
C JoomlaSerializer
▶N Service
▶N Provider
C Application
C Authentication
C CacheController
C Config
C Console
C Database
C Dispatcher
C Document
C Form
C HTMLRegistry
C Language
C Logger
C Menu
C Pathway
C Router
C Session
C Toolbar
C User
C WebAssetRegistry
▶N Session
▶N EventListener
C MetadataManagerListener
▶N Exception
C UnsupportedStorageException
▶N Storage
C JoomlaStorage
C MetadataManager
C Session
C SessionFactory
C SessionManager
▶N String
C PunycodeHelper
▶N Table
C Asset
C Category
C Content
C ContentHistory
C ContentType
C CoreContent
C Extension
C Language
C Menu
C MenuType
C Module
C Nested
C Table
C TableInterface
C Ucm
C Update
C UpdateSite
C User
C Usergroup
C ViewLevel
▶N Tag
C TaggableTableInterface
C TagServiceInterface
▶N Toolbar
▶N Button
C AbstractGroupButton
C BasicButton
C ConfirmButton
C CustomButton
C DropdownButton
C HelpButton
C InlinehelpButton
C LinkButton
C PopupButton
C SeparatorButton
C StandardButton
C ContainerAwareToolbarFactory
C Toolbar
C ToolbarButton
C ToolbarFactoryInterface
C ToolbarHelper
▶N Tree
C ImmutableNodeInterface
C NodeInterface
▶N UCM
C UCM
C UCMBase
C UCMContent
C UCMType
▶N Updater
▶N Adapter
C CollectionAdapter
C ExtensionAdapter
C DownloadSource
C Update
C UpdateAdapter
C Updater
▶N Uri
C Uri
▶N User
C CurrentUserInterface
C User
C UserFactory
C UserFactoryInterface
C UserHelper
▶N Utility
C BufferStreamHandler
C Utility
▶N Versioning
C VersionableTableInterface
C Versioning
▶N WebAsset
▶N AssetItem
C CoreAssetItem
C FormValidateAssetItem
C KeepaliveAssetItem
C LangActiveAssetItem
C TableColumnsAssetItem
▶N Exception
C InvalidActionException
C UnknownAssetException
C UnsatisfiedDependencyException
C WebAssetExceptionInterface
C WebAssetAttachBehaviorInterface
C WebAssetItem
C WebAssetItemInterface
C WebAssetManager
C WebAssetManagerInterface
C WebAssetRegistry
C WebAssetRegistryInterface
▶N Workflow
C Workflow
C WorkflowServiceInterface
C Factory
C Version
▶N Component
▶N Actionlogs
▶N Administrator
▶N Controller
C ActionlogsController
C DisplayController
▶N Field
C ExtensionField
C LogcreatorField
C LogsdaterangeField
C LogtypeField
C PlugininfoField
▶N Helper
C ActionlogsHelper
▶N Model
C ActionlogConfigModel
C ActionlogModel
C ActionlogsModel
▶N Plugin
C ActionLogPlugin
▶N View
▶N Actionlogs
C HtmlView
▶N Admin
▶N Administrator
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Extension
C AdminComponent
▶N Model
C HelpModel
C SysinfoModel
▶N Service
▶N HTML
C Configuration
C Directory
C PhpSetting
C System
▶N View
▶N Help
C HtmlView
▶N Sysinfo
C HtmlView
C JsonView
C TextView
▶N Associations
▶N Administrator
▶N Controller
C AssociationController
C AssociationsController
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Field
▶N Modal
C AssociationField
C ItemlanguageField
C ItemtypeField
▶N Helper
C AssociationsHelper
▶N Model
C AssociationModel
C AssociationsModel
▶N View
▶N Association
C HtmlView
▶N Associations
C HtmlView
▶N Banners
▶N Administrator
▶N Controller
C BannerController
C BannersController
C ClientController
C ClientsController
C DisplayController
C TracksController
▶N Extension
C BannersComponent
▶N Field
C BannerclientField
C ClicksField
C ImpmadeField
C ImptotalField
▶N Helper
C BannersHelper
▶N Model
C BannerModel
C BannersModel
C ClientModel
C ClientsModel
C DownloadModel
C TracksModel
▶N Service
▶N Html
C Banner
▶N Table
C BannerTable
C ClientTable
▶N View
▶N Banner
C HtmlView
▶N Banners
C HtmlView
▶N Client
C HtmlView
▶N Clients
C HtmlView
▶N Download
C HtmlView
▶N Tracks
C HtmlView
C RawView
▶N Api
▶N Controller
C BannersController
C ClientsController
▶N View
▶N Banners
C JsonapiView
▶N Clients
C JsonapiView
▶N Site
▶N Controller
C DisplayController
▶N Helper
C BannerHelper
▶N Model
C BannerModel
C BannersModel
▶N Service
C Category
C Router
▶N Cache
▶N Administrator
▶N Controller
C DisplayController
▶N Model
C CacheModel
▶N View
▶N Cache
C HtmlView
▶N Categories
▶N Administrator
▶N Controller
C AjaxController
C CategoriesController
C CategoryController
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Extension
C CategoriesComponent
▶N Field
▶N Modal
C CategoryField
C CategoryeditField
C ComponentsCategoryField
▶N Helper
C CategoriesHelper
C CategoryAssociationHelper
▶N Model
C CategoriesModel
C CategoryModel
▶N Service
▶N HTML
C AdministratorService
▶N Table
C CategoryTable
▶N View
▶N Categories
C HtmlView
▶N Category
C HtmlView
▶N Api
▶N Controller
C CategoriesController
▶N View
▶N Categories
C JsonapiView
▶N Checkin
▶N Administrator
▶N Controller
C DisplayController
▶N Model
C CheckinModel
▶N View
▶N Checkin
C HtmlView
▶N Config
▶N Administrator
▶N Controller
C ApplicationController
C ComponentController
C DisplayController
C RequestController
▶N Extension
C ConfigComponent
▶N Field
C ConfigComponentsField
C FiltersField
▶N Helper
C ConfigHelper
▶N Model
C ApplicationModel
C ComponentModel
▶N View
▶N Application
C HtmlView
▶N Component
C HtmlView
▶N Api
▶N Controller
C ApplicationController
C ComponentController
▶N View
▶N Application
C JsonapiView
▶N Component
C JsonapiView
▶N Site
▶N Controller
C ConfigController
C DisplayController
C ModulesController
C TemplatesController
▶N Dispatcher
C Dispatcher
▶N Model
C ConfigModel
C FormModel
C ModulesModel
C TemplatesModel
▶N Service
C Router
▶N View
▶N Config
C HtmlView
▶N Modules
C HtmlView
▶N Templates
C HtmlView
▶N Contact
▶N Administrator
▶N Controller
C AjaxController
C ContactController
C ContactsController
C DisplayController
▶N Extension
C ContactComponent
▶N Field
▶N Modal
C ContactField
▶N Helper
C AssociationsHelper
C ContactHelper
▶N Model
C ContactModel
C ContactsModel
▶N Service
▶N HTML
C AdministratorService
C Icon
▶N Table
C ContactTable
▶N View
▶N Contact
C HtmlView
▶N Contacts
C HtmlView
▶N Api
▶N Controller
C ContactController
▶N Serializer
C ContactSerializer
▶N View
▶N Contacts
C JsonapiView
▶N Site
▶N Controller
C ContactController
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Helper
C AssociationHelper
C RouteHelper
▶N Model
C CategoriesModel
C CategoryModel
C ContactModel
C FeaturedModel
C FormModel
▶N Rule
C ContactEmailMessageRule
C ContactEmailRule
C ContactEmailSubjectRule
▶N Service
C Category
C Router
▶N View
▶N Categories
C HtmlView
▶N Category
C FeedView
C HtmlView
▶N Contact
C HtmlView
C VcfView
▶N Featured
C HtmlView
▶N Form
C HtmlView
▶N Content
▶N Administrator
▶N Controller
C AjaxController
C ArticleController
C ArticlesController
C DisplayController
C FeaturedController
▶N Event
▶N Model
C FeatureEvent
▶N Extension
C ContentComponent
▶N Field
▶N Modal
C ArticleField
C AssocField
C VotelistField
C VoteradioField
▶N Helper
C AssociationsHelper
C ContentHelper
▶N Model
C ArticleModel
C ArticlesModel
C FeaturedModel
C FeatureModel
▶N Service
▶N HTML
C AdministratorService
C Icon
▶N Table
C ArticleTable
C FeaturedTable
▶N View
▶N Article
C HtmlView
▶N Articles
C HtmlView
▶N Featured
C HtmlView
▶N Api
▶N Controller
C ArticlesController
▶N Helper
C ContentHelper
▶N Serializer
C ContentSerializer
▶N View
▶N Articles
C JsonapiView
▶N Site
▶N Controller
C ArticleController
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Helper
C AssociationHelper
C QueryHelper
C RouteHelper
▶N Model
C ArchiveModel
C ArticleModel
C ArticlesModel
C CategoriesModel
C CategoryModel
C FeaturedModel
C FormModel
▶N Service
C Category
C Router
▶N View
▶N Archive
C HtmlView
▶N Article
C HtmlView
▶N Categories
C HtmlView
▶N Category
C FeedView
C HtmlView
▶N Featured
C FeedView
C HtmlView
▶N Form
C HtmlView
▶N Contenthistory
▶N Administrator
▶N Controller
C DisplayController
C HistoryController
C PreviewController
▶N Dispatcher
C Dispatcher
▶N Helper
C ContenthistoryHelper
▶N Model
C CompareModel
C HistoryModel
C PreviewModel
▶N View
▶N Compare
C HtmlView
▶N History
C HtmlView
▶N Preview
C HtmlView
▶N Api
▶N Controller
C HistoryController
▶N View
▶N History
C JsonapiView
▶N Site
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Cpanel
▶N Administrator
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N View
▶N Cpanel
C HtmlView
▶N Fields
▶N Administrator
▶N Controller
C DisplayController
C FieldController
C FieldsController
C GroupController
C GroupsController
▶N Dispatcher
C Dispatcher
▶N Extension
C FieldsComponent
▶N Field
C ComponentsFieldgroupField
C ComponentsFieldsField
C FieldcontextsField
C FieldgroupsField
C FieldLayoutField
C SectionField
C SubfieldsField
C TypeField
▶N Helper
C FieldsHelper
▶N Model
C FieldModel
C FieldsModel
C GroupModel
C GroupsModel
▶N Plugin
C FieldsListPlugin
C FieldsPlugin
▶N Table
C FieldTable
C GroupTable
▶N View
▶N Field
C HtmlView
▶N Fields
C HtmlView
▶N Group
C HtmlView
▶N Groups
C HtmlView
▶N Api
▶N Controller
C FieldsController
C GroupsController
▶N View
▶N Fields
C JsonapiView
▶N Groups
C JsonapiView
▶N Site
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Finder
▶N Administrator
▶N Controller
C DisplayController
C FilterController
C FiltersController
C IndexController
C IndexerController
C MapsController
C SearchesController
▶N Extension
C FinderComponent
▶N Field
C BranchesField
C ContentmapField
C ContenttypesField
C SearchfilterField
▶N Helper
C FinderHelper
C LanguageHelper
▶N Indexer
▶N Language
C El
C Zh
▶N Parser
C Html
C Rtf
C Txt
C Adapter
C Helper
C Indexer
C Language
C Parser
C Query
C Result
C Taxonomy
C Token
▶N Model
C FilterModel
C FiltersModel
C IndexerModel
C IndexModel
C MapsModel
C SearchesModel
C StatisticsModel
▶N Response
C Response
▶N Service
▶N HTML
C Filter
C Finder
C Query
▶N Table
C FilterTable
C LinkTable
C MapTable
▶N View
▶N Filter
C HtmlView
▶N Filters
C HtmlView
▶N Index
C HtmlView
▶N Indexer
C HtmlView
▶N Maps
C HtmlView
▶N Searches
C HtmlView
▶N Statistics
C HtmlView
▶N Site
▶N Controller
C DisplayController
C SuggestionsController
▶N Helper
C FinderHelper
C RouteHelper
▶N Model
C SearchModel
C SuggestionsModel
▶N Service
C Router
▶N View
▶N Search
C FeedView
C HtmlView
C OpensearchView
▶N Installer
▶N Administrator
▶N Controller
C DatabaseController
C DiscoverController
C DisplayController
C InstallController
C ManageController
C UpdateController
C UpdatesiteController
C UpdatesitesController
▶N Extension
C InstallerComponent
▶N Field
C ExtensionstatusField
C FolderField
C LocationField
C PackageField
C TypeField
▶N Helper
C InstallerHelper
▶N Model
C DatabaseModel
C DiscoverModel
C InstallerModel
C InstallModel
C LanguagesModel
C ManageModel
C UpdateModel
C UpdatesiteModel
C UpdatesitesModel
C WarningsModel
▶N Service
▶N HTML
C Manage
C Updatesites
▶N Table
C UpdatesiteTable
▶N View
▶N Database
C HtmlView
▶N Discover
C HtmlView
▶N Install
C HtmlView
▶N Installer
C HtmlView
▶N Languages
C HtmlView
▶N Manage
C HtmlView
▶N Update
C HtmlView
▶N Updatesite
C HtmlView
▶N Updatesites
C HtmlView
▶N Warnings
C HtmlView
▶N Api
▶N Controller
C ManageController
▶N View
▶N Manage
C JsonapiView
▶N Joomlaupdate
▶N Administrator
▶N Controller
C DisplayController
C UpdateController
▶N Dispatcher
C Dispatcher
▶N Model
C UpdateModel
▶N View
▶N Joomlaupdate
C HtmlView
▶N Update
C HtmlView
▶N Upload
C HtmlView
▶N Languages
▶N Administrator
▶N Controller
C DisplayController
C InstalledController
C LanguageController
C LanguagesController
C OverrideController
C OverridesController
C StringsController
▶N Extension
C LanguagesComponent
▶N Field
C LanguageclientField
▶N Helper
C LanguagesHelper
C MultilangstatusHelper
▶N Model
C InstalledModel
C LanguageModel
C LanguagesModel
C OverrideModel
C OverridesModel
C StringsModel
▶N Service
▶N HTML
C Languages
▶N View
▶N Installed
C HtmlView
▶N Language
C HtmlView
▶N Languages
C HtmlView
▶N Multilangstatus
C HtmlView
▶N Override
C HtmlView
▶N Overrides
C HtmlView
▶N Api
▶N Controller
C LanguagesController
C OverridesController
C StringsController
▶N View
▶N Languages
C JsonapiView
▶N Overrides
C JsonapiView
▶N Strings
C JsonapiView
▶N Login
▶N Administrator
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Model
C LoginModel
▶N View
▶N Login
C HtmlView
▶N Mails
▶N Administrator
▶N Controller
C DisplayController
C TemplateController
▶N Helper
C MailsHelper
▶N Model
C TemplateModel
C TemplatesModel
▶N Table
C TemplateTable
▶N View
▶N Template
C HtmlView
▶N Templates
C HtmlView
▶N Media
▶N Administrator
▶N Adapter
C AdapterInterface
▶N Controller
C ApiController
C DisplayController
C PluginController
▶N Dispatcher
C Dispatcher
▶N Event
C AbstractMediaItemValidationEvent
C FetchMediaItemEvent
C FetchMediaItemsEvent
C FetchMediaItemUrlEvent
C MediaProviderEvent
C OAuthCallbackEvent
▶N Exception
C FileExistsException
C FileNotFoundException
C InvalidPathException
▶N Model
C ApiModel
C FileModel
C MediaModel
▶N Plugin
C MediaActionPlugin
▶N Provider
C ProviderInterface
C ProviderManager
▶N View
▶N File
C HtmlView
▶N Media
C HtmlView
▶N Api
▶N Controller
C AdaptersController
C MediaController
▶N Model
C AdapterModel
C AdaptersModel
C MediaModel
C MediumModel
▶N View
▶N Adapters
C JsonapiView
▶N Media
C JsonapiView
▶N Site
▶N Dispatcher
C Dispatcher
▶N Menus
▶N Administrator
▶N Controller
C AjaxController
C DisplayController
C ItemController
C ItemsController
C MenuController
C MenusController
▶N Extension
C MenusComponent
▶N Field
▶N Modal
C MenuField
C MenuItemByTypeField
C MenuOrderingField
C MenuParentField
C MenuPresetField
C MenutypeField
▶N Helper
C AssociationsHelper
C MenusHelper
▶N Model
C ItemModel
C ItemsModel
C MenuModel
C MenusModel
C MenutypesModel
▶N Service
▶N HTML
C Menus
▶N Table
C MenuTable
C MenuTypeTable
▶N View
▶N Item
C HtmlView
▶N Items
C HtmlView
▶N Menu
C HtmlView
C XmlView
▶N Menus
C HtmlView
▶N Menutypes
C HtmlView
▶N Api
▶N Controller
C ItemsController
C MenusController
▶N View
▶N Items
C JsonapiView
▶N Menus
C JsonapiView
▶N Site
▶N Dispatcher
C Dispatcher
▶N Messages
▶N Administrator
▶N Controller
C ConfigController
C DisplayController
C MessageController
C MessagesController
▶N Extension
C MessagesComponent
▶N Field
C MessageStatesField
C UserMessagesField
▶N Helper
C MessagesHelper
▶N Model
C ConfigModel
C MessageModel
C MessagesModel
▶N Service
▶N HTML
C Messages
▶N Table
C MessageTable
▶N View
▶N Config
C HtmlView
▶N Message
C HtmlView
▶N Messages
C HtmlView
▶N Api
▶N Controller
C MessagesController
▶N View
▶N Messages
C JsonapiView
▶N Modules
▶N Administrator
▶N Controller
C DisplayController
C ModuleController
C ModulesController
▶N Extension
C ModulesComponent
▶N Field
C ModulesModuleField
C ModulesPositioneditField
C ModulesPositionField
▶N Helper
C ModulesHelper
▶N Model
C ModuleModel
C ModulesModel
C PositionsModel
C SelectModel
▶N Service
▶N HTML
C Modules
▶N View
▶N Module
C HtmlView
▶N Modules
C HtmlView
▶N Select
C HtmlView
▶N Api
▶N Controller
C ModulesController
▶N View
▶N Modules
C JsonapiView
▶N Site
▶N Controller
C DisplayController
▶N Dispatcher
C Dispatcher
▶N Newsfeeds
▶N Administrator
▶N Controller
C AjaxController
C DisplayController
C NewsfeedController
C NewsfeedsController
▶N Extension
C NewsfeedsComponent
▶N Field
▶N Modal
C NewsfeedField
C NewsfeedsField
▶N Helper
C AssociationsHelper
C NewsfeedsHelper
▶N Model
C NewsfeedModel
C NewsfeedsModel
▶N Service
▶N HTML
C AdministratorService
▶N Table
C NewsfeedTable
▶N View
▶N Newsfeed
C HtmlView
▶N Newsfeeds
C HtmlView
▶N Api
▶N Controller
C FeedsController
▶N Serializer
C NewsfeedSerializer
▶N View
▶N Feeds
C JsonapiView
▶N Site
▶N Controller
C DisplayController
▶N Helper
C AssociationHelper
C RouteHelper
▶N Model
C CategoriesModel
C CategoryModel
C NewsfeedModel
▶N Service
C Category
C Router
▶N View
▶N Categories
C HtmlView
▶N Category
C HtmlView
▶N Newsfeed
C HtmlView
▶N Plugins
▶N Administrator
▶N Controller
C DisplayController
C PluginController
C PluginsController
▶N Field
C PluginElementField
C PluginorderingField
C PluginTypeField
▶N Helper
C PluginsHelper
▶N Model
C PluginModel
C PluginsModel
▶N View
▶N Plugin
C HtmlView
▶N Plugins
C HtmlView
▶N Api
▶N Controller
C PluginsController
▶N View
▶N Plugins
C JsonapiView
▶N Postinstall
▶N Administrator
▶N Controller
C DisplayController
C MessageController
▶N Helper
C PostinstallHelper
▶N Model
C MessagesModel
▶N View
▶N Messages
C HtmlView
▶N Privacy
▶N Administrator
▶N Controller
C ConsentsController
C DisplayController
C RequestController
C RequestsController
▶N Dispatcher
C Dispatcher
▶N Export
C Domain
C Field
C Item
▶N Extension
C PrivacyComponent
▶N Field
C RequeststatusField
C RequesttypeField
▶N Helper
C PrivacyHelper
▶N Model
C CapabilitiesModel
C ConsentsModel
C ExportModel
C RemoveModel
C RequestModel
C RequestsModel
▶N Plugin
C PrivacyPlugin
▶N Removal
C Status
▶N Service
▶N HTML
C Privacy
▶N Table
C ConsentTable
C RequestTable
▶N View
▶N Capabilities
C HtmlView
▶N Consents
C HtmlView
▶N Export
C XmlView
▶N Request
C HtmlView
▶N Requests
C HtmlView
▶N Api
▶N Controller
C ConsentsController
C RequestsController
▶N View
▶N Consents
C JsonapiView
▶N Requests
C JsonapiView
▶N Site
▶N Controller
C DisplayController
C RequestController
▶N Model
C ConfirmModel
C RemindModel
C RequestModel
▶N Service
C Router
▶N View
▶N Confirm
C HtmlView
▶N Remind
C HtmlView
▶N Request
C HtmlView
▶N Redirect
▶N Administrator
▶N Controller
C DisplayController
C LinkController
C LinksController
▶N Extension
C RedirectComponent
▶N Field
C RedirectField
▶N Helper
C RedirectHelper
▶N Model
C LinkModel
C LinksModel
▶N Service
▶N HTML
C Redirect
▶N Table
C LinkTable
▶N View
▶N Link
C HtmlView
▶N Links
C HtmlView
▶N Api
▶N Controller
C RedirectController
▶N View
▶N Redirect
C JsonapiView
▶N Scheduler
▶N Administrator
▶N Controller
C DisplayController
C TaskController
C TasksController
▶N Event
C ExecuteTaskEvent
▶N Extension
C SchedulerComponent
▶N Field
C CronField
C ExecutionRuleField
C IntervalField
C TaskStateField
C TaskTypeField
C WebcronLinkField
▶N Helper
C ExecRuleHelper
C SchedulerHelper
▶N Model
C SelectModel
C TaskModel
C TasksModel
▶N Rule
C ExecutionRulesRule
▶N Scheduler
C Scheduler
▶N Table
C TaskTable
▶N Task
C Status
C Task
C TaskOption
C TaskOptions
▶N View
▶N Select
C HtmlView
▶N Task
C HtmlView
▶N Tasks
C HtmlView
▶N Tags
▶N Administrator
▶N Controller
C DisplayController
C TagController
C TagsController
▶N Extension
C TagsComponent
▶N Model
C TagModel
C TagsModel
▶N Table
C TagTable
▶N View
▶N Tag
C HtmlView
▶N Tags
C HtmlView
▶N Api
▶N Controller
C TagsController
▶N View
▶N Tags
C JsonapiView
▶N Site
▶N Controller
C DisplayController
C TagsController
▶N Helper
C RouteHelper
▶N Model
C TagModel
C TagsModel
▶N Service
C Router
▶N View
▶N Tag
C FeedView
C HtmlView
▶N Tags
C FeedView
C HtmlView
▶N Templates
▶N Administrator
▶N Controller
C DisplayController
C StyleController
C StylesController
C TemplateController
▶N Extension
C TemplatesComponent
▶N Field
C TemplatelocationField
C TemplatenameField
▶N Helper
C TemplateHelper
C TemplatesHelper
▶N Model
C StyleModel
C StylesModel
C TemplateModel
C TemplatesModel
▶N Service
▶N HTML
C Templates
▶N Table
C StyleTable
▶N View
▶N Style
C HtmlView
C JsonView
▶N Styles
C HtmlView
▶N Template
C HtmlView
▶N Templates
C HtmlView
▶N Api
▶N Controller
C StylesController
▶N View
▶N Styles
C JsonapiView
▶N Users
▶N Administrator
▶N Controller
C CallbackController
C CaptiveController
C DisplayController
C GroupController
C GroupsController
C LevelController
C LevelsController
C MailController
C MethodController
C MethodsController
C NoteController
C NotesController
C UserController
C UsersController
▶N DataShape
C CaptiveRenderOptions
C DataShapeObject
C MethodDescriptor
C SetupRenderOptions
▶N Dispatcher
C Dispatcher
▶N Extension
C UsersComponent
▶N Field
C GroupparentField
C LevelsField
C ModulesPositionField
▶N Helper
C DebugHelper
C Mfa
C UsersHelper
▶N Model
C BackupcodesModel
C CaptiveModel
C DebuggroupModel
C DebuguserModel
C GroupModel
C GroupsModel
C LevelModel
C LevelsModel
C MailModel
C MethodModel
C MethodsModel
C NoteModel
C NotesModel
C UserModel
C UsersModel
▶N Service
▶N HTML
C Users
C Encrypt
▶N Table
C MfaTable
C NoteTable
▶N View
▶N Captive
C HtmlView
▶N Debuggroup
C HtmlView
▶N Debuguser
C HtmlView
▶N Group
C HtmlView
▶N Groups
C HtmlView
▶N Level
C HtmlView
▶N Levels
C HtmlView
▶N Mail
C HtmlView
▶N Method
C HtmlView
▶N Methods
C HtmlView
▶N Note
C HtmlView
▶N Notes
C HtmlView
▶N User
C HtmlView
▶N Users
C HtmlView
▶N Api
▶N Controller
C GroupsController
C LevelsController
C UsersController
▶N View
▶N Groups
C JsonapiView
▶N Levels
C JsonapiView
▶N Users
C JsonapiView
▶N Site
▶N Controller
C CallbackController
C CaptiveController
C DisplayController
C MethodController
C MethodsController
C ProfileController
C RegistrationController
C RemindController
C ResetController
C UserController
▶N Model
C BackupcodesModel
C CaptiveModel
C LoginModel
C MethodModel
C MethodsModel
C ProfileModel
C RegistrationModel
C RemindModel
C ResetModel
▶N Rule
C LoginUniqueFieldRule
C LogoutUniqueFieldRule
▶N Service
C Router
▶N View
▶N Captive
C HtmlView
▶N Login
C HtmlView
▶N Method
C HtmlView
▶N Methods
C HtmlView
▶N Profile
C HtmlView
▶N Registration
C HtmlView
▶N Remind
C HtmlView
▶N Reset
C HtmlView
▶N Workflow
▶N Administrator
▶N Controller
C DisplayController
C StageController
C StagesController
C TransitionController
C TransitionsController
C WorkflowController
C WorkflowsController
▶N Dispatcher
C Dispatcher
▶N Field
C ComponentsWorkflowField
C WorkflowcontextsField
▶N Helper
C StageHelper
C WorkflowHelper
▶N Model
C StageModel
C StagesModel
C TransitionModel
C TransitionsModel
C WorkflowModel
C WorkflowsModel
▶N Table
C StageTable
C TransitionTable
C WorkflowTable
▶N View
▶N Stage
C HtmlView
▶N Stages
C HtmlView
▶N Transition
C HtmlView
▶N Transitions
C HtmlView
▶N Workflow
C HtmlView
▶N Workflows
C HtmlView
▶N Wrapper
▶N Administrator
▶N Extension
C WrapperComponent
▶N Site
▶N Controller
C DisplayController
▶N Service
C Router
▶N View
▶N Wrapper
C HtmlView
▶N Console
▶N Command
C AbstractCommand
C HelpCommand
C ListCommand
▶N Descriptor
C ApplicationDescription
C TextDescriptor
▶N Event
C ApplicationErrorEvent
C BeforeCommandExecuteEvent
C CommandErrorEvent
C ConsoleEvent
C TerminateEvent
▶N Exception
C NamespaceNotFoundException
▶N Helper
C DescriptorHelper
▶N Loader
C ContainerLoader
C LoaderInterface
C Application
C ConsoleEvents
▶N Crypt
▶N Cipher
C Crypto
C OpenSSL
C Sodium
▶N Exception
C CryptExceptionInterface
C DecryptionException
C EncryptionException
C InvalidKeyException
C InvalidKeyTypeException
C UnsupportedCipherException
C CipherInterface
C Crypt
C Key
▶N Data
C DataObject
C DataSet
C DumpableInterface
▶N Database
▶N Command
C ExportCommand
C ImportCommand
▶N Event
C ConnectionEvent
▶N Exception
C ConnectionFailureException
C DatabaseNotFoundException
C ExecutionFailureException
C PrepareStatementFailureException
C QueryTypeAlreadyDefinedException
C UnknownTypeException
C UnsupportedAdapterException
▶N Monitor
C ChainedMonitor
C DebugMonitor
C LoggingMonitor
▶N Mysql
C MysqlDriver
C MysqlExporter
C MysqlImporter
C MysqlQuery
▶N Mysqli
C MysqliDriver
C MysqliExporter
C MysqliImporter
C MysqliQuery
C MysqliStatement
▶N Pdo
C PdoDriver
C PdoQuery
C PdoStatement
▶N Pgsql
C PgsqlDriver
C PgsqlExporter
C PgsqlImporter
C PgsqlQuery
▶N Query
C LimitableInterface
C PreparableInterface
C QueryElement
▶N Service
C DatabaseProvider
▶N Sqlazure
C SqlazureDriver
C SqlazureQuery
▶N Sqlite
C SqliteDriver
C SqliteQuery
▶N Sqlsrv
C SqlsrvQuery
C SqlsrvStatement
C DatabaseAwareInterface
C DatabaseDriver
C DatabaseEvents
C DatabaseExporter
C DatabaseFactory
C DatabaseImporter
C DatabaseInterface
C DatabaseIterator
C DatabaseQuery
C FetchMode
C FetchOrientation
C ParameterType
C QueryInterface
C QueryMonitorInterface
C StatementInterface
C UTF8MB4SupportInterface
▶N DI
▶N Exception
C ContainerNotFoundException
C DependencyResolutionException
C KeyNotFoundException
C ProtectedKeyException
C Container
C ContainerAwareInterface
C ContainerResource
C ServiceProviderInterface
▶N Event
▶N Command
C DebugEventDispatcherCommand
C AbstractEvent
C Dispatcher
C DispatcherAwareInterface
C DispatcherInterface
C Event
C EventImmutable
C EventInterface
C LazyServiceEventListener
C ListenersPriorityQueue
C Priority
C SubscriberInterface
▶N Filesystem
▶N Clients
C FtpClient
▶N Exception
C FilesystemException
▶N Stream
C StringWrapper
▶N Support
C StringController
C Buffer
C File
C Folder
C Helper
C Patcher
C Path
C Stream
▶N Filter
C InputFilter
C OutputFilter
▶N Http
▶N Exception
C InvalidResponseCodeException
C UnexpectedResponseException
▶N Transport
C Curl
C Socket
C Stream
C AbstractTransport
C Http
C HttpFactory
C Response
C TransportInterface
▶N Input
C Cookie
C Files
C Input
C Json
▶N Ldap
C LdapClient
▶N Module
▶N ArticlesArchive
▶N Site
▶N Helper
C ArticlesArchiveHelper
▶N ArticlesCategories
▶N Site
▶N Helper
C ArticlesCategoriesHelper
▶N ArticlesCategory
▶N Site
▶N Helper
C ArticlesCategoryHelper
▶N ArticlesLatest
▶N Site
▶N Dispatcher
C Dispatcher
▶N Helper
C ArticlesLatestHelper
▶N ArticlesNews
▶N Site
▶N Dispatcher
C Dispatcher
▶N Helper
C ArticlesNewsHelper
▶N ArticlesPopular
▶N Site
▶N Helper
C ArticlesPopularHelper
▶N Banners
▶N Site
▶N Helper
C BannersHelper
▶N Breadcrumbs
▶N Site
▶N Helper
C BreadcrumbsHelper
▶N Feed
▶N Administrator
▶N Helper
C FeedHelper
▶N Site
▶N Helper
C FeedHelper
▶N Finder
▶N Site
▶N Helper
C FinderHelper
▶N Languages
▶N Site
▶N Helper
C LanguagesHelper
▶N Latest
▶N Administrator
▶N Helper
C LatestHelper
▶N LatestActions
▶N Administrator
▶N Helper
C LatestActionsHelper
▶N Logged
▶N Administrator
▶N Helper
C LoggedHelper
▶N Login
▶N Administrator
▶N Helper
C LoginHelper
▶N Site
▶N Helper
C LoginHelper
▶N Menu
▶N Administrator
▶N Menu
C CssMenu
▶N Site
▶N Helper
C MenuHelper
▶N Popular
▶N Administrator
▶N Helper
C PopularHelper
▶N PrivacyDashboard
▶N Administrator
▶N Helper
C PrivacyDashboardHelper
▶N PrivacyStatus
▶N Administrator
▶N Helper
C PrivacyStatusHelper
▶N Quickicon
▶N Administrator
▶N Dispatcher
C Dispatcher
▶N Event
C QuickIconsEvent
▶N Helper
C QuickIconHelper
▶N RandomImage
▶N Site
▶N Helper
C RandomImageHelper
▶N RelatedItems
▶N Site
▶N Helper
C RelatedItemsHelper
▶N Sampledata
▶N Administrator
▶N Helper
C SampledataHelper
▶N Stats
▶N Site
▶N Helper
C StatsHelper
▶N StatsAdmin
▶N Administrator
▶N Helper
C StatsAdminHelper
▶N Submenu
▶N Administrator
▶N Menu
C Menu
▶N Syndicate
▶N Site
▶N Helper
C SyndicateHelper
▶N TagsPopular
▶N Site
▶N Helper
C TagsPopularHelper
▶N TagsSimilar
▶N Site
▶N Helper
C TagsSimilarHelper
▶N UsersLatest
▶N Site
▶N Helper
C UsersLatestHelper
▶N Version
▶N Administrator
▶N Helper
C VersionHelper
▶N Whosonline
▶N Site
▶N Helper
C WhosonlineHelper
▶N Wrapper
▶N Site
▶N Helper
C WrapperHelper
▶N OAuth1
C Client
▶N OAuth2
C Client
▶N Plugin
▶N Actionlog
▶N Joomla
▶N Extension
C Joomla
▶N ApiAuthentication
▶N Basic
▶N Extension
C Basic
▶N Token
▶N Extension
C Token
▶N Behaviour
▶N Taggable
▶N Extension
C Taggable
▶N Versionable
▶N Extension
C Versionable
▶N Content
▶N ConfirmConsent
▶N Field
C ConsentBoxField
▶N Editors
▶N CodeMirror
▶N Field
C FontsField
▶N TinyMCE
▶N Field
C TemplatesListField
C TinymcebuilderField
C UploaddirsField
▶N Filesystem
▶N Local
▶N Adapter
C LocalAdapter
▶N Multifactorauth
▶N Email
▶N Extension
C Email
▶N Fixed
▶N Extension
C Fixed
▶N Totp
▶N Extension
C Totp
▶N Webauthn
▶N Extension
C Webauthn
▶N Helper
C Credentials
▶N Hotfix
C AndroidKeyAttestationStatementSupport
C FidoU2FAttestationStatementSupport
C Server
C CredentialRepository
▶N Yubikey
▶N Extension
C Yubikey
▶N Quickicon
▶N Joomlaupdate
▶N Extension
C Joomlaupdate
▶N System
▶N Cache
▶N Extension
C Cache
▶N Debug
▶N DataCollector
C InfoCollector
C LanguageErrorsCollector
C LanguageFilesCollector
C LanguageStringsCollector
C ProfileCollector
C QueryCollector
C SessionCollector
▶N Storage
C FileStorage
C AbstractDataCollector
C DataFormatter
C JavascriptRenderer
C JoomlaHttpDriver
▶N PrivacyConsent
▶N Field
C PrivacyField
▶N Shortcut
▶N Extension
C Shortcut
▶N Stats
▶N Field
C AbstractStatsField
C DataField
C UniqueidField
▶N Webauthn
▶N Extension
C Webauthn
▶N Field
C WebauthnField
▶N Hotfix
C AndroidKeyAttestationStatementSupport
C FidoU2FAttestationStatementSupport
C Server
C Authentication
C CredentialRepository
C MetadataRepository
▶N Task
▶N Checkfiles
▶N Extension
C Checkfiles
▶N DemoTasks
▶N Extension
C DemoTasks
▶N Requests
▶N Extension
C Requests
▶N SiteStatus
▶N Extension
C SiteStatus
▶N User
▶N Profile
▶N Field
C TosField
▶N Terms
▶N Field
C TermsField
▶N Token
▶N Field
C JoomlatokenField
▶N Registry
▶N Format
C Ini
C Json
C Php
C Xml
C Yaml
C Factory
C FormatInterface
C Registry
▶N Router
▶N Command
C DebugRouterCommand
▶N Exception
C MethodNotAllowedException
C RouteNotFoundException
C ResolvedRoute
C Route
C Router
C RouterInterface
▶N Session
▶N Command
C CreateSessionTableCommand
▶N Exception
C CreateSessionTableException
C InvalidSessionException
C UnsupportedDatabaseDriverException
▶N Handler
C ApcuHandler
C DatabaseHandler
C FilesystemHandler
C MemcachedHandler
C RedisHandler
C WincacheHandler
▶N Storage
C NativeStorage
C RuntimeStorage
▶N Validator
C AddressValidator
C ForwardedValidator
C HandlerInterface
C Session
C SessionEvent
C SessionEvents
C SessionInterface
C SessionState
C StorageInterface
C ValidatorInterface
▶N String
C Inflector
C Normalise
C StringHelper
▶N Uri
C AbstractUri
C Uri
C UriHelper
C UriImmutable
C UriInterface
▶N Utilities
C ArrayHelper
C IpHelper
▶N Jose
▶N Component
▶N Core
▶N Util
C BigInteger
C ECKey
C ECSignature
C Hash
C JsonConverter
C KeyChecker
C RSAKey
C Algorithm
C AlgorithmManager
C AlgorithmManagerFactory
C JWK
C JWKSet
C JWT
▶N Signature
▶N Algorithm
▶N Util
C RSA
C ECDSA
C EdDSA
C ES256
C ES256K
C ES384
C ES512
C HMAC
C HS1
C HS256
C HS256_64
C HS384
C HS512
C MacAlgorithm
C None
C PS256
C PS384
C PS512
C RS1
C RS256
C RS384
C RS512
C RSA
C RSAPKCS1
C RSAPSS
C SignatureAlgorithm
▶N Serializer
C CompactSerializer
C JSONFlattenedSerializer
C JSONGeneralSerializer
C JWSSerializer
C JWSSerializerManager
C JWSSerializerManagerFactory
C Serializer
C JWS
C JWSBuilder
C JWSBuilderFactory
C JWSLoader
C JWSLoaderFactory
C JWSTokenSupport
C JWSVerifier
C JWSVerifierFactory
C Signature
▶N Laminas
▶N Diactoros
▶N Exception
C DeserializationException
C ExceptionInterface
C InvalidArgumentException
C InvalidStreamPointerPositionException
C SerializationException
C UnreadableStreamException
C UnrecognizedProtocolVersionException
C UnrewindableStreamException
C UnseekableStreamException
C UntellableStreamException
C UnwritableStreamException
C UploadedFileAlreadyMovedException
C UploadedFileErrorException
▶N Request
C ArraySerializer
C Serializer
▶N Response
C ArraySerializer
C EmptyResponse
C HtmlResponse
C JsonResponse
C RedirectResponse
C Serializer
C TextResponse
C XmlResponse
C AbstractSerializer
C CallbackStream
C ConfigProvider
C HeaderSecurity
C Module
C PhpInputStream
C RelativeStream
C Request
C RequestFactory
C Response
C ResponseFactory
C ServerRequest
C ServerRequestFactory
C Stream
C StreamFactory
C UploadedFile
C UploadedFileFactory
C Uri
C UriFactory
▶N ZendFrameworkBridge
C Autoloader
C ConfigPostProcessor
C Module
C Replacements
C RewriteRules
▶N Lcobucci
▶N JWT
▶N Claim
C Basic
C EqualsTo
C Factory
C GreaterOrEqualsTo
C LesserOrEqualsTo
C Validatable
▶N Encoding
C CannotDecodeContent
C CannotEncodeContent
▶N Parsing
C Decoder
C Encoder
▶N Signer
▶N Ecdsa
C ConversionFailed
C MultibyteStringConverter
C Sha256
C Sha384
C Sha512
C SignatureConverter
▶N Hmac
C Sha256
C Sha384
C Sha512
▶N Key
C InMemory
C LocalFileReference
▶N Rsa
C Sha256
C Sha384
C Sha512
C BaseSigner
C CannotSignPayload
C Ecdsa
C Hmac
C InvalidKeyProvided
C Key
C Keychain
C None
C OpenSSL
C Rsa
▶N Token
C DataSet
C InvalidTokenStructure
C RegisteredClaimGiven
C RegisteredClaims
C UnsupportedHeaderFound
▶N Validation
▶N Constraint
C IdentifiedBy
C IssuedBy
C LeewayCannotBeNegative
C PermittedFor
C RelatedTo
C SignedWith
C ValidAt
C Constraint
C ConstraintViolation
C NoConstraintsGiven
C RequiredConstraintsViolated
C Validator
C Builder
C Claim
C Configuration
C Parser
C Signature
C Signer
C Token
C ValidationData
C Validator
▶N Negotiation
▶N Exception
C Exception
C InvalidArgument
C InvalidHeader
C InvalidLanguage
C InvalidMediaType
C AbstractNegotiator
C Accept
C AcceptCharset
C AcceptEncoding
C AcceptHeader
C AcceptLanguage
C AcceptMatch
C BaseAccept
C CharsetNegotiator
C EncodingNegotiator
C LanguageNegotiator
C Negotiator
▶N Nyholm
▶N Psr7
▶N Factory
C HttplugFactory
C Psr17Factory
C Request
C Response
C ServerRequest
C Stream
C UploadedFile
C Uri
▶N ParagonIE
▶N ConstantTime
C Base32
C Base32Hex
C Base64
C Base64DotSlash
C Base64DotSlashOrdered
C Base64UrlSafe
C Binary
C EncoderInterface
C Encoding
C Hex
C RFC4648
▶N Sodium
▶N Core
▶N ChaCha20
C Ctx
C IetfCtx
▶N Curve25519
▶N Ge
C Cached
C P1p1
C P2
C P3
C Precomp
C Fe
C H
▶N Poly1305
C State
C BLAKE2b
C ChaCha20
C Curve25519
C Ed25519
C HChaCha20
C HSalsa20
C Poly1305
C Salsa20
C SipHash
C Util
C X25519
C XChaCha20
C Xsalsa20
C Compat
C Crypto
C File
▶N PHPMailer
▶N PHPMailer
C Exception
C OAuth
C OAuthTokenProvider
C PHPMailer
C POP3
C SMTP
▶N phpseclib3
▶N Common
▶N Functions
C Strings
▶N Crypt
▶N Common
▶N Formats
▶N Keys
C OpenSSH
C PKCS
C PKCS1
C PKCS8
C PuTTY
▶N Signature
C Raw
C AsymmetricKey
C BlockCipher
C PrivateKey
C PublicKey
C StreamCipher
C SymmetricKey
▶N DH
▶N Formats
▶N Keys
C PKCS1
C PKCS8
C Parameters
C PrivateKey
C PublicKey
▶N DSA
▶N Formats
▶N Keys
C OpenSSH
C PKCS1
C PKCS8
C PuTTY
C Raw
C XML
▶N Signature
C ASN1
C Raw
C SSH2
C Parameters
C PrivateKey
C PublicKey
▶N EC
▶N BaseCurves
C Base
C Binary
C KoblitzPrime
C Montgomery
C Prime
C TwistedEdwards
▶N Curves
C brainpoolP160r1
C brainpoolP160t1
C brainpoolP192r1
C brainpoolP192t1
C brainpoolP224r1
C brainpoolP224t1
C brainpoolP256r1
C brainpoolP256t1
C brainpoolP320r1
C brainpoolP320t1
C brainpoolP384r1
C brainpoolP384t1
C brainpoolP512r1
C brainpoolP512t1
C Curve25519
C Curve448
C Ed25519
C Ed448
C nistb233
C nistb409
C nistk163
C nistk233
C nistk283
C nistk409
C nistp192
C nistp224
C nistp256
C nistp384
C nistp521
C nistt571
C prime192v1
C prime192v2
C prime192v3
C prime239v1
C prime239v2
C prime239v3
C prime256v1
C secp112r1
C secp112r2
C secp128r1
C secp128r2
C secp160k1
C secp160r1
C secp160r2
C secp192k1
C secp192r1
C secp224k1
C secp224r1
C secp256k1
C secp256r1
C secp384r1
C secp521r1
C sect113r1
C sect113r2
C sect131r1
C sect131r2
C sect163k1
C sect163r1
C sect163r2
C sect193r1
C sect193r2
C sect233k1
C sect233r1
C sect239k1
C sect283k1
C sect283r1
C sect409k1
C sect409r1
C sect571k1
C sect571r1
▶N Formats
▶N Keys
C libsodium
C MontgomeryPrivate
C MontgomeryPublic
C OpenSSH
C PKCS1
C PKCS8
C PuTTY
C XML
▶N Signature
C ASN1
C Raw
C SSH2
C Parameters
C PrivateKey
C PublicKey
▶N RSA
▶N Formats
▶N Keys
C MSBLOB
C OpenSSH
C PKCS1
C PKCS8
C PSS
C PuTTY
C Raw
C XML
C PrivateKey
C PublicKey
C AES
C Blowfish
C ChaCha20
C DES
C DH
C DSA
C EC
C Hash
C PublicKeyLoader
C Random
C RC2
C RC4
C Rijndael
C RSA
C Salsa20
C TripleDES
C Twofish
▶N Exception
C BadConfigurationException
C BadDecryptionException
C BadModeException
C ConnectionClosedException
C FileNotFoundException
C InconsistentSetupException
C InsufficientSetupException
C NoKeyLoadedException
C NoSupportedAlgorithmsException
C UnableToConnectException
C UnsupportedAlgorithmException
C UnsupportedCurveException
C UnsupportedFormatException
C UnsupportedOperationException
▶N File
▶N ASN1
▶N Maps
C AccessDescription
C AdministrationDomainName
C AlgorithmIdentifier
C AnotherName
C Attribute
C Attributes
C AttributeType
C AttributeTypeAndValue
C AttributeValue
C AuthorityInfoAccessSyntax
C AuthorityKeyIdentifier
C BaseDistance
C BasicConstraints
C BuiltInDomainDefinedAttribute
C BuiltInDomainDefinedAttributes
C BuiltInStandardAttributes
C Certificate
C CertificateIssuer
C CertificateList
C CertificatePolicies
C CertificateSerialNumber
C CertificationRequest
C CertificationRequestInfo
C CertPolicyId
C Characteristic_two
C CountryName
C CPSuri
C CRLDistributionPoints
C CRLNumber
C CRLReason
C Curve
C DHParameter
C DigestInfo
C DirectoryString
C DisplayText
C DistributionPoint
C DistributionPointName
C DSAParams
C DSAPrivateKey
C DSAPublicKey
C DssSigValue
C EcdsaSigValue
C ECParameters
C ECPoint
C ECPrivateKey
C EDIPartyName
C EncryptedData
C EncryptedPrivateKeyInfo
C Extension
C ExtensionAttribute
C ExtensionAttributes
C Extensions
C ExtKeyUsageSyntax
C FieldElement
C FieldID
C GeneralName
C GeneralNames
C GeneralSubtree
C GeneralSubtrees
C HashAlgorithm
C HoldInstructionCode
C InvalidityDate
C IssuerAltName
C IssuingDistributionPoint
C KeyIdentifier
C KeyPurposeId
C KeyUsage
C MaskGenAlgorithm
C Name
C NameConstraints
C netscape_ca_policy_url
C netscape_cert_type
C netscape_comment
C NetworkAddress
C NoticeReference
C NumericUserIdentifier
C OneAsymmetricKey
C ORAddress
C OrganizationalUnitNames
C OrganizationName
C OtherPrimeInfo
C OtherPrimeInfos
C PBEParameter
C PBES2params
C PBKDF2params
C PBMAC1params
C Pentanomial
C PersonalName
C PKCS9String
C PolicyInformation
C PolicyMappings
C PolicyQualifierId
C PolicyQualifierInfo
C PostalAddress
C Prime_p
C PrivateDomainName
C PrivateKey
C PrivateKeyInfo
C PrivateKeyUsagePeriod
C PublicKey
C PublicKeyAndChallenge
C PublicKeyInfo
C RC2CBCParameter
C RDNSequence
C ReasonFlags
C RelativeDistinguishedName
C RevokedCertificate
C RSAPrivateKey
C RSAPublicKey
C RSASSA_PSS_params
C SignedPublicKeyAndChallenge
C SpecifiedECDomain
C SubjectAltName
C SubjectDirectoryAttributes
C SubjectInfoAccessSyntax
C SubjectPublicKeyInfo
C TBSCertificate
C TBSCertList
C TerminalIdentifier
C Time
C Trinomial
C UniqueIdentifier
C UserNotice
C Validity
C Element
C ANSI
C ASN1
C X509
▶N Math
▶N BigInteger
▶N Engines
▶N BCMath
▶N Reductions
C Barrett
C EvalBarrett
C Base
C BuiltIn
C DefaultEngine
C OpenSSL
▶N GMP
C DefaultEngine
▶N PHP
▶N Reductions
C Barrett
C Classic
C EvalBarrett
C Montgomery
C MontgomeryMult
C PowerOfTwo
C Base
C DefaultEngine
C Montgomery
C OpenSSL
C BCMath
C Engine
C GMP
C OpenSSL
C PHP
C PHP32
C PHP64
▶N BinaryField
C Integer
▶N Common
▶N FiniteField
C Integer
C FiniteField
▶N PrimeField
C Integer
C BigInteger
C BinaryField
C PrimeField
▶N Net
▶N SFTP
C Stream
C SFTP
C SSH2
▶N System
▶N SSH
▶N Agent
C Identity
▶N Common
C Agent
▶N Psr
▶N Container
C ContainerExceptionInterface
C ContainerInterface
C NotFoundExceptionInterface
▶N Http
▶N Client
C ClientExceptionInterface
C ClientInterface
C NetworkExceptionInterface
C RequestExceptionInterface
▶N Message
C MessageInterface
C RequestFactoryInterface
C RequestInterface
C ResponseFactoryInterface
C ResponseInterface
C ServerRequestFactoryInterface
C ServerRequestInterface
C StreamFactoryInterface
C StreamInterface
C UploadedFileFactoryInterface
C UploadedFileInterface
C UriFactoryInterface
C UriInterface
▶N Link
C EvolvableLinkInterface
C EvolvableLinkProviderInterface
C LinkInterface
C LinkProviderInterface
▶N Log
C AbstractLogger
C InvalidArgumentException
C LoggerAwareInterface
C LoggerInterface
C LogLevel
C NullLogger
▶N Ramsey
▶N Uuid
▶N Builder
C DefaultUuidBuilder
C DegradedUuidBuilder
C UuidBuilderInterface
▶N Codec
C CodecInterface
C GuidStringCodec
C OrderedTimeCodec
C StringCodec
C TimestampFirstCombCodec
C TimestampLastCombCodec
▶N Converter
▶N Number
C BigNumberConverter
C DegradedNumberConverter
▶N Time
C BigNumberTimeConverter
C DegradedTimeConverter
C PhpTimeConverter
C NumberConverterInterface
C TimeConverterInterface
▶N Exception
C InvalidUuidStringException
C UnsatisfiedDependencyException
C UnsupportedOperationException
▶N Generator
C CombGenerator
C DefaultTimeGenerator
C MtRandGenerator
C OpenSslGenerator
C PeclUuidRandomGenerator
C PeclUuidTimeGenerator
C RandomBytesGenerator
C RandomGeneratorFactory
C RandomGeneratorInterface
C RandomLibAdapter
C SodiumRandomGenerator
C TimeGeneratorFactory
C TimeGeneratorInterface
▶N Provider
▶N Node
C FallbackNodeProvider
C RandomNodeProvider
C SystemNodeProvider
▶N Time
C FixedTimeProvider
C SystemTimeProvider
C NodeProviderInterface
C TimeProviderInterface
C BinaryUtils
C DegradedUuid
C FeatureSet
C Uuid
C UuidFactory
C UuidFactoryInterface
C UuidInterface
▶N ReCaptcha
▶N RequestMethod
C Curl
C CurlPost
C Post
C Socket
C SocketPost
C ReCaptcha
C RequestMethod
C RequestParameters
C Response
▶N Symfony
▶N Component
▶N Console
▶N Attribute
C AsCommand
▶N CI
C GithubActionReporter
▶N Command
C Command
C CompleteCommand
C DumpCompletionCommand
C HelpCommand
C LazyCommand
C ListCommand
C SignalableCommandInterface
▶N CommandLoader
C CommandLoaderInterface
C ContainerCommandLoader
C FactoryCommandLoader
▶N Completion
▶N Output
C BashCompletionOutput
C CompletionOutputInterface
C CompletionInput
C CompletionSuggestions
C Suggestion
▶N DependencyInjection
C AddConsoleCommandPass
▶N Descriptor
C ApplicationDescription
C Descriptor
C DescriptorInterface
C JsonDescriptor
C MarkdownDescriptor
C TextDescriptor
C XmlDescriptor
▶N Event
C ConsoleCommandEvent
C ConsoleErrorEvent
C ConsoleEvent
C ConsoleSignalEvent
C ConsoleTerminateEvent
▶N EventListener
C ErrorListener
▶N Exception
C CommandNotFoundException
C ExceptionInterface
C InvalidArgumentException
C InvalidOptionException
C LogicException
C MissingInputException
C NamespaceNotFoundException
C RuntimeException
▶N Formatter
C NullOutputFormatter
C NullOutputFormatterStyle
C OutputFormatter
C OutputFormatterInterface
C OutputFormatterStyle
C OutputFormatterStyleInterface
C OutputFormatterStyleStack
C WrappableOutputFormatterInterface
▶N Helper
C DebugFormatterHelper
C DescriptorHelper
C Dumper
C FormatterHelper
C Helper
C HelperInterface
C HelperSet
C InputAwareHelper
C ProcessHelper
C ProgressBar
C ProgressIndicator
C QuestionHelper
C SymfonyQuestionHelper
C Table
C TableCell
C TableCellStyle
C TableRows
C TableSeparator
C TableStyle
▶N Input
C ArgvInput
C ArrayInput
C Input
C InputArgument
C InputAwareInterface
C InputDefinition
C InputInterface
C InputOption
C StreamableInputInterface
C StringInput
▶N Logger
C ConsoleLogger
▶N Output
C BufferedOutput
C ConsoleOutput
C ConsoleOutputInterface
C ConsoleSectionOutput
C NullOutput
C Output
C OutputInterface
C StreamOutput
C TrimmedBufferOutput
▶N Question
C ChoiceQuestion
C ConfirmationQuestion
C Question
▶N SignalRegistry
C SignalRegistry
▶N Style
C OutputStyle
C StyleInterface
C SymfonyStyle
▶N Tester
▶N Constraint
C CommandIsSuccessful
C ApplicationTester
C CommandCompletionTester
C CommandTester
C Application
C Color
C ConsoleEvents
C Cursor
C SingleCommandApplication
C Terminal
▶N ErrorHandler
▶N Error
C ClassNotFoundError
C FatalError
C OutOfMemoryError
C UndefinedFunctionError
C UndefinedMethodError
▶N ErrorEnhancer
C ClassNotFoundErrorEnhancer
C ErrorEnhancerInterface
C UndefinedFunctionErrorEnhancer
C UndefinedMethodErrorEnhancer
▶N ErrorRenderer
C CliErrorRenderer
C ErrorRendererInterface
C HtmlErrorRenderer
C SerializerErrorRenderer
▶N Exception
C FlattenException
C SilencedErrorContext
▶N Internal
C TentativeTypes
C BufferingLogger
C Debug
C DebugClassLoader
C ErrorHandler
C ThrowableUtils
▶N Ldap
▶N Adapter
▶N ExtLdap
C Adapter
C Collection
C Connection
C ConnectionOptions
C EntryManager
C Query
C UpdateOperation
C AbstractConnection
C AbstractQuery
C AdapterInterface
C CollectionInterface
C ConnectionInterface
C EntryManagerInterface
C QueryInterface
▶N Exception
C AlreadyExistsException
C ConnectionException
C ConnectionTimeoutException
C DriverNotFoundException
C ExceptionInterface
C InvalidCredentialsException
C LdapException
C NotBoundException
C UpdateOperationException
▶N Security
C CheckLdapCredentialsListener
C LdapAuthenticator
C LdapBadge
C LdapUser
C LdapUserProvider
C Entry
C Ldap
C LdapInterface
▶N OptionsResolver
▶N Debug
C OptionsResolverIntrospector
▶N Exception
C AccessException
C ExceptionInterface
C InvalidArgumentException
C InvalidOptionsException
C MissingOptionsException
C NoConfigurationException
C NoSuchOptionException
C OptionDefinitionException
C UndefinedOptionsException
C OptionConfigurator
C Options
C OptionsResolver
▶N String
▶N Exception
C ExceptionInterface
C InvalidArgumentException
C RuntimeException
▶N Inflector
C EnglishInflector
C FrenchInflector
C InflectorInterface
▶N Slugger
C AsciiSlugger
C SluggerInterface
C AbstractString
C AbstractUnicodeString
C ByteString
C CodePointString
C LazyString
C UnicodeString
▶N VarDumper
▶N Caster
C AmqpCaster
C ArgsStub
C Caster
C ClassStub
C ConstStub
C CutArrayStub
C CutStub
C DateCaster
C DoctrineCaster
C DOMCaster
C DsCaster
C DsPairStub
C EnumStub
C ExceptionCaster
C FiberCaster
C FrameStub
C GmpCaster
C ImagineCaster
C ImgStub
C IntlCaster
C LinkStub
C MemcachedCaster
C MysqliCaster
C PdoCaster
C PgSqlCaster
C ProxyManagerCaster
C RdKafkaCaster
C RedisCaster
C ReflectionCaster
C ResourceCaster
C SplCaster
C StubCaster
C SymfonyCaster
C TraceStub
C UuidCaster
C XmlReaderCaster
C XmlResourceCaster
▶N Cloner
C AbstractCloner
C ClonerInterface
C Cursor
C Data
C DumperInterface
C Stub
C VarCloner
▶N Command
▶N Descriptor
C CliDescriptor
C DumpDescriptorInterface
C HtmlDescriptor
C ServerDumpCommand
▶N Dumper
▶N ContextProvider
C CliContextProvider
C ContextProviderInterface
C RequestContextProvider
C SourceContextProvider
C AbstractDumper
C CliDumper
C ContextualizedDumper
C DataDumperInterface
C HtmlDumper
C ServerDumper
▶N Exception
C ThrowingCasterException
▶N Server
C Connection
C DumpServer
C VarDumper
▶N WebLink
▶N EventListener
C AddLinkHeaderListener
C GenericLinkProvider
C HttpHeaderSerializer
C Link
▶N Yaml
▶N Command
C LintCommand
▶N Exception
C DumpException
C ExceptionInterface
C ParseException
C RuntimeException
▶N Tag
C TaggedValue
C Dumper
C Escaper
C Inline
C Parser
C Unescaper
C Yaml
▶N Contracts
▶N Service
▶N Attribute
C Required
C SubscribedService
▶N Test
C ServiceLocatorTest
C ResetInterface
C ServiceProviderInterface
C ServiceSubscriberInterface
▶N Polyfill
▶N Ctype
C Ctype
▶N Iconv
C Iconv
▶N Intl
▶N Grapheme
C Grapheme
▶N Normalizer
C Normalizer
▶N Mbstring
C Mbstring
▶N Php72
C Php72
▶N Php73
C Php73
▶N Php80
C Php80
C PhpToken
▶N Tobscure
▶N JsonApi
▶N Exception
▶N Handler
C ExceptionHandlerInterface
C FallbackExceptionHandler
C InvalidParameterExceptionHandler
C ResponseBag
C InvalidParameterException
C AbstractSerializer
C Collection
C Document
C ElementInterface
C ErrorHandler
C Parameters
C Relationship
C Resource
C SerializerInterface
C Util
▶N TYPO3
▶N PharStreamWrapper
▶N Interceptor
C ConjunctionInterceptor
C PharExtensionInterceptor
C PharMetaDataInterceptor
▶N Phar
C Container
C DeserializationException
C Manifest
C Reader
C ReaderException
C Stub
▶N Resolver
C PharInvocation
C PharInvocationCollection
C PharInvocationResolver
C Assertable
C Behavior
C Collectable
C Exception
C Helper
C Manager
C PharStreamWrapper
C Resolvable
▶N voku
▶N helper
C ASCII
C Bootup
▶N Wamania
▶N Snowball
▶N Stemmer
C Catalan
C Danish
C Dutch
C English
C Finnish
C French
C German
C Italian
C Norwegian
C Portuguese
C Romanian
C Russian
C Spanish
C Stem
C Stemmer
C Swedish
C NotFoundException
C StemmerFactory
C StemmerManager
▶N Webauthn
▶N AttestationStatement
C AndroidKeyAttestationStatementSupport
C AndroidSafetyNetAttestationStatementSupport
C AttestationObject
C AttestationObjectLoader
C AttestationStatement
C AttestationStatementSupport
C AttestationStatementSupportManager
C FidoU2FAttestationStatementSupport
C NoneAttestationStatementSupport
C PackedAttestationStatementSupport
C TPMAttestationStatementSupport
▶N AuthenticationExtensions
C AuthenticationExtension
C AuthenticationExtensionsClientInputs
C AuthenticationExtensionsClientOutputs
C AuthenticationExtensionsClientOutputsLoader
C ExtensionOutputChecker
C ExtensionOutputCheckerHandler
C ExtensionOutputError
▶N MetadataService
C AuthenticatorStatus
C BiometricAccuracyDescriptor
C BiometricStatusReport
C CodeAccuracyDescriptor
C DisplayPNGCharacteristicsDescriptor
C DistantSingleMetadata
C DistantSingleMetadataFactory
C EcdaaTrustAnchor
C ExtensionDescriptor
C MetadataService
C MetadataServiceFactory
C MetadataStatement
C MetadataStatementFetcher
C MetadataStatementRepository
C MetadataTOCPayload
C MetadataTOCPayloadEntry
C PatternAccuracyDescriptor
C RgbPaletteEntry
C RogueListEntry
C SimpleMetadataStatementRepository
C SingleMetadata
C StatusReport
C VerificationMethodANDCombinations
C VerificationMethodDescriptor
C Version
▶N TokenBinding
C IgnoreTokenBindingHandler
C TokenBinding
C TokenBindingHandler
C TokenBindingNotSupportedHandler
▶N TrustPath
C CertificateTrustPath
C EcdaaKeyIdTrustPath
C EmptyTrustPath
C TrustPath
C TrustPathLoader
▶N Util
C CoseSignatureFixer
C AttestedCredentialData
C AuthenticatorAssertionResponse
C AuthenticatorAssertionResponseValidator
C AuthenticatorAttestationResponse
C AuthenticatorAttestationResponseValidator
C AuthenticatorData
C AuthenticatorResponse
C AuthenticatorSelectionCriteria
C CertificateToolbox
C CollectedClientData
C Credential
C PublicKeyCredential
C PublicKeyCredentialCreationOptions
C PublicKeyCredentialDescriptor
C PublicKeyCredentialDescriptorCollection
C PublicKeyCredentialEntity
C PublicKeyCredentialLoader
C PublicKeyCredentialOptions
C PublicKeyCredentialParameters
C PublicKeyCredentialRequestOptions
C PublicKeyCredentialRpEntity
C PublicKeyCredentialSource
C PublicKeyCredentialSourceRepository
C PublicKeyCredentialUserEntity
C Server
C StringStream
▶N Webmozart
▶N Assert
C Assert
C InvalidArgumentException
▶N Zend
C Attribute
C BannersHelper
C CannotPerformOperationException
C CategoriesHelper
C ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f
C ContactHelper
C ContactHelperRoute
C ContentHelper
C ContenthistoryHelper
C Crypto
C CryptoExceptionHandler
C CryptoTestFailedException
C En_GBLocalise
C FieldsHelper
C FinderHelperLanguage
C FinderHelperRoute
C Fr_FRLocalise
C InstallerHelper
C InvalidCiphertextException
C JHtmlIcon
C JLoader
C JNamespacePsr4Map
C JoomlaInstallerScript
C MediaHelper
C MenusHelper
C ModulesHelper
C NewsfeedsHelper
C NewsfeedsHelperRoute
C Normalizer
C ParagonIE_Sodium_Compat
C ParagonIE_Sodium_Core32_BLAKE2b
C ParagonIE_Sodium_Core32_ChaCha20
C ParagonIE_Sodium_Core32_ChaCha20_Ctx
C ParagonIE_Sodium_Core32_ChaCha20_IetfCtx
C ParagonIE_Sodium_Core32_Curve25519
C ParagonIE_Sodium_Core32_Curve25519_Fe
C ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
C ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1
C ParagonIE_Sodium_Core32_Curve25519_Ge_P2
C ParagonIE_Sodium_Core32_Curve25519_Ge_P3
C ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
C ParagonIE_Sodium_Core32_Curve25519_H
C ParagonIE_Sodium_Core32_Ed25519
C ParagonIE_Sodium_Core32_HChaCha20
C ParagonIE_Sodium_Core32_HSalsa20
C ParagonIE_Sodium_Core32_Int32
C ParagonIE_Sodium_Core32_Int64
C ParagonIE_Sodium_Core32_Poly1305
C ParagonIE_Sodium_Core32_Poly1305_State
C ParagonIE_Sodium_Core32_Salsa20
C ParagonIE_Sodium_Core32_SecretStream_State
C ParagonIE_Sodium_Core32_SipHash
C ParagonIE_Sodium_Core32_Util
C ParagonIE_Sodium_Core32_X25519
C ParagonIE_Sodium_Core32_XChaCha20
C ParagonIE_Sodium_Core32_XSalsa20
C ParagonIE_Sodium_Core_Base64_Common
C ParagonIE_Sodium_Core_Base64_Original
C ParagonIE_Sodium_Core_Base64_UrlSafe
C ParagonIE_Sodium_Core_BLAKE2b
C ParagonIE_Sodium_Core_ChaCha20
C ParagonIE_Sodium_Core_ChaCha20_Ctx
C ParagonIE_Sodium_Core_ChaCha20_IetfCtx
C ParagonIE_Sodium_Core_Curve25519
C ParagonIE_Sodium_Core_Curve25519_Fe
C ParagonIE_Sodium_Core_Curve25519_Ge_Cached
C ParagonIE_Sodium_Core_Curve25519_Ge_P1p1
C ParagonIE_Sodium_Core_Curve25519_Ge_P2
C ParagonIE_Sodium_Core_Curve25519_Ge_P3
C ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
C ParagonIE_Sodium_Core_Curve25519_H
C ParagonIE_Sodium_Core_Ed25519
C ParagonIE_Sodium_Core_HChaCha20
C ParagonIE_Sodium_Core_HSalsa20
C ParagonIE_Sodium_Core_Poly1305
C ParagonIE_Sodium_Core_Poly1305_State
C ParagonIE_Sodium_Core_Ristretto255
C ParagonIE_Sodium_Core_Salsa20
C ParagonIE_Sodium_Core_SecretStream_State
C ParagonIE_Sodium_Core_SipHash
C ParagonIE_Sodium_Core_Util
C ParagonIE_Sodium_Core_X25519
C ParagonIE_Sodium_Core_XChaCha20
C ParagonIE_Sodium_Core_XSalsa20
C ParagonIE_Sodium_Crypto
C ParagonIE_Sodium_Crypto32
C ParagonIE_Sodium_File
C PasswordHash
C PlgAuthenticationCookie
C PlgAuthenticationJoomla
C PlgAuthenticationLdap
C PlgButtonArticle
C PlgButtonContact
C PlgButtonFields
C PlgButtonImage
C PlgButtonMenu
C PlgButtonModule
C PlgButtonPagebreak
C PlgButtonReadmore
C PlgCaptchaRecaptcha
C PlgCaptchaRecaptcha_Invisible
C PlgContentConfirmConsent
C PlgContentContact
C PlgContentEmailcloak
C PlgContentFields
C PlgContentFinder
C PlgContentJoomla
C PlgContentLoadmodule
C PlgContentPagebreak
C PlgContentPagenavigation
C PlgContentVote
C PlgEditorCodemirror
C PlgEditorNone
C PlgEditorTinymce
C PlgExtensionFinder
C PlgExtensionJoomla
C PlgExtensionNamespacemap
C PlgFieldsCalendar
C PlgFieldsCheckboxes
C PlgFieldsColor
C PlgFieldsEditor
C PlgFieldsImagelist
C PlgFieldsInteger
C PlgFieldsList
C PlgFieldsMedia
C PlgFieldsRadio
C PlgFieldsSql
C PlgFieldsSubform
C PlgFieldsText
C PlgFieldsTextarea
C PlgFieldsUrl
C PlgFieldsUser
C PlgFieldsUsergrouplist
C PlgFileSystemLocal
C PlgFinderCategories
C PlgFinderContacts
C PlgFinderContent
C PlgFinderNewsfeeds
C PlgFinderTags
C PlgInstallerFolderInstaller
C PlgInstallerOverride
C PlgInstallerPackageInstaller
C PlgInstallerUrlInstaller
C PlgInstallerWebinstaller
C PlgMediaActionCrop
C PlgMediaActionResize
C PlgMediaActionRotate
C PlgPrivacyActionlogs
C PlgPrivacyConsents
C PlgPrivacyContact
C PlgPrivacyContent
C PlgPrivacyMessage
C PlgPrivacyUser
C PlgQuickiconDownloadkey
C PlgQuickiconExtensionupdate
C PlgQuickiconOverrideCheck
C PlgQuickiconPhpVersionCheck
C PlgQuickiconPrivacyCheck
C PlgSampledataBlog
C PlgSampledataMultilang
C PlgSystemAccessibility
C PlgSystemActionLogs
C PlgSystemDebug
C PlgSystemFields
C PlgSystemHighlight
C PlgSystemHttpHeaders
C PlgSystemJooa11y
C PlgSystemLanguagecode
C PlgSystemLanguageFilter
C PlgSystemLog
C PlgSystemLogout
C PlgSystemLogrotation
C PlgSystemPrivacyconsent
C PlgSystemRedirect
C PlgSystemRemember
C PlgSystemSchedulerunner
C PlgSystemSef
C PlgSystemSessionGc
C PlgSystemSkipto
C PlgSystemStats
C PlgSystemTasknotification
C PlgSystemUpdatenotification
C PlgUserContactCreator
C PlgUserJoomla
C PlgUserProfile
C PlgUserTerms
C PlgUserToken
C PlgWebservicesBanners
C PlgWebservicesConfig
C PlgWebservicesContact
C PlgWebservicesContent
C PlgWebservicesInstaller
C PlgWebservicesLanguages
C PlgWebservicesMedia
C PlgWebservicesMenus
C PlgWebservicesMessages
C PlgWebservicesModules
C PlgWebservicesNewsfeeds
C PlgWebservicesPlugins
C PlgWebservicesPrivacy
C PlgWebservicesRedirect
C PlgWebservicesTags
C PlgWebservicesTemplates
C PlgWebservicesUsers
C PlgWorkflowFeaturing
C PlgWorkflowNotification
C PlgWorkflowPublishing
C PluginsHelper
C RedirectHelper
C ServiceProviderInterface
C SplFixedArray
C TagsHelperRoute
C TemplateHelper
C TemplatesHelper
C UsersHelper
C UsersHelperDebug
C ZIPExtraction


Joomla CMS: Référence de l'interface EncodingHelperInterface

  • Algo26
  • IdnaConvert
  • EncodingHelper
  • EncodingHelperInterface
Fonctions membres publiques
Référence de l'interface EncodingHelperInterface
+ Graphe d'héritage de EncodingHelperInterface:
FromUtf8 ToUtf8

Fonctions membres publiques

convert (string $sourceString, string $encoding='ISO-8859-1', bool $safeMode=false)

Documentation des fonctions membres

◆ convert()

convert | ( | string | $sourceString,
 |  | string | $encoding = 'ISO-8859-1',
 |  | bool | $safeMode = false
 | ) |  |
La documentation de cette interface a été générée à partir du fichier suivant :
  • EncodingHelperInterface.php


Joomla CMS: Référence de la classe FromUtf8

  • Algo26
  • IdnaConvert
  • EncodingHelper
  • FromUtf8
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FromUtf8
+ Graphe d'héritage de FromUtf8:
EncodingHelperInterface

Fonctions membres publiques

convert (string $sourceString, ?string $encoding=self::DEFAULT_ENCODING, ?bool $safeMode=false)
- Fonctions membres publiques hérités de EncodingHelperInterface
convert (string $sourceString, string $encoding='ISO-8859-1', bool $safeMode=false)

Fonctions membres privées

mapIso8859_1ToWindows1252 ($string='')
convertWithLibraries (string $string)

Attributs privés

const DEFAULT_ENCODING = 'ISO-8859-1'
$encoding = self::DEFAULT_ENCODING

Documentation des fonctions membres

◆ convert()

convert | ( | string | $sourceString,
 |  | ?string | $encoding = self::DEFAULT_ENCODING,
 |  | ?bool | $safeMode = false
 | ) |  |

Références FromUtf8\$encoding, FromUtf8\convertWithLibraries(), et null.

◆ convertWithLibraries()

convertWithLibraries ( string $string )
private

Référencé par FromUtf8\convert().

◆ mapIso8859_1ToWindows1252()

mapIso8859_1ToWindows1252 ( $string = '' )
private

Special treatment for our guys in Redmond Windows-1252 is basically ISO-8859-1 – with some exceptions, which get dealt with here

Paramètres
string $string Your input in ISO-8859-1
Renvoie
string The resulting Win1252 string
Depuis
0.0.1

Références $i, et $return.

Documentation des champs

◆ $encoding

$encoding = self::DEFAULT_ENCODING
private

Référencé par FromUtf8\convert().

◆ DEFAULT_ENCODING

const DEFAULT_ENCODING = 'ISO-8859-1'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • FromUtf8.php


Joomla CMS: Référence de la classe ToUtf8

  • Algo26
  • IdnaConvert
  • EncodingHelper
  • ToUtf8
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ToUtf8
+ Graphe d'héritage de ToUtf8:
EncodingHelperInterface

Fonctions membres publiques

convert (string $sourceString, ?string $encoding=self::DEFAULT_ENCODING, ?bool $safeMode=false)
- Fonctions membres publiques hérités de EncodingHelperInterface
convert (string $sourceString, string $encoding='ISO-8859-1', bool $safeMode=false)

Fonctions membres privées

mapWindows1252ToIso8859_1 ($string='')
convertWithLibraries (string $string)

Attributs privés

const DEFAULT_ENCODING = 'ISO-8859-1'
$encoding = self::DEFAULT_ENCODING

Documentation des fonctions membres

◆ convert()

convert | ( | string | $sourceString,
 |  | ?string | $encoding = self::DEFAULT_ENCODING,
 |  | ?bool | $safeMode = false
 | ) |  |

Références ToUtf8\$encoding, ToUtf8\convertWithLibraries(), ToUtf8\mapWindows1252ToIso8859_1(), et null.

◆ convertWithLibraries()

convertWithLibraries ( string $string )
private

Référencé par ToUtf8\convert().

◆ mapWindows1252ToIso8859_1()

mapWindows1252ToIso8859_1 ( $string = '' )
private

Special treatment for our guys in Redmond Windows-1252 is basically ISO-8859-1 – with some exceptions, which get dealt with here

Paramètres
string $string Your input in Win1252
Renvoie
string The resulting ISO-8859-1 string
Depuis
0.0.1

Références $i, et $return.

Référencé par ToUtf8\convert().

Documentation des champs

◆ $encoding

$encoding = self::DEFAULT_ENCODING
private

Référencé par ToUtf8\convert().

◆ DEFAULT_ENCODING

const DEFAULT_ENCODING = 'ISO-8859-1'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ToUtf8.php


Joomla CMS: Référence de la classe AlreadyPunycodeException

  • Algo26
  • IdnaConvert
  • Exception
  • AlreadyPunycodeException
Référence de la classe AlreadyPunycodeException
+ Graphe d'héritage de AlreadyPunycodeException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • AlreadyPunycodeException.php


Joomla CMS: Référence de la classe InvalidCharacterException

  • Algo26
  • IdnaConvert
  • Exception
  • InvalidCharacterException
Référence de la classe InvalidCharacterException
+ Graphe d'héritage de InvalidCharacterException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidCharacterException.php


Joomla CMS: Référence de la classe InvalidIdnVersionException

  • Algo26
  • IdnaConvert
  • Exception
  • InvalidIdnVersionException
Référence de la classe InvalidIdnVersionException
+ Graphe d'héritage de InvalidIdnVersionException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidIdnVersionException.php


Joomla CMS: Référence de la classe NamePrep

  • Algo26
  • IdnaConvert
  • NamePrep
  • NamePrep
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe NamePrep
+ Graphe d'héritage de NamePrep:
NamePrepInterface

Fonctions membres publiques

__construct (?string $idnVersion=null)
do (array $inputArray)

Champs de données

const | sBase = 0xAC00
const | lBase = 0x1100
const | vBase = 0x1161
const | tBase = 0x11A7
const | lCount = 19
const | vCount = 21
const | tCount = 28
const | nCount = 588
const | sCount = 11172
const | sLast = self::sBase + self::lCount * self::vCount * self::tCount

Fonctions membres privées

applyCharacterMaps (array $inputArray)
combineCodePoints (array $codePoints)
hangulDecompose (int $codePoint)
hangulCompose (array $input)
getCombiningClass (int $char)
applyCanonicalOrdering (array $input)
combine (array $input)

Attributs privés

$namePrepData

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?string $idnVersion = null )
Paramètres
string | null $idnVersion
Exceptions
InvalidIdnVersionException

Références null.

Documentation des fonctions membres

◆ applyCanonicalOrdering()

applyCanonicalOrdering ( array $input )
private

Applies the canonical ordering of a decomposed UCS4 sequence

Paramètres
array $input Decomposed UCS4 sequence
Renvoie
array Ordered USC4 sequence

Références $input, et NamePrep\getCombiningClass().

Référencé par NamePrep\applyCharacterMaps().

◆ applyCharacterMaps()

applyCharacterMaps ( array $inputArray )
private
Paramètres
array $inputArray
Renvoie
array
Exceptions
InvalidCharacterException

Références $range, NamePrep\applyCanonicalOrdering(), elseif, et NamePrep\hangulDecompose().

Référencé par NamePrep\do().

◆ combine()

combine ( array $input )
private

Do composition of a sequence of starter and non-starter

Paramètres
array $input UCS4 Decomposed sequence
Renvoie
array|false Ordered USC4 sequence

Références $input.

Référencé par NamePrep\combineCodePoints().

◆ combineCodePoints()

combineCodePoints ( array $codePoints )
private

Références NamePrep\combine(), et NamePrep\getCombiningClass().

Référencé par NamePrep\do().

◆ do()

do ( array $inputArray )
Paramètres
array $inputArray
Renvoie
array
Exceptions
InvalidCharacterException

Implémente NamePrepInterface.

Références NamePrep\applyCharacterMaps(), NamePrep\combineCodePoints(), et NamePrep\hangulCompose().

◆ getCombiningClass()

getCombiningClass ( int $char )
private

Returns the combining class of a certain wide char

Paramètres
integer $char Wide char to check (32bit integer)
Renvoie
integer Combining class if found, else 0

Référencé par NamePrep\applyCanonicalOrdering(), et NamePrep\combineCodePoints().

◆ hangulCompose()

hangulCompose ( array $input )
private

Compose a Hangul syllable (see http://www.unicode.org/unicode/reports/tr15/#Hangul

Paramètres
array $input Decomposed UCS4 sequence
Renvoie
array UCS4 sequence with syllables composed

Références $i, $input, et $result.

Référencé par NamePrep\do().

◆ hangulDecompose()

hangulDecompose ( int $codePoint )
private

Decomposes a Hangul syllable (see http://www.unicode.org/unicode/reports/tr15/#Hangul

Paramètres
integer 32bit UCS4 code point
Renvoie
array Either Hangul Syllable decomposed or original 32bit value as one value array

Références $result.

Référencé par NamePrep\applyCharacterMaps().

Documentation des champs

◆ $namePrepData

$namePrepData
private

◆ lBase

const lBase = 0x1100

◆ lCount

const lCount = 19

◆ nCount

const nCount = 588

◆ sBase

const sBase = 0xAC00

◆ sCount

const sCount = 11172

◆ sLast

const sLast = self::sBase + self::lCount * self::vCount * self::tCount

◆ tBase

const tBase = 0x11A7

◆ tCount

const tCount = 28

◆ vBase

const vBase = 0x1161

◆ vCount

const vCount = 21
La documentation de cette classe a été générée à partir du fichier suivant :
  • NamePrep.php


Joomla CMS: Référence de la classe NamePrepData2003

  • Algo26
  • IdnaConvert
  • NamePrep
  • NamePrepData2003
Champs de données
Référence de la classe NamePrepData2003
+ Graphe d'héritage de NamePrepData2003:
NamePrepData2008 NamePrepDataInterface NamePrepDataInterface

Champs de données

$replaceMaps
- Champs de données hérités de NamePrepData2008
$mapToNothing
$generalProhibited
$prohibit
$prohibitRanges
$replaceMaps
$normalizeCombiningClasses

Description détaillée

character mapss

Documentation des champs

◆ $replaceMaps

$replaceMaps
Valeur initiale :
= [
0x41 => [0x61]
La documentation de cette classe a été générée à partir du fichier suivant :
  • NamePrepData2003.php


Joomla CMS: Référence de la classe NamePrepData2008

  • Algo26
  • IdnaConvert
  • NamePrep
  • NamePrepData2008
Champs de données
Référence de la classe NamePrepData2008
+ Graphe d'héritage de NamePrepData2008:
NamePrepDataInterface NamePrepData2003

Champs de données

$mapToNothing
$generalProhibited
$prohibit
$prohibitRanges
$replaceMaps
$normalizeCombiningClasses

Description détaillée

character mapss

Documentation des champs

◆ $generalProhibited

$generalProhibited
Valeur initiale :
= [
0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19,
20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42,
43, 44, 47, 59, 60, 61, 62, 63, 64, 91, 92, 93, 94, 95, 96, 123, 124, 125, 126, 127, 0x3002
]

◆ $mapToNothing

$mapToNothing
Valeur initiale :
= [
0xAD, 0x34F, 0x1806, 0x180B, 0x180C, 0x180D, 0x200B, 0x200C,
0x200D, 0x2060, 0xFE00, 0xFE01, 0xFE02, 0xFE03, 0xFE04, 0xFE05, 0xFE06, 0xFE07,
0xFE08, 0xFE09, 0xFE0A, 0xFE0B, 0xFE0C, 0xFE0D, 0xFE0E, 0xFE0F, 0xFEFF
]

◆ $normalizeCombiningClasses

$normalizeCombiningClasses
Valeur initiale :
= [
0x334 => 1

◆ $prohibit

$prohibit
Valeur initiale :
= [
0xA0, 0x340, 0x341, 0x6DD, 0x70F, 0x1680, 0x180E, 0x2000, 0x2001, 0x2002, 0x2003,
0x2004, 0x2005, 0x2006, 0x2007, 0x2008, 0x2009, 0x200A, 0x200B, 0x200C, 0x200D, 0x200E, 0x200F,
0x2028, 0x2029, 0x202A, 0x202B, 0x202C, 0x202D, 0x202E, 0x202F, 0x205F, 0x206A, 0x206B, 0x206C,
0x206D, 0x206E, 0x206F, 0x3000, 0x33C2, 0xFEFF, 0xFFF9, 0xFFFA, 0xFFFB, 0xFFFC, 0xFFFD, 0xFFFE, 0xFFFF,
0x1FFFE, 0x1FFFF, 0x2FFFE, 0x2FFFF, 0x3FFFE, 0x3FFFF, 0x4FFFE, 0x4FFFF, 0x5FFFE, 0x5FFFF, 0x6FFFE,
0x6FFFF, 0x7FFFE, 0x7FFFF, 0x8FFFE, 0x8FFFF, 0x9FFFE, 0x9FFFF, 0xAFFFE, 0xAFFFF, 0xBFFFE, 0xBFFFF,
0xCFFFE, 0xCFFFF, 0xDFFFE, 0xDFFFF, 0xE0001, 0xEFFFE, 0xEFFFF, 0xFFFFE, 0xFFFFF, 0x10FFFE, 0x10FFFF
]

◆ $prohibitRanges

$prohibitRanges
Valeur initiale :
= [
[0x80, 0x9F], [0x2060, 0x206F], [0x1D173, 0x1D17A],
[0xE000, 0xF8FF], [0xF0000, 0xFFFFD], [0x100000, 0x10FFFD],
[0xFDD0, 0xFDEF], [0xD800, 0xDFFF], [0x2FF0, 0x2FFB], [0xE0020, 0xE007F]
]

◆ $replaceMaps

$replaceMaps
Valeur initiale :
= [
0x41 => [0x61]
La documentation de cette classe a été générée à partir du fichier suivant :
  • NamePrepData2008.php


Joomla CMS: Référence de l'interface NamePrepDataInterface

  • Algo26
  • IdnaConvert
  • NamePrep
  • NamePrepDataInterface
Référence de l'interface NamePrepDataInterface
+ Graphe d'héritage de NamePrepDataInterface:
NamePrepData2003 NamePrepData2008 NamePrepData2003
La documentation de cette interface a été générée à partir du fichier suivant :
  • NamePrepDataInterface.php


Joomla CMS: Référence de l'interface NamePrepInterface

  • Algo26
  • IdnaConvert
  • NamePrep
  • NamePrepInterface
Fonctions membres publiques
Référence de l'interface NamePrepInterface
+ Graphe d'héritage de NamePrepInterface:
NamePrep

Fonctions membres publiques

do (array $inputArray)

Documentation des fonctions membres

◆ do()

do ( array $inputArray )
Paramètres
array $inputArray
Renvoie
array

Implémenté dans NamePrep.

La documentation de cette interface a été générée à partir du fichier suivant :
  • NamePrepInterface.php


Joomla CMS: Référence de la classe AbstractPunycode

  • Algo26
  • IdnaConvert
  • Punycode
  • AbstractPunycode
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe AbstractPunycode
+ Graphe d'héritage de AbstractPunycode:
FromPunycode ToPunycode

Fonctions membres publiques

__construct ()
getPunycodePrefix ()

Champs de données

const | punycodePrefix = 'xn--'
const | invalidUcs = 0x80000000
const | maxUcs = 0x10FFFF
const | base = 36
const | tMin = 1
const | tMax = 26
const | skew = 38
const | damp = 700
const | initialBias = 72
const | initialN = 0x80

Fonctions membres protégées

byteLength ($string)
adapt ($delta, $nPoints, $isFirst)

Attributs protégés

$unicodeTransCoder

Attributs protégés statiques

static | $isMbStringOverload
static | $prefixAsArray
static | $prefixLength

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références AbstractPunycode\byteLength(), et null.

Documentation des fonctions membres

◆ adapt()

adapt | ( | $delta,
 |  | $nPoints,
 |  | $isFirst
 | ) |
protected

Adapt the bias according to the current code point and position

Paramètres
int | $delta
int | $nPoints
int | $isFirst
Renvoie
int

Référencé par FromPunycode\convert(), et ToPunycode\convert().

◆ byteLength()

byteLength ( $string )
protected

Gets the length of a string in bytes even if mbstring function overloading is turned on

Paramètres
string $string the string for which to get the length.
Renvoie
integer the length of the string in bytes.

Référencé par AbstractPunycode\__construct(), et FromPunycode\convert().

◆ getPunycodePrefix()

getPunycodePrefix ( )

Documentation des champs

◆ $isMbStringOverload

$isMbStringOverload
staticprotected

◆ $prefixAsArray

$prefixAsArray
staticprotected

◆ $prefixLength

$prefixLength
staticprotected

◆ $unicodeTransCoder

$unicodeTransCoder
protected

◆ base

const base = 36

◆ damp

const damp = 700

◆ initialBias

const initialBias = 72

◆ initialN

const initialN = 0x80

◆ invalidUcs

const invalidUcs = 0x80000000

◆ maxUcs

const maxUcs = 0x10FFFF

◆ punycodePrefix

const punycodePrefix = 'xn--'

◆ skew

const skew = 38

◆ tMax

const tMax = 26

◆ tMin

const tMin = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractPunycode.php


Joomla CMS: Référence de la classe FromPunycode

  • Algo26
  • IdnaConvert
  • Punycode
  • FromPunycode
Fonctions membres publiques | Fonctions membres privées
Référence de la classe FromPunycode
+ Graphe d'héritage de FromPunycode:
AbstractPunycode PunycodeInterface

Fonctions membres publiques

__construct (?string $idnVersion=null)
convert ($encoded)
- Fonctions membres publiques hérités de AbstractPunycode
__construct ()
getPunycodePrefix ()
- Fonctions membres publiques hérités de PunycodeInterface
__construct (string $idnVersion=null)
getPunycodePrefix ()

Fonctions membres privées

validate ($encoded)
decodeDigit (string $cp)

Membres hérités additionnels

- Champs de données hérités de AbstractPunycode
const | punycodePrefix = 'xn--'
const | invalidUcs = 0x80000000
const | maxUcs = 0x10FFFF
const | base = 36
const | tMin = 1
const | tMax = 26
const | skew = 38
const | damp = 700
const | initialBias = 72
const | initialN = 0x80
- Fonctions membres protégées hérités de AbstractPunycode
byteLength ($string)
adapt ($delta, $nPoints, $isFirst)
- Attributs protégés hérités de AbstractPunycode
$unicodeTransCoder
- Attributs protégés statiques hérités de AbstractPunycode
static | $isMbStringOverload
static | $prefixAsArray
static | $prefixLength

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?string $idnVersion = null )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ convert()

convert ( $encoded )

The actual decoding algorithm

Paramètres
string
Renvoie
mixed

Références $i, AbstractPunycode\adapt(), AbstractPunycode\byteLength(), FromPunycode\decodeDigit(), et FromPunycode\validate().

◆ decodeDigit()

decodeDigit ( string $cp )
private

Référencé par FromPunycode\convert().

◆ validate()

validate ( $encoded )
private

Checks, whether or not the provided string is a valid punycode string

Paramètres
string $encoded
Renvoie
boolean

Référencé par FromPunycode\convert().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FromPunycode.php


Joomla CMS: Référence de l'interface PunycodeInterface

  • Algo26
  • IdnaConvert
  • Punycode
  • PunycodeInterface
Fonctions membres publiques
Référence de l'interface PunycodeInterface
+ Graphe d'héritage de PunycodeInterface:
FromPunycode ToPunycode

Fonctions membres publiques

__construct (string $idnVersion=null)
getPunycodePrefix ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $idnVersion = null )

Documentation des fonctions membres

◆ getPunycodePrefix()

getPunycodePrefix ( )
La documentation de cette interface a été générée à partir du fichier suivant :
  • PunycodeInterface.php


Joomla CMS: Référence de la classe ToPunycode

  • Algo26
  • IdnaConvert
  • Punycode
  • ToPunycode
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ToPunycode
+ Graphe d'héritage de ToPunycode:
AbstractPunycode PunycodeInterface

Fonctions membres publiques

__construct (?string $idnVersion=null)
convert (array $decoded)
- Fonctions membres publiques hérités de AbstractPunycode
__construct ()
getPunycodePrefix ()
- Fonctions membres publiques hérités de PunycodeInterface
__construct (string $idnVersion=null)
getPunycodePrefix ()

Fonctions membres privées

encodeDigit ($d)

Attributs privés

$namePrep

Membres hérités additionnels

- Champs de données hérités de AbstractPunycode
const | punycodePrefix = 'xn--'
const | invalidUcs = 0x80000000
const | maxUcs = 0x10FFFF
const | base = 36
const | tMin = 1
const | tMax = 26
const | skew = 38
const | damp = 700
const | initialBias = 72
const | initialN = 0x80
- Fonctions membres protégées hérités de AbstractPunycode
byteLength ($string)
adapt ($delta, $nPoints, $isFirst)
- Attributs protégés hérités de AbstractPunycode
$unicodeTransCoder
- Attributs protégés statiques hérités de AbstractPunycode
static | $isMbStringOverload
static | $prefixAsArray
static | $prefixLength

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?string $idnVersion = null )
Exceptions
InvalidIdnVersionException

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ convert()

convert ( array $decoded )
Paramètres
array $decoded
Renvoie
string
Exceptions
AlreadyPunycodeException
InvalidCharacterException

Références $i, AbstractPunycode\adapt(), elseif, et ToPunycode\encodeDigit().

◆ encodeDigit()

encodeDigit ( $d )
private

Encoding a certain digit

Paramètres
int $d
Renvoie
string

Référencé par ToPunycode\convert().

Documentation des champs

◆ $namePrep

$namePrep
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ToPunycode.php


Joomla CMS: Référence de la classe TranscodeUnicode

  • Algo26
  • IdnaConvert
  • TranscodeUnicode
  • TranscodeUnicode
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe TranscodeUnicode
+ Graphe d'héritage de TranscodeUnicode:
TranscodeUnicodeInterface

Fonctions membres publiques

convert ( $data, string $fromEncoding, string $toEncoding, bool $safeMode=false, ?int $safeCodepoint=null)
- Fonctions membres publiques hérités de TranscodeUnicodeInterface
convert ( $data, string $fromEncoding, string $toEncoding, bool $safeMode=false, int $safeCodepoint=0xFFFC)

Champs de données

const | FORMAT_UCS4 = 'ucs4'
const | FORMAT_UCS4_ARRAY = 'ucs4array'
const | FORMAT_UTF8 = 'utf8'
const | FORMAT_UTF7 = 'utf7'
const | FORMAT_UTF7_IMAP = 'utf7imap'

Fonctions membres protégées

byteLength ($string)

Fonctions membres privées

utf8_ucs4array ($input)
ucs4array_utf8 ($input)
utf7imap_ucs4array ($input)
utf7_ucs4array ($input, $sc='+')
ucs4array_utf7imap ($input)
ucs4array_utf7 ($input, $sc='+')
ucs4array_ucs4 ($input)
ucs4_ucs4array ($input)

Attributs privés

const encodings
$safeMode
$safeCodepoint = 0xFFFC

Documentation des fonctions membres

◆ byteLength()

byteLength ( $string )
protected

Gets the length of a string in bytes even if mbstring function overloading is turned on

Paramètres
string $string the string for which to get the length.
Renvoie
integer the length of the string in bytes.

Référencé par TranscodeUnicode\ucs4_ucs4array(), TranscodeUnicode\utf7_ucs4array(), et TranscodeUnicode\utf8_ucs4array().

◆ convert()

convert | ( |  | $data,
 |  | string | $fromEncoding,
 |  | string | $toEncoding,
 |  | bool | $safeMode = false,
 |  | ?int | $safeCodepoint = null
 | ) |  |

Références $data, $methodName, TranscodeUnicode\$safeCodepoint, TranscodeUnicode\$safeMode, et null.

◆ ucs4_ucs4array()

ucs4_ucs4array ( $input )
private

Convert UCS-4 string (LE ar the moment) into UCS-4 array

Paramètres
$input string UCS-4 LE string
Renvoie
array public
Exceptions
InvalidCharacterException

Références $i, $input, $output, et TranscodeUnicode\byteLength().

◆ ucs4array_ucs4()

ucs4array_ucs4 ( $input )
private

Convert UCS-4 array into UCS-4 string (Little Endian at the moment)

Paramètres
$input array UCS-4 code points
Renvoie
string public

Références $input, et $output.

◆ ucs4array_utf7()

ucs4array_utf7 | ( | $input,
 |  | $sc = '+'
 | ) |
private

Références $input, $mode, $output, et elseif.

Référencé par TranscodeUnicode\ucs4array_utf7imap().

◆ ucs4array_utf7imap()

ucs4array_utf7imap ( $input )
private

Références $input, et TranscodeUnicode\ucs4array_utf7().

◆ ucs4array_utf8()

ucs4array_utf8 ( $input )
private

Convert UCS-4 arary into UTF-8 string See utf8_ucs4array() for details

Paramètres
$input array Array of UCS-4 codepoints
Renvoie
string public
Exceptions
InvalidCharacterException

Références $input, $output, TranscodeUnicode\$safeCodepoint, et elseif.

◆ utf7_ucs4array()

utf7_ucs4array | ( | $input,
 |  | $sc = '+'
 | ) |
private

Références $c, $i, $input, $mode, $output, $tmp, et TranscodeUnicode\byteLength().

Référencé par TranscodeUnicode\utf7imap_ucs4array().

◆ utf7imap_ucs4array()

utf7imap_ucs4array ( $input )
private

Références $input, et TranscodeUnicode\utf7_ucs4array().

◆ utf8_ucs4array()

utf8_ucs4array ( $input )
private

This converts an UTF-8 encoded string to its UCS-4 representation

Paramètres
string $input The UTF-8 string to convert
Renvoie
array Array of 32bit values representing each codepoint
Exceptions
InvalidCharacterException public

Références $input, $mode, $output, TranscodeUnicode\$safeCodepoint, TranscodeUnicode\byteLength(), et elseif.

Documentation des champs

◆ $safeCodepoint

$safeCodepoint = 0xFFFC
private

Référencé par TranscodeUnicode\convert(), TranscodeUnicode\ucs4array_utf8(), et TranscodeUnicode\utf8_ucs4array().

◆ $safeMode

$safeMode
private

Référencé par TranscodeUnicode\convert().

◆ encodings

const encodings
private
Valeur initiale :
= [
self::FORMAT_UCS4,
self::FORMAT_UCS4_ARRAY,
self::FORMAT_UTF8,
self::FORMAT_UTF7,
self::FORMAT_UTF7_IMAP
]

◆ FORMAT_UCS4

const FORMAT_UCS4 = 'ucs4'

◆ FORMAT_UCS4_ARRAY

const FORMAT_UCS4_ARRAY = 'ucs4array'

◆ FORMAT_UTF7

const FORMAT_UTF7 = 'utf7'

◆ FORMAT_UTF7_IMAP

const FORMAT_UTF7_IMAP = 'utf7imap'

◆ FORMAT_UTF8

const FORMAT_UTF8 = 'utf8'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TranscodeUnicode.php


Joomla CMS: Référence de l'interface TranscodeUnicodeInterface

  • Algo26
  • IdnaConvert
  • TranscodeUnicode
  • TranscodeUnicodeInterface
Fonctions membres publiques
Référence de l'interface TranscodeUnicodeInterface
+ Graphe d'héritage de TranscodeUnicodeInterface:
TranscodeUnicode

Fonctions membres publiques

convert ( $data, string $fromEncoding, string $toEncoding, bool $safeMode=false, int $safeCodepoint=0xFFFC)

Documentation des fonctions membres

◆ convert()

convert | ( |  | $data,
 |  | string | $fromEncoding,
 |  | string | $toEncoding,
 |  | bool | $safeMode = false,
 |  | int | $safeCodepoint = 0xFFFC
 | ) |  |
La documentation de cette interface a été générée à partir du fichier suivant :
  • TranscodeUnicodeInterface.php


Joomla CMS: Référence de la classe AbstractIdnaConvert

  • Algo26
  • IdnaConvert
  • AbstractIdnaConvert
Fonctions membres publiques
Référence de la classe AbstractIdnaConvert
+ Graphe d'héritage de AbstractIdnaConvert:
ToIdn ToUnicode

Fonctions membres publiques

convert (string $host)
convertEmailAddress (string $emailAddress)
convertUrl (string $url)

Documentation des fonctions membres

◆ convert()

convert ( string $host )
abstract

Référencé par AbstractIdnaConvert\convertEmailAddress(), et AbstractIdnaConvert\convertUrl().

◆ convertEmailAddress()

convertEmailAddress ( string $emailAddress )
Paramètres
string $emailAddress
Renvoie
string

Références $parts, et AbstractIdnaConvert\convert().

◆ convertUrl()

convertUrl ( string $url )
Paramètres
string $url
Renvoie
string

Références $url, AbstractIdnaConvert\convert(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractIdnaConvert.php


Joomla CMS: Référence de l'interface IdnaConvertInterface

  • Algo26
  • IdnaConvert
  • IdnaConvertInterface
Fonctions membres publiques
Référence de l'interface IdnaConvertInterface
+ Graphe d'héritage de IdnaConvertInterface:
ToIdn ToUnicode

Fonctions membres publiques

convert (string $host)
convertEmailAddress (string $emailAddress)
convertUrl (string $url)

Documentation des fonctions membres

◆ convert()

convert ( string $host )

Implémenté dans ToIdn, et ToUnicode.

◆ convertEmailAddress()

convertEmailAddress ( string $emailAddress )

◆ convertUrl()

convertUrl ( string $url )
La documentation de cette interface a été générée à partir du fichier suivant :
  • IdnaConvertInterface.php


Joomla CMS: Référence de la classe ToIdn

  • Algo26
  • IdnaConvert
  • ToIdn
Fonctions membres publiques | Attributs privés
Référence de la classe ToIdn
+ Graphe d'héritage de ToIdn:
AbstractIdnaConvert IdnaConvertInterface

Fonctions membres publiques

__construct ($idnVersion=null)
convert (string $host)
- Fonctions membres publiques hérités de AbstractIdnaConvert
convert (string $host)
convertEmailAddress (string $emailAddress)
convertUrl (string $url)
- Fonctions membres publiques hérités de IdnaConvertInterface
convertEmailAddress (string $emailAddress)
convertUrl (string $url)

Attributs privés

$unicodeTransCoder
$punycodeEncoder

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $idnVersion = null )
Exceptions
InvalidIdnVersionException

Documentation des fonctions membres

◆ convert()

convert ( string $host )
Paramètres
string $host
Renvoie
string
Exceptions
InvalidCharacterException
Exception

Implémente IdnaConvertInterface.

Références $label.

Documentation des champs

◆ $punycodeEncoder

$punycodeEncoder
private

◆ $unicodeTransCoder

$unicodeTransCoder
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ToIdn.php


Joomla CMS: Référence de la classe ToUnicode

  • Algo26
  • IdnaConvert
  • ToUnicode
Fonctions membres publiques | Attributs privés
Référence de la classe ToUnicode
+ Graphe d'héritage de ToUnicode:
AbstractIdnaConvert IdnaConvertInterface

Fonctions membres publiques

__construct ()
convert (string $host)
- Fonctions membres publiques hérités de AbstractIdnaConvert
convert (string $host)
convertEmailAddress (string $emailAddress)
convertUrl (string $url)
- Fonctions membres publiques hérités de IdnaConvertInterface
convertEmailAddress (string $emailAddress)
convertUrl (string $url)

Attributs privés

$unicodeTransCoder
$punycodeEncoder

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ convert()

convert ( string $host )

Implémente IdnaConvertInterface.

Références $input, $label, et $return.

Documentation des champs

◆ $punycodeEncoder

$punycodeEncoder
private

◆ $unicodeTransCoder

$unicodeTransCoder
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ToUnicode.php


Joomla CMS: Référence de la classe Assert

  • Assert
  • Assert
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Assert

Fonctions membres publiques statiques

static | that ($value, $defaultMessage=null, string $defaultPropertyPath=null)
static | thatAll ($values, $defaultMessage=null, string $defaultPropertyPath=null)
static | thatNullOr ($value, $defaultMessage=null, string $defaultPropertyPath=null)
static | lazy ()

Attributs protégés statiques

static | $lazyAssertionExceptionClass = LazyAssertionException::class
static | $assertionClass = Assertion::class

Description détaillée

AssertionChain factory.

Documentation des fonctions membres

◆ lazy()

static lazy ( )
static

Create a lazy assertion object.

◆ that()

static that | ( |  | $value,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |
static

Références $value.

◆ thatAll()

static thatAll | ( |  | $values,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |
static

Start validation on a set of values, returns AssertionChain.

Paramètres
mixed | $values
string | callable | null | $defaultMessage

Références Assert\that().

◆ thatNullOr()

static thatNullOr | ( |  | $value,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |
static

Start validation and allow NULL, returns AssertionChain.

Paramètres
mixed | $value
string | callable | null | $defaultMessage

Références $value, et Assert\that().

Documentation des champs

◆ $assertionClass

$assertionClass = Assertion::class
staticprotected

◆ $lazyAssertionExceptionClass

$lazyAssertionExceptionClass = LazyAssertionException::class
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • beberlei/assert/lib/Assert/Assert.php


Joomla CMS: Référence de la classe Assertion

  • Assert
  • Assertion
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe Assertion

Fonctions membres publiques statiques

static | eq ($value, $value2, $message=null, string $propertyPath=null)
static | eqArraySubset ($value, $value2, $message=null, string $propertyPath=null)
static | same ($value, $value2, $message=null, string $propertyPath=null)
static | notEq ($value1, $value2, $message=null, string $propertyPath=null)
static | notSame ($value1, $value2, $message=null, string $propertyPath=null)
static | notInArray ($value, array $choices, $message=null, string $propertyPath=null)
static | integer ($value, $message=null, string $propertyPath=null)
static | float ($value, $message=null, string $propertyPath=null)
static | digit ($value, $message=null, string $propertyPath=null)
static | integerish ($value, $message=null, string $propertyPath=null)
static | boolean ($value, $message=null, string $propertyPath=null)
static | scalar ($value, $message=null, string $propertyPath=null)
static | notEmpty ($value, $message=null, string $propertyPath=null)
static | noContent ($value, $message=null, string $propertyPath=null)
static | null ($value, $message=null, string $propertyPath=null)
static | notNull ($value, $message=null, string $propertyPath=null)
static | string ($value, $message=null, string $propertyPath=null)
static | regex ($value, $pattern, $message=null, string $propertyPath=null)
static | notRegex ($value, $pattern, $message=null, string $propertyPath=null)
static | length ($value, $length, $message=null, string $propertyPath=null, $encoding='utf8')
static | minLength ($value, $minLength, $message=null, string $propertyPath=null, $encoding='utf8')
static | maxLength ($value, $maxLength, $message=null, string $propertyPath=null, $encoding='utf8')
static | betweenLength ($value, $minLength, $maxLength, $message=null, string $propertyPath=null, $encoding='utf8')
static | startsWith ($string, $needle, $message=null, string $propertyPath=null, $encoding='utf8')
static | endsWith ($string, $needle, $message=null, string $propertyPath=null, $encoding='utf8')
static | contains ($string, $needle, $message=null, string $propertyPath=null, $encoding='utf8')
static | notContains ($string, $needle, $message=null, string $propertyPath=null, $encoding='utf8')
static | choice ($value, array $choices, $message=null, string $propertyPath=null)
static | inArray ($value, array $choices, $message=null, string $propertyPath=null)
static | numeric ($value, $message=null, string $propertyPath=null)
static | isResource ($value, $message=null, string $propertyPath=null)
static | isArray ($value, $message=null, string $propertyPath=null)
static | isTraversable ($value, $message=null, string $propertyPath=null)
static | isArrayAccessible ($value, $message=null, string $propertyPath=null)
static | isCountable ($value, $message=null, string $propertyPath=null)
static | keyExists ($value, $key, $message=null, string $propertyPath=null)
static | keyNotExists ($value, $key, $message=null, string $propertyPath=null)
static | uniqueValues (array $values, $message=null, string $propertyPath=null)
static | keyIsset ($value, $key, $message=null, string $propertyPath=null)
static | notEmptyKey ($value, $key, $message=null, string $propertyPath=null)
static | notBlank ($value, $message=null, string $propertyPath=null)
static | isInstanceOf ($value, $className, $message=null, string $propertyPath=null)
static | notIsInstanceOf ($value, $className, $message=null, string $propertyPath=null)
static | subclassOf ($value, $className, $message=null, string $propertyPath=null)
static | range ($value, $minValue, $maxValue, $message=null, string $propertyPath=null)
static | min ($value, $minValue, $message=null, string $propertyPath=null)
static | max ($value, $maxValue, $message=null, string $propertyPath=null)
static | file ($value, $message=null, string $propertyPath=null)
static | directory ($value, $message=null, string $propertyPath=null)
static | readable ($value, $message=null, string $propertyPath=null)
static | writeable ($value, $message=null, string $propertyPath=null)
static | email ($value, $message=null, string $propertyPath=null)
static | url ($value, $message=null, string $propertyPath=null)
static | alnum ($value, $message=null, string $propertyPath=null)
static | true ($value, $message=null, string $propertyPath=null)
static | false ($value, $message=null, string $propertyPath=null)
static | classExists ($value, $message=null, string $propertyPath=null)
static | interfaceExists ($value, $message=null, string $propertyPath=null)
static | implementsInterface ($class, $interfaceName, $message=null, string $propertyPath=null)
static | isJsonString ($value, $message=null, string $propertyPath=null)
static | uuid ($value, $message=null, string $propertyPath=null)
static | e164 ($value, $message=null, string $propertyPath=null)
static | count ($countable, $count, $message=null, string $propertyPath=null)
static | minCount ($countable, $count, $message=null, string $propertyPath=null)
static | maxCount ($countable, $count, $message=null, string $propertyPath=null)
static | __callStatic ($method, $args)
static | choicesNotEmpty (array $values, array $choices, $message=null, string $propertyPath=null)
static | methodExists ($value, $object, $message=null, string $propertyPath=null)
static | isObject ($value, $message=null, string $propertyPath=null)
static | lessThan ($value, $limit, $message=null, string $propertyPath=null)
static | lessOrEqualThan ($value, $limit, $message=null, string $propertyPath=null)
static | greaterThan ($value, $limit, $message=null, string $propertyPath=null)
static | greaterOrEqualThan ($value, $limit, $message=null, string $propertyPath=null)
static | between ($value, $lowerLimit, $upperLimit, $message=null, string $propertyPath=null)
static | betweenExclusive ($value, $lowerLimit, $upperLimit, $message=null, string $propertyPath=null)
static | extensionLoaded ($value, $message=null, string $propertyPath=null)
static | date ($value, $format, $message=null, string $propertyPath=null)
static | objectOrClass ($value, $message=null, string $propertyPath=null)
static | propertyExists ($value, $property, $message=null, string $propertyPath=null)
static | propertiesExist ($value, array $properties, $message=null, string $propertyPath=null)
static | version ($version1, $operator, $version2, $message=null, string $propertyPath=null)
static | phpVersion ($operator, $version, $message=null, string $propertyPath=null)
static | extensionVersion ($extension, $operator, $version, $message=null, string $propertyPath=null)
static | isCallable ($value, $message=null, string $propertyPath=null)
static | satisfy ($value, $callback, $message=null, string $propertyPath=null)
static | ip ($value, $flag=null, $message=null, string $propertyPath=null)
static | ipv4 ($value, $flag=null, $message=null, string $propertyPath=null)
static | ipv6 ($value, $flag=null, $message=null, string $propertyPath=null)
static | defined ($constant, $message=null, string $propertyPath=null)
static | base64 ($value, $message=null, string $propertyPath=null)

Champs de données

const | INVALID_FLOAT = 9
const | INVALID_INTEGER = 10
const | INVALID_DIGIT = 11
const | INVALID_INTEGERISH = 12
const | INVALID_BOOLEAN = 13
const | VALUE_EMPTY = 14
const | VALUE_NULL = 15
const | VALUE_NOT_NULL = 25
const | INVALID_STRING = 16
const | INVALID_REGEX = 17
const | INVALID_MIN_LENGTH = 18
const | INVALID_MAX_LENGTH = 19
const | INVALID_STRING_START = 20
const | INVALID_STRING_CONTAINS = 21
const | INVALID_CHOICE = 22
const | INVALID_NUMERIC = 23
const | INVALID_ARRAY = 24
const | INVALID_KEY_EXISTS = 26
const | INVALID_NOT_BLANK = 27
const | INVALID_INSTANCE_OF = 28
const | INVALID_SUBCLASS_OF = 29
const | INVALID_RANGE = 30
const | INVALID_ALNUM = 31
const | INVALID_TRUE = 32
const | INVALID_EQ = 33
const | INVALID_SAME = 34
const | INVALID_MIN = 35
const | INVALID_MAX = 36
const | INVALID_LENGTH = 37
const | INVALID_FALSE = 38
const | INVALID_STRING_END = 39
const | INVALID_UUID = 40
const | INVALID_COUNT = 41
const | INVALID_NOT_EQ = 42
const | INVALID_NOT_SAME = 43
const | INVALID_TRAVERSABLE = 44
const | INVALID_ARRAY_ACCESSIBLE = 45
const | INVALID_KEY_ISSET = 46
const | INVALID_VALUE_IN_ARRAY = 47
const | INVALID_E164 = 48
const | INVALID_BASE64 = 49
const | INVALID_NOT_REGEX = 50
const | INVALID_DIRECTORY = 101
const | INVALID_FILE = 102
const | INVALID_READABLE = 103
const | INVALID_WRITEABLE = 104
const | INVALID_CLASS = 105
const | INVALID_INTERFACE = 106
const | INVALID_FILE_NOT_EXISTS = 107
const | INVALID_EMAIL = 201
const | INTERFACE_NOT_IMPLEMENTED = 202
const | INVALID_URL = 203
const | INVALID_NOT_INSTANCE_OF = 204
const | VALUE_NOT_EMPTY = 205
const | INVALID_JSON_STRING = 206
const | INVALID_OBJECT = 207
const | INVALID_METHOD = 208
const | INVALID_SCALAR = 209
const | INVALID_LESS = 210
const | INVALID_LESS_OR_EQUAL = 211
const | INVALID_GREATER = 212
const | INVALID_GREATER_OR_EQUAL = 213
const | INVALID_DATE = 214
const | INVALID_CALLABLE = 215
const | INVALID_KEY_NOT_EXISTS = 216
const | INVALID_SATISFY = 217
const | INVALID_IP = 218
const | INVALID_BETWEEN = 219
const | INVALID_BETWEEN_EXCLUSIVE = 220
const | INVALID_EXTENSION = 222
const | INVALID_CONSTANT = 221
const | INVALID_VERSION = 223
const | INVALID_PROPERTY = 224
const | INVALID_RESOURCE = 225
const | INVALID_COUNTABLE = 226
const | INVALID_MIN_COUNT = 227
const | INVALID_MAX_COUNT = 228
const | INVALID_STRING_NOT_CONTAINS = 229
const | INVALID_UNIQUE_VALUES = 230

Fonctions membres protégées statiques

static | createException ($value, $message, $code, $propertyPath=null, array $constraints=[])
static | stringify ($value)
static | generateMessage ($message)

Attributs protégés statiques

static $exceptionClass = InvalidArgumentException::class

Description détaillée

Assert library.

Auteur
Benjamin Eberlei konta.nosp@m.kt@b.nosp@m.eberl.nosp@m.ei.d.nosp@m.e

static bool allAlnum(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is alphanumeric for all values. static bool allBase64(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that a constant is defined for all values. static bool allBetween(mixed[] $value, mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater or equal than a lower limit, and less than or equal to an upper limit for all values. static bool allBetweenExclusive(mixed[] $value, mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater than a lower limit, and less than an upper limit for all values. static bool allBetweenLength(mixed[] $value, int $minLength, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string length is between min and max lengths for all values. static bool allBoolean(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is php boolean for all values. static bool allChoice(mixed[] $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices for all values. static bool allChoicesNotEmpty(array[] $values, array $choices, string|callable $message = null, string $propertyPath = null) Determines if the values array has every choice as key and that this choice has content for all values. static bool allClassExists(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the class exists for all values. static bool allContains(mixed[] $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string contains a sequence of chars for all values. static bool allCount(array[]|Countable[]|ResourceBundle[]|SimpleXMLElement[] $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the count of countable is equal to count for all values. static bool allDate(string[] $value, string $format, string|callable $message = null, string $propertyPath = null) Assert that date is valid and corresponds to the given format for all values. static bool allDefined(mixed[] $constant, string|callable $message = null, string $propertyPath = null) Assert that a constant is defined for all values. static bool allDigit(mixed[] $value, string|callable $message = null, string $propertyPath = null) Validates if an integer or integerish is a digit for all values. static bool allDirectory(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that a directory exists for all values. static bool allE164(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid E164 Phone Number for all values. static bool allEmail(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is an email address (using input_filter/FILTER_VALIDATE_EMAIL) for all values. static bool allEndsWith(mixed[] $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string ends with a sequence of chars for all values. static bool allEq(mixed[] $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are equal (using ==) for all values. static bool allEqArraySubset(mixed[] $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that the array contains the subset for all values. static bool allExtensionLoaded(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded for all values. static bool allExtensionVersion(string[] $extension, string $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded and a specific version is installed for all values. static bool allFalse(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the value is boolean False for all values. static bool allFile(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that a file exists for all values. static bool allFloat(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php float for all values. static bool allGreaterOrEqualThan(mixed[] $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater or equal than given limit for all values. static bool allGreaterThan(mixed[] $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater than given limit for all values. static bool allImplementsInterface(mixed[] $class, string $interfaceName, string|callable $message = null, string $propertyPath = null) Assert that the class implements the interface for all values. static bool allInArray(mixed[] $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. This is an alias of Assertion::choice() for all values. static bool allInteger(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php integer for all values. static bool allIntegerish(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php integer'ish for all values. static bool allInterfaceExists(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the interface exists for all values. static bool allIp(string[] $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 or IPv6 address for all values. static bool allIpv4(string[] $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 address for all values. static bool allIpv6(string[] $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv6 address for all values. static bool allIsArray(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array for all values. static bool allIsArrayAccessible(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array or an array-accessible object for all values. static bool allIsCallable(mixed[] $value, string|callable $message = null, string $propertyPath = null) Determines that the provided value is callable for all values. static bool allIsCountable(array[]|Countable[]|ResourceBundle[]|SimpleXMLElement[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is countable for all values. static bool allIsInstanceOf(mixed[] $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is instance of given class-name for all values. static bool allIsJsonString(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid json string for all values. static bool allIsObject(mixed[] $value, string|callable $message = null, string $propertyPath = null) Determines that the provided value is an object for all values. static bool allIsResource(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a resource for all values. static bool allIsTraversable(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array or a traversable object for all values. static bool allKeyExists(mixed[] $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array for all values. static bool allKeyIsset(mixed[] $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object using isset() for all values. static bool allKeyNotExists(mixed[] $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key does not exist in an array for all values. static bool allLength(mixed[] $value, int $length, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string has a given length for all values. static bool allLessOrEqualThan(mixed[] $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less or equal than given limit for all values. static bool allLessThan(mixed[] $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less than given limit for all values. static bool allMax(mixed[] $value, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that a number is smaller as a given limit for all values. static bool allMaxCount(array[]|Countable[]|ResourceBundle[]|SimpleXMLElement[] $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at most $count elements for all values. static bool allMaxLength(mixed[] $value, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string value is not longer than $maxLength chars for all values. static bool allMethodExists(string[] $value, mixed $object, string|callable $message = null, string $propertyPath = null) Determines that the named method is defined in the provided object for all values. static bool allMin(mixed[] $value, mixed $minValue, string|callable $message = null, string $propertyPath = null) Assert that a value is at least as big as a given limit for all values. static bool allMinCount(array[]|Countable[]|ResourceBundle[]|SimpleXMLElement[] $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at least $count elements for all values. static bool allMinLength(mixed[] $value, int $minLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that a string is at least $minLength chars long for all values. static bool allNoContent(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is empty for all values. static bool allNotBlank(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is not blank for all values. static bool allNotContains(mixed[] $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string does not contains a sequence of chars for all values. static bool allNotEmpty(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is not empty for all values. static bool allNotEmptyKey(mixed[] $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object and its value is not empty for all values. static bool allNotEq(mixed[] $value1, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not equal (using ==) for all values. static bool allNotInArray(mixed[] $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is not in array of choices for all values. static bool allNotIsInstanceOf(mixed[] $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is not instance of given class-name for all values. static bool allNotNull(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is not null for all values. static bool allNotRegex(mixed[] $value, string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value does not match a regex for all values. static bool allNotSame(mixed[] $value1, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not the same (using ===) for all values. static bool allNull(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is null for all values. static bool allNumeric(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is numeric for all values. static bool allObjectOrClass(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the value is an object, or a class that exists for all values. static bool allPhpVersion(string[] $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert on PHP version for all values. static bool allPropertiesExist(mixed[] $value, array $properties, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the properties all exist for all values. static bool allPropertyExists(mixed[] $value, string $property, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the property exists for all values. static bool allRange(mixed[] $value, mixed $minValue, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that value is in range of numbers for all values. static bool allReadable(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that the value is something readable for all values. static bool allRegex(mixed[] $value, string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value matches a regex for all values. static bool allSame(mixed[] $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are the same (using ===) for all values. static bool allSatisfy(mixed[] $value, callable $callback, string|callable $message = null, string $propertyPath = null) Assert that the provided value is valid according to a callback for all values. static bool allScalar(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a PHP scalar for all values. static bool allStartsWith(mixed[] $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string starts with a sequence of chars for all values. static bool allString(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is a string for all values. static bool allSubclassOf(mixed[] $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is subclass of given class-name for all values. static bool allTrue(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that the value is boolean True for all values. static bool allUniqueValues(array[] $values, string|callable $message = null, string $propertyPath = null) Assert that values in array are unique (using strict equality) for all values. static bool allUrl(mixed[] $value, string|callable $message = null, string $propertyPath = null) Assert that value is an URL for all values. static bool allUuid(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid UUID for all values. static bool allVersion(string[] $version1, string $operator, string $version2, string|callable $message = null, string $propertyPath = null) Assert comparison of two versions for all values. static bool allWriteable(string[] $value, string|callable $message = null, string $propertyPath = null) Assert that the value is something writeable for all values. static bool nullOrAlnum(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is alphanumeric or that the value is null. static bool nullOrBase64(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that a constant is defined or that the value is null. static bool nullOrBetween(mixed|null $value, mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater or equal than a lower limit, and less than or equal to an upper limit or that the value is null. static bool nullOrBetweenExclusive(mixed|null $value, mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater than a lower limit, and less than an upper limit or that the value is null. static bool nullOrBetweenLength(mixed|null $value, int $minLength, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string length is between min and max lengths or that the value is null. static bool nullOrBoolean(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is php boolean or that the value is null. static bool nullOrChoice(mixed|null $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices or that the value is null. static bool nullOrChoicesNotEmpty(array|null $values, array $choices, string|callable $message = null, string $propertyPath = null) Determines if the values array has every choice as key and that this choice has content or that the value is null. static bool nullOrClassExists(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the class exists or that the value is null. static bool nullOrContains(mixed|null $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string contains a sequence of chars or that the value is null. static bool nullOrCount(array|Countable|ResourceBundle|SimpleXMLElement|null $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the count of countable is equal to count or that the value is null. static bool nullOrDate(string|null $value, string $format, string|callable $message = null, string $propertyPath = null) Assert that date is valid and corresponds to the given format or that the value is null. static bool nullOrDefined(mixed|null $constant, string|callable $message = null, string $propertyPath = null) Assert that a constant is defined or that the value is null. static bool nullOrDigit(mixed|null $value, string|callable $message = null, string $propertyPath = null) Validates if an integer or integerish is a digit or that the value is null. static bool nullOrDirectory(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that a directory exists or that the value is null. static bool nullOrE164(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid E164 Phone Number or that the value is null. static bool nullOrEmail(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is an email address (using input_filter/FILTER_VALIDATE_EMAIL) or that the value is null. static bool nullOrEndsWith(mixed|null $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string ends with a sequence of chars or that the value is null. static bool nullOrEq(mixed|null $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are equal (using ==) or that the value is null. static bool nullOrEqArraySubset(mixed|null $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that the array contains the subset or that the value is null. static bool nullOrExtensionLoaded(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded or that the value is null. static bool nullOrExtensionVersion(string|null $extension, string $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded and a specific version is installed or that the value is null. static bool nullOrFalse(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the value is boolean False or that the value is null. static bool nullOrFile(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that a file exists or that the value is null. static bool nullOrFloat(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php float or that the value is null. static bool nullOrGreaterOrEqualThan(mixed|null $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater or equal than given limit or that the value is null. static bool nullOrGreaterThan(mixed|null $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater than given limit or that the value is null. static bool nullOrImplementsInterface(mixed|null $class, string $interfaceName, string|callable $message = null, string $propertyPath = null) Assert that the class implements the interface or that the value is null. static bool nullOrInArray(mixed|null $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. This is an alias of Assertion::choice() or that the value is null. static bool nullOrInteger(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php integer or that the value is null. static bool nullOrIntegerish(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a php integer'ish or that the value is null. static bool nullOrInterfaceExists(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the interface exists or that the value is null. static bool nullOrIp(string|null $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 or IPv6 address or that the value is null. static bool nullOrIpv4(string|null $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 address or that the value is null. static bool nullOrIpv6(string|null $value, int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv6 address or that the value is null. static bool nullOrIsArray(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array or that the value is null. static bool nullOrIsArrayAccessible(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array or an array-accessible object or that the value is null. static bool nullOrIsCallable(mixed|null $value, string|callable $message = null, string $propertyPath = null) Determines that the provided value is callable or that the value is null. static bool nullOrIsCountable(array|Countable|ResourceBundle|SimpleXMLElement|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is countable or that the value is null. static bool nullOrIsInstanceOf(mixed|null $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is instance of given class-name or that the value is null. static bool nullOrIsJsonString(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid json string or that the value is null. static bool nullOrIsObject(mixed|null $value, string|callable $message = null, string $propertyPath = null) Determines that the provided value is an object or that the value is null. static bool nullOrIsResource(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a resource or that the value is null. static bool nullOrIsTraversable(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is an array or a traversable object or that the value is null. static bool nullOrKeyExists(mixed|null $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array or that the value is null. static bool nullOrKeyIsset(mixed|null $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object using isset() or that the value is null. static bool nullOrKeyNotExists(mixed|null $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key does not exist in an array or that the value is null. static bool nullOrLength(mixed|null $value, int $length, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string has a given length or that the value is null. static bool nullOrLessOrEqualThan(mixed|null $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less or equal than given limit or that the value is null. static bool nullOrLessThan(mixed|null $value, mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less than given limit or that the value is null. static bool nullOrMax(mixed|null $value, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that a number is smaller as a given limit or that the value is null. static bool nullOrMaxCount(array|Countable|ResourceBundle|SimpleXMLElement|null $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at most $count elements or that the value is null. static bool nullOrMaxLength(mixed|null $value, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string value is not longer than $maxLength chars or that the value is null. static bool nullOrMethodExists(string|null $value, mixed $object, string|callable $message = null, string $propertyPath = null) Determines that the named method is defined in the provided object or that the value is null. static bool nullOrMin(mixed|null $value, mixed $minValue, string|callable $message = null, string $propertyPath = null) Assert that a value is at least as big as a given limit or that the value is null. static bool nullOrMinCount(array|Countable|ResourceBundle|SimpleXMLElement|null $countable, int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at least $count elements or that the value is null. static bool nullOrMinLength(mixed|null $value, int $minLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that a string is at least $minLength chars long or that the value is null. static bool nullOrNoContent(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is empty or that the value is null. static bool nullOrNotBlank(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is not blank or that the value is null. static bool nullOrNotContains(mixed|null $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string does not contains a sequence of chars or that the value is null. static bool nullOrNotEmpty(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is not empty or that the value is null. static bool nullOrNotEmptyKey(mixed|null $value, string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object and its value is not empty or that the value is null. static bool nullOrNotEq(mixed|null $value1, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not equal (using ==) or that the value is null. static bool nullOrNotInArray(mixed|null $value, array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is not in array of choices or that the value is null. static bool nullOrNotIsInstanceOf(mixed|null $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is not instance of given class-name or that the value is null. static bool nullOrNotNull(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is not null or that the value is null. static bool nullOrNotRegex(mixed|null $value, string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value does not match a regex or that the value is null. static bool nullOrNotSame(mixed|null $value1, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not the same (using ===) or that the value is null. static bool nullOrNull(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is null or that the value is null. static bool nullOrNumeric(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is numeric or that the value is null. static bool nullOrObjectOrClass(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the value is an object, or a class that exists or that the value is null. static bool nullOrPhpVersion(string|null $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert on PHP version or that the value is null. static bool nullOrPropertiesExist(mixed|null $value, array $properties, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the properties all exist or that the value is null. static bool nullOrPropertyExists(mixed|null $value, string $property, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the property exists or that the value is null. static bool nullOrRange(mixed|null $value, mixed $minValue, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that value is in range of numbers or that the value is null. static bool nullOrReadable(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that the value is something readable or that the value is null. static bool nullOrRegex(mixed|null $value, string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value matches a regex or that the value is null. static bool nullOrSame(mixed|null $value, mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are the same (using ===) or that the value is null. static bool nullOrSatisfy(mixed|null $value, callable $callback, string|callable $message = null, string $propertyPath = null) Assert that the provided value is valid according to a callback or that the value is null. static bool nullOrScalar(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a PHP scalar or that the value is null. static bool nullOrStartsWith(mixed|null $string, string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string starts with a sequence of chars or that the value is null. static bool nullOrString(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is a string or that the value is null. static bool nullOrSubclassOf(mixed|null $value, string $className, string|callable $message = null, string $propertyPath = null) Assert that value is subclass of given class-name or that the value is null. static bool nullOrTrue(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that the value is boolean True or that the value is null. static bool nullOrUniqueValues(array|null $values, string|callable $message = null, string $propertyPath = null) Assert that values in array are unique (using strict equality) or that the value is null. static bool nullOrUrl(mixed|null $value, string|callable $message = null, string $propertyPath = null) Assert that value is an URL or that the value is null. static bool nullOrUuid(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid UUID or that the value is null. static bool nullOrVersion(string|null $version1, string $operator, string $version2, string|callable $message = null, string $propertyPath = null) Assert comparison of two versions or that the value is null. static bool nullOrWriteable(string|null $value, string|callable $message = null, string $propertyPath = null) Assert that the value is something writeable or that the value is null.

Documentation des fonctions membres

◆ __callStatic()

static __callStatic | ( | $method,
 |  | $args
 | ) |
static

static call handler to implement:

  • "null or assertion" delegation
  • "all" delegation.
Paramètres
string | $method
array | $args
Renvoie
bool|mixed
Exceptions
AssertionFailedException

Références $method, $value, et null.

◆ alnum()

static alnum | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is alphanumeric.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ base64()

static base64 | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a constant is defined.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ between()

static between | ( |  | $value,
 |  |  | $lowerLimit,
 |  |  | $upperLimit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a value is greater or equal than a lower limit, and less than or equal to an upper limit.

Paramètres
mixed | $value
mixed | $lowerLimit
mixed | $upperLimit
string | callable | null | $message
string | $propertyPath
Exceptions
AssertionFailedException

Références $message, et $value.

◆ betweenExclusive()

static betweenExclusive | ( |  | $value,
 |  |  | $lowerLimit,
 |  |  | $upperLimit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a value is greater than a lower limit, and less than an upper limit.

Paramètres
mixed | $value
mixed | $lowerLimit
mixed | $upperLimit
string | callable | null | $message
string | $propertyPath
Exceptions
AssertionFailedException

Références $message, et $value.

◆ betweenLength()

static betweenLength | ( |  | $value,
 |  |  | $minLength,
 |  |  | $maxLength,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string length is between min and max lengths.

Paramètres
mixed | $value
int | $minLength
int | $maxLength
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ boolean()

static boolean | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is php boolean.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert bool $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ choice()

static choice | ( |  | $value,
 |  | array | $choices,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is in array of choices.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ choicesNotEmpty()

static choicesNotEmpty | ( | array | $values,
 |  | array | $choices,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines if the values array has every choice as key and that this choice has content.

Paramètres
string | callable | null $message
Exceptions
AssertionFailedException

Références $message.

◆ classExists()

static classExists | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the class exists.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert class-string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ contains()

static contains | ( |  | $string,
 |  |  | $needle,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string contains a sequence of chars.

Paramètres
mixed | $string
string | $needle
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $string
Renvoie
bool
Exceptions
AssertionFailedException

Références $message.

◆ count()

static count | ( |  | $countable,
 |  |  | $count,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the count of countable is equal to count.

Paramètres
array | Countable | ResourceBundle | SimpleXMLElement | $countable
int | $count
string | callable | null | $message
string | null | $propertyPath
Renvoie
bool
Exceptions
AssertionFailedException

Références $count, et $message.

Référencé par FidoU2FAttestationStatementSupport\load().

◆ createException()

static createException | ( |  | $value,
 |  |  | $message,
 |  |  | $code,
 |  |  | $propertyPath = null,
 |  | array | $constraints = []
 | ) |  |
staticprotected

Helper method that handles building the assertion failure exceptions. They are returned from this method so that the stack trace still shows the assertions method.

Paramètres
mixed | $value
string | callable | null | $message
int | $code
Renvoie
mixed

Références $message, et $value.

◆ date()

static date | ( |  | $value,
 |  |  | $format,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that date is valid and corresponds to the given format.

Paramètres
string | $value
string | $format | supports all of the options date(), except for the following: N, w, W, t, L, o, B, a, A, g, h, I, O, P, Z, c, r
string | callable | null | $message
Exceptions
AssertionFailedException
Voir également
http://php.net/manual/function.date.php#refsect1-function.date-parameters

Références $format, $message, et $value.

◆ defined()

static defined | ( |  | $constant,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a constant is defined.

Paramètres
mixed | $constant
string | callable | null | $message

Références $message.

◆ digit()

static digit | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Validates if an integer or integerish is a digit.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert =numeric $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ directory()

static directory | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a directory exists.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ e164()

static e164 | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the given string is a valid E164 Phone Number.

Voir également
https://en.wikipedia.org/wiki/E.164
Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ email()

static email | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an email address (using input_filter/FILTER_VALIDATE_EMAIL).

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ endsWith()

static endsWith | ( |  | $string,
 |  |  | $needle,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string ends with a sequence of chars.

Paramètres
mixed | $string
string | $needle
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $string
Renvoie
bool
Exceptions
AssertionFailedException

Références $message.

◆ eq()

static eq | ( |  | $value,
 |  |  | $value2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that two values are equal (using ==).

Paramètres
mixed | $value
mixed | $value2
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par SymmetricKey\__construct(), OkpKey\__construct(), RsaKey\__construct(), Ec2Key\__construct(), FidoU2FAttestationStatementSupport\checkCertificate(), TPMAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), TPMAttestationStatementSupport\checkCertInfo(), Hmac\checKey(), AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), TPMAttestationStatementSupport\checkUniquePublicKey(), AuthenticationExtensionsClientOutputs\createFromString(), MetadataStatementFetcher\fetch(), MetadataStatementFetcher\fetchMetadataStatement(), MetadataStatementFetcher\fetchTableOfContent(), MetadataStatementFetcher\getJwsPayload(), SingleMetadata\getMetadataStatement(), ECDSA\handleKey(), FidoU2FAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\load(), PackedAttestationStatementSupport\processWithSelfAttestation(), AndroidSafetyNetAttestationStatementSupport\validatePayload(), et AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ eqArraySubset()

static eqArraySubset | ( |  | $value,
 |  |  | $value2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the array contains the subset.

Paramètres
mixed | $value
mixed | $value2
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ extensionLoaded()

static extensionLoaded | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that extension is loaded.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ extensionVersion()

static extensionVersion | ( |  | $extension,
 |  |  | $operator,
 |  |  | $version,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that extension is loaded and a specific version is installed.

Paramètres
string | $extension
string | $operator
mixed | $version
string | callable | null | $message
Exceptions
AssertionFailedException

Références $extension, $message, et $version.

◆ false()

static false | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is boolean False.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert false $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par TokenBinding\__construct(), RsaKey\asPem(), PackedAttestationStatementSupport\checkCertificate(), et TPMAttestationStatementSupport\checkCertificate().

◆ file()

static file | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a file exists.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ float()

static float | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a php float.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert float $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ generateMessage()

static generateMessage ( $message )
staticprotected

Generate the message.

Paramètres
string | callable | null $message

Références $message, $method, et $parameters.

◆ greaterOrEqualThan()

static greaterOrEqualThan | ( |  | $value,
 |  |  | $limit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines if the value is greater or equal than given limit.

Paramètres
mixed | $value
mixed | $limit
string | callable | null | $message
Exceptions
AssertionFailedException

Références $limit, $message, et $value.

◆ greaterThan()

static greaterThan | ( |  | $value,
 |  |  | $limit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines if the value is greater than given limit.

Paramètres
mixed | $value
mixed | $limit
string | callable | null | $message
Exceptions
AssertionFailedException

Références $limit, $message, et $value.

Référencé par AndroidKeyAttestationStatementSupport\load().

◆ implementsInterface()

static implementsInterface | ( |  | $class,
 |  |  | $interfaceName,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the class implements the interface.

Paramètres
mixed | $class
string | $interfaceName
string | callable | null | $message
Exceptions
AssertionFailedException

Références $class, et $message.

◆ inArray()

static inArray | ( |  | $value,
 |  | array | $choices,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is in array of choices.

This is an alias of {

Voir également
choice()}.
Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par OkpKey\__construct(), Ec2Key\__construct(), et TokenBinding\createFormArray().

◆ integer()

static integer | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a php integer.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert int $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par TPMAttestationStatementSupport\checkCertificate(), et AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ integerish()

static integerish | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a php integer'ish.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ interfaceExists()

static interfaceExists | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the interface exists.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert class-string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ ip()

static ip | ( |  | $value,
 |  |  | $flag = null,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an IPv4 or IPv6 address (using input_filter/FILTER_VALIDATE_IP).

Paramètres
string | $value
int | null | $flag
string | callable | null | $message
Exceptions
AssertionFailedException
Voir également
http://php.net/manual/filter.filters.flags.php

Références $message, $value, et null.

◆ ipv4()

static ipv4 | ( |  | $value,
 |  |  | $flag = null,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an IPv4 address (using input_filter/FILTER_VALIDATE_IP).

Paramètres
string | $value
int | null | $flag
string | callable | null | $message
Exceptions
AssertionFailedException
Voir également
http://php.net/manual/filter.filters.flags.php

Références $message, et $value.

◆ ipv6()

static ipv6 | ( |  | $value,
 |  |  | $flag = null,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an IPv6 address (using input_filter/FILTER_VALIDATE_IP).

Paramètres
string | $value
int | null | $flag
string | callable | null | $message
Exceptions
AssertionFailedException
Voir également
http://php.net/manual/filter.filters.flags.php

Références $message, et $value.

◆ isArray()

static isArray | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an array.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert array $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par PackedAttestationStatementSupport\checkCertificate(), TPMAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), VerificationMethodANDCombinations\createFromArray(), DisplayPNGCharacteristicsDescriptor\createFromArray(), MetadataTOCPayloadEntry\createFromArray(), MetadataStatement\createFromArray(), AuthenticationExtensionsClientOutputs\createFromString(), MetadataStatementFetcher\getJwsPayload(), AttestationObjectLoader\load(), FidoU2FAttestationStatementSupport\load(), AndroidKeyAttestationStatementSupport\load(), PackedAttestationStatementSupport\loadBasicType(), et AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ isArrayAccessible()

static isArrayAccessible | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an array or an array-accessible object.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ isCallable()

static isCallable | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines that the provided value is callable.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert callable $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ isCountable()

static isCountable | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is countable.

Paramètres
array | Countable | ResourceBundle | SimpleXMLElement | $value
string | callable | null | $message
string | null | $propertyPath | -assert countable $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ isInstanceOf()

static isInstanceOf | ( |  | $value,
 |  |  | $className,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is instance of given class-name.

Paramètres
mixed | $value
string | $className
string | callable | null | $message
string | null | $propertyPath | -template ExpectedType of object -param class-string<ExpectedType> $className -assert ExpectedType $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $className, $message, et $value.

Référencé par AndroidKeyAttestationStatementSupport\checkAbsenceOfAllApplicationsTag(), FidoU2FAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), TPMAttestationStatementSupport\checkUniquePublicKey(), FidoU2FAttestationStatementSupport\extractPublicKey(), FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), AuthenticationExtensionsClientOutputsLoader\load(), AttestationObjectLoader\load(), Server\loadAndCheckAssertionResponse(), Server\loadAndCheckAttestationResponse(), TPMAttestationStatementSupport\processWithCertificate(), et PackedAttestationStatementSupport\processWithSelfAttestation().

◆ isJsonString()

static isJsonString | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the given string is a valid json string.

NOTICE: Since this does a json_decode to determine its validity you probably should consider, when using the variable content afterwards, just to decode and check for yourself instead of using this assertion.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, $value, et null.

◆ isObject()

static isObject | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines that the provided value is an object.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert object $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ isResource()

static isResource | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a resource.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert resource $value
Renvoie
bool

Références $message, et $value.

Référencé par FidoU2FAttestationStatementSupport\checkCertificate(), et AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey().

◆ isTraversable()

static isTraversable | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an array or a traversable object.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert iterable $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ keyExists()

static keyExists | ( |  | $value,
 |  |  | $key,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that key exists in an array.

Paramètres
mixed | $value
string | int | $key
string | callable | null | $message
Exceptions
AssertionFailedException

Références $key, $message, et $value.

Référencé par SymmetricKey\__construct(), Key\__construct(), OkpKey\__construct(), RsaKey\__construct(), Ec2Key\__construct(), FidoU2FAttestationStatementSupport\checkCertificate(), TPMAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), ManagerFactory\create(), TokenBinding\createFormArray(), CertificateTrustPath\createFromArray(), EcdaaKeyIdTrustPath\createFromArray(), AttestationStatement\createFromArray(), Key\createFromData(), Key\get(), MetadataStatementFetcher\getJwsPayload(), AttestationObjectLoader\load(), TPMAttestationStatementSupport\load(), FidoU2FAttestationStatementSupport\load(), AndroidKeyAttestationStatementSupport\load(), PackedAttestationStatementSupport\load(), AndroidSafetyNetAttestationStatementSupport\load(), TrustPathLoader\loadTrustPath(), AndroidSafetyNetAttestationStatementSupport\validatePayload(), et AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ keyIsset()

static keyIsset | ( |  | $value,
 |  |  | $key,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that key exists in an array/array-accessible object using isset().

Paramètres
mixed | $value
string | int | $key
string | callable | null | $message
Exceptions
AssertionFailedException

Références $key, $message, et $value.

◆ keyNotExists()

static keyNotExists | ( |  | $value,
 |  |  | $key,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that key does not exist in an array.

Paramètres
mixed | $value
string | int | $key
string | callable | null | $message
Exceptions
AssertionFailedException

Références $key, $message, et $value.

Référencé par TPMAttestationStatementSupport\load().

◆ length()

static length | ( |  | $value,
 |  |  | $length,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string has a given length.

Paramètres
mixed | $value
int | $length
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par Ec2Key\__construct().

◆ lessOrEqualThan()

static lessOrEqualThan | ( |  | $value,
 |  |  | $limit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines if the value is less or equal than given limit.

Paramètres
mixed | $value
mixed | $limit
string | callable | null | $message
Exceptions
AssertionFailedException

Références $limit, $message, et $value.

Référencé par AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ lessThan()

static lessThan | ( |  | $value,
 |  |  | $limit,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines if the value is less than given limit.

Paramètres
mixed | $value
mixed | $limit
string | callable | null | $message
Exceptions
AssertionFailedException

Références $limit, $message, et $value.

◆ max()

static max | ( |  | $value,
 |  |  | $maxValue,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a number is smaller as a given limit.

Paramètres
mixed | $value
mixed | $maxValue
string | callable | null | $message
string | null | $propertyPath | -assert =numeric $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ maxCount()

static maxCount | ( |  | $countable,
 |  |  | $count,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the countable have at most $count elements.

Paramètres
array | Countable | ResourceBundle | SimpleXMLElement | $countable
int | $count
string | callable | null | $message
Exceptions
AssertionFailedException

Références $count, et $message.

◆ maxLength()

static maxLength | ( |  | $value,
 |  |  | $maxLength,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string value is not longer than $maxLength chars.

Paramètres
mixed | $value
int | $maxLength
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ methodExists()

static methodExists | ( |  | $value,
 |  |  | $object,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Determines that the named method is defined in the provided object.

Paramètres
string | $value
mixed | $object
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ min()

static min | ( |  | $value,
 |  |  | $minValue,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that a value is at least as big as a given limit.

Paramètres
mixed | $value
mixed | $minValue
string | callable | null | $message
string | null | $propertyPath | -assert =numeric $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ minCount()

static minCount | ( |  | $countable,
 |  |  | $count,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the countable have at least $count elements.

Paramètres
array | Countable | ResourceBundle | SimpleXMLElement | $countable
int | $count
string | callable | null | $message
Exceptions
AssertionFailedException

Références $count, et $message.

Référencé par TPMAttestationStatementSupport\load(), et PackedAttestationStatementSupport\loadBasicType().

◆ minLength()

static minLength | ( |  | $value,
 |  |  | $minLength,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that a string is at least $minLength chars long.

Paramètres
mixed | $value
int | $minLength
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ noContent()

static noContent | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is empty.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert empty $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par NoneAttestationStatementSupport\load().

◆ notBlank()

static notBlank | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is not blank.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ notContains()

static notContains | ( |  | $string,
 |  |  | $needle,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string does not contains a sequence of chars.

Paramètres
mixed | $string
string | $needle
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $string
Renvoie
bool
Exceptions
AssertionFailedException

Références $message.

◆ notEmpty()

static notEmpty | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is not empty.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert !empty $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par MetadataStatementFetcher\fetch(), MetadataStatementFetcher\getJwsPayload(), et AndroidSafetyNetAttestationStatementSupport\load().

◆ notEmptyKey()

static notEmptyKey | ( |  | $value,
 |  |  | $key,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that key exists in an array/array-accessible object and its value is not empty.

Paramètres
mixed | $value
string | int | $key
string | callable | null | $message
Exceptions
AssertionFailedException

Références $key, $message, et $value.

◆ notEq()

static notEq | ( |  | $value1,
 |  |  | $value2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that two values are not equal (using ==).

Paramètres
mixed | $value1
mixed | $value2
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message.

Référencé par AndroidKeyAttestationStatementSupport\checkAbsenceOfAllApplicationsTag().

◆ notInArray()

static notInArray | ( |  | $value,
 |  | array | $choices,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is not in array of choices.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ notIsInstanceOf()

static notIsInstanceOf | ( |  | $value,
 |  |  | $className,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is not instance of given class-name.

Paramètres
mixed | $value
string | $className
string | callable | null | $message
string | null | $propertyPath | -template ExpectedType of object -param class-string<ExpectedType> $className -assert !ExpectedType $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $className, $message, et $value.

◆ notNull()

static notNull | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is not null.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert !null $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, $value, et null.

Référencé par PackedAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), FidoU2FAttestationStatementSupport\extractPublicKey(), PackedAttestationStatementSupport\processWithSelfAttestation(), et AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ notRegex()

static notRegex | ( |  | $value,
 |  |  | $pattern,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value does not match a regex.

Paramètres
mixed | $value
string | $pattern
string | callable | null | $message
string | null | $propertyPath | -assert !=string $value
Exceptions
AssertionFailedException

Références $message, et $value.

◆ notSame()

static notSame | ( |  | $value1,
 |  |  | $value2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that two values are not the same (using ===).

Paramètres
mixed | $value1
mixed | $value2
string | callable | null | $message
string | null | $propertyPath | -template ExpectedType -param ExpectedType $value2 -assert !=ExpectedType $value1
Renvoie
bool
Exceptions
AssertionFailedException

Références $message.

◆ null()

static null | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is null.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert null $value
Renvoie
bool

Références $message, $value, et null.

◆ numeric()

static numeric | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is numeric.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert numeric $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ objectOrClass()

static objectOrClass | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is an object, or a class that exists.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ phpVersion()

static phpVersion | ( |  | $operator,
 |  |  | $version,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert on PHP version.

Paramètres
string | $operator
mixed | $version
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $version.

◆ propertiesExist()

static propertiesExist | ( |  | $value,
 |  | array | $properties,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is an object or class, and that the properties all exist.

Paramètres
mixed | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ propertyExists()

static propertyExists | ( |  | $value,
 |  |  | $property,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is an object or class, and that the property exists.

Paramètres
mixed | $value
string | $property
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ range()

static range | ( |  | $value,
 |  |  | $minValue,
 |  |  | $maxValue,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is in range of numbers.

Paramètres
mixed | $value
mixed | $minValue
mixed | $maxValue
string | callable | null | $message
string | null | $propertyPath | -assert =numeric $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ readable()

static readable | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is something readable.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ regex()

static regex | ( |  | $value,
 |  |  | $pattern,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value matches a regex.

Paramètres
mixed | $value
string | $pattern
string | callable | null | $message
string | null | $propertyPath | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ same()

static same | ( |  | $value,
 |  |  | $value2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that two values are the same (using ===).

Paramètres
mixed | $value
mixed | $value2
string | callable | null | $message
string | null | $propertyPath | -template ExpectedType -param ExpectedType $value2 -assert =ExpectedType $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ satisfy()

static satisfy | ( |  | $value,
 |  |  | $callback,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the provided value is valid according to a callback.

If the callback returns false the assertion will fail.

Paramètres
mixed | $value
callable | $callback
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ scalar()

static scalar | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a PHP scalar.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert scalar $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

◆ startsWith()

static startsWith | ( |  | $string,
 |  |  | $needle,
 |  |  | $message = null,
 |  | string | $propertyPath = null,
 |  |  | $encoding = 'utf8'
 | ) |  |
static

Assert that string starts with a sequence of chars.

Paramètres
mixed | $string
string | $needle
string | callable | null | $message
string | null | $propertyPath
string | $encoding | -assert =string $string
Renvoie
bool
Exceptions
AssertionFailedException

Références $message.

◆ string()

string | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is a string.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert string $value
Renvoie
bool
Exceptions
AssertionFailedException Exception to throw when an assertion failed.

Références $message, et $value.

Référencé par SingleMetadata\getMetadataStatement(), AuthenticationExtensionsClientOutputsLoader\load(), PackedAttestationStatementSupport\load(), et PackedAttestationStatementSupport\loadEcdaaType().

◆ stringify()

static stringify ( $value )
staticprotected

Make a string version of a value.

Paramètres
mixed $value

Références $result, $val, $value, elseif, et null.

◆ subclassOf()

static subclassOf | ( |  | $value,
 |  |  | $className,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is subclass of given class-name.

Paramètres
mixed | $value
string | $className
string | callable | null | $message
Exceptions
AssertionFailedException

Références $className, $message, et $value.

◆ true()

static true | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is boolean True.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert true $value
Renvoie
bool
Exceptions
AssertionFailedException

Références $message, et $value.

Référencé par TokenBindingNotSupportedHandler\check(), TPMAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), TPMAttestationStatementSupport\checkCertInfo(), Hmac\checKey(), AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), TPMAttestationStatementSupport\checkPubArea(), OkpKey\d(), RsaKey\d(), Ec2Key\d(), RsaKey\dI(), RsaKey\dP(), RsaKey\dQ(), FidoU2FAttestationStatementSupport\extractPublicKey(), AttestationStatementSupportManager\get(), AuthenticationExtensionsClientInputs\get(), Manager\get(), AuthenticationExtensionsClientOutputs\get(), AttestationStatement\get(), MetadataStatementFetcher\getJwsPayload(), AttestationObjectLoader\load(), RsaKey\other(), RsaKey\p(), PackedAttestationStatementSupport\processWithSelfAttestation(), RsaKey\q(), RsaKey\QInv(), RsaKey\rI(), RSA\sign(), EdDSA\sign(), ECDSA\sign(), RsaKey\tI(), AndroidSafetyNetAttestationStatementSupport\validatePayload(), AndroidSafetyNetAttestationStatementSupport\validateSignature(), et AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ uniqueValues()

static uniqueValues | ( | array | $values,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that values in array are unique (using strict equality).

Paramètres
mixed[] | $values
string | callable | null | $message
Exceptions
AssertionFailedException

Références $key, $message, et $value.

◆ url()

static url | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that value is an URL.

This code snipped was taken from the Symfony project and modified to the special demands of this method.

Paramètres
mixed | $value
string | callable | null | $message
string | null | $propertyPath | -assert =string $value
Renvoie
bool
Exceptions
AssertionFailedException
Voir également
https://github.com/symfony/Validator/blob/master/Constraints/UrlValidator.php
https://github.com/symfony/Validator/blob/master/Constraints/Url.php

Références $message, et $value.

◆ uuid()

static uuid | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the given string is a valid UUID.

Uses code from https://github.com/ramsey/uuid that is MIT licensed.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

◆ version()

static version | ( |  | $version1,
 |  |  | $operator,
 |  |  | $version2,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert comparison of two versions.

Paramètres
string | $version1
string | $operator
string | $version2
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, $version1, et $version2.

◆ writeable()

static writeable | ( |  | $value,
 |  |  | $message = null,
 |  | string | $propertyPath = null
 | ) |  |
static

Assert that the value is something writeable.

Paramètres
string | $value
string | callable | null | $message
Exceptions
AssertionFailedException

Références $message, et $value.

Documentation des champs

◆ $exceptionClass

$exceptionClass = InvalidArgumentException::class
staticprotected

◆ INTERFACE_NOT_IMPLEMENTED

const INTERFACE_NOT_IMPLEMENTED = 202

◆ INVALID_ALNUM

const INVALID_ALNUM = 31

◆ INVALID_ARRAY

const INVALID_ARRAY = 24

◆ INVALID_ARRAY_ACCESSIBLE

const INVALID_ARRAY_ACCESSIBLE = 45

◆ INVALID_BASE64

const INVALID_BASE64 = 49

◆ INVALID_BETWEEN

const INVALID_BETWEEN = 219

◆ INVALID_BETWEEN_EXCLUSIVE

const INVALID_BETWEEN_EXCLUSIVE = 220

◆ INVALID_BOOLEAN

const INVALID_BOOLEAN = 13

◆ INVALID_CALLABLE

const INVALID_CALLABLE = 215

◆ INVALID_CHOICE

const INVALID_CHOICE = 22

◆ INVALID_CLASS

const INVALID_CLASS = 105

◆ INVALID_CONSTANT

const INVALID_CONSTANT = 221

◆ INVALID_COUNT

const INVALID_COUNT = 41

◆ INVALID_COUNTABLE

const INVALID_COUNTABLE = 226

◆ INVALID_DATE

const INVALID_DATE = 214

◆ INVALID_DIGIT

const INVALID_DIGIT = 11

◆ INVALID_DIRECTORY

const INVALID_DIRECTORY = 101

◆ INVALID_E164

const INVALID_E164 = 48

◆ INVALID_EMAIL

const INVALID_EMAIL = 201

◆ INVALID_EQ

const INVALID_EQ = 33

◆ INVALID_EXTENSION

const INVALID_EXTENSION = 222

◆ INVALID_FALSE

const INVALID_FALSE = 38

◆ INVALID_FILE

const INVALID_FILE = 102

◆ INVALID_FILE_NOT_EXISTS

const INVALID_FILE_NOT_EXISTS = 107

◆ INVALID_FLOAT

const INVALID_FLOAT = 9

◆ INVALID_GREATER

const INVALID_GREATER = 212

◆ INVALID_GREATER_OR_EQUAL

const INVALID_GREATER_OR_EQUAL = 213

◆ INVALID_INSTANCE_OF

const INVALID_INSTANCE_OF = 28

◆ INVALID_INTEGER

const INVALID_INTEGER = 10

◆ INVALID_INTEGERISH

const INVALID_INTEGERISH = 12

◆ INVALID_INTERFACE

const INVALID_INTERFACE = 106

◆ INVALID_IP

const INVALID_IP = 218

◆ INVALID_JSON_STRING

const INVALID_JSON_STRING = 206

◆ INVALID_KEY_EXISTS

const INVALID_KEY_EXISTS = 26

◆ INVALID_KEY_ISSET

const INVALID_KEY_ISSET = 46

◆ INVALID_KEY_NOT_EXISTS

const INVALID_KEY_NOT_EXISTS = 216

◆ INVALID_LENGTH

const INVALID_LENGTH = 37

◆ INVALID_LESS

const INVALID_LESS = 210

◆ INVALID_LESS_OR_EQUAL

const INVALID_LESS_OR_EQUAL = 211

◆ INVALID_MAX

const INVALID_MAX = 36

◆ INVALID_MAX_COUNT

const INVALID_MAX_COUNT = 228

◆ INVALID_MAX_LENGTH

const INVALID_MAX_LENGTH = 19

◆ INVALID_METHOD

const INVALID_METHOD = 208

◆ INVALID_MIN

const INVALID_MIN = 35

◆ INVALID_MIN_COUNT

const INVALID_MIN_COUNT = 227

◆ INVALID_MIN_LENGTH

const INVALID_MIN_LENGTH = 18

◆ INVALID_NOT_BLANK

const INVALID_NOT_BLANK = 27

◆ INVALID_NOT_EQ

const INVALID_NOT_EQ = 42

◆ INVALID_NOT_INSTANCE_OF

const INVALID_NOT_INSTANCE_OF = 204

◆ INVALID_NOT_REGEX

const INVALID_NOT_REGEX = 50

◆ INVALID_NOT_SAME

const INVALID_NOT_SAME = 43

◆ INVALID_NUMERIC

const INVALID_NUMERIC = 23

◆ INVALID_OBJECT

const INVALID_OBJECT = 207

◆ INVALID_PROPERTY

const INVALID_PROPERTY = 224

◆ INVALID_RANGE

const INVALID_RANGE = 30

◆ INVALID_READABLE

const INVALID_READABLE = 103

◆ INVALID_REGEX

const INVALID_REGEX = 17

◆ INVALID_RESOURCE

const INVALID_RESOURCE = 225

◆ INVALID_SAME

const INVALID_SAME = 34

◆ INVALID_SATISFY

const INVALID_SATISFY = 217

◆ INVALID_SCALAR

const INVALID_SCALAR = 209

◆ INVALID_STRING

const INVALID_STRING = 16

◆ INVALID_STRING_CONTAINS

const INVALID_STRING_CONTAINS = 21

◆ INVALID_STRING_END

const INVALID_STRING_END = 39

◆ INVALID_STRING_NOT_CONTAINS

const INVALID_STRING_NOT_CONTAINS = 229

◆ INVALID_STRING_START

const INVALID_STRING_START = 20

◆ INVALID_SUBCLASS_OF

const INVALID_SUBCLASS_OF = 29

◆ INVALID_TRAVERSABLE

const INVALID_TRAVERSABLE = 44

◆ INVALID_TRUE

const INVALID_TRUE = 32

◆ INVALID_UNIQUE_VALUES

const INVALID_UNIQUE_VALUES = 230

◆ INVALID_URL

const INVALID_URL = 203

◆ INVALID_UUID

const INVALID_UUID = 40

◆ INVALID_VALUE_IN_ARRAY

const INVALID_VALUE_IN_ARRAY = 47

◆ INVALID_VERSION

const INVALID_VERSION = 223

◆ INVALID_WRITEABLE

const INVALID_WRITEABLE = 104

◆ VALUE_EMPTY

const VALUE_EMPTY = 14

◆ VALUE_NOT_EMPTY

const VALUE_NOT_EMPTY = 205

◆ VALUE_NOT_NULL

const VALUE_NOT_NULL = 25

◆ VALUE_NULL

const VALUE_NULL = 15
La documentation de cette classe a été générée à partir du fichier suivant :
  • Assertion.php


Joomla CMS: Référence de la classe AssertionChain

  • Assert
  • AssertionChain
Fonctions membres publiques | Attributs privés
Référence de la classe AssertionChain

Fonctions membres publiques

__construct ($value, $defaultMessage=null, string $defaultPropertyPath=null)
__call ($methodName, $args)
all ()
nullOr ()
setAssertionClassName ($className)

Attributs privés

$value
$defaultMessage
$defaultPropertyPath
$alwaysValid = false
$all = false
$assertionClassName = 'Assert\Assertion'

Description détaillée

Chaining builder for assertions.

Auteur
Benjamin Eberlei konta.nosp@m.kt@b.nosp@m.eberl.nosp@m.ei.d.nosp@m.e

AssertionChain alnum(string|callable $message = null, string $propertyPath = null) Assert that value is alphanumeric. AssertionChain base64(string|callable $message = null, string $propertyPath = null) Assert that a constant is defined. AssertionChain between(mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater or equal than a lower limit, and less than or equal to an upper limit. AssertionChain betweenExclusive(mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater than a lower limit, and less than an upper limit. AssertionChain betweenLength(int $minLength, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string length is between min and max lengths. AssertionChain boolean(string|callable $message = null, string $propertyPath = null) Assert that value is php boolean. AssertionChain choice(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. AssertionChain choicesNotEmpty(array $choices, string|callable $message = null, string $propertyPath = null) Determines if the values array has every choice as key and that this choice has content. AssertionChain classExists(string|callable $message = null, string $propertyPath = null) Assert that the class exists. AssertionChain contains(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string contains a sequence of chars. AssertionChain count(int $count, string|callable $message = null, string $propertyPath = null) Assert that the count of countable is equal to count. AssertionChain date(string $format, string|callable $message = null, string $propertyPath = null) Assert that date is valid and corresponds to the given format. AssertionChain defined(string|callable $message = null, string $propertyPath = null) Assert that a constant is defined. AssertionChain digit(string|callable $message = null, string $propertyPath = null) Validates if an integer or integerish is a digit. AssertionChain directory(string|callable $message = null, string $propertyPath = null) Assert that a directory exists. AssertionChain e164(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid E164 Phone Number. AssertionChain email(string|callable $message = null, string $propertyPath = null) Assert that value is an email address (using input_filter/FILTER_VALIDATE_EMAIL). AssertionChain endsWith(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string ends with a sequence of chars. AssertionChain eq(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are equal (using ==). AssertionChain eqArraySubset(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that the array contains the subset. AssertionChain extensionLoaded(string|callable $message = null, string $propertyPath = null) Assert that extension is loaded. AssertionChain extensionVersion(string $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded and a specific version is installed. AssertionChain false(string|callable $message = null, string $propertyPath = null) Assert that the value is boolean False. AssertionChain file(string|callable $message = null, string $propertyPath = null) Assert that a file exists. AssertionChain float(string|callable $message = null, string $propertyPath = null) Assert that value is a php float. AssertionChain greaterOrEqualThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater or equal than given limit. AssertionChain greaterThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater than given limit. AssertionChain implementsInterface(string $interfaceName, string|callable $message = null, string $propertyPath = null) Assert that the class implements the interface. AssertionChain inArray(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. This is an alias of Assertion::choice(). AssertionChain integer(string|callable $message = null, string $propertyPath = null) Assert that value is a php integer. AssertionChain integerish(string|callable $message = null, string $propertyPath = null) Assert that value is a php integer'ish. AssertionChain interfaceExists(string|callable $message = null, string $propertyPath = null) Assert that the interface exists. AssertionChain ip(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 or IPv6 address. AssertionChain ipv4(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 address. AssertionChain ipv6(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv6 address. AssertionChain isArray(string|callable $message = null, string $propertyPath = null) Assert that value is an array. AssertionChain isArrayAccessible(string|callable $message = null, string $propertyPath = null) Assert that value is an array or an array-accessible object. AssertionChain isCallable(string|callable $message = null, string $propertyPath = null) Determines that the provided value is callable. AssertionChain isCountable(string|callable $message = null, string $propertyPath = null) Assert that value is countable. AssertionChain isInstanceOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is instance of given class-name. AssertionChain isJsonString(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid json string. AssertionChain isObject(string|callable $message = null, string $propertyPath = null) Determines that the provided value is an object. AssertionChain isResource(string|callable $message = null, string $propertyPath = null) Assert that value is a resource. AssertionChain isTraversable(string|callable $message = null, string $propertyPath = null) Assert that value is an array or a traversable object. AssertionChain keyExists(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array. AssertionChain keyIsset(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object using isset(). AssertionChain keyNotExists(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key does not exist in an array. AssertionChain length(int $length, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string has a given length. AssertionChain lessOrEqualThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less or equal than given limit. AssertionChain lessThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less than given limit. AssertionChain max(mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that a number is smaller as a given limit. AssertionChain maxCount(int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at most $count elements. AssertionChain maxLength(int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string value is not longer than $maxLength chars. AssertionChain methodExists(mixed $object, string|callable $message = null, string $propertyPath = null) Determines that the named method is defined in the provided object. AssertionChain min(mixed $minValue, string|callable $message = null, string $propertyPath = null) Assert that a value is at least as big as a given limit. AssertionChain minCount(int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at least $count elements. AssertionChain minLength(int $minLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that a string is at least $minLength chars long. AssertionChain noContent(string|callable $message = null, string $propertyPath = null) Assert that value is empty. AssertionChain notBlank(string|callable $message = null, string $propertyPath = null) Assert that value is not blank. AssertionChain notContains(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string does not contains a sequence of chars. AssertionChain notEmpty(string|callable $message = null, string $propertyPath = null) Assert that value is not empty. AssertionChain notEmptyKey(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object and its value is not empty. AssertionChain notEq(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not equal (using ==). AssertionChain notInArray(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is not in array of choices. AssertionChain notIsInstanceOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is not instance of given class-name. AssertionChain notNull(string|callable $message = null, string $propertyPath = null) Assert that value is not null. AssertionChain notRegex(string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value does not match a regex. AssertionChain notSame(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not the same (using ===). AssertionChain null(string|callable $message = null, string $propertyPath = null) Assert that value is null. AssertionChain numeric(string|callable $message = null, string $propertyPath = null) Assert that value is numeric. AssertionChain objectOrClass(string|callable $message = null, string $propertyPath = null) Assert that the value is an object, or a class that exists. AssertionChain phpVersion(mixed $version, string|callable $message = null, string $propertyPath = null) Assert on PHP version. AssertionChain propertiesExist(array $properties, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the properties all exist. AssertionChain propertyExists(string $property, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the property exists. AssertionChain range(mixed $minValue, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that value is in range of numbers. AssertionChain readable(string|callable $message = null, string $propertyPath = null) Assert that the value is something readable. AssertionChain regex(string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value matches a regex. AssertionChain same(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are the same (using ===). AssertionChain satisfy(callable $callback, string|callable $message = null, string $propertyPath = null) Assert that the provided value is valid according to a callback. AssertionChain scalar(string|callable $message = null, string $propertyPath = null) Assert that value is a PHP scalar. AssertionChain startsWith(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string starts with a sequence of chars. AssertionChain string(string|callable $message = null, string $propertyPath = null) Assert that value is a string. AssertionChain subclassOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is subclass of given class-name. AssertionChain true(string|callable $message = null, string $propertyPath = null) Assert that the value is boolean True. AssertionChain uniqueValues(string|callable $message = null, string $propertyPath = null) Assert that values in array are unique (using strict equality). AssertionChain url(string|callable $message = null, string $propertyPath = null) Assert that value is an URL. AssertionChain uuid(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid UUID. AssertionChain version(string $operator, string $version2, string|callable $message = null, string $propertyPath = null) Assert comparison of two versions. AssertionChain writeable(string|callable $message = null, string $propertyPath = null) Assert that the value is something writeable.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $value,
 |  |  | $defaultMessage = null,
 |  | string | $defaultPropertyPath = null
 | ) |  |

AssertionChain constructor.

Paramètres
mixed | $value
string | callable | null | $defaultMessage

Références $value, et value.

Documentation des fonctions membres

◆ __call()

__call | ( | $methodName,
 |  | $args
 | ) |

Call assertion on the current value in the chain.

Paramètres
string | $methodName
array | $args

Références $method, $methodName, $params, $this, et value.

◆ all()

all ( )

Switch chain into validation mode for an array of values.

Références $this.

◆ nullOr()

nullOr ( )

Switch chain into mode allowing nulls, ignoring further assertions.

Références $this, null, et value.

◆ setAssertionClassName()

setAssertionClassName ( $className )
Paramètres
string $className
Renvoie
$this

Références $className, $this, et class.

Documentation des champs

◆ $all

$all = false
private

◆ $alwaysValid

$alwaysValid = false
private

◆ $assertionClassName

$assertionClassName = 'Assert\Assertion'
private

◆ $defaultMessage

$defaultMessage
private

◆ $defaultPropertyPath

$defaultPropertyPath
private

◆ $value

$value
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AssertionChain.php


Joomla CMS: Référence de l'interface AssertionFailedException

  • Assert
  • AssertionFailedException
Fonctions membres publiques
Référence de l'interface AssertionFailedException
+ Graphe d'héritage de AssertionFailedException:
InvalidArgumentException LazyAssertionException

Fonctions membres publiques

getPropertyPath ()
getValue ()
getConstraints ()

Documentation des fonctions membres

◆ getConstraints()

getConstraints ( )

Implémenté dans InvalidArgumentException.

◆ getPropertyPath()

getPropertyPath ( )
Renvoie
string|null

Implémenté dans InvalidArgumentException.

◆ getValue()

getValue ( )
Renvoie
mixed

Implémenté dans InvalidArgumentException.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AssertionFailedException.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Assert
  • InvalidArgumentException
Fonctions membres publiques | Attributs privés
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
AssertionFailedException LazyAssertionException

Fonctions membres publiques

__construct ($message, $code, string $propertyPath=null, $value=null, array $constraints=[])
getPropertyPath ()
getValue ()
getConstraints ()

Attributs privés

$propertyPath
$value
$constraints

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message,
 |  |  | $code,
 |  | string | $propertyPath = null,
 |  |  | $value = null,
 |  | array | $constraints = []
 | ) |  |

Références $message, $value, Symfony\Contracts\Service\__construct(), et value.

Documentation des fonctions membres

◆ getConstraints()

getConstraints ( )

Get the constraints that applied to the failed assertion.

Implémente AssertionFailedException.

◆ getPropertyPath()

getPropertyPath ( )

User controlled way to define a sub-property causing the failure of a currently asserted objects.

Useful to transport information about the nature of the error back to higher layers.

Renvoie
string|null

Implémente AssertionFailedException.

◆ getValue()

getValue ( )

Get the value that caused the assertion to fail.

Renvoie
mixed

Implémente AssertionFailedException.

Références $value.

Documentation des champs

◆ $constraints

$constraints
private

◆ $propertyPath

$propertyPath
private

◆ $value

$value
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • beberlei/assert/lib/Assert/InvalidArgumentException.php


Joomla CMS: Référence de la classe LazyAssertion

  • Assert
  • LazyAssertion
Fonctions membres publiques | Attributs privés
Référence de la classe LazyAssertion

Fonctions membres publiques

that ($value, string $propertyPath=null, $defaultMessage=null)
tryAll ()
__call ($method, $args)
verifyNow ()
setAssertClass (string $className)
setExceptionClass (string $className)

Attributs privés

$currentChainFailed = false
$alwaysTryAll = false
$thisChainTryAll = false
$currentChain
$errors = []
$assertClass = Assert::class
$exceptionClass = LazyAssertionException::class

Description détaillée

Chaining builder for lazy assertions.

Auteur
Benjamin Eberlei konta.nosp@m.kt@b.nosp@m.eberl.nosp@m.ei.d.nosp@m.e

LazyAssertion alnum(string|callable $message = null, string $propertyPath = null) Assert that value is alphanumeric. LazyAssertion base64(string|callable $message = null, string $propertyPath = null) Assert that a constant is defined. LazyAssertion between(mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater or equal than a lower limit, and less than or equal to an upper limit. LazyAssertion betweenExclusive(mixed $lowerLimit, mixed $upperLimit, string|callable $message = null, string $propertyPath = null) Assert that a value is greater than a lower limit, and less than an upper limit. LazyAssertion betweenLength(int $minLength, int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string length is between min and max lengths. LazyAssertion boolean(string|callable $message = null, string $propertyPath = null) Assert that value is php boolean. LazyAssertion choice(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. LazyAssertion choicesNotEmpty(array $choices, string|callable $message = null, string $propertyPath = null) Determines if the values array has every choice as key and that this choice has content. LazyAssertion classExists(string|callable $message = null, string $propertyPath = null) Assert that the class exists. LazyAssertion contains(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string contains a sequence of chars. LazyAssertion count(int $count, string|callable $message = null, string $propertyPath = null) Assert that the count of countable is equal to count. LazyAssertion date(string $format, string|callable $message = null, string $propertyPath = null) Assert that date is valid and corresponds to the given format. LazyAssertion defined(string|callable $message = null, string $propertyPath = null) Assert that a constant is defined. LazyAssertion digit(string|callable $message = null, string $propertyPath = null) Validates if an integer or integerish is a digit. LazyAssertion directory(string|callable $message = null, string $propertyPath = null) Assert that a directory exists. LazyAssertion e164(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid E164 Phone Number. LazyAssertion email(string|callable $message = null, string $propertyPath = null) Assert that value is an email address (using input_filter/FILTER_VALIDATE_EMAIL). LazyAssertion endsWith(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string ends with a sequence of chars. LazyAssertion eq(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are equal (using ==). LazyAssertion eqArraySubset(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that the array contains the subset. LazyAssertion extensionLoaded(string|callable $message = null, string $propertyPath = null) Assert that extension is loaded. LazyAssertion extensionVersion(string $operator, mixed $version, string|callable $message = null, string $propertyPath = null) Assert that extension is loaded and a specific version is installed. LazyAssertion false(string|callable $message = null, string $propertyPath = null) Assert that the value is boolean False. LazyAssertion file(string|callable $message = null, string $propertyPath = null) Assert that a file exists. LazyAssertion float(string|callable $message = null, string $propertyPath = null) Assert that value is a php float. LazyAssertion greaterOrEqualThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater or equal than given limit. LazyAssertion greaterThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is greater than given limit. LazyAssertion implementsInterface(string $interfaceName, string|callable $message = null, string $propertyPath = null) Assert that the class implements the interface. LazyAssertion inArray(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is in array of choices. This is an alias of Assertion::choice(). LazyAssertion integer(string|callable $message = null, string $propertyPath = null) Assert that value is a php integer. LazyAssertion integerish(string|callable $message = null, string $propertyPath = null) Assert that value is a php integer'ish. LazyAssertion interfaceExists(string|callable $message = null, string $propertyPath = null) Assert that the interface exists. LazyAssertion ip(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 or IPv6 address. LazyAssertion ipv4(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv4 address. LazyAssertion ipv6(int $flag = null, string|callable $message = null, string $propertyPath = null) Assert that value is an IPv6 address. LazyAssertion isArray(string|callable $message = null, string $propertyPath = null) Assert that value is an array. LazyAssertion isArrayAccessible(string|callable $message = null, string $propertyPath = null) Assert that value is an array or an array-accessible object. LazyAssertion isCallable(string|callable $message = null, string $propertyPath = null) Determines that the provided value is callable. LazyAssertion isCountable(string|callable $message = null, string $propertyPath = null) Assert that value is countable. LazyAssertion isInstanceOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is instance of given class-name. LazyAssertion isJsonString(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid json string. LazyAssertion isObject(string|callable $message = null, string $propertyPath = null) Determines that the provided value is an object. LazyAssertion isResource(string|callable $message = null, string $propertyPath = null) Assert that value is a resource. LazyAssertion isTraversable(string|callable $message = null, string $propertyPath = null) Assert that value is an array or a traversable object. LazyAssertion keyExists(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array. LazyAssertion keyIsset(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object using isset(). LazyAssertion keyNotExists(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key does not exist in an array. LazyAssertion length(int $length, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string has a given length. LazyAssertion lessOrEqualThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less or equal than given limit. LazyAssertion lessThan(mixed $limit, string|callable $message = null, string $propertyPath = null) Determines if the value is less than given limit. LazyAssertion max(mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that a number is smaller as a given limit. LazyAssertion maxCount(int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at most $count elements. LazyAssertion maxLength(int $maxLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string value is not longer than $maxLength chars. LazyAssertion methodExists(mixed $object, string|callable $message = null, string $propertyPath = null) Determines that the named method is defined in the provided object. LazyAssertion min(mixed $minValue, string|callable $message = null, string $propertyPath = null) Assert that a value is at least as big as a given limit. LazyAssertion minCount(int $count, string|callable $message = null, string $propertyPath = null) Assert that the countable have at least $count elements. LazyAssertion minLength(int $minLength, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that a string is at least $minLength chars long. LazyAssertion noContent(string|callable $message = null, string $propertyPath = null) Assert that value is empty. LazyAssertion notBlank(string|callable $message = null, string $propertyPath = null) Assert that value is not blank. LazyAssertion notContains(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string does not contains a sequence of chars. LazyAssertion notEmpty(string|callable $message = null, string $propertyPath = null) Assert that value is not empty. LazyAssertion notEmptyKey(string|int $key, string|callable $message = null, string $propertyPath = null) Assert that key exists in an array/array-accessible object and its value is not empty. LazyAssertion notEq(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not equal (using ==). LazyAssertion notInArray(array $choices, string|callable $message = null, string $propertyPath = null) Assert that value is not in array of choices. LazyAssertion notIsInstanceOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is not instance of given class-name. LazyAssertion notNull(string|callable $message = null, string $propertyPath = null) Assert that value is not null. LazyAssertion notRegex(string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value does not match a regex. LazyAssertion notSame(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are not the same (using ===). LazyAssertion null(string|callable $message = null, string $propertyPath = null) Assert that value is null. LazyAssertion numeric(string|callable $message = null, string $propertyPath = null) Assert that value is numeric. LazyAssertion objectOrClass(string|callable $message = null, string $propertyPath = null) Assert that the value is an object, or a class that exists. LazyAssertion phpVersion(mixed $version, string|callable $message = null, string $propertyPath = null) Assert on PHP version. LazyAssertion propertiesExist(array $properties, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the properties all exist. LazyAssertion propertyExists(string $property, string|callable $message = null, string $propertyPath = null) Assert that the value is an object or class, and that the property exists. LazyAssertion range(mixed $minValue, mixed $maxValue, string|callable $message = null, string $propertyPath = null) Assert that value is in range of numbers. LazyAssertion readable(string|callable $message = null, string $propertyPath = null) Assert that the value is something readable. LazyAssertion regex(string $pattern, string|callable $message = null, string $propertyPath = null) Assert that value matches a regex. LazyAssertion same(mixed $value2, string|callable $message = null, string $propertyPath = null) Assert that two values are the same (using ===). LazyAssertion satisfy(callable $callback, string|callable $message = null, string $propertyPath = null) Assert that the provided value is valid according to a callback. LazyAssertion scalar(string|callable $message = null, string $propertyPath = null) Assert that value is a PHP scalar. LazyAssertion startsWith(string $needle, string|callable $message = null, string $propertyPath = null, string $encoding = 'utf8') Assert that string starts with a sequence of chars. LazyAssertion string(string|callable $message = null, string $propertyPath = null) Assert that value is a string. LazyAssertion subclassOf(string $className, string|callable $message = null, string $propertyPath = null) Assert that value is subclass of given class-name. LazyAssertion true(string|callable $message = null, string $propertyPath = null) Assert that the value is boolean True. LazyAssertion uniqueValues(string|callable $message = null, string $propertyPath = null) Assert that values in array are unique (using strict equality). LazyAssertion url(string|callable $message = null, string $propertyPath = null) Assert that value is an URL. LazyAssertion uuid(string|callable $message = null, string $propertyPath = null) Assert that the given string is a valid UUID. LazyAssertion version(string $operator, string $version2, string|callable $message = null, string $propertyPath = null) Assert comparison of two versions. LazyAssertion writeable(string|callable $message = null, string $propertyPath = null) Assert that the value is something writeable. LazyAssertion all() Switch chain into validation mode for an array of values. LazyAssertion nullOr() Switch chain into mode allowing nulls, ignoring further assertions.

Documentation des fonctions membres

◆ __call()

__call | ( | $method,
 |  | $args
 | ) |
Paramètres
string | $method
array | $args
Renvoie
static

Références $method, et $this.

◆ setAssertClass()

setAssertClass ( string $className )
Paramètres
string $className
Renvoie
static

Références $className, $this, et class.

◆ setExceptionClass()

setExceptionClass ( string $className )
Paramètres
string $className
Renvoie
static

Références $className, $this, et class.

◆ that()

that | ( |  | $value,
 |  | string | $propertyPath = null,
 |  |  | $defaultMessage = null
 | ) |  |
Paramètres
mixed | $value
string | callable | null | $defaultMessage
Renvoie
static

Références $this, $value, et Assert\that().

◆ tryAll()

tryAll ( )
Renvoie
static

Références $this.

◆ verifyNow()

verifyNow ( )
Exceptions
LazyAssertionException

Documentation des champs

◆ $alwaysTryAll

$alwaysTryAll = false
private

◆ $assertClass

$assertClass = Assert::class
private

◆ $currentChain

$currentChain
private

◆ $currentChainFailed

$currentChainFailed = false
private

◆ $errors

$errors = []
private

◆ $exceptionClass

$exceptionClass = LazyAssertionException::class
private

◆ $thisChainTryAll

$thisChainTryAll = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LazyAssertion.php


Joomla CMS: Référence de la classe LazyAssertionException

  • Assert
  • LazyAssertionException
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe LazyAssertionException
+ Graphe d'héritage de LazyAssertionException:
InvalidArgumentException AssertionFailedException

Fonctions membres publiques

__construct ($message, array $errors)
getErrorExceptions ()
- Fonctions membres publiques hérités de InvalidArgumentException
__construct ($message, $code, string $propertyPath=null, $value=null, array $constraints=[])
getPropertyPath ()
getValue ()
getConstraints ()

Fonctions membres publiques statiques

static fromErrors (array $errors)

Attributs privés

$errors = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message,
 |  | array | $errors
 | ) |  |

Références $message, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ fromErrors()

static fromErrors ( array $errors )
static
Paramètres
InvalidArgumentException[] $errors

Références $i, et $message.

◆ getErrorExceptions()

getErrorExceptions ( )
Renvoie
InvalidArgumentException[]

Documentation des champs

◆ $errors

$errors = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LazyAssertionException.php


Joomla CMS: Référence de la classe Base64Url

  • Base64Url
  • Base64Url
Fonctions membres publiques statiques
Référence de la classe Base64Url

Fonctions membres publiques statiques

static | encode (string $data, bool $usePadding=false)
static | decode (string $data)

Description détaillée

Encode and decode data into Base64 Url Safe.

Documentation des fonctions membres

◆ decode()

static decode ( string $data )
static
Paramètres
string $data The data to decode
Exceptions
InvalidArgumentException
Renvoie
string The data decoded

Références $data.

Référencé par RSAKey\convertBase64StringToBigInteger(), TokenBinding\createFormArray(), MetadataStatementFetcher\fetchMetadataStatement(), RSAKey\fromBase64ToInteger(), TPMAttestationStatementSupport\getExponent(), HMAC\getKey(), ECKey\getKey(), Base64UrlEncodingTag\getNormalizedData(), AttestationObjectLoader\load(), ECKey\p256KPrivateKey(), ECKey\p256PrivateKey(), ECKey\p384PrivateKey(), ECKey\p521PrivateKey(), JSONGeneralSerializer\processHeaders(), JSONGeneralSerializer\processPayload(), EdDSA\sign(), CompactSerializer\unserialize(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), et EdDSA\verify().

◆ encode()

static encode | ( | string | $data,
 |  | bool | $usePadding = false
 | ) |  |
static
Paramètres
string | $data | The data to encode
bool | $usePadding | If true, the "=" padding at end of the encoded value are kept, else it is removed
Renvoie
string The data encoded

Références $data.

Référencé par ECKey\createECKeyUsingOpenSSL(), JWSVerifier\getInputToVerify(), JSONFlattenedSerializer\serialize(), CompactSerializer\serialize(), JSONGeneralSerializer\serialize(), et JWK\thumbprint().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64Url.php


Joomla CMS: Référence de la classe BCMath

  • bcmath_compat
  • BCMath
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe BCMath

Fonctions membres publiques statiques

static __callStatic ($name, $arguments)

Fonctions membres privées statiques

static | scale ($scale=null)
static | format ($x, $scale, $pad)
static | isNegative ($x)
static | add ($x, $y, $scale, $pad)
static | sub ($x, $y, $scale, $pad)
static | mul ($x, $y, $scale, $pad)
static | div ($x, $y, $scale, $pad)
static | mod ($x, $y, $scale, $pad)
static | comp ($x, $y, $scale, $pad)
static | pow ($x, $y, $scale, $pad)
static | powmod ($x, $e, $n, $scale, $pad)
static | sqrt ($n, $scale, $pad)

Attributs privés statiques

static $scale

Description détaillée

BCMath Emulation Class

Auteur
Jim Wigginton terra.nosp@m.fros.nosp@m.t@php.nosp@m..net public

Documentation des fonctions membres

◆ __callStatic()

static __callStatic | ( | $name,
 |  | $arguments
 | ) |
static

Références $i, $name, $names, $params, $type, et elseif.

◆ add()

static add | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

◆ comp()

static comp | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

◆ div()

static div | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $temp.

◆ format()

static format | ( | $x,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $result, $temp, et elseif.

◆ isNegative()

static isNegative ( $x )
staticprivate

◆ mod()

static mod | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

◆ mul()

static mul | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $r, et $result.

◆ pow()

static pow | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $i, $r, et $temp.

◆ powmod()

static powmod | ( | $x,
 |  | $e,
 |  | $n,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $n.

◆ scale()

static scale ( $scale = null )
staticprivate

◆ sqrt()

static sqrt | ( | $n,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Références $c, $i, $n, $parts, $result, $temp, et elseif.

◆ sub()

static sub | ( | $x,
 |  | $y,
 |  | $scale,
 |  | $pad
 | ) |
staticprivate

Documentation des champs

◆ $scale

int $scale
staticprivate

Default scale parameter for all bc math functions

La documentation de cette classe a été générée à partir du fichier suivant :
  • bcmath_compat/src/BCMath.php


Joomla CMS: Référence de la classe DivisionByZeroException

  • Brick
  • Math
  • Exception
  • DivisionByZeroException
Fonctions membres publiques statiques
Référence de la classe DivisionByZeroException
+ Graphe d'héritage de DivisionByZeroException:
MathException

Fonctions membres publiques statiques

static | divisionByZero ()
static | modulusMustNotBeZero ()
static | denominatorMustNotBeZero ()

Description détaillée

Exception thrown when a division by zero occurs.

Documentation des fonctions membres

◆ denominatorMustNotBeZero()

static denominatorMustNotBeZero ( )
static
Renvoie
DivisionByZeroException

-pure

Référencé par BigRational\__construct(), et BigNumber\of().

◆ divisionByZero()

static divisionByZero ( )
static
Renvoie
DivisionByZeroException

-pure

Référencé par BigDecimal\dividedBy(), BigInteger\dividedBy(), BigDecimal\exactlyDividedBy(), BigDecimal\quotient(), BigInteger\quotient(), BigDecimal\quotientAndRemainder(), BigInteger\quotientAndRemainder(), BigDecimal\remainder(), et BigInteger\remainder().

◆ modulusMustNotBeZero()

static modulusMustNotBeZero ( )
static
Renvoie
DivisionByZeroException

-pure

Référencé par BigInteger\mod(), BigInteger\modInverse(), et BigInteger\modPow().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DivisionByZeroException.php


Joomla CMS: Référence de la classe IntegerOverflowException

  • Brick
  • Math
  • Exception
  • IntegerOverflowException
Fonctions membres publiques statiques
Référence de la classe IntegerOverflowException
+ Graphe d'héritage de IntegerOverflowException:
MathException

Fonctions membres publiques statiques

static toIntOverflow (BigInteger $value)

Description détaillée

Exception thrown when an integer overflow occurs.

Documentation des fonctions membres

◆ toIntOverflow()

static toIntOverflow ( BigInteger $value )
static
Paramètres
BigInteger $value
Renvoie
IntegerOverflowException

-pure

Références $message, et $value.

Référencé par BigInteger\toInt().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IntegerOverflowException.php


Joomla CMS: Référence de la classe MathException

  • Brick
  • Math
  • Exception
  • MathException
Référence de la classe MathException
+ Graphe d'héritage de MathException:
DivisionByZeroException IntegerOverflowException NegativeNumberException NumberFormatException RoundingNecessaryException

Description détaillée

Base class for all math exceptions.

This class is abstract to ensure that only fine-grained exceptions are thrown throughout the code.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MathException.php


Joomla CMS: Référence de la classe NegativeNumberException

  • Brick
  • Math
  • Exception
  • NegativeNumberException
Référence de la classe NegativeNumberException
+ Graphe d'héritage de NegativeNumberException:
MathException

Description détaillée

Exception thrown when attempting to perform an unsupported operation, such as a square root, on a negative number.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NegativeNumberException.php


Joomla CMS: Référence de la classe NumberFormatException

  • Brick
  • Math
  • Exception
  • NumberFormatException
Fonctions membres publiques statiques
Référence de la classe NumberFormatException
+ Graphe d'héritage de NumberFormatException:
MathException

Fonctions membres publiques statiques

static charNotInAlphabet (string $char)

Description détaillée

Exception thrown when attempting to create a number from a string with an invalid format.

Documentation des fonctions membres

◆ charNotInAlphabet()

static charNotInAlphabet ( string $char )
static
Paramètres
string $char The failing character.
Renvoie
NumberFormatException

-pure

Référencé par BigInteger\fromArbitraryBase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NumberFormatException.php


Joomla CMS: Référence de la classe RoundingNecessaryException

  • Brick
  • Math
  • Exception
  • RoundingNecessaryException
Fonctions membres publiques statiques
Référence de la classe RoundingNecessaryException
+ Graphe d'héritage de RoundingNecessaryException:
MathException

Fonctions membres publiques statiques

static roundingNecessary ()

Description détaillée

Exception thrown when a number cannot be represented at the requested scale without rounding.

Documentation des fonctions membres

◆ roundingNecessary()

static roundingNecessary ( )
static
Renvoie
RoundingNecessaryException

-pure

Référencé par Calculator\divRound().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RoundingNecessaryException.php


Joomla CMS: Référence de la classe BcMathCalculator

  • Brick
  • Math
  • Internal
  • Calculator
  • BcMathCalculator
Fonctions membres publiques
Référence de la classe BcMathCalculator
+ Graphe d'héritage de BcMathCalculator:
Calculator

Fonctions membres publiques

add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
modPow (string $base, string $exp, string $mod)
sqrt (string $n)
- Fonctions membres publiques hérités de Calculator
abs (string $n)
neg (string $n)
cmp (string $a, string $b)
add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
mod (string $a, string $b)
modInverse (string $x, string $m)
modPow (string $base, string $exp, string $mod)
gcd (string $a, string $b)
sqrt (string $n)
fromBase (string $number, int $base)
toBase (string $number, int $base)
fromArbitraryBase (string $number, string $alphabet, int $base)
toArbitraryBase (string $number, string $alphabet, int $base)
divRound (string $a, string $b, int $roundingMode)
and (string $a, string $b)
or (string $a, string $b)
xor (string $a, string $b)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Calculator
static | set (?Calculator $calculator)
static | get ()
- Champs de données hérités de Calculator
const | MAX_POWER = 1000000
const | ALPHABET = '0123456789abcdefghijklmnopqrstuvwxyz'
- Fonctions membres protégées hérités de Calculator
init (string $a, string $b)

Description détaillée

Calculator implementation built around the bcmath library.

Documentation des fonctions membres

◆ add()

add | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ divQ()

divQ | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ divQR()

divQR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, et $r.

◆ divR()

divR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ modPow()

modPow | ( | string | $base,
 |  | string | $exp,
 |  | string | $mod
 | ) |  |

{}

Références $base, et $mod.

◆ mul()

mul | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ pow()

pow | ( | string | $a,
 |  | int | $e
 | ) |  |

{}

◆ sqrt()

sqrt ( string $n )

Références $n.

◆ sub()

sub | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BcMathCalculator.php


Joomla CMS: Référence de la classe GmpCalculator

  • Brick
  • Math
  • Internal
  • Calculator
  • GmpCalculator
Fonctions membres publiques
Référence de la classe GmpCalculator
+ Graphe d'héritage de GmpCalculator:
Calculator

Fonctions membres publiques

add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
modInverse (string $x, string $m)
modPow (string $base, string $exp, string $mod)
gcd (string $a, string $b)
fromBase (string $number, int $base)
toBase (string $number, int $base)
and (string $a, string $b)
or (string $a, string $b)
xor (string $a, string $b)
sqrt (string $n)
- Fonctions membres publiques hérités de Calculator
abs (string $n)
neg (string $n)
cmp (string $a, string $b)
add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
mod (string $a, string $b)
modInverse (string $x, string $m)
modPow (string $base, string $exp, string $mod)
gcd (string $a, string $b)
sqrt (string $n)
fromBase (string $number, int $base)
toBase (string $number, int $base)
fromArbitraryBase (string $number, string $alphabet, int $base)
toArbitraryBase (string $number, string $alphabet, int $base)
divRound (string $a, string $b, int $roundingMode)
and (string $a, string $b)
or (string $a, string $b)
xor (string $a, string $b)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Calculator
static | set (?Calculator $calculator)
static | get ()
- Champs de données hérités de Calculator
const | MAX_POWER = 1000000
const | ALPHABET = '0123456789abcdefghijklmnopqrstuvwxyz'
- Fonctions membres protégées hérités de Calculator
init (string $a, string $b)

Description détaillée

Calculator implementation built around the GMP library.

Documentation des fonctions membres

◆ add()

add | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ and()

and | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ divQ()

divQ | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ divQR()

divQR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, et $r.

◆ divR()

divR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ fromBase()

fromBase | ( | string | $number,
 |  | int | $base
 | ) |  |

{}

Références $base.

◆ gcd()

gcd | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ modInverse()

modInverse | ( | string | $x,
 |  | string | $m
 | ) |  |

{}

Références $result, et null.

◆ modPow()

modPow | ( | string | $base,
 |  | string | $exp,
 |  | string | $mod
 | ) |  |

{}

Références $base, et $mod.

◆ mul()

mul | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ or()

or | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ pow()

pow | ( | string | $a,
 |  | int | $e
 | ) |  |

{}

◆ sqrt()

sqrt ( string $n )

Références $n.

◆ sub()

sub | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

◆ toBase()

toBase | ( | string | $number,
 |  | int | $base
 | ) |  |

{}

Références $base.

◆ xor()

xor | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GmpCalculator.php


Joomla CMS: Référence de la classe NativeCalculator

  • Brick
  • Math
  • Internal
  • Calculator
  • NativeCalculator
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe NativeCalculator
+ Graphe d'héritage de NativeCalculator:
Calculator

Fonctions membres publiques

__construct ()
add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
modPow (string $base, string $exp, string $mod)
sqrt (string $n)
- Fonctions membres publiques hérités de Calculator
abs (string $n)
neg (string $n)
cmp (string $a, string $b)
add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
mod (string $a, string $b)
modInverse (string $x, string $m)
modPow (string $base, string $exp, string $mod)
gcd (string $a, string $b)
sqrt (string $n)
fromBase (string $number, int $base)
toBase (string $number, int $base)
fromArbitraryBase (string $number, string $alphabet, int $base)
toArbitraryBase (string $number, string $alphabet, int $base)
divRound (string $a, string $b, int $roundingMode)
and (string $a, string $b)
or (string $a, string $b)
xor (string $a, string $b)

Fonctions membres privées

doAdd (string $a, string $b)
doSub (string $a, string $b)
doMul (string $a, string $b)
doDiv (string $a, string $b)
doCmp (string $a, string $b)
pad (string $a, string $b)

Attributs privés

$maxDigits

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Calculator
static | set (?Calculator $calculator)
static | get ()
- Champs de données hérités de Calculator
const | MAX_POWER = 1000000
const | ALPHABET = '0123456789abcdefghijklmnopqrstuvwxyz'
- Fonctions membres protégées hérités de Calculator
init (string $a, string $b)

Description détaillée

Calculator implementation using only native PHP code.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Class constructor.

Documentation des fonctions membres

◆ add()

add | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, $result, NativeCalculator\doAdd(), NativeCalculator\doSub(), Calculator\init(), et Calculator\neg().

Référencé par NativeCalculator\doDiv(), NativeCalculator\doMul(), NativeCalculator\sqrt(), et NativeCalculator\sub().

◆ divQ()

divQ | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, et NativeCalculator\divQR().

Référencé par NativeCalculator\modPow(), et NativeCalculator\sqrt().

◆ divQR()

divQR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, $r, NativeCalculator\doDiv(), Calculator\init(), et Calculator\neg().

Référencé par NativeCalculator\divQ(), et NativeCalculator\divR().

◆ divR()

divR | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, et NativeCalculator\divQR().

Référencé par NativeCalculator\modPow().

◆ doAdd()

doAdd | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Performs the addition of two non-signed large integers.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
string

Références $b, $i, NativeCalculator\$maxDigits, $result, et NativeCalculator\pad().

Référencé par NativeCalculator\add().

◆ doCmp()

doCmp | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Compares two non-signed large numbers.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
int [-1, 0, 1]

Références $b.

Référencé par NativeCalculator\doDiv(), et NativeCalculator\doSub().

◆ doDiv()

doDiv | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Performs the division of two non-signed large integers.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
string[] The quotient and remainder.

Références $b, $r, NativeCalculator\add(), NativeCalculator\doCmp(), et NativeCalculator\sub().

Référencé par NativeCalculator\divQR().

◆ doMul()

doMul | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Performs the multiplication of two non-signed large integers.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
string

Références $b, $i, NativeCalculator\$maxDigits, $result, $value, et NativeCalculator\add().

Référencé par NativeCalculator\mul().

◆ doSub()

doSub | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Performs the subtraction of two non-signed large integers.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
string

Références $b, $c, $i, NativeCalculator\$maxDigits, $result, NativeCalculator\doCmp(), Calculator\neg(), et NativeCalculator\pad().

Référencé par NativeCalculator\add().

◆ modPow()

modPow | ( | string | $base,
 |  | string | $exp,
 |  | string | $mod
 | ) |  |

Algorithm from: https://www.geeksforgeeks.org/modular-exponentiation-power-in-modular-arithmetic/

{}

Références $base, $mod, NativeCalculator\divQ(), NativeCalculator\divR(), et NativeCalculator\mul().

◆ mul()

mul | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références $b, $result, NativeCalculator\doMul(), Calculator\init(), et Calculator\neg().

Référencé par NativeCalculator\modPow(), et NativeCalculator\pow().

◆ pad()

pad | ( | string | $a,
 |  | string | $b
 | ) |  |
private

Pads the left of one of the given numbers with zeros if necessary to make both numbers the same length.

The numbers must only consist of digits, without leading minus sign.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
array{0: string, 1: string, 2: int}

Références $b.

Référencé par NativeCalculator\doAdd(), et NativeCalculator\doSub().

◆ pow()

pow | ( | string | $a,
 |  | int | $e
 | ) |  |

{}

Références $result, et NativeCalculator\mul().

◆ sqrt()

sqrt ( string $n )

Adapted from https://cp-algorithms.com/num_methods/roots_newton.html

Références $n, NativeCalculator\add(), Calculator\cmp(), et NativeCalculator\divQ().

◆ sub()

sub | ( | string | $a,
 |  | string | $b
 | ) |  |

{}

Références NativeCalculator\add(), et Calculator\neg().

Référencé par NativeCalculator\doDiv().

Documentation des champs

◆ $maxDigits

$maxDigits
private

Référencé par NativeCalculator\doAdd(), NativeCalculator\doMul(), et NativeCalculator\doSub().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NativeCalculator.php


Joomla CMS: Référence de la classe Calculator

  • Brick
  • Math
  • Internal
  • Calculator
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Calculator
+ Graphe d'héritage de Calculator:
BcMathCalculator GmpCalculator NativeCalculator

Fonctions membres publiques

abs (string $n)
neg (string $n)
cmp (string $a, string $b)
add (string $a, string $b)
sub (string $a, string $b)
mul (string $a, string $b)
divQ (string $a, string $b)
divR (string $a, string $b)
divQR (string $a, string $b)
pow (string $a, int $e)
mod (string $a, string $b)
modInverse (string $x, string $m)
modPow (string $base, string $exp, string $mod)
gcd (string $a, string $b)
sqrt (string $n)
fromBase (string $number, int $base)
toBase (string $number, int $base)
fromArbitraryBase (string $number, string $alphabet, int $base)
toArbitraryBase (string $number, string $alphabet, int $base)
divRound (string $a, string $b, int $roundingMode)
and (string $a, string $b)
or (string $a, string $b)
xor (string $a, string $b)

Fonctions membres publiques statiques

static | set (?Calculator $calculator)
static | get ()

Champs de données

const | MAX_POWER = 1000000
const | ALPHABET = '0123456789abcdefghijklmnopqrstuvwxyz'

Fonctions membres protégées

init (string $a, string $b)

Fonctions membres privées

gcdExtended (string $a, string $b, string &$x, string &$y)
bitwise (string $operator, string $a, string $b)
twosComplement (string $number)
toBinary (string $number)
toDecimal (string $bytes)

Fonctions membres privées statiques

static detect ()

Attributs privés statiques

static $instance

Description détaillée

Performs basic operations on arbitrary size integers.

Unless otherwise specified, all parameters must be validated as non-empty strings of digits, without leading zero, and with an optional leading minus sign if the number is not zero.

Any other parameter format will lead to undefined behaviour. All methods must return strings respecting this format, unless specified otherwise.

Documentation des fonctions membres

◆ abs()

abs ( string $n )
final

Returns the absolute value of a number.

Paramètres
string $n The number.
Renvoie
string The absolute value.

Références $n.

Référencé par Calculator\divRound(), Calculator\gcd(), et Calculator\modInverse().

◆ add()

add | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Adds two numbers.

Paramètres
string | $a | The augend.
string | $b | The addend.
Renvoie
string The sum.

Référencé par Calculator\divRound(), Calculator\fromArbitraryBase(), Calculator\mod(), Calculator\modInverse(), et Calculator\toDecimal().

◆ and()

and | ( | string | $a,
 |  | string | $b
 | ) |  |

Calculates bitwise AND of two numbers.

This method can be overridden by the concrete implementation if the underlying library has built-in support for bitwise operations.

Paramètres
string | $a
string | $b
Renvoie
string

Références $b, et Calculator\bitwise().

Référencé par Calculator\bitwise().

◆ bitwise()

bitwise | ( | string | $operator,
 |  | string | $a,
 |  | string | $b
 | ) |  |
private

Performs a bitwise operation on a decimal number.

Paramètres
string | $operator | The operator to use, must be "and", "or" or "xor".
string | $a | The left operand.
string | $b | The right operand.
Renvoie
string

Références $b, $result, $value, Calculator\and(), elseif, Calculator\init(), Calculator\neg(), Calculator\or(), Calculator\toBinary(), Calculator\toDecimal(), Calculator\twosComplement(), et Calculator\xor().

Référencé par Calculator\and(), Calculator\or(), et Calculator\xor().

◆ cmp()

cmp | ( | string | $a,
 |  | string | $b
 | ) |  |
final

Compares two numbers.

Paramètres
string | $a | The first number.
string | $b | The second number.
Renvoie
int [-1, 0, 1] If the first number is less than, equal to, or greater than the second number.

Références $b, $result, elseif, et Calculator\init().

Référencé par Calculator\divRound(), Calculator\modInverse(), et NativeCalculator\sqrt().

◆ detect()

static detect ( )
staticprivate

Returns the fastest available Calculator implementation.

Renvoie
Calculator

◆ divQ()

divQ | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Returns the quotient of the division of two numbers.

Paramètres
string | $a | The dividend.
string | $b | The divisor, must not be zero.
Renvoie
string The quotient.

Référencé par Calculator\gcdExtended().

◆ divQR()

divQR | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Returns the quotient and remainder of the division of two numbers.

Paramètres
string | $a | The dividend.
string | $b | The divisor, must not be zero.
Renvoie
string[] An array containing the quotient and remainder.

Référencé par Calculator\divRound(), Calculator\toArbitraryBase(), et Calculator\toBinary().

◆ divR()

divR | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Returns the remainder of the division of two numbers.

Paramètres
string | $a | The dividend.
string | $b | The divisor, must not be zero.
Renvoie
string The remainder.

Référencé par Calculator\gcd(), et Calculator\mod().

◆ divRound()

divRound | ( | string | $a,
 |  | string | $b,
 |  | int | $roundingMode
 | ) |  |
final

Performs a rounded division.

Rounding is performed when the remainder of the division is not zero.

Paramètres
string | $a | The dividend.
string | $b | The divisor.
int | $roundingMode | The rounding mode.
Renvoie
string
Exceptions

Références $b, $r, Calculator\abs(), Calculator\add(), RoundingMode\CEILING, Calculator\cmp(), Calculator\divQR(), RoundingMode\DOWN, RoundingMode\FLOOR, RoundingMode\HALF_CEILING, RoundingMode\HALF_DOWN, RoundingMode\HALF_EVEN, RoundingMode\HALF_FLOOR, RoundingMode\HALF_UP, Calculator\mul(), RoundingNecessaryException\roundingNecessary(), RoundingMode\UNNECESSARY, et RoundingMode\UP.

◆ fromArbitraryBase()

fromArbitraryBase | ( | string | $number,
 |  | string | $alphabet,
 |  | int | $base
 | ) |  |
final

Converts a non-negative number in an arbitrary base using a custom alphabet, to base 10.

Paramètres
string | $number | The number to convert, validated as a non-empty string, containing only chars in the given alphabet/base.
string | $alphabet | The alphabet that contains every digit, validated as 2 chars minimum.
int | $base | The base of the number, validated from 2 to alphabet length.
Renvoie
string The number in base 10, following the Calculator conventions.

Références $base, $i, $result, Calculator\add(), et Calculator\mul().

Référencé par Calculator\fromBase().

◆ fromBase()

fromBase | ( | string | $number,
 |  | int | $base
 | ) |  |

Converts a number from an arbitrary base.

This method can be overridden by the concrete implementation if the underlying library has built-in support for base conversion.

Paramètres
string | $number | The number, positive or zero, non-empty, case-insensitively validated for the given base.
int | $base | The base of the number, validated from 2 to 36.
Renvoie
string The converted number, following the Calculator conventions.

Références $base, et Calculator\fromArbitraryBase().

◆ gcd()

gcd | ( | string | $a,
 |  | string | $b
 | ) |  |

Returns the greatest common divisor of the two numbers.

This method can be overridden by the concrete implementation if the underlying library has built-in support for GCD calculations.

Paramètres
string | $a | The first number.
string | $b | The second number.
Renvoie
string The GCD, always positive, or zero if both arguments are zero.

Références $b, Calculator\abs(), et Calculator\divR().

◆ gcdExtended()

gcdExtended | ( | string | $a,
 |  | string | $b,
 |  | string & | $x,
 |  | string & | $y
 | ) |  |
private

Références $b, Calculator\divQ(), Calculator\mod(), Calculator\mul(), et Calculator\sub().

Référencé par Calculator\modInverse().

◆ get()

static get ( )
staticfinal

Returns the Calculator instance to use.

If none has been explicitly set, the fastest available implementation will be returned.

Renvoie
Calculator

-pure -suppress ImpureStaticProperty

-suppress ImpureMethodCall

Références null.

Référencé par BigInteger\and(), BigDecimal\compareTo(), BigInteger\compareTo(), BigDecimal\dividedBy(), BigInteger\dividedBy(), BigDecimal\exactlyDividedBy(), BigInteger\fromArbitraryBase(), BigInteger\fromBase(), BigInteger\gcd(), BigDecimal\minus(), BigInteger\minus(), BigInteger\mod(), BigInteger\modInverse(), BigInteger\modPow(), BigDecimal\multipliedBy(), BigInteger\multipliedBy(), BigDecimal\negated(), BigInteger\negated(), BigInteger\or(), BigDecimal\plus(), BigInteger\plus(), BigDecimal\power(), BigInteger\power(), BigDecimal\quotient(), BigInteger\quotient(), BigDecimal\quotientAndRemainder(), BigInteger\quotientAndRemainder(), BigDecimal\remainder(), BigInteger\remainder(), BigDecimal\sqrt(), BigInteger\sqrt(), BigInteger\toArbitraryBase(), BigInteger\toBase(), et BigInteger\xor().

◆ init()

init | ( | string | $a,
 |  | string | $b
 | ) |  |
finalprotected

Extracts the sign & digits of the operands.

Paramètres
string | $a | The first operand.
string | $b | The second operand.
Renvoie
array{0: bool, 1: bool, 2: string, 3: string} Whether $a and $b are negative, followed by their digits.

Références $b.

Référencé par NativeCalculator\add(), Calculator\bitwise(), Calculator\cmp(), NativeCalculator\divQR(), et NativeCalculator\mul().

◆ mod()

mod | ( | string | $a,
 |  | string | $b
 | ) |  |
Paramètres
string | $a
string | $b | The modulus; must not be zero.
Renvoie
string

Références $b, Calculator\add(), et Calculator\divR().

Référencé par Calculator\gcdExtended(), et Calculator\modInverse().

◆ modInverse()

modInverse | ( | string | $x,
 |  | string | $m
 | ) |  |

Returns the modular multiplicative inverse of $x modulo $m.

If $x has no multiplicative inverse mod m, this method must return null.

This method can be overridden by the concrete implementation if the underlying library has built-in support.

Paramètres
string | $x
string | $m | The modulus; must not be negative or zero.
Renvoie
string|null

Références $g, Calculator\abs(), Calculator\add(), Calculator\cmp(), Calculator\gcdExtended(), Calculator\mod(), et null.

◆ modPow()

modPow | ( | string | $base,
 |  | string | $exp,
 |  | string | $mod
 | ) |  |
abstract

Raises a number into power with modulo.

Paramètres
string | $base | The base number; must be positive or zero.
string | $exp | The exponent; must be positive or zero.
string | $mod | The modulus; must be strictly positive.
Renvoie
string The power.

◆ mul()

mul | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Multiplies two numbers.

Paramètres
string | $a | The multiplicand.
string | $b | The multiplier.
Renvoie
string The product.

Référencé par Calculator\divRound(), Calculator\fromArbitraryBase(), Calculator\gcdExtended(), et Calculator\toDecimal().

◆ neg()

neg ( string $n )
final

Negates a number.

Paramètres
string $n The number.
Renvoie
string The negated value.

Références $n.

Référencé par NativeCalculator\add(), Calculator\bitwise(), NativeCalculator\divQR(), NativeCalculator\doSub(), NativeCalculator\mul(), et NativeCalculator\sub().

◆ or()

or | ( | string | $a,
 |  | string | $b
 | ) |  |

Calculates bitwise OR of two numbers.

This method can be overridden by the concrete implementation if the underlying library has built-in support for bitwise operations.

Paramètres
string | $a
string | $b
Renvoie
string

Références $b, et Calculator\bitwise().

Référencé par Calculator\bitwise().

◆ pow()

pow | ( | string | $a,
 |  | int | $e
 | ) |  |
abstract

Exponentiates a number.

Paramètres
string | $a | The base number.
int | $e | The exponent, validated as an integer between 0 and MAX_POWER.
Renvoie
string The power.

◆ set()

static set ( ?Calculator $calculator )
staticfinal

Sets the Calculator instance to use.

An instance is typically set only in unit tests: the autodetect is usually the best option.

Paramètres
Calculator | null $calculator The calculator instance, or NULL to revert to autodetect.
Renvoie
void

◆ sqrt()

sqrt ( string $n )
abstract

Returns the square root of the given number, rounded down.

The result is the largest x such that x² ≤ n. The input MUST NOT be negative.

Paramètres
string $n The number.
Renvoie
string The square root.

◆ sub()

sub | ( | string | $a,
 |  | string | $b
 | ) |  |
abstract

Subtracts two numbers.

Paramètres
string | $a | The minuend.
string | $b | The subtrahend.
Renvoie
string The difference.

Référencé par Calculator\gcdExtended().

◆ toArbitraryBase()

toArbitraryBase | ( | string | $number,
 |  | string | $alphabet,
 |  | int | $base
 | ) |  |
final

Converts a non-negative number to an arbitrary base using a custom alphabet.

Paramètres
string | $number | The number to convert, positive or zero, following the Calculator conventions.
string | $alphabet | The alphabet that contains every digit, validated as 2 chars minimum.
int | $base | The base to convert to, validated from 2 to alphabet length.
Renvoie
string The converted number in the given alphabet.

Références $base, $result, et Calculator\divQR().

Référencé par Calculator\toBase().

◆ toBase()

toBase | ( | string | $number,
 |  | int | $base
 | ) |  |

Converts a number to an arbitrary base.

This method can be overridden by the concrete implementation if the underlying library has built-in support for base conversion.

Paramètres
string | $number | The number to convert, following the Calculator conventions.
int | $base | The base to convert to, validated from 2 to 36.
Renvoie
string The converted number, lowercase.

Références $base, et Calculator\toArbitraryBase().

◆ toBinary()

toBinary ( string $number )
private

Converts a decimal number to a binary string.

Paramètres
string $number The number to convert, positive or zero, only digits.
Renvoie
string

Références $result, et Calculator\divQR().

Référencé par Calculator\bitwise().

◆ toDecimal()

toDecimal ( string $bytes )
private

Returns the positive decimal representation of a binary number.

Paramètres
string $bytes The bytes representing the number.
Renvoie
string

Références $i, $result, Calculator\add(), et Calculator\mul().

Référencé par Calculator\bitwise().

◆ twosComplement()

twosComplement ( string $number )
private
Paramètres
string $number A positive, binary number.
Renvoie
string

Références $i.

Référencé par Calculator\bitwise().

◆ xor()

xor | ( | string | $a,
 |  | string | $b
 | ) |  |

Calculates bitwise XOR of two numbers.

This method can be overridden by the concrete implementation if the underlying library has built-in support for bitwise operations.

Paramètres
string | $a
string | $b
Renvoie
string

Références $b, et Calculator\bitwise().

Référencé par Calculator\bitwise().

Documentation des champs

◆ $instance

$instance
staticprivate

◆ ALPHABET

const ALPHABET = '0123456789abcdefghijklmnopqrstuvwxyz'

The alphabet for converting from and to base 2 to 36, lowercase.

Référencé par BigInteger\fromBase().

◆ MAX_POWER

const MAX_POWER = 1000000

The maximum exponent value allowed for the pow() method.

Référencé par BigDecimal\power(), et BigInteger\power().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Calculator.php


Joomla CMS: Référence de la classe BigDecimal

  • Brick
  • Math
  • BigDecimal
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe BigDecimal
+ Graphe d'héritage de BigDecimal:
BigNumber

Fonctions membres publiques

plus ($that)
minus ($that)
multipliedBy ($that)
dividedBy ($that, ?int $scale=null, int $roundingMode=RoundingMode::UNNECESSARY)
exactlyDividedBy ($that)
power (int $exponent)
quotient ($that)
remainder ($that)
quotientAndRemainder ($that)
sqrt (int $scale)
withPointMovedLeft (int $n)
withPointMovedRight (int $n)
stripTrailingZeros ()
abs ()
negated ()
compareTo ($that)
getSign ()
getUnscaledValue ()
getScale ()
getIntegralPart ()
getFractionalPart ()
hasNonZeroFractionalPart ()
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
serialize ()
unserialize ($value)
- Fonctions membres publiques hérités de BigNumber
isEqualTo ($that)
isLessThan ($that)
isLessThanOrEqualTo ($that)
isGreaterThan ($that)
isGreaterThanOrEqualTo ($that)
isZero ()
isNegative ()
isNegativeOrZero ()
isPositive ()
isPositiveOrZero ()
getSign ()
compareTo ($that)
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
jsonSerialize ()

Fonctions membres publiques statiques

static | of ($value)
static | ofUnscaledValue ($value, int $scale=0)
static | zero ()
static | one ()
static | ten ()
- Fonctions membres publiques statiques hérités de BigNumber
static | of ($value)
static | min (... $values)
static | max (... $values)

Fonctions membres protégées

__construct (string $value, int $scale=0)

Fonctions membres privées

scaleValues (BigDecimal $x, BigDecimal $y)
valueWithMinScale (int $scale)
getUnscaledValueWithLeadingZeros ()

Attributs privés

$value
$scale

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de BigNumber
static create (... $args)

Description détaillée

Immutable, arbitrary-precision signed decimal numbers.

-immutable

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $value,
 |  | int | $scale = 0
 | ) |  |
protected

Protected constructor. Use a factory method to obtain an instance.

Paramètres
string | $value | The unscaled value, validated.
int | $scale | The scale, validated.

Références BigDecimal\$scale, BigDecimal\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

{}

Références BigDecimal\$value, et BigDecimal\getUnscaledValueWithLeadingZeros().

◆ abs()

abs ( )

Returns the absolute value of this number.

Renvoie
BigDecimal

Références $this, BigNumber\isNegative(), et BigDecimal\negated().

◆ compareTo()

compareTo ( $that )

{}

Références $b, $this, Calculator\get(), BigNumber\of(), et BigDecimal\scaleValues().

◆ dividedBy()

dividedBy | ( |  | $that,
 |  | ?int | $scale = null,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |

Returns the result of the division of this number by the given one, at the given scale.

Paramètres
BigNumber | int | float | string | $that | The divisor.
int | null | $scale | The desired scale, or null to use the scale of this number.
int | $roundingMode | An optional rounding mode.
Renvoie
BigDecimal
Exceptions

Références $result, BigDecimal\$scale, $this, DivisionByZeroException\divisionByZero(), elseif, Calculator\get(), null, BigDecimal\of(), et BigDecimal\valueWithMinScale().

Référencé par BigDecimal\exactlyDividedBy(), BigDecimal\toBigInteger(), et BigDecimal\toScale().

◆ exactlyDividedBy()

exactlyDividedBy ( $that )

Returns the exact result of the division of this number by the given one.

The scale of the result is automatically calculated to fit all the fraction digits.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The result.
Exceptions
MathException If the divisor is not a valid number, is not convertible to a BigDecimal, is zero, or the result yields an infinite number of digits.

Références $b, BigDecimal\$scale, $this, BigDecimal\dividedBy(), DivisionByZeroException\divisionByZero(), Calculator\get(), BigDecimal\of(), et BigDecimal\scaleValues().

◆ getFractionalPart()

getFractionalPart ( )

Returns a string representing the fractional part of this decimal number.

If the scale is zero, an empty string is returned.

Examples: -123.456 => '456', 123 => ''.

Renvoie
string

Références BigDecimal\$value, et BigDecimal\getUnscaledValueWithLeadingZeros().

Référencé par BigDecimal\hasNonZeroFractionalPart().

◆ getIntegralPart()

getIntegralPart ( )

Returns a string representing the integral part of this decimal number.

Example: -123.456 => -123.

Renvoie
string

Références BigDecimal\$value, et BigDecimal\getUnscaledValueWithLeadingZeros().

◆ getScale()

getScale ( )
Renvoie
int

Références BigDecimal\$scale.

◆ getSign()

getSign ( )

{}

Références value.

◆ getUnscaledValue()

getUnscaledValue ( )
Renvoie
BigInteger

Références BigNumber\create(), et value.

◆ getUnscaledValueWithLeadingZeros()

getUnscaledValueWithLeadingZeros ( )
private

Adds leading zeros if necessary to the unscaled value to represent the full decimal number.

Renvoie
string

Références BigDecimal\$value.

Référencé par BigDecimal\__toString(), BigDecimal\getFractionalPart(), et BigDecimal\getIntegralPart().

◆ hasNonZeroFractionalPart()

hasNonZeroFractionalPart ( )

Returns whether this decimal number has a non-zero fractional part.

Renvoie
bool

Références BigDecimal\getFractionalPart().

◆ minus()

minus ( $that )

Returns the difference of this number and the given one.

The result has a scale of max($this->scale, $that->scale).

Paramètres
BigNumber | int | float | string $that The number to subtract. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The result.
Exceptions
MathException If the number is not valid, or is not convertible to a BigDecimal.

Références $b, BigDecimal\$scale, $this, BigDecimal\$value, Calculator\get(), BigDecimal\of(), et BigDecimal\scaleValues().

◆ multipliedBy()

multipliedBy ( $that )

Returns the product of this number and the given one.

The result has a scale of $this->scale + $that->scale.

Paramètres
BigNumber | int | float | string $that The multiplier. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The result.
Exceptions
MathException If the multiplier is not a valid number, or is not convertible to a BigDecimal.

Références BigDecimal\$scale, $this, BigDecimal\$value, Calculator\get(), BigDecimal\of(), et value.

◆ negated()

negated ( )

Returns the negated value of this number.

Renvoie
BigDecimal

Références Calculator\get(), et value.

Référencé par BigDecimal\abs().

◆ of()

static of ( $value )
static

Creates a BigDecimal of the given value.

Paramètres
BigNumber | int | float | string $value
Renvoie
BigDecimal
Exceptions
MathException If the value cannot be converted to a BigDecimal.

-pure

Références BigDecimal\$value, et BigNumber\toBigDecimal().

Référencé par BigDecimal\dividedBy(), BigDecimal\exactlyDividedBy(), BigDecimal\minus(), BigDecimal\multipliedBy(), BigDecimal\plus(), BigDecimal\quotient(), BigDecimal\quotientAndRemainder(), et BigDecimal\remainder().

◆ ofUnscaledValue()

static ofUnscaledValue | ( |  | $value,
 |  | int | $scale = 0
 | ) |  |
static

Creates a BigDecimal from an unscaled value and a scale.

Example: (12345, 3) will result in the BigDecimal 12.345.

Paramètres
BigNumber | int | float | string | $value | The unscaled value. Must be convertible to a BigInteger.
int | $scale | The scale of the number, positive or zero.
Renvoie
BigDecimal
Exceptions

Références BigDecimal\$scale, BigDecimal\$value, et BigInteger\of().

◆ one()

static one ( )
static

Returns a BigDecimal representing one, with a scale of zero.

Renvoie
BigDecimal

-pure

-suppress ImpureStaticVariable

Références null.

Référencé par BigDecimal\power(), et BigDecimal\toScale().

◆ plus()

plus ( $that )

Returns the sum of this number and the given one.

The result has a scale of max($this->scale, $that->scale).

Paramètres
BigNumber | int | float | string $that The number to add. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The result.
Exceptions
MathException If the number is not valid, or is not convertible to a BigDecimal.

Références $b, BigDecimal\$scale, $this, BigDecimal\$value, Calculator\get(), BigDecimal\of(), BigDecimal\scaleValues(), et value.

◆ power()

power ( int $exponent )

Returns this number exponentiated to the given value.

The result has a scale of $this->scale * $exponent.

Paramètres
int $exponent The exponent.
Renvoie
BigDecimal The result.
Exceptions

Références $this, Calculator\get(), Calculator\MAX_POWER, BigDecimal\one(), et value.

◆ quotient()

quotient ( $that )

Returns the quotient of the division of this number by this given one.

The quotient has a scale of 0.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The quotient.
Exceptions
MathException If the divisor is not a valid decimal number, or is zero.

Références DivisionByZeroException\divisionByZero(), Calculator\get(), BigDecimal\of(), et BigDecimal\valueWithMinScale().

◆ quotientAndRemainder()

quotientAndRemainder ( $that )

Returns the quotient and remainder of the division of this number by the given one.

The quotient has a scale of 0, and the remainder has a scale of max($this->scale, $that->scale).

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigDecimal.
Renvoie
BigDecimal[] An array containing the quotient and the remainder.
Exceptions
MathException If the divisor is not a valid decimal number, or is zero.

Références BigDecimal\$scale, DivisionByZeroException\divisionByZero(), Calculator\get(), BigDecimal\of(), et BigDecimal\valueWithMinScale().

◆ remainder()

remainder ( $that )

Returns the remainder of the division of this number by this given one.

The remainder has a scale of max($this->scale, $that->scale).

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigDecimal.
Renvoie
BigDecimal The remainder.
Exceptions
MathException If the divisor is not a valid decimal number, or is zero.

Références BigDecimal\$scale, DivisionByZeroException\divisionByZero(), Calculator\get(), BigDecimal\of(), et BigDecimal\valueWithMinScale().

◆ scaleValues()

scaleValues | ( | BigDecimal | $x,
 |  | BigDecimal | $y
 | ) |  |
private

Puts the internal values of the given decimal numbers on the same scale.

Paramètres
BigDecimal | $x | The first decimal number.
BigDecimal | $y | The second decimal number.
Renvoie
array{0: string, 1: string} The scaled integer values of $x and $y.

Références $b, et elseif.

Référencé par BigDecimal\compareTo(), BigDecimal\exactlyDividedBy(), BigDecimal\minus(), et BigDecimal\plus().

◆ serialize()

serialize ( )

This method is required by interface Serializable and SHOULD NOT be accessed directly.

Références BigDecimal\$scale, et value.

◆ sqrt()

sqrt ( int $scale )

Returns the square root of this number, rounded down to the given number of decimals.

Paramètres
int $scale
Renvoie
BigDecimal
Exceptions

Références BigDecimal\$scale, BigDecimal\$value, elseif, Calculator\get(), et value.

◆ stripTrailingZeros()

stripTrailingZeros ( )

Returns a copy of this BigDecimal with any trailing zeros removed from the fractional part.

Renvoie
BigDecimal

Références BigDecimal\$scale, $this, BigDecimal\$value, value, et BigDecimal\zero().

◆ ten()

static ten ( )
static

Returns a BigDecimal representing ten, with a scale of zero.

Renvoie
BigDecimal

-pure

-suppress ImpureStaticVariable

Références null.

◆ toBigDecimal()

toBigDecimal ( )

{}

Références $this.

Référencé par BigRational\toBigDecimal(), et BigRational\toScale().

◆ toBigInteger()

toBigInteger ( )

{}

Références $this, BigNumber\create(), et BigDecimal\dividedBy().

Référencé par BigDecimal\toInt().

◆ toBigRational()

toBigRational ( )

{}

Références BigNumber\create(), et value.

◆ toFloat()

toFloat ( )

{}

Références $this.

◆ toInt()

toInt ( )

{}

Références BigDecimal\toBigInteger().

◆ toScale()

toScale | ( | int | $scale,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |

{}

Références BigDecimal\$scale, $this, BigDecimal\dividedBy(), et BigDecimal\one().

◆ unserialize()

unserialize ( $value )

This method is only here to implement interface Serializable and cannot be accessed directly.

Références BigDecimal\$scale, BigDecimal\$value, et value.

◆ valueWithMinScale()

valueWithMinScale ( int $scale )
private
Paramètres
int $scale
Renvoie
string

Références BigDecimal\$scale, BigDecimal\$value, et value.

Référencé par BigDecimal\dividedBy(), BigDecimal\quotient(), BigDecimal\quotientAndRemainder(), et BigDecimal\remainder().

◆ withPointMovedLeft()

withPointMovedLeft ( int $n )

Returns a copy of this BigDecimal with the decimal point moved $n places to the left.

Paramètres
int $n
Renvoie
BigDecimal

Références $n, $this, value, et BigDecimal\withPointMovedRight().

Référencé par BigDecimal\withPointMovedRight().

◆ withPointMovedRight()

withPointMovedRight ( int $n )

Returns a copy of this BigDecimal with the decimal point moved $n places to the right.

Paramètres
int $n
Renvoie
BigDecimal

Références $n, BigDecimal\$scale, $this, BigDecimal\$value, et BigDecimal\withPointMovedLeft().

Référencé par BigDecimal\withPointMovedLeft().

◆ zero()

static zero ( )
static

Returns a BigDecimal representing zero, with a scale of zero.

Renvoie
BigDecimal

-pure

-suppress ImpureStaticVariable

Références null.

Référencé par BigDecimal\stripTrailingZeros().

Documentation des champs

◆ $scale

$scale
private

Référencé par BigDecimal\__construct(), BigDecimal\dividedBy(), BigDecimal\exactlyDividedBy(), BigDecimal\getScale(), BigDecimal\minus(), BigDecimal\multipliedBy(), BigDecimal\ofUnscaledValue(), BigDecimal\plus(), BigDecimal\quotientAndRemainder(), BigDecimal\remainder(), BigDecimal\serialize(), BigDecimal\sqrt(), BigDecimal\stripTrailingZeros(), BigDecimal\toScale(), BigDecimal\unserialize(), BigDecimal\valueWithMinScale(), et BigDecimal\withPointMovedRight().

◆ $value

$value
private

Référencé par BigDecimal\__construct(), BigDecimal\__toString(), BigDecimal\getFractionalPart(), BigDecimal\getIntegralPart(), BigDecimal\getUnscaledValueWithLeadingZeros(), BigDecimal\minus(), BigDecimal\multipliedBy(), BigDecimal\of(), BigDecimal\ofUnscaledValue(), BigDecimal\plus(), BigDecimal\sqrt(), BigDecimal\stripTrailingZeros(), BigDecimal\unserialize(), BigDecimal\valueWithMinScale(), et BigDecimal\withPointMovedRight().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BigDecimal.php


Joomla CMS: Référence de la classe BigInteger

  • Brick
  • Math
  • BigInteger
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe BigInteger
+ Graphe d'héritage de BigInteger:
BigNumber

Fonctions membres publiques

plus ($that)
minus ($that)
multipliedBy ($that)
dividedBy ($that, int $roundingMode=RoundingMode::UNNECESSARY)
power (int $exponent)
quotient ($that)
remainder ($that)
quotientAndRemainder ($that)
mod ($that)
modInverse (BigInteger $m)
modPow ($exp, $mod)
powerMod ($exp, $mod)
gcd ($that)
sqrt ()
abs ()
negated ()
and ($that)
or ($that)
xor ($that)
shiftedLeft (int $distance)
shiftedRight (int $distance)
getBitLength ()
getLowestSetBit ()
isEven ()
isOdd ()
testBit (int $n)
compareTo ($that)
getSign ()
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
toBase (int $base)
toArbitraryBase (string $alphabet)
toBytes (bool $signed=true)
__toString ()
serialize ()
unserialize ($value)
- Fonctions membres publiques hérités de BigNumber
isEqualTo ($that)
isLessThan ($that)
isLessThanOrEqualTo ($that)
isGreaterThan ($that)
isGreaterThanOrEqualTo ($that)
isZero ()
isNegative ()
isNegativeOrZero ()
isPositive ()
isPositiveOrZero ()
getSign ()
compareTo ($that)
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
jsonSerialize ()

Fonctions membres publiques statiques

static | of ($value)
static | parse (string $number, int $base=10)
static | fromBase (string $number, int $base)
static | fromArbitraryBase (string $number, string $alphabet)
static | fromBytes (string $value, bool $signed=true)
static | randomBits (int $numBits, ?callable $randomBytesGenerator=null)
static | randomRange ($min, $max, ?callable $randomBytesGenerator=null)
static | zero ()
static | one ()
static | ten ()
- Fonctions membres publiques statiques hérités de BigNumber
static | of ($value)
static | min (... $values)
static | max (... $values)

Fonctions membres protégées

__construct (string $value)

Attributs privés

$value

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de BigNumber
static create (... $args)

Description détaillée

An arbitrary-size integer.

All methods accepting a number as a parameter accept either a BigInteger instance, an integer, or a string representing an arbitrary size integer.

-immutable

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $value )
protected

Protected constructor. Use a factory method to obtain an instance.

Paramètres
string $value A string of digits, with optional leading minus sign.

Références BigInteger\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

{}

Références BigInteger\$value.

◆ abs()

abs ( )

Returns the absolute value of this number.

Renvoie
BigInteger

Références $this, BigNumber\isNegative(), et BigInteger\negated().

Référencé par BigInteger\getBitLength(), et BigInteger\toBytes().

◆ and()

and ( $that )

Returns the integer bitwise-and combined with another integer.

This method returns a negative BigInteger if and only if both operands are negative.

Paramètres
BigNumber | int | float | string $that The operand. Must be convertible to an integer number.
Renvoie
BigInteger

Références Calculator\get(), BigInteger\of(), et value.

◆ compareTo()

compareTo ( $that )

{}

Références $this, Calculator\get(), BigNumber\of(), et value.

◆ dividedBy()

dividedBy | ( |  | $that,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |

Returns the result of the division of this number by the given one.

Paramètres
BigNumber | int | float | string | $that | The divisor. Must be convertible to a BigInteger.
int | $roundingMode | An optional rounding mode.
Renvoie
BigInteger The result.
Exceptions
MathException If the divisor is not a valid number, is not convertible to a BigInteger, is zero, or RoundingMode::UNNECESSARY is used and the remainder is not zero.

Références $result, $this, DivisionByZeroException\divisionByZero(), Calculator\get(), BigInteger\of(), et value.

Référencé par BigInteger\shiftedRight().

◆ fromArbitraryBase()

static fromArbitraryBase | ( | string | $number,
 |  | string | $alphabet
 | ) |  |
static

Parses a string containing an integer in an arbitrary base, using a custom alphabet.

Because this method accepts an alphabet with any character, including dash, it does not handle negative numbers.

Paramètres
string | $number | The number to parse.
string | $alphabet | The alphabet, for example '01' for base 2, or '01234567' for base 8.
Renvoie
BigInteger
Exceptions
NumberFormatException If the given number is empty or contains invalid chars for the given alphabet.

Références $base, NumberFormatException\charNotInAlphabet(), et Calculator\get().

◆ fromBase()

static fromBase | ( | string | $number,
 |  | int | $base
 | ) |  |
static

Creates a number from a string in a given base.

The string can optionally be prefixed with the + or - sign.

Bases greater than 36 are not supported by this method, as there is no clear consensus on which of the lowercase or uppercase characters should come first. Instead, this method accepts any base up to 36, and does not differentiate lowercase and uppercase characters, which are considered equal.

For bases greater than 36, and/or custom alphabets, use the fromArbitraryBase() method.

Paramètres
string | $number | The number to convert, in the given base.
int | $base | The base of the number, between 2 and 36.
Renvoie
BigInteger
Exceptions
NumberFormatException If the number is empty, or contains invalid chars for the given base.

Références $base, $result, Calculator\ALPHABET, elseif, Calculator\get(), et BigInteger\zero().

Référencé par NegativeBigIntegerTag\getNormalizedData().

◆ fromBytes()

static fromBytes | ( | string | $value,
 |  | bool | $signed = true
 | ) |  |
static

Translates a string of bytes containing the binary representation of a BigInteger into a BigInteger.

The input string is assumed to be in big-endian byte-order: the most significant byte is in the zeroth element.

If $signed is true, the input is assumed to be in two's-complement representation, and the leading bit is interpreted as a sign bit. If $signed is false, the input is interpreted as an unsigned number, and the resulting BigInteger will always be positive or zero.

This method can be used to retrieve a number exported by toBytes(), as long as the $signed flags match.

Paramètres
string | $value | The byte string.
bool | $signed | Whether to interpret as a signed number in two's-complement representation with a leading sign bit.
Renvoie
BigInteger
Exceptions
NumberFormatException If the string is empty.

Références BigInteger\$value.

◆ gcd()

gcd ( $that )

Returns the greatest common divisor of this number and the given one.

The GCD is always positive, unless both operands are zero, in which case it is zero.

Paramètres
BigNumber | int | float | string $that The operand. Must be convertible to an integer number.
Renvoie
BigInteger

Références $this, BigInteger\$value, Calculator\get(), BigInteger\of(), et value.

◆ getBitLength()

getBitLength ( )

Returns the number of bits in the minimal two's-complement representation of this BigInteger, excluding a sign bit.

For positive BigIntegers, this is equivalent to the number of bits in the ordinary binary representation. Computes (ceil(log2(this < 0 ? -this : this+1))).

Renvoie
int

Références BigInteger\abs(), BigNumber\isNegative(), BigInteger\toBase(), et value.

Référencé par BigInteger\getLowestSetBit().

◆ getLowestSetBit()

getLowestSetBit ( )

Returns the index of the rightmost (lowest-order) one bit in this BigInteger.

Returns -1 if this BigInteger contains no one bits.

Renvoie
int

Références $i, $n, $this, et BigInteger\getBitLength().

◆ getSign()

getSign ( )

{}

Références value.

◆ isEven()

isEven ( )

Returns whether this number is even.

Renvoie
bool

Références value.

◆ isOdd()

isOdd ( )

Returns whether this number is odd.

Renvoie
bool

Références value.

◆ minus()

minus ( $that )

Returns the difference of this number and the given one.

Paramètres
BigNumber | int | float | string $that The number to subtract. Must be convertible to a BigInteger.
Renvoie
BigInteger The result.
Exceptions
MathException If the number is not valid, or is not convertible to a BigInteger.

Références $this, BigInteger\$value, Calculator\get(), BigInteger\of(), et value.

◆ mod()

mod ( $that )

Returns the modulo of this number and the given one.

The modulo operation yields the same result as the remainder operation when both operands are of the same sign, and may differ when signs are different.

The result of the modulo operation, when non-zero, has the same sign as the divisor.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigInteger.
Renvoie
BigInteger
Exceptions
DivisionByZeroException If the divisor is zero.

Références BigInteger\$value, Calculator\get(), DivisionByZeroException\modulusMustNotBeZero(), BigInteger\of(), et value.

◆ modInverse()

modInverse ( BigInteger $m )

Returns the modular multiplicative inverse of this BigInteger modulo $m.

Paramètres
BigInteger $m
Renvoie
BigInteger
Exceptions
DivisionByZeroException | If $m is zero.
NegativeNumberException | If $m is negative.
MathException | If this BigInteger has no multiplicative inverse mod m (that is, this BigInteger is not relatively prime to m).

Références BigInteger\$value, Calculator\get(), BigNumber\isNegative(), DivisionByZeroException\modulusMustNotBeZero(), null, value, et BigInteger\zero().

◆ modPow()

modPow | ( | $exp,
 |  | $mod
 | ) |

Returns this number raised into power with modulo.

This operation only works on positive numbers.

Paramètres
BigNumber | int | float | string | $exp | The positive exponent.
BigNumber | int | float | string | $mod | The modulus. Must not be zero.
Renvoie
BigInteger
Exceptions
NegativeNumberException | If any of the operands is negative.
DivisionByZeroException | If the modulus is zero.

Références $mod, $result, Calculator\get(), BigNumber\isNegative(), DivisionByZeroException\modulusMustNotBeZero(), BigInteger\of(), et value.

Référencé par BigInteger\powerMod().

◆ multipliedBy()

multipliedBy ( $that )

Returns the product of this number and the given one.

Paramètres
BigNumber | int | float | string $that The multiplier. Must be convertible to a BigInteger.
Renvoie
BigInteger The result.
Exceptions
MathException If the multiplier is not a valid number, or is not convertible to a BigInteger.

Références $this, BigInteger\$value, Calculator\get(), BigInteger\of(), et value.

Référencé par BigInteger\shiftedLeft().

◆ negated()

negated ( )

Returns the inverse of this number.

Renvoie
BigInteger

Références Calculator\get(), et value.

Référencé par BigInteger\abs().

◆ of()

static of ( $value )
static

Creates a BigInteger of the given value.

Paramètres
BigNumber | int | float | string $value
Renvoie
BigInteger
Exceptions
MathException If the value cannot be converted to a BigInteger.

-pure

Références BigInteger\$value, et BigNumber\toBigInteger().

Référencé par BigInteger\and(), BigInteger\dividedBy(), BigInteger\gcd(), NegativeBigIntegerTag\getNormalizedData(), BigInteger\minus(), BigInteger\mod(), BigInteger\modPow(), BigInteger\multipliedBy(), BigRational\nd(), BigDecimal\ofUnscaledValue(), BigInteger\or(), BigInteger\plus(), BigInteger\quotient(), BigInteger\quotientAndRemainder(), BigInteger\randomRange(), BigInteger\remainder(), BigInteger\shiftedLeft(), BigInteger\shiftedRight(), BigRational\unserialize(), et BigInteger\xor().

◆ one()

static one ( )
static

Returns a BigInteger representing one.

Renvoie
BigInteger

-pure

-suppress ImpureStaticVariable

Références null.

Référencé par DoublePrecisionFloatObject\getSign(), HalfPrecisionFloatObject\getSign(), SinglePrecisionFloatObject\getSign(), BigRational\one(), BigRational\power(), BigInteger\power(), BigRational\ten(), BigInteger\toBigRational(), et BigRational\zero().

◆ or()

or ( $that )

Returns the integer bitwise-or combined with another integer.

This method returns a negative BigInteger if and only if either of the operands is negative.

Paramètres
BigNumber | int | float | string $that The operand. Must be convertible to an integer number.
Renvoie
BigInteger

Références Calculator\get(), BigInteger\of(), et value.

◆ parse()

static parse | ( | string | $number,
 |  | int | $base = 10
 | ) |  |
static

Parses a string containing an integer in an arbitrary base.

Obsolète:
will be removed in version 0.9 - use fromBase() instead

The string can optionally be prefixed with the + or - sign. For bases greater than 10, both uppercase and lowercase letters are allowed.

Paramètres
string | $number | The number to parse.
int | $base | The base of the number, between 2 and 36.
Renvoie
BigInteger
Exceptions

Références $base.

◆ plus()

plus ( $that )

Returns the sum of this number and the given one.

Paramètres
BigNumber | int | float | string $that The number to add. Must be convertible to a BigInteger.
Renvoie
BigInteger The result.
Exceptions
MathException If the number is not valid, or is not convertible to a BigInteger.

Références $this, BigInteger\$value, Calculator\get(), BigInteger\of(), et value.

◆ power()

power ( int $exponent )

Returns this number exponentiated to the given value.

Paramètres
int $exponent The exponent.
Renvoie
BigInteger The result.
Exceptions

Références $this, Calculator\get(), Calculator\MAX_POWER, BigInteger\one(), et value.

Référencé par BigInteger\shiftedLeft().

◆ powerMod()

powerMod | ( | $exp,
 |  | $mod
 | ) |

Returns this number raised into power with modulo.

Obsolète:
Use modPow() instead.
Paramètres
BigNumber | int | float | string | $exp | The positive exponent.
BigNumber | int | float | string | $mod | The modulus. Must not be zero.
Renvoie
BigInteger
Exceptions
NegativeNumberException | If any of the operands is negative.
DivisionByZeroException | If the modulus is zero.

Références $mod, et BigInteger\modPow().

◆ quotient()

quotient ( $that )

Returns the quotient of the division of this number by the given one.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigInteger.
Renvoie
BigInteger
Exceptions
DivisionByZeroException If the divisor is zero.

Références $this, DivisionByZeroException\divisionByZero(), Calculator\get(), BigInteger\of(), et value.

Référencé par BigInteger\shiftedRight().

◆ quotientAndRemainder()

quotientAndRemainder ( $that )

Returns the quotient and remainder of the division of this number by the given one.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigInteger.
Renvoie
BigInteger[] An array containing the quotient and the remainder.
Exceptions
DivisionByZeroException If the divisor is zero.

Références DivisionByZeroException\divisionByZero(), Calculator\get(), BigInteger\of(), et value.

◆ randomBits()

static randomBits | ( | int | $numBits,
 |  | ?callable | $randomBytesGenerator = null
 | ) |  |
static

Generates a pseudo-random number in the range 0 to 2^numBits - 1.

Using the default random bytes generator, this method is suitable for cryptographic use.

Paramètres
int | $numBits | The number of bits.
callable | null | $randomBytesGenerator | A function that accepts a number of bytes as an integer, and returns a string of random bytes of the given length. Defaults to the random_bytes() function.
Renvoie
BigInteger
Exceptions

Références null, et BigInteger\zero().

◆ randomRange()

static randomRange | ( |  | $min,
 |  |  | $max,
 |  | ?callable | $randomBytesGenerator = null
 | ) |  |
static

Generates a pseudo-random number between $min and $max.

Using the default random bytes generator, this method is suitable for cryptographic use.

Paramètres
BigNumber | int | float | string | $min | The lower bound. Must be convertible to a BigInteger.
BigNumber | int | float | string | $max | The upper bound. Must be convertible to a BigInteger.
callable | null | $randomBytesGenerator | A function that accepts a number of bytes as an integer, and returns a string of random bytes of the given length. Defaults to the random_bytes() function.
Renvoie
BigInteger
Exceptions
MathException If one of the parameters cannot be converted to a BigInteger, or $min is greater than $max.

Références BigInteger\of().

◆ remainder()

remainder ( $that )

Returns the remainder of the division of this number by the given one.

The remainder, when non-zero, has the same sign as the dividend.

Paramètres
BigNumber | int | float | string $that The divisor. Must be convertible to a BigInteger.
Renvoie
BigInteger
Exceptions
DivisionByZeroException If the divisor is zero.

Références DivisionByZeroException\divisionByZero(), Calculator\get(), BigInteger\of(), value, et BigInteger\zero().

◆ serialize()

serialize ( )

This method is required by interface Serializable and SHOULD NOT be accessed directly.

Références BigInteger\$value.

◆ shiftedLeft()

shiftedLeft ( int $distance )

Returns the integer left shifted by a given number of bits.

Paramètres
int $distance The distance to shift.
Renvoie
BigInteger

Références $this, BigInteger\multipliedBy(), BigInteger\of(), BigInteger\power(), et BigInteger\shiftedRight().

Référencé par BigInteger\shiftedRight().

◆ shiftedRight()

shiftedRight ( int $distance )

Returns the integer right shifted by a given number of bits.

Paramètres
int $distance The distance to shift.
Renvoie
BigInteger

Références $this, BigInteger\dividedBy(), BigNumber\isPositiveOrZero(), BigInteger\of(), BigInteger\quotient(), BigInteger\shiftedLeft(), et RoundingMode\UP.

Référencé par BigInteger\shiftedLeft(), et BigInteger\testBit().

◆ sqrt()

sqrt ( )

Returns the integer square root number of this number, rounded down.

The result is the largest x such that x² ≤ n.

Renvoie
BigInteger
Exceptions
NegativeNumberException If this number is negative.

Références BigInteger\$value, Calculator\get(), et value.

◆ ten()

static ten ( )
static

Returns a BigInteger representing ten.

Renvoie
BigInteger

-pure

-suppress ImpureStaticVariable

Références null.

Référencé par BigRational\ten().

◆ testBit()

testBit ( int $n )

Returns true if and only if the designated bit is set.

Computes ((this & (1<<n)) != 0).

Paramètres
int $n The bit to test, 0-based.
Renvoie
bool
Exceptions

Références $n, et BigInteger\shiftedRight().

◆ toArbitraryBase()

toArbitraryBase ( string $alphabet )

Returns a string representation of this number in an arbitrary base with a custom alphabet.

Because this method accepts an alphabet with any character, including dash, it does not handle negative numbers; a NegativeNumberException will be thrown when attempting to call this method on a negative number.

Paramètres
string $alphabet The alphabet, for example '01' for base 2, or '01234567' for base 8.
Renvoie
string
Exceptions
NegativeNumberException If this number is negative.

Références $base, Calculator\get(), et value.

◆ toBase()

toBase ( int $base )

Returns a string representation of this number in the given base.

The output will always be lowercase for bases greater than 10.

Paramètres
int $base
Renvoie
string
Exceptions

Références $base, BigInteger\$value, Calculator\get(), et value.

Référencé par UnsignedIntegerObject\createBigInteger(), et BigInteger\getBitLength().

◆ toBigDecimal()

toBigDecimal ( )

{}

Références BigNumber\create(), et value.

Référencé par BigInteger\toScale().

◆ toBigInteger()

toBigInteger ( )

{}

Références $this.

◆ toBigRational()

toBigRational ( )

{}

Références $this, BigNumber\create(), et BigInteger\one().

◆ toBytes()

toBytes ( bool $signed = true )

Returns a string of bytes containing the binary representation of this BigInteger.

The string is in big-endian byte-order: the most significant byte is in the zeroth element.

If $signed is true, the output will be in two's-complement representation, and a sign bit will be prepended to the output. If $signed is false, no sign bit will be prepended, and this method will throw an exception if the number is negative.

The string will contain the minimum number of bytes required to represent this BigInteger, including a sign bit if $signed is true.

This representation is compatible with the fromBytes() factory method, as long as the $signed flags match.

Paramètres
bool $signed Whether to output a signed number in two's-complement representation with a leading sign bit.
Renvoie
string
Exceptions
NegativeNumberException If $signed is false, and the number is negative.

Références BigInteger\abs(), et BigNumber\isNegative().

◆ toFloat()

toFloat ( )

{}

Références BigInteger\$value.

◆ toInt()

toInt ( )

{}

Références $this, IntegerOverflowException\toIntOverflow(), et value.

Référencé par UnsignedIntegerObject\createBigInteger().

◆ toScale()

toScale | ( | int | $scale,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |

{}

Références BigInteger\toBigDecimal().

◆ unserialize()

unserialize ( $value )

This method is only here to implement interface Serializable and cannot be accessed directly.

Références BigInteger\$value, et value.

◆ xor()

xor ( $that )

Returns the integer bitwise-xor combined with another integer.

This method returns a negative BigInteger if and only if exactly one of the operands is negative.

Paramètres
BigNumber | int | float | string $that The operand. Must be convertible to an integer number.
Renvoie
BigInteger

Références Calculator\get(), BigInteger\of(), et value.

◆ zero()

static zero ( )
static

Returns a BigInteger representing zero.

Renvoie
BigInteger

-pure

-suppress ImpureStaticVariable

Références null.

Référencé par BigInteger\fromBase(), BigInteger\modInverse(), BigInteger\randomBits(), BigInteger\remainder(), et BigRational\zero().

Documentation des champs

◆ $value

$value
private

Référencé par BigInteger\__construct(), BigInteger\__toString(), BigInteger\fromBytes(), BigInteger\gcd(), BigInteger\minus(), BigInteger\mod(), BigInteger\modInverse(), BigInteger\multipliedBy(), BigInteger\of(), BigInteger\plus(), BigInteger\serialize(), BigInteger\sqrt(), BigInteger\toBase(), BigInteger\toFloat(), et BigInteger\unserialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brick/math/src/BigInteger.php


Joomla CMS: Référence de la classe BigNumber

  • Brick
  • Math
  • BigNumber
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe BigNumber
+ Graphe d'héritage de BigNumber:
BigDecimal BigInteger BigRational

Fonctions membres publiques

isEqualTo ($that)
isLessThan ($that)
isLessThanOrEqualTo ($that)
isGreaterThan ($that)
isGreaterThanOrEqualTo ($that)
isZero ()
isNegative ()
isNegativeOrZero ()
isPositive ()
isPositiveOrZero ()
getSign ()
compareTo ($that)
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
jsonSerialize ()

Fonctions membres publiques statiques

static | of ($value)
static | min (... $values)
static | max (... $values)

Fonctions membres protégées statiques

static create (... $args)

Fonctions membres privées statiques

static | floatToString (float $float)
static | cleanUp (string $number)

Attributs privés

const PARSE_REGEXP

Description détaillée

Common interface for arbitrary-precision rational numbers.

-immutable

Documentation des fonctions membres

◆ __toString()

__toString ( )
abstract

Returns a string representation of this number.

The output of this method can be parsed by the of() factory method; this will yield an object equal to this one, without any information loss.

Renvoie
string

Référencé par BigNumber\jsonSerialize().

◆ cleanUp()

static cleanUp ( string $number )
staticprivate

Removes optional leading zeros and + sign from the given number.

Paramètres
string $number The number, validated as a non-empty string of digits with optional sign.
Renvoie
string

-pure

◆ compareTo()

compareTo ( $that )
abstract

Compares this number to the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
int [-1,0,1] If $this is lower than, equal to, or greater than $that.
Exceptions
MathException If the number is not valid.

Référencé par BigNumber\isEqualTo(), BigNumber\isGreaterThan(), BigNumber\isGreaterThanOrEqualTo(), BigNumber\isLessThan(), et BigNumber\isLessThanOrEqualTo().

◆ create()

static create ( $args )
staticprotected

Proxy method to access protected constructors from sibling classes.

-suppress TooManyArguments

Référencé par BigDecimal\getUnscaledValue(), BigInteger\toBigDecimal(), BigDecimal\toBigInteger(), BigDecimal\toBigRational(), et BigInteger\toBigRational().

◆ floatToString()

static floatToString ( float $float )
staticprivate

Safely converts float to string, avoiding locale-dependent issues.

Voir également
https://github.com/brick/math/pull/20
Paramètres
float $float
Renvoie
string

-pure -suppress ImpureFunctionCall

Références $result.

◆ getSign()

getSign ( )
abstract

Returns the sign of this number.

Renvoie
int -1 if the number is negative, 0 if zero, 1 if positive.

Référencé par BigNumber\isNegative(), BigNumber\isNegativeOrZero(), BigNumber\isPositive(), BigNumber\isPositiveOrZero(), et BigNumber\isZero().

◆ isEqualTo()

isEqualTo ( $that )

Checks if this number is equal to the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
bool

Références BigNumber\compareTo().

◆ isGreaterThan()

isGreaterThan ( $that )

Checks if this number is strictly greater than the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
bool

Références BigNumber\compareTo().

◆ isGreaterThanOrEqualTo()

isGreaterThanOrEqualTo ( $that )

Checks if this number is greater than or equal to the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
bool

Références BigNumber\compareTo().

Référencé par SignedIntegerObject\createBigInteger().

◆ isLessThan()

isLessThan ( $that )

Checks if this number is strictly lower than the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
bool

Références BigNumber\compareTo().

Référencé par UnsignedIntegerObject\createBigInteger().

◆ isLessThanOrEqualTo()

isLessThanOrEqualTo ( $that )

Checks if this number is lower than or equal to the given one.

Paramètres
BigNumber | int | float | string $that
Renvoie
bool

Références BigNumber\compareTo().

◆ isNegative()

isNegative ( )

Checks if this number is strictly negative.

Renvoie
bool

Références BigNumber\getSign().

Référencé par BigDecimal\abs(), BigInteger\abs(), BigInteger\getBitLength(), BigInteger\modInverse(), BigInteger\modPow(), et BigInteger\toBytes().

◆ isNegativeOrZero()

isNegativeOrZero ( )

Checks if this number is negative or zero.

Renvoie
bool

Références BigNumber\getSign().

◆ isPositive()

isPositive ( )

Checks if this number is strictly positive.

Renvoie
bool

Références BigNumber\getSign().

◆ isPositiveOrZero()

isPositiveOrZero ( )

Checks if this number is positive or zero.

Renvoie
bool

Références BigNumber\getSign().

Référencé par BigInteger\shiftedRight().

◆ isZero()

isZero ( )

Checks if this number equals zero.

Renvoie
bool

Références BigNumber\getSign().

◆ jsonSerialize()

jsonSerialize ( )

{}

Références BigNumber\__toString().

◆ max()

static max ( $values )
static

Returns the maximum of the given values.

Paramètres
BigNumber|int|float|string ...$values The numbers to compare. All the numbers need to be convertible to an instance of the class this method is called on.
Renvoie
static The maximum value.
Exceptions

Références $value, et null.

◆ min()

static min ( $values )
static

Returns the minimum of the given values.

Paramètres
BigNumber|int|float|string ...$values The numbers to compare. All the numbers need to be convertible to an instance of the class this method is called on.
Renvoie
static The minimum value.
Exceptions

Références $value, et null.

◆ of()

static of ( $value )
static

Creates a BigNumber of the given value.

The concrete return type is dependent on the given value, with the following rules:

  • BigNumber instances are returned as is
  • integer numbers are returned as BigInteger
  • floating point numbers are converted to a string then parsed as such
  • strings containing a / character are returned as BigRational
  • strings containing a . character or using an exponential notation are returned as BigDecimal
  • strings containing only digits with an optional leading + or - sign are returned as BigInteger
Paramètres
BigNumber | int | float | string $value
Renvoie
BigNumber
Exceptions
NumberFormatException | If the format of the number is not valid.
DivisionByZeroException | If the value represents a rational number with a denominator of zero.

-pure

Références $value, et DivisionByZeroException\denominatorMustNotBeZero().

Référencé par BigDecimal\compareTo(), et BigInteger\compareTo().

◆ toBigDecimal()

toBigDecimal ( )
abstract

Converts this number to a BigDecimal.

Renvoie
BigDecimal The converted number.
Exceptions
RoundingNecessaryException If this number cannot be converted to a BigDecimal without rounding.

Référencé par BigDecimal\of().

◆ toBigInteger()

toBigInteger ( )
abstract

Converts this number to a BigInteger.

Renvoie
BigInteger The converted number.
Exceptions
RoundingNecessaryException If this number cannot be converted to a BigInteger without rounding.

Référencé par BigInteger\of().

◆ toBigRational()

toBigRational ( )
abstract

Converts this number to a BigRational.

Renvoie
BigRational The converted number.

Référencé par BigRational\of().

◆ toFloat()

toFloat ( )
abstract

Returns an approximation of this number as a floating-point value.

Note that this method can discard information as the precision of a floating-point value is inherently limited.

If the number is greater than the largest representable floating point number, positive infinity is returned. If the number is less than the smallest representable floating point number, negative infinity is returned.

Renvoie
float The converted value.

◆ toInt()

toInt ( )
abstract

Returns the exact value of this number as a native integer.

If this number cannot be converted to a native integer without losing precision, an exception is thrown. Note that the acceptable range for an integer depends on the platform and differs for 32-bit and 64-bit.

Renvoie
int The converted value.
Exceptions
MathException If this number cannot be exactly converted to a native integer.

◆ toScale()

toScale | ( | int | $scale,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |
abstract

Converts this number to a BigDecimal with the given scale, using rounding if necessary.

Paramètres
int | $scale | The scale of the resulting BigDecimal.
int | $roundingMode | A RoundingMode constant.
Renvoie
BigDecimal
Exceptions
RoundingNecessaryException If this number cannot be converted to the given scale without rounding. This only applies when RoundingMode::UNNECESSARY is used.

Documentation des champs

◆ PARSE_REGEXP

const PARSE_REGEXP
private
Valeur initiale :
=
'/^' .
'(?<integral>[\-\+]?[0-9]+)' .
'(?:' .
'(?:' .
'(?:\.(?<fractional>[0-9]+))?' .
'(?:[eE](?<exponent>[\-\+]?[0-9]+))?' .
')' . '|' . '(?:' .
'(?:\/(?<denominator>[0-9]+))?' .
')' .
')?' .
'$/'
La documentation de cette classe a été générée à partir du fichier suivant :
  • BigNumber.php


Joomla CMS: Référence de la classe BigRational

  • Brick
  • Math
  • BigRational
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe BigRational
+ Graphe d'héritage de BigRational:
BigNumber

Fonctions membres publiques

getNumerator ()
getDenominator ()
quotient ()
remainder ()
quotientAndRemainder ()
plus ($that)
minus ($that)
multipliedBy ($that)
dividedBy ($that)
power (int $exponent)
reciprocal ()
abs ()
negated ()
simplified ()
compareTo ($that)
getSign ()
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
serialize ()
unserialize ($value)
- Fonctions membres publiques hérités de BigNumber
isEqualTo ($that)
isLessThan ($that)
isLessThanOrEqualTo ($that)
isGreaterThan ($that)
isGreaterThanOrEqualTo ($that)
isZero ()
isNegative ()
isNegativeOrZero ()
isPositive ()
isPositiveOrZero ()
getSign ()
compareTo ($that)
toBigInteger ()
toBigDecimal ()
toBigRational ()
toScale (int $scale, int $roundingMode=RoundingMode::UNNECESSARY)
toInt ()
toFloat ()
__toString ()
jsonSerialize ()

Fonctions membres publiques statiques

static | of ($value)
static | nd ($numerator, $denominator)
static | zero ()
static | one ()
static | ten ()
- Fonctions membres publiques statiques hérités de BigNumber
static | of ($value)
static | min (... $values)
static | max (... $values)

Fonctions membres protégées

__construct (BigInteger $numerator, BigInteger $denominator, bool $checkDenominator)

Attributs privés

$numerator
$denominator

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de BigNumber
static create (... $args)

Description détaillée

An arbitrarily large rational number.

This class is immutable.

-immutable

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | BigInteger | $numerator,
 |  | BigInteger | $denominator,
 |  | bool | $checkDenominator
 | ) |  |
protected

Protected constructor. Use a factory method to obtain an instance.

Paramètres
BigInteger | $numerator | The numerator.
BigInteger | $denominator | The denominator.
bool | $checkDenominator | Whether to check the denominator for negative and zero.
Exceptions
DivisionByZeroException If the denominator is zero.

Références BigRational\$denominator, BigRational\$numerator, et DivisionByZeroException\denominatorMustNotBeZero().

Documentation des fonctions membres

◆ __toString()

__toString ( )

{}

Références BigRational\$denominator, et BigRational\$numerator.

◆ abs()

abs ( )

Returns the absolute value of this BigRational.

Renvoie
BigRational

Références BigRational\$denominator.

◆ compareTo()

compareTo ( $that )

{}

Références BigRational\minus().

◆ dividedBy()

dividedBy ( $that )

Returns the result of the division of this number by the given one.

Paramètres
BigNumber | int | float | string $that The divisor.
Renvoie
BigRational The result.
Exceptions
MathException If the divisor is not a valid number, or is zero.

Références BigRational\$denominator, BigRational\$numerator, et BigRational\of().

◆ getDenominator()

getDenominator ( )
Renvoie
BigInteger

Références BigRational\$denominator.

◆ getNumerator()

getNumerator ( )
Renvoie
BigInteger

Références BigRational\$numerator.

◆ getSign()

getSign ( )

{}

◆ minus()

minus ( $that )

Returns the difference of this number and the given one.

Paramètres
BigNumber | int | float | string $that The number to subtract.
Renvoie
BigRational The result.
Exceptions
MathException If the number is not valid.

Références BigRational\$denominator, BigRational\$numerator, $this, et BigRational\of().

Référencé par BigRational\compareTo().

◆ multipliedBy()

multipliedBy ( $that )

Returns the product of this number and the given one.

Paramètres
BigNumber | int | float | string $that The multiplier.
Renvoie
BigRational The result.
Exceptions
MathException If the multiplier is not a valid number.

Références BigRational\$denominator, BigRational\$numerator, et BigRational\of().

◆ nd()

static nd | ( | $numerator,
 |  | $denominator
 | ) |
static

Creates a BigRational out of a numerator and a denominator.

If the denominator is negative, the signs of both the numerator and the denominator will be inverted to ensure that the denominator is always positive.

Paramètres
BigNumber | int | float | string | $numerator | The numerator. Must be convertible to a BigInteger.
BigNumber | int | float | string | $denominator | The denominator. Must be convertible to a BigInteger.
Renvoie
BigRational
Exceptions
NumberFormatException | If an argument does not represent a valid number.
RoundingNecessaryException | If an argument represents a non-integer number.
DivisionByZeroException | If the denominator is zero.

-pure

Références BigRational\$denominator, BigRational\$numerator, et BigInteger\of().

◆ negated()

negated ( )

Returns the negated value of this BigRational.

Renvoie
BigRational

Références BigRational\$denominator.

◆ of()

static of ( $value )
static

Creates a BigRational of the given value.

Paramètres
BigNumber | int | float | string $value
Renvoie
BigRational
Exceptions
MathException If the value cannot be converted to a BigRational.

-pure

Références $value, et BigNumber\toBigRational().

Référencé par BigRational\dividedBy(), BigRational\minus(), BigRational\multipliedBy(), et BigRational\plus().

◆ one()

static one ( )
static

Returns a BigRational representing one.

Renvoie
BigRational

-pure

-suppress ImpureStaticVariable

Références null, et BigInteger\one().

◆ plus()

plus ( $that )

Returns the sum of this number and the given one.

Paramètres
BigNumber | int | float | string $that The number to add.
Renvoie
BigRational The result.
Exceptions
MathException If the number is not valid.

Références BigRational\$denominator, BigRational\$numerator, $this, et BigRational\of().

◆ power()

power ( int $exponent )

Returns this number exponentiated to the given value.

Paramètres
int $exponent The exponent.
Renvoie
BigRational The result.
Exceptions

Références $this, false, et BigInteger\one().

◆ quotient()

quotient ( )

Returns the quotient of the division of the numerator by the denominator.

Renvoie
BigInteger

◆ quotientAndRemainder()

quotientAndRemainder ( )

Returns the quotient and remainder of the division of the numerator by the denominator.

Renvoie
BigInteger[]

◆ reciprocal()

reciprocal ( )

Returns the reciprocal of this BigRational.

The reciprocal has the numerator and denominator swapped.

Renvoie
BigRational
Exceptions
DivisionByZeroException If the numerator is zero.

◆ remainder()

remainder ( )

Returns the remainder of the division of the numerator by the denominator.

Renvoie
BigInteger

◆ serialize()

serialize ( )

This method is required by interface Serializable and SHOULD NOT be accessed directly.

Références BigRational\$denominator.

◆ simplified()

simplified ( )

Returns the simplified value of this BigRational.

Renvoie
BigRational

Références BigRational\$denominator, et BigRational\$numerator.

Référencé par BigRational\toBigInteger().

◆ ten()

static ten ( )
static

Returns a BigRational representing ten.

Renvoie
BigRational

-pure

-suppress ImpureStaticVariable

Références null, BigInteger\one(), et BigInteger\ten().

◆ toBigDecimal()

toBigDecimal ( )

{}

Références BigDecimal\toBigDecimal().

◆ toBigInteger()

toBigInteger ( )

{}

Références BigRational\simplified().

Référencé par BigRational\toInt().

◆ toBigRational()

toBigRational ( )

{}

Références $this.

◆ toFloat()

toFloat ( )

{}

◆ toInt()

toInt ( )

{}

Références BigRational\toBigInteger().

◆ toScale()

toScale | ( | int | $scale,
 |  | int | $roundingMode = RoundingMode::UNNECESSARY
 | ) |  |

{}

Références BigDecimal\toBigDecimal().

◆ unserialize()

unserialize ( $value )

This method is only here to implement interface Serializable and cannot be accessed directly.

Références BigRational\$denominator, BigRational\$numerator, $value, et BigInteger\of().

◆ zero()

static zero ( )
static

Returns a BigRational representing zero.

Renvoie
BigRational

-pure

-suppress ImpureStaticVariable

Références null, BigInteger\one(), et BigInteger\zero().

Documentation des champs

◆ $denominator

$denominator
private

Référencé par BigRational\__construct(), BigRational\__toString(), BigRational\abs(), BigRational\dividedBy(), BigRational\getDenominator(), BigRational\minus(), BigRational\multipliedBy(), BigRational\nd(), BigRational\negated(), BigRational\plus(), BigRational\serialize(), BigRational\simplified(), et BigRational\unserialize().

◆ $numerator

$numerator
private

Référencé par BigRational\__construct(), BigRational\__toString(), BigRational\dividedBy(), BigRational\getNumerator(), BigRational\minus(), BigRational\multipliedBy(), BigRational\nd(), BigRational\plus(), BigRational\simplified(), et BigRational\unserialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BigRational.php


Joomla CMS: Référence de la classe RoundingMode

  • Brick
  • Math
  • RoundingMode
Champs de données | Fonctions membres privées
Référence de la classe RoundingMode

Champs de données

const | UNNECESSARY = 0
const | UP = 1
const | DOWN = 2
const | CEILING = 3
const | FLOOR = 4
const | HALF_UP = 5
const | HALF_DOWN = 6
const | HALF_CEILING = 7
const | HALF_FLOOR = 8
const | HALF_EVEN = 9

Fonctions membres privées

__construct ()

Description détaillée

Specifies a rounding behavior for numerical operations capable of discarding precision.

Each rounding mode indicates how the least significant returned digit of a rounded result is to be calculated. If fewer digits are returned than the digits needed to represent the exact numerical result, the discarded digits will be referred to as the discarded fraction regardless the digits' contribution to the value of the number. In other words, considered as a numerical value, the discarded fraction could have an absolute value greater than one.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor. This class is not instantiable.

Documentation des champs

◆ CEILING

const CEILING = 3

Rounds towards positive infinity.

If the result is positive, behaves as for UP; if negative, behaves as for DOWN. Note that this rounding mode never decreases the calculated value.

Référencé par Calculator\divRound().

◆ DOWN

const DOWN = 2

Rounds towards zero.

Never increments the digit prior to a discarded fraction (i.e., truncates). Note that this rounding mode never increases the magnitude of the calculated value.

Référencé par Calculator\divRound().

◆ FLOOR

const FLOOR = 4

Rounds towards negative infinity.

If the result is positive, behave as for DOWN; if negative, behave as for UP. Note that this rounding mode never increases the calculated value.

Référencé par Calculator\divRound().

◆ HALF_CEILING

const HALF_CEILING = 7

Rounds towards "nearest neighbor" unless both neighbors are equidistant, in which case round towards positive infinity.

If the result is positive, behaves as for HALF_UP; if negative, behaves as for HALF_DOWN.

Référencé par Calculator\divRound().

◆ HALF_DOWN

const HALF_DOWN = 6

Rounds towards "nearest neighbor" unless both neighbors are equidistant, in which case round down.

Behaves as for UP if the discarded fraction is > 0.5; otherwise, behaves as for DOWN.

Référencé par Calculator\divRound().

◆ HALF_EVEN

const HALF_EVEN = 9

Rounds towards the "nearest neighbor" unless both neighbors are equidistant, in which case rounds towards the even neighbor.

Behaves as for HALF_UP if the digit to the left of the discarded fraction is odd; behaves as for HALF_DOWN if it's even.

Note that this is the rounding mode that statistically minimizes cumulative error when applied repeatedly over a sequence of calculations. It is sometimes known as "Banker's rounding", and is chiefly used in the USA.

Référencé par Calculator\divRound().

◆ HALF_FLOOR

const HALF_FLOOR = 8

Rounds towards "nearest neighbor" unless both neighbors are equidistant, in which case round towards negative infinity.

If the result is positive, behaves as for HALF_DOWN; if negative, behaves as for HALF_UP.

Référencé par Calculator\divRound().

◆ HALF_UP

const HALF_UP = 5

Rounds towards "nearest neighbor" unless both neighbors are equidistant, in which case round up.

Behaves as for UP if the discarded fraction is >= 0.5; otherwise, behaves as for DOWN. Note that this is the rounding mode commonly taught at school.

Référencé par Calculator\divRound().

◆ UNNECESSARY

const UNNECESSARY = 0

Asserts that the requested operation has an exact result, hence no rounding is necessary.

If this rounding mode is specified on an operation that yields a result that cannot be represented at the requested scale, a RoundingNecessaryException is thrown.

Référencé par Calculator\divRound().

◆ UP

const UP = 1

Rounds away from zero.

Always increments the digit prior to a nonzero discarded fraction. Note that this rounding mode never decreases the magnitude of the calculated value.

Référencé par Calculator\divRound(), et BigInteger\shiftedRight().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RoundingMode.php


Joomla CMS: Référence de la classe BreakObject

  • CBOR
  • OtherObject
  • BreakObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe BreakObject
+ Graphe d'héritage de BreakObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • BreakObject.php


Joomla CMS: Référence de la classe DoublePrecisionFloatObject

  • CBOR
  • OtherObject
  • DoublePrecisionFloatObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe DoublePrecisionFloatObject
+ Graphe d'héritage de DoublePrecisionFloatObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
getExponent ()
getMantissa ()
getSign ()
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
static | create (string $value)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( string $value )
static
Renvoie
DoublePrecisionFloatObject

Références $value.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, et TagObject\$data.

◆ getExponent()

getExponent ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par DoublePrecisionFloatObject\getNormalizedData().

◆ getMantissa()

getMantissa ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par DoublePrecisionFloatObject\getNormalizedData().

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $val, elseif, DoublePrecisionFloatObject\getExponent(), DoublePrecisionFloatObject\getMantissa(), et DoublePrecisionFloatObject\getSign().

◆ getSign()

getSign ( )

Références TagObject\$data, Utils\binToBigInteger(), et BigInteger\one().

Référencé par DoublePrecisionFloatObject\getNormalizedData().

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • DoublePrecisionFloatObject.php


Joomla CMS: Référence de la classe FalseObject

  • CBOR
  • OtherObject
  • FalseObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe FalseObject
+ Graphe d'héritage de FalseObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • FalseObject.php


Joomla CMS: Référence de la classe GenericObject

  • CBOR
  • OtherObject
  • GenericObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe GenericObject
+ Graphe d'héritage de GenericObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, et TagObject\$data.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références TagObject\$data.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • GenericObject.php


Joomla CMS: Référence de la classe HalfPrecisionFloatObject

  • CBOR
  • OtherObject
  • HalfPrecisionFloatObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe HalfPrecisionFloatObject
+ Graphe d'héritage de HalfPrecisionFloatObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
getExponent ()
getMantissa ()
getSign ()
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
static | create (string $value)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( string $value )
static
Renvoie
HalfPrecisionFloatObject

Références $value.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, et TagObject\$data.

◆ getExponent()

getExponent ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par HalfPrecisionFloatObject\getNormalizedData().

◆ getMantissa()

getMantissa ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par HalfPrecisionFloatObject\getNormalizedData().

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $val, elseif, HalfPrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getMantissa(), et HalfPrecisionFloatObject\getSign().

◆ getSign()

getSign ( )

Références TagObject\$data, Utils\binToBigInteger(), et BigInteger\one().

Référencé par HalfPrecisionFloatObject\getNormalizedData().

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • HalfPrecisionFloatObject.php


Joomla CMS: Référence de la classe NullObject

  • CBOR
  • OtherObject
  • NullObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe NullObject
+ Graphe d'héritage de NullObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • spomky-labs/cbor-php/src/OtherObject/NullObject.php


Joomla CMS: Référence de la classe OtherObjectManager

  • CBOR
  • OtherObject
  • OtherObjectManager
Fonctions membres publiques | Attributs privés
Référence de la classe OtherObjectManager

Fonctions membres publiques

add (string $class)
getClassForValue (int $value)

Attributs privés

$classes = []

Documentation des fonctions membres

◆ add()

add ( string $class )

Références $class.

◆ getClassForValue()

getClassForValue ( int $value )

Références $value, et class.

Documentation des champs

◆ $classes

$classes = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OtherObjectManager.php


Joomla CMS: Référence de la classe SimpleObject

  • CBOR
  • OtherObject
  • SimpleObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe SimpleObject
+ Graphe d'héritage de SimpleObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
static | create (int $value)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( int $value )
static
Renvoie
SimpleObject

Références $value, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, et TagObject\$data.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références Utils\binToInt(), AbstractCBORObject\getAdditionalInformation(), et null.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • SimpleObject.php


Joomla CMS: Référence de la classe SinglePrecisionFloatObject

  • CBOR
  • OtherObject
  • SinglePrecisionFloatObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe SinglePrecisionFloatObject
+ Graphe d'héritage de SinglePrecisionFloatObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
getExponent ()
getMantissa ()
getSign ()
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
static | create (string $value)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( string $value )
static
Renvoie
SinglePrecisionFloatObject

Références $value.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, et TagObject\$data.

◆ getExponent()

getExponent ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par SinglePrecisionFloatObject\getNormalizedData().

◆ getMantissa()

getMantissa ( )

Références TagObject\$data, Utils\binToBigInteger(), et Utils\hexToBigInteger().

Référencé par SinglePrecisionFloatObject\getNormalizedData().

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $val, elseif, SinglePrecisionFloatObject\getExponent(), SinglePrecisionFloatObject\getMantissa(), et SinglePrecisionFloatObject\getSign().

◆ getSign()

getSign ( )

Références TagObject\$data, Utils\binToBigInteger(), et BigInteger\one().

Référencé par SinglePrecisionFloatObject\getNormalizedData().

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • SinglePrecisionFloatObject.php


Joomla CMS: Référence de la classe TrueObject

  • CBOR
  • OtherObject
  • TrueObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe TrueObject
+ Graphe d'héritage de TrueObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • TrueObject.php


Joomla CMS: Référence de la classe UndefinedObject

  • CBOR
  • OtherObject
  • UndefinedObject
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe UndefinedObject
+ Graphe d'héritage de UndefinedObject:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedObject.php


Joomla CMS: Référence de la classe Base16EncodingTag

  • CBOR
  • Tag
  • Base16EncodingTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Base16EncodingTag
+ Graphe d'héritage de Base16EncodingTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base16EncodingTag.php


Joomla CMS: Référence de la classe Base64EncodingTag

  • CBOR
  • Tag
  • Base64EncodingTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Base64EncodingTag
+ Graphe d'héritage de Base64EncodingTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64EncodingTag.php


Joomla CMS: Référence de la classe Base64UrlEncodingTag

  • CBOR
  • Tag
  • Base64UrlEncodingTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Base64UrlEncodingTag
+ Graphe d'héritage de Base64UrlEncodingTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références Base64Url\decode().

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64UrlEncodingTag.php


Joomla CMS: Référence de la classe BigFloatTag

  • CBOR
  • Tag
  • BigFloatTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe BigFloatTag
+ Graphe d'héritage de BigFloatTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (int $additionalInformation, ?string $data, CBORObject $object)
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
static | createFromExponentAndMantissa (CBORObject $e, CBORObject $m)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |

Références AbstractCBORObject\$additionalInformation, TagObject\$data, TagObject\$object, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromExponentAndMantissa()

static createFromExponentAndMantissa | ( | CBORObject | $e,
 |  | CBORObject | $m
 | ) |  |
static

Références TagObject\$object.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • BigFloatTag.php


Joomla CMS: Référence de la classe DecimalFractionTag

  • CBOR
  • Tag
  • DecimalFractionTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe DecimalFractionTag
+ Graphe d'héritage de DecimalFractionTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (CBORObject $object)
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | createFromExponentAndMantissa (CBORObject $e, CBORObject $m)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CBORObject $object )

Références TagObject\$object, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ createFromExponentAndMantissa()

static createFromExponentAndMantissa | ( | CBORObject | $e,
 |  | CBORObject | $m
 | ) |  |
static

Références TagObject\$object.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • DecimalFractionTag.php


Joomla CMS: Référence de la classe EpochTag

  • CBOR
  • Tag
  • EpochTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe EpochTag
+ Graphe d'héritage de EpochTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • EpochTag.php


Joomla CMS: Référence de la classe GenericTag

  • CBOR
  • Tag
  • GenericTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe GenericTag
+ Graphe d'héritage de GenericTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références TagObject\$object.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • GenericTag.php


Joomla CMS: Référence de la classe NegativeBigIntegerTag

  • CBOR
  • Tag
  • NegativeBigIntegerTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe NegativeBigIntegerTag
+ Graphe d'héritage de NegativeBigIntegerTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références BigInteger\fromBase(), et BigInteger\of().

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • NegativeBigIntegerTag.php


Joomla CMS: Référence de la classe PositiveBigIntegerTag

  • CBOR
  • Tag
  • PositiveBigIntegerTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe PositiveBigIntegerTag
+ Graphe d'héritage de PositiveBigIntegerTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références Utils\hexToString().

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • PositiveBigIntegerTag.php


Joomla CMS: Référence de la classe TagObjectManager

  • CBOR
  • Tag
  • TagObjectManager
Fonctions membres publiques | Attributs privés
Référence de la classe TagObjectManager

Fonctions membres publiques

add (string $class)
getClassForValue (int $value)

Attributs privés

$classes = []

Documentation des fonctions membres

◆ add()

add ( string $class )

Références $class.

◆ getClassForValue()

getClassForValue ( int $value )

Références $value, et class.

Documentation des champs

◆ $classes

$classes = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagObjectManager.php


Joomla CMS: Référence de la classe TimestampTag

  • CBOR
  • Tag
  • TimestampTag
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe TimestampTag
+ Graphe d'héritage de TimestampTag:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)
static | create (CBORObject $object)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Membres hérités additionnels

- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des fonctions membres

◆ create()

static create ( CBORObject $object )
static

Références TagObject\$object, et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
static

Références AbstractCBORObject\$additionalInformation, TagObject\$data, et TagObject\$object.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

◆ getTagId()

static getTagId ( )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • TimestampTag.php


Joomla CMS: Référence de la classe AbstractCBORObject

  • CBOR
  • AbstractCBORObject
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe AbstractCBORObject
+ Graphe d'héritage de AbstractCBORObject:
CBORObject ByteStringObject ByteStringWithChunkObject InfiniteListObject InfiniteMapObject ListObject MapObject OtherObject SignedIntegerObject TagObject TextStringObject TextStringWithChunkObject UnsignedIntegerObject

Fonctions membres publiques

__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()
- Fonctions membres publiques hérités de CBORObject
getNormalizedData (bool $ignoreTags=false)

Attributs protégés

$additionalInformation

Attributs privés

$majorType

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $majorType,
 |  | int | $additionalInformation
 | ) |  |

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

◆ getAdditionalInformation()

getAdditionalInformation ( )

Implémente CBORObject.

Référencé par SimpleObject\getNormalizedData().

◆ getMajorType()

getMajorType ( )

Implémente CBORObject.

Documentation des champs

◆ $additionalInformation

$additionalInformation
protected

Référencé par BigFloatTag\__construct(), GenericObject\createFromLoadedData(), GenericTag\createFromLoadedData(), EpochTag\createFromLoadedData(), SimpleObject\createFromLoadedData(), NegativeBigIntegerTag\createFromLoadedData(), SinglePrecisionFloatObject\createFromLoadedData(), HalfPrecisionFloatObject\createFromLoadedData(), PositiveBigIntegerTag\createFromLoadedData(), DoublePrecisionFloatObject\createFromLoadedData(), Base16EncodingTag\createFromLoadedData(), Base64EncodingTag\createFromLoadedData(), Base64UrlEncodingTag\createFromLoadedData(), TimestampTag\createFromLoadedData(), et BigFloatTag\createFromLoadedData().

◆ $majorType

$majorType
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractCBORObject.php


Joomla CMS: Référence de la classe ByteStringObject

  • CBOR
  • ByteStringObject
Fonctions membres publiques | Attributs privés
Référence de la classe ByteStringObject
+ Graphe d'héritage de ByteStringObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (string $data)
__toString ()
getValue ()
getLength ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const MAJOR_TYPE = 0b010
$value
$length

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $data )

Références $data, Symfony\Contracts\Service\__construct(), et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, $value, Joomla\Database\Query\__toString(), et null.

◆ getLength()

getLength ( )

Références value.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $value.

◆ getValue()

getValue ( )

Références $value.

Documentation des champs

◆ $length

$length
private

◆ $value

$value
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b010
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ByteStringObject.php


Joomla CMS: Référence de la classe ByteStringWithChunkObject

  • CBOR
  • ByteStringWithChunkObject
Fonctions membres publiques | Attributs privés
Référence de la classe ByteStringWithChunkObject
+ Graphe d'héritage de ByteStringWithChunkObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
__toString ()
add (ByteStringObject $chunk)
append (string $chunk)
getValue ()
getLength ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const | MAJOR_TYPE = 0b010
const | ADDITIONAL_INFORMATION = 0b00011111
$chunks = []

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, et Joomla\Database\Query\__toString().

◆ add()

add ( ByteStringObject $chunk )

◆ append()

append ( string $chunk )

◆ getLength()

getLength ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result.

◆ getValue()

getValue ( )

Références $result.

Documentation des champs

◆ $chunks

$chunks = []
private

◆ ADDITIONAL_INFORMATION

const ADDITIONAL_INFORMATION = 0b00011111
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b010
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ByteStringWithChunkObject.php


Joomla CMS: Référence de l'interface CBORObject

  • CBOR
  • CBORObject
Fonctions membres publiques
Référence de l'interface CBORObject
+ Graphe d'héritage de CBORObject:
AbstractCBORObject ByteStringObject ByteStringWithChunkObject InfiniteListObject InfiniteMapObject ListObject MapObject OtherObject SignedIntegerObject TagObject TextStringObject TextStringWithChunkObject UnsignedIntegerObject

Fonctions membres publiques

__toString ()
getMajorType ()
getAdditionalInformation ()
getNormalizedData (bool $ignoreTags=false)

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémenté dans Integer, Integer, ListObject, MapObject, ByteStringObject, TextStringObject, InfiniteListObject, InfiniteMapObject, TagObject, AbstractCBORObject, SignedIntegerObject, UnsignedIntegerObject, ByteStringWithChunkObject, TextStringWithChunkObject, et OtherObject.

◆ getAdditionalInformation()

getAdditionalInformation ( )

Implémenté dans UnsignedIntegerObject, et AbstractCBORObject.

◆ getMajorType()

getMajorType ( )

Implémenté dans UnsignedIntegerObject, et AbstractCBORObject.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémenté dans UnsignedIntegerObject, SignedIntegerObject, MapObject, ListObject, ByteStringWithChunkObject, TextStringWithChunkObject, BigFloatTag, InfiniteMapObject, DecimalFractionTag, ByteStringObject, TextStringObject, InfiniteListObject, TimestampTag, DoublePrecisionFloatObject, HalfPrecisionFloatObject, SinglePrecisionFloatObject, Base64UrlEncodingTag, Base16EncodingTag, Base64EncodingTag, NegativeBigIntegerTag, PositiveBigIntegerTag, EpochTag, BreakObject, FalseObject, NullObject, TrueObject, UndefinedObject, SimpleObject, GenericTag, et GenericObject.

Référencé par AuthenticationExtensionsClientOutputsLoader\load().

La documentation de cette interface a été générée à partir du fichier suivant :
  • CBORObject.php


Joomla CMS: Référence de la classe Decoder

  • CBOR
  • Decoder
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Decoder

Fonctions membres publiques

__construct (TagObjectManager $tagObjectManager, OtherObjectManager $otherTypeManager)
decode (Stream $stream)

Fonctions membres privées

process (Stream $stream, bool $breakable=false)
processFinite (Stream $stream, int $mt, int $ai, ?string $val)
processInfinite (Stream $stream, int $mt, bool $breakable)

Attributs privés

$tagObjectManager
$otherTypeManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | TagObjectManager | $tagObjectManager,
 |  | OtherObjectManager | $otherTypeManager
 | ) |  |

Documentation des fonctions membres

◆ decode()

decode ( Stream $stream )

Références Laminas\Diactoros\$stream.

◆ process()

process | ( | Stream | $stream,
 |  | bool | $breakable = false
 | ) |  |
private

Références Laminas\Diactoros\$stream, $val, et null.

◆ processFinite()

processFinite | ( | Stream | $stream,
 |  | int | $mt,
 |  | int | $ai,
 |  | ?string | $val
 | ) |  |
private

Références $i, Laminas\Diactoros\$stream, $val, et null.

◆ processInfinite()

processInfinite | ( | Stream | $stream,
 |  | int | $mt,
 |  | bool | $breakable
 | ) |  |
private

Références Laminas\Diactoros\$stream.

Documentation des champs

◆ $otherTypeManager

$otherTypeManager
private

◆ $tagObjectManager

$tagObjectManager
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • spomky-labs/cbor-php/src/Decoder.php


Joomla CMS: Référence de la classe InfiniteListObject

  • CBOR
  • InfiniteListObject
Fonctions membres publiques | Attributs privés
Référence de la classe InfiniteListObject
+ Graphe d'héritage de InfiniteListObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
__toString ()
getNormalizedData (bool $ignoreTags=false)
add (CBORObject $item)
count ()
getIterator ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const | MAJOR_TYPE = 0b100
const | ADDITIONAL_INFORMATION = 0b00011111
$data = []

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, et Joomla\Database\Query\__toString().

◆ add()

add ( CBORObject $item )

Références $item.

◆ count()

count ( )

◆ getIterator()

getIterator ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $data, et $item.

Documentation des champs

◆ $data

$data = []
private

◆ ADDITIONAL_INFORMATION

const ADDITIONAL_INFORMATION = 0b00011111
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b100
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • InfiniteListObject.php


Joomla CMS: Référence de la classe InfiniteMapObject

  • CBOR
  • InfiniteMapObject
Fonctions membres publiques | Attributs privés
Référence de la classe InfiniteMapObject
+ Graphe d'héritage de InfiniteMapObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
__toString ()
append (CBORObject $key, CBORObject $value)
count ()
getIterator ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const | MAJOR_TYPE = 0b101
const | ADDITIONAL_INFORMATION = 0b00011111
$data = []

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, et Joomla\Database\Query\__toString().

◆ append()

append | ( | CBORObject | $key,
 |  | CBORObject | $value
 | ) |  |

Références $key, et $value.

◆ count()

count ( )

◆ getIterator()

getIterator ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result.

Documentation des champs

◆ $data

$data = []
private

◆ ADDITIONAL_INFORMATION

const ADDITIONAL_INFORMATION = 0b00011111
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b101
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • InfiniteMapObject.php


Joomla CMS: Référence de la classe LengthCalculator

  • CBOR
  • LengthCalculator
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe LengthCalculator

Fonctions membres publiques statiques

static | getLengthOfString (string $data)
static | getLengthOfArray (array $data)

Fonctions membres privées statiques

static | computeLength (int $length)
static | hex2bin (string $data)
static | fixHexLength (string $data)

Documentation des fonctions membres

◆ computeLength()

static computeLength ( int $length )
staticprivate

Références null.

◆ fixHexLength()

static fixHexLength ( string $data )
staticprivate

Références $data.

◆ getLengthOfArray()

static getLengthOfArray ( array $data )
static

Références $data.

◆ getLengthOfString()

static getLengthOfString ( string $data )
static

Références $data.

◆ hex2bin()

static hex2bin ( string $data )
staticprivate

Références $data, et $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LengthCalculator.php


Joomla CMS: Référence de la classe ListObject

  • CBOR
  • ListObject
Fonctions membres publiques | Attributs privés
Référence de la classe ListObject
+ Graphe d'héritage de ListObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (array $data=[])
__toString ()
add (CBORObject $object)
get (int $index)
getNormalizedData (bool $ignoreTags=false)
count ()
getIterator ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const MAJOR_TYPE = 0b100
$data = []
$length

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data = [] )
Paramètres
CBORObject[] $data

Références $data, $item, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, Joomla\Database\Query\__toString(), et null.

◆ add()

add ( CBORObject $object )

◆ count()

count ( )

◆ get()

get ( int $index )

◆ getIterator()

getIterator ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $data, et $item.

Documentation des champs

◆ $data

$data = []
private

◆ $length

$length
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b100
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ListObject.php


Joomla CMS: Référence de la classe MapItem

  • CBOR
  • MapItem
Fonctions membres publiques | Attributs privés
Référence de la classe MapItem

Fonctions membres publiques

__construct (CBORObject $key, CBORObject $value)
getKey ()
getValue ()

Attributs privés

$key
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CBORObject | $key,
 |  | CBORObject | $value
 | ) |  |

Références $key, $value, et value.

Documentation des fonctions membres

◆ getKey()

getKey ( )

Références $key.

◆ getValue()

getValue ( )

Références $value.

Documentation des champs

◆ $key

$key
private

◆ $value

$value
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MapItem.php


Joomla CMS: Référence de la classe MapObject

  • CBOR
  • MapObject
Fonctions membres publiques | Attributs privés
Référence de la classe MapObject
+ Graphe d'héritage de MapObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (array $data=[])
__toString ()
add (CBORObject $key, CBORObject $value)
count ()
getIterator ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const MAJOR_TYPE = 0b101
$data = []
$length

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data = [] )
Paramètres
MapItem[] $data

Références $data, $item, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, Joomla\Database\Query\__toString(), et null.

◆ add()

add | ( | CBORObject | $key,
 |  | CBORObject | $value
 | ) |  |

Références $key, et $value.

◆ count()

count ( )

◆ getIterator()

getIterator ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result.

Documentation des champs

◆ $data

$data = []
private

◆ $length

$length
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b101
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MapObject.php


Joomla CMS: Référence de la classe OtherObject

  • CBOR
  • OtherObject
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe OtherObject
+ Graphe d'héritage de OtherObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (int $additionalInformation, ?string $data)
__toString ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()
- Fonctions membres publiques hérités de CBORObject
getNormalizedData (bool $ignoreTags=false)

Fonctions membres publiques statiques

static | supportedAdditionalInformation ()
static | createFromLoadedData (int $additionalInformation, ?string $data)

Attributs protégés

$data
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Attributs privés

const MAJOR_TYPE = 0b111

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |

Références $data, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $data, $result, Joomla\Database\Query\__toString(), et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
staticabstract

◆ supportedAdditionalInformation()

static supportedAdditionalInformation ( )
staticabstract
Renvoie
int[]

Documentation des champs

◆ $data

$data
protected

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b111
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OtherObject.php


Joomla CMS: Référence de la classe SignedIntegerObject

  • CBOR
  • SignedIntegerObject
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe SignedIntegerObject
+ Graphe d'héritage de SignedIntegerObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (int $additionalInformation, ?string $data)
__toString ()
getValue ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | createObjectForValue (int $additionalInformation, ?string $data)
static | create (int $value)
static | createFromString (string $value)
static | createFromGmpValue (GMP $value)

Fonctions membres privées statiques

static | createBigInteger (BigInteger $integer)
static | hex2bin (string $data)

Attributs privés

const MAJOR_TYPE = 0b001
$data

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |

Références $data, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $data, $result, Joomla\Database\Query\__toString(), et null.

◆ create()

static create ( int $value )
static

Références $value.

◆ createBigInteger()

static createBigInteger ( BigInteger $integer )
staticprivate

Références $data, BigNumber\isGreaterThanOrEqualTo(), et null.

◆ createFromGmpValue()

static createFromGmpValue ( GMP $value )
static
Obsolète:
Deprecated since v1.1 and will be removed in v2.0. Please use "create" or "createFromString" instead

Références $data, $value, et null.

◆ createFromString()

static createFromString ( string $value )
static

Références $value.

◆ createObjectForValue()

static createObjectForValue | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références $data.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result, et null.

◆ getValue()

getValue ( )

◆ hex2bin()

static hex2bin ( string $data )
staticprivate

Références $data, et $result.

Documentation des champs

◆ $data

$data
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b001
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SignedIntegerObject.php


Joomla CMS: Référence de l'interface Stream

  • CBOR
  • Stream
Fonctions membres publiques
Référence de l'interface Stream
+ Graphe d'héritage de Stream:
StringStream StringStream

Fonctions membres publiques

read (int $length)

Documentation des fonctions membres

◆ read()

read ( int $length )

Implémenté dans StringStream, et StringStream.

La documentation de cette interface a été générée à partir du fichier suivant :
  • vendor/spomky-labs/cbor-php/src/Stream.php


Joomla CMS: Référence de la classe StringStream

  • CBOR
  • StringStream
Fonctions membres publiques | Attributs privés
Référence de la classe StringStream
+ Graphe d'héritage de StringStream:
Stream

Fonctions membres publiques

__construct (string $data)
read (int $length)

Attributs privés

$resource

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $data )

Références $data, et $result.

Documentation des fonctions membres

◆ read()

read ( int $length )

Implémente Stream.

Références $data.

Documentation des champs

◆ $resource

$resource
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • spomky-labs/cbor-php/src/StringStream.php


Joomla CMS: Référence de la classe TagObject

  • CBOR
  • TagObject
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe TagObject
+ Graphe d'héritage de TagObject:
AbstractCBORObject CBORObject BreakObject DoublePrecisionFloatObject FalseObject GenericObject HalfPrecisionFloatObject NullObject SimpleObject SinglePrecisionFloatObject TrueObject UndefinedObject Base16EncodingTag Base64EncodingTag Base64UrlEncodingTag BigFloatTag DecimalFractionTag EpochTag GenericTag NegativeBigIntegerTag PositiveBigIntegerTag TimestampTag Integer Integer

Fonctions membres publiques

__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()
- Fonctions membres publiques hérités de CBORObject
getNormalizedData (bool $ignoreTags=false)

Fonctions membres publiques statiques

static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Attributs protégés

$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Attributs privés

const MAJOR_TYPE = 0b110

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |

Références $data, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $data, $result, Joomla\Database\Query\__toString(), et null.

◆ createFromLoadedData()

static createFromLoadedData | ( | int | $additionalInformation,
 |  | ?string | $data,
 |  | CBORObject | $object
 | ) |  |
staticabstract

◆ getTagId()

static getTagId ( )
staticabstract

◆ getValue()

getValue ( )

Documentation des champs

◆ $data

$data
protected

Référencé par BigFloatTag\__construct(), GenericObject\createFromLoadedData(), GenericTag\createFromLoadedData(), EpochTag\createFromLoadedData(), SimpleObject\createFromLoadedData(), NegativeBigIntegerTag\createFromLoadedData(), PositiveBigIntegerTag\createFromLoadedData(), SinglePrecisionFloatObject\createFromLoadedData(), DoublePrecisionFloatObject\createFromLoadedData(), HalfPrecisionFloatObject\createFromLoadedData(), Base64EncodingTag\createFromLoadedData(), Base16EncodingTag\createFromLoadedData(), Base64UrlEncodingTag\createFromLoadedData(), TimestampTag\createFromLoadedData(), BigFloatTag\createFromLoadedData(), SinglePrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getExponent(), DoublePrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getMantissa(), DoublePrecisionFloatObject\getMantissa(), SinglePrecisionFloatObject\getMantissa(), GenericObject\getNormalizedData(), HalfPrecisionFloatObject\getSign(), SinglePrecisionFloatObject\getSign(), et DoublePrecisionFloatObject\getSign().

◆ $object

$object
protected

Référencé par BigFloatTag\__construct(), DecimalFractionTag\__construct(), EpochTag\create(), NegativeBigIntegerTag\create(), PositiveBigIntegerTag\create(), Base64EncodingTag\create(), Base16EncodingTag\create(), Base64UrlEncodingTag\create(), TimestampTag\create(), BigFloatTag\create(), DecimalFractionTag\createFromExponentAndMantissa(), BigFloatTag\createFromExponentAndMantissa(), GenericTag\createFromLoadedData(), EpochTag\createFromLoadedData(), NegativeBigIntegerTag\createFromLoadedData(), PositiveBigIntegerTag\createFromLoadedData(), Base64EncodingTag\createFromLoadedData(), Base16EncodingTag\createFromLoadedData(), Base64UrlEncodingTag\createFromLoadedData(), TimestampTag\createFromLoadedData(), BigFloatTag\createFromLoadedData(), DecimalFractionTag\createFromLoadedData(), et GenericTag\getNormalizedData().

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b110
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagObject.php


Joomla CMS: Référence de la classe TextStringObject

  • CBOR
  • TextStringObject
Fonctions membres publiques | Attributs privés
Référence de la classe TextStringObject
+ Graphe d'héritage de TextStringObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (string $data)
__toString ()
getValue ()
getLength ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const MAJOR_TYPE = 0b011
$length
$data

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $data )

Références $data, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $data, $result, Joomla\Database\Query\__toString(), et null.

◆ getLength()

getLength ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $data.

◆ getValue()

getValue ( )

Références $data.

Documentation des champs

◆ $data

$data
private

◆ $length

$length
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b011
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TextStringObject.php


Joomla CMS: Référence de la classe TextStringWithChunkObject

  • CBOR
  • TextStringWithChunkObject
Fonctions membres publiques | Attributs privés
Référence de la classe TextStringWithChunkObject
+ Graphe d'héritage de TextStringWithChunkObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ()
__toString ()
add (TextStringObject $chunk)
append (string $chunk)
getValue ()
getLength ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Attributs privés

const | MAJOR_TYPE = 0b011
const | ADDITIONAL_INFORMATION = 0b00011111
$data = []

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $result, et Joomla\Database\Query\__toString().

◆ add()

add ( TextStringObject $chunk )

◆ append()

append ( string $chunk )

◆ getLength()

getLength ( )

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références $result.

◆ getValue()

getValue ( )

Références $result.

Documentation des champs

◆ $data

$data = []
private

◆ ADDITIONAL_INFORMATION

const ADDITIONAL_INFORMATION = 0b00011111
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b011
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TextStringWithChunkObject.php


Joomla CMS: Référence de la classe UnsignedIntegerObject

  • CBOR
  • UnsignedIntegerObject
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe UnsignedIntegerObject
+ Graphe d'héritage de UnsignedIntegerObject:
AbstractCBORObject CBORObject

Fonctions membres publiques

__construct (int $additionalInformation, ?string $data)
__toString ()
getMajorType ()
getAdditionalInformation ()
getValue ()
getNormalizedData (bool $ignoreTags=false)
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()

Fonctions membres publiques statiques

static | createObjectForValue (int $additionalInformation, ?string $data)
static | create (int $value)
static | createFromHex (string $value)
static | createFromString (string $value)
static | createFromGmpValue (GMP $value)

Fonctions membres privées statiques

static | createBigInteger (BigInteger $integer)
static | hex2bin (string $data)

Attributs privés

const MAJOR_TYPE = 0b000
$data

Membres hérités additionnels

- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |

Références $data, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Implémente CBORObject.

Références $data, $result, Joomla\Database\Query\__toString(), et null.

◆ create()

static create ( int $value )
static

Références $value.

◆ createBigInteger()

static createBigInteger ( BigInteger $integer )
staticprivate

Références $data, BigNumber\isLessThan(), null, BigInteger\toBase(), et BigInteger\toInt().

◆ createFromGmpValue()

static createFromGmpValue ( GMP $value )
static
Obsolète:
Deprecated since v1.1 and will be removed in v2.0. Please use "create" or "createFromString" instead

Références $data, $value, et null.

◆ createFromHex()

static createFromHex ( string $value )
static

Références $value.

◆ createFromString()

static createFromString ( string $value )
static

Références $value.

◆ createObjectForValue()

static createObjectForValue | ( | int | $additionalInformation,
 |  | ?string | $data
 | ) |  |
static

Références $data.

◆ getAdditionalInformation()

getAdditionalInformation ( )

Implémente CBORObject.

◆ getMajorType()

getMajorType ( )

Implémente CBORObject.

◆ getNormalizedData()

getNormalizedData ( bool $ignoreTags = false )
Renvoie
mixed|null

Implémente CBORObject.

Références null.

◆ getValue()

getValue ( )

◆ hex2bin()

static hex2bin ( string $data )
staticprivate

Références $data, et $result.

Documentation des champs

◆ $data

$data
private

◆ MAJOR_TYPE

const MAJOR_TYPE = 0b000
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsignedIntegerObject.php


Joomla CMS: Référence de la classe Utils

  • CBOR
  • Utils
Fonctions membres publiques statiques
Référence de la classe Utils

Fonctions membres publiques statiques

static | binToInt (string $value)
static | binToBigInteger (string $value)
static | hexToInt (string $value)
static | hexToBigInteger (string $value)
static | hexToString (string $value)
static | intToHex (int $value)

Documentation des fonctions membres

◆ binToBigInteger()

static binToBigInteger ( string $value )
static

Références $value.

Référencé par DoublePrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getExponent(), SinglePrecisionFloatObject\getExponent(), DoublePrecisionFloatObject\getMantissa(), SinglePrecisionFloatObject\getMantissa(), HalfPrecisionFloatObject\getMantissa(), DoublePrecisionFloatObject\getSign(), SinglePrecisionFloatObject\getSign(), et HalfPrecisionFloatObject\getSign().

◆ binToInt()

static binToInt ( string $value )
static

Références $value.

Référencé par SimpleObject\getNormalizedData().

◆ hexToBigInteger()

static hexToBigInteger ( string $value )
static

Références $value.

Référencé par DoublePrecisionFloatObject\getExponent(), SinglePrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getExponent(), HalfPrecisionFloatObject\getMantissa(), DoublePrecisionFloatObject\getMantissa(), et SinglePrecisionFloatObject\getMantissa().

◆ hexToInt()

static hexToInt ( string $value )
static

Références $value.

◆ hexToString()

static hexToString ( string $value )
static

Références $value.

Référencé par PositiveBigIntegerTag\getNormalizedData().

◆ intToHex()

static intToHex ( int $value )
static

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Utils.php


Joomla CMS: Référence de la classe ClassLoader

  • Composer
  • Autoload
  • ClassLoader
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe ClassLoader

Fonctions membres publiques

__construct ($vendorDir=null)
getPrefixes ()
getPrefixesPsr4 ()
getFallbackDirs ()
getFallbackDirsPsr4 ()
getClassMap ()
addClassMap (array $classMap)
add ($prefix, $paths, $prepend=false)
addPsr4 ($prefix, $paths, $prepend=false)
set ($prefix, $paths)
setPsr4 ($prefix, $paths)
setUseIncludePath ($useIncludePath)
getUseIncludePath ()
setClassMapAuthoritative ($classMapAuthoritative)
isClassMapAuthoritative ()
setApcuPrefix ($apcuPrefix)
getApcuPrefix ()
register ($prepend=false)
unregister ()
loadClass ($class)
findFile ($class)

Fonctions membres publiques statiques

static getRegisteredLoaders ()

Fonctions membres privées

findFileWithExtension ($class, $ext)

Attributs privés

$vendorDir
$prefixLengthsPsr4 = array()
$prefixDirsPsr4 = array()
$fallbackDirsPsr4 = array()
$prefixesPsr0 = array()
$fallbackDirsPsr0 = array()
$useIncludePath = false
$classMap = array()
$classMapAuthoritative = false
$missingClasses = array()
$apcuPrefix

Attributs privés statiques

static $registeredLoaders = array()

Description détaillée

ClassLoader implements a PSR-0, PSR-4 and classmap class loader.

$loader = new \Composer\Autoload\ClassLoader();

// register classes with namespaces
$loader->add('Symfony\Component', __DIR__.'/component');
$loader->add('Symfony',           __DIR__.'/framework');

// activate the autoloader
$loader->register();

// to enable searching the include path (eg. for PEAR packages)
$loader->setUseIncludePath(true);

In this example, if you try to use a class in the Symfony namespace or one of its children (Symfony for instance), the autoloader will first look for the class under the component/ directory, and it will then fallback to the framework/ directory if not found before giving up.

This class is loosely based on the Symfony UniversalClassLoader.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Jordi Boggiano j.bog.nosp@m.gian.nosp@m.o@sel.nosp@m.d.be
Voir également
https://www.php-fig.org/psr/psr-0/
https://www.php-fig.org/psr/psr-4/

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $vendorDir = null )
Paramètres
?string $vendorDir

Références ClassLoader\$vendorDir.

Documentation des fonctions membres

◆ add()

add | ( | $prefix,
 |  | $paths,
 |  | $prepend = false
 | ) |

Registers a set of PSR-0 directories for a given prefix, either appending or prepending to the ones previously set for this prefix.

Paramètres
string | $prefix | The prefix
string[]|string | $paths The PSR-0 root directories
bool | $prepend | Whether to prepend the directories
Renvoie
void

Références $prefix.

◆ addClassMap()

addClassMap ( array $classMap )
Paramètres
string[] $classMap Class to filename map -param array<string, string> $classMap
Renvoie
void

Références ClassLoader\$classMap.

◆ addPsr4()

addPsr4 | ( | $prefix,
 |  | $paths,
 |  | $prepend = false
 | ) |

Registers a set of PSR-4 directories for a given namespace, either appending or prepending to the ones previously set for this namespace.

Paramètres
string | $prefix | The prefix/namespace, with trailing '\'
string[]|string | $paths The PSR-4 base directories
bool | $prepend | Whether to prepend the directories
Exceptions

Références $prefix, et elseif.

◆ findFile()

findFile ( $class )

Finds the path to the file where the class is defined.

Paramètres
string $class The name of the class
Renvoie
string|false The path if found, false otherwise

Références $class, ClassLoader\findFileWithExtension(), et null.

Référencé par ClassLoader\loadClass().

◆ findFileWithExtension()

findFileWithExtension | ( | $class,
 |  | $ext
 | ) |
private
Paramètres
string | $class
string | $ext
Renvoie
string|false

Références $class, $dir, et $prefix.

Référencé par ClassLoader\findFile().

◆ getApcuPrefix()

getApcuPrefix ( )

The APCu prefix in use, or null if APCu caching is not enabled.

Renvoie
string|null

Références ClassLoader\$apcuPrefix.

◆ getClassMap()

getClassMap ( )
Renvoie
string[] Array of classname => path -return array<string, string>

Références ClassLoader\$classMap.

◆ getFallbackDirs()

getFallbackDirs ( )
Renvoie
array[] -return array<string, string>

Références ClassLoader\$fallbackDirsPsr0.

◆ getFallbackDirsPsr4()

getFallbackDirsPsr4 ( )
Renvoie
array[] -return array<string, string>

Références ClassLoader\$fallbackDirsPsr4.

◆ getPrefixes()

getPrefixes ( )
Renvoie
string[]

◆ getPrefixesPsr4()

getPrefixesPsr4 ( )
Renvoie
array[] -return array<string, array<int, string>>

Références ClassLoader\$prefixDirsPsr4.

◆ getRegisteredLoaders()

static getRegisteredLoaders ( )
static

Returns the currently registered loaders indexed by their corresponding vendor directories.

Renvoie
self[]

◆ getUseIncludePath()

getUseIncludePath ( )

Can be used to check if the autoloader uses the include path to check for classes.

Renvoie
bool

Références ClassLoader\$useIncludePath.

◆ isClassMapAuthoritative()

isClassMapAuthoritative ( )

Should class lookup fail if not found in the current class map?

Renvoie
bool

Références ClassLoader\$classMapAuthoritative.

◆ loadClass()

loadClass ( $class )

Loads the given class or interface.

Paramètres
string $class The name of the class
Renvoie
true|null True if loaded, null otherwise

Références $class, ClassLoader\findFile(), Composer\Autoload\includeFile(), et null.

Référencé par Autoloader\createPrependAutoloader().

◆ register()

register ( $prepend = false )

Registers this instance as an autoloader.

Paramètres
bool $prepend Whether to prepend the autoloader or not
Renvoie
void

Références $this, ClassLoader\$vendorDir, et null.

◆ set()

set | ( | $prefix,
 |  | $paths
 | ) |

Registers a set of PSR-0 directories for a given prefix, replacing any others previously set for this prefix.

Paramètres
string | $prefix | The prefix
string[]|string | $paths The PSR-0 base directories
Renvoie
void

Références $prefix.

◆ setApcuPrefix()

setApcuPrefix ( $apcuPrefix )

APCu prefix to use to cache found/not-found classes, if the extension is enabled.

Paramètres
string | null $apcuPrefix
Renvoie
void

Références ClassLoader\$apcuPrefix, et null.

◆ setClassMapAuthoritative()

setClassMapAuthoritative ( $classMapAuthoritative )

Turns off searching the prefix and fallback directories for classes that have not been registered with the class map.

Paramètres
bool $classMapAuthoritative
Renvoie
void

Références ClassLoader\$classMapAuthoritative.

◆ setPsr4()

setPsr4 | ( | $prefix,
 |  | $paths
 | ) |

Registers a set of PSR-4 directories for a given namespace, replacing any others previously set for this namespace.

Paramètres
string | $prefix | The prefix/namespace, with trailing '\'
string[]|string | $paths The PSR-4 base directories
Exceptions

Références $prefix.

◆ setUseIncludePath()

setUseIncludePath ( $useIncludePath )

Turns on searching the include path for class files.

Paramètres
bool $useIncludePath
Renvoie
void

Références ClassLoader\$useIncludePath.

◆ unregister()

unregister ( )

Unregisters this instance as an autoloader.

Renvoie
void

Références $this, et null.

Documentation des champs

◆ $apcuPrefix

$apcuPrefix
private

Référencé par ClassLoader\getApcuPrefix(), et ClassLoader\setApcuPrefix().

◆ $classMap

$classMap = array()
private

Référencé par ClassLoader\addClassMap(), et ClassLoader\getClassMap().

◆ $classMapAuthoritative

$classMapAuthoritative = false
private

Référencé par ClassLoader\isClassMapAuthoritative(), et ClassLoader\setClassMapAuthoritative().

◆ $fallbackDirsPsr0

$fallbackDirsPsr0 = array()
private

Référencé par ClassLoader\getFallbackDirs().

◆ $fallbackDirsPsr4

$fallbackDirsPsr4 = array()
private

Référencé par ClassLoader\getFallbackDirsPsr4().

◆ $missingClasses

$missingClasses = array()
private

◆ $prefixDirsPsr4

$prefixDirsPsr4 = array()
private

Référencé par ClassLoader\getPrefixesPsr4().

◆ $prefixesPsr0

$prefixesPsr0 = array()
private

◆ $prefixLengthsPsr4

$prefixLengthsPsr4 = array()
private

◆ $registeredLoaders

$registeredLoaders = array()
staticprivate

◆ $useIncludePath

$useIncludePath = false
private

Référencé par ClassLoader\getUseIncludePath(), et ClassLoader\setUseIncludePath().

◆ $vendorDir

$vendorDir
private

Référencé par ClassLoader\__construct(), et ClassLoader\register().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/composer/ClassLoader.php


Joomla CMS: Référence de la classe ComposerStaticInit2399d40fc48ada3450e844df0430bf2f

  • Composer
  • Autoload
  • ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe ComposerStaticInit2399d40fc48ada3450e844df0430bf2f

Fonctions membres publiques statiques

static getInitializer (ClassLoader $loader)

Attributs publics statiques

static | $files
static | $prefixLengthsPsr4
static | $prefixDirsPsr4
static | $classMap

Documentation des fonctions membres

◆ getInitializer()

static getInitializer ( ClassLoader $loader )
static

Références ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\$classMap, $loader, ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\$prefixDirsPsr4, ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\$prefixLengthsPsr4, class, et null.

Documentation des champs

◆ $classMap

$classMap
static

Référencé par ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer().

◆ $files

$files
static

Référencé par ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\getLoader().

◆ $prefixDirsPsr4

$prefixDirsPsr4
static

Référencé par ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer().

◆ $prefixLengthsPsr4

$prefixLengthsPsr4
static

Référencé par ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer().

La documentation de cette classe a été générée à partir du fichier suivant :
  • autoload_static.php


Joomla CMS: Référence de la classe CaBundle

  • Composer
  • CaBundle
  • CaBundle
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe CaBundle

Fonctions membres publiques statiques

static | getSystemCaRootBundlePath (LoggerInterface $logger=null)
static | getBundledCaBundlePath ()
static | validateCaFile ($filename, LoggerInterface $logger=null)
static | isOpensslParseSafe ()
static | reset ()

Fonctions membres privées statiques

static | getEnvVariable ($name)
static | caFileUsable ($certFile, LoggerInterface $logger=null)
static | caDirUsable ($certDir, LoggerInterface $logger=null)
static | isFile ($certFile, LoggerInterface $logger=null)
static | isDir ($certDir, LoggerInterface $logger=null)
static | isReadable ($certFileOrDir, LoggerInterface $logger=null)
static | glob ($pattern, LoggerInterface $logger=null)

Attributs privés statiques

static | $caPath
static | $caFileValidity = array()
static | $useOpensslParse

Description détaillée

Auteur
Chris Smith chris.nosp@m.@cs2.nosp@m.78.or.nosp@m.g
Jordi Boggiano j.bog.nosp@m.gian.nosp@m.o@sel.nosp@m.d.be

Documentation des fonctions membres

◆ caDirUsable()

static caDirUsable | ( |  | $certDir,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | false | $certDir
LoggerInterface | null | $logger
Renvoie
bool

◆ caFileUsable()

static caFileUsable | ( |  | $certFile,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | false | $certFile
LoggerInterface | null | $logger
Renvoie
bool

◆ getBundledCaBundlePath()

static getBundledCaBundlePath ( )
static

Returns the path to the bundled CA file

In case you don't want to trust the user or the system, you can use this directly

Renvoie
string path to a CA bundle file

Références __DIR__.

Référencé par CurlTransport\request(), et StreamTransport\request().

◆ getEnvVariable()

static getEnvVariable ( $name )
staticprivate
Paramètres
string $name
Renvoie
string|false

Références $name, $value, et null.

◆ getSystemCaRootBundlePath()

static getSystemCaRootBundlePath ( LoggerInterface $logger = null )
static

Returns the system CA bundle path, or a path to the bundled one

This method was adapted from Sslurp. https://github.com/EvanDotPro/Sslurp

(c) Evan Coury me@ev.nosp@m.anco.nosp@m.ury.c.nosp@m.om

For the full copyright and license information, please see below:

Copyright (c) 2013, Evan Coury All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice,
  this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice,
  this list of conditions and the following disclaimer in the documentation
  and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Paramètres
LoggerInterface $logger optional logger for information about which CA files were loaded
Renvoie
string path to a CA bundle file or directory

Références $location, et null.

Référencé par Curl\request(), Stream\request(), et Curl\setCAOptionAndValue().

◆ glob()

static glob | ( |  | $pattern,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | $pattern
LoggerInterface | null | $logger
Renvoie
bool

◆ isDir()

static isDir | ( |  | $certDir,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | $certDir
LoggerInterface | null | $logger
Renvoie
bool

◆ isFile()

static isFile | ( |  | $certFile,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | $certFile
LoggerInterface | null | $logger
Renvoie
bool

◆ isOpensslParseSafe()

static isOpensslParseSafe ( )
static

Test if it is safe to use the PHP function openssl_x509_parse().

This checks if OpenSSL extensions is vulnerable to remote code execution via the exploit documented as CVE-2013-6420.

Renvoie
bool

Références $info, $output, $prefix, $script, et null.

◆ isReadable()

static isReadable | ( |  | $certFileOrDir,
 |  | LoggerInterface | $logger = null
 | ) |  |
staticprivate
Paramètres
string | $certFileOrDir
LoggerInterface | null | $logger
Renvoie
bool

◆ reset()

static reset ( )
static

Resets the static caches

Renvoie
void

Références null.

◆ validateCaFile()

static validateCaFile | ( |  | $filename,
 |  | LoggerInterface | $logger = null
 | ) |  |
static

Validates a CA file using opensl_x509_parse only if it is safe to use

Paramètres
string | $filename
LoggerInterface | $logger | optional logger for information about which CA files were loaded
Renvoie
bool

Références elseif, et null.

Documentation des champs

◆ $caFileValidity

$caFileValidity = array()
staticprivate

◆ $caPath

$caPath
staticprivate

◆ $useOpensslParse

$useOpensslParse
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • CaBundle.php


Joomla CMS: Référence de la classe InstalledVersions

  • Composer
  • InstalledVersions
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe InstalledVersions

Fonctions membres publiques statiques

static | getInstalledPackages ()
static | getInstalledPackagesByType ($type)
static | isInstalled ($packageName, $includeDevRequirements=true)
static | satisfies (VersionParser $parser, $packageName, $constraint)
static | getVersionRanges ($packageName)
static | getVersion ($packageName)
static | getPrettyVersion ($packageName)
static | getReference ($packageName)
static | getInstallPath ($packageName)
static | getRootPackage ()
static | getRawData ()
static | getAllRawData ()
static | reload ($data)

Fonctions membres privées statiques

static getInstalled ()

Attributs privés statiques

static | $installed
static | $canGetVendors
static | $installedByVendor = array()

Description détaillée

This class is copied in every Composer installed project and available to all

See also https://getcomposer.org/doc/07-runtime.md#installed-versions

To require its presence, you can require composer-runtime-api ^2.0

Documentation des fonctions membres

◆ getAllRawData()

static getAllRawData ( )
static

Returns the raw data of all installed.php which are currently loaded for custom implementations

Renvoie
array[] -return list<array{root: array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}, versions: array<string, array{pretty_version?: string, version?: string, reference?: string|null, type?: string, install_path?: string, aliases?: string[], dev_requirement: bool, replaced?: string[], provided?: string[]}>}>

◆ getInstalled()

static getInstalled ( )
staticprivate
Renvoie
array[] -return list<array{root: array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}, versions: array<string, array{pretty_version?: string, version?: string, reference?: string|null, type?: string, install_path?: string, aliases?: string[], dev_requirement: bool, replaced?: string[], provided?: string[]}>}>

Références $loader, $vendorDir, __DIR__, elseif, et null.

◆ getInstalledPackages()

static getInstalledPackages ( )
static

Returns a list of all package names which are present, either by being installed, replaced or provided

Renvoie
string[] -return list<string>

◆ getInstalledPackagesByType()

static getInstalledPackagesByType ( $type )
static

Returns a list of all package names with a specific type e.g. 'library'

Paramètres
string $type
Renvoie
string[] -return list<string>

Références $name, et $type.

◆ getInstallPath()

static getInstallPath ( $packageName )
static
Paramètres
string $packageName
Renvoie
string|null If the package is being replaced or provided but is not really installed, null will be returned as install path. Packages of type metapackages also have a null install path.

Références null.

◆ getPrettyVersion()

static getPrettyVersion ( $packageName )
static
Paramètres
string $packageName
Renvoie
string|null If the package is being replaced or provided but is not really installed, null will be returned as version, use satisfies or getVersionRanges if you need to know if a given version is present

Références null.

◆ getRawData()

static getRawData ( )
static

Returns the raw installed.php data for custom implementations

Obsolète:
Use getAllRawData() instead which returns all datasets for all autoloaders present in the process. getRawData only returns the first dataset loaded, which may not be what you expect.
Renvoie
array[] -return array{root: array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}, versions: array<string, array{pretty_version?: string, version?: string, reference?: string|null, type?: string, install_path?: string, aliases?: string[], dev_requirement: bool, replaced?: string[], provided?: string[]}>}

Références __DIR__, et null.

◆ getReference()

static getReference ( $packageName )
static
Paramètres
string $packageName
Renvoie
string|null If the package is being replaced or provided but is not really installed, null will be returned as reference

Références null.

◆ getRootPackage()

static getRootPackage ( )
static
Renvoie
array -return array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}

Référencé par DebugClassLoader\checkAnnotations().

◆ getVersion()

static getVersion ( $packageName )
static
Paramètres
string $packageName
Renvoie
string|null If the package is being replaced or provided but is not really installed, null will be returned as version, use satisfies or getVersionRanges if you need to know if a given version is present

Références null.

◆ getVersionRanges()

static getVersionRanges ( $packageName )
static

Returns a version constraint representing all the range(s) which are installed for a given package

It is easier to use this via isInstalled() with the $constraint argument if you need to check whether a given version of a package is installed, and not just whether it exists

Paramètres
string $packageName
Renvoie
string Version constraint usable with composer/semver

◆ isInstalled()

static isInstalled | ( | $packageName,
 |  | $includeDevRequirements = true
 | ) |
static

Checks whether the given package is installed

This also returns true if the package name is provided or replaced by another package

Paramètres
string | $packageName
bool | $includeDevRequirements
Renvoie
bool

◆ reload()

static reload ( $data )
static

Lets you reload the static array from another file

This is only useful for complex integrations in which a project needs to use this class but then also needs to execute another project's autoloader in process, and wants to ensure both projects have access to their version of installed.php.

A typical case would be PHPUnit, where it would need to make sure it reads all the data it needs from this class, then call reload() with require $CWD/vendor/composer/installed.php (or similar) as input to make sure the project in which it runs can then also use this class safely, without interference between PHPUnit's dependencies and the project's dependencies.

Paramètres
array[] $data A vendor/composer/installed.php data set
Renvoie
void

-param array{root: array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}, versions: array<string, array{pretty_version?: string, version?: string, reference?: string|null, type?: string, install_path?: string, aliases?: string[], dev_requirement: bool, replaced?: string[], provided?: string[]}>} $data

Références $data.

◆ satisfies()

static satisfies | ( | VersionParser | $parser,
 |  |  | $packageName,
 |  |  | $constraint
 | ) |  |
static

Checks whether the given package satisfies a version constraint

e.g. If you want to know whether version 2.3+ of package foo/bar is installed, you would call:

Composer::satisfies(new VersionParser, 'foo/bar', '^2.3')

Paramètres
VersionParser | $parser | Install composer/semver to have access to this class and functionality
string | $packageName
string | null | $constraint | A version constraint to check for, if you pass one you have to make sure composer/semver is required by your package
Renvoie
bool

Documentation des champs

◆ $canGetVendors

$canGetVendors
staticprivate

◆ $installed

$installed
staticprivate

◆ $installedByVendor

$installedByVendor = array()
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstalledVersions.php


Joomla CMS: Référence de la classe Hmac

  • Cose
  • Algorithm
  • Mac
  • Hmac
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe Hmac
+ Graphe d'héritage de Hmac:
Mac Algorithm HS256 HS256Truncated64 HS384 HS512

Fonctions membres publiques

hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres protégées

getHashAlgorithm ()
getSignatureLength ()

Fonctions membres privées

checKey (Key $key)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des fonctions membres

◆ checKey()

checKey ( Key $key )
private

Références $key, Assertion\eq(), et Assertion\true().

Référencé par Hmac\hash().

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par Hmac\hash().

◆ getSignatureLength()

getSignatureLength ( )
abstractprotected

Référencé par Hmac\hash().

◆ hash()

hash | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Mac.

Références $key, Hmac\checKey(), Hmac\getHashAlgorithm(), et Hmac\getSignatureLength().

Référencé par Hmac\verify().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Mac.

Références $key, et Hmac\hash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Mac/Hmac.php


Joomla CMS: Référence de la classe HS256

  • Cose
  • Algorithm
  • Mac
  • HS256
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe HS256
+ Graphe d'héritage de HS256:
Hmac Mac Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = 5

Fonctions membres protégées

getHashAlgorithm ()
getSignatureLength ()
- Fonctions membres protégées hérités de Hmac
getHashAlgorithm ()
getSignatureLength ()

Membres hérités additionnels

- Fonctions membres publiques hérités de Hmac
hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignatureLength()

getSignatureLength ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = 5
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Mac/HS256.php


Joomla CMS: Référence de la classe HS256Truncated64

  • Cose
  • Algorithm
  • Mac
  • HS256Truncated64
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe HS256Truncated64
+ Graphe d'héritage de HS256Truncated64:
Hmac Mac Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = 4

Fonctions membres protégées

getHashAlgorithm ()
getSignatureLength ()
- Fonctions membres protégées hérités de Hmac
getHashAlgorithm ()
getSignatureLength ()

Membres hérités additionnels

- Fonctions membres publiques hérités de Hmac
hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignatureLength()

getSignatureLength ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = 4
La documentation de cette classe a été générée à partir du fichier suivant :
  • HS256Truncated64.php


Joomla CMS: Référence de la classe HS384

  • Cose
  • Algorithm
  • Mac
  • HS384
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe HS384
+ Graphe d'héritage de HS384:
Hmac Mac Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = 6

Fonctions membres protégées

getHashAlgorithm ()
getSignatureLength ()
- Fonctions membres protégées hérités de Hmac
getHashAlgorithm ()
getSignatureLength ()

Membres hérités additionnels

- Fonctions membres publiques hérités de Hmac
hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignatureLength()

getSignatureLength ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = 6
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Mac/HS384.php


Joomla CMS: Référence de la classe HS512

  • Cose
  • Algorithm
  • Mac
  • HS512
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe HS512
+ Graphe d'héritage de HS512:
Hmac Mac Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = 7

Fonctions membres protégées

getHashAlgorithm ()
getSignatureLength ()
- Fonctions membres protégées hérités de Hmac
getHashAlgorithm ()
getSignatureLength ()

Membres hérités additionnels

- Fonctions membres publiques hérités de Hmac
hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignatureLength()

getSignatureLength ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = 7
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Mac/HS512.php


Joomla CMS: Référence de l'interface Mac

  • Cose
  • Algorithm
  • Mac
  • Mac
Fonctions membres publiques
Référence de l'interface Mac
+ Graphe d'héritage de Mac:
Algorithm Hmac HS256 HS256Truncated64 HS384 HS512

Fonctions membres publiques

hash (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des fonctions membres

◆ hash()

hash | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémenté dans Hmac.

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémenté dans Hmac.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Mac.php


Joomla CMS: Référence de la classe ECDSA

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ECDSA
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ECDSA
+ Graphe d'héritage de ECDSA:
Signature Algorithm ES256 ES256K ES384 ES512

Fonctions membres publiques

__construct ()
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres protégées

getCurve ()
getHashAlgorithm ()

Fonctions membres privées

handleKey (Key $key)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références $this.

Documentation des fonctions membres

◆ getCurve()

getCurve ( )
abstractprotected

Référencé par ECDSA\handleKey().

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par ECDSA\sign(), et ECDSA\verify().

◆ handleKey()

handleKey ( Key $key )
private

Références $key, Assertion\eq(), et ECDSA\getCurve().

Référencé par ECDSA\sign(), et ECDSA\verify().

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, $result, ECDSA\getHashAlgorithm(), ECDSA\handleKey(), et Assertion\true().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, ECDSA\getHashAlgorithm(), et ECDSA\handleKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECDSA.php


Joomla CMS: Référence de la classe ECSignature

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ECSignature
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe ECSignature

Fonctions membres publiques statiques

static | toAsn1 (string $signature, int $length)
static | fromAsn1 (string $signature, int $length)

Fonctions membres privées statiques

static | octetLength (string $data)
static | preparePositiveInteger (string $data)
static | readAsn1Content (string $message, int &$position, int $length)
static | readAsn1Integer (string $message, int &$position)
static | retrievePositiveInteger (string $data)
static | hex2bin (string $data)

Attributs privés

const | ASN1_SEQUENCE = '30'
const | ASN1_INTEGER = '02'
const | ASN1_MAX_SINGLE_BYTE = 128
const | ASN1_LENGTH_2BYTES = '81'
const | ASN1_BIG_INTEGER_LIMIT = '7f'
const | ASN1_NEGATIVE_INTEGER = '00'
const | BYTE_SIZE = 2

Documentation des fonctions membres

◆ fromAsn1()

static fromAsn1 | ( | string | $signature,
 |  | int | $length
 | ) |  |
static

Références $message, et $position.

Référencé par ES256\sign(), ES512\sign(), ES384\sign(), et ES256K\sign().

◆ hex2bin()

static hex2bin ( string $data )
staticprivate

Références $data, et $result.

◆ octetLength()

static octetLength ( string $data )
staticprivate

Références $data.

◆ preparePositiveInteger()

static preparePositiveInteger ( string $data )
staticprivate

Références $data, et null.

◆ readAsn1Content()

static readAsn1Content | ( | string | $message,
 |  | int & | $position,
 |  | int | $length
 | ) |  |
staticprivate

Références $content, $message, et $position.

◆ readAsn1Integer()

static readAsn1Integer | ( | string | $message,
 |  | int & | $position
 | ) |  |
staticprivate

Références $message, et $position.

◆ retrievePositiveInteger()

static retrievePositiveInteger ( string $data )
staticprivate

Références $data, et null.

◆ toAsn1()

static toAsn1 | ( | string | $signature,
 |  | int | $length
 | ) |  |
static

Références null.

Référencé par ES256\verify(), ES512\verify(), ES384\verify(), et ES256K\verify().

Documentation des champs

◆ ASN1_BIG_INTEGER_LIMIT

const ASN1_BIG_INTEGER_LIMIT = '7f'
private

◆ ASN1_INTEGER

const ASN1_INTEGER = '02'
private

◆ ASN1_LENGTH_2BYTES

const ASN1_LENGTH_2BYTES = '81'
private

◆ ASN1_MAX_SINGLE_BYTE

const ASN1_MAX_SINGLE_BYTE = 128
private

◆ ASN1_NEGATIVE_INTEGER

const ASN1_NEGATIVE_INTEGER = '00'
private

◆ ASN1_SEQUENCE

const ASN1_SEQUENCE = '30'
private

◆ BYTE_SIZE

const BYTE_SIZE = 2
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECSignature.php


Joomla CMS: Référence de la classe ES256

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ES256
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe ES256
+ Graphe d'héritage de ES256:
ECDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de ECDSA
__construct ()
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -7

Fonctions membres protégées

getHashAlgorithm ()
getCurve ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getCurve ()
getHashAlgorithm ()

Documentation des fonctions membres

◆ getCurve()

getCurve ( )
protected

Références Ec2Key\CURVE_P256.

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

Référencé par ES256\sign(), et ES256\verify().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, ECSignature\fromAsn1(), et ES256\getSignaturePartLength().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, ES256\getSignaturePartLength(), et ECSignature\toAsn1().

Documentation des champs

◆ ID

const ID = -7
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256.php


Joomla CMS: Référence de la classe ES256K

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ES256K
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe ES256K
+ Graphe d'héritage de ES256K:
ECDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de ECDSA
__construct ()
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -43

Fonctions membres protégées

getHashAlgorithm ()
getCurve ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getCurve ()
getHashAlgorithm ()

Documentation des fonctions membres

◆ getCurve()

getCurve ( )
protected

Références Ec2Key\CURVE_P256K.

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

Référencé par ES256K\sign(), et ES256K\verify().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, ECSignature\fromAsn1(), et ES256K\getSignaturePartLength().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, ES256K\getSignaturePartLength(), et ECSignature\toAsn1().

Documentation des champs

◆ ID

const ID = -43
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256K.php


Joomla CMS: Référence de la classe ES384

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ES384
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe ES384
+ Graphe d'héritage de ES384:
ECDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de ECDSA
__construct ()
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -35

Fonctions membres protégées

getHashAlgorithm ()
getCurve ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getCurve ()
getHashAlgorithm ()

Documentation des fonctions membres

◆ getCurve()

getCurve ( )
protected

Références Ec2Key\CURVE_P384.

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

Référencé par ES384\sign(), et ES384\verify().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, ECSignature\fromAsn1(), et ES384\getSignaturePartLength().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, ES384\getSignaturePartLength(), et ECSignature\toAsn1().

Documentation des champs

◆ ID

const ID = -35
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES384.php


Joomla CMS: Référence de la classe ES512

  • Cose
  • Algorithm
  • Signature
  • ECDSA
  • ES512
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe ES512
+ Graphe d'héritage de ES512:
ECDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de ECDSA
__construct ()
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -36

Fonctions membres protégées

getHashAlgorithm ()
getCurve ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getCurve ()
getHashAlgorithm ()

Documentation des fonctions membres

◆ getCurve()

getCurve ( )
protected

Références Ec2Key\CURVE_P521.

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

Référencé par ES512\sign(), et ES512\verify().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, ECSignature\fromAsn1(), et ES512\getSignaturePartLength().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, ES512\getSignaturePartLength(), et ECSignature\toAsn1().

Documentation des champs

◆ ID

const ID = -36
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES512.php


Joomla CMS: Référence de la classe Ed25519

  • Cose
  • Algorithm
  • Signature
  • EdDSA
  • Ed25519
Fonctions membres publiques statiques | Champs de données
Référence de la classe Ed25519
+ Graphe d'héritage de Ed25519:
EdDSA Signature Algorithm

Fonctions membres publiques statiques

static | identifier ()
- Fonctions membres publiques statiques hérités de EdDSA
static | identifier ()

Champs de données

const ID = -8

Membres hérités additionnels

- Fonctions membres publiques hérités de EdDSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -8
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/EdDSA/Ed25519.php


Joomla CMS: Référence de la classe ED256

  • Cose
  • Algorithm
  • Signature
  • EdDSA
  • ED256
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe ED256
+ Graphe d'héritage de ED256:
EdDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de EdDSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static | identifier ()
- Fonctions membres publiques statiques hérités de EdDSA
static | identifier ()

Champs de données

const ID = -260

Documentation des fonctions membres

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, et $key.

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, et $key.

Documentation des champs

◆ ID

const ID = -260
La documentation de cette classe a été générée à partir du fichier suivant :
  • ED256.php


Joomla CMS: Référence de la classe ED512

  • Cose
  • Algorithm
  • Signature
  • EdDSA
  • ED512
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe ED512
+ Graphe d'héritage de ED512:
EdDSA Signature Algorithm

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
- Fonctions membres publiques hérités de EdDSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static | identifier ()
- Fonctions membres publiques statiques hérités de EdDSA
static | identifier ()

Champs de données

const ID = -261

Documentation des fonctions membres

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, et $key.

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, et $key.

Documentation des champs

◆ ID

const ID = -261
La documentation de cette classe a été générée à partir du fichier suivant :
  • ED512.php


Joomla CMS: Référence de la classe EdDSA

  • Cose
  • Algorithm
  • Signature
  • EdDSA
  • EdDSA
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées
Référence de la classe EdDSA
+ Graphe d'héritage de EdDSA:
Signature Algorithm Ed25519 ED256 ED512

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres publiques statiques

static identifier ()

Fonctions membres privées

handleKey (Key $key)

Documentation des fonctions membres

◆ handleKey()

handleKey ( Key $key )
private

Références $key.

Référencé par EdDSA\sign(), et EdDSA\verify().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Références Algorithms\COSE_ALGORITHM_EdDSA.

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, OkpKey\CURVE_ED25519, EdDSA\handleKey(), et Assertion\true().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, OkpKey\CURVE_ED25519, et EdDSA\handleKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/EdDSA/EdDSA.php


Joomla CMS: Référence de la classe PS256

  • Cose
  • Algorithm
  • Signature
  • RSA
  • PS256
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe PS256
+ Graphe d'héritage de PS256:
PSSRSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -37

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de PSSRSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de PSSRSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
exponentiate (RsaKey $key, BigInteger $c)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

Références Hash\sha256().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -37
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/PS256.php


Joomla CMS: Référence de la classe PS384

  • Cose
  • Algorithm
  • Signature
  • RSA
  • PS384
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe PS384
+ Graphe d'héritage de PS384:
PSSRSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -38

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de PSSRSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de PSSRSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
exponentiate (RsaKey $key, BigInteger $c)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

Références Hash\sha384().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -38
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/PS384.php


Joomla CMS: Référence de la classe PS512

  • Cose
  • Algorithm
  • Signature
  • RSA
  • PS512
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe PS512
+ Graphe d'héritage de PS512:
PSSRSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -39

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de PSSRSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de PSSRSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
exponentiate (RsaKey $key, BigInteger $c)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

Références Hash\sha512().

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -39
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/PS512.php


Joomla CMS: Référence de la classe PSSRSA

  • Cose
  • Algorithm
  • Signature
  • RSA
  • PSSRSA
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe PSSRSA
+ Graphe d'héritage de PSSRSA:
Signature Algorithm PS256 PS384 PS512

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)
exponentiate (RsaKey $key, BigInteger $c)

Fonctions membres protégées

getHashAlgorithm ()

Fonctions membres privées

handleKey (Key $key)
convertIntegerToOctetString (BigInteger $x, int $xLen)
getMGF1 (string $mgfSeed, int $maskLen, Hash $mgfHash)
encodeEMSAPSS (string $message, int $modulusLength, Hash $hash)
verifyEMSAPSS (string $m, string $em, int $emBits, Hash $hash)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des fonctions membres

◆ convertIntegerToOctetString()

convertIntegerToOctetString | ( | BigInteger | $x,
 |  | int | $xLen
 | ) |  |
private

Références BigInteger\toBytes().

Référencé par PSSRSA\sign(), et PSSRSA\verify().

◆ encodeEMSAPSS()

encodeEMSAPSS | ( | string | $message,
 |  | int | $modulusLength,
 |  | Hash | $hash
 | ) |  |
private

EMSA-PSS-ENCODE.

Références $db, $hash, $message, et PSSRSA\getMGF1().

Référencé par PSSRSA\sign().

◆ exponentiate()

exponentiate | ( | RsaKey | $key,
 |  | BigInteger | $c
 | ) |  |

Exponentiate with or without Chinese Remainder Theorem. Operation with primes 'p' and 'q' is appox. 2x faster.

Références $c, $key, BigInteger\createFromBinaryString(), et BigInteger\createFromDecimal().

Référencé par PSSRSA\sign(), et PSSRSA\verify().

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par PSSRSA\sign(), et PSSRSA\verify().

◆ getMGF1()

getMGF1 | ( | string | $mgfSeed,
 |  | int | $maskLen,
 |  | Hash | $mgfHash
 | ) |  |
private

MGF1.

Références $c, $count, $i, Hash\getLength(), et Hash\hash().

Référencé par PSSRSA\encodeEMSAPSS(), et PSSRSA\verifyEMSAPSS().

◆ handleKey()

handleKey ( Key $key )
private

Références $key.

Référencé par PSSRSA\sign(), et PSSRSA\verify().

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $key, $message, PSSRSA\convertIntegerToOctetString(), BigInteger\createFromBinaryString(), PSSRSA\encodeEMSAPSS(), PSSRSA\exponentiate(), PSSRSA\getHashAlgorithm(), et PSSRSA\handleKey().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $key, PSSRSA\convertIntegerToOctetString(), BigInteger\createFromBinaryString(), PSSRSA\exponentiate(), PSSRSA\getHashAlgorithm(), PSSRSA\handleKey(), et PSSRSA\verifyEMSAPSS().

◆ verifyEMSAPSS()

verifyEMSAPSS | ( | string | $m,
 |  | string | $em,
 |  | int | $emBits,
 |  | Hash | $hash
 | ) |  |
private

EMSA-PSS-VERIFY.

Références $db, $hash, $temp, PSSRSA\getMGF1(), et null.

Référencé par PSSRSA\verify().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PSSRSA.php


Joomla CMS: Référence de la classe RS1

  • Cose
  • Algorithm
  • Signature
  • RSA
  • RS1
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe RS1
+ Graphe d'héritage de RS1:
RSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -65535

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de RSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de RSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -65535
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/RS1.php


Joomla CMS: Référence de la classe RS256

  • Cose
  • Algorithm
  • Signature
  • RSA
  • RS256
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe RS256
+ Graphe d'héritage de RS256:
RSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -257

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de RSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de RSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -257
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/RS256.php


Joomla CMS: Référence de la classe RS384

  • Cose
  • Algorithm
  • Signature
  • RSA
  • RS384
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe RS384
+ Graphe d'héritage de RS384:
RSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -258

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de RSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de RSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -258
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/RS384.php


Joomla CMS: Référence de la classe RS512

  • Cose
  • Algorithm
  • Signature
  • RSA
  • RS512
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe RS512
+ Graphe d'héritage de RS512:
RSA Signature Algorithm

Fonctions membres publiques statiques

static identifier ()

Champs de données

const ID = -259

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de RSA
getHashAlgorithm ()

Membres hérités additionnels

- Fonctions membres publiques hérités de RSA
sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ identifier()

static identifier ( )
static

Implémente Algorithm.

Documentation des champs

◆ ID

const ID = -259
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/RS512.php


Joomla CMS: Référence de la classe RSA

  • Cose
  • Algorithm
  • Signature
  • RSA
  • RSA
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RSA
+ Graphe d'héritage de RSA:
Signature Algorithm RS1 RS256 RS384 RS512

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Fonctions membres protégées

getHashAlgorithm ()

Fonctions membres privées

handleKey (Key $key)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par RSA\sign(), et RSA\verify().

◆ handleKey()

handleKey ( Key $key )
private

Références $key.

Référencé par RSA\sign(), et RSA\verify().

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémente Signature.

Références $data, $key, $result, RSA\getHashAlgorithm(), RSA\handleKey(), et Assertion\true().

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémente Signature.

Références $data, $key, RSA\getHashAlgorithm(), et RSA\handleKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/RSA/RSA.php


Joomla CMS: Référence de l'interface Signature

  • Cose
  • Algorithm
  • Signature
  • Signature
Fonctions membres publiques
Référence de l'interface Signature
+ Graphe d'héritage de Signature:
Algorithm ECDSA EdDSA PSSRSA RSA ES256 ES256K ES384 ES512 Ed25519 ED256 ED512 PS256 PS384 PS512 RS1 RS256 RS384 RS512

Fonctions membres publiques

sign (string $data, Key $key)
verify (string $data, Key $key, string $signature)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Algorithm
static identifier ()

Documentation des fonctions membres

◆ sign()

sign | ( | string | $data,
 |  | Key | $key
 | ) |  |

Implémenté dans PSSRSA, ECDSA, ES256, ES256K, ES384, ES512, ED256, ED512, EdDSA, et RSA.

◆ verify()

verify | ( | string | $data,
 |  | Key | $key,
 |  | string | $signature
 | ) |  |

Implémenté dans PSSRSA, EdDSA, ECDSA, ES256, ES256K, ES384, ES512, ED256, ED512, et RSA.

La documentation de cette interface a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Signature/Signature.php


Joomla CMS: Référence de l'interface Algorithm

  • Cose
  • Algorithm
  • Algorithm
Fonctions membres publiques statiques
Référence de l'interface Algorithm
+ Graphe d'héritage de Algorithm:
Mac Signature Hmac ECDSA EdDSA PSSRSA RSA HS256 HS256Truncated64 HS384 HS512 ES256 ES256K ES384 ES512 Ed25519 ED256 ED512 PS256 PS384 PS512 RS1 RS256 RS384 RS512

Fonctions membres publiques statiques

static identifier ()

Documentation des fonctions membres

◆ identifier()

static identifier ( )
static

Implémenté dans EdDSA, ES256, ES256K, ES384, ES512, ED256, ED512, PS256, PS384, PS512, HS256, HS256Truncated64, HS384, HS512, Ed25519, RS1, RS256, RS384, et RS512.

La documentation de cette interface a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Algorithm.php


Joomla CMS: Référence de la classe Manager

  • Cose
  • Algorithm
  • Manager
Fonctions membres publiques | Attributs privés
Référence de la classe Manager

Fonctions membres publiques

add (Algorithm $algorithm)
getAlgorithms ()
list ()
all ()
has (int $identifier)
get (int $identifier)

Attributs privés

$algorithms = []

Documentation des fonctions membres

◆ add()

add ( Algorithm $algorithm )

◆ all()

all ( )
Renvoie
Algorithm[]

Références Manager\$algorithms.

◆ get()

get ( int $identifier )

Références Manager\has(), et Assertion\true().

◆ getAlgorithms()

getAlgorithms ( )
Obsolète:
Will be removed in v3.0. Please use all() instead

Références Manager\$algorithms.

◆ has()

has ( int $identifier )

Référencé par Manager\get().

◆ list()

list ( )

Documentation des champs

◆ $algorithms

$algorithms = []
private

Référencé par Manager\all(), et Manager\getAlgorithms().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Algorithm/Manager.php


Joomla CMS: Référence de la classe ManagerFactory

  • Cose
  • Algorithm
  • ManagerFactory
Fonctions membres publiques | Attributs privés
Référence de la classe ManagerFactory

Fonctions membres publiques

add (string $alias, Algorithm $algorithm)
list ()
all ()
create (array $aliases)

Attributs privés

$algorithms = []

Documentation des fonctions membres

◆ add()

add | ( | string | $alias,
 |  | Algorithm | $algorithm
 | ) |  |

◆ all()

all ( )

◆ create()

create ( array $aliases )

Références Assertion\keyExists().

◆ list()

list ( )

Documentation des champs

◆ $algorithms

$algorithms = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ManagerFactory.php


Joomla CMS: Référence de la classe Ec2Key

  • Cose
  • Key
  • Ec2Key
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Ec2Key
+ Graphe d'héritage de Ec2Key:
Key

Fonctions membres publiques

__construct (array $data)
toPublic ()
x ()
y ()
isPrivate ()
d ()
curve ()
asPEM ()
getUncompressedCoordinates ()
- Fonctions membres publiques hérités de Key
__construct (array $data)
type ()
alg ()
getData ()
has (int $key)
get (int $key)

Champs de données

const | CURVE_P256 = 1
const | CURVE_P256K = 8
const | CURVE_P384 = 2
const | CURVE_P521 = 3
const | DATA_CURVE = -1
const | DATA_X = -2
const | DATA_Y = -3
const | DATA_D = -4
- Champs de données hérités de Key
const | TYPE = 1
const | TYPE_OKP = 1
const | TYPE_EC2 = 2
const | TYPE_RSA = 3
const | TYPE_OCT = 4
const | KID = 2
const | ALG = 3
const | KEY_OPS = 4
const | BASE_IV = 5

Fonctions membres privées

getCurveOid ()
pem (string $type, string $der)

Attributs privés

const | SUPPORTED_CURVES
const | NAMED_CURVE_OID
const | CURVE_KEY_LENGTH

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Key
static createFromData (array $data)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )

Références Key\$data, Symfony\Contracts\Service\__construct(), Assertion\eq(), Assertion\inArray(), Assertion\keyExists(), Assertion\length(), et null.

Documentation des fonctions membres

◆ asPEM()

asPEM ( )

Références Ec2Key\d(), Ec2Key\getCurveOid(), Ec2Key\getUncompressedCoordinates(), Ec2Key\isPrivate(), et Ec2Key\pem().

◆ curve()

curve ( )

Référencé par Ec2Key\getCurveOid().

◆ d()

d ( )

Références Ec2Key\isPrivate(), et Assertion\true().

Référencé par Ec2Key\asPEM().

◆ getCurveOid()

getCurveOid ( )
private

Références Ec2Key\curve().

Référencé par Ec2Key\asPEM().

◆ getUncompressedCoordinates()

getUncompressedCoordinates ( )

Référencé par Ec2Key\asPEM().

◆ isPrivate()

isPrivate ( )

Références Key\getData().

Référencé par Ec2Key\asPEM(), et Ec2Key\d().

◆ pem()

pem | ( | string | $type,
 |  | string | $der
 | ) |  |
private

Références $type.

Référencé par Ec2Key\asPEM().

◆ toPublic()

toPublic ( )

Références Key\$data, et Key\getData().

◆ x()

x ( )

Référencé par TPMAttestationStatementSupport\checkUniquePublicKey().

◆ y()

y ( )

Documentation des champs

◆ CURVE_KEY_LENGTH

const CURVE_KEY_LENGTH
private
Valeur initiale :
= [
self::CURVE_P256 => 32

◆ CURVE_P256

const CURVE_P256 = 1

Référencé par FidoU2FAttestationStatementSupport\extractPublicKey(), et ES256\getCurve().

◆ CURVE_P256K

const CURVE_P256K = 8

Référencé par ES256K\getCurve().

◆ CURVE_P384

const CURVE_P384 = 2

Référencé par ES384\getCurve().

◆ CURVE_P521

const CURVE_P521 = 3

Référencé par ES512\getCurve().

◆ DATA_CURVE

const DATA_CURVE = -1

Référencé par FidoU2FAttestationStatementSupport\extractPublicKey().

◆ DATA_D

const DATA_D = -4

◆ DATA_X

const DATA_X = -2

◆ DATA_Y

const DATA_Y = -3

◆ NAMED_CURVE_OID

const NAMED_CURVE_OID
private
Valeur initiale :
= [
self::CURVE_P256 => '1.2.840.10045.3.1.7'

◆ SUPPORTED_CURVES

const SUPPORTED_CURVES
private
Valeur initiale :
= [
self::CURVE_P256,
self::CURVE_P256K,
self::CURVE_P384,
self::CURVE_P521,
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • Ec2Key.php


Joomla CMS: Référence de la classe Key

  • Cose
  • Key
  • Key
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe Key
+ Graphe d'héritage de Key:
Ec2Key OkpKey RsaKey SymmetricKey

Fonctions membres publiques

__construct (array $data)
type ()
alg ()
getData ()
has (int $key)
get (int $key)

Fonctions membres publiques statiques

static createFromData (array $data)

Champs de données

const | TYPE = 1
const | TYPE_OKP = 1
const | TYPE_EC2 = 2
const | TYPE_RSA = 3
const | TYPE_OCT = 4
const | KID = 2
const | ALG = 3
const | KEY_OPS = 4
const | BASE_IV = 5

Attributs privés

$data

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )

Références Key\$data, et Assertion\keyExists().

Documentation des fonctions membres

◆ alg()

alg ( )

◆ createFromData()

static createFromData ( array $data )
static

Références Key\$data, et Assertion\keyExists().

Référencé par AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey().

◆ get()

get ( int $key )
Renvoie
mixed

Références $key, et Assertion\keyExists().

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getData()

getData ( )

Références Key\$data.

Référencé par OkpKey\isPrivate(), Ec2Key\isPrivate(), RsaKey\isPrivate(), et Ec2Key\toPublic().

◆ has()

has ( int $key )

Références $key.

Référencé par RsaKey\hasCoefficient(), RsaKey\hasExponents(), et RsaKey\hasPrimes().

◆ type()

type ( )
Renvoie
int|string

Documentation des champs

◆ $data

$data
private

Référencé par SymmetricKey\__construct(), Key\__construct(), OkpKey\__construct(), RsaKey\__construct(), Ec2Key\__construct(), Key\createFromData(), Key\getData(), et Ec2Key\toPublic().

◆ ALG

const ALG = 3

◆ BASE_IV

const BASE_IV = 5

◆ KEY_OPS

const KEY_OPS = 4

◆ KID

const KID = 2

◆ TYPE

const TYPE = 1

Référencé par FidoU2FAttestationStatementSupport\extractPublicKey().

◆ TYPE_EC2

const TYPE_EC2 = 2

Référencé par TPMAttestationStatementSupport\checkUniquePublicKey().

◆ TYPE_OCT

const TYPE_OCT = 4

◆ TYPE_OKP

const TYPE_OKP = 1

Référencé par TPMAttestationStatementSupport\checkUniquePublicKey().

◆ TYPE_RSA

const TYPE_RSA = 3

Référencé par TPMAttestationStatementSupport\checkUniquePublicKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Key/Key.php


Joomla CMS: Référence de la classe OkpKey

  • Cose
  • Key
  • OkpKey
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe OkpKey
+ Graphe d'héritage de OkpKey:
Key

Fonctions membres publiques

__construct (array $data)
x ()
isPrivate ()
d ()
curve ()
- Fonctions membres publiques hérités de Key
__construct (array $data)
type ()
alg ()
getData ()
has (int $key)
get (int $key)

Champs de données

const | CURVE_X25519 = 4
const | CURVE_X448 = 5
const | CURVE_ED25519 = 6
const | CURVE_ED448 = 7
const | DATA_CURVE = -1
const | DATA_X = -2
const | DATA_D = -4
- Champs de données hérités de Key
const | TYPE = 1
const | TYPE_OKP = 1
const | TYPE_EC2 = 2
const | TYPE_RSA = 3
const | TYPE_OCT = 4
const | KID = 2
const | ALG = 3
const | KEY_OPS = 4
const | BASE_IV = 5

Attributs privés

const SUPPORTED_CURVES

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Key
static createFromData (array $data)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )

Références Key\$data, Symfony\Contracts\Service\__construct(), Assertion\eq(), Assertion\inArray(), et Assertion\keyExists().

Documentation des fonctions membres

◆ curve()

curve ( )

◆ d()

d ( )

Références OkpKey\isPrivate(), et Assertion\true().

◆ isPrivate()

isPrivate ( )

Références Key\getData().

Référencé par OkpKey\d().

◆ x()

x ( )

Documentation des champs

◆ CURVE_ED25519

const CURVE_ED25519 = 6

Référencé par EdDSA\sign(), et EdDSA\verify().

◆ CURVE_ED448

const CURVE_ED448 = 7

◆ CURVE_X25519

const CURVE_X25519 = 4

◆ CURVE_X448

const CURVE_X448 = 5

◆ DATA_CURVE

const DATA_CURVE = -1

◆ DATA_D

const DATA_D = -4

◆ DATA_X

const DATA_X = -2

◆ SUPPORTED_CURVES

const SUPPORTED_CURVES
private
Valeur initiale :
= [
self::CURVE_X25519,
self::CURVE_X448,
self::CURVE_ED25519,
self::CURVE_ED448,
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • OkpKey.php


Joomla CMS: Référence de la classe RsaKey

  • Cose
  • Key
  • RsaKey
Fonctions membres publiques | Champs de données | Fonctions membres privées
Référence de la classe RsaKey
+ Graphe d'héritage de RsaKey:
Key

Fonctions membres publiques

__construct (array $data)
n ()
e ()
d ()
p ()
q ()
dP ()
dQ ()
QInv ()
other ()
rI ()
dI ()
tI ()
hasPrimes ()
primes ()
hasExponents ()
exponents ()
hasCoefficient ()
isPublic ()
isPrivate ()
asPem ()
- Fonctions membres publiques hérités de Key
__construct (array $data)
type ()
alg ()
getData ()
has (int $key)
get (int $key)

Champs de données

const | DATA_N = -1
const | DATA_E = -2
const | DATA_D = -3
const | DATA_P = -4
const | DATA_Q = -5
const | DATA_DP = -6
const | DATA_DQ = -7
const | DATA_QI = -8
const | DATA_OTHER = -9
const | DATA_RI = -10
const | DATA_DI = -11
const | DATA_TI = -12
- Champs de données hérités de Key
const | TYPE = 1
const | TYPE_OKP = 1
const | TYPE_EC2 = 2
const | TYPE_RSA = 3
const | TYPE_OCT = 4
const | KID = 2
const | ALG = 3
const | KEY_OPS = 4
const | BASE_IV = 5

Fonctions membres privées

fromBase64ToInteger (string $value)
pem (string $type, string $der)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Key
static createFromData (array $data)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )

Références Key\$data, Symfony\Contracts\Service\__construct(), Assertion\eq(), et Assertion\keyExists().

Documentation des fonctions membres

◆ asPem()

asPem ( )

Références RsaKey\e(), Assertion\false(), RsaKey\fromBase64ToInteger(), RsaKey\isPrivate(), RsaKey\n(), et RsaKey\pem().

◆ d()

d ( )

Références RsaKey\isPrivate(), et Assertion\true().

◆ dI()

dI ( )

Références RsaKey\isPrivate(), et Assertion\true().

◆ dP()

dP ( )

Références RsaKey\isPrivate(), et Assertion\true().

Référencé par RsaKey\exponents().

◆ dQ()

dQ ( )

Références RsaKey\isPrivate(), et Assertion\true().

Référencé par RsaKey\exponents().

◆ e()

e ( )

Référencé par RsaKey\asPem().

◆ exponents()

exponents ( )

Références RsaKey\dP(), et RsaKey\dQ().

◆ fromBase64ToInteger()

fromBase64ToInteger ( string $value )
private

Références $value.

Référencé par RsaKey\asPem().

◆ hasCoefficient()

hasCoefficient ( )

Références Key\has().

◆ hasExponents()

hasExponents ( )

Références Key\has().

◆ hasPrimes()

hasPrimes ( )

Références Key\has().

◆ isPrivate()

isPrivate ( )

Références Key\getData().

Référencé par RsaKey\asPem(), RsaKey\d(), RsaKey\dI(), RsaKey\dP(), RsaKey\dQ(), RsaKey\isPublic(), RsaKey\other(), RsaKey\p(), RsaKey\q(), RsaKey\QInv(), RsaKey\rI(), et RsaKey\tI().

◆ isPublic()

isPublic ( )

Références RsaKey\isPrivate().

◆ n()

n ( )

Référencé par RsaKey\asPem().

◆ other()

other ( )

Références RsaKey\isPrivate(), et Assertion\true().

◆ p()

p ( )

Références RsaKey\isPrivate(), et Assertion\true().

Référencé par RsaKey\primes().

◆ pem()

pem | ( | string | $type,
 |  | string | $der
 | ) |  |
private

Références $type.

Référencé par RsaKey\asPem().

◆ primes()

primes ( )

Références RsaKey\p(), et RsaKey\q().

◆ q()

q ( )

Références RsaKey\isPrivate(), et Assertion\true().

Référencé par RsaKey\primes().

◆ QInv()

QInv ( )

Références RsaKey\isPrivate(), et Assertion\true().

◆ rI()

rI ( )

Références RsaKey\isPrivate(), et Assertion\true().

◆ tI()

tI ( )

Références RsaKey\isPrivate(), et Assertion\true().

Documentation des champs

◆ DATA_D

const DATA_D = -3

◆ DATA_DI

const DATA_DI = -11

◆ DATA_DP

const DATA_DP = -6

◆ DATA_DQ

const DATA_DQ = -7

◆ DATA_E

const DATA_E = -2

◆ DATA_N

const DATA_N = -1

◆ DATA_OTHER

const DATA_OTHER = -9

◆ DATA_P

const DATA_P = -4

◆ DATA_Q

const DATA_Q = -5

◆ DATA_QI

const DATA_QI = -8

◆ DATA_RI

const DATA_RI = -10

◆ DATA_TI

const DATA_TI = -12
La documentation de cette classe a été générée à partir du fichier suivant :
  • RsaKey.php


Joomla CMS: Référence de la classe SymmetricKey

  • Cose
  • Key
  • SymmetricKey
Fonctions membres publiques | Champs de données
Référence de la classe SymmetricKey
+ Graphe d'héritage de SymmetricKey:
Key

Fonctions membres publiques

__construct (array $data)
k ()
- Fonctions membres publiques hérités de Key
__construct (array $data)
type ()
alg ()
getData ()
has (int $key)
get (int $key)

Champs de données

const | DATA_K = -1
- Champs de données hérités de Key
const | TYPE = 1
const | TYPE_OKP = 1
const | TYPE_EC2 = 2
const | TYPE_RSA = 3
const | TYPE_OCT = 4
const | KID = 2
const | ALG = 3
const | KEY_OPS = 4
const | BASE_IV = 5

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Key
static createFromData (array $data)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )

Références Key\$data, Symfony\Contracts\Service\__construct(), Assertion\eq(), et Assertion\keyExists().

Documentation des fonctions membres

◆ k()

k ( )

Documentation des champs

◆ DATA_K

const DATA_K = -1
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/cose-lib/src/Key/SymmetricKey.php


Joomla CMS: Référence de la classe Algorithms

  • Cose
  • Algorithms
Fonctions membres publiques statiques | Champs de données
Référence de la classe Algorithms

Fonctions membres publiques statiques

static | getOpensslAlgorithmFor (int $algorithmIdentifier)
static | getHashAlgorithmFor (int $algorithmIdentifier)
static | getAlgorithm (int $identifier)
static | getAlgorithms ()

Champs de données

const | COSE_ALGORITHM_AES_CCM_64_128_256 = 33
const | COSE_ALGORITHM_AES_CCM_64_128_128 = 32
const | COSE_ALGORITHM_AES_CCM_16_128_256 = 31
const | COSE_ALGORITHM_AES_CCM_16_128_128 = 30
const | COSE_ALGORITHM_AES_MAC_256_128 = 26
const | COSE_ALGORITHM_AES_MAC_128_128 = 25
const | COSE_ALGORITHM_CHACHA20_POLY1305 = 24
const | COSE_ALGORITHM_AES_MAC_256_64 = 15
const | COSE_ALGORITHM_AES_MAC_128_64 = 14
const | COSE_ALGORITHM_AES_CCM_64_64_256 = 13
const | COSE_ALGORITHM_AES_CCM_64_64_128 = 12
const | COSE_ALGORITHM_AES_CCM_16_64_256 = 11
const | COSE_ALGORITHM_AES_CCM_16_64_128 = 10
const | COSE_ALGORITHM_HS512 = 7
const | COSE_ALGORITHM_HS384 = 6
const | COSE_ALGORITHM_HS256 = 5
const | COSE_ALGORITHM_HS256_64 = 4
const | COSE_ALGORITHM_A256GCM = 3
const | COSE_ALGORITHM_A192GCM = 2
const | COSE_ALGORITHM_A128GCM = 1
const | COSE_ALGORITHM_A128KW = -3
const | COSE_ALGORITHM_A192KW = -4
const | COSE_ALGORITHM_A256KW = -5
const | COSE_ALGORITHM_DIRECT = -6
const | COSE_ALGORITHM_ES256 = -7
const | COSE_ALGORITHM_EdDSA = -8
const | COSE_ALGORITHM_ED256 = -260
const | COSE_ALGORITHM_ED512 = -261
const | COSE_ALGORITHM_DIRECT_HKDF_SHA_256 = -10
const | COSE_ALGORITHM_DIRECT_HKDF_SHA_512 = -11
const | COSE_ALGORITHM_DIRECT_HKDF_AES_128 = -12
const | COSE_ALGORITHM_DIRECT_HKDF_AES_256 = -13
const | COSE_ALGORITHM_ECDH_ES_HKDF_256 = -25
const | COSE_ALGORITHM_ECDH_ES_HKDF_512 = -26
const | COSE_ALGORITHM_ECDH_SS_HKDF_256 = -27
const | COSE_ALGORITHM_ECDH_SS_HKDF_512 = -28
const | COSE_ALGORITHM_ECDH_ES_A128KW = -29
const | COSE_ALGORITHM_ECDH_ES_A192KW = -30
const | COSE_ALGORITHM_ECDH_ES_A256KW = -31
const | COSE_ALGORITHM_ECDH_SS_A128KW = -32
const | COSE_ALGORITHM_ECDH_SS_A192KW = -33
const | COSE_ALGORITHM_ECDH_SS_A256KW = -34
const | COSE_ALGORITHM_ES384 = -35
const | COSE_ALGORITHM_ES512 = -36
const | COSE_ALGORITHM_PS256 = -37
const | COSE_ALGORITHM_PS384 = -38
const | COSE_ALGORITHM_PS512 = -39
const | COSE_ALGORITHM_RSAES_OAEP = -40
const | COSE_ALGORITHM_RSAES_OAEP_256 = -41
const | COSE_ALGORITHM_RSAES_OAEP_512 = -42
const | COSE_ALGORITHM_ES256K = -43
const | COSE_ALGORITHM_RS256 = -257
const | COSE_ALGORITHM_RS384 = -258
const | COSE_ALGORITHM_RS512 = -259
const | COSE_ALGORITHM_RS1 = -65535
const | COSE_ALGORITHM_MAP
const | COSE_HASH_MAP

Description détaillée

Voir également
https://www.iana.org/assignments/cose/cose.xhtml#algorithms

Documentation des fonctions membres

◆ getAlgorithm()

static getAlgorithm ( int $identifier )
static
Obsolète:
Will be removed in v3.0. Please use the Manager or the ManagerFactory

◆ getAlgorithms()

static getAlgorithms ( )
static
Obsolète:
Will be removed in v3.0. Please use the Manager or the ManagerFactory
Renvoie
Algorithm[]

◆ getHashAlgorithmFor()

static getHashAlgorithmFor ( int $algorithmIdentifier )
static

Référencé par TPMAttestationStatementSupport\isValid().

◆ getOpensslAlgorithmFor()

static getOpensslAlgorithmFor ( int $algorithmIdentifier )
static

Référencé par AndroidKeyAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\processWithCertificate(), et TPMAttestationStatementSupport\processWithCertificate().

Documentation des champs

◆ COSE_ALGORITHM_A128GCM

const COSE_ALGORITHM_A128GCM = 1

◆ COSE_ALGORITHM_A128KW

const COSE_ALGORITHM_A128KW = -3

◆ COSE_ALGORITHM_A192GCM

const COSE_ALGORITHM_A192GCM = 2

◆ COSE_ALGORITHM_A192KW

const COSE_ALGORITHM_A192KW = -4

◆ COSE_ALGORITHM_A256GCM

const COSE_ALGORITHM_A256GCM = 3

◆ COSE_ALGORITHM_A256KW

const COSE_ALGORITHM_A256KW = -5

◆ COSE_ALGORITHM_AES_CCM_16_128_128

const COSE_ALGORITHM_AES_CCM_16_128_128 = 30

◆ COSE_ALGORITHM_AES_CCM_16_128_256

const COSE_ALGORITHM_AES_CCM_16_128_256 = 31

◆ COSE_ALGORITHM_AES_CCM_16_64_128

const COSE_ALGORITHM_AES_CCM_16_64_128 = 10

◆ COSE_ALGORITHM_AES_CCM_16_64_256

const COSE_ALGORITHM_AES_CCM_16_64_256 = 11

◆ COSE_ALGORITHM_AES_CCM_64_128_128

const COSE_ALGORITHM_AES_CCM_64_128_128 = 32

◆ COSE_ALGORITHM_AES_CCM_64_128_256

const COSE_ALGORITHM_AES_CCM_64_128_256 = 33

◆ COSE_ALGORITHM_AES_CCM_64_64_128

const COSE_ALGORITHM_AES_CCM_64_64_128 = 12

◆ COSE_ALGORITHM_AES_CCM_64_64_256

const COSE_ALGORITHM_AES_CCM_64_64_256 = 13

◆ COSE_ALGORITHM_AES_MAC_128_128

const COSE_ALGORITHM_AES_MAC_128_128 = 25

◆ COSE_ALGORITHM_AES_MAC_128_64

const COSE_ALGORITHM_AES_MAC_128_64 = 14

◆ COSE_ALGORITHM_AES_MAC_256_128

const COSE_ALGORITHM_AES_MAC_256_128 = 26

◆ COSE_ALGORITHM_AES_MAC_256_64

const COSE_ALGORITHM_AES_MAC_256_64 = 15

◆ COSE_ALGORITHM_CHACHA20_POLY1305

const COSE_ALGORITHM_CHACHA20_POLY1305 = 24

◆ COSE_ALGORITHM_DIRECT

const COSE_ALGORITHM_DIRECT = -6

◆ COSE_ALGORITHM_DIRECT_HKDF_AES_128

const COSE_ALGORITHM_DIRECT_HKDF_AES_128 = -12

◆ COSE_ALGORITHM_DIRECT_HKDF_AES_256

const COSE_ALGORITHM_DIRECT_HKDF_AES_256 = -13

◆ COSE_ALGORITHM_DIRECT_HKDF_SHA_256

const COSE_ALGORITHM_DIRECT_HKDF_SHA_256 = -10

◆ COSE_ALGORITHM_DIRECT_HKDF_SHA_512

const COSE_ALGORITHM_DIRECT_HKDF_SHA_512 = -11

◆ COSE_ALGORITHM_ECDH_ES_A128KW

const COSE_ALGORITHM_ECDH_ES_A128KW = -29

◆ COSE_ALGORITHM_ECDH_ES_A192KW

const COSE_ALGORITHM_ECDH_ES_A192KW = -30

◆ COSE_ALGORITHM_ECDH_ES_A256KW

const COSE_ALGORITHM_ECDH_ES_A256KW = -31

◆ COSE_ALGORITHM_ECDH_ES_HKDF_256

const COSE_ALGORITHM_ECDH_ES_HKDF_256 = -25

◆ COSE_ALGORITHM_ECDH_ES_HKDF_512

const COSE_ALGORITHM_ECDH_ES_HKDF_512 = -26

◆ COSE_ALGORITHM_ECDH_SS_A128KW

const COSE_ALGORITHM_ECDH_SS_A128KW = -32

◆ COSE_ALGORITHM_ECDH_SS_A192KW

const COSE_ALGORITHM_ECDH_SS_A192KW = -33

◆ COSE_ALGORITHM_ECDH_SS_A256KW

const COSE_ALGORITHM_ECDH_SS_A256KW = -34

◆ COSE_ALGORITHM_ECDH_SS_HKDF_256

const COSE_ALGORITHM_ECDH_SS_HKDF_256 = -27

◆ COSE_ALGORITHM_ECDH_SS_HKDF_512

const COSE_ALGORITHM_ECDH_SS_HKDF_512 = -28

◆ COSE_ALGORITHM_ED256

const COSE_ALGORITHM_ED256 = -260

◆ COSE_ALGORITHM_ED512

const COSE_ALGORITHM_ED512 = -261

◆ COSE_ALGORITHM_EdDSA

const COSE_ALGORITHM_EdDSA = -8

Référencé par EdDSA\identifier().

◆ COSE_ALGORITHM_ES256

const COSE_ALGORITHM_ES256 = -7

◆ COSE_ALGORITHM_ES256K

const COSE_ALGORITHM_ES256K = -43

◆ COSE_ALGORITHM_ES384

const COSE_ALGORITHM_ES384 = -35

◆ COSE_ALGORITHM_ES512

const COSE_ALGORITHM_ES512 = -36

◆ COSE_ALGORITHM_HS256

const COSE_ALGORITHM_HS256 = 5

◆ COSE_ALGORITHM_HS256_64

const COSE_ALGORITHM_HS256_64 = 4

◆ COSE_ALGORITHM_HS384

const COSE_ALGORITHM_HS384 = 6

◆ COSE_ALGORITHM_HS512

const COSE_ALGORITHM_HS512 = 7

◆ COSE_ALGORITHM_MAP

const COSE_ALGORITHM_MAP
Valeur initiale :
= [
self::COSE_ALGORITHM_ES256 => OPENSSL_ALGO_SHA256

◆ COSE_ALGORITHM_PS256

const COSE_ALGORITHM_PS256 = -37

◆ COSE_ALGORITHM_PS384

const COSE_ALGORITHM_PS384 = -38

◆ COSE_ALGORITHM_PS512

const COSE_ALGORITHM_PS512 = -39

◆ COSE_ALGORITHM_RS1

const COSE_ALGORITHM_RS1 = -65535

◆ COSE_ALGORITHM_RS256

const COSE_ALGORITHM_RS256 = -257

◆ COSE_ALGORITHM_RS384

const COSE_ALGORITHM_RS384 = -258

◆ COSE_ALGORITHM_RS512

const COSE_ALGORITHM_RS512 = -259

◆ COSE_ALGORITHM_RSAES_OAEP

const COSE_ALGORITHM_RSAES_OAEP = -40

◆ COSE_ALGORITHM_RSAES_OAEP_256

const COSE_ALGORITHM_RSAES_OAEP_256 = -41

◆ COSE_ALGORITHM_RSAES_OAEP_512

const COSE_ALGORITHM_RSAES_OAEP_512 = -42

◆ COSE_HASH_MAP

const COSE_HASH_MAP
Valeur initiale :
= [
self::COSE_ALGORITHM_ES256K => 'sha256'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Algorithms.php


Joomla CMS: Référence de la classe Verifier

  • Cose
  • Verifier
Référence de la classe Verifier
La documentation de cette classe a été générée à partir du fichier suivant :
  • Verifier.php


Joomla CMS: Référence de la classe AbstractField

  • Cron
  • AbstractField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractField
+ Graphe d'héritage de AbstractField:
FieldInterface DayOfMonthField DayOfWeekField HoursField MinutesField MonthField

Fonctions membres publiques

__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)
- Fonctions membres publiques hérités de FieldInterface
isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)

Fonctions membres protégées

convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Attributs protégés

$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Description détaillée

Abstract CRON expression field.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor

Documentation des fonctions membres

◆ convertLiterals()

convertLiterals ( string $value )
protected

Convert literal.

Paramètres
string $value
Renvoie
string

Références $key, et $value.

◆ getRangeForExpression()

getRangeForExpression | ( | string | $expression,
 |  | int | $max
 | ) |  |

Returns a range of values for the given cron expression.

Paramètres
string | $expression | The expression to evaluate
int | $max | Maximum offset for range
Renvoie
array

Références $i, Joomla\Database\Query\$offset, et $range.

◆ isIncrementsOfRanges()

isIncrementsOfRanges ( string $value )

Check if a value is an increments of ranges.

Références $value.

◆ isInIncrementsOfRanges()

isInIncrementsOfRanges | ( | int | $dateValue,
 |  | string | $value
 | ) |  |

Test if a value is within an increments of ranges (offset[-to]/step size).

-ignore-next-line

Références $range, $step, $value, et null.

◆ isInRange()

isInRange | ( | int | $dateValue,
 |  |  | $value
 | ) |  |

Test if a value is within a range.

Références $parts, et $value.

◆ isRange()

isRange ( string $value )

Check if a value is a range.

Références $value.

◆ isSatisfied()

isSatisfied | ( | int | $dateValue,
 |  | string | $value
 | ) |  |

Check to see if a field is satisfied by a value.

Références $value.

◆ setTimeHour()

setTimeHour | ( | DateTimeInterface | $date,
 |  | bool | $invert,
 |  | int | $originalTimestamp
 | ) |  |
protected

Références $date, et elseif.

◆ timezoneSafeModify()

timezoneSafeModify | ( | DateTimeInterface | $dt,
 |  | string | $modification
 | ) |  |
protected

◆ validate()

validate ( string $value )

Checks to see if a value is valid for the field.

Paramètres
string $value
Renvoie
bool

Implémente FieldInterface.

Références $range, $step, et $value.

Documentation des champs

◆ $fullRange

$fullRange = []
protected

◆ $literals

$literals = []
protected

◆ $rangeEnd

$rangeEnd
protected

◆ $rangeStart

$rangeStart
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractField.php


Joomla CMS: Référence de la classe CronExpression

  • Cron
  • CronExpression
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Attributs privés statiques
Référence de la classe CronExpression

Fonctions membres publiques

__construct (string $expression, FieldFactoryInterface $fieldFactory=null)
setExpression (string $value)
setPart (int $position, string $value)
setMaxIterationCount (int $maxIterationCount)
getNextRunDate ($currentTime='now', int $nth=0, bool $allowCurrentDate=false, $timeZone=null)
getPreviousRunDate ($currentTime='now', int $nth=0, bool $allowCurrentDate=false, $timeZone=null)
getMultipleRunDates (int $total, $currentTime='now', bool $invert=false, bool $allowCurrentDate=false, $timeZone=null)
getExpression ($part=null)
getParts ()
__toString ()
isDue ($currentTime='now', $timeZone=null)

Fonctions membres publiques statiques

static | registerAlias (string $alias, string $expression)
static | unregisterAlias (string $alias)
static | supportsAlias (string $alias)
static | getAliases ()
static | factory (string $expression, FieldFactoryInterface $fieldFactory=null)
static | isValidExpression (string $expression)

Champs de données

const | MINUTE = 0
const | HOUR = 1
const | DAY = 2
const | MONTH = 3
const | WEEKDAY = 4
const | YEAR = 5
const | MAPPINGS

Fonctions membres protégées

getRunDate ($currentTime=null, int $nth=0, bool $invert=false, bool $allowCurrentDate=false, $timeZone=null)
determineTimeZone ($currentTime, ?string $timeZone)

Attributs protégés

$cronParts
$fieldFactory
$maxIterationCount = 1000

Attributs protégés statiques

static $order

Attributs privés statiques

static $registeredAliases = self::MAPPINGS

Description détaillée

CRON expression parser that can determine whether or not a CRON expression is due to run, the next run date and previous run date of a CRON expression. The determinations made by this class are accurate if checked run once per minute (seconds are dropped from date time comparisons).

Schedule parts must map to: minute [0-59], hour [0-23], day of month, month [1-12|JAN-DEC], day of week [1-7|MON-SUN], and an optional year.

Voir également
http://en.wikipedia.org/wiki/Cron

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $expression,
 |  | FieldFactoryInterface | $fieldFactory = null
 | ) |  |

Parse a CRON expression.

Paramètres
string | $expression | CRON expression (e.g. '8 * * * *')
null | FieldFactoryInterface | $fieldFactory | Factory to create cron fields

Documentation des fonctions membres

◆ __toString()

__toString ( )

Helper method to output the full expression.

Renvoie
string Full CRON expression

◆ determineTimeZone()

determineTimeZone | ( |  | $currentTime,
 |  | ?string | $timeZone
 | ) |  |
protected

Workout what timeZone should be used.

Paramètres
string | \DateTimeInterface | null | $currentTime | Relative calculation date
string | null | $timeZone | TimeZone to use instead of the system default
Renvoie
string

Références null.

◆ factory()

FieldFactoryInterface CRON field factory | ( | string | $expression,
 |  | FieldFactoryInterface | $fieldFactory = null
 | ) |  |
static
Obsolète:
since version 3.0.2, use __construct instead.

-ignore-next-line

◆ getAliases()

static getAliases ( )
static

Returns all registered aliases as an associated array where the aliases are the key and their associated expressions are the values.

Renvoie
array<string, string>

◆ getExpression()

getExpression ( $part = null )

Get all or part of the CRON expression.

Paramètres
int | string | null $part specify the part to retrieve or NULL to get the full cron schedule string
Renvoie
null|string Returns the CRON expression, a part of the CRON expression, or NULL if the part was specified but not found

Références null.

◆ getMultipleRunDates()

getMultipleRunDates | ( | int | $total,
 |  |  | $currentTime = 'now',
 |  | bool | $invert = false,
 |  | bool | $allowCurrentDate = false,
 |  |  | $timeZone = null
 | ) |  |

Get multiple run dates starting at the current date or a specific date.

Paramètres
int | $total | Set the total number of dates to calculate
string | \DateTimeInterface | null | $currentTime | Relative calculation date
bool | $invert | Set to TRUE to retrieve previous dates
bool | $allowCurrentDate | Set to TRUE to return the current date if it matches the cron expression
null | string | $timeZone | TimeZone to use instead of the system default
Renvoie
[] Returns an array of run dates

Références $i, $result, $total, class, et elseif.

◆ getNextRunDate()

getNextRunDate | ( |  | $currentTime = 'now',
 |  | int | $nth = 0,
 |  | bool | $allowCurrentDate = false,
 |  |  | $timeZone = null
 | ) |  |

Get a next run date relative to the current date or a specific date

Paramètres
string | \DateTimeInterface | $currentTime | Relative calculation date
int | $nth | Number of matches to skip before returning a matching next run date. 0, the default, will return the current date and time if the next run date falls on the current date and time. Setting this value to 1 will skip the first match and go to the second match. Setting this value to 2 will skip the first 2 matches and so on.
bool | $allowCurrentDate | Set to TRUE to return the current date if it matches the cron expression.
null | string | $timeZone | TimeZone to use instead of the system default
Exceptions

◆ getParts()

getParts ( )

Gets the parts of the cron expression as an array.

Renvoie
string[] The array of parts that make up this expression.

◆ getPreviousRunDate()

getPreviousRunDate | ( |  | $currentTime = 'now',
 |  | int | $nth = 0,
 |  | bool | $allowCurrentDate = false,
 |  |  | $timeZone = null
 | ) |  |

Get a previous run date relative to the current date or a specific date.

Paramètres
string | \DateTimeInterface | $currentTime | Relative calculation date
int | $nth | Number of matches to skip before returning
bool | $allowCurrentDate | Set to TRUE to return the current date if it matches the cron expression
null | string | $timeZone | TimeZone to use instead of the system default
Exceptions

◆ getRunDate()

getRunDate | ( |  | $currentTime = null,
 |  | int | $nth = 0,
 |  | bool | $invert = false,
 |  | bool | $allowCurrentDate = false,
 |  |  | $timeZone = null
 | ) |  |
protected

Get the next or previous run date of the expression relative to a date.

Paramètres
string | \DateTimeInterface | null | $currentTime | Relative calculation date
int | $nth | Number of matches to skip before returning
bool | $invert | Set to TRUE to go backwards in time
bool | $allowCurrentDate | Set to TRUE to return the current date if it matches the cron expression
string | null | $timeZone | TimeZone to use instead of the system default
Exceptions

Références $b, $currentDate, $field, $fields, $i, $parts, $position, class, elseif, et null.

◆ isDue()

isDue | ( | $currentTime = 'now',
 |  | $timeZone = null
 | ) |

Determine if the cron is due to run based on the current date or a specific date. This method assumes that the current number of seconds are irrelevant, and should be called once per minute.

Paramètres
string | \DateTimeInterface | $currentTime | Relative calculation date
null | string | $timeZone | TimeZone to use instead of the system default
Renvoie
bool Returns TRUE if the cron is due to run or FALSE if not

Références class, et elseif.

◆ isValidExpression()

static isValidExpression ( string $expression )
static

Validate a CronExpression.

Paramètres
string $expression the CRON expression to validate
Renvoie
bool True if a valid CRON expression was passed. False if not.

◆ registerAlias()

static registerAlias | ( | string | $alias,
 |  | string | $expression
 | ) |  |
static

Registered a user defined CRON Expression Alias.

Exceptions
LogicException If the expression or the alias name are invalid or if the alias is already registered.

◆ setExpression()

setExpression ( string $value )

Set or change the CRON expression.

Paramètres
string $value CRON expression (e.g. 8 * * * *)
Exceptions

Références $position, $this, et $value.

◆ setMaxIterationCount()

setMaxIterationCount ( int $maxIterationCount )

Set max iteration count for searching next run dates.

Paramètres
int $maxIterationCount Max iteration count when searching for next run date
Renvoie
CronExpression

Références $this.

◆ setPart()

setPart | ( | int | $position,
 |  | string | $value
 | ) |  |

Set part of the CRON expression.

Paramètres
int | $position | The position of the CRON expression to set
string | $value | The value to set
Exceptions

Références $position, $this, et $value.

◆ supportsAlias()

static supportsAlias ( string $alias )
static

Tells whether a CRON Expression alias is registered.

◆ unregisterAlias()

static unregisterAlias ( string $alias )
static

Unregistered a user defined CRON Expression Alias.

Exceptions
LogicException If the user tries to unregister a built-in alias

Documentation des champs

◆ $cronParts

$cronParts
protected

◆ $fieldFactory

$fieldFactory
protected

◆ $maxIterationCount

$maxIterationCount = 1000
protected

◆ $order

$order
staticprotected
Valeur initiale :
= [
self::YEAR,
self::MONTH,
self::DAY,
self::WEEKDAY,
self::HOUR,
self::MINUTE,
]

◆ $registeredAliases

$registeredAliases = self::MAPPINGS
staticprivate

◆ DAY

const DAY = 2

◆ HOUR

const HOUR = 1

◆ MAPPINGS

const MAPPINGS
Valeur initiale :
= [
'@yearly' => '0 0 1 1 *'

◆ MINUTE

const MINUTE = 0

◆ MONTH

const MONTH = 3

◆ WEEKDAY

const WEEKDAY = 4

◆ YEAR

const YEAR = 5
Obsolète:
La documentation de cette classe a été générée à partir du fichier suivant :
  • CronExpression.php


Joomla CMS: Référence de la classe DayOfMonthField

  • Cron
  • DayOfMonthField
Fonctions membres publiques | Attributs protégés | Fonctions membres privées statiques
Référence de la classe DayOfMonthField
+ Graphe d'héritage de DayOfMonthField:
AbstractField FieldInterface

Fonctions membres publiques

isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
validate (string $value)
- Fonctions membres publiques hérités de AbstractField
__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)

Attributs protégés

$rangeStart = 1
$rangeEnd = 31
- Attributs protégés hérités de AbstractField
$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Fonctions membres privées statiques

static getNearestWeekday (int $currentYear, int $currentMonth, int $targetDay)

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractField
convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Description détaillée

Day of month field. Allows: * , / - ? L W.

'L' stands for "last" and specifies the last day of the month.

The 'W' character is used to specify the weekday (Monday-Friday) nearest the given day. As an example, if you were to specify "15W" as the value for the day-of-month field, the meaning is: "the nearest weekday to the 15th of the month". So if the 15th is a Saturday, the trigger will fire on Friday the 14th. If the 15th is a Sunday, the trigger will fire on Monday the 16th. If the 15th is a Tuesday, then it will fire on Tuesday the 15th. However if you specify "1W" as the value for day-of-month, and the 1st is a Saturday, the trigger will fire on Monday the 3rd, as it will not 'jump' over the boundary of a month's days. The 'W' character can only be specified when the day-of-month is a single day, not a range or list of days.

Auteur
Michael Dowling mtdow.nosp@m.ling.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des fonctions membres

◆ getNearestWeekday()

static getNearestWeekday | ( | int | $currentYear,
 |  | int | $currentMonth,
 |  | int | $targetDay
 | ) |  |
staticprivate

Get the nearest day of the week for a given day in a month.

Paramètres
int | $currentYear | Current year
int | $currentMonth | Current month
int | $targetDay | Target day of the month
Renvoie
|null Returns the nearest date

Références $i, $target, et null.

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |
Paramètres
\DateTime | \DateTimeImmutable $date

Implémente FieldInterface.

Références $date, et $this.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

{Check if the respective value of a DateTime field satisfies a CRON exp.}

Implémente FieldInterface.

Références $date, $fieldValue, et $value.

◆ validate()

validate ( string $value )

{Validates a CRON expression for a given field.

Paramètres
string $value CRON expression value to validate
Renvoie
bool Returns TRUE if valid, FALSE otherwise
}

Implémente FieldInterface.

Références $value.

Documentation des champs

◆ $rangeEnd

$rangeEnd = 31
protected

{}

◆ $rangeStart

$rangeStart = 1
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • DayOfMonthField.php


Joomla CMS: Référence de la classe DayOfWeekField

  • Cron
  • DayOfWeekField
Fonctions membres publiques | Attributs protégés
Référence de la classe DayOfWeekField
+ Graphe d'héritage de DayOfWeekField:
AbstractField FieldInterface

Fonctions membres publiques

__construct ()
isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
validate (string $value)
- Fonctions membres publiques hérités de AbstractField
__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)

Attributs protégés

$rangeStart = 0
$rangeEnd = 7
$nthRange
$literals = [1 => 'MON'
- Attributs protégés hérités de AbstractField
$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractField
convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Description détaillée

Day of week field. Allows: * / , - ? L #.

Days of the week can be represented as a number 0-7 (0|7 = Sunday) or as a three letter string: SUN, MON, TUE, WED, THU, FRI, SAT.

'L' stands for "last". It allows you to specify constructs such as "the last Friday" of a given month.

'#' is allowed for the day-of-week field, and must be followed by a number between one and five. It allows you to specify constructs such as "the second Friday" of a given month.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |

Implémente FieldInterface.

Références $date, et $this.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

Implémente FieldInterface.

Références $date, $fieldValue, $format, $parts, $value, et elseif.

◆ validate()

validate ( string $value )

{Validates a CRON expression for a given field.

Paramètres
string $value CRON expression value to validate
Renvoie
bool Returns TRUE if valid, FALSE otherwise
}

Implémente FieldInterface.

Références $value.

Documentation des champs

◆ $literals

$literals = [1 => 'MON'
protected

{}

◆ $nthRange

$nthRange
protected

◆ $rangeEnd

$rangeEnd = 7
protected

{}

◆ $rangeStart

$rangeStart = 0
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • DayOfWeekField.php


Joomla CMS: Référence de la classe FieldFactory

  • Cron
  • FieldFactory
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FieldFactory
+ Graphe d'héritage de FieldFactory:
FieldFactoryInterface

Fonctions membres publiques

getField (int $position)

Fonctions membres privées

instantiateField (int $position)

Attributs privés

$fields = []

Description détaillée

CRON field factory implementing a flyweight factory.

Voir également
http://en.wikipedia.org/wiki/Cron

Documentation des fonctions membres

◆ getField()

getField ( int $position )

Get an instance of a field object for a cron expression position.

Paramètres
int $position CRON expression position value to retrieve
Exceptions
InvalidArgumentException if a position is not valid

Implémente FieldFactoryInterface.

Références $position, et fields.

◆ instantiateField()

instantiateField ( int $position )
private

Références $position.

Documentation des champs

◆ $fields

$fields = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldFactory.php


Joomla CMS: Référence de l'interface FieldFactoryInterface

  • Cron
  • FieldFactoryInterface
Fonctions membres publiques
Référence de l'interface FieldFactoryInterface
+ Graphe d'héritage de FieldFactoryInterface:
FieldFactory

Fonctions membres publiques

getField (int $position)

Documentation des fonctions membres

◆ getField()

getField ( int $position )

Implémenté dans FieldFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FieldFactoryInterface.php


Joomla CMS: Référence de l'interface FieldInterface

  • Cron
  • FieldInterface
Fonctions membres publiques
Référence de l'interface FieldInterface
+ Graphe d'héritage de FieldInterface:
AbstractField DayOfMonthField DayOfWeekField HoursField MinutesField MonthField

Fonctions membres publiques

isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
validate (string $value)

Description détaillée

CRON field interface.

Documentation des fonctions membres

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |

When a CRON expression is not satisfied, this method is used to increment or decrement a DateTime object by the unit of the cron field.

Implémenté dans DayOfWeekField, HoursField, DayOfMonthField, MonthField, et MinutesField.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

Check if the respective value of a DateTime field satisfies a CRON exp.

Implémenté dans DayOfMonthField, DayOfWeekField, HoursField, MonthField, et MinutesField.

◆ validate()

validate ( string $value )

Validates a CRON expression for a given field.

Paramètres
string $value CRON expression value to validate
Renvoie
bool Returns TRUE if valid, FALSE otherwise

Implémenté dans AbstractField, DayOfWeekField, et DayOfMonthField.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FieldInterface.php


Joomla CMS: Référence de la classe HoursField

  • Cron
  • HoursField
Fonctions membres publiques | Attributs protégés
Référence de la classe HoursField
+ Graphe d'héritage de HoursField:
AbstractField FieldInterface

Fonctions membres publiques

isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
getPastTransition (DateTimeInterface $date)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
- Fonctions membres publiques hérités de AbstractField
__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)

Attributs protégés

$rangeStart = 0
$rangeEnd = 23
$transitions = null
$transitionsStart = null
$transitionsEnd = null
- Attributs protégés hérités de AbstractField
$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractField
convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Description détaillée

Hours field. Allows: * , / -.

Documentation des fonctions membres

◆ getPastTransition()

getPastTransition ( DateTimeInterface $date )

Références $date, et null.

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |

{When a CRON expression is not satisfied, this method is used to increment or decrement a DateTime object by the unit of the cron field.}

Paramètres
string | null $parts

Implémente FieldInterface.

Références $date, $i, $parts, $position, $target, $this, et null.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

{Check if the respective value of a DateTime field satisfies a CRON exp.}

Implémente FieldInterface.

Références $date, $value, et null.

Documentation des champs

◆ $rangeEnd

$rangeEnd = 23
protected

{}

◆ $rangeStart

$rangeStart = 0
protected

{}

◆ $transitions

$transitions = null
protected

◆ $transitionsEnd

$transitionsEnd = null
protected

◆ $transitionsStart

$transitionsStart = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HoursField.php


Joomla CMS: Référence de la classe MinutesField

  • Cron
  • MinutesField
Fonctions membres publiques | Attributs protégés
Référence de la classe MinutesField
+ Graphe d'héritage de MinutesField:
AbstractField FieldInterface

Fonctions membres publiques

isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
- Fonctions membres publiques hérités de AbstractField
__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)

Attributs protégés

$rangeStart = 0
$rangeEnd = 59
- Attributs protégés hérités de AbstractField
$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractField
convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Description détaillée

Minutes field. Allows: * , / -.

Documentation des fonctions membres

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |

{When a CRON expression is not satisfied, this method is used to increment or decrement a DateTime object by the unit of the cron field.} When a CRON expression is not satisfied, this method is used to increment or decrement a DateTime object by the unit of the cron field.

Paramètres
string | null $parts

Implémente FieldInterface.

Références $date, $i, $parts, $position, $target, et $this.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

{Check if the respective value of a DateTime field satisfies a CRON exp.}

Implémente FieldInterface.

Références $date, et $value.

Documentation des champs

◆ $rangeEnd

$rangeEnd = 59
protected

{}

◆ $rangeStart

$rangeStart = 0
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • MinutesField.php


Joomla CMS: Référence de la classe MonthField

  • Cron
  • MonthField
Fonctions membres publiques | Attributs protégés
Référence de la classe MonthField
+ Graphe d'héritage de MonthField:
AbstractField FieldInterface

Fonctions membres publiques

isSatisfiedBy (DateTimeInterface $date, $value, bool $invert)
increment (DateTimeInterface &$date, $invert=false, $parts=null)
- Fonctions membres publiques hérités de AbstractField
__construct ()
isSatisfied (int $dateValue, string $value)
isRange (string $value)
isIncrementsOfRanges (string $value)
isInRange (int $dateValue, $value)
isInIncrementsOfRanges (int $dateValue, string $value)
getRangeForExpression (string $expression, int $max)
validate (string $value)

Attributs protégés

$rangeStart = 1
$rangeEnd = 12
$literals = [1 => 'JAN'
- Attributs protégés hérités de AbstractField
$fullRange = []
$literals = []
$rangeStart
$rangeEnd

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractField
convertLiterals (string $value)
timezoneSafeModify (DateTimeInterface $dt, string $modification)
setTimeHour (DateTimeInterface $date, bool $invert, int $originalTimestamp)

Description détaillée

Month field. Allows: * , / -.

Documentation des fonctions membres

◆ increment()

increment | ( | DateTimeInterface & | $date,
 |  |  | $invert = false,
 |  |  | $parts = null
 | ) |  |
Paramètres
\DateTime | \DateTimeImmutable $date

Implémente FieldInterface.

Références $date, et $this.

◆ isSatisfiedBy()

isSatisfiedBy | ( | DateTimeInterface | $date,
 |  |  | $value,
 |  | bool | $invert
 | ) |  |

{Check if the respective value of a DateTime field satisfies a CRON exp.}

Implémente FieldInterface.

Références $date, et $value.

Documentation des champs

◆ $literals

$literals = [1 => 'JAN'
protected

{}

◆ $rangeEnd

$rangeEnd = 12
protected

{}

◆ $rangeStart

$rangeStart = 1
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • MonthField.php


Joomla CMS: Référence de la classe SwiftLogCollector

  • DebugBar
  • Bridge
  • SwiftMailer
  • SwiftLogCollector
Fonctions membres publiques
Référence de la classe SwiftLogCollector
+ Graphe d'héritage de SwiftLogCollector:
MessagesCollector AbstractLogger DataCollectorInterface MessagesAggregateInterface Renderable AssetProvider LoggerInterface

Fonctions membres publiques

__construct (Swift_Mailer $mailer)
add ($entry)
dump ()
getName ()
- Fonctions membres publiques hérités de MessagesCollector
__construct ($name='messages')
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
addMessage ($message, $label='info', $isString=true)
aggregate (MessagesAggregateInterface $messages)
getMessages ()
log ($level, $message, array $context=array())
interpolate ($message, array $context=array())
clear ()
collect ()
getName ()
getAssets ()
getWidgets ()
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Membres hérités additionnels

- Attributs protégés hérités de MessagesCollector
$name
$messages = array()
$aggregates = array()
$dataFormater
$varDumper
$useHtmlVarDumper = false

Description détaillée

Collects log messages

http://swiftmailer.org/

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Swift_Mailer $mailer )

Références $this.

Documentation des fonctions membres

◆ add()

add ( $entry )

Références MessagesCollector\addMessage().

◆ dump()

dump ( )

Références $message.

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SwiftLogCollector.php


Joomla CMS: Référence de la classe SwiftMailCollector

  • DebugBar
  • Bridge
  • SwiftMailer
  • SwiftMailCollector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SwiftMailCollector
+ Graphe d'héritage de SwiftMailCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (Swift_Mailer $mailer)
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres protégées

formatTo ($to)

Attributs protégés

$messagesLogger
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects data about sent mails

http://swiftmailer.org/

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Swift_Mailer $mailer )

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références SwiftMailCollector\formatTo().

◆ formatTo()

formatTo ( $to )
protected

Référencé par SwiftMailCollector\collect().

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
  • inline_css: an array map of content ID to inline CSS content (not including <style> tag)
  • inline_js: an array map of content ID to inline JS content (not including <script> tag)
  • inline_head: an array map of content ID to arbitrary inline HTML content (typically <style>/<script> tags); it must be embedded within the <head> element

All keys are optional.

Ideally, you should store static assets in filenames that are returned via the normal css/js keys. However, the inline asset elements are useful when integrating with 3rd-party libraries that require static assets that are only available in an inline format.

The inline content arrays require special string array keys: the caller of this function will use them to deduplicate content. This is particularly useful if multiple instances of the same asset provider are used. Inline assets from all collectors are merged together into the same array, so these content IDs effectively deduplicate the inline assets.

Renvoie
array

Implémente AssetProvider.

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémente Renderable.

Documentation des champs

◆ $messagesLogger

$messagesLogger
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SwiftMailCollector.php


Joomla CMS: Référence de la classe TimeableTwigExtensionProfiler

  • DebugBar
  • Bridge
  • Twig
  • TimeableTwigExtensionProfiler
Fonctions membres publiques | Attributs privés
Référence de la classe TimeableTwigExtensionProfiler
+ Graphe d'héritage de TimeableTwigExtensionProfiler:

Fonctions membres publiques

setTimeDataCollector (TimeDataCollector $timeDataCollector)
__construct (\Twig_Profiler_Profile $profile, TimeDataCollector $timeDataCollector=null)
enter (Twig_Profiler_Profile $profile)
leave (Twig_Profiler_Profile $profile)

Attributs privés

$timeDataCollector

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Twig_Profiler_Profile | $profile,
 |  | TimeDataCollector | $timeDataCollector = null
 | ) |  |

Références TimeableTwigExtensionProfiler\$timeDataCollector, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ enter()

enter ( Twig_Profiler_Profile $profile )

◆ leave()

leave ( Twig_Profiler_Profile $profile )

◆ setTimeDataCollector()

setTimeDataCollector ( TimeDataCollector $timeDataCollector )
Paramètres
\DebugBar\DataCollector\TimeDataCollector $timeDataCollector

Références TimeableTwigExtensionProfiler\$timeDataCollector.

Documentation des champs

◆ $timeDataCollector

$timeDataCollector
private

Référencé par TimeableTwigExtensionProfiler\__construct(), et TimeableTwigExtensionProfiler\setTimeDataCollector().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TimeableTwigExtensionProfiler.php


Joomla CMS: Référence de la classe TraceableTwigEnvironment

  • DebugBar
  • Bridge
  • Twig
  • TraceableTwigEnvironment
Fonctions membres publiques | Attributs protégés
Référence de la classe TraceableTwigEnvironment
+ Graphe d'héritage de TraceableTwigEnvironment:

Fonctions membres publiques

__construct (Twig_Environment $twig, TimeDataCollector $timeDataCollector=null)
__call ($name, $arguments)
getRenderedTemplates ()
addRenderedTemplate (array $info)
getTimeDataCollector ()
getBaseTemplateClass ()
setBaseTemplateClass ($class)
enableDebug ()
disableDebug ()
isDebug ()
enableAutoReload ()
disableAutoReload ()
isAutoReload ()
enableStrictVariables ()
disableStrictVariables ()
isStrictVariables ()
getCache ($original=true)
setCache ($cache)
getCacheFilename ($name)
getTemplateClass ($name, $index=null)
getTemplateClassPrefix ()
render ($name, array $context=array())
display ($name, array $context=array())
loadTemplate ($name, $index=null)
isTemplateFresh ($name, $time)
resolveTemplate ($names)
clearTemplateCache ()
clearCacheFiles ()
getLexer ()
setLexer (Twig_LexerInterface $lexer)
tokenize ($source, $name=null)
getParser ()
setParser (Twig_ParserInterface $parser)
parse (Twig_TokenStream $tokens)
getCompiler ()
setCompiler (Twig_CompilerInterface $compiler)
compile (Twig_NodeInterface $node)
compileSource ($source, $name=null)
setLoader (Twig_LoaderInterface $loader)
getLoader ()
setCharset ($charset)
getCharset ()
initRuntime ()
hasExtension ($name)
getExtension ($name)
addExtension (Twig_ExtensionInterface $extension)
removeExtension ($name)
setExtensions (array $extensions)
getExtensions ()
addTokenParser (Twig_TokenParserInterface $parser)
getTokenParsers ()
getTags ()
addNodeVisitor (Twig_NodeVisitorInterface $visitor)
getNodeVisitors ()
addFilter ($name, $filter=null)
getFilter ($name)
registerUndefinedFilterCallback ($callable)
getFilters ()
addTest ($name, $test=null)
getTests ()
getTest ($name)
addFunction ($name, $function=null)
getFunction ($name)
registerUndefinedFunctionCallback ($callable)
getFunctions ()
addGlobal ($name, $value)
getGlobals ()
mergeGlobals (array $context)
getUnaryOperators ()
getBinaryOperators ()
computeAlternatives ($name, $items)

Attributs protégés

$twig
$renderedTemplates = array()
$timeDataCollector

Description détaillée

Wrapped a Twig Environment to provide profiling features

Obsolète:

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Twig_Environment | $twig,
 |  | TimeDataCollector | $timeDataCollector = null
 | ) |  |
Paramètres
Twig_Environment | $twig
TimeDataCollector | $timeDataCollector

Références TraceableTwigEnvironment\$timeDataCollector, et TraceableTwigEnvironment\$twig.

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $arguments
 | ) |

Références $name.

◆ addExtension()

addExtension ( Twig_ExtensionInterface $extension )

Références $extension.

◆ addFilter()

addFilter | ( | $name,
 |  | $filter = null
 | ) |

Références $name.

◆ addFunction()

addFunction | ( | $name,
 |  | $function = null
 | ) |

Références $function, et $name.

◆ addGlobal()

addGlobal | ( | $name,
 |  | $value
 | ) |

Références $name, et $value.

◆ addNodeVisitor()

addNodeVisitor ( Twig_NodeVisitorInterface $visitor )

◆ addRenderedTemplate()

addRenderedTemplate ( array $info )

Références $info.

◆ addTest()

addTest | ( | $name,
 |  | $test = null
 | ) |

Références $name.

◆ addTokenParser()

addTokenParser ( Twig_TokenParserInterface $parser )

◆ clearCacheFiles()

clearCacheFiles ( )

◆ clearTemplateCache()

clearTemplateCache ( )

◆ compile()

compile ( Twig_NodeInterface $node )

◆ compileSource()

compileSource | ( | $source,
 |  | $name = null
 | ) |

Références $name.

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ computeAlternatives()

computeAlternatives | ( | $name,
 |  | $items
 | ) |

Références $items, et $name.

◆ disableAutoReload()

disableAutoReload ( )

◆ disableDebug()

disableDebug ( )

◆ disableStrictVariables()

disableStrictVariables ( )

◆ display()

display | ( |  | $name,
 |  | array | $context = array()
 | ) |  |

Références $context, $name, et TraceableTwigEnvironment\loadTemplate().

◆ enableAutoReload()

enableAutoReload ( )

◆ enableDebug()

enableDebug ( )

◆ enableStrictVariables()

enableStrictVariables ( )

◆ getBaseTemplateClass()

getBaseTemplateClass ( )

◆ getBinaryOperators()

getBinaryOperators ( )

◆ getCache()

getCache ( $original = true )

◆ getCacheFilename()

getCacheFilename ( $name )

Références $name.

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ getCharset()

getCharset ( )

◆ getCompiler()

getCompiler ( )

◆ getExtension()

getExtension ( $name )

Références $name.

◆ getExtensions()

getExtensions ( )

◆ getFilter()

getFilter ( $name )

Références $name.

◆ getFilters()

getFilters ( )

◆ getFunction()

getFunction ( $name )

Références $name.

◆ getFunctions()

getFunctions ( )

◆ getGlobals()

getGlobals ( )

◆ getLexer()

getLexer ( )

◆ getLoader()

getLoader ( )

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ getNodeVisitors()

getNodeVisitors ( )

◆ getParser()

getParser ( )

◆ getRenderedTemplates()

getRenderedTemplates ( )

Références TraceableTwigEnvironment\$renderedTemplates.

◆ getTags()

getTags ( )

◆ getTemplateClass()

getTemplateClass | ( | $name,
 |  | $index = null
 | ) |

Références $name.

◆ getTemplateClassPrefix()

getTemplateClassPrefix ( )

◆ getTest()

getTest ( $name )

Références $name.

◆ getTests()

getTests ( )

◆ getTimeDataCollector()

getTimeDataCollector ( )

Références TraceableTwigEnvironment\$timeDataCollector.

◆ getTokenParsers()

getTokenParsers ( )

◆ getUnaryOperators()

getUnaryOperators ( )

◆ hasExtension()

hasExtension ( $name )

Références $name.

◆ initRuntime()

initRuntime ( )

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ isAutoReload()

isAutoReload ( )

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ isDebug()

isDebug ( )

◆ isStrictVariables()

isStrictVariables ( )

◆ isTemplateFresh()

isTemplateFresh | ( | $name,
 |  | $time
 | ) |

Références $name.

Référencé par TraceableTwigEnvironment\loadTemplate().

◆ loadTemplate()

loadTemplate | ( | $name,
 |  | $index = null
 | ) |

Références $name, $this, TraceableTwigEnvironment\compileSource(), TraceableTwigEnvironment\getCacheFilename(), TraceableTwigEnvironment\getLoader(), TraceableTwigEnvironment\initRuntime(), TraceableTwigEnvironment\isAutoReload(), et TraceableTwigEnvironment\isTemplateFresh().

Référencé par TraceableTwigEnvironment\display(), et TraceableTwigEnvironment\render().

◆ mergeGlobals()

mergeGlobals ( array $context )

Références $context.

◆ parse()

parse ( Twig_TokenStream $tokens )

◆ registerUndefinedFilterCallback()

registerUndefinedFilterCallback ( $callable )

◆ registerUndefinedFunctionCallback()

registerUndefinedFunctionCallback ( $callable )

◆ removeExtension()

removeExtension ( $name )

Références $name.

◆ render()

render | ( |  | $name,
 |  | array | $context = array()
 | ) |  |

Références $context, $name, et TraceableTwigEnvironment\loadTemplate().

◆ resolveTemplate()

resolveTemplate ( $names )

Références $names.

◆ setBaseTemplateClass()

setBaseTemplateClass ( $class )

Références $class.

◆ setCache()

setCache ( $cache )

◆ setCharset()

setCharset ( $charset )

◆ setCompiler()

setCompiler ( Twig_CompilerInterface $compiler )

◆ setExtensions()

setExtensions ( array $extensions )

◆ setLexer()

setLexer ( Twig_LexerInterface $lexer )

◆ setLoader()

setLoader ( Twig_LoaderInterface $loader )

Références $loader.

◆ setParser()

setParser ( Twig_ParserInterface $parser )

◆ tokenize()

tokenize | ( | $source,
 |  | $name = null
 | ) |

Références $name.

Documentation des champs

◆ $renderedTemplates

$renderedTemplates = array()
protected

Référencé par TraceableTwigEnvironment\getRenderedTemplates().

◆ $timeDataCollector

$timeDataCollector
protected

Référencé par TraceableTwigEnvironment\__construct(), et TraceableTwigEnvironment\getTimeDataCollector().

◆ $twig

$twig
protected

Référencé par TraceableTwigEnvironment\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TraceableTwigEnvironment.php


Joomla CMS: Référence de la classe TraceableTwigTemplate

  • DebugBar
  • Bridge
  • Twig
  • TraceableTwigTemplate
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe TraceableTwigTemplate
+ Graphe d'héritage de TraceableTwigTemplate:

Fonctions membres publiques

__construct (TraceableTwigEnvironment $env, Twig_Template $template)
__call ($name, $arguments)
doDisplay (array $context, array $blocks=array())
getTemplateName ()
getEnvironment ()
getParent (array $context)
isTraitable ()
displayParentBlock ($name, array $context, array $blocks=array())
displayBlock ($name, array $context, array $blocks=array(), $useBlocks=true)
renderParentBlock ($name, array $context, array $blocks=array())
renderBlock ($name, array $context, array $blocks=array(), $useBlocks=true)
hasBlock ($name)
getBlockNames ()
getBlocks ()
display (array $context, array $blocks=array())
render (array $context)

Fonctions membres publiques statiques

static clearCache ()

Attributs protégés

$template

Description détaillée

Wraps a Twig_Template to add profiling features

Obsolète:

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | TraceableTwigEnvironment | $env,
 |  | Twig_Template | $template
 | ) |  |
Paramètres
TraceableTwigEnvironment | $env
Twig_Template | $template

Références TraceableTwigTemplate\$template.

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $arguments
 | ) |

Références $name.

◆ clearCache()

static clearCache ( )
static

◆ display()

display | ( | array | $context,
 |  | array | $blocks = array()
 | ) |  |

Références $name, et $start.

Référencé par TraceableTwigTemplate\render().

◆ displayBlock()

displayBlock | ( |  | $name,
 |  | array | $context,
 |  | array | $blocks = array(),
 |  |  | $useBlocks = true
 | ) |  |

Références $name.

◆ displayParentBlock()

displayParentBlock | ( |  | $name,
 |  | array | $context,
 |  | array | $blocks = array()
 | ) |  |

Références $name.

◆ doDisplay()

doDisplay | ( | array | $context,
 |  | array | $blocks = array()
 | ) |  |

◆ getBlockNames()

getBlockNames ( )

◆ getBlocks()

getBlocks ( )

◆ getEnvironment()

getEnvironment ( )

◆ getParent()

getParent ( array $context )

◆ getTemplateName()

getTemplateName ( )

◆ hasBlock()

hasBlock ( $name )

Références $name.

◆ isTraitable()

isTraitable ( )

◆ render()

render ( array $context )

Références TraceableTwigTemplate\display().

◆ renderBlock()

renderBlock | ( |  | $name,
 |  | array | $context,
 |  | array | $blocks = array(),
 |  |  | $useBlocks = true
 | ) |  |

Références $name.

◆ renderParentBlock()

renderParentBlock | ( |  | $name,
 |  | array | $context,
 |  | array | $blocks = array()
 | ) |  |

Références $name.

Documentation des champs

◆ $template

$template
protected

Référencé par TraceableTwigTemplate\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TraceableTwigTemplate.php


Joomla CMS: Référence de la classe TwigCollector

  • DebugBar
  • Bridge
  • Twig
  • TwigCollector
Fonctions membres publiques
Référence de la classe TwigCollector
+ Graphe d'héritage de TwigCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (TraceableTwigEnvironment $twig)
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

Collects data about rendered templates

http://twig.sensiolabs.org/

Your Twig_Environment object needs to be wrapped in a TraceableTwigEnvironment object

$env = new TraceableTwigEnvironment(new Twig_Environment($loader)); $debugbar->addCollector(new TwigCollector($env));

Obsolète:
use DebugBar instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( TraceableTwigEnvironment $twig )

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références DataCollector\formatDuration().

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
  • inline_css: an array map of content ID to inline CSS content (not including <style> tag)
  • inline_js: an array map of content ID to inline JS content (not including <script> tag)
  • inline_head: an array map of content ID to arbitrary inline HTML content (typically <style>/<script> tags); it must be embedded within the <head> element

All keys are optional.

Ideally, you should store static assets in filenames that are returned via the normal css/js keys. However, the inline asset elements are useful when integrating with 3rd-party libraries that require static assets that are only available in an inline format.

The inline content arrays require special string array keys: the caller of this function will use them to deduplicate content. This is particularly useful if multiple instances of the same asset provider are used. Inline assets from all collectors are merged together into the same array, so these content IDs effectively deduplicate the inline assets.

Renvoie
array

Implémente AssetProvider.

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémente Renderable.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TwigCollector.php


Joomla CMS: Référence de la classe CacheCacheCollector

  • DebugBar
  • Bridge
  • CacheCacheCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe CacheCacheCollector
+ Graphe d'héritage de CacheCacheCollector:
MonologCollector DataCollectorInterface Renderable MessagesAggregateInterface

Fonctions membres publiques

__construct (Cache $cache=null, Logger $logger=null, $level=Logger::DEBUG, $bubble=true)
addCache (Cache $cache)
getName ()
- Fonctions membres publiques hérités de MonologCollector
__construct (Logger $logger=null, $level=Logger::DEBUG, $bubble=true, $name='monolog')
addLogger (Logger $logger)
getMessages ()
collect ()
getName ()
getWidgets ()

Attributs protégés

$logger
- Attributs protégés hérités de MonologCollector
$name
$records = array()

Membres hérités additionnels

- Fonctions membres protégées hérités de MonologCollector
write (array $record)

Description détaillée

Collects CacheCache operations

http://maximebf.github.io/CacheCache/

Example: $debugbar->addCollector(new CacheCacheCollector(CacheManager::get('default'))); // or $debugbar->addCollector(new CacheCacheCollector()); $debugbar['cache']->addCache(CacheManager::get('default'));

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Cache | $cache = null,
 |  | Logger | $logger = null,
 |  |  | $level = Logger::DEBUG,
 |  |  | $bubble = true
 | ) |  |

CacheCacheCollector constructor.

Paramètres
Cache | null | $cache
Logger | null | $logger
bool | $level
bool | $bubble

Références CacheCacheCollector\$logger, Symfony\Contracts\Service\__construct(), CacheCacheCollector\addCache(), et null.

Documentation des fonctions membres

◆ addCache()

addCache ( Cache $cache )
Paramètres
Cache $cache

Références MonologCollector\addLogger().

Référencé par CacheCacheCollector\__construct().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Documentation des champs

◆ $logger

$logger
protected

Référencé par CacheCacheCollector\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheCacheCollector.php


Joomla CMS: Référence de la classe DoctrineCollector

  • DebugBar
  • Bridge
  • DoctrineCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe DoctrineCollector
+ Graphe d'héritage de DoctrineCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct ($debugStackOrEntityManager)
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$debugStack
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects Doctrine queries

http://doctrine-project.org

Uses the DebugStack logger to collects data about queries

$debugStack = new Doctrine(); $entityManager->getConnection()->getConfiguration()->setSQLLogger($debugStack); $debugbar->addCollector(new DoctrineCollector($debugStack));

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $debugStackOrEntityManager )

DoctrineCollector constructor.

Paramètres
$debugStackOrEntityManager
Exceptions
DebugBarException

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références DataCollector\formatDuration().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Documentation des champs

◆ $debugStack

$debugStack
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DoctrineCollector.php


Joomla CMS: Référence de la classe MonologCollector

  • DebugBar
  • Bridge
  • MonologCollector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MonologCollector
+ Graphe d'héritage de MonologCollector:
DataCollectorInterface Renderable MessagesAggregateInterface CacheCacheCollector

Fonctions membres publiques

__construct (Logger $logger=null, $level=Logger::DEBUG, $bubble=true, $name='monolog')
addLogger (Logger $logger)
getMessages ()
collect ()
getName ()
getWidgets ()

Fonctions membres protégées

write (array $record)

Attributs protégés

$name
$records = array()

Description détaillée

A monolog handler as well as a data collector

https://github.com/Seldaek/monolog

$debugbar->addCollector(new MonologCollector($logger));

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Logger | $logger = null,
 |  |  | $level = Logger::DEBUG,
 |  |  | $bubble = true,
 |  |  | $name = 'monolog'
 | ) |  |
Paramètres
Logger | $logger
int | $level
boolean | $bubble
string | $name

Références MonologCollector\$name, Symfony\Contracts\Service\__construct(), MonologCollector\addLogger(), name, et null.

Documentation des fonctions membres

◆ addLogger()

addLogger ( Logger $logger )

Adds logger which messages you want to log

Paramètres
Logger $logger

Références $this.

Référencé par MonologCollector\__construct(), et CacheCacheCollector\addCache().

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

◆ getMessages()

getMessages ( )
Renvoie
array

Implémente MessagesAggregateInterface.

Références MonologCollector\$records.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Références MonologCollector\$name.

Référencé par MonologCollector\getWidgets().

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Références MonologCollector\$name, et MonologCollector\getName().

◆ write()

write ( array $record )
protected
Paramètres
array $record

Documentation des champs

◆ $name

$name
protected

Référencé par MonologCollector\__construct(), MonologCollector\getName(), et MonologCollector\getWidgets().

◆ $records

$records = array()
protected

Référencé par MonologCollector\getMessages().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MonologCollector.php


Joomla CMS: Référence de la classe NamespacedTwigProfileCollector

  • DebugBar
  • Bridge
  • NamespacedTwigProfileCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe NamespacedTwigProfileCollector
+ Graphe d'héritage de NamespacedTwigProfileCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (Profile $profile, $loaderOrEnv=null)
getWidgets ()
getAssets ()
collect ()
getName ()
getHtmlCallGraph ()
getXdebugLink ($template, $line=1)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

computeData (Profile $profile)

Attributs privés

$profile
$loader
$templateCount
$blockCount
$macroCount
$templates

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

Collects data about rendered templates

http://twig.sensiolabs.org/

A should be added to your The root-Twig-object should then be injected into this collector

you can optionally provide the or the to also create debug-links.

Voir également
,

$env = new ($loader); // Or from a PSR11-container $profile = new (); $env->addExtension(new ($profile)); $debugbar->addCollector(new ModernTwigProfileCollector($profile, $env)); // or: $debugbar->addCollector(new ModernTwigProfileCollector($profile, $loader));

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Profile | $profile,
 |  |  | $loaderOrEnv = null
 | ) |  |

TwigProfileCollector constructor.

Paramètres
Profile | $profile
LoaderInterface | Environment | $loaderOrEnv

Références NamespacedTwigProfileCollector\$profile.

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références NamespacedTwigProfileCollector\$blockCount, NamespacedTwigProfileCollector\$macroCount, NamespacedTwigProfileCollector\$templateCount, NamespacedTwigProfileCollector\$templates, NamespacedTwigProfileCollector\computeData(), DataCollector\getDataFormatter(), et NamespacedTwigProfileCollector\getHtmlCallGraph().

◆ computeData()

computeData ( Profile $profile )
private

Références NamespacedTwigProfileCollector\$profile, DataCollector\getDataFormatter(), et NamespacedTwigProfileCollector\getXdebugLink().

Référencé par NamespacedTwigProfileCollector\collect().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

◆ getHtmlCallGraph()

getHtmlCallGraph ( )

Référencé par NamespacedTwigProfileCollector\collect().

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Renvoie
array

Implémente Renderable.

◆ getXdebugLink()

getXdebugLink | ( | $template,
 |  | $line = 1
 | ) |

Références $template, et null.

Référencé par NamespacedTwigProfileCollector\computeData().

Documentation des champs

◆ $blockCount

$blockCount
private

Référencé par NamespacedTwigProfileCollector\collect().

◆ $loader

$loader
private

◆ $macroCount

$macroCount
private

Référencé par NamespacedTwigProfileCollector\collect().

◆ $profile

$profile
private

Référencé par NamespacedTwigProfileCollector\__construct(), et NamespacedTwigProfileCollector\computeData().

◆ $templateCount

$templateCount
private

Référencé par NamespacedTwigProfileCollector\collect().

◆ $templates

$templates
private

Référencé par NamespacedTwigProfileCollector\collect().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NamespacedTwigProfileCollector.php


Joomla CMS: Référence de la classe Propel2Collector

  • DebugBar
  • Bridge
  • Propel2Collector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Propel2Collector
+ Graphe d'héritage de Propel2Collector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (ConnectionInterface $connection, array $logMethods=array('beginTransaction', 'commit', 'rollBack', 'forceRollBack', 'exec', 'query', 'execute'))
getHandler ()
getConfig ()
getLogger ()
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres protégées

getDefaultLogger ()
getQueryCount ()
getStatements ($records, $config)

Attributs protégés

$handler = null
$logger = null
$config = array()
$errors = array()
$queryCount = 0
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

A Propel logger which acts as a data collector

http://propelorm.org/

Will log queries and display them using the SQLQueries widget.

Example: $debugbar->addCollector(new (::getServiceContainer()->getReadConnection()));

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ConnectionInterface | $connection,
 |  | array | $logMethods = array( 'beginTransaction', 'commit', 'rollBack', 'forceRollBack', 'exec', 'query', 'execute' )
 | ) |  |
Paramètres
ConnectionInterface $connection Propel connection

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références Propel2Collector\$errors, $message, DataCollector\formatBytes(), DataCollector\formatDuration(), Propel2Collector\getConfig(), DataCollector\getDataFormatter(), Propel2Collector\getHandler(), Propel2Collector\getQueryCount(), Propel2Collector\getStatements(), et null.

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

◆ getConfig()

getConfig ( )
Renvoie
array

Références Propel2Collector\$config.

Référencé par Propel2Collector\collect().

◆ getDefaultLogger()

getDefaultLogger ( )
protected
Renvoie
LoggerInterface

Référencé par Propel2Collector\getName().

◆ getHandler()

getHandler ( )
Renvoie
TestHandler|null

Références Propel2Collector\$handler.

Référencé par Propel2Collector\collect().

◆ getLogger()

getLogger ( )
Renvoie
Logger|null

Références Propel2Collector\$logger.

Référencé par Propel2Collector\getName().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Références Propel2Collector\getDefaultLogger(), et Propel2Collector\getLogger().

Référencé par Propel2Collector\getWidgets().

◆ getQueryCount()

getQueryCount ( )
protected
Renvoie
int

Références Propel2Collector\$queryCount.

Référencé par Propel2Collector\collect().

◆ getStatements()

getStatements | ( | $records,
 |  | $config
 | ) |
protected
Paramètres
array | $records
array | $config
Renvoie
array

Références Propel2Collector\$config, $i, $key, $message, $parameters, $suffix, $value, DataCollector\formatBytes(), DataCollector\formatDuration(), DataCollector\getDataFormatter(), LogLevel\INFO, et null.

Référencé par Propel2Collector\collect().

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Références Propel2Collector\getName().

Documentation des champs

◆ $config

$config = array()
protected

Référencé par Propel2Collector\getConfig(), et Propel2Collector\getStatements().

◆ $errors

$errors = array()
protected

Référencé par Propel2Collector\collect().

◆ $handler

$handler = null
protected

Référencé par Propel2Collector\getHandler().

◆ $logger

$logger = null
protected

Référencé par Propel2Collector\getLogger().

◆ $queryCount

$queryCount = 0
protected

Référencé par Propel2Collector\getQueryCount().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Propel2Collector.php


Joomla CMS: Référence de la classe PropelCollector

  • DebugBar
  • Bridge
  • PropelCollector
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PropelCollector
+ Graphe d'héritage de PropelCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (LoggerInterface $logger=null, PropelPDO $conn=null)
setLogQueriesToLogger ($enable=true)
isLogQueriesToLogger ()
emergency ($m)
alert ($m)
crit ($m)
err ($m)
warning ($m)
notice ($m)
info ($m)
debug ($m)
log ($message, $severity=null)
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres publiques statiques

static | enablePropelProfiling (PropelConfiguration $config=null)
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Fonctions membres protégées

convertLogLevel ($level)
parseAndLogSqlQuery ($message)

Attributs protégés

$logger
$statements = array()
$accumulatedTime = 0
$peakMemory = 0
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

A Propel logger which acts as a data collector

http://propelorm.org/

Will log queries and display them using the SQLQueries widget. You can provide a LoggerInterface object to forward non-query related message to.

Example: $debugbar->addCollector(new PropelCollector($debugbar['messages'])); PropelCollector::enablePropelProfiling();

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | LoggerInterface | $logger = null,
 |  | PropelPDO | $conn = null
 | ) |  |
Paramètres
LoggerInterface | $logger | A logger to forward non-query log lines to
PropelPDO | $conn | Bound this collector to a connection only

Références PropelCollector\$logger, $this, et Psr\Log\setLogger().

Documentation des fonctions membres

◆ alert()

alert ( $m )

Références PropelCollector\log().

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références DataCollector\formatBytes(), et DataCollector\formatDuration().

◆ convertLogLevel()

convertLogLevel ( $level )
protected

Converts Propel log levels to PSR log levels

Paramètres
int $level
Renvoie
string

Références LogLevel\ALERT, LogLevel\CRITICAL, LogLevel\DEBUG, LogLevel\EMERGENCY, LogLevel\ERROR, LogLevel\NOTICE, et LogLevel\WARNING.

Référencé par PropelCollector\log().

◆ crit()

crit ( $m )

Références PropelCollector\log().

◆ debug()

debug ( $m )

Références PropelCollector\log().

◆ emergency()

emergency ( $m )

Références PropelCollector\log().

◆ enablePropelProfiling()

static enablePropelProfiling ( PropelConfiguration $config = null )
static

Sets the needed configuration option in propel to enable query logging

Paramètres
PropelConfiguration $config Apply profiling on a specific config

Références $config, et null.

◆ err()

err ( $m )

Références PropelCollector\log().

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
  • inline_css: an array map of content ID to inline CSS content (not including <style> tag)
  • inline_js: an array map of content ID to inline JS content (not including <script> tag)
  • inline_head: an array map of content ID to arbitrary inline HTML content (typically <style>/<script> tags); it must be embedded within the <head> element

All keys are optional.

Ideally, you should store static assets in filenames that are returned via the normal css/js keys. However, the inline asset elements are useful when integrating with 3rd-party libraries that require static assets that are only available in an inline format.

The inline content arrays require special string array keys: the caller of this function will use them to deduplicate content. This is particularly useful if multiple instances of the same asset provider are used. Inline assets from all collectors are merged together into the same array, so these content IDs effectively deduplicate the inline assets.

Renvoie
array

Implémente AssetProvider.

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémente Renderable.

◆ info()

info ( $m )

Références PropelCollector\log().

◆ isLogQueriesToLogger()

isLogQueriesToLogger ( )

◆ log()

log | ( | $message,
 |  | $severity = null
 | ) |

Références $message, $sql, PropelCollector\convertLogLevel(), null, et PropelCollector\parseAndLogSqlQuery().

Référencé par PropelCollector\alert(), PropelCollector\crit(), PropelCollector\debug(), PropelCollector\emergency(), PropelCollector\err(), PropelCollector\info(), PropelCollector\notice(), et PropelCollector\warning().

◆ notice()

notice ( $m )

Références PropelCollector\log().

◆ parseAndLogSqlQuery()

parseAndLogSqlQuery ( $message )
protected

Parse a log line to extract query information

Paramètres
string $message

Références $message, $parts, $sql, elseif, DataCollector\formatBytes(), et DataCollector\formatDuration().

Référencé par PropelCollector\log().

◆ setLogQueriesToLogger()

setLogQueriesToLogger ( $enable = true )

Références $this.

◆ warning()

warning ( $m )

Références PropelCollector\log().

Documentation des champs

◆ $accumulatedTime

$accumulatedTime = 0
protected

◆ $logger

$logger
protected

Référencé par PropelCollector\__construct().

◆ $peakMemory

$peakMemory = 0
protected

◆ $statements

$statements = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PropelCollector.php


Joomla CMS: Référence de la classe SlimCollector

  • DebugBar
  • Bridge
  • SlimCollector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SlimCollector
+ Graphe d'héritage de SlimCollector:
MessagesCollector AbstractLogger DataCollectorInterface MessagesAggregateInterface Renderable AssetProvider LoggerInterface

Fonctions membres publiques

__construct (Slim $slim)
write ($message, $level)
getName ()
- Fonctions membres publiques hérités de MessagesCollector
__construct ($name='messages')
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
addMessage ($message, $label='info', $isString=true)
aggregate (MessagesAggregateInterface $messages)
getMessages ()
log ($level, $message, array $context=array())
interpolate ($message, array $context=array())
clear ()
collect ()
getName ()
getAssets ()
getWidgets ()
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Fonctions membres protégées

getLevelName ($level)

Attributs protégés

$slim
$originalLogWriter
- Attributs protégés hérités de MessagesCollector
$name
$messages = array()
$aggregates = array()
$dataFormater
$varDumper
$useHtmlVarDumper = false

Description détaillée

Collects messages from a Slim logger

http://slimframework.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Slim $slim )

Références SlimCollector\$slim, et $this.

Documentation des fonctions membres

◆ getLevelName()

getLevelName ( $level )
protected

Références LogLevel\ALERT, LogLevel\CRITICAL, LogLevel\DEBUG, LogLevel\EMERGENCY, LogLevel\ERROR, LogLevel\INFO, LogLevel\NOTICE, et LogLevel\WARNING.

Référencé par SlimCollector\write().

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ write()

write | ( | $message,
 |  | $level
 | ) |

Références $message, MessagesCollector\addMessage(), et SlimCollector\getLevelName().

Documentation des champs

◆ $originalLogWriter

$originalLogWriter
protected

◆ $slim

$slim
protected

Référencé par SlimCollector\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SlimCollector.php


Joomla CMS: Référence de la classe TwigProfileCollector

  • DebugBar
  • Bridge
  • TwigProfileCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe TwigProfileCollector
+ Graphe d'héritage de TwigProfileCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (\Twig_Profiler_Profile $profile, $loaderOrEnv=null)
getWidgets ()
getAssets ()
collect ()
getName ()
getHtmlCallGraph ()
getXdebugLink ($template, $line=1)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

computeData (\Twig_Profiler_Profile $profile)

Attributs privés

$profile
$loader
$templateCount
$blockCount
$macroCount
$templates

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

Collects data about rendered templates

http://twig.sensiolabs.org/

A Twig_Extension_Profiler should be added to your Twig_Environment The root-Twig_Profiler_Profile-object should then be injected into this collector

you can optionally provide the Twig_Environment or the Twig_Loader to also create debug-links.

Voir également
,

$env = new Twig_Environment($loader); // Or from a PSR11-container $profile = new Twig_Profiler_Profile(); $env->addExtension(new Twig_Extension_Profile($profile)); $debugbar->addCollector(new TwigProfileCollector($profile, $env)); // or: $debugbar->addCollector(new TwigProfileCollector($profile, $loader));

Obsolète:
Use \Debugbar\Bridge\NamespacedTwigProfileCollector instead for Twig 2.x and 3.x

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Twig_Profiler_Profile | $profile,
 |  |  | $loaderOrEnv = null
 | ) |  |

TwigProfileCollector constructor.

Paramètres
\Twig_Profiler_Profile | $profile
\Twig_LoaderInterface | \Twig_Environment | $loaderOrEnv

Références TwigProfileCollector\$profile.

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références TwigProfileCollector\computeData(), DataCollector\getDataFormatter(), et TwigProfileCollector\getHtmlCallGraph().

◆ computeData()

computeData ( \Twig_Profiler_Profile $profile )
private

Références TwigProfileCollector\$profile, DataCollector\getDataFormatter(), et TwigProfileCollector\getXdebugLink().

Référencé par TwigProfileCollector\collect().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

◆ getHtmlCallGraph()

getHtmlCallGraph ( )

Référencé par TwigProfileCollector\collect().

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémente Renderable.

◆ getXdebugLink()

getXdebugLink | ( | $template,
 |  | $line = 1
 | ) |

Références $template, et null.

Référencé par TwigProfileCollector\computeData().

Documentation des champs

◆ $blockCount

$blockCount
private

◆ $loader

$loader
private

◆ $macroCount

$macroCount
private

◆ $profile

$profile
private

Référencé par TwigProfileCollector\__construct(), et TwigProfileCollector\computeData().

◆ $templateCount

$templateCount
private

◆ $templates

$templates
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TwigProfileCollector.php


Joomla CMS: Référence de la classe PDOCollector

  • DebugBar
  • DataCollector
  • PDO
  • PDOCollector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PDOCollector
+ Graphe d'héritage de PDOCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

__construct (\PDO $pdo=null, TimeDataCollector $timeCollector=null)
setRenderSqlWithParams ($enabled=true, $quotationChar='<>')
isSqlRenderedWithParams ()
getSqlQuotationChar ()
addConnection (\PDO $pdo, $name=null)
getConnections ()
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres protégées

collectPDO (TraceablePDO $pdo, TimeDataCollector $timeCollector=null, $connectionName=null)

Attributs protégés

$connections = array()
$timeCollector
$renderSqlWithParams = false
$sqlQuotationChar = '<>'
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects data about SQL statements executed with PDO

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \PDO | $pdo = null,
 |  | TimeDataCollector | $timeCollector = null
 | ) |  |
Paramètres
\PDO | $pdo
TimeDataCollector | $timeCollector

Références PDOCollector\$timeCollector, PDOCollector\addConnection(), et null.

Documentation des fonctions membres

◆ addConnection()

addConnection | ( | \PDO | $pdo,
 |  |  | $name = null
 | ) |  |

Adds a new PDO instance to be collector

Paramètres
TraceablePDO | $pdo
string | $name | Optional connection name

Références $name, et null.

Référencé par PDOCollector\__construct().

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références $data, $name, PDOCollector\collectPDO(), et DataCollector\getDataFormatter().

◆ collectPDO()

collectPDO | ( | TraceablePDO | $pdo,
 |  | TimeDataCollector | $timeCollector = null,
 |  |  | $connectionName = null
 | ) |  |
protected

Collects data from a single TraceablePDO instance

Paramètres
TraceablePDO | $pdo
TimeDataCollector | $timeCollector
string | null | $connectionName | the pdo connection (eg default | read | write)
Renvoie
array

Références $this, PDOCollector\$timeCollector, TraceablePDO\getAccumulatedStatementsDuration(), DataCollector\getDataFormatter(), TraceablePDO\getExecutedStatements(), TraceablePDO\getFailedExecutedStatements(), TraceablePDO\getMemoryUsage(), TraceablePDO\getPeakMemoryUsage(), et null.

Référencé par PDOCollector\collect().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

◆ getConnections()

getConnections ( )

Returns PDO instances to be collected

Renvoie
array

Références PDOCollector\$connections.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getSqlQuotationChar()

getSqlQuotationChar ( )
Renvoie
string

Références PDOCollector\$sqlQuotationChar.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

◆ isSqlRenderedWithParams()

isSqlRenderedWithParams ( )
Renvoie
bool

Références PDOCollector\$renderSqlWithParams.

◆ setRenderSqlWithParams()

setRenderSqlWithParams | ( | $enabled = true,
 |  | $quotationChar = '<>'
 | ) |

Renders the SQL of traced statements with params embeded

Paramètres
boolean $enabled

Références $enabled.

Documentation des champs

◆ $connections

$connections = array()
protected

Référencé par PDOCollector\getConnections().

◆ $renderSqlWithParams

$renderSqlWithParams = false
protected

Référencé par PDOCollector\isSqlRenderedWithParams().

◆ $sqlQuotationChar

$sqlQuotationChar = '<>'
protected

Référencé par PDOCollector\getSqlQuotationChar().

◆ $timeCollector

$timeCollector
protected

Référencé par PDOCollector\__construct(), et PDOCollector\collectPDO().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PDOCollector.php


Joomla CMS: Référence de la classe TraceablePDO

  • DebugBar
  • DataCollector
  • PDO
  • TraceablePDO
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TraceablePDO
+ Graphe d'héritage de TraceablePDO:

Fonctions membres publiques

__construct (PDO $pdo)
beginTransaction ()
commit ()
errorCode ()
errorInfo ()
exec ($statement)
getAttribute ($attribute)
inTransaction ()
lastInsertId ($name=null)
prepare ($statement, $driver_options=[])
query ($statement, $fetchMode=null,... $fetchModeArgs)
quote ($string, $parameter_type=PDO::PARAM_STR)
rollBack ()
setAttribute ($attribute, $value)
addExecutedStatement (TracedStatement $stmt)
getAccumulatedStatementsDuration ()
getMemoryUsage ()
getPeakMemoryUsage ()
getExecutedStatements ()
getFailedExecutedStatements ()
__get ($name)
__set ($name, $value)
__call ($name, $args)

Fonctions membres protégées

profileCall ($method, $sql, array $args)

Attributs protégés

$pdo
$executedStatements = []

Description détaillée

A PDO proxy which traces statements

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( PDO $pdo )

Références TraceablePDO\$pdo, $this, et class.

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $args
 | ) |
Paramètres
$name
$args
Renvoie
mixed

Références $name.

Référencé par TraceablePDO\profileCall().

◆ __get()

__get ( $name )
Paramètres
$name
Renvoie
mixed

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |
Paramètres
$name
$value

Références $value.

◆ addExecutedStatement()

addExecutedStatement ( TracedStatement $stmt )

Adds an executed TracedStatement

Paramètres
TracedStatement $stmt

Référencé par TraceablePDO\profileCall().

◆ beginTransaction()

beginTransaction ( )

Initiates a transaction

bool TRUE on success or FALSE on failure.

◆ commit()

commit ( )

Commits a transaction

bool TRUE on success or FALSE on failure.

◆ errorCode()

errorCode ( )

Fetch extended error information associated with the last operation on the database handle

array PDO::errorInfo returns an array of error information

◆ errorInfo()

errorInfo ( )

Fetch extended error information associated with the last operation on the database handle

array PDO::errorInfo returns an array of error information

◆ exec()

exec ( $statement )

Execute an SQL statement and return the number of affected rows

string $statement int|bool PDO::exec returns the number of rows that were modified or deleted by the SQL statement you issued. If no rows were affected, PDO::exec returns 0. This function may return Boolean FALSE, but may also return a non-Boolean value which evaluates to FALSE. Please read the section on Booleans for more information

Références TraceablePDO\profileCall().

◆ getAccumulatedStatementsDuration()

getAccumulatedStatementsDuration ( )

Returns the accumulated execution time of statements

Renvoie
int

Référencé par PDOCollector\collectPDO().

◆ getAttribute()

getAttribute ( $attribute )

Retrieve a database connection attribute

int $attribute One of the PDO::ATTR_* constants mixed A successful call returns the value of the requested PDO attribute. An unsuccessful call returns null.

◆ getExecutedStatements()

getExecutedStatements ( )

Returns the list of executed statements as TracedStatement objects

Renvoie
TracedStatement[]

Références TraceablePDO\$executedStatements.

Référencé par PDOCollector\collectPDO().

◆ getFailedExecutedStatements()

getFailedExecutedStatements ( )

Returns the list of failed statements

Renvoie
TracedStatement[]

Référencé par PDOCollector\collectPDO().

◆ getMemoryUsage()

getMemoryUsage ( )

Returns the peak memory usage while performing statements

Renvoie
int

Référencé par PDOCollector\collectPDO().

◆ getPeakMemoryUsage()

getPeakMemoryUsage ( )

Returns the peak memory usage while performing statements

Renvoie
int

Référencé par PDOCollector\collectPDO().

◆ inTransaction()

inTransaction ( )

Checks if inside a transaction

bool TRUE if a transaction is currently active, and FALSE if not.

◆ lastInsertId()

lastInsertId ( $name = null )

Returns the ID of the last inserted row or sequence value

string $name [optional] string If a sequence name was not specified for the name parameter, PDO::lastInsertId returns a string representing the row ID of the last row that was inserted into the database.

Références $name.

◆ prepare()

prepare | ( | $statement,
 |  | $driver_options = []
 | ) |

Prepares a statement for execution and returns a statement object

string $statement This must be a valid SQL statement template for the target DB server. array $driver_options [optional] This array holds one or more key=>value pairs to set attribute values for the PDOStatement object that this method returns. TraceablePDOStatement|bool If the database server successfully prepares the statement, PDO::prepare returns a PDOStatement object. If the database server cannot successfully prepare the statement, PDO::prepare returns FALSE or emits PDOException (depending on error handling).

◆ profileCall()

profileCall | ( |  | $method,
 |  |  | $sql,
 |  | array | $args
 | ) |  |
protected

Profiles a call to a PDO method

Paramètres
string | $method
string | $sql
array | $args
Renvoie
mixed The result of the call

Références $method, $result, $sql, TraceablePDO\__call(), TraceablePDO\addExecutedStatement(), et null.

Référencé par TraceablePDO\exec(), et TraceablePDO\query().

◆ query()

query | ( | $statement,
 |  | $fetchMode = null,
 |  | $fetchModeArgs
 | ) |

Executes an SQL statement, returning a result set as a PDOStatement object

string $statement int $fetchMode mixed ...$fetchModeArgs TraceablePDOStatement|bool PDO::query returns a PDOStatement object, or FALSE on failure.

Références TraceablePDO\profileCall().

◆ quote()

quote | ( | $string,
 |  | $parameter_type = PDO::PARAM_STR
 | ) |

Quotes a string for use in a query.

string $string The string to be quoted. int $parameter_type [optional] Provides a data type hint for drivers that have alternate quoting styles. string|bool A quoted string that is theoretically safe to pass into an SQL statement. Returns FALSE if the driver does not support quoting in this way.

◆ rollBack()

rollBack ( )

Rolls back a transaction

bool TRUE on success or FALSE on failure.

◆ setAttribute()

setAttribute | ( | $attribute,
 |  | $value
 | ) |

Set an attribute

int $attribute mixed $value bool TRUE on success or FALSE on failure.

Références $value.

Documentation des champs

◆ $executedStatements

$executedStatements = []
protected

Référencé par TraceablePDO\getExecutedStatements().

◆ $pdo

$pdo
protected

Référencé par TraceablePDO\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TraceablePDO.php


Joomla CMS: Référence de la classe TraceablePDOStatement

  • DebugBar
  • DataCollector
  • PDO
  • TraceablePDOStatement
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TraceablePDOStatement
+ Graphe d'héritage de TraceablePDOStatement:

Fonctions membres publiques

bindColumn ($column, &$param, $type=null, $maxlen=null, $driverdata=null)
bindParam ($parameter, &$variable, $data_type=PDO::PARAM_STR, $length=null, $driver_options=null)
bindValue ($parameter, $value, $data_type=PDO::PARAM_STR)
execute ($input_parameters=null)

Fonctions membres protégées

__construct (TraceablePDO $pdo)

Attributs protégés

$pdo
$boundParameters = []

Description détaillée

A traceable PDO statement to use with Traceablepdo

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( TraceablePDO $pdo )
protected

TraceablePDOStatement constructor.

Paramètres
TraceablePDO $pdo

Références TraceablePDOStatement\$pdo.

Documentation des fonctions membres

◆ bindColumn()

bindColumn | ( |  | $column,
 |  | & | $param,
 |  |  | $type = null,
 |  |  | $maxlen = null,
 |  |  | $driverdata = null
 | ) |  |

Bind a column to a PHP variable

mixed $column Number of the column (1-indexed) or name of the column in the result set mixed $param Name of the PHP variable to which the column will be bound. int $type [optional] Data type of the parameter, specified by the PDO::PARAM_* constants. int $maxlen [optional] A hint for pre-allocation. mixed $driverdata [optional] Optional parameter(s) for the driver. bool TRUE on success or FALSE on failure.

◆ bindParam()

bindParam | ( |  | $parameter,
 |  | & | $variable,
 |  |  | $data_type = PDO::PARAM_STR,
 |  |  | $length = null,
 |  |  | $driver_options = null
 | ) |  |

Binds a parameter to the specified variable name

mixed $parameter Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter. mixed $variable Name of the PHP variable to bind to the SQL statement parameter. int $data_type [optional] Explicit data type for the parameter using the PDO::PARAM_* constants. int $length [optional] Length of the data type. To indicate that a parameter is an OUT parameter from a stored procedure, you must explicitly set the length. mixed $driver_options [optional] bool TRUE on success or FALSE on failure.

◆ bindValue()

bindValue | ( | $parameter,
 |  | $value,
 |  | $data_type = PDO::PARAM_STR
 | ) |

Binds a value to a parameter

mixed $parameter Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter. mixed $value The value to bind to the parameter. int $data_type [optional] Explicit data type for the parameter using the PDO::PARAM_* constants. bool TRUE on success or FALSE on failure.

Références $value.

◆ execute()

execute ( $input_parameters = null )

Executes a prepared statement

array $input_parameters [optional] An array of values with as many elements as there are bound parameters in the SQL statement being executed. All values are treated as PDO::PARAM_STR. PDOException bool TRUE on success or FALSE on failure.

Références TraceablePDOStatement\$boundParameters, $result, $this, et null.

Documentation des champs

◆ $boundParameters

$boundParameters = []
protected

Référencé par TraceablePDOStatement\execute().

◆ $pdo

$pdo
protected

Référencé par TraceablePDOStatement\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TraceablePDOStatement.php


Joomla CMS: Référence de la classe TracedStatement

  • DebugBar
  • DataCollector
  • PDO
  • TracedStatement
Fonctions membres publiques | Attributs protégés
Référence de la classe TracedStatement

Fonctions membres publiques

__construct ($sql, array $params=[], $preparedId=null)
start ($startTime=null, $startMemory=null)
end (\Exception $exception=null, $rowCount=0, $endTime=null, $endMemory=null)
checkParameters ($params)
getSql ()
getSqlWithParams ($quotationChar='<>')
getRowCount ()
getParameters ()
getPreparedId ()
isPrepared ()
getStartTime ()
getEndTime ()
getDuration ()
getStartMemory ()
getEndMemory ()
getMemoryUsage ()
isSuccess ()
getException ()
getErrorCode ()
getErrorMessage ()

Attributs protégés

$sql
$rowCount
$parameters
$startTime
$endTime
$duration
$startMemory
$endMemory
$memoryDelta
$exception

Description détaillée

Holds information about a statement

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $sql,
 |  | array | $params = [],
 |  |  | $preparedId = null
 | ) |  |
Paramètres
string | $sql
array | $params
string | $preparedId

Références $params, TracedStatement\$sql, et TracedStatement\checkParameters().

Documentation des fonctions membres

◆ checkParameters()

checkParameters ( $params )

Check parameters for illegal (non UTF-8) strings, like Binary data.

Paramètres
array $params
Renvoie
array

Références $params.

Référencé par TracedStatement\__construct().

◆ end()

end | ( | \Exception | $exception = null,
 |  |  | $rowCount = 0,
 |  |  | $endTime = null,
 |  |  | $endMemory = null
 | ) |  |
Paramètres
\Exception | null | $exception
int | $rowCount
float | $endTime
int | $endMemory

Références TracedStatement\$endMemory, TracedStatement\$endTime, TracedStatement\$exception, TracedStatement\$rowCount, TracedStatement\$startMemory, et TracedStatement\$startTime.

◆ getDuration()

getDuration ( )

Returns the duration in seconds + microseconds of the execution

Renvoie
float

Références TracedStatement\$duration.

◆ getEndMemory()

getEndMemory ( )
Renvoie
int

Références TracedStatement\$endMemory.

◆ getEndTime()

getEndTime ( )
Renvoie
float

Références TracedStatement\$endTime.

◆ getErrorCode()

getErrorCode ( )

Returns the exception's code

Renvoie
int|string

Références null.

◆ getErrorMessage()

getErrorMessage ( )

Returns the exception's message

Renvoie
string

Références null.

◆ getException()

getException ( )

Returns the exception triggered

Renvoie

Références TracedStatement\$exception.

◆ getMemoryUsage()

getMemoryUsage ( )

Returns the memory usage during the execution

Renvoie
int

Références TracedStatement\$memoryDelta.

◆ getParameters()

getParameters ( )

Returns an array of parameters used with the query

Renvoie
array

Références $name, $params, et ENT_QUOTES.

◆ getPreparedId()

getPreparedId ( )

Returns the prepared statement id

Renvoie
string

◆ getRowCount()

getRowCount ( )

Returns the number of rows affected/returned

Renvoie
int

Références TracedStatement\$rowCount.

◆ getSql()

getSql ( )

Returns the SQL string used for the query, without filled parameters

Renvoie
string

Références TracedStatement\$sql.

◆ getSqlWithParams()

getSqlWithParams ( $quotationChar = '<>' )

Returns the SQL string with any parameters used embedded

Paramètres
string $quotationChar
Renvoie
string

Références $i, et TracedStatement\$sql.

◆ getStartMemory()

getStartMemory ( )
Renvoie
int

Références TracedStatement\$startMemory.

◆ getStartTime()

getStartTime ( )
Renvoie
float

Références TracedStatement\$startTime.

◆ isPrepared()

isPrepared ( )

Checks if this is a prepared statement

Renvoie
boolean

Références null.

◆ isSuccess()

isSuccess ( )

Checks if the statement was successful

Renvoie
boolean

Références null.

◆ start()

start | ( | $startTime = null,
 |  | $startMemory = null
 | ) |
Paramètres
null | $startTime
null | $startMemory

Références TracedStatement\$startMemory, et TracedStatement\$startTime.

Documentation des champs

◆ $duration

$duration
protected

Référencé par TracedStatement\getDuration().

◆ $endMemory

$endMemory
protected

Référencé par TracedStatement\end(), et TracedStatement\getEndMemory().

◆ $endTime

$endTime
protected

Référencé par TracedStatement\end(), et TracedStatement\getEndTime().

◆ $exception

$exception
protected

Référencé par TracedStatement\end(), et TracedStatement\getException().

◆ $memoryDelta

$memoryDelta
protected

Référencé par TracedStatement\getMemoryUsage().

◆ $parameters

$parameters
protected

◆ $rowCount

$rowCount
protected

Référencé par TracedStatement\end(), et TracedStatement\getRowCount().

◆ $sql

$sql
protected

Référencé par TracedStatement\__construct(), TracedStatement\getSql(), et TracedStatement\getSqlWithParams().

◆ $startMemory

$startMemory
protected

Référencé par TracedStatement\end(), TracedStatement\getStartMemory(), et TracedStatement\start().

◆ $startTime

$startTime
protected

Référencé par TracedStatement\end(), TracedStatement\getStartTime(), et TracedStatement\start().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TracedStatement.php


Joomla CMS: Référence de la classe AggregatedCollector

  • DebugBar
  • DataCollector
  • AggregatedCollector
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AggregatedCollector
+ Graphe d'héritage de AggregatedCollector:
DataCollectorInterface

Fonctions membres publiques

__construct ($name, $mergeProperty=null, $sort=false)
addCollector (DataCollectorInterface $collector)
getCollectors ()
setMergeProperty ($property)
getMergeProperty ()
setSort ($sort)
getSort ()
collect ()
getName ()
offsetSet ($key, $value)
offsetGet ($key)
offsetExists ($key)
offsetUnset ($key)

Fonctions membres protégées

sort ($data)

Attributs protégés

$name
$mergeProperty
$sort
$collectors = array()

Description détaillée

Aggregates data from multiple collectors

$aggcollector = new AggregateCollector('foobar'); $aggcollector->addCollector(new MessagesCollector('msg1')); $aggcollector->addCollector(new MessagesCollector('msg2')); $aggcollector['msg1']->addMessage('hello world');

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $name,
 |  | $mergeProperty = null,
 |  | $sort = false
 | ) |
Paramètres
string | $name
string | $mergeProperty
boolean | $sort

Références AggregatedCollector\$mergeProperty, AggregatedCollector\$name, AggregatedCollector\$sort, name, et AggregatedCollector\sort().

Documentation des fonctions membres

◆ addCollector()

addCollector ( DataCollectorInterface $collector )
Paramètres
DataCollectorInterface $collector

Références DataCollectorInterface\getName().

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références $data, AggregatedCollector\$mergeProperty, null, et AggregatedCollector\sort().

◆ getCollectors()

getCollectors ( )
Renvoie
array

Références AggregatedCollector\$collectors.

◆ getMergeProperty()

getMergeProperty ( )
Renvoie
string

Références AggregatedCollector\$mergeProperty.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Références AggregatedCollector\$name.

◆ getSort()

getSort ( )
Renvoie
bool|string

Références AggregatedCollector\$sort.

◆ offsetExists()

offsetExists ( $key )
Paramètres
mixed $key
Renvoie
bool

Références $key.

◆ offsetGet()

offsetGet ( $key )
Paramètres
mixed $key
Renvoie
mixed

Références $key.

◆ offsetSet()

offsetSet | ( | $key,
 |  | $value
 | ) |
Paramètres
mixed | $key
mixed | $value
Exceptions
DebugBarException

◆ offsetUnset()

offsetUnset ( $key )
Paramètres
mixed $key
Exceptions
DebugBarException

◆ setMergeProperty()

setMergeProperty ( $property )

Merge data from one of the key/value pair of the collected data

Paramètres
string $property

◆ setSort()

setSort ( $sort )

Sorts the collected data

If true, sorts using sort() If it is a string, sorts the data using the value from a key/value pair of the array

Paramètres
bool | string $sort

Références AggregatedCollector\$sort, et AggregatedCollector\sort().

◆ sort()

sort ( $data )
protected

Sorts the collected data

Paramètres
array $data
Renvoie
array

Références $b, $data, AggregatedCollector\$sort, et elseif.

Référencé par AggregatedCollector\__construct(), AggregatedCollector\collect(), et AggregatedCollector\setSort().

Documentation des champs

◆ $collectors

$collectors = array()
protected

Référencé par AggregatedCollector\getCollectors().

◆ $mergeProperty

$mergeProperty
protected

Référencé par AggregatedCollector\__construct(), AggregatedCollector\collect(), et AggregatedCollector\getMergeProperty().

◆ $name

$name
protected

Référencé par AggregatedCollector\__construct(), et AggregatedCollector\getName().

◆ $sort

$sort
protected

Référencé par AggregatedCollector\__construct(), AggregatedCollector\getSort(), AggregatedCollector\setSort(), et AggregatedCollector\sort().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AggregatedCollector.php


Joomla CMS: Référence de l'interface AssetProvider

  • DebugBar
  • DataCollector
  • AssetProvider
Fonctions membres publiques
Référence de l'interface AssetProvider
+ Graphe d'héritage de AssetProvider:
DoctrineCollector NamespacedTwigProfileCollector Propel2Collector PropelCollector SwiftMailCollector TwigCollector TwigProfileCollector ConfigCollector MessagesCollector PDOCollector RequestDataCollector DebugBarVarDumper InfoCollector LanguageErrorsCollector LanguageFilesCollector LanguageStringsCollector QueryCollector

Fonctions membres publiques

getAssets ()

Description détaillée

Indicates that a DataCollector provides some assets

Documentation des fonctions membres

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
  • inline_css: an array map of content ID to inline CSS content (not including <style> tag)
  • inline_js: an array map of content ID to inline JS content (not including <script> tag)
  • inline_head: an array map of content ID to arbitrary inline HTML content (typically <style>/<script> tags); it must be embedded within the <head> element

All keys are optional.

Ideally, you should store static assets in filenames that are returned via the normal css/js keys. However, the inline asset elements are useful when integrating with 3rd-party libraries that require static assets that are only available in an inline format.

The inline content arrays require special string array keys: the caller of this function will use them to deduplicate content. This is particularly useful if multiple instances of the same asset provider are used. Inline assets from all collectors are merged together into the same array, so these content IDs effectively deduplicate the inline assets.

Renvoie
array

Implémenté dans Propel2Collector, DebugBarVarDumper, MessagesCollector, PropelCollector, PDOCollector, QueryCollector, LanguageFilesCollector, NamespacedTwigProfileCollector, LanguageErrorsCollector, DoctrineCollector, TwigProfileCollector, InfoCollector, LanguageStringsCollector, ConfigCollector, SwiftMailCollector, TwigCollector, et RequestDataCollector.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AssetProvider.php


Joomla CMS: Référence de la classe ConfigCollector

  • DebugBar
  • DataCollector
  • ConfigCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe ConfigCollector
+ Graphe d'héritage de ConfigCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
__construct (array $data=array(), $name='config')
setData (array $data)
collect ()
getName ()
getAssets ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$name
$data
$useHtmlVarDumper = false
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects array data

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $data = array(),
 |  |  | $name = 'config'
 | ) |  |
Paramètres
array | $data
string | $name

Références ConfigCollector\$data, ConfigCollector\$name, et name.

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références ConfigCollector\$data, DataCollector\getDataFormatter(), DataCollector\getVarDumper(), et ConfigCollector\isHtmlVarDumperUsed().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

Références DataCollector\getVarDumper(), et ConfigCollector\isHtmlVarDumperUsed().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Références ConfigCollector\$name.

Référencé par ConfigCollector\getWidgets().

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Références ConfigCollector\$name, ConfigCollector\getName(), et ConfigCollector\isHtmlVarDumperUsed().

◆ isHtmlVarDumperUsed()

isHtmlVarDumperUsed ( )

Indicates whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Renvoie
mixed

Références ConfigCollector\$useHtmlVarDumper.

Référencé par ConfigCollector\collect(), ConfigCollector\getAssets(), et ConfigCollector\getWidgets().

◆ setData()

setData ( array $data )

Sets the data

Paramètres
array $data

Références ConfigCollector\$data.

◆ useHtmlVarDumper()

useHtmlVarDumper ( $value = true )

Sets a flag indicating whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Paramètres
bool $value
Renvoie
$this

Références $this, et $value.

Documentation des champs

◆ $data

$data
protected

Référencé par ConfigCollector\__construct(), ConfigCollector\collect(), et ConfigCollector\setData().

◆ $name

$name
protected

Référencé par ConfigCollector\__construct(), ConfigCollector\getName(), et ConfigCollector\getWidgets().

◆ $useHtmlVarDumper

$useHtmlVarDumper = false
protected

Référencé par ConfigCollector\isHtmlVarDumperUsed().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigCollector.php


Joomla CMS: Référence de la classe DataCollector

  • DebugBar
  • DataCollector
  • DataCollector
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés statiques
Référence de la classe DataCollector
+ Graphe d'héritage de DataCollector:
DataCollectorInterface DoctrineCollector NamespacedTwigProfileCollector Propel2Collector PropelCollector SwiftMailCollector TwigCollector TwigProfileCollector ConfigCollector ExceptionsCollector LocalizationCollector MemoryCollector PDOCollector PhpInfoCollector RequestDataCollector TimeDataCollector AbstractDataCollector

Fonctions membres publiques

setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)
- Fonctions membres publiques hérités de DataCollectorInterface
collect ()
getName ()

Fonctions membres publiques statiques

static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Attributs protégés

$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Attributs privés statiques

static | $defaultDataFormatter
static | $defaultVarDumper

Description détaillée

Abstract class for data collectors

Documentation des fonctions membres

◆ formatBytes()

formatBytes | ( | $size,
 |  | $precision = 2
 | ) |
Obsolète:

Références $size, et DataCollector\getDataFormatter().

Référencé par MemoryCollector\collect(), PropelCollector\collect(), Propel2Collector\collect(), Propel2Collector\getStatements(), et PropelCollector\parseAndLogSqlQuery().

◆ formatDuration()

formatDuration ( $seconds )
Obsolète:

Références DataCollector\getDataFormatter().

Référencé par TimeDataCollector\addMeasure(), TwigCollector\collect(), DoctrineCollector\collect(), TimeDataCollector\collect(), PropelCollector\collect(), Propel2Collector\collect(), Propel2Collector\getStatements(), et PropelCollector\parseAndLogSqlQuery().

◆ formatVar()

formatVar ( $var )
Obsolète:

Références DataCollector\getDataFormatter().

◆ getDataFormatter()

getDataFormatter ( )
Renvoie
DataFormatterInterface

Références DataCollector\$dataFormater, et null.

Référencé par TimeDataCollector\addMeasure(), ProfileCollector\addMeasure(), SessionCollector\collect(), RequestDataCollector\collect(), MemoryCollector\collect(), ConfigCollector\collect(), PDOCollector\collect(), QueryCollector\collect(), TwigProfileCollector\collect(), NamespacedTwigProfileCollector\collect(), TimeDataCollector\collect(), Propel2Collector\collect(), ProfileCollector\collect(), PDOCollector\collectPDO(), TwigProfileCollector\computeData(), NamespacedTwigProfileCollector\computeData(), DataCollector\formatBytes(), DataCollector\formatDuration(), DataCollector\formatVar(), Propel2Collector\getStatements(), et QueryCollector\getStatements().

◆ getDefaultDataFormatter()

static getDefaultDataFormatter ( )
static

Returns the default data formater

Renvoie
DataFormatterInterface

Références null.

Référencé par MessagesCollector\getDataFormatter().

◆ getDefaultVarDumper()

static getDefaultVarDumper ( )
static

Returns the default variable dumper

Renvoie
DebugBarVarDumper

Références null.

Référencé par MessagesCollector\getVarDumper().

◆ getVarDumper()

getVarDumper ( )

Gets the variable dumper instance used by this collector; note that collectors using this instance need to be sure to return the static assets provided by the variable dumper.

Renvoie
DebugBarVarDumper

Références DataCollector\$varDumper, et null.

Référencé par RequestDataCollector\collect(), ConfigCollector\collect(), ExceptionsCollector\formatThrowableData(), RequestDataCollector\getAssets(), et ConfigCollector\getAssets().

◆ getXdebugLink()

getXdebugLink | ( | $file,
 |  | $line = 1
 | ) |

Références $url, DataCollector\getXdebugLinkTemplate(), et DataCollector\getXdebugShouldUseAjax().

Référencé par ExceptionsCollector\formatThrowableData().

◆ getXdebugLinkTemplate()

getXdebugLinkTemplate ( )
Renvoie
string

Références DataCollector\$xdebugLinkTemplate.

Référencé par LanguageErrorsCollector\collect(), LanguageFilesCollector\collect(), QueryCollector\collect(), LanguageStringsCollector\getData(), et DataCollector\getXdebugLink().

◆ getXdebugReplacements()

getXdebugReplacements ( )

returns an array of filename-replacements

this is useful f.e. when using vagrant or remote servers, where the path of the file is different between server and development environment

Renvoie
array key-value-pairs of replacements, key = path on server, value = replacement

Références DataCollector\$xdebugReplacements.

◆ getXdebugShouldUseAjax()

getXdebugShouldUseAjax ( )
Renvoie
bool

Références DataCollector\$xdebugShouldUseAjax.

Référencé par DataCollector\getXdebugLink().

◆ setDataFormatter()

setDataFormatter ( DataFormatterInterface $formater )

Sets the data formater instance used by this collector

Paramètres
DataFormatterInterface $formater
Renvoie
$this

Références $this.

◆ setDefaultDataFormatter()

static setDefaultDataFormatter ( DataFormatterInterface $formater )
static

Sets the default data formater instance used by all collectors subclassing this class

Paramètres
DataFormatterInterface $formater

◆ setDefaultVarDumper()

static setDefaultVarDumper ( DebugBarVarDumper $varDumper )
static

Sets the default variable dumper used by all collectors subclassing this class

Paramètres
DebugBarVarDumper $varDumper

Références DataCollector\$varDumper.

◆ setVarDumper()

setVarDumper ( DebugBarVarDumper $varDumper )

Sets the variable dumper instance used by this collector

Paramètres
DebugBarVarDumper $varDumper
Renvoie
$this

Références $this, et DataCollector\$varDumper.

◆ setXdebugLinkTemplate()

setXdebugLinkTemplate | ( | $xdebugLinkTemplate,
 |  | $shouldUseAjax = false
 | ) |
Paramètres
string | $xdebugLinkTemplate
bool | $shouldUseAjax

Références DataCollector\$xdebugLinkTemplate.

◆ setXdebugReplacement()

setXdebugReplacement | ( | $serverPath,
 |  | $replacement
 | ) |

◆ setXdebugReplacements()

setXdebugReplacements ( $xdebugReplacements )
Paramètres
array $xdebugReplacements

Références DataCollector\$xdebugReplacements.

Documentation des champs

◆ $dataFormater

$dataFormater
protected

Référencé par DataCollector\getDataFormatter().

◆ $defaultDataFormatter

$defaultDataFormatter
staticprivate

◆ $defaultVarDumper

$defaultVarDumper
staticprivate

◆ $varDumper

$varDumper
protected

Référencé par DataCollector\getVarDumper(), DataCollector\setDefaultVarDumper(), et DataCollector\setVarDumper().

◆ $xdebugLinkTemplate

$xdebugLinkTemplate = ''
protected

Référencé par DataCollector\getXdebugLinkTemplate(), et DataCollector\setXdebugLinkTemplate().

◆ $xdebugReplacements

$xdebugReplacements = array()
protected

Référencé par DataCollector\getXdebugReplacements(), et DataCollector\setXdebugReplacements().

◆ $xdebugShouldUseAjax

$xdebugShouldUseAjax = false
protected

Référencé par DataCollector\getXdebugShouldUseAjax().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DataCollector.php


Joomla CMS: Référence de l'interface DataCollectorInterface

  • DebugBar
  • DataCollector
  • DataCollectorInterface
Fonctions membres publiques
Référence de l'interface DataCollectorInterface
+ Graphe d'héritage de DataCollectorInterface:
MonologCollector AggregatedCollector DataCollector MessagesCollector CacheCacheCollector DoctrineCollector NamespacedTwigProfileCollector Propel2Collector PropelCollector SwiftMailCollector TwigCollector TwigProfileCollector ConfigCollector ExceptionsCollector LocalizationCollector MemoryCollector PDOCollector PhpInfoCollector RequestDataCollector TimeDataCollector AbstractDataCollector SlimCollector SwiftLogCollector

Fonctions membres publiques

collect ()
getName ()

Description détaillée

DataCollector Interface

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémenté dans ProfileCollector, MessagesCollector, Propel2Collector, PropelCollector, TimeDataCollector, NamespacedTwigProfileCollector, InfoCollector, TwigProfileCollector, AggregatedCollector, QueryCollector, ExceptionsCollector, PDOCollector, MonologCollector, ConfigCollector, MemoryCollector, DoctrineCollector, LanguageErrorsCollector, LanguageFilesCollector, RequestDataCollector, LanguageStringsCollector, SessionCollector, LocalizationCollector, TwigCollector, SwiftMailCollector, et PhpInfoCollector.

◆ getName()

getName ( )

Returns the unique name of the collector

Renvoie
string

Implémenté dans ProfileCollector, Propel2Collector, MessagesCollector, PropelCollector, TimeDataCollector, PDOCollector, NamespacedTwigProfileCollector, ExceptionsCollector, TwigProfileCollector, AggregatedCollector, QueryCollector, MonologCollector, ConfigCollector, LanguageFilesCollector, DoctrineCollector, MemoryCollector, CacheCacheCollector, RequestDataCollector, InfoCollector, LanguageErrorsCollector, SwiftMailCollector, SlimCollector, TwigCollector, LanguageStringsCollector, SessionCollector, LocalizationCollector, SwiftLogCollector, et PhpInfoCollector.

Référencé par AggregatedCollector\addCollector(), et DebugBar\addCollector().

La documentation de cette interface a été générée à partir du fichier suivant :
  • DataCollectorInterface.php


Joomla CMS: Référence de la classe ExceptionsCollector

  • DebugBar
  • DataCollector
  • ExceptionsCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe ExceptionsCollector
+ Graphe d'héritage de ExceptionsCollector:
DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

addException (Exception $e)
addThrowable ($e)
setChainExceptions ($chainExceptions=true)
getExceptions ()
useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
collect ()
formatExceptionData (Exception $e)
formatThrowableData ($e)
getName ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$exceptions = array()
$chainExceptions = false
$useHtmlVarDumper = false
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects info about exceptions

Documentation des fonctions membres

◆ addException()

addException ( Exception $e )

Adds an exception to be profiled in the debug bar

Paramètres
Exception $e
Obsolète:
in favor on addThrowable

Références ExceptionsCollector\addThrowable().

◆ addThrowable()

addThrowable ( $e )

Adds a Throwable to be profiled in the debug bar

Paramètres
\Throwable $e

Référencé par ExceptionsCollector\addException().

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Renvoie
array Collected data

Implémente DataCollectorInterface.

Références $this.

◆ formatExceptionData()

formatExceptionData ( Exception $e )

Returns exception data as an array

Paramètres
Exception $e
Renvoie
array
Obsolète:
in favor on formatThrowableData

Références ExceptionsCollector\formatThrowableData().

◆ formatThrowableData()

formatThrowableData ( $e )

Returns Throwable data as an array

Paramètres
\Throwable $e
Renvoie
array

Références $start, DataCollector\getVarDumper(), DataCollector\getXdebugLink(), ExceptionsCollector\isHtmlVarDumperUsed(), et null.

Référencé par ExceptionsCollector\formatExceptionData().

◆ getExceptions()

getExceptions ( )

Returns the list of exceptions being profiled

Renvoie
array[]

Références ExceptionsCollector\$exceptions.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

◆ isHtmlVarDumperUsed()

isHtmlVarDumperUsed ( )

Indicates whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Renvoie
mixed

Références ExceptionsCollector\$useHtmlVarDumper.

Référencé par ExceptionsCollector\formatThrowableData().

◆ setChainExceptions()

setChainExceptions ( $chainExceptions = true )

Configure whether or not all chained exceptions should be shown.

Paramètres
bool $chainExceptions

Références ExceptionsCollector\$chainExceptions.

◆ useHtmlVarDumper()

useHtmlVarDumper ( $value = true )

Sets a flag indicating whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Paramètres
bool $value
Renvoie
$this

Références $this, et $value.

Documentation des champs

◆ $chainExceptions

$chainExceptions = false
protected

Référencé par ExceptionsCollector\setChainExceptions().

◆ $exceptions

$exceptions = array()
protected

Référencé par ExceptionsCollector\getExceptions().

◆ $useHtmlVarDumper

$useHtmlVarDumper = false
protected

Référencé par ExceptionsCollector\isHtmlVarDumperUsed().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExceptionsCollector.php


Joomla CMS: Référence de la classe LocalizationCollector

  • DebugBar
  • DataCollector
  • LocalizationCollector
Fonctions membres publiques
Référence de la classe LocalizationCollector
+ Graphe d'héritage de LocalizationCollector:
DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

getLocale ()
getDomain ()
collect ()
getName ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

Collects info about the current localization state

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références LocalizationCollector\getDomain(), et LocalizationCollector\getLocale().

◆ getDomain()

getDomain ( )

Get the current translations domain

Renvoie
string

Référencé par LocalizationCollector\collect().

◆ getLocale()

getLocale ( )

Get the current locale

Renvoie
string

Référencé par LocalizationCollector\collect().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LocalizationCollector.php


Joomla CMS: Référence de la classe MemoryCollector

  • DebugBar
  • DataCollector
  • MemoryCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe MemoryCollector
+ Graphe d'héritage de MemoryCollector:
DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

getRealUsage ()
setRealUsage ($realUsage)
getPeakUsage ()
updatePeakUsage ()
collect ()
getName ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$realUsage = false
$peakUsage = 0
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects info about memory usage

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références DataCollector\formatBytes(), DataCollector\getDataFormatter(), et MemoryCollector\updatePeakUsage().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getPeakUsage()

getPeakUsage ( )

Returns the peak memory usage

Renvoie
integer

Références MemoryCollector\$peakUsage.

◆ getRealUsage()

getRealUsage ( )

Returns whether total allocated memory page size is used instead of actual used memory size by the application. See $real_usage parameter on memory_get_peak_usage for details.

Renvoie
bool

Références MemoryCollector\$realUsage.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

◆ setRealUsage()

setRealUsage ( $realUsage )

Sets whether total allocated memory page size is used instead of actual used memory size by the application. See $real_usage parameter on memory_get_peak_usage for details.

Paramètres
bool $realUsage

Références MemoryCollector\$realUsage.

◆ updatePeakUsage()

updatePeakUsage ( )

Updates the peak memory usage value

Référencé par MemoryCollector\collect().

Documentation des champs

◆ $peakUsage

$peakUsage = 0
protected

Référencé par MemoryCollector\getPeakUsage().

◆ $realUsage

$realUsage = false
protected

Référencé par MemoryCollector\getRealUsage(), et MemoryCollector\setRealUsage().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MemoryCollector.php


Joomla CMS: Référence de l'interface MessagesAggregateInterface

  • DebugBar
  • DataCollector
  • MessagesAggregateInterface
Fonctions membres publiques
Référence de l'interface MessagesAggregateInterface
+ Graphe d'héritage de MessagesAggregateInterface:
MonologCollector MessagesCollector CacheCacheCollector SlimCollector SwiftLogCollector

Fonctions membres publiques

getMessages ()

Documentation des fonctions membres

◆ getMessages()

getMessages ( )

Returns collected messages

Renvoie
array

Implémenté dans MessagesCollector, et MonologCollector.

La documentation de cette interface a été générée à partir du fichier suivant :
  • MessagesAggregateInterface.php


Joomla CMS: Référence de la classe MessagesCollector

  • DebugBar
  • DataCollector
  • MessagesCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe MessagesCollector
+ Graphe d'héritage de MessagesCollector:
AbstractLogger DataCollectorInterface MessagesAggregateInterface Renderable AssetProvider LoggerInterface SlimCollector SwiftLogCollector

Fonctions membres publiques

__construct ($name='messages')
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
addMessage ($message, $label='info', $isString=true)
aggregate (MessagesAggregateInterface $messages)
getMessages ()
log ($level, $message, array $context=array())
interpolate ($message, array $context=array())
clear ()
collect ()
getName ()
getAssets ()
getWidgets ()
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Attributs protégés

$name
$messages = array()
$aggregates = array()
$dataFormater
$varDumper
$useHtmlVarDumper = false

Description détaillée

Provides a way to log messages

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $name = 'messages' )
Paramètres
string $name

Références MessagesCollector\$name, et name.

Documentation des fonctions membres

◆ addMessage()

addMessage | ( | $message,
 |  | $label = 'info',
 |  | $isString = true
 | ) |

Adds a message

A message can be anything from an object to a string

Paramètres
mixed | $message
string | $label

Références $label, $message, MessagesCollector\getDataFormatter(), MessagesCollector\getVarDumper(), MessagesCollector\isHtmlVarDumperUsed(), et null.

Référencé par SwiftLogCollector\add(), MessagesCollector\log(), et SlimCollector\write().

◆ aggregate()

aggregate ( MessagesAggregateInterface $messages )

Aggregates messages from other collectors

Paramètres
MessagesAggregateInterface $messages

Références MessagesCollector\$messages.

◆ clear()

clear ( )

Deletes all messages

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références MessagesCollector\$messages, et MessagesCollector\getMessages().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

Références MessagesCollector\getVarDumper(), et MessagesCollector\isHtmlVarDumperUsed().

◆ getDataFormatter()

getDataFormatter ( )
Renvoie
DataFormatterInterface

Références MessagesCollector\$dataFormater, DataCollector\getDefaultDataFormatter(), et null.

Référencé par MessagesCollector\addMessage().

◆ getMessages()

getMessages ( )
Renvoie
array

Implémente MessagesAggregateInterface.

Références $b, et MessagesCollector\$messages.

Référencé par MessagesCollector\collect().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

Références MessagesCollector\$name.

Référencé par MessagesCollector\getWidgets().

◆ getVarDumper()

getVarDumper ( )

Gets the variable dumper instance used by this collector

Renvoie
DebugBarVarDumper

Références MessagesCollector\$varDumper, DataCollector\getDefaultVarDumper(), et null.

Référencé par MessagesCollector\addMessage(), et MessagesCollector\getAssets().

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Références MessagesCollector\$name, et MessagesCollector\getName().

◆ interpolate()

interpolate | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Interpolates context values into the message placeholders.

Paramètres
$message
array $context
Renvoie
string

Références $context, $key, $message, et $val.

Référencé par MessagesCollector\log().

◆ isHtmlVarDumperUsed()

isHtmlVarDumperUsed ( )

Indicates whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Renvoie
mixed

Références MessagesCollector\$useHtmlVarDumper.

Référencé par MessagesCollector\addMessage(), et MessagesCollector\getAssets().

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = array()
 | ) |  |
Paramètres
$level
$message
array $context

Implémente LoggerInterface.

Références $context, $message, MessagesCollector\addMessage(), et MessagesCollector\interpolate().

◆ setDataFormatter()

setDataFormatter ( DataFormatterInterface $formater )

Sets the data formater instance used by this collector

Paramètres
DataFormatterInterface $formater
Renvoie
$this

Références $this.

◆ setVarDumper()

setVarDumper ( DebugBarVarDumper $varDumper )

Sets the variable dumper instance used by this collector

Paramètres
DebugBarVarDumper $varDumper
Renvoie
$this

Références $this, et MessagesCollector\$varDumper.

◆ useHtmlVarDumper()

useHtmlVarDumper ( $value = true )

Sets a flag indicating whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering. Be sure to set this flag before logging any messages for the first time.

Paramètres
bool $value
Renvoie
$this

Références $this, et $value.

Documentation des champs

◆ $aggregates

$aggregates = array()
protected

◆ $dataFormater

$dataFormater
protected

Référencé par MessagesCollector\getDataFormatter().

◆ $messages

$messages = array()
protected

Référencé par MessagesCollector\aggregate(), MessagesCollector\collect(), et MessagesCollector\getMessages().

◆ $name

$name
protected

Référencé par MessagesCollector\__construct(), MessagesCollector\getName(), et MessagesCollector\getWidgets().

◆ $useHtmlVarDumper

$useHtmlVarDumper = false
protected

Référencé par MessagesCollector\isHtmlVarDumperUsed().

◆ $varDumper

$varDumper
protected

Référencé par MessagesCollector\getVarDumper(), et MessagesCollector\setVarDumper().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessagesCollector.php


Joomla CMS: Référence de la classe PhpInfoCollector

  • DebugBar
  • DataCollector
  • PhpInfoCollector
Fonctions membres publiques
Référence de la classe PhpInfoCollector
+ Graphe d'héritage de PhpInfoCollector:
DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

getName ()
collect ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

Collects info about PHP

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémente Renderable.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpInfoCollector.php


Joomla CMS: Référence de l'interface Renderable

  • DebugBar
  • DataCollector
  • Renderable
Fonctions membres publiques
Référence de l'interface Renderable
+ Graphe d'héritage de Renderable:
DoctrineCollector MonologCollector NamespacedTwigProfileCollector Propel2Collector PropelCollector SwiftMailCollector TwigCollector TwigProfileCollector ConfigCollector ExceptionsCollector LocalizationCollector MemoryCollector MessagesCollector PDOCollector PhpInfoCollector RequestDataCollector TimeDataCollector AbstractDataCollector

Fonctions membres publiques

getWidgets ()

Description détaillée

Indicates that a DataCollector is renderable using JavascriptRenderer

Documentation des fonctions membres

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
DebugBar::addControl()}
Renvoie
array

Implémenté dans ProfileCollector, Propel2Collector, MessagesCollector, PropelCollector, TimeDataCollector, PDOCollector, ExceptionsCollector, QueryCollector, ConfigCollector, MonologCollector, LanguageFilesCollector, NamespacedTwigProfileCollector, DoctrineCollector, TwigProfileCollector, RequestDataCollector, MemoryCollector, LanguageErrorsCollector, InfoCollector, LanguageStringsCollector, SessionCollector, SwiftMailCollector, TwigCollector, LocalizationCollector, et PhpInfoCollector.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Renderable.php


Joomla CMS: Référence de la classe RequestDataCollector

  • DebugBar
  • DataCollector
  • RequestDataCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe RequestDataCollector
+ Graphe d'héritage de RequestDataCollector:
DataCollector Renderable AssetProvider DataCollectorInterface

Fonctions membres publiques

useHtmlVarDumper ($value=true)
isHtmlVarDumperUsed ()
collect ()
getName ()
getAssets ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$useHtmlVarDumper = false
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects info about the current request

Documentation des fonctions membres

◆ collect()

collect ( )
Renvoie
array

Implémente DataCollectorInterface.

Références $data, $key, DataCollector\getDataFormatter(), DataCollector\getVarDumper(), et RequestDataCollector\isHtmlVarDumperUsed().

◆ getAssets()

getAssets ( )
Renvoie
array

Implémente AssetProvider.

Références DataCollector\getVarDumper(), et RequestDataCollector\isHtmlVarDumperUsed().

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

Références RequestDataCollector\isHtmlVarDumperUsed().

◆ isHtmlVarDumperUsed()

isHtmlVarDumperUsed ( )

Indicates whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Renvoie
mixed

Références RequestDataCollector\$useHtmlVarDumper.

Référencé par RequestDataCollector\collect(), RequestDataCollector\getAssets(), et RequestDataCollector\getWidgets().

◆ useHtmlVarDumper()

useHtmlVarDumper ( $value = true )

Sets a flag indicating whether the Symfony HtmlDumper will be used to dump variables for rich variable rendering.

Paramètres
bool $value
Renvoie
$this

Références $this, et $value.

Documentation des champs

◆ $useHtmlVarDumper

$useHtmlVarDumper = false
protected

Référencé par RequestDataCollector\isHtmlVarDumperUsed().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestDataCollector.php


Joomla CMS: Référence de la classe TimeDataCollector

  • DebugBar
  • DataCollector
  • TimeDataCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe TimeDataCollector
+ Graphe d'héritage de TimeDataCollector:
DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

__construct ($requestStartTime=null)
startMeasure ($name, $label=null, $collector=null)
hasStartedMeasure ($name)
stopMeasure ($name, $params=array())
addMeasure ($label, $start, $end, $params=array(), $collector=null)
measure ($label, \Closure $closure, $collector=null)
getMeasures ()
getRequestStartTime ()
getRequestEndTime ()
getRequestDuration ()
collect ()
getName ()
getWidgets ()
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$requestStartTime
$requestEndTime
$startedMeasures = array()
$measures = array()
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects info about the request duration as well as providing a way to log duration of any operations

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $requestStartTime = null )
Paramètres
float $requestStartTime

Références TimeDataCollector\$requestStartTime, et null.

Documentation des fonctions membres

◆ addMeasure()

addMeasure | ( | $label,
 |  | $start,
 |  | $end,
 |  | $params = array(),
 |  | $collector = null
 | ) |

Adds a measure

Paramètres
string | $label
float | $start
float | $end
array | $params
string | null | $collector

Références $label, $params, $start, DataCollector\formatDuration(), et DataCollector\getDataFormatter().

Référencé par TimeDataCollector\stopMeasure().

◆ collect()

collect ( )
Renvoie
array
Exceptions
DebugBarException

Implémente DataCollectorInterface.

Références $b, $name, DataCollector\formatDuration(), DataCollector\getDataFormatter(), TimeDataCollector\getRequestDuration(), et TimeDataCollector\stopMeasure().

◆ getMeasures()

getMeasures ( )

Returns an array of all measures

Renvoie
array

Références TimeDataCollector\$measures.

◆ getName()

getName ( )
Renvoie
string

Implémente DataCollectorInterface.

◆ getRequestDuration()

getRequestDuration ( )

Returns the duration of a request

Renvoie
float

Références TimeDataCollector\$requestStartTime, et null.

Référencé par TimeDataCollector\collect().

◆ getRequestEndTime()

getRequestEndTime ( )

Returns the request end time

Renvoie
float

Références TimeDataCollector\$requestEndTime.

◆ getRequestStartTime()

getRequestStartTime ( )

Returns the request start time

Renvoie
float

Références TimeDataCollector\$requestStartTime.

◆ getWidgets()

getWidgets ( )
Renvoie
array

Implémente Renderable.

◆ hasStartedMeasure()

hasStartedMeasure ( $name )

Check a measure exists

Paramètres
string $name
Renvoie
bool

Références $name.

Référencé par TimeDataCollector\stopMeasure().

◆ measure()

measure | ( |  | $label,
 |  | \Closure | $closure,
 |  |  | $collector = null
 | ) |  |

Utility function to measure the execution of a Closure

Paramètres
string | $label
\Closure | $closure
string | null | $collector
Renvoie
mixed

Références $label, $name, $params, $result, TimeDataCollector\startMeasure(), et TimeDataCollector\stopMeasure().

◆ startMeasure()

startMeasure | ( | $name,
 |  | $label = null,
 |  | $collector = null
 | ) |

Starts a measure

Paramètres
string | $name | Internal name, used to stop the measure
string | null | $label | Public name
string | null | $collector | The source of the collector

Références $label, $name, et $start.

Référencé par TimeDataCollector\measure().

◆ stopMeasure()

stopMeasure | ( | $name,
 |  | $params = array()
 | ) |

Stops a measure

Paramètres
string | $name
array | $params
Exceptions
DebugBarException

Références $name, $params, TimeDataCollector\addMeasure(), et TimeDataCollector\hasStartedMeasure().

Référencé par TimeDataCollector\collect(), et TimeDataCollector\measure().

Documentation des champs

◆ $measures

$measures = array()
protected

Référencé par TimeDataCollector\getMeasures().

◆ $requestEndTime

$requestEndTime
protected

Référencé par TimeDataCollector\getRequestEndTime().

◆ $requestStartTime

$requestStartTime
protected

Référencé par TimeDataCollector\__construct(), TimeDataCollector\getRequestDuration(), et TimeDataCollector\getRequestStartTime().

◆ $startedMeasures

$startedMeasures = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TimeDataCollector.php


Joomla CMS: Référence de la classe DebugBarHtmlDumper

  • DebugBar
  • DataFormatter
  • VarDumper
  • DebugBarHtmlDumper
Fonctions membres publiques
Référence de la classe DebugBarHtmlDumper
+ Graphe d'héritage de DebugBarHtmlDumper:
HtmlDumper CliDumper AbstractDumper DataDumperInterface DumperInterface

Fonctions membres publiques

resetDumpHeader ()
getDumpHeaderByDebugBar ()
- Fonctions membres publiques hérités de HtmlDumper
__construct ($output=null, string $charset=null, int $flags=0)
setStyles (array $styles)
setTheme (string $themeName)
setDisplayOptions (array $displayOptions)
setDumpHeader (?string $header)
setDumpBoundaries (string $prefix, string $suffix)
dump (Data $data, $output=null, array $extraDisplayOptions=[])
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)
- Fonctions membres publiques hérités de CliDumper
__construct ($output=null, string $charset=null, int $flags=0)
setColors (bool $colors)
setMaxStringWidth (int $maxStringWidth)
setStyles (array $styles)
setDisplayOptions (array $displayOptions)
dumpScalar (Cursor $cursor, string $type, $value)
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)
- Fonctions membres publiques hérités de AbstractDumper
__construct ($output=null, string $charset=null, int $flags=0)
setOutput ($output)
setCharset (string $charset)
setIndentPad (string $pad)
dump (Data $data, $output=null)
- Fonctions membres publiques hérités de DataDumperInterface
dump (Data $data)

Membres hérités additionnels

- Champs de données hérités de AbstractDumper
const | DUMP_LIGHT_ARRAY = 1
const | DUMP_STRING_LENGTH = 2
const | DUMP_COMMA_SEPARATOR = 4
const | DUMP_TRAILING_COMMA = 8
- Attributs publics statiques hérités de HtmlDumper
static | $defaultOutput = 'php://output'
- Attributs publics statiques hérités de CliDumper
static | $defaultColors
static | $defaultOutput = 'php://stdout'
static | n
- Attributs publics statiques hérités de AbstractDumper
static | $defaultOutput = 'php://output'
- Fonctions membres protégées hérités de HtmlDumper
getDumpHeader ()
style (string $style, string $value, array $attr=[])
dumpLine (int $depth, bool $endOfValue=false)
- Fonctions membres protégées hérités de CliDumper
dumpEllipsis (Cursor $cursor, bool $hasChild, int $cut)
dumpKey (Cursor $cursor)
style (string $style, string $value, array $attr=[])
supportsColors ()
dumpLine (int $depth, bool $endOfValue=false)
endValue (Cursor $cursor)
- Fonctions membres protégées hérités de AbstractDumper
dumpLine (int $depth)
echoLine (string $line, int $depth, string $indentPad)
utf8Encode (?string $s)
- Attributs protégés hérités de HtmlDumper
static | $dumpHeader
$dumpPrefix = '<pre class=sf-dump id=%s data-indent-pad="%s">'
$dumpSuffix = '</pre><script>Sfdump(%s)</script>'
$dumpId = 'sf-dump'
$colors = true
$headerIsDumped = false
$lastDepth = -1
$styles
- Attributs protégés hérités de CliDumper
$colors
$maxStringWidth = 0
$styles
$collapseNextHash = false
$expandNextHash = false
- Attributs protégés hérités de AbstractDumper
$line = ''
$lineDumper
$outputStream
$decimalPoint
$indentPad = ' '
$flags
- Attributs protégés statiques hérités de HtmlDumper
static | $themes
- Attributs protégés statiques hérités de CliDumper
static | $controlCharsRx = '/[\x00-\x1F\x7F]+/'
static | $controlCharsMap

Description détaillée

We have to extend the base HtmlDumper class in order to get access to the protected-only getDumpHeader function.

Documentation des fonctions membres

◆ getDumpHeaderByDebugBar()

getDumpHeaderByDebugBar ( )

Références HtmlDumper\getDumpHeader().

◆ resetDumpHeader()

resetDumpHeader ( )

Resets an HTML header.

Références null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugBarHtmlDumper.php


Joomla CMS: Référence de la classe SeekingData

  • DebugBar
  • DataFormatter
  • VarDumper
  • SeekingData
Fonctions membres publiques | Attributs privés
Référence de la classe SeekingData
+ Graphe d'héritage de SeekingData:
Data

Fonctions membres publiques

seek ($key)
dump (DumperInterface $dumper)
- Fonctions membres publiques hérités de Data
__construct (array $data)
getType ()
getValue ($recursive=false)
count ()
getIterator ()
__get (string $key)
__isset (string $key)
offsetExists ($key)
offsetGet ($key)
offsetSet ($key, $value)
offsetUnset ($key)
__toString ()
withMaxDepth (int $maxDepth)
withMaxItemsPerDepth (int $maxItemsPerDepth)
withRefHandles (bool $useRefHandles)
withContext (array $context)
seek ($key)
dump (DumperInterface $dumper)

Attributs privés

$position = 0
$key = 0

Description détaillée

This class backports the seek() function from Symfony 3.2 to older versions - up to v2.6. The class should not be used with newer Symfony versions that provide the seek function, as it relies on a lot of undocumented functionality.

Documentation des fonctions membres

◆ dump()

dump ( DumperInterface $dumper )

{}

Références $class, Data\$data, et $this.

◆ seek()

seek ( $key )

Seeks to a specific key in nested data structures.

Paramètres
string | int $key The key to seek to
Renvoie
self|null A clone of $this of null if the key is not set

Références Data\$data, $item, SeekingData\$key, SeekingData\$position, $this, null, Stub\TYPE_ARRAY, Stub\TYPE_OBJECT, et Stub\TYPE_RESOURCE.

Documentation des champs

◆ $key

$key = 0
private

Référencé par SeekingData\seek().

◆ $position

$position = 0
private

Référencé par SeekingData\seek().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SeekingData.php


Joomla CMS: Référence de la classe DataFormatter

  • DebugBar
  • DataFormatter
  • DataFormatter
Fonctions membres publiques
Référence de la classe DataFormatter
+ Graphe d'héritage de DataFormatter:
DataFormatterInterface DataFormatter

Fonctions membres publiques

__construct ()
formatVar ($data)
formatDuration ($seconds)
formatBytes ($size, $precision=2)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

DataFormatter constructor.

Documentation des fonctions membres

◆ formatBytes()

formatBytes | ( | $size,
 |  | $precision = 2
 | ) |
Paramètres
string | $size
int | $precision
Renvoie
string

Implémente DataFormatterInterface.

Références $base, $size, et null.

◆ formatDuration()

formatDuration ( $seconds )
Paramètres
float $seconds
Renvoie
string

Implémente DataFormatterInterface.

Références elseif.

◆ formatVar()

formatVar ( $data )
Paramètres
$data
Renvoie
string

Implémente DataFormatterInterface.

Références $data, et $output.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/maximebf/debugbar/src/DebugBar/DataFormatter/DataFormatter.php


Joomla CMS: Référence de l'interface DataFormatterInterface

  • DebugBar
  • DataFormatter
  • DataFormatterInterface
Fonctions membres publiques
Référence de l'interface DataFormatterInterface
+ Graphe d'héritage de DataFormatterInterface:
DataFormatter DataFormatter

Fonctions membres publiques

formatVar ($data)
formatDuration ($seconds)
formatBytes ($size, $precision=2)

Description détaillée

Formats data to be outputed as string

Documentation des fonctions membres

◆ formatBytes()

formatBytes | ( | $size,
 |  | $precision = 2
 | ) |

Transforms a size in bytes to a human readable string

Paramètres
string | $size
integer | $precision
Renvoie
string

Implémenté dans DataFormatter.

◆ formatDuration()

formatDuration ( $seconds )

Transforms a duration in seconds in a readable string

Paramètres
float $seconds
Renvoie
string

Implémenté dans DataFormatter.

◆ formatVar()

formatVar ( $data )

Transforms a PHP variable to a string representation

Paramètres
mixed $data
Renvoie
string

Implémenté dans DataFormatter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DataFormatterInterface.php


Joomla CMS: Référence de la classe DebugBarVarDumper

  • DebugBar
  • DataFormatter
  • DebugBarVarDumper
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe DebugBarVarDumper
+ Graphe d'héritage de DebugBarVarDumper:
AssetProvider

Fonctions membres publiques

getClonerOptions ()
mergeClonerOptions ($options)
resetClonerOptions ($options=null)
getDumperOptions ()
mergeDumperOptions ($options)
resetDumperOptions ($options=null)
captureVar ($data)
renderCapturedVar ($capturedData, $seekPath=array())
renderVar ($data)
getAssets ()

Fonctions membres protégées

getCloner ()
getDumper ()
getDisplayOptions ()
dump (Data $data)

Attributs protégés

$clonerOptions
$dumperOptions
$cloner
$dumper

Attributs protégés statiques

static | $defaultClonerOptions = array()
static | $defaultDumperOptions

Description détaillée

Clones and renders variables in HTML format using the Symfony VarDumper component.

Cloning is decoupled from rendering, so that dumper users can have the fastest possible cloning performance, while delaying rendering until it is actually needed.

Documentation des fonctions membres

◆ captureVar()

captureVar ( $data )

Captures the data from a variable and serializes it for later rendering.

Paramètres
mixed $data The variable to capture.
Renvoie
string Serialized variable data.

Références $data, et DebugBarVarDumper\getCloner().

◆ dump()

dump ( Data $data )
protected

Helper function to dump a Data object to HTML.

Paramètres
Data $data
Renvoie
string

Références DebugBarVarDumper\$dumper, $output, $result, DebugBarVarDumper\getDisplayOptions(), DebugBarVarDumper\getDumper(), et null.

Référencé par DebugBarVarDumper\renderCapturedVar(), et DebugBarVarDumper\renderVar().

◆ getAssets()

getAssets ( )

Returns assets required for rendering variables.

Renvoie
array

Implémente AssetProvider.

Références DebugBarVarDumper\$dumper, et DebugBarVarDumper\getDumper().

◆ getCloner()

getCloner ( )
protected

Gets the VarCloner instance with configuration options set.

Renvoie
VarCloner

Références DebugBarVarDumper\$cloner, DebugBarVarDumper\$clonerOptions, et DebugBarVarDumper\getClonerOptions().

Référencé par DebugBarVarDumper\captureVar(), et DebugBarVarDumper\renderVar().

◆ getClonerOptions()

getClonerOptions ( )

Gets the array of non-default VarCloner configuration options.

Renvoie
array

Références DebugBarVarDumper\$clonerOptions, et null.

Référencé par DebugBarVarDumper\getCloner(), et DebugBarVarDumper\mergeClonerOptions().

◆ getDisplayOptions()

getDisplayOptions ( )
protected

Gets the display options for the HTML dumper.

Renvoie
array

Références DebugBarVarDumper\$dumperOptions, et DebugBarVarDumper\getDumperOptions().

Référencé par DebugBarVarDumper\dump().

◆ getDumper()

getDumper ( )
protected

Gets the DebugBarHtmlDumper instance with configuration options set.

Renvoie
DebugBarHtmlDumper

Références DebugBarVarDumper\$dumper, DebugBarVarDumper\$dumperOptions, et DebugBarVarDumper\getDumperOptions().

Référencé par DebugBarVarDumper\dump(), et DebugBarVarDumper\getAssets().

◆ getDumperOptions()

getDumperOptions ( )

Gets the array of non-default HtmlDumper configuration options.

Renvoie
array

Références DebugBarVarDumper\$dumperOptions, et null.

Référencé par DebugBarVarDumper\getDisplayOptions(), DebugBarVarDumper\getDumper(), et DebugBarVarDumper\mergeDumperOptions().

◆ mergeClonerOptions()

mergeClonerOptions ( $options )

Merges an array of non-default VarCloner configuration options with the existing non-default options.

Configuration options are:

  • casters: a map of VarDumper Caster objects to use instead of the default casters.
  • additional_casters: a map of VarDumper Caster objects to use in addition to the default casters.
  • max_items: maximum number of items to clone beyond the minimum depth.
  • max_string: maximum string size
  • min_depth: minimum tree depth to clone before counting items against the max_items limit. (Requires Symfony 3.4; ignored on older versions.)
Paramètres
array $options

Références $options, DebugBarVarDumper\getClonerOptions(), et null.

◆ mergeDumperOptions()

mergeDumperOptions ( $options )

Merges an array of non-default HtmlDumper configuration options with the existing non-default options.

Configuration options are:

  • styles: a map of CSS styles to include in the assets, as documented in HtmlDumper::setStyles.
  • expanded_depth: the tree depth to initially expand. (Requires Symfony 3.2; ignored on older versions.)
  • max_string: maximum string size. (Requires Symfony 3.2; ignored on older versions.)
  • file_link_format: link format for files; f expanded to file and l expanded to line (Requires Symfony 3.2; ignored on older versions.)
Paramètres
array $options

Références $options, DebugBarVarDumper\getDumperOptions(), et null.

◆ renderCapturedVar()

renderCapturedVar | ( | $capturedData,
 |  | $seekPath = array()
 | ) |

Renders previously-captured data from captureVar to HTML and returns it as a string.

Paramètres
string | $capturedData | Captured data from captureVar.
array | $seekPath | Pass an array of keys to traverse if you only want to render a subset of the data.
Renvoie
string HTML rendering of the variable.

Références $data, $key, et DebugBarVarDumper\dump().

◆ renderVar()

renderVar ( $data )

Captures and renders the data from a variable to HTML and returns it as a string.

Paramètres
mixed $data The variable to capture and render.
Renvoie
string HTML rendering of the variable.

Références $data, DebugBarVarDumper\dump(), et DebugBarVarDumper\getCloner().

◆ resetClonerOptions()

resetClonerOptions ( $options = null )

Resets the array of non-default VarCloner configuration options without retaining any of the existing non-default options.

Configuration options are:

  • casters: a map of VarDumper Caster objects to use instead of the default casters.
  • additional_casters: a map of VarDumper Caster objects to use in addition to the default casters.
  • max_items: maximum number of items to clone beyond the minimum depth.
  • max_string: maximum string size
  • min_depth: minimum tree depth to clone before counting items against the max_items limit. (Requires Symfony 3.4; ignored on older versions.)
Paramètres
array $options

Références $options, et null.

◆ resetDumperOptions()

resetDumperOptions ( $options = null )

Resets the array of non-default HtmlDumper configuration options without retaining any of the existing non-default options.

Configuration options are:

  • styles: a map of CSS styles to include in the assets, as documented in HtmlDumper::setStyles.
  • expanded_depth: the tree depth to initially expand. (Requires Symfony 3.2; ignored on older versions.)
  • max_string: maximum string size. (Requires Symfony 3.2; ignored on older versions.)
  • file_link_format: link format for files; f expanded to file and l expanded to line (Requires Symfony 3.2; ignored on older versions.)
Paramètres
array $options

Références $options, et null.

Documentation des champs

◆ $cloner

$cloner
protected

Référencé par DebugBarVarDumper\getCloner().

◆ $clonerOptions

$clonerOptions
protected

Référencé par DebugBarVarDumper\getCloner(), et DebugBarVarDumper\getClonerOptions().

◆ $defaultClonerOptions

$defaultClonerOptions = array()
staticprotected

◆ $defaultDumperOptions

$defaultDumperOptions
staticprotected
Valeur initiale :
= array(
'expanded_depth' => 0,
'styles' => array(
'default' => 'word-wrap: break-word; white-space: pre-wrap; word-break: normal',
'num' => 'font-weight:bold; color:#1299DA',
'const' => 'font-weight:bold',
'str' => 'font-weight:bold; color:#3A9B26',
'note' => 'color:#1299DA',
'ref' => 'color:#7B7B7B',
'public' => 'color:#000000',
'protected' => 'color:#000000',
'private' => 'color:#000000',
'meta' => 'color:#B729D9',
'key' => 'color:#3A9B26',
'index' => 'color:#1299DA',
'ellipsis' => 'color:#A0A000',
),
)

◆ $dumper

$dumper
protected

Référencé par DebugBarVarDumper\dump(), DebugBarVarDumper\getAssets(), et DebugBarVarDumper\getDumper().

◆ $dumperOptions

$dumperOptions
protected

Référencé par DebugBarVarDumper\getDisplayOptions(), DebugBarVarDumper\getDumper(), et DebugBarVarDumper\getDumperOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugBarVarDumper.php


Joomla CMS: Référence de la classe FileStorage

  • DebugBar
  • Storage
  • FileStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FileStorage
+ Graphe d'héritage de FileStorage:
StorageInterface FileStorage

Fonctions membres publiques

__construct ($dirname)
save ($id, $data)
get ($id)
find (array $filters=array(), $max=20, $offset=0)
clear ()
makeFilename ($id)

Fonctions membres protégées

filter ($meta, $filters)

Attributs protégés

$dirname

Description détaillée

Stores collected data into files

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $dirname )
Paramètres
string $dirname Directories where to store files

Références FileStorage\$dirname.

Documentation des fonctions membres

◆ clear()

clear ( )

{Clears all the collected data}

Implémente StorageInterface.

◆ filter()

filter | ( | $meta,
 |  | $filters
 | ) |
protected

Filter the metadata for matches.

Paramètres
array | $meta
array | $filters
Renvoie
bool

Références $filters, $key, et $value.

Référencé par FileStorage\find().

◆ find()

find | ( | array | $filters = array(),
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

{Returns a metadata about collected data

Paramètres
array | $filters
integer | $max
integer | $offset
Renvoie
array
}

Implémente StorageInterface.

Références $b, $data, $filters, $i, Joomla\Database\Query\$offset, $results, FileStorage\filter(), et null.

◆ get()

get ( $id )

{Returns collected data with the specified id

Paramètres
string $id
Renvoie
array
}

Implémente StorageInterface.

Références $id, et FileStorage\makeFilename().

◆ makeFilename()

makeFilename ( $id )
Paramètres
string $id
Renvoie
string

Références $id.

Référencé par FileStorage\get(), et FileStorage\save().

◆ save()

save | ( | $id,
 |  | $data
 | ) |

{Saves collected data

Paramètres
string | $id
string | $data
}

Implémente StorageInterface.

Références $data, $id, et FileStorage\makeFilename().

Documentation des champs

◆ $dirname

$dirname
protected

Référencé par FileStorage\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/maximebf/debugbar/src/DebugBar/Storage/FileStorage.php


Joomla CMS: Référence de la classe MemcachedStorage

  • DebugBar
  • Storage
  • MemcachedStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MemcachedStorage
+ Graphe d'héritage de MemcachedStorage:
StorageInterface

Fonctions membres publiques

__construct (Memcached $memcached, $keyNamespace='phpdebugbar', $expiration=0)
save ($id, $data)
get ($id)
find (array $filters=array(), $max=20, $offset=0)
clear ()

Fonctions membres protégées

filter ($meta, $filters)
createKey ($id)
memcachedGetMulti ($keys, $flags)

Attributs protégés

$memcached
$keyNamespace
$expiration
$newGetMultiSignature

Description détaillée

Stores collected data into Memcache using the Memcached extension

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Memcached | $memcached,
 |  |  | $keyNamespace = 'phpdebugbar',
 |  |  | $expiration = 0
 | ) |  |
Paramètres
Memcached | $memcached
string | $keyNamespace | Namespace for Memcached key names (to avoid conflict with other Memcached users).
int | $expiration | Expiration for Memcached entries (see Expiration Times in Memcached documentation).

Références MemcachedStorage\$expiration, MemcachedStorage\$keyNamespace, et MemcachedStorage\$memcached.

Documentation des fonctions membres

◆ clear()

clear ( )

{Clears all the collected data}

Implémente StorageInterface.

Références $this.

◆ createKey()

createKey ( $id )
protected
Paramètres
string $id
Renvoie
string

Référencé par MemcachedStorage\get(), et MemcachedStorage\save().

◆ filter()

filter | ( | $meta,
 |  | $filters
 | ) |
protected

Filter the metadata for matches.

Paramètres
array | $meta
array | $filters
Renvoie
bool

Références $filters, $key, et $value.

Référencé par MemcachedStorage\find().

◆ find()

find | ( | array | $filters = array(),
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

{Returns a metadata about collected data

Paramètres
array | $filters
integer | $max
integer | $offset
Renvoie
array
}

Implémente StorageInterface.

Références $data, $filters, Joomla\Database\Query\$offset, $results, $this, MemcachedStorage\filter(), et MemcachedStorage\memcachedGetMulti().

◆ get()

get ( $id )

{Returns collected data with the specified id

Paramètres
string $id
Renvoie
array
}

Implémente StorageInterface.

Références $id, et MemcachedStorage\createKey().

◆ memcachedGetMulti()

memcachedGetMulti | ( | $keys,
 |  | $flags
 | ) |
protected

The memcached getMulti function changed in version 3.0.0 to only have two parameters.

Paramètres
array | $keys
int | $flags

Références null.

Référencé par MemcachedStorage\find().

◆ save()

save | ( | $id,
 |  | $data
 | ) |

{Saves collected data

Paramètres
string | $id
string | $data
}

Implémente StorageInterface.

Références $data, $id, $key, $this, et MemcachedStorage\createKey().

Documentation des champs

◆ $expiration

$expiration
protected

Référencé par MemcachedStorage\__construct().

◆ $keyNamespace

$keyNamespace
protected

Référencé par MemcachedStorage\__construct().

◆ $memcached

$memcached
protected

Référencé par MemcachedStorage\__construct().

◆ $newGetMultiSignature

$newGetMultiSignature
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/maximebf/debugbar/src/DebugBar/Storage/MemcachedStorage.php


Joomla CMS: Référence de la classe PdoStorage

  • DebugBar
  • Storage
  • PdoStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PdoStorage
+ Graphe d'héritage de PdoStorage:
StorageInterface

Fonctions membres publiques

__construct (PDO $pdo, $tableName='phpdebugbar', array $sqlQueries=array())
setSqlQueries (array $queries)
save ($id, $data)
get ($id)
find (array $filters=array(), $max=20, $offset=0)
clear ()

Fonctions membres protégées

getSqlQuery ($name, array $vars=array())

Attributs protégés

$pdo
$tableName
$sqlQueries

Description détaillée

Stores collected data into a database using PDO

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PDO | $pdo,
 |  |  | $tableName = 'phpdebugbar',
 |  | array | $sqlQueries = array()
 | ) |  |
Paramètres
\PDO | $pdo | The PDO instance
string | $tableName
array | $sqlQueries

Références PdoStorage\$pdo, PdoStorage\$sqlQueries, PdoStorage\$tableName, et PdoStorage\setSqlQueries().

Documentation des fonctions membres

◆ clear()

clear ( )

{Clears all the collected data}

Implémente StorageInterface.

Références PdoStorage\getSqlQuery().

◆ find()

find | ( | array | $filters = array(),
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

{Returns a metadata about collected data

Paramètres
array | $filters
integer | $max
integer | $offset
Renvoie
array
}

Implémente StorageInterface.

Références $data, $filters, $key, Joomla\Database\Query\$offset, $params, $results, $sql, $value, et PdoStorage\getSqlQuery().

◆ get()

get ( $id )

{Returns collected data with the specified id

Paramètres
string $id
Renvoie
array
}

Implémente StorageInterface.

Références $data, $id, $sql, PdoStorage\getSqlQuery(), et null.

◆ getSqlQuery()

getSqlQuery | ( |  | $name,
 |  | array | $vars = array()
 | ) |  |
protected

Get a SQL Query for a task, with the variables replaced

Paramètres
string | $name
array | $vars
Renvoie
string

Références $name, et $sql.

Référencé par PdoStorage\clear(), PdoStorage\find(), PdoStorage\get(), et PdoStorage\save().

◆ save()

save | ( | $id,
 |  | $data
 | ) |

{Saves collected data

Paramètres
string | $id
string | $data
}

Implémente StorageInterface.

Références $data, $id, $sql, et PdoStorage\getSqlQuery().

◆ setSqlQueries()

setSqlQueries ( array $queries )

Sets the sql queries to be used

Paramètres
array $queries

Référencé par PdoStorage\__construct().

Documentation des champs

◆ $pdo

$pdo
protected

Référencé par PdoStorage\__construct().

◆ $sqlQueries

$sqlQueries
protected
Valeur initiale :
= array(
'save' => "INSERT INTO %tablename% (id, data, meta_utime, meta_datetime, meta_uri, meta_ip, meta_method) VALUES (?, ?, ?, ?, ?, ?, ?)",
'get' => "SELECT data FROM %tablename% WHERE id = ?",
'find' => "SELECT data FROM %tablename% %where% ORDER BY meta_datetime DESC LIMIT %limit% OFFSET %offset%",
'clear' => "DELETE FROM %tablename%"
)

Référencé par PdoStorage\__construct().

◆ $tableName

$tableName
protected

Référencé par PdoStorage\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PdoStorage.php


Joomla CMS: Référence de la classe RedisStorage

  • DebugBar
  • Storage
  • RedisStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe RedisStorage
+ Graphe d'héritage de RedisStorage:
StorageInterface

Fonctions membres publiques

__construct ($redis, $hash='phpdebugbar')
save ($id, $data)
get ($id)
find (array $filters=[], $max=20, $offset=0)
clear ()

Fonctions membres protégées

filter ($meta, $filters)

Attributs protégés

$redis
$hash

Description détaillée

Stores collected data into Redis

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $redis,
 |  | $hash = 'phpdebugbar'
 | ) |
Paramètres
\Predis\Client | \Redis | $redis | Redis Client
string | $hash

Références RedisStorage\$hash, et RedisStorage\$redis.

Documentation des fonctions membres

◆ clear()

clear ( )

{Clears all the collected data}

Implémente StorageInterface.

◆ filter()

filter | ( | $meta,
 |  | $filters
 | ) |
protected

Filter the metadata for matches.

Références $filters, $key, et $value.

Référencé par RedisStorage\find().

◆ find()

find | ( | array | $filters = [],
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

{Returns a metadata about collected data

Paramètres
array | $filters
integer | $max
integer | $offset
Renvoie
array
}

Implémente StorageInterface.

Références $b, $data, $filters, Joomla\Database\Query\$offset, $results, et RedisStorage\filter().

◆ get()

get ( $id )

{Returns collected data with the specified id

Paramètres
string $id
Renvoie
array
}

Implémente StorageInterface.

Références $id.

◆ save()

save | ( | $id,
 |  | $data
 | ) |

{Saves collected data

Paramètres
string | $id
string | $data
}

Implémente StorageInterface.

Références $data, et $id.

Documentation des champs

◆ $hash

$hash
protected

Référencé par RedisStorage\__construct().

◆ $redis

$redis
protected

Référencé par RedisStorage\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/maximebf/debugbar/src/DebugBar/Storage/RedisStorage.php


Joomla CMS: Référence de l'interface StorageInterface

  • DebugBar
  • Storage
  • StorageInterface
Fonctions membres publiques
Référence de l'interface StorageInterface
+ Graphe d'héritage de StorageInterface:
FileStorage MemcachedStorage PdoStorage RedisStorage FileStorage

Fonctions membres publiques

save ($id, $data)
get ($id)
find (array $filters=array(), $max=20, $offset=0)
clear ()

Documentation des fonctions membres

◆ clear()

clear ( )

Clears all the collected data

Implémenté dans MemcachedStorage, PdoStorage, FileStorage, et RedisStorage.

◆ find()

find | ( | array | $filters = array(),
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

Returns a metadata about collected data

Paramètres
array | $filters
integer | $max
integer | $offset
Renvoie
array

Implémenté dans PdoStorage, FileStorage, MemcachedStorage, RedisStorage, et FileStorage.

◆ get()

get ( $id )

Returns collected data with the specified id

Paramètres
string $id
Renvoie
array

Implémenté dans PdoStorage, MemcachedStorage, FileStorage, RedisStorage, et FileStorage.

◆ save()

save | ( | $id,
 |  | $data
 | ) |

Saves collected data

Paramètres
string | $id
string | $data

Implémenté dans PdoStorage, MemcachedStorage, RedisStorage, FileStorage, et FileStorage.

La documentation de cette interface a été générée à partir du fichier suivant :
  • maximebf/debugbar/src/DebugBar/Storage/StorageInterface.php


Joomla CMS: Référence de la classe DebugBar

  • DebugBar
  • DebugBar
Fonctions membres publiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DebugBar
+ Graphe d'héritage de DebugBar:
StandardDebugBar

Fonctions membres publiques

addCollector (DataCollectorInterface $collector)
hasCollector ($name)
getCollector ($name)
getCollectors ()
setRequestIdGenerator (RequestIdGeneratorInterface $generator)
getRequestIdGenerator ()
getCurrentRequestId ()
setStorage (StorageInterface $storage=null)
getStorage ()
isDataPersisted ()
setHttpDriver (HttpDriverInterface $driver)
getHttpDriver ()
collect ()
getData ()
getDataAsHeaders ($headerName='phpdebugbar', $maxHeaderLength=4096, $maxTotalHeaderLength=250000)
sendDataInHeaders ($useOpenHandler=null, $headerName='phpdebugbar', $maxHeaderLength=4096)
stackData ()
hasStackedData ()
getStackedData ($delete=true)
setStackDataSessionNamespace ($ns)
getStackDataSessionNamespace ()
setStackAlwaysUseSessionStorage ($enabled=true)
isStackAlwaysUseSessionStorage ()
getJavascriptRenderer ($baseUrl=null, $basePath=null)
offsetSet ($key, $value)
offsetGet ($key)
offsetExists ($key)
offsetUnset ($key)

Attributs publics statiques

static $useOpenHandlerWhenSendingDataHeaders = false

Fonctions membres protégées

initStackSession ()

Attributs protégés

$collectors = array()
$data
$jsRenderer
$requestIdGenerator
$requestId
$storage
$httpDriver
$stackSessionNamespace = 'PHPDEBUGBAR_STACK_DATA'
$stackAlwaysUseSessionStorage = false

Description détaillée

Main DebugBar object

Manages data collectors. DebugBar provides an array-like access to collectors by name.

$debugbar = new DebugBar(); $debugbar->addCollector(new DataCollector()); $debugbar['messages']->addMessage("foobar");

Documentation des fonctions membres

◆ addCollector()

addCollector ( DataCollectorInterface $collector )

Adds a data collector

Paramètres
DataCollectorInterface $collector
Exceptions
DebugBarException
Renvoie
$this

Références $this, et DataCollectorInterface\getName().

◆ collect()

collect ( )

Collects the data from the collectors

Renvoie
array

Références $data, $item, $name, et null.

◆ getCollector()

getCollector ( $name )

Returns a data collector

Paramètres
string $name
Renvoie
DataCollectorInterface
Exceptions
DebugBarException

Références $name.

◆ getCollectors()

getCollectors ( )

Returns an array of all data collectors

Renvoie
array[DataCollectorInterface]

◆ getCurrentRequestId()

getCurrentRequestId ( )

Returns the id of the current request

Renvoie
string

Références null.

◆ getData()

getData ( )

Returns collected data

Will collect the data if none have been collected yet

Renvoie
array

Références $data, et null.

◆ getDataAsHeaders()

getDataAsHeaders | ( | $headerName = 'phpdebugbar',
 |  | $maxHeaderLength = 4096,
 |  | $maxTotalHeaderLength = 250000
 | ) |

Returns an array of HTTP headers containing the data

Paramètres
string | $headerName
integer | $maxHeaderLength
Renvoie
array

Références $c, $data, $i, et $name.

◆ getHttpDriver()

getHttpDriver ( )

Returns the HTTP driver

If no http driver where defined, a PhpHttpDriver is automatically created

Renvoie
HttpDriverInterface

Références null.

◆ getJavascriptRenderer()

getJavascriptRenderer | ( | $baseUrl = null,
 |  | $basePath = null
 | ) |

Returns a JavascriptRenderer for this instance

Paramètres
string | $baseUrl
string | $basePath
Renvoie
JavascriptRenderer

Références $basePath, $this, et null.

◆ getRequestIdGenerator()

getRequestIdGenerator ( )
Renvoie
RequestIdGeneratorInterface

Références null.

◆ getStackDataSessionNamespace()

getStackDataSessionNamespace ( )

Returns the key used in the $_SESSION array

Renvoie
string

◆ getStackedData()

getStackedData ( $delete = true )

Returns the data stacked in the session

Paramètres
boolean $delete Whether to delete the data in the session
Renvoie
array

Références $data, et $id.

◆ getStorage()

getStorage ( )
Renvoie
StorageInterface

◆ hasCollector()

hasCollector ( $name )

Checks if a data collector has been added

Paramètres
string $name
Renvoie
boolean

Références $name.

◆ hasStackedData()

hasStackedData ( )

Checks if there is stacked data in the session

Renvoie
boolean

Références $this.

◆ initStackSession()

initStackSession ( )
protected

Initializes the session for stacked data

Renvoie
HttpDriverInterface
Exceptions
DebugBarException

Références $this.

◆ isDataPersisted()

isDataPersisted ( )

Checks if the data will be persisted

Renvoie
boolean

Références null.

Référencé par OpenHandler\__construct().

◆ isStackAlwaysUseSessionStorage()

isStackAlwaysUseSessionStorage ( )

Checks if the session is always used to store stacked data even if a storage is enabled

Renvoie
boolean

◆ offsetExists()

offsetExists ( $key )

Références $key.

◆ offsetGet()

offsetGet ( $key )

Références $key.

◆ offsetSet()

offsetSet | ( | $key,
 |  | $value
 | ) |

◆ offsetUnset()

offsetUnset ( $key )

◆ sendDataInHeaders()

sendDataInHeaders | ( | $useOpenHandler = null,
 |  | $headerName = 'phpdebugbar',
 |  | $maxHeaderLength = 4096
 | ) |

Sends the data through the HTTP headers

Paramètres
bool | $useOpenHandler
string | $headerName
integer | $maxHeaderLength
Renvoie
$this

Références $this, et null.

◆ setHttpDriver()

setHttpDriver ( HttpDriverInterface $driver )

Sets the HTTP driver

Paramètres
HttpDriverInterface $driver
Renvoie
$this

Références $this.

◆ setRequestIdGenerator()

setRequestIdGenerator ( RequestIdGeneratorInterface $generator )

Sets the request id generator

Paramètres
RequestIdGeneratorInterface $generator
Renvoie
$this

Références $this.

◆ setStackAlwaysUseSessionStorage()

setStackAlwaysUseSessionStorage ( $enabled = true )

Sets whether to only use the session to store stacked data even if a storage is enabled

Paramètres
boolean $enabled
Renvoie
$this

Références $enabled, et $this.

◆ setStackDataSessionNamespace()

setStackDataSessionNamespace ( $ns )

Sets the key to use in the $_SESSION array

Paramètres
string $ns
Renvoie
$this

Références $this.

◆ setStorage()

setStorage ( StorageInterface $storage = null )

Sets the storage backend to use to store the collected data

Paramètres
StorageInterface $storage
Renvoie
$this

Références $this.

◆ stackData()

stackData ( )

Stacks the data in the session for later rendering

Références $data, $this, elseif, et null.

Documentation des champs

◆ $collectors

$collectors = array()
protected

◆ $data

$data
protected

◆ $httpDriver

$httpDriver
protected

◆ $jsRenderer

$jsRenderer
protected

◆ $requestId

$requestId
protected

◆ $requestIdGenerator

$requestIdGenerator
protected

◆ $stackAlwaysUseSessionStorage

$stackAlwaysUseSessionStorage = false
protected

◆ $stackSessionNamespace

$stackSessionNamespace = 'PHPDEBUGBAR_STACK_DATA'
protected

◆ $storage

$storage
protected

◆ $useOpenHandlerWhenSendingDataHeaders

$useOpenHandlerWhenSendingDataHeaders = false
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugBar.php


Joomla CMS: Référence de la classe DebugBarException

  • DebugBar
  • DebugBarException
Référence de la classe DebugBarException
+ Graphe d'héritage de DebugBarException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugBarException.php


Joomla CMS: Référence de l'interface HttpDriverInterface

  • DebugBar
  • HttpDriverInterface
Fonctions membres publiques
Référence de l'interface HttpDriverInterface
+ Graphe d'héritage de HttpDriverInterface:
PhpHttpDriver JoomlaHttpDriver

Fonctions membres publiques

setHeaders (array $headers)
isSessionStarted ()
setSessionValue ($name, $value)
hasSessionValue ($name)
getSessionValue ($name)
deleteSessionValue ($name)

Description détaillée

Provides an abstraction of PHP native features for easier integration in third party frameworks

Documentation des fonctions membres

◆ deleteSessionValue()

deleteSessionValue ( $name )

Deletes a value from the session

Paramètres
string $name

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

◆ getSessionValue()

getSessionValue ( $name )

Returns a value from the session

Paramètres
string $name
Renvoie
mixed

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

◆ hasSessionValue()

hasSessionValue ( $name )

Checks if a value is in the session

Paramètres
string $name
Renvoie
boolean

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

◆ isSessionStarted()

isSessionStarted ( )

Checks if the session is started

Renvoie
boolean

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

◆ setHeaders()

setHeaders ( array $headers )

Sets HTTP headers

Paramètres
array $headers
Renvoie

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

◆ setSessionValue()

setSessionValue | ( | $name,
 |  | $value
 | ) |

Sets a value in the session

Paramètres
string | $name
string | $value

Implémenté dans JoomlaHttpDriver, et PhpHttpDriver.

La documentation de cette interface a été générée à partir du fichier suivant :
  • HttpDriverInterface.php


Joomla CMS: Référence de la classe JavascriptRenderer

  • DebugBar
  • JavascriptRenderer
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe JavascriptRenderer
+ Graphe d'héritage de JavascriptRenderer:
JavascriptRenderer

Fonctions membres publiques

__construct (DebugBar $debugBar, $baseUrl=null, $basePath=null)
setOptions (array $options)
setBasePath ($path)
getBasePath ()
setBaseUrl ($url)
getBaseUrl ()
setIncludeVendors ($enabled=true)
areVendorsIncluded ()
disableVendor ($name)
setJavascriptClass ($className)
getJavascriptClass ()
setVariableName ($name)
getVariableName ()
setInitialization ($init)
getInitialization ()
setEnableJqueryNoConflict ($enabled=true)
isJqueryNoConflictEnabled ()
setUseRequireJs ($enabled=true)
isRequireJsUsed ()
addControl ($name, array $options)
disableControl ($name)
getControls ()
ignoreCollector ($name)
getIgnoredCollectors ()
setAjaxHandlerClass ($className)
getAjaxHandlerClass ()
setBindAjaxHandlerToFetch ($bind=true)
isAjaxHandlerBoundToFetch ()
setBindAjaxHandlerToJquery ($bind=true)
isAjaxHandlerBoundToJquery ()
setBindAjaxHandlerToXHR ($bind=true)
isAjaxHandlerBoundToXHR ()
setAjaxHandlerAutoShow ($autoShow=true)
isAjaxHandlerAutoShow ()
setOpenHandlerClass ($className)
getOpenHandlerClass ()
setOpenHandlerUrl ($url)
getOpenHandlerUrl ()
setCspNonce ($nonce=null)
getCspNonce ()
addAssets ($cssFiles, $jsFiles, $basePath=null, $baseUrl=null)
addInlineAssets ($inlineCss, $inlineJs, $inlineHead)
getAssets ($type=null, $relativeTo=self::RELATIVE_PATH)
getAsseticCollection ($type=null)
dumpCssAssets ($targetFilename=null)
dumpJsAssets ($targetFilename=null)
dumpHeadAssets ($targetFilename=null)
renderHead ()
renderOnShutdown ($here=true, $initialize=true, $renderStackedData=true, $head=false)
renderOnShutdownWithHead ($here=true, $initialize=true, $renderStackedData=true)
replaceTagInBuffer ($here=true, $initialize=true, $renderStackedData=true, $head=false)
render ($initialize=true, $renderStackedData=true)

Champs de données

const | INITIALIZE_CONSTRUCTOR = 2
const | INITIALIZE_CONTROLS = 4
const | REPLACEABLE_TAG = "{--DEBUGBAR_OB_START_REPLACE_ME--}"
const | RELATIVE_PATH = 'path'
const | RELATIVE_URL = 'url'

Fonctions membres protégées

getRelativeRoot ($relativeTo, $basePath, $baseUrl)
makeUriRelativeTo ($uri, $root)
filterAssetArray ($array, $type='')
createAsseticCollection ($files=null, $content=null)
dumpAssets ($files=null, $content=null, $targetFilename=null, $useRequireJs=false)
getJsInitializationCode ()
getJsControlsDefinitionCode ($varname)
getAddDatasetCode ($requestId, $data, $suffix=null)
getNonceAttribute ()

Attributs protégés

$debugBar
$baseUrl
$basePath
$cssVendors
$jsVendors
$includeVendors = true
$cssFiles = array('debugbar.css', 'widgets.css', 'openhandler.css')
$jsFiles = array('debugbar.js', 'widgets.js', 'openhandler.js')
$additionalAssets = array()
$javascriptClass = 'PhpDebugBar.DebugBar'
$variableName = 'phpdebugbar'
$enableJqueryNoConflict = true
$useRequireJs = false
$initialization
$controls = array()
$ignoredCollectors = array()
$ajaxHandlerClass = 'PhpDebugBar.AjaxHandler'
$ajaxHandlerBindToFetch = false
$ajaxHandlerBindToJquery = true
$ajaxHandlerBindToXHR = false
$ajaxHandlerAutoShow = true
$openHandlerClass = 'PhpDebugBar.OpenHandler'
$openHandlerUrl
$cspNonce

Description détaillée

Renders the debug bar using the client side javascript implementation

Generates all the needed initialization code of controls

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DebugBar | $debugBar,
 |  |  | $baseUrl = null,
 |  |  | $basePath = null
 | ) |  |
Paramètres
\DebugBar\DebugBar | $debugBar
string | $baseUrl
string | $basePath

Références $basePath, __DIR__, baseUrl, et null.

Documentation des fonctions membres

◆ addAssets()

addAssets | ( | $cssFiles,
 |  | $jsFiles,
 |  | $basePath = null,
 |  | $baseUrl = null
 | ) |

Add assets stored in files to render in the head

Paramètres
array | $cssFiles | An array of filenames
array | $jsFiles | An array of filenames
string | $basePath | Base path of those files
string | $baseUrl | Base url of those files
Renvoie
$this

Références $basePath, et $this.

◆ addControl()

addControl | ( |  | $name,
 |  | array | $options
 | ) |  |

Adds a control to initialize

Possible options:

  • icon: icon name
  • tooltip: string
  • widget: widget class name
  • title: tab title
  • map: a property name from the data to map the control to
  • default: a js string, default value of the data map

"icon" or "widget" are at least needed

Paramètres
string | $name
array | $options

Références $name, $options, et $this.

◆ addInlineAssets()

addInlineAssets | ( | $inlineCss,
 |  | $inlineJs,
 |  | $inlineHead
 | ) |

Add inline assets to render inline in the head. Ideally, you should store static assets in files that you add with the addAssets function. However, adding inline assets is useful when integrating with 3rd-party libraries that require static assets that are only available in an inline format.

The inline content arrays require special string array keys: they are used to deduplicate content. This is particularly useful if multiple instances of the same asset end up being added. Inline assets from all collectors are merged together into the same array, so these content IDs effectively deduplicate the inline assets.

Paramètres
array | $inlineCss | An array map of content ID to inline CSS content (not including <style> tag)
array | $inlineJs | An array map of content ID to inline JS content (not including <script> tag)
array | $inlineHead | An array map of content ID to arbitrary inline HTML content (typically <style>/<script> tags); it must be embedded within the <head> element
Renvoie
$this

Références $this.

◆ areVendorsIncluded()

areVendorsIncluded ( )

Checks if vendors assets are included

Renvoie
boolean

◆ createAsseticCollection()

createAsseticCollection | ( | $files = null,
 |  | $content = null
 | ) |
protected

Create an Assetic AssetCollection with the given content. Filenames will be converted to absolute path using the base path.

Paramètres
array | null | $files | Array of asset filenames.
array | null | $content | Array of inline asset content.
Renvoie

Références $content, et $item.

◆ disableControl()

disableControl ( $name )

Disables a control

Paramètres
string $name

Références $name, $this, et null.

◆ disableVendor()

disableVendor ( $name )

Disable a specific vendor's assets.

Paramètres
string $name "jquery", "fontawesome", "highlightjs"
Renvoie
void

Références $name.

◆ dumpAssets()

dumpAssets | ( | $files = null,
 |  | $content = null,
 |  | $targetFilename = null,
 |  | $useRequireJs = false
 | ) |
protected

Write assets to standard output or in a file

Paramètres
array | null | $files | Filenames containing assets
array | null | $content | Inline content to dump
string | $targetFilename
bool | $useRequireJs

Références $content, $item, et null.

◆ dumpCssAssets()

dumpCssAssets ( $targetFilename = null )

Write all CSS assets to standard output or in a file

Paramètres
string $targetFilename

◆ dumpHeadAssets()

dumpHeadAssets ( $targetFilename = null )

Write all inline HTML header assets to standard output or in a file (only returns assets not already returned by dumpCssAssets or dumpJsAssets)

Paramètres
string $targetFilename

Références null.

◆ dumpJsAssets()

dumpJsAssets ( $targetFilename = null )

Write all JS assets to standard output or in a file

Paramètres
string $targetFilename

◆ filterAssetArray()

filterAssetArray | ( | $array,
 |  | $type = ''
 | ) |
protected

Filters a tuple of (css, js, inline_css, inline_js, inline_head) assets according to $type

Paramètres
array | $array
string | $type | 'css', 'js', 'inline_css', 'inline_js', 'inline_head', or null for all
Renvoie
array

Références $type.

◆ getAddDatasetCode()

getAddDatasetCode | ( | $requestId,
 |  | $data,
 |  | $suffix = null
 | ) |
protected

Returns the js code needed to add a dataset

Paramètres
string | $requestId
array | $data
mixed | $suffix
Renvoie
string

Références $data, et $suffix.

◆ getAjaxHandlerClass()

getAjaxHandlerClass ( )

Returns the class name of the ajax handler

Renvoie
string

◆ getAsseticCollection()

getAsseticCollection ( $type = null )

Returns an array where all items are Assetic AssetCollection:

  • The first one contains the CSS files
  • The second one contains the JS files
  • The third one contains arbitrary inline HTML (typically composed of <script>/<style> elements); it must be embedded within the <head> element
Paramètres
string $type Optionally return only 'css', 'js', or 'inline_head' collection
Renvoie
array|

Références $type, et null.

◆ getAssets()

getAssets | ( | $type = null,
 |  | $relativeTo = self::RELATIVE_PATH
 | ) |

Returns the list of asset files

Paramètres
string | $type | 'css', 'js', 'inline_css', 'inline_js', 'inline_head', or null for all
string | $relativeTo | The type of path to which filenames must be relative (path, url or null)
Renvoie
array

Références $basePath, $root, $type, et baseUrl.

◆ getBasePath()

getBasePath ( )

Returns the path which assets are relative to

Renvoie
string

Références $basePath.

◆ getBaseUrl()

getBaseUrl ( )

Returns the base URL from which assets will be served

Renvoie
string

◆ getControls()

getControls ( )

Returns the list of controls

This does not include controls provided by collectors

Renvoie
array

◆ getCspNonce()

getCspNonce ( )

Get the CSP Nonce

Renvoie
string|null

◆ getIgnoredCollectors()

getIgnoredCollectors ( )

Returns the list of ignored collectors

Renvoie
array

◆ getInitialization()

getInitialization ( )

Returns what should be initialized

Renvoie
integer

◆ getJavascriptClass()

getJavascriptClass ( )

Returns the javascript class name

Renvoie
string

◆ getJsControlsDefinitionCode()

getJsControlsDefinitionCode ( $varname )
protected

Returns the js code needed to initialized the controls and data mapping of the debug bar

Controls can be defined by collectors themselves or using {

Voir également
addControl()}
Paramètres
string $varname Debug bar's variable name
Renvoie
string

Références $name, $options, $opts, et elseif.

◆ getJsInitializationCode()

getJsInitializationCode ( )
protected

Returns the js code needed to initialize the debug bar

Renvoie
string

Références elseif, et null.

◆ getNonceAttribute()

getNonceAttribute ( )
protected

If a nonce it set, create the correct attribute

Renvoie
string

◆ getOpenHandlerClass()

getOpenHandlerClass ( )

Returns the class name of the js open handler

Renvoie
string

◆ getOpenHandlerUrl()

getOpenHandlerUrl ( )

Returns the url for the open handler

Renvoie
string

◆ getRelativeRoot()

getRelativeRoot | ( | $relativeTo,
 |  | $basePath,
 |  | $baseUrl
 | ) |
protected

Returns the correct base according to the type

Paramètres
string | $relativeTo
string | $basePath
string | $baseUrl
Renvoie
string

Références $basePath, et null.

◆ getVariableName()

getVariableName ( )

Returns the variable name of the class instance

Renvoie
string

◆ ignoreCollector()

ignoreCollector ( $name )

Ignores widgets provided by a collector

Paramètres
string $name

Références $name, et $this.

◆ isAjaxHandlerAutoShow()

isAjaxHandlerAutoShow ( )

Checks whether the ajax handler will immediately show new ajax requests.

Renvoie
boolean

◆ isAjaxHandlerBoundToFetch()

isAjaxHandlerBoundToFetch ( )

Checks whether bindToFetch() will be called on the ajax handler

Renvoie
boolean

◆ isAjaxHandlerBoundToJquery()

isAjaxHandlerBoundToJquery ( )

Checks whether bindToJquery() will be called on the ajax handler

Renvoie
boolean

◆ isAjaxHandlerBoundToXHR()

isAjaxHandlerBoundToXHR ( )

Checks whether bindToXHR() will be called on the ajax handler

Renvoie
boolean

◆ isJqueryNoConflictEnabled()

isJqueryNoConflictEnabled ( )

Checks if jQuery.noConflict() will be called

Renvoie
boolean

◆ isRequireJsUsed()

isRequireJsUsed ( )

Checks if RequireJS is used

Renvoie
boolean

◆ makeUriRelativeTo()

makeUriRelativeTo | ( | $uri,
 |  | $root
 | ) |
protected

Makes a URI relative to another

Paramètres
string | array | $uri
string | $root
Renvoie
string

Références $root, et $uri.

◆ render()

render | ( | $initialize = true,
 |  | $renderStackedData = true
 | ) |

Returns the code needed to display the debug bar

AJAX request should not render the initialization code.

Paramètres
boolean | $initialize | Whether or not to render the debug bar initialization code
boolean | $renderStackedData | Whether or not to render the stacked data
Renvoie
string

Références $data, $id, $suffix, et null.

◆ renderHead()

renderHead ( )

Renders the html to include needed assets

Only useful if Assetic is not used

Renvoie
string

Références $content, $html, et null.

◆ renderOnShutdown()

renderOnShutdown | ( | $here = true,
 |  | $initialize = true,
 |  | $renderStackedData = true,
 |  | $head = false
 | ) |

Register shutdown to display the debug bar

Paramètres
boolean | $here | Set position of HTML. True if is to current position or false for end file
boolean | $initialize | Whether to render the de bug bar initialization code
bool | $renderStackedData
bool | $head
Renvoie
string Return "{--DEBUGBAR_OB_START_REPLACE_ME--}" or return an empty string if $here == false

Références $this.

◆ renderOnShutdownWithHead()

renderOnShutdownWithHead | ( | $here = true,
 |  | $initialize = true,
 |  | $renderStackedData = true
 | ) |

Same as renderOnShutdown() with $head = true

Paramètres
boolean | $here
boolean | $initialize
boolean | $renderStackedData
Renvoie
string

◆ replaceTagInBuffer()

replaceTagInBuffer | ( | $here = true,
 |  | $initialize = true,
 |  | $renderStackedData = true,
 |  | $head = false
 | ) |

Is callback function for register_shutdown_function(...)

Paramètres
boolean | $here | Set position of HTML. True if is to current position or false for end file
boolean | $initialize | Whether to render the de bug bar initialization code
bool | $renderStackedData
bool | $head

Références $count.

◆ setAjaxHandlerAutoShow()

setAjaxHandlerAutoShow ( $autoShow = true )

Sets whether new ajax debug data will be immediately shown. Setting to false could be useful if there are a lot of tracking events cluttering things.

Paramètres
boolean $autoShow

Références $this.

◆ setAjaxHandlerClass()

setAjaxHandlerClass ( $className )

Sets the class name of the ajax handler

Set to false to disable

Paramètres
string $className

Références $className, et $this.

◆ setBasePath()

setBasePath ( $path )

Sets the path which assets are relative to

Paramètres
string $path

Références $path, et $this.

◆ setBaseUrl()

setBaseUrl ( $url )

Sets the base URL from which assets will be served

Paramètres
string $url

Références $this, $url, et baseUrl.

◆ setBindAjaxHandlerToFetch()

setBindAjaxHandlerToFetch ( $bind = true )

Sets whether to call bindToFetch() on the ajax handler

Paramètres
boolean $bind

Références $this.

◆ setBindAjaxHandlerToJquery()

setBindAjaxHandlerToJquery ( $bind = true )

Sets whether to call bindToJquery() on the ajax handler

Paramètres
boolean $bind

Références $this.

◆ setBindAjaxHandlerToXHR()

setBindAjaxHandlerToXHR ( $bind = true )

Sets whether to call bindToXHR() on the ajax handler

Paramètres
boolean $bind

Références $this.

◆ setCspNonce()

setCspNonce ( $nonce = null )

Sets the CSP Nonce (or remove it by setting to null)

Paramètres
string | null $nonce
Renvoie
$this

Références $this.

◆ setEnableJqueryNoConflict()

setEnableJqueryNoConflict ( $enabled = true )

Sets whether to call jQuery.noConflict()

Paramètres
boolean $enabled

Références $enabled, et $this.

◆ setIncludeVendors()

setIncludeVendors ( $enabled = true )

Whether to include vendor assets

You can only include js or css vendors using setIncludeVendors('css') or setIncludeVendors('js')

Paramètres
boolean $enabled

Références $enabled, et $this.

◆ setInitialization()

setInitialization ( $init )

Sets what should be initialized

  • INITIALIZE_CONSTRUCTOR: only initializes the instance
  • INITIALIZE_CONTROLS: initializes the controls and data mapping
  • INITIALIZE_CONSTRUCTOR | INITIALIZE_CONTROLS: initialize everything (default)
Paramètres
integer $init

Références $this.

◆ setJavascriptClass()

setJavascriptClass ( $className )

Sets the javascript class name

Paramètres
string $className

Références $className, et $this.

◆ setOpenHandlerClass()

setOpenHandlerClass ( $className )

Sets the class name of the js open handler

Paramètres
string $className

Références $className, et $this.

◆ setOpenHandlerUrl()

setOpenHandlerUrl ( $url )

Sets the url of the open handler

Paramètres
string $url

Références $this, et $url.

◆ setOptions()

setOptions ( array $options )

Sets options from an array

Options:

  • base_path
  • base_url
  • include_vendors
  • javascript_class
  • variable_name
  • initialization
  • enable_jquery_noconflict
  • controls
  • disable_controls
  • ignore_collectors
  • ajax_handler_classname
  • ajax_handler_bind_to_jquery
  • ajax_handler_auto_show
  • open_handler_classname
  • open_handler_url
Paramètres
array $options [description]

Références $control, $name, et $options.

◆ setUseRequireJs()

setUseRequireJs ( $enabled = true )

Sets whether to use RequireJS or not

Paramètres
boolean $enabled
Renvoie
$this

Références $enabled, et $this.

◆ setVariableName()

setVariableName ( $name )

Sets the variable name of the class instance

Paramètres
string $name

Références $name, et $this.

Documentation des champs

◆ $additionalAssets

$additionalAssets = array()
protected

◆ $ajaxHandlerAutoShow

$ajaxHandlerAutoShow = true
protected

◆ $ajaxHandlerBindToFetch

$ajaxHandlerBindToFetch = false
protected

◆ $ajaxHandlerBindToJquery

$ajaxHandlerBindToJquery = true
protected

◆ $ajaxHandlerBindToXHR

$ajaxHandlerBindToXHR = false
protected

◆ $ajaxHandlerClass

$ajaxHandlerClass = 'PhpDebugBar.AjaxHandler'
protected

◆ $basePath

$basePath
protected

◆ $baseUrl

$baseUrl
protected

◆ $controls

$controls = array()
protected

◆ $cspNonce

$cspNonce
protected

◆ $cssFiles

$cssFiles = array('debugbar.css', 'widgets.css', 'openhandler.css')
protected

◆ $cssVendors

$cssVendors
protected
Valeur initiale :
= array(
'fontawesome' => 'vendor/font-awesome/css/font-awesome.min.css',
'highlightjs' => 'vendor/highlightjs/styles/github.css'
)

◆ $debugBar

$debugBar
protected

◆ $enableJqueryNoConflict

$enableJqueryNoConflict = true
protected

◆ $ignoredCollectors

$ignoredCollectors = array()
protected

◆ $includeVendors

$includeVendors = true
protected

◆ $initialization

$initialization
protected

◆ $javascriptClass

$javascriptClass = 'PhpDebugBar.DebugBar'
protected

◆ $jsFiles

$jsFiles = array('debugbar.js', 'widgets.js', 'openhandler.js')
protected

◆ $jsVendors

$jsVendors
protected
Valeur initiale :
= array(
'jquery' => 'vendor/jquery/dist/jquery.min.js',
'highlightjs' => 'vendor/highlightjs/highlight.pack.js'
)

◆ $openHandlerClass

$openHandlerClass = 'PhpDebugBar.OpenHandler'
protected

◆ $openHandlerUrl

$openHandlerUrl
protected

◆ $useRequireJs

$useRequireJs = false
protected

◆ $variableName

$variableName = 'phpdebugbar'
protected

◆ INITIALIZE_CONSTRUCTOR

const INITIALIZE_CONSTRUCTOR = 2

◆ INITIALIZE_CONTROLS

const INITIALIZE_CONTROLS = 4

◆ RELATIVE_PATH

const RELATIVE_PATH = 'path'

◆ RELATIVE_URL

const RELATIVE_URL = 'url'

◆ REPLACEABLE_TAG

const REPLACEABLE_TAG = "{--DEBUGBAR_OB_START_REPLACE_ME--}"
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/maximebf/debugbar/src/DebugBar/JavascriptRenderer.php


Joomla CMS: Référence de la classe OpenHandler

  • DebugBar
  • OpenHandler
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe OpenHandler

Fonctions membres publiques

__construct (DebugBar $debugBar)
handle ($request=null, $echo=true, $sendHeader=true)

Fonctions membres protégées

find ($request)
get ($request)
clear ($request)

Attributs protégés

$debugBar

Description détaillée

Handler to list and open saved dataset

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DebugBar $debugBar )
Paramètres
DebugBar $debugBar
Exceptions
DebugBarException

Références DebugBar\isDataPersisted().

Documentation des fonctions membres

◆ clear()

clear ( $request )
protected

Clear operation

◆ find()

find ( $request )
protected

Find operation

Paramètres
$request
Renvoie
array

Références $filters, $key, et Joomla\Database\Query\$offset.

◆ get()

get ( $request )
protected

Get operation

Paramètres
$request
Renvoie
array
Exceptions
DebugBarException

◆ handle()

handle | ( | $request = null,
 |  | $echo = true,
 |  | $sendHeader = true
 | ) |

Handles the current request

Paramètres
array | $request | Request data
bool | $echo
bool | $sendHeader
Renvoie
string
Exceptions
DebugBarException

Références $this, et null.

Documentation des champs

◆ $debugBar

$debugBar
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • OpenHandler.php


Joomla CMS: Référence de la classe PhpHttpDriver

  • DebugBar
  • PhpHttpDriver
Fonctions membres publiques
Référence de la classe PhpHttpDriver
+ Graphe d'héritage de PhpHttpDriver:
HttpDriverInterface

Fonctions membres publiques

setHeaders (array $headers)
isSessionStarted ()
setSessionValue ($name, $value)
hasSessionValue ($name)
getSessionValue ($name)
deleteSessionValue ($name)

Description détaillée

HTTP driver for native php

Documentation des fonctions membres

◆ deleteSessionValue()

deleteSessionValue ( $name )
Paramètres
string $name

Implémente HttpDriverInterface.

Références $name.

◆ getSessionValue()

getSessionValue ( $name )
Paramètres
string $name
Renvoie
mixed

Implémente HttpDriverInterface.

Références $name.

◆ hasSessionValue()

hasSessionValue ( $name )
Paramètres
string $name
Renvoie
bool

Implémente HttpDriverInterface.

Références $name.

◆ isSessionStarted()

isSessionStarted ( )
Renvoie
bool

Implémente HttpDriverInterface.

◆ setHeaders()

setHeaders ( array $headers )
Paramètres
array $headers

Implémente HttpDriverInterface.

Références $name, et $value.

◆ setSessionValue()

setSessionValue | ( | $name,
 |  | $value
 | ) |
Paramètres
string | $name
string | $value

Implémente HttpDriverInterface.

Références $name, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpHttpDriver.php


Joomla CMS: Référence de la classe RequestIdGenerator

  • DebugBar
  • RequestIdGenerator
Fonctions membres publiques | Attributs protégés
Référence de la classe RequestIdGenerator
+ Graphe d'héritage de RequestIdGenerator:
RequestIdGeneratorInterface

Fonctions membres publiques

generate ()

Attributs protégés

$index = 0

Description détaillée

Basic request ID generator

Documentation des fonctions membres

◆ generate()

generate ( )
Renvoie
string

Implémente RequestIdGeneratorInterface.

Références $this.

Documentation des champs

◆ $index

$index = 0
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestIdGenerator.php


Joomla CMS: Référence de l'interface RequestIdGeneratorInterface

  • DebugBar
  • RequestIdGeneratorInterface
Fonctions membres publiques
Référence de l'interface RequestIdGeneratorInterface
+ Graphe d'héritage de RequestIdGeneratorInterface:
RequestIdGenerator

Fonctions membres publiques

generate ()

Documentation des fonctions membres

◆ generate()

generate ( )

Generates a unique id for the current request. If called repeatedly, a new unique id must always be returned on each call to generate() - even across different object instances.

To avoid any potential confusion in ID –> value maps, the returned value must be guaranteed to not be all-numeric.

Renvoie
string

Implémenté dans RequestIdGenerator.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RequestIdGeneratorInterface.php


Joomla CMS: Référence de la classe StandardDebugBar

  • DebugBar
  • StandardDebugBar
Fonctions membres publiques
Référence de la classe StandardDebugBar
+ Graphe d'héritage de StandardDebugBar:
DebugBar

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de DebugBar
addCollector (DataCollectorInterface $collector)
hasCollector ($name)
getCollector ($name)
getCollectors ()
setRequestIdGenerator (RequestIdGeneratorInterface $generator)
getRequestIdGenerator ()
getCurrentRequestId ()
setStorage (StorageInterface $storage=null)
getStorage ()
isDataPersisted ()
setHttpDriver (HttpDriverInterface $driver)
getHttpDriver ()
collect ()
getData ()
getDataAsHeaders ($headerName='phpdebugbar', $maxHeaderLength=4096, $maxTotalHeaderLength=250000)
sendDataInHeaders ($useOpenHandler=null, $headerName='phpdebugbar', $maxHeaderLength=4096)
stackData ()
hasStackedData ()
getStackedData ($delete=true)
setStackDataSessionNamespace ($ns)
getStackDataSessionNamespace ()
setStackAlwaysUseSessionStorage ($enabled=true)
isStackAlwaysUseSessionStorage ()
getJavascriptRenderer ($baseUrl=null, $basePath=null)
offsetSet ($key, $value)
offsetGet ($key)
offsetExists ($key)
offsetUnset ($key)

Membres hérités additionnels

- Attributs publics statiques hérités de DebugBar
static $useOpenHandlerWhenSendingDataHeaders = false
- Fonctions membres protégées hérités de DebugBar
initStackSession ()
- Attributs protégés hérités de DebugBar
$collectors = array()
$data
$jsRenderer
$requestIdGenerator
$requestId
$storage
$httpDriver
$stackSessionNamespace = 'PHPDEBUGBAR_STACK_DATA'
$stackAlwaysUseSessionStorage = false

Description détaillée

Debug bar subclass which adds all included collectors

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
La documentation de cette classe a été générée à partir du fichier suivant :
  • StandardDebugBar.php


Joomla CMS: Référence de la classe BadFormatException

  • Defuse
  • Crypto
  • Exception
  • BadFormatException
Référence de la classe BadFormatException
+ Graphe d'héritage de BadFormatException:
CryptoException
La documentation de cette classe a été générée à partir du fichier suivant :
  • BadFormatException.php


Joomla CMS: Référence de la classe CryptoException

  • Defuse
  • Crypto
  • Exception
  • CryptoException
Référence de la classe CryptoException
+ Graphe d'héritage de CryptoException:
BadFormatException EnvironmentIsBrokenException IOException WrongKeyOrModifiedCiphertextException
La documentation de cette classe a été générée à partir du fichier suivant :
  • CryptoException.php


Joomla CMS: Référence de la classe EnvironmentIsBrokenException

  • Defuse
  • Crypto
  • Exception
  • EnvironmentIsBrokenException
Référence de la classe EnvironmentIsBrokenException
+ Graphe d'héritage de EnvironmentIsBrokenException:
CryptoException
La documentation de cette classe a été générée à partir du fichier suivant :
  • EnvironmentIsBrokenException.php


Joomla CMS: Référence de la classe IOException

  • Defuse
  • Crypto
  • Exception
  • IOException
Référence de la classe IOException
+ Graphe d'héritage de IOException:
CryptoException
La documentation de cette classe a été générée à partir du fichier suivant :
  • IOException.php


Joomla CMS: Référence de la classe WrongKeyOrModifiedCiphertextException

  • Defuse
  • Crypto
  • Exception
  • WrongKeyOrModifiedCiphertextException
Référence de la classe WrongKeyOrModifiedCiphertextException
+ Graphe d'héritage de WrongKeyOrModifiedCiphertextException:
CryptoException
La documentation de cette classe a été générée à partir du fichier suivant :
  • WrongKeyOrModifiedCiphertextException.php


Joomla CMS: Référence de la classe Core

  • Defuse
  • Crypto
  • Core
Fonctions membres publiques statiques | Champs de données
Référence de la classe Core

Fonctions membres publiques statiques

static | incrementCounter ($ctr, $inc)
static | secureRandom ($octets)
static | hashEquals ($expected, $given)
static | ensureConstantExists ($name)
static | ensureFunctionExists ($name)
static | ensureTrue ($condition, $message='')
static | ourStrlen ($str)
static | ourSubstr ($str, $start, $length=null)
static | pbkdf2 ($algorithm, $password, $salt, $count, $key_length, $raw_output=false)

Champs de données

const | HEADER_VERSION_SIZE = 4
const | MINIMUM_CIPHERTEXT_SIZE = 84
const | CURRENT_VERSION = "\xDE\xF5\x02\x00"
const | CIPHER_METHOD = 'aes-256-ctr'
const | BLOCK_BYTE_SIZE = 16
const | KEY_BYTE_SIZE = 32
const | SALT_BYTE_SIZE = 32
const | MAC_BYTE_SIZE = 32
const | HASH_FUNCTION_NAME = 'sha256'
const | ENCRYPTION_INFO_STRING = 'DefusePHP|V2|KeyForEncryption'
const | AUTHENTICATION_INFO_STRING = 'DefusePHP|V2|KeyForAuthentication'
const | BUFFER_BYTE_SIZE = 1048576
const | LEGACY_CIPHER_METHOD = 'aes-128-cbc'
const | LEGACY_BLOCK_BYTE_SIZE = 16
const | LEGACY_KEY_BYTE_SIZE = 16
const | LEGACY_HASH_FUNCTION_NAME = 'sha256'
const | LEGACY_MAC_BYTE_SIZE = 32
const | LEGACY_ENCRYPTION_INFO_STRING = 'DefusePHP|KeyForEncryption'
const | LEGACY_AUTHENTICATION_INFO_STRING = 'DefusePHP|KeyForAuthentication'

Documentation des fonctions membres

◆ ensureConstantExists()

static ensureConstantExists ( $name )
static

Throws an exception if the constant doesn't exist.

Paramètres
string $name
Renvoie
void
Exceptions
Ex

Références $name, et Core\ensureTrue().

◆ ensureFunctionExists()

static ensureFunctionExists ( $name )
static

Throws an exception if the function doesn't exist.

Paramètres
string $name
Renvoie
void
Exceptions
Ex

Références $name, et Core\ensureTrue().

Référencé par RuntimeTests\runtimeTest().

◆ ensureTrue()

static ensureTrue | ( | $condition,
 |  | $message = ''
 | ) |
static

Throws an exception if the condition is false.

Paramètres
bool | $condition
string | $message
Renvoie
void
Exceptions
Ex

Références $message.

Référencé par Key\__construct(), KeyOrPassword\__construct(), RuntimeTests\AESTestVector(), KeyOrPassword\deriveKeys(), Core\ensureConstantExists(), Core\ensureFunctionExists(), Core\hashEquals(), RuntimeTests\HKDFTestVector(), RuntimeTests\HMACTestVector(), Core\incrementCounter(), Encoding\loadBytesFromChecksummedAsciiSafeString(), Core\ourStrlen(), Core\pbkdf2(), RuntimeTests\runtimeTest(), Encoding\saveBytesToChecksummedAsciiSafeString(), et RuntimeTests\testEncryptDecrypt().

◆ hashEquals()

static hashEquals | ( | $expected,
 |  | $given
 | ) |
static

Checks if two equal-length strings are the same without leaking information through side channels.

Paramètres
string | $expected
string | $given
Exceptions
Ex

Références Core\ensureTrue(), Core\HASH_FUNCTION_NAME, null, Core\ourStrlen(), et Core\secureRandom().

Référencé par Encoding\loadBytesFromChecksummedAsciiSafeString(), et Crypto\verifyHMAC().

◆ incrementCounter()

static incrementCounter | ( | $ctr,
 |  | $inc
 | ) |
static

Adds an integer to a block-sized counter.

Paramètres
string | $ctr
int | $inc
Exceptions
Ex

Références $i, Core\BLOCK_BYTE_SIZE, Core\ensureTrue(), et Core\ourStrlen().

◆ ourStrlen()

static ourStrlen ( $str )
static

Computes the length of a string in bytes.

Paramètres
string $str
Exceptions
Ex

Références Core\ensureTrue(), et null.

Référencé par Key\__construct(), Encoding\binToHex(), KeyOrPassword\deriveKeys(), Core\hashEquals(), Encoding\hexToBin(), Core\incrementCounter(), Encoding\loadBytesFromChecksummedAsciiSafeString(), Core\ourSubstr(), Core\pbkdf2(), RuntimeTests\runtimeTest(), Encoding\saveBytesToChecksummedAsciiSafeString(), et Encoding\trimTrailingWhitespace().

◆ ourSubstr()

static ourSubstr | ( | $str,
 |  | $start,
 |  | $length = null
 | ) |
static

Behaves roughly like the function substr() in PHP 7 does.

Paramètres
string | $str
int | $start
int | $length
Exceptions
Ex

Références $start, null, et Core\ourStrlen().

Référencé par Encoding\loadBytesFromChecksummedAsciiSafeString(), Core\pbkdf2(), et Encoding\trimTrailingWhitespace().

◆ pbkdf2()

static pbkdf2 | ( | $algorithm,
 |  | $password,
 |  | $salt,
 |  | $count,
 |  | $key_length,
 |  | $raw_output = false
 | ) |
static

Computes the PBKDF2 password-based key derivation function.

The PBKDF2 function is defined in RFC 2898. Test vectors can be found in RFC 6070. This implementation of PBKDF2 was originally created by Taylor Hornby, with improvements from http://www.variations-of-shadow.com/.

Paramètres
string | $algorithm | The hash algorithm to use. Recommended: SHA256
string | $password | The password.
string | $salt | A salt that is unique to the password.
int | $count | Iteration count. Higher is better, but slower. Recommended: At least 1000.
int | $key_length | The length of the derived key in bytes.
bool | $raw_output | If true, the key is returned in raw binary format. Hex encoded otherwise.
Exceptions
Ex

-suppress InvalidOperand

Références $count, $i, $last, $output, $password, Encoding\binToHex(), Core\ensureTrue(), Core\ourStrlen(), et Core\ourSubstr().

Référencé par KeyOrPassword\deriveKeys().

◆ secureRandom()

static secureRandom ( $octets )
static

Returns a random byte string of the specified length.

Paramètres
int $octets
Exceptions
Ex

Référencé par Key\createNewRandomKey(), Crypto\encryptInternal(), et Core\hashEquals().

Documentation des champs

◆ AUTHENTICATION_INFO_STRING

const AUTHENTICATION_INFO_STRING = 'DefusePHP|V2|KeyForAuthentication'

Référencé par KeyOrPassword\deriveKeys(), et RuntimeTests\runtimeTest().

◆ BLOCK_BYTE_SIZE

const BLOCK_BYTE_SIZE = 16

Référencé par Crypto\encryptInternal(), Core\incrementCounter(), et RuntimeTests\testEncryptDecrypt().

◆ BUFFER_BYTE_SIZE

const BUFFER_BYTE_SIZE = 1048576

◆ CIPHER_METHOD

const CIPHER_METHOD = 'aes-256-ctr'

Référencé par RuntimeTests\AESTestVector(), et RuntimeTests\runtimeTest().

◆ CURRENT_VERSION

const CURRENT_VERSION = "\xDE\xF5\x02\x00"

Référencé par Crypto\encryptInternal().

◆ ENCRYPTION_INFO_STRING

const ENCRYPTION_INFO_STRING = 'DefusePHP|V2|KeyForEncryption'

Référencé par KeyOrPassword\deriveKeys(), et RuntimeTests\runtimeTest().

◆ HASH_FUNCTION_NAME

const HASH_FUNCTION_NAME = 'sha256'

Référencé par KeyProtectedByPassword\changePassword(), KeyProtectedByPassword\createRandomPasswordProtectedKey(), KeyOrPassword\deriveKeys(), Crypto\encryptInternal(), Core\hashEquals(), RuntimeTests\HMACTestVector(), KeyProtectedByPassword\unlockKey(), et Crypto\verifyHMAC().

◆ HEADER_VERSION_SIZE

const HEADER_VERSION_SIZE = 4

Référencé par RuntimeTests\testEncryptDecrypt().

◆ KEY_BYTE_SIZE

const KEY_BYTE_SIZE = 32

Référencé par KeyOrPassword\deriveKeys(), et RuntimeTests\runtimeTest().

◆ LEGACY_AUTHENTICATION_INFO_STRING

const LEGACY_AUTHENTICATION_INFO_STRING = 'DefusePHP|KeyForAuthentication'

◆ LEGACY_BLOCK_BYTE_SIZE

const LEGACY_BLOCK_BYTE_SIZE = 16

◆ LEGACY_CIPHER_METHOD

const LEGACY_CIPHER_METHOD = 'aes-128-cbc'

◆ LEGACY_ENCRYPTION_INFO_STRING

const LEGACY_ENCRYPTION_INFO_STRING = 'DefusePHP|KeyForEncryption'

◆ LEGACY_HASH_FUNCTION_NAME

const LEGACY_HASH_FUNCTION_NAME = 'sha256'

◆ LEGACY_KEY_BYTE_SIZE

const LEGACY_KEY_BYTE_SIZE = 16

◆ LEGACY_MAC_BYTE_SIZE

const LEGACY_MAC_BYTE_SIZE = 32

◆ MAC_BYTE_SIZE

const MAC_BYTE_SIZE = 32

◆ MINIMUM_CIPHERTEXT_SIZE

const MINIMUM_CIPHERTEXT_SIZE = 84

Référencé par RuntimeTests\testEncryptDecrypt().

◆ SALT_BYTE_SIZE

const SALT_BYTE_SIZE = 32

Référencé par KeyOrPassword\deriveKeys(), Crypto\encryptInternal(), et RuntimeTests\testEncryptDecrypt().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Core.php


Joomla CMS: Référence de la classe Crypto

  • Defuse
  • Crypto
  • Crypto
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées statiques
Référence de la classe Crypto
+ Graphe d'héritage de Crypto:
RuntimeTests

Fonctions membres publiques statiques

static | encrypt ($plaintext, $key, $raw_binary=false)
static | encryptWithPassword ($plaintext, $password, $raw_binary=false)
static | decrypt ($ciphertext, $key, $raw_binary=false)
static | decryptWithPassword ($ciphertext, $password, $raw_binary=false)

Fonctions membres protégées statiques

static verifyHMAC ($expected_hmac, $message, $key)

Fonctions membres privées statiques

static encryptInternal ($plaintext, KeyOrPassword $secret, $raw_binary)

Documentation des fonctions membres

◆ decrypt()

static decrypt | ( | $ciphertext,
 |  | $key,
 |  | $raw_binary = false
 | ) |
static

Decrypts a ciphertext to a string with a Key.

Paramètres
string | $ciphertext
Key | $key
bool | $raw_binary
Exceptions

Références $key, et KeyOrPassword\createFromKey().

Référencé par RuntimeTests\testEncryptDecrypt().

◆ decryptWithPassword()

static decryptWithPassword | ( | $ciphertext,
 |  | $password,
 |  | $raw_binary = false
 | ) |
static

Decrypts a ciphertext to a string with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
string | $ciphertext
string | $password
bool | $raw_binary
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

Référencé par KeyProtectedByPassword\unlockKey().

◆ encrypt()

static encrypt | ( | $plaintext,
 |  | $key,
 |  | $raw_binary = false
 | ) |
static

Encrypts a string with a Key.

Paramètres
string | $plaintext
Key | $key
bool | $raw_binary
Exceptions
Ex

Références $key, et KeyOrPassword\createFromKey().

Référencé par RuntimeTests\testEncryptDecrypt().

◆ encryptInternal()

static encryptInternal | ( |  | $plaintext,
 |  | KeyOrPassword | $secret,
 |  |  | $raw_binary
 | ) |  |
staticprivate

Encrypts a string with either a key or a password.

Paramètres
string | $plaintext
KeyOrPassword | $secret
bool | $raw_binary
Renvoie
string

Références Encoding\binToHex(), Core\BLOCK_BYTE_SIZE, Core\CURRENT_VERSION, KeyOrPassword\deriveKeys(), Core\HASH_FUNCTION_NAME, RuntimeTests\runtimeTest(), Core\SALT_BYTE_SIZE, et Core\secureRandom().

◆ encryptWithPassword()

static encryptWithPassword | ( | $plaintext,
 |  | $password,
 |  | $raw_binary = false
 | ) |
static

Encrypts a string with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
string | $plaintext
string | $password
bool | $raw_binary
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

Référencé par KeyProtectedByPassword\changePassword(), et KeyProtectedByPassword\createRandomPasswordProtectedKey().

◆ verifyHMAC()

static verifyHMAC | ( | $expected_hmac,
 |  | $message,
 |  | $key
 | ) |
staticprotected

Verifies an HMAC without leaking information through side-channels.

Paramètres
string | $expected_hmac
string | $message
string | $key
Exceptions
Ex

Références $key, $message, Core\HASH_FUNCTION_NAME, et Core\hashEquals().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/defuse/php-encryption/src/Crypto.php


Joomla CMS: Référence de la classe DerivedKeys

  • Defuse
  • Crypto
  • DerivedKeys
Fonctions membres publiques | Attributs privés
Référence de la classe DerivedKeys

Fonctions membres publiques

getAuthenticationKey ()
getEncryptionKey ()
__construct ($akey, $ekey)

Attributs privés

$akey = ''
$ekey = ''

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $akey,
 |  | $ekey
 | ) |

Constructor for DerivedKeys.

Paramètres
string | $akey
string | $ekey

Références DerivedKeys\$akey, et DerivedKeys\$ekey.

Documentation des fonctions membres

◆ getAuthenticationKey()

getAuthenticationKey ( )

Returns the authentication key.

Renvoie
string

Références DerivedKeys\$akey.

◆ getEncryptionKey()

getEncryptionKey ( )

Returns the encryption key.

Renvoie
string

Références DerivedKeys\$ekey.

Documentation des champs

◆ $akey

$akey = ''
private

Référencé par DerivedKeys\__construct(), et DerivedKeys\getAuthenticationKey().

◆ $ekey

$ekey = ''
private

Référencé par DerivedKeys\__construct(), et DerivedKeys\getEncryptionKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DerivedKeys.php


Joomla CMS: Référence de la classe Encoding

  • Defuse
  • Crypto
  • Encoding
Fonctions membres publiques statiques | Champs de données
Référence de la classe Encoding

Fonctions membres publiques statiques

static | binToHex ($byte_string)
static | hexToBin ($hex_string)
static | trimTrailingWhitespace ($string='')
static | saveBytesToChecksummedAsciiSafeString ($header, $bytes)
static | loadBytesFromChecksummedAsciiSafeString ($expected_header, $string)

Champs de données

const | CHECKSUM_BYTE_SIZE = 32
const | CHECKSUM_HASH_ALGO = 'sha256'
const | SERIALIZE_HEADER_BYTES = 4

Documentation des fonctions membres

◆ binToHex()

static binToHex ( $byte_string )
static

Converts a byte string to a hexadecimal string without leaking information through side channels.

Paramètres
string $byte_string
Exceptions
Ex

Références $b, $c, $i, et Core\ourStrlen().

Référencé par Crypto\encryptInternal(), Core\pbkdf2(), et Encoding\saveBytesToChecksummedAsciiSafeString().

◆ hexToBin()

static hexToBin ( $hex_string )
static

Converts a hexadecimal string into a byte string without leaking information through side channels.

Paramètres
string $hex_string
Exceptions
Ex

Références $c, $state, et Core\ourStrlen().

Référencé par RuntimeTests\AESTestVector(), RuntimeTests\HKDFTestVector(), et Encoding\loadBytesFromChecksummedAsciiSafeString().

◆ loadBytesFromChecksummedAsciiSafeString()

static loadBytesFromChecksummedAsciiSafeString | ( | $expected_header,
 |  | $string
 | ) |
static

INTERNAL USE ONLY: Decodes, verifies the header and checksum, and returns the encoded byte string.

Paramètres
string | $expected_header
string | $string
Exceptions
Ex

Références Core\ensureTrue(), Core\hashEquals(), Encoding\hexToBin(), Core\ourStrlen(), et Core\ourSubstr().

Référencé par Key\loadFromAsciiSafeString(), et KeyProtectedByPassword\loadFromAsciiSafeString().

◆ saveBytesToChecksummedAsciiSafeString()

static saveBytesToChecksummedAsciiSafeString | ( | $header,
 |  | $bytes
 | ) |
static

INTERNAL USE ONLY: Applies a version header, applies a checksum, and then encodes a byte string into a range of printable ASCII characters.

Paramètres
string | $header
string | $bytes
Exceptions
Ex

Références $header, Encoding\binToHex(), Core\ensureTrue(), et Core\ourStrlen().

Référencé par Key\saveToAsciiSafeString(), et KeyProtectedByPassword\saveToAsciiSafeString().

◆ trimTrailingWhitespace()

static trimTrailingWhitespace ( $string = '' )
static

Remove trialing whitespace without table look-ups or branches.

Calling this function may leak the length of the string as well as the number of trailing whitespace characters through side-channels.

Paramètres
string $string
Renvoie
string

Références $last, Core\ourStrlen(), et Core\ourSubstr().

Référencé par Key\loadFromAsciiSafeString().

Documentation des champs

◆ CHECKSUM_BYTE_SIZE

const CHECKSUM_BYTE_SIZE = 32

◆ CHECKSUM_HASH_ALGO

const CHECKSUM_HASH_ALGO = 'sha256'

◆ SERIALIZE_HEADER_BYTES

const SERIALIZE_HEADER_BYTES = 4
La documentation de cette classe a été générée à partir du fichier suivant :
  • defuse/php-encryption/src/Encoding.php


Joomla CMS: Référence de la classe File

  • Defuse
  • Crypto
  • File
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe File

Fonctions membres publiques statiques

static | encryptFile ($inputFilename, $outputFilename, Key $key)
static | encryptFileWithPassword ($inputFilename, $outputFilename, $password)
static | decryptFile ($inputFilename, $outputFilename, Key $key)
static | decryptFileWithPassword ($inputFilename, $outputFilename, $password)
static | encryptResource ($inputHandle, $outputHandle, Key $key)
static | encryptResourceWithPassword ($inputHandle, $outputHandle, $password)
static | decryptResource ($inputHandle, $outputHandle, Key $key)
static | decryptResourceWithPassword ($inputHandle, $outputHandle, $password)

Fonctions membres privées statiques

static | encryptFileInternal ($inputFilename, $outputFilename, KeyOrPassword $secret)
static | decryptFileInternal ($inputFilename, $outputFilename, KeyOrPassword $secret)
static | getLastErrorMessage ()

Documentation des fonctions membres

◆ decryptFile()

static decryptFile | ( |  | $inputFilename,
 |  |  | $outputFilename,
 |  | Key | $key
 | ) |  |
static

Decrypts the input file, saving the plaintext to the output file.

Paramètres
string | $inputFilename
string | $outputFilename
Key | $key
Renvoie
void
Exceptions
Ex

Références $key, et KeyOrPassword\createFromKey().

◆ decryptFileInternal()

static decryptFileInternal | ( |  | $inputFilename,
 |  |  | $outputFilename,
 |  | KeyOrPassword | $secret
 | ) |  |
staticprivate

Decrypts a file with either a key or a password.

Paramètres
string | $inputFilename
string | $outputFilename
KeyOrPassword | $secret
Renvoie
void
Exceptions
Ex

◆ decryptFileWithPassword()

static decryptFileWithPassword | ( | $inputFilename,
 |  | $outputFilename,
 |  | $password
 | ) |
static

Decrypts a file with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
string | $inputFilename
string | $outputFilename
string | $password
Renvoie
void
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

◆ decryptResource()

static decryptResource | ( |  | $inputHandle,
 |  |  | $outputHandle,
 |  | Key | $key
 | ) |  |
static

Takes two resource handles and decrypts the contents of the first, writing the plaintext into the second.

Paramètres
resource | $inputHandle
resource | $outputHandle
Key | $key
Renvoie
void
Exceptions
Ex

Références $key, et KeyOrPassword\createFromKey().

◆ decryptResourceWithPassword()

static decryptResourceWithPassword | ( | $inputHandle,
 |  | $outputHandle,
 |  | $password
 | ) |
static

Decrypts the contents of one resource into another with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
resource | $inputHandle
resource | $outputHandle
string | $password
Renvoie
void
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

◆ encryptFile()

static encryptFile | ( |  | $inputFilename,
 |  |  | $outputFilename,
 |  | Key | $key
 | ) |  |
static

Encrypts the input file, saving the ciphertext to the output file.

Paramètres
string | $inputFilename
string | $outputFilename
Key | $key
Renvoie
void
Exceptions
Ex

Références $key, et KeyOrPassword\createFromKey().

◆ encryptFileInternal()

static encryptFileInternal | ( |  | $inputFilename,
 |  |  | $outputFilename,
 |  | KeyOrPassword | $secret
 | ) |  |
staticprivate

Encrypts a file with either a key or a password.

Paramètres
string | $inputFilename
string | $outputFilename
KeyOrPassword | $secret
Renvoie
void
Exceptions
Ex

◆ encryptFileWithPassword()

static encryptFileWithPassword | ( | $inputFilename,
 |  | $outputFilename,
 |  | $password
 | ) |
static

Encrypts a file with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
string | $inputFilename
string | $outputFilename
string | $password
Renvoie
void
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

◆ encryptResource()

static encryptResource | ( |  | $inputHandle,
 |  |  | $outputHandle,
 |  | Key | $key
 | ) |  |
static

Takes two resource handles and encrypts the contents of the first, writing the ciphertext into the second.

Paramètres
resource | $inputHandle
resource | $outputHandle
Key | $key
Renvoie
void
Exceptions
Ex

Références $key, et KeyOrPassword\createFromKey().

◆ encryptResourceWithPassword()

static encryptResourceWithPassword | ( | $inputHandle,
 |  | $outputHandle,
 |  | $password
 | ) |
static

Encrypts the contents of one resource handle into another with a password, using a slow key derivation function to make password cracking more expensive.

Paramètres
resource | $inputHandle
resource | $outputHandle
string | $password
Renvoie
void
Exceptions
Ex

Références $password, et KeyOrPassword\createFromPassword().

◆ getLastErrorMessage()

static getLastErrorMessage ( )
staticprivate

Returns the last PHP error's or warning's message string.

Renvoie
string

Références null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/defuse/php-encryption/src/File.php


Joomla CMS: Référence de la classe Key

  • Defuse
  • Crypto
  • Key
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Key

Fonctions membres publiques

saveToAsciiSafeString ()
getRawBytes ()

Fonctions membres publiques statiques

static | createNewRandomKey ()
static | loadFromAsciiSafeString ($saved_key_string, $do_not_trim=false)

Champs de données

const | KEY_CURRENT_VERSION = "\xDE\xF0\x00\x00"
const | KEY_BYTE_SIZE = 32

Fonctions membres privées

__construct ($bytes)

Attributs privés

$key_bytes

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $bytes )
private

Constructs a new Key object from a string of raw bytes.

Paramètres
string $bytes
Exceptions
Ex

Références Core\ensureTrue(), et Core\ourStrlen().

Documentation des fonctions membres

◆ createNewRandomKey()

static createNewRandomKey ( )
static

Creates new random key.

Exceptions
Ex

Références Core\secureRandom().

Référencé par KeyProtectedByPassword\createRandomPasswordProtectedKey(), RuntimeTests\runtimeTest(), et RuntimeTests\testEncryptDecrypt().

◆ getRawBytes()

getRawBytes ( )

Gets the raw bytes of the key.

Renvoie
string

Références Key\$key_bytes.

◆ loadFromAsciiSafeString()

static loadFromAsciiSafeString | ( | $saved_key_string,
 |  | $do_not_trim = false
 | ) |
static

Loads a Key from its encoded form.

By default, this function will call Encoding::trimTrailingWhitespace() to remove trailing CR, LF, NUL, TAB, and SPACE characters, which are commonly appended to files when working with text editors.

Paramètres
string | $saved_key_string
bool | $do_not_trim | (default: false)
Exceptions
Ex

Références Key\$key_bytes, Encoding\loadBytesFromChecksummedAsciiSafeString(), et Encoding\trimTrailingWhitespace().

Référencé par KeyProtectedByPassword\unlockKey().

◆ saveToAsciiSafeString()

saveToAsciiSafeString ( )

Encodes the Key into a string of printable ASCII characters.

Exceptions
Ex

Références Encoding\saveBytesToChecksummedAsciiSafeString().

Documentation des champs

◆ $key_bytes

$key_bytes
private

Référencé par Key\getRawBytes(), et Key\loadFromAsciiSafeString().

◆ KEY_BYTE_SIZE

const KEY_BYTE_SIZE = 32

◆ KEY_CURRENT_VERSION

const KEY_CURRENT_VERSION = "\xDE\xF0\x00\x00"
La documentation de cette classe a été générée à partir du fichier suivant :
  • defuse/php-encryption/src/Key.php


Joomla CMS: Référence de la classe KeyOrPassword

  • Defuse
  • Crypto
  • KeyOrPassword
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe KeyOrPassword

Fonctions membres publiques

deriveKeys ($salt)

Fonctions membres publiques statiques

static | createFromKey (Key $key)
static | createFromPassword ($password)

Champs de données

const | PBKDF2_ITERATIONS = 100000
const | SECRET_TYPE_KEY = 1
const | SECRET_TYPE_PASSWORD = 2

Fonctions membres privées

__construct ($secret_type, $secret)

Attributs privés

$secret_type = 0
$secret

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $secret_type,
 |  | $secret
 | ) |
private

Constructor for KeyOrPassword.

Paramètres
int | $secret_type
mixed | $secret | (either a Key or a password string)

Références KeyOrPassword\$secret, KeyOrPassword\$secret_type, elseif, et Core\ensureTrue().

Documentation des fonctions membres

◆ createFromKey()

static createFromKey ( Key $key )
static

Initializes an instance of KeyOrPassword from a key.

Paramètres
Key $key
Renvoie
KeyOrPassword

Références $key.

Référencé par Crypto\decrypt(), File\decryptFile(), File\decryptResource(), Crypto\encrypt(), File\encryptFile(), et File\encryptResource().

◆ createFromPassword()

static createFromPassword ( $password )
static

Initializes an instance of KeyOrPassword from a password.

Paramètres
string $password
Renvoie
KeyOrPassword

Références $password.

Référencé par File\decryptFileWithPassword(), File\decryptResourceWithPassword(), Crypto\decryptWithPassword(), File\encryptFileWithPassword(), File\encryptResourceWithPassword(), et Crypto\encryptWithPassword().

◆ deriveKeys()

deriveKeys ( $salt )

Derives authentication and encryption keys from the secret, using a slow key derivation function if the secret is a password.

Paramètres
string $salt
Exceptions
Ex

-suppress PossiblyInvalidMethodCall

-suppress PossiblyInvalidMethodCall

-suppress PossiblyInvalidArgument

Références Core\AUTHENTICATION_INFO_STRING, elseif, Core\ENCRYPTION_INFO_STRING, Core\ensureTrue(), Core\HASH_FUNCTION_NAME, Core\KEY_BYTE_SIZE, Core\ourStrlen(), Core\pbkdf2(), et Core\SALT_BYTE_SIZE.

Référencé par Crypto\encryptInternal().

Documentation des champs

◆ $secret

$secret
private

Référencé par KeyOrPassword\__construct().

◆ $secret_type

$secret_type = 0
private

Référencé par KeyOrPassword\__construct().

◆ PBKDF2_ITERATIONS

const PBKDF2_ITERATIONS = 100000

◆ SECRET_TYPE_KEY

const SECRET_TYPE_KEY = 1

◆ SECRET_TYPE_PASSWORD

const SECRET_TYPE_PASSWORD = 2
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyOrPassword.php


Joomla CMS: Référence de la classe KeyProtectedByPassword

  • Defuse
  • Crypto
  • KeyProtectedByPassword
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe KeyProtectedByPassword

Fonctions membres publiques

saveToAsciiSafeString ()
unlockKey ($password)
changePassword ($current_password, $new_password)

Fonctions membres publiques statiques

static | createRandomPasswordProtectedKey ($password)
static | loadFromAsciiSafeString ($saved_key_string)

Champs de données

const PASSWORD_KEY_CURRENT_VERSION = "\xDE\xF1\x00\x00"

Fonctions membres privées

__construct ($encrypted_key)

Attributs privés

$encrypted_key = ''

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $encrypted_key )
private

Constructor for KeyProtectedByPassword.

Paramètres
string $encrypted_key

Références KeyProtectedByPassword\$encrypted_key.

Documentation des fonctions membres

◆ changePassword()

changePassword | ( | $current_password,
 |  | $new_password
 | ) |

Changes the password.

Paramètres
string | $current_password
string | $new_password
Exceptions
Ex

Références KeyProtectedByPassword\$encrypted_key, $this, Crypto\encryptWithPassword(), Core\HASH_FUNCTION_NAME, true, et KeyProtectedByPassword\unlockKey().

◆ createRandomPasswordProtectedKey()

static createRandomPasswordProtectedKey ( $password )
static

Creates a random key protected by the provided password.

Paramètres
string $password
Exceptions
Ex

Références KeyProtectedByPassword\$encrypted_key, $password, Key\createNewRandomKey(), Crypto\encryptWithPassword(), Core\HASH_FUNCTION_NAME, et true.

◆ loadFromAsciiSafeString()

static loadFromAsciiSafeString ( $saved_key_string )
static

Loads a KeyProtectedByPassword from its encoded form.

Paramètres
string $saved_key_string
Exceptions
Ex

Références KeyProtectedByPassword\$encrypted_key, et Encoding\loadBytesFromChecksummedAsciiSafeString().

◆ saveToAsciiSafeString()

saveToAsciiSafeString ( )

Encodes the KeyProtectedByPassword into a string of printable ASCII characters.

Exceptions
Ex

Références Encoding\saveBytesToChecksummedAsciiSafeString().

◆ unlockKey()

unlockKey ( $password )

Decrypts the protected key, returning an unprotected Key object that can be used for encryption and decryption.

Exceptions
Ex

Références $password, Crypto\decryptWithPassword(), Core\HASH_FUNCTION_NAME, et Key\loadFromAsciiSafeString().

Référencé par KeyProtectedByPassword\changePassword().

Documentation des champs

◆ $encrypted_key

$encrypted_key = ''
private

Référencé par KeyProtectedByPassword\__construct(), KeyProtectedByPassword\changePassword(), KeyProtectedByPassword\createRandomPasswordProtectedKey(), et KeyProtectedByPassword\loadFromAsciiSafeString().

◆ PASSWORD_KEY_CURRENT_VERSION

const PASSWORD_KEY_CURRENT_VERSION = "\xDE\xF1\x00\x00"
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyProtectedByPassword.php


Joomla CMS: Référence de la classe RuntimeTests

  • Defuse
  • Crypto
  • RuntimeTests
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe RuntimeTests
+ Graphe d'héritage de RuntimeTests:
Crypto

Fonctions membres publiques statiques

static | runtimeTest ()
- Fonctions membres publiques statiques hérités de Crypto
static | encrypt ($plaintext, $key, $raw_binary=false)
static | encryptWithPassword ($plaintext, $password, $raw_binary=false)
static | decrypt ($ciphertext, $key, $raw_binary=false)
static | decryptWithPassword ($ciphertext, $password, $raw_binary=false)

Fonctions membres privées statiques

static | testEncryptDecrypt ()
static | HKDFTestVector ()
static | HMACTestVector ()
static | AESTestVector ()

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de Crypto
static verifyHMAC ($expected_hmac, $message, $key)

Documentation des fonctions membres

◆ AESTestVector()

static AESTestVector ( )
staticprivate

Test AES against test vectors.

Exceptions
Ex

Références $key, Core\CIPHER_METHOD, Core\ensureTrue(), et Encoding\hexToBin().

Référencé par RuntimeTests\runtimeTest().

◆ HKDFTestVector()

static HKDFTestVector ( )
staticprivate

Test HKDF against test vectors.

Exceptions
Ex

Références $info, Core\ensureTrue(), Encoding\hexToBin(), et null.

Référencé par RuntimeTests\runtimeTest().

◆ HMACTestVector()

static HMACTestVector ( )
staticprivate

Test HMAC against test vectors.

Exceptions
Ex

Références $data, $key, Core\ensureTrue(), et Core\HASH_FUNCTION_NAME.

Référencé par RuntimeTests\runtimeTest().

◆ runtimeTest()

static runtimeTest ( )
static

Runs the runtime tests.

Exceptions
Ex

Références RuntimeTests\AESTestVector(), Core\AUTHENTICATION_INFO_STRING, Core\CIPHER_METHOD, Key\createNewRandomKey(), Core\ENCRYPTION_INFO_STRING, Core\ensureFunctionExists(), Core\ensureTrue(), RuntimeTests\HKDFTestVector(), RuntimeTests\HMACTestVector(), Core\KEY_BYTE_SIZE, Core\ourStrlen(), et RuntimeTests\testEncryptDecrypt().

Référencé par Crypto\encryptInternal(), et Crypto\isSupported().

◆ testEncryptDecrypt()

static testEncryptDecrypt ( )
staticprivate

High-level tests of Crypto operations.

Exceptions
Ex

Références $data, $key, Core\BLOCK_BYTE_SIZE, Key\createNewRandomKey(), Crypto\decrypt(), Crypto\encrypt(), Core\ensureTrue(), Core\HEADER_VERSION_SIZE, Core\MINIMUM_CIPHERTEXT_SIZE, et Core\SALT_BYTE_SIZE.

Référencé par RuntimeTests\runtimeTest().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RuntimeTests.php


Joomla CMS: Référence de la classe Inflector

  • Doctrine
  • Common
  • Inflector
  • Inflector
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Inflector
+ Graphe d'héritage de Inflector:
Inflector

Fonctions membres publiques statiques

static | tableize (string $word)
static | classify (string $word)
static | camelize (string $word)
static | ucwords (string $string, string $delimiters=" \\\B-")
static | reset ()
static | rules (string $type, iterable $rules, bool $reset=false)
static | pluralize (string $word)
static | singularize (string $word)

Fonctions membres privées statiques

static | getInstance ()
static | createFactory ()
static | buildRuleset (iterable $rules)

Attributs privés statiques

static | $factory
static | $instance

Description détaillée

Obsolète:

Documentation des fonctions membres

◆ buildRuleset()

static buildRuleset ( iterable $rules )
staticprivate
Paramètres
array<string,mixed>|iterable<string,mixed> $rules An array of rules to be added.

◆ camelize()

static camelize ( string $word )
static

Camelizes a word. This uses the classify() method and turns the first character to lowercase.

Obsolète:

◆ classify()

static classify ( string $word )
static

Converts a word into the format for a Doctrine class name. Converts 'table_name' to 'TableName'.

◆ createFactory()

static createFactory ( )
staticprivate

Références InflectorFactory\create().

◆ getInstance()

static getInstance ( )
staticprivate

Références null.

Référencé par FormController\__construct(), et ListView\addToolbar().

◆ pluralize()

static pluralize ( string $word )
static

Returns a word in plural form.

Paramètres
string $word The word in singular form.
Renvoie
string The word in plural form.
Obsolète:

Référencé par DisplayController\display().

◆ reset()

static reset ( )
static

Clears Inflectors inflected value caches, and resets the inflection rules to the initial values.

Obsolète:

Références null.

◆ rules()

static rules | ( | string | $type,
 |  | iterable | $rules,
 |  | bool | $reset = false
 | ) |  |
static

Adds custom inflection $rules, of either 'plural' or 'singular' $type.

Usage:

{{{ Inflector::rules('plural', array('/^(inflect)or$/i' => '\1ables')); Inflector::rules('plural', array( 'rules' => array('/^(inflect)ors$/i' => '\1ables'), 'uninflected' => array('dontinflectme'), 'irregular' => array('red' => 'redlings') )); }}}

Paramètres
string | $type | The type of inflection, either 'plural' or 'singular'
array<string,mixed>|iterable<string,mixed> | $rules An array of rules to be added.
boolean | $reset | If true, will unset default inflections for all new rules that are being defined in $rules.
Renvoie
void
Obsolète:

Références $type, et null.

◆ singularize()

static singularize ( string $word )
static

Returns a word in singular form.

Paramètres
string $word The word in plural form.
Renvoie
string The word in singular form.
Obsolète:

Référencé par MediaController\delete(), et StylesController\preprocessSaveData().

◆ tableize()

static tableize ( string $word )
static

Converts a word into the format for a Doctrine table name. Converts 'ModelName' to 'model_name'.

Obsolète:

◆ ucwords()

static ucwords | ( | string | $string,
 |  | string | $delimiters = " \n\t\r\0\x0B-"
 | ) |  |
static

Uppercases words with configurable delimiters between words.

Takes a string and capitalizes all of the words, like PHP's built-in ucwords function. This extends that behavior, however, by allowing the word delimiters to be configured, rather than only separating on whitespace.

Here is an example: <?php $string = 'top-o-the-morning to all_of_you!'; echo ::ucwords($string); // Top-O-The-Morning To All_of_you!

echo ::ucwords($string, '-_ '); // Top-O-The-Morning To All_Of_You! ?>

Paramètres
string | $string | The string to operate on.
string | $delimiters | A list of word separators.
Renvoie
string The string with all delimiter-separated words capitalized.
Obsolète:

Documentation des champs

◆ $factory

$factory
staticprivate

◆ $instance

$instance
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • English
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • English/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • English
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/English/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • English
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/English/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • English
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • English/Uninflected.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • French
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • French/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • French
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/French/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • French
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/French/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • French
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • French/Uninflected.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NorwegianBokmal/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/NorwegianBokmal/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/NorwegianBokmal/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NorwegianBokmal/Uninflected.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • Portuguese
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Portuguese/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • Portuguese
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/Portuguese/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • Portuguese
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Portuguese/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • Portuguese
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Portuguese/Uninflected.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • Spanish
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Spanish/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • Spanish
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/Spanish/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • Spanish
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Spanish/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • Spanish
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Spanish/Uninflected.php


Joomla CMS: Référence de la classe Inflectible

  • Doctrine
  • Inflector
  • Rules
  • Turkish
  • Inflectible
Fonctions membres publiques statiques
Référence de la classe Inflectible

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()
static | getIrregular ()

Documentation des fonctions membres

◆ getIrregular()

static getIrregular ( )
static
Renvoie
Substitution[]

Référencé par Rules\getPluralRuleset(), et Rules\getSingularRuleset().

◆ getPlural()

static getPlural ( )
static
Renvoie
Transformation[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Transformation[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Turkish/Inflectible.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • Rules
  • Turkish
  • InflectorFactory
Fonctions membres protégées
Référence de la classe InflectorFactory
+ Graphe d'héritage de InflectorFactory:
GenericLanguageInflectorFactory LanguageInflectorFactory

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()
- Fonctions membres protégées hérités de GenericLanguageInflectorFactory
getSingularRuleset ()
getPluralRuleset ()

Membres hérités additionnels

- Fonctions membres publiques hérités de GenericLanguageInflectorFactory
__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Documentation des fonctions membres

◆ getPluralRuleset()

getPluralRuleset ( )
protected

Références Rules\getPluralRuleset().

◆ getSingularRuleset()

getSingularRuleset ( )
protected

Références Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rules/Turkish/InflectorFactory.php


Joomla CMS: Référence de la classe Rules

  • Doctrine
  • Inflector
  • Rules
  • Turkish
  • Rules
Fonctions membres publiques statiques
Référence de la classe Rules

Fonctions membres publiques statiques

static | getSingularRuleset ()
static | getPluralRuleset ()

Documentation des fonctions membres

◆ getPluralRuleset()

static getPluralRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getPlural(), et Inflectible\getPlural().

Référencé par InflectorFactory\getPluralRuleset().

◆ getSingularRuleset()

static getSingularRuleset ( )
static

Références Inflectible\getIrregular(), Uninflected\getSingular(), et Inflectible\getSingular().

Référencé par InflectorFactory\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Turkish/Rules.php


Joomla CMS: Référence de la classe Uninflected

  • Doctrine
  • Inflector
  • Rules
  • Turkish
  • Uninflected
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Uninflected

Fonctions membres publiques statiques

static | getSingular ()
static | getPlural ()

Fonctions membres privées statiques

static getDefault ()

Documentation des fonctions membres

◆ getDefault()

static getDefault ( )
staticprivate
Renvoie
Pattern[]

◆ getPlural()

static getPlural ( )
static
Renvoie
Pattern[]

Référencé par Rules\getPluralRuleset().

◆ getSingular()

static getSingular ( )
static
Renvoie
Pattern[]

Référencé par Rules\getSingularRuleset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Turkish/Uninflected.php


Joomla CMS: Référence de la classe Pattern

  • Doctrine
  • Inflector
  • Rules
  • Pattern
Fonctions membres publiques | Attributs privés
Référence de la classe Pattern

Fonctions membres publiques

__construct (string $pattern)
getPattern ()
getRegex ()
matches (string $word)

Attributs privés

$pattern
$regex

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $pattern )

Références Pattern\$pattern.

Documentation des fonctions membres

◆ getPattern()

getPattern ( )

Références Pattern\$pattern.

Référencé par Patterns\__construct().

◆ getRegex()

getRegex ( )

Références Pattern\$regex.

Référencé par Pattern\matches().

◆ matches()

matches ( string $word )

Références Pattern\getRegex().

Documentation des champs

◆ $pattern

$pattern
private

Référencé par Pattern\__construct(), et Pattern\getPattern().

◆ $regex

$regex
private

Référencé par Pattern\getRegex().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Pattern.php


Joomla CMS: Référence de la classe Patterns

  • Doctrine
  • Inflector
  • Rules
  • Patterns
Fonctions membres publiques | Attributs privés
Référence de la classe Patterns

Fonctions membres publiques

__construct (Pattern ... $patterns)
matches (string $word)

Attributs privés

$patterns
$regex

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Pattern ... $patterns )

Références Patterns\$patterns, et Pattern\getPattern().

Documentation des fonctions membres

◆ matches()

matches ( string $word )

Documentation des champs

◆ $patterns

$patterns
private

Référencé par Patterns\__construct().

◆ $regex

$regex
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Patterns.php


Joomla CMS: Référence de la classe Ruleset

  • Doctrine
  • Inflector
  • Rules
  • Ruleset
Fonctions membres publiques | Attributs privés
Référence de la classe Ruleset

Fonctions membres publiques

__construct (Transformations $regular, Patterns $uninflected, Substitutions $irregular)
getRegular ()
getUninflected ()
getIrregular ()

Attributs privés

$regular
$uninflected
$irregular

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Transformations | $regular,
 |  | Patterns | $uninflected,
 |  | Substitutions | $irregular
 | ) |  |

Références Ruleset\$irregular, Ruleset\$regular, et Ruleset\$uninflected.

Documentation des fonctions membres

◆ getIrregular()

getIrregular ( )

Références Ruleset\$irregular.

◆ getRegular()

getRegular ( )

Références Ruleset\$regular.

◆ getUninflected()

getUninflected ( )

Références Ruleset\$uninflected.

Documentation des champs

◆ $irregular

$irregular
private

Référencé par Ruleset\__construct(), et Ruleset\getIrregular().

◆ $regular

$regular
private

Référencé par Ruleset\__construct(), et Ruleset\getRegular().

◆ $uninflected

$uninflected
private

Référencé par Ruleset\__construct(), et Ruleset\getUninflected().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ruleset.php


Joomla CMS: Référence de la classe Substitution

  • Doctrine
  • Inflector
  • Rules
  • Substitution
Fonctions membres publiques | Attributs privés
Référence de la classe Substitution

Fonctions membres publiques

__construct (Word $from, Word $to)
getFrom ()
getTo ()

Attributs privés

$from
$to

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Word | $from,
 |  | Word | $to
 | ) |  |

Références Substitution\$from, et Substitution\$to.

Documentation des fonctions membres

◆ getFrom()

getFrom ( )

Références Substitution\$from.

◆ getTo()

getTo ( )

Références Substitution\$to.

Documentation des champs

◆ $from

$from
private

Référencé par Substitution\__construct(), et Substitution\getFrom().

◆ $to

$to
private

Référencé par Substitution\__construct(), et Substitution\getTo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Substitution.php


Joomla CMS: Référence de la classe Substitutions

  • Doctrine
  • Inflector
  • Rules
  • Substitutions
Fonctions membres publiques | Attributs privés
Référence de la classe Substitutions
+ Graphe d'héritage de Substitutions:
WordInflector

Fonctions membres publiques

__construct (Substitution ... $substitutions)
getFlippedSubstitutions ()
inflect (string $word)

Attributs privés

$substitutions

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Substitution ... $substitutions )

Références Substitutions\$substitutions.

Documentation des fonctions membres

◆ getFlippedSubstitutions()

getFlippedSubstitutions ( )

Références Substitutions\$substitutions.

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

Documentation des champs

◆ $substitutions

$substitutions
private

Référencé par Substitutions\__construct(), et Substitutions\getFlippedSubstitutions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Substitutions.php


Joomla CMS: Référence de la classe Transformation

  • Doctrine
  • Inflector
  • Rules
  • Transformation
Fonctions membres publiques | Attributs privés
Référence de la classe Transformation
+ Graphe d'héritage de Transformation:
WordInflector

Fonctions membres publiques

__construct (Pattern $pattern, string $replacement)
getPattern ()
getReplacement ()
inflect (string $word)

Attributs privés

$pattern
$replacement

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Pattern | $pattern,
 |  | string | $replacement
 | ) |  |

Références Transformation\$pattern, et Transformation\$replacement.

Documentation des fonctions membres

◆ getPattern()

getPattern ( )

Références Transformation\$pattern.

◆ getReplacement()

getReplacement ( )

Références Transformation\$replacement.

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

Références Transformation\$replacement.

Documentation des champs

◆ $pattern

$pattern
private

Référencé par Transformation\__construct(), et Transformation\getPattern().

◆ $replacement

$replacement
private

Référencé par Transformation\__construct(), Transformation\getReplacement(), et Transformation\inflect().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Transformation.php


Joomla CMS: Référence de la classe Transformations

  • Doctrine
  • Inflector
  • Rules
  • Transformations
Fonctions membres publiques | Attributs privés
Référence de la classe Transformations
+ Graphe d'héritage de Transformations:
WordInflector

Fonctions membres publiques

__construct (Transformation ... $transformations)
inflect (string $word)

Attributs privés

$transformations

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Transformation ... $transformations )

Références Transformations\$transformations.

Documentation des fonctions membres

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

Documentation des champs

◆ $transformations

$transformations
private

Référencé par Transformations\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Transformations.php


Joomla CMS: Référence de la classe Word

  • Doctrine
  • Inflector
  • Rules
  • Word
Fonctions membres publiques | Attributs privés
Référence de la classe Word

Fonctions membres publiques

__construct (string $word)
getWord ()

Attributs privés

$word

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $word )

Références Word\$word.

Documentation des fonctions membres

◆ getWord()

getWord ( )

Références Word\$word.

Documentation des champs

◆ $word

$word
private

Référencé par Word\__construct(), et Word\getWord().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Word.php


Joomla CMS: Référence de la classe CachedWordInflector

  • Doctrine
  • Inflector
  • CachedWordInflector
Fonctions membres publiques | Attributs privés
Référence de la classe CachedWordInflector
+ Graphe d'héritage de CachedWordInflector:
WordInflector

Fonctions membres publiques

__construct (WordInflector $wordInflector)
inflect (string $word)

Attributs privés

$wordInflector
$cache = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( WordInflector $wordInflector )

Références CachedWordInflector\$wordInflector.

Documentation des fonctions membres

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

Documentation des champs

◆ $cache

$cache = []
private

◆ $wordInflector

$wordInflector
private

Référencé par CachedWordInflector\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CachedWordInflector.php


Joomla CMS: Référence de la classe GenericLanguageInflectorFactory

  • Doctrine
  • Inflector
  • GenericLanguageInflectorFactory
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe GenericLanguageInflectorFactory
+ Graphe d'héritage de GenericLanguageInflectorFactory:
LanguageInflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory

Fonctions membres publiques

__construct ()
build ()
withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)

Fonctions membres protégées

getSingularRuleset ()
getPluralRuleset ()

Attributs privés

$singularRulesets = []
$pluralRulesets = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
final

Références GenericLanguageInflectorFactory\getPluralRuleset(), et GenericLanguageInflectorFactory\getSingularRuleset().

Documentation des fonctions membres

◆ build()

build ( )
final

Builds the inflector instance with all applicable rules

Implémente LanguageInflectorFactory.

◆ getPluralRuleset()

getPluralRuleset ( )
abstractprotected

Référencé par GenericLanguageInflectorFactory\__construct().

◆ getSingularRuleset()

getSingularRuleset ( )
abstractprotected

Référencé par GenericLanguageInflectorFactory\__construct().

◆ withPluralRules()

withPluralRules | ( | ?Ruleset | $pluralRules,
 |  | bool | $reset = false
 | ) |  |
final

Applies custom rules for pluralisation

Paramètres
bool $reset If true, will unset default inflections for all new rules
Renvoie
$this

Implémente LanguageInflectorFactory.

Références $this.

◆ withSingularRules()

withSingularRules | ( | ?Ruleset | $singularRules,
 |  | bool | $reset = false
 | ) |  |
final

Applies custom rules for singularisation

Paramètres
bool $reset If true, will unset default inflections for all new rules
Renvoie
$this

Implémente LanguageInflectorFactory.

Références $this.

Documentation des champs

◆ $pluralRulesets

$pluralRulesets = []
private

◆ $singularRulesets

$singularRulesets = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • GenericLanguageInflectorFactory.php


Joomla CMS: Référence de la classe Inflector

  • Doctrine
  • Inflector
  • Inflector
Fonctions membres publiques | Attributs privés
Référence de la classe Inflector

Fonctions membres publiques

__construct (WordInflector $singularizer, WordInflector $pluralizer)
tableize (string $word)
classify (string $word)
camelize (string $word)
capitalize (string $string, string $delimiters=" \\\B-")
seemsUtf8 (string $string)
unaccent (string $string)
urlize (string $string)
singularize (string $word)
pluralize (string $word)

Attributs privés

const ACCENTED_CHARACTERS
$singularizer
$pluralizer

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | WordInflector | $singularizer,
 |  | WordInflector | $pluralizer
 | ) |  |

Références Inflector\$pluralizer, et Inflector\$singularizer.

Documentation des fonctions membres

◆ camelize()

camelize ( string $word )

Camelizes a word. This uses the classify() method and turns the first character to lowercase.

Références Inflector\classify().

◆ capitalize()

capitalize | ( | string | $string,
 |  | string | $delimiters = " \n\t\r\0\x0B-"
 | ) |  |

Uppercases words with configurable delimiters between words.

Takes a string and capitalizes all of the words, like PHP's built-in ucwords function. This extends that behavior, however, by allowing the word delimiters to be configured, rather than only separating on whitespace.

Here is an example: <?php $string = 'top-o-the-morning to all_of_you!'; echo $inflector->capitalize($string); // Top-O-The-Morning To All_of_you!

echo $inflector->capitalize($string, '-_ '); // Top-O-The-Morning To All_Of_You! ?>

Paramètres
string | $string | The string to operate on.
string | $delimiters | A list of word separators.
Renvoie
string The string with all delimiter-separated words capitalized.

◆ classify()

classify ( string $word )

Converts a word into the format for a Doctrine class name. Converts 'table_name' to 'TableName'.

Référencé par Inflector\camelize().

◆ pluralize()

pluralize ( string $word )

Returns a word in plural form.

Paramètres
string $word The word in singular form.
Renvoie
string The word in plural form.

◆ seemsUtf8()

seemsUtf8 ( string $string )

Checks if the given string seems like it has utf8 characters in it.

Paramètres
string $string The string to check for utf8 characters in.

Références $i, $n, et elseif.

Référencé par Inflector\unaccent().

◆ singularize()

singularize ( string $word )

Returns a word in singular form.

Paramètres
string $word The word in plural form.
Renvoie
string The word in singular form.

◆ tableize()

tableize ( string $word )

Converts a word into the format for a Doctrine table name. Converts 'ModelName' to 'model_name'.

Références null.

◆ unaccent()

unaccent ( string $string )

Remove any illegal characters, accents, etc.

Paramètres
string $string String to unaccent
Renvoie
string Unaccented string

Références Inflector\seemsUtf8().

Référencé par Inflector\urlize().

◆ urlize()

urlize ( string $string )

Convert any passed string to a url friendly string. Converts 'My first blog post' to 'my-first-blog-post'

Paramètres
string $string String to urlize.
Renvoie
string Urlized string.

Références null, et Inflector\unaccent().

Documentation des champs

◆ $pluralizer

$pluralizer
private

Référencé par Inflector\__construct().

◆ $singularizer

$singularizer
private

Référencé par Inflector\__construct().

◆ ACCENTED_CHARACTERS

const ACCENTED_CHARACTERS
private
Valeur initiale :
= [
'À' => 'A'
La documentation de cette classe a été générée à partir du fichier suivant :
  • doctrine/inflector/lib/Doctrine/Inflector/Inflector.php


Joomla CMS: Référence de la classe InflectorFactory

  • Doctrine
  • Inflector
  • InflectorFactory
Fonctions membres publiques statiques
Référence de la classe InflectorFactory

Fonctions membres publiques statiques

static | create ()
static | createForLanguage (string $language)

Documentation des fonctions membres

◆ create()

static create ( )
static

Références Language\ENGLISH.

Référencé par Inflector\createFactory().

◆ createForLanguage()

static createForLanguage ( string $language )
static

Références $language, Language\ENGLISH, Language\FRENCH, Language\NORWEGIAN_BOKMAL, Language\PORTUGUESE, Language\SPANISH, et Language\TURKISH.

La documentation de cette classe a été générée à partir du fichier suivant :
  • InflectorFactory.php


Joomla CMS: Référence de la classe Language

  • Doctrine
  • Inflector
  • Language
Champs de données | Fonctions membres privées
Référence de la classe Language

Champs de données

const | ENGLISH = 'english'
const | FRENCH = 'french'
const | NORWEGIAN_BOKMAL = 'norwegian-bokmal'
const | PORTUGUESE = 'portuguese'
const | SPANISH = 'spanish'
const | TURKISH = 'turkish'

Fonctions membres privées

__construct ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Documentation des champs

◆ ENGLISH

const ENGLISH = 'english'

Référencé par InflectorFactory\create(), et InflectorFactory\createForLanguage().

◆ FRENCH

const FRENCH = 'french'

Référencé par InflectorFactory\createForLanguage().

◆ NORWEGIAN_BOKMAL

const NORWEGIAN_BOKMAL = 'norwegian-bokmal'

Référencé par InflectorFactory\createForLanguage().

◆ PORTUGUESE

const PORTUGUESE = 'portuguese'

Référencé par InflectorFactory\createForLanguage().

◆ SPANISH

const SPANISH = 'spanish'

Référencé par InflectorFactory\createForLanguage().

◆ TURKISH

const TURKISH = 'turkish'

Référencé par InflectorFactory\createForLanguage().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/doctrine/inflector/lib/Doctrine/Inflector/Language.php


Joomla CMS: Référence de l'interface LanguageInflectorFactory

  • Doctrine
  • Inflector
  • LanguageInflectorFactory
Fonctions membres publiques
Référence de l'interface LanguageInflectorFactory
+ Graphe d'héritage de LanguageInflectorFactory:
GenericLanguageInflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory InflectorFactory

Fonctions membres publiques

withSingularRules (?Ruleset $singularRules, bool $reset=false)
withPluralRules (?Ruleset $pluralRules, bool $reset=false)
build ()

Documentation des fonctions membres

◆ build()

build ( )

Builds the inflector instance with all applicable rules

Implémenté dans GenericLanguageInflectorFactory.

◆ withPluralRules()

withPluralRules | ( | ?Ruleset | $pluralRules,
 |  | bool | $reset = false
 | ) |  |

Applies custom rules for pluralisation

Paramètres
bool $reset If true, will unset default inflections for all new rules
Renvoie
$this

Implémenté dans GenericLanguageInflectorFactory.

◆ withSingularRules()

withSingularRules | ( | ?Ruleset | $singularRules,
 |  | bool | $reset = false
 | ) |  |

Applies custom rules for singularisation

Paramètres
bool $reset If true, will unset default inflections for all new rules
Renvoie
$this

Implémenté dans GenericLanguageInflectorFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LanguageInflectorFactory.php


Joomla CMS: Référence de la classe NoopWordInflector

  • Doctrine
  • Inflector
  • NoopWordInflector
Fonctions membres publiques
Référence de la classe NoopWordInflector
+ Graphe d'héritage de NoopWordInflector:
WordInflector

Fonctions membres publiques

inflect (string $word)

Documentation des fonctions membres

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NoopWordInflector.php


Joomla CMS: Référence de la classe RulesetInflector

  • Doctrine
  • Inflector
  • RulesetInflector
Fonctions membres publiques | Attributs privés
Référence de la classe RulesetInflector
+ Graphe d'héritage de RulesetInflector:
WordInflector

Fonctions membres publiques

__construct (Ruleset $ruleset, Ruleset ... $rulesets)
inflect (string $word)

Attributs privés

$rulesets

Description détaillée

Inflects based on multiple rulesets.

Rules:

  • If the word matches any uninflected word pattern, it is not inflected
  • The first ruleset that returns a different value for an irregular word wins
  • The first ruleset that returns a different value for a regular word wins
  • If none of the above match, the word is left as-is

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Ruleset | $ruleset,
 |  | Ruleset ... | $rulesets
 | ) |  |

Références RulesetInflector\$rulesets.

Documentation des fonctions membres

◆ inflect()

inflect ( string $word )

Implémente WordInflector.

Documentation des champs

◆ $rulesets

$rulesets
private

Référencé par RulesetInflector\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RulesetInflector.php


Joomla CMS: Référence de l'interface WordInflector

  • Doctrine
  • Inflector
  • WordInflector
Fonctions membres publiques
Référence de l'interface WordInflector
+ Graphe d'héritage de WordInflector:
CachedWordInflector NoopWordInflector Substitutions Transformation Transformations RulesetInflector

Fonctions membres publiques

inflect (string $word)

Documentation des fonctions membres

◆ inflect()

inflect ( string $word )

Implémenté dans Substitutions, Transformation, RulesetInflector, CachedWordInflector, Transformations, et NoopWordInflector.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WordInflector.php


Joomla CMS: Référence de la classe AllowedAttributes

  • enshrined
  • svgSanitize
  • data
  • AllowedAttributes
Fonctions membres publiques statiques
Référence de la classe AllowedAttributes
+ Graphe d'héritage de AllowedAttributes:
AttributeInterface

Fonctions membres publiques statiques

static getAttributes ()

Documentation des fonctions membres

◆ getAttributes()

static getAttributes ( )
static

Returns an array of attributes

Renvoie
array

Implémente AttributeInterface.

Référencé par Sanitizer\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AllowedAttributes.php


Joomla CMS: Référence de la classe AllowedTags

  • enshrined
  • svgSanitize
  • data
  • AllowedTags
Fonctions membres publiques statiques
Référence de la classe AllowedTags
+ Graphe d'héritage de AllowedTags:
TagInterface

Fonctions membres publiques statiques

static getTags ()

Documentation des fonctions membres

◆ getTags()

static getTags ( )
static

Returns an array of tags

Renvoie
array

Implémente TagInterface.

Référencé par Sanitizer\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AllowedTags.php


Joomla CMS: Référence de l'interface AttributeInterface

  • enshrined
  • svgSanitize
  • data
  • AttributeInterface
Fonctions membres publiques statiques
Référence de l'interface AttributeInterface
+ Graphe d'héritage de AttributeInterface:
AllowedAttributes

Fonctions membres publiques statiques

static getAttributes ()

Documentation des fonctions membres

◆ getAttributes()

static getAttributes ( )
static

Returns an array of attributes

Renvoie
array

Implémenté dans AllowedAttributes.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AttributeInterface.php


Joomla CMS: Référence de l'interface TagInterface

  • enshrined
  • svgSanitize
  • data
  • TagInterface
Fonctions membres publiques statiques
Référence de l'interface TagInterface
+ Graphe d'héritage de TagInterface:
AllowedTags

Fonctions membres publiques statiques

static getTags ()

Documentation des fonctions membres

◆ getTags()

static getTags ( )
static

Returns an array of tags

Renvoie
array

Implémenté dans AllowedTags.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TagInterface.php


Joomla CMS: Référence de la classe XPath

  • enshrined
  • svgSanitize
  • data
  • XPath
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe XPath
+ Graphe d'héritage de XPath:

Fonctions membres publiques

__construct (\DOMDocument $doc)
createNodeName ($nodeName)

Champs de données

const DEFAULT_NAMESPACE_PREFIX = 'svg'

Fonctions membres protégées

handleDefaultNamespace ()

Attributs protégés

$defaultNamespaceURI

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \DOMDocument $doc )

Références $doc, Symfony\Contracts\Service\__construct(), et XPath\handleDefaultNamespace().

Documentation des fonctions membres

◆ createNodeName()

createNodeName ( $nodeName )
Paramètres
string $nodeName
Renvoie
string

◆ handleDefaultNamespace()

handleDefaultNamespace ( )
protected

Référencé par XPath\__construct().

Documentation des champs

◆ $defaultNamespaceURI

$defaultNamespaceURI
protected

◆ DEFAULT_NAMESPACE_PREFIX

const DEFAULT_NAMESPACE_PREFIX = 'svg'
La documentation de cette classe a été générée à partir du fichier suivant :
  • XPath.php


Joomla CMS: Référence de la classe Resolver

  • enshrined
  • svgSanitize
  • ElementReference
  • Resolver
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Resolver

Fonctions membres publiques

__construct (XPath $xPath, $useNestingLimit)
collect ()
findByElement (\DOMElement $element, $considerChildren=false)
findByElementId ($elementId)
getElementsToRemove ()

Fonctions membres protégées

determineInvalidSubjects ()
markSubjectAsInvalid (Subject $subject)

Attributs protégés

$xPath
$subjects = []
$elementsToRemove = []
$useNestingLimit

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | XPath | $xPath,
 |  |  | $useNestingLimit
 | ) |  |

Références Resolver\$useNestingLimit, et Resolver\$xPath.

Documentation des fonctions membres

◆ collect()

collect ( )

Références Resolver\determineInvalidSubjects().

◆ determineInvalidSubjects()

determineInvalidSubjects ( )
protected

Determines and tags infinite loops.

Références Resolver\$elementsToRemove, $subject, elseif, Helper\extractIdReferenceFromHref(), NestingException\getElement(), Helper\getElementHref(), et Resolver\markSubjectAsInvalid().

Référencé par Resolver\collect().

◆ findByElement()

findByElement | ( | \DOMElement | $element,
 |  |  | $considerChildren = false
 | ) |  |

Resolves one subject by element.

Paramètres
\DOMElement | $element
bool | $considerChildren | Whether to search in Subject's children as well
Renvoie
Subject|null

Références $subject, Helper\isElementContainedIn(), et null.

◆ findByElementId()

findByElementId ( $elementId )

Resolves subjects (plural!) by element id - in theory malformed DOM might have same ids assigned to different elements and leaving it to client/browser implementation which element to actually use.

Paramètres
string $elementId
Renvoie
Subject[]

Références $subject.

◆ getElementsToRemove()

getElementsToRemove ( )

Get all the elements that caused a nesting exception.

Renvoie
array

Références Resolver\$elementsToRemove.

◆ markSubjectAsInvalid()

markSubjectAsInvalid ( Subject $subject )
protected

The Subject is invalid for some reason, therefore we should remove it and all it's child usages.

Paramètres
Subject $subject

Références $subject.

Référencé par Resolver\determineInvalidSubjects().

Documentation des champs

◆ $elementsToRemove

$elementsToRemove = []
protected

Référencé par Resolver\determineInvalidSubjects(), et Resolver\getElementsToRemove().

◆ $subjects

$subjects = []
protected

◆ $useNestingLimit

$useNestingLimit
protected

Référencé par Resolver\__construct().

◆ $xPath

$xPath
protected

Référencé par Resolver\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Resolver.php


Joomla CMS: Référence de la classe Subject

  • enshrined
  • svgSanitize
  • ElementReference
  • Subject
Fonctions membres publiques | Attributs protégés
Référence de la classe Subject

Fonctions membres publiques

__construct (\DOMElement $element, $useNestingLimit)
getElement ()
getElementId ()
hasInfiniteLoop (array $subjects=[], $level=1)
addUse (Subject $subject)
addUsedIn (Subject $subject)
countUse ($accumulated=false)
countUsedIn ()
clearInternalAndGetAffectedElements ()

Attributs protégés

$element
$useCollection = []
$usedInCollection = []
$useNestingLimit

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \DOMElement | $element,
 |  |  | $useNestingLimit
 | ) |  |

Subject constructor.

Paramètres
\DOMElement | $element
int | $useNestingLimit

Références Subject\$element, et Subject\$useNestingLimit.

Documentation des fonctions membres

◆ addUse()

addUse ( Subject $subject )
Paramètres
Subject $subject

Références $subject, et $this.

◆ addUsedIn()

addUsedIn ( Subject $subject )
Paramètres
Subject $subject

Références $subject, et $this.

◆ clearInternalAndGetAffectedElements()

clearInternalAndGetAffectedElements ( )

Clear the internal arrays (to free up memory as they can get big) and return all the child usages DOMElement's

Renvoie
array

Références Subject\$useCollection, et Usage\getSubject().

◆ countUse()

countUse ( $accumulated = false )
Paramètres
bool $accumulated
Renvoie
int

Références $count.

◆ countUsedIn()

countUsedIn ( )
Renvoie
int

Références $count.

◆ getElement()

getElement ( )
Renvoie

Références Subject\$element.

Référencé par Subject\hasInfiniteLoop().

◆ getElementId()

getElementId ( )
Renvoie
string

◆ hasInfiniteLoop()

hasInfiniteLoop | ( | array | $subjects = [],
 |  |  | $level = 1
 | ) |  |
Paramètres
array | $subjects | Previously processed subjects
int | $level | The current level of nesting.
Renvoie
bool
Exceptions

Références $this, Subject\getElement(), et null.

Documentation des champs

◆ $element

$element
protected

Référencé par Subject\__construct(), et Subject\getElement().

◆ $useCollection

$useCollection = []
protected

Référencé par Subject\clearInternalAndGetAffectedElements().

◆ $usedInCollection

$usedInCollection = []
protected

◆ $useNestingLimit

$useNestingLimit
protected

Référencé par Subject\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Subject.php


Joomla CMS: Référence de la classe Usage

  • enshrined
  • svgSanitize
  • ElementReference
  • Usage
Fonctions membres publiques | Attributs protégés
Référence de la classe Usage

Fonctions membres publiques

__construct (Subject $subject, $count=1)
increment ($by=1)
getSubject ()
getCount ()

Attributs protégés

$subject
$count

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Subject | $subject,
 |  |  | $count = 1
 | ) |  |
Paramètres
Subject | $subject
int | $count

Références Usage\$count, et Usage\$subject.

Documentation des fonctions membres

◆ getCount()

getCount ( )
Renvoie
int

Références Usage\$count.

◆ getSubject()

getSubject ( )
Renvoie
Subject

Références Usage\$subject.

Référencé par Subject\clearInternalAndGetAffectedElements().

◆ increment()

increment ( $by = 1 )
Paramètres
int $by

Documentation des champs

◆ $count

$count
protected

Référencé par Usage\__construct(), et Usage\getCount().

◆ $subject

$subject
protected

Référencé par Usage\__construct(), et Usage\getSubject().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Usage.php


Joomla CMS: Référence de la classe NestingException

  • enshrined
  • svgSanitize
  • Exceptions
  • NestingException
Fonctions membres publiques | Attributs protégés
Référence de la classe NestingException
+ Graphe d'héritage de NestingException:

Fonctions membres publiques

__construct ($message="", $code=0, Exception $previous=null, \DOMElement $element=null)
getElement ()

Attributs protégés

$element

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = "",
 |  |  | $code = 0,
 |  | Exception | $previous = null,
 |  | \DOMElement | $element = null
 | ) |  |

NestingException constructor.

Paramètres
string | $message
int | $code
Exception | null | $previous
\DOMElement | null | $element

Références NestingException\$element, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getElement()

getElement ( )

Get the element that caused the exception.

Renvoie

Références NestingException\$element.

Référencé par Resolver\determineInvalidSubjects().

Documentation des champs

◆ $element

$element
protected

Référencé par NestingException\__construct(), et NestingException\getElement().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NestingException.php


Joomla CMS: Référence de la classe Helper

  • enshrined
  • svgSanitize
  • Helper
Fonctions membres publiques statiques
Référence de la classe Helper

Fonctions membres publiques statiques

static | getElementHref (\DOMElement $element)
static | extractIdReferenceFromHref ($href)
static | isElementContainedIn (\DOMElement $needle, \DOMElement $haystack)

Documentation des fonctions membres

◆ extractIdReferenceFromHref()

static extractIdReferenceFromHref ( $href )
static
Paramètres
string $href
Renvoie
string|null

Références $href, et null.

Référencé par Resolver\determineInvalidSubjects().

◆ getElementHref()

static getElementHref ( \DOMElement $element )
static
Paramètres
\DOMElement $element
Renvoie
string|null

Références null.

Référencé par Resolver\determineInvalidSubjects().

◆ isElementContainedIn()

static isElementContainedIn | ( | \DOMElement | $needle,
 |  | \DOMElement | $haystack
 | ) |  |
static
Paramètres
\DOMElement | $needle
\DOMElement | $haystack
Renvoie
bool

Référencé par Resolver\findByElement().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/enshrined/svg-sanitize/src/Helper.php


Joomla CMS: Référence de la classe Sanitizer

  • enshrined
  • svgSanitize
  • Sanitizer
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Sanitizer

Fonctions membres publiques

__construct ()
setXMLOptions ($xmlOptions)
getXMLOptions ()
getAllowedTags ()
setAllowedTags (TagInterface $allowedTags)
getAllowedAttrs ()
setAllowedAttrs (AttributeInterface $allowedAttrs)
removeRemoteReferences ($removeRemoteRefs=false)
getXmlIssues ()
sanitize ($dirty)
minify ($shouldMinify=false)
removeXMLTag ($removeXMLTag=false)
useThreshold ($useThreshold=1000)
setUseNestingLimit ($limit)

Fonctions membres protégées

resetInternal ()
setUpBefore ()
resetAfter ()
cleanAttributesOnWhitelist (\DOMElement $element)
cleanXlinkHrefs (\DOMElement $element)
cleanHrefs (\DOMElement $element)
isHrefSafeValue ($value)
removeNonPrintableCharacters ($value)
hasRemoteReference ($value)
isAriaAttribute ($attributeName)
isDataAttribute ($attributeName)
isUseTagDirty (\DOMElement $element)
isUseTagExceedingThreshold (\DOMElement $element)

Attributs protégés

$xmlDocument
$allowedTags
$allowedAttrs
$xmlLoaderValue
$minifyXML = false
$removeRemoteReferences = false
$useThreshold = 1000
$removeXMLTag = false
$xmlOptions = LIBXML_NOEMPTYTAG
$xmlIssues = array()
$elementReferenceResolver
$useNestingLimit = 15

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références AllowedAttributes\getAttributes(), et AllowedTags\getTags().

Documentation des fonctions membres

◆ cleanAttributesOnWhitelist()

cleanAttributesOnWhitelist ( \DOMElement $element )
protected

Only allow attributes that are on the whitelist

Paramètres
\DOMElement $element

This is used for when a namespace isn't imported properly. Such as xlink:href when the xlink namespace isn't imported. We have to do this as the link is still ran in this case.

Références $href, Sanitizer\hasRemoteReference(), Sanitizer\isAriaAttribute(), Sanitizer\isDataAttribute(), Sanitizer\isHrefSafeValue(), et Sanitizer\removeRemoteReferences().

◆ cleanHrefs()

cleanHrefs ( \DOMElement $element )
protected

Clean the hrefs of script and data embeds

Paramètres
\DOMElement $element

Références $href, et Sanitizer\isHrefSafeValue().

◆ cleanXlinkHrefs()

cleanXlinkHrefs ( \DOMElement $element )
protected

Clean the xlink:hrefs of script and data embeds

Paramètres
\DOMElement $element

Références Sanitizer\isHrefSafeValue().

◆ getAllowedAttrs()

getAllowedAttrs ( )

Get the array of allowed attributes

Renvoie
array

Références Sanitizer\$allowedAttrs.

◆ getAllowedTags()

getAllowedTags ( )

Get the array of allowed tags

Renvoie
array

Références Sanitizer\$allowedTags.

◆ getXmlIssues()

getXmlIssues ( )

Get XML issues.

Renvoie
array

Références Sanitizer\$xmlIssues.

◆ getXMLOptions()

getXMLOptions ( )

Get XML options to use when saving XML See: DOMDocument::saveXML

Renvoie
int

Références Sanitizer\$xmlOptions.

◆ hasRemoteReference()

hasRemoteReference ( $value )
protected

Does this attribute value have a remote reference?

Paramètres
$value
Renvoie
bool

Références $value, et Sanitizer\removeNonPrintableCharacters().

Référencé par Sanitizer\cleanAttributesOnWhitelist().

◆ isAriaAttribute()

isAriaAttribute ( $attributeName )
protected

Check to see if an attribute is an aria attribute or not

Paramètres
$attributeName
Renvoie
bool

Référencé par Sanitizer\cleanAttributesOnWhitelist().

◆ isDataAttribute()

isDataAttribute ( $attributeName )
protected

Check to see if an attribute is an data attribute or not

Paramètres
$attributeName
Renvoie
bool

Référencé par Sanitizer\cleanAttributesOnWhitelist().

◆ isHrefSafeValue()

isHrefSafeValue ( $value )
protected

Only allow whitelisted starts to be within the href.

This will stop scripts etc from being passed through, with or without attempting to hide bypasses. This stops the need for us to use a complicated script regex.

Paramètres
$value
Renvoie
bool

Références $value.

Référencé par Sanitizer\cleanAttributesOnWhitelist(), Sanitizer\cleanHrefs(), et Sanitizer\cleanXlinkHrefs().

◆ isUseTagDirty()

isUseTagDirty ( \DOMElement $element )
protected

Make sure our use tag is only referencing internal resources

Paramètres
\DOMElement $element
Renvoie
bool

◆ isUseTagExceedingThreshold()

isUseTagExceedingThreshold ( \DOMElement $element )
protected

Determines whether <use ... xlink:href="#identifier"> is expanded recursively in order to create DoS scenarios. The amount of a actually used element needs to be below $this->useThreshold.

Paramètres
\DOMElement $element
Renvoie
bool

◆ minify()

minify ( $shouldMinify = false )

Should we minify the output?

Paramètres
bool $shouldMinify

◆ removeNonPrintableCharacters()

removeNonPrintableCharacters ( $value )
protected

Removes non-printable ASCII characters from string & trims it

Paramètres
string $value
Renvoie
bool

Références $value.

Référencé par Sanitizer\hasRemoteReference().

◆ removeRemoteReferences()

removeRemoteReferences ( $removeRemoteRefs = false )

Should we remove references to remote files?

Paramètres
bool $removeRemoteRefs

Référencé par Sanitizer\cleanAttributesOnWhitelist().

◆ removeXMLTag()

removeXMLTag ( $removeXMLTag = false )

Should we remove the XML tag in the header?

Paramètres
bool $removeXMLTag

Référencé par Sanitizer\sanitize().

◆ resetAfter()

resetAfter ( )
protected

Reset the class after use

Référencé par Sanitizer\sanitize().

◆ resetInternal()

resetInternal ( )
protected

Set up the DOMDocument

Références Sanitizer\$minifyXML.

Référencé par Sanitizer\sanitize().

◆ sanitize()

sanitize ( $dirty )

Sanitize the passed string

Paramètres
string $dirty
Renvoie
string

Références $this, Sanitizer\removeXMLTag(), Sanitizer\resetAfter(), Sanitizer\resetInternal(), et Sanitizer\setUpBefore().

◆ setAllowedAttrs()

setAllowedAttrs ( AttributeInterface $allowedAttrs )

Set custom allowed attributes

Paramètres
AttributeInterface $allowedAttrs

Références Fig\Link\getAttributes().

◆ setAllowedTags()

setAllowedTags ( TagInterface $allowedTags )

Set custom allowed tags

Paramètres
TagInterface $allowedTags

◆ setUpBefore()

setUpBefore ( )
protected

Set up libXML before we start

Référencé par Sanitizer\sanitize().

◆ setUseNestingLimit()

setUseNestingLimit ( $limit )

Set the nesting limit for <use> tags.

Paramètres
$limit

◆ setXMLOptions()

setXMLOptions ( $xmlOptions )

Set XML options to use when saving XML See: DOMDocument::saveXML

Paramètres
int $xmlOptions

Références Sanitizer\$xmlOptions.

◆ useThreshold()

useThreshold ( $useThreshold = 1000 )

Whether <use ... xlink:href="#identifier"> elements shall be removed in case expansion would exceed this threshold.

Paramètres
int $useThreshold

Documentation des champs

◆ $allowedAttrs

$allowedAttrs
protected

Référencé par Sanitizer\getAllowedAttrs().

◆ $allowedTags

$allowedTags
protected

Référencé par Sanitizer\getAllowedTags().

◆ $elementReferenceResolver

$elementReferenceResolver
protected

◆ $minifyXML

$minifyXML = false
protected

Référencé par Sanitizer\resetInternal().

◆ $removeRemoteReferences

$removeRemoteReferences = false
protected

◆ $removeXMLTag

$removeXMLTag = false
protected

◆ $useNestingLimit

$useNestingLimit = 15
protected

◆ $useThreshold

$useThreshold = 1000
protected

◆ $xmlDocument

$xmlDocument
protected

◆ $xmlIssues

$xmlIssues = array()
protected

Référencé par Sanitizer\getXmlIssues().

◆ $xmlLoaderValue

$xmlLoaderValue
protected

◆ $xmlOptions

$xmlOptions = LIBXML_NOEMPTYTAG
protected

Référencé par Sanitizer\getXMLOptions(), et Sanitizer\setXMLOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Sanitizer.php


Joomla CMS: Référence de la classe AttributeTypeAndValue

  • FG
  • ASN1
  • Composite
  • AttributeTypeAndValue
Fonctions membres publiques
Référence de la classe AttributeTypeAndValue
+ Graphe d'héritage de AttributeTypeAndValue:
Sequence Construct Parsable ASNObject Parsable Parsable AlgorithmIdentifier

Fonctions membres publiques

__construct ($objIdentifier, ASNObject $value)
__toString ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $objIdentifier,
 |  | ASNObject | $value
 | ) |  |
Paramètres
ObjectIdentifier | string | $objIdentifier
\FG\ASN1\ASNObject | $value

Références $value, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références children.

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/ASN1/Composite/AttributeTypeAndValue.php


Joomla CMS: Référence de la classe RDNString

  • FG
  • ASN1
  • Composite
  • RDNString
Fonctions membres publiques
Référence de la classe RDNString
+ Graphe d'héritage de RDNString:
RelativeDistinguishedName Set Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($objectIdentifierString, $value)
- Fonctions membres publiques hérités de RelativeDistinguishedName
__construct ($objIdentifierString, ASNObject $value)
- Fonctions membres publiques hérités de Set
getType ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RelativeDistinguishedName
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $objectIdentifierString,
 |  | $value
 | ) |
Paramètres
string | \FG\ASN1\Universal\ObjectIdentifier | $objectIdentifierString
string | \FG\ASN1\ASNObject | $value

Références $value, Symfony\Contracts\Service\__construct(), et AbstractString\isValid().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RDNString.php


Joomla CMS: Référence de la classe RelativeDistinguishedName

  • FG
  • ASN1
  • Composite
  • RelativeDistinguishedName
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe RelativeDistinguishedName
+ Graphe d'héritage de RelativeDistinguishedName:
Set Sequence Construct Parsable ASNObject Parsable Parsable RDNString

Fonctions membres publiques

__construct ($objIdentifierString, ASNObject $value)
- Fonctions membres publiques hérités de Set
getType ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Membres hérités additionnels

- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $objIdentifierString,
 |  | ASNObject | $value
 | ) |  |
Paramètres
string | \FG\ASN1\Universal\ObjectIdentifier | $objIdentifierString
\FG\ASN1\ASNObject | $value

Références $value, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

At the current version this code can not work since the implementation of Construct requires the class to support a constructor without arguments.

Obsolète:
this function is not yet implemented! Feel free to submit a pull request on github
Paramètres
string | $binaryData
int | $offsetIndex
Exceptions
NotImplementedException

Implémente Parsable.

Référencé par CertificateSubject\fromBinary().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/ASN1/Composite/RelativeDistinguishedName.php


Joomla CMS: Référence de la classe NotImplementedException

  • FG
  • ASN1
  • Exception
  • NotImplementedException
Référence de la classe NotImplementedException
+ Graphe d'héritage de NotImplementedException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotImplementedException.php


Joomla CMS: Référence de la classe ParserException

  • FG
  • ASN1
  • Exception
  • ParserException
Fonctions membres publiques | Attributs privés
Référence de la classe ParserException
+ Graphe d'héritage de ParserException:

Fonctions membres publiques

__construct ($errorMessage, $offset)
getOffset ()

Attributs privés

$errorMessage
$offset

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $errorMessage,
 |  | $offset
 | ) |

Références ParserException\$errorMessage, ParserException\$offset, Symfony\Contracts\Service\__construct(), et Joomla\Database\Query\offset().

Documentation des fonctions membres

◆ getOffset()

getOffset ( )

Références ParserException\$offset.

Référencé par RelativeObjectIdentifier\fromBinary().

Documentation des champs

◆ $errorMessage

$errorMessage
private

Référencé par ParserException\__construct().

◆ $offset

$offset
private

Référencé par ParserException\__construct(), et ParserException\getOffset().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ParserException.php


Joomla CMS: Référence de la classe BitString

  • FG
  • ASN1
  • Universal
  • BitString
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe BitString
+ Graphe d'héritage de BitString:
OctetString Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($value, $nrOfUnusedBits=0)
getType ()
getNumberOfUnusedBits ()
- Fonctions membres publiques hérités de OctetString
__construct ($value)
getType ()
getContent ()
getBinaryContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de OctetString
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de OctetString
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$nrOfUnusedBits

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de OctetString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $value,
 |  | $nrOfUnusedBits = 0
 | ) |

Creates a new ASN.1 BitString object.

Paramètres
string | int | $value | Either the hexadecimal value as a string (spaces are allowed - leading 0x is optional) or a numeric value
int | $nrOfUnusedBits | the number of unused bits in the last octet [optional].
Exceptions
Exception if the second parameter is no positive numeric value

Références BitString\$nrOfUnusedBits, OctetString\$value, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, BitString\$nrOfUnusedBits, OctetString\$value, et Identifier\BITSTRING.

Référencé par ASNObject\fromBinary().

◆ getEncodedValue()

getEncodedValue ( )
protected

◆ getNumberOfUnusedBits()

getNumberOfUnusedBits ( )

Références BitString\$nrOfUnusedBits.

◆ getType()

getType ( )

Références Identifier\BITSTRING.

Documentation des champs

◆ $nrOfUnusedBits

$nrOfUnusedBits
private

Référencé par BitString\__construct(), BitString\fromBinary(), et BitString\getNumberOfUnusedBits().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BitString.php


Joomla CMS: Référence de la classe BMPString

  • FG
  • ASN1
  • Universal
  • BMPString
Fonctions membres publiques
Référence de la classe BMPString
+ Graphe d'héritage de BMPString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 BMP String.

BMPString is a subtype of UniversalString that has its own unique tag and contains only the characters in the Basic Multilingual Plane (those corresponding to the first 64K-2 cells, less cells whose encoding is used to address characters outside the Basic Multilingual Plane) of ISO/IEC 10646-1.

TODO The encodable characters of this type are not yet checked.

Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\BMP_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BMPString.php


Joomla CMS: Référence de la classe Boolean

  • FG
  • ASN1
  • Universal
  • Boolean
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe Boolean
+ Graphe d'héritage de Boolean:
ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($value)
getType ()
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$value

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )
Paramètres
bool $value

Références Boolean\$value, et value.

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, Boolean\$value, Identifier\BOOLEAN, et true.

Référencé par ASNObject\fromBinary().

◆ getContent()

getContent ( )

Références value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références value.

◆ getType()

getType ( )

Références Identifier\BOOLEAN.

Documentation des champs

◆ $value

$value
private

Référencé par Boolean\__construct(), et Boolean\fromBinary().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Boolean.php


Joomla CMS: Référence de la classe CharacterString

  • FG
  • ASN1
  • Universal
  • CharacterString
Fonctions membres publiques
Référence de la classe CharacterString
+ Graphe d'héritage de CharacterString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\CHARACTER_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CharacterString.php


Joomla CMS: Référence de la classe Enumerated

  • FG
  • ASN1
  • Universal
  • Enumerated
Fonctions membres publiques
Référence de la classe Enumerated
+ Graphe d'héritage de Enumerated:
Integer ASNObject Parsable Parsable

Fonctions membres publiques

getType ()
- Fonctions membres publiques hérités de Integer
__construct ($value)
getType ()
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Integer
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Integer
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\ENUMERATED.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Enumerated.php


Joomla CMS: Référence de la classe GeneralizedTime

  • FG
  • ASN1
  • Universal
  • GeneralizedTime
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe GeneralizedTime
+ Graphe d'héritage de GeneralizedTime:
AbstractTime Parsable ASNObject Parsable

Fonctions membres publiques

__construct ($dateTime=null, $dateTimeZone='UTC')
getType ()
containsFractionalSecondsElement ()
__toString ()
- Fonctions membres publiques hérités de AbstractTime
__construct ($dateTime=null, $dateTimeZone='UTC')
getContent ()
__toString ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de AbstractTime
getLastDateTimeErrors ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$microseconds

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de AbstractTime
static | extractTimeZoneData (&$binaryData, &$offsetIndex, DateTime $dateTime)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractTime
$value

Description détaillée

This ASN.1 universal type contains date and time information according to ISO 8601.

The type consists of values representing: a) a calendar date, as defined in ISO 8601; and b) a time of day, to any of the precisions defined in ISO 8601, except for the hours value 24 which shall not be used; and c) the local time differential factor as defined in ISO 8601.

Decoding of this type will accept the Basic Encoding Rules (BER) The encoding will comply with the Distinguished Encoding Rules (DER).

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $dateTime = null,
 |  | $dateTimeZone = 'UTC'
 | ) |

Références Symfony\Contracts\Service\__construct(), GeneralizedTime\containsFractionalSecondsElement(), et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références GeneralizedTime\containsFractionalSecondsElement(), et value.

◆ calculateContentLength()

calculateContentLength ( )
protected

Références GeneralizedTime\containsFractionalSecondsElement().

◆ containsFractionalSecondsElement()

containsFractionalSecondsElement ( )

Référencé par GeneralizedTime\__construct(), GeneralizedTime\__toString(), GeneralizedTime\calculateContentLength(), et GeneralizedTime\getEncodedValue().

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références $content, ASNObject\$contentLength, $format, elseif, et Identifier\GENERALIZED_TIME.

Référencé par ASNObject\fromBinary().

◆ getEncodedValue()

getEncodedValue ( )
protected

Références GeneralizedTime\containsFractionalSecondsElement(), et value.

◆ getType()

getType ( )

Références Identifier\GENERALIZED_TIME.

Documentation des champs

◆ $microseconds

$microseconds
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralizedTime.php


Joomla CMS: Référence de la classe GeneralString

  • FG
  • ASN1
  • Universal
  • GeneralString
Fonctions membres publiques
Référence de la classe GeneralString
+ Graphe d'héritage de GeneralString:
AbstractString ASNObject Parsable Parsable DNSName

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 GeneralString. TODO The encodable characters of this type are not yet checked.

Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\GENERAL_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralString.php


Joomla CMS: Référence de la classe GraphicString

  • FG
  • ASN1
  • Universal
  • GraphicString
Fonctions membres publiques
Référence de la classe GraphicString
+ Graphe d'héritage de GraphicString:
AbstractString ASNObject Parsable Parsable ObjectDescriptor

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 Graphic String. TODO The encodable characters of this type are not yet checked.

Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\GRAPHIC_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GraphicString.php


Joomla CMS: Référence de la classe IA5String

  • FG
  • ASN1
  • Universal
  • IA5String
Fonctions membres publiques
Référence de la classe IA5String
+ Graphe d'héritage de IA5String:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Description détaillée

The International Alphabet No.5 (IA5) references the encoding of the ASCII characters.

Each character in the data is encoded as 1 byte.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Références $i, Symfony\Contracts\Service\__construct(), et AbstractString\allowCharacter().

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\IA5_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • IA5String.php


Joomla CMS: Référence de la classe Integer

  • FG
  • ASN1
  • Universal
  • Integer
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées statiques | Attributs privés
Référence de la classe Integer
+ Graphe d'héritage de Integer:
ASNObject Parsable Parsable Enumerated

Fonctions membres publiques

__construct ($value)
getType ()
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Fonctions membres privées statiques

static ensureMinimalEncoding ($binaryData, $offsetIndex)

Attributs privés

$value

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )
Paramètres
int $value
Exceptions
Exception if the value is not numeric

Références Integer\$value, et value.

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

Références Integer\getEncodedValue().

◆ ensureMinimalEncoding()

static ensureMinimalEncoding | ( | $binaryData,
 |  | $offsetIndex
 | ) |
staticprivate

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, $i, et BigInteger\create().

Référencé par ASNObject\fromBinary().

◆ getContent()

getContent ( )

Références Integer\$value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références $i, $limit, $mod, $r, Integer\$value, BigInteger\create(), et value.

Référencé par Integer\calculateContentLength().

◆ getType()

getType ( )

Références Identifier\INTEGER.

Documentation des champs

◆ $value

$value
private

Référencé par Integer\__construct(), Integer\getContent(), et Integer\getEncodedValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/ASN1/Universal/Integer.php


Joomla CMS: Référence de la classe NullObject

  • FG
  • ASN1
  • Universal
  • NullObject
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées
Référence de la classe NullObject
+ Graphe d'héritage de NullObject:
ASNObject Parsable Parsable

Fonctions membres publiques

getType ()
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, et Identifier\NULL.

Référencé par ASNObject\fromBinary().

◆ getContent()

getContent ( )

◆ getEncodedValue()

getEncodedValue ( )
protected

Références null.

◆ getType()

getType ( )

Références Identifier\NULL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/ASN1/Universal/NullObject.php


Joomla CMS: Référence de la classe NumericString

  • FG
  • ASN1
  • Universal
  • NumericString
Fonctions membres publiques
Référence de la classe NumericString
+ Graphe d'héritage de NumericString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 NumericString.

The following characters are permitted: Digits 0,1, ... 9 SPACE (space)

Paramètres
string $string

Références AbstractString\allowNumbers(), AbstractString\allowSpaces(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\NUMERIC_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NumericString.php


Joomla CMS: Référence de la classe ObjectDescriptor

  • FG
  • ASN1
  • Universal
  • ObjectDescriptor
Fonctions membres publiques
Référence de la classe ObjectDescriptor
+ Graphe d'héritage de ObjectDescriptor:
GraphicString AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($objectDescription)
getType ()
- Fonctions membres publiques hérités de GraphicString
__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $objectDescription )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\OBJECT_DESCRIPTOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ObjectDescriptor.php


Joomla CMS: Référence de la classe ObjectIdentifier

  • FG
  • ASN1
  • Universal
  • ObjectIdentifier
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe ObjectIdentifier
+ Graphe d'héritage de ObjectIdentifier:
ASNObject Parsable Parsable RelativeObjectIdentifier

Fonctions membres publiques

__construct ($value)
getContent ()
getType ()
__toString ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Fonctions membres protégées statiques

static | parseOid (&$binaryData, &$offsetIndex, $octetsToRead)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Attributs protégés

$subIdentifiers
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )

Références $i, ObjectIdentifier\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références OID\getName(), et value.

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, et Identifier\OBJECT_IDENTIFIER.

Référencé par Attributes\fromBinary(), et ASNObject\fromBinary().

◆ getContent()

getContent ( )

Références ObjectIdentifier\$value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références Base128\encode().

◆ getType()

getType ( )

Références Identifier\OBJECT_IDENTIFIER.

◆ parseOid()

static parseOid | ( | & | $binaryData,
 |  | & | $offsetIndex,
 |  |  | $octetsToRead
 | ) |  |
staticprotected

Parses an object identifier except for the first octet, which is parsed differently. This way relative object identifiers can also be parsed using this.

Paramètres
$binaryData
$offsetIndex
$octetsToRead
Exceptions
ParserException
Renvoie
string

Références $oid, et Base128\decode().

Documentation des champs

◆ $subIdentifiers

$subIdentifiers
protected

Référencé par RelativeObjectIdentifier\__construct().

◆ $value

$value
protected

Référencé par ObjectIdentifier\__construct(), et ObjectIdentifier\getContent().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ObjectIdentifier.php


Joomla CMS: Référence de la classe OctetString

  • FG
  • ASN1
  • Universal
  • OctetString
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe OctetString
+ Graphe d'héritage de OctetString:
ASNObject Parsable Parsable BitString

Fonctions membres publiques

__construct ($value)
getType ()
getContent ()
getBinaryContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs protégés

$value

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )

Références OctetString\$value, elseif, null, et value.

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

Références value.

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, OctetString\$value, et Identifier\OCTETSTRING.

Référencé par ASNObject\fromBinary().

◆ getBinaryContent()

getBinaryContent ( )

Références OctetString\getEncodedValue().

◆ getContent()

getContent ( )

Références value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références $result, et OctetString\$value.

Référencé par OctetString\getBinaryContent().

◆ getType()

getType ( )

Références Identifier\OCTETSTRING.

Documentation des champs

◆ $value

$value
protected

Référencé par OctetString\__construct(), BitString\__construct(), BitString\fromBinary(), OctetString\fromBinary(), et OctetString\getEncodedValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OctetString.php


Joomla CMS: Référence de la classe PrintableString

  • FG
  • ASN1
  • Universal
  • PrintableString
Fonctions membres publiques
Référence de la classe PrintableString
+ Graphe d'héritage de PrintableString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 PrintableString.

The ITU-T X.680 Table 8 permits the following characters: Latin capital letters A,B, ... Z Latin small letters a,b, ... z Digits 0,1, ... 9 SPACE (space) APOSTROPHE ' LEFT PARENTHESIS ( RIGHT PARENTHESIS ) PLUS SIGN + COMMA , HYPHEN-MINUS - FULL STOP . SOLIDUS / COLON : EQUALS SIGN = QUESTION MARK ?

Paramètres
string $string

Références AbstractString\allowAllLetters(), AbstractString\allowCharacters(), AbstractString\allowNumbers(), AbstractString\allowSpaces(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\PRINTABLE_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrintableString.php


Joomla CMS: Référence de la classe RelativeObjectIdentifier

  • FG
  • ASN1
  • Universal
  • RelativeObjectIdentifier
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe RelativeObjectIdentifier
+ Graphe d'héritage de RelativeObjectIdentifier:
ObjectIdentifier Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($subIdentifiers)
getType ()
- Fonctions membres publiques hérités de ObjectIdentifier
__construct ($value)
getContent ()
getType ()
__toString ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ObjectIdentifier
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Membres hérités additionnels

- Fonctions membres protégées hérités de ObjectIdentifier
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ObjectIdentifier
static | parseOid (&$binaryData, &$offsetIndex, $octetsToRead)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de ObjectIdentifier
$subIdentifiers
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $subIdentifiers )

Références $i, ObjectIdentifier\$subIdentifiers, et value.

Documentation des fonctions membres

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, ParserException\getOffset(), et Identifier\RELATIVE_OID.

Référencé par ASNObject\fromBinary().

◆ getType()

getType ( )

Références Identifier\RELATIVE_OID.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RelativeObjectIdentifier.php


Joomla CMS: Référence de la classe Sequence

  • FG
  • ASN1
  • Universal
  • Sequence
Fonctions membres publiques
Référence de la classe Sequence
+ Graphe d'héritage de Sequence:
Construct Parsable ASNObject Parsable Parsable AttributeTypeAndValue Set CertificateSubject CSR PrivateKey PublicKey AlgorithmIdentifier RelativeDistinguishedName CertificateExtensions RDNString

Fonctions membres publiques

getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\SEQUENCE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Sequence.php


Joomla CMS: Référence de la classe Set

  • FG
  • ASN1
  • Universal
  • Set
Fonctions membres publiques
Référence de la classe Set
+ Graphe d'héritage de Set:
Sequence Construct Parsable ASNObject Parsable Parsable RelativeDistinguishedName CertificateExtensions RDNString

Fonctions membres publiques

getType ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\SET.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Set.php


Joomla CMS: Référence de la classe T61String

  • FG
  • ASN1
  • Universal
  • T61String
Fonctions membres publiques
Référence de la classe T61String
+ Graphe d'héritage de T61String:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 T61 String. TODO The encodable characters of this type are not yet checked.

Voir également
http://en.wikipedia.org/wiki/ITU_T.61
Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\T61_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • T61String.php


Joomla CMS: Référence de la classe UniversalString

  • FG
  • ASN1
  • Universal
  • UniversalString
Fonctions membres publiques
Référence de la classe UniversalString
+ Graphe d'héritage de UniversalString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 Universal String. TODO The encodable characters of this type are not yet checked.

Voir également
http://en.wikipedia.org/wiki/Universal_Character_Set
Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\UNIVERSAL_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UniversalString.php


Joomla CMS: Référence de la classe UTCTime

  • FG
  • ASN1
  • Universal
  • UTCTime
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées
Référence de la classe UTCTime
+ Graphe d'héritage de UTCTime:
AbstractTime Parsable ASNObject Parsable

Fonctions membres publiques

getType ()
- Fonctions membres publiques hérités de AbstractTime
__construct ($dateTime=null, $dateTimeZone='UTC')
getContent ()
__toString ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de AbstractTime
getLastDateTimeErrors ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de AbstractTime
static | extractTimeZoneData (&$binaryData, &$offsetIndex, DateTime $dateTime)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractTime
$value

Description détaillée

This ASN.1 universal type contains the calendar date and time.

The precision is one minute or one second and optionally a local time differential from coordinated universal time.

Decoding of this type will accept the Basic Encoding Rules (BER) The encoding will comply with the Distinguished Encoding Rules (DER).

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, $format, elseif, et Identifier\UTC_TIME.

Référencé par ASNObject\fromBinary().

◆ getEncodedValue()

getEncodedValue ( )
protected

Références value.

◆ getType()

getType ( )

Références Identifier\UTC_TIME.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UTCTime.php


Joomla CMS: Référence de la classe UTF8String

  • FG
  • ASN1
  • Universal
  • UTF8String
Fonctions membres publiques
Référence de la classe UTF8String
+ Graphe d'héritage de UTF8String:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 Universal String. TODO The encodable characters of this type are not yet checked.

Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\UTF8_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UTF8String.php


Joomla CMS: Référence de la classe VisibleString

  • FG
  • ASN1
  • Universal
  • VisibleString
Fonctions membres publiques
Référence de la classe VisibleString
+ Graphe d'héritage de VisibleString:
AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

Creates a new ASN.1 Visible String. TODO The encodable characters of this type are not yet checked.

Paramètres
string $string

Références AbstractString\allowAll(), et value.

Documentation des fonctions membres

◆ getType()

getType ( )

Références Identifier\VISIBLE_STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • VisibleString.php


Joomla CMS: Référence de la classe AbstractString

  • FG
  • ASN1
  • AbstractString
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe AbstractString
+ Graphe d'héritage de AbstractString:
ASNObject Parsable Parsable BMPString CharacterString GeneralString GraphicString IA5String NumericString PrintableString T61String UniversalString UTF8String VisibleString

Fonctions membres publiques

__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs protégés

$value

Attributs privés

$checkStringForIllegalChars = true
$allowedCharacters = []

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $string )

The abstract base class for ASN.1 classes which represent some string of character.

Paramètres
string $string

Références value.

Documentation des fonctions membres

◆ allowAll()

allowAll ( )
protected

Référencé par CharacterString\__construct(), GraphicString\__construct(), UTF8String\__construct(), VisibleString\__construct(), GeneralString\__construct(), UniversalString\__construct(), T61String\__construct(), et BMPString\__construct().

◆ allowAllLetters()

allowAllLetters ( )
protected

Références AbstractString\allowCapitalLetters(), et AbstractString\allowSmallLetters().

Référencé par PrintableString\__construct().

◆ allowCapitalLetters()

allowCapitalLetters ( )
protected

Référencé par AbstractString\allowAllLetters().

◆ allowCharacter()

allowCharacter ( $character )
protected

Référencé par IA5String\__construct().

◆ allowCharacters()

allowCharacters ( $characters )
protected

Référencé par PrintableString\__construct().

◆ allowNumbers()

allowNumbers ( )
protected

Référencé par NumericString\__construct(), et PrintableString\__construct().

◆ allowSmallLetters()

allowSmallLetters ( )
protected

Référencé par AbstractString\allowAllLetters().

◆ allowSpaces()

allowSpaces ( )
protected

Référencé par NumericString\__construct(), et PrintableString\__construct().

◆ calculateContentLength()

calculateContentLength ( )
protected

Références value.

◆ checkString()

checkString ( )
protected

Références $i, ASNObject\getContentLength(), Identifier\getName(), ASNObject\getType(), et value.

Référencé par AbstractString\getEncodedValue().

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength.

Référencé par ASNObject\fromBinary().

◆ getContent()

getContent ( )

Références AbstractString\$value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références AbstractString\$value, et AbstractString\checkString().

◆ isValid()

static isValid ( $string )
static

Référencé par RDNString\__construct().

Documentation des champs

◆ $allowedCharacters

$allowedCharacters = []
private

◆ $checkStringForIllegalChars

$checkStringForIllegalChars = true
private

◆ $value

$value
protected

Référencé par AbstractString\getContent(), et AbstractString\getEncodedValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/ASN1/AbstractString.php


Joomla CMS: Référence de la classe AbstractTime

  • FG
  • ASN1
  • AbstractTime
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe AbstractTime
+ Graphe d'héritage de AbstractTime:
ASNObject Parsable GeneralizedTime UTCTime

Fonctions membres publiques

__construct ($dateTime=null, $dateTimeZone='UTC')
getContent ()
__toString ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres protégées

getLastDateTimeErrors ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Fonctions membres protégées statiques

static | extractTimeZoneData (&$binaryData, &$offsetIndex, DateTime $dateTime)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Attributs protégés

$value

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ASNObject
static fromBinary (&$binaryData, &$offsetIndex=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $dateTime = null,
 |  | $dateTimeZone = 'UTC'
 | ) |

Références $className, elseif, AbstractTime\getLastDateTimeErrors(), Identifier\getName(), ASNObject\getType(), null, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références value.

◆ extractTimeZoneData()

static extractTimeZoneData | ( | & | $binaryData,
 |  | & | $offsetIndex,
 |  | DateTime | $dateTime
 | ) |  |
staticprotected

◆ getContent()

getContent ( )

Références AbstractTime\$value.

◆ getLastDateTimeErrors()

getLastDateTimeErrors ( )
protected

Références $messages.

Référencé par AbstractTime\__construct().

Documentation des champs

◆ $value

$value
protected

Référencé par AbstractTime\getContent().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractTime.php


Joomla CMS: Référence de la classe ASNObject

  • FG
  • ASN1
  • ASNObject
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Fonctions membres privées | Attributs privés
Référence de la classe ASNObject
+ Graphe d'héritage de ASNObject:
Parsable AbstractString AbstractTime Construct ExplicitlyTaggedObject Boolean Integer NullObject ObjectIdentifier OctetString UnknownObject IPAddress SubjectAlternativeNames

Fonctions membres publiques

getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Fonctions membres protégées statiques

static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Fonctions membres privées

createLengthPart ()

Attributs privés

$contentLength
$nrOfLengthOctets

Description détaillée

Class ASNObject is the base class for all concrete ASN.1 objects.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références ASNObject\getContent().

◆ calculateContentLength()

calculateContentLength ( )
abstractprotected

Must return the number of octets of the content part.

Renvoie
int

Référencé par ASNObject\getContentLength().

◆ createLengthPart()

createLengthPart ( )
private

Références ASNObject\$contentLength, ASNObject\$nrOfLengthOctets, ASNObject\getContentLength(), et ASNObject\getNumberOfLengthOctets().

Référencé par ASNObject\getBinary().

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static
Paramètres
string | $binaryData
int | $offsetIndex
Exceptions
ParserException
Renvoie

Implémente Parsable.

Références Identifier\BITSTRING, Identifier\BMP_STRING, Identifier\BOOLEAN, Identifier\CHARACTER_STRING, Identifier\ENUMERATED, NullObject\fromBinary(), RelativeObjectIdentifier\fromBinary(), UTCTime\fromBinary(), Boolean\fromBinary(), BitString\fromBinary(), OctetString\fromBinary(), GeneralizedTime\fromBinary(), ObjectIdentifier\fromBinary(), ExplicitlyTaggedObject\fromBinary(), Integer\fromBinary(), AbstractString\fromBinary(), Construct\fromBinary(), Identifier\GENERAL_STRING, Identifier\GENERALIZED_TIME, Identifier\GRAPHIC_STRING, Identifier\IA5_STRING, Identifier\INTEGER, Identifier\isConstructed(), Identifier\isContextSpecificClass(), Identifier\NULL, Identifier\NUMERIC_STRING, Identifier\OBJECT_DESCRIPTOR, Identifier\OBJECT_IDENTIFIER, Identifier\OCTETSTRING, Identifier\PRINTABLE_STRING, Identifier\RELATIVE_OID, Identifier\SEQUENCE, Identifier\SET, Identifier\T61_STRING, Identifier\UNIVERSAL_STRING, Identifier\UTC_TIME, Identifier\UTF8_STRING, et Identifier\VISIBLE_STRING.

Référencé par UnknownConstructedObject\__construct(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), Attributes\fromBinary(), ExplicitlyTaggedObject\fromBinary(), Construct\fromBinary(), et TemplateParser\parseBinary().

◆ getBinary()

getBinary ( )

Encode this object using DER encoding.

Renvoie
string the full binary representation of the complete object

Références $result, ASNObject\createLengthPart(), ASNObject\getEncodedValue(), et ASNObject\getIdentifier().

Référencé par CSR\__toString().

◆ getContent()

getContent ( )
abstract

Return the content of this object in a non encoded form. This can be used to print the value in human readable form.

Renvoie
mixed

Référencé par ASNObject\__toString().

◆ getContentLength()

getContentLength ( )
protected

Références ASNObject\$contentLength, et ASNObject\calculateContentLength().

Référencé par UnknownObject\calculateContentLength(), AbstractString\checkString(), ASNObject\createLengthPart(), ASNObject\getNumberOfLengthOctets(), et ASNObject\getObjectLength().

◆ getEncodedValue()

getEncodedValue ( )
abstractprotected

Encode the object using DER encoding.

Voir également
http://en.wikipedia.org/wiki/X.690#DER_encoding
Renvoie
string the binary representation of an objects value

Référencé par ASNObject\getBinary().

◆ getIdentifier()

getIdentifier ( )

Returns all identifier octets. If an inheriting class models a tag with the long form identifier format, it MUST reimplement this method to return all octets of the identifier.

Exceptions
LogicException If the identifier format is long form
Renvoie
string Identifier as a set of octets

Références $this, ASNObject\getType(), et Identifier\isLongForm().

Référencé par ASNObject\getBinary(), et ASNObject\getObjectLength().

◆ getNumberOfLengthOctets()

getNumberOfLengthOctets ( $contentLength = null )
protected

Références ASNObject\$contentLength, ASNObject\$nrOfLengthOctets, ASNObject\getContentLength(), et null.

Référencé par ASNObject\createLengthPart(), ASNObject\getObjectLength(), et ASNObject\setContentLength().

◆ getObjectLength()

getObjectLength ( )

Returns the length of the whole object (including the identifier and length octets).

Références ASNObject\$contentLength, ASNObject\$nrOfLengthOctets, ASNObject\getContentLength(), ASNObject\getIdentifier(), et ASNObject\getNumberOfLengthOctets().

◆ getType()

getType ( )
abstract

Return the object type octet. This should use the class constants of Identifier.

Voir également
Identifier
Renvoie
int

Référencé par AbstractTime\__construct(), TemplateParser\assertTypeId(), AbstractString\checkString(), ASNObject\getIdentifier(), et ASNObject\getTypeName().

◆ getTypeName()

getTypeName ( )

Returns the name of the ASN.1 Type of this object.

Voir également
Identifier::getName()

Références Identifier\getName(), et ASNObject\getType().

◆ parseBinaryIdentifier()

static parseBinaryIdentifier | ( |  | $binaryData,
 |  | & | $offsetIndex
 | ) |  |
staticprotected

Références Identifier\isLongForm().

◆ parseContentLength()

static parseContentLength | ( | & | $binaryData,
 |  | & | $offsetIndex,
 |  |  | $minimumLength = 0
 | ) |  |
staticprotected

Références ASNObject\$contentLength, $i, ASNObject\$nrOfLengthOctets, et BigInteger\create().

◆ parseIdentifier()

static parseIdentifier | ( | $identifierOctet,
 |  | $expectedIdentifier,
 |  | $offsetForExceptionHandling
 | ) |
staticprotected

Références $message, et Identifier\getName().

◆ setContentLength()

setContentLength ( $newContentLength )
protected

Références ASNObject\getNumberOfLengthOctets().

Référencé par UnknownObject\__construct().

Documentation des champs

◆ $contentLength

$contentLength
private

Référencé par UnknownObject\__construct(), ASNObject\createLengthPart(), Attributes\fromBinary(), NullObject\fromBinary(), RelativeObjectIdentifier\fromBinary(), UTCTime\fromBinary(), IPAddress\fromBinary(), Boolean\fromBinary(), BitString\fromBinary(), OctetString\fromBinary(), GeneralizedTime\fromBinary(), ObjectIdentifier\fromBinary(), CertificateSubject\fromBinary(), Integer\fromBinary(), AbstractString\fromBinary(), Construct\fromBinary(), ASNObject\getContentLength(), ASNObject\getNumberOfLengthOctets(), ASNObject\getObjectLength(), et ASNObject\parseContentLength().

◆ $nrOfLengthOctets

$nrOfLengthOctets
private

Référencé par ASNObject\createLengthPart(), ASNObject\getNumberOfLengthOctets(), ASNObject\getObjectLength(), et ASNObject\parseContentLength().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ASNObject.php


Joomla CMS: Référence de la classe Base128

  • FG
  • ASN1
  • Base128
Fonctions membres publiques statiques
Référence de la classe Base128

Fonctions membres publiques statiques

static | encode ($value)
static | decode ($octets)

Description détaillée

A base-128 decoder.

Documentation des fonctions membres

◆ decode()

static decode ( $octets )
static
Paramètres
string $octets
Exceptions
InvalidArgumentException if the given octets represent a malformed base-128 value or the decoded value would exceed the the maximum integer length
Renvoie
int

Références $i, $value, et BigInteger\create().

Référencé par Identifier\getTagNumber(), et ObjectIdentifier\parseOid().

◆ encode()

static encode ( $value )
static
Paramètres
int $value
Renvoie
string

Références $value, et BigInteger\create().

Référencé par ObjectIdentifier\getEncodedValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Base128.php


Joomla CMS: Référence de la classe Construct

  • FG
  • ASN1
  • Construct
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe Construct
+ Graphe d'héritage de Construct:
ASNObject Parsable Parsable Sequence UnknownConstructedObject Attributes AttributeTypeAndValue Set CertificateSubject CSR PrivateKey PublicKey AlgorithmIdentifier RelativeDistinguishedName CertificateExtensions RDNString

Fonctions membres publiques

__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs protégés

$children

Attributs privés

$iteratorPosition

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $children )
Paramètres

Références Construct\$children, et children.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références Construct\getNumberOfChildren().

◆ addChild()

addChild ( ASNObject $child )

Références children.

Référencé par Attributes\addAttribute(), Construct\addChildren(), et CSR\createCSRSequence().

◆ addChildren()

addChildren ( array $children )

Références Construct\$children, et Construct\addChild().

◆ calculateContentLength()

calculateContentLength ( )
protected

Références $component, et children.

◆ count()

count ( $mode = COUNT_NORMAL )

Références $mode, et children.

Référencé par Construct\getNumberOfChildren(), et Construct\offsetSet().

◆ current()

current ( )

Références Construct\$iteratorPosition, et children.

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static
Paramètres
string | $binaryData
int | $offsetIndex
Exceptions
Exception

Implémente Parsable.

Références Construct\$children, ASNObject\$contentLength, et ASNObject\fromBinary().

Référencé par ASNObject\fromBinary().

◆ getChildren()

getChildren ( )
Renvoie
[]

Références Construct\$children.

Référencé par AndroidKeyAttestationStatementSupport\checkAbsenceOfAllApplicationsTag().

◆ getContent()

getContent ( )

Références Construct\$children.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références $component, $result, et children.

◆ getFirstChild()

getFirstChild ( )
Renvoie

Références children.

◆ getIterator()

getIterator ( )

Références children.

◆ getNumberOfChildren()

getNumberOfChildren ( )

Références children, et Construct\count().

Référencé par Construct\__toString().

◆ key()

key ( )

Références Construct\$iteratorPosition.

◆ next()

next ( )

◆ offsetExists()

offsetExists ( $offset )

Références Joomla\Database\Query\$offset, et children.

◆ offsetGet()

offsetGet ( $offset )

Références Joomla\Database\Query\$offset, et children.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Références Joomla\Database\Query\$offset, $value, children, Construct\count(), et null.

◆ offsetUnset()

offsetUnset ( $offset )

Références Joomla\Database\Query\$offset, et children.

◆ rewind()

rewind ( )

Référencé par CSR\createCSRSequence().

◆ valid()

valid ( )

Références children.

Documentation des champs

◆ $children

$children
protected

Référencé par UnknownConstructedObject\__construct(), Construct\__construct(), Construct\addChildren(), Construct\fromBinary(), Construct\getChildren(), et Construct\getContent().

◆ $iteratorPosition

$iteratorPosition
private

Référencé par Construct\current(), et Construct\key().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Construct.php


Joomla CMS: Référence de la classe ExplicitlyTaggedObject

  • FG
  • ASN1
  • ExplicitlyTaggedObject
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés
Référence de la classe ExplicitlyTaggedObject
+ Graphe d'héritage de ExplicitlyTaggedObject:
ASNObject Parsable

Fonctions membres publiques

__construct ($tag,... $objects)
getContent ()
__toString ()
getType ()
getIdentifier ()
getTag ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$decoratedObjects
$tag

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Description détaillée

Class ExplicitlyTaggedObject decorate an inner object with an additional tag that gives information about its context specific meaning.

Explanation taken from A Layman's Guide to a Subset of ASN.1, BER, and DER:

An RSA Laboratories Technical Note Burton S. Kaliski Jr. Revised November 1, 1993

[...] Explicitly tagged types are derived from other types by adding an outer tag to the underlying type. In effect, explicitly tagged types are structured types consisting of one component, the underlying type. Explicit tagging is denoted by the ASN.1 keywords [class number] EXPLICIT (see Section 5.2). [...]

Voir également
http://luca.ntop.org/Teaching/Appunti/asn1.html

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $tag,
 |  | $objects
 | ) |
Paramètres
int | $tag
\FG\ASN1\ASNObject | $objects,...

Références ExplicitlyTaggedObject\$tag.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références Identifier\getShortName(), et ExplicitlyTaggedObject\getType().

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ExplicitlyTaggedObject\$decoratedObjects, ExplicitlyTaggedObject\$tag, ASNObject\fromBinary(), Identifier\getTagNumber(), Identifier\isConstructed(), et Identifier\isContextSpecificClass().

Référencé par ASNObject\fromBinary().

◆ getContent()

getContent ( )

Références ExplicitlyTaggedObject\$decoratedObjects.

◆ getEncodedValue()

getEncodedValue ( )
protected

◆ getIdentifier()

getIdentifier ( )

Références Identifier\CLASS_CONTEXT_SPECIFIC, et Identifier\create().

Référencé par ExplicitlyTaggedObject\getType().

◆ getTag()

getTag ( )

Références ExplicitlyTaggedObject\$tag.

◆ getType()

getType ( )

Références ExplicitlyTaggedObject\getIdentifier().

Référencé par ExplicitlyTaggedObject\__toString().

Documentation des champs

◆ $decoratedObjects

$decoratedObjects
private

Référencé par ExplicitlyTaggedObject\fromBinary(), et ExplicitlyTaggedObject\getContent().

◆ $tag

$tag
private

Référencé par ExplicitlyTaggedObject\__construct(), ExplicitlyTaggedObject\fromBinary(), et ExplicitlyTaggedObject\getTag().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExplicitlyTaggedObject.php


Joomla CMS: Référence de la classe Identifier

  • FG
  • ASN1
  • Identifier
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques
Référence de la classe Identifier

Fonctions membres publiques statiques

static | create ($class, $isConstructed, $tagNumber)
static | isConstructed ($identifierOctet)
static | isLongForm ($identifierOctet)
static | getName ($identifier)
static | getShortName ($identifier)
static | getClassDescription ($identifier)
static | getTagNumber ($identifier)
static | isUniversalClass ($identifier)
static | isApplicationClass ($identifier)
static | isContextSpecificClass ($identifier)
static | isPrivateClass ($identifier)

Champs de données

const | CLASS_UNIVERSAL = 0x00
const | CLASS_APPLICATION = 0x01
const | CLASS_CONTEXT_SPECIFIC = 0x02
const | CLASS_PRIVATE = 0x03
const | EOC = 0x00
const | BOOLEAN = 0x01
const | INTEGER = 0x02
const | BITSTRING = 0x03
const | OCTETSTRING = 0x04
const | NULL = 0x05
const | OBJECT_IDENTIFIER = 0x06
const | OBJECT_DESCRIPTOR = 0x07
const | EXTERNAL = 0x08
const | REAL = 0x09
const | ENUMERATED = 0x0A
const | EMBEDDED_PDV = 0x0B
const | UTF8_STRING = 0x0C
const | RELATIVE_OID = 0x0D
const | SEQUENCE = 0x30
const | SET = 0x31
const | NUMERIC_STRING = 0x12
const | PRINTABLE_STRING = 0x13
const | T61_STRING = 0x14
const | VIDEOTEXT_STRING = 0x15
const | IA5_STRING = 0x16
const | UTC_TIME = 0x17
const | GENERALIZED_TIME = 0x18
const | GRAPHIC_STRING = 0x19
const | VISIBLE_STRING = 0x1A
const | GENERAL_STRING = 0x1B
const | UNIVERSAL_STRING = 0x1C
const | CHARACTER_STRING = 0x1D
const | BMP_STRING = 0x1E
const | LONG_FORM = 0x1F
const | IS_CONSTRUCTED = 0x20

Fonctions membres privées statiques

static makeNumeric ($identifierOctet)

Description détaillée

The Identifier encodes the ASN.1 tag (class and number) of the type of a data value.

Every identifier whose number is in the range 0 to 30 has the following structure:

Bits: 8 7 6 5 4 3 2 1 | Class | P/C | Tag number | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bits 8 and 7 define the class of this type ( Universal, Application, Context-specific or Private). Bit 6 encoded whether this type is primitive or constructed The remaining bits 5 - 1 encode the tag number

Documentation des fonctions membres

◆ create()

static create | ( | $class,
 |  | $isConstructed,
 |  | $tagNumber
 | ) |
static

Creates an identifier. Short form identifiers are returned as integers for BC, long form identifiers will be returned as a string of octets.

Paramètres
int | $class
bool | $isConstructed
int | $tagNumber
Exceptions
Exception if the given arguments are invalid
Renvoie
int|string

Références $class.

Référencé par ExplicitlyTaggedObject\getIdentifier().

◆ getClassDescription()

static getClassDescription ( $identifier )
static

Returns a textual description of the information encoded in a given identifier octet.

The first three (most significant) bytes are evaluated to determine if this is a constructed or primitive type and if it is either universal, application, context-specific or private.

Example: Constructed context-specific Primitive universal

Paramètres
int | string $identifier
Renvoie
string

◆ getName()

static getName ( $identifier )
static

Return the name of the mapped ASN.1 type with a preceding "ASN.1 ".

Example: ASN.1 Octet String

Voir également
Identifier::getShortName()
Paramètres
int | string $identifier
Renvoie
string

Référencé par AbstractTime\__construct(), AbstractString\checkString(), ASNObject\getTypeName(), et ASNObject\parseIdentifier().

◆ getShortName()

static getShortName ( $identifier )
static

Return the short version of the type name.

If the given identifier octet can be mapped to a known universal type this will return its name. Else Identifier::getClassDescription() is used to retrieve information about the identifier.

Voir également
Identifier::getName()
Identifier::getClassDescription()
Paramètres
int | string $identifier
Renvoie
string

Référencé par ExplicitlyTaggedObject\__toString().

◆ getTagNumber()

static getTagNumber ( $identifier )
static
Paramètres
int | string $identifier
Renvoie
int

Références Base128\decode().

Référencé par ExplicitlyTaggedObject\fromBinary().

◆ isApplicationClass()

static isApplicationClass ( $identifier )
static

◆ isConstructed()

static isConstructed ( $identifierOctet )
static

Référencé par ExplicitlyTaggedObject\fromBinary(), et ASNObject\fromBinary().

◆ isContextSpecificClass()

static isContextSpecificClass ( $identifier )
static

Référencé par ExplicitlyTaggedObject\fromBinary(), et ASNObject\fromBinary().

◆ isLongForm()

static isLongForm ( $identifierOctet )
static

Référencé par ASNObject\getIdentifier(), et ASNObject\parseBinaryIdentifier().

◆ isPrivateClass()

static isPrivateClass ( $identifier )
static

◆ isUniversalClass()

static isUniversalClass ( $identifier )
static

◆ makeNumeric()

static makeNumeric ( $identifierOctet )
staticprivate

Documentation des champs

◆ BITSTRING

const BITSTRING = 0x03

Référencé par BitString\fromBinary(), ASNObject\fromBinary(), et BitString\getType().

◆ BMP_STRING

const BMP_STRING = 0x1E

Référencé par ASNObject\fromBinary(), et BMPString\getType().

◆ BOOLEAN

const BOOLEAN = 0x01

Référencé par Boolean\fromBinary(), ASNObject\fromBinary(), et Boolean\getType().

◆ CHARACTER_STRING

const CHARACTER_STRING = 0x1D

Référencé par ASNObject\fromBinary(), et CharacterString\getType().

◆ CLASS_APPLICATION

const CLASS_APPLICATION = 0x01

◆ CLASS_CONTEXT_SPECIFIC

const CLASS_CONTEXT_SPECIFIC = 0x02

Référencé par ExplicitlyTaggedObject\getIdentifier().

◆ CLASS_PRIVATE

const CLASS_PRIVATE = 0x03

◆ CLASS_UNIVERSAL

const CLASS_UNIVERSAL = 0x00

◆ EMBEDDED_PDV

const EMBEDDED_PDV = 0x0B

◆ ENUMERATED

const ENUMERATED = 0x0A

Référencé par ASNObject\fromBinary(), et Enumerated\getType().

◆ EOC

const EOC = 0x00

◆ EXTERNAL

const EXTERNAL = 0x08

◆ GENERAL_STRING

const GENERAL_STRING = 0x1B

Référencé par ASNObject\fromBinary(), et GeneralString\getType().

◆ GENERALIZED_TIME

const GENERALIZED_TIME = 0x18

Référencé par GeneralizedTime\fromBinary(), ASNObject\fromBinary(), et GeneralizedTime\getType().

◆ GRAPHIC_STRING

const GRAPHIC_STRING = 0x19

Référencé par ASNObject\fromBinary(), et GraphicString\getType().

◆ IA5_STRING

const IA5_STRING = 0x16

Référencé par ASNObject\fromBinary(), et IA5String\getType().

◆ INTEGER

const INTEGER = 0x02

Référencé par ASNObject\fromBinary(), et Integer\getType().

◆ IS_CONSTRUCTED

const IS_CONSTRUCTED = 0x20

◆ LONG_FORM

const LONG_FORM = 0x1F

◆ NULL

const NULL = 0x05

Référencé par NullObject\fromBinary(), ASNObject\fromBinary(), et NullObject\getType().

◆ NUMERIC_STRING

const NUMERIC_STRING = 0x12

Référencé par ASNObject\fromBinary(), et NumericString\getType().

◆ OBJECT_DESCRIPTOR

const OBJECT_DESCRIPTOR = 0x07

Référencé par ASNObject\fromBinary(), et ObjectDescriptor\getType().

◆ OBJECT_IDENTIFIER

const OBJECT_IDENTIFIER = 0x06

Référencé par ObjectIdentifier\fromBinary(), ASNObject\fromBinary(), et ObjectIdentifier\getType().

◆ OCTETSTRING

const OCTETSTRING = 0x04

Référencé par OctetString\fromBinary(), ASNObject\fromBinary(), SubjectAlternativeNames\getType(), et OctetString\getType().

◆ PRINTABLE_STRING

const PRINTABLE_STRING = 0x13

Référencé par ASNObject\fromBinary(), et PrintableString\getType().

◆ REAL

const REAL = 0x09

◆ RELATIVE_OID

const RELATIVE_OID = 0x0D

Référencé par RelativeObjectIdentifier\fromBinary(), ASNObject\fromBinary(), et RelativeObjectIdentifier\getType().

◆ SEQUENCE

const SEQUENCE = 0x30

Référencé par Attributes\fromBinary(), CertificateSubject\fromBinary(), ASNObject\fromBinary(), et Sequence\getType().

◆ SET

const SET = 0x31

Référencé par ASNObject\fromBinary(), et Set\getType().

◆ T61_STRING

const T61_STRING = 0x14

Référencé par ASNObject\fromBinary(), et T61String\getType().

◆ UNIVERSAL_STRING

const UNIVERSAL_STRING = 0x1C

Référencé par ASNObject\fromBinary(), et UniversalString\getType().

◆ UTC_TIME

const UTC_TIME = 0x17

Référencé par UTCTime\fromBinary(), ASNObject\fromBinary(), et UTCTime\getType().

◆ UTF8_STRING

const UTF8_STRING = 0x0C

Référencé par ASNObject\fromBinary(), et UTF8String\getType().

◆ VIDEOTEXT_STRING

const VIDEOTEXT_STRING = 0x15

◆ VISIBLE_STRING

const VISIBLE_STRING = 0x1A

Référencé par ASNObject\fromBinary(), et VisibleString\getType().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Identifier.php


Joomla CMS: Référence de la classe OID

  • FG
  • ASN1
  • OID
Fonctions membres publiques statiques | Champs de données
Référence de la classe OID

Fonctions membres publiques statiques

static | getName ($oidString, $loadFromWeb=true)
static | loadFromWeb ($oidString)

Champs de données

const | RSA_ENCRYPTION = '1.2.840.113549.1.1.1'
const | MD5_WITH_RSA_ENCRYPTION = '1.2.840.113549.1.1.4'
const | SHA1_WITH_RSA_SIGNATURE = '1.2.840.113549.1.1.5'
const | SHA256_WITH_RSA_SIGNATURE = '1.2.840.113549.1.1.11'
const | PKCS9_EMAIL = '1.2.840.113549.1.9.1'
const | PKCS9_UNSTRUCTURED_NAME = '1.2.840.113549.1.9.2'
const | PKCS9_CONTENT_TYPE = '1.2.840.113549.1.9.3'
const | PKCS9_MESSAGE_DIGEST = '1.2.840.113549.1.9.4'
const | PKCS9_SIGNING_TIME = '1.2.840.113549.1.9.5'
const | PKCS9_EXTENSION_REQUEST = '1.2.840.113549.1.9.14'
const | CERT_EXT_SUBJECT_DIRECTORY_ATTR = '2.5.29.9'
const | CERT_EXT_SUBJECT_KEY_IDENTIFIER = '2.5.29.14'
const | CERT_EXT_KEY_USAGE = '2.5.29.15'
const | CERT_EXT_PRIVATE_KEY_USAGE_PERIOD = '2.5.29.16'
const | CERT_EXT_SUBJECT_ALT_NAME = '2.5.29.17'
const | CERT_EXT_ISSUER_ALT_NAME = '2.5.29.18'
const | CERT_EXT_BASIC_CONSTRAINTS = '2.5.29.19'
const | CERT_EXT_CRL_NUMBER = '2.5.29.20'
const | CERT_EXT_REASON_CODE = '2.5.29.21'
const | CERT_EXT_INVALIDITY_DATE = '2.5.29.24'
const | CERT_EXT_DELTA_CRL_INDICATOR = '2.5.29.27'
const | CERT_EXT_ISSUING_DIST_POINT = '2.5.29.28'
const | CERT_EXT_CERT_ISSUER = '2.5.29.29'
const | CERT_EXT_NAME_CONSTRAINTS = '2.5.29.30'
const | CERT_EXT_CRL_DISTRIBUTION_POINTS = '2.5.29.31'
const | CERT_EXT_CERT_POLICIES = '2.5.29.32'
const | CERT_EXT_AUTHORITY_KEY_IDENTIFIER = '2.5.29.35'
const | CERT_EXT_EXTENDED_KEY_USAGE = '2.5.29.37'
const | COMMON_NAME = '2.5.4.3'
const | SURNAME = '2.5.4.4'
const | SERIAL_NUMBER = '2.5.4.5'
const | COUNTRY_NAME = '2.5.4.6'
const | LOCALITY_NAME = '2.5.4.7'
const | STATE_OR_PROVINCE_NAME = '2.5.4.8'
const | STREET_ADDRESS = '2.5.4.9'
const | ORGANIZATION_NAME = '2.5.4.10'
const | OU_NAME = '2.5.4.11'
const | TITLE = '2.5.4.12'
const | DESCRIPTION = '2.5.4.13'
const | POSTAL_ADDRESS = '2.5.4.16'
const | POSTAL_CODE = '2.5.4.17'
const | AUTHORITY_REVOCATION_LIST = '2.5.4.38'
const | AUTHORITY_INFORMATION_ACCESS = '1.3.6.1.5.5.7.1.1'

Documentation des fonctions membres

◆ getName()

static getName | ( | $oidString,
 |  | $loadFromWeb = true
 | ) |
static

Returns the name of the given object identifier.

Some OIDs are saved as class constants in this class. If the wanted oidString is not among them, this method will query http://oid-info.com for the right name. This behavior can be suppressed by setting the second method parameter to false.

Paramètres
string | $oidString
bool | $loadFromWeb
Voir également
self::loadFromWeb($oidString)
Renvoie
string

Référencé par ObjectIdentifier\__toString().

◆ loadFromWeb()

static loadFromWeb ( $oidString )
static

Documentation des champs

◆ AUTHORITY_INFORMATION_ACCESS

const AUTHORITY_INFORMATION_ACCESS = '1.3.6.1.5.5.7.1.1'

◆ AUTHORITY_REVOCATION_LIST

const AUTHORITY_REVOCATION_LIST = '2.5.4.38'

◆ CERT_EXT_AUTHORITY_KEY_IDENTIFIER

const CERT_EXT_AUTHORITY_KEY_IDENTIFIER = '2.5.29.35'

◆ CERT_EXT_BASIC_CONSTRAINTS

const CERT_EXT_BASIC_CONSTRAINTS = '2.5.29.19'

◆ CERT_EXT_CERT_ISSUER

const CERT_EXT_CERT_ISSUER = '2.5.29.29'

◆ CERT_EXT_CERT_POLICIES

const CERT_EXT_CERT_POLICIES = '2.5.29.32'

◆ CERT_EXT_CRL_DISTRIBUTION_POINTS

const CERT_EXT_CRL_DISTRIBUTION_POINTS = '2.5.29.31'

◆ CERT_EXT_CRL_NUMBER

const CERT_EXT_CRL_NUMBER = '2.5.29.20'

◆ CERT_EXT_DELTA_CRL_INDICATOR

const CERT_EXT_DELTA_CRL_INDICATOR = '2.5.29.27'

◆ CERT_EXT_EXTENDED_KEY_USAGE

const CERT_EXT_EXTENDED_KEY_USAGE = '2.5.29.37'

◆ CERT_EXT_INVALIDITY_DATE

const CERT_EXT_INVALIDITY_DATE = '2.5.29.24'

◆ CERT_EXT_ISSUER_ALT_NAME

const CERT_EXT_ISSUER_ALT_NAME = '2.5.29.18'

◆ CERT_EXT_ISSUING_DIST_POINT

const CERT_EXT_ISSUING_DIST_POINT = '2.5.29.28'

◆ CERT_EXT_KEY_USAGE

const CERT_EXT_KEY_USAGE = '2.5.29.15'

◆ CERT_EXT_NAME_CONSTRAINTS

const CERT_EXT_NAME_CONSTRAINTS = '2.5.29.30'

◆ CERT_EXT_PRIVATE_KEY_USAGE_PERIOD

const CERT_EXT_PRIVATE_KEY_USAGE_PERIOD = '2.5.29.16'

◆ CERT_EXT_REASON_CODE

const CERT_EXT_REASON_CODE = '2.5.29.21'

◆ CERT_EXT_SUBJECT_ALT_NAME

const CERT_EXT_SUBJECT_ALT_NAME = '2.5.29.17'

Référencé par CertificateExtensions\addSubjectAlternativeNames().

◆ CERT_EXT_SUBJECT_DIRECTORY_ATTR

const CERT_EXT_SUBJECT_DIRECTORY_ATTR = '2.5.29.9'

◆ CERT_EXT_SUBJECT_KEY_IDENTIFIER

const CERT_EXT_SUBJECT_KEY_IDENTIFIER = '2.5.29.14'

◆ COMMON_NAME

const COMMON_NAME = '2.5.4.3'

Référencé par CertificateSubject\__construct().

◆ COUNTRY_NAME

const COUNTRY_NAME = '2.5.4.6'

Référencé par CertificateSubject\__construct().

◆ DESCRIPTION

const DESCRIPTION = '2.5.4.13'

◆ LOCALITY_NAME

const LOCALITY_NAME = '2.5.4.7'

Référencé par CertificateSubject\__construct().

◆ MD5_WITH_RSA_ENCRYPTION

const MD5_WITH_RSA_ENCRYPTION = '1.2.840.113549.1.1.4'

◆ ORGANIZATION_NAME

const ORGANIZATION_NAME = '2.5.4.10'

Référencé par CertificateSubject\__construct().

◆ OU_NAME

const OU_NAME = '2.5.4.11'

Référencé par CertificateSubject\__construct().

◆ PKCS9_CONTENT_TYPE

const PKCS9_CONTENT_TYPE = '1.2.840.113549.1.9.3'

◆ PKCS9_EMAIL

const PKCS9_EMAIL = '1.2.840.113549.1.9.1'

Référencé par CertificateSubject\__construct().

◆ PKCS9_EXTENSION_REQUEST

const PKCS9_EXTENSION_REQUEST = '1.2.840.113549.1.9.14'

Référencé par Attributes\fromBinary().

◆ PKCS9_MESSAGE_DIGEST

const PKCS9_MESSAGE_DIGEST = '1.2.840.113549.1.9.4'

◆ PKCS9_SIGNING_TIME

const PKCS9_SIGNING_TIME = '1.2.840.113549.1.9.5'

◆ PKCS9_UNSTRUCTURED_NAME

const PKCS9_UNSTRUCTURED_NAME = '1.2.840.113549.1.9.2'

◆ POSTAL_ADDRESS

const POSTAL_ADDRESS = '2.5.4.16'

◆ POSTAL_CODE

const POSTAL_CODE = '2.5.4.17'

◆ RSA_ENCRYPTION

const RSA_ENCRYPTION = '1.2.840.113549.1.1.1'

◆ SERIAL_NUMBER

const SERIAL_NUMBER = '2.5.4.5'

◆ SHA1_WITH_RSA_SIGNATURE

const SHA1_WITH_RSA_SIGNATURE = '1.2.840.113549.1.1.5'

◆ SHA256_WITH_RSA_SIGNATURE

const SHA256_WITH_RSA_SIGNATURE = '1.2.840.113549.1.1.11'

◆ STATE_OR_PROVINCE_NAME

const STATE_OR_PROVINCE_NAME = '2.5.4.8'

Référencé par CertificateSubject\__construct().

◆ STREET_ADDRESS

const STREET_ADDRESS = '2.5.4.9'

◆ SURNAME

const SURNAME = '2.5.4.4'

◆ TITLE

const TITLE = '2.5.4.12'
La documentation de cette classe a été générée à partir du fichier suivant :
  • OID.php


Joomla CMS: Référence de l'interface Parsable

  • FG
  • ASN1
  • Parsable
Fonctions membres publiques statiques
Référence de l'interface Parsable
+ Graphe d'héritage de Parsable:
AbstractString ASNObject Construct BitString Boolean GeneralizedTime Integer NullObject ObjectIdentifier OctetString RelativeObjectIdentifier Sequence UTCTime CertificateExtensions CertificateSubject Attributes IPAddress SubjectAlternativeNames

Fonctions membres publiques statiques

static fromBinary (&$binaryData, &$offsetIndex=null)

Description détaillée

The Parsable interface describes classes that can be parsed from their binary DER representation.

Documentation des fonctions membres

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = null
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémenté dans ASNObject, Construct, AbstractString, Integer, ExplicitlyTaggedObject, CertificateSubject, ObjectIdentifier, GeneralizedTime, OctetString, BitString, Boolean, IPAddress, RelativeDistinguishedName, UTCTime, RelativeObjectIdentifier, NullObject, et Attributes.

Référencé par Attributes\fromBinary().

La documentation de cette interface a été générée à partir du fichier suivant :
  • Parsable.php


Joomla CMS: Référence de la classe TemplateParser

  • FG
  • ASN1
  • TemplateParser
Fonctions membres publiques | Fonctions membres privées
Référence de la classe TemplateParser

Fonctions membres publiques

parseBase64 ($data, array $template)
parseBinary ($binary, array $template)

Fonctions membres privées

validate (ASNObject $object, $key, $value)
assertTypeId ($expectedTypeId, ASNObject $object)

Documentation des fonctions membres

◆ assertTypeId()

assertTypeId | ( |  | $expectedTypeId,
 |  | ASNObject | $object
 | ) |  |
private

Références ASNObject\getType().

Référencé par TemplateParser\validate().

◆ parseBase64()

parseBase64 | ( |  | $data,
 |  | array | $template
 | ) |  |
Paramètres
string | $data
array | $template
Renvoie
|Sequence
Exceptions
ParserException if there was an issue parsing

Références $data, et TemplateParser\parseBinary().

◆ parseBinary()

parseBinary | ( |  | $binary,
 |  | array | $template
 | ) |  |
Paramètres
string | $binary
array | $template
Renvoie
|Sequence
Exceptions
ParserException if there was an issue parsing

Références $key, $template, $value, ASNObject\fromBinary(), et TemplateParser\validate().

Référencé par TemplateParser\parseBase64().

◆ validate()

validate | ( | ASNObject | $object,
 |  |  | $key,
 |  |  | $value
 | ) |  |
private

Références $key, $value, et TemplateParser\assertTypeId().

Référencé par TemplateParser\parseBinary().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplateParser.php


Joomla CMS: Référence de la classe UnknownConstructedObject

  • FG
  • ASN1
  • UnknownConstructedObject
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe UnknownConstructedObject
+ Graphe d'héritage de UnknownConstructedObject:
Construct ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($binaryData, &$offsetIndex)
getType ()
getIdentifier ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$identifier
$contentLength

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $binaryData,
 |  | & | $offsetIndex
 | ) |  |
Paramètres
string | $binaryData
int | $offsetIndex
Exceptions

Références Construct\$children, UnknownConstructedObject\$contentLength, Symfony\Contracts\Service\__construct(), et ASNObject\fromBinary().

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

Références UnknownConstructedObject\$contentLength.

◆ getEncodedValue()

getEncodedValue ( )
protected

◆ getIdentifier()

getIdentifier ( )

Références UnknownConstructedObject\$identifier.

◆ getType()

getType ( )

Documentation des champs

◆ $contentLength

$contentLength
private

Référencé par UnknownConstructedObject\__construct(), et UnknownConstructedObject\calculateContentLength().

◆ $identifier

$identifier
private

Référencé par UnknownConstructedObject\getIdentifier().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnknownConstructedObject.php


Joomla CMS: Référence de la classe UnknownObject

  • FG
  • ASN1
  • UnknownObject
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe UnknownObject
+ Graphe d'héritage de UnknownObject:
ASNObject Parsable

Fonctions membres publiques

__construct ($identifier, $contentLength)
getContent ()
getType ()
getIdentifier ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$value
$identifier

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $identifier,
 |  | $contentLength
 | ) |
Paramètres
string | int | $identifier | Either the first identifier octet as int or all identifier bytes as a string
int | $contentLength

Références ASNObject\$contentLength, UnknownObject\$identifier, ASNObject\setContentLength(), et value.

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

Références ASNObject\getContentLength().

◆ getContent()

getContent ( )

Références UnknownObject\$value.

◆ getEncodedValue()

getEncodedValue ( )
protected

◆ getIdentifier()

getIdentifier ( )

Références UnknownObject\$identifier.

◆ getType()

getType ( )

Documentation des champs

◆ $identifier

$identifier
private

Référencé par UnknownObject\__construct(), et UnknownObject\getIdentifier().

◆ $value

$value
private

Référencé par UnknownObject\getContent().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnknownObject.php


Joomla CMS: Référence de la classe BigInteger

  • FG
  • Utility
  • BigInteger
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs privés statiques
Référence de la classe BigInteger
+ Graphe d'héritage de BigInteger:
BigIntegerBcmath BigIntegerGmp

Fonctions membres publiques

__clone ()
__toString ()
toInteger ()
isNegative ()
compare ($number)
add ($b)
subtract ($b)
multiply ($b)
modulus ($b)
toPower ($b)
shiftRight ($bits=8)
shiftLeft ($bits=8)
absoluteValue ()

Fonctions membres publiques statiques

static | setPrefer ($prefer=null)
static | create ($val)

Fonctions membres protégées

__construct ()
_fromString ($str)
_fromInteger ($integer)

Attributs privés statiques

static $_prefer

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

BigInteger constructor. Prevent directly instantiating object, use BigInteger::create instead.

Documentation des fonctions membres

◆ __clone()

__clone ( )
abstract

Subclasses must provide clone functionality.

Renvoie
BigInteger

◆ __toString()

__toString ( )
abstract

Must provide string implementation that returns base 10 number.

Renvoie
string

◆ _fromInteger()

_fromInteger ( $integer )
abstractprotected

Assign the instance value from an integer type.

Paramètres
int $integer

◆ _fromString()

_fromString ( $str )
abstractprotected

Assign the instance value from base 10 string.

Paramètres
string $str

◆ absoluteValue()

absoluteValue ( )
abstract

Returns the absolute value.

Renvoie
BigInteger

◆ add()

add ( $b )
abstract

Add another integer $b and returns the result.

Paramètres
BigInteger | string | int $b
Renvoie
BigInteger

◆ compare()

compare ( $number )
abstract

Compare the integer with $number, returns a negative integer if $this is less than number, returns 0 if $this is equal to number and returns a positive integer if $this is greater than number.

Paramètres
BigInteger | string | int $number
Renvoie
int

◆ create()

static create ( $val )
static

Create a BigInteger instance based off the base 10 string or an integer.

Paramètres
string | int $val
Renvoie
BigInteger
Exceptions

Références $val, et elseif.

Référencé par Base128\decode(), Base128\encode(), Integer\fromBinary(), Integer\getEncodedValue(), et ASNObject\parseContentLength().

◆ isNegative()

isNegative ( )
abstract

Is represented integer negative?

Renvoie
bool

◆ modulus()

modulus ( $b )
abstract

The value $this modulus $b.

Paramètres
BigInteger | string | int $b
Renvoie
BigInteger

◆ multiply()

multiply ( $b )
abstract

Multiply value.

Paramètres
BigInteger | string | int $b
Renvoie
BigInteger

◆ setPrefer()

static setPrefer ( $prefer = null )
static

◆ shiftLeft()

shiftLeft ( $bits = 8 )
abstract

Shift the value to the left by a set number of bits and returns the result.

Paramètres
int $bits
Renvoie
BigInteger

◆ shiftRight()

shiftRight ( $bits = 8 )
abstract

Shift the value to the right by a set number of bits and returns the result.

Paramètres
int $bits
Renvoie
BigInteger

◆ subtract()

subtract ( $b )
abstract

Subtract $b from $this and returns the result.

Paramètres
BigInteger | string | int $b
Renvoie
BigInteger

◆ toInteger()

toInteger ( )
abstract

Return integer, if possible. Throws an exception if the number can not be represented as a native integer.

Renvoie
int
Exceptions

◆ toPower()

toPower ( $b )
abstract

Raise $this to the power of $b and returns the result.

Paramètres
BigInteger | string | int $b
Renvoie
BigInteger

Documentation des champs

◆ $_prefer

$_prefer
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/Utility/BigInteger.php


Joomla CMS: Référence de la classe BigIntegerBcmath

  • FG
  • Utility
  • BigIntegerBcmath
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe BigIntegerBcmath
+ Graphe d'héritage de BigIntegerBcmath:
BigInteger

Fonctions membres publiques

__clone ()
__toString ()
toInteger ()
isNegative ()
compare ($number)
add ($b)
subtract ($b)
multiply ($b)
modulus ($b)
toPower ($b)
shiftRight ($bits=8)
shiftLeft ($bits=8)
absoluteValue ()
- Fonctions membres publiques hérités de BigInteger
__clone ()
__toString ()
toInteger ()
isNegative ()
compare ($number)
add ($b)
subtract ($b)
multiply ($b)
modulus ($b)
toPower ($b)
shiftRight ($bits=8)
shiftLeft ($bits=8)
absoluteValue ()

Fonctions membres protégées

_fromString ($str)
_fromInteger ($integer)
_unwrap ($number)
- Fonctions membres protégées hérités de BigInteger
__construct ()
_fromString ($str)
_fromInteger ($integer)

Attributs protégés

$_str

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BigInteger
static | setPrefer ($prefer=null)
static | create ($val)

Documentation des fonctions membres

◆ __clone()

__clone ( )

◆ __toString()

__toString ( )

Références BigIntegerBcmath\$_str.

◆ _fromInteger()

_fromInteger ( $integer )
protected

◆ _fromString()

_fromString ( $str )
protected

◆ _unwrap()

_unwrap ( $number )
protected

Référencé par BigIntegerBcmath\add(), BigIntegerBcmath\compare(), BigIntegerBcmath\modulus(), BigIntegerBcmath\multiply(), BigIntegerBcmath\subtract(), et BigIntegerBcmath\toPower().

◆ absoluteValue()

absoluteValue ( )

Références BigIntegerBcmath\$_str.

◆ add()

add ( $b )

Références $b, et BigIntegerBcmath\_unwrap().

◆ compare()

compare ( $number )

Références BigIntegerBcmath\_unwrap().

Référencé par BigIntegerBcmath\toInteger().

◆ isNegative()

isNegative ( )

Référencé par BigIntegerBcmath\modulus().

◆ modulus()

modulus ( $b )

Références $b, BigIntegerBcmath\_unwrap(), et BigIntegerBcmath\isNegative().

◆ multiply()

multiply ( $b )

Références $b, et BigIntegerBcmath\_unwrap().

◆ shiftLeft()

shiftLeft ( $bits = 8 )

◆ shiftRight()

shiftRight ( $bits = 8 )

◆ subtract()

subtract ( $b )

Références $b, et BigIntegerBcmath\_unwrap().

◆ toInteger()

toInteger ( )

Références BigIntegerBcmath\$_str, et BigIntegerBcmath\compare().

◆ toPower()

toPower ( $b )

Références $b, et BigIntegerBcmath\_unwrap().

Documentation des champs

◆ $_str

$_str
protected

Référencé par BigIntegerBcmath\__toString(), BigIntegerBcmath\absoluteValue(), et BigIntegerBcmath\toInteger().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BigIntegerBcmath.php


Joomla CMS: Référence de la classe BigIntegerGmp

  • FG
  • Utility
  • BigIntegerGmp
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe BigIntegerGmp
+ Graphe d'héritage de BigIntegerGmp:
BigInteger

Fonctions membres publiques

__clone ()
__toString ()
toInteger ()
isNegative ()
compare ($number)
add ($b)
subtract ($b)
multiply ($b)
modulus ($b)
toPower ($b)
shiftRight ($bits=8)
shiftLeft ($bits=8)
absoluteValue ()
- Fonctions membres publiques hérités de BigInteger
__clone ()
__toString ()
toInteger ()
isNegative ()
compare ($number)
add ($b)
subtract ($b)
multiply ($b)
modulus ($b)
toPower ($b)
shiftRight ($bits=8)
shiftLeft ($bits=8)
absoluteValue ()

Fonctions membres protégées

_fromString ($str)
_fromInteger ($integer)
_unwrap ($number)
- Fonctions membres protégées hérités de BigInteger
__construct ()
_fromString ($str)
_fromInteger ($integer)

Attributs protégés

$_rh

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BigInteger
static | setPrefer ($prefer=null)
static | create ($val)

Documentation des fonctions membres

◆ __clone()

__clone ( )

◆ __toString()

__toString ( )

◆ _fromInteger()

_fromInteger ( $integer )
protected

◆ _fromString()

_fromString ( $str )
protected

◆ _unwrap()

_unwrap ( $number )
protected

Référencé par BigIntegerGmp\add(), BigIntegerGmp\compare(), BigIntegerGmp\modulus(), BigIntegerGmp\multiply(), et BigIntegerGmp\subtract().

◆ absoluteValue()

absoluteValue ( )

◆ add()

add ( $b )

Références $b, et BigIntegerGmp\_unwrap().

◆ compare()

compare ( $number )

Références BigIntegerGmp\_unwrap().

Référencé par BigIntegerGmp\toInteger().

◆ isNegative()

isNegative ( )

◆ modulus()

modulus ( $b )

Références $b, et BigIntegerGmp\_unwrap().

◆ multiply()

multiply ( $b )

Références $b, et BigIntegerGmp\_unwrap().

◆ shiftLeft()

shiftLeft ( $bits = 8 )

◆ shiftRight()

shiftRight ( $bits = 8 )

◆ subtract()

subtract ( $b )

Références $b, et BigIntegerGmp\_unwrap().

◆ toInteger()

toInteger ( )

Références $this, et BigIntegerGmp\compare().

◆ toPower()

toPower ( $b )

Références $b.

Documentation des champs

◆ $_rh

$_rh
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BigIntegerGmp.php


Joomla CMS: Référence de la classe Attributes

  • FG
  • X509
  • CSR
  • Attributes
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Attributes
+ Graphe d'héritage de Attributes:
Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

getType ()
addAttribute ($objectIdentifier, Set $attribute)
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Membres hérités additionnels

- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des fonctions membres

◆ addAttribute()

addAttribute | ( |  | $objectIdentifier,
 |  | Set | $attribute
 | ) |  |

Références Construct\addChild().

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, Parsable\fromBinary(), ObjectIdentifier\fromBinary(), ASNObject\fromBinary(), OID\PKCS9_EXTENSION_REQUEST, et Identifier\SEQUENCE.

◆ getType()

getType ( )
La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/X509/CSR/Attributes.php


Joomla CMS: Référence de la classe CSR

  • FG
  • X509
  • CSR
  • CSR
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe CSR
+ Graphe d'héritage de CSR:
Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($commonName, $email, $organization, $locality, $state, $country, $organizationalUnit, $publicKey, $signature=null, $signatureAlgorithm=OID::SHA1_WITH_RSA_SIGNATURE)
getSignatureSubject ()
setSignature ($signature, $signatureAlgorithm=OID::SHA1_WITH_RSA_SIGNATURE)
__toString ()
getVersion ()
getOrganizationName ()
getLocalName ()
getState ()
getCountry ()
getOrganizationalUnit ()
getPublicKey ()
getSignature ()
getSignatureAlgorithm ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Champs de données

const CSR_VERSION_NR = 0

Fonctions membres protégées

createCSRSequence ()
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs protégés

$subject
$publicKey
$signature
$signatureAlgorithm
$startSequence
- Attributs protégés hérités de Construct
$children

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $commonName,
 |  | $email,
 |  | $organization,
 |  | $locality,
 |  | $state,
 |  | $country,
 |  | $organizationalUnit,
 |  | $publicKey,
 |  | $signature = null,
 |  | $signatureAlgorithm = OID::SHA1_WITH_RSA_SIGNATURE
 | ) |
Paramètres
string | $commonName
string | $email
string | $organization
string | $locality
string | $state
string | $country
string | $organizationalUnit
string | $publicKey
string | $signature
string | $signatureAlgorithm

Références CSR\$publicKey, CSR\$signature, CSR\$signatureAlgorithm, $state, et CSR\createCSRSequence().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références $i, $result, $tmp, et ASNObject\getBinary().

◆ createCSRSequence()

createCSRSequence ( )
protected

Références CSR\$publicKey, CSR\$signature, CSR\$signatureAlgorithm, Construct\addChild(), children, et Construct\rewind().

Référencé par CSR\__construct(), et CSR\setSignature().

◆ getCountry()

getCountry ( )

◆ getLocalName()

getLocalName ( )

◆ getOrganizationalUnit()

getOrganizationalUnit ( )

◆ getOrganizationName()

getOrganizationName ( )

◆ getPublicKey()

getPublicKey ( )

Références CSR\$publicKey.

◆ getSignature()

getSignature ( )

Références CSR\$signature.

◆ getSignatureAlgorithm()

getSignatureAlgorithm ( )

Références CSR\$signatureAlgorithm.

◆ getSignatureSubject()

getSignatureSubject ( )

Références CSR\$publicKey.

◆ getState()

getState ( )

◆ getVersion()

getVersion ( )

◆ setSignature()

setSignature | ( | $signature,
 |  | $signatureAlgorithm = OID::SHA1_WITH_RSA_SIGNATURE
 | ) |

Références CSR\$signature, CSR\$signatureAlgorithm, et CSR\createCSRSequence().

Documentation des champs

◆ $publicKey

$publicKey
protected

Référencé par CSR\__construct(), CSR\createCSRSequence(), CSR\getPublicKey(), et CSR\getSignatureSubject().

◆ $signature

$signature
protected

Référencé par CSR\__construct(), CSR\createCSRSequence(), CSR\getSignature(), et CSR\setSignature().

◆ $signatureAlgorithm

$signatureAlgorithm
protected

Référencé par CSR\__construct(), CSR\createCSRSequence(), CSR\getSignatureAlgorithm(), et CSR\setSignature().

◆ $startSequence

$startSequence
protected

◆ $subject

$subject
protected

◆ CSR_VERSION_NR

const CSR_VERSION_NR = 0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CSR.php


Joomla CMS: Référence de la classe DNSName

  • FG
  • X509
  • SAN
  • DNSName
Fonctions membres publiques | Champs de données
Référence de la classe DNSName
+ Graphe d'héritage de DNSName:
GeneralString AbstractString ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($dnsNameString)
getType ()
- Fonctions membres publiques hérités de GeneralString
__construct ($string)
getType ()
- Fonctions membres publiques hérités de AbstractString
__construct ($string)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Champs de données

const IDENTIFIER = 0x82

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractString
static | fromBinary (&$binaryData, &$offsetIndex=0)
static | isValid ($string)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de AbstractString
allowCharacter ($character)
allowCharacters (... $characters)
allowNumbers ()
allowAllLetters ()
allowSmallLetters ()
allowCapitalLetters ()
allowSpaces ()
allowAll ()
calculateContentLength ()
getEncodedValue ()
checkString ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de AbstractString
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $dnsNameString )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getType()

getType ( )

Documentation des champs

◆ IDENTIFIER

const IDENTIFIER = 0x82
La documentation de cette classe a été générée à partir du fichier suivant :
  • DNSName.php


Joomla CMS: Référence de la classe IPAddress

  • FG
  • X509
  • SAN
  • IPAddress
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs privés
Référence de la classe IPAddress
+ Graphe d'héritage de IPAddress:
ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($ipAddressString)
getType ()
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Champs de données

const IDENTIFIER = 0x87

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$value

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $ipAddressString )

Références value.

Documentation des fonctions membres

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength.

◆ getContent()

getContent ( )

Références IPAddress\$value.

◆ getEncodedValue()

getEncodedValue ( )
protected

Références value.

◆ getType()

getType ( )

Documentation des champs

◆ $value

$value
private

Référencé par IPAddress\getContent().

◆ IDENTIFIER

const IDENTIFIER = 0x87
La documentation de cette classe a été générée à partir du fichier suivant :
  • IPAddress.php


Joomla CMS: Référence de la classe SubjectAlternativeNames

  • FG
  • X509
  • SAN
  • SubjectAlternativeNames
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe SubjectAlternativeNames
+ Graphe d'héritage de SubjectAlternativeNames:
ASNObject Parsable Parsable

Fonctions membres publiques

__construct ()
getType ()
addDomainName (DNSName $domainName)
addIP (IPAddress $ip)
getContent ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres protégées

calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)

Attributs privés

$alternativeNamesSequence

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)

Description détaillée

See section 8.3.2.1 of ITU-T X.509.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ addDomainName()

addDomainName ( DNSName $domainName )

◆ addIP()

addIP ( IPAddress $ip )

◆ calculateContentLength()

calculateContentLength ( )
protected

◆ getContent()

getContent ( )

◆ getEncodedValue()

getEncodedValue ( )
protected

◆ getType()

getType ( )

Références Identifier\OCTETSTRING.

Documentation des champs

◆ $alternativeNamesSequence

$alternativeNamesSequence
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubjectAlternativeNames.php


Joomla CMS: Référence de la classe AlgorithmIdentifier

  • FG
  • X509
  • AlgorithmIdentifier
Fonctions membres publiques
Référence de la classe AlgorithmIdentifier
+ Graphe d'héritage de AlgorithmIdentifier:
AttributeTypeAndValue Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($objectIdentifierString)
- Fonctions membres publiques hérités de AttributeTypeAndValue
__construct ($objIdentifier, ASNObject $value)
__toString ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $objectIdentifierString )

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/X509/AlgorithmIdentifier.php


Joomla CMS: Référence de la classe CertificateExtensions

  • FG
  • X509
  • CertificateExtensions
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe CertificateExtensions
+ Graphe d'héritage de CertificateExtensions:
Set Parsable Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ()
addSubjectAlternativeNames (SubjectAlternativeNames $sans)
getContent ()
- Fonctions membres publiques hérités de Set
getType ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres privées

addExtension ($oidString, ASNObject $extension)

Attributs privés

$innerSequence
$extensions = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addExtension()

addExtension | ( |  | $oidString,
 |  | ASNObject | $extension
 | ) |  |
private

Références $extension.

Référencé par CertificateExtensions\addSubjectAlternativeNames().

◆ addSubjectAlternativeNames()

addSubjectAlternativeNames ( SubjectAlternativeNames $sans )

Références CertificateExtensions\addExtension(), et OID\CERT_EXT_SUBJECT_ALT_NAME.

◆ getContent()

getContent ( )

Références CertificateExtensions\$extensions.

Documentation des champs

◆ $extensions

$extensions = []
private

Référencé par CertificateExtensions\getContent().

◆ $innerSequence

$innerSequence
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateExtensions.php


Joomla CMS: Référence de la classe CertificateSubject

  • FG
  • X509
  • CertificateSubject
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe CertificateSubject
+ Graphe d'héritage de CertificateSubject:
Sequence Parsable Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($commonName, $email, $organization, $locality, $state, $country, $organizationalUnit)
getCommonName ()
getEmail ()
getOrganization ()
getLocality ()
getState ()
getCountry ()
getOrganizationalUnit ()
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Fonctions membres publiques statiques

static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)

Attributs privés

$commonName
$email
$organization
$locality
$state
$country
$organizationalUnit

Membres hérités additionnels

- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $commonName,
 |  | $email,
 |  | $organization,
 |  | $locality,
 |  | $state,
 |  | $country,
 |  | $organizationalUnit
 | ) |
Paramètres
string | $commonName
string | $email
string | $organization
string | $locality
string | $state
string | $country
string | $organizationalUnit

Références CertificateSubject\$commonName, CertificateSubject\$country, CertificateSubject\$email, CertificateSubject\$locality, CertificateSubject\$organization, CertificateSubject\$organizationalUnit, CertificateSubject\$state, Symfony\Contracts\Service\__construct(), OID\COMMON_NAME, OID\COUNTRY_NAME, OID\LOCALITY_NAME, OID\ORGANIZATION_NAME, OID\OU_NAME, OID\PKCS9_EMAIL, et OID\STATE_OR_PROVINCE_NAME.

Documentation des fonctions membres

◆ fromBinary()

static fromBinary | ( | & | $binaryData,
 |  | & | $offsetIndex = 0
 | ) |  |
static

Parse an instance of this class from its binary DER encoded representation.

Paramètres
string | $binaryData
int | $offsetIndex | the offset at which parsing of the $binaryData is started. This parameter ill be modified to contain the offset index of the next object after this object has been parsed
Exceptions
ParserException if the given binary data is either invalid or not currently supported
Renvoie
static

Implémente Parsable.

Références ASNObject\$contentLength, $names, RelativeDistinguishedName\fromBinary(), et Identifier\SEQUENCE.

◆ getCommonName()

getCommonName ( )

Références CertificateSubject\$commonName.

◆ getCountry()

getCountry ( )

Références CertificateSubject\$country.

◆ getEmail()

getEmail ( )

Références CertificateSubject\$email.

◆ getLocality()

getLocality ( )

Références CertificateSubject\$locality.

◆ getOrganization()

getOrganization ( )

Références CertificateSubject\$organization.

◆ getOrganizationalUnit()

getOrganizationalUnit ( )

Références CertificateSubject\$organizationalUnit.

◆ getState()

getState ( )

Références CertificateSubject\$state.

Documentation des champs

◆ $commonName

$commonName
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getCommonName().

◆ $country

$country
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getCountry().

◆ $email

$email
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getEmail().

◆ $locality

$locality
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getLocality().

◆ $organization

$organization
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getOrganization().

◆ $organizationalUnit

$organizationalUnit
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getOrganizationalUnit().

◆ $state

$state
private

Référencé par CertificateSubject\__construct(), et CertificateSubject\getState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateSubject.php


Joomla CMS: Référence de la classe PrivateKey

  • FG
  • X509
  • PrivateKey
Fonctions membres publiques
Référence de la classe PrivateKey
+ Graphe d'héritage de PrivateKey:
Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($hexKey, $algorithmIdentifierString=OID::RSA_ENCRYPTION)
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $hexKey,
 |  | $algorithmIdentifierString = OID::RSA_ENCRYPTION
 | ) |
Paramètres
string | $hexKey
\FG\ASN1\ASNObject | string | $algorithmIdentifierString

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/X509/PrivateKey.php


Joomla CMS: Référence de la classe PublicKey

  • FG
  • X509
  • PublicKey
Fonctions membres publiques
Référence de la classe PublicKey
+ Graphe d'héritage de PublicKey:
Sequence Construct Parsable ASNObject Parsable Parsable

Fonctions membres publiques

__construct ($hexKey, $algorithmIdentifierString=OID::RSA_ENCRYPTION)
- Fonctions membres publiques hérités de Sequence
getType ()
- Fonctions membres publiques hérités de Construct
__construct (... $children)
getContent ()
rewind ()
current ()
key ()
next ()
valid ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
addChild (ASNObject $child)
addChildren (array $children)
__toString ()
getNumberOfChildren ()
getChildren ()
getFirstChild ()
count ($mode=COUNT_NORMAL)
getIterator ()
- Fonctions membres publiques hérités de ASNObject
getContent ()
getType ()
getIdentifier ()
getBinary ()
getObjectLength ()
__toString ()
getTypeName ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Construct
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres publiques statiques hérités de ASNObject
static | fromBinary (&$binaryData, &$offsetIndex=0)
- Fonctions membres protégées hérités de Construct
calculateContentLength ()
getEncodedValue ()
- Fonctions membres protégées hérités de ASNObject
calculateContentLength ()
getEncodedValue ()
getNumberOfLengthOctets ($contentLength=null)
getContentLength ()
setContentLength ($newContentLength)
- Fonctions membres protégées statiques hérités de ASNObject
static | parseIdentifier ($identifierOctet, $expectedIdentifier, $offsetForExceptionHandling)
static | parseBinaryIdentifier ($binaryData, &$offsetIndex)
static | parseContentLength (&$binaryData, &$offsetIndex, $minimumLength=0)
- Attributs protégés hérités de Construct
$children

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $hexKey,
 |  | $algorithmIdentifierString = OID::RSA_ENCRYPTION
 | ) |
Paramètres
string | $hexKey
\FG\ASN1\ASNObject | string | $algorithmIdentifierString

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • fgrosse/phpasn1/lib/X509/PublicKey.php


Joomla CMS: Référence de la classe GenericLinkProvider

  • Fig
  • Link
  • GenericLinkProvider
Fonctions membres publiques
Référence de la classe GenericLinkProvider
+ Graphe d'héritage de GenericLinkProvider:
EvolvableLinkProviderInterface LinkProviderInterface

Fonctions membres publiques

__construct (array $links=[])
- Fonctions membres publiques hérités de EvolvableLinkProviderInterface
withLink (LinkInterface $link)
withoutLink (LinkInterface $link)
- Fonctions membres publiques hérités de LinkProviderInterface
getLinks ()
getLinksByRel ($rel)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $links = [] )

Constructs a new link provider.

Paramètres
LinkInterface[] $links Optionally, specify an initial set of links for this provider. Note that the keys of the array will be ignored.

Références $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • fig/link-util/src/GenericLinkProvider.php


Joomla CMS: Référence de la classe Link

  • Fig
  • Link
  • Link
Fonctions membres publiques
Référence de la classe Link
+ Graphe d'héritage de Link:
EvolvableLinkInterface LinkInterface

Fonctions membres publiques

__construct ($rel='', $href='')
- Fonctions membres publiques hérités de EvolvableLinkInterface
withHref ($href)
withRel ($rel)
withoutRel ($rel)
withAttribute ($attribute, $value)
withoutAttribute ($attribute)
- Fonctions membres publiques hérités de LinkInterface
getHref ()
isTemplated ()
getRels ()
getAttributes ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $rel = '',
 |  | $href = ''
 | ) |

Link constructor.

Paramètres
string | $rel | A single relationship to include on this link.
string | $href | An href for this link.

Références Fig\Link\$href, et Fig\Link\$rel.

La documentation de cette classe a été générée à partir du fichier suivant :
  • fig/link-util/src/Link.php


Joomla CMS: Référence de l'interface Relations

  • Fig
  • Link
  • Relations
Champs de données
Référence de l'interface Relations

Champs de données

const | REL_ABOUT = 'about'
const | REL_ALTERNATE = 'alternate'
const | REL_AMPHTML = 'amphtml'
const | REL_APPENDIX = 'appendix'
const | REL_APPLE_TOUCH_ICON = 'apple-touch-icon'
const | REL_APPLE_TOUCH_STARTUP_IMAGE = 'apple-touch-startup-image'
const | REL_ARCHIVES = 'archives'
const | REL_AUTHOR = 'author'
const | REL_BLOCKED_BY = 'blocked-by'
const | REL_BOOKMARK = 'bookmark'
const | REL_CANONICAL = 'canonical'
const | REL_CHAPTER = 'chapter'
const | REL_CITE_AS = 'cite-as'
const | REL_COLLECTION = 'collection'
const | REL_CONTENTS = 'contents'
const | REL_CONVERTEDFROM = 'convertedFrom'
const | REL_COPYRIGHT = 'copyright'
const | REL_CREATE_FORM = 'create-form'
const | REL_CURRENT = 'current'
const | REL_DESCRIBEDBY = 'describedby'
const | REL_DESCRIBES = 'describes'
const | REL_DISCLOSURE = 'disclosure'
const | REL_DNS_PREFETCH = 'dns-prefetch'
const | REL_DUPLICATE = 'duplicate'
const | REL_EDIT = 'edit'
const | REL_EDIT_FORM = 'edit-form'
const | REL_EDIT_MEDIA = 'edit-media'
const | REL_ENCLOSURE = 'enclosure'
const | REL_EXTERNAL = 'external'
const | REL_FIRST = 'first'
const | REL_GLOSSARY = 'glossary'
const | REL_HELP = 'help'
const | REL_HOSTS = 'hosts'
const | REL_HUB = 'hub'
const | REL_ICON = 'icon'
const | REL_INDEX = 'index'
const | REL_INTERVALAFTER = 'intervalAfter'
const | REL_INTERVALBEFORE = 'intervalBefore'
const | REL_INTERVALCONTAINS = 'intervalContains'
const | REL_INTERVALDISJOINT = 'intervalDisjoint'
const | REL_INTERVALDURING = 'intervalDuring'
const | REL_INTERVALEQUALS = 'intervalEquals'
const | REL_INTERVALFINISHEDBY = 'intervalFinishedBy'
const | REL_INTERVALFINISHES = 'intervalFinishes'
const | REL_INTERVALIN = 'intervalIn'
const | REL_INTERVALMEETS = 'intervalMeets'
const | REL_INTERVALMETBY = 'intervalMetBy'
const | REL_INTERVALOVERLAPPEDBY = 'intervalOverlappedBy'
const | REL_INTERVALOVERLAPS = 'intervalOverlaps'
const | REL_INTERVALSTARTEDBY = 'intervalStartedBy'
const | REL_INTERVALSTARTS = 'intervalStarts'
const | REL_ITEM = 'item'
const | REL_LAST = 'last'
const | REL_LATEST_VERSION = 'latest-version'
const | REL_LICENSE = 'license'
const | REL_LRDD = 'lrdd'
const | REL_MANIFEST = 'manifest'
const | REL_MASK_ICON = 'mask-icon'
const | REL_MEDIA_FEED = 'media-feed'
const | REL_MEMENTO = 'memento'
const | REL_MICROPUB = 'micropub'
const | REL_MODULEPRELOAD = 'modulepreload'
const | REL_MONITOR = 'monitor'
const | REL_MONITOR_GROUP = 'monitor-group'
const | REL_NEXT = 'next'
const | REL_NEXT_ARCHIVE = 'next-archive'
const | REL_NOFOLLOW = 'nofollow'
const | REL_NOOPENER = 'noopener'
const | REL_NOREFERRER = 'noreferrer'
const | REL_OPENER = 'opener'
const | REL_OPENID2_LOCAL_ID = 'openid2.local_id'
const | REL_OPENID2_PROVIDER = 'openid2.provider'
const | REL_ORIGINAL = 'original'
const | REL_P3PV1 = 'P3Pv1'
const | REL_PAYMENT = 'payment'
const | REL_PINGBACK = 'pingback'
const | REL_PRECONNECT = 'preconnect'
const | REL_PREDECESSOR_VERSION = 'predecessor-version'
const | REL_PREFETCH = 'prefetch'
const | REL_PRELOAD = 'preload'
const | REL_PRERENDER = 'prerender'
const | REL_PREV = 'prev'
const | REL_PREVIEW = 'preview'
const | REL_PREVIOUS = 'previous'
const | REL_PREV_ARCHIVE = 'prev-archive'
const | REL_PRIVACY_POLICY = 'privacy-policy'
const | REL_PROFILE = 'profile'
const | REL_PUBLICATION = 'publication'
const | REL_RELATED = 'related'
const | REL_RESTCONF = 'restconf'
const | REL_REPLIES = 'replies'
const | REL_RULEINPUT = 'ruleinput'
const | REL_SEARCH = 'search'
const | REL_SECTION = 'section'
const | REL_SELF = 'self'
const | REL_SERVICE = 'service'
const | REL_SERVICE_DESC = 'service-desc'
const | REL_SERVICE_DOC = 'service-doc'
const | REL_SERVICE_META = 'service-meta'
const | REL_SPONSORED = 'sponsored'
const | REL_START = 'start'
const | REL_STATUS = 'status'
const | REL_STYLESHEET = 'stylesheet'
const | REL_SUBSECTION = 'subsection'
const | REL_SUCCESSOR_VERSION = 'successor-version'
const | REL_SUNSET = 'sunset'
const | REL_TAG = 'tag'
const | REL_TERMS_OF_SERVICE = 'terms-of-service'
const | REL_TIMEGATE = 'timegate'
const | REL_TIMEMAP = 'timemap'
const | REL_TYPE = 'type'
const | REL_UGC = 'ugc'
const | REL_UP = 'up'
const | REL_VERSION_HISTORY = 'version-history'
const | REL_VIA = 'via'
const | REL_WEBMENTION = 'webmention'
const | REL_WORKING_COPY = 'working-copy'
const | REL_WORKING_COPY_OF = 'working-copy-of'

Description détaillée

Standard relation names.

This interface provides convenience constants for standard relationships defined by IANA. They are not required, but are useful for avoiding typos and similar such errors.

This interface may be referenced directly like so:

Relations::REL_UP

Or you may implement this interface in your class and then refer to the constants locally:

static::REL_UP

Documentation des champs

◆ REL_ABOUT

const REL_ABOUT = 'about'

Refers to a resource that is the subject of the link's context.

Voir également
https://tools.ietf.org/html/rfc6903

◆ REL_ALTERNATE

const REL_ALTERNATE = 'alternate'

Refers to a substitute for this context

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-alternate

◆ REL_AMPHTML

const REL_AMPHTML = 'amphtml'

Used to reference alternative content that uses the AMP profile of the HTML format.

Voir également
https://amp.dev/documentation/guides-and-tutorials/learn/spec/amphtml/

◆ REL_APPENDIX

const REL_APPENDIX = 'appendix'

Refers to an appendix.

Voir également
https://www.w3.org/TR/html401/

◆ REL_APPLE_TOUCH_ICON

const REL_APPLE_TOUCH_ICON = 'apple-touch-icon'

Refers to an icon for the context. Synonym for icon.

Voir également
https://developer.apple.com/library/archive/documentation/AppleApplications/Reference/SafariWebContent/ConfiguringWebApplications/ConfiguringWebApplications.html#//apple_ref/doc/uid/TP40002051-CH3-SW3

◆ REL_APPLE_TOUCH_STARTUP_IMAGE

const REL_APPLE_TOUCH_STARTUP_IMAGE = 'apple-touch-startup-image'

Refers to a launch screen for the context.

Voir également
https://developer.apple.com/library/archive/documentation/AppleApplications/Reference/SafariWebContent/ConfiguringWebApplications/ConfiguringWebApplications.html#//apple_ref/doc/uid/TP40002051-CH3-SW3

◆ REL_ARCHIVES

const REL_ARCHIVES = 'archives'

Refers to a collection of records, documents, or other materials of historical interest.

Voir également
http://www.w3.org/TR/2011/WD-html5-20110113/links.html#rel-archives

◆ REL_AUTHOR

const REL_AUTHOR = 'author'

Refers to the context's author.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-author

◆ REL_BLOCKED_BY

const REL_BLOCKED_BY = 'blocked-by'

Identifies the entity that blocks access to a resource following receipt of a legal demand.

Voir également
https://tools.ietf.org/html/rfc7725

◆ REL_BOOKMARK

const REL_BOOKMARK = 'bookmark'

Gives a permanent link to use for bookmarking purposes.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-bookmark

◆ REL_CANONICAL

const REL_CANONICAL = 'canonical'

Designates the preferred version of a resource (the IRI and its contents).

Voir également
https://tools.ietf.org/html/rfc6596

◆ REL_CHAPTER

const REL_CHAPTER = 'chapter'

Refers to a chapter in a collection of resources.

Voir également
https://www.w3.org/TR/html401/

◆ REL_CITE_AS

const REL_CITE_AS = 'cite-as'

Indicates that the link target is preferred over the link context for the purpose of permanent citation.

Voir également
https://tools.ietf.org/html/rfc8574

◆ REL_COLLECTION

const REL_COLLECTION = 'collection'

The target IRI points to a resource which represents the collection resource for the context IRI.

Voir également
https://tools.ietf.org/html/rfc6573

◆ REL_CONTENTS

const REL_CONTENTS = 'contents'

Refers to a table of contents.

Voir également
https://www.w3.org/TR/html401/

◆ REL_CONVERTEDFROM

const REL_CONVERTEDFROM = 'convertedFrom'

The document linked to was later converted to the document that contains this link relation. For example, an RFC can have a link to the Internet-Draft that became the RFC; in that case, the link relation would be "convertedFrom".

This relation is different than "predecessor-version" in that "predecessor-version" is for items in a version control system. It is also different than "previous" in that this relation is used for converted resources, not those that are part of a sequence of resources.

Voir également
https://tools.ietf.org/html/rfc7991

◆ REL_COPYRIGHT

const REL_COPYRIGHT = 'copyright'

Refers to a copyright statement that applies to the link's context.

Voir également
https://www.w3.org/TR/html401/

◆ REL_CREATE_FORM

const REL_CREATE_FORM = 'create-form'

The target IRI points to a resource where a submission form can be obtained.

Voir également
https://tools.ietf.org/html/rfc6861

◆ REL_CURRENT

const REL_CURRENT = 'current'

Refers to a resource containing the most recent item(s) in a collection of resources.

Voir également
https://tools.ietf.org/html/rfc5005

◆ REL_DESCRIBEDBY

const REL_DESCRIBEDBY = 'describedby'

Refers to a resource providing information about the link's context.

Voir également
http://www.w3.org/TR/powder-dr/#assoc-linking

◆ REL_DESCRIBES

const REL_DESCRIBES = 'describes'

The relationship A 'describes' B asserts that resource A provides a description of resource B. There are no constraints on the format or representation of either A or B, neither are there any further constraints on either resource.

This link relation type is the inverse of the 'describedby' relation type. While 'describedby' establishes a relation from the described resource back to the resource that describes it, 'describes' established a relation from the describing resource to the resource it describes. If B is 'describedby' A, then A 'describes' B.

Voir également
https://tools.ietf.org/html/rfc6892

◆ REL_DISCLOSURE

const REL_DISCLOSURE = 'disclosure'

Refers to a list of patent disclosures made with respect to material for which 'disclosure' relation is specified.

Voir également
https://tools.ietf.org/html/rfc6579

◆ REL_DNS_PREFETCH

const REL_DNS_PREFETCH = 'dns-prefetch'

Used to indicate an origin that will be used to fetch required resources for the link context, and that the user agent ought to resolve as early as possible.

Voir également
https://www.w3.org/TR/resource-hints/

◆ REL_DUPLICATE

const REL_DUPLICATE = 'duplicate'

Refers to a resource whose available representations are byte-for-byte identical with the corresponding representations of the context IRI.

This relation is for static resources. That is, an HTTP GET request on any duplicate will return the same representation. It does not make sense for dynamic or POSTable resources and should not be used for them.

Voir également
https://tools.ietf.org/html/rfc6249

◆ REL_EDIT

const REL_EDIT = 'edit'

Refers to a resource that can be used to edit the link's context.

Voir également
https://tools.ietf.org/html/rfc5023

◆ REL_EDIT_FORM

const REL_EDIT_FORM = 'edit-form'

The target IRI points to a resource where a submission form for editing associated resource can be obtained.

Voir également
https://tools.ietf.org/html/rfc6861

◆ REL_EDIT_MEDIA

const REL_EDIT_MEDIA = 'edit-media'

Refers to a resource that can be used to edit media associated with the link's context.

Voir également
https://tools.ietf.org/html/rfc5023

◆ REL_ENCLOSURE

const REL_ENCLOSURE = 'enclosure'

Identifies a related resource that is potentially large and might require special handling.

Voir également
https://tools.ietf.org/html/rfc4287

◆ REL_EXTERNAL

const REL_EXTERNAL = 'external'

Refers to a resource that is not part of the same site as the current context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-external

◆ REL_FIRST

const REL_FIRST = 'first'

An IRI that refers to the furthest preceding resource in a series of resources.

This relation type registration did not indicate a reference. Originally requested by Mark Nottingham in December 2004.

Voir également
https://tools.ietf.org/html/rfc8288

◆ REL_GLOSSARY

const REL_GLOSSARY = 'glossary'

Refers to a glossary of terms.

Voir également
https://www.w3.org/TR/html401/

◆ REL_HELP

const REL_HELP = 'help'

Refers to context-sensitive help.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-help

◆ REL_HOSTS

const REL_HOSTS = 'hosts'

Refers to a resource hosted by the server indicated by the link context.

This relation is used in CoRE where links are retrieved as a "/.well-known/core" resource representation, and is the default relation type in the CoRE Link Format.

Voir également
https://tools.ietf.org/html/rfc6690

◆ REL_HUB

const REL_HUB = 'hub'

Refers to a hub that enables registration for notification of updates to the context.

This relation type was requested by Brett Slatkin.

Voir également
https://www.w3.org/TR/websub/

◆ REL_ICON

const REL_ICON = 'icon'

Refers to an icon representing the link's context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#rel-icon

◆ REL_INDEX

const REL_INDEX = 'index'

Refers to an index.

Voir également
https://www.w3.org/TR/html401/

◆ REL_INTERVALAFTER

const REL_INTERVALAFTER = 'intervalAfter'

refers to a resource associated with a time interval that ends before the beginning of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalAfter

◆ REL_INTERVALBEFORE

const REL_INTERVALBEFORE = 'intervalBefore'

refers to a resource associated with a time interval that begins after the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalBefore

◆ REL_INTERVALCONTAINS

const REL_INTERVALCONTAINS = 'intervalContains'

refers to a resource associated with a time interval that begins after the beginning of the time interval associated with the context resource, and ends before the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalContains

◆ REL_INTERVALDISJOINT

const REL_INTERVALDISJOINT = 'intervalDisjoint'

refers to a resource associated with a time interval that begins after the end of the time interval associated with the context resource, or ends before the beginning of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalDisjoint

◆ REL_INTERVALDURING

const REL_INTERVALDURING = 'intervalDuring'

refers to a resource associated with a time interval that begins before the beginning of the time interval associated with the context resource, and ends after the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalDuring

◆ REL_INTERVALEQUALS

const REL_INTERVALEQUALS = 'intervalEquals'

refers to a resource associated with a time interval whose beginning coincides with the beginning of the time interval associated with the context resource, and whose end coincides with the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalEquals

◆ REL_INTERVALFINISHEDBY

const REL_INTERVALFINISHEDBY = 'intervalFinishedBy'

refers to a resource associated with a time interval that begins after the beginning of the time interval associated with the context resource, and whose end coincides with the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalFinishedBy

◆ REL_INTERVALFINISHES

const REL_INTERVALFINISHES = 'intervalFinishes'

refers to a resource associated with a time interval that begins before the beginning of the time interval associated with the context resource, and whose end coincides with the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalFinishes

◆ REL_INTERVALIN

const REL_INTERVALIN = 'intervalIn'

refers to a resource associated with a time interval that begins before or is coincident with the beginning of the time interval associated with the context resource, and ends after or is coincident with the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalIn

◆ REL_INTERVALMEETS

const REL_INTERVALMEETS = 'intervalMeets'

refers to a resource associated with a time interval whose beginning coincides with the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalMeets

◆ REL_INTERVALMETBY

const REL_INTERVALMETBY = 'intervalMetBy'

refers to a resource associated with a time interval whose end coincides with the beginning of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalMetBy

◆ REL_INTERVALOVERLAPPEDBY

const REL_INTERVALOVERLAPPEDBY = 'intervalOverlappedBy'

refers to a resource associated with a time interval that begins before the beginning of the time interval associated with the context resource, and ends after the beginning of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalOverlappedBy

◆ REL_INTERVALOVERLAPS

const REL_INTERVALOVERLAPS = 'intervalOverlaps'

refers to a resource associated with a time interval that begins before the end of the time interval associated with the context resource, and ends after the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalOverlaps

◆ REL_INTERVALSTARTEDBY

const REL_INTERVALSTARTEDBY = 'intervalStartedBy'

refers to a resource associated with a time interval whose beginning coincides with the beginning of the time interval associated with the context resource, and ends before the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalStartedBy

◆ REL_INTERVALSTARTS

const REL_INTERVALSTARTS = 'intervalStarts'

refers to a resource associated with a time interval whose beginning coincides with the beginning of the time interval associated with the context resource, and ends after the end of the time interval associated with the context resource

Voir également
https://www.w3.org/TR/owl-time/#time:intervalStarts

◆ REL_ITEM

const REL_ITEM = 'item'

The target IRI points to a resource that is a member of the collection represented by the context IRI.

Voir également
https://tools.ietf.org/html/rfc6573

◆ REL_LAST

const REL_LAST = 'last'

An IRI that refers to the furthest following resource in a series of resources.

This relation type registration did not indicate a reference. Originally requested by Mark Nottingham in December 2004.

Voir également
https://tools.ietf.org/html/rfc8288

◆ REL_LATEST_VERSION

const REL_LATEST_VERSION = 'latest-version'

Points to a resource containing the latest (e.g., current) version of the context.

Voir également
https://tools.ietf.org/html/rfc5829

◆ REL_LICENSE

const REL_LICENSE = 'license'

Refers to a license associated with this context.

For implications of use in HTML, see: http://www.w3.org/TR/html5/links.html#link-type-license

Voir également
https://tools.ietf.org/html/rfc4946

◆ REL_LRDD

const REL_LRDD = 'lrdd'

Refers to further information about the link's context, expressed as a LRDD ("Link-based Resource Descriptor Document") resource. See for information about processing this relation type in host-meta documents. When used elsewhere, it refers to additional links and other metadata. Multiple instances indicate additional LRDD resources. LRDD resources MUST have an "application/xrd+xml" representation, and MAY have others.

Voir également
https://tools.ietf.org/html/rfc6415

◆ REL_MANIFEST

const REL_MANIFEST = 'manifest'

Links to a manifest file for the context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-manifest

◆ REL_MASK_ICON

const REL_MASK_ICON = 'mask-icon'

Refers to a mask that can be applied to the icon for the context.

Voir également
https://developer.apple.com/library/archive/documentation/AppleApplications/Reference/SafariWebContent/pinnedTabs/pinnedTabs.html#//apple_ref/doc/uid/TP40002051-CH18-SW1

◆ REL_MEDIA_FEED

const REL_MEDIA_FEED = 'media-feed'

Refers to a feed of personalised media recommendations relevant to the link context.

Voir également
https://wicg.github.io/media-feeds/#discovery-of-media-feeds

◆ REL_MEMENTO

const REL_MEMENTO = 'memento'

The Target IRI points to a Memento, a fixed resource that will not change state anymore.

A Memento for an Original Resource is a resource that encapsulates a prior state of the Original Resource.

Voir également
https://tools.ietf.org/html/rfc7089

◆ REL_MICROPUB

const REL_MICROPUB = 'micropub'

Links to the context's Micropub endpoint.

Voir également
https://www.w3.org/TR/micropub/#endpoint-discovery-p-1

◆ REL_MODULEPRELOAD

const REL_MODULEPRELOAD = 'modulepreload'

Refers to a module that the user agent is to preemptively fetch and store for use in the current context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-modulepreload

◆ REL_MONITOR

const REL_MONITOR = 'monitor'

Refers to a resource that can be used to monitor changes in an HTTP resource.

Voir également
https://tools.ietf.org/html/rfc5989

◆ REL_MONITOR_GROUP

const REL_MONITOR_GROUP = 'monitor-group'

Refers to a resource that can be used to monitor changes in a specified group of HTTP resources.

Voir également
https://tools.ietf.org/html/rfc5989

◆ REL_NEXT

const REL_NEXT = 'next'

Indicates that the link's context is a part of a series, and that the next in the series is the link target.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-next

◆ REL_NEXT_ARCHIVE

const REL_NEXT_ARCHIVE = 'next-archive'

Refers to the immediately following archive resource.

Voir également
https://tools.ietf.org/html/rfc5005

◆ REL_NOFOLLOW

const REL_NOFOLLOW = 'nofollow'

Indicates that the context’s original author or publisher does not endorse the link target.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-nofollow

◆ REL_NOOPENER

const REL_NOOPENER = 'noopener'

Indicates that any newly created top-level browsing context which results from following the link will not be an auxiliary browsing context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-noopener

◆ REL_NOREFERRER

const REL_NOREFERRER = 'noreferrer'

Indicates that no referrer information is to be leaked when following the link.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-noreferrer

◆ REL_OPENER

const REL_OPENER = 'opener'

Indicates that any newly created top-level browsing context which results from following the link will be an auxiliary browsing context.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-opener

◆ REL_OPENID2_LOCAL_ID

const REL_OPENID2_LOCAL_ID = 'openid2.local_id'

Refers to an OpenID Authentication server on which the context relies for an assertion that the end user controls an Identifier.

Voir également
https://openid.net/specs/openid-authentication-2_0.html#rfc.section.7.3.3

◆ REL_OPENID2_PROVIDER

const REL_OPENID2_PROVIDER = 'openid2.provider'

Refers to a resource which accepts OpenID Authentication protocol messages for the context.

Voir également
https://openid.net/specs/openid-authentication-2_0.html#rfc.section.7.3.3

◆ REL_ORIGINAL

const REL_ORIGINAL = 'original'

The Target IRI points to an Original Resource.

An Original Resource is a resource that exists or used to exist, and for which access to one of its prior states may be required.

Voir également
https://tools.ietf.org/html/rfc7089

◆ REL_P3PV1

const REL_P3PV1 = 'P3Pv1'

Refers to a P3P privacy policy for the context.

Voir également
https://www.w3.org/TR/P3P/#syntax_link

◆ REL_PAYMENT

const REL_PAYMENT = 'payment'

Indicates a resource where payment is accepted.

This relation type registration did not indicate a reference. Requested by Joshua Kinberg and Robert Sayre. It is meant as a general way to facilitate acts of payment, and thus this specification makes no assumptions on the type of payment or transaction protocol. Examples may include a web page where donations are accepted or where goods and services are available for purchase. rel="payment" is not intended to initiate an automated transaction. In Atom documents, a link element with a rel="payment" attribute may exist at the feed/channel level and/or the entry/item level. For example, a rel="payment" link at the feed/channel level may point to a "tip jar" URI, whereas an entry/ item containing a book review may include a rel="payment" link that points to the location where the book may be purchased through an online retailer.

Voir également
https://tools.ietf.org/html/rfc8288

◆ REL_PINGBACK

const REL_PINGBACK = 'pingback'

Gives the address of the pingback resource for the link context.

Voir également
http://www.hixie.ch/specs/pingback/pingback

◆ REL_PRECONNECT

const REL_PRECONNECT = 'preconnect'

Used to indicate an origin that will be used to fetch required resources for the link context. Initiating an early connection, which includes the DNS lookup, TCP handshake, and optional TLS negotiation, allows the user agent to mask the high latency costs of establishing a connection.

Voir également
https://www.w3.org/TR/resource-hints/

◆ REL_PREDECESSOR_VERSION

const REL_PREDECESSOR_VERSION = 'predecessor-version'

Points to a resource containing the predecessor version in the version history.

Voir également
https://tools.ietf.org/html/rfc5829

◆ REL_PREFETCH

const REL_PREFETCH = 'prefetch'

The prefetch link relation type is used to identify a resource that might be required by the next navigation from the link context, and that the user agent ought to fetch, such that the user agent can deliver a faster response once the resource is requested in the future.

Voir également
http://www.w3.org/TR/resource-hints/

◆ REL_PRELOAD

const REL_PRELOAD = 'preload'

Refers to a resource that should be loaded early in the processing of the link's context, without blocking rendering.

Additional target attributes establish the detailed fetch properties of the link.

Voir également
http://www.w3.org/TR/preload/

◆ REL_PRERENDER

const REL_PRERENDER = 'prerender'

Used to identify a resource that might be required by the next navigation from the link context, and that the user agent ought to fetch and execute, such that the user agent can deliver a faster response once the resource is requested in the future.

Voir également
https://www.w3.org/TR/resource-hints/

◆ REL_PREV

const REL_PREV = 'prev'

Indicates that the link's context is a part of a series, and that the previous in the series is the link target.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-prev

◆ REL_PREV_ARCHIVE

const REL_PREV_ARCHIVE = 'prev-archive'

Refers to the immediately preceding archive resource.

Voir également
https://tools.ietf.org/html/rfc5005

◆ REL_PREVIEW

const REL_PREVIEW = 'preview'

Refers to a resource that provides a preview of the link's context.

Voir également
https://tools.ietf.org/html/rfc6903

◆ REL_PREVIOUS

const REL_PREVIOUS = 'previous'

Refers to the previous resource in an ordered series of resources. Synonym for "prev".

Voir également
https://www.w3.org/TR/html401/

◆ REL_PRIVACY_POLICY

const REL_PRIVACY_POLICY = 'privacy-policy'

Refers to a privacy policy associated with the link's context.

Voir également
https://tools.ietf.org/html/rfc6903

◆ REL_PROFILE

const REL_PROFILE = 'profile'

Identifying that a resource representation conforms to a certain profile, without affecting the non-profile semantics of the resource representation.

Profile URIs are primarily intended to be used as identifiers, and thus clients SHOULD NOT indiscriminately access profile URIs.

Voir également
https://tools.ietf.org/html/rfc6906

◆ REL_PUBLICATION

const REL_PUBLICATION = 'publication'

Links to a publication manifest. A manifest represents structured information about a publication, such as informative metadata, a list of resources, and a default reading order.

Voir également
https://www.w3.org/TR/pub-manifest/#link-relation-type-registration

◆ REL_RELATED

const REL_RELATED = 'related'

Identifies a related resource.

Voir également
https://tools.ietf.org/html/rfc4287

◆ REL_REPLIES

const REL_REPLIES = 'replies'

Identifies a resource that is a reply to the context of the link.

Voir également
https://tools.ietf.org/html/rfc4685

◆ REL_RESTCONF

const REL_RESTCONF = 'restconf'

Identifies the root of RESTCONF API as configured on this HTTP server. The "restconf" relation defines the root of the API defined in RFC8040. Subsequent revisions of RESTCONF will use alternate relation values to support protocol versioning.

Voir également
https://tools.ietf.org/html/rfc8040

◆ REL_RULEINPUT

const REL_RULEINPUT = 'ruleinput'

The resource identified by the link target provides an input value to an instance of a rule, where the resource which represents the rule instance is identified by the link context.

Voir également
https://openconnectivity.org/specs/OCF_Core_Optional_Specification_v2.2.0.pdf

◆ REL_SEARCH

const REL_SEARCH = 'search'

Refers to a resource that can be used to search through the link's context and related resources.

Voir également
http://www.opensearch.org/Specifications/OpenSearch/1.1

◆ REL_SECTION

const REL_SECTION = 'section'

Refers to a section in a collection of resources.

Voir également
https://www.w3.org/TR/html401/

◆ REL_SELF

const REL_SELF = 'self'

Conveys an identifier for the link's context.

Voir également
https://tools.ietf.org/html/rfc4287

◆ REL_SERVICE

const REL_SERVICE = 'service'

Indicates a URI that can be used to retrieve a service document.

When used in an Atom document, this relation type specifies Atom Publishing Protocol service documents by default. Requested by James Snell.

Voir également
https://tools.ietf.org/html/rfc5023

◆ REL_SERVICE_DESC

const REL_SERVICE_DESC = 'service-desc'

Identifies service description for the context that is primarily intended for consumption by machines.

Voir également
https://tools.ietf.org/html/rfc8631

◆ REL_SERVICE_DOC

const REL_SERVICE_DOC = 'service-doc'

Identifies service documentation for the context that is primarily intended for human consumption.

Voir également
https://tools.ietf.org/html/rfc8631

◆ REL_SERVICE_META

const REL_SERVICE_META = 'service-meta'

Identifies general metadata for the context that is primarily intended for consumption by machines.

Voir également
https://tools.ietf.org/html/rfc8631

◆ REL_SPONSORED

const REL_SPONSORED = 'sponsored'

Refers to a resource that is within a context that is sponsored (such as advertising or another compensation agreement).

Voir également
https://webmasters.googleblog.com/2019/09/evolving-nofollow-new-ways-to-identify.html

◆ REL_START

const REL_START = 'start'

Refers to the first resource in a collection of resources.

Voir également
https://www.w3.org/TR/html401

◆ REL_STATUS

const REL_STATUS = 'status'

Identifies a resource that represents the context's status.

Voir également
https://tools.ietf.org/html/rfc8631

◆ REL_STYLESHEET

const REL_STYLESHEET = 'stylesheet'

Refers to a stylesheet.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-stylesheet

◆ REL_SUBSECTION

const REL_SUBSECTION = 'subsection'

Refers to a resource serving as a subsection in a collection of resources.

Voir également
https://www.w3.org/TR/html401/

◆ REL_SUCCESSOR_VERSION

const REL_SUCCESSOR_VERSION = 'successor-version'

Points to a resource containing the successor version in the version history.

Voir également
https://tools.ietf.org/html/rfc5829

◆ REL_SUNSET

const REL_SUNSET = 'sunset'

Identifies a resource that provides information about the context's retirement policy.

Voir également
https://tools.ietf.org/html/rfc8594

◆ REL_TAG

const REL_TAG = 'tag'

Gives a tag (identified by the given address) that applies to the current document.

Voir également
https://html.spec.whatwg.org/multipage/links.html#link-type-tag

◆ REL_TERMS_OF_SERVICE

const REL_TERMS_OF_SERVICE = 'terms-of-service'

Refers to the terms of service associated with the link's context.

Voir également
https://tools.ietf.org/html/rfc6903

◆ REL_TIMEGATE

const REL_TIMEGATE = 'timegate'

The Target IRI points to a TimeGate for an Original Resource.

A TimeGate for an Original Resource is a resource that is capable of datetime negotiation to support access to prior states of the Original Resource.

Voir également
https://tools.ietf.org/html/rfc7089

◆ REL_TIMEMAP

const REL_TIMEMAP = 'timemap'

The Target IRI points to a TimeMap for an Original Resource.

A TimeMap for an Original Resource is a resource from which a list of URIs of Mementos of the Original Resource is available.

Voir également
https://tools.ietf.org/html/rfc7089

◆ REL_TYPE

const REL_TYPE = 'type'

Refers to a resource identifying the abstract semantic type of which the link's context is considered to be an instance.

Voir également
https://tools.ietf.org/html/rfc6903

◆ REL_UGC

const REL_UGC = 'ugc'

Refers to a resource that is within a context that is User Generated Content.

Voir également
https://webmasters.googleblog.com/2019/09/evolving-nofollow-new-ways-to-identify.html

◆ REL_UP

const REL_UP = 'up'

Refers to a parent document in a hierarchy of documents.

This relation type registration did not indicate a reference. Requested by Noah Slater.

Voir également
https://tools.ietf.org/html/rfc8288

◆ REL_VERSION_HISTORY

const REL_VERSION_HISTORY = 'version-history'

Points to a resource containing the version history for the context.

Voir également
https://tools.ietf.org/html/rfc5829

◆ REL_VIA

const REL_VIA = 'via'

Identifies a resource that is the source of the information in the link's context.

Voir également
https://tools.ietf.org/html/rfc4287

◆ REL_WEBMENTION

const REL_WEBMENTION = 'webmention'

Identifies a target URI that supports the Webmention protocol. This allows clients that mention a resource in some form of publishing process to contact that endpoint and inform it that this resource has been mentioned.

This is a similar "Linkback" mechanism to the ones of Refback, Trackback, and Pingback. It uses a different protocol, though, and thus should be discoverable through its own link relation type.

Voir également
http://www.w3.org/TR/webmention/

◆ REL_WORKING_COPY

const REL_WORKING_COPY = 'working-copy'

Points to a working copy for this resource.

Voir également
https://tools.ietf.org/html/rfc5829

◆ REL_WORKING_COPY_OF

const REL_WORKING_COPY_OF = 'working-copy-of'

Points to the versioned resource from which this working copy was obtained.

Voir également
https://tools.ietf.org/html/rfc5829
La documentation de cette interface a été générée à partir du fichier suivant :
  • Relations.php


Joomla CMS: Référence de l'interface MessageFactory

  • Http
  • Message
  • MessageFactory
Référence de l'interface MessageFactory
+ Graphe d'héritage de MessageFactory:
RequestFactory ResponseFactory HttplugFactory

Membres hérités additionnels

- Fonctions membres publiques hérités de RequestFactory
createRequest ( $method, $uri, array $headers=[], $body=null, $protocolVersion='1.1')
- Fonctions membres publiques hérités de ResponseFactory
createResponse ( $statusCode=200, $reasonPhrase=null, array $headers=[], $body=null, $protocolVersion='1.1')

Description détaillée

Factory for PSR-7 Request and Response.

Auteur
Márk Sági-Kazár mark..nosp@m.sagi.nosp@m.kazar.nosp@m.@gma.nosp@m.il.co.nosp@m.m
La documentation de cette interface a été générée à partir du fichier suivant :
  • MessageFactory.php


Joomla CMS: Référence de l'interface RequestFactory

  • Http
  • Message
  • RequestFactory
Fonctions membres publiques
Référence de l'interface RequestFactory
+ Graphe d'héritage de RequestFactory:
MessageFactory HttplugFactory

Fonctions membres publiques

createRequest ( $method, $uri, array $headers=[], $body=null, $protocolVersion='1.1')

Description détaillée

Factory for PSR-7 Request.

Auteur
Márk Sági-Kazár mark..nosp@m.sagi.nosp@m.kazar.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des fonctions membres

◆ createRequest()

createRequest | ( |  | $method,
 |  |  | $uri,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  |  | $protocolVersion = '1.1'
 | ) |  |

Creates a new PSR-7 request.

Paramètres
string | $method
string | UriInterface | $uri
array | $headers
resource | string | StreamInterface | null | $body
string | $protocolVersion
Renvoie
RequestInterface

Implémenté dans HttplugFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • php-http/message-factory/src/RequestFactory.php


Joomla CMS: Référence de l'interface ResponseFactory

  • Http
  • Message
  • ResponseFactory
Fonctions membres publiques
Référence de l'interface ResponseFactory
+ Graphe d'héritage de ResponseFactory:
MessageFactory HttplugFactory

Fonctions membres publiques

createResponse ( $statusCode=200, $reasonPhrase=null, array $headers=[], $body=null, $protocolVersion='1.1')

Description détaillée

Factory for PSR-7 Response.

This factory contract can be reused in Message and Server Message factories.

Auteur
Márk Sági-Kazár mark..nosp@m.sagi.nosp@m.kazar.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des fonctions membres

◆ createResponse()

createResponse | ( |  | $statusCode = 200,
 |  |  | $reasonPhrase = null,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  |  | $protocolVersion = '1.1'
 | ) |  |

Creates a new PSR-7 response.

Paramètres
int | $statusCode
string | null | $reasonPhrase
array | $headers
resource | string | StreamInterface | null | $body
string | $protocolVersion
Renvoie
ResponseInterface

Implémenté dans HttplugFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • php-http/message-factory/src/ResponseFactory.php


Joomla CMS: Référence de l'interface StreamFactory

  • Http
  • Message
  • StreamFactory
Fonctions membres publiques
Référence de l'interface StreamFactory
+ Graphe d'héritage de StreamFactory:
HttplugFactory

Fonctions membres publiques

createStream ($body=null)

Description détaillée

Factory for PSR-7 Stream.

Auteur
Márk Sági-Kazár mark..nosp@m.sagi.nosp@m.kazar.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des fonctions membres

◆ createStream()

createStream ( $body = null )

Creates a new PSR-7 stream.

Paramètres
string | resource | StreamInterface | null $body
Renvoie
StreamInterface
Exceptions

Implémenté dans HttplugFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • php-http/message-factory/src/StreamFactory.php


Joomla CMS: Référence de l'interface UriFactory

  • Http
  • Message
  • UriFactory
Fonctions membres publiques
Référence de l'interface UriFactory
+ Graphe d'héritage de UriFactory:
HttplugFactory

Fonctions membres publiques

createUri ($uri)

Description détaillée

Factory for PSR-7 URI.

Auteur
Márk Sági-Kazár mark..nosp@m.sagi.nosp@m.kazar.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des fonctions membres

◆ createUri()

createUri ( $uri )

Creates an PSR-7 URI.

Paramètres
string | UriInterface $uri
Renvoie
UriInterface
Exceptions

Implémenté dans HttplugFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • php-http/message-factory/src/UriFactory.php


Joomla CMS: Référence de la classe ContainerControllerResolver

  • Joomla
  • Application
  • Controller
  • ContainerControllerResolver
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe ContainerControllerResolver
+ Graphe d'héritage de ContainerControllerResolver:
ControllerResolver ControllerResolverInterface

Fonctions membres publiques

__construct (ContainerInterface $container)
- Fonctions membres publiques hérités de ControllerResolver
resolve (ResolvedRoute $route)

Fonctions membres protégées

instantiateController (string $class)
- Fonctions membres protégées hérités de ControllerResolver
instantiateController (string $class)

Attributs privés

$container

Description détaillée

Controller resolver which supports creating controllers from a PSR-11 compatible container

Controllers must be registered in the container using their FQCN as a service key

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ContainerInterface $container )

Constructor

Paramètres
ContainerInterface $container The container to search for controllers in
Depuis
2.0.0

Références ContainerControllerResolver\$container.

Documentation des fonctions membres

◆ instantiateController()

instantiateController ( string $class )
protected

Instantiate a controller class

Paramètres
string $class The class to instantiate
Renvoie
object Controller class instance
Depuis
2.0.0

Références $class.

Documentation des champs

◆ $container

$container
private

Référencé par ContainerControllerResolver\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerControllerResolver.php


Joomla CMS: Référence de la classe ControllerResolver

  • Joomla
  • Application
  • Controller
  • ControllerResolver
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ControllerResolver
+ Graphe d'héritage de ControllerResolver:
ControllerResolverInterface ContainerControllerResolver

Fonctions membres publiques

resolve (ResolvedRoute $route)

Fonctions membres protégées

instantiateController (string $class)

Description détaillée

Resolves a controller for the given route.

Depuis
2.0.0

Documentation des fonctions membres

◆ instantiateController()

instantiateController ( string $class )
protected

Instantiate a controller class

Paramètres
string $class The class to instantiate
Renvoie
object Controller class instance
Depuis
2.0.0

Références $class.

Référencé par ControllerResolver\resolve().

◆ resolve()

resolve ( ResolvedRoute $route )

Resolve the controller for a route

Paramètres
ResolvedRoute $route The route to resolve the controller for
Renvoie
callable
Depuis
2.0.0
Exceptions

Implémente ControllerResolverInterface.

Références $route, class, et ControllerResolver\instantiateController().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ControllerResolver.php


Joomla CMS: Référence de l'interface ControllerResolverInterface

  • Joomla
  • Application
  • Controller
  • ControllerResolverInterface
Fonctions membres publiques
Référence de l'interface ControllerResolverInterface
+ Graphe d'héritage de ControllerResolverInterface:
ControllerResolver ContainerControllerResolver

Fonctions membres publiques

resolve (ResolvedRoute $route)

Description détaillée

Interface defining a controller resolver.

Depuis
2.0.0

Documentation des fonctions membres

◆ resolve()

resolve ( ResolvedRoute $route )

Resolve the controller for a route

Paramètres
ResolvedRoute $route The route to resolve the controller for
Renvoie
callable
Depuis
2.0.0
Exceptions

Implémenté dans ControllerResolver.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ControllerResolverInterface.php


Joomla CMS: Référence de la classe ApplicationErrorEvent

  • Joomla
  • Application
  • Event
  • ApplicationErrorEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ApplicationErrorEvent
+ Graphe d'héritage de ApplicationErrorEvent:
ApplicationEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (\Throwable $error, AbstractApplication $application)
getError ()
setError (\Throwable $error)
- Fonctions membres publiques hérités de ApplicationEvent
__construct (string $name, AbstractApplication $application)
getApplication ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$error

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class thrown when an application error occurs.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Throwable | $error,
 |  | AbstractApplication | $application
 | ) |  |

Event constructor.

Paramètres
\Throwable | $error | The Throwable object with the error data.
AbstractApplication | $application | The active application.
Depuis
2.0.0

Références ApplicationEvent\$application, ApplicationErrorEvent\$error, Symfony\Contracts\Service\__construct(), et ApplicationEvents\ERROR.

Documentation des fonctions membres

◆ getError()

getError ( )

Get the error object.

Renvoie
Depuis
2.0.0

Références ApplicationErrorEvent\$error.

◆ setError()

setError ( \Throwable $error )

Set the error object.

Paramètres
\Throwable $error The error object to set to the event.
Renvoie
void
Depuis
2.0.0

Références ApplicationErrorEvent\$error.

Documentation des champs

◆ $error

$error
private

Référencé par ApplicationErrorEvent\__construct(), ApplicationErrorEvent\getError(), et ApplicationErrorEvent\setError().

La documentation de cette classe a été générée à partir du fichier suivant :
  • application/src/Event/ApplicationErrorEvent.php


Joomla CMS: Référence de la classe ApplicationEvent

  • Joomla
  • Application
  • Event
  • ApplicationEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ApplicationEvent
+ Graphe d'héritage de ApplicationEvent:
Event AbstractEvent EventInterface ApplicationErrorEvent

Fonctions membres publiques

__construct (string $name, AbstractApplication $application)
getApplication ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$application

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Base event class for application events.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | AbstractApplication | $application
 | ) |  |

Event constructor.

Paramètres
string | $name | The event name.
AbstractApplication | $application | The active application.
Depuis
2.0.0

Références ApplicationEvent\$application, AbstractEvent\$name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getApplication()

getApplication ( )

Get the active application.

Renvoie
AbstractApplication
Depuis
2.0.0

Références ApplicationEvent\$application.

Documentation des champs

◆ $application

$application
private

Référencé par ApplicationEvent\__construct(), ApplicationErrorEvent\__construct(), et ApplicationEvent\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApplicationEvent.php


Joomla CMS: Référence de la classe UnableToWriteBody

  • Joomla
  • Application
  • Exception
  • UnableToWriteBody
Référence de la classe UnableToWriteBody
+ Graphe d'héritage de UnableToWriteBody:

Description détaillée

Exception thrown when the application can't write to the response body

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnableToWriteBody.php


Joomla CMS: Référence de la classe WebClient

  • Joomla
  • Application
  • Web
  • WebClient
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe WebClient

Fonctions membres publiques

__construct ($userAgent=null, $acceptEncoding=null, $acceptLanguage=null)
__get ($name)

Champs de données

const | WINDOWS = 1
const | WINDOWS_PHONE = 2
const | WINDOWS_CE = 3
const | IPHONE = 4
const | IPAD = 5
const | IPOD = 6
const | MAC = 7
const | BLACKBERRY = 8
const | ANDROID = 9
const | LINUX = 10
const | TRIDENT = 11
const | WEBKIT = 12
const | GECKO = 13
const | PRESTO = 14
const | KHTML = 15
const | AMAYA = 16
const | IE = 17
const | FIREFOX = 18
const | CHROME = 19
const | SAFARI = 20
const | OPERA = 21
const | ANDROIDTABLET = 22
const | EDGE = 23
const | BLINK = 24
const | EDG = 25

Fonctions membres protégées

detectBrowser ($userAgent)
detectEncoding ($acceptEncoding)
detectEngine ($userAgent)
detectLanguage ($acceptLanguage)
detectPlatform ($userAgent)
detectRobot ($userAgent)
detectHeaders ()

Attributs protégés

$platform
$mobile = false
$engine
$browser
$browserVersion
$languages = []
$encodings = []
$userAgent
$acceptEncoding
$acceptLanguage
$robot = false
$detection = []
$headers

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $userAgent = null,
 |  | $acceptEncoding = null,
 |  | $acceptLanguage = null
 | ) |

Class constructor.

Paramètres
string | $userAgent | The optional user-agent string to parse.
string | $acceptEncoding | The optional client accept encoding string to parse.
string | $acceptLanguage | The optional client accept language string to parse.
Depuis
1.0

Références WebClient\$acceptEncoding, WebClient\$acceptLanguage, et WebClient\$userAgent.

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to get an object property's value by name.

Paramètres
string $name Name of the property for which to return a value.
Renvoie
mixed The requested value if it exists.
Depuis
1.0

Références $name, $this, WebClient\detectBrowser(), WebClient\detectEncoding(), WebClient\detectEngine(), WebClient\detectHeaders(), WebClient\detectLanguage(), WebClient\detectPlatform(), et WebClient\detectRobot().

◆ detectBrowser()

detectBrowser ( $userAgent )
protected

Detects the client browser and version in a user agent string.

Paramètres
string $userAgent The user-agent string to parse.
Renvoie
void
Depuis
1.0

Références $key, WebClient\$userAgent, et elseif.

Référencé par WebClient\__get().

◆ detectEncoding()

detectEncoding ( $acceptEncoding )
protected

Method to detect the accepted response encoding by the client.

Paramètres
string $acceptEncoding The client accept encoding string to parse.
Renvoie
void
Depuis
1.0

Références WebClient\$acceptEncoding.

Référencé par WebClient\__get().

◆ detectEngine()

detectEngine ( $userAgent )
protected

Detects the client rendering engine in a user agent string.

Paramètres
string $userAgent The user-agent string to parse.
Renvoie
void
Depuis
1.0

Références $result, WebClient\$userAgent, $version, et elseif.

Référencé par WebClient\__get().

◆ detectHeaders()

detectHeaders ( )
protected

Fills internal array of headers

Renvoie
void
Depuis
1.3.0

Références $name, et $value.

Référencé par WebClient\__get().

◆ detectLanguage()

detectLanguage ( $acceptLanguage )
protected

Method to detect the accepted languages by the client.

Paramètres
mixed $acceptLanguage The client accept language string to parse.
Renvoie
void
Depuis
1.0

Références WebClient\$acceptLanguage.

Référencé par WebClient\__get().

◆ detectPlatform()

detectPlatform ( $userAgent )
protected

Detects the client platform in a user agent string.

Paramètres
string $userAgent The user-agent string to parse.
Renvoie
void
Depuis
1.0

Références WebClient\$userAgent, et elseif.

Référencé par WebClient\__get().

◆ detectRobot()

detectRobot ( $userAgent )
protected

Determines if the browser is a robot or not.

Paramètres
string $userAgent The user-agent string to parse.
Renvoie
void
Depuis
1.0

Références WebClient\$userAgent.

Référencé par WebClient\__get().

Documentation des champs

◆ $acceptEncoding

$acceptEncoding
protected

Référencé par WebClient\__construct(), et WebClient\detectEncoding().

◆ $acceptLanguage

$acceptLanguage
protected

Référencé par WebClient\__construct(), et WebClient\detectLanguage().

◆ $browser

$browser
protected

◆ $browserVersion

$browserVersion
protected

◆ $detection

$detection = []
protected

◆ $encodings

$encodings = []
protected

◆ $engine

$engine
protected

◆ $headers

$headers
protected

◆ $languages

$languages = []
protected

◆ $mobile

$mobile = false
protected

◆ $platform

$platform
protected

◆ $robot

$robot = false
protected

◆ $userAgent

$userAgent
protected

Référencé par WebClient\__construct(), WebClient\detectBrowser(), WebClient\detectEngine(), WebClient\detectPlatform(), et WebClient\detectRobot().

◆ AMAYA

const AMAYA = 16

◆ ANDROID

const ANDROID = 9

◆ ANDROIDTABLET

const ANDROIDTABLET = 22

◆ BLACKBERRY

const BLACKBERRY = 8

◆ BLINK

const BLINK = 24

◆ CHROME

const CHROME = 19

◆ EDG

const EDG = 25

◆ EDGE

const EDGE = 23

◆ FIREFOX

const FIREFOX = 18

◆ GECKO

const GECKO = 13

◆ IE

const IE = 17

◆ IPAD

const IPAD = 5

◆ IPHONE

const IPHONE = 4

◆ IPOD

const IPOD = 6

◆ KHTML

const KHTML = 15

◆ LINUX

const LINUX = 10

◆ MAC

const MAC = 7

◆ OPERA

const OPERA = 21

◆ PRESTO

const PRESTO = 14

◆ SAFARI

const SAFARI = 20

◆ TRIDENT

const TRIDENT = 11

◆ WEBKIT

const WEBKIT = 12

◆ WINDOWS

const WINDOWS = 1

◆ WINDOWS_CE

const WINDOWS_CE = 3

◆ WINDOWS_PHONE

const WINDOWS_PHONE = 2
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebClient.php


Joomla CMS: Référence de la classe AbstractApplication

  • Joomla
  • Application
  • AbstractApplication
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractApplication
+ Graphe d'héritage de AbstractApplication:
ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface AbstractWebApplication BaseApplication CliApplication Application WebApplication WebApplication DaemonApplication ConsoleApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$config

Description détaillée

Joomla Framework Base Application Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Registry $config = null )

Class constructor.

Paramètres
Registry $config An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
Depuis
1.0

Références AbstractApplication\$config, et AbstractApplication\initialise().

Documentation des fonctions membres

◆ close()

close ( $code = 0 )

Method to close the application.

Paramètres
integer $code The exit code (optional; default is 0).
Renvoie
void
Depuis
1.0

Implémente ApplicationInterface.

Référencé par Application\__construct(), Application\execute(), et AbstractWebApplication\redirect().

◆ dispatchEvent()

dispatchEvent | ( | string | $eventName,
 |  | ?EventInterface | $event = null
 | ) |  |
protected

Dispatches an application event if the dispatcher has been set.

Paramètres
string | $eventName | The event to dispatch.
EventInterface | null | $event | The event object.
Renvoie
EventInterface|null The dispatched event or null if no dispatcher is set
Depuis
2.0.0

Références $this, Joomla\CMS\Application\getDispatcher(), et null.

Référencé par Application\doExecute(), AbstractApplication\execute(), AbstractWebApplication\execute(), Application\execute(), AbstractWebApplication\redirect(), et Application\runCommand().

◆ doExecute()

doExecute ( )
abstractprotected

Method to run the application routines.

Most likely you will want to instantiate a controller and execute it, or perform some sort of task directly.

Renvoie
mixed
Depuis
1.0

Référencé par AbstractApplication\execute(), et AbstractWebApplication\execute().

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
1.0

Implémente ApplicationInterface.

Références $this, ApplicationEvents\AFTER_EXECUTE, ApplicationEvents\BEFORE_EXECUTE, AbstractApplication\dispatchEvent(), AbstractApplication\doExecute(), et ApplicationEvents\ERROR.

◆ get()

get | ( | $key,
 |  | $default = null
 | ) |

Returns a property of the object or the default value if the property is not set.

Paramètres
string | $key | The name of the property.
mixed | $default | The default value (optional) if none is set.
Renvoie
mixed The value of the configuration.
Depuis
1.0

Implémente ConfigurationAwareApplicationInterface.

Références $default, et $key.

Référencé par MetadataManager\createSessionRecord(), et MetadataManager\updateSessionRecord().

◆ getLogger()

getLogger ( )

Get the logger.

Renvoie
LoggerInterface
Depuis
1.0

Références LoggerAwareInterface\setLogger().

◆ initialise()

initialise ( )
protected

Custom initialisation method.

Called at the end of the AbstractApplication::__construct method. This is for developers to inject initialisation code for their application classes.

Renvoie
void
Depuis
1.0

Référencé par AbstractApplication\__construct().

◆ set()

set | ( | $key,
 |  | $value = null
 | ) |

Modifies a property of the object, creating it if it does not already exist.

Paramètres
string | $key | The name of the property.
mixed | $value | The value of the property to set (optional).
Renvoie
mixed Previous value of the property
Depuis
1.0

Implémente ConfigurationAwareApplicationInterface.

Références $key, et $value.

◆ setConfiguration()

setConfiguration ( Registry $config )

Sets the configuration for the application.

Paramètres
Registry $config A registry object holding the configuration.
Renvoie
$this
Depuis
1.0

Implémente ConfigurationAwareApplicationInterface.

Références AbstractApplication\$config, et $this.

Documentation des champs

◆ $config

$config
protected

Référencé par AbstractApplication\__construct(), WebApplication\__construct(), AbstractWebApplication\__construct(), Application\__construct(), et AbstractApplication\setConfiguration().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractApplication.php


Joomla CMS: Référence de la classe AbstractWebApplication

  • Joomla
  • Application
  • AbstractWebApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe AbstractWebApplication
+ Graphe d'héritage de AbstractWebApplication:
AbstractApplication WebApplicationInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface WebApplication WebApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static isAscii ($str)

Champs de données

$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client

Fonctions membres protégées

compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Attributs privés

$cacheable = false
$responseMap

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | Web\WebClient | $client = null,
 |  | ResponseInterface | $response = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is an Input object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
Web\WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a Web object that object will become the application's client object, otherwise a default client object is created.
ResponseInterface | $response | An optional argument to provide dependency injection for the application's response object. If the argument is a ResponseInterface object that object will become the application's response object, otherwise a default response object is created.
Depuis
1.0

Références AbstractWebApplication\$client, AbstractApplication\$config, AbstractWebApplication\$input, AbstractWebApplication\$response, Symfony\Contracts\Service\__construct(), AbstractWebApplication\loadSystemUris(), et AbstractWebApplication\setResponse().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to access properties of the application.

Paramètres
string $name The name of the property.
Renvoie
mixed A value if the property name is valid, null otherwise.
Depuis
2.0.0
Obsolète:
3.0 This is a B/C proxy for deprecated read accesses

Références $name, class, et AbstractWebApplication\getInput().

◆ allowCache()

allowCache ( $allow = null )

Set/get cachable state for the response.

If $allow is set, sets the cachable state of the response. Always returns the current state.

Paramètres
boolean $allow True to allow browser caching.
Renvoie
boolean
Depuis
1.0

Implémente WebApplicationInterface.

Références AbstractWebApplication\$cacheable, et null.

Référencé par AbstractWebApplication\respond().

◆ appendBody()

appendBody ( $content )

Append content to the body content

Paramètres
string $content The content to append to the response body.
Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $content, Laminas\Diactoros\$stream, $this, elseif, AbstractWebApplication\getResponse(), AbstractWebApplication\setResponse(), et Laminas\Diactoros\withBody().

◆ checkConnectionAlive()

checkConnectionAlive ( )
protected

Method to check the current client connection status to ensure that it is alive. We are wrapping this to isolate the connection_status() function from our code base for testing reasons.

Renvoie
boolean True if the connection is valid and normal.
Voir également
connection_status()
Depuis
1.0

Référencé par AbstractWebApplication\compress().

◆ checkHeadersSent()

checkHeadersSent ( )
protected

Method to check to see if headers have already been sent.

Renvoie
boolean True if the headers have already been sent.
Voir également
headers_sent()
Depuis
1.0

Référencé par AbstractWebApplication\compress(), AbstractWebApplication\redirect(), et AbstractWebApplication\sendHeaders().

◆ clearHeaders()

clearHeaders ( )

Method to clear any set response headers.

Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $name, AbstractWebApplication\$response, $this, AbstractWebApplication\getResponse(), et AbstractWebApplication\setResponse().

◆ compress()

compress ( )
protected

Checks the accept encoding of the browser and compresses the data before sending it to the client if possible.

Renvoie
void
Depuis
1.0

Références $data, AbstractWebApplication\checkConnectionAlive(), AbstractWebApplication\checkHeadersSent(), AbstractWebApplication\getBody(), AbstractWebApplication\setBody(), et AbstractWebApplication\setHeader().

Référencé par AbstractWebApplication\execute().

◆ detectRequestUri()

detectRequestUri ( )
protected

Method to detect the requested URI from server environment variables.

Renvoie
string The requested URI
Depuis
1.0

Références $uri, et AbstractWebApplication\isSslConnection().

Référencé par AbstractWebApplication\loadSystemUris().

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
1.0

Implémente ApplicationInterface.

Références $this, ApplicationEvents\AFTER_EXECUTE, ApplicationEvents\AFTER_RESPOND, ApplicationEvents\BEFORE_EXECUTE, ApplicationEvents\BEFORE_RESPOND, AbstractWebApplication\compress(), AbstractApplication\dispatchEvent(), AbstractApplication\doExecute(), ApplicationEvents\ERROR, et AbstractWebApplication\respond().

◆ getBody()

getBody ( )

Return the body content

Renvoie
string The response body as a string.
Depuis
1.0

Implémente WebApplicationInterface.

Références AbstractWebApplication\getResponse().

Référencé par AbstractWebApplication\compress(), et AbstractWebApplication\respond().

◆ getHeaders()

getHeaders ( )

Method to get the array of response headers to be sent when the response is sent to the client.

Renvoie
array
Depuis
1.0

Implémente WebApplicationInterface.

Références $name, $return, $value, et AbstractWebApplication\getResponse().

Référencé par AbstractWebApplication\sendHeaders().

◆ getHttpStatusValue()

getHttpStatusValue ( $value )
protected

Check if a given value can be successfully mapped to a valid http status value

Paramètres
string | int $value The given status as int or string
Renvoie
string
Depuis
1.8.0

Références $value.

Référencé par AbstractWebApplication\sendHeaders().

◆ getInput()

getInput ( )

Method to get the application input object.

Renvoie
Input
Depuis
2.0.0

Implémente WebApplicationInterface.

Références AbstractWebApplication\$input.

Référencé par AbstractWebApplication\__get().

◆ getResponse()

getResponse ( )

Get the PSR-7 Response Object.

Renvoie
ResponseInterface
Depuis
2.0.0

Implémente WebApplicationInterface.

Références AbstractWebApplication\$response.

Référencé par AbstractWebApplication\appendBody(), AbstractWebApplication\clearHeaders(), AbstractWebApplication\getBody(), AbstractWebApplication\getHeaders(), AbstractWebApplication\prependBody(), AbstractWebApplication\respond(), AbstractWebApplication\setBody(), et AbstractWebApplication\setHeader().

◆ header()

header | ( | $string,
 |  | $replace = true,
 |  | $code = null
 | ) |
protected

Method to send a header to the client.

Paramètres
string | $string | The header string.
boolean | $replace | The optional replace parameter indicates whether the header should replace a previous similar header, or add a second header of the same type.
integer | $code | Forces the HTTP response code to the specified value. Note that this parameter only has an effect if the string is not empty.
Renvoie
void
Voir également
header()
Depuis
1.0

Références null.

Référencé par AbstractWebApplication\sendHeaders().

◆ isAscii()

static isAscii ( $str )
static

Tests whether a string contains only 7bit ASCII bytes.

You might use this to conditionally check whether a string needs handling as UTF-8 or not, potentially offering performance benefits by using the native PHP equivalent if it's just ASCII e.g.;

Paramètres
string $str The string to test.
Renvoie
boolean True if the string is all ASCII
Depuis
1.4.0

◆ isRedirectState()

isRedirectState ( $state )
protected

Checks if a state is a redirect state

Paramètres
integer $state The HTTP status code.
Renvoie
boolean
Depuis
1.8.0

Références $state.

Référencé par AbstractWebApplication\redirect().

◆ isSslConnection()

isSslConnection ( )

Determine if we are using a secure (SSL) connection.

Renvoie
boolean True if using SSL, false if not.
Depuis
1.0

Implémente WebApplicationInterface.

Référencé par AbstractWebApplication\detectRequestUri().

◆ isValidHttpStatus()

isValidHttpStatus ( $code )

Check if the value is a valid HTTP status code

Paramètres
integer $code The potential status code
Renvoie
boolean
Depuis
1.8.1

Implémente WebApplicationInterface.

◆ loadSystemUris()

loadSystemUris ( $requestUri = null )
protected

Method to load the system URI strings for the application.

Paramètres
string $requestUri An optional request URI to use instead of detecting one from the server environment variables.
Renvoie
void
Depuis
1.0

Références $path, $uri, et AbstractWebApplication\detectRequestUri().

Référencé par AbstractWebApplication\__construct().

◆ prependBody()

prependBody ( $content )

Prepend content to the body content

Paramètres
string $content The content to prepend to the response body.
Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $content, Laminas\Diactoros\$stream, $this, AbstractWebApplication\getResponse(), AbstractWebApplication\setResponse(), et Laminas\Diactoros\withBody().

◆ redirect()

redirect | ( | $url,
 |  | $status = 303
 | ) |

Redirect to another URL.

If the headers have not been sent the redirect will be accomplished using a "301 Moved Permanently" or "303 See Other" code in the header pointing to the new location. If the headers have already been sent this will be accomplished using a JavaScript statement.

Paramètres
string | $url | The URL to redirect to. Can only be http/https URL
integer | boolean | $status | The HTTP status code to be provided. 303 is assumed by default.
Renvoie
void
Depuis
1.0
Exceptions

Implémente WebApplicationInterface.

Références $html, $parts, $path, $prefix, $uri, $url, ApplicationEvents\AFTER_RESPOND, ApplicationEvents\BEFORE_RESPOND, AbstractWebApplication\checkHeadersSent(), AbstractApplication\close(), AbstractApplication\dispatchEvent(), elseif, AbstractWebApplication\isRedirectState(), AbstractWebApplication\respond(), et AbstractWebApplication\setHeader().

◆ respond()

respond ( )
protected

Method to send the application response to the client. All headers will be sent prior to the main application output data.

Renvoie
void
Depuis
1.0

Références AbstractWebApplication\allowCache(), AbstractWebApplication\getBody(), AbstractWebApplication\getResponse(), Symfony\Component\Console\Tester\getStatusCode(), Laminas\Diactoros\hasHeader(), AbstractWebApplication\sendHeaders(), et AbstractWebApplication\setHeader().

Référencé par AbstractWebApplication\execute(), et AbstractWebApplication\redirect().

◆ sendHeaders()

sendHeaders ( )

Send the response headers.

Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $header, $this, AbstractWebApplication\checkHeadersSent(), AbstractWebApplication\getHeaders(), AbstractWebApplication\getHttpStatusValue(), et AbstractWebApplication\header().

Référencé par AbstractWebApplication\respond().

◆ setBody()

setBody ( $content )

Set body content. If body content already defined, this will replace it.

Paramètres
string $content The content to set as the response body.
Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $content, Laminas\Diactoros\$stream, $this, AbstractWebApplication\getResponse(), AbstractWebApplication\setResponse(), et Laminas\Diactoros\withBody().

Référencé par AbstractWebApplication\compress().

◆ setHeader()

setHeader | ( | $name,
 |  | $value,
 |  | $replace = false
 | ) |

Method to set a response header.

If the replace flag is set then all headers with the given name will be replaced by the new one. The headers are stored in an internal array to be sent when the site is sent to the browser.

Paramètres
string | $name | The name of the header to set.
string | $value | The value of the header to set.
boolean | $replace | True to replace any headers with the same name.
Renvoie
$this
Depuis
1.0

Implémente WebApplicationInterface.

Références $name, AbstractWebApplication\$response, $this, $value, AbstractWebApplication\getResponse(), et AbstractWebApplication\setResponse().

Référencé par AbstractWebApplication\compress(), AbstractWebApplication\redirect(), et AbstractWebApplication\respond().

◆ setResponse()

setResponse ( ResponseInterface $response )

Set the PSR-7 Response Object.

Paramètres
ResponseInterface $response The response object
Renvoie
void
Depuis
2.0.0

Implémente WebApplicationInterface.

Références AbstractWebApplication\$response.

Référencé par AbstractWebApplication\__construct(), AbstractWebApplication\appendBody(), AbstractWebApplication\clearHeaders(), AbstractWebApplication\prependBody(), AbstractWebApplication\setBody(), et AbstractWebApplication\setHeader().

Documentation des champs

◆ $cacheable

$cacheable = false
private

Référencé par AbstractWebApplication\allowCache().

◆ $charSet

$charSet = 'utf-8'

◆ $client

$client

Référencé par WebApplication\__construct(), et AbstractWebApplication\__construct().

◆ $httpVersion

$httpVersion = '1.1'

◆ $input

$input
protected

Référencé par WebApplication\__construct(), AbstractWebApplication\__construct(), et AbstractWebApplication\getInput().

◆ $mimeType

$mimeType = 'text/html'

◆ $modifiedDate

$modifiedDate

◆ $response

$response
protected

Référencé par WebApplication\__construct(), AbstractWebApplication\__construct(), AbstractWebApplication\clearHeaders(), AbstractWebApplication\getResponse(), AbstractWebApplication\setHeader(), et AbstractWebApplication\setResponse().

◆ $responseMap

$responseMap
private
Valeur initiale :
= [
100 => 'HTTP/{version} 100 Continue'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractWebApplication.php


Joomla CMS: Référence de la classe ApplicationEvents

  • Joomla
  • Application
  • ApplicationEvents
Champs de données
Référence de la classe ApplicationEvents

Champs de données

const | ERROR = 'application.error'
const | BEFORE_EXECUTE = 'application.before_execute'
const | AFTER_EXECUTE = 'application.after_execute'
const | BEFORE_RESPOND = 'application.before_respond'
const | AFTER_RESPOND = 'application.after_respond'

Description détaillée

Class defining the events available in the application.

Depuis
2.0.0

Documentation des champs

◆ AFTER_EXECUTE

const AFTER_EXECUTE = 'application.after_execute'

Référencé par AbstractApplication\execute(), AbstractWebApplication\execute(), et Application\execute().

◆ AFTER_RESPOND

const AFTER_RESPOND = 'application.after_respond'

Référencé par AbstractWebApplication\execute(), et AbstractWebApplication\redirect().

◆ BEFORE_EXECUTE

const BEFORE_EXECUTE = 'application.before_execute'

Référencé par AbstractApplication\execute(), AbstractWebApplication\execute(), et Application\execute().

◆ BEFORE_RESPOND

const BEFORE_RESPOND = 'application.before_respond'

Référencé par AbstractWebApplication\execute(), et AbstractWebApplication\redirect().

◆ ERROR

const ERROR = 'application.error'

Référencé par ApplicationErrorEvent\__construct(), AbstractApplication\execute(), et AbstractWebApplication\execute().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApplicationEvents.php


Joomla CMS: Référence de l'interface ApplicationInterface

  • Joomla
  • Application
  • ApplicationInterface
Fonctions membres publiques
Référence de l'interface ApplicationInterface
+ Graphe d'héritage de ApplicationInterface:
ConfigurationAwareApplicationInterface WebApplicationInterface AbstractApplication CMSApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface AbstractWebApplication BaseApplication CliApplication Application CliApplication CMSWebApplicationInterface ConsoleApplication WebApplication WebApplication WebApplication CMSWebApplicationInterface

Fonctions membres publiques

close ($code=0)
execute ()

Description détaillée

Joomla Framework Application Interface

Depuis
2.0.0

Documentation des fonctions membres

◆ close()

close ( $code = 0 )

Method to close the application.

Paramètres
integer $code The exit code (optional; default is 0).
Renvoie
void
Depuis
2.0.0

Implémenté dans AbstractApplication.

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
2.0.0

Implémenté dans Application, DaemonApplication, AbstractWebApplication, CliApplication, InstallationApplication, ConsoleApplication, WebApplication, et AbstractApplication.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ApplicationInterface.php


Joomla CMS: Référence de l'interface ConfigurationAwareApplicationInterface

  • Joomla
  • Application
  • ConfigurationAwareApplicationInterface
Fonctions membres publiques
Référence de l'interface ConfigurationAwareApplicationInterface
+ Graphe d'héritage de ConfigurationAwareApplicationInterface:
ApplicationInterface AbstractApplication CMSApplicationInterface AbstractWebApplication BaseApplication CliApplication Application CliApplication CMSWebApplicationInterface ConsoleApplication WebApplication WebApplication DaemonApplication ConsoleApplication DaemonApplication CMSApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

get ($key, $default=null)
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de ApplicationInterface
close ($code=0)
execute ()

Description détaillée

Application sub-interface defining an application class which is aware of its configuration

Depuis
2.0.0

Documentation des fonctions membres

◆ get()

get | ( | $key,
 |  | $default = null
 | ) |

Returns a property of the object or the default value if the property is not set.

Paramètres
string | $key | The name of the property.
mixed | $default | The default value (optional) if none is set.
Renvoie
mixed The value of the configuration.
Depuis
2.0.0

Implémenté dans AbstractApplication.

◆ set()

set | ( | $key,
 |  | $value = null
 | ) |

Modifies a property of the object, creating it if it does not already exist.

Paramètres
string | $key | The name of the property.
mixed | $value | The value of the property to set (optional).
Renvoie
mixed Previous value of the property
Depuis
2.0.0

Implémenté dans AbstractApplication.

◆ setConfiguration()

setConfiguration ( Registry $config )

Sets the configuration for the application.

Paramètres
Registry $config A registry object holding the configuration.
Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractApplication.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ConfigurationAwareApplicationInterface.php


Joomla CMS: Référence de l'interface SessionAwareWebApplicationInterface

  • Joomla
  • Application
  • SessionAwareWebApplicationInterface
Fonctions membres publiques
Référence de l'interface SessionAwareWebApplicationInterface
+ Graphe d'héritage de SessionAwareWebApplicationInterface:
WebApplicationInterface ApplicationInterface WebApplication CMSWebApplicationInterface CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de WebApplicationInterface
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de ApplicationInterface
close ($code=0)
execute ()

Description détaillée

Application sub-interface defining a web application class which supports sessions

Depuis
2.0.0

Documentation des fonctions membres

◆ checkToken()

checkToken ( $method = 'post' )

Checks for a form token in the request.

Paramètres
string $method The request method in which to look for the token key.
Renvoie
boolean
Depuis
2.0.0

◆ getFormToken()

getFormToken ( $forceNew = false )

Method to determine a hash for anti-spoofing variable names

Paramètres
boolean $forceNew If true, force a new token to be created
Renvoie
string Hashed var name
Depuis
2.0.0

◆ getSession()

getSession ( )

Method to get the application session object.

Renvoie
SessionInterface The session object
Depuis
2.0.0

◆ setSession()

setSession ( SessionInterface $session )

Sets the session for the application to use, if required.

Paramètres
SessionInterface $session A session object.
Renvoie
$this
Depuis
2.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • SessionAwareWebApplicationInterface.php


Joomla CMS: Référence de la classe WebApplication

  • Joomla
  • Application
  • WebApplication
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WebApplication
+ Graphe d'héritage de WebApplication:
AbstractWebApplication SessionAwareWebApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface

Fonctions membres publiques

__construct (ControllerResolverInterface $controllerResolver, RouterInterface $router, Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)

Fonctions membres protégées

doExecute ()
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$controllerResolver
$router
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractWebApplication
static isAscii ($str)
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client

Description détaillée

A basic web application class for handing HTTP requests.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ControllerResolverInterface | $controllerResolver,
 |  | RouterInterface | $router,
 |  | Input | $input = null,
 |  | Registry | $config = null,
 |  | Web\WebClient | $client = null,
 |  | ResponseInterface | $response = null
 | ) |  |

Class constructor.

Paramètres
ControllerResolverInterface | $controllerResolver | The application's controller resolver
RouterInterface | $router | The application's router
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is an Input object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
Web\WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a Web object that object will become the application's client object, otherwise a default client object is created.
ResponseInterface | $response | An optional argument to provide dependency injection for the application's response object. If the argument is a ResponseInterface object that object will become the application's response object, otherwise a default response object is created.
Depuis
2.0.0

Références AbstractWebApplication\$client, AbstractApplication\$config, WebApplication\$controllerResolver, AbstractWebApplication\$input, AbstractWebApplication\$response, WebApplication\$router, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ doExecute()

doExecute ( )
protected

Method to run the application routines.

Renvoie
void
Depuis
2.0.0

Références $key, $route, et $value.

Documentation des champs

◆ $controllerResolver

$controllerResolver
protected

Référencé par WebApplication\__construct().

◆ $router

$router
protected

Référencé par WebApplication\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/application/src/WebApplication.php


Joomla CMS: Référence de l'interface WebApplicationInterface

  • Joomla
  • Application
  • WebApplicationInterface
Fonctions membres publiques
Référence de l'interface WebApplicationInterface
+ Graphe d'héritage de WebApplicationInterface:
ApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface WebApplication WebApplication WebApplication CMSWebApplicationInterface CMSApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de ApplicationInterface
close ($code=0)
execute ()

Description détaillée

Application sub-interface defining a web application class

Depuis
2.0.0

Documentation des fonctions membres

◆ allowCache()

allowCache ( $allow = null )

Set/get cachable state for the response.

If $allow is set, sets the cachable state of the response. Always returns the current state.

Paramètres
boolean $allow True to allow browser caching.
Renvoie
boolean
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ appendBody()

appendBody ( $content )

Append content to the body content

Paramètres
string $content The content to append to the response body.
Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ clearHeaders()

clearHeaders ( )

Method to clear any set response headers.

Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ getBody()

getBody ( )

Return the body content

Renvoie
mixed The response body as a string.
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ getHeaders()

getHeaders ( )

Method to get the array of response headers to be sent when the response is sent to the client.

Renvoie
array
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ getInput()

getInput ( )

Method to get the application input object.

Renvoie
Input
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ getResponse()

getResponse ( )

Get the PSR-7 Response Object.

Renvoie
ResponseInterface
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ isSslConnection()

isSslConnection ( )

Determine if we are using a secure (SSL) connection.

Renvoie
boolean True if using SSL, false if not.
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ isValidHttpStatus()

isValidHttpStatus ( $code )

Check if the value is a valid HTTP status code

Paramètres
integer $code The potential status code
Renvoie
boolean
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ prependBody()

prependBody ( $content )

Prepend content to the body content

Paramètres
string $content The content to prepend to the response body.
Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ redirect()

redirect | ( | $url,
 |  | $status = 303
 | ) |

Redirect to another URL.

If the headers have not been sent the redirect will be accomplished using a "301 Moved Permanently" or "303 See Other" code in the header pointing to the new location. If the headers have already been sent this will be accomplished using a JavaScript statement.

Paramètres
string | $url | The URL to redirect to. Can only be http/https URL
integer | boolean | $status | The HTTP status code to be provided. 303 is assumed by default.
Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans CMSApplication, et AbstractWebApplication.

◆ sendHeaders()

sendHeaders ( )

Send the response headers.

Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ setBody()

setBody ( $content )

Set body content. If body content already defined, this will replace it.

Paramètres
string $content The content to set as the response body.
Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ setHeader()

setHeader | ( | $name,
 |  | $value,
 |  | $replace = false
 | ) |

Method to set a response header.

If the replace flag is set then all headers with the given name will be replaced by the new one. The headers are stored in an internal array to be sent when the site is sent to the browser.

Paramètres
string | $name | The name of the header to set.
string | $value | The value of the header to set.
boolean | $replace | True to replace any headers with the same name.
Renvoie
$this
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

◆ setResponse()

setResponse ( ResponseInterface $response )

Set the PSR-7 Response Object.

Paramètres
ResponseInterface $response The response object
Renvoie
void
Depuis
2.0.0

Implémenté dans AbstractWebApplication.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WebApplicationInterface.php


Joomla CMS: Référence de la classe UnknownArchiveException

  • Joomla
  • Archive
  • Exception
  • UnknownArchiveException
Référence de la classe UnknownArchiveException
+ Graphe d'héritage de UnknownArchiveException:

Description détaillée

Exception class defining an unknown archive type

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnknownArchiveException.php


Joomla CMS: Référence de la classe UnsupportedArchiveException

  • Joomla
  • Archive
  • Exception
  • UnsupportedArchiveException
Fonctions membres publiques | Attributs protégés
Référence de la classe UnsupportedArchiveException
+ Graphe d'héritage de UnsupportedArchiveException:

Fonctions membres publiques

__construct (string $adapterType, string $message='', int $code=0, ?\Throwable $previous=null)
getUnsupportedAdapterType ()

Attributs protégés

$adapterType = ''

Description détaillée

Exception class defining an unsupported archive adapter

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $adapterType,
 |  | string | $message = '',
 |  | int | $code = 0,
 |  | ?\Throwable | $previous = null
 | ) |  |

Constructor

Paramètres
string | $adapterType | The unsupported adapter type.
string | $message | The Exception message to throw.
int | $code | The Exception code.
\Throwable | ?,$previous | The previous throwable used for the exception chaining.
Depuis
2.0.0-beta2

Références UnsupportedArchiveException\$adapterType, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getUnsupportedAdapterType()

getUnsupportedAdapterType ( )

Gets the name of the adapter type that was unsupported

Renvoie
string
Depuis
2.0.0-beta2

Références UnsupportedArchiveException\$adapterType.

Documentation des champs

◆ $adapterType

$adapterType = ''
protected

Référencé par UnsupportedArchiveException\__construct(), et UnsupportedArchiveException\getUnsupportedAdapterType().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedArchiveException.php


Joomla CMS: Référence de la classe Archive

  • Joomla
  • Archive
  • Archive
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe Archive

Fonctions membres publiques

__construct ($options=[])
extract ($archivename, $extractdir)
setAdapter ($type, $class, $override=true)
getAdapter ($type)

Champs de données

$options = []

Attributs protégés

$adapters = []

Description détaillée

An Archive handling class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Create a new Archive object.

Paramètres
array | \ArrayAccess $options An array of options
Depuis
1.0
Exceptions

Références Archive\$options.

Documentation des fonctions membres

◆ extract()

extract | ( | $archivename,
 |  | $extractdir
 | ) |

Extract an archive file to a directory.

Paramètres
string | $archivename | The name of the archive file
string | $extractdir | Directory to unpack into
Renvoie
boolean True for success
Depuis
1.0
Exceptions
UnknownArchiveException if the archive type is not supported

Références $path, $result, File\copy(), Folder\create(), Archive\getAdapter(), et null.

◆ getAdapter()

getAdapter ( $type )

Get a file compression adapter.

Paramètres
string $type The type of adapter (bzip2|gzip|tar|zip).
Renvoie
ExtractableInterface Adapter for the requested type
Depuis
1.0

Références $type, et Archive\setAdapter().

Référencé par Archive\extract().

◆ setAdapter()

setAdapter | ( | $type,
 |  | $class,
 |  | $override = true
 | ) |

Method to override the provided adapter with your own implementation.

Paramètres
string | $type | Name of the adapter to set.
string | $class | FQCN of your class which implements ExtractableInterface.
boolean | $override | True to force override the adapter type.
Renvoie
$this
Depuis
1.0
Exceptions
UnsupportedArchiveException if the adapter type is not supported

Références $class, $this, $type, et class.

Référencé par Archive\getAdapter().

Documentation des champs

◆ $adapters

$adapters = []
protected

◆ $options

$options = []

Référencé par Archive\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Archive.php


Joomla CMS: Référence de la classe Bzip2

  • Joomla
  • Archive
  • Bzip2
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe Bzip2
+ Graphe d'héritage de Bzip2:
ExtractableInterface

Fonctions membres publiques

__construct ($options=[])
extract ($archive, $destination)

Fonctions membres publiques statiques

static isSupported ()

Attributs protégés

$options = []

Attributs privés

$data

Description détaillée

Bzip2 format adapter for the Archive package

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Create a new Archive object.

Paramètres
array | \ArrayAccess $options An array of options
Depuis
1.0
Exceptions

Références Bzip2\$options.

Documentation des fonctions membres

◆ extract()

extract | ( | $archive,
 |  | $destination
 | ) |

Extract a Bzip2 compressed file to a given path

Paramètres
string | $archive | Path to Bzip2 archive to extract
string | $destination | Path to extract archive to
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Implémente ExtractableInterface.

Références $buffer, $input, $output, $this, Stream\getStream(), null, et File\write().

◆ isSupported()

static isSupported ( )
static

Tests whether this adapter can unpack files on this computer.

Renvoie
boolean True if supported
Depuis
1.0

Implémente ExtractableInterface.

Documentation des champs

◆ $data

$data
private

◆ $options

$options = []
protected

Référencé par Bzip2\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Bzip2.php


Joomla CMS: Référence de l'interface ExtractableInterface

  • Joomla
  • Archive
  • ExtractableInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface ExtractableInterface
+ Graphe d'héritage de ExtractableInterface:
Bzip2 Gzip Tar Zip

Fonctions membres publiques

extract ($archive, $destination)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Archive class interface

Depuis
1.0

Documentation des fonctions membres

◆ extract()

extract | ( | $archive,
 |  | $destination
 | ) |

Extract a compressed file to a given path

Paramètres
string | $archive | Path to archive to extract
string | $destination | Path to extract archive to
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Implémenté dans Zip, Tar, Gzip, et Bzip2.

◆ isSupported()

static isSupported ( )
static

Tests whether this adapter can unpack files on this computer.

Renvoie
boolean True if supported
Depuis
1.0

Implémenté dans Zip, Gzip, Tar, et Bzip2.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ExtractableInterface.php


Joomla CMS: Référence de la classe Gzip

  • Joomla
  • Archive
  • Gzip
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe Gzip
+ Graphe d'héritage de Gzip:
ExtractableInterface

Fonctions membres publiques

__construct ($options=[])
extract ($archive, $destination)
getFilePosition ()

Fonctions membres publiques statiques

static isSupported ()

Attributs protégés

$options = []

Attributs privés

const FLAGS = ['FTEXT' => 0x01
$data

Description détaillée

Gzip format adapter for the Archive package

This class is inspired from and draws heavily in code and concept from the Compress package of The Horde Project http://www.horde.org

Michael Slusarz slusa.nosp@m.rz@h.nosp@m.orde..nosp@m.org Michael Cochrane mike@.nosp@m.graf.nosp@m.tonha.nosp@m.ll.c.nosp@m.o.nz

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Create a new Archive object.

Paramètres
array | \ArrayAccess $options An array of options
Depuis
1.0
Exceptions

Références Gzip\$options.

Documentation des fonctions membres

◆ extract()

extract | ( | $archive,
 |  | $destination
 | ) |

Extract a Gzip compressed file to a given path

Paramètres
string | $archive | Path to ZIP archive to extract
string | $destination | Path to extract archive to
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Implémente ExtractableInterface.

Références $buffer, $input, $output, $position, $this, Gzip\getFilePosition(), Stream\getStream(), null, et File\write().

◆ getFilePosition()

getFilePosition ( )

Get file data offset for archive

Renvoie
integer Data position marker for archive
Depuis
1.0
Exceptions

Références $info, et $position.

Référencé par Gzip\extract().

◆ isSupported()

static isSupported ( )
static

Tests whether this adapter can unpack files on this computer.

Renvoie
boolean True if supported
Depuis
1.0

Implémente ExtractableInterface.

Documentation des champs

◆ $data

$data
private

◆ $options

$options = []
protected

Référencé par Gzip\__construct().

◆ FLAGS

const FLAGS = ['FTEXT' => 0x01
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Gzip.php


Joomla CMS: Référence de la classe Tar

  • Joomla
  • Archive
  • Tar
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Tar
+ Graphe d'héritage de Tar:
ExtractableInterface

Fonctions membres publiques

__construct ($options=[])
extract ($archive, $destination)

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getTarInfo (&$data)

Attributs protégés

$options = []

Fonctions membres privées

isBelow ($destination, $path)

Attributs privés

const TYPES
$data
$metadata

Description détaillée

Tar format adapter for the Archive package

This class is inspired from and draws heavily in code and concept from the Compress package of The Horde Project http://www.horde.org

Michael Slusarz slusa.nosp@m.rz@h.nosp@m.orde..nosp@m.org Michael Cochrane mike@.nosp@m.graf.nosp@m.tonha.nosp@m.ll.c.nosp@m.o.nz

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Create a new Archive object.

Paramètres
array | \ArrayAccess $options An array of options or an object that implements
Depuis
1.0
Exceptions

Références Tar\$options.

Documentation des fonctions membres

◆ extract()

extract | ( | $archive,
 |  | $destination
 | ) |

Extract a ZIP compressed file to a given path

Paramètres
string | $archive | Path to ZIP archive to extract
string | $destination | Path to extract archive into
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Implémente ExtractableInterface.

Références $buffer, $i, $n, $path, $type, Path\clean(), Folder\create(), Tar\getTarInfo(), Tar\isBelow(), null, et File\write().

◆ getTarInfo()

getTarInfo ( & $data )
protected

Get the list of files/data from a Tar archive buffer and builds a metadata array.

Array structure:

KEY: Position in the array
VALUES: 'attr'  --  File attributes
'data'  --  Raw file contents
'date'  --  File modification time
'name'  --  Filename
'size'  --  Original file size
'type'  --  File type
Paramètres
string $data The Tar archive buffer.
Renvoie
void
Depuis
1.0
Exceptions

Références Tar\$data, $info, $mode, $position, elseif, et null.

Référencé par Tar\extract().

◆ isBelow()

isBelow | ( | $destination,
 |  | $path
 | ) |
private

Check if a path is below a given destination path

Paramètres
string | $destination | The destination path
string | $path | The path to be checked
Renvoie
boolean
Depuis
2.0.1

Références $path, Path\clean(), et Path\resolve().

Référencé par Tar\extract().

◆ isSupported()

static isSupported ( )
static

Tests whether this adapter can unpack files on this computer.

Renvoie
boolean True if supported
Depuis
1.0

Implémente ExtractableInterface.

Documentation des champs

◆ $data

$data
private

Référencé par Tar\getTarInfo().

◆ $metadata

$metadata
private

◆ $options

$options = []
protected

Référencé par Tar\__construct().

◆ TYPES

const TYPES
private
Valeur initiale :
= [
0x0 => 'Unix file'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Tar.php


Joomla CMS: Référence de la classe Zip

  • Joomla
  • Archive
  • Zip
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Zip
+ Graphe d'héritage de Zip:
ExtractableInterface

Fonctions membres publiques

__construct ($options=[])
create ($archive, $files)
extract ($archive, $destination)
checkZipData ($data)

Fonctions membres publiques statiques

static | isSupported ()
static | hasNativeSupport ()

Fonctions membres protégées

extractCustom ($archive, $destination)
extractNative ($archive, $destination)
unix2DosTime ($unixtime=null)

Attributs protégés

$options = []

Fonctions membres privées

readZipInfo ($data)
getFileData (int $key)
addToZipFile (array &$file, array &$contents, array &$ctrldir)
createZipFile (array $contents, array $ctrlDir, string $path)
isBelow ($destination, $path)

Attributs privés

const | METHODS
const | CTRL_DIR_HEADER = "\x50\x4b\x01\x02"
const | CTRL_DIR_END = "\x50\x4b\x05\x06\x00\x00\x00\x00"
const | FILE_HEADER = "\x50\x4b\x03\x04"
$data
$metadata

Description détaillée

ZIP format adapter for the Archive package

The ZIP compression code is partially based on code from: Eric Mueller eric@.nosp@m.them.nosp@m.epark.nosp@m..com http://www.zend.com/codex.php?id=535&single=1

Deins125 webma.nosp@m.ster.nosp@m.@atla.nosp@m.nt.r.nosp@m.u http://www.zend.com/codex.php?id=470&single=1

The ZIP compression date code is partially based on code from Peter Listiak mlady.nosp@m.@use.nosp@m.rs.so.nosp@m.urce.nosp@m.forge.nosp@m..net

This class is inspired from and draws heavily in code and concept from the Compress package of The Horde Project http://www.horde.org

Chuck Hagenbuch chuck.nosp@m.@hor.nosp@m.de.or.nosp@m.g Michael Slusarz slusa.nosp@m.rz@h.nosp@m.orde..nosp@m.org Michael Cochrane mike@.nosp@m.graf.nosp@m.tonha.nosp@m.ll.c.nosp@m.o.nz

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Create a new Archive object.

Paramètres
array | \ArrayAccess $options An array of options or an object that implements
Depuis
1.0
Exceptions

Références Zip\$options.

Documentation des fonctions membres

◆ addToZipFile()

addToZipFile | ( | array & | $file,
 |  | array & | $contents,
 |  | array & | $ctrldir
 | ) |  |
private

Adds a "file" to the ZIP archive.

Paramètres
array | $file | File data array to add
array | $contents | An array of existing zipped files.
array | $ctrldir | An array of central directory information.
Renvoie
void
Depuis
1.0

Références Zip\$data, $name, null, et Zip\unix2DosTime().

Référencé par Zip\create().

◆ checkZipData()

checkZipData ( $data )

Checks to see if the data is a valid ZIP file.

Paramètres
string $data ZIP archive data buffer.
Renvoie
boolean True if valid, false if invalid.
Depuis
1.0

Références Zip\$data.

◆ create()

create | ( | $archive,
 |  | $files
 | ) |

Create a ZIP compressed file from an array of file data.

Paramètres
string | $archive | Path to save archive.
array | $files | Array of files to add to archive.
Renvoie
boolean True if successful.
Depuis
1.0

Références Zip\addToZipFile(), et Zip\createZipFile().

◆ createZipFile()

createZipFile | ( | array | $contents,
 |  | array | $ctrlDir,
 |  | string | $path
 | ) |  |
private

Creates the ZIP file.

Official ZIP file format: http://www.pkware.com/appnote.txt

Paramètres
array | $contents | An array of existing zipped files.
array | $ctrlDir | An array of central directory information.
string | $path | The path to store the archive.
Renvoie
boolean True if successful
Depuis
1.0

Références $buffer, Zip\$data, $dir, $path, et File\write().

Référencé par Zip\create().

◆ extract()

extract | ( | $archive,
 |  | $destination
 | ) |

Extract a ZIP compressed file to a given path

Paramètres
string | $archive | Path to ZIP archive to extract
string | $destination | Path to extract archive into
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Implémente ExtractableInterface.

Références Zip\extractCustom(), et Zip\extractNative().

◆ extractCustom()

extractCustom | ( | $archive,
 |  | $destination
 | ) |
protected

Extract a ZIP compressed file to a given path using a php based algorithm that only requires zlib support

Paramètres
string | $archive | Path to ZIP archive to extract.
string | $destination | Path to extract archive into.
Renvoie
boolean True if successful
Depuis
1.0
Exceptions

Références $buffer, $i, Zip\$metadata, $path, Path\clean(), Folder\create(), Zip\getFileData(), Zip\isBelow(), null, Zip\readZipInfo(), et File\write().

Référencé par Zip\extract().

◆ extractNative()

extractNative | ( | $archive,
 |  | $destination
 | ) |
protected

Extract a ZIP compressed file to a given path using native php api calls for speed

Paramètres
string | $archive | Path to ZIP archive to extract
string | $destination | Path to extract archive into
Renvoie
boolean True on success
Exceptions

Références $buffer, Folder\create(), Zip\isBelow(), et File\write().

Référencé par Zip\extract().

◆ getFileData()

getFileData ( int $key )
private

Returns the file data for a file by offset in the ZIP archive

Paramètres
integer $key The position of the file in the archive.
Renvoie
string Uncompressed file data buffer.
Depuis
1.0

Références $key.

Référencé par Zip\extractCustom().

◆ hasNativeSupport()

static hasNativeSupport ( )
static

Method to determine if the server has native zip support for faster handling

Renvoie
boolean True if php has native ZIP support
Depuis
1.0

◆ isBelow()

isBelow | ( | $destination,
 |  | $path
 | ) |
private

Check if a path is below a given destination path

Paramètres
string | $destination | The destination path
string | $path | The path to be checked
Renvoie
boolean
Depuis
1.1.10

Références $path, Path\clean(), et Path\resolve().

Référencé par Zip\extractCustom(), et Zip\extractNative().

◆ isSupported()

static isSupported ( )
static

Tests whether this adapter can unpack files on this computer.

Renvoie
boolean True if supported
Depuis
1.0

Implémente ExtractableInterface.

◆ readZipInfo()

readZipInfo ( $data )
private

Get the list of files/data from a ZIP archive buffer.

KEY: Position in zipfile
VALUES: 'attr'  --  File attributes
        'crc'   --  CRC checksum
        'csize' --  Compressed file size
        'date'  --  File modification time
        'name'  --  Filename
        'method'--  Compression method
        'size'  --  Original file size
        'type'  --  File type
Paramètres
string $data The ZIP archive buffer.
Renvoie
boolean True on success
Depuis
1.0
Exceptions

Références Zip\$data, $info, $last, $name, Joomla\Database\Query\$offset, et null.

Référencé par Zip\extractCustom().

◆ unix2DosTime()

unix2DosTime ( $unixtime = null )
protected

Converts a UNIX timestamp to a 4-byte DOS date and time format (date in high 2-bytes, time in low 2-bytes allowing magnitude comparison).

Paramètres
integer $unixtime The current UNIX timestamp.
Renvoie
integer The current date in a 4-byte DOS format.
Depuis
1.0

Références null.

Référencé par Zip\addToZipFile().

Documentation des champs

◆ $data

$data
private

Référencé par Zip\addToZipFile(), Zip\checkZipData(), Zip\createZipFile(), et Zip\readZipInfo().

◆ $metadata

$metadata
private

Référencé par Zip\extractCustom().

◆ $options

$options = []
protected

Référencé par Zip\__construct().

◆ CTRL_DIR_END

const CTRL_DIR_END = "\x50\x4b\x05\x06\x00\x00\x00\x00"
private

◆ CTRL_DIR_HEADER

const CTRL_DIR_HEADER = "\x50\x4b\x01\x02"
private

◆ FILE_HEADER

const FILE_HEADER = "\x50\x4b\x03\x04"
private

◆ METHODS

const METHODS
private
Valeur initiale :
= [
0x0 => 'None'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Zip.php


Joomla CMS: Référence de la classe UnsupportedPasswordHandlerException

  • Joomla
  • Authentication
  • Exception
  • UnsupportedPasswordHandlerException
Référence de la classe UnsupportedPasswordHandlerException
+ Graphe d'héritage de UnsupportedPasswordHandlerException:

Description détaillée

Exception class defining an unsupported password handler

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedPasswordHandlerException.php


Joomla CMS: Référence de la classe Argon2idHandler

  • Joomla
  • Authentication
  • Password
  • Argon2idHandler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Argon2idHandler
+ Graphe d'héritage de Argon2idHandler:
HandlerInterface Argon2idHandler

Fonctions membres publiques

hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Password handler for Argon2id hashed passwords

Depuis
1.3.0

Documentation des fonctions membres

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
1.3.0
Exceptions
UnsupportedPasswordHandlerException if the password handler is not supported

Implémente HandlerInterface.

Références $options.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
1.3.0

Implémente HandlerInterface.

Référencé par Authentication\register().

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
1.3.0
Exceptions
UnsupportedPasswordHandlerException if the password handler is not supported

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/authentication/src/Password/Argon2idHandler.php


Joomla CMS: Référence de la classe Argon2iHandler

  • Joomla
  • Authentication
  • Password
  • Argon2iHandler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Argon2iHandler
+ Graphe d'héritage de Argon2iHandler:
HandlerInterface Argon2iHandler

Fonctions membres publiques

hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Password handler for Argon2i hashed passwords

Depuis
1.2.0

Documentation des fonctions membres

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
1.2.0
Exceptions
UnsupportedPasswordHandlerException if the password handler is not supported

Implémente HandlerInterface.

Références $hash, $options, SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE, et SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
1.2.0

Implémente HandlerInterface.

Référencé par Authentication\register().

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
1.2.0
Exceptions
UnsupportedPasswordHandlerException if the password handler is not supported

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/authentication/src/Password/Argon2iHandler.php


Joomla CMS: Référence de la classe BCryptHandler

  • Joomla
  • Authentication
  • Password
  • BCryptHandler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe BCryptHandler
+ Graphe d'héritage de BCryptHandler:
HandlerInterface BCryptHandler

Fonctions membres publiques

hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Password handler for BCrypt hashed passwords

Depuis
1.2.0

Documentation des fonctions membres

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
1.2.0

Implémente HandlerInterface.

Références $options.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
1.2.0

Implémente HandlerInterface.

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
1.2.0

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/authentication/src/Password/BCryptHandler.php


Joomla CMS: Référence de l'interface HandlerInterface

  • Joomla
  • Authentication
  • Password
  • HandlerInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface HandlerInterface
+ Graphe d'héritage de HandlerInterface:
Argon2idHandler Argon2iHandler BCryptHandler ChainedHandler MD5Handler PHPassHandler Argon2idHandler Argon2iHandler BCryptHandler

Fonctions membres publiques

hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Interface defining a password handler

Depuis
1.2.0

Documentation des fonctions membres

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
1.2.0

Implémenté dans ChainedHandler, MD5Handler, PHPassHandler, Argon2idHandler, Argon2iHandler, et BCryptHandler.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
1.2.0

Implémenté dans ChainedHandler, Argon2iHandler, MD5Handler, PHPassHandler, Argon2idHandler, et BCryptHandler.

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
1.2.0

Implémenté dans ChainedHandler, Argon2iHandler, MD5Handler, PHPassHandler, Argon2idHandler, et BCryptHandler.

La documentation de cette interface a été générée à partir du fichier suivant :
  • authentication/src/Password/HandlerInterface.php


Joomla CMS: Référence de la classe DatabaseStrategy

  • Joomla
  • Authentication
  • Strategies
  • DatabaseStrategy
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe DatabaseStrategy
+ Graphe d'héritage de DatabaseStrategy:
AbstractUsernamePasswordAuthenticationStrategy AuthenticationStrategyInterface

Fonctions membres publiques

__construct (Input $input, DatabaseInterface $database, array $options=[], ?HandlerInterface $passwordHandler=null)
authenticate ()
- Fonctions membres publiques hérités de AbstractUsernamePasswordAuthenticationStrategy
__construct (?HandlerInterface $passwordHandler=null)
getResult ()

Fonctions membres protégées

getHashedPassword ($username)
- Fonctions membres protégées hérités de AbstractUsernamePasswordAuthenticationStrategy
doAuthenticate ($username, $password)
getHashedPassword ($username)
verifyPassword ($username, $password, $hashedPassword)

Attributs privés

$db
$dbOptions
$input

Membres hérités additionnels

- Attributs protégés hérités de AbstractUsernamePasswordAuthenticationStrategy
$passwordHandler
$status

Description détaillée

Joomla Framework Database Strategy Authentication class

Depuis
1.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input,
 |  | DatabaseInterface | $database,
 |  | array | $options = [],
 |  | ?HandlerInterface | $passwordHandler = null
 | ) |  |

Strategy Constructor

Paramètres
Input | $input | The input object from which to retrieve the request credentials.
DatabaseInterface | $database | DatabaseDriver for retrieving user credentials.
array | $options | Optional options array for configuring the credential storage connection.
HandlerInterface | $passwordHandler | The password handler.
Depuis
1.1.0

Références DatabaseStrategy\$input, $options, AbstractUsernamePasswordAuthenticationStrategy\$passwordHandler, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ authenticate()

authenticate ( )

Attempt to authenticate the username and password pair.

Renvoie
string|boolean A string containing a username if authentication is successful, false otherwise.
Depuis
1.1.0

Implémente AuthenticationStrategyInterface.

Références $password, AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate(), et Authentication\NO_CREDENTIALS.

◆ getHashedPassword()

getHashedPassword ( $username )
protected

Retrieve the hashed password for the specified user.

Paramètres
string $username Username to lookup.
Renvoie
string|boolean Hashed password on success or boolean false on failure.
Depuis
1.1.0

Références $password, et $this.

Documentation des champs

◆ $db

$db
private

◆ $dbOptions

$dbOptions
private

◆ $input

$input
private

Référencé par DatabaseStrategy\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseStrategy.php


Joomla CMS: Référence de la classe LocalStrategy

  • Joomla
  • Authentication
  • Strategies
  • LocalStrategy
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe LocalStrategy
+ Graphe d'héritage de LocalStrategy:
AbstractUsernamePasswordAuthenticationStrategy AuthenticationStrategyInterface

Fonctions membres publiques

__construct (Input $input, array $credentialStore=[], ?HandlerInterface $passwordHandler=null)
authenticate ()
- Fonctions membres publiques hérités de AbstractUsernamePasswordAuthenticationStrategy
__construct (?HandlerInterface $passwordHandler=null)
getResult ()

Fonctions membres protégées

getHashedPassword ($username)
- Fonctions membres protégées hérités de AbstractUsernamePasswordAuthenticationStrategy
doAuthenticate ($username, $password)
getHashedPassword ($username)
verifyPassword ($username, $password, $hashedPassword)

Attributs privés

$credentialStore
$input

Membres hérités additionnels

- Attributs protégés hérités de AbstractUsernamePasswordAuthenticationStrategy
$passwordHandler
$status

Description détaillée

Joomla Framework Local Strategy Authentication class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input,
 |  | array | $credentialStore = [],
 |  | ?HandlerInterface | $passwordHandler = null
 | ) |  |

Strategy Constructor

Paramètres
Input | $input | The input object from which to retrieve the request credentials.
array | $credentialStore | Hash of username and hash pairs.
HandlerInterface | $passwordHandler | The password handler.
Depuis
1.0

Références LocalStrategy\$credentialStore, LocalStrategy\$input, AbstractUsernamePasswordAuthenticationStrategy\$passwordHandler, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ authenticate()

authenticate ( )

Attempt to authenticate the username and password pair.

Renvoie
string|boolean A string containing a username if authentication is successful, false otherwise.
Depuis
1.0

Implémente AuthenticationStrategyInterface.

Références $password, AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate(), et Authentication\NO_CREDENTIALS.

◆ getHashedPassword()

getHashedPassword ( $username )
protected

Retrieve the hashed password for the specified user.

Paramètres
string $username Username to lookup.
Renvoie
string|boolean Hashed password on success or boolean false on failure.
Depuis
1.1.0

Documentation des champs

◆ $credentialStore

$credentialStore
private

Référencé par LocalStrategy\__construct().

◆ $input

$input
private

Référencé par LocalStrategy\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LocalStrategy.php


Joomla CMS: Référence de la classe AbstractUsernamePasswordAuthenticationStrategy

  • Joomla
  • Authentication
  • AbstractUsernamePasswordAuthenticationStrategy
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractUsernamePasswordAuthenticationStrategy
+ Graphe d'héritage de AbstractUsernamePasswordAuthenticationStrategy:
AuthenticationStrategyInterface DatabaseStrategy LocalStrategy

Fonctions membres publiques

__construct (?HandlerInterface $passwordHandler=null)
getResult ()
- Fonctions membres publiques hérités de AuthenticationStrategyInterface
authenticate ()

Fonctions membres protégées

doAuthenticate ($username, $password)
getHashedPassword ($username)
verifyPassword ($username, $password, $hashedPassword)

Attributs protégés

$passwordHandler
$status

Description détaillée

Abstract AuthenticationStrategy for username/password based authentication

Depuis
1.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?HandlerInterface $passwordHandler = null )

Constructor.

Paramètres
HandlerInterface $passwordHandler The password handler.
Depuis
1.2.0

Références AbstractUsernamePasswordAuthenticationStrategy\$passwordHandler.

Documentation des fonctions membres

◆ doAuthenticate()

doAuthenticate | ( | $username,
 |  | $password
 | ) |
protected

Attempt to authenticate the username and password pair.

Paramètres
string | $username | The username to authenticate.
string | $password | The password to attempt authentication with.
Renvoie
string|boolean A string containing a username if authentication is successful, false otherwise.
Depuis
1.1.0

Références $password, AbstractUsernamePasswordAuthenticationStrategy\getHashedPassword(), Authentication\INVALID_CREDENTIALS, Authentication\NO_SUCH_USER, Authentication\SUCCESS, et AbstractUsernamePasswordAuthenticationStrategy\verifyPassword().

Référencé par LocalStrategy\authenticate(), et DatabaseStrategy\authenticate().

◆ getHashedPassword()

getHashedPassword ( $username )
abstractprotected

Retrieve the hashed password for the specified user.

Paramètres
string $username Username to lookup.
Renvoie
string|boolean Hashed password on success or boolean false on failure.
Depuis
1.1.0

Référencé par AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate().

◆ getResult()

getResult ( )

Get the status of the last authentication attempt.

Renvoie
integer Authentication class constant result.
Depuis
1.1.0

Implémente AuthenticationStrategyInterface.

Références AbstractUsernamePasswordAuthenticationStrategy\$status.

◆ verifyPassword()

verifyPassword | ( | $username,
 |  | $password,
 |  | $hashedPassword
 | ) |
protected

Attempt to verify the username and password pair.

Paramètres
string | $username | The username to authenticate.
string | $password | The password to attempt authentication with.
string | $hashedPassword | The hashed password to attempt authentication against.
Renvoie
boolean
Depuis
1.1.0

Références $password.

Référencé par AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate().

Documentation des champs

◆ $passwordHandler

$passwordHandler
protected

Référencé par AbstractUsernamePasswordAuthenticationStrategy\__construct(), LocalStrategy\__construct(), et DatabaseStrategy\__construct().

◆ $status

$status
protected

Référencé par AbstractUsernamePasswordAuthenticationStrategy\getResult().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractUsernamePasswordAuthenticationStrategy.php


Joomla CMS: Référence de la classe Authentication

  • Joomla
  • Authentication
  • Authentication
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe Authentication

Fonctions membres publiques

addStrategy ($strategyName, AuthenticationStrategyInterface $strategy)
getResults ()

Champs de données

const | SUCCESS = 1
const | INVALID_CREDENTIALS = 2
const | NO_SUCH_USER = 3
const | NO_CREDENTIALS = 4
const | INCOMPLETE_CREDENTIALS = 5

Attributs privés

$strategies = []
$results = []

Description détaillée

Joomla Framework Authentication Class

Depuis
1.0

Documentation des fonctions membres

◆ addStrategy()

addStrategy | ( |  | $strategyName,
 |  | AuthenticationStrategyInterface | $strategy
 | ) |  |

Register a new strategy

Paramètres
string | $strategyName | The name to use for the strategy.
AuthenticationStrategyInterface | $strategy | The authentication strategy object to add.
Renvoie
void
Depuis
1.0

◆ getResults()

getResults ( )

Get authentication results.

Use this if you want to get more detailed information about the results of an authentication attempts.

Renvoie
integer[] An array containing authentication results.
Depuis
1.0

Références Authentication\$results.

Documentation des champs

◆ $results

$results = []
private

Référencé par Authentication\getResults().

◆ $strategies

$strategies = []
private

◆ INCOMPLETE_CREDENTIALS

const INCOMPLETE_CREDENTIALS = 5

There were partial credentials found but they were not complete.

Depuis
1.0

◆ INVALID_CREDENTIALS

const INVALID_CREDENTIALS = 2

Credentials were provided but they were invalid.

Depuis
1.0

Référencé par AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate().

◆ NO_CREDENTIALS

const NO_CREDENTIALS = 4

There were no credentials found.

Depuis
1.0

Référencé par LocalStrategy\authenticate(), et DatabaseStrategy\authenticate().

◆ NO_SUCH_USER

const NO_SUCH_USER = 3

Credentials were provided but the user did not exist in the credential store.

Depuis
1.0

Référencé par AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate().

◆ SUCCESS

const SUCCESS = 1

Authentication was successful.

Depuis
1.0

Référencé par AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/authentication/src/Authentication.php


Joomla CMS: Référence de l'interface AuthenticationStrategyInterface

  • Joomla
  • Authentication
  • AuthenticationStrategyInterface
Fonctions membres publiques
Référence de l'interface AuthenticationStrategyInterface
+ Graphe d'héritage de AuthenticationStrategyInterface:
AbstractUsernamePasswordAuthenticationStrategy DatabaseStrategy LocalStrategy

Fonctions membres publiques

authenticate ()
getResult ()

Description détaillée

Joomla Framework AuthenticationStrategy Interface

Depuis
1.0

Documentation des fonctions membres

◆ authenticate()

authenticate ( )

Attempt authentication.

Renvoie
string|boolean A string containing a username if authentication is successful, false otherwise.
Depuis
1.0

Implémenté dans DatabaseStrategy, et LocalStrategy.

◆ getResult()

getResult ( )

Get last authentication result.

Renvoie
integer An integer from Authentication class constants with the authentication result.
Depuis
1.0

Implémenté dans AbstractUsernamePasswordAuthenticationStrategy.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AuthenticationStrategyInterface.php


Joomla CMS: Référence de la classe AuthenticationFailed

  • Joomla
  • CMS
  • Access
  • Exception
  • AuthenticationFailed
Référence de la classe AuthenticationFailed
+ Graphe d'héritage de AuthenticationFailed:

Description détaillée

Exception class defining an authentication failed event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationFailed.php


Joomla CMS: Référence de la classe NotAllowed

  • Joomla
  • CMS
  • Access
  • Exception
  • NotAllowed
Référence de la classe NotAllowed
+ Graphe d'héritage de NotAllowed:

Description détaillée

Exception class defining a not allowed access

Depuis
3.6.3
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotAllowed.php


Joomla CMS: Référence de la classe Access

  • Joomla
  • CMS
  • Access
  • Access
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe Access

Fonctions membres publiques statiques

static | clearStatics ()
static | check ($userId, $action, $assetKey=null, $preload=true)
static | preload ($assetTypes='components', $reload=false)
static | checkGroup ($groupId, $action, $assetKey=null, $preload=true)
static | getAssetRules ($assetKey, $recursive=false, $recursiveParentAsset=true, $preload=true)
static | getExtensionNameFromAsset ($assetKey)
static | getAssetType ($assetKey)
static | getGroupTitle ($groupId)
static | getGroupsByUser ($userId, $recursive=true)
static | getUsersByGroup ($groupId, $recursive=false)
static | getAuthorisedViewLevels ($userId)
static | getActionsFromFile ($file, $xpath="/access/section[@name='component']/")
static | getActionsFromData ($data, $xpath="/access/section[@name='component']/")

Fonctions membres protégées statiques

static | getAssetAncestors ($assetType, $assetId)
static | preloadPermissions ($assetType, $reload=false)
static | preloadComponents ()
static | getGroupPath ($groupId)
static | cleanAssetKey ($assetKey=null)
static | getAssetId ($assetKey)
static | getAssetName ($assetKey)

Attributs protégés statiques

static | $viewLevels = array()
static | $assetRules = array()
static | $assetRulesIdentities = array()
static | $assetPermissionsParentIdMapping = array()
static | $preloadedAssetTypes = array()
static | $identities = array()
static | $userGroups = array()
static | $userGroupPaths = array()
static | $groupsByUser = array()
static | $preloadedAssets = array()
static | $rootAssetId = null

Description détaillée

Class that handles all access authorisation routines.

Depuis
1.7.0

Documentation des fonctions membres

◆ check()

static check | ( | $userId,
 |  | $action,
 |  | $assetKey = null,
 |  | $preload = true
 | ) |
static

Method to check if a user is authorised to perform an action, optionally on an asset.

Paramètres
integer | $userId | Id of the user for which to check authorisation.
string | $action | The name of the action to authorise.
integer | string | $assetKey | The asset key (asset id or asset name). null fallback to root asset.
boolean | $preload | Indicates whether preloading should be used.
Renvoie
boolean|null True if allowed, false for an explicit deny, null for an implicit deny.
Depuis
1.7.0

Références $userId.

Référencé par UserModel\activate(), UserController\allowEdit(), User\authorise(), UserModel\block(), UserModel\delete(), et User\save().

◆ checkGroup()

static checkGroup | ( | $groupId,
 |  | $action,
 |  | $assetKey = null,
 |  | $preload = true
 | ) |
static

Method to check if a group is authorised to perform an action, optionally on an asset.

Paramètres
integer | $groupId | The path to the group for which to check authorisation.
string | $action | The name of the action to authorise.
integer | string | $assetKey | The asset key (asset id or asset name). null fallback to root asset.
boolean | $preload | Indicates whether preloading should be used.
Renvoie
boolean True if authorised.
Depuis
1.7.0

Référencé par GroupController\allowEdit(), LevelController\allowEdit(), UserModel\batchUser(), LevelModel\canDelete(), UserHelper\checkSuperUserInUsers(), GroupModel\delete(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), UserMessagesField\getGroups(), DebuggroupModel\getItems(), GroupparentField\getOptions(), UsergrouplistField\getOptions(), User\groups(), GroupModel\save(), ComponentModel\save(), UserModel\save(), User\save(), et LevelModel\validate().

◆ cleanAssetKey()

static cleanAssetKey ( $assetKey = null )
staticprotected

Method to clean the asset key to make sure we always have something.

Paramètres
integer | string $assetKey The asset key (asset id or asset name). null fallback to root asset.
Renvoie
integer|string Asset id or asset name.
Depuis
3.7.0

Références Factory\getDbo(), et null.

◆ clearStatics()

static clearStatics ( )
static

Method for clearing static caches.

Renvoie
void
Depuis
1.7.3

Références null.

Référencé par User\clearAccessRights().

◆ getActionsFromData()

static getActionsFromData | ( | $data,
 |  | $xpath = "/access/section[@name='component']/"
 | ) |
static

Method to return a list of actions from a string or from an xml for which permissions can be set.

Paramètres
string | \SimpleXMLElement | $data | The XML string or an XML element.
string | $xpath | An optional xpath to search for the fields.
Renvoie
boolean|array False if case of error or the list of actions available.
Depuis
3.0.0

Références $actions, et $data.

◆ getActionsFromFile()

static getActionsFromFile | ( | $file,
 |  | $xpath = "/access/section[@name='component']/"
 | ) |
static

Method to return a list of actions from a file for which permissions can be set.

Paramètres
string | $file | The path to the XML file.
string | $xpath | An optional xpath to search for the fields.
Renvoie
boolean|array False if case of error or the list of actions available.
Depuis
3.0.0

Références $xml.

Référencé par ContentHelper\getActions(), DebugHelper\getDebugActions(), RulesRule\getFieldActions(), RulesField\getInput(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), et ComponentsFieldgroupField\getOptions().

◆ getAssetAncestors()

static getAssetAncestors | ( | $assetType,
 |  | $assetId
 | ) |
staticprotected

Method to recursively retrieve the list of parent Asset IDs for a particular Asset.

Paramètres
string | $assetType | The asset type, or the asset name, or the extension of the asset (e.g. 'com_content.article', 'com_menus.menu.2', 'com_contact').
integer | $assetId | The numeric asset id.
Renvoie
array List of ancestor ids (includes original $assetId).
Depuis
1.6

Références $assetId, et $id.

◆ getAssetId()

static getAssetId ( $assetKey )
staticprotected

Method to get the asset id from the asset key.

Paramètres
integer | string $assetKey The asset key (asset id or asset name).
Renvoie
integer The asset id.
Depuis
3.7.0

Références Factory\getDbo(), et null.

◆ getAssetName()

static getAssetName ( $assetKey )
staticprotected

Method to get the asset name from the asset key.

Paramètres
integer | string $assetKey The asset key (asset id or asset name).
Renvoie
string The asset name (ex: com_content.article.8).
Depuis
3.7.0

Références elseif, Factory\getDbo(), et null.

◆ getAssetRules()

static getAssetRules | ( | $assetKey,
 |  | $recursive = false,
 |  | $recursiveParentAsset = true,
 |  | $preload = true
 | ) |
static

Method to return the Rules object for an asset. The returned object can optionally hold only the rules explicitly set for the asset or the summation of all inherited rules from parent assets and explicit rules.

Paramètres
integer | string | $assetKey | The asset key (asset id or asset name). null fallback to root asset.
boolean | $recursive | True to return the rules object with inherited rules.
boolean | $recursiveParentAsset | True to calculate the rule also based on inherited component/extension rules.
boolean | $preload | Indicates whether preloading should be used.
Renvoie
Rules Rules object for the asset.
Depuis
1.7.0
Note
The non preloading code will be removed in 4.0. All asset rules should use asset preloading.

Hashing the collected rules allows us to store only one instance of the Rules object for Assets that have the same exact permissions... it's a great way to save some memory.

Références $assetId, $db, $hash, $id, $query, $result, Log\add(), Factory\getDbo(), Profiler\getInstance(), Log\INFO, ParameterType\INTEGER, JDEBUG, name, null, et Log\WARNING.

Référencé par User\authorise(), RulesField\getInput(), et GroupModel\save().

◆ getAssetType()

static getAssetType ( $assetKey )
static

Method to get the asset type from the asset name.

For top level components this returns "components": 'com_content' returns 'components'

For other types: 'com_content.article.1' returns 'com_content.article' 'com_content.category.1' returns 'com_content.category'

Paramètres
integer | string $assetKey The asset key (asset id or asset name).
Renvoie
string The asset type (ex: com_content.article).
Depuis
1.6

◆ getAuthorisedViewLevels()

static getAuthorisedViewLevels ( $userId )
static

Method to return a list of view levels for which the user is authorised.

Paramètres
integer $userId Id of the user for which to get the list of authorised view levels.
Renvoie
array List of view levels for which the user is authorised.
Depuis
1.7.0

Références $authorised, $db, $groups, $id, $query, $user, $userId, elseif, Factory\getApplication(), Factory\getDbo(), et User\getInstance().

Référencé par User\getAuthorisedViewLevels(), ArticlesPopularHelper\getList(), et ArticlesCategoryHelper\getList().

◆ getExtensionNameFromAsset()

static getExtensionNameFromAsset ( $assetKey )
static

Method to get the extension name from the asset name.

Paramètres
integer | string $assetKey The asset key (asset id or asset name).
Renvoie
string The extension name (ex: com_content).
Depuis
1.6

◆ getGroupPath()

static getGroupPath ( $groupId )
staticprotected

Gets the parent groups that a leaf group belongs to in its branch back to the root of the tree (including the leaf group id).

Paramètres
mixed $groupId An integer or array of integers representing the identities to check.
Renvoie
mixed True if allowed, false for an explicit deny, null for an implicit deny.
Depuis
1.7.0

Références $groups, et UserGroupsHelper\getInstance().

◆ getGroupsByUser()

static getGroupsByUser | ( | $userId,
 |  | $recursive = true
 | ) |
static

Method to return a list of user groups mapped to a user. The returned list can optionally hold only the groups explicitly mapped to the user or all groups both explicitly mapped and inherited by the user.

Paramètres
integer | $userId | Id of the user for which to get the list of groups.
boolean | $recursive | True to include inherited user groups.
Renvoie
array List of user group ids to which the user is mapped.
Depuis
1.7.0

Références $db, $query, $result, $userId, Factory\getDbo(), ComponentHelper\getParams(), ParameterType\INTEGER, et ArrayHelper\toInteger().

Référencé par GroupModel\delete(), RemoveUserFromGroupCommand\doExecute(), ComponentHelper\filterText(), User\getAuthorisedGroups(), AddUserToGroupCommand\getGroups(), RemoveUserFromGroupCommand\getGroups(), GroupModel\save(), ProfileModel\save(), et ApplicationModel\save().

◆ getGroupTitle()

static getGroupTitle ( $groupId )
static

Method to return the title of a user group

Paramètres
integer $groupId Id of the group for which to get the title of.
Renvoie
string The title of the group
Depuis
3.5

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ getUsersByGroup()

static getUsersByGroup | ( | $groupId,
 |  | $recursive = false
 | ) |
static

Method to return a list of user Ids contained in a Group

Paramètres
integer | $groupId | The group Id
boolean | $recursive | Recursively include all child groups (optional)
Renvoie
array
Depuis
1.7.0

Références $db, $query, $result, Factory\getDbo(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ preload()

static preload | ( | $assetTypes = 'components',
 |  | $reload = false
 | ) |
static

Method to preload the Rules object for the given asset type.

Paramètres
integer | string | array | $assetTypes | The type or name of the asset (e.g. 'com_content.article', 'com_menus.menu.2'). Also accepts the asset id. An array of asset type or a special 'components' string to load all component assets.
boolean | $reload | Set to true to reload from database.
Renvoie
boolean True on success.
Depuis
1.6
Note
This method will return void in 4.0.

◆ preloadComponents()

static preloadComponents ( )
staticprotected

Method to preload the Rules objects for all components.

Note: This will only get the base permissions for the component. e.g. it will get 'com_content', but not 'com_content.article.1' or any more specific asset type rules.

Renvoie
array Array of component names that were preloaded.
Depuis
1.6

Références $component, $db, $query, ComponentHelper\getComponents(), Factory\getDbo(), Profiler\getInstance(), JDEBUG, null, et ParameterType\STRING.

◆ preloadPermissions()

static preloadPermissions | ( | $assetType,
 |  | $reload = false
 | ) |
staticprotected

Method to retrieve the Asset Rule strings for this particular Asset Type and stores them for later usage in getAssetRules(). Stores 2 arrays: one where the list has the Asset ID as the key and a second one where the Asset Name is the key.

Paramètres
string | $assetType | The asset type, or the asset name, or the extension of the asset (e.g. 'com_content.article', 'com_menus.menu.2', 'com_contact').
boolean | $reload | Reload the preloaded assets.
Renvoie
void
Depuis
1.6

Références $db, $query, Factory\getDbo(), Profiler\getInstance(), et JDEBUG.

Documentation des champs

◆ $assetPermissionsParentIdMapping

$assetPermissionsParentIdMapping = array()
staticprotected

◆ $assetRules

$assetRules = array()
staticprotected

◆ $assetRulesIdentities

$assetRulesIdentities = array()
staticprotected

◆ $groupsByUser

$groupsByUser = array()
staticprotected

◆ $identities

$identities = array()
staticprotected

◆ $preloadedAssets

$preloadedAssets = array()
staticprotected

◆ $preloadedAssetTypes

$preloadedAssetTypes = array()
staticprotected

◆ $rootAssetId

$rootAssetId = null
staticprotected

◆ $userGroupPaths

$userGroupPaths = array()
staticprotected

◆ $userGroups

$userGroups = array()
staticprotected

◆ $viewLevels

$viewLevels = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Access/Access.php


Joomla CMS: Référence de la classe Rule

  • Joomla
  • CMS
  • Access
  • Rule
Fonctions membres publiques | Attributs protégés
Référence de la classe Rule

Fonctions membres publiques

__construct ($identities)
getData ()
mergeIdentities ($identities)
mergeIdentity ($identity, $allow)
allow ($identities)
__toString ()

Attributs protégés

$data = array()

Description détaillée

Rule class.

Depuis
2.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $identities )

Constructor.

The input array must be in the form: array(-42 => true, 3 => true, 4 => false) or an equivalent JSON encoded string.

Paramètres
mixed $identities A JSON format string (probably from the database) or a named array.
Depuis
1.7.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Convert this object into a JSON encoded string.

Renvoie
string JSON encoded string
Depuis
1.7.0

◆ allow()

allow ( $identities )

Checks that this action can be performed by an identity.

The identity is an integer where +ve represents a user group, and -ve represents a user.

Paramètres
mixed $identities An integer or array of integers representing the identities to check.
Renvoie
mixed True if allowed, false for an explicit deny, null for an implicit deny.
Depuis
1.7.0

Références $result, et null.

◆ getData()

getData ( )

Get the data for the action.

Renvoie
array A named array
Depuis
1.7.0

Références $data.

◆ mergeIdentities()

mergeIdentities ( $identities )

Merges the identities

Paramètres
mixed $identities An integer or array of integers representing the identities to check.
Renvoie
void
Depuis
1.7.0

◆ mergeIdentity()

mergeIdentity | ( | $identity,
 |  | $allow
 | ) |

Merges the values for an identity.

Paramètres
integer | $identity | The identity.
boolean | $allow | The value for the identity (true == allow, false == deny).
Renvoie
void
Depuis
1.7.0

Documentation des champs

◆ $data

$data = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Rule.php


Joomla CMS: Référence de la classe Rules

  • Joomla
  • CMS
  • Access
  • Rules
Fonctions membres publiques | Attributs protégés
Référence de la classe Rules

Fonctions membres publiques

__construct ($input='')
getData ()
mergeCollection ($input)
merge ($actions)
mergeAction ($action, $identities)
allow ($action, $identity)
getAllowed ($identity)
__toString ()

Attributs protégés

$data = array()

Description détaillée

Access rules class.

Depuis
2.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $input = '' )

Constructor.

The input array must be in the form: array('action' => array(-42 => true, 3 => true, 4 => false)) or an equivalent JSON encoded string, or an object where properties are arrays.

Paramètres
mixed $input A JSON format string (probably from the database) or a nested array.
Depuis
1.7.0

Références $input, et elseif.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic method to convert the object to JSON string representation.

Renvoie
string JSON representation of the actions array
Depuis
1.7.0

Références $data, $name, et $temp.

◆ allow()

allow | ( | $action,
 |  | $identity
 | ) |

Checks that an action can be performed by an identity.

The identity is an integer where +ve represents a user group, and -ve represents a user.

Paramètres
string | $action | The name of the action.
mixed | $identity | An integer representing the identity, or an array of identities
Renvoie
mixed Object or null if there is no information about the action.
Depuis
1.7.0

◆ getAllowed()

getAllowed ( $identity )

Get the allowed actions for an identity.

Paramètres
mixed $identity An integer representing the identity or an array of identities
Renvoie
CMSObject Allowed actions for the identity or identities
Depuis
1.7.0

Références $name.

◆ getData()

getData ( )

Get the data for the action.

Renvoie
array A named array of Rule objects.
Depuis
1.7.0

Références $data.

◆ merge()

merge ( $actions )

Method to merge actions with this object.

Paramètres
mixed $actions Rule object, an array of actions or a JSON string array of actions.
Renvoie
void
Depuis
1.7.0

Références $actions, $data, $name, et elseif.

◆ mergeAction()

mergeAction | ( | $action,
 |  | $identities
 | ) |

Merges an array of identities for an action.

Paramètres
string | $action | The name of the action.
array | $identities | An array of identities
Renvoie
void
Depuis
1.7.0

◆ mergeCollection()

mergeCollection ( $input )

Method to merge a collection of Rules.

Paramètres
mixed $input Rule or array of Rules
Renvoie
void
Depuis
1.7.0

Références $actions, et $input.

Documentation des champs

◆ $data

$data = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Access/Rules.php


Joomla CMS: Référence de la classe Adapter

  • Joomla
  • CMS
  • Adapter
  • Adapter
Fonctions membres publiques | Attributs protégés
Référence de la classe Adapter
+ Graphe d'héritage de Adapter:
CMSObject Installer Updater

Fonctions membres publiques

__construct ($basepath, $classprefix=null, $adapterfolder=null)
getDbo ()
getAdapter ($name, $options=array())
setAdapter ($name, &$adapter=null, $options=array())
loadAllAdapters ($options=array())
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Attributs protégés

$_adapters = array()
$_adapterfolder = 'adapters'
$_classprefix = 'J'
$_basepath = null
$_db
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Adapter Class Retains common adapter pattern functions Class harvested from joomla.installer.installer

Depuis
1.6
Obsolète:
5.0 Will be removed without replacement

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $basepath,
 |  | $classprefix = null,
 |  | $adapterfolder = null
 | ) |

Constructor

Paramètres
string | $basepath | Base Path of the adapters
string | $classprefix | Class prefix of adapters
string | $adapterfolder | Name of folder to append to base path
Depuis
1.6

Références $this, Factory\getDbo(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ getAdapter()

getAdapter | ( | $name,
 |  | $options = array()
 | ) |

Return an adapter.

Paramètres
string | $name | Name of adapter to return
array | $options | Adapter options
Renvoie
static|boolean Adapter of type 'name' or false
Depuis
1.6

Références $name, et $options.

◆ getDbo()

getDbo ( )

Get the database connector object

Renvoie
Database connector object
Depuis
1.6

◆ loadAllAdapters()

loadAllAdapters ( $options = array() )

Loads all adapters.

Paramètres
array $options Adapter options
Renvoie
void
Depuis
1.6

$file

Références $class, $name, $options, et $this.

◆ setAdapter()

setAdapter | ( |  | $name,
 |  | & | $adapter = null,
 |  |  | $options = array()
 | ) |  |

Set an adapter by name

Paramètres
string | $name | Adapter name
object | $adapter | Adapter object
array | $options | Adapter options
Renvoie
boolean True if successful
Depuis
1.6

Références $class, $name, $options, $this, et JLoader\register().

Documentation des champs

◆ $_adapterfolder

$_adapterfolder = 'adapters'
protected

◆ $_adapters

$_adapters = array()
protected

◆ $_basepath

$_basepath = null
protected

◆ $_classprefix

$_classprefix = 'J'
protected

◆ $_db

$_db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Adapter/Adapter.php


Joomla CMS: Référence de la classe AdapterInstance

  • Joomla
  • CMS
  • Adapter
  • AdapterInstance
Fonctions membres publiques | Attributs protégés
Référence de la classe AdapterInstance
+ Graphe d'héritage de AdapterInstance:
CMSObject UpdateAdapter CollectionAdapter ExtensionAdapter

Fonctions membres publiques

__construct (Adapter $parent, DatabaseDriver $db, array $options=array())
getParent ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Attributs protégés

$parent = null
$db = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Adapter Instance Class

Depuis
1.6
Obsolète:
5.0 Will be removed without replacement

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Adapter | $parent,
 |  | DatabaseDriver | $db,
 |  | array | $options = array()
 | ) |  |

Constructor

Paramètres
Adapter | $parent | Parent object
DatabaseDriver | $db | Database object
array | $options | Configuration Options
Depuis
1.6

Références $db, $options, Factory\getDbo(), et parent.

Documentation des fonctions membres

◆ getParent()

getParent ( )

Retrieves the parent object

Renvoie
Adapter
Depuis
1.6

Documentation des champs

◆ $db

$db = null
protected

◆ $parent

$parent = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdapterInstance.php


Joomla CMS: Référence de la classe ColorProcessor

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
  • Processor
  • ColorProcessor
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe ColorProcessor
+ Graphe d'héritage de ColorProcessor:
ProcessorInterface

Fonctions membres publiques

__construct ($noColors=null)
addStyle ($name, ColorStyle $style)
process ($string)

Fonctions membres publiques statiques

static stripColors ($string)

Champs de données

$noColors = false

Attributs protégés

$tagFilter = '/<([a-z=;]+)>(.*?)<\/\\1>/s'
$styles = []

Attributs protégés statiques

static $stripFilter = '/<[\/]?[a-z=;]+>/'

Fonctions membres privées

replaceColors ($text, $tag, $match, ColorStyle $style)
addPredefinedStyles ()

Description détaillée

Command line output processor supporting ANSI-colored output

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $noColors = null )

Class constructor

Paramètres
boolean $noColors Defines non-colored mode on construct
Depuis
4.0.0

Références null.

Documentation des fonctions membres

◆ addPredefinedStyles()

addPredefinedStyles ( )
private

Adds predefined color styles to the ColorProcessor object

Renvoie
$this
Depuis
4.0.0

Références $this.

◆ addStyle()

addStyle | ( |  | $name,
 |  | ColorStyle | $style
 | ) |  |

Add a style.

Paramètres
string | $name | The style name.
ColorStyle | $style | The color style.
Renvoie
$this
Depuis
4.0.0

Références $name, $style, et $this.

◆ process()

process ( $string )

Process a string.

Paramètres
string $string The string to process.
Renvoie
string
Depuis
4.0.0

Implémente ProcessorInterface.

Références $i, elseif, et ColorStyle\fromString().

◆ replaceColors()

replaceColors | ( |  | $text,
 |  |  | $tag,
 |  |  | $match,
 |  | ColorStyle | $style
 | ) |  |
private

Replace color tags in a string.

Paramètres
string | $text | The original text.
string | $tag | The matched tag.
string | $match | The match.
ColorStyle | $style | The color style to apply.
Renvoie
mixed
Depuis
4.0.0

Références $style, et $text.

◆ stripColors()

static stripColors ( $string )
static

Strip color tags from a string.

Paramètres
string $string The string.
Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $noColors

$noColors = false

◆ $stripFilter

$stripFilter = '/<[\/]?[a-z=;]+>/'
staticprotected

◆ $styles

$styles = []
protected

◆ $tagFilter

$tagFilter = '/<([a-z=;]+)>(.*?)<\/\\1>/s'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ColorProcessor.php


Joomla CMS: Référence de l'interface ProcessorInterface

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
  • Processor
  • ProcessorInterface
Fonctions membres publiques
Référence de l'interface ProcessorInterface
+ Graphe d'héritage de ProcessorInterface:
ColorProcessor

Fonctions membres publiques

process ($output)

Description détaillée

Interface for a command line output processor

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des fonctions membres

◆ process()

process ( $output )

Process the provided output into a string.

Paramètres
string $output The string to process.
Renvoie
string
Depuis
4.0.0

Implémenté dans ColorProcessor.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ProcessorInterface.php


Joomla CMS: Référence de la classe Stdout

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
  • Stdout
Fonctions membres publiques
Référence de la classe Stdout
+ Graphe d'héritage de Stdout:
CliOutput

Fonctions membres publiques

out ($text='', $nl=true)
- Fonctions membres publiques hérités de CliOutput
__construct (ProcessorInterface $processor=null)
setProcessor (ProcessorInterface $processor)
getProcessor ()
out ($text='', $nl=true)

Membres hérités additionnels

- Attributs protégés hérités de CliOutput
$processor

Description détaillée

Output handler for writing command line output to the stdout interface

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des fonctions membres

◆ out()

out | ( | $text = '',
 |  | $nl = true
 | ) |

Write a string to standard output

Paramètres
string | $text | The text to display.
boolean | $nl | True (default) to append a new line at the end of the output string.
Renvoie
$this
Depuis
4.0.0

Références $text, $this, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Stdout.php


Joomla CMS: Référence de la classe Xml

  • Joomla
  • CMS
  • Application
  • CLI
  • Output
  • Xml
Fonctions membres publiques
Référence de la classe Xml
+ Graphe d'héritage de Xml:
CliOutput

Fonctions membres publiques

out ($text='', $nl=true)
- Fonctions membres publiques hérités de CliOutput
__construct (ProcessorInterface $processor=null)
setProcessor (ProcessorInterface $processor)
getProcessor ()
out ($text='', $nl=true)

Membres hérités additionnels

- Attributs protégés hérités de CliOutput
$processor

Description détaillée

Output handler for writing command line output to the stdout interface

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des fonctions membres

◆ out()

out | ( | $text = '',
 |  | $nl = true
 | ) |

Write a string to standard output.

Paramètres
string | $text | The text to display.
boolean | $nl | True (default) to append a new line at the end of the output string.
Renvoie
$this
Depuis
4.0.0
Exceptions

Références $text, $this, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Application/CLI/Output/Xml.php


Joomla CMS: Référence de la classe CliInput

  • Joomla
  • CMS
  • Application
  • CLI
  • CliInput
Fonctions membres publiques
Référence de la classe CliInput

Fonctions membres publiques

in ()

Description détaillée

Class CliInput

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des fonctions membres

◆ in()

in ( )

Get a value from standard input.

Renvoie
string The input string from standard input.
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CliInput.php


Joomla CMS: Référence de la classe CliOutput

  • Joomla
  • CMS
  • Application
  • CLI
  • CliOutput
Fonctions membres publiques | Attributs protégés
Référence de la classe CliOutput
+ Graphe d'héritage de CliOutput:
Stdout Xml

Fonctions membres publiques

__construct (ProcessorInterface $processor=null)
setProcessor (ProcessorInterface $processor)
getProcessor ()
out ($text='', $nl=true)

Attributs protégés

$processor

Description détaillée

Base class defining a command line output handler

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ProcessorInterface $processor = null )

Constructor

Paramètres
ProcessorInterface $processor The output processor.
Depuis
4.0.0

Documentation des fonctions membres

◆ getProcessor()

getProcessor ( )

Get a processor

Renvoie
ProcessorInterface
Depuis
4.0.0
Exceptions

◆ out()

out | ( | $text = '',
 |  | $nl = true
 | ) |
abstract

Write a string to an output handler.

Paramètres
string | $text | The text to display.
boolean | $nl | True (default) to append a new line at the end of the output string.
Renvoie
$this
Depuis
4.0.0

◆ setProcessor()

setProcessor ( ProcessorInterface $processor )

Set a processor

Paramètres
ProcessorInterface $processor The output processor.
Renvoie
$this
Depuis
4.0.0

Références $this.

Documentation des champs

◆ $processor

$processor
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CliOutput.php


Joomla CMS: Référence de la classe ColorStyle

  • Joomla
  • CMS
  • Application
  • CLI
  • ColorStyle
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés | Attributs privés statiques
Référence de la classe ColorStyle

Fonctions membres publiques

__construct (string $fg='', string $bg='', array $options=[])
__toString ()
getStyle ()
getKnownColors ()
getKnownOptions ()

Fonctions membres publiques statiques

static fromString (string $string)

Attributs privés

$fgColor = 0
$bgColor = 0
$options = []

Attributs privés statiques

static | $knownColors
static | $knownOptions
static | $fgBase = 30
static | $bgBase = 40

Description détaillée

Class defining ANSI-color styles for command line output

Depuis
4.0.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $fg = '',
 |  | string | $bg = '',
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
string | $fg | Foreground color.
string | $bg | Background color.
array | $options | Style options.
Depuis
4.0.0
Exceptions

Références $option, et $options.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Convert to a string.

Renvoie
string
Depuis
4.0.0

◆ fromString()

static fromString ( string $string )
static

Create a color style from a parameter string.

Example: fg=red;bg=blue;options=bold,blink

Paramètres
string $string The parameter string.
Renvoie
$this
Depuis
4.0.0
Exceptions

Références $options, et $parts.

Référencé par ColorProcessor\process().

◆ getKnownColors()

getKnownColors ( )

Get the known colors.

Renvoie
string[]
Depuis
4.0.0

◆ getKnownOptions()

getKnownOptions ( )

Get the known options.

Renvoie
string[]
Depuis
4.0.0

◆ getStyle()

getStyle ( )

Get the translated color code.

Renvoie
string
Depuis
4.0.0

Références $option.

Documentation des champs

◆ $bgBase

$bgBase = 40
staticprivate

◆ $bgColor

$bgColor = 0
private

◆ $fgBase

$fgBase = 30
staticprivate

◆ $fgColor

$fgColor = 0
private

◆ $knownColors

$knownColors
staticprivate
Valeur initiale :
= [
'black' => 0

◆ $knownOptions

$knownOptions
staticprivate
Valeur initiale :
= [
'bold' => 1

◆ $options

$options = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ColorStyle.php


Joomla CMS: Référence de la classe NotAcceptable

  • Joomla
  • CMS
  • Application
  • Exception
  • NotAcceptable
Référence de la classe NotAcceptable
+ Graphe d'héritage de NotAcceptable:

Description détaillée

Exception class defining a not acceptable class

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotAcceptable.php


Joomla CMS: Référence de la classe AdministratorApplication

  • Joomla
  • CMS
  • Application
  • AdministratorApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AdministratorApplication
+ Graphe d'héritage de AdministratorApplication:
CMSApplication WebApplication ContainerAwareInterface CMSWebApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface CMSApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
dispatch ($component=null)
getTemplate ($params=false)
login ($credentials, $options=array())
- Fonctions membres publiques hérités de CMSApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
checkSession ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getCfg ($varname, $default=null)
getClientId ()
getMenu ($name=null, $options=array())
getMessageQueue ($clear=false)
getName ()
getPathway ()
getTemplate ($params=false)
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
isHttpsForced ($clientId=null)
isClient ($identifier)
login ($credentials, $options=array())
logout ($userid=null, $options=array())
redirect ($url, $status=303)
setUserState ($key, $value)
toString ($compress=false)
isCli ()
setMenuFactory (MenuFactoryInterface $menuFactory)
- Fonctions membres publiques hérités de WebApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de CMSWebApplicationInterface
getDocument ()
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de CMSApplicationInterface
getMessageQueue ()
getIdentity ()
getInput ()
getLanguage ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static | getRouter ($name='administrator', array $options=array())
static | purgeMessages ()
- Fonctions membres publiques statiques hérités de CMSApplication
static | getInstance ($name=null, $prefix='\JApplication', Container $container=null)
static | getRouter ($name=null, array $options=array())
- Fonctions membres publiques statiques hérités de WebApplication
static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)

Fonctions membres protégées

doExecute ()
initialiseApp ($options=array())
render ()
route ()
- Fonctions membres protégées hérités de CMSApplication
checkUserRequireReset ($option, $view, $layout, $tasks)
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
isTwoFactorAuthenticationRequired ()
- Fonctions membres protégées hérités de WebApplication
render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$allowedUnprivilegedOptions
- Attributs protégés hérités de CMSApplication
$docOptions = array()
$clientId = null
$messageQueue = array()
$name = null
$profiler = null
$template = null
$pathway = null
$authenticationPluginType = 'authentication'
$menus = []
- Attributs protégés hérités de WebApplication
$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Membres hérités additionnels

- Champs de données hérités de CMSApplication
$scope = null
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client
- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'
- Attributs protégés statiques hérités de CMSApplication
static | $instances = array()
- Attributs protégés statiques hérités de WebApplication
static | $instance

Description détaillée

Joomla! Administrator Application class

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
Container | $container | Dependency injection container.
Depuis
3.2

Références $client, $config, $container, $input, Symfony\Contracts\Service\__construct(), Uri\base(), name, null, et Uri\root().

Documentation des fonctions membres

◆ dispatch()

dispatch ( $component = null )

Dispatch the application

Paramètres
string $component The component which is being rendered.
Renvoie
void
Depuis
3.2

Références $clientId, $component, $document, Factory\$document, $template, Text\_(), Factory\getDocument(), PluginHelper\importPlugin(), null, et Joomla\CMS\Application\triggerEvent().

◆ doExecute()

doExecute ( )
protected

Method to run the Web application routines.

Renvoie
void
Depuis
3.2

Références $options, JDEBUG, et null.

◆ getRouter()

static getRouter | ( |  | $name = 'administrator',
 |  | array | $options = array()
 | ) |  |
static

Return a reference to the Router object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Router
Depuis
3.2
Obsolète:
5.0 Inject the router or load it from the dependency injection container

Implémente CMSWebApplicationInterface.

Références $name, et $options.

◆ getTemplate()

getTemplate ( $params = false )

Gets the name of the current template.

Paramètres
boolean $params True to return the template parameters
Renvoie
string The name of the template.
Depuis
3.2
Exceptions

Références $params, $template, Text\_(), Joomla\CMS\Application\getIdentity(), InputFilter\getInstance(), Joomla\CMS\Application\getLogger(), JPATH_THEMES, et Text\sprintf().

◆ initialiseApp()

initialiseApp ( $options = array() )
protected

Initialise the application.

Paramètres
array $options An optional associative array of configuration settings.
Renvoie
void
Depuis
3.2

Références $lang, $options, $params, $user, LanguageHelper\exists(), ComponentHelper\getParams(), et Factory\getUser().

◆ login()

login | ( | $credentials,
 |  | $options = array()
 | ) |

Login authentication function

Paramètres
array | $credentials | Array('username' => string, 'password' => string)
array | $options | Array('remember' => boolean)
Renvoie
boolean True on success.
Depuis
3.2

Références $lang, $options, $result, Uri\base(), et Joomla\CMS\Application\getIdentity().

◆ purgeMessages()

static purgeMessages ( )
static

Purge the jos_messages table of old messages

Renvoie
void
Depuis
3.2
Obsolète:
5.0 Purge the messages through the model

Références Factory\getApplication(), et Factory\getUser().

◆ render()

render ( )
protected

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
3.2

Références $component, $input, elseif, Session\getFormToken(), Factory\getUser(), et Text\sprintf().

◆ route()

route ( )
protected

Route the application.

Routing is the process of examining the request environment to determine which component should receive the request. The component optional parameters are then set in the request object to be processed when the application is being dispatched.

Renvoie
void
Depuis
3.2

Références $uri, Uri\getInstance(), PluginHelper\importPlugin(), et Joomla\CMS\Application\triggerEvent().

Documentation des champs

◆ $allowedUnprivilegedOptions

$allowedUnprivilegedOptions
protected
Valeur initiale :
= [
'com_login',
'com_ajax',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdministratorApplication.php


Joomla CMS: Référence de la classe ApiApplication

  • Joomla
  • CMS
  • Application
  • ApiApplication
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ApiApplication
+ Graphe d'héritage de ApiApplication:
CMSApplication WebApplication ContainerAwareInterface CMSWebApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface CMSApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (JInputJson $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
addFormatMap ($contentHeader, $format)
getTemplate ($params=false)
getApiRouter ()
dispatch ($component=null)
- Fonctions membres publiques hérités de CMSApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
checkSession ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getCfg ($varname, $default=null)
getClientId ()
getMenu ($name=null, $options=array())
getMessageQueue ($clear=false)
getName ()
getPathway ()
getTemplate ($params=false)
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
isHttpsForced ($clientId=null)
isClient ($identifier)
login ($credentials, $options=array())
logout ($userid=null, $options=array())
redirect ($url, $status=303)
setUserState ($key, $value)
toString ($compress=false)
isCli ()
setMenuFactory (MenuFactoryInterface $menuFactory)
- Fonctions membres publiques hérités de WebApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de CMSWebApplicationInterface
getDocument ()
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de CMSApplicationInterface
getMessageQueue ()
getIdentity ()
getInput ()
getLanguage ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres protégées

doExecute ()
render ()
respond ($options=array())
handlePreflight ($method, $router)
- Fonctions membres protégées hérités de CMSApplication
checkUserRequireReset ($option, $view, $layout, $tasks)
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
isTwoFactorAuthenticationRequired ()
- Fonctions membres protégées hérités de WebApplication
render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$formatMapper = array()
$authenticationPluginType = 'api-authentication'
- Attributs protégés hérités de CMSApplication
$docOptions = array()
$clientId = null
$messageQueue = array()
$name = null
$profiler = null
$template = null
$pathway = null
$authenticationPluginType = 'authentication'
$menus = []
- Attributs protégés hérités de WebApplication
$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CMSApplication
static | getInstance ($name=null, $prefix='\JApplication', Container $container=null)
static | getRouter ($name=null, array $options=array())
- Fonctions membres publiques statiques hérités de WebApplication
static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)
- Champs de données hérités de CMSApplication
$scope = null
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client
- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'
- Attributs protégés statiques hérités de CMSApplication
static | $instances = array()
- Attributs protégés statiques hérités de WebApplication
static | $instance

Description détaillée

Joomla! API Application class

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | JInputJson | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
JInputJson | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
Container | $container | Dependency injection container.
Depuis
4.0.0

Références $client, $config, $container, $input, Symfony\Contracts\Service\__construct(), Uri\base(), name, null, et Uri\root().

Documentation des fonctions membres

◆ addFormatMap()

addFormatMap | ( | $contentHeader,
 |  | $format
 | ) |

Adds a mapping from a content type to the format stored. Note the format type cannot be overwritten.

Paramètres
string | $contentHeader | The content header
string | $format | The content type format
Renvoie
void
Depuis
4.0.0

Références $format.

◆ dispatch()

dispatch ( $component = null )

Dispatch the application

Paramètres
string $component The component which is being rendered.
Renvoie
void
Depuis
4.0.0

Références $component, $document, Factory\$document, Factory\getDocument(), PluginHelper\importPlugin(), null, et Joomla\CMS\Application\triggerEvent().

◆ doExecute()

doExecute ( )
protected

Method to run the application routines.

Most likely you will want to instantiate a controller and execute it, or perform some sort of task directly.

Renvoie
void
Depuis
4.0.0

Références JDEBUG, et null.

◆ getApiRouter()

getApiRouter ( )

Returns the application Router object.

Renvoie
ApiRouter
Depuis
4.0.0
Obsolète:
5.0 Inject the router or load it from the dependency injection container

Références class, et Joomla\DI\getContainer().

◆ getTemplate()

getTemplate ( $params = false )

Gets the name of the current template.

Paramètres
boolean $params True to return the template parameters
Renvoie
string|
Depuis
4.0.0

Références $params, et $template.

◆ handlePreflight()

handlePreflight | ( | $method,
 |  | $router
 | ) |
protected

Handles preflight requests.

Paramètres
String | $method | The REST verb
ApiRouter | $router | The API Routing object
Renvoie
void
Depuis
4.0.0

If not an OPTIONS request or CORS is not enabled, there's nothing useful to do here.

Obtain allowed CORS origin from Global Settings. Set to * (=all) if not set.

Obtain allowed CORS headers from Global Settings. Set to sensible default if not set.

Obtain allowed CORS methods from Global Settings. Set to methods exposed by current route if not set.

Références $method, et $route.

◆ render()

render ( )
protected

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
4.0.0
Note
Rendering should be overridden to get rid of the theme files.

Références $this.

◆ respond()

respond ( $options = array() )
protected

Method to send the application response to the client. All headers will be sent prior to the main application output data.

Paramètres
array $options An optional argument to enable CORS. (Temporary)
Renvoie
void
Depuis
4.0.0

Enable CORS (Cross-origin resource sharing) Obtain allowed CORS origin from Global Settings. Set to * (=all) if not set.

Références null.

Documentation des champs

◆ $authenticationPluginType

$authenticationPluginType = 'api-authentication'
protected

◆ $formatMapper

$formatMapper = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApiApplication.php


Joomla CMS: Référence de la classe ApplicationHelper

  • Joomla
  • CMS
  • Application
  • ApplicationHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe ApplicationHelper

Fonctions membres publiques statiques

static | getComponentName ($default=null)
static | getHash ($seed)
static | stringURLSafe ($string, $language='')
static | getClientInfo ($id=null, $byName=false)
static | addClientInfo ($client)

Attributs protégés statiques

static $_clients = array()

Description détaillée

Application helper functions

Depuis
1.5

Documentation des fonctions membres

◆ addClientInfo()

static addClientInfo ( $client )
static

Adds information for a client.

Paramètres
mixed $client A client identifier either an array or object
Renvoie
boolean True if the information is added. False on error
Depuis
1.6

Références $client, et $info.

◆ getClientInfo()

static getClientInfo | ( | $id = null,
 |  | $byName = false
 | ) |
static

Gets information on a specific client id. This method will be useful in future versions when we start mapping applications in the database.

This method will return a client information array if called with no arguments which can be used to add custom application information.

Paramètres
integer | string | null | $id | A client identifier
boolean | $byName | If true, find the client by its name
Renvoie
|array|void Object describing the client, array containing all the clients or void if $id not known
Depuis
1.5

Références $client, $id, JPATH_ADMINISTRATOR, JPATH_API, JPATH_CLI, JPATH_INSTALLATION, JPATH_SITE, et null.

Référencé par InstallerExtension\__construct(), PackageAdapter\_getExtensionId(), CollectionAdapter\_startElement(), TemplateModel\child(), TemplateModel\copy(), Installer\copyManifest(), TemplateModel\createOverride(), ModuleAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover_install(), ExtensionAdapter\findUpdate(), InstalledModel\getClient(), LanguagesModel\getClient(), PlgSampledataMultilang\getClient(), TemplateModel\getCoreFile(), TemplateModel\getCoreList(), InstalledModel\getData(), TemplateModel\getFiles(), MenutypesModel\getFolders(), TemplateModel\getFont(), TemplatestyleField\getGroups(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), StyleModel\getItem(), ModuleModel\getItem(), TemplatesModel\getItems(), PositionsModel\getItems(), SelectModel\getItems(), TemplateModel\getOverridesList(), MenutypesModel\getTypeOptionsByComponent(), MenutypesModel\getTypeOptionsFromLayouts(), TemplateModel\getUpdatedList(), LanguageAdapter\install(), Installer\parseFiles(), Installer\parseLanguages(), PluginAdapter\prepareDiscoverInstall(), TemplateAdapter\prepareDiscoverInstall(), ModuleAdapter\prepareDiscoverInstall(), StyleModel\preprocessForm(), ModuleModel\preprocessForm(), ItemModel\preprocessForm(), ModuleAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), LanguageAdapter\removeExtensionFiles(), Installer\removeFiles(), LanguageAdapter\resetUserLanguage(), ModulepositionField\setup(), ChromestyleField\setup(), TemplateAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), LanguageAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), ModuleAdapter\setupUninstall(), Templates\thumb(), Templates\thumbModal(), et LanguageAdapter\update().

◆ getComponentName()

static getComponentName ( $default = null )
static

Return the name of the request component [main component]

Paramètres
string $default The default option
Renvoie
string Option (e.g. com_something)
Depuis
1.6

Références $default, $input, $option, et Factory\getApplication().

Référencé par HtmlView\_setPath(), Help\createUrl(), HtmlView\display(), et FileLayout\setComponent().

◆ getHash()

static getHash ( $seed )
static

Provides a secure hash based on a seed

Paramètres
string $seed Seed string.
Renvoie
string A secure hash
Depuis
3.2

Références Factory\getApplication().

Référencé par RegistrationModel\activate(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), Session\getFormToken(), UserController\menulogout(), DownloadModel\populateState(), ResetModel\processResetRequest(), et RegistrationModel\register().

◆ stringURLSafe()

static stringURLSafe | ( | $string,
 |  | $language = ''
 | ) |
static

This method transliterates a string into a URL safe string or returns a URL safe UTF-8 string based on the global configuration

Paramètres
string | $string | String to process
string | $language | Language to transliterate to if unicode slugs are disabled
Renvoie
string Processed string
Depuis
3.2

Références $language, $output, Factory\getApplication(), ComponentHelper\getParams(), OutputFilter\stringURLSafe(), et OutputFilter\stringUrlUnicodeSlug().

Référencé par PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addCategory(), MenuType\check(), MapTable\check(), TagTable\check(), NewsfeedTable\check(), FilterTable\check(), CoreContent\check(), BannerTable\check(), FieldTable\check(), Category\check(), Content\check(), HtmlView\display(), ContactTable\generateAlias(), ConfigHelper\getComponentsWithConfig(), LogtypeField\getOptions(), NewsfeedModel\prepareTable(), LanguageModel\save(), et Menu\store().

Documentation des champs

◆ $_clients

$_clients = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApplicationHelper.php


Joomla CMS: Référence de la classe BaseApplication

  • Joomla
  • CMS
  • Application
  • BaseApplication
Fonctions membres publiques
Référence de la classe BaseApplication
+ Graphe d'héritage de BaseApplication:
AbstractApplication DispatcherAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null)
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()
- Attributs protégés hérités de AbstractApplication
$config

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
Depuis
3.0.0

Références $config, et $input.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseApplication.php


Joomla CMS: Référence de la classe CliApplication

  • Joomla
  • CMS
  • Application
  • CliApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe CliApplication
+ Graphe d'héritage de CliApplication:
AbstractApplication DispatcherAwareInterface CMSApplicationInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface DaemonApplication

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, CliOutput $output=null, CliInput $cliInput=null, DispatcherInterface $dispatcher=null, Container $container=null)
__get ($name)
getInput ()
getLanguage ()
execute ()
getOutput ()
getCliInput ()
out ($text='', $nl=true)
in ()
setOutput (CliOutput $output)
enqueueMessage ($msg, $type=self::MSG_INFO)
getMessageQueue ()
isClient ($identifier)
getSession ()
getConfig ()
isCli ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CMSApplicationInterface
getIdentity ()
getName ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static getInstance ($name=null)

Attributs protégés

$output
$input = null
$cliInput
$language
$messages = []
- Attributs protégés hérités de AbstractApplication
$config

Attributs protégés statiques

static $instance

Membres hérités additionnels

- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Description détaillée

Base class for a Joomla! command line application.

Depuis
2.5.0
Obsolète:
5.0 Use the ConsoleApplication instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | CliOutput | $output = null,
 |  | CliInput | $cliInput = null,
 |  | DispatcherInterface | $dispatcher = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInputCli object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
CliOutput | $output | The output handler.
CliInput | $cliInput | The CLI input handler.
DispatcherInterface | $dispatcher | An optional argument to provide dependency injection for the application's event dispatcher. If the argument is a DispatcherInterface object that object will become the application's event dispatcher, if it is null then the default event dispatcher will be created based on the application's loadDispatcher() method.
Container | $container | Dependency injection container.
Depuis
1.7.0

Références $config, $container, $output, Symfony\Contracts\Service\__construct(), class, Factory\getContainer(), Factory\getLanguage(), language, Joomla\DI\setContainer(), et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to access properties of the application.

Paramètres
string $name The name of the property.
Renvoie
mixed A value if the property name is valid, null otherwise.
Depuis
4.0.0
Obsolète:
5.0 This is a B/C proxy for deprecated read accesses

Références $name, et Joomla\Application\getInput().

◆ enqueueMessage()

enqueueMessage | ( | $msg,
 |  | $type = self::MSG_INFO
 | ) |

Enqueue a system message.

Paramètres
string | $msg | The message to enqueue.
string | $type | The message type.
Renvoie
void
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $type.

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
1.7.0

Implémente ApplicationInterface.

Références Joomla\CMS\Application\triggerEvent().

◆ getCliInput()

getCliInput ( )

Get a CLI input object.

Renvoie
CliInput
Depuis
4.0.0

◆ getConfig()

getConfig ( )

Retrieve the application configuration object.

Renvoie
Registry
Depuis
4.0.0

Références $config.

◆ getInput()

getInput ( )

Method to get the application input object.

Renvoie
Input
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $input.

◆ getInstance()

static getInstance ( $name = null )
static

Returns a reference to the global CliApplication object, only creating it if it doesn't already exist.

This method must be invoked as: $cli = CliApplication::getInstance();

Paramètres
string $name The name (optional) of the Application Cli class to instantiate.
Renvoie
CliApplication
Depuis
1.7.0
Obsolète:
5.0 Load the app through the container
Exceptions

Références $name.

◆ getLanguage()

getLanguage ( )

Method to get the application language object.

Renvoie
Language The language object
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $language.

◆ getMessageQueue()

getMessageQueue ( )

Get the system message queue.

Renvoie
array The system message queue.
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $messages.

◆ getOutput()

getOutput ( )

Get an output object.

Renvoie
CliOutput
Depuis
4.0.0

Références $output.

◆ getSession()

getSession ( )

Method to get the application session object.

Renvoie
SessionInterface The session object
Depuis
4.0.0

Références class.

◆ in()

in ( )

Get a value from standard input.

Renvoie
string The input string from standard input.
Depuis
4.0.0

◆ isCli()

isCli ( )

Flag if the application instance is a CLI or web based application.

Helper function, you should use the native PHP functions to detect if it is a CLI application.

Renvoie
boolean
Depuis
4.0.0
Obsolète:
5.0 Will be removed without replacements

Implémente CMSApplicationInterface.

◆ isClient()

isClient ( $identifier )

Check the client interface by name.

Paramètres
string $identifier String identifier for the application interface
Renvoie
boolean True if this application is of the given type client interface.
Depuis
4.0.0

Implémente CMSApplicationInterface.

◆ out()

out | ( | $text = '',
 |  | $nl = true
 | ) |

Write a string to standard output.

Paramètres
string | $text | The text to display.
boolean | $nl | True (default) to append a new line at the end of the output string.
Renvoie
$this
Depuis
4.0.0

Références $text, $this, et Symfony\Component\Console\Tester\getOutput().

◆ setOutput()

setOutput ( CliOutput $output )

Set an output object.

Paramètres
CliOutput $output CliOutput object
Renvoie
$this
Depuis
3.3

Références $output, et $this.

Documentation des champs

◆ $cliInput

$cliInput
protected

◆ $input

$input = null
protected

◆ $instance

$instance
staticprotected

◆ $language

$language
protected

◆ $messages

$messages = []
protected

◆ $output

$output
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CliApplication.php


Joomla CMS: Référence de la classe CMSApplication

  • Joomla
  • CMS
  • Application
  • CMSApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe CMSApplication
+ Graphe d'héritage de CMSApplication:
WebApplication ContainerAwareInterface CMSWebApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface CMSApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
checkSession ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getCfg ($varname, $default=null)
getClientId ()
getMenu ($name=null, $options=array())
getMessageQueue ($clear=false)
getName ()
getPathway ()
getTemplate ($params=false)
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
isHttpsForced ($clientId=null)
isClient ($identifier)
login ($credentials, $options=array())
logout ($userid=null, $options=array())
redirect ($url, $status=303)
setUserState ($key, $value)
toString ($compress=false)
isCli ()
setMenuFactory (MenuFactoryInterface $menuFactory)
- Fonctions membres publiques hérités de WebApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de CMSWebApplicationInterface
getDocument ()
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de CMSApplicationInterface
getMessageQueue ()
getIdentity ()
getInput ()
getLanguage ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static | getInstance ($name=null, $prefix='\JApplication', Container $container=null)
static | getRouter ($name=null, array $options=array())
- Fonctions membres publiques statiques hérités de WebApplication
static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)

Champs de données

$scope = null
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client
- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'

Fonctions membres protégées

checkUserRequireReset ($option, $view, $layout, $tasks)
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
isTwoFactorAuthenticationRequired ()
- Fonctions membres protégées hérités de WebApplication
render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$docOptions = array()
$clientId = null
$messageQueue = array()
$name = null
$profiler = null
$template = null
$pathway = null
$authenticationPluginType = 'authentication'
$menus = []
- Attributs protégés hérités de WebApplication
$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Attributs protégés statiques

static | $instances = array()
- Attributs protégés statiques hérités de WebApplication
static | $instance

Fonctions membres privées

sanityCheckSystemVariables ()
hasUserConfiguredTwoFactorAuthentication ()
setupLogging ()

Attributs privés

$menuFactory

Description détaillée

Joomla! CMS Application class

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
Container | $container | Dependency injection container.
Depuis
3.2

Références $client, $config, $container, $input, Symfony\Contracts\Service\__construct(), Profiler\getInstance(), JDEBUG, null, et Joomla\DI\setContainer().

Documentation des fonctions membres

◆ checkSession()

checkSession ( )

Checks the user session.

If the session record doesn't exist, initialise it. If session is new, create session variables

Renvoie
void
Depuis
3.2
Exceptions

Références class, Joomla\DI\getContainer(), Joomla\CMS\Application\getIdentity(), et Joomla\Application\getSession().

◆ checkUserRequireReset()

checkUserRequireReset | ( | $option,
 |  | $view,
 |  | $layout,
 |  | $tasks
 | ) |
protected

Check if the user is required to reset their password.

If the user is required to reset their password will be redirected to the page that manage the password reset.

Paramètres
string | $option | The option that manage the password reset
string | $view | The view that manage the password reset
string | $layout | The layout of the view that manage the password reset
string | $tasks | Permitted tasks
Renvoie
void
Exceptions

Références $layout, $name, $option, $task, $url, $user, $view, Text\_(), Route\_(), Factory\getApplication(), et Factory\getUser().

◆ enqueueMessage()

enqueueMessage | ( | $msg,
 |  | $type = self::MSG_INFO
 | ) |

Enqueue a system message.

Paramètres
string | $msg | The message to enqueue.
string | $type | The message type. Default is message.
Renvoie
void
Depuis
3.2

Implémente CMSApplicationInterface.

Références $message, $messages, $type, InputFilter\getInstance(), null, InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

◆ getCfg()

getCfg | ( | $varname,
 |  | $default = null
 | ) |

Gets a configuration value.

Paramètres
string | $varname | The name of the value to get.
string | $default | Default value to return
Renvoie
mixed The user state.
Depuis
3.2
Obsolète:
5.0 Use get() instead

Références $default, Log\add(), et Log\WARNING.

◆ getClientId()

getClientId ( )

Gets the client id of the current running application.

Renvoie
integer A client identifier.
Depuis
3.2

Références $clientId.

◆ getInstance()

static getInstance | ( |  | $name = null,
 |  |  | $prefix = '\JApplication',
 |  | Container | $container = null
 | ) |  |
static

Returns a reference to the global CmsApplication object, only creating it if it doesn't already exist.

This method must be invoked as: $web = CmsApplication::getInstance();

Paramètres
string | $name | The name (optional) of the CmsApplication class to instantiate.
string | $prefix | The class name prefix of the object.
Container | $container | An optional dependency injection container to inject into the application.
Renvoie
CmsApplication
Depuis
3.2
Exceptions

Références $container, $name, $prefix, elseif, Factory\getContainer(), Factory\getUser(), null, et Text\sprintf().

◆ getMenu()

getMenu | ( | $name = null,
 |  | $options = array()
 | ) |

Returns the application object.

Paramètres
string | $name | The name of the application/client.
array | $options | An optional associative array of configuration settings.
Renvoie
AbstractMenu
Depuis
3.2

Implémente CMSWebApplicationInterface.

Références AbstractMenu\$instances, $name, $options, $this, class, Joomla\DI\getContainer(), et null.

◆ getMessageQueue()

getMessageQueue ( $clear = false )

Get the system message queue.

Paramètres
boolean $clear Clear the messages currently attached to the application object
Renvoie
array The system message queue.
Depuis
3.2

Références Joomla\Application\getSession().

◆ getName()

getName ( )

Gets the name of the current running application.

Renvoie
string The name of the application.
Depuis
3.2

Implémente CMSApplicationInterface.

Références $name.

◆ getPathway()

getPathway ( )

Returns the application Pathway object.

Renvoie
Pathway
Depuis
3.2

Références Joomla\DI\getContainer(), Symfony\Contracts\Service\has(), et Text\sprintf().

◆ getRouter()

static getRouter | ( |  | $name = null,
 |  | array | $options = array()
 | ) |  |
static

Returns the application Router object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Router
Depuis
3.2
Obsolète:
5.0 Inject the router or load it from the dependency injection container

Implémente CMSWebApplicationInterface.

Références $app, $name, $options, Factory\getApplication(), et Router\getInstance().

◆ getTemplate()

getTemplate ( $params = false )

Gets the name of the current template.

Paramètres
boolean $params An optional associative array of configuration settings
Renvoie
mixed System is the fallback.
Depuis
3.2

Références $params, et $template.

◆ getUserState()

getUserState | ( | $key,
 |  | $default = null
 | ) |

Gets a user state.

Paramètres
string | $key | The path of the state.
mixed | $default | Optional default value, returned if the internal value is null.
Renvoie
mixed The user state or null.
Depuis
3.2

Implémente CMSWebApplicationInterface.

Références $default, $key, Joomla\Application\getSession(), et null.

◆ getUserStateFromRequest()

getUserStateFromRequest | ( | $key,
 |  | $request,
 |  | $default = null,
 |  | $type = 'none'
 | ) |

Gets the value of a user state variable.

Paramètres
string | $key | The key of the user state variable.
string | $request | The name of the variable passed in a request.
string | $default | The default value for the variable if not found. Optional.
string | $type | Filter for the variable, for valid values see InputFilter::clean(). Optional.
Renvoie
mixed The request user state.
Depuis
3.2

Implémente CMSWebApplicationInterface.

Références $default, $key, $type, et null.

◆ hasUserConfiguredTwoFactorAuthentication()

hasUserConfiguredTwoFactorAuthentication ( )
private

No longer used

Renvoie
boolean
Depuis
4.0.0
Exceptions

◆ initialiseApp()

initialiseApp ( $options = array() )
protected

Initialise the application.

Paramètres
array $options An optional associative array of configuration settings.
Renvoie
void
Depuis
3.2

Références $editor, $lang, Factory\$language, $options, $user, Language\getInstance(), Factory\getUser(), PluginHelper\importPlugin(), PluginHelper\isEnabled(), et Joomla\CMS\Application\triggerEvent().

◆ isCli()

isCli ( )

Flag if the application instance is a CLI or web based application.

Helper function, you should use the native PHP functions to detect if it is a CLI application.

Renvoie
boolean
Depuis
4.0.0
Obsolète:
5.0 Will be removed without replacements

Implémente CMSApplicationInterface.

◆ isClient()

isClient ( $identifier )

Check the client interface by name.

Paramètres
string $identifier String identifier for the application interface
Renvoie
boolean True if this application is of the given type client interface.
Depuis
3.7.0

Implémente CMSApplicationInterface.

◆ isHttpsForced()

isHttpsForced ( $clientId = null )

Checks if HTTPS is forced in the client configuration.

Paramètres
integer $clientId An optional client id (defaults to current application client).
Renvoie
boolean True if is forced for the client, false otherwise.
Depuis
3.7.3

Références $clientId, et null.

◆ isTwoFactorAuthenticationRequired()

isTwoFactorAuthenticationRequired ( )
protected

No longer used

Renvoie
boolean
Depuis
4.0.0
Exceptions

◆ loadLibraryLanguage()

loadLibraryLanguage ( )
protected

Load the library language files for the application

Renvoie
void
Depuis
3.6.3

Références JPATH_ADMINISTRATOR.

◆ login()

login | ( | $credentials,
 |  | $options = array()
 | ) |

Login authentication function.

Username and encoded password are passed the onUserLogin event which is responsible for the user validation. A successful validation updates the current session record with the user's details.

Username and encoded password are sent as credentials (along with other possibilities) to each observer (authentication plugin) for user validation. Successful validation will update the current session with the user details.

Paramètres
array | $credentials | Array('username' => string, 'password' => string)
array | $options | Array('remember' => boolean)
Renvoie
boolean| True on success, false if failed or silent handling is configured, or a object on authentication error.
Depuis
3.2

Références $options, $results, $user, Text\_(), Factory\getApplication(), Authentication\getInstance(), Joomla\CMS\Application\getLogger(), Factory\getUser(), PluginHelper\importPlugin(), Authentication\STATUS_DENIED, Authentication\STATUS_EXPIRED, Authentication\STATUS_SUCCESS, et Joomla\CMS\Application\triggerEvent().

◆ logout()

logout | ( | $userid = null,
 |  | $options = array()
 | ) |

Logout authentication function.

Passed the current user information to the onUserLogout event and reverts the current session record back to 'anonymous' parameters. If any of the authentication plugins did not successfully complete the logout routine then the whole method fails. Any errors raised should be done in the plugin as this provides the ability to give much more information about why the routine may have failed.

Paramètres
integer | $userid | The user to load - Can be an integer or string - If string, it is converted to ID automatically
array | $options | Array('clientid' => array of client id's)
Renvoie
boolean True on success
Depuis
3.2

Références $options, $parameters, $results, $user, Factory\getUser(), PluginHelper\importPlugin(), et Joomla\CMS\Application\triggerEvent().

◆ redirect()

redirect | ( | $url,
 |  | $status = 303
 | ) |

Redirect to another URL.

If the headers have not been sent the redirect will be accomplished using a "301 Moved Permanently" or "303 See Other" code in the header pointing to the new location. If the headers have already been sent this will be accomplished using a JavaScript statement.

Paramètres
string | $url | The URL to redirect to. Can only be http/https URL
integer | $status | The HTTP 1.1 status code to be provided. 303 is assumed by default.
Renvoie
void
Depuis
3.2

Implémente WebApplicationInterface.

Références $url, et Joomla\Application\getSession().

◆ render()

render ( )
protected

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
3.2

Références $data, __DIR__, Factory\getUser(), PluginHelper\importPlugin(), JDEBUG, JPATH_BASE, JPATH_THEMES, null, et Joomla\CMS\Application\triggerEvent().

◆ route()

route ( )
protected

Route the application.

Routing is the process of examining the request environment to determine which component should receive the request. The component optional parameters are then set in the request object to be processed when the application is being dispatched.

Renvoie
void
Depuis
3.2
Obsolète:
5.0 Implement the route functionality in the extending class, this here will be removed without replacement

Références $active, $base, $item, $key, $position, $result, $uri, $value, Uri\base(), Uri\getInstance(), PluginHelper\importPlugin(), null, StringHelper\strtolower(), et Joomla\CMS\Application\triggerEvent().

◆ sanityCheckSystemVariables()

sanityCheckSystemVariables ( )
private

Ensure several core system input variables are not arrays.

Renvoie
void
Depuis
3.9

Références $input, et null.

◆ setMenuFactory()

setMenuFactory ( MenuFactoryInterface $menuFactory )

Sets the internal menu factory.

Paramètres
MenuFactoryInterface $menuFactory The menu factory
Renvoie
void
Depuis
4.2.0

◆ setupLogging()

setupLogging ( )
private

Setup logging functionality.

Renvoie
void
Depuis
4.0.0

Références $mode, Log\addLogger(), Log\ALERT, Log\ALL, Log\CRITICAL, Log\EMERGENCY, et Log\ERROR.

◆ setUserState()

setUserState | ( | $key,
 |  | $value
 | ) |

Sets the value of a user state variable.

Paramètres
string | $key | The path of the state.
mixed | $value | The value of the variable.
Renvoie
mixed|void The previous state, if one existed.
Depuis
3.2

Implémente CMSWebApplicationInterface.

Références $key, $value, Joomla\Application\getSession(), et null.

◆ toString()

toString ( $compress = false )

Sends all headers prior to returning the string

Paramètres
boolean $compress If true, compress the data
Renvoie
string
Depuis
3.2

Références Laminas\Diactoros\getBody().

Documentation des champs

◆ $authenticationPluginType

$authenticationPluginType = 'authentication'
protected

◆ $clientId

$clientId = null
protected

◆ $docOptions

$docOptions = array()
protected

◆ $instances

$instances = array()
staticprotected

◆ $menuFactory

$menuFactory
private

◆ $menus

$menus = []
protected

◆ $messageQueue

$messageQueue = array()
protected

◆ $name

$name = null
protected

◆ $pathway

$pathway = null
protected

◆ $profiler

$profiler = null
protected

◆ $scope

$scope = null

◆ $template

$template = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CMSApplication.php


Joomla CMS: Référence de l'interface CMSApplicationInterface

  • Joomla
  • CMS
  • Application
  • CMSApplicationInterface
Fonctions membres publiques | Champs de données
Référence de l'interface CMSApplicationInterface
+ Graphe d'héritage de CMSApplicationInterface:
ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ApplicationInterface DispatcherAwareInterface CliApplication CMSWebApplicationInterface ConsoleApplication DaemonApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

enqueueMessage ($msg, $type=self::MSG_INFO)
getMessageQueue ()
isClient ($identifier)
isCli ()
getIdentity ()
getInput ()
getLanguage ()
getName ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de ConfigurationAwareApplicationInterface
get ($key, $default=null)
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de ApplicationInterface
close ($code=0)
execute ()
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'

Documentation des fonctions membres

◆ enqueueMessage()

enqueueMessage | ( | $msg,
 |  | $type = self::MSG_INFO
 | ) |

Enqueue a system message.

Paramètres
string | $msg | The message to enqueue.
string | $type | The message type.
Renvoie
void
Depuis
4.0.0

Implémenté dans CliApplication, ConsoleApplication, et CMSApplication.

◆ getIdentity()

getIdentity ( )

Get the application identity.

Renvoie
User|null A User object or null if not set.
Depuis
4.0.0

◆ getInput()

getInput ( )

Method to get the application input object.

Renvoie
Input
Depuis
4.0.0

Implémenté dans ConsoleApplication, et CliApplication.

◆ getLanguage()

getLanguage ( )

Method to get the application language object.

Renvoie
Language The language object
Depuis
4.0.0

Implémenté dans ConsoleApplication, et CliApplication.

◆ getMessageQueue()

getMessageQueue ( )

Get the system message queue.

Renvoie
array The system message queue.
Depuis
4.0.0

Implémenté dans ConsoleApplication, et CliApplication.

◆ getName()

getName ( )

Gets the name of the current running application.

Renvoie
string The name of the application.
Depuis
4.0.0

Implémenté dans CMSApplication, et ConsoleApplication.

Référencé par ComponentDispatcherFactory\createDispatcher(), et RouterFactory\createRouter().

◆ isCli()

isCli ( )

Flag if the application instance is a CLI or web based application.

Helper function, you should use the native PHP functions to detect if it is a CLI application.

Renvoie
boolean
Depuis
4.0.0
Obsolète:
5.0 Will be removed without replacements

Implémenté dans CMSApplication, CliApplication, et ConsoleApplication.

◆ isClient()

isClient ( $identifier )

Check the client interface by name.

Paramètres
string $identifier String identifier for the application interface
Renvoie
boolean True if this application is of the given type client interface.
Depuis
4.0.0

Implémenté dans CMSApplication, ConsoleApplication, et CliApplication.

Référencé par ModuleDispatcherFactory\createDispatcher(), et ComponentDispatcherFactory\createDispatcher().

◆ loadIdentity()

loadIdentity ( User $identity = null )

Allows the application to load a custom or default identity.

Paramètres
User $identity An optional identity object. If omitted, the factory user is created.
Renvoie
$this
Depuis
4.0.0

Documentation des champs

◆ MSG_ALERT

const MSG_ALERT = 'alert'

◆ MSG_CRITICAL

const MSG_CRITICAL = 'critical'

◆ MSG_DEBUG

const MSG_DEBUG = 'debug'

◆ MSG_EMERGENCY

const MSG_EMERGENCY = 'emergency'

◆ MSG_ERROR

const MSG_ERROR = 'error'

◆ MSG_INFO

const MSG_INFO = 'info'

◆ MSG_NOTICE

const MSG_NOTICE = 'notice'

◆ MSG_WARNING

const MSG_WARNING = 'warning'

Référencé par HtmlView\display().

La documentation de cette interface a été générée à partir du fichier suivant :
  • CMSApplicationInterface.php


Joomla CMS: Référence de l'interface CMSWebApplicationInterface

  • Joomla
  • CMS
  • Application
  • CMSWebApplicationInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface CMSWebApplicationInterface
+ Graphe d'héritage de CMSWebApplicationInterface:
SessionAwareWebApplicationInterface CMSApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

getDocument ()
getMenu ($name=null, $options=array())
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
setUserState ($key, $value)
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de WebApplicationInterface
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de ApplicationInterface
close ($code=0)
execute ()
- Fonctions membres publiques hérités de CMSApplicationInterface
enqueueMessage ($msg, $type=self::MSG_INFO)
getMessageQueue ()
isClient ($identifier)
isCli ()
getIdentity ()
getInput ()
getLanguage ()
getName ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de ConfigurationAwareApplicationInterface
get ($key, $default=null)
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static getRouter ($name=null, array $options=array())

Membres hérités additionnels

- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'

Description détaillée

Interface defining a Joomla! CMS Application class for web applications.

Depuis
4.0.0

Documentation des fonctions membres

◆ getDocument()

getDocument ( )

Method to get the application document object.

Renvoie
Document The document object
Depuis
4.0.0

◆ getMenu()

getMenu | ( | $name = null,
 |  | $options = array()
 | ) |

Get the menu object.

Paramètres
string | $name | The application name for the menu
array | $options | An array of options to initialise the menu with
Renvoie
AbstractMenu|null An AbstractMenu object or null if not set.
Depuis
4.0.0

Implémenté dans InstallationApplication, et CMSApplication.

◆ getRouter()

static getRouter | ( |  | $name = null,
 |  | array | $options = array()
 | ) |  |
static

Returns the application Router object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Router
Depuis
4.0.0
Obsolète:
5.0 Inject the router or load it from the dependency injection container

Implémenté dans CMSApplication, SiteApplication, et AdministratorApplication.

◆ getUserState()

getUserState | ( | $key,
 |  | $default = null
 | ) |

Gets a user state.

Paramètres
string | $key | The path of the state.
mixed | $default | Optional default value, returned if the internal value is null.
Renvoie
mixed The user state or null.
Depuis
4.0.0

Implémenté dans CMSApplication.

◆ getUserStateFromRequest()

getUserStateFromRequest | ( | $key,
 |  | $request,
 |  | $default = null,
 |  | $type = 'none'
 | ) |

Gets the value of a user state variable.

Paramètres
string | $key | The key of the user state variable.
string | $request | The name of the variable passed in a request.
string | $default | The default value for the variable if not found. Optional.
string | $type | Filter for the variable, for valid values see InputFilter::clean(). Optional.
Renvoie
mixed The request user state.
Depuis
4.0.0

Implémenté dans CMSApplication.

◆ setUserState()

setUserState | ( | $key,
 |  | $value
 | ) |

Sets the value of a user state variable.

Paramètres
string | $key | The path of the state.
mixed | $value | The value of the variable.
Renvoie
mixed|void The previous state, if one existed. Void otherwise.
Depuis
4.0.0

Implémenté dans CMSApplication.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CMSWebApplicationInterface.php


Joomla CMS: Référence de la classe ConsoleApplication

  • Joomla
  • CMS
  • Application
  • ConsoleApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe ConsoleApplication
+ Graphe d'héritage de ConsoleApplication:
Application DispatcherAwareInterface CMSApplicationInterface AbstractApplication ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (Registry $config, DispatcherInterface $dispatcher, Container $container, Language $language, ?InputInterface $input=null, ?OutputInterface $output=null)
__get ($name)
execute ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getName ()
getConfig ()
getInput ()
getLanguage ()
getMessageQueue ()
getSession ()
isClient ($identifier)
isCli ()
setSession (SessionInterface $session)
flushAssets ()
getLongVersion ()
setName (string $name)
- Fonctions membres publiques hérités de Application
__construct (?InputInterface $input=null, ?OutputInterface $output=null, ?Registry $config=null)
addCommand (AbstractCommand $command)
execute ()
findNamespace (string $namespace)
getAllCommands (string $namespace='')
getCommands ()
getConsoleInput ()
getConsoleOutput ()
getDefinition ()
getHelperSet ()
getLongVersion ()
getName ()
getNamespaces ()
getVersion ()
hasCommand (string $name)
renderThrowable (\Throwable $throwable)
setAutoExit (bool $autoExit)
setCatchThrowables (bool $catchThrowables)
setCommandLoader (Loader\LoaderInterface $loader)
setHelperSet (HelperSet $helperSet)
setName (string $name)
setVersion (string $version)
shouldAutoExit ()
shouldCatchThrowables ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CMSApplicationInterface
getIdentity ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static getRouter ($name=null, array $options=array())

Fonctions membres protégées

doExecute ()
getDefaultCommands ()
populateHttpHost ()
getDefaultInputDefinition ()
- Fonctions membres protégées hérités de Application
configureIO ()
doExecute ()
getCommandName (InputInterface $input)
getDefaultCommands ()
getDefaultInputDefinition ()
getDefaultHelperSet ()
initialise ()
doRenderThrowable (\Throwable $throwable, OutputInterface $output)
runCommand (AbstractCommand $command, InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$input = null
$name = null
$language
- Attributs protégés hérités de AbstractApplication
$config

Attributs privés

$messages = []
$session

Membres hérités additionnels

- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'

Description détaillée

The Joomla! CMS Console Application

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Registry | $config,
 |  | DispatcherInterface | $dispatcher,
 |  | Container | $container,
 |  | Language | $language,
 |  | ?InputInterface | $input = null,
 |  | ?OutputInterface | $output = null
 | ) |  |

Class constructor.

Paramètres
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
DispatcherInterface | $dispatcher | An optional argument to provide dependency injection for the application's event dispatcher. If the argument is a DispatcherInterface object that object will become the application's event dispatcher, if it is null then the default event dispatcher will be created based on the application's loadDispatcher() method.
Container | $container | Dependency injection container.
Language | $language | The language object provisioned for the application.
InputInterface | null | $input | An optional argument to provide dependency injection for the application's input object. If the argument is an InputInterface object that object will become the application's input object, otherwise a default input object is created.
OutputInterface | null | $output | An optional argument to provide dependency injection for the application's output object. If the argument is an OutputInterface object that object will become the application's output object, otherwise a default output object is created.
Depuis
4.0.0

Références $input, $language, $output, Symfony\Contracts\Service\__construct(), language, name, Joomla\DI\setContainer(), et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to access properties of the application.

Paramètres
string $name The name of the property.
Renvoie
mixed A value if the property name is valid, null otherwise.
Depuis
4.0.0
Obsolète:
5.0 This is a B/C proxy for deprecated read accesses

Références $name, et Joomla\Application\getInput().

◆ doExecute()

doExecute ( )
protected

Method to run the application routines.

Renvoie
integer The exit code for the application
Depuis
4.0.0
Exceptions

Références $messages, $method, $style, et $type.

◆ enqueueMessage()

enqueueMessage | ( | $msg,
 |  | $type = self::MSG_INFO
 | ) |

Enqueue a system message.

Paramètres
string | $msg | The message to enqueue.
string | $type | The message type.
Renvoie
void
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $type.

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
4.0.0
Exceptions

Address issues with instantiating WebApplication descendants under CLI.

IMPORTANT! This code must be always be executed before the first use of PluginHelper::importPlugin(). Some plugins will attempt to register an MVCFactory for a component in their service provider. This will in turn try to get the SiteRouter service for the component which tries to get an instance of SiteApplication which will fail with a RuntimeException if the populateHttpHost() method has not already executed.

Implémente ApplicationInterface.

Références PluginHelper\importPlugin().

◆ flushAssets()

flushAssets ( )

Flush the media version to refresh versionable assets

Renvoie
void
Depuis
4.0.0

◆ getConfig()

getConfig ( )

Retrieve the application configuration object.

Renvoie
Registry
Depuis
4.0.0

Références $config.

◆ getDefaultCommands()

getDefaultCommands ( )
protected

Get the commands which should be registered by default to the application.

Renvoie
[]
Depuis
4.0.0

Références Joomla\Database\getDatabase().

◆ getDefaultInputDefinition()

getDefaultInputDefinition ( )
protected

Builds the default input definition.

Renvoie
InputDefinition
Depuis
4.2.1

Références null, InputArgument\REQUIRED, InputOption\VALUE_NONE, et InputOption\VALUE_OPTIONAL.

◆ getInput()

getInput ( )

Method to get the application input object.

Renvoie
Input
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $input.

◆ getLanguage()

getLanguage ( )

Method to get the application language object.

Renvoie
Language The language object
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $language.

◆ getLongVersion()

getLongVersion ( )

Get the long version string for the application.

Overrides the parent method due to conflicting use of the getName method between the console application and the CMS application interface.

Renvoie
string
Depuis
4.0.0

Références JDEBUG.

◆ getMessageQueue()

getMessageQueue ( )

Get the system message queue.

Renvoie
array The system message queue.
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $messages.

◆ getName()

getName ( )

Gets the name of the current running application.

Renvoie
string The name of the application.
Depuis
4.0.0

Implémente CMSApplicationInterface.

Références $name.

◆ getRouter()

static getRouter | ( |  | $name = null,
 |  | array | $options = array()
 | ) |  |
static

Returns the application Router object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Router
Depuis
4.0.6
Exceptions

Références $name, $options, Factory\getApplication(), et Router\getInstance().

◆ getSession()

getSession ( )

Method to get the application session object.

Renvoie
SessionInterface The session object
Depuis
4.0.0

◆ isCli()

isCli ( )

Flag if the application instance is a CLI or web based application.

Helper function, you should use the native PHP functions to detect if it is a CLI application.

Renvoie
boolean
Depuis
4.0.0
Obsolète:
5.0 Will be removed without replacements

Implémente CMSApplicationInterface.

◆ isClient()

isClient ( $identifier )

Check the client interface by name.

Paramètres
string $identifier String identifier for the application interface
Renvoie
boolean True if this application is of the given type client interface.
Depuis
4.0.0

Implémente CMSApplicationInterface.

◆ populateHttpHost()

populateHttpHost ( )
protected

Populates the HTTP_HOST and REQUEST_URI from the URL provided in the –live-site parameter.

If the URL provided is empty or invalid we will use the URL https://joomla.invalid/set/by/console/application just so that the CLI application doesn't crash when a WebApplication descendant is instantiated in it.

This is a practical workaround for using any service depending on a WebApplication descendant under CLI.

Practical example: using a component's MVCFactory which instantiates the SiteRouter service for that component which in turn relies on an instance of SiteApplication.

Renvoie
void
Depuis
4.2.1
Voir également
https://github.com/joomla/joomla-cms/issues/38518

Try to use the live site URL we were given. If all else fails, fall back to https://joomla.invalid/set/by/console/application.

Yes, this is icky but it is the only way to trick WebApplication into compliance.

Voir également
::detectRequestUri

Références $input, $uri, et Uri\getInstance().

◆ setName()

setName ( string $name )

Set the name of the application.

Paramètres
string $name The new application name.
Renvoie
void
Depuis
4.0.0
Exceptions

◆ setSession()

setSession ( SessionInterface $session )

Sets the session for the application to use, if required.

Paramètres
SessionInterface $session A session object.
Renvoie
$this
Depuis
4.0.0

Références $this.

Documentation des champs

◆ $input

$input = null
protected

◆ $language

$language
protected

◆ $messages

$messages = []
private

◆ $name

$name = null
protected

◆ $session

$session
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleApplication.php


Joomla CMS: Référence de la classe DaemonApplication

  • Joomla
  • CMS
  • Application
  • DaemonApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe DaemonApplication
+ Graphe d'héritage de DaemonApplication:
CliApplication AbstractApplication DispatcherAwareInterface CMSApplicationInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (Cli $input=null, Registry $config=null, DispatcherInterface $dispatcher=null)
isActive ()
loadConfiguration ($data)
execute ()
restart ()
stop ()
- Fonctions membres publiques hérités de CliApplication
__construct (Input $input=null, Registry $config=null, CliOutput $output=null, CliInput $cliInput=null, DispatcherInterface $dispatcher=null, Container $container=null)
__get ($name)
getInput ()
getLanguage ()
execute ()
getOutput ()
getCliInput ()
out ($text='', $nl=true)
in ()
setOutput (CliOutput $output)
enqueueMessage ($msg, $type=self::MSG_INFO)
getMessageQueue ()
isClient ($identifier)
getSession ()
getConfig ()
isCli ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CMSApplicationInterface
getIdentity ()
getName ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static | signal ($signal)
- Fonctions membres publiques statiques hérités de CliApplication
static | getInstance ($name=null)

Fonctions membres protégées

changeIdentity ()
daemonize ()
detach ()
fork ()
gc ()
setupSignalHandlers ()
shutdown ($restart=false)
writeProcessIdFile ()
postFork ()
pcntlChildExitStatus ($status)
pcntlFork ()
pcntlSignal ($signal, $handler, $restart=true)
pcntlWait (&$status, $options=0)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$exiting = false
$parentId = 0
$processId = 0
$running = false
- Attributs protégés hérités de CliApplication
$output
$input = null
$cliInput
$language
$messages = []
- Attributs protégés hérités de AbstractApplication
$config

Attributs protégés statiques

static | $signals
- Attributs protégés statiques hérités de CliApplication
static | $instance

Membres hérités additionnels

- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'

Description détaillée

Class to turn CliApplication applications into daemons. It requires CLI and PCNTL support built into PHP.

https://www.php.net/manual/en/features.commandline.php 1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Cli | $input = null,
 |  | Registry | $config = null,
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |

Class constructor.

Paramètres
Cli | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInputCli object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
DispatcherInterface | $dispatcher | An optional argument to provide dependency injection for the application's event dispatcher. If the argument is a DispatcherInterface object that object will become the application's event dispatcher, if it is null then the default event dispatcher will be created based on the application's loadDispatcher() method.
Depuis
1.7.0

Références $config, $input, Symfony\Contracts\Service\__construct(), Log\add(), Log\ERROR, et null.

Documentation des fonctions membres

◆ changeIdentity()

changeIdentity ( )
protected

Method to change the identity of the daemon process and resources.

Renvoie
boolean True if identity successfully changed
Depuis
1.7.0
Voir également
posix_setuid()

Références $info, $user, Log\add(), Log\ERROR, et Log\INFO.

◆ daemonize()

daemonize ( )
protected

Method to put the application into the background.

Renvoie
boolean
Depuis
1.7.0
Exceptions

Références Log\add(), Log\CRITICAL, Log\EMERGENCY, name, et Log\WARNING.

◆ detach()

detach ( )
protected

This is truly where the magic happens. This is where we fork the process and kill the parent process, which is essentially what turns the application into a daemon.

Renvoie
void
Depuis
3.0.0
Exceptions

Références Log\add(), Log\DEBUG, et name.

◆ execute()

execute ( )

Execute the daemon.

Renvoie
void
Depuis
1.7.0

Implémente ApplicationInterface.

Références Log\add(), Log\INFO, name, et Joomla\CMS\Application\triggerEvent().

◆ fork()

fork ( )
protected

Method to fork the process.

Renvoie
integer The child process id to the parent process, zero to the child process.
Depuis
1.7.0
Exceptions

Références Log\add(), Log\DEBUG, et elseif.

◆ gc()

gc ( )
protected

Method to perform basic garbage collection and memory management in the sense of clearing the stat cache. We will probably call this method pretty regularly in our main loop.

Renvoie
void
Depuis
1.7.0

◆ isActive()

isActive ( )

Check to see if the daemon is active. This does not assume that $this daemon is active, but only if an instance of the application is active as a daemon.

Renvoie
boolean True if daemon is active.
Depuis
1.7.0

Références Log\add(), et Log\WARNING.

◆ loadConfiguration()

loadConfiguration ( $data )

Load an object or array into the application configuration object.

Paramètres
mixed $data Either an array or object to be loaded into the configuration object.
Renvoie
DaemonApplication Instance of $this to allow chaining.
Depuis
1.7.0

Références $name, $options, $this, $tmp, et null.

◆ pcntlChildExitStatus()

pcntlChildExitStatus ( $status )
protected

Method to return the exit code of a terminated child process.

Paramètres
integer $status The status parameter is the status parameter supplied to a successful call to pcntl_waitpid().
Renvoie
integer The child process exit code.
Voir également
pcntl_wexitstatus()
Depuis
1.7.3

◆ pcntlFork()

pcntlFork ( )
protected

Method to return the exit code of a terminated child process.

Renvoie
integer On success, the PID of the child process is returned in the parent's thread of execution, and a 0 is returned in the child's thread of execution. On failure, a -1 will be returned in the parent's context, no child process will be created, and a PHP error is raised.
Voir également
pcntl_fork()
Depuis
1.7.3

◆ pcntlSignal()

pcntlSignal | ( | $signal,
 |  | $handler,
 |  | $restart = true
 | ) |
protected

Method to install a signal handler.

Paramètres
integer | $signal | The signal number.
callable | $handler | The signal handler which may be the name of a user created function, or method, or either of the two global constants SIG_IGN or SIG_DFL.
boolean | $restart | Specifies whether system call restarting should be used when this signal arrives.
Renvoie
boolean True on success.
Voir également
pcntl_signal()
Depuis
1.7.3

◆ pcntlWait()

pcntlWait | ( | & | $status,
 |  |  | $options = 0
 | ) |  |
protected

Method to wait on or return the status of a forked child.

Paramètres
integer | &$status | Status information.
integer | $options | If wait3 is available on your system (mostly BSD-style systems), you can provide the optional options parameter.
Renvoie
integer The process ID of the child which exited, -1 on error or zero if WNOHANG was provided as an option (on wait3-available systems) and no child was available.
Voir également
pcntl_wait()
Depuis
1.7.3

Références $options.

◆ postFork()

postFork ( )
protected

Method to handle post-fork triggering of the onFork event.

Renvoie
void
Depuis
3.0.0

Références Joomla\CMS\Application\triggerEvent().

◆ restart()

restart ( )

Restart daemon process.

Renvoie
void
Depuis
1.7.0

Références Log\add(), Log\INFO, et name.

◆ setupSignalHandlers()

setupSignalHandlers ( )
protected

Method to attach the DaemonApplication signal handler to the known signals. Applications can override these handlers by using the pcntl_signal() function and attaching a different callback method.

Renvoie
boolean
Depuis
1.7.0
Voir également
pcntl_signal()

Références Log\add(), Log\DEBUG, Log\EMERGENCY, et null.

◆ shutdown()

shutdown ( $restart = false )
protected

Method to shut down the daemon and optionally restart it.

Paramètres
boolean $restart True to restart the daemon on exit.
Renvoie
void
Depuis
1.7.0

Références Log\add(), et Log\INFO.

◆ signal()

static signal ( $signal )
static

Method to handle POSIX signals.

Paramètres
integer $signal The received POSIX signal.
Renvoie
void
Depuis
1.7.0
Voir également
pcntl_signal()
Exceptions

Références Log\add(), class, Log\DEBUG, et Log\EMERGENCY.

◆ stop()

stop ( )

Stop daemon process.

Renvoie
void
Depuis
1.7.0

Références Log\add(), Log\INFO, et name.

◆ writeProcessIdFile()

writeProcessIdFile ( )
protected

Method to write the process id file out to disk.

Renvoie
boolean
Depuis
1.7.0

Références $folder, Log\add(), Folder\create(), Log\EMERGENCY, et Log\ERROR.

Documentation des champs

◆ $exiting

$exiting = false
protected

◆ $parentId

$parentId = 0
protected

◆ $processId

$processId = 0
protected

◆ $running

$running = false
protected

◆ $signals

$signals
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DaemonApplication.php


Joomla CMS: Référence de l'interface EventAwareInterface

  • Joomla
  • CMS
  • Application
  • EventAwareInterface
Fonctions membres publiques
Référence de l'interface EventAwareInterface
+ Graphe d'héritage de EventAwareInterface:
DispatcherAwareInterface CMSApplicationInterface CliApplication CMSWebApplicationInterface ConsoleApplication DaemonApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

getDispatcher ()
triggerEvent ($eventName, $args=[])
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Description détaillée

Interface defining application that can trigger Joomla 3.x style events

Depuis
4.0.0
Obsolète:
5.0 This interface will be removed as the Joomla 3.x compatibility layer will be removed

Documentation des fonctions membres

◆ getDispatcher()

getDispatcher ( )

Get the event dispatcher.

Renvoie
DispatcherInterface
Depuis
4.0.0
Exceptions

◆ triggerEvent()

triggerEvent | ( | $eventName,
 |  | $args = []
 | ) |

Calls all handlers associated with an event group.

This is a legacy method, implementing old-style (Joomla! 3.x) plugin calls. It's best to go directly through the Dispatcher and handle the returned EventInterface object instead of going through this method. This method is deprecated and will be removed in Joomla! 5.x.

This method will only return the 'result' argument of the event

Paramètres
string | $eventName | The event name.
array | Event | $args | An array of arguments or an Event object (optional).
Renvoie
array An array of results from each function call. Note this will be an empty array if no dispatcher is set.
Depuis
4.0.0
Exceptions
La documentation de cette interface a été générée à partir du fichier suivant :
  • EventAwareInterface.php


Joomla CMS: Référence de la classe SiteApplication

  • Joomla
  • CMS
  • Application
  • SiteApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SiteApplication
+ Graphe d'héritage de SiteApplication:
CMSApplication WebApplication ContainerAwareInterface CMSWebApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface CMSApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
dispatch ($component=null)
getDetectBrowser ()
getLanguageFilter ()
getParams ($option=null)
getPathway ($name='site', $options=array())
login ($credentials, $options=array())
setDetectBrowser ($state=false)
setLanguageFilter ($state=false)
setTemplate ($template, $styleParams=null)
- Fonctions membres publiques hérités de CMSApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
checkSession ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getCfg ($varname, $default=null)
getClientId ()
getMenu ($name=null, $options=array())
getMessageQueue ($clear=false)
getName ()
getPathway ()
getTemplate ($params=false)
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
isHttpsForced ($clientId=null)
isClient ($identifier)
login ($credentials, $options=array())
logout ($userid=null, $options=array())
redirect ($url, $status=303)
setUserState ($key, $value)
toString ($compress=false)
isCli ()
setMenuFactory (MenuFactoryInterface $menuFactory)
- Fonctions membres publiques hérités de WebApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de CMSWebApplicationInterface
getDocument ()
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de CMSApplicationInterface
getMessageQueue ()
getIdentity ()
getInput ()
getLanguage ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres publiques statiques

static | getRouter ($name='site', array $options=array())
- Fonctions membres publiques statiques hérités de CMSApplication
static | getInstance ($name=null, $prefix='\JApplication', Container $container=null)
static | getRouter ($name=null, array $options=array())
- Fonctions membres publiques statiques hérités de WebApplication
static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)

Fonctions membres protégées

authorise ($itemid)
doExecute ()
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
- Fonctions membres protégées hérités de CMSApplication
checkUserRequireReset ($option, $view, $layout, $tasks)
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
isTwoFactorAuthenticationRequired ()
- Fonctions membres protégées hérités de WebApplication
render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$language_filter = false
$detect_browser = false
- Attributs protégés hérités de CMSApplication
$docOptions = array()
$clientId = null
$messageQueue = array()
$name = null
$profiler = null
$template = null
$pathway = null
$authenticationPluginType = 'authentication'
$menus = []
- Attributs protégés hérités de WebApplication
$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Membres hérités additionnels

- Champs de données hérités de CMSApplication
$scope = null
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client
- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'
- Attributs protégés statiques hérités de CMSApplication
static | $instances = array()
- Attributs protégés statiques hérités de WebApplication
static | $instance

Description détaillée

Joomla! Site Application class

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
Container | $container | Dependency injection container.
Depuis
3.2

Références $client, $config, $container, $input, Symfony\Contracts\Service\__construct(), et name.

Documentation des fonctions membres

◆ authorise()

authorise ( $itemid )
protected

Check if the user can access the application

Paramètres
integer $itemid The item ID to check authorisation for
Renvoie
void
Depuis
3.2
Exceptions

Références $itemid, $url, $user, Text\_(), Route\_(), Uri\getInstance(), et Factory\getUser().

◆ dispatch()

dispatch ( $component = null )

Dispatch the application

Paramètres
string $component The component which is being rendered.
Renvoie
void
Depuis
3.2

Références $component, $document, Factory\$document, $params, $template, $this, Uri\current(), PluginHelper\importPlugin(), null, et Joomla\CMS\Application\triggerEvent().

◆ doExecute()

doExecute ( )
protected

Method to run the Web application routines.

Renvoie
void
Depuis
3.2

Références JDEBUG, et null.

◆ getDetectBrowser()

getDetectBrowser ( )

Return the current state of the detect browser option.

Renvoie
boolean
Depuis
3.2

◆ getLanguageFilter()

getLanguageFilter ( )

Return the current state of the language filter.

Renvoie
boolean
Depuis
3.2

◆ getParams()

getParams ( $option = null )

Get the application parameters

Paramètres
string $option The component option
Renvoie
Registry The parameters object
Depuis
3.2

Références $description, $hash, $languages, $menu, $option, $params, $temp, $title, ComponentHelper\getParams(), et null.

◆ getPathway()

getPathway | ( | $name = 'site',
 |  | $options = array()
 | ) |

Return a reference to the Pathway object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Pathway A Pathway object
Depuis
3.2

Références $name, et $options.

◆ getRouter()

static getRouter | ( |  | $name = 'site',
 |  | array | $options = array()
 | ) |  |
static

Return a reference to the Router object.

Paramètres
string | $name | The name of the application.
array | $options | An optional associative array of configuration settings.
Renvoie
Depuis
3.2
Obsolète:
5.0 Inject the router or load it from the dependency injection container

Implémente CMSWebApplicationInterface.

Références $name, et $options.

◆ initialiseApp()

initialiseApp ( $options = array() )
protected

Initialise the application.

Paramètres
array $options An optional associative array of configuration settings.
Renvoie
void
Depuis
3.2

Références $lang, $options, $params, $user, LanguageHelper\detectLanguage(), LanguageHelper\exists(), ComponentHelper\getParams(), PluginHelper\getPlugin(), Factory\getUser(), et null.

◆ loadLibraryLanguage()

loadLibraryLanguage ( )
protected

Load the library language files for the application

Renvoie
void
Depuis
3.6.3

Références JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ login()

login | ( | $credentials,
 |  | $options = array()
 | ) |

Login authentication function

Paramètres
array | $credentials | Array('username' => string, 'password' => string)
array | $options | Array('remember' => boolean)
Renvoie
boolean True on success.
Depuis
3.2

Références $options, et Uri\base().

◆ render()

render ( )
protected

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
3.2

Références $template, $this, Uri\getInstance(), Factory\getUser(), et JPATH_THEMES.

◆ route()

route ( )
protected

Route the application.

Routing is the process of examining the request environment to determine which component should receive the request. The component optional parameters are then set in the request object to be processed when the application is being dispatched.

Renvoie
void
Depuis
3.2

Références $active, $base, $item, $key, $position, $result, $uri, $value, Uri\base(), class, Joomla\DI\getContainer(), Uri\getInstance(), PluginHelper\importPlugin(), null, StringHelper\strtolower(), et Joomla\CMS\Application\triggerEvent().

◆ setDetectBrowser()

setDetectBrowser ( $state = false )

Set the current state of the detect browser option.

Paramètres
boolean $state The new state of the detect browser option
Renvoie
boolean The previous state
Depuis
3.2

Références $state.

◆ setLanguageFilter()

setLanguageFilter ( $state = false )

Set the current state of the language filter.

Paramètres
boolean $state The new state of the language filter
Renvoie
boolean The previous state
Depuis
3.2

Références $state.

◆ setTemplate()

setTemplate | ( | $template,
 |  | $styleParams = null
 | ) |

Overrides the default template that would be used

Paramètres
\stdClass | string | $template | The template name or definition
mixed | $styleParams | The template style parameters
Renvoie
void
Depuis
3.2

Références $template, et JPATH_THEMES.

Documentation des champs

◆ $detect_browser

$detect_browser = false
protected

◆ $language_filter

$language_filter = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteApplication.php


Joomla CMS: Référence de la classe WebApplication

  • Joomla
  • CMS
  • Application
  • WebApplication
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe WebApplication
+ Graphe d'héritage de WebApplication:
AbstractWebApplication AbstractApplication WebApplicationInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)

Fonctions membres protégées

render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Attributs protégés

$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config

Attributs protégés statiques

static $instance

Membres hérités additionnels

- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client

Description détaillée

Base class for a Joomla! Web application.

Depuis
2.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | ResponseInterface | $response = null
 | ) |  |

Class constructor.

Paramètres
Input | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
ResponseInterface | $response | An optional argument to provide dependency injection for the application's response object. If the argument is a ResponseInterface object that object will become the application's response object, otherwise a default response object is created.
Depuis
1.7.3

Références $client, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ afterSessionStart()

afterSessionStart ( SessionEvent $event )

After the session has been started we need to populate it with some default values.

Paramètres
SessionEvent $event Session event being triggered
Renvoie
void
Depuis
3.0.1

Références Joomla\CMS\Application\getIdentity(), SessionEvent\getSession(), et Joomla\CMS\Application\loadIdentity().

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
1.7.3

Implémente ApplicationInterface.

Références Joomla\CMS\Application\triggerEvent().

◆ flushAssets()

flushAssets ( )

Flush the media version to refresh versionable assets

Renvoie
void
Depuis
3.2

◆ getConfig()

getConfig ( )

Retrieve the application configuration object.

Renvoie
Registry
Depuis
4.0.0

Références $config.

◆ getDocument()

getDocument ( )

Method to get the application document object.

Renvoie
Document The document object
Depuis
1.7.3

Références $document.

◆ getInstance()

static getInstance ( $name = null )
static

Returns a reference to the global WebApplication object, only creating it if it doesn't already exist.

This method must be invoked as: $web = WebApplication::getInstance();

Paramètres
string $name The name (optional) of the WebApplication class to instantiate.
Renvoie
WebApplication
Depuis
1.7.3
Exceptions

Références $name.

◆ getLanguage()

getLanguage ( )

Method to get the application language object.

Renvoie
Language The language object
Depuis
1.7.3

Références $language.

◆ loadDocument()

loadDocument ( Document $document = null )

Allows the application to load a custom or default document.

The logic and options for creating this object are adequately generic for default cases but for many applications it will make sense to override this method and create a document, if required, based on more specific needs.

Paramètres
Document $document An optional document object. If omitted, the factory document is created.
Renvoie
WebApplication This method is chainable.
Depuis
1.7.3

Références $document, $this, et Factory\getDocument().

◆ loadLanguage()

loadLanguage ( Language $language = null )

Allows the application to load a custom or default language.

The logic and options for creating this object are adequately generic for default cases but for many applications it will make sense to override this method and create a language, if required, based on more specific needs.

Paramètres
Language $language An optional language object. If omitted, the factory language is created.
Renvoie
WebApplication This method is chainable.
Depuis
1.7.3

Références $language, $this, Factory\getLanguage(), et language.

◆ loadSession()

loadSession ( Session $session = null )

Allows the application to load a custom or default session.

The logic and options for creating this object are adequately generic for default cases but for many applications it will make sense to override this method and create a session, if required, based on more specific needs.

Paramètres
Session $session An optional session object. If omitted, the session is created.
Renvoie
WebApplication This method is chainable.
Depuis
1.7.3
Obsolète:
5.0 The session should be injected as a service.

Références $this, et Joomla\CMS\Application\getLogger().

◆ loadSystemUris()

loadSystemUris ( $requestUri = null )
protected

Method to load the system URI strings for the application.

Paramètres
string $requestUri An optional request URI to use instead of detecting one from the server environment variables.
Renvoie
void
Depuis
1.7.3

Références $path, $uri, et Uri\getInstance().

◆ render()

render ( )
protected

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
1.7.3

Références $data, $options, __DIR__, JPATH_BASE, et JPATH_THEMES.

Documentation des champs

◆ $document

$document
protected

◆ $instance

$instance
staticprotected

◆ $language

$language
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Application/WebApplication.php


Joomla CMS: Référence de la classe AssociationExtensionHelper

  • Joomla
  • CMS
  • Association
  • AssociationExtensionHelper
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe AssociationExtensionHelper
+ Graphe d'héritage de AssociationExtensionHelper:
AssociationExtensionInterface AssociationsHelper AssociationsHelper AssociationsHelper AssociationsHelper

Fonctions membres publiques

hasAssociationsSupport ()
getItemTypes ()
getAssociationList ($typeName, $itemId)
getType ($typeName='')
getTypeFields ($typeName)
getTypeSupport ($typeName)
getTypeTables ($typeName)
getTypeJoins ($typeName)
getTypeTitle ($typeName)
getTypeFieldName ($typeName, $fieldName)
- Fonctions membres publiques hérités de AssociationExtensionInterface
getAssociationsForItem ($id=0, $view=null)

Fonctions membres protégées

getSupportTemplate ()
getFieldsTemplate ()

Attributs protégés

$extension = 'com_??'
$itemTypes = array()
$associationsSupport = false

Fonctions membres privées

getTypeInformation ($typeName, $part='support')

Description détaillée

Association Extension Helper

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociationList()

getAssociationList | ( | $typeName,
 |  | $itemId
 | ) |

Get the associated items for an item

Paramètres
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $itemId, $items, $key, et ArrayHelper\fromObject().

◆ getFieldsTemplate()

getFieldsTemplate ( )
protected

Get default values for fields array

Renvoie
array
Depuis
3.7.0

◆ getItemTypes()

getItemTypes ( )

Get the item types

Renvoie
array Array of item types
Depuis
3.7.0

◆ getSupportTemplate()

getSupportTemplate ( )
protected

Get default values for support array

Renvoie
array
Depuis
3.7.0

◆ getType()

getType ( $typeName = '' )

Get information about the type

Paramètres
string $typeName The item type
Renvoie
array Array of item types
Depuis
3.7.0

Références $fields, et $title.

◆ getTypeFieldName()

getTypeFieldName | ( | $typeName,
 |  | $fieldName
 | ) |

Get a table field name for a type

Paramètres
string | $typeName | The item type
string | $fieldName | The item type
Renvoie
string
Depuis
3.7.0

Références $fields, et $tmp.

◆ getTypeFields()

getTypeFields ( $typeName )

Get information about the fields the type provides

Paramètres
string $typeName The item type
Renvoie
array Array of support information
Depuis
3.7.0

◆ getTypeInformation()

getTypeInformation | ( | $typeName,
 |  | $part = 'support'
 | ) |
private

Get information about the type

Paramètres
string | $typeName | The item type
string | $part | part of the information
Renvoie
array Array of support information
Depuis
3.7.0

Références $type.

◆ getTypeJoins()

getTypeJoins ( $typeName )

Get information about the table joins for the type

Paramètres
string $typeName The item type
Renvoie
array Array of support information
Depuis
3.7.0

◆ getTypeSupport()

getTypeSupport ( $typeName )

Get information about the fields the type provides

Paramètres
string $typeName The item type
Renvoie
array Array of support information
Depuis
3.7.0

◆ getTypeTables()

getTypeTables ( $typeName )

Get information about the tables the type use

Paramètres
string $typeName The item type
Renvoie
array Array of support information
Depuis
3.7.0

◆ getTypeTitle()

getTypeTitle ( $typeName )

Get the type title

Paramètres
string $typeName The item type
Renvoie
string The type title
Depuis
3.7.0

Références $type.

◆ hasAssociationsSupport()

hasAssociationsSupport ( )

Checks if the extension supports associations

Renvoie
boolean Supports the extension associations
Depuis
3.7.0

Implémente AssociationExtensionInterface.

Documentation des champs

◆ $associationsSupport

boolean $associationsSupport = false
protected

Has the extension association support

Depuis
3.7.0

◆ $extension

array $extension = 'com_??'
protected

The extension name

Depuis
3.7.0

◆ $itemTypes

array $itemTypes = array()
protected

Array of item types

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationExtensionHelper.php


Joomla CMS: Référence de l'interface AssociationExtensionInterface

  • Joomla
  • CMS
  • Association
  • AssociationExtensionInterface
Fonctions membres publiques
Référence de l'interface AssociationExtensionInterface
+ Graphe d'héritage de AssociationExtensionInterface:
AssociationExtensionHelper AssociationsHelper AssociationsHelper AssociationsHelper AssociationsHelper

Fonctions membres publiques

hasAssociationsSupport ()
getAssociationsForItem ($id=0, $view=null)

Description détaillée

Association Extension Interface for the helper classes

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociationsForItem()

getAssociationsForItem | ( | $id = 0,
 |  | $view = null
 | ) |

Method to get the associations for a given item.

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
4.0.0

Implémenté dans AssociationsHelper, AssociationsHelper, AssociationsHelper, et AssociationsHelper.

◆ hasAssociationsSupport()

hasAssociationsSupport ( )

Checks if the extension supports associations

Renvoie
boolean Supports the extension associations
Depuis
3.7.0

Implémenté dans AssociationExtensionHelper.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AssociationExtensionInterface.php


Joomla CMS: Référence de l'interface AssociationServiceInterface

  • Joomla
  • CMS
  • Association
  • AssociationServiceInterface
Fonctions membres publiques
Référence de l'interface AssociationServiceInterface
+ Graphe d'héritage de AssociationServiceInterface:
ContactComponent ContentComponent MenusComponent NewsfeedsComponent

Fonctions membres publiques

getAssociationsExtension ()

Description détaillée

The association service.

Depuis
4.0.0

Documentation des fonctions membres

◆ getAssociationsExtension()

getAssociationsExtension ( )

Returns the associations extension helper class.

Renvoie
AssociationExtensionInterface
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • AssociationServiceInterface.php


Joomla CMS: Référence de la classe Argon2idHandler

  • Joomla
  • CMS
  • Authentication
  • Password
  • Argon2idHandler
Fonctions membres publiques
Référence de la classe Argon2idHandler
+ Graphe d'héritage de Argon2idHandler:
Argon2idHandler CheckIfRehashNeededHandlerInterface HandlerInterface

Fonctions membres publiques

checkIfRehashNeeded (string $hash)
- Fonctions membres publiques hérités de Argon2idHandler
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Argon2idHandler
static isSupported ()

Description détaillée

Password handler for Argon2id hashed passwords

Depuis
4.0.0

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

Références $hash.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Authentication/Password/Argon2idHandler.php


Joomla CMS: Référence de la classe Argon2iHandler

  • Joomla
  • CMS
  • Authentication
  • Password
  • Argon2iHandler
Fonctions membres publiques
Référence de la classe Argon2iHandler
+ Graphe d'héritage de Argon2iHandler:
Argon2iHandler CheckIfRehashNeededHandlerInterface HandlerInterface

Fonctions membres publiques

checkIfRehashNeeded (string $hash)
- Fonctions membres publiques hérités de Argon2iHandler
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Argon2iHandler
static isSupported ()

Description détaillée

Password handler for Argon2i hashed passwords

Depuis
4.0.0

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

Références $hash.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Authentication/Password/Argon2iHandler.php


Joomla CMS: Référence de la classe BCryptHandler

  • Joomla
  • CMS
  • Authentication
  • Password
  • BCryptHandler
Fonctions membres publiques
Référence de la classe BCryptHandler
+ Graphe d'héritage de BCryptHandler:
BCryptHandler CheckIfRehashNeededHandlerInterface HandlerInterface

Fonctions membres publiques

checkIfRehashNeeded (string $hash)
- Fonctions membres publiques hérités de BCryptHandler
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BCryptHandler
static isSupported ()

Description détaillée

Password handler for BCrypt hashed passwords

Depuis
4.0.0

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

Références $hash.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Authentication/Password/BCryptHandler.php


Joomla CMS: Référence de la classe ChainedHandler

  • Joomla
  • CMS
  • Authentication
  • Password
  • ChainedHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe ChainedHandler
+ Graphe d'héritage de ChainedHandler:
HandlerInterface CheckIfRehashNeededHandlerInterface

Fonctions membres publiques

addHandler (HandlerInterface $handler)
checkIfRehashNeeded (string $hash)
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$handlers = []

Description détaillée

Password handler supporting testing against a chain of handlers

Depuis
4.0.0

Documentation des fonctions membres

◆ addHandler()

addHandler ( HandlerInterface $handler )

Add a handler to the chain

Paramètres
HandlerInterface $handler The password handler to add
Renvoie
void
Depuis
4.0.0

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

Références $hash, et CheckIfRehashNeededHandlerInterface\checkIfRehashNeeded().

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
void
Depuis
4.0.0
Exceptions

Implémente HandlerInterface.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

Documentation des champs

◆ $handlers

$handlers = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ChainedHandler.php


Joomla CMS: Référence de l'interface CheckIfRehashNeededHandlerInterface

  • Joomla
  • CMS
  • Authentication
  • Password
  • CheckIfRehashNeededHandlerInterface
Fonctions membres publiques
Référence de l'interface CheckIfRehashNeededHandlerInterface
+ Graphe d'héritage de CheckIfRehashNeededHandlerInterface:
Argon2idHandler Argon2iHandler BCryptHandler ChainedHandler MD5Handler PHPassHandler

Fonctions membres publiques

checkIfRehashNeeded (string $hash)

Description détaillée

Interface for a password handler which supports checking if the password requires rehashing

Depuis
4.0.0

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémenté dans ChainedHandler, MD5Handler, PHPassHandler, Argon2idHandler, Argon2iHandler, et BCryptHandler.

Référencé par ChainedHandler\checkIfRehashNeeded().

La documentation de cette interface a été générée à partir du fichier suivant :
  • CheckIfRehashNeededHandlerInterface.php


Joomla CMS: Référence de la classe MD5Handler

  • Joomla
  • CMS
  • Authentication
  • Password
  • MD5Handler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe MD5Handler
+ Graphe d'héritage de MD5Handler:
HandlerInterface CheckIfRehashNeededHandlerInterface

Fonctions membres publiques

checkIfRehashNeeded (string $hash)
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Password handler for MD5 hashed passwords

Depuis
4.0.0
Obsolète:
5.0 Support for MD5 hashed passwords will be removed

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
4.0.0

Implémente HandlerInterface.

Références UserHelper\genRandomPassword().

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

Références $parts, et Crypt\timingSafeCompare().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MD5Handler.php


Joomla CMS: Référence de la classe PHPassHandler

  • Joomla
  • CMS
  • Authentication
  • Password
  • PHPassHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées
Référence de la classe PHPassHandler
+ Graphe d'héritage de PHPassHandler:
HandlerInterface CheckIfRehashNeededHandlerInterface

Fonctions membres publiques

checkIfRehashNeeded (string $hash)
hashPassword ($plaintext, array $options=[])
validatePassword ($plaintext, $hashed)

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres privées

getPasswordHash ()

Description détaillée

Password handler for PHPass hashed passwords

Depuis
4.0.0
Obsolète:
5.0 Support for PHPass hashed passwords will be removed

Documentation des fonctions membres

◆ checkIfRehashNeeded()

checkIfRehashNeeded ( string $hash )

Check if the password requires rehashing

Paramètres
string $hash The password hash to check
Renvoie
boolean
Depuis
4.0.0

Implémente CheckIfRehashNeededHandlerInterface.

◆ getPasswordHash()

getPasswordHash ( )
private

Get an instance of the PasswordHash class

Renvoie
Depuis
4.0.0

◆ hashPassword()

hashPassword | ( |  | $plaintext,
 |  | array | $options = []
 | ) |  |

Generate a hash for a plaintext password

Paramètres
string | $plaintext | The plaintext password to validate
array | $options | Options for the hashing operation
Renvoie
string
Depuis
4.0.0

Implémente HandlerInterface.

◆ isSupported()

static isSupported ( )
static

Check that the password handler is supported in this environment

Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

Références class.

◆ validatePassword()

validatePassword | ( | $plaintext,
 |  | $hashed
 | ) |

Validate a password

Paramètres
string | $plaintext | The plain text password to validate
string | $hashed | The password hash to validate against
Renvoie
boolean
Depuis
4.0.0

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PHPassHandler.php


Joomla CMS: Référence de la classe Authentication

  • Joomla
  • CMS
  • Authentication
  • Authentication
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques
Référence de la classe Authentication

Fonctions membres publiques

__construct (string $pluginType='authentication', DispatcherInterface $dispatcher=null)
authenticate ($credentials, $options=array())
authorise ($response, $options=array())

Fonctions membres publiques statiques

static getInstance (string $pluginType='authentication')

Champs de données

const | STATUS_SUCCESS = 1
const | STATUS_CANCEL = 2
const | STATUS_FAILURE = 4
const | STATUS_EXPIRED = 8
const | STATUS_DENIED = 16
const | STATUS_UNKNOWN = 32

Attributs protégés

$pluginType

Attributs protégés statiques

static $instance = []

Description détaillée

Authentication class, provides an interface for the Joomla authentication system

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $pluginType = 'authentication',
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |

Constructor

Paramètres
string | $pluginType | The plugin type to run authorisation and authentication on
DispatcherInterface | $dispatcher | The event dispatcher we're going to use
Depuis
1.7.0

Références Text\_(), Log\add(), Factory\getContainer(), PluginHelper\importPlugin(), Joomla\Event\setDispatcher(), et Log\WARNING.

Documentation des fonctions membres

◆ authenticate()

authenticate | ( | $credentials,
 |  | $options = array()
 | ) |

Finds out if a set of login credentials are valid by asking all observing objects to run their respective authentication routines.

Paramètres
array | $credentials | Array holding the user credentials.
array | $options | Array holding user options.
Renvoie
AuthenticationResponse Response object with status variable filled in for last plugin or first successful plugin.
Voir également
AuthenticationResponse
Depuis
1.7.0

Perform authentication

Paramètres
string[] $strategies Array of strategies to try - empty to try all strategies.
Renvoie
string|boolean A string containing a username if authentication is successful, false otherwise.
Depuis
1.0
Exceptions

Références $options, Log\add(), Factory\getApplication(), PluginHelper\getPlugin(), Text\sprintf(), et Log\WARNING.

◆ authorise()

authorise | ( | $response,
 |  | $options = array()
 | ) |

Authorises that a particular user should be able to login

Paramètres
AuthenticationResponse | $response | response including username of the user to authorise
array | $options | list of options
Renvoie
AuthenticationResponse[] Array of authentication response objects
Depuis
1.7.0
Exceptions

Références $options, $results, Factory\getApplication(), et PluginHelper\importPlugin().

◆ getInstance()

static getInstance ( string $pluginType = 'authentication' )
static

Returns the global authentication object, only creating it if it doesn't already exist.

Paramètres
string $pluginType The plugin type to run authorisation and authentication on
Renvoie
Authentication The global Authentication object
Depuis
1.7.0

Référencé par UpdateModel\captiveLogin(), et CMSApplication\login().

Documentation des champs

◆ $instance

$instance = []
staticprotected

◆ $pluginType

$pluginType
protected

◆ STATUS_CANCEL

const STATUS_CANCEL = 2

◆ STATUS_DENIED

const STATUS_DENIED = 16

Référencé par CMSApplication\login(), et Token\onUserAuthenticate().

◆ STATUS_EXPIRED

const STATUS_EXPIRED = 8

Référencé par CMSApplication\login().

◆ STATUS_FAILURE

const STATUS_FAILURE = 4

Référencé par Basic\onUserAuthenticate(), et Token\onUserAuthenticate().

◆ STATUS_SUCCESS

const STATUS_SUCCESS = 1

Référencé par UpdateModel\captiveLogin(), CMSApplication\login(), Basic\onUserAuthenticate(), et Token\onUserAuthenticate().

◆ STATUS_UNKNOWN

const STATUS_UNKNOWN = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Authentication/Authentication.php


Joomla CMS: Référence de la classe AuthenticationResponse

  • Joomla
  • CMS
  • Authentication
  • AuthenticationResponse
Champs de données
Référence de la classe AuthenticationResponse

Champs de données

$status = Authentication::STATUS_FAILURE
$type = ''
$error_message = ''
$username = ''
$password = ''
$email = ''
$fullname = ''
$birthdate = ''
$gender = ''
$postcode = ''
$country = ''
$language = ''
$timezone = ''

Description détaillée

Authentication response class, provides an object for storing user and error details

Depuis
1.7.0

Documentation des champs

◆ $birthdate

$birthdate = ''

◆ $country

$country = ''

◆ $email

$email = ''

◆ $error_message

$error_message = ''

◆ $fullname

$fullname = ''

◆ $gender

$gender = ''

◆ $language

$language = ''

◆ $password

$password = ''

◆ $postcode

$postcode = ''

◆ $status

$status = Authentication::STATUS_FAILURE

◆ $timezone

$timezone = ''

◆ $type

$type = ''

◆ $username

$username = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationResponse.php


Joomla CMS: Référence de l'interface ProviderAwareAuthenticationPluginInterface

  • Joomla
  • CMS
  • Authentication
  • ProviderAwareAuthenticationPluginInterface
Fonctions membres publiques statiques
Référence de l'interface ProviderAwareAuthenticationPluginInterface

Fonctions membres publiques statiques

static | isPrimaryProvider ()
static | getProviderName ()

Description détaillée

Interface class defining the necessary methods for an authentication plugin to be provider aware Please note: might be deprecated with Joomla 4.2

Depuis
3.10.7

Documentation des fonctions membres

◆ getProviderName()

static getProviderName ( )
static

Return provider name

Renvoie
string
Depuis
3.10.7

◆ isPrimaryProvider()

static isPrimaryProvider ( )
static

Return if plugin acts as primary provider

Renvoie
true
Depuis
3.10.7
La documentation de cette interface a été générée à partir du fichier suivant :
  • ProviderAwareAuthenticationPluginInterface.php


Joomla CMS: Référence de la classe ClassLoader

  • Joomla
  • CMS
  • Autoload
  • ClassLoader
Fonctions membres publiques | Attributs privés
Référence de la classe ClassLoader

Fonctions membres publiques

__construct (ComposerClassLoader $loader)
loadClass ($class)

Attributs privés

$loader

Description détaillée

Decorate Composer ClassLoader for Joomla!

For backward compatibility due to class aliasing in the CMS, the loadClass() method was modified to call the JLoader::applyAliasFor() method.

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ComposerClassLoader $loader )

Constructor

Paramètres
ComposerClassLoader $loader Composer autoloader
Depuis
3.4

Références $loader.

Documentation des fonctions membres

◆ loadClass()

loadClass ( $class )

Loads the given class or interface.

Paramètres
string $class The name of the class
Renvoie
boolean|null True if loaded, null otherwise
Depuis
3.4

Références $class, $result, et JLoader\applyAliasFor().

Documentation des champs

◆ $loader

$loader
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Autoload/ClassLoader.php


Joomla CMS: Référence de la classe ActionButton

  • Joomla
  • CMS
  • Button
  • ActionButton
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ActionButton
+ Graphe d'héritage de ActionButton:
FeaturedButton PublishedButton TransitionButton

Fonctions membres publiques

__construct (array $options=[])
addState (int $value, string $task, string $icon='ok', string $title='', array $options=[])
getState (int $value)
removeState (int $value)
render (?int $value=null, ?int $row=null, array $options=[])
__toString ()
getLayout ()
setLayout (string $layout)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
fetchIconClass (string $identifier)

Fonctions membres protégées

preprocess ()

Attributs protégés

$states = []
$unknownState
$options
$layout = 'joomla.button.action-button'

Description détaillée

The TaskButton class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = [] )

ActionButton constructor.

Paramètres
array $options The options for all buttons in this group.
Depuis
4.0.0

Références $options, et Text\_().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Render to string.

Renvoie
string
Depuis
4.0.0

◆ addState()

addState | ( | int | $value,
 |  | string | $task,
 |  | string | $icon = 'ok',
 |  | string | $title = '',
 |  | array | $options = []
 | ) |  |

Add a state profile.

Paramètres
integer | $value | The value of this state.
string | $task | The task you want to execute after click this button.
string | $icon | The icon to display for user.
string | $title | Title text will show if we enable tooltips.
array | $options | The button options, will override group options.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $icon, $options, $task, $this, $title, et $value.

◆ fetchIconClass()

fetchIconClass ( string $identifier )

Method to get the CSS class name for an icon identifier.

Can be redefined in the final class.

Paramètres
string $identifier Icon identification string.
Renvoie
string CSS class name.
Depuis
4.0.0

Références $layout.

◆ getLayout()

getLayout ( )

Method to get property layout.

Renvoie
string
Depuis
4.0.0

Références $layout.

◆ getOption()

getOption | ( | string | $name,
 |  |  | $default = null
 | ) |  |

Get an option value.

Paramètres
string | $name | The option name.
mixed | $default | Default value if not exists.
Renvoie
mixed Return option value or default value.
Depuis
4.0.0

Références $default, et $name.

◆ getOptions()

getOptions ( )

Method to get property options.

Renvoie
array
Depuis
4.0.0

◆ getState()

getState ( int $value )

Get state profile by value name.

Paramètres
integer $value The value name we want to get.
Renvoie
array|null Return state profile or NULL.
Depuis
4.0.0

Références $value, et null.

◆ preprocess()

preprocess ( )
protected

Configure this object.

Renvoie
void
Depuis
4.0.0

◆ removeState()

removeState ( int $value )

Remove a state by value name.

Paramètres
integer $value Remove state by this value.
Renvoie
static Return to support chaining.
Depuis
4.0.0

Références $this, et $value.

◆ render()

render | ( | ?int | $value = null,
 |  | ?int | $row = null,
 |  | array | $options = []
 | ) |  |

Render action button by item value.

Paramètres
integer | null | $value | Current value of this item.
integer | null | $row | The row number of this item.
array | $options | The options to override group options.
Renvoie
string Rendered HTML.
Depuis
4.0.0
Exceptions

Références $data, $options, $value, Joomla\CMS\MVC\Model\getState(), ArrayHelper\mergeRecursive(), et LayoutHelper\render().

◆ setLayout()

setLayout ( string $layout )

Method to set property template.

Paramètres
string $layout The layout path.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $layout, et $this.

◆ setOption()

setOption | ( | string | $name,
 |  |  | $value
 | ) |  |

Set option value.

Paramètres
string | $name | The option name.
mixed | $value | The option value.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $name, $this, et $value.

◆ setOptions()

setOptions ( array $options )

Method to set property options.

Paramètres
array $options The options of this button group.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $options, et $this.

Documentation des champs

◆ $layout

$layout = 'joomla.button.action-button'
protected

◆ $options

$options
protected

◆ $states

$states = []
protected

◆ $unknownState

$unknownState
protected
Valeur initiale :
= [
'value' => null
La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionButton.php


Joomla CMS: Référence de la classe FeaturedButton

  • Joomla
  • CMS
  • Button
  • FeaturedButton
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FeaturedButton
+ Graphe d'héritage de FeaturedButton:
ActionButton

Fonctions membres publiques

render (?int $value=null, ?int $row=null, array $options=[], $featuredUp=null, $featuredDown=null)
- Fonctions membres publiques hérités de ActionButton
__construct (array $options=[])
addState (int $value, string $task, string $icon='ok', string $title='', array $options=[])
getState (int $value)
removeState (int $value)
render (?int $value=null, ?int $row=null, array $options=[])
__toString ()
getLayout ()
setLayout (string $layout)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
fetchIconClass (string $identifier)

Fonctions membres protégées

preprocess ()
- Fonctions membres protégées hérités de ActionButton
preprocess ()

Membres hérités additionnels

- Attributs protégés hérités de ActionButton
$states = []
$unknownState
$options
$layout = 'joomla.button.action-button'

Description détaillée

The FeaturedButton class.

Depuis
4.0.0

Documentation des fonctions membres

◆ preprocess()

preprocess ( )
protected

Configure this object.

Renvoie
void
Depuis
4.0.0

Références Text\_().

◆ render()

render | ( | ?int | $value = null,
 |  | ?int | $row = null,
 |  | array | $options = [],
 |  |  | $featuredUp = null,
 |  |  | $featuredDown = null
 | ) |  |

Render action button by item value.

Paramètres
integer | null | $value | Current value of this item.
integer | null | $row | The row number of this item.
array | $options | The options to override group options.
string | Date | $featuredUp | The date which item featured up.
string | Date | $featuredDown | The date which item featured down.
Renvoie
string Rendered HTML.
Depuis
4.0.0

Références $default, $html, $nowDate, $options, $value, Text\_(), HTMLHelper\_(), false, Factory\getDate(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FeaturedButton.php


Joomla CMS: Référence de la classe PublishedButton

  • Joomla
  • CMS
  • Button
  • PublishedButton
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PublishedButton
+ Graphe d'héritage de PublishedButton:
ActionButton

Fonctions membres publiques

render (?int $value=null, ?int $row=null, array $options=[], $publishUp=null, $publishDown=null)
- Fonctions membres publiques hérités de ActionButton
__construct (array $options=[])
addState (int $value, string $task, string $icon='ok', string $title='', array $options=[])
getState (int $value)
removeState (int $value)
render (?int $value=null, ?int $row=null, array $options=[])
__toString ()
getLayout ()
setLayout (string $layout)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
fetchIconClass (string $identifier)

Fonctions membres protégées

preprocess ()
- Fonctions membres protégées hérités de ActionButton
preprocess ()

Membres hérités additionnels

- Attributs protégés hérités de ActionButton
$states = []
$unknownState
$options
$layout = 'joomla.button.action-button'

Description détaillée

The PublishedButton class.

Depuis
4.0.0

Documentation des fonctions membres

◆ preprocess()

preprocess ( )
protected

Configure this object.

Renvoie
void
Depuis
4.0.0

Références Text\_().

◆ render()

render | ( | ?int | $value = null,
 |  | ?int | $row = null,
 |  | array | $options = [],
 |  |  | $publishUp = null,
 |  |  | $publishDown = null
 | ) |  |

Render action button by item value.

Paramètres
integer | null | $value | Current value of this item.
integer | null | $row | The row number of this item.
array | $options | The options to override group options.
string | Date | $publishUp | The date which item publish up.
string | Date | $publishDown | The date which item publish down.
Renvoie
string Rendered HTML.
Depuis
4.0.0

Références $default, $html, $nowDate, $options, $value, Text\_(), HTMLHelper\_(), false, Factory\getDate(), Factory\getDbo(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PublishedButton.php


Joomla CMS: Référence de la classe TransitionButton

  • Joomla
  • CMS
  • Button
  • TransitionButton
Fonctions membres publiques | Attributs protégés
Référence de la classe TransitionButton
+ Graphe d'héritage de TransitionButton:
ActionButton

Fonctions membres publiques

__construct (array $options=[])
render (?int $value=null, ?int $row=null, array $options=[])
- Fonctions membres publiques hérités de ActionButton
__construct (array $options=[])
addState (int $value, string $task, string $icon='ok', string $title='', array $options=[])
getState (int $value)
removeState (int $value)
render (?int $value=null, ?int $row=null, array $options=[])
__toString ()
getLayout ()
setLayout (string $layout)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
fetchIconClass (string $identifier)

Attributs protégés

$layout = 'joomla.button.transition-button'
- Attributs protégés hérités de ActionButton
$states = []
$unknownState
$options
$layout = 'joomla.button.action-button'

Membres hérités additionnels

- Fonctions membres protégées hérités de ActionButton
preprocess ()

Description détaillée

The PublishedButton class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = [] )

ActionButton constructor.

Paramètres
array $options The options for all buttons in this group.
Depuis
4.0.0

Références $options, Text\_(), et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ render()

render | ( | ?int | $value = null,
 |  | ?int | $row = null,
 |  | array | $options = []
 | ) |  |

Render action button by item value.

Paramètres
integer | null | $value | Current value of this item.
integer | null | $row | The row number of this item.
array | $options | The options to override group options.
Renvoie
string Rendered HTML.
Depuis
4.0.0

Références $default, $options, et $value.

Documentation des champs

◆ $layout

$layout = 'joomla.button.transition-button'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionButton.php


Joomla CMS: Référence de la classe CallbackController

  • Joomla
  • CMS
  • Cache
  • Controller
  • CallbackController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe CallbackController
+ Graphe d'héritage de CallbackController:
CacheController

Fonctions membres publiques

store ($data, $id, $group=null, $wrkarounds=true)
- Fonctions membres publiques hérités de CacheController
__construct ($options)
__call ($name, $arguments)

Fonctions membres protégées

_makeId ($callback, $args)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CacheController
static | getInstance ($type='output', $options=array())
static | addIncludePath ($path='')
- Champs de données hérités de CacheController
$cache
$options

Description détaillée

Joomla! Cache callback type object

Depuis
1.7.0

Documentation des fonctions membres

◆ _makeId()

_makeId | ( | $callback,
 |  | $args
 | ) |
protected

Generate a callback cache ID

Paramètres
mixed | $callback | Callback to cache
array | $args | Arguments to the callback method to cache
Renvoie
string MD5 Hash
Depuis
1.7.0

Références $hash.

◆ store()

store | ( | $data,
 |  | $id,
 |  | $group = null,
 |  | $wrkarounds = true
 | ) |

Store data to cache by ID and group

Paramètres
mixed | $data | The data to store
string | $id | The cache data ID
string | $group | The cache data group
boolean | $wrkarounds | True to use wrkarounds
Renvoie
boolean True if cache stored
Depuis
4.0.0

Références $data, $id, et $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Cache/Controller/CallbackController.php


Joomla CMS: Référence de la classe OutputController

  • Joomla
  • CMS
  • Cache
  • Controller
  • OutputController
Fonctions membres publiques | Attributs protégés
Référence de la classe OutputController
+ Graphe d'héritage de OutputController:
CacheController

Fonctions membres publiques

get ($id, $group=null)
store ($data, $id, $group=null, $wrkarounds=true)
- Fonctions membres publiques hérités de CacheController
__construct ($options)
__call ($name, $arguments)

Attributs protégés

$_id
$_group

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CacheController
static | getInstance ($type='output', $options=array())
static | addIncludePath ($path='')
- Champs de données hérités de CacheController
$cache
$options

Description détaillée

Joomla Cache output type object

Depuis
1.7.0

Documentation des fonctions membres

◆ get()

get | ( | $id,
 |  | $group = null
 | ) |

Get stored cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
mixed Boolean false on no result, cached object otherwise
Depuis
1.7.0

Références $data, et $id.

◆ store()

store | ( | $data,
 |  | $id,
 |  | $group = null,
 |  | $wrkarounds = true
 | ) |

Store data to cache by ID and group

Paramètres
mixed | $data | The data to store
string | $id | The cache data ID
string | $group | The cache data group
boolean | $wrkarounds | True to use wrkarounds
Renvoie
boolean True if cache stored
Depuis
1.7.0

Références $data, $id, et $result.

Documentation des champs

◆ $_group

$_group
protected

◆ $_id

$_id
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • OutputController.php


Joomla CMS: Référence de la classe PageController

  • Joomla
  • CMS
  • Cache
  • Controller
  • PageController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PageController
+ Graphe d'héritage de PageController:
CacheController

Fonctions membres publiques

get ($id=false, $group='page')
store ($data, $id, $group=null, $wrkarounds=true)
- Fonctions membres publiques hérités de CacheController
__construct ($options)
__call ($name, $arguments)

Fonctions membres protégées

_makeId ()
_noChange ()
_setEtag ($etag)

Attributs protégés

$_id
$_group
$_locktest = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CacheController
static | getInstance ($type='output', $options=array())
static | addIncludePath ($path='')
- Champs de données hérités de CacheController
$cache
$options

Description détaillée

Joomla! Cache page type object

Depuis
1.7.0

Documentation des fonctions membres

◆ _makeId()

_makeId ( )
protected

Generate a page cache id

Renvoie
string MD5 Hash
Depuis
1.7.0

Références Cache\makeId().

◆ _noChange()

_noChange ( )
protected

There is no change in page data so send an unmodified header and die gracefully

Renvoie
void
Depuis
1.7.0

Références $app, et Factory\getApplication().

◆ _setEtag()

_setEtag ( $etag )
protected

Set the ETag header in the response

Paramètres
string $etag The entity tag (etag) to set
Renvoie
void
Depuis
1.7.0

Références Factory\getApplication().

◆ get()

get | ( | $id = false,
 |  | $group = 'page'
 | ) |

Get the cached page data

Paramètres
boolean | $id | The cache data ID
string | $group | The cache data group
Renvoie
mixed Boolean false on no result, cached object otherwise
Depuis
1.7.0

Références $data, $id, $this, Cache\getWorkarounds(), et null.

◆ store()

store | ( | $data,
 |  | $id,
 |  | $group = null,
 |  | $wrkarounds = true
 | ) |

Stop the cache buffer and store the cached data

Paramètres
mixed | $data | The data to store
string | $id | The cache data ID
string | $group | The cache data group
boolean | $wrkarounds | True to use workarounds
Renvoie
boolean
Depuis
1.7.0

Références $data, $id, $result, $this, Factory\getApplication(), et Cache\setWorkarounds().

Documentation des champs

◆ $_group

$_group
protected

◆ $_id

$_id
protected

◆ $_locktest

$_locktest = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PageController.php


Joomla CMS: Référence de la classe ViewController

  • Joomla
  • CMS
  • Cache
  • Controller
  • ViewController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ViewController
+ Graphe d'héritage de ViewController:
CacheController

Fonctions membres publiques

get ($view, $method='display', $id=false, $wrkarounds=true)
store ($data, $id, $group=null, $wrkarounds=true)
- Fonctions membres publiques hérités de CacheController
__construct ($options)
__call ($name, $arguments)

Fonctions membres protégées

_makeId ($view, $method)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CacheController
static | getInstance ($type='output', $options=array())
static | addIncludePath ($path='')
- Champs de données hérités de CacheController
$cache
$options

Description détaillée

Joomla! Cache view type object

Depuis
1.7.0

Documentation des fonctions membres

◆ _makeId()

_makeId | ( | $view,
 |  | $method
 | ) |
protected

Generate a view cache ID.

Paramètres
object | $view | The view object to cache output for
string | $method | The method name to cache for the view object
Renvoie
string MD5 Hash
Depuis
1.7.0

Références $method, $view, et Cache\makeId().

◆ get()

get | ( | $view,
 |  | $method = 'display',
 |  | $id = false,
 |  | $wrkarounds = true
 | ) |

Get the cached view data

Paramètres
object | $view | The view object to cache output for
string | $method | The method name of the view method to cache output for
mixed | $id | The cache data ID
boolean | $wrkarounds | True to enable workarounds.
Renvoie
boolean True if the cache is hit (false else)
Depuis
1.7.0

Références $data, $id, $method, $view, Cache\getWorkarounds(), null, et Cache\setWorkarounds().

◆ store()

store | ( | $data,
 |  | $id,
 |  | $group = null,
 |  | $wrkarounds = true
 | ) |

Store data to cache by ID and group

Paramètres
mixed | $data | The data to store
string | $id | The cache data ID
string | $group | The cache data group
boolean | $wrkarounds | True to use wrkarounds
Renvoie
boolean True if cache stored
Depuis
4.0.0

Références $data, $id, et $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ViewController.php


Joomla CMS: Référence de la classe CacheConnectingException

  • Joomla
  • CMS
  • Cache
  • Exception
  • CacheConnectingException
Référence de la classe CacheConnectingException
+ Graphe d'héritage de CacheConnectingException:
CacheExceptionInterface

Description détaillée

Exception class defining an error connecting to the cache storage engine

Depuis
3.6.3
La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheConnectingException.php


Joomla CMS: Référence de l'interface CacheExceptionInterface

  • Joomla
  • CMS
  • Cache
  • Exception
  • CacheExceptionInterface
Référence de l'interface CacheExceptionInterface
+ Graphe d'héritage de CacheExceptionInterface:
CacheConnectingException UnsupportedCacheException

Description détaillée

Exception interface defining a cache storage error

Depuis
3.7.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • CacheExceptionInterface.php


Joomla CMS: Référence de la classe UnsupportedCacheException

  • Joomla
  • CMS
  • Cache
  • Exception
  • UnsupportedCacheException
Référence de la classe UnsupportedCacheException
+ Graphe d'héritage de UnsupportedCacheException:
CacheExceptionInterface

Description détaillée

Exception class defining an unsupported cache storage object

Depuis
3.6.3
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedCacheException.php


Joomla CMS: Référence de la classe ApcuStorage

  • Joomla
  • CMS
  • Cache
  • Storage
  • ApcuStorage
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe ApcuStorage
+ Graphe d'héritage de ApcuStorage:
CacheStorage

Fonctions membres publiques

contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)
- Fonctions membres publiques hérités de CacheStorage
__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de CacheStorage
static | isSupported ()
static | addIncludePath ($path='')

Membres hérités additionnels

- Champs de données hérités de CacheStorage
$_now
$_lifetime
$_locking
$_language
$_application
$_hash
- Fonctions membres protégées hérités de CacheStorage
_getCacheId ($id, $group)
- Attributs protégés hérités de CacheStorage
$rawname

Description détaillée

APCu cache storage handler

3.5

Documentation des fonctions membres

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
3.5

Références $key, $mode, et elseif.

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

Références $id.

◆ gc()

gc ( )

Garbage collect expired cache data

Renvoie
boolean
Depuis
3.5

Références $key, et elseif.

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.5

Références $id.

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.5

Références $data, $item, $key, $name, et elseif.

◆ isSupported()

static isSupported ( )
static

Test to see if the storage handler is available.

Renvoie
boolean
Depuis
3.5

◆ lock()

lock | ( | $id,
 |  | $group,
 |  | $locktime
 | ) |

Lock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
integer | $locktime | Cached item max lock time
Renvoie
mixed Boolean false if locking failed or an object containing properties lock and locklooped
Depuis
3.5

Références $id, et Joomla\Database\Query\$returning.

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.5

Références $id.

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
3.5

Références $data, et $id.

◆ unlock()

unlock | ( | $id,
 |  | $group = null
 | ) |

Unlock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.5

Références $id.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApcuStorage.php


Joomla CMS: Référence de la classe CacheStorageHelper

  • Joomla
  • CMS
  • Cache
  • Storage
  • CacheStorageHelper
Fonctions membres publiques | Champs de données
Référence de la classe CacheStorageHelper

Fonctions membres publiques

__construct ($group)
updateSize ($size)

Champs de données

$group = ''
$size = 0
$count = 0

Description détaillée

Cache storage helper functions.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $group )

Constructor

Paramètres
string $group The cache data group
Depuis
1.7.0

Documentation des fonctions membres

◆ updateSize()

updateSize ( $size )

Increase cache items count.

Paramètres
string $size Cached item size
Renvoie
void
Depuis
1.7.0

Références $size.

Documentation des champs

◆ $count

$count = 0

◆ $group

$group = ''

◆ $size

$size = 0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheStorageHelper.php


Joomla CMS: Référence de la classe FileStorage

  • Joomla
  • CMS
  • Cache
  • Storage
  • FileStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FileStorage
+ Graphe d'héritage de FileStorage:
CacheStorage

Fonctions membres publiques

__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)
- Fonctions membres publiques hérités de CacheStorage
__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres protégées

_checkExpire ($id, $group)
_getFilePath ($id, $group)
_deleteFolder ($path)
_cleanPath ($path, $ds=DIRECTORY_SEPARATOR)
_filesInFolder ($path, $filter='.', $recurse=false, $fullpath=false, $exclude=array('.svn', 'CVS', '.DS_Store', '__MACOSX'), $excludefilter=array('^\..*', '.*~'))
_folders ($path, $filter='.', $recurse=false, $fullpath=false, $exclude=array('.svn', 'CVS', '.DS_Store', '__MACOSX'), $excludefilter=array('^\..*'))
- Fonctions membres protégées hérités de CacheStorage
_getCacheId ($id, $group)

Attributs protégés

$_root
$_locked_files = array()
- Attributs protégés hérités de CacheStorage
$rawname

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CacheStorage
static | isSupported ()
static | addIncludePath ($path='')
- Champs de données hérités de CacheStorage
$_now
$_lifetime
$_locking
$_language
$_application
$_hash

Description détaillée

File cache storage handler

Depuis
1.7.0
Note
For performance reasons this class does not use the Filesystem package's API

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options Optional parameters
Depuis
1.7.0

Références $options, $path, Symfony\Contracts\Service\__construct(), et File\invalidateFileCache().

Documentation des fonctions membres

◆ _checkExpire()

_checkExpire | ( | $id,
 |  | $group
 | ) |
protected

Check if a cache object has expired

Using @ error suppressor here because between if we did a file_exists() and then filemsize() there will be a little time space when another process can delete the file and then you get PHP Warning

Paramètres
string | $id | Cache ID to check
string | $group | The cache data group
Renvoie
boolean True if the cache ID is valid
Depuis
1.7.0

Références $id, $path, et File\invalidateFileCache().

◆ _cleanPath()

_cleanPath | ( | $path,
 |  | $ds = DIRECTORY_SEPARATOR
 | ) |
protected

Function to strip additional / or \ in a path name

Paramètres
string | $path | The path to clean
string | $ds | Directory separator (optional)
Renvoie
string The cleaned path
Depuis
1.7.0

Références $path.

◆ _deleteFolder()

_deleteFolder ( $path )
protected

Quickly delete a folder of files

Paramètres
string $path The path to the folder to delete.
Renvoie
boolean
Depuis
1.7.0

Références $folder, $path, Text\_(), Log\add(), elseif, File\invalidateFileCache(), Text\sprintf(), et Log\WARNING.

◆ _filesInFolder()

_filesInFolder | ( | $path,
 |  | $filter = '.',
 |  | $recurse = false,
 |  | $fullpath = false,
 |  | $exclude = array('.svn', 'CVS', '.DS_Store', '__MACOSX'),
 |  | $excludefilter = array('^\..*', '.*~')
 | ) |
protected

Utility function to quickly read the files in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for file names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $fullpath | True to return the full path to the file.
array | $exclude | Array with names of files which should not be shown in the result.
array | $excludefilter | Array of folder names to exclude
Renvoie
array Files in the given folder.
Depuis
1.7.0

Références $dir, $path, Log\add(), Text\sprintf(), et Log\WARNING.

◆ _folders()

_folders | ( | $path,
 |  | $filter = '.',
 |  | $recurse = false,
 |  | $fullpath = false,
 |  | $exclude = array('.svn', 'CVS', '.DS_Store', '__MACOSX'),
 |  | $excludefilter = array('^\..*')
 | ) |
protected

Utility function to read the folders in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for folder names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $fullpath | True to return the full path to the folders.
array | $exclude | Array with names of folders which should not be shown in the result.
array | $excludefilter | Array with regular expressions matching folders which should not be shown in the result.
Renvoie
array Folders in the given folder.
Depuis
1.7.0

Références $dir, $path, Log\add(), Text\sprintf(), et Log\WARNING.

◆ _getFilePath()

_getFilePath | ( | $id,
 |  | $group
 | ) |
protected

Get a cache file path from an ID/group pair

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean|string The path to the data object or boolean false if the cache directory does not exist
Depuis
1.7.0

Références $dir, $id, et $name.

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
1.7.0

Références $folder, $i, $mode, $n, et $return.

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

Références $id.

◆ gc()

gc ( )

Garbage collect expired cache data

Renvoie
boolean
Depuis
1.7.0

Références $result, et File\invalidateFileCache().

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0

Références $data, $id, et $path.

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0

Références $data, $folder, $item, et $path.

◆ lock()

lock | ( | $id,
 |  | $group,
 |  | $locktime
 | ) |

Lock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
integer | $locktime | Cached item max lock time
Renvoie
mixed Boolean false if locking failed or an object containing properties lock and locklooped
Depuis
1.7.0

Références $id, $path, et Joomla\Database\Query\$returning.

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Références $id, $path, et File\invalidateFileCache().

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
1.7.0

Références $data, $id, $path, et $result.

◆ unlock()

unlock | ( | $id,
 |  | $group = null
 | ) |

Unlock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Références $id, et $path.

Documentation des champs

◆ $_locked_files

$_locked_files = array()
protected

◆ $_root

$_root
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Cache/Storage/FileStorage.php


Joomla CMS: Référence de la classe MemcachedStorage

  • Joomla
  • CMS
  • Cache
  • Storage
  • MemcachedStorage
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe MemcachedStorage
+ Graphe d'héritage de MemcachedStorage:
CacheStorage

Fonctions membres publiques

__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)
- Fonctions membres publiques hérités de CacheStorage
__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de CacheStorage
static | isSupported ()
static | addIncludePath ($path='')

Fonctions membres protégées

getConnection ()
_getCacheId ($id, $group)
lockindex ()
unlockindex ()
- Fonctions membres protégées hérités de CacheStorage
_getCacheId ($id, $group)

Attributs protégés

$_compress = 0
- Attributs protégés hérités de CacheStorage
$rawname

Attributs protégés statiques

static $_db = null

Membres hérités additionnels

- Champs de données hérités de CacheStorage
$_now
$_lifetime
$_locking
$_language
$_application
$_hash

Description détaillée

Memcached cache storage handler

3.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options Optional parameters.
Depuis
3.0.0

Références $options, Symfony\Contracts\Service\__construct(), Factory\getApplication(), et null.

Documentation des fonctions membres

◆ _getCacheId()

_getCacheId | ( | $id,
 |  | $group
 | ) |
protected

Get a cache_id string from an id/group pair

Paramètres
string | $id | The cache data id
string | $group | The cache data group
Renvoie
string The cache_id string
Depuis
1.7.0

Références $id, $prefix, et Cache\getPlatformPrefix().

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
3.0.0

Références $key, $mode, $prefix, et $value.

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

Références $id.

◆ flush()

flush ( )

Flush all existing items in storage.

Renvoie
boolean
Depuis
3.6.3

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.0.0

Références $id.

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.0.0

Références $data, $item, et $key.

◆ getConnection()

getConnection ( )
protected

Create the Memcached connection

Renvoie
void
Depuis
3.0.0
Exceptions

Références $app, $result, Factory\getApplication(), et null.

◆ isSupported()

static isSupported ( )
static

Test to see if the storage handler is available.

Renvoie
boolean
Depuis
3.0.0

◆ lock()

lock | ( | $id,
 |  | $group,
 |  | $locktime
 | ) |

Lock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
integer | $locktime | Cached item max lock time
Renvoie
mixed Boolean false if locking failed or an object containing properties lock and locklooped
Depuis
3.0.0

Références $id, et Joomla\Database\Query\$returning.

◆ lockindex()

lockindex ( )
protected

Lock cache index

Renvoie
boolean
Depuis
3.0.0

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.0.0

Références $id, $key, et $value.

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
3.0.0

Références $data, et $id.

◆ unlock()

unlock | ( | $id,
 |  | $group = null
 | ) |

Unlock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.0.0

Références $id.

◆ unlockindex()

unlockindex ( )
protected

Unlock cache index

Renvoie
boolean
Depuis
3.0.0

Documentation des champs

◆ $_compress

$_compress = 0
protected

◆ $_db

$_db = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Cache/Storage/MemcachedStorage.php


Joomla CMS: Référence de la classe RedisStorage

  • Joomla
  • CMS
  • Cache
  • Storage
  • RedisStorage
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe RedisStorage
+ Graphe d'héritage de RedisStorage:
CacheStorage

Fonctions membres publiques

__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
- Fonctions membres publiques hérités de CacheStorage
__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres publiques statiques

static | isSupported ()
static | isConnected ()
- Fonctions membres publiques statiques hérités de CacheStorage
static | isSupported ()
static | addIncludePath ($path='')

Fonctions membres protégées

getConnection ()
- Fonctions membres protégées hérités de CacheStorage
_getCacheId ($id, $group)

Attributs protégés

$_persistent = false
- Attributs protégés hérités de CacheStorage
$rawname

Attributs protégés statiques

static $_redis = null

Membres hérités additionnels

- Champs de données hérités de CacheStorage
$_now
$_lifetime
$_locking
$_language
$_application
$_hash

Description détaillée

Redis cache storage handler for PECL

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options Optional parameters.
Depuis
3.4

Références $options, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
3.4

Références $key, et $mode.

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

Références $id.

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.4

Références $id.

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
3.4

Références $data, $item, et $key.

◆ getConnection()

getConnection ( )
protected

Create the Redis connection

Renvoie
|boolean Redis connection object on success, boolean on failure
Depuis
3.4
Note
As of 4.0 this method will throw a JCacheExceptionConnecting object on connection failure

Références $app, Log\add(), Log\DEBUG, Factory\getApplication(), et null.

◆ isConnected()

static isConnected ( )
static

Test to see if the Redis connection is available.

Renvoie
boolean
Depuis
3.4

◆ isSupported()

static isSupported ( )
static

Test to see if the storage handler is available.

Renvoie
boolean
Depuis
3.4

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.4

Références $id.

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
3.4

Références $data, et $id.

Documentation des champs

◆ $_persistent

$_persistent = false
protected

◆ $_redis

$_redis = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Cache/Storage/RedisStorage.php


Joomla CMS: Référence de la classe WincacheStorage

  • Joomla
  • CMS
  • Cache
  • Storage
  • WincacheStorage
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe WincacheStorage
+ Graphe d'héritage de WincacheStorage:
CacheStorage

Fonctions membres publiques

contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
gc ()
- Fonctions membres publiques hérités de CacheStorage
__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de CacheStorage
static | isSupported ()
static | addIncludePath ($path='')

Membres hérités additionnels

- Champs de données hérités de CacheStorage
$_now
$_lifetime
$_locking
$_language
$_application
$_hash
- Fonctions membres protégées hérités de CacheStorage
_getCacheId ($id, $group)
- Attributs protégés hérités de CacheStorage
$rawname

Description détaillée

WinCache cache storage handler

1.7.0 deprecated 121.

Documentation des fonctions membres

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
1.7.0
Obsolète:
5.0

Références $key, et $mode.

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0
Obsolète:
5.0

Références $id.

◆ gc()

gc ( )

Garbage collect expired cache data

Renvoie
boolean
Depuis
1.7.0
Obsolète:
5.0

Références $key.

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0
Obsolète:
5.0

Références $id.

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0
Obsolète:
5.0

Références $data, $item, $key, et $name.

◆ isSupported()

static isSupported ( )
static

Test to see if the storage handler is available.

Renvoie
boolean
Depuis
3.0.0
Obsolète:
5.0

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0
Obsolète:
5.0

Références $id.

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
1.7.0
Obsolète:
5.0

Références $data, et $id.

La documentation de cette classe a été générée à partir du fichier suivant :
  • WincacheStorage.php


Joomla CMS: Référence de la classe Cache

  • Joomla
  • CMS
  • Cache
  • Cache
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques
Référence de la classe Cache

Fonctions membres publiques

__construct ($options)
setCaching ($enabled)
getCaching ()
setLifeTime ($lt)
contains ($id, $group=null)
get ($id, $group=null)
getAll ()
store ($data, $id, $group=null)
remove ($id, $group=null)
clean ($group=null, $mode='group')
gc ()
lock ($id, $group=null, $locktime=null)
unlock ($id, $group=null)
& _getStorage ()

Fonctions membres publiques statiques

static | getInstance ($type='output', $options=array())
static | getStores ()
static | getWorkarounds ($data, $options=array())
static | setWorkarounds ($data, $options=[])
static | makeId ()
static | getPlatformPrefix ()
static | addIncludePath ($path='')

Champs de données

$_options

Attributs publics statiques

static $_handler = array()

Description détaillée

Joomla! Cache base object

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options )

Constructor

Paramètres
array $options Cache options
Depuis
1.7.0

Références $app, $option, $options, $value, Factory\getApplication(), JPATH_CACHE, et Cache\setCaching().

Documentation des fonctions membres

◆ _getStorage()

& _getStorage ( )

Get the cache storage handler

Renvoie
CacheStorage
Depuis
1.7.0

Références $hash.

Référencé par Cache\clean(), Cache\contains(), Cache\gc(), Cache\get(), Cache\getAll(), Cache\lock(), Cache\remove(), Cache\store(), et Cache\unlock().

◆ addIncludePath()

static addIncludePath ( $path = '' )
static

Add a directory where Cache should search for handlers. You may either pass a string or an array of directories.

Paramètres
array | string $path A path to search.
Renvoie
array An array with directory elements
Depuis
1.7.0

Références $path, et Path\clean().

◆ clean()

clean | ( | $group = null,
 |  | $mode = 'group'
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean True on success, false otherwise
Depuis
1.7.0

Références $mode, Cache\_getStorage(), et Cache\getCaching().

◆ contains()

contains | ( | $id,
 |  | $group = null
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

Références $id, Cache\_getStorage(), et Cache\getCaching().

◆ gc()

gc ( )

Garbage collect expired cache data

Renvoie
boolean
Depuis
1.7.0

Références Cache\_getStorage(), et Cache\getCaching().

◆ get()

get | ( | $id,
 |  | $group = null
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0

Références $id, Cache\_getStorage(), et Cache\getCaching().

◆ getAll()

getAll ( )

Get a list of all cached data

Renvoie
mixed Boolean false on failure or an object with a list of cache groups and data
Depuis
1.7.0

Références Cache\_getStorage(), et Cache\getCaching().

◆ getCaching()

getCaching ( )

Get caching state

Renvoie
boolean
Depuis
1.7.0

Référencé par Cache\clean(), Cache\contains(), Cache\gc(), Cache\get(), Cache\getAll(), Cache\lock(), Cache\remove(), Cache\store(), et Cache\unlock().

◆ getInstance()

static getInstance | ( | $type = 'output',
 |  | $options = array()
 | ) |
static

Returns a reference to a cache adapter object, always creating it

Paramètres
string | $type | The cache object type to instantiate
array | $options | The array of options
Renvoie
CacheController
Depuis
1.7.0
Obsolète:
5.0 Use the cache controller factory instead

Références $options, $type, class, et Factory\getContainer().

Référencé par CacheModel\getCache().

◆ getPlatformPrefix()

static getPlatformPrefix ( )
static

Set a prefix cache key if device calls for separate caching

Renvoie
string
Depuis
3.5

Références Factory\getApplication().

Référencé par MemcachedStorage\_getCacheId(), et CacheStorage\_getCacheId().

◆ getStores()

static getStores ( )
static

Get the storage handlers

Renvoie
array
Depuis
1.7.0

$file

Références $class, et __DIR__.

Référencé par CachehandlerField\getOptions().

◆ getWorkarounds()

static getWorkarounds | ( | $data,
 |  | $options = array()
 | ) |
static

Perform workarounds on retrieved cached data

Paramètres
array | $data | Cached data
array | $options | Array of options
Renvoie
string Body of cached data
Depuis
1.7.0

Références $app, $data, $document, $header, $name, $options, elseif, Factory\getApplication(), Factory\getDocument(), Session\getFormToken(), et null.

Référencé par ViewController\get(), et PageController\get().

◆ lock()

lock | ( | $id,
 |  | $group = null,
 |  | $locktime = null
 | ) |

Set lock flag on cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $locktime | The default locktime for locking the cache.
Renvoie
Object with properties of lock and locklooped
Depuis
1.7.0

Références $id, Joomla\Database\Query\$returning, Cache\_getStorage(), et Cache\getCaching().

◆ makeId()

static makeId ( )
static

Create a safe ID for cached data from URL parameters

Renvoie
string MD5 encoded cache ID
Depuis
1.7.0

Références $app, $key, $type, $value, Factory\getApplication(), et null.

Référencé par ViewController\_makeId(), et PageController\_makeId().

◆ remove()

remove | ( | $id,
 |  | $group = null
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Références $id, Cache\_getStorage(), et Cache\getCaching().

◆ setCaching()

setCaching ( $enabled )

Set caching enabled state

Paramètres
boolean $enabled True to enable caching
Renvoie
void
Depuis
1.7.0

Références $enabled.

Référencé par Cache\__construct().

◆ setLifeTime()

setLifeTime ( $lt )

Set cache lifetime

Paramètres
integer $lt Cache lifetime
Renvoie
void
Depuis
1.7.0

◆ setWorkarounds()

static setWorkarounds | ( | $data,
 |  | $options = []
 | ) |
static

Create workarounds for data to be cached

Paramètres
string | $data | Cached data
array | $options | Array of options
Renvoie
array Data to be cached
Depuis
1.7.0

Références $app, $data, $document, $key, $options, Factory\getApplication(), et Factory\getDocument().

Référencé par ViewController\get(), et PageController\store().

◆ store()

store | ( | $data,
 |  | $id,
 |  | $group = null
 | ) |

Store the cached data by ID and group

Paramètres
mixed | $data | The data to store
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Références $data, $id, Cache\_getStorage(), et Cache\getCaching().

◆ unlock()

unlock | ( | $id,
 |  | $group = null
 | ) |

Unset lock flag on cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Références $id, Cache\_getStorage(), et Cache\getCaching().

Documentation des champs

◆ $_handler

$_handler = array()
static

◆ $_options

$_options
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Cache/Cache.php


Joomla CMS: Référence de la classe CacheController

  • Joomla
  • CMS
  • Cache
  • CacheController
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe CacheController
+ Graphe d'héritage de CacheController:
CallbackController OutputController PageController ViewController

Fonctions membres publiques

__construct ($options)
__call ($name, $arguments)

Fonctions membres publiques statiques

static | getInstance ($type='output', $options=array())
static | addIncludePath ($path='')

Champs de données

$cache
$options

Description détaillée

Public cache handler

Depuis
1.7.0
Note
As of 4.0 this class will be abstract

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options )

Constructor

Paramètres
array $options Array of options
Depuis
1.7.0

Références $option, $options, et $value.

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $arguments
 | ) |

Magic method to proxy CacheController method calls to Cache

Paramètres
string | $name | Name of the function
array | $arguments | Array of arguments for the function
Renvoie
mixed
Depuis
1.7.0

Références $name.

◆ addIncludePath()

static addIncludePath ( $path = '' )
static

Add a directory where Cache should search for controllers. You may either pass a string or an array of directories.

Paramètres
array | string $path A path to search.
Renvoie
array An array with directory elements
Depuis
1.7.0
Obsolète:
5.0 Use the cache controller factory instead

Références $path, et Path\clean().

◆ getInstance()

static getInstance | ( | $type = 'output',
 |  | $options = array()
 | ) |
static

Returns a reference to a cache adapter object, always creating it

Paramètres
string | $type | The cache object type to instantiate; default is output.
array | $options | Array of options
Renvoie
CacheController
Depuis
1.7.0
Exceptions

Références $class, $options, $path, $type, class, Path\find(), Factory\getContainer(), et JLoader\register().

Documentation des champs

◆ $cache

$cache

◆ $options

$options
La documentation de cette classe a été générée à partir du fichier suivant :
  • Cache/CacheController.php


Joomla CMS: Référence de la classe CacheControllerFactory

  • Joomla
  • CMS
  • Cache
  • CacheControllerFactory
Fonctions membres publiques
Référence de la classe CacheControllerFactory
+ Graphe d'héritage de CacheControllerFactory:
CacheControllerFactoryInterface

Fonctions membres publiques

createCacheController ($type='output', $options=array())

Description détaillée

Default factory for creating CacheController objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createCacheController()

createCacheController | ( | $type = 'output',
 |  | $options = array()
 | ) |

Method to get an instance of a cache controller.

Paramètres
string | $type | The cache object type to instantiate
array | $options | Array of options
Renvoie
CacheController
Depuis
4.0.0
Exceptions

Implémente CacheControllerFactoryInterface.

Références $class, $options, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheControllerFactory.php


Joomla CMS: Référence de l'interface CacheControllerFactoryAwareInterface

  • Joomla
  • CMS
  • Cache
  • CacheControllerFactoryAwareInterface
Fonctions membres publiques
Référence de l'interface CacheControllerFactoryAwareInterface
+ Graphe d'héritage de CacheControllerFactoryAwareInterface:
HtmlDocument SiteMenu BaseDatabaseModel ErrorDocument BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

setCacheControllerFactory (CacheControllerFactoryInterface $factory)

Description détaillée

Interface to be implemented by classes depending on a cache controller factory.

Depuis
4.2.0

Documentation des fonctions membres

◆ setCacheControllerFactory()

setCacheControllerFactory ( CacheControllerFactoryInterface $factory )

Set the cache controller factory to use.

Paramètres
CacheControllerFactoryInterface $factory The cache controller factory to use.
Renvoie
void
Depuis
4.2.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • CacheControllerFactoryAwareInterface.php


Joomla CMS: Référence de l'interface CacheControllerFactoryInterface

  • Joomla
  • CMS
  • Cache
  • CacheControllerFactoryInterface
Fonctions membres publiques
Référence de l'interface CacheControllerFactoryInterface
+ Graphe d'héritage de CacheControllerFactoryInterface:
CacheControllerFactory

Fonctions membres publiques

createCacheController ($type='output', $options=array())

Description détaillée

Interface defining a factory which can create CacheController objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createCacheController()

createCacheController | ( | $type = 'output',
 |  | $options = array()
 | ) |

Method to get an instance of a cache controller.

Paramètres
string | $type | The cache object type to instantiate
array | $options | Array of options
Renvoie
CacheController
Depuis
4.0.0
Exceptions

Implémenté dans CacheControllerFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CacheControllerFactoryInterface.php


Joomla CMS: Référence de la classe CacheStorage

  • Joomla
  • CMS
  • Cache
  • CacheStorage
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe CacheStorage
+ Graphe d'héritage de CacheStorage:
ApcuStorage FileStorage MemcachedStorage RedisStorage WincacheStorage

Fonctions membres publiques

__construct ($options=array())
contains ($id, $group)
get ($id, $group, $checkTime=true)
getAll ()
store ($id, $group, $data)
remove ($id, $group)
clean ($group, $mode=null)
flush ()
gc ()
lock ($id, $group, $locktime)
unlock ($id, $group=null)

Fonctions membres publiques statiques

static | isSupported ()
static | addIncludePath ($path='')

Champs de données

$_now
$_lifetime
$_locking
$_language
$_application
$_hash

Fonctions membres protégées

_getCacheId ($id, $group)

Attributs protégés

$rawname

Description détaillée

Abstract cache storage handler

Depuis
1.7.0
Note
As of 4.0 this class will be abstract

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options Optional parameters
Depuis
1.7.0

Références $app, $options, Factory\getApplication(), et JPATH_CONFIGURATION.

Documentation des fonctions membres

◆ _getCacheId()

_getCacheId | ( | $id,
 |  | $group
 | ) |
protected

Get a cache ID string from an ID/group pair

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
string
Depuis
1.7.0

Références $id, $name, et Cache\getPlatformPrefix().

◆ addIncludePath()

static addIncludePath ( $path = '' )
static

Add a directory where CacheStorage should search for handlers. You may either pass a string or an array of directories.

Paramètres
array | string $path A path to search.
Renvoie
array An array with directory elements
Depuis
1.7.0

Références $path, et Path\clean().

◆ clean()

clean | ( | $group,
 |  | $mode = null
 | ) |

Clean cache for a group given a mode.

group mode : cleans all cache in the group notgroup mode : cleans all cache not in the group

Paramètres
string | $group | The cache data group
string | $mode | The mode for cleaning cache [group|notgroup]
Renvoie
boolean
Depuis
1.7.0

◆ contains()

contains | ( | $id,
 |  | $group
 | ) |

Check if the cache contains data stored by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
3.7.0

◆ flush()

flush ( )

Flush all existing items in storage.

Renvoie
boolean
Depuis
3.6.3

◆ gc()

gc ( )

Garbage collect expired cache data

Renvoie
boolean
Depuis
1.7.0

◆ get()

get | ( | $id,
 |  | $group,
 |  | $checkTime = true
 | ) |

Get cached data by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
boolean | $checkTime | True to verify cache time expiration threshold
Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0

◆ getAll()

getAll ( )

Get all cached data

Renvoie
mixed Boolean false on failure or a cached data object
Depuis
1.7.0

◆ isSupported()

static isSupported ( )
static

Test to see if the storage handler is available.

Renvoie
boolean
Depuis
3.0.0

◆ lock()

lock | ( | $id,
 |  | $group,
 |  | $locktime
 | ) |

Lock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
integer | $locktime | Cached item max lock time
Renvoie
mixed Boolean false if locking failed or an object containing properties lock and locklooped
Depuis
1.7.0

◆ remove()

remove | ( | $id,
 |  | $group
 | ) |

Remove a cached data entry by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

◆ store()

store | ( | $id,
 |  | $group,
 |  | $data
 | ) |

Store the data to cache by ID and group

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
string | $data | The data to store in cache
Renvoie
boolean
Depuis
1.7.0

◆ unlock()

unlock | ( | $id,
 |  | $group = null
 | ) |

Unlock cached item

Paramètres
string | $id | The cache data ID
string | $group | The cache data group
Renvoie
boolean
Depuis
1.7.0

Documentation des champs

◆ $_application

$_application

◆ $_hash

$_hash

◆ $_language

$_language

◆ $_lifetime

$_lifetime

◆ $_locking

$_locking

◆ $_now

$_now

◆ $rawname

$rawname
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheStorage.php


Joomla CMS: Référence de la classe HttpBridgePostRequestMethod

  • Joomla
  • CMS
  • Captcha
  • Google
  • HttpBridgePostRequestMethod
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe HttpBridgePostRequestMethod
+ Graphe d'héritage de HttpBridgePostRequestMethod:
RequestMethod

Fonctions membres publiques

__construct (Http $http=null)
submit (RequestParameters $params)

Champs de données

const SITE_VERIFY_URL = 'https://www.google.com/recaptcha/api/siteverify'

Attributs privés

$http

Description détaillée

Bridges the Joomla! HTTP API to the Google Recaptcha RequestMethod interface for a POST request.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Http $http = null )

Class constructor.

Paramètres
Http | null $http The HTTP adapter
Depuis
3.9.0

Références HttpFactory\getHttp().

Documentation des fonctions membres

◆ submit()

submit ( RequestParameters $params )

Submit the request with the specified parameters.

Paramètres
RequestParameters $params Request parameters
Renvoie
string Body of the reCAPTCHA response
Depuis
3.9.0

Implémente RequestMethod.

Références $params.

Documentation des champs

◆ $http

$http
private

◆ SITE_VERIFY_URL

const SITE_VERIFY_URL = 'https://www.google.com/recaptcha/api/siteverify'
La documentation de cette classe a été générée à partir du fichier suivant :
  • HttpBridgePostRequestMethod.php


Joomla CMS: Référence de la classe Captcha

  • Joomla
  • CMS
  • Captcha
  • Captcha
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe Captcha
+ Graphe d'héritage de Captcha:
DispatcherAwareInterface

Fonctions membres publiques

__construct ($captcha, $options)
initialise ($id)
display ($name, $id, $class='')
checkAnswer ($code)
setupField (\Joomla\CMS\Form\Field\CaptchaField $field, \SimpleXMLElement $element)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static getInstance ($captcha, array $options=array())

Fonctions membres privées

update ($name, &$args)
_load (array $options=array())

Attributs privés

$captcha
$name

Attributs privés statiques

static $instances = array()

Description détaillée

Joomla! Captcha base object

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $captcha,
 |  | $options
 | ) |

Class constructor.

Paramètres
string | $captcha | The plugin to use.
array | $options | Associative array of options.
Depuis
2.5
Exceptions

Références $options, Factory\getApplication(), Joomla\CMS\Application\getDispatcher(), name, et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ _load()

_load ( array $options = array() )
private

Load the Captcha plugin.

Paramètres
array $options Associative array of options.
Renvoie
void
Depuis
2.5
Exceptions

Références $name, $options, $params, $path, Joomla\CMS\Application\getDispatcher(), InputFilter\getInstance(), PluginHelper\getPlugin(), JPATH_PLUGINS, name, et Text\sprintf().

◆ checkAnswer()

checkAnswer ( $code )

Checks if the answer is correct.

Paramètres
string $code The answer.
Renvoie
bool Whether the provided answer was correct
Depuis
2.5
Exceptions

Références $result, et null.

◆ display()

display | ( | $name,
 |  | $id,
 |  | $class = ''
 | ) |

Get the HTML for the captcha.

Paramètres
string | $name | The control name.
string | $id | The id for the control.
string | $class | Value for the HTML class attribute
Renvoie
string The return value of the function "onDisplay" of the selected Plugin.
Depuis
2.5
Exceptions

Références $class, $id, $name, $result, et null.

◆ getInstance()

static getInstance | ( |  | $captcha,
 |  | array | $options = array()
 | ) |  |
static

Returns the global Captcha object, only creating it if it doesn't already exist.

Paramètres
string | $captcha | The plugin to use.
array | $options | Associative array of options.
Renvoie
Captcha|null Instance of this class.
Depuis
2.5
Exceptions

Références $options.

Référencé par CaptchaField\setup(), et CaptchaRule\test().

◆ initialise()

initialise ( $id )

Fire the onInit event to initialise the captcha plugin.

Paramètres
string $id The id of the field.
Renvoie
boolean True on success
Depuis
2.5
Exceptions

Références $id.

◆ setupField()

setupField | ( | \Joomla\CMS\Form\Field\CaptchaField | $field,
 |  | \SimpleXMLElement | $element
 | ) |  |

Method to react on the setup of a captcha field. Gives the possibility to change the field and/or the XML element for the field.

Paramètres
\Joomla\CMS\Form\Field\CaptchaField | $field | Captcha field instance
\SimpleXMLElement | $element | XML form definition
Renvoie
void

Références $field, $result, et null.

◆ update()

update | ( |  | $name,
 |  | & | $args
 | ) |  |
private

Method to call the captcha callback if it exist.

Paramètres
string | $name | Callback name
array | &$args | Arguments
Renvoie
mixed
Depuis
4.0.0

Références $name, et null.

Documentation des champs

◆ $captcha

$captcha
private

◆ $instances

$instances = array()
staticprivate

◆ $name

$name
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Captcha.php


Joomla CMS: Référence de la classe Categories

  • Joomla
  • CMS
  • Categories
  • Categories
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Categories
+ Graphe d'héritage de Categories:
CategoryInterface DatabaseAwareInterface Category Category Category Category

Fonctions membres publiques

__construct ($options)
get ($id='root', $forceload=false)
getExtension ()
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres publiques statiques

static getInstance ($extension, $options=array())

Attributs publics statiques

static $instances = array()

Fonctions membres protégées

_load ($id)

Attributs protégés

$_nodes
$_checkedCategories
$_extension = null
$_table = null
$_field = null
$_key = null
$_statefield = null
$_options = []

Description détaillée

Categories Class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options )

Class constructor

Paramètres
array $options Array of options
Depuis
1.6

Références $options, Factory\getLanguage(), et Multilanguage\isEnabled().

Documentation des fonctions membres

◆ _load()

_load ( $id )
protected

Load method

Paramètres
integer $id Id of category to load
Renvoie
void
Depuis
1.6

Références $app, $db, $extension, $groups, $id, $query, $result, $results, $this, $user, class, elseif, Factory\getApplication(), Factory\getContainer(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), ParameterType\INTEGER, Multilanguage\isEnabled(), null, et ParameterType\STRING.

◆ get()

get | ( | $id = 'root',
 |  | $forceload = false
 | ) |

Loads a specific category and all its children in a CategoryNode object.

Paramètres
mixed | $id | an optional id integer or equal to 'root'
boolean | $forceload | True to force the _load method to execute
Renvoie
CategoryNode|null CategoryNode object or null if $id is not valid
Depuis
1.6

Implémente CategoryInterface.

Références $id, et null.

◆ getExtension()

getExtension ( )

Returns the extension of the category.

Renvoie
string The extension
Depuis
3.9.0

◆ getInstance()

static getInstance | ( | $extension,
 |  | $options = array()
 | ) |
static

Returns a reference to a Categories object

Paramètres
string | $extension | Name of the categories extension
array | $options | An array of options
Renvoie
Categories|boolean Categories object on success, boolean false if an object does not exist
Depuis
1.6
Obsolète:
5.0 Use the ComponentInterface to get the categories

Références $component, $extension, $hash, $options, $parts, Factory\getApplication(), et null.

Référencé par HtmlView\_prepareDocument(), FeedView\display(), CategoryModel\getCategory(), RouteHelper\getCategoryRoute(), CategoriesModel\getItems(), ArticlesCategoriesHelper\getList(), RouteHelper\getRoute(), PopularHelper\getTitle(), LatestHelper\getTitle(), PlgFinderNewsfeeds\index(), et PlgFinderContacts\index().

Documentation des champs

◆ $_checkedCategories

$_checkedCategories
protected

◆ $_extension

$_extension = null
protected

◆ $_field

$_field = null
protected

◆ $_key

$_key = null
protected

◆ $_nodes

$_nodes
protected

◆ $_options

$_options = []
protected

◆ $_statefield

$_statefield = null
protected

◆ $_table

$_table = null
protected

◆ $instances

$instances = array()
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Categories.php


Joomla CMS: Référence de la classe CategoryFactory

  • Joomla
  • CMS
  • Categories
  • CategoryFactory
Fonctions membres publiques | Attributs privés
Référence de la classe CategoryFactory
+ Graphe d'héritage de CategoryFactory:
CategoryFactoryInterface

Fonctions membres publiques

__construct ($namespace)
createCategory (array $options=[], string $section='')

Attributs privés

$namespace

Description détaillée

Option based categories factory.

Depuis
3.10.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $namespace )

The namespace must be like: Joomla

Paramètres
string $namespace The namespace
Depuis
4.0.0

Références $namespace.

Documentation des fonctions membres

◆ createCategory()

createCategory | ( | array | $options = [],
 |  | string | $section = ''
 | ) |  |

Creates a category.

Paramètres
array | $options | The options
string | $section | The section
Renvoie
CategoryInterface
Depuis
3.10.0
Exceptions
SectionNotFoundException

Implémente CategoryFactoryInterface.

Références $category, $className, $options, $section, et Joomla\Database\getDatabase().

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Categories/CategoryFactory.php


Joomla CMS: Référence de l'interface CategoryFactoryInterface

  • Joomla
  • CMS
  • Categories
  • CategoryFactoryInterface
Fonctions membres publiques
Référence de l'interface CategoryFactoryInterface
+ Graphe d'héritage de CategoryFactoryInterface:
CategoryFactory

Fonctions membres publiques

createCategory (array $options=[], string $section='')

Description détaillée

Category factory interface

Depuis
3.10.0

Documentation des fonctions membres

◆ createCategory()

createCategory | ( | array | $options = [],
 |  | string | $section = ''
 | ) |  |

Creates a category.

Paramètres
array | $options | The options
string | $section | The section
Renvoie
CategoryInterface
Depuis
3.10.0
Exceptions
SectionNotFoundException

Implémenté dans CategoryFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CategoryFactoryInterface.php


Joomla CMS: Référence de l'interface CategoryInterface

  • Joomla
  • CMS
  • Categories
  • CategoryInterface
Fonctions membres publiques
Référence de l'interface CategoryInterface
+ Graphe d'héritage de CategoryInterface:
Categories Category Category Category Category

Fonctions membres publiques

get ($id='root', $forceload=false)

Description détaillée

The category interface.

Depuis
3.10.0

Documentation des fonctions membres

◆ get()

get | ( | $id = 'root',
 |  | $forceload = false
 | ) |

Loads a specific category and all its children in a CategoryNode object.

Paramètres
mixed | $id | an optional id integer or equal to 'root'
boolean | $forceload | True to force the _load method to execute
Renvoie
CategoryNode|null CategoryNode object or null if $id is not valid
Depuis
3.10.0

Implémenté dans Categories.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CategoryInterface.php


Joomla CMS: Référence de la classe CategoryNode

  • Joomla
  • CMS
  • Categories
  • CategoryNode
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe CategoryNode
+ Graphe d'héritage de CategoryNode:
CMSObject NodeInterface ImmutableNodeInterface

Fonctions membres publiques

__construct ($category=null, $constructor=null)
setParent (NodeInterface $parent)
& getChildren ($recursive=false)
getSibling ($right=true)
getParams ()
getMetadata ()
getPath ()
getAuthor ($modifiedUser=false)
setAllLoaded ()
getNumItems ($recursive=false)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de NodeInterface
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)
- Fonctions membres publiques hérités de ImmutableNodeInterface
getParent ()
getRoot ()
hasChildren ()
hasParent ()

Champs de données

$id = null
$asset_id = null
$parent_id = null
$lft = null
$rgt = null
$level = null
$extension = null
$title = null
$alias = null
$description = null
$published = null
$checked_out = null
$checked_out_time = null
$access = null
$params = null
$metadesc = null
$metakey = null
$metadata = null
$created_user_id = null
$created_time = null
$modified_user_id = null
$modified_time = null
$hits = null
$language = null
$numitems = null
$childrennumitems = null
$slug = null
$assets = null

Attributs protégés

$_path = array()
$_allChildrenloaded = false
$_constructor = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Helper class to load Categorytree

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $category = null,
 |  | $constructor = null
 | ) |

Class constructor

Paramètres
array | $category | The category data.
Categories | $constructor | The tree constructor.
Depuis
1.6

Références $category.

Documentation des fonctions membres

◆ getAuthor()

getAuthor ( $modifiedUser = false )

Returns the user that created the category

Paramètres
boolean $modifiedUser Returns the modified_user when set to true
Renvoie
A User object containing a userid
Depuis
1.6

Références Factory\getUser().

◆ getChildren()

& getChildren ( $recursive = false )

Get the children of this node

Paramètres
boolean $recursive False by default
Renvoie
CategoryNode[] The children
Depuis
1.6

Implémente ImmutableNodeInterface.

Références Joomla\CMS\Tree\$_children, $items, et $temp.

◆ getMetadata()

getMetadata ( )

Returns the category metadata

Renvoie
Registry A Registry object containing the metadata
Depuis
1.6

◆ getNumItems()

getNumItems ( $recursive = false )

Returns the number of items.

Paramètres
boolean $recursive If false number of children, if true number of descendants
Renvoie
integer Number of children or descendants
Depuis
1.6

Références $count, et Joomla\CMS\Tree\getChildren().

◆ getParams()

getParams ( )

Returns the category parameters

Renvoie
Registry
Depuis
1.6

Références $params.

◆ getPath()

getPath ( )

Returns the category path to the root category

Renvoie
array
Depuis
1.6

◆ getSibling()

getSibling ( $right = true )

Returns the right or left sibling of a category

Paramètres
boolean $right If set to false, returns the left sibling
Renvoie
CategoryNode|null CategoryNode object with the sibling information or null if there is no sibling on that side.
Depuis
1.6

Implémente ImmutableNodeInterface.

Références Joomla\CMS\Tree\$_leftSibling, Joomla\CMS\Tree\$_rightSibling, et $temp.

◆ setAllLoaded()

setAllLoaded ( )

Set to load all children

Renvoie
void
Depuis
1.6

◆ setParent()

setParent ( NodeInterface $parent )

Set the parent of this category

If the category already has a parent, the link is unset

Paramètres
CategoryNode | null $parent CategoryNode for the parent to be set or null
Renvoie
void
Depuis
1.6

Implémente NodeInterface.

Références $id, $key, et $this.

Documentation des champs

◆ $_allChildrenloaded

$_allChildrenloaded = false
protected

◆ $_constructor

$_constructor = null
protected

◆ $_path

$_path = array()
protected

◆ $access

$access = null

◆ $alias

$alias = null

◆ $asset_id

$asset_id = null

◆ $assets

$assets = null

◆ $checked_out

$checked_out = null

◆ $checked_out_time

$checked_out_time = null

◆ $childrennumitems

$childrennumitems = null

◆ $created_time

$created_time = null

◆ $created_user_id

$created_user_id = null

◆ $description

$description = null

◆ $extension

$extension = null

◆ $hits

$hits = null

◆ $id

$id = null

◆ $language

$language = null

◆ $level

$level = null

◆ $lft

$lft = null

◆ $metadata

$metadata = null

◆ $metadesc

$metadesc = null

◆ $metakey

$metakey = null

◆ $modified_time

$modified_time = null

◆ $modified_user_id

$modified_user_id = null

◆ $numitems

$numitems = null

◆ $params

$params = null

◆ $parent_id

$parent_id = null

◆ $published

$published = null

◆ $rgt

$rgt = null

◆ $slug

$slug = null

◆ $title

$title = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryNode.php


Joomla CMS: Référence de l'interface CategoryServiceInterface

  • Joomla
  • CMS
  • Categories
  • CategoryServiceInterface
Fonctions membres publiques
Référence de l'interface CategoryServiceInterface
+ Graphe d'héritage de CategoryServiceInterface:
LegacyComponent BannersComponent ContactComponent ContentComponent FieldsComponent NewsfeedsComponent

Fonctions membres publiques

getCategory (array $options=[], $section='')
countItems (array $items, string $section)
prepareForm (Form $form, $data)

Description détaillée

Access to component specific categories.

Depuis
4.0.0

Documentation des fonctions membres

◆ countItems()

countItems | ( | array | $items,
 |  | string | $section
 | ) |  |

Adds Count Items for Category Manager.

Paramètres

Implémenté dans ContentComponent, et LegacyComponent.

◆ getCategory()

getCategory | ( | array | $options = [],
 |  |  | $section = ''
 | ) |  |

Returns the category service.

Paramètres
array | $options | The options
string | $section | The section
Renvoie
CategoryInterface
Depuis
4.0.0
Exceptions
SectionNotFoundException

Implémenté dans LegacyComponent.

◆ prepareForm()

prepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Prepares the category form

Paramètres
Form | $form | The form to change
array | object | $data | The form data
Renvoie
void

Implémenté dans ContentComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CategoryServiceInterface.php


Joomla CMS: Référence de la classe SectionNotFoundException

  • Joomla
  • CMS
  • Categories
  • SectionNotFoundException
Référence de la classe SectionNotFoundException
+ Graphe d'héritage de SectionNotFoundException:

Description détaillée

Representing when a category section cannot be found.

Depuis
3.10.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SectionNotFoundException.php


Joomla CMS: Référence de la classe Changelog

  • Joomla
  • CMS
  • Changelog
  • Changelog
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe Changelog
+ Graphe d'héritage de Changelog:
CMSObject

Fonctions membres publiques

setVersion (string $version)
startElement ($parser, $name, $attrs=array())
endElement ($parser, $name)
characterData ($parser, $data)
loadFromXml ($url)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres protégées

getStackLocation ()
getLastTag ()

Attributs protégés

$element
$type
$version
$security = array()
$fix = array()
$language = array()
$addition = array()
$change = array()
$remove = array()
$note = array()
$xmlParser
$stack = array('base')
$currentChangelog
$latest
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$items = array()
$matchVersion = ''

Description détaillée

Changelog class.

Depuis
4.0.0

Documentation des fonctions membres

◆ characterData()

characterData | ( | $parser,
 |  | $data
 | ) |

Character Parser Function

Paramètres
object | $parser | Parser object.
object | $data | The data.
Renvoie
void
Note
This is public because its called externally.
Depuis
1.7.0

Références $data, et items.

◆ endElement()

endElement | ( | $parser,
 |  | $name
 | ) |

Callback for closing the element

Paramètres
object | $parser | Parser object
string | $name | Name of element that was closed
Renvoie
void
Note
This is public because it is called externally
Depuis
1.7.0

Références $items, $key, $name, $this, $val, elseif, et items.

◆ getLastTag()

getLastTag ( )
protected

Get the last position in stack count

Renvoie
string
Depuis
4.0.0

◆ getStackLocation()

getStackLocation ( )
protected

Gets the reference to the current direct parent

Renvoie
string
Depuis
4.0.0

◆ loadFromXml()

loadFromXml ( $url )

Loads an XML file from a URL.

Paramètres
string $url The URL.
Renvoie
boolean True on success
Depuis
4.0.0

Références $this, $url, $version, Log\add(), HttpFactory\getHttp(), null, Text\sprintf(), et Log\WARNING.

◆ setVersion()

setVersion ( string $version )

Set the version to match.

Paramètres
string $version The version to match
Renvoie
void
Depuis
4.0.0

Références $version.

◆ startElement()

startElement | ( | $parser,
 |  | $name,
 |  | $attrs = array()
 | ) |

XML Start Element callback

Paramètres
object | $parser | Parser object
string | $name | Name of the tag found
array | $attrs | Attributes of the tag
Renvoie
void
Note
This is public because it is called externally
Depuis
1.7.0

Références $data, $key, et $name.

Documentation des champs

◆ $addition

$addition = array()
protected

◆ $change

$change = array()
protected

◆ $currentChangelog

$currentChangelog
protected

◆ $element

$element
protected

◆ $fix

$fix = array()
protected

◆ $items

$items = array()
private

◆ $language

$language = array()
protected

◆ $latest

$latest
protected

◆ $matchVersion

$matchVersion = ''
private

◆ $note

$note = array()
protected

◆ $remove

$remove = array()
protected

◆ $security

$security = array()
protected

◆ $stack

$stack = array('base')
protected

◆ $type

$type
protected

◆ $version

$version
protected

◆ $xmlParser

$xmlParser
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Changelog.php


Joomla CMS: Référence de la classe ClientHelper

  • Joomla
  • CMS
  • Client
  • ClientHelper
Fonctions membres publiques statiques
Référence de la classe ClientHelper

Fonctions membres publiques statiques

static | getCredentials ($client, $force=false)
static | setCredentials ($client, $user, $pass)
static | hasCredentials ($client)
static | setCredentialsFromRequest ($client)

Description détaillée

Client helper class

Depuis
1.7.0

Documentation des fonctions membres

◆ getCredentials()

static getCredentials | ( | $client,
 |  | $force = false
 | ) |
static

Method to return the array of client layer configuration options

Paramètres
string | $client | Client name, currently only 'ftp' is supported
boolean | $force | Forces re-creation of the login credentials. Set this to true if login credentials in the session storage have changed
Renvoie
array Client layer configuration options, consisting of at least these fields: enabled, host, port, user, pass, root
Depuis
1.7.0

Références $app, $client, $options, Factory\getApplication(), Factory\getSession(), et null.

Référencé par File\append(), Folder\copy(), File\copy(), Folder\create(), File\delete(), Folder\delete(), Factory\getStream(), File\move(), Folder\move(), File\upload(), et File\write().

◆ hasCredentials()

static hasCredentials ( $client )
static

Method to determine if client login credentials are present

Paramètres
string $client Client name, currently only 'ftp' is supported
Renvoie
boolean True if login credentials are available
Depuis
1.7.0

Références $app, $client, $options, $return, $user, elseif, Factory\getApplication(), Factory\getSession(), et null.

◆ setCredentials()

static setCredentials | ( | $client,
 |  | $user,
 |  | $pass
 | ) |
static

Method to set client login credentials

Paramètres
string | $client | Client name, currently only 'ftp' is supported
string | $user | Username
string | $pass | Password
Renvoie
boolean True if the given login credentials have been set and are valid
Depuis
1.7.0

Références $app, $client, $options, $return, $user, Factory\getApplication(), FtpClient\getInstance(), et Factory\getSession().

◆ setCredentialsFromRequest()

static setCredentialsFromRequest ( $client )
static

Determine whether input fields for client settings need to be shown

If valid credentials were passed along with the request, they are saved to the session. This functions returns an exception if invalid credentials have been given or if the connection to the server failed for some other reason.

Paramètres
string $client The name of the client.
Renvoie
boolean True if credentials are present
Depuis
1.7.0
Exceptions

Références $client, $input, $return, $user, Factory\getApplication(), et null.

Référencé par ConfigController\save(), et TemplatesController\save().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ClientHelper.php


Joomla CMS: Référence de la classe FtpClient

  • Joomla
  • CMS
  • Client
  • FtpClient
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe FtpClient

Fonctions membres publiques

__construct (array $options=array())
__destruct ()
setOptions (array $options)
connect ($host='127.0.0.1', $port=21)
isConnected ()
login ($user='anonymous', $pass='jftp @joomla.org')
quit ()
pwd ()
syst ()
chdir ($path)
reinit ()
rename ($from, $to)
chmod ($path, $mode)
delete ($path)
mkdir ($path)
restart ($point)
create ($path)
read ($remote, &$buffer)
get ($local, $remote)
store ($local, $remote=null)
write ($remote, $buffer)
append ($remote, $buffer)
size ($remote)
listNames ($path=null)
listDetails ($path=null, $type='all')

Fonctions membres publiques statiques

static getInstance ($host='127.0.0.1', $port='21', array $options=array(), $user=null, $pass=null)

Fonctions membres protégées

_putCmd ($cmd, $expectedResponse)
_verifyResponse ($expected)
_passive ()
_findMode ($fileName)
_mode ($mode)

Attributs protégés

$_conn = null
$_dataconn = null
$_pasv = null
$_response = null
$_timeout = 15
$_type = null
$_autoAscii
$_lineEndings = array('UNIX' => "\n", 'WIN' => "\r\n")

Attributs protégés statiques

static $instances = array()

Description détaillée

FTP client class

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = array() )

FtpClient object constructor

Paramètres
array $options Associative array of options to set
Depuis
1.5

Références $options, FtpClient\setOptions(), et BufferStreamHandler\stream_register().

◆ __destruct()

__destruct ( )

FtpClient object destructor

Closes an existing connection, if we have one

Depuis
1.5

Références FtpClient\quit().

Documentation des fonctions membres

◆ _findMode()

_findMode ( $fileName )
protected

Method to find out the correct transfer mode for a specific file

Paramètres
string $fileName Name of the file
Renvoie
integer Transfer-mode for this filetype [FTP_ASCII|FTP_BINARY]
Depuis
1.5

Références $mode, et elseif.

Référencé par FtpClient\append(), FtpClient\get(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ _mode()

_mode ( $mode )
protected

Set transfer mode

Paramètres
integer $mode Integer representation of data transfer mode [1:Binary|0:Ascii] Defined constants can also be used [FTP_BINARY|FTP_ASCII]
Renvoie
boolean True if successful
Depuis
1.5

Références $mode, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

Référencé par FtpClient\append(), FtpClient\get(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ _passive()

_passive ( )
protected

Set server to passive mode and open a data port connection

Renvoie
boolean True if successful
Depuis
1.5

Références FtpClient\$_timeout, $parts, Log\add(), null, Text\sprintf(), et Log\WARNING.

Référencé par FtpClient\append(), FtpClient\create(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\read(), FtpClient\size(), FtpClient\store(), et FtpClient\write().

◆ _putCmd()

_putCmd | ( | $cmd,
 |  | $expectedResponse
 | ) |
protected

Send command to the FTP server and validate an expected response code

Paramètres
string | $cmd | Command to send to the FTP server
mixed | $expectedResponse | Integer response code or array of integer response codes
Renvoie
boolean True if command executed successfully
Depuis
1.5

Références FtpClient\_verifyResponse(), Log\add(), Text\sprintf(), et Log\WARNING.

Référencé par FtpClient\_mode(), FtpClient\append(), FtpClient\chdir(), FtpClient\chmod(), FtpClient\create(), FtpClient\delete(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\login(), FtpClient\mkdir(), FtpClient\pwd(), FtpClient\read(), FtpClient\reinit(), FtpClient\rename(), FtpClient\restart(), FtpClient\size(), FtpClient\store(), FtpClient\syst(), et FtpClient\write().

◆ _verifyResponse()

_verifyResponse ( $expected )
protected

Verify the response code from the server and log response if flag is set

Paramètres
mixed $expected Integer response code or array of integer response codes
Renvoie
boolean True if response code from the server is expected
Depuis
1.5

Références FtpClient\$_timeout, $parts, Log\add(), null, Text\sprintf(), et Log\WARNING.

Référencé par FtpClient\_putCmd(), FtpClient\append(), FtpClient\connect(), FtpClient\create(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ append()

append | ( | $remote,
 |  | $buffer
 | ) |

Method to append a string to the FTP server

Paramètres
string | $remote | FTP path to file to append to
string | $buffer | Contents to append to the FTP server
Renvoie
boolean True if successful
Depuis
3.6.0

Références $buffer, $mode, $result, $size, $tmp, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), FtpClient\size(), et Text\sprintf().

◆ chdir()

chdir ( $path )

Method to change the current working directory on the FTP server

Paramètres
string $path Path to change into on the server
Renvoie
boolean True if successful
Depuis
1.5

Références $path, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ chmod()

chmod | ( | $path,
 |  | $mode
 | ) |

Method to change mode for a path on the FTP server

Paramètres
string | $path | Path to change mode on
mixed | $mode | Octal value to change mode to, e.g. '0777', 0777 or 511 (string or integer)
Renvoie
boolean True if successful
Depuis
1.5

Références $mode, $path, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ connect()

connect | ( | $host = '127.0.0.1',
 |  | $port = 21
 | ) |

Method to connect to a FTP server

Paramètres
string | $host | Host to connect to [Default: 127.0.0.1]
int | $port | Port to connect on [Default: port 21]
Renvoie
boolean True if successful
Depuis
3.0.0

Références FtpClient\_verifyResponse(), Log\add(), null, Text\sprintf(), et Log\WARNING.

◆ create()

create ( $path )

Method to create an empty file on the FTP server

Paramètres
string $path Path local file to store on the FTP server
Renvoie
boolean True if successful
Depuis
1.5

Références $buffer, $path, FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ delete()

delete ( $path )

Method to delete a path [file/folder] on the FTP server

Paramètres
string $path Path to delete
Renvoie
boolean True if successful
Depuis
1.5

Références $path, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ get()

get | ( | $local,
 |  | $remote
 | ) |

Method to get a file from the FTP server and save it to a local file

Paramètres
string | $local | Local path to save remote file to
string | $remote | Path to remote file to get on the FTP server
Renvoie
boolean True if successful
Depuis
1.5

Références $buffer, $mode, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ getInstance()

static getInstance | ( |  | $host = '127.0.0.1',
 |  |  | $port = '21',
 |  | array | $options = array(),
 |  |  | $user = null,
 |  |  | $pass = null
 | ) |  |
static

Returns the global FTP connector object, only creating it if it doesn't already exist.

You may optionally specify a username and password in the parameters. If you do so, you may not login() again with different credentials using the same object. If you do not use this option, you must quit() the current connection when you are done, to free it for use by others.

Paramètres
string | $host | Host to connect to
string | $port | Port to connect to
array | $options | Array with any of these options: type=>[FTP_AUTOASCII|FTP_ASCII|FTP_BINARY], timeout=>(int)
string | $user | Username to use for a connection
string | $pass | Password to use for a connection
Renvoie
FtpClient The FTP Client object.
Depuis
1.5

Références $options, $return, $user, FtpClient\isConnected(), et null.

Référencé par File\append(), Folder\copy(), File\copy(), Folder\create(), File\delete(), Folder\delete(), File\move(), Folder\move(), ClientHelper\setCredentials(), File\upload(), et File\write().

◆ isConnected()

isConnected ( )

Method to determine if the object is connected to an FTP server

Renvoie
boolean True if connected
Depuis
1.5

Référencé par FtpClient\getInstance().

◆ listDetails()

listDetails | ( | $path = null,
 |  | $type = 'all'
 | ) |

Method to list the contents of a directory on the FTP server

Paramètres
string | $path | Path to the local file to be stored on the FTP server
string | $type | Return type [raw|all|folders|files]
Renvoie
mixed If $type is raw: string Directory listing, otherwise array of string with file-names
Depuis
1.5

Références $data, $path, $type, FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), null, Text\sprintf(), et Log\WARNING.

Référencé par FtpClient\listNames().

◆ listNames()

listNames ( $path = null )

Method to list the filenames of the contents of a directory on the FTP server

Note: Some servers also return folder names. However, to be sure to list folders on all servers, you should use listDetails() instead if you also need to deal with folders

Paramètres
string $path Path local file to store on the FTP server
Renvoie
string Directory listing
Depuis
1.5

Références $data, $key, $list, $path, FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), FtpClient\listDetails(), null, Text\sprintf(), et Log\WARNING.

◆ login()

login | ( | $user = 'anonymous',
 |  | $pass = 'jftp@joomla.org'
 | ) |

Method to login to a server once connected

Paramètres
string | $user | Username to login to the server
string | $pass | Password to login to the server
Renvoie
boolean True if successful
Depuis
1.5

Références $user, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ mkdir()

mkdir ( $path )

Method to create a directory on the FTP server

Paramètres
string $path Directory to create
Renvoie
boolean True if successful
Depuis
1.5

Références $path, FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ pwd()

pwd ( )

Method to retrieve the current working directory on the FTP server

Renvoie
string Current working directory
Depuis
1.5

Références FtpClient\_putCmd(), Log\add(), null, Text\sprintf(), et Log\WARNING.

◆ quit()

quit ( )

Method to quit and close the connection

Renvoie
boolean True if successful
Depuis
1.5

Référencé par FtpClient\__destruct().

◆ read()

read | ( |  | $remote,
 |  | & | $buffer
 | ) |  |

Method to read a file from the FTP server's contents into a buffer

Paramètres
string | $remote | Path to remote file to read on the FTP server
string | &$buffer | Buffer variable to read file contents into
Renvoie
boolean True if successful
Depuis
1.5

Références $buffer, $mode, $os, $tmp, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ reinit()

reinit ( )

Method to reinitialise the server, ie. need to login again

NOTE: This command not available on all servers

Renvoie
boolean True if successful
Depuis
1.5

Références FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ rename()

rename | ( | $from,
 |  | $to
 | ) |

Method to rename a file/folder on the FTP server

Paramètres
string | $from | Path to change file/folder from
string | $to | Path to change file/folder to
Renvoie
boolean True if successful
Depuis
1.5

Références FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ restart()

restart ( $point )

Method to restart data transfer at a given byte

Paramètres
integer $point Byte to restart transfer at
Renvoie
boolean True if successful
Depuis
1.5

Références FtpClient\_putCmd(), Log\add(), Text\sprintf(), et Log\WARNING.

◆ setOptions()

setOptions ( array $options )

Set client options

Paramètres
array $options Associative array of options to set
Renvoie
boolean True if successful
Depuis
1.5

Références $options.

Référencé par FtpClient\__construct().

◆ size()

size ( $remote )

Get the size of the remote file.

Paramètres
string $remote FTP path to file whose size to get
Renvoie
mixed number of bytes or false on error
Depuis
3.6.0

Références $size, FtpClient\_passive(), FtpClient\_putCmd(), et Text\sprintf().

Référencé par FtpClient\append().

◆ store()

store | ( | $local,
 |  | $remote = null
 | ) |

Method to store a file to the FTP server

Paramètres
string | $local | Path to local file to store on the FTP server
string | $remote | FTP path to file to create
Renvoie
boolean True if successful
Depuis
1.5

Références $mode, $result, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), null, Text\sprintf(), et Log\WARNING.

◆ syst()

syst ( )

Method to system string from the FTP server

Renvoie
string System identifier string
Depuis
1.5

Références FtpClient\$_response, FtpClient\_putCmd(), Log\add(), elseif, Text\sprintf(), et Log\WARNING.

◆ write()

write | ( | $remote,
 |  | $buffer
 | ) |

Method to write a string to the FTP server

Paramètres
string | $remote | FTP path to file to write to
string | $buffer | Contents to write to the FTP server
Renvoie
boolean True if successful
Depuis
1.5

Références $buffer, $mode, $result, $tmp, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), Log\add(), Text\sprintf(), et Log\WARNING.

Documentation des champs

◆ $_autoAscii

$_autoAscii
protected
Valeur initiale :
= array(
'asp',
'bat',
'c',
'cpp',
'csv',
'h',
'htm',
'html',
'shtml',
'ini',
'inc',
'log',
'php',
'php3',
'pl',
'perl',
'sh',
'sql',
'txt',
'xhtml',
'xml',
)

◆ $_conn

$_conn = null
protected

◆ $_dataconn

$_dataconn = null
protected

◆ $_lineEndings

$_lineEndings = array('UNIX' => "\n", 'WIN' => "\r\n")
protected

◆ $_pasv

$_pasv = null
protected

◆ $_response

$_response = null
protected

Référencé par FtpClient\syst().

◆ $_timeout

$_timeout = 15
protected

Référencé par FtpClient\_passive(), et FtpClient\_verifyResponse().

◆ $_type

$_type = null
protected

◆ $instances

$instances = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Client/FtpClient.php


Joomla CMS: Référence de la classe MissingComponentException

  • Joomla
  • CMS
  • Component
  • Exception
  • MissingComponentException
Fonctions membres publiques
Référence de la classe MissingComponentException
+ Graphe d'héritage de MissingComponentException:
RouteNotFoundException

Fonctions membres publiques

__construct ($message='', $code=404, \Exception $previous=null)
- Fonctions membres publiques hérités de RouteNotFoundException
__construct ($message='', $code=404, \Exception $previous=null)

Description détaillée

Exception class defining an error for a missing component

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = '',
 |  |  | $code = 404,
 |  | \Exception | $previous = null
 | ) |  |

Constructor

Paramètres
string | $message | The Exception message to throw.
integer | $code | The Exception code.
\Exception | $previous | The previous exception used for the exception chaining.
Depuis
3.7.0

Références $message, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MissingComponentException.php


Joomla CMS: Référence de la classe MenuRules

  • Joomla
  • CMS
  • Component
  • Router
  • Rules
  • MenuRules
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MenuRules
+ Graphe d'héritage de MenuRules:
RulesInterface

Fonctions membres publiques

__construct (RouterView $router)
preprocess (&$query)
parse (&$segments, &$vars)
build (&$query, &$segments)

Fonctions membres protégées

buildLookup ($language=' *')

Attributs protégés

$router
$lookup = array()

Description détaillée

Rule to identify the right Itemid for a view in a component

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( RouterView $router )

Class constructor.

Paramètres
RouterView $router Router this rule belongs to
Depuis
3.4

Documentation des fonctions membres

◆ build()

build | ( | & | $query,
 |  | & | $segments
 | ) |  |

Dummy method to fulfil the interface requirements

Paramètres
array | &$query | The vars that should be converted
array | &$segments | The URL segments to create
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

◆ buildLookup()

buildLookup ( $language = '*' )
protected

Method to build the lookup array

Paramètres
string $language The language that the lookup should be built up for
Renvoie
void
Depuis
3.4

Here it will become a bit tricky language != * can override existing entries language == * cannot override existing entries

Here it will become a bit tricky language != * can override existing entries language == * cannot override existing entries

Références $attributes, $component, $item, $items, $language, $layout, $view, et ComponentHelper\getComponent().

◆ parse()

parse | ( | & | $segments,
 |  | & | $vars
 | ) |  |

Dummy method to fulfil the interface requirements

Paramètres
array | &$segments | The URL segments to parse
array | &$vars | The vars that result from the segments
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

◆ preprocess()

preprocess ( & $query )

Finds the right Itemid for this query

Paramètres
array &$query The query array to process
Renvoie
void
Depuis
3.4

If the active item id is not the same as the supplied item id or we have a supplied item id and no active menu item then we just use the supplied menu item and continue

Implémente RulesInterface.

Références $active, $default, $id, $language, $layout, $query, $this, $view, Multilanguage\isEnabled(), et null.

Documentation des champs

◆ $lookup

$lookup = array()
protected

◆ $router

$router
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuRules.php


Joomla CMS: Référence de la classe NomenuRules

  • Joomla
  • CMS
  • Component
  • Router
  • Rules
  • NomenuRules
Fonctions membres publiques | Attributs protégés
Référence de la classe NomenuRules
+ Graphe d'héritage de NomenuRules:
RulesInterface

Fonctions membres publiques

__construct (RouterView $router)
preprocess (&$query)
parse (&$segments, &$vars)
build (&$query, &$segments)

Attributs protégés

$router

Description détaillée

Rule to process URLs without a menu item

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( RouterView $router )

Class constructor.

Paramètres
RouterView $router Router this rule belongs to
Depuis
3.4

Documentation des fonctions membres

◆ build()

build | ( | & | $query,
 |  | & | $segments
 | ) |  |

Build a menu-less URL

Paramètres
array | &$query | The vars that should be converted
array | &$segments | The URL segments to create
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Références $item, $query, $result, et $view.

◆ parse()

parse | ( | & | $segments,
 |  | & | $vars
 | ) |  |

Parse a menu-less URL

Paramètres
array | &$segments | The URL segments to parse
array | &$vars | The vars that result from the segments
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Références $active, $result, $this, et $view.

◆ preprocess()

preprocess ( & $query )

Dummy method to fulfil the interface requirements

Paramètres
array &$query The query array to process
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Documentation des champs

◆ $router

$router
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NomenuRules.php


Joomla CMS: Référence de l'interface RulesInterface

  • Joomla
  • CMS
  • Component
  • Router
  • Rules
  • RulesInterface
Fonctions membres publiques
Référence de l'interface RulesInterface
+ Graphe d'héritage de RulesInterface:
MenuRules NomenuRules StandardRules

Fonctions membres publiques

preprocess (&$query)
parse (&$segments, &$vars)
build (&$query, &$segments)

Description détaillée

RouterRules interface for Joomla

Depuis
3.4

Documentation des fonctions membres

◆ build()

build | ( | & | $query,
 |  | & | $segments
 | ) |  |

Builds URI segments from a query to encode the necessary information for a route in a human-readable URL. This method should retrieve all its input from its method arguments.

Paramètres
array | &$query | The vars that should be converted
array | &$segments | The URL segments to create
Renvoie
void
Depuis
3.4

Implémenté dans MenuRules, StandardRules, et NomenuRules.

◆ parse()

parse | ( | & | $segments,
 |  | & | $vars
 | ) |  |

Parses a URI to retrieve information for the right route through the component. This method should retrieve all its input from its method arguments.

Paramètres
array | &$segments | The URL segments to parse
array | &$vars | The vars that result from the segments
Renvoie
void
Depuis
3.4

Implémenté dans MenuRules, NomenuRules, et StandardRules.

◆ preprocess()

preprocess ( & $query )

Prepares a query set to be handed over to the build() method. This should complete a partial query set to work as a complete non-SEFed URL and in general make sure that all information is present and properly formatted. For example, the Itemid should be retrieved and set here.

Paramètres
array &$query The query array to process
Renvoie
void
Depuis
3.4

Implémenté dans MenuRules, NomenuRules, et StandardRules.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RulesInterface.php


Joomla CMS: Référence de la classe StandardRules

  • Joomla
  • CMS
  • Component
  • Router
  • Rules
  • StandardRules
Fonctions membres publiques | Attributs protégés
Référence de la classe StandardRules
+ Graphe d'héritage de StandardRules:
RulesInterface

Fonctions membres publiques

__construct (RouterView $router)
preprocess (&$query)
parse (&$segments, &$vars)
build (&$query, &$segments)

Attributs protégés

$router

Description détaillée

Rule for the standard handling of component routing

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( RouterView $router )

Class constructor.

Paramètres
RouterView $router Router this rule belongs to
Depuis
3.4

Documentation des fonctions membres

◆ build()

build | ( | & | $query,
 |  | & | $segments
 | ) |  |

Build a standard URL

Paramètres
array | &$query | The vars that should be converted
array | &$segments | The URL segments to create
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Références $id, $item, $path, $query, $this, $view, elseif, et null.

◆ parse()

parse | ( | & | $segments,
 |  | & | $vars
 | ) |  |

Parse the URL

Paramètres
array | &$segments | The URL segments to parse
array | &$vars | The vars that result from the segments
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Références $active, $key, $view, children, elseif, et name.

◆ preprocess()

preprocess ( & $query )

Dummy method to fulfil the interface requirements

Paramètres
array &$query The query array to process
Renvoie
void
Depuis
3.4

Implémente RulesInterface.

Documentation des champs

◆ $router

$router
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StandardRules.php


Joomla CMS: Référence de la classe RouterBase

  • Joomla
  • CMS
  • Component
  • Router
  • RouterBase
Fonctions membres publiques | Champs de données
Référence de la classe RouterBase
+ Graphe d'héritage de RouterBase:
RouterInterface RouterView Router Router Router Router Router Router Router Router Router Router

Fonctions membres publiques

__construct ($app=null, $menu=null)
preprocess ($query)
- Fonctions membres publiques hérités de RouterInterface
build (&$query)
parse (&$segments)

Champs de données

$app
$menu

Description détaillée

Base component routing class

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $app = null,
 |  | $menu = null
 | ) |

Class constructor.

Paramètres
\Joomla\CMS\Application\CMSApplication | $app | Application-object that the router should use
\Joomla\CMS\Menu\AbstractMenu | $menu | Menu-object that the router should use
Depuis
3.4

Références $app, $menu, et Factory\getApplication().

Documentation des fonctions membres

◆ preprocess()

preprocess ( $query )

Generic method to preprocess a URL

Paramètres
array $query An associative array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $query.

Documentation des champs

◆ $app

$app

◆ $menu

$menu
La documentation de cette classe a été générée à partir du fichier suivant :
  • RouterBase.php


Joomla CMS: Référence de la classe RouterFactory

  • Joomla
  • CMS
  • Component
  • Router
  • RouterFactory
Fonctions membres publiques | Attributs privés
Référence de la classe RouterFactory
+ Graphe d'héritage de RouterFactory:
RouterFactoryInterface

Fonctions membres publiques

__construct ($namespace, CategoryFactoryInterface $categoryFactory=null, DatabaseInterface $db=null)
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Attributs privés

$namespace
$categoryFactory
$db

Description détaillée

Default router factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $namespace,
 |  | CategoryFactoryInterface | $categoryFactory = null,
 |  | DatabaseInterface | $db = null
 | ) |  |

The namespace must be like: Joomla

Paramètres
string | $namespace | The namespace
CategoryFactoryInterface | $categoryFactory | The category object
DatabaseInterface | $db | The database object
Depuis
4.0.0

Références $db, et $namespace.

Documentation des fonctions membres

◆ createRouter()

createRouter | ( | CMSApplicationInterface | $application,
 |  | AbstractMenu | $menu
 | ) |  |

Creates a router.

Paramètres
CMSApplicationInterface | $application | The application
AbstractMenu | $menu | The menu object to work with
Renvoie
RouterInterface
Depuis
4.0.0

Implémente RouterFactoryInterface.

Références $className, $menu, et CMSApplicationInterface\getName().

Documentation des champs

◆ $categoryFactory

$categoryFactory
private

◆ $db

$db
private

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Component/Router/RouterFactory.php


Joomla CMS: Référence de l'interface RouterFactoryInterface

  • Joomla
  • CMS
  • Component
  • Router
  • RouterFactoryInterface
Fonctions membres publiques
Référence de l'interface RouterFactoryInterface
+ Graphe d'héritage de RouterFactoryInterface:
RouterFactory

Fonctions membres publiques

createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Router factory interface

Depuis
4.0.0

Documentation des fonctions membres

◆ createRouter()

createRouter | ( | CMSApplicationInterface | $application,
 |  | AbstractMenu | $menu
 | ) |  |

Creates a router.

Paramètres
CMSApplicationInterface | $application | The application
AbstractMenu | $menu | The menu object to work with
Renvoie
RouterInterface
Depuis
4.0.0

Implémenté dans RouterFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RouterFactoryInterface.php


Joomla CMS: Référence de l'interface RouterInterface

  • Joomla
  • CMS
  • Component
  • Router
  • RouterInterface
Fonctions membres publiques
Référence de l'interface RouterInterface
+ Graphe d'héritage de RouterInterface:
RouterBase RouterLegacy RouterView Router Router Router Router Router Router Router Router Router Router

Fonctions membres publiques

preprocess ($query)
build (&$query)
parse (&$segments)

Description détaillée

Component routing interface

Depuis
3.3

Documentation des fonctions membres

◆ build()

build ( & $query )

Build method for URLs This method is meant to transform the query parameters into a more human readable form. It is only executed when SEF mode is switched on.

Paramètres
array &$query An array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémenté dans RouterView, Router, RouterLegacy, Router, et Router.

◆ parse()

parse ( & $segments )

Parse method for URLs This method is meant to transform the human readable URL back into query parameters. It is only executed when SEF mode is switched on.

Paramètres
array &$segments The segments of the URL to parse.
Renvoie
array The URL attributes to be used by the application.
Depuis
3.3

Implémenté dans RouterView, Router, RouterLegacy, Router, et Router.

◆ preprocess()

preprocess ( $query )

Prepare-method for URLs This method is meant to validate and complete the URL parameters. For example it can add the Itemid or set a language parameter. This method is executed on each URL, regardless of SEF mode switched on or not.

Paramètres
array $query An associative array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémenté dans RouterView, RouterBase, et RouterLegacy.

La documentation de cette interface a été générée à partir du fichier suivant :
  • src/Component/Router/RouterInterface.php


Joomla CMS: Référence de la classe RouterLegacy

  • Joomla
  • CMS
  • Component
  • Router
  • RouterLegacy
Fonctions membres publiques | Attributs protégés
Référence de la classe RouterLegacy
+ Graphe d'héritage de RouterLegacy:
RouterInterface

Fonctions membres publiques

__construct ($component)
preprocess ($query)
build (&$query)
parse (&$segments)

Attributs protégés

$component

Description détaillée

Default routing class for missing or legacy component routers

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $component )

Constructor

Paramètres
string $component Component name without the com_ prefix this router should react upon
Depuis
3.3

Références $component.

Documentation des fonctions membres

◆ build()

build ( & $query )

Generic build function for missing or legacy component router

Paramètres
array &$query An array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $function, $i, $query, et $total.

◆ parse()

parse ( & $segments )

Generic parse function for missing or legacy component router

Paramètres
array &$segments The segments of the URL to parse.
Renvoie
array The URL attributes to be used by the application.
Depuis
3.3

Implémente RouterInterface.

Références $function, $i, et $total.

◆ preprocess()

preprocess ( $query )

Generic preprocess function for missing or legacy component router

Paramètres
array $query An associative array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $query.

Documentation des champs

◆ $component

$component
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RouterLegacy.php


Joomla CMS: Référence de l'interface RouterServiceInterface

  • Joomla
  • CMS
  • Component
  • Router
  • RouterServiceInterface
Fonctions membres publiques
Référence de l'interface RouterServiceInterface
+ Graphe d'héritage de RouterServiceInterface:
LegacyComponent BannersComponent ConfigComponent ContactComponent ContentComponent FinderComponent NewsfeedsComponent PrivacyComponent TagsComponent UsersComponent WrapperComponent

Fonctions membres publiques

createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

The component router service.

Depuis
4.0.0

Documentation des fonctions membres

◆ createRouter()

createRouter | ( | CMSApplicationInterface | $application,
 |  | AbstractMenu | $menu
 | ) |  |

Returns the router.

Paramètres
CMSApplicationInterface | $application | The application object
AbstractMenu | $menu | The menu object to work with
Renvoie
RouterInterface
Depuis
4.0.0

Implémenté dans LegacyComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RouterServiceInterface.php


Joomla CMS: Référence de la classe RouterView

  • Joomla
  • CMS
  • Component
  • Router
  • RouterView
Fonctions membres publiques | Attributs protégés
Référence de la classe RouterView
+ Graphe d'héritage de RouterView:
RouterBase RouterInterface Router Router Router Router Router Router Router

Fonctions membres publiques

registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Attributs protégés

$name
$rules = array()
$views = array()

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

View-based component routing class

Depuis
3.5

Documentation des fonctions membres

◆ attachRule()

attachRule ( RulesInterface $rule )

Attach a build rule

Paramètres
RulesInterface $rule The function to be called.
Renvoie
void
Depuis
3.5

◆ attachRules()

attachRules ( $rules )

Add a number of router rules to the object

Paramètres
RulesInterface[] $rules Array of JComponentRouterRulesInterface objects
Renvoie
void
Depuis
3.5

◆ build()

build ( & $query )

Build method for URLs

Paramètres
array &$query Array of query elements
Renvoie
array Array of URL segments
Depuis
3.5

Implémente RouterInterface.

Références $query.

◆ detachRule()

detachRule ( RulesInterface $rule )

Remove a build rule

Paramètres
RulesInterface $rule The rule to be removed.
Renvoie
boolean Was a rule removed?
Depuis
3.5

Références $id, et $r.

◆ getName()

getName ( )

Method to return the name of the router

Renvoie
string Name of the router
Depuis
3.5

Références $name, $r, $this, ComponentHelper\getComponentName(), name, et null.

◆ getPath()

getPath ( $query )

Get the path of views from target view to root view including content items of a nestable view

Paramètres
array $query Array of query elements
Renvoie
array List of views including IDs of content items
Depuis
3.5

Références $key, $path, $query, $result, $start, $this, $view, et elseif.

◆ getRules()

getRules ( )

Get all currently attached rules

Renvoie
RulesInterface[] All currently attached rules in an array
Depuis
3.5

◆ getViews()

getViews ( )

Return an array of registered view objects

Renvoie
RouterViewConfiguration[] Array of registered view objects
Depuis
3.5

◆ parse()

parse ( & $segments )

Parse method for URLs

Paramètres
array &$segments Array of URL string-segments
Renvoie
array Associative array of query values
Depuis
3.5

Implémente RouterInterface.

◆ preprocess()

preprocess ( $query )

Generic method to preprocess a URL

Paramètres
array $query An associative array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.5

Implémente RouterInterface.

Références $query.

◆ registerView()

registerView ( RouterViewConfiguration $view )

Register the views of a component

Paramètres
RouterViewConfiguration $view View configuration object
Renvoie
void
Depuis
3.5

Références $view.

Documentation des champs

◆ $name

$name
protected

◆ $rules

$rules = array()
protected

◆ $views

$views = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RouterView.php


Joomla CMS: Référence de la classe RouterViewConfiguration

  • Joomla
  • CMS
  • Component
  • Router
  • RouterViewConfiguration
Fonctions membres publiques | Champs de données
Référence de la classe RouterViewConfiguration

Fonctions membres publiques

__construct ($name)
setName ($name)
setKey ($key)
setParent (RouterViewConfiguration $parent, $parentKey=null)
setNestable ($isNestable=true)
addLayout ($layout)
removeLayout ($layout)

Champs de données

$name
$key = false
$parent = false
$parent_key = false
$nestable = false
$layouts = array('default')
$children = array()
$child_keys = array()
$path = array()

Description détaillée

View-configuration class for the view-based component router

Depuis
3.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $name )

Constructor for the View-configuration class

Paramètres
string $name Name of the view
Depuis
3.5

Références $name, name, et path.

Documentation des fonctions membres

◆ addLayout()

addLayout ( $layout )

Add a layout to this view

Paramètres
string $layout Layouts that this view supports
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $layout, et $this.

◆ removeLayout()

removeLayout ( $layout )

Remove a layout from this view

Paramètres
string $layout Layouts that this view supports
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $key, $layout, et $this.

◆ setKey()

setKey ( $key )

Set the key-identifier for the view

Paramètres
string $key Key of the view
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $key, et $this.

◆ setName()

setName ( $name )

Set the name of the view

Paramètres
string $name Name of the view
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $name, $this, name, et path.

◆ setNestable()

setNestable ( $isNestable = true )

Set if this view is nestable or not

Paramètres
bool $isNestable If set to true, the view is nestable
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $this.

◆ setParent()

setParent | ( | RouterViewConfiguration | $parent,
 |  |  | $parentKey = null
 | ) |  |

Set the parent view of this view

Paramètres
RouterViewConfiguration | $parent | Parent view object
string | $parentKey | Key of the parent view in this context
Renvoie
RouterViewConfiguration This object for chaining
Depuis
3.5

Références $key, $name, $this, parent, et path.

Documentation des champs

◆ $child_keys

$child_keys = array()

◆ $children

$children = array()

◆ $key

$key = false

◆ $layouts

$layouts = array('default')

◆ $name

$name

◆ $nestable

$nestable = false

◆ $parent

$parent = false

◆ $parent_key

$parent_key = false

◆ $path

$path = array()
La documentation de cette classe a été générée à partir du fichier suivant :
  • RouterViewConfiguration.php


Joomla CMS: Référence de la classe ComponentHelper

  • Joomla
  • CMS
  • Component
  • ComponentHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe ComponentHelper

Fonctions membres publiques statiques

static | getComponent ($option, $strict=false)
static | isEnabled ($option)
static | isInstalled ($option)
static | getParams ($option, $strict=false)
static | filterText ($text)
static | getComponents ()
static | getComponentName ($object, string $alternativeName)

Attributs protégés statiques

static $components = array()

Description détaillée

Component helper class

Depuis
1.5

Documentation des fonctions membres

◆ filterText()

static filterText ( $text )
static

Applies the global text filters to arbitrary text as per settings for current user groups

Paramètres
string $text The string to filter
Renvoie
string The filtered string
Depuis
2.5

Références $attributes, $config, $filters, $text, $user, elseif, Access\getGroupsByUser(), InputFilter\getInstance(), Factory\getUser(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

◆ getComponent()

static getComponent | ( | $option,
 |  | $strict = false
 | ) |
static

Get the component information.

Paramètres
string | $option | The component option.
boolean | $strict | If set and the component does not exist, the enabled attribute will be set to false.
Renvoie
ComponentRecord An object with the information for the component.
Depuis
1.5

Références $option, $result, et false.

Référencé par Joomla\__construct(), RouteHelper\_findItem(), ActionlogModel\addLog(), MenuRules\buildLookup(), JsonapiView\displayList(), RouteHelper\findItem(), DatabaseModel\fixDefaultTextFilters(), ComponentModel\getComponent(), ItemModel\getItem(), RouteHelper\getItemid(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), et ItemController\setType().

◆ getComponentName()

static getComponentName | ( |  | $object,
 |  | string | $alternativeName
 | ) |  |
static

Returns the component name (eg. com_content) for the given object based on the class name. If the object is not namespaced, then the alternative name is used.

Paramètres
object | $object | The object controller or model
string | $alternativeName | Mostly the value of getName() from the object
Renvoie
string The name
Depuis
4.0.0

Références class.

Référencé par ComponentDispatcher\__construct(), AdminController\__construct(), BaseDatabaseModel\__construct(), FormController\__construct(), ApiController\__construct(), et RouterView\getName().

◆ getComponents()

static getComponents ( )
static

Get installed components

Renvoie
ComponentRecord[] The components property
Depuis
3.6.3

Référencé par MenusHelper\getPresets(), et Access\preloadComponents().

◆ getParams()

static getParams | ( | $option,
 |  | $strict = false
 | ) |
static

Gets the parameter object for the component

Paramètres
string | $option | The option for the component.
boolean | $strict | If set and the component does not exist, false will be returned
Renvoie
Registry A Registry object.
Voir également
Registry
Depuis
1.5

Références $option.

Référencé par Response\__construct(), TagField\__construct(), Router\__construct(), Result\__construct(), PlgUserJoomla\_getUser(), Task\acquireLock(), RegistrationModel\activate(), Tag\ajaxfield(), UpdateModel\applyUpdateSite(), IndexerController\batch(), LinksController\batch(), LinksModel\batchProcess(), ContactModel\buildContactExtendedData(), QueryHelper\buildVotingQuery(), Mfa\canAddEditMethod(), TemplateHelper\canUpload(), MediaHelper\canUpload(), LinkTable\check(), UpdateModel\checkCompatibility(), ApiController\checkContent(), MediaController\checkContent(), MediaHelper\checkFileExtension(), TemplateModel\checkFormat(), MediaHelper\checkMimeType(), BannerModel\click(), Help\createUrl(), OpensearchView\display(), DisplayController\display(), HtmlView\display(), CaptiveModel\getAllowedModulePositions(), UserModel\getAssignedGroups(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), ApplicationModel\getData(), InstalledModel\getData(), RegistrationModel\getData(), Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName(), Helper\getDefaultLanguage(), SysinfoModel\getDirectory(), ArticlesModel\getFilterForm(), ActionlogsModel\getFilterForm(), LinkModel\getForm(), TemplateModel\getForm(), ProfileModel\getForm(), UserModel\getForm(), Access\getGroupsByUser(), NumberField\getInput(), TextField\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), ArticlesModel\getItems(), TagsHelper\getItemTags(), MediaField\getLayoutData(), TagsPopularHelper\getList(), ArticlesPopularHelper\getList(), BannersHelper\getList(), TagsSimilarHelper\getList(), ArticlesCategoryHelper\getList(), BannersModel\getListQuery(), TagsModel\getListQuery(), ClientsModel\getListQuery(), TasksModel\getListQuery(), TagModel\getListQuery(), ArticlesModel\getListQuery(), ModuleHelper\getModules(), LanguageField\getOptions(), ListField\getOptions(), TagField\getOptions(), CaptiveModel\getPageTitle(), SiteApplication\getParams(), PrivacyStatusHelper\getRequestFormPublished(), Indexer\getState(), SuggestionsController\getSuggestions(), UpdateModel\getUpdateInformation(), BannersModel\impress(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), ModuleHelper\isAdminMultilang(), Helper\isCommon(), ApiModel\isMediaFile(), Joomla\CMS\Workflow\isWorkflowActive(), FinderHelper\logSearch(), PlgSampledataMultilang\onAjaxSampledataApplyStep6(), PlgContentJoomla\onContentAfterSave(), PlgSystemHighlight\onFinderResult(), ConfigModel\populateState(), SelectModel\populateState(), SearchesModel\populateState(), ClientsModel\populateState(), PositionsModel\populateState(), GroupsModel\populateState(), LevelsModel\populateState(), StylesModel\populateState(), TemplatesModel\populateState(), LanguagesModel\populateState(), PluginsModel\populateState(), TracksModel\populateState(), ModulesModel\populateState(), TagModel\populateState(), LanguageModel\populateState(), NewsfeedsModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), ArticlesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), StyleModel\populateState(), MenuModel\populateState(), InstalledModel\populateState(), CapabilitiesModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ModuleModel\populateState(), FiltersModel\populateState(), RequestsModel\populateState(), SuggestionsModel\populateState(), ConsentsModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), RemoveModel\populateState(), TaskModel\populateState(), BannersModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), ExportModel\populateState(), IndexModel\populateState(), TemplateModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), AdminModel\populateState(), Menu\preprocess(), CssMenu\preprocess(), ProfileModel\preprocessForm(), RegistrationModel\preprocessForm(), Query\processString(), InstalledModel\publish(), UpdateModel\refreshUpdates(), RegistrationModel\register(), ModuleHelper\renderModule(), ProfileModel\save(), MessageModel\save(), MailModel\send(), IndexerController\sendResponse(), LanguagesModel\setDefault(), UploaddirsField\setup(), PasswordField\setup(), LanguageAdapter\setupUninstall(), Joomla\CMS\MVC\Model\setUpWorkflow(), IndexerController\start(), Helper\stem(), Versioning\store(), ApplicationHelper\stringURLSafe(), ContactEmailMessageRule\test(), ContactEmailRule\test(), ContactEmailSubjectRule\test(), PasswordRule\test(), EmailRule\test(), Helper\tokenize(), et Indexer\tokenizeToDbShort().

◆ isEnabled()

static isEnabled ( $option )
static

Checks if the component is enabled

Paramètres
string $option The component option.
Renvoie
boolean
Depuis
1.5

Références $option.

Référencé par HtmlView\addToolbar(), FormView\addToolbar(), PlgFinderContacts\index(), PlgFinderNewsfeeds\index(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSampledataMultilang\onAjaxSampledataApplyStep3(), PlgSampledataMultilang\onAjaxSampledataApplyStep4(), PlgSampledataMultilang\onAjaxSampledataApplyStep5(), PlgSampledataMultilang\onAjaxSampledataApplyStep6(), PlgSampledataMultilang\onAjaxSampledataApplyStep7(), PlgButtonFields\onDisplay(), Menu\preprocess(), CssMenu\preprocess(), et FileLayout\validComponent().

◆ isInstalled()

static isInstalled ( $option )
static

Checks if a component is installed

Paramètres
string $option The component option.
Renvoie
integer
Depuis
3.4

Références $option.

Documentation des champs

◆ $components

$components = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentHelper.php


Joomla CMS: Référence de la classe ComponentRecord

  • Joomla
  • CMS
  • Component
  • ComponentRecord
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe ComponentRecord

Fonctions membres publiques

__construct ($data=array())
__get ($name)
__set ($name, $value)
getParams ()
setParams ($params)

Champs de données

$id
$option
$namespace
$enabled

Attributs protégés

$params

Description détaillée

Object representing a component extension record

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $data = array() )

Class constructor

Paramètres
array $data The component record data to load
Depuis
3.7.0

Références $data, $key, et $value.

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.7.0
Obsolète:
5.0 Access the item parameters through the getParams() method

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.7.0
Obsolète:
5.0 Set the item parameters through the setParams() method

Références $name, et $value.

◆ getParams()

getParams ( )

Returns the menu item parameters

Renvoie
Registry
Depuis
3.7.0

Références $params.

◆ setParams()

setParams ( $params )

Sets the menu item parameters

Paramètres
Registry | string $params The data to be stored as the parameters
Renvoie
void
Depuis
3.7.0

Références $params.

Documentation des champs

◆ $enabled

$enabled

◆ $id

$id

◆ $namespace

$namespace

◆ $option

$option

◆ $params

$params
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentRecord.php


Joomla CMS: Référence de la classe WritableContainerLoader

  • Joomla
  • CMS
  • Console
  • Loader
  • WritableContainerLoader
Fonctions membres publiques | Attributs privés
Référence de la classe WritableContainerLoader
+ Graphe d'héritage de WritableContainerLoader:
WritableLoaderInterface LoaderInterface

Fonctions membres publiques

__construct (ContainerInterface $container, array $commandMap)
add (string $commandName, string $className)
get (string $name)
getNames ()
has ($name)

Attributs privés

$container
$commandMap

Description détaillée

PSR-11 compatible writable command loader.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ContainerInterface | $container,
 |  | array | $commandMap
 | ) |  |

Constructor.

Paramètres
ContainerInterface | $container | A container from which to load command services.
array | $commandMap | An array with command names as keys and service IDs as values.
Depuis
4.0.0

Références $container.

Documentation des fonctions membres

◆ add()

add | ( | string | $commandName,
 |  | string | $className
 | ) |  |

Adds a command to the loader.

Paramètres
string | $commandName | The name of the command to load.
string | $className | The fully qualified class name of the command.
Renvoie
void
Depuis
4.0.0

Implémente WritableLoaderInterface.

Références $className.

◆ get()

get ( string $name )

Loads a command.

Paramètres
string $name The command to load.
Renvoie
AbstractCommand
Depuis
4.0.0
Exceptions
CommandNotFoundException

Implémente LoaderInterface.

Références $name, et Symfony\Contracts\Service\has().

◆ getNames()

getNames ( )

Get the names of the registered commands.

Renvoie
string[]
Depuis
4.0.0

Implémente LoaderInterface.

◆ has()

has ( $name )

Checks if a command exists.

Paramètres
string $name The command to check.
Renvoie
boolean
Depuis
4.0.0

Implémente LoaderInterface.

Références $name.

Documentation des champs

◆ $commandMap

$commandMap
private

◆ $container

$container
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • WritableContainerLoader.php


Joomla CMS: Référence de l'interface WritableLoaderInterface

  • Joomla
  • CMS
  • Console
  • Loader
  • WritableLoaderInterface
Fonctions membres publiques
Référence de l'interface WritableLoaderInterface
+ Graphe d'héritage de WritableLoaderInterface:
LoaderInterface WritableContainerLoader

Fonctions membres publiques

add (string $commandName, string $className)
- Fonctions membres publiques hérités de LoaderInterface
get (string $name)
getNames ()
has ($name)

Description détaillée

Interface defining a writable command loader.

Depuis
4.0.0

Documentation des fonctions membres

◆ add()

add | ( | string | $commandName,
 |  | string | $className
 | ) |  |

Adds a command to the loader.

Paramètres
string | $commandName | The name of the command to load.
string | $className | The fully qualified class name of the command.
Renvoie
void
Depuis
4.0.0

Implémenté dans WritableContainerLoader.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WritableLoaderInterface.php


Joomla CMS: Référence de la classe AddUserCommand

  • Joomla
  • CMS
  • Console
  • AddUserCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe AddUserCommand
+ Graphe d'héritage de AddUserCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
getStringFromOption ($option, $question)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
getGroupId ($groupName)
getUserGroups ()
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:add'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle
$cliInput
$user
$password
$name
$email
$userGroups = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for adding a user

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_OPTIONAL.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, $password, $user, Command\FAILURE, User\getInstance(), name, et Command\SUCCESS.

◆ getGroupId()

getGroupId ( $groupName )
protected

Method to get groupId by groupName

Paramètres
string $groupName name of group
Renvoie
integer
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getStringFromOption()

getStringFromOption | ( | $option,
 |  | $question
 | ) |

Method to get a value from option

Paramètres
string | $option | set the option name
string | $question | set the question if user enters no value to option
Renvoie
string
Depuis
4.0.0

Références $option.

◆ getUserGroups()

getUserGroups ( )
protected

Method to get a value from option

Renvoie
array
Depuis
4.0.0

Références $db, $groups, $list, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'user:add'
staticprotected

◆ $email

$email
private

◆ $ioStyle

$ioStyle
private

◆ $name

$name
private

◆ $password

$password
private

◆ $user

$user
private

◆ $userGroups

$userGroups = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AddUserCommand.php


Joomla CMS: Référence de la classe AddUserToGroupCommand

  • Joomla
  • CMS
  • Console
  • AddUserToGroupCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe AddUserToGroupCommand
+ Graphe d'héritage de AddUserToGroupCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
getGroups ($user)
getGroupId ($groupName)
getUserId ($username)
getStringFromOption ($option, $question)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:addtogroup'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle
$cliInput
$username
$userGroups = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to add a user to group

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_OPTIONAL.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $db, $input, $output, $query, $result, $user, $userId, UserHelper\addUserToGroup(), Command\FAILURE, Joomla\Database\getDatabase(), User\getInstance(), et Command\SUCCESS.

◆ getGroupId()

getGroupId ( $groupName )
protected

Method to get groupId by groupName

Paramètres
string $groupName name of group
Renvoie
integer
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getGroups()

getGroups ( $user )
protected

Method to get a value from option

Paramètres
User $user a UserInstance
Renvoie
array
Depuis
4.0.0

Références $db, $groups, $list, $query, $user, Joomla\Database\getDatabase(), et Access\getGroupsByUser().

◆ getStringFromOption()

getStringFromOption | ( | $option,
 |  | $question
 | ) |
protected

Method to get a value from option

Paramètres
string | $option | set the option name
string | $question | set the question if user enters no value to option
Renvoie
string
Depuis
4.0.0

Références $option.

◆ getUserId()

getUserId ( $username )
protected

Method to get a user object

Paramètres
string $username username
Renvoie
object
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'user:addtogroup'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $userGroups

$userGroups = []
private

◆ $username

$username
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AddUserToGroupCommand.php


Joomla CMS: Référence de la classe ChangeUserPasswordCommand

  • Joomla
  • CMS
  • Console
  • ChangeUserPasswordCommand
Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ChangeUserPasswordCommand
+ Graphe d'héritage de ChangeUserPasswordCommand:
AbstractCommand

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
getStringFromOption ($option, $question)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:reset-password'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle
$cliInput
$username
$password

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to change a user's password

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_OPTIONAL.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, $user, $userId, Command\FAILURE, User\getInstance(), UserHelper\getUserId(), UserHelper\hashPassword(), et Command\SUCCESS.

◆ getStringFromOption()

getStringFromOption | ( | $option,
 |  | $question
 | ) |
protected

Method to get a value from option

Paramètres
string | $option | set the option name
string | $question | set the question if user enters no value to option
Renvoie
string
Depuis
4.0.0

Références $option.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'user:reset-password'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $password

$password
private

◆ $username

$username
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ChangeUserPasswordCommand.php


Joomla CMS: Référence de la classe CheckJoomlaUpdatesCommand

  • Joomla
  • CMS
  • Console
  • CheckJoomlaUpdatesCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe CheckJoomlaUpdatesCommand
+ Graphe d'héritage de CheckJoomlaUpdatesCommand:
AbstractCommand

Fonctions membres publiques

getUpdateInfo ()
setUpdateInfo ($info=null)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'core:check-updates'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

getUpdateInformationFromModel ()

Attributs privés

$updateInfo

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for checking if there are pending extension updates

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $data, $input, $model, $output, et Command\SUCCESS.

◆ getUpdateInfo()

getUpdateInfo ( )

Gets the Update Information

Renvoie
mixed
Depuis
4.0.0

◆ getUpdateInformationFromModel()

getUpdateInformationFromModel ( )
private

Retrieves Update Information

Renvoie
mixed
Depuis
4.0.0

Références $app.

◆ setUpdateInfo()

setUpdateInfo ( $info = null )

Sets the Update Information

Paramètres
null $info stores update Information
Renvoie
void
Depuis
4.0.0

Références $info.

Documentation des champs

◆ $defaultName

$defaultName = 'core:check-updates'
staticprotected

◆ $updateInfo

$updateInfo
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckJoomlaUpdatesCommand.php


Joomla CMS: Référence de la classe CheckUpdatesCommand

  • Joomla
  • CMS
  • Console
  • CheckUpdatesCommand
Fonctions membres protégées | Attributs protégés statiques
Référence de la classe CheckUpdatesCommand
+ Graphe d'héritage de CheckUpdatesCommand:
AbstractCommand

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'update:extensions:check'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for checking if there are pending extension updates

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, Updater\getInstance(), et Command\SUCCESS.

Documentation des champs

◆ $defaultName

$defaultName = 'update:extensions:check'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckUpdatesCommand.php


Joomla CMS: Référence de la classe CleanCacheCommand

  • Joomla
  • CMS
  • Console
  • CleanCacheCommand
Fonctions membres protégées | Attributs protégés statiques
Référence de la classe CleanCacheCommand
+ Graphe d'héritage de CleanCacheCommand:
AbstractCommand

Fonctions membres protégées

configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'cache:clean'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for cleaning the system cache

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références InputArgument\OPTIONAL.

Documentation des champs

◆ $defaultName

$defaultName = 'cache:clean'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CleanCacheCommand.php


Joomla CMS: Référence de la classe DeleteUserCommand

  • Joomla
  • CMS
  • Console
  • DeleteUserCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe DeleteUserCommand
+ Graphe d'héritage de DeleteUserCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
getStringFromOption ($option, $question)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:delete'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle
$cliInput
$username

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for deleting a user

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_OPTIONAL.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $db, $groups, $input, $output, $result, $user, $userId, Access\checkGroup(), Command\FAILURE, Joomla\Database\getDatabase(), User\getInstance(), UserHelper\getUserGroups(), UserHelper\getUserId(), ParameterType\INTEGER, et Command\SUCCESS.

◆ getStringFromOption()

getStringFromOption | ( | $option,
 |  | $question
 | ) |
protected

Method to get a value from option

Paramètres
string | $option | set the option name
string | $question | set the question if user enters no value to option
Renvoie
string
Depuis
4.0.0

Références $option.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'user:delete'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $username

$username
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • DeleteUserCommand.php


Joomla CMS: Référence de la classe ExtensionDiscoverCommand

  • Joomla
  • CMS
  • Console
  • ExtensionDiscoverCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ExtensionDiscoverCommand
+ Graphe d'héritage de ExtensionDiscoverCommand:
AbstractCommand

Fonctions membres publiques

processDiscover ()
getNote (int $count)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'extension:discover'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$cliInput
$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for discovering extensions

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $count, $input, $output, et Command\SUCCESS.

◆ getNote()

getNote ( int $count )

Used for finding the text for the note

Paramètres
int $count The count of installed Extensions
Renvoie
string The text for the note
Depuis
4.0.0

Références $count, et elseif.

◆ processDiscover()

processDiscover ( )

Used for discovering extensions

Renvoie
integer The count of discovered extensions
Exceptions

Références $app, et $model.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'extension:discover'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionDiscoverCommand.php


Joomla CMS: Référence de la classe ExtensionDiscoverInstallCommand

  • Joomla
  • CMS
  • Console
  • ExtensionDiscoverInstallCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ExtensionDiscoverInstallCommand
+ Graphe d'héritage de ExtensionDiscoverInstallCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
processDiscover ($eid)
getNote (int $count, int $eid)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'extension:discover:install'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$cliInput
$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for discovering extensions

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Instantiate the command.

Paramètres
DatabaseInterface $db Database connector
Depuis
4.0.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, $result, elseif, Command\FAILURE, et Command\SUCCESS.

◆ getNote()

getNote | ( | int | $count,
 |  | int | $eid
 | ) |  |

Used for finding the text for the note

Paramètres
int | $count | Number of extensions to install
int | $eid | ID of the extension or -1 if no special
Renvoie
string The text for the note
Depuis
4.0.0

Références $count, et elseif.

◆ processDiscover()

processDiscover ( $eid )

Used for discovering extensions

Paramètres
string $eid Id of the extension
Renvoie
integer The count of installed extensions
Exceptions

Références $count, $db, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'extension:discover:install'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionDiscoverInstallCommand.php


Joomla CMS: Référence de la classe ExtensionDiscoverListCommand

  • Joomla
  • CMS
  • Console
  • ExtensionDiscoverListCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe ExtensionDiscoverListCommand
+ Graphe d'héritage de ExtensionDiscoverListCommand:
ExtensionsListCommand AbstractCommand

Fonctions membres publiques

filterExtensionsBasedOnState ($extensions, $state)
- Fonctions membres publiques hérités de ExtensionsListCommand
__construct (DatabaseInterface $db)
getExtensions ()
setExtensions ($extensions=null)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de ExtensionsListCommand
configureIO (InputInterface $input, OutputInterface $output)
configure ()
getExtensionsNameAndId ($extensions)
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'extension:discover:list'
- Attributs protégés statiques hérités de ExtensionsListCommand
static | $defaultName = 'extension:list'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()
- Attributs protégés hérités de ExtensionsListCommand
$extensions
$cliInput
$ioStyle

Description détaillée

Console command for list discovered extensions

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, $state, et Command\SUCCESS.

◆ filterExtensionsBasedOnState()

filterExtensionsBasedOnState | ( | $extensions,
 |  | $state
 | ) |

Filters the extension state

Paramètres
array | $extensions | The Extensions
string | $state | The Extension state
Renvoie
array
Depuis
4.0.0

Références $extension, $key, et $state.

Documentation des champs

◆ $defaultName

$defaultName = 'extension:discover:list'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionDiscoverListCommand.php


Joomla CMS: Référence de la classe ExtensionInstallCommand

  • Joomla
  • CMS
  • Console
  • ExtensionInstallCommand
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ExtensionInstallCommand
+ Graphe d'héritage de ExtensionInstallCommand:
AbstractCommand

Fonctions membres publiques

processPathInstallation ($path)
processUrlInstallation ($url)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Champs de données

const | INSTALLATION_FAILED = 1
const | INSTALLATION_SUCCESSFUL = 0

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'extension:install'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$cliInput
$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for installing extensions

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Exceptions

Références $input, $output, $path, $result, $url, et elseif.

◆ processPathInstallation()

processPathInstallation ( $path )

Used for installing extension from a path

Paramètres
string $path Path to the extension zip file
Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $path, $result, InstallerHelper\cleanupInstall(), Installer\getInstance(), et InstallerHelper\unpack().

◆ processUrlInstallation()

processUrlInstallation ( $url )

Used for installing extension from a URL

Paramètres
string $url URL to the extension zip file
Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $path, $result, $url, InstallerHelper\cleanupInstall(), InstallerHelper\downloadPackage(), et InstallerHelper\unpack().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'extension:install'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ INSTALLATION_FAILED

const INSTALLATION_FAILED = 1

Exit Code For installation failure

Depuis
4.0.0

◆ INSTALLATION_SUCCESSFUL

const INSTALLATION_SUCCESSFUL = 0

Exit Code For installation Success

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionInstallCommand.php


Joomla CMS: Référence de la classe ExtensionRemoveCommand

  • Joomla
  • CMS
  • Console
  • ExtensionRemoveCommand
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ExtensionRemoveCommand
+ Graphe d'héritage de ExtensionRemoveCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Champs de données

const | REMOVE_ABORT = 3
const | REMOVE_FAILED = 1
const | REMOVE_INVALID_RESPONSE = 5
const | REMOVE_INVALID_TYPE = 6
const | REMOVE_LOCKED = 4
const | REMOVE_NOT_FOUND = 2
const | REMOVE_SUCCESSFUL = 0

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'extension:remove'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$cliInput
$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for removing extensions

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références InputArgument\REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, $language, $output, Factory\getLanguage(), JPATH_ADMINISTRATOR, et null.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, elseif, Joomla\Database\getDatabase(), Installer\getInstance(), et Text\sprintf().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'extension:remove'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ REMOVE_ABORT

const REMOVE_ABORT = 3

Exit Code for extensions remove abort

Depuis
4.0.0

◆ REMOVE_FAILED

const REMOVE_FAILED = 1

Exit Code for extensions remove failure

Depuis
4.0.0

◆ REMOVE_INVALID_RESPONSE

const REMOVE_INVALID_RESPONSE = 5

Exit Code for invalid response

Depuis
4.0.0

◆ REMOVE_INVALID_TYPE

const REMOVE_INVALID_TYPE = 6

Exit Code for invalid type

Depuis
4.0.0

◆ REMOVE_LOCKED

const REMOVE_LOCKED = 4

Exit Code for extensions locked remove failure

Depuis
4.0.0

◆ REMOVE_NOT_FOUND

const REMOVE_NOT_FOUND = 2

Exit Code for extensions not found

Depuis
4.0.0

◆ REMOVE_SUCCESSFUL

const REMOVE_SUCCESSFUL = 0

Exit Code for extensions remove success

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionRemoveCommand.php


Joomla CMS: Référence de la classe ExtensionsListCommand

  • Joomla
  • CMS
  • Console
  • ExtensionsListCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe ExtensionsListCommand
+ Graphe d'héritage de ExtensionsListCommand:
AbstractCommand ExtensionDiscoverListCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
getExtensions ()
setExtensions ($extensions=null)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configureIO (InputInterface $input, OutputInterface $output)
configure ()
getExtensionsNameAndId ($extensions)
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés

$extensions
$cliInput
$ioStyle

Attributs protégés statiques

static | $defaultName = 'extension:list'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

getAllExtensionsFromDB ()
filterExtensionsBasedOn ($type)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for listing installed extensions

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Instantiate the command.

Paramètres
DatabaseInterface $db Database connector
Depuis
4.0.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, $type, et Command\SUCCESS.

◆ filterExtensionsBasedOn()

filterExtensionsBasedOn ( $type )
private

Filters the extension type

Paramètres
string $type Extension type
Renvoie
array
Depuis
4.0.0

Références $extension, $key, et $type.

◆ getAllExtensionsFromDB()

getAllExtensionsFromDB ( )
private

Retrieves extension list from DB

Renvoie
array
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getExtensions()

getExtensions ( )

Retrieves all extensions

Renvoie
mixed
Depuis
4.0.0

◆ getExtensionsNameAndId()

getExtensionsNameAndId ( $extensions )
protected

Transforms extension arrays into required form

Paramètres
array $extensions Array of extensions
Renvoie
array
Depuis
4.0.0

Références $extension, $key, et $manifest.

◆ setExtensions()

setExtensions ( $extensions = null )

Retrieves the extension from the model and sets the class variable

Paramètres
null $extensions Array of extensions
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $cliInput

$cliInput
protected

◆ $defaultName

$defaultName = 'extension:list'
staticprotected

◆ $extensions

$extensions
protected

◆ $ioStyle

$ioStyle
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionsListCommand.php


Joomla CMS: Référence de la classe FinderIndexCommand

  • Joomla
  • CMS
  • Console
  • FinderIndexCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe FinderIndexCommand
+ Graphe d'héritage de FinderIndexCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'finder:index'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)
getFilters ()
purge ()
index ()
putFilters ()

Attributs privés

$cliInput
$ioStyle
$db
$time
$qtime
$filters = array()
$pause = 'division'
$divisor = 5
$minimumBatchProcessingTime = 1

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command Purges and rebuilds the index (search filters are preserved)

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Instantiate the command.

Paramètres
DatabaseInterface $db Database connector
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références null, InputArgument\OPTIONAL, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, $language, $output, Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_SITE, et null.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, Text\sprintf(), et Command\SUCCESS.

◆ getFilters()

getFilters ( )
private

Save static filters.

Since a purge/index cycle will cause all the taxonomy ids to change, the static filters need to be updated with the new taxonomy ids. The static filter information is saved prior to the purge/index so that it can later be used to update the filters with new ids.

Renvoie
void
Depuis
4.0.0

Références $db, $filters, $query, $taxonomies, Text\_(), et Text\sprintf().

◆ index()

index ( )
private

Run the indexer.

Renvoie
void
Depuis
2.5

Références $app, $c, $i, $state, $text, Text\_(), elseif, Factory\getApplication(), Indexer\getState(), PluginHelper\importPlugin(), Indexer\resetState(), et Text\sprintf().

◆ purge()

purge ( )
private

Purge the index.

Renvoie
void
Depuis
3.3

Références $app, $message, $model, $return, et Text\_().

◆ putFilters()

putFilters ( )
private

Restore static filters.

Using the saved filter information, update the filter records with the new taxonomy ids.

Renvoie
void
Depuis
3.3

Références $db, $query, $text, Text\_(), et Text\sprintf().

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $db

$db
private

◆ $defaultName

$defaultName = 'finder:index'
staticprotected

◆ $divisor

$divisor = 5
private

◆ $filters

$filters = array()
private

◆ $ioStyle

$ioStyle
private

◆ $minimumBatchProcessingTime

$minimumBatchProcessingTime = 1
private

◆ $pause

$pause = 'division'
private

◆ $qtime

$qtime
private

◆ $time

$time
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • FinderIndexCommand.php


Joomla CMS: Référence de la classe GetConfigurationCommand

  • Joomla
  • CMS
  • Console
  • GetConfigurationCommand
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe GetConfigurationCommand
+ Graphe d'héritage de GetConfigurationCommand:
AbstractCommand

Fonctions membres publiques

processGroupOptions ($group)
getGroups ()
formatConfig (array $configs)
processSingleOption ($option)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Champs de données

const | DB_GROUP
const | SESSION_GROUP
const | MAIL_GROUP
const const | CONFIG_GET_SUCCESSFUL = 0
const | CONFIG_GET_GROUP_NOT_FOUND = 1
const | CONFIG_GET_OPTION_NOT_FOUND = 2
const | CONFIG_GET_OPTION_FAILED = 3

Fonctions membres protégées

formatConfigValue ($value)
configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'config:get'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$cliInput
$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for displaying configuration options

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références $groups, $key, null, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $key, $option, $options, $output, et $value.

◆ formatConfig()

formatConfig ( array $configs )

Formats the configuration array into desired format

Paramètres
array $configs Array of the configurations
Renvoie
array
Depuis
4.0.0

Références $config, et $key.

◆ formatConfigValue()

formatConfigValue ( $value )
protected

Formats the Configuration value

Paramètres
mixed $value Value to be formatted
Renvoie
string
Depuis
4.0.0

Références $value, elseif, et null.

◆ getGroups()

getGroups ( )

Gets the defined option groups

Renvoie
array
Depuis
4.0.0

◆ processGroupOptions()

processGroupOptions ( $group )

Displays logically grouped options

Paramètres
string $group The group to be processed
Renvoie
integer
Depuis
4.0.0

Références $groups, $key, $option, $options, et $value.

◆ processSingleOption()

processSingleOption ( $option )

Handles the command when a single option is requested

Paramètres
string $option The option we want to get its value
Renvoie
integer
Depuis
4.0.0

Références $option, et $value.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'config:get'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ CONFIG_GET_GROUP_NOT_FOUND

const CONFIG_GET_GROUP_NOT_FOUND = 1

Return code if configuration group option is not found

Depuis
4.0.0

◆ CONFIG_GET_OPTION_FAILED

const CONFIG_GET_OPTION_FAILED = 3

Return code if the command has been invoked with wrong options

Depuis
4.0.0

◆ CONFIG_GET_OPTION_NOT_FOUND

const CONFIG_GET_OPTION_NOT_FOUND = 2

Return code if configuration option is not found

Depuis
4.0.0

◆ CONFIG_GET_SUCCESSFUL

const const CONFIG_GET_SUCCESSFUL = 0

Return code if configuration is get successfully

Depuis
4.0.0

◆ DB_GROUP

const DB_GROUP
Valeur initiale :
= [
'name' => 'db'

◆ MAIL_GROUP

const MAIL_GROUP
Valeur initiale :
= [
'name' => 'mail'

◆ SESSION_GROUP

const SESSION_GROUP
Valeur initiale :
= [
'name' => 'session'
La documentation de cette classe a été générée à partir du fichier suivant :
  • GetConfigurationCommand.php


Joomla CMS: Référence de la classe ListUserCommand

  • Joomla
  • CMS
  • Console
  • ListUserCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ListUserCommand
+ Graphe d'héritage de ListUserCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:list'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to list existing users

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $db, $groups, $input, $output, $query, $user, Joomla\Database\getDatabase(), et Command\SUCCESS.

Documentation des champs

◆ $defaultName

$defaultName = 'user:list'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ListUserCommand.php


Joomla CMS: Référence de la classe RemoveOldFilesCommand

  • Joomla
  • CMS
  • Console
  • RemoveOldFilesCommand
Fonctions membres protégées | Attributs protégés statiques
Référence de la classe RemoveOldFilesCommand
+ Graphe d'héritage de RemoveOldFilesCommand:
AbstractCommand

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'update:joomla:remove-old-files'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for removing files which should have been cleared during an update

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_NONE.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $folder, $input, $output, JPATH_ADMINISTRATOR, JLoader\register(), Command\SUCCESS, OutputInterface\VERBOSITY_DEBUG, OutputInterface\VERBOSITY_VERBOSE, et OutputInterface\VERBOSITY_VERY_VERBOSE.

Documentation des champs

◆ $defaultName

$defaultName = 'update:joomla:remove-old-files'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RemoveOldFilesCommand.php


Joomla CMS: Référence de la classe RemoveUserFromGroupCommand

  • Joomla
  • CMS
  • Console
  • RemoveUserFromGroupCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe RemoveUserFromGroupCommand
+ Graphe d'héritage de RemoveUserFromGroupCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
getGroups ($user)
getGroupId ($groupName)
getStringFromOption ($option, $question)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'user:removefromgroup'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle
$cliInput
$username
$userGroups = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to remove a user from a group

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Command constructor.

Paramètres
DatabaseInterface $db The database
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références null, et InputOption\VALUE_OPTIONAL.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $db, $input, $output, $query, $result, $user, $userId, Access\checkGroup(), Command\FAILURE, Joomla\Database\getDatabase(), Access\getGroupsByUser(), User\getInstance(), UserHelper\getUserId(), UserHelper\removeUserFromGroup(), et Command\SUCCESS.

◆ getGroupId()

getGroupId ( $groupName )
protected

Method to get groupId by groupName

Paramètres
string $groupName name of group
Renvoie
integer
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getGroups()

getGroups ( $user )
protected

Method to get a value from option

Paramètres
object $user user object
Renvoie
array
Depuis
4.0.0

Références $db, $option, $query, $result, $user, Joomla\Database\getDatabase(), et Access\getGroupsByUser().

◆ getStringFromOption()

getStringFromOption | ( | $option,
 |  | $question
 | ) |
protected

Method to get a value from option

Paramètres
string | $option | set the option name
string | $question | set the question if user enters no value to option
Renvoie
string
Depuis
4.0.0

Références $option.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'user:removefromgroup'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $userGroups

$userGroups = array()
private

◆ $username

$username
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • RemoveUserFromGroupCommand.php


Joomla CMS: Référence de la classe SessionGcCommand

  • Joomla
  • CMS
  • Console
  • SessionGcCommand
Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées
Référence de la classe SessionGcCommand
+ Graphe d'héritage de SessionGcCommand:
AbstractCommand ContainerAwareInterface

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'session:gc'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

getSessionService (string $application)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for performing session garbage collection

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

Références InputOption\VALUE_OPTIONAL.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, Command\FAILURE, et Command\SUCCESS.

◆ getSessionService()

getSessionService ( string $application )
private

Get the session service for the requested application.

Paramètres
string $application The application session service to retrieve
Renvoie
SessionInterface
Depuis
4.0.0

Références Joomla\DI\getContainer(), et Symfony\Contracts\Service\has().

Documentation des champs

◆ $defaultName

$defaultName = 'session:gc'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionGcCommand.php


Joomla CMS: Référence de la classe SessionMetadataGcCommand

  • Joomla
  • CMS
  • Console
  • SessionMetadataGcCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe SessionMetadataGcCommand
+ Graphe d'héritage de SessionMetadataGcCommand:
AbstractCommand

Fonctions membres publiques

__construct (SessionInterface $session, MetadataManager $metadataManager)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'session:metadata:gc'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Attributs privés

$metadataManager
$session

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for performing session metadata garbage collection

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SessionInterface | $session,
 |  | MetadataManager | $metadataManager
 | ) |  |

Instantiate the command.

Paramètres
SessionInterface | $session | The session object.
MetadataManager | $metadataManager | The session metadata manager.
Depuis
4.0.0

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.0.0

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, et Command\FAILURE.

Documentation des champs

◆ $defaultName

$defaultName = 'session:metadata:gc'
staticprotected

◆ $metadataManager

$metadataManager
private

◆ $session

$session
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionMetadataGcCommand.php


Joomla CMS: Référence de la classe SetConfigurationCommand

  • Joomla
  • CMS
  • Console
  • SetConfigurationCommand
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe SetConfigurationCommand
+ Graphe d'héritage de SetConfigurationCommand:
AbstractCommand

Fonctions membres publiques

setOptions ($options)
getOptions ()
getInitialConfigurationOptions ()
saveConfiguration ($options)
checkDb ($options)
sanitizeOptions (array $options)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Champs de données

const | CONFIG_SET_SUCCESSFUL = 0
const | CONFIG_SET_FAILED = 1
const | CONFIG_VALIDATION_FAILED = 2
const | CONFIG_OPTIONS_WRONG = 3
const | DB_VALIDATION_FAILED = 4

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'config:set'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)
retrieveOptionsFromInput (array $options)
validateOptions ()

Attributs privés

$cliInput
$ioStyle
$options

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command Setting Configuration options

Depuis
4.0.0

Documentation des fonctions membres

◆ checkDb()

checkDb ( $options )

Verifies database connection

Paramètres
array $options Options array
Renvoie
boolean|
Depuis
4.0.0
Exceptions

Références $app, $db, $model, $options, $settings, $value, Text\_(), DatabaseDriver\getInstance(), et Text\sprintf().

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

Références InputArgument\IS_ARRAY, et InputArgument\REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, $language, $output, Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_INSTALLATION, et null.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0
Exceptions

Références $input, $options, et $output.

◆ getInitialConfigurationOptions()

getInitialConfigurationOptions ( )

Returns Default configuration Object

Renvoie
Registry
Depuis
4.0.0

◆ getOptions()

getOptions ( )

Collects the options array

Renvoie
array|mixed
Depuis
4.0.0

◆ retrieveOptionsFromInput()

retrieveOptionsFromInput ( array $options )
private

Collects options from user input

Paramètres
array $options Options input by users
Renvoie
boolean
Depuis
4.0.0

Références $option, $options, et $value.

◆ sanitizeOptions()

sanitizeOptions ( array $options )

Sanitize the options array for boolean

Paramètres
array $options Options array
Renvoie
array
Depuis
4.0.0

Références $key, $options, $value, false, et true.

◆ saveConfiguration()

saveConfiguration ( $options )

Save the configuration file

Paramètres
array $options Options array
Renvoie
boolean
Depuis
4.0.0

Références $app, $model, $options, et Text\_().

◆ setOptions()

setOptions ( $options )

Sets the options array

Paramètres
string $options Options string
Depuis
4.0.0
Renvoie
void

Références $options.

◆ validateOptions()

validateOptions ( )
private

Validates the options provided

Renvoie
boolean
Depuis
4.0.0

Références $config, $key, et $value.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $defaultName

$defaultName = 'config:set'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $options

$options
private

◆ CONFIG_OPTIONS_WRONG

const CONFIG_OPTIONS_WRONG = 3

Return code if options are wrong

Depuis
4.0.0

◆ CONFIG_SET_FAILED

const CONFIG_SET_FAILED = 1

Return code if configuration set failed

Depuis
4.0.0

◆ CONFIG_SET_SUCCESSFUL

const CONFIG_SET_SUCCESSFUL = 0

Return code if configuration is set successfully

Depuis
4.0.0

◆ CONFIG_VALIDATION_FAILED

const CONFIG_VALIDATION_FAILED = 2

Return code if config validation failed

Depuis
4.0.0

◆ DB_VALIDATION_FAILED

const DB_VALIDATION_FAILED = 4

Return code if database validation failed

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SetConfigurationCommand.php


Joomla CMS: Référence de la classe SiteDownCommand

  • Joomla
  • CMS
  • Console
  • SiteDownCommand
Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe SiteDownCommand
+ Graphe d'héritage de SiteDownCommand:
AbstractCommand

Champs de données

const | SITE_DOWN_FAILED = 1
const | SITE_DOWN_SUCCESSFUL = 0

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'site:down'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command wrapper for getting the site into offline mode

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, et AbstractCommand\getDefaultName().

Documentation des champs

◆ $defaultName

$defaultName = 'site:down'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ SITE_DOWN_FAILED

const SITE_DOWN_FAILED = 1

Return code if site:down failed

Depuis
4.0.0

◆ SITE_DOWN_SUCCESSFUL

const SITE_DOWN_SUCCESSFUL = 0

Return code if site:down was successful

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteDownCommand.php


Joomla CMS: Référence de la classe SiteUpCommand

  • Joomla
  • CMS
  • Console
  • SiteUpCommand
Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe SiteUpCommand
+ Graphe d'héritage de SiteUpCommand:
AbstractCommand

Champs de données

const | SITE_UP_FAILED = 1
const | SITE_UP_SUCCESSFUL = 0

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'site:up'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command wrapper for getting the site into offline mode

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0

Références $input, $output, et AbstractCommand\getDefaultName().

Documentation des champs

◆ $defaultName

$defaultName = 'site:up'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ SITE_UP_FAILED

const SITE_UP_FAILED = 1

Return code if site:up failed

Depuis
4.0.0

◆ SITE_UP_SUCCESSFUL

const SITE_UP_SUCCESSFUL = 0

Return code if site:up was successful

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteUpCommand.php


Joomla CMS: Référence de la classe TasksListCommand

  • Joomla
  • CMS
  • Console
  • TasksListCommand
Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe TasksListCommand
+ Graphe d'héritage de TasksListCommand:
AbstractCommand

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés

$application

Attributs protégés statiques

static | $defaultName = 'scheduler:list'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

getTasks ()
configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to list scheduled tasks.

Depuis
4.1.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.1.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.1.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.1.0
Exceptions

Références $enabled, $input, $output, $task, Factory\getApplication(), Factory\getDate(), et JPATH_ADMINISTRATOR.

◆ getTasks()

getTasks ( )
private

Returns a stdClass object array of scheduled tasks.

Renvoie
array
Depuis
4.1.0
Exceptions

Documentation des champs

◆ $application

$application
protected

◆ $defaultName

$defaultName = 'scheduler:list'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TasksListCommand.php


Joomla CMS: Référence de la classe TasksRunCommand

  • Joomla
  • CMS
  • Console
  • TasksRunCommand
Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe TasksRunCommand
+ Graphe d'héritage de TasksRunCommand:
AbstractCommand

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'scheduler:run'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to run scheduled tasks.

Depuis
4.1.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.1.0

Références InputOption\VALUE_NONE, et InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.1.0

Références $input, et $output.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected
Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code.
Depuis
4.1.0
Exceptions

Not as a class constant because of some the autoload order doesn't let us load the namespace when it's time to do that (why?)

Références $filters, $id, $input, $key, $output, $task, elseif, Status\NO_ROUTINE, Status\NO_RUN, Status\NO_TASK, null, Status\OK, et Status\WILL_RESUME.

Documentation des champs

◆ $defaultName

$defaultName = 'scheduler:run'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TasksRunCommand.php


Joomla CMS: Référence de la classe TasksStateCommand

  • Joomla
  • CMS
  • Console
  • TasksStateCommand
Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe TasksStateCommand
+ Graphe d'héritage de TasksStateCommand:
AbstractCommand

Fonctions membres protégées

configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés

$application

Attributs protégés statiques

static | $defaultName = 'scheduler:state'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)

Attributs privés

$ioStyle

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command to change the state of tasks.

Depuis
4.1.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
4.1.0

Références InputOption\VALUE_REQUIRED.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configure the IO.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
4.1.0

Références $input, et $output.

Documentation des champs

◆ $application

$application
protected

◆ $defaultName

$defaultName = 'scheduler:state'
staticprotected

◆ $ioStyle

$ioStyle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • TasksStateCommand.php


Joomla CMS: Référence de la classe UpdateCoreCommand

  • Joomla
  • CMS
  • Console
  • UpdateCoreCommand
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe UpdateCoreCommand
+ Graphe d'héritage de UpdateCoreCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
doExecute (InputInterface $input, OutputInterface $output)
setUpdateInfo ($data)
getUpdateModel ()
setUpdateModel ()
processUpdatePackage ($updateInformation)
downloadFile ($url)
extractFile ($file)
copyFileTo ($file, $dir)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Champs de données

$updateInfo
$updateModel
$progressBar
const | UPDATE_SUCCESSFUL = 0
const | ERR_UPDATE_FAILED = 2
const | ERR_CHECKS_FAILED = 1

Fonctions membres protégées

configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'core:update'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

configureIO (InputInterface $input, OutputInterface $output)
updateJoomlaCore ($updatemodel)

Attributs privés

$cliInput
$ioStyle
$db

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for updating Joomla! core

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

UpdateCoreCommand constructor.

Paramètres
DatabaseInterface $db Database Instance
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Initialise the command.

Renvoie
void
Depuis
4.0.0

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
private

Configures the IO

Paramètres
InputInterface | $input | Console Input
OutputInterface | $output | Console Output
Renvoie
void
Depuis
4.0.0

Références $input, $output, et ProgressBar\setFormatDefinition().

◆ copyFileTo()

copyFileTo | ( | $file,
 |  | $dir
 | ) |

Copy a file to a destination directory

Paramètres
string | $file | Full path to file
string | $dir | Destination directory
Renvoie
void
Depuis
4.0.0

Références $dir, et Folder\copy().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
4.0.0
Exceptions

Références $input, $model, et $output.

◆ downloadFile()

downloadFile ( $url )

Downloads the Update file

Paramètres
string $url URL to update file
Renvoie
boolean | string
Depuis
4.0.0

Références $url, et InstallerHelper\downloadPackage().

◆ extractFile()

extractFile ( $file )

Extracts Update file

Paramètres
string $file Full path to file location
Renvoie
array | boolean
Depuis
4.0.0

Références InstallerHelper\unpack().

◆ getUpdateModel()

getUpdateModel ( )

Retrieves the Update model from com_joomlaupdate

Renvoie
mixed
Depuis
4.0.0
Exceptions

◆ processUpdatePackage()

processUpdatePackage ( $updateInformation )

Downloads and extracts the update Package

Paramètres
array $updateInformation Stores the update information
Renvoie
array | boolean
Depuis
4.0.0

Références JPATH_BASE.

◆ setUpdateInfo()

setUpdateInfo ( $data )

Sets the update Information

Paramètres
array $data Stores the update information
Depuis
4.0.0
Renvoie
void

Références $data.

◆ setUpdateModel()

setUpdateModel ( )

Sets the Update Model

Renvoie
void
Depuis
4.0.0

Références $app.

◆ updateJoomlaCore()

updateJoomlaCore ( $updatemodel )
private

Update Core Joomla

Paramètres
mixed $updatemodel Update Model
Renvoie
boolean success
Depuis
4.0.0

Références $result, InstallerHelper\cleanupInstall(), File\delete(), et JPATH_BASE.

Documentation des champs

◆ $cliInput

$cliInput
private

◆ $db

$db
private

◆ $defaultName

$defaultName = 'core:update'
staticprotected

◆ $ioStyle

$ioStyle
private

◆ $progressBar

$progressBar

◆ $updateInfo

$updateInfo

◆ $updateModel

$updateModel

◆ ERR_CHECKS_FAILED

const ERR_CHECKS_FAILED = 1

Return code for failed checks

Depuis
4.0.0

◆ ERR_UPDATE_FAILED

const ERR_UPDATE_FAILED = 2

Return code for failed update

Depuis
4.0.0

◆ UPDATE_SUCCESSFUL

const UPDATE_SUCCESSFUL = 0

Return code for successful update

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdateCoreCommand.php


Joomla CMS: Référence de la classe CryptoCipher

  • Joomla
  • CMS
  • Crypt
  • Cipher
  • CryptoCipher
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe CryptoCipher
+ Graphe d'héritage de CryptoCipher:
CipherInterface

Fonctions membres publiques

decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=array())

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Crypt cipher for encryption, decryption and key generation via the php-encryption library.

Depuis
3.5
Obsolète:
5.0 Without replacement use SodiumCipher

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
3.5
Exceptions

Implémente CipherInterface.

Références $data, et $key.

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
3.5
Exceptions

Implémente CipherInterface.

Références $data, et $key.

◆ generateKey()

generateKey ( array $options = array() )

Method to generate a new encryption key object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
3.5
Exceptions

Implémente CipherInterface.

Références Crypto\CreateNewRandomKey().

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
4.0.0

Implémente CipherInterface.

Références Crypto\RuntimeTest().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CryptoCipher.php


Joomla CMS: Référence de la classe SodiumCipher

  • Joomla
  • CMS
  • Crypt
  • Cipher
  • SodiumCipher
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe SodiumCipher
+ Graphe d'héritage de SodiumCipher:
CipherInterface

Fonctions membres publiques

decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=array())
setNonce ($nonce)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$nonce

Description détaillée

JCrypt cipher for sodium algorithm encryption, decryption and key generation.

Depuis
3.8.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
3.8.0
Exceptions

Implémente CipherInterface.

Références $data, $key, ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey(), et ParagonIE_Sodium_Compat\crypto_box_open().

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
3.8.0
Exceptions

Implémente CipherInterface.

Références $data, $key, ParagonIE_Sodium_Compat\crypto_box(), et ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey().

◆ generateKey()

generateKey ( array $options = array() )

Method to generate a new encryption key object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
3.8.0
Exceptions

Implémente CipherInterface.

Références ParagonIE_Sodium_Compat\crypto_box_keypair(), ParagonIE_Sodium_Compat\crypto_box_publickey(), et ParagonIE_Sodium_Compat\crypto_box_secretkey().

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
4.0.0

Implémente CipherInterface.

Références class.

◆ setNonce()

setNonce ( $nonce )

Set the nonce to use for encrypting/decrypting messages

Paramètres
string $nonce The message nonce
Renvoie
void
Depuis
3.8.0

Documentation des champs

◆ $nonce

$nonce
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SodiumCipher.php


Joomla CMS: Référence de la classe Crypt

  • Joomla
  • CMS
  • Crypt
  • Crypt
Fonctions membres publiques statiques
Référence de la classe Crypt
+ Graphe d'héritage de Crypt:
Crypt

Fonctions membres publiques statiques

static | timingSafeCompare ($known, $unknown)
static | safeStrlen ($str)
static | safeSubstr ($str, $start, $length=null)
- Fonctions membres publiques statiques hérités de Crypt
static | genRandomBytes ($length=16)

Membres hérités additionnels

- Fonctions membres publiques hérités de Crypt
__construct (?CipherInterface $cipher=null, ?Key $key=null)
decrypt ($data)
encrypt ($data)
generateKey (array $options=[])
setKey (Key $key)

Description détaillée

Crypt is a Joomla Platform class for handling basic encryption/decryption of data.

Depuis
3.0.0

Documentation des fonctions membres

◆ safeStrlen()

static safeStrlen ( $str )
static

Safely detect a string's length

This method is derived from ::safeStrlen()

Paramètres
string $str String to check the length of
Renvoie
integer
Depuis
3.5 mbstring.func_overload
Exceptions

Références null.

◆ safeSubstr()

static safeSubstr | ( | $str,
 |  | $start,
 |  | $length = null
 | ) |
static

Safely extract a substring

This method is derived from ::safeSubstr()

Paramètres
string | $str | The string to extract the substring from
integer | $start | The starting position to extract from
integer | $length | The length of the string to return
Renvoie
string
Depuis
3.5

Références $start, et null.

◆ timingSafeCompare()

static timingSafeCompare | ( | $known,
 |  | $unknown
 | ) |
static

A timing safe comparison method.

This defeats hacking attempts that use timing based attack vectors.

NOTE: Length will leak.

Paramètres
string | $known | A known string to check against.
string | $unknown | An unknown string to check.
Renvoie
boolean True if the two strings are exactly the same.
Depuis
3.2

Explanation about the function_exists

Yes, hash_equals has existed since PHP 5.6.0 and Joomla's minimum requirements are higher than that. However, this does not prevent a misguided server administrator from disabling hash_equals in php.ini. Hence the need for checking whether the function exists or not.

If hash_equals is not available we use a pure PHP implementation by Anthony Ferrara.

Voir également
https://blog.ircmaxell.com/2014/11/its-all-about-time.html

Références $i, et $result.

Référencé par BackupcodesModel\isBackupCode(), Token\onUserAuthenticate(), et MD5Handler\validatePassword().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Crypt/Crypt.php


Joomla CMS: Référence de la classe Date

  • Joomla
  • CMS
  • Date
  • Date
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Date
+ Graphe d'héritage de Date:

Fonctions membres publiques

__construct ($date='now', $tz=null)
__get ($name)
__toString ()
dayToString ($day, $abbr=false)
calendar ($format, $local=false, $translate=true)
format ($format, $local=false, $translate=true)
getOffsetFromGmt ($hours=false)
monthToString ($month, $abbr=false)
setTimezone ($tz)
toISO8601 ($local=false)
toSql ($local=false, DatabaseDriver $db=null)
toRFC822 ($local=false)
toUnix ()

Fonctions membres publiques statiques

static getInstance ($date='now', $tz=null)

Champs de données

const | DAY_ABBR = "\x021\x03"
const | DAY_NAME = "\x022\x03"
const | MONTH_ABBR = "\x023\x03"
const | MONTH_NAME = "\x024\x03"

Attributs publics statiques

static $format = 'Y-m-d H:i:s'

Attributs protégés

$tz

Attributs protégés statiques

static | $gmt
static | $stz

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $date = 'now',
 |  | $tz = null
 | ) |

Constructor.

Paramètres
string | $date | String in a format accepted by strtotime(), defaults to "now".
mixed | $tz | Time zone to be used for the date. Might be a string or a DateTimeZone object.
Depuis
1.7.0

Références $date, Date\$tz, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to access properties of the date given by class to the format method.

Paramètres
string $name The name of the property.
Renvoie
mixed A value if the property name is valid, null otherwise.
Depuis
1.7.0

Références $name, $value, Date\format(), et null.

◆ __toString()

__toString ( )

Magic method to render the date object in the format specified in the public static member Date::$format.

Renvoie
string The date as a formatted string.
Depuis
1.7.0

Références $format.

◆ calendar()

calendar | ( | $format,
 |  | $local = false,
 |  | $translate = true
 | ) |

Gets the date as a formatted string in a local calendar.

Paramètres
string | $format | The date format specification string (see PHP_MANUAL#date)
boolean | $local | True to return the date string in the local time zone, false to return it in GMT.
boolean | $translate | True to translate localised strings
Renvoie
string The date string in the specified format format.
Depuis
1.7.0

Références Date\$format, et Date\format().

◆ dayToString()

dayToString | ( | $day,
 |  | $abbr = false
 | ) |

Translates day of week number to a string.

Paramètres
integer | $day | The numeric day of the week.
boolean | $abbr | Return the abbreviated day string?
Renvoie
string The day of the week.
Depuis
1.7.0

Références Text\_().

Référencé par Date\format().

◆ format()

format | ( | $format,
 |  | $local = false,
 |  | $translate = true
 | ) |

Gets the date as a formatted string.

Paramètres
string | $format | The date format specification string (see PHP_MANUAL#date)
boolean | $local | True to return the date string in the local time zone, false to return it in GMT.
boolean | $translate | True to translate localised strings
Renvoie
string The date string in the specified format format.
Depuis
1.7.0

Références Date\$format, $return, Date\dayToString(), Date\monthToString(), et null.

Référencé par Date\__get(), Date\calendar(), Date\toISO8601(), Date\toRFC822(), et Date\toSql().

◆ getInstance()

static getInstance | ( | $date = 'now',
 |  | $tz = null
 | ) |
static

Proxy for new Date().

Paramètres
string | $date | String in a format accepted by strtotime(), defaults to "now".
mixed | $tz | Time zone to be used for the date.
Renvoie
Date
Depuis
1.7.3

Références $date, et Date\$tz.

Référencé par PlgUserProfile\onUserBeforeSave(), et MfaTable\store().

◆ getOffsetFromGmt()

getOffsetFromGmt ( $hours = false )

Get the time offset from GMT in hours or seconds.

Paramètres
boolean $hours True to return the value in hours.
Renvoie
float The time offset from GMT either in hours or in seconds.
Depuis
1.7.0

Références $this.

◆ monthToString()

monthToString | ( | $month,
 |  | $abbr = false
 | ) |

Translates month number to a string.

Paramètres
integer | $month | The numeric month of the year.
boolean | $abbr | If true, return the abbreviated month string
Renvoie
string The month of the year.
Depuis
1.7.0

Références Text\_().

Référencé par Date\format().

◆ setTimezone()

setTimezone ( $tz )

Method to wrap the setTimezone() function and set the internal time zone object.

Paramètres
\DateTimeZone $tz The new object.
Renvoie
Date
Depuis
1.7.0
Note
This method can't be type hinted due to a PHP bug: https://bugs.php.net/bug.php?id=61483

Références Date\$tz.

◆ toISO8601()

toISO8601 ( $local = false )

Gets the date as an ISO 8601 string. IETF RFC 3339 defines the ISO 8601 format and it can be found at the IETF Web site.

Paramètres
boolean $local True to return the date string in the local time zone, false to return it in GMT.
Renvoie
string The date string in ISO 8601 format.

1.7.0

Références Date\format().

◆ toRFC822()

toRFC822 ( $local = false )

Gets the date as an RFC 822 string. IETF RFC 2822 supercedes RFC 822 and its definition can be found at the IETF Web site.

Paramètres
boolean $local True to return the date string in the local time zone, false to return it in GMT.
Renvoie
string The date string in RFC 822 format.

1.7.0

Références Date\format().

◆ toSql()

toSql | ( |  | $local = false,
 |  | DatabaseDriver | $db = null
 | ) |  |

Gets the date as an SQL datetime string.

Paramètres
boolean | $local | True to return the date string in the local time zone, false to return it in GMT.
DatabaseDriver | $db | The database driver or null to use Factory::getDbo()
Renvoie
string The date string in SQL datetime format.

2.5.0

Références $db, Date\format(), Factory\getDbo(), et null.

◆ toUnix()

toUnix ( )

Gets the date as UNIX time stamp.

Renvoie
integer The date as a UNIX timestamp.
Depuis
1.7.0

Documentation des champs

◆ $format

$format = 'Y-m-d H:i:s'
static

Référencé par Date\calendar(), et Date\format().

◆ $gmt

$gmt
staticprotected

◆ $stz

$stz
staticprotected

◆ $tz

$tz
protected

Référencé par Date\__construct(), Date\getInstance(), et Date\setTimezone().

◆ DAY_ABBR

const DAY_ABBR = "\x021\x03"

◆ DAY_NAME

const DAY_NAME = "\x022\x03"

◆ MONTH_ABBR

const MONTH_ABBR = "\x023\x03"

◆ MONTH_NAME

const MONTH_NAME = "\x024\x03"
La documentation de cette classe a été générée à partir du fichier suivant :
  • Date/Date.php


Joomla CMS: Référence de la classe AbstractModuleDispatcher

  • Joomla
  • CMS
  • Dispatcher
  • AbstractModuleDispatcher
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractModuleDispatcher
+ Graphe d'héritage de AbstractModuleDispatcher:
Dispatcher DispatcherInterface ModuleDispatcher Dispatcher Dispatcher Dispatcher

Fonctions membres publiques

__construct (\stdClass $module, CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de DispatcherInterface
dispatch ()

Fonctions membres protégées

getLayoutData ()
loadLanguage ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Attributs protégés

$module
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Base class for a Joomla Module Dispatcher.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \stdClass | $module,
 |  | CMSApplicationInterface | $app,
 |  | Input | $input
 | ) |  |

Constructor for Dispatcher

Paramètres
\stdClass | $module | The module
CMSApplicationInterface | $app | The application instance
Input | $input | The input instance
Depuis
4.0.0

Références $app, $input, $module, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Returns the layout data. This function can be overridden by subclasses to add more attributes for the layout.

If false is returned, then it means that the dispatch process should be aborted.

Renvoie
array|false
Depuis
4.0.0

Références $app, $input, et $module.

◆ loadLanguage()

loadLanguage ( )
protected

Load the language.

Renvoie
void
Depuis
4.0.0

Références $language, et JPATH_BASE.

Documentation des champs

◆ $module

stdClass $module
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractModuleDispatcher.php


Joomla CMS: Référence de la classe ApiDispatcher

  • Joomla
  • CMS
  • Dispatcher
  • ApiDispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ApiDispatcher
+ Graphe d'héritage de ApiDispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

dispatch ()
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

API Implementation for our dispatcher. It loads a component's administrator language files, and calls the API Controller so that components that haven't implemented web services can add their own handling.

Depuis
4.0.0

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Dispatch a controller task. API Overrides to ensure there is no redirects.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références $config, $option, et $task.

◆ loadLanguage()

loadLanguage ( )
protected

Load the component's administrator language

Depuis
4.0.0
Renvoie
void

Références JPATH_ADMINISTRATOR, et JPATH_BASE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApiDispatcher.php


Joomla CMS: Référence de la classe ComponentDispatcher

  • Joomla
  • CMS
  • Dispatcher
  • ComponentDispatcher
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentDispatcher
+ Graphe d'héritage de ComponentDispatcher:
Dispatcher DispatcherInterface ApiDispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher

Fonctions membres publiques

__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Attributs protégés

$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Base class for a Joomla Component Dispatcher

Dispatchers are responsible for checking ACL of a component if appropriate and choosing an appropriate controller (and if necessary, a task) and executing it.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CMSApplicationInterface | $app,
 |  | Input | $input,
 |  | MVCFactoryInterface | $mvcFactory
 | ) |  |

Constructor for ComponentDispatcher

Paramètres
CMSApplicationInterface | $app | The application instance
Input | $input | The input instance
MVCFactoryInterface | $mvcFactory | The MVC factory instance
Depuis
4.0.0

Références $app, $input, $this, Symfony\Contracts\Service\__construct(), et ComponentHelper\getComponentName().

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Renvoie
void
Depuis
4.0.0

◆ dispatch()

dispatch ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références $config, $option, et $task.

◆ getController()

getController | ( | string | $name,
 |  | string | $client = '',
 |  | array | $config = array()
 | ) |  |

Get a controller from the component

Paramètres
string | $name | Controller name
string | $client | Optional client (like Administrator, Site etc.)
array | $config | Optional controller config
Renvoie
BaseController
Depuis
4.0.0

Références $client, $config, $name, et Text\sprintf().

◆ loadLanguage()

loadLanguage ( )
protected

Load the language

Renvoie
void
Depuis
4.0.0

Références JPATH_BASE.

Documentation des champs

◆ $mvcFactory

$mvcFactory
protected

◆ $option

$option
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentDispatcher.php


Joomla CMS: Référence de la classe ComponentDispatcherFactory

  • Joomla
  • CMS
  • Dispatcher
  • ComponentDispatcherFactory
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe ComponentDispatcherFactory
+ Graphe d'héritage de ComponentDispatcherFactory:
ComponentDispatcherFactoryInterface

Fonctions membres publiques

__construct (string $namespace, MVCFactoryInterface $mvcFactory)
createDispatcher (CMSApplicationInterface $application, Input $input=null)

Attributs protégés

$namespace

Attributs privés

$mvcFactory

Description détaillée

Namespace based implementation of the ComponentDispatcherFactoryInterface

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $namespace,
 |  | MVCFactoryInterface | $mvcFactory
 | ) |  |

ComponentDispatcherFactory constructor.

Paramètres
string | $namespace | The namespace
MVCFactoryInterface | $mvcFactory | The MVC factory
Depuis
4.0.0

Documentation des fonctions membres

◆ createDispatcher()

createDispatcher | ( | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Creates a dispatcher.

Paramètres
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémente ComponentDispatcherFactoryInterface.

Références $className, $input, $name, $this, class, CMSApplicationInterface\getName(), et CMSApplicationInterface\isClient().

Documentation des champs

◆ $mvcFactory

$mvcFactory
private

◆ $namespace

$namespace
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Dispatcher/ComponentDispatcherFactory.php


Joomla CMS: Référence de l'interface ComponentDispatcherFactoryInterface

  • Joomla
  • CMS
  • Dispatcher
  • ComponentDispatcherFactoryInterface
Fonctions membres publiques
Référence de l'interface ComponentDispatcherFactoryInterface
+ Graphe d'héritage de ComponentDispatcherFactoryInterface:
ComponentDispatcherFactory

Fonctions membres publiques

createDispatcher (CMSApplicationInterface $application, Input $input=null)

Description détaillée

Component dispatcher factory interface

Depuis
4.0.0

Documentation des fonctions membres

◆ createDispatcher()

createDispatcher | ( | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Creates a dispatcher.

Paramètres
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémenté dans ComponentDispatcherFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ComponentDispatcherFactoryInterface.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • CMS
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
DispatcherInterface AbstractModuleDispatcher ComponentDispatcher ModuleDispatcher Dispatcher Dispatcher Dispatcher ApiDispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher

Fonctions membres publiques

__construct (CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de DispatcherInterface
dispatch ()

Fonctions membres protégées

getApplication ()

Attributs protégés

$app
$input

Description détaillée

Base class for a Joomla Dispatcher

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CMSApplicationInterface | $app,
 |  | Input | $input
 | ) |  |

Constructor for Dispatcher

Paramètres
CMSApplicationInterface | $app | The application instance
Input | $input | The input instance
Depuis
4.0.0

Références $app, et $input.

Documentation des fonctions membres

◆ getApplication()

getApplication ( )
protected

The application the dispatcher is working with.

Renvoie
CMSApplicationInterface
Depuis
4.0.0

Références $app.

Documentation des champs

◆ $app

$app
protected

◆ $input

$input
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de l'interface DispatcherInterface

  • Joomla
  • CMS
  • Dispatcher
  • DispatcherInterface
Fonctions membres publiques
Référence de l'interface DispatcherInterface
+ Graphe d'héritage de DispatcherInterface:
Dispatcher LegacyComponentDispatcher AbstractModuleDispatcher ComponentDispatcher ModuleDispatcher Dispatcher Dispatcher Dispatcher ApiDispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher Dispatcher

Fonctions membres publiques

dispatch ()

Description détaillée

Joomla Platform CMS Dispatcher Interface

Depuis
4.0.0

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Runs the dispatcher.

Renvoie
void
Depuis
4.0.0

Implémenté dans ComponentDispatcher, LegacyComponentDispatcher, ApiDispatcher, Dispatcher, Dispatcher, Dispatcher, et ModuleDispatcher.

La documentation de cette interface a été générée à partir du fichier suivant :
  • src/Dispatcher/DispatcherInterface.php


Joomla CMS: Référence de la classe LegacyComponentDispatcher

  • Joomla
  • CMS
  • Dispatcher
  • LegacyComponentDispatcher
Fonctions membres publiques | Attributs privés
Référence de la classe LegacyComponentDispatcher
+ Graphe d'héritage de LegacyComponentDispatcher:
DispatcherInterface

Fonctions membres publiques

__construct (CMSApplication $app)
dispatch ()

Attributs privés

$app

Description détaillée

Base class for a legacy Joomla Dispatcher

Executes the single entry file of a legacy component.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CMSApplication $app )

Constructor for Dispatcher

Paramètres
CMSApplication $app The application instance
Depuis
4.0.0

Références $app.

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références $lang, $loader, $path, Text\_(), et JPATH_BASE.

Documentation des champs

◆ $app

$app
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LegacyComponentDispatcher.php


Joomla CMS: Référence de la classe ModuleDispatcher

  • Joomla
  • CMS
  • Dispatcher
  • ModuleDispatcher
Fonctions membres publiques
Référence de la classe ModuleDispatcher
+ Graphe d'héritage de ModuleDispatcher:
AbstractModuleDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

dispatch ()
- Fonctions membres publiques hérités de AbstractModuleDispatcher
__construct (\stdClass $module, CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractModuleDispatcher
getLayoutData ()
loadLanguage ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()
- Attributs protégés hérités de AbstractModuleDispatcher
$module
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Base class for a Joomla Module Dispatcher

Executes the single entry file of a module.

Depuis
4.0.0

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Dispatches the dispatcher.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références $displayData, $loader, $path, et JPATH_BASE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleDispatcher.php


Joomla CMS: Référence de la classe ModuleDispatcherFactory

  • Joomla
  • CMS
  • Dispatcher
  • ModuleDispatcherFactory
Fonctions membres publiques | Attributs privés
Référence de la classe ModuleDispatcherFactory
+ Graphe d'héritage de ModuleDispatcherFactory:
ModuleDispatcherFactoryInterface

Fonctions membres publiques

__construct (string $namespace)
createDispatcher (\stdClass $module, CMSApplicationInterface $application, Input $input=null)

Attributs privés

$namespace

Description détaillée

Namespace based implementation of the ModuleDispatcherFactoryInterface

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

ModuleDispatcherFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ createDispatcher()

createDispatcher | ( | \stdClass | $module,
 |  | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Creates a dispatcher.

Paramètres
\stdClass | $module | The module
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémente ModuleDispatcherFactoryInterface.

Références $className, $input, $name, class, et CMSApplicationInterface\isClient().

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Dispatcher/ModuleDispatcherFactory.php


Joomla CMS: Référence de l'interface ModuleDispatcherFactoryInterface

  • Joomla
  • CMS
  • Dispatcher
  • ModuleDispatcherFactoryInterface
Fonctions membres publiques
Référence de l'interface ModuleDispatcherFactoryInterface
+ Graphe d'héritage de ModuleDispatcherFactoryInterface:
ModuleDispatcherFactory

Fonctions membres publiques

createDispatcher (\stdClass $module, CMSApplicationInterface $application, Input $input=null)

Description détaillée

Module dispatcher factory interface

Depuis
4.0.0

Documentation des fonctions membres

◆ createDispatcher()

createDispatcher | ( | \stdClass | $module,
 |  | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Creates a dispatcher.

Paramètres
\stdClass | $module | The module
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémenté dans ModuleDispatcherFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ModuleDispatcherFactoryInterface.php


Joomla CMS: Référence de la classe FeedEnclosure

  • Joomla
  • CMS
  • Document
  • Feed
  • FeedEnclosure
Champs de données
Référence de la classe FeedEnclosure

Champs de données

$url = ''
$length = ''
$type = ''

Description détaillée

Data object representing a feed enclosure

Depuis
1.7.0

Documentation des champs

◆ $length

$length = ''

◆ $type

$type = ''

◆ $url

$url = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedEnclosure.php


Joomla CMS: Référence de la classe FeedImage

  • Joomla
  • CMS
  • Document
  • Feed
  • FeedImage
Champs de données
Référence de la classe FeedImage

Champs de données

$title = ''
$url = ''
$link = ''
$width
$height
$description

Description détaillée

Data object representing a feed image

Depuis
1.7.0

Documentation des champs

◆ $description

$description

◆ $height

$height

◆ $link

$link = ''

◆ $title

$title = ''

◆ $url

$url = ''

◆ $width

$width
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedImage.php


Joomla CMS: Référence de la classe FeedItem

  • Joomla
  • CMS
  • Document
  • Feed
  • FeedItem
Fonctions membres publiques | Champs de données
Référence de la classe FeedItem

Fonctions membres publiques

setEnclosure (FeedEnclosure $enclosure)

Champs de données

$title
$link
$description
$author
$authorEmail
$category
$comments
$enclosure = null
$guid
$date
$source

Description détaillée

Data object representing a feed item

Depuis
1.7.0

Documentation des fonctions membres

◆ setEnclosure()

setEnclosure ( FeedEnclosure $enclosure )

Set the FeedEnclosure for this item

Paramètres
FeedEnclosure $enclosure The FeedEnclosure to add to the feed.
Renvoie
FeedItem instance of $this to allow chaining
Depuis
1.7.0

Références $this.

Documentation des champs

◆ $author

$author

◆ $authorEmail

$authorEmail

◆ $category

$category

◆ $comments

$comments

◆ $date

$date

◆ $description

$description

◆ $enclosure

$enclosure = null

◆ $guid

$guid

◆ $link

$link

◆ $source

$source

◆ $title

$title
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedItem.php


Joomla CMS: Référence de la classe OpensearchImage

  • Joomla
  • CMS
  • Document
  • Opensearch
  • OpensearchImage
Champs de données
Référence de la classe OpensearchImage

Champs de données

$type = ''
$data = ''
$width
$height

Description détaillée

Data object representing an OpenSearch image

Depuis
1.7.0

Documentation des champs

◆ $data

$data = ''

◆ $height

$height

◆ $type

$type = ''

◆ $width

$width
La documentation de cette classe a été générée à partir du fichier suivant :
  • OpensearchImage.php


Joomla CMS: Référence de la classe OpensearchUrl

  • Joomla
  • CMS
  • Document
  • Opensearch
  • OpensearchUrl
Champs de données
Référence de la classe OpensearchUrl

Champs de données

$type = 'text/html'
$rel = 'results'
$template

Description détaillée

Data object representing an OpenSearch URL

Depuis
1.7.0

Documentation des champs

◆ $rel

$rel = 'results'

◆ $template

$template

◆ $type

$type = 'text/html'
La documentation de cette classe a été générée à partir du fichier suivant :
  • OpensearchUrl.php


Joomla CMS: Référence de la classe AtomRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Feed
  • AtomRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe AtomRenderer
+ Graphe d'héritage de AtomRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($name='', $params=null, $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Attributs protégés

$_mime = 'application/atom+xml'
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)

Documentation des fonctions membres

◆ render()

render | ( | $name = '',
 |  | $params = null,
 |  | $content = null
 | ) |

Render the feed.

Paramètres
string | $name | The name of the element to render
array | $params | Array of values
string | $content | Override the output of the renderer
Renvoie
string The output of the script
Voir également
DocumentRenderer::render()
Depuis
3.5

Implémente RendererInterface.

Références $app, $count, $data, $feed, $i, $minorVersion, $now, Document\$title, $url, Route\_(), elseif, ENT_COMPAT, Factory\getApplication(), Factory\getDate(), Uri\getInstance(), Version\MAJOR_VERSION, Version\MINOR_VERSION, null, et Text\sprintf().

Documentation des champs

◆ $_mime

$_mime = 'application/atom+xml'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AtomRenderer.php


Joomla CMS: Référence de la classe RssRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Feed
  • RssRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe RssRenderer
+ Graphe d'héritage de RssRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($name='', $params=null, $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Attributs protégés

$_mime = 'application/rss+xml'
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)

Documentation des fonctions membres

◆ render()

render | ( | $name = '',
 |  | $params = null,
 |  | $content = null
 | ) |

Render the feed.

Paramètres
string | $name | The name of the element to render
array | $params | Array of values
string | $content | Override the output of the renderer
Renvoie
string The output of the script
Voir également
DocumentRenderer::render()
Depuis
3.5

Implémente RendererInterface.

Références $app, $count, $data, $feed, $i, Document\$title, $url, Route\_(), elseif, ENT_COMPAT, Factory\getApplication(), Factory\getDate(), Uri\getInstance(), null, et Text\sprintf().

Documentation des champs

◆ $_mime

$_mime = 'application/rss+xml'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RssRenderer.php


Joomla CMS: Référence de la classe ComponentRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • ComponentRenderer
Fonctions membres publiques
Référence de la classe ComponentRenderer
+ Graphe d'héritage de ComponentRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($component=null, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

HTML document renderer for the component output

Depuis
3.5

Documentation des fonctions membres

◆ render()

render | ( | $component = null,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders a component script and returns the results as a string

Paramètres
string | $component | The name of the component to render
array | $params | Associative array of values
string | $content | Content script
Renvoie
string The output of the script
Depuis
3.5

Implémente RendererInterface.

Références $content.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentRenderer.php


Joomla CMS: Référence de la classe HeadRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • HeadRenderer
Fonctions membres publiques
Référence de la classe HeadRenderer
+ Graphe d'héritage de HeadRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($head, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

HTML document renderer for the document <head> element

Depuis
3.5

Documentation des fonctions membres

◆ render()

render | ( | $head,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders the document head and returns the results as a string

Paramètres
string | $head | (unused)
array | $params | Associative array of values
string | $content | The script
Renvoie
string The output of the script
Depuis
3.5

Implémente RendererInterface.

Références $buffer, $content, et $params.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HeadRenderer.php


Joomla CMS: Référence de la classe MessageRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • MessageRenderer
Fonctions membres publiques | Fonctions membres privées
Référence de la classe MessageRenderer
+ Graphe d'héritage de MessageRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($name, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Fonctions membres privées

getData ()

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

HTML document renderer for the system message queue

Depuis
3.5

Documentation des fonctions membres

◆ getData()

getData ( )
private

Get and prepare system message data for output

Renvoie
array An array contains system message
Depuis
3.5

Références $messages, et Factory\getApplication().

◆ render()

render | ( | $name,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders the error stack and returns the results as a string

Paramètres
string | $name | Not used.
array | $params | Associative array of values
string | $content | Not used.
Renvoie
string The output of the script
Depuis
3.5

Implémente RendererInterface.

Références $app, $content, $displayData, $msgList, $name, $params, Factory\getApplication(), JPATH_THEMES, et LayoutHelper\render().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessageRenderer.php


Joomla CMS: Référence de la classe MetasRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • MetasRenderer
Référence de la classe MetasRenderer
+ Graphe d'héritage de MetasRenderer:
DocumentRenderer RendererInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()
- Fonctions membres publiques hérités de RendererInterface
render ($name, $params=null, $content=null)
- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

JDocument metas renderer

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • MetasRenderer.php


Joomla CMS: Référence de la classe ModuleRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • ModuleRenderer
Fonctions membres publiques
Référence de la classe ModuleRenderer
+ Graphe d'héritage de ModuleRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($module, $attribs=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

HTML document renderer for a single module

Depuis
3.5

Documentation des fonctions membres

◆ render()

render | ( | $module,
 |  | $attribs = array(),
 |  | $content = null
 | ) |

Renders a module script and returns the results as a string

Paramètres
string | $module | The name of the module to render
array | $attribs | Associative array of values
string | $content | If present, module information from the buffer will be used
Renvoie
string The output of the script
Depuis
3.5

If module isn't found in the database but data has been pushed in the buffer we want to render it

Implémente RendererInterface.

Références $attribs, $cacheparams, $content, $module, $params, Document\$title, $tmp, class, ENT_COMPAT, Factory\getApplication(), ModuleHelper\getModule(), null, et ModuleHelper\renderModule().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleRenderer.php


Joomla CMS: Référence de la classe ModulesRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • ModulesRenderer
Fonctions membres publiques
Référence de la classe ModulesRenderer
+ Graphe d'héritage de ModulesRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($position, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

HTML document renderer for a module position

Depuis
3.5

Documentation des fonctions membres

◆ render()

render | ( | $position,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders multiple modules script and returns the results as a string

Paramètres
string | $position | The position of the modules to render
array | $params | Associative array of values
string | $content | Module content
Renvoie
string The output of the script
Depuis
3.5

Implémente RendererInterface.

Références $app, $buffer, $content, $displayData, $menusEditing, $mod, $moduleHtml, $params, $position, $renderer, $user, Factory\getApplication(), ModuleHelper\getModules(), Factory\getUser(), et LayoutHelper\render().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulesRenderer.php


Joomla CMS: Référence de la classe ScriptsRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • ScriptsRenderer
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ScriptsRenderer
+ Graphe d'héritage de ScriptsRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($head, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Fonctions membres privées

renderElement ($item)
renderInlineElement ($item)
renderAttributes (array $attributes)

Attributs privés

$renderedSrc = []

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

JDocument head renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render | ( | $head,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders the document script tags and returns the results as a string

Paramètres
string | $head | (unused)
array | $params | Associative array of values
string | $content | The script
Renvoie
string The output of the script
Depuis
4.0.0

Implémente RendererInterface.

Références $buffer, $content, $item, $key, $type, $wam, et null.

◆ renderAttributes()

renderAttributes ( array $attributes )
private

Renders the element attributes

Paramètres
array $attributes The element attributes
Renvoie
string The attributes string
Depuis
4.0.0

Références $attributes, $buffer, $value, elseif, et ENT_COMPAT.

◆ renderElement()

renderElement ( $item )
private

Renders the element

Paramètres
WebAssetItemInterface | array $item The element
Renvoie
string The resulting string
Depuis
4.0.0

Références $attribs, $buffer, $item, Document\$mediaVersion, $version, JDEBUG, et null.

◆ renderInlineElement()

renderInlineElement ( $item )
private

Renders the inline element

Paramètres
WebAssetItemInterface | array $item The element
Renvoie
string The resulting string
Depuis
4.0.0

Références $attribs, $buffer, $content, et $item.

Documentation des champs

◆ $renderedSrc

$renderedSrc = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ScriptsRenderer.php


Joomla CMS: Référence de la classe StylesRenderer

  • Joomla
  • CMS
  • Document
  • Renderer
  • Html
  • StylesRenderer
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe StylesRenderer
+ Graphe d'héritage de StylesRenderer:
DocumentRenderer RendererInterface

Fonctions membres publiques

render ($head, $params=array(), $content=null)
- Fonctions membres publiques hérités de DocumentRenderer
__construct (Document $doc)
getContentType ()

Fonctions membres privées

renderElement ($item)
renderInlineElement ($item)
renderAttributes (array $attributes)

Attributs privés

$renderedSrc = []

Membres hérités additionnels

- Fonctions membres protégées hérités de DocumentRenderer
_relToAbs ($text)
- Attributs protégés hérités de DocumentRenderer
$_doc = null
$_mime = 'text/html'

Description détaillée

JDocument styles renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render | ( | $head,
 |  | $params = array(),
 |  | $content = null
 | ) |

Renders the document stylesheets and style tags and returns the results as a string

Paramètres
string | $head | (unused)
array | $params | Associative array of values
string | $content | The script
Renvoie
string The output of the script
Depuis
4.0.0

Implémente RendererInterface.

Références $buffer, $content, $item, $key, $type, $wam, et null.

◆ renderAttributes()

renderAttributes ( array $attributes )
private

Renders the element attributes

Paramètres
array $attributes The element attributes
Renvoie
string The attributes string
Depuis
4.0.0

Références $attributes, $buffer, $value, elseif, et ENT_COMPAT.

◆ renderElement()

renderElement ( $item )
private

Renders the element

Paramètres
WebAssetItemInterface | array $item The element
Renvoie
string The resulting string
Depuis
4.0.0

Références $attribs, $buffer, $item, Document\$mediaVersion, $version, JDEBUG, et null.

◆ renderInlineElement()

renderInlineElement ( $item )
private

Renders the inline element

Paramètres
WebAssetItemInterface | array $item The element
Renvoie
string The resulting string
Depuis
4.0.0

Références $attribs, $buffer, $content, et $item.

Documentation des champs

◆ $renderedSrc

$renderedSrc = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • StylesRenderer.php


Joomla CMS: Référence de la classe Document

  • Joomla
  • CMS
  • Document
  • Document
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Document
+ Graphe d'héritage de Document:
FeedDocument HtmlDocument ImageDocument JsonDocument OpensearchDocument RawDocument XmlDocument ErrorDocument JsonapiDocument

Fonctions membres publiques

__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Fonctions membres publiques statiques

static getInstance ($type='html', $attributes=array())

Champs de données

$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null

Attributs publics statiques

static $_buffer = null

Fonctions membres protégées

preloadAssets ()

Attributs protégés

$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Attributs protégés statiques

static $instances = array()

Description détaillée

Document class, provides an easy interface to parse and display a document

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor.

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, Document\$webAssetManager, Factory\getContainer(), Document\setBase(), Document\setCharset(), Document\setDirection(), Document\setFactory(), Document\setLanguage(), Document\setLineEnd(), Document\setLink(), Document\setMediaVersion(), Document\setPreloadManager(), Document\setTab(), et Document\setWebAssetManager().

Documentation des fonctions membres

◆ _getLineEnd()

_getLineEnd ( )

Returns the lineEnd

Renvoie
string
Depuis
1.7.0

Références Document\$_lineEnd.

◆ _getTab()

_getTab ( )

Returns a string containing the unit for indenting HTML

Renvoie
string
Depuis
1.7.0

Références Document\$_tab.

◆ addScript()

addScript | ( | $url,
 |  | $options = array(),
 |  | $attribs = array()
 | ) |

Adds a linked script to the page

Paramètres
string | $url | URL to the linked script.
array | $options | Array of options. Example: array('version' => 'auto', 'conditional' => 'lt IE 9', 'preload' => array('preload'))
array | $attribs | Array of attributes. Example: array('id' => 'scriptid', 'async' => 'async', 'data-test' => 1)
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0
Obsolète:
5.0 Use WebAssetManager

Références $attribs, $options, $this, et $url.

◆ addScriptDeclaration()

addScriptDeclaration | ( | $content,
 |  | $type = 'text/javascript'
 | ) |

Adds a script to the page

Paramètres
string | $content | Script
string | $type | Scripting mime (defaults to 'text/javascript')
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0
Obsolète:
5.0 Use WebAssetManager

Références $content, $this, et $type.

Référencé par HtmlDocument\mergeHeadData().

◆ addScriptOptions()

addScriptOptions | ( | $key,
 |  | $options,
 |  | $merge = true
 | ) |

Add option for script

Paramètres
string | $key | Name in Storage
mixed | $options | Scrip options as array or string
bool | $merge | Whether merge with existing (true) or replace (false)
Renvoie
Document instance of $this to allow chaining
Depuis
3.5

Références $key, $options, et $this.

Référencé par HtmlDocument\mergeHeadData().

◆ addStyleDeclaration()

addStyleDeclaration | ( | $content,
 |  | $type = 'text/css'
 | ) |

Adds a stylesheet declaration to the page

Paramètres
string | $content | Style declarations
string | $type | Type of stylesheet (defaults to 'text/css')
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0
Obsolète:
5.0 Use WebAssetManager

Références $content, $this, et $type.

Référencé par HtmlDocument\mergeHeadData().

◆ addStyleSheet()

addStyleSheet | ( | $url,
 |  | $options = array(),
 |  | $attribs = array()
 | ) |

Adds a linked stylesheet to the page

Paramètres
string | $url | URL to the linked style sheet
array | $options | Array of options. Example: array('version' => 'auto', 'conditional' => 'lt IE 9', 'preload' => array('preload'))
array | $attribs | Array of attributes. Example: array('id' => 'stylesheet', 'data-test' => 1)
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0
Obsolète:
5.0 Use WebAssetManager

Références $attribs, $options, $this, et $url.

◆ getBase()

getBase ( )

Return the base URI of the document.

Renvoie
string
Depuis
1.7.0

Références Document\$base.

◆ getBuffer()

getBuffer ( )

Get the contents of the document buffer

Renvoie
mixed
Depuis
1.7.0

Référencé par HtmlDocument\_renderTemplate(), RawDocument\render(), ImageDocument\render(), et XmlDocument\render().

◆ getCharset()

getCharset ( )

Returns the document charset encoding.

Renvoie
string
Depuis
1.7.0

Références Document\$_charset.

◆ getDescription()

getDescription ( )

Return the description of the document.

Renvoie
string
Depuis
1.7.0

Références Document\$description.

Référencé par Document\getMetaData().

◆ getDirection()

getDirection ( )

Returns the document direction declaration.

Renvoie
string
Depuis
1.7.0

Références Document\$direction.

◆ getGenerator()

getGenerator ( )

Returns the document generator

Renvoie
string
Depuis
1.7.0

Références Document\$_generator.

Référencé par Document\getMetaData(), et FeedDocument\render().

◆ getInstance()

static getInstance | ( | $type = 'html',
 |  | $attributes = array()
 | ) |
static

Returns the global Document object, only creating it if it doesn't already exist.

Paramètres
string | $type | The document type to instantiate
array | $attributes | Array of attributes
Renvoie
static The document object.
Depuis
1.7.0
Obsolète:
5.0 Use the instead

Références $attributes, $type, class, et Joomla\DI\getContainer().

◆ getLanguage()

getLanguage ( )

Returns the document language.

Renvoie
string
Depuis
1.7.0

Références Document\$language.

◆ getLink()

getLink ( )

Returns the document base url

Renvoie
string
Depuis
1.7.0

Références Document\$link.

◆ getMediaVersion()

getMediaVersion ( )

Return the media version

Renvoie
string
Depuis
3.2

Références Document\$mediaVersion.

◆ getMetaData()

getMetaData | ( | $name,
 |  | $attribute = 'name'
 | ) |

Gets a meta tag.

Paramètres
string | $name | Name of the meta HTML tag
string | $attribute | Attribute to use in the meta HTML tag
Renvoie
string
Depuis
1.7.0

Références $name, $result, elseif, Document\getDescription(), et Document\getGenerator().

◆ getMimeEncoding()

getMimeEncoding ( )

Return the document MIME encoding that is sent to the browser.

Renvoie
string
Depuis
1.7.0

Références Document\$_mime.

◆ getModifiedDate()

getModifiedDate ( )

Returns the document modified date

Renvoie
string|Date
Depuis
1.7.0

Références Document\$_mdate.

Référencé par JsonapiDocument\render(), et Document\render().

◆ getPreloadManager()

getPreloadManager ( )

Return the preload manager

Renvoie
PreloadManagerInterface
Depuis
4.0.0

Références Document\$preloadManager.

Référencé par Document\preloadAssets().

◆ getScriptOptions()

getScriptOptions ( $key = null )

Get script(s) options

Paramètres
string $key Name in Storage
Renvoie
array Options for given $key, or all script options
Depuis
3.5

Références $key, et Document\$scriptOptions.

◆ getTitle()

getTitle ( )

Return the title of the document.

Renvoie
string
Depuis
1.7.0

Références Document\$title.

◆ getType()

getType ( )

Returns the document type

Renvoie
string
Depuis
1.7.0

Références Document\$_type.

◆ getWebAssetManager()

getWebAssetManager ( )

Return WebAsset manager

Renvoie
WebAssetManager
Depuis
4.0.0

Références Document\$webAssetManager.

Référencé par HtmlDocument\getHeadData(), HtmlDocument\mergeHeadData(), et HtmlDocument\setHeadData().

◆ loadRenderer()

loadRenderer ( $type )

Load a renderer

Paramètres
string $type The renderer type
Renvoie
RendererInterface
Depuis
1.7.0
Exceptions

Références $this, et $type.

Référencé par HtmlDocument\countModules(), et FeedDocument\render().

◆ parse()

parse ( $params = array() )

Parses the document and prepares the buffers

Paramètres
array $params The array of parameters
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this.

Référencé par HtmlDocument\render().

◆ preloadAssets()

preloadAssets ( )
protected

Generate the Link header for assets configured for preloading

Renvoie
void
Depuis
4.0.0

Références Document\$link, elseif, Fig\Link\getLinks(), et Document\getPreloadManager().

Référencé par Document\render().

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Outputs the document

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références Document\$_charset, Document\$_mime, $app, Document\getModifiedDate(), et Document\preloadAssets().

◆ setBase()

setBase ( $base )

Sets the base URI of the document

Paramètres
string $base The base URI to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références Document\$base, et $this.

Référencé par Document\__construct().

◆ setBuffer()

setBuffer | ( | $content,
 |  | $options = array()
 | ) |

Set the contents of the document buffer

Paramètres
string | $content | The content to be set in the buffer.
array | $options | Array of optional elements.
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $content, et $this.

◆ setCharset()

setCharset ( $type = 'utf-8' )

Sets the document charset

Paramètres
string $type Charset encoding string
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this, et $type.

Référencé par Document\__construct().

◆ setDescription()

setDescription ( $description )

Sets the description of the document

Paramètres
string $description The description to set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références Document\$description, $this, et description.

Référencé par Document\setMetaData().

◆ setDirection()

setDirection ( $dir = 'ltr' )

Sets the global document direction declaration. Default is left-to-right (ltr).

Paramètres
string $dir The language direction to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $dir, et $this.

Référencé par Document\__construct().

◆ setFactory()

setFactory ( FactoryInterface $factory )

Set the factory instance

Paramètres
FactoryInterface $factory The factory instance
Renvoie
Document
Depuis
4.0.0

Références Document\$factory, et $this.

Référencé par Document\__construct().

◆ setGenerator()

setGenerator ( $generator )

Sets the document generator

Paramètres
string $generator The generator to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this.

Référencé par Document\setMetaData().

◆ setLanguage()

setLanguage ( $lang = 'en-gb' )

Sets the global document language declaration. Default is English (en-gb).

Paramètres
string $lang The language to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $lang, $this, et language.

Référencé par Document\__construct().

◆ setLineEnd()

setLineEnd ( $style )

Sets the line end style to Windows, Mac, Unix or a custom string.

Paramètres
string $style "win", "mac", "unix" or custom string.
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $style, et $this.

Référencé par Document\__construct().

◆ setLink()

setLink ( $url )

Sets the document link

Paramètres
string $url A url
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this, et $url.

Référencé par Document\__construct().

◆ setMediaVersion()

setMediaVersion ( $mediaVersion )

Set the assets version

Paramètres
string $mediaVersion Media version to use
Renvoie
Document instance of $this to allow chaining
Depuis
3.2

Références Document\$mediaVersion, et $this.

Référencé par Document\__construct().

◆ setMetaData()

setMetaData | ( | $name,
 |  | $content,
 |  | $attribute = 'name'
 | ) |

Sets or alters a meta tag.

Paramètres
string | $name | Name of the meta HTML tag
mixed | $content | Value of the meta HTML tag as array or string
string | $attribute | Attribute to use in the meta HTML tag
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $content, $name, $this, elseif, Document\setDescription(), et Document\setGenerator().

Référencé par HtmlDocument\mergeHeadData(), et Document\setMimeEncoding().

◆ setMimeEncoding()

setMimeEncoding | ( | $type = 'text/html',
 |  | $sync = true
 | ) |

Sets the document MIME encoding that is sent to the browser.

This usually will be text/html because most browsers cannot yet accept the proper mime settings for XHTML: application/xhtml+xml and to a lesser extent application/xml and text/xml. See the W3C note ( https://www.w3.org/TR/xhtml-media-types/) for more details.

Paramètres
string | $type | The document type to be sent
boolean | $sync | Should the type be synced with HTML?
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

https://www.w3.org/TR/xhtml-media-types/

Références $this, $type, et Document\setMetaData().

Référencé par HtmlDocument\__construct(), et FeedDocument\render().

◆ setModifiedDate()

setModifiedDate ( $date )

Sets the document modified date

Paramètres
string | Date $date The date to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0
Exceptions

Références $date, et $this.

◆ setPreloadManager()

setPreloadManager ( PreloadManagerInterface $preloadManager )

Set the preload manager

Paramètres
PreloadManagerInterface $preloadManager The preload manager service
Renvoie
Document instance of $this to allow chaining
Depuis
4.0.0

Références Document\$preloadManager, et $this.

Référencé par Document\__construct().

◆ setTab()

setTab ( $string )

Sets the string used to indent HTML

Paramètres
string $string String used to indent ("\11", "\t", ' ', etc.).
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this.

Référencé par Document\__construct().

◆ setTitle()

setTitle ( $title )

Sets the title of the document

Paramètres
string $title The title to be set
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this, et Document\$title.

◆ setType()

setType ( $type )

Set the document type

Paramètres
string $type Type document is to set to
Renvoie
Document instance of $this to allow chaining
Depuis
1.7.0

Références $this, et $type.

◆ setWebAssetManager()

setWebAssetManager ( WebAssetManager $webAsset )

Set WebAsset manager

Paramètres
WebAssetManager $webAsset The WebAsset instance
Renvoie
Document
Depuis
4.0.0

Références $this.

Référencé par Document\__construct().

Documentation des champs

◆ $_buffer

$_buffer = null
static

◆ $_charset

$_charset = 'utf-8'

Référencé par Document\getCharset(), JsonapiDocument\render(), et Document\render().

◆ $_engine

$_engine = null

◆ $_generator

$_generator = 'Joomla! - Open Source Content Management'

Référencé par Document\getGenerator().

◆ $_lineEnd

$_lineEnd = "\12"

Référencé par Document\_getLineEnd().

◆ $_mdate

$_mdate = ''

Référencé par Document\getModifiedDate().

◆ $_metaTags

$_metaTags = array()

Référencé par HtmlDocument\getHeadData(), et HtmlDocument\setHeadData().

◆ $_mime

$_mime = ''

Référencé par DocumentRenderer\getContentType(), Document\getMimeEncoding(), JsonapiDocument\render(), et Document\render().

◆ $_namespace

$_namespace = ''

◆ $_profile

$_profile = ''

◆ $_script

$_script = array()

Référencé par HtmlDocument\getHeadData(), et HtmlDocument\setHeadData().

◆ $_scripts

$_scripts = array()

Référencé par HtmlDocument\getHeadData(), HtmlDocument\mergeHeadData(), et HtmlDocument\setHeadData().

◆ $_style

$_style = array()

Référencé par HtmlDocument\getHeadData(), et HtmlDocument\setHeadData().

◆ $_styleSheets

$_styleSheets = array()

Référencé par HtmlDocument\getHeadData(), HtmlDocument\mergeHeadData(), et HtmlDocument\setHeadData().

◆ $_tab

$_tab = "\11"

Référencé par Document\_getTab().

◆ $_type

$_type = null

Référencé par Document\getType().

◆ $base

$base = ''

Référencé par DocumentRenderer\_relToAbs(), Document\getBase(), et Document\setBase().

◆ $description

$description = ''

Référencé par Document\getDescription(), HtmlDocument\getHeadData(), Document\setDescription(), et HtmlDocument\setHeadData().

◆ $direction

$direction = 'ltr'

Référencé par Document\getDirection().

◆ $factory

$factory
protected

Référencé par Document\setFactory().

◆ $instances

$instances = array()
staticprotected

◆ $language

$language = 'en-gb'

Référencé par Document\getLanguage().

◆ $link

$link = ''

Référencé par FeedDocument\addItem(), HtmlDocument\getHeadData(), Document\getLink(), PreloadManager\link(), HtmlDocument\mergeHeadData(), Document\preloadAssets(), et HtmlDocument\setHeadData().

◆ $mediaVersion

$mediaVersion = null
protected

Référencé par Document\getMediaVersion(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), et Document\setMediaVersion().

◆ $preloadManager

$preloadManager = null
protected

Référencé par Document\getPreloadManager(), et Document\setPreloadManager().

◆ $preloadTypes

$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
protected

◆ $scriptOptions

$scriptOptions = array()
protected

Référencé par HtmlDocument\getHeadData(), Document\getScriptOptions(), et HtmlDocument\mergeHeadData().

◆ $title

$title = ''

Référencé par HtmlDocument\getHeadData(), Document\getTitle(), ModuleRenderer\render(), RssRenderer\render(), AtomRenderer\render(), HtmlDocument\setHeadData(), et Document\setTitle().

◆ $webAssetManager

$webAssetManager = null
protected

Référencé par Document\__construct(), et Document\getWebAssetManager().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Document/Document.php


Joomla CMS: Référence de la classe DocumentRenderer

  • Joomla
  • CMS
  • Document
  • DocumentRenderer
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DocumentRenderer
+ Graphe d'héritage de DocumentRenderer:
RendererInterface AtomRenderer RssRenderer ComponentRenderer HeadRenderer MessageRenderer MetasRenderer ModuleRenderer ModulesRenderer ScriptsRenderer StylesRenderer

Fonctions membres publiques

__construct (Document $doc)
getContentType ()
- Fonctions membres publiques hérités de RendererInterface
render ($name, $params=null, $content=null)

Fonctions membres protégées

_relToAbs ($text)

Attributs protégés

$_doc = null
$_mime = 'text/html'

Description détaillée

Abstract class for a renderer

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Document $doc )

Class constructor

Paramètres
Document $doc A reference to the Document object that instantiated the renderer
Depuis
1.7.0

Références $doc.

Documentation des fonctions membres

◆ _relToAbs()

_relToAbs ( $text )
protected

Convert links in a text from relative to absolute

Paramètres
string $text The text processed
Renvoie
string Text with converted links
Depuis
1.7.0

Références Document\$base, $text, et Uri\base().

◆ getContentType()

getContentType ( )

Return the content type of the renderer

Renvoie
string The contentType
Depuis
1.7.0

Références Document\$_mime.

Documentation des champs

◆ $_doc

$_doc = null
protected

◆ $_mime

$_mime = 'text/html'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DocumentRenderer.php


Joomla CMS: Référence de la classe ErrorDocument

  • Joomla
  • CMS
  • Document
  • ErrorDocument
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe ErrorDocument
+ Graphe d'héritage de ErrorDocument:
HtmlDocument Document CacheControllerFactoryAwareInterface

Fonctions membres publiques

__construct ($options=array())
setError ($error)
loadRenderer ($type)
render ($cache=false, $params=array())
renderBacktrace ()
- Fonctions membres publiques hérités de HtmlDocument
__construct ($options=array())
getHeadData ()
resetHeadData ($types=null)
setHeadData ($data)
mergeHeadData ($data)
addHeadLink ($href, $relation, $relType='rel', $attribs=array())
addFavicon ($href, $type='image/vnd.microsoft.icon', $relation='shortcut icon')
addCustomTag ($html)
isHtml5 ()
setHtml5 ($state)
setBuffer ($content, $options=array())
parse ($params=array())
render ($caching=false, $params=array())
countModules (string $positionName, bool $withContentOnly=false)
countMenuChildren ()
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)

Champs de données

$debug = false
$error
- Champs de données hérités de HtmlDocument
$_links = array()
$_custom = array()
$template = null
$baseurl = null
$params = null
$_file = null
$cspNonce = null
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null

Attributs protégés

$_error
- Attributs protégés hérités de HtmlDocument
$_template = ''
$_template_tags = array()
$_caching = null
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de HtmlDocument
_loadTemplate ($directory, $filename)
_fetchTemplate ($params=array())
_parseTemplate ()
_renderTemplate ()
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

ErrorDocument class, provides an easy interface to parse and display an HTML based error page

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of attributes
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ loadRenderer()

loadRenderer ( $type )

Load a renderer

Paramètres
string $type The renderer type
Renvoie
RendererInterface
Depuis
4.0.0
Exceptions

Références $this, et $type.

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références $params.

◆ renderBacktrace()

renderBacktrace ( )

Render the backtrace

Renvoie
string The contents of the backtrace
Depuis
1.7.0

Références LayoutHelper\render().

◆ setError()

setError ( $error )

Set error object

Paramètres
\Throwable $error Error object to set
Renvoie
boolean True on success
Depuis
1.7.0

Documentation des champs

◆ $_error

$_error
protected

◆ $debug

$debug = false

◆ $error

$error
La documentation de cette classe a été générée à partir du fichier suivant :
  • ErrorDocument.php


Joomla CMS: Référence de la classe Factory

  • Joomla
  • CMS
  • Document
  • Factory
Fonctions membres publiques
Référence de la classe Factory
+ Graphe d'héritage de Factory:
FactoryInterface

Fonctions membres publiques

createRenderer (Document $document, string $type, string $docType='')
- Fonctions membres publiques hérités de FactoryInterface
createDocument (string $type='html', array $attributes=[])

Description détaillée

Default factory for creating Document objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createRenderer()

createRenderer | ( | Document | $document,
 |  | string | $type,
 |  | string | $docType = ''
 | ) |  |

Creates a new renderer object.

Paramètres
Document | $document | The Document instance to attach to the renderer
string | $type | The renderer type to instantiate
string | $docType | The document type the renderer is part of
Renvoie
RendererInterface
Depuis
4.0.0

Implémente FactoryInterface.

Références $class, $document, $type, et Joomla\CMS\Cache\getCacheControllerFactory().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Document/Factory.php


Joomla CMS: Référence de l'interface FactoryInterface

  • Joomla
  • CMS
  • Document
  • FactoryInterface
Fonctions membres publiques
Référence de l'interface FactoryInterface
+ Graphe d'héritage de FactoryInterface:
Factory

Fonctions membres publiques

createDocument (string $type='html', array $attributes=[])
createRenderer (Document $document, string $type, string $docType='')

Description détaillée

Interface defining a factory which can create Document objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createDocument()

createDocument | ( | string | $type = 'html',
 |  | array | $attributes = []
 | ) |  |

Creates a new Document object for the requested format.

Paramètres
string | $type | The document type to instantiate
array | $attributes | Array of attributes
Renvoie
Document
Depuis
4.0.0

◆ createRenderer()

createRenderer | ( | Document | $document,
 |  | string | $type,
 |  | string | $docType = ''
 | ) |  |

Creates a new renderer object.

Paramètres
Document | $document | The Document instance to attach to the renderer
string | $type | The renderer type to instantiate
string | $docType | The document type the renderer is part of
Renvoie
RendererInterface
Depuis
4.0.0

Implémenté dans Factory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FactoryInterface.php


Joomla CMS: Référence de la classe FeedDocument

  • Joomla
  • CMS
  • Document
  • FeedDocument
Fonctions membres publiques | Champs de données
Référence de la classe FeedDocument
+ Graphe d'héritage de FeedDocument:
Document

Fonctions membres publiques

__construct ($options=array())
render ($cache=false, $params=array())
addItem (FeedItem $item)
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Champs de données

$syndicationURL = ''
$image = null
$copyright = ''
$pubDate = ''
$lastBuildDate
$editor = ''
$docs = ''
$editorEmail = ''
$webmaster = ''
$category = ''
$ttl = ''
$rating = ''
$skipHours = ''
$skipDays = ''
$items = array()
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

FeedDocument class, provides an easy interface to parse and display any feed document

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addItem()

addItem ( FeedItem $item )

Adds a FeedItem to the feed.

Paramètres
FeedItem $item The feeditem to add to the feed.
Renvoie
FeedDocument instance of $this to allow chaining
Depuis
1.7.0

Références $item, Document\$link, $this, et items.

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0
Exceptions

Références $attr, $data, $params, $renderer, $type, Text\_(), Document\getGenerator(), Document\loadRenderer(), et Document\setMimeEncoding().

Documentation des champs

◆ $category

$category = ''

◆ $copyright

$copyright = ''

◆ $docs

$docs = ''

◆ $editor

$editor = ''

◆ $editorEmail

$editorEmail = ''

◆ $image

$image = null

◆ $items

$items = array()

◆ $lastBuildDate

$lastBuildDate

◆ $pubDate

$pubDate = ''

◆ $rating

$rating = ''

◆ $skipDays

$skipDays = ''

◆ $skipHours

$skipHours = ''

◆ $syndicationURL

$syndicationURL = ''

◆ $ttl

$ttl = ''

◆ $webmaster

$webmaster = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedDocument.php


Joomla CMS: Référence de la classe HtmlDocument

  • Joomla
  • CMS
  • Document
  • HtmlDocument
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe HtmlDocument
+ Graphe d'héritage de HtmlDocument:
Document CacheControllerFactoryAwareInterface ErrorDocument

Fonctions membres publiques

__construct ($options=array())
getHeadData ()
resetHeadData ($types=null)
setHeadData ($data)
mergeHeadData ($data)
addHeadLink ($href, $relation, $relType='rel', $attribs=array())
addFavicon ($href, $type='image/vnd.microsoft.icon', $relation='shortcut icon')
addCustomTag ($html)
isHtml5 ()
setHtml5 ($state)
setBuffer ($content, $options=array())
parse ($params=array())
render ($caching=false, $params=array())
countModules (string $positionName, bool $withContentOnly=false)
countMenuChildren ()
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)

Champs de données

$_links = array()
$_custom = array()
$template = null
$baseurl = null
$params = null
$_file = null
$cspNonce = null
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null

Fonctions membres protégées

_loadTemplate ($directory, $filename)
_fetchTemplate ($params=array())
_parseTemplate ()
_renderTemplate ()
- Fonctions membres protégées hérités de Document
preloadAssets ()

Attributs protégés

$_template = ''
$_template_tags = array()
$_caching = null
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Fonctions membres privées

resetHeadDatum ($type)

Attributs privés

$html5 = true

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

HtmlDocument class, provides an easy interface to parse and display a HTML document

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, Symfony\Contracts\Service\__construct(), et Document\setMimeEncoding().

Documentation des fonctions membres

◆ _fetchTemplate()

_fetchTemplate ( $params = array() )
protected

Fetch the template, and initialise the params

Paramètres
array $params Parameters to determine the template
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $baseDir, $lang, $params, $template, $this, Uri\base(), InputFilter\getInstance(), et JPATH_BASE.

◆ _loadTemplate()

_loadTemplate | ( | $directory,
 |  | $filename
 | ) |
protected

Load a template file

Paramètres
string | $directory | The name of the template
string | $filename | The actual filename
Renvoie
string The contents of the template
Depuis
1.7.0

◆ _parseTemplate()

_parseTemplate ( )
protected

Parse a document template

Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $attribs, $i, $messages, $name, $this, $type, elseif, null, et Utility\parseAttributes().

◆ _renderTemplate()

_renderTemplate ( )
protected

Render pre-parsed template

Renvoie
string rendered template
Depuis
1.7.0

Références Document\getBuffer().

◆ addCustomTag()

addCustomTag ( $html )

Adds a custom HTML string to the head block

Paramètres
string $html The HTML to add to the head
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $html, et $this.

◆ addFavicon()

addFavicon | ( | $href,
 |  | $type = 'image/vnd.microsoft.icon',
 |  | $relation = 'shortcut icon'
 | ) |

Adds a shortcut icon (favicon)

This adds a link to the icon shown in the favorites list or on the left of the url in the address bar. Some browsers display it on the tab, as well.

Paramètres
string | $href | The link that is being related.
string | $type | File type
string | $relation | Relation of link
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $href, $this, et $type.

◆ addHeadLink()

addHeadLink | ( | $href,
 |  | $relation,
 |  | $relType = 'rel',
 |  | $attribs = array()
 | ) |

Adds <link> tags to the head of the document

$relType defaults to 'rel' as it is the most common relation type used. ('rev' refers to reverse relation, 'rel' indicates normal, forward relation.) Typical tag: <link href="index.php" rel="Start">

Paramètres
string | $href | The link that is being related.
string | $relation | Relation of link.
string | $relType | Relation type attribute. Either rel or rev (default: 'rel').
array | $attribs | Associative array of remaining attributes.
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $attribs, $href, et $this.

◆ countMenuChildren()

countMenuChildren ( )

Count the number of child menu items of the current active menu item

Renvoie
integer Number of child menu items
Depuis
1.7.0

Références $active, $app, $db, $menu, $query, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ countModules()

countModules | ( | string | $positionName,
 |  | bool | $withContentOnly = false
 | ) |  |

Count the modules in the given position

Paramètres
string | $positionName | The position to use
boolean | $withContentOnly | Count only a modules which actually has a content
Renvoie
integer Number of modules found
Depuis
1.7.0

Références $module, $modules, $renderer, $result, ModuleHelper\getModules(), et Document\loadRenderer().

◆ getHeadData()

getHeadData ( )

Get the HTML document head data

Renvoie
array The document head data in array form
Depuis
1.7.0

Références Document\$_metaTags, Document\$_script, Document\$_scripts, Document\$_style, Document\$_styleSheets, $data, Document\$description, Document\$link, Document\$scriptOptions, Document\$title, $wa, Text\getScriptStrings(), et Document\getWebAssetManager().

◆ isHtml5()

isHtml5 ( )

Returns whether the document is set up to be output as HTML5

Renvoie
boolean true when HTML5 is used
Depuis
3.0.0

◆ mergeHeadData()

mergeHeadData ( $data )

Merge the HTML document head data

Paramètres
array $data The document head data in array form
Renvoie
HtmlDocument|void instance of $this to allow chaining or void for empty input data
Depuis
1.7.0

Références Document\$_scripts, Document\$_styleSheets, $data, $hash, $key, Document\$link, $script, Document\$scriptOptions, $style, $this, $type, $wa, Document\addScriptDeclaration(), Document\addScriptOptions(), Document\addStyleDeclaration(), description, Document\getWebAssetManager(), et Document\setMetaData().

◆ parse()

parse ( $params = array() )

Parses the template and populates the buffer

Paramètres
array $params Parameters for fetching the template
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $params.

◆ render()

render | ( | $caching = false,
 |  | $params = array()
 | ) |

Outputs the template to the browser.

Paramètres
boolean | $caching | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références $data, $params, et Document\parse().

◆ resetHeadData()

resetHeadData ( $types = null )

Reset the HTML document head data

Paramètres
mixed $types type or types of the heads elements to reset
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
3.7.0

Références $this, $type, et description.

◆ resetHeadDatum()

resetHeadDatum ( $type )
private

Reset a part the HTML document head data

Paramètres
string $type type of the heads elements to reset
Renvoie
void
Depuis
3.7.0

Références $type.

◆ setBuffer()

setBuffer | ( | $content,
 |  | $options = array()
 | ) |

Set the contents a document includes

Paramètres
string | $content | The content to be set in the buffer.
array | $options | Array of optional elements.
Renvoie
HtmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $content, $options, $this, et null.

◆ setHeadData()

setHeadData ( $data )

Set the HTML document head data

Paramètres
array $data The document head data in array form
Renvoie
HtmlDocument|null instance of $this to allow chaining or null for empty input data
Depuis
1.7.0

Références Document\$_metaTags, Document\$_script, Document\$_scripts, Document\$_style, Document\$_styleSheets, $data, Document\$description, Document\$link, $this, Document\$title, $wa, description, Document\getWebAssetManager(), et null.

◆ setHtml5()

setHtml5 ( $state )

Sets whether the document should be output as HTML5

Paramètres
bool $state True when HTML5 should be output
Renvoie
void
Depuis
3.0.0

Références $state.

Documentation des champs

◆ $_caching

$_caching = null
protected

◆ $_custom

$_custom = array()

◆ $_file

$_file = null

◆ $_links

$_links = array()

◆ $_template

$_template = ''
protected

◆ $_template_tags

$_template_tags = array()
protected

◆ $baseurl

$baseurl = null

◆ $cspNonce

$cspNonce = null

◆ $html5

$html5 = true
private

◆ $params

$params = null

◆ $template

$template = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlDocument.php


Joomla CMS: Référence de la classe ImageDocument

  • Joomla
  • CMS
  • Document
  • ImageDocument
Fonctions membres publiques
Référence de la classe ImageDocument
+ Graphe d'héritage de ImageDocument:
Document

Fonctions membres publiques

__construct ($options=array())
render ($cache=false, $params=array())
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

ImageDocument class, provides an easy interface to output image data

Depuis
3.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
3.0.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document.

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
3.0.0

Références $params, $type, Factory\getApplication(), Document\getBuffer(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ImageDocument.php


Joomla CMS: Référence de la classe JsonapiDocument

  • Joomla
  • CMS
  • Document
  • JsonapiDocument
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonapiDocument
+ Graphe d'héritage de JsonapiDocument:
JsonDocument Document

Fonctions membres publiques

__construct ($options=array())
setData (ElementInterface $element)
setErrors ($errors)
setJsonapi ($jsonapi)
toArray ()
__toString ()
render ($cache=false, $params=array())
jsonSerialize ()
addLink ($key, $value)
addMeta ($key, $value)
- Fonctions membres publiques hérités de JsonDocument
__construct ($options=array())
getName ()
setName ($name='joomla')
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Attributs protégés

$document
- Attributs protégés hérités de JsonDocument
$_name = 'joomla'
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

JsonapiDocument class, provides an easy interface to parse output in JSON-API format.

4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor.

Paramètres
array $options Associative array of options
Depuis
4.0.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Map to string.

Renvoie
string
Depuis
4.0.0

◆ addLink()

addLink | ( | $key,
 |  | $value
 | ) |

Add a link to the output.

Paramètres
string | $key | The name of the link
string | $value | The link
Renvoie
$this
Depuis
4.0.0

Références $key, $this, et $value.

◆ addMeta()

addMeta | ( | $key,
 |  | $value
 | ) |

Add a link to the output.

Paramètres
string | $key | The name of the metadata key
string | $value | The value
Renvoie
$this
Depuis
4.0.0

Références $key, $this, et $value.

◆ jsonSerialize()

jsonSerialize ( )

Serialize for JSON usage.

Renvoie
array
Depuis
4.0.0

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Outputs the document.

Paramètres
boolean | $cache | If true, cache the output.
array | $params | Associative array of attributes.
Renvoie
string The rendered data.
Depuis
4.0.0

Références Document\$_charset, Document\$_mime, $app, Factory\getApplication(), et Document\getModifiedDate().

◆ setData()

setData ( ElementInterface $element )

Set the data object.

Paramètres
ElementInterface $element Element interface.
Renvoie
$this
Depuis
4.0.0

Références $this.

◆ setErrors()

setErrors ( $errors )

Set the errors array.

Paramètres
array $errors Error array.
Renvoie
$this
Depuis
4.0.0

Références $this.

◆ setJsonapi()

setJsonapi ( $jsonapi )

Set the JSON-API array.

Paramètres
array $jsonapi JSON-API array.
Renvoie
$this
Depuis
4.0.0

Références $this.

◆ toArray()

toArray ( )

Map everything to arrays.

Renvoie
array
Depuis
4.0.0

Documentation des champs

◆ $document

$document
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonapiDocument.php


Joomla CMS: Référence de la classe JsonDocument

  • Joomla
  • CMS
  • Document
  • JsonDocument
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonDocument
+ Graphe d'héritage de JsonDocument:
Document JsonapiDocument

Fonctions membres publiques

__construct ($options=array())
getName ()
setName ($name='joomla')
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Attributs protégés

$_name = 'joomla'
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

JsonDocument class, provides an easy interface to parse and display JSON output

1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getName()

getName ( )

Returns the document name

Renvoie
string
Depuis
1.7.0

◆ setName()

setName ( $name = 'joomla' )

Sets the document name

Paramètres
string $name Document name
Renvoie
JsonDocument instance of $this to allow chaining
Depuis
1.7.0

Références $name, et $this.

Documentation des champs

◆ $_name

$_name = 'joomla'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonDocument.php


Joomla CMS: Référence de la classe OpensearchDocument

  • Joomla
  • CMS
  • Document
  • OpensearchDocument
Fonctions membres publiques | Attributs privés
Référence de la classe OpensearchDocument
+ Graphe d'héritage de OpensearchDocument:
Document

Fonctions membres publiques

__construct ($options=array())
render ($cache=false, $params=array())
setShortName ($name)
addUrl (OpensearchUrl $url)
addImage (OpensearchImage $image)
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Attributs privés

$_shortName = ''
$_images = array()
$_urls = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

Opensearch class, provides an easy interface to display an Opensearch document

1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $app, $dir, $options, $path, Route\_(), Symfony\Contracts\Service\__construct(), Uri\base(), Factory\getApplication(), Uri\getInstance(), JPATH_BASE, et JPATH_THEMES.

Documentation des fonctions membres

◆ addImage()

addImage ( OpensearchImage $image )

Adds an image to the Opensearch description.

Paramètres
OpensearchImage $image The image to add to the description.
Renvoie
OpensearchDocument instance of $this to allow chaining
Depuis
1.7.0

Références $image, et $this.

◆ addUrl()

addUrl ( OpensearchUrl $url )

Adds a URL to the Opensearch description.

Paramètres
OpensearchUrl $url The url to add to the description.
Renvoie
OpensearchDocument instance of $this to allow chaining
Depuis
1.7.0

Références $this, et $url.

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références $image, $params, $url, $xml, description, et JDEBUG.

◆ setShortName()

setShortName ( $name )

Sets the short name

Paramètres
string $name The name.
Renvoie
OpensearchDocument instance of $this to allow chaining
Depuis
1.7.0

Références $name, et $this.

Documentation des champs

◆ $_images

$_images = array()
private

◆ $_shortName

$_shortName = ''
private

◆ $_urls

$_urls = array()
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OpensearchDocument.php


Joomla CMS: Référence de la classe PreloadManager

  • Joomla
  • CMS
  • Document
  • PreloadManager
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PreloadManager
+ Graphe d'héritage de PreloadManager:
PreloadManagerInterface

Fonctions membres publiques

__construct (EvolvableLinkProviderInterface $linkProvider=null)
getLinkProvider ()
setLinkProvider (EvolvableLinkProviderInterface $linkProvider)
preload (string $uri, array $attributes=[])
dnsPrefetch (string $uri, array $attributes=[])
preconnect (string $uri, array $attributes=[])
prefetch (string $uri, array $attributes=[])
prerender (string $uri, array $attributes=[])

Attributs protégés

$linkProvider

Fonctions membres privées

link (string $uri, string $rel, array $attributes=[])

Description détaillée

Joomla! Preload Manager

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( EvolvableLinkProviderInterface $linkProvider = null )

PreloadManager constructor

Paramètres
EvolvableLinkProviderInterface $linkProvider The link provider
Depuis
4.0.0

Documentation des fonctions membres

◆ dnsPrefetch()

dnsPrefetch | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Resolves a resource origin as early as possible.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $attributes, et $uri.

◆ getLinkProvider()

getLinkProvider ( )

Get the link provider

Renvoie
EvolvableLinkProviderInterface
Depuis
4.0.0

Implémente PreloadManagerInterface.

◆ link()

link | ( | string | $uri,
 |  | string | $rel,
 |  | array | $attributes = []
 | ) |  |
private

Adds a "Link" HTTP header.

Paramètres
string | $uri | The relation URI
string | $rel | The relation type (e.g. "preload", "prefetch", "prerender" or "dns-prefetch")
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Références $attributes, $key, Document\$link, $rel, $uri, $value, et Fig\Link\withLink().

◆ preconnect()

preconnect | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Initiates an early connection to a resource (DNS resolution, TCP handshake, TLS negotiation).

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $attributes, et $uri.

◆ prefetch()

prefetch | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Indicates to the client that it should prefetch this resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $attributes, et $uri.

◆ preload()

preload | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Preloads a resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('crossorigin' => 'use-credentials')")
Renvoie
void
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $attributes, et $uri.

◆ prerender()

prerender | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Indicates to the client that it should prerender this resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $attributes, et $uri.

◆ setLinkProvider()

setLinkProvider ( EvolvableLinkProviderInterface $linkProvider )

Set the link provider

Paramètres
EvolvableLinkProviderInterface $linkProvider The link provider
Renvoie
$this
Depuis
4.0.0

Implémente PreloadManagerInterface.

Références $this.

Documentation des champs

◆ $linkProvider

$linkProvider
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PreloadManager.php


Joomla CMS: Référence de l'interface PreloadManagerInterface

  • Joomla
  • CMS
  • Document
  • PreloadManagerInterface
Fonctions membres publiques
Référence de l'interface PreloadManagerInterface
+ Graphe d'héritage de PreloadManagerInterface:
PreloadManager

Fonctions membres publiques

getLinkProvider ()
setLinkProvider (EvolvableLinkProviderInterface $linkProvider)
preload (string $uri, array $attributes=[])
dnsPrefetch (string $uri, array $attributes=[])
preconnect (string $uri, array $attributes=[])
prefetch (string $uri, array $attributes=[])
prerender (string $uri, array $attributes=[])

Description détaillée

Joomla! Preload Manager Interface

Depuis
4.0.0

Documentation des fonctions membres

◆ dnsPrefetch()

dnsPrefetch | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Resolves a resource origin as early as possible.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ getLinkProvider()

getLinkProvider ( )

Get the link provider

Renvoie
EvolvableLinkProviderInterface
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ preconnect()

preconnect | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Initiates an early connection to a resource (DNS resolution, TCP handshake, TLS negotiation).

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ prefetch()

prefetch | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Indicates to the client that it should prefetch this resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ preload()

preload | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Preloads a resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('crossorigin' => 'use-credentials')")
Renvoie
void
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ prerender()

prerender | ( | string | $uri,
 |  | array | $attributes = []
 | ) |  |

Indicates to the client that it should prerender this resource.

Paramètres
string | $uri | A public path
array | $attributes | The attributes of this link (e.g. "array('as' => true)", "array('pr' => 0.5)")
Renvoie
void
Depuis
4.0.0

Implémenté dans PreloadManager.

◆ setLinkProvider()

setLinkProvider ( EvolvableLinkProviderInterface $linkProvider )

Set the link provider

Paramètres
EvolvableLinkProviderInterface $linkProvider The link provider
Renvoie
$this
Depuis
4.0.0

Implémenté dans PreloadManager.

La documentation de cette interface a été générée à partir du fichier suivant :
  • PreloadManagerInterface.php


Joomla CMS: Référence de la classe RawDocument

  • Joomla
  • CMS
  • Document
  • RawDocument
Fonctions membres publiques
Référence de la classe RawDocument
+ Graphe d'héritage de RawDocument:
Document

Fonctions membres publiques

__construct ($options=array())
render ($cache=false, $params=array())
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

RawDocument class, provides an easy interface to parse and display raw output

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document.

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références $params, et Document\getBuffer().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RawDocument.php


Joomla CMS: Référence de l'interface RendererInterface

  • Joomla
  • CMS
  • Document
  • RendererInterface
Fonctions membres publiques
Référence de l'interface RendererInterface
+ Graphe d'héritage de RendererInterface:
DocumentRenderer AtomRenderer RssRenderer ComponentRenderer HeadRenderer MessageRenderer MetasRenderer ModuleRenderer ModulesRenderer ScriptsRenderer StylesRenderer

Fonctions membres publiques

render ($name, $params=null, $content=null)

Description détaillée

Interface for a document renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render | ( | $name,
 |  | $params = null,
 |  | $content = null
 | ) |

Renders a script and returns the results as a string

Paramètres
string | $name | The name of the element to render
array | $params | Array of values
string | $content | Override the output of the renderer
Renvoie
string The output of the script
Depuis
4.0.0

Implémenté dans AtomRenderer, RssRenderer, ScriptsRenderer, StylesRenderer, ModuleRenderer, ModulesRenderer, MessageRenderer, ComponentRenderer, et HeadRenderer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Document/RendererInterface.php


Joomla CMS: Référence de la classe XmlDocument

  • Joomla
  • CMS
  • Document
  • XmlDocument
Fonctions membres publiques | Attributs protégés
Référence de la classe XmlDocument
+ Graphe d'héritage de XmlDocument:
Document

Fonctions membres publiques

__construct ($options=array())
render ($cache=false, $params=array())
getName ()
setName ($name='joomla')
isDownload ()
setDownload ($download=false)
- Fonctions membres publiques hérités de Document
__construct ($options=array())
setFactory (FactoryInterface $factory)
setType ($type)
getType ()
getBuffer ()
setBuffer ($content, $options=array())
getMetaData ($name, $attribute='name')
setMetaData ($name, $content, $attribute='name')
addScript ($url, $options=array(), $attribs=array())
addScriptDeclaration ($content, $type='text/javascript')
addScriptOptions ($key, $options, $merge=true)
getScriptOptions ($key=null)
addStyleSheet ($url, $options=array(), $attribs=array())
addStyleDeclaration ($content, $type='text/css')
setCharset ($type='utf-8')
getCharset ()
setLanguage ($lang='en-gb')
getLanguage ()
setDirection ($dir='ltr')
getDirection ()
setTitle ($title)
getTitle ()
setMediaVersion ($mediaVersion)
getMediaVersion ()
setPreloadManager (PreloadManagerInterface $preloadManager)
getPreloadManager ()
setWebAssetManager (WebAssetManager $webAsset)
getWebAssetManager ()
setBase ($base)
getBase ()
setDescription ($description)
getDescription ()
setLink ($url)
getLink ()
setGenerator ($generator)
getGenerator ()
setModifiedDate ($date)
getModifiedDate ()
setMimeEncoding ($type='text/html', $sync=true)
getMimeEncoding ()
setLineEnd ($style)
_getLineEnd ()
setTab ($string)
_getTab ()
loadRenderer ($type)
parse ($params=array())
render ($cache=false, $params=array())

Attributs protégés

$name = 'joomla'
$isDownload = false
- Attributs protégés hérités de Document
$scriptOptions = array()
$mediaVersion = null
$factory
$preloadManager = null
$preloadTypes = ['preload', 'dns-prefetch', 'preconnect', 'prefetch', 'prerender']
$webAssetManager = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Document
static | getInstance ($type='html', $attributes=array())
- Champs de données hérités de Document
$title = ''
$description = ''
$link = ''
$base = ''
$language = 'en-gb'
$direction = 'ltr'
$_generator = 'Joomla! - Open Source Content Management'
$_mdate = ''
$_tab = "\11"
$_lineEnd = "\12"
$_charset = 'utf-8'
$_mime = ''
$_namespace = ''
$_profile = ''
$_scripts = array()
$_script = array()
$_styleSheets = array()
$_style = array()
$_metaTags = array()
$_engine = null
$_type = null
- Attributs publics statiques hérités de Document
static | $_buffer = null
- Fonctions membres protégées hérités de Document
preloadAssets ()
- Attributs protégés statiques hérités de Document
static | $instances = array()

Description détaillée

XmlDocument class, provides an easy interface to parse and display XML output

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Associative array of options
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getName()

getName ( )

Returns the document name

Renvoie
string
Depuis
1.7.0

Références $name.

◆ isDownload()

isDownload ( )

Check if this document is intended for download

Renvoie
string
Depuis
3.9.0

◆ render()

render | ( | $cache = false,
 |  | $params = array()
 | ) |

Render the document.

Paramètres
boolean | $cache | If true, cache the output
array | $params | Associative array of attributes
Renvoie
string The rendered data
Depuis
1.7.0

Références $params, et Document\getBuffer().

◆ setDownload()

setDownload ( $download = false )

Sets the document's download state

Paramètres
boolean $download If true, this document will be downloaded; if false, this document will be displayed inline
Renvoie
XmlDocument instance of $this to allow chaining
Depuis
3.9.0

Références $this.

◆ setName()

setName ( $name = 'joomla' )

Sets the document name

Paramètres
string $name Document name
Renvoie
XmlDocument instance of $this to allow chaining
Depuis
1.7.0

Références $name, $this, et name.

Documentation des champs

◆ $isDownload

$isDownload = false
protected

◆ $name

$name = 'joomla'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlDocument.php


Joomla CMS: Référence de la classe Editor

  • Joomla
  • CMS
  • Editor
  • Editor
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Editor
+ Graphe d'héritage de Editor:
DispatcherAwareInterface

Fonctions membres publiques

__construct ($editor='none', DispatcherInterface $dispatcher=null)
initialise ()
display ($name, $html, $width, $height, $col, $row, $buttons=true, $id=null, $asset=null, $author=null, $params=array())
getButtons ($editor, $buttons=true)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static getInstance ($editor='none')

Fonctions membres protégées

_loadEditor ($config=array())

Attributs protégés

$_editor = null
$_name = null
$asset = null
$author = null

Attributs protégés statiques

static $instances = array()

Description détaillée

Editor class to handle WYSIWYG editors

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $editor = 'none',
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |

Constructor

Paramètres
string | $editor | The editor name
DispatcherInterface | $dispatcher | The event dispatcher we're going to use

Références $buttons, $editor, $result, AbstractEvent\getArgument(), Factory\getContainer(), Joomla\CMS\Application\getDispatcher(), null, et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ _loadEditor()

_loadEditor ( $config = array() )
protected

Load the editor

Paramètres
array $config Associative array of editor config parameters
Renvoie
mixed
Depuis
1.5

Références $config, $name, $params, $path, Text\_(), Log\add(), Joomla\CMS\Application\getDispatcher(), InputFilter\getInstance(), PluginHelper\getPlugin(), PluginHelper\importPlugin(), JPATH_PLUGINS, null, et Log\WARNING.

◆ display()

display | ( | $name,
 |  | $html,
 |  | $width,
 |  | $height,
 |  | $col,
 |  | $row,
 |  | $buttons = true,
 |  | $id = null,
 |  | $asset = null,
 |  | $author = null,
 |  | $params = array()
 | ) |

Display the editor area.

Paramètres
string | $name | The control name.
string | $html | The contents of the text area.
string | $width | The width of the text area (px or %).
string | $height | The height of the text area (px or %).
integer | $col | The number of columns for the textarea.
integer | $row | The number of rows for the textarea.
boolean | $buttons | True and the editor buttons will be displayed.
string | $id | An optional ID for the textarea (note: since 1.6). If not supplied the name is used.
string | $asset | The object asset
object | $author | The author.
array | $params | Associative array of editor parameters.
Renvoie
string
Depuis
1.5

Références $author, $buttons, $height, $html, $id, $name, $params, $width, Text\_(), Factory\getApplication(), et null.

◆ getButtons()

getButtons | ( | $editor,
 |  | $buttons = true
 | ) |

Get the editor extended buttons (usually from plugins)

Paramètres
string | $editor | The name of the editor.
mixed | $buttons | Can be boolean or array, if boolean defines if the buttons are displayed, if array defines a list of buttons not to show.
Renvoie
array
Depuis
1.5

Références $button, $buttons, $className, $editor, $result, Joomla\CMS\Application\getDispatcher(), PluginHelper\getPlugin(), et PluginHelper\importPlugin().

◆ getInstance()

static getInstance ( $editor = 'none' )
static

Returns the global Editor object, only creating it if it doesn't already exist.

Paramètres
string $editor The editor to use.
Renvoie
Editor The Editor object.
Depuis
1.5

Références $editor.

Référencé par EditorField\getEditor().

◆ initialise()

initialise ( )

Initialise the editor

Renvoie
void
Depuis
1.5

Références null.

Documentation des champs

◆ $_editor

$_editor = null
protected

◆ $_name

$_name = null
protected

◆ $asset

$asset = null
protected

◆ $author

$author = null
protected

◆ $instances

$instances = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Editor.php


Joomla CMS: Référence de la classe AbstractAES

  • Joomla
  • CMS
  • Encrypt
  • AES
  • AbstractAES
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AbstractAES
+ Graphe d'héritage de AbstractAES:
Mcrypt OpenSSL

Fonctions membres publiques

resizeKey ($key, $size)

Fonctions membres protégées

getZeroPadding ($string, $blockSize)

Description détaillée

Abstract AES encryption class

Depuis
4.0.0

Documentation des fonctions membres

◆ getZeroPadding()

getZeroPadding | ( | $string,
 |  | $blockSize
 | ) |
protected

Returns null bytes to append to the string so that it's zero padded to the specified block size

Paramètres
string | $string | The binary string which will be zero padded
int | $blockSize | The block size
Renvoie
string The zero bytes to append to the string to zero pad it to $blockSize

◆ resizeKey()

resizeKey | ( | $key,
 |  | $size
 | ) |

Trims or zero-pads a key / IV

Paramètres
string | $key | The key or IV to treat
int | $size | The block size of the currently used algorithm
Renvoie
null|string Null if $key is null, treated string of $size byte length otherwise

Références $key, $size, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractAES.php


Joomla CMS: Référence de l'interface AesInterface

  • Joomla
  • CMS
  • Encrypt
  • AES
  • AesInterface
Fonctions membres publiques
Référence de l'interface AesInterface
+ Graphe d'héritage de AesInterface:
Mcrypt OpenSSL

Fonctions membres publiques

setEncryptionMode ($mode='cbc', $strength=128)
encrypt ($plainText, $key, $iv=null)
decrypt ($cipherText, $key)
getBlockSize ()
isSupported ()

Description détaillée

Interface for AES encryption adapters

Depuis
4.0.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( | $cipherText,
 |  | $key
 | ) |

Decrypts a string. Returns the raw binary plaintext.

$ciphertext MUST start with the IV followed by the ciphertext, even for EBC data (the first block of data is dropped in EBC mode since there is no concept of IV in EBC).

WARNING: The returned plaintext is zero-padded to the algorithm's block size during encryption. You are advised to trim the string to the original plaintext's length upon decryption. While rtrim($decrypted, "\0") sounds appealing it's NOT the correct approach for binary data (zero bytes may actually be part of your plaintext, not just padding!).

Paramètres
string | $cipherText | The ciphertext to encrypt
string | $key | The raw binary key (will be zero-padded or chopped if its size is different than the block size)
Renvoie
string The raw unencrypted binary string.

Implémenté dans OpenSSL, et Mcrypt.

◆ encrypt()

encrypt | ( | $plainText,
 |  | $key,
 |  | $iv = null
 | ) |

Encrypts a string. Returns the raw binary ciphertext.

WARNING: The plaintext is zero-padded to the algorithm's block size. You are advised to store the size of the plaintext and trim the string to that length upon decryption.

Paramètres
string | $plainText | The plaintext to encrypt
string | $key | The raw binary key (will be zero-padded or chopped if its size is different than the block size)
null | string | $iv | The initialization vector (for CBC mode algorithms)
Renvoie
string The raw encrypted binary string.

Implémenté dans OpenSSL, et Mcrypt.

◆ getBlockSize()

getBlockSize ( )

Returns the encryption block size in bytes

Renvoie
integer

Implémenté dans OpenSSL, et Mcrypt.

◆ isSupported()

isSupported ( )

Is this adapter supported?

Renvoie
boolean

Implémenté dans OpenSSL, et Mcrypt.

◆ setEncryptionMode()

setEncryptionMode | ( | $mode = 'cbc',
 |  | $strength = 128
 | ) |

Sets the AES encryption mode.

WARNING: The strength is deprecated as it has a different effect in MCrypt and OpenSSL. MCrypt was abandoned in 2003 before the Rijndael-128 algorithm was officially the Advanced Encryption Standard (AES). MCrypt also offered Rijndael-192 and Rijndael-256 algorithms with different block sizes. These are NOT used in AES. OpenSSL, however, implements AES correctly. It always uses a 128-bit (16 byte) block. The 192 and 256 bit strengths refer to the key size, not the block size. Therefore using different strengths in MCrypt and OpenSSL will result in different and incompatible ciphertexts.

TL;DR: Always use $strength = 128!

Paramètres
string | $mode | Choose between CBC (recommended) or ECB
int | $strength | Bit strength of the key (128, 192 or 256 bits). DEPRECATED. READ NOTES ABOVE.
Renvoie
mixed

Implémenté dans OpenSSL, et Mcrypt.

La documentation de cette interface a été générée à partir du fichier suivant :
  • AesInterface.php


Joomla CMS: Référence de la classe Mcrypt

  • Joomla
  • CMS
  • Encrypt
  • AES
  • Mcrypt
Fonctions membres publiques | Attributs protégés
Référence de la classe Mcrypt
+ Graphe d'héritage de Mcrypt:
AbstractAES AesInterface

Fonctions membres publiques

setEncryptionMode ($mode='cbc', $strength=128)
encrypt ($plainText, $key, $iv=null)
decrypt ($cipherText, $key)
isSupported ()
getBlockSize ()
- Fonctions membres publiques hérités de AbstractAES
resizeKey ($key, $size)

Attributs protégés

$cipherType = MCRYPT_RIJNDAEL_128
$cipherMode = MCRYPT_MODE_CBC

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractAES
getZeroPadding ($string, $blockSize)

Description détaillée

Mcrypt implementation

Depuis
4.0.0
Obsolète:
4.0.0 will be removed in 5.0.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( | $cipherText,
 |  | $key
 | ) |

Decrypt encrypted data

Paramètres
string | $cipherText | Encrypted data
string | $key | Encryptionkey
Renvoie
string Plaintext data

Implémente AesInterface.

Références $key.

◆ encrypt()

encrypt | ( | $plainText,
 |  | $key,
 |  | $iv = null
 | ) |

Encrypt the data

Paramètres
string | $plainText | Plaintext data
string | $key | Encryption key
string | $iv | IV for the encryption
Renvoie
string Encrypted data

Implémente AesInterface.

Références $key.

◆ getBlockSize()

getBlockSize ( )

Get the block size

Renvoie
integer

Implémente AesInterface.

◆ isSupported()

isSupported ( )

Is this adapter supported?

Renvoie
boolean

Implémente AesInterface.

◆ setEncryptionMode()

setEncryptionMode | ( | $mode = 'cbc',
 |  | $strength = 128
 | ) |

Set the encryption mode

Paramètres
string | $mode | Encryption Mode
integer | $strength | Encryption Strength
Renvoie
void

Implémente AesInterface.

Références $mode.

Documentation des champs

◆ $cipherMode

$cipherMode = MCRYPT_MODE_CBC
protected

◆ $cipherType

$cipherType = MCRYPT_RIJNDAEL_128
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Mcrypt.php


Joomla CMS: Référence de la classe OpenSSL

  • Joomla
  • CMS
  • Encrypt
  • AES
  • OpenSSL
Fonctions membres publiques | Attributs protégés
Référence de la classe OpenSSL
+ Graphe d'héritage de OpenSSL:
AbstractAES AesInterface

Fonctions membres publiques

__construct ()
setEncryptionMode ($mode='cbc', $strength=128)
encrypt ($plainText, $key, $iv=null)
decrypt ($cipherText, $key)
isSupported ()
getBlockSize ()
- Fonctions membres publiques hérités de AbstractAES
resizeKey ($key, $size)

Attributs protégés

$openSSLOptions = 0
$method = 'aes-128-cbc'

Membres hérités additionnels

- Fonctions membres protégées hérités de AbstractAES
getZeroPadding ($string, $blockSize)

Description détaillée

OpenSSL encryption class

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor for this class

Documentation des fonctions membres

◆ decrypt()

decrypt | ( | $cipherText,
 |  | $key
 | ) |

Decrypts a string. Returns the raw binary plaintext.

$ciphertext MUST start with the IV followed by the ciphertext, even for EBC data (the first block of data is dropped in EBC mode since there is no concept of IV in EBC).

WARNING: The returned plaintext is zero-padded to the algorithm's block size during encryption. You are advised to trim the string to the original plaintext's length upon decryption. While rtrim($decrypted, "\0") sounds appealing it's NOT the correct approach for binary data (zero bytes may actually be part of your plaintext, not just padding!).

Paramètres
string | $cipherText | The ciphertext to encrypt
string | $key | The raw binary key (will be zero-padded or chopped if its size is different than the block size)
Renvoie
string The raw unencrypted binary string.

Implémente AesInterface.

Références $key, et method.

◆ encrypt()

encrypt | ( | $plainText,
 |  | $key,
 |  | $iv = null
 | ) |

Encrypts a string. Returns the raw binary ciphertext.

WARNING: The plaintext is zero-padded to the algorithm's block size. You are advised to store the size of the plaintext and trim the string to that length upon decryption.

Paramètres
string | $plainText | The plaintext to encrypt
string | $key | The raw binary key (will be zero-padded or chopped if its size is different than the block size)
null | string | $iv | The initialization vector (for CBC mode algorithms)
Renvoie
string The raw encrypted binary string.

Implémente AesInterface.

Références $key, et method.

◆ getBlockSize()

getBlockSize ( )

Returns the encryption block size in bytes

Renvoie
integer

Implémente AesInterface.

Références method.

◆ isSupported()

isSupported ( )

Is this adapter supported?

Renvoie
boolean

Implémente AesInterface.

◆ setEncryptionMode()

setEncryptionMode | ( | $mode = 'cbc',
 |  | $strength = 128
 | ) |

Sets the AES encryption mode.

WARNING: The strength is deprecated as it has a different effect in MCrypt and OpenSSL. MCrypt was abandoned in 2003 before the Rijndael-128 algorithm was officially the Advanced Encryption Standard (AES). MCrypt also offered Rijndael-192 and Rijndael-256 algorithms with different block sizes. These are NOT used in AES. OpenSSL, however, implements AES correctly. It always uses a 128-bit (16 byte) block. The 192 and 256 bit strengths refer to the key size, not the block size. Therefore using different strengths in MCrypt and OpenSSL will result in different and incompatible ciphertexts.

TL;DR: Always use $strength = 128!

Paramètres
string | $mode | Choose between CBC (recommended) or ECB
int | $strength | Bit strength of the key (128, 192 or 256 bits). DEPRECATED. READ NOTES ABOVE.
Renvoie
mixed

Implémente AesInterface.

Références $mode, method, et null.

Documentation des champs

◆ $method

$method = 'aes-128-cbc'
protected

◆ $openSSLOptions

$openSSLOptions = 0
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Encrypt/AES/OpenSSL.php


Joomla CMS: Référence de la classe Aes

  • Joomla
  • CMS
  • Encrypt
  • Aes
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe Aes

Fonctions membres publiques

__construct ($key, $strength=128, $mode='cbc', $priority='openssl')
setPassword ($password, $legacyMode=false)
encryptString ($stringToEncrypt, $base64encoded=true)
decryptString ($stringToDecrypt, $base64encoded=true)
getExpandedKey ($blockSize, $iv)

Fonctions membres publiques statiques

static isSupported ()

Attributs protégés

$key = ''
$adapter

Description détaillée

A simple implementation of AES-128, AES-192 and AES-256 encryption using the high performance mcrypt library.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key,
 |  | $strength = 128,
 |  | $mode = 'cbc',
 |  | $priority = 'openssl'
 | ) |

Initialise the AES encryption object.

Note: If the key is not 16 bytes this class will do a stupid key expansion for legacy reasons (produce the SHA-256 of the key string and throw away half of it).

Paramètres
string | $key | The encryption key (password). It can be a raw key (16 bytes) or a passphrase.
int | $strength | Bit strength (128, 192 or 256) – ALWAYS USE 128 BITS. THIS PARAMETER IS DEPRECATED.
string | $mode | Encryption mode. Can be ebc or cbc. We recommend using cbc.
string | $priority | Priority which adapter we should try first
Obsolète:
5.0 $strength will be removed

Références $key, et $mode.

Documentation des fonctions membres

◆ decryptString()

decryptString | ( | $stringToDecrypt,
 |  | $base64encoded = true
 | ) |

Decrypts a ciphertext into a plaintext string using AES

Paramètres
string | $stringToDecrypt | The ciphertext to decrypt. The first 16 bytes of the raw string must contain the IV (initialisation vector).
bool | $base64encoded | Should I Base64-decode the data before decryption?
Renvoie
string The plain text string

Références $key.

◆ encryptString()

encryptString | ( | $stringToEncrypt,
 |  | $base64encoded = true
 | ) |

Encrypts a string using AES

Paramètres
string | $stringToEncrypt | The plaintext to encrypt
bool | $base64encoded | Should I Base64-encode the result?
Renvoie
string The cryptotext. Please note that the first 16 bytes of the raw string is the IV (initialisation vector) which is necessary for decoding the string.

Références $key.

◆ getExpandedKey()

getExpandedKey | ( | $blockSize,
 |  | $iv
 | ) |

Get the expanded key

Paramètres
integer | $blockSize | Blocksize to process
string | $iv | IV
Renvoie
string

Références $key.

◆ isSupported()

static isSupported ( )
static

Is AES encryption supported by this PHP installation?

Renvoie
boolean

◆ setPassword()

setPassword | ( | $password,
 |  | $legacyMode = false
 | ) |

Sets the password for this instance.

WARNING: Do not use the legacy mode, it's insecure

Paramètres
string | $password | The password (either user-provided password or binary encryption key) to use
bool | $legacyMode | True to use the legacy key expansion. We recommend against using it.
Depuis
4.0.0
Renvoie
void

Références $password.

Documentation des champs

◆ $adapter

$adapter
protected

◆ $key

$key = ''
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Aes.php


Joomla CMS: Référence de la classe Base32

  • Joomla
  • CMS
  • Encrypt
  • Base32
Fonctions membres publiques | Champs de données | Fonctions membres privées
Référence de la classe Base32

Fonctions membres publiques

encode ($str)
decode ($str)

Champs de données

const CSRFC3548 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ234567'

Fonctions membres privées

str2bin ($str)
bin2str ($str)
fromBin ($str)
toBin ($str)
_mapcharset ($str)
_mapbin ($chr)

Description détaillée

Base32 encryption class

Depuis
1.0

Documentation des fonctions membres

◆ _mapbin()

_mapbin ( $chr )
private

_mapbin

Used with array_map to map the characters from a base32 character set directly into a binary string

Paramètres
string $chr The character to map
Renvoie
string String of 0's and 1's

private

◆ _mapcharset()

_mapcharset ( $str )
private

_mapcharset

Used with array_map to map the bits from a binary string directly into a base32 character set

Paramètres
string $str The string of 0's and 1's you want to convert
Renvoie
string Resulting base32 character

private

◆ bin2str()

bin2str ( $str )
private

bin2str

Converts a binary string to an ascii string

Paramètres
string $str The string of 0's and 1's you want to convert
Renvoie
string The ascii output
Exceptions

◆ decode()

decode ( $str )

toString

Convert any base32 string to a normal sctring This should be binary safe...

Paramètres
string $str The base32 string to convert
Renvoie
string The normal string

◆ encode()

encode ( $str )

fromString

Convert any string to a base32 string This should be binary safe...

Paramètres
string $str The string to convert
Renvoie
string The converted base32 string

◆ fromBin()

fromBin ( $str )
private

fromBin

Converts a correct binary string to base32

Paramètres
string $str The string of 0's and 1's you want to convert
Renvoie
string String encoded as base32
Exceptions

Références $this.

◆ str2bin()

str2bin ( $str )
private

str2bin

Converts any ascii string to a binary string

Paramètres
string $str The string you want to convert
Renvoie
string String of 0's and 1's

◆ toBin()

toBin ( $str )
private

toBin

Accepts a base32 string and returns an ascii binary string

Paramètres
string $str The base32 string to convert
Renvoie
string Ascii binary string
Exceptions

Références $this.

Documentation des champs

◆ CSRFC3548

const CSRFC3548 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ234567'

CSRFC3548

The character set as defined by RFC3548 http://www.ietf.org/rfc/rfc3548.txt

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Encrypt/Base32.php


Joomla CMS: Référence de la classe Randval

  • Joomla
  • CMS
  • Encrypt
  • Randval
Fonctions membres publiques
Référence de la classe Randval
+ Graphe d'héritage de Randval:
RandValInterface

Fonctions membres publiques

generate ($bytes=32)
- Fonctions membres publiques hérités de RandValInterface
generate ()

Description détaillée

Generates cryptographically-secure random values.

Depuis
4.0.0

Documentation des fonctions membres

◆ generate()

generate ( $bytes = 32 )

Returns a cryptographically secure random value.

This method allows us to quickly address any future issues if we ever find problems with PHP's random_bytes() on some weird host (you can't be too careful when releasing mass-distributed software).

Paramètres
integer $bytes How many bytes to return
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Randval.php


Joomla CMS: Référence de l'interface RandValInterface

  • Joomla
  • CMS
  • Encrypt
  • RandValInterface
Fonctions membres publiques
Référence de l'interface RandValInterface
+ Graphe d'héritage de RandValInterface:
Randval

Fonctions membres publiques

generate ()

Description détaillée

Interface RandValInterface

Depuis
4.0.0

Documentation des fonctions membres

◆ generate()

generate ( )

Returns a cryptographically secure random value.

Renvoie
string
La documentation de cette interface a été générée à partir du fichier suivant :
  • RandValInterface.php


Joomla CMS: Référence de la classe Totp

  • Joomla
  • CMS
  • Encrypt
  • Totp
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe Totp

Fonctions membres publiques

__construct ($timeStep=30, $passCodeLength=6, $secretLength=10, $base32=null)
getPeriod ($time=null)
checkCode ($secret, $code)
getCode ($secret, $time=null)
getUrl ($user, $hostname, $secret)
generateSecret ()

Fonctions membres protégées

hashToInt ($bytes, $start)

Attributs privés

$_passCodeLength = 6
$_pinModulo
$_secretLength = 20
$_timeStep = 30
$_base32 = null

Description détaillée

This class provides an RFC6238-compliant Time-based One Time Passwords, compatible with Google Authenticator (with PassCodeLength = 6 and TimePeriod = 30).

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $timeStep = 30,
 |  | $passCodeLength = 6,
 |  | $secretLength = 10,
 |  | $base32 = null
 | ) |

Initialises an RFC6238-compatible TOTP generator. Please note that this class does not implement the constraint in the last paragraph of §5.2 of RFC6238. It's up to you to ensure that the same user/device does not retry validation within the same Time Step.

Paramètres
int | $timeStep | The Time Step (in seconds). Use 30 to be compatible with Google Authenticator.
int | $passCodeLength | The generated passcode length. Default: 6 digits.
int | $secretLength | The length of the secret key. Default: 10 bytes (80 bits).
Object | $base32 | The base32 en/decrypter

Documentation des fonctions membres

◆ checkCode()

checkCode | ( | $secret,
 |  | $code
 | ) |

Check is the given passcode $code is a valid TOTP generated using secret key $secret

Paramètres
string | $secret | The Base32-encoded secret key
string | $code | The passcode to check
Renvoie
boolean True if the code is valid

Références $i.

◆ generateSecret()

generateSecret ( )

Generates a (semi-)random Secret Key for TOTP generation

Renvoie
string
Note
Since 3.9.25 we use the secure method "random_bytes" over the original insecure "rand" function. The random_bytes function has been backported to outdated PHP versions by the core shipped library paragonie/random_compat

◆ getCode()

getCode | ( | $secret,
 |  | $time = null
 | ) |

Gets the TOTP passcode for a given secret key $secret and a given UNIX timestamp $time

Paramètres
string | $secret | The Base32-encoded secret key
int | $time | UNIX timestamp
Renvoie
string

Références $hash, et Joomla\Database\Query\$offset.

◆ getPeriod()

getPeriod ( $time = null )

Get the time period based on the $time timestamp and the Time Step defined. If $time is skipped or set to null the current timestamp will be used.

Paramètres
int | null $time Timestamp
Renvoie
integer The time period since the UNIX Epoch

◆ getUrl()

getUrl | ( | $user,
 |  | $hostname,
 |  | $secret
 | ) |

Returns a QR code URL for easy setup of TOTP apps like Google Authenticator

Paramètres
string | $user | User
string | $hostname | Hostname
string | $secret | Secret string
Renvoie
string

Références $url, et $user.

◆ hashToInt()

hashToInt | ( | $bytes,
 |  | $start
 | ) |
protected

Extracts a part of a hash as an integer

Paramètres
string | $bytes | The hash
string | $start | The char to start from (0 = first char)
Renvoie
string

Références $input, et $start.

Documentation des champs

◆ $_base32

$_base32 = null
private

◆ $_passCodeLength

$_passCodeLength = 6
private

◆ $_pinModulo

$_pinModulo
private

◆ $_secretLength

$_secretLength = 20
private

◆ $_timeStep

$_timeStep = 30
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Encrypt/Totp.php


Joomla CMS: Référence de la classe Browser

  • Joomla
  • CMS
  • Environment
  • Browser
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Browser

Fonctions membres publiques

__construct ($userAgent=null, $accept=null)
match ($userAgent=null, $accept=null)
getPlatform ()
setBrowser ($browser)
getBrowser ()
getMajor ()
getMinor ()
getVersion ()
getAgentString ()
getHTTPProtocol ()
isViewable ($mimetype)
isBrowser ($browser)
isRobot ()
isMobile ()

Fonctions membres publiques statiques

static getInstance ($userAgent=null, $accept=null)

Fonctions membres protégées

_setPlatform ()
identifyBrowserVersion ()

Attributs protégés

$majorVersion = 0
$minorVersion = 0
$browser = ''
$agent = ''
$lowerAgent = ''
$accept = ''
$acceptParsed = array()
$platform = ''
$robots
$mobile = false
$images = array('jpeg', 'gif', 'png', 'pjpeg', 'x-png', 'bmp')

Attributs protégés statiques

static $instances = array()

Description détaillée

Browser class, provides capability information about the current web client.

Browser identification is performed by examining the HTTP_USER_AGENT environment variable provided by the web server.

This class has many influences from the lib/Browser.php code in version 3 of Horde by Chuck Hagenbuch and Jon Parise.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $userAgent = null,
 |  | $accept = null
 | ) |

Create a browser instance (constructor).

Paramètres
string | $userAgent | The browser string to parse.
string | $accept | The HTTP_ACCEPT settings to use.
Depuis
1.7.0

Documentation des fonctions membres

◆ _setPlatform()

_setPlatform ( )
protected

Match the platform of the browser.

This is a pretty simplistic implementation, but it's intended to let us tell what line breaks to send, so it's good enough for its purpose.

Renvoie
void
Depuis
1.7.0

Références elseif.

◆ getAgentString()

getAgentString ( )

Return the full browser agent string.

Renvoie
string The browser agent string
Depuis
1.7.0

◆ getBrowser()

getBrowser ( )

Retrieve the current browser.

Renvoie
string The current browser.
Depuis
1.7.0

◆ getHTTPProtocol()

getHTTPProtocol ( )

Returns the server protocol in use on the current server.

Renvoie
string The HTTP server protocol version.
Depuis
1.7.0

◆ getInstance()

static getInstance | ( | $userAgent = null,
 |  | $accept = null
 | ) |
static

Returns the global Browser object, only creating it if it doesn't already exist.

Paramètres
string | $userAgent | The browser string to parse.
string | $accept | The HTTP_ACCEPT settings to use.
Renvoie
Browser The Browser object.
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par BannersHelper\getList(), et HTMLHelper\includeRelativeFiles().

◆ getMajor()

getMajor ( )

Retrieve the current browser's major version.

Renvoie
integer The current browser's major version
Depuis
1.7.0

◆ getMinor()

getMinor ( )

Retrieve the current browser's minor version.

Renvoie
integer The current browser's minor version.
Depuis
1.7.0

Références $minorVersion.

◆ getPlatform()

getPlatform ( )

Return the currently matched platform.

Renvoie
string The user's platform.
Depuis
1.7.0

◆ getVersion()

getVersion ( )

Retrieve the current browser's version.

Renvoie
string The current browser's version.
Depuis
1.7.0

Références $minorVersion.

◆ identifyBrowserVersion()

identifyBrowserVersion ( )
protected

Set browser version, not by engine version Fallback to use when no other method identify the engine version

Renvoie
void
Depuis
1.7.0

Références $version.

◆ isBrowser()

isBrowser ( $browser )

Determine if the given browser is the same as the current.

Paramètres
string $browser The browser to check.
Renvoie
boolean Is the given browser the same as the current?
Depuis
1.7.0

◆ isMobile()

isMobile ( )

Determines if the browser is mobile version or not.

Renvoie
boolean True if browser is a known mobile version.
Depuis
1.7.0

◆ isRobot()

isRobot ( )

Determines if the browser is a robot or not.

Renvoie
boolean True if browser is a known robot.
Depuis
1.7.0

◆ isViewable()

isViewable ( $mimetype )

Determines if a browser can display a given MIME type.

Note that image/jpeg and image/pjpeg appear to be the same entity, but Mozilla doesn't seem to want to accept the latter. For our purposes, we will treat them the same.

Paramètres
string $mimetype The MIME type to check.
Renvoie
boolean True if the browser can display the MIME type.
Depuis
1.7.0

Références $type.

◆ match()

match | ( | $userAgent = null,
 |  | $accept = null
 | ) |

Parses the user agent string and inititializes the object with all the known features and quirks for the given browser.

Paramètres
string | $userAgent | The browser string to parse.
string | $accept | The HTTP_ACCEPT settings to use.
Renvoie
void
Depuis
1.7.0

We have to check for Edge as the first browser, because Edge has something like: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3738.0 Safari/537.36 Edg/75.0.107.0

Références $version, et elseif.

◆ setBrowser()

setBrowser ( $browser )

Sets the current browser.

Paramètres
string $browser The browser to set as current.
Renvoie
void
Depuis
1.7.0

Documentation des champs

◆ $accept

$accept = ''
protected

◆ $acceptParsed

$acceptParsed = array()
protected

◆ $agent

$agent = ''
protected

◆ $browser

$browser = ''
protected

◆ $images

$images = array('jpeg', 'gif', 'png', 'pjpeg', 'x-png', 'bmp')
protected

◆ $instances

$instances = array()
staticprotected

◆ $lowerAgent

$lowerAgent = ''
protected

◆ $majorVersion

$majorVersion = 0
protected

◆ $minorVersion

$minorVersion = 0
protected

◆ $mobile

$mobile = false
protected

◆ $platform

$platform = ''
protected

◆ $robots

$robots
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Browser.php


Joomla CMS: Référence de la classe AuthenticationFailedExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • AuthenticationFailedExceptionHandler
Fonctions membres publiques
Référence de la classe AuthenticationFailedExceptionHandler
+ Graphe d'héritage de AuthenticationFailedExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for permission errors that should give a 401

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationFailedExceptionHandler.php


Joomla CMS: Référence de la classe CheckinCheckoutExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • CheckinCheckoutExceptionHandler
Fonctions membres publiques
Référence de la classe CheckinCheckoutExceptionHandler
+ Graphe d'héritage de CheckinCheckoutExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for invalid checkin/checkout exceptions

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckinCheckoutExceptionHandler.php


Joomla CMS: Référence de la classe InvalidParameterExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • InvalidParameterExceptionHandler
Fonctions membres publiques
Référence de la classe InvalidParameterExceptionHandler
+ Graphe d'héritage de InvalidParameterExceptionHandler:
InvalidParameterExceptionHandler ExceptionHandlerInterface

Fonctions membres publiques

handle (Exception $e)
- Fonctions membres publiques hérités de InvalidParameterExceptionHandler
manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for invalid param

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Error/JsonApi/InvalidParameterExceptionHandler.php


Joomla CMS: Référence de la classe InvalidRouteExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • InvalidRouteExceptionHandler
Fonctions membres publiques
Référence de la classe InvalidRouteExceptionHandler
+ Graphe d'héritage de InvalidRouteExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for routing errors that should give a 404

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidRouteExceptionHandler.php


Joomla CMS: Référence de la classe NotAcceptableExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • NotAcceptableExceptionHandler
Fonctions membres publiques
Référence de la classe NotAcceptableExceptionHandler
+ Graphe d'héritage de NotAcceptableExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for routing errors that should give a 406

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NotAcceptableExceptionHandler.php


Joomla CMS: Référence de la classe NotAllowedExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • NotAllowedExceptionHandler
Fonctions membres publiques
Référence de la classe NotAllowedExceptionHandler
+ Graphe d'héritage de NotAllowedExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for permission errors that should give a 403

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NotAllowedExceptionHandler.php


Joomla CMS: Référence de la classe ResourceNotFoundExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • ResourceNotFoundExceptionHandler
Fonctions membres publiques
Référence de la classe ResourceNotFoundExceptionHandler
+ Graphe d'héritage de ResourceNotFoundExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for invalid resource requests that should give a 404

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ResourceNotFoundExceptionHandler.php


Joomla CMS: Référence de la classe SaveExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • SaveExceptionHandler
Fonctions membres publiques
Référence de la classe SaveExceptionHandler
+ Graphe d'héritage de SaveExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for invalid checkin/checkout exceptions

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SaveExceptionHandler.php


Joomla CMS: Référence de la classe SendEmailExceptionHandler

  • Joomla
  • CMS
  • Error
  • JsonApi
  • SendEmailExceptionHandler
Fonctions membres publiques
Référence de la classe SendEmailExceptionHandler
+ Graphe d'héritage de SendEmailExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Description détaillée

Handler for error when send email

Depuis
4.0.0

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
Exception $e The exception being handled
Renvoie
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e The exception to be handled
Renvoie
boolean
Depuis
4.0.0

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SendEmailExceptionHandler.php


Joomla CMS: Référence de la classe CliRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • CliRenderer
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe CliRenderer
+ Graphe d'héritage de CliRenderer:
AbstractRenderer RendererInterface

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'cli'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Fonctions membres privées

getTrace (\Throwable $error)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

Cli error renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ getTrace()

getTrace ( \Throwable $error )
private

Returns a trace for the given error.

Paramètres
\Throwable $error The error
Renvoie
string
Depuis
4.0.0

Références JDEBUG.

◆ render()

render ( \Throwable $error )

Render the error for the given object.

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Références $buffer.

Documentation des champs

◆ $type

$type = 'cli'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CliRenderer.php


Joomla CMS: Référence de la classe FeedRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • FeedRenderer
Référence de la classe FeedRenderer
+ Graphe d'héritage de FeedRenderer:
XmlRenderer AbstractRenderer RendererInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de XmlRenderer
render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()
- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()
- Attributs protégés hérités de XmlRenderer
$type = 'xml'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Description détaillée

RSS/Atom feed error page renderer

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedRenderer.php


Joomla CMS: Référence de la classe HtmlRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • HtmlRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlRenderer
+ Graphe d'héritage de HtmlRenderer:
AbstractRenderer RendererInterface

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'error'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

HTML error page renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Références $app, $template, $wa, Text\_(), Factory\getApplication(), JDEBUG, et JPATH_THEMES.

Documentation des champs

◆ $type

$type = 'error'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlRenderer.php


Joomla CMS: Référence de la classe JsonapiRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • JsonapiRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonapiRenderer
+ Graphe d'héritage de JsonapiRenderer:
JsonRenderer AbstractRenderer RendererInterface

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de JsonRenderer
render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'jsonapi'
- Attributs protégés hérités de JsonRenderer
$type = 'json'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

JSON error page renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Références $app, Factory\getApplication(), et JDEBUG.

Documentation des champs

◆ $type

$type = 'jsonapi'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonapiRenderer.php


Joomla CMS: Référence de la classe JsonRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • JsonRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonRenderer
+ Graphe d'héritage de JsonRenderer:
AbstractRenderer RendererInterface JsonapiRenderer

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'json'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

JSON error page renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Références $app, $data, Factory\getApplication(), et JDEBUG.

Documentation des champs

◆ $type

$type = 'json'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Error/Renderer/JsonRenderer.php


Joomla CMS: Référence de la classe XmlRenderer

  • Joomla
  • CMS
  • Error
  • Renderer
  • XmlRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe XmlRenderer
+ Graphe d'héritage de XmlRenderer:
AbstractRenderer RendererInterface FeedRenderer

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'xml'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

XML error page renderer

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Références JDEBUG.

Documentation des champs

◆ $type

$type = 'xml'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlRenderer.php


Joomla CMS: Référence de la classe AbstractRenderer

  • Joomla
  • CMS
  • Error
  • AbstractRenderer
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractRenderer
+ Graphe d'héritage de AbstractRenderer:
RendererInterface CliRenderer HtmlRenderer JsonRenderer XmlRenderer JsonRenderer JsonapiRenderer FeedRenderer

Fonctions membres publiques

getDocument ()
- Fonctions membres publiques hérités de RendererInterface
render (\Throwable $error)

Fonctions membres publiques statiques

static getRenderer (string $type)

Fonctions membres protégées

loadDocument ()

Attributs protégés

$document
$type

Description détaillée

Base class for error page renderers

Depuis
4.0.0

Documentation des fonctions membres

◆ getDocument()

getDocument ( )

Retrieve the Document instance attached to this renderer

Renvoie
Document
Depuis
4.0.0

Implémente RendererInterface.

Références $document.

◆ getRenderer()

static getRenderer ( string $type )
static

Get a renderer instance for the given type

Paramètres
string $type The type of renderer to fetch
Renvoie
static
Depuis
4.0.0
Exceptions

Références $class, $type, Factory\getContainer(), et Symfony\Contracts\Service\has().

◆ loadDocument()

loadDocument ( )
protected

Create the Document object for this renderer

Renvoie
Document
Depuis
4.0.0

Références $attributes, Factory\$language, class, Factory\getContainer(), et Factory\getLanguage().

Documentation des champs

◆ $document

$document
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractRenderer.php


Joomla CMS: Référence de l'interface RendererInterface

  • Joomla
  • CMS
  • Error
  • RendererInterface
Fonctions membres publiques
Référence de l'interface RendererInterface
+ Graphe d'héritage de RendererInterface:
AbstractRenderer CliRenderer HtmlRenderer JsonRenderer XmlRenderer JsonRenderer JsonapiRenderer FeedRenderer

Fonctions membres publiques

getDocument ()
render (\Throwable $error)

Description détaillée

Interface defining the rendering engine for the error handling layer

Depuis
4.0.0

Documentation des fonctions membres

◆ getDocument()

getDocument ( )

Retrieve the Document instance attached to this renderer

Renvoie
Document
Depuis
4.0.0

Implémenté dans AbstractRenderer.

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémenté dans JsonapiRenderer, HtmlRenderer, JsonRenderer, JsonRenderer, CliRenderer, et XmlRenderer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Error/RendererInterface.php


Joomla CMS: Référence de la classe BeforeBatchEvent

  • Joomla
  • CMS
  • Event
  • Model
  • BeforeBatchEvent
Fonctions membres publiques
Référence de la classe BeforeBatchEvent
+ Graphe d'héritage de BeforeBatchEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for modifying a table object before a batch event is applied

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeBatchEvent.php


Joomla CMS: Référence de la classe BeforeDisplayMethods

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • BeforeDisplayMethods
Fonctions membres publiques
Référence de la classe BeforeDisplayMethods
+ Graphe d'héritage de BeforeDisplayMethods:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (User $user)
setUser (User $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorBeforeDisplayMethods event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( User $user )

Public constructor

Paramètres
User $user The user the MFA methods are displayed for
Depuis
4.2.0

Références $user, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setUser()

setUser ( User $value )

Validate the value of the 'user' named parameter

Paramètres
User $value The value to validate
Renvoie
User
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeDisplayMethods.php


Joomla CMS: Référence de la classe Callback

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • Callback
Fonctions membres publiques
Référence de la classe Callback
+ Graphe d'héritage de Callback:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $method)
setMethod (string $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorCallback event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $method )

Public constructor

Paramètres
string $method The MFA method name
Depuis
4.2.0

Références $method, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setMethod()

setMethod ( string $value )

Validate the value of the 'method' named parameter

Paramètres
string | null $value The value to validate
Renvoie
string
Exceptions
DomainException
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Callback.php


Joomla CMS: Référence de la classe Captive

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • Captive
Fonctions membres publiques
Référence de la classe Captive
+ Graphe d'héritage de Captive:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (MfaTable $record)
setRecord (MfaTable $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorCaptive event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( MfaTable $record )

Public constructor

Paramètres
MfaTable $record The MFA record to use in the captive login page
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et class.

Documentation des fonctions membres

◆ setRecord()

setRecord ( MfaTable $value )

Validate the value of the 'record' named parameter

Paramètres
MfaTable $value The value to validate
Renvoie
MfaTable
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Captive.php


Joomla CMS: Référence de la classe GetMethod

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • GetMethod
Fonctions membres publiques
Référence de la classe GetMethod
+ Graphe d'héritage de GetMethod:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorGetMethod event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Public constructor

Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GetMethod.php


Joomla CMS: Référence de la classe GetSetup

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • GetSetup
Fonctions membres publiques
Référence de la classe GetSetup
+ Graphe d'héritage de GetSetup:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (MfaTable $record)
setRecord (MfaTable $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorGetSetup event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( MfaTable $record )

Public constructor

Paramètres
MfaTable $record The record to display the setup page for
Depuis
4.2.0

Références Symfony\Contracts\Service\__construct(), et class.

Documentation des fonctions membres

◆ setRecord()

setRecord ( MfaTable $value )

Validate the value of the 'record' named parameter

Paramètres
MfaTable $value The value to validate
Renvoie
MfaTable
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GetSetup.php


Joomla CMS: Référence de la classe NotifyActionLog

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • NotifyActionLog
Fonctions membres publiques | Attributs privés
Référence de la classe NotifyActionLog
+ Graphe d'héritage de NotifyActionLog:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

const ACCEPTABLE_EVENTS

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the custom events used to notify the User Action Log plugin about Two Factor Authentication actions.

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $arguments = []
 | ) |  |

Public constructor

Paramètres
string | $name | Event name. Must belong in self::ACCEPTABLE_EVENTS
array | $arguments | Event arguments (different for each event).
Depuis
4.2.0

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ ACCEPTABLE_EVENTS

const ACCEPTABLE_EVENTS
private
Valeur initiale :
= [
'onComUsersCaptiveValidateSuccess',
'onComUsersViewMethodsAfterDisplay',
'onComUsersCaptiveShowCaptive',
'onComUsersCaptiveShowSelect',
'onComUsersCaptiveValidateFailed',
'onComUsersCaptiveValidateInvalidMethod',
'onComUsersCaptiveValidateSuccess',
'onComUsersControllerMethodAfterRegenerateBackupCodes',
'onComUsersControllerMethodBeforeAdd',
'onComUsersControllerMethodBeforeDelete',
'onComUsersControllerMethodBeforeEdit',
'onComUsersControllerMethodBeforeSave',
'onComUsersControllerMethodsBeforeDisable',
'onComUsersControllerMethodsBeforeDoNotShowThisAgain',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotifyActionLog.php


Joomla CMS: Référence de la classe SaveSetup

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • SaveSetup
Fonctions membres publiques
Référence de la classe SaveSetup
+ Graphe d'héritage de SaveSetup:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (MfaTable $record, Input $input)
setRecord (MfaTable $value)
setInput (Input $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorSaveSetup event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | MfaTable | $record,
 |  | Input | $input
 | ) |  |

Public constructor

Paramètres
MfaTable | $record | The record to save into
Input | $input | The application input object
Depuis
4.2.0

Références $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setInput()

setInput ( Input $value )

Validate the value of the 'record' named parameter

Paramètres
Input $value The value to validate
Renvoie
Input
Depuis
4.2.0

Références $value, et name.

◆ setRecord()

setRecord ( MfaTable $value )

Validate the value of the 'record' named parameter

Paramètres
MfaTable $value The value to validate
Renvoie
MfaTable
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SaveSetup.php


Joomla CMS: Référence de la classe Validate

  • Joomla
  • CMS
  • Event
  • MultiFactor
  • Validate
Fonctions membres publiques
Référence de la classe Validate
+ Graphe d'héritage de Validate:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (MfaTable $record, User $user, string $code)
setRecord (MfaTable $value)
setUser (User $value)
setCode (?string $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete Event class for the onUserMultifactorValidate event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | MfaTable | $record,
 |  | User | $user,
 |  | string | $code
 | ) |  |

Public constructor

Paramètres
MfaTable | $record | The MFA record to validate against
User | $user | The user currently logged into the site
string | $code | The MFA code we are validating
Depuis
4.2.0

Références $user, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setCode()

setCode ( ?string $value )

Validate the value of the 'code' named parameter

Paramètres
string | null $value The value to validate
Renvoie
string|null
Depuis
4.2.0

Références $value.

◆ setRecord()

setRecord ( MfaTable $value )

Validate the value of the 'record' named parameter

Paramètres
MfaTable $value The value to validate
Renvoie
MfaTable
Depuis
4.2.0

Références $value, et name.

◆ setUser()

setUser ( User $value )

Validate the value of the 'user' named parameter

Paramètres
User $value The value to validate
Renvoie
User
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Validate.php


Joomla CMS: Référence de la classe Ajax

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • Ajax
Référence de la classe Ajax
+ Graphe d'héritage de Ajax:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthn event

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Ajax.php


Joomla CMS: Référence de la classe AjaxChallenge

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxChallenge
Fonctions membres publiques
Référence de la classe AjaxChallenge
+ Graphe d'héritage de AjaxChallenge:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

typeCheckResult ($data)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnChallenge event

Depuis
4.2.0

Documentation des fonctions membres

◆ typeCheckResult()

typeCheckResult ( $data )

Make sure the result is valid JSON or boolean false

Paramètres
mixed $data The data to check
Renvoie
void
Depuis
4.2.0

Implémente ResultAwareInterface.

Références $data, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxChallenge.php


Joomla CMS: Référence de la classe AjaxCreate

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxCreate
Référence de la classe AjaxCreate
+ Graphe d'héritage de AjaxCreate:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnCreate event

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxCreate.php


Joomla CMS: Référence de la classe AjaxDelete

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxDelete
Référence de la classe AjaxDelete
+ Graphe d'héritage de AjaxDelete:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnDelete event

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxDelete.php


Joomla CMS: Référence de la classe AjaxInitCreate

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxInitCreate
Fonctions membres publiques
Référence de la classe AjaxInitCreate
+ Graphe d'héritage de AjaxInitCreate:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnInitcreate event

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor

Paramètres
string | $name | Event name
array | $arguments | Event arguments
Depuis
4.2.0

Références $name, Symfony\Contracts\Service\__construct(), et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxInitCreate.php


Joomla CMS: Référence de la classe AjaxLogin

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxLogin
Référence de la classe AjaxLogin
+ Graphe d'héritage de AjaxLogin:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnLogin event

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxLogin.php


Joomla CMS: Référence de la classe AjaxSaveLabel

  • Joomla
  • CMS
  • Event
  • Plugin
  • System
  • Webauthn
  • AjaxSaveLabel
Référence de la classe AjaxSaveLabel
+ Graphe d'héritage de AjaxSaveLabel:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Concrete event class for the onAjaxWebauthnSavelabel event

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AjaxSaveLabel.php


Joomla CMS: Référence de la classe GetIconEvent

  • Joomla
  • CMS
  • Event
  • QuickIcon
  • GetIconEvent
Fonctions membres publiques
Référence de la classe GetIconEvent
+ Graphe d'héritage de GetIconEvent:
AbstractImmutableEvent ResultAwareInterface AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $name, array $arguments=[])
setContext (string $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques hérités de ResultAwareInterface
addResult ($data)
typeCheckResult ($data)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for the onGetIcon event.

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.2.0
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setContext()

setContext ( string $value )

A method to validate the 'context' named parameter.

Paramètres
string $value The calling context for retrieving icons.
Renvoie
void
Depuis
4.2.0

Références $value, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GetIconEvent.php


Joomla CMS: Référence de l'interface ResultAwareInterface

  • Joomla
  • CMS
  • Event
  • Result
  • ResultAwareInterface
Fonctions membres publiques
Référence de l'interface ResultAwareInterface
+ Graphe d'héritage de ResultAwareInterface:
Captive GetMethod GetSetup SaveSetup Validate AjaxChallenge AjaxCreate AjaxDelete AjaxInitCreate AjaxSaveLabel GetIconEvent

Fonctions membres publiques

addResult ($data)
typeCheckResult ($data)

Description détaillée

Defines an Event which has an append-only array argument named 'result'.

This is used for Events whose handlers are expected to return something when called, similar to how many plugin events worked in earlier versions of Joomla.

This interface is partially implemented by the ResultAware trait. The typeCheckResult method is implemented by the various ResultType*Aware traits. Your event needs to use both the ResultAware trait and one of the ResultType*Aware traits. For example, if your event returns boolean results you need to use the ResultAware and ResultTypeBooleanAware traits in your event.

Depuis
4.2.0

Documentation des fonctions membres

◆ addResult()

addResult ( $data )

Appends data to the result array of the event.

Paramètres
mixed $data What to add to the result array.
Renvoie
void
Depuis
4.2.0

Référencé par Webauthn\onUserMultifactorGetMethod(), Totp\onUserMultifactorGetMethod(), Yubikey\onUserMultifactorGetMethod(), Fixed\onUserMultifactorGetMethod(), et Email\onUserMultifactorGetMethod().

◆ typeCheckResult()

typeCheckResult ( $data )

Checks the type of the data being appended to the result argument.

Paramètres
mixed $data The data to type check
Renvoie
void
Exceptions
InvalidArgumentException

Implémenté dans AjaxChallenge.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ResultAwareInterface.php


Joomla CMS: Référence de la classe AbstractEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AbstractEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AbstractEvent
+ Graphe d'héritage de AbstractEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface AfterDeleteEvent AfterLoadEvent AfterMoveEvent AfterReorderEvent AfterResetEvent AfterStoreEvent BeforeBindEvent BeforeCheckinEvent BeforeCheckoutEvent BeforeDeleteEvent BeforeLoadEvent BeforeMoveEvent BeforePublishEvent BeforeReorderEvent BeforeResetEvent BeforeStoreEvent CheckEvent ObjectCreateEvent SetNewTagsEvent

Fonctions membres publiques

__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for the Table's events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = []
 | ) |  |
Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
1.0

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setSubject()

setSubject ( $value )
protected

Setter for the subject argument

Paramètres
TableInterface $value The value to set
Renvoie
TableInterface
Exceptions
BadMethodCallException If the argument is not of the expected type.

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Event/Table/AbstractEvent.php


Joomla CMS: Référence de la classe AfterBindEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterBindEvent
Référence de la classe AfterBindEvent
+ Graphe d'héritage de AfterBindEvent:
BeforeBindEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforeBindEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de BeforeBindEvent
setSrc ($value)
setIgnore ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterBind event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterBindEvent.php


Joomla CMS: Référence de la classe AfterCheckinEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterCheckinEvent
Référence de la classe AfterCheckinEvent
+ Graphe d'héritage de AfterCheckinEvent:
BeforeCheckinEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforeCheckinEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterCheckin event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterCheckinEvent.php


Joomla CMS: Référence de la classe AfterCheckoutEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterCheckoutEvent
Référence de la classe AfterCheckoutEvent
+ Graphe d'héritage de AfterCheckoutEvent:
BeforeCheckoutEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforeCheckoutEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de BeforeCheckoutEvent
setUserId ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterCheckout event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterCheckoutEvent.php


Joomla CMS: Référence de la classe AfterDeleteEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterDeleteEvent
Fonctions membres publiques
Référence de la classe AfterDeleteEvent
+ Graphe d'héritage de AfterDeleteEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterDelete event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on pk The optional primary key value we deleted.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterDeleteEvent.php


Joomla CMS: Référence de la classe AfterHitEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterHitEvent
Référence de la classe AfterHitEvent
+ Graphe d'héritage de AfterHitEvent:
BeforeCheckinEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforeCheckinEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterHit event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterHitEvent.php


Joomla CMS: Référence de la classe AfterLoadEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterLoadEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AfterLoadEvent
+ Graphe d'héritage de AfterLoadEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setResult ($value)
setRow ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterLoad event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on result boolean Did the table record load succeed? row null|array The values loaded from the database, null if it failed

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setResult()

setResult ( $value )
protected

Setter for the result argument

Paramètres
boolean $value The value to set
Renvoie
boolean
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value, et true.

◆ setRow()

setRow ( $value )
protected

Setter for the row argument

Paramètres
array | null $value The value to set
Renvoie
array|null
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterLoadEvent.php


Joomla CMS: Référence de la classe AfterMoveEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterMoveEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AfterMoveEvent
+ Graphe d'héritage de AfterMoveEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setRow ($value)
setDelta ($value)
setWhere ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterMove event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on row stdClass|null The primary keys and ordering value for the selection. delta int The direction and magnitude to move the row in the ordering sequence. where string WHERE clause which was used for limiting the selection of rows to compact the ordering values.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setDelta()

setDelta ( $value )
protected

Setter for the delta argument

Paramètres
int $value The value to set
Renvoie
integer
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setRow()

setRow ( $value )
protected

Setter for the rows argument

Paramètres
stdClass | null $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setWhere()

setWhere ( $value )
protected

Setter for the where argument

Paramètres
string | null $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterMoveEvent.php


Joomla CMS: Référence de la classe AfterPublishEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterPublishEvent
Référence de la classe AfterPublishEvent
+ Graphe d'héritage de AfterPublishEvent:
BeforePublishEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforePublishEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de BeforePublishEvent
setQuery ($value)
setState ($value)
setUserId ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterPublish event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterPublishEvent.php


Joomla CMS: Référence de la classe AfterReorderEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterReorderEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AfterReorderEvent
+ Graphe d'héritage de AfterReorderEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setWhere ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterReorder event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on rows stdClass[]|null The primary keys and ordering values for the selection. where string WHERE clause which was used for limiting the selection of rows to compact the ordering values.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setWhere()

setWhere ( $value )
protected

Setter for the where argument

Paramètres
array | string | null $value A string or array of where conditions.
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterReorderEvent.php


Joomla CMS: Référence de la classe AfterResetEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterResetEvent
Référence de la classe AfterResetEvent
+ Graphe d'héritage de AfterResetEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterReset event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterResetEvent.php


Joomla CMS: Référence de la classe AfterStoreEvent

  • Joomla
  • CMS
  • Event
  • Table
  • AfterStoreEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AfterStoreEvent
+ Graphe d'héritage de AfterStoreEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setResult ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onAfterStore event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on result boolean Did the save succeed?

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setResult()

setResult ( $value )
protected

Setter for the result argument

Paramètres
boolean $value The value to set
Renvoie
boolean
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterStoreEvent.php


Joomla CMS: Référence de la classe BeforeBindEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeBindEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeBindEvent
+ Graphe d'héritage de BeforeBindEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface AfterBindEvent

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setSrc ($value)
setIgnore ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeBind event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on src mixed An associative array or object to bind to the JTable instance. ignore mixed An optional array or space separated list of properties to ignore while binding.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setIgnore()

setIgnore ( $value )
protected

Setter for the ignore argument

Paramètres
mixed $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setSrc()

setSrc ( $value )
protected

Setter for the src argument

Paramètres
mixed $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeBindEvent.php


Joomla CMS: Référence de la classe BeforeCheckinEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeCheckinEvent
Fonctions membres publiques
Référence de la classe BeforeCheckinEvent
+ Graphe d'héritage de BeforeCheckinEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface AfterCheckinEvent AfterHitEvent BeforeHitEvent

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeCheckin event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on pk mixed An optional primary key value to check out.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeCheckinEvent.php


Joomla CMS: Référence de la classe BeforeCheckoutEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeCheckoutEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeCheckoutEvent
+ Graphe d'héritage de BeforeCheckoutEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface AfterCheckoutEvent

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setUserId ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeCheckout event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on userId integer The Id of the user checking out the row. pk mixed An optional primary key value to check out.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setUserId()

setUserId ( $value )
protected

Setter for the userId argument

Paramètres
mixed $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeCheckoutEvent.php


Joomla CMS: Référence de la classe BeforeDeleteEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeDeleteEvent
Fonctions membres publiques
Référence de la classe BeforeDeleteEvent
+ Graphe d'héritage de BeforeDeleteEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeDelete event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on pk An optional primary key value to delete.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeDeleteEvent.php


Joomla CMS: Référence de la classe BeforeHitEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeHitEvent
Référence de la classe BeforeHitEvent
+ Graphe d'héritage de BeforeHitEvent:
BeforeCheckinEvent AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BeforeCheckinEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeHit event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeHitEvent.php


Joomla CMS: Référence de la classe BeforeLoadEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeLoadEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeLoadEvent
+ Graphe d'héritage de BeforeLoadEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setReset ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeLoad event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on keys mixed The optional primary key value to load the row by, or an array of fields to match. reset boolean True to reset the default values before loading the new row.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setReset()

setReset ( $value )
protected

Setter for the reset attribute

Paramètres
mixed $value The value to set
Renvoie
boolean Normalised value

Références $value, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeLoadEvent.php


Joomla CMS: Référence de la classe BeforeMoveEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeMoveEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeMoveEvent
+ Graphe d'héritage de BeforeMoveEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setQuery ($value)
setDelta ($value)
setWhere ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeMove event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on query DatabaseQuery The query to get the primary keys and ordering values for the selection. delta int The direction and magnitude to move the row in the ordering sequence. where string WHERE clause to use for limiting the selection of rows to compact the ordering values.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setDelta()

setDelta ( $value )
protected

Setter for the delta argument

Paramètres
int $value The value to set
Renvoie
integer
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setQuery()

setQuery ( $value )
protected

Setter for the query argument

Paramètres
DatabaseQuery $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setWhere()

setWhere ( $value )
protected

Setter for the where argument

Paramètres
string | null $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeMoveEvent.php


Joomla CMS: Référence de la classe BeforePublishEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforePublishEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforePublishEvent
+ Graphe d'héritage de BeforePublishEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface AfterPublishEvent

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setQuery ($value)
setState ($value)
setUserId ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforePublish event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on pks mixed An optional array of primary key values to update. state int The publishing state. eg. [0 = unpublished, 1 = published] userId int The user id of the user performing the operation.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setQuery()

setQuery ( $value )
protected

Setter for the pks argument

Paramètres
array | null $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setState()

setState ( $value )
protected

Setter for the state argument

Paramètres
int $value The value to set
Renvoie
integer
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setUserId()

setUserId ( $value )
protected

Setter for the userId argument

Paramètres
int $value The value to set
Renvoie
integer
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforePublishEvent.php


Joomla CMS: Référence de la classe BeforeReorderEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeReorderEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeReorderEvent
+ Graphe d'héritage de BeforeReorderEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setQuery ($value)
setWhere ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeReorder event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on query DatabaseQuery The query to get the primary keys and ordering values for the selection. where string WHERE clause to use for limiting the selection of rows to compact the ordering values.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setQuery()

setQuery ( $value )
protected

Setter for the query argument

Paramètres
DatabaseQuery $value The value to set
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

◆ setWhere()

setWhere ( $value )
protected

Setter for the where argument

Paramètres
array | string | null $value A string or array of where conditions.
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeReorderEvent.php


Joomla CMS: Référence de la classe BeforeResetEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeResetEvent
Référence de la classe BeforeResetEvent
+ Graphe d'héritage de BeforeResetEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeReset event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeResetEvent.php


Joomla CMS: Référence de la classe BeforeStoreEvent

  • Joomla
  • CMS
  • Event
  • Table
  • BeforeStoreEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BeforeStoreEvent
+ Graphe d'héritage de BeforeStoreEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setUpdateNulls ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onBeforeStore event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on updateNulls boolean True to update fields even if they are null. k mixed Name of the primary key fields in the table (string or array of strings).

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setUpdateNulls()

setUpdateNulls ( $value )
protected

Setter for the updateNulls attribute

Paramètres
mixed $value The value to set
Renvoie
boolean Normalised value

Références $value, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeStoreEvent.php


Joomla CMS: Référence de la classe CheckEvent

  • Joomla
  • CMS
  • Event
  • Table
  • CheckEvent
Référence de la classe CheckEvent
+ Graphe d'héritage de CheckEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onCheck event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckEvent.php


Joomla CMS: Référence de la classe ObjectCreateEvent

  • Joomla
  • CMS
  • Event
  • Table
  • ObjectCreateEvent
Référence de la classe ObjectCreateEvent
+ Graphe d'héritage de ObjectCreateEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onObjectCreate event

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ObjectCreateEvent.php


Joomla CMS: Référence de la classe SetNewTagsEvent

  • Joomla
  • CMS
  • Event
  • Table
  • SetNewTagsEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe SetNewTagsEvent
+ Graphe d'héritage de SetNewTagsEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setReplaceTags ($value)
- Fonctions membres protégées hérités de AbstractEvent
setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for JTable's onSetNewTags event

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: subject JTableInterface The table we are operating on newTags int[] New tags to be added to or replace current tags for an item replaceTags bool Replace tags (true) or add them (false)

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setReplaceTags()

setReplaceTags ( $value )
protected

Setter for the replaceTags attribute

Paramètres
mixed $value The value to set
Renvoie
boolean Normalised value

Références $value, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SetNewTagsEvent.php


Joomla CMS: Référence de la classe DisplayEvent

  • Joomla
  • CMS
  • Event
  • View
  • DisplayEvent
Fonctions membres publiques
Référence de la classe DisplayEvent
+ Graphe d'héritage de DisplayEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for WebAsset events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, $parts, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DisplayEvent.php


Joomla CMS: Référence de la classe AbstractEvent

  • Joomla
  • CMS
  • Event
  • WebAsset
  • AbstractEvent
Fonctions membres publiques
Référence de la classe AbstractEvent
+ Graphe d'héritage de AbstractEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface WebAssetRegistryAssetChanged

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for WebAsset events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Event/WebAsset/AbstractEvent.php


Joomla CMS: Référence de la classe WebAssetRegistryAssetChanged

  • Joomla
  • CMS
  • Event
  • WebAsset
  • WebAssetRegistryAssetChanged
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe WebAssetRegistryAssetChanged
+ Graphe d'héritage de WebAssetRegistryAssetChanged:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
getAsset ()
getAssetType ()
getChange ()
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setSubject ($value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for WebAssetRegistry "asset changed" events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAsset()

getAsset ( )

Return modified asset

Renvoie
WebAssetItemInterface
Depuis
4.0.0

Référencé par WebAssetManager\__construct().

◆ getAssetType()

getAssetType ( )

Return a type of modified asset

Renvoie
string
Depuis
4.0.0

Référencé par WebAssetManager\__construct().

◆ getChange()

getChange ( )

Return a type of changes: new, remove, override

Renvoie
string
Depuis
4.0.0

◆ setSubject()

setSubject ( $value )
protected

Setter for the subject argument

Paramètres
WebAssetRegistryInterface $value The value to set
Renvoie
WebAssetRegistryInterface
Exceptions
BadMethodCallException if the argument is not of the expected type
Depuis
4.0.0

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • WebAssetRegistryAssetChanged.php


Joomla CMS: Référence de la classe AbstractEvent

  • Joomla
  • CMS
  • Event
  • Workflow
  • AbstractEvent
Fonctions membres publiques
Référence de la classe AbstractEvent
+ Graphe d'héritage de AbstractEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface WorkflowFunctionalityUsedEvent WorkflowTransitionEvent

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for WebAsset events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, $parts, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Event/Workflow/AbstractEvent.php


Joomla CMS: Référence de la classe WorkflowFunctionalityUsedEvent

  • Joomla
  • CMS
  • Event
  • Workflow
  • WorkflowFunctionalityUsedEvent
Fonctions membres publiques
Référence de la classe WorkflowFunctionalityUsedEvent
+ Graphe d'héritage de WorkflowFunctionalityUsedEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
setUsed ($value=true)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for Workflow Functionality Used events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setUsed()

setUsed ( $value = true )

Set used parameter to true

Paramètres
bool $value The value to set
Renvoie
void
Depuis
4.0.0

Références $value.

Référencé par PlgWorkflowFeaturing\onWorkflowFunctionalityUsed(), et PlgWorkflowPublishing\onWorkflowFunctionalityUsed().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowFunctionalityUsedEvent.php


Joomla CMS: Référence de la classe WorkflowTransitionEvent

  • Joomla
  • CMS
  • Event
  • Workflow
  • WorkflowTransitionEvent
Fonctions membres publiques
Référence de la classe WorkflowTransitionEvent
+ Graphe d'héritage de WorkflowTransitionEvent:
AbstractEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
setStopTransition ($value=true)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for Workflow Functionality Used events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setStopTransition()

setStopTransition ( $value = true )

Set used parameter to true

Paramètres
bool $value The value to set
Renvoie
void
Depuis
4.0.0

Références $value.

Référencé par PlgWorkflowFeaturing\onWorkflowBeforeTransition(), et PlgWorkflowPublishing\onWorkflowBeforeTransition().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowTransitionEvent.php


Joomla CMS: Référence de la classe AbstractEvent

  • Joomla
  • CMS
  • Event
  • AbstractEvent
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe AbstractEvent
+ Graphe d'héritage de AbstractEvent:
Event AbstractEvent EventInterface AbstractImmutableEvent ErrorEvent GenericEvent MediaProviderEvent OAuthCallbackEvent ExecuteTaskEvent QuickIconsEvent AfterExtensionBootEvent BeforeExtensionBootEvent BeforeBatchEvent BeforeDisplayMethods Callback Captive GetMethod GetSetup NotifyActionLog SaveSetup Validate Ajax AjaxChallenge AjaxCreate AjaxDelete AjaxInitCreate AjaxLogin AjaxSaveLabel GetIconEvent AbstractEvent DisplayEvent AbstractEvent AbstractEvent OnGetApiFields OnGetApiAttributes OnGetApiRelation FeatureEvent AbstractMediaItemValidationEvent FetchMediaItemUrlEvent

Fonctions membres publiques

__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres publiques statiques

static create (string $eventName, array $arguments=[])

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

This class implements the base Event object used system-wide to offer orthogonality. Core objects such as Models, Controllers, etc create such events on-the-fly and dispatch them through the application's Dispatcher (colloquially known as the "Joomla! plugin system"). This way a suitable plugin, typically a "system" plugin, can modify the behaviour of any internal class, providing system-wide services such as tags, content versioning, comments or even low-level services such as the implementation of created/modified/locked behaviours, record hit counter etc.

You can create a new Event with something like this:

$event = AbstractEvent::create('onModelBeforeSomething', $myModel, $arguments);

You can access the subject object from your event Listener using $event['subject']. It is up to your listener to determine whether it should apply its functionality against the subject.

This AbstractEvent class implements a mutable event which is allowed to change its arguments at runtime. This is generally unadvisable. It's best to use AbstractImmutableEvent instead and constrict all your interaction to the subject class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor. Overridden to go through the argument setters.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.0.0

Références $name, $value, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ create()

static create | ( | string | $eventName,
 |  | array | $arguments = []
 | ) |  |
static

Creates a new CMS event object for a given event name and subject. The following arguments must be given: subject object The subject of the event. This is the core object you are going to manipulate. eventClass string The Event class name. If you do not provide it Joomla<eventNameWithoutOnPrefix> will be used.

Paramètres
string | $eventName | The name of the event, e.g. onTableBeforeLoad
array | $arguments | Additional arguments to pass to the event
Renvoie
static
Depuis
4.0.0
Exceptions
BadMethodCallException If you do not provide a subject argument

If the class name isn't set/found determine it from the event name, e.g. TableBeforeLoadEvent from the onTableBeforeLoad event name.

The detection code above failed. This is to be expected, it was written back when we only had the Table events. It does not address most other core events. So, let's use our fancier detection instead.

Références $parts, class, Normalise\fromCamelCase(), et Joomla\CMS\Event\getEventClassByEventName().

Référencé par Table\__construct(), AdminModel\batchTag(), Table\bind(), Table\check(), Table\checkIn(), Table\checkOut(), WebAssetRegistry\dispatchAssetChanged(), Task\dispatchExitEvent(), HtmlView\display(), Workflow\executeTransition(), ArticleModel\featured(), SampledataHelper\getList(), Table\hit(), Joomla\CMS\Workflow\isFunctionalityUsed(), Table\load(), Table\move(), Table\publish(), Table\reorder(), Table\reset(), Versioning\store(), Nested\store(), et TaskTable\unlock().

◆ getArgument()

getArgument | ( | $name,
 |  | $default = null
 | ) |

Get an event argument value. It will use a getter method if one exists. The getters have the signature:

get<ArgumentName>($value): mixed

where:

$value is the value currently stored in the $arguments array of the event It returns the value to return to the caller.

Paramètres
string | $name | The argument name.
mixed | $default | The default value if not found.
Renvoie
mixed The argument value or the default value.
Depuis
4.0.0

Implémente EventInterface.

Références $default, $methodName, $name, $this, et $value.

Référencé par Checkfiles\checkImages(), Joomlaupdate\getCoreUpdateNotification(), Requests\makeGetRequest(), PlgWorkflowFeaturing\onAfterDisplay(), PlgWorkflowPublishing\onAfterDisplay(), PlgWorkflowFeaturing\onContentBeforeChangeFeatured(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), PlgWorkflowNotification\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowBeforeTransition(), PlgWorkflowPublishing\onWorkflowBeforeTransition(), PlgWorkflowFeaturing\onWorkflowFunctionalityUsed(), PlgWorkflowPublishing\onWorkflowFunctionalityUsed(), DemoTasks\sleep(), et Joomla\Component\Scheduler\Administrator\Traits\startRoutine().

◆ setArgument()

setArgument | ( | $name,
 |  | $value
 | ) |

Add argument to event. It will use a setter method if one exists. The setters have the signature:

set<ArgumentName>($value): mixed

where:

$value is the value being set by the user It returns the value to return to set in the $arguments array of the event.

Paramètres
string | $name | Argument name.
mixed | $value | Value.
Renvoie
$this
Depuis
4.0.0

Références $methodName, $name, $this, et $value.

Référencé par Joomlaupdate\getCoreUpdateNotification().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Event/AbstractEvent.php


Joomla CMS: Référence de la classe AbstractImmutableEvent

  • Joomla
  • CMS
  • Event
  • AbstractImmutableEvent
Fonctions membres publiques | Attributs privés
Référence de la classe AbstractImmutableEvent
+ Graphe d'héritage de AbstractImmutableEvent:
AbstractEvent Event AbstractEvent EventInterface AfterExtensionBootEvent BeforeExtensionBootEvent BeforeBatchEvent BeforeDisplayMethods Callback Captive GetMethod GetSetup NotifyActionLog SaveSetup Validate Ajax AjaxChallenge AjaxCreate AjaxDelete AjaxInitCreate AjaxLogin AjaxSaveLabel GetIconEvent AbstractEvent DisplayEvent AbstractEvent AbstractEvent OnGetApiFields OnGetApiAttributes OnGetApiRelation FeatureEvent AbstractMediaItemValidationEvent FetchMediaItemUrlEvent

Fonctions membres publiques

__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$constructed = false

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

This class implements the immutable base Event object used system-wide to offer orthogonality.

Voir également
Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.0.0
Exceptions
BadMethodCallException

Références $name, Symfony\Contracts\Service\__construct(), et name.

Documentation des fonctions membres

◆ offsetSet()

offsetSet | ( | $name,
 |  | $value
 | ) |

Set the value of an event argument.

Paramètres
string | $name | The argument name.
mixed | $value | The argument value.
Renvoie
void
Depuis
4.0.0
Exceptions
BadMethodCallException

Références $name, et name.

◆ offsetUnset()

offsetUnset ( $name )

Remove an event argument.

Paramètres
string $name The argument name.
Renvoie
void
Depuis
4.0.0
Exceptions
BadMethodCallException

Références $name, et name.

Documentation des champs

◆ $constructed

$constructed = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractImmutableEvent.php


Joomla CMS: Référence de la classe AfterExtensionBootEvent

  • Joomla
  • CMS
  • Event
  • AfterExtensionBootEvent
Fonctions membres publiques
Référence de la classe AfterExtensionBootEvent
+ Graphe d'héritage de AfterExtensionBootEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getExtensionType ()
getExtensionName ()
getContainer ()
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for representing the extensions's onBeforeExtensionBoot event

Depuis
4.0.0

Documentation des fonctions membres

◆ getContainer()

getContainer ( )

Get the event's container object

Renvoie
Container
Depuis
4.0.0

◆ getExtensionName()

getExtensionName ( )

Get the event's extension name.

Renvoie
string
Depuis
4.0.0

◆ getExtensionType()

getExtensionType ( )

Get the event's extension type. Can be:

  • component
Renvoie
string
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AfterExtensionBootEvent.php


Joomla CMS: Référence de la classe BeforeExtensionBootEvent

  • Joomla
  • CMS
  • Event
  • BeforeExtensionBootEvent
Fonctions membres publiques
Référence de la classe BeforeExtensionBootEvent
+ Graphe d'héritage de BeforeExtensionBootEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getExtensionType ()
getExtensionName ()
getContainer ()
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for representing the extensions's onBeforeExtensionBoot event

Depuis
4.0.0

Documentation des fonctions membres

◆ getContainer()

getContainer ( )

Get the event's container object

Renvoie
Container
Depuis
4.0.0

◆ getExtensionName()

getExtensionName ( )

Get the event's extension name.

Renvoie
string
Depuis
4.0.0

◆ getExtensionType()

getExtensionType ( )

Get the event's extension type. Can be:

  • component
Renvoie
string
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeExtensionBootEvent.php


Joomla CMS: Référence de la classe ErrorEvent

  • Joomla
  • CMS
  • Event
  • ErrorEvent
Fonctions membres publiques
Référence de la classe ErrorEvent
+ Graphe d'héritage de ErrorEvent:
AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getApplication ()
getError ()
setError (\Throwable $error)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for representing the application's onError event

Depuis
4.0.0

Documentation des fonctions membres

◆ getApplication()

getApplication ( )

Get the event's application object

Renvoie
AbstractApplication
Depuis
4.0.0

◆ getError()

getError ( )

Get the event's error object

Renvoie
Depuis
4.0.0

◆ setError()

setError ( \Throwable $error )

Set the event's error object

Paramètres
\Throwable $error The new error to process
Renvoie
void
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ErrorEvent.php


Joomla CMS: Référence de la classe GenericEvent

  • Joomla
  • CMS
  • Event
  • GenericEvent
Référence de la classe GenericEvent
+ Graphe d'héritage de GenericEvent:
AbstractEvent Event AbstractEvent EventInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

This class gives a concrete implementation of the AbstractEvent class.

Voir également
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • GenericEvent.php


Joomla CMS: Référence de la classe ExceptionHandler

  • Joomla
  • CMS
  • Exception
  • ExceptionHandler
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ExceptionHandler

Fonctions membres publiques statiques

static | handleUserDeprecatedErrors (int $errorNumber, string $errorMessage, string $errorFile, int $errorLine)
static | handleException (\Throwable $error)

Fonctions membres protégées statiques

static | isException ($error)
static | logException (\Throwable $error)

Description détaillée

Displays the custom error page when an uncaught exception occurs.

Depuis
3.0

Documentation des fonctions membres

◆ handleException()

static handleException ( \Throwable $error )
static

Handles exceptions: logs errors and renders error page.

Paramètres
\Exception | \Throwable $error An Exception or Throwable (PHP 7+) object for which to render the error page.
Renvoie
void
Depuis
3.10.0

◆ handleUserDeprecatedErrors()

static handleUserDeprecatedErrors | ( | int | $errorNumber,
 |  | string | $errorMessage,
 |  | string | $errorFile,
 |  | int | $errorLine
 | ) |  |
static

Handles an error triggered with the E_USER_DEPRECATED level.

Paramètres
integer | $errorNumber | The level of the raised error, represented by the E_* constants.
string | $errorMessage | The error message.
string | $errorFile | The file the error was triggered from.
integer | $errorLine | The line number the error was triggered from.
Renvoie
boolean
Depuis
4.0.0

Références Log\add(), JDEBUG, et Log\WARNING.

◆ isException()

static isException ( $error )
staticprotected

Checks if given error belong to PHP exception class ( for PHP 7+, for PHP 5-).

Paramètres
mixed $error Any error value.
Renvoie
boolean
Depuis
3.10.0

◆ logException()

static logException ( \Throwable $error )
staticprotected

Logs exception, catching all possible errors during logging.

Paramètres
\Throwable $error An Exception or Throwable (PHP 7+) object to get error message from.
Renvoie
void
Depuis
3.10.0

Références Log\add(), et Log\CRITICAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExceptionHandler.php


Joomla CMS: Référence de la classe CategoryFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • CategoryFactory
Fonctions membres publiques | Attributs privés
Référence de la classe CategoryFactory
+ Graphe d'héritage de CategoryFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct ($namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service categories.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $namespace )

The namespace must be like: Joomla

Paramètres
string $namespace The namespace
Depuis
4.0.0

Références $namespace.

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, et class.

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/CategoryFactory.php


Joomla CMS: Référence de la classe ComponentDispatcherFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • ComponentDispatcherFactory
Fonctions membres publiques | Attributs privés
Référence de la classe ComponentDispatcherFactory
+ Graphe d'héritage de ComponentDispatcherFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct (string $namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service dispatcher factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

ComponentDispatcherFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et Container\get().

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/ComponentDispatcherFactory.php


Joomla CMS: Référence de la classe HelperFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • HelperFactory
Fonctions membres publiques | Attributs privés
Référence de la classe HelperFactory
+ Graphe d'héritage de HelperFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct (string $namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service helper factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

HelperFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, et class.

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/HelperFactory.php


Joomla CMS: Référence de la classe Module

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • Module
Fonctions membres publiques
Référence de la classe Module
+ Graphe d'héritage de Module:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the service based modules.

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Extension/Service/Provider/Module.php


Joomla CMS: Référence de la classe ModuleDispatcherFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • ModuleDispatcherFactory
Fonctions membres publiques | Attributs privés
Référence de la classe ModuleDispatcherFactory
+ Graphe d'héritage de ModuleDispatcherFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct (string $namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service dispatcher factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

ComponentDispatcherFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, et class.

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/ModuleDispatcherFactory.php


Joomla CMS: Référence de la classe MVCFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • MVCFactory
Fonctions membres publiques | Attributs privés
Référence de la classe MVCFactory
+ Graphe d'héritage de MVCFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct (string $namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service MVC factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

MVCFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et Factory\getApplication().

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/MVCFactory.php


Joomla CMS: Référence de la classe RouterFactory

  • Joomla
  • CMS
  • Extension
  • Service
  • Provider
  • RouterFactory
Fonctions membres publiques | Attributs privés
Référence de la classe RouterFactory
+ Graphe d'héritage de RouterFactory:
ServiceProviderInterface

Fonctions membres publiques

__construct (string $namespace)
register (Container $container)

Attributs privés

$namespace

Description détaillée

Service provider for the service router factory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

DispatcherFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et null.

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extension/Service/Provider/RouterFactory.php


Joomla CMS: Référence de l'interface BootableExtensionInterface

  • Joomla
  • CMS
  • Extension
  • BootableExtensionInterface
Fonctions membres publiques
Référence de l'interface BootableExtensionInterface
+ Graphe d'héritage de BootableExtensionInterface:
AdminComponent BannersComponent CategoriesComponent ContactComponent ContentComponent FinderComponent InstallerComponent LanguagesComponent MenusComponent MessagesComponent ModulesComponent NewsfeedsComponent PrivacyComponent RedirectComponent SchedulerComponent TemplatesComponent UsersComponent

Fonctions membres publiques

boot (ContainerInterface $container)

Description détaillée

Interface which defines that an extension can be booted.

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémenté dans ContentComponent, ContactComponent, NewsfeedsComponent, BannersComponent, FinderComponent, MenusComponent, UsersComponent, AdminComponent, PrivacyComponent, InstallerComponent, CategoriesComponent, LanguagesComponent, MessagesComponent, ModulesComponent, RedirectComponent, SchedulerComponent, et TemplatesComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • BootableExtensionInterface.php


Joomla CMS: Référence de la classe Component

  • Joomla
  • CMS
  • Extension
  • Component
Fonctions membres publiques | Attributs privés
Référence de la classe Component
+ Graphe d'héritage de Component:
ComponentInterface MVCComponent AdminComponent BannersComponent CategoriesComponent ConfigComponent ContactComponent ContentComponent FieldsComponent FinderComponent InstallerComponent LanguagesComponent MenusComponent MessagesComponent ModulesComponent NewsfeedsComponent PrivacyComponent RedirectComponent SchedulerComponent TagsComponent TemplatesComponent UsersComponent WrapperComponent

Fonctions membres publiques

__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)

Attributs privés

$dispatcherFactory

Description détaillée

Access to component specific services.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ComponentDispatcherFactoryInterface $dispatcherFactory )

Component constructor.

Paramètres
ComponentDispatcherFactoryInterface $dispatcherFactory The dispatcher factory
Depuis
4.0.0

Documentation des fonctions membres

◆ getDispatcher()

getDispatcher ( CMSApplicationInterface $application )

Returns the dispatcher for the given application.

Paramètres
CMSApplicationInterface $application The application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémente ComponentInterface.

Documentation des champs

◆ $dispatcherFactory

$dispatcherFactory
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Component.php


Joomla CMS: Référence de l'interface ComponentInterface

  • Joomla
  • CMS
  • Extension
  • ComponentInterface
Fonctions membres publiques
Référence de l'interface ComponentInterface
+ Graphe d'héritage de ComponentInterface:
Component LegacyComponent MVCComponent AdminComponent BannersComponent CategoriesComponent ConfigComponent ContactComponent ContentComponent FieldsComponent FinderComponent InstallerComponent LanguagesComponent MenusComponent MessagesComponent ModulesComponent NewsfeedsComponent PrivacyComponent RedirectComponent SchedulerComponent TagsComponent TemplatesComponent UsersComponent WrapperComponent

Fonctions membres publiques

getDispatcher (CMSApplicationInterface $application)

Description détaillée

Access to component specific services.

Depuis
4.0.0

Documentation des fonctions membres

◆ getDispatcher()

getDispatcher ( CMSApplicationInterface $application )

Returns the dispatcher for the given application.

Paramètres
CMSApplicationInterface $application The application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémenté dans LegacyComponent, et Component.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ComponentInterface.php


Joomla CMS: Référence de la classe DummyPlugin

  • Joomla
  • CMS
  • Extension
  • DummyPlugin
Référence de la classe DummyPlugin
+ Graphe d'héritage de DummyPlugin:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Placeholder plugin.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DummyPlugin.php


Joomla CMS: Référence de la classe ExtensionHelper

  • Joomla
  • CMS
  • Extension
  • ExtensionHelper
Fonctions membres publiques statiques | Attributs publics statiques | Attributs protégés statiques | Attributs privés statiques
Référence de la classe ExtensionHelper

Fonctions membres publiques statiques

static | getCoreExtensions ()
static | getCoreExtensionIds ()
static | checkIfCoreExtension ($type, $element, $clientId=0, $folder='')
static | getExtensionRecord (string $element, string $type, ?int $clientId=null, ?string $folder=null)

Attributs publics statiques

static $extensions = [ModuleInterface::class => []

Attributs protégés statiques

static | $coreExtensions
static | $coreExtensionIds

Attributs privés statiques

static $loadedExtensions = []

Description détaillée

Extension Helper class.

Depuis
3.7.4
Obsolète:
4.0 Replace class with a non static methods for better testing

Documentation des fonctions membres

◆ checkIfCoreExtension()

static checkIfCoreExtension | ( | $type,
 |  | $element,
 |  | $clientId = 0,
 |  | $folder = ''
 | ) |
static

Check if an extension is core or not

Paramètres
string | $type | The extension's type.
string | $element | The extension's element name.
integer | $clientId | The extension's client ID. Default 0.
string | $folder | The extension's folder. Default ''.
Renvoie
boolean True if core, false if not.
Depuis
3.7.4

Références $clientId, $folder, et $type.

◆ getCoreExtensionIds()

static getCoreExtensionIds ( )
static

Returns an array of core extension IDs.

Renvoie
array
Depuis
4.0.0
Exceptions

Références $db, $extension, $query, Factory\getDbo(), ParameterType\INTEGER, null, et ParameterType\STRING.

Référencé par ManageModel\getListQuery(), UpdateModel\getNonCoreExtensions(), et UpdateModel\getNonCorePlugins().

◆ getCoreExtensions()

static getCoreExtensions ( )
static

Gets the core extensions.

Renvoie
array Array with core extensions. Each extension is an array with following format: type, element, folder, client_id.
Depuis
3.7.4

◆ getExtensionRecord()

static getExtensionRecord | ( | string | $element,
 |  | string | $type,
 |  | ?int | $clientId = null,
 |  | ?string | $folder = null
 | ) |  |
static

Returns an extension record for the given name.

Paramètres
string | $element | The extension element
string | $type | The extension type
integer | null | $clientId | The client ID
string | null | $folder | Plugin folder
Renvoie
|null The object or null if not found.
Depuis
4.0.0
Exceptions

Références $clientId, $db, $folder, $key, $query, $type, Factory\getDbo(), ParameterType\INTEGER, et null.

Référencé par UpdateModel\applyUpdateSite(), UpdateModel\finaliseUpgrade(), FinderHelper\getFinderPluginId(), MessagesModel\getJoomlaFilesExtensionId(), UpdateModel\getListQuery(), UpdateModel\getUpdateInformation(), JsonapiView\prepareItem(), et UpdateModel\refreshUpdates().

Documentation des champs

◆ $coreExtensionIds

$coreExtensionIds
staticprotected

◆ $coreExtensions

$coreExtensions
staticprotected

◆ $extensions

$extensions = [ModuleInterface::class => []
static

◆ $loadedExtensions

$loadedExtensions = []
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionHelper.php


Joomla CMS: Référence de l'interface ExtensionManagerInterface

  • Joomla
  • CMS
  • Extension
  • ExtensionManagerInterface
Fonctions membres publiques
Référence de l'interface ExtensionManagerInterface
+ Graphe d'héritage de ExtensionManagerInterface:
CMSApplicationInterface CliApplication CMSWebApplicationInterface ConsoleApplication DaemonApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)

Description détaillée

Loads extensions.

Depuis
4.0.0

Documentation des fonctions membres

◆ bootComponent()

bootComponent ( $component )

Boots the component with the given name.

Paramètres
string $component The component to boot.
Renvoie
ComponentInterface
Depuis
4.0.0

◆ bootModule()

bootModule | ( | $module,
 |  | $applicationName
 | ) |

Boots the module with the given name.

Paramètres
string | $module | The module to boot
string | $applicationName | The application name
Renvoie
ModuleInterface
Depuis
4.0.0

◆ bootPlugin()

bootPlugin | ( | $plugin,
 |  | $type
 | ) |

Boots the plugin with the given name and type.

Paramètres
string | $plugin | The plugin name
string | $type | The type of the plugin
Renvoie
PluginInterface
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • ExtensionManagerInterface.php


Joomla CMS: Référence de la classe LegacyComponent

  • Joomla
  • CMS
  • Extension
  • LegacyComponent
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe LegacyComponent
+ Graphe d'héritage de LegacyComponent:
ComponentInterface MVCFactoryServiceInterface CategoryServiceInterface FieldsServiceInterface RouterServiceInterface TagServiceInterface

Fonctions membres publiques

__construct (string $component)
getDispatcher (CMSApplicationInterface $application)
getMVCFactory ()
getCategory (array $options=[], $section='')
countItems (array $items, string $section)
countTagItems (array $items, string $extension)
validateSection ($section, $item=null)
getContexts ()
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
- Fonctions membres publiques hérités de CategoryServiceInterface
prepareForm (Form $form, $data)

Champs de données

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait

Fonctions membres privées

loadHelper ()

Attributs privés

$component

Description détaillée

Access to component specific services.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $component )

LegacyComponentContainer constructor.

Paramètres
string $component The component
Depuis
4.0.0

Références $component.

Documentation des fonctions membres

◆ countItems()

countItems | ( | array | $items,
 |  | string | $section
 | ) |  |

Adds Count Items for Category Manager.

Paramètres

Implémente CategoryServiceInterface.

Références $helper, $items, $section, et Joomla\CMS\Categories\countItems().

◆ countTagItems()

countTagItems | ( | array | $items,
 |  | string | $extension
 | ) |  |

Adds Count Items for Tag Manager.

Paramètres

Implémente TagServiceInterface.

Références $extension, $helper, et $items.

◆ createRouter()

createRouter | ( | CMSApplicationInterface | $application,
 |  | AbstractMenu | $menu
 | ) |  |

Returns the router.

Paramètres
CMSApplicationInterface | $application | The application object
AbstractMenu | $menu | The menu object to work with
Renvoie
RouterInterface
Depuis
4.0.0

Implémente RouterServiceInterface.

Références $class, $menu, $path, et JPATH_SITE.

◆ getCategory()

getCategory | ( | array | $options = [],
 |  |  | $section = ''
 | ) |  |

Returns the category service.

Paramètres
array | $options | The options
string | $section | The section
Renvoie
CategoryInterface
Depuis
4.0.0
Exceptions
SectionNotFoundException

Implémente CategoryServiceInterface.

Références $options, $path, $section, et JPATH_SITE.

◆ getContexts()

getContexts ( )

Returns valid contexts.

Renvoie
array
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $helper.

◆ getDispatcher()

getDispatcher ( CMSApplicationInterface $application )

Returns the dispatcher for the given application.

Paramètres
CMSApplicationInterface $application The application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémente ComponentInterface.

◆ getMVCFactory()

getMVCFactory ( )

Get the factory.

Renvoie
MVCFactoryInterface
Depuis
4.0.0
Exceptions

Implémente MVCFactoryServiceInterface.

◆ loadHelper()

loadHelper ( )
private

Returns the classname of the legacy helper class. If none is found it returns false.

Renvoie
boolean|string
Depuis
4.0.0

Références $className, Path\clean(), JPATH_ADMINISTRATOR, et JLoader\register().

◆ validateSection()

validateSection | ( | $section,
 |  | $item = null
 | ) |

Returns a valid section for articles. If it is not valid then null is returned.

Paramètres
string | $section | The section to get the mapping for
object | $item | The item
Renvoie
string|null The new section
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $helper, $item, et $section.

Documentation des champs

◆ $component

$component
private

◆ TagServiceTrait

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait
La documentation de cette classe a été générée à partir du fichier suivant :
  • LegacyComponent.php


Joomla CMS: Référence de la classe Module

  • Joomla
  • CMS
  • Extension
  • Module
Fonctions membres publiques | Attributs privés
Référence de la classe Module
+ Graphe d'héritage de Module:
ModuleInterface HelperFactoryInterface

Fonctions membres publiques

__construct (ModuleDispatcherFactoryInterface $dispatcherFactory, HelperFactoryInterface $helperFactory)
getDispatcher (\stdClass $module, CMSApplicationInterface $application, Input $input=null)
getHelper (string $name, array $config=[])

Attributs privés

$dispatcherFactory
$helperFactory

Description détaillée

Access to module specific services.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ModuleDispatcherFactoryInterface | $dispatcherFactory,
 |  | HelperFactoryInterface | $helperFactory
 | ) |  |

Module constructor.

Paramètres
ModuleDispatcherFactoryInterface | $dispatcherFactory | The dispatcher factory
HelperFactoryInterface | $helperFactory | The helper factory
Depuis
4.0.0

Documentation des fonctions membres

◆ getDispatcher()

getDispatcher | ( | \stdClass | $module,
 |  | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Returns the dispatcher for the given application, module and input.

Paramètres
\stdClass | $module | The module
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémente ModuleInterface.

Références $input, et $module.

◆ getHelper()

getHelper | ( | string | $name,
 |  | array | $config = []
 | ) |  |

Returns a helper instance for the given name.

Paramètres
string | $name | The name
array | $config | The config
Renvoie
Depuis
4.0.0

Implémente HelperFactoryInterface.

Références $config, et $name.

Documentation des champs

◆ $dispatcherFactory

$dispatcherFactory
private

◆ $helperFactory

$helperFactory
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Extension/Module.php


Joomla CMS: Référence de l'interface ModuleInterface

  • Joomla
  • CMS
  • Extension
  • ModuleInterface
Fonctions membres publiques
Référence de l'interface ModuleInterface
+ Graphe d'héritage de ModuleInterface:
Module

Fonctions membres publiques

getDispatcher (\stdClass $module, CMSApplicationInterface $application, Input $input=null)

Description détaillée

Access to module specific services.

Depuis
4.0.0

Documentation des fonctions membres

◆ getDispatcher()

getDispatcher | ( | \stdClass | $module,
 |  | CMSApplicationInterface | $application,
 |  | Input | $input = null
 | ) |  |

Returns the dispatcher for the given application, module and input.

Paramètres
\stdClass | $module | The module
CMSApplicationInterface | $application | The application
Input | $input | The input object, defaults to the one in the application
Renvoie
DispatcherInterface
Depuis
4.0.0

Implémenté dans Module.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ModuleInterface.php


Joomla CMS: Référence de la classe MVCComponent

  • Joomla
  • CMS
  • Extension
  • MVCComponent
Référence de la classe MVCComponent
+ Graphe d'héritage de MVCComponent:
Component MVCFactoryServiceInterface ComponentInterface AdminComponent BannersComponent CategoriesComponent ConfigComponent ContactComponent ContentComponent FieldsComponent FinderComponent InstallerComponent LanguagesComponent MenusComponent MessagesComponent ModulesComponent NewsfeedsComponent PrivacyComponent RedirectComponent SchedulerComponent TagsComponent TemplatesComponent UsersComponent WrapperComponent

Membres hérités additionnels

- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

MVC Component class.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • MVCComponent.php


Joomla CMS: Référence de l'interface PluginInterface

  • Joomla
  • CMS
  • Extension
  • PluginInterface
Fonctions membres publiques
Référence de l'interface PluginInterface
+ Graphe d'héritage de PluginInterface:
DispatcherAwareInterface CMSPlugin DummyPlugin ActionLogPlugin FieldsPlugin Adapter MediaActionPlugin PrivacyPlugin Basic Token Taggable Versionable Email Fixed Totp Webauthn Yubikey Joomlaupdate Cache Shortcut Webauthn Checkfiles DemoTasks Requests SiteStatus PlgAuthenticationCookie PlgAuthenticationJoomla PlgAuthenticationLdap PlgButtonArticle PlgButtonContact PlgButtonFields PlgButtonImage PlgButtonMenu PlgButtonModule PlgButtonPagebreak PlgButtonReadmore PlgCaptchaRecaptcha PlgCaptchaRecaptcha_Invisible PlgContentConfirmConsent PlgContentContact PlgContentEmailcloak PlgContentFields PlgContentFinder PlgContentJoomla PlgContentLoadmodule PlgContentPagebreak PlgContentPagenavigation PlgContentVote PlgEditorCodemirror PlgEditorNone PlgEditorTinymce PlgExtensionFinder PlgExtensionJoomla PlgExtensionNamespacemap PlgFileSystemLocal PlgInstallerFolderInstaller PlgInstallerOverride PlgInstallerPackageInstaller PlgInstallerUrlInstaller PlgInstallerWebinstaller PlgQuickiconDownloadkey PlgQuickiconExtensionupdate PlgQuickiconOverrideCheck PlgQuickiconPhpVersionCheck PlgQuickiconPrivacyCheck PlgSampledataBlog PlgSampledataMultilang PlgSystemAccessibility PlgSystemActionLogs PlgSystemDebug PlgSystemFields PlgSystemHighlight PlgSystemHttpHeaders PlgSystemJooa11y PlgSystemLanguagecode PlgSystemLanguageFilter PlgSystemLog PlgSystemLogout PlgSystemLogrotation PlgSystemPrivacyconsent PlgSystemRedirect PlgSystemRemember PlgSystemSchedulerunner PlgSystemSef PlgSystemSessionGc PlgSystemSkipto PlgSystemStats PlgSystemTasknotification PlgSystemUpdatenotification PlgUserContactCreator PlgUserJoomla PlgUserProfile PlgUserTerms PlgUserToken PlgWebservicesBanners PlgWebservicesConfig PlgWebservicesContact PlgWebservicesContent PlgWebservicesInstaller PlgWebservicesLanguages PlgWebservicesMedia PlgWebservicesMenus PlgWebservicesMessages PlgWebservicesModules PlgWebservicesNewsfeeds PlgWebservicesPlugins PlgWebservicesPrivacy PlgWebservicesRedirect PlgWebservicesTags PlgWebservicesTemplates PlgWebservicesUsers PlgWorkflowFeaturing PlgWorkflowNotification PlgWorkflowPublishing

Fonctions membres publiques

registerListeners ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Description détaillée

Access to plugin specific services.

Depuis
4.0.0

Documentation des fonctions membres

◆ registerListeners()

registerListeners ( )

Registers its listeners.

Renvoie
void
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • PluginInterface.php


Joomla CMS: Référence de la classe ItunesRssParser

  • Joomla
  • CMS
  • Feed
  • Parser
  • Rss
  • ItunesRssParser
Fonctions membres publiques
Référence de la classe ItunesRssParser
+ Graphe d'héritage de ItunesRssParser:
NamespaceParserInterface

Fonctions membres publiques

processElementForFeed (Feed $feed, \SimpleXMLElement $el)
processElementForFeedEntry (FeedEntry $entry, \SimpleXMLElement $el)

Description détaillée

RSS Feed Parser Namespace handler for iTunes.

3.1.4

Documentation des fonctions membres

◆ processElementForFeed()

processElementForFeed | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle an element for the feed given that the itunes namespace is present.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémente NamespaceParserInterface.

◆ processElementForFeedEntry()

processElementForFeedEntry | ( | FeedEntry | $entry,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle the feed entry element for the feed given that the itunes namespace is present.

Paramètres
FeedEntry | $entry | The FeedEntry object being built from the parsed feed entry.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémente NamespaceParserInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ItunesRssParser.php


Joomla CMS: Référence de la classe MediaRssParser

  • Joomla
  • CMS
  • Feed
  • Parser
  • Rss
  • MediaRssParser
Fonctions membres publiques
Référence de la classe MediaRssParser
+ Graphe d'héritage de MediaRssParser:
NamespaceParserInterface

Fonctions membres publiques

processElementForFeed (Feed $feed, \SimpleXMLElement $el)
processElementForFeedEntry (FeedEntry $entry, \SimpleXMLElement $el)

Description détaillée

RSS Feed Parser Namespace handler for MediaRSS.

3.1.4

Documentation des fonctions membres

◆ processElementForFeed()

processElementForFeed | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle an element for the feed given that the media namespace is present.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémente NamespaceParserInterface.

◆ processElementForFeedEntry()

processElementForFeedEntry | ( | FeedEntry | $entry,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle the feed entry element for the feed given that the media namespace is present.

Paramètres
FeedEntry | $entry | The FeedEntry object being built from the parsed feed entry.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémente NamespaceParserInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaRssParser.php


Joomla CMS: Référence de la classe AtomParser

  • Joomla
  • CMS
  • Feed
  • Parser
  • AtomParser
Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe AtomParser
+ Graphe d'héritage de AtomParser:
FeedParser

Fonctions membres protégées

handleAuthor (Feed $feed, \SimpleXMLElement $el)
handleContributor (Feed $feed, \SimpleXMLElement $el)
handleGenerator (Feed $feed, \SimpleXMLElement $el)
handleId (Feed $feed, \SimpleXMLElement $el)
handleLink (Feed $feed, \SimpleXMLElement $el)
handleRights (Feed $feed, \SimpleXMLElement $el)
handleSubtitle (Feed $feed, \SimpleXMLElement $el)
handleTitle (Feed $feed, \SimpleXMLElement $el)
handleUpdated (Feed $feed, \SimpleXMLElement $el)
initialise ()
processFeedEntry (FeedEntry $entry, \SimpleXMLElement $el)
- Fonctions membres protégées hérités de FeedParser
initialise ()
processElement (Feed $feed, \SimpleXMLElement $el, array $namespaces)
fetchNamespace ($prefix)
moveToNextElement ($name=null)
moveToClosingElement ()

Attributs protégés

$version
- Attributs protégés hérités de FeedParser
$entryElementName = 'entry'
$namespaces = array()
$stream
$inputFilter

Fonctions membres privées

bestLinkForUri (array $links)

Membres hérités additionnels

- Fonctions membres publiques hérités de FeedParser
__construct (\XMLReader $stream, InputFilter $inputFilter=null)
parse ()
registerNamespace ($prefix, NamespaceParserInterface $namespace)

Description détaillée

ATOM Feed Parser class.

3.1.4

Documentation des fonctions membres

◆ bestLinkForUri()

bestLinkForUri ( array $links )
private

If there is more than one <link> in the feed entry, find the most appropriate one and return it.

Paramètres
array $links Array of <link> elements from the feed entry.
Renvoie

Références $link, et $rel.

◆ handleAuthor()

handleAuthor | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <author> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleContributor()

handleContributor | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <contributor> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleGenerator()

handleGenerator | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <generator> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleId()

handleId | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <id> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleLink()

handleLink | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <link> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed, et $link.

◆ handleRights()

handleRights | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <rights> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleSubtitle()

handleSubtitle | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <subtitle> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleTitle()

handleTitle | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <title> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleUpdated()

handleUpdated | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <updated> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ initialise()

initialise ( )
protected

Method to initialise the feed for parsing. Here we detect the version and advance the stream reader so that it is ready to parse feed elements.

Renvoie
void
Depuis
3.1.4

◆ processFeedEntry()

processFeedEntry | ( | FeedEntry | $entry,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle a <entry> element for the feed.

Paramètres
FeedEntry | $entry | The FeedEntry object being built from the parsed feed entry.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $link, $this, et $uri.

Documentation des champs

◆ $version

$version
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AtomParser.php


Joomla CMS: Référence de l'interface NamespaceParserInterface

  • Joomla
  • CMS
  • Feed
  • Parser
  • NamespaceParserInterface
Fonctions membres publiques
Référence de l'interface NamespaceParserInterface
+ Graphe d'héritage de NamespaceParserInterface:
ItunesRssParser MediaRssParser

Fonctions membres publiques

processElementForFeed (Feed $feed, \SimpleXMLElement $el)
processElementForFeedEntry (FeedEntry $entry, \SimpleXMLElement $el)

Description détaillée

Feed Namespace interface.

Depuis
3.1.4

Documentation des fonctions membres

◆ processElementForFeed()

processElementForFeed | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle an element for the feed given that a certain namespace is present.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémenté dans ItunesRssParser, et MediaRssParser.

◆ processElementForFeedEntry()

processElementForFeedEntry | ( | FeedEntry | $entry,
 |  | \SimpleXMLElement | $el
 | ) |  |

Method to handle the feed entry element for the feed given that a certain namespace is present.

Paramètres
FeedEntry | $entry | The FeedEntry object being built from the parsed feed entry.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Implémenté dans ItunesRssParser, et MediaRssParser.

La documentation de cette interface a été générée à partir du fichier suivant :
  • NamespaceParserInterface.php


Joomla CMS: Référence de la classe RssParser

  • Joomla
  • CMS
  • Feed
  • Parser
  • RssParser
Fonctions membres protégées | Attributs protégés
Référence de la classe RssParser
+ Graphe d'héritage de RssParser:
FeedParser

Fonctions membres protégées

handleCategory (Feed $feed, \SimpleXMLElement $el)
handleCloud (Feed $feed, \SimpleXMLElement $el)
handleCopyright (Feed $feed, \SimpleXMLElement $el)
handleDescription (Feed $feed, \SimpleXMLElement $el)
handleGenerator (Feed $feed, \SimpleXMLElement $el)
handleImage (Feed $feed, \SimpleXMLElement $el)
handleLanguage (Feed $feed, \SimpleXMLElement $el)
handleLastBuildDate (Feed $feed, \SimpleXMLElement $el)
handleLink (Feed $feed, \SimpleXMLElement $el)
handleManagingEditor (Feed $feed, \SimpleXMLElement $el)
handleSkipDays (Feed $feed, \SimpleXMLElement $el)
handleSkipHours (Feed $feed, \SimpleXMLElement $el)
handlePubDate (Feed $feed, \SimpleXMLElement $el)
handleTitle (Feed $feed, \SimpleXMLElement $el)
handleTtl (Feed $feed, \SimpleXMLElement $el)
handleWebmaster (Feed $feed, \SimpleXMLElement $el)
initialise ()
processFeedEntry (FeedEntry $entry, \SimpleXMLElement $el)
processPerson ($data)
- Fonctions membres protégées hérités de FeedParser
initialise ()
processElement (Feed $feed, \SimpleXMLElement $el, array $namespaces)
fetchNamespace ($prefix)
moveToNextElement ($name=null)
moveToClosingElement ()

Attributs protégés

$entryElementName = 'item'
$version
- Attributs protégés hérités de FeedParser
$entryElementName = 'entry'
$namespaces = array()
$stream
$inputFilter

Membres hérités additionnels

- Fonctions membres publiques hérités de FeedParser
__construct (\XMLReader $stream, InputFilter $inputFilter=null)
parse ()
registerNamespace ($prefix, NamespaceParserInterface $namespace)

Description détaillée

RSS Feed Parser class.

3.1.4

Documentation des fonctions membres

◆ handleCategory()

handleCategory | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <category> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $category, et $feed.

◆ handleCloud()

handleCloud | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <cloud> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleCopyright()

handleCopyright | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <copyright> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleDescription()

handleDescription | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <description> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleGenerator()

handleGenerator | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <generator> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleImage()

handleImage | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <image> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed, $image, $this, et null.

◆ handleLanguage()

handleLanguage | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <language> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleLastBuildDate()

handleLastBuildDate | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <lastBuildDate> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleLink()

handleLink | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <link> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed, et $link.

◆ handleManagingEditor()

handleManagingEditor | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <managingEditor> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handlePubDate()

handlePubDate | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <pubDate> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleSkipDays()

handleSkipDays | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <skipDays> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleSkipHours()

handleSkipHours | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <skipHours> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleTitle()

handleTitle | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <title> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleTtl()

handleTtl | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <ttl> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed.

◆ handleWebmaster()

handleWebmaster | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle the <webmaster> element for the feed.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $feed, $name, $tmp, et null.

◆ initialise()

initialise ( )
protected

Method to initialise the feed for parsing. Here we detect the version and advance the stream reader so that it is ready to parse feed elements.

Renvoie
void
Depuis
3.1.4

◆ processFeedEntry()

processFeedEntry | ( | FeedEntry | $entry,
 |  | \SimpleXMLElement | $el
 | ) |  |
protected

Method to handle a <item> element for the feed.

Paramètres
FeedEntry | $entry | The FeedEntry object being built from the parsed feed entry.
\SimpleXMLElement | $el | The current XML element object to handle.
Renvoie
void
Depuis
3.1.4

Références $author, $category, $link, $this, FeedEntry\addCategory(), FeedEntry\addLink(), et null.

◆ processPerson()

processPerson ( $data )
protected

Method to parse a string with person data and return a FeedPerson object.

Paramètres
string $data The string to parse for a person.
Renvoie
FeedPerson
Depuis
3.1.4

Références $data.

Documentation des champs

◆ $entryElementName

$entryElementName = 'item'
protected

◆ $version

$version
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RssParser.php


Joomla CMS: Référence de la classe Feed

  • Joomla
  • CMS
  • Feed
  • Feed
Fonctions membres publiques | Attributs protégés
Référence de la classe Feed
+ Graphe d'héritage de Feed:

Fonctions membres publiques

__get ($name)
__set ($name, $value)
addCategory ($name, $uri='')
addContributor ($name, $email, $uri=null, $type=null)
addEntry (FeedEntry $entry)
count ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
removeCategory ($name)
removeContributor (FeedPerson $contributor)
removeEntry (FeedEntry $entry)
setAuthor ($name, $email, $uri=null, $type=null)
reverseItems ()

Attributs protégés

$properties
$entries = array()

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to return values for feed properties.

Paramètres
string $name The name of the property.
Renvoie
mixed
Depuis
3.1.4

Références $name, et null.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Magic method to set values for feed properties.

Paramètres
string | $name | The name of the property.
mixed | $value | The value to set for the property.
Renvoie
void
Depuis
3.1.4

Références $name, $this, $value, et null.

◆ addCategory()

addCategory | ( | $name,
 |  | $uri = ''
 | ) |

Method to add a category to the feed object.

Paramètres
string | $name | The name of the category to add.
string | $uri | The optional URI for the category to add.
Renvoie
Feed
Depuis
3.1.4

Références $name, $this, et $uri.

◆ addContributor()

addContributor | ( | $name,
 |  | $email,
 |  | $uri = null,
 |  | $type = null
 | ) |

Method to add a contributor to the feed object.

Paramètres
string | $name | The full name of the person to add.
string | $email | The email address of the person to add.
string | $uri | The optional URI for the person to add.
string | $type | The optional type of person to add.
Renvoie
Feed
Depuis
3.1.4

Références $c, $name, $this, $type, et $uri.

◆ addEntry()

addEntry ( FeedEntry $entry )

Method to add an entry to the feed object.

Paramètres
FeedEntry $entry The entry object to add.
Renvoie
Feed
Depuis
3.1.4

Références $this.

◆ count()

count ( )

Returns a count of the number of entries in the feed.

This method is here to implement the Countable interface. You can call it by doing count($feed) rather than $feed->count();

Renvoie
integer number of entries in the feed.

◆ offsetExists()

offsetExists ( $offset )

Whether or not an offset exists. This method is executed when using isset() or empty() on objects implementing ArrayAccess.

Paramètres
mixed $offset An offset to check for.
Renvoie
boolean
Voir également
ArrayAccess::offsetExists()
Depuis
3.1.4

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Returns the value at specified offset.

Paramètres
mixed $offset The offset to retrieve.
Renvoie
mixed The value at the offset.
Voir également
ArrayAccess::offsetGet()
Depuis
3.1.4

Références Joomla\Database\Query\$offset.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Assigns a value to the specified offset.

Paramètres
mixed | $offset | The offset to assign the value to.
FeedEntry | $value | The JFeedEntry to set.
Renvoie
boolean
Voir également
ArrayAccess::offsetSet()
Depuis
3.1.4
Exceptions

Références Joomla\Database\Query\$offset, $this, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Unsets an offset.

Paramètres
mixed $offset The offset to unset.
Renvoie
void
Voir également
ArrayAccess::offsetUnset()
Depuis
3.1.4

Références Joomla\Database\Query\$offset.

◆ removeCategory()

removeCategory ( $name )

Method to remove a category from the feed object.

Paramètres
string $name The name of the category to remove.
Renvoie
Feed
Depuis
3.1.4

Références $name, et $this.

◆ removeContributor()

removeContributor ( FeedPerson $contributor )

Method to remove a contributor from the feed object.

Paramètres
FeedPerson $contributor The person object to remove.
Renvoie
Feed
Depuis
3.1.4

Références $c, et $this.

◆ removeEntry()

removeEntry ( FeedEntry $entry )

Method to remove an entry from the feed object.

Paramètres
FeedEntry $entry The entry object to remove.
Renvoie
Feed
Depuis
3.1.4

Références $this.

◆ reverseItems()

reverseItems ( )

Method to reverse the items if display is set to 'oldest first'

Renvoie
Feed
Depuis
3.1.4

Références $this.

◆ setAuthor()

setAuthor | ( | $name,
 |  | $email,
 |  | $uri = null,
 |  | $type = null
 | ) |

Shortcut method to set the author for the feed object.

Paramètres
string | $name | The full name of the person to set.
string | $email | The email address of the person to set.
string | $uri | The optional URI for the person to set.
string | $type | The optional type of person to set.
Renvoie
Feed
Depuis
3.1.4

Références $author, $name, $this, $type, et $uri.

Documentation des champs

◆ $entries

$entries = array()
protected

◆ $properties

$properties
protected
Valeur initiale :
= array(
'uri' => '',
'title' => '',
'updatedDate' => '',
'description' => '',
'categories' => array(),
'contributors' => array(),
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • Feed.php


Joomla CMS: Référence de la classe FeedEntry

  • Joomla
  • CMS
  • Feed
  • FeedEntry
Fonctions membres publiques | Attributs protégés
Référence de la classe FeedEntry

Fonctions membres publiques

__get ($name)
__set ($name, $value)
addCategory ($name, $uri='')
addContributor ($name, $email, $uri=null, $type=null)
addLink (FeedLink $link)
removeCategory ($name)
removeContributor (FeedPerson $contributor)
removeLink (FeedLink $link)
setAuthor ($name, $email, $uri=null, $type=null)

Attributs protégés

$properties

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to return values for feed entry properties.

Paramètres
string $name The name of the property.
Renvoie
mixed
Depuis
3.1.4

Références $name, et null.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Magic method to set values for feed properties.

Paramètres
string | $name | The name of the property.
mixed | $value | The value to set for the property.
Renvoie
void
Depuis
3.1.4

Références $name, $this, $value, et null.

◆ addCategory()

addCategory | ( | $name,
 |  | $uri = ''
 | ) |

Method to add a category to the feed entry object.

Paramètres
string | $name | The name of the category to add.
string | $uri | The optional URI for the category to add.
Renvoie
FeedEntry
Depuis
3.1.4

Références $name, $this, et $uri.

Référencé par RssParser\processFeedEntry().

◆ addContributor()

addContributor | ( | $name,
 |  | $email,
 |  | $uri = null,
 |  | $type = null
 | ) |

Method to add a contributor to the feed entry object.

Paramètres
string | $name | The full name of the person to add.
string | $email | The email address of the person to add.
string | $uri | The optional URI for the person to add.
string | $type | The optional type of person to add.
Renvoie
FeedEntry
Depuis
3.1.4

Références $c, $name, $this, $type, et $uri.

◆ addLink()

addLink ( FeedLink $link )

Method to add a link to the feed entry object.

Paramètres
FeedLink $link The link object to add.
Renvoie
FeedEntry
Depuis
3.1.4

Références $link, et $this.

Référencé par RssParser\processFeedEntry().

◆ removeCategory()

removeCategory ( $name )

Method to remove a category from the feed entry object.

Paramètres
string $name The name of the category to remove.
Renvoie
FeedEntry
Depuis
3.1.4

Références $name, et $this.

◆ removeContributor()

removeContributor ( FeedPerson $contributor )

Method to remove a contributor from the feed entry object.

Paramètres
FeedPerson $contributor The person object to remove.
Renvoie
FeedEntry
Depuis
3.1.4

Références $c, et $this.

◆ removeLink()

removeLink ( FeedLink $link )

Method to remove a link from the feed entry object.

Paramètres
FeedLink $link The link object to remove.
Renvoie
FeedEntry
Depuis
3.1.4

Références $link, et $this.

◆ setAuthor()

setAuthor | ( | $name,
 |  | $email,
 |  | $uri = null,
 |  | $type = null
 | ) |

Shortcut method to set the author for the feed entry object.

Paramètres
string | $name | The full name of the person to set.
string | $email | The email address of the person to set.
string | $uri | The optional URI for the person to set.
string | $type | The optional type of person to set.
Renvoie
FeedEntry
Depuis
3.1.4

Références $author, $name, $this, $type, et $uri.

Documentation des champs

◆ $properties

$properties
protected
Valeur initiale :
= array(
'uri' => '',
'title' => '',
'updatedDate' => '',
'content' => '',
'categories' => array(),
'contributors' => array(),
'links' => array(),
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedEntry.php


Joomla CMS: Référence de la classe FeedFactory

  • Joomla
  • CMS
  • Feed
  • FeedFactory
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe FeedFactory

Fonctions membres publiques

getFeed ($uri)
registerParser ($tagName, $className, $overwrite=false)
getParsers ()

Attributs protégés

$parsers = array('rss' => 'Joomla\\CMS\\Feed\\Parser\\RssParser', 'feed' => 'Joomla\\CMS\\Feed\\Parser\\AtomParser')

Fonctions membres privées

_fetchFeedParser ($type, \XMLReader $reader)

Description détaillée

Feed factory class.

Depuis
3.1.4

Documentation des fonctions membres

◆ _fetchFeedParser()

_fetchFeedParser | ( |  | $type,
 |  | \XMLReader | $reader
 | ) |  |
private

Method to return a new JFeedParser object based on the registered parsers and a given type.

Paramètres
string | $type | The name of parser to return.
\XMLReader | $reader | The XMLReader instance for the feed.
Renvoie
FeedParser
Depuis
3.1.4
Exceptions

Références $type.

◆ getFeed()

getFeed ( $uri )

Method to load a URI into the feed reader for parsing.

Paramètres
string $uri The URI of the feed to load. Idn uris must be passed already converted to punycode.
Renvoie
Feed
Depuis
3.1.4
Exceptions

Références $options, $uri, HttpFactory\getHttp(), et null.

◆ getParsers()

getParsers ( )

Method to get the registered Parsers

Renvoie
array
Depuis
4.0.0

◆ registerParser()

registerParser | ( | $tagName,
 |  | $className,
 |  | $overwrite = false
 | ) |

Method to register a FeedParser class for a given root tag name.

Paramètres
string | $tagName | The root tag name for which to register the parser class.
string | $className | The FeedParser class name to register for a root tag name.
boolean | $overwrite | True to overwrite the parser class if one is already registered.
Renvoie
FeedFactory
Depuis
3.1.4
Exceptions

Références $className, $tagName, et $this.

Documentation des champs

◆ $parsers

$parsers = array('rss' => 'Joomla\\CMS\\Feed\\Parser\\RssParser', 'feed' => 'Joomla\\CMS\\Feed\\Parser\\AtomParser')
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedFactory.php


Joomla CMS: Référence de la classe FeedLink

  • Joomla
  • CMS
  • Feed
  • FeedLink
Fonctions membres publiques | Champs de données
Référence de la classe FeedLink

Fonctions membres publiques

__construct ($uri=null, $relation=null, $type=null, $language=null, $title=null, $length=null)

Champs de données

$uri
$relation
$type
$language
$title
$length

Description détaillée

Feed Link class.

Depuis
3.1.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $uri = null,
 |  | $relation = null,
 |  | $type = null,
 |  | $language = null,
 |  | $title = null,
 |  | $length = null
 | ) |

Constructor.

Paramètres
string | $uri | The URI to the linked resource.
string | $relation | The relationship between the feed and the linked resource.
string | $type | The resource type.
string | $language | The language of the resource found at the given URI.
string | $title | The title of the resource.
integer | $length | The length of the resource in bytes.
Depuis
3.1.4
Exceptions

Références $language, $title, $type, $uri, et language.

Documentation des champs

◆ $language

$language

◆ $length

$length

◆ $relation

$relation

◆ $title

$title

◆ $type

$type

◆ $uri

$uri
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedLink.php


Joomla CMS: Référence de la classe FeedParser

  • Joomla
  • CMS
  • Feed
  • FeedParser
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FeedParser
+ Graphe d'héritage de FeedParser:
AtomParser RssParser

Fonctions membres publiques

__construct (\XMLReader $stream, InputFilter $inputFilter=null)
parse ()
registerNamespace ($prefix, NamespaceParserInterface $namespace)

Fonctions membres protégées

initialise ()
processElement (Feed $feed, \SimpleXMLElement $el, array $namespaces)
fetchNamespace ($prefix)
moveToNextElement ($name=null)
moveToClosingElement ()

Attributs protégés

$entryElementName = 'entry'
$namespaces = array()
$stream
$inputFilter

Description détaillée

Feed Parser class.

Depuis
3.1.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \XMLReader | $stream,
 |  | InputFilter | $inputFilter = null
 | ) |  |

Constructor.

Paramètres
\XMLReader | $stream | The XMLReader stream object for the feed.
InputFilter | $inputFilter | The InputFilter object to be used
Depuis
3.1.4

Références Laminas\Diactoros\$stream, et InputFilter\getInstance().

Documentation des fonctions membres

◆ fetchNamespace()

fetchNamespace ( $prefix )
protected

Method to get a namespace object for a given namespace prefix.

Paramètres
string $prefix The XML prefix for which to fetch the namespace object.
Renvoie
mixed NamespaceParserInterface or false if none exists.
Depuis
3.1.4

Références $className, $prefix, et $this.

◆ initialise()

initialise ( )
abstractprotected

Method to initialise the feed for parsing. If child parsers need to detect versions or other such things this is where you'll want to implement that logic.

Renvoie
void
Depuis
3.1.4

◆ moveToClosingElement()

moveToClosingElement ( )
protected

Method to move the stream parser to the closing XML node of the current element.

Renvoie
void
Depuis
3.1.4
Exceptions

Références $name.

◆ moveToNextElement()

moveToNextElement ( $name = null )
protected

Method to move the stream parser to the next XML element node.

Paramètres
string $name The name of the element for which to move the stream forward until is found.
Renvoie
boolean True if the stream parser is on an XML element node.
Depuis
3.1.4

Références $name.

◆ parse()

parse ( )

Method to parse the feed into a JFeed object.

Renvoie
Feed
Depuis
3.1.4

Références $feed, $namespace, $prefix, et $uri.

◆ processElement()

processElement | ( | Feed | $feed,
 |  | \SimpleXMLElement | $el,
 |  | array | $namespaces
 | ) |  |
protected

Method to parse a specific feed element.

Paramètres
Feed | $feed | The Feed object being built from the parsed feed.
\SimpleXMLElement | $el | The current XML element object to handle.
array | $namespaces | The array of relevant namespace objects to process for the element.
Renvoie
void
Depuis
3.1.4

Références $feed, $method, $namespace, et $this.

◆ registerNamespace()

registerNamespace | ( |  | $prefix,
 |  | NamespaceParserInterface | $namespace
 | ) |  |

Method to register a namespace handler object.

Paramètres
string | $prefix | The XML namespace prefix for which to register the namespace object.
NamespaceParserInterface | $namespace | The namespace object to register.
Renvoie
FeedParser
Depuis
3.1.4

Références $namespace, $prefix, et $this.

Documentation des champs

◆ $entryElementName

$entryElementName = 'entry'
protected

◆ $inputFilter

$inputFilter
protected

◆ $namespaces

$namespaces = array()
protected

◆ $stream

$stream
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedParser.php


Joomla CMS: Référence de la classe FeedPerson

  • Joomla
  • CMS
  • Feed
  • FeedPerson
Fonctions membres publiques | Champs de données
Référence de la classe FeedPerson

Fonctions membres publiques

__construct ($name=null, $email=null, $uri=null, $type=null)

Champs de données

$email
$name
$type
$uri

Description détaillée

Feed Person class.

Depuis
3.1.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $name = null,
 |  | $email = null,
 |  | $uri = null,
 |  | $type = null
 | ) |

Constructor.

Paramètres
string | $name | The full name of the person.
string | $email | The email address of the person.
string | $uri | The URI for the person.
string | $type | The type of person.
Depuis
3.1.4

Références $name, $type, $uri, et name.

Documentation des champs

◆ $email

$email

◆ $name

$name

◆ $type

$type

◆ $uri

$uri
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedPerson.php


Joomla CMS: Référence de l'interface FieldsServiceInterface

  • Joomla
  • CMS
  • Fields
  • FieldsServiceInterface
Fonctions membres publiques
Référence de l'interface FieldsServiceInterface
+ Graphe d'héritage de FieldsServiceInterface:
LegacyComponent ContactComponent ContentComponent UsersComponent

Fonctions membres publiques

validateSection ($section, $item=null)
getContexts ()

Description détaillée

The fields service.

Depuis
4.0.0

Documentation des fonctions membres

◆ getContexts()

getContexts ( )

Returns valid contexts.

Renvoie
array
Depuis
4.0.0

Implémenté dans LegacyComponent, ContentComponent, ContactComponent, et UsersComponent.

◆ validateSection()

validateSection | ( | $section,
 |  | $item = null
 | ) |

Returns a valid section for the given section. If it is not valid then null is returned.

Paramètres
string | $section | The section to get the mapping for
object | $item | The item
Renvoie
string|null The new section
Depuis
4.0.0

Implémenté dans LegacyComponent, ContentComponent, ContactComponent, et UsersComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FieldsServiceInterface.php


Joomla CMS: Référence de la classe StreamString

  • Joomla
  • CMS
  • Filesystem
  • Streams
  • StreamString
Fonctions membres publiques | Attributs protégés
Référence de la classe StreamString

Fonctions membres publiques

stream_open ($path, $mode, $options, &$openedPath)
stream_stat ()
url_stat ($path, $flags=0)
stream_read ($count)
stream_write ($data)
stream_tell ()
stream_eof ()
stream_seek ($offset, $whence)
stream_flush ()

Attributs protégés

$currentString
$path
$mode
$options
$openedPath
$pos
$len
$stat

Description détaillée

String Stream Wrapper

This class allows you to use a PHP string in the same way that you would normally use a regular stream wrapper

Depuis
1.7.0

Documentation des fonctions membres

◆ stream_eof()

stream_eof ( )

End of field check

Renvoie
boolean True if at end of field.
Depuis
1.7.0

◆ stream_flush()

stream_flush ( )

Stream flush, always returns true.

Renvoie
boolean
Depuis
1.7.0
Note
Data storage is not supported

◆ stream_open()

stream_open | ( |  | $path,
 |  |  | $mode,
 |  |  | $options,
 |  | & | $openedPath
 | ) |  |

Method to open a file or URL.

Paramètres
string | $path | The stream path.
string | $mode | Not used.
integer | $options | Not used.
string | $openedPath | Not used.
Renvoie
boolean
Depuis
1.7.0

Références $path, et StringController\getRef().

◆ stream_read()

stream_read ( $count )

Method to read a given number of bytes starting at the current position and moving to the end of the string defined by the current position plus the given number.

Paramètres
integer $count Bytes of data from the current position should be returned.
Renvoie
string
Depuis
1.7.0

https://www.php.net/manual/en/streamwrapper.stream-read.php

Références $count, et $result.

◆ stream_seek()

stream_seek | ( | $offset,
 |  | $whence
 | ) |

Stream offset

Paramètres
integer | $offset | The starting offset.
integer | $whence | SEEK_SET, SEEK_CUR, SEEK_END
Renvoie
boolean True on success.
Depuis
1.7.0

Références Joomla\Database\Query\$offset.

◆ stream_stat()

stream_stat ( )

Method to retrieve information from a file resource

Renvoie
array

1.7.0

◆ stream_tell()

stream_tell ( )

Method to get the current position

Renvoie
integer The position
Depuis
1.7.0

◆ stream_write()

stream_write ( $data )

Stream write, always returning false.

Paramètres
string $data The data to write.
Renvoie
boolean
Depuis
1.7.0
Note
Updating the string is not supported.

◆ url_stat()

url_stat | ( | $path,
 |  | $flags = 0
 | ) |

Method to retrieve information about a file.

Paramètres
string | $path | File path or URL to stat
integer | $flags | Additional flags set by the streams API
Renvoie
array

1.7.0

Références $now, $path, et StringController\getRef().

Documentation des champs

◆ $currentString

$currentString
protected

◆ $len

$len
protected

◆ $mode

$mode
protected

◆ $openedPath

$openedPath
protected

◆ $options

$options
protected

◆ $path

$path
protected

◆ $pos

$pos
protected

◆ $stat

$stat
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StreamString.php


Joomla CMS: Référence de la classe StringController

  • Joomla
  • CMS
  • Filesystem
  • Support
  • StringController
Fonctions membres publiques
Référence de la classe StringController

Fonctions membres publiques

_getArray ()
createRef ($reference, &$string)
getRef ($reference)

Description détaillée

String Controller

Depuis
1.7.0

Documentation des fonctions membres

◆ _getArray()

_getArray ( )

Defines a variable as an array

Renvoie
array
Depuis
1.7.0

Références $strings.

◆ createRef()

createRef | ( |  | $reference,
 |  | & | $string
 | ) |  |

Create a reference

Paramètres
string | $reference | The key
string | $string | The value
Renvoie
void
Depuis
1.7.0

◆ getRef()

getRef ( $reference )

Get reference

Paramètres
string $reference The key for the reference.
Renvoie
mixed False if not set, reference if it exists
Depuis
1.7.0

Référencé par StreamString\stream_open(), et StreamString\url_stat().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/Support/StringController.php


Joomla CMS: Référence de la classe File

  • Joomla
  • CMS
  • Filesystem
  • File
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe File

Fonctions membres publiques statiques

static | getExt ($file)
static | stripExt ($file)
static | makeSafe ($file)
static | copy ($src, $dest, $path=null, $useStreams=false)
static | invalidateFileCache ($filepath, $force=true)
static | canFlushFileCache ()
static | delete ($file)
static | move ($src, $dest, $path='', $useStreams=false)
static | write ($file, $buffer, $useStreams=false)
static | append ($file, $buffer, $useStreams=false)
static | upload ($src, $dest, $useStreams=false, $allowUnsafe=false, $safeFileOptions=array())
static | exists ($file)

Attributs protégés statiques

static $canFlushFileCache

Description détaillée

A File handling class

Depuis
1.7.0

Documentation des fonctions membres

◆ append()

static append | ( | $file,
 |  | $buffer,
 |  | $useStreams = false
 | ) |
static

Append contents to a file

Paramètres
string | $file | The full file path
string | $buffer | The buffer to write
boolean | $useStreams | Use streams
Renvoie
boolean True on success
Depuis
3.6.0

Références $buffer, Laminas\Diactoros\$stream, Log\add(), Path\clean(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

◆ canFlushFileCache()

static canFlushFileCache ( )
static

First we check if opcache is enabled Then we check if the opcache_invalidate function is available Lastly we check if the host has restricted which scripts can use opcache_invalidate using opcache.restrict_api.

‘$_SERVER['SCRIPT_FILENAME’]approximates the origin file's path, butrealpath() is necessary becauseSCRIPT_FILENAMEcan be a relative path when run from CLI. If the host has this set, check whether the path inopcache.restrict_api` matches the beginning of the path of the origin file.

Renvoie
boolean TRUE if we can proceed to use opcache_invalidate to flush a file from the OPCache
Depuis
4.0.1

◆ copy()

static copy | ( | $src,
 |  | $dest,
 |  | $path = null,
 |  | $useStreams = false
 | ) |
static

Copies a file

Paramètres
string | $src | The path to the source file
string | $dest | The path to the destination file
string | $path | An optional base path to prefix to the file names
boolean | $useStreams | True to use streams
Renvoie
boolean True on success
Depuis
1.7.0

Références $path, Laminas\Diactoros\$stream, Log\add(), Path\clean(), Folder\create(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

Référencé par TemplateModel\child(), TemplateModel\copy(), LocalAdapter\copyFile(), TemplateModel\copyFile(), Installer\copyFiles(), et TemplateModel\createTemplateOverride().

◆ delete()

static delete ( $file )
static

Delete a file or array of files

Paramètres
mixed $file The file name or an array of file names
Renvoie
boolean True on success
Depuis
1.7.0

Try making the file writable first. If it's read-only, it can't be deleted on Windows, even if the parent folder is writable

Invalidate the OPCache for the file before actually deleting it

Voir également
https://github.com/joomla/joomla-cms/pull/32915#issuecomment-812865635
https://www.php.net/manual/en/function.opcache-invalidate.php#116372

In case of restricted permissions we delete it one way or the other as long as the owner is either the webserver or the ftp

Références Log\add(), Path\clean(), elseif, ClientHelper\getCredentials(), FtpClient\getInstance(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

Référencé par Installer\abort(), Patcher\apply(), LocalAdapter\checkContent(), UpdateModel\cleanUp(), InstallerHelper\cleanupInstall(), LocalAdapter\copyFolder(), UpdateModel\createUpdateFile(), LocalAdapter\delete(), Folder\delete(), ConfigurationModel\deleteConfiguration(), TemplateModel\deleteFile(), CleanupModel\deleteInstallationFolder(), UpdateModel\downloadPackage(), FileAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), TracksModel\getContent(), OverridesModel\getOverrides(), Path\isOwner(), LocalAdapter\moveFolder(), Installer\parseFiles(), FileAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), Installer\removeFiles(), UpdateModel\removePackageFiles(), et UpdateCoreCommand\updateJoomlaCore().

◆ exists()

static exists ( $file )
static

Wrapper for the standard file_exists function

Paramètres
string $file File path
Renvoie
boolean True if path is a file
Depuis
1.7.0

Références Path\clean().

Référencé par MessageController\action(), UpdateController\captive(), UpdateModel\captiveFileExists(), DatabaseHelper\checkRemoteDbHost(), TemplateModel\child(), UpdateModel\cleanUp(), TemplateModel\copy(), TemplateModel\createTemplateOverride(), UpdateModel\createUpdateFile(), LocalAdapter\delete(), TemplateModel\fixTemplateName(), ContenthistoryHelper\getFormFile(), ConfigComponentsField\getOptions(), MessagesModel\onProcessList(), UpdateModel\preparePreUpdate(), UpdateModel\removePackageFiles(), LocalAdapter\updateFile(), DatabaseHelper\validateConnectionParameters(), et ApplicationModel\validateDbConnection().

◆ getExt()

static getExt ( $file )
static

Gets the extension of a file name

Paramètres
string $file The file name
Renvoie
string The file extension
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par TemplateHelper\canUpload(), LocalAdapter\checkContent(), ApiModel\createFile(), TemplateModel\createTemplateOverride(), MailTemplate\getAttachmentName(), LocalAdapter\getPathInformation(), TemplateModel\getSafeName(), LocalAdapter\getSafeName(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), HTMLHelper\includeRelativeFiles(), Stream\open(), et ApiModel\updateFile().

◆ invalidateFileCache()

static invalidateFileCache | ( | $filepath,
 |  | $force = true
 | ) |
static

Invalidate opcache for a newly written/deleted file immediately, if opcache* functions exist and if this was a PHP file.

Paramètres
string | $filepath | The path to the file just written to, to flush from opcache
boolean | $force | If set to true, the script will be invalidated regardless of whether invalidation is necessary
Renvoie
boolean TRUE if the opcode cache for script was invalidated/nothing to invalidate, or FALSE if the opcode cache is disabled or other conditions returning FALSE from opcache_invalidate (like file not found).
Depuis
4.0.1

Référencé par FileStorage\__construct(), FileStorage\_checkExpire(), FileStorage\_deleteFolder(), UpdateModel\createUpdateFile(), FileStorage\gc(), et FileStorage\remove().

◆ makeSafe()

static makeSafe ( $file )
static

Makes file name safe to use

Paramètres
string $file The name of the file [not full path]
Renvoie
string The sanitised string
Depuis
1.7.0

Référencé par TemplateHelper\canUpload(), MediaHelper\canUpload(), ContenthistoryHelper\getFormFile(), LocalAdapter\getSafeName(), et TemplateModel\uploadFile().

◆ move()

static move | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $useStreams = false
 | ) |
static

Moves a file

Paramètres
string | $src | The path to the source file
string | $dest | The path to the destination file
string | $path | An optional base path to prefix to the file names
boolean | $useStreams | True to use streams
Renvoie
boolean True on success
Depuis
1.7.0

Références $path, Laminas\Diactoros\$stream, Text\_(), Log\add(), Path\clean(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

Référencé par CleanupModel\deleteInstallationFolder(), TemplateModel\fixTemplateName(), InstallerScript\moveCliFiles(), et LocalAdapter\moveFile().

◆ stripExt()

static stripExt ( $file )
static

Strips the last extension off of a file name

Paramètres
string $file The file name
Renvoie
string The file name without the extension
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par TemplateModel\createTemplateOverride(), PluginAdapter\discover(), MailTemplate\getAttachmentName(), MenusHelper\getPresets(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), HTMLHelper\includeRelativeFiles(), Indexer\index(), Installer\parseXMLInstallFile(), et ConfigurationModel\setup().

◆ upload()

static upload | ( | $src,
 |  | $dest,
 |  | $useStreams = false,
 |  | $allowUnsafe = false,
 |  | $safeFileOptions = array()
 | ) |
static

Moves an uploaded file to a destination folder

Paramètres
string | $src | The name of the php (temporary) uploaded file
string | $dest | The path (including filename) to move the uploaded file to
boolean | $useStreams | True to use streams
boolean | $allowUnsafe | Allow the upload of unsafe files
array | $safeFileOptions | Options to InputFilter::isSafeFile
Renvoie
boolean True on success
Depuis
1.7.0

Références $baseDir, Laminas\Diactoros\$stream, Text\_(), Log\add(), Path\clean(), Folder\create(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), InputFilter\isSafeFile(), JPATH_ROOT, Path\setPermissions(), Text\sprintf(), et Log\WARNING.

Référencé par InstallModel\_getPackageFromUpload(), UpdateModel\upload(), et TemplateModel\uploadFile().

◆ write()

static write | ( | $file,
 |  | $buffer,
 |  | $useStreams = false
 | ) |
static

Write contents to a file

Paramètres
string | $file | The full file path
string | $buffer | The buffer to write
boolean | $useStreams | Use streams
Renvoie
boolean True on success
Depuis
1.7.0

Références $buffer, Laminas\Diactoros\$stream, Log\add(), Path\clean(), Folder\create(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

Référencé par Patcher\apply(), LocalAdapter\checkContent(), DatabaseHelper\checkRemoteDbHost(), TemplateModel\child(), LocalAdapter\createFile(), UpdateModel\createUpdateFile(), InstallerHelper\downloadPackage(), UpdateModel\downloadPackage(), TemplateModel\fixTemplateName(), Path\isOwner(), FileStorage\save(), TemplateModel\save(), LanguageHelper\saveToIniFile(), LocalAdapter\updateFile(), et ApplicationModel\writeConfigFile().

Documentation des champs

◆ $canFlushFileCache

$canFlushFileCache
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/File.php


Joomla CMS: Référence de la classe FilesystemHelper

  • Joomla
  • CMS
  • Filesystem
  • FilesystemHelper
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe FilesystemHelper

Fonctions membres publiques statiques

static | remotefsize ($url)
static | ftpChmod ($url, $mode)
static | getWriteModes ()
static | getSupported ()
static | getTransports ()
static | getFilters ()
static | isJoomlaStream ($streamname)
static | fileUploadMaxSize ($unitOutput=true)

Fonctions membres privées statiques

static | parseSize ($size)
static | parseSizeUnit ($maxSize)

Description détaillée

File system helper

Holds support functions for the filesystem, particularly the stream

Depuis
1.7.0

Documentation des fonctions membres

◆ fileUploadMaxSize()

static fileUploadMaxSize ( $unitOutput = true )
static

Calculates the maximum upload file size and returns string with unit or the size in bytes

Call it with JFilesystemHelper::fileUploadMaxSize();

Paramètres
bool $unitOutput This parameter determines whether the return value should be a string with a unit
Renvoie
float|string The maximum upload size of files with the appropriate unit or in bytes
Depuis
3.4

◆ ftpChmod()

static ftpChmod | ( | $url,
 |  | $mode
 | ) |
static

Quick FTP chmod

Paramètres
string | $url | Link identifier
integer | $mode | The new permissions, given as an octal value.
Renvoie
mixed

1.7.0

Références $mode, $path, $url, et $user.

Référencé par Stream\chmod().

◆ getFilters()

static getFilters ( )
static

Returns a list of filters

Renvoie
array
Depuis
1.7.0

◆ getSupported()

static getSupported ( )
static

Stream and Filter Support Operations

Returns the supported streams, in addition to direct file access Also includes Joomla! streams as well as PHP streams

Renvoie
array Streams
Depuis
1.7.0

◆ getTransports()

static getTransports ( )
static

Returns a list of transports

Renvoie
array
Depuis
1.7.0

◆ getWriteModes()

static getWriteModes ( )
static

Modes that require a write operation

Renvoie
array
Depuis
1.7.0

Référencé par Stream\_getFilename().

◆ isJoomlaStream()

static isJoomlaStream ( $streamname )
static

Determine if a stream is a Joomla stream.

Paramètres
string $streamname The name of a stream
Renvoie
boolean True for a Joomla Stream
Depuis
1.7.0

Référencé par Stream\open().

◆ parseSize()

static parseSize ( $size )
staticprivate

Returns the size in bytes without the unit for the comparison

Paramètres
string $size The size which is received from the PHP settings
Renvoie
float The size in bytes without the unit
Depuis
3.4

Références $return, et $size.

◆ parseSizeUnit()

static parseSizeUnit ( $maxSize )
staticprivate

Creates the rounded size of the size with the appropriate unit

Paramètres
float $maxSize The maximum size which is allowed for the uploads
Renvoie
string String with the size and the appropriate unit
Depuis
3.4

Références $base, et $maxSize.

◆ remotefsize()

static remotefsize ( $url )
static

Remote file size function for streams that don't support it

Paramètres
string $url Link identifier
Renvoie
mixed

1.7.0

Références $path, $url, et $user.

Référencé par Stream\filesize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FilesystemHelper.php


Joomla CMS: Référence de la classe Folder

  • Joomla
  • CMS
  • Filesystem
  • Folder
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Folder

Fonctions membres publiques statiques

static | copy ($src, $dest, $path='', $force=false, $useStreams=false)
static | create ($path='', $mode=0755)
static | delete ($path)
static | move ($src, $dest, $path='', $useStreams=false)
static | exists ($path)
static | files ( $path, $filter='.', $recurse=false, $full=false, $exclude=array('.svn', 'CVS', '.DS_Store', '__MACOSX'), $excludeFilter=array('^\..*', '.*~'), $naturalSort=false)
static | folders ( $path, $filter='.', $recurse=false, $full=false, $exclude=array('.svn', 'CVS', '.DS_Store', '__MACOSX'), $excludeFilter=array('^\..*'))
static | listFolderTree ($path, $filter, $maxLevel=3, $level=0, $parent=0)
static | makeSafe ($path)

Fonctions membres protégées statiques

static _items ($path, $filter, $recurse, $full, $exclude, $excludeFilterString, $findFiles)

Description détaillée

A Folder handling class

Depuis
1.7.0

Documentation des fonctions membres

◆ _items()

static _items | ( | $path,
 |  | $filter,
 |  | $recurse,
 |  | $full,
 |  | $exclude,
 |  | $excludeFilterString,
 |  | $findFiles
 | ) |
staticprotected

Function to read the files/folders in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for file names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the file.
array | $exclude | Array with names of files which should not be shown in the result.
string | $excludeFilterString | Regexp of files to exclude
boolean | $findFiles | True to read the files, false to read the folders
Renvoie
array Files.
Depuis
1.7.0

Références $path.

◆ copy()

static copy | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $force = false,
 |  | $useStreams = false
 | ) |
static

Copy a folder.

Paramètres
string | $src | The path to the source folder.
string | $dest | The path to the destination folder.
string | $path | An optional base path to prefix to the file names.
boolean | $force | Force copy.
boolean | $useStreams | Optionally force folder/file overwrites.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $path, Laminas\Diactoros\$stream, Path\clean(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, null, et Path\removeRoot().

Référencé par TemplateModel\copy(), Installer\copyFiles(), UpdateCoreCommand\copyFileTo(), LocalAdapter\copyFolder(), et LocalAdapter\moveFolder().

◆ create()

static create | ( | $path = '',
 |  | $mode = 0755
 | ) |
static

Create a folder – and all necessary parent folders.

Paramètres
string | $path | A path to create from the base path.
integer | $mode | Directory permissions to set for folders created. 0755 by default.
Renvoie
boolean True if successful.
Depuis
1.7.0

Références $mode, $path, Text\_(), Log\add(), Path\clean(), ClientHelper\getCredentials(), FtpClient\getInstance(), JPATH_ROOT, null, et Log\WARNING.

Référencé par TemplateModel\child(), File\copy(), TemplateModel\copy(), FileAdapter\copyBaseFiles(), ComponentAdapter\createExtensionRoot(), InstallerAdapter\createExtensionRoot(), LocalAdapter\createFolder(), TemplateModel\createFolder(), TemplateModel\createOverride(), TemplateModel\createTemplateOverride(), FileAdapter\finaliseInstall(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), FileStorage\save(), ApplicationModel\save(), File\upload(), File\write(), et DaemonApplication\writeProcessIdFile().

◆ delete()

static delete ( $path )
static

Delete a folder.

Paramètres
string $path The path to the folder to delete.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $folder, $path, Text\_(), Log\add(), Path\clean(), File\delete(), elseif, ClientHelper\getCredentials(), FtpClient\getInstance(), JPATH_ROOT, Text\sprintf(), et Log\WARNING.

Référencé par Installer\abort(), TemplateModel\child(), TemplateModel\cleanup(), InstallerHelper\cleanupInstall(), TemplateModel\copy(), LocalAdapter\delete(), TemplateModel\deleteFolder(), CleanupModel\deleteInstallationFolder(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), LocalAdapter\moveFolder(), Installer\parseFiles(), LanguageAdapter\removeExtensionFiles(), FileAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), Installer\removeFiles(), TemplateAdapter\setupUninstall(), et ComponentAdapter\setupUninstall().

◆ exists()

static exists ( $path )
static

Wrapper for the standard file_exists function

Paramètres
string $path Folder name relative to installation dir
Renvoie
boolean True if path is a folder
Depuis
1.7.0

Références $path, et Path\clean().

Référencé par TemplateModel\child(), TemplateModel\copy(), FileAdapter\copyBaseFiles(), TemplateModel\createOverride(), TemplateModel\createTemplateOverride(), LocalAdapter\delete(), PackageAdapter\finaliseUninstall(), Installer\findManifest(), MenusHelper\getPresets(), ChromestyleField\getTemplateModuleStyles(), Installer\install(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Installer\parseLanguages(), FileAdapter\populateFilesAndFolderList(), FileAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), Installer\removeFiles(), ApplicationModel\save(), LanguageAdapter\setupUninstall(), FolderPathExistsRule\test(), InstallerHelper\unpack(), et Installer\update().

◆ files()

static files | ( | $path,
 |  | $filter = '.',
 |  | $recurse = false,
 |  | $full = false,
 |  | $exclude = array('.svn', 'CVS', '.DS_Store', '__MACOSX'),
 |  | $excludeFilter = array('^\..*', '.*~'),
 |  | $naturalSort = false
 | ) |
static

Utility function to read the files in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for file names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the file.
array | $exclude | Array with names of files which should not be shown in the result.
array | $excludeFilter | Array of filter to exclude
boolean | $naturalSort | False for asort, true for natsort
Renvoie
array|boolean Files in the given folder.
Depuis
1.7.0

Références $path, Log\add(), Path\clean(), Text\sprintf(), et Log\WARNING.

Référencé par TemplateModel\createTemplateOverride(), InstallerHelper\detectType(), PluginAdapter\discover(), Installer\findManifest(), TemplateModel\fixTemplateName(), TracksModel\getContent(), LocalAdapter\getFiles(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), FilelistField\getOptions(), MenusHelper\getPresets(), ChromestyleField\getTemplateModuleStyles(), HelpModel\getToc(), MenutypesModel\getTypeOptionsFromLayouts(), ChangeSet\getUpdateFiles(), FieldsPlugin\onCustomFieldsGetTypes(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Installer\parseSchemaUpdates(), FileAdapter\populateFilesAndFolderList(), ModuleModel\preprocessForm(), UpdatesitesModel\rebuild(), StringsModel\refresh(), FileAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), Installer\setSchemaVersion(), ConfigurationModel\setup(), et InstallerHelper\unpack().

◆ folders()

static folders | ( | $path,
 |  | $filter = '.',
 |  | $recurse = false,
 |  | $full = false,
 |  | $exclude = array('.svn', 'CVS', '.DS_Store', '__MACOSX'),
 |  | $excludeFilter = array('^\..*')
 | ) |
static

Utility function to read the folders in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for folder names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the folders.
array | $exclude | Array with names of folders which should not be shown in the result.
array | $excludeFilter | Array with regular expressions matching folders which should not be shown in the result.
Renvoie
array Folders in the given folder.
Depuis
1.7.0

Références $path, Log\add(), Path\clean(), Text\sprintf(), et Log\WARNING.

Référencé par TemplateModel\createTemplateOverride(), ModuleAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), LocalAdapter\getFiles(), InstalledModel\getFolders(), MenutypesModel\getFolders(), InstallationApplication\getLocaliseAdmin(), FolderlistField\getOptions(), TemplateModel\getOverridesList(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromMvc(), LibraryAdapter\removeExtensionFiles(), Menu\store(), et InstallerHelper\unpack().

◆ listFolderTree()

static listFolderTree | ( | $path,
 |  | $filter,
 |  | $maxLevel = 3,
 |  | $level = 0,
 |  | $parent = 0
 | ) |
static

Lists folder in format suitable for tree display.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for folder names.
integer | $maxLevel | The maximum number of levels to recursively read, defaults to three.
integer | $level | The current level, optional.
integer | $parent | Unique identifier of the parent folder, if any.
Renvoie
array Folders in the given folder.
Depuis
1.7.0

Références $id, $name, $path, Path\clean(), et JPATH_ROOT.

◆ makeSafe()

static makeSafe ( $path )
static

Makes path name safe to use.

Paramètres
string $path The full path to sanitise.
Renvoie
string The sanitised string.
Depuis
1.7.0

Références $path.

Référencé par ContenthistoryHelper\getFormFile().

◆ move()

static move | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $useStreams = false
 | ) |
static

Moves a folder.

Paramètres
string | $src | The path to the source folder.
string | $dest | The path to the destination folder.
string | $path | An optional base path to prefix to the file names.
boolean | $useStreams | Optionally use streams.
Renvoie
mixed Error message on false or boolean true on success.
Depuis
1.7.0

Références $path, Laminas\Diactoros\$stream, Text\_(), Path\clean(), ClientHelper\getCredentials(), FtpClient\getInstance(), Factory\getStream(), JPATH_ROOT, et Text\sprintf().

Référencé par LocalAdapter\moveFolder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/Folder.php


Joomla CMS: Référence de la classe Patcher

  • Joomla
  • CMS
  • Filesystem
  • Patcher
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Patcher

Fonctions membres publiques

reset ()
apply ()
addFile ($filename, $root=JPATH_BASE, $strip=0)
add ($udiff, $root=JPATH_BASE, $strip=0)

Fonctions membres publiques statiques

static getInstance ()

Champs de données

const | SRC_FILE = '/^---\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'
const | DST_FILE = '/^\\+\\+\\+\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'
const | HUNK = '/@@ -(\\d+)(,(\\d+))?\\s+\\+(\\d+)(,(\\d+))?\\s+@@($)/A'
const | SPLIT = '/(\r\n)|(\r)|(\n)/'

Fonctions membres protégées

__construct ()
applyHunk (&$lines, $src, $dst, $srcLine, $srcSize, $dstLine, $dstSize)
& getSource ($src)
& getDestination ($dst, $src)

Fonctions membres protégées statiques

static | splitLines ($data)
static | findHeader (&$lines, &$src, &$dst)
static | findHunk (&$lines, &$srcLine, &$srcSize, &$dstLine, &$dstSize)

Attributs protégés

$sources = array()
$destinations = array()
$removals = array()
$patches = array()

Attributs protégés statiques

static $instance

Description détaillée

A Unified Diff Format Patcher class

This has been derived from the PhpPatcher version 0.1.1 written by Giuseppe Mazzotta 3.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor

The constructor is protected to force the use of FilesystemPatcher::getInstance()

Depuis
3.0.0

Documentation des fonctions membres

◆ add()

add | ( | $udiff,
 |  | $root = JPATH_BASE,
 |  | $strip = 0
 | ) |

Add a unified diff string to the patcher

Paramètres
string | $udiff | Unified diff input string
string | $root | The files root path
integer | $strip | The number of '/' to strip
Renvoie
Patcher $this for chaining
Depuis
3.0.0

Références $root, et $this.

◆ addFile()

addFile | ( | $filename,
 |  | $root = JPATH_BASE,
 |  | $strip = 0
 | ) |

Add a unified diff file to the patcher

Paramètres
string | $filename | Path to the unified diff file
string | $root | The files root path
integer | $strip | The number of '/' to strip
Renvoie
Patcher $this for chaining
Depuis
3.0.0

Références $root.

◆ apply()

apply ( )

Apply the patches

Renvoie
integer The number of files patched
Depuis
3.0.0
Exceptions

Références $buffer, $content, File\delete(), null, et File\write().

◆ applyHunk()

applyHunk | ( | & | $lines,
 |  |  | $src,
 |  |  | $dst,
 |  |  | $srcLine,
 |  |  | $srcSize,
 |  |  | $dstLine,
 |  |  | $dstSize
 | ) |  |
protected

Apply the patch

Paramètres
array | $lines | The udiff array of lines
string | $src | The source file
string | $dst | The destination file
string | $srcLine | The beginning of the patch for the source file
string | $srcSize | The size of the patch for the source file
string | $dstLine | The beginning of the patch for the destination file
string | $dstSize | The size of the patch for the destination file
Renvoie
void
Depuis
3.0.0
Exceptions

Références elseif, Path\removeRoot(), et Text\sprintf().

◆ findHeader()

static findHeader | ( | & | $lines,
 |  | & | $src,
 |  | & | $dst
 | ) |  |
staticprotected

Find the diff header

The internal array pointer of $lines is on the next line after the finding

Paramètres
array | $lines | The udiff array of lines
string | $src | The source file
string | $dst | The destination file
Renvoie
boolean TRUE in case of success, FALSE in case of failure
Depuis
3.0.0
Exceptions

◆ findHunk()

static findHunk | ( | & | $lines,
 |  | & | $srcLine,
 |  | & | $srcSize,
 |  | & | $dstLine,
 |  | & | $dstSize
 | ) |  |
staticprotected

Find the next hunk of difference

The internal array pointer of $lines is on the next line after the finding

Paramètres
array | $lines | The udiff array of lines
string | $srcLine | The beginning of the patch for the source file
string | $srcSize | The size of the patch for the source file
string | $dstLine | The beginning of the patch for the destination file
string | $dstSize | The size of the patch for the destination file
Renvoie
boolean TRUE in case of success, false in case of failure
Depuis
3.0.0
Exceptions

◆ getDestination()

& getDestination | ( | $dst,
 |  | $src
 | ) |
protected

Get the lines of a destination file

Paramètres
string | $dst | The path of a destination file
string | $src | The path of a source file
Renvoie
array The lines of the destination file
Depuis
3.0.0

◆ getInstance()

static getInstance ( )
static

Method to get a patcher

Renvoie
Patcher an instance of the patcher
Depuis
3.0.0

◆ getSource()

& getSource ( $src )
protected

Get the lines of a source file

Paramètres
string $src The path of a file
Renvoie
array The lines of the source file
Depuis
3.0.0

Références null.

◆ reset()

reset ( )

Reset the patcher

Renvoie
Patcher This object for chaining
Depuis
3.0.0

Références $this.

◆ splitLines()

static splitLines ( $data )
staticprotected

Separate CR or CRLF lines

Paramètres
string $data Input string
Renvoie
array The lines of the inputdestination file
Depuis
3.0.0

Références $data.

Documentation des champs

◆ $destinations

$destinations = array()
protected

◆ $instance

$instance
staticprotected

◆ $patches

$patches = array()
protected

◆ $removals

$removals = array()
protected

◆ $sources

$sources = array()
protected

◆ DST_FILE

const DST_FILE = '/^\\+\\+\\+\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'

Regular expression for searching destination files

◆ HUNK

const HUNK = '/@@ -(\\d+)(,(\\d+))?\\s+\\+(\\d+)(,(\\d+))?\\s+@@($)/A'

Regular expression for searching hunks of differences

◆ SPLIT

const SPLIT = '/(\r\n)|(\r)|(\n)/'

Regular expression for splitting lines

◆ SRC_FILE

const SRC_FILE = '/^---\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'

Regular expression for searching source files

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/Patcher.php


Joomla CMS: Référence de la classe Path

  • Joomla
  • CMS
  • Filesystem
  • Path
Fonctions membres publiques statiques
Référence de la classe Path

Fonctions membres publiques statiques

static | canChmod ($path)
static | setPermissions ($path, $filemode='0644', $foldermode='0755')
static | getPermissions ($path)
static | check ($path)
static | clean ($path, $ds=DIRECTORY_SEPARATOR)
static | isOwner ($path)
static | find ($paths, $file)
static | resolve ($path)
static | removeRoot ($message, $rootDirectory=null)

Description détaillée

A Path handling class

Depuis
1.7.0

Documentation des fonctions membres

◆ canChmod()

static canChmod ( $path )
static

Checks if a path's permissions can be changed.

Paramètres
string $path Path to check.
Renvoie
boolean True if path can have mode changed.
Depuis
1.7.0

Références $path.

◆ check()

static check ( $path )
static

Checks for snooping outside of the file system root.

Paramètres
string $path A file system path to check.
Renvoie
string A cleaned version of the path or exit on error.
Exceptions

Références $path, et JPATH_ROOT.

Référencé par BaseController\addPath(), TemplateModel\getForm(), ModuleHelper\getLayoutPath(), LocalAdapter\getLocalPath(), TemplateModel\getSource(), Users\image(), ComponentModel\populateState(), FilePathRule\test(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ clean()

static clean | ( | $path,
 |  | $ds = DIRECTORY_SEPARATOR
 | ) |
static

Function to strip additional / or \ in a path name.

Paramètres
string | $path | The path to clean.
string | $ds | Directory separator (optional).
Renvoie
string The cleaned path.
Exceptions
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $path, elseif, et JPATH_ROOT.

Référencé par LocalAdapter\__construct(), SubformField\__set(), HtmlView\_addPath(), InstallModel\_getPackageFromFolder(), BaseModel\addIncludePath(), CacheController\addIncludePath(), CacheStorage\addIncludePath(), Cache\addIncludePath(), HTMLHelper\addIncludePath(), WebAssetRegistry\addRegistryFile(), HtmlView\addToolbar(), File\append(), LocalAdapter\checkContent(), TemplateModel\child(), InstallerHelper\cleanupInstall(), Folder\copy(), File\copy(), LocalAdapter\copy(), TemplateModel\copy(), TemplateModel\copyFile(), Installer\copyFiles(), Folder\create(), TemplateModel\createFile(), TemplateModel\createFolder(), TemplateModel\createOverride(), File\delete(), Folder\delete(), TemplateModel\deleteFolder(), Folder\exists(), File\exists(), TemplateModel\extractArchive(), Folder\files(), Folder\folders(), TemplateModel\getArchive(), ActionlogsHelper\getContentTypeLink(), TemplateModel\getCoreFile(), TemplateModel\getCoreList(), FileAdapter\getElement(), LocalAdapter\getFileName(), LocalAdapter\getFiles(), TemplateModel\getFiles(), TemplateModel\getFont(), OverrideModel\getForm(), TemplateModel\getForm(), TemplateModel\getImage(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), PluginModel\getItem(), StyleModel\getItem(), ModuleModel\getItem(), PositionsModel\getItems(), SelectModel\getItems(), TemplateModel\getMediaFiles(), BaseController\getModel(), AliastagField\getOptions(), FolderlistField\getOptions(), FilelistField\getOptions(), TemplateModel\getOverridesList(), LocalAdapter\getPathInformation(), TemplatesHelper\getPositions(), ModulesModel\getPositions(), TemplateModel\getSource(), TemplateModel\getUpdatedList(), BaseController\getView(), Folder\listFolderTree(), LegacyComponent\loadHelper(), ContenthistoryHelper\loadLanguageFiles(), File\move(), Folder\move(), LocalAdapter\move(), Installer\parseMedia(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), FileAdapter\populateFilesAndFolderList(), ComponentModel\populateState(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ModuleModel\preprocessForm(), FieldModel\preprocessForm(), ItemModel\preprocessForm(), StringsModel\refresh(), ApplicationModel\save(), TemplateModel\save(), LocalAdapter\search(), ComponentAdapter\setupInstallPaths(), ComponentAdapter\setupUninstall(), FolderPathExistsRule\test(), InstallerHelper\unpack(), File\upload(), TemplateModel\uploadFile(), DatabaseHelper\validateConnectionParameters(), ApplicationModel\validateDbConnection(), File\write(), et Debug\xdebuglink().

◆ find()

static find | ( | $paths,
 |  | $file
 | ) |
static

Searches the directory paths for a given file.

Paramètres
mixed | $paths | An path string or array of path strings to search in
string | $file | The file name to look for.
Renvoie
mixed The full path and file name for the target file, or boolean false if the file is not found in any of the paths.
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $path.

Référencé par HTMLHelper\_(), LegacyFactory\createView(), TemplateModel\getCoreFile(), CacheController\getInstance(), Table\getInstance(), HtmlView\getLayoutFile(), FileLayout\getPath(), FormHelper\loadClass(), Form\loadFile(), HtmlView\loadHelper(), HtmlView\loadTemplate(), et ItemModel\preprocessForm().

◆ getPermissions()

static getPermissions ( $path )
static

Get the permissions of the file/folder at a given path.

Paramètres
string $path The path of a file/folder.
Renvoie
string Filesystem permissions.
Depuis
1.7.0

Références $i, $mode, et $path.

Référencé par TemplateModel\save().

◆ isOwner()

static isOwner ( $path )
static

Method to determine if script owns the path.

Paramètres
string $path Path to check ownership.
Renvoie
boolean True if the php script owns the path passed.
Depuis
1.7.0

Références $dir, $path, $return, $tmp, File\delete(), Crypt\genRandomBytes(), JPATH_SITE, et File\write().

Référencé par TemplateModel\save(), et ApplicationModel\writeConfigFile().

◆ removeRoot()

static removeRoot | ( | $message,
 |  | $rootDirectory = null
 | ) |
static

Remove all references to root directory path and the system tmp path from a message

Paramètres
string | $message | The message to be cleaned
string | $rootDirectory | Optional root directory, defaults to JPATH_ROOT
Renvoie
string
Depuis
3.10.7

Références $dir, $message, et JPATH_ROOT.

Référencé par LogEntry\__construct(), Patcher\applyHunk(), et Folder\copy().

◆ resolve()

static resolve ( $path )
static

Resolves /./, /../ and multiple / in a string and returns the resulting absolute path, inspired by Flysystem Removes trailing slashes

Paramètres
string $path A path to resolve
Renvoie
string The resolved path
Depuis
3.9.25

Références $parts, et $path.

◆ setPermissions()

static setPermissions | ( | $path,
 |  | $filemode = '0644',
 |  | $foldermode = '0755'
 | ) |
static

Chmods files and directories recursively to given permissions.

Paramètres
string | $path | Root path to begin changing mode [without trailing slash].
string | $filemode | Octal representation of the value to change file mode to [null = no change].
string | $foldermode | Octal representation of the value to change folder mode to [null = no change].
Renvoie
boolean True if successful [one fail means the whole operation failed].
Depuis
1.7.0

Références $path.

Référencé par TemplateModel\save(), File\upload(), et ApplicationModel\writeConfigFile().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/Path.php


Joomla CMS: Référence de la classe Stream

  • Joomla
  • CMS
  • Filesystem
  • Stream
Fonctions membres publiques | Attributs protégés
Référence de la classe Stream
+ Graphe d'héritage de Stream:
CMSObject

Fonctions membres publiques

__construct ($writeprefix='', $readprefix='', $context=array())
__destruct ()
open ( $filename, $mode='r', $useIncludePath=false, $context=null, $usePrefix=false, $relative=false, $detectProcessingMode=false)
close ()
eof ()
filesize ()
gets ($length=0)
read ($length=0)
seek ($offset, $whence=SEEK_SET)
tell ()
write (&$string, $length=0, $chunk=0)
chmod ($filename='', $mode=0)
get_meta_data ()
_buildContext ()
setContextOptions ($context)
addContextEntry ($wrapper, $name, $value)
deleteContextEntry ($wrapper, $name)
applyContextToStream ()
appendFilter ($filterName, $readWrite=STREAM_FILTER_READ, $params=array())
prependFilter ($filterName, $readWrite=STREAM_FILTER_READ, $params=array())
removeFilter (&$resource, $byindex=false)
copy ($src, $dest, $context=null, $usePrefix=true, $relative=false)
move ($src, $dest, $context=null, $usePrefix=true, $relative=false)
delete ($filename, $context=null, $usePrefix=true, $relative=false)
upload ($src, $dest, $context=null, $usePrefix=true, $relative=false)
writeFile ($filename, &$buffer)
_getFilename ($filename, $mode, $usePrefix, $relative)
getFileHandle ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Attributs protégés

$filemode = 0644
$dirmode = 0755
$chunksize = 8192
$filename
$writeprefix
$readprefix
$processingmethod = 'f'
$filters = array()
$fh
$filesize
$context = null
$contextOptions
$openmode
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Joomla! Stream Interface

The Joomla! stream interface is designed to handle files as streams where as the legacy File static class treated files in a rather atomic manner.

Note
This class adheres to the stream wrapper operations: https://www.php.net/manual/en/intro.stream.php PHP Stream Manual https://www.php.net/manual/en/wrappers.php Stream Wrappers https://www.php.net/manual/en/filters.php Stream Filters https://www.php.net/manual/en/transports.php Socket Transports (used by some options, particularly HTTP proxy) 1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $writeprefix = '',
 |  | $readprefix = '',
 |  | $context = array()
 | ) |

Constructor

Paramètres
string | $writeprefix | Prefix of the stream (optional). Unlike the JPATH_*, this has a final path separator!
string | $readprefix | The read prefix (optional).
array | $context | The context options (optional).
Depuis
1.7.0

Références $context.

◆ __destruct()

__destruct ( )

Destructor

Depuis
1.7.0

Documentation des fonctions membres

◆ _buildContext()

_buildContext ( )

Stream contexts Builds the context from the array

Renvoie
mixed
Depuis
1.7.0

Références null.

◆ _getFilename()

_getFilename | ( | $filename,
 |  | $mode,
 |  | $usePrefix,
 |  | $relative
 | ) |

Determine the appropriate 'filename' of a file

Paramètres
string | $filename | Original filename of the file
string | $mode | Mode string to retrieve the filename
boolean | $usePrefix | Controls the use of a prefix
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
string
Depuis
1.7.0

Références $mode, FilesystemHelper\getWriteModes(), et JPATH_ROOT.

◆ addContextEntry()

addContextEntry | ( | $wrapper,
 |  | $name,
 |  | $value
 | ) |

Adds a particular options to the context

Paramètres
string | $wrapper | The wrapper to use
string | $name | The option to set
string | $value | The value of the option
Renvoie
void

Stream Context Creation https://www.php.net/manual/en/context.php Context Options for various streams 1.7.0

Références $name, $value, et $wrapper.

◆ appendFilter()

appendFilter | ( | $filterName,
 |  | $readWrite = STREAM_FILTER_READ,
 |  | $params = array()
 | ) |

Stream filters Append a filter to the chain

Paramètres
string | $filterName | The key name of the filter.
integer | $readWrite | Optional. Defaults to STREAM_FILTER_READ.
array | $params | An array of params for the stream_filter_append call.
Renvoie
mixed

1.7.0

Références $params.

◆ applyContextToStream()

applyContextToStream ( )

Applies the current context to the stream

Use this to change the values of the context after you've opened a stream

Renvoie
mixed
Depuis
1.7.0

◆ chmod()

chmod | ( | $filename = '',
 |  | $mode = 0
 | ) |

Chmod wrapper

Paramètres
string | $filename | File name.
mixed | $mode | Mode to use.
Renvoie
boolean
Depuis
1.7.0

Références $mode, Text\_(), et FilesystemHelper\ftpChmod().

◆ close()

close ( )

Attempt to close a file handle

Will return false if it failed and true on success If the file is not open the system will return true, this function destroys the file handle as well

Renvoie
boolean
Depuis
1.7.0

Références Text\_(), et null.

◆ copy()

copy | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Copy a file from src to dest

Paramètres
string | $src | The file path to copy from.
string | $dest | The file path to copy to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
mixed
Depuis
1.7.0

Références $context, et elseif.

◆ delete()

delete | ( | $filename,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Delete a file

Paramètres
string | $filename | The file path to delete.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
mixed
Depuis
1.7.0

Références $context, et elseif.

◆ deleteContextEntry()

deleteContextEntry | ( | $wrapper,
 |  | $name
 | ) |

Deletes a particular setting from a context

Paramètres
string | $wrapper | The wrapper to use
string | $name | The option to unset
Renvoie
void

1.7.0

Références $name, et $wrapper.

◆ eof()

eof ( )

Work out if we're at the end of the file for a stream

Renvoie
boolean
Depuis
1.7.0

Références Text\_().

◆ filesize()

filesize ( )

Retrieve the file size of the path

Renvoie
mixed
Depuis
1.7.0

Références Text\_(), et FilesystemHelper\remotefsize().

◆ get_meta_data()

get_meta_data ( )

Get the stream metadata

Renvoie
array|boolean header/metadata

1.7.0

Références Text\_().

◆ getFileHandle()

getFileHandle ( )

Return the internal file handle

Renvoie
resource File handler
Depuis
1.7.0

◆ gets()

gets ( $length = 0 )

Get a line from the stream source.

Paramètres
integer $length The number of bytes (optional) to read.
Renvoie
mixed
Depuis
1.7.0

Références Text\_().

◆ move()

move | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Moves a file

Paramètres
string | $src | The file path to move from.
string | $dest | The file path to move to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
mixed
Depuis
1.7.0

Références $context, et elseif.

◆ open()

open | ( | $filename,
 |  | $mode = 'r',
 |  | $useIncludePath = false,
 |  | $context = null,
 |  | $usePrefix = false,
 |  | $relative = false,
 |  | $detectProcessingMode = false
 | ) |

Generic File Operations

Open a stream with some lazy loading smarts

Paramètres
string | $filename | Filename
string | $mode | Mode string to use
boolean | $useIncludePath | Use the PHP include path
resource | $context | Context to use when opening
boolean | $usePrefix | Use a prefix to open the file
boolean | $relative | Filename is a relative path (if false, strips JPATH_ROOT to make it relative)
boolean | $detectProcessingMode | Detect the processing method for the file and use the appropriate function to handle output automatically
Renvoie
boolean
Depuis
1.7.0

Références $context, $mode, $url, Text\_(), __DIR__, elseif, File\getExt(), et FilesystemHelper\isJoomlaStream().

◆ prependFilter()

prependFilter | ( | $filterName,
 |  | $readWrite = STREAM_FILTER_READ,
 |  | $params = array()
 | ) |

Prepend a filter to the chain

Paramètres
string | $filterName | The key name of the filter.
integer | $readWrite | Optional. Defaults to STREAM_FILTER_READ.
array | $params | An array of params for the stream_filter_prepend call.
Renvoie
mixed

1.7.0

Références $filters, et $params.

◆ read()

read ( $length = 0 )

Read a file

Handles user space streams appropriately otherwise any read will return 8192

Paramètres
integer $length Length of data to read
Renvoie
mixed

1.7.0

Références $filesize, et Text\_().

◆ removeFilter()

removeFilter | ( | & | $resource,
 |  |  | $byindex = false
 | ) |  |

Remove a filter, either by resource (handed out from the append or prepend function) or via getting the filter list)

Paramètres
resource | $resource | The resource.
boolean | $byindex | The index of the filter.
Renvoie
boolean Result of operation
Depuis
1.7.0

◆ seek()

seek | ( | $offset,
 |  | $whence = SEEK_SET
 | ) |

Seek the file

Note: the return value is different to that of fseek

Paramètres
integer | $offset | Offset to use when seeking.
integer | $whence | Seek mode to use.
Renvoie
boolean True on success, false on failure

1.7.0

Références Joomla\Database\Query\$offset, et Text\_().

◆ setContextOptions()

setContextOptions ( $context )

Updates the context to the array

Format is the same as the options for stream_context_create

Paramètres
array $context Options to create the context with
Renvoie
void

1.7.0

Références $context.

◆ tell()

tell ( )

Returns the current position of the file read/write pointer.

Renvoie
mixed
Depuis
1.7.0

Références Text\_().

◆ upload()

upload | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Upload a file

Paramètres
string | $src | The file path to copy from (usually a temp folder).
string | $dest | The file path to copy to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
mixed
Depuis
1.7.0

Références $context, et Text\_().

◆ write()

write | ( | & | $string,
 |  |  | $length = 0,
 |  |  | $chunk = 0
 | ) |  |

File write

Whilst this function accepts a reference, the underlying fwrite will do a copy! This will roughly double the memory allocation for any write you do. Specifying chunked will get around this by only writing in specific chunk sizes. This defaults to 8192 which is a sane number to use most of the time (change the default with JStream::set('chunksize', newsize);) Note: This doesn't support gzip/bzip2 writing like reading does

Paramètres
string | $string | Reference to the string to write.
integer | $length | Length of the string to write.
integer | $chunk | Size of chunks to write in.
Renvoie
boolean

1.7.0

Références $start, Text\_(), et elseif.

◆ writeFile()

writeFile | ( |  | $filename,
 |  | & | $buffer
 | ) |  |

Writes a chunk of data to a file.

Paramètres
string | $filename | The file name.
string | $buffer | The data to write to the file.
Renvoie
boolean
Depuis
1.7.0

Références $buffer, et $result.

Documentation des champs

◆ $chunksize

$chunksize = 8192
protected

◆ $context

$context = null
protected

◆ $contextOptions

$contextOptions
protected

◆ $dirmode

$dirmode = 0755
protected

◆ $fh

$fh
protected

◆ $filemode

$filemode = 0644
protected

◆ $filename

$filename
protected

◆ $filesize

$filesize
protected

◆ $filters

$filters = array()
protected

◆ $openmode

$openmode
protected

◆ $processingmethod

$processingmethod = 'f'
protected

◆ $readprefix

$readprefix
protected

◆ $writeprefix

$writeprefix
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filesystem/Stream.php


Joomla CMS: Référence de la classe InputFilter

  • Joomla
  • CMS
  • Filter
  • InputFilter
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés statiques | Attributs privés
Référence de la classe InputFilter
+ Graphe d'héritage de InputFilter:
InputFilter

Fonctions membres publiques

__construct ($tagsArray=array(), $attrArray=array(), $tagsMethod=0, $attrMethod=0, $xssAuto=1, $stripUSC=0)
clean ($source, $type='string')
emailToPunycode ($text)
- Fonctions membres publiques hérités de InputFilter
__construct (array $tagsArray=[], array $attrArray=[], $tagsMethod=self::ONLY_ALLOW_DEFINED_TAGS, $attrMethod=self::ONLY_ALLOW_DEFINED_ATTRIBUTES, $xssAuto=1)
clean ($source, $type='string')

Fonctions membres publiques statiques

static | getInstance ($tagsArray=array(), $attrArray=array(), $tagsMethod=0, $attrMethod=0, $xssAuto=1, $stripUSC=0)
static | isSafeFile ($file, $options=array())
- Fonctions membres publiques statiques hérités de InputFilter
static | checkAttribute ($attrSubSet)

Champs de données

const | FORBIDDEN_FILE_EXTENSIONS
- Champs de données hérités de InputFilter
const | ONLY_ALLOW_DEFINED_TAGS = 0
const | ONLY_BLOCK_DEFINED_TAGS = 1
const | ONLY_ALLOW_DEFINED_ATTRIBUTES = 0
const | ONLY_BLOCK_DEFINED_ATTRIBUTES = 1
$tagsArray
$attrArray
$tagsMethod
$attrMethod
$xssAuto
$blockedTags
$blockedAttributes

Fonctions membres protégées

decode ($source)
stripUSC ($source)
- Fonctions membres protégées hérités de InputFilter
remove ($source)
cleanTags ($source)
cleanAttributes (array $attrSet)
decode ($source)
escapeAttributeValues ($source)
stripCssExpressions ($source)

Fonctions membres protégées statiques

static decodeFileData (array $data)

Attributs protégés statiques

static $instances = array()

Attributs privés

$stripUSC = 0

Description détaillée

InputFilter is a class for filtering input from any data source

Forked from the php input filter library by: Daniel Morris dan@r.nosp@m.ootc.nosp@m.ube.c.nosp@m.om Original Contributors: Gianpaolo Racca, Ghislain Picard, Marco Wandschneider, Chris Tobin and Andrew Eddie.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $tagsArray = array(),
 |  | $attrArray = array(),
 |  | $tagsMethod = 0,
 |  | $attrMethod = 0,
 |  | $xssAuto = 1,
 |  | $stripUSC = 0
 | ) |

Constructor for inputFilter class. Only first parameter is required.

Paramètres
array | $tagsArray | List of user-defined tags
array | $attrArray | List of user-defined attributes
integer | $tagsMethod | The constant static::ONLY_ALLOW_DEFINED_TAGS or static::BLOCK_DEFINED_TAGS
integer | $attrMethod | The constant static::ONLY_ALLOW_DEFINED_ATTRIBUTES or static::BLOCK_DEFINED_ATTRIBUTES
integer | $xssAuto | Only auto clean essentials = 0, Allow clean blocked tags/attributes = 1
integer | $stripUSC | Strip 4-byte unicode characters = 1, no strip = 0
Depuis
1.7.0

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ clean()

clean | ( | $source,
 |  | $type = 'string'
 | ) |

Method to be called by another php script. Processes for XSS and specified bad code.

Paramètres
mixed | $source | Input string/array-of-string to be 'cleaned'
string | $type | The return type for the variable: INT: An integer, or an array of integers, UINT: An unsigned integer, or an array of unsigned integers, FLOAT: A floating point number, or an array of floating point numbers, BOOLEAN: A boolean value, WORD: A string containing A-Z or underscores only (not case sensitive), ALNUM: A string containing A-Z or 0-9 only (not case sensitive), CMD: A string containing A-Z, 0-9, underscores, periods or hyphens (not case sensitive), BASE64: A string containing A-Z, 0-9, forward slashes, plus or equals (not case sensitive), STRING: A fully decoded and sanitised string (default), HTML: A sanitised string, ARRAY: An array, PATH: A sanitised file path, or an array of sanitised file paths, TRIM: A string trimmed from normal, non-breaking and multibyte spaces USERNAME: Do not use (use an application specific filter), RAW: The raw string is returned with no filtering, unknown: An unknown filter will act like STRING. If the input is an array it will return an array of fully decoded and sanitised strings.
Renvoie
mixed 'Cleaned' version of input parameter
Depuis
1.7.0

Références $type.

◆ decode()

decode ( $source )
protected

Try to convert to plaintext

Paramètres
string $source The source string.
Renvoie
string Plaintext string
Depuis
3.5

Références ENT_COMPAT.

◆ decodeFileData()

static decodeFileData ( array $data )
staticprotected

Method to decode a file data array.

Paramètres
array $data The data array to decode.
Renvoie
array
Depuis
3.4

Références $data, et $result.

◆ emailToPunycode()

emailToPunycode ( $text )

Function to punyencode utf8 mail when saving content

Paramètres
string $text The strings to encode
Renvoie
string The punyencoded mail
Depuis
3.5

Références $text, et PunycodeHelper\emailToPunycode().

◆ getInstance()

static getInstance | ( | $tagsArray = array(),
 |  | $attrArray = array(),
 |  | $tagsMethod = 0,
 |  | $attrMethod = 0,
 |  | $xssAuto = 1,
 |  | $stripUSC = 0
 | ) |
static

Returns an input filter object, only creating it if it doesn't already exist.

Paramètres
array | $tagsArray | List of user-defined tags
array | $attrArray | List of user-defined attributes
integer | $tagsMethod | The constant static::ONLY_ALLOW_DEFINED_TAGS or static::BLOCK_DEFINED_TAGS
integer | $attrMethod | The constant static::ONLY_ALLOW_DEFINED_ATTRIBUTES or static::BLOCK_DEFINED_ATTRIBUTES
integer | $xssAuto | Only auto clean essentials = 0, Allow clean blocked tags/attributes = 1
integer | $stripUSC | Strip 4-byte unicode characters = 1, no strip = 0
Renvoie
InputFilter The InputFilter object.
Depuis
1.7.0

Référencé par Cookie\__construct(), Files\__construct(), Json\__construct(), Cli\__construct(), Input\__construct(), FeedParser\__construct(), ExtensionAdapter\_endElement(), Update\_endElement(), HtmlDocument\_fetchTemplate(), Captcha\_load(), Editor\_loadEditor(), CollectionAdapter\_startElement(), User\check(), TemplateController\createFile(), HtmlView\display(), ArticlesController\displayList(), UsersController\displayList(), PluginsController\displayList(), MediaController\displayList(), CMSApplication\enqueueMessage(), SafehtmlFilter\filter(), UrlFilter\filter(), FormField\filter(), LanguagesHelper\filterKey(), LanguagesHelper\filterText(), ComponentHelper\filterText(), PackageAdapter\getElement(), InstallerAdapter\getElement(), Parser\getInstance(), BaseController\getInstance(), InstallerAdapter\getName(), FinderHelper\getQuery(), InstallerAdapter\getScriptClassName(), AdministratorApplication\getTemplate(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), TemplateController\overrides(), ListModel\populateState(), LevelModel\save(), StringsModel\search(), MailModel\send(), ItemController\setType(), UsernameRule\test(), Cli\unserialize(), Input\unserialize(), LanguageAdapter\update(), et TemplateController\uploadFile().

◆ isSafeFile()

static isSafeFile | ( | $file,
 |  | $options = array()
 | ) |
static

Checks an uploaded for suspicious naming and potential PHP contents which could indicate a hacking attempt.

The options you can define are: null_byte Prevent files with a null byte in their name (buffer overflow attack) forbidden_extensions Do not allow these strings anywhere in the file's extension php_tag_in_content Do not allow <?php tag in content phar_stub_in_content Do not allow the __HALT_COMPILER() phar stub in content shorttag_in_content Do not allow short tag <? in content shorttag_extensions Which file extensions to scan for short tags in content fobidden_ext_in_content Do not allow forbidden_extensions anywhere in content php_ext_content_extensions Which file extensions to scan for .php in content

This code is an adaptation and improvement of Admin Tools' UploadShield feature, relicensed and contributed by its author.

Paramètres
array | $file | An uploaded file descriptor
array | $options | The scanner options (see the code for details)
Renvoie
boolean True of the file is safe
Depuis
3.4

Références $data, $i, et $options.

Référencé par Files\get(), et File\upload().

◆ stripUSC()

stripUSC ( $source )
protected

Recursively strip Unicode Supplementary Characters from the source. Not: objects cannot be filtered.

Paramètres
mixed $source The data to filter
Renvoie
mixed The filtered result
Depuis
3.5

Documentation des champs

◆ $instances

$instances = array()
staticprotected

◆ $stripUSC

$stripUSC = 0
private

◆ FORBIDDEN_FILE_EXTENSIONS

const FORBIDDEN_FILE_EXTENSIONS
Valeur initiale :
= [
'php', 'phps', 'pht', 'phtml', 'php3', 'php4', 'php5', 'php6', 'php7', 'asp',
'php8', 'phar', 'inc', 'pl', 'cgi', 'fcgi', 'java', 'jar', 'py', 'aspx'
]

An array containing a list of extensions for files that are typically executable directly in the webserver context, potentially resulting in code executions

Depuis
4.0.0

Référencé par MediaHelper\canUpload(), et MediaHelper\checkFileExtension().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filter/InputFilter.php


Joomla CMS: Référence de la classe OutputFilter

  • Joomla
  • CMS
  • Filter
  • OutputFilter
Fonctions membres publiques statiques
Référence de la classe OutputFilter
+ Graphe d'héritage de OutputFilter:
OutputFilter

Fonctions membres publiques statiques

static | linkXHTMLSafe ($input)
static | stringJSSafe ($string)
static | stringURLSafe ($string, $language='')
static | ampReplaceCallback ($m)
- Fonctions membres publiques statiques hérités de OutputFilter
static | objectHtmlSafe (&$mixed, $quoteStyle=\ENT_QUOTES, $excludeKeys='')
static | linkXhtmlSafe ($input)
static | stringUrlSafe ($string, $language='')
static | stringUrlUnicodeSlug ($string)
static | ampReplace ($text)
static | cleanText (&$text)
static | setLanguage (Language $language)
static | stripImages ($string)
static | stripIframes ($string)

Description détaillée

OutputFilter

Depuis
1.7.0

Documentation des fonctions membres

◆ ampReplaceCallback()

static ampReplaceCallback ( $m )
static

Callback method for replacing & with & in a string

Paramètres
string $m String to process
Renvoie
string Replaced string
Depuis
3.5

◆ linkXHTMLSafe()

static linkXHTMLSafe ( $input )
static

This method processes a string and replaces all instances of & with & in links only.

Paramètres
string $input String to process
Renvoie
string Processed string
Depuis
1.7.0

Références $input.

◆ stringJSSafe()

static stringJSSafe ( $string )
static

This method processes a string and escapes it for use in JavaScript

Paramètres
string $string String to process
Renvoie
string Processed text

Références StringHelper\ord().

◆ stringURLSafe()

static stringURLSafe | ( | $string,
 |  | $language = ''
 | ) |
static

This method processes a string and replaces all accented UTF-8 characters by unaccented ASCII-7 "equivalents", whitespaces are replaced by hyphens and the string is lowercase.

Paramètres
string | $string | String to process
string | $language | Language to transliterate to
Renvoie
string Processed string
Depuis
1.7.0

Références $lang, $language, Language\getInstance(), Factory\getLanguage(), et StringHelper\strtolower().

Référencé par Filter\select(), et ApplicationHelper\stringURLSafe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Filter/OutputFilter.php


Joomla CMS: Référence de la classe AccessiblemediaField

  • Joomla
  • CMS
  • Form
  • Field
  • AccessiblemediaField
Fonctions membres publiques | Attributs protégés
Référence de la classe AccessiblemediaField
+ Graphe d'héritage de AccessiblemediaField:
SubformField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de SubformField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
loadSubForm ()
filter ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Accessiblemedia'
$preview
$directory
$previewWidth
$previewHeight
$layout
- Attributs protégés hérités de SubformField
$type = 'Subform'
$formsource
$min = 0
$max = 1000
$layout = 'joomla.form.field.subform.default'
$groupByFieldset = false
$buttons = array('add' => true, 'remove' => true, 'move' => true)
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de SubformField
getInput ()
getName ($fieldName)
loadSubFormData (Form $subForm)
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

The Field to load the form inside current form

Depuis
4.0.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
4.0.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value.
Renvoie
boolean True on success.
Depuis
4.0.0

When you have subforms which are not repeatable (i.e. a subform custom field with the repeat attribute set to 0) you get an array here since the data comes from decoding the JSON into an associative array, including the media subfield's data.

However, this method expects an object or a string, not an array. Typecasting the array to an object solves the data format discrepancy.

If the value is not a string, it is most likely within a custom field of type subform and the value is a stdClass with properties imagefile and alt_text. So it is fine.

If the value is not empty and is not a valid JSON string, it is most likely a custom field created in Joomla 3 and the value is a string that contains the file name.

Références $value, $xml, description, elseif, fieldset, JPATH_ROOT, et name.

Documentation des champs

◆ $directory

$directory
protected

◆ $layout

$layout
protected

◆ $preview

$preview
protected

◆ $previewHeight

$previewHeight
protected

◆ $previewWidth

$previewWidth
protected

◆ $type

$type = 'Accessiblemedia'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AccessiblemediaField.php


Joomla CMS: Référence de la classe AccesslevelField

  • Joomla
  • CMS
  • Form
  • Field
  • AccesslevelField
Fonctions membres protégées | Attributs protégés
Référence de la classe AccesslevelField
+ Graphe d'héritage de AccesslevelField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Accesslevel'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a list of access levels. Access levels control what users in specific groups can see.

Voir également
JAccess
Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
4.0.0

Références HTMLHelper\_().

Documentation des champs

◆ $type

$type = 'Accesslevel'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AccesslevelField.php


Joomla CMS: Référence de la classe AliastagField

  • Joomla
  • CMS
  • Form
  • Field
  • AliastagField
Fonctions membres protégées | Attributs protégés
Référence de la classe AliastagField
+ Graphe d'héritage de AliastagField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Aliastag'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Framework.

Depuis
2.5.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.6

Références $b, $db, $extension, $i, $item, $lang, $options, $parts, $query, Text\_(), Path\clean(), Joomla\Database\getDatabase(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $type

$type = 'Aliastag'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AliastagField.php


Joomla CMS: Référence de la classe AuthorField

  • Joomla
  • CMS
  • Form
  • Field
  • AuthorField
Champs de données | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe AuthorField
+ Graphe d'héritage de AuthorField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Author'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés statiques

static | $options = []
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Description détaillée

Form Field to load a list of content authors

Depuis
3.2

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the options to populate list

Renvoie
array The field option objects.
Depuis
3.2

Références $db, $hash, $options, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $options

$options = []
staticprotected

◆ $type

$type = 'Author'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthorField.php


Joomla CMS: Référence de la classe CachehandlerField

  • Joomla
  • CMS
  • Form
  • Field
  • CachehandlerField
Fonctions membres protégées | Attributs protégés
Référence de la classe CachehandlerField
+ Graphe d'héritage de CachehandlerField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Cachehandler'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a list of available cache handlers

Voir également
JCache
Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $options, Text\_(), HTMLHelper\_(), et Cache\getStores().

Documentation des champs

◆ $type

$type = 'Cachehandler'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CachehandlerField.php


Joomla CMS: Référence de la classe CalendarField

  • Joomla
  • CMS
  • Form
  • Field
  • CalendarField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CalendarField
+ Graphe d'héritage de CalendarField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
filter ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Calendar'
$maxlength
$format
$filterFormat
$filter
$minyear
$maxyear
$layout = 'joomla.form.field.calendar'
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform.

Provides a pop up date picker linked to a button. Optionally may be filtered to use user's or server's time zone.

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ filter()

filter | ( |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null
 | ) |  |

Method to filter a field value.

Paramètres
mixed | $value | The optional value to use as the default for the field.
string | $group | The optional dot-separated form group path on which to find the field.
Registry | $input | An optional Registry object with the entire data set to filter against the entire form.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Références $app, Joomla\Database\Query\$offset, $return, $this, $value, Factory\getApplication(), et Factory\getDate().

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

Références $date, $user, Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getDate(), et value.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7.0

Références $data, $direction, $lang, Factory\getApplication(), Factory\getDocument(), JPATH_ROOT, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $lang, $return, $value, Text\_(), Factory\getLanguage(), et null.

Documentation des champs

◆ $filter

$filter
protected

◆ $filterFormat

$filterFormat
protected

◆ $format

$format
protected

◆ $layout

$layout = 'joomla.form.field.calendar'
protected

◆ $maxlength

$maxlength
protected

◆ $maxyear

$maxyear
protected

◆ $minyear

$minyear
protected

◆ $parentclass

$parentclass
protected

◆ $type

$type = 'Calendar'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CalendarField.php


Joomla CMS: Référence de la classe CaptchaField

  • Joomla
  • CMS
  • Form
  • Field
  • CaptchaField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CaptchaField
+ Graphe d'héritage de CaptchaField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Captcha'
$_captcha
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Captcha field.

Depuis
2.5

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input.

Renvoie
string The field input.
Depuis
2.5

Références Factory\getApplication(), name, et null.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
2.5

Give the captcha instance a possibility to react on the setup-process, e.g. by altering the XML structure of the field, for example hiding the label when using invisible captchas.

Références $app, $default, $result, $this, $value, Factory\getApplication(), Captcha\getInstance(), null, et try.

Documentation des champs

◆ $_captcha

$_captcha
protected

◆ $type

$type = 'Captcha'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CaptchaField.php


Joomla CMS: Référence de la classe CategoryField

  • Joomla
  • CMS
  • Form
  • Field
  • CategoryField
Champs de données | Fonctions membres protégées
Référence de la classe CategoryField
+ Graphe d'héritage de CategoryField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Category'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports an HTML select list of categories

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options for category Use the extension attribute in a form to specify the.specific extension for which categories should be displayed. Use the show_root attribute to specify whether to show the global category root in the list.

Renvoie
array The field option objects.
Depuis
1.6

Références $extension, $filters, $i, $language, $option, $options, $published, $user, Text\_(), HTMLHelper\_(), Log\add(), Factory\getUser(), et Log\WARNING.

Documentation des champs

◆ $type

$type = 'Category'
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Form/Field/CategoryField.php


Joomla CMS: Référence de la classe CheckboxesField

  • Joomla
  • CMS
  • Form
  • Field
  • CheckboxesField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe CheckboxesField
+ Graphe d'héritage de CheckboxesField:
ListField FormField DatabaseAwareInterface ConsentBoxField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$checkedOptions
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Checkboxes'
$layout = 'joomla.form.field.checkboxes'
$forceMultiple = true
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Displays options as a list of checkboxes. Multiselect may be forced to be true.

Voir également
CheckboxesField
Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the radio button field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

Références name.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $data, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $checkedOptions

$checkedOptions

◆ $forceMultiple

$forceMultiple = true
protected

◆ $layout

$layout = 'joomla.form.field.checkboxes'
protected

◆ $type

$type = 'Checkboxes'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckboxesField.php


Joomla CMS: Référence de la classe CheckboxField

  • Joomla
  • CMS
  • Form
  • Field
  • CheckboxField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CheckboxField
+ Graphe d'héritage de CheckboxField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Checkbox'
$layout = 'joomla.form.field.checkbox'
$checked = false
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Single checkbox field. This is a boolean field with null for false and the specified option for true

CheckboxField 1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $checked, et $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
4.0.0

Références $data, et $value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $checked, $default, $return, $value, null, et value.

Documentation des champs

◆ $checked

$checked = false
protected

◆ $layout

$layout = 'joomla.form.field.checkbox'
protected

◆ $type

$type = 'Checkbox'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckboxField.php


Joomla CMS: Référence de la classe ChromestyleField

  • Joomla
  • CMS
  • Form
  • Field
  • ChromestyleField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ChromestyleField
+ Graphe d'héritage de ChromestyleField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'ChromeStyle'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
getTemplateModuleStyles ()
getTemplates ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$clientId
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Chrome Styles field.

Depuis
3.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $clientId, et $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to get the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getGroups()

getGroups ( )
protected

Method to get the list of template chrome style options grouped by template.

Renvoie
array The field option objects as a nested array in groups.
Depuis
3.0

Références $groups, $style, $template, $tmp, Text\_(), et HTMLHelper\_().

◆ getTemplateModuleStyles()

getTemplateModuleStyles ( )
protected

Method to get the templates module styles.

Renvoie
array The array of styles, grouped by templates.
Depuis
3.0

Références $layout, $path, $template, Folder\exists(), Folder\files(), JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getTemplates()

getTemplates ( )
protected

Return a list of templates

Renvoie
array List of templates
Depuis
3.2.1

Références $db, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $client, $clientId, $result, $value, et ApplicationHelper\getClientInfo().

Documentation des champs

◆ $clientId

$clientId
protected

◆ $type

$type = 'ChromeStyle'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ChromestyleField.php


Joomla CMS: Référence de la classe ColorField

  • Joomla
  • CMS
  • Form
  • Field
  • ColorField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ColorField
+ Graphe d'héritage de ColorField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
getSimpleModeLayoutData ()
getAdvancedModeLayoutData ($lang)
getSliderModeLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Color'
$control = 'hue'
$default
$display = 'hue'
$format = 'hex'
$keywords = ''
$position = 'default'
$colors
$preview = false
$saveFormat = 'hex'
$split = 3
$layout = 'joomla.form.field.color'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Color Form Field class for the Joomla Platform. This implementation is designed to be compatible with HTML5's <input type="color">

1.7.3

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getAdvancedModeLayoutData()

getAdvancedModeLayoutData ( $lang )
protected

Method to get the data for the advanced mode to be passed to the layout for rendering.

Paramètres
object $lang The language object
Renvoie
array
Depuis
3.5

Références $lang.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.3

Références $control.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $color, $data, $lang, $position, elseif, Factory\getApplication(), et value.

◆ getSimpleModeLayoutData()

getSimpleModeLayoutData ( )
protected

Method to get the data for the simple mode to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $colors, et $count.

◆ getSliderModeLayoutData()

getSliderModeLayoutData ( )
protected

Method to get the data for the slider

Renvoie
array
Depuis
4.0.0

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $colors

$colors
protected

◆ $control

$control = 'hue'
protected

◆ $default

$default
protected

◆ $display

$display = 'hue'
protected

◆ $format

$format = 'hex'
protected

◆ $keywords

$keywords = ''
protected

◆ $layout

$layout = 'joomla.form.field.color'
protected

◆ $position

$position = 'default'
protected

◆ $preview

$preview = false
protected

◆ $saveFormat

$saveFormat = 'hex'
protected

◆ $split

$split = 3
protected

◆ $type

$type = 'Color'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ColorField.php


Joomla CMS: Référence de la classe ComboField

  • Joomla
  • CMS
  • Form
  • Field
  • ComboField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComboField
+ Graphe d'héritage de ComboField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Combo'
$layout = 'joomla.form.field.combo'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Implements a combo box field.

Depuis
1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a combo box field.

Renvoie
string The field input markup.
Depuis
1.7.0

Références name.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.8.0

Références $data, et $options.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.combo'
protected

◆ $type

$type = 'Combo'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComboField.php


Joomla CMS: Référence de la classe ComponentlayoutField

  • Joomla
  • CMS
  • Form
  • Field
  • ComponentlayoutField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentlayoutField
+ Graphe d'héritage de ComponentlayoutField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ComponentLayout'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to display a list of the layouts for a component view from the extension or template overrides.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input for a component layout field.

Renvoie
string The field input.
Depuis
1.6

Références $attr, $client, $clientId, $db, $extension, $groups, $html, $i, $key, $lang, $menu, $query, $selected, $template, $text, $value, $view, $xml, Text\_(), HTMLHelper\_(), Path\clean(), Folder\files(), ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, JPATH_ADMINISTRATOR, name, null, Text\sprintf(), et value.

Documentation des champs

◆ $type

$type = 'ComponentLayout'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentlayoutField.php


Joomla CMS: Référence de la classe ComponentsField

  • Joomla
  • CMS
  • Form
  • Field
  • ComponentsField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentsField
+ Graphe d'héritage de ComponentsField:
ListField FormField DatabaseAwareInterface WorkflowComponentSectionsField

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Components'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Framework.

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
2.5.0

Références $db, $extension, $item, $items, $lang, $options, $query, Text\_(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'Components'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentsField.php


Joomla CMS: Référence de la classe ContenthistoryField

  • Joomla
  • CMS
  • Form
  • Field
  • ContenthistoryField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ContenthistoryField
+ Graphe d'héritage de ContenthistoryField:
FormField DatabaseAwareInterface

Fonctions membres publiques

getLayoutData ()
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'ContentHistory'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$layout = 'joomla.form.field.contenthistory'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to select Content History from a modal list.

Depuis
3.2

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the content history field input markup.

Renvoie
string The field input markup.
Depuis
3.2

Références name.

◆ getLayoutData()

getLayoutData ( )

Get the data that is going to be passed to the layout

Renvoie
array

Références $data, $itemId, $label, $link, Text\_(), et Session\getFormToken().

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.contenthistory'
protected

◆ $type

$type = 'ContentHistory'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContenthistoryField.php


Joomla CMS: Référence de la classe ContentlanguageField

  • Joomla
  • CMS
  • Form
  • Field
  • ContentlanguageField
Champs de données | Fonctions membres protégées
Référence de la classe ContentlanguageField
+ Graphe d'héritage de ContentlanguageField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'ContentLanguage'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides a list of content languages

Voir également
for a select list of application languages.
Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options for content languages.

Renvoie
array The options the field is going to show.
Depuis
1.6

Références HTMLHelper\_().

Documentation des champs

◆ $type

$type = 'ContentLanguage'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentlanguageField.php


Joomla CMS: Référence de la classe ContenttypeField

  • Joomla
  • CMS
  • Form
  • Field
  • ContenttypeField
Champs de données | Fonctions membres protégées
Référence de la classe ContenttypeField
+ Graphe d'héritage de ContenttypeField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Contenttype'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Content Type field.

Depuis
3.1

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input for a list of content types.

Renvoie
string The field input.
Depuis
3.1

Références Joomla\Application\getInput(), et value.

◆ getOptions()

getOptions ( )
protected

Method to get a list of content types

Renvoie
array The field option objects.
Depuis
3.1

Références $db, $lang, $option, $options, $parts, $query, Text\_(), Joomla\Database\getDatabase(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $type

$type = 'Contenttype'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContenttypeField.php


Joomla CMS: Référence de la classe DatabaseconnectionField

  • Joomla
  • CMS
  • Form
  • Field
  • DatabaseconnectionField
Fonctions membres protégées | Attributs protégés
Référence de la classe DatabaseconnectionField
+ Graphe d'héritage de DatabaseconnectionField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Databaseconnection'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a list of available database connections, optionally limiting to a given list.

Voir également
DatabaseDriver
Depuis
1.7.3

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the list of database options.

This method produces a drop down list of available databases supported by DatabaseDriver classes that are also supported by the application.

Renvoie
array The field option objects.
Depuis
1.7.3
Voir également
DatabaseDriver::getConnectors()

This gets the list of database types supported by the application. This should be entered in the form definition as a comma separated list. If no supported databases are listed, it is assumed all available databases are supported.

Références $options, et Text\_().

Documentation des champs

◆ $type

$type = 'Databaseconnection'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseconnectionField.php


Joomla CMS: Référence de la classe EditorField

  • Joomla
  • CMS
  • Form
  • Field
  • EditorField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe EditorField
+ Graphe d'héritage de EditorField:
TextareaField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de TextareaField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'Editor'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getEditor ()
- Fonctions membres protégées hérités de TextareaField
getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$editor
$height
$width
$assetField
$authorField
$asset
$buttons
$hide
$editorType
$parentclass
- Attributs protégés hérités de TextareaField
$type = 'Textarea'
$rows
$columns
$maxlength
$charcounter = false
$layout = 'joomla.form.field.textarea'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

A textarea field for content creation

Voir également
JEditor
Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, $value, et elseif.

◆ getEditor()

getEditor ( )
protected

Method to get an Editor object based on the form field.

Renvoie
Editor The Editor object.
Depuis
1.6

Références $db, $editor, $query, Factory\getApplication(), Joomla\Database\getDatabase(), Editor\getInstance(), et null.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for the editor area

Renvoie
string The field input markup.
Depuis
1.6

Références $editor, $params, $this, ENT_COMPAT, name, value, et width.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $buttons, $result, $value, elseif, et width.

Documentation des champs

◆ $asset

$asset
protected

◆ $assetField

$assetField
protected

◆ $authorField

$authorField
protected

◆ $buttons

$buttons
protected

◆ $editor

$editor
protected

◆ $editorType

$editorType
protected

◆ $height

$height
protected

◆ $hide

$hide
protected

◆ $parentclass

$parentclass
protected

◆ $type

$type = 'Editor'

◆ $width

$width
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • EditorField.php


Joomla CMS: Référence de la classe EmailField

  • Joomla
  • CMS
  • Form
  • Field
  • EmailField
Fonctions membres protégées | Attributs protégés
Référence de la classe EmailField
+ Graphe d'héritage de EmailField:
TextField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Email'
$layout = 'joomla.form.field.email'
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides and input field for email addresses

1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for email addresses.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $data.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.email'
protected

◆ $type

$type = 'Email'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • EmailField.php


Joomla CMS: Référence de la classe FileField

  • Joomla
  • CMS
  • Form
  • Field
  • FileField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FileField
+ Graphe d'héritage de FileField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'File'
$accept
$layout = 'joomla.form.field.file'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides an input field for files

1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for the file field. Field attributes allow specification of a maximum file size and a string of accepted file extensions.

Renvoie
string The field input markup.
Note
The field does not include an upload mechanism.
Voir également
Depuis
1.7.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.6

Références $data.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $accept

$accept
protected

◆ $layout

$layout = 'joomla.form.field.file'
protected

◆ $type

$type = 'File'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FileField.php


Joomla CMS: Référence de la classe FilelistField

  • Joomla
  • CMS
  • Form
  • Field
  • FilelistField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FilelistField
+ Graphe d'héritage de FilelistField:
ListField FormField DatabaseAwareInterface ImagelistField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Filelist'
$fileFilter
$exclude
$hideNone = false
$hideDefault = false
$stripExt = false
$directory
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML select list of files

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getOptions()

getOptions ( )
protected

Method to get the list of files for the field options. Specify the target directory with a directory attribute Attributes allow an exclude mask and stripping of extensions from file name. Default attribute may optionally be set to null (no file) or -1 (use a default).

Renvoie
array The field option objects.
Depuis
1.7.0

Références $options, $path, HTMLHelper\_(), Text\alt(), Path\clean(), Folder\files(), JPATH_ROOT, et File\stripExt().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $directory

$directory
protected

◆ $exclude

$exclude
protected

◆ $fileFilter

$fileFilter
protected

◆ $hideDefault

$hideDefault = false
protected

◆ $hideNone

$hideNone = false
protected

◆ $stripExt

$stripExt = false
protected

◆ $type

$type = 'Filelist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FilelistField.php


Joomla CMS: Référence de la classe FolderlistField

  • Joomla
  • CMS
  • Form
  • Field
  • FolderlistField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FolderlistField
+ Graphe d'héritage de FolderlistField:
ListField FormField DatabaseAwareInterface TemplatesListField UploaddirsField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Folderlist'
$folderFilter
$exclude
$recursive
$hideNone = false
$hideDefault = false
$directory
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML select list of folder

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $folder, $options, $path, HTMLHelper\_(), Text\alt(), Path\clean(), Folder\folders(), et JPATH_ROOT.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $directory

$directory
protected

◆ $exclude

$exclude
protected

◆ $folderFilter

$folderFilter
protected

◆ $hideDefault

$hideDefault = false
protected

◆ $hideNone

$hideNone = false
protected

◆ $recursive

$recursive
protected

◆ $type

$type = 'Folderlist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FolderlistField.php


Joomla CMS: Référence de la classe FrontendlanguageField

  • Joomla
  • CMS
  • Form
  • Field
  • FrontendlanguageField
Champs de données | Fonctions membres protégées
Référence de la classe FrontendlanguageField
+ Graphe d'héritage de FrontendlanguageField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Frontend_Language'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides a list of published content languages with home pages

Voir également
for a select list of application languages.
Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options for frontend published content languages with homes.

Renvoie
array The options the field is going to show.
Depuis
3.5

Références $db, $languages, $query, Factory\getApplication(), Joomla\Database\getDatabase(), et Factory\getUser().

Documentation des champs

◆ $type

$type = 'Frontend_Language'
La documentation de cette classe a été générée à partir du fichier suivant :
  • FrontendlanguageField.php


Joomla CMS: Référence de la classe GroupedlistField

  • Joomla
  • CMS
  • Form
  • Field
  • GroupedlistField
Fonctions membres protégées | Attributs protégés
Référence de la classe GroupedlistField
+ Graphe d'héritage de GroupedlistField:
FormField DatabaseAwareInterface ChromestyleField MenuField MenuitemField TemplatestyleField TimezoneField WorkflowstageField ItemtypeField ContentmapField MenuItemByTypeField

Fonctions membres protégées

getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a grouped list select field.

Depuis
1.7.0

Documentation des fonctions membres

◆ getGroups()

getGroups ( )
protected

Method to get the field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
1.7.0
Exceptions

Références $disabled, $groups, $label, $option, $tmp, Text\_(), HTMLHelper\_(), et Text\alt().

◆ getInput()

getInput ( )
protected

Method to get the field input markup fora grouped list. Multiselect is enabled by using the multiple attribute.

Renvoie
string The field input markup.
Depuis
1.7.0

Références $data.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.groupedlist'
protected

◆ $type

$type = 'Groupedlist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • GroupedlistField.php


Joomla CMS: Référence de la classe HeadertagField

  • Joomla
  • CMS
  • Form
  • Field
  • HeadertagField
Fonctions membres protégées | Attributs protégés
Référence de la classe HeadertagField
+ Graphe d'héritage de HeadertagField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'HeaderTag'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla! CMS.

Depuis
3.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.0

Références $options, $tmp, et HTMLHelper\_().

Documentation des champs

◆ $type

$type = 'HeaderTag'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HeadertagField.php


Joomla CMS: Référence de la classe HiddenField

  • Joomla
  • CMS
  • Form
  • Field
  • HiddenField
Fonctions membres protégées | Attributs protégés
Référence de la classe HiddenField
+ Graphe d'héritage de HiddenField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Hidden'
$layout = 'joomla.form.field.hidden'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a hidden field

1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.hidden'
protected

◆ $type

$type = 'Hidden'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HiddenField.php


Joomla CMS: Référence de la classe ImagelistField

  • Joomla
  • CMS
  • Form
  • Field
  • ImagelistField
Fonctions membres protégées | Attributs protégés
Référence de la classe ImagelistField
+ Graphe d'héritage de ImagelistField:
FilelistField ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de FilelistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Imagelist'
- Attributs protégés hérités de FilelistField
$type = 'Filelist'
$fileFilter
$exclude
$hideNone = false
$hideDefault = false
$stripExt = false
$directory
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FilelistField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML select list of image

Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the list of images field options. Use the filter attribute to specify allowable file extensions.

Renvoie
array The field option objects.
Depuis
1.7.0

Documentation des champs

◆ $type

$type = 'Imagelist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ImagelistField.php


Joomla CMS: Référence de la classe IntegerField

  • Joomla
  • CMS
  • Form
  • Field
  • IntegerField
Fonctions membres protégées | Attributs protégés
Référence de la classe IntegerField
+ Graphe d'héritage de IntegerField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Integer'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a select list of integers with specified first, last and step values.

Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $i, $last, $options, $step, HTMLHelper\_(), et elseif.

Documentation des champs

◆ $type

$type = 'Integer'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • IntegerField.php


Joomla CMS: Référence de la classe LanguageField

  • Joomla
  • CMS
  • Form
  • Field
  • LanguageField
Fonctions membres protégées | Attributs protégés
Référence de la classe LanguageField
+ Graphe d'héritage de LanguageField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Language'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a list of installed application languages

Voir également
for a select list of content languages.
Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $b, $client, $lang, $languages, $options, LanguageHelper\createLanguageList(), Factory\getLanguage(), ComponentHelper\getParams(), et value.

Documentation des champs

◆ $type

$type = 'Language'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Form/Field/LanguageField.php


Joomla CMS: Référence de la classe LastvisitdaterangeField

  • Joomla
  • CMS
  • Form
  • Field
  • LastvisitdaterangeField
Fonctions membres publiques
Référence de la classe LastvisitdaterangeField
+ Graphe d'héritage de LastvisitdaterangeField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__construct ($form=null)
- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to show a list of available date ranges to filter on last visit date.

Depuis
3.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $form = null )

Method to instantiate the form field object.

Paramètres
Form $form The form to attach to the form field object.
Depuis
1.7.0

Références $form, $lang, Symfony\Contracts\Service\__construct(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LastvisitdaterangeField.php


Joomla CMS: Référence de la classe LimitboxField

  • Joomla
  • CMS
  • Form
  • Field
  • LimitboxField
Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe LimitboxField
+ Graphe d'héritage de LimitboxField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Limitbox'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$defaultLimits = array(5, 10, 15, 20, 25, 30, 50, 100, 200, 500)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Description détaillée

Field to load a list of possible item count limits

Depuis
3.2

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the options to populate to populate list

Renvoie
array The field option objects.
Depuis
3.2

Références $hash, $options, $showAll, $value, et Text\_().

Documentation des champs

◆ $defaultLimits

$defaultLimits = array(5, 10, 15, 20, 25, 30, 50, 100, 200, 500)
protected

◆ $options

$options = array()
staticprotected

◆ $type

$type = 'Limitbox'
La documentation de cette classe a été générée à partir du fichier suivant :
  • LimitboxField.php


Joomla CMS: Référence de la classe ListField

  • Joomla
  • CMS
  • Form
  • Field
  • ListField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ListField
+ Graphe d'héritage de ListField:
FormField DatabaseAwareInterface AccesslevelField AliastagField AuthorField CachehandlerField CategoryField CheckboxesField ComboField ComponentsField ContentlanguageField ContenttypeField DatabaseconnectionField FilelistField FolderlistField FrontendlanguageField HeadertagField IntegerField LanguageField LimitboxField ModuletagField PluginsField PredefinedlistField RadiobasicField RadioField SessionhandlerField SqlField TagField TransitionField UsergrouplistField WorkflowconditionField LanguageField ExtensionField LogcreatorField LogtypeField ItemlanguageField BannerclientField CategoryeditField ComponentsCategoryField ConfigComponentsField AssocField VotelistField ComponentsFieldgroupField ComponentsFieldsField FieldcontextsField FieldgroupsField SectionField SubfieldsField TypeField BranchesField ContenttypesField SearchfilterField ExtensionstatusField FolderField LocationField PackageField TypeField LanguageclientField MenuOrderingField MenuParentField MenuPresetField MenutypeField MessageStatesField ModulesModuleField ModulesPositionField NewsfeedsField PluginElementField PluginTypeField RedirectField CronField TaskTypeField TemplatelocationField TemplatenameField GroupparentField LevelsField ComponentsWorkflowField WorkflowcontextsField FontsField

Fonctions membres publiques

addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a generic list of options.

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.7.0

Références $name.

◆ addOption()

addOption | ( | $text,
 |  | $attributes = array()
 | ) |

Method to add an option to the list field.

Paramètres
string | $text | Text/Language variable of the option.
array | $attributes | Array of attributes ('name' => 'value' format)
Renvoie
ListField For chaining.
Depuis
3.7.0

Références $attributes, $name, $text, $this, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a generic list. Use the multiple attribute to enable multiselect.

Renvoie
string The field input markup.
Depuis
3.7.0

Références $data.

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.7.0

Références $checked, $component, $disabled, $link, $option, $options, $params, $selected, $text, $tmp, $uri, $value, Text\_(), Text\alt(), Factory\getApplication(), ComponentHelper\getParams(), ModuleHelper\isAdminMultilang(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), Associations\isEnabled(), FormHelper\parseShowOnConditions(), et Text\sprintf().

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.list'
protected

◆ $type

$type = 'List'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ListField.php


Joomla CMS: Référence de la classe MediaField

  • Joomla
  • CMS
  • Form
  • Field
  • MediaField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MediaField
+ Graphe d'héritage de MediaField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
getLayoutData ()
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Media'
$authorField
$asset
$link
$width
$height
$preview
$directory
$previewWidth
$previewHeight
$types
$layout = 'joomla.form.field.media'
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides a modal media selector including upload mechanism

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a media selector. Use attributes to identify specific created_by and asset_id fields

Renvoie
string The field input markup.
Depuis
1.6

Références name.

◆ getLayoutData()

getLayoutData ( )

Get the data that is going to be passed to the layout

Renvoie
array

Local image, for example images/sampledata/cassiopeia/nasa2-640.jpg . We need to validate and make sure the top level folder is one of the directory configured in filesystem local plugin to avoid error message displayed in manage when users click on Select button to select a new image

This is the case where a folder is configured in directory attribute of the form field. The directory needs to be a relative folder of the folder configured in Path to Images Folder config option of Media component. Same with a already stored local image above, we need to validate and make sure top level folder is one of the directory configured in filesystem local plugin

Directory contains adapter information and path, for example via programming or directly defined in xml via directory attribute

Références $data, $folder, $link, $mediaTypes, $path, $preview, $this, $uri, elseif, Factory\getApplication(), ComponentHelper\getParams(), MediaHelper\isValidLocalDirectory(), JPATH_ROOT, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $result, $value, et width.

Documentation des champs

◆ $asset

$asset
protected

◆ $authorField

$authorField
protected

◆ $directory

$directory
protected

◆ $height

$height
protected

◆ $layout

$layout = 'joomla.form.field.media'
protected

◆ $link

$link
protected

◆ $parentclass

$parentclass
protected

◆ $preview

$preview
protected

◆ $previewHeight

$previewHeight
protected

◆ $previewWidth

$previewWidth
protected

◆ $type

$type = 'Media'
protected

◆ $types

$types
protected

◆ $width

$width
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaField.php


Joomla CMS: Référence de la classe MenuField

  • Joomla
  • CMS
  • Form
  • Field
  • MenuField
Champs de données | Fonctions membres protégées
Référence de la classe MenuField
+ Graphe d'héritage de MenuField:
GroupedlistField FormField DatabaseAwareInterface

Champs de données

$type = 'Menu'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML select list of menus

Depuis
1.6

Documentation des fonctions membres

◆ getGroups()

getGroups ( )
protected

Method to get the field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
1.7.0
Exceptions

Références $check, $client, $clientId, $db, $groups, $key, $label, $menu, $option, $options, $opts, $query, $showAll, $user, Text\_(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, et value.

Documentation des champs

◆ $type

$type = 'Menu'
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Form/Field/MenuField.php


Joomla CMS: Référence de la classe MenuitemField

  • Joomla
  • CMS
  • Form
  • Field
  • MenuitemField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe MenuitemField
+ Graphe d'héritage de MenuitemField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'MenuItem'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$menuType
$clientId
$language
$published
$disable
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML grouped select list of menu item grouped by menu

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getGroups()

getGroups ( )
protected

Method to get the field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
1.6

Références $db, $groups, $items, $lang, $link, $menu, $menuType, $query, $this, HTMLHelper\_(), Joomla\Database\getDatabase(), MenusHelper\getMenuLinks(), et language.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $result, $value, et language.

Documentation des champs

◆ $clientId

$clientId
protected

◆ $disable

$disable
protected

◆ $language

$language
protected

◆ $menuType

$menuType
protected

◆ $published

$published
protected

◆ $type

$type = 'MenuItem'
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuitemField.php


Joomla CMS: Référence de la classe MeterField

  • Joomla
  • CMS
  • Form
  • Field
  • MeterField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MeterField
+ Graphe d'héritage de MeterField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Meter'
$active = false
$animated = true
$max = 100
$striped
$layout = 'joomla.form.field.meter'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a meter to show value in a range.

3.2

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.2

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $data, color, et width.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $active, $return, $value, color, et width.

Documentation des champs

◆ $active

$active = false
protected

◆ $animated

$animated = true
protected

◆ $layout

$layout = 'joomla.form.field.meter'
protected

◆ $max

$max = 100
protected

◆ $striped

$striped
protected

◆ $type

$type = 'Meter'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MeterField.php


Joomla CMS: Référence de la classe ModulelayoutField

  • Joomla
  • CMS
  • Form
  • Field
  • ModulelayoutField
Fonctions membres protégées | Attributs protégés
Référence de la classe ModulelayoutField
+ Graphe d'héritage de ModulelayoutField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ModuleLayout'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to display a list of the layouts for module display from the module or template overrides.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input for module layouts.

Renvoie
string The field input.
Depuis
1.6

Références $attr, $client, $clientId, $db, $groups, $html, $i, $key, $lang, $module, $query, $selected, $template, $text, $value, Text\_(), HTMLHelper\_(), Path\clean(), Folder\files(), ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, name, null, Text\sprintf(), et value.

Documentation des champs

◆ $type

$type = 'ModuleLayout'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulelayoutField.php


Joomla CMS: Référence de la classe ModuleorderField

  • Joomla
  • CMS
  • Form
  • Field
  • ModuleorderField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ModuleorderField
+ Graphe d'héritage de ModuleorderField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ModuleOrder'
$layout = 'joomla.form.field.moduleorder'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Module Order field.

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.6.3

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.6.3

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for the moduleorder field.

Renvoie
string The field input markup.
Depuis
1.6

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.6.3

Références $data, $name, et Session\getFormToken().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.6.3

Références $return, et $value.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.moduleorder'
protected

◆ $type

$type = 'ModuleOrder'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleorderField.php


Joomla CMS: Référence de la classe ModulepositionField

  • Joomla
  • CMS
  • Form
  • Field
  • ModulepositionField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ModulepositionField
+ Graphe d'héritage de ModulepositionField:
TextField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ModulePosition'
$clientId
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Module Position field.

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $clientId, et $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $clientId, $html, $link, $script, Text\_(), HTMLHelper\_(), Factory\getDocument(), et Joomla\Application\getInput().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $client, $clientId, $result, $value, et ApplicationHelper\getClientInfo().

Documentation des champs

◆ $clientId

$clientId
protected

◆ $type

$type = 'ModulePosition'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulepositionField.php


Joomla CMS: Référence de la classe ModuletagField

  • Joomla
  • CMS
  • Form
  • Field
  • ModuletagField
Fonctions membres protégées | Attributs protégés
Référence de la classe ModuletagField
+ Graphe d'héritage de ModuletagField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ModuleTag'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Module Tag field.

Depuis
3.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.0

Références $options, $tmp, et HTMLHelper\_().

Documentation des champs

◆ $type

$type = 'ModuleTag'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuletagField.php


Joomla CMS: Référence de la classe NoteField

  • Joomla
  • CMS
  • Form
  • Field
  • NoteField
Fonctions membres protégées | Attributs protégés
Référence de la classe NoteField
+ Graphe d'héritage de NoteField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Note'
$hiddenLabel = true
$hiddenDescription = true
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a one line text field.

1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
1.7.0

Références $class, $description, $heading, $html, $title, Text\_(), et HTMLHelper\_().

Documentation des champs

◆ $hiddenDescription

$hiddenDescription = true
protected

◆ $hiddenLabel

$hiddenLabel = true
protected

◆ $type

$type = 'Note'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoteField.php


Joomla CMS: Référence de la classe NumberField

  • Joomla
  • CMS
  • Form
  • Field
  • NumberField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe NumberField
+ Graphe d'héritage de NumberField:
FormField DatabaseAwareInterface RangeField IntervalField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Number'
$max = null
$min = null
$step = 0
$layout = 'joomla.form.field.number'
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a one line text box with up-down handles to set a number in the field.

3.2

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.2

Références $component, $link, $params, $uri, $value, Factory\getApplication(), ComponentHelper\getParams(), et Text\sprintf().

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $data, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, $value, et null.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.number'
protected

◆ $max

$max = null
protected

◆ $min

$min = null
protected

◆ $parentclass

$parentclass
protected

◆ $step

$step = 0
protected

◆ $type

$type = 'Number'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NumberField.php


Joomla CMS: Référence de la classe OrderingField

  • Joomla
  • CMS
  • Form
  • Field
  • OrderingField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe OrderingField
+ Graphe d'héritage de OrderingField:
FormField DatabaseAwareInterface PluginorderingField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getQuery ()
getItemId ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Ordering'
$contentType
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Ordering field.

Depuis
3.2

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.2

Références $attr, $html, $itemId, $query, $this, HTMLHelper\_(), class, if, name, et value.

◆ getItemId()

getItemId ( )
protected

Retrieves the current Item's Id.

Renvoie
integer The current item ID
Depuis
3.2

◆ getQuery()

getQuery ( )
protected

Builds the query for the ordering list.

Renvoie
DatabaseQuery The query for the ordering form field
Depuis
3.2

Références $db, $ordering, $query, $this, $title, elseif, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $result, et $value.

Documentation des champs

◆ $contentType

$contentType
protected

◆ $type

$type = 'Ordering'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • OrderingField.php


Joomla CMS: Référence de la classe PasswordField

  • Joomla
  • CMS
  • Form
  • Field
  • PasswordField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PasswordField
+ Graphe d'héritage de PasswordField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Password'
$threshold = 66
$maxLength
$meter = false
$force = false
$layout = 'joomla.form.field.password'
$lock = false
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Text field for passwords

Two password fields may be validated as matching using 1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for password.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $data, et Symfony\Component\Console\Command\lock().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, $value, Factory\getApplication(), ComponentHelper\getParams(), et Symfony\Component\Console\Command\lock().

Documentation des champs

◆ $force

$force = false
protected

◆ $layout

$layout = 'joomla.form.field.password'
protected

◆ $lock

$lock = false
protected

◆ $maxLength

$maxLength
protected

◆ $meter

$meter = false
protected

◆ $threshold

$threshold = 66
protected

◆ $type

$type = 'Password'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PasswordField.php


Joomla CMS: Référence de la classe PluginsField

  • Joomla
  • CMS
  • Form
  • Field
  • PluginsField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PluginsField
+ Graphe d'héritage de PluginsField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Plugins'
$folder
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Framework.

Depuis
2.5.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $folder, et $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
2.5.0

Références $db, $extension, $folder, $i, $item, $lang, $options, $query, $text, Text\_(), Log\add(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, Text\sprintf(), et Log\WARNING.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $folder

$folder
protected

◆ $type

$type = 'Plugins'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginsField.php


Joomla CMS: Référence de la classe PluginstatusField

  • Joomla
  • CMS
  • Form
  • Field
  • PluginstatusField
Champs de données | Attributs protégés
Référence de la classe PluginstatusField
+ Graphe d'héritage de PluginstatusField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Plugin_Status'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Plugin Status field.

Depuis
3.5

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'0' => 'JDISABLED',
'1' => 'JENABLED',
)

◆ $type

$type = 'Plugin_Status'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginstatusField.php


Joomla CMS: Référence de la classe PredefinedlistField

  • Joomla
  • CMS
  • Form
  • Field
  • PredefinedlistField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe PredefinedlistField
+ Graphe d'héritage de PredefinedlistField:
ListField FormField DatabaseAwareInterface LastvisitdaterangeField PluginstatusField RedirectStatusField RegistrationdaterangeField StatusField UseractiveField UserstateField LogsdaterangeField RequeststatusField RequesttypeField ExecutionRuleField TaskStateField

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false

Description détaillée

Form Field to load a list of predefined values

Depuis
3.2

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the options to populate list

Renvoie
array The field option objects.
Depuis
3.2

Références $hash, $options, $text, $type, $val, $value, et Text\_().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
::setup()
Depuis
4.0.0

Références $return, et $value.

Documentation des champs

◆ $options

$options = array()
staticprotected

◆ $optionsFilter

$optionsFilter = []
protected

◆ $predefinedOptions

$predefinedOptions = array()
protected

◆ $translate

$translate = true
protected

◆ $type

$type = 'Predefinedlist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PredefinedlistField.php


Joomla CMS: Référence de la classe RadiobasicField

  • Joomla
  • CMS
  • Form
  • Field
  • RadiobasicField
Fonctions membres protégées | Attributs protégés
Référence de la classe RadiobasicField
+ Graphe d'héritage de RadiobasicField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Radiobasic'
$layout = 'joomla.form.field.radiobasic'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides radio button inputs using default styling

Depuis
4.0.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the radio button field input markup.

Renvoie
string The field input markup.
Depuis
4.0.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
4.0.0

Références $data, et value.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.radiobasic'
protected

◆ $type

$type = 'Radiobasic'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RadiobasicField.php


Joomla CMS: Référence de la classe RadioField

  • Joomla
  • CMS
  • Form
  • Field
  • RadioField
Fonctions membres protégées | Attributs protégés
Référence de la classe RadioField
+ Graphe d'héritage de RadioField:
ListField FormField DatabaseAwareInterface VoteradioField PrivacyField TosField TermsField

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Radio'
$layout = 'joomla.form.field.radio.buttons'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides radio button inputs

1.7.0

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $data, et value.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.radio.buttons'
protected

◆ $type

$type = 'Radio'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RadioField.php


Joomla CMS: Référence de la classe RangeField

  • Joomla
  • CMS
  • Form
  • Field
  • RangeField
Fonctions membres protégées | Attributs protégés
Référence de la classe RangeField
+ Graphe d'héritage de RangeField:
NumberField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de NumberField
getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Range'
$layout = 'joomla.form.field.range'
- Attributs protégés hérités de NumberField
$type = 'Number'
$max = null
$min = null
$step = 0
$layout = 'joomla.form.field.number'
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de NumberField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a horizontal scroll bar to specify a value in a range.

3.2

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.2

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $data.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.range'
protected

◆ $type

$type = 'Range'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RangeField.php


Joomla CMS: Référence de la classe RedirectStatusField

  • Joomla
  • CMS
  • Form
  • Field
  • RedirectStatusField
Champs de données | Attributs protégés
Référence de la classe RedirectStatusField
+ Graphe d'héritage de RedirectStatusField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Redirect_Status'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Redirect Status field.

Depuis
3.8.0

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'-2' => 'JTRASHED',
'0' => 'JDISABLED',
'1' => 'JENABLED',
'2' => 'JARCHIVED',
'*' => 'JALL',
)

◆ $type

$type = 'Redirect_Status'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectStatusField.php


Joomla CMS: Référence de la classe RegistrationdaterangeField

  • Joomla
  • CMS
  • Form
  • Field
  • RegistrationdaterangeField
Fonctions membres publiques | Attributs protégés
Référence de la classe RegistrationdaterangeField
+ Graphe d'héritage de RegistrationdaterangeField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__construct ($form=null)
- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'RegistrationDateRange'
$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Registration Date Range field.

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $form = null )

Method to instantiate the form field object.

Paramètres
Form $form The form to attach to the form field object.
Depuis
1.7.0

Références $form, $lang, Symfony\Contracts\Service\__construct(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'today' => 'COM_USERS_OPTION_RANGE_TODAY',
'past_week' => 'COM_USERS_OPTION_RANGE_PAST_WEEK',
'past_1month' => 'COM_USERS_OPTION_RANGE_PAST_1MONTH',
'past_3month' => 'COM_USERS_OPTION_RANGE_PAST_3MONTH',
'past_6month' => 'COM_USERS_OPTION_RANGE_PAST_6MONTH',
'past_year' => 'COM_USERS_OPTION_RANGE_PAST_YEAR',
'post_year' => 'COM_USERS_OPTION_RANGE_POST_YEAR',
)

◆ $type

$type = 'RegistrationDateRange'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RegistrationdaterangeField.php


Joomla CMS: Référence de la classe RulesField

  • Joomla
  • CMS
  • Form
  • Field
  • RulesField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe RulesField
+ Graphe d'héritage de RulesField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
getUserGroups ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Rules'
$layout = 'joomla.form.field.rules'
$section
$component
$assetField
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Field for assigning permissions to groups for a given asset

Voir également
JAccess
Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for Access Control Lists. Optionally can be associated with a specific component and section.

Renvoie
string The field input markup.
Depuis
1.7.0

Références $component, $db, $query, $section, Access\getActionsFromFile(), Access\getAssetRules(), Joomla\Database\getDatabase(), ParameterType\INTEGER, et JPATH_ADMINISTRATOR.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
4.0.0

Références $data.

◆ getUserGroups()

getUserGroups ( )
protected

Get a list of the user groups.

Renvoie
array
Depuis
1.7.0

Références $option, $options, et UserGroupsHelper\getInstance().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $assetField

$assetField
protected

◆ $component

$component
protected

◆ $layout

$layout = 'joomla.form.field.rules'
protected

◆ $parentclass

$parentclass
protected

◆ $section

$section
protected

◆ $type

$type = 'Rules'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RulesField.php


Joomla CMS: Référence de la classe SessionhandlerField

  • Joomla
  • CMS
  • Form
  • Field
  • SessionhandlerField
Fonctions membres protégées | Attributs protégés
Référence de la classe SessionhandlerField
+ Graphe d'héritage de SessionhandlerField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Sessionhandler'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a select list of session handler options.

Depuis
1.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the session handler field options.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $options, Text\_(), HTMLHelper\_(), et Session\getHandlers().

Documentation des champs

◆ $type

$type = 'Sessionhandler'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionhandlerField.php


Joomla CMS: Référence de la classe SpacerField

  • Joomla
  • CMS
  • Form
  • Field
  • SpacerField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SpacerField
+ Graphe d'héritage de SpacerField:
FormField DatabaseAwareInterface

Fonctions membres publiques

renderField ($options=array())
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLabel ()
getTitle ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Spacer'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides spacer markup to be used in form layouts.

Depuis
1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a spacer. The spacer does not have accept input.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup for a spacer. Use the label text or name from the XML element as the spacer or Use a hr="true" to automatically generate plain hr markup

Renvoie
string The field label markup.
Depuis
1.7.0

Références $class, $html, $label, $text, Text\_(), HTMLHelper\_(), description, ENT_COMPAT, Factory\getLanguage(), if, et true.

◆ getTitle()

getTitle ( )
protected

Method to get the field title.

Renvoie
string The field title.
Depuis
1.7.0

◆ renderField()

renderField ( $options = array() )

Method to get a control group with label and input.

Paramètres
array $options Options to be passed into the rendering of the field
Renvoie
string A string containing the html for the control group
Depuis
3.7.3

Références $options.

Documentation des champs

◆ $type

$type = 'Spacer'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SpacerField.php


Joomla CMS: Référence de la classe SqlField

  • Joomla
  • CMS
  • Form
  • Field
  • SqlField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe SqlField
+ Graphe d'héritage de SqlField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'SQL'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

processQuery ($conditions, $filters, $defaults)
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$keyField
$valueField
$translate = false
$query
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a custom SQL select list

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getOptions()

getOptions ( )
protected

Method to get the custom field options. Use the query attribute to supply a query to generate the list.

Renvoie
array The field option objects.
Depuis
1.7.0

Références $db, $header, $item, $items, $key, $options, $value, Text\_(), HTMLHelper\_(), Factory\getApplication(), et Joomla\Database\getDatabase().

◆ processQuery()

processQuery | ( | $conditions,
 |  | $filters,
 |  | $defaults
 | ) |
protected

Method to process the query from form.

Paramètres
array | $conditions | The conditions from the form.
string | $filters | The columns to filter.
array | $defaults | The defaults value to set if condition is empty.
Renvoie
DatabaseQuery The query object.
Depuis
3.5

Références $db, $filters, $query, $value, elseif, Factory\getApplication(), et Joomla\Database\getDatabase().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $filters, $name, $query, $return, et $value.

Documentation des champs

◆ $keyField

$keyField
protected

◆ $query

$query
protected

◆ $translate

$translate = false
protected

◆ $type

$type = 'SQL'

◆ $valueField

$valueField
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlField.php


Joomla CMS: Référence de la classe StatusField

  • Joomla
  • CMS
  • Form
  • Field
  • StatusField
Champs de données | Attributs protégés
Référence de la classe StatusField
+ Graphe d'héritage de StatusField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Status'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to load a list of states

Depuis
3.2

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
-2 => 'JTRASHED',
0 => 'JUNPUBLISHED',
1 => 'JPUBLISHED',
2 => 'JARCHIVED',
'*' => 'JALL',
)

◆ $type

$type = 'Status'
La documentation de cette classe a été générée à partir du fichier suivant :
  • StatusField.php


Joomla CMS: Référence de la classe SubformField

  • Joomla
  • CMS
  • Form
  • Field
  • SubformField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SubformField
+ Graphe d'héritage de SubformField:
FormField DatabaseAwareInterface AccessiblemediaField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
loadSubForm ()
filter ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getName ($fieldName)
loadSubFormData (Form $subForm)
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Subform'
$formsource
$min = 0
$max = 1000
$layout = 'joomla.form.field.subform.default'
$groupByFieldset = false
$buttons = array('add' => true, 'remove' => true, 'move' => true)
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

The Field to load the form inside current form

with all attributes: <field name="field-name" type="subform" formsource="path/to/form.xml" min="1" max="3" multiple="true" buttons="add,remove,move" layout="joomla.form.field.subform.repeatable-table" groupbyfieldset="false" component="com_example" client="site" label="Field Label" description="Field Description">

Depuis
3.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.6

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.6

Références $name, $value, Path\clean(), JPATH_ROOT, null, et value.

◆ filter()

filter | ( |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null
 | ) |  |

Method to filter a field value.

Paramètres
mixed | $value | The optional value to use as the default for the field.
string | $group | The optional dot-separated form group path on which to find the field.
Registry | $input | An optional Registry object with the entire data set to filter against the entire form.
Renvoie
mixed The filtered value.
Depuis
4.0.0
Exceptions

Références $input, $key, $return, $this, $val, $value, et null.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.6

For each rendering process of a subform element, we want to have a separate unique subform id present to could distinguish the eventhandlers regarding adding/moving/removing rows from nested subforms from their parents.

Références $buttons, $control, $data, $html, $id, $name, $renderer, $tmpl, name, et null.

◆ getName()

getName ( $fieldName )
protected

Method to get the name used for the field input tag.

Paramètres
string $fieldName The field element name.
Renvoie
string The name to be used for the field input tag.
Depuis
3.6

Références $groups, et $name.

◆ loadSubForm()

loadSubForm ( )

Loads the form instance for the subform.

Renvoie
Form The form instance.
Exceptions

Références $control, $name, $tmpl, Form\getInstance(), et name.

◆ loadSubFormData()

loadSubFormData ( Form $subForm )
protected

Binds given data to the subform and its elements.

Paramètres
Form $subForm Form instance of the subform.
Renvoie
Form[] Array of Form instances for the rows.
Depuis
3.9.7

Références $c, $control, $i, $value, Form\bind(), Form\getInstance(), Form\getName(), name, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value.
Renvoie
boolean True on success.
Depuis
3.6

Références $value, et value.

Documentation des champs

◆ $buttons

array $buttons = array('add' => true, 'remove' => true, 'move' => true)
protected

Which buttons to show in multiple mode

◆ $formsource

$formsource
protected

◆ $groupByFieldset

$groupByFieldset = false
protected

◆ $layout

$layout = 'joomla.form.field.subform.default'
protected

◆ $max

$max = 1000
protected

◆ $min

$min = 0
protected

◆ $type

$type = 'Subform'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubformField.php


Joomla CMS: Référence de la classe TagField

  • Joomla
  • CMS
  • Form
  • Field
  • TagField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe TagField
+ Graphe d'héritage de TagField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__construct ()
isNested ()
allowCustom ()
isRemoteSearch ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'Tag'
$isNested = null
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getOptions ()
prepareOptionsNested (&$options)
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$comParams = null
$layout = 'joomla.form.field.tag'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

List of Tags field.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor

Depuis
3.1

Références Symfony\Contracts\Service\__construct(), et ComponentHelper\getParams().

Documentation des fonctions membres

◆ allowCustom()

allowCustom ( )

Determines if the field allows or denies custom values

Renvoie
boolean

Références Factory\getUser().

◆ getInput()

getInput ( )
protected

Method to get the field input for a tag field.

Renvoie
string The field input.
Depuis
3.1

Références $data, $value, et value.

◆ getOptions()

getOptions ( )
protected

Method to get a list of tags

Renvoie
array The field option objects.
Depuis
3.1

Références $app, $count, $db, $id, $language, $option, $options, $published, $query, TagsHelper\convertPathsToNames(), elseif, Factory\getApplication(), ArrayHelper\getColumn(), Joomla\Database\getDatabase(), ComponentHelper\getParams(), ParameterType\INTEGER, Multilanguage\isEnabled(), null, ParameterType\STRING, ArrayHelper\toInteger(), et value.

◆ isNested()

isNested ( )

Determine if the field has to be tagnested

Renvoie
boolean
Depuis
3.1

Références null.

◆ isRemoteSearch()

isRemoteSearch ( )

Check whether need to enable AJAX search

Renvoie
boolean
Depuis
4.0.0

◆ prepareOptionsNested()

prepareOptionsNested ( & $options )
protected

Add "-" before nested tags, depending on level

Paramètres
array &$options Array of tags
Renvoie
array The field option objects.
Depuis
3.1

Références $option, et $options.

Documentation des champs

◆ $comParams

$comParams = null
protected

◆ $isNested

$isNested = null

◆ $layout

$layout = 'joomla.form.field.tag'
protected

◆ $type

$type = 'Tag'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagField.php


Joomla CMS: Référence de la classe TelephoneField

  • Joomla
  • CMS
  • Form
  • Field
  • TelephoneField
Fonctions membres protégées | Attributs protégés
Référence de la classe TelephoneField
+ Graphe d'héritage de TelephoneField:
TextField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Telephone'
$layout = 'joomla.form.field.tel'
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a text field telephone numbers.

for telephone number validation JHtmlTel for rendering of telephone numbers 1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.2

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7.0

Références $data.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.tel'
protected

◆ $type

$type = 'Telephone'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TelephoneField.php


Joomla CMS: Référence de la classe TemplatestyleField

  • Joomla
  • CMS
  • Form
  • Field
  • TemplatestyleField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe TemplatestyleField
+ Graphe d'héritage de TemplatestyleField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'TemplateStyle'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$clientName
$template
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a select grouped list of template styles

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getGroups()

getGroups ( )
protected

Method to get the list of template style options grouped by template. Use the client attribute to specify a specific client. Use the template attribute to specify a specific template

Renvoie
array The field option objects as a nested array in groups.
Depuis
1.6

Références $client, $db, $groups, $lang, $name, $query, $style, $template, Text\_(), HTMLHelper\_(), ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Factory\getLanguage(), et ParameterType\INTEGER.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $result, et $value.

Documentation des champs

◆ $clientName

$clientName
protected

◆ $template

$template
protected

◆ $type

$type = 'TemplateStyle'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatestyleField.php


Joomla CMS: Référence de la classe TextareaField

  • Joomla
  • CMS
  • Form
  • Field
  • TextareaField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TextareaField
+ Graphe d'héritage de TextareaField:
FormField DatabaseAwareInterface EditorField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Textarea'
$rows
$columns
$maxlength
$charcounter = false
$layout = 'joomla.form.field.textarea'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a multi line area for entry of plain text

1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the textarea field input markup. Use the rows and columns attributes to specify the dimensions of the area.

Renvoie
string The field input markup.
Depuis
1.7.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $columns, $data, et $rows.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $charcounter

$charcounter = false
protected

◆ $columns

$columns
protected

◆ $layout

$layout = 'joomla.form.field.textarea'
protected

◆ $maxlength

$maxlength
protected

◆ $rows

$rows
protected

◆ $type

$type = 'Textarea'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TextareaField.php


Joomla CMS: Référence de la classe TextField

  • Joomla
  • CMS
  • Form
  • Field
  • TextField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TextField
+ Graphe d'héritage de TextField:
FormField DatabaseAwareInterface EmailField ModulepositionField TelephoneField UrlField WebcronLinkField JoomlatokenField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a one line text field.

1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

Références $component, $link, $params, $uri, $value, Factory\getApplication(), ComponentHelper\getParams(), et Text\sprintf().

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $data, et $options.

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.4

Références $option, $options, HTMLHelper\_(), et Text\alt().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $key, $result, $value, et Text\_().

Documentation des champs

◆ $addonAfter

$addonAfter
protected

◆ $addonBefore

$addonBefore
protected

◆ $dirname

$dirname
protected

◆ $inputmode

$inputmode
protected

◆ $layout

$layout = 'joomla.form.field.text'
protected

◆ $maxLength

$maxLength
protected

◆ $type

$type = 'Text'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TextField.php


Joomla CMS: Référence de la classe TimeField

  • Joomla
  • CMS
  • Form
  • Field
  • TimeField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TimeField
+ Graphe d'héritage de TimeField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Time'
$min
$max
$step
$layout = 'joomla.form.field.time'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Provides a select list of integers with specified first, last and step values.

Depuis
4.0.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
4.0.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
4.0.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
4.0.0

Références $data, et $step.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Voir également
FormField::setup()
Renvoie
boolean True on success.
Depuis
4.0.0

Références $return, $value, et null.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.time'
protected

◆ $max

$max
protected

◆ $min

$min
protected

◆ $step

$step
protected

◆ $type

$type = 'Time'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TimeField.php


Joomla CMS: Référence de la classe TimezoneField

  • Joomla
  • CMS
  • Form
  • Field
  • TimezoneField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe TimezoneField
+ Graphe d'héritage de TimezoneField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Timezone'
$keyField
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $zones = array('Africa', 'America', 'Antarctica', 'Arctic', 'Asia', 'Atlantic', 'Australia', 'Europe', 'Indian', 'Pacific')
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false

Description détaillée

Form Field class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.2

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, et $value.

◆ getGroups()

getGroups ( )
protected

Method to get the time zone field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
1.7.0

Références $groups, $location, et HTMLHelper\_().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $keyField

$keyField
protected

◆ $type

$type = 'Timezone'
protected

◆ $zones

$zones = array('Africa', 'America', 'Antarctica', 'Arctic', 'Asia', 'Atlantic', 'Australia', 'Europe', 'Indian', 'Pacific')
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TimezoneField.php


Joomla CMS: Référence de la classe TransitionField

  • Joomla
  • CMS
  • Form
  • Field
  • TransitionField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TransitionField
+ Graphe d'héritage de TransitionField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Transition'
$extension
$workflowStage
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Components Category field.

Depuis
4.0.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of HTMLHelper options.
Depuis
4.0.0

Références $component, $db, $default, $extension, $item, $items, $options, $parts, $query, $user, Text\_(), HTMLHelper\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), ParameterType\INTEGER, et JPATH_ADMINISTRATOR.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to setup the extension

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $input, $result, $value, extension, et Factory\getApplication().

Documentation des champs

◆ $extension

$extension
protected

◆ $type

$type = 'Transition'
protected

◆ $workflowStage

$workflowStage
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionField.php


Joomla CMS: Référence de la classe UrlField

  • Joomla
  • CMS
  • Form
  • Field
  • UrlField
Fonctions membres protégées | Attributs protégés
Référence de la classe UrlField
+ Graphe d'héritage de UrlField:
TextField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Url'
$layout = 'joomla.form.field.url'
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Platform. Supports a URL text field

for validation of full urls 1.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.1.2 (CMS)

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7

Références $data.

Documentation des champs

◆ $layout

$layout = 'joomla.form.field.url'
protected

◆ $type

$type = 'Url'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UrlField.php


Joomla CMS: Référence de la classe UseractiveField

  • Joomla
  • CMS
  • Form
  • Field
  • UseractiveField
Fonctions membres publiques | Attributs protégés
Référence de la classe UseractiveField
+ Graphe d'héritage de UseractiveField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__construct ($form=null)
- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'UserActive'
$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to show a list of available user active statuses

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $form = null )

Method to instantiate the form field object.

Paramètres
Form $form The form to attach to the form field object.
Depuis
1.7.0

Références $form, $lang, Symfony\Contracts\Service\__construct(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'0' => 'COM_USERS_ACTIVATED',
'1' => 'COM_USERS_UNACTIVATED',
)

◆ $type

$type = 'UserActive'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UseractiveField.php


Joomla CMS: Référence de la classe UserField

  • Joomla
  • CMS
  • Form
  • Field
  • UserField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe UserField
+ Graphe d'héritage de UserField:
FormField DatabaseAwareInterface UserMessagesField

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
getLayoutData ()
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'User'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getGroups ()
getExcluded ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$groups = null
$excluded = null
$layout = 'joomla.form.field.user'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to select a user ID from a modal list.

Depuis
1.6

Documentation des fonctions membres

◆ getExcluded()

getExcluded ( )
protected

Method to get the users to exclude from the list of users

Renvoie
mixed Array of users to exclude or null to to not exclude them
Depuis
1.6

◆ getGroups()

getGroups ( )
protected

Method to get the filtering groups (null means no filtering)

Renvoie
mixed Array of filtering groups or null.
Depuis
1.6

◆ getInput()

getInput ( )
protected

Method to get the user field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références name.

◆ getLayoutData()

getLayoutData ( )

Get the data that is going to be passed to the layout

Renvoie
array
Depuis
3.5

Références $data, $name, $value, Text\_(), elseif, User\getInstance(), Factory\getUser(), null, et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
3.7.0
Voir également
FormField::setup()

Références $return, $value, et Factory\getUser().

Documentation des champs

◆ $excluded

$excluded = null
protected

◆ $groups

$groups = null
protected

◆ $layout

$layout = 'joomla.form.field.user'
protected

◆ $type

$type = 'User'
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserField.php


Joomla CMS: Référence de la classe UsergrouplistField

  • Joomla
  • CMS
  • Form
  • Field
  • UsergrouplistField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe UsergrouplistField
+ Graphe d'héritage de UsergrouplistField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'UserGroupList'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false

Description détaillée

Field to load a dropdown list of available user groups

Depuis
3.2

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the options to populate list

Renvoie
array The field option objects.
Depuis
3.2

Références $groups, $options, Access\checkGroup(), et UserGroupsHelper\getInstance().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
1.7.0

Références $value.

Documentation des champs

◆ $options

$options = array()
staticprotected

◆ $type

$type = 'UserGroupList'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UsergrouplistField.php


Joomla CMS: Référence de la classe UserstateField

  • Joomla
  • CMS
  • Form
  • Field
  • UserstateField
Attributs protégés
Référence de la classe UserstateField
+ Graphe d'héritage de UserstateField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Attributs protégés

$type = 'UserState'
$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to load a list of available users statuses

Depuis
3.2

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'0' => 'JENABLED',
'1' => 'JDISABLED',
)

◆ $type

$type = 'UserState'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserstateField.php


Joomla CMS: Référence de la classe WorkflowComponentSectionsField

  • Joomla
  • CMS
  • Form
  • Field
  • WorkflowComponentSectionsField
Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowComponentSectionsField
+ Graphe d'héritage de WorkflowComponentSectionsField:
ComponentsField ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ComponentsField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'WorkflowComponentSections'
- Attributs protégés hérités de ComponentsField
$type = 'Components'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field class for the Joomla Framework.

Depuis
4.0.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
4.0.0

Références $app, $component, $extension, $item, $items, $options, $text, Text\_(), HTMLHelper\_(), Factory\getApplication(), et Text\sprintf().

Documentation des champs

◆ $type

$type = 'WorkflowComponentSections'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowComponentSectionsField.php


Joomla CMS: Référence de la classe WorkflowconditionField

  • Joomla
  • CMS
  • Form
  • Field
  • WorkflowconditionField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowconditionField
+ Graphe d'héritage de WorkflowconditionField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Workflowcondition'
$extension = ''
$hideAll = false
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Workflow States field.

Depuis
4.0.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
4.0.0

Références $component, $option, $options, $parts, $selected, $text, $tmp, $value, Text\_(), Text\alt(), extension, Factory\getApplication(), et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $value, extension, et Factory\getApplication().

Documentation des champs

◆ $extension

$extension = ''
protected

◆ $hideAll

$hideAll = false
protected

◆ $type

$type = 'Workflowcondition'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowconditionField.php


Joomla CMS: Référence de la classe WorkflowstageField

  • Joomla
  • CMS
  • Form
  • Field
  • WorkflowstageField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowstageField
+ Graphe d'héritage de WorkflowstageField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Workflowstage'
$extension = ''
$activeonly = false
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Workflow Stages field.

Depuis
4.0.0

Documentation des fonctions membres

◆ getGroups()

getGroups ( )
protected

Method to get the field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
4.0.0
Exceptions

Références $db, $query, Text\_(), HTMLHelper\_(), extension, et Joomla\Database\getDatabase().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $result, $value, extension, et Factory\getApplication().

Documentation des champs

◆ $activeonly

$activeonly = false
protected

◆ $extension

$extension = ''
protected

◆ $type

$type = 'Workflowstage'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowstageField.php


Joomla CMS: Référence de la classe IntarrayFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • IntarrayFilter
Fonctions membres publiques
Référence de la classe IntarrayFilter
+ Graphe d'héritage de IntarrayFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for integer arrays

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références $value, et ArrayHelper\toInteger().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IntarrayFilter.php


Joomla CMS: Référence de la classe RawFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • RawFilter
Fonctions membres publiques
Référence de la classe RawFilter
+ Graphe d'héritage de RawFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for raw values

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RawFilter.php


Joomla CMS: Référence de la classe RulesFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • RulesFilter
Fonctions membres publiques
Référence de la classe RulesFilter
+ Graphe d'héritage de RulesFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for rules

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références $id, $return, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RulesFilter.php


Joomla CMS: Référence de la classe SafehtmlFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • SafehtmlFilter
Fonctions membres publiques
Référence de la classe SafehtmlFilter
+ Graphe d'héritage de SafehtmlFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for safe HTML

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références $value, InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SafehtmlFilter.php


Joomla CMS: Référence de la classe TelFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • TelFilter
Fonctions membres publiques
Référence de la classe TelFilter
+ Graphe d'héritage de TelFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for phone numbers

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références $result, $value, elseif, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TelFilter.php


Joomla CMS: Référence de la classe UnsetFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • UnsetFilter
Fonctions membres publiques
Référence de la classe UnsetFilter
+ Graphe d'héritage de UnsetFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class to unset

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsetFilter.php


Joomla CMS: Référence de la classe UrlFilter

  • Joomla
  • CMS
  • Form
  • Filter
  • UrlFilter
Fonctions membres publiques
Référence de la classe UrlFilter
+ Graphe d'héritage de UrlFilter:
FormFilterInterface

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Filter class for URLs

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémente FormFilterInterface.

Références Laminas\Diactoros\$protocol, $value, elseif, Uri\getInstance(), InputFilter\getInstance(), Uri\root(), et PunycodeHelper\urlToPunycode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UrlFilter.php


Joomla CMS: Référence de la classe BooleanRule

  • Joomla
  • CMS
  • Form
  • Rule
  • BooleanRule
Attributs protégés
Référence de la classe BooleanRule
+ Graphe d'héritage de BooleanRule:
FormRule

Attributs protégés

$regex = '^(?:[01]|true|false)$'
$modifiers = 'i'
- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des champs

◆ $modifiers

$modifiers = 'i'
protected

◆ $regex

$regex = '^(?:[01]|true|false)$'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BooleanRule.php


Joomla CMS: Référence de la classe CalendarRule

  • Joomla
  • CMS
  • Form
  • Rule
  • CalendarRule
Fonctions membres publiques
Référence de la classe CalendarRule
+ Graphe d'héritage de CalendarRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform

Depuis
3.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the calendar value for a valid parts.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.7.0

Références $required, $value, et Factory\getDate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CalendarRule.php


Joomla CMS: Référence de la classe CaptchaRule

  • Joomla
  • CMS
  • Form
  • Rule
  • CaptchaRule
Fonctions membres publiques
Référence de la classe CaptchaRule
+ Graphe d'héritage de CaptchaRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Framework.

Depuis
2.5

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if the Captcha is correct.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
2.5

Références $app, $form, $namespace, $value, Factory\getApplication(), et Captcha\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CaptchaRule.php


Joomla CMS: Référence de la classe ColorRule

  • Joomla
  • CMS
  • Form
  • Rule
  • ColorRule
Fonctions membres publiques
Référence de la classe ColorRule
+ Graphe d'héritage de ColorRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test for a valid color in hexadecimal.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0

Références $required, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ColorRule.php


Joomla CMS: Référence de la classe CssIdentifierRule

  • Joomla
  • CMS
  • Form
  • Rule
  • CssIdentifierRule
Fonctions membres publiques
Référence de la classe CssIdentifierRule
+ Graphe d'héritage de CssIdentifierRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
4.0.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if the file path is valid

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
4.0.0

The following regex rules are based on the Html::cleanCssIdentifier method from Drupal https://github.com/drupal/drupal/blob/8.8.5/core/lib/Drupal/Component/Utility/Html.php#L116-L130

with the addition for Joomla that we allow the colon (U+003A).

Valid characters in a CSS identifier are:

  • the hyphen (U+002D)
  • a-z (U+0030 - U+0039)
  • A-Z (U+0041 - U+005A)
  • the underscore (U+005F)
  • the colon (U+003A)
  • 0-9 (U+0061 - U+007A)
  • ISO 10646 characters U+00A1 and higher

Full identifiers cannot start with a digit, two hyphens, or a hyphen followed by a digit.

Références $i, $required, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CssIdentifierRule.php


Joomla CMS: Référence de la classe CssIdentifierSubstringRule

  • Joomla
  • CMS
  • Form
  • Rule
  • CssIdentifierSubstringRule
Fonctions membres publiques
Référence de la classe CssIdentifierSubstringRule
+ Graphe d'héritage de CssIdentifierSubstringRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
3.10.7

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if a string is a valid CSS identifier substring

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.10.7

The following regex rules are based on the Html::cleanCssIdentifier method from Drupal https://github.com/drupal/drupal/blob/8.8.5/core/lib/Drupal/Component/Utility/Html.php#L116-L130

with the addition for Joomla that we allow the colon (U+003A).

Valid characters in a CSS identifier are:

  • the hyphen (U+002D)
  • a-z (U+0030 - U+0039)
  • A-Z (U+0041 - U+005A)
  • the underscore (U+005F)
  • the colon (U+003A)
  • 0-9 (U+0061 - U+007A)
  • ISO 10646 characters U+00A1 and higher

Références $required, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CssIdentifierSubstringRule.php


Joomla CMS: Référence de la classe EmailRule

  • Joomla
  • CMS
  • Form
  • Rule
  • EmailRule
Fonctions membres publiques | Attributs protégés
Référence de la classe EmailRule
+ Graphe d'héritage de EmailRule:
FormRule DatabaseAwareInterface ContactEmailRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$regex
- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the email address and optionally check for uniqueness.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed Boolean true if field value is valid.
Depuis
1.7.0
Exceptions

validDomains value should consist of component name and the name of domain list field in component's configuration, separated by a dot. This allows different components and contexts to use different lists. If value is incomplete, com_users.domains is used as fallback.

Références $config, $db, $form, $input, $key, $query, $required, $userId, $value, Text\_(), PunycodeHelper\emailToPunycode(), Joomla\Database\getDatabase(), ComponentHelper\getParams(), ParameterType\INTEGER, et Text\sprintf().

Documentation des champs

◆ $regex

$regex
protected
Valeur initiale :
= "^[a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])"
. "?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*$"
La documentation de cette classe a été générée à partir du fichier suivant :
  • EmailRule.php


Joomla CMS: Référence de la classe EqualsRule

  • Joomla
  • CMS
  • Form
  • Rule
  • EqualsRule
Fonctions membres publiques
Référence de la classe EqualsRule
+ Graphe d'héritage de EqualsRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if two values are equal. To use this rule, the form XML needs a validate attribute of equals and a field attribute that is equal to the field to test against.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0
Exceptions

Références $field, $form, $input, $this, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • EqualsRule.php


Joomla CMS: Référence de la classe ExistsRule

  • Joomla
  • CMS
  • Form
  • Rule
  • ExistsRule
Fonctions membres publiques
Référence de la classe ExistsRule
+ Graphe d'héritage de ExistsRule:
FormRule DatabaseAwareInterface

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form rule class to determine if a value exists in a database table.

Depuis
3.9.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the username for uniqueness.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.9.0

Références $db, $value, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExistsRule.php


Joomla CMS: Référence de la classe FilePathRule

  • Joomla
  • CMS
  • Form
  • Rule
  • FilePathRule
Fonctions membres publiques
Référence de la classe FilePathRule
+ Graphe d'héritage de FilePathRule:
FormRule FolderPathExistsRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
3.9.21

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if the file path is valid

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.9.21

Références $path, $required, $value, Path\check(), et JPATH_ROOT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FilePathRule.php


Joomla CMS: Référence de la classe FolderPathExistsRule

  • Joomla
  • CMS
  • Form
  • Rule
  • FolderPathExistsRule
Fonctions membres publiques
Référence de la classe FolderPathExistsRule
+ Graphe d'héritage de FolderPathExistsRule:
FilePathRule FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FilePathRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla CMS.

Depuis
4.0.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if the folder path is valid and points to an existing folder below the Joomla root

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid and points to an existing folder below the Joomla root, false otherwise.
Depuis
4.0.0

Références $form, $input, $value, Path\clean(), Folder\exists(), JPATH_ROOT, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FolderPathExistsRule.php


Joomla CMS: Référence de la classe ModuleLayoutRule

  • Joomla
  • CMS
  • Form
  • Rule
  • ModuleLayoutRule
Attributs protégés
Référence de la classe ModuleLayoutRule
+ Graphe d'héritage de ModuleLayoutRule:
FormRule

Attributs protégés

$regex = '^([A-Za-z0-9_-]+:)?[A-Za-z0-9-][A-Za-z0-9\.-]*$'
- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
3.9.26

Documentation des champs

◆ $regex

$regex = '^([A-Za-z0-9_-]+:)?[A-Za-z0-9-][A-Za-z0-9\.-]*$'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleLayoutRule.php


Joomla CMS: Référence de la classe NotequalsRule

  • Joomla
  • CMS
  • Form
  • Rule
  • NotequalsRule
Fonctions membres publiques
Référence de la classe NotequalsRule
+ Graphe d'héritage de NotequalsRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if two values are not equal. To use this rule, the form XML needs a validate attribute of equals and a field attribute that is equal to the field to test against.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0
Exceptions

Références $field, $input, $this, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NotequalsRule.php


Joomla CMS: Référence de la classe NumberRule

  • Joomla
  • CMS
  • Form
  • Rule
  • NumberRule
Fonctions membres publiques
Référence de la classe NumberRule
+ Graphe d'héritage de NumberRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
3.5

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the range for a number value using min and max attributes.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.5

Références $required, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NumberRule.php


Joomla CMS: Référence de la classe OptionsRule

  • Joomla
  • CMS
  • Form
  • Rule
  • OptionsRule
Fonctions membres publiques
Référence de la classe OptionsRule
+ Graphe d'héritage de OptionsRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform. Requires the value entered be one of the options in a field of type="list"

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0

Références $field, $form, $options, $required, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • OptionsRule.php


Joomla CMS: Référence de la classe PasswordRule

  • Joomla
  • CMS
  • Form
  • Rule
  • PasswordRule
Fonctions membres publiques
Référence de la classe PasswordRule
+ Graphe d'héritage de PasswordRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
3.1.2

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if two values are not equal. To use this rule, the form XML needs a validate attribute of equals and a field attribute that is equal to the field to test against.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.1.2
Exceptions

Références $params, $required, $value, Text\_(), Factory\getApplication(), ComponentHelper\getParams(), et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PasswordRule.php


Joomla CMS: Référence de la classe RulesRule

  • Joomla
  • CMS
  • Form
  • Rule
  • RulesRule
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RulesRule
+ Graphe d'héritage de RulesRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Fonctions membres protégées

getValueActions ($value)
getFieldActions (\SimpleXMLElement $element)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ getFieldActions()

getFieldActions ( \SimpleXMLElement $element )
protected

Method to get the list of possible permission action names for the form field.

Paramètres
\SimpleXMLElement $element The object representing the <field> tag for the form field object.
Renvoie
array A list of permission action names from the form field element definition.
Depuis
1.7.0

Références $actions, $component, $item, $section, Access\getActionsFromFile(), et JPATH_ADMINISTRATOR.

◆ getValueActions()

getValueActions ( $value )
protected

Method to get the list of permission action names from the form field value.

Paramètres
mixed $value The form field value to validate.
Renvoie
array A list of permission action names from the form field value.
Depuis
1.7.0

Références $actions, $name, et $value.

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RulesRule.php


Joomla CMS: Référence de la classe SubformRule

  • Joomla
  • CMS
  • Form
  • Rule
  • SubformRule
Fonctions membres publiques
Référence de la classe SubformRule
+ Graphe d'héritage de SubformRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form rule to validate subforms field-wise.

Depuis
3.9.7

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test given values for a subform..

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.9.7

Références $field, $form, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SubformRule.php


Joomla CMS: Référence de la classe TelRule

  • Joomla
  • CMS
  • Form
  • Rule
  • TelRule
Fonctions membres publiques
Référence de la classe TelRule
+ Graphe d'héritage de TelRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the url for a valid parts.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0

Références $required, $value, et elseif.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TelRule.php


Joomla CMS: Référence de la classe TimeRule

  • Joomla
  • CMS
  • Form
  • Rule
  • TimeRule
Fonctions membres publiques
Référence de la classe TimeRule
+ Graphe d'héritage de TimeRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
4.0.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the range for a number value using min and max attributes.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
4.0.0
Exceptions

Références $required, $value, Text\_(), Factory\getApplication(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TimeRule.php


Joomla CMS: Référence de la classe UrlRule

  • Joomla
  • CMS
  • Form
  • Rule
  • UrlRule
Fonctions membres publiques
Référence de la classe UrlRule
+ Graphe d'héritage de UrlRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test an external or internal url for all valid parts.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0 https://www.w3.org/Addressing/URL/url-spec.txt

Références $required, $value, UriHelper\parse_url(), Text\sprintf(), et StringHelper\valid().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UrlRule.php


Joomla CMS: Référence de la classe UserIdRule

  • Joomla
  • CMS
  • Form
  • Rule
  • UserIdRule
Fonctions membres publiques
Référence de la classe UserIdRule
+ Graphe d'héritage de UserIdRule:
FormRule DatabaseAwareInterface

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
4.0.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the validity of a Joomla User.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
?string | $group The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
?Registry | $input An optional Registry object with the entire data set to validate against the entire form.
?Form | $form The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
4.0.0

Références $db, $query, $required, $value, Joomla\Database\getDatabase(), ParameterType\INTEGER, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UserIdRule.php


Joomla CMS: Référence de la classe UsernameRule

  • Joomla
  • CMS
  • Form
  • Rule
  • UsernameRule
Fonctions membres publiques
Référence de la classe UsernameRule
+ Graphe d'héritage de UsernameRule:
FormRule DatabaseAwareInterface

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.7.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the username for uniqueness.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.7.0

Références $db, $form, $query, $userId, $value, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Form/Rule/UsernameRule.php


Joomla CMS: Référence de la classe Form

  • Joomla
  • CMS
  • Form
  • Form
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Form

Fonctions membres publiques

__construct ($name, array $options=[])
bind ($data)
getErrors ()
getField ($name, $group=null, $value=null)
getFieldAttribute ($name, $attribute, $default=null, $group=null)
getFieldset ($set=null)
getFieldsets ($group=null)
getFormControl ()
getGroup ($group, $nested=false)
getInput ($name, $group=null, $value=null)
getLabel ($name, $group=null)
getName ()
getValue ($name, $group=null, $default=null)
renderField ($name, $group=null, $default=null, $options=[])
renderFieldset ($name, $options=[])
load ($data, $replace=true, $xpath=null)
loadFile ($file, $reset=true, $xpath=null)
removeField ($name, $group=null)
removeGroup ($group)
reset ($xml=false)
setField (\SimpleXMLElement $element, $group=null, $replace=true, $fieldset='default')
setFieldAttribute ($name, $attribute, $value, $group=null)
setFields (&$elements, $group=null, $replace=true, $fieldset='default')
setValue ($name, $group=null, $value=null)
process ($data, $group=null)
filter ($data, $group=null)
validate ($data, $group=null)
postProcess ($data, $group=null)
getAttribute ($name, $default=null)
getData ()
getXml ()
getFieldXml ($name, $group=null)

Fonctions membres publiques statiques

static | addFieldPath ($new=null)
static | addFormPath ($new=null)
static | addRulePath ($new=null)
static | addFilterPath ($new=null)
static | getInstance ($name, $data=null, $options=[], $replace=true, $xpath=false)

Champs de données

$repeat = false

Fonctions membres protégées

bindLevel ($group, $data)
findField ($name, $group=null)
& findFieldsByFieldset ($name)
& findFieldsByGroup ($group=null, $nested=false)
& findGroup ($group)
loadField ($element, $group=null, $value=null)
syncPaths ()

Fonctions membres protégées statiques

static | addNode (\SimpleXMLElement $source, \SimpleXMLElement $new)
static | mergeNode (\SimpleXMLElement $source, \SimpleXMLElement $new)
static | mergeNodes (\SimpleXMLElement $source, \SimpleXMLElement $new)

Attributs protégés

$data
$errors = []
$name
$options = []
$xml

Attributs protégés statiques

static $forms = []

Description détaillée

Form Class for the Joomla Platform.

This class implements a robust API for constructing, populating, filtering, and validating forms. It uses XML definitions to construct form fields and a variety of field and rule classes to render and validate the form.

https://html.spec.whatwg.org/multipage/forms.html 1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $options = []
 | ) |  |

Method to instantiate the form object.

Paramètres
string | $name | The name of the form.
array | $options | An array of form options.
Depuis
1.7.0

Références $name, $options, et name.

Documentation des fonctions membres

◆ addFieldPath()

static addFieldPath ( $new = null )
static

Proxy for FormHelper::addFieldPath().

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
1.7.0

Références FormHelper\addFieldPath().

Référencé par PluginModel\getForm(), TaskModel\getForm(), ContactModel\getForm(), StyleModel\getForm(), UpdateModel\getForm(), ModuleModel\getForm(), LanguagesModel\getForm(), Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ addFilterPath()

static addFilterPath ( $new = null )
static

Proxy for FormHelper::addFilterPath().

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Voir également
FormHelper::addFilterPath()
Depuis
4.0.0

Références FormHelper\addFilterPath().

◆ addFormPath()

static addFormPath ( $new = null )
static

Proxy for FormHelper::addFormPath().

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Voir également
FormHelper::addFormPath()
Depuis
1.7.0

Références FormHelper\addFormPath().

Référencé par ContactModel\buildContactExtendedData(), ComponentModel\getForm(), SetupModel\getForm(), ChecksModel\getForm(), UpdateModel\getForm(), LanguagesModel\getForm(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), ModulesModel\preprocessForm(), ModuleModel\preprocessForm(), StyleController\save(), ModuleController\save(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ addNode()

static addNode | ( | \SimpleXMLElement | $source,
 |  | \SimpleXMLElement | $new
 | ) |  |
staticprotected

Adds a new child SimpleXMLElement node to the source.

Paramètres
\SimpleXMLElement | $source | The source element on which to append.
\SimpleXMLElement | $new | The new element to append.
Renvoie
void
Depuis
1.7.0

Références $name, et $value.

◆ addRulePath()

static addRulePath ( $new = null )
static

Proxy for FormHelper::addRulePath().

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Voir également
FormHelper::addRulePath()
Depuis
1.7.0

Références FormHelper\addRulePath().

Référencé par LanguagesModel\getForm().

◆ bind()

bind ( $data )

Method to bind data to the form.

Paramètres
mixed $data An array or object of data to bind to the form.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $data, $this, et null.

Référencé par SubformField\loadSubFormData().

◆ bindLevel()

bindLevel | ( | $group,
 |  | $data
 | ) |
protected

Method to bind data to the form for the group level.

Paramètres
string | $group | The dot-separated form group path on which to bind the data.
mixed | $data | An array or object of data to bind to the form for the group level.
Renvoie
void
Depuis
1.7.0

Références $data, elseif, et ArrayHelper\isAssociative().

◆ filter()

filter | ( | $data,
 |  | $group = null
 | ) |

Method to filter the form data.

Paramètres
array | $data | An array of field values to filter.
string | $group | The dot-separated form group path on which to filter the fields.
Renvoie
mixed Array or false.
Depuis
4.0.0

Références $data, $field, $fields, $groups, $input, $key, $name, $output, et $this.

◆ findField()

findField | ( | $name,
 |  | $group = null
 | ) |
protected

Method to get a form field represented as an XML element object.

Paramètres
string | $name | The name of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
|boolean The XML element object for the field or boolean false on error.
Depuis
1.7.0

Références $field, $fields, $name, $names, $this, et $tmp.

◆ findFieldsByFieldset()

& findFieldsByFieldset ( $name )
protected

Method to get an array of <field> elements from the form XML document which are in a specified fieldset by name.

Paramètres
string $name The name of the fieldset.
Renvoie
[]|boolean Boolean false on error or array of SimpleXMLElement objects.
Depuis
1.7.0

Références $fields, $name, et $this.

◆ findFieldsByGroup()

& findFieldsByGroup | ( | $group = null,
 |  | $nested = false
 | ) |
protected

Method to get an array of <field> elements from the form XML document which are in a control group by name.

Paramètres
mixed | $group | The optional dot-separated form group path on which to find the fields. Null will return all fields. False will return fields not in a group.
boolean | $nested | True to also include fields in nested groups that are inside of the group for which to find fields.
Renvoie
[]|boolean Boolean false on error or array of SimpleXMLElement objects.
Depuis
1.7.0

Références $field, $fields, $names, $this, $tmp, et elseif.

◆ findGroup()

& findGroup ( $group )
protected

Method to get a form field group represented as an XML element object.

Paramètres
string $group The dot-separated form group path on which to find the group.
Renvoie
[]|boolean An array of XML element objects for the group or boolean false on error.
Depuis
1.7.0

Références $fields, $groups, $i, $n, $names, $this, et $tmp.

◆ getAttribute()

getAttribute | ( | $name,
 |  | $default = null
 | ) |

Returns the value of an attribute of the form itself

Paramètres
string | $name | Name of the attribute to get
mixed | $default | Optional value to return if attribute not found
Renvoie
mixed Value of the attribute / default
Depuis
3.2

Références $default, $value, et null.

◆ getData()

getData ( )

Getter for the form data

Renvoie
Registry Object with the data
Depuis
3.2

Références $data.

◆ getErrors()

getErrors ( )

Return all errors, if any.

Renvoie
array Array of error messages or RuntimeException objects.
Depuis
1.7.0

◆ getField()

getField | ( | $name,
 |  | $group = null,
 |  | $value = null
 | ) |

Method to get a form field represented as a FormField object.

Paramètres
string | $name | The name of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
mixed | $value | The optional value to use as the default for the field.
Renvoie
FormField|boolean The FormField object for the field or boolean false on error.
Depuis
1.7.0

Références $name, $this, et $value.

◆ getFieldAttribute()

getFieldAttribute | ( | $name,
 |  | $attribute,
 |  | $default = null,
 |  | $group = null
 | ) |

Method to get an attribute value from a field XML element. If the attribute doesn't exist or is null then the optional default value will be used.

Paramètres
string | $name | The name of the form field for which to get the attribute value.
string | $attribute | The name of the attribute for which to get a value.
mixed | $default | The optional default value to use if no attribute value exists.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
mixed The attribute value for the field.
Depuis
1.7.0
Exceptions

Références $default, $name, et $this.

◆ getFieldset()

getFieldset ( $set = null )

Method to get an array of FormField objects in a given fieldset by name. If no name is given then all fields are returned.

Paramètres
string $set The optional name of the fieldset.
Renvoie
FormField[] The array of FormField objects in the fieldset.
Depuis
1.7.0

Références $field, $fields, et $groups.

◆ getFieldsets()

getFieldsets ( $group = null )

Method to get an array of fieldset objects optionally filtered over a given field group.

Paramètres
string $group The dot-separated form group path on which to filter the fieldsets.
Renvoie
array The array of fieldset objects.
Depuis
1.7.0

Références $fieldsets, $name, $this, $tmp, et $value.

◆ getFieldXml()

getFieldXml | ( | $name,
 |  | $group = null
 | ) |

Method to get a form field represented as an XML element object.

Paramètres
string | $name | The name of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
|boolean The XML element object for the field or boolean false on error.
Depuis
3.7.0

Références $name.

◆ getFormControl()

getFormControl ( )

Method to get the form control. This string serves as a container for all form fields. For example, if there is a field named 'foo' and a field named 'bar' and the form control is empty the fields will be rendered like: <input name="foo" /> and <input name="bar" />. If the form control is set to 'joomla' however, the fields would be rendered like: <input name="joomla[foo]" /> and <input name="joomla[bar]" />.

Renvoie
string The form control string.
Depuis
1.7.0

◆ getGroup()

getGroup | ( | $group,
 |  | $nested = false
 | ) |

Method to get an array of FormField objects in a given field group by name.

Paramètres
string | $group | The dot-separated form group path for which to get the form fields.
boolean | $nested | True to also include fields in nested groups that are inside of the group for which to find fields.
Renvoie
FormField[] The array of FormField objects in the field group.
Depuis
1.7.0

Références $field, $fields, et $groups.

◆ getInput()

getInput | ( | $name,
 |  | $group = null,
 |  | $value = null
 | ) |

Method to get a form field markup for the field input.

Paramètres
string | $name | The name of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
mixed | $value | The optional value to use as the default for the field.
Renvoie
string The form field markup.
Depuis
1.7.0

Références $field, $name, et $value.

◆ getInstance()

static getInstance | ( | $name,
 |  | $data = null,
 |  | $options = [],
 |  | $replace = true,
 |  | $xpath = false
 | ) |
static

Method to get an instance of a form.

Paramètres
string | $name | The name of the form.
string | $data | The name of an XML file or string to load as the form definition.
array | $options | An array of form options.
boolean | $replace | Flag to toggle whether form fields should be replaced if a field already exists with the same group/name.
string | boolean | $xpath | An optional xpath to search for the fields.
Renvoie
Form Form instance.
Depuis
1.7.0
Obsolète:
5.0 Use the FormFactory service from the container
Exceptions

Références $data, $name, $options, class, et Factory\getContainer().

Référencé par ContactModel\buildContactExtendedData(), SetupModel\getForm(), ChecksModel\getForm(), UpdateModel\getForm(), LanguagesModel\getForm(), TinymcebuilderField\getLayoutData(), FormModel\loadForm(), SubformField\loadSubForm(), et SubformField\loadSubFormData().

◆ getLabel()

getLabel | ( | $name,
 |  | $group = null
 | ) |

Method to get the label for a field input.

Paramètres
string | $name | The name of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
string The form field label.
Depuis
1.7.0

Références $field, et $name.

◆ getName()

getName ( )

Method to get the form name.

Renvoie
string The name of the form.
Depuis
1.7.0

Références $name.

Référencé par SubformField\loadSubFormData().

◆ getValue()

getValue | ( | $name,
 |  | $group = null,
 |  | $default = null
 | ) |

Method to get the value of a field.

Paramètres
string | $name | The name of the field for which to get the value.
string | $group | The optional dot-separated form group path on which to get the value.
mixed | $default | The optional default value of the field value is empty.
Renvoie
mixed The value of the field or the default value if empty.
Depuis
1.7.0

Références $default, $name, et $return.

◆ getXml()

getXml ( )

Method to get the XML form object

Renvoie
The form XML object
Depuis
3.2

Références $xml.

◆ load()

load | ( | $data,
 |  | $replace = true,
 |  | $xpath = null
 | ) |

Method to load the form description from an XML string or object.

The replace option works per field. If a field being loaded already exists in the current form definition then the behavior or load will vary depending upon the replace flag. If it is set to true, then the existing field will be replaced in its exact location by the new field being loaded. If it is false, then the new field being loaded will be ignored and the method will move on to the next field to load.

Paramètres
string | $data | The name of an XML string or object.
boolean | $replace | Flag to toggle whether form fields should be replaced if a field already exists with the same group/name.
string | $xpath | An optional xpath to search for the fields.
Renvoie
boolean True on success, false otherwise.
Depuis
1.7.0

Références $data, $field, $fields, $groups, et elseif.

◆ loadField()

loadField | ( | $element,
 |  | $group = null,
 |  | $value = null
 | ) |
protected

Method to load, setup and return a FormField object based on field data.

Paramètres
string | $element | The XML element object representation of the form field.
string | $group | The optional dot-separated form group path on which to find the field.
mixed | $value | The optional value to use as the default for the field.
Renvoie
FormField|boolean The FormField object for the field or boolean false on error.
Depuis
1.7.0

Références $default, $field, $lang, $this, $type, $value, Text\_(), class, Factory\getContainer(), Joomla\Database\getDatabase(), Factory\getLanguage(), FormHelper\loadFieldType(), et null.

◆ loadFile()

loadFile | ( | $file,
 |  | $reset = true,
 |  | $xpath = null
 | ) |

Method to load the form description from an XML file.

The reset option works on a group basis. If the XML file references groups that have already been created they will be replaced with the fields in the new XML file unless the $reset parameter has been set to false.

Paramètres
string | $file | The filesystem path of an XML file.
boolean | $reset | Flag to toggle whether form fields should be replaced if a field already exists with the same group/name.
string | $xpath | An optional xpath to search for the fields.
Renvoie
boolean True on success, false otherwise.
Depuis
1.7.0

Références $xml, et Path\find().

Référencé par StyleModel\preprocessForm(), et CategoryModel\preprocessForm().

◆ mergeNode()

static mergeNode | ( | \SimpleXMLElement | $source,
 |  | \SimpleXMLElement | $new
 | ) |  |
staticprotected

Update the attributes of a child node

Paramètres
\SimpleXMLElement | $source | The source element on which to append the attributes
\SimpleXMLElement | $new | The new element to append
Renvoie
void
Depuis
1.7.0

Références $name, et $value.

◆ mergeNodes()

static mergeNodes | ( | \SimpleXMLElement | $source,
 |  | \SimpleXMLElement | $new
 | ) |  |
staticprotected

Merges new elements into a source <fields> element.

Paramètres
\SimpleXMLElement | $source | The source element.
\SimpleXMLElement | $new | The new element to merge.
Renvoie
void
Depuis
1.7.0

Références $fields, $name, $type, et $value.

◆ postProcess()

postProcess | ( | $data,
 |  | $group = null
 | ) |

Method to post-process form data.

Paramètres
array | $data | An array of field values to post-process.
string | $group | The optional dot-separated form group path on which to filter the fields to be validated.
Renvoie
mixed Array or false.
Depuis
4.0.0

Références $data, $field, $fields, $groups, $input, $key, $name, $output, et $this.

◆ process()

process | ( | $data,
 |  | $group = null
 | ) |

Method to process the form data.

Paramètres
array | $data | An array of field values to filter.
string | $group | The dot-separated form group path on which to filter the fields.
Renvoie
mixed Array or false.
Depuis
4.0.0

Références $data.

◆ removeField()

removeField | ( | $name,
 |  | $group = null
 | ) |

Method to remove a field from the form definition.

Paramètres
string | $name | The name of the form field for which remove.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
boolean True on success, false otherwise.
Depuis
1.7.0
Exceptions

Références $name, et $this.

◆ removeGroup()

removeGroup ( $group )

Method to remove a group from the form definition.

Paramètres
string $group The dot-separated form group path for the group to remove.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $this.

◆ renderField()

renderField | ( | $name,
 |  | $group = null,
 |  | $default = null,
 |  | $options = []
 | ) |

Method to get a control group with label and input.

Paramètres
string | $name | The name of the field for which to get the value.
string | $group | The optional dot-separated form group path on which to get the value.
mixed | $default | The optional default value of the field value is empty.
array | $options | Any options to be passed into the rendering of the field
Renvoie
string A string containing the html for the control group
Depuis
3.2.3

Références $default, $field, $name, et $options.

◆ renderFieldset()

renderFieldset | ( | $name,
 |  | $options = []
 | ) |

Method to get all control groups with label and input of a fieldset.

Paramètres
string | $name | The name of the fieldset for which to get the values.
array | $options | Any options to be passed into the rendering of the field
Renvoie
string A string containing the html for the control groups
Depuis
3.2.3

Références $field, $fields, $html, $name, et $options.

◆ reset()

reset ( $xml = false )

Method to reset the form data store and optionally the form XML definition.

Paramètres
boolean $xml True to also reset the XML form definition.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $xml.

◆ setField()

setField | ( | \SimpleXMLElement | $element,
 |  |  | $group = null,
 |  |  | $replace = true,
 |  |  | $fieldset = 'default'
 | ) |  |

Method to set a field XML element to the form definition. If the replace flag is set then the field will be set whether it already exists or not. If it isn't set, then the field will not be replaced if it already exists.

Paramètres
\SimpleXMLElement | $element | The XML element object representation of the form field.
string | $group | The optional dot-separated form group path on which to set the field.
boolean | $replace | True to replace an existing field if one already exists.
string | $fieldset | The name of the fieldset we are adding the field to.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $fields, $path, et $this.

◆ setFieldAttribute()

setFieldAttribute | ( | $name,
 |  | $attribute,
 |  | $value,
 |  | $group = null
 | ) |

Method to set an attribute value for a field XML element.

Paramètres
string | $name | The name of the form field for which to set the attribute value.
string | $attribute | The name of the attribute for which to set a value.
mixed | $value | The value to set for the attribute.
string | $group | The optional dot-separated form group path on which to find the field.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $name, $this, et $value.

Référencé par FormModel\preprocessForm(), et ItemsModel\preprocessForm().

◆ setFields()

setFields | ( | & | $elements,
 |  |  | $group = null,
 |  |  | $replace = true,
 |  |  | $fieldset = 'default'
 | ) |  |

Method to set some field XML elements to the form definition. If the replace flag is set then the fields will be set whether they already exists or not. If it isn't set, then the fields will not be replaced if they already exist.

Paramètres
array | &$elements | The array of XML element object representations of the form fields.
string | $group | The optional dot-separated form group path on which to set the fields.
boolean | $replace | True to replace existing fields if they already exist.
string | $fieldset | The name of the fieldset we are adding the field to.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $return, et $this.

◆ setValue()

setValue | ( | $name,
 |  | $group = null,
 |  | $value = null
 | ) |

Method to set the value of a field. If the field does not exist in the form then the method will return false.

Paramètres
string | $name | The name of the field for which to set the value.
string | $group | The optional dot-separated form group path on which to find the field.
mixed | $value | The value to set for the field.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $name, et $value.

◆ syncPaths()

syncPaths ( )
protected

Method to synchronize any field, form or rule paths contained in the XML document.

Renvoie
boolean True on success.
Depuis
1.7.0

Références $path, $prefix, $this, FormHelper\addFieldPrefix(), FormHelper\addFilterPrefix(), FormHelper\addFormPrefix(), FormHelper\addRulePrefix(), et JPATH_ROOT.

◆ validate()

validate | ( | $data,
 |  | $group = null
 | ) |

Method to validate form data.

Validation warnings will be pushed into JForm::errors and should be retrieved with JForm::getErrors() when validate returns boolean false.

Paramètres
array | $data | An array of field values to validate.
string | $group | The optional dot-separated form group path on which to filter the fields to be validated.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $data, $disabled, $field, $fields, $groups, $input, $key, $name, $return, $this, Text\_(), elseif, et Text\sprintf().

Documentation des champs

◆ $data

$data
protected

◆ $errors

$errors = []
protected

◆ $forms

$forms = []
staticprotected

◆ $name

$name
protected

◆ $options

$options = []
protected

◆ $repeat

$repeat = false

◆ $xml

$xml
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Form/Form.php


Joomla CMS: Référence de la classe FormFactory

  • Joomla
  • CMS
  • Form
  • FormFactory
Fonctions membres publiques
Référence de la classe FormFactory
+ Graphe d'héritage de FormFactory:
FormFactoryInterface

Fonctions membres publiques

createForm (string $name, array $options=array())

Description détaillée

Default factory for creating Form objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createForm()

createForm | ( | string | $name,
 |  | array | $options = array()
 | ) |  |

Method to get an instance of a form.

Paramètres
string | $name | The name of the form.
array | $options | An array of form options.
Renvoie
Form
Depuis
4.0.0

Implémente FormFactoryInterface.

Références $form, $name, $options, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FormFactory.php


Joomla CMS: Référence de l'interface FormFactoryAwareInterface

  • Joomla
  • CMS
  • Form
  • FormFactoryAwareInterface
Fonctions membres publiques
Référence de l'interface FormFactoryAwareInterface
+ Graphe d'héritage de FormFactoryAwareInterface:
FormController MVCFactory FormModel ListModel AssociationController BannerController ClientController CategoryController ComponentController ContactController ContactController ArticleController ArticleController FieldController GroupController FilterController UpdatesiteController LanguageController OverrideController TemplateController ItemController MenuController MessageController ModuleController NewsfeedController PluginController ConsentsController RequestController LinkController TaskController TagController StyleController GroupController LevelController NoteController UserController StageController TransitionController WorkflowController ApiMVCFactory AdminModel DownloadModel ApplicationModel ComponentModel FormModel FileModel MenuModel ConfigModel TemplateModel LoginModel ProfileModel RegistrationModel RemindModel ResetModel ActionlogsModel AssociationModel AssociationsModel BannersModel ClientsModel TracksModel BannersModel CacheModel CategoriesModel CheckinModel ContactsModel CategoriesModel CategoryModel FeaturedModel ArticlesModel ArticlesModel CategoriesModel CategoryModel CompareModel HistoryModel FieldsModel GroupsModel FiltersModel IndexModel MapsModel SearchesModel SearchModel SuggestionsModel InstallerModel LanguagesModel UpdateModel WarningsModel InstalledModel LanguagesModel OverridesModel TemplatesModel ItemsModel MenusModel MessagesModel ModulesModel PositionsModel SelectModel NewsfeedsModel CategoriesModel CategoryModel PluginsModel ConsentsModel RequestsModel LinksModel SelectModel TasksModel TagsModel TagModel TagsModel StylesModel TemplatesModel DebuggroupModel DebuguserModel GroupsModel LevelsModel NotesModel UsersModel StagesModel TransitionsModel WorkflowsModel

Fonctions membres publiques

setFormFactory (FormFactoryInterface $factory)

Description détaillée

Interface to be implemented by classes depending on a form factory.

Depuis
4.0.0

Documentation des fonctions membres

◆ setFormFactory()

setFormFactory ( FormFactoryInterface $factory )

Set the form factory to use.

Paramètres
FormFactoryInterface $factory The form factory to use.
Renvoie
FormFactoryAwareInterface This method is chainable.
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • FormFactoryAwareInterface.php


Joomla CMS: Référence de l'interface FormFactoryInterface

  • Joomla
  • CMS
  • Form
  • FormFactoryInterface
Fonctions membres publiques
Référence de l'interface FormFactoryInterface
+ Graphe d'héritage de FormFactoryInterface:
FormFactory

Fonctions membres publiques

createForm (string $name, array $options=array())

Description détaillée

Interface defining a factory which can create Form objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createForm()

createForm | ( | string | $name,
 |  | array | $options = array()
 | ) |  |

Method to get an instance of a form.

Paramètres
string | $name | The name of the form.
array | $options | An array of form options.
Renvoie
Form
Depuis
4.0.0

Implémenté dans FormFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FormFactoryInterface.php


Joomla CMS: Référence de la classe FormField

  • Joomla
  • CMS
  • Form
  • FormField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe FormField
+ Graphe d'héritage de FormField:
DatabaseAwareInterface CalendarField CaptchaField CheckboxField ColorField ComponentlayoutField ContenthistoryField FileField GroupedlistField HiddenField ListField MediaField MeterField ModulelayoutField ModuleorderField NoteField NumberField OrderingField PasswordField RulesField SpacerField SubformField TextareaField TextField TimeField UserField PrefixField PlugininfoField AssociationField ClicksField ImpmadeField ImptotalField CategoryField FiltersField ContactField ArticleField FieldLayoutField MenuField ModulesPositioneditField NewsfeedField TinymcebuilderField AbstractStatsField WebauthnField

Fonctions membres publiques

__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$repeat = false

Fonctions membres protégées

getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Abstract Form Field class for the Joomla Platform.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $form = null )

Method to instantiate the form field object.

Paramètres
Form $form The form to attach to the form field object.
Depuis
1.7.0

Références $form, $parts, Normalise\fromCamelCase(), et StringHelper\ucfirst().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
1.7.0

Références $input, $label, $name, et Joomla\Application\getInput().

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.2

Références $name, $value, Log\add(), et name.

◆ filter()

filter | ( |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null
 | ) |  |

Method to filter a field value.

Paramètres
mixed | $value | The optional value to use as the default for the field.
string | $group | The optional dot-separated form group path on which to find the field.
Registry | $input | An optional Registry object with the entire data set to filter against the entire form.
Renvoie
mixed The filtered value.
Depuis
4.0.0
Exceptions

Références $input, $key, $required, $return, $this, $val, $value, InputFilter\getInstance(), FormHelper\loadFilterType(), et null.

◆ getAttribute()

getAttribute | ( | $name,
 |  | $default = null
 | ) |

Method to get an attribute of the field

Paramètres
string | $name | Name of the attribute to get
mixed | $default | Optional value to return if attribute not found
Renvoie
mixed Value of the attribute / default
Depuis
3.2

Références $attributes, $default, et null.

◆ getDataAttributes()

getDataAttributes ( )

Method to get data attributes. For example, data-user-type

Renvoie
array list of data attribute(s)
Depuis
4.0.0

◆ getFieldName()

getFieldName ( $fieldName )
protected

Method to get the field name used.

Paramètres
string $fieldName The field element name.
Renvoie
string The field name
Depuis
1.7.0

Références $count.

◆ getId()

getId | ( | $fieldId,
 |  | $fieldName
 | ) |
protected

Method to get the id used for the field input tag.

Paramètres
string | $fieldId | The field element id.
string | $fieldName | The field element name.
Renvoie
string The id to be used for the field input tag.
Depuis
1.7.0

Références $id.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7.0

Références name.

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
1.7.0

Références $data, et $position.

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $alt, $autocomplete, $autofocus, $class, $description, $disabled, $hint, $id, $label, $name, $onchange, $onclick, $readonly, $this, Text\_(), Text\alt(), description, null, et value.

◆ getLayoutPaths()

getLayoutPaths ( )
protected

Allow to override renderer include paths in child fields

Renvoie
array
Depuis
3.5

Références $renderer.

◆ getName()

getName ( $fieldName )
protected

Method to get the name used for the field input tag.

Paramètres
string $fieldName The field element name.
Renvoie
string The name to be used for the field input tag.
Depuis
1.7.0

Références $groups, et $name.

◆ getRenderer()

getRenderer ( $layoutId = 'default' )
protected

Get the renderer

Paramètres
string $layoutId Id to load
Renvoie
FileLayout
Depuis
3.5

Références $renderer.

◆ getTitle()

getTitle ( )
protected

Method to get the field title.

Renvoie
string The field title.
Depuis
1.7.0

Références $title, et Text\_().

◆ isDebugEnabled()

isDebugEnabled ( )
protected

Is debug enabled for this field

Renvoie
boolean
Depuis
3.5

◆ postProcess()

postProcess | ( |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null
 | ) |  |

Method to post-process a field value.

Paramètres
mixed | $value | The optional value to use as the default for the field.
string | $group | The optional dot-separated form group path on which to find the field.
Registry | $input | An optional Registry object with the entire data set to filter against the entire form.
Renvoie
mixed The processed value.
Depuis
4.0.0

Références $value.

◆ render()

render | ( | $layoutId,
 |  | $data = array()
 | ) |

Render a layout of this field

Paramètres
string | $layoutId | Layout identifier
array | $data | Optional data for the layout
Renvoie
string
Depuis
3.5

Références $data.

◆ renderDataAttributes()

renderDataAttributes ( )

Method to render data attributes to html.

Renvoie
string A HTML Tag Attribute string of data attribute(s)
Depuis
4.0.0

Références $dataAttribute, $key, et ENT_COMPAT.

◆ renderField()

renderField ( $options = array() )

Method to get a control group with label and input.

Paramètres
array $options Options to be passed into the rendering of the field
Renvoie
string A string containing the html for the control group
Depuis
3.2

Références $data, $options, Joomla\Application\getInput(), et FormHelper\parseShowOnConditions().

◆ setForm()

setForm ( Form $form )

Method to attach a Form object to the field.

Paramètres
Form $form The Form object to attach to the form field.
Renvoie
FormField The form field object so that the method can be used in a chain.
Depuis
1.7.0

Références $form, et $this.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
1.7.0

Références $attributes, $key, $value, class, null, et value.

Référencé par IntervalField\setup().

◆ setValue()

setValue ( $value )

Simple method to set the value

Paramètres
mixed $value Value to set
Renvoie
void
Depuis
3.2

Références $value, et value.

◆ validate()

validate | ( |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null
 | ) |  |

Method to validate a FormField object based on field data.

Paramètres
mixed | $value | The optional value to use as the default for the field.
string | $group | The optional dot-separated form group path on which to find the field.
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Renvoie
boolean| Boolean true if field value is valid, Exception on failure.
Depuis
4.0.0
Exceptions

Références $input, $message, $required, $this, $type, $value, Text\_(), class, Factory\getContainer(), Joomla\Database\getDatabase(), FormHelper\loadRuleType(), null, et Text\sprintf().

Documentation des champs

◆ $autocomplete

$autocomplete = 'on'
protected

◆ $autofocus

$autofocus = false
protected

◆ $class

$class
protected

◆ $count

$count = 0
staticprotected

◆ $dataAttributes

$dataAttributes = array()
protected

◆ $default

$default
protected

◆ $description

$description
protected

◆ $disabled

$disabled = false
protected

◆ $element

$element
protected

◆ $fieldname

$fieldname
protected

◆ $form

$form
protected

◆ $formControl

$formControl
protected

◆ $generated_fieldname

$generated_fieldname = '__field'
staticprotected

◆ $group

$group
protected

◆ $hidden

$hidden = false
protected

◆ $hiddenDescription

$hiddenDescription = false
protected

◆ $hiddenLabel

$hiddenLabel = false
protected

◆ $hint

$hint
protected

◆ $id

$id
protected

◆ $input

$input
protected

◆ $label

$label
protected

◆ $labelclass

$labelclass
protected

◆ $layout

$layout
protected

◆ $multiple

$multiple = false
protected

◆ $name

$name
protected

◆ $onchange

$onchange
protected

◆ $onclick

$onclick
protected

◆ $parentclass

$parentclass
protected

◆ $pattern

$pattern
protected

◆ $readonly

$readonly = false
protected

◆ $renderLabelLayout

$renderLabelLayout = 'joomla.form.renderlabel'
protected

◆ $renderLayout

$renderLayout = 'joomla.form.renderfield'
protected

◆ $repeat

$repeat = false

◆ $required

$required = false
protected

◆ $showon

$showon
protected

◆ $size

$size
protected

◆ $spellcheck

$spellcheck = true
protected

◆ $translateDescription

$translateDescription = true
protected

◆ $translateHint

$translateHint = true
protected

◆ $translateLabel

$translateLabel = true
protected

◆ $type

$type
protected

◆ $validate

$validate
protected

◆ $validationtext

$validationtext
protected

◆ $value

$value
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormField.php


Joomla CMS: Référence de l'interface FormFilterInterface

  • Joomla
  • CMS
  • Form
  • FormFilterInterface
Fonctions membres publiques
Référence de l'interface FormFilterInterface
+ Graphe d'héritage de FormFilterInterface:
IntarrayFilter RawFilter RulesFilter SafehtmlFilter TelFilter UnsetFilter UrlFilter

Fonctions membres publiques

filter (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Interface for a filter class.

Depuis
4.0.0

Documentation des fonctions membres

◆ filter()

filter | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to filter a field value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
mixed The filtered value.
Depuis
4.0.0

Implémenté dans UrlFilter, IntarrayFilter, SafehtmlFilter, RawFilter, RulesFilter, TelFilter, et UnsetFilter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FormFilterInterface.php


Joomla CMS: Référence de la classe FormHelper

  • Joomla
  • CMS
  • Form
  • FormHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe FormHelper

Fonctions membres publiques statiques

static | loadFieldType ($type, $new=true)
static | loadRuleType ($type, $new=true)
static | loadFilterType ($type, $new=true)
static | loadFieldClass ($type)
static | loadRuleClass ($type)
static | loadFilterClass ($type)
static | addFieldPath ($new=null)
static | addFormPath ($new=null)
static | addRulePath ($new=null)
static | addFilterPath ($new=null)
static | addFieldPrefix ($new=null)
static | addFormPrefix ($new=null)
static | addRulePrefix ($new=null)
static | addFilterPrefix ($new=null)
static | parseShowOnConditions ($showOn, $formControl=null, $group=null)

Fonctions membres protégées statiques

static | loadType ($entity, $type, $new=true)
static | loadClass ($entity, $type)
static | addPath ($entity, $new=null)
static | addPrefix ($entity, $new=null)

Attributs protégés statiques

static | $paths
static | $prefixes = array('field' => array(), 'form' => array(), 'rule' => array(), 'filter' => array())
static | $entities = array('field' => array(), 'form' => array(), 'rule' => array(), 'filter' => array())

Description détaillée

Form's helper class. Provides a storage for filesystem's paths where Form's entities reside and methods for creating those entities. Also stores objects with entities' prototypes for further reusing.

Depuis
1.7.0

Documentation des fonctions membres

◆ addFieldPath()

static addFieldPath ( $new = null )
static

Method to add a path to the list of field include paths.

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
1.7.0

Référencé par Form\addFieldPath().

◆ addFieldPrefix()

static addFieldPrefix ( $new = null )
static

Method to add a namespace prefix to the list of field lookups.

Paramètres
mixed $new A namespaces or array of namespaces to add.
Renvoie
array The list of namespaces that have been added.
Depuis
3.8.0

Référencé par Form\syncPaths().

◆ addFilterPath()

static addFilterPath ( $new = null )
static

Method to add a path to the list of filter include paths.

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
4.0.0

Référencé par Form\addFilterPath().

◆ addFilterPrefix()

static addFilterPrefix ( $new = null )
static

Method to add a namespace to the list of filter lookups.

Paramètres
mixed $new A namespace or array of namespaces to add.
Renvoie
array The list of namespaces that have been added.
Depuis
4.0.0

Référencé par Form\syncPaths().

◆ addFormPath()

static addFormPath ( $new = null )
static

Method to add a path to the list of form include paths.

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
1.7.0

Référencé par Form\addFormPath(), et FileModel\getForm().

◆ addFormPrefix()

static addFormPrefix ( $new = null )
static

Method to add a namespace to the list of form lookups.

Paramètres
mixed $new A namespace or array of namespaces to add.
Renvoie
array The list of namespaces that have been added.
Depuis
3.8.0

Référencé par Form\syncPaths().

◆ addPath()

static addPath | ( | $entity,
 |  | $new = null
 | ) |
staticprotected

Method to add a path to the list of include paths for one of the form's entities. Currently supported entities: field, rule and form. You are free to support your own in a subclass.

Paramètres
string | $entity | Form's entity name for which paths will be added.
mixed | $new | A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
1.7.0

Références $path.

◆ addPrefix()

static addPrefix | ( | $entity,
 |  | $new = null
 | ) |
staticprotected

Method to add a namespace to the list of namespaces for one of the form's entities. Currently supported entities: field, rule and form. You are free to support your own in a subclass.

Paramètres
string | $entity | Form's entity name for which paths will be added.
mixed | $new | A namespace or array of namespaces to add.
Renvoie
array The list of namespaces that have been added.
Depuis
3.8.0

Références $prefix.

◆ addRulePath()

static addRulePath ( $new = null )
static

Method to add a path to the list of rule include paths.

Paramètres
mixed $new A path or array of paths to add.
Renvoie
array The list of paths that have been added.
Depuis
1.7.0

Référencé par Form\addRulePath(), et FieldModel\checkDefaultValue().

◆ addRulePrefix()

static addRulePrefix ( $new = null )
static

Method to add a namespace to the list of rule lookups.

Paramètres
mixed $new A namespace or array of namespaces to add.
Renvoie
array The list of namespaces that have been added.
Depuis
3.8.0

Référencé par Form\syncPaths().

◆ loadClass()

static loadClass | ( | $entity,
 |  | $type
 | ) |
staticprotected

Load a class for one of the form's entities of a particular type. Currently, it makes sense to use this method for the "field" and "rule" entities (but you can support more entities in your subclass).

Paramètres
string | $entity | One of the form entities (field or rule).
string | $type | Type of an entity.
Renvoie
string|boolean Class name on success or false otherwise.
Depuis
1.7.0

Références $class, $i, $n, $name, $path, $prefix, $type, Path\find(), Normalise\toSpaceSeparated(), et StringHelper\ucfirst().

◆ loadFieldClass()

static loadFieldClass ( $type )
static

Attempt to import the FormField class file if it isn't already imported. You can use this method outside of Form for loading a field for inheritance or composition.

Paramètres
string $type Type of a field whose class should be loaded.
Renvoie
string|boolean Class name on success or false otherwise.
Depuis
1.7.0

Références $type.

◆ loadFieldType()

static loadFieldType | ( | $type,
 |  | $new = true
 | ) |
static

Method to load a form field object given a type.

Paramètres
string | $type | The field type.
boolean | $new | Flag to toggle whether we should get a new instance of the object.
Renvoie
FormField|boolean FormField object on success, false otherwise.
Depuis
1.7.0

Références $type.

Référencé par Form\loadField().

◆ loadFilterClass()

static loadFilterClass ( $type )
static

Attempt to import the FormFilter class file if it isn't already imported. You can use this method outside of Form for loading a filter for inheritance or composition.

Paramètres
string $type Type of a filter whose class should be loaded.
Renvoie
string|boolean Class name on success or false otherwise.
Depuis
4.0.0

Références $type.

◆ loadFilterType()

static loadFilterType | ( | $type,
 |  | $new = true
 | ) |
static

Method to load a form filter object given a type.

Paramètres
string | $type | The rule type.
boolean | $new | Flag to toggle whether we should get a new instance of the object.
Renvoie
FormFilterInterface|boolean FormRule object on success, false otherwise.
Depuis
4.0.0

Références $type.

Référencé par FormField\filter().

◆ loadRuleClass()

static loadRuleClass ( $type )
static

Attempt to import the FormRule class file if it isn't already imported. You can use this method outside of Form for loading a rule for inheritance or composition.

Paramètres
string $type Type of a rule whose class should be loaded.
Renvoie
string|boolean Class name on success or false otherwise.
Depuis
1.7.0

Références $type.

◆ loadRuleType()

static loadRuleType | ( | $type,
 |  | $new = true
 | ) |
static

Method to load a form rule object given a type.

Paramètres
string | $type | The rule type.
boolean | $new | Flag to toggle whether we should get a new instance of the object.
Renvoie
FormRule|boolean FormRule object on success, false otherwise.
Depuis
1.7.0

Références $type.

Référencé par FieldModel\checkDefaultValue(), et FormField\validate().

◆ loadType()

static loadType | ( | $entity,
 |  | $type,
 |  | $new = true
 | ) |
staticprotected

Method to load a form entity object given a type. Each type is loaded only once and then used as a prototype for other objects of same type. Please, use this method only with those entities which support types (forms don't support them).

Paramètres
string | $entity | The entity.
string | $type | The entity type.
boolean | $new | Flag to toggle whether we should get a new instance of the object.
Renvoie
mixed Entity object on success, false otherwise.
Depuis
1.7.0

Références $class, $key, et $type.

◆ parseShowOnConditions()

static parseShowOnConditions | ( | $showOn,
 |  | $formControl = null,
 |  | $group = null
 | ) |
static

Parse the show on conditions

Paramètres
string | $showOn | Show on conditions.
string | $formControl | Form name.
string | $group | The dot-separated form group path.
Renvoie
array Array with show on conditions.
Depuis
3.7.0

Références $field, et $groups.

Référencé par ListField\getOptions(), et FormField\renderField().

Documentation des champs

◆ $entities

$entities = array('field' => array(), 'form' => array(), 'rule' => array(), 'filter' => array())
staticprotected

◆ $paths

$paths
staticprotected

◆ $prefixes

$prefixes = array('field' => array(), 'form' => array(), 'rule' => array(), 'filter' => array())
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormHelper.php


Joomla CMS: Référence de la classe FormRule

  • Joomla
  • CMS
  • Form
  • FormRule
Fonctions membres publiques | Attributs protégés
Référence de la classe FormRule
+ Graphe d'héritage de FormRule:
BooleanRule CalendarRule CaptchaRule ColorRule CssIdentifierRule CssIdentifierSubstringRule EmailRule EqualsRule ExistsRule FilePathRule ModuleLayoutRule NotequalsRule NumberRule OptionsRule PasswordRule RulesRule SubformRule TelRule TimeRule UrlRule UserIdRule UsernameRule PrefixRule UsernameRule ContactEmailMessageRule ContactEmailSubjectRule ExecutionRulesRule LoginUniqueFieldRule LogoutUniqueFieldRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Attributs protégés

$regex
$modifiers = ''

Description détaillée

Form Rule class for the Joomla Platform.

Depuis
1.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test the value.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
1.6
Exceptions

Références $this, $value, et null.

Documentation des champs

◆ $modifiers

$modifiers = ''
protected

◆ $regex

$regex
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormRule.php


Joomla CMS: Référence de la classe Help

  • Joomla
  • CMS
  • Help
  • Help
Fonctions membres publiques statiques
Référence de la classe Help

Fonctions membres publiques statiques

static | createUrl ($ref, $useComponent=false, $override=null, $component=null)
static | createSiteList ($pathToXml)

Description détaillée

Help system class

Depuis
1.5

Documentation des fonctions membres

◆ createSiteList()

static createSiteList ( $pathToXml )
static

Builds a list of the help sites which can be used in a select option.

Paramètres
string $pathToXml Path to an XML file.
Renvoie
array An array of arrays (text, value, selected).
Depuis
1.5

Références $list, $option, et $xml.

◆ createUrl()

static createUrl | ( | $ref,
 |  | $useComponent = false,
 |  | $override = null,
 |  | $component = null
 | ) |
static

Create a URL for a given help key reference

Paramètres
string | $ref | The name of the help screen (its key reference)
boolean | $useComponent | Use the help file in the component directory
string | $override | Use this URL instead of any other
string | $component | Name of component (or null for current component)
Renvoie
string
Depuis
1.5

Références $app, $component, $lang, $params, $url, $version, Text\_(), Factory\getApplication(), ApplicationHelper\getComponentName(), Factory\getLanguage(), ComponentHelper\getParams(), JPATH_BASE, et null.

Référencé par HelpButton\_getCommand(), et HelpModel\getPage().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Help.php


Joomla CMS: Référence de la classe AuthenticationHelper

  • Joomla
  • CMS
  • Helper
  • AuthenticationHelper
Fonctions membres publiques statiques
Référence de la classe AuthenticationHelper

Fonctions membres publiques statiques

static getTwoFactorMethods ()

Description détaillée

Authentication helper class

Depuis
3.6.3

Documentation des fonctions membres

◆ getTwoFactorMethods()

static getTwoFactorMethods ( )
static

No longer used

Renvoie
array Always empty
Depuis
3.6.3
Obsolète:
4.2.0 Will be removed in 5.0.
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationHelper.php


Joomla CMS: Référence de la classe CMSHelper

  • Joomla
  • CMS
  • Helper
  • CMSHelper
Fonctions membres publiques
Référence de la classe CMSHelper
+ Graphe d'héritage de CMSHelper:
TagsHelper

Fonctions membres publiques

getCurrentLanguage ($detectBrowser=true)
getLanguageId ($langCode)
getRowData (TableInterface $table)
getDataObject (TableInterface $table)

Description détaillée

Base Helper class.

Depuis
3.2

Documentation des fonctions membres

◆ getCurrentLanguage()

getCurrentLanguage ( $detectBrowser = true )

Gets the current language

Paramètres
boolean $detectBrowser Flag indicating whether to use the browser language as a fallback.
Renvoie
string The language string
Depuis
3.2

Références $app, LanguageHelper\detectLanguage(), Factory\getApplication(), ApplicationHelper\getHash(), ComponentHelper\getParams(), PluginHelper\getPlugin(), Multilanguage\isEnabled(), et null.

◆ getDataObject()

getDataObject ( TableInterface $table )

Method to get an object containing all of the table columns and values.

Paramètres
TableInterface $table Table object.
Renvoie
Contains all of the columns and values.
Depuis
3.2

Références $field, et $fields.

◆ getLanguageId()

getLanguageId ( $langCode )

Gets the associated language ID

Paramètres
string $langCode The language code to look up
Renvoie
integer The language ID
Depuis
3.2

Références $db, $query, et Factory\getDbo().

◆ getRowData()

getRowData ( TableInterface $table )

Gets a row of data from a table

Paramètres
TableInterface $table Table instance for a row.
Renvoie
array Associative array of all columns and values for a row in a table.
Depuis
3.2

Références $data, $field, $fields, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CMSHelper.php


Joomla CMS: Référence de la classe ContentHelper

  • Joomla
  • CMS
  • Helper
  • ContentHelper
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe ContentHelper
+ Graphe d'héritage de ContentHelper:
AssociationsHelper BannersHelper ConfigHelper ContactHelper ContentHelper MenusHelper NewsfeedsHelper PrivacyHelper UsersHelper StageHelper WorkflowHelper

Fonctions membres publiques

getRowData (Table $table)

Fonctions membres publiques statiques

static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Helper for standard content style extensions. This class mainly simplifies static helper methods often repeated in individual components

Depuis
3.1

Documentation des fonctions membres

◆ addSubmenu()

static addSubmenu ( $vName )
static

Configure the Linkbar. Must be implemented by each extension.

Paramètres
string $vName The name of the active view.
Renvoie
void
Depuis
3.1

◆ countRelations()

static countRelations | ( | & | $items,
 |  |  | $config
 | ) |  |
static

Adds Count relations for Category and Tag Managers

Paramètres

Get relation counts for all category objects with single query NOTE: 'state IN', allows counting specific states / conditions only, also prevents warnings with custom states / conditions, do not remove

Références $config, $db, $item, $items, $n, et Factory\getDbo().

Référencé par Joomla\CMS\Categories\countItems().

◆ getActions()

static getActions | ( | $component = '',
 |  | $section = '',
 |  | $id = 0
 | ) |
static

Gets a list of the actions that can be performed.

Paramètres
string | $component | The component name.
string | $section | The access section name.
integer | $id | The item ID.
Renvoie
CMSObject
Depuis
3.2

Références $actions, $component, $id, $result, $section, $user, Log\add(), Log\ERROR, Access\getActionsFromFile(), Factory\getUser(), JPATH_ADMINISTRATOR, et Text\sprintf().

Référencé par HtmlView\addToolbar(), DisplayController\canView(), et HtmlView\display().

◆ getCurrentLanguage()

static getCurrentLanguage ( $detectBrowser = true )
static

Gets the current language

Paramètres
boolean $detectBrowser Flag indicating whether to use the browser language as a fallback.
Renvoie
string The language string
Depuis
3.1
Note
CmsHelper::getCurrentLanguage is the preferred method

Références $app, LanguageHelper\detectLanguage(), Factory\getApplication(), ApplicationHelper\getHash(), ComponentHelper\getParams(), PluginHelper\getPlugin(), Multilanguage\isEnabled(), et null.

Référencé par TagsPopularHelper\getList(), TagsSimilarHelper\getList(), et TagsModel\getListQuery().

◆ getLanguageId()

static getLanguageId ( $langCode )
static

Gets the associated language ID

Paramètres
string $langCode The language code to look up
Renvoie
integer The language ID
Depuis
3.1
Note
CmsHelper::getLanguage() is the preferred method.

Références $db, $query, et Joomla\CMS\MVC\Model\getDbo().

Référencé par UCMBase\mapBase(), UCMContent\store(), et CoreContent\storeUcmBase().

◆ getRowData()

getRowData ( Table $table )

Gets a row of data from a table

Paramètres
Table $table Table instance for a row.
Renvoie
array Associative array of all columns and values for a row in a table.
Depuis
3.1

Références $data.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Helper/ContentHelper.php


Joomla CMS: Référence de la classe HelperFactory

  • Joomla
  • CMS
  • Helper
  • HelperFactory
Fonctions membres publiques | Attributs privés
Référence de la classe HelperFactory
+ Graphe d'héritage de HelperFactory:
HelperFactoryInterface

Fonctions membres publiques

__construct (string $namespace)
getHelper (string $name, array $config=[])

Attributs privés

$namespace

Description détaillée

Namespace based implementation of the HelperFactoryInterface

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $namespace )

HelperFactory constructor.

Paramètres
string $namespace The namespace
Depuis
4.0.0

Documentation des fonctions membres

◆ getHelper()

getHelper | ( | string | $name,
 |  | array | $config = []
 | ) |  |

Returns a helper instance for the given name.

Paramètres
string | $name | The name
array | $config | The config
Renvoie
Depuis
4.0.0

Implémente HelperFactoryInterface.

Références $className, $config, $helper, $name, Joomla\Database\getDatabase(), et null.

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Helper/HelperFactory.php


Joomla CMS: Référence de l'interface HelperFactoryAwareInterface

  • Joomla
  • CMS
  • Helper
  • HelperFactoryAwareInterface
Fonctions membres publiques
Référence de l'interface HelperFactoryAwareInterface
+ Graphe d'héritage de HelperFactoryAwareInterface:
Dispatcher Dispatcher

Fonctions membres publiques

setHelperFactory (HelperFactory $helper)

Description détaillée

Interface to be implemented by classes depending on a helper factory.

Depuis
4.2.0

Documentation des fonctions membres

◆ setHelperFactory()

setHelperFactory ( HelperFactory $helper )

Sets the helper factory to use.

Paramètres
HelperFactory $helper The helper factory to use.
Renvoie
void
Depuis
4.2.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • HelperFactoryAwareInterface.php


Joomla CMS: Référence de l'interface HelperFactoryInterface

  • Joomla
  • CMS
  • Helper
  • HelperFactoryInterface
Fonctions membres publiques
Référence de l'interface HelperFactoryInterface
+ Graphe d'héritage de HelperFactoryInterface:
Module HelperFactory

Fonctions membres publiques

getHelper (string $name, array $config=[])

Description détaillée

Factory to load helper classes.

Depuis
4.0.0

Documentation des fonctions membres

◆ getHelper()

getHelper | ( | string | $name,
 |  | array | $config = []
 | ) |  |

Returns a helper instance for the given name.

Paramètres
string | $name | The name
array | $config | The config
Renvoie
Depuis
4.0.0

Implémenté dans Module, et HelperFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • HelperFactoryInterface.php


Joomla CMS: Référence de la classe LibraryHelper

  • Joomla
  • CMS
  • Helper
  • LibraryHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe LibraryHelper

Fonctions membres publiques statiques

static | getLibrary ($element, $strict=false)
static | isEnabled ($element)
static | getParams ($element, $strict=false)
static | saveParams ($element, $params)

Attributs protégés statiques

static $libraries = array()

Description détaillée

Library helper class

Depuis
3.2

Documentation des fonctions membres

◆ getLibrary()

static getLibrary | ( | $element,
 |  | $strict = false
 | ) |
static

Get the library information.

Paramètres
string | $element | Element of the library in the extensions table.
boolean | $strict | If set and the library does not exist, the enabled attribute will be set to false.
Renvoie
An object with the library's information.
Depuis
3.2

Références $result, et false.

◆ getParams()

static getParams | ( | $element,
 |  | $strict = false
 | ) |
static

Gets the parameter object for the library

Paramètres
string | $element | Element of the library in the extensions table.
boolean | $strict | If set and the library does not exist, false will be returned
Renvoie
Registry A Registry object.
Voir également
Registry
Depuis
3.2

◆ isEnabled()

static isEnabled ( $element )
static

Checks if a library is enabled

Paramètres
string $element Element of the library in the extensions table.
Renvoie
boolean
Depuis
3.2

◆ saveParams()

static saveParams | ( | $element,
 |  | $params
 | ) |
static

Save the parameters object for the library

Paramètres
string | $element | Element of the library in the extensions table.
Registry | $params | Params to save
Renvoie
Registry|boolean A Registry object.
Voir également
Registry
Depuis
3.2

Références $db, $params, $query, $result, et Factory\getDbo().

Documentation des champs

◆ $libraries

$libraries = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LibraryHelper.php


Joomla CMS: Référence de la classe MediaHelper

  • Joomla
  • CMS
  • Helper
  • MediaHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées
Référence de la classe MediaHelper

Fonctions membres publiques

canUpload ($file, $component='com_media', $allowedExecutables=array())
countFiles ($dir)
toBytes ($val)

Fonctions membres publiques statiques

static | isImage ($fileName)
static | getTypeIcon ($fileName)
static | getMimeType ($file, $isImage=false)
static | checkFileExtension ($extension, $component='com_media', $allowedExecutables=array())
static | imageResize ($width, $height, $target)
static | isValidLocalDirectory ($directory)
static | getCleanMediaFieldValue ($value)

Champs de données

const EXECUTABLES

Fonctions membres privées

checkMimeType ($mime, $component='com_media')

Description détaillée

Media helper class

Depuis
3.2

Documentation des fonctions membres

◆ canUpload()

canUpload | ( | $file,
 |  | $component = 'com_media',
 |  | $allowedExecutables = array()
 | ) |

Checks if the file can be uploaded

Paramètres
array | $file | File information
string | $component | The option name for the component storing the parameters
string | $allowedExecutables | Array of executable file types that shall be whitelisted
Renvoie
boolean
Depuis
3.2

Références $app, $check, $component, $i, $maxSize, $params, $result, $sanitizer, Text\_(), elseif, InputFilter\FORBIDDEN_FILE_EXTENSIONS, Factory\getApplication(), ComponentHelper\getParams(), Factory\getUser(), File\makeSafe(), et Text\sprintf().

◆ checkFileExtension()

static checkFileExtension | ( | $extension,
 |  | $component = 'com_media',
 |  | $allowedExecutables = array()
 | ) |
static

Checks the file extension

Paramètres
string | $extension | The extension to be checked
string | $component | The optional name for the component storing the parameters
Renvoie
boolean true if it passes the checks else false
Depuis
4.0.0

Références $component, $extension, $params, InputFilter\FORBIDDEN_FILE_EXTENSIONS, et ComponentHelper\getParams().

Référencé par LocalAdapter\moveFile().

◆ checkMimeType()

checkMimeType | ( | $mime,
 |  | $component = 'com_media'
 | ) |
private

Checks the Mime type

Paramètres
string | $mime | The mime to be checked
string | $component | The optional name for the component storing the parameters
Renvoie
boolean true if mime type checking is disabled or it passes the checks else false
Depuis
3.7

Références $component, $params, et ComponentHelper\getParams().

◆ countFiles()

countFiles ( $dir )

Counts the files and directories in a directory that are not php or html files.

Paramètres
string $dir Directory name
Renvoie
array The number of media files and directories in the given directory
Depuis
3.2

Références $dir.

◆ getCleanMediaFieldValue()

static getCleanMediaFieldValue ( $value )
static

Helper method get clean data for value stores in a Media form field by removing adapter information from the value if available (in this case, the value will have this format: images/headers/blue-flower.jpg#joomlaImage://local-images/headers/blue-flower.jpg?width=700&height=180)

Paramètres
string $value
Renvoie
string
Depuis
4.0.0

Références $value.

◆ getMimeType()

static getMimeType | ( | $file,
 |  | $isImage = false
 | ) |
static

Get the Mime type

Paramètres
string | $file | The link to the file to be checked
boolean | $isImage | True if the passed file is an image else false
Renvoie
mixed the mime type detected false on error
Depuis
3.7.2

Références elseif.

Référencé par LocalAdapter\getPathInformation().

◆ getTypeIcon()

static getTypeIcon ( $fileName )
static

Gets the file extension for purposed of using an icon

Paramètres
string $fileName The filename
Renvoie
string File extension to determine icon
Depuis
3.2

◆ imageResize()

static imageResize | ( | $width,
 |  | $height,
 |  | $target
 | ) |
static

Calculate the size of a resized image

Paramètres
integer | $width | Image width
integer | $height | Image height
integer | $target | Target size
Renvoie
array The new width and height
Depuis
3.2

Références $height, $target, et $width.

◆ isImage()

static isImage ( $fileName )
static

Checks if the file is an image

Paramètres
string $fileName The filename
Renvoie
boolean
Depuis
3.2

Référencé par LocalAdapter\getPathInformation().

◆ isValidLocalDirectory()

static isValidLocalDirectory ( $directory )
static

Method to check if the given directory is a directory configured in FileSystem - Local plugin

Paramètres
string $directory
Renvoie
boolean
Depuis
4.0.0

Références $params, et PluginHelper\getPlugin().

Référencé par MediaField\getLayoutData().

◆ toBytes()

toBytes ( $val )

Small helper function that properly converts any configuration options to their byte representation.

Paramètres
string | integer $val The value to be converted to bytes.
Renvoie
integer The calculated bytes value from the input.
Depuis
3.3

Références $val.

Documentation des champs

◆ EXECUTABLES

const EXECUTABLES
Valeur initiale :
= array(
'js', 'exe', 'dll', 'go', 'ade', 'adp', 'bat', 'chm', 'cmd', 'com', 'cpl', 'hta',
'ins', 'isp', 'jse', 'lib', 'mde', 'msc', 'msp', 'mst', 'pif', 'scr', 'sct', 'shb',
'sys', 'vb', 'vbe', 'vbs', 'vxd', 'wsc', 'wsf', 'wsh', 'html', 'htm', 'msi'
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaHelper.php


Joomla CMS: Référence de la classe ModuleHelper

  • Joomla
  • CMS
  • Helper
  • ModuleHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ModuleHelper

Fonctions membres publiques statiques

static & | getModule ($name, $title=null)
static & | getModules ($position)
static | isEnabled ($module)
static | renderModule ($module, $attribs=array())
static | renderRawModule ($module, Registry $params, $attribs=array())
static | getLayoutPath ($module, $layout='default')
static | cleanModuleList ($modules)
static | isAdminMultilang ()
static & | getModuleById ($id)

Fonctions membres protégées statiques

static & | load ()
static | createDummyModule ()

Description détaillée

Module helper class

Depuis
1.5

Documentation des fonctions membres

◆ cleanModuleList()

static cleanModuleList ( $modules )
static

Clean the module list

Paramètres
array $modules Array with module objects
Renvoie
array

Références $i, $module, $modules, Factory\getApplication(), et null.

◆ createDummyModule()

static createDummyModule ( )
staticprotected

Method to create a dummy module.

Renvoie
The Module object
Depuis
4.0.0

Références $module.

◆ getLayoutPath()

static getLayoutPath | ( | $module,
 |  | $layout = 'default'
 | ) |
static

Get the path to a layout for a module

Paramètres
string | $module | The name of the module
string | $layout | The name of the module layout. If alternative layout, in the form template:filename.
Renvoie
string The path to the module layout
Depuis
1.5

Références $layout, $module, $temp, $template, Path\check(), Factory\getApplication(), JPATH_BASE, et JPATH_THEMES.

◆ getModule()

static& getModule | ( | $name,
 |  | $title = null
 | ) |
static

Get module by name (real, eg 'Breadcrumbs' or folder, eg 'mod_breadcrumbs')

Paramètres
string | $name | The name of the module
string | $title | The title of the module, optional
Renvoie
The Module object
Depuis
1.5

Références $i, $modules, $name, $result, $title, $total, name, et null.

Référencé par ModuleRenderer\render().

◆ getModuleById()

static& getModuleById ( $id )
static

Get module by id

Paramètres
string $id The id of the module
Renvoie
The Module object
Depuis
3.9.0

Références $i, $id, $modules, $result, et $total.

◆ getModules()

static& getModules ( $position )
static

Get modules by position

Paramètres
string $position The position of the module
Renvoie
array An array of module objects
Depuis
1.5

Références $i, $input, $modules, $position, $result, $total, Factory\getApplication(), et ComponentHelper\getParams().

Référencé par HtmlDocument\countModules(), HtmlView\display(), et ModulesRenderer\render().

◆ isAdminMultilang()

static isAdminMultilang ( )
static

Method to determine if filtering by language is enabled in back-end for modules.

Renvoie
boolean True if enabled; false otherwise.
Depuis
3.8.0

Références $enabled, et ComponentHelper\getParams().

Référencé par HtmlView\display(), ModuleModel\getForm(), MenusModel\getMissingModuleLanguages(), et ListField\getOptions().

◆ isEnabled()

static isEnabled ( $module )
static

Checks if a module is enabled. A given module will only be returned if it meets the following criteria: it is enabled, it is assigned to the current menu item or all items, and the user meets the access level requirements.

Paramètres
string $module The module name
Renvoie
boolean See description for conditions.
Depuis
1.5

Références $module, $result, et null.

◆ load()

static& load ( )
staticprotected

Load published modules.

Renvoie
array
Depuis
3.2

Références $app, $modules, Factory\getApplication(), et null.

◆ renderModule()

static renderModule | ( | $module,
 |  | $attribs = array()
 | ) |
static

Render the module.

Paramètres
object | $module | A module object.
array | $attribs | An array of attributes for the module (probably from the XML).
Renvoie
string The HTML content of the module output.
Depuis
1.5

Références $app, $attribs, $basePath, $displayData, $module, $params, $scope, $style, $template, Log\addLogger(), Log\ALL, Factory\getApplication(), Profiler\getInstance(), ComponentHelper\getParams(), JDEBUG, JPATH_THEMES, null, et LayoutHelper\render().

Référencé par ModuleRenderer\render().

◆ renderRawModule()

static renderRawModule | ( |  | $module,
 |  | Registry | $params,
 |  |  | $attribs = array()
 | ) |  |
static

Render the module content.

Paramètres
object | $module | A module object
Registry | $params | A module parameters
array | $attribs | An array of attributes for the module (probably from the XML).
Renvoie
string
Depuis
4.0.0

Références $app, $module, $scope, Factory\getApplication(), Joomla\CMS\Application\getDispatcher(), Profiler\getInstance(), et JDEBUG.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleHelper.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • CMS
  • Helper
  • RouteHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe RouteHelper
+ Graphe d'héritage de RouteHelper:
RouteHelper TagsHelperRoute

Fonctions membres publiques

getRoute ($id, $typealias, $link='', $language=null, $catid=null)

Fonctions membres publiques statiques

static getCategoryRoute ($catid, $language=0, $extension='')

Fonctions membres protégées

findItem ($needles=array())

Fonctions membres protégées statiques

static lookupItem ($needles=array())

Attributs protégés

$extension
$id
$view

Attributs protégés statiques

static $lookup

Description détaillée

Route Helper

A class providing basic routing for urls that are for content types found in the #__content_types table and rows found in the #__ucm_content table.

Depuis
3.1

Documentation des fonctions membres

◆ findItem()

findItem ( $needles = array() )
protected

Method to find the item in the menu structure

Paramètres
array $needles Array of lookup values
Renvoie
mixed
Depuis
3.1

Références $active, $app, $attributes, $component, $default, $id, $item, $items, $language, $this, $view, extension, Factory\getApplication(), ComponentHelper\getComponent(), Multilanguage\isEnabled(), et null.

◆ getCategoryRoute()

static getCategoryRoute | ( | $catid,
 |  | $language = 0,
 |  | $extension = ''
 | ) |
static

Fetches the category route

Paramètres
mixed | $catid | Category ID or CategoryNode instance
mixed | $language | Language code
string | $extension | Extension to lookup
Renvoie
string
Depuis
3.2
Exceptions

Références $category, $extension, $id, $item, $language, $link, Categories\getInstance(), et Multilanguage\isEnabled().

Référencé par CategoryFeedView\display().

◆ getRoute()

getRoute | ( | $id,
 |  | $typealias,
 |  | $link = '',
 |  | $language = null,
 |  | $catid = null
 | ) |

A method to get the route for a specific item

Paramètres
integer | $id | Value of the primary key for the item in its content table
string | $typealias | The type_alias for the item being routed. Of the form extension.view.
string | $link | The link to be routed
string | $language | The language of the content for multilingual sites
integer | $catid | Optional category id
Renvoie
string The route of the item
Depuis
3.1

Références $category, $id, $item, $language, $link, $name, $view, extension, Factory\getApplication(), Categories\getInstance(), et Multilanguage\isEnabled().

◆ lookupItem()

static lookupItem ( $needles = array() )
staticprotected

Static alias to findItem() used to find the item in the menu structure

Paramètres
array $needles Array of lookup values
Renvoie
mixed
Depuis
3.2

Documentation des champs

◆ $extension

$extension
protected

◆ $id

$id
protected

◆ $lookup

$lookup
staticprotected

◆ $view

$view
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe TagsHelper

  • Joomla
  • CMS
  • Helper
  • TagsHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés
Référence de la classe TagsHelper
+ Graphe d'héritage de TagsHelper:
CMSHelper

Fonctions membres publiques

addTagMapping ($ucmId, TableInterface $table, $tags=array())
createTagsFromField ($tags)
getItemTags ($contentType, $id, $getTagData=true)
getTagIds ($ids, $prefix)
getTagItemsQuery ( $tagId, $typesr=null, $includeChildren=false, $orderByOption='c.core_title', $orderDir='ASC', $anyOrAll=true, $languageFilter='all', $stateFilter='0, 1')
getTagNames ($tagIds)
getTagTreeArray ($id, &$tagTreeArray=array())
postStoreProcess (TableInterface $table, $newTags=array(), $replace=true)
preStoreProcess (TableInterface $table, $newTags=array())
tagDeleteInstances ($tagId)
tagItem ($ucmId, TableInterface $table, $tags=array(), $replace=true)
unTagItem ($contentId, TableInterface $table, $tags=array())
- Fonctions membres publiques hérités de CMSHelper
getCurrentLanguage ($detectBrowser=true)
getLanguageId ($langCode)
getRowData (TableInterface $table)
getDataObject (TableInterface $table)

Fonctions membres publiques statiques

static | convertPathsToNames ($tags)
static | getTypes ($arrayType='objectList', $selectTypes=null, $useAlias=true)
static | searchTags ($filters=array())

Champs de données

$typeAlias
$itemTags

Attributs protégés

$tagsChanged = false
$replaceTags = false

Description détaillée

Tags helper class, provides methods to perform various tasks relevant tagging of content.

Depuis
3.1

Documentation des fonctions membres

◆ addTagMapping()

addTagMapping | ( |  | $ucmId,
 |  | TableInterface | $table,
 |  |  | $tags = array()
 | ) |  |

Method to add tag rows to mapping table.

Paramètres
integer | $ucmId | ID of the #__ucm_content item being tagged
TableInterface | $table | Table object being tagged
array | $tags | Array of tags to be applied.
Renvoie
boolean true on success, otherwise false.
Depuis
3.1

Références $db, $item, $key, $query, TableInterface\getDbo(), TableInterface\getKeyName(), et ParameterType\STRING.

◆ convertPathsToNames()

static convertPathsToNames ( $tags )
static

Function that converts tags paths into paths of names

Paramètres
array $tags Array of tags
Renvoie
array
Depuis
3.1

Références $db, $query, Factory\getDbo(), et ParameterType\STRING.

Référencé par TagField\getOptions().

◆ createTagsFromField()

createTagsFromField ( $tags )

Create any new tags by looking for #new# in the strings

Paramètres
array $tags Tags text array from the field
Renvoie
mixed If successful, metadata with new tag titles replaced by tag ids. Otherwise false.
Depuis
3.1

Références $canCreate, $key, $result, Factory\getApplication(), et Factory\getUser().

◆ getItemTags()

getItemTags | ( | $contentType,
 |  | $id,
 |  | $getTagData = true
 | ) |

Method to get a list of tags for an item, optionally with the tag data.

Paramètres
string | $contentType | Content type alias. Dot separated.
integer | $id | Id of the item to retrieve tags for.
boolean | $getTagData | If true, data from the tags table will be included, defaults to true.
Renvoie
array Array of of tag objects
Depuis
3.1

Références $db, $groups, $id, $language, $query, $user, Factory\getDbo(), ComponentHelper\getParams(), Factory\getUser(), ParameterType\INTEGER, et ParameterType\STRING.

◆ getTagIds()

getTagIds | ( | $ids,
 |  | $prefix
 | ) |

Method to get a list of tags for a given item. Normally used for displaying a list of tags within a layout

Paramètres
mixed | $ids | The id or array of ids (primary key) of the item to be tagged.
string | $prefix | Dot separated string with the option and view to be used for a url.
Renvoie
string Comma separated list of tag Ids.
Depuis
3.1

Ids possible formats:

$id = 1; $id = array(1,2); $id = array('1,3,4,19'); $id = '1,3';

Références $db, $prefix, $query, Factory\getDbo(), et ArrayHelper\toInteger().

◆ getTagItemsQuery()

getTagItemsQuery | ( |  | $tagId,
 |  |  | $typesr = null,
 |  |  | $includeChildren = false,
 |  |  | $orderByOption = 'c.core_title',
 |  |  | $orderDir = 'ASC',
 |  |  | $anyOrAll = true,
 |  |  | $languageFilter = 'all',
 |  |  | $stateFilter = '0,
 |  | 1' |
 | ) |  |

Method to get a query to retrieve a detailed list of items for a tag.

Paramètres
mixed | $tagId | Tag or array of tags to be matched
mixed | $typesr | Null, type or array of type aliases for content types to be included in the results
boolean | $includeChildren | True to include the results from child tags
string | $orderByOption | Column to order the results by
string | $orderDir | Direction to sort the results in
boolean | $anyOrAll | True to include items matching at least one tag, false to include items all tags in the array.
string | $languageFilter | Optional filter on language. Options are 'all', 'current' or any string.
string | $stateFilter | Optional filtering on publication state, defaults to published or unpublished.
Renvoie
Query to retrieve a list of tags
Depuis
3.1

Références $db, $groups, $nowDate, $query, $user, Factory\getDate(), Factory\getDbo(), Factory\getUser(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

◆ getTagNames()

getTagNames ( $tagIds )

Function that converts tag ids to their tag names

Paramètres
array $tagIds Array of integer tag ids.
Renvoie
array An array of tag names.
Depuis
3.1

Références $db, $query, Factory\getDbo(), et ArrayHelper\toInteger().

◆ getTagTreeArray()

getTagTreeArray | ( |  | $id,
 |  | & | $tagTreeArray = array()
 | ) |  |

Method to get an array of tag ids for the current tag and its children

Paramètres
integer | $id | An optional ID
array | &$tagTreeArray | Array containing the tag tree
Renvoie
mixed
Depuis
3.1

Références $id, et Factory\getApplication().

◆ getTypes()

static getTypes | ( | $arrayType = 'objectList',
 |  | $selectTypes = null,
 |  | $useAlias = true
 | ) |
static

Method to get a list of types with associated data.

Paramètres
string | $arrayType | Optionally specify that the returned list consist of objects, associative arrays, or arrays. Options are: rowList, assocList, and objectList
array | $selectTypes | Optional array of type ids or aliases to limit the results to. Often from a request.
boolean | $useAlias | If true, the alias is used to match, if false the type_id is used.
Renvoie
array Array of of types
Depuis
3.1

Références $db, $query, Factory\getDbo(), ParameterType\STRING, et ArrayHelper\toInteger().

Référencé par HtmlView\display().

◆ postStoreProcess()

postStoreProcess | ( | TableInterface | $table,
 |  |  | $newTags = array(),
 |  |  | $replace = true
 | ) |  |

Function that handles saving tags used in a table class after a store()

Paramètres
TableInterface | $table | Table being processed
array | $newTags | Array of new tags
boolean | $replace | Flag indicating if all existing tags should be replaced
Renvoie
boolean
Depuis
3.1

Références $data, $key, $result, Table\getInstance(), et TableInterface\reset().

◆ preStoreProcess()

preStoreProcess | ( | TableInterface | $table,
 |  |  | $newTags = array()
 | ) |  |

Function that preProcesses data from a table prior to a store() to ensure proper tag handling

Paramètres
TableInterface | $table | Table being processed
array | $newTags | Array of new tags
Renvoie
null
Depuis
3.1

Références $key, et TableInterface\reset().

◆ searchTags()

static searchTags ( $filters = array() )
static

Function to search tags

Paramètres
array $filters Filter to apply to the search
Renvoie
array
Depuis
3.1

Références $db, $filters, $groups, $published, $query, $results, Factory\getApplication(), Factory\getDbo(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

Référencé par TagsController\searchAjax().

◆ tagDeleteInstances()

tagDeleteInstances ( $tagId )

Method to delete all instances of a tag from the mapping table. Generally used when a tag is deleted.

Paramètres
integer $tagId The tag_id (primary key) for the deleted tag.
Renvoie
void
Depuis
3.1

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ tagItem()

tagItem | ( |  | $ucmId,
 |  | TableInterface | $table,
 |  |  | $tags = array(),
 |  |  | $replace = true
 | ) |  |

Method to add or update tags associated with an item.

Paramètres
integer | $ucmId | Id of the #__ucm_content item being tagged
TableInterface | $table | Table object being tagged
array | $tags | Array of tags to be applied.
boolean | $replace | Flag indicating if all existing tags should be replaced
Renvoie
boolean true on success, otherwise false.
Depuis
3.1

Références $key, $result, et $this.

◆ unTagItem()

unTagItem | ( |  | $contentId,
 |  | TableInterface | $table,
 |  |  | $tags = array()
 | ) |  |

Method to untag an item

Paramètres
integer | $contentId | ID of the content item being untagged
TableInterface | $table | Table object being untagged
array | $tags | Array of tags to be untagged. Use an empty array to untag all existing tags.
Renvoie
boolean true on success, otherwise false.
Depuis
3.1

Références $db, $id, $key, $query, Factory\getDbo(), TableInterface\getKeyName(), ParameterType\INTEGER, et ArrayHelper\toInteger().

Documentation des champs

◆ $itemTags

$itemTags

◆ $replaceTags

$replaceTags = false
protected

◆ $tagsChanged

$tagsChanged = false
protected

◆ $typeAlias

$typeAlias
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagsHelper.php


Joomla CMS: Référence de la classe UserGroupsHelper

  • Joomla
  • CMS
  • Helper
  • UserGroupsHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe UserGroupsHelper

Fonctions membres publiques

__construct (array $groups=array(), $mode=self::MODE_INSTANCE)
count ()
get ($id)
getAll ()
has ($id)
total ()
load ($id)
loadAll ()
populateGroupData ($group)
setGroups (array $groups)

Fonctions membres publiques statiques

static getInstance ()

Champs de données

const | MODE_SINGLETON = 1
const | MODE_INSTANCE = 2

Fonctions membres privées

isSingleton ()
populateGroupsData ()

Attributs privés

$groups = array()
$mode
$total

Attributs privés statiques

static $instance

Description détaillée

Helper to deal with user groups.

Depuis
3.6.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $groups = array(),
 |  |  | $mode = self::MODE_INSTANCE
 | ) |  |

Constructor

Paramètres
array | $groups | Array of groups
integer | $mode | Working mode for this class
Depuis
3.6.3

Références $groups, et $mode.

Documentation des fonctions membres

◆ count()

count ( )

Count loaded user groups.

Renvoie
integer
Depuis
3.6.3

◆ get()

get ( $id )

Get a user group by its id.

Paramètres
integer $id Group identifier
Renvoie
mixed stdClass on success. False otherwise
Depuis
3.6.3

Références $id, et Symfony\Contracts\Service\has().

◆ getAll()

getAll ( )

Get the list of existing user groups.

Renvoie
array
Depuis
3.6.3

Références $groups.

◆ getInstance()

static getInstance ( )
static

Get the helper instance.

Renvoie
self
Depuis
3.6.3

Références $groups, et null.

Référencé par Access\getGroupPath(), UsersHelper\getGroups(), GroupparentField\getOptions(), UsergrouplistField\getOptions(), RulesField\getUserGroups(), User\groups(), Access\usergroup(), Access\usergroups(), et LevelModel\validate().

◆ has()

has ( $id )

Check if a group is in the list.

Paramètres
integer $id Group identifier
Renvoie
boolean
Depuis
3.6.3

Références $id.

◆ isSingleton()

isSingleton ( )
private

Check if this instance is a singleton.

Renvoie
boolean
Depuis
3.6.3

◆ load()

load ( $id )

Load a group from database.

Paramètres
integer $id Group identifier
Renvoie
mixed
Depuis
3.6.3

Références $db, $id, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ loadAll()

loadAll ( )

Load all user groups from the database.

Renvoie
self
Depuis
3.6.3

Références $db, $groups, $query, $this, et Factory\getDbo().

◆ populateGroupData()

populateGroupData ( $group )

Populate data for a specific user group.

Paramètres
\stdClass $group Group
Renvoie
Depuis
3.6.3

Références Symfony\Contracts\Service\has(), et if.

◆ populateGroupsData()

populateGroupsData ( )
private

Populates extra information for groups.

Renvoie
array
Depuis
3.6.3

Références $groups.

◆ setGroups()

setGroups ( array $groups )

Set the groups to be used as source.

Paramètres
array $groups Array of user groups.
Renvoie
self
Depuis
3.6.3

Références $groups, et $this.

◆ total()

total ( )

Get total available user groups in database.

Renvoie
integer
Depuis
3.6.3

Références $db, $query, $total, Factory\getDbo(), et null.

Documentation des champs

◆ $groups

$groups = array()
private

◆ $instance

$instance
staticprivate

◆ $mode

$mode
private

◆ $total

$total
private

◆ MODE_INSTANCE

const MODE_INSTANCE = 2

◆ MODE_SINGLETON

const MODE_SINGLETON = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserGroupsHelper.php


Joomla CMS: Référence de la classe Access

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Access
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Access

Fonctions membres publiques statiques

static | level ($name, $selected, $attribs='', $params=true, $id=false)
static | usergroup ($name, $selected, $attribs='', $allowAll=true, $id=false)
static | usergroups ($name, $selected, $checkSuperAdmin=false)
static | actions ($name, $selected, $component, $section='global')
static | assetgroups ()
static | assetgrouplist ($name, $selected, $attribs=null, $config=array())

Attributs protégés statiques

static $asset_groups = null

Description détaillée

Extended Utility class for all HTML drawing classes.

Depuis
1.6

Documentation des fonctions membres

◆ actions()

static actions | ( | $name,
 |  | $selected,
 |  | $component,
 |  | $section = 'global'
 | ) |
static

Returns a UL list of actions with checkboxes

Paramètres
string | $name | The name of the checkbox controls array
array | $selected | An array of the checked boxes
string | $component | The component the permissions apply to
string | $section | The section (within a component) the permissions apply to
Renvoie
string
Voir également
AccessCheck
Depuis
1.6

Références $actions, $checked, $component, $count, $html, $i, $item, $n, $name, $section, $selected, Text\_(), et JPATH_ADMINISTRATOR.

◆ assetgrouplist()

static assetgrouplist | ( | $name,
 |  | $selected,
 |  | $attribs = null,
 |  | $config = array()
 | ) |
static

Displays a Select list of the available asset groups

Paramètres
string | $name | The name of the select element
mixed | $selected | The selected asset group id
string | $attribs | Optional attributes for the select field
array | $config | An array of options for the control
Renvoie
mixed An HTML string or null if an error occurs
Depuis
1.6

Références $attribs, $config, $count, $name, $options, $selected, HTMLHelper\_(), et null.

◆ assetgroups()

static assetgroups ( )
static

Gets a list of the asset groups as an array of JHtml compatible options.

Renvoie
mixed An array or false if an error occurs
Depuis
1.6

Références $db, $query, et Factory\getDbo().

◆ level()

static level | ( | $name,
 |  | $selected,
 |  | $attribs = '',
 |  | $params = true,
 |  | $id = false
 | ) |
static

Displays a list of the available access view levels

Paramètres
string | $name | The form field name.
string | $selected | The name of the selected section.
string | $attribs | Additional attributes to add to the select field.
mixed | $params | True to add "All Sections" option or an array of options
mixed | $id | The form field id or false if not used
Renvoie
string The required HTML for the SELECT tag.
Voir également
Depuis
1.6

Références $attribs, $db, $id, $name, $options, $params, $query, $selected, Text\_(), HTMLHelper\_(), elseif, et Factory\getDbo().

◆ usergroup()

static usergroup | ( | $name,
 |  | $selected,
 |  | $attribs = '',
 |  | $allowAll = true,
 |  | $id = false
 | ) |
static

Displays a list of the available user groups.

Paramètres
string | $name | The form field name.
string | $selected | The name of the selected section.
string | $attribs | Additional attributes to add to the select field.
boolean | $allowAll | True to add "All Groups" option.
mixed | $id | The form field id
Renvoie
string The required HTML for the SELECT tag.
Voir également
Depuis
1.6

Références $attribs, $i, $id, $n, $name, $options, $selected, Text\_(), HTMLHelper\_(), UserGroupsHelper\getInstance(), et level.

◆ usergroups()

static usergroups | ( | $name,
 |  | $selected,
 |  | $checkSuperAdmin = false
 | ) |
static

Returns a UL list of user groups with checkboxes

Paramètres
string | $name | The name of the checkbox controls array
array | $selected | An array of the checked boxes
boolean | $checkSuperAdmin | If false only super admins can add to super admin groups
Renvoie
string
Depuis
1.6

Références $checked, $count, $groups, $html, $i, $item, $n, $name, $rel, $selected, UserGroupsHelper\getInstance(), Factory\getUser(), et LayoutHelper\render().

Documentation des champs

◆ $asset_groups

$asset_groups = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HTML/Helpers/Access.php


Joomla CMS: Référence de la classe ActionsDropdown

  • Joomla
  • CMS
  • HTML
  • Helpers
  • ActionsDropdown
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe ActionsDropdown

Fonctions membres publiques statiques

static | render ($item='')
static | publish ($id, $prefix='')
static | unpublish ($id, $prefix='')
static | feature ($id, $prefix='')
static | unfeature ($id, $prefix='')
static | archive ($id, $prefix='')
static | unarchive ($id, $prefix='')
static | duplicate ($id, $prefix='')
static | trash ($id, $prefix='')
static | untrash ($id, $prefix='')
static | divider ()
static | addCustomItem ($label, $icon='', $id='', $task='')

Attributs protégés statiques

static $dropDownList = array()

Description détaillée

HTML utility class for building a dropdown menu

Depuis
3.2

Documentation des fonctions membres

◆ addCustomItem()

static addCustomItem | ( | $label,
 |  | $icon = '',
 |  | $id = '',
 |  | $task = ''
 | ) |
static

Append a custom item to current dropdown menu.

Paramètres
string | $label | The label of the item.
string | $icon | The icon classname.
string | $id | The item id.
string | $task | The task.
Renvoie
void
Depuis
3.2

Références $icon, $id, $label, $task, HTMLHelper\link(), et LayoutHelper\render().

◆ archive()

static archive | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append an archive item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ divider()

static divider ( )
static

Writes a divider between dropdown items

Renvoie
void
Depuis
3.0

◆ duplicate()

static duplicate | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append a duplicate item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ feature()

static feature | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append a feature item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ publish()

static publish | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append a publish item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ render()

static render ( $item = '' )
static

Method to render current dropdown menu

Paramètres
string $item An item to render.
Renvoie
string HTML markup for the dropdown list
Depuis
3.2

Références $html, $item, null, et Text\sprintf().

◆ trash()

static trash | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append a trash item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ unarchive()

static unarchive | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append an unarchive item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ unfeature()

static unfeature | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append an unfeature item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ unpublish()

static unpublish | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append an unpublish item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, $prefix, $task, et Text\_().

◆ untrash()

static untrash | ( | $id,
 |  | $prefix = ''
 | ) |
static

Append an untrash item to the current dropdown menu

Paramètres
string | $id | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.2

Références $id, et $prefix.

Documentation des champs

◆ $dropDownList

$dropDownList = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionsDropdown.php


Joomla CMS: Référence de la classe AdminLanguage

  • Joomla
  • CMS
  • HTML
  • Helpers
  • AdminLanguage
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe AdminLanguage

Fonctions membres publiques statiques

static existing ($all=false, $translate=false)

Attributs protégés statiques

static $items = null

Description détaillée

Utility class working with administrator language select lists

Depuis
3.8.0

Documentation des fonctions membres

◆ existing()

static existing | ( | $all = false,
 |  | $translate = false
 | ) |
static

Get a list of the available administrator language items.

Paramètres
boolean | $all | True to include All (*)
boolean | $translate | True to translate All
Renvoie
array
Depuis
3.8.0

Références $items, $language, $languages, Text\alt(), LanguageHelper\getKnownLanguages(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $items

$items = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdminLanguage.php


Joomla CMS: Référence de la classe Behavior

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Behavior
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe Behavior

Fonctions membres publiques statiques

static | core ()
static | formvalidator ()
static | combobox ()
static | multiselect ($id='adminForm')
static | keepalive ()
static | highlighter (array $terms, $start='highlighter-start', $end='highlighter-end', $className='highlight', $tag='span')

Fonctions membres protégées statiques

static calendartranslation ()

Attributs protégés statiques

static $loaded = array()

Description détaillée

Utility class for JavaScript behaviors

Depuis
1.5

Documentation des fonctions membres

◆ calendartranslation()

static calendartranslation ( )
staticprotected

Internal method to translate the JavaScript Calendar

Renvoie
string JavaScript that translates the object
Depuis
1.5

Références $text, Text\_(), et Factory\getLanguage().

◆ combobox()

static combobox ( )
static

Add unobtrusive JavaScript support for a combobox effect.

Note that this control is only reliable in absolutely positioned elements. Avoid using a combobox in a slider or dynamic pane.

Renvoie
void
Depuis
1.5
Obsolète:
5.0 Use the script directly

Références Factory\getDocument().

◆ core()

static core ( )
static

Method to load core.js into the document head.

Core.js defines the 'Joomla' namespace and contains functions which are used across extensions

Renvoie
void
Depuis
3.3
Obsolète:
5.0 Use Joomla::enable();

Références Factory\getApplication().

◆ formvalidator()

static formvalidator ( )
static

Add unobtrusive JavaScript support for form validation.

To enable form validation the form tag must have class="form-validate". Each field that needs to be validated needs to have class="validate". Additional handlers can be added to the handler for username, password, numeric and email. To use these add class="validate-email" and so on.

Renvoie
void
Depuis
3.4
Obsolète:
5.0 Use the script directly

Références Factory\getDocument().

◆ highlighter()

static highlighter | ( | array | $terms,
 |  |  | $start = 'highlighter-start',
 |  |  | $end = 'highlighter-end',
 |  |  | $className = 'highlight',
 |  |  | $tag = 'span'
 | ) |  |
static

Highlight some words via Javascript.

Paramètres
array | $terms | Array of words that should be highlighted.
string | $start | ID of the element that marks the begin of the section in which words should be highlighted. Note this element will be removed from the DOM.
string | $end | ID of the element that end this section. Note this element will be removed from the DOM.
string | $className | Class name of the element highlights are wrapped in.
string | $tag | Tag that will be used to wrap the highlighted words.
Renvoie
void
Depuis
2.5
Obsolète:
5.0 Use the script directly

Références $doc, $start, et Factory\getDocument().

◆ keepalive()

static keepalive ( )
static

Keep session alive, for example, while editing or creating an article.

Renvoie
void
Depuis
1.5
Obsolète:
5.0 Use Joomla::enable();

Références Factory\getApplication().

◆ multiselect()

static multiselect ( $id = 'adminForm' )
static

JavaScript behavior to allow shift select in grids

Paramètres
string $id The id of the form for which a multiselect behaviour is to be applied.
Renvoie
void
Depuis
1.7
Obsolète:
5.0 Use the script directly

Références $id, et Factory\getDocument().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/HTML/Helpers/Behavior.php


Joomla CMS: Référence de la classe Bootstrap

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Bootstrap
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Bootstrap

Fonctions membres publiques statiques

static | alert ($selector='')
static | button ($selector='')
static | carousel ($selector='', $params=[])
static | collapse ($selector='', $params=[])
static | dropdown ($selector='', $params=[])
static | modal ($selector='', $options=[])
static | offcanvas ($selector='', $options=[])
static | popover ($selector='', $options=[])
static | scrollspy ($selector='', $options=[])
static | tab ($selector='', $options=[])
static | tooltip ($selector='', $options=[])
static | toast ($selector='', $options=[])
static | framework ($debug=null)
static | loadCss ($includeMainCss=true, $direction='ltr', $attribs=[])
static | startAccordion ($selector='myAccordian', $options=[])
static | endAccordion ()
static | addSlide ($selector, $text, $id, $class='')
static | endSlide ()
static | renderModal ($selector='modal', $options=[], $body='')
static | startTabSet ($selector='myTab', $params=[])
static | endTabSet ()
static | addTab ($selector, $id, $title)
static | endTab ()

Attributs protégés statiques

static $loaded = []

Description détaillée

Utility class for Bootstrap elements.

Depuis
3.0

Documentation des fonctions membres

◆ addSlide()

static addSlide | ( | $selector,
 |  | $text,
 |  | $id,
 |  | $class = ''
 | ) |
static

Begins the display of a new accordion slide.

Paramètres
string | $selector | Identifier of the accordion group.
string | $text | Text to display.
string | $id | Identifier of the slide.
string | $class | Class of the accordion group.
Renvoie
string HTML to add the slide
Depuis
3.0

Références $class, $id, $selector, $text, et true.

◆ addTab()

static addTab | ( | $selector,
 |  | $id,
 |  | $title
 | ) |
static

Begins the display of a new tab content panel.

Paramètres
string | $selector | Identifier of the panel. Expects a valid ID without the #!
string | $id | The ID of the div element. Expects a valid ID without the #!
string | $title | The title text for the new UL tab
Renvoie
string HTML to start a new panel
Depuis
3.1

Références $active, $id, $selector, $title, et null.

◆ alert()

static alert ( $selector = '' )
static

Add javascript support for Bootstrap alerts

Paramètres
string $selector Common class for the alerts
Renvoie
void
Exceptions

Références $doc, $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ button()

static button ( $selector = '' )
static

Add javascript support for Bootstrap buttons

Paramètres
string $selector Common class for the buttons
Renvoie
void
Exceptions

Références $doc, $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ carousel()

static carousel | ( | $selector = '',
 |  | $params = []
 | ) |
static

Add javascript support for Bootstrap carousels

Paramètres
string | $selector | Common class for the carousels.
array | $params | An array of options for the carousel.
Renvoie
void
Exceptions

Références $params, $selector, Factory\getApplication(), et Factory\getDocument().

◆ collapse()

static collapse | ( | $selector = '',
 |  | $params = []
 | ) |
static

Add javascript support for Bootstrap collapse

Paramètres
string | $selector | Common class for the collapse
string[] | $params Additional parameters - see below
Renvoie
void
Exceptions

Références $params, $selector, Factory\getApplication(), et Factory\getDocument().

◆ dropdown()

static dropdown | ( | $selector = '',
 |  | $params = []
 | ) |
static

Add javascript support for Bootstrap dropdowns

Paramètres
string | $selector | Common class for the dropdowns
array | $params | The options for the dropdowns
Renvoie
void
Depuis
4.0.0

Options for the collapse can be:

  • flip boolean true Allow Dropdown to flip in case of an overlapping on the reference element
  • boundary string scrollParent Overflow constraint boundary of the dropdown menu
  • reference string toggle Reference element of the dropdown menu. Accepts 'toggle' or 'parent'
  • display string dynamic By default, we use Popper for dynamic positioning. Disable this with static

Références $params, $selector, Factory\getApplication(), et Factory\getDocument().

◆ endAccordion()

static endAccordion ( )
static

Close the current accordion

Renvoie
string HTML to close the accordion
Depuis
3.0

◆ endSlide()

static endSlide ( )
static

Close the current slide

Renvoie
string HTML to close the slide
Depuis
3.0

◆ endTab()

static endTab ( )
static

Close the current tab content panel

Renvoie
string HTML to close the pane
Depuis
3.1

Références LayoutHelper\render().

◆ endTabSet()

static endTabSet ( )
static

Close the current tab pane

Renvoie
string HTML to close the pane
Depuis
3.1

Références LayoutHelper\render().

◆ framework()

static framework ( $debug = null )
static

Method to load the ALL the Bootstrap Components

If debugging mode is on an uncompressed version of Bootstrap is included for easier debugging.

Paramètres
mixed $debug Is debugging mode on? [optional]
Renvoie
void
Depuis
3.0
Obsolète:
5.0

Références $script, $wa, et Factory\getApplication().

◆ loadCss()

static loadCss | ( | $includeMainCss = true,
 |  | $direction = 'ltr',
 |  | $attribs = []
 | ) |
static

Loads CSS files needed by Bootstrap

Paramètres
boolean | $includeMainCss | If true, main bootstrap.css files are loaded
string | $direction | rtl or ltr direction. If empty, ltr is assumed
array | $attribs | Optional array of attributes to be passed to HTMLHelper::_('stylesheet')
Renvoie
void
Depuis
3.0

Références Factory\getDocument().

◆ modal()

static modal | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap modal

Paramètres
string | $selector | The ID selector for the modal.
array | $options | An array of options for the modal.
Renvoie
void
Depuis
4.0.0

Options for the modal can be:

  • backdrop string| true Includes a modal-backdrop element. Alternatively, specify static boolean for a backdrop which doesn't close the modal on click.
  • keyboard boolean true Closes the modal when escape key is pressed
  • focus boolean true Closes the modal when escape key is pressed

Références $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ offcanvas()

static offcanvas | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap offcanvas

Paramètres
string | $selector | The ID selector for the offcanvas.
array | $options | An array of options for the offcanvas.
Renvoie
void
Depuis
4.0.0

Options for the offcanvas can be:

  • backdrop boolean true Apply a backdrop on body while offcanvas is open
  • keyboard boolean true Closes the offcanvas when escape key is pressed
  • scroll boolean false Allow body scrolling while offcanvas is open

Références $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ popover()

static popover | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap popovers

Use element's Title as popover content

Paramètres
string | $selector | Selector for the popover
array | $options | The options for the popover
Renvoie
void
Depuis
3.0
  • Options for the popover can be:
  • animation boolean true Apply a CSS fade transition to the popover
  • container string| false Appends the popover to a specific element. Eg.: 'body' boolean
  • content string null Default content value if data-bs-content attribute isn't present
  • delay number 0 Delay showing and hiding the popover (ms) does not apply to manual trigger type
  • html boolean true Insert HTML into the popover. If false, innerText property will be used to insert content into the DOM.
  • placement string right How to position the popover - auto | top | bottom | left | right. When auto is specified, it will dynamically reorient the popover
  • selector string false If a selector is provided, popover objects will be delegated to the specified targets.
  • template string null Base HTML to use when creating the popover.
  • title string null Default title value if title tag isn't present
  • trigger string click How popover is triggered - click | hover | focus | manual
  • offset integer 0 Offset of the popover relative to its target.

Références $options, $selector, Factory\getApplication(), Factory\getDocument(), et null.

◆ renderModal()

static renderModal | ( | $selector = 'modal',
 |  | $options = [],
 |  | $body = ''
 | ) |
static

Method to render a Bootstrap modal

Paramètres
string | $selector | The ID selector for the modal. Expects a valid ID without the #!
array | $options | An array of options for the modal.
string | $body | Markup for the modal body. Appended after the <iframe> if the URL option is set
Renvoie
string HTML markup for a modal
Depuis
3.0

Options for the modal can be:

  • backdrop string| true Includes a modal-backdrop element. Alternatively, specify static boolean for a backdrop which doesn't close the modal on click.
  • keyboard boolean true Closes the modal when escape key is pressed
  • focus boolean true Closes the modal when escape key is pressed
  • title string null The modal title
  • closeButton boolean true Display modal close button (default = true)
  • footer string null Optional markup for the modal footer
  • url string null URL of a resource to be inserted as an <iframe> inside the modal body
  • height string null Height of the <iframe> containing the remote resource
  • width string null Width of the <iframe> containing the remote resource

Références $options, $selector, HTMLHelper\_(), et LayoutHelper\render().

◆ scrollspy()

static scrollspy | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap Scrollspy

Paramètres
string | $selector | The ID selector for the ScrollSpy element.
array | $options | An array of options for the ScrollSpy.
Renvoie
void
Depuis
3.0

Options for the Scrollspy can be:

  • offset number Pixels to offset from top when calculating position of scroll.
  • method string Finds which section the spied element is in.
  • target string Specifies element to apply Scrollspy plugin.

Références $options, $selector, Factory\getApplication(), Factory\getDocument(), et null.

◆ startAccordion()

static startAccordion | ( | $selector = 'myAccordian',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap accordions and insert the accordion

Paramètres
string | $selector | The ID selector for the tooltip. Expects a valid ID without the #!
array | $options | An array of options for the tooltip.
Renvoie
string HTML for the accordion
Depuis
3.0

Options for the tooltip can be:

  • parent selector If selector then all collapsible elements under the specified parent will be closed when this collapsible item is shown. (similar to traditional accordion behavior)
  • toggle boolean Toggles the collapsible element on invocation
  • active string Sets the active slide during load

Références $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ startTabSet()

static startTabSet | ( | $selector = 'myTab',
 |  | $params = []
 | ) |
static

Creates a tab pane

Paramètres
string | $selector | The pane identifier. Expects a valid ID without the #!
array | $params | The parameters for the pane
Renvoie
string
Depuis
3.1

Références $params, $selector, HTMLHelper\_(), et LayoutHelper\render().

◆ tab()

static tab | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap tab

Paramètres
string | $selector | Common class for the tabs
array | $options | Options for the tabs
Renvoie
void
Exceptions

Références $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ toast()

static toast | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap toasts

Paramètres
string | $selector | Common class for the toasts
array | $options | Options for the toasts
Renvoie
void
Exceptions

Références $options, $selector, Factory\getApplication(), Factory\getDocument(), et null.

◆ tooltip()

static tooltip | ( | $selector = '',
 |  | $options = []
 | ) |
static

Add javascript support for Bootstrap tooltips

Add a title attribute to any element in the form title="title::text"

Paramètres
string | $selector | The ID selector for the tooltip.
array | $options | An array of options for the tooltip.
Renvoie
void
Depuis
3.0
                        Options for the tooltip can be:
  • animation boolean apply a css fade transition to the popover
  • container string|boolean Appends the popover to a specific element: { container: 'body' }
  • delay number|object delay showing and hiding the popover (ms) - does not apply to manual trigger type If a number is supplied, delay is applied to both hide/show Object structure is: delay: { show: 500, hide: 100 }
  • html boolean Insert HTML into the popover. If false, jQuery's text method will be used to insert content into the dom.
  • placement string|function how to position the popover - top | bottom | left | right
  • selector string If a selector is provided, popover objects will be delegated to the specified targets.
  • template string Base HTML to use when creating the popover.
  • title string|function default title value if title tag isn't present
  • trigger string how popover is triggered - hover | focus | manual
  • constraints array An array of constraints - passed through to Popper.
  • offset string Offset of the popover relative to its target.

Références $options, $selector, Factory\getApplication(), Factory\getDocument(), et null.

Documentation des champs

◆ $loaded

$loaded = []
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Bootstrap.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Category
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Category

Fonctions membres publiques statiques

static | options ($extension, $config=array('filter.published'=> array(0, 1)))
static | categories ($extension, $config=array('filter.published'=> array(0, 1)))

Attributs protégés statiques

static $items = array()

Description détaillée

Utility class for categories

Depuis
1.5

Documentation des fonctions membres

◆ categories()

static categories | ( | $extension,
 |  | $config = array('filter.published' => array(0, 1))
 | ) |
static

Returns an array of categories for the given extension.

Paramètres
string | $extension | The extension option.
array | $config | An array of configuration options. By default, only published and unpublished categories are returned.
Renvoie
array Categories for the extension
Depuis
1.6

Références $config, $db, $extension, $groups, $hash, $item, $items, $query, $user, Text\_(), HTMLHelper\_(), elseif, Factory\getDbo(), Factory\getUser(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ options()

static options | ( | $extension,
 |  | $config = array('filter.published' => array(0, 1))
 | ) |
static

Returns an array of categories for the given extension.

Paramètres
string | $extension | The extension option e.g. com_something.
array | $config | An array of configuration options. By default, only published and unpublished categories are returned.
Renvoie
array
Depuis
1.5

Références $config, $db, $extension, $groups, $hash, $item, $items, $query, $user, HTMLHelper\_(), elseif, Factory\getDbo(), Factory\getUser(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

Documentation des champs

◆ $items

$items = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/HTML/Helpers/Category.php


Joomla CMS: Référence de la classe Content

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Content
Fonctions membres publiques statiques
Référence de la classe Content

Fonctions membres publiques statiques

static prepare ($text, $params=null, $context='text')

Description détaillée

Utility class to fire onContentPrepare for non-article based content.

Depuis
1.5

Documentation des fonctions membres

◆ prepare()

static prepare | ( | $text,
 |  | $params = null,
 |  | $context = 'text'
 | ) |
static

Fire onContentPrepare for content that isn't part of an article.

Paramètres
string | $text | The content to be transformed.
array | $params | The content params.
string | $context | The context of the content to be transformed.
Renvoie
string The content after transformation.
Depuis
1.5

Références $article, $context, $params, $text, Factory\getApplication(), PluginHelper\importPlugin(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HTML/Helpers/Content.php


Joomla CMS: Référence de la classe ContentLanguage

  • Joomla
  • CMS
  • HTML
  • Helpers
  • ContentLanguage
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe ContentLanguage

Fonctions membres publiques statiques

static existing ($all=false, $translate=false)

Attributs protégés statiques

static $items = null

Description détaillée

Utility class working with content language select lists

Depuis
1.6

Documentation des fonctions membres

◆ existing()

static existing | ( | $all = false,
 |  | $translate = false
 | ) |
static

Get a list of the available content language items.

Paramètres
boolean | $all | True to include All (*)
boolean | $translate | True to translate All
Renvoie
array
Voir également
Depuis
1.6

Références $db, $items, $query, Text\alt(), et Factory\getDbo().

Documentation des champs

◆ $items

$items = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentLanguage.php


Joomla CMS: Référence de la classe Date

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Date
Fonctions membres publiques statiques
Référence de la classe Date

Fonctions membres publiques statiques

static relative ($date, $unit=null, $time=null, $format=null)

Description détaillée

Extended Utility class for handling date display.

Depuis
2.5

Documentation des fonctions membres

◆ relative()

static relative | ( | $date,
 |  | $unit = null,
 |  | $time = null,
 |  | $format = null
 | ) |
static

Function to convert a static time into a relative measurement

Paramètres
string | $date | The date to convert
string | $unit | The optional unit of measurement to return if the value of the diff is greater than one
string | $time | An optional time to compare to, defaults to now
string | $format | An optional format for the HTMLHelper::date output
Renvoie
string The converted time string
Depuis
2.5

Références $date, $format, Text\_(), HTMLHelper\_(), null, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HTML/Helpers/Date.php


Joomla CMS: Référence de la classe Debug

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Debug
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe Debug

Fonctions membres publiques statiques

static xdebuglink ($file, $line='')

Attributs publics statiques

static $xdebugLinkFormat

Description détaillée

Extended Utility class for render debug information.

Depuis
3.7.0

Documentation des fonctions membres

◆ xdebuglink()

static xdebuglink | ( | $file,
 |  | $line = ''
 | ) |
static

Replaces the Joomla! root with "JROOT" to improve readability. Formats a link with a special value xdebug.file_link_format from the php.ini file.

Paramètres
string | $file | The full path to the file.
string | $line | The line number.
Renvoie
string
Exceptions

Références $href, $html, $link, HTMLHelper\_(), Path\clean(), JPATH_ROOT, et null.

Documentation des champs

◆ $xdebugLinkFormat

$xdebugLinkFormat
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/HTML/Helpers/Debug.php


Joomla CMS: Référence de la classe DraggableList

  • Joomla
  • CMS
  • HTML
  • Helpers
  • DraggableList
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe DraggableList

Fonctions membres publiques statiques

static draggable (string $tableId='', string $formId='', string $sortDir='asc', string $saveOrderingUrl='', $redundant=null, bool $nestedList=false)

Attributs protégés statiques

static $loaded = array()

Description détaillée

HTML utility class for creating a sortable table list

Depuis
4.0.0

Documentation des fonctions membres

◆ draggable()

static draggable | ( | string | $tableId = '',
 |  | string | $formId = '',
 |  | string | $sortDir = 'asc',
 |  | string | $saveOrderingUrl = '',
 |  |  | $redundant = null,
 |  | bool | $nestedList = false
 | ) |  |
static

Method to load the Dragula script and make table sortable

Paramètres
string | $tableId | DOM id of the table
string | $formId | DOM id of the form
string | $sortDir | Sort direction
string | $saveOrderingUrl | Save ordering url, ajax-load after an item dropped
string | $redundant | Not used
boolean | $nestedList | Set whether the list is a nested list
Renvoie
void
Depuis
4.0.0

Références $doc, $formId, $saveOrderingUrl, Factory\getDocument(), et Session\getFormToken().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DraggableList.php


Joomla CMS: Référence de la classe Dropdown

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Dropdown
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Dropdown

Fonctions membres publiques statiques

static | init ()
static | start ()
static | render ()
static | edit ($id, $prefix='', $customLink='')
static | publish ($checkboxId, $prefix='')
static | unpublish ($checkboxId, $prefix='')
static | featured ($checkboxId, $prefix='')
static | unfeatured ($checkboxId, $prefix='')
static | archive ($checkboxId, $prefix='')
static | unarchive ($checkboxId, $prefix='')
static | trash ($checkboxId, $prefix='')
static | untrash ($checkboxId, $prefix='')
static | checkin ($checkboxId, $prefix='')
static | divider ()
static | addCustomItem ( $label, $link='javascript:void(0)', $linkAttributes='', $className='', $ajaxLoad=false, $jsCallBackFunc=null)

Attributs protégés statiques

static | $loaded = array()
static | $dropDownList = null

Description détaillée

HTML utility class for building a dropdown menu

Depuis
3.0

Documentation des fonctions membres

◆ addCustomItem()

static addCustomItem | ( | $label,
 |  | $link = 'javascript:void(0)',
 |  | $linkAttributes = '',
 |  | $className = '',
 |  | $ajaxLoad = false,
 |  | $jsCallBackFunc = null
 | ) |
static

Append a custom item to current dropdown menu

Paramètres
string | $label | The label of item
string | $link | The link of item
string | $linkAttributes | Custom link attributes
string | $className | Class name of item
boolean | $ajaxLoad | True if using ajax load when item clicked
string | $jsCallBackFunc | Javascript function name, called when ajax load successfully
Renvoie
void
Depuis
3.0

◆ archive()

static archive | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append an archive item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ checkin()

static checkin | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append a checkin item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ divider()

static divider ( )
static

Writes a divider between dropdown items

Renvoie
void
Depuis
3.0

◆ edit()

static edit | ( | $id,
 |  | $prefix = '',
 |  | $customLink = ''
 | ) |
static

Append an edit item to the current dropdown menu

Paramètres
integer | $id | Record ID
string | $prefix | Task prefix
string | $customLink | The custom link if dont use default Joomla action format
Renvoie
void
Depuis
3.0

Références $id, $link, $option, $prefix, Text\_(), Route\_(), et Factory\getApplication().

◆ featured()

static featured | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append a featured item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ init()

static init ( )
static

Method to inject needed script

Renvoie
void
Depuis
3.0

Références HTMLHelper\_(), et Factory\getDocument().

◆ publish()

static publish | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append a publish item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

Références $prefix, $task, et Text\_().

◆ render()

static render ( )
static

Method to render current dropdown menu

Renvoie
string HTML markup for the dropdown list
Depuis
3.0

Références null.

◆ start()

static start ( )
static

Method to start a new dropdown menu

Renvoie
void
Depuis
3.0

◆ trash()

static trash | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append a trash item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ unarchive()

static unarchive | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append an unarchive item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ unfeatured()

static unfeatured | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append an unfeatured item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ unpublish()

static unpublish | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append an unpublish item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

◆ untrash()

static untrash | ( | $checkboxId,
 |  | $prefix = ''
 | ) |
static

Append an untrash item to the current dropdown menu

Paramètres
string | $checkboxId | ID of corresponding checkbox of the record
string | $prefix | The task prefix
Renvoie
void
Depuis
3.0

Documentation des champs

◆ $dropDownList

$dropDownList = null
staticprotected

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Dropdown.php


Joomla CMS: Référence de la classe Email

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Email
Fonctions membres publiques statiques
Référence de la classe Email

Fonctions membres publiques statiques

static cloak ($mail, $mailto=true, $text='', $email=true, $attribsBefore='', $attribsAfter='')

Description détaillée

Utility class for cloaking email addresses

Depuis
1.5

Documentation des fonctions membres

◆ cloak()

static cloak | ( | $mail,
 |  | $mailto = true,
 |  | $text = '',
 |  | $email = true,
 |  | $attribsBefore = '',
 |  | $attribsAfter = ''
 | ) |
static

Simple JavaScript email cloaker

By default replaces an email with a mailto link with email cloaked

Paramètres
string | $mail | The -mail address to cloak.
boolean | $mailto | True if text and mailing address differ
string | $text | Text for the link
boolean | $email | True if text is an email address
string | $attribsBefore | Any attributes before the email address
string | $attribsAfter | Any attributes before the email address
Renvoie
string The cloaked email.
Depuis
1.5

Références $name, $text, Text\_(), elseif, PunycodeHelper\emailToUTF8(), Factory\getDocument(), et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/HTML/Helpers/Email.php


Joomla CMS: Référence de la classe Form

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Form
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Form

Fonctions membres publiques statiques

static token (array $attribs=array())

Attributs protégés statiques

static $loaded = array()

Description détaillée

Utility class for form elements

Depuis
1.5

Documentation des fonctions membres

◆ token()

static token ( array $attribs = array() )
static

Displays a hidden token field to reduce the risk of CSRF exploits

Use in conjunction with Session::checkToken()

Paramètres
array $attribs Input element attributes.
Renvoie
string A hidden input field with a token
Voir également
Session::checkToken()
Depuis
1.5

Références $attribs, $attributes, Session\getFormToken(), et ArrayHelper\toString().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HTML/Helpers/Form.php


Joomla CMS: Référence de la classe FormBehavior

  • Joomla
  • CMS
  • HTML
  • Helpers
  • FormBehavior
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe FormBehavior

Fonctions membres publiques statiques

static ajaxchosen (Registry $options, $debug=null)

Attributs protégés statiques

static $loaded = array()

Description détaillée

Utility class for form related behaviors

Depuis
3.0
Obsolète:
5.0 Without replacement

Documentation des fonctions membres

◆ ajaxchosen()

static ajaxchosen | ( | Registry | $options,
 |  |  | $debug = null
 | ) |  |
static

Method to load the AJAX Chosen library

If debugging mode is on an uncompressed version of AJAX Chosen is included for easier debugging.

Paramètres
Registry | $options | Options in a Registry object
mixed | $debug | Is debugging mode on? [optional]
Renvoie
void
Depuis
3.0

Références $options, $selector, $type, $url, HTMLHelper\_(), Factory\getDocument(), null, et Text\script().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormBehavior.php


Joomla CMS: Référence de la classe Grid

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Grid
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Grid

Fonctions membres publiques statiques

static | sort ($title, $order, $direction='asc', $selected='', $task=null, $newDirection='asc', $tip='', $form=null)
static | checkall ($name='checkall-toggle', $action='Joomla.checkAll(this)')
static | id ($rowNum, $recId, $checkedOut=false, $name='cid', $stub='cb', $title='', $formId=null)
static | checkedOut (&$row, $i, $identifier='id')
static | published ($value, $i, $img1='tick.png', $img0='publish_x.png', $prefix='')
static | state ($filterState=' *', $published='JPUBLISHED', $unpublished='JUNPUBLISHED', $archived=null, $trashed=null)
static | order ($rows, $image='filesave.png', $task='saveorder')

Fonctions membres protégées statiques

static _checkedOut (&$row, $overlib=true)

Description détaillée

Utility class for creating HTML Grids

Depuis
1.5

Documentation des fonctions membres

◆ _checkedOut()

static _checkedOut | ( | & | $row,
 |  |  | $overlib = true
 | ) |  |
staticprotected

Method to create a checked out icon with optional overlib in a grid.

Paramètres
object | $row | The row object
boolean | $overlib | True if an overlib with checkout information should be created.
Renvoie
string HTMl for the icon and overlib
Depuis
1.5

◆ checkall()

static checkall | ( | $name = 'checkall-toggle',
 |  | $action = 'Joomla.checkAll(this)'
 | ) |
static

Method to check all checkboxes in a grid

Paramètres
string | $name | The name of the form element
string | $action | The action to perform on clicking the checkbox
Renvoie
string
Depuis
3.1.2

◆ checkedOut()

static checkedOut | ( | & | $row,
 |  |  | $i,
 |  |  | $identifier = 'id'
 | ) |  |
static

Displays a checked out icon.

Paramètres
object | $row | A data object (must contain checked out as a property).
integer | $i | The index of the row.
string | $identifier | The property name of the primary key or index of the row.
Renvoie
string
Depuis
1.5

◆ id()

static id | ( | $rowNum,
 |  | $recId,
 |  | $checkedOut = false,
 |  | $name = 'cid',
 |  | $stub = 'cb',
 |  | $title = '',
 |  | $formId = null
 | ) |
static

Method to create a checkbox for a grid row.

Paramètres
integer | $rowNum | The row index
integer | $recId | The record id
boolean | $checkedOut | True if item is checked out
string | $name | The name of the form element
string | $stub | The name of stub identifier
string | $title | The name of the item
string | $formId | An optional form selector.
Renvoie
mixed String of html with a checkbox if item is not checked out, null if checked out.
Depuis
1.5

◆ order()

static order | ( | $rows,
 |  | $image = 'filesave.png',
 |  | $task = 'saveorder'
 | ) |
static

Method to create an icon for saving a new ordering in a grid

Paramètres
array | $rows | The array of rows of rows
string | $image | The image [UNUSED]
string | $task | The task to use, defaults to save order
Renvoie
string
Depuis
1.5

◆ published()

static published | ( | $value,
 |  | $i,
 |  | $img1 = 'tick.png',
 |  | $img0 = 'publish_x.png',
 |  | $prefix = ''
 | ) |
static

Method to create a clickable icon to change the state of an item

Paramètres
mixed | $value | Either the scalar value or an object (for backward compatibility, deprecated)
integer | $i | The index
string | $img1 | Image for a positive or on value
string | $img0 | Image for the empty or off value
string | $prefix | An optional prefix for the task
Renvoie
string
Depuis
1.5

◆ sort()

static sort | ( | $title,
 |  | $order,
 |  | $direction = 'asc',
 |  | $selected = '',
 |  | $task = null,
 |  | $newDirection = 'asc',
 |  | $tip = '',
 |  | $form = null
 | ) |
static

Method to sort a column in a grid

Paramètres
string | $title | The link title
string | $order | The order field for the column
string | $direction | The current direction
string | $selected | The selected ordering
string | $task | An optional task override
string | $newDirection | An optional direction for the new column
string | $tip | An optional text shown as tooltip title instead of $title
string | $form | An optional form selector
Renvoie
string
Depuis
1.5

Références $direction, $form, $icon, $selected, HTMLHelper\_(), et content.

◆ state()

static state | ( | $filterState = '*',
 |  | $published = 'JPUBLISHED',
 |  | $unpublished = 'JUNPUBLISHED',
 |  | $archived = null,
 |  | $trashed = null
 | ) |
static

Method to create a select list of states for filtering By default the filter shows only published and unpublished items

Paramètres
string | $filterState | The initial filter state
string | $published | The Text string for published
string | $unpublished | The Text string for Unpublished
string | $archived | The Text string for Archived
string | $trashed | The Text string for Trashed
Renvoie
string
Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • Grid.php


Joomla CMS: Référence de la classe Icons

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Icons
Fonctions membres publiques statiques
Référence de la classe Icons

Fonctions membres publiques statiques

static | buttons ($buttons)
static | button ($button)

Description détaillée

Utility class for icons.

Depuis
2.5

Documentation des fonctions membres

◆ button()

static button ( $button )
static

Method to generate html code for a list of buttons

Paramètres
array $button Button properties
Renvoie
string
Depuis
2.5

Références $button, $i, $layout, $n, $user, et Factory\getUser().

◆ buttons()

static buttons ( $buttons )
static

Method to generate html code for a list of buttons

Paramètres
array $buttons Array of buttons
Renvoie
string
Depuis
2.5

Références $button, $buttons, $html, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Icons.php


Joomla CMS: Référence de la classe JGrid

  • Joomla
  • CMS
  • HTML
  • Helpers
  • JGrid
Fonctions membres publiques statiques
Référence de la classe JGrid

Fonctions membres publiques statiques

static | action ( $i, $task, $prefix='', $activeTitle='', $inactiveTitle='', $tip=false, $activeClass='', $inactiveClass='', $enabled=true, $translate=true, $checkbox='cb', $formId=null)
static | state ($states, $value, $i, $prefix='', $enabled=true, $translate=true, $checkbox='cb', $formId=null)
static | published ( $value, $i, $prefix='', $enabled=true, $checkbox='cb', $publishUp=null, $publishDown=null, $formId=null)
static | isdefault ($value, $i, $prefix='', $enabled=true, $checkbox='cb', $formId=null, $active_class='icon-color-featured icon-star', $inactive_class='icon-unfeatured')
static | publishedOptions ($config=array())
static | checkedout ($i, $editorName, $time, $prefix='', $enabled=false, $checkbox='cb', $formId=null)
static | orderUp ($i, $task='orderup', $prefix='', $text='JLIB_HTML_MOVE_UP', $enabled=true, $checkbox='cb', $formId=null)
static | orderDown ( $i, $task='orderdown', $prefix='', $text='JLIB_HTML_MOVE_DOWN', $enabled=true, $checkbox='cb', $formId=null)

Description détaillée

Utility class for creating HTML Grids

Depuis
1.6

Documentation des fonctions membres

◆ action()

static action | ( | $i,
 |  | $task,
 |  | $prefix = '',
 |  | $activeTitle = '',
 |  | $inactiveTitle = '',
 |  | $tip = false,
 |  | $activeClass = '',
 |  | $inactiveClass = '',
 |  | $enabled = true,
 |  | $translate = true,
 |  | $checkbox = 'cb',
 |  | $formId = null
 | ) |
static

Returns an action on a grid

Paramètres
integer | $i | The row index
string | $task | The task to fire
string | array | $prefix | An optional task prefix or an array of options
string | $activeTitle | An optional active tooltip to display if $enable is true
string | $inactiveTitle | An optional inactive tooltip to display if $enable is true
boolean | $tip | An optional setting for tooltip
string | $activeClass | An optional active HTML class
string | $inactiveClass | An optional inactive HTML class
boolean | $enabled | An optional setting for access control on the action.
boolean | $translate | An optional setting for translation.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Depuis
1.6

Références $enabled, $formId, $html, $i, $options, $prefix, $task, $title, Text\_(), et null.

◆ checkedout()

static checkedout | ( | $i,
 |  | $editorName,
 |  | $time,
 |  | $prefix = '',
 |  | $enabled = false,
 |  | $checkbox = 'cb',
 |  | $formId = null
 | ) |
static

Returns a checked-out icon

Paramètres
integer | $i | The row index.
string | $editorName | The name of the editor.
string | $time | The time that the object was checked out.
string | array | $prefix | An optional task prefix or an array of options
boolean | $enabled | True to enable the action.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Depuis
1.6

◆ isdefault()

static isdefault | ( | $value,
 |  | $i,
 |  | $prefix = '',
 |  | $enabled = true,
 |  | $checkbox = 'cb',
 |  | $formId = null,
 |  | $active_class = 'icon-color-featured icon-star',
 |  | $inactive_class = 'icon-unfeatured'
 | ) |
static

Returns an isDefault state on a grid

Paramètres
integer | $value | The state value.
integer | $i | The row index
string | array | $prefix | An optional task prefix or an array of options
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
string | $active_class | The class for active items.
string | $inactive_class | The class for inactive items.
Renvoie
string The HTML markup
Voir également
JHtmlJGrid::state()
Depuis
1.6

◆ orderDown()

static orderDown | ( | $i,
 |  | $task = 'orderdown',
 |  | $prefix = '',
 |  | $text = 'JLIB_HTML_MOVE_DOWN',
 |  | $enabled = true,
 |  | $checkbox = 'cb',
 |  | $formId = null
 | ) |
static

Creates an order-down action icon.

Paramètres
integer | $i | The row index.
string | $task | An optional task to fire.
string | array | $prefix | An optional task prefix or an array of options
string | $text | An optional text to display
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Depuis
1.6

◆ orderUp()

static orderUp | ( | $i,
 |  | $task = 'orderup',
 |  | $prefix = '',
 |  | $text = 'JLIB_HTML_MOVE_UP',
 |  | $enabled = true,
 |  | $checkbox = 'cb',
 |  | $formId = null
 | ) |
static

Creates an order-up action icon.

Paramètres
integer | $i | The row index.
string | $task | An optional task to fire.
string | array | $prefix | An optional task prefix or an array of options
string | $text | An optional text to display
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Depuis
1.6

◆ published()

static published | ( | $value,
 |  | $i,
 |  | $prefix = '',
 |  | $enabled = true,
 |  | $checkbox = 'cb',
 |  | $publishUp = null,
 |  | $publishDown = null,
 |  | $formId = null
 | ) |
static

Returns a published state on a grid

Paramètres
integer | $value | The state value.
integer | $i | The row index
string | array | $prefix | An optional task prefix or an array of options
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
string | $publishUp | An optional start publishing date.
string | $publishDown | An optional finish publishing date.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Voir également
JHtmlJGrid::state()
Depuis
1.6

◆ publishedOptions()

static publishedOptions ( $config = array() )
static

Returns an array of standard published state filter options.

Paramètres
array $config An array of configuration options. This array can contain a list of key/value pairs where values are boolean and keys can be taken from 'published', 'unpublished', 'archived', 'trash', 'all'. These pairs determine which values are displayed.
Renvoie
array The array of standard published state filter options
Depuis
1.6

◆ state()

static state | ( | $states,
 |  | $value,
 |  | $i,
 |  | $prefix = '',
 |  | $enabled = true,
 |  | $translate = true,
 |  | $checkbox = 'cb',
 |  | $formId = null
 | ) |
static

Returns a state on a grid

Paramètres
array | $states | array of value/state. Each state is an array of the form (task, text, active title, inactive title, tip (boolean), HTML active class, HTML inactive class) or ('task'=>task, 'text'=>text, 'active_title'=>active title, 'inactive_title'=>inactive title, 'tip'=>boolean, 'active_class'=>html active class, 'inactive_class'=>html inactive class)
integer | $value | The state value.
integer | $i | The row index
string | array | $prefix | An optional task prefix or an array of options
boolean | $enabled | An optional setting for access control on the action.
boolean | $translate | An optional setting for translation.
string | $checkbox | An optional prefix for checkboxes.
string | $formId | An optional form selector.
Renvoie
string The HTML markup
Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • JGrid.php


Joomla CMS: Référence de la classe Jquery

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Jquery
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Jquery

Fonctions membres publiques statiques

static | framework ($noConflict=true, $debug=null, $migrate=false)
static | token ($name='csrf.token')

Attributs protégés statiques

static $loaded = array()

Description détaillée

Utility class for jQuery JavaScript behaviors

Depuis
3.0

Documentation des fonctions membres

◆ framework()

static framework | ( | $noConflict = true,
 |  | $debug = null,
 |  | $migrate = false
 | ) |
static

Method to load the jQuery JavaScript framework into the document head

If debugging mode is on an uncompressed version of jQuery is included for easier debugging.

Paramètres
boolean | $noConflict | True to load jQuery in noConflict mode [optional]
mixed | $debug | Is debugging mode on? [optional]
boolean | $migrate | True to enable the jQuery Migrate plugin
Renvoie
void
Depuis
3.0
Obsolète:
5.0 Use Joomla::useAsset();

Références $wa, et Factory\getApplication().

◆ token()

static token ( $name = 'csrf.token' )
static

Auto set CSRF token to ajaxSetup so all jQuery ajax call will contains CSRF token.

Paramètres
string $name The CSRF meta tag name.
Renvoie
void
Exceptions

Références $doc, $name, HTMLHelper\_(), et Factory\getDocument().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Jquery.php


Joomla CMS: Référence de la classe Links

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Links
Fonctions membres publiques statiques
Référence de la classe Links

Fonctions membres publiques statiques

static | linksgroups ($groupsOfLinks)
static | links ($links)
static | link ($link)

Description détaillée

Utility class for icons.

Depuis
3.2

Documentation des fonctions membres

◆ link()

static link ( $link )
static

Method to generate html code for a single link

Paramètres
array $link link properties
Renvoie
string
Depuis
3.2

Références $i, $layout, $link, $n, $user, et Factory\getUser().

◆ links()

static links ( $links )
static

Method to generate html code for a list of links

Paramètres
array $links Array of links
Renvoie
string
Depuis
3.2

Références $html, $link, et HTMLHelper\_().

◆ linksgroups()

static linksgroups ( $groupsOfLinks )
static

Method to generate html code for groups of lists of links

Paramètres
array $groupsOfLinks Array of links
Renvoie
string
Depuis
3.2

Références $html, $layout, $title, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Links.php


Joomla CMS: Référence de la classe ListHelper

  • Joomla
  • CMS
  • HTML
  • Helpers
  • ListHelper
Fonctions membres publiques statiques
Référence de la classe ListHelper

Fonctions membres publiques statiques

static | images ($name, $active=null, $javascript=null, $directory=null, $extensions='bmp|gif|jpg|png')
static | genericordering ($query, $chop=30)
static | ordering ($name, $query, $attribs=null, $selected=null, $neworder=null, ?string $id=null)
static | users ($name, $active, $nouser=0, $javascript=null, $order='name')
static | positions ( $name, $active=null, $javascript=null, $none=true, $center=true, $left=true, $right=true, $id=false)

Description détaillée

Utility class for creating different select lists

Depuis
1.5

Documentation des fonctions membres

◆ genericordering()

static genericordering | ( | $query,
 |  | $chop = 30
 | ) |
static

Returns an array of options

Paramètres
DatabaseQuery | string | $query | SQL with 'ordering' AS value and 'name field' AS text
integer | $chop | The length of the truncated headline
Renvoie
array An array of objects formatted for JHtml list processing
Depuis
1.5

Références $db, $i, $items, $n, $options, $query, $text, Text\_(), HTMLHelper\_(), Factory\getDbo(), text, et value.

◆ images()

static images | ( | $name,
 |  | $active = null,
 |  | $javascript = null,
 |  | $directory = null,
 |  | $extensions = 'bmp|gif|jpg|png'
 | ) |
static

Build the select list to choose an image

Paramètres
string | $name | The name of the field
string | $active | The selected item
string | $javascript | Alternative javascript
string | $directory | Directory the images are stored in
string | $extensions | Allowed extensions
Renvoie
array Image names
Depuis
1.5

Références $active, $images, $name, Text\_(), HTMLHelper\_(), et JPATH_SITE.

◆ ordering()

static ordering | ( |  | $name,
 |  |  | $query,
 |  |  | $attribs = null,
 |  |  | $selected = null,
 |  |  | $neworder = null,
 |  | ?string | $id = null
 | ) |  |
static

Build the select list for Ordering derived from a query

Paramètres
integer | $name | The scalar value
string | $query | The query
string | $attribs | HTML tag attributes
string | $selected | The selected item
integer | $neworder | 1 if new and first, -1 if new and last, 0 or null if existing item
string | $id | ID attribute for the resulting <select> element
Renvoie
string HTML markup for the select list
Depuis
1.6

Références $attribs, $html, $id, $name, $query, $selected, $text, Text\_(), HTMLHelper\_(), et elseif.

◆ positions()

static positions | ( | $name,
 |  | $active = null,
 |  | $javascript = null,
 |  | $none = true,
 |  | $center = true,
 |  | $left = true,
 |  | $right = true,
 |  | $id = false
 | ) |
static

Select list of positions - generally used for location of images

Paramètres
string | $name | Name of the field
string | $active | The active value
string | $javascript | Alternative javascript
boolean | $none | Null if not assigned
boolean | $center | Null if not assigned
boolean | $left | Null if not assigned
boolean | $right | Null if not assigned
boolean | $id | Null if not assigned
Renvoie
array The positions
Depuis
1.5

Références $active, $id, $name, $positions, Text\_(), HTMLHelper\_(), et null.

◆ users()

static users | ( | $name,
 |  | $active,
 |  | $nouser = 0,
 |  | $javascript = null,
 |  | $order = 'name'
 | ) |
static

Select list of active users

Paramètres
string | $name | The name of the field
string | $active | The active user
integer | $nouser | If set include an option to select no user
string | $javascript | Custom javascript
string | $order | Specify a field to order by
Renvoie
string The HTML for a list of users list of users
Depuis
1.5

Références $active, $db, $name, $query, Text\_(), HTMLHelper\_(), et Factory\getDbo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ListHelper.php


Joomla CMS: Référence de la classe Menu

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Menu
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Menu

Fonctions membres publiques statiques

static | menus ($clientId=0)
static | menuItems ($config=array())
static | menuItemList ($name, $selected=null, $attribs=null, $config=array())
static | ordering (&$row, $id)
static | linkOptions ($all=false, $unassigned=false, $clientId=0)
static | treerecurse ($id, $indent, $list, &$children, $maxlevel=9999, $level=0, $type=1)

Attributs protégés statiques

static | $menus = array()
static | $items = array()

Description détaillée

Utility class working with menu select lists

Depuis
1.5

Documentation des fonctions membres

◆ linkOptions()

static linkOptions | ( | $all = false,
 |  | $unassigned = false,
 |  | $clientId = 0
 | ) |
static

Build the multiple select list for Menu Links/Pages

Paramètres
boolean | $all | True if all can be selected
boolean | $unassigned | True if unassigned can be selected
int | $clientId | The client id
Renvoie
string
Depuis
1.5

Références $clientId, $db, $list, $query, Text\_(), HTMLHelper\_(), Factory\getDbo(), ParameterType\INTEGER, et null.

◆ menuItemList()

static menuItemList | ( | $name,
 |  | $selected = null,
 |  | $attribs = null,
 |  | $config = array()
 | ) |
static

Displays an HTML select list of menu items.

Paramètres
string | $name | The name of the control.
string | $selected | The value of the selected option.
string | $attribs | Attributes for the control.
array | $config | An array of options for the control [id, published, checkacl, clientid].
Renvoie
string
Depuis
1.6

Références $attribs, $config, $count, $name, $options, $selected, et HTMLHelper\_().

◆ menuItems()

static menuItems ( $config = array() )
static

Returns an array of menu items grouped by menu.

Paramètres
array $config An array of configuration options [published, checkacl, clientid].
Renvoie
array
Depuis
1.6

Références $clientId, $config, $db, $item, $items, $key, $menu, $query, $user, Text\_(), HTMLHelper\_(), elseif, Factory\getDbo(), Factory\getUser(), et ParameterType\INTEGER.

◆ menus()

static menus ( $clientId = 0 )
static

Get a list of the available menus.

Paramètres
int $clientId The client id
Renvoie
array
Depuis
1.6

Références $clientId, $db, $key, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ ordering()

static ordering | ( | & | $row,
 |  |  | $id
 | ) |  |
static

Build the select list for Menu Ordering

Paramètres
object | $row | The row object
integer | $id | The id for the row. Must exist to enable menu ordering
Renvoie
string
Depuis
1.5

Références $db, $id, $ordering, $query, Text\_(), HTMLHelper\_(), Factory\getDbo(), et ParameterType\INTEGER.

◆ treerecurse()

static treerecurse | ( |  | $id,
 |  |  | $indent,
 |  |  | $list,
 |  | & | $children,
 |  |  | $maxlevel = 9999,
 |  |  | $level = 0,
 |  |  | $type = 1
 | ) |  |
static

Build the list representing the menu tree

Paramètres
integer | $id | Id of the menu item
string | $indent | The indentation string
array | $list | The list to process
array | $children | The children of the current item
integer | $maxlevel | The maximum number of levels in the tree
integer | $level | The starting level
int | $type | Set the type of spacer to use. Use 1 for |_ or 0 for -
Renvoie
array
Depuis
1.5

Références $id, $list, et $type.

Documentation des champs

◆ $items

$items = array()
staticprotected

◆ $menus

$menus = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/HTML/Helpers/Menu.php


Joomla CMS: Référence de la classe Number

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Number
Fonctions membres publiques statiques
Référence de la classe Number

Fonctions membres publiques statiques

static bytes ($bytes, $unit='auto', $precision=2, $iec=false)

Description détaillée

HTML helper class for rendering numbers.

Depuis
1.6

Documentation des fonctions membres

◆ bytes()

static bytes | ( | $bytes,
 |  | $unit = 'auto',
 |  | $precision = 2,
 |  | $iec = false
 | ) |
static

Converts bytes to more distinguishable formats such as: kilobytes, megabytes, etc.

By default, the proper format will automatically be chosen. However, one of the allowed unit types (viz. 'b', 'kB', 'MB', 'GB', 'TB', 'PB', 'EB', 'ZB', 'YB') may also be used instead. IEC standard unit types ('KiB', 'MiB', 'GiB', 'TiB', 'PiB', 'EiB', 'ZiB', 'YiB') can be used as well.

Paramètres
string | $bytes | The number of bytes. Can be either numeric or suffixed format: 32M, 60K, 12G or 812b
string | $unit | The type of unit to return, few special values are: Blank string '' for no unit, 'auto' to choose automatically (default) 'binary' to choose automatically but use binary unit prefix
integer | $precision | The number of digits to be used after the decimal place.
bool | $iec | Whether to be aware of IEC standards. IEC prefixes are always acceptable in input. When IEC is ON: KiB = 1024 B, KB = 1000 B When IEC is OFF: KiB = 1024 B, KB = 1024 B
Renvoie
string The number of bytes in the proper units.
Depuis
1.6 https://en.wikipedia.org/wiki/Binary_prefix

Références $base, $i, $suffix, Text\_(), et elseif.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Number.php


Joomla CMS: Référence de la classe SearchTools

  • Joomla
  • CMS
  • HTML
  • Helpers
  • SearchTools
Fonctions membres publiques statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe SearchTools

Fonctions membres publiques statiques

static | form ($selector='.js-stools-form', $options=array())
static | sort ( $title, $order, $direction='asc', $selected=0, $task=null, $newDirection='asc', $tip='', $icon=null, $formName='adminForm')

Attributs protégés statiques

static $loaded = array()

Fonctions membres privées statiques

static optionsToRegistry ($options)

Description détaillée

Searchtools elements.

Depuis
3.2

Documentation des fonctions membres

◆ form()

static form | ( | $selector = '.js-stools-form',
 |  | $options = array()
 | ) |
static

Load searchtools for a specific form

Paramètres
mixed | $selector | Is debugging mode on? [optional]
array | $options | Optional array of parameters for search tools
Renvoie
void
Depuis
3.2

Références $options, $selector, Factory\getApplication(), et Factory\getDocument().

◆ optionsToRegistry()

static optionsToRegistry ( $options )
staticprivate

Function to receive & pre-process javascript options

Paramètres
mixed $options Associative array/Registry object with options
Renvoie
Registry Options converted to Registry object

Références $options.

◆ sort()

static sort | ( | $title,
 |  | $order,
 |  | $direction = 'asc',
 |  | $selected = 0,
 |  | $task = null,
 |  | $newDirection = 'asc',
 |  | $tip = '',
 |  | $icon = null,
 |  | $formName = 'adminForm'
 | ) |
static

Method to sort a column in a grid

Paramètres
string | $title | The link title
string | $order | The order field for the column
string | $direction | The current direction
mixed | $selected | The selected ordering
string | $task | An optional task override
string | $newDirection | An optional direction for the new column
string | $tip | An optional text shown as tooltip title instead of $title
string | $icon | Icon to show
string | $formName | Name of the form to submit
Renvoie
string

Références $data, $direction, $icon, $selected, $task, $title, et LayoutHelper\render().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SearchTools.php


Joomla CMS: Référence de la classe Select

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Select
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Select

Fonctions membres publiques statiques

static | booleanlist ($name, $attribs=array(), $selected=null, $yes='JYES', $no='JNO', $id=false)
static | genericlist ( $data, $name, $attribs=null, $optKey='value', $optText='text', $selected=null, $idtag=false, $translate=false)
static | groupedlist ($data, $name, $options=array())
static | integerlist ($start, $end, $inc, $name, $attribs=null, $selected=null, $format='')
static | option ($value, $text='', $optKey='value', $optText='text', $disable=false)
static | options ($arr, $optKey='value', $optText='text', $selected=null, $translate=false)
static | radiolist ( $data, $name, $attribs=null, $optKey='value', $optText='text', $selected=null, $idtag=false, $translate=false)

Attributs protégés statiques

static $optionDefaults

Description détaillée

Utility class for creating HTML select lists

Depuis
1.5

Documentation des fonctions membres

◆ booleanlist()

static booleanlist | ( | $name,
 |  | $attribs = array(),
 |  | $selected = null,
 |  | $yes = 'JYES',
 |  | $no = 'JNO',
 |  | $id = false
 | ) |
static

Generates a yes/no radio list.

Paramètres
string | $name | The value of the HTML name attribute
array | $attribs | Additional HTML attributes for the <select> tag
string | $selected | The key that is selected
string | $yes | Language key for Yes
string | $no | Language key for no
mixed | $id | The id for the field or false for no id
Renvoie
string HTML for the radio list
Depuis
1.5
Voir également

Références $attribs, $id, $name, $selected, Text\_(), et HTMLHelper\_().

◆ genericlist()

static genericlist | ( | $data,
 |  | $name,
 |  | $attribs = null,
 |  | $optKey = 'value',
 |  | $optText = 'text',
 |  | $selected = null,
 |  | $idtag = false,
 |  | $translate = false
 | ) |
static

Generates an HTML selection list.

Paramètres
array | $data | An array of objects, arrays, or scalars.
string | $name | The value of the HTML name attribute.
mixed | $attribs | Additional HTML attributes for the <select> tag. This can be an array of attributes, or an array of options. Treated as options if it is the last argument passed. Valid options are: Format options, see {
Voir également
HTMLHelper::$formatOptions}. Selection options, see {
JHtmlSelect::options()}. list.attr, string|array: Additional attributes for the select element. id, string: Value to use as the select element id attribute. Defaults to the same as the name. list.select, string|array: Identifies one or more option elements to be selected, based on the option key values.
Paramètres
string | $optKey | The name of the object variable for the option value. If set to null, the index of the value array is used.
string | $optText | The name of the object variable for the option text.
mixed | $selected | The key that is selected (accepts an array or a string).
mixed | $idtag | Value of the field id or null by default
boolean | $translate | True to translate
Renvoie
string HTML for the select list.
Depuis
1.5

Références $attribs, $data, HTMLHelper\$formatOptions, $html, $id, $name, $options, $selected, Factory\getDocument(), et ArrayHelper\toString().

◆ groupedlist()

static groupedlist | ( | $data,
 |  | $name,
 |  | $options = array()
 | ) |
static

Generates a grouped HTML selection list from nested arrays.

Paramètres
array | $data | An array of groups, each of which is an array of options.
string | $name | The value of the HTML name attribute
array | $options | Options, an array of key/value pairs. Valid options are: Format options, {
Voir également
HTMLHelper::$formatOptions}. Selection options. See {
JHtmlSelect::options()}. group.id: The property in each group to use as the group id attribute. Defaults to none. group.label: The property in each group to use as the group label. Defaults to "text". If set to null, the data array index key is used. group.items: The property in each group to use as the array of items in the group. Defaults to "items". If set to null, group.id and group. label are forced to null and the data element is assumed to be a list of selections. id: Value to use as the select element id attribute. Defaults to the same as the name. list.attr: Attributes for the select element. Can be a string or an array of key/value pairs. Defaults to none. list.select: either the value of one selected option or an array of selected options. Default: none. list.translate: Boolean. If set, text and labels are translated via Text::_().
Renvoie
string HTML for the select list
Depuis
1.5
Exceptions

Références $attribs, $data, HTMLHelper\$formatOptions, $html, $id, $label, $name, $options, elseif, null, et ArrayHelper\toString().

◆ integerlist()

static integerlist | ( | $start,
 |  | $end,
 |  | $inc,
 |  | $name,
 |  | $attribs = null,
 |  | $selected = null,
 |  | $format = ''
 | ) |
static

Generates a selection list of integers.

Paramètres
integer | $start | The start integer
integer | $end | The end integer
integer | $inc | The increment
string | $name | The value of the HTML name attribute
mixed | $attribs | Additional HTML attributes for the <select> tag, an array of attributes, or an array of options. Treated as options if it is the last argument passed.
mixed | $selected | The key that is selected
string | $format | The printf format to be applied to the number
Renvoie
string HTML for the select list
Depuis
1.5

Références $attribs, $data, $format, HTMLHelper\$formatOptions, $i, $name, $options, $selected, $start, HTMLHelper\_(), et null.

◆ option()

static option | ( | $value,
 |  | $text = '',
 |  | $optKey = 'value',
 |  | $optText = 'text',
 |  | $disable = false
 | ) |
static

Create an object that represents an option in an option list.

Paramètres
string | $value | The value of the option
string | $text | The text for the option
mixed | $optKey | If a string, the returned object property name for the value. If an array, options. Valid options are: attr: String|array. Additional attributes for this option. Defaults to none. disable: Boolean. If set, this option is disabled. label: String. The value for the option label. option.attr: The property in each option array to use for additional selection attributes. Defaults to none. option.disable: The property that will hold the disabled state. Defaults to "disable". option.key: The property that will hold the selection value. Defaults to "value". option.label: The property in each option array to use as the selection label attribute. If a "label" option is provided, defaults to "label", if no label is given, defaults to null (none). option.text: The property that will hold the the displayed text. Defaults to "text". If set to null, the option array is assumed to be a list of displayable scalars.
string | $optText | The property that will hold the the displayed text. This parameter is ignored if an options array is passed.
boolean | $disable | Not used.
Renvoie
Depuis
1.5

Références $options, et null.

◆ options()

static options | ( | $arr,
 |  | $optKey = 'value',
 |  | $optText = 'text',
 |  | $selected = null,
 |  | $translate = false
 | ) |
static

Generates the option tags for an HTML select list (with no select tag surrounding the options).

Paramètres
array | $arr | An array of objects, arrays, or values.
mixed | $optKey | If a string, this is the name of the object variable for the option value. If null, the index of the array of objects is used. If an array, this is a set of options, as key/value pairs. Valid options are: -Format options, {
Voir également
HTMLHelper::$formatOptions}. -groups: Boolean. If set, looks for keys with the value "&lt;optgroup>" and synthesizes groups from them. Deprecated. Defaults true for backwards compatibility. -list.select: either the value of one selected option or an array of selected options. Default: none. -list.translate: Boolean. If set, text and labels are translated via Text::_(). Default is false. -option.id: The property in each option array to use as the selection id attribute. Defaults to none. -option.key: The property in each option array to use as the selection value. Defaults to "value". If set to null, the index of the option array is used. -option.label: The property in each option array to use as the selection label attribute. Defaults to null (none). -option.text: The property in each option array to use as the displayed text. Defaults to "text". If set to null, the option array is assumed to be a list of displayable scalars. -option.attr: The property in each option array to use for additional selection attributes. Defaults to none. -option.disable: The property that will hold the disabled state. Defaults to "disable". -option.key: The property that will hold the selection value. Defaults to "value". -option.text: The property that will hold the the displayed text. Defaults to "text". If set to null, the option array is assumed to be a list of displayable scalars.
Paramètres
string | $optText | The name of the object variable for the option text.
mixed | $selected | The key that is selected (accepts an array or a string)
boolean | $translate | Translate the option values.
Renvoie
string HTML for the select list
Depuis
1.5

Références $attr, HTMLHelper\$formatOptions, $html, $id, $key, $label, $options, $selected, $text, elseif, et null.

◆ radiolist()

static radiolist | ( | $data,
 |  | $name,
 |  | $attribs = null,
 |  | $optKey = 'value',
 |  | $optText = 'text',
 |  | $selected = null,
 |  | $idtag = false,
 |  | $translate = false
 | ) |
static

Generates an HTML radio list.

Paramètres
array | $data | An array of objects
string | $name | The value of the HTML name attribute
string | $attribs | Additional HTML attributes for the <select> tag
mixed | $optKey | The key that is selected
string | $optText | The name of the object variable for the option value
string | $selected | The name of the object variable for the option text
boolean | $idtag | Value of the field id or null by default
boolean | $translate | True if options will be translated
Renvoie
string HTML for the select list
Depuis
1.5

Références $attribs, $data, $html, $id, $name, $selected, $val, Text\_(), null, et ArrayHelper\toString().

Documentation des champs

◆ $optionDefaults

$optionDefaults
staticprotected
Valeur initiale :
= array(
'option' => array(
'option.attr' => null,
'option.disable' => 'disable',
'option.id' => null,
'option.key' => 'value',
'option.key.toHtml' => true,
'option.label' => null,
'option.label.toHtml' => true,
'option.text' => 'text',
'option.text.toHtml' => true,
'option.class' => 'class',
'option.onclick' => 'onclick',
),
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • Select.php


Joomla CMS: Référence de la classe Sidebar

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Sidebar
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Sidebar

Fonctions membres publiques statiques

static | render ()
static | addEntry ($name, $link='', $active=false)
static | getEntries ()
static | addFilter ($label, $name, $options, $noDefault=false)
static | getFilters ()
static | setAction ($action)
static | getAction ()

Attributs protégés statiques

static | $entries = array()
static | $filters = array()
static | $action = ''

Description détaillée

Utility class to render a list view sidebar

Depuis
3.0

Documentation des fonctions membres

◆ addEntry()

static addEntry | ( | $name,
 |  | $link = '',
 |  | $active = false
 | ) |
static

Method to add a menu item to submenu.

Paramètres
string | $name | Name of the menu item.
string | $link | URL of the menu item.
bool | $active | True if the item is active, false otherwise.
Renvoie
void
Depuis
3.0

Références $active, $link, et $name.

◆ addFilter()

static addFilter | ( | $label,
 |  | $name,
 |  | $options,
 |  | $noDefault = false
 | ) |
static

Method to add a filter to the submenu

Paramètres
string | $label | Label for the menu item.
string | $name | Name for the filter. Also used as id.
string | $options | Options for the select field.
bool | $noDefault | Don't show the label as the empty option
Renvoie
void
Depuis
3.0

Références $filters, $label, $name, et $options.

◆ getAction()

static getAction ( )
static

Get value for the action attribute of the filter form

Renvoie
string
Depuis
3.0

◆ getEntries()

static getEntries ( )
static

Returns an array of all submenu entries

Renvoie
array
Depuis
3.0

◆ getFilters()

static getFilters ( )
static

Returns an array of all filters

Renvoie
array
Depuis
3.0

Références $filters.

◆ render()

static render ( )
static

Render the sidebar.

Renvoie
string The necessary HTML to display the sidebar
Depuis
3.0

Références $data, $layout, et Factory\getApplication().

◆ setAction()

static setAction ( $action )
static

Set value for the action attribute of the filter form

Paramètres
string $action Value for the action attribute of the form
Renvoie
void
Depuis
3.0

Documentation des champs

◆ $action

$action = ''
staticprotected

◆ $entries

$entries = array()
staticprotected

◆ $filters

$filters = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Sidebar.php


Joomla CMS: Référence de la classe SortableList

  • Joomla
  • CMS
  • HTML
  • Helpers
  • SortableList
Fonctions membres publiques statiques
Référence de la classe SortableList

Fonctions membres publiques statiques

static sortable ($tableId, $formId, $sortDir='asc', $saveOrderingUrl=null, $proceedSaveOrderButton=true, $nestedList=false)

Description détaillée

HTML utility class for creating a sortable table list

Depuis
3.0
Obsolète:
5.0 Sortable List will be deprecated in favour of a new dragula script in 4.0

Documentation des fonctions membres

◆ sortable()

static sortable | ( | $tableId,
 |  | $formId,
 |  | $sortDir = 'asc',
 |  | $saveOrderingUrl = null,
 |  | $proceedSaveOrderButton = true,
 |  | $nestedList = false
 | ) |
static

Method to load the Sortable script and make table sortable

Paramètres
string | $tableId | DOM id of the table
string | $formId | DOM id of the form
string | $sortDir | Sort direction
string | $saveOrderingUrl | Save ordering url, ajax-load after an item dropped
boolean | $proceedSaveOrderButton | Set whether a save order button is displayed
boolean | $nestedList | Set whether the list is a nested list
Renvoie
void
Depuis
3.0
Obsolète:
5.0 In Joomla 4 call JHtml::_('draggablelist.draggable') and add a class of js-draggable to the tbody element of the table

Références $formId, $saveOrderingUrl, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SortableList.php


Joomla CMS: Référence de la classe StringHelper

  • Joomla
  • CMS
  • HTML
  • Helpers
  • StringHelper
Fonctions membres publiques statiques
Référence de la classe StringHelper

Fonctions membres publiques statiques

static | truncate ($text, $length=0, $noSplit=true, $allowHtml=true)
static | truncateComplex ($html, $maxLength=0, $noSplit=true)
static | abridge ($text, $length=50, $intro=30)

Description détaillée

HTML helper class for rendering manipulated strings.

Depuis
1.6

Documentation des fonctions membres

◆ abridge()

static abridge | ( | $text,
 |  | $length = 50,
 |  | $intro = 30
 | ) |
static

Abridges text strings over the specified character limit. The behavior will insert an ellipsis into the text replacing a section of variable size to ensure the string does not exceed the defined maximum length. This method is UTF-8 safe.

For example, it transforms "Really long title" to "Really...title".

Note that this method does not scan for HTML tags so will potentially break them.

Paramètres
string | $text | The text to abridge.
integer | $length | The maximum length of the text (default is 50).
integer | $intro | The maximum length of the intro text (default is 30).
Renvoie
string The abridged text.
Depuis
1.6

Références $text.

◆ truncate()

static truncate | ( | $text,
 |  | $length = 0,
 |  | $noSplit = true,
 |  | $allowHtml = true
 | ) |
static

Truncates text blocks over the specified character limit and closes all open HTML tags. The method will optionally not truncate an individual word, it will find the first space that is within the limit and truncate at that point. This method is UTF-8 safe.

Paramètres
string | $text | The text to truncate.
integer | $length | The maximum length of the text.
boolean | $noSplit | Don't split a word if that is where the cutoff occurs (default: true).
boolean | $allowHtml | Allow HTML tags in the output, and close any open tags (default: true).
Renvoie
string The truncated text.
Depuis
1.6

Références $i, Joomla\Database\Query\$offset, $result, $text, $tmp, et ENT_QUOTES.

◆ truncateComplex()

static truncateComplex | ( | $html,
 |  | $maxLength = 0,
 |  | $noSplit = true
 | ) |
static

Method to extend the truncate method to more complex situations

The goal is to get the proper length plain text string with as much of the html intact as possible with all tags properly closed.

Paramètres
string | $html | The content of the introtext to be truncated
integer | $maxLength | The maximum number of characters to render
boolean | $noSplit | Don't split a word if that is where the cutoff occurs (default: true).
Renvoie
string The truncated string. If the string is truncated an ellipsis (...) will be appended.
Note
If a maximum length of 3 or less is selected and the text has more than that number of characters an ellipsis will be displayed. This method will not create valid HTML from malformed HTML.
Depuis
3.1

Références $html, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/HTML/Helpers/StringHelper.php


Joomla CMS: Référence de la classe Tag

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Tag
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Tag

Fonctions membres publiques statiques

static | options ($config=array('filter.published'=> array(0, 1)))
static | tags ($config=array('filter.published'=> array(0, 1)))
static | ajaxfield ($selector='#jform_tags', $allowCustom=true)

Attributs protégés statiques

static $items = array()

Description détaillée

Utility class for tags

Depuis
3.1

Documentation des fonctions membres

◆ ajaxfield()

static ajaxfield | ( | $selector = '#jform_tags',
 |  | $allowCustom = true
 | ) |
static

This is just a proxy for the formbehavior.ajaxchosen method

Paramètres
string | $selector | DOM id of the tag field
boolean | $allowCustom | Flag to allow custom values
Renvoie
void
Depuis
3.1
Obsolète:
5.0 Without replacement

Références $params, $selector, HTMLHelper\_(), Factory\getDocument(), ComponentHelper\getParams(), Factory\getUser(), JDEBUG, Uri\root(), et Text\script().

◆ options()

static options ( $config = array('filter.published' => array(0, 1)) )
static

Returns an array of tags.

Paramètres
array $config An array of configuration options. By default, only published and unpublished categories are returned.
Renvoie
array
Depuis
3.1

Références $config, $db, $hash, $item, $items, $query, HTMLHelper\_(), elseif, Factory\getDbo(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

◆ tags()

static tags ( $config = array('filter.published' => array(0, 1)) )
static

Returns an array of tags.

Paramètres
array $config An array of configuration options. By default, only published and unpublished tags are returned.
Renvoie
array Tag data
Depuis
3.1

Références $config, $db, $hash, $item, $items, $query, HTMLHelper\_(), elseif, Factory\getDbo(), ParameterType\INTEGER, et ArrayHelper\toInteger().

Documentation des champs

◆ $items

$items = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Tag.php


Joomla CMS: Référence de la classe Telephone

  • Joomla
  • CMS
  • HTML
  • Helpers
  • Telephone
Fonctions membres publiques statiques
Référence de la classe Telephone

Fonctions membres publiques statiques

static tel ($number, $displayplan)

Description détaillée

HTML helper class for rendering telephone numbers.

Depuis
1.6

Documentation des fonctions membres

◆ tel()

static tel | ( | $number,
 |  | $displayplan
 | ) |
static

Converts strings of integers into more readable telephone format

By default, the ITU-T format will automatically be used. However, one of the allowed unit types may also be used instead.

Paramètres
integer | $number | The integers in a phone number with dot separated country code ccc.nnnnnnn where ccc represents country code and nnn represents the local number.
string | $displayplan | The numbering plan used to display the numbers.
Renvoie
string The formatted telephone number.
Voir également
Depuis
1.6

Références $display, elseif, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Telephone.php


Joomla CMS: Référence de la classe UiTab

  • Joomla
  • CMS
  • HTML
  • Helpers
  • UiTab
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe UiTab

Fonctions membres publiques statiques

static | startTabSet ($selector='myTab', $params=array())
static | endTabSet ()
static | addTab ($selector, $id, $title)
static | endTab ()

Attributs protégés statiques

static $loaded = array()

Description détaillée

Utility class for the Joomla core UI Tab element.

Depuis
4.0.0

Documentation des fonctions membres

◆ addTab()

static addTab | ( | $selector,
 |  | $id,
 |  | $title
 | ) |
static

Begins the display of a new tab content panel.

Paramètres
string | $selector | Identifier of the panel.
string | $id | The ID of the div element
string | $title | The title text for the button
Renvoie
string HTML to start a new panel
Depuis
4.0.0

Références $active, $id, $selector, $title, et ENT_COMPAT.

◆ endTab()

static endTab ( )
static

Close the current tab content panel

Renvoie
string HTML to close the pane
Depuis
4.0.0

◆ endTabSet()

static endTabSet ( )
static

Close the current tab pane

Renvoie
string HTML to close the pane
Depuis
4.0.0

◆ startTabSet()

static startTabSet | ( | $selector = 'myTab',
 |  | $params = array()
 | ) |
static

Creates a core UI tab pane

Paramètres
string | $selector | The pane identifier.
array | $params | The parameters for the pane
Renvoie
string
Depuis
4.0.0

Références $params, $selector, et Factory\getDocument().

Documentation des champs

◆ $loaded

$loaded = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UiTab.php


Joomla CMS: Référence de la classe User

  • Joomla
  • CMS
  • HTML
  • Helpers
  • User
Fonctions membres publiques statiques
Référence de la classe User

Fonctions membres publiques statiques

static | groups ($includeSuperAdmin=false)
static | userlist ()

Description détaillée

Utility class working with users

Depuis
2.5

Documentation des fonctions membres

◆ groups()

static groups ( $includeSuperAdmin = false )
static

Displays a list of user groups.

Paramètres
boolean $includeSuperAdmin true to include super admin groups, false to exclude them
Renvoie
array An array containing a list of user groups.
Depuis
2.5

Références $groups, $i, $n, $options, HTMLHelper\_(), Access\checkGroup(), UserGroupsHelper\getInstance(), level, text, et value.

◆ userlist()

static userlist ( )
static

Get a list of users.

Renvoie
string
Depuis
2.5

Références $db, $query, et Factory\getDbo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HTML/Helpers/User.php


Joomla CMS: Référence de la classe WorkflowStage

  • Joomla
  • CMS
  • HTML
  • Helpers
  • WorkflowStage
Fonctions membres publiques statiques
Référence de la classe WorkflowStage

Fonctions membres publiques statiques

static existing ($options)

Description détaillée

Utility class working with workflow states select lists

Depuis
4.0.0

Documentation des fonctions membres

◆ existing()

static existing ( $options )
static

Get a list of the available workflow stages.

Paramètres
array $options An array of options for the control
Renvoie
array
Depuis
4.0.0

Références $db, $options, $prefix, $query, Text\_(), HTMLHelper\_(), et Factory\getDbo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowStage.php


Joomla CMS: Référence de la classe HTMLHelper

  • Joomla
  • CMS
  • HTML
  • HTMLHelper
Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres protégées statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe HTMLHelper

Fonctions membres publiques statiques

static | _ (string $key,... $methodArgs)
static | register ($key, callable $function)
static | unregister ($key)
static | isRegistered ($key)
static | getServiceRegistry ()
static | link ($url, $text, $attribs=null)
static | iframe ($url, $name, $attribs=null, $noFrames='')
static | cleanImageURL ($url)
static | image ($file, $alt, $attribs=null, $relative=false, $returnPath=0)
static | stylesheet ($file, $options=array(), $attribs=array())
static | script ($file, $options=array(), $attribs=array())
static | setFormatOptions ($options)
static | date ($input='now', $format=null, $tz=true, $gregorian=false)
static | tooltip ($tooltip, $title='', $image='tooltip.png', $text='', $href='', $alt='Tooltip', $class='hasTooltip')
static | tooltipText ($title='', $content='', $translate=true, $escape=true)
static | calendar ($value, $name, $id, $format='%Y-%m-%d', $attribs=array())
static | addIncludePath ($path='')

Attributs publics statiques

static $formatOptions = array('format.depth' => 0, 'format.eol' => "\n", 'format.indent' => "\t")

Fonctions membres protégées statiques

static | extract ($key)
static | call (callable $function, $args)
static | includeRelativeFiles ($folder, $file, $relative, $detectBrowser, $detectDebug)
static | addFileToBuffer ($path='', $ext='', $debugMode=false)
static | convertToRelativePath ($path)

Attributs protégés statiques

static | $includePaths = array()
static | $registry = array()
static | $serviceRegistry

Fonctions membres privées statiques

static checkFileOrder ($first, $second)

Description détaillée

Utility class for all HTML drawing classes

Depuis
1.5

Documentation des fonctions membres

◆ _()

static _ | ( | string | $key,
 |  |  | $methodArgs
 | ) |  |
staticfinal

Class loader method

Additional arguments may be supplied and are passed to the sub-class. Additional include paths are also able to be specified for third-party use

Paramètres
string | $key | The name of helper method to load, (prefix).(class).function prefix and class are optional and can be used to load custom html helpers.
array | $methodArgs | The arguments to pass forward to the method being called
Renvoie
mixed Result of HTMLHelper::call($function, $args)
Depuis
1.5
Exceptions

Références $className, $function, $key, $path, $prefix, Path\find(), et JLoader\register().

Référencé par LinkModel\activate(), FormBehavior\ajaxchosen(), Tag\ajaxfield(), Access\assetgrouplist(), Modules\batchOptions(), Select\booleanlist(), Icons\buttons(), Category\categories(), Banner\clients(), Languages\clients(), Icon\create(), FeedView\display(), DisplayController\display(), HtmlView\display(), Icon\edit(), WorkflowStage\existing(), ListHelper\genericordering(), UsersHelper\getActiveOptions(), ModulesModel\getActivePositions(), ModulesHelper\getAssignmentOptions(), TemplatesHelper\getClientOptions(), ModulesHelper\getClientOptions(), InstallerHelper\getClientOptions(), BannersHelper\getClientOptions(), MessagesModel\getComponentOptions(), InstallerHelper\getExtensionGroups(), InstallerHelper\getExtensionTypes(), ItemtypeField\getGroups(), GroupedlistField\getGroups(), WorkflowstageField\getGroups(), TimezoneField\getGroups(), TemplatestyleField\getGroups(), ChromestyleField\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), PlugininfoField\getInput(), AssociationField\getInput(), FieldLayoutField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), UploaddirsField\getInput(), TemplatesListField\getInput(), OrderingField\getInput(), ModulesPositioneditField\getInput(), ModulepositionField\getInput(), ConsentBoxField\getInput(), Authentication\getKnownAuthenticators(), TosField\getLabel(), SpacerField\getLabel(), NoteField\getLabel(), ConsentBoxField\getLabel(), LoginHelper\getLanguageList(), DebugHelper\getLevelsOptions(), Pagination\getLimitBox(), StatsHelper\getList(), ArticlesArchiveHelper\getList(), ArticlesCategoryHelper\getList(), Utility\getMaxUploadSize(), ModuletagField\getOptions(), HeadertagField\getOptions(), IntegerField\getOptions(), ContentlanguageField\getOptions(), AccesslevelField\getOptions(), BranchesField\getOptions(), WorkflowComponentSectionsField\getOptions(), SearchfilterField\getOptions(), SessionhandlerField\getOptions(), CachehandlerField\getOptions(), ExtensionField\getOptions(), FontsField\getOptions(), LogtypeField\getOptions(), MenuPresetField\getOptions(), TaskTypeField\getOptions(), ContenttypesField\getOptions(), CategoryField\getOptions(), TypeField\getOptions(), SubfieldsField\getOptions(), TransitionField\getOptions(), RedirectField\getOptions(), CategoryeditField\getOptions(), CronField\getOptions(), FolderlistField\getOptions(), FilelistField\getOptions(), TextField\getOptions(), SqlField\getOptions(), LocalAdapter\getPathInformation(), ModulesHelper\getPositions(), DisplayController\getQuickiconContent(), UsersHelper\getRangeOptions(), MessagesHelper\getStateOptions(), ModulesHelper\getStateOptions(), UsersHelper\getStateOptions(), InstallerHelper\getStateOptions(), User\groups(), ListHelper\images(), Dropdown\init(), Select\integerlist(), Access\level(), Menu\linkOptions(), Links\links(), Links\linksgroups(), MediaActionPlugin\loadCss(), MediaActionPlugin\loadJs(), Finder\mapslist(), Menu\menuItemList(), Menu\menuItems(), Users\notesModal(), CoreAssetItem\onAttachCallback(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Category\options(), Tag\options(), Pagination\orderDownIcon(), ListHelper\ordering(), Menu\ordering(), Pagination\orderUpIcon(), Banner\pinned(), Modules\positions(), ListHelper\positions(), ContentmapField\prepareLevel(), Languages\published(), PluginsHelper\publishedOptions(), RedirectHelper\publishedOptions(), Languages\publishedOptions(), FeedView\reconcileNames(), Date\relative(), PublishedButton\render(), FeaturedButton\render(), PopupButton\renderButton(), Bootstrap\renderModal(), WebAssetItem\resolvePath(), Text\script(), Filter\select(), ActionlogModel\sendNotificationEmails(), BreadcrumbsHelper\setSeparator(), Filter\slider(), Grid\sort(), SortableList\sortable(), Bootstrap\startTabSet(), Updatesites\state(), Manage\state(), Modules\state(), Finder\statelist(), Tag\tags(), Modules\templates(), Modules\templateStates(), Templates\thumb(), Templates\thumbModal(), Jquery\token(), ArticlesCategoryHelper\truncate(), StringHelper\truncateComplex(), Modules\types(), Finder\typeslist(), Access\usergroup(), ListHelper\users(), et Debug\xdebuglink().

◆ addFileToBuffer()

static addFileToBuffer | ( | $path = '',
 |  | $ext = '',
 |  | $debugMode = false
 | ) |
staticprotected

Method that searches if file exists in given path and returns the relative path. If a minified version exists it will be preferred.

Paramètres
string | $path | The actual path of the file
string | $ext | The extension of the file
boolean | $debugMode | Signifies if debug is enabled
Renvoie
string The relative path of the file
Depuis
4.0.0

Références $path, et $position.

◆ addIncludePath()

static addIncludePath ( $path = '' )
static

Add a directory where HTMLHelper should search for helpers. You may either pass a string or an array of directories.

Paramètres
string $path A path to search.
Renvoie
array An array with directory elements
Depuis
1.5
Obsolète:
5.0 Use the service registry instead

Références $dir, $path, et Path\clean().

◆ calendar()

static calendar | ( | $value,
 |  | $name,
 |  | $id,
 |  | $format = '%Y-%m-%d',
 |  | $attribs = array()
 | ) |
static

Displays a calendar control field

Paramètres
string | $value | The date value
string | $name | The name of the text field
string | $id | The id of the text field
string | $format | The date format
mixed | $attribs | Additional HTML attributes The array can have the following keys: readonly Sets the readonly parameter for the input tag disabled Sets the disabled parameter for the input tag autofocus Sets the autofocus parameter for the input tag autocomplete Sets the autocomplete parameter for the input tag filter Sets the filter for the input tag
Renvoie
string HTML markup for a calendar field
Depuis
1.5

Références $app, $attribs, $autocomplete, $autofocus, $class, $data, $direction, $disabled, $format, $hint, $id, $inputvalue, $lang, $name, $onchange, $readonly, $required, $value, Factory\getApplication(), Factory\getDbo(), JPATH_ROOT, null, et LayoutHelper\render().

◆ call()

static call | ( | callable | $function,
 |  |  | $args
 | ) |  |
staticprotected

Function caller method

Paramètres
callable | $function | Function or method to call
array | $args | Arguments to be passed to function
Renvoie
mixed Function result or false on error.

1.6

Références $function, et $temp.

◆ checkFileOrder()

static checkFileOrder | ( | $first,
 |  | $second
 | ) |
staticprivate

Method that takes two paths and checks if the files exist with different order

Paramètres
string | $first | the path of the minified file
string | $second | the path of the non minified file
Renvoie
string
Depuis
4.0.0

◆ cleanImageURL()

static cleanImageURL ( $url )
static

Références $height, $url, $width, et null.

◆ convertToRelativePath()

static convertToRelativePath ( $path )
staticprotected

Method that takes a file path and converts it to a relative path

Paramètres
string $path The actual path of the file
Renvoie
string The relative path of the file
Depuis
4.0.0

Références $path, JPATH_ROOT, et Uri\root().

◆ date()

static date | ( | $input = 'now',
 |  | $format = null,
 |  | $tz = true,
 |  | $gregorian = false
 | ) |
static

Returns formatted date according to a given format and time zone.

Paramètres
string | $input | String in a format accepted by date(), defaults to "now".
string | $format | The date format specification string (see PHP_MANUAL#date).
mixed | $tz | Time zone to be used for the date. Special cases: boolean true for user setting, boolean false for server setting.
boolean | $gregorian | True to use Gregorian calendar.
Renvoie
string A date translated by the given format and time zone.
Voir également
strftime
Depuis
1.5

Références $app, $date, $format, $input, Text\_(), elseif, Factory\getApplication(), Factory\getDate(), Factory\getLanguage(), et null.

◆ extract()

static extract ( $key )
staticprotected

Method to extract a key

Paramètres
string $key The name of helper method to load, (prefix).(class).function prefix and class are optional and can be used to load custom html helpers.
Renvoie
array Contains lowercase key, prefix, file, function.
Depuis
1.6
Obsolète:
5.0 Use the service registry instead

Références $key, $parts, et $prefix.

◆ getServiceRegistry()

static getServiceRegistry ( )
static

Retrieves the service registry.

Renvoie
Registry
Depuis
4.0.0

Références class, et Factory\getContainer().

◆ iframe()

static iframe | ( | $url,
 |  | $name,
 |  | $attribs = null,
 |  | $noFrames = ''
 | ) |
static

Write a <iframe> element

Paramètres
string | $url | The relative URL to use for the src attribute.
string | $name | The target attribute to use.
array | string | $attribs | Attributes to be added to the <iframe> element
string | $noFrames | The message to display if the iframe tag is not supported.
Renvoie
string
Depuis
1.5

Références $attribs, $name, $url, et ArrayHelper\toString().

◆ image()

static image | ( | $file,
 |  | $alt,
 |  | $attribs = null,
 |  | $relative = false,
 |  | $returnPath = 0
 | ) |
static

Write a <img> element

Paramètres
string | $file | The relative or absolute URL to use for the src attribute.
string | $alt | The alt text.
array | string | $attribs | Attributes to be added to the <img> element
boolean | $relative | Flag if the path to the file is relative to the /media folder (and searches in template).
integer | $returnPath | Defines the return value for the method: -1: Returns a <img> tag without looking for relative files 0: Returns a <img> tag while searching for relative files 1: Returns the file path to the image while searching for relative files
Renvoie
string|null HTML markup for the image, relative path to the image, or null if path is to be returned but image is not found
Depuis
1.5

Références $alt, $attribs, $attributes, $key, $path, $value, Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), null, et LayoutHelper\render().

◆ includeRelativeFiles()

static includeRelativeFiles | ( | $folder,
 |  | $file,
 |  | $relative,
 |  | $detectBrowser,
 |  | $detectDebug
 | ) |
staticprotected

Compute the files to be included

Paramètres
string | $folder | Folder name to search in (i.e. images, css, js).
string | $file | Path to file.
boolean | $relative | Flag if the path to the file is relative to the /media folder (and searches in template).
boolean | $detectBrowser | Flag if the browser should be detected to include specific browser files.
boolean | $detectDebug | Flag if debug mode is enabled to include uncompressed files if debug is on.
Renvoie
array files to be included.
Voir également
Browser
Depuis
1.6

Loop on 1 or 2 files and break on first found. Add the content of the MD5SUM file located in the same folder to url to ensure cache browser refresh This MD5SUM file must represent the signature of the folder content

Loop on 1 or 2 files and break on first found. Add the content of the MD5SUM file located in the same folder to url to ensure cache browser refresh This MD5SUM file must represent the signature of the folder content

Références $app, $client, $extension, $path, $template, Factory\getApplication(), File\getExt(), Browser\getInstance(), JDEBUG, JPATH_ROOT, JPATH_THEMES, et File\stripExt().

◆ isRegistered()

static isRegistered ( $key )
static

Test if the key is registered.

Paramètres
string $key The name of the key
Renvoie
boolean True if the key is registered.
Depuis
1.6

Références $key.

◆ link()

static link | ( | $url,
 |  | $text,
 |  | $attribs = null
 | ) |
static

Write a <a> element

Paramètres
string | $url | The relative URL to use for the href attribute
string | $text | The target attribute to use
array | string | $attribs | Attributes to be added to the <a> element
Renvoie
string
Depuis
1.5

Références $attribs, $text, $url, et ArrayHelper\toString().

Référencé par ActionsDropdown\addCustomItem().

◆ register()

static register | ( |  | $key,
 |  | callable | $function
 | ) |  |
static

Registers a function to be called with a specific key

Paramètres
string | $key | The name of the key
callable | $function | Function or method
Renvoie
boolean True if the function is callable
Depuis
1.6
Obsolète:
5.0 Use the service registry instead

Références $function, et $key.

◆ script()

static script | ( | $file,
 |  | $options = array(),
 |  | $attribs = array()
 | ) |
static

Write a <script> element to load a JavaScript file

Paramètres
string | $file | Path to file.
array | $options | Array of options. Example: array('version' => 'auto', 'conditional' => 'lt IE 9')
array | $attribs | Array of attributes. Example: array('id' => 'scriptid', 'async' => 'async', 'data-test' => 1)
Renvoie
array|string|null Nothing if $returnPath is false, null, path or array of path if specific JavaScript browser files were detected
Voir également
HTMLHelper::stylesheet()
Depuis
1.5

Références $attribs, $document, $options, Factory\getApplication(), et Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles().

◆ setFormatOptions()

static setFormatOptions ( $options )
static

Set format related options.

Updates the formatOptions array with all valid values in the passed array.

Paramètres
array $options Option key/value pairs.
Renvoie
void
Voir également
HTMLHelper::$formatOptions
Depuis
1.5

Références $key, $options, et $val.

◆ stylesheet()

static stylesheet | ( | $file,
 |  | $options = array(),
 |  | $attribs = array()
 | ) |
static

Write a <link> element to load a CSS file

Paramètres
string | $file | Path to file
array | $options | Array of options. Example: array('version' => 'auto', 'conditional' => 'lt IE 9')
array | $attribs | Array of attributes. Example: array('id' => 'scriptid', 'async' => 'async', 'data-test' => 1)
Renvoie
array|string|null nothing if $returnPath is false, null, path or array of path if specific CSS browser files were detected
Voir également
Browser
Depuis
1.5

Références $attribs, $document, $options, Factory\getApplication(), et Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles().

◆ tooltip()

static tooltip | ( | $tooltip,
 |  | $title = '',
 |  | $image = 'tooltip.png',
 |  | $text = '',
 |  | $href = '',
 |  | $alt = 'Tooltip',
 |  | $class = 'hasTooltip'
 | ) |
static

Creates a tooltip with an image as button

Paramètres
string | $tooltip | The tip string.
mixed | $title | The title of the tooltip or an associative array with keys contained in {'title','image','text','href','alt'} and values corresponding to parameters of the same name.
string | $image | The image for the tip, if no text is provided.
string | $text | The text for the tip.
string | $href | A URL that will be used to create the link.
string | $alt | The alt attribute for img tag.
string | $class | CSS class for the tool tip.
Renvoie
string
Depuis
1.5

Références $alt, $class, $href, $image, $text, $title, $tooltip, ENT_COMPAT, image, et null.

◆ tooltipText()

static tooltipText | ( | $title = '',
 |  | $content = '',
 |  | $translate = true,
 |  | $escape = true
 | ) |
static

Converts a double colon separated string or 2 separate strings to a string ready for bootstrap tooltips

Paramètres
string | $title | The title of the tooltip (or combined '::' separated string).
string | $content | The content to tooltip.
boolean | $translate | If true will pass texts through Text.
boolean | $escape | If true will pass texts through htmlspecialchars.
Renvoie
string The tooltip string
Depuis
3.1.2

Références $content, $result, $title, Text\_(), et elseif.

◆ unregister()

static unregister ( $key )
static

Removes a key for a method from registry.

Paramètres
string $key The name of the key
Renvoie
boolean True if a set key is unset
Depuis
1.6
Obsolète:
5.0 Use the service registry instead

Références $key.

Documentation des champs

◆ $formatOptions

$formatOptions = array('format.depth' => 0, 'format.eol' => "\n", 'format.indent' => "\t")
static

Référencé par Select\genericlist(), Select\groupedlist(), Select\integerlist(), et Select\options().

◆ $includePaths

$includePaths = array()
staticprotected

◆ $registry

$registry = array()
staticprotected

◆ $serviceRegistry

$serviceRegistry
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HTMLHelper.php


Joomla CMS: Référence de la classe Registry

  • Joomla
  • CMS
  • HTML
  • Registry
Fonctions membres publiques | Attributs privés
Référence de la classe Registry

Fonctions membres publiques

getService (string $key)
hasService (string $key)
register (string $key, $handler, bool $replace=false)

Attributs privés

$serviceMap

Description détaillée

Service registry for JHtml services

Depuis
4.0.0

Documentation des fonctions membres

◆ getService()

getService ( string $key )

Get the service for a given key

Paramètres
string $key The service key to look up
Renvoie
string|object
Depuis
4.0.0

Références $key.

◆ hasService()

hasService ( string $key )

Check if the registry has a service for the given key

Paramètres
string $key The service key to look up
Renvoie
boolean
Depuis
4.0.0

Références $key.

◆ register()

register | ( | string | $key,
 |  |  | $handler,
 |  | bool | $replace = false
 | ) |  |

Register a service

Paramètres
string | $key | The service key to be registered
string | object | $handler | The handler for the service as either a PHP class name or class object
boolean | $replace | Flag indicating the service key may replace an existing definition
Renvoie
void
Depuis
4.0.0

Références $key.

Documentation des champs

◆ $serviceMap

$serviceMap
private
Valeur initiale :
= [
'access' => Helpers\Access::class
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/HTML/Registry.php


Joomla CMS: Référence de la classe CurlTransport

  • Joomla
  • CMS
  • Http
  • Transport
  • CurlTransport
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe CurlTransport
+ Graphe d'héritage de CurlTransport:
AbstractTransport TransportInterface TransportInterface TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getResponse ($content, $info)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Fonctions membres privées

redirectsAllowed ()

Membres hérités additionnels

- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using cURL.

Depuis
1.7.3

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | $content,
 |  | $info
 | ) |
protected

Method to get a response object from a server response.

Paramètres
string | $content | The complete server response, including headers as a string if the response has no errors.
array | $info | The cURL request information.
Renvoie
Response
Depuis
1.7.3
Exceptions
InvalidResponseCodeException

Références $content, $info, Symfony\Component\Console\Tester\$statusCode, et null.

◆ isSupported()

static isSupported ( )
static

Method to check if HTTP transport cURL is available for use

Renvoie
boolean true if available, else false
Depuis
3.0.0

Implémente TransportInterface.

◆ redirectsAllowed()

redirectsAllowed ( )
private

Check if redirects are allowed

Renvoie
boolean
Depuis
3.0.0

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.7.3
Exceptions

Implémente TransportInterface.

Références $app, $content, $data, $info, $key, $message, $method, $options, $this, $uri, $user, $value, Factory\getApplication(), et CaBundle\getBundledCaBundlePath().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CurlTransport.php


Joomla CMS: Référence de la classe SocketTransport

  • Joomla
  • CMS
  • Http
  • Transport
  • SocketTransport
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SocketTransport
+ Graphe d'héritage de SocketTransport:
AbstractTransport TransportInterface TransportInterface TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getResponse ($content)
connect (UriInterface $uri, $timeout=null)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Attributs protégés

$connections
- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using sockets directly.

Depuis
1.7.3

Documentation des fonctions membres

◆ connect()

connect | ( | UriInterface | $uri,
 |  |  | $timeout = null
 | ) |  |
protected

Method to connect to a server and get the resource.

Paramètres
UriInterface | $uri | The URI to connect with.
integer | $timeout | Read timeout in seconds.
Renvoie
resource Socket connection resource.
Depuis
1.7.3
Exceptions

Références $key, $uri, elseif, et null.

◆ getResponse()

getResponse ( $content )
protected

Method to get a response object from a server response.

Paramètres
string $content The complete server response, including headers.
Renvoie
Response
Depuis
1.7.3
Exceptions
InvalidResponseCodeException

Références $content, et Symfony\Component\Console\Tester\$statusCode.

◆ isSupported()

static isSupported ( )
static

Method to check if http transport socket available for use

Renvoie
boolean True if available else false
Depuis
3.0.0

Implémente TransportInterface.

Références Factory\getApplication().

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.7.3
Exceptions

Implémente TransportInterface.

Références $content, $data, $method, $path, $uri, $value, et null.

Documentation des champs

◆ $connections

$connections
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SocketTransport.php


Joomla CMS: Référence de la classe StreamTransport

  • Joomla
  • CMS
  • Http
  • Transport
  • StreamTransport
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées
Référence de la classe StreamTransport
+ Graphe d'héritage de StreamTransport:
AbstractTransport TransportInterface TransportInterface TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getResponse (array $headers, $body)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Membres hérités additionnels

- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using PHP streams.

Depuis
1.7.3

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | array | $headers,
 |  |  | $body
 | ) |  |
protected

Method to get a response object from a server response.

Paramètres
array | $headers | The response headers as an array.
string | $body | The response body as a string.
Renvoie
Response
Depuis
1.7.3
Exceptions
InvalidResponseCodeException

Références Symfony\Component\Console\Tester\$statusCode.

◆ isSupported()

static isSupported ( )
static

Method to check if http transport stream available for use

Renvoie
boolean true if available else false
Depuis
3.0.0

Implémente TransportInterface.

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.7.3
Exceptions

Implémente TransportInterface.

Références $app, $content, $context, $data, $key, $method, $options, Laminas\Diactoros\$stream, $uri, $user, $value, elseif, Factory\getApplication(), et CaBundle\getBundledCaBundlePath().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StreamTransport.php


Joomla CMS: Référence de la classe Http

  • Joomla
  • CMS
  • Http
  • Http
Fonctions membres publiques
Référence de la classe Http
+ Graphe d'héritage de Http:
Http ClientInterface

Fonctions membres publiques

__construct ($options=[], FrameworkTransportInterface $transport=null)
- Fonctions membres publiques hérités de Http
__construct ($options=[], TransportInterface $transport=null)
getOption ($key, $default=null)
setOption ($key, $value)
options ($url, array $headers=[], $timeout=null)
head ($url, array $headers=[], $timeout=null)
get ($url, array $headers=[], $timeout=null)
post ($url, $data, array $headers=[], $timeout=null)
put ($url, $data, array $headers=[], $timeout=null)
delete ($url, array $headers=[], $timeout=null, $data=null)
trace ($url, array $headers=[], $timeout=null)
patch ($url, $data, array $headers=[], $timeout=null)
sendRequest (RequestInterface $request)

Membres hérités additionnels

- Fonctions membres protégées hérités de Http
makeTransportRequest ($method, $url, $data=null, array $headers=[], $timeout=null)
- Attributs protégés hérités de Http
$options
$transport

Description détaillée

HTTP client class.

Depuis
1.7.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $options = [],
 |  | FrameworkTransportInterface | $transport = null
 | ) |  |

Constructor.

Paramètres
array | \ArrayAccess | $options | Client options array. If the registry contains any headers.* elements, these will be added to the request headers.
FrameworkTransportInterface | $transport | The HTTP transport object.
Depuis
1.7.3
Exceptions

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Http/Http.php


Joomla CMS: Référence de la classe HttpFactory

  • Joomla
  • CMS
  • Http
  • HttpFactory
Fonctions membres publiques statiques
Référence de la classe HttpFactory

Fonctions membres publiques statiques

static | getHttp ($options=[], $adapters=null)
static | getHttpTransports ()

Description détaillée

HTTP factory class.

Depuis
3.0.0

Documentation des fonctions membres

◆ getHttp()

static getHttp | ( | $options = [],
 |  | $adapters = null
 | ) |
static

Method to create a JHttp instance.

Paramètres
array | \ArrayAccess | $options | Client options array.
array | string | $adapters | Adapter (string) or queue of adapters (array) to use for communication.
Renvoie
Http
Depuis
3.0.0
Exceptions

Références $options, et $version.

Référencé par HttpBridgePostRequestMethod\__construct(), UpdateModel\download(), InstallerHelper\downloadPackage(), UpdateModel\downloadPackage(), FeedFactory\getFeed(), LanguagesModel\getLanguages(), UpdateAdapter\getUpdateSiteResponse(), Changelog\loadFromXml(), Update\loadFromXml(), ApplicationModel\save(), et Yubikey\validateYubikeyOtp().

◆ getHttpTransports()

getHttpTransports ( )
static

Get the http transport handlers

Renvoie
array An array of available transport handlers
Depuis
3.0.0

Get the HTTP transport handlers

Renvoie
string[] An array of available transport handler types
Depuis
1.0

$file

Références $key, $names, et __DIR__.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Http/HttpFactory.php


Joomla CMS: Référence de la classe Response

  • Joomla
  • CMS
  • Http
  • Response
Référence de la classe Response
+ Graphe d'héritage de Response:
Response Response ResponseInterface MessageInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de Response
__get ($name)
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)
- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

HTTP response data object class.

Depuis
1.7.3
Obsolète:
5.0 Use Joomla instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Http/Response.php


Joomla CMS: Référence de l'interface TransportInterface

  • Joomla
  • CMS
  • Http
  • TransportInterface
Référence de l'interface TransportInterface
+ Graphe d'héritage de TransportInterface:
TransportInterface CurlTransport SocketTransport StreamTransport

Membres hérités additionnels

- Fonctions membres publiques hérités de TransportInterface
request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques statiques hérités de TransportInterface
static isSupported ()

Description détaillée

HTTP transport class interface.

Depuis
1.7.3
Obsolète:
5.0 Implement Joomla instead
La documentation de cette interface a été générée à partir du fichier suivant :
  • src/Http/TransportInterface.php


Joomla CMS: Référence de la classe UnparsableImageException

  • Joomla
  • CMS
  • Image
  • Exception
  • UnparsableImageException
Référence de la classe UnparsableImageException
+ Graphe d'héritage de UnparsableImageException:

Description détaillée

Exception thrown when an image has no known properties.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnparsableImageException.php


Joomla CMS: Référence de la classe Backgroundfill

  • Joomla
  • CMS
  • Image
  • Filter
  • Backgroundfill
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Backgroundfill
+ Graphe d'héritage de Backgroundfill:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Fonctions membres protégées

sanitizeColor ($input)

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class fill background with color;

Depuis
3.4

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a background color to an image resource.

Paramètres
array $options An array of options for the filter. color Background matte color
Renvoie
void
Depuis
3.4
Exceptions

Références $color, $height, $options, $width, et null.

◆ sanitizeColor()

sanitizeColor ( $input )
protected

Method to sanitize color values and/or convert to an array

Paramètres
mixed $input Associative array of colors and alpha, or hex RGBA string when alpha FF is opaque. Defaults to black and opaque alpha.
Renvoie
array Associative array of red, green, blue and alpha
Depuis
3.4
Note
'#FF0000FF' returns an array with alpha of 0 (opaque)

Références $colors, $input, $value, et elseif.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Backgroundfill.php


Joomla CMS: Référence de la classe Brightness

  • Joomla
  • CMS
  • Image
  • Filter
  • Brightness
Fonctions membres publiques
Référence de la classe Brightness
+ Graphe d'héritage de Brightness:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class adjust the brightness of an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
Exceptions

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Brightness.php


Joomla CMS: Référence de la classe Contrast

  • Joomla
  • CMS
  • Image
  • Filter
  • Contrast
Fonctions membres publiques
Référence de la classe Contrast
+ Graphe d'héritage de Contrast:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class adjust the contrast of an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
Exceptions

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Contrast.php


Joomla CMS: Référence de la classe Edgedetect

  • Joomla
  • CMS
  • Image
  • Filter
  • Edgedetect
Fonctions membres publiques
Référence de la classe Edgedetect
+ Graphe d'héritage de Edgedetect:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class to add an edge detect effect to an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Edgedetect.php


Joomla CMS: Référence de la classe Emboss

  • Joomla
  • CMS
  • Image
  • Filter
  • Emboss
Fonctions membres publiques
Référence de la classe Emboss
+ Graphe d'héritage de Emboss:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class to emboss an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Emboss.php


Joomla CMS: Référence de la classe Grayscale

  • Joomla
  • CMS
  • Image
  • Filter
  • Grayscale
Fonctions membres publiques
Référence de la classe Grayscale
+ Graphe d'héritage de Grayscale:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class to transform an image to grayscale.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Grayscale.php


Joomla CMS: Référence de la classe Negate

  • Joomla
  • CMS
  • Image
  • Filter
  • Negate
Fonctions membres publiques
Référence de la classe Negate
+ Graphe d'héritage de Negate:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class to negate the colors of an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Negate.php


Joomla CMS: Référence de la classe Sketchy

  • Joomla
  • CMS
  • Image
  • Filter
  • Sketchy
Fonctions membres publiques
Référence de la classe Sketchy
+ Graphe d'héritage de Sketchy:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class to make an image appear "sketchy".

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Sketchy.php


Joomla CMS: Référence de la classe Smooth

  • Joomla
  • CMS
  • Image
  • Filter
  • Smooth
Fonctions membres publiques
Référence de la classe Smooth
+ Graphe d'héritage de Smooth:
ImageFilter

Fonctions membres publiques

execute (array $options=[])
- Fonctions membres publiques hérités de ImageFilter
__construct ($handle)
execute (array $options=[])

Membres hérités additionnels

- Attributs protégés hérités de ImageFilter
$handle

Description détaillée

Image Filter class adjust the smoothness of an image.

Depuis
2.5.0

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0
Exceptions

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Smooth.php


Joomla CMS: Référence de la classe Image

  • Joomla
  • CMS
  • Image
  • Image
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe Image

Fonctions membres publiques

__construct ($source=null)
getHandle ()
getOrientation ()
generateThumbs ($thumbSizes, $creationMethod=self::SCALE_INSIDE)
createThumbs ($thumbSizes, $creationMethod=self::SCALE_INSIDE, $thumbsFolder=null)
crop ($width, $height, $left=null, $top=null, $createNew=true)
filter ($type, array $options=[])
getHeight ()
getWidth ()
getPath ()
isLoaded ()
isTransparent ()
loadFile ($path)
resize ($width, $height, $createNew=true, $scaleMethod=self::SCALE_INSIDE)
cropResize ($width, $height, $createNew=true)
rotate ($angle, $background=-1, $createNew=true)
flip ($mode, $createNew=true)
watermark (Image $watermark, $transparency=50, $bottomMargin=0, $rightMargin=0)
toFile ($path, $type=IMAGETYPE_JPEG, array $options=[])
destroy ()
__destruct ()
setThumbnailGenerate ($quality=true)

Fonctions membres publiques statiques

static getImageFileProperties ($path)

Champs de données

const | SCALE_FILL = 1
const | SCALE_INSIDE = 2
const | SCALE_OUTSIDE = 3
const | CROP = 4
const | CROP_RESIZE = 5
const | SCALE_FIT = 6
const | ORIENTATION_LANDSCAPE = 'landscape'
const | ORIENTATION_PORTRAIT = 'portrait'
const | ORIENTATION_SQUARE = 'square'

Fonctions membres protégées

getFilterInstance ($type)
prepareDimensions ($width, $height, $scaleMethod)
sanitizeHeight ($height, $width)
sanitizeOffset ($offset)
sanitizeWidth ($width, $height)

Attributs protégés

$handle
$path = null
$generateBestQuality = true

Attributs protégés statiques

static $formats = []

Fonctions membres privées statiques

static getOrientationString (int $width, int $height)

Description détaillée

Class to manipulate an image.

Depuis
1.7.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $source = null )

Class constructor.

Paramètres
mixed $source Either a file path for a source image or a GD resource handler for an image.
Depuis
1.7.3
Exceptions

If the source input is a resource, set it as the image handle.

Références $info, et elseif.

◆ __destruct()

__destruct ( )

Method to call the destroy() method one last time to free any memory when the object is unset

Voir également
Image::destroy()
Depuis
2.5.0

Documentation des fonctions membres

◆ createThumbs()

createThumbs | ( | $thumbSizes,
 |  | $creationMethod = self::SCALE_INSIDE,
 |  | $thumbsFolder = null
 | ) |

Method to create thumbnails from the current image and save them to disk. It allows creation by resizing or cropping the original image.

Paramètres
mixed | $thumbSizes | string or array of strings. Example: $thumbSizes = array('150x75','250x150');
integer | $creationMethod | 1-3 resize $scaleMethod | 4 create cropping
string | $thumbsFolder | destination thumbs folder. null generates a thumbs folder in the image folder
Renvoie
array
Depuis
2.5.0
Exceptions

◆ crop()

crop | ( | $width,
 |  | $height,
 |  | $left = null,
 |  | $top = null,
 |  | $createNew = true
 | ) |

Method to crop the current image.

Paramètres
mixed | $width | The width of the image section to crop in pixels or a percentage.
mixed | $height | The height of the image section to crop in pixels or a percentage.
integer | $left | The number of pixels from the left to start cropping.
integer | $top | The number of pixels from the top to start cropping.
boolean | $createNew | If true the current image will be cloned, cropped and returned; else the current image will be cropped and returned.
Renvoie
Image
Depuis
2.5.0
Exceptions

Références $color, $height, $this, et $width.

◆ cropResize()

cropResize | ( | $width,
 |  | $height,
 |  | $createNew = true
 | ) |

Method to crop an image after resizing it to maintain proportions without having to do all the set up work.

Paramètres
integer | $width | The desired width of the image in pixels or a percentage.
integer | $height | The desired height of the image in pixels or a percentage.
boolean | $createNew | If true the current image will be cloned, resized, cropped and returned.
Renvoie
Image
Depuis
2.5.0

Références $height, $width, et null.

◆ destroy()

destroy ( )

Method to destroy an image handle and free the memory associated with the handle

Renvoie
boolean True on success, false on failure or if no image is loaded
Depuis
2.5.0

◆ filter()

filter | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Method to apply a filter to the image by type. Two examples are: grayscale and sketchy.

Paramètres
string | $type | The name of the image filter to apply.
array | $options | An array of options for the filter.
Renvoie
Image
Depuis
2.5.0
Voir également
Exceptions

Références $options, $this, et $type.

◆ flip()

flip | ( | $mode,
 |  | $createNew = true
 | ) |

Method to flip the current image.

Paramètres
integer | $mode | The flip mode for flipping the image http://php.net/imageflip#refsect1-function.imageflip-parameters
boolean | $createNew | If true the current image will be cloned, flipped and returned; else the current image will be flipped and returned.
Renvoie
Image
Depuis
3.4.2
Exceptions

Références $mode, et $this.

◆ generateThumbs()

generateThumbs | ( | $thumbSizes,
 |  | $creationMethod = self::SCALE_INSIDE
 | ) |

Method to generate thumbnails from the current image. It allows creation by resizing or cropping the original image.

Paramètres
mixed | $thumbSizes | String or array of strings. Example: $thumbSizes = array('150x75','250x150');
integer | $creationMethod | 1-3 resize $scaleMethod | 4 create cropping | 5 resize then crop
Renvoie
array
Depuis
2.5.0
Exceptions

Références $size, et null.

◆ getFilterInstance()

getFilterInstance ( $type )
protected

Method to get an image filter instance of a specified type.

Paramètres
string $type The image filter type to get.
Renvoie
ImageFilter
Depuis
2.5.0
Exceptions

Références $className, et $type.

◆ getHandle()

getHandle ( )

Get the image resource handle

Renvoie
resource
Depuis
3.8.0
Exceptions

Référencé par Image\watermark().

◆ getHeight()

getHeight ( )

Method to get the height of the image in pixels.

Renvoie
integer
Depuis
2.5.0
Exceptions

Référencé par Image\watermark().

◆ getImageFileProperties()

static getImageFileProperties ( $path )
static

Method to return a properties object for an image given a filesystem path.

The result object has values for image width, height, type, attributes, mime type, bits, and channels.

Paramètres
string $path The filesystem path to the image for which to get properties.
Renvoie
Depuis
2.5.0
Exceptions

Références $info, $path, et null.

Référencé par Checkfiles\checkImages(), et LocalAdapter\getPathInformation().

◆ getOrientation()

getOrientation ( )

Method to detect whether an image's orientation is landscape, portrait or square.

The orientation will be returned as a string.

Renvoie
mixed Orientation string or null.
Depuis
3.4.2

Références null.

◆ getOrientationString()

static getOrientationString | ( | int | $width,
 |  | int | $height
 | ) |  |
staticprivate

Compare width and height integers to determine image orientation.

Paramètres
integer | $width | The width value to use for calculation
integer | $height | The height value to use for calculation
Renvoie
string Orientation string
Depuis
3.4.2

Références $height, et $width.

◆ getPath()

getPath ( )

Method to return the path

Renvoie
string
Depuis
2.5.0

Références $path.

◆ getWidth()

getWidth ( )

Method to get the width of the image in pixels.

Renvoie
integer
Depuis
2.5.0
Exceptions

Référencé par Image\watermark().

◆ isLoaded()

isLoaded ( )

Method to determine whether or not an image has been loaded into the object.

Renvoie
boolean
Depuis
2.5.0

Make sure the resource handle is valid.

◆ isTransparent()

isTransparent ( )

Method to determine whether or not the image has transparency.

Renvoie
boolean
Depuis
2.5.0
Exceptions

◆ loadFile()

loadFile ( $path )

Method to load a file into the Image object as the resource.

Paramètres
string $path The filesystem path to load as an image.
Renvoie
void
Depuis
2.5.0
Exceptions

Check if handle has been created successfully

Références $path, $type, et path.

◆ prepareDimensions()

prepareDimensions | ( | $width,
 |  | $height,
 |  | $scaleMethod
 | ) |
protected

Method to get the new dimensions for a resized image.

Paramètres
integer | $width | The width of the resized image in pixels.
integer | $height | The height of the resized image in pixels.
integer | $scaleMethod | The method to use for scaling
Renvoie
Depuis
2.5.0
Exceptions

Références $height, et $width.

◆ resize()

resize | ( | $width,
 |  | $height,
 |  | $createNew = true,
 |  | $scaleMethod = self::SCALE_INSIDE
 | ) |

Method to resize the current image.

Paramètres
mixed | $width | The width of the resized image in pixels or a percentage.
mixed | $height | The height of the resized image in pixels or a percentage.
boolean | $createNew | If true the current image will be cloned, resized and returned; else the current image will be resized and returned.
integer | $scaleMethod | Which method to use for scaling
Renvoie
Image
Depuis
2.5.0
Exceptions

Références $color, $height, Joomla\Database\Query\$offset, $this, et $width.

◆ rotate()

rotate | ( | $angle,
 |  | $background = -1,
 |  | $createNew = true
 | ) |

Method to rotate the current image.

Paramètres
mixed | $angle | The angle of rotation for the image
integer | $background | The background color to use when areas are added due to rotation
boolean | $createNew | If true the current image will be cloned, rotated and returned; else the current image will be rotated and returned.
Renvoie
Image
Depuis
2.5.0
Exceptions

Références $this.

◆ sanitizeHeight()

sanitizeHeight | ( | $height,
 |  | $width
 | ) |
protected

Method to sanitize a height value.

Paramètres
mixed | $height | The input height value to sanitize.
mixed | $width | The input width value for reference.
Renvoie
integer
Depuis
2.5.0

Références $height, $width, et null.

◆ sanitizeOffset()

sanitizeOffset ( $offset )
protected

Method to sanitize an offset value like left or top.

Paramètres
mixed $offset An offset value.
Renvoie
integer
Depuis
2.5.0

Références Joomla\Database\Query\$offset.

◆ sanitizeWidth()

sanitizeWidth | ( | $width,
 |  | $height
 | ) |
protected

Method to sanitize a width value.

Paramètres
mixed | $width | The input width value to sanitize.
mixed | $height | The input height value for reference.
Renvoie
integer
Depuis
2.5.0

Références $height, $width, et null.

◆ setThumbnailGenerate()

setThumbnailGenerate ( $quality = true )

Method for set option of generate thumbnail method

Paramètres
boolean $quality True for best quality. False for best speed.
Renvoie
void
Depuis
3.7.0

◆ toFile()

toFile | ( |  | $path,
 |  |  | $type = IMAGETYPE_JPEG,
 |  | array | $options = []
 | ) |  |

Method to write the current image out to a file or output directly.

Paramètres
mixed | $path | The filesystem path to save the image. When null, the raw image stream will be outputted directly.
integer | $type | The image type to save the file as.
array | $options | The image type options to use in saving the file. For PNG and JPEG formats use quality key to set compression level (0..9 and 0..100)
Renvoie
boolean

2.5.0

Références $options, $path, et $type.

◆ watermark()

watermark | ( | Image | $watermark,
 |  |  | $transparency = 50,
 |  |  | $bottomMargin = 0,
 |  |  | $rightMargin = 0
 | ) |  |

Watermark the image

Paramètres
Image | $watermark | The Image object containing the watermark graphic
integer | $transparency | The transparency to use for the watermark graphic
integer | $bottomMargin | The margin from the bottom of this image
integer | $rightMargin | The margin from the right side of this image
Renvoie
Image
Depuis
3.8.0 https://secure.php.net/manual/en/image.examples-watermark.php

Références $this, Image\getHandle(), Image\getHeight(), et Image\getWidth().

Documentation des champs

◆ $formats

$formats = []
staticprotected

◆ $generateBestQuality

$generateBestQuality = true
protected

◆ $handle

$handle
protected

◆ $path

$path = null
protected

◆ CROP

const CROP = 4

integer

Depuis
2.5.0

◆ CROP_RESIZE

const CROP_RESIZE = 5

integer

Depuis
2.5.0

◆ ORIENTATION_LANDSCAPE

const ORIENTATION_LANDSCAPE = 'landscape'

string

Depuis
3.4.2

◆ ORIENTATION_PORTRAIT

const ORIENTATION_PORTRAIT = 'portrait'

string

Depuis
3.4.2

◆ ORIENTATION_SQUARE

const ORIENTATION_SQUARE = 'square'

string

Depuis
3.4.2

◆ SCALE_FILL

const SCALE_FILL = 1

integer

Depuis
2.5.0

Référencé par TemplateModel\resizeImage().

◆ SCALE_FIT

const SCALE_FIT = 6

integer

Depuis
2.5.0

◆ SCALE_INSIDE

const SCALE_INSIDE = 2

integer

Depuis
2.5.0

◆ SCALE_OUTSIDE

const SCALE_OUTSIDE = 3

integer

Depuis
2.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Image.php


Joomla CMS: Référence de la classe ImageFilter

  • Joomla
  • CMS
  • Image
  • ImageFilter
Fonctions membres publiques | Attributs protégés
Référence de la classe ImageFilter
+ Graphe d'héritage de ImageFilter:
Backgroundfill Brightness Contrast Edgedetect Emboss Grayscale Negate Sketchy Smooth

Fonctions membres publiques

__construct ($handle)
execute (array $options=[])

Attributs protégés

$handle

Description détaillée

Class to manipulate an image.

Depuis
1.7.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $handle )

Class constructor.

Paramètres
resource $handle The image resource on which to apply the filter.
Depuis
1.7.3
Exceptions

Make sure the file handle is valid.

Documentation des fonctions membres

◆ execute()

execute ( array $options = [] )
abstract

Method to apply a filter to an image resource.

Paramètres
array $options An array of options for the filter.
Renvoie
void
Depuis
2.5.0

Documentation des champs

◆ $handle

$handle
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ImageFilter.php


Joomla CMS: Référence de la classe Cli

  • Joomla
  • CMS
  • Input
  • Cli
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe Cli
+ Graphe d'héritage de Cli:
Input Input

Fonctions membres publiques

__construct (array $source=null, array $options=array())
serialize ()
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=array())
__get ($name)
getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Champs de données

$executable
$args = array()

Fonctions membres protégées

parseArguments ()
- Fonctions membres protégées hérités de Input
getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)

Membres hérités additionnels

- Attributs protégés hérités de Input
$inputs = array()
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input CLI Class

Depuis
1.7.0
Obsolète:
5.0 Use the joomla/console package instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $source = null,
 |  | array | $options = array()
 | ) |  |

Constructor.

Paramètres
array | $source | Source data (Optional, default is $_REQUEST)
array | $options | Array of configuration parameters (Optional)
Depuis
1.7.0
Obsolète:
5.0 Use the joomla/console package instead

Références $options, et InputFilter\getInstance().

Documentation des fonctions membres

◆ parseArguments()

parseArguments ( )
protected

Initialise the options and arguments

Not supported: -abc c-value

Renvoie
void
Depuis
1.7.0
Obsolète:
5.0 Use the joomla/console package instead

Références $argv, $i, $key, $value, et elseif.

◆ serialize()

serialize ( )

Method to serialize the input.

Renvoie
string The serialized input.
Depuis
3.0.0
Obsolète:
5.0 Use the joomla/console package instead

Références Symfony\Component\Console\Tester\$inputs.

◆ unserialize()

unserialize ( $input )

Method to unserialize the input.

Paramètres
string $input The serialized input.
Renvoie
Input The input object.
Depuis
3.0.0
Obsolète:
5.0 Use the joomla/console package instead

Références $input, et InputFilter\getInstance().

Documentation des champs

◆ $args

$args = array()

◆ $executable

$executable
La documentation de cette classe a été générée à partir du fichier suivant :
  • Cli.php


Joomla CMS: Référence de la classe Cookie

  • Joomla
  • CMS
  • Input
  • Cookie
Fonctions membres publiques
Référence de la classe Cookie
+ Graphe d'héritage de Cookie:
Input Input

Fonctions membres publiques

__construct (array $source=null, array $options=array())
set ($name, $value, $expire=0, $path='', $domain='', $secure=false, $httpOnly=false)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=array())
__get ($name)
getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Input
getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)
- Attributs protégés hérités de Input
$inputs = array()
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input Cookie Class

Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $source = null,
 |  | array | $options = array()
 | ) |  |

Constructor.

Paramètres
array | $source | Ignored.
array | $options | Array of configuration parameters (Optional)
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Références $options, et InputFilter\getInstance().

Documentation des fonctions membres

◆ set()

set | ( | $name,
 |  | $value,
 |  | $expire = 0,
 |  | $path = '',
 |  | $domain = '',
 |  | $secure = false,
 |  | $httpOnly = false
 | ) |

Sets a value

Paramètres
string | $name | Name of the value to set.
mixed | $value | Value to assign to the input.
integer | $expire | The time the cookie expires. This is a Unix timestamp so is in number of seconds since the epoch. In other words, you'll most likely set this with the time() function plus the number of seconds before you want it to expire. Or you might use mktime(). time()+60*60*24*30 will set the cookie to expire in 30 days. If set to 0, or omitted, the cookie will expire at the end of the session (when the browser closes).
string | $path | The path on the server in which the cookie will be available on. If set to '/', the cookie will be available within the entire domain. If set to '/foo/', the cookie will only be available within the /foo/ directory and all sub-directories such as /foo/bar/ of domain. The default value is the current directory that the cookie is being set in.
string | $domain | The domain that the cookie is available to. To make the cookie available on all subdomains of example.com (including example.com itself) then you'd set it to '.example.com'. Although some browsers will accept cookies without the initial ., RFC 2109 requires it to be included. Setting the domain to 'www.example.com' or '.www.example.com' will make the cookie only available in the www subdomain.
boolean | $secure | Indicates that the cookie should only be transmitted over a secure HTTPS connection from the client. When set to TRUE, the cookie will only be set if a secure connection exists. On the server-side, it's on the programmer to send this kind of cookie only on secure connection (e.g. with respect to $_SERVER["HTTPS"]).
boolean | $httpOnly | When TRUE the cookie will be made accessible only through the HTTP protocol. This means that the cookie won't be accessible by scripting languages, such as JavaScript. This setting can effectively help to reduce identity theft through XSS attacks (although it is not supported by all browsers).
Renvoie
void

setcookie() 1.7.0 deprecated 206.

Références $key, $name, $path, $val, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Input/Cookie.php


Joomla CMS: Référence de la classe Files

  • Joomla
  • CMS
  • Input
  • Files
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Files
+ Graphe d'héritage de Files:
Input Input

Fonctions membres publiques

__construct (array $source=null, array $options=array())
get ($name, $default=null, $filter='cmd')
set ($name, $value)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=array())
__get ($name)
getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Fonctions membres protégées

decodeData (array $data)
- Fonctions membres protégées hérités de Input
getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)

Attributs protégés

$decodedData = array()
- Attributs protégés hérités de Input
$inputs = array()
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input Files Class

Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $source = null,
 |  | array | $options = array()
 | ) |  |

The class constructor.

Paramètres
array | $source | The source argument is ignored. $_FILES is always used.
array | $options | An optional array of configuration options: filter : a custom InputFilter object.
Depuis
3.0.0
Obsolète:
5.0 Use Joomla instead

Références $options, et InputFilter\getInstance().

Documentation des fonctions membres

◆ decodeData()

decodeData ( array $data )
protected

Method to decode a data array.

Paramètres
array $data The data array to decode.
Renvoie
array
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Références $data, et $result.

◆ get()

get | ( | $name,
 |  | $default = null,
 |  | $filter = 'cmd'
 | ) |

Gets a value from the input data.

Paramètres
string | $name | The name of the input property (usually the name of the files INPUT tag) to get.
mixed | $default | The default value to return if the named property does not exist.
string | $filter | The filter to apply to the value.
Renvoie
mixed The filtered input value.
Voir également
InputFilter::clean()
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Références $default, $name, $results, et InputFilter\isSafeFile().

◆ set()

set | ( | $name,
 |  | $value
 | ) |

Sets a value.

Paramètres
string | $name | The name of the input property to set.
mixed | $value | The value to assign to the input property.
Renvoie
void
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Documentation des champs

◆ $decodedData

$decodedData = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Input/Files.php


Joomla CMS: Référence de la classe Input

  • Joomla
  • CMS
  • Input
  • Input
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés statiques
Référence de la classe Input
+ Graphe d'héritage de Input:
Input Cli Cookie Files Json

Fonctions membres publiques

__construct ($source=null, array $options=array())
__get ($name)
getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Fonctions membres protégées

getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)

Attributs protégés

$inputs = array()
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Attributs privés statiques

static $allowedGlobals = array('REQUEST', 'GET', 'POST', 'FILES', 'SERVER', 'ENV')

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $source = null,
 |  | array | $options = array()
 | ) |  |

Constructor.

Paramètres
array | $source | Source data (Optional, default is $_REQUEST)
array | $options | Array of configuration parameters (Optional)
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Références $options, Symfony\Contracts\Service\__construct(), et InputFilter\getInstance().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to get an input object

Paramètres
mixed $name Name of the input object to retrieve.
Renvoie
The request input object
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

Références $className, $name, et null.

◆ getArray()

getArray | ( | array | $vars = array(),
 |  |  | $datasource = null,
 |  |  | $defaultFilter = 'unknown'
 | ) |  |

Gets an array of values from the request.

Paramètres
array | $vars | Associative array of keys and filter types to apply. If empty and datasource is null, all the input data will be returned but filtered using the filter given by the parameter defaultFilter in InputFilter::clean.
mixed | $datasource | Array to retrieve data from, or null.
string | $defaultFilter | Default filter used in InputFilter::clean if vars is empty and datasource is null. If 'unknown', the default case is used in InputFilter::clean.
Renvoie
mixed The filtered input data.
Depuis
1.7.0
Obsolète:
5.0 Use Joomla instead

◆ getArrayRecursive()

getArrayRecursive | ( | array | $vars = array(),
 |  |  | $datasource = null,
 |  |  | $defaultFilter = 'unknown',
 |  |  | $recursion = false
 | ) |  |
protected

Gets an array of values from the request.

Paramètres
array | $vars | Associative array of keys and filter types to apply. If empty and datasource is null, all the input data will be returned but filtered using the filter given by the parameter defaultFilter in InputFilter::clean.
mixed | $datasource | Array to retrieve data from, or null.
string | $defaultFilter | Default filter used in InputFilter::clean if vars is empty and datasource is null. If 'unknown', the default case is used in InputFilter::clean.
bool | $recursion | Flag to indicate a recursive function call.
Renvoie
mixed The filtered input data.
Depuis
3.4.2
Obsolète:
5.0 Use Joomla instead

Références $data, $results, elseif, et null.

◆ unserialize()

unserialize ( $input )

Method to unserialize the input.

Paramètres
string $input The serialized input.
Renvoie
Input The input object.
Depuis
3.0.0
Obsolète:
5.0 Use Joomla instead

Références $input, et InputFilter\getInstance().

Documentation des champs

◆ $allowedGlobals

$allowedGlobals = array('REQUEST', 'GET', 'POST', 'FILES', 'SERVER', 'ENV')
staticprivate

◆ $inputs

$inputs = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Input/Input.php


Joomla CMS: Référence de la classe Json

  • Joomla
  • CMS
  • Input
  • Json
Fonctions membres publiques | Attributs privés
Référence de la classe Json
+ Graphe d'héritage de Json:
Input Input

Fonctions membres publiques

__construct (array $source=null, array $options=array())
getRaw ()
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=array())
__get ($name)
getArray (array $vars=array(), $datasource=null, $defaultFilter='unknown')
unserialize ($input)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Attributs privés

$_raw

Membres hérités additionnels

- Fonctions membres protégées hérités de Input
getArrayRecursive (array $vars=array(), $datasource=null, $defaultFilter='unknown', $recursion=false)
- Attributs protégés hérités de Input
$inputs = array()
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input JSON Class

This class decodes a JSON string from the raw request data and makes it available via the standard JInput interface.

Depuis
3.0.1
Obsolète:
5.0 Use Joomla instead

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $source = null,
 |  | array | $options = array()
 | ) |  |

Constructor.

Paramètres
array | $source | Source data (Optional, default is the raw HTTP input decoded from JSON)
array | $options | Array of configuration parameters (Optional)
Depuis
3.0.1
Obsolète:
5.0 Use Joomla instead

Références $options, et InputFilter\getInstance().

Documentation des fonctions membres

◆ getRaw()

getRaw ( )

Gets the raw JSON string from the request.

Renvoie
string The raw JSON string from the request.
Depuis
3.0.1
Obsolète:
5.0 Use Joomla instead

Documentation des champs

◆ $_raw

$_raw
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Input/Json.php


Joomla CMS: Référence de la classe InstallationApplication

  • Joomla
  • CMS
  • Installation
  • Application
  • InstallationApplication
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe InstallationApplication
+ Graphe d'héritage de InstallationApplication:
CMSApplication WebApplication ContainerAwareInterface CMSWebApplicationInterface AbstractWebApplication SessionAwareWebApplicationInterface CMSApplicationInterface AbstractApplication WebApplicationInterface WebApplicationInterface ExtensionManagerInterface ConfigurationAwareApplicationInterface EventAwareInterface ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ApplicationInterface ApplicationInterface DispatcherAwareInterface ApplicationInterface

Fonctions membres publiques

__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
afterSessionStart (SessionEvent $event)
debugLanguage ()
dispatch ()
execute ()
getLocalise ()
getLocaliseAdmin (DatabaseInterface $db=null)
getTemplate ($params=false)
loadDocument (Document $document=null)
render ()
setCfg (array $vars=array(), $namespace='config')
getMenu ($name=null, $options=array())
- Fonctions membres publiques hérités de CMSApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, Container $container=null)
checkSession ()
enqueueMessage ($msg, $type=self::MSG_INFO)
getCfg ($varname, $default=null)
getClientId ()
getMenu ($name=null, $options=array())
getMessageQueue ($clear=false)
getName ()
getPathway ()
getTemplate ($params=false)
getUserState ($key, $default=null)
getUserStateFromRequest ($key, $request, $default=null, $type='none')
isHttpsForced ($clientId=null)
isClient ($identifier)
login ($credentials, $options=array())
logout ($userid=null, $options=array())
redirect ($url, $status=303)
setUserState ($key, $value)
toString ($compress=false)
isCli ()
setMenuFactory (MenuFactoryInterface $menuFactory)
- Fonctions membres publiques hérités de WebApplication
__construct (Input $input=null, Registry $config=null, WebClient $client=null, ResponseInterface $response=null)
execute ()
getDocument ()
getLanguage ()
flushAssets ()
loadDocument (Document $document=null)
loadLanguage (Language $language=null)
loadSession (Session $session=null)
afterSessionStart (SessionEvent $event)
getConfig ()
- Fonctions membres publiques hérités de AbstractWebApplication
__construct (Input $input=null, Registry $config=null, Web\WebClient $client=null, ResponseInterface $response=null)
__get ($name)
execute ()
getInput ()
redirect ($url, $status=303)
allowCache ($allow=null)
setHeader ($name, $value, $replace=false)
getHeaders ()
clearHeaders ()
sendHeaders ()
setBody ($content)
prependBody ($content)
appendBody ($content)
getBody ()
getResponse ()
isValidHttpStatus ($code)
setResponse (ResponseInterface $response)
isSslConnection ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de CMSWebApplicationInterface
getDocument ()
- Fonctions membres publiques hérités de SessionAwareWebApplicationInterface
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)
- Fonctions membres publiques hérités de CMSApplicationInterface
getMessageQueue ()
getIdentity ()
getInput ()
getLanguage ()
loadIdentity (User $identity=null)
- Fonctions membres publiques hérités de ExtensionManagerInterface
bootComponent ($component)
bootModule ($module, $applicationName)
bootPlugin ($plugin, $type)
- Fonctions membres publiques hérités de EventAwareInterface
getDispatcher ()
triggerEvent ($eventName, $args=[])

Fonctions membres protégées

doExecute ()
fetchConfigurationData ($file='', $class='JConfig')
initialiseApp ($options=array())
- Fonctions membres protégées hérités de CMSApplication
checkUserRequireReset ($option, $view, $layout, $tasks)
initialiseApp ($options=array())
loadLibraryLanguage ()
render ()
route ()
isTwoFactorAuthenticationRequired ()
- Fonctions membres protégées hérités de WebApplication
render ()
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractWebApplication
compress ()
respond ()
getHttpStatusValue ($value)
checkConnectionAlive ()
checkHeadersSent ()
detectRequestUri ()
header ($string, $replace=true, $code=null)
isRedirectState ($state)
loadSystemUris ($requestUri=null)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Fonctions membres privées

executeController ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CMSApplication
static | getInstance ($name=null, $prefix='\JApplication', Container $container=null)
static | getRouter ($name=null, array $options=array())
- Fonctions membres publiques statiques hérités de WebApplication
static | getInstance ($name=null)
- Fonctions membres publiques statiques hérités de AbstractWebApplication
static | isAscii ($str)
- Champs de données hérités de CMSApplication
$scope = null
- Champs de données hérités de AbstractWebApplication
$charSet = 'utf-8'
$mimeType = 'text/html'
$httpVersion = '1.1'
$modifiedDate
$client
- Champs de données hérités de CMSApplicationInterface
const | MSG_EMERGENCY = 'emergency'
const | MSG_ALERT = 'alert'
const | MSG_CRITICAL = 'critical'
const | MSG_ERROR = 'error'
const | MSG_WARNING = 'warning'
const | MSG_NOTICE = 'notice'
const | MSG_INFO = 'info'
const | MSG_DEBUG = 'debug'
- Attributs protégés hérités de CMSApplication
$docOptions = array()
$clientId = null
$messageQueue = array()
$name = null
$profiler = null
$template = null
$pathway = null
$authenticationPluginType = 'authentication'
$menus = []
- Attributs protégés hérités de WebApplication
$document
$language
- Attributs protégés hérités de AbstractWebApplication
$input
$response
- Attributs protégés hérités de AbstractApplication
$config
- Attributs protégés statiques hérités de CMSApplication
static | $instances = array()
- Attributs protégés statiques hérités de WebApplication
static | $instance

Description détaillée

Joomla! Installation Application class.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input = null,
 |  | Registry | $config = null,
 |  | WebClient | $client = null,
 |  | Container | $container = null
 | ) |  |

Class constructor.

Paramètres
Input | null | $input | An optional argument to provide dependency injection for the application's input object. If the argument is a JInput object that object will become the application's input object, otherwise a default input object is created.
Registry | null | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
WebClient | null | $client | An optional argument to provide dependency injection for the application's client object. If the argument is a WebClient object that object will become the application's client object, otherwise a default client object is created.
Container | null | $container | Dependency injection container.
Depuis
3.1

Références $client, $config, Factory\$config, $container, $input, $parts, Symfony\Contracts\Service\__construct(), Uri\base(), JDEBUG, name, null, et Uri\root().

Documentation des fonctions membres

◆ afterSessionStart()

afterSessionStart ( SessionEvent $event )

After the session has been started we need to populate it with some default values.

Paramètres
SessionEvent $event Session event being triggered
Renvoie
void
Depuis
4.0.0

Références SessionEvent\getSession().

◆ debugLanguage()

debugLanguage ( )

Method to display errors in language parsing.

Renvoie
string Language debug output.
Depuis
3.1

Références $key, $lang, $output, $parts, Text\_(), et Factory\getLanguage().

◆ dispatch()

dispatch ( )

Dispatch the application.

Renvoie
void
Depuis
3.1

Références $document, Factory\$document, Text\_(), JPATH_ADMINISTRATOR, JPATH_BASE, et JPATH_SITE.

◆ doExecute()

doExecute ( )
protected

Method to run the Web application routines.

Renvoie
void
Depuis
3.1

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
4.0.0

Implémente ApplicationInterface.

◆ executeController()

executeController ( )
private

Executed a controller from the input task.

Renvoie
void
Depuis
4.0.0

Références $task, $this, class, et Joomla\DI\getContainer().

◆ fetchConfigurationData()

fetchConfigurationData | ( | $file = '',
 |  | $class = 'JConfig'
 | ) |
protected

Method to load a PHP configuration class file based on convention and return the instantiated data object. You will extend this method in child classes to provide configuration data from whatever data source is relevant for your specific application.

Paramètres
string | $file | The path and filename of the configuration file. If not provided, configuration.php in JPATH_BASE will be used.
string | $class | The class name to instantiate.
Renvoie
mixed Either an array or object to be loaded into the configuration object.
Depuis
1.7.3
Exceptions

◆ getLocalise()

getLocalise ( )

Returns the language code and help URL set in the localise.xml file. Used for forcing a particular language in localised releases.

Renvoie
mixed False on failure, array on success.
Depuis
3.1

Références $xml, et JPATH_INSTALLATION.

◆ getLocaliseAdmin()

getLocaliseAdmin ( DatabaseInterface $db = null )

Returns the installed language files in the administrative and frontend area.

Paramètres
DatabaseInterface | null $db Database driver.
Renvoie
array Array with installed language packs in admin and site area.
Depuis
3.1

Références $clientId, $db, $lang, $language, Folder\folders(), LanguageHelper\getLanguagePath(), JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getMenu()

getMenu | ( | $name = null,
 |  | $options = array()
 | ) |

Returns the application object.

Paramètres
string | null | $name | The name of the application/client.
array | $options | An optional associative array of configuration settings.
Renvoie
null
Depuis
3.2

Implémente CMSWebApplicationInterface.

Références null.

◆ getTemplate()

getTemplate ( $params = false )

Gets the name of the current template.

Paramètres
boolean $params True to return the template parameters
Renvoie
string| The name of the template.
Depuis
3.1

Références $params, et $template.

◆ initialiseApp()

initialiseApp ( $options = array() )
protected

Initialise the application.

Paramètres
array $options An optional associative array of configuration settings.
Renvoie
void
Depuis
3.1

Références $options, LanguageHelper\detectLanguage(), Joomla\Application\getSession(), et null.

◆ loadDocument()

loadDocument ( Document $document = null )

Allows the application to load a custom or default document.

The logic and options for creating this object are adequately generic for default cases but for many applications it will make sense to override this method and create a document, if required, based on more specific needs.

Paramètres
Document | null $document An optional document object. If omitted, the factory document is created.
Renvoie
InstallationApplication This method is chainable.
Depuis
3.2

Références $attributes, $date, $document, Factory\$document, $lang, $this, $type, class, Joomla\DI\getContainer(), Factory\getLanguage(), et null.

◆ render()

render ( )

Rendering is the process of pushing the document buffers into the template placeholders, retrieving data from the document and pushing it into the application response buffer.

Renvoie
void
Depuis
3.1

Références $data, $options, et JPATH_THEMES.

◆ setCfg()

setCfg | ( | array | $vars = array(),
 |  |  | $namespace = 'config'
 | ) |  |

Set configuration values.

Paramètres
array | $vars | Array of configuration values
string | $namespace | The namespace
Renvoie
void
Depuis
3.1

Références $namespace.

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallationApplication.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • CMS
  • Installation
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getView ($name='', $type='', $prefix='', $config=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Display controller class for the Joomla Installer.

Depuis
3.1

Documentation des fonctions membres

◆ getView()

getView | ( | $name = '',
 |  | $type = '',
 |  | $prefix = '',
 |  | $config = array()
 | ) |

Method to get a reference to the current view and load it if necessary.

Paramètres
string | $name | The view name. Optional, defaults to the controller name.
string | $type | The view type. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for view. Optional.
Renvoie
AbstractView Reference to the view or an error.
Depuis
3.0
Exceptions

Références $config, $name, $prefix, $type, et $view.

La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe InstallationController

  • Joomla
  • CMS
  • Installation
  • Controller
  • InstallationController
Fonctions membres publiques
Référence de la classe InstallationController
+ Graphe d'héritage de InstallationController:
JSONController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[], MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de JSONController
checkValidToken ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de JSONController
sendJsonResponse ($response)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Default controller class for the Joomla Installer.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object.
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallationController.php


Joomla CMS: Référence de la classe JSONController

  • Joomla
  • CMS
  • Installation
  • Controller
  • JSONController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe JSONController
+ Graphe d'héritage de JSONController:
BaseController ControllerInterface DispatcherAwareInterface InstallationController LanguageController

Fonctions membres publiques

checkValidToken ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

sendJsonResponse ($response)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Default JSON controller class for the Joomla Installer controllers.

Depuis
4.0.0

Documentation des fonctions membres

◆ checkValidToken()

checkValidToken ( )

Checks for a form token, if it is invalid a JSON response with the error code 403 is sent.

Renvoie
void
Depuis
4.0.0
Voir également
Session::checkToken()

Références Text\_(), et Session\checkToken().

◆ sendJsonResponse()

sendJsonResponse ( $response )
protected

Method to send a JSON response. The data parameter can be an Exception object for when an error has occurred or a JsonResponse for a good response.

Paramètres
mixed $response JsonResponse on success, Exception on failure.
Renvoie
void
Depuis
4.0.0

Références Text\_(), Session\getFormToken(), et Factory\getLanguage().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JSONController.php


Joomla CMS: Référence de la classe LanguageController

  • Joomla
  • CMS
  • Installation
  • Controller
  • LanguageController
Référence de la classe LanguageController
+ Graphe d'héritage de LanguageController:
JSONController BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de JSONController
checkValidToken ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de JSONController
sendJsonResponse ($response)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Language controller class for the Joomla Installer.

Depuis
3.1
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Controller/LanguageController.php


Joomla CMS: Référence de la classe JsonRenderer

  • Joomla
  • CMS
  • Installation
  • Error
  • Renderer
  • JsonRenderer
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonRenderer
+ Graphe d'héritage de JsonRenderer:
AbstractRenderer RendererInterface

Fonctions membres publiques

render (\Throwable $error)
- Fonctions membres publiques hérités de AbstractRenderer
getDocument ()

Attributs protégés

$type = 'json'
- Attributs protégés hérités de AbstractRenderer
$document
$type

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractRenderer
static getRenderer (string $type)
- Fonctions membres protégées hérités de AbstractRenderer
loadDocument ()

Description détaillée

JSON error page renderer for the installation application

Depuis
4.0.0

Documentation des fonctions membres

◆ render()

render ( \Throwable $error )

Render the error page for the given object

Paramètres
\Throwable $error The error object to be rendered
Renvoie
string
Depuis
4.0.0

Implémente RendererInterface.

Documentation des champs

◆ $type

$type = 'json'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Error/Renderer/JsonRenderer.php


Joomla CMS: Référence de la classe LanguageField

  • Joomla
  • CMS
  • Installation
  • Form
  • Field
  • Installation
  • LanguageField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe LanguageField
+ Graphe d'héritage de LanguageField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
_sortLanguages ($a, $b)
getNativeLanguage ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Language'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Installation Language field.

Depuis
1.6

Documentation des fonctions membres

◆ _sortLanguages()

_sortLanguages | ( | $a,
 |  | $b
 | ) |
protected

Method to sort languages by name.

Paramètres
array | $a | The first value to determine sort
array | $b | The second value to determine sort
Renvoie
integer
Depuis
3.1

Références $b.

◆ getNativeLanguage()

getNativeLanguage ( )
protected

Determinate the native language to select

Renvoie
string The native language to use
Depuis
4.2.0

Références $app, $model, $options, LanguageHelper\detectLanguage(), et Factory\getApplication().

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références $option, $options, $this, LanguageHelper\createLanguageList(), et Factory\getLanguage().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.2.0

Références $value.

Documentation des champs

◆ $type

$type = 'Language'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Form/Field/Installation/LanguageField.php


Joomla CMS: Référence de la classe PrefixField

  • Joomla
  • CMS
  • Installation
  • Form
  • Field
  • Installation
  • PrefixField
Fonctions membres protégées | Attributs protégés
Référence de la classe PrefixField
+ Graphe d'héritage de PrefixField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Prefix'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Database Prefix field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $class, $disabled, $i, $onchange, $prefix, $readonly, $size, ENT_COMPAT, Factory\getSession(), et name.

Documentation des champs

◆ $type

$type = 'Prefix'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrefixField.php


Joomla CMS: Référence de la classe PrefixRule

  • Joomla
  • CMS
  • Installation
  • Form
  • Rule
  • PrefixRule
Attributs protégés
Référence de la classe PrefixRule
+ Graphe d'héritage de PrefixRule:
FormRule

Attributs protégés

$regex = '^[a-z][a-z0-9]*_$'
$modifiers = 'i'
- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Description détaillée

Form Rule class for the prefix DB.

Depuis
1.7

Documentation des champs

◆ $modifiers

$modifiers = 'i'
protected

◆ $regex

$regex = '^[a-z][a-z0-9]*_$'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrefixRule.php


Joomla CMS: Référence de la classe UsernameRule

  • Joomla
  • CMS
  • Installation
  • Form
  • Rule
  • UsernameRule
Fonctions membres publiques
Référence de la classe UsernameRule
+ Graphe d'héritage de UsernameRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

Form Rule class for the username.

Depuis
3.9.4

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test a username

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | null | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | null | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | null | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.

Références $value, et InputFilter\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Form/Rule/UsernameRule.php


Joomla CMS: Référence de la classe DatabaseHelper

  • Joomla
  • CMS
  • Installation
  • Helper
  • DatabaseHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe DatabaseHelper

Fonctions membres publiques statiques

static | getDbo ($driver, $host, $user, $password, $database, $prefix, $select=true, array $ssl=[])
static | getEncryptionSettings ($options)
static | getMinimumServerVersion ($db, $options)
static | validateConnectionParameters ($options)
static | checkRemoteDbHost ($options)
static | checkDbServerParameters ($db, $options)

Attributs protégés statiques

static | $dbMinimumMariaDb = '10.1'
static | $dbMinimumMySql = '5.6'
static | $dbMinimumPostgreSql = '11.0'

Description détaillée

Joomla Installation Database Helper Class.

Depuis
1.6

Documentation des fonctions membres

◆ checkDbServerParameters()

static checkDbServerParameters | ( | $db,
 |  | $options
 | ) |
static

Check database server parameters after connection

Paramètres
DatabaseDriver | $db | Database object
\stdClass | $options | The session options
Renvoie
string|boolean A string with the translated error message if some server parameter is not ok, otherwise false.
Depuis
4.0.0

Références $db, $options, Text\_(), et Text\sprintf().

Référencé par DatabaseModel\createDatabase(), et SetupModel\validateDbConnection().

◆ checkRemoteDbHost()

static checkRemoteDbHost ( $options )
static

Security check for remote db hosts

Paramètres
\stdClass $options The session options
Renvoie
boolean True if passed, otherwise false.
Depuis
4.0.0

Références $options, Text\_(), File\exists(), UserHelper\genRandomPassword(), Factory\getApplication(), Factory\getSession(), JPATH_INSTALLATION, Text\sprintf(), et File\write().

Référencé par DatabaseModel\initialise(), et SetupModel\validateDbConnection().

◆ getDbo()

static getDbo | ( |  | $driver,
 |  |  | $host,
 |  |  | $user,
 |  |  | $password,
 |  |  | $database,
 |  |  | $prefix,
 |  |  | $select = true,
 |  | array | $ssl = []
 | ) |  |
static

Method to get a database driver.

Paramètres
string | $driver | The database driver to use.
string | $host | The hostname to connect on.
string | $user | The user name to connect with.
string | $password | The password to use for connection authentication.
string | $database | The database to use.
string | $prefix | The table prefix to use.
boolean | $select | True if the database should be selected.
array | $ssl | Database TLS connection options.
Renvoie
DatabaseInterface
Depuis
1.6

Références $db, $options, $password, $prefix, $user, $value, et DatabaseDriver\getInstance().

Référencé par DatabaseModel\initialise(), ConfigurationModel\setup(), et SetupModel\validateDbConnection().

◆ getEncryptionSettings()

static getEncryptionSettings ( $options )
static

Convert encryption options to array.

Paramètres
\stdClass $options The session options
Renvoie
array The encryption settings
Depuis
4.0.0

Références $options.

Référencé par DatabaseModel\createDatabase(), DatabaseModel\initialise(), ConfigurationModel\setup(), et SetupModel\validateDbConnection().

◆ getMinimumServerVersion()

static getMinimumServerVersion | ( | $db,
 |  | $options
 | ) |
static

Get the minimum required database server version.

Paramètres
DatabaseDriver | $db | Database object
\stdClass | $options | The session options
Renvoie
string The minimum required database server version.
Depuis
4.0.0

Références $db, et $options.

◆ validateConnectionParameters()

static validateConnectionParameters ( $options )
static

Validate and clean up database connection parameters.

Paramètres
\stdClass $options The session options
Renvoie
string|boolean A string with the translated error message if validation error, otherwise false.
Depuis
4.0.0

Références $options, Text\_(), Path\clean(), File\exists(), ArrayHelper\fromObject(), Factory\getSession(), et Text\sprintf().

Référencé par DatabaseModel\initialise(), et SetupModel\validateDbConnection().

Documentation des champs

◆ $dbMinimumMariaDb

$dbMinimumMariaDb = '10.1'
staticprotected

◆ $dbMinimumMySql

$dbMinimumMySql = '5.6'
staticprotected

◆ $dbMinimumPostgreSql

$dbMinimumPostgreSql = '11.0'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseHelper.php


Joomla CMS: Référence de la classe BaseInstallationModel

  • Joomla
  • CMS
  • Installation
  • Model
  • BaseInstallationModel
Fonctions membres publiques
Référence de la classe BaseInstallationModel
+ Graphe d'héritage de BaseInstallationModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ChecksModel CleanupModel ConfigurationModel DatabaseModel LanguagesModel SetupModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Base Model for the installation model classes

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | null | $factory | The factory.
Depuis
3.0
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseInstallationModel.php


Joomla CMS: Référence de la classe ChecksModel

  • Joomla
  • CMS
  • Installation
  • Model
  • ChecksModel
Fonctions membres publiques
Référence de la classe ChecksModel
+ Graphe d'héritage de ChecksModel:
BaseInstallationModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getIniParserAvailability ()
getPhpOptions ()
getPhpOptionsSufficient ()
getPhpSettings ()
getOptions ()
getForm ($view=null)
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Checks model for the Joomla Core Installer.

Depuis
4.0.0

Documentation des fonctions membres

◆ getForm()

getForm ( $view = null )

Method to get the form.

Paramètres
string | null $view The view being processed.
Renvoie
Form|boolean Form object on success, false on failure.
Depuis
3.1

Références $data, $form, $view, Form\addFormPath(), Factory\getApplication(), et Form\getInstance().

◆ getIniParserAvailability()

getIniParserAvailability ( )

Checks the availability of the parse_ini_file and parse_ini_string functions.

Renvoie
boolean True if the method exists.
Depuis
3.1

Références $i, et $result.

◆ getOptions()

getOptions ( )

Get the current setup options from the session.

Renvoie
array An array of options from the session.
Depuis
3.1

Références Factory\getSession().

◆ getPhpOptions()

getPhpOptions ( )

Gets PHP options.

Renvoie
array Array of PHP config options
Depuis
3.1

Références $option, $options, Text\_(), JPATH_CONFIGURATION, JPATH_ROOT, null, et Text\sprintf().

◆ getPhpOptionsSufficient()

getPhpOptionsSufficient ( )

Checks if all of the mandatory PHP options are met.

Renvoie
boolean True on success.
Depuis
3.1

Références $option, $options, $result, et false.

◆ getPhpSettings()

getPhpSettings ( )

Gets PHP Settings.

Renvoie
array
Depuis
3.1

Références $settings, Text\_(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ChecksModel.php


Joomla CMS: Référence de la classe CleanupModel

  • Joomla
  • CMS
  • Installation
  • Model
  • CleanupModel
Fonctions membres publiques
Référence de la classe CleanupModel
+ Graphe d'héritage de CleanupModel:
BaseInstallationModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

deleteInstallationFolder ()
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Cleanup model for the Joomla Core Installer.

Depuis
4.0.0

Documentation des fonctions membres

◆ deleteInstallationFolder()

deleteInstallationFolder ( )

Deletes the installation folder. Returns true on success.

Renvoie
boolean
Depuis
4.0.0

Références $return, File\delete(), Folder\delete(), JPATH_INSTALLATION, JPATH_ROOT, et File\move().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CleanupModel.php


Joomla CMS: Référence de la classe ConfigurationModel

  • Joomla
  • CMS
  • Installation
  • Model
  • ConfigurationModel
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe ConfigurationModel
+ Graphe d'héritage de ConfigurationModel:
BaseInstallationModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

setup ($options)
checkTestingSampledata ($db)
createConfiguration ($options)
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres publiques statiques

static | getUserId ()
static | resetRandUserId ()
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')

Fonctions membres protégées

updateUserIds ($db)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres protégées statiques

static generateRandUserId ()

Attributs protégés statiques

static | $userId = 0
- Attributs protégés statiques hérités de BaseModel
static | $paths

Fonctions membres privées

createRootUser ($options, $db)
deleteConfiguration ()

Membres hérités additionnels

- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Configuration setup model for the Joomla Core Installer.

Depuis
3.1

Documentation des fonctions membres

◆ checkTestingSampledata()

checkTestingSampledata ( $db )

Method to check for the testing sampledata plugin.

Paramètres
DatabaseDriver $db Database connector object $db*.
Renvoie
void
Depuis
4.0.0

Références $db, $version, Factory\getApplication(), JPATH_PLUGINS, null, et Text\sprintf().

◆ createConfiguration()

createConfiguration ( $options )

Method to create the configuration file

Paramètres
\stdClass $options The session options
Renvoie
boolean True on success
Depuis
3.1

Références $buffer, $options, $path, Text\_(), UserHelper\genRandomPassword(), Factory\getSession(), JPATH_ADMINISTRATOR, JPATH_CONFIGURATION, JPATH_ROOT, et null.

◆ createRootUser()

createRootUser | ( | $options,
 |  | $db
 | ) |
private

Method to create the root user for the site.

Paramètres
object | $options | The session options.
DatabaseDriver | $db | Database connector object $db*.
Renvoie
boolean True on success.
Depuis
3.1

Références $columns, $db, $options, $query, $result, $userId, Factory\getApplication(), et UserHelper\hashPassword().

◆ deleteConfiguration()

deleteConfiguration ( )
private

Method to erase the configuration file.

Renvoie
void
Depuis
4.0.0

Références $path, File\delete(), et JPATH_CONFIGURATION.

◆ generateRandUserId()

static generateRandUserId ( )
staticprotected

Generates the user ID.

Renvoie
integer The user ID.
Depuis
3.1

Références Factory\getSession().

◆ getUserId()

static getUserId ( )
static

Retrieves the default user ID and sets it if necessary.

Renvoie
integer The user ID.
Depuis
3.1

Références $userId.

◆ resetRandUserId()

static resetRandUserId ( )
static

Resets the user ID.

Renvoie
void
Depuis
3.1

Références $userId, et Factory\getSession().

◆ setup()

setup ( $options )

Method to setup the configuration file

Paramètres
array $options The session options
Renvoie
boolean True on success
Depuis
3.1

Références Factory\$database, $db, $extension, $languages, $options, $params, $query, $return, $version, Text\_(), Folder\files(), Factory\getApplication(), DatabaseHelper\getDbo(), DatabaseHelper\getEncryptionSettings(), Installer\getInstance(), JPATH_ADMINISTRATOR, Text\sprintf(), File\stripExt(), et ArrayHelper\toObject().

◆ updateUserIds()

updateUserIds ( $db )
protected

Method to update the user id of sql data content to the new rand user id.

Paramètres
DatabaseDriver $db Database connector object $db*.
Renvoie
void
Depuis
3.6.1

Références $db, $field, $fields, $query, $userId, et Factory\getApplication().

Documentation des champs

◆ $userId

$userId = 0
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigurationModel.php


Joomla CMS: Référence de la classe DatabaseModel

  • Joomla
  • CMS
  • Installation
  • Model
  • DatabaseModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe DatabaseModel
+ Graphe d'héritage de DatabaseModel:
BaseInstallationModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getOptions ()
initialise ($select=true)
createDatabase ()
handleOldDatabase ()
createTables ($schema)
backupDatabase ($db, $prefix)
createDb ($db, $options, $utf)
populateDatabase ($db, $schema)
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

splitQueries ($query)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Database configuration model for the Joomla Core Installer.

Depuis
3.1

Documentation des fonctions membres

◆ backupDatabase()

backupDatabase | ( | $db,
 |  | $prefix
 | ) |

Method to backup all tables in a database with a given prefix.

Paramètres
DatabaseDriver | $db | JDatabaseDriver object.
string | $prefix | Database table prefix.
Renvoie
boolean True on success.
Depuis
3.1

Références $db, $prefix, $return, Factory\getApplication(), et Text\sprintf().

◆ createDatabase()

createDatabase ( )

Method to create a new database.

Renvoie
boolean
Depuis
3.1
Exceptions

Références $db, $i, $option, $options, $type, Text\_(), DatabaseHelper\checkDbServerParameters(), DatabaseHelper\getEncryptionSettings(), DatabaseDriver\getInstance(), Factory\getSession(), et Text\sprintf().

◆ createDb()

createDb | ( | $db,
 |  | $options,
 |  | $utf
 | ) |

Method to create a new database.

Paramètres
DatabaseDriver | $db | Database object.
CMSObject | $options | CMSObject coming from "initialise" function to pass user and database name to database driver.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
boolean True on success.
Depuis
3.1

Références $db, et $options.

◆ createTables()

createTables ( $schema )

Method to create the database tables.

Paramètres
string $schema The SQL schema file to apply.
Renvoie
boolean True on success.
Depuis
3.1

Références $db, Text\_(), Factory\getApplication(), et Text\sprintf().

◆ getOptions()

getOptions ( )

Get the current setup options from the session.

Renvoie
array An array of options from the session.
Depuis
4.0.0

Références Factory\getSession().

◆ handleOldDatabase()

handleOldDatabase ( )

Method to process the old database.

Renvoie
boolean True on success.
Depuis
3.1

Références $db, $options, et ArrayHelper\toObject().

◆ initialise()

initialise ( $select = true )

Method to initialise the database.

Paramètres
boolean $select Select the database when creating the connections.
Renvoie
DatabaseInterface|boolean Database object on success, boolean false on failure
Depuis
3.1

Références $lang, $options, DatabaseHelper\checkRemoteDbHost(), LanguageHelper\exists(), Factory\getApplication(), DatabaseHelper\getDbo(), DatabaseHelper\getEncryptionSettings(), Factory\getLanguage(), JPATH_ADMINISTRATOR, Text\sprintf(), ArrayHelper\toObject(), et DatabaseHelper\validateConnectionParameters().

◆ populateDatabase()

populateDatabase | ( | $db,
 |  | $schema
 | ) |

Method to import a database schema from a file.

Paramètres
\Joomla\Database\DatabaseInterface | $db | JDatabase object.
string | $schema | Path to the schema file.
Renvoie
boolean True on success.
Depuis
3.1

Références $buffer, $db, $query, $return, Text\_(), et Factory\getApplication().

◆ splitQueries()

splitQueries ( $query )
protected

Method to split up queries from a schema file into an array.

Paramètres
string $query SQL schema.
Renvoie
array Queries to perform.
Depuis
3.1

Références $buffer, $i, $query, et elseif.

La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Model/DatabaseModel.php


Joomla CMS: Référence de la classe LanguagesModel

  • Joomla
  • CMS
  • Installation
  • Model
  • LanguagesModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe LanguagesModel
+ Graphe d'héritage de LanguagesModel:
BaseInstallationModel DatabaseAwareInterface BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ()
getItems ()
install ($lids)
getInstalledlangsAdministrator ()
getInstalledlangsFrontend ()
setDefault ($language, $clientName='administrator')
getOptions ()
getForm ($view=null)
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getLanguageManifest ($uid)
getPackageUrl ($remoteManifest)
downloadPackage ($url)
getInstalledlangs ($clientName='administrator')
getLanguageList ($clientId=1)
compareLanguages ($lang1, $lang2)
getPath ()
getClient ($client='administrator')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$client
$data
$path
$langlist
$adminId
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Language Installer model for the Joomla Core Installer.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor: Deletes the default installation config file and recreates it with the good config file.

Depuis
3.1

Références Symfony\Contracts\Service\__construct(), Factory\getApplication(), et JPATH_BASE.

Documentation des fonctions membres

◆ compareLanguages()

compareLanguages | ( | $lang1,
 |  | $lang2
 | ) |
protected

Compare two languages in order to sort them.

Paramètres
object | $lang1 | The first language.
object | $lang2 | The second language.
Renvoie
integer
Depuis
3.1

◆ downloadPackage()

downloadPackage ( $url )
protected

Download a language package from a URL and unpack it in the tmp folder.

Paramètres
string $url URL of the package.
Renvoie
array|boolean Package details or false on failure.
Depuis
3.1

Références $app, $url, Text\_(), InstallerHelper\downloadPackage(), Factory\getApplication(), et InstallerHelper\unpack().

◆ getClient()

getClient ( $client = 'administrator' )
protected

Get the client object of Administrator or Frontend.

Paramètres
string $client Name of the client object.
Renvoie
object
Depuis
3.1

Références $client, et ApplicationHelper\getClientInfo().

◆ getForm()

getForm ( $view = null )

Get the model form.

Paramètres
string | null $view The view being processed.
Renvoie
mixed JForm object on success, false on failure.
Depuis
3.1

Références $data, $form, $view, Form\addFieldPath(), Form\addFormPath(), Form\addRulePath(), Factory\getApplication(), et Form\getInstance().

◆ getInstalledlangs()

getInstalledlangs ( $clientName = 'administrator' )
protected

Get Languages item data.

Paramètres
string $clientName Name of the cms client.
Renvoie
array
Depuis
3.1

Références $client, $data, $info, $key, $lang, $params, $path, $this, $value, ComponentHelper\getParams(), null, et Installer\parseXMLInstallFile().

◆ getInstalledlangsAdministrator()

getInstalledlangsAdministrator ( )

Get Languages item data for the Administrator.

Renvoie
array
Depuis
3.1

◆ getInstalledlangsFrontend()

getInstalledlangsFrontend ( )

Get Languages item data for the Frontend.

Renvoie
array List of installed languages in the frontend application.
Depuis
3.1

◆ getItems()

getItems ( )

Generate a list of language choices to install in the Joomla CMS.

Renvoie
array
Depuis
3.1

Références $db, $list, $query, Joomla\Database\getDatabase(), et Updater\getInstance().

◆ getLanguageList()

getLanguageList ( $clientId = 1 )
protected

Get installed languages data.

Paramètres
integer $clientId The client ID to retrieve data for.
Renvoie
object The language data.
Depuis
3.1

Références $clientId, $db, $query, et Joomla\Database\getDatabase().

◆ getLanguageManifest()

getLanguageManifest ( $uid )
protected

Gets the manifest file of a selected language from a the language list in an update server.

Paramètres
integer $uid The id of the language in the #__updates table.
Renvoie
string
Depuis
3.1

Références Table\getInstance().

◆ getOptions()

getOptions ( )

Get the current setup options from the session.

Renvoie
array
Depuis
3.1

Références Factory\getSession().

◆ getPackageUrl()

getPackageUrl ( $remoteManifest )
protected

Finds the URL of the package to download.

Paramètres
string $remoteManifest URL to the manifest XML file of the remote package.
Renvoie
string|boolean
Depuis
3.1

◆ getPath()

getPath ( )
protected

Get the languages folder path.

Renvoie
string The path to the languages folders.
Depuis
3.1

Références $client, $path, LanguageHelper\getLanguagePath(), null, et path.

◆ install()

install ( $lids )

Method that installs in Joomla! the selected languages in the Languages View of the installer.

Paramètres
array $lids List of the update_id value of the languages to install.
Renvoie
boolean True if successful

Références $app, $id, $language, $message, Text\_(), InstallerHelper\cleanupInstall(), Factory\getApplication(), Joomla\Database\getDatabase(), Table\getInstance(), et Text\sprintf().

◆ setDefault()

setDefault | ( | $language,
 |  | $clientName = 'administrator'
 | ) |

Set the default language.

Paramètres
string | $language | The language to be set as default.
string | $clientName | The name of the CMS client.
Renvoie
boolean
Depuis
3.1

Références $client, $id, $language, $params, Factory\getApplication(), Table\getInstance(), et ComponentHelper\getParams().

Documentation des champs

◆ $adminId

$adminId
protected

◆ $client

$client
protected

◆ $data

$data
protected

◆ $langlist

$langlist
protected

◆ $path

$path
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Model/LanguagesModel.php


Joomla CMS: Référence de la classe SetupModel

  • Joomla
  • CMS
  • Installation
  • Model
  • SetupModel
Fonctions membres publiques
Référence de la classe SetupModel
+ Graphe d'héritage de SetupModel:
BaseInstallationModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getOptions ()
storeOptions ($options)
getForm ($view=null)
checkForm ($page='setup')
getLanguages ()
validate ($data, $view=null)
validateDbConnection ()
- Fonctions membres publiques hérités de BaseInstallationModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Setup model for the Joomla Core Installer.

Depuis
3.1

Documentation des fonctions membres

◆ checkForm()

checkForm ( $page = 'setup' )

Method to check the form data.

Paramètres
string $page The view being checked.
Renvoie
array|boolean Array with the validated form data or boolean false on a validation failure.
Depuis
3.1

Références $data, $form, $return, et Factory\getApplication().

◆ getForm()

getForm ( $view = null )

Method to get the form.

Paramètres
string | null $view The view being processed.
Renvoie
Form|boolean JForm object on success, false on failure.
Depuis
3.1

Références $data, $form, $view, Form\addFormPath(), Factory\getApplication(), et Form\getInstance().

◆ getLanguages()

getLanguages ( )

Generate a panel of language choices for the user to select their language.

Renvoie
array
Depuis
3.1

Références $list, LanguageHelper\createLanguageList(), LanguageHelper\detectLanguage(), et Factory\getApplication().

◆ getOptions()

getOptions ( )

Get the current setup options from the session.

Renvoie
array An array of options from the session.
Depuis
3.1

Références Factory\getSession().

◆ storeOptions()

storeOptions ( $options )

Store the current setup options in the session.

Paramètres
array $options The installation options.
Renvoie
array An array of options from the session.
Depuis
3.1

Références $options, Factory\getLanguage(), Factory\getSession(), et null.

◆ validate()

validate | ( | $data,
 |  | $view = null
 | ) |

Method to validate the form data.

Paramètres
array | $data | The form data.
string | null | $view | The view.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Depuis
3.1

Références $data, $form, $message, $messages, $return, $view, et Factory\getApplication().

◆ validateDbConnection()

validateDbConnection ( )

Method to validate the db connection properties.

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $lang, $options, DatabaseHelper\checkDbServerParameters(), DatabaseHelper\checkRemoteDbHost(), LanguageHelper\exists(), Factory\getApplication(), DatabaseHelper\getDbo(), DatabaseHelper\getEncryptionSettings(), Factory\getLanguage(), JPATH_ADMINISTRATOR, Text\sprintf(), ArrayHelper\toObject(), et DatabaseHelper\validateConnectionParameters().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SetupModel.php


Joomla CMS: Référence de la classe JsonResponse

  • Joomla
  • CMS
  • Installation
  • Response
  • JsonResponse
Fonctions membres publiques
Référence de la classe JsonResponse

Fonctions membres publiques

__construct ($data)

Description détaillée

JSON Response class for the Joomla Installer.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $data )

Constructor for the JSON response

Paramètres
mixed $data Exception if there is an error, otherwise, the session data
Depuis
3.1

Références $data, $messages, Text\_(), Factory\getApplication(), Session\getFormToken(), et Factory\getLanguage().

La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Response/JsonResponse.php


Joomla CMS: Référence de la classe InstallationRouter

  • Joomla
  • CMS
  • Installation
  • Router
  • InstallationRouter
Fonctions membres publiques
Référence de la classe InstallationRouter
+ Graphe d'héritage de InstallationRouter:
Router

Fonctions membres publiques

parse (&$uri, $setVars=false)
build ($url)
- Fonctions membres publiques hérités de Router
parse (&$uri, $setVars=false)
build ($url)
setVar ($key, $value, $create=true)
setVars ($vars=array(), $merge=true)
getVar ($key)
getVars ()
attachBuildRule (callable $callback, $stage=self::PROCESS_DURING)
attachParseRule (callable $callback, $stage=self::PROCESS_DURING)
detachRule ($type, $rule, $stage=self::PROCESS_DURING)
getRules ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Router
static | getInstance ($client, $options=array())
- Champs de données hérités de Router
const | PROCESS_BEFORE = 'preprocess'
const | PROCESS_DURING = ''
const | PROCESS_AFTER = 'postprocess'
- Fonctions membres protégées hérités de Router
processParseRules (&$uri, $stage=self::PROCESS_DURING)
processBuildRules (&$uri, $stage=self::PROCESS_DURING)
createUri ($url)
- Attributs protégés hérités de Router
$vars = array()
$rules
$cache = array()
- Attributs protégés statiques hérités de Router
static | $instances = array()

Description détaillée

Class to create and parse routes.

Depuis
1.5

Documentation des fonctions membres

◆ build()

build ( $url )

Function to convert an internal URI to a route

Paramètres
string $url The internal URL
Renvoie
string The absolute search engine friendly URL
Depuis
1.5

Références $url.

◆ parse()

parse | ( | & | $uri,
 |  |  | $setVars = false
 | ) |  |

Function to convert a route to an internal URI

Paramètres
Uri | $uri | The uri.
bool | $setVars | Set the parsed data in the internal storage for current-request-URLs
Renvoie
boolean
Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallationRouter.php


Joomla CMS: Référence de la classe Application

  • Joomla
  • CMS
  • Installation
  • Service
  • Provider
  • Application
Fonctions membres publiques
Référence de la classe Application
+ Graphe d'héritage de Application:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Application service provider

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $app, Factory\$application, $container, class, null, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/Service/Provider/Application.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • CMS
  • Installation
  • View
  • Error
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
DefaultView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de DefaultView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de DefaultView
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The HTML Joomla Core Install Error View

Depuis
3.1
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/View/Error/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • CMS
  • Installation
  • View
  • Preinstall
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
DefaultView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de DefaultView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$options
$_defaultModel = 'checks'
- Attributs protégés hérités de DefaultView
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The HTML Joomla Core Install Preinstall View

Depuis
3.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string | null $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Documentation des champs

◆ $_defaultModel

$_defaultModel = 'checks'
protected

◆ $options

$options
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/View/Preinstall/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • CMS
  • Installation
  • View
  • Remove
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
DefaultView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de DefaultView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$development
$items
$phpsettings
$phpoptions
$installed_languages
- Attributs protégés hérités de DefaultView
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The HTML Joomla Core Install Remove View

Depuis
3.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string | null $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $development

$development
protected

◆ $installed_languages

$installed_languages
protected

◆ $items

$items
protected

◆ $phpoptions

$phpoptions
protected

◆ $phpsettings

$phpsettings
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/View/Remove/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • CMS
  • Installation
  • View
  • Setup
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
DefaultView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de DefaultView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de DefaultView
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The HTML Joomla Core Install Setup View

Depuis
3.1
La documentation de cette classe a été générée à partir du fichier suivant :
  • installation/src/View/Setup/HtmlView.php


Joomla CMS: Référence de la classe DefaultView

  • Joomla
  • CMS
  • Installation
  • View
  • DefaultView
Fonctions membres publiques | Attributs protégés
Référence de la classe DefaultView
+ Graphe d'héritage de DefaultView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView HtmlView HtmlView HtmlView

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Generic Installation View

Depuis
3.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string | null $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DefaultView.php


Joomla CMS: Référence de la classe ComponentAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • ComponentAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentAdapter
+ Graphe d'héritage de ComponentAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

getElement ($element=null)
loadLanguage ($path=null)
discover ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
finaliseUninstall ()
parseOptionalTags ()
parseQueries ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
setupUpdates ()
_buildAdminMenus ($componentId=null)
_updateSiteMenus ($componentId=null)
_updateMenus ($componentId, $clientId=null)
_rollback_menu ($step)
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$oldAdminFiles = null
$oldApiFiles = null
$oldFiles = null
$manifest_script = null
$install_script = null
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Component installer

Depuis
3.1

Documentation des fonctions membres

◆ _buildAdminMenus()

_buildAdminMenus ( $componentId = null )
protected

Method to build menu database entries for a component

Paramètres
int | null $componentId The component ID for which I'm building menus
Renvoie
boolean True if successful
Depuis
3.1

Références $data, $db, $option, $params, $query, Joomla\Database\getDatabase(), et parent.

◆ _rollback_menu()

_rollback_menu ( $step )
protected

Custom rollback method

  • Roll back the component menu item
Paramètres
array $step Installation step to rollback.
Renvoie
boolean True on success
Exceptions

Références $step.

◆ _updateMenus()

_updateMenus | ( | $componentId,
 |  | $clientId = null
 | ) |
protected

Method to update menu database entries for a component in case if the component has been uninstalled before.

Paramètres
int | null | $componentId | The component ID.
int | $clientId | The client id
Renvoie
boolean True if successful
Depuis
3.7.0

Références $clientId, $db, $link, $option, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ _updateSiteMenus()

_updateSiteMenus ( $componentId = null )
protected

Method to update menu database entries for a component in case the component has been uninstalled before. NOTE: This will not update admin menus. Use _updateMenus() instead to update admin menus ase well.

Paramètres
int | null $componentId The component ID.
Renvoie
boolean True if successful
Depuis
3.4.2

◆ checkExtensionInFilesystem()

checkExtensionInFilesystem ( )
protected

Method to check if the extension is present in the filesystem

Renvoie
boolean
Depuis
3.4
Exceptions

Références elseif, parent, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $path, $result, $this, Text\_(), parent, et Text\sprintf().

◆ createExtensionRoot()

createExtensionRoot ( )
protected

Method to create the extension root path if necessary

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), Folder\create(), parent, et Text\sprintf().

◆ discover()

discover ( )

Discover unregistered extensions.

Renvoie
array A list of extensions.
Depuis
3.1

Références $component, $extension, $results, Folder\folders(), Table\getInstance(), JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, et Installer\parseXMLInstallFile().

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $query, $this, Text\_(), Log\add(), Folder\delete(), extension, Joomla\Database\getDatabase(), Table\getInstance(), ParameterType\INTEGER, parent, et Log\WARNING.

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

◆ loadLanguage()

loadLanguage ( $path = null )

Custom loadLanguage method

Paramètres
string $path The path language files are on.
Renvoie
void
Depuis
3.1

Références $client, $extension, $folder, $path, $this, elseif, JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, null, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ parseQueries()

parseQueries ( )
protected

Method to parse the queries specified in the <sql> tags

Renvoie
void
Depuis
4.0.0
Exceptions

Références extension.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean Result of operation, true if updated, false on failure
Depuis
3.1

Références $client, Text\_(), Log\add(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références parent.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), Path\clean(), JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, et parent.

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références Text\_(), Path\clean(), Folder\delete(), extension, JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, et parent.

◆ setupUpdates()

setupUpdates ( )
protected

Method to setup the update routine for the adapter

Renvoie
void
Depuis
3.4

Références Joomla\Database\getDatabase(), null, et parent.

Documentation des champs

◆ $install_script

$install_script = null
protected

◆ $manifest_script

$manifest_script = null
protected

◆ $oldAdminFiles

$oldAdminFiles = null
protected

◆ $oldApiFiles

$oldApiFiles = null
protected

◆ $oldFiles

$oldFiles = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentAdapter.php


Joomla CMS: Référence de la classe FileAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • FileAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FileAdapter
+ Graphe d'héritage de FileAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

getElement ($element=null)
loadLanguage ($path)
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

copyBaseFiles ()
finaliseInstall ()
finaliseUninstall ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
extensionExistsInSystem ($extension=null)
populateFilesAndFolderList ()
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$scriptElement = null
$supportsDiscoverInstall = false
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

File installer

Depuis
3.1

Documentation des fonctions membres

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $folder, Folder\create(), Folder\exists(), parent, et Text\sprintf().

◆ extensionExistsInSystem()

extensionExistsInSystem ( $extension = null )
protected

Function used to check if extension is already installed

Paramètres
string $extension The element name of the extension to install
Renvoie
boolean True if extension exists
Depuis
3.1

Références $db, $extension, $id, $query, et Joomla\Database\getDatabase().

◆ finaliseInstall()

finaliseInstall ( )
protected

Method to finalise the installation processing

Renvoie
void
Depuis
3.4
Exceptions

Références $manifest, $path, Text\_(), Folder\create(), Table\getInstance(), JPATH_MANIFESTS, parent, et Text\sprintf().

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $query, $this, File\delete(), extension, Joomla\Database\getDatabase(), Table\getInstance(), ParameterType\INTEGER, et JPATH_MANIFESTS.

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

Références Path\clean(), et parent.

◆ loadLanguage()

loadLanguage ( $path )

Custom loadLanguage method

Paramètres
string $path The path on which to find language files.
Renvoie
void
Depuis
3.1

Références $extension, $path, et JPATH_SITE.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ populateFilesAndFolderList()

populateFilesAndFolderList ( )
protected

Function used to populate files and folder list

Renvoie
boolean none
Depuis
3.1

Références $dir, $folder, $path, $target, Log\add(), Path\clean(), Folder\exists(), Folder\files(), JPATH_ROOT, parent, Text\sprintf(), et Log\WARNING.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean result of operation, true if updated, false on failure
Depuis
3.1

Références Text\_(), Log\add(), JPATH_MANIFESTS, parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références $folder, $target, File\delete(), Folder\delete(), Folder\exists(), Folder\files(), JPATH_ROOT, et parent.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4

Références JPATH_MANIFESTS, JPATH_ROOT, name, et parent.

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $xml, Text\_(), extension, JPATH_MANIFESTS, et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

Références $name, Text\_(), extension, parent, et Text\sprintf().

Documentation des champs

◆ $scriptElement

$scriptElement = null
protected

◆ $supportsDiscoverInstall

$supportsDiscoverInstall = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FileAdapter.php


Joomla CMS: Référence de la classe LanguageAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • LanguageAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe LanguageAdapter
+ Graphe d'héritage de LanguageAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

install ()
update ()
discover ()
discover_install ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

copyBaseFiles ()
finaliseInstall ()
finaliseUninstall ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
getSefString ($itemLanguageTag)
createContentLanguage ($tag)
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$core = false
$tag
$ignoreUninstallQueries = false
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Fonctions membres privées

resetUserLanguage ()

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Language installer

Depuis
3.1

Documentation des fonctions membres

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

◆ createContentLanguage()

createContentLanguage ( $tag )
protected

Create an unpublished content language.

Paramètres
$tag string The language tag
Exceptions

Références Log\add(), Factory\getApplication(), Table\getInstance(), JPATH_INSTALLATION, JPATH_SITE, Log\NOTICE, LanguageHelper\parseXMLLanguageFile(), et Text\sprintf().

◆ discover()

discover ( )

Custom discover method Finds language files

Renvoie
[] Array of discovered extensions.
Depuis
3.1

Références $basePath, $clientId, $extension, $language, $languages, $results, Folder\folders(), Table\getInstance(), JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, et Installer\parseXMLInstallFile().

◆ discover_install()

discover_install ( )

Custom discover install method Basically updates the manifest cache and leaves everything alone

Renvoie
integer The extension id
Depuis
3.1

Références $client, Text\_(), Log\add(), Factory\getCache(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ finaliseInstall()

finaliseInstall ( )
protected

Method to finalise the installation processing

Renvoie
void
Depuis
4.0.0
Exceptions

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $query, $this, extension, Factory\getCache(), Joomla\Database\getDatabase(), Table\getInstance(), et ParameterType\INTEGER.

◆ getSefString()

getSefString ( $itemLanguageTag )
protected

Gets a unique language SEF string.

This function checks other existing language with the same code, if they exist provides a unique SEF name. For instance: en-GB, en-US and en-AU will share the same SEF code by default: www.mywebsite.com/en/ To avoid this conflict, this function creates an specific SEF in case of existing conflict: For example: www.mywebsite.com/en-au/

Paramètres
string $itemLanguageTag Language Tag.
Renvoie
string
Depuis
3.7.0

Références $db, $langs, $query, et Joomla\Database\getDatabase().

◆ install()

install ( )

Custom install method

Note: This behaves badly due to hacks made in the middle of 1.5.x to add the ability to install multiple distinct packs in one install. The preferred method is to use a package to install multiple language packs.

Renvoie
boolean|integer The extension ID on success, boolean false on failure
Depuis
3.1

Références $basePath, $client, $clientId, $this, ApplicationHelper\getClientInfo(), JPATH_SITE, null, parent, et Text\sprintf().

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean result of operation, true if updated, false on failure
Depuis
3.1

Références $client, Text\_(), Log\add(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références $path, Text\_(), Log\add(), Folder\delete(), extension, ApplicationHelper\getClientInfo(), parent, et Log\WARNING.

◆ resetUserLanguage()

resetUserLanguage ( )
private

Resets user language to default language

Renvoie
void
Depuis
4.0.0

Références $client, $count, $db, $query, $user, $userId, Log\add(), extension, ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), ParameterType\INTEGER, Log\NOTICE, et Text\plural().

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $client, $params, $path, Text\_(), Folder\exists(), extension, ApplicationHelper\getClientInfo(), ComponentHelper\getParams(), et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

◆ update()

update ( )

Custom update method

Renvoie
boolean True on success, false on failure
Depuis
3.1

Finalization and Cleanup Section

Références $basePath, $client, $clientId, $name, $xml, Text\_(), Factory\getCache(), ApplicationHelper\getClientInfo(), InputFilter\getInstance(), Table\getInstance(), if, null, parent, et Text\sprintf().

Documentation des champs

◆ $core

$core = false
protected

◆ $ignoreUninstallQueries

$ignoreUninstallQueries = false
protected

◆ $tag

$tag
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageAdapter.php


Joomla CMS: Référence de la classe LibraryAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • LibraryAdapter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LibraryAdapter
+ Graphe d'héritage de LibraryAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

getElement ($element=null)
loadLanguage ($path=null)
prepareDiscoverInstall ()
discover ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExtensionInFilesystem ()
copyBaseFiles ()
finaliseUninstall ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Description détaillée

Library installer

Depuis
3.1

Documentation des fonctions membres

◆ checkExtensionInFilesystem()

checkExtensionInFilesystem ( )
protected

Method to check if the extension is present in the filesystem, flags the route as update if so

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), extension, Joomla\Database\getDatabase(), Table\getInstance(), null, et parent.

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $this, parent, et Text\sprintf().

◆ discover()

discover ( )

Custom discover method

Renvoie
array Extension list of extensions available
Depuis
3.1

Références $extension, $folder, $results, Table\getInstance(), JPATH_MANIFESTS, et Installer\parseXMLInstallFile().

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $query, $this, extension, Joomla\Database\getDatabase(), Table\getInstance(), et ParameterType\INTEGER.

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

◆ loadLanguage()

loadLanguage ( $path = null )

Custom loadLanguage method

Paramètres
string $path The path where to find language files.
Renvoie
void
Depuis
3.1

Références $extension, $path, JPATH_SITE, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ prepareDiscoverInstall()

prepareDiscoverInstall ( )

Prepares the adapter for a discover_install task

Renvoie
void
Depuis
3.4

Références extension, JPATH_MANIFESTS, et parent.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean Result of operation, true if updated, false on failure
Depuis
3.1

Références Text\_(), Log\add(), JPATH_MANIFESTS, parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références File\delete(), Folder\delete(), Folder\exists(), extension, Folder\files(), Folder\folders(), JPATH_MANIFESTS, et parent.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), et parent.

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $manifest, $xml, Text\_(), extension, JPATH_MANIFESTS, et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

Références $name, Text\_(), extension, parent, Installer\parseXMLInstallFile(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LibraryAdapter.php


Joomla CMS: Référence de la classe ModuleAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • ModuleAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ModuleAdapter
+ Graphe d'héritage de ModuleAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

discover ()
getElement ($element=null)
loadLanguage ($path=null)
prepareDiscoverInstall ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExistingExtension ()
copyBaseFiles ()
finaliseInstall ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
_rollback_menu ($arg)
_rollback_module ($arg)
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$clientId
$scriptElement = null
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Module installer

Depuis
3.1

Documentation des fonctions membres

◆ _rollback_menu()

_rollback_menu ( $arg )
protected

Custom rollback method

  • Roll back the menu item
Paramètres
array $arg Installation step to rollback
Renvoie
boolean True on success
Depuis
3.1

Références $db, $moduleId, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ _rollback_module()

_rollback_module ( $arg )
protected

Custom rollback method

  • Roll back the module item
Paramètres
array $arg Installation step to rollback
Renvoie
boolean True on success
Depuis
3.1

Références $db, $moduleId, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ checkExistingExtension()

checkExistingExtension ( )
protected

Method to check if the extension is already present in the database

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), extension, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $path, $this, Text\_(), parent, et Text\sprintf().

◆ discover()

discover ( )

Custom discover method

Renvoie
array Extension list of extensions available
Depuis
3.1

Références $extension, $module, $results, Folder\folders(), ApplicationHelper\getClientInfo(), Table\getInstance(), JPATH_ADMINISTRATOR, JPATH_SITE, et Installer\parseXMLInstallFile().

◆ finaliseInstall()

finaliseInstall ( )
protected

Method to finalise the installation processing

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), Table\getInstance(), parent, et Text\sprintf().

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string|null The filtered element
Depuis
3.4

◆ loadLanguage()

loadLanguage ( $path = null )

Custom loadLanguage method

Paramètres
string $path The path where we find language files
Renvoie
void
Depuis
3.4

Références $client, $extension, $folder, $path, JPATH_ADMINISTRATOR, JPATH_SITE, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ prepareDiscoverInstall()

prepareDiscoverInstall ( )

Prepares the adapter for a discover_install task

Renvoie
void
Depuis
3.4

Références $client, ApplicationHelper\getClientInfo(), et parent.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean Result of operation, true if updated, false on failure.
Depuis
3.1

Références $client, Text\_(), Log\add(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références extension, et parent.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références $basePath, $client, Text\_(), ApplicationHelper\getClientInfo(), JPATH_SITE, parent, et Text\sprintf().

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $client, extension, ApplicationHelper\getClientInfo(), JPATH_ADMINISTRATOR, JPATH_SITE, parent, et Text\sprintf().

Documentation des champs

◆ $clientId

$clientId
protected

◆ $scriptElement

$scriptElement = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleAdapter.php


Joomla CMS: Référence de la classe PackageAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • PackageAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PackageAdapter
+ Graphe d'héritage de PackageAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

getElement ($element=null)
loadLanguage ($path)
onExtensionAfterInstall (Event $event)
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
finaliseUninstall ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
triggerManifestScript ($method)
_getExtensionId ($type, $id, $client, $group)
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$installedIds = array()
$results = array()
$supportsDiscoverInstall = false
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Package installer

Depuis
3.1

Documentation des fonctions membres

◆ _getExtensionId()

_getExtensionId | ( | $type,
 |  | $id,
 |  | $client,
 |  | $group
 | ) |
protected

Gets the extension id.

Paramètres
string | $type | The extension type.
string | $id | The name of the extension (the element field).
integer | $client | The application id (0: Joomla CMS site; 1: Joomla CMS administrator).
string | $group | The extension group (mainly for plugins).
Renvoie
integer
Depuis
3.1

Références $client, $clientId, $db, $id, $query, $type, ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ checkExtensionInFilesystem()

checkExtensionInFilesystem ( )
protected

Method to check if the extension is present in the filesystem, flags the route as update if so

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), elseif, JPATH_MANIFESTS, parent, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $folder, $this, Text\_(), InstallerHelper\detectType(), Factory\getApplication(), Joomla\Database\getDatabase(), parent, Text\sprintf(), et InstallerHelper\unpack().

◆ createExtensionRoot()

createExtensionRoot ( )
protected

Method to create the extension root path if necessary

Renvoie
void
Depuis
3.4
Exceptions

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $folder, $query, $this, File\delete(), Folder\delete(), Folder\exists(), extension, Joomla\Database\getDatabase(), Table\getInstance(), ParameterType\INTEGER, JPATH_MANIFESTS, et parent.

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

Références InputFilter\getInstance().

◆ loadLanguage()

loadLanguage ( $path )

Load language from a path

Paramètres
string $path The path of the language.
Renvoie
void
Depuis
3.1

Références $path.

◆ onExtensionAfterInstall()

onExtensionAfterInstall ( Event $event )

Handler for the onExtensionAfterInstall event

Paramètres
Event $event The event
Renvoie
void
Depuis
3.7.0

Références AbstractEvent\getArgument().

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean Result of operation, true if updated, false on failure
Depuis
3.1

Références Text\_(), Log\add(), JPATH_MANIFESTS, parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références $extension, $id, $manifest, Text\_(), Log\add(), extension, Joomla\Database\getDatabase(), JPATH_MANIFESTS, parent, Text\sprintf(), et Log\WARNING.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), JPATH_MANIFESTS, parent, et Text\sprintf().

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $manifest, $xml, Text\_(), extension, JPATH_MANIFESTS, JPATH_SITE, et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

Références $name, Text\_(), extension, name, parent, et Text\sprintf().

◆ triggerManifestScript()

triggerManifestScript ( $method )
protected

Executes a custom install script method

Paramètres
string $method The install method to execute
Renvoie
boolean True on success
Depuis
3.4

Références $method, $this, Text\_(), parent, et Text\sprintf().

Documentation des champs

◆ $installedIds

$installedIds = array()
protected

◆ $results

$results = array()
protected

◆ $supportsDiscoverInstall

$supportsDiscoverInstall = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PackageAdapter.php


Joomla CMS: Référence de la classe PluginAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • PluginAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PluginAdapter
+ Graphe d'héritage de PluginAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

getElement ($element=null)
loadLanguage ($path=null)
prepareDiscoverInstall ()
discover ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExistingExtension ()
copyBaseFiles ()
createExtensionRoot ()
finaliseUninstall ()
getScriptClassName ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$scriptElement = null
$oldFiles = null
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Plugin installer

Depuis
3.1

Documentation des fonctions membres

◆ checkExistingExtension()

checkExistingExtension ( )
protected

Method to check if the extension is already present in the database

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), extension, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $path, $this, Text\_(), parent, et Text\sprintf().

◆ createExtensionRoot()

createExtensionRoot ( )
protected

Method to create the extension root path if necessary

Renvoie
void
Depuis
3.4
Exceptions

Références Joomla\Database\getDatabase(), et parent.

◆ discover()

discover ( )

Custom discover method

Renvoie
array Extension) list of extensions available
Depuis
3.1

Références $extension, $folder, $results, Folder\files(), Folder\folders(), Table\getInstance(), JPATH_SITE, Installer\parseXMLInstallFile(), et File\stripExt().

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $db, $query, Folder\delete(), extension, Joomla\Database\getDatabase(), ParameterType\INTEGER, et parent.

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

Références $type.

◆ getScriptClassName()

getScriptClassName ( )
protected

Get the class name for the install adapter script.

Renvoie
string The class name.
Depuis
3.4

◆ loadLanguage()

loadLanguage ( $path = null )

Custom loadLanguage method

Paramètres
string $path The path where to find language files.
Renvoie
void
Depuis
3.1

Références $extension, $folder, $name, $path, $this, JPATH_ADMINISTRATOR, JPATH_PLUGINS, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ prepareDiscoverInstall()

prepareDiscoverInstall ( )

Prepares the adapter for a discover_install task

Renvoie
void
Depuis
3.4

Références $basePath, $client, extension, ApplicationHelper\getClientInfo(), et parent.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache.

Renvoie
boolean Result of operation, true if updated, false on failure.
Depuis
3.1

Références $client, Text\_(), Log\add(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références parent.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), JPATH_PLUGINS, parent, et Text\sprintf().

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $this, Text\_(), extension, JPATH_PLUGINS, et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

Références $name, $this, Text\_(), extension, name, parent, Installer\parseXMLInstallFile(), et Text\sprintf().

Documentation des champs

◆ $oldFiles

$oldFiles = null
protected

◆ $scriptElement

$scriptElement = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginAdapter.php


Joomla CMS: Référence de la classe TemplateAdapter

  • Joomla
  • CMS
  • Installer
  • Adapter
  • TemplateAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TemplateAdapter
+ Graphe d'héritage de TemplateAdapter:
InstallerAdapter ContainerAwareInterface DatabaseAwareInterface

Fonctions membres publiques

loadLanguage ($path=null)
prepareDiscoverInstall ()
discover ()
refreshManifestCache ()
- Fonctions membres publiques hérités de InstallerAdapter
__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

checkExistingExtension ()
copyBaseFiles ()
finaliseUninstall ()
parseOptionalTags ()
parseQueries ()
removeExtensionFiles ()
setupInstallPaths ()
setupUninstall ()
storeExtension ()
- Fonctions membres protégées hérités de InstallerAdapter
canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$clientId
- Attributs protégés hérités de InstallerAdapter
$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Membres hérités additionnels

- Champs de données hérités de InstallerAdapter
$manifest = null

Description détaillée

Template installer

Depuis
3.1

Documentation des fonctions membres

◆ checkExistingExtension()

checkExistingExtension ( )
protected

Method to check if the extension is already present in the database

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), extension, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
protected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

Références $path, $this, Text\_(), parent, et Text\sprintf().

◆ discover()

discover ( )

Discover existing but uninstalled templates

Renvoie
array Extension list

Références $extension, $results, $template, Folder\folders(), ApplicationHelper\getClientInfo(), Table\getInstance(), JPATH_ADMINISTRATOR, JPATH_SITE, et Installer\parseXMLInstallFile().

◆ finaliseUninstall()

finaliseUninstall ( )
protected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

Références $clientId, $db, $query, $this, extension, Joomla\Database\getDatabase(), Table\getInstance(), et ParameterType\INTEGER.

◆ loadLanguage()

loadLanguage ( $path = null )

Custom loadLanguage method

Paramètres
string $path The path where to find language files.
Renvoie
void
Depuis
3.1

Références $base, $basePath, $client, $extension, $path, JPATH_ADMINISTRATOR, JPATH_SITE, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.4

Références parent.

◆ parseQueries()

parseQueries ( )
protected

Overloaded method to parse queries for template installations

Renvoie
void
Depuis
3.4
Exceptions

Références $columns, $db, $lang, $query, $this, Text\_(), extension, Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, Text\sprintf(), et ParameterType\STRING.

◆ prepareDiscoverInstall()

prepareDiscoverInstall ( )

Prepares the adapter for a discover_install task

Renvoie
void
Depuis
3.4

Références $client, extension, ApplicationHelper\getClientInfo(), et parent.

◆ refreshManifestCache()

refreshManifestCache ( )

Refreshes the extension table cache

Renvoie
boolean Result of operation, true if updated, false on failure
Depuis
3.1

Références $client, Text\_(), Log\add(), ApplicationHelper\getClientInfo(), parent, Installer\parseXMLInstallFile(), et Log\WARNING.

◆ removeExtensionFiles()

removeExtensionFiles ( )
protected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

Références Text\_(), Log\add(), Folder\delete(), Folder\exists(), extension, parent, et Log\WARNING.

◆ setupInstallPaths()

setupInstallPaths ( )
protected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4
Exceptions

Références $basePath, $client, Text\_(), ApplicationHelper\getClientInfo(), JPATH_SITE, parent, et Text\sprintf().

◆ setupUninstall()

setupUninstall ( )
protected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

Références $client, $clientId, $db, $extension, $manifest, $name, $query, Text\_(), Folder\delete(), extension, ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), et parent.

◆ storeExtension()

storeExtension ( )
protected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

Références $clientId, $name, Text\_(), extension, parent, Installer\parseXMLInstallFile(), et Text\sprintf().

Documentation des champs

◆ $clientId

$clientId
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplateAdapter.php


Joomla CMS: Référence de la classe LibraryManifest

  • Joomla
  • CMS
  • Installer
  • Manifest
  • LibraryManifest
Champs de données | Fonctions membres protégées
Référence de la classe LibraryManifest
+ Graphe d'héritage de LibraryManifest:
Manifest

Champs de données

$libraryname = ''
$creationDate = ''
$copyright = ''
$license = ''
$author = ''
$authoremail = ''
$authorurl = ''
- Champs de données hérités de Manifest
$manifest_file = ''
$name = ''
$version = ''
$description = ''
$packager = ''
$packagerurl = ''
$update = ''
$filelist = array()

Fonctions membres protégées

loadManifestFromData (\SimpleXMLElement $xml)
- Fonctions membres protégées hérités de Manifest
loadManifestFromData (\SimpleXMLElement $xml)

Membres hérités additionnels

- Fonctions membres publiques hérités de Manifest
__construct ($xmlpath='')
loadManifestFromXml ($xmlfile)

Description détaillée

Joomla! Library Manifest File

Depuis
3.1

Documentation des fonctions membres

◆ loadManifestFromData()

loadManifestFromData ( \SimpleXMLElement $xml )
protected

Apply manifest data from a to the object.

Paramètres
\SimpleXMLElement $xml Data to load
Renvoie
void
Depuis
3.1

Références $this, $xml, if, et name.

Documentation des champs

◆ $author

$author = ''

◆ $authoremail

$authoremail = ''

◆ $authorurl

$authorurl = ''

◆ $copyright

$copyright = ''

◆ $creationDate

$creationDate = ''

◆ $libraryname

$libraryname = ''

◆ $license

$license = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • LibraryManifest.php


Joomla CMS: Référence de la classe PackageManifest

  • Joomla
  • CMS
  • Installer
  • Manifest
  • PackageManifest
Champs de données | Fonctions membres protégées
Référence de la classe PackageManifest
+ Graphe d'héritage de PackageManifest:
Manifest

Champs de données

$packagename = ''
$url = ''
$scriptfile = ''
$blockChildUninstall = false
- Champs de données hérités de Manifest
$manifest_file = ''
$name = ''
$version = ''
$description = ''
$packager = ''
$packagerurl = ''
$update = ''
$filelist = array()

Fonctions membres protégées

loadManifestFromData (\SimpleXMLElement $xml)
- Fonctions membres protégées hérités de Manifest
loadManifestFromData (\SimpleXMLElement $xml)

Membres hérités additionnels

- Fonctions membres publiques hérités de Manifest
__construct ($xmlpath='')
loadManifestFromXml ($xmlfile)

Description détaillée

Joomla! Package Manifest File

Depuis
3.1

Documentation des fonctions membres

◆ loadManifestFromData()

loadManifestFromData ( \SimpleXMLElement $xml )
protected

Apply manifest data from a to the object.

Paramètres
\SimpleXMLElement $xml Data to load
Renvoie
void
Depuis
3.1

Références $folder, $this, $value, $xml, description, if, et name.

Documentation des champs

◆ $blockChildUninstall

$blockChildUninstall = false

◆ $packagename

$packagename = ''

◆ $scriptfile

$scriptfile = ''

◆ $url

$url = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • PackageManifest.php


Joomla CMS: Référence de la classe Installer

  • Joomla
  • CMS
  • Installer
  • Installer
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques
Référence de la classe Installer
+ Graphe d'héritage de Installer:
Adapter DatabaseAwareInterface CMSObject

Fonctions membres publiques

__construct ($basepath=__DIR__, $classprefix='\\Joomla\\CMS\\Installer\\Adapter', $adapterfolder='Adapter')
isOverwrite ()
setOverwrite ($state=false)
getRedirectUrl ()
setRedirectUrl ($newurl)
isPackageUninstall ()
setPackageUninstall ($uninstall)
isUpgrade ()
setUpgrade ($state=false)
getManifest ()
getPath ($name, $default=null)
setPath ($name, $value)
pushStep ($step)
abort ($msg=null, $type=null)
install ($path=null)
discover_install ($eid=null)
discover ()
update ($path=null)
uninstall ($type, $identifier)
refreshManifestCache ($eid)
setupInstall ($route='install', $returnAdapter=false)
parseQueries (\SimpleXMLElement $element)
parseSQLFiles ($element)
setSchemaVersion (\SimpleXMLElement $schema, $eid)
parseSchemaUpdates (\SimpleXMLElement $schema, $eid)
parseFiles (\SimpleXMLElement $element, $cid=0, $oldFiles=null, $oldMD5=null)
parseLanguages (\SimpleXMLElement $element, $cid=0)
parseMedia (\SimpleXMLElement $element, $cid=0)
getParams ()
copyFiles ($files, $overwrite=null)
removeFiles ($element, $cid=0)
copyManifest ($cid=1)
findManifest ()
isManifest ($file)
generateManifestCache ()
cleanDiscoveredExtension ($type, $element, $folder='', $client=0)
findDeletedFiles ($oldFiles, $newFiles)
loadMD5Sum ($filename)
getAdapters ($options=array(), array $custom=array())
loadAdapter ($adapter, $options=array())
- Fonctions membres publiques hérités de Adapter
__construct ($basepath, $classprefix=null, $adapterfolder=null)
getDbo ()
getAdapter ($name, $options=array())
setAdapter ($name, &$adapter=null, $options=array())
loadAllAdapters ($options=array())
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres publiques statiques

static | getInstance ($basepath=__DIR__, $classprefix='\\Joomla\\CMS\\Installer\\Adapter', $adapterfolder='Adapter')
static | splitSql (?string $sql)
static | parseXMLInstallFile ($path)

Champs de données

$manifestClass = null
$extension = null
$message = null
$manifest = null
$extraQuery = ''

Attributs protégés

$paths = array()
$upgrade = null
$overwrite = false
$stepStack = array()
$extension_message = null
$redirect_url = null
$packageUninstall = false
const | CAN_FAIL_MARKER = '/** CAN FAIL **/'
const | CAN_FAIL_MARKER_LENGTH = 16
- Attributs protégés hérités de Adapter
$_adapters = array()
$_adapterfolder = 'adapters'
$_classprefix = 'J'
$_basepath = null
$_db
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs protégés statiques

static $instances

Description détaillée

Joomla base installer class

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $basepath = __DIR__,
 |  | $classprefix = '\\Joomla\\CMS\\Installer\\Adapter',
 |  | $adapterfolder = 'Adapter'
 | ) |

Constructor

Paramètres
string | $basepath | Base Path of the adapters
string | $classprefix | Class prefix of adapters
string | $adapterfolder | Name of folder to append to base path
Depuis
3.1

Références Symfony\Contracts\Service\__construct(), extension, et Table\getInstance().

Documentation des fonctions membres

◆ abort()

abort | ( | $msg = null,
 |  | $type = null
 | ) |

Installation abort method

Paramètres
string | $msg | Abort message from the installer
string | $type | Package type if defined
Renvoie
boolean True if successful
Depuis
3.1

Références $db, $method, $query, $step, $type, Text\_(), Log\add(), File\delete(), Folder\delete(), Joomla\Database\getDatabase(), ParameterType\INTEGER, null, et Log\WARNING.

◆ cleanDiscoveredExtension()

cleanDiscoveredExtension | ( | $type,
 |  | $element,
 |  | $folder = '',
 |  | $client = 0
 | ) |

Cleans up discovered extensions if they're being installed some other way

Paramètres
string | $type | The type of extension (component, etc)
string | $element | Unique element identifier (e.g. com_content)
string | $folder | The folder of the extension (plugins; e.g. system)
integer | $client | The client application (administrator or site)
Renvoie
object Result of query
Depuis
3.1

Références $client, $db, $folder, $query, $type, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ copyFiles()

copyFiles | ( | $files,
 |  | $overwrite = null
 | ) |

Copyfiles

Copy files from source directory to the target directory

Paramètres
array | $files | Array with filenames
boolean | $overwrite | True if existing files can be replaced
Renvoie
boolean True on success
Depuis
3.1

Références $step, Text\_(), Log\add(), Path\clean(), Folder\copy(), File\copy(), elseif, null, Text\sprintf(), et Log\WARNING.

◆ copyManifest()

copyManifest ( $cid = 1 )

Copies the installation manifest file to the extension folder in the given client

Paramètres
integer $cid Where to copy the installfile [optional: defaults to 1 (admin)]
Renvoie
boolean True on success, False on error
Depuis
3.1

Références $client, $path, et ApplicationHelper\getClientInfo().

◆ discover()

discover ( )

Extension discover method

Asks each adapter to find extensions

Renvoie
InstallerExtension[]
Depuis
3.1

Références $results, et $tmp.

◆ discover_install()

discover_install ( $eid = null )

Discovered package installation method

Paramètres
integer $eid Extension ID
Renvoie
boolean True if successful
Depuis
3.1

Références $params, $result, $this, $type, Text\_(), extension, Factory\getApplication(), PluginHelper\importPlugin(), null, et Text\sprintf().

◆ findDeletedFiles()

findDeletedFiles | ( | $oldFiles,
 |  | $newFiles
 | ) |

Compares two "files" entries to find deleted files/folders

Paramètres
array | $oldFiles | An array of objects that are the old files
array | $newFiles | An array of objects that are the new files
Renvoie
array An array with the delete files and folders in findDeletedFiles[files] and findDeletedFiles[folders] respectively
Depuis
3.1

Références $container.

◆ findManifest()

findManifest ( )

Tries to find the package manifest file

Renvoie
boolean True on success, False on error
Depuis
3.1

Références $manifest, Text\_(), Log\add(), Folder\exists(), Folder\files(), null, et Log\WARNING.

◆ generateManifestCache()

generateManifestCache ( )

Generates a manifest cache

Renvoie
string serialised manifest data
Depuis
3.1

◆ getAdapters()

getAdapters | ( |  | $options = array(),
 |  | array | $custom = array()
 | ) |  |

Gets a list of available install adapters.

Paramètres
array | $options | An array of options to inject into the adapter
array | $custom | Array of custom install adapters
Renvoie
string[] An array of the class names of available install adapters.
Depuis
3.4

Références $class, $name, et JLoader\register().

◆ getInstance()

static getInstance | ( | $basepath = __DIR__,
 |  | $classprefix = '\\Joomla\\CMS\\Installer\\Adapter',
 |  | $adapterfolder = 'Adapter'
 | ) |
static

Returns the global Installer object, only creating it if it doesn't already exist.

Paramètres
string | $basepath | Base Path of the adapters
string | $classprefix | Class prefix of adapters
string | $adapterfolder | Name of folder to append to base path
Renvoie
Installer An installer object
Depuis
3.1

Références class, et Factory\getContainer().

Référencé par DiscoverModel\discover(), ExtensionRemoveCommand\doExecute(), UpdateModel\finaliseUpgrade(), InstallModel\install(), UpdateModel\install(), ExtensionInstallCommand\processPathInstallation(), ManageModel\refresh(), ManageModel\remove(), et ConfigurationModel\setup().

◆ getManifest()

getManifest ( )

Get the installation manifest object

Renvoie
Manifest object
Depuis
3.1

Références $manifest.

◆ getParams()

getParams ( )

Method to parse the parameters of an extension, build the JSON string for its default parameters, and return the JSON string.

Renvoie
string JSON string of parameter values
Depuis
3.1
Note
This method must always return a JSON compliant string

Références $field, $fieldsets, $name, $value, et null.

◆ getPath()

getPath | ( | $name,
 |  | $default = null
 | ) |

Get an installer path by name

Paramètres
string | $name | Path name
string | $default | Default value
Renvoie
string Path
Depuis
3.1

Références $default, et $name.

◆ getRedirectUrl()

getRedirectUrl ( )

Get the redirect location

Renvoie
string Redirect location (or null)
Depuis
3.1

◆ install()

install ( $path = null )

Package installation method

Paramètres
string $path Path to package source folder
Renvoie
boolean True if successful
Depuis
3.1

Références $manifest, $path, $result, $this, Text\_(), Folder\exists(), Factory\getApplication(), et PluginHelper\importPlugin().

◆ isManifest()

isManifest ( $file )

Is the XML file a valid Joomla installation manifest file.

Paramètres
string $file An xmlfile path to check
Renvoie
|null A , or null if the file failed to parse
Depuis
3.1

Références $xml.

◆ isOverwrite()

isOverwrite ( )

Get the allow overwrite switch

Renvoie
boolean Allow overwrite switch
Depuis
3.1

◆ isPackageUninstall()

isPackageUninstall ( )

Get whether this installer is uninstalling extensions which are part of a package

Renvoie
boolean
Depuis
3.7.0

◆ isUpgrade()

isUpgrade ( )

Get the upgrade switch

Renvoie
boolean
Depuis
3.1

◆ loadAdapter()

loadAdapter | ( | $adapter,
 |  | $options = array()
 | ) |

Method to load an adapter instance

Paramètres
string | $adapter | Adapter name
array | $options | Adapter options
Renvoie
InstallerAdapter
Depuis
3.4
Exceptions

Références $class, $options, $this, Joomla\DI\getContainer(), Joomla\Database\getDatabase(), et Symfony\Contracts\Service\has().

◆ loadMD5Sum()

loadMD5Sum ( $filename )

Loads an MD5SUMS file into an associative array

Paramètres
string $filename Filename to load
Renvoie
array Associative array with filenames as the index and the MD5 as the value
Depuis
3.1

Références $data, et $results.

◆ parseFiles()

parseFiles | ( | \SimpleXMLElement | $element,
 |  |  | $cid = 0,
 |  |  | $oldFiles = null,
 |  |  | $oldMD5 = null
 | ) |  |

Method to parse through a files element of the installation manifest and take appropriate action.

Paramètres
\SimpleXMLElement | $element | The XML node to process
integer | $cid | Application ID of application to install to
array | $oldFiles | List of old files (SimpleXMLElement's)
array | $oldMD5 | List of old MD5 sums (indexed by filename with value as MD5)
Renvoie
boolean True on success
Depuis
3.1

Références $client, $folder, $path, Text\_(), Log\add(), Folder\create(), File\delete(), Folder\delete(), ApplicationHelper\getClientInfo(), Text\sprintf(), et Log\WARNING.

◆ parseLanguages()

parseLanguages | ( | \SimpleXMLElement | $element,
 |  |  | $cid = 0
 | ) |  |

Method to parse through a languages element of the installation manifest and take appropriate action.

Paramètres
\SimpleXMLElement | $element | The XML node to process
integer | $cid | Application ID of application to install to
Renvoie
boolean True on success
Depuis
3.1

Références $client, $folder, $path, Text\_(), Log\add(), Folder\create(), Folder\exists(), ApplicationHelper\getClientInfo(), Text\sprintf(), et Log\WARNING.

◆ parseMedia()

parseMedia | ( | \SimpleXMLElement | $element,
 |  |  | $cid = 0
 | ) |  |

Method to parse through a media element of the installation manifest and take appropriate action.

Paramètres
\SimpleXMLElement | $element | The XML node to process
integer | $cid | Application ID of application to install to
Renvoie
boolean True on success
Depuis
3.1

Références $folder, $path, Text\_(), Log\add(), Path\clean(), Folder\create(), JPATH_ROOT, null, Text\sprintf(), et Log\WARNING.

◆ parseQueries()

parseQueries ( \SimpleXMLElement $element )

Backward compatible method to parse through a queries element of the installation manifest file and take appropriate action.

Paramètres
\SimpleXMLElement $element The XML node to process
Renvoie
mixed Number of queries processed or False on error
Depuis
3.1

Références $db, $query, Log\add(), Text\sprintf(), et Log\WARNING.

◆ parseSchemaUpdates()

parseSchemaUpdates | ( | \SimpleXMLElement | $schema,
 |  |  | $eid
 | ) |  |

Method to process the updates for an item

Paramètres
\SimpleXMLElement | $schema | The XML node to process
integer | $eid | Extension Identifier
Renvoie
boolean|int Number of SQL updates executed; false on failure.
Depuis
3.1

Références $buffer, $db, $query, $version, Text\_(), Log\add(), elseif, Folder\files(), Joomla\Database\getDatabase(), Log\INFO, ParameterType\INTEGER, Text\sprintf(), et Log\WARNING.

◆ parseSQLFiles()

parseSQLFiles ( $element )

Method to extract the name of a discreet installation sql file from the installation manifest file.

Paramètres
object $element The XML node to process
Renvoie
mixed Number of queries processed or False on error
Depuis
3.1

Références $buffer, $db, $query, Text\_(), Log\add(), elseif, Text\sprintf(), et Log\WARNING.

◆ parseXMLInstallFile()

static parseXMLInstallFile ( $path )
static

Parse a XML install manifest file.

XML Root tag should be 'install' except for languages which use meta file.

Paramètres
string $path Full path to XML file.
Renvoie
array XML metadata.
Depuis
3.0.0

Références $data, $name, $path, $xml, Text\_(), et File\stripExt().

Référencé par ModuleAdapter\discover(), LibraryAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), LanguageAdapter\discover_install(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), ModuleAdapter\refreshManifestCache(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), et TemplateAdapter\storeExtension().

◆ pushStep()

pushStep ( $step )

Pushes a step onto the installer stack for rolling back steps

Paramètres
array $step Installer step
Renvoie
void
Depuis
3.1

Références $step.

◆ refreshManifestCache()

refreshManifestCache ( $eid )

Refreshes the manifest cache stored in #__extensions

Paramètres
integer $eid Extension ID
Renvoie
boolean
Depuis
3.1

Références $result, Text\_(), extension, et Text\sprintf().

◆ removeFiles()

removeFiles | ( | $element,
 |  | $cid = 0
 | ) |

Method to parse through a files element of the installation manifest and remove the files that were installed

Paramètres
object | $element | The XML node to process
integer | $cid | Application ID of application to remove from
Renvoie
boolean True on success
Depuis
3.1

Références $client, $folder, $path, $val, Log\add(), File\delete(), Folder\delete(), Folder\exists(), ApplicationHelper\getClientInfo(), null, et Log\WARNING.

◆ setOverwrite()

setOverwrite ( $state = false )

Set the allow overwrite switch

Paramètres
boolean $state Overwrite switch state
Renvoie
boolean True it state is set, false if it is not
Depuis
3.1

Références $state, et $tmp.

◆ setPackageUninstall()

setPackageUninstall ( $uninstall )

Set whether this installer is uninstalling extensions which are part of a package

Paramètres
boolean $uninstall True if a package triggered the uninstall, false otherwise
Renvoie
void
Depuis
3.7.0

◆ setPath()

setPath | ( | $name,
 |  | $value
 | ) |

Sets an installer path by name

Paramètres
string | $name | Path name
string | $value | Path
Renvoie
void
Depuis
3.1

Références $name, et $value.

◆ setRedirectUrl()

setRedirectUrl ( $newurl )

Set the redirect location

Paramètres
string $newurl New redirect location
Renvoie
void
Depuis
3.1

◆ setSchemaVersion()

setSchemaVersion | ( | \SimpleXMLElement | $schema,
 |  |  | $eid
 | ) |  |

Set the schema version for an extension by looking at its latest update

Paramètres
\SimpleXMLElement | $schema | Schema Tag
integer | $eid | Extension ID
Renvoie
void
Depuis
3.1

Références $db, $query, Folder\files(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ setUpgrade()

setUpgrade ( $state = false )

Set the upgrade switch

Paramètres
boolean $state Upgrade switch state
Renvoie
boolean True if upgrade, false otherwise
Depuis
3.1

Références $state, et $tmp.

◆ setupInstall()

setupInstall | ( | $route = 'install',
 |  | $returnAdapter = false
 | ) |

Prepare for installation: this method sets the installation directory, finds and checks the installation file and verifies the installation type.

Paramètres
string | $route | The install route being followed
boolean | $returnAdapter | Flag to return the instantiated adapter
Renvoie
boolean|InstallerAdapter InstallerAdapter object if explicitly requested otherwise boolean
Depuis
3.1

Références $params, $route, et $type.

◆ splitSql()

static splitSql ( ?string $sql )
static

Splits a string of multiple queries into an array of individual queries.

This is different than DatabaseDriver::splitSql. It supports the special CAN FAIL comment marker which indicates that a SQL statement could fail without raising an error during the installation.

Paramètres
string | null $sql Input SQL string with which to split into individual queries.
Renvoie
array
Depuis
4.2.0

Références $i, $query, $sql, $start, et elseif.

◆ uninstall()

uninstall | ( | $type,
 |  | $identifier
 | ) |

Package uninstallation method

Paramètres
string | $type | Package type
mixed | $identifier | Package identifier for adapter
Renvoie
boolean True if successful
Depuis
3.1

Références $params, $result, $this, $type, extension, Factory\getApplication(), et PluginHelper\importPlugin().

◆ update()

update ( $path = null )

Package update method

Paramètres
string $path Path to package source folder
Renvoie
boolean True if successful
Depuis
3.1

Références $manifest, $path, $result, $this, Text\_(), Folder\exists(), Factory\getApplication(), et PluginHelper\importPlugin().

Documentation des champs

◆ $extension

$extension = null

◆ $extension_message

$extension_message = null
protected

◆ $extraQuery

$extraQuery = ''

◆ $instances

$instances
staticprotected

◆ $manifest

$manifest = null

◆ $manifestClass

$manifestClass = null

◆ $message

$message = null

◆ $overwrite

$overwrite = false
protected

◆ $packageUninstall

$packageUninstall = false
protected

◆ $paths

$paths = array()
protected

◆ $redirect_url

$redirect_url = null
protected

◆ $stepStack

$stepStack = array()
protected

◆ $upgrade

$upgrade = null
protected

◆ CAN_FAIL_MARKER

const CAN_FAIL_MARKER = '/** CAN FAIL **/'
protected

A comment marker to indicate that an update SQL query may fail without triggering an update error.

Depuis
4.2.0

◆ CAN_FAIL_MARKER_LENGTH

const CAN_FAIL_MARKER_LENGTH = 16
protected

The length of the CAN_FAIL_MARKER string

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Installer.php


Joomla CMS: Référence de la classe InstallerAdapter

  • Joomla
  • CMS
  • Installer
  • InstallerAdapter
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe InstallerAdapter
+ Graphe d'héritage de InstallerAdapter:
ContainerAwareInterface DatabaseAwareInterface ComponentAdapter FileAdapter LanguageAdapter LibraryAdapter ModuleAdapter PackageAdapter PluginAdapter TemplateAdapter

Fonctions membres publiques

__construct (Installer $parent, DatabaseDriver $db, array $options=array())
discover_install ()
getDiscoverInstallSupported ()
getElement ($element=null)
getManifest ()
getName ()
getParent ()
getRoute ()
install ()
prepareDiscoverInstall ()
setManifest ($manifest)
setRoute ($route)
uninstall ($id)
update ()
__get ($name)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$manifest = null

Fonctions membres protégées

canUninstallPackageChild ($packageId)
checkExistingExtension ()
checkExtensionInFilesystem ()
copyBaseFiles ()
createExtensionRoot ()
doDatabaseTransactions ()
doLoadLanguage ($extension, $source, $base=JPATH_ADMINISTRATOR)
finaliseInstall ()
finaliseUninstall ()
getScriptClassName ()
parseQueries ()
parseOptionalTags ()
removeExtensionFiles ()
setupInstallPaths ()
setupScriptfile ()
setupUninstall ()
setupUpdates ()
storeExtension ()
triggerManifestScript ($method)

Attributs protégés

$changelogurl = null
$currentExtensionId = null
$element = null
$extension = null
$extensionMessage = ''
$manifest_script = null
$name = null
$parent = null
$route = 'install'
$supportsDiscoverInstall = true
$type

Description détaillée

Abstract adapter for the installer.

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Installer | $parent,
 |  | DatabaseDriver | $db,
 |  | array | $options = array()
 | ) |  |

Constructor

Paramètres
Installer | $parent | Parent object
DatabaseDriver | $db | Database object
array | $options | Configuration Options
Depuis
3.4

Références $key, $options, $this, $value, extension, Table\getInstance(), parent, et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Proxy for db variable.

Paramètres
string $name The name of the element
Renvoie
mixed The value of the element if set, null otherwise
Depuis
4.2.0
Obsolète:
5.0 Use getDatabase() instead of directly accessing db

Références $name, Joomla\Database\getDatabase(), et null.

◆ canUninstallPackageChild()

canUninstallPackageChild ( $packageId )
protected

Check if a package extension allows its child extensions to be uninstalled individually

Paramètres
integer $packageId The extension ID of the package to check
Renvoie
boolean
Depuis
3.7.0
Note
This method defaults to true to emulate the behavior of 3.6 and earlier which did not support this lookup

Références $manifest, $xml, Table\getInstance(), JPATH_MANIFESTS, et parent.

◆ checkExistingExtension()

checkExistingExtension ( )
protected

Method to check if the extension is already present in the database

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), extension, et Text\sprintf().

◆ checkExtensionInFilesystem()

checkExtensionInFilesystem ( )
protected

Method to check if the extension is present in the filesystem, flags the route as update if so

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), elseif, parent, et Text\sprintf().

◆ copyBaseFiles()

copyBaseFiles ( )
abstractprotected

Method to copy the extension's base files from the <files> tag(s) and the manifest file

Renvoie
void
Depuis
3.4
Exceptions

◆ createExtensionRoot()

createExtensionRoot ( )
protected

Method to create the extension root path if necessary

Renvoie
void
Depuis
3.4
Exceptions

Références Text\_(), Folder\create(), parent, et Text\sprintf().

◆ discover_install()

discover_install ( )

Generic discover_install method for extensions

Renvoie
boolean True on success
Depuis
3.4

Références $description, Text\_(), extension, name, et parent.

◆ doDatabaseTransactions()

doDatabaseTransactions ( )
protected

Method to handle database transactions for the installer

Renvoie
boolean True on success
Depuis
3.4
Exceptions

Références $result, $route, Text\_(), et parent.

◆ doLoadLanguage()

doLoadLanguage | ( | $extension,
 |  | $source,
 |  | $base = JPATH_ADMINISTRATOR
 | ) |
protected

Load language files

Paramètres
string | $extension | The name of the extension
string | $source | Path to the extension
string | $base | Base path for the extension language
Renvoie
void
Depuis
3.4

Références $base, $extension, $lang, et Factory\getLanguage().

◆ finaliseInstall()

finaliseInstall ( )
abstractprotected

Method to finalise the installation processing

Renvoie
void
Depuis
4.0.0
Exceptions

◆ finaliseUninstall()

finaliseUninstall ( )
abstractprotected

Method to finalise the uninstallation processing

Renvoie
boolean
Depuis
4.0.0
Exceptions

◆ getDiscoverInstallSupported()

getDiscoverInstallSupported ( )

Checks if the adapter supports discover_install

Renvoie
boolean
Depuis
3.4

◆ getElement()

getElement ( $element = null )

Get the filtered extension element from the manifest

Paramètres
string $element Optional element name to be converted
Renvoie
string The filtered element
Depuis
3.4

Références InputFilter\getInstance().

◆ getManifest()

getManifest ( )

Get the manifest object.

Renvoie
Manifest object
Depuis
3.4

Références $manifest.

◆ getName()

getName ( )

Get the filtered component name from the manifest

Renvoie
string The filtered name
Depuis
3.4

Références $name, et InputFilter\getInstance().

◆ getParent()

getParent ( )

Retrieves the parent installer

Renvoie
Installer
Depuis
4.0.0

◆ getRoute()

getRoute ( )

Get the install route being followed

Renvoie
string The install route
Depuis
3.4

Références $route.

◆ getScriptClassName()

getScriptClassName ( )
protected

Get the class name for the install adapter script.

Renvoie
string The class name.
Depuis
3.4

Références $className, et InputFilter\getInstance().

◆ install()

install ( )

Generic install method for extensions

Renvoie
boolean|integer The extension ID on success, boolean false on failure
Depuis
3.4

Références $description, Text\_(), extension, name, et parent.

◆ parseOptionalTags()

parseOptionalTags ( )
protected

Method to parse optional tags in the manifest

Renvoie
void
Depuis
3.1

◆ parseQueries()

parseQueries ( )
protected

Method to parse the queries specified in the <sql> tags

Renvoie
void
Depuis
3.4
Exceptions

Références $result, $this, Text\_(), elseif, et parent.

◆ prepareDiscoverInstall()

prepareDiscoverInstall ( )

Prepares the adapter for a discover_install task

Renvoie
void
Depuis
3.4

◆ removeExtensionFiles()

removeExtensionFiles ( )
abstractprotected

Removes this extension's files

Renvoie
void
Depuis
4.0.0
Exceptions

◆ setManifest()

setManifest ( $manifest )

Set the manifest object.

Paramètres
object $manifest The manifest object
Renvoie
InstallerAdapter Instance of this class to support chaining
Depuis
3.4

Références $manifest, et $this.

◆ setRoute()

setRoute ( $route )

Set the install route being followed

Paramètres
string $route The install route being followed
Renvoie
InstallerAdapter Instance of this class to support chaining
Depuis
3.4

Références $route, et $this.

◆ setupInstallPaths()

setupInstallPaths ( )
abstractprotected

Method to do any prechecks and setup the install paths for the extension

Renvoie
void
Depuis
3.4

◆ setupScriptfile()

setupScriptfile ( )
protected

Setup the manifest script file for those adapters that use it.

Renvoie
void
Depuis
3.4

Références $container, $this, class, Joomla\DI\getContainer(), Factory\getContainer(), null, parent, et JLoader\register().

◆ setupUninstall()

setupUninstall ( )
abstractprotected

Method to do any prechecks and setup the uninstall job

Renvoie
void
Depuis
4.0.0

◆ setupUpdates()

setupUpdates ( )
protected

Method to setup the update routine for the adapter

Renvoie
void
Depuis
3.4

◆ storeExtension()

storeExtension ( )
abstractprotected

Method to store the extension to the database

Renvoie
void
Depuis
3.4
Exceptions

◆ triggerManifestScript()

triggerManifestScript ( $method )
protected

Executes a custom install script method

Paramètres
string $method The install method to execute
Renvoie
boolean True on success
Depuis
3.4
Exceptions

Références $method, $this, Text\_(), parent, et Text\sprintf().

◆ uninstall()

uninstall ( $id )

Generic update method for extensions

Paramètres
integer $id The extension ID
Renvoie
boolean True on success
Depuis
4.0.0

Références $id, $this, Text\_(), Log\add(), elseif, extension, name, Text\sprintf(), et Log\WARNING.

◆ update()

update ( )

Generic update method for extensions

Renvoie
boolean|integer The extension ID on success, boolean false on failure
Depuis
3.4

Références parent.

Documentation des champs

◆ $changelogurl

$changelogurl = null
protected

◆ $currentExtensionId

$currentExtensionId = null
protected

◆ $element

$element = null
protected

◆ $extension

$extension = null
protected

◆ $extensionMessage

$extensionMessage = ''
protected

◆ $manifest

$manifest = null

◆ $manifest_script

$manifest_script = null
protected

◆ $name

$name = null
protected

◆ $parent

$parent = null
protected

◆ $route

$route = 'install'
protected

◆ $supportsDiscoverInstall

$supportsDiscoverInstall = true
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallerAdapter.php


Joomla CMS: Référence de la classe InstallerExtension

  • Joomla
  • CMS
  • Installer
  • InstallerExtension
Fonctions membres publiques | Champs de données
Référence de la classe InstallerExtension
+ Graphe d'héritage de InstallerExtension:
CMSObject

Fonctions membres publiques

__construct (\SimpleXMLElement $element=null)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Champs de données

$filename = ''
$type = ''
$id = ''
$published = false
$client = 'site'
$group = ''
$manifest_cache = null
$params = null
$namespace = null

Membres hérités additionnels

- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension object

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \SimpleXMLElement $element = null )

Constructor

Paramètres
\SimpleXMLElement $element A SimpleXMLElement from which to load data from
Depuis
3.1

Références Text\_(), Log\add(), ApplicationHelper\getClientInfo(), null, et Log\WARNING.

Documentation des champs

◆ $client

$client = 'site'

◆ $filename

$filename = ''

◆ $group

$group = ''

◆ $id

$id = ''

◆ $manifest_cache

$manifest_cache = null

◆ $namespace

$namespace = null

◆ $params

$params = null

◆ $published

$published = false

◆ $type

$type = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallerExtension.php


Joomla CMS: Référence de la classe InstallerHelper

  • Joomla
  • CMS
  • Installer
  • InstallerHelper
Fonctions membres publiques statiques | Champs de données
Référence de la classe InstallerHelper

Fonctions membres publiques statiques

static | downloadPackage ($url, $target=false)
static | unpack ($packageFilename, $alwaysReturnArray=false)
static | detectType ($packageDirectory)
static | getFilenameFromUrl ($url)
static | cleanupInstall ($package, $resultdir)
static | isChecksumValid ($packagefile, $updateObject)

Champs de données

const | HASH_NOT_VALIDATED = 0
const | HASH_VALIDATED = 1
const | HASH_NOT_PROVIDED = 2

Description détaillée

Installer helper class

Depuis
3.1

Documentation des fonctions membres

◆ cleanupInstall()

static cleanupInstall | ( | $package,
 |  | $resultdir
 | ) |
static

Clean up temporary uploaded package and unpacked extension

Paramètres
string | $package | Path to the uploaded package file
string | $resultdir | Path to the unpacked extension
Renvoie
boolean True on success
Depuis
3.1

Références Path\clean(), File\delete(), Folder\delete(), elseif, et Factory\getApplication().

Référencé par LanguagesModel\install(), ExtensionInstallCommand\processPathInstallation(), ExtensionInstallCommand\processUrlInstallation(), et UpdateCoreCommand\updateJoomlaCore().

◆ detectType()

static detectType ( $packageDirectory )
static

Method to detect the extension type from a package directory

Paramètres
string $packageDirectory Path to package directory
Renvoie
mixed Extension type string or boolean false on fail
Depuis
3.1

Références $type, $xml, Text\_(), Log\add(), Folder\files(), et Log\WARNING.

Référencé par PackageAdapter\copyBaseFiles().

◆ downloadPackage()

static downloadPackage | ( | $url,
 |  | $target = false
 | ) |
static

Downloads a package

Paramètres
string | $url | URL of file to download
string | bool | $target | Download target filename or false to get the filename from the URL
Renvoie
string|boolean Path to downloaded package or boolean false on failure
Depuis
3.1

Références $parts, $target, $url, $version, Log\add(), elseif, Factory\getApplication(), HttpFactory\getHttp(), PluginHelper\importPlugin(), Text\sprintf(), Log\WARNING, et File\write().

Référencé par UpdateCoreCommand\downloadFile(), LanguagesModel\downloadPackage(), et ExtensionInstallCommand\processUrlInstallation().

◆ getFilenameFromUrl()

static getFilenameFromUrl ( $url )
static

Gets a file name out of a url

Paramètres
string $url URL to get name from
Renvoie
string Clean version of the filename or a unique id
Depuis
3.1

Références $default, $parts, et $url.

◆ isChecksumValid()

static isChecksumValid | ( | $packagefile,
 |  | $updateObject
 | ) |
static

Return the result of the checksum of a package with the SHA256/SHA384/SHA512 tags in the update server manifest

Paramètres
string | $packagefile | Location of the package to be installed
Update | $updateObject | The Update Object
Renvoie
integer one if the hashes match, zero if hashes doesn't match, two if hashes not found
Depuis
3.9.0

Références $hash.

◆ unpack()

static unpack | ( | $packageFilename,
 |  | $alwaysReturnArray = false
 | ) |
static

Unpacks a file and verifies it as a Joomla element package Supports .gz .tar .tar.gz and .zip

Paramètres
string | $packageFilename | The uploaded package filename or install directory
boolean | $alwaysReturnArray | If should return false (and leave garbage behind) or return $retval['type']=false
Renvoie
array|boolean Array on success or boolean false on failure
Depuis
3.1

Références Path\clean(), Folder\exists(), Folder\files(), Folder\folders(), Factory\getApplication(), et null.

Référencé par PackageAdapter\copyBaseFiles(), LanguagesModel\downloadPackage(), UpdateCoreCommand\extractFile(), ExtensionInstallCommand\processPathInstallation(), et ExtensionInstallCommand\processUrlInstallation().

Documentation des champs

◆ HASH_NOT_PROVIDED

const HASH_NOT_PROVIDED = 2

◆ HASH_NOT_VALIDATED

const HASH_NOT_VALIDATED = 0

◆ HASH_VALIDATED

const HASH_VALIDATED = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Installer/InstallerHelper.php


Joomla CMS: Référence de la classe InstallerScript

  • Joomla
  • CMS
  • Installer
  • InstallerScript
Fonctions membres publiques | Attributs protégés
Référence de la classe InstallerScript

Fonctions membres publiques

preflight ($type, $parent)
getInstances ($isModule)
getParam ($name, $id=0)
setParams ($paramArray=null, $type='edit', $id=0)
getItemArray ($element, $table, $column, $identifier)
removeFiles ()
moveCliFiles ()
addDashboardMenu (string $dashboard, string $preset)

Attributs protégés

$release
$paramTable
$extension
$deleteFiles = array()
$deleteFolders = array()
$cliScriptFiles = array()
$minimumPhp
$minimumJoomla
$allowDowngrades = false

Description détaillée

Base install script for use by extensions providing helper methods for common behaviours.

Depuis
3.6

Documentation des fonctions membres

◆ addDashboardMenu()

addDashboardMenu | ( | string | $dashboard,
 |  | string | $preset
 | ) |  |

Creates the dashboard menu module

Paramètres
string | $dashboard | The name of the dashboard
string | $preset | The name of the menu preset
Renvoie
void
Exceptions

Références $model, $module, $title, Text\_(), extension, Factory\getApplication(), et Text\sprintf().

◆ getInstances()

getInstances ( $isModule )

Gets each instance of a module in the #__modules table

Paramètres
boolean $isModule True if the extension is a module as this can have multiple instances
Renvoie
array An array of ID's of the extension
Depuis
3.6

Références $db, $extension, $query, et Factory\getDbo().

◆ getItemArray()

getItemArray | ( | $element,
 |  | $table,
 |  | $column,
 |  | $identifier
 | ) |

Builds a standard select query to produce better DRY code in this script. This should produce a single unique cell which is json encoded - it will then return an associated array with this data in.

Paramètres
string | $element | The element to get from the query
string | $table | The table to search for the data in
string | $column | The column of the database to search from
mixed | $identifier | The integer id or the string
Renvoie
array Associated array containing data from the cell
Depuis
3.6

Références $db, $query, Factory\getDbo(), ParameterType\INTEGER, et ParameterType\STRING.

◆ getParam()

getParam | ( | $name,
 |  | $id = 0
 | ) |

Gets parameter value in the extensions row of the extension table

Paramètres
string | $name | The name of the parameter to be retrieved
integer | $id | The id of the item in the Param Table
Renvoie
string The parameter desired
Depuis
3.6

Références $id, $name, et $params.

◆ moveCliFiles()

moveCliFiles ( )

Moves the CLI scripts into the CLI folder in the CMS

Renvoie
void
Depuis
3.6

Références $name, JPATH_ROOT, File\move(), et Text\sprintf().

◆ preflight()

preflight | ( | $type,
 |  | $parent
 | ) |

Function called before extension installation/update/removal procedure commences

Paramètres
string | $type | The type of change (install, update or discover_install, not uninstall)
InstallerAdapter | $parent | The class calling this method
Renvoie
boolean True on success
Depuis
3.6

Références $manifest, $type, Log\add(), extension, Factory\getApplication(), Symfony\Component\Console\Command\release(), Text\sprintf(), et Log\WARNING.

◆ removeFiles()

removeFiles ( )

Remove the files and folders in the given array from

Renvoie
void
Depuis
3.6

Références $folder, File\delete(), Folder\delete(), Folder\exists(), JPATH_ROOT, et Text\sprintf().

◆ setParams()

setParams | ( | $paramArray = null,
 |  | $type = 'edit',
 |  | $id = 0
 | ) |

Sets parameter values in the extensions row of the extension table. Note that the this must be called separately for deleting and editing. Note if edit is called as a type then if the param doesn't exist it will be created

Paramètres
array | $paramArray | The array of parameters to be added/edited/removed
string | $type | The type of change to be made to the param (edit/remove)
integer | $id | The id of the item in the relevant table
Renvoie
boolean True on success
Depuis
3.6

Références $db, $id, $name, $params, $query, $this, $type, $value, elseif, Factory\getDbo(), et ParameterType\INTEGER.

Documentation des champs

◆ $allowDowngrades

$allowDowngrades = false
protected

◆ $cliScriptFiles

$cliScriptFiles = array()
protected

◆ $deleteFiles

$deleteFiles = array()
protected

◆ $deleteFolders

$deleteFolders = array()
protected

◆ $extension

$extension
protected

◆ $minimumJoomla

$minimumJoomla
protected

◆ $minimumPhp

$minimumPhp
protected

◆ $paramTable

$paramTable
protected

◆ $release

$release
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallerScript.php


Joomla CMS: Référence de l'interface InstallerScriptInterface

  • Joomla
  • CMS
  • Installer
  • InstallerScriptInterface
Fonctions membres publiques
Référence de l'interface InstallerScriptInterface
+ Graphe d'héritage de InstallerScriptInterface:
LegacyInstallerScript

Fonctions membres publiques

install (InstallerAdapter $adapter)
update (InstallerAdapter $adapter)
uninstall (InstallerAdapter $adapter)
preflight (string $type, InstallerAdapter $adapter)
postflight (string $type, InstallerAdapter $adapter)

Description détaillée

Base install script interface for use by extensions providing helper methods for common behaviours.

Depuis
4.2.0

Documentation des fonctions membres

◆ install()

install ( InstallerAdapter $adapter )

Function called after the extension is installed.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémenté dans LegacyInstallerScript.

◆ postflight()

postflight | ( | string | $type,
 |  | InstallerAdapter | $adapter
 | ) |  |

Function called after extension installation/update/removal procedure commences.

Paramètres
string | $type | The type of change (install or discover_install, update, uninstall)
InstallerAdapter | $adapter | The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémenté dans LegacyInstallerScript.

◆ preflight()

preflight | ( | string | $type,
 |  | InstallerAdapter | $adapter
 | ) |  |

Function called before extension installation/update/removal procedure commences.

Paramètres
string | $type | The type of change (install or discover_install, update, uninstall)
InstallerAdapter | $adapter | The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémenté dans LegacyInstallerScript.

◆ uninstall()

uninstall ( InstallerAdapter $adapter )

Function called after the extension is uninstalled.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémenté dans LegacyInstallerScript.

◆ update()

update ( InstallerAdapter $adapter )

Function called after the extension is updated.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémenté dans LegacyInstallerScript.

La documentation de cette interface a été générée à partir du fichier suivant :
  • InstallerScriptInterface.php


Joomla CMS: Référence de la classe LegacyInstallerScript

  • Joomla
  • CMS
  • Installer
  • LegacyInstallerScript
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe LegacyInstallerScript
+ Graphe d'héritage de LegacyInstallerScript:
InstallerScriptInterface

Fonctions membres publiques

__construct ($installerScript)
install (InstallerAdapter $adapter)
update (InstallerAdapter $adapter)
uninstall (InstallerAdapter $adapter)
preflight (string $type, InstallerAdapter $adapter)
postflight (string $type, InstallerAdapter $adapter)
__set (string $name, $value)
__get (string $name)
__call (string $name, array $arguments)

Fonctions membres privées

callOnScript (string $name, array $arguments)

Attributs privés

$installerScript

Description détaillée

Legacy installer script which delegates the methods to the internal instance when possible.

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $installerScript )
Paramètres
\stdClass $installerScript The script instance

Documentation des fonctions membres

◆ __call()

__call | ( | string | $name,
 |  | array | $arguments
 | ) |  |

Calls the function with the given name on the internal script with the given name and arguments.

Paramètres
string | $name | The name of the function
array | $arguments | The arguments
Renvoie
mixed
Depuis
4.2.0

Références $name.

◆ __get()

__get ( string $name )

Returns the variable from the internal script.

Paramètres
string $name The name of the variable
Renvoie
mixed
Depuis
4.2.0

◆ __set()

__set | ( | string | $name,
 |  |  | $value
 | ) |  |

Sets the variable to the internal script.

Paramètres
string | $name | The name of the variable
mixed | $value | The value of the variable
Renvoie
void
Depuis
4.2.0

Références $value.

◆ callOnScript()

callOnScript | ( | string | $name,
 |  | array | $arguments
 | ) |  |
private

Calls the function with the given name on the internal script with some condition checking.

Paramètres
string | $name | The name of the function
array | $arguments | The arguments
Renvoie
bool
Depuis
4.2.0

Références $name, $return, et null.

◆ install()

install ( InstallerAdapter $adapter )

Function called after the extension is installed.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémente InstallerScriptInterface.

◆ postflight()

postflight | ( | string | $type,
 |  | InstallerAdapter | $adapter
 | ) |  |

Function called after extension installation/update/removal procedure commences.

Paramètres
string | $type | The type of change (install or discover_install, update, uninstall)
InstallerAdapter | $adapter | The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémente InstallerScriptInterface.

Références $type.

◆ preflight()

preflight | ( | string | $type,
 |  | InstallerAdapter | $adapter
 | ) |  |

Function called before extension installation/update/removal procedure commences.

Paramètres
string | $type | The type of change (install or discover_install, update, uninstall)
InstallerAdapter | $adapter | The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémente InstallerScriptInterface.

Références $type.

◆ uninstall()

uninstall ( InstallerAdapter $adapter )

Function called after the extension is uninstalled.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémente InstallerScriptInterface.

◆ update()

update ( InstallerAdapter $adapter )

Function called after the extension is updated.

Paramètres
InstallerAdapter $adapter The adapter calling this method
Renvoie
boolean True on success
Depuis
4.2.0

Implémente InstallerScriptInterface.

Documentation des champs

◆ $installerScript

$installerScript
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LegacyInstallerScript.php


Joomla CMS: Référence de la classe Manifest

  • Joomla
  • CMS
  • Installer
  • Manifest
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe Manifest
+ Graphe d'héritage de Manifest:
LibraryManifest PackageManifest

Fonctions membres publiques

__construct ($xmlpath='')
loadManifestFromXml ($xmlfile)

Champs de données

$manifest_file = ''
$name = ''
$version = ''
$description = ''
$packager = ''
$packagerurl = ''
$update = ''
$filelist = array()

Fonctions membres protégées

loadManifestFromData (\SimpleXMLElement $xml)

Description détaillée

Joomla! Package Manifest File

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $xmlpath = '' )

Constructor

Paramètres
string $xmlpath Path to XML manifest file.
Depuis
3.1

Documentation des fonctions membres

◆ loadManifestFromData()

loadManifestFromData ( \SimpleXMLElement $xml )
abstractprotected

Apply manifest data from a to the object.

Paramètres
\SimpleXMLElement $xml Data to load
Renvoie
void
Depuis
3.1

◆ loadManifestFromXml()

loadManifestFromXml ( $xmlfile )

Load a manifest from a file

Paramètres
string $xmlfile Path to file to load
Renvoie
boolean
Depuis
3.1

Références $xml, et Text\sprintf().

Documentation des champs

◆ $description

$description = ''

◆ $filelist

$filelist = array()

◆ $manifest_file

$manifest_file = ''

◆ $name

$name = ''

◆ $packager

$packager = ''

◆ $packagerurl

$packagerurl = ''

◆ $update

$update = ''

◆ $version

$version = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Installer/Manifest.php


Joomla CMS: Référence de la classe Associations

  • Joomla
  • CMS
  • Language
  • Associations
Fonctions membres publiques statiques
Référence de la classe Associations

Fonctions membres publiques statiques

static | getAssociations ( $extension, $tablename, $context, $id, $pk='id', $aliasField='alias', $catField='catid', $advClause=array())
static | isEnabled ()

Description détaillée

Utility class for associations in multilang

Depuis
3.1

Documentation des fonctions membres

◆ getAssociations()

static getAssociations | ( | $extension,
 |  | $tablename,
 |  | $context,
 |  | $id,
 |  | $pk = 'id',
 |  | $aliasField = 'alias',
 |  | $catField = 'catid',
 |  | $advClause = array()
 | ) |
static

Get the associations.

Paramètres
string | $extension | The name of the component.
string | $tablename | The name of the table.
string | $context | The context
integer | $id | The primary key value.
string | $pk | The name of the primary key in the given $table.
string | $aliasField | If the table has an alias field set it here. Null to not use it
string | $catField | If the table has a catid field set it here. Null to not use it
array | $advClause | Additional advanced 'where' clause; use c as parent column key, c2 as associations column key
Renvoie
array The associated items
Depuis
3.1
Exceptions

Références $context, $db, $extension, $id, $item, $items, $query, Factory\getDbo(), et ParameterType\INTEGER.

Référencé par AdministratorService\association(), AjaxController\fetchAssociations(), ConsentBoxField\getAssignedArticleUrl(), ConsentBoxField\getAssignedMenuItemUrl(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), AssociationsHelper\getAssociations(), MenusHelper\getAssociations(), FormModel\getForm(), ContactModel\getItem(), NewsfeedModel\getItem(), ArticleModel\getItem(), TosField\getLabel(), TermsField\getLayoutData(), et FormModel\save().

◆ isEnabled()

static isEnabled ( )
static

Method to determine if the language filter Associations parameter is enabled. This works for both site and administrator.

Renvoie
boolean True if the parameter is implemented; false otherwise.
Depuis
3.2

Références $enabled, $params, PluginHelper\getPlugin(), et Multilanguage\isEnabled().

Référencé par ContactsModel\__construct(), NewsfeedsModel\__construct(), ItemsModel\__construct(), ArticlesModel\__construct(), CategoriesModel\__construct(), HtmlView\addToolbar(), AdminModel\delete(), HtmlView\display(), ConsentBoxField\getAssignedArticleUrl(), ConsentBoxField\getAssignedMenuItemUrl(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), FormModel\getForm(), ContactModel\getItem(), NewsfeedModel\getItem(), ArticleModel\getItem(), ItemModel\getItem(), ArticlesModel\getItems(), TosField\getLabel(), TermsField\getLayoutData(), LanguagesHelper\getList(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ListField\getOptions(), Menu\preprocess(), CssMenu\preprocess(), NewsfeedModel\preprocessForm(), ContactModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), FormModel\save(), AdminModel\save(), ItemModel\save(), et AssocField\setup().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Associations.php


Joomla CMS: Référence de la classe CachingLanguageFactory

  • Joomla
  • CMS
  • Language
  • CachingLanguageFactory
Fonctions membres publiques | Attributs privés statiques
Référence de la classe CachingLanguageFactory
+ Graphe d'héritage de CachingLanguageFactory:
LanguageFactory LanguageFactoryInterface

Fonctions membres publiques

createLanguage ($lang, $debug=false)
- Fonctions membres publiques hérités de LanguageFactory
createLanguage ($lang, $debug=false)

Attributs privés statiques

static $languages = array()

Description détaillée

Caching factory for creating language objects. The requested languages are cached in memory.

Depuis
4.0.0

Documentation des fonctions membres

◆ createLanguage()

createLanguage | ( | $lang,
 |  | $debug = false
 | ) |

Method to get an instance of a language.

Paramètres
string | $lang | The language to use
boolean | $debug | The debug mode
Renvoie
Language
Depuis
4.0.0

Implémente LanguageFactoryInterface.

Références Language\$debug, Language\$lang, et $languages.

Documentation des champs

◆ $languages

$languages = array()
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • CachingLanguageFactory.php


Joomla CMS: Référence de la classe Language

  • Joomla
  • CMS
  • Language
  • Language
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Language

Fonctions membres publiques

__construct ($lang=null, $debug=false)
_ ($string, $jsSafe=false, $interpretBackSlashes=true)
transliterate ($string)
getTransliterator ()
setTransliterator (callable $function)
getPluralSuffixes ($count)
getPluralSuffixesCallback ()
setPluralSuffixesCallback (callable $function)
getIgnoredSearchWords ()
getIgnoredSearchWordsCallback ()
setIgnoredSearchWordsCallback (callable $function)
getLowerLimitSearchWord ()
getLowerLimitSearchWordCallback ()
setLowerLimitSearchWordCallback (callable $function)
getUpperLimitSearchWord ()
getUpperLimitSearchWordCallback ()
setUpperLimitSearchWordCallback (callable $function)
getSearchDisplayedCharactersNumber ()
getSearchDisplayedCharactersNumberCallback ()
setSearchDisplayedCharactersNumberCallback (callable $function)
load ($extension='joomla', $basePath=JPATH_BASE, $lang=null, $reload=false, $default=true)
debugFile ($filename)
get ($property, $default=null)
getName ()
getPaths ($extension=null)
getErrorFiles ()
getTag ()
getCalendar ()
isRtl ()
setDebug ($debug)
getDebug ()
getDefault ()
setDefault ($lang)
getOrphans ()
getUsed ()
hasKey ($string)
getLocale ()
getFirstDay ()
getWeekEnd ()

Fonctions membres publiques statiques

static getInstance ($lang, $debug=false)

Fonctions membres protégées

loadLanguage ($fileName, $extension='unknown')
parse ($fileName)
getTrace ()
getCallerInfo ()

Attributs protégés

$debug = false
$default = 'en-GB'
$orphans = array()
$metadata = null
$locale = null
$lang = null
$paths = array()
$errorfiles = array()
$strings = array()
$used = array()
$counter = 0
$override = array()
$transliterator = null
$pluralSuffixesCallback = null
$ignoredSearchWordsCallback = null
$lowerLimitSearchWordCallback = null
$upperLimitSearchWordCallback = null
$searchDisplayedCharactersNumberCallback = null

Attributs protégés statiques

static $languages = array()

Description détaillée

Languages/translation handler class

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $lang = null,
 |  | $debug = false
 | ) |

Constructor activating the default information of the language.

Paramètres
string | $lang | The language
boolean | $debug | Indicates if language debugging is enabled.
Depuis
1.7.0

Class exists. Try to find -a transliterate method, -a getPluralSuffixes method, -a getIgnoredSearchWords method -a getLowerLimitSearchWord method -a getUpperLimitSearchWord method -a getSearchDisplayCharactersNumber method

Références $class, Language\$debug, Language\$default, Language\$lang, $path, Language\$paths, LanguageHelper\getMetadata(), JPATH_ADMINISTRATOR, JPATH_BASE, JPATH_SITE, Language\load(), Language\loadLanguage(), null, Language\parse(), et Language\setDebug().

Documentation des fonctions membres

◆ _()

_ | ( | $string,
 |  | $jsSafe = false,
 |  | $interpretBackSlashes = true
 | ) |

Translate function, mimics the php gettext (alias _) function.

The function checks if $jsSafe is true, then if $interpretBackslashes is true.

Paramètres
string | $string | The string to translate
boolean | $jsSafe | Make the result javascript safe
boolean $interpretBackSlashes Interpret and
Renvoie
string The translation of the string
Depuis
1.7.0

Références $info, $key, $value, elseif, Factory\getApplication(), Language\getCallerInfo(), et Language\getTrace().

◆ debugFile()

debugFile ( $filename )

Debugs a language file

Paramètres
string $filename Absolute path to the file to debug
Renvoie
integer A count of the number of parsing errors
Depuis
3.6.3
Exceptions

Références Language\$debug, $key, elseif, Language\getDebug(), et null.

Référencé par Language\parse().

◆ get()

get | ( | $property,
 |  | $default = null
 | ) |

Get a metadata language property.

Paramètres
string | $property | The name of the property.
mixed | $default | The default value.
Renvoie
mixed The value of the property.
Depuis
1.7.0

Références Language\$default.

◆ getCalendar()

getCalendar ( )

Getter for the calendar type

Renvoie
string The calendar type.
Depuis
3.7.0

◆ getCallerInfo()

getCallerInfo ( )
protected

Determine who called Language or Text.

Renvoie
array Caller information.
Depuis
1.7.0

Références $class, $info, $step, et class.

Référencé par Language\_().

◆ getDebug()

getDebug ( )

Get the Debug property.

Renvoie
boolean True is in debug mode.
Depuis
1.7.0

Références Language\$debug.

Référencé par Language\debugFile().

◆ getDefault()

getDefault ( )

Get the default language code.

Renvoie
string Language code.
Depuis
1.7.0

Références Language\$default.

◆ getErrorFiles()

getErrorFiles ( )

Get a list of language files that are in error state.

Renvoie
array
Depuis
1.7.0

Références Language\$errorfiles.

◆ getFirstDay()

getFirstDay ( )

Get the first day of the week for this language.

Renvoie
integer The first day of the week according to the language
Depuis
1.7.0

◆ getIgnoredSearchWords()

getIgnoredSearchWords ( )

Returns an array of ignored search words

Renvoie
array The array of ignored search words.
Depuis
1.7.0

Références null.

◆ getIgnoredSearchWordsCallback()

getIgnoredSearchWordsCallback ( )

Getter for ignoredSearchWordsCallback function.

Renvoie
callable Function name or the actual function.
Depuis
1.7.0

Références Language\$ignoredSearchWordsCallback.

◆ getInstance()

static getInstance | ( | $lang,
 |  | $debug = false
 | ) |
static

Returns a language object.

Paramètres
string | $lang | The language to use.
boolean | $debug | The debug mode.
Renvoie
Language The Language object.
Depuis
1.7.0
Obsolète:
5.0 Use the language factory instead

Références Language\$debug, Language\$lang, $languages, class, et Factory\getContainer().

Référencé par OverrideModel\getForm(), CMSApplication\initialiseApp(), PlgSystemLanguageFilter\parseRule(), MessageModel\save(), InstalledController\setDefault(), OutputFilter\stringURLSafe(), et InstalledController\switchAdminLanguage().

◆ getLocale()

getLocale ( )

Get the language locale based on current language.

Renvoie
array The locale according to the language.
Depuis
1.7.0

Références Language\$locale.

◆ getLowerLimitSearchWord()

getLowerLimitSearchWord ( )

Returns a lower limit integer for length of search words

Renvoie
integer The lower limit integer for length of search words (3 if no value was set for a specific language).
Depuis
1.7.0

Références null.

◆ getLowerLimitSearchWordCallback()

getLowerLimitSearchWordCallback ( )

Getter for lowerLimitSearchWordCallback function

Renvoie
callable Function name or the actual function.
Depuis
1.7.0

Références Language\$lowerLimitSearchWordCallback.

◆ getName()

getName ( )

Getter for Name.

Renvoie
string Official name element of the language.
Depuis
1.7.0

◆ getOrphans()

getOrphans ( )

Get the list of orphaned strings if being tracked.

Renvoie
array Orphaned text.
Depuis
1.7.0

Références Language\$orphans.

◆ getPaths()

getPaths ( $extension = null )

Get a list of language files that have been loaded.

Paramètres
string $extension An optional extension name.
Renvoie
array
Depuis
1.7.0

Références $extension, et Language\$paths.

◆ getPluralSuffixes()

getPluralSuffixes ( $count )

Returns an array of suffixes for plural rules.

Paramètres
integer $count The count number the rule is for.
Renvoie
array The array of suffixes.
Depuis
1.7.0

Références $count, et null.

◆ getPluralSuffixesCallback()

getPluralSuffixesCallback ( )

Getter for pluralSuffixesCallback function.

Renvoie
callable Function name or the actual function.
Depuis
1.7.0

Références Language\$pluralSuffixesCallback.

◆ getSearchDisplayedCharactersNumber()

getSearchDisplayedCharactersNumber ( )

Returns the number of characters displayed in search results.

Renvoie
integer The number of characters displayed (200 if no value was set for a specific language).
Depuis
1.7.0

Références null.

◆ getSearchDisplayedCharactersNumberCallback()

getSearchDisplayedCharactersNumberCallback ( )

Getter for searchDisplayedCharactersNumberCallback function

Renvoie
callable Function name or the actual function.
Depuis
1.7.0

Références Language\$searchDisplayedCharactersNumberCallback.

◆ getTag()

getTag ( )

Getter for the language tag (as defined in RFC 3066)

Renvoie
string The language tag.
Depuis
1.7.0

◆ getTrace()

getTrace ( )
protected

Get a back trace.

Renvoie
array
Depuis
4.0.0

Référencé par Language\_().

◆ getTransliterator()

getTransliterator ( )

Getter for transliteration function

Renvoie
callable The transliterator function
Depuis
1.7.0

Références Language\$transliterator.

◆ getUpperLimitSearchWord()

getUpperLimitSearchWord ( )

Returns an upper limit integer for length of search words

Renvoie
integer The upper limit integer for length of search words (200 if no value was set or if default value is < 200).
Depuis
1.7.0

Références null.

◆ getUpperLimitSearchWordCallback()

getUpperLimitSearchWordCallback ( )

Getter for upperLimitSearchWordCallback function

Renvoie
callable Function name or the actual function.
Depuis
1.7.0

Références Language\$upperLimitSearchWordCallback.

◆ getUsed()

getUsed ( )

Get the list of used strings.

Used strings are those strings requested and found either as a string or a constant.

Renvoie
array Used strings.
Depuis
1.7.0

Références Language\$used.

◆ getWeekEnd()

getWeekEnd ( )

Get the weekends days for this language.

Renvoie
string The weekend days of the week separated by a comma according to the language
Depuis
3.2

◆ hasKey()

hasKey ( $string )

Determines is a key exists.

Paramètres
string $string The key to check.
Renvoie
boolean True, if the key exists.
Depuis
1.7.0

Références null.

Référencé par Text\alt().

◆ isRtl()

isRtl ( )

Get the RTL property.

Renvoie
boolean True is it an RTL language.
Depuis
1.7.0

◆ load()

load | ( | $extension = 'joomla',
 |  | $basePath = JPATH_BASE,
 |  | $lang = null,
 |  | $reload = false,
 |  | $default = true
 | ) |

Loads a single language file and appends the results to the existing strings

Paramètres
string | $extension | The extension for which a language file should be loaded.
string | $basePath | The basepath to use.
string | $lang | The language to load, default null for the current language.
boolean | $reload | Flag that will force a language to be reloaded if set to true.
boolean | $default | Flag that force the default language to be loaded if the current does not exist.
Renvoie
boolean True if the file has successfully loaded.
Depuis
1.7.0

Références $basePath, Language\$default, $extension, Language\$lang, $path, $result, LanguageHelper\getLanguagePath(), et Language\loadLanguage().

Référencé par Language\__construct().

◆ loadLanguage()

loadLanguage | ( | $fileName,
 |  | $extension = 'unknown'
 | ) |
protected

Loads a language file.

This method will not note the successful loading of a file - use load() instead.

Paramètres
string | $fileName | The name of the file.
string | $extension | The name of the extension.
Renvoie
boolean True if new strings have been added to the language
Voir également
Language::load()
Depuis
1.7.0

Références $extension, $result, Language\$strings, counter, et Language\parse().

Référencé par Language\__construct(), et Language\load().

◆ parse()

parse ( $fileName )
protected

Parses a language file.

Paramètres
string $fileName The name of the file.
Renvoie
array The array of parsed strings.
Depuis
1.7.0

Références Language\$strings, Language\debugFile(), et LanguageHelper\parseIniFile().

Référencé par Language\__construct(), et Language\loadLanguage().

◆ setDebug()

setDebug ( $debug )

Set the Debug property.

Paramètres
boolean $debug The debug setting.
Renvoie
boolean Previous value.
Depuis
1.7.0

Références Language\$debug.

Référencé par Language\__construct().

◆ setDefault()

setDefault ( $lang )

Set the default language code.

Paramètres
string $lang The language code.
Renvoie
string Previous value.
Depuis
1.7.0

Références Language\$default, et Language\$lang.

◆ setIgnoredSearchWordsCallback()

setIgnoredSearchWordsCallback ( callable $function )

Setter for the ignoredSearchWordsCallback function

Paramètres
callable $function Function name or actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$ignoredSearchWordsCallback.

◆ setLowerLimitSearchWordCallback()

setLowerLimitSearchWordCallback ( callable $function )

Setter for the lowerLimitSearchWordCallback function.

Paramètres
callable $function Function name or actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$lowerLimitSearchWordCallback.

◆ setPluralSuffixesCallback()

setPluralSuffixesCallback ( callable $function )

Set the pluralSuffixes function.

Paramètres
callable $function Function name or actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$pluralSuffixesCallback.

◆ setSearchDisplayedCharactersNumberCallback()

setSearchDisplayedCharactersNumberCallback ( callable $function )

Setter for the searchDisplayedCharactersNumberCallback function.

Paramètres
callable $function Function name or the actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$searchDisplayedCharactersNumberCallback.

◆ setTransliterator()

setTransliterator ( callable $function )

Set the transliteration function.

Paramètres
callable $function Function name or the actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$transliterator.

◆ setUpperLimitSearchWordCallback()

setUpperLimitSearchWordCallback ( callable $function )

Setter for the upperLimitSearchWordCallback function

Paramètres
callable $function Function name or the actual function.
Renvoie
callable The previous function.
Depuis
1.7.0

Références $function, et Language\$upperLimitSearchWordCallback.

◆ transliterate()

transliterate ( $string )

Transliterate function

This method processes a string and replaces all accented UTF-8 characters by unaccented ASCII-7 "equivalents".

Paramètres
string $string The string to transliterate.
Renvoie
string The transliteration of the string.
Depuis
1.7.0

Références null, StringHelper\strtolower(), et Transliterate\utf8_latin_to_ascii().

Documentation des champs

◆ $counter

$counter = 0
protected

◆ $debug

$debug = false
protected

Référencé par Language\__construct(), LanguageFactory\createLanguage(), CachingLanguageFactory\createLanguage(), Language\debugFile(), Language\getDebug(), Language\getInstance(), LanguageHelper\parseIniFile(), et Language\setDebug().

◆ $default

$default = 'en-GB'
protected

Référencé par Language\__construct(), Language\get(), Language\getDefault(), Language\load(), et Language\setDefault().

◆ $errorfiles

$errorfiles = array()
protected

Référencé par Language\getErrorFiles().

◆ $ignoredSearchWordsCallback

$ignoredSearchWordsCallback = null
protected

Référencé par Language\getIgnoredSearchWordsCallback(), et Language\setIgnoredSearchWordsCallback().

◆ $lang

$lang = null
protected

Référencé par Text\_(), Language\__construct(), LanguageFactory\createLanguage(), CachingLanguageFactory\createLanguage(), LanguageHelper\exists(), Language\getInstance(), LanguageHelper\getMetadata(), Language\load(), Text\passSprintf(), Text\plural(), Text\printf(), Language\setDefault(), et Text\sprintf().

◆ $languages

$languages = array()
staticprotected

Référencé par LanguageHelper\createLanguageList(), et LanguageHelper\parseLanguageFiles().

◆ $locale

$locale = null
protected

Référencé par Language\getLocale().

◆ $lowerLimitSearchWordCallback

$lowerLimitSearchWordCallback = null
protected

Référencé par Language\getLowerLimitSearchWordCallback(), et Language\setLowerLimitSearchWordCallback().

◆ $metadata

$metadata = null
protected

Référencé par LanguageHelper\createLanguageList(), LanguageHelper\parseLanguageFiles(), et LanguageHelper\parseXMLLanguageFile().

◆ $orphans

$orphans = array()
protected

Référencé par Language\getOrphans().

◆ $override

$override = array()
protected

◆ $paths

$paths = array()
protected

Référencé par Language\__construct(), LanguageHelper\exists(), et Language\getPaths().

◆ $pluralSuffixesCallback

$pluralSuffixesCallback = null
protected

Référencé par Language\getPluralSuffixesCallback(), et Language\setPluralSuffixesCallback().

◆ $searchDisplayedCharactersNumberCallback

$searchDisplayedCharactersNumberCallback = null
protected

Référencé par Language\getSearchDisplayedCharactersNumberCallback(), et Language\setSearchDisplayedCharactersNumberCallback().

◆ $strings

$strings = array()
protected

Référencé par Language\loadLanguage(), Language\parse(), LanguageHelper\parseIniFile(), et LanguageHelper\saveToIniFile().

◆ $transliterator

$transliterator = null
protected

Référencé par Language\getTransliterator(), et Language\setTransliterator().

◆ $upperLimitSearchWordCallback

$upperLimitSearchWordCallback = null
protected

Référencé par Language\getUpperLimitSearchWordCallback(), et Language\setUpperLimitSearchWordCallback().

◆ $used

$used = array()
protected

Référencé par Language\getUsed().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Language/Language.php


Joomla CMS: Référence de la classe LanguageFactory

  • Joomla
  • CMS
  • Language
  • LanguageFactory
Fonctions membres publiques
Référence de la classe LanguageFactory
+ Graphe d'héritage de LanguageFactory:
LanguageFactoryInterface CachingLanguageFactory

Fonctions membres publiques

createLanguage ($lang, $debug=false)

Description détaillée

Default factory for creating language objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createLanguage()

createLanguage | ( | $lang,
 |  | $debug = false
 | ) |

Method to get an instance of a language.

Paramètres
string | $lang | The language to use
boolean | $debug | The debug mode
Renvoie
Language
Depuis
4.0.0

Implémente LanguageFactoryInterface.

Références Language\$debug, et Language\$lang.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageFactory.php


Joomla CMS: Référence de l'interface LanguageFactoryInterface

  • Joomla
  • CMS
  • Language
  • LanguageFactoryInterface
Fonctions membres publiques
Référence de l'interface LanguageFactoryInterface
+ Graphe d'héritage de LanguageFactoryInterface:
LanguageFactory CachingLanguageFactory

Fonctions membres publiques

createLanguage ($lang, $debug=false)

Description détaillée

Interface defining a factory which can create language objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createLanguage()

createLanguage | ( | $lang,
 |  | $debug = false
 | ) |

Method to get an instance of a language.

Paramètres
string | $lang | The language to use
boolean | $debug | The debug mode
Renvoie
Language
Depuis
4.0.0

Implémenté dans CachingLanguageFactory, et LanguageFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LanguageFactoryInterface.php


Joomla CMS: Référence de la classe LanguageHelper

  • Joomla
  • CMS
  • Language
  • LanguageHelper
Fonctions membres publiques statiques
Référence de la classe LanguageHelper

Fonctions membres publiques statiques

static | createLanguageList ($actualLanguage, $basePath=JPATH_BASE, $caching=false, $installed=false)
static | detectLanguage ()
static | parseIniFile ($fileName, $debug=false)
static | saveToIniFile ($fileName, array $strings)
static | exists ($lang, $basePath=JPATH_BASE)
static | getMetadata ($lang)
static | getKnownLanguages ($basePath=JPATH_BASE)
static | getLanguagePath ($basePath=JPATH_BASE, $language=null)
static | parseLanguageFiles ($dir=null)
static | parseXMLLanguageFile ($path)

Description détaillée

Language helper class

Depuis
1.5

Documentation des fonctions membres

◆ createLanguageList()

static createLanguageList | ( | $actualLanguage,
 |  | $basePath = JPATH_BASE,
 |  | $caching = false,
 |  | $installed = false
 | ) |
static

Builds a list of the system languages which can be used in a select option

Paramètres
string | $actualLanguage | Client key for the area
string | $basePath | Base path to use
boolean | $caching | True if caching is used
boolean | $installed | Get only installed languages
Renvoie
array List of system languages
Depuis
1.5

Références $basePath, $clientId, $language, Language\$languages, $list, Language\$metadata, JPATH_ADMINISTRATOR, et null.

Référencé par LoginHelper\getLanguageList(), SetupModel\getLanguages(), et LanguageField\getOptions().

◆ detectLanguage()

static detectLanguage ( )
static

Tries to detect the language.

Renvoie
string locale or null if not found
Depuis
1.5

Références elseif.

Référencé par CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), SetupModel\getLanguages(), LanguageField\getNativeLanguage(), InstallationApplication\initialiseApp(), et SiteApplication\initialiseApp().

◆ exists()

static exists | ( | $lang,
 |  | $basePath = JPATH_BASE
 | ) |
static

Checks if a language exists.

This is a simple, quick check for the directory that should contain language files for the given user.

Paramètres
string | $lang | Language to check.
string | $basePath | Optional path to check.
Renvoie
boolean True if the language exists.
Depuis
3.7.0

Références $basePath, Language\$lang, $path, et Language\$paths.

Référencé par DatabaseModel\initialise(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), et SetupModel\validateDbConnection().

◆ getKnownLanguages()

static getKnownLanguages ( $basePath = JPATH_BASE )
static

Returns a list of known languages for an area

Paramètres
string $basePath The basepath to use
Renvoie
array key/value pair with the language file and real name.
Depuis
3.7.0

Références $basePath.

Référencé par AdminLanguage\existing(), LanguageclientField\getOptions(), et PlgSystemLanguagecode\onContentPrepareForm().

◆ getLanguagePath()

static getLanguagePath | ( | $basePath = JPATH_BASE,
 |  | $language = null
 | ) |
static

Get the path to a language

Paramètres
string | $basePath | The basepath to use.
string | $language | The language tag.
Renvoie
string language related path or null.
Depuis
3.7.0

Références $basePath, et $language.

Référencé par Users\admin_language(), InstallationApplication\getLocaliseAdmin(), InstalledModel\getPath(), LanguagesModel\getPath(), PlgSampledataMultilang\getPath(), Users\language(), et Language\load().

◆ getMetadata()

static getMetadata ( $lang )
static

Returns an associative array holding the metadata.

Paramètres
string $lang The name of the language.
Renvoie
mixed If $lang exists return key/value pair with the language metadata, otherwise return NULL.
Depuis
3.7.0

Références Language\$lang, $result, JPATH_BASE, et null.

Référencé par Language\__construct(), et LanguagesHelper\getList().

◆ parseIniFile()

static parseIniFile | ( | $fileName,
 |  | $debug = false
 | ) |
static

Parse strings from a language file.

Paramètres
string | $fileName | The language ini file path.
boolean | $debug | If set to true debug language ini file.
Renvoie
array The strings parsed.
Depuis
3.9.0

Références Language\$debug, Language\$strings, et null.

Référencé par OverridesModel\delete(), OverrideModel\getItem(), OverridesModel\getOverrides(), Language\parse(), StringsModel\refresh(), et OverrideModel\save().

◆ parseLanguageFiles()

static parseLanguageFiles ( $dir = null )
static

Searches for language directories within a certain base dir.

Paramètres
string $dir directory of files.
Renvoie
array Array holding the found languages as filename => real name pairs.
Depuis
3.7.0

Références $dir, Language\$languages, et Language\$metadata.

◆ parseXMLLanguageFile()

static parseXMLLanguageFile ( $path )
static

Parse XML file for language information.

Paramètres
string $path Path to the XML files.
Renvoie
array Array holding the found metadata as a key => value pair.
Depuis
3.7.0
Exceptions

Références Language\$metadata, $path, et $xml.

Référencé par Users\admin_language(), LanguageAdapter\createContentLanguage(), Users\language(), et InstalledController\switchAdminLanguage().

◆ saveToIniFile()

static saveToIniFile | ( |  | $fileName,
 |  | array | $strings
 | ) |  |
static

Save strings to a language file.

Paramètres
string | $fileName | The language ini file path.
array | $strings | The array of strings.
Renvoie
boolean True if saved, false otherwise.
Depuis
3.7.0

Références $key, Language\$strings, et File\write().

Référencé par OverridesModel\delete(), et OverrideModel\save().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Language/LanguageHelper.php


Joomla CMS: Référence de la classe Multilanguage

  • Joomla
  • CMS
  • Language
  • Multilanguage
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe Multilanguage

Fonctions membres publiques statiques

static | isEnabled (CMSApplication $app=null, DatabaseInterface $db=null)
static | getSiteHomePages (DatabaseInterface $db=null)

Attributs publics statiques

static $enabled = false

Description détaillée

Utility class for multilang

Depuis
2.5.4

Documentation des fonctions membres

◆ getSiteHomePages()

static getSiteHomePages ( DatabaseInterface $db = null )
static

Method to return a list of language home page menu items.

Paramètres
DatabaseInterface $db The database
Renvoie
array of menu objects.
Depuis
3.5

Références $db, $query, Factory\getDbo(), et null.

Référencé par HtmlView\display(), et AssociationHelper\displayAssociations().

◆ isEnabled()

static isEnabled | ( | CMSApplication | $app = null,
 |  | DatabaseInterface | $db = null
 | ) |  |
static

Method to determine if the language filter plugin is enabled. This works for both site and administrator.

Paramètres
CMSApplication | $app | The application
DatabaseInterface | $db | The database
Renvoie
boolean True if site is supporting multiple languages; false otherwise.
Depuis
2.5.4

Références $app, $db, $enabled, $query, Factory\getApplication(), et Factory\getDbo().

Référencé par SitePathway\__construct(), Categories\__construct(), Categories\_load(), ContactModel\buildContactExtendedData(), HtmlView\display(), JsonapiView\displayItem(), RouteHelper\findItem(), RouteHelper\getArticleRoute(), ConsentBoxField\getAssignedMenuItemUrl(), RouteHelper\getCategoryRoute(), RouteHelper\getContactRoute(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), MenuHelper\getDefault(), FieldsHelper\getFields(), ProfileModel\getForm(), UserModel\getForm(), RegistrationModel\getForm(), BreadcrumbsHelper\getHome(), SiteMenu\getItems(), PrivacyField\getLayoutData(), LanguagesHelper\getList(), LoginModel\getMenuLanguage(), MenusHelper\getMenuLinks(), RouteHelper\getNewsfeedRoute(), ListField\getOptions(), TagField\getOptions(), LoginHelper\getRegistrationUrl(), PrivacyStatusHelper\getRequestFormPublished(), LoginHelper\getReturnUrl(), RouteHelper\getRoute(), Helper\isCommon(), Associations\isEnabled(), ContactModel\loadFormData(), RegistrationModel\loadFormData(), UserController\login(), UserController\logout(), UserController\menulogout(), ArticleModel\populateState(), ArticlesModel\populateState(), SuggestionsModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), SearchModel\populateState(), JsonapiView\prepareItem(), MenuRules\preprocess(), FormModel\preprocessForm(), StyleModel\preprocessForm(), FormModel\save(), ArticleController\save(), Filter\select(), InstalledController\setDefault(), Filter\slider(), Helper\stem(), Menu\store(), et Helper\tokenize().

Documentation des champs

◆ $enabled

$enabled = false
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Multilanguage.php


Joomla CMS: Référence de la classe Text

  • Joomla
  • CMS
  • Language
  • Text
Fonctions membres publiques statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe Text

Fonctions membres publiques statiques

static | _ ($string, $jsSafe=false, $interpretBackSlashes=true, $script=false)
static | alt ($string, $alt, $jsSafe=false, $interpretBackSlashes=true, $script=false)
static | plural ($string, $n)
static | sprintf ($string)
static | printf ($string)
static | script ($string=null, $jsSafe=false, $interpretBackSlashes=true)
static | getScriptStrings ()

Attributs protégés statiques

static $strings = array()

Fonctions membres privées statiques

static passSprintf (&$string, $jsSafe=false, $interpretBackSlashes=true, $script=false)

Description détaillée

Text handling class.

Depuis
1.7.0

Documentation des fonctions membres

◆ _()

static _ | ( | $string,
 |  | $jsSafe = false,
 |  | $interpretBackSlashes = true,
 |  | $script = false
 | ) |
static

Translates a string into the current language.

Examples: ‘<script>alert(Joomla.Text._(’<?php echo Text::_("JDEFAULT", array("script"=>true)); ?>'));</script>‘ will generate an alert message containing 'Default’ <?php echo Text::_("JDEFAULT"); ?> will generate a 'Default' string

Paramètres
string | $string | The string to translate.
mixed | $jsSafe | Boolean: Make the result javascript safe.
boolean $interpretBackSlashes To interpret backslashes (\=\,
=carriage return, =tabulation)
boolean | $script | To indicate that the string will be push in the javascript language store
Renvoie
string The translated string or the key if $script is true
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références Language\$lang, $script, $strings, et Factory\getLanguage().

Référencé par JsonResponse\__construct(), Response\__construct(), TransitionButton\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), StageController\__construct(), TransitionController\__construct(), DisplayController\__construct(), TaskOption\__construct(), TransitionsController\__construct(), StagesController\__construct(), ActionButton\__construct(), Authentication\__construct(), InstallerExtension\__construct(), Pagination\_buildDataObject(), FileStorage\_deleteFolder(), ExtensionAdapter\_endElement(), HelpButton\_getCommand(), InstallModel\_getPackageFromFolder(), InstallModel\_getPackageFromUpload(), InstallModel\_getPackageFromUrl(), Pagination\_list_footer(), Editor\_loadEditor(), HtmlView\_prepareDocument(), ContactController\_sendEmail(), Installer\abort(), JGrid\action(), Access\actions(), LinksController\activate(), RegistrationModel\activate(), UsersController\activate(), LinkModel\activate(), UserModel\activate(), UserHelper\activateUser(), ModuleController\add(), FormController\add(), InstallerScript\addDashboardMenu(), Users\addNote(), Shortcut\addShortcuts(), HtmlView\addToolbar(), FormView\addToolbar(), ListView\addToolbar(), InstallController\ajax_upload(), LevelController\allowEdit(), UpdateModel\applyUpdateSite(), ActionsDropdown\archive(), MethodController\assertCanDelete(), MethodController\assertCanEdit(), MethodsController\assertLoggedInUser(), MethodController\assertLoggedInUser(), TasksModel\attachTaskOptions(), SiteApplication\authorise(), IndexerController\batch(), LinksController\batch(), FormController\batch(), AdminModel\batch(), UserModel\batch(), AdminModel\batchAccess(), ItemModel\batchCopy(), ModuleModel\batchCopy(), CategoryModel\batchCopy(), FieldModel\batchCopy(), AdminModel\batchLanguage(), ArticleModel\batchMove(), ModuleModel\batchMove(), ItemModel\batchMove(), AdminModel\batchMove(), CategoryModel\batchMove(), FieldModel\batchMove(), Modules\batchOptions(), UserModel\batchReset(), AdminModel\batchTag(), ContactModel\batchUser(), UserModel\batchUser(), Joomla\CMS\MVC\Model\batchWorkflowStage(), StyleTable\bind(), Menu\bind(), BannerTable\bind(), User\bind(), UserModel\block(), PhpSetting\boolean(), Select\booleanlist(), LanguageHelper\branchLanguageTitle(), Number\bytes(), Behavior\calendartranslation(), CallbackController\callback(), LevelModel\canDelete(), StageModel\canDelete(), TemplateHelper\canUpload(), MediaHelper\canUpload(), UpdateController\captive(), Category\categories(), UsersController\changeBlock(), Language\check(), UpdateSite\check(), Usergroup\check(), LinkTable\check(), MenuType\check(), MessageTable\check(), MapTable\check(), Update\check(), MenuTable\check(), ViewLevel\check(), NewsfeedTable\check(), CoreContent\check(), Extension\check(), ClientTable\check(), StyleTable\check(), BannerTable\check(), Asset\check(), GroupTable\check(), Menu\check(), StageTable\check(), WorkflowTable\check(), Module\check(), FieldTable\check(), ContactTable\check(), Category\check(), Content\check(), User\check(), CssMenu\check(), AdminModel\checkCategoryId(), ApiController\checkContent(), MediaController\checkContent(), LocalAdapter\checkContent(), SetConfigurationCommand\checkDb(), DatabaseHelper\checkDbServerParameters(), FieldModel\checkDefaultValue(), TemplateAdapter\checkExistingExtension(), ModuleAdapter\checkExistingExtension(), PluginAdapter\checkExistingExtension(), InstallerAdapter\checkExistingExtension(), LibraryAdapter\checkExtensionInFilesystem(), PackageAdapter\checkExtensionInFilesystem(), InstallerAdapter\checkExtensionInFilesystem(), FormModel\checkin(), AssociationsController\checkin(), GroupsController\checkin(), FormModel\checkout(), DatabaseHelper\checkRemoteDbHost(), Session\checkToken(), BaseController\checkToken(), CMSApplication\checkUserRequireReset(), JSONController\checkValidToken(), TemplateModel\child(), Stream\chmod(), AssociationsModel\clean(), BannerModel\click(), Banner\clients(), Languages\clients(), Email\cloak(), Stream\close(), CategoryView\commonCategoryDisplay(), TemplateModel\copy(), TemplateAdapter\copyBaseFiles(), PluginAdapter\copyBaseFiles(), ModuleAdapter\copyBaseFiles(), PackageAdapter\copyBaseFiles(), ComponentAdapter\copyBaseFiles(), TemplateModel\copyFile(), Installer\copyFiles(), TemplateModel\copyStyles(), Icon\create(), Folder\create(), ConfigurationModel\createConfiguration(), DatabaseModel\createDatabase(), ComponentAdapter\createExtensionRoot(), InstallerAdapter\createExtensionRoot(), TemplateController\createFile(), TemplateModel\createFile(), TemplateModel\createFolder(), TemplateModel\createOverride(), DatabaseModel\createTables(), Help\createUrl(), HTMLHelper\date(), Date\dayToString(), InstallationApplication\debugLanguage(), OverridesController\delete(), GroupsController\delete(), StageTable\delete(), WorkflowTable\delete(), DisplayController\delete(), MessageModel\delete(), MapsModel\delete(), LevelController\delete(), IndexModel\delete(), StyleModel\delete(), UpdatesitesModel\delete(), AdminController\delete(), HistoryModel\delete(), UpdatesitesController\delete(), StyleTable\delete(), TracksModel\delete(), MenuType\delete(), OverridesModel\delete(), MfaTable\delete(), MethodController\delete(), GroupModel\delete(), Folder\delete(), UserModel\delete(), ModuleModel\delete(), TemplateController\delete(), AdminModel\delete(), MethodsModel\deleteAll(), TemplateModel\deleteFile(), ApiController\deleteFiles(), TemplateModel\deleteFolder(), InstallerHelper\detectType(), DiscoverModel\discover_install(), InstallerAdapter\discover_install(), Installer\discover_install(), LanguageAdapter\discover_install(), Dispatcher\dispatch(), LegacyComponentDispatcher\dispatch(), AdministratorApplication\dispatch(), InstallationApplication\dispatch(), CategoryFeedView\display(), FeedView\display(), TextView\display(), JsonView\display(), DisplayController\display(), XmlView\display(), CategoriesView\display(), HtmlView\display(), MethodsController\display(), Editor\display(), JsonapiView\displayList(), PlgUserProfile\dob(), InstallerAdapter\doDatabaseTransactions(), LanguagesModel\downloadPackage(), StylesController\duplicate(), ModulesController\duplicate(), ActionsDropdown\duplicate(), StyleModel\duplicate(), ModuleModel\duplicate(), LinksController\duplicateUrls(), LinkModel\duplicateUrls(), ProfileController\edit(), OverrideController\edit(), AssociationController\edit(), TemplateController\edit(), Icon\edit(), Dropdown\edit(), FormController\edit(), Users\editor(), Stream\eof(), ApiController\execute(), Joomla\CMS\MVC\Model\executeTransition(), WorkflowStage\existing(), Query\explained(), MenuController\exportXml(), TemplateModel\extractArchive(), ActionsDropdown\feature(), ContactModel\featured(), ArticleModel\featured(), AjaxController\fetchAssociations(), DatabaseModel\fetchSchemaCache(), Stream\filesize(), Users\filterNotes(), FileAdapter\finaliseInstall(), ModuleAdapter\finaliseInstall(), ComponentAdapter\finaliseUninstall(), UpdateModel\finaliseUpgrade(), Installer\findManifest(), CredentialRepository\formatDate(), MethodsModel\formatRelative(), ListHelper\genericordering(), Stream\get_meta_data(), UsersHelper\getActiveOptions(), ModulesModel\getActivePositions(), ProviderManager\getAdapter(), TemplateModel\getArchive(), AssociationsHelper\getAssociationHtmlList(), TracksModel\getBaseName(), CapabilitiesModel\getCapabilities(), TracksModel\getCategoryName(), TracksModel\getClientName(), TemplatesHelper\getClientOptions(), ModulesHelper\getClientOptions(), InstallerHelper\getClientOptions(), BannersHelper\getClientOptions(), DebugHelper\getComponents(), ConfigHelper\getComponentsWithConfig(), TracksModel\getContent(), ContactComponent\getContexts(), ContentComponent\getContexts(), Joomlaupdate\getCoreUpdateNotification(), ActionlogsHelper\getCsvData(), CacheModel\getData(), PlgSystemTasknotification\getDataFromTask(), MessagesModel\getExtensionName(), SysinfoModel\getExtensions(), InstallerHelper\getExtensionTypes(), FeedHelper\getFeed(), TemplateModel\getFiles(), ActionlogsModel\getFilterForm(), FinderIndexCommand\getFilters(), TemplateModel\getFont(), OverrideModel\getForm(), TemplateModel\getForm(), ContenthistoryHelper\getFormValues(), MenuField\getGroups(), GroupedlistField\getGroups(), WorkflowstageField\getGroups(), TemplatestyleField\getGroups(), ChromestyleField\getGroups(), BreadcrumbsHelper\getHome(), ActionlogsHelper\getHumanReadableLogMessage(), TemplateModel\getImage(), ImpmadeField\getInput(), ClicksField\getInput(), PlugininfoField\getInput(), AssociationField\getInput(), FieldLayoutField\getInput(), FiltersField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), MenuOrderingField\getInput(), ModulepositionField\getInput(), NewsfeedModel\getItem(), ArticleModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), AdminModel\getItem(), WarningsModel\getItems(), SelectModel\getItems(), HistoryModel\getItems(), ItemsModel\getItems(), RequestController\getJson(), Authentication\getKnownAuthenticators(), TosField\getLabel(), SpacerField\getLabel(), NoteField\getLabel(), LoginHelper\getLanguageList(), LanguagesModel\getLanguages(), ContenthistoryField\getLayoutData(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), UserField\getLayoutData(), FormField\getLayoutData(), Pagination\getLimitBox(), StatsHelper\getList(), TagsSimilarHelper\getList(), ArticlesArchiveHelper\getList(), TemplateModel\getMediaFiles(), ItemsModel\getMenu(), DatabaseController\getMenuBadgeData(), DisplayController\getMenuBadgeData(), DiscoverController\getMenuBadgeData(), UpdateController\getMenuBadgeData(), MenusHelper\getMenuItems(), ModulesHelper\getModules(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), AliastagField\getOptions(), ComponentsField\getOptions(), SearchfilterField\getOptions(), SessionhandlerField\getOptions(), WorkflowComponentSectionsField\getOptions(), ExtensionField\getOptions(), MenuParentField\getOptions(), CachehandlerField\getOptions(), ComponentsCategoryField\getOptions(), LogtypeField\getOptions(), MenuOrderingField\getOptions(), MenuPresetField\getOptions(), ConfigComponentsField\getOptions(), ContenttypesField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsWorkflowField\getOptions(), CategoryField\getOptions(), DatabaseconnectionField\getOptions(), LanguageclientField\getOptions(), LimitboxField\getOptions(), ContenttypeField\getOptions(), TemplatesListField\getOptions(), SubfieldsField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), TransitionField\getOptions(), PredefinedlistField\getOptions(), PluginsField\getOptions(), CategoryeditField\getOptions(), CronField\getOptions(), SqlField\getOptions(), MethodModel\getPageTitle(), CaptiveModel\getPageTitle(), LocalAdapter\getPathInformation(), SysinfoModel\getPHPInfo(), ChecksModel\getPhpOptions(), UpdateModel\getPhpOptions(), ChecksModel\getPhpSettings(), UpdateModel\getPhpSettings(), Authentication\getPKCredentialRequestOptions(), ModulesHelper\getPositions(), ModulesModel\getPositions(), TemplateModel\getPreview(), ProviderManager\getProvider(), DisplayController\getQuickiconContent(), UsersHelper\getRangeOptions(), Pagination\getResultsCounter(), Stream\gets(), LocalAdapter\getSafeName(), TemplateModel\getSource(), MessagesHelper\getStateOptions(), ModulesHelper\getStateOptions(), UsersHelper\getStateOptions(), InstallerHelper\getStateOptions(), StatsAdminHelper\getStats(), AssociationsHelper\getSupportedExtension(), AdministratorApplication\getTemplate(), TemplateModel\getTemplate(), PopularHelper\getTitle(), LatestHelper\getTitle(), FormField\getTitle(), HelpModel\getToc(), ArticlesModel\getTransitions(), ModulesHelper\getTranslatedModulePosition(), UsersLatestHelper\getUsers(), ContentComponent\getWorkflowContexts(), ListHelper\images(), FinderIndexCommand\index(), FormView\initializeView(), InstallModel\install(), LanguagesModel\install(), UpdateModel\install(), Installer\install(), InstallerAdapter\install(), MenusHelper\installPreset(), HistoryController\keep(), HistoryModel\keep(), Access\level(), Menu\linkOptions(), CaptiveModel\loadCaptiveRenderOptions(), Form\loadField(), CMSApplication\login(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), Finder\mapslist(), Menu\menuItems(), Directory\message(), ToolbarHelper\modal(), Date\monthToString(), File\move(), Folder\move(), LocalAdapter\move(), Users\notesModal(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSampledataMultilang\onAjaxSampledataApplyStep3(), PlgSampledataMultilang\onAjaxSampledataApplyStep4(), PlgSampledataMultilang\onAjaxSampledataApplyStep5(), PlgSampledataMultilang\onAjaxSampledataApplyStep6(), PlgSampledataMultilang\onAjaxSampledataApplyStep7(), PlgSampledataMultilang\onAjaxSampledataApplyStep8(), PlgSystemStats\onAjaxSendAlways(), PlgSystemStats\onAjaxSendNever(), PlgSystemStats\onAjaxSendStats(), PlgWorkflowPublishing\onContentBeforeChangeState(), PlgContentConfirmConsent\onContentPrepareForm(), FieldsListPlugin\onCustomFieldsPrepareDom(), PlgButtonModule\onDisplay(), PlgButtonFields\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgQuickiconPrivacyCheck\onGetIcons(), PlgInstallerUrlInstaller\onInstallerAddInstallationTab(), PlgInstallerWebinstaller\onInstallerAddInstallationTab(), ContentHelper\onPrepareForm(), PlgPrivacyUser\onPrivacyCanRemoveData(), PlgSampledataMultilang\onSampledataGetOverview(), PlgUserContactCreator\onUserAfterSave(), PlgUserProfile\onUserBeforeSave(), Webauthn\onUserMultifactorGetMethod(), Totp\onUserMultifactorGetMethod(), Yubikey\onUserMultifactorGetMethod(), Fixed\onUserMultifactorGetMethod(), Email\onUserMultifactorGetMethod(), Stream\open(), IndexController\optimise(), IndexerController\optimize(), ListHelper\ordering(), Menu\ordering(), ModuleController\orderPosition(), TemplateController\overrides(), Router\parse(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), TemplateAdapter\parseQueries(), InstallerAdapter\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), Installer\parseXMLInstallFile(), DatabaseModel\populateDatabase(), MethodModel\populateMfaMethods(), Modules\positions(), ListHelper\positions(), ApiController\postFiles(), RequestController\postSaveHook(), CategoriesView\prepareDocument(), CategoryView\prepareDocument(), HtmlView\prepareDocument(), ContentmapField\prepareLevel(), ConfirmButton\prepareOptions(), ToolbarButton\prepareOptions(), HtmlView\prepareToolbar(), PublishedButton\preprocess(), FeaturedButton\preprocess(), Menu\preprocess(), CssMenu\preprocess(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ModuleModel\preprocessForm(), FieldModel\preprocessForm(), ItemModel\preprocessForm(), Query\processDates(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processString(), ActionsDropdown\publish(), GroupsController\publish(), UpdatesitesModel\publish(), TemplateController\publish(), ManageModel\publish(), Dropdown\publish(), ItemsController\publish(), AdminController\publish(), MessageModel\publish(), InstalledModel\publish(), MapsModel\publish(), StageModel\publish(), WorkflowModel\publish(), IndexModel\publish(), AdminModel\publish(), Table\publish(), ItemModel\publish(), Languages\published(), DisplayController\purge(), ActionlogsController\purge(), LinksController\purge(), OverridesModel\purge(), DiscoverModel\purge(), UpdateModel\purge(), FinderIndexCommand\purge(), AssociationsModel\purge(), ApiController\putFiles(), FinderIndexCommand\putFilters(), Select\radiolist(), Stream\read(), UpdatesitesModel\rebuild(), FeedView\reconcileNames(), AdminModel\redirectToAssociations(), ModuleAdapter\refreshManifestCache(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), Installer\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), RegistrationModel\register(), Date\relative(), ManageModel\remove(), LanguageAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), ApplicationModel\removeroot(), TemplateModel\renameFile(), HtmlRenderer\render(), PublishedButton\render(), FeaturedButton\render(), FeedDocument\render(), GroupsController\reorder(), LevelsModel\reorder(), AdminController\reorder(), AdminModel\reorder(), MessageController\reply(), SearchesController\reset(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), AdminController\runTransition(), ConfigController\save(), StyleController\save(), TemplatesController\save(), OverrideController\save(), MediumModel\save(), OverrideModel\save(), GroupModel\save(), ComponentModel\save(), LanguageModel\save(), UserModel\save(), ApplicationModel\save(), MessageModel\save(), RequestModel\save(), StyleModel\save(), CategoryModel\save(), FormController\save(), TemplateModel\save(), AdminModel\save(), ItemModel\save(), SetConfigurationCommand\saveConfiguration(), GroupsController\saveorder(), LevelsModel\saveorder(), AdminController\saveorder(), AdminModel\saveorder(), Stream\seek(), Filter\select(), MailModel\send(), Mail\Send(), Email\sendCode(), JSONController\sendJsonResponse(), ActionlogModel\sendNotificationEmails(), ApplicationModel\sendTestMail(), System\server(), PhpSetting\set(), InstalledController\setDefault(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), WorkflowModel\setDefault(), StageModel\setDefault(), StyleModel\setHome(), ItemModel\setHome(), ConfigurationModel\setup(), TextField\setup(), CalendarField\setup(), LibraryAdapter\setupInstallPaths(), PluginAdapter\setupInstallPaths(), TemplateAdapter\setupInstallPaths(), PackageAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), ComponentAdapter\setupInstallPaths(), LanguageAdapter\setupUninstall(), FileAdapter\setupUninstall(), LibraryAdapter\setupUninstall(), PluginAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), PackageAdapter\setupUninstall(), ComponentAdapter\setupUninstall(), Filter\slider(), IndexerController\start(), Finder\statelist(), Privacy\statusLabel(), Language\store(), ContactTable\store(), ContentType\store(), MenuType\store(), FilterTable\store(), NewsfeedTable\store(), TagTable\store(), Menu\store(), Category\store(), Content\store(), FileAdapter\storeExtension(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), TemplateAdapter\storeExtension(), PhpSetting\string(), ContactController\submit(), InstalledModel\switchAdminLanguage(), Stream\tell(), TimeRule\test(), PasswordRule\test(), EmailRule\test(), Templates\thumb(), Templates\thumbModal(), ToolbarHelper\title(), HTMLHelper\tooltipText(), PlgUserProfile\tos(), InstallerModel\translate(), PluginsModel\translate(), UpdateModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), CaptiveModel\translateMethodName(), ActionsDropdown\trash(), PackageAdapter\triggerManifestScript(), InstallerAdapter\triggerManifestScript(), Finder\typeslist(), ActionsDropdown\unarchive(), ActionsDropdown\unfeature(), InstallerAdapter\uninstall(), TaskTable\unlock(), ActionsDropdown\unpublish(), StyleModel\unsetHome(), LanguageAdapter\update(), Installer\update(), File\upload(), UpdateModel\upload(), Stream\upload(), TemplateController\uploadFile(), TemplateModel\uploadFile(), Access\usergroup(), ListHelper\users(), LevelModel\validate(), TemplateModel\validate(), RequestModel\validate(), Form\validate(), FormField\validate(), Authentication\validateAssertionResponse(), DatabaseHelper\validateConnectionParameters(), ApplicationModel\validateDbConnection(), DisplayController\validateEntry(), Users\value(), Credentials\verifyAttestation(), Menus\visibility(), ArticleController\vote(), Directory\writable(), Stream\write(), et ApplicationModel\writeConfigFile().

◆ alt()

static alt | ( | $string,
 |  | $alt,
 |  | $jsSafe = false,
 |  | $interpretBackSlashes = true,
 |  | $script = false
 | ) |
static

Translates a string into the current language.

Examples: ‘<?php echo Text::alt('JALL’, 'language'); ?>‘ will generate a 'All’ string in English but a "Toutes" string in French ‘<?php echo Text::alt('JALL’, 'module'); ?>‘ will generate a 'All’ string in English but a "Tous" string in French

Paramètres
string | $string | The string to translate.
string | $alt | The alternate option for global string
mixed | $jsSafe | Boolean: Make the result javascript safe.
boolean $interpretBackSlashes To interpret backslashes (\=\,
=carriage return, =tabulation)
boolean | $script | To indicate that the string will be pushed in the javascript language store
Renvoie
string The translated string or the key if $script is true
Depuis
1.7.0

Références $alt, $script, Factory\getLanguage(), et Language\hasKey().

Référencé par AdminLanguage\existing(), ContentLanguage\existing(), GroupedlistField\getGroups(), FormField\getLayoutData(), ListField\getOptions(), WorkflowconditionField\getOptions(), FolderlistField\getOptions(), FilelistField\getOptions(), et TextField\getOptions().

◆ getScriptStrings()

static getScriptStrings ( )
static

Get the strings that have been loaded to the JavaScript language store.

Renvoie
array
Depuis
3.7.0

Références $strings.

Référencé par HtmlDocument\getHeadData().

◆ passSprintf()

static passSprintf | ( | & | $string,
 |  |  | $jsSafe = false,
 |  |  | $interpretBackSlashes = true,
 |  |  | $script = false
 | ) |  |
staticprivate

Checks the string if it should be interpreted as sprintf and runs sprintf over it.

Paramètres
string | &$string | The string to translate.
mixed | $jsSafe | Boolean: Make the result javascript safe.
boolean $interpretBackSlashes To interpret backslashes (\=\,
=carriage return, =tabulation)
boolean | $script | To indicate that the string will be push in the javascript language store
Renvoie
boolean Whether the string be interpreted as sprintf
Depuis
3.4.4

Références $i, Language\$lang, $script, $strings, et Factory\getLanguage().

◆ plural()

static plural | ( | $string,
 |  | $n
 | ) |
static

Like Text::sprintf but tries to pluralise the string.

Note that this method can take a mixed number of arguments as for the sprintf function.

The last argument can take an array of options:

array('jsSafe'=>boolean, 'interpretBackSlashes'=>boolean, 'script'=>boolean)

where:

jsSafe is a boolean to generate a javascript safe strings. interpretBackSlashes is a boolean to interpret backslashes \->\,
->new line, ->tabulation. script is a boolean to indicate that the string will be push in the javascript language store.

Examples: ‘<script>alert(Joomla.Text._(’<?php echo Text::plural("COM_PLUGINS_N_ITEMS_UNPUBLISHED", 1, array("script"=>true)); ?>'));</script>‘ will generate an alert message containing '1 plugin successfully disabled’ ‘<?php echo Text::plural('COM_PLUGINS_N_ITEMS_UNPUBLISHED’, 1); ?>‘ will generate a '1 plugin successfully disabled’ string

Paramètres
string | $string | The format string.
integer | $n | The number of items
Renvoie
string The translated strings or the key if 'script' is true in the array of options
Depuis
1.7.0

Références $count, $key, Language\$lang, $n, $strings, $suffix, et Factory\getLanguage().

Référencé par LinksController\activate(), UsersController\activate(), LinksController\batch(), UsersController\changeBlock(), AdminController\checkin(), OverridesController\delete(), LevelController\delete(), UpdatesitesModel\delete(), AdminController\delete(), HtmlView\display(), ModulesController\duplicate(), LinksController\duplicateUrls(), PluginsController\getQuickiconContent(), CategoriesController\getQuickiconContent(), ItemsController\getQuickiconContent(), TagsController\getQuickiconContent(), ModulesController\getQuickiconContent(), DisplayController\getQuickiconContent(), ArticlesController\getQuickiconContent(), UsersController\getQuickiconContent(), LatestActionsHelper\getTitle(), LoggedHelper\getTitle(), PopularHelper\getTitle(), LatestHelper\getTitle(), HistoryController\keep(), Users\notes(), Users\notesModal(), ResetModel\processResetRequest(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), Date\relative(), LanguageAdapter\resetUserLanguage(), StyleModel\save(), MailModel\send(), ItemsController\setDefault(), et PasswordRule\test().

◆ printf()

static printf ( $string )
static

Passes a string thru an printf.

Note that this method can take a mixed number of arguments as for the sprintf function.

Paramètres
string $string The format string.
Renvoie
mixed
Depuis
1.7.0

Références $count, Language\$lang, et Factory\getLanguage().

◆ script()

static script | ( | $string = null,
 |  | $jsSafe = false,
 |  | $interpretBackSlashes = true
 | ) |
static

Translate a string into the current language and stores it in the JavaScript language store.

Paramètres
string | $string | The Text key.
boolean | $jsSafe | Ensure the output is JavaScript safe.
boolean $interpretBackSlashes Interpret and
.
Renvoie
array
Depuis
1.7.0

Références $strings, HTMLHelper\_(), Factory\getDocument(), Factory\getLanguage(), et null.

Référencé par ConfirmButton\_getCommand(), StandardButton\_getCommand(), FormBehavior\ajaxchosen(), Tag\ajaxfield(), HtmlView\display(), Joomlaupdate\getCoreUpdateNotification(), FiltersField\getInput(), Shortcut\initialize(), FormValidateAssetItem\onAttachCallback(), TableColumnsAssetItem\onAttachCallback(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgInstallerWebinstaller\onInstallerAddInstallationTab(), et IndexerController\start().

◆ sprintf()

static sprintf ( $string )
static

Passes a string thru a sprintf.

Note that this method can take a mixed number of arguments as for the sprintf function.

The last argument can take an array of options:

array('jsSafe'=>boolean, 'interpretBackSlashes'=>boolean, 'script'=>boolean)

where:

jsSafe is a boolean to generate a javascript safe strings. interpretBackSlashes is a boolean to interpret backslashes \->\,
->new line, ->tabulation. script is a boolean to indicate that the string will be push in the javascript language store.

Paramètres
string $string The format string.
Renvoie
string The translated strings or the key if 'script' is true in the array of options.
Depuis
1.7.0

Références $count, Language\$lang, $strings, et Factory\getLanguage().

Référencé par AdminController\__construct(), BaseDatabaseModel\__construct(), FormController\__construct(), ApiController\__construct(), FileStorage\_deleteFolder(), ExtensionAdapter\_endElement(), FileStorage\_filesInFolder(), FileStorage\_folders(), Captcha\_load(), FtpClient\_mode(), FtpClient\_passive(), HtmlView\_prepareDocument(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), RegistrationModel\activate(), LinkModel\activate(), MediaController\add(), InstallerScript\addDashboardMenu(), HtmlView\addToolbar(), File\append(), FtpClient\append(), Patcher\applyHunk(), AdministratorService\association(), Menus\association(), Authentication\authenticate(), DatabaseModel\backupDatabase(), LinksController\batch(), FormController\batch(), ItemModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), ArticleModel\batchMove(), ItemModel\batchMove(), AdminModel\batchMove(), CategoryModel\batchMove(), Joomla\CMS\MVC\Model\batchWorkflowStage(), BannerTable\bind(), FormController\cancel(), LevelModel\canDelete(), MediaHelper\canUpload(), FtpClient\chdir(), MenuType\check(), ViewLevel\check(), User\check(), CssMenu\check(), Dispatcher\checkAccess(), SetConfigurationCommand\checkDb(), DatabaseHelper\checkDbServerParameters(), TemplateAdapter\checkExistingExtension(), ModuleAdapter\checkExistingExtension(), PluginAdapter\checkExistingExtension(), InstallerAdapter\checkExistingExtension(), PackageAdapter\checkExtensionInFilesystem(), ComponentAdapter\checkExtensionInFilesystem(), InstallerAdapter\checkExtensionInFilesystem(), AdminController\checkin(), DatabaseHelper\checkRemoteDbHost(), ConfigurationModel\checkTestingSampledata(), FtpClient\chmod(), DatabaseModel\compareUpdateVersion(), FtpClient\connect(), File\copy(), FileAdapter\copyBaseFiles(), LibraryAdapter\copyBaseFiles(), TemplateAdapter\copyBaseFiles(), PluginAdapter\copyBaseFiles(), ModuleAdapter\copyBaseFiles(), PackageAdapter\copyBaseFiles(), ComponentAdapter\copyBaseFiles(), TemplateModel\copyFile(), Installer\copyFiles(), TemplateModel\copyStyles(), FtpClient\create(), LanguageAdapter\createContentLanguage(), DatabaseModel\createDatabase(), ComponentAdapter\createExtensionRoot(), InstallerAdapter\createExtensionRoot(), TemplateModel\createFile(), MenuFactory\createMenu(), DatabaseModel\createTables(), LegacyFactory\createView(), StageTable\delete(), WorkflowTable\delete(), DisplayController\delete(), UpdatesitesModel\delete(), MenuType\delete(), File\delete(), MediumModel\delete(), Folder\delete(), FtpClient\delete(), Installer\discover_install(), DisplayController\display(), HtmlView\display(), ManageController\displayList(), UsersController\displayList(), ExtensionRemoveCommand\doExecute(), FinderIndexCommand\doExecute(), InstallerHelper\downloadPackage(), UpdateModel\downloadPackage(), Icon\edit(), MediaController\edit(), FormController\edit(), PlgWorkflowPublishing\enhanceItemForm(), ApiController\execute(), BaseController\execute(), Query\explained(), AjaxController\fetchAssociations(), DatabaseModel\fetchSchemaCache(), Folder\files(), FileAdapter\finaliseInstall(), ModuleAdapter\finaliseInstall(), UpdateModel\finaliseUpgrade(), CollectionAdapter\findUpdate(), ExtensionAdapter\findUpdate(), Folder\folders(), FtpClient\get(), ContentHelper\getActions(), AssociationsHelper\getAssociationHtmlList(), CapabilitiesModel\getCapabilities(), ComponentDispatcher\getController(), DatabaseModel\getErrorsMessage(), SysinfoModel\getExtensions(), FinderIndexCommand\getFilters(), OverrideModel\getForm(), PlugininfoField\getInput(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), NumberField\getInput(), TextField\getInput(), Parser\getInstance(), Pathway\getInstance(), Router\getInstance(), AbstractMenu\getInstance(), BaseController\getInstance(), CMSApplication\getInstance(), MediumModel\getItem(), MediaModel\getItems(), WarningsModel\getItems(), LanguagesModel\getLanguages(), TinymcebuilderField\getLayoutData(), DebugHelper\getLevelsOptions(), ArticlesArchiveHelper\getList(), MultilangstatusHelper\getModule(), BaseModel\getName(), AbstractView\getName(), BaseController\getName(), WorkflowComponentSectionsField\getOptions(), LanguageclientField\getOptions(), ListField\getOptions(), PluginsField\getOptions(), DatabaseModel\getOtherInformationMessage(), Pagination\getPagesCounter(), CMSApplication\getPathway(), ChecksModel\getPhpOptions(), UpdateModel\getPhpOptions(), ChecksModel\getPhpSettings(), UpdateModel\getPhpSettings(), DisplayController\getQuickiconContent(), Pagination\getResultsCounter(), BaseDatabaseModel\getTable(), AdministratorApplication\getTemplate(), UpdateAdapter\getUpdateSiteResponse(), RegistrationModel\getUserIdFromToken(), BaseController\getView(), FinderIndexCommand\index(), DatabaseModel\initialise(), InstallModel\install(), LanguagesModel\install(), LanguageAdapter\install(), UpdateModel\install(), Route\link(), FtpClient\listDetails(), FtpClient\listNames(), User\load(), Changelog\loadFromXml(), Update\loadFromXml(), Manifest\loadManifestFromXml(), HtmlView\loadTemplate(), FtpClient\login(), FtpClient\mkdir(), File\move(), Folder\move(), InstallerScript\moveCliFiles(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSampledataMultilang\onAjaxSampledataApplyStep3(), PlgSampledataMultilang\onAjaxSampledataApplyStep4(), PlgSampledataMultilang\onAjaxSampledataApplyStep5(), PlgSampledataMultilang\onAjaxSampledataApplyStep6(), PlgSampledataMultilang\onAjaxSampledataApplyStep7(), PlgSystemLanguagecode\onContentPrepareForm(), FieldsPlugin\onCustomFieldsGetTypes(), ContentHelper\onPrepareForm(), ModuleController\orderPosition(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), TemplateAdapter\parseQueries(), Installer\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), FileAdapter\populateFilesAndFolderList(), InstallerScript\preflight(), PluginModel\preprocessForm(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), PlgSampledataMultilang\publishContentLanguages(), FinderIndexCommand\putFilters(), FtpClient\pwd(), FtpClient\read(), UpdatesitesModel\rebuild(), Installer\refreshManifestCache(), RegistrationModel\register(), FtpClient\reinit(), ManageModel\remove(), PackageAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), FtpClient\rename(), ActionsDropdown\render(), RssRenderer\render(), PublishedButton\render(), AtomRenderer\render(), FeaturedButton\render(), AdministratorApplication\render(), Toolbar\renderButton(), AdminController\reorder(), FtpClient\restart(), AdminController\runTransition(), ConfigController\save(), StyleController\save(), TemplatesController\save(), OverrideController\save(), MediumModel\save(), ApplicationModel\save(), FormController\save(), TemplateModel\save(), AdminController\saveorder(), Filter\select(), ApplicationModel\sendTestMail(), HtmlView\setDocumentTitle(), ItemModel\setHome(), Mail\setSender(), ConfigurationModel\setup(), PluginAdapter\setupInstallPaths(), TemplateAdapter\setupInstallPaths(), PackageAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), ModuleAdapter\setupUninstall(), FtpClient\size(), Filter\slider(), Finder\statelist(), MenuType\store(), Menu\store(), FtpClient\store(), FileAdapter\storeExtension(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), TemplateAdapter\storeExtension(), ArticleModel\storeVote(), InstalledController\switchAdminLanguage(), FtpClient\syst(), UrlRule\test(), EmailRule\test(), Templates\thumbModal(), PackageAdapter\triggerManifestScript(), InstallerAdapter\triggerManifestScript(), Finder\typeslist(), InstallerAdapter\uninstall(), LanguageAdapter\update(), File\upload(), TemplateController\uploadFile(), Form\validate(), FormField\validate(), DatabaseHelper\validateConnectionParameters(), ApplicationModel\validateDbConnection(), SetupModel\validateDbConnection(), DisplayController\validateEntry(), File\write(), et FtpClient\write().

Documentation des champs

◆ $strings

$strings = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Text.php


Joomla CMS: Référence de la classe Transliterate

  • Joomla
  • CMS
  • Language
  • Transliterate
Fonctions membres publiques statiques
Référence de la classe Transliterate

Fonctions membres publiques statiques

static utf8_latin_to_ascii ($string, $case=0)

Description détaillée

Class to transliterate strings

Depuis
1.7.0
Note
Port of phputf8's utf8_accents_to_ascii()

Documentation des fonctions membres

◆ utf8_latin_to_ascii()

static utf8_latin_to_ascii | ( | $string,
 |  | $case = 0
 | ) |
static

Returns strings transliterated from UTF-8 to Latin

Paramètres
string | $string | String to transliterate
integer | $case | Optionally specify upper or lower case. Default to null.
Renvoie
string Transliterated string
Depuis
1.7.0

Références null.

Référencé par Language\transliterate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Transliterate.php


Joomla CMS: Référence de la classe BaseLayout

  • Joomla
  • CMS
  • Layout
  • BaseLayout
Fonctions membres publiques | Attributs protégés
Référence de la classe BaseLayout
+ Graphe d'héritage de BaseLayout:
LayoutInterface FileLayout

Fonctions membres publiques

setOptions ($options=null)
getOptions ()
resetOptions ()
escape ($output)
getDebugMessages ()
render ($displayData)
renderDebugMessages ()
addDebugMessage ($message)
clearDebugMessages ()
debug ($data=array())
get ($key, $defaultValue=null)
getData ()
isDebugEnabled ()
set ($key, $value)
setData (array $data)
setDebug ($debug)

Attributs protégés

$options = null
$data = array()
$debugMessages = array()

Description détaillée

Base class for rendering a display layout

3.0

Documentation des fonctions membres

◆ addDebugMessage()

addDebugMessage ( $message )

Add a debug message to the debug messages array

Paramètres
string $message Message to save
Renvoie
self
Depuis
3.2

Références $message, et $this.

◆ clearDebugMessages()

clearDebugMessages ( )

Clear the debug messages array

Renvoie
self
Depuis
3.5

Références $this.

◆ debug()

debug ( $data = array() )

Render a layout with debug info

Paramètres
mixed $data Data passed to the layout
Renvoie
string
Depuis
3.5

Références $data, et $output.

◆ escape()

escape ( $output )

Method to escape output.

Paramètres
string $output The output to escape.
Renvoie
string The escaped output.
Note
the ENT_COMPAT flag was replaced by ENT_QUOTES in Joomla 4.0 to also escape single quotes
Depuis
3.0

Implémente LayoutInterface.

Références $output, ENT_QUOTES, et null.

◆ get()

get | ( | $key,
 |  | $defaultValue = null
 | ) |

Method to get the value from the data array

Paramètres
string | $key | Key to search for in the data array
mixed | $defaultValue | Default value to return if the key is not set
Renvoie
mixed Value from the data array | defaultValue if doesn't exist
Depuis
3.5

Références $key.

◆ getData()

getData ( )

Get the data being rendered

Renvoie
array
Depuis
3.5

Références $data.

◆ getDebugMessages()

getDebugMessages ( )

Get the debug messages array

Renvoie
array
Depuis
3.2

◆ getOptions()

getOptions ( )

Get the options

Renvoie
Registry Object with the options
Depuis
3.2

Références $options.

◆ isDebugEnabled()

isDebugEnabled ( )

Check if debug mode is enabled

Renvoie
boolean
Depuis
3.5

◆ render()

render ( $displayData )

Method to render the layout.

Paramètres
array $displayData Array of properties available for use inside the layout file to build the displayed output
Renvoie
string The necessary HTML to display the layout
Depuis
3.0

Implémente LayoutInterface.

Références $displayData.

◆ renderDebugMessages()

renderDebugMessages ( )

Render the list of debug messages

Renvoie
string Output text/HTML code
Depuis
3.2

◆ resetOptions()

resetOptions ( )

Function to empty all the options

Renvoie
BaseLayout Instance of $this to allow chaining.
Depuis
3.2

Références null.

◆ set()

set | ( | $key,
 |  | $value
 | ) |

Method to set a value in the data array. Example: $layout->set('items', $items);

Paramètres
string | $key | Key for the data array
mixed | $value | Value to assign to the key
Renvoie
self
Depuis
3.5

Références $key, $this, et $value.

◆ setData()

setData ( array $data )

Set the the data passed the layout

Paramètres
array $data Array with the data for the layout
Renvoie
self
Depuis
3.5

Références $data, et $this.

◆ setDebug()

setDebug ( $debug )

Change the debug mode

Paramètres
boolean $debug Enable / Disable debug
Renvoie
self
Depuis
3.5

Références $this.

◆ setOptions()

setOptions ( $options = null )

Set the options

Paramètres
array | Registry $options Array / Registry object with the options to load
Renvoie
BaseLayout Instance of $this to allow chaining.
Depuis
3.2

Références $options, $this, et elseif.

Documentation des champs

◆ $data

$data = array()
protected

◆ $debugMessages

$debugMessages = array()
protected

◆ $options

$options = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseLayout.php


Joomla CMS: Référence de la classe FileLayout

  • Joomla
  • CMS
  • Layout
  • FileLayout
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe FileLayout
+ Graphe d'héritage de FileLayout:
BaseLayout LayoutInterface

Fonctions membres publiques

__construct ($layoutId, $basePath=null, $options=null)
render ($displayData=array())
addIncludePath ($path)
addIncludePaths ($paths)
clearIncludePaths ()
getIncludePaths ()
getLayoutId ()
getSuffixes ()
loadLanguageSuffixes ()
loadVersionSuffixes ()
removeIncludePath ($path)
removeIncludePaths ($paths)
setComponent ($option)
setClient ($client)
setLayoutId ($layoutId)
getDefaultIncludePaths ()
setIncludePaths ($paths)
setSuffixes (array $suffixes)
sublayout ($layoutId, $displayData)
- Fonctions membres publiques hérités de BaseLayout
setOptions ($options=null)
getOptions ()
resetOptions ()
escape ($output)
getDebugMessages ()
render ($displayData)
renderDebugMessages ()
addDebugMessage ($message)
clearDebugMessages ()
debug ($data=array())
get ($key, $defaultValue=null)
getData ()
isDebugEnabled ()
set ($key, $value)
setData (array $data)
setDebug ($debug)

Fonctions membres protégées

getPath ()
validComponent ($option=null)

Attributs protégés

$layoutId = ''
$basePath = null
$fullPath = null
$includePaths = array()
- Attributs protégés hérités de BaseLayout
$options = null
$data = array()
$debugMessages = array()

Attributs protégés statiques

static $cache = array()

Description détaillée

Base class for rendering a display layout loaded from from a layout file

3.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $layoutId,
 |  | $basePath = null,
 |  | $options = null
 | ) |

Method to instantiate the file-based layout.

Paramètres
string | $layoutId | Dot separated path to the layout file, relative to base path
string | $basePath | Base path to use when loading layout files
mixed | $options | Optional custom options to load. Registry or array format [
Depuis
3.2]
3.0

Références $basePath, et $options.

Documentation des fonctions membres

◆ addIncludePath()

addIncludePath ( $path )

Add one path to include in layout search. Proxy of addIncludePaths()

Paramètres
string|string[] $path The path to search for layouts
Renvoie
self
Depuis
3.2

Références $path, et $this.

◆ addIncludePaths()

addIncludePaths ( $paths )

Add one or more paths to include in layout search

Paramètres
string|string[] $paths The path or array of paths to search for layouts
Renvoie
self
Depuis
3.2

Références $this.

◆ clearIncludePaths()

clearIncludePaths ( )

Clear the include paths

Renvoie
self
Depuis
3.5

Références $this.

◆ getDefaultIncludePaths()

getDefaultIncludePaths ( )

Get the default array of include paths

Renvoie
array
Depuis
3.5

Références $component, $template, Factory\getApplication(), JPATH_ADMINISTRATOR, JPATH_ROOT, JPATH_SITE, JPATH_THEMES, et null.

◆ getIncludePaths()

getIncludePaths ( )

Get the active include paths

Renvoie
array
Depuis
3.5

◆ getLayoutId()

getLayoutId ( )

Get the active layout id

Renvoie
string
Depuis
3.5

◆ getPath()

getPath ( )
protected

Method to finds the full real file path, checking possible overrides

Renvoie
string The full path to the layout file
Depuis
3.0

Références $hash, $suffix, et Path\find().

◆ getSuffixes()

getSuffixes ( )

Get the active suffixes

Renvoie
array
Depuis
3.5

◆ loadLanguageSuffixes()

loadLanguageSuffixes ( )

Load the automatically generated language suffixes. Example: array('es-ES', 'es', 'ltr')

Renvoie
self
Depuis
3.5

Références $lang, $this, et Factory\getLanguage().

◆ loadVersionSuffixes()

loadVersionSuffixes ( )

Load the automatically generated version suffixes. Example: array('j311', 'j31', 'j3')

Renvoie
self
Depuis
3.5

Références $this.

◆ removeIncludePath()

removeIncludePath ( $path )

Remove one path from the layout search

Paramètres
string $path The path to remove from the layout search
Renvoie
self
Depuis
3.2

Références $path, et $this.

◆ removeIncludePaths()

removeIncludePaths ( $paths )

Remove one or more paths to exclude in layout search

Paramètres
string $paths The path or array of paths to remove for the layout search
Renvoie
self
Depuis
3.2

Références $this.

◆ render()

render ( $displayData = array() )

Method to render the layout.

Paramètres
array $displayData Array of properties available for use inside the layout file to build the displayed output
Renvoie
string The necessary HTML to display the layout
Depuis
3.0

Implémente LayoutInterface.

Références $displayData, et $path.

◆ setClient()

setClient ( $client )

Function to initialise the application client

Paramètres
mixed $client Frontend: 'site' or 0 | Backend: 'admin' or 1
Renvoie
void
Depuis
3.2

Références $client, et Factory\getApplication().

◆ setComponent()

setComponent ( $option )

Method to change the component where search for layouts

Paramètres
string $option URL Option of the component. Example: com_content
Renvoie
mixed Component option string | null for none
Depuis
3.2

Références $component, $option, ApplicationHelper\getComponentName(), et null.

◆ setIncludePaths()

setIncludePaths ( $paths )

Set the include paths to search for layouts

Paramètres
array $paths Array with paths to search in
Renvoie
self
Depuis
3.5

Références $this.

◆ setLayoutId()

setLayoutId ( $layoutId )

Set the active layout id

Paramètres
string $layoutId Layout identifier
Renvoie
self
Depuis
3.5

Références $this, et null.

◆ setSuffixes()

setSuffixes ( array $suffixes )

Set suffixes to search layouts

Paramètres
mixed $suffixes String with a single suffix or 'auto' | 'none' or array of suffixes
Renvoie
self
Depuis
3.5

Références $this.

◆ sublayout()

sublayout | ( | $layoutId,
 |  | $displayData
 | ) |

Render a layout with the same include paths & options

Paramètres
string | $layoutId | The identifier for the sublayout to be searched in a subfolder with the name of the current layout
mixed | $displayData | Data to be rendered
Renvoie
string The necessary HTML to display the layout
Depuis
3.2

Références $basePath, $displayData, $options, et $sublayout.

◆ validComponent()

validComponent ( $option = null )
protected

Validate that the active component is valid

Paramètres
string $option URL Option of the component. Example: com_content
Renvoie
boolean
Depuis
3.2

Références $component, $option, ComponentHelper\isEnabled(), et null.

Documentation des champs

◆ $basePath

$basePath = null
protected

◆ $cache

$cache = array()
staticprotected

◆ $fullPath

$fullPath = null
protected

◆ $includePaths

$includePaths = array()
protected

◆ $layoutId

$layoutId = ''
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FileLayout.php


Joomla CMS: Référence de la classe LayoutHelper

  • Joomla
  • CMS
  • Layout
  • LayoutHelper
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe LayoutHelper

Fonctions membres publiques statiques

static | debug ($layoutFile, $displayData=null, $basePath='', $options=null)
static | render ($layoutFile, $displayData=null, $basePath='', $options=null)

Attributs publics statiques

static $defaultBasePath = ''

Description détaillée

Helper to render a Layout object, storing a base path

3.1

Documentation des fonctions membres

◆ debug()

static debug | ( | $layoutFile,
 |  | $displayData = null,
 |  | $basePath = '',
 |  | $options = null
 | ) |
static

Method to render a layout with debug info

Paramètres
string | $layoutFile | Dot separated path to the layout file, relative to base path
mixed | $displayData | Object which properties are used inside the layout file to build displayed output
string | $basePath | Base path to use when loading layout files
mixed | $options | Optional custom options to load. Registry or array format
Renvoie
string
Depuis
3.5

Références $basePath, $displayData, $layout, $options, et null.

◆ render()

static render | ( | $layoutFile,
 |  | $displayData = null,
 |  | $basePath = '',
 |  | $options = null
 | ) |
static

Method to render the layout.

Paramètres
string | $layoutFile | Dot separated path to the layout file, relative to base path
mixed | $displayData | Object which properties are used inside the layout file to build displayed output
string | $basePath | Base path to use when loading layout files
mixed | $options | Optional custom options to load. Registry or array format
Renvoie
string
Depuis
3.1
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $basePath, $displayData, $layout, $options, et null.

Référencé par Pagination\_item_active(), Pagination\_item_inactive(), Pagination\_list_render(), ActionsDropdown\addCustomItem(), AdministratorService\association(), Menus\association(), HTMLHelper\calendar(), Icon\edit(), Bootstrap\endTab(), Bootstrap\endTabSet(), AssociationsHelper\getAssociationHtmlList(), FiltersField\getInput(), Pagination\getPaginationLinks(), HTMLHelper\image(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Icon\print_screen(), MessageRenderer\render(), ModulesRenderer\render(), ActionButton\render(), FieldsHelper\render(), ErrorDocument\renderBacktrace(), Bootstrap\renderModal(), ModuleHelper\renderModule(), SearchTools\sort(), Bootstrap\startTabSet(), et Access\usergroups().

Documentation des champs

◆ $defaultBasePath

$defaultBasePath = ''
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • LayoutHelper.php


Joomla CMS: Référence de l'interface LayoutInterface

  • Joomla
  • CMS
  • Layout
  • LayoutInterface
Fonctions membres publiques
Référence de l'interface LayoutInterface
+ Graphe d'héritage de LayoutInterface:
BaseLayout FileLayout

Fonctions membres publiques

escape ($output)
render ($displayData)

Description détaillée

Interface to handle display layout

3.0

Documentation des fonctions membres

◆ escape()

escape ( $output )

Method to escape output.

Paramètres
string $output The output to escape.
Renvoie
string The escaped output.
Depuis
3.0

Implémenté dans BaseLayout.

◆ render()

render ( $displayData )

Method to render the layout.

Paramètres
array $displayData Array of properties available for use inside the layout file to build the displayed output
Renvoie
string The rendered layout.
Depuis
3.0

Implémenté dans BaseLayout, et FileLayout.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LayoutInterface.php


Joomla CMS: Référence de la classe CallbackLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • CallbackLogger
Fonctions membres publiques | Attributs protégés
Référence de la classe CallbackLogger
+ Graphe d'héritage de CallbackLogger:
Logger

Fonctions membres publiques

__construct (array &$options)
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$callback
- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla! Callback Log class

This class allows logging to be handled by a callback function. This allows unprecedented flexibility in the way logging can be handled.

Depuis
3.0.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
3.0.1
Exceptions

Références Logger\$options, $this, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
3.0.1
Exceptions

Documentation des champs

◆ $callback

$callback
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CallbackLogger.php


Joomla CMS: Référence de la classe DatabaseLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • DatabaseLogger
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DatabaseLogger
+ Graphe d'héritage de DatabaseLogger:
Logger

Fonctions membres publiques

__construct (array &$options)
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Fonctions membres protégées

connect ()

Attributs protégés

$driver = 'mysqli'
$host = '127.0.0.1'
$user = 'root'
$password = ''
$database = 'logging'
$table = 'jos_'
$db
- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla! MySQL Database Log class

This class is designed to output logs to a specific MySQL database table. Fields in this table are based on the Syslog style of log output. This is designed to allow quick and easy searching.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
1.7.0

Références Logger\$options, Symfony\Contracts\Service\__construct(), Factory\getDbo(), et null.

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
1.7.0
Exceptions

◆ connect()

connect ( )
protected

Method to connect to the database server based on object properties.

Renvoie
void
Depuis
1.7.0
Exceptions

Références Logger\$options, et DatabaseDriver\getInstance().

Documentation des champs

◆ $database

$database = 'logging'
protected

◆ $db

$db
protected

◆ $driver

$driver = 'mysqli'
protected

◆ $host

$host = '127.0.0.1'
protected

◆ $password

$password = ''
protected

◆ $table

$table = 'jos_'
protected

◆ $user

$user = 'root'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseLogger.php


Joomla CMS: Référence de la classe EchoLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • EchoLogger
Fonctions membres publiques | Attributs protégés
Référence de la classe EchoLogger
+ Graphe d'héritage de EchoLogger:
Logger

Fonctions membres publiques

__construct (array &$options)
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$line_separator = "\n"
- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla Echo logger class.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
3.0.0

Références Logger\$options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
1.7.0

Documentation des champs

◆ $line_separator

$line_separator = "\n"
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • EchoLogger.php


Joomla CMS: Référence de la classe FormattedtextLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • FormattedtextLogger
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FormattedtextLogger
+ Graphe d'héritage de FormattedtextLogger:
Logger W3cLogger

Fonctions membres publiques

__construct (array &$options)
__destruct ()
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Fonctions membres protégées

formatLine (LogEntry $entry)
generateFileHeader ()
initFile ()
parseFields ()

Attributs protégés

$format = '{DATETIME} {PRIORITY} {CLIENTIP} {CATEGORY} {MESSAGE}'
$fields = array()
$path
$defer = false
$deferredEntries = array()
- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla! Formatted Text File Log class

This class is designed to use as a base for building formatted text files for output. By default it emulates the Syslog style format output. This is a disk based output format.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
1.7.0

Références Logger\$options, Symfony\Contracts\Service\__construct(), Factory\getApplication(), JPATH_ADMINISTRATOR, et path.

◆ __destruct()

__destruct ( )

If deferred, write all pending logs.

Depuis
3.9.0

Références $this, et path.

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
1.7.0
Exceptions

Références path.

◆ formatLine()

formatLine ( LogEntry $entry )
protected

Format a line for the log file.

Paramètres
LogEntry $entry The log entry to format as a string.
Renvoie
String
Depuis
3.9.0

Références $field, $format, $tmp, et fields.

◆ generateFileHeader()

generateFileHeader ( )
protected

Method to generate the log file header.

Renvoie
string The log file header
Depuis
1.7.0

◆ initFile()

initFile ( )
protected

Method to initialise the log file. This will create the folder path to the file if it doesn't already exist and also get a new file header if the file doesn't already exist. If the file already exists it will simply open it for writing.

Renvoie
void
Depuis
1.7.0
Exceptions

Références path.

◆ parseFields()

parseFields ( )
protected

Method to parse the format string into an array of fields.

Renvoie
void
Depuis
1.7.0

Références fields.

Documentation des champs

◆ $defer

$defer = false
protected

◆ $deferredEntries

$deferredEntries = array()
protected

◆ $fields

$fields = array()
protected

◆ $format

$format = '{DATETIME} {PRIORITY} {CLIENTIP} {CATEGORY} {MESSAGE}'
protected

◆ $path

$path
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormattedtextLogger.php


Joomla CMS: Référence de la classe InMemoryLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • InMemoryLogger
Fonctions membres publiques | Attributs protégés | Attributs protégés statiques
Référence de la classe InMemoryLogger
+ Graphe d'héritage de InMemoryLogger:
Logger

Fonctions membres publiques

__construct (array &$options)
addEntry (LogEntry $entry)
getCollectedEntries ()
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$group = 'default'
- Attributs protégés hérités de Logger
$options = array()
$priorities

Attributs protégés statiques

static $logEntries = []

Description détaillée

Logger class that keeps all entries in memory

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
4.0.0

Références Logger\$options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
4.0.0

◆ getCollectedEntries()

getCollectedEntries ( )

Returns a list of collected entries.

Renvoie
array
Depuis
4.0.0

Documentation des champs

◆ $group

$group = 'default'
protected

◆ $logEntries

$logEntries = []
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InMemoryLogger.php


Joomla CMS: Référence de la classe MessagequeueLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • MessagequeueLogger
Fonctions membres publiques
Référence de la classe MessagequeueLogger
+ Graphe d'héritage de MessagequeueLogger:
Logger

Fonctions membres publiques

addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Membres hérités additionnels

- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla MessageQueue logger class.

This class is designed to output logs to a specific MySQL database table. Fields in this table are based on the Syslog style of log output. This is designed to allow quick and easy searching.

Depuis
1.7.0

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
1.7.0

Références Log\ALERT, Log\CRITICAL, Log\EMERGENCY, Log\ERROR, Factory\getApplication(), Log\INFO, Log\NOTICE, et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessagequeueLogger.php


Joomla CMS: Référence de la classe SyslogLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • SyslogLogger
Fonctions membres publiques | Attributs protégés
Référence de la classe SyslogLogger
+ Graphe d'héritage de SyslogLogger:
Logger

Fonctions membres publiques

__construct (array &$options)
__destruct ()
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$priorities
- Attributs protégés hérités de Logger
$options = array()
$priorities

Description détaillée

Joomla! Syslog Log class

This class is designed to call the PHP Syslog function call which is then sent to the system wide log system. For Linux/Unix based systems this is the syslog subsystem, for the Windows based implementations this can be found in the Event Log. For Windows, permissions may prevent PHP from properly outputting messages.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
1.7.0

Références Logger\$options, et Symfony\Contracts\Service\__construct().

◆ __destruct()

__destruct ( )

Destructor.

Depuis
1.7.0

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
1.7.0

Documentation des champs

◆ $priorities

$priorities
protected
Valeur initiale :
= array(
Log::EMERGENCY => 'EMERG',
Log::ALERT => 'ALERT',
Log::CRITICAL => 'CRIT',
Log::ERROR => 'ERR',
Log::WARNING => 'WARNING',
Log::NOTICE => 'NOTICE',
Log::INFO => 'INFO',
Log::DEBUG => 'DEBUG',
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • SyslogLogger.php


Joomla CMS: Référence de la classe W3cLogger

  • Joomla
  • CMS
  • Log
  • Logger
  • W3cLogger
Fonctions membres publiques | Attributs protégés
Référence de la classe W3cLogger
+ Graphe d'héritage de W3cLogger:
FormattedtextLogger Logger

Fonctions membres publiques

__construct (array &$options)
- Fonctions membres publiques hérités de FormattedtextLogger
__construct (array &$options)
__destruct ()
addEntry (LogEntry $entry)
- Fonctions membres publiques hérités de Logger
__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$format = '{DATE} {TIME} {PRIORITY} {CLIENTIP} {CATEGORY} {MESSAGE}'
- Attributs protégés hérités de FormattedtextLogger
$format = '{DATETIME} {PRIORITY} {CLIENTIP} {CATEGORY} {MESSAGE}'
$fields = array()
$path
$defer = false
$deferredEntries = array()
- Attributs protégés hérités de Logger
$options = array()
$priorities

Membres hérités additionnels

- Fonctions membres protégées hérités de FormattedtextLogger
formatLine (LogEntry $entry)
generateFileHeader ()
initFile ()
parseFields ()

Description détaillée

Joomla! W3C Logging class

This class is designed to build log files based on the W3C specification.

1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
1.7.0

Références Logger\$options, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ $format

$format = '{DATE} {TIME} {PRIORITY} {CLIENTIP} {CATEGORY} {MESSAGE}'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • W3cLogger.php


Joomla CMS: Référence de la classe DelegatingPsrLogger

  • Joomla
  • CMS
  • Log
  • DelegatingPsrLogger
Fonctions membres publiques | Attributs protégés
Référence de la classe DelegatingPsrLogger
+ Graphe d'héritage de DelegatingPsrLogger:
AbstractLogger LoggerInterface

Fonctions membres publiques

__construct (Log $logger)
log ($level, $message, array $context=array())
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Attributs protégés

$logger
$priorityMap

Description détaillée

Delegating logger which delegates log messages received from the PSR-3 interface to the Joomla! Log object.

Depuis
3.8.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Log $logger )

Constructor.

Paramètres
Log $logger The Log instance to delegate messages to.
Depuis
3.8.0

Documentation des fonctions membres

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = array()
 | ) |  |

Logs with an arbitrary level.

Paramètres
mixed | $level | The log level.
string | $message | The log message.
array | $context | Additional message context.
Renvoie
void
Depuis
3.8.0
Exceptions
InvalidArgumentException

Implémente LoggerInterface.

Références $category, $context, $date, $message, et null.

Documentation des champs

◆ $logger

$logger
protected

◆ $priorityMap

$priorityMap
protected
Valeur initiale :
= array(
LogLevel::EMERGENCY => Log::EMERGENCY,
LogLevel::ALERT => Log::ALERT,
LogLevel::CRITICAL => Log::CRITICAL,
LogLevel::ERROR => Log::ERROR,
LogLevel::WARNING => Log::WARNING,
LogLevel::NOTICE => Log::NOTICE,
LogLevel::INFO => Log::INFO,
LogLevel::DEBUG => Log::DEBUG
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • DelegatingPsrLogger.php


Joomla CMS: Référence de la classe Log

  • Joomla
  • CMS
  • Log
  • Log
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Log

Fonctions membres publiques

registerLogger (string $key, string $class, bool $replace=false)

Fonctions membres publiques statiques

static | add ($entry, $priority=self::INFO, $category='', $date=null, array $context=array())
static | addLogger (array $options, $priorities=self::ALL, $categories=array(), $exclude=false)
static | createDelegatedLogger ()
static | setInstance ($instance)

Champs de données

const | ALL = 30719
const | EMERGENCY = 1
const | ALERT = 2
const | CRITICAL = 4
const | ERROR = 8
const | WARNING = 16
const | NOTICE = 32
const | INFO = 64
const | DEBUG = 128

Fonctions membres protégées

__construct ()
addLoggerInternal (array $options, $priorities=self::ALL, $categories=array(), $exclude=false)
addLogEntry (LogEntry $entry)
findLoggers ($priority, $category)

Attributs protégés

$configurations = array()
$loggers = array()
$lookup = array()
$loggerRegistry

Attributs protégés statiques

static $instance

Description détaillée

Joomla! Log Class

This class hooks into the global log configuration settings to allow for user configured logging events to be sent to where the user wishes them to be sent. On high load sites Syslog is probably the best (pure PHP function), then the text file based loggers (CSV, W3c or plain Formattedtext) and finally MySQL offers the most features (e.g. rapid searching) but will incur a performance hit due to INSERT being issued.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor.

Depuis
1.7.0

Documentation des fonctions membres

◆ add()

static add | ( |  | $entry,
 |  |  | $priority = self::INFO,
 |  |  | $category = '',
 |  |  | $date = null,
 |  | array | $context = array()
 | ) |  |
static

Method to add an entry to the log.

Paramètres
mixed | $entry | The LogEntry object to add to the log or the message for a new LogEntry object.
integer | $priority | Message priority.
string | $category | Type of entry
string | $date | Date of entry (defaults to now if not specified or blank)
array | $context | An optional array with additional message context.
Renvoie
void
Depuis
1.7.0

Références $category, $context, et $date.

Référencé par Response\__construct(), Authentication\__construct(), InstallerExtension\__construct(), DaemonApplication\__construct(), TaskOption\__get(), FormField\__set(), FileStorage\_deleteFolder(), FileStorage\_filesInFolder(), FileStorage\_folders(), Editor\_loadEditor(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), ContactController\_sendEmail(), FtpClient\_verifyResponse(), Installer\abort(), RegistrationModel\activate(), UserHelper\activateUser(), File\append(), Authentication\authenticate(), IndexerController\batch(), DaemonApplication\changeIdentity(), FtpClient\chdir(), FtpClient\chmod(), FtpClient\connect(), File\copy(), Installer\copyFiles(), Folder\create(), FtpClient\create(), LanguageAdapter\createContentLanguage(), Factory\createMailer(), DaemonApplication\daemonize(), MessageModel\delete(), HistoryModel\delete(), File\delete(), Folder\delete(), FtpClient\delete(), AdminModel\delete(), DaemonApplication\detach(), InstallerHelper\detectType(), LanguageAdapter\discover_install(), XmlView\display(), InstallerHelper\downloadPackage(), UpdateModel\downloadPackage(), DaemonApplication\execute(), Folder\files(), ComponentAdapter\finaliseUninstall(), Installer\findManifest(), Folder\folders(), DaemonApplication\fork(), FtpClient\get(), ContentHelper\getActions(), Access\getAssetRules(), CMSApplication\getCfg(), RedisStorage\getConnection(), SysinfoModel\getExtensions(), ItemsModel\getMenu(), MultilangstatusHelper\getModule(), CategoryField\getOptions(), PluginsField\getOptions(), Authentication\getPKCredentialRequestOptions(), Authentication\getPubkeyRequestOptions(), UpdateAdapter\getUpdateSiteResponse(), ExceptionHandler\handleUserDeprecatedErrors(), DaemonApplication\isActive(), HistoryModel\keep(), FtpClient\listDetails(), FtpClient\listNames(), User\load(), Toolbar\loadButtonType(), Changelog\loadFromXml(), Update\loadFromXml(), ExceptionHandler\logException(), FtpClient\login(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), FtpClient\mkdir(), File\move(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), Installer\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), FileAdapter\populateFilesAndFolderList(), InstallerScript\preflight(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), ItemsController\publish(), MessageModel\publish(), AdminModel\publish(), FtpClient\pwd(), FtpClient\read(), ModuleAdapter\refreshManifestCache(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), RegistrationModel\register(), FtpClient\reinit(), LanguageAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), Installer\removeFiles(), FtpClient\rename(), AdminModel\reorder(), LanguageAdapter\resetUserLanguage(), DaemonApplication\restart(), FtpClient\restart(), ApplicationModel\save(), MessageModel\save(), AdminModel\saveorder(), MailModel\send(), Email\sendCode(), IndexerController\sendResponse(), WorkflowModel\setDefault(), StageModel\setDefault(), Mail\setSender(), DaemonApplication\setupSignalHandlers(), DaemonApplication\shutdown(), DaemonApplication\signal(), IndexerController\start(), DaemonApplication\stop(), FtpClient\store(), FtpClient\syst(), InstallerAdapter\uninstall(), File\upload(), Authentication\validateAssertionResponse(), File\write(), FtpClient\write(), et DaemonApplication\writeProcessIdFile().

◆ addLogEntry()

addLogEntry ( LogEntry $entry )
protected

Method to add an entry to the appropriate loggers.

Paramètres
LogEntry $entry The LogEntry object to send to the loggers.
Renvoie
void
Depuis
1.7.0
Exceptions

Références $class, Log\$loggers, $this, et Log\findLoggers().

◆ addLogger()

static addLogger | ( | array | $options,
 |  |  | $priorities = self::ALL,
 |  |  | $categories = array(),
 |  |  | $exclude = false
 | ) |  |
static

Add a logger to the Log instance. Loggers route log entries to the correct files/systems to be logged.

Paramètres
array | $options | The object configuration array.
integer | $priorities | Message priority
array | $categories | Types of entry
boolean | $exclude | If true, all categories will be logged except those in the $categories array
Renvoie
void
Depuis
1.7.0

Références $options.

Référencé par Response\__construct(), Webauthn\__construct(), Task\__construct(), BaseController\__construct(), IndexerController\batch(), ModuleHelper\renderModule(), IndexerController\sendResponse(), CMSApplication\setupLogging(), et IndexerController\start().

◆ addLoggerInternal()

addLoggerInternal | ( | array | $options,
 |  |  | $priorities = self::ALL,
 |  |  | $categories = array(),
 |  |  | $exclude = false
 | ) |  |
protected

Add a logger to the Log instance. Loggers route log entries to the correct files/systems to be logged. This method allows you to extend Log completely.

Paramètres
array | $options | The object configuration array.
integer | $priorities | Message priority
array | $categories | Types of entry
boolean | $exclude | If true, all categories will be logged except those in the $categories array
Renvoie
void
Depuis
1.7.0

Références $options, et elseif.

◆ createDelegatedLogger()

static createDelegatedLogger ( )
static

Creates a delegated PSR-3 compatible logger from the current singleton instance. This method always returns a new delegated logger.

Renvoie
DelegatingPsrLogger
Depuis
3.8.0

Référencé par Task\__construct(), et Logger\register().

◆ findLoggers()

findLoggers | ( | $priority,
 |  | $category
 | ) |
protected

Method to find the loggers to use based on priority and category values.

Paramètres
integer | $priority | Message priority.
string | $category | Type of entry
Renvoie
array The array of loggers to use for the given priority and category values.
Depuis
1.7.0

Références $category, et Log\$loggers.

Référencé par Log\addLogEntry().

◆ registerLogger()

registerLogger | ( | string | $key,
 |  | string | $class,
 |  | bool | $replace = false
 | ) |  |

Register a logger to the registry

Paramètres
string | $key | The service key to be registered
string | $class | The class name of the logger
boolean | $replace | Flag indicating the service key may replace an existing definition
Renvoie
void
Depuis
4.0.0

Références $class, et $key.

◆ setInstance()

static setInstance ( $instance )
static

Returns a reference to the a Log object, only creating it if it doesn't already exist. Note: This is principally made available for testing and internal purposes.

Paramètres
Log $instance The logging object instance to be used by the static methods.
Renvoie
void
Depuis
1.7.0

Références Log\$instance, et null.

Documentation des champs

◆ $configurations

$configurations = array()
protected

◆ $instance

$instance
staticprotected

Référencé par Log\setInstance().

◆ $loggerRegistry

$loggerRegistry
protected

◆ $loggers

$loggers = array()
protected

Référencé par Log\addLogEntry(), et Log\findLoggers().

◆ $lookup

$lookup = array()
protected

◆ ALERT

const ALERT = 2

Référencé par Webauthn\__construct(), MessagequeueLogger\addEntry(), et CMSApplication\setupLogging().

◆ ALL

const ALL = 30719

Référencé par Webauthn\__construct(), Task\__construct(), BaseController\__construct(), ModuleHelper\renderModule(), et CMSApplication\setupLogging().

◆ CRITICAL

const CRITICAL = 4

Référencé par Webauthn\__construct(), MessagequeueLogger\addEntry(), DaemonApplication\daemonize(), ExceptionHandler\logException(), et CMSApplication\setupLogging().

◆ DEBUG

const DEBUG = 128

Référencé par DaemonApplication\detach(), DaemonApplication\fork(), RedisStorage\getConnection(), Authentication\getPubkeyRequestOptions(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), DaemonApplication\setupSignalHandlers(), et DaemonApplication\signal().

◆ EMERGENCY

const EMERGENCY = 1

Référencé par Webauthn\__construct(), MessagequeueLogger\addEntry(), DaemonApplication\daemonize(), CMSApplication\setupLogging(), DaemonApplication\setupSignalHandlers(), DaemonApplication\signal(), et DaemonApplication\writeProcessIdFile().

◆ ERROR

const ERROR = 8

Référencé par Response\__construct(), Webauthn\__construct(), DaemonApplication\__construct(), MessagequeueLogger\addEntry(), DaemonApplication\changeIdentity(), XmlView\display(), ContentHelper\getActions(), ItemsModel\getMenu(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), IndexerController\sendResponse(), CMSApplication\setupLogging(), et DaemonApplication\writeProcessIdFile().

◆ INFO

const INFO = 64

Référencé par LogEntry\__construct(), MessagequeueLogger\addEntry(), IndexerController\batch(), DaemonApplication\changeIdentity(), UpdateModel\downloadPackage(), DaemonApplication\execute(), Access\getAssetRules(), UpdateAdapter\getUpdateSiteResponse(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), Installer\parseSchemaUpdates(), DaemonApplication\restart(), DaemonApplication\shutdown(), IndexerController\start(), et DaemonApplication\stop().

◆ NOTICE

const NOTICE = 32

Référencé par MessagequeueLogger\addEntry(), LanguageAdapter\createContentLanguage(), Authentication\getPKCredentialRequestOptions(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), LanguageAdapter\resetUserLanguage(), et Authentication\validateAssertionResponse().

◆ WARNING

const WARNING = 16

Référencé par Authentication\__construct(), InstallerExtension\__construct(), TaskOption\__get(), FileStorage\_deleteFolder(), FileStorage\_filesInFolder(), FileStorage\_folders(), Editor\_loadEditor(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), ContactController\_sendEmail(), FtpClient\_verifyResponse(), Installer\abort(), RegistrationModel\activate(), UserHelper\activateUser(), MessagequeueLogger\addEntry(), File\append(), Authentication\authenticate(), FtpClient\chdir(), FtpClient\chmod(), FtpClient\connect(), File\copy(), Installer\copyFiles(), Folder\create(), FtpClient\create(), Factory\createMailer(), DaemonApplication\daemonize(), MessageModel\delete(), HistoryModel\delete(), File\delete(), Folder\delete(), FtpClient\delete(), AdminModel\delete(), InstallerHelper\detectType(), LanguageAdapter\discover_install(), XmlView\display(), InstallerHelper\downloadPackage(), Folder\files(), ComponentAdapter\finaliseUninstall(), Installer\findManifest(), Folder\folders(), FtpClient\get(), Access\getAssetRules(), CMSApplication\getCfg(), SysinfoModel\getExtensions(), MultilangstatusHelper\getModule(), CategoryField\getOptions(), PluginsField\getOptions(), UpdateAdapter\getUpdateSiteResponse(), ExceptionHandler\handleUserDeprecatedErrors(), DaemonApplication\isActive(), HistoryModel\keep(), FtpClient\listDetails(), FtpClient\listNames(), User\load(), Toolbar\loadButtonType(), Changelog\loadFromXml(), Update\loadFromXml(), FtpClient\login(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), FtpClient\mkdir(), File\move(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), Installer\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), FileAdapter\populateFilesAndFolderList(), InstallerScript\preflight(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), ItemsController\publish(), MessageModel\publish(), AdminModel\publish(), FtpClient\pwd(), FtpClient\read(), ModuleAdapter\refreshManifestCache(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), RegistrationModel\register(), FtpClient\reinit(), LanguageAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), Installer\removeFiles(), FtpClient\rename(), AdminModel\reorder(), FtpClient\restart(), ApplicationModel\save(), MessageModel\save(), AdminModel\saveorder(), MailModel\send(), Email\sendCode(), WorkflowModel\setDefault(), StageModel\setDefault(), Mail\setSender(), FtpClient\store(), FtpClient\syst(), InstallerAdapter\uninstall(), File\upload(), File\write(), et FtpClient\write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Log.php


Joomla CMS: Référence de la classe LogEntry

  • Joomla
  • CMS
  • Log
  • LogEntry
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe LogEntry

Fonctions membres publiques

__construct ($message, $priority=Log::INFO, $category='', $date=null, array $context=array())

Champs de données

$category
$context
$date
$message
$priority = Log::INFO
$callStack = array()

Attributs protégés

$priorities

Description détaillée

Joomla! Log Entry class

This class is designed to hold log entries for either writing to an engine, or for supported engines, retrieving lists and building in memory (PHP based) search operations.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message,
 |  |  | $priority = Log::INFO,
 |  |  | $category = '',
 |  |  | $date = null,
 |  | array | $context = array()
 | ) |  |

Constructor

Paramètres
string | $message | The message to log.
int | $priority | Message priority based on {$this->priorities}.
string | $category | Type of entry
string | $date | Date of entry (defaults to now if not specified or blank)
array | $context | An optional array with additional message context.
Depuis
1.7.0 3.10.7 If the message contains a full path, the root path (JPATH_ROOT) is removed from it to avoid any full path disclosure. Before 3.10.7, the path was propagated as provided.

Références $category, $context, $date, $message, category, Log\INFO, et Path\removeRoot().

Documentation des champs

◆ $callStack

$callStack = array()

◆ $category

$category

◆ $context

$context

◆ $date

$date

◆ $message

$message

◆ $priorities

$priorities
protected
Valeur initiale :
= array(
Log::EMERGENCY,
Log::ALERT,
Log::CRITICAL,
Log::ERROR,
Log::WARNING,
Log::NOTICE,
Log::INFO,
Log::DEBUG,
)

◆ $priority

$priority = Log::INFO
La documentation de cette classe a été générée à partir du fichier suivant :
  • LogEntry.php


Joomla CMS: Référence de la classe Logger

  • Joomla
  • CMS
  • Log
  • Logger
Fonctions membres publiques | Attributs protégés
Référence de la classe Logger
+ Graphe d'héritage de Logger:
CallbackLogger DatabaseLogger EchoLogger FormattedtextLogger InMemoryLogger MessagequeueLogger SyslogLogger W3cLogger

Fonctions membres publiques

__construct (array &$options)
addEntry (LogEntry $entry)

Attributs protégés

$options = array()
$priorities

Description détaillée

Joomla! Logger Base Class

This class is used to be the basis of logger classes to allow for defined functions to exist regardless of the child class.

Depuis
3.0.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array & $options )

Constructor.

Paramètres
array &$options Log object options.
Depuis
3.0.1

Références $options.

Documentation des fonctions membres

◆ addEntry()

addEntry ( LogEntry $entry )
abstract

Method to add an entry to the log.

Paramètres
LogEntry $entry The log entry object to add to the log.
Renvoie
void
Depuis
3.0.1
Exceptions

Documentation des champs

◆ $options

$options = array()
protected

Référencé par EchoLogger\__construct(), W3cLogger\__construct(), CallbackLogger\__construct(), InMemoryLogger\__construct(), SyslogLogger\__construct(), FormattedtextLogger\__construct(), DatabaseLogger\__construct(), et DatabaseLogger\connect().

◆ $priorities

$priorities
protected
Valeur initiale :
= array(
Log::EMERGENCY => 'EMERGENCY',
Log::ALERT => 'ALERT',
Log::CRITICAL => 'CRITICAL',
Log::ERROR => 'ERROR',
Log::WARNING => 'WARNING',
Log::NOTICE => 'NOTICE',
Log::INFO => 'INFO',
Log::DEBUG => 'DEBUG',
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • Log/Logger.php


Joomla CMS: Référence de la classe LoggerRegistry

  • Joomla
  • CMS
  • Log
  • LoggerRegistry
Fonctions membres publiques | Attributs privés
Référence de la classe LoggerRegistry

Fonctions membres publiques

getLoggerClass (string $key)
hasLogger (string $key)
register (string $key, string $class, bool $replace=false)

Attributs privés

$loggerMap

Description détaillée

Service registry for loggers

Depuis
4.0.0

Documentation des fonctions membres

◆ getLoggerClass()

getLoggerClass ( string $key )

Get the logger class for a given key

Paramètres
string $key The key to look up
Renvoie
string
Depuis
4.0.0
Exceptions

Références $key.

◆ hasLogger()

hasLogger ( string $key )

Check if the registry has a logger for the given key

Paramètres
string $key The key to look up
Renvoie
boolean
Depuis
4.0.0

Références $key.

◆ register()

register | ( | string | $key,
 |  | string | $class,
 |  | bool | $replace = false
 | ) |  |

Register a logger

Paramètres
string | $key | The service key to be registered
string | $class | The class name of the logger
boolean | $replace | Flag indicating the service key may replace an existing definition
Renvoie
void
Depuis
4.0.0

Références $class, et $key.

Documentation des champs

◆ $loggerMap

$loggerMap
private
Valeur initiale :
= [
'callback' => Logger\CallbackLogger::class
La documentation de cette classe a été générée à partir du fichier suivant :
  • LoggerRegistry.php


Joomla CMS: Référence de la classe MailDisabledException

  • Joomla
  • CMS
  • Mail
  • Exception
  • MailDisabledException
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe MailDisabledException
+ Graphe d'héritage de MailDisabledException:

Fonctions membres publiques

__construct (string $reason, string $message='', int $code=0, \Throwable $previous=null)
getReason ()

Champs de données

const | REASON_USER_DISABLED = 'user_disabled'
const | REASON_MAIL_FUNCTION_NOT_AVAILABLE = 'mail_function_not_available'

Attributs privés

$reason

Description détaillée

Exception class defining an error for disabled mail functionality.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $reason,
 |  | string | $message = '',
 |  | int | $code = 0,
 |  | \Throwable | $previous = null
 | ) |  |

Constructor.

Paramètres
string | $reason | The reason why mail is disabled.
string | $message | The Exception message to throw.
integer | $code | The Exception code.
\Throwable | $previous | The previous exception used for the exception chaining.
Depuis
4.0.0

Références $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getReason()

getReason ( )

Method to return the reason why mail is disabled.

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $reason

$reason
private

◆ REASON_MAIL_FUNCTION_NOT_AVAILABLE

const REASON_MAIL_FUNCTION_NOT_AVAILABLE = 'mail_function_not_available'

Référencé par Mail\Send().

◆ REASON_USER_DISABLED

const REASON_USER_DISABLED = 'user_disabled'

Référencé par Mail\Send().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MailDisabledException.php


Joomla CMS: Référence de la classe Mail

  • Joomla
  • CMS
  • Mail
  • Mail
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe Mail
+ Graphe d'héritage de Mail:
PHPMailer

Fonctions membres publiques

Send ()
setSender ($from)
setSubject ($subject)
setBody ($content)
addRecipient ($recipient, $name='')
addCc ($cc, $name='')
addBcc ($bcc, $name='')
addAttachment ($path, $name='', $encoding='base64', $type='application/octet-stream', $disposition='attachment')
clearAttachments ()
removeAttachment ($index=0)
addReplyTo ($replyto, $name='')
isHtml ($ishtml=true)
isSendmail ()
useSendmail ($sendmail=null)
useSmtp ($auth=null, $host=null, $user=null, $pass=null, $secure=null, $port=25)
sendMail ( $from, $fromName, $recipient, $subject, $body, $mode=false, $cc=null, $bcc=null, $attachment=null, $replyTo=null, $replyToName=null)
- Fonctions membres publiques hérités de PHPMailer
__construct ($exceptions=null)
__destruct ()
isHTML ($isHtml=true)
isSMTP ()
isMail ()
isSendmail ()
isQmail ()
addAddress ($address, $name='')
addCC ($address, $name='')
addBCC ($address, $name='')
addReplyTo ($address, $name='')
setFrom ($address, $name='', $auto=true)
getLastMessageID ()
punyencodeAddress ($address)
send ()
preSend ()
postSend ()
getSMTPInstance ()
setSMTPInstance (SMTP $smtp)
smtpConnect ($options=null)
smtpClose ()
setLanguage ($langcode='en', $lang_path='')
getTranslations ()
addrAppend ($type, $addr)
addrFormat ($addr)
wrapText ($message, $length, $qp_mode=false)
utf8CharBoundary ($encodedText, $maxLength)
setWordWrap ()
createHeader ()
getMailMIME ()
getSentMIMEMessage ()
createBody ()
headerLine ($name, $value)
textLine ($value)
addAttachment ( $path, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='attachment')
getAttachments ()
encodeString ($str, $encoding=self::ENCODING_BASE64)
encodeHeader ($str, $position='text')
hasMultiBytes ($str)
has8bitChars ($text)
base64EncodeWrapMB ($str, $linebreak=null)
encodeQP ($string)
encodeQ ($str, $position='text')
addStringAttachment ( $string, $filename, $encoding=self::ENCODING_BASE64, $type='', $disposition='attachment')
addEmbeddedImage ( $path, $cid, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='inline')
addStringEmbeddedImage ( $string, $cid, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='inline')
inlineImageExists ()
attachmentExists ()
alternativeExists ()
clearQueuedAddresses ($kind)
clearAddresses ()
clearCCs ()
clearBCCs ()
clearReplyTos ()
clearAllRecipients ()
clearAttachments ()
clearCustomHeaders ()
isError ()
addCustomHeader ($name, $value=null)
getCustomHeaders ()
msgHTML ($message, $basedir='', $advanced=false)
html2text ($html, $advanced=false)
set ($name, $value='')
secureHeader ($str)
sign ($cert_filename, $key_filename, $key_pass, $extracerts_filename='')
DKIM_QP ($txt)
DKIM_Sign ($signHeader)
DKIM_HeaderC ($signHeader)
DKIM_BodyC ($body)
DKIM_Add ($headers_line, $subject, $body)
getToAddresses ()
getCcAddresses ()
getBccAddresses ()
getReplyToAddresses ()
getAllRecipientAddresses ()
getOAuth ()
setOAuth (OAuthTokenProvider $oauth)

Fonctions membres publiques statiques

static | getInstance ($id='Joomla', $exceptions=true)
- Fonctions membres publiques statiques hérités de PHPMailer
static | parseAddresses ($addrstr, $useimap=true, $charset=self::CHARSET_ISO88591)
static | validateAddress ($address, $patternselect=null)
static | idnSupported ()
static | rfcDate ()
static | isValidHost ($host)
static | _mime_types ($ext='')
static | filenameToType ($filename)
static | mb_pathinfo ($path, $options=null)
static | normalizeBreaks ($text, $breaktype=null)
static | stripTrailingWSP ($text)
static | getLE ()
static | hasLineLongerThanMax ($str)
static | quotedString ($str)

Champs de données

$CharSet = 'utf-8'
- Champs de données hérités de PHPMailer
const | CHARSET_ASCII = 'us-ascii'
const | CHARSET_ISO88591 = 'iso-8859-1'
const | CHARSET_UTF8 = 'utf-8'
const | CONTENT_TYPE_PLAINTEXT = 'text/plain'
const | CONTENT_TYPE_TEXT_CALENDAR = 'text/calendar'
const | CONTENT_TYPE_TEXT_HTML = 'text/html'
const | CONTENT_TYPE_MULTIPART_ALTERNATIVE = 'multipart/alternative'
const | CONTENT_TYPE_MULTIPART_MIXED = 'multipart/mixed'
const | CONTENT_TYPE_MULTIPART_RELATED = 'multipart/related'
const | ENCODING_7BIT = '7bit'
const | ENCODING_8BIT = '8bit'
const | ENCODING_BASE64 = 'base64'
const | ENCODING_BINARY = 'binary'
const | ENCODING_QUOTED_PRINTABLE = 'quoted-printable'
const | ENCRYPTION_STARTTLS = 'tls'
const | ENCRYPTION_SMTPS = 'ssl'
const | ICAL_METHOD_REQUEST = 'REQUEST'
const | ICAL_METHOD_PUBLISH = 'PUBLISH'
const | ICAL_METHOD_REPLY = 'REPLY'
const | ICAL_METHOD_ADD = 'ADD'
const | ICAL_METHOD_CANCEL = 'CANCEL'
const | ICAL_METHOD_REFRESH = 'REFRESH'
const | ICAL_METHOD_COUNTER = 'COUNTER'
const | ICAL_METHOD_DECLINECOUNTER = 'DECLINECOUNTER'
$Priority
$CharSet = self::CHARSET_ISO88591
$ContentType = self::CONTENT_TYPE_PLAINTEXT
$Encoding = self::ENCODING_8BIT
$ErrorInfo = ''
$From = ''
$FromName = ''
$Sender = ''
$Subject = ''
$Body = ''
$AltBody = ''
$Ical = ''
$WordWrap = 0
$Mailer = 'mail'
$Sendmail = '/usr/sbin/sendmail'
$UseSendmailOptions = true
$ConfirmReadingTo = ''
$Hostname = ''
$MessageID = ''
$MessageDate = ''
$Host = 'localhost'
$Port = 25
$Helo = ''
$SMTPSecure = ''
$SMTPAutoTLS = true
$SMTPAuth = false
$SMTPOptions = []
$Username = ''
$Password = ''
$AuthType = ''
$Timeout = 300
$dsn = ''
$SMTPDebug = 0
$Debugoutput = 'echo'
$SMTPKeepAlive = false
$SingleTo = false
$do_verp = false
$AllowEmpty = false
$DKIM_selector = ''
$DKIM_identity = ''
$DKIM_passphrase = ''
$DKIM_domain = ''
$DKIM_copyHeaderFields = true
$DKIM_extraHeaders = []
$DKIM_private = ''
$DKIM_private_string = ''
$action_function = ''
$XMailer = ''
const | VERSION = '6.6.0'
const | STOP_MESSAGE = 0
const | STOP_CONTINUE = 1
const | STOP_CRITICAL = 2
const | CRLF = "\r\n"
const | FWS = ' '
const | MAIL_MAX_LINE_LENGTH = 63
const | MAX_LINE_LENGTH = 998
const | STD_LINE_LENGTH = 76

Fonctions membres protégées

add ($recipient, $name='', $method='addAddress')
- Fonctions membres protégées hérités de PHPMailer
edebug ($str)
addOrEnqueueAnAddress ($kind, $address, $name)
addAnAddress ($kind, $address, $name='')
sendmailSend ($header, $body)
mailSend ($header, $body)
smtpSend ($header, $body)
generateId ()
getBoundary ($boundary, $charSet, $contentType, $encoding)
endBoundary ($boundary)
setMessageType ()
attachAll ($disposition_type, $boundary)
encodeFile ($path, $encoding=self::ENCODING_BASE64)
validateEncoding ($encoding)
cidExists ($cid)
setError ($msg)
serverHostname ()
lang ($key)
doCallback ($isSent, $to, $cc, $bcc, $subject, $body, $from, $extra)

Attributs protégés statiques

static | $instances = array()
- Attributs protégés statiques hérités de PHPMailer
static | $IcalMethods
static | $LE = self::CRLF

Membres hérités additionnels

- Attributs publics statiques hérités de PHPMailer
static | $validator = 'php'
- Fonctions membres protégées statiques hérités de PHPMailer
static | isShellSafe ($string)
static | isPermittedPath ($path)
static | fileIsAccessible ($path)
static | setLE ($le)
- Attributs protégés hérités de PHPMailer
$MIMEBody = ''
$MIMEHeader = ''
$mailHeader = ''
$oauth
$SingleToArray = []
$smtp
$to = []
$cc = []
$bcc = []
$ReplyTo = []
$all_recipients = []
$RecipientsQueue = []
$ReplyToQueue = []
$attachment = []
$CustomHeader = []
$lastMessageID = ''
$message_type = ''
$boundary = []
$language = []
$error_count = 0
$sign_cert_file = ''
$sign_key_file = ''
$sign_extracerts_file = ''
$sign_key_pass = ''
$exceptions = false
$uniqueid = ''

Description détaillée

Email Class. Provides a common interface to send email from the Joomla! Platform

Depuis
1.7.0

Documentation des fonctions membres

◆ add()

add | ( | $recipient,
 |  | $name = '',
 |  | $method = 'addAddress'
 | ) |
protected

Add recipients to the email.

Paramètres
mixed | $recipient | Either a string or array of strings [email address(es)]
mixed | $name | Either a string or array of strings [name(s)]
string | $method | The parent method's name.
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure.
Depuis
1.7.0
Exceptions

Références $method, $name, $this, PHPMailer\$to, et MailHelper\cleanLine().

Référencé par Mail\addBcc(), Mail\addCc(), Mail\addRecipient(), et Mail\addReplyTo().

◆ addAttachment()

addAttachment | ( | $path,
 |  | $name = '',
 |  | $encoding = 'base64',
 |  | $type = 'application/octet-stream',
 |  | $disposition = 'attachment'
 | ) |

Add file attachment to the email

Paramètres
mixed | $path | Either a string or array of strings [filenames]
mixed | $name | Either a string or array of strings [names]. N.B. if this is an array it must contain the same number of elements as the array of paths supplied.
mixed | $encoding | The encoding of the attachment
mixed | $type | The mime type
string | $disposition | The disposition of the attachment
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure when exception throwing is disabled.
Depuis
3.0.1
Exceptions

Références $key, $name, $path, $result, $this, et $type.

Référencé par Mail\sendMail().

◆ addBcc()

addBcc | ( | $bcc,
 |  | $name = ''
 | ) |

Add blind carbon copy recipients to the email

Paramètres
mixed | $bcc | Either a string or array of strings [email address(es)]
mixed | $name | Either a string or array of strings [name(s)]
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure when exception throwing is disabled.
Depuis
1.7.0
Exceptions
phpmailerException if exception throwing is enabled

Références PHPMailer\$bcc, $name, $this, et Mail\add().

Référencé par Mail\sendMail().

◆ addCc()

addCc | ( | $cc,
 |  | $name = ''
 | ) |

Add carbon copy recipients to the email

Paramètres
mixed | $cc | Either a string or array of strings [email address(es)]
mixed | $name | Either a string or array of strings [name(s)]
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure when exception throwing is enabled.
Depuis
1.7.0
Exceptions
phpmailerException if exception throwing is enabled

Références PHPMailer\$cc, $name, $this, et Mail\add().

Référencé par Mail\sendMail().

◆ addRecipient()

addRecipient | ( | $recipient,
 |  | $name = ''
 | ) |

Add recipients to the email

Paramètres
mixed | $recipient | Either a string or array of strings [email address(es)]
mixed | $name | Either a string or array of strings [name(s)]
Renvoie
Mail|boolean Returns this object for chaining on success or false on failure when exception throwing is disabled.
Depuis
1.7.0
Exceptions
phpmailerException if exception throwing is enabled

Références $name, et Mail\add().

Référencé par Mail\sendMail().

◆ addReplyTo()

addReplyTo | ( | $replyto,
 |  | $name = ''
 | ) |

Add Reply to email address(es) to the email

Paramètres
mixed | $replyto | Either a string or array of strings [email address(es)]
mixed | $name | Either a string or array of strings [name(s)]
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure when exception throwing is disabled.
Depuis
1.7.0
Exceptions
phpmailerException if exception throwing is enabled

Références $name, et Mail\add().

Référencé par Mail\sendMail().

◆ clearAttachments()

clearAttachments ( )

Unset all file attachments from the email

Renvoie
Mail Returns this object for chaining.
Depuis
3.0.1

Références $this.

◆ getInstance()

static getInstance | ( | $id = 'Joomla',
 |  | $exceptions = true
 | ) |
static

Returns the global email object, only creating it if it doesn't already exist.

NOTE: If you need an instance to use that does not have the global configuration values, use an id string that is not 'Joomla'.

Paramètres
string | $id | The id string for the Mail instance [optional]
boolean | $exceptions | Flag if Exceptions should be thrown [optional]
Renvoie
Mail The global Mail object
Depuis
1.7.0

Références PHPMailer\$exceptions, et $id.

Référencé par Factory\createMailer().

◆ isHtml()

isHtml ( $ishtml = true )

Sets message type to HTML

Paramètres
boolean $ishtml Boolean true or false.
Renvoie
Mail Returns this object for chaining.
Depuis
3.1.4

Références $this.

Référencé par Mail\sendMail().

◆ isSendmail()

isSendmail ( )

Send messages using $Sendmail.

This overrides the parent class to remove the restriction on the executable's name containing the word "sendmail"

Renvoie
void
Depuis
1.7.0

Références Factory\getApplication().

Référencé par Mail\useSendmail().

◆ removeAttachment()

removeAttachment ( $index = 0 )

Unset file attachments specified by array index.

Paramètres
integer $index The numerical index of the attachment to remove
Renvoie
Mail Returns this object for chaining.
Depuis
3.0.1

Références $this.

◆ Send()

Send ( )

Send the mail

Renvoie
boolean Boolean true if successful, false if exception throwing is disabled.
Depuis
1.7.0
Exceptions
MailDisabledException | if the mail function is disabled
phpmailerException | if sending failed

Références $result, Text\_(), Factory\getApplication(), MailDisabledException\REASON_MAIL_FUNCTION_NOT_AVAILABLE, et MailDisabledException\REASON_USER_DISABLED.

Référencé par Mail\sendMail().

◆ sendMail()

sendMail | ( | $from,
 |  | $fromName,
 |  | $recipient,
 |  | $subject,
 |  | $body,
 |  | $mode = false,
 |  | $cc = null,
 |  | $bcc = null,
 |  | $attachment = null,
 |  | $replyTo = null,
 |  | $replyToName = null
 | ) |

Function to send an email

Paramètres
string | $from | From email address
string | $fromName | From name
mixed | $recipient | Recipient email address(es)
string | $subject | email subject
string | $body | Message body
boolean | $mode | false = plain text, true = HTML
mixed | $cc | CC email address(es)
mixed | $bcc | BCC email address(es)
mixed | $attachment | Attachment file name(s)
mixed | $replyTo | Reply to email address(es)
mixed | $replyToName | Reply to name(s)
Renvoie
boolean True on success, false on failure when exception throwing is disabled.
Depuis
1.7.0
Exceptions
MailDisabledException | if the mail function is disabled
phpmailerException | if exception throwing is enabled

Références $app, PHPMailer\$attachment, PHPMailer\$bcc, PHPMailer\$cc, $i, $mode, $subject, Mail\addAttachment(), Mail\addBcc(), Mail\addCc(), Mail\addRecipient(), Mail\addReplyTo(), elseif, Factory\getApplication(), Mail\isHtml(), Mail\Send(), Mail\setBody(), Mail\setSender(), et Mail\setSubject().

◆ setBody()

setBody ( $content )

Set the email body

Paramètres
string $content Body of the email
Renvoie
Mail Returns this object for chaining.
Depuis
1.7.0

Références $content, $this, et MailHelper\cleanText().

Référencé par Mail\sendMail().

◆ setSender()

setSender ( $from )

Set the email sender

Paramètres
mixed $from email address and Name of sender array([0] => email Address, [1] => Name) or as a string
Renvoie
Mail|boolean Returns this object for chaining on success or boolean false on failure.
Depuis
1.7.0
Exceptions

Références $result, $this, Log\add(), MailHelper\cleanLine(), elseif, PHPMailer\setFrom(), Text\sprintf(), et Log\WARNING.

Référencé par Mail\sendMail().

◆ setSubject()

setSubject ( $subject )

Set the email subject

Paramètres
string $subject Subject of the email
Renvoie
Mail Returns this object for chaining.
Depuis
1.7.0

Références $subject, $this, et MailHelper\cleanLine().

Référencé par Mail\sendMail().

◆ useSendmail()

useSendmail ( $sendmail = null )

Use sendmail for sending the email

Paramètres
string $sendmail Path to sendmail [optional]
Renvoie
boolean True on success
Depuis
1.7.0

Références PHPMailer\isMail(), et Mail\isSendmail().

◆ useSmtp()

useSmtp | ( | $auth = null,
 |  | $host = null,
 |  | $user = null,
 |  | $pass = null,
 |  | $secure = null,
 |  | $port = 25
 | ) |

Use SMTP for sending the email

Paramètres
string | $auth | SMTP Authentication [optional]
string | $host | SMTP Host [optional]
string | $user | SMTP Username [optional]
string | $pass | SMTP Password [optional]
string | $secure | Use secure methods
integer | $port | The SMTP port
Renvoie
boolean True on success
Depuis
1.7.0

Références $user, PHPMailer\isMail(), PHPMailer\isSMTP(), et null.

Documentation des champs

◆ $CharSet

$CharSet = 'utf-8'

◆ $instances

$instances = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Mail.php


Joomla CMS: Référence de la classe MailHelper

  • Joomla
  • CMS
  • Mail
  • MailHelper
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe MailHelper

Fonctions membres publiques statiques

static | cleanLine ($value)
static | cleanText ($value)
static | cleanBody ($body)
static | cleanSubject ($subject)
static | cleanAddress ($address)
static | isEmailAddress ($email)
static | convertRelativeToAbsoluteUrls ($content)

Fonctions membres privées statiques

static checkContent ($content)

Description détaillée

Email helper class, provides static methods to perform various tasks relevant to the Joomla email routines.

Depuis
1.7.0

Documentation des fonctions membres

◆ checkContent()

static checkContent ( $content )
staticprivate

Check the content after regular expression function call.

Paramètres
string $content Content to be checked.
Renvoie
void
Exceptions

Références $content, $message, et null.

◆ cleanAddress()

static cleanAddress ( $address )
static

Verifies that an email address does not have any extra headers injected into it.

Paramètres
string $address email address.
Renvoie
mixed email address string or boolean false if injected headers are present.
Depuis
1.7.0

◆ cleanBody()

static cleanBody ( $body )
static

Cleans any injected headers from the email body.

Paramètres
string $body email body string.
Renvoie
string Cleaned email body string.
Depuis
1.7.0

◆ cleanLine()

static cleanLine ( $value )
static

Cleans single line inputs.

Paramètres
string $value String to be cleaned.
Renvoie
string Cleaned string.
Depuis
1.7.0

Références $value, et PunycodeHelper\emailToPunycode().

Référencé par Mail\add(), Factory\createMailer(), Mail\setSender(), et Mail\setSubject().

◆ cleanSubject()

static cleanSubject ( $subject )
static

Cleans any injected headers from the subject string.

Paramètres
string $subject email subject string.
Renvoie
string Cleaned email subject string.
Depuis
1.7.0

Références $subject.

◆ cleanText()

static cleanText ( $value )
static

Cleans multi-line inputs.

Paramètres
string $value Multi-line string to be cleaned.
Renvoie
string Cleaned multi-line string.
Depuis
1.7.0

Références $value.

Référencé par Mail\setBody().

◆ convertRelativeToAbsoluteUrls()

static convertRelativeToAbsoluteUrls ( $content )
static

Convert relative (links, images sources) to absolute urls so that content is accessible in email

Paramètres
string $content The content need to convert
Renvoie
string The converted content which the relative urls are converted to absolute urls
Depuis
4.1.0

Références $attributes, $content, Route\link(), Uri\root(), et Route\TLS_IGNORE.

◆ isEmailAddress()

static isEmailAddress ( $email )
static

Verifies that the string is in a proper email address format.

Paramètres
string $email String to be verified.
Renvoie
boolean True if string has the correct format; false otherwise.
Depuis
1.7.0

Références PunycodeHelper\toPunycode().

Référencé par User\check(), Factory\createMailer(), et HtmlView\display().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MailHelper.php


Joomla CMS: Référence de la classe MailTemplate

  • Joomla
  • CMS
  • Mail
  • MailTemplate
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MailTemplate

Fonctions membres publiques

__construct ($templateId, $language, Mail $mailer=null)
addAttachment ($name, $file)
addRecipient ($mail, $name=null, $type='to')
setReplyTo ($mail, $name='')
addTemplateData ($data)

Fonctions membres publiques statiques

static | getTemplate ($key, $language)
static | createTemplate ($key, $subject, $body, $tags, $htmlbody='')
static | updateTemplate ($key, $subject, $body, $tags, $htmlbody='')
static | deleteTemplate ($key)

Fonctions membres protégées

replaceTags ($text, $tags)
getAttachmentName (string $file, string $name)

Attributs protégés

$mailer
$template_id
$language
$data = array()
$attachments = array()
$recipients = array()
$replyto

Description détaillée

Email Templating Class

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $templateId,
 |  |  | $language,
 |  | Mail | $mailer = null
 | ) |  |

Constructor for the mail templating class

Paramètres
string | $templateId | Id of the mail template.
string | $language | Language of the template to use.
Mail | $mailer | Mail object to send the mail with.
Depuis
4.0.0

Références PHPMailer\$language, Factory\getMailer(), et language.

Documentation des fonctions membres

◆ addAttachment()

addAttachment | ( | $name,
 |  | $file
 | ) |

Add an attachment to the mail

Paramètres
string | $name | Filename of the attachment
string | $file | Either a filepath or filecontent
Renvoie
void
Depuis
4.0.0

Références PHPMailer\$attachment, et $name.

◆ addRecipient()

addRecipient | ( | $mail,
 |  | $name = null,
 |  | $type = 'to'
 | ) |

Adds recipients for this mail

Paramètres
string | $mail | Mail address of the recipient
string | $name | Name of the recipient
string | $type | How should the recipient receive the mail? ('to', 'cc', 'bcc')
Renvoie
void
Depuis
4.0.0

Références $name, et $type.

Référencé par ContactController\_sendEmail(), et Email\sendCode().

◆ addTemplateData()

addTemplateData ( $data )

Add data to replace in the template

Paramètres
array $data Associative array of strings to replace
Renvoie
void
Depuis
4.0.0

Références $data.

Référencé par RegistrationModel\activate(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), RegistrationModel\register(), PlgSystemPrivacyconsent\remindExpiringConsents(), et ActionlogModel\sendNotificationEmails().

◆ createTemplate()

static createTemplate | ( | $key,
 |  | $subject,
 |  | $body,
 |  | $tags,
 |  | $htmlbody = ''
 | ) |
static

Insert a new mail template into the system

Paramètres
string | $key | Mail template key
string | $subject | A default subject (normally a translatable string)
string | $body | A default body (normally a translatable string)
array | $tags | Associative array of tags to replace
string | $htmlbody | A default htmlbody (normally a translatable string)
Renvoie
boolean True on success, false on failure
Depuis
4.0.0

Références $db, $key, $params, $subject, $template, et Factory\getDbo().

◆ deleteTemplate()

static deleteTemplate ( $key )
static

Method to delete a mail template

Paramètres
string $key The key of the mail template
Renvoie
boolean True on success, false on failure
Depuis
4.0.0

Références $db, $key, $query, et Factory\getDbo().

◆ getAttachmentName()

getAttachmentName | ( | string | $file,
 |  | string | $name
 | ) |  |
protected

Check and if necessary fix the file name of an attachment so that the attached file has the same extension as the source file, and not a different file extension

Paramètres
string | $file | Path to the file to be attached
string | $name | The file name to be used for the attachment
Renvoie
string The corrected file name for the attachment
Depuis
4.0.0

Références $name, File\getExt(), et File\stripExt().

◆ getTemplate()

static getTemplate | ( | $key,
 |  | $language
 | ) |
static

Get a specific mail template

Paramètres
string | $key | Template identifier
string | $language | Language code of the template
Renvoie
object|null An object with the data of the mail, or null if the template not found in the db.
Depuis
4.0.0

Références $db, $key, PHPMailer\$language, $query, Factory\getDbo(), et ParameterType\STRING.

◆ replaceTags()

replaceTags | ( | $text,
 |  | $tags
 | ) |
protected

Replace tags with their values recursively

Paramètres
string | $text | The template to process
array | $tags | An associative array to replace in the template
Renvoie
string Rendered mail template
Depuis
4.0.0

Références $i, $key, $text, et $value.

◆ setReplyTo()

setReplyTo | ( | $mail,
 |  | $name = ''
 | ) |

Set reply to for this mail

Paramètres
string | $mail | Mail address to reply to
string | $name | Name
Renvoie
void
Depuis
4.0.0

Références $name.

◆ updateTemplate()

static updateTemplate | ( | $key,
 |  | $subject,
 |  | $body,
 |  | $tags,
 |  | $htmlbody = ''
 | ) |
static

Update an existing mail template

Paramètres
string | $key | Mail template key
string | $subject | A default subject (normally a translatable string)
string | $body | A default body (normally a translatable string)
array | $tags | Associative array of tags to replace
string | $htmlbody | A default htmlbody (normally a translatable string)
Renvoie
boolean True on success, false on failure
Depuis
4.0.0

Références $db, $key, $params, $subject, $template, et Factory\getDbo().

Documentation des champs

◆ $attachments

$attachments = array()
protected

◆ $data

$data = array()
protected

◆ $language

$language
protected

◆ $mailer

$mailer
protected

◆ $recipients

$recipients = array()
protected

◆ $replyto

$replyto
protected

◆ $template_id

$template_id
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MailTemplate.php


Joomla CMS: Référence de la classe AbstractMenu

  • Joomla
  • CMS
  • Menu
  • AbstractMenu
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe AbstractMenu
+ Graphe d'héritage de AbstractMenu:
AdministratorMenu SiteMenu

Fonctions membres publiques

__construct ($options=array())
setUser ($user)
getItem ($id)
setDefault ($id, $language=' *')
getDefault ($language=' *')
setActive ($id)
getActive ()
getItems ($attributes, $values, $firstonly=false)
getParams ($id)
getMenu ()
authorise ($id)
load ()
__get ($propName)

Fonctions membres publiques statiques

static getInstance ($client, $options=array())

Attributs publics statiques

static $instances = array()

Fonctions membres protégées

getUser ()

Attributs protégés

$items = array()
$default = array()
$active = 0
$storedUser

Attributs privés

$itemsLoaded = false

Description détaillée

Menu class

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options An array of configuration options.
Depuis
1.5

It is preferred NOT to inject and store the user when constructing the menu object, at least for the Menu object used by Joomla. The menu object can be built very early in the request, from an onAfterInitialise event but the user can be updated later (by the Remember me plugin for instance). As the stored user object is not updated, the menu will render incorrectly, not complying with menu items access levels.

Voir également
https://github.com/joomla/joomla-cms/issues/11541

Références $options, et null.

Documentation des fonctions membres

◆ __get()

__get ( $propName )

Magic getter for the user object. Returns the injected one if any, or the current one if none.

Using a magic getter to preserve B/C when we stopped storing the user object upon construction of the menu object. As the user property is not initialized anymore, this getter ensures any class extending this one can still use $instance->user and get a proper value.

Paramètres
string $propName Name of the missing or protected property.
Renvoie
User|null
Depuis
3.9.26

Références Factory\getUser(), et null.

◆ authorise()

authorise ( $id )

Method to check Menu object authorization against an access control object and optionally an access extension object

Paramètres
integer $id The menu id
Renvoie
boolean
Depuis
1.5

Références $id, $menu, et if.

◆ getActive()

getActive ( )

Get menu item by id.

Renvoie
MenuItem|void The item object if an active menu item has been set or null
Depuis
1.5

Références $active.

◆ getDefault()

getDefault ( $language = '*' )

Get the default item by language code.

Paramètres
string $language The language code, default value of * means all.
Renvoie
MenuItem|void The item object or null when not found for given language
Depuis
1.5

Références $items, et $language.

◆ getInstance()

static getInstance | ( | $client,
 |  | $options = array()
 | ) |
static

Returns a Menu object

Paramètres
string | $client | The name of the client
array | $options | An associative array of options
Renvoie
AbstractMenu A menu object.
Depuis
1.5
Exceptions

Références $client, $options, class, Factory\getContainer(), et Text\sprintf().

Référencé par RouteHelper\_findItem().

◆ getItem()

getItem ( $id )

Get menu item by id

Paramètres
integer $id The item id
Renvoie
MenuItem|null The item object if the ID exists or null if not found
Depuis
1.5

Références $id, $result, et null.

◆ getItems()

getItems | ( | $attributes,
 |  | $values,
 |  | $firstonly = false
 | ) |

Gets menu items by attribute

Paramètres
mixed | $attributes | The field name(s).
mixed | $values | The value(s) of the field. If an array, need to match field names each attribute may have multiple values to lookup for.
boolean | $firstonly | If true, only returns the first item found
Renvoie
MenuItem|MenuItem[] An array of menu item objects or a single object if the $firstonly parameter is true
Depuis
1.5

Références $attributes, $count, $i, $item, et $items.

◆ getMenu()

getMenu ( )

Getter for the menu array

Renvoie
MenuItem[]
Depuis
1.5

Références $item, $items, et items.

◆ getParams()

getParams ( $id )

Gets the parameter object for a certain menu item

Paramètres
integer $id The item id
Renvoie
Registry
Depuis
1.5

Références $id, et $menu.

◆ getUser()

getUser ( )
protected

Internal getter for the user. Returns the injected one if any, or the current one if none.

Renvoie
User
Depuis
3.9.26

Références Factory\getUser().

◆ load()

load ( )
abstract

Loads the menu items

Renvoie
array
Depuis
1.5

◆ setActive()

setActive ( $id )

Set the default item by id

Paramètres
integer $id The item id
Renvoie
MenuItem|void The menu item representing the given ID if present or null otherwise
Depuis
1.5

Références $id.

◆ setDefault()

setDefault | ( | $id,
 |  | $language = '*'
 | ) |

Set the default item by id and language code.

Paramètres
integer | $id | The menu item id.
string | $language | The language code (since 1.6).
Renvoie
boolean True if a menu item with the given ID exists
Depuis
1.5

Références $id, et $language.

◆ setUser()

setUser ( $user )

Setter for the current user used to build menu.

Paramètres
User $user The new user to set.
Renvoie
void
Depuis
3.9.26

Références $user.

Documentation des champs

◆ $active

$active = 0
protected

◆ $default

$default = array()
protected

◆ $instances

$instances = array()
static

Référencé par CMSApplication\getMenu().

◆ $items

$items = array()
protected

◆ $itemsLoaded

$itemsLoaded = false
private

◆ $storedUser

$storedUser
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractMenu.php


Joomla CMS: Référence de la classe AdministratorMenu

  • Joomla
  • CMS
  • Menu
  • AdministratorMenu
Fonctions membres publiques
Référence de la classe AdministratorMenu
+ Graphe d'héritage de AdministratorMenu:
AbstractMenu

Fonctions membres publiques

load ()
- Fonctions membres publiques hérités de AbstractMenu
__construct ($options=array())
setUser ($user)
getItem ($id)
setDefault ($id, $language=' *')
getDefault ($language=' *')
setActive ($id)
getActive ()
getItems ($attributes, $values, $firstonly=false)
getParams ($id)
getMenu ()
authorise ($id)
load ()
__get ($propName)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractMenu
static | getInstance ($client, $options=array())
- Attributs publics statiques hérités de AbstractMenu
static | $instances = array()
- Fonctions membres protégées hérités de AbstractMenu
getUser ()
- Attributs protégés hérités de AbstractMenu
$items = array()
$default = array()
$active = 0
$storedUser

Description détaillée

Menu class.

Depuis
1.5

Documentation des fonctions membres

◆ load()

load ( )

Loads the menu items

Renvoie
array
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdministratorMenu.php


Joomla CMS: Référence de la classe AdministratorMenuItem

  • Joomla
  • CMS
  • Menu
  • AdministratorMenuItem
Champs de données
Référence de la classe AdministratorMenuItem
+ Graphe d'héritage de AdministratorMenuItem:
MenuItem NodeInterface ImmutableNodeInterface

Champs de données

$target
$icon
$iconImage
- Champs de données hérités de MenuItem
$id
$menutype
$title
$alias
$note
$route
$link
$type
$level
$language
$browserNav
$access
$home
$img
$template_style_id
$component_id
$parent_id
$component
$tree = array()
$query = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de MenuItem
__construct ($data=array())
getParams ()
setParams ($params)
- Fonctions membres publiques hérités de NodeInterface
setParent (NodeInterface $parent)
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)
- Fonctions membres publiques hérités de ImmutableNodeInterface
& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)
- Attributs protégés hérités de MenuItem
$params

Description détaillée

Object representing an administrator menu item

Depuis
4.0.0

Documentation des champs

◆ $icon

$icon

◆ $iconImage

$iconImage

◆ $target

$target
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdministratorMenuItem.php


Joomla CMS: Référence de la classe MenuFactory

  • Joomla
  • CMS
  • Menu
  • MenuFactory
Fonctions membres publiques
Référence de la classe MenuFactory
+ Graphe d'héritage de MenuFactory:
MenuFactoryInterface

Fonctions membres publiques

createMenu (string $client, array $options=[])

Description détaillée

Default factory for creating Menu objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createMenu()

createMenu | ( | string | $client,
 |  | array | $options = []
 | ) |  |

Creates a new Menu object for the requested format.

Paramètres
string | $client | The name of the client
array | $options | An associative array of options
Renvoie
AbstractMenu
Depuis
4.0.0
Exceptions

Implémente MenuFactoryInterface.

Références $client, $options, Joomla\CMS\Cache\getCacheControllerFactory(), Joomla\Database\getDatabase(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuFactory.php


Joomla CMS: Référence de l'interface MenuFactoryInterface

  • Joomla
  • CMS
  • Menu
  • MenuFactoryInterface
Fonctions membres publiques
Référence de l'interface MenuFactoryInterface
+ Graphe d'héritage de MenuFactoryInterface:
MenuFactory

Fonctions membres publiques

createMenu (string $client, array $options=[])

Description détaillée

Interface defining a factory which can create Menu objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createMenu()

createMenu | ( | string | $client,
 |  | array | $options = []
 | ) |  |

Creates a new Menu object for the requested format.

Paramètres
string | $client | The name of the client
array | $options | An associative array of options
Renvoie
AbstractMenu
Depuis
4.0.0

Implémenté dans MenuFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • MenuFactoryInterface.php


Joomla CMS: Référence de la classe MenuItem

  • Joomla
  • CMS
  • Menu
  • MenuItem
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe MenuItem
+ Graphe d'héritage de MenuItem:
NodeInterface ImmutableNodeInterface AdministratorMenuItem

Fonctions membres publiques

__construct ($data=array())
getParams ()
setParams ($params)
- Fonctions membres publiques hérités de NodeInterface
setParent (NodeInterface $parent)
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)
- Fonctions membres publiques hérités de ImmutableNodeInterface
& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)

Champs de données

$id
$menutype
$title
$alias
$note
$route
$link
$type
$level
$language
$browserNav
$access
$home
$img
$template_style_id
$component_id
$parent_id
$component
$tree = array()
$query = array()

Attributs protégés

$params

Description détaillée

Object representing a menu item

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $data = array() )

Class constructor

Paramètres
array $data The menu item data to load
Depuis
3.7.0

Références $data, $key, et $value.

Documentation des fonctions membres

◆ getParams()

getParams ( )

Returns the menu item parameters

Renvoie
Registry
Depuis
3.7.0

Références $params.

◆ setParams()

setParams ( $params )

Sets the menu item parameters

Paramètres
Registry | string $params The data to be stored as the parameters
Renvoie
void
Depuis
3.7.0

Références $params.

Documentation des champs

◆ $access

$access

◆ $alias

$alias

◆ $browserNav

$browserNav

◆ $component

$component

◆ $component_id

$component_id

◆ $home

$home

◆ $id

$id

◆ $img

$img

◆ $language

$language

◆ $level

$level

◆ $link

$link

◆ $menutype

$menutype

◆ $note

$note

◆ $params

$params
protected

◆ $parent_id

$parent_id

◆ $query

$query = array()

◆ $route

$route

◆ $template_style_id

$template_style_id

◆ $title

$title

◆ $tree

$tree = array()

◆ $type

$type
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuItem.php


Joomla CMS: Référence de la classe SiteMenu

  • Joomla
  • CMS
  • Menu
  • SiteMenu
Fonctions membres publiques | Attributs protégés
Référence de la classe SiteMenu
+ Graphe d'héritage de SiteMenu:
AbstractMenu CacheControllerFactoryAwareInterface

Fonctions membres publiques

__construct ($options=array())
getItems ($attributes, $values, $firstonly=false)
getDefault ($language=' *')
- Fonctions membres publiques hérités de AbstractMenu
__construct ($options=array())
setUser ($user)
getItem ($id)
setDefault ($id, $language=' *')
getDefault ($language=' *')
setActive ($id)
getActive ()
getItems ($attributes, $values, $firstonly=false)
getParams ($id)
getMenu ()
authorise ($id)
load ()
__get ($propName)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)

Attributs protégés

$app
$db
$language
- Attributs protégés hérités de AbstractMenu
$items = array()
$default = array()
$active = 0
$storedUser

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractMenu
static | getInstance ($client, $options=array())
- Attributs publics statiques hérités de AbstractMenu
static | $instances = array()
- Fonctions membres protégées hérités de AbstractMenu
getUser ()

Description détaillée

Menu class

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options An array of configuration options.
Depuis
1.5

Références $options, Symfony\Contracts\Service\__construct(), class, Factory\getApplication(), Factory\getContainer(), Factory\getLanguage(), et language.

Documentation des fonctions membres

◆ getDefault()

getDefault ( $language = '*' )

Get menu item by id

Paramètres
string $language The language code.
Renvoie
MenuItem|null The item object or null when not found for given language
Depuis
1.6

Références $items, et $language.

◆ getItems()

getItems | ( | $attributes,
 |  | $values,
 |  | $firstonly = false
 | ) |

Gets menu items by attribute

Paramètres
string | $attributes | The field name
string | $values | The value of the field
boolean | $firstonly | If true, only returns the first item found
Renvoie
MenuItem|MenuItem[] An array of menu item objects or a single object if the $firstonly parameter is true
Depuis
1.6

Références $attributes, $key, elseif, Factory\getLanguage(), Multilanguage\isEnabled(), et null.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected

◆ $language

$language
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteMenu.php


Joomla CMS: Référence de la classe Microdata

  • Joomla
  • CMS
  • Microdata
  • Microdata
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Microdata

Fonctions membres publiques

__construct ($type='', $flag=true)
enable ($flag=true)
isEnabled ()
setType ($type)
getType ()
property ($property)
getProperty ()
content ($content, $machineContent=null)
getContent ()
getMachineContent ()
fallback ($type, $property)
getFallbackType ()
getFallbackProperty ()
display ($displayType='', $emptyOutput=false)
displayScope ()

Fonctions membres publiques statiques

static | sanitizeType ($type)
static | sanitizeProperty ($property)
static | getTypes ()
static | getAvailableTypes ()
static | getExpectedTypes ($type, $property)
static | isPropertyInType ($type, $property)
static | isTypeAvailable ($type)
static | htmlMeta ($content, $property, $scope='', $invert=false)
static | htmlSpan ($content, $property='', $scope='', $invert=false)
static | htmlDiv ($content, $property='', $scope='', $invert=false)
static | htmlTag ($tag, $content, $property='', $scope='', $invert=false)
static | htmlScope ($scope)
static | htmlProperty ($property)

Fonctions membres protégées

resetParams ()

Fonctions membres protégées statiques

static | loadTypes ()
static | getExpectedDisplayType ($type, $property)

Attributs protégés

$type = null
$property = null
$content = null
$machineContent = null
$fallbackType = null
$fallbackProperty = null
$enabled = true

Attributs protégés statiques

static $types = null

Description détaillée

Joomla Platform class for interacting with Microdata semantics.

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $type = '',
 |  | $flag = true
 | ) |

Initialize the class and setup the default $Type

Paramètres
string | $type | Optional, fallback to 'Thing' Type
boolean | $flag | Enable or disable the library output
Depuis
3.2

Références $type.

Documentation des fonctions membres

◆ content()

content | ( | $content,
 |  | $machineContent = null
 | ) |

Setup a Human content or content for the Machines

Paramètres
string | $content | The human content or machine content to be used
string | $machineContent | The machine content
Renvoie
Microdata Instance of $this
Depuis
3.2

Références $content, $this, et content.

◆ display()

display | ( | $displayType = '',
 |  | $emptyOutput = false
 | ) |

This function handles the display logic. It checks if the Type, Property are available, if not check for a Fallback, then reset all params for the next use and return the HTML.

Paramètres
string | $displayType | Optional, 'inline', available options ['inline'|'span'|'div'|meta]
boolean | $emptyOutput | Return an empty string if the library output is disabled and there is a $content value
Renvoie
string
Depuis
3.2

Références $content, $html, content, elseif, et null.

◆ displayScope()

displayScope ( )

Return the HTML of the current Scope

Renvoie
string
Depuis
3.2

◆ enable()

enable ( $flag = true )

Enable or Disable the library output

Paramètres
boolean $flag Enable or disable the library output
Renvoie
Microdata Instance of $this
Depuis
3.2

Références $this.

◆ fallback()

fallback | ( | $type,
 |  | $property
 | ) |

Setup a Fallback Type and Property

Paramètres
string | $type | The Fallback Type
string | $property | The Fallback Property
Renvoie
Microdata Instance of $this
Depuis
3.2

Références $this, $type, et null.

◆ getAvailableTypes()

static getAvailableTypes ( )
static

Return an array with all available Types from the http://schema.org vocabulary

Renvoie
array
Depuis
3.2

◆ getContent()

getContent ( )

Return the current $content

Renvoie
string
Depuis
3.2

Références $content.

◆ getExpectedDisplayType()

static getExpectedDisplayType | ( | $type,
 |  | $property
 | ) |
staticprotected

Return the expected display type: [normal|nested|meta] In which way to display the Property: normal -> itemprop="name" nested -> itemprop="director" itemscope itemtype="https://schema.org/Person" meta -> <meta itemprop="datePublished" content="1991-05-01">

Paramètres
string | $type | The Type where to find the Property
string | $property | The Property to process
Renvoie
string
Depuis
3.2

Références $type.

◆ getExpectedTypes()

static getExpectedTypes | ( | $type,
 |  | $property
 | ) |
static

Return the expected Types of the given Property

Paramètres
string | $type | The Type to process
string | $property | The Property to process
Renvoie
array
Depuis
3.2

Références $tmp, et $type.

◆ getFallbackProperty()

getFallbackProperty ( )

Return the current $fallbackProperty

Renvoie
string
Depuis
3.2

◆ getFallbackType()

getFallbackType ( )

Return the current $fallbackType

Renvoie
string
Depuis
3.2

◆ getMachineContent()

getMachineContent ( )

Return the current $machineContent

Renvoie
string
Depuis
3.3

◆ getProperty()

getProperty ( )

Return the current $Property name

Renvoie
string
Depuis
3.2

◆ getType()

getType ( )

Return the current $Type name

Renvoie
string
Depuis
3.2

Références $type.

◆ getTypes()

static getTypes ( )
static

Return an array with all available Types and Properties from the http://schema.org vocabulary

Renvoie
array
Depuis
3.2

◆ htmlDiv()

static htmlDiv | ( | $content,
 |  | $property = '',
 |  | $scope = '',
 |  | $invert = false
 | ) |
static

Return Microdata semantics in a <div> tag.

Paramètres
string | $content | The human content
string | $property | Optional, the human content to display
string | $scope | Optional, the Type scope to display
boolean | $invert | Optional, default = false, invert the $scope with the $property
Renvoie
string
Depuis
3.2

Références $content, et $scope.

◆ htmlMeta()

static htmlMeta | ( | $content,
 |  | $property,
 |  | $scope = '',
 |  | $invert = false
 | ) |
static

Return Microdata semantics in a <meta> tag with content for machines.

Paramètres
string | $content | The machine content to display
string | $property | The Property
string | $scope | Optional, the Type scope to display
boolean | $invert | Optional, default = false, invert the $scope with the $property
Renvoie
string
Depuis
3.2

Références $content, et $scope.

◆ htmlProperty()

static htmlProperty ( $property )
static

Return the HTML Property

Paramètres
string $property The Property to process
Renvoie
string
Depuis
3.2

◆ htmlScope()

static htmlScope ( $scope )
static

Return the HTML Scope

Paramètres
string $scope The Scope to process
Renvoie
string
Depuis
3.2

Références $scope.

◆ htmlSpan()

static htmlSpan | ( | $content,
 |  | $property = '',
 |  | $scope = '',
 |  | $invert = false
 | ) |
static

Return Microdata semantics in a <span> tag.

Paramètres
string | $content | The human content
string | $property | Optional, the human content to display
string | $scope | Optional, the Type scope to display
boolean | $invert | Optional, default = false, invert the $scope with the $property
Renvoie
string
Depuis
3.2

Références $content, et $scope.

◆ htmlTag()

static htmlTag | ( | $tag,
 |  | $content,
 |  | $property = '',
 |  | $scope = '',
 |  | $invert = false
 | ) |
static

Return Microdata semantics in a specified tag.

Paramètres
string | $tag | The HTML tag
string | $content | The human content
string | $property | Optional, the human content to display
string | $scope | Optional, the Type scope to display
boolean | $invert | Optional, default = false, invert the $scope with the $property
Renvoie
string
Depuis
3.3

Références $content, $scope, et $tmp.

◆ isEnabled()

isEnabled ( )

Return 'true' if the library output is enabled

Renvoie
boolean
Depuis
3.2

Références $enabled.

◆ isPropertyInType()

static isPropertyInType | ( | $type,
 |  | $property
 | ) |
static

Recursive function, control if the given Type has the given Property

Paramètres
string | $type | The Type where to check
string | $property | The Property to check
Renvoie
boolean
Depuis
3.2

Références $type.

◆ isTypeAvailable()

static isTypeAvailable ( $type )
static

Control if the given Type class is available

Paramètres
string $type The Type to check
Renvoie
boolean
Depuis
3.2

Références $type.

◆ loadTypes()

static loadTypes ( )
staticprotected

Load all available Types and Properties from the http://schema.org vocabulary contained in the types.json file

Renvoie
void
Depuis
3.2

Références $path, et __DIR__.

◆ property()

property ( $property )

Setup a $Property

Paramètres
string $property The Property
Renvoie
Microdata Instance of $this
Depuis
3.2

Références $this.

◆ resetParams()

resetParams ( )
protected

Reset all params

Renvoie
void
Depuis
3.2

Références content, et null.

◆ sanitizeProperty()

static sanitizeProperty ( $property )
static

Return the sanitized $Property

Paramètres
string $property The Property to sanitize
Renvoie
string
Depuis
3.2

◆ sanitizeType()

static sanitizeType ( $type )
static

Return the sanitized $Type

Paramètres
string $type The Type to sanitize
Renvoie
string
Depuis
3.2

Références $type.

◆ setType()

setType ( $type )

Set a new http://schema.org Type

Paramètres
string $type The $Type to be setup
Renvoie
Microdata Instance of $this
Depuis
3.2

Références $this, et $type.

Documentation des champs

◆ $content

$content = null
protected

◆ $enabled

$enabled = true
protected

◆ $fallbackProperty

$fallbackProperty = null
protected

◆ $fallbackType

$fallbackType = null
protected

◆ $machineContent

$machineContent = null
protected

◆ $property

$property = null
protected

◆ $type

$type = null
protected

◆ $types

$types = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Microdata.php


Joomla CMS: Référence de la classe CheckinCheckout

  • Joomla
  • CMS
  • MVC
  • Controller
  • Exception
  • CheckinCheckout
Référence de la classe CheckinCheckout
+ Graphe d'héritage de CheckinCheckout:

Description détaillée

Checkin/checkout Exception

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckinCheckout.php


Joomla CMS: Référence de la classe ResourceNotFound

  • Joomla
  • CMS
  • MVC
  • Controller
  • Exception
  • ResourceNotFound
Référence de la classe ResourceNotFound
+ Graphe d'héritage de ResourceNotFound:

Description détaillée

Exception class defining a resource not found exception

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ResourceNotFound.php


Joomla CMS: Référence de la classe Save

  • Joomla
  • CMS
  • MVC
  • Controller
  • Exception
  • Save
Référence de la classe Save
+ Graphe d'héritage de Save:

Description détaillée

Exception saving data

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Save.php


Joomla CMS: Référence de la classe SendEmail

  • Joomla
  • CMS
  • MVC
  • Controller
  • Exception
  • SendEmail
Référence de la classe SendEmail
+ Graphe d'héritage de SendEmail:

Description détaillée

Send email Exception

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SendEmail.php


Joomla CMS: Référence de la classe AdminController

  • Joomla
  • CMS
  • MVC
  • Controller
  • AdminController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AdminController
+ Graphe d'héritage de AdminController:
BaseController ControllerInterface DispatcherAwareInterface ActionlogsController AssociationsController BannersController ClientsController CategoriesController ContactsController ArticlesController HistoryController FieldsController GroupsController FiltersController IndexController MapsController UpdatesitesController LanguagesController OverridesController StringsController ItemsController MessagesController ModulesController NewsfeedsController PluginsController RequestsController LinksController TasksController TagsController StylesController GroupsController LevelsController NotesController UsersController StagesController TransitionsController WorkflowsController

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base class for a Joomla Administrator Controller

Controller (controllers are where you put all the actual code) Provides basic functionality, such as rendering views (aka displaying templates).

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | The Input object for the request
Depuis
3.0

Références $app, $config, $input, $r, $this, Symfony\Contracts\Service\__construct(), elseif, ComponentHelper\getComponentName(), et Text\sprintf().

Documentation des fonctions membres

◆ checkin()

checkin ( )

Check in of one or more records.

Renvoie
boolean True on success
Depuis
1.6

Références $message, $model, $return, Route\_(), Joomla\Application\checkToken(), Text\plural(), et Text\sprintf().

◆ delete()

delete ( )

Removes an item.

Renvoie
void
Depuis
1.6

Références $model, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\plural().

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

◆ postDeleteHook()

postDeleteHook | ( | BaseDatabaseModel | $model,
 |  |  | $id = null
 | ) |  |
protected

Function that allows child controller access to model data after the item has been deleted.

Paramètres
BaseDatabaseModel | $model | The data model object.
integer | $id | The validated data.
Renvoie
void
Depuis
3.1

◆ publish()

publish ( )

Method to publish a list of items

Renvoie
void
Depuis
1.6

Références $data, $model, $task, $value, Text\_(), Route\_(), Joomla\Application\checkToken(), elseif, ArrayHelper\getValue(), null, et Text\plural().

◆ reorder()

reorder ( )

Changes the order of one or more records.

Renvoie
boolean True on success
Depuis
1.6

Références $message, $model, $return, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\sprintf().

◆ runTransition()

runTransition ( )

Method to run Transition by id of item.

Renvoie
boolean Indicates whether the transition was successful.
Depuis
4.0.0

Références $message, $model, $return, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\sprintf().

◆ saveorder()

saveorder ( )

Method to save the submitted ordering values for records.

Renvoie
boolean True on success
Depuis
1.6

Références $i, $message, $model, $return, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\sprintf().

◆ saveOrderAjax()

saveOrderAjax ( )

Method to save the submitted ordering values for records via AJAX.

Renvoie
void
Depuis
3.0

Références $i, $model, $return, et Joomla\Application\checkToken().

Documentation des champs

◆ $option

$option
protected

◆ $text_prefix

$text_prefix
protected

◆ $view_list

$view_list
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdminController.php


Joomla CMS: Référence de la classe ApiController

  • Joomla
  • CMS
  • MVC
  • Controller
  • ApiController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ApiController
+ Graphe d'héritage de ApiController:
BaseController ControllerInterface DispatcherAwareInterface BannersController ClientsController CategoriesController ApplicationController ComponentController ContactController ArticlesController HistoryController FieldsController GroupsController ManageController LanguagesController OverridesController StringsController AdaptersController MediaController ItemsController MenusController MessagesController ModulesController FeedsController PluginsController ConsentsController RequestsController RedirectController TagsController StylesController GroupsController LevelsController UsersController

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base class for a Joomla API Controller

Controller (controllers are where you put all the actual code) Provides basic functionality, such as rendering views (aka displaying templates).

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $input, $r, $this, Symfony\Contracts\Service\__construct(), ComponentHelper\getComponentName(), null, et Text\sprintf().

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new record.

Renvoie
void
Depuis
4.0.0
Exceptions
NotAllowed

Références $recordId.

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Extended classes can override this if necessary.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

Références $this, et $user.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit an existing record.

Extended classes can override this if necessary.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key; default is id.
Renvoie
boolean
Depuis
4.0.0

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0

Références $data.

Documentation des champs

◆ $contentType

$contentType
protected

◆ $context

$context
protected

◆ $itemsPerPage

$itemsPerPage = 20
protected

◆ $modelState

$modelState
protected

◆ $option

$option
protected

◆ $text_prefix

$text_prefix
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/MVC/Controller/ApiController.php


Joomla CMS: Référence de la classe BaseController

  • Joomla
  • CMS
  • MVC
  • Controller
  • BaseController
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe BaseController
+ Graphe d'héritage de BaseController:
ControllerInterface DispatcherAwareInterface DisplayController JSONController AdminController ApiController FormController DisplayController DisplayController DisplayController DisplayController TracksController DisplayController DisplayController AjaxController DisplayController DisplayController ApplicationController DisplayController RequestController ConfigController DisplayController ModulesController TemplatesController AjaxController DisplayController DisplayController AjaxController DisplayController DisplayController DisplayController PreviewController DisplayController DisplayController DisplayController DisplayController DisplayController IndexerController SearchesController DisplayController SuggestionsController DatabaseController DiscoverController DisplayController InstallController ManageController UpdateController DisplayController UpdateController DisplayController InstalledController DisplayController DisplayController ApiController DisplayController PluginController AjaxController DisplayController MenusController ConfigController DisplayController DisplayController DisplayController AjaxController DisplayController DisplayController DisplayController DisplayController MessageController DisplayController DisplayController RequestController DisplayController DisplayController DisplayController DisplayController TagsController DisplayController TemplateController CallbackController CaptiveController DisplayController MailController MethodController MethodsController DisplayController ProfileController RegistrationController RemindController ResetController UserController DisplayController DisplayController

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())

Fonctions membres protégées

addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Attributs protégés statiques

static | $instance
static | $views

Description détaillée

Base class for a Joomla Controller

Controller (Controllers are where you put all the actual code.) Provides basic functionality, such as rendering views (aka displaying templates).

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, $r, $this, Log\addLogger(), Log\ALL, elseif, Factory\getApplication(), JDEBUG, name, et null.

Documentation des fonctions membres

◆ addModelPath()

static addModelPath | ( | $path,
 |  | $prefix = ''
 | ) |
static

Adds to the stack of model paths in LIFO order.

Paramètres
mixed | $path | The directory (string), or list of directories (array) to add.
string | $prefix | A prefix for models
Renvoie
void
Depuis
3.0
Obsolète:
5.0 See ::getInstance

Références $path, $prefix, et BaseModel\addIncludePath().

◆ addPath()

addPath | ( | $type,
 |  | $path
 | ) |
protected

Adds to the search path for templates and resources.

Paramètres
string | $type | The path type (e.g. 'model', 'view').
mixed | $path | The directory string or stream array to search.
Renvoie
static A object to support chaining.
Depuis
3.0

Références $dir, $path, $this, $type, et Path\check().

◆ addViewPath()

addViewPath ( $path )

Add one or more view paths to the controller's stack, in LIFO order.

Paramètres
mixed $path The directory (string) or list of directories (array) to add.
Renvoie
static This object to support chaining.
Depuis
3.0

Références $path.

◆ checkEditId()

checkEditId | ( | $context,
 |  | $id
 | ) |
protected

Method to check whether an ID is in the edit list.

Paramètres
string | $context | The context for the session storage.
integer | $id | The ID of the record to add to the edit list.
Renvoie
boolean True if the ID is in the edit list.
Depuis
3.0

Références $context, $id, $result, et JDEBUG.

◆ checkToken()

checkToken | ( | $method = 'post',
 |  | $redirect = true
 | ) |

Checks for a form token in the request.

Use in conjunction with HTMLHelper::_('form.token') or Session::getFormToken.

Paramètres
string | $method | The request method in which to look for the token key.
boolean | $redirect | Whether to implicitly redirect user to the referrer page on failure or simply return false.
Renvoie
boolean True if found and valid, otherwise return false or redirect to referrer page.
Depuis
3.7.0
Voir également
Session::checkToken()

Références $method, Text\_(), Session\checkToken(), et Uri\isInternal().

◆ createFileName()

static createFileName | ( | $type,
 |  | $parts = array()
 | ) |
static

Create the filename for a resource.

Paramètres
string | $type | The resource type to create the filename for.
array | $parts | An associative array of filename information. Optional.
Renvoie
string The filename.
Depuis
3.0

Références $parts, et $type.

Référencé par LegacyFactory\createView().

◆ createModel()

createModel | ( | $name,
 |  | $prefix = '',
 |  | $config = array()
 | ) |
protected

Method to load and return a model object.

Paramètres
string | $name | The name of the model.
string | $prefix | Optional model prefix.
array | $config | Configuration array for the model. Optional.
Renvoie
BaseDatabaseModel|boolean Model object on success; otherwise false on failure.
Depuis
3.0

Références $config, $model, $name, $prefix, et null.

◆ createView()

createView | ( | $name,
 |  | $prefix = '',
 |  | $type = '',
 |  | $config = array()
 | ) |
protected

Method to load and return a view object. This method first looks in the current template directory for a match and, failing that, uses a default set path to load the view class file.

Note the "name, prefix, type" order of parameters, which differs from the "name, type, prefix" order used in related public methods.

Paramètres
string | $name | The name of the view.
string | $prefix | Optional prefix for the view class name.
string | $type | The type of view.
array | $config | Configuration array for the view. Optional.
Renvoie
ViewInterface|null View object on success; null or error result on failure.
Depuis
3.0
Exceptions

Références $config, $name, $prefix, $type, et $view.

◆ execute()

execute ( $task )

Execute a task by triggering a method in the derived class.

Paramètres
string $task The task to perform. If no matching task is found, the '__default' task is executed, if defined.
Renvoie
mixed The value returned by the called method.
Depuis
3.0
Exceptions

Implémente ControllerInterface.

Références $task, elseif, et Text\sprintf().

◆ getInstance()

static getInstance | ( | $prefix,
 |  | $config = array()
 | ) |
static

Method to get a singleton controller instance.

Paramètres
string | $prefix | The prefix for the controller.
array | $config | An array of optional constructor options.
Renvoie
static
Depuis
3.0
Obsolète:
5.0 Get the controller through the MVCFactory instead
Exceptions

Références $app, $basePath, $class, $config, $format, $input, $path, $prefix, $task, $type, class, elseif, Factory\getApplication(), Factory\getContainer(), InputFilter\getInstance(), Symfony\Contracts\Service\has(), null, et Text\sprintf().

◆ getModel()

getModel | ( | $name = '',
 |  | $prefix = '',
 |  | $config = array()
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
BaseDatabaseModel|boolean Model object on success; otherwise false on failure.
Depuis
3.0

Références $config, $item, $menu, $model, $name, $params, $prefix, Path\clean(), elseif, et JPATH_ADMINISTRATOR.

◆ getName()

getName ( )

Method to get the controller name

The dispatcher name is set by default parsed using the classname, or it can be set by passing a $config['name'] in the class constructor

Renvoie
string The name of the dispatcher
Depuis
3.0
Exceptions

Références $name, $r, $this, name, null, et Text\sprintf().

◆ getTask()

getTask ( )

Get the last task that is being performed or was most recently performed.

Renvoie
string The task that is being performed or was most recently performed.
Depuis
3.0

Références $task.

◆ getTasks()

getTasks ( )

Gets the available tasks in the controller.

Renvoie
array Array[i] of task names.
Depuis
3.0

◆ getView()

getView | ( | $name = '',
 |  | $type = '',
 |  | $prefix = '',
 |  | $config = array()
 | ) |

Method to get a reference to the current view and load it if necessary.

Paramètres
string | $name | The view name. Optional, defaults to the controller name.
string | $type | The view type. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for view. Optional.
Renvoie
ViewInterface Reference to the view or an error.
Depuis
3.0
Exceptions

Références $config, $name, $prefix, $type, $view, Path\clean(), elseif, JPATH_ADMINISTRATOR, et Text\sprintf().

◆ holdEditId()

holdEditId | ( | $context,
 |  | $id
 | ) |
protected

Method to add a record ID to the edit list.

Paramètres
string | $context | The context for the session storage.
integer | $id | The ID of the record to add to the edit list.
Renvoie
void
Depuis
3.0

Références $context, $id, et JDEBUG.

◆ redirect()

redirect ( )

Redirects the browser or returns false if no redirect is set.

Renvoie
boolean False if no redirect exists.
Depuis
3.0

◆ registerDefaultTask()

registerDefaultTask ( $method )

Register the default task to perform if a mapping is not found.

Paramètres
string $method The name of the method in the derived class to perform if a named task is not found.
Renvoie
static A object to support chaining.
Depuis
3.0

Références $method, et $this.

◆ registerTask()

registerTask | ( | $task,
 |  | $method
 | ) |

Register (map) a task to a method in the class.

Paramètres
string | $task | The task.
string | $method | The name of the method in the derived class to perform for this task.
Renvoie
static A object to support chaining.
Depuis
3.0

Références $method, $task, et $this.

◆ releaseEditId()

releaseEditId | ( | $context,
 |  | $id
 | ) |
protected

Method to check whether an ID is in the edit list.

Paramètres
string | $context | The context for the session storage.
integer | $id | The ID of the record to add to the edit list.
Renvoie
void
Depuis
3.0

Références $context, $id, et JDEBUG.

◆ setMessage()

setMessage | ( | $text,
 |  | $type = 'message'
 | ) |

Sets the internal message that is passed with a redirect

Paramètres
string | $text | Message to display on redirect.
string | $type | Message type. Optional, defaults to 'message'.
Renvoie
string Previous message
Depuis
3.0

Références $message, $text, et $type.

◆ setPath()

setPath | ( | $type,
 |  | $path
 | ) |
protected

Sets an entire array of search paths for resources.

Paramètres
string | $type | The type of path to set, typically 'view' or 'model'.
string | $path | The new set of search paths. If null or false, resets to the current directory only.
Renvoie
void
Depuis
3.0

Références $path, et $type.

◆ setRedirect()

setRedirect | ( | $url,
 |  | $msg = null,
 |  | $type = null
 | ) |

Set a URL for browser redirection.

Paramètres
string | $url | URL to redirect to.
string | $msg | Message to display on redirect. Optional, defaults to value set internally by controller, if any.
string | $type | Message type. Optional, defaults to 'message' or the type set by a previous call to setMessage.
Renvoie
static This object to support chaining.
Depuis
3.0

Références $this, $type, $url, et null.

◆ unregisterTask()

unregisterTask ( $task )

Unregister (unmap) a task in the class.

Paramètres
string $task The task.
Renvoie
static This object to support chaining.
Depuis
3.0

Références $task, et $this.

Documentation des champs

◆ $app

$app
protected

◆ $basePath

$basePath
protected

◆ $default_view

$default_view
protected

◆ $doTask

$doTask
protected

◆ $factory

$factory
protected

◆ $input

$input
protected

◆ $instance

$instance
staticprotected

◆ $message

$message
protected

◆ $messageType

$messageType
protected

◆ $methods

$methods
protected

◆ $model_prefix

$model_prefix
protected

◆ $name

$name
protected

◆ $paths

$paths
protected

◆ $redirect

$redirect
protected

◆ $task

$task
protected

◆ $taskMap

$taskMap
protected

◆ $views

$views
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseController.php


Joomla CMS: Référence de l'interface ControllerInterface

  • Joomla
  • CMS
  • MVC
  • Controller
  • ControllerInterface
Fonctions membres publiques
Référence de l'interface ControllerInterface
+ Graphe d'héritage de ControllerInterface:
BaseController DisplayController JSONController AdminController ApiController FormController DisplayController DisplayController DisplayController DisplayController TracksController DisplayController DisplayController AjaxController DisplayController DisplayController ApplicationController DisplayController RequestController ConfigController DisplayController ModulesController TemplatesController AjaxController DisplayController DisplayController AjaxController DisplayController DisplayController DisplayController PreviewController DisplayController DisplayController DisplayController DisplayController DisplayController IndexerController SearchesController DisplayController SuggestionsController DatabaseController DiscoverController DisplayController InstallController ManageController UpdateController DisplayController UpdateController DisplayController InstalledController DisplayController DisplayController ApiController DisplayController PluginController AjaxController DisplayController MenusController ConfigController DisplayController DisplayController DisplayController AjaxController DisplayController DisplayController DisplayController DisplayController MessageController DisplayController DisplayController RequestController DisplayController DisplayController DisplayController DisplayController TagsController DisplayController TemplateController CallbackController CaptiveController DisplayController MailController MethodController MethodsController DisplayController ProfileController RegistrationController RemindController ResetController UserController DisplayController DisplayController

Fonctions membres publiques

execute ($task)

Description détaillée

Joomla Platform CMS Interface

Depuis
4.0.0

Documentation des fonctions membres

◆ execute()

execute ( $task )

Execute a controller task.

Paramètres
string $task The task to perform.
Renvoie
mixed The value returned by the called method.
Depuis
4.0.0
Exceptions

Implémenté dans BaseController, MethodController, ApiController, CaptiveController, MethodController, et MethodsController.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ControllerInterface.php


Joomla CMS: Référence de la classe FormController

  • Joomla
  • CMS
  • MVC
  • Controller
  • FormController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FormController
+ Graphe d'héritage de FormController:
BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface AssociationController BannerController ClientController CategoryController ComponentController ContactController ContactController ArticleController ArticleController FieldController GroupController FilterController UpdatesiteController LanguageController OverrideController TemplateController ItemController MenuController MessageController ModuleController NewsfeedController PluginController ConsentsController RequestController LinkController TaskController TagController StyleController GroupController LevelController NoteController UserController StageController TransitionController WorkflowController

Fonctions membres publiques

__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller tailored to suit most form-based admin operations.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
FormFactoryInterface | $formFactory | The form factory.
Depuis
3.0

Références $app, $config, $context, $input, $r, $this, Symfony\Contracts\Service\__construct(), ComponentHelper\getComponentName(), Inflector\getInstance(), null, Joomla\CMS\Form\setFormFactory(), et Text\sprintf().

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new record.

Renvoie
boolean True if the record can be added, false if not.
Depuis
1.6

Références $context, Text\_(), Route\_(), et null.

◆ allowAdd()

allowAdd ( $data = [] )
protected

Method to check if you can add a new record.

Extended classes can override this if necessary.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $this, et $user.

◆ allowEdit()

allowEdit | ( | $data = [],
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit an existing record.

Extended classes can override this if necessary.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key; default is id.
Renvoie
boolean
Depuis
1.6

◆ allowSave()

allowSave | ( | $data,
 |  | $key = 'id'
 | ) |
protected

Method to check if you can save a new or existing record.

Extended classes can override this if necessary.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, $key, et $recordId.

◆ batch()

batch ( $model )

Method to run batch operations.

Paramètres
BaseDatabaseModel $model The model of the component being processed.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
1.7

Références $id, $model, $option, Text\_(), extension, et Text\sprintf().

◆ cancel()

cancel ( $key = null )

Method to cancel an edit.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
1.6

Références $context, $key, $model, $recordId, $return, $url, Route\_(), Joomla\Application\checkToken(), Uri\isInternal(), null, et Text\sprintf().

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to edit an existing record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if access level check and checkout passes, false otherwise.
Depuis
1.6

Références $context, $key, $model, $recordId, Text\_(), Route\_(), null, et Text\sprintf().

◆ editAssociations()

editAssociations ( )

Load item to edit associations in com_associations

Renvoie
void
Depuis
3.9.0
Obsolète:
5.0 It is handled by regular save method now.

Références $app, $data, $input, et $model.

◆ getModel()

getModel | ( | $name = '',
 |  | $prefix = '',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
BaseDatabaseModel The model.
Depuis
1.6

Références $config, $context, $name, et $prefix.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

Références $append, $layout, $recordId, $return, $tmpl, et null.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

Références $append, et $tmpl.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
1.6

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to save a record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if successful, false otherwise.
Depuis
1.6

We need the filtered value of calendar fields because the UTC normalisation is done in the filter and on output. This would apply the Timezone offset on reload. We set the calendar values we save to the processed date.

Références $app, $context, $data, $field, $form, $i, $key, $model, $n, $prefix, $recordId, $return, $task, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), Uri\isInternal(), null, et Text\sprintf().

Documentation des champs

◆ $context

$context
protected

◆ $option

$option
protected

◆ $text_prefix

$text_prefix
protected

◆ $view_item

$view_item
protected

◆ $view_list

$view_list
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormController.php


Joomla CMS: Référence de la classe ApiMVCFactory

  • Joomla
  • CMS
  • MVC
  • Factory
  • ApiMVCFactory
Fonctions membres publiques
Référence de la classe ApiMVCFactory
+ Graphe d'héritage de ApiMVCFactory:
MVCFactory MVCFactoryInterface FormFactoryAwareInterface SiteRouterAwareInterface

Fonctions membres publiques

createModel ($name, $prefix='', array $config=array())
createTable ($name, $prefix='', array $config=array())
- Fonctions membres publiques hérités de MVCFactory
__construct ($namespace)
createController ($name, $prefix, array $config, CMSApplicationInterface $app, Input $input)
createModel ($name, $prefix='', array $config=[])
createView ($name, $prefix='', $type='', array $config=[])
createTable ($name, $prefix='', array $config=[])
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de SiteRouterAwareInterface
setSiteRouter (SiteRouter $router)

Membres hérités additionnels

- Fonctions membres protégées hérités de MVCFactory
getClassName (string $suffix, string $prefix)

Description détaillée

Factory to create MVC objects based on a namespace. Note that in an API Application model and table objects will be created from their administrator counterparts.

Depuis
4.0.0

Documentation des fonctions membres

◆ createModel()

createModel | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = array()
 | ) |  |

Method to load and return a model object.

Paramètres
string | $name | The name of the model.
string | $prefix | Optional model prefix.
array | $config | Optional configuration array for the model.
Renvoie
The model object
Depuis
4.0.0
Exceptions

Implémente MVCFactoryInterface.

Références $config, $model, $name, et $prefix.

◆ createTable()

createTable | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = array()
 | ) |  |

Method to load and return a table object.

Paramètres
string | $name | The name of the table.
string | $prefix | Optional table prefix.
array | $config | Optional configuration array for the table.
Renvoie
The table object
Depuis
4.0.0
Exceptions

Implémente MVCFactoryInterface.

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApiMVCFactory.php


Joomla CMS: Référence de la classe LegacyFactory

  • Joomla
  • CMS
  • MVC
  • Factory
  • LegacyFactory
Fonctions membres publiques
Référence de la classe LegacyFactory
+ Graphe d'héritage de LegacyFactory:
MVCFactoryInterface

Fonctions membres publiques

createController ($name, $prefix, array $config, CMSApplicationInterface $app, Input $input)
createModel ($name, $prefix='', array $config=[])
createView ($name, $prefix='', $type='', array $config=[])
createTable ($name, $prefix='Table', array $config=[])

Description détaillée

Factory to create MVC objects in legacy mode. Uses the static getInstance function on the classes itself. Behavior of the old none namespaced extension set up.

Depuis
3.10.0

Documentation des fonctions membres

◆ createController()

createController | ( |  | $name,
 |  |  | $prefix,
 |  | array | $config,
 |  | CMSApplicationInterface | $app,
 |  | Input | $input
 | ) |  |

Method to load and return a controller object.

Paramètres
string | $name | The name of the controller
string | $prefix | The controller prefix
array | $config | The configuration array for the controller
CMSApplicationInterface | $app | The app
Input | $input | The input
Renvoie
Depuis
4.0.0
Exceptions

Implémente MVCFactoryInterface.

◆ createModel()

createModel | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a model object.

Paramètres
string | $name | The name of the model.
string | $prefix | Optional model prefix.
array | $config | Optional configuration array for the model.
Renvoie
ModelInterface The model object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $config, $name, et $prefix.

◆ createTable()

createTable | ( |  | $name,
 |  |  | $prefix = 'Table',
 |  | array | $config = []
 | ) |  |

Method to load and return a table object.

Paramètres
string | $name | The name of the table.
string | $prefix | Optional table prefix.
array | $config | Optional configuration array for the table.
Renvoie
The table object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $config, $name, $prefix, et Table\getInstance().

◆ createView()

createView | ( |  | $name,
 |  |  | $prefix = '',
 |  |  | $type = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a view object.

Paramètres
string | $name | The name of the view.
string | $prefix | Optional view prefix.
string | $type | Optional type of view.
array | $config | Optional configuration array for the view.
Renvoie
The view object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $config, $name, $path, $prefix, $type, BaseController\createFileName(), Path\find(), null, JLoader\register(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LegacyFactory.php


Joomla CMS: Référence de la classe MVCFactory

  • Joomla
  • CMS
  • MVC
  • Factory
  • MVCFactory
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe MVCFactory
+ Graphe d'héritage de MVCFactory:
MVCFactoryInterface FormFactoryAwareInterface SiteRouterAwareInterface ApiMVCFactory

Fonctions membres publiques

__construct ($namespace)
createController ($name, $prefix, array $config, CMSApplicationInterface $app, Input $input)
createModel ($name, $prefix='', array $config=[])
createView ($name, $prefix='', $type='', array $config=[])
createTable ($name, $prefix='', array $config=[])
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de SiteRouterAwareInterface
setSiteRouter (SiteRouter $router)

Fonctions membres protégées

getClassName (string $suffix, string $prefix)

Fonctions membres privées

setFormFactoryOnObject ($object)
setDispatcherOnObject ($object)
setRouterOnObject ($object)
setCacheControllerOnObject ($object)

Attributs privés

$namespace

Description détaillée

Factory to create MVC objects based on a namespace.

Depuis
3.10.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $namespace )

The namespace must be like: Joomla

Paramètres
string $namespace The namespace
Depuis
4.0.0

Références $namespace.

Documentation des fonctions membres

◆ createController()

createController | ( |  | $name,
 |  |  | $prefix,
 |  | array | $config,
 |  | CMSApplicationInterface | $app,
 |  | Input | $input
 | ) |  |

Method to load and return a controller object.

Paramètres
string | $name | The name of the controller
string | $prefix | The controller prefix
array | $config | The configuration array for the controller
CMSApplicationInterface | $app | The app
Input | $input | The input
Renvoie
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $app, $className, $config, $input, $name, $prefix, $this, et null.

◆ createModel()

createModel | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a model object.

Paramètres
string | $name | The name of the model.
string | $prefix | Optional model prefix.
array | $config | Optional configuration array for the model.
Renvoie
ModelInterface The model object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $className, $config, $model, $name, $prefix, $this, class, Factory\getApplication(), Factory\getContainer(), Joomla\Database\getDatabase(), et null.

◆ createTable()

createTable | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a table object.

Paramètres
string | $name | The name of the table.
string | $prefix | Optional table prefix.
array | $config | Optional configuration array for the table.
Renvoie
The table object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $className, $config, $db, $name, $prefix, class, Factory\getApplication(), Factory\getContainer(), Joomla\Database\getDatabase(), et null.

◆ createView()

createView | ( |  | $name,
 |  |  | $prefix = '',
 |  |  | $type = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a view object.

Paramètres
string | $name | The name of the view.
string | $prefix | Optional view prefix.
string | $type | Optional type of view.
array | $config | Optional configuration array for the view.
Renvoie
The view object
Depuis
3.10.0
Exceptions

Implémente MVCFactoryInterface.

Références $className, $config, $name, $prefix, $type, $view, Factory\getApplication(), et null.

◆ getClassName()

getClassName | ( | string | $suffix,
 |  | string | $prefix
 | ) |  |
protected

Returns a standard classname, if the class doesn't exist null is returned.

Paramètres
string | $suffix | The suffix
string | $prefix | The prefix
Renvoie
string|null The class name
Depuis
3.10.0

Références $className, $prefix, $suffix, Factory\getApplication(), et null.

◆ setCacheControllerOnObject()

setCacheControllerOnObject ( $object )
private

Sets the internal cache controller on the given object.

Paramètres
object $object The object
Renvoie
void
Depuis
4.2.0

Références Joomla\CMS\Cache\getCacheControllerFactory().

◆ setDispatcherOnObject()

setDispatcherOnObject ( $object )
private

Sets the internal event dispatcher on the given object.

Paramètres
object $object The object
Renvoie
void
Depuis
4.2.0

Références Joomla\CMS\Application\getDispatcher().

◆ setFormFactoryOnObject()

setFormFactoryOnObject ( $object )
private

Sets the internal form factory on the given object.

Paramètres
object $object The object
Renvoie
void
Depuis
4.0.0

Références Joomla\CMS\Form\getFormFactory().

◆ setRouterOnObject()

setRouterOnObject ( $object )
private

Sets the internal router on the given object.

Paramètres
object $object The object
Renvoie
void
Depuis
4.2.0

Références Joomla\CMS\Router\getSiteRouter().

Documentation des champs

◆ $namespace

$namespace
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MVC/Factory/MVCFactory.php


Joomla CMS: Référence de l'interface MVCFactoryInterface

  • Joomla
  • CMS
  • MVC
  • Factory
  • MVCFactoryInterface
Fonctions membres publiques
Référence de l'interface MVCFactoryInterface
+ Graphe d'héritage de MVCFactoryInterface:
LegacyFactory MVCFactory ApiMVCFactory

Fonctions membres publiques

createController ($name, $prefix, array $config, CMSApplicationInterface $app, Input $input)
createModel ($name, $prefix='', array $config=[])
createView ($name, $prefix='', $type='', array $config=[])
createTable ($name, $prefix='', array $config=[])

Description détaillée

Factory to create MVC objects.

Depuis
3.10.0

Documentation des fonctions membres

◆ createController()

createController | ( |  | $name,
 |  |  | $prefix,
 |  | array | $config,
 |  | CMSApplicationInterface | $app,
 |  | Input | $input
 | ) |  |

Method to load and return a controller object.

Paramètres
string | $name | The name of the controller
string | $prefix | The controller prefix
array | $config | The configuration array for the controller
CMSApplicationInterface | $app | The app
Input | $input | The input
Renvoie
Depuis
4.0.0
Exceptions

Implémenté dans MVCFactory, et LegacyFactory.

◆ createModel()

createModel | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a model object.

Paramètres
string | $name | The name of the model.
string | $prefix | Optional model prefix.
array | $config | Optional configuration array for the model.
Renvoie
ModelInterface The model object
Depuis
3.10.0
Exceptions

Implémenté dans MVCFactory, LegacyFactory, et ApiMVCFactory.

◆ createTable()

createTable | ( |  | $name,
 |  |  | $prefix = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a table object.

Paramètres
string | $name | The name of the table.
string | $prefix | Optional table prefix.
array | $config | Optional configuration array for the table.
Renvoie
The table object
Depuis
3.10.0
Exceptions

Implémenté dans MVCFactory, LegacyFactory, et ApiMVCFactory.

◆ createView()

createView | ( |  | $name,
 |  |  | $prefix = '',
 |  |  | $type = '',
 |  | array | $config = []
 | ) |  |

Method to load and return a view object.

Paramètres
string | $name | The name of the view.
string | $prefix | Optional view prefix.
string | $type | Optional type of view.
array | $config | Optional configuration array for the view.
Renvoie
The view object
Depuis
3.10.0
Exceptions

Implémenté dans MVCFactory, et LegacyFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • MVCFactoryInterface.php


Joomla CMS: Référence de l'interface MVCFactoryServiceInterface

  • Joomla
  • CMS
  • MVC
  • Factory
  • MVCFactoryServiceInterface
Fonctions membres publiques
Référence de l'interface MVCFactoryServiceInterface
+ Graphe d'héritage de MVCFactoryServiceInterface:
LegacyComponent MVCComponent AdminComponent BannersComponent CategoriesComponent ConfigComponent ContactComponent ContentComponent FieldsComponent FinderComponent InstallerComponent LanguagesComponent MenusComponent MessagesComponent ModulesComponent NewsfeedsComponent PrivacyComponent RedirectComponent SchedulerComponent TagsComponent TemplatesComponent UsersComponent WrapperComponent

Fonctions membres publiques

getMVCFactory ()

Description détaillée

Interface to be implemented by classes depending on a MVC factory.

Depuis
4.0.0

Documentation des fonctions membres

◆ getMVCFactory()

getMVCFactory ( )

Get the factory.

Renvoie
MVCFactoryInterface
Depuis
4.0.0
Exceptions

Implémenté dans LegacyComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • MVCFactoryServiceInterface.php


Joomla CMS: Référence de la classe AdminModel

  • Joomla
  • CMS
  • MVC
  • Model
  • AdminModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe AdminModel
+ Graphe d'héritage de AdminModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface BannerModel ClientModel CategoryModel ContactModel ArticleModel FieldModel GroupModel FilterModel UpdatesiteModel LanguageModel OverrideModel TemplateModel ItemModel MessageModel ModuleModel NewsfeedModel PluginModel RequestModel ConfirmModel RemindModel RequestModel LinkModel TaskModel TagModel StyleModel GroupModel LevelModel MailModel NoteModel UserModel StageModel TransitionModel WorkflowModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de FormModelInterface
getForm ($data=array(), $loadData=true)

Champs de données

$typeAlias

Fonctions membres protégées

batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Prototype admin model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
FormFactoryInterface | $formFactory | The form factory.
Depuis
1.6
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et elseif.

Documentation des fonctions membres

◆ batch()

batch | ( | $commands,
 |  | $pks,
 |  | $contexts
 | ) |

Method to perform batch operations on an item or a set of items.

Paramètres
array | $commands | An array of commands to perform.
array | $pks | An array of item ids.
array | $contexts | An array of item contexts.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.7

Références $result, Text\_(), elseif, ArrayHelper\getValue(), et ArrayHelper\toInteger().

◆ batchAccess()

batchAccess | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch access level changes for a group of rows.

Paramètres
integer | $value | The new value matching an Asset Group ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
1.7

Références $value, et Text\_().

◆ batchCopy()

batchCopy | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch copy items to a new category or current.

Paramètres
integer | $value | The new category.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
array|boolean An array of new IDs on success, boolean false on failure.
Depuis
1.7

Références $db, $query, $this, $value, elseif, Joomla\CMS\MVC\Model\getDbo(), ParameterType\INTEGER, et Text\sprintf().

◆ batchLanguage()

batchLanguage | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch language changes for a group of rows.

Paramètres
string | $value | The new value matching a language.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
2.5

Références $value, et Text\_().

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move items to a new category

Paramètres
integer | $value | The new category ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
1.7

Références $value, Text\_(), et Text\sprintf().

◆ batchTag()

batchTag | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch tag a list of item.

Paramètres
integer | $value | The value of the new tag.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
3.1

Références $value, Text\_(), et AbstractEvent\create().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
1.6

Références Factory\getUser().

◆ checkCategoryId()

checkCategoryId ( $categoryId )
protected

Method to check the validity of the category ID for batch copy and move

Paramètres
integer $categoryId The category ID to check
Renvoie
boolean
Depuis
3.2

Références $extension, $user, Text\_(), Factory\getApplication(), Table\getInstance(), et Factory\getUser().

◆ checkin()

checkin ( $pks = array() )

Method override to check-in a record or an array of record

Paramètres
mixed $pks The ID of the primary key or an array of IDs
Renvoie
integer|boolean Boolean false if there is an error, otherwise the count of records checked in.
Depuis
1.6

Références $count, et Joomla\CMS\MVC\Model\getState().

◆ checkout()

checkout ( $pk = null )

Method override to check-out a record.

Paramètres
integer $pk The ID of the primary key.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
1.6

Références Joomla\CMS\MVC\Model\getState().

◆ cleanupPostBatchCopy()

cleanupPostBatchCopy | ( | TableInterface | $table,
 |  |  | $newId,
 |  |  | $oldId
 | ) |  |
protected

Function that can be overridden to do any data cleanup after batch copying data

Paramètres
TableInterface | $table | The table object containing the newly created item
integer | $newId | The id of the new item
integer | $oldId | The original item id
Renvoie
void
Depuis
3.8.12

◆ delete()

delete ( & $pks )

Method to delete one or more records.

Paramètres
array &$pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
1.6

Références $context, $db, $i, $name, $query, $result, Text\_(), Log\add(), Factory\getApplication(), Joomla\CMS\MVC\Model\getDbo(), PluginHelper\importPlugin(), ParameterType\INTEGER, Associations\isEnabled(), ArrayHelper\toInteger(), et Log\WARNING.

◆ editAssociations()

editAssociations ( $data )

Method to load an item in com_associations.

Paramètres
array $data The form data.
Renvoie
boolean True if successful, false otherwise.
Depuis
3.9.0
Obsolète:
5.0 It is handled by regular save method now.

Références $data.

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title & alias.

Paramètres
integer | $categoryId | The id of the category.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
1.7

Références $title, et StringHelper\increment().

◆ generateTitle()

generateTitle | ( | $categoryId,
 |  | $table
 | ) |

A method to preprocess generating a new title in order to allow tables with alternative names for alias and title to use the batch move and copy methods

Paramètres
integer | $categoryId | The target category id
Table | $table | The Table within which move or copy is taking place
Renvoie
void
Depuis
3.2

Références $data.

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
CMSObject|boolean Object on success, false on failure.
Depuis
1.6

Références $item, $return, Text\_(), class, Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
Table $table A Table object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

◆ initBatch()

initBatch ( )

Method to initialize member variables used by batch methods and other methods like saveorder()

Renvoie
void
Depuis
3.8.2

Références Factory\getUser(), et null.

◆ populateState()

populateState ( )
protected

Stock method to auto-populate the model state.

Renvoie
void
Depuis
1.6

Références $key, $value, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table data prior to saving.

Paramètres
Table $table A reference to a Table object.
Renvoie
void
Depuis
1.6

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
1.6

Prune items that are already at the given state. Note: Only models whose table correctly sets 'published' column alias (if different than published) will benefit from this

Références $context, $i, $name, $result, $user, $value, Text\_(), Log\add(), Factory\getApplication(), Factory\getUser(), PluginHelper\importPlugin(), et Log\WARNING.

◆ redirectToAssociations()

redirectToAssociations ( $data )
protected

Method to load an item in com_associations.

Paramètres
array $data The form data.
Renvoie
boolean True if successful, false otherwise.
Exceptions

If the site contains only 2 languages and an association exists for the item load directly the associated target item in the side by side view otherwise select already the target language

Références $app, $client, $component, $data, $extension, $id, $language, $languages, $target, $view, Text\_(), Route\_(), et Factory\getApplication().

◆ reorder()

reorder | ( | $pks,
 |  | $delta = 0
 | ) |

Method to adjust the ordering of a row.

Returns NULL if the user did not have edit privileges for any of the selected primary keys.

Paramètres
integer | $pks | The ID of the primary key to move.
integer | $delta | Increment, usually +1 or -1
Renvoie
boolean|null False on failure or error, true on success, null if the $pk is empty (no items selected).
Depuis
1.6

Références $i, $result, Text\_(), Log\add(), null, et Log\WARNING.

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
1.6

Références $app, $context, $data, $db, $id, $key, $name, $query, $result, $this, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getDbo(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), ParameterType\INTEGER, Associations\isEnabled(), null, Joomla\CMS\MVC\Model\setState(), ParameterType\STRING, et ArrayHelper\toInteger().

◆ saveorder()

saveorder | ( | $pks = array(),
 |  | $order = null
 | ) |

Saves the manually set order of records.

Paramètres
array | $pks | An array of primary key ids.
integer | $order | +1 or -1
Renvoie
boolean Boolean true on success, false on failure
Depuis
1.6

Références $i, $key, Text\_(), Log\add(), elseif, Factory\getApplication(), et Log\WARNING.

Documentation des champs

◆ $associationsContext

$associationsContext = null
protected

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage',
'tag' => 'batchTag'
)

◆ $batch_copymove

$batch_copymove = 'category_id'
protected

◆ $batchSet

$batchSet = null
protected

◆ $contentType

$contentType = null
protected

◆ $event_after_delete

$event_after_delete = null
protected

◆ $event_after_save

$event_after_save = null
protected

◆ $event_before_batch

$event_before_batch = null
protected

◆ $event_before_change_state

$event_before_change_state = null
protected

◆ $event_before_delete

$event_before_delete = null
protected

◆ $event_before_save

$event_before_save = null
protected

◆ $event_change_state

$event_change_state = null
protected

◆ $table

$table = null
protected

◆ $tableClassName

$tableClassName = null
protected

◆ $text_prefix

$text_prefix = null
protected

◆ $type

$type = null
protected

◆ $typeAlias

$typeAlias

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdminModel.php


Joomla CMS: Référence de la classe BaseDatabaseModel

  • Joomla
  • CMS
  • MVC
  • Model
  • BaseDatabaseModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe BaseDatabaseModel
+ Graphe d'héritage de BaseDatabaseModel:
BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Base class for a database aware Joomla Model

Acts as a Factory class for application specific objects and provides many supporting API functions.

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
Depuis
3.0
Exceptions
Obsolète:
5.0 Database instance is injected through the setter function, subclasses should not use the db instance in constructor anymore

Références $component, $config, $db, $r, $this, Symfony\Contracts\Service\__construct(), elseif, Factory\getApplication(), ComponentHelper\getComponentName(), Factory\getDbo(), null, Joomla\Database\setDatabase(), Joomla\CMS\MVC\Model\setDbo(), Joomla\CMS\MVC\Factory\setMVCFactory(), et Text\sprintf().

Documentation des fonctions membres

◆ __get()

__get ( $name )

Proxy for _db variable.

Paramètres
string $name The name of the element
Renvoie
mixed The value of the element if set, null otherwise
Depuis
4.2.0
Obsolète:
5.0 Use getDatabase() instead of directly accessing _db

Références $name, Joomla\CMS\MVC\Model\getDbo(), et null.

◆ _createTable()

_createTable | ( | $name,
 |  | $prefix = 'Table',
 |  | $config = array()
 | ) |
protected

Method to load and return a table object.

Paramètres
string | $name | The name of the view
string | $prefix | The class prefix. Optional.
array | $config | Configuration settings to pass to Table::getInstance
Renvoie
Table|boolean Table object or boolean false if failed
Depuis
3.0
Voir également
::getInstance()

Références $config, $name, $prefix, Joomla\CMS\MVC\Model\getDbo(), et Joomla\CMS\MVC\Factory\getMVCFactory().

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Gets an array of objects from the results of database query.

Paramètres
string | $query | The query.
integer | $limitstart | Offset.
integer | $limit | The number of records.
Renvoie
object[] An array of results.
Depuis
3.0
Exceptions

Références $limit, $query, et Joomla\CMS\MVC\Model\getDbo().

◆ _getListCount()

_getListCount ( $query )
protected

Returns a record count for the query.

Note: Current implementation of this method assumes that getListQuery() returns a set of unique rows, thus it uses SELECT COUNT(*) to count the rows. In cases that getListQuery() uses DISTINCT then either this method must be overridden by a custom implementation at the derived Model Class or a GROUP BY clause should be used to make the set unique.

Paramètres
DatabaseQuery | string $query The query.
Renvoie
integer Number of rows for query.
Depuis
3.0

Références $query, Joomla\CMS\MVC\Model\getDbo(), et null.

◆ bootComponent()

bootComponent ( $component )
protected

Boots the component with the given name.

Paramètres
string $component The component name, eg. com_content.
Renvoie
ComponentInterface The service container
Depuis
4.0.0

Références $component, et Factory\getApplication().

◆ dispatchEvent()

dispatchEvent ( EventInterface $event )
protected

Dispatches the given event on the internal dispatcher, does a fallback to the global one.

Paramètres
EventInterface $event The event
Renvoie
void
Depuis
4.1.0

Références class, Factory\getContainer(), Joomla\CMS\Application\getDispatcher(), et EventInterface\getName().

◆ getDbo()

getDbo ( )

Get the database driver.

Renvoie
DatabaseInterface The database driver.
Depuis
4.2.0
Exceptions

Implémente DatabaseModelInterface.

Références Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $name = '',
 |  | $prefix = '',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.0
Exceptions

Références $name, $options, $prefix, Joomla\CMS\MVC\Factory\getMVCFactory(), et Text\sprintf().

◆ isCheckedOut()

isCheckedOut ( $item )

Method to check if the given record is checked out by the current user

Paramètres
\stdClass $item The record to check
Renvoie
bool

Références $item.

◆ setDbo()

setDbo ( DatabaseInterface $db = null )

Set the database driver.

Paramètres
DatabaseInterface $db The database driver.
Renvoie
void
Depuis
4.2.0
Obsolète:
5.0 Use setDatabase() instead

Références $db, null, et Joomla\Database\setDatabase().

Documentation des champs

◆ $event_clean_cache

$event_clean_cache = null
protected

◆ $option

$option = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseDatabaseModel.php


Joomla CMS: Référence de la classe BaseModel

  • Joomla
  • CMS
  • MVC
  • Model
  • BaseModel
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe BaseModel
+ Graphe d'héritage de BaseModel:
CMSObject ModelInterface StatefulModelInterface BaseDatabaseModel AdapterModel AdaptersModel MediaModel MediumModel CapabilitiesModel BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Fonctions membres publiques statiques

static addIncludePath ($path='', $prefix='')

Attributs protégés

$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs protégés statiques

static $paths

Description détaillée

Base class for a Joomla Model

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor

Paramètres
array $config An array of configuration options (name, state, ignore_request).
Depuis
4.0.0
Exceptions

Références $config, et name.

Documentation des fonctions membres

◆ addIncludePath()

static addIncludePath | ( | $path = '',
 |  | $prefix = ''
 | ) |
static

Add a directory where should search for models. You may either pass a string or an array of directories.

Paramètres
mixed | $path | A path or array[sting] of paths to search.
string | $prefix | A prefix for models.
Renvoie
array An array with directory elements. If prefix is equal to '', all directories are returned.
Depuis
3.0
Obsolète:
5.0 See LegacyModelLoaderTrait

Références $path, $prefix, et Path\clean().

Référencé par BaseController\addModelPath().

◆ getName()

getName ( )

Method to get the model name

The model name. By default parsed using the classname or it can be set by passing a $config['name'] in the class constructor

Renvoie
string The name of the model
Depuis
4.0.0
Exceptions

Implémente ModelInterface.

Références $name, $r, $this, name, null, et Text\sprintf().

Documentation des champs

◆ $name

$name
protected

◆ $paths

$paths
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseModel.php


Joomla CMS: Référence de l'interface DatabaseModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • DatabaseModelInterface
Fonctions membres publiques
Référence de l'interface DatabaseModelInterface
+ Graphe d'héritage de DatabaseModelInterface:
BaseDatabaseModel BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

getDbo ()

Description détaillée

Interface for a database model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getDbo()

getDbo ( )

Method to get the database driver object.

Renvoie
DatabaseInterface
Depuis
4.0.0

Implémenté dans BaseDatabaseModel.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DatabaseModelInterface.php


Joomla CMS: Référence de la classe FormModel

  • Joomla
  • CMS
  • MVC
  • Model
  • FormModel
Fonctions membres publiques | Attributs protégés
Référence de la classe FormModel
+ Graphe d'héritage de FormModel:
BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface AdminModel DownloadModel ApplicationModel ComponentModel FormModel FileModel MenuModel ConfigModel TemplateModel LoginModel ProfileModel RegistrationModel RemindModel ResetModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de FormModelInterface
getForm ($data=array(), $loadData=true)

Attributs protégés

$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Prototype form model.

Voir également
Form
FormField
FormRule
Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
FormFactoryInterface | $formFactory | The form factory.
Depuis
3.6
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Joomla\CMS\Form\setFormFactory().

Documentation des fonctions membres

◆ checkin()

checkin ( $pk = null )

Method to checkin a row.

Paramètres
integer $pk The numeric id of the primary key.
Renvoie
boolean False on failure or error, true otherwise.
Depuis
1.6

Références $user, Text\_(), et Joomla\CMS\User\getCurrentUser().

◆ checkout()

checkout ( $pk = null )

Method to check-out a row for editing.

Paramètres
integer $pk The numeric id of the primary key.
Renvoie
boolean False on failure or error, true otherwise.
Depuis
1.6

Références $user, Text\_(), et Joomla\CMS\User\getCurrentUser().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
FormRule
InputFilter
Depuis
1.6

Références $data, $form, $message, $return, Factory\getApplication(), Factory\getContainer(), et PluginHelper\importPlugin().

Documentation des champs

◆ $events_map

$events_map = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/MVC/Model/FormModel.php


Joomla CMS: Référence de l'interface FormModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • FormModelInterface
Fonctions membres publiques
Référence de l'interface FormModelInterface
+ Graphe d'héritage de FormModelInterface:
FormModel AdminModel DownloadModel ApplicationModel ComponentModel FormModel FileModel MenuModel ConfigModel TemplateModel LoginModel ProfileModel RegistrationModel RemindModel ResetModel

Fonctions membres publiques

getForm ($data=array(), $loadData=true)

Description détaillée

Interface for a form model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method for getting a form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form
Depuis
4.0.0
Exceptions

Implémenté dans TemplateModel, ModuleModel, ItemModel, FieldModel, ArticleModel, RegistrationModel, StyleModel, CategoryModel, TransitionModel, StageModel, FormModel, RequestModel, MessageModel, BannerModel, LevelModel, ConfirmModel, ContactModel, MenuModel, TaskModel, TagModel, WorkflowModel, LanguageModel, RemindModel, UserModel, ProfileModel, NewsfeedModel, ConfigModel, ContactModel, FilterModel, GroupModel, ClientModel, PluginModel, GroupModel, TemplateModel, ComponentModel, ApplicationModel, RequestModel, LinkModel, DownloadModel, FormModel, ModulesModel, TemplatesModel, UpdatesiteModel, NoteModel, ResetModel, MailModel, LoginModel, RemindModel, OverrideModel, FileModel, et ConfigModel.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FormModelInterface.php


Joomla CMS: Référence de la classe ItemModel

  • Joomla
  • CMS
  • MVC
  • Model
  • ItemModel
Fonctions membres protégées | Attributs protégés
Référence de la classe ItemModel
+ Graphe d'héritage de ItemModel:
BaseDatabaseModel ItemModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ArticleModel PreviewModel NewsfeedModel

Fonctions membres protégées

getStoreId ($id='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_item = null
$_context = 'group.type'
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de ItemModelInterface
getItem ($pk=null)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Prototype item model.

Depuis
1.6

Documentation des fonctions membres

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id.

Documentation des champs

◆ $_context

$_context = 'group.type'
protected

◆ $_item

$_item = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/MVC/Model/ItemModel.php


Joomla CMS: Référence de l'interface ItemModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • ItemModelInterface
Fonctions membres publiques
Référence de l'interface ItemModelInterface
+ Graphe d'héritage de ItemModelInterface:
ItemModel ArticleModel PreviewModel NewsfeedModel

Fonctions membres publiques

getItem ($pk=null)

Description détaillée

Interface for an item model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getItem()

getItem ( $pk = null )

Method to get an item.

Paramètres
integer $pk The id of the item
Renvoie
object
Depuis
4.0.0
Exceptions

Implémenté dans ArticleModel, et NewsfeedModel.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ItemModelInterface.php


Joomla CMS: Référence de la classe ListModel

  • Joomla
  • CMS
  • MVC
  • Model
  • ListModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ListModel
+ Graphe d'héritage de ListModel:
BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ActionlogsModel AssociationModel AssociationsModel BannersModel ClientsModel TracksModel BannersModel CacheModel CategoriesModel CheckinModel ContactsModel CategoriesModel CategoryModel FeaturedModel ArticlesModel ArticlesModel CategoriesModel CategoryModel CompareModel HistoryModel FieldsModel GroupsModel FiltersModel IndexModel MapsModel SearchesModel SearchModel SuggestionsModel InstallerModel LanguagesModel UpdateModel WarningsModel InstalledModel LanguagesModel OverridesModel TemplatesModel ItemsModel MenusModel MessagesModel ModulesModel PositionsModel SelectModel NewsfeedsModel CategoriesModel CategoryModel PluginsModel ConsentsModel RequestsModel LinksModel SelectModel TasksModel TagsModel TagModel TagsModel StylesModel TemplatesModel DebuggroupModel DebuguserModel GroupsModel LevelsModel NotesModel UsersModel StagesModel TransitionsModel WorkflowsModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for handling lists of items.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
Depuis
1.6
Exceptions
Exception

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getListQuery()

_getListQuery ( )
protected

Method to cache the last query constructed.

This method ensures that the query is constructed only once for a given state of the model.

Renvoie
DatabaseQuery A DatabaseQuery object
Depuis
1.6

Références $query.

◆ getActiveFilters()

getActiveFilters ( )

Function to get the active filters

Renvoie
array Associative array in the format: array('filter_published' => 0)
Depuis
3.2

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Provide a query to be used to evaluate if this is an Empty State, can be overridden in the model to provide granular control.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $query.

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
Form|null The object or null if the form can't be found
Depuis
3.2

Références Joomla\CMS\MVC\Model\loadForm(), et null.

◆ getIsEmptyState()

getIsEmptyState ( )

Is this an empty state, I.e: no items of this type regardless of the searched for states.

Renvoie
boolean
Exceptions
Exception
Depuis
4.0.0

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6

Implémente ListModelInterface.

Références Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
DatabaseQuery A DatabaseQuery object to retrieve the data set.
Depuis
1.6

Références Joomla\CMS\MVC\Model\getDbo().

◆ getPagination()

getPagination ( )

Method to get a object for the data set.

Renvoie
Pagination A Pagination object for the data set.
Depuis
1.6

Références $limit, et Joomla\CMS\MVC\Model\getState().

◆ getStart()

getStart ( )

Method to get the starting number of items for the data set.

Renvoie
integer The starting number of items available in the data set.
Depuis
1.6

Références $limit, $start, $total, et Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on the model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id An identifier string to generate the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTotal()

getTotal ( )

Method to get the total number of items for the data set.

Renvoie
integer The total number of items available in the data set.
Depuis
1.6

◆ getUserStateFromRequest()

getUserStateFromRequest | ( | $key,
 |  | $request,
 |  | $default = null,
 |  | $type = 'none',
 |  | $resetPage = true
 | ) |

Gets the value of a user state variable and sets it in the session

This is the same as the method in Application except that this also can optionally force you back to the first page when a filter has changed

Paramètres
string | $key | The key of the user state variable.
string | $request | The name of the variable passed in a request.
string | $default | The default value for the variable if not found. Optional.
string | $type | Filter for the variable, for valid values see InputFilter::clean(). Optional.
boolean | $resetPage | If true, the limitstart in request is set to zero
Renvoie
mixed The request user state.
Depuis
1.6

Références $app, $default, $filters, $input, $key, $name, $type, Factory\getApplication(), et null.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
3.2

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $field, $filters, $limit, $list, $name, $ordering, $this, $value, Factory\getApplication(), InputFilter\getInstance(), et Joomla\CMS\MVC\Model\setState().

◆ refineSearchStringToRegex()

refineSearchStringToRegex | ( | $search,
 |  | $regexDelimiter = '/'
 | ) |
protected

Parse and transform the search string into a string fit for regex-ing arbitrary strings against

Paramètres
string | $search | The search string
string | $regexDelimiter | The regex delimiter to use for the quoting
Renvoie
string Search string escaped for regex
Depuis
3.4

Références $key.

Documentation des champs

◆ $cache

$cache = array()
protected

◆ $context

$context = null
protected

◆ $filter_fields

$filter_fields = array()
protected

◆ $filterBlacklist

$filterBlacklist = array()
protected

◆ $filterForbiddenList

$filterForbiddenList = array()
protected

◆ $filterFormName

$filterFormName = null
protected

◆ $htmlFormName

$htmlFormName = 'adminForm'
protected

◆ $lastQueryStoreId

$lastQueryStoreId = null
protected

◆ $listBlacklist

$listBlacklist = array('select')
protected

◆ $listForbiddenList

$listForbiddenList = array('select')
protected

◆ $query

$query = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ListModel.php


Joomla CMS: Référence de l'interface ListModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • ListModelInterface
Fonctions membres publiques
Référence de l'interface ListModelInterface
+ Graphe d'héritage de ListModelInterface:
ListModel AdaptersModel MediaModel ActionlogsModel AssociationModel AssociationsModel BannersModel ClientsModel TracksModel BannersModel CacheModel CategoriesModel CheckinModel ContactsModel CategoriesModel CategoryModel FeaturedModel ArticlesModel ArticlesModel CategoriesModel CategoryModel CompareModel HistoryModel FieldsModel GroupsModel FiltersModel IndexModel MapsModel SearchesModel SearchModel SuggestionsModel InstallerModel LanguagesModel UpdateModel WarningsModel InstalledModel LanguagesModel OverridesModel TemplatesModel ItemsModel MenusModel MessagesModel ModulesModel PositionsModel SelectModel NewsfeedsModel CategoriesModel CategoryModel PluginsModel ConsentsModel RequestsModel LinksModel SelectModel TasksModel TagsModel TagModel TagsModel StylesModel TemplatesModel DebuggroupModel DebuguserModel GroupsModel LevelsModel NotesModel UsersModel StagesModel TransitionsModel WorkflowsModel

Fonctions membres publiques

getItems ()

Description détaillée

Interface for a list model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items
Depuis
4.0.0
Exceptions

Implémenté dans ArticlesModel, ArticlesModel, ItemsModel, UpdatesitesModel, CategoriesModel, DatabaseModel, TagsModel, BannersModel, ListModel, CategoryModel, ClientsModel, HistoryModel, CheckinModel, UsersModel, SearchesModel, SelectModel, CategoryModel, FeaturedModel, CategoriesModel, CategoryModel, CategoriesModel, WorkflowsModel, GroupsModel, PositionsModel, LanguagesModel, TagModel, WarningsModel, TemplatesModel, SearchModel, DebuggroupModel, DebuguserModel, TemplatesModel, MediaModel, SelectModel, MenusModel, FeaturedModel, SuggestionsModel, et AdaptersModel.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ListModelInterface.php


Joomla CMS: Référence de l'interface ModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • ModelInterface
Fonctions membres publiques
Référence de l'interface ModelInterface
+ Graphe d'héritage de ModelInterface:
BaseModel BaseDatabaseModel AdapterModel AdaptersModel MediaModel MediumModel CapabilitiesModel BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

getName ()

Description détaillée

Interface for a base model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getName()

getName ( )

Method to get the model name.

Renvoie
string The name of the model
Depuis
4.0.0
Exceptions

Implémenté dans BaseModel.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ModelInterface.php


Joomla CMS: Référence de l'interface StatefulModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • StatefulModelInterface
Fonctions membres publiques
Référence de l'interface StatefulModelInterface
+ Graphe d'héritage de StatefulModelInterface:
BaseModel BaseDatabaseModel AdapterModel AdaptersModel MediaModel MediumModel CapabilitiesModel BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel

Fonctions membres publiques

getState ($property=null, $default=null)
setState ($property, $value=null)

Description détaillée

Interface for a stateful model.

Depuis
4.0.0

Documentation des fonctions membres

◆ getState()

getState | ( | $property = null,
 |  | $default = null
 | ) |

Method to get model state variables.

Paramètres
string | $property | Optional parameter name
mixed | $default | Optional default value
Renvoie
mixed The property where specified, the state object where omitted
Depuis
4.0.0

◆ setState()

setState | ( | $property,
 |  | $value = null
 | ) |

Method to set model state variables.

Paramètres
string | $property | The name of the property.
mixed | $value | The value of the property to set or null.
Renvoie
mixed The previous value of the property or null if not set.
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • StatefulModelInterface.php


Joomla CMS: Référence de l'interface WorkflowModelInterface

  • Joomla
  • CMS
  • MVC
  • Model
  • WorkflowModelInterface
Fonctions membres publiques
Référence de l'interface WorkflowModelInterface
+ Graphe d'héritage de WorkflowModelInterface:
ArticleModel FeatureModel FormModel

Fonctions membres publiques

setUpWorkflow ($extension)
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
getState ($property=null, $default=null)
getName ()
getTable ($name='', $prefix='', $options=array())

Description détaillée

Interface for a workflow model.

Depuis
4.0.0

Documentation des fonctions membres

◆ executeTransition()

executeTransition | ( | array | $pks,
 |  | int | $transitionId
 | ) |  |

Runs transition for item.

Paramètres
array | $pks | Id of items to execute the transition
integer | $transitionId | Id of transition
Renvoie
boolean
Depuis
4.0.0

◆ getName()

getName ( )

Method to get the model name

The model name. By default parsed using the classname or it can be set by passing a $config['name'] in the class constructor

Renvoie
string The name of the model
Depuis
4.0.0
Exceptions

◆ getState()

getState | ( | $property = null,
 |  | $default = null
 | ) |

Method to get state variables.

Paramètres
string | $property | Optional parameter name
mixed | $default | Optional default value
Renvoie
mixed The property where specified, the state object where omitted
Depuis
4.0.0

◆ getTable()

getTable | ( | $name = '',
 |  | $prefix = '',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.0
Exceptions

Implémenté dans FormModel, et FeatureModel.

◆ setUpWorkflow()

setUpWorkflow ( $extension )

Set Up the workflow

Paramètres
string $extension The option and section separated by.
Renvoie
void
Depuis
4.0.0

◆ workflowAfterSave()

workflowAfterSave ( $data )

Executing of relevant workflow methods

Renvoie
void
Depuis
4.0.0

◆ workflowBeforeSave()

workflowBeforeSave ( )

Preparation of workflow data/plugins

Renvoie
void
Depuis
4.0.0

◆ workflowBeforeStageChange()

workflowBeforeStageChange ( )

Let plugins access stage change events

Renvoie
void
Depuis
4.0.0

◆ workflowCleanupBatchMove()

workflowCleanupBatchMove | ( | $oldId,
 |  | $newId
 | ) |

Batch change workflow stage or current.

Paramètres
integer | $oldId | The ID of the item copied from
integer | $newId | The ID of the new item
Renvoie
null
Depuis
4.0.0

◆ workflowPreprocessForm()

workflowPreprocessForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
Renvoie
void
Voir également
FormField
Depuis
4.0.0
Exceptions
La documentation de cette interface a été générée à partir du fichier suivant :
  • WorkflowModelInterface.php


Joomla CMS: Référence de la classe OnGetApiFields

  • Joomla
  • CMS
  • MVC
  • View
  • Event
  • OnGetApiFields
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs privés
Référence de la classe OnGetApiFields
+ Graphe d'héritage de OnGetApiFields:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
addFields (array $fields)
addRelations (array $fields)
getAllPropertiesToRender ()
getAllRelationsToRender ()
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Champs de données

const | LIST = 'list'
const | ITEM = 'item'

Fonctions membres protégées

setType ($value)
setFields ($value)
setRelations ($value)

Attributs privés

$extraRelations = []
$extraAttributes = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event for getting extra API Fields and Relations to render with an entity

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: type string The type of the field. Should be a constant from static::VIEW_TYPE fields fields The list of fields that will be rendered in the API.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addFields()

addFields ( array $fields )

Allows the user to add names of properties that will be interpreted as relations Note that if there is an existing data property it will also be displayed as well as the relation due to the internal implementation (this behaviour is not part of this API however and should not be guaranteed)

Paramètres
string[] $fields The array of additional fields to add to the data of the attribute
Renvoie
void

Références $fields.

◆ addRelations()

addRelations ( array $fields )

Allows the user to add names of properties that will be interpreted as relations Note that if there is an existing data property it will also be displayed as well as the relation due to the internal implementation (this behaviour is not part of this API however and should not be guaranteed)

Paramètres
string[] $fields The array of additional fields to add as relations
Renvoie
void

Références $fields.

◆ getAllPropertiesToRender()

getAllPropertiesToRender ( )

Get properties to render.

Renvoie
array

◆ getAllRelationsToRender()

getAllRelationsToRender ( )

Get properties to render.

Renvoie
array

◆ setFields()

setFields ( $value )
protected

Setter for the fields argument

Paramètres
mixed $value The value to set
Renvoie
array
Exceptions
BadMethodCallException if the argument is not a non-empty array

Références $value.

◆ setRelations()

setRelations ( $value )
protected

Setter for the relations argument

Paramètres
mixed $value The value to set
Renvoie
array
Exceptions
BadMethodCallException if the argument is not a non-empty array

Références $value.

◆ setType()

setType ( $value )
protected

Setter for the type argument

Paramètres
integer $value The constant from VIEW_TYPE
Renvoie
mixed
Exceptions
BadMethodCallException if the argument is not of the expected type

Références $value.

Documentation des champs

◆ $extraAttributes

$extraAttributes = []
private

◆ $extraRelations

$extraRelations = []
private

◆ ITEM

const ITEM = 'item'

List of types of view supported

Depuis
4.0.0

◆ LIST

const LIST = 'list'

List of types of view supported

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • OnGetApiFields.php


Joomla CMS: Référence de la classe AbstractView

  • Joomla
  • CMS
  • MVC
  • View
  • AbstractView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractView
+ Graphe d'héritage de AbstractView:
CMSObject ViewInterface DispatcherAwareInterface HtmlView JsonView JsonView TextView VcfView FeedView OpensearchView XmlView

Fonctions membres publiques

__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$document

Fonctions membres protégées

dispatchEvent (EventInterface $event)

Attributs protégés

$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Base class for a Joomla View

Class holding methods for displaying presentation data.

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor

Paramètres
array $config A named configuration array for object construction. name: the name (optional) of the view (defaults to the view class name suffix). charset: the character set to use for display escape: the name (optional) of the function to use for escaping strings base_path: the parent path (optional) of the views directory (defaults to the component folder) template_plath: the path (optional) of the layout directory (defaults to base_path + /views/ + view name helper_path: the path (optional) of the helper files (defaults to base_path + /helpers/) layout: the layout (optional) to use to display the view
Depuis
3.0

Références $config.

Documentation des fonctions membres

◆ dispatchEvent()

dispatchEvent ( EventInterface $event )
protected

Dispatches the given event on the internal dispatcher, does a fallback to the global one.

Paramètres
EventInterface $event The event
Renvoie
void
Depuis
4.1.0

Références class, Factory\getContainer(), Joomla\CMS\Application\getDispatcher(), et EventInterface\getName().

◆ display()

display ( $tpl = null )
abstract

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.0

Implémente ViewInterface.

◆ get()

get | ( | $property,
 |  | $default = null
 | ) |

Method to get data from a registered model or a property of the view

Paramètres
string | $property | The name of the method to call on the model or the property to get
string | $default | The name of the model to reference or the default value [optional]
Renvoie
mixed The return value of the method
Depuis
3.0

Références $default, $method, $model, Symfony\Contracts\Service\get(), et null.

◆ getModel()

getModel ( $name = null )

Method to get the model object

Paramètres
string $name The name of the model (optional)
Renvoie
BaseDatabaseModel The model object
Depuis
3.0

Implémente ViewInterface.

Références $name, et null.

◆ getName()

getName ( )

Method to get the view name

The model name by default parsed using the classname, or it can be set by passing a $config['name'] in the class constructor

Renvoie
string The name of the model
Depuis
3.0
Exceptions

Références $className, $this, et Text\sprintf().

◆ setModel()

setModel | ( | $model,
 |  | $default = false
 | ) |

Method to add a model to the view. We support a multiple model single view system by which models are referenced by classname. A caveat to the classname referencing is that any classname prepended by will be referenced by the name without , eg. is just Category.

Paramètres
BaseDatabaseModel | $model | The model to add to the view.
boolean | $default | Is this the default model?
Renvoie
BaseDatabaseModel The added model.
Depuis
3.0

Références $default, $model, et $name.

Documentation des champs

◆ $_defaultModel

$_defaultModel = null
protected

◆ $_models

$_models = array()
protected

◆ $_name

$_name = null
protected

◆ $document

$document

◆ $option

$option = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractView.php


Joomla CMS: Référence de la classe CategoriesView

  • Joomla
  • CMS
  • MVC
  • View
  • CategoriesView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoriesView
+ Graphe d'héritage de CategoriesView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView HtmlView HtmlView

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$pageHeading
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Categories view base class.

Depuis
3.2

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void|boolean
Depuis
3.2
Exceptions

Implémente ViewInterface.

Références $app, $items, $params, $state, Text\_(), ENT_COMPAT, Factory\getApplication(), items, maxLevelcat, et parent.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
3.2

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $items

$items
protected

◆ $pageHeading

$pageHeading
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoriesView.php


Joomla CMS: Référence de la classe CategoryFeedView

  • Joomla
  • CMS
  • MVC
  • View
  • CategoryFeedView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe CategoryFeedView
+ Graphe d'héritage de CategoryFeedView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface FeedView FeedView

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

reconcileNames ($item)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Base feed View class for a category

Depuis
3.2

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.2
Exceptions

Implémente ViewInterface.

Références $app, $author, $category, $date, $description, $document, $extension, $item, $items, $language, $link, $title, Text\_(), Route\_(), elseif, ENT_COMPAT, Factory\getApplication(), RouteHelper\getCategoryRoute(), Factory\getDocument(), et null.

◆ reconcileNames()

reconcileNames ( $item )
protected

Method to reconcile non standard names from components to usage in this class. Typically overridden in the component feed view class.

Paramètres
object $item The item for a feed, an element of the $items array.
Renvoie
void
Depuis
3.2

Références $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryFeedView.php


Joomla CMS: Référence de la classe CategoryView

  • Joomla
  • CMS
  • MVC
  • View
  • CategoryView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryView
+ Graphe d'héritage de CategoryView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView HtmlView HtmlView

Fonctions membres publiques

commonCategoryDisplay ()
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
addFeed ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$category
$categories
$pagination
$children
$extension
$viewName
$defaultPageTitle
$runPlugins = false
$menuItemMatchCategory = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Base HTML View class for the a Category list

Depuis
3.2

Documentation des fonctions membres

◆ addFeed()

addFeed ( )
protected

Method to add an alternative feed link to a category layout.

Renvoie
void
Depuis
3.2

Références $attribs, $link, et Route\_().

◆ commonCategoryDisplay()

commonCategoryDisplay ( )

Method with common display elements used in category list displays

Renvoie
void
Depuis
3.2

Références $active, $app, $category, $cparams, $groups, $items, $layout, $model, $params, $results, $state, $this, $user, Text\_(), category, children, elseif, extension, Factory\getApplication(), Factory\getUser(), PluginHelper\importPlugin(), items, maxLevel, et parent.

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.2
Exceptions

Implémente ViewInterface.

◆ prepareDocument()

prepareDocument ( )
protected

Method to prepares the document

Renvoie
void
Depuis
3.2

Références $app, $this, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $categories

$categories
protected

◆ $category

$category
protected

◆ $children

$children
protected

◆ $defaultPageTitle

$defaultPageTitle
protected

◆ $extension

$extension
protected

◆ $items

$items
protected

◆ $menuItemMatchCategory

$menuItemMatchCategory = false
protected

◆ $pagination

$pagination
protected

◆ $runPlugins

$runPlugins = false
protected

◆ $state

$state
protected

◆ $viewName

$viewName
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryView.php


Joomla CMS: Référence de la classe FormView

  • Joomla
  • CMS
  • MVC
  • View
  • FormView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FormView
+ Graphe d'héritage de FormView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (array $config)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

initializeView ()
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
$toolbarTitle
$toolbarIcon
$previewLink
$helpLink
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Base class for a Joomla Form View

Class holding methods for displaying presentation data.

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $config )

Constructor

Paramètres
array $config An optional associative array of configuration settings.

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $user, $userId, Text\_(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), Factory\getUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), ToolbarHelper\preview(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions

Implémente ViewInterface.

◆ initializeView()

initializeView ( )
protected

Prepare view data

Renvoie
void

Références Text\_().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $helpLink

$helpLink
protected

◆ $item

$item
protected

◆ $previewLink

$previewLink
protected

◆ $state

$state
protected

◆ $toolbarIcon

$toolbarIcon
protected

◆ $toolbarTitle

$toolbarTitle
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FormView.php


Joomla CMS: Référence de la classe GenericDataException

  • Joomla
  • CMS
  • MVC
  • View
  • GenericDataException
Référence de la classe GenericDataException
+ Graphe d'héritage de GenericDataException:

Description détaillée

Exception class defining an error getting data from a model into a view

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • GenericDataException.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • CMS
  • MVC
  • View
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface DefaultView CategoriesView CategoryFeedView CategoryView FormView ListView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView RawView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView FeedView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView XmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView FeedView HtmlView FeedView HtmlView HtmlView JsonView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView

Fonctions membres publiques

__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Base class for a Joomla Html View

Class holding methods for displaying presentation data.

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor

Paramètres
array $config A named configuration array for object construction. name: the name (optional) of the view (defaults to the view class name suffix). charset: the character set to use for display escape: the name (optional) of the function to use for escaping strings base_path: the parent path (optional) of the views directory (defaults to the component folder) template_plath: the path (optional) of the layout directory (defaults to base_path + /views/ + view name helper_path: the path (optional) of the helper files (defaults to base_path + /helpers/) layout: the layout (optional) to use to display the view
Depuis
3.0

Références $config, Symfony\Contracts\Service\__construct(), Uri\base(), et elseif.

Documentation des fonctions membres

◆ _addPath()

_addPath | ( | $type,
 |  | $path
 | ) |
protected

Adds to the search path for templates and resources.

Paramètres
string | $type | The type of path to add.
mixed | $path | The directory or stream, or an array of either, to search.
Renvoie
void
Depuis
3.0

Références $dir, $path, $type, et Path\clean().

◆ _createFileName()

_createFileName | ( | $type,
 |  | $parts = array()
 | ) |
protected

Create the filename for a resource

Paramètres
string | $type | The resource type to create the filename for
array | $parts | An associative array of filename information
Renvoie
string The filename
Depuis
3.0

Références $parts, et $type.

◆ _setPath()

_setPath | ( | $type,
 |  | $path
 | ) |
protected

Sets an entire array of search paths for templates or resources.

Paramètres
string | $type | The type of path to set, typically 'template'.
mixed | $path | The new search path, or an array of search paths. If null or false, resets to the current directory only.
Renvoie
void
Depuis
3.0

Références $app, $component, $name, $option, $path, $template, $type, Factory\getApplication(), ApplicationHelper\getComponentName(), et JPATH_THEMES.

◆ addHelperPath()

addHelperPath ( $path )

Adds to the stack of helper script paths in LIFO order.

Paramètres
mixed $path A directory path or an array of paths.
Renvoie
void
Depuis
3.0

Références $path.

◆ addTemplatePath()

addTemplatePath ( $path )

Adds to the stack of view script paths in LIFO order.

Paramètres
mixed $path A directory path or an array of paths.
Renvoie
void
Depuis
3.0

Références $path.

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions

Implémente ViewInterface.

Références $app, $component, $context, $option, $result, $this, AbstractEvent\create(), Factory\getApplication(), et ApplicationHelper\getComponentName().

◆ escape()

escape ( $var )

Escapes a value for output in a view script.

If escaping mechanism is htmlspecialchars, use $_charset setting.

Paramètres
mixed $var The output to escape.
Renvoie
mixed The escaped value.
Note
the ENT_COMPAT flag was replaced by ENT_QUOTES in Joomla 4.0 to also escape single quotes
Depuis
3.0

Références ENT_QUOTES, et null.

◆ getForm()

getForm ( )

Returns the form object

Renvoie
mixed A object on success, false on failure
Depuis
3.2

Références $form.

◆ getLayout()

getLayout ( )

Get the layout.

Renvoie
string The layout name
Depuis
3.0

◆ getLayoutTemplate()

getLayoutTemplate ( )

Get the layout template.

Renvoie
string The layout template name
Depuis
3.0

◆ loadHelper()

loadHelper ( $hlp = null )

Load a helper file

Paramètres
string $hlp The name of the helper source file automatically searches the helper paths and compiles as needed.
Renvoie
void
Depuis
3.0

Références $helper, et Path\find().

◆ loadTemplate()

loadTemplate ( $tpl = null )

Load a template file – first look in the templates folder for an override

Paramètres
string $tpl The name of the template source file; automatically searches the template paths and compiles as needed.
Renvoie
string The output of the the template script.
Depuis
3.0
Exceptions

Références $lang, $layout, $template, $this, Path\find(), Factory\getApplication(), Factory\getLanguage(), JPATH_BASE, JPATH_THEMES, null, et Text\sprintf().

◆ setDocumentTitle()

setDocumentTitle ( $title )

Sets the document title according to Global Configuration options

Paramètres
string $title The page title
Renvoie
void
Depuis
3.6

Références $app, $title, elseif, Factory\getApplication(), et Text\sprintf().

◆ setLayout()

setLayout ( $layout )

Sets the layout name to use

Paramètres
string $layout The layout name or a string in format <template>:<layout file>="">
Renvoie
string Previous value.
Depuis
3.0

Références $layout, et $temp.

◆ setLayoutExt()

setLayoutExt ( $value )

Allows a different extension for the layout files to be used

Paramètres
string $value The extension.
Renvoie
string Previous value
Depuis
3.0

Références $value.

Documentation des champs

◆ $_basePath

$_basePath = null
protected

◆ $_charset

$_charset = 'UTF-8'
protected

◆ $_layout

$_layout = 'default'
protected

◆ $_layoutExt

$_layoutExt = 'php'
protected

◆ $_layoutTemplate

$_layoutTemplate = '_'
protected

◆ $_output

$_output = null
protected

◆ $_path

$_path = array('template' => array(), 'helper' => array())
protected

◆ $_template

$_template = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/MVC/View/HtmlView.php


Joomla CMS: Référence de la classe JsonApiView

  • Joomla
  • CMS
  • MVC
  • View
  • JsonApiView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonApiView
+ Graphe d'héritage de JsonApiView:
JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView

Fonctions membres publiques

__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$document
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Base class for a Joomla Json List View

Class holding methods for displaying presentation data.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config A named configuration array for object construction. contentType: the name (optional) of the content type to use for the serialization
Depuis
4.0.0

Références $config, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

◆ queryEncode()

queryEncode ( $query )
protected

Encode square brackets in the URI query, according to JSON API specification.

Paramètres
string $query The URI query
Renvoie
string
Depuis
4.0.0

Références $query.

Documentation des champs

◆ $document

$document

◆ $fieldsToRenderItem

$fieldsToRenderItem = []
protected

◆ $fieldsToRenderList

$fieldsToRenderList = []
protected

◆ $relationship

$relationship = []
protected

◆ $serializer

$serializer
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonApiView.php


Joomla CMS: Référence de la classe JsonView

  • Joomla
  • CMS
  • MVC
  • View
  • JsonView
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonView
+ Graphe d'héritage de JsonView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface JsonApiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView JsonapiView

Fonctions membres publiques

__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Base class for a Joomla Json View

Class holding methods for displaying presentation data.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor

Paramètres
array $config A named configuration array for object construction. name: the name (optional) of the view (defaults to the view class name suffix). charset: the character set to use for display escape: the name (optional) of the function to use for escaping strings base_path: the parent path (optional) of the views directory (defaults to the component folder) template_plath: the path (optional) of the layout directory (defaults to base_path + /views/ + view name helper_path: the path (optional) of the helper files (defaults to base_path + /helpers/) layout: the layout (optional) to use to display the view
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $result.

Documentation des champs

◆ $_basePath

$_basePath = null
protected

◆ $_charset

$_charset = 'UTF-8'
protected

◆ $_output

$_output = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/MVC/View/JsonView.php


Joomla CMS: Référence de la classe ListView

  • Joomla
  • CMS
  • MVC
  • View
  • ListView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ListView
+ Graphe d'héritage de ListView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (array $config)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

initializeView ()
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$canDo
$sidebar
$toolbarTitle
$toolbarIcon
$supportsBatch = true
$helpLink
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Base class for a Joomla List View

Class holding methods for displaying presentation data.

Depuis
2.5.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $config )

Constructor

Paramètres
array $config An optional associative array of configuration settings.

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $layout, $this, $title, $user, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\archiveList(), ToolbarHelper\checkin(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\editList(), elseif, Inflector\getInstance(), Toolbar\getInstance(), Factory\getUser(), ToolbarHelper\help(), items, ToolbarHelper\preferences(), ToolbarHelper\publish(), ToolbarHelper\title(), ToolbarHelper\trash(), et ToolbarHelper\unpublish().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions

Implémente ViewInterface.

◆ initializeView()

initializeView ( )
protected

Prepare view data

Renvoie
void

Références items, et JLoader\register().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $canDo

$canDo
protected

◆ $filterForm

$filterForm

◆ $helpLink

$helpLink
protected

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $sidebar

$sidebar
protected

◆ $state

$state
protected

◆ $supportsBatch

$supportsBatch = true
protected

◆ $toolbarIcon

$toolbarIcon
protected

◆ $toolbarTitle

$toolbarTitle
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ListView.php


Joomla CMS: Référence de l'interface ViewInterface

  • Joomla
  • CMS
  • MVC
  • View
  • ViewInterface
Fonctions membres publiques
Référence de l'interface ViewInterface
+ Graphe d'héritage de ViewInterface:
AbstractView HtmlView JsonView JsonView TextView VcfView FeedView OpensearchView XmlView

Fonctions membres publiques

display ($tpl=null)
getModel ($name=null)

Description détaillée

Joomla Platform CMS Interface

Depuis
4.0.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémenté dans CategoryView, HtmlView, HtmlView, ListView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, FormView, AbstractView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, JsonView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, CategoriesView, HtmlView, HtmlView, HtmlView, JsonView, HtmlView, HtmlView, XmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, HtmlView, VcfView, DefaultView, JsonView, TextView, HtmlView, FeedView, OpensearchView, CategoryFeedView, HtmlView, FeedView, HtmlView, FeedView, HtmlView, HtmlView, et FeedView.

◆ getModel()

getModel ( $name = null )

Method to get the model object

Paramètres
string $name The name of the model (optional)
Renvoie
BaseDatabaseModel The model object
Depuis
3.0

Implémenté dans AbstractView.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ViewInterface.php


Joomla CMS: Référence de la classe CMSObject

  • Joomla
  • CMS
  • Object
  • CMSObject
Fonctions membres publiques | Attributs protégés
Référence de la classe CMSObject
+ Graphe d'héritage de CMSObject:
Adapter AdapterInstance CategoryNode Changelog Stream InstallerExtension BaseModel AbstractView Table Update User

Fonctions membres publiques

__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Attributs protégés

$_errors = array()

Description détaillée

Joomla Platform Object Class

This class allows for simple but smart objects with get and set methods and an internal error handler.

Depuis
1.7.0
Obsolète:
4.0.0 Use or instead.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $properties = null )

Class constructor, overridden in descendant classes.

Paramètres
mixed $properties Either and associative array or another object to set the initial properties of the object.
Depuis
1.7.0

Références null.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic method to convert the object to a string gracefully.

Renvoie
string The classname.
Depuis
1.7.0
Obsolète:
3.1.4 Classes should provide their own __toString() implementation.

Références $this.

◆ def()

def | ( | $property,
 |  | $default = null
 | ) |

Sets a default value if not already assigned

Paramètres
string | $property | The name of the property.
mixed | $default | The default value.
Renvoie
mixed
Depuis
1.7.0

Références $default, et $value.

◆ get()

get | ( | $property,
 |  | $default = null
 | ) |

Returns a property of the object or the default value if the property is not set.

Paramètres
string | $property | The name of the property.
mixed | $default | The default value.
Renvoie
mixed The value of the property.
Depuis
1.7.0
Voir également
CMSObject::getProperties()

Références $default.

Référencé par MediaHelper\getContentTypeLink().

◆ getError()

getError | ( | $i = null,
 |  | $toString = true
 | ) |

Get the most recent error message.

Paramètres
integer | $i | Option error index.
boolean | $toString | Indicates if Exception objects should return their error message.
Renvoie
string Error message
Depuis
1.7.0
Obsolète:
3.1.4 JError has been deprecated

Références $i, elseif, et null.

Référencé par User\delete(), et User\save().

◆ getErrors()

getErrors ( )

Return all errors, if any.

Renvoie
array Array of error messages.
Depuis
1.7.0
Obsolète:
3.1.4 JError has been deprecated

◆ getProperties()

getProperties ( $public = true )

Returns an associative array of object properties.

Paramètres
boolean $public If true, returns only the public properties.
Renvoie
array
Depuis
1.7.0
Voir également
CMSObject::get()

Références $key, $this, et $value.

Référencé par User\delete(), et User\save().

◆ set()

set | ( | $property,
 |  | $value = null
 | ) |

Modifies a property of the object, creating it if it does not already exist.

Paramètres
string | $property | The name of the property.
mixed | $value | The value of the property to set.
Renvoie
mixed Previous value of the property.
Depuis
1.7.0

Références $value, et null.

◆ setError()

setError ( $error )

Add an error message.

Paramètres
string $error Error message.
Renvoie
void
Depuis
1.7.0
Obsolète:
3.1.4 JError has been deprecated

Référencé par User\bind(), User\delete(), et User\save().

◆ setProperties()

setProperties ( $properties )

Set the object properties based on a named array/hash.

Paramètres
mixed $properties Either an associative array or another object.
Renvoie
boolean
Depuis
1.7.0
Voir également
CMSObject::set()

Référencé par User\bind(), et User\load().

Documentation des champs

◆ $_errors

$_errors = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CMSObject.php


Joomla CMS: Référence de la classe Pagination

  • Joomla
  • CMS
  • Pagination
  • Pagination
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe Pagination

Fonctions membres publiques

__construct ($total, $limitstart, $limit, $prefix='', CMSApplication $app=null)
setAdditionalUrlParam ($key, $value)
getAdditionalUrlParam ($key)
getRowOffset ($index)
getData ()
getPagesCounter ()
getResultsCounter ()
getPagesLinks ()
getPaginationLinks ($layoutId='joomla.pagination.links', $options=array())
getPaginationPages ()
getListFooter ()
getLimitBox ()
orderUpIcon ($i, $condition=true, $task='orderup', $alt='JLIB_HTML_MOVE_UP', $enabled=true, $checkbox='cb')
orderDownIcon ($i, $n, $condition=true, $task='orderdown', $alt='JLIB_HTML_MOVE_DOWN', $enabled=true, $checkbox='cb')

Champs de données

$limitstart = null
$limit = null
$total = null
$prefix = null
$pagesStart
$pagesStop
$pagesCurrent
$pagesTotal
$hideEmptyLimitstart = false

Fonctions membres protégées

_list_footer ($list)
_list_render ($list)
_item_active (PaginationObject $item)
_item_inactive (PaginationObject $item)
_buildDataObject ()

Attributs protégés

$viewall = false
$additionalUrlParams = array()
$app = null
$data

Description détaillée

Pagination Class. Provides a common interface for content pagination for the Joomla! CMS.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $total,
 |  |  | $limitstart,
 |  |  | $limit,
 |  |  | $prefix = '',
 |  | CMSApplication | $app = null
 | ) |  |

Constructor.

Paramètres
integer | $total | The total number of items.
integer | $limitstart | The offset of the item to start at.
integer | $limit | The number of items to display per page.
string | $prefix | The prefix used for request variables.
CMSApplication | $app | The application object
Depuis
1.5

Références $app, $limit, $prefix, $total, Factory\getApplication(), Joomla\Database\Query\limit(), et limitstart.

Documentation des fonctions membres

◆ _buildDataObject()

_buildDataObject ( )
protected

Create and return the pagination data object.

Renvoie
Pagination data object.
Depuis
1.5

Références $data, $i, $key, $limit, Joomla\Database\Query\$offset, $params, $value, Text\_(), Route\_(), et Joomla\Database\Query\limit().

◆ _item_active()

_item_active ( PaginationObject $item )
protected

Method to create an active pagination link to the item

Paramètres
PaginationObject $item The object with which to make an active link.
Renvoie
string HTML link
Depuis
1.5

Références $item, et LayoutHelper\render().

◆ _item_inactive()

_item_inactive ( PaginationObject $item )
protected

Method to create an inactive pagination string

Paramètres
PaginationObject $item The item to be processed
Renvoie
string
Depuis
1.5

Références $item, et LayoutHelper\render().

◆ _list_footer()

_list_footer ( $list )
protected

Create the HTML for a list footer

Paramètres
array $list Pagination list data structure.
Renvoie
string HTML for a list footer
Depuis
1.5

Références $html, $list, et Text\_().

◆ _list_render()

_list_render ( $list )
protected

Create the html for a list footer

Paramètres
array $list Pagination list data structure.
Renvoie
string HTML for a list start, previous, next,end
Depuis
1.5

Références $list, et LayoutHelper\render().

◆ getAdditionalUrlParam()

getAdditionalUrlParam ( $key )

Method to get an additional URL parameter (if it exists) to be added to all pagination class generated links.

Paramètres
string $key The name of the URL parameter for which to get the value.
Renvoie
mixed The value if it exists or null if it does not.
Depuis
1.6

Références $key, et null.

◆ getData()

getData ( )

Return the pagination data object, only creating it if it doesn't already exist.

Renvoie
Pagination data object.
Depuis
1.5

Références $data.

◆ getLimitBox()

getLimitBox ( )

Creates a dropdown box for selecting how many records to show per page.

Renvoie
string The HTML for the limit # input box.
Depuis
1.5

Références $html, $i, $limit, $selected, Text\_(), et HTMLHelper\_().

◆ getListFooter()

getListFooter ( )

Return the pagination footer.

Renvoie
string Pagination footer.
Depuis
1.5

Références $list, JPATH_THEMES, Joomla\Database\Query\limit(), et limitstart.

◆ getPagesCounter()

getPagesCounter ( )

Create and return the pagination pages counter string, ie. Page 2 of 4.

Renvoie
string Pagination pages counter string.
Depuis
1.5

Références $html, null, et Text\sprintf().

◆ getPagesLinks()

getPagesLinks ( )

Create and return the pagination page list string, ie. Previous, Next, 1 2 3 ... x.

Renvoie
string Pagination page list string.
Depuis
1.5

Références $data, $i, $list, $prefix, JPATH_THEMES, Joomla\Database\Query\limit(), et null.

◆ getPaginationLinks()

getPaginationLinks | ( | $layoutId = 'joomla.pagination.links',
 |  | $options = array()
 | ) |

Get the pagination links

Paramètres
string | $layoutId | Layout to render the links
array | $options | Optional array with settings for the layout
Renvoie
string Pagination links.
Depuis
3.3

Références $list, $options, Joomla\Database\Query\limit(), limitstart, et LayoutHelper\render().

◆ getPaginationPages()

getPaginationPages ( )

Create and return the pagination pages list, ie. Previous, Next, 1 2 3 ... x.

Renvoie
array Pagination pages list.
Depuis
3.3

Références $data, $i, $list, Joomla\Database\Query\limit(), et null.

◆ getResultsCounter()

getResultsCounter ( )

Create and return the pagination result set counter string, e.g. Results 1-10 of 42

Renvoie
string Pagination result set counter string.
Depuis
1.5

Références $html, $limit, $total, Text\_(), limitstart, null, et Text\sprintf().

◆ getRowOffset()

getRowOffset ( $index )

Return the rationalised offset for a row with a given index.

Paramètres
integer $index The row index
Renvoie
integer Rationalised offset for a row with a given index.
Depuis
1.5

◆ orderDownIcon()

orderDownIcon | ( | $i,
 |  | $n,
 |  | $condition = true,
 |  | $task = 'orderdown',
 |  | $alt = 'JLIB_HTML_MOVE_DOWN',
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Return the icon to move an item DOWN.

Paramètres
integer | $i | The row index.
integer | $n | The number of items in the list.
boolean | $condition | True to show the icon.
string | $task | The task to fire.
string | $alt | The image alternative text string.
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string Either the icon to move an item down or a space.
Depuis
1.5

Références $alt, $enabled, $i, $task, et HTMLHelper\_().

◆ orderUpIcon()

orderUpIcon | ( | $i,
 |  | $condition = true,
 |  | $task = 'orderup',
 |  | $alt = 'JLIB_HTML_MOVE_UP',
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Return the icon to move an item UP.

Paramètres
integer | $i | The row index.
boolean | $condition | True to show the icon.
string | $task | The task to fire.
string | $alt | The image alternative text string.
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string Either the icon to move an item up or a space.
Depuis
1.5

Références $alt, $enabled, $i, $task, HTMLHelper\_(), et limitstart.

◆ setAdditionalUrlParam()

setAdditionalUrlParam | ( | $key,
 |  | $value
 | ) |

Method to set an additional URL parameter to be added to all pagination class generated links.

Paramètres
string | $key | The name of the URL parameter for which to set a value.
mixed | $value | The value to set for the URL parameter.
Renvoie
mixed The old value for the parameter.
Depuis
1.6

Références $key, $result, $value, et null.

Documentation des champs

◆ $additionalUrlParams

$additionalUrlParams = array()
protected

◆ $app

$app = null
protected

◆ $data

$data
protected

◆ $hideEmptyLimitstart

$hideEmptyLimitstart = false

◆ $limit

$limit = null

◆ $limitstart

$limitstart = null

◆ $pagesCurrent

$pagesCurrent

◆ $pagesStart

$pagesStart

◆ $pagesStop

$pagesStop

◆ $pagesTotal

$pagesTotal

◆ $prefix

$prefix = null

◆ $total

$total = null

◆ $viewall

$viewall = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Pagination.php


Joomla CMS: Référence de la classe PaginationObject

  • Joomla
  • CMS
  • Pagination
  • PaginationObject
Fonctions membres publiques | Champs de données
Référence de la classe PaginationObject

Fonctions membres publiques

__construct ($text, $prefix='', $base=null, $link=null, $active=false)

Champs de données

$text
$base
$link
$prefix
$active

Description détaillée

Pagination object representing a particular item in the pagination lists.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $text,
 |  | $prefix = '',
 |  | $base = null,
 |  | $link = null,
 |  | $active = false
 | ) |

Class constructor.

Paramètres
string | $text | The link text.
string | $prefix | The prefix used for request variables.
integer | $base | The number of rows as a base offset.
string | $link | The link URL.
boolean | $active | Flag whether the object is the 'active' page
Depuis
1.5

Références $active, $base, $link, $prefix, $text, et text.

Documentation des champs

◆ $active

$active

◆ $base

$base

◆ $link

$link

◆ $prefix

$prefix

◆ $text

$text
La documentation de cette classe a été générée à partir du fichier suivant :
  • PaginationObject.php


Joomla CMS: Référence de la classe Pathway

  • Joomla
  • CMS
  • Pathway
  • Pathway
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Pathway
+ Graphe d'héritage de Pathway:
SitePathway

Fonctions membres publiques

getPathway ()
setPathway ($pathway)
getPathwayNames ()
addItem ($name, $link='')
setItemName ($id, $name)

Fonctions membres publiques statiques

static getInstance ($client)

Fonctions membres protégées

makeItem ($name, $link)

Attributs protégés

$pathway = array()
$count = 0

Attributs protégés statiques

static $instances = array()

Description détaillée

Class to maintain a pathway.

The user's navigated path within the application.

Depuis
1.5

Documentation des fonctions membres

◆ addItem()

addItem | ( | $name,
 |  | $link = ''
 | ) |

Create and add an item to the pathway.

Paramètres
string | $name | The name of the item.
string | $link | The link to the item.
Renvoie
boolean True on success
Depuis
1.5

Références $link, et $name.

◆ getInstance()

static getInstance ( $client )
static

Returns a Pathway object

Paramètres
string $client The name of the client
Renvoie
Pathway A Pathway object.
Depuis
1.5
Exceptions

Références $client, $name, Factory\getContainer(), Symfony\Contracts\Service\has(), et Text\sprintf().

◆ getPathway()

getPathway ( )

Return the Pathway items array

Renvoie
array Array of pathway items
Depuis
1.5

◆ getPathwayNames()

getPathwayNames ( )

Create and return an array of the pathway names.

Renvoie
array Array of names of pathway items
Depuis
1.5

Références $item, et $names.

◆ makeItem()

makeItem | ( | $name,
 |  | $link
 | ) |
protected

Create and return a new pathway object.

Paramètres
string | $name | Name of the item
string | $link | Link to the item
Renvoie
Pathway item object
Depuis
3.1

Références $item, $link, $name, et ENT_COMPAT.

◆ setItemName()

setItemName | ( | $id,
 |  | $name
 | ) |

Set item name.

Paramètres
integer | $id | The id of the item on which to set the name.
string | $name | The name to set.
Renvoie
boolean True on success
Depuis
1.5

Références $id, et $name.

◆ setPathway()

setPathway ( $pathway )

Set the Pathway items array.

Paramètres
array $pathway An array of pathway objects.
Renvoie
array The previous pathway data.
Depuis
1.5

Documentation des champs

◆ $count

$count = 0
protected

◆ $instances

$instances = array()
staticprotected

◆ $pathway

$pathway = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Pathway/Pathway.php


Joomla CMS: Référence de la classe SitePathway

  • Joomla
  • CMS
  • Pathway
  • SitePathway
Fonctions membres publiques
Référence de la classe SitePathway
+ Graphe d'héritage de SitePathway:
Pathway

Fonctions membres publiques

__construct (SiteApplication $app=null)
- Fonctions membres publiques hérités de Pathway
getPathway ()
setPathway ($pathway)
getPathwayNames ()
addItem ($name, $link='')
setItemName ($id, $name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Pathway
static | getInstance ($client)
- Fonctions membres protégées hérités de Pathway
makeItem ($name, $link)
- Attributs protégés hérités de Pathway
$pathway = array()
$count = 0
- Attributs protégés statiques hérités de Pathway
static | $instances = array()

Description détaillée

Class to manage the site application pathway.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( SiteApplication $app = null )

Class constructor.

Paramètres
SiteApplication $app Application Object
Depuis
1.5

Références $app, $item, $lang, $link, $menu, $url, class, Factory\getContainer(), Factory\getLanguage(), Multilanguage\isEnabled(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SitePathway.php


Joomla CMS: Référence de la classe CMSPlugin

  • Joomla
  • CMS
  • Plugin
  • CMSPlugin
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe CMSPlugin
+ Graphe d'héritage de CMSPlugin:
DispatcherAwareInterface PluginInterface DispatcherAwareInterface DummyPlugin ActionLogPlugin FieldsPlugin Adapter MediaActionPlugin PrivacyPlugin Basic Token Taggable Versionable Email Fixed Totp Webauthn Yubikey Joomlaupdate Cache Shortcut Webauthn Checkfiles DemoTasks Requests SiteStatus PlgAuthenticationCookie PlgAuthenticationJoomla PlgAuthenticationLdap PlgButtonArticle PlgButtonContact PlgButtonFields PlgButtonImage PlgButtonMenu PlgButtonModule PlgButtonPagebreak PlgButtonReadmore PlgCaptchaRecaptcha PlgCaptchaRecaptcha_Invisible PlgContentConfirmConsent PlgContentContact PlgContentEmailcloak PlgContentFields PlgContentFinder PlgContentJoomla PlgContentLoadmodule PlgContentPagebreak PlgContentPagenavigation PlgContentVote PlgEditorCodemirror PlgEditorNone PlgEditorTinymce PlgExtensionFinder PlgExtensionJoomla PlgExtensionNamespacemap PlgFileSystemLocal PlgInstallerFolderInstaller PlgInstallerOverride PlgInstallerPackageInstaller PlgInstallerUrlInstaller PlgInstallerWebinstaller PlgQuickiconDownloadkey PlgQuickiconExtensionupdate PlgQuickiconOverrideCheck PlgQuickiconPhpVersionCheck PlgQuickiconPrivacyCheck PlgSampledataBlog PlgSampledataMultilang PlgSystemAccessibility PlgSystemActionLogs PlgSystemDebug PlgSystemFields PlgSystemHighlight PlgSystemHttpHeaders PlgSystemJooa11y PlgSystemLanguagecode PlgSystemLanguageFilter PlgSystemLog PlgSystemLogout PlgSystemLogrotation PlgSystemPrivacyconsent PlgSystemRedirect PlgSystemRemember PlgSystemSchedulerunner PlgSystemSef PlgSystemSessionGc PlgSystemSkipto PlgSystemStats PlgSystemTasknotification PlgSystemUpdatenotification PlgUserContactCreator PlgUserJoomla PlgUserProfile PlgUserTerms PlgUserToken PlgWebservicesBanners PlgWebservicesConfig PlgWebservicesContact PlgWebservicesContent PlgWebservicesInstaller PlgWebservicesLanguages PlgWebservicesMedia PlgWebservicesMenus PlgWebservicesMessages PlgWebservicesModules PlgWebservicesNewsfeeds PlgWebservicesPlugins PlgWebservicesPrivacy PlgWebservicesRedirect PlgWebservicesTags PlgWebservicesTemplates PlgWebservicesUsers PlgWorkflowFeaturing PlgWorkflowNotification PlgWorkflowPublishing

Fonctions membres publiques

__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Champs de données

$params = null

Fonctions membres protégées

registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

parameterImplementsEventInterface (\ReflectionParameter $parameter)

Attributs privés

$application

Description détaillée

Plugin Class

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config = array()
 | ) |  |

Constructor

Paramètres
DispatcherInterface | &$subject | The object to observe
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'group', 'params', 'language' (this list is not meant to be comprehensive).
Depuis
1.5

Références $config, $subject, $this, Factory\getApplication(), Factory\getDbo(), et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ getApplication()

getApplication ( )
protected

Returns the internal application or null when not set.

Renvoie
CMSApplicationInterface|null
Depuis
4.2.0

Référencé par Joomla\getActionLogParams(), Joomla\onAfterDispatch(), Joomla\onAfterLogExport(), Joomla\onAfterLogPurge(), Joomla\onAfterPurge(), Joomla\onApplicationAfterSave(), Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), Joomla\onContentChangeState(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterSave(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), Joomla\onJoomlaAfterUpdate(), Joomla\onUserAfterDelete(), Joomla\onUserAfterDeleteGroup(), Joomla\onUserAfterRemind(), Joomla\onUserAfterSave(), et Joomla\onUserAfterSaveGroup().

◆ loadLanguage()

loadLanguage | ( | $extension = '',
 |  | $basePath = JPATH_ADMINISTRATOR
 | ) |

Loads the plugin language file

Paramètres
string | $extension | The extension for which a language file should be loaded
string | $basePath | The basepath to use
Renvoie
boolean True, if the file has successfully loaded.
Depuis
1.5

Références $basePath, $extension, $lang, Factory\getLanguage(), et JPATH_PLUGINS.

◆ parameterImplementsEventInterface()

parameterImplementsEventInterface ( \ReflectionParameter $parameter )
private

Checks if parameter is typehinted to accept .

Paramètres
\ReflectionParameter $parameter
Renvoie
boolean
Depuis
4.0.0

Références $type, class, et null.

◆ registerLegacyListener()

registerLegacyListener ( string $methodName )
finalprotected

Registers a legacy event listener, i.e. a method which accepts individual arguments instead of an AbstractEvent in its arguments. This provides backwards compatibility to Joomla! 3.x-style plugins.

This method will register lambda functions (closures) which try to unwrap the arguments of the dispatched Event into old style method arguments and call your on<Something> method with them. The result will be passed back to the Event, as an element into an array argument called 'result'.

Paramètres
string $methodName The method name to register
Renvoie
void
Depuis
4.0.0

Références $methodName, $result, AbstractEvent\getArguments(), Joomla\CMS\Application\getDispatcher(), et null.

◆ registerListener()

registerListener ( string $methodName )
finalprotected

Registers a proper event listener, i.e. a method which accepts an AbstractEvent as its sole argument. This is the preferred way to implement plugins in Joomla! 4.x and will be the only possible method with Joomla! 5.x onwards.

Paramètres
string $methodName The method name to register
Renvoie
void
Depuis
4.0.0

Références $methodName, $this, et Joomla\CMS\Application\getDispatcher().

◆ setApplication()

setApplication ( CMSApplicationInterface $application )

Sets the application to use.

Paramètres
CMSApplicationInterface $application The application
Renvoie
void
Depuis
4.2.0

Référencé par ServiceProviderInterface\register().

Documentation des champs

◆ $_name

$_name = null
protected

◆ $_type

$_type = null
protected

◆ $allowLegacyListeners

$allowLegacyListeners = true
protected

◆ $application

$application
private

◆ $autoloadLanguage

$autoloadLanguage = false
protected

◆ $params

$params = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • CMSPlugin.php


Joomla CMS: Référence de la classe PluginHelper

  • Joomla
  • CMS
  • Plugin
  • PluginHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe PluginHelper

Fonctions membres publiques statiques

static | getLayoutPath ($type, $name, $layout='default')
static | getPlugin ($type, $plugin=null)
static | isEnabled ($type, $plugin=null)
static | importPlugin ($type, $plugin=null, $autocreate=true, DispatcherInterface $dispatcher=null)

Fonctions membres protégées statiques

static import ($plugin, $autocreate=true, DispatcherInterface $dispatcher=null)

Attributs protégés statiques

static $plugins = null

Description détaillée

Plugin helper class

Depuis
1.5

Documentation des fonctions membres

◆ getLayoutPath()

static getLayoutPath | ( | $type,
 |  | $name,
 |  | $layout = 'default'
 | ) |
static

Get the path to a layout from a Plugin

Paramètres
string | $type | Plugin type
string | $name | Plugin name
string | $layout | Layout name
Renvoie
string Layout path
Depuis
3.0

Références $layout, $name, $temp, $template, $type, Factory\getApplication(), JPATH_PLUGINS, et JPATH_THEMES.

Référencé par FieldsPlugin\onCustomFieldsPrepareField().

◆ getPlugin()

static getPlugin | ( | $type,
 |  | $plugin = null
 | ) |
static

Get the plugin data of a specific type if no specific plugin is specified otherwise only the specific plugin data is returned.

Paramètres
string | $type | The plugin type, relates to the subdirectory in the plugins directory.
string | $plugin | The plugin name.
Renvoie
mixed An array of plugin data objects, or a plugin data object.
Depuis
1.5

Références $result, et $type.

Référencé par Captcha\_load(), Editor\_loadEditor(), Authentication\authenticate(), RedirectHelper\collectUrlsEnabled(), HtmlView\display(), Editor\getButtons(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), StatisticsModel\getData(), TinymcebuilderField\getLayoutData(), SiteApplication\initialiseApp(), Associations\isEnabled(), MediaHelper\isValidLocalDirectory(), PluginController\oauthcallback(), et ServiceProviderInterface\register().

◆ import()

static import | ( |  | $plugin,
 |  |  | $autocreate = true,
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |
staticprotected

Loads the plugin file.

Paramètres
object | $plugin | The plugin.
boolean | $autocreate | True to autocreate.
DispatcherInterface | $dispatcher | Optionally allows the plugin to use a different dispatcher.
Renvoie
void
Depuis
3.2

Références $hash, et Factory\getApplication().

◆ importPlugin()

static importPlugin | ( |  | $type,
 |  |  | $plugin = null,
 |  |  | $autocreate = true,
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |
static

Loads all the plugin files for a particular type if no specific plugin is specified otherwise only the specific plugin is loaded.

Paramètres
string | $type | The plugin type, relates to the subdirectory in the plugins directory.
string | $plugin | The plugin name.
boolean | $autocreate | Autocreate the plugin.
DispatcherInterface | $dispatcher | Optionally allows the plugin to use a different dispatcher.
Renvoie
boolean True on success.
Depuis
1.5

Références $i, $results, $type, Factory\getApplication(), name, et null.

Référencé par Authentication\__construct(), Editor\_loadEditor(), RegistrationModel\activate(), UserModel\activate(), Authentication\authorise(), IndexerController\batch(), ArticleModel\batchMove(), UserModel\block(), ContactModel\buildContactExtendedData(), CallbackController\callback(), UpdateModel\cleanUp(), CategoryView\commonCategoryDisplay(), ApiModel\createFile(), ApiModel\createFolder(), UpdateModel\createUpdateFile(), MapsModel\delete(), IndexModel\delete(), StyleModel\delete(), GroupModel\delete(), MenuModel\delete(), UserModel\delete(), ApiModel\delete(), ModuleModel\delete(), User\delete(), AdminModel\delete(), Installer\discover_install(), AdministratorApplication\dispatch(), SiteApplication\dispatch(), ApiApplication\dispatch(), HtmlView\display(), InstallerHelper\downloadPackage(), StyleModel\duplicate(), ConsoleApplication\execute(), Workflow\executeTransition(), ArticleModel\featured(), QuickIconHelper\getButtons(), Editor\getButtons(), Cache\getCacheKey(), CapabilitiesModel\getCapabilities(), Helper\getContentExtras(), RegistrationModel\getData(), FieldsHelper\getFields(), FieldsHelper\getFieldTypes(), FileModel\getForm(), FieldModel\getForm(), NoteModel\getItem(), DataField\getLayoutData(), SampledataHelper\getList(), StatsHelper\getList(), Mfa\getMfaMethods(), PrivacyStatusHelper\getPrivacyPolicyInfo(), UserHelper\getProfile(), Joomla\Component\Media\Administrator\Provider\getProviderManager(), StatsAdminHelper\getStats(), Joomla\CMS\MVC\Model\importWorkflowPlugins(), Indexer\index(), FinderIndexCommand\index(), CMSApplication\initialiseApp(), InstallModel\install(), UpdateModel\install(), Installer\install(), Cache\isExcluded(), CMSApplication\login(), CMSApplication\logout(), PluginController\oauthcallback(), Cache\onAfterRoute(), IndexController\optimise(), IndexerController\optimize(), Content\prepare(), Helper\prepareContent(), JsonapiView\prepareItem(), UpdateModel\preparePreUpdate(), Joomla\CMS\MVC\Model\preprocessData(), FormModel\preprocessData(), Joomla\CMS\MVC\Model\preprocessForm(), FormModel\preprocessForm(), TransitionModel\preprocessForm(), TaskModel\preprocessForm(), ManageModel\publish(), MapsModel\publish(), IndexModel\publish(), CategoryModel\publish(), AdminModel\publish(), IndexModel\purge(), UpdatesitesModel\rebuild(), RegistrationModel\register(), Indexer\remove(), CMSApplication\render(), AdministratorApplication\route(), SiteApplication\route(), CMSApplication\route(), FieldModel\save(), GroupModel\save(), ComponentModel\save(), LanguageModel\save(), MenuModel\save(), ProfileModel\save(), TemplateModel\save(), StyleModel\save(), CategoryModel\save(), User\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), IndexerController\start(), Versioning\store(), ContactController\submit(), Installer\uninstall(), Installer\update(), ApiModel\updateFile(), et FormModel\validate().

◆ isEnabled()

static isEnabled | ( | $type,
 |  | $plugin = null
 | ) |
static

Checks if a plugin is enabled.

Paramètres
string | $type | The plugin type, relates to the subdirectory in the plugins directory.
string | $plugin | The plugin name.
Renvoie
boolean
Depuis
1.5

Références $result, et $type.

Référencé par HtmlView\addToolbar(), RedirectHelper\collectUrlsEnabled(), DisplayController\display(), HtmlView\display(), UsersModel\getFilterForm(), ArticlesCategoryHelper\getList(), ArticlesModel\getListQuery(), UsersModel\getListQuery(), ListField\getOptions(), UsersModel\getStoreId(), httpheaders_postinstall_condition(), CMSApplication\initialiseApp(), PluginController\oauthcallback(), QueryHelper\orderbySecondary(), UpdatesitesModel\rebuild(), VotelistField\setup(), et VoteradioField\setup().

Documentation des champs

◆ $plugins

$plugins = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginHelper.php


Joomla CMS: Référence de la classe Profiler

  • Joomla
  • CMS
  • Profiler
  • Profiler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Profiler

Fonctions membres publiques

__construct ($prefix='')
mark ($label)
getMarks ()
getBuffer ()
setStart ($startTime=0.0, $startMem=0)

Fonctions membres publiques statiques

static getInstance ($prefix='')

Attributs protégés

$start = 0
$prefix = ''
$buffer = null
$marks = null
$previousTime = 0.0
$previousMem = 0.0

Attributs protégés statiques

static $instances = array()

Description détaillée

Utility class to assist in the process of benchmarking the execution of sections of code to understand where time is being spent.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $prefix = '' )

Constructor

Paramètres
string $prefix Prefix for mark messages
Depuis
1.7.0

Références $prefix.

Documentation des fonctions membres

◆ getBuffer()

getBuffer ( )

Get all profiler mark buffers.

Returns an array of all mark buffers created since the Profiler object was instantiated. Marks are strings as per Profiler::mark().

Renvoie
array Array of profiler marks
Depuis
1.7.0

Références $buffer.

◆ getInstance()

static getInstance ( $prefix = '' )
static

Returns the global Profiler object, only creating it if it doesn't already exist.

Paramètres
string $prefix Prefix used to distinguish profiler objects.
Renvoie
Profiler The Profiler object.
Depuis
1.7.0

Références $prefix.

Référencé par CMSApplication\__construct(), ProfileCollector\collect(), HtmlView\display(), Access\getAssetRules(), Indexer\getState(), Access\preloadComponents(), Access\preloadPermissions(), ModuleHelper\renderModule(), et ModuleHelper\renderRawModule().

◆ getMarks()

getMarks ( )

Get all profiler marks.

Returns an array of all marks created since the Profiler object was instantiated. Marks are objects as per JProfiler::mark().

Renvoie
array Array of profiler marks
Depuis
1.7.0

◆ mark()

mark ( $label )

Output a time mark

Paramètres
string $label A label for the time mark
Renvoie
string
Depuis
1.7.0

Références $label, et $start.

◆ setStart()

setStart | ( | $startTime = 0.0,
 |  | $startMem = 0
 | ) |

Sets the start time.

Paramètres
double | $startTime | Unix timestamp in microseconds for setting the Profiler start time.
int | $startMem | Memory amount in bytes for setting the Profiler start memory.
Renvoie
$this For chaining
Depuis
3.0.0

Références $startMem, $startTime, et $this.

Documentation des champs

◆ $buffer

$buffer = null
protected

◆ $instances

$instances = array()
staticprotected

◆ $marks

$marks = null
protected

◆ $prefix

$prefix = ''
protected

◆ $previousMem

$previousMem = 0.0
protected

◆ $previousTime

$previousTime = 0.0
protected

◆ $start

$start = 0
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Profiler.php


Joomla CMS: Référence de la classe JsonResponse

  • Joomla
  • CMS
  • Response
  • JsonResponse
Fonctions membres publiques | Champs de données
Référence de la classe JsonResponse

Fonctions membres publiques

__construct ($response=null, $message=null, $error=false, $ignoreMessages=false)
__toString ()

Champs de données

$success = true
$message = null
$messages = null
$data = null

Description détaillée

JSON Response class.

This class serves to provide the Joomla Platform with a common interface to access response variables for e.g. Ajax requests.

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $response = null,
 |  | $message = null,
 |  | $error = false,
 |  | $ignoreMessages = false
 | ) |

Constructor

Paramètres
mixed | $response | The Response data
string | $message | The main response message
boolean | $error | True, if the success flag shall be set to false, defaults to false
boolean | $ignoreMessages | True, if the message queue shouldn't be included, defaults to false
Depuis
3.1

Références $app, $message, $messages, Factory\getApplication(), et null.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic toString method for sending the response in JSON format

Renvoie
string The response in JSON format
Depuis
3.1

Références $this.

Documentation des champs

◆ $data

$data = null

◆ $message

$message = null

◆ $messages

$messages = null

◆ $success

$success = true
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Response/JsonResponse.php


Joomla CMS: Référence de la classe RouteNotFoundException

  • Joomla
  • CMS
  • Router
  • Exception
  • RouteNotFoundException
Fonctions membres publiques
Référence de la classe RouteNotFoundException
+ Graphe d'héritage de RouteNotFoundException:
MissingComponentException

Fonctions membres publiques

__construct ($message='', $code=404, \Exception $previous=null)

Description détaillée

Exception class defining an error for a missing route

Depuis
3.8.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = '',
 |  |  | $code = 404,
 |  | \Exception | $previous = null
 | ) |  |

Constructor

Paramètres
string | $message | The Exception message to throw.
integer | $code | The Exception code.
\Exception | $previous | The previous exception used for the exception chaining.
Depuis
3.8.0

Références $message, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Router/Exception/RouteNotFoundException.php


Joomla CMS: Référence de la classe AdministratorRouter

  • Joomla
  • CMS
  • Router
  • AdministratorRouter
Fonctions membres publiques
Référence de la classe AdministratorRouter
+ Graphe d'héritage de AdministratorRouter:
Router

Fonctions membres publiques

parse (&$uri, $setVars=false)
build ($url)
- Fonctions membres publiques hérités de Router
parse (&$uri, $setVars=false)
build ($url)
setVar ($key, $value, $create=true)
setVars ($vars=array(), $merge=true)
getVar ($key)
getVars ()
attachBuildRule (callable $callback, $stage=self::PROCESS_DURING)
attachParseRule (callable $callback, $stage=self::PROCESS_DURING)
detachRule ($type, $rule, $stage=self::PROCESS_DURING)
getRules ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Router
static | getInstance ($client, $options=array())
- Champs de données hérités de Router
const | PROCESS_BEFORE = 'preprocess'
const | PROCESS_DURING = ''
const | PROCESS_AFTER = 'postprocess'
- Fonctions membres protégées hérités de Router
processParseRules (&$uri, $stage=self::PROCESS_DURING)
processBuildRules (&$uri, $stage=self::PROCESS_DURING)
createUri ($url)
- Attributs protégés hérités de Router
$vars = array()
$rules
$cache = array()
- Attributs protégés statiques hérités de Router
static | $instances = array()

Description détaillée

Class to create and parse routes

Depuis
1.5

Documentation des fonctions membres

◆ build()

build ( $url )

Function to convert an internal URI to a route

Paramètres
string $url The internal URL
Renvoie
Uri The absolute search engine friendly URL
Depuis
1.5

Références $route, $uri, $url, JPATH_ADMINISTRATOR, et Uri\root().

◆ parse()

parse | ( | & | $uri,
 |  |  | $setVars = false
 | ) |  |

Function to convert a route to an internal URI.

Paramètres
Uri | &$uri | The uri.
bool | $setVars | Set the parsed data in the internal storage for current-request-URLs
Renvoie
array
Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdministratorRouter.php


Joomla CMS: Référence de la classe ApiRouter

  • Joomla
  • CMS
  • Router
  • ApiRouter
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe ApiRouter
+ Graphe d'héritage de ApiRouter:
Router

Fonctions membres publiques

__construct (CMSApplicationInterface $app, array $maps=[])
createCRUDRoutes ($baseName, $controller, $defaults=[], $publicGets=false)
parseApiRoute ($method='GET')
getRoutePath ()
getMatchingRoutes ()
- Fonctions membres publiques hérités de Router
parse (&$uri, $setVars=false)
build ($url)
setVar ($key, $value, $create=true)
setVars ($vars=array(), $merge=true)
getVar ($key)
getVars ()
attachBuildRule (callable $callback, $stage=self::PROCESS_DURING)
attachParseRule (callable $callback, $stage=self::PROCESS_DURING)
detachRule ($type, $rule, $stage=self::PROCESS_DURING)
getRules ()

Attributs protégés

$app
- Attributs protégés hérités de Router
$vars = array()
$rules
$cache = array()

Fonctions membres privées

removeIndexPhpFromPath (string $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Router
static | getInstance ($client, $options=array())
- Champs de données hérités de Router
const | PROCESS_BEFORE = 'preprocess'
const | PROCESS_DURING = ''
const | PROCESS_AFTER = 'postprocess'
- Fonctions membres protégées hérités de Router
processParseRules (&$uri, $stage=self::PROCESS_DURING)
processBuildRules (&$uri, $stage=self::PROCESS_DURING)
createUri ($url)
- Attributs protégés statiques hérités de Router
static | $instances = array()

Description détaillée

Joomla! API Router class

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CMSApplicationInterface | $app,
 |  | array | $maps = []
 | ) |  |

Constructor.

Paramètres
CMSApplicationInterface | $app | The application object
array | $maps | An optional array of route maps
Depuis
1.0

Références $app, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createCRUDRoutes()

createCRUDRoutes | ( | $baseName,
 |  | $controller,
 |  | $defaults = [],
 |  | $publicGets = false
 | ) |

Creates routes map for CRUD

Paramètres
string | $baseName | The base name of the component.
string | $controller | The name of the controller that contains CRUD functions.
array | $defaults | An array of default values that are used when the URL is matched.
bool | $publicGets | Allow the public to make GET requests.
Renvoie
void
Depuis
4.0.0

◆ getMatchingRoutes()

getMatchingRoutes ( )

Extract routes matching current route from all known routes.

Renvoie
[]
Depuis
4.0.0

Références $route.

◆ getRoutePath()

getRoutePath ( )

Get the path from the route and remove and leading or trailing slash.

Renvoie
string
Depuis
4.0.0

In some environments (e.g. CLI we can't form a valid base URL). In this case we catch the exception thrown by URI and set an empty base URI for further work.

Références $path, $uri, Uri\base(), et Uri\getInstance().

◆ parseApiRoute()

parseApiRoute ( $method = 'GET' )

Parse the given route and return the name of a controller mapped to the given route.

Paramètres
string $method Request method to match. One of GET, POST, PUT, DELETE, HEAD, OPTIONS, TRACE or PATCH
Renvoie
array An array containing the controller and the matched variables.
Depuis
4.0.0
Exceptions

Références $i, $method, $query, $route, et Uri\getInstance().

◆ removeIndexPhpFromPath()

removeIndexPhpFromPath ( string $path )
private

Removes the index.php from the route's path.

Paramètres
string $path The path
Renvoie
string
Depuis
4.0.0

Références $path.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApiRouter.php


Joomla CMS: Référence de la classe Route

  • Joomla
  • CMS
  • Router
  • Route
Fonctions membres publiques statiques | Champs de données | Attributs privés statiques
Référence de la classe Route

Fonctions membres publiques statiques

static | _ ($url, $xhtml=true, $tls=self::TLS_IGNORE, $absolute=false)
static | link ($client, $url, $xhtml=true, $tls=self::TLS_IGNORE, $absolute=false)

Champs de données

const | TLS_IGNORE = 0
const | TLS_FORCE = 1
const | TLS_DISABLE = 2

Attributs privés statiques

static $_router = array()

Description détaillée

Route handling class

Depuis
1.7.0

Documentation des fonctions membres

◆ _()

static _ | ( | $url,
 |  | $xhtml = true,
 |  | $tls = self::TLS_IGNORE,
 |  | $absolute = false
 | ) |
static

Translates an internal Joomla URL to a humanly readable URL. This method builds links for the current active client.

Paramètres
string | $url | Absolute or Relative URI to Joomla resource.
boolean | $xhtml | Replace & by & for XML compliance.
integer | $tls | Secure state for the resolved URI. Use Route::TLS_* constants 0: (default) No change, use the protocol currently used in the request 1: Make URI secure using global secure site URI. 2: Make URI unsecure using the global unsecure site URI.
boolean | $absolute | Return an absolute URL
Renvoie
string The translated humanly readable URL.
Depuis
1.7.0

Références $app, $client, $url, Factory\getApplication(), et null.

Référencé par OpensearchDocument\__construct(), Pagination\_buildDataObject(), HtmlView\_prepareDocument(), ModuleController\add(), ArticleController\add(), FormController\add(), CategoryView\addFeed(), DisplayController\addModule(), Users\addNote(), Shortcut\addShortcuts(), HtmlView\addToolbar(), LevelController\allowEdit(), AdministratorService\association(), Menus\association(), SiteApplication\authorise(), BannerController\batch(), NewsfeedController\batch(), UserController\batch(), ModuleController\batch(), ApplicationController\cancel(), TemplateController\cancel(), AssociationController\cancel(), ConfigController\cancel(), ItemController\cancel(), OverrideController\cancel(), ComponentController\cancel(), ProfileController\cancel(), FormController\cancel(), ContactController\cancel(), AssociationsController\checkin(), AdminController\checkin(), Session\checkToken(), CMSApplication\checkUserRequireReset(), AssociationsController\clean(), TemplateController\close(), Icon\create(), TemplateController\createFile(), OverridesController\delete(), AdminController\delete(), UpdatesitesController\delete(), MethodController\delete(), TemplateController\delete(), OpensearchView\display(), FeedView\display(), CategoryFeedView\display(), MenuController\display(), DisplayController\display(), XmlView\display(), HtmlView\display(), ProfileController\edit(), OverrideController\edit(), AssociationController\edit(), TemplateController\edit(), Icon\edit(), Dropdown\edit(), ArticleController\edit(), FormController\edit(), MethodController\execute(), MethodsController\execute(), CaptiveController\execute(), MenuController\exportXml(), Users\filterNotes(), ConsentBoxField\getAssignedArticleUrl(), ConsentBoxField\getAssignedMenuItemUrl(), AssociationsHelper\getAssociationHtmlList(), QuickIconHelper\getButtons(), HtmlView\getFields(), FinderHelper\getGetFields(), PlugininfoField\getInput(), MenutypeField\getInput(), ModuleModel\getItem(), TosField\getLabel(), ArticlesPopularHelper\getList(), LatestHelper\getList(), ArticlesArchiveHelper\getList(), LanguagesHelper\getList(), PopularHelper\getList(), LoggedHelper\getList(), ArticlesCategoryHelper\getList(), StatsAdminHelper\getStats(), InstallModel\install(), HistoryController\keep(), UserController\login(), UserController\logout(), Users\notesModal(), PluginController\oauthcallback(), KeepaliveAssetItem\onAttachCallback(), TemplateController\overrides(), ArticleController\postSaveHook(), ContactController\postSaveHook(), HtmlView\prepareDocument(), PluginModel\preprocessForm(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), AssociationsController\purge(), ActionlogsController\purge(), UpdatesitesController\rebuild(), UpdatesitesModel\rebuild(), FeedView\reconcileNames(), AdminModel\redirectToAssociations(), RssRenderer\render(), AtomRenderer\render(), AdminController\reorder(), AdminController\runTransition(), ConfigController\save(), TemplatesController\save(), OverrideController\save(), ArticleController\save(), FormController\save(), AdminController\saveorder(), MailController\send(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), ItemController\setType(), ContactController\submit(), TemplateController\uploadFile(), et ArticleController\vote().

◆ link()

static link | ( | $client,
 |  | $url,
 |  | $xhtml = true,
 |  | $tls = self::TLS_IGNORE,
 |  | $absolute = false
 | ) |
static

Translates an internal Joomla URL to a humanly readable URL. NOTE: To build link for active client instead of a specific client, you can use Route::_()

Paramètres
string | $client | The client name for which to build the link.
string | $url | Absolute or Relative URI to Joomla resource.
boolean | $xhtml | Replace & by & for XML compliance.
integer | $tls | Secure state for the resolved URI. Use Route::TLS_* constants 0: (default) No change, use the protocol currently used in the request 1: Make URI secure using global secure site URI. 2: Make URI unsecure using the global unsecure site URI.
boolean | $absolute | Return an absolute URL
Renvoie
string The translated humanly readable URL.
Exceptions

Références $client, $uri, $url, elseif, ENT_COMPAT, Factory\getApplication(), Factory\getContainer(), Uri\getInstance(), et Text\sprintf().

Référencé par RegistrationModel\activate(), HtmlView\addToolbar(), ContentSerializer\category(), ContactSerializer\category(), NewsfeedSerializer\category(), MailHelper\convertRelativeToAbsoluteUrls(), ContentSerializer\createdBy(), NewsfeedSerializer\createdBy(), ContactSerializer\createdBy(), ActionlogsHelper\getHumanReadableLogMessage(), PrivacyStatusHelper\getRequestFormPublished(), ContentSerializer\languageAssociations(), NewsfeedSerializer\languageAssociations(), ContactSerializer\languageAssociations(), ContentSerializer\modifiedBy(), NewsfeedSerializer\modifiedBy(), ContactSerializer\modifiedBy(), RegistrationModel\register(), MessageModel\save(), et ContactSerializer\userId().

Documentation des champs

◆ $_router

$_router = array()
staticprivate

◆ TLS_DISABLE

const TLS_DISABLE = 2

Make URI unsecure using plain http (http).

Depuis
3.9.7

◆ TLS_FORCE

const TLS_FORCE = 1

Make URI secure using http over TLS (https).

Depuis
3.9.7

Référencé par RegistrationModel\activate(), FeedView\display(), ActionlogsHelper\getHumanReadableLogMessage(), PrivacyStatusHelper\getRequestFormPublished(), FeedView\reconcileNames(), RegistrationModel\register(), et MessageModel\save().

◆ TLS_IGNORE

const TLS_IGNORE = 0

No change, use the protocol currently used.

Depuis
3.9.7

Référencé par RegistrationModel\activate(), MailHelper\convertRelativeToAbsoluteUrls(), FeedView\display(), ActionlogsHelper\getHumanReadableLogMessage(), PrivacyStatusHelper\getRequestFormPublished(), FeedView\reconcileNames(), RegistrationModel\register(), et MessageModel\save().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Router/Route.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • CMS
  • Router
  • Router
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Router
+ Graphe d'héritage de Router:
InstallationRouter AdministratorRouter ApiRouter SiteRouter

Fonctions membres publiques

parse (&$uri, $setVars=false)
build ($url)
setVar ($key, $value, $create=true)
setVars ($vars=array(), $merge=true)
getVar ($key)
getVars ()
attachBuildRule (callable $callback, $stage=self::PROCESS_DURING)
attachParseRule (callable $callback, $stage=self::PROCESS_DURING)
detachRule ($type, $rule, $stage=self::PROCESS_DURING)
getRules ()

Fonctions membres publiques statiques

static getInstance ($client, $options=array())

Champs de données

const | PROCESS_BEFORE = 'preprocess'
const | PROCESS_DURING = ''
const | PROCESS_AFTER = 'postprocess'

Fonctions membres protégées

processParseRules (&$uri, $stage=self::PROCESS_DURING)
processBuildRules (&$uri, $stage=self::PROCESS_DURING)
createUri ($url)

Attributs protégés

$vars = array()
$rules
$cache = array()

Attributs protégés statiques

static $instances = array()

Description détaillée

Class to create and parse routes

Depuis
1.5

Documentation des fonctions membres

◆ attachBuildRule()

attachBuildRule | ( | callable | $callback,
 |  |  | $stage = self::PROCESS_DURING
 | ) |  |

Attach a build rule

Paramètres
callable | $callback | The function to be called
string | $stage | The stage of the build process that this should be added to. Possible values: 'preprocess', '' for the main build process, 'postprocess'
Renvoie
void
Depuis
1.5

◆ attachParseRule()

attachParseRule | ( | callable | $callback,
 |  |  | $stage = self::PROCESS_DURING
 | ) |  |

Attach a parse rule

Paramètres
callable | $callback | The function to be called.
string | $stage | The stage of the parse process that this should be added to. Possible values: 'preprocess', '' for the main parse process, 'postprocess'
Renvoie
void
Depuis
1.5

◆ build()

build ( $url )

Function to convert an internal URI to a route

Paramètres
string | array | Uri $url The internal URL or an associative array
Renvoie
Uri The absolute search engine friendly URL object
Depuis
1.5

Références $key, $uri, $url, et Laminas\Diactoros\createUri().

◆ createUri()

createUri ( $url )
protected

Create a uri based on a full or partial URL string

Paramètres
string $url The URI or an associative array
Renvoie
Uri
Depuis
3.2

Références $key, $uri, et $url.

◆ detachRule()

detachRule | ( | $type,
 |  | $rule,
 |  | $stage = self::PROCESS_DURING
 | ) |

Remove a rule

Paramètres
string | $type | Type of rule to remove (parse or build)
callable | $rule | The rule to be removed.
string | $stage | The stage of the parse process that this should be added to. Possible values: 'preprocess', '' for the main parse process, 'postprocess'
Renvoie
boolean Was a rule removed?
Depuis
4.0.0
Exceptions

Références $id, $r, et $type.

◆ getInstance()

static getInstance | ( | $client,
 |  | $options = array()
 | ) |
static

Returns the global Router object, only creating it if it doesn't already exist.

Paramètres
string | $client | The name of the client
array | $options | An associative array of options
Renvoie
Router A Router object.
Depuis
1.5
Exceptions

Références $client, Factory\getContainer(), Symfony\Contracts\Service\has(), et Text\sprintf().

Référencé par ConsoleApplication\getRouter(), et CMSApplication\getRouter().

◆ getRules()

getRules ( )

Get all currently attached rules

Renvoie
array All currently attached rules in an array
Depuis
4.0.0

◆ getVar()

getVar ( $key )

Get a router variable

Paramètres
string $key The name of the variable
Renvoie
mixed Value of the variable
Depuis
1.5

Références $key, $result, et null.

◆ getVars()

getVars ( )

Get the router variable array

Renvoie
array An associative array of router variables
Depuis
1.5

◆ parse()

parse | ( | & | $uri,
 |  |  | $setVars = false
 | ) |  |

Function to convert a route to an internal URI

Paramètres
Uri | &$uri | The uri.
bool | $setVars | Set the parsed data in the internal storage for current-request-URLs
Renvoie
array
Depuis
1.5
Exceptions

Références $uri, et Text\_().

◆ processBuildRules()

processBuildRules | ( | & | $uri,
 |  |  | $stage = self::PROCESS_DURING
 | ) |  |
protected

Process the build uri query data based on custom defined rules

Paramètres
\Joomla\CMS\Uri\Uri | &$uri | The URI
string | $stage | The stage that should be processed. Possible values: 'preprocess', 'postprocess' and '' for the main build stage
Renvoie
void
Depuis
3.2

Références $this, et $uri.

◆ processParseRules()

processParseRules | ( | & | $uri,
 |  |  | $stage = self::PROCESS_DURING
 | ) |  |
protected

Process the parsed router variables based on custom defined rules

Paramètres
\Joomla\CMS\Uri\Uri | &$uri | The URI to parse
string | $stage | The stage that should be processed. Possible values: 'preprocess', 'postprocess' and '' for the main parse stage
Renvoie
void
Depuis
3.2

Références $this, et $uri.

◆ setVar()

setVar | ( | $key,
 |  | $value,
 |  | $create = true
 | ) |

Set a router variable, creating it if it doesn't exist

Paramètres
string | $key | The name of the variable
mixed | $value | The value of the variable
boolean | $create | If True, the variable will be created if it doesn't exist yet
Renvoie
void
Depuis
1.5

Références $key, et $value.

◆ setVars()

setVars | ( | $vars = array(),
 |  | $merge = true
 | ) |

Set the router variable array

Paramètres
array | $vars | An associative array with variables
boolean | $merge | If True, the array will be merged instead of overwritten
Renvoie
void
Depuis
1.5

Documentation des champs

◆ $cache

$cache = array()
protected

◆ $instances

$instances = array()
staticprotected

◆ $rules

$rules
protected
Valeur initiale :
= array(
'buildpreprocess' => array(),
'build' => array(),
'buildpostprocess' => array(),
'parsepreprocess' => array(),
'parse' => array(),
'parsepostprocess' => array(),
)

◆ $vars

$vars = array()
protected

◆ PROCESS_AFTER

const PROCESS_AFTER = 'postprocess'

◆ PROCESS_BEFORE

const PROCESS_BEFORE = 'preprocess'

◆ PROCESS_DURING

const PROCESS_DURING = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Router/Router.php


Joomla CMS: Référence de la classe SiteRouter

  • Joomla
  • CMS
  • Router
  • SiteRouter
Fonctions membres publiques | Attributs protégés
Référence de la classe SiteRouter
+ Graphe d'héritage de SiteRouter:
Router

Fonctions membres publiques

__construct (CMSApplication $app=null, AbstractMenu $menu=null)
parseCheckSSL (&$router, &$uri)
parseInit (&$router, &$uri)
parseFormat (&$router, &$uri)
parseSefRoute (&$router, &$uri)
parseRawRoute (&$router, &$uri)
parsePaginationData (&$router, &$uri)
buildInit (&$router, &$uri)
buildComponentPreprocess (&$router, &$uri)
buildSefRoute (&$router, &$uri)
buildPaginationData (&$router, &$uri)
buildFormat (&$router, &$uri)
buildRewrite (&$router, &$uri)
buildBase (&$router, &$uri)
getComponentRouter ($component)
setComponentRouter ($component, $router)
- Fonctions membres publiques hérités de Router
parse (&$uri, $setVars=false)
build ($url)
setVar ($key, $value, $create=true)
setVars ($vars=array(), $merge=true)
getVar ($key)
getVars ()
attachBuildRule (callable $callback, $stage=self::PROCESS_DURING)
attachParseRule (callable $callback, $stage=self::PROCESS_DURING)
detachRule ($type, $rule, $stage=self::PROCESS_DURING)
getRules ()

Attributs protégés

$componentRouters = []
$app
$menu
- Attributs protégés hérités de Router
$vars = array()
$rules
$cache = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Router
static | getInstance ($client, $options=array())
- Champs de données hérités de Router
const | PROCESS_BEFORE = 'preprocess'
const | PROCESS_DURING = ''
const | PROCESS_AFTER = 'postprocess'
- Fonctions membres protégées hérités de Router
processParseRules (&$uri, $stage=self::PROCESS_DURING)
processBuildRules (&$uri, $stage=self::PROCESS_DURING)
createUri ($url)
- Attributs protégés statiques hérités de Router
static | $instances = array()

Description détaillée

Class to create and parse routes for the site application

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CMSApplication | $app = null,
 |  | AbstractMenu | $menu = null
 | ) |  |

Class constructor

Paramètres
CMSApplication | $app | Application Object
AbstractMenu | $menu | Menu object
Depuis
3.4

Références $app, $menu, $this, class, et Factory\getContainer().

Documentation des fonctions membres

◆ buildBase()

buildBase | ( | & | $router,
 |  | & | $uri
 | ) |  |

Add the basepath to the URI

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $uri, et Uri\root().

◆ buildComponentPreprocess()

buildComponentPreprocess | ( | & | $router,
 |  | & | $uri
 | ) |  |

Run the component preprocess method

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $component, $item, $query, et $uri.

◆ buildFormat()

buildFormat | ( | & | $router,
 |  | & | $uri
 | ) |  |

Build the format of the request

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $format, $route, et $uri.

◆ buildInit()

buildInit | ( | & | $router,
 |  | & | $uri
 | ) |  |

Do some initial processing for building a URL

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $item, $itemid, et $uri.

◆ buildPaginationData()

buildPaginationData | ( | & | $router,
 |  | & | $uri
 | ) |  |

Convert limits for pagination

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $uri, et null.

◆ buildRewrite()

buildRewrite | ( | & | $router,
 |  | & | $uri
 | ) |  |

Create a uri based on a full or partial URL string

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $route, et $uri.

◆ buildSefRoute()

buildSefRoute | ( | & | $router,
 |  | & | $uri
 | ) |  |

Build the SEF route

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $component, $item, $parts, $query, $tmp, $uri, et null.

◆ getComponentRouter()

getComponentRouter ( $component )

Get component router

Paramètres
string $component Name of the component including com_ prefix
Renvoie
RouterInterface Component router
Depuis
3.3

Références $component.

◆ parseCheckSSL()

parseCheckSSL | ( | & | $router,
 |  | & | $uri
 | ) |  |

Force to SSL

Paramètres
Router | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $uri.

◆ parseFormat()

parseFormat | ( | & | $router,
 |  | & | $uri
 | ) |  |

Parse the format of the request

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $route, $suffix, et $uri.

◆ parseInit()

parseInit | ( | & | $router,
 |  | & | $uri
 | ) |  |

Do some initial cleanup before parsing the URL

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

In some environments (e.g. CLI we can't form a valid base URL). In this case we catch the exception thrown by URI and set an empty base URI for further work.

Références $path, $uri, Uri\base(), et JPATH_SITE.

◆ parsePaginationData()

parsePaginationData | ( | & | $router,
 |  | & | $uri
 | ) |  |

Convert limits for pagination

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $start, $uri, et null.

◆ parseRawRoute()

parseRawRoute | ( | & | $router,
 |  | & | $uri
 | ) |  |

Convert a raw route to an internal URI

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $item, et $uri.

◆ parseSefRoute()

parseSefRoute | ( | & | $router,
 |  | & | $uri
 | ) |  |

Convert a sef route to an internal URI

Paramètres
SiteRouter | &$router | Router object
Uri | &$uri | URI object to process
Renvoie
void
Depuis
4.0.0

Références $component, $item, $items, $route, $this, $uri, et null.

◆ setComponentRouter()

setComponentRouter | ( | $component,
 |  | $router
 | ) |

Set a router for a component

Paramètres
string | $component | Component name with com_ prefix
object | $router | Component router
Renvoie
boolean True if the router was accepted, false if not
Depuis
3.3

Références $component.

Documentation des champs

◆ $app

$app
protected

◆ $componentRouters

$componentRouters = []
protected

◆ $menu

$menu
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteRouter.php


Joomla CMS: Référence de l'interface SiteRouterAwareInterface

  • Joomla
  • CMS
  • Router
  • SiteRouterAwareInterface
Fonctions membres publiques
Référence de l'interface SiteRouterAwareInterface
+ Graphe d'héritage de SiteRouterAwareInterface:
MVCFactory HtmlView ApiMVCFactory

Fonctions membres publiques

setSiteRouter (SiteRouter $router)

Description détaillée

Interface for site router aware classes.

Depuis
4.2.0

Documentation des fonctions membres

◆ setSiteRouter()

setSiteRouter ( SiteRouter $router )

Set the router to use.

Paramètres
SiteRouter $router The router to use.
Renvoie
void
Depuis
4.2.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • SiteRouterAwareInterface.php


Joomla CMS: Référence de la classe MysqlChangeItem

  • Joomla
  • CMS
  • Schema
  • ChangeItem
  • MysqlChangeItem
Fonctions membres protégées | Fonctions membres privées
Référence de la classe MysqlChangeItem
+ Graphe d'héritage de MysqlChangeItem:
ChangeItem

Fonctions membres protégées

buildCheckQuery ()
- Fonctions membres protégées hérités de ChangeItem
buildCheckQuery ()

Fonctions membres privées

fixInteger ($type1, $type2)
fixQuote ($string)
fixUtf8mb4TypeChecks ($type)
checkNull ($changesArray)
checkDefault ($changesArray, $type)

Membres hérités additionnels

- Fonctions membres publiques hérités de ChangeItem
__construct ($db, $file, $query)
check ()
fix ()
- Fonctions membres publiques statiques hérités de ChangeItem
static getInstance ($db, $file, $query)
- Champs de données hérités de ChangeItem
$file = null
$updateQuery = null
$checkQuery = null
$checkQueryExpected = 1
$db = null
$queryType = null
$msgElements = array()
$checkStatus = 0
$rerunStatus = 0

Description détaillée

Checks the database schema against one MySQL DDL query to see if it has been run.

Depuis
2.5

Documentation des fonctions membres

◆ buildCheckQuery()

buildCheckQuery ( )
protected

Checks a DDL query to see if it is a known type If yes, build a check query to see if the DDL has been run on the database. If successful, the $msgElements, $queryType, $checkStatus and $checkQuery fields are populated. The $msgElements contains the text to create the user message. The $checkQuery contains the SQL query to check whether the schema change has been run against the current database. The $queryType contains the type of DDL query that was run (for example, CREATE_TABLE, ADD_COLUMN, CHANGE_COLUMN_TYPE, ADD_INDEX). The $checkStatus field is set to zero if the query is created

If not successful, $checkQuery is empty and , and $checkStatus is -1. For example, this will happen if the current line is a non-DDL statement.

Renvoie
void
Depuis
2.5

When we made the UTF8MB4 conversion then text becomes medium text - so loosen the checks to these two types otherwise (for example) the profile fields profile_value check fails - see https://github.com/joomla/joomla-cms/issues/9258

When we made the UTF8MB4 conversion then text becomes medium text - so loosen the checks to these two types otherwise (for example) the profile fields profile_value check fails - see https://github.com/joomla/joomla-cms/issues/9258

Références $result, $type, ChangeItem\$updateQuery, elseif, et null.

◆ checkDefault()

checkDefault | ( | $changesArray,
 |  | $type
 | ) |
private

Create query clause for column changes/modifications for DEFAULT attribute

Paramètres
array | $changesArray | The array of words after COLUMN name
string | $type | The type of the COLUMN
Renvoie
string The query clause for DEFAULT check in the check query
Depuis
3.8.6

Références $type.

◆ checkNull()

checkNull ( $changesArray )
private

Create query clause for column changes/modifications for NULL attribute

Paramètres
array $changesArray The array of words after COLUMN name
Renvoie
string The query clause for NULL check in the check query
Depuis
3.8.6

◆ fixInteger()

fixInteger | ( | $type1,
 |  | $type2
 | ) |
private

Fix up integer. Fixes problem with MySQL integer descriptions. On MySQL 8 display length is not shown anymore. This means we have to match e.g. both "int(10) unsigned" and "int unsigned", or both "int(11)" and "int" and so on. The same applies to the other integer data types "tinyint", "smallint", "mediumint" and "bigint".

Paramètres
string | $type1 | the column type
string | $type2 | the column attributes
Renvoie
string The original or changed column type.
Depuis
2.5

Références $result.

◆ fixQuote()

fixQuote ( $string )
private

Fixes up a string for inclusion in a query. Replaces name quote character with normal quote for literal. Drops trailing semicolon. Injects the database prefix.

Paramètres
string $string The input string to be cleaned up.
Renvoie
string The modified string.
Depuis
2.5

◆ fixUtf8mb4TypeChecks()

fixUtf8mb4TypeChecks ( $type )
private

Make check query for column changes/modifications tolerant for automatic type changes of text columns, e.g. from TEXT to MEDIUMTEXT, after conversion from utf8 to utf8mb4, and fix integer columns without display length for MySQL 8 (see also function "fixInteger" above).

Paramètres
string $type The column type found in the update query
Renvoie
string The condition for type check in the check query
Depuis
3.5

Références $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqlChangeItem.php


Joomla CMS: Référence de la classe PostgresqlChangeItem

  • Joomla
  • CMS
  • Schema
  • ChangeItem
  • PostgresqlChangeItem
Fonctions membres protégées | Fonctions membres privées
Référence de la classe PostgresqlChangeItem
+ Graphe d'héritage de PostgresqlChangeItem:
ChangeItem

Fonctions membres protégées

buildCheckQuery ()
- Fonctions membres protégées hérités de ChangeItem
buildCheckQuery ()

Fonctions membres privées

fixInteger ($type1, $type2)
fixQuote ($string)

Membres hérités additionnels

- Fonctions membres publiques hérités de ChangeItem
__construct ($db, $file, $query)
check ()
fix ()
- Fonctions membres publiques statiques hérités de ChangeItem
static getInstance ($db, $file, $query)
- Champs de données hérités de ChangeItem
$file = null
$updateQuery = null
$checkQuery = null
$checkQueryExpected = 1
$db = null
$queryType = null
$msgElements = array()
$checkStatus = 0
$rerunStatus = 0

Description détaillée

Checks the database schema against one PostgreSQL DDL query to see if it has been run.

Depuis
3.0

Documentation des fonctions membres

◆ buildCheckQuery()

buildCheckQuery ( )
protected

Checks a DDL query to see if it is a known type If yes, build a check query to see if the DDL has been run on the database. If successful, the $msgElements, $queryType, $checkStatus and $checkQuery fields are populated. The $msgElements contains the text to create the user message. The $checkQuery contains the SQL query to check whether the schema change has been run against the current database. The $queryType contains the type of DDL query that was run (for example, CREATE_TABLE, ADD_COLUMN, CHANGE_COLUMN_TYPE, ADD_INDEX). The $checkStatus field is set to zero if the query is created

If not successful, $checkQuery is empty and , and $checkStatus is -1. For example, this will happen if the current line is a non-DDL statement.

Renvoie
void
Depuis
3.0

Références $actions, $result, $type, ChangeItem\$updateQuery, elseif, et null.

◆ fixInteger()

fixInteger | ( | $type1,
 |  | $type2
 | ) |
private

Fix up integer. Fixes problem with PostgreSQL integer descriptions. If you change a column to "integer unsigned" it shows as "int(10) unsigned" in the check query.

Paramètres
string | $type1 | the column type
string | $type2 | the column attributes
Renvoie
string The original or changed column type.
Depuis
3.0

Références $result.

◆ fixQuote()

fixQuote ( $string )
private

Fixes up a string for inclusion in a query. Replaces name quote character with normal quote for literal. Drops trailing semicolon. Injects the database prefix.

Paramètres
string $string The input string to be cleaned up.
Renvoie
string The modified string.
Depuis
3.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • PostgresqlChangeItem.php


Joomla CMS: Référence de la classe SqlsrvChangeItem

  • Joomla
  • CMS
  • Schema
  • ChangeItem
  • SqlsrvChangeItem
Fonctions membres protégées | Fonctions membres privées
Référence de la classe SqlsrvChangeItem
+ Graphe d'héritage de SqlsrvChangeItem:
ChangeItem

Fonctions membres protégées

buildCheckQuery ()
- Fonctions membres protégées hérités de ChangeItem
buildCheckQuery ()

Fonctions membres privées

fixInteger ($type1, $type2)
fixQuote ($string)

Membres hérités additionnels

- Fonctions membres publiques hérités de ChangeItem
__construct ($db, $file, $query)
check ()
fix ()
- Fonctions membres publiques statiques hérités de ChangeItem
static getInstance ($db, $file, $query)
- Champs de données hérités de ChangeItem
$file = null
$updateQuery = null
$checkQuery = null
$checkQueryExpected = 1
$db = null
$queryType = null
$msgElements = array()
$checkStatus = 0
$rerunStatus = 0

Description détaillée

Checks the database schema against one SQL Server DDL query to see if it has been run.

Depuis
2.5

Documentation des fonctions membres

◆ buildCheckQuery()

buildCheckQuery ( )
protected

Checks a DDL query to see if it is a known type If yes, build a check query to see if the DDL has been run on the database. If successful, the $msgElements, $queryType, $checkStatus and $checkQuery fields are populated. The $msgElements contains the text to create the user message. The $checkQuery contains the SQL query to check whether the schema change has been run against the current database. The $queryType contains the type of DDL query that was run (for example, CREATE_TABLE, ADD_COLUMN, CHANGE_COLUMN_TYPE, ADD_INDEX). The $checkStatus field is set to zero if the query is created

If not successful, $checkQuery is empty and , and $checkStatus is -1. For example, this will happen if the current line is a non-DDL statement.

Renvoie
void
Depuis
2.5

Références $result, ChangeItem\$updateQuery, elseif, et null.

◆ fixInteger()

fixInteger | ( | $type1,
 |  | $type2
 | ) |
private

Fix up integer. Fixes problem with MySQL integer descriptions. If you change a column to "integer unsigned" it shows as "int(10) unsigned" in the check query.

Paramètres
string | $type1 | the column type
string | $type2 | the column attributes
Renvoie
string The original or changed column type.
Depuis
2.5

Références $result.

◆ fixQuote()

fixQuote ( $string )
private

Fixes up a string for inclusion in a query. Replaces name quote character with normal quote for literal. Drops trailing semicolon. Injects the database prefix.

Paramètres
string $string The input string to be cleaned up.
Renvoie
string The modified string.
Depuis
2.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlsrvChangeItem.php


Joomla CMS: Référence de la classe ChangeItem

  • Joomla
  • CMS
  • Schema
  • ChangeItem
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe ChangeItem
+ Graphe d'héritage de ChangeItem:
MysqlChangeItem PostgresqlChangeItem SqlsrvChangeItem

Fonctions membres publiques

__construct ($db, $file, $query)
check ()
fix ()

Fonctions membres publiques statiques

static getInstance ($db, $file, $query)

Champs de données

$file = null
$updateQuery = null
$checkQuery = null
$checkQueryExpected = 1
$db = null
$queryType = null
$msgElements = array()
$checkStatus = 0
$rerunStatus = 0

Fonctions membres protégées

buildCheckQuery ()

Description détaillée

Each object represents one query, which is one line from a DDL SQL query. This class is used to check the site's database to see if the DDL query has been run. If not, it provides the ability to fix the database by re-running the DDL query. The queries are parsed from the update files in the folder administrator/components/com_admin/sql/updates/<database>. These updates are run automatically if the site was updated using com_installer. However, it is possible that the program files could be updated without updating the database (for example, if a user just copies the new files over the top of an existing installation).

This is an abstract class. We need to extend it for each database and add a buildCheckQuery() method that creates the query to check that a DDL query has been run.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $db,
 |  | $file,
 |  | $query
 | ) |

Constructor: builds check query and message from $updateQuery

Paramètres
DatabaseDriver | $db | Database connector object
string | $file | Full path name of the sql file
string | $query | Text of the sql query (one line of the file)
Depuis
2.5

Références $db, et $query.

Documentation des fonctions membres

◆ buildCheckQuery()

buildCheckQuery ( )
abstractprotected

Checks a DDL query to see if it is a known type If yes, build a check query to see if the DDL has been run on the database. If successful, the $msgElements, $queryType, $checkStatus and $checkQuery fields are populated. The $msgElements contains the text to create the user message. The $checkQuery contains the SQL query to check whether the schema change has been run against the current database. The $queryType contains the type of DDL query that was run (for example, CREATE_TABLE, ADD_COLUMN, CHANGE_COLUMN_TYPE, ADD_INDEX). The $checkStatus field is set to zero if the query is created

If not successful, $checkQuery is empty and , and $checkStatus is -1. For example, this will happen if the current line is a non-DDL statement.

Renvoie
void
Depuis
2.5

◆ check()

check ( )

Runs the check query and checks that 1 row is returned

Renvoie
integer 1 if success, -1 if skipped, -2 if check failed
Depuis
2.5

Références $rows, et Factory\getApplication().

◆ fix()

fix ( )

Runs the update query to apply the change to the database

Renvoie
void
Depuis
2.5

Références $query.

◆ getInstance()

static getInstance | ( | $db,
 |  | $file,
 |  | $query
 | ) |
static

Returns a reference to the ChangeItem object.

Paramètres
DatabaseDriver | $db | Database connector object
string | $file | Full path name of the sql file
string | $query | Text of the sql query (one line of the file)
Renvoie
ChangeItem instance based on the database driver
Depuis
2.5
Exceptions

Références $class, $db, et $query.

Référencé par ChangeSet\__construct().

Documentation des champs

◆ $checkQuery

$checkQuery = null

◆ $checkQueryExpected

$checkQueryExpected = 1

◆ $checkStatus

$checkStatus = 0

◆ $db

$db = null

◆ $file

$file = null

◆ $msgElements

$msgElements = array()

◆ $queryType

$queryType = null

◆ $rerunStatus

$rerunStatus = 0

◆ $updateQuery

$updateQuery = null

Référencé par MysqlChangeItem\buildCheckQuery(), SqlsrvChangeItem\buildCheckQuery(), et PostgresqlChangeItem\buildCheckQuery().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ChangeItem.php


Joomla CMS: Référence de la classe ChangeSet

  • Joomla
  • CMS
  • Schema
  • ChangeSet
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe ChangeSet

Fonctions membres publiques

__construct ($db, $folder=null)
check ()
fix ()
getStatus ()
getSchema ()

Fonctions membres publiques statiques

static getInstance ($db, $folder=null)

Attributs protégés

$changeItems = array()
$db = null
$folder = null

Attributs protégés statiques

static $instance

Fonctions membres privées

getUpdateFiles ()
getUpdateQueries (array $sqlfiles)

Description détaillée

Contains a set of JSchemaChange objects for a particular instance of Joomla. Each of these objects contains a DDL query that should have been run against the database when this database was created or updated. This enables the Installation Manager to check that the current database schema is up to date.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $db,
 |  | $folder = null
 | ) |

Constructor: builds array of $changeItems by processing the .sql files in a folder. The folder for the Joomla core updates is administrator/components/com_admin/sql/updates/<database>.

Paramètres
DatabaseDriver | $db | The current database object
string | $folder | The full path to the folder containing the update queries
Depuis
2.5

Références $db, $folder, $rows, $this, et ChangeItem\getInstance().

Documentation des fonctions membres

◆ check()

check ( )

Checks the database and returns an array of any errors found. Note these are not database errors but rather situations where the current schema is not up to date.

Renvoie
array Array of errors if any.
Depuis
2.5

Références $item.

◆ fix()

fix ( )

Runs the update query to apply the change to the database

Renvoie
void
Depuis
2.5

Références $item.

◆ getInstance()

static getInstance | ( | $db,
 |  | $folder = null
 | ) |
static

Returns a reference to the ChangeSet object, only creating it if it doesn't already exist.

Paramètres
DatabaseDriver | $db | The current database object
string | $folder | The full path to the folder containing the update queries
Renvoie
ChangeSet
Depuis
2.5

Références $db, et $folder.

◆ getSchema()

getSchema ( )

Gets the current database schema, based on the highest version number. Note that the .sql files are named based on the version and date, so the file name of the last file should match the database schema version in the #__schemas table.

Renvoie
string the schema version for the database
Depuis
2.5

Références $result.

◆ getStatus()

getStatus ( )

Returns an array of results for this set

Renvoie
array associative array of changeitems grouped by unchecked, ok, error, and skipped
Depuis
2.5

Références $item, et $result.

◆ getUpdateFiles()

getUpdateFiles ( )
private

Get list of SQL update files for this database

Renvoie
array|boolean list of sql update full-path names. False if directory doesn't exist
Depuis
2.5

Références Folder\files(), et JPATH_ADMINISTRATOR.

◆ getUpdateQueries()

getUpdateQueries ( array $sqlfiles )
private

Get array of SQL queries

Paramètres
array $sqlfiles Array of .sql update filenames.
Renvoie
array Array of objects where: file=filename, update_query = text of SQL update query
Depuis
2.5

Références $buffer, $query, $result, et DatabaseDriver\splitSql().

Documentation des champs

◆ $changeItems

$changeItems = array()
protected

◆ $db

$db = null
protected

◆ $folder

$folder = null
protected

◆ $instance

$instance
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ChangeSet.php


Joomla CMS: Référence de la classe OnGetApiAttributes

  • Joomla
  • CMS
  • Serializer
  • Events
  • OnGetApiAttributes
Fonctions membres publiques | Attributs privés
Référence de la classe OnGetApiAttributes
+ Graphe d'héritage de OnGetApiAttributes:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
getAttributes ()
addAttribute ($name, $value)
addAttributes (array $value)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$attributes = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event for getting extra data attributes for an API Entity

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: attributes array The main data for the object. context string The content type of the api resource.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.0.0
Exceptions

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addAttribute()

addAttribute | ( | $name,
 |  | $value
 | ) |

Set a named attribute to be rendered in the API.

Paramètres
string | $name | The name of the property to be rendered in the api
mixed | $value | The value of the named property to be rendered in the api.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ addAttributes()

addAttributes ( array $value )

Set attributes to be rendered in the API.

Paramètres
array $value An array of key/value pairs for properties to be added to the api.
Renvoie
void
Depuis
4.0.0

Références $value.

◆ getAttributes()

getAttributes ( )

The properties to be rendered.

Renvoie
array
Depuis
4.0.0

Références $attributes.

Documentation des champs

◆ $attributes

$attributes = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OnGetApiAttributes.php


Joomla CMS: Référence de la classe OnGetApiRelation

  • Joomla
  • CMS
  • Serializer
  • Events
  • OnGetApiRelation
Fonctions membres publiques | Attributs privés
Référence de la classe OnGetApiRelation
+ Graphe d'héritage de OnGetApiRelation:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
getRelationship ()
setRelationship (Relationship $relationship)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$relationship

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event for getting information on an API Relationship

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Mandatory arguments: model mixed The model being used to render the resource. field string The field name we wish to obtain a relationship for. context string The content type of the api resource.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.0.0
Exceptions

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getRelationship()

getRelationship ( )

Get properties to render.

Renvoie
Relationship
Depuis
4.0.0

◆ setRelationship()

setRelationship ( Relationship $relationship )

Set relationship object that should be rendered.

Paramètres
Relationship $relationship The relationship object that should be rendered.
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $relationship

$relationship
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OnGetApiRelation.php


Joomla CMS: Référence de la classe JoomlaSerializer

  • Joomla
  • CMS
  • Serializer
  • JoomlaSerializer
Fonctions membres publiques
Référence de la classe JoomlaSerializer
+ Graphe d'héritage de JoomlaSerializer:
AbstractSerializer SerializerInterface ContactSerializer ContentSerializer NewsfeedSerializer

Fonctions membres publiques

__construct (string $type)
- Fonctions membres publiques hérités de AbstractSerializer
getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Membres hérités additionnels

- Attributs protégés hérités de AbstractSerializer
$type

Description détaillée

This class does the messy job of sanitising all the classes Joomla has that contain data and converting them into a standard array that can be consumed by the Tobscure library. It also throws appropriate plugin events to allow 3rd party extensions to add custom data and relations into these properties before they are rendered

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $type )

Constructor.

Paramètres
string $type The content type to be loaded
Depuis
4.0.0

Références $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • JoomlaSerializer.php


Joomla CMS: Référence de la classe Application

  • Joomla
  • CMS
  • Service
  • Provider
  • Application
Fonctions membres publiques
Référence de la classe Application
+ Graphe d'héritage de Application:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Application service provider

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $app, Factory\$application, $config, $container, $lang, class, AbstractCommand\getDefaultName(), null, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Application.php


Joomla CMS: Référence de la classe Authentication

  • Joomla
  • CMS
  • Service
  • Provider
  • Authentication
Fonctions membres publiques
Référence de la classe Authentication
+ Graphe d'héritage de Authentication:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the authentication dependencies

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, Argon2idHandler\isSupported(), Argon2iHandler\isSupported(), et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Authentication.php


Joomla CMS: Référence de la classe CacheController

  • Joomla
  • CMS
  • Service
  • Provider
  • CacheController
Fonctions membres publiques
Référence de la classe CacheController
+ Graphe d'héritage de CacheController:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the cache controller dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/CacheController.php


Joomla CMS: Référence de la classe Config

  • Joomla
  • CMS
  • Service
  • Provider
  • Config
Fonctions membres publiques
Référence de la classe Config
+ Graphe d'héritage de Config:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's config dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, JPATH_CONFIGURATION, JLoader\register(), et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Config.php


Joomla CMS: Référence de la classe Console

  • Joomla
  • CMS
  • Service
  • Provider
  • Console
Fonctions membres publiques
Référence de la classe Console
+ Graphe d'héritage de Console:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's console services

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Console.php


Joomla CMS: Référence de la classe Database

  • Joomla
  • CMS
  • Service
  • Provider
  • Database
Fonctions membres publiques
Référence de la classe Database
+ Graphe d'héritage de Database:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's database dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, $db, $options, $value, class, DatabaseDriver\getInstance(), MysqlDriver\isSupported(), JDEBUG, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Database.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • CMS
  • Service
  • Provider
  • Dispatcher
Fonctions membres publiques
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's event dispatcher dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Dispatcher.php


Joomla CMS: Référence de la classe Document

  • Joomla
  • CMS
  • Service
  • Provider
  • Document
Fonctions membres publiques
Référence de la classe Document
+ Graphe d'héritage de Document:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's document dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Service/Provider/Document.php


Joomla CMS: Référence de la classe Form

  • Joomla
  • CMS
  • Service
  • Provider
  • Form
Fonctions membres publiques
Référence de la classe Form
+ Graphe d'héritage de Form:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the form dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/Form.php


Joomla CMS: Référence de la classe HTMLRegistry

  • Joomla
  • CMS
  • Service
  • Provider
  • HTMLRegistry
Fonctions membres publiques
Référence de la classe HTMLRegistry
+ Graphe d'héritage de HTMLRegistry:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the HTML service registry

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HTMLRegistry.php


Joomla CMS: Référence de la classe Language

  • Joomla
  • CMS
  • Service
  • Provider
  • Language
Fonctions membres publiques
Référence de la classe Language
+ Graphe d'héritage de Language:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the language dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Language.php


Joomla CMS: Référence de la classe Logger

  • Joomla
  • CMS
  • Service
  • Provider
  • Logger
Fonctions membres publiques
Référence de la classe Logger
+ Graphe d'héritage de Logger:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's PSR-3 logger dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, Log\createDelegatedLogger(), et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/Logger.php


Joomla CMS: Référence de la classe Menu

  • Joomla
  • CMS
  • Service
  • Provider
  • Menu
Fonctions membres publiques
Référence de la classe Menu
+ Graphe d'héritage de Menu:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's menu dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Menu.php


Joomla CMS: Référence de la classe Pathway

  • Joomla
  • CMS
  • Service
  • Provider
  • Pathway
Fonctions membres publiques
Référence de la classe Pathway
+ Graphe d'héritage de Pathway:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's pathway dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/Pathway.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • CMS
  • Service
  • Provider
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's API router dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Service/Provider/Router.php


Joomla CMS: Référence de la classe Session

  • Joomla
  • CMS
  • Service
  • Provider
  • Session
Fonctions membres privées
Référence de la classe Session
+ Graphe d'héritage de Session:
ServiceProviderInterface

Fonctions membres privées

buildSession (StorageInterface $storage, CMSApplicationInterface $app, DispatcherInterface $dispatcher, array $options)
registerSessionHandlerAsService (Container $container, \SessionHandlerInterface $sessionHandler)

Membres hérités additionnels

- Fonctions membres publiques hérités de ServiceProviderInterface
register (Container $container)

Description détaillée

Service provider for the application's session dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ buildSession()

buildSession | ( | StorageInterface | $storage,
 |  | CMSApplicationInterface | $app,
 |  | DispatcherInterface | $dispatcher,
 |  | array | $options
 | ) |  |
private

Build the root session service

Paramètres
StorageInterface | $storage | The session storage engine.
CMSApplicationInterface | $app | The application instance.
DispatcherInterface | $dispatcher | The event dispatcher.
array | $options | The configured session options.
Renvoie
SessionInterface
Depuis
4.0.0

Références $app, $input, $options, DispatcherInterface\addListener(), Priority\HIGH, et SessionEvents\START.

◆ registerSessionHandlerAsService()

registerSessionHandlerAsService | ( | Container | $container,
 |  | \SessionHandlerInterface | $sessionHandler
 | ) |  |
private

Registers the session handler as a service

Paramètres
Container | $container | The container to register the service to.
\SessionHandlerInterface | $sessionHandler | The session handler.
Renvoie
void
Depuis
4.0.0

Références $container, et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Service/Provider/Session.php


Joomla CMS: Référence de la classe Toolbar

  • Joomla
  • CMS
  • Service
  • Provider
  • Toolbar
Fonctions membres publiques
Référence de la classe Toolbar
+ Graphe d'héritage de Toolbar:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's toolbar dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/Toolbar.php


Joomla CMS: Référence de la classe User

  • Joomla
  • CMS
  • Service
  • Provider
  • User
Fonctions membres publiques
Référence de la classe User
+ Graphe d'héritage de User:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the user dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/User.php


Joomla CMS: Référence de la classe WebAssetRegistry

  • Joomla
  • CMS
  • Service
  • Provider
  • WebAssetRegistry
Fonctions membres publiques
Référence de la classe WebAssetRegistry
+ Graphe d'héritage de WebAssetRegistry:
ServiceProviderInterface

Fonctions membres publiques

register (Container $container)

Description détaillée

Service provider for the application's WebAsset dependency

Depuis
4.0.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Implémente ServiceProviderInterface.

Références $container, class, et true.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Service/Provider/WebAssetRegistry.php


Joomla CMS: Référence de la classe MetadataManagerListener

  • Joomla
  • CMS
  • Session
  • EventListener
  • MetadataManagerListener
Fonctions membres publiques | Attributs privés
Référence de la classe MetadataManagerListener

Fonctions membres publiques

__construct (MetadataManager $metadataManager, Registry $config)
onAfterSessionStart (SessionEvent $event)

Attributs privés

$metadataManager
$config

Description détaillée

Event listener for session events regarding the session metadata for users.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | MetadataManager | $metadataManager,
 |  | Registry | $config
 | ) |  |

Constructor.

Paramètres
MetadataManager | $metadataManager | Session metadata manager.
Registry | $config | Application configuration.
Depuis
4.0.0

Références $config.

Documentation des fonctions membres

◆ onAfterSessionStart()

onAfterSessionStart ( SessionEvent $event )

Listener for the session.start event.

Paramètres
SessionEvent $event The session event.
Renvoie
void
Depuis
4.0.0

Références $user, et SessionEvent\getSession().

Documentation des champs

◆ $config

$config
private

◆ $metadataManager

$metadataManager
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataManagerListener.php


Joomla CMS: Référence de la classe UnsupportedStorageException

  • Joomla
  • CMS
  • Session
  • Exception
  • UnsupportedStorageException
Référence de la classe UnsupportedStorageException
+ Graphe d'héritage de UnsupportedStorageException:

Description détaillée

Exception class defining an unsupported session storage object

Depuis
3.6.3
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedStorageException.php


Joomla CMS: Référence de la classe JoomlaStorage

  • Joomla
  • CMS
  • Session
  • Storage
  • JoomlaStorage
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe JoomlaStorage
+ Graphe d'héritage de JoomlaStorage:
NativeStorage StorageInterface

Fonctions membres publiques

__construct (Input $input, \SessionHandlerInterface $handler=null, array $options=[])
all ()
clear ()
close ()
get (string $name, $default)
has (string $name)
remove (string $name)
set (string $name, $value=null)
setOptions (array $options)
start ()
- Fonctions membres publiques hérités de NativeStorage
__construct (?\SessionHandlerInterface $handler=null, array $options=[])
all ()
clear ()
close ()
gc ()
abort ()
get (string $name, $default)
getHandler ()
getId ()
getName ()
has (string $name)
isActive ()
isStarted ()
remove (string $name)
regenerate (bool $destroy=false)
set (string $name, $value=null)
setHandler (?\SessionHandlerInterface $handler=null)
setId (string $id)
setName (string $name)
setOptions (array $options)
start ()

Fonctions membres protégées

setCookieParams ()

Attributs privés

$data
$forceSSL = false
$input

Description détaillée

Service provider for the application's session dependency

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input,
 |  | \SessionHandlerInterface | $handler = null,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
Input | $input | Input object
\SessionHandlerInterface | $handler | Session save handler
array | $options | Session options
Depuis
4.0.0

Références $input, $options, $this, Session\isActive(), et Session\setOptions().

Documentation des fonctions membres

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array
Depuis
4.0.0

Implémente StorageInterface.

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
4.0.0

Implémente StorageInterface.

Références $app, Factory\getApplication(), et Session\getName().

◆ close()

close ( )

Writes session data and ends session

Renvoie
void
Voir également
session_write_close()
Depuis
4.0.0

Implémente StorageInterface.

◆ get()

get | ( | string | $name,
 |  |  | $default
 | ) |  |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
4.0.0

Implémente StorageInterface.

Références $default, $name, Session\isStarted(), et Session\start().

◆ has()

has ( string $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean True if the variable exists
Depuis
4.0.0

Implémente StorageInterface.

Références $name, Session\isStarted(), et Session\start().

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
4.0.0

Implémente StorageInterface.

Références $name, Session\isStarted(), et Session\start().

◆ set()

set | ( | string | $name,
 |  |  | $value = null
 | ) |  |

Set data into the session store

Paramètres
string | $name | Name of a variable.
mixed | $value | Value of a variable.
Renvoie
mixed Old value of a variable.
Depuis
4.0.0

Implémente StorageInterface.

Références $name, $value, Session\isStarted(), et Session\start().

◆ setCookieParams()

setCookieParams ( )
protected

Set session cookie parameters

Renvoie
void
Depuis
4.0.0

Références $app, Factory\getApplication(), et Session\isActive().

◆ setOptions()

setOptions ( array $options )

Sets session options

Paramètres
array $options Session ini directives array(key => value).
Renvoie
$this
Voir également
http://php.net/session.configuration
Depuis
4.0.0

Références $options.

◆ start()

start ( )

Start a session

Renvoie
void
Depuis
4.0.0

Implémente StorageInterface.

Références Session\getName(), et Session\setId().

Documentation des champs

◆ $data

$data
private

◆ $forceSSL

$forceSSL = false
private

◆ $input

$input
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • JoomlaStorage.php


Joomla CMS: Référence de la classe MetadataManager

  • Joomla
  • CMS
  • Session
  • MetadataManager
Fonctions membres publiques | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe MetadataManager

Fonctions membres publiques

__construct (AbstractApplication $app, DatabaseInterface $db)
createRecordIfNonExisting (SessionInterface $session, User $user)
createOrUpdateRecord (SessionInterface $session, User $user)
deletePriorTo ($time)

Fonctions membres privées

checkSessionRecordExists (string $sessionId)
createSessionRecord (SessionInterface $session, User $user)
updateSessionRecord (SessionInterface $session, User $user)

Attributs privés

$app
$db

Attributs privés statiques

static | $sessionRecordExists = 1
static | $sessionRecordDoesNotExist = 0
static | $sessionRecordUnknown = -1

Description détaillée

Manager for optional session metadata.

Depuis
3.8.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AbstractApplication | $app,
 |  | DatabaseInterface | $db
 | ) |  |

MetadataManager constructor.

Paramètres
AbstractApplication | $app | Application object.
DatabaseInterface | $db | Database driver.
Depuis
3.8.6

Références $app, et $db.

Documentation des fonctions membres

◆ checkSessionRecordExists()

checkSessionRecordExists ( string $sessionId )
private

Check if the session record exists

Paramètres
string $sessionId The session ID to check
Renvoie
integer Status value for record presence
Depuis
4.0.0

Références $query.

◆ createOrUpdateRecord()

createOrUpdateRecord | ( | SessionInterface | $session,
 |  | User | $user
 | ) |  |

Create the metadata record if it does not exist.

Paramètres
SessionInterface | $session | The session to create or update the metadata record for.
User | $user | The user to associate with the record.
Renvoie
void
Depuis
4.0.0
Exceptions

Références $user, et SessionInterface\getId().

◆ createRecordIfNonExisting()

createRecordIfNonExisting | ( | SessionInterface | $session,
 |  | User | $user
 | ) |  |

Create the metadata record if it does not exist.

Paramètres
SessionInterface | $session | The session to create the metadata record for.
User | $user | The user to associate with the record.
Renvoie
void
Depuis
3.8.6
Exceptions

Références $user, et SessionInterface\getId().

◆ createSessionRecord()

createSessionRecord | ( | SessionInterface | $session,
 |  | User | $user
 | ) |  |
private

Create the session record

Paramètres
SessionInterface | $session | The session to create the metadata record for.
User | $user | The user to associate with the record.
Renvoie
void
Depuis
4.0.0

Références $clientId, $columns, $query, $user, $userId, SessionInterface\get(), AbstractApplication\get(), SessionInterface\getId(), ParameterType\INTEGER, SessionInterface\isNew(), et null.

◆ deletePriorTo()

deletePriorTo ( $time )

Delete records with a timestamp prior to the given time.

Paramètres
integer $time The time records should be deleted if expired before.
Renvoie
void
Depuis
3.8.6

Références $query, et ParameterType\INTEGER.

◆ updateSessionRecord()

updateSessionRecord | ( | SessionInterface | $session,
 |  | User | $user
 | ) |  |
private

Update the session record

Paramètres
SessionInterface | $session | The session to update the metadata record for.
User | $user | The user to associate with the record.
Renvoie
void
Depuis
4.0.0

Références $clientId, $query, $user, $userId, AbstractApplication\get(), SessionInterface\getId(), ParameterType\INTEGER, et null.

Documentation des champs

◆ $app

$app
private

◆ $db

$db
private

◆ $sessionRecordDoesNotExist

$sessionRecordDoesNotExist = 0
staticprivate

◆ $sessionRecordExists

$sessionRecordExists = 1
staticprivate

◆ $sessionRecordUnknown

$sessionRecordUnknown = -1
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataManager.php


Joomla CMS: Référence de la classe Session

  • Joomla
  • CMS
  • Session
  • Session
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Session
+ Graphe d'héritage de Session:
Session SessionInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (StorageInterface $store=null, DispatcherInterface $dispatcher=null, array $options=[])
get ($name, $default=null)
set ($name, $value=null)
has ($name)
clear ()
- Fonctions membres publiques hérités de Session
__construct (StorageInterface $store=null, DispatcherInterface $dispatcher=null, array $options=[])
addValidator (ValidatorInterface $validator)
getExpire ()
getState ()
getToken ($forceNew=false)
hasToken ($token, $forceExpire=true)
getIterator ()
getName ()
setName (string $name)
getId ()
setId (string $id)
isActive ()
isNew ()
isStarted ()
get ($name, $default=null)
set ($name, $value=null)
has ($name)
remove (string $name)
clear ()
all ()
start ()
destroy ()
restart ()
fork ($destroy=false)
close ()
gc ()
abort ()
- Fonctions membres publiques hérités de SessionInterface
fork ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | checkToken ($method='post')
static | getFormToken ($forceNew=false)
static | getHandlers ()
static | getInstance ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Session
createToken ()
setCounter ()
setExpire ($expire)
setState ($state)
setTimers ()
setOptions (array $options)
validate ($restart=false)
- Attributs protégés hérités de Session
$state = SessionState::INACTIVE
$expire = 900
$store
$sessionValidators = []

Description détaillée

Class for managing HTTP sessions

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | StorageInterface | $store = null,
 |  | DispatcherInterface | $dispatcher = null,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
StorageInterface | $store | A StorageInterface implementation.
DispatcherInterface | $dispatcher | DispatcherInterface for the session to use.
array $options Optional parameters. Supported keys include:
  • name: The session name
  • id: The session ID
  • expire: The session lifetime in seconds
Depuis
1.0

Références $options, Session\$store, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ checkToken()

static checkToken ( $method = 'post' )
static

Checks for a form token in the request.

Use in conjunction with HTMLHelper::_('form.token') or JSession::getFormToken.

Paramètres
string $method The request method in which to look for the token key.
Renvoie
boolean True if found and valid, false otherwise.
Depuis
2.5.4

Références $app, Text\_(), Route\_(), Factory\getApplication(), et Joomla\Application\getFormToken().

Référencé par InstallController\ajax_upload(), IndexerController\batch(), BaseController\checkToken(), JSONController\checkValidToken(), ApiController\execute(), AjaxController\fetchAssociations(), IndexerController\optimize(), ModuleController\orderPosition(), SearchesController\reset(), et IndexerController\start().

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
1.5

Implémente SessionInterface.

Références $name, et Joomla\Database\Query\clear().

◆ get()

get | ( | $name,
 |  | $default = null
 | ) |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
1.5

Implémente SessionInterface.

Références $default, $name, Symfony\Contracts\Service\get(), et Symfony\Contracts\Service\has().

◆ getFormToken()

static getFormToken ( $forceNew = false )
static

Method to determine a hash for anti-spoofing variable names

Paramètres
boolean $forceNew If true, force a new token to be created
Renvoie
string Hashed var name
Depuis
1.6

Références $user, Factory\getApplication(), ApplicationHelper\getHash(), et Factory\getUser().

Référencé par JsonResponse\__construct(), HtmlView\addToolbar(), DraggableList\draggable(), Joomlaupdate\getCoreUpdateNotification(), AssociationField\getInput(), ContenthistoryField\getLayoutData(), ModuleorderField\getLayoutData(), LoggedHelper\getList(), HistoryController\getRedirectToListAppend(), Cache\getWorkarounds(), HistoryController\keep(), UserController\menulogout(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), AdministratorApplication\render(), JSONController\sendJsonResponse(), et Form\token().

◆ getHandlers()

static getHandlers ( )
static

Get the available session handlers

Renvoie
array An array of available session handlers
Depuis
4.0.0

Références $class, et JPATH_LIBRARIES.

Référencé par SessionhandlerField\getOptions().

◆ getInstance()

static getInstance ( )
static

Returns the global session object.

Renvoie
static The Session object.
Depuis
1.5
Obsolète:
5.0 Load the session service from the dependency injection container or via $app->getSession()

Références Factory\getApplication().

◆ has()

has ( $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean True if the variable exists
Depuis
1.5

Implémente SessionInterface.

Références $name, et Symfony\Contracts\Service\has().

◆ set()

set | ( | $name,
 |  | $value = null
 | ) |

Set data into the session store.

Paramètres
string | $name | Name of a variable.
mixed | $value | Value of a variable.
Renvoie
mixed Old value of a variable.
Depuis
1.5

Implémente SessionInterface.

Références $name, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Session/Session.php


Joomla CMS: Référence de la classe SessionFactory

  • Joomla
  • CMS
  • Session
  • SessionFactory
Fonctions membres protégées
Référence de la classe SessionFactory
+ Graphe d'héritage de SessionFactory:
ContainerAwareInterface

Fonctions membres protégées

configureSessionHandlerOptions (OptionsResolver $resolver)

Membres hérités additionnels

- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)

Description détaillée

Factory for creating session API objects

Depuis
4.0.0

Documentation des fonctions membres

◆ configureSessionHandlerOptions()

configureSessionHandlerOptions ( OptionsResolver $resolver )
protected

Resolve the options for the session handler.

Paramètres
OptionsResolver $resolver The options resolver.
Renvoie
void
Depuis
4.0.0

Références OptionsResolver\setAllowedTypes(), OptionsResolver\setDefaults(), et OptionsResolver\setRequired().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionFactory.php


Joomla CMS: Référence de la classe SessionManager

  • Joomla
  • CMS
  • Session
  • SessionManager
Fonctions membres publiques | Attributs privés
Référence de la classe SessionManager

Fonctions membres publiques

__construct (\SessionHandlerInterface $sessionHandler)
destroySession (string $sessionId)
destroySessions (array $sessionIds)

Attributs privés

$sessionHandler

Description détaillée

Manager for interacting with the session handler to perform updates on sessions.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \SessionHandlerInterface $sessionHandler )

SessionManager constructor.

Paramètres
\SessionHandlerInterface $sessionHandler Session handler.
Depuis
4.0.0

Documentation des fonctions membres

◆ destroySession()

destroySession ( string $sessionId )

Destroys the given session ID.

Paramètres
string $sessionId The session ID to destroy.
Renvoie
boolean
Depuis
4.0.0

◆ destroySessions()

destroySessions ( array $sessionIds )

Destroys the given session IDs.

Paramètres
string[] $sessionIds The session IDs to destroy.
Renvoie
boolean
Depuis
4.0.0

Références $result.

Documentation des champs

◆ $sessionHandler

$sessionHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionManager.php


Joomla CMS: Référence de la classe PunycodeHelper

  • Joomla
  • CMS
  • String
  • PunycodeHelper
Fonctions membres publiques statiques
Référence de la classe PunycodeHelper

Fonctions membres publiques statiques

static | toPunycode ($utfString)
static | fromPunycode ($punycodeString)
static | urlToPunycode ($uri)
static | urlToUTF8 ($uri)
static | emailToPunycode ($email)
static | emailToUTF8 ($email)

Description détaillée

Joomla Platform String Punycode Class

Class for handling UTF-8 URLs Wraps the Punycode library All functions assume the validity of utf-8 URLs.

Depuis
3.1.2

Documentation des fonctions membres

◆ emailToPunycode()

static emailToPunycode ( $email )
static

Transforms a UTF-8 email to a Punycode email This assumes a valid email address

Paramètres
string $email The UTF-8 email to transform
Renvoie
string The punycode email
Depuis
3.1.2

Référencé par ContactController\_sendEmail(), User\check(), MailHelper\cleanLine(), InputFilter\emailToPunycode(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), RegistrationModel\register(), ProfileModel\save(), ContactTable\store(), et EmailRule\test().

◆ emailToUTF8()

static emailToUTF8 ( $email )
static

Transforms a Punycode email to a UTF-8 email This assumes a valid email address

Paramètres
string $email The punycode email to transform
Renvoie
string The punycode email
Depuis
3.1.2

Référencé par Email\cloak(), et User\load().

◆ fromPunycode()

static fromPunycode ( $punycodeString )
static

Transforms a Punycode string to a UTF-8 string

Paramètres
string $punycodeString The Punycode string to transform
Renvoie
string The UF-8 URL
Depuis
3.1.2

◆ toPunycode()

static toPunycode ( $utfString )
static

Transforms a UTF-8 string to a Punycode string

Paramètres
string $utfString The UTF-8 string to transform
Renvoie
string The punycode string
Depuis
3.1.2

Référencé par LocalAdapter\getSafeName(), et MailHelper\isEmailAddress().

◆ urlToPunycode()

static urlToPunycode ( $uri )
static

Transforms a UTF-8 URL to a Punycode URL

Paramètres
string $uri The UTF-8 URL to transform
Renvoie
string The punycode URL
Depuis
3.1.2

Références $uri, et UriHelper\parse_url().

Référencé par UrlFilter\filter(), ContactTable\store(), et NewsfeedTable\store().

◆ urlToUTF8()

static urlToUTF8 ( $uri )
static

Transforms a Punycode URL to a UTF-8 URL

Paramètres
string $uri The Punycode URL to transform
Renvoie
string The UTF-8 URL
Depuis
3.1.2

Références $uri, et UriHelper\parse_url().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PunycodeHelper.php


Joomla CMS: Référence de la classe Asset

  • Joomla
  • CMS
  • Table
  • Asset
Fonctions membres publiques | Champs de données
Référence de la classe Asset
+ Graphe d'héritage de Asset:
Nested Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
loadByName ($name)
check ()
rebuild ($parentId=null, $leftId=0, $level=0, $path=null)
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$id = null
$name = null
$title = null
$rules = null
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Table class supporting modified pre-order tree traversal behavior.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Assert that the nested set data is valid.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Depuis
1.7.0

Implémente TableInterface.

Références $query, $this, et Text\_().

◆ loadByName()

loadByName ( $name )

Method to load an asset by its name.

Paramètres
string $name The name of the asset.
Renvoie
integer
Depuis
1.7.0

Références $name.

◆ rebuild()

rebuild | ( | $parentId = null,
 |  | $leftId = 0,
 |  | $level = 0,
 |  | $path = null
 | ) |

Method to recursively rebuild the whole nested set tree.

Paramètres
integer | $parentId | The root of the tree to rebuild.
integer | $leftId | The left id to start with in building the tree.
integer | $level | The level to assign to the current nodes.
string | $path | The path to the current nodes.
Renvoie
integer 1 + value of root rgt on success, false on failure
Depuis
3.5
Exceptions

Références $query, $this, et null.

Documentation des champs

◆ $id

$id = null

◆ $name

$name = null

◆ $rules

$rules = null

◆ $title

$title = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • Asset.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • CMS
  • Table
  • Category
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Category
+ Graphe d'héritage de Category:
Nested VersionableTableInterface TaggableTableInterface Table TableInterface TableInterface CMSObject TableInterface DispatcherAwareInterface CategoryTable

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
bind ($array, $ignore='')
store ($updateNulls=true)
getTypeAlias ()
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Category table

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.5

Références $db, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
1.6

Références extension.

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Get the parent asset id for the record

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | The id for the asset
Renvoie
integer The id of the asset's parent
Depuis
1.6

Références $assetId, $id, $query, $result, elseif, extension, ParameterType\INTEGER, et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
1.6

Références $title.

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Overloaded bind function.

Paramètres
array | $array | named array
string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
mixed Null if operation was satisfactory, otherwise returns an error
Voir également
Table::bind()
Depuis
1.6

Implémente TableInterface.

◆ check()

check ( )

Override check function

Renvoie
boolean
Voir également
Table::check()
Depuis
1.5

Implémente TableInterface.

Références $title, Text\_(), Factory\getDate(), language, et ApplicationHelper\stringURLSafe().

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente TaggableTableInterface.

Références extension.

◆ store()

store ( $updateNulls = true )

Overridden Table::store to set created/modified and user id.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $date, $user, Text\_(), extension, Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), et Factory\getUser().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Table/Category.php


Joomla CMS: Référence de la classe Content

  • Joomla
  • CMS
  • Table
  • Content
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Content
+ Graphe d'héritage de Content:
Table VersionableTableInterface TaggableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface TableInterface ArticleTable

Fonctions membres publiques

__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
store ($updateNulls=true)
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Content table

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object
Depuis
1.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
1.6

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset id for the record

Paramètres
Table | $table | A Table object (optional) for the asset parent
integer | $id | The id (optional) of the content.
Renvoie
integer
Depuis
1.6

Références $assetId, $id, $query, $result, ParameterType\INTEGER, et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
1.6

Références $title.

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Overloaded bind function

Paramètres
array | $array | Named array
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
mixed Null if operation was satisfactory, otherwise returns an error string
Voir également
Table::bind()
Depuis
1.6

Implémente TableInterface.

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success, false on failure
Voir également
Table::check()
Depuis
1.5

Ensure any new items have compulsory fields set. This is needed for things like frontend editing where we don't show all the fields or using some kind of API

Implémente TableInterface.

Références $key, $temp, $title, Text\_(), Factory\getDate(), hits, language, null, StringHelper\str_ireplace(), et ApplicationHelper\stringURLSafe().

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for UCM features

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente TaggableTableInterface.

◆ store()

store ( $updateNulls = true )

Overrides Table::store to set modified data and user id.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $date, $user, Text\_(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), et Factory\getUser().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Table/Content.php


Joomla CMS: Référence de la classe ContentHistory

  • Joomla
  • CMS
  • Table
  • ContentHistory
Fonctions membres publiques | Champs de données
Référence de la classe ContentHistory
+ Graphe d'héritage de ContentHistory:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=false)
getSha1 ($jsonData, ContentType $typeTable)
getHashMatch ()
deleteOldVersions ($maxVersions)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$ignoreChanges = array()
$convertToInt = array()
- Champs de données hérités de Table
$typeAlias = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Content History table.

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object
Depuis
3.1

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ deleteOldVersions()

deleteOldVersions ( $maxVersions )

Utility method to remove the oldest versions of an item, saving only the most recent versions.

Paramètres
integer $maxVersions The maximum number of versions to save. All others will be deleted.
Renvoie
boolean true on success, false on failure.
Depuis
3.2

Références $db, $itemId, $query, $result, et ParameterType\STRING.

◆ getHashMatch()

getHashMatch ( )

Utility method to get a matching row based on the hash value and id columns. This lets us check to make sure we don't save duplicate versions.

Renvoie
string SHA1 hash on success. Empty string on failure.
Depuis
3.2

Références $db, $itemId, $query, et ParameterType\STRING.

◆ getSha1()

getSha1 | ( |  | $jsonData,
 |  | ContentType | $typeTable
 | ) |  |

Utility method to get the hash after removing selected values. This lets us detect changes other than modified date (which will change on every save).

Paramètres
mixed | $jsonData | Either an object or a string with json-encoded data
ContentType | $typeTable | Table object with data for this content type
Renvoie
string SHA1 hash on success. Empty string on failure.
Depuis
3.2

Références $name, $options, $value, et null.

◆ store()

store ( $updateNulls = false )

Overrides Table::store to set modified hash, user id, and save date.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.2

Implémente TableInterface.

Références Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), Factory\getUser(), et null.

Documentation des champs

◆ $convertToInt

$convertToInt = array()

◆ $ignoreChanges

$ignoreChanges = array()
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentHistory.php


Joomla CMS: Référence de la classe ContentType

  • Joomla
  • CMS
  • Table
  • ContentType
Fonctions membres publiques
Référence de la classe ContentType
+ Graphe d'héritage de ContentType:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=false)
fieldmapExpand ($assoc=true)
getTypeId ($typeAlias)
getContentTable ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Tags table

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object
Depuis
3.1

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check method to ensure data integrity.

Renvoie
boolean True on success.
Depuis
3.1
Exceptions

Implémente TableInterface.

◆ fieldmapExpand()

fieldmapExpand ( $assoc = true )

Method to expand the field mapping

Paramètres
boolean $assoc True to return an associative array.
Renvoie
mixed Array or object with field mappings. Defaults to object.
Depuis
3.1

Références $assoc.

◆ getContentTable()

getContentTable ( )

Method to get the Table object for the content type from the table object.

Renvoie
mixed Table object on success, otherwise false.
Depuis
3.2
Exceptions

Références $class, et $result.

◆ getTypeId()

getTypeId ( $typeAlias )

Method to get the id given the type alias

Paramètres
string $typeAlias Content type alias (for example, 'com_content.article').
Renvoie
mixed type_id for this alias if successful, otherwise null.
Depuis
3.2

Références $db, $query, et $this.

◆ store()

store ( $updateNulls = false )

Overridden Table::store.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.1

Implémente TableInterface.

Références Text\_(), Joomla\CMS\MVC\Model\getDbo(), et Table\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentType.php


Joomla CMS: Référence de la classe CoreContent

  • Joomla
  • CMS
  • Table
  • CoreContent
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CoreContent
+ Graphe d'héritage de CoreContent:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
delete ($pk=null)
deleteByContentId ($contentItemId=null, $typeAlias=null)
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

storeUcmBase ($updateNulls=true, $isNew=false)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
$_jsonEncode = ['core_params', 'core_metadata', 'core_images', 'core_urls', 'core_body']
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Core content table

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object
Depuis
3.1

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success, false on failure
Voir également
Table::check()
Depuis
3.1

Implémente TableInterface.

Références $key, $temp, Text\_(), Factory\getDate(), null, StringHelper\str_ireplace(), et ApplicationHelper\stringURLSafe().

◆ delete()

delete ( $pk = null )

Override JTable delete method to include deleting corresponding row from #__ucm_base.

Paramètres
integer $pk primary key value to delete. Must be set or throws an exception.
Renvoie
boolean True on success.
Depuis
3.1
Exceptions

Implémente TableInterface.

Références Joomla\CMS\MVC\Model\getDbo(), et Table\getInstance().

◆ deleteByContentId()

deleteByContentId | ( | $contentItemId = null,
 |  | $typeAlias = null
 | ) |

Method to delete a row from the #__ucm_content table by content_item_id.

Paramètres
integer | $contentItemId | value of the core_content_item_id to delete. Corresponds to the primary key of the content table.
string | $typeAlias | Alias for the content type
Renvoie
boolean True on success.
Depuis
3.1
Exceptions

Références $db, $query, Joomla\CMS\MVC\Model\getDbo(), ParameterType\INTEGER, et null.

◆ store()

store ( $updateNulls = true )

Overrides Table::store to set modified data and user id.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.1

Implémente TableInterface.

Références $date, $result, $user, Factory\getDate(), et Factory\getUser().

◆ storeUcmBase()

storeUcmBase | ( | $updateNulls = true,
 |  | $isNew = false
 | ) |
protected

Insert or update row in ucm_base table

Paramètres
boolean | $updateNulls | True to update fields even if they are null.
boolean | $isNew | if true, need to insert. Otherwise update.
Renvoie
boolean True on success.
Depuis
3.1

Références $db, $query, $this, Joomla\CMS\MVC\Model\getDbo(), ContentHelper\getLanguageId(), et ParameterType\INTEGER.

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['core_params', 'core_metadata', 'core_images', 'core_urls', 'core_body']
protected

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CoreContent.php


Joomla CMS: Référence de la classe Extension

  • Joomla
  • CMS
  • Table
  • Extension
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe Extension
+ Graphe d'héritage de Extension:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
find ($options=array())
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$custom_data = ''
- Champs de données hérités de Table
$typeAlias = null

Attributs protégés

$_supportNullValue = true
$_jsonEncode = ['params']
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Extension table

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True if the object is ok
Voir également
Table::check()
Depuis
1.7.0

Implémente TableInterface.

Références Text\_(), et name.

◆ find()

find ( $options = array() )

Method to create and execute a SELECT WHERE query.

Paramètres
array $options Array of options
Renvoie
string The database query result
Depuis
1.7.0

Références $options, $query, et $val.

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['params']
protected

◆ $_supportNullValue

$_supportNullValue = true
protected

◆ $custom_data

$custom_data = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Table/Extension.php


Joomla CMS: Référence de la classe Language

  • Joomla
  • CMS
  • Table
  • Language
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Language
+ Graphe d'héritage de Language:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Languages table.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
3.8.0

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset under which to register this one. By default, all assets are registered to the ROOT node with ID, which will default to 1 if none exists. The extended class can define a table and id to lookup. If the asset does not exist it will be created.

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | Id to look up
Renvoie
integer
Depuis
3.8.0

Références $assetId, $id, Table\getInstance(), et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
3.8.0

Références $title.

◆ check()

check ( )

Overloaded check method to ensure data integrity

Renvoie
boolean True on success
Depuis
1.7.0

Implémente TableInterface.

Références Text\_().

◆ store()

store ( $updateNulls = false )

Overrides Table::store to check unique fields.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
2.5.0

Implémente TableInterface.

Références Text\_(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), et image.

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Table/Language.php


Joomla CMS: Référence de la classe Menu

  • Joomla
  • CMS
  • Table
  • Menu
Fonctions membres publiques | Attributs protégés
Référence de la classe Menu
+ Graphe d'héritage de Menu:
Nested Table CMSObject TableInterface DispatcherAwareInterface MenuTable

Fonctions membres publiques

__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
store ($updateNulls=true)
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Menu table

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.5

Références $db, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Overloaded bind function

Paramètres
array | $array | Named array
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
mixed Null if operation was satisfactory, otherwise returns an error
Voir également
Table::bind()
Depuis
1.5

Implémente TableInterface.

Références Text\_(), et language.

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success
Voir également
Table::check()
Depuis
1.5

Implémente TableInterface.

Références Text\_(), null, et path.

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
1.6

Implémente TableInterface.

Références $db, $id, $language, $query, $this, Text\_(), elseif, Folder\folders(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), ParameterType\INTEGER, Multilanguage\isEnabled(), JPATH_ROOT, language, null, Text\sprintf(), et ApplicationHelper\stringURLSafe().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/src/Table/Menu.php


Joomla CMS: Référence de la classe MenuType

  • Joomla
  • CMS
  • Table
  • MenuType
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MenuType
+ Graphe d'héritage de MenuType:
Table CMSObject TableInterface DispatcherAwareInterface MenuTypeTable

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=false)
delete ($pk=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Menu Types table

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.6

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
3.6

Références $id.

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset under which to register this one. By default, all assets are registered to the ROOT node with ID, which will default to 1 if none exists. The extended class can define a table and id to lookup. If the asset does not exist it will be created.

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | Id to look up
Renvoie
integer
Depuis
3.6

Références $assetId, $id, Table\getInstance(), et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
3.6

Références $title.

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success, false on failure
Voir également
Table::check()
Depuis
1.6

Implémente TableInterface.

Références $id, $menutype, $query, Text\_(), ParameterType\INTEGER, Text\sprintf(), et ApplicationHelper\stringURLSafe().

◆ delete()

delete ( $pk = null )

Method to delete a row from the database table by primary key value.

Paramètres
mixed $pk An optional primary key value to delete. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $query, $star, $this, $userId, Text\_(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), Factory\getUser(), ParameterType\INTEGER, null, et Text\sprintf().

◆ store()

store ( $updateNulls = false )

Method to store a row in the database from the Table instance properties.

If a primary key value is set the row with that primary key value will be updated with the instance property values. If no primary key value is set a new row will be inserted into the database with the properties from the Table instance.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $query, $this, $userId, Text\_(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), Factory\getUser(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuType.php


Joomla CMS: Référence de la classe Module

  • Joomla
  • CMS
  • Table
  • Module
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Module
+ Graphe d'héritage de Module:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
bind ($array, $ignore='')
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Module table

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor.

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.5

Références $db, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
3.2

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset id for the record

Paramètres
Table | $table | A Table object (optional) for the asset parent
integer | $id | The id (optional) of the content.
Renvoie
integer
Depuis
3.2

Références $assetId, $id, $query, $result, et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
3.2

Références $title.

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Overloaded bind function.

Paramètres
array | $array | Named array.
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
mixed Null if operation was satisfactory, otherwise returns an error
Voir également
Table::bind()
Depuis
1.5

Implémente TableInterface.

◆ check()

check ( )

Overloaded check function.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Voir également
Table::check()
Depuis
1.5

Implémente TableInterface.

Références $temp, Text\_(), content, et null.

◆ store()

store ( $updateNulls = true )

Stores a module.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success, false on failure.
Depuis
3.7.0

Implémente TableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Table/Module.php


Joomla CMS: Référence de la classe Nested

  • Joomla
  • CMS
  • Table
  • Nested
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Attributs privés
Référence de la classe Nested
+ Graphe d'héritage de Nested:
Table CMSObject TableInterface DispatcherAwareInterface Asset Category Menu MapTable TagTable CategoryTable MenuTable

Fonctions membres publiques

debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null

Fonctions membres protégées

recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs protégés statiques

static $root_id = 0

Attributs privés

$_validLocations = array('before', 'after', 'first-child', 'last-child')

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)

Description détaillée

Table class supporting modified pre-order tree traversal behavior.

Depuis
1.7.0

Documentation des fonctions membres

◆ _getNode()

_getNode | ( | $id,
 |  | $key = null
 | ) |
protected

Method to get nested set properties for a node in the tree.

Paramètres
integer | $id | Value to look up the node by.
string | $key | An optional key to look up the node by (parent | left | right). If omitted, the primary key of the table is used.
Renvoie
mixed Boolean false on failure or node object on success.
Depuis
1.7.0
Exceptions

Références $id, $key, $query, et $this.

◆ _getTreeRepositionData()

_getTreeRepositionData | ( | $referenceNode,
 |  | $nodeWidth,
 |  | $position = 'before'
 | ) |
protected

Method to get various data necessary to make room in the tree at a location for a node and its children. The returned data object includes conditions for SQL WHERE clauses for updating left and right id values to make room for the node as well as the new left and right ids for the node.

Paramètres
object | $referenceNode | A node object with at least a 'lft' and 'rgt' with which to make room in the tree around for a new node.
integer | $nodeWidth | The width of the node for which to make room in the tree.
string | $position | The position relative to the reference node where the room should be made.
Renvoie
mixed Boolean false on failure or data object on success.
Depuis
1.7.0

Références $data, et $position.

◆ _logtable()

_logtable | ( | $showData = true,
 |  | $showQuery = true
 | ) |
protected

Method to create a log table in the buffer optionally showing the query and/or data.

Paramètres
boolean | $showData | True to show data
boolean | $showQuery | True to show query
Renvoie
void
Depuis
1.7.0

Références $buffer, $query, $rows, et ENT_QUOTES.

◆ _runQuery()

_runQuery | ( | $query,
 |  | $errorMessage
 | ) |
protected

Runs a query and unlocks the database on an error.

Paramètres
mixed | $query | A string or DatabaseQuery object.
string | $errorMessage | Unused.
Renvoie
void
Note
Since 3.0.0 this method returns void and will rethrow the database exception.
Depuis
1.7.0
Exceptions

Références $query.

◆ check()

check ( )

Checks that the object is valid and able to be stored.

This method checks that the parent_id is non-zero and exists in the database. Note that the root node (parent_id = 0) cannot be manipulated with this class.

Renvoie
boolean True if all checks pass.
Depuis
1.7.0

Implémente TableInterface.

Références $query, et $this.

◆ debug()

debug ( $level )

Sets the debug level on or off

Paramètres
integer $level 0 = off, 1 = on
Renvoie
void
Depuis
1.7.0

◆ getPath()

getPath | ( | $pk = null,
 |  | $diagnostic = false
 | ) |

Method to get an array of nodes from a given node to its root.

Paramètres
integer | $pk | Primary key of the node for which to get the path.
boolean | $diagnostic | Only select diagnostic data for the nested sets.
Renvoie
mixed An array of node objects including the start node.
Depuis
1.7.0
Exceptions

Références $query.

◆ getRootId()

getRootId ( )

Gets the ID of the root item in the tree

Renvoie
mixed The primary id of the root row, or false if not found and the internal error is set.
Depuis
1.7.0

Références $fields, $query, $result, et $this.

◆ getTree()

getTree | ( | $pk = null,
 |  | $diagnostic = false
 | ) |

Method to get a node and all its child nodes.

Paramètres
integer | $pk | Primary key of the node for which to get the tree.
boolean | $diagnostic | Only select diagnostic data for the nested sets.
Renvoie
mixed Boolean false on failure or array of node objects on success.
Depuis
1.7.0
Exceptions

Références $query.

◆ isLeaf()

isLeaf ( $pk = null )

Method to determine if a node is a leaf node in the tree (has no children).

Paramètres
integer $pk Primary key of the node to check.
Renvoie
boolean True if a leaf node, false if not or null if the node does not exist.
Note
Since 3.0.0 this method returns null if the node does not exist.
Depuis
1.7.0
Exceptions

◆ move()

move | ( | $delta,
 |  | $where = ''
 | ) |

Method to move a row in the ordering sequence of a group of rows defined by an SQL WHERE clause. Negative numbers move the row up in the sequence and positive numbers move it down.

Paramètres
integer | $delta | The direction and magnitude to move the row in the ordering sequence.
string | $where | WHERE clause to use for limiting the selection of rows to compact the ordering values.
Renvoie
mixed Boolean true on success.
Depuis
1.7.0

Références $position, et $query.

◆ moveByReference()

moveByReference | ( | $referenceId,
 |  | $position = 'after',
 |  | $pk = null,
 |  | $recursiveUpdate = true
 | ) |

Method to move a node and its children to a new location in the tree.

Paramètres
integer | $referenceId | The primary key of the node to reference new location by.
string | $position | Location type string. ['before', 'after', 'first-child', 'last-child']
integer | $pk | The primary key of the node to move.
boolean | $recursiveUpdate | Flag indicate that method recursiveUpdatePublishedColumn should be call.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $fields, Joomla\Database\Query\$offset, $position, $query, $this, level, et null.

◆ orderDown()

orderDown ( $pk )

Method to move a node one position to the right in the same level.

Paramètres
integer $pk Primary key of the node to move.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $query.

◆ orderUp()

orderUp ( $pk )

Method to move a node one position to the left in the same level.

Paramètres
integer $pk Primary key of the node to move.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $query.

◆ publish()

publish | ( | $pks = null,
 |  | $state = 1,
 |  | $userId = 0
 | ) |

Method to set the publishing state for a node or list of nodes in the database table. The method respects rows checked out by other users and will attempt to checkin rows that it can after adjustments are made. The method will not allow you to set a publishing state higher than any ancestor node and will not allow you to set a publishing state on a node with a checked out child.

Paramètres
mixed | $pks | An optional array of primary key values to update. If not set the instance property value is used.
integer | $state | The publishing state. eg. [0 = unpublished, 1 = published]
integer | $userId | The user id of the user performing the operation.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $key, $published, $query, $state, $this, $userId, et ArrayHelper\toInteger().

◆ rebuild()

rebuild | ( | $parentId = null,
 |  | $leftId = 0,
 |  | $level = 0,
 |  | $path = ''
 | ) |

Method to recursively rebuild the whole nested set tree.

Paramètres
integer | $parentId | The root of the tree to rebuild.
integer | $leftId | The left id to start with in building the tree.
integer | $level | The level to assign to the current nodes.
string | $path | The path to the current nodes.
Renvoie
integer 1 + value of root rgt on success, false on failure
Depuis
1.7.0
Exceptions

Références $path, $query, $this, et null.

◆ rebuildPath()

rebuildPath ( $pk = null )

Method to rebuild the node's path field from the alias values of the nodes from the current node to the root node of the tree.

Paramètres
integer $pk Primary key of the node for which to get the path.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $fields, $path, $query, et path.

◆ recursiveUpdatePublishedColumn()

recursiveUpdatePublishedColumn | ( | $pk,
 |  | $newState = null
 | ) |
protected

Method to recursive update published column for children rows.

Paramètres
integer | $pk | Id number of row which published column was changed.
integer | $newState | An optional value for published column of row identified by $pk.
Renvoie
boolean True on success.
Depuis
3.7.0
Exceptions

We have to calculate the correct value for c2.published based on p2.published and own c2.published column, where (p2) is parent category is and (c2) current category

p2.published <= c2.published AND p2.published > 0 THEN c2.published 2 <= 2 THEN 2 (If archived in archived then archived) 1 <= 2 THEN 2 (If archived in published then archived) 1 <= 1 THEN 1 (If published in published then published)

p2.published > c2.published AND c2.published > 0 THEN p2.published 2 > 1 THEN 2 (If published in archived then archived)

p2.published > c2.published THEN c2.published ELSE p2.published 2 > -2 THEN -2 (If trashed in archived then trashed) 2 > 0 THEN 0 (If unpublished in archived then unpublished) 1 > 0 THEN 0 (If unpublished in published then unpublished) 0 > -2 THEN -2 (If trashed in unpublished then trashed) ELSE 0 <= 2 THEN 0 (If archived in unpublished then unpublished) 0 <= 1 THEN 0 (If published in unpublished then unpublished) 0 <= 0 THEN 0 (If unpublished in unpublished then unpublished) -2 <= -2 THEN -2 (If trashed in trashed then trashed) -2 <= 0 THEN -2 (If unpublished in trashed then trashed) -2 <= 1 THEN -2 (If published in trashed then trashed) -2 <= 2 THEN -2 (If archived in trashed then trashed)

Références $key, $published, $query, et null.

◆ reset()

reset ( )

Method to reset class properties to the defaults set in the class definition. It will ignore the primary key as well as any private class properties (except $_errors).

Renvoie
void
Depuis
3.2.1

Implémente TableInterface.

◆ saveorder()

saveorder | ( | $idArray = null,
 |  | $lftArray = null
 | ) |

Method to update order of table rows

Paramètres
array | $idArray | id numbers of rows to be reordered.
array | $lftArray | lft values of rows to be reordered.
Renvoie
integer|boolean 1 + value of root rgt on success, false on failure.
Depuis
1.7.0
Exceptions

Références $count, $i, et $query.

◆ setLocation()

setLocation | ( | $referenceId,
 |  | $position = 'after'
 | ) |

Method to set the location of a node in the tree object. This method does not save the new location to the database, but will set it in the object so that when the node is stored it will be stored in the new location.

Paramètres
integer | $referenceId | The primary key of the node to reference new location by.
string | $position | Location type string.
Renvoie
void
Note
Since 3.0.0 this method returns void and throws an when an invalid position is passed.
Voir également
Nested::$_validLocations
Depuis
1.7.0
Exceptions

Références $position.

◆ store()

store ( $updateNulls = false )

Method to store a node in the database table.

Paramètres
boolean $updateNulls True to update null values as well.
Renvoie
boolean True on success.
Depuis
1.7.0

If we have a given primary key then we assume we are simply updating this node in the tree. We should assess whether or not we are moving the node or just updating its data fields.

Implémente TableInterface.

Références $query, $result, $this, AbstractEvent\create(), Joomla\CMS\Application\getDispatcher(), level, et Joomla\Event\setDispatcher().

Documentation des champs

◆ $_cache

$_cache = array()
protected

◆ $_debug

$_debug = 0
protected

◆ $_location

$_location
protected

◆ $_location_id

$_location_id
protected

◆ $_validLocations

$_validLocations = array('before', 'after', 'first-child', 'last-child')
private

◆ $alias

$alias

◆ $level

$level

◆ $lft

$lft

◆ $parent_id

$parent_id

◆ $rgt

$rgt

◆ $root_id

$root_id = 0
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Nested.php


Joomla CMS: Référence de la classe Table

  • Joomla
  • CMS
  • Table
  • Table
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés statiques
Référence de la classe Table
+ Graphe d'héritage de Table:
CMSObject TableInterface DispatcherAwareInterface Content ContentHistory ContentType CoreContent Extension Language MenuType Module Nested Ucm Update UpdateSite User Usergroup ViewLevel BannerTable ClientTable ContactTable FeaturedTable FieldTable GroupTable FilterTable LinkTable UpdatesiteTable TemplateTable MessageTable NewsfeedTable ConsentTable RequestTable LinkTable TaskTable StyleTable MfaTable NoteTable StageTable TransitionTable WorkflowTable

Fonctions membres publiques

__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)

Champs de données

$typeAlias = null

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés statiques

static | $_includePaths = array()
static | $tableFields

Description détaillée

Abstract Table class

Parent class to all tables.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $table,
 |  |  | $key,
 |  | DatabaseDriver | $db,
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |

Object constructor to set table and key fields. In most cases this will be overridden by child classes to explicitly set the table and key fields for a particular database table.

Paramètres
string | $table | Name of the table to model.
mixed | $key | Name of the primary key field in the table or array of field names that compose the primary key.
DatabaseDriver | $db | DatabaseDriver object.
DispatcherInterface | $dispatcher | Event dispatcher for this table
Depuis
1.7.0

Références $db, $fields, $key, $name, $this, Symfony\Contracts\Service\__construct(), AbstractEvent\create(), elseif, Factory\getApplication(), Joomla\CMS\Application\getDispatcher(), null, et Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
1.7.0

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

In tracking the assets a title is kept for each asset so that there is some context available in a unified access manager. Usually this would just return $this->title or $this->name or whatever is being used for the primary name of the row. If this method is not overridden, the asset name is used.

Renvoie
string The string to use as the title in the asset table.
Depuis
1.7.0

◆ _lock()

_lock ( )
protected

Method to lock the database table for writing.

Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

◆ _unlock()

_unlock ( )
protected

Method to unlock the database table for writing.

Renvoie
boolean True on success.
Depuis
1.7.0

◆ addIncludePath()

static addIncludePath ( $path = null )
static

Add a filesystem path where Table should search for table class files.

Paramètres
array | string $path A filesystem path or array of filesystem paths to add.
Renvoie
array An array of filesystem paths to find Table classes in.
Depuis
1.7.0
Obsolète:
5.0 Should not be used anymore as tables are loaded through the MvcFactory

Références $dir, $path, et __DIR__.

Référencé par AjaxController\fetchAssociations(), et HistoryModel\getSha1Hash().

◆ appendPrimaryKeys()

appendPrimaryKeys | ( | $query,
 |  | $pk = null
 | ) |

Method to append the primary keys for this table to a query.

Paramètres
DatabaseQuery | $query | A query object to append.
mixed | $pk | Optional primary key parameter.
Renvoie
void
Depuis
3.1.4

Références $query.

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Method to bind an associative array or object to the Table instance.This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Implémente TableInterface.

Références $field, $this, AbstractEvent\create(), et Joomla\CMS\Application\getDispatcher().

◆ check()

check ( )

Method to perform sanity checks on the Table instance properties to ensure they are safe to store in the database.

Child classes should override this method to make sure the data they are storing in the database is safe and as expected before storage.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Depuis
1.7.0

Implémente TableInterface.

Références $this, AbstractEvent\create(), et Joomla\CMS\Application\getDispatcher().

◆ checkIn()

checkIn ( $pk = null )

Method to check a row in if the necessary properties/fields exist.

Checking a row in will allow other users the ability to edit the row.

Paramètres
mixed $pk An optional primary key value to check out. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $key, $query, $this, AbstractEvent\create(), elseif, Factory\getApplication(), Joomla\CMS\Application\getDispatcher(), et null.

◆ checkOut()

checkOut | ( | $userId,
 |  | $pk = null
 | ) |

Method to check a row out if the necessary properties/fields exist.

To prevent race conditions while editing rows in a database, a row can be checked out if the fields 'checked_out' and 'checked_out_time' are available. While a row is checked out, any attempt to store the row by a user other than the one who checked the row out should be held until the row is checked in again.

Paramètres
integer | $userId | The Id of the user checking out the row.
mixed | $pk | An optional primary key value to check out. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $key, $query, $this, $userId, AbstractEvent\create(), elseif, Factory\getDate(), Joomla\CMS\Application\getDispatcher(), et null.

◆ getColumnAlias()

getColumnAlias ( $column )

Method to return the real name of a "special" column such as ordering, hits, published etc etc. In this way you are free to follow your db naming convention and use the built in functions.

Paramètres
string $column Name of the "special" column (ie ordering, hits)
Renvoie
string The string that identify the special
Depuis
3.4

Références $return.

◆ getDbo()

getDbo ( )

Method to get the DatabaseDriver object.

Renvoie
DatabaseDriver The internal database driver object.
Depuis
1.7.0

Implémente TableInterface.

◆ getFields()

getFields ( $reload = false )

Get the columns from database table.

Paramètres
bool $reload flag to reload cache
Renvoie
mixed An array of the field names, or false if an error occurs.
Depuis
1.7.0
Exceptions

Références $fields, $key, et $name.

◆ getId()

getId ( )

Returns the identity (primary key) value of this record

Renvoie
mixed
Depuis
4.0.0

Implémente TableInterface.

Références $key.

◆ getInstance()

static getInstance | ( | $type,
 |  | $prefix = 'JTable',
 |  | $config = array()
 | ) |
static

Static method to get an instance of a Table class if it can be found in the table include paths.

To add include paths for searching for Table classes see Table::addIncludePath().

Paramètres
string | $type | The type (name) of the Table class to get an instance of.
string | $prefix | An optional prefix for the table class name.
array | $config | An optional array of configuration values for the Table object.
Renvoie
Table|boolean A Table object if found or boolean false on failure.
Depuis
1.7.0
Obsolète:
5.0 Use the MvcFactory instead

Références $config, $db, $prefix, $type, Path\find(), Factory\getContainer(), Factory\getDbo(), et Symfony\Contracts\Service\has().

Référencé par UCMContent\__construct(), InstallerAdapter\__construct(), Installer\__construct(), Language\_getAssetParentId(), MenuType\_getAssetParentId(), ExtensionAdapter\_startElement(), CollectionAdapter\_startElement(), InstallerAdapter\canUninstallPackageChild(), CssMenu\check(), AdminModel\checkCategoryId(), LibraryAdapter\checkExtensionInFilesystem(), LanguageAdapter\createContentLanguage(), LegacyFactory\createTable(), CoreContent\delete(), MenuType\delete(), LanguagesModel\delete(), ModuleAdapter\discover(), LibraryAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), AjaxController\fetchAssociations(), FileAdapter\finaliseInstall(), ModuleAdapter\finaliseInstall(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), AssociationsHelper\getItem(), LanguagesModel\getLanguageManifest(), ContactsModel\getListQuery(), AssociationsModel\getListQuery(), ArticlesModel\getListQuery(), LanguageModel\getTable(), GroupModel\getTable(), UserModel\getTable(), MenuModel\getTable(), PreviewModel\getTable(), LevelModel\getTable(), CompareModel\getTable(), PluginModel\getTable(), HistoryModel\getTable(), User\getTable(), ModuleModel\getTable(), ArticleModel\hit(), CategoryModel\hit(), LanguagesModel\install(), TagsHelper\postStoreProcess(), Helper\prepareContent(), ContenthistoryHelper\prepareData(), InstalledModel\publish(), LevelsModel\reorder(), ComponentModel\save(), ApplicationModel\save(), StyleModel\save(), LevelsModel\saveorder(), LanguagesModel\setDefault(), StyleModel\setHome(), LanguagesModel\setPublished(), Language\store(), UCMBase\store(), ContentType\store(), ContentHistory\store(), ContactTable\store(), Versioning\store(), MenuType\store(), NewsfeedTable\store(), Menu\store(), UCMContent\store(), Category\store(), Content\store(), LanguageAdapter\update(), updatecachetime_postinstall_action(), et CategoriesHelper\validateCategoryId().

◆ getKeyName()

getKeyName ( $multiple = false )

Method to get the primary key field name for the table.

Paramètres
boolean $multiple True to return all primary keys (as an array) or false to return just the first one (as a string).
Renvoie
mixed Array of primary key field names or string containing the first primary key field.
Depuis
1.7.0

◆ getNextOrder()

getNextOrder ( $where = '' )

Method to get the next ordering value for a group of rows defined by an SQL WHERE clause.

This is useful for placing a new item last in a group of items in the table.

Paramètres
string $where WHERE clause to use for selecting the MAX(ordering) for the table.
Renvoie
integer The next ordering value.
Depuis
1.7.0
Exceptions

Références $query, et $this.

◆ getPrimaryKey()

getPrimaryKey ( array $keys = array() )

Get the primary key values for this table using passed in values as a default.

Paramètres
array $keys Optional primary key values to use.
Renvoie
array An array of primary key names and values.
Depuis
3.1.4

Références $key.

◆ getRules()

getRules ( )

Method to get the rules for the record.

Renvoie
Rules object
Depuis
1.7.0

◆ getTableName()

getTableName ( )

Method to get the database table name for the class.

Renvoie
string The name of the database table being modeled.
Depuis
1.7.0

◆ hasField()

hasField ( $key )

Check if the record has a property (applying a column alias if it exists)

Paramètres
string $key key to be checked
Renvoie
boolean
Depuis
3.9.11

Implémente TableInterface.

Références $key, et $this.

◆ hasPrimaryKey()

hasPrimaryKey ( )

Validate that the primary key has been set.

Renvoie
boolean True if the primary key(s) have been set.
Depuis
3.1.4

Références $count, $key, et $query.

◆ hit()

hit ( $pk = null )

Method to increment the hits for a row if the necessary property/field exists.

Paramètres
mixed $pk An optional primary key value to increment. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $key, $query, $this, AbstractEvent\create(), elseif, Joomla\CMS\Application\getDispatcher(), hits, et null.

◆ isCheckedOut()

isCheckedOut | ( | $with = 0,
 |  | $against = null
 | ) |

Method to determine if a row is checked out and therefore uneditable by a user.

If the row is checked out by the same user, then it is considered not checked out – as the user can still edit it.

Paramètres
integer | $with | The user ID to perform the match with, if an item is checked out by this user the function will return false.
integer | $against | The user ID to perform the match against when the function is used as a static function.
Renvoie
boolean True if checked out.
Depuis
1.7.0

Références $db, $query, $this, Factory\getApplication(), et Factory\getDbo().

◆ load()

load | ( | $keys = null,
 |  | $reset = true
 | ) |

Method to load a row from the database by primary key and bind the fields to the Table instance properties.

Paramètres
mixed | $keys | An optional primary key value to load the row by, or an array of fields to match. If not set the instance property value is used.
boolean | $reset | True to reset the default values before loading the new row.
Renvoie
boolean True if successful. False if row not found.
Depuis
1.7.0
Exceptions

Implémente TableInterface.

Références $field, $fields, $key, $query, $result, $this, $value, AbstractEvent\create(), elseif, et Joomla\CMS\Application\getDispatcher().

Référencé par JoomlaInstallerScript\contactItems(), et JoomlaInstallerScript\finderItems().

◆ move()

move | ( | $delta,
 |  | $where = ''
 | ) |

Method to move a row in the ordering sequence of a group of rows defined by an SQL WHERE clause.

Negative numbers move the row up in the sequence and positive numbers move it down.

Paramètres
integer | $delta | The direction and magnitude to move the row in the ordering sequence.
string | $where | WHERE clause to use for limiting the selection of rows to compact the ordering values.
Renvoie
boolean True on success.
Depuis
1.7.0
Exceptions

Références $query, $this, AbstractEvent\create(), elseif, Joomla\CMS\Application\getDispatcher(), et null.

◆ publish()

publish | ( | $pks = null,
 |  | $state = 1,
 |  | $userId = 0
 | ) |

Method to set the publishing state for a row or list of rows in the database table.

The method respects checked out rows by other users and will attempt to checkin rows that it can after adjustments are made.

Paramètres
mixed | $pks | An optional array of primary key values to update. If not set the instance property value is used.
integer | $state | The publishing state. eg. [0 = unpublished, 1 = published]
integer | $userId | The user ID of the user performing the operation.
Renvoie
boolean True on success; false if $pks is empty.
Depuis
1.7.0

Références $key, $nowDate, $query, $state, $this, $userId, Text\_(), AbstractEvent\create(), Factory\getDate(), et Joomla\CMS\Application\getDispatcher().

◆ reorder()

reorder ( $where = '' )

Method to compact the ordering values of rows in a group of rows defined by an SQL WHERE clause.

Paramètres
string $where WHERE clause to use for limiting the selection of rows to compact the ordering values.
Renvoie
mixed Boolean True on success.
Depuis
1.7.0
Exceptions

Références $i, $key, $query, $this, AbstractEvent\create(), et Joomla\CMS\Application\getDispatcher().

◆ reset()

reset ( )

Method to reset class properties to the defaults set in the class definition. It will ignore the primary key as well as any private class properties (except $_errors).

Renvoie
void
Depuis
1.7.0

Implémente TableInterface.

Références $this, AbstractEvent\create(), et Joomla\CMS\Application\getDispatcher().

◆ save()

save | ( | $src,
 |  | $orderingFilter = '',
 |  | $ignore = ''
 | ) |

Method to provide a shortcut to binding, checking and storing a Table instance to the database table.

The method will check a row in once the data has been stored and if an ordering filter is present will attempt to reorder the table rows based on the filter. The ordering filter is an instance property name. The rows that will be reordered are those whose value matches the Table instance for the property specified.

Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
string | $orderingFilter | Filter for the order updating
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
1.7.0

◆ setColumnAlias()

setColumnAlias | ( | $column,
 |  | $columnAlias
 | ) |

Method to register a column alias for a "special" column.

Paramètres
string | $column | The "special" column (ie ordering)
string | $columnAlias | The real column name (ie foo_ordering)
Renvoie
void
Depuis
3.4

◆ setDbo()

setDbo ( DatabaseDriver $db )

Method to set the DatabaseDriver object.

Paramètres
DatabaseDriver $db A DatabaseDriver object to be used by the table object.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $db.

◆ setRules()

setRules ( $input )

Method to set rules for the record.

Paramètres
mixed $input A Rules object, JSON string, or array.
Renvoie
void
Depuis
1.7.0

Références $input.

Documentation des champs

◆ $_autoincrement

$_autoincrement = true
protected

◆ $_columnAlias

$_columnAlias = array()
protected

◆ $_db

$_db
protected

◆ $_includePaths

$_includePaths = array()
staticprivate

◆ $_jsonEncode

$_jsonEncode = array()
protected

◆ $_locked

$_locked = false
protected

◆ $_rules

$_rules
protected

◆ $_supportNullValue

$_supportNullValue = false
protected

◆ $_tbl

$_tbl = ''
protected

◆ $_tbl_key

$_tbl_key = ''
protected

◆ $_tbl_keys

$_tbl_keys = array()
protected

◆ $_trackAssets

$_trackAssets = false
protected

◆ $tableFields

$tableFields
staticprivate

◆ $typeAlias

$typeAlias = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Table/Table.php


Joomla CMS: Référence de l'interface TableInterface

  • Joomla
  • CMS
  • Table
  • TableInterface
Fonctions membres publiques
Référence de l'interface TableInterface
+ Graphe d'héritage de TableInterface:
Table TaggableTableInterface VersionableTableInterface Content ContentHistory ContentType CoreContent Extension Language MenuType Module Nested Ucm Update UpdateSite User Usergroup ViewLevel BannerTable ClientTable ContactTable FeaturedTable FieldTable GroupTable FilterTable LinkTable UpdatesiteTable TemplateTable MessageTable NewsfeedTable ConsentTable RequestTable LinkTable TaskTable StyleTable MfaTable NoteTable StageTable TransitionTable WorkflowTable Category Content ContactTable NewsfeedTable Category Content BannerTable ClientTable ContactTable NewsfeedTable TagTable NoteTable

Fonctions membres publiques

bind ($src, $ignore=array())
check ()
delete ($pk=null)
getDbo ()
getKeyName ()
load ($keys=null, $reset=true)
reset ()
store ($updateNulls=false)
getId ()
hasField ($key)

Description détaillée

Table class interface.

Depuis
3.2

Documentation des fonctions membres

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Method to bind an associative array or object to the TableInterface instance.

This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
mixed | $src | An associative array or object to bind to the TableInterface instance.
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
3.2
Exceptions

Implémenté dans Table, WorkflowTable, StageTable, Category, Module, TaskTable, BannerTable, User, Content, TransitionTable, FieldTable, GroupTable, Menu, StyleTable, et ViewLevel.

◆ check()

check ( )

Method to perform sanity checks on the TableInterface instance properties to ensure they are safe to store in the database.

Implementations of this interface should use this method to make sure the data they are storing in the database is safe and as expected before storage.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Depuis
3.2

Implémenté dans Table, Nested, Content, User, Category, ContactTable, FieldTable, Module, WorkflowTable, StageTable, Menu, TaskTable, GroupTable, NoteTable, Asset, BannerTable, StyleTable, ClientTable, Extension, FilterTable, CoreContent, NewsfeedTable, TagTable, ViewLevel, MenuTable, Update, MapTable, MessageTable, LinkTable, MenuType, UpdateSite, Usergroup, ContentType, et Language.

◆ delete()

delete ( $pk = null )

Method to delete a record.

Paramètres
mixed $pk An optional primary key value to delete. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
3.2
Exceptions

Implémenté dans User, Usergroup, MfaTable, MenuType, CoreContent, StyleTable, WorkflowTable, et StageTable.

◆ getDbo()

getDbo ( )

Method to get the DatabaseDriver object.

Renvoie
DatabaseDriver The internal database driver object.
Depuis
3.2

Implémenté dans Table.

Référencé par TagsHelper\addTagMapping().

◆ getId()

getId ( )

Returns the identity (primary key) value of this record

Renvoie
mixed
Depuis
4.0.0

Implémenté dans Table.

◆ getKeyName()

getKeyName ( )

Method to get the primary key field name for the table.

Renvoie
string The name of the primary key for the table.
Depuis
3.2

Référencé par TagsHelper\addTagMapping(), et TagsHelper\unTagItem().

◆ hasField()

hasField ( $key )

Check if the record has a property (applying a column alias if it exists)

Paramètres
string $key key to be checked
Renvoie
boolean
Depuis
4.0.0

Implémenté dans Table.

Référencé par PlgWorkflowFeaturing\isSupported(), et PlgWorkflowPublishing\isSupported().

◆ load()

load | ( | $keys = null,
 |  | $reset = true
 | ) |

Method to load a row from the database by primary key and bind the fields to the TableInterface instance properties.

Paramètres
mixed | $keys | An optional primary key value to load the row by, or an array of fields to match. If not set the instance property value is used.
boolean | $reset | True to reset the default values before loading the new row.
Renvoie
boolean True if successful. False if row not found.
Depuis
3.2
Exceptions

Implémenté dans Table, MfaTable, et User.

◆ reset()

reset ( )

Method to reset class properties to the defaults set in the class definition.

It will ignore the primary key as well as any private class properties.

Renvoie
void
Depuis
3.2

Implémenté dans Nested, et Table.

Référencé par TagsHelper\postStoreProcess(), et TagsHelper\preStoreProcess().

◆ store()

store ( $updateNulls = false )

Method to store a row in the database from the TableInterface instance properties.

If a primary key value is set the row with that primary key value will be updated with the instance property values. If no primary key value is set a new row will be inserted into the database with the properties from the TableInterface instance.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.2

Implémenté dans Nested, User, Content, Category, CoreContent, FieldTable, Module, Usergroup, StageTable, WorkflowTable, Menu, TagTable, GroupTable, NewsfeedTable, TaskTable, LinkTable, FilterTable, MenuType, StyleTable, MfaTable, ContactTable, ContentHistory, ContentType, Language, RequestTable, NoteTable, LinkTable, et ConsentTable.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TableInterface.php


Joomla CMS: Référence de la classe Ucm

  • Joomla
  • CMS
  • Table
  • Ucm
Fonctions membres publiques
Référence de la classe Ucm
+ Graphe d'héritage de Ucm:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($db)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

UCM map table

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $db )

Constructor

Paramètres
\Joomla\Database\DatabaseDriver $db A database connector object
Depuis
3.1

Références $db, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ucm.php


Joomla CMS: Référence de la classe Update

  • Joomla
  • CMS
  • Table
  • Update
Fonctions membres publiques | Attributs protégés
Référence de la classe Update
+ Graphe d'héritage de Update:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
find ($options=array())
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_jsonEncode = ['params']
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Update table Stores updates temporarily

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True if the object is ok
Voir également
Table::check()
Depuis
1.7.0

Implémente TableInterface.

Références Text\_(), description, name, et null.

◆ find()

find ( $options = array() )

Method to create and execute a SELECT WHERE query.

Paramètres
array $options Array of options
Renvoie
string Results of query
Depuis
1.7.0

Références $options, $query, $this, et $val.

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['params']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Table/Update.php


Joomla CMS: Référence de la classe UpdateSite

  • Joomla
  • CMS
  • Table
  • UpdateSite
Fonctions membres publiques
Référence de la classe UpdateSite
+ Graphe d'héritage de UpdateSite:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Update site table Stores the update sites for extensions

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
3.4

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True if the object is ok
Voir également
Table::check()
Depuis
3.4

Implémente TableInterface.

Références Text\_(), et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdateSite.php


Joomla CMS: Référence de la classe User

  • Joomla
  • CMS
  • Table
  • User
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe User
+ Graphe d'héritage de User:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
load ($userId=null, $reset=true)
bind ($array, $ignore='')
check ()
store ($updateNulls=true)
delete ($userId=null)
setLastVisit ($timeStamp=null, $userId=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$groups
- Champs de données hérités de Table
$typeAlias = null

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Users table

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Method to bind the user, user groups, and any other necessary data.

Paramètres
array | $array | The data to bind.
mixed | $ignore | An array or space separated list of fields to ignore.
Renvoie
boolean True on success, false on failure.
Depuis
1.7.0

Implémente TableInterface.

Références $query, $return, et ArrayHelper\toInteger().

◆ check()

check ( )

Validation and filtering

Renvoie
boolean True if satisfactory
Depuis
1.7.0

Implémente TableInterface.

Références $query, $this, Text\_(), PunycodeHelper\emailToPunycode(), Factory\getApplication(), Factory\getDate(), InputFilter\getInstance(), ParameterType\INTEGER, MailHelper\isEmailAddress(), null, Text\sprintf(), et StringHelper\strlen().

◆ delete()

delete ( $userId = null )

Method to delete a user, user groups, and any other necessary data from the database.

Paramètres
integer $userId An optional user id.
Renvoie
boolean True on success, false on failure.
Depuis
1.7.0

Implémente TableInterface.

Références $key, $query, $this, $userId, et ParameterType\INTEGER.

◆ load()

load | ( | $userId = null,
 |  | $reset = true
 | ) |

Method to load a user, user groups, and any other necessary data from the database so that it can be bound to the user object.

Paramètres
integer | $userId | An optional user id.
boolean | $reset | False if row not found or on error (internal error state set in that case).
Renvoie
boolean True on success, false on failure.
Depuis
1.7.0

Implémente TableInterface.

Références $data, $id, $query, $return, $userId, PunycodeHelper\emailToUTF8(), ParameterType\INTEGER, et null.

◆ setLastVisit()

setLastVisit | ( | $timeStamp = null,
 |  | $userId = null
 | ) |

Updates last visit time of user

Paramètres
integer | $timeStamp | The timestamp, defaults to 'now'.
integer | $userId | The user id (optional).
Renvoie
boolean False if an error occurs
Depuis
1.7.0

Pass through method to the table for setting the last visit date

Paramètres
integer $timestamp The timestamp, defaults to 'now'.
Renvoie
boolean True on success.
Depuis
1.7.0

Références $date, $db, $id, $query, $this, $userId, Factory\getDate(), ParameterType\INTEGER, et null.

◆ store()

store ( $updateNulls = true )

Method to store a row in the database from the Table instance properties.

If a primary key value is set the row with that primary key value will be updated with the instance property values. If no primary key value is set a new row will be inserted into the database with the properties from the Table instance.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.7.0

Implémente TableInterface.

Références $groups, $key, $query, $result, $this, block, et ParameterType\INTEGER.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected

◆ $groups

$groups
La documentation de cette classe a été générée à partir du fichier suivant :
  • Table/User.php


Joomla CMS: Référence de la classe Usergroup

  • Joomla
  • CMS
  • Table
  • Usergroup
Fonctions membres publiques
Référence de la classe Usergroup
+ Graphe d'héritage de Usergroup:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
rebuild ($parentId=0, $left=0)
store ($updateNulls=false)
delete ($oid=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Usergroup table class.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Method to check the current record to save

Renvoie
boolean True on success
Depuis
1.7.0

Implémente TableInterface.

Références $db, $id, $query, $this, $title, Text\_(), elseif, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ delete()

delete ( $oid = null )

Delete this object and its dependencies

Paramètres
integer $oid The primary key of the user group to delete.
Renvoie
mixed Boolean or Exception.
Depuis
1.7.0
Exceptions

Implémente TableInterface.

Références $db, $id, $oid, $query, $this, et ParameterType\INTEGER.

◆ rebuild()

rebuild | ( | $parentId = 0,
 |  | $left = 0
 | ) |

Method to recursively rebuild the nested set tree.

Paramètres
integer | $parentId | The root of the tree to rebuild.
integer | $left | The left id to start with in building the tree.
Renvoie
boolean True on success
Depuis
1.7.0

Références $db, $i, $n, $query, $this, et ParameterType\INTEGER.

◆ store()

store ( $updateNulls = false )

Inserts a new row if id is zero or updates an existing row in the database table

Paramètres
boolean $updateNulls If false, null object variables are not updated
Renvoie
boolean True if successful, false otherwise and an internal error message is set
Depuis
1.7.0

Implémente TableInterface.

Références $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Usergroup.php


Joomla CMS: Référence de la classe ViewLevel

  • Joomla
  • CMS
  • Table
  • ViewLevel
Fonctions membres publiques
Référence de la classe ViewLevel
+ Graphe d'héritage de ViewLevel:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Viewlevels table class.

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database driver object.
Depuis
1.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Method to bind the data.

Paramètres
array | $array | The data to bind.
mixed | $ignore | An array or space separated list of fields to ignore.
Renvoie
boolean True on success, false on failure.
Depuis
1.7.0

Implémente TableInterface.

◆ check()

check ( )

Method to check the current record to save

Renvoie
boolean True on success
Depuis
1.7.0

Implémente TableInterface.

Références $db, $id, $query, Text\_(), ParameterType\INTEGER, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ViewLevel.php


Joomla CMS: Référence de l'interface TaggableTableInterface

  • Joomla
  • CMS
  • Tag
  • TaggableTableInterface
Fonctions membres publiques
Référence de l'interface TaggableTableInterface
+ Graphe d'héritage de TaggableTableInterface:
TableInterface Category Content ContactTable NewsfeedTable CategoryTable ArticleTable

Fonctions membres publiques

getTypeAlias ()
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()
- Fonctions membres publiques hérités de TableInterface
bind ($src, $ignore=array())
check ()
delete ($pk=null)
getDbo ()
getKeyName ()
load ($keys=null, $reset=true)
reset ()
store ($updateNulls=false)
getId ()
hasField ($key)

Description détaillée

Interface for a taggable Table class

Depuis
3.10.0

Documentation des fonctions membres

◆ clearTagsHelper()

clearTagsHelper ( )

Clears a set tags helper

Renvoie
void
Depuis
4.0.0

◆ getTagsHelper()

getTagsHelper ( )

Get the tags helper

Renvoie
?TagsHelper The tags helper object
Depuis
4.0.0

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the tags mapping table

The type alias generally is the internal component name with the content type. Ex.: com_content.article

Renvoie
string The alias as described above
Depuis
4.0.0

Implémenté dans Content, Category, ContactTable, et NewsfeedTable.

◆ setTagsHelper()

setTagsHelper ( TagsHelper $tagsHelper )

Set the tags helper

Paramètres
TagsHelper $tagsHelper The tags helper object
Renvoie
void
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • TaggableTableInterface.php


Joomla CMS: Référence de l'interface TagServiceInterface

  • Joomla
  • CMS
  • Tag
  • TagServiceInterface
Fonctions membres publiques
Référence de l'interface TagServiceInterface
+ Graphe d'héritage de TagServiceInterface:
LegacyComponent BannersComponent ContactComponent ContentComponent NewsfeedsComponent

Fonctions membres publiques

countTagItems (array $items, string $extension)

Description détaillée

Access to component specific tagging information.

Depuis
4.0.0

Documentation des fonctions membres

◆ countTagItems()

countTagItems | ( | array | $items,
 |  | string | $extension
 | ) |  |

Adds Count Items for Tag Manager.

Paramètres

Implémenté dans ContentComponent, et LegacyComponent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TagServiceInterface.php


Joomla CMS: Référence de la classe AbstractGroupButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • AbstractGroupButton
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractGroupButton
+ Graphe d'héritage de AbstractGroupButton:
BasicButton ToolbarButton DropdownButton

Fonctions membres publiques

configure (callable $handler)
getChildToolbar ()
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

fetchId ()
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Attributs protégés

$child
- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()
- Attributs protégés statiques hérités de ToolbarButton
static | $idCounter = []

Description détaillée

The AbstractGroupButton class.

Depuis
4.0.0

Documentation des fonctions membres

◆ configure()

configure ( callable $handler )

Add children buttons as dropdown.

Paramètres
callable $handler The callback to configure dropdown items.
Renvoie
static
Depuis
4.0.0

Références $this.

◆ fetchId()

fetchId ( )
protected

Get the button CSS Id.

Renvoie
string Button CSS Id
Depuis
4.0.0

Références parent.

◆ getChildToolbar()

getChildToolbar ( )

Get child toolbar.

Renvoie
Toolbar Return new child Toolbar instance.
Depuis
4.0.0

Références parent.

Documentation des champs

◆ $child

$child
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractGroupButton.php


Joomla CMS: Référence de la classe BasicButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • BasicButton
Fonctions membres publiques | Attributs protégés
Référence de la classe BasicButton
+ Graphe d'héritage de BasicButton:
ToolbarButton AbstractGroupButton HelpButton InlinehelpButton StandardButton DropdownButton ConfirmButton

Fonctions membres publiques

fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Attributs protégés

$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()
- Attributs protégés statiques hérités de ToolbarButton
static | $idCounter = []

Description détaillée

Renders a basic button.

Depuis
4.0.0

Documentation des fonctions membres

◆ fetchButton()

fetchButton ( $type = 'Basic' )

Fetch the HTML for the button

Paramètres
string $type Unused string.
Renvoie
void
Depuis
3.0
Obsolète:
5.0 Use render() instead.
Exceptions

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.basic'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BasicButton.php


Joomla CMS: Référence de la classe ConfirmButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • ConfirmButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe ConfirmButton
+ Graphe d'héritage de ConfirmButton:
StandardButton BasicButton ToolbarButton

Fonctions membres publiques

fetchButton ($type='Confirm', $msg='', $name='', $text='', $task='', $list=true, $hideMenu=false)
- Fonctions membres publiques hérités de StandardButton
fetchButton ($type='Standard', $name='', $text='', $task='', $list=true, $formId=null)
fetchButtonClass (string $name)
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
_getCommand ()
- Fonctions membres protégées hérités de StandardButton
prepareOptions (array &$options)
_getCommand ()
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Membres hérités additionnels

- Attributs protégés hérités de StandardButton
$layout = 'joomla.toolbar.standard'
- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []
- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a standard button with a confirm dialog

self message(string $value) bool getMessage()

Depuis
3.0

Documentation des fonctions membres

◆ _getCommand()

_getCommand ( )
protected

Get the JavaScript command for the button

Renvoie
string JavaScript command string
Depuis
3.0

Références $alert, $message, et Text\script().

◆ fetchButton()

fetchButton | ( | $type = 'Confirm',
 |  | $msg = '',
 |  | $name = '',
 |  | $text = '',
 |  | $task = '',
 |  | $list = true,
 |  | $hideMenu = false
 | ) |

Fetch the HTML for the button

Paramètres
string | $type | Unused string.
string | $msg | Message to render
string | $name | Name to be used as apart of the id
string | $text | Button text
string | $task | The task associated with the button
boolean | $list | True to allow use of lists
boolean | $hideMenu | True to hide the menu on click
Renvoie
string HTML string for the button
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Références $list, $name, $task, $text, et name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $options, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfirmButton.php


Joomla CMS: Référence de la classe CustomButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • CustomButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe CustomButton
+ Graphe d'héritage de CustomButton:
ToolbarButton

Fonctions membres publiques

fetchButton ($type='Custom', $html='', $id='custom')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

renderButton (array &$options)
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Membres hérités additionnels

- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []
- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a custom button

self html(string $value) string getHtml()

Depuis
3.0

Documentation des fonctions membres

◆ fetchButton()

fetchButton | ( | $type = 'Custom',
 |  | $html = '',
 |  | $id = 'custom'
 | ) |

Fetch the HTML for the button

Paramètres
string | $type | Button type, unused string.
string | $html | HTML string for the button
string | $id | CSS id for the button
Renvoie
string HTML string for the button
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Références $html.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ renderButton()

renderButton ( array & $options )
protected

Render button HTML.

Paramètres
array $options The button options.
Renvoie
string The button HTML.
Depuis
4.0.0

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CustomButton.php


Joomla CMS: Référence de la classe DropdownButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • DropdownButton
Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe DropdownButton
+ Graphe d'héritage de DropdownButton:
AbstractGroupButton BasicButton ToolbarButton

Fonctions membres protégées

renderButton (array &$options)
fetchId ()
- Fonctions membres protégées hérités de AbstractGroupButton
fetchId ()
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Attributs protégés

$layout = 'joomla.toolbar.dropdown'
- Attributs protégés hérités de AbstractGroupButton
$child
- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractGroupButton
configure (callable $handler)
getChildToolbar ()
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)
- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Render dropdown buttons.

self toggleSplit(bool $value) self toggleButtonClass(string $value) bool getToggleSplit() string getToggleButtonClass()

Depuis
4.0.0

Documentation des fonctions membres

◆ fetchId()

fetchId ( )
protected

Get the button CSS Id.

Renvoie
string Button CSS Id
Depuis
4.0.0

Références parent.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ renderButton()

renderButton ( array & $options )
protected

Render button HTML.

Paramètres
array $options The button options.
Renvoie
string The button HTML.
Depuis
4.0.0

Références $options.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.dropdown'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DropdownButton.php


Joomla CMS: Référence de la classe HelpButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • HelpButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe HelpButton
+ Graphe d'héritage de HelpButton:
BasicButton ToolbarButton

Fonctions membres publiques

fetchButton ($type='Help', $ref='', $com=false, $override=null, $component=null)
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
_getCommand ()
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Membres hérités additionnels

- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []
- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a help popup window button

self ref(string $value) self component(string $value) self useComponent(bool $value) self url(string $value) string getRef() string getComponent() bool getUseComponent() string getUrl()

Depuis
3.0

Documentation des fonctions membres

◆ _getCommand()

_getCommand ( )
protected

Get the JavaScript command for the button

Renvoie
string JavaScript command string
Depuis
3.0

Références $url, Text\_(), Help\createUrl(), et ENT_QUOTES.

◆ fetchButton()

fetchButton | ( | $type = 'Help',
 |  | $ref = '',
 |  | $com = false,
 |  | $override = null,
 |  | $component = null
 | ) |

Fetches the button HTML code.

Paramètres
string | $type | Unused string.
string | $ref | The name of the help screen (its key reference).
boolean | $com | Use the help file in the component directory.
string | $override | Use this URL instead of any other.
string | $component | Name of component to get Help (null for current component)
Renvoie
string
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Références $component, et name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HelpButton.php


Joomla CMS: Référence de la classe InlinehelpButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • InlinehelpButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe InlinehelpButton
+ Graphe d'héritage de InlinehelpButton:
BasicButton ToolbarButton

Fonctions membres publiques

fetchButton ( $type='Inlinehelp', string $targetClass='hide-aware-inline-help', string $text='JINLINEHELP', string $icon='fa fa-question-circle', string $buttonClass='btn btn-info')
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Attributs protégés

$layout = 'joomla.toolbar.inlinehelp'
- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a button to show / hide the inline help text

self targetclass(string $value) string getTargetclass()

Depuis
4.1.0

Documentation des fonctions membres

◆ fetchButton()

fetchButton | ( |  | $type = 'Inlinehelp',
 |  | string | $targetClass = 'hide-aware-inline-help',
 |  | string | $text = 'JINLINEHELP',
 |  | string | $icon = 'fa fa-question-circle',
 |  | string | $buttonClass = 'btn btn-info'
 | ) |  |

Fetches the button HTML code.

Paramètres
string | $type | Unused string.
string | $targetClass | The class of the DIVs holding the descriptions to toggle.
string | $text | Button label
string | $icon | Button icon
string | $buttonClass | Button class
Renvoie
string
Depuis
4.1.0
Obsolète:
5.0 Use render() instead.

Références $buttonClass, $icon, $text, et name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.1.0

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options for this button.
Renvoie
void
Depuis
4.1.0

Références $options.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.inlinehelp'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InlinehelpButton.php


Joomla CMS: Référence de la classe LinkButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • LinkButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe LinkButton
+ Graphe d'héritage de LinkButton:
ToolbarButton

Fonctions membres publiques

fetchButton ($type='Link', $name='back', $text='', $url=null)
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Attributs protégés

$layout = 'joomla.toolbar.link'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a link button

self url(string $value) self target(string $value) string getUrl() string getTarget()

Depuis
3.0

Documentation des fonctions membres

◆ fetchButton()

fetchButton | ( | $type = 'Link',
 |  | $name = 'back',
 |  | $text = '',
 |  | $url = null
 | ) |

Fetch the HTML for the button

Paramètres
string | $type | Unused string.
string | $name | Name to be used as apart of the id
string | $text | Button text
string | $url | The link url
Renvoie
string HTML string for the button
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Références $name, $text, $url, et name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $options.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.link'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LinkButton.php


Joomla CMS: Référence de la classe PopupButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • PopupButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Fonctions membres privées
Référence de la classe PopupButton
+ Graphe d'héritage de PopupButton:
ToolbarButton

Fonctions membres publiques

fetchButton ( $type='Modal', $name='', $text='', $url='', $iframeWidth=640, $iframeHeight=480, $bodyHeight=null, $modalWidth=null, $onClose='', $title='', $footer=null)
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
renderButton (array &$options)
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static | getAccessors ()
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()

Attributs protégés

$layout = 'joomla.toolbar.popup'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Fonctions membres privées

_getCommand ($url)

Membres hérités additionnels

- Attributs protégés statiques hérités de ToolbarButton
static $idCounter = []

Description détaillée

Renders a modal window button

self url(string $value) self icon(string $value) self iframeWidth(int $value) self iframeHeight(int $value) self bodyHeight(int $value) self modalWidth(int $value) self onclose(string $value) self title(string $value) self footer(string $value) self selector(string $value) self listCheck(bool $value) string getUrl() int getIframeWidth() int getIframeHeight() int getBodyHeight() int getModalWidth() string getOnclose() string getTitle() string getFooter() string getSelector() bool getListCheck()

Depuis
3.0

Documentation des fonctions membres

◆ _getCommand()

_getCommand ( $url )
private

Get the JavaScript command for the button

Paramètres
string $url URL for popup
Renvoie
string JavaScript command string
Depuis
3.0

Références $url, et Uri\base().

◆ fetchButton()

fetchButton | ( | $type = 'Modal',
 |  | $name = '',
 |  | $text = '',
 |  | $url = '',
 |  | $iframeWidth = 640,
 |  | $iframeHeight = 480,
 |  | $bodyHeight = null,
 |  | $modalWidth = null,
 |  | $onClose = '',
 |  | $title = '',
 |  | $footer = null
 | ) |

Fetch the HTML for the button

Paramètres
string | $type | Unused string, formerly button type.
string | $name | Modal name, used to generate element ID
string | $text | The link text
string | $url | URL for popup
integer | $iframeWidth | Width of popup
integer | $iframeHeight | Height of popup
integer | $bodyHeight | Optional height of the modal body in viewport units (vh)
integer | $modalWidth | Optional width of the modal in viewport units (vh)
string | $onClose | JavaScript for the onClose event.
string | $title | The title text
string | $footer | The footer html
Renvoie
string HTML string for the button
Depuis
3.0

Références $bodyHeight, $modalWidth, $name, $text, $title, $url, et name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $options.

◆ renderButton()

renderButton ( array & $options )
protected

Render button HTML.

Paramètres
array $options The button options.
Renvoie
string The button HTML.
Depuis
4.0.0

Références $html, $options, $params, $selector, HTMLHelper\_(), Factory\getDocument(), et null.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.popup'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PopupButton.php


Joomla CMS: Référence de la classe SeparatorButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • SeparatorButton
Fonctions membres publiques | Attributs protégés
Référence de la classe SeparatorButton
+ Graphe d'héritage de SeparatorButton:
ToolbarButton

Fonctions membres publiques

fetchButton ()
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Attributs protégés

$layout = 'joomla.toolbar.separator'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)
- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()
- Attributs protégés statiques hérités de ToolbarButton
static | $idCounter = []

Description détaillée

Renders a button separator

Depuis
3.0

Documentation des fonctions membres

◆ fetchButton()

fetchButton ( )

Empty implementation (not required for separator)

Renvoie
void
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.separator'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SeparatorButton.php


Joomla CMS: Référence de la classe StandardButton

  • Joomla
  • CMS
  • Toolbar
  • Button
  • StandardButton
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe StandardButton
+ Graphe d'héritage de StandardButton:
BasicButton ToolbarButton ConfirmButton

Fonctions membres publiques

fetchButton ($type='Standard', $name='', $text='', $task='', $list=true, $formId=null)
fetchButtonClass (string $name)
- Fonctions membres publiques hérités de BasicButton
fetchButton ($type='Basic')
- Fonctions membres publiques hérités de ToolbarButton
__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
_getCommand ()
- Fonctions membres protégées hérités de ToolbarButton
prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Attributs protégés

$layout = 'joomla.toolbar.standard'
- Attributs protégés hérités de BasicButton
$layout = 'joomla.toolbar.basic'
- Attributs protégés hérités de ToolbarButton
$name
$parent
$layout
$options = []

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ToolbarButton
static | getAccessors ()
- Attributs protégés statiques hérités de ToolbarButton
static | $idCounter = []

Description détaillée

Renders a standard button

Depuis
3.0

Documentation des fonctions membres

◆ _getCommand()

_getCommand ( )
protected

Get the JavaScript command for the button

Renvoie
string JavaScript command string
Depuis
3.0

Références $alert, $messages, et Text\script().

◆ fetchButton()

fetchButton | ( | $type = 'Standard',
 |  | $name = '',
 |  | $text = '',
 |  | $task = '',
 |  | $list = true,
 |  | $formId = null
 | ) |

Fetch the HTML for the button

Paramètres
string | $type | Unused string.
string | $name | The name of the button icon class.
string | $text | Button text.
string | $task | Task associated with the button.
boolean | $list | True to allow lists
string | $formId | The id of action form.
Renvoie
string HTML string for the button
Depuis
3.0
Obsolète:
5.0 Use render() instead.

Références $formId, $list, $name, $task, $text, name, et null.

◆ fetchButtonClass()

fetchButtonClass ( string $name )

Fetch button class for standard buttons.

Paramètres
string $name The button name.
Renvoie
string
Depuis
4.0.0

Références $name.

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array $options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $class, et $options.

Documentation des champs

◆ $layout

$layout = 'joomla.toolbar.standard'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StandardButton.php


Joomla CMS: Référence de la classe ContainerAwareToolbarFactory

  • Joomla
  • CMS
  • Toolbar
  • ContainerAwareToolbarFactory
Fonctions membres publiques | Fonctions membres privées
Référence de la classe ContainerAwareToolbarFactory
+ Graphe d'héritage de ContainerAwareToolbarFactory:
ToolbarFactoryInterface ContainerAwareInterface

Fonctions membres publiques

createToolbar (string $name='toolbar')
- Fonctions membres publiques hérités de ToolbarFactoryInterface
createButton (Toolbar $toolbar, string $type)
- Fonctions membres publiques hérités de ContainerAwareInterface
setContainer (Container $container)

Fonctions membres privées

loadButtonClass (string $type)

Description détaillée

Default factory for creating toolbar objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createToolbar()

createToolbar ( string $name = 'toolbar' )

Creates a new Toolbar object.

Paramètres
string $name The toolbar name.
Renvoie
Toolbar
Depuis
4.0.0

Implémente ToolbarFactoryInterface.

Références $name, et $this.

◆ loadButtonClass()

loadButtonClass ( string $type )
private

Load the button class including the deprecated ones.

Paramètres
string $type Button Type (normalized)
Renvoie
string|null
Depuis
4.0.0

Références $buttonClass, $type, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerAwareToolbarFactory.php


Joomla CMS: Référence de la classe Toolbar

  • Joomla
  • CMS
  • Toolbar
  • Toolbar
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Toolbar

Fonctions membres publiques

__construct ($name='toolbar', ToolbarFactoryInterface $factory=null)
setFactory (ToolbarFactoryInterface $factory)
appendButton ($button,... $args)
getItems ()
setItems (array $items)
getName ()
prependButton ($button,... $args)
render (array $options=[])
renderButton (&$node)
loadButtonType ($type, $new=false)
addButtonPath ($path)
getButtonPath ()
createChild ($name)
__call ($name, $args)

Fonctions membres publiques statiques

static getInstance ($name='toolbar')

Attributs protégés

$_name = ''
$_bar = []
$_buttonPath = []
$factory

Attributs protégés statiques

static $instances = array()

Description détaillée

ToolBar handler

StandardButton standardButton(string $name = '', string $text = '', string $task = '') SeparatorButton separatorButton(string $name = '', string $text = '', string $task = '') PopupButton popupButton(string $name = '', string $text = '', string $task = '') LinkButton linkButton(string $name = '', string $text = '', string $task = '') HelpButton helpButton(string $name = '', string $text = '', string $task = '') InlinehelpButton inlinehelpButton(string $name = '', string $text = '', string $task = '') CustomButton customButton(string $name = '', string $text = '', string $task = '') ConfirmButton confirmButton(string $name = '', string $text = '', string $task = '') BasicButton basicButton(string $name = '', string $text = '', string $task = '') DropdownButton dropdownButton(string $name = '', string $text = '', string $task = '')

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name = 'toolbar',
 |  | ToolbarFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
string | $name | The toolbar name.
ToolbarFactoryInterface | $factory | The toolbar factory.
Depuis
1.5

Références $name, $this, __DIR__, class, et Factory\getContainer().

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $args
 | ) |

Magic method proxy.

Paramètres
string | $name | The method name.
array | $args | The method arguments.
Renvoie
ToolbarButton
Exceptions

Références $button, $name, $this, $type, et class.

◆ addButtonPath()

addButtonPath ( $path )

Add a directory where Toolbar should search for button types in LIFO order.

You may either pass a string or an array of directories.

Toolbar will be searching for an element type in the same order you added them. If the parameter type cannot be found in the custom folders, it will look in libraries/joomla/html/toolbar/button.

Paramètres
mixed $path Directory or directories to search.
Renvoie
void
Depuis
1.5
Obsolète:
5.0 ToolbarButton classes should be autoloaded

Références $dir, $path, et class.

◆ appendButton()

appendButton | ( | $button,
 |  | $args
 | ) |

Append a button to toolbar.

Paramètres
ToolbarButton | $button | The button instance.
array | $args | The more arguments.
Renvoie
ToolbarButton|boolean Return button instance to help chaining configure. If using legacy arguments returns true
Depuis
1.5

Références $button, $this, et class.

◆ createChild()

createChild ( $name )

Create child toolbar.

Paramètres
string $name The toolbar name.
Renvoie
static
Depuis
4.0.0

Références $name.

◆ getButtonPath()

getButtonPath ( )

Get the lookup paths for button objects

Renvoie
array
Depuis
4.0.0
Obsolète:
5.0 ToolbarButton classes should be autoloaded

Références class.

◆ getInstance()

static getInstance ( $name = 'toolbar' )
static

Returns the global Toolbar object, only creating it if it doesn't already exist.

Paramètres
string $name The name of the toolbar.
Renvoie
Toolbar The Toolbar object.
Depuis
1.5
Obsolète:
5.0 Use the ToolbarFactoryInterface instead
Exceptions

Références $name, class, et Factory\getContainer().

Référencé par ToolbarHelper\addNew(), HtmlView\addToolbar(), ListView\addToolbar(), ToolbarHelper\apply(), ToolbarHelper\archiveList(), ToolbarHelper\assign(), ToolbarHelper\back(), ToolbarHelper\cancel(), ToolbarHelper\checkin(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ToolbarHelper\editCss(), ToolbarHelper\editHtml(), ToolbarHelper\editList(), ToolbarHelper\help(), ToolbarHelper\inlinehelp(), ToolbarHelper\jooa11y(), ToolbarHelper\link(), ToolbarHelper\makeDefault(), ToolbarHelper\media_manager(), ToolbarHelper\modal(), ToolbarHelper\preferences(), HtmlView\prepareToolbar(), ToolbarHelper\preview(), ToolbarHelper\publish(), ToolbarHelper\publishList(), ToolbarHelper\save(), ToolbarHelper\save2copy(), ToolbarHelper\save2new(), ToolbarHelper\saveGroup(), ToolbarHelper\spacer(), HtmlView\toolbar(), ToolbarHelper\trash(), ToolbarHelper\unarchiveList(), ToolbarHelper\unpublish(), et ToolbarHelper\unpublishList().

◆ getItems()

getItems ( )

Get the list of toolbar links.

Renvoie
array
Depuis
1.6

◆ getName()

getName ( )

Get the name of the toolbar.

Renvoie
string
Depuis
1.6

◆ loadButtonType()

loadButtonType | ( | $type,
 |  | $new = false
 | ) |

Loads a button type.

Paramètres
string | $type | Button Type
boolean | $new | False by default
Renvoie
false|ToolbarButton
Depuis
1.5

Références $this, $type, Log\add(), et Log\WARNING.

◆ prependButton()

prependButton | ( | $button,
 |  | $args
 | ) |

Prepend a button to toolbar.

Paramètres
ToolbarButton | $button | The button instance.
array | $args | The more arguments.
Renvoie
ToolbarButton|boolean Return button instance to help chaining configure. If using legacy arguments returns true
Depuis
1.5

Références $button, $this, et class.

◆ render()

render ( array $options = [] )

Render a toolbar.

Paramètres
array $options The options of toolbar.
Renvoie
string HTML for the toolbar.
Exceptions

Références $button, $html, $i, $layout, et $options.

◆ renderButton()

renderButton ( & $node )

Render a button.

Paramètres
array &$node A toolbar node.
Renvoie
string
Depuis
1.5
Exceptions

Références $button, $this, $type, et Text\sprintf().

◆ setFactory()

setFactory ( ToolbarFactoryInterface $factory )

Set the factory instance

Paramètres
ToolbarFactoryInterface $factory The factory instance
Renvoie
$this
Depuis
4.0.0

Références $this.

◆ setItems()

setItems ( array $items )

Set the button list.

Paramètres
ToolbarButton[] $items The button list array.
Renvoie
static
Depuis
4.0.0

Références $items, et $this.

Documentation des champs

◆ $_bar

$_bar = []
protected

◆ $_buttonPath

$_buttonPath = []
protected

◆ $_name

$_name = ''
protected

◆ $factory

$factory
protected

◆ $instances

$instances = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Toolbar/Toolbar.php


Joomla CMS: Référence de la classe ToolbarButton

  • Joomla
  • CMS
  • Toolbar
  • ToolbarButton
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe ToolbarButton
+ Graphe d'héritage de ToolbarButton:
BasicButton CustomButton LinkButton PopupButton SeparatorButton AbstractGroupButton HelpButton InlinehelpButton StandardButton DropdownButton ConfirmButton

Fonctions membres publiques

__construct (string $name='', string $text='', array $options=[])
render (&$definition=null)
fetchIconClass ($identifier)
fetchButton ()
getParent ()
setParent (Toolbar $parent)
getOptions ()
setOptions (array $options)
getOption (string $name, $default=null)
setOption (string $name, $value)
getName ()
name (string $name)
getLayout ()
layout (string $layout)
__call (string $name, array $args)

Fonctions membres protégées

prepareOptions (array &$options)
renderButton (array &$options)
fetchId ()
ensureUniqueId (string $id)

Fonctions membres protégées statiques

static getAccessors ()

Attributs protégés

$name
$parent
$layout
$options = []

Attributs protégés statiques

static $idCounter = []

Fonctions membres privées statiques

static findOptionName (string $name)

Description détaillée

The ToolbarButton class.

self text(string $value) self task(string $value) self icon(string $value) self buttonClass(string $value) self attributes(array $value) self onclick(array $value) self listCheck(bool $value) self listCheckMessage(string $value) self form(string $value) self formValidation(bool $value) string getText() string getTask() string getIcon() string getButtonClass() array getAttributes() string getOnclick() bool getListCheck() string getListCheckMessage() string getForm() bool getFormValidation()

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name = '',
 |  | string | $text = '',
 |  | array | $options = []
 | ) |  |

Init this class.

Paramètres
string | $name | Name of this button.
string | $text | The button text, will auto translate.
array | $options | Button options.
Depuis
4.0.0
Exceptions

Références $name, $options, $text, ArrayHelper\mergeRecursive(), et name.

Documentation des fonctions membres

◆ __call()

__call | ( | string | $name,
 |  | array | $args
 | ) |  |

Magiix method to adapt option accessors.

Paramètres
string | $name | The method name.
array | $args | The method arguments.
Renvoie
mixed
Exceptions

Références $name.

◆ ensureUniqueId()

ensureUniqueId ( string $id )
protected

Make sure the id is unique

Paramètres
string $id The id string.
Renvoie
string
Depuis
4.0.0

Références $id.

◆ fetchButton()

fetchButton ( )
abstract

Get the button

Defined in the final button class

Renvoie
string
Depuis
3.0
Obsolète:
5.0 Use render() instead.

◆ fetchIconClass()

fetchIconClass ( $identifier )

Method to get the CSS class name for an icon identifier

Can be redefined in the final class

Paramètres
string $identifier Icon identification string
Renvoie
string CSS class name
Depuis
3.0

Références $layout.

◆ fetchId()

fetchId ( )
protected

Get the button CSS Id.

Renvoie
string Button CSS Id
Depuis
3.0

Références parent.

◆ findOptionName()

static findOptionName ( string $name )
staticprivate

Find field option name from accessors.

Paramètres
string $name The field name.
Renvoie
boolean|string
Depuis
4.0.0

Références $name.

◆ getAccessors()

static getAccessors ( )
staticprotected

Method to configure available option accessors.

Renvoie
array
Depuis
4.0.0

◆ getLayout()

getLayout ( )

Get layout path.

Renvoie
string
Depuis
4.0.0

Références $layout.

◆ getName()

getName ( )

Get button name.

Renvoie
string
Depuis
4.0.0

Références $name.

◆ getOption()

getOption | ( | string | $name,
 |  |  | $default = null
 | ) |  |

Get single option value.

Paramètres
string | $name | The option name.
mixed | $default | The default value if this name not exists.
Renvoie
mixed
Depuis
4.0.0

Références $default, et $name.

◆ getOptions()

getOptions ( )

Get button options.

Renvoie
array
Depuis
4.0.0

Références $options.

◆ getParent()

getParent ( )

Get parent toolbar instance.

Renvoie
Toolbar
Depuis
4.0.0

◆ layout()

layout ( string $layout )

Set layout path.

Paramètres
string $layout The layout path name to render.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $layout, et $this.

◆ name()

name ( string $name )

Set button name.

Paramètres
string $name The button name.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $name, $this, et name.

◆ prepareOptions()

prepareOptions ( array & $options )
protected

Prepare options for this button.

Paramètres
array &$options The options about this button.
Renvoie
void
Depuis
4.0.0

Références $options, et Text\_().

◆ render()

render ( & $definition = null )

Get the HTML to render the button

Paramètres
array &$definition Parameters to be passed
Renvoie
string
Depuis
3.0
Exceptions

Références $layout, elseif, et null.

◆ renderButton()

renderButton ( array & $options )
protected

Render button HTML.

Paramètres
array &$options The button options.
Renvoie
string The button HTML.
Depuis
4.0.0

Références $buttonClass, $layout, $options, et ArrayHelper\toString().

◆ setOption()

setOption | ( | string | $name,
 |  |  | $value
 | ) |  |

Set option value.

Paramètres
string | $name | The option name to store value.
mixed | $value | The option value.
Renvoie
static
Depuis
4.0.0

Références $name, $this, et $value.

◆ setOptions()

setOptions ( array $options )

Set all options.

Paramètres
array $options The button options.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $options, et $this.

◆ setParent()

setParent ( Toolbar $parent )

Set parent Toolbar instance.

Paramètres
Toolbar $parent The parent Toolbar instance to set.
Renvoie
static Return self to support chaining.
Depuis
4.0.0

Références $this, et parent.

Documentation des champs

◆ $idCounter

$idCounter = []
staticprotected

◆ $layout

$layout
protected

◆ $name

$name
protected

◆ $options

$options = []
protected

◆ $parent

$parent
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ToolbarButton.php


Joomla CMS: Référence de l'interface ToolbarFactoryInterface

  • Joomla
  • CMS
  • Toolbar
  • ToolbarFactoryInterface
Fonctions membres publiques
Référence de l'interface ToolbarFactoryInterface
+ Graphe d'héritage de ToolbarFactoryInterface:
ContainerAwareToolbarFactory

Fonctions membres publiques

createButton (Toolbar $toolbar, string $type)
createToolbar (string $name='toolbar')

Description détaillée

Interface for creating toolbar objects

Depuis
4.0.0

Documentation des fonctions membres

◆ createButton()

createButton | ( | Toolbar | $toolbar,
 |  | string | $type
 | ) |  |

Creates a new toolbar button.

Paramètres
Toolbar | $toolbar | The Toolbar instance to attach to the button
string | $type | Button Type
Renvoie
ToolbarButton
Depuis
4.0.0
Exceptions

◆ createToolbar()

createToolbar ( string $name = 'toolbar' )

Creates a new Toolbar object.

Paramètres
string $name The toolbar name.
Renvoie
Toolbar
Depuis
4.0.0

Implémenté dans ContainerAwareToolbarFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ToolbarFactoryInterface.php


Joomla CMS: Référence de la classe ToolbarHelper

  • Joomla
  • CMS
  • Toolbar
  • ToolbarHelper
Fonctions membres publiques statiques
Référence de la classe ToolbarHelper

Fonctions membres publiques statiques

static | title ($title, $icon='generic.png')
static | spacer ($width='')
static | divider ()
static | custom ($task='', $icon='', $iconOver='', $alt='', $listSelect=true, $formId=null)
static | preview ($url='', $updateEditors=false, $icon='preview', $bodyHeight=null, $modalWidth=null)
static | jooa11y ($url='', $updateEditors=false, $icon='icon-universal-access', $bodyHeight=null, $modalWidth=null)
static | help ($ref, $com=false, $override=null, $component=null)
static | inlinehelp (string $class="hide-aware-inline-help")
static | back ($alt='JTOOLBAR_BACK', $href='javascript:history.back();')
static | link ($url, $text, $name='link')
static | media_manager ($directory='', $alt='JTOOLBAR_UPLOAD')
static | makeDefault ($task='default', $alt='JTOOLBAR_DEFAULT')
static | assign ($task='assign', $alt='JTOOLBAR_ASSIGN')
static | addNew ($task='add', $alt='JTOOLBAR_NEW', $check=false)
static | publish ($task='publish', $alt='JTOOLBAR_PUBLISH', $check=false)
static | publishList ($task='publish', $alt='JTOOLBAR_PUBLISH')
static | unpublish ($task='unpublish', $alt='JTOOLBAR_UNPUBLISH', $check=false)
static | unpublishList ($task='unpublish', $alt='JTOOLBAR_UNPUBLISH')
static | archiveList ($task='archive', $alt='JTOOLBAR_ARCHIVE')
static | unarchiveList ($task='unarchive', $alt='JTOOLBAR_UNARCHIVE')
static | editList ($task='edit', $alt='JTOOLBAR_EDIT')
static | editHtml ($task='edit_source', $alt='JTOOLBAR_EDIT_HTML')
static | editCss ($task='edit_css', $alt='JTOOLBAR_EDIT_CSS')
static | deleteList ($msg='', $task='remove', $alt='JTOOLBAR_DELETE')
static | trash ($task='remove', $alt='JTOOLBAR_TRASH', $check=true)
static | apply ($task='apply', $alt='JTOOLBAR_APPLY')
static | save ($task='save', $alt='JTOOLBAR_SAVE')
static | save2new ($task='save2new', $alt='JTOOLBAR_SAVE_AND_NEW')
static | save2copy ($task='save2copy', $alt='JTOOLBAR_SAVE_AS_COPY')
static | checkin ($task='checkin', $alt='JTOOLBAR_CHECKIN', $check=true)
static | cancel ($task='cancel', $alt='JTOOLBAR_CANCEL')
static | preferences ($component, $height=550, $width=875, $alt='JTOOLBAR_OPTIONS', $path='')
static | saveGroup ($buttons=array(), $class='btn-success')
static | modal ($targetModalId, $icon, $alt, $class='btn-primary')

Description détaillée

Utility class for the button bar.

Depuis
1.5

Documentation des fonctions membres

◆ addNew()

static addNew | ( | $task = 'add',
 |  | $alt = 'JTOOLBAR_NEW',
 |  | $check = false
 | ) |
static

Writes the common 'new' icon for the button bar.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
boolean | $check | True if required to check that a standard list item is checked.
Renvoie
void
Depuis
1.5

Références $alt, $check, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), et ListView\addToolbar().

◆ apply()

static apply | ( | $task = 'apply',
 |  | $alt = 'JTOOLBAR_APPLY'
 | ) |
static

Writes a save button for a given option. Apply operation leads to a save action only (does not leave edit mode).

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ archiveList()

static archiveList | ( | $task = 'archive',
 |  | $alt = 'JTOOLBAR_ARCHIVE'
 | ) |
static

Writes a common 'archive' button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ assign()

static assign | ( | $task = 'assign',
 |  | $alt = 'JTOOLBAR_ASSIGN'
 | ) |
static

Writes a common 'assign' button for a record.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

◆ back()

static back | ( | $alt = 'JTOOLBAR_BACK',
 |  | $href = 'javascript:history.back();'
 | ) |
static

Writes a cancel button that will go back to the previous page without doing any other operation.

Paramètres
string | $alt | Alternative text.
string | $href | URL of the href attribute.
Renvoie
void
Depuis
1.5

Références $alt, $href, Toolbar\getInstance(), et Factory\getLanguage().

◆ cancel()

static cancel | ( | $task = 'cancel',
 |  | $alt = 'JTOOLBAR_CANCEL'
 | ) |
static

Writes a cancel button and invokes a cancel operation (eg a checkin).

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par FormView\addToolbar(), et HtmlView\addToolbar().

◆ checkin()

static checkin | ( | $task = 'checkin',
 |  | $alt = 'JTOOLBAR_CHECKIN',
 |  | $check = true
 | ) |
static

Writes a checkin button for a given option.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
boolean | $check | True if required to check that a standard list item is checked.
Renvoie
void
Depuis
1.7

Références $alt, $check, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ custom()

static custom | ( | $task = '',
 |  | $icon = '',
 |  | $iconOver = '',
 |  | $alt = '',
 |  | $listSelect = true,
 |  | $formId = null
 | ) |
static

Writes a custom option and task button for the button bar.

Paramètres
string | $task | The task to perform (picked up by the switch($task) blocks).
string | $icon | The image to display.
string | $iconOver

Références $alt, $formId, $icon, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), et ListView\addToolbar().

◆ deleteList()

static deleteList | ( | $msg = '',
 |  | $task = 'remove',
 |  | $alt = 'JTOOLBAR_DELETE'
 | ) |
static

Writes a common 'delete' button for a list of records.

Paramètres
string | $msg | Postscript for the 'are you sure' message.
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), et ListView\addToolbar().

◆ divider()

static divider ( )
static

Writes a divider between menu buttons

Renvoie
void
Depuis
1.5

Références Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), FormView\addToolbar(), et HtmlView\prepareToolbar().

◆ editCss()

static editCss | ( | $task = 'edit_css',
 |  | $alt = 'JTOOLBAR_EDIT_CSS'
 | ) |
static

Writes a common 'edit' button for a template css.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

◆ editHtml()

static editHtml | ( | $task = 'edit_source',
 |  | $alt = 'JTOOLBAR_EDIT_HTML'
 | ) |
static

Writes a common 'edit' button for a template html.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

◆ editList()

static editList | ( | $task = 'edit',
 |  | $alt = 'JTOOLBAR_EDIT'
 | ) |
static

Writes a common 'edit' button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ help()

static help | ( | $ref,
 |  | $com = false,
 |  | $override = null,
 |  | $component = null
 | ) |
static

Writes a help button for a given option (opens a popup window).

Paramètres
string | $ref | The name of the popup file (excluding the file extension for an xml file).
bool | $com | Use the help file in the component directory.
string | $override | Use this URL instead of any other
string | $component | Name of component to get Help (null for current component)
Renvoie
void
Depuis
1.5

Références $component, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), FormView\addToolbar(), ListView\addToolbar(), HtmlView\display(), et HtmlView\prepareToolbar().

◆ inlinehelp()

static inlinehelp ( string $class = "hide-aware-inline-help" )
static

Writes a help button for showing/hiding the inline help of a form

Paramètres
string $class The class used by the inline help items.
Renvoie
void
Depuis
4.1.0

Références $class, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ jooa11y()

static jooa11y | ( | $url = '',
 |  | $updateEditors = false,
 |  | $icon = 'icon-universal-access',
 |  | $bodyHeight = null,
 |  | $modalWidth = null
 | ) |
static

Writes a jooa11y accessibility checker button for a given option (opens a popup window).

Paramètres
string | $url | The url to open
bool | $updateEditors | Unused
string | $icon | The image to display.
integer | $bodyHeight | The body height of the preview popup
integer | $modalWidth | The modal width of the preview popup
Renvoie
void
Depuis
4.1.0

Références $bodyHeight, $icon, $modalWidth, $url, et Toolbar\getInstance().

◆ link()

static link | ( | $url,
 |  | $text,
 |  | $name = 'link'
 | ) |
static

Creates a button to redirect to a link

Paramètres
string | $url | The link url
string | $text | Button text
string | $name | Name to be used as apart of the id
Renvoie
void
Depuis
3.5

Références $name, $text, $url, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ makeDefault()

static makeDefault | ( | $task = 'default',
 |  | $alt = 'JTOOLBAR_DEFAULT'
 | ) |
static

Writes a common 'default' button for a record.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ media_manager()

static media_manager | ( | $directory = '',
 |  | $alt = 'JTOOLBAR_UPLOAD'
 | ) |
static

Writes a media_manager button.

Paramètres
string | $directory | The subdirectory to upload the media to.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, et Toolbar\getInstance().

◆ modal()

static modal | ( | $targetModalId,
 |  | $icon,
 |  | $alt,
 |  | $class = 'btn-primary'
 | ) |
static

Displays a modal button

Paramètres
string | $targetModalId | ID of the target modal box
string | $icon | Icon class to show on modal button
string | $alt | Title for the modal button
string | $class | The button class
Renvoie
void
Depuis
3.2

Références $alt, $class, $icon, $title, Text\_(), et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ preferences()

static preferences | ( | $component,
 |  | $height = 550,
 |  | $width = 875,
 |  | $alt = 'JTOOLBAR_OPTIONS',
 |  | $path = ''
 | ) |
static

Writes a configuration button and invokes a cancel operation (eg a checkin).

Paramètres
string | $component | The name of the component, eg, com_content.
integer | $height | The height of the popup. [UNUSED]
integer | $width | The width of the popup. [UNUSED]
string | $alt | The name of the button.
string | $path | An alternative path for the configuration xml relative to JPATH_SITE.
Renvoie
void
Depuis
1.5

Références $alt, $component, $path, $return, $uri, Uri\getInstance(), et Toolbar\getInstance().

Référencé par HtmlView\addToolbar(), ListView\addToolbar(), et HtmlView\prepareToolbar().

◆ preview()

static preview | ( | $url = '',
 |  | $updateEditors = false,
 |  | $icon = 'preview',
 |  | $bodyHeight = null,
 |  | $modalWidth = null
 | ) |
static

Writes a preview button for a given option (opens a popup window).

Paramètres
string | $url | The name of the popup file (excluding the file extension)
bool | $updateEditors | Unused
string | $icon | The image to display.
integer | $bodyHeight | The body height of the preview popup
integer | $modalWidth | The modal width of the preview popup
Renvoie
void
Depuis
1.5

Références $bodyHeight, $icon, $modalWidth, $url, et Toolbar\getInstance().

Référencé par FormView\addToolbar().

◆ publish()

static publish | ( | $task = 'publish',
 |  | $alt = 'JTOOLBAR_PUBLISH',
 |  | $check = false
 | ) |
static

Writes a common 'publish' button.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
boolean | $check | True if required to check that a standard list item is checked.
Renvoie
void
Depuis
1.5

Références $alt, $check, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ publishList()

static publishList | ( | $task = 'publish',
 |  | $alt = 'JTOOLBAR_PUBLISH'
 | ) |
static

Writes a common 'publish' button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

◆ save()

static save | ( | $task = 'save',
 |  | $alt = 'JTOOLBAR_SAVE'
 | ) |
static

Writes a save button for a given option. Save operation leads to a save and then close action.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

Référencé par HtmlView\addToolbar().

◆ save2copy()

static save2copy | ( | $task = 'save2copy',
 |  | $alt = 'JTOOLBAR_SAVE_AS_COPY'
 | ) |
static

Writes a save as copy button for a given option. Save as copy operation leads to a save after clearing the key, then returns user to edit mode with new key.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.6

Références $alt, $task, et Toolbar\getInstance().

◆ save2new()

static save2new | ( | $task = 'save2new',
 |  | $alt = 'JTOOLBAR_SAVE_AND_NEW'
 | ) |
static

Writes a save and create new button for a given option. Save and create operation leads to a save and then add action.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.6

Références $alt, $task, et Toolbar\getInstance().

◆ saveGroup()

static saveGroup | ( | $buttons = array(),
 |  | $class = 'btn-success'
 | ) |
static

Writes a save button for a given option, with an additional dropdown

Paramètres
array | $buttons | An array of buttons
string | $class | The button class
Renvoie
void
Depuis
4.0.0

Références $button, $buttons, $options, Toolbar\getInstance(), et text.

Référencé par HtmlView\addToolbar(), et FormView\addToolbar().

◆ spacer()

static spacer ( $width = '' )
static

Writes a spacer cell.

Paramètres
string $width The width for the cell
Renvoie
void
Depuis
1.5

Références $width, et Toolbar\getInstance().

◆ title()

static title | ( | $title,
 |  | $icon = 'generic.png'
 | ) |
static

Title cell. For the title and toolbar to be rendered correctly, this title function must be called before the starttable function and the toolbars icons this is due to the nature of how the css has been used to position the title in respect to the toolbar.

Paramètres
string | $title | The title.
string | $icon | The space-separated names of the image.
Renvoie
void
Depuis
1.5

Références $app, $html, $icon, $layout, $title, Text\_(), Factory\getApplication(), et Factory\getDocument().

Référencé par HtmlView\addToolbar(), FormView\addToolbar(), ListView\addToolbar(), HtmlView\display(), et HtmlView\prepareToolbar().

◆ trash()

static trash | ( | $task = 'remove',
 |  | $alt = 'JTOOLBAR_TRASH',
 |  | $check = true
 | ) |
static

Writes a common 'trash' button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
bool | $check | True to allow lists.
Renvoie
void
Depuis
1.5

Références $alt, $check, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ unarchiveList()

static unarchiveList | ( | $task = 'unarchive',
 |  | $alt = 'JTOOLBAR_UNARCHIVE'
 | ) |
static

Writes an unarchive button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

◆ unpublish()

static unpublish | ( | $task = 'unpublish',
 |  | $alt = 'JTOOLBAR_UNPUBLISH',
 |  | $check = false
 | ) |
static

Writes a common 'unpublish' button.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
boolean | $check | True if required to check that a standard list item is checked.
Renvoie
void
Depuis
1.5

Références $alt, $check, $task, et Toolbar\getInstance().

Référencé par ListView\addToolbar().

◆ unpublishList()

static unpublishList | ( | $task = 'unpublish',
 |  | $alt = 'JTOOLBAR_UNPUBLISH'
 | ) |
static

Writes a common 'unpublish' button for a list of records.

Paramètres
string | $task | An override for the task.
string | $alt | An override for the alt text.
Renvoie
void
Depuis
1.5

Références $alt, $task, et Toolbar\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ToolbarHelper.php


Joomla CMS: Référence de l'interface ImmutableNodeInterface

  • Joomla
  • CMS
  • Tree
  • ImmutableNodeInterface
Fonctions membres publiques
Référence de l'interface ImmutableNodeInterface
+ Graphe d'héritage de ImmutableNodeInterface:
NodeInterface CategoryNode MenuItem AdministratorMenuItem

Fonctions membres publiques

& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)

Description détaillée

Interface for an immutable node class

Depuis
4.0.0

Documentation des fonctions membres

◆ getChildren()

& getChildren ( $recursive = false )

Get the children of this node

Paramètres
boolean $recursive False by default
Renvoie
NodeInterface[] The children
Depuis
4.0.0

Implémenté dans CategoryNode.

◆ getParent()

getParent ( )

Get the parent of this node

Renvoie
NodeInterface|null
Depuis
4.0.0

Référencé par Taxonomy\addNestedNode().

◆ getRoot()

getRoot ( )

Get the root of the tree

Renvoie
ImmutableNodeInterface
Depuis
4.0.0

◆ getSibling()

getSibling ( $right = true )

Returns the right or left sibling of a node

Paramètres
boolean $right If set to false, returns the left sibling
Renvoie
NodeInterface|null NodeInterface object of the sibling.
Depuis
4.0.0

Implémenté dans CategoryNode.

◆ hasChildren()

hasChildren ( )

Test if this node has children

Renvoie
boolean True if there is a child
Depuis
4.0.0

◆ hasParent()

hasParent ( )

Test if this node has a parent

Renvoie
boolean True if there is a parent
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • ImmutableNodeInterface.php


Joomla CMS: Référence de l'interface NodeInterface

  • Joomla
  • CMS
  • Tree
  • NodeInterface
Fonctions membres publiques
Référence de l'interface NodeInterface
+ Graphe d'héritage de NodeInterface:
ImmutableNodeInterface CategoryNode MenuItem AdministratorMenuItem

Fonctions membres publiques

setParent (NodeInterface $parent)
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)
- Fonctions membres publiques hérités de ImmutableNodeInterface
& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)

Description détaillée

Interface for a node class

Depuis
4.0.0

Documentation des fonctions membres

◆ addChild()

addChild ( NodeInterface $child )

Add child to this node

If the child already has a parent, the link is unset

Paramètres
NodeInterface $child The child to be added.
Renvoie
void
Depuis
4.0.0

◆ removeChild()

removeChild ( NodeInterface $child )

Remove a specific child

Paramètres
NodeInterface $child Child to remove
Renvoie
void
Depuis
4.0.0

◆ setParent()

setParent ( NodeInterface $parent )

Set the parent of this node

If the node already has a parent, the link is unset

Paramètres
NodeInterface | null $parent NodeInterface for the parent to be set or null
Renvoie
void
Depuis
4.0.0

Implémenté dans CategoryNode.

Référencé par Joomla\CMS\Tree\addChild().

◆ setSibling()

setSibling | ( | NodeInterface | $sibling,
 |  |  | $right = true
 | ) |  |

Function to set the left or right sibling of a node

Paramètres
NodeInterface | $sibling | NodeInterface object for the sibling
boolean | $right | If set to false, the sibling is the left one
Renvoie
void
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • NodeInterface.php


Joomla CMS: Référence de l'interface UCM

  • Joomla
  • CMS
  • UCM
  • UCM
Référence de l'interface UCM
+ Graphe d'héritage de UCM:
UCMBase UCMType UCMContent

Description détaillée

Interface to handle UCM

Depuis
3.1
La documentation de cette interface a été générée à partir du fichier suivant :
  • UCM.php


Joomla CMS: Référence de la classe UCMBase

  • Joomla
  • CMS
  • UCM
  • UCMBase
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UCMBase
+ Graphe d'héritage de UCMBase:
UCM UCMContent

Fonctions membres publiques

__construct ($alias=null, UCMType $type=null)
getType ()
mapBase ($original, UCMType $type=null)

Fonctions membres protégées

store ($data, TableInterface $table=null, $primaryKey=null)

Attributs protégés

$type
$alias

Description détaillée

Base class for implementing UCM

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $alias = null,
 |  | UCMType | $type = null
 | ) |  |

Instantiate the UCMBase.

Paramètres
string | $alias | The alias string
UCMType | $type | The type object
Depuis
3.1

Références $input, $type, et Factory\getApplication().

Documentation des fonctions membres

◆ getType()

getType ( )

Get the UCM Content type.

Renvoie
UCMType The UCM content type
Depuis
3.1

Références $type.

◆ mapBase()

mapBase | ( |  | $original,
 |  | UCMType | $type = null
 | ) |  |

Method to map the base ucm fields

Paramètres
array | $original | Data array
UCMType | $type | UCM Content Type
Renvoie
array Data array of UCM mappings
Depuis
3.1

Références $data, $type, et ContentHelper\getLanguageId().

◆ store()

store | ( |  | $data,
 |  | TableInterface | $table = null,
 |  |  | $primaryKey = null
 | ) |  |
protected

Store data to the appropriate table

Paramètres
array | $data | Data to be stored
TableInterface | $table | Table Object
string | $primaryKey | The primary key name
Renvoie
boolean True on success
Depuis
3.1
Exceptions

Références $data, Table\getInstance(), et null.

Documentation des champs

◆ $alias

$alias
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UCMBase.php


Joomla CMS: Référence de la classe UCMContent

  • Joomla
  • CMS
  • UCM
  • UCMContent
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe UCMContent
+ Graphe d'héritage de UCMContent:
UCMBase UCM

Fonctions membres publiques

__construct (TableInterface $table=null, $alias=null, UCMType $type=null)
save ($original=null, UCMType $type=null)
delete ($pk, UCMType $type=null)
mapData ($original, UCMType $type=null)
getPrimaryKey ($typeId, $contentItemId)
- Fonctions membres publiques hérités de UCMBase
__construct ($alias=null, UCMType $type=null)
getType ()
mapBase ($original, UCMType $type=null)

Champs de données

$ucmData

Fonctions membres protégées

store ($data, TableInterface $table=null, $primaryKey=null)
- Fonctions membres protégées hérités de UCMBase
store ($data, TableInterface $table=null, $primaryKey=null)

Attributs protégés

$table
- Attributs protégés hérités de UCMBase
$type
$alias

Description détaillée

Base class for implementing UCM

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | TableInterface | $table = null,
 |  |  | $alias = null,
 |  | UCMType | $type = null
 | ) |  |

Instantiate UCMContent.

Paramètres
TableInterface | $table | The table object
string | $alias | The type alias
UCMType | $type | The type object
Depuis
3.1

Références $type, Symfony\Contracts\Service\__construct(), et Table\getInstance().

Documentation des fonctions membres

◆ delete()

delete | ( |  | $pk,
 |  | UCMType | $type = null
 | ) |  |

Delete content from the Core Content table

Paramètres
mixed | $pk | Array or comma-separated string of ids to delete
UCMType | $type | The content type object
Renvoie
boolean True if success
Depuis
3.1

Références $db, $query, $type, Factory\getDbo(), et ParameterType\INTEGER.

◆ getPrimaryKey()

getPrimaryKey | ( | $typeId,
 |  | $contentItemId
 | ) |

Get the value of the primary key from #__ucm_base

Paramètres
integer | $typeId | The ID for the type
integer | $contentItemId | Value of the primary key in the legacy or secondary table
Renvoie
integer The integer of the primary key
Depuis
3.1

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ mapData()

mapData | ( |  | $original,
 |  | UCMType | $type = null
 | ) |  |

Map the original content to the Core Content fields

Paramètres
array | $original | The original data array
UCMType | $type | Type object for this data
Renvoie
array $ucmData The mapped UCM data
Depuis
3.1

Références $field, $fields, $i, et $type.

◆ save()

save | ( |  | $original = null,
 |  | UCMType | $type = null
 | ) |  |

Method to save the data

Paramètres
array | $original | The original data to be saved
UCMType | $type | The UCM Type object
Renvoie
boolean true
Depuis
3.1

Références $type.

◆ store()

store | ( |  | $data,
 |  | TableInterface | $table = null,
 |  |  | $primaryKey = null
 | ) |  |
protected

Store data to the appropriate table

Paramètres
array | $data | Data to be stored
TableInterface | $table | Table Object
boolean | $primaryKey | Flag that is true for data that are using #__ucm_content as their primary table
Renvoie
boolean true on success
Depuis
3.1

Références $data, Table\getInstance(), et ContentHelper\getLanguageId().

Documentation des champs

◆ $table

$table
protected

◆ $ucmData

$ucmData
La documentation de cette classe a été générée à partir du fichier suivant :
  • UCMContent.php


Joomla CMS: Référence de la classe UCMType

  • Joomla
  • CMS
  • UCM
  • UCMType
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe UCMType
+ Graphe d'héritage de UCMType:
UCM

Fonctions membres publiques

__construct ($alias=null, DatabaseDriver $database=null, AbstractApplication $application=null)
getType ($pk=null)
getTypeByAlias ($typeAlias=null)
getTypeByTable ($tableName)
getTypeId ($alias=null)
fieldmapExpand ($assoc=false)
__get ($ucmField)

Champs de données

$type

Attributs protégés

$db
$alias

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $alias = null,
 |  | DatabaseDriver | $database = null,
 |  | AbstractApplication | $application = null
 | ) |  |

Class constructor

Paramètres
string | $alias | The alias for the item
DatabaseDriver | $database | The database object
AbstractApplication | $application | The application object
Depuis
3.1

Références $app, Factory\getApplication(), et Factory\getDbo().

Documentation des fonctions membres

◆ __get()

__get ( $ucmField )

Magic method to get the name of the field mapped to a ucm field (core_something).

Paramètres
string $ucmField The name of the field in JTableCorecontent
Renvoie
string The name mapped to the $ucmField for a given content type
Depuis
3.2

Références null.

◆ fieldmapExpand()

fieldmapExpand ( $assoc = false )

Method to expand the field mapping

Paramètres
boolean $assoc True to return an associative array.
Renvoie
mixed Array or object with field mappings. Defaults to object.
Depuis
3.2

Références $assoc.

◆ getType()

getType ( $pk = null )

Get the Content Type

Paramètres
integer $pk The primary key of the alias type
Renvoie
object The UCM Type data
Depuis
3.1

Références $query, et ParameterType\INTEGER.

◆ getTypeByAlias()

getTypeByAlias ( $typeAlias = null )

Get the Content Type from the alias

Paramètres
string $typeAlias The alias for the type
Renvoie
object The UCM Type data
Depuis
3.2

Références $query.

◆ getTypeByTable()

getTypeByTable ( $tableName )

Get the Content Type from the table class name

Paramètres
string $tableName The table for the type
Renvoie
mixed The UCM Type data if found, false if no match is found
Depuis
3.2

Références $query, et $type.

◆ getTypeId()

getTypeId ( $alias = null )

Retrieves the UCM type ID

Paramètres
string $alias The string of the type alias
Renvoie
mixed The ID of the requested type or false if type is not found
Depuis
3.1

Références $id, et $query.

Documentation des champs

◆ $alias

$alias
protected

◆ $db

$db
protected

◆ $type

$type
La documentation de cette classe a été générée à partir du fichier suivant :
  • UCMType.php


Joomla CMS: Référence de la classe CollectionAdapter

  • Joomla
  • CMS
  • Updater
  • Adapter
  • CollectionAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CollectionAdapter
+ Graphe d'héritage de CollectionAdapter:
UpdateAdapter AdapterInstance CMSObject

Fonctions membres publiques

_startElement ($parser, $name, $attrs=array())
findUpdate ($options)
- Fonctions membres publiques hérités de UpdateAdapter
findUpdate ($options)
- Fonctions membres publiques hérités de AdapterInstance
__construct (Adapter $parent, DatabaseDriver $db, array $options=array())
getParent ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres protégées

_getStackLocation ()
_getParent ()
_endElement ($parser, $name)
- Fonctions membres protégées hérités de UpdateAdapter
_getStackLocation ()
_getLastTag ()
toggleUpdateSite ($updateSiteId, $enabled=true)
getUpdateSiteName ($updateSiteId)
getUpdateSiteResponse ($options=array())

Attributs protégés

$base
$parent = array(0)
$pop_parent = 0
$update_sites = array()
$updates = array()
- Attributs protégés hérités de UpdateAdapter
$xmlParser
$stack = array('base')
$updateSiteId = 0
$updatecols = array('NAME', 'ELEMENT', 'TYPE', 'FOLDER', 'CLIENT', 'VERSION', 'DESCRIPTION', 'INFOURL', 'CHANGELOGURL', 'EXTRA_QUERY')
$appendExtension = false
$updateSiteName = ''
$_url = ''
$minimum_stability = Updater::STABILITY_STABLE
- Attributs protégés hérités de AdapterInstance
$parent = null
$db = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Collection Update Adapter Class

Depuis
1.7.0

Documentation des fonctions membres

◆ _endElement()

_endElement | ( | $parser,
 |  | $name
 | ) |
protected

Closing an XML element Note: This is a protected function though has to be exposed externally as a callback

Paramètres
object | $parser | Parser object
string | $name | Name of the element closing
Renvoie
void
Depuis
1.7.0

Références $name, et parent.

◆ _getParent()

_getParent ( )
protected

Get the parent tag

Renvoie
string parent
Depuis
1.7.0

Références parent.

◆ _getStackLocation()

_getStackLocation ( )
protected

Gets the reference to the current direct parent

Renvoie
string
Depuis
1.7.0

◆ _startElement()

_startElement | ( | $parser,
 |  | $name,
 |  | $attrs = array()
 | ) |

Opening an XML element

Paramètres
object | $parser | Parser object
string | $name | Name of element that is opened
array | $attrs | Array of attributes for the element
Renvoie
void
Depuis
1.7.0

Références $attr, $client, $key, $name, ApplicationHelper\getClientInfo(), InputFilter\getInstance(), et Table\getInstance().

◆ findUpdate()

findUpdate ( $options )

Finds an update

Paramètres
array $options Options to use: update_site_id: the unique ID of the update site to look at
Renvoie
array|boolean Update_sites and updates discovered. False on failure
Depuis
1.7.0

Références $app, $options, $this, Factory\getApplication(), et Text\sprintf().

Documentation des champs

◆ $base

$base
protected

◆ $parent

$parent = array(0)
protected

◆ $pop_parent

$pop_parent = 0
protected

◆ $update_sites

$update_sites = array()
protected

◆ $updates

$updates = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CollectionAdapter.php


Joomla CMS: Référence de la classe ExtensionAdapter

  • Joomla
  • CMS
  • Updater
  • Adapter
  • ExtensionAdapter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ExtensionAdapter
+ Graphe d'héritage de ExtensionAdapter:
UpdateAdapter AdapterInstance CMSObject

Fonctions membres publiques

findUpdate ($options)
- Fonctions membres publiques hérités de UpdateAdapter
findUpdate ($options)
- Fonctions membres publiques hérités de AdapterInstance
__construct (Adapter $parent, DatabaseDriver $db, array $options=array())
getParent ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres protégées

_startElement ($parser, $name, $attrs=array())
_endElement ($parser, $name)
_characterData ($parser, $data)
stabilityTagToInteger ($tag)
- Fonctions membres protégées hérités de UpdateAdapter
_getStackLocation ()
_getLastTag ()
toggleUpdateSite ($updateSiteId, $enabled=true)
getUpdateSiteName ($updateSiteId)
getUpdateSiteResponse ($options=array())

Membres hérités additionnels

- Attributs protégés hérités de UpdateAdapter
$xmlParser
$stack = array('base')
$updateSiteId = 0
$updatecols = array('NAME', 'ELEMENT', 'TYPE', 'FOLDER', 'CLIENT', 'VERSION', 'DESCRIPTION', 'INFOURL', 'CHANGELOGURL', 'EXTRA_QUERY')
$appendExtension = false
$updateSiteName = ''
$_url = ''
$minimum_stability = Updater::STABILITY_STABLE
- Attributs protégés hérités de AdapterInstance
$parent = null
$db = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension class for updater

Depuis
1.7.0

Documentation des fonctions membres

◆ _characterData()

_characterData | ( | $parser,
 |  | $data
 | ) |
protected

Character Parser Function

Paramètres
object | $parser | Parser object.
object | $data | The data.
Renvoie
void
Note
This is public because its called externally.
Depuis
1.7.0

Références $data.

◆ _endElement()

_endElement | ( | $parser,
 |  | $name
 | ) |
protected

Character Parser Function

Paramètres
object | $parser | Parser object.
object | $name | The name of the element.
Renvoie
void
Depuis
1.7.0

Références $db, $name, $this, Text\_(), Factory\getApplication(), Factory\getDbo(), InputFilter\getInstance(), Version\PRODUCT, et Text\sprintf().

◆ _startElement()

_startElement | ( | $parser,
 |  | $name,
 |  | $attrs = array()
 | ) |
protected

Start element parser callback.

Paramètres
object | $parser | The parser object.
string | $name | The name of the element.
array | $attrs | The attributes of the element.
Renvoie
void
Depuis
1.7.0

Références $name, et Table\getInstance().

◆ findUpdate()

findUpdate ( $options )

Finds an update.

Paramètres
array $options Update options.
Renvoie
array|boolean Array containing the array of update sites and array of updates. False on failure
Depuis
1.7.0

Références $app, $options, $this, Factory\getApplication(), ApplicationHelper\getClientInfo(), et Text\sprintf().

◆ stabilityTagToInteger()

stabilityTagToInteger ( $tag )
protected

Converts a tag to numeric stability representation. If the tag doesn't represent a known stability level (one of dev, alpha, beta, rc, stable) it is ignored.

Paramètres
string $tag The tag string, e.g. dev, alpha, beta, rc, stable
Renvoie
integer
Depuis
3.4

Références Updater\STABILITY_STABLE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionAdapter.php


Joomla CMS: Référence de la classe DownloadSource

  • Joomla
  • CMS
  • Updater
  • DownloadSource
Champs de données
Référence de la classe DownloadSource

Champs de données

const | FORMAT_TAR_BZIP = 'bz2'
const | FORMAT_TAR_GZ = 'gz'
const | FORMAT_ZIP = 'zip'
const | TYPE_FULL = 'full'
const | TYPE_PATCH = 'patch'
const | TYPE_UPGRADE = 'upgrade'
$type = self::TYPE_FULL
$format = self::FORMAT_ZIP
$url

Description détaillée

Data object representing a download source given as part of an update's <downloads> element

Depuis
3.8.3

Documentation des champs

◆ $format

$format = self::FORMAT_ZIP

◆ $type

$type = self::TYPE_FULL

◆ $url

$url

◆ FORMAT_TAR_BZIP

const FORMAT_TAR_BZIP = 'bz2'

◆ FORMAT_TAR_GZ

const FORMAT_TAR_GZ = 'gz'

◆ FORMAT_ZIP

const FORMAT_ZIP = 'zip'

◆ TYPE_FULL

const TYPE_FULL = 'full'

◆ TYPE_PATCH

const TYPE_PATCH = 'patch'

◆ TYPE_UPGRADE

const TYPE_UPGRADE = 'upgrade'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DownloadSource.php


Joomla CMS: Référence de la classe Update

  • Joomla
  • CMS
  • Updater
  • Update
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Update
+ Graphe d'héritage de Update:
CMSObject

Fonctions membres publiques

_startElement ($parser, $name, $attrs=array())
_endElement ($parser, $name)
_characterData ($parser, $data)
loadFromXml ($url, $minimumStability=Updater::STABILITY_STABLE)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres protégées

_getStackLocation ()
_getLastTag ()
stabilityTagToInteger ($tag)

Attributs protégés

$name
$description
$element
$type
$version
$infourl
$client
$group
$downloads
$downloadSources = array()
$tags
$maintainer
$maintainerurl
$category
$relationships
$targetplatform
$extra_query
$xmlParser
$stack = array('base')
$stateStore = array()
$currentUpdate
$latest
$minimum_stability = Updater::STABILITY_STABLE
$compatibleVersions = array()
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Update class. It is used by Updater::update() to install an update. Use Updater::findUpdates() to find updates for an extension.

Depuis
1.7.0

Documentation des fonctions membres

◆ _characterData()

_characterData | ( | $parser,
 |  | $data
 | ) |

Character Parser Function

Paramètres
object | $parser | Parser object.
object | $data | The data.
Renvoie
void
Note
This is public because its called externally.
Depuis
1.7.0

Références $data.

◆ _endElement()

_endElement | ( | $parser,
 |  | $name
 | ) |

Callback for closing the element

Paramètres
object | $parser | Parser object
string | $name | Name of element that was closed
Renvoie
void
Note
This is public because it is called externally
Depuis
1.7.0

Références $db, $key, $name, $this, $val, elseif, Factory\getDbo(), InputFilter\getInstance(), et Version\PRODUCT.

◆ _getLastTag()

_getLastTag ( )
protected

Get the last position in stack count

Renvoie
string
Depuis
1.7.0

◆ _getStackLocation()

_getStackLocation ( )
protected

Gets the reference to the current direct parent

Renvoie
string
Depuis
1.7.0

◆ _startElement()

_startElement | ( | $parser,
 |  | $name,
 |  | $attrs = array()
 | ) |

XML Start Element callback

Paramètres
object | $parser | Parser object
string | $name | Name of the tag found
array | $attrs | Attributes of the tag
Renvoie
void
Note
This is public because it is called externally
Depuis
1.7.0

Références $data, $key, et $name.

◆ loadFromXml()

loadFromXml | ( | $url,
 |  | $minimumStability = Updater::STABILITY_STABLE
 | ) |

Loads an XML file from a URL.

Paramètres
string | $url | The URL.
int | $minimumStability | The minimum stability required for updating the extension {
Voir également
Updater}
Renvoie
boolean True on success
Depuis
1.7.0

Références $this, $url, $version, Log\add(), HttpFactory\getHttp(), null, Text\sprintf(), et Log\WARNING.

◆ stabilityTagToInteger()

stabilityTagToInteger ( $tag )
protected

Converts a tag to numeric stability representation. If the tag doesn't represent a known stability level (one of dev, alpha, beta, rc, stable) it is ignored.

Paramètres
string $tag The tag string, e.g. dev, alpha, beta, rc, stable
Renvoie
integer
Depuis
3.4

Références Updater\STABILITY_STABLE.

Documentation des champs

◆ $category

$category
protected

◆ $client

$client
protected

◆ $compatibleVersions

$compatibleVersions = array()
protected

◆ $currentUpdate

$currentUpdate
protected

◆ $description

$description
protected

◆ $downloads

$downloads
protected

◆ $downloadSources

$downloadSources = array()
protected

◆ $element

$element
protected

◆ $extra_query

$extra_query
protected

◆ $group

$group
protected

◆ $infourl

$infourl
protected

◆ $latest

$latest
protected

◆ $maintainer

$maintainer
protected

◆ $maintainerurl

$maintainerurl
protected

◆ $minimum_stability

$minimum_stability = Updater::STABILITY_STABLE
protected

◆ $name

$name
protected

◆ $relationships

$relationships
protected

◆ $stack

$stack = array('base')
protected

◆ $stateStore

$stateStore = array()
protected

◆ $tags

$tags
protected

◆ $targetplatform

$targetplatform
protected

◆ $type

$type
protected

◆ $version

$version
protected

◆ $xmlParser

$xmlParser
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Updater/Update.php


Joomla CMS: Référence de la classe UpdateAdapter

  • Joomla
  • CMS
  • Updater
  • UpdateAdapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UpdateAdapter
+ Graphe d'héritage de UpdateAdapter:
AdapterInstance CMSObject CollectionAdapter ExtensionAdapter

Fonctions membres publiques

findUpdate ($options)
- Fonctions membres publiques hérités de AdapterInstance
__construct (Adapter $parent, DatabaseDriver $db, array $options=array())
getParent ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres protégées

_getStackLocation ()
_getLastTag ()
toggleUpdateSite ($updateSiteId, $enabled=true)
getUpdateSiteName ($updateSiteId)
getUpdateSiteResponse ($options=array())

Attributs protégés

$xmlParser
$stack = array('base')
$updateSiteId = 0
$updatecols = array('NAME', 'ELEMENT', 'TYPE', 'FOLDER', 'CLIENT', 'VERSION', 'DESCRIPTION', 'INFOURL', 'CHANGELOGURL', 'EXTRA_QUERY')
$appendExtension = false
$updateSiteName = ''
$_url = ''
$minimum_stability = Updater::STABILITY_STABLE
- Attributs protégés hérités de AdapterInstance
$parent = null
$db = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

UpdateAdapter class.

Depuis
1.7.0

Documentation des fonctions membres

◆ _getLastTag()

_getLastTag ( )
protected

Gets the reference to the last tag

Renvoie
object
Depuis
1.7.0

◆ _getStackLocation()

_getStackLocation ( )
protected

Gets the reference to the current direct parent

Renvoie
string
Depuis
1.7.0

◆ findUpdate()

findUpdate ( $options )
abstract

Finds an update

Paramètres
array $options Options to use: update_site_id: the unique ID of the update site to look at
Renvoie
array Update_sites and updates discovered
Depuis
1.7.0

◆ getUpdateSiteName()

getUpdateSiteName ( $updateSiteId )
protected

Get the name of an update site. This is used in logging.

Paramètres
int $updateSiteId The numeric ID of the update site
Renvoie
string The name of the update site or an empty string if it's not found

Références $db, $name, $query, ParameterType\INTEGER, et parent.

◆ getUpdateSiteResponse()

getUpdateSiteResponse ( $options = array() )
protected

Try to get the raw HTTP response from the update site, hopefully containing the update XML.

Paramètres
array $options The update options, see findUpdate() in children classes
Renvoie
|bool False if we can't connect to the site, HTTP Response object otherwise
Exceptions

Références $app, $options, $startTime, $url, $version, Log\add(), Factory\getApplication(), HttpFactory\getHttp(), Log\INFO, null, Text\sprintf(), et Log\WARNING.

◆ toggleUpdateSite()

toggleUpdateSite | ( | $updateSiteId,
 |  | $enabled = true
 | ) |
protected

Toggles the enabled status of an update site. Update sites are disabled before getting the update information from their URL and enabled afterwards. If the URL fetch fails with a PHP fatal error (e.g. timeout) the faulty update site will remain disabled the next time we attempt to load the update information.

Paramètres
int | $updateSiteId | The numeric ID of the update site to enable/disable
bool | $enabled | Enable the site when true, disable it when false
Renvoie
void

Références $db, $enabled, $query, ParameterType\INTEGER, et parent.

Documentation des champs

◆ $_url

$_url = ''
protected

◆ $appendExtension

$appendExtension = false
protected

◆ $minimum_stability

$minimum_stability = Updater::STABILITY_STABLE
protected

◆ $stack

$stack = array('base')
protected

◆ $updatecols

$updatecols = array('NAME', 'ELEMENT', 'TYPE', 'FOLDER', 'CLIENT', 'VERSION', 'DESCRIPTION', 'INFOURL', 'CHANGELOGURL', 'EXTRA_QUERY')
protected

◆ $updateSiteId

$updateSiteId = 0
protected

◆ $updateSiteName

$updateSiteName = ''
protected

◆ $xmlParser

$xmlParser
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdateAdapter.php


Joomla CMS: Référence de la classe Updater

  • Joomla
  • CMS
  • Updater
  • Updater
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Updater
+ Graphe d'héritage de Updater:
Adapter CMSObject

Fonctions membres publiques

__construct ($basepath=__DIR__, $classprefix='\\Joomla\\CMS\\Updater\\Adapter', $adapterfolder='Adapter')
- Fonctions membres publiques hérités de Adapter
__construct ($basepath, $classprefix=null, $adapterfolder=null)
getDbo ()
getAdapter ($name, $options=array())
setAdapter ($name, &$adapter=null, $options=array())
loadAllAdapters ($options=array())
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres publiques statiques

static getInstance ()

Champs de données

const | STABILITY_DEV = 0
const | STABILITY_ALPHA = 1
const | STABILITY_BETA = 2
const | STABILITY_RC = 3
const | STABILITY_STABLE = 4

Attributs protégés statiques

static $instance

Fonctions membres privées

getUpdateSites ($eid=0)
getSitesWithUpdates ($timestamp=0)
updateLastCheckTimestamp ($updateSiteId)

Membres hérités additionnels

- Attributs protégés hérités de Adapter
$_adapters = array()
$_adapterfolder = 'adapters'
$_classprefix = 'J'
$_basepath = null
$_db
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Updater Class

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $basepath = __DIR__,
 |  | $classprefix = '\\Joomla\\CMS\\Updater\\Adapter',
 |  | $adapterfolder = 'Adapter'
 | ) |

Constructor

Paramètres
string | $basepath | Base Path of the adapters
string | $classprefix | Class prefix of adapters
string | $adapterfolder | Name of folder to append to base path
Depuis
3.1

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getInstance()

static getInstance ( )
static

Returns a reference to the global Installer object, only creating it if it doesn't already exist.

Renvoie
Updater An installer object
Depuis
1.7.0

Référencé par CheckUpdatesCommand\doExecute(), UpdateModel\findUpdates(), UpdateModel\getCheckForSelfUpdate(), LanguagesModel\getItems(), et UpdateModel\refreshUpdates().

◆ getSitesWithUpdates()

getSitesWithUpdates ( $timestamp = 0 )
private

Returns the IDs of the update sites with cached updates

Paramètres
int $timestamp Optional. If set, only update sites checked before $timestamp will be taken into account.
Renvoie
array The IDs of the update sites with cached updates
Depuis
3.6.0

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ getUpdateSites()

getUpdateSites ( $eid = 0 )
private

Returns the update site records for an extension with ID $eid. If $eid is zero all enabled update sites records will be returned.

Paramètres
int $eid The extension ID to fetch.
Renvoie
array
Depuis
3.6.0

Références $db, $query, $result, elseif, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ updateLastCheckTimestamp()

updateLastCheckTimestamp ( $updateSiteId )
private

Update the last check timestamp of an update site

Paramètres
int $updateSiteId The update site ID to mark as just checked
Renvoie
void
Depuis
3.6.0

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

Documentation des champs

◆ $instance

$instance
staticprotected

◆ STABILITY_ALPHA

const STABILITY_ALPHA = 1

◆ STABILITY_BETA

const STABILITY_BETA = 2

◆ STABILITY_DEV

const STABILITY_DEV = 0

◆ STABILITY_RC

const STABILITY_RC = 3

◆ STABILITY_STABLE

const STABILITY_STABLE = 4

Référencé par UpdateModel\checkCompatibility(), UpdateModel\getCheckForSelfUpdate(), UpdateModel\getUpdateInformation(), UpdateModel\refreshUpdates(), ExtensionAdapter\stabilityTagToInteger(), et Update\stabilityTagToInteger().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Updater.php


Joomla CMS: Référence de la classe Uri

  • Joomla
  • CMS
  • Uri
  • Uri
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Uri
+ Graphe d'héritage de Uri:
Uri AbstractUri UriInterface

Fonctions membres publiques

parse ($uri)
- Fonctions membres publiques hérités de Uri
setVar ($name, $value)
delVar ($name)
setQuery ($query)
setScheme ($scheme)
setUser ($user)
setPass ($pass)
setHost ($host)
setPort ($port)
setPath ($path)
setFragment ($anchor)
- Fonctions membres publiques hérités de AbstractUri
__construct ($uri=null)
__toString ()
toString ($parts=['scheme', 'user', 'pass', 'host', 'port', 'path', 'query', 'fragment'])
render ($parts=self::ALL)
hasVar ($name)
getVar ($name, $default=null)
getQuery ($toArray=false)
getScheme ()
getUser ()
getPass ()
getHost ()
getPort ()
getPath ()
getFragment ()
isSsl ()

Fonctions membres publiques statiques

static | getInstance ($uri='SERVER')
static | base ($pathonly=false)
static | root ($pathonly=false, $path=null)
static | current ()
static | reset ()
static | isInternal ($url)
static | buildQuery (array $params)

Attributs protégés statiques

static | $instances = array()
static | $base = array()
static | $root = array()
static | $current

Membres hérités additionnels

- Champs de données hérités de UriInterface
const | SCHEME = 1
const | USER = 2
const | PASS = 4
const | HOST = 8
const | PORT = 16
const | PATH = 32
const | QUERY = 64
const | FRAGMENT = 128
const | ALL = 255
- Fonctions membres protégées hérités de AbstractUri
parse ($uri)
cleanPath ($path)
- Fonctions membres protégées statiques hérités de AbstractUri
static | buildQuery (array $params)
- Attributs protégés hérités de AbstractUri
$uri
$scheme
$host
$port
$user
$pass
$path
$query
$fragment
$vars = []

Description détaillée

Uri Class

This class serves two purposes. First it parses a URI and provides a common interface for the Joomla Platform to access and manipulate a URI. Second it obtains the URI of the current executing script from the server regardless of server.

Depuis
1.7.0

Documentation des fonctions membres

◆ base()

static base ( $pathonly = false )
static

Returns the base URI for the request.

Paramètres
boolean $pathonly If false, prepend the scheme, host and port information. Default is false.
Renvoie
string The base URI string
Depuis
1.7.0

Références $base, $config, $uri, Factory\getContainer(), JPATH_ADMINISTRATOR, JPATH_API, et JPATH_BASE.

Référencé par InstallationApplication\__construct(), OpensearchDocument\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), HtmlView\__construct(), HtmlDocument\_fetchTemplate(), PopupButton\_getCommand(), DocumentRenderer\_relToAbs(), ContactController\_sendEmail(), RegistrationModel\activate(), DisplayController\cancel(), ConfigController\cancel(), TemplatesController\cancel(), ModulesController\cancel(), UserController\cancel(), ModuleController\cancel(), ComponentController\cancel(), Joomlaupdate\getCoreUpdateNotification(), RandomImageHelper\getFolder(), ArticleController\getReturnPage(), ContactController\getReturnPage(), ApiRouter\getRoutePath(), UserHelper\getShortHashedUserAgent(), Authentication\getSiteIcon(), AdministratorApplication\login(), SiteApplication\login(), CoreAssetItem\onAttachCallback(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), SiteRouter\parseInit(), SiteApplication\route(), CMSApplication\route(), UserController\save(), ItemModel\save(), et Email\sendCode().

◆ buildQuery()

static buildQuery ( array $params )
static

Build a query from an array (reverse of the PHP parse_str()).

Paramètres
array $params The array of key => value pairs to return as a query string.
Renvoie
string The resulting query string.
Voir également
parse_str()
Depuis
1.7.0
Note
The parent method is protected, this exposes it as public for B/C

Références $params.

Référencé par ItemController\setType().

◆ current()

static current ( )
static

Returns the URL for the request, minus the query.

Renvoie
string
Depuis
1.7.0

Références $uri.

Référencé par SiteApplication\dispatch().

◆ getInstance()

static getInstance ( $uri = 'SERVER' )
static

Returns the global Uri object, only creating it if it doesn't already exist.

Paramètres
string $uri The URI to parse. [optional: if null uses script URI]
Renvoie
Uri The URI object.
Depuis
1.7.0

Références $uri, et elseif.

Référencé par OpensearchDocument\__construct(), SiteApplication\authorise(), CssMenu\check(), Icon\create(), OpensearchView\display(), DisplayController\display(), HtmlView\display(), JsonapiView\displayList(), Icon\edit(), UrlFilter\filter(), RouteHelper\getAdvancedRoute(), Credentials\getAvatar(), Authentication\getAvatar(), Cache\getCacheKey(), HtmlView\getFields(), FinderHelper\getGetFields(), LanguagesHelper\getList(), LoginHelper\getReturnUri(), LoginHelper\getReturnUrl(), ApiRouter\getRoutePath(), RouteHelper\getSearchRoute(), Authentication\getWebauthnServer(), Cache\isExcluded(), Route\link(), CssMenu\load(), WebApplication\loadSystemUris(), Joomla\Plugin\System\Webauthn\PluginTraits\mustDisplayButton(), PlgSystemLanguageFilter\onAfterDispatch(), ApiRouter\parseApiRoute(), ConsoleApplication\populateHttpHost(), ToolbarHelper\preferences(), HtmlView\prepareDocument(), RssRenderer\render(), AtomRenderer\render(), SiteApplication\render(), AdministratorApplication\route(), SiteApplication\route(), CMSApplication\route(), ApplicationModel\save(), ItemModel\save(), Query\toUri(), et Yubikey\validateYubikeyOtp().

◆ isInternal()

static isInternal ( $url )
static

Checks if the supplied URL is internal

Paramètres
string $url The URL to check.
Renvoie
boolean True if Internal.
Depuis
1.7.0

Références $base, $uri, et $url.

Référencé par UserController\cancel(), ModuleController\cancel(), ComponentController\cancel(), FormController\cancel(), BaseController\checkToken(), ArticleController\getReturnPage(), ContactController\getReturnPage(), LoginModel\loadFormData(), UserController\login(), DisplayController\login(), DisplayController\logout(), UserController\logout(), LoginModel\populateState(), UserController\save(), FormController\save(), et ArticleController\vote().

◆ parse()

parse ( $uri )

Parse a given URI and populate the class fields.

Paramètres
string $uri The URI string to parse.
Renvoie
boolean True on success.
Depuis
1.7.0
Note
The parent method is protected, this exposes it as public for B/C

Références $uri.

◆ reset()

static reset ( )
static

Method to reset class static members for testing and other various issues.

Renvoie
void
Depuis
1.7.0

Références $base, et $root.

◆ root()

static root | ( | $pathonly = false,
 |  | $path = null
 | ) |
static

Returns the root URI for the request.

Paramètres
boolean | $pathonly | If false, prepend the scheme, host and port information. Default is false.
string | $path | The path
Renvoie
string The root URI string.
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $path, $root, et $uri.

Référencé par InstallationApplication\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), HtmlView\addToolbar(), Tag\ajaxfield(), AdministratorRouter\build(), SiteRouter\buildBase(), ContentSerializer\category(), ContactSerializer\category(), NewsfeedSerializer\category(), Email\cloak(), MailHelper\convertRelativeToAbsoluteUrls(), HTMLHelper\convertToRelativePath(), ContentSerializer\createdBy(), ContactSerializer\createdBy(), NewsfeedSerializer\createdBy(), UrlFilter\filter(), LanguageStringsCollector\getAssets(), InfoCollector\getAssets(), LanguageErrorsCollector\getAssets(), LanguageFilesCollector\getAssets(), QueryCollector\getAssets(), TemplateModel\getFont(), TemplateModel\getImage(), Authentication\getKnownAuthenticators(), LocalAdapter\getUrl(), Users\image(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), ContentSerializer\languageAssociations(), ContactSerializer\languageAssociations(), NewsfeedSerializer\languageAssociations(), UserController\logout(), UserController\menulogout(), ContentSerializer\modifiedBy(), ContactSerializer\modifiedBy(), NewsfeedSerializer\modifiedBy(), CoreAssetItem\onAttachCallback(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), RegistrationModel\register(), ContentHelper\resolve(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), ApplicationModel\save(), Templates\thumb(), Templates\thumbModal(), et ContactSerializer\userId().

Documentation des champs

◆ $base

$base = array()
staticprotected

◆ $current

$current
staticprotected

◆ $instances

$instances = array()
staticprotected

◆ $root

$root = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Uri/Uri.php


Joomla CMS: Référence de l'interface CurrentUserInterface

  • Joomla
  • CMS
  • User
  • CurrentUserInterface
Fonctions membres publiques
Référence de l'interface CurrentUserInterface
+ Graphe d'héritage de CurrentUserInterface:
BaseDatabaseModel HtmlView BaseInstallationModel FormModel ItemModel ListModel ActionlogConfigModel ActionlogModel HelpModel SysinfoModel BannerModel IndexerModel StatisticsModel InstallModel UpdateModel StringsModel LoginModel ApiModel MediaModel MenutypesModel MessagesModel ExportModel RemoveModel BackupcodesModel CaptiveModel MethodModel MethodsModel DefaultView CategoriesView CategoryFeedView CategoryView FormView ListView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView RawView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView FeedView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView XmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView FeedView HtmlView FeedView HtmlView HtmlView JsonView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView

Fonctions membres publiques

setCurrentUser (User $currentUser)

Description détaillée

Interface to be implemented by classes depending on a current user.

Depuis
4.2.0

Documentation des fonctions membres

◆ setCurrentUser()

setCurrentUser ( User $currentUser )

Sets the current user.

Paramètres
User $currentUser The current user object
Renvoie
void
Depuis
4.2.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • CurrentUserInterface.php


Joomla CMS: Référence de la classe User

  • Joomla
  • CMS
  • User
  • User
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques
Référence de la classe User
+ Graphe d'héritage de User:
CMSObject

Fonctions membres publiques

__construct ($identifier=0)
getParam ($key, $default=null)
setParam ($key, $value)
defParam ($key, $value)
authorise ($action, $assetname=null)
getAuthorisedCategories ($component, $action)
getAuthorisedViewLevels ()
getAuthorisedGroups ()
clearAccessRights ()
getTimezone ()
setParameters ($params)
bind (&$array)
save ($updateOnly=false)
delete ()
load ($id)
__sleep ()
__wakeup ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)

Fonctions membres publiques statiques

static | getInstance ($identifier=0)
static | getTable ($type=null, $prefix='JTable')

Champs de données

$id = null
$name = null
$username = null
$email = null
$password = null
$password_clear = ''
$block = null
$sendEmail = null
$registerDate = null
$lastvisitDate = null
$activation = null
$params = null
$groups = array()
$guest = null
$lastResetTime = null
$resetCount = null
$requireReset = null

Attributs protégés

$isRoot = null
$_params = null
$_authGroups = null
$_authLevels = null
$_authActions = null
$_errorMsg = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs protégés statiques

static $instances = array()

Description détaillée

User class. Handles all application interaction with a user

Depuis
1.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $identifier = 0 )

Constructor activating the default information of the language

Paramètres
integer $identifier The primary key of the user to load (optional).
Depuis
1.7.0

Références User\load().

Documentation des fonctions membres

◆ __sleep()

__sleep ( )

Method to allow serialize the object with minimal properties.

Renvoie
array The names of the properties to include in serialization.
Depuis
3.6.0

◆ __wakeup()

__wakeup ( )

Method to recover the full object on unserialize.

Renvoie
void
Depuis
3.6.0

Références User\$id, $this, et User\load().

◆ authorise()

authorise | ( | $action,
 |  | $assetname = null
 | ) |

Method to check User object authorisation against an access control object and optionally an access extension object

Paramètres
string | $action | The name of the action to check for permission.
string | $assetname | The name of the asset on which to perform the action.
Renvoie
boolean True if authorised
Depuis
1.7.0

Références Access\check(), elseif, Factory\getApplication(), Access\getAssetRules(), User\getAuthorisedGroups(), null, et true.

Référencé par User\getAuthorisedCategories().

◆ bind()

bind ( & $array )

Method to bind an associative array of data to a user object

Paramètres
array &$array The associative array to bind to the object
Renvoie
boolean True on success
Depuis
1.7.0

Références User\$params, User\$password, Text\_(), UserHelper\genRandomPassword(), Factory\getApplication(), Factory\getDate(), ArrayHelper\getValue(), UserHelper\hashPassword(), CMSObject\setError(), et CMSObject\setProperties().

Référencé par UserHelper\activateUser(), UserHelper\addUserToGroup(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), User\getAuthorisedCategories(), UserHelper\getUserId(), et UserFactory\loadUserByUsername().

◆ clearAccessRights()

clearAccessRights ( )

Clears the access rights cache of this user

Renvoie
void
Depuis
3.4.0

Références Access\clearStatics(), et null.

◆ defParam()

defParam | ( | $key,
 |  | $value
 | ) |

Method to set a default parameter if it does not exist

Paramètres
string | $key | Parameter key
mixed | $value | Parameter value
Renvoie
mixed Set parameter value
Depuis
1.7.0

Références $key, et $value.

◆ delete()

delete ( )

Method to delete the User object from the database

Renvoie
boolean True on success
Depuis
1.7.0

Références $result, $this, Factory\getApplication(), CMSObject\getError(), CMSObject\getProperties(), User\getTable(), PluginHelper\importPlugin(), et CMSObject\setError().

◆ getAuthorisedCategories()

getAuthorisedCategories | ( | $component,
 |  | $action
 | ) |

Method to return a list of all categories that a user has permission for a given action

Paramètres
string | $component | The component from which to retrieve the categories
string | $action | The name of the section within the component from which to retrieve the actions.
Renvoie
array List of categories that this group can do this action to (empty array if none). Categories must be published.
Depuis
1.7.0

Références $category, $component, $db, $query, User\authorise(), User\bind(), et Factory\getDbo().

◆ getAuthorisedGroups()

getAuthorisedGroups ( )

Gets an array of the authorised user groups

Renvoie
array
Depuis
1.7.0

Références User\$_authGroups, Access\getGroupsByUser(), et null.

Référencé par User\authorise().

◆ getAuthorisedViewLevels()

getAuthorisedViewLevels ( )

Gets an array of the authorised access levels for the user

Renvoie
array
Depuis
1.7.0

Références User\$_authLevels, Access\getAuthorisedViewLevels(), et null.

◆ getInstance()

static getInstance ( $identifier = 0 )
static

Returns the global User object, only creating it if it doesn't already exist.

Paramètres
integer $identifier The primary key of the user to load (optional).
Renvoie
User The User object.
Depuis
1.7.0
Obsolète:
5.0 Load the user service from the dependency injection container or via $app->getIdentity()

Références User\$id, class, et Factory\getContainer().

Référencé par PlgUserJoomla\_getUser(), ContactController\_sendEmail(), UserHelper\activateUser(), HtmlView\addToolbar(), UserHelper\addUserToGroup(), ChangeUserPasswordCommand\doExecute(), DeleteUserCommand\doExecute(), AddUserToGroupCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserCommand\doExecute(), Access\getAuthorisedViewLevels(), UserField\getLayoutData(), Factory\getUser(), UserHelper\getUserGroups(), PlgContentJoomla\onContentAfterSave(), PlgAuthenticationJoomla\onUserAuthenticate(), Joomla\onUserLogout(), ResetModel\processResetComplete(), ResetModel\processResetRequest(), UserHelper\removeUserFromGroup(), UserModel\save(), MessageModel\save(), et UserHelper\setUserGroups().

◆ getParam()

getParam | ( | $key,
 |  | $default = null
 | ) |

Method to get a parameter value

Paramètres
string | $key | Parameter key
mixed | $default | Parameter default value
Renvoie
mixed The value or the default if it did not exist
Depuis
1.7.0

Références $default, et $key.

Référencé par User\getTimezone().

◆ getTable()

static getTable | ( | $type = null,
 |  | $prefix = 'JTable'
 | ) |
static

Method to get the user table object

This function uses a static variable to store the table name of the user table to instantiate. You can call this function statically to set the table name if needed.

Paramètres
string | $type | The user table name to be used
string | $prefix | The user table prefix to be used
Renvoie
Table The user table object
Note
At 4.0 this method will no longer be static
Depuis
1.7.0

Références $prefix, $type, et Table\getInstance().

Référencé par User\delete(), User\load(), et User\save().

◆ getTimezone()

getTimezone ( )

Method to get the user timezone.

If the user didn't set a timezone, it will return the server timezone

Renvoie
Depuis
3.7.0

Références Factory\getApplication(), et User\getParam().

◆ load()

load ( $id )

Method to load a User object by user id number

Paramètres
mixed $id The user id of the user to load
Renvoie
boolean True on success
Depuis
1.7.0

Références User\$id, Log\add(), User\getTable(), CMSObject\setProperties(), Text\sprintf(), et Log\WARNING.

Référencé par User\__construct(), et User\__wakeup().

◆ save()

save ( $updateOnly = false )

Method to save the User object to the database

Paramètres
boolean $updateOnly Save the object only if not a new user Currently only used in the user reset password method.
Renvoie
boolean True on success
Depuis
1.7.0
Exceptions

Références User\$password, $result, $this, Access\check(), Access\checkGroup(), Factory\getApplication(), CMSObject\getError(), CMSObject\getProperties(), User\getTable(), Factory\getUser(), PluginHelper\importPlugin(), null, et CMSObject\setError().

◆ setParam()

setParam | ( | $key,
 |  | $value
 | ) |

Method to set a parameter

Paramètres
string | $key | Parameter key
mixed | $value | Parameter value
Renvoie
mixed Set parameter value
Depuis
1.7.0

Références $key, et $value.

◆ setParameters()

setParameters ( $params )

Method to get the user parameters

Paramètres
object $params The user parameters object
Renvoie
void
Depuis
1.7.0

Références User\$params.

Documentation des champs

◆ $_authActions

$_authActions = null
protected

◆ $_authGroups

$_authGroups = null
protected

Référencé par User\getAuthorisedGroups().

◆ $_authLevels

$_authLevels = null
protected

Référencé par User\getAuthorisedViewLevels().

◆ $_errorMsg

$_errorMsg = null
protected

◆ $_params

$_params = null
protected

◆ $activation

$activation = null

Référencé par UserHelper\activateUser().

◆ $block

$block = null

◆ $email

$email = null

◆ $groups

$groups = array()

Référencé par UserHelper\setUserGroups().

◆ $guest

$guest = null

◆ $id

$id = null

Référencé par User\__wakeup(), UserHelper\activateUser(), User\getInstance(), User\load(), et UserFactory\loadUserById().

◆ $instances

$instances = array()
staticprotected

◆ $isRoot

$isRoot = null
protected

◆ $lastResetTime

$lastResetTime = null

◆ $lastvisitDate

$lastvisitDate = null

◆ $name

$name = null

◆ $params

$params = null

Référencé par User\bind(), et User\setParameters().

◆ $password

$password = null

Référencé par User\bind(), UserHelper\hashPassword(), et User\save().

◆ $password_clear

$password_clear = ''

◆ $registerDate

$registerDate = null

◆ $requireReset

$requireReset = null

◆ $resetCount

$resetCount = null

◆ $sendEmail

$sendEmail = null

◆ $username

$username = null

Référencé par UserHelper\getUserId(), et UserFactory\loadUserByUsername().

La documentation de cette classe a été générée à partir du fichier suivant :
  • User/User.php


Joomla CMS: Référence de la classe UserFactory

  • Joomla
  • CMS
  • User
  • UserFactory
Fonctions membres publiques | Attributs privés
Référence de la classe UserFactory
+ Graphe d'héritage de UserFactory:
UserFactoryInterface

Fonctions membres publiques

__construct (DatabaseInterface $db)
loadUserById (int $id)
loadUserByUsername (string $username)

Attributs privés

$db

Description détaillée

Default factory for creating User objects

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

UserFactory constructor.

Paramètres
DatabaseInterface $db The database

Références $db.

Documentation des fonctions membres

◆ loadUserById()

loadUserById ( int $id )

Method to get an instance of a user for the given id.

Paramètres
int $id The id
Renvoie
User
Depuis
4.0.0

Implémente UserFactoryInterface.

Références User\$id.

◆ loadUserByUsername()

loadUserByUsername ( string $username )

Method to get an instance of a user for the given username.

Paramètres
string $username The username
Renvoie
User
Depuis
4.0.0

Implémente UserFactoryInterface.

Références $query, User\$username, et User\bind().

Documentation des champs

◆ $db

$db
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserFactory.php


Joomla CMS: Référence de l'interface UserFactoryInterface

  • Joomla
  • CMS
  • User
  • UserFactoryInterface
Fonctions membres publiques
Référence de l'interface UserFactoryInterface
+ Graphe d'héritage de UserFactoryInterface:
UserFactory

Fonctions membres publiques

loadUserById (int $id)
loadUserByUsername (string $username)

Description détaillée

Interface defining a factory which can create User objects

Depuis
4.0.0

Documentation des fonctions membres

◆ loadUserById()

loadUserById ( int $id )

Method to get an instance of a user for the given id.

Paramètres
int $id The id
Renvoie
User
Depuis
4.0.0

Implémenté dans UserFactory.

◆ loadUserByUsername()

loadUserByUsername ( string $username )

Method to get an instance of a user for the given username.

Paramètres
string $username The username
Renvoie
User
Depuis
4.0.0

Implémenté dans UserFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UserFactoryInterface.php


Joomla CMS: Référence de la classe UserHelper

  • Joomla
  • CMS
  • User
  • UserHelper
Fonctions membres publiques statiques | Champs de données
Référence de la classe UserHelper

Fonctions membres publiques statiques

static | addUserToGroup ($userId, $groupId)
static | getUserGroups ($userId)
static | removeUserFromGroup ($userId, $groupId)
static | setUserGroups ($userId, $groups)
static | getProfile ($userId=0)
static | activateUser ($activation)
static | getUserId ($username)
static | hashPassword ($password, $algorithm=self::HASH_BCRYPT, array $options=array())
static | genRandomPassword ($length=8)
static | getShortHashedUserAgent ()
static | checkSuperUserInUsers (array $userIds)

Champs de données

const | HASH_ARGON2I = 'argon2i'
const | HASH_ARGON2I_BC = 2
const | HASH_ARGON2ID = 'argon2id'
const | HASH_ARGON2ID_BC = 3
const | HASH_BCRYPT = '2y'
const | HASH_BCRYPT_BC = 1
const | HASH_MD5 = 'md5'
const | HASH_PHPASS = 'phpass'
const | HASH_ALGORITHMS

Description détaillée

Authorisation helper class, provides static methods to perform various tasks relevant to the Joomla user and authorisation classes

This class has influences and some method logic from the Horde Auth package

Depuis
1.7.0

Documentation des fonctions membres

◆ activateUser()

static activateUser ( $activation )
static

Method to activate a user

Paramètres
string $activation Activation string
Renvoie
boolean True on success
Depuis
1.7.0

Références User\$activation, $db, User\$id, $query, $user, Text\_(), Log\add(), User\bind(), Factory\getDbo(), User\getInstance(), et Log\WARNING.

◆ addUserToGroup()

static addUserToGroup | ( | $userId,
 |  | $groupId
 | ) |
static

Method to add a user to a group.

Paramètres
integer | $userId | The id of the user.
integer | $groupId | The id of the group.
Renvoie
boolean True on success
Depuis
1.7.0
Exceptions

Références $db, $query, $temp, $user, $userId, User\bind(), Factory\getDbo(), User\getInstance(), Factory\getSession(), Factory\getUser(), ParameterType\INTEGER, et null.

Référencé par AddUserToGroupCommand\doExecute().

◆ checkSuperUserInUsers()

static checkSuperUserInUsers ( array $userIds )
static

Check if there is a super user in the user ids.

Paramètres
array $userIds An array of user IDs on which to operate
Renvoie
boolean True on success, false on failure
Depuis
3.6.5

Références $userId, et Access\checkGroup().

Référencé par UserModel\batchReset(), et UserModel\batchUser().

◆ genRandomPassword()

static genRandomPassword ( $length = 8 )
static

Generate a random password

Paramètres
integer $length Length of the password to generate
Renvoie
string Random Password
Depuis
1.7.0

Références $base, $i, et Crypt\genRandomBytes().

Référencé par RegistrationModel\activate(), User\bind(), DatabaseHelper\checkRemoteDbHost(), ConfigurationModel\createConfiguration(), UpdateModel\createUpdateFile(), MD5Handler\hashPassword(), ResetModel\processResetRequest(), RegistrationModel\register(), et ApplicationModel\save().

◆ getProfile()

static getProfile ( $userId = 0 )
static

Gets the user profile information

Paramètres
integer $userId The id of the user.
Renvoie
object
Depuis
1.7.0

Références $data, $user, $userId, Factory\getApplication(), Factory\getUser(), et PluginHelper\importPlugin().

◆ getShortHashedUserAgent()

static getShortHashedUserAgent ( )
static

Method to get a hashed user agent string that does not include browser version. Used when frequent version changes cause problems.

Renvoie
string A hashed user agent string with version replaced by 'abcd'
Depuis
3.2

Références Uri\base(), et Factory\getApplication().

◆ getUserGroups()

static getUserGroups ( $userId )
static

Method to get a list of groups a user is in.

Paramètres
integer $userId The id of the user.
Renvoie
array List of groups
Depuis
1.7.0

Références $user, $userId, et User\getInstance().

Référencé par DeleteUserCommand\doExecute(), et UserModel\getAssignedGroups().

◆ getUserId()

static getUserId ( $username )
static

Returns userid if a user exists

Paramètres
string $username The username to search on.
Renvoie
integer The user id or 0 if not found.
Depuis
1.7.0

Références $db, $query, User\$username, User\bind(), et Factory\getDbo().

Référencé par ChangeUserPasswordCommand\doExecute(), DeleteUserCommand\doExecute(), et RemoveUserFromGroupCommand\doExecute().

◆ hashPassword()

static hashPassword | ( |  | $password,
 |  |  | $algorithm = self::HASH_BCRYPT,
 |  | array | $options = array()
 | ) |  |
static

Hashes a password using the current encryption.

Paramètres
string | $password | The plaintext password to encrypt.
string | integer | $algorithm | The hashing algorithm to use, represented by HASH_* class constants, or a container service ID.
array | $options | The options for the algorithm to use.
Renvoie
string The encrypted password.
Depuis
3.2.1
Exceptions

Références $container, $options, User\$password, et Factory\getContainer().

Référencé par User\bind(), ConfigurationModel\createRootUser(), ChangeUserPasswordCommand\doExecute(), Basic\onUserAuthenticate(), et ResetModel\processResetRequest().

◆ removeUserFromGroup()

static removeUserFromGroup | ( | $userId,
 |  | $groupId
 | ) |
static

Method to remove a user from a group.

Paramètres
integer | $userId | The id of the user.
integer | $groupId | The id of the group.
Renvoie
boolean True on success
Depuis
1.7.0

Références $key, $temp, $user, $userId, User\getInstance(), et Factory\getUser().

Référencé par RemoveUserFromGroupCommand\doExecute().

◆ setUserGroups()

static setUserGroups | ( | $userId,
 |  | $groups
 | ) |
static

Method to set the groups for a user.

Paramètres
integer | $userId | The id of the user.
array | $groups | An array of group ids to put the user in.
Renvoie
boolean True on success
Depuis
1.7.0

Références $db, User\$groups, $i, $n, $query, $results, $temp, $user, $userId, Factory\getDbo(), User\getInstance(), Factory\getSession(), Factory\getUser(), et ArrayHelper\toInteger().

Documentation des champs

◆ HASH_ALGORITHMS

const HASH_ALGORITHMS
Valeur initiale :
= [
self::HASH_ARGON2I => Argon2iHandler::class

◆ HASH_ARGON2I

const HASH_ARGON2I = 'argon2i'

◆ HASH_ARGON2I_BC

const HASH_ARGON2I_BC = 2

◆ HASH_ARGON2ID

const HASH_ARGON2ID = 'argon2id'

◆ HASH_ARGON2ID_BC

const HASH_ARGON2ID_BC = 3

◆ HASH_BCRYPT

const HASH_BCRYPT = '2y'

◆ HASH_BCRYPT_BC

const HASH_BCRYPT_BC = 1

◆ HASH_MD5

const HASH_MD5 = 'md5'

◆ HASH_PHPASS

const HASH_PHPASS = 'phpass'
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserHelper.php


Joomla CMS: Référence de la classe BufferStreamHandler

  • Joomla
  • CMS
  • Utility
  • BufferStreamHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs privés statiques
Référence de la classe BufferStreamHandler

Fonctions membres publiques

stream_open ($path, $mode, $options, &$openedPath)
stream_read ($count)
stream_write ($data)
stream_tell ()
stream_eof ()
stream_seek ($offset, $whence)

Fonctions membres publiques statiques

static stream_register ()

Champs de données

$position = 0
$name = null
$buffers = array()

Fonctions membres protégées

seek_set ($offset)
seek_cur ($offset)
seek_end ($offset)

Attributs privés statiques

static $registered = false

Description détaillée

Generic Buffer stream handler

This class provides a generic buffer stream. It can be used to store/retrieve/manipulate string buffers with the standard PHP filesystem I/O methods.

Depuis
1.7.0

Documentation des fonctions membres

◆ seek_cur()

seek_cur ( $offset )
protected

Adds the offset to current position

Paramètres
integer $offset The offset in bytes
Renvoie
boolean

Références Joomla\Database\Query\$offset.

◆ seek_end()

seek_end ( $offset )
protected

Sets the position to the end of the current buffer + offset

Paramètres
integer $offset The offset in bytes
Renvoie
boolean

Références Joomla\Database\Query\$offset, et name.

◆ seek_set()

seek_set ( $offset )
protected

Set the position to the offset

Paramètres
integer $offset The offset in bytes
Renvoie
boolean

Références Joomla\Database\Query\$offset, et name.

◆ stream_eof()

stream_eof ( )

Function to test for end of file pointer

Renvoie
boolean True if the pointer is at the end of the stream
Voir également
streamWrapper::stream_eof
Depuis
1.7.0

Références name.

◆ stream_open()

stream_open | ( |  | $path,
 |  |  | $mode,
 |  |  | $options,
 |  | & | $openedPath
 | ) |  |

Function to open file or url

Paramètres
string | $path | The URL that was passed
string | $mode | Mode used to open the file
Voir également
fopen
Paramètres
integer | $options | Flags used by the API, may be STREAM_USE_PATH and STREAM_REPORT_ERRORS
string | &$openedPath | Full path of the resource. Used with STREAM_USE_PATH option
Renvoie
boolean
Depuis
1.7.0
Voir également
streamWrapper::stream_open

Références $name, $path, $url, name, et null.

◆ stream_read()

stream_read ( $count )

Read stream

Paramètres
integer $count How many bytes of data from the current position should be returned.
Renvoie
mixed The data from the stream up to the specified number of bytes (all data if the total number of bytes in the stream is less than $count. Null if the stream is empty.
Voir également
streamWrapper::stream_read
Depuis
1.7.0

Références $count, et name.

◆ stream_register()

static stream_register ( )
static

Function to register the stream wrapper

Renvoie
void
Depuis
3.8.2

Référencé par FtpClient\__construct().

◆ stream_seek()

stream_seek | ( | $offset,
 |  | $whence
 | ) |

The read write position updates in response to $offset and $whence

Paramètres
integer | $offset | The offset in bytes
integer | $whence | Position the offset is added to Options are SEEK_SET, SEEK_CUR, and SEEK_END
Renvoie
boolean True if updated
Voir également
streamWrapper::stream_seek
Depuis
1.7.0

Références Joomla\Database\Query\$offset.

◆ stream_tell()

stream_tell ( )

Function to get the current position of the stream

Renvoie
integer
Voir également
streamWrapper::stream_tell
Depuis
1.7.0

Références $position.

◆ stream_write()

stream_write ( $data )

Write stream

Paramètres
string $data The data to write to the stream.
Renvoie
integer
Voir également
streamWrapper::stream_write
Depuis
1.7.0

Références $data, $name, et name.

Documentation des champs

◆ $buffers

$buffers = array()

◆ $name

$name = null

◆ $position

$position = 0

◆ $registered

$registered = false
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • BufferStreamHandler.php


Joomla CMS: Référence de la classe Utility

  • Joomla
  • CMS
  • Utility
  • Utility
Fonctions membres publiques statiques
Référence de la classe Utility

Fonctions membres publiques statiques

static | parseAttributes ($string)
static | getMaxUploadSize ($custom=null)

Description détaillée

JUtility is a utility functions class

Depuis
1.7.0

Documentation des fonctions membres

◆ getMaxUploadSize()

static getMaxUploadSize ( $custom = null )
static

Method to get the maximum allowed file size for the HTTP uploads based on the active PHP configuration

Paramètres
mixed $custom A custom upper limit, if the PHP settings are all above this then this will be used
Renvoie
mixed Size in number of bytes
Depuis
3.7.0

Références HTMLHelper\_().

◆ parseAttributes()

static parseAttributes ( $string )
static

Method to extract key/value pairs out of a string with XML style attributes

Paramètres
string $string String containing XML style attributes
Renvoie
array Key/Value pairs for the attributes
Depuis
1.7.0

Références $attr, et $i.

Référencé par HtmlDocument\_parseTemplate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Utility.php


Joomla CMS: Référence de l'interface VersionableTableInterface

  • Joomla
  • CMS
  • Versioning
  • VersionableTableInterface
Fonctions membres publiques
Référence de l'interface VersionableTableInterface
+ Graphe d'héritage de VersionableTableInterface:
TableInterface Category Content BannerTable ClientTable ContactTable NewsfeedTable TagTable NoteTable

Fonctions membres publiques

getTypeAlias ()
- Fonctions membres publiques hérités de TableInterface
bind ($src, $ignore=array())
check ()
delete ($pk=null)
getDbo ()
getKeyName ()
load ($keys=null, $reset=true)
reset ()
store ($updateNulls=false)
getId ()
hasField ($key)

Description détaillée

Interface for a versionable Table class

Depuis
3.10.0

Documentation des fonctions membres

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

The type alias generally is the internal component name with the content type. Ex.: com_content.article

Renvoie
string The alias as described above
Depuis
3.10.0

Implémenté dans Content, BannerTable, Category, ContactTable, TagTable, NewsfeedTable, NoteTable, et ClientTable.

La documentation de cette interface a été générée à partir du fichier suivant :
  • VersionableTableInterface.php


Joomla CMS: Référence de la classe Versioning

  • Joomla
  • CMS
  • Versioning
  • Versioning
Fonctions membres publiques statiques
Référence de la classe Versioning

Fonctions membres publiques statiques

static | get ($typeAlias, $id)
static | delete ($typeAlias, $id)
static | store ($typeAlias, $id, $data, $note='')

Description détaillée

Handle the versioning of content items

Depuis
4.0.0

Documentation des fonctions membres

◆ delete()

static delete | ( | $typeAlias,
 |  | $id
 | ) |
static

Method to delete the history for an item.

Paramètres
string | $typeAlias | Typealias of the component
integer | $id | ID of the content item to delete
Renvoie
boolean true on success, otherwise false.
Depuis
4.0.0

Références $db, $id, $itemid, $query, Factory\getDbo(), et ParameterType\STRING.

◆ get()

static get | ( | $typeAlias,
 |  | $id
 | ) |
static

Method to get a list of available versions of this item.

Paramètres
string | $typeAlias | Typealias of the component
integer | $id | ID of the content item to get
Renvoie
object[] A list of history items
Depuis
4.0.0

Références $db, $id, $itemid, $query, Factory\getDbo(), et ParameterType\STRING.

◆ store()

static store | ( | $typeAlias,
 |  | $id,
 |  | $data,
 |  | $note = ''
 | ) |
static

Method to save a version snapshot to the content history table.

Paramètres
string | $typeAlias | Typealias of the content type
integer | $id | ID of the content item
mixed | $data | Array or object of data that can be en- and decoded into JSON
string | $note | Note for the version to store
Renvoie
boolean True on success, otherwise false.
Depuis
4.0.0

Références $component, $context, $data, $id, $result, AbstractEvent\create(), elseif, Factory\getApplication(), Table\getInstance(), ComponentHelper\getParams(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Versioning.php


Joomla CMS: Référence de la classe CoreAssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
  • CoreAssetItem
Fonctions membres publiques
Référence de la classe CoreAssetItem
+ Graphe d'héritage de CoreAssetItem:
WebAssetItem WebAssetAttachBehaviorInterface WebAssetItemInterface

Fonctions membres publiques

onAttachCallback (Document $doc)
- Fonctions membres publiques hérités de WebAssetItem
__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Membres hérités additionnels

- Fonctions membres protégées hérités de WebAssetItem
resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)
- Attributs protégés hérités de WebAssetItem
$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class for Core asset

Depuis
4.0.0

Documentation des fonctions membres

◆ onAttachCallback()

onAttachCallback ( Document $doc )

Method called when asset attached to the Document. Useful for Asset to add a Script options.

Paramètres
Document $doc Active document
Renvoie
void
Depuis
4.0.0

Implémente WebAssetAttachBehaviorInterface.

Références $doc, HTMLHelper\_(), Uri\base(), et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CoreAssetItem.php


Joomla CMS: Référence de la classe FormValidateAssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
  • FormValidateAssetItem
Fonctions membres publiques
Référence de la classe FormValidateAssetItem
+ Graphe d'héritage de FormValidateAssetItem:
WebAssetItem WebAssetAttachBehaviorInterface WebAssetItemInterface

Fonctions membres publiques

onAttachCallback (Document $doc)
- Fonctions membres publiques hérités de WebAssetItem
__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Membres hérités additionnels

- Fonctions membres protégées hérités de WebAssetItem
resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)
- Attributs protégés hérités de WebAssetItem
$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class for form.validate asset

Depuis
4.0.0

Documentation des fonctions membres

◆ onAttachCallback()

onAttachCallback ( Document $doc )

Method called when asset attached to the Document. Useful for Asset to add a Script options.

Paramètres
Document $doc Active document
Renvoie
void
Depuis
4.0.0

Implémente WebAssetAttachBehaviorInterface.

Références Text\script().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FormValidateAssetItem.php


Joomla CMS: Référence de la classe KeepaliveAssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
  • KeepaliveAssetItem
Fonctions membres publiques
Référence de la classe KeepaliveAssetItem
+ Graphe d'héritage de KeepaliveAssetItem:
WebAssetItem WebAssetAttachBehaviorInterface WebAssetItemInterface

Fonctions membres publiques

onAttachCallback (Document $doc)
- Fonctions membres publiques hérités de WebAssetItem
__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Membres hérités additionnels

- Fonctions membres protégées hérités de WebAssetItem
resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)
- Attributs protégés hérités de WebAssetItem
$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class for Keepalive asset

Depuis
4.0.0

Documentation des fonctions membres

◆ onAttachCallback()

onAttachCallback ( Document $doc )

Method called when asset attached to the Document. Useful for Asset to add a Script options.

Paramètres
Document $doc Active document
Renvoie
void
Depuis
4.0.0

Implémente WebAssetAttachBehaviorInterface.

Références $app, $doc, $uri, Route\_(), Factory\getApplication(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • KeepaliveAssetItem.php


Joomla CMS: Référence de la classe LangActiveAssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
  • LangActiveAssetItem
Fonctions membres publiques
Référence de la classe LangActiveAssetItem
+ Graphe d'héritage de LangActiveAssetItem:
WebAssetItem WebAssetItemInterface

Fonctions membres publiques

__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
- Fonctions membres publiques hérités de WebAssetItem
__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Membres hérités additionnels

- Fonctions membres protégées hérités de WebAssetItem
resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)
- Attributs protégés hérités de WebAssetItem
$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class for load asset file for active language. Used in core templates.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | string | $uri = null,
 |  | array | $options = [],
 |  | array | $attributes = [],
 |  | array | $dependencies = []
 | ) |  |

Class constructor

Paramètres
string | $name | The asset name
string | $uri | The URI for the asset
array | $options | Additional options for the asset
array | $attributes | Attributes for the asset
array | $dependencies | Asset dependencies
Depuis
4.0.0

Références $attributes, $client, $name, $options, $uri, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LangActiveAssetItem.php


Joomla CMS: Référence de la classe TableColumnsAssetItem

  • Joomla
  • CMS
  • WebAsset
  • AssetItem
  • TableColumnsAssetItem
Fonctions membres publiques
Référence de la classe TableColumnsAssetItem
+ Graphe d'héritage de TableColumnsAssetItem:
WebAssetItem WebAssetAttachBehaviorInterface WebAssetItemInterface

Fonctions membres publiques

onAttachCallback (Document $doc)
- Fonctions membres publiques hérités de WebAssetItem
__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Membres hérités additionnels

- Fonctions membres protégées hérités de WebAssetItem
resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)
- Attributs protégés hérités de WebAssetItem
$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class for tables.column asset

Depuis
4.2.0

Documentation des fonctions membres

◆ onAttachCallback()

onAttachCallback ( Document $doc )

Method called when asset attached to the Document. Used to add the language strings required by the script.

Paramètres
Document $doc Active document
Renvoie
void
Depuis
4.2.0

Implémente WebAssetAttachBehaviorInterface.

Références Text\script().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TableColumnsAssetItem.php


Joomla CMS: Référence de la classe InvalidActionException

  • Joomla
  • CMS
  • WebAsset
  • Exception
  • InvalidActionException
Référence de la classe InvalidActionException
+ Graphe d'héritage de InvalidActionException:
WebAssetExceptionInterface

Description détaillée

Exception class defining an Invalid Action error

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidActionException.php


Joomla CMS: Référence de la classe UnknownAssetException

  • Joomla
  • CMS
  • WebAsset
  • Exception
  • UnknownAssetException
Référence de la classe UnknownAssetException
+ Graphe d'héritage de UnknownAssetException:
WebAssetExceptionInterface

Description détaillée

Exception class defining an Unknown Asset

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnknownAssetException.php


Joomla CMS: Référence de la classe UnsatisfiedDependencyException

  • Joomla
  • CMS
  • WebAsset
  • Exception
  • UnsatisfiedDependencyException
Référence de la classe UnsatisfiedDependencyException
+ Graphe d'héritage de UnsatisfiedDependencyException:
WebAssetExceptionInterface

Description détaillée

Exception class defining an Unsatisfied Dependency

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/WebAsset/Exception/UnsatisfiedDependencyException.php


Joomla CMS: Référence de l'interface WebAssetExceptionInterface

  • Joomla
  • CMS
  • WebAsset
  • Exception
  • WebAssetExceptionInterface
Référence de l'interface WebAssetExceptionInterface
+ Graphe d'héritage de WebAssetExceptionInterface:
InvalidActionException UnknownAssetException UnsatisfiedDependencyException

Description détaillée

Exception interface defining a WebAsset error

Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • WebAssetExceptionInterface.php


Joomla CMS: Référence de l'interface WebAssetAttachBehaviorInterface

  • Joomla
  • CMS
  • WebAsset
  • WebAssetAttachBehaviorInterface
Fonctions membres publiques
Référence de l'interface WebAssetAttachBehaviorInterface
+ Graphe d'héritage de WebAssetAttachBehaviorInterface:
CoreAssetItem FormValidateAssetItem KeepaliveAssetItem TableColumnsAssetItem

Fonctions membres publiques

onAttachCallback (Document $doc)

Description détaillée

Web Asset Behavior interface

Depuis
4.0.0

Documentation des fonctions membres

◆ onAttachCallback()

onAttachCallback ( Document $doc )

Method called when asset attached to the Document. Useful for Asset to add a Script options.

Paramètres
Document $doc Active document
Renvoie
void
Depuis
4.0.0

Implémenté dans CoreAssetItem, KeepaliveAssetItem, FormValidateAssetItem, et TableColumnsAssetItem.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WebAssetAttachBehaviorInterface.php


Joomla CMS: Référence de la classe WebAssetItem

  • Joomla
  • CMS
  • WebAsset
  • WebAssetItem
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WebAssetItem
+ Graphe d'héritage de WebAssetItem:
WebAssetItemInterface CoreAssetItem FormValidateAssetItem KeepaliveAssetItem LangActiveAssetItem TableColumnsAssetItem

Fonctions membres publiques

__construct (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Fonctions membres protégées

resolvePath (string $path, string $type)
isPathExternal (string $path)
isPathAbsolute (string $path)

Attributs protégés

$name = ''
$uri = ''
$options = []
$attributes = []
$dependencies = []
$version = 'auto'

Description détaillée

Web Asset Item class

Asset Item are "read only" object, all properties must be set through class constructor. Only properties allowed to be edited is an attributes and an options. Changing an uri or a dependencies are not allowed, prefer to create a new asset instance.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | string | $uri = null,
 |  | array | $options = [],
 |  | array | $attributes = [],
 |  | array | $dependencies = []
 | ) |  |

Class constructor

Paramètres
string | $name | The asset name
string | $uri | The URI for the asset
array | $options | Additional options for the asset
array | $attributes | Attributes for the asset
array | $dependencies | Asset dependencies
Depuis
4.0.0

Références $attributes, $name, $options, $uri, et name.

Documentation des fonctions membres

◆ getAttribute()

getAttribute | ( | string | $key,
 |  |  | $default = null
 | ) |  |

Get the attribute

Paramètres
string | $key | An attributes key
string | $default | A default value
Renvoie
mixed
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $default, et $key.

◆ getAttributes()

getAttributes ( )

Get all attributes

Renvoie
array
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $attributes.

◆ getDependencies()

getDependencies ( )

Return dependencies list

Renvoie
array
Depuis
4.0.0

Implémente WebAssetItemInterface.

◆ getName()

getName ( )

Return Asset name

Renvoie
string
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $name.

◆ getOption()

getOption | ( | string | $key,
 |  |  | $default = null
 | ) |  |

Get the option

Paramètres
string | $key | An option key
string | $default | A default value
Renvoie
mixed
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $default, et $key.

◆ getOptions()

getOptions ( )

Get all options

Renvoie
array
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $options.

◆ getUri()

getUri ( $resolvePath = true )

Get the file path

Paramètres
boolean $resolvePath Whether need to search for a real paths
Renvoie
string The resolved path if resolved, else an empty string.
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $path, et $uri.

◆ getVersion()

getVersion ( )

Return Asset version

Renvoie
string
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $version.

◆ isPathAbsolute()

isPathAbsolute ( string $path )
protected

Check if the Path is relative to /media folder or absolute

Paramètres
string $path Path to test
Renvoie
boolean
Depuis
4.0.0

Références $path, et JPATH_ROOT.

◆ isPathExternal()

isPathExternal ( string $path )
protected

Check if the Path is External

Paramètres
string $path Path to test
Renvoie
boolean
Depuis
4.0.0

Références $path.

◆ resolvePath()

resolvePath | ( | string | $path,
 |  | string | $type
 | ) |  |
protected

Resolve path

Paramètres
string | $path | The path to resolve
string | $type | The resolver method
Renvoie
string
Depuis
4.0.0

Références $path, $type, et HTMLHelper\_().

◆ setAttribute()

setAttribute | ( | string | $key,
 |  |  | $value = null
 | ) |  |

Set the attribute

Paramètres
string | $key | An attribute key
string | $value | An attribute value
Renvoie
self
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $key, $this, et $value.

◆ setOption()

setOption | ( | string | $key,
 |  |  | $value = null
 | ) |  |

Set the option

Paramètres
string | $key | An option key
string | $value | An option value
Renvoie
self
Depuis
4.0.0

Implémente WebAssetItemInterface.

Références $key, $this, et $value.

Documentation des champs

◆ $attributes

$attributes = []
protected

◆ $dependencies

$dependencies = []
protected

◆ $name

string $name = ''
protected

Asset name

Depuis
4.0.0

◆ $options

$options = []
protected

◆ $uri

$uri = ''
protected

◆ $version

$version = 'auto'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebAssetItem.php


Joomla CMS: Référence de l'interface WebAssetItemInterface

  • Joomla
  • CMS
  • WebAsset
  • WebAssetItemInterface
Fonctions membres publiques
Référence de l'interface WebAssetItemInterface
+ Graphe d'héritage de WebAssetItemInterface:
WebAssetItem CoreAssetItem FormValidateAssetItem KeepaliveAssetItem LangActiveAssetItem TableColumnsAssetItem

Fonctions membres publiques

getName ()
getVersion ()
getDependencies ()
getUri ($resolvePath=true)
getOption (string $key, $default=null)
setOption (string $key, $value=null)
getOptions ()
getAttribute (string $key, $default=null)
setAttribute (string $key, $value=null)
getAttributes ()

Description détaillée

Web Asset Item interface

Asset Item are "read only" object, all properties must be set through class constructor. Only properties allowed to be edited is an attributes and an options. Changing an uri or a dependencies are not allowed, prefer to create a new asset instance.

Depuis
4.0.0

Documentation des fonctions membres

◆ getAttribute()

getAttribute | ( | string | $key,
 |  |  | $default = null
 | ) |  |

Get the attribute

Paramètres
string | $key | An attributes key
string | $default | A default value
Renvoie
mixed
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getAttributes()

getAttributes ( )

Get all attributes

Renvoie
array
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getDependencies()

getDependencies ( )

Return dependencies list

Renvoie
array
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getName()

getName ( )

Return Asset name

Renvoie
string
Depuis
4.0.0

Implémenté dans WebAssetItem.

Référencé par WebAssetManager\__call(), et WebAssetRegistry\add().

◆ getOption()

getOption | ( | string | $key,
 |  |  | $default = null
 | ) |  |

Get the option

Paramètres
string | $key | An option key
string | $default | A default value
Renvoie
mixed
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getOptions()

getOptions ( )

Get all options of the asset

Renvoie
array
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getUri()

getUri ( $resolvePath = true )

Get the URI of the asset

Paramètres
boolean $resolvePath Whether need to search for a real paths
Renvoie
string
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ getVersion()

getVersion ( )

Return Asset version

Renvoie
string
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ setAttribute()

setAttribute | ( | string | $key,
 |  |  | $value = null
 | ) |  |

Set the attribute

Paramètres
string | $key | An attribute key
string | $value | An attribute value
Renvoie
self
Depuis
4.0.0

Implémenté dans WebAssetItem.

◆ setOption()

setOption | ( | string | $key,
 |  |  | $value = null
 | ) |  |

Set the option

Paramètres
string | $key | An option key
string | $value | An option value
Renvoie
self
Depuis
4.0.0

Implémenté dans WebAssetItem.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WebAssetItemInterface.php


Joomla CMS: Référence de la classe WebAssetManager

  • Joomla
  • CMS
  • WebAsset
  • WebAssetManager
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe WebAssetManager
+ Graphe d'héritage de WebAssetManager:
WebAssetManagerInterface

Fonctions membres publiques

__construct (WebAssetRegistry $registry)
getRegistry ()
reset ()
__call ($method, $arguments)
useAsset (string $type, string $name)
disableAsset (string $type, string $name)
getAssetState (string $type, string $name)
isAssetActive (string $type, string $name)
assetExists (string $type, string $name)
registerAsset (string $type, $asset, string $uri='', array $options=[], array $attributes=[], array $dependencies=[])
getAsset (string $type, string $name)
getAssets (string $type, bool $sort=false)
getInlineRelation (array $assets)
filterOutInlineAssets (array &$assets)
addInline (string $type, $content, array $options=[], array $attributes=[], array $dependencies=[])
lock ()
getManagerState ()

Champs de données

const | ASSET_STATE_INACTIVE = 0
const | ASSET_STATE_ACTIVE = 1
const | ASSET_STATE_DEPENDENCY = 2

Fonctions membres protégées

usePresetItems ($name)
disablePresetItems ($name)
enableDependencies (string $type=null, WebAssetItem $asset=null)
calculateOrderOfActiveAssets ($type)
getConnectionsGraph (array $assets)
getDependenciesForAsset (string $type, WebAssetItem $asset, $recursively=false, string $recursionType=null, WebAssetItem $recursionRoot=null)

Attributs protégés

$registry
$activeAssets = []
$locked = false
$dependenciesIsActual = false

Description détaillée

Web Asset Manager class

WebAssetManager registerStyle(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager registerAndUseStyle(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager useStyle($name) WebAssetManager disableStyle($name) WebAssetManager addInlineStyle(WebAssetItem|string $content, $options = [], $attributes = [], $dependencies = [])

WebAssetManager registerScript(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager registerAndUseScript(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager useScript($name) WebAssetManager disableScript($name) WebAssetManager addInlineScript(WebAssetItem|string $content, $options = [], $attributes = [], $dependencies = [])

WebAssetManager registerPreset(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager registerAndUsePreset(WebAssetItem|string $asset, string $uri = '', $options = [], $attributes = [], $dependencies = []) WebAssetManager usePreset($name) WebAssetManager disablePreset($name)

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( WebAssetRegistry $registry )

Class constructor

Paramètres
WebAssetRegistry $registry The WebAsset Registry instance
Depuis
4.0.0

Références WebAssetRegistryAssetChanged\getAsset(), et WebAssetRegistryAssetChanged\getAssetType().

Documentation des fonctions membres

◆ __call()

__call | ( | $method,
 |  | $arguments
 | ) |

Adds support for magic method calls

Paramètres
string | $method | A method name
array | $arguments | Arguments for a method
Renvoie
mixed
Exceptions

Références $method, $name, $this, $type, et WebAssetItemInterface\getName().

◆ addInline()

addInline | ( | string | $type,
 |  |  | $content,
 |  | array | $options = [],
 |  | array | $attributes = [],
 |  | array | $dependencies = []
 | ) |  |

Add a new inline content asset. Allow to register WebAssetItem instance in the registry, by call addInline($type, $assetInstance) Or create an asset on fly (from name and Uri) and register in the registry, by call addInline($type, $content, $options ....)

Paramètres
string | $type | The asset type, script or style
WebAssetItem | string | $content | The content to of inline asset
array | $options | Additional options for the asset
array | $attributes | Attributes for the asset
array | $dependencies | Asset dependencies
Renvoie
self
Depuis
4.0.0
Exceptions

Références $attributes, $content, $name, $options, $this, $type, class, et elseif.

◆ assetExists()

assetExists | ( | string | $type,
 |  | string | $name
 | ) |  |

Helper method to check whether the asset exists in the registry.

Paramètres
string | $type | Asset type, script or style
string | $name | Asset name
Renvoie
boolean
Depuis
4.0.0

Références $name, et $type.

◆ calculateOrderOfActiveAssets()

calculateOrderOfActiveAssets ( $type )
protected

Calculate weight of active Assets, by its Dependencies

Paramètres
string $type The asset type, script or style
Renvoie
WebAssetItem[]
Depuis
4.0.0

Références $item, $name, $type, et null.

◆ disableAsset()

disableAsset | ( | string | $type,
 |  | string | $name
 | ) |  |

Deactivate an asset item, so it will not be attached to a Document

Paramètres
string | $type | The asset type, script or style
string | $name | The asset name
Renvoie
self
Exceptions
UnknownAssetException | When Asset cannot be found
InvalidActionException | When the Manager already attached to a Document
Depuis
4.0.0

Implémente WebAssetManagerInterface.

Références $name, $this, et $type.

◆ disablePresetItems()

disablePresetItems ( $name )
protected

Deactivate list of assets provided by Preset item.

Paramètres
string $name The asset name
Renvoie
self
Exceptions
UnsatisfiedDependencyException When Asset dependency cannot be found
Depuis
4.0.0

Références $name, et $this.

◆ enableDependencies()

enableDependencies | ( | string | $type = null,
 |  | WebAssetItem | $asset = null
 | ) |  |
protected

Update Dependencies state for all active Assets or only for given

Paramètres
string | $type | The asset type, script or style
WebAssetItem | $asset | The asset instance to which need to enable dependencies
Renvoie
self
Depuis
4.0.0

Références $name, $state, $this, $type, et WebAssetManager\ASSET_STATE_ACTIVE.

◆ filterOutInlineAssets()

filterOutInlineAssets ( array & $assets )

Helper method to filter an inline assets

Paramètres
WebAssetItem[] $assets Reference to a full list of active assets
Renvoie
WebAssetItem[] Array of inline assets
Depuis
4.0.0

◆ getAsset()

getAsset | ( | string | $type,
 |  | string | $name
 | ) |  |

Helper method to get the asset from the registry.

Paramètres
string | $type | Asset type, script or style
string | $name | Asset name
Renvoie
WebAssetItemInterface
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Références $name, et $type.

◆ getAssets()

getAssets | ( | string | $type,
 |  | bool | $sort = false
 | ) |  |

Get all active assets, optionally sort them to follow the dependency Graph

Paramètres
string | $type | The asset type, script or style
bool | $sort | Whether need to sort the assets to follow the dependency Graph
Renvoie
WebAssetItem[]
Exceptions
UnknownAssetException | When Asset cannot be found
UnsatisfiedDependencyException | When Dependency cannot be found
Depuis
4.0.0

Implémente WebAssetManagerInterface.

Références $name, $sort, et $type.

◆ getAssetState()

getAssetState | ( | string | $type,
 |  | string | $name
 | ) |  |

Get a state for the Asset

Paramètres
string | $type | The asset type, script or style
string | $name | The asset name
Renvoie
integer
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Références $name, et $type.

◆ getConnectionsGraph()

getConnectionsGraph ( array $assets )
protected

Build Graph of Outgoing and Incoming connections for given assets.

Paramètres
WebAssetItem[] $assets Asset instances
Renvoie
array
Depuis
4.0.0

Références $name.

◆ getDependenciesForAsset()

getDependenciesForAsset | ( | string | $type,
 |  | WebAssetItem | $asset,
 |  |  | $recursively = false,
 |  | string | $recursionType = null,
 |  | WebAssetItem | $recursionRoot = null
 | ) |  |
protected

Return dependencies for Asset as array of WebAssetItem objects

Paramètres
string | $type | The asset type, script or style
WebAssetItem | $asset | Asset instance
boolean | $recursively | Whether to search for dependency recursively
string | $recursionType | The type of initial item to prevent loop
WebAssetItem | $recursionRoot | Initial item to prevent loop
Renvoie
array
Exceptions
UnsatisfiedDependencyException When Dependency cannot be found
Depuis
4.0.0

Références $type.

◆ getInlineRelation()

getInlineRelation ( array $assets )

Helper method to calculate inline to non inline relation (before/after positions). Return associated array, which contain dependency (handle) name as key, and list of inline items for each position. Example: ['handle.name' => ['before' => ['inline1', 'inline2'], 'after' => ['inline3', 'inline4']]]

Note: If inline asset have a multiple dependencies, then will be used last one from the list for positioning

Paramètres
WebAssetItem[] $assets The assets list
Renvoie
array
Depuis
4.0.0

Références $position, et null.

◆ getManagerState()

getManagerState ( )

Get the manager state. A collection of registry files and active asset names (per type).

Renvoie
array
Depuis
4.0.0

Références Joomla\CMS\HTML\getRegistry().

◆ getRegistry()

getRegistry ( )

Get associated registry instance

Renvoie
WebAssetRegistry
Depuis
4.0.0

◆ isAssetActive()

isAssetActive | ( | string | $type,
 |  | string | $name
 | ) |  |

Check whether the asset are enabled

Paramètres
string | $type | The asset type, script or style
string | $name | The asset name
Renvoie
boolean
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Implémente WebAssetManagerInterface.

Références $name, et $type.

◆ lock()

lock ( )

Lock the manager to prevent further modifications

Renvoie
self
Depuis
4.0.0

Références $this.

◆ registerAsset()

registerAsset | ( | string | $type,
 |  |  | $asset,
 |  | string | $uri = '',
 |  | array | $options = [],
 |  | array | $attributes = [],
 |  | array | $dependencies = []
 | ) |  |

Register a new asset. Allow to register WebAssetItem instance in the registry, by call registerAsset($type, $assetInstance) Or create an asset on fly (from name and Uri) and register in the registry, by call registerAsset($type, $assetName, $uri, $options ....)

Paramètres
string | $type | The asset type, script or style
WebAssetItem | string | $asset | The asset name or instance to register
string | $uri | The URI for the asset
array | $options | Additional options for the asset
array | $attributes | Attributes for the asset
array | $dependencies | Asset dependencies
Renvoie
self
Depuis
4.0.0
Exceptions

Références $attributes, $options, $this, $type, $uri, class, et elseif.

◆ reset()

reset ( )

Clears all collected items.

Renvoie
self
Depuis
4.1.1

Références $this.

◆ useAsset()

useAsset | ( | string | $type,
 |  | string | $name
 | ) |  |

Enable an asset item to be attached to a Document

Paramètres
string | $type | The asset type, script or style
string | $name | The asset name
Renvoie
self
Exceptions
UnknownAssetException | When Asset cannot be found
InvalidActionException | When the Manager already attached to a Document
Depuis
4.0.0

Implémente WebAssetManagerInterface.

Références $name, $this, et $type.

◆ usePresetItems()

usePresetItems ( $name )
protected

Enable list of assets provided by Preset item.

"Preset" a special kind of asset that hold a list of assets that has to be enabled, same as direct call of useAsset() to each of item in list. Can hold mixed types of assets (script, style, another preset, etc), the type provided after # symbol, after the asset name, example: foo::style, bar::script.

The method call useAsset() internally for each of its dependency, this is important for keeping FIFO order of enabled items. The Preset not a strict asset, and each of its dependency can be safely disabled by use of disableAsset() later.

Paramètres
string $name The asset name
Renvoie
self
Exceptions
UnsatisfiedDependencyException When Asset dependency cannot be found
Depuis
4.0.0

Références $name, et $this.

Documentation des champs

◆ $activeAssets

$activeAssets = []
protected

◆ $dependenciesIsActual

$dependenciesIsActual = false
protected

◆ $locked

$locked = false
protected

◆ $registry

$registry
protected

◆ ASSET_STATE_ACTIVE

const ASSET_STATE_ACTIVE = 1

Référencé par WebAssetManager\enableDependencies().

◆ ASSET_STATE_DEPENDENCY

const ASSET_STATE_DEPENDENCY = 2

◆ ASSET_STATE_INACTIVE

const ASSET_STATE_INACTIVE = 0
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebAssetManager.php


Joomla CMS: Référence de l'interface WebAssetManagerInterface

  • Joomla
  • CMS
  • WebAsset
  • WebAssetManagerInterface
Fonctions membres publiques
Référence de l'interface WebAssetManagerInterface
+ Graphe d'héritage de WebAssetManagerInterface:
WebAssetManager

Fonctions membres publiques

useAsset (string $type, string $name)
disableAsset (string $type, string $name)
isAssetActive (string $type, string $name)
getAssets (string $type, bool $sort=false)

Description détaillée

Web Asset Manager Interface

Depuis
4.0.0

Documentation des fonctions membres

◆ disableAsset()

disableAsset | ( | string | $type,
 |  | string | $name
 | ) |  |

Deactivate an asset item, so it will not be attached to a Document

Paramètres
string | $type | Asset type, script or style etc
string | $name | The asset name
Renvoie
self
Exceptions
UnknownAssetException | When Asset cannot be found
InvalidActionException | When the Manager already attached to a Document
Depuis
4.0.0

Implémenté dans WebAssetManager.

◆ getAssets()

getAssets | ( | string | $type,
 |  | bool | $sort = false
 | ) |  |

Get all assets that was enabled for given type

Paramètres
string | $type | Asset type, script or style etc
bool | $sort | Whether need to sort the assets to follow the dependency Graph
Renvoie
WebAssetItemInterface[]
Exceptions
UnknownAssetException | When Asset cannot be found
UnsatisfiedDependencyException | When Dependency cannot be found
Depuis
4.0.0

Implémenté dans WebAssetManager.

◆ isAssetActive()

isAssetActive | ( | string | $type,
 |  | string | $name
 | ) |  |

Check whether the asset are enabled

Paramètres
string | $type | Asset type, script or style etc
string | $name | The asset name
Renvoie
boolean
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Implémenté dans WebAssetManager.

◆ useAsset()

useAsset | ( | string | $type,
 |  | string | $name
 | ) |  |

Enable an asset item to be attached to a Document

Paramètres
string | $type | Asset type, script or style etc
string | $name | The asset name
Renvoie
self
Exceptions
UnknownAssetException | When Asset cannot be found
InvalidActionException | When the Manager already attached to a Document
Depuis
4.0.0

Implémenté dans WebAssetManager.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WebAssetManagerInterface.php


Joomla CMS: Référence de la classe WebAssetRegistry

  • Joomla
  • CMS
  • WebAsset
  • WebAssetRegistry
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WebAssetRegistry
+ Graphe d'héritage de WebAssetRegistry:
WebAssetRegistryInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ()
get (string $type, string $name)
add (string $type, WebAssetItemInterface $asset)
remove (string $type, string $name)
exists (string $type, string $name)
createAsset (string $name, string $uri=null, array $options=[], array $attributes=[], array $dependencies=[])
addRegistryFile (string $path)
getRegistryFiles ()
addTemplateRegistryFile (string $template, int $client)
addExtensionRegistryFile (string $name)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

parseRegistryFiles ()
parseRegistryFile ($path)
dispatchAssetChanged (string $type, WebAssetItemInterface $asset, string $change)

Attributs protégés

$dataFilesNew = []
$dataFilesParsed = []
$assets = []

Description détaillée

Web Asset Registry class

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Registry constructor

Depuis
4.0.0

Références Joomla\Event\setDispatcher().

Documentation des fonctions membres

◆ add()

add | ( | string | $type,
 |  | WebAssetItemInterface | $asset
 | ) |  |

Add Asset to registry of known assets

Paramètres
string | $type | Asset type, script or style
WebAssetItemInterface | $asset | Asset instance
Renvoie
self
Depuis
4.0.0

Implémente WebAssetRegistryInterface.

Références $this, $type, et WebAssetItemInterface\getName().

◆ addExtensionRegistryFile()

addExtensionRegistryFile ( string $name )

Helper method to register new file with Extension Asset(s) info

Paramètres
string $name A full extension name, actually a name in the /media folder, eg: com_example, plg_system_example etc.
Renvoie
self
Depuis
4.0.0

Références $name, et $this.

◆ addRegistryFile()

addRegistryFile ( string $path )

Register new file with Asset(s) info

Paramètres
string $path Relative path
Renvoie
self
Depuis
4.0.0

Références $path, $this, Path\clean(), et JPATH_ROOT.

◆ addTemplateRegistryFile()

addTemplateRegistryFile | ( | string | $template,
 |  | int | $client
 | ) |  |

Helper method to register new file with Template Asset(s) info

Paramètres
string | $template | The template name
integer | $client | The application client id
Renvoie
self
Depuis
4.0.0

Références $client, $template, et $this.

◆ createAsset()

createAsset | ( | string | $name,
 |  | string | $uri = null,
 |  | array | $options = [],
 |  | array | $attributes = [],
 |  | array | $dependencies = []
 | ) |  |

Prepare new Asset instance.

Paramètres
string | $name | The asset name
string | $uri | The URI for the asset
array | $options | Additional options for the asset
array | $attributes | Attributes for the asset
array | $dependencies | Asset dependencies
Renvoie
WebAssetItem
Depuis
4.0.0

Références $attributes, $className, $name, $options, $uri, et null.

◆ dispatchAssetChanged()

dispatchAssetChanged | ( | string | $type,
 |  | WebAssetItemInterface | $asset,
 |  | string | $change
 | ) |  |
protected

Dispatch an event to notify listeners about asset changes: new, remove, override Events:

  • onWebAssetRegistryChangedAssetNew When new asset added to the registry
  • onWebAssetRegistryChangedAssetOverride When the asset overridden
  • onWebAssetRegistryChangedAssetRemove When new asset was removed from the registry
Paramètres
string | $type | Asset type, script or style
WebAssetItemInterface | $asset | Asset instance
string | $change | A type of change: new, remove, override
Renvoie
void
Depuis
4.0.0

Références $this, $type, AbstractEvent\create(), et Joomla\CMS\Application\getDispatcher().

◆ exists()

exists | ( | string | $type,
 |  | string | $name
 | ) |  |

Check whether the asset exists in the registry.

Paramètres
string | $type | Asset type, script or style
string | $name | Asset name
Renvoie
boolean
Depuis
4.0.0

Implémente WebAssetRegistryInterface.

Références $name, et $type.

◆ get()

get | ( | string | $type,
 |  | string | $name
 | ) |  |

Get an existing Asset from a registry, by asset name.

Paramètres
string | $type | Asset type, script or style
string | $name | Asset name
Renvoie
WebAssetItem
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Implémente WebAssetRegistryInterface.

Références $name, et $type.

◆ getRegistryFiles()

getRegistryFiles ( )

Get a list of the registry files

Renvoie
array
Depuis
4.0.0

◆ parseRegistryFile()

parseRegistryFile ( $path )
protected

Parse registry file

Paramètres
string $path Relative path to the data file
Renvoie
void
Exceptions

Références $data, $i, $item, $name, $namespace, $options, $path, $uri, JPATH_ROOT, et null.

◆ parseRegistryFiles()

parseRegistryFiles ( )
protected

Parse registered files

Renvoie
void
Depuis
4.0.0

Références $path.

◆ remove()

remove | ( | string | $type,
 |  | string | $name
 | ) |  |

Remove Asset from registry.

Paramètres
string | $type | Asset type, script or style
string | $name | Asset name
Renvoie
self
Depuis
4.0.0

Implémente WebAssetRegistryInterface.

Références $name, $this, et $type.

Documentation des champs

◆ $assets

$assets = []
protected

◆ $dataFilesNew

$dataFilesNew = []
protected

◆ $dataFilesParsed

$dataFilesParsed = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebAsset/WebAssetRegistry.php


Joomla CMS: Référence de l'interface WebAssetRegistryInterface

  • Joomla
  • CMS
  • WebAsset
  • WebAssetRegistryInterface
Fonctions membres publiques
Référence de l'interface WebAssetRegistryInterface
+ Graphe d'héritage de WebAssetRegistryInterface:
WebAssetRegistry

Fonctions membres publiques

get (string $type, string $name)
add (string $type, WebAssetItemInterface $asset)
remove (string $type, string $name)
exists (string $type, string $name)

Description détaillée

Web Asset Registry interface

Depuis
4.0.0

Documentation des fonctions membres

◆ add()

add | ( | string | $type,
 |  | WebAssetItemInterface | $asset
 | ) |  |

Add Asset to registry of known assets

Paramètres
string | $type | Asset type, script or style etc
WebAssetItemInterface | $asset | Asset instance
Renvoie
self
Depuis
4.0.0

Implémenté dans WebAssetRegistry.

◆ exists()

exists | ( | string | $type,
 |  | string | $name
 | ) |  |

Check whether the asset exists in the registry.

Paramètres
string | $type | Asset type, script or style etc
string | $name | Asset name
Renvoie
boolean
Depuis
4.0.0

Implémenté dans WebAssetRegistry.

◆ get()

get | ( | string | $type,
 |  | string | $name
 | ) |  |

Get an existing Asset from a registry, by asset name and asset type.

Paramètres
string | $type | Asset type, script or style etc
string | $name | Asset name
Renvoie
WebAssetItem
Exceptions
UnknownAssetException When Asset cannot be found
Depuis
4.0.0

Implémenté dans WebAssetRegistry.

◆ remove()

remove | ( | string | $type,
 |  | string | $name
 | ) |  |

Remove Asset from registry.

Paramètres
string | $type | Asset type, script or style etc
string | $name | Asset name
Renvoie
self
Depuis
4.0.0

Implémenté dans WebAssetRegistry.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WebAssetRegistryInterface.php


Joomla CMS: Référence de la classe Workflow

  • Joomla
  • CMS
  • Workflow
  • Workflow
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe Workflow

Fonctions membres publiques

__construct (string $extension, ?CMSApplication $app=null, ?DatabaseDriver $db=null)
getConditionName (int $value)
getDefaultStageByCategory ($catId=0)
getValidTransition (array $pks, int $transitionId)
executeTransition (array $pks, int $transitionId)
createAssociation (int $pk, int $state)
updateAssociations (array $pks, int $state)
deleteAssociation (array $pks)
getAssociation (int $itemId)

Champs de données

const | CONDITION_NAMES
const | CONDITION_PUBLISHED = 1
const | CONDITION_UNPUBLISHED = 0
const | CONDITION_TRASHED = -2
const | CONDITION_ARCHIVED = 2

Fonctions membres protégées

getComponent ()

Attributs protégés

$component = null
$extension = null
$app
$db

Description détaillée

Workflow Class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $extension,
 |  | ?CMSApplication | $app = null,
 |  | ?DatabaseDriver | $db = null
 | ) |  |

Class constructor

Paramètres
string | $extension | The extension name
?CMSApplication | $app Application Object
?DatabaseDriver | $db Database Driver Object
Depuis
4.0.0

Références $app, $db, $extension, extension, Factory\getApplication(), et Factory\getDbo().

Documentation des fonctions membres

◆ createAssociation()

createAssociation | ( | int | $pk,
 |  | int | $state
 | ) |  |

Creates an association for the workflow_associations table

Paramètres
integer | $pk | ID of the item
integer | $state | ID of state
Renvoie
boolean
Depuis
4.0.0

Références $query, $state, extension, et ParameterType\INTEGER.

◆ deleteAssociation()

deleteAssociation ( array $pks )

Removes associations from the workflow_associations table

Paramètres
integer[] $pks ID of content
Renvoie
boolean
Depuis
4.0.0

Références $query, extension, et ArrayHelper\toInteger().

◆ executeTransition()

executeTransition | ( | array | $pks,
 |  | int | $transitionId
 | ) |  |

Executes a transition to change the current state in the association table

Paramètres
integer[] | $pks The item IDs, which should use the transition
integer | $transitionId | The transition which should be executed
Renvoie
boolean

Références $assoc, $this, AbstractEvent\create(), extension, PluginHelper\importPlugin(), et ArrayHelper\toInteger().

◆ getAssociation()

getAssociation ( int $itemId )

Loads an existing association item with state and item ID

Paramètres
integer $itemId The item ID to load
Renvoie
|null
Depuis
4.0.0

Références $itemId, $query, extension, et ParameterType\INTEGER.

◆ getComponent()

getComponent ( )
protected

Returns the booted component

Renvoie
ComponentInterface
Depuis
4.0.0

Références $component, $parts, et extension.

◆ getConditionName()

getConditionName ( int $value )

Returns the translated condition name, based on the given number

Paramètres
integer $value The condition ID
Renvoie
string
Depuis
4.0.0

Références $component, $value, extension, et ArrayHelper\getValue().

◆ getDefaultStageByCategory()

getDefaultStageByCategory ( $catId = 0 )

Try to load a workflow default stage by category ID.

Paramètres
integer $catId The category ID.
Renvoie
boolean|integer An integer, holding the stage ID or false
Depuis
4.0.0

Références $category, $query, elseif, extension, et ParameterType\INTEGER.

◆ getValidTransition()

getValidTransition | ( | array | $pks,
 |  | int | $transitionId
 | ) |  |

Check if a transition can be executed

Paramètres
integer[] | $pks The item IDs, which should use the transition
integer | $transitionId | The transition which should be executed
Renvoie
object | null

Références $option, $parts, $query, $user, extension, ParameterType\INTEGER, null, et ArrayHelper\toInteger().

◆ updateAssociations()

updateAssociations | ( | array | $pks,
 |  | int | $state
 | ) |  |

Update an existing association with a new state

Paramètres
array | $pks | An Array of item IDs which should be changed
integer | $state | The new state ID
Renvoie
boolean
Depuis
4.0.0

Références $query, $state, extension, ParameterType\INTEGER, et ArrayHelper\toInteger().

Documentation des champs

◆ $app

$app
protected

◆ $component

$component = null
protected

◆ $db

$db
protected

◆ $extension

$extension = null
protected

◆ CONDITION_ARCHIVED

const CONDITION_ARCHIVED = 2

Every item with a state which has the condition ARCHIVED is archived

◆ CONDITION_NAMES

const CONDITION_NAMES
Valeur initiale :
= [
self::CONDITION_PUBLISHED => 'JPUBLISHED'

Condition to names mapping

Depuis
4.0.0

Référencé par Joomla\CMS\Workflow\getConditions().

◆ CONDITION_PUBLISHED

const CONDITION_PUBLISHED = 1

Every item with a state which has the condition PUBLISHED is visible/active on the page

Référencé par Icon\edit(), et ArticleModel\prepareTable().

◆ CONDITION_TRASHED

const CONDITION_TRASHED = -2

Every item with a state which has the condition TRASHED is trashed

◆ CONDITION_UNPUBLISHED

const CONDITION_UNPUBLISHED = 0

Every item with a state which has the condition UNPUBLISHED is not visible/inactive on the page

Référencé par Icon\edit().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Workflow.php


Joomla CMS: Référence de l'interface WorkflowServiceInterface

  • Joomla
  • CMS
  • Workflow
  • WorkflowServiceInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface WorkflowServiceInterface
+ Graphe d'héritage de WorkflowServiceInterface:
ContentComponent

Fonctions membres publiques

supportFunctionality ($functionality, $context)
getModelName ($context)
isWorkflowActive ($context)
filterTransitions (array $transitions, int $pk)
getWorkflowTableBySection (?string $section=null)
getWorkflowContexts ()
getCategoryWorkflowContext (?string $section=null)

Fonctions membres publiques statiques

static getConditions (string $extension)

Description détaillée

The workflow service.

Depuis
4.0.0

Documentation des fonctions membres

◆ filterTransitions()

filterTransitions | ( | array | $transitions,
 |  | int | $pk
 | ) |  |

Method to filter transitions by given id of state.

Paramètres
integer[] | $transitions Array of transitions to filter for
integer | $pk | Id of the state on which the transitions are performed
Renvoie
array
Depuis
4.0.0

Implémenté dans ContentComponent.

◆ getCategoryWorkflowContext()

getCategoryWorkflowContext ( ?string $section = null )

Returns the workflow context based on the given category section

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Implémenté dans ContentComponent.

◆ getConditions()

static getConditions ( string $extension )
static

Returns an array of possible conditions for the component.

Paramètres
string $extension Full extension string
Renvoie
array
Depuis
4.0.0

◆ getModelName()

getModelName ( $context )

Returns the model name, based on the context

Paramètres
string $context The context of the workflow
Renvoie
boolean

Implémenté dans ContentComponent.

◆ getWorkflowContexts()

getWorkflowContexts ( )

Returns valid contexts.

Renvoie
array
Depuis
4.0.0

Implémenté dans ContentComponent.

◆ getWorkflowTableBySection()

getWorkflowTableBySection ( ?string $section = null )

Returns a table name for the state association

Paramètres
string $section An optional section to differ different areas in the component
Renvoie
string
Depuis
4.0.0

Implémenté dans ContentComponent.

◆ isWorkflowActive()

isWorkflowActive ( $context )

Check if the workflow is active

Paramètres
string $context The context of the workflow
Renvoie
boolean

◆ supportFunctionality()

supportFunctionality | ( | $functionality,
 |  | $context
 | ) |

Check if the functionality is supported by the context

Paramètres
string | $functionality | The functionality
string | $context | The context of the functionality
Renvoie
boolean
Depuis
4.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • WorkflowServiceInterface.php


Joomla CMS: Référence de la classe Factory

  • Joomla
  • CMS
  • Factory
Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres protégées statiques
Référence de la classe Factory

Fonctions membres publiques statiques

static | getApplication ()
static | getConfig ($file=null, $type='PHP', $namespace='')
static | getContainer ()
static | getSession (array $options=array())
static | getLanguage ()
static | getDocument ()
static | getUser ($id=null)
static | getCache ($group='', $handler='callback', $storage=null)
static | getDbo ()
static | getMailer ()
static | getDate ($time='now', $tzOffset=null)
static | getStream ($usePrefix=true, $useNetwork=true, $userAgentSuffix='Joomla', $maskUserAgent=false)

Attributs publics statiques

static | $application = null
static | $cache = null
static | $config = null
static | $container = null
static | $dates = array()
static | $session = null
static | $language = null
static | $document = null
static | $database = null
static | $mailer = null

Fonctions membres protégées statiques

static | createConfig ($file, $type='PHP', $namespace='')
static | createContainer ()
static | createDbo ()
static | createMailer ()
static | createLanguage ()
static | createDocument ()

Description détaillée

Joomla Platform Factory class.

Depuis
1.7.0

Documentation des fonctions membres

◆ createConfig()

static createConfig | ( | $file,
 |  | $type = 'PHP',
 |  | $namespace = ''
 | ) |
staticprotected

Create a configuration object

Paramètres
string | $file | The path to the configuration file.
string | $type | The type of the configuration file.
string | $namespace | The namespace of the configuration file.
Renvoie
Registry
Voir également
Registry
Depuis
1.7.0
Obsolète:
5.0 Use the configuration object within the application.

Références $config, $name, $namespace, et $type.

◆ createContainer()

static createContainer ( )
staticprotected

Create a container object

Renvoie
Container
Depuis
4.0.0

Références $container.

◆ createDbo()

static createDbo ( )
staticprotected

Create a database object

Renvoie
DatabaseDriver
Voir également
DatabaseDriver
Depuis
1.7.0
Obsolète:
5.0 Use the database service in the DI container

Références $db, $options, $password, $prefix, $user, $value, class, et DatabaseDriver\getInstance().

◆ createDocument()

createDocument ( )
staticprotected

Create a document object

Renvoie
Document object
Voir également
Document
Depuis
1.7.0
Obsolète:
5.0 Load the document service from the dependency injection container or via $app->getDocument()

Creates a new Document object for the requested format.

Paramètres
string | $type | The document type to instantiate
array | $attributes | Array of attributes
Renvoie
Document
Depuis
4.0.0

Références $attributes, $input, $lang, $type, $version, class, et Joomla\DI\getContainer().

◆ createLanguage()

static createLanguage ( )
staticprotected

Create a language object

Renvoie
Language object
Voir également
Language
Depuis
1.7.0
Obsolète:
5.0 Load the language service from the dependency injection container or via $app->getLanguage()

Références $lang, class, et Joomla\DI\getContainer().

◆ createMailer()

static createMailer ( )
staticprotected

Create a mailer object

Renvoie
Mail object
Voir également
Mail
Depuis
1.7.0

Références Log\add(), MailHelper\cleanLine(), Mail\getInstance(), MailHelper\isEmailAddress(), null, et Log\WARNING.

◆ getApplication()

static getApplication ( )
static

Get the global application object. When the global application doesn't exist, an exception is thrown.

Renvoie
CMSApplicationInterface object
Depuis
1.7.0
Exceptions
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Route\_(), Language\_(), JsonResponse\__construct(), MapTable\__construct(), LangActiveAssetItem\__construct(), DisplayController\__construct(), Module\__construct(), Menu\__construct(), SelectModel\__construct(), RouterBase\__construct(), MemcachedStorage\__construct(), Cache\__construct(), Category\__construct(), UCMBase\__construct(), HtmlView\__construct(), CredentialRepository\__construct(), OpensearchDocument\__construct(), SiteMenu\__construct(), Captcha\__construct(), LanguagesModel\__construct(), FormattedtextLogger\__construct(), BaseDatabaseModel\__construct(), CacheStorage\__construct(), CategoryModel\__construct(), UCMType\__construct(), FieldModel\__construct(), CMSPlugin\__construct(), Workflow\__construct(), TaskModel\__construct(), Pagination\__construct(), Task\__construct(), Table\__construct(), BaseController\__construct(), CategoryModel\_buildContentOrderBy(), ExtensionAdapter\_endElement(), InstallModel\_getPackageFromFolder(), InstallModel\_getPackageFromUpload(), InstallModel\_getPackageFromUrl(), Categories\_load(), PageController\_noChange(), HtmlView\_prepareDocument(), ContactController\_sendEmail(), PageController\_setEtag(), HtmlView\_setPath(), RegistrationModel\activate(), UserModel\activate(), PlgSampledataMultilang\addCategory(), InstallerScript\addDashboardMenu(), MessagequeueLogger\addEntry(), HtmlView\addToolbar(), FormView\addToolbar(), Bootstrap\alert(), UpdateModel\applyUpdateSite(), AdministratorService\association(), Menus\association(), Authentication\authenticate(), Authentication\authorise(), User\authorise(), DatabaseModel\backupDatabase(), CategoryModel\batchCopy(), ArticleModel\batchMove(), CategoryModel\batchMove(), FieldModel\batchMove(), Joomla\CMS\MVC\Model\batchWorkflowStage(), User\bind(), UserModel\block(), BaseDatabaseModel\bootComponent(), LanguageHelper\branchSingular(), ContactModel\buildContactExtendedData(), ActionlogsModel\buildDateRange(), UsersModel\buildDateRange(), Bootstrap\button(), HTMLHelper\calendar(), Mfa\canAddEditMethod(), TransitionModel\canDelete(), StageModel\canDelete(), Mfa\canDeleteMethod(), TransitionModel\canEditState(), StageModel\canEditState(), TemplateHelper\canUpload(), MediaHelper\canUpload(), UpdateModel\captiveFileExists(), Bootstrap\carousel(), TaskTable\check(), User\check(), ChangeItem\check(), AdminModel\checkCategoryId(), FieldModel\checkDefaultValue(), SetupModel\checkForm(), CheckinModel\checkin(), Table\checkIn(), DatabaseHelper\checkRemoteDbHost(), ResetModel\checkResetLimit(), ConfigurationModel\checkTestingSampledata(), Session\checkToken(), CMSApplication\checkUserRequireReset(), TemplateModel\child(), CacheModel\clean(), AssociationsModel\clean(), GroupModel\cleanCache(), FieldModel\cleanCache(), CategoryModel\cleanCache(), ModuleHelper\cleanModuleList(), TemplateModel\cleanup(), UpdateModel\cleanUp(), InstallerHelper\cleanupInstall(), ArticleModel\cleanupPostBatchCopy(), JoomlaStorage\clear(), PlgSystemActionLogs\clearCacheGroups(), Banner\clientlist(), Bootstrap\collapse(), SessionCollector\collect(), InfoCollector\collect(), CategoryView\commonCategoryDisplay(), JoomlaInstallerScript\convertTablesToUtf8mb4(), TemplateModel\copy(), PackageAdapter\copyBaseFiles(), TemplateModel\copyFile(), TemplateModel\copyStyles(), Behavior\core(), TagsModel\countItems(), CategoriesModel\countItems(), CategoriesHelper\createCategory(), LanguageAdapter\createContentLanguage(), ApiModel\createFile(), TemplateModel\createFile(), ApiModel\createFolder(), TemplateModel\createFolder(), MVCFactory\createModel(), TemplateModel\createOverride(), ConfigurationModel\createRootUser(), MVCFactory\createTable(), DatabaseModel\createTables(), TagsHelper\createTagsFromField(), UpdateModel\createUpdateFile(), Help\createUrl(), MVCFactory\createView(), TemplateModel\cropImage(), HTMLHelper\date(), StageTable\delete(), WorkflowTable\delete(), MessageModel\delete(), MapsModel\delete(), IndexModel\delete(), StyleModel\delete(), UpdatesitesModel\delete(), HistoryModel\delete(), TracksModel\delete(), OverridesModel\delete(), MfaTable\delete(), GroupModel\delete(), MenuModel\delete(), UserModel\delete(), ApiModel\delete(), ModuleModel\delete(), ActionlogsModel\delete(), User\delete(), AdminModel\delete(), MethodsModel\deleteAll(), TemplateModel\deleteFile(), TemplateModel\deleteFolder(), DiscoverModel\discover_install(), Installer\discover_install(), FeedView\display(), OpensearchView\display(), CategoryFeedView\display(), TextView\display(), JsonView\display(), VcfView\display(), XmlView\display(), CategoriesView\display(), HtmlView\display(), Editor\display(), PlgSystemFields\display(), FieldsHelper\displayFieldOnForm(), TasksListCommand\doExecute(), InstallerHelper\downloadPackage(), LanguagesModel\downloadPackage(), Bootstrap\dropdown(), StyleModel\duplicate(), ModuleModel\duplicate(), Dropdown\edit(), PluginsHelper\elementOptions(), Joomla\CMS\MVC\Model\executeTransition(), Query\explained(), FieldsHelper\extract(), TemplateModel\extractArchive(), ArticleModel\featured(), CalendarField\filter(), UpdateModel\finaliseUpgrade(), RouteHelper\findItem(), CollectionAdapter\findUpdate(), ExtensionAdapter\findUpdate(), PluginsHelper\folderOptions(), SearchTools\form(), CredentialRepository\formatDate(), MethodsModel\formatRelative(), Jquery\framework(), Bootstrap\framework(), Version\generateMediaVersion(), RemoveModel\getActionlogModel(), ConfirmModel\getActionlogModel(), ExportModel\getActionlogModel(), RequestModel\getActionlogModel(), MenuHelper\getActive(), ModulesModel\getActivePositions(), CaptiveModel\getAllowedModulePositions(), TemplateModel\getArchive(), AssociationsHelper\getAssociationHtmlList(), AssociationHelper\getAssociations(), Access\getAuthorisedViewLevels(), MenuHelper\getBase(), TracksModel\getBaseName(), TemplateModel\getBasePath(), QuickIconHelper\getButtons(), CacheModel\getCache(), CapabilitiesModel\getCapabilities(), CategoryModel\getCategory(), UpdateModel\getCheckForSelfUpdate(), MVCFactory\getClassName(), BannersHelper\getClientOptions(), ApplicationHelper\getComponentName(), MessagesModel\getComponentOptions(), UpdateModel\getConfiguredDatabaseType(), RedisStorage\getConnection(), MemcachedStorage\getConnection(), TracksModel\getContent(), Helper\getContentExtras(), UsersComponent\getContexts(), UsersHelper\getContexts(), TemplateModel\getCoreFile(), TemplateModel\getCoreList(), ClientHelper\getCredentials(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), Joomla\CMS\User\getCurrentUser(), MessageRenderer\getData(), ProfileModel\getData(), ApplicationModel\getData(), ArchiveModel\getData(), RegistrationModel\getData(), LocalAdapter\getDate(), MenuHelper\getDefault(), FileLayout\getDefaultIncludePaths(), SysinfoModel\getDirectory(), EditorField\getEditor(), SysinfoModel\getEditor(), MessagesModel\getExtensionName(), SysinfoModel\getExtensions(), FieldsHelper\getFields(), FieldsHelper\getFieldsPluginId(), FieldsHelper\getFieldTypes(), ApiModel\getFile(), ApiModel\getFiles(), TemplateModel\getFiles(), TemplateModel\getFont(), TemplatesModel\getForm(), SetupModel\getForm(), GroupModel\getForm(), RemindModel\getForm(), TagModel\getForm(), ConfirmModel\getForm(), FormModel\getForm(), TransitionModel\getForm(), CategoryModel\getForm(), ChecksModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), LanguagesModel\getForm(), TemplateModel\getForm(), Session\getFormToken(), UserMessagesField\getGroups(), ApplicationHelper\getHash(), HelpModel\getHelpSearch(), ActionlogsHelper\getHumanReadableLogMessage(), TemplateModel\getImage(), AssociationField\getInput(), MenutypeField\getInput(), SectionField\getInput(), CaptchaField\getInput(), NumberField\getInput(), TextField\getInput(), CalendarField\getInput(), Categories\getInstance(), Session\getInstance(), BaseController\getInstance(), NoteModel\getItem(), FormModel\getItem(), OverrideModel\getItem(), LanguageModel\getItem(), TagModel\getItem(), NewsfeedModel\getItem(), FieldModel\getItem(), ModuleModel\getItem(), RouteHelper\getItemid(), WarningsModel\getItems(), CategoriesModel\getItems(), CheckinModel\getItems(), CategoryModel\getItems(), ArticlesModel\getItems(), AssociationsHelper\getLanguagefilterPluginId(), LoginHelper\getLanguageList(), LanguagesModel\getLanguages(), SetupModel\getLanguages(), DataField\getLayoutData(), TinymcebuilderField\getLayoutData(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), ColorField\getLayoutData(), MediaField\getLayoutData(), CalendarField\getLayoutData(), PluginHelper\getLayoutPath(), ModuleHelper\getLayoutPath(), AbstractStatsField\getLayoutPaths(), JoomlatokenField\getLayoutPaths(), PlgSystemStats\getLayoutPaths(), SampledataHelper\getList(), StatsHelper\getList(), TagsPopularHelper\getList(), ArticlesPopularHelper\getList(), LanguagesHelper\getList(), TagsSimilarHelper\getList(), ArticlesArchiveHelper\getList(), ArticlesCategoryHelper\getList(), ArticlesLatestHelper\getList(), ArticlesNewsHelper\getList(), ArchiveModel\getListQuery(), TagsModel\getListQuery(), FieldsModel\getListQuery(), ActionlogsHelper\getLogContentTypeParams(), TemplateModel\getMediaFiles(), MenusHelper\getMenuItems(), MenusHelper\getMenuLinks(), MethodsModel\getMethods(), Mfa\getMfaMethods(), ContentComponent\getModelName(), ModuleHelper\getModules(), LanguageField\getNativeLanguage(), WhosonlineHelper\getOnlineCount(), WhosonlineHelper\getOnlineUserNames(), FrontendlanguageField\getOptions(), NewsfeedsField\getOptions(), TemplatenameField\getOptions(), WorkflowComponentSectionsField\getOptions(), BranchesField\getOptions(), MenuParentField\getOptions(), ItemlanguageField\getOptions(), MenuOrderingField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsWorkflowField\getOptions(), ContenttypesField\getOptions(), ComponentsFieldsField\getOptions(), FieldcontextsField\getOptions(), WorkflowcontextsField\getOptions(), TypeField\getOptions(), GroupparentField\getOptions(), SubfieldsField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), SqlField\getOptions(), UserModel\getOtpConfigEncryptionKey(), HelpModel\getPage(), WrapperHelper\getParams(), Encrypt\getPassword(), Cache\getPlatformPrefix(), ModulesHelper\getPositions(), ModulesModel\getPositions(), MenusHelper\getPresets(), TemplateModel\getPreview(), PrivacyStatusHelper\getPrivacyPolicyInfo(), UserHelper\getProfile(), Joomla\Component\Media\Administrator\Provider\getProviderManager(), FinderHelper\getQuery(), CaptiveModel\getRecords(), RedirectHelper\getRedirectPluginId(), LoginHelper\getRegistrationUrl(), MethodModel\getRenderOptions(), PrivacyStatusHelper\getRequestFormPublished(), ResetModel\getResetConfirmForm(), LoginHelper\getReturnUrl(), RouteHelper\getRoute(), ConsoleApplication\getRouter(), CMSApplication\getRouter(), Joomla\Component\Scheduler\Administrator\Traits\getRoutineId(), HistoryModel\getSha1Hash(), UserHelper\getShortHashedUserAgent(), TemplateModel\getSource(), Indexer\getState(), PlgSystemJooa11y\getSubscribedEvents(), PlgSystemSchedulerunner\getSubscribedEvents(), Webauthn\getSubscribedEvents(), TagsHelper\getTagTreeArray(), TemplateModel\getTemplate(), User\getTimezone(), JoomlatokenField\getTokenForDisplay(), MenutypesModel\getTypeOptions(), UpdateAdapter\getUpdateSiteResponse(), ApiModel\getUrl(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), UsersLatestHelper\getUsers(), ListModel\getUserStateFromRequest(), Cache\getWorkarounds(), TransitionModel\getWorkflow(), ClientHelper\hasCredentials(), NewsfeedModel\hit(), ArticleModel\hit(), ContactModel\hit(), CategoryModel\hit(), PluginHelper\import(), PluginHelper\importPlugin(), HTMLHelper\includeRelativeFiles(), Indexer\index(), FinderIndexCommand\index(), DatabaseModel\initialise(), InstallModel\install(), LanguagesModel\install(), UpdateModel\install(), Installer\install(), Table\isCheckedOut(), Multilanguage\isEnabled(), Joomla\CMS\Workflow\isFunctionalityUsed(), ApiModel\isMediaFile(), Mail\isSendmail(), SocketTransport\isSupported(), Joomla\CMS\Workflow\isWorkflowActive(), HistoryModel\keep(), Behavior\keepalive(), Route\link(), ModuleHelper\load(), CaptiveModel\loadCaptiveRenderOptions(), FormModel\loadForm(), LoginModel\loadFormData(), MailModel\loadFormData(), OverrideModel\loadFormData(), NoteModel\loadFormData(), LinkModel\loadFormData(), RequestModel\loadFormData(), ComponentModel\loadFormData(), ClientModel\loadFormData(), FilterModel\loadFormData(), PluginModel\loadFormData(), NewsfeedModel\loadFormData(), LanguageModel\loadFormData(), UserModel\loadFormData(), MenuModel\loadFormData(), TagModel\loadFormData(), LevelModel\loadFormData(), WorkflowModel\loadFormData(), BannerModel\loadFormData(), MessageModel\loadFormData(), ContactModel\loadFormData(), StageModel\loadFormData(), TemplateModel\loadFormData(), TransitionModel\loadFormData(), GroupModel\loadFormData(), StyleModel\loadFormData(), CategoryModel\loadFormData(), ListModel\loadFormData(), UpdateModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), FieldModel\loadFormData(), AssociationsHelper\loadHelper(), HtmlView\loadTemplate(), CMSApplication\login(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), MailsHelper\mailtags(), Cache\makeId(), Finder\mapslist(), Bootstrap\modal(), Bootstrap\offcanvas(), PlgWorkflowPublishing\onAfterDisplay(), KeepaliveAssetItem\onAttachCallback(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgUserJoomla\onContentPrepareForm(), PlgSystemActionLogs\onContentPrepareForm(), PlgSystemFields\onContentPrepareForm(), PlgFieldsMedia\onCustomFieldsPrepareDom(), PlgFieldsSubform\onCustomFieldsPrepareDom(), PlgFieldsSubform\onCustomFieldsPrepareField(), PlgButtonFields\onDisplay(), PlgButtonImage\onDisplay(), ContentHelper\onPrepareForm(), MessagesModel\onProcessList(), PlgSystemFields\onUserAfterSave(), Bootstrap\popover(), DatabaseModel\populateDatabase(), LoginModel\populateState(), StageModel\populateState(), TransitionModel\populateState(), WorkflowModel\populateState(), ComponentModel\populateState(), DownloadModel\populateState(), SelectModel\populateState(), NewsfeedModel\populateState(), MessagesModel\populateState(), ArchiveModel\populateState(), ArticleModel\populateState(), TagsModel\populateState(), MenutypesModel\populateState(), MessageModel\populateState(), InstallModel\populateState(), StagesModel\populateState(), StylesModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), WorkflowsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), ManageModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), LanguageModel\populateState(), TagModel\populateState(), NewsfeedsModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), StyleModel\populateState(), MenuModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ModuleModel\populateState(), ArticlesModel\populateState(), NoteModel\populateState(), ResetModel\populateState(), SuggestionsModel\populateState(), OverridesModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), FormModel\populateState(), RemindModel\populateState(), RemoveModel\populateState(), GroupModel\populateState(), OverrideModel\populateState(), ConfirmModel\populateState(), ProfileModel\populateState(), NotesModel\populateState(), PluginModel\populateState(), RequestModel\populateState(), LanguagesModel\populateState(), HistoryModel\populateState(), ExportModel\populateState(), SearchModel\populateState(), TemplateModel\populateState(), RegistrationModel\populateState(), ListModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), AdminModel\populateState(), Modules\positionList(), Modules\positions(), InstallerScript\preflight(), Content\prepare(), Helper\prepareContent(), CategoriesView\prepareDocument(), CategoryView\prepareDocument(), HtmlView\prepareDocument(), JsonapiView\prepareItem(), HtmlView\prepareToolbar(), Menu\preprocess(), Joomla\CMS\MVC\Model\preprocessData(), FormModel\preprocessData(), TemplatesModel\preprocessForm(), Joomla\CMS\MVC\Model\preprocessForm(), FormModel\preprocessForm(), WorkflowModel\preprocessForm(), PluginModel\preprocessForm(), TransitionModel\preprocessForm(), StageModel\preprocessForm(), CategoryModel\preprocessForm(), Query\processDates(), SqlField\processQuery(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processString(), ManageModel\publish(), MessageModel\publish(), MapsModel\publish(), StageModel\publish(), WorkflowModel\publish(), IndexModel\publish(), CategoryModel\publish(), AdminModel\publish(), ItemModel\publish(), OverridesModel\purge(), CacheModel\purge(), IndexModel\purge(), ActionlogsModel\purge(), AssociationsModel\purge(), AdministratorApplication\purgeMessages(), UpdatesitesModel\rebuild(), ItemModel\rebuild(), FeedView\reconcileNames(), AdminModel\redirectToAssociations(), StringsModel\refresh(), BackupcodesModel\regenerateBackupCodes(), MVCFactory\register(), RegistrationModel\register(), ManageModel\remove(), Adapter\remove(), Indexer\remove(), UpdateModel\removePackageFiles(), ApplicationModel\removeroot(), TemplateModel\renameFile(), MessageRenderer\render(), ModulesRenderer\render(), ModuleRenderer\render(), JsonRenderer\render(), HtmlRenderer\render(), RssRenderer\render(), ImageDocument\render(), JsonapiRenderer\render(), Sidebar\render(), AtomRenderer\render(), JavascriptRenderer\render(), JsonapiDocument\render(), JavascriptRenderer\renderHead(), ModuleHelper\renderModule(), ModuleHelper\renderRawModule(), StreamTransport\request(), CurlTransport\request(), Credentials\requestAttestation(), TemplateModel\resizeImage(), PlgSystemSchedulerunner\runTestCron(), GroupModel\save(), StageModel\save(), WorkflowModel\save(), FieldModel\save(), OverrideModel\save(), TransitionModel\save(), ComponentModel\save(), LanguageModel\save(), UserModel\save(), MenuModel\save(), ApplicationModel\save(), MessageModel\save(), TemplateModel\save(), RequestModel\save(), StyleModel\save(), CategoryModel\save(), User\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), LevelsModel\saveorder(), AdminModel\saveorder(), HTMLHelper\script(), Bootstrap\scrollspy(), StringsModel\search(), TagsHelper\searchTags(), Filter\select(), MailModel\send(), Mail\Send(), Mail\sendMail(), ActionlogModel\sendNotificationEmails(), IndexerController\sendResponse(), ApplicationModel\sendTestMail(), FileLayout\setClient(), JoomlaStorage\setCookieParams(), ClientHelper\setCredentials(), ClientHelper\setCredentialsFromRequest(), LanguagesModel\setDefault(), HtmlView\setDocumentTitle(), ItemModel\setHome(), BreadcrumbsHelper\setSeparator(), ConfigurationModel\setup(), TransitionField\setup(), WorkflowconditionField\setup(), WorkflowstageField\setup(), CaptchaField\setup(), MenuField\setup(), MenuItemByTypeField\setup(), PasswordField\setup(), Cache\setWorkarounds(), Bootstrap\startAccordion(), Versioning\store(), TaskTable\store(), PageController\store(), ArticleModel\storeVote(), ApplicationHelper\stringURLSafe(), HTMLHelper\stylesheet(), CaptiveModel\suppressAllModules(), InstalledModel\switchAdminLanguage(), Bootstrap\tab(), CaptchaRule\test(), TimeRule\test(), PasswordRule\test(), ToolbarHelper\title(), Bootstrap\toast(), Bootstrap\tooltip(), Query\toUri(), Installer\uninstall(), InstallerHelper\unpack(), Installer\update(), updatecachetime_postinstall_action(), ApiModel\updateFile(), ConfigurationModel\updateUserIds(), UpdateModel\upload(), TemplateModel\uploadFile(), SetupModel\validate(), FormModel\validate(), ApplicationModel\validateDbConnection(), SetupModel\validateDbConnection(), UsersComponent\validateSection(), ContactComponent\validateSection(), ContentComponent\validateSection(), UsersHelper\validateSection(), Credentials\verifyAttestation(), et ApplicationModel\writeConfigFile().

◆ getCache()

static getCache | ( | $group = '',
 |  | $handler = 'callback',
 |  | $storage = null
 | ) |
static

Get a cache object

Returns the global CacheController object

Paramètres
string | $group | The cache group name
string | $handler | The handler to use
string | $storage | The storage method
Renvoie
object
Voir également
Cache
Depuis
1.7.0
Obsolète:
5.0 Use the cache controller factory instead

Références $hash, $options, class, et Joomla\DI\getContainer().

Référencé par MessagesModel\addPostInstallationMessage(), MessagesModel\archiveMessage(), LanguageAdapter\discover_install(), LanguageAdapter\finaliseUninstall(), MessagesModel\hideMessages(), CacheModel\purge(), MessagesModel\republishMessage(), MessagesModel\resetMessages(), ApplicationModel\save(), Filter\select(), MessagesModel\unpublishMessage(), et LanguageAdapter\update().

◆ getConfig()

static getConfig | ( | $file = null,
 |  | $type = 'PHP',
 |  | $namespace = ''
 | ) |
static

Get a configuration object

Returns the global JConfigobject,onlycreatingitifitdoesn'talreadyexist.@paramstring$fileThepathtotheconfigurationfile@paramstring$typeThetypeoftheconfigurationfile@paramstring$namespaceThenamespaceoftheconfigurationfile@returnRegistry@seeRegistry@since1.7.0\xrefitemdeprecated163.

If there is an application object, fetch the configuration from there. Check it's not null because LanguagesModel can make it null and if it's null we would want to re-init it from configuration.php.

Références $config, $namespace, $type, JPATH_CONFIGURATION, et null.

◆ getContainer()

static getContainer ( )
static

Get a container object

Returns the global service container object, only creating it if it doesn't already exist.

This method is only suggested for use in code whose responsibility is to create new services and needs to be able to resolve the dependencies, and should therefore only be used when the container is not accessible by other means. Valid uses of this method include:

  • A static getInstance() method calling a factory service from the container, see Joomla\CMS\Toolbar\Toolbar::getInstance() as an example
  • An application front controller loading and executing the Joomla application class, see the cli/joomla.php file as an example
  • Retrieving optional constructor dependencies when not injected into a class during a transitional period to retain backward compatibility, in this case a deprecation notice should also be emitted to notify developers of changes needed in their code

This method is not suggested for use as a one-for-one replacement of static calls, such as replacing calls to Factory::getDbo() with calls to ‘Factory::getContainer()->get('db’)`, code should be refactored to support dependency injection instead of making this change.

Renvoie
Container
Depuis
4.0.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $container.

Référencé par SitePathway\__construct(), CredentialRepository\__construct(), SiteRouter\__construct(), SiteMenu\__construct(), Editor\__construct(), Toolbar\__construct(), Authentication\__construct(), CliApplication\__construct(), Indexer\__construct(), Task\__construct(), Query\__construct(), Document\__construct(), Categories\_load(), MethodsController\assertLoggedInUser(), MethodController\assertLoggedInUser(), Uri\base(), Mfa\canAddEditMethod(), Mfa\canDeleteMethod(), FieldModel\checkDefaultValue(), MVCFactory\createModel(), MVCFactory\createTable(), ExecRuleHelper\dateTimeToSql(), MfaTable\delete(), MethodController\delete(), AbstractView\dispatchEvent(), BaseDatabaseModel\dispatchEvent(), MethodsController\display(), CredentialRepository\formatDate(), MethodsModel\formatRelative(), Joomla\CMS\Cache\getCacheControllerFactory(), SysinfoModel\getExtensions(), ContactModel\getForm(), Pathway\getInstance(), CacheController\getInstance(), Cache\getInstance(), Router\getInstance(), AbstractMenu\getInstance(), Toolbar\getInstance(), Installer\getInstance(), BaseController\getInstance(), User\getInstance(), Table\getInstance(), Language\getInstance(), CMSApplication\getInstance(), Form\getInstance(), MenusHelper\getMenuItems(), MethodsModel\getMethods(), FinderHelper\getQuery(), CaptiveModel\getRecords(), AbstractRenderer\getRenderer(), HTMLHelper\getServiceRegistry(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), UserHelper\hashPassword(), Route\link(), AbstractRenderer\loadDocument(), Form\loadField(), Joomla\CMS\MVC\Model\loadForm(), BackupcodesModel\regenerateBackupCodes(), Email\sendCode(), InstallerAdapter\setupScriptfile(), FormModel\validate(), FormField\validate(), et Credentials\verifyAttestation().

◆ getDate()

static getDate | ( | $time = 'now',
 |  | $tzOffset = null
 | ) |
static

Return the Date object

Paramètres
mixed | $time | The initial time for the Date object
mixed | $tzOffset | The timezone offset.
Renvoie
Date object
Voir également
Date
Depuis
1.7.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $date, $key, et $language.

Référencé par Response\__construct(), BannerTable\__construct(), Task\acquireLock(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addCategory(), ActionlogModel\addLog(), LinksModel\batchProcess(), User\bind(), ContactModel\buildContactExtendedData(), TagTable\check(), NewsfeedTable\check(), FilterTable\check(), CoreContent\check(), BannerTable\check(), GroupTable\check(), TaskTable\check(), FieldTable\check(), Category\check(), User\check(), Content\check(), Table\checkOut(), ResetModel\checkResetLimit(), BannerModel\click(), TemplateModel\createTemplateOverride(), HTMLHelper\date(), TasksListCommand\doExecute(), LinkModel\duplicateUrls(), Icon\edit(), Query\explained(), CalendarField\filter(), ContactTable\generateAlias(), AssociationHelper\getAssociations(), PlgSystemTasknotification\getDataFromTask(), LocalAdapter\getDate(), WorkflowModel\getForm(), CalendarField\getInput(), NewsfeedModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), TagsPopularHelper\getList(), TagsSimilarHelper\getList(), ArticlesArchiveHelper\getList(), BannersModel\getListQuery(), FeaturedModel\getListQuery(), TasksModel\getListQuery(), SearchModel\getListQuery(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), Indexer\getState(), TagsHelper\getTagItemsQuery(), TaskModel\getTask(), ArchiveModel\getYears(), BannersModel\impress(), Indexer\index(), ExecRuleHelper\nextExec(), PlgSystemActionLogs\onAfterRespond(), PlgContentPagenavigation\onContentBeforeDisplay(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ArticleModel\prepareTable(), ContactModel\prepareTable(), Query\processDates(), Query\processString(), WorkflowModel\publish(), Table\publish(), MessagesModel\purge(), RssRenderer\render(), PublishedButton\render(), AtomRenderer\render(), FeaturedButton\render(), MessageModel\save(), TaskModel\save(), WorkflowModel\setDefault(), User\setLastVisit(), ConsentTable\store(), NoteTable\store(), RequestTable\store(), ContentHistory\store(), ContactTable\store(), FilterTable\store(), LinkTable\store(), TaskTable\store(), NewsfeedTable\store(), TagTable\store(), Menu\store(), WorkflowTable\store(), CoreContent\store(), Category\store(), Content\store(), et CalendarRule\test().

◆ getDbo()

static getDbo ( )
static

Get a database object.

Returns the global DatabaseDriver object, only creating it if it doesn't already exist.

Renvoie
DatabaseDriver
Voir également
DatabaseDriver
Depuis
1.7.0
Obsolète:
5.0 Load the database service from the dependency injection container
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références Joomla\DI\getContainer(), et Symfony\Contracts\Service\has().

Référencé par AdapterInstance\__construct(), Adapter\__construct(), BaseDatabaseModel\__construct(), UCMType\__construct(), DatabaseLogger\__construct(), CMSPlugin\__construct(), Workflow\__construct(), ExtensionAdapter\_endElement(), Update\_endElement(), UserHelper\activateUser(), Helper\addContentType(), Taxonomy\addMap(), UserHelper\addUserToGroup(), Access\assetgroups(), AdministratorService\association(), Menus\association(), HTMLHelper\calendar(), ContentHelper\canDeleteState(), Category\categories(), Access\cleanAssetKey(), TagsHelper\convertPathsToNames(), NewsfeedsHelper\countItems(), ContentHelper\countRelations(), NewsfeedsHelper\countTagItems(), MailTemplate\createTemplate(), Versioning\delete(), UCMContent\delete(), MailTemplate\deleteTemplate(), HtmlView\display(), Users\editor(), PluginsHelper\elementOptions(), WorkflowStage\existing(), ContentLanguage\existing(), PluginsHelper\folderOptions(), ListHelper\genericordering(), Versioning\get(), ModulesModel\getActivePositions(), ConfigHelper\getAllComponents(), Access\getAssetId(), Access\getAssetName(), Access\getAssetRules(), FieldsHelper\getAssignedCategoriesIds(), FieldsHelper\getAssignedCategoriesTitles(), AssociationsHelper\getAssociationHtmlList(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), Associations\getAssociations(), User\getAuthorisedCategories(), Access\getAuthorisedViewLevels(), Taxonomy\getBranchTitles(), BannersHelper\getClientOptions(), Helper\getCommonWords(), DebugHelper\getComponents(), MultilangstatusHelper\getContacts(), MultilangstatusHelper\getContentlangs(), ExtensionHelper\getCoreExtensionIds(), PrivacyDashboardHelper\getData(), MultilangstatusHelper\getDefaultHomeModule(), AssociationsHelper\getEnabledExtensions(), InstallerHelper\getExtensionDownloadKey(), InstallerHelper\getExtensionGroups(), ExtensionHelper\getExtensionRecord(), InstallerHelper\getExtensionTypes(), FieldsHelper\getFieldsPluginId(), Access\getGroupsByUser(), Access\getGroupTitle(), MultilangstatusHelper\getHomes(), Table\getInstance(), InstallerScript\getInstances(), InstallerScript\getItemArray(), TagsHelper\getItemTags(), MultilangstatusHelper\getLangswitchers(), CMSHelper\getLanguageId(), StatsHelper\getList(), TagsPopularHelper\getList(), ArticlesArchiveHelper\getList(), TagsSimilarHelper\getList(), ArticlesCategoryHelper\getList(), ContenthistoryHelper\getLookupValue(), MenusHelper\getMenuLinks(), MenusHelper\getMenuTypes(), MultilangstatusHelper\getModule(), ModulesHelper\getModules(), Taxonomy\getNodeByTitle(), PrivacyStatusHelper\getNumberUrgentRequests(), WhosonlineHelper\getOnlineCount(), WhosonlineHelper\getOnlineUserNames(), ModulesHelper\getPositions(), UCMContent\getPrimaryKey(), PrivacyHelper\getPrivacyConsentPluginId(), QueryHelper\getQueryDate(), RedirectHelper\getRedirectPluginId(), PrivacyStatusHelper\getRequestFormPublished(), Multilanguage\getSiteHomePages(), Updater\getSitesWithUpdates(), Indexer\getState(), MultilangstatusHelper\getStatus(), TagsHelper\getTagIds(), TagsHelper\getTagItemsQuery(), TagsHelper\getTagNames(), Taxonomy\getTaxonomy(), MailTemplate\getTemplate(), TemplatesHelper\getTemplateOptions(), ModulesHelper\getTemplates(), TagsHelper\getTypes(), InstallerHelper\getUpdateSitesInformation(), UserHelper\getUserId(), UsersLatestHelper\getUsers(), Access\getUsersByGroup(), UsersHelper\getVisibleByGroups(), Table\isCheckedOut(), Multilanguage\isEnabled(), Access\level(), Menu\linkOptions(), UserGroupsHelper\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), UserGroupsHelper\loadAll(), LanguageHelper\loadPluginLanguage(), MenusHelper\loadXml(), FinderHelper\logSearch(), Menu\menuItems(), Menu\menus(), ContentHelper\onPrepareForm(), Category\options(), Tag\options(), QueryHelper\orderbySecondary(), Menu\ordering(), ModuleController\orderPosition(), Modules\positionList(), Access\preloadComponents(), Access\preloadPermissions(), Taxonomy\removeMaps(), Taxonomy\removeOrphanMaps(), Taxonomy\removeOrphanNodes(), PublishedButton\render(), MenusHelper\resolveAlias(), MenusController\resync(), LibraryHelper\saveParams(), TagsHelper\searchTags(), InstallerScript\setParams(), UserHelper\setUserGroups(), Taxonomy\storeNode(), TagsHelper\tagDeleteInstances(), Tag\tags(), Users\templatestyle(), Date\toSql(), UserGroupsHelper\total(), TagsHelper\unTagItem(), Updater\updateLastCheckTimestamp(), MailTemplate\updateTemplate(), User\userlist(), et ListHelper\users().

◆ getDocument()

static getDocument ( )
static

Get a document object.

Returns the global Joomla\CMS\Document\Documentobject,onlycreatingitifitdoesn'talreadyexist.@returnDocumentobject@seeDocument@since1.7.0\xrefitemdeprecated166.

Références $document.

Référencé par FormBehavior\ajaxchosen(), Tag\ajaxfield(), Bootstrap\alert(), Bootstrap\button(), Bootstrap\carousel(), Email\cloak(), Bootstrap\collapse(), Behavior\combobox(), AdministratorApplication\dispatch(), ApiApplication\dispatch(), CategoryFeedView\display(), DraggableList\draggable(), Bootstrap\dropdown(), SearchTools\form(), Behavior\formvalidator(), Select\genericlist(), FiltersField\getInput(), ModulepositionField\getInput(), CalendarField\getLayoutData(), Cache\getWorkarounds(), Behavior\highlighter(), Dropdown\init(), Bootstrap\loadCss(), WebApplication\loadDocument(), Bootstrap\modal(), Behavior\multiselect(), Bootstrap\offcanvas(), Bootstrap\popover(), PopupButton\renderButton(), Text\script(), Bootstrap\scrollspy(), Cache\setWorkarounds(), Bootstrap\startAccordion(), UiTab\startTabSet(), Bootstrap\tab(), ToolbarHelper\title(), Bootstrap\toast(), Jquery\token(), et Bootstrap\tooltip().

◆ getLanguage()

static getLanguage ( )
static

Get a language object.

Returns the global Language object, only creating it if it doesn't already exist.

Renvoie
Language object
Voir également
Language
Depuis
1.7.0
Obsolète:
5.0 Load the language service from the dependency injection container or via $app->getLanguage()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $language.

Référencé par Text\_(), LastvisitdaterangeField\__construct(), SitePathway\__construct(), JsonResponse\__construct(), UseractiveField\__construct(), RegistrationdaterangeField\__construct(), LogsdaterangeField\__construct(), SiteMenu\__construct(), Categories\__construct(), CliApplication\__construct(), Categories\_load(), ContactController\_sendEmail(), HtmlView\addToolbar(), Text\alt(), ToolbarHelper\back(), IndexerController\batch(), ContactModel\buildContactExtendedData(), Behavior\calendartranslation(), LanguageFilesCollector\collect(), SetConfigurationCommand\configureIO(), ExtensionRemoveCommand\configureIO(), FinderIndexCommand\configureIO(), Help\createUrl(), HTMLHelper\date(), InstallationApplication\debugLanguage(), HtmlView\display(), InstallerAdapter\doLoadLanguage(), Users\editor(), Query\explained(), ConsentBoxField\getAssignedArticleUrl(), ConsentBoxField\getAssignedMenuItemUrl(), AssociationHelper\getAssociations(), ComponentModel\getComponent(), DebugHelper\getComponents(), ContactComponent\getContexts(), ContentComponent\getContexts(), LanguageStringsCollector\getCount(), StatisticsModel\getData(), LanguageStringsCollector\getData(), LanguageErrorsCollector\getData(), InstalledModel\getData(), DebugHelper\getDebugActions(), MenuHelper\getDefault(), TemplateModel\getFiles(), ComponentModel\getForm(), TemplatestyleField\getGroups(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), ArticleModel\getItem(), ItemModel\getItem(), PositionsModel\getItems(), SelectModel\getItems(), SiteMenu\getItems(), ItemsModel\getItems(), TosField\getLabel(), SpacerField\getLabel(), HelpModel\getLangTag(), TinymcebuilderField\getLayoutData(), TermsField\getLayoutData(), LanguagesHelper\getList(), ArticlesArchiveHelper\getList(), BannersModel\getListQuery(), FeaturedModel\getListQuery(), SearchModel\getListQuery(), ModulesModel\getListQuery(), ModulesHelper\getModules(), ComponentsField\getOptions(), AliastagField\getOptions(), ComponentsCategoryField\getOptions(), ConfigComponentsField\getOptions(), ContenttypesField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), LanguageField\getOptions(), ContenttypeField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), ModulesModel\getPositions(), AssociationsHelper\getSupportedExtension(), ArticlesModel\getTransitions(), ModulesHelper\getTranslatedModulePosition(), MenutypesModel\getTypeOptions(), MenutypesModel\getTypeOptionsFromLayouts(), ContentComponent\getWorkflowContexts(), DatabaseModel\initialise(), ActionlogsHelper\loadActionLogPluginsLanguage(), LanguageHelper\loadComponentLanguage(), AbstractRenderer\loadDocument(), InstallationApplication\loadDocument(), Form\loadField(), ContactModel\loadFormData(), RegistrationModel\loadFormData(), CMSPlugin\loadLanguage(), WebApplication\loadLanguage(), ContenthistoryHelper\loadLanguageFiles(), ConfigHelper\loadLanguageForComponent(), FileLayout\loadLanguageSuffixes(), LanguageHelper\loadPluginLanguage(), HtmlView\loadTemplate(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), Finder\mapslist(), PlgContentPagenavigation\onContentBeforeDisplay(), ContentHelper\onPrepareForm(), PlgUserJoomla\onUserAfterSave(), TemplateAdapter\parseQueries(), Text\passSprintf(), Text\plural(), ItemsModel\populateState(), SuggestionsModel\populateState(), SearchModel\populateState(), ContentmapField\prepareLevel(), Menu\preprocess(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ModuleModel\preprocessForm(), FieldModel\preprocessForm(), Text\printf(), Text\script(), Filter\select(), MailModel\send(), JSONController\sendJsonResponse(), InstalledController\setDefault(), CalendarField\setup(), Filter\slider(), Text\sprintf(), SetupModel\storeOptions(), OutputFilter\stringURLSafe(), InstalledController\switchAdminLanguage(), InstallerModel\translate(), PluginsModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), Finder\typeslist(), et SetupModel\validateDbConnection().

◆ getMailer()

static getMailer ( )
static

Get a mailer object.

Returns the global Mail object, only creating it if it doesn't already exist.

Renvoie
Mail object
Voir également
Mail
Depuis
1.7.0

Référencé par MailTemplate\__construct(), Email\sendCode(), et ApplicationModel\sendTestMail().

◆ getSession()

static getSession ( array $options = array() )
static

Get a session object.

Returns the global Session object, only creating it if it doesn't already exist.

Paramètres
array $options An array containing session options
Renvoie
Session object
Voir également
Session
Depuis
1.7.0
Obsolète:
5.0 Load the session service from the dependency injection container or via $app->getSession()

Référencé par UserHelper\addUserToGroup(), DatabaseHelper\checkRemoteDbHost(), ConfigurationModel\createConfiguration(), DatabaseModel\createDatabase(), ConfigurationModel\generateRandUserId(), ClientHelper\getCredentials(), PrefixField\getInput(), SetupModel\getOptions(), DatabaseModel\getOptions(), ChecksModel\getOptions(), LanguagesModel\getOptions(), Indexer\getState(), ClientHelper\hasCredentials(), ConfigurationModel\resetRandUserId(), Indexer\resetState(), ClientHelper\setCredentials(), Indexer\setState(), UserHelper\setUserGroups(), SetupModel\storeOptions(), ContactController\submit(), et DatabaseHelper\validateConnectionParameters().

◆ getStream()

static getStream | ( | $usePrefix = true,
 |  | $useNetwork = true,
 |  | $userAgentSuffix = 'Joomla',
 |  | $maskUserAgent = false
 | ) |
static

Creates a new stream object with appropriate prefix

Paramètres
boolean | $usePrefix | Prefix the connections for writing
boolean | $useNetwork | Use network if available for writing; use false to disable (e.g. FTP, SCP)
string | $userAgentSuffix | String to append to user agent
boolean | $maskUserAgent | User agent masking (prefix Mozilla)
Renvoie
Stream
Voir également
Stream
Depuis
1.7.0

Références $context, $prefix, $version, elseif, ClientHelper\getCredentials(), et JPATH_ROOT.

Référencé par File\append(), Folder\copy(), File\copy(), File\move(), Folder\move(), File\upload(), et File\write().

◆ getUser()

static getUser ( $id = null )
static

Get a user object.

Returns the global User object, only creating it if it doesn't already exist.

Paramètres
integer $id The user to load - Can be an integer or string - If string, it is converted to ID automatically.
Renvoie
User object
Voir également
User
Depuis
1.7.0
Obsolète:
5.0 Load the user service from the dependency injection container or via $app->getIdentity()

Références $id, elseif, et User\getInstance().

Référencé par AbstractMenu\__get(), Categories\_load(), RegistrationModel\activate(), LinkModel\activate(), UserModel\activate(), ActionlogModel\addLog(), FormView\addToolbar(), ListView\addToolbar(), UserHelper\addUserToGroup(), Tag\ajaxfield(), AssociationsHelper\allowAdd(), TagField\allowCustom(), AssociationsHelper\allowEdit(), SiteApplication\authorise(), ItemModel\batchCopy(), ModuleModel\batchCopy(), FieldModel\batchCopy(), ArticleModel\batchMove(), ModuleModel\batchMove(), ItemModel\batchMove(), FieldModel\batchMove(), UserModel\batchReset(), UserModel\batchUser(), UserModel\block(), ContactModel\buildContactExtendedData(), Icons\button(), AssociationsHelper\canCheckinItem(), NewsfeedModel\canCreateCategory(), BannerModel\canCreateCategory(), ContactModel\canCreateCategory(), ArticleModel\canCreateCategory(), ClientModel\canDelete(), LevelModel\canDelete(), MenuModel\canDelete(), TransitionModel\canDelete(), MapsModel\canDelete(), NewsfeedModel\canDelete(), IndexModel\canDelete(), ItemModel\canDelete(), CategoryModel\canDelete(), BannerModel\canDelete(), ContactModel\canDelete(), StageModel\canDelete(), GroupModel\canDelete(), ArticleModel\canDelete(), WorkflowModel\canDelete(), AdminModel\canDelete(), FieldModel\canDelete(), FieldsHelper\canEditFieldValue(), ClientModel\canEditState(), MenuModel\canEditState(), MapsModel\canEditState(), TransitionModel\canEditState(), NewsfeedModel\canEditState(), IndexModel\canEditState(), CategoryModel\canEditState(), ItemModel\canEditState(), ContactModel\canEditState(), BannerModel\canEditState(), GroupModel\canEditState(), StageModel\canEditState(), ModuleModel\canEditState(), ArticleModel\canEditState(), WorkflowModel\canEditState(), AdminModel\canEditState(), FieldModel\canEditState(), ItemModel\canSave(), MediaHelper\canUpload(), UpdateModel\captiveLogin(), Category\categories(), GroupTable\check(), FieldTable\check(), AdminModel\checkCategoryId(), FormModel\checkin(), FormModel\checkout(), CMSApplication\checkUserRequireReset(), TemplateModel\child(), CategoryView\commonCategoryDisplay(), TagsHelper\createTagsFromField(), MessageModel\delete(), StyleModel\delete(), UpdatesitesModel\delete(), TracksModel\delete(), MenuType\delete(), OverridesModel\delete(), GroupModel\delete(), UserModel\delete(), ModuleModel\delete(), MethodsModel\deleteAll(), JsonView\display(), TextView\display(), AssociationHelper\displayAssociations(), StyleModel\duplicate(), ModuleModel\duplicate(), LinkModel\duplicateUrls(), Icon\edit(), ComponentHelper\filterText(), ContentHelper\getActions(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), CategoryNode\getAuthor(), Taxonomy\getBranchTitles(), CategoryModel\getCategory(), ConfigHelper\getComponentsWithConfig(), Joomla\CMS\User\getCurrentUser(), LocalAdapter\getDate(), UserMessagesField\getExcluded(), GroupModel\getForm(), NewsfeedModel\getForm(), ProfileModel\getForm(), UserModel\getForm(), TagModel\getForm(), ContactModel\getForm(), BannerModel\getForm(), CategoryModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), ModuleModel\getForm(), Session\getFormToken(), MenuField\getGroups(), FieldsModel\getGroups(), UserModel\getGroups(), CMSApplication\getInstance(), NewsfeedModel\getItem(), FormModel\getItem(), ArticleModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), Adapter\getItemMenuTitle(), DebuguserModel\getItems(), HistoryModel\getItems(), ArticlesModel\getItems(), TagsHelper\getItemTags(), UserField\getLayoutData(), TagsPopularHelper\getList(), ArticlesPopularHelper\getList(), LatestHelper\getList(), LanguagesHelper\getList(), TagsSimilarHelper\getList(), PopularHelper\getList(), ArticlesCategoryHelper\getList(), SuggestionsModel\getListQuery(), FeaturedModel\getListQuery(), MessagesModel\getListQuery(), GroupsModel\getListQuery(), SearchModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), ItemsModel\getMenu(), Taxonomy\getNodeByTitle(), WhosonlineHelper\getOnlineUserNames(), FieldgroupsField\getOptions(), FrontendlanguageField\getOptions(), CategoryField\getOptions(), GroupparentField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), CategoryeditField\getOptions(), UserHelper\getProfile(), MethodModel\getRenderOptions(), TagsHelper\getTagItemsQuery(), JoomlatokenField\getTokenForDisplay(), ArticlesModel\getTransitions(), LoginHelper\getType(), DebuguserModel\getUser(), AbstractMenu\getUser(), UsersLatestHelper\getUsers(), AdminModel\initBatch(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), CMSApplication\initialiseApp(), PlgSystemStats\isAllowedUser(), Links\link(), ExportModel\logExport(), ExportModel\logExportEmailed(), CMSApplication\login(), CMSApplication\logout(), RemoveModel\logRemove(), RemoveModel\logRemoveBlocked(), Menu\menuItems(), Joomla\onAfterCheckin(), Joomla\onAfterLogExport(), Joomla\onAfterLogPurge(), Joomla\onAfterPurge(), KeepaliveAssetItem\onAttachCallback(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgSystemActionLogs\onContentPrepareForm(), PlgButtonModule\onDisplay(), PlgButtonImage\onDisplay(), Joomla\onJoomlaAfterUpdate(), PlgSystemFields\onUserAfterSave(), Joomla\onUserAfterSave(), PlgUserJoomla\onUserLogout(), Category\options(), ConfigModel\populateState(), NewsfeedModel\populateState(), ArticleModel\populateState(), TagsModel\populateState(), MessageModel\populateState(), ArticlesModel\populateState(), SuggestionsModel\populateState(), FeaturedModel\populateState(), ProfileModel\populateState(), CategoryModel\populateState(), SearchModel\populateState(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ContactModel\prepareTable(), ProfileModel\preprocessForm(), Query\processDynamicTaxonomy(), Query\processStaticTaxonomy(), UpdatesitesModel\publish(), ManageModel\publish(), MessageModel\publish(), MapsModel\publish(), IndexModel\publish(), AdminModel\publish(), AdministratorApplication\purgeMessages(), UpdatesitesModel\rebuild(), RegistrationModel\register(), ManageModel\remove(), UserHelper\removeUserFromGroup(), ModulesRenderer\render(), PublishedButton\render(), FeaturedButton\render(), AdministratorApplication\render(), SiteApplication\render(), CMSApplication\render(), LevelsModel\reorder(), GroupModel\save(), ComponentModel\save(), UserModel\save(), ApplicationModel\save(), MessageModel\save(), StyleModel\save(), User\save(), LevelsModel\saveorder(), Filter\select(), MailModel\send(), ApplicationModel\sendTestMail(), StyleModel\setHome(), JoomlatokenField\setup(), UserField\setup(), UserHelper\setUserGroups(), Filter\slider(), NoteTable\store(), ContentHistory\store(), ContactTable\store(), MenuType\store(), FilterTable\store(), NewsfeedTable\store(), TagTable\store(), WorkflowTable\store(), CoreContent\store(), Category\store(), Content\store(), StyleModel\unsetHome(), Access\usergroups(), MenuModel\validate(), LevelModel\validate(), GroupModel\validate(), CategoryModel\validate(), RequestModel\validate(), ArticleModel\validate(), ModuleModel\validate(), et FieldModel\validate().

Documentation des champs

◆ $application

Joomla CMS $application = null
static

Référencé par Application\register().

◆ $cache

$cache = null
static

◆ $config

$config = null
static

Référencé par InstallationApplication\__construct().

◆ $container

$container = null
static

◆ $database

$database = null
static

Référencé par ConfigurationModel\setup().

◆ $dates

$dates = array()
static

◆ $document

$document = null
static

Référencé par AdministratorApplication\dispatch(), SiteApplication\dispatch(), InstallationApplication\dispatch(), ApiApplication\dispatch(), et InstallationApplication\loadDocument().

◆ $language

$language = null
static

Référencé par CMSApplication\initialiseApp(), AbstractRenderer\loadDocument(), InstalledController\setDefault(), et InstalledController\switchAdminLanguage().

◆ $mailer

$mailer = null
static

◆ $session

$session = null
static
La documentation de cette classe a été générée à partir des fichiers suivants :
  • src/Factory.php
  • administrator/includes/app.php
  • cli/joomla.php


Joomla CMS: Référence de la classe Version

  • Joomla
  • CMS
  • Version
Fonctions membres publiques | Champs de données | Attributs privés statiques
Référence de la classe Version

Fonctions membres publiques

isInDevelopmentState ()
isCompatible (string $minimum)
getHelpVersion ()
getShortVersion ()
getLongVersion ()
getUserAgent (string $suffix='', bool $mask=false, bool $addVersion=true)
generateMediaVersion ()
getMediaVersion ()
refreshMediaVersion ()
setMediaVersion (string $mediaVersion)

Champs de données

const | PRODUCT = 'Joomla!'
const | MAJOR_VERSION = 4
const | MINOR_VERSION = 2
const | PATCH_VERSION = 2
const | EXTRA_VERSION = ''
const | DEV_STATUS = 'Stable'
const | CODENAME = 'Uaminifu'
const | RELDATE = '2-September-2022'
const | RELTIME = '20:41'
const | RELTZ = 'GMT'
const | COPYRIGHT = '(C) 2005 Open Source Matters, Inc. <https://www.joomla.org>'
const | URL = '<a href="https://www.joomla.org">Joomla!</a> is Free Software released under the GNU General Public License.'

Attributs privés statiques

static $mediaVersion = null

Description détaillée

Version information class for the Joomla CMS.

Depuis
1.0

Documentation des fonctions membres

◆ generateMediaVersion()

generateMediaVersion ( )

Generate a media version string for assets Public to allow third party developers to use it

Renvoie
string
Depuis
3.2

Références Factory\getApplication().

◆ getHelpVersion()

getHelpVersion ( )

Method to get the help file version.

Renvoie
string Version suffix for help files.
Depuis
1.0

◆ getLongVersion()

getLongVersion ( )

Gets a version string for the current Joomla with all release information.

Renvoie
string Complete version string.
Depuis
1.5

◆ getMediaVersion()

getMediaVersion ( )

Gets a media version which is used to append to Joomla core media files.

This media version is used to append to Joomla core media in order to trick browsers into reloading the CSS and JavaScript, because they think the files are renewed. The media version is renewed after Joomla core update, install, discover_install and uninstallation.

Renvoie
string The media version.
Depuis
3.2

Références $mediaVersion, $this, et null.

◆ getShortVersion()

getShortVersion ( )

Gets a "PHP standardized" version string for the current Joomla.

Renvoie
string Version string.
Depuis
1.5

Références $version.

◆ getUserAgent()

getUserAgent | ( | string | $suffix = '',
 |  | bool | $mask = false,
 |  | bool | $addVersion = true
 | ) |  |

Returns the user agent.

Paramètres
string | $suffix | String to append to resulting user agent.
bool | $mask | Mask as Mozilla/5.0 or not.
bool | $addVersion | Add version afterwards to component.
Renvoie
string User Agent.
Depuis
1.0

Références $suffix.

◆ isCompatible()

isCompatible ( string $minimum )

Compares two a "PHP standardized" version number against the current Joomla version.

Paramètres
string $minimum The minimum version of the Joomla which is compatible.
Renvoie
boolean True if the version is compatible.

1.0

◆ isInDevelopmentState()

isInDevelopmentState ( )

Check if we are in development mode

Renvoie
boolean
Depuis
3.4.3

◆ refreshMediaVersion()

refreshMediaVersion ( )

Function to refresh the media version

Renvoie
Version Instance of $this to allow chaining.
Depuis
3.2

◆ setMediaVersion()

setMediaVersion ( string $mediaVersion )

Sets the media version which is used to append to Joomla core media files.

Paramètres
string $mediaVersion The media version.
Renvoie
Version Instance of $this to allow chaining.
Depuis
3.2

Références $mediaVersion, et $this.

Documentation des champs

◆ $mediaVersion

$mediaVersion = null
staticprivate

◆ CODENAME

const CODENAME = 'Uaminifu'

◆ COPYRIGHT

const COPYRIGHT = '(C) 2005 Open Source Matters, Inc. <https://www.joomla.org>'

◆ DEV_STATUS

const DEV_STATUS = 'Stable'

◆ EXTRA_VERSION

const EXTRA_VERSION = ''

◆ MAJOR_VERSION

const MAJOR_VERSION = 4

Référencé par HtmlView\display(), UpdateModel\getPhpOptions(), UpdateModel\isDatabaseTypeSupported(), AtomRenderer\render(), et HtmlView\shouldDisplayPreUpdateCheck().

◆ MINOR_VERSION

const MINOR_VERSION = 2

Référencé par AtomRenderer\render(), et HtmlView\shouldDisplayPreUpdateCheck().

◆ PATCH_VERSION

const PATCH_VERSION = 2

◆ PRODUCT

const PRODUCT = 'Joomla!'

Référencé par ExtensionAdapter\_endElement(), et Update\_endElement().

◆ RELDATE

const RELDATE = '2-September-2022'

◆ RELTIME

const RELTIME = '20:41'

◆ RELTZ

const RELTZ = 'GMT'

◆ URL

const URL = '<a href="https://www.joomla.org">Joomla!</a> is Free Software released under the GNU General Public License.'
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Version.php


Joomla CMS: Référence de la classe ActionlogsController

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Controller
  • ActionlogsController
Fonctions membres publiques
Référence de la classe ActionlogsController
+ Graphe d'héritage de ActionlogsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[], MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Actionlogs', $prefix='Administrator', $config=['ignore_request'=> true])
purge ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Actionlogs list controller class.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.9.0
Exceptions
Exception

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getModel()

getModel | ( |  | $name = 'Actionlogs',
 |  |  | $prefix = 'Administrator',
 |  |  | $config = ['ignore_request' =,
 |  | true] |
 | ) |  |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
3.9.0

Références $config, $name, et $prefix.

◆ purge()

purge ( )

Clean out the logs

Renvoie
void
Depuis
3.9.0

Références $message, $model, Text\_(), Route\_(), et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionlogsController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Controller
  • DisplayController
Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$default_view = 'actionlogs'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Plugins master display controller.

Depuis
4.0.0

Documentation des champs

◆ $default_view

$default_view = 'actionlogs'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_actionlogs/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe ExtensionField

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
  • ExtensionField
Fonctions membres publiques | Attributs protégés
Référence de la classe ExtensionField
+ Graphe d'héritage de ExtensionField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'extension'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to load a list of all extensions that have logged actions

Depuis
3.9.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the options to populate list

Renvoie
array The field option objects.
Depuis
3.9.0

Références $context, $db, $extension, $item, $options, $query, Text\_(), HTMLHelper\_(), Joomla\Database\getDatabase(), et ActionlogsHelper\loadTranslationFiles().

Documentation des champs

◆ $type

$type = 'extension'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionField.php


Joomla CMS: Référence de la classe LogcreatorField

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
  • LogcreatorField
Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe LogcreatorField
+ Graphe d'héritage de LogcreatorField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'LogCreator'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $options = []
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false

Description détaillée

Field to load a list of all users that have logged actions

Depuis
3.9.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the options to populate list

Renvoie
array The field option objects.
Depuis
3.9.0

Références $db, $hash, $options, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $options

$options = []
staticprotected

◆ $type

$type = 'LogCreator'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LogcreatorField.php


Joomla CMS: Référence de la classe LogsdaterangeField

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
  • LogsdaterangeField
Fonctions membres publiques | Attributs protégés
Référence de la classe LogsdaterangeField
+ Graphe d'héritage de LogsdaterangeField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__construct ($form=null)
- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'logsdaterange'
$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to show a list of range dates to sort with

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $form = null )

Method to instantiate the form field object.

Paramètres
Form $form The form to attach to the form field object.
Depuis
3.9.0

Références $form, $lang, Symfony\Contracts\Service\__construct(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= array(
'today' => 'COM_ACTIONLOGS_OPTION_RANGE_TODAY',
'past_week' => 'COM_ACTIONLOGS_OPTION_RANGE_PAST_WEEK',
'past_1month' => 'COM_ACTIONLOGS_OPTION_RANGE_PAST_1MONTH',
'past_3month' => 'COM_ACTIONLOGS_OPTION_RANGE_PAST_3MONTH',
'past_6month' => 'COM_ACTIONLOGS_OPTION_RANGE_PAST_6MONTH',
'past_year' => 'COM_ACTIONLOGS_OPTION_RANGE_PAST_YEAR',
)

◆ $type

$type = 'logsdaterange'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LogsdaterangeField.php


Joomla CMS: Référence de la classe LogtypeField

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
  • LogtypeField
Fonctions membres publiques | Attributs protégés
Référence de la classe LogtypeField
+ Graphe d'héritage de LogtypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'LogType'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to load a list of all users that have logged actions

Depuis
3.9.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.9.0

Références $db, $extension, $options, $query, Text\_(), HTMLHelper\_(), Joomla\Database\getDatabase(), ActionlogsHelper\loadTranslationFiles(), et ApplicationHelper\stringURLSafe().

Documentation des champs

◆ $type

$type = 'LogType'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LogtypeField.php


Joomla CMS: Référence de la classe PlugininfoField

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Field
  • PlugininfoField
Fonctions membres protégées | Attributs protégés
Référence de la classe PlugininfoField
+ Graphe d'héritage de PlugininfoField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'PluginInfo'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Information field.

Depuis
3.9.2

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.9.2

Références $db, $link, $query, $result, Text\_(), Route\_(), HTMLHelper\_(), Joomla\Database\getDatabase(), et Text\sprintf().

Documentation des champs

◆ $type

$type = 'PluginInfo'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PlugininfoField.php


Joomla CMS: Référence de la classe ActionlogsHelper

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Helper
  • ActionlogsHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs privés statiques
Référence de la classe ActionlogsHelper

Fonctions membres publiques statiques

static | getCsvData ($data)
static | loadTranslationFiles ($extension)
static | getLogContentTypeParams ($context)
static | getHumanReadableLogMessage ($log, $generateLinks=true)
static | getContentTypeLink ($component, $contentType, $id, $urlVar='id', $object=null)
static | loadActionLogPluginsLanguage ()

Fonctions membres protégées statiques

static escapeCsvFormula ($value)

Attributs privés statiques

static $characters = array('=', '+', '-', '@')

Description détaillée

Actionlogs component helper.

Depuis
3.9.0

Documentation des fonctions membres

◆ escapeCsvFormula()

static escapeCsvFormula ( $value )
staticprotected

Escapes potential characters that start a formula in a CSV value to prevent injection attacks

Paramètres
mixed $value csv field value
Renvoie
mixed
Depuis
3.9.7

Références $value.

◆ getContentTypeLink()

static getContentTypeLink | ( | $component,
 |  | $contentType,
 |  | $id,
 |  | $urlVar = 'id',
 |  | $object = null
 | ) |
static

Get link to an item of given content type

Paramètres
string | $component
string | $contentType
integer | $id
string | $urlVar
CMSObject | $object
Renvoie
string Link to the content item
Depuis
3.9.0

Références $component, $id, $prefix, Path\clean(), JPATH_ADMINISTRATOR, et JLoader\register().

Référencé par Joomla\onContentAfterSave(), Joomla\onContentChangeState(), et Joomla\onExtensionAfterSave().

◆ getCsvData()

static getCsvData ( $data )
static

Method to convert logs objects array to an iterable type for use with a CSV export

Paramètres
array | \Traversable $data The logs data objects to be exported
Renvoie
Generator
Depuis
3.9.0
Exceptions

Références $data, $extension, et Text\_().

◆ getHumanReadableLogMessage()

static getHumanReadableLogMessage | ( | $log,
 |  | $generateLinks = true
 | ) |
static

Get human readable log message for a User Action Log

Paramètres
\stdClass | $log | A User Action log message record
boolean | $generateLinks | Flag to disable link generation when creating a message
Renvoie
string
Depuis
3.9.0

Références $key, $message, $value, Text\_(), ENT_QUOTES, Factory\getApplication(), Route\link(), StringHelper\strpos(), Route\TLS_FORCE, et Route\TLS_IGNORE.

Référencé par ActionlogModel\sendNotificationEmails().

◆ getLogContentTypeParams()

static getLogContentTypeParams ( $context )
static

Get parameters to be

Paramètres
string $context The context of the content
Renvoie
mixed An object contains content type parameters, or null if not found
Depuis
3.9.0
Obsolète:
5.0 Use the action log config model instead

Références $context, et Factory\getApplication().

◆ loadActionLogPluginsLanguage()

static loadActionLogPluginsLanguage ( )
static

Load both enabled and disabled actionlog plugins language file.

It is used to make sure actions log is displayed properly instead of only language items displayed when a plugin is disabled.

Renvoie
void
Depuis
3.9.0

Références $db, $extension, $lang, $name, $query, $rows, $type, Factory\getDbo(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et JPATH_PLUGINS.

◆ loadTranslationFiles()

static loadTranslationFiles ( $extension )
static

Load the translation files for an extension

Paramètres
string $extension Extension name
Renvoie
void
Depuis
3.9.0

Références $extension, $lang, $parts, Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_BASE, JPATH_LIBRARIES, JPATH_PLUGINS, et JPATH_SITE.

Référencé par ExtensionField\getOptions(), LogtypeField\getOptions(), et ActionlogModel\sendNotificationEmails().

Documentation des champs

◆ $characters

$characters = array('=', '+', '-', '@')
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionlogsHelper.php


Joomla CMS: Référence de la classe ActionlogConfigModel

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Model
  • ActionlogConfigModel
Fonctions membres publiques
Référence de la classe ActionlogConfigModel
+ Graphe d'héritage de ActionlogConfigModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getLogContentTypeParams (string $context)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model to interact with the action log configuration.

Depuis
4.2.0

Documentation des fonctions membres

◆ getLogContentTypeParams()

getLogContentTypeParams ( string $context )

Returns the action logs config for the given context.

Paramètres
string $context The context of the content
Renvoie
stdClass|null An object contains content type parameters, or null if not found
Depuis
4.2.0

Références $context, $db, $query, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionlogConfigModel.php


Joomla CMS: Référence de la classe ActionlogModel

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Model
  • ActionlogModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ActionlogModel
+ Graphe d'héritage de ActionlogModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

addLog ($messages, $messageLanguageKey, $context, $userId=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

sendNotificationEmails ($messages, $username, $context)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of Actionlog records.

Depuis
3.9.0

Documentation des fonctions membres

◆ addLog()

addLog | ( | $messages,
 |  | $messageLanguageKey,
 |  | $context,
 |  | $userId = null
 | ) |

Function to add logs to the database This method adds a record to #__action_logs contains (message_language_key, message, date, context, user)

Paramètres
array | $messages | The contents of the messages to be logged
string | $messageLanguageKey | The language key of the message
string | $context | The context of the content passed to the plugin
integer | $userId | ID of user perform the action, usually ID of current logged in user
Renvoie
void
Depuis
3.9.0

Références $context, $date, $db, $message, $messages, $params, $user, $userId, ComponentHelper\getComponent(), Joomla\Database\getDatabase(), Factory\getDate(), IpHelper\getIp(), et Factory\getUser().

◆ sendNotificationEmails()

sendNotificationEmails | ( | $messages,
 |  | $username,
 |  | $context
 | ) |
protected

Send notification emails about the action log

Paramètres
array | $messages | The logged messages
string | $username | The username
string | $context | The Context
Renvoie
void
Depuis
3.9.0
Exceptions
MailDisabledException | if mail is disabled
phpmailerException | if sending mail failed

Références $app, $context, $db, $extension, $lang, $message, $messages, $query, $temp, $user, Text\_(), HTMLHelper\_(), MailTemplate\addTemplateData(), Factory\getApplication(), Joomla\Database\getDatabase(), ActionlogsHelper\getHumanReadableLogMessage(), JPATH_ADMINISTRATOR, et ActionlogsHelper\loadTranslationFiles().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionlogModel.php


Joomla CMS: Référence de la classe ActionlogsModel

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Model
  • ActionlogsModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ActionlogsModel
+ Graphe d'héritage de ActionlogsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getLogsForItem ($extension, $itemId)
getLogsData ($pks=null)
getLogDataAsIterator ($pks=null)
delete (&$pks)
purge ()
getFilterForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.id', $direction='desc')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

buildDateRange ($range)
getLogDataQuery ($pks=null)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of article records.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
3.9.0
Exceptions
Exception

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ buildDateRange()

buildDateRange ( $range )
private

Construct the date range to filter on.

Paramètres
string $range The textual range to construct the filter for.
Renvoie
array The date range to filter on.
Depuis
3.9.0
Exceptions
Exception

Références Joomla\Database\Query\$offset, $range, et Factory\getApplication().

◆ delete()

delete ( & $pks )

Delete logs

Paramètres
array $pks Primary keys of logs
Renvoie
boolean
Depuis
3.9.0

Références $db, $query, Factory\getApplication(), Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
Form|boolean The Form object or false on error
Depuis
3.9.0

Références $data, $field, $form, $params, Text\_(), et ComponentHelper\getParams().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery
Depuis
3.9.0
Exceptions
Exception

Références $date, $db, $extension, $query, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getLogDataAsIterator()

getLogDataAsIterator ( $pks = null )

Get logs data as a database iterator

Paramètres
integer[]|null $pks An optional array of log record IDs to load
Renvoie
DatabaseIterator
Depuis
3.9.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getLogDataQuery()

getLogDataQuery ( $pks = null )
private

Get the query for loading logs data

Paramètres
integer[]|null $pks An optional array of log record IDs to load
Renvoie
DatabaseQuery
Depuis
3.9.0

Références $db, $query, Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ getLogsData()

getLogsData ( $pks = null )

Get logs data into Table object

Paramètres
integer[]|null $pks An optional array of log record IDs to load
Renvoie
array All logs in the table
Depuis
3.9.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getLogsForItem()

getLogsForItem | ( | $extension,
 |  | $itemId
 | ) |

Get all log entries for an item

Paramètres
string | $extension | The extension the item belongs to
integer | $itemId | The item ID
Renvoie
array
Depuis
3.9.0

Références $db, $extension, $itemId, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ populateState()

populateState | ( | $ordering = 'a.id',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.9.0
Exceptions
Exception

Références $direction, $ordering, et Joomla\CMS\MVC\Model\populateState().

◆ purge()

purge ( )

Removes all of logs from the table.

Renvoie
boolean result of operation
Depuis
3.9.0

Références Factory\getApplication(), et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionlogsModel.php


Joomla CMS: Référence de la classe ActionLogPlugin

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • Plugin
  • ActionLogPlugin
Attributs protégés
Référence de la classe ActionLogPlugin
+ Graphe d'héritage de ActionLogPlugin:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface Joomla

Attributs protégés

$app
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Abstract Action Log Plugin

Depuis
3.9.0

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ActionLogPlugin.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Actionlogs
  • Administrator
  • View
  • Actionlogs
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$state
$pagination
$showIpColumn = false
$dateRelative = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

View class for a list of logs.

Depuis
3.9.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.9.0

Références Text\_(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $dateRelative

$dateRelative = false
protected

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $showIpColumn

$showIpColumn = false
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_actionlogs/src/View/Actionlogs/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Admin
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Admin Controller

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

View method

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticSupportschaining.@since3.9

Références $format, et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Admin
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_admin

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

com_admin does not require check permission, so we override checkAccess method and have it empty

Renvoie
void
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AdminComponent

  • Joomla
  • Component
  • Admin
  • Administrator
  • Extension
  • AdminComponent
Fonctions membres publiques
Référence de la classe AdminComponent
+ Graphe d'héritage de AdminComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_admin

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AdminComponent.php


Joomla CMS: Référence de la classe HelpModel

  • Joomla
  • Component
  • Admin
  • Administrator
  • Model
  • HelpModel
Fonctions membres publiques | Attributs protégés
Référence de la classe HelpModel
+ Graphe d'héritage de HelpModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

& getHelpSearch ()
& getPage ()
getLangTag ()
& getToc ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$help_search = null
$page = null
$lang_tag = null
$toc = null
$latest_version_check = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Admin Component Help Model

Depuis
1.6

Documentation des fonctions membres

◆ getHelpSearch()

& getHelpSearch ( )

Method to get the help search string

Renvoie
string Help search string
Depuis
1.6

Références Factory\getApplication().

◆ getLangTag()

getLangTag ( )

Method to get the lang tag

Renvoie
string lang iso tag
Depuis
1.6

Références Factory\getLanguage(), et JPATH_BASE.

◆ getPage()

& getPage ( )

Method to get the page

Renvoie
string The page
Depuis
1.6

Références Help\createUrl(), et Factory\getApplication().

◆ getToc()

& getToc ( )

Method to get the table of contents

Renvoie
array Table of contents

Références $buffer, $data, $key, $title, $value, Text\_(), Folder\files(), JPATH_BASE, StringHelper\strpos(), et StringHelper\strtolower().

Documentation des champs

◆ $help_search

$help_search = null
protected

◆ $lang_tag

$lang_tag = null
protected

◆ $latest_version_check

$latest_version_check = null
protected

◆ $page

$page = null
protected

◆ $toc

$toc = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • HelpModel.php


Joomla CMS: Référence de la classe SysinfoModel

  • Joomla
  • Component
  • Admin
  • Administrator
  • Model
  • SysinfoModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe SysinfoModel
+ Graphe d'héritage de SysinfoModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

& getPhpSettings ()
& getConfig ()
& getInfo ()
phpinfoEnabled ()
getSafeData (string $dataType, bool $public=true)
& getPHPInfo ()
getPhpInfoArray ()
getExtensions ()
getDirectory (bool $public=false)
& getEditor ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

cleanPrivateData (array $dataArray, string $dataType='other')
cleanSectionPrivateData ($sectionValues)
parsePhpInfo (string $html)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$php_settings = []
$config = []
$info = []
$php_info = null
$phpInfoArray
$privateSettings
$safeData
$directories = []
$editor = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

addDirectory (string $name, string $path, string $message='')

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for the display of system information.

Depuis
1.6

Documentation des fonctions membres

◆ addDirectory()

addDirectory | ( | string | $name,
 |  | string | $path,
 |  | string | $message = ''
 | ) |  |
private

Method to add a directory

Paramètres
string | $name | Directory Name
string | $path | Directory path
string | $message | Message
Renvoie
void
Depuis
1.6

Références $message, $name, et $path.

◆ cleanPrivateData()

cleanPrivateData | ( | array | $dataArray,
 |  | string | $dataType = 'other'
 | ) |  |
protected

Remove sections of data marked as private in the privateSettings

Paramètres
array | $dataArray | Array with data that may contain private information
string | $dataType | Type of data to search for a specific section in the privateSettings array
Renvoie
array
Depuis
3.5

Références $section.

◆ cleanSectionPrivateData()

cleanSectionPrivateData ( $sectionValues )
protected

Obfuscate section values

Paramètres
mixed $sectionValues Section data
Renvoie
string|array
Depuis
3.5

Références $value, et JPATH_ROOT.

◆ getConfig()

& getConfig ( )

Method to get the config

Renvoie
array config values
Depuis
1.6

Références $config, et $key.

◆ getDirectory()

getDirectory ( bool $public = false )

Method to get the directory states

Paramètres
bool $public If true no information is going to be removed
Renvoie
array States of directories
Exceptions

Références $cparams, $folder, Factory\getApplication(), ComponentHelper\getParams(), JPATH_ADMINISTRATOR, JPATH_CACHE, JPATH_CONFIGURATION, JPATH_LIBRARIES, JPATH_PLUGINS, JPATH_ROOT, JPATH_SITE, et JPATH_THEMES.

◆ getEditor()

& getEditor ( )

Method to get the editor

Renvoie
string The default editor
Note
Has to be removed (it is present in the config...)
Depuis
1.6

Références $editor, et Factory\getApplication().

◆ getExtensions()

getExtensions ( )

Method to get a list of installed extensions

Renvoie
array installed extensions
Depuis
3.5

Références $db, $extension, $manifest, $query, Text\_(), Log\add(), Factory\getApplication(), Factory\getContainer(), Text\sprintf(), et Log\WARNING.

◆ getInfo()

& getInfo ( )

Method to get the system information

Renvoie
array System information values
Depuis
1.6

Références $db, $info, et Joomla\Database\getDatabase().

◆ getPHPInfo()

& getPHPInfo ( )

Method to get the PHP info

Renvoie
string PHP info
Depuis
1.6

Références $output, et Text\_().

◆ getPhpInfoArray()

getPhpInfoArray ( )

Get phpinfo() output as array

Renvoie
array
Depuis
3.5

Références null.

◆ getPhpSettings()

& getPhpSettings ( )

Method to get the PHP settings

Renvoie
array Some PHP settings
Depuis
1.6

◆ getSafeData()

getSafeData | ( | string | $dataType,
 |  | bool | $public = true
 | ) |  |

Method to get filter data from the model

Paramètres
string | $dataType | Type of data to get safely
bool | $public | If true no sensitive information will be removed
Renvoie
array
Depuis
3.5

Références $data, $methodName, et $this.

◆ parsePhpInfo()

parsePhpInfo ( string $html )
protected

Parse phpinfo output into an array Source https://gist.github.com/sbmzhcn/6255314

Paramètres
string $html Output of phpinfo()
Renvoie
array
Depuis
3.5

Références $count, $html, $i, $name, $r, $val, et elseif.

◆ phpinfoEnabled()

phpinfoEnabled ( )

Check if the phpinfo function is enabled

Renvoie
boolean True if enabled
Depuis
3.4.1

Documentation des champs

◆ $config

$config = []
protected

◆ $directories

$directories = []
protected

◆ $editor

$editor = null
protected

◆ $info

$info = []
protected

◆ $php_info

$php_info = null
protected

◆ $php_settings

$php_settings = []
protected

◆ $phpInfoArray

$phpInfoArray
protected

◆ $privateSettings

$privateSettings
protected

◆ $safeData

$safeData
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SysinfoModel.php


Joomla CMS: Référence de la classe Configuration

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
  • HTML
  • Configuration
Fonctions membres publiques
Référence de la classe Configuration

Fonctions membres publiques

value ($value)

Description détaillée

Class for rendering configuration values

Depuis
4.0.0

Documentation des fonctions membres

◆ value()

value ( $value )

Method to generate a string for a value

Paramètres
mixed $value The configuration value
Renvoie
string Formatted and escaped string
Depuis
4.0.0

Références $value, et ENT_QUOTES.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/Service/HTML/Configuration.php


Joomla CMS: Référence de la classe Directory

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
  • HTML
  • Directory
Fonctions membres publiques
Référence de la classe Directory

Fonctions membres publiques

writable ($writable)
message ($dir, $message, $visible=true)

Description détaillée

Utility class working with directory

Depuis
1.6

Documentation des fonctions membres

◆ message()

message | ( | $dir,
 |  | $message,
 |  | $visible = true
 | ) |

Method to generate a message for a directory

Paramètres
string | $dir | the directory
boolean | $message | the message
boolean | $visible | is the $dir visible?
Renvoie
string html code

Références $dir, $message, $output, et Text\_().

◆ writable()

writable ( $writable )

Method to generate a (un)writable message for directory

Paramètres
boolean $writable is the directory writable?
Renvoie
string html code

Références Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Directory.php


Joomla CMS: Référence de la classe PhpSetting

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
  • HTML
  • PhpSetting
Fonctions membres publiques
Référence de la classe PhpSetting

Fonctions membres publiques

boolean ($val)
set ($val)
string ($val)

Description détaillée

Utility class working with phpsetting

Depuis
1.6

Documentation des fonctions membres

◆ boolean()

boolean ( $val )

Method to generate a boolean message for a value

Paramètres
boolean $val is the value set?
Renvoie
string html code

Références $val, et Text\_().

◆ set()

set ( $val )

Method to generate a boolean message for a value

Paramètres
boolean $val is the value set?
Renvoie
string html code

Références $val, et Text\_().

◆ string()

string ( $val )

Method to generate a string message for a value

Paramètres
string $val a php ini value
Renvoie
string html code

Références $val, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpSetting.php


Joomla CMS: Référence de la classe System

  • Joomla
  • Component
  • Admin
  • Administrator
  • Service
  • HTML
  • System
Fonctions membres publiques
Référence de la classe System

Fonctions membres publiques

server ($val)

Description détaillée

Utility class working with system

Depuis
1.6

Documentation des fonctions membres

◆ server()

server ( $val )

Method to generate a string message for a value

Paramètres
string $val a php ini value
Renvoie
string html code

Références $val, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • System.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Help
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$helpSearch = null
$page = null
$languageTag = null
$toc = []
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Admin component

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Setup the Toolbar

Renvoie
void
Depuis
1.6

Références Text\_(), et ToolbarHelper\title().

Documentation des champs

◆ $helpSearch

$helpSearch = null
protected

◆ $languageTag

$languageTag = null
protected

◆ $page

$page = null
protected

◆ $toc

$toc = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/View/Help/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Sysinfo
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$phpSettings = []
$config = []
$info = []
$phpInfo = null
$directory = []
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

Sysinfo View class for the Admin component

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Setup the Toolbar

Renvoie
void
Depuis
1.6

Références Text\_(), Route\_(), Session\getFormToken(), ToolbarHelper\help(), ToolbarHelper\link(), et ToolbarHelper\title().

Documentation des champs

◆ $config

$config = []
protected

◆ $directory

$directory = []
protected

◆ $info

$info = []
protected

◆ $phpInfo

$phpInfo = null
protected

◆ $phpSettings

$phpSettings = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/View/Sysinfo/HtmlView.php


Joomla CMS: Référence de la classe JsonView

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Sysinfo
  • JsonView
Fonctions membres publiques
Référence de la classe JsonView
+ Graphe d'héritage de JsonView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Sysinfo View class for the Admin component

Depuis
3.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.5
Exceptions
Exception

Implémente ViewInterface.

Références $data, Text\_(), Factory\getApplication(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_admin/src/View/Sysinfo/JsonView.php


Joomla CMS: Référence de la classe TextView

  • Joomla
  • Component
  • Admin
  • Administrator
  • View
  • Sysinfo
  • TextView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TextView
+ Graphe d'héritage de TextView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

renderSection (string $sectionName, array $sectionData, int $level=0)
renderDirectories (string $sectionName, array $sectionData, int $level=-1)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Sysinfo View class for the Admin component

Depuis
3.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.
Depuis
3.5
Exceptions
Exception

Implémente ViewInterface.

Références $data, $section, $this, Text\_(), Factory\getApplication(), Factory\getUser(), et JPATH_ROOT.

◆ renderDirectories()

renderDirectories | ( | string | $sectionName,
 |  | array | $sectionData,
 |  | int | $level = -1
 | ) |  |
protected

Specific rendering for directories

Paramètres
string | $sectionName | Name of the section
array | $sectionData | Directories information
integer | $level | Starting level
Renvoie
string
Depuis
3.5

Références $data.

◆ renderSection()

renderSection | ( | string | $sectionName,
 |  | array | $sectionData,
 |  | int | $level = 0
 | ) |  |
protected

Render a section

Paramètres
string | $sectionName | Name of the section to render
array | $sectionData | Data of the section to render
integer | $level | Depth level for indentation
Renvoie
string
Depuis
3.5

Références $margin, $name, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TextView.php


Joomla CMS: Référence de la classe AssociationController

  • Joomla
  • Component
  • Associations
  • Administrator
  • Controller
  • AssociationController
Fonctions membres publiques
Référence de la classe AssociationController
+ Graphe d'héritage de AssociationController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

edit ($key=null, $urlVar=null)
cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Association edit controller class.

Depuis
3.7.0

Documentation des fonctions membres

◆ cancel()

cancel ( $key = null )

Method for canceling the edit action

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
void
Depuis
3.7.0

Références $id, $key, Route\_(), Joomla\Application\checkToken(), AssociationsHelper\getItem(), et AssociationsHelper\typeSupportsCheckout().

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to edit an existing record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
FormController|boolean True if access level check and checkout passes, false otherwise.
Depuis
3.7.0

Références $id, Text\_(), Route\_(), et AssociationsHelper\allowEdit().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationController.php


Joomla CMS: Référence de la classe AssociationsController

  • Joomla
  • Component
  • Associations
  • Administrator
  • Controller
  • AssociationsController
Fonctions membres publiques | Attributs protégés
Référence de la classe AssociationsController
+ Graphe d'héritage de AssociationsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Associations', $prefix='Administrator', $config=array('ignore_request'=> true))
purge ()
clean ()
checkin ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$view_list = 'associations'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Associations controller class.

Depuis
3.7.0

Documentation des fonctions membres

◆ checkin()

checkin ( )

Method to check in an item from the association item overview.

Renvoie
void
Depuis
3.7.1

Références $extension, $id, $item, Text\_(), Route\_(), AssociationsHelper\canCheckinItem(), AssociationsHelper\getItem(), AssociationsHelper\getSupportedExtension(), et AssociationsHelper\typeSupportsCheckout().

◆ clean()

clean ( )

Method to delete the orphans from the associations table.

Renvoie
void
Depuis
3.7.0

Références Route\_(), et Joomla\Application\checkToken().

◆ getModel()

getModel | ( | $name = 'Associations',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
|boolean
Depuis
3.7.0

Références $config, $name, et $prefix.

◆ purge()

purge ( )

Method to purge the associations table.

Renvoie
void
Depuis
3.7.0

Références Route\_(), et Joomla\Application\checkToken().

Documentation des champs

◆ $view_list

$view_list = 'associations'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationsController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Associations
  • Administrator
  • Controller
  • DisplayController
Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$default_view = 'associations'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
3.7.0

Documentation des champs

◆ $default_view

$default_view = 'associations'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_associations/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Associations
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_associations

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void
Exceptions

Références AssociationsHelper\hasSupport(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_associations/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AssociationField

  • Joomla
  • Component
  • Associations
  • Administrator
  • Field
  • Modal
  • AssociationField
Fonctions membres protégées | Attributs protégés
Référence de la classe AssociationField
+ Graphe d'héritage de AssociationField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Association'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal item picker.

Depuis
3.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.7.0

Références $doc, $html, $id, $value, $wa, Text\_(), HTMLHelper\_(), Factory\getApplication(), Session\getFormToken(), name, et value.

Documentation des champs

◆ $type

$type = 'Modal_Association'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationField.php


Joomla CMS: Référence de la classe ItemlanguageField

  • Joomla
  • Component
  • Associations
  • Administrator
  • Field
  • ItemlanguageField
Fonctions membres protégées | Attributs protégés
Référence de la classe ItemlanguageField
+ Graphe d'héritage de ItemlanguageField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Itemlanguage'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field listing item languages

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.7.0

Références $canCreate, $canEdit, $helper, $input, $itemId, $language, $options, AssociationsHelper\allowAdd(), AssociationsHelper\allowEdit(), AssociationsHelper\canCheckinItem(), ArrayHelper\fromObject(), Factory\getApplication(), AssociationsHelper\getAssociationList(), AssociationsHelper\getExtensionHelper(), et AssociationsHelper\getItem().

Documentation des champs

◆ $type

$type = 'Itemlanguage'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ItemlanguageField.php


Joomla CMS: Référence de la classe ItemtypeField

  • Joomla
  • Component
  • Associations
  • Administrator
  • Field
  • ItemtypeField
Fonctions membres protégées | Attributs protégés
Référence de la classe ItemtypeField
+ Graphe d'héritage de ItemtypeField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Itemtype'
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

A drop down containing all component item types that implement associations.

Depuis
3.7.0

Documentation des fonctions membres

◆ getGroups()

getGroups ( )
protected

Method to get the field input markup.

Renvoie
array The field option objects as a nested array in groups.
Depuis
3.7.0
Exceptions

Références $context, $extension, $options, $type, HTMLHelper\_(), et AssociationsHelper\getSupportedExtensions().

Documentation des champs

◆ $type

$type = 'Itemtype'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ItemtypeField.php


Joomla CMS: Référence de la classe AssociationsHelper

  • Joomla
  • Component
  • Associations
  • Administrator
  • Helper
  • AssociationsHelper
Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres privées statiques
Référence de la classe AssociationsHelper
+ Graphe d'héritage de AssociationsHelper:
ContentHelper

Fonctions membres publiques statiques

static | getAssociationList ($extensionName, $typeName, $itemId)
static | getExtensionHelper ($extensionName)
static | getItem ($extensionName, $typeName, $itemId)
static | hasSupport ($extensionName)
static | getAssociationHtmlList ($extensionName, $typeName, $itemId, $itemLanguage, $addLink=true, $assocLanguages=true)
static | getSupportedExtensions ()
static | getSupportedExtension ($extensionName)
static | getContentLanguages ()
static | allowEdit ($extensionName, $typeName, $itemId)
static | allowAdd ($extensionName, $typeName)
static | isCheckoutItem ($extensionName, $typeName, $itemId)
static | canCheckinItem ($extensionName, $typeName, $itemId)
static | typeSupportsCheckout ($extensionName, $typeName)
static | getTypeFieldName ($extensionName, $typeName, $fieldName)
static | getLanguagefilterPluginId ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Attributs publics statiques

static | $extensionsSupport = null
static | $supportedExtensionsList = array()

Fonctions membres privées statiques

static | loadHelper ($extensionName)
static | getExtensionHelperClassName ($extensionName)
static | getExtensionRealName ($extensionName)
static | getEnabledExtensions ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Associations component helper.

Depuis
3.7.0

Documentation des fonctions membres

◆ allowAdd()

static allowAdd | ( | $extensionName,
 |  | $typeName
 | ) |
static

Check if user is allowed to create items.

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
Renvoie
boolean True on allowed.
Depuis
3.7.0

Références $helper, et Factory\getUser().

Référencé par ItemlanguageField\getOptions().

◆ allowEdit()

static allowEdit | ( | $extensionName,
 |  | $typeName,
 |  | $itemId
 | ) |
static

Get the associated items for an item

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
boolean
Depuis
3.7.0

Références $helper, $itemId, et Factory\getUser().

Référencé par AssociationController\edit(), et ItemlanguageField\getOptions().

◆ canCheckinItem()

static canCheckinItem | ( | $extensionName,
 |  | $typeName,
 |  | $itemId
 | ) |
static

Check if user can checkin an item.

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
boolean True on allowed.
Depuis
3.7.0

Références $helper, $item, $itemId, $userId, et Factory\getUser().

Référencé par AssociationsController\checkin(), et ItemlanguageField\getOptions().

◆ getAssociationHtmlList()

static getAssociationHtmlList | ( | $extensionName,
 |  | $typeName,
 |  | $itemId,
 |  | $itemLanguage,
 |  | $addLink = true,
 |  | $assocLanguages = true
 | ) |
static

Get the associated language edit links Html.

Paramètres
string | $extensionName | Extension Name
string | $typeName | ItemType
integer | $itemId | Item id.
string | $itemLanguage | Item language code.
boolean | $addLink | True for adding edit links. False for just text.
boolean | $assocLanguages | True for showing non associated content languages. False only languages with associations.
Renvoie
string The language HTML
Depuis
3.7.0

Références $canCreate, $classes, $content_languages, $db, $item, $itemId, $items, $labelClass, $language, $languages, $options, $query, $target, $text, $title, $tooltip, $url, Text\_(), Route\_(), elseif, ENT_QUOTES, Factory\getApplication(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), et Text\sprintf().

◆ getAssociationList()

static getAssociationList | ( | $extensionName,
 |  | $typeName,
 |  | $itemId
 | ) |
static

Get the associated items for an item

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $helper, et $itemId.

Référencé par ItemlanguageField\getOptions().

◆ getContentLanguages()

static getContentLanguages ( )
static

Get all the content languages.

Renvoie
array Array of objects all content languages by language code.
Depuis
3.7.0

◆ getEnabledExtensions()

static getEnabledExtensions ( )
staticprivate

Get all installed and enabled extensions

Renvoie
mixed
Depuis
3.7.0

Références $db, $query, et Factory\getDbo().

◆ getExtensionHelper()

static getExtensionHelper ( $extensionName )
static

Get the the instance of the extension helper class

Paramètres
string $extensionName The extension name with com_
Renvoie
|null
Depuis
3.7.0

Références null.

Référencé par HtmlView\addToolbar(), et ItemlanguageField\getOptions().

◆ getExtensionHelperClassName()

static getExtensionHelperClassName ( $extensionName )
staticprivate

Get the extension specific helper class name

Paramètres
string $extensionName The extension name with com_
Renvoie
string
Depuis
3.7.0

◆ getExtensionRealName()

static getExtensionRealName ( $extensionName )
staticprivate

Get the real extension name. This means without com_

Paramètres
string $extensionName The extension name with com_
Renvoie
string
Depuis
3.7.0

◆ getItem()

static getItem | ( | $extensionName,
 |  | $typeName,
 |  | $itemId
 | ) |
static

Get item information

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
|null
Depuis
3.7.0

Références $helper, $itemId, et null.

Référencé par AssociationController\cancel(), AssociationsController\checkin(), et ItemlanguageField\getOptions().

◆ getLanguagefilterPluginId()

static getLanguagefilterPluginId ( )
static

Gets the language filter system plugin extension id.

Renvoie
integer The language filter system plugin extension id.
Depuis
3.7.2

Références $db, $query, $result, Factory\getApplication(), et Joomla\CMS\MVC\Model\getDbo().

Référencé par HtmlView\display().

◆ getSupportedExtension()

static getSupportedExtension ( $extensionName )
static

Get item context based on the item key.

Paramètres
string $extensionName The extension identifier.
Renvoie
The item properties.
Depuis
3.7.0

Références $context, $helper, $lang, $result, $title, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et null.

Référencé par AssociationsController\checkin(), HtmlView\display(), et AssociationsModel\getListQuery().

◆ getSupportedExtensions()

static getSupportedExtensions ( )
static

Get all extensions with associations support.

Renvoie
array The extensions.
Depuis
3.7.0

Références $extension.

Référencé par ItemtypeField\getGroups().

◆ getTypeFieldName()

static getTypeFieldName | ( | $extensionName,
 |  | $typeName,
 |  | $fieldName
 | ) |
static

Get a table field name for a type

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
string | $fieldName | The item type
Renvoie
boolean True on allowed.
Depuis
3.7.0

Références $helper.

◆ hasSupport()

static hasSupport ( $extensionName )
static

Check if extension supports associations

Paramètres
string $extensionName The extension name with com_
Renvoie
boolean
Depuis
3.7.0

Référencé par Dispatcher\checkAccess().

◆ isCheckoutItem()

static isCheckoutItem | ( | $extensionName,
 |  | $typeName,
 |  | $itemId
 | ) |
static

Check if an item is checked out

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
int | $itemId | The id of item for which we need the associated items
Renvoie
boolean True if item is checked out.
Depuis
3.7.0

Références $helper, $item, et $itemId.

◆ loadHelper()

static loadHelper ( $extensionName )
staticprivate

Loads the helper for the given class.

Paramètres
string $extensionName The extension name with com_
Renvoie
AssociationExtensionInterface|null
Depuis
4.0.0

Références $component, Factory\getApplication(), JPATH_ADMINISTRATOR, et null.

◆ typeSupportsCheckout()

static typeSupportsCheckout | ( | $extensionName,
 |  | $typeName
 | ) |
static

Check if the type supports checkout

Paramètres
string | $extensionName | The extension name with com_
string | $typeName | The item type
Renvoie
boolean True on allowed.
Depuis
3.7.0

Références $helper.

Référencé par AssociationController\cancel(), et AssociationsController\checkin().

Documentation des champs

◆ $extensionsSupport

$extensionsSupport = null
static

◆ $supportedExtensionsList

$supportedExtensionsList = array()
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_associations/src/Helper/AssociationsHelper.php


Joomla CMS: Référence de la classe AssociationModel

  • Joomla
  • Component
  • Associations
  • Administrator
  • Model
  • AssociationModel
Fonctions membres publiques
Référence de la classe AssociationModel
+ Graphe d'héritage de AssociationModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of article records.

Depuis
3.7.0

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
3.7.0

Références $form, et Joomla\CMS\MVC\Model\loadForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationModel.php


Joomla CMS: Référence de la classe AssociationsModel

  • Joomla
  • Component
  • Associations
  • Administrator
  • Model
  • AssociationsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe AssociationsModel
+ Graphe d'héritage de AssociationsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
purge ($context='', $key='')
clean ($context='', $key='')
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='ordering', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of article records.

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.7

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ clean()

clean | ( | $context = '',
 |  | $key = ''
 | ) |

Delete orphans from the #__associations table.

Paramètres
string | $context | The associations context. Empty for all.
string | $key | The associations key. Empty for all.
Renvoie
boolean True on success
Depuis
3.7.0

Références $app, $context, $count, $db, $key, $query, $value, Text\_(), Factory\getApplication(), et Joomla\Database\getDatabase().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
|boolean
Depuis
3.7.0

Références $db, $extension, $fields, $groups, $key, $language, $menutype, $query, $section, $state, $type, $user, elseif, Joomla\Database\getDatabase(), Table\getInstance(), Joomla\CMS\MVC\Model\getState(), AssociationsHelper\getSupportedExtension(), Factory\getUser(), ParameterType\INTEGER, et null.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
3.7.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'ordering',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.7.0

Références $app, $direction, $layout, $ordering, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ purge()

purge | ( | $context = '',
 |  | $key = ''
 | ) |

Delete associations from #__associations table.

Paramètres
string | $context | The associations context. Empty for all.
string | $key | The associations key. Empty for all.
Renvoie
boolean True on success.
Depuis
3.7.0

Références $app, $context, $db, $key, $query, Text\_(), Factory\getApplication(), et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AssociationsModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Associations
  • Administrator
  • View
  • Association
  • HtmlView
Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items = []
$pagination
$state
$itemType
$app
$referenceId = 0
$typeName = ''
$referenceLanguage = ''
$referenceTitle = ''
$referenceTitleValue = ''
$editUri = ''
$targetId = ''
$targetLanguage = ''
$defaultTargetSrc = ''
$targetAction = ''
$targetTitle = ''
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$save2copy = false
$type
$typeSupports = []
$extensionName = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

View class for a list of articles.

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.7.0
Exceptions

Références $helper, $title, Text\_(), ToolbarHelper\cancel(), ToolbarHelper\custom(), AssociationsHelper\getExtensionHelper(), Toolbar\getInstance(), ToolbarHelper\help(), Text\sprintf(), et ToolbarHelper\title().

Documentation des champs

◆ $app

$app
protected

◆ $defaultTargetSrc

$defaultTargetSrc = ''
protected

◆ $editUri

$editUri = ''
protected

◆ $extensionName

$extensionName = ''
private

◆ $form

$form
protected

◆ $items

$items = []
protected

◆ $itemType

$itemType
protected

◆ $pagination

$pagination
protected

◆ $referenceId

$referenceId = 0
protected

◆ $referenceLanguage

$referenceLanguage = ''
protected

◆ $referenceTitle

$referenceTitle = ''
protected

◆ $referenceTitleValue

$referenceTitleValue = ''
protected

◆ $save2copy

$save2copy = false
private

◆ $state

$state
protected

◆ $targetAction

$targetAction = ''
protected

◆ $targetId

$targetId = ''
protected

◆ $targetLanguage

$targetLanguage = ''
protected

◆ $targetTitle

$targetTitle = ''
protected

◆ $type

$type
private

◆ $typeName

$typeName = ''
protected

◆ $typeSupports

$typeSupports = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_associations/src/View/Association/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Associations
  • Administrator
  • View
  • Associations
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$itemType = null
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of articles.

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.7.0

Références $helper, $title, $user, Text\_(), ToolbarHelper\custom(), Joomla\CMS\User\getCurrentUser(), AssociationsHelper\getExtensionHelper(), ToolbarHelper\help(), ToolbarHelper\preferences(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.7.0

Implémente ViewInterface.

Références $extension, $fields, $link, $type, Text\_(), Route\_(), elseif, Factory\getApplication(), AssociationsHelper\getLanguagefilterPluginId(), AssociationsHelper\getSupportedExtension(), Associations\isEnabled(), items, null, et Text\sprintf().

Documentation des champs

◆ $items

$items
protected

◆ $itemType

$itemType = null

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_associations/src/View/Associations/HtmlView.php


Joomla CMS: Référence de la classe BannerController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • BannerController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe BannerController
+ Graphe d'héritage de BannerController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_BANNERS_BANNER'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Banner controller class.

Depuis
1.6

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $data, et ArrayHelper\getValue().

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, $key, et $recordId.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
string $model The model
Renvoie
boolean True on success.
Depuis
2.5

Références $model, Route\_(), et Joomla\Application\checkToken().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_BANNERS_BANNER'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BannerController.php


Joomla CMS: Référence de la classe BannersController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • BannersController
Fonctions membres publiques | Attributs protégés
Référence de la classe BannersController
+ Graphe d'héritage de BannersController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Banner', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_BANNERS_BANNERS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Banners list controller class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Banner',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_BANNERS_BANNERS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Controller/BannersController.php


Joomla CMS: Référence de la classe ClientController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • ClientController
Attributs protégés
Référence de la classe ClientController
+ Graphe d'héritage de ClientController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Attributs protégés

$text_prefix = 'COM_BANNERS_CLIENT'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Client controller class.

Depuis
1.6

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_BANNERS_CLIENT'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ClientController.php


Joomla CMS: Référence de la classe ClientsController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • ClientsController
Fonctions membres publiques | Attributs protégés
Référence de la classe ClientsController
+ Graphe d'héritage de ClientsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Client', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_BANNERS_CLIENTS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Clients list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Client',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_BANNERS_CLIENTS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Controller/ClientsController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'banners'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Banners master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnBaseController|booleanThisobjecttosupportchaining.@since1.5

Références $id, $layout, $view, Route\_(), elseif, et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'banners'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe TracksController

  • Joomla
  • Component
  • Banners
  • Administrator
  • Controller
  • TracksController
Fonctions membres publiques | Attributs protégés
Référence de la classe TracksController
+ Graphe d'héritage de TracksController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Tracks', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$context = 'com_banners.tracks'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Tracks list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Tracks',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

Documentation des champs

◆ $context

$context = 'com_banners.tracks'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TracksController.php


Joomla CMS: Référence de la classe BannersComponent

  • Joomla
  • Component
  • Banners
  • Administrator
  • Extension
  • BannersComponent
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe BannersComponent
+ Graphe d'héritage de BannersComponent:
MVCComponent BootableExtensionInterface CategoryServiceInterface RouterServiceInterface TagServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de CategoryServiceInterface
getCategory (array $options=[], $section='')
countItems (array $items, string $section)
prepareForm (Form $form, $data)
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
- Fonctions membres publiques hérités de TagServiceInterface
countTagItems (array $items, string $extension)

Champs de données

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait

Fonctions membres protégées

getTableNameForSection (string $section=null)

Description détaillée

Component class for com_banners

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références $container, class, et Joomla\CMS\HTML\getRegistry().

◆ getTableNameForSection()

getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Documentation des champs

◆ TagServiceTrait

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait
La documentation de cette classe a été générée à partir du fichier suivant :
  • BannersComponent.php


Joomla CMS: Référence de la classe BannerclientField

  • Joomla
  • Component
  • Banners
  • Administrator
  • Field
  • BannerclientField
Fonctions membres publiques | Attributs protégés
Référence de la classe BannerclientField
+ Graphe d'héritage de BannerclientField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'BannerClient'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Bannerclient field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références BannersHelper\getClientOptions().

Documentation des champs

◆ $type

$type = 'BannerClient'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BannerclientField.php


Joomla CMS: Référence de la classe ClicksField

  • Joomla
  • Component
  • Banners
  • Administrator
  • Field
  • ClicksField
Fonctions membres protégées | Attributs protégés
Référence de la classe ClicksField
+ Graphe d'héritage de ClicksField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Clicks'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Clicks field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $onclick, Text\_(), ENT_COMPAT, name, et value.

Documentation des champs

◆ $type

$type = 'Clicks'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ClicksField.php


Joomla CMS: Référence de la classe ImpmadeField

  • Joomla
  • Component
  • Banners
  • Administrator
  • Field
  • ImpmadeField
Fonctions membres protégées | Attributs protégés
Référence de la classe ImpmadeField
+ Graphe d'héritage de ImpmadeField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ImpMade'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Impressions field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $onclick, Text\_(), ENT_COMPAT, name, et value.

Documentation des champs

◆ $type

$type = 'ImpMade'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ImpmadeField.php


Joomla CMS: Référence de la classe ImptotalField

  • Joomla
  • Component
  • Banners
  • Administrator
  • Field
  • ImptotalField
Fonctions membres protégées | Attributs protégés
Référence de la classe ImptotalField
+ Graphe d'héritage de ImptotalField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ImpTotal'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Total Impressions field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $class, $onchange, $this, text, et value.

Documentation des champs

◆ $type

$type = 'ImpTotal'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ImptotalField.php


Joomla CMS: Référence de la classe BannersHelper

  • Joomla
  • Component
  • Banners
  • Administrator
  • Helper
  • BannersHelper
Fonctions membres publiques statiques
Référence de la classe BannersHelper
+ Graphe d'héritage de BannersHelper:
ContentHelper BannersHelper

Fonctions membres publiques statiques

static | getClientOptions ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Banners component helper.

Depuis
1.6

Documentation des fonctions membres

◆ getClientOptions()

static getClientOptions ( )
static

Get client list in text/value format for a select field

Renvoie
array

Références $db, $options, $query, Text\_(), HTMLHelper\_(), Factory\getApplication(), et Factory\getDbo().

Référencé par BannerclientField\getOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Helper/BannersHelper.php


Joomla CMS: Référence de la classe BannerModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • BannerModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe BannerModel
+ Graphe d'héritage de BannerModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

generateTitle ($categoryId, $table)
getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_banners.banner'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
loadFormData ()
getReorderConditions ($table)
prepareTable ($table)
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_BANNERS_BANNER'
$batch_copymove = 'category_id'
$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

canCreateCategory ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Banner model.

Depuis
1.6

Documentation des fonctions membres

◆ canCreateCategory()

canCreateCategory ( )
private

Is the user allowed to create an on the fly category?

Renvoie
boolean
Depuis
3.6.1

Références Factory\getUser().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ generateTitle()

generateTitle | ( | $categoryId,
 |  | $table
 | ) |

A method to preprocess generating a new title in order to allow tables with alternative names for alias and title to use the batch move and copy methods

Paramètres
integer | $categoryId | The target category id
Table | $table | The JTable within which move or copy is taking place
Renvoie
void
Depuis
3.8.12

Références $data.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form. [optional]
boolean | $loadData | True if the form is to load its own data (default case), false if not. [optional]
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $data, $form, Factory\getUser(), et Joomla\CMS\MVC\Model\loadForm().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
Table $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références $db, et Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $data, $filters, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table prior to saving.

Paramètres
Table $table A Table object.
Renvoie
void
Depuis
1.6

Références $date, $db, $query, $user, Joomla\Database\getDatabase(), Factory\getDate(), et Factory\getUser().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Allows preprocessing of the Form object.

Paramètres
Form | $form | The form object
array | $data | The data to be merged into the form object
string | $group | The plugin group to be executed
Renvoie
void
Depuis
3.6.1

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

Documentation des champs

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'client_id' => 'batchClient',
'language_id' => 'batchLanguage'
)

◆ $batch_copymove

$batch_copymove = 'category_id'
protected

◆ $text_prefix

$text_prefix = 'COM_BANNERS_BANNER'
protected

◆ $typeAlias

$typeAlias = 'com_banners.banner'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Model/BannerModel.php


Joomla CMS: Référence de la classe BannersModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • BannersModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BannersModel
+ Graphe d'héritage de BannersModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
& getCategoryOrders ()
getTable ($type='Banner', $prefix='Administrator', $config=array())
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.name', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of banner records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getCategoryOrders()

& getCategoryOrders ( )

Method to get the maximum ordering value for each category.

Renvoie
array
Depuis
1.6

Références $db, $query, et Joomla\Database\getDatabase().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $clientId, $db, $language, $ordering, $published, $query, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTable()

getTable | ( | $type = 'Banner',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Returns a reference to the a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
1.6

Références $config, $prefix, et $type.

◆ populateState()

populateState | ( | $ordering = 'a.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/Model/BannersModel.php


Joomla CMS: Référence de la classe ClientModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • ClientModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe ClientModel
+ Graphe d'héritage de ClientModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_banners.client'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
loadFormData ()
prepareTable ($table)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Client model.

Depuis
1.6

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références $user, et Factory\getUser().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table prior to saving.

Paramètres
Table $table A Table object.
Renvoie
void
Depuis
1.6

Références ENT_QUOTES.

Documentation des champs

◆ $typeAlias

$typeAlias = 'com_banners.client'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ClientModel.php


Joomla CMS: Référence de la classe ClientsModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • ClientsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ClientsModel
+ Graphe d'héritage de ClientsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.name', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of banner records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Overrides the getItems method to attach additional metrics to the list.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.6

Implémente ListModelInterface.

Références $db, $item, $items, $query, $state, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie

Références $db, $published, $query, $this, elseif, Joomla\Database\getDatabase(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ClientsModel.php


Joomla CMS: Référence de la classe DownloadModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • DownloadModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DownloadModel
+ Graphe d'héritage de DownloadModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
loadFormData ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_context = 'com_banners.tracks'
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Download model.

Depuis
1.5

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $input, $this, Factory\getApplication(), ApplicationHelper\getHash(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_banners.tracks'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DownloadModel.php


Joomla CMS: Référence de la classe TracksModel

  • Joomla
  • Component
  • Banners
  • Administrator
  • Model
  • TracksModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TracksModel
+ Graphe d'héritage de TracksModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
delete ()
getBaseName ()
getFileType ()
getMimeType ()
getContent ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='b.name', $direction='asc')
getListQuery ()
getCategoryName ()
getClientName ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$basename
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of tracks.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( )

Method to delete rows.

Renvoie
boolean Returns true on success, false on failure.

Références $clientId, $db, $query, $type, $user, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et ParameterType\INTEGER.

◆ getBaseName()

getBaseName ( )

Get file name

Renvoie
string The file name
Depuis
1.6

Références $clientId, $type, Text\_(), Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ getCategoryName()

getCategoryName ( )
protected

Get the category name.

Renvoie
string The category name
Depuis
1.6

Références $db, $name, $query, Text\_(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getClientName()

getClientName ( )
protected

Get the client name

Renvoie
string The client name.
Depuis
1.6

Références $clientId, $db, $name, $query, Text\_(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getContent()

getContent ( )

Get the content

Renvoie
string The content.
Depuis
1.6

Références $app, $content, $item, Text\_(), content, File\delete(), elseif, Folder\files(), Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ getFileType()

getFileType ( )

Get the file type.

Renvoie
string The file type
Depuis
1.6

Références Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $clientId, $db, $query, $this, $type, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et StringHelper\strtolower().

◆ getMimeType()

getMimeType ( )

Get the mime type.

Renvoie
string The mime type.
Depuis
1.6

Références Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'b.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $basename

$basename
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TracksModel.php


Joomla CMS: Référence de la classe Banner

  • Joomla
  • Component
  • Banners
  • Administrator
  • Service
  • Html
  • Banner
Fonctions membres publiques
Référence de la classe Banner

Fonctions membres publiques

clients ()
clientlist ()
pinned ($value, $i, $enabled=true, $checkbox='cb')

Description détaillée

Banner HTML class.

Depuis
2.5

Documentation des fonctions membres

◆ clientlist()

clientlist ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références $db, $options, $query, Factory\getApplication(), et Joomla\Database\getDatabase().

◆ clients()

clients ( )

Display a batch widget for the client selector.

Renvoie
string The necessary HTML for the widget.
Depuis
2.5

Références Text\_(), et HTMLHelper\_().

◆ pinned()

pinned | ( | $value,
 |  | $i,
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Returns a pinned state on a grid

Paramètres
integer | $value | The state value.
integer | $i | The row index
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string The Html code
Voir également
HTMLHelperJGrid::state
Depuis
2.5.5

Références $enabled, $i, $value, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Banner.php


Joomla CMS: Référence de la classe BannerTable

  • Joomla
  • Component
  • Banners
  • Administrator
  • Table
  • BannerTable
Fonctions membres publiques | Attributs protégés
Référence de la classe BannerTable
+ Graphe d'héritage de BannerTable:
Table VersionableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
clicks ()
check ()
bind ($array, $ignore=array())
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Banner table

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
1.5

Références $db, Symfony\Contracts\Service\__construct(), et Factory\getDate().

Documentation des fonctions membres

◆ bind()

bind | ( | $array,
 |  | $ignore = array()
 | ) |

Overloaded bind function

Paramètres
mixed | $array | An associative array or object to bind to the instance.
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success
Depuis
1.5

Implémente TableInterface.

Références $height, $width, Text\_(), et Text\sprintf().

◆ check()

check ( )

Overloaded check function

Renvoie
boolean
Voir également
Table::check
Depuis
1.5

Implémente TableInterface.

Références $name, Text\_(), elseif, ENT_QUOTES, Factory\getDate(), language, name, null, et ApplicationHelper\stringURLSafe().

◆ clicks()

clicks ( )

Increase click count

Renvoie
void

Références $id, $query, et ParameterType\INTEGER.

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente VersionableTableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BannerTable.php


Joomla CMS: Référence de la classe ClientTable

  • Joomla
  • Component
  • Banners
  • Administrator
  • Table
  • ClientTable
Fonctions membres publiques | Attributs protégés
Référence de la classe ClientTable
+ Graphe d'héritage de ClientTable:
Table VersionableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
getTypeAlias ()
check ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Client table

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
1.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True if the object is ok
Voir également
Table::check()
Depuis
4.0.0

Implémente TableInterface.

Références Text\_(), et name.

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente VersionableTableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ClientTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Banner
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a banner.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions
Exception

Références $canDo, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Banner/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Banners
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = []
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$categories = []
$items = []
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

View class for a list of banners.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, $user, Text\_(), elseif, ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters = []

◆ $categories

$categories = []
protected

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items = []
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Banners/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Client
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a client.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions
Exception

Références $canDo, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Client/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Clients
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = []
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items = []
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

View class for a list of clients.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, Text\_(), ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters = []

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items = []
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Clients/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Download
  • HtmlView
Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View class for download a list of tracks.

Depuis
1.6

Documentation des champs

◆ $form

$form
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Download/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Tracks
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = []
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items = []
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

View class for a list of tracks.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), Route\_(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters = []

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items = []
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/src/View/Tracks/HtmlView.php


Joomla CMS: Référence de la classe RawView

  • Joomla
  • Component
  • Banners
  • Administrator
  • View
  • Tracks
  • RawView
Référence de la classe RawView
+ Graphe d'héritage de RawView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of tracks.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • RawView.php


Joomla CMS: Référence de la classe BannersController

  • Joomla
  • Component
  • Banners
  • Api
  • Controller
  • BannersController
Attributs protégés
Référence de la classe BannersController
+ Graphe d'héritage de BannersController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'banners'
$default_view = 'banners'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The banners controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'banners'
protected

◆ $default_view

$default_view = 'banners'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_banners/src/Controller/BannersController.php


Joomla CMS: Référence de la classe ClientsController

  • Joomla
  • Component
  • Banners
  • Api
  • Controller
  • ClientsController
Attributs protégés
Référence de la classe ClientsController
+ Graphe d'héritage de ClientsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'clients'
$default_view = 'clients'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The clients controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'clients'
protected

◆ $default_view

$default_view = 'clients'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_banners/src/Controller/ClientsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Banners
  • Api
  • View
  • Banners
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The banners view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'alias',
'checked_out',
'checked_out_time',
'catid',
'clicks',
'metakey',
'sticky',
'impmade',
'imptotal',
'state',
'ordering',
'purchase_type',
'language',
'publish_up',
'publish_down',
'language_image',
'editor',
'category_title',
'client_name',
'client_purchase_type',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_banners/src/View/Banners/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Banners
  • Api
  • View
  • Clients
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The clients view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'typeAlias',
'id',
'checked_out_time',
'name',
'contact',
'email',
'checked_out',
'checked_out_time',
'extrainfo',
'state',
'metakey',
'own_prefix',
'metakey_prefix',
'purchase_type',
'track_clicks',
'track_impressions',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'contact',
'checked_out',
'checked_out_time',
'state',
'metakey',
'purchase_type',
'nbanners',
'editor',
'count_published',
'count_unpublished',
'count_trashed',
'count_archived',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_banners/src/View/Clients/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Banners
  • Site
  • Controller
  • DisplayController
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Banners Controller

Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_banners/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe BannerHelper

  • Joomla
  • Component
  • Banners
  • Site
  • Helper
  • BannerHelper
Fonctions membres publiques statiques
Référence de la classe BannerHelper

Fonctions membres publiques statiques

static isImage ($url)

Description détaillée

Banner Helper Class

Depuis
1.6

Documentation des fonctions membres

◆ isImage()

static isImage ( $url )
static

Checks if a URL is an image

Paramètres
string $url The URL path to the potential image
Renvoie
boolean True if an image of type bmp, gif, jp(e)g, png or webp, false otherwise
Depuis
1.6

Références $url.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BannerHelper.php


Joomla CMS: Référence de la classe BannerModel

  • Joomla
  • Component
  • Banners
  • Site
  • Model
  • BannerModel
Fonctions membres publiques | Attributs protégés
Référence de la classe BannerModel
+ Graphe d'héritage de BannerModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

click ()
getUrl ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$_item
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Banner model for the Joomla Banners component.

Depuis
1.5

Documentation des fonctions membres

◆ click()

click ( )

Clicks the URL, incrementing the counter

Renvoie
void
Depuis
1.5
Exceptions

Références $config, $count, $db, $id, $item, $query, Text\_(), Joomla\Database\getDatabase(), Factory\getDate(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getUrl()

getUrl ( )

Get the URL for a banner

Renvoie
string
Depuis
1.5

Références $item, et $url.

Documentation des champs

◆ $_item

$_item
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_banners/src/Model/BannerModel.php


Joomla CMS: Référence de la classe BannersModel

  • Joomla
  • Component
  • Banners
  • Site
  • Model
  • BannersModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe BannersModel
+ Graphe d'héritage de BannersModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
impress ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Banners model for the Joomla Banners component.

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( )

Get a list of banners.

Renvoie
array
Depuis
1.6

Implémente ListModelInterface.

Références $item, $keywords, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\setState().

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
DatabaseQuery A DatabaseQuery object to retrieve the data set.
Depuis
1.6

Références $config, $db, $key, $keywords, $nowDate, $ordering, $prefix, $query, $temp, $type, elseif, Joomla\Database\getDatabase(), Factory\getDate(), Factory\getLanguage(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ impress()

impress ( )

Makes impressions on a list of banners

Renvoie
void
Depuis
1.6
Exceptions

Références $config, $db, $item, $items, $query, Joomla\Database\getDatabase(), Factory\getDate(), ComponentHelper\getParams(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_banners/src/Model/BannersModel.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • Component
  • Banners
  • Site
  • Service
  • Category
Fonctions membres publiques
Référence de la classe Category
+ Graphe d'héritage de Category:
Categories CategoryInterface DatabaseAwareInterface

Fonctions membres publiques

__construct ($options=array())
- Fonctions membres publiques hérités de Categories
__construct ($options)
get ($id='root', $forceload=false)
getExtension ()
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Categories
static | getInstance ($extension, $options=array())
- Attributs publics statiques hérités de Categories
static | $instances = array()
- Fonctions membres protégées hérités de Categories
_load ($id)
- Attributs protégés hérités de Categories
$_nodes
$_checkedCategories
$_extension = null
$_table = null
$_field = null
$_key = null
$_statefield = null
$_options = []

Description détaillée

Banners Component Category Tree

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options Array of options
Depuis
1.6

Références $options, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_banners/src/Service/Category.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Banners
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterBase RouterInterface

Fonctions membres publiques

build (&$query)
parse (&$segments)
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class from com_banners

Depuis
3.3

Documentation des fonctions membres

◆ build()

build ( & $query )

Build the route for the com_banners component

Paramètres
array $query An array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $i, $query, et $total.

◆ parse()

parse ( & $segments )

Parse the segments of a URL.

Paramètres
array $segments The segments of the URL to parse.
Renvoie
array The URL attributes to be used by the application.
Depuis
3.3

Implémente RouterInterface.

Références $count, $i, et $total.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_banners/src/Service/Router.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Cache
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getQuickiconContent ()
delete ()
purge ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'cache'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Cache Controller

Depuis
1.6

Documentation des fonctions membres

◆ delete()

delete ( )

Method to delete a list of cache groups.

Renvoie
void

Références $result, Text\_(), Joomla\Application\checkToken(), et Text\sprintf().

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get The Cache Size

Depuis
4.0.0

Références $data, $model, $result, $size, HTMLHelper\_(), et Text\sprintf().

◆ purge()

purge ( )

Purge the cache.

Renvoie
void

Références Text\_(), et Joomla\Application\checkToken().

Documentation des champs

◆ $default_view

$default_view = 'cache'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_cache/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe CacheModel

  • Joomla
  • Component
  • Cache
  • Administrator
  • Model
  • CacheModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CacheModel
+ Graphe d'héritage de CacheModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getData ()
getCache ()
getTotal ()
getPagination ()
clean ($group='')
cleanlist ($array)
purge ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='group', $direction='asc')
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_data = array()
$_total = null
$_pagination = null
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Cache Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
3.5

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ clean()

clean ( $group = '' )

Clean out a cache group as named by param. If no param is passed clean all cache groups.

Paramètres
string $group Cache group name.
Renvoie
boolean True on success, false otherwise

Références Factory\getApplication().

◆ cleanlist()

cleanlist ( $array )

Purge an array of cache groups.

Paramètres
array $array Array of cache group names.
Renvoie
array Array with errors, if they exist.

◆ getCache()

getCache ( )

Method to get cache instance.

Renvoie
CacheController

Références $app, $options, Factory\getApplication(), Cache\getInstance(), et JPATH_CACHE.

◆ getData()

getData ( )

Method to get cache data

Renvoie
array

Références $data, $key, $limit, $listDirn, $listOrder, $start, Text\_(), Joomla\CMS\MVC\Model\getState(), et ArrayHelper\sortObjects().

◆ getPagination()

getPagination ( )

Method to get a pagination object for the cache.

Renvoie
Pagination

Références Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
3.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTotal()

getTotal ( )

Get the number of current Cache Groups.

Renvoie
integer

◆ populateState()

populateState | ( | $ordering = 'group',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | Field for ordering.
string | $direction | Direction of ordering.
Renvoie
void
Depuis
1.6

Références $direction, $ordering, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ purge()

purge ( )

Purge all cache items.

Renvoie
boolean True if successful; false otherwise.

Références Factory\getApplication(), et Factory\getCache().

Documentation des champs

◆ $_data

$_data = array()
protected

◆ $_pagination

$_pagination = null
protected

◆ $_total

$_total = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CacheModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Cache
  • Administrator
  • View
  • Cache
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = []
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$data = []
$pagination
$total = 0
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

HTML View class for the Cache component

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $toolbar, Text\_(), ToolbarHelper\custom(), ToolbarHelper\divider(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters = []

◆ $data

$data = []
protected

◆ $filterForm

$filterForm

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $total

$total = 0
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_cache/src/View/Cache/HtmlView.php


Joomla CMS: Référence de la classe AjaxController

  • Joomla
  • Component
  • Categories
  • Administrator
  • Controller
  • AjaxController
Fonctions membres publiques
Référence de la classe AjaxController
+ Graphe d'héritage de AjaxController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

fetchAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The categories controller for ajax requests

Depuis
3.9.0

Documentation des fonctions membres

◆ fetchAssociations()

fetchAssociations ( )

Method to fetch associations of a category

The method assumes that the following http parameters are passed in an Ajax Get request: token: the form token assocId: the id of the category whose associations are to be returned excludeLang: the association for this language is to be excluded

Renvoie
void
Depuis
3.9.0

Références $extension, $lang, $message, Text\_(), Table\addIncludePath(), Session\checkToken(), elseif, Associations\getAssociations(), Table\getInstance(), JPATH_ADMINISTRATOR, null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_categories/src/Controller/AjaxController.php


Joomla CMS: Référence de la classe CategoriesController

  • Joomla
  • Component
  • Categories
  • Administrator
  • Controller
  • CategoriesController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe CategoriesController
+ Graphe d'héritage de CategoriesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Category', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Categories List Controller

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Category',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Outputs the JSON-encoded amount of published content categories

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $extension, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Controller/CategoriesController.php


Joomla CMS: Référence de la classe CategoryController

  • Joomla
  • Component
  • Categories
  • Administrator
  • Controller
  • CategoryController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryController
+ Graphe d'héritage de CategoryController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, CMSApplication $app=null, Input $input=null)
save ($key=null, $urlVar=null)
cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='parent_id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$extension
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Category Controller

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | CMSApplication | $app = null,
 |  | Input | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
Input | null | $input | Input
Depuis
1.6
Exceptions

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $this, et $user.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'parent_id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, $key, $recordId, $this, et $user.

◆ cancel()

cancel ( $key = null )

Override cancel method to clear form data for a failed edit action

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
3.10.3

Références $key, $result, extension, et null.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | null | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

Références $append, $extension, $recordId, et extension.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

Références $append, et $extension.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
\Joomla\CMS\MVC\Model\BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
3.1

Références $item, et $model.

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Override parent save method to store form data with right key as expected by edit category page

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if successful, false otherwise.
Depuis
3.10.3

Références $key, $result, et extension.

Documentation des champs

◆ $extension

$extension
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Categories
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'categories'
$extension
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Categories view class for the Category package.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
Input | null | $input | Input
Depuis
3.0

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchaining.@since1.5

Références $document, $id, $model, $this, $view, Route\_(), extension, et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'categories'
protected

◆ $extension

$extension
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Categories
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_categories

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Categories have to check for extension permission

Renvoie
void

Références $extension, et $parts.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe CategoriesComponent

  • Joomla
  • Component
  • Categories
  • Administrator
  • Extension
  • CategoriesComponent
Fonctions membres publiques
Référence de la classe CategoriesComponent
+ Graphe d'héritage de CategoriesComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_categories

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoriesComponent.php


Joomla CMS: Référence de la classe CategoryField

  • Joomla
  • Component
  • Categories
  • Administrator
  • Field
  • Modal
  • CategoryField
Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryField
+ Graphe d'héritage de CategoryField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Category'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal category picker.

Depuis
3.1

Documentation des fonctions membres

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.7.0

Documentation des champs

◆ $type

$type = 'Modal_Category'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Field/Modal/CategoryField.php


Joomla CMS: Référence de la classe CategoryeditField

  • Joomla
  • Component
  • Categories
  • Administrator
  • Field
  • CategoryeditField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryeditField
+ Graphe d'héritage de CategoryeditField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
__get ($name)
__set ($name, $value)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'CategoryEdit'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
getInput ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$allowAdd
$customPrefix
$layout = 'joomla.form.field.categoryedit'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Category Edit field..

Depuis
1.6

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.6

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.6

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a generic list. Use the multiple attribute to enable multiselect.

Renvoie
string The field input markup.
Depuis
3.6

Références $data, et $renderer.

◆ getOptions()

getOptions ( )
protected

Method to get a list of categories that respects access controls and can be used for either category assignment or parent category assignment in edit screens. Use the parent element to indicate that the field will be used for assigning parent categories.

Renvoie
array The field option objects.
Depuis
1.6

Références $db, $extension, $groups, $i, $language, $n, $name, $option, $options, $published, $query, $state, $user, Text\_(), HTMLHelper\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, language, level, ParameterType\STRING, et ArrayHelper\toInteger().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | null | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.2

Références $return, et $value.

Documentation des champs

◆ $allowAdd

$allowAdd
protected

◆ $customPrefix

$customPrefix
protected

◆ $layout

$layout = 'joomla.form.field.categoryedit'
protected

◆ $type

$type = 'CategoryEdit'
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryeditField.php


Joomla CMS: Référence de la classe ComponentsCategoryField

  • Joomla
  • Component
  • Categories
  • Administrator
  • Field
  • ComponentsCategoryField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentsCategoryField
+ Graphe d'héritage de ComponentsCategoryField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ComponentsCategory'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Components Category field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.7.0

Références $component, $db, $lang, $option, $options, $parts, $query, $section, Text\_(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_BASE, null, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ComponentsCategory'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentsCategoryField.php


Joomla CMS: Référence de la classe CategoriesHelper

  • Joomla
  • Component
  • Categories
  • Administrator
  • Helper
  • CategoriesHelper
Fonctions membres publiques statiques
Référence de la classe CategoriesHelper
+ Graphe d'héritage de CategoriesHelper:
CategoriesHelper

Fonctions membres publiques statiques

static | getAssociations ($pk, $extension='com_content')
static | validateCategoryId ($catid, $extension)
static | createCategory ($data)

Description détaillée

Categories helper.

Depuis
1.6

Documentation des fonctions membres

◆ createCategory()

static createCategory ( $data )
static

Create new Category from within item view.

Paramètres
array $data Array of data for new category.
Renvoie
integer

Références $data, et Factory\getApplication().

◆ getAssociations()

static getAssociations | ( | $pk,
 |  | $extension = 'com_content'
 | ) |
static

Gets a list of associations for a given item.

Paramètres
integer | $pk | Content item key.
string | $extension | Optional extension name.
Renvoie
array of associations.

Références $db, $extension, $groups, $query, $result, $user, Associations\getAssociations(), Factory\getDbo(), Factory\getUser(), et ParameterType\INTEGER.

Référencé par AdministratorService\association(), CategoryAssociationHelper\getCategoryAssociations(), et CategoryModel\getItem().

◆ validateCategoryId()

static validateCategoryId | ( | $catid,
 |  | $extension
 | ) |
static

Check if Category ID exists otherwise assign to ROOT category.

Paramètres
mixed | $catid | Name or ID of category.
string | $extension | Extension that triggers this function
Renvoie
integer $catid Category ID.

Références $data, $extension, et Table\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoriesHelper.php


Joomla CMS: Référence de la classe CategoryAssociationHelper

  • Joomla
  • Component
  • Categories
  • Administrator
  • Helper
  • CategoryAssociationHelper
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe CategoryAssociationHelper
+ Graphe d'héritage de CategoryAssociationHelper:
AssociationHelper AssociationHelper AssociationHelper

Fonctions membres publiques statiques

static getCategoryAssociations ($id=0, $extension='com_content', $layout=null)

Attributs publics statiques

static $category_association = true

Description détaillée

Category Component Association Helper

Depuis
3.0

Documentation des fonctions membres

◆ getCategoryAssociations()

static getCategoryAssociations | ( | $id = 0,
 |  | $extension = 'com_content',
 |  | $layout = null
 | ) |
static

Method to get the associations for a given category

Paramètres
integer | $id | Id of the item
string | $extension | Name of the component
string | null | $layout | Category layout
Renvoie
array Array of associations for the component categories
Depuis
3.0

Références $extension, $id, $item, $layout, $return, et CategoriesHelper\getAssociations().

Documentation des champs

◆ $category_association

$category_association = true
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryAssociationHelper.php


Joomla CMS: Référence de la classe CategoriesModel

  • Joomla
  • Component
  • Categories
  • Administrator
  • Model
  • CategoriesModel
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe CategoriesModel
+ Graphe d'héritage de CategoriesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getAssoc ()
getItems ()
countItems (&$items, $extension)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
getEmptyStateQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs privés

$hasAssociation

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Categories Component Categories Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
Depuis
1.6

Références $config, Symfony\Contracts\Service\__construct(), et Associations\isEnabled().

Documentation des fonctions membres

◆ countItems()

countItems | ( | & | $items,
 |  |  | $extension
 | ) |  |

Method to load the countItems method from the extensions

Paramètres

Références $component, $extension, $items, $parts, $section, et Factory\getApplication().

◆ getAssoc()

getAssoc ( )

Method to determine if an association exists

Renvoie
boolean True if the association exists
Depuis
3.0

Références $component, $extension, Joomla\CMS\MVC\Model\getState(), Associations\isEnabled(), JPATH_SITE, et JLoader\register().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $extension, $query, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.0.1

Implémente ListModelInterface.

Références $extension, $items, Joomla\CMS\Categories\countItems(), et Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Method to get a database query to list categories.

Renvoie
Depuis
1.6

Références $assoc, $db, $extension, $groups, $language, $listDirn, $published, $query, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $extension, $layout, $ordering, $parts, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $hasAssociation

$hasAssociation
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Model/CategoriesModel.php


Joomla CMS: Référence de la classe CategoryModel

  • Joomla
  • Component
  • Categories
  • Administrator
  • Model
  • CategoryModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe CategoryModel
+ Graphe d'héritage de CategoryModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($type='Category', $prefix='Administrator', $config=array())
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
save ($data)
publish (&$pks, $value=1)
rebuild ()
saveorder ($idArray=null, $lftArray=null)
getAssoc ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = null
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
populateState ()
getReorderConditions ($table)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
batchFlipordering ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
cleanCache ($group=null, $clientId=0)
generateNewTitle ($parentId, $alias, $title)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_CATEGORIES'
$associationsContext = 'com_categories.item'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$hasAssociation

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Categories Component Category Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
Voir également
Depuis
3.2

Références $config, $extension, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ batchCopy()

batchCopy | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch copy categories to a new category.

Paramètres
integer | $value | The new category.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
mixed An array of new IDs on success, boolean false on failure.
Depuis
1.6

Références $canCreate, $count, $db, $extension, $parts, $query, $this, $title, $type, $value, Text\_(), elseif, Factory\getApplication(), Joomla\Database\getDatabase(), ArrayHelper\getValue(), ParameterType\INTEGER, null, et Text\sprintf().

◆ batchFlipordering()

batchFlipordering | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch flip category ordering.

Paramètres
integer | $value | The new category.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
mixed An array of new IDs on success, boolean false on failure.
Depuis
3.6.3

For each category get the max ordering value Re-order with max - ordering

Références $db, $id, $query, false, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move categories to a new category.

Paramètres
integer | $value | The new category ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True on success.
Depuis
1.6

Références $canCreate, $db, $extension, $query, $type, $value, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), ParameterType\INTEGER, Text\sprintf(), et ArrayHelper\toInteger().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références $user, et Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean the cache of com_content and content modules

Paramètres
string | $group | Cache group name.
integer | $clientId

Références $extension, et Factory\getApplication().

◆ generateNewTitle()

generateNewTitle | ( | $parentId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title & alias.

Paramètres
integer | $parentId | The id of the parent.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
1.7

Références $title, et StringHelper\increment().

◆ getAssoc()

getAssoc ( )

Method to determine if a category association is available.

Renvoie
boolean True if a category association is available; false otherwise.

Références $component, $extension, Joomla\CMS\MVC\Model\getState(), Associations\isEnabled(), JPATH_SITE, et JLoader\register().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A JForm object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $data, $extension, $form, $parts, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getItem()

getItem ( $pk = null )

Method to get a category.

Paramètres
integer $pk An optional id of the object to get, otherwise the id from the model state is used.
Renvoie
mixed Category data object on success, false on failure.
Depuis
1.6

Références $assoc, $result, CategoriesHelper\getAssociations(), Joomla\CMS\MVC\Model\getState(), null, et ArrayHelper\toInteger().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get the where clause for the reorder This ensures that the row will be moved relative to a row with the same extension

Paramètres
Category $table Current table instance
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Category',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
A Table object
Depuis
1.6

Références $config, $prefix, et $type.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $data, $extension, $filters, Factory\getApplication(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $extension, $params, $parts, Factory\getApplication(), ComponentHelper\getParams(), null, et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import.
Renvoie
mixed
Depuis
1.6
Exceptions

Références $component, $data, $extension, $field, $fields, $form, $lang, $language, $languages, $name, $path, $section, Text\_(), Path\clean(), Factory\getApplication(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), JPATH_ADMINISTRATOR, JPATH_BASE, Form\loadFile(), null, Joomla\CMS\MVC\Model\preprocessForm(), et JLoader\register().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | $pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
2.5

Références $extension, $value, Factory\getApplication(), et PluginHelper\importPlugin().

◆ rebuild()

rebuild ( )

Method rebuild the entire nested set tree.

Renvoie
boolean False on failure or error, true otherwise.
Depuis
1.6

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $assoc, $context, $data, $db, $id, $input, $key, $name, $query, $result, $this, $title, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), ParameterType\INTEGER, null, Joomla\CMS\MVC\Model\setState(), ParameterType\STRING, et ArrayHelper\toInteger().

◆ saveorder()

saveorder | ( | $idArray = null,
 |  | $lftArray = null
 | ) |

Method to save the reordered nested set tree. First we save the new order values in the lft values of the changed ids. Then we invoke the table rebuild to implement the new ordering.

Paramètres
array | $idArray | An array of primary key ids.
integer | $lftArray | The lft value
Renvoie
boolean False on failure or error, True otherwise
Depuis
1.6

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFormRule
JFilterInput
Depuis
3.9.23

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $associationsContext

$associationsContext = 'com_categories.item'
protected

◆ $hasAssociation

$hasAssociation
private

◆ $text_prefix

$text_prefix = 'COM_CATEGORIES'
protected

◆ $typeAlias

$typeAlias = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/Model/CategoryModel.php


Joomla CMS: Référence de la classe AdministratorService

  • Joomla
  • Component
  • Categories
  • Administrator
  • Service
  • HTML
  • AdministratorService
Fonctions membres publiques
Référence de la classe AdministratorService

Fonctions membres publiques

association ($catid, $extension='com_content')

Description détaillée

Administrator category HTML

Depuis
3.2

Documentation des fonctions membres

◆ association()

association | ( | $catid,
 |  | $extension = 'com_content'
 | ) |

Render the list of associated items

Paramètres
integer | $catid | Category identifier to search its associations
string | $extension | Category Extension
Renvoie
string The language HTML
Depuis
3.2
Exceptions

Références $classes, $content_languages, $db, $extension, $html, $item, $items, $languages, $query, $text, $tooltip, $url, Route\_(), ENT_QUOTES, Factory\getApplication(), CategoriesHelper\getAssociations(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), Text\sprintf(), et ArrayHelper\toInteger().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_categories/src/Service/HTML/AdministratorService.php


Joomla CMS: Référence de la classe CategoryTable

  • Joomla
  • Component
  • Categories
  • Administrator
  • Table
  • CategoryTable
Fonctions membres publiques
Référence de la classe CategoryTable
+ Graphe d'héritage de CategoryTable:
Category Nested VersionableTableInterface TaggableTableInterface Table TableInterface TableInterface CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

delete ($pk=null, $children=false)
- Fonctions membres publiques hérités de Category
__construct (DatabaseDriver $db)
check ()
bind ($array, $ignore='')
store ($updateNulls=true)
getTypeAlias ()
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Category
_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Category
$_supportNullValue = true
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Category table

Depuis
1.6

Documentation des fonctions membres

◆ delete()

delete | ( | $pk = null,
 |  | $children = false
 | ) |

Method to delete a node and, optionally, its child nodes from the table.

Paramètres
integer | null | $pk | The primary key of the node to delete.
boolean | $children | True to delete child nodes, false to move them up a level.
Renvoie
boolean True on success.
Depuis
2.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • CategoryTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Categories
  • Administrator
  • View
  • Categories
  • HtmlView
Fonctions membres publiques | Champs de données | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Attributs protégés

$items
$pagination
$state
$assoc
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Categories view class for the Category package.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string | null $tpl The name of the template file to parse; automatically searches through the template paths.
Exceptions
GenericDataException
Renvoie
void

Implémente ViewInterface.

Références $item, Factory\getApplication(), Multilanguage\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $assoc

$assoc
protected

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/View/Categories/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Categories
  • Administrator
  • View
  • Category
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$form
$item
$state
$assoc
$canDo
$checkTags = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

HTML View class for the Categories component

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string | null $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $section, ContentHelper\getActions(), Factory\getApplication(), TagsHelper\getTypes(), et null.

Documentation des champs

◆ $assoc

$assoc
protected

◆ $canDo

$canDo
protected

◆ $checkTags

$checkTags = false
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/src/View/Category/HtmlView.php


Joomla CMS: Référence de la classe CategoriesController

  • Joomla
  • Component
  • Categories
  • Api
  • Controller
  • CategoriesController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe CategoriesController
+ Graphe d'héritage de CategoriesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

preprocessSaveData (array $data)
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'categories'
$default_view = 'categories'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getExtensionFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The categories controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getExtensionFromInput()

getExtensionFromInput ( )
private

Get extension from input

Renvoie
string
Depuis
4.0.0

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0

Références $data, et $extension.

Documentation des champs

◆ $contentType

$contentType = 'categories'
protected

◆ $default_view

$default_view = 'categories'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_categories/src/Controller/CategoriesController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Categories
  • Api
  • View
  • Categories
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

displayList (array $items=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The categories view

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( array $items = null )

Execute and display a template script.

Paramètres
array | null $items Array of items
Renvoie
string
Depuis
4.0.0

Références $field, et FieldsHelper\getFields().

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $field, $item, et FieldsHelper\getFields().

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'title',
'alias',
'note',
'published',
'access',
'checked_out',
'checked_out_time',
'created_user_id',
'parent_id',
'level',
'extension',
'lft',
'rgt',
'language',
'language_title',
'language_image',
'editor',
'access_level',
'author_name',
'count_trashed',
'count_unpublished',
'count_published',
'count_archived',
'params',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'title',
'alias',
'note',
'published',
'access',
'checked_out',
'checked_out_time',
'created_user_id',
'parent_id',
'level',
'lft',
'rgt',
'language',
'language_title',
'language_image',
'editor',
'access_level',
'author_name',
'count_trashed',
'count_unpublished',
'count_published',
'count_archived',
'params',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_categories/src/View/Categories/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Checkin
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
getMenuBadgeData ()
getQuickiconContent ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'checkin'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Checkin Controller

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticA\JControllerLegacyobjecttosupportchaining.

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, et Text\_().

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the number of locked icons

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, $result, Text\_(), et Text\plural().

Documentation des champs

◆ $default_view

$default_view = 'checkin'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_checkin/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe CheckinModel

  • Joomla
  • Component
  • Checkin
  • Administrator
  • Model
  • CheckinModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CheckinModel
+ Graphe d'héritage de CheckinModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
checkin ($ids=array())
getTotal ()
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='table', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$total
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Checkin Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ checkin()

checkin ( $ids = array() )

Checks in requested tables

Paramètres
array $ids An array of table names. Optional.
Renvoie
mixed The database results or 0
Depuis
1.6

Références $app, $db, $fields, $query, $results, Factory\getApplication(), et Joomla\Database\getDatabase().

◆ getItems()

getItems ( )

Get tables

Renvoie
array Checked in table names as keys and checked in item count as values.
Depuis
1.6

Implémente ListModelInterface.

Références $count, $db, $fields, $items, $limit, $prefix, $query, $results, Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et items.

◆ getTotal()

getTotal ( )

Get total of tables

Renvoie
integer Total to check-in tables
Depuis
1.6

Références $total.

◆ populateState()

populateState | ( | $ordering = 'table',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note: Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, et Joomla\CMS\MVC\Model\populateState().

Documentation des champs

◆ $total

$total
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckinModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Checkin
  • Administrator
  • View
  • Checkin
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

HTML View class for the Checkin component

Depuis
1.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références Text\_(), ToolbarHelper\custom(), ToolbarHelper\divider(), Factory\getApplication(), Joomla\CMS\Application\getIdentity(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_checkin/src/View/Checkin/HtmlView.php


Joomla CMS: Référence de la classe ApplicationController

  • Joomla
  • Component
  • Config
  • Administrator
  • Controller
  • ApplicationController
Fonctions membres publiques
Référence de la classe ApplicationController
+ Graphe d'héritage de ApplicationController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller for global configuration

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cancel()

cancel ( )

Cancel operation.

Renvoie
void
Depuis
3.0.0

Références Route\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/Controller/ApplicationController.php


Joomla CMS: Référence de la classe ComponentController

  • Joomla
  • Component
  • Config
  • Administrator
  • Controller
  • ComponentController
Fonctions membres publiques
Référence de la classe ComponentController
+ Graphe d'héritage de ComponentController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Note: this view is intended only to be opened in a popup

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cancel()

cancel ( $key = null )

Method to cancel global configuration component.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean
Depuis
3.2

Références $component, Route\_(), Uri\base(), Uri\isInternal(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/Controller/ComponentController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Config
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'application'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller for global configuration

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Typical view method for MVC based architecture

This function is provide as a default implementation, in most cases you will need to override it in your own controllers.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe url parameters and their variable types, for valid values see InputFilter::clean().
Renvoie
static A object to support chaining.
Depuis
3.0
Exceptions

Références $component, Text\_(), et Route\_().

Documentation des champs

◆ $default_view

$default_view = 'application'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe RequestController

  • Joomla
  • Component
  • Config
  • Administrator
  • Controller
  • RequestController
Fonctions membres publiques
Référence de la classe RequestController
+ Graphe d'héritage de RequestController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getJson ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Requests from the frontend

Depuis
4.0.0

Documentation des fonctions membres

◆ getJson()

getJson ( )

Execute the controller.

Renvoie
mixed A rendered view or false
Depuis
3.2

Références $component, $data, $model, $user, Text\_(), JPATH_ADMINISTRATOR, JPATH_BASE, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/Controller/RequestController.php


Joomla CMS: Référence de la classe ConfigComponent

  • Joomla
  • Component
  • Config
  • Administrator
  • Extension
  • ConfigComponent
Référence de la classe ConfigComponent
+ Graphe d'héritage de ConfigComponent:
MVCComponent RouterServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_config

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigComponent.php


Joomla CMS: Référence de la classe ConfigComponentsField

  • Joomla
  • Component
  • Config
  • Administrator
  • Field
  • ConfigComponentsField
Champs de données | Fonctions membres protégées
Référence de la classe ConfigComponentsField
+ Graphe d'héritage de ConfigComponentsField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'ConfigComponents'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Text Filters form field.

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.7.0

Références $db, $extension, $item, $items, $lang, $options, $query, Text\_(), File\exists(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, null, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ConfigComponents'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigComponentsField.php


Joomla CMS: Référence de la classe FiltersField

  • Joomla
  • Component
  • Config
  • Administrator
  • Field
  • FiltersField
Champs de données | Fonctions membres protégées
Référence de la classe FiltersField
+ Graphe d'héritage de FiltersField:
FormField DatabaseAwareInterface

Champs de données

$type = 'Filters'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getUserGroups ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Text Filters form field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $groups, $html, Text\_(), ENT_QUOTES, Factory\getDocument(), name, LayoutHelper\render(), Text\script(), et value.

◆ getUserGroups()

getUserGroups ( )
protected

A helper to get the list of user groups.

Renvoie
array
Depuis
1.6

Références $db, $options, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $type

$type = 'Filters'
La documentation de cette classe a été générée à partir du fichier suivant :
  • FiltersField.php


Joomla CMS: Référence de la classe ConfigHelper

  • Joomla
  • Component
  • Config
  • Administrator
  • Helper
  • ConfigHelper
Fonctions membres publiques statiques
Référence de la classe ConfigHelper
+ Graphe d'héritage de ConfigHelper:
ContentHelper

Fonctions membres publiques statiques

static | getAllComponents ()
static | hasComponentConfig ($component)
static | getComponentsWithConfig ($authCheck=true)
static | loadLanguageForComponents ($components)
static | loadLanguageForComponent ($component)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Components helper for com_config

Depuis
3.0

Documentation des fonctions membres

◆ getAllComponents()

static getAllComponents ( )
static

Get an array of all enabled components.

Renvoie
array
Depuis
3.0

Références $db, $query, $result, et Factory\getDbo().

◆ getComponentsWithConfig()

static getComponentsWithConfig ( $authCheck = true )
static

Returns an array of all components with configuration options. Optionally return only those components for which the current user has 'core.manage' rights.

Paramètres
boolean $authCheck True to restrict to components where current user has 'core.manage' rights.
Renvoie
array
Depuis
3.0

Références $component, $result, $user, Text\_(), Factory\getUser(), et ApplicationHelper\stringURLSafe().

Référencé par HtmlView\display().

◆ hasComponentConfig()

static hasComponentConfig ( $component )
static

Returns true if the component has configuration options.

Paramètres
string $component Component name
Renvoie
boolean
Depuis
3.0

Références $component, et JPATH_ADMINISTRATOR.

◆ loadLanguageForComponent()

static loadLanguageForComponent ( $component )
static

Load the sys language for the given component.

Paramètres
string $component component name.
Renvoie
void
Depuis
3.5

Références $component, $lang, Factory\getLanguage(), JPATH_ADMINISTRATOR, et JPATH_BASE.

◆ loadLanguageForComponents()

static loadLanguageForComponents ( $components )
static

Load the sys language for the given component.

Paramètres
array $components Array of component names.
Renvoie
void
Depuis
3.0

Références $component.

Référencé par HtmlView\display().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigHelper.php


Joomla CMS: Référence de la classe ApplicationModel

  • Joomla
  • Component
  • Config
  • Administrator
  • Model
  • ApplicationModel
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ApplicationModel
+ Graphe d'héritage de ApplicationModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getData ()
validateDbConnection ($data)
save ($data)
removeroot ()
sendTestMail ()
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres privées

writeConfigFile (Registry $config)

Attributs privés

$protectedConfigurationFields = array('password', 'secret', 'smtppass', 'redis_server_auth', 'session_redis_server_auth')

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for the global configuration

Depuis
3.2

Documentation des fonctions membres

◆ getData()

getData ( )

Method to get the configuration data.

This method will load the global configuration data straight from JConfig. If configuration data has been saved in the session, that data will be merged into the original data, overwriting it.

Renvoie
array An array containing all global config data.
Depuis
1.6

Références $config, $data, $params, $temp, ArrayHelper\fromObject(), Factory\getApplication(), Joomla\Database\getDatabase(), et ComponentHelper\getParams().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get a form object.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
mixed A JForm object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ removeroot()

removeroot ( )

Method to unset the root_user value from configuration data.

This method will load the global configuration data straight from JConfig and remove the root_user value for security, then save the configuration.

Renvoie
boolean True on success, false on failure.
Depuis
1.6

Références $app, $config, $result, Text\_(), ArrayHelper\fromObject(), et Factory\getApplication().

◆ save()

save ( $data )

Method to save the configuration data.

Paramètres
array $data An array containing all global config data.
Renvoie
boolean True on success, false on failure.
Depuis
1.6

Références $app, $config, $data, $db, $extension, $options, $path, $query, $result, $value, Text\_(), Log\add(), OutputFilter\ampReplace(), Path\clean(), Folder\create(), elseif, Folder\exists(), ArrayHelper\fromObject(), UserHelper\genRandomPassword(), Factory\getApplication(), Factory\getCache(), Joomla\Database\getDatabase(), Access\getGroupsByUser(), HttpFactory\getHttp(), Uri\getInstance(), Table\getInstance(), DatabaseDriver\getInstance(), Factory\getUser(), JPATH_ADMINISTRATOR, JPATH_CACHE, JPATH_ROOT, null, Uri\root(), Text\sprintf(), et Log\WARNING.

◆ sendTestMail()

sendTestMail ( )

Method to send a test mail which is called via an AJAX request

Renvoie
boolean
Depuis
3.5

Références $app, $input, $methodName, $user, Text\_(), Factory\getApplication(), Factory\getMailer(), Factory\getUser(), null, et Text\sprintf().

◆ validateDbConnection()

validateDbConnection ( $data )

Method to validate the db connection properties.

Paramètres
array $data An array containing all global config data.
Renvoie
array|boolean Array with the validated global config data or boolean false on a validation failure.
Depuis
4.0.0

Références $data, Text\_(), Path\clean(), File\exists(), Factory\getApplication(), et Text\sprintf().

◆ writeConfigFile()

writeConfigFile ( Registry $config )
private

Method to write the configuration to a file.

Paramètres
Registry $config A Registry object containing all global config data.
Renvoie
boolean True on success, false on failure.
Depuis
2.5.4
Exceptions

Références $app, $config, $configuration, Text\_(), Factory\getApplication(), Path\isOwner(), JPATH_CONFIGURATION, Path\setPermissions(), et File\write().

Documentation des champs

◆ $protectedConfigurationFields

$protectedConfigurationFields = array('password', 'secret', 'smtppass', 'redis_server_auth', 'session_redis_server_auth')
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApplicationModel.php


Joomla CMS: Référence de la classe ComponentModel

  • Joomla
  • Component
  • Config
  • Administrator
  • Model
  • ComponentModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ComponentModel
+ Graphe d'héritage de ComponentModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getComponent ()
save ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
loadFormData ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for component configuration

Depuis
3.2

Documentation des fonctions membres

◆ getComponent()

getComponent ( )

Get the component information.

Renvoie
object
Depuis
3.2

Références $lang, $option, $result, $state, ComponentHelper\getComponent(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), et JPATH_BASE.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get a form object.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
mixed A JForm object on success, false on failure
Depuis
3.2

Implémente FormModelInterface.

Références $form, $lang, $option, $path, $state, Form\addFormPath(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), JPATH_ADMINISTRATOR, JPATH_BASE, et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
4.0.0

Références $data, $option, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.2

Références $component, $input, $path, Path\check(), Path\clean(), Factory\getApplication(), et JPATH_SITE.

◆ save()

save ( $data )

Method to save the configuration data.

Paramètres
array $data An array containing all global config data.
Renvoie
boolean True on success, false on failure.
Depuis
3.2
Exceptions

Références $context, $data, $field, $form, $name, $result, $root, Text\_(), Access\checkGroup(), Factory\getApplication(), Table\getInstance(), Factory\getUser(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Config
  • Administrator
  • View
  • Application
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$state
$form
$data
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for the global configuration

Depuis
3.2

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.2

Références Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ToolbarHelper\help(), ToolbarHelper\inlinehelp(), ToolbarHelper\save(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
::loadTemplate()
Depuis
3.0

Implémente ViewInterface.

Références $data, $form, $user, Factory\getApplication(), ConfigHelper\getComponentsWithConfig(), Joomla\CMS\User\getCurrentUser(), ComponentHelper\getParams(), et ConfigHelper\loadLanguageForComponents().

Documentation des champs

◆ $data

$data

◆ $form

$form

◆ $state

$state
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/View/Application/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Config
  • Administrator
  • View
  • Component
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$state
$form
$component
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for the component configuration

Depuis
3.2

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.2

Références $helpUrl, $language, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\inlinehelp(), null, ToolbarHelper\save(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
::loadTemplate()
Depuis
3.2

Implémente ViewInterface.

Références $component, $form, $user, fieldsets, Factory\getApplication(), ConfigHelper\getComponentsWithConfig(), Joomla\CMS\User\getCurrentUser(), et null.

Documentation des champs

◆ $component

$component

◆ $form

$form

◆ $state

$state
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_config/src/View/Component/HtmlView.php


Joomla CMS: Référence de la classe ApplicationController

  • Joomla
  • Component
  • Config
  • Api
  • Controller
  • ApplicationController
Attributs protégés
Référence de la classe ApplicationController
+ Graphe d'héritage de ApplicationController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'application'
$default_view = 'application'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The application controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'application'
protected

◆ $default_view

$default_view = 'application'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_config/src/Controller/ApplicationController.php


Joomla CMS: Référence de la classe ComponentController

  • Joomla
  • Component
  • Config
  • Api
  • Controller
  • ComponentController
Attributs protégés
Référence de la classe ComponentController
+ Graphe d'héritage de ComponentController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'component'
$default_view = 'component'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The component controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'component'
protected

◆ $default_view

$default_view = 'component'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_config/src/Controller/ComponentController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Config
  • Api
  • View
  • Application
  • JsonapiView
Fonctions membres protégées
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The application view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item, et ExtensionHelper\getExtensionRecord().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_config/src/View/Application/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Config
  • Api
  • View
  • Component
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

displayList (array $items=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The component view

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( array $items = null )

Execute and display a template script.

Paramètres
array | null $items Array of items
Renvoie
string
Depuis
4.0.0

Références $component, $data, $item, $items, $key, $limit, Joomla\Database\Query\$offset, $value, Text\_(), ComponentHelper\getComponent(), Uri\getInstance(), et null.

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item, et ExtensionHelper\getExtensionRecord().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_config/src/View/Component/JsonapiView.php


Joomla CMS: Référence de la classe ConfigController

  • Joomla
  • Component
  • Config
  • Site
  • Controller
  • ConfigController
Fonctions membres publiques
Référence de la classe ConfigController
+ Graphe d'héritage de ConfigController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ()
save ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The JApplication for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object for the request
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cancel()

cancel ( )

Method to handle cancel

Renvoie
void
Depuis
3.2

Références Uri\base().

◆ save()

save ( )

Method to save global configuration.

Renvoie
boolean True on success.
Depuis
3.2

Références $data, $document, $form, $model, $return, Text\_(), Route\_(), Joomla\Application\checkToken(), et ClientHelper\setCredentialsFromRequest().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Controller/ConfigController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Config
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des fonctions membres

◆ cancel()

cancel ( )

Method to handle cancel

Renvoie
void
Depuis
3.2

Références Uri\base().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe ModulesController

  • Joomla
  • Component
  • Config
  • Site
  • Controller
  • ModulesController
Fonctions membres publiques
Référence de la classe ModulesController
+ Graphe d'héritage de ModulesController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object for the request
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cancel()

cancel ( )

Method to handle cancel

Renvoie
void
Depuis
3.2

Références Uri\base().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Controller/ModulesController.php


Joomla CMS: Référence de la classe TemplatesController

  • Joomla
  • Component
  • Config
  • Site
  • Controller
  • TemplatesController
Fonctions membres publiques
Référence de la classe TemplatesController
+ Graphe d'héritage de TemplatesController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ()
save ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object for the request
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cancel()

cancel ( )

Method to handle cancel

Renvoie
boolean True on success.
Depuis
3.2

Références Uri\base().

◆ save()

save ( )

Method to save global configuration.

Renvoie
boolean True on success.
Depuis
3.2

Références $app, $document, $return, Text\_(), Route\_(), Joomla\Application\checkToken(), ClientHelper\setCredentialsFromRequest(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatesController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Config
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_config

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void
Exceptions

Références $task, $this, $user, $view, et elseif.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ConfigModel

  • Joomla
  • Component
  • Config
  • Site
  • Model
  • ConfigModel
Fonctions membres publiques
Référence de la classe ConfigModel
+ Graphe d'héritage de ConfigModel:
FormModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de FormModel
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de FormModel
loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=false)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de FormModel
$forms = array()
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for the global configuration

Depuis
3.2

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get a form object.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
mixed A JForm object on success, false on failure
Depuis
3.2

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Model/ConfigModel.php


Joomla CMS: Référence de la classe FormModel

  • Joomla
  • Component
  • Config
  • Site
  • Model
  • FormModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FormModel
+ Graphe d'héritage de FormModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ConfigModel ModulesModel TemplatesModel

Fonctions membres publiques

checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de FormModelInterface
getForm ($data=array(), $loadData=true)

Fonctions membres protégées

loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=false)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$forms = array()
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Prototype form model.

Voir également
JForm
Depuis
3.2

Documentation des fonctions membres

◆ checkin()

checkin ( $pk = null )

Method to checkin a row.

Paramètres
integer $pk The numeric id of the primary key.
Renvoie
boolean False on failure or error, true otherwise.
Depuis
3.2
Exceptions

Références $user, et Factory\getUser().

◆ checkout()

checkout ( $pk = null )

Method to check-out a row for editing.

Paramètres
integer $pk The numeric id of the primary key.
Renvoie
boolean False on failure or error, true otherwise.
Depuis
3.2

Références $user, Text\_(), et Factory\getUser().

◆ loadForm()

loadForm | ( | $name,
 |  | $source = null,
 |  | $options = array(),
 |  | $clear = false,
 |  | $xpath = false
 | ) |
protected

Method to get a form object.

Paramètres
string | $name | The name of the form.
string | $source | The form source. Can be XML string if file flag is set to false.
array | $options | Optional array of options for the form creation.
boolean | $clear | Optional argument to force load a new form.
string | $xpath | An optional xpath to search for the fields.
Renvoie
mixed JForm object on success, False on error.
Voir également
JForm
Depuis
3.2

Références $data, $form, $hash, $name, $options, Form\addFormPath(), Factory\getApplication(), Form\getInstance(), ArrayHelper\getValue(), JPATH_ADMINISTRATOR, JPATH_SITE, Joomla\CMS\MVC\Model\loadFormData(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
3.2

◆ preprocessData()

preprocessData | ( |  | $context,
 |  | & | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the data.

Paramètres
string | $context | The context identifier.
mixed | &$data | The data to be processed. It gets altered directly.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
3.2

Références $context, $data, Factory\getApplication(), et PluginHelper\importPlugin().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Voir également
Depuis
3.2
Exceptions

Références $data, $form, Factory\getApplication(), et PluginHelper\importPlugin().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
mixed Array of filtered data if valid, false otherwise.
Voir également
JFilterInput
Depuis
3.2

Références $data, $form, $message, $return, et Factory\getApplication().

Documentation des champs

◆ $forms

$forms = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Model/FormModel.php


Joomla CMS: Référence de la classe ModulesModel

  • Joomla
  • Component
  • Config
  • Site
  • Model
  • ModulesModel
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées statiques
Référence de la classe ModulesModel
+ Graphe d'héritage de ModulesModel:
FormModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getPositions ()
- Fonctions membres publiques hérités de FormModel
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres publiques statiques

static | getActivePositions ($clientId, $editPositions=false)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')

Fonctions membres protégées

populateState ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de FormModel
loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=false)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées statiques

static | createOption ($value='', $text='')
static | createOptionGroup ($label='', $options=array())

Membres hérités additionnels

- Attributs protégés hérités de FormModel
$forms = array()
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static $paths

Description détaillée

Config Module model.

Depuis
3.2

Documentation des fonctions membres

◆ createOption()

static createOption | ( | $value = '',
 |  | $text = ''
 | ) |
staticprivate

Create and return a new Option

Paramètres
string | $value | The option value [optional]
string | $text | The option text [optional]
Renvoie
object The option as an object (stdClass instance)
Depuis
3.6.3

Références $option, $text, et $value.

◆ createOptionGroup()

static createOptionGroup | ( | $label = '',
 |  | $options = array()
 | ) |
staticprivate

Create and return a new Option Group

Paramètres
string | $label | Value and label for group [optional]
array | $options | Array of options to insert into group [optional]
Renvoie
array Return the new group as an array
Depuis
3.6.3

Références $label, et $options.

◆ getActivePositions()

static getActivePositions | ( | $clientId,
 |  | $editPositions = false
 | ) |
static

Get a list of modules positions

Paramètres
integer | $clientId | Client ID
boolean | $editPositions | Allow to edit the positions
Renvoie
array A list of positions
Depuis
3.6.3

Références $clientId, $db, $options, $position, $positions, $query, Text\_(), HTMLHelper\_(), Factory\getApplication(), et Factory\getDbo().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
3.2

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getPositions()

getPositions ( )

Method to get list of module positions in current template

Renvoie
array
Depuis
3.2

Références $lang, $option, $path, $position, $text, $value, $xml, Text\_(), Path\clean(), Factory\getApplication(), Factory\getLanguage(), et JPATH_BASE.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.2

Références $app, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
3.2
Exceptions

Références $basePath, $data, $form, $lang, $module, $xml, Text\_(), Form\addFormPath(), Path\clean(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), JPATH_BASE, et Joomla\CMS\MVC\Model\preprocessForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Model/ModulesModel.php


Joomla CMS: Référence de la classe TemplatesModel

  • Joomla
  • Component
  • Config
  • Site
  • Model
  • TemplatesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TemplatesModel
+ Graphe d'héritage de TemplatesModel:
FormModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de FormModel
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de FormModel
loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=false)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$forms = array()
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Template style model.

Depuis
3.2

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A JForm object on success, false on failure
Depuis
3.2

Implémente FormModelInterface.

Références $data, $form, Factory\getApplication(), Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
null
Depuis
3.2

Références ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | Plugin group to load
Renvoie
void
Depuis
3.2
Exceptions

Références $data, $form, $lang, $template, $xml, Text\_(), Path\clean(), Factory\getApplication(), Factory\getLanguage(), JPATH_BASE, et Joomla\CMS\MVC\Model\preprocessForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Model/TemplatesModel.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Config
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Description détaillée

Routing class from com_config

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu
 | ) |  |

Config Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with

Références $app, $menu, $this, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Config
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$form
$data
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$userIsSuperAdmin
$pageclass_sfx = ''
$params = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for the global configuration

Depuis
3.2

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
4.0.0

Références $params, et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.2

Implémente ViewInterface.

Références $form, $user, et Joomla\CMS\User\getCurrentUser().

Documentation des champs

◆ $data

$data

◆ $form

$form

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $userIsSuperAdmin

$userIsSuperAdmin
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/View/Config/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Modules
  • HtmlView
Champs de données | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$item
$form
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View to edit a module.

Depuis
3.2

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
4.0.0

Références Text\_().

Documentation des champs

◆ $form

$form

◆ $item

$item
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/View/Modules/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Config
  • Site
  • View
  • Templates
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$item
$form
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$userIsSuperAdmin
$pageclass_sfx = ''
$params = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

View to edit a template style.

Depuis
3.2

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
4.0.0

Références $params, et Factory\getApplication().

Documentation des champs

◆ $form

$form

◆ $item

$item

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $userIsSuperAdmin

$userIsSuperAdmin
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_config/src/View/Templates/HtmlView.php


Joomla CMS: Référence de la classe AjaxController

  • Joomla
  • Component
  • Contact
  • Administrator
  • Controller
  • AjaxController
Fonctions membres publiques
Référence de la classe AjaxController
+ Graphe d'héritage de AjaxController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

fetchAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The contact controller for ajax requests

Depuis
3.9.0

Documentation des fonctions membres

◆ fetchAssociations()

fetchAssociations ( )

Method to fetch associations of a contact

The method assumes that the following http parameters are passed in an Ajax Get request: token: the form token assocId: the id of the contact whose associations are to be returned excludeLang: the association for this language is to be excluded

Renvoie
void
Depuis
3.9.0

Références $lang, $message, Text\_(), Session\checkToken(), elseif, Associations\getAssociations(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/Controller/AjaxController.php


Joomla CMS: Référence de la classe ContactController

  • Joomla
  • Component
  • Contact
  • Administrator
  • Controller
  • ContactController
Fonctions membres protégées
Référence de la classe ContactController
+ Graphe d'héritage de ContactController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
postSaveHook (BaseDatabaseModel $model, $validData=[])
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller for a single contact

Depuis
1.6

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $data, et ArrayHelper\getValue().

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $canEditOwn, $data, $item, $key, $recordId, et $user.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = []
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
4.1.0

Références $id, $link, $model, $type, et Route\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/src/Controller/ContactController.php


Joomla CMS: Référence de la classe ContactsController

  • Joomla
  • Component
  • Contact
  • Administrator
  • Controller
  • ContactsController
Fonctions membres publiques
Référence de la classe ContactsController
+ Graphe d'héritage de ContactsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Contact', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Contacts list controller class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Contact',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model.
string | $prefix | The prefix for the PHP class name.
array | $config | Array of configuration parameters.
Renvoie
Depuis
1.6

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactsController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Contact
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'contacts'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchaining.Falseonfailure.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'contacts'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe ContactComponent

  • Joomla
  • Component
  • Contact
  • Administrator
  • Extension
  • ContactComponent
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe ContactComponent
+ Graphe d'héritage de ContactComponent:
MVCComponent BootableExtensionInterface CategoryServiceInterface FieldsServiceInterface AssociationServiceInterface RouterServiceInterface TagServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
validateSection ($section, $item=null)
getContexts ()
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de CategoryServiceInterface
getCategory (array $options=[], $section='')
countItems (array $items, string $section)
prepareForm (Form $form, $data)
- Fonctions membres publiques hérités de AssociationServiceInterface
getAssociationsExtension ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
- Fonctions membres publiques hérités de TagServiceInterface
countTagItems (array $items, string $extension)

Champs de données

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait

Fonctions membres protégées

getTableNameForSection (string $section=null)
getStateColumnForSection (string $section=null)

Description détaillée

Component class for com_contact

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références $container, class, et Joomla\CMS\HTML\getRegistry().

◆ getContexts()

getContexts ( )

Returns valid contexts

Renvoie
array
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références Text\_(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ getStateColumnForSection()

getStateColumnForSection ( string $section = null )
protected

Returns the state column for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

◆ getTableNameForSection()

getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Références $section.

◆ validateSection()

validateSection | ( | $section,
 |  | $item = null
 | ) |

Returns a valid section for the given section. If it is not valid then null is returned.

Paramètres
string | $section | The section to get the mapping for
object | $item | The item
Renvoie
string|null The new section
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $item, $section, Factory\getApplication(), et null.

Documentation des champs

◆ TagServiceTrait

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactComponent.php


Joomla CMS: Référence de la classe ContactField

  • Joomla
  • Component
  • Contact
  • Administrator
  • Field
  • Modal
  • ContactField
Fonctions membres protégées | Attributs protégés
Référence de la classe ContactField
+ Graphe d'héritage de ContactField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Contact'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal contact picker.

Depuis
1.6

Documentation des fonctions membres

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.4

Documentation des champs

◆ $type

$type = 'Modal_Contact'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactField.php


Joomla CMS: Référence de la classe AssociationsHelper

  • Joomla
  • Component
  • Contact
  • Administrator
  • Helper
  • AssociationsHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe AssociationsHelper
+ Graphe d'héritage de AssociationsHelper:
AssociationExtensionHelper AssociationExtensionInterface

Fonctions membres publiques

getAssociationsForItem ($id=0, $view=null)
getAssociations ($typeName, $id)
getItem ($typeName, $id)
getType ($typeName='')
- Fonctions membres publiques hérités de AssociationExtensionHelper
hasAssociationsSupport ()
getItemTypes ()
getAssociationList ($typeName, $itemId)
getType ($typeName='')
getTypeFields ($typeName)
getTypeSupport ($typeName)
getTypeTables ($typeName)
getTypeJoins ($typeName)
getTypeTitle ($typeName)
getTypeFieldName ($typeName, $fieldName)

Attributs protégés

$extension = 'com_contact'
$itemTypes = array('contact', 'category')
$associationsSupport = true
- Attributs protégés hérités de AssociationExtensionHelper
$extension = 'com_??'
$itemTypes = array()
$associationsSupport = false

Membres hérités additionnels

- Fonctions membres protégées hérités de AssociationExtensionHelper
getSupportTemplate ()
getFieldsTemplate ()

Description détaillée

Content associations helper.

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociations()

getAssociations | ( | $typeName,
 |  | $id
 | ) |

Get the associated items for an item

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $context, $id, $type, extension, et Associations\getAssociations().

◆ getAssociationsForItem()

getAssociationsForItem | ( | $id = 0,
 |  | $view = null
 | ) |

Method to get the associations for a given item.

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
4.0.0

Implémente AssociationExtensionInterface.

Références $id, $view, et AssociationHelper\getAssociations().

◆ getItem()

getItem | ( | $typeName,
 |  | $id
 | ) |

Get item information

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
Table|null
Depuis
3.7.0

Références $id, Table\getInstance(), et null.

◆ getType()

getType ( $typeName = '' )

Get information about the type

Paramètres
string $typeName The item type
Renvoie
array Array of item types
Depuis
3.7.0

Références $fields, et $title.

Documentation des champs

◆ $associationsSupport

boolean $associationsSupport = true
protected

Has the extension association support

Depuis
3.7.0

◆ $extension

array $extension = 'com_contact'
protected

The extension name

Depuis
3.7.0

◆ $itemTypes

array $itemTypes = array('contact', 'category')
protected

Array of item types

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/Helper/AssociationsHelper.php


Joomla CMS: Référence de la classe ContactHelper

  • Joomla
  • Component
  • Contact
  • Administrator
  • Helper
  • ContactHelper
Référence de la classe ContactHelper
+ Graphe d'héritage de ContactHelper:
ContentHelper ContactHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Contact component helper.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactHelper.php


Joomla CMS: Référence de la classe ContactModel

  • Joomla
  • Component
  • Contact
  • Administrator
  • Model
  • ContactModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ContactModel
+ Graphe d'héritage de ContactModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface FormModel ContactModel

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
featured ($pks, $value=0)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_contact.contact'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

batchUser ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
loadFormData ()
prepareTable ($table)
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$associationsContext = 'com_contact.item'
$batch_copymove = 'category_id'
$batch_commands
$formName = 'contact'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

canCreateCategory ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Item Model for a Contact.

Depuis
1.6

Documentation des fonctions membres

◆ batchUser()

batchUser | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch change a linked user.

Paramètres
integer | $value | The new value matching a User ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
2.5

Références $value, et Text\_().

◆ canCreateCategory()

canCreateCategory ( )
private

Is the user allowed to create an on the fly category?

Renvoie
boolean
Depuis
3.6.1

Références Factory\getUser().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state edited.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ featured()

featured | ( | $pks,
 |  | $value = 0
 | ) |

Method to toggle the featured setting of contacts.

Paramètres
array | $pks | The ids of the items to toggle.
integer | $value | The value to toggle to.
Renvoie
boolean True on success.
Depuis
1.6

Références $db, $query, $value, Text\_(), Joomla\Database\getDatabase(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $data, $form, Form\addFieldPath(), Factory\getUser(), JPATH_ADMINISTRATOR, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $assoc, $item, Associations\getAssociations(), Associations\isEnabled(), et null.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
\Joomla\CMS\Table\Table $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $data, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\preprocessData().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table prior to saving.

Paramètres
\Joomla\CMS\Table\Table $table The Table object
Renvoie
void
Depuis
1.6

Références $date, $db, $query, ENT_QUOTES, Joomla\Database\getDatabase(), Factory\getDate(), et Factory\getUser().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Preprocess the form.

Paramètres
Form | $form | Form object.
object | $data | Data object.
string | $group | Group name.
Renvoie
void
Depuis
3.0.3

Références $data, $field, $fields, $form, $language, $languages, Associations\isEnabled(), null, et Joomla\CMS\MVC\Model\preprocessForm().

Documentation des champs

◆ $associationsContext

$associationsContext = 'com_contact.item'
protected

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage',
'tag' => 'batchTag',
'user_id' => 'batchUser',
)

◆ $batch_copymove

$batch_copymove = 'category_id'
protected

◆ $formName

$formName = 'contact'
protected

◆ $typeAlias

$typeAlias = 'com_contact.contact'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/src/Model/ContactModel.php


Joomla CMS: Référence de la classe ContactsModel

  • Joomla
  • Component
  • Contact
  • Administrator
  • Model
  • ContactsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ContactsModel
+ Graphe d'héritage de ContactsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.name', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of contact records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, Symfony\Contracts\Service\__construct(), et Associations\isEnabled().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $db, $language, $published, $query, $user, elseif, Joomla\Database\getDatabase(), Table\getInstance(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, Associations\isEnabled(), et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $layout, $ordering, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactsModel.php


Joomla CMS: Référence de la classe AdministratorService

  • Joomla
  • Component
  • Contact
  • Administrator
  • Service
  • HTML
  • AdministratorService
Fonctions membres publiques
Référence de la classe AdministratorService

Fonctions membres publiques

association ($contactid)
featured ($value, $i, $canChange=true)

Description détaillée

Contact HTML helper class.

Depuis
1.6

Documentation des fonctions membres

◆ association()

association ( $contactid )

Get the associated language flags

Paramètres
integer $contactid The item id to search associations
Renvoie
string The language HTML
Exceptions

Références $classes, $content_languages, $db, $html, $item, $items, $languages, $query, $text, $tooltip, $url, Route\_(), ENT_QUOTES, Factory\getApplication(), Associations\getAssociations(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), et Text\sprintf().

◆ featured()

featured | ( | $value,
 |  | $i,
 |  | $canChange = true
 | ) |

Show the featured/not-featured icon.

Paramètres
integer | $value | The featured value.
integer | $i | Id of the item.
boolean | $canChange | Whether the value can be changed or not.
Renvoie
string The anchor tag to toggle featured/unfeatured contacts.
Depuis
1.6

Références $i, $icon, $onclick, $state, $value, et ArrayHelper\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/Service/HTML/AdministratorService.php


Joomla CMS: Référence de la classe Icon

  • Joomla
  • Component
  • Contact
  • Administrator
  • Service
  • HTML
  • Icon
Fonctions membres publiques | Attributs privés
Référence de la classe Icon

Fonctions membres publiques

__construct (UserFactoryInterface $userFactory)
create ($category, $params, $attribs=array())
edit ($contact, $params, $attribs=array(), $legacy=false)

Attributs privés

$userFactory

Description détaillée

Content Component HTML Helper

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( UserFactoryInterface $userFactory )

Service constructor

Paramètres
UserFactoryInterface $userFactory The userFactory
Depuis
4.0.0

Références Joomla\CMS\Application\$userFactory.

Documentation des fonctions membres

◆ create()

create | ( | $category,
 |  | $params,
 |  | $attribs = array()
 | ) |

Method to generate a link to the create item page for the given category

Paramètres
object | $category | The category information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
Renvoie
string The HTML markup for the create item link
Depuis
4.0.0

Références $attribs, $button, $category, $params, $text, $uri, $url, Text\_(), Route\_(), HTMLHelper\_(), et Uri\getInstance().

◆ edit()

edit | ( | $contact,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |

Display an edit icon for the contact.

This icon will not display in a popup window, nor if the contact is trashed. Edit access checks must be performed in the calling code.

Paramètres
object | $contact | The contact information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML for the contact edit icon.
Depuis
4.0.0

Références $aria_described, $attribs, $date, $icon, $nowDate, $output, $params, $text, $tooltip, $uri, $url, $user, Text\_(), Route\_(), HTMLHelper\_(), RouteHelper\getContactRoute(), Factory\getDate(), Uri\getInstance(), Factory\getUser(), null, LayoutHelper\render(), et Text\sprintf().

Documentation des champs

◆ $userFactory

$userFactory
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/Service/HTML/Icon.php


Joomla CMS: Référence de la classe ContactTable

  • Joomla
  • Component
  • Contact
  • Administrator
  • Table
  • ContactTable
Fonctions membres publiques | Attributs protégés
Référence de la classe ContactTable
+ Graphe d'héritage de ContactTable:
Table VersionableTableInterface TaggableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface TableInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=true)
check ()
generateAlias ()
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Attributs protégés

$_supportNullValue = true
$_jsonEncode = array('params', 'metadata')
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Contact Table class.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
1.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success, false on failure
Voir également
::check
Depuis
1.5

Implémente TableInterface.

Références Text\_(), InputFilter\checkAttribute(), hits, name, null, et StringHelper\str_ireplace().

◆ generateAlias()

generateAlias ( )

Generate a valid alias from title / date. Remains public to be able to check for duplicated alias before saving

Renvoie
string

Références $name, Factory\getDate(), language, et ApplicationHelper\stringURLSafe().

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente TaggableTableInterface.

◆ store()

store ( $updateNulls = true )

Stores a contact.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success, false on failure.
Depuis
1.6

Implémente TableInterface.

Références $date, $userId, Text\_(), PunycodeHelper\emailToPunycode(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Table\getInstance(), Factory\getUser(), null, et PunycodeHelper\urlToPunycode().

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = array('params', 'metadata')
protected

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Administrator
  • View
  • Contact
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a contact.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), ToolbarHelper\help(), ComponentHelper\isEnabled(), Associations\isEnabled(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références Factory\getApplication(), et null.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/src/View/Contact/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Administrator
  • View
  • Contacts
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of contacts.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, $user, Text\_(), ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $item, Factory\getApplication(), Multilanguage\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/src/View/Contacts/HtmlView.php


Joomla CMS: Référence de la classe ContactController

  • Joomla
  • Component
  • Contact
  • Api
  • Controller
  • ContactController
Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ContactController
+ Graphe d'héritage de ContactController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres protégées

preprocessSaveData (array $data)
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'contacts'
$default_view = 'contacts'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

_sendEmail ($data, $contact, $emailCopyToSender)

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The contact controller

Depuis
4.0.0

Documentation des fonctions membres

◆ _sendEmail()

_sendEmail | ( | $data,
 |  | $contact,
 |  | $emailCopyToSender
 | ) |
private

Method to get a model object, loading it if required.

Paramètres
array | $data | The data to send in the email.
\stdClass | $contact | The user information to send the email to
boolean | $emailCopyToSender | True to send a copy of the email to the user.
Renvoie
boolean True on success sending the email, false on failure.
Depuis
1.6.4

Références $app, $data, $fields, $output, Text\_(), Log\add(), MailTemplate\addRecipient(), Uri\base(), PunycodeHelper\emailToPunycode(), Factory\getApplication(), FieldsHelper\getFields(), User\getInstance(), Factory\getLanguage(), JPATH_SITE, FieldsHelper\render(), et Log\WARNING.

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0

Références $data, $field, et FieldsHelper\getFields().

Documentation des champs

◆ $contentType

$contentType = 'contacts'
protected

◆ $default_view

$default_view = 'contacts'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_contact/src/Controller/ContactController.php


Joomla CMS: Référence de la classe ContactSerializer

  • Joomla
  • Component
  • Contact
  • Api
  • Serializer
  • ContactSerializer
Fonctions membres publiques
Référence de la classe ContactSerializer
+ Graphe d'héritage de ContactSerializer:
JoomlaSerializer AbstractSerializer SerializerInterface

Fonctions membres publiques

languageAssociations ($model)
category ($model)
createdBy ($model)
modifiedBy ($model)
userId ($model)
- Fonctions membres publiques hérités de JoomlaSerializer
__construct (string $type)
- Fonctions membres publiques hérités de AbstractSerializer
getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Membres hérités additionnels

- Attributs protégés hérités de AbstractSerializer
$type

Description détaillée

Temporary serializer

Depuis
4.0.0

Documentation des fonctions membres

◆ category()

category ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ createdBy()

createdBy ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ languageAssociations()

languageAssociations ( $model )

Build content relationships by associations

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ modifiedBy()

modifiedBy ( $model )

Build editor relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ userId()

userId ( $model )

Build contact user relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactSerializer.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Contact
  • Api
  • View
  • Contacts
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[])
displayList (array $items=null)
displayItem ($item=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
$relationship
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The contacts view

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config A named configuration array for object construction. contentType: the name (optional) of the content type to use for the serialization
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ displayItem()

displayItem ( $item = null )

Execute and display a template script.

Paramètres
object $item Item
Renvoie
string
Depuis
4.0.0

Références $field, FieldsHelper\getFields(), et Multilanguage\isEnabled().

◆ displayList()

displayList ( array $items = null )

Execute and display a template script.

Paramètres
array | null $items Array of items
Renvoie
string
Depuis
4.0.0

Références $field, et FieldsHelper\getFields().

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $field, $item, et FieldsHelper\getFields().

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'alias',
'name',
'category',
'created',
'created_by',
'created_by_alias',
'modified',
'modified_by',
'image',
'tags',
'user_id',
]

◆ $relationship

$relationship
protected
Valeur initiale :
= [
'category',
'created_by',
'modified_by',
'user_id',
'tags',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/View/Contacts/JsonapiView.php


Joomla CMS: Référence de la classe ContactController

  • Joomla
  • Component
  • Contact
  • Site
  • Controller
  • ContactController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ContactController
+ Graphe d'héritage de ContactController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='form', $prefix='', $config=array('ignore_request'=> true))
submit ()
cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=0, $urlVar='id')
getReturnPage ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$view_item = 'form'
$view_list = 'categories'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

_sendEmail ($data, $contact, $emailCopyToSender)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller for single contact view

Depuis
1.5.19

Documentation des fonctions membres

◆ _sendEmail()

_sendEmail | ( | $data,
 |  | $contact,
 |  | $emailCopyToSender
 | ) |
private

Method to get a model object, loading it if required.

Paramètres
array | $data | The data to send in the email.
\stdClass | $contact | The user information to send the email to
boolean | $emailCopyToSender | True to send a copy of the email to the user.
Renvoie
boolean True on success sending the email, false on failure.
Depuis
1.6.4

Références $app, $data, $fields, $output, Text\_(), Log\add(), MailTemplate\addRecipient(), Uri\base(), PunycodeHelper\emailToPunycode(), FieldsHelper\getFields(), User\getInstance(), FieldsHelper\render(), et Log\WARNING.

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

Références $data, $user, et ArrayHelper\getValue().

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key; default is id.
Renvoie
boolean
Depuis
4.0.0

Références $data, $key, $recordId, $this, $user, et if.

◆ cancel()

cancel ( $key = null )

Method to cancel an edit.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
4.0.0

Références $key, $result, et Route\_().

◆ getModel()

getModel | ( | $name = 'form',
 |  | $prefix = '',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6.4

Références $name, et $prefix.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = 0,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, $itemId, $recordId, $return, et $tmpl.

◆ getReturnPage()

getReturnPage ( )
protected

Get the return URL.

If a "return" variable has been passed in the request

Renvoie
string The return URL.
Depuis
4.0.0

Références $return, Uri\base(), Uri\isInternal(), et null.

◆ submit()

submit ( )

Method to submit the contact form and send an email.

Renvoie
boolean True on success sending the email. False on failure.
Depuis
1.5.19

Références $active, $app, $data, $form, $id, $model, $result, $results, Text\_(), Route\_(), Joomla\Application\checkToken(), Factory\getSession(), PluginHelper\importPlugin(), et null.

Documentation des champs

◆ $view_item

$view_item = 'form'
protected

◆ $view_list

$view_list = 'categories'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Controller/ContactController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Contact
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Contact Component Controller

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object for the request
Depuis
3.0

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnDisplayControllerThisobjecttosupportchaining.@since1.5

Références $this, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Contact
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

dispatch ()
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Membres hérités additionnels

- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_contact

Depuis
4.0.0

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références Text\_(), et JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AssociationHelper

  • Joomla
  • Component
  • Contact
  • Site
  • Helper
  • AssociationHelper
Fonctions membres publiques statiques
Référence de la classe AssociationHelper
+ Graphe d'héritage de AssociationHelper:
CategoryAssociationHelper

Fonctions membres publiques statiques

static | getAssociations ($id=0, $view=null)
- Fonctions membres publiques statiques hérités de CategoryAssociationHelper
static | getCategoryAssociations ($id=0, $extension='com_content', $layout=null)

Membres hérités additionnels

- Attributs publics statiques hérités de CategoryAssociationHelper
static $category_association = true

Description détaillée

Contact Component Association Helper

Depuis
3.0

Documentation des fonctions membres

◆ getAssociations()

static getAssociations | ( | $id = 0,
 |  | $view = null
 | ) |
static

Method to get the associations for a given item

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
3.0

Références $id, $item, $return, $view, Factory\getApplication(), Associations\getAssociations(), et RouteHelper\getContactRoute().

Référencé par AssociationsHelper\getAssociationsForItem().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/Helper/AssociationHelper.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • Component
  • Contact
  • Site
  • Helper
  • RouteHelper
Fonctions membres publiques statiques
Référence de la classe RouteHelper
+ Graphe d'héritage de RouteHelper:
ContactHelperRoute

Fonctions membres publiques statiques

static | getContactRoute ($id, $catid, $language=0)
static | getCategoryRoute ($catid, $language=0)

Documentation des fonctions membres

◆ getCategoryRoute()

static getCategoryRoute | ( | $catid,
 |  | $language = 0
 | ) |
static

Get the URL route for a contact category from a contact category ID and language

Paramètres
mixed | $catid | The id of the contact's category either an integer id or an instance of CategoryNode
mixed | $language | The id of the language being used.
Renvoie
string The link to the contact
Depuis
1.5

Références $id, $language, $link, et Multilanguage\isEnabled().

Référencé par HtmlView\_prepareDocument(), et HtmlView\prepareDocument().

◆ getContactRoute()

static getContactRoute | ( | $id,
 |  | $catid,
 |  | $language = 0
 | ) |
static

Get the URL route for a contact from a contact ID, contact category ID and language

Paramètres
integer | $id | The id of the contact
integer | $catid | The id of the contact's category
mixed | $language | The id of the language being used.
Renvoie
string The link to the contact
Depuis
1.5

Références $id, $language, $link, et Multilanguage\isEnabled().

Référencé par Icon\edit(), et AssociationHelper\getAssociations().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe CategoriesModel

  • Joomla
  • Component
  • Contact
  • Site
  • Model
  • CategoriesModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe CategoriesModel
+ Graphe d'héritage de CategoriesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
getParent ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$_context = 'com_contact.categories'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_extension = 'com_contact'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$_parent = null
$_items = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving lists of contact categories.

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( )

Redefine the function and add some properties to make the styling easier

Renvoie
mixed An array of data items on success, false on failure.

Implémente ListModelInterface.

Références $active, $app, $menu, $options, $params, Factory\getApplication(), Categories\getInstance(), Joomla\CMS\MVC\Model\getState(), et null.

◆ getParent()

getParent ( )

Gets the id of the parent category for the selected list of categories

Renvoie
integer The id of the parent category
Depuis
1.6.0

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_contact.categories'

◆ $_extension

$_extension = 'com_contact'
protected

◆ $_items

$_items = null
private

◆ $_parent

$_parent = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Model/CategoriesModel.php


Joomla CMS: Référence de la classe CategoryModel

  • Joomla
  • Component
  • Contact
  • Site
  • Model
  • CategoryModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe CategoryModel
+ Graphe d'héritage de CategoryModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
getCategory ()
getParent ()
& getLeftSibling ()
& getRightSibling ()
& getChildren ()
hit ($pk=0)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_item
$_articles
$_siblings
$_children
$_parent
$_category
$_categories
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getSlugColumn ($query, $id, $alias)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getCategory()

getCategory ( )

Method to get category data for the current category

Renvoie
object The category object
Depuis
1.5

Références $active, $app, $menu, $options, $params, Factory\getApplication(), Categories\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ getChildren()

& getChildren ( )

Get the child categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Tree\$_children, et Joomla\CMS\Categories\getCategory().

◆ getItems()

getItems ( )

Method to get a list of items.

Renvoie
mixed An array of objects on success, false on failure.

Implémente ListModelInterface.

Références $id, $item, $itemIds, $items, et Joomla\CMS\MVC\Model\getState().

◆ getLeftSibling()

& getLeftSibling ( )

Get the sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ getParent()

getParent ( )

Get the parent category.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ getRightSibling()

& getRightSibling ( )

Get the sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ getSlugColumn()

getSlugColumn | ( | $query,
 |  | $id,
 |  | $alias
 | ) |
private

Generate column expression for slug or catslug.

Paramètres
\Joomla\Database\DatabaseQuery | $query | Current query instance.
string | $id | Column id name.
string | $alias | Column alias name.
Renvoie
string
Depuis
4.0.0

Références $id, et $query.

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the category.

Paramètres
integer $pk Optional primary key of the category to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.
Depuis
3.2

Références $input, Factory\getApplication(), Table\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $format, $id, $itemid, $limit, $listOrder, $menu, $params, $user, Factory\getApplication(), ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_articles

$_articles
protected

◆ $_categories

$_categories
protected

◆ $_category

$_category
protected

◆ $_children

$_children
protected

◆ $_item

$_item
protected

◆ $_parent

$_parent
protected

◆ $_siblings

$_siblings
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Model/CategoryModel.php


Joomla CMS: Référence de la classe ContactModel

  • Joomla
  • Component
  • Contact
  • Site
  • Model
  • ContactModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ContactModel
+ Graphe d'héritage de ContactModel:
FormModel ContactModel AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
hit ($pk=0)
- Fonctions membres publiques hérités de FormModel
getForm ($data=array(), $loadData=true)
getItem ($itemId=null)
getReturnPage ()
save ($data)
getTable ($name='Contact', $prefix='Administrator', $options=array())
- Fonctions membres publiques hérités de ContactModel
getForm ($data=array(), $loadData=true)
getItem ($pk=null)
featured ($pks, $value=0)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
buildContactExtendedData ($contact)
- Fonctions membres protégées hérités de FormModel
populateState ()
preprocessForm (Form $form, $data, $group='contact')
- Fonctions membres protégées hérités de ContactModel
batchUser ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
loadFormData ()
prepareTable ($table)
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$view_item = 'contact'
$_item = null
$_context = 'com_contact.contact'
- Attributs protégés hérités de FormModel
$formName = 'form'
- Attributs protégés hérités de ContactModel
$associationsContext = 'com_contact.item'
$batch_copymove = 'category_id'
$batch_commands
$formName = 'contact'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getSlugColumn ($query, $id, $alias)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de FormModel
$typeAlias = 'com_contact.contact'
- Champs de données hérités de ContactModel
$typeAlias = 'com_contact.contact'
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Documentation des fonctions membres

◆ buildContactExtendedData()

buildContactExtendedData ( $contact )
protected

Load extended data (profile, articles) for a contact

Paramètres
object $contact The contact object
Renvoie
void

Références $data, $db, $form, $groups, $language, $nowDate, $published, $query, $this, $user, Form\addFormPath(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getDate(), Form\getInstance(), Factory\getLanguage(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), PluginHelper\importPlugin(), ParameterType\INTEGER, Multilanguage\isEnabled(), JPATH_SITE, null, et ParameterType\STRING.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the contact form. The base form is loaded from XML and then an event is fired

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $active, $form, $temp, class, Factory\getContainer(), Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Gets a contact

Paramètres
integer $pk Id for the contact
Renvoie
mixed Object or null
Depuis
1.6.0

In case some entity params have been set to "use global", those are represented as an empty string and must be "overridden" by merging the component and / or menu params here.

Références $data, $db, $groups, $nowDate, $published, $query, $user, Text\_(), Joomla\Database\getDatabase(), Factory\getDate(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, et null.

◆ getSlugColumn()

getSlugColumn | ( | $query,
 |  | $id,
 |  | $alias
 | ) |
private

Generate column expression for slug or catslug.

Paramètres
QueryInterface | $query | Current query instance.
string | $id | Column id name.
string | $alias | Column alias name.
Renvoie
string
Depuis
4.0.0

Références $id, et $query.

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the contact.

Paramètres
integer $pk Optional primary key of the contact to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.
Depuis
3.0

Références $input, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
1.6.2

Références $data, Factory\getApplication(), Factory\getLanguage(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\preprocessData().

Documentation des champs

◆ $_context

$_context = 'com_contact.contact'
protected

◆ $_item

$_item = null
protected

◆ $view_item

$view_item = 'contact'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Model/ContactModel.php


Joomla CMS: Référence de la classe FeaturedModel

  • Joomla
  • Component
  • Contact
  • Site
  • Model
  • FeaturedModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FeaturedModel
+ Graphe d'héritage de FeaturedModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
populateState ($ordering=null, $direction=null)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Featured contact model class.

Depuis
1.6.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of items.

Renvoie
mixed An array of objects on success, false on failure.

Implémente ListModelInterface.

Références $i, $item, $items, et $n.

◆ getListQuery()

getListQuery ( )
protected

Method to build an SQL query to load the list data.

Renvoie
string An SQL query
Depuis
1.6

Références $db, $groups, $nowDate, $query, $state, $this, $user, Joomla\Database\getDatabase(), Factory\getDate(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, et ParameterType\STRING.

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $limit, $listOrder, $params, $user, Factory\getApplication(), ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Model/FeaturedModel.php


Joomla CMS: Référence de la classe FormModel

  • Joomla
  • Component
  • Contact
  • Site
  • Model
  • FormModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe FormModel
+ Graphe d'héritage de FormModel:
ContactModel AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ContactModel

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($itemId=null)
getReturnPage ()
save ($data)
getTable ($name='Contact', $prefix='Administrator', $options=array())
- Fonctions membres publiques hérités de ContactModel
getForm ($data=array(), $loadData=true)
getItem ($pk=null)
featured ($pks, $value=0)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_contact.contact'
- Champs de données hérités de ContactModel
$typeAlias = 'com_contact.contact'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

populateState ()
preprocessForm (Form $form, $data, $group='contact')
- Fonctions membres protégées hérités de ContactModel
batchUser ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
loadFormData ()
prepareTable ($table)
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$formName = 'form'
- Attributs protégés hérités de ContactModel
$associationsContext = 'com_contact.item'
$batch_copymove = 'category_id'
$batch_commands
$formName = 'contact'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Contact Component Contact Model

Depuis
4.0.0

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $data, $form, $id, Associations\getAssociations(), Joomla\CMS\MVC\Model\getState(), et Associations\isEnabled().

◆ getItem()

getItem ( $itemId = null )

Method to get contact data.

Paramètres
integer $itemId The id of the contact.
Renvoie
mixed Contact item data object on success, false on failure.
Exceptions
Exception
Depuis
4.0.0

Références $itemId, $value, class, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getReturnPage()

getReturnPage ( )

Get the return URL.

Renvoie
string The return URL.
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\getState().

◆ getTable()

getTable | ( | $name = 'Contact',
 |  | $prefix = 'Administrator',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
bool|Table A Table object
Depuis
4.0.0
Exceptions
Exception

Références $name, $options, et $prefix.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
4.0.0
Exceptions
Exception

Références $app, $params, $return, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'contact'
 | ) |  |
protected

Allows preprocessing of the JForm object.

Paramètres
Form | $form | The form object
array | $data | The data to be merged into the form object
string | $group | The plugin group to be executed
Renvoie
void
Depuis
4.0.0

Références $data, $form, Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
4.0.0
Exceptions
Exception

Références $data, Associations\getAssociations(), et Associations\isEnabled().

Documentation des champs

◆ $formName

$formName = 'form'
protected

◆ $typeAlias

$typeAlias = 'com_contact.contact'
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Model/FormModel.php


Joomla CMS: Référence de la classe ContactEmailMessageRule

  • Joomla
  • Component
  • Contact
  • Site
  • Rule
  • ContactEmailMessageRule
Fonctions membres publiques
Référence de la classe ContactEmailMessageRule
+ Graphe d'héritage de ContactEmailMessageRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

FormRule for com_contact to make sure the message body contains no banned word.

Depuis
1.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test a message for banned words

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.

Références $item, $params, $value, ComponentHelper\getParams(), et StringHelper\stristr().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactEmailMessageRule.php


Joomla CMS: Référence de la classe ContactEmailRule

  • Joomla
  • Component
  • Contact
  • Site
  • Rule
  • ContactEmailRule
Fonctions membres publiques
Référence de la classe ContactEmailRule
+ Graphe d'héritage de ContactEmailRule:
EmailRule FormRule DatabaseAwareInterface

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de EmailRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Attributs protégés hérités de EmailRule
$regex
- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

FormRule for com_contact to make sure the email address is not blocked.

Depuis
1.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test for banned email addresses

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.

Références $form, $input, $item, $params, $value, ComponentHelper\getParams(), et StringHelper\stristr().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactEmailRule.php


Joomla CMS: Référence de la classe ContactEmailSubjectRule

  • Joomla
  • Component
  • Contact
  • Site
  • Rule
  • ContactEmailSubjectRule
Fonctions membres publiques
Référence de la classe ContactEmailSubjectRule
+ Graphe d'héritage de ContactEmailSubjectRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

FormRule for com_contact to make sure the subject contains no banned word.

Depuis
1.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test for a banned subject

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise

Références $item, $params, $value, ComponentHelper\getParams(), et StringHelper\stristr().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContactEmailSubjectRule.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • Component
  • Contact
  • Site
  • Service
  • Category
Fonctions membres publiques
Référence de la classe Category
+ Graphe d'héritage de Category:
Categories CategoryInterface DatabaseAwareInterface

Fonctions membres publiques

__construct ($options=array())
- Fonctions membres publiques hérités de Categories
__construct ($options)
get ($id='root', $forceload=false)
getExtension ()
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Categories
static | getInstance ($extension, $options=array())
- Attributs publics statiques hérités de Categories
static | $instances = array()
- Fonctions membres protégées hérités de Categories
_load ($id)
- Attributs protégés hérités de Categories
$_nodes
$_checkedCategories
$_extension = null
$_table = null
$_field = null
$_key = null
$_statefield = null
$_options = []

Description détaillée

Contact Component Category Tree

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Array of options
Depuis
1.6

Références $options, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Service/Category.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Contact
  • Site
  • Service
  • Router
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu, CategoryFactoryInterface $categoryFactory, DatabaseInterface $db)
getCategorySegment ($id, $query)
getCategoriesSegment ($id, $query)
getContactSegment ($id, $query)
getFormSegment ($id, $query)
getCategoryId ($segment, $query)
getCategoriesId ($segment, $query)
getContactId ($segment, $query)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Attributs protégés

$noIDs = false
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Fonctions membres privées

getCategories (array $options=[])

Attributs privés

$categoryFactory
$categoryCache = []
$db

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class from com_contact

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu,
 |  | CategoryFactoryInterface | $categoryFactory,
 |  | DatabaseInterface | $db
 | ) |  |

Content Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with
CategoryFactoryInterface | $categoryFactory | The category object
DatabaseInterface | $db | The database object

Références $app, $category, $db, $form, $menu, $params, $this, Symfony\Contracts\Service\__construct(), et ComponentHelper\getParams().

Documentation des fonctions membres

◆ getCategories()

getCategories ( array $options = [] )
private

Method to get categories from cache

Paramètres
array $options The options for retrieving categories
Renvoie
CategoryInterface The object containing categories
Depuis
4.0.0

Références $key, et $options.

◆ getCategoriesId()

getCategoriesId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query.

◆ getCategoriesSegment()

getCategoriesSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et $query.

◆ getCategoryId()

getCategoryId | ( | $segment,
 |  | $query
 | ) |

Method to get the id for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $category, et $query.

◆ getCategorySegment()

getCategorySegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $category, $id, et $path.

◆ getContactId()

getContactId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for a contact

Paramètres
string | $segment | Segment of the contact to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query, et ParameterType\INTEGER.

◆ getContactSegment()

getContactSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a contact

Paramètres
string | $id | ID of the contact to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et ParameterType\INTEGER.

◆ getFormSegment()

getFormSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a form

Paramètres
string | $id | ID of the contact form to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item
Depuis
4.0.0

Références $id, et $query.

Documentation des champs

◆ $categoryCache

$categoryCache = []
private

◆ $categoryFactory

$categoryFactory
private

◆ $db

$db
private

◆ $noIDs

$noIDs = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Categories
  • HtmlView
Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoriesView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$pageHeading = 'COM_CONTACT_DEFAULT_PAGE_TITLE'
$extension = 'com_contact'
- Attributs protégés hérités de CategoriesView
$state
$items
$pageHeading
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de CategoriesView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de CategoriesView
prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Contact categories view.

Depuis
1.6

Documentation des champs

◆ $extension

$extension = 'com_contact'
protected

◆ $pageHeading

$pageHeading = 'COM_CONTACT_DEFAULT_PAGE_TITLE'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/View/Categories/HtmlView.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Category
  • FeedView
Fonctions membres protégées | Attributs protégés
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
CategoryFeedView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

reconcileNames ($item)
- Fonctions membres protégées hérités de CategoryFeedView
reconcileNames ($item)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$viewName = 'contact'
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de CategoryFeedView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Contact component

Depuis
1.5

Documentation des fonctions membres

◆ reconcileNames()

reconcileNames ( $item )
protected

Method to reconcile non standard names from components to usage in this class. Typically overridden in the component feed view class.

Paramètres
object $item The item for a feed, an element of the $items array.
Renvoie
void
Depuis
3.2

Références $item.

Documentation des champs

◆ $viewName

$viewName = 'contact'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/src/View/Category/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Category
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoryView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de CategoryView
commonCategoryDisplay ()
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de CategoryView
prepareDocument ()
addFeed ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$extension = 'com_contact'
$defaultPageTitle = 'COM_CONTACT_DEFAULT_PAGE_TITLE'
$viewName = 'contact'
$runPlugins = true
- Attributs protégés hérités de CategoryView
$state
$items
$category
$categories
$pagination
$children
$extension
$viewName
$defaultPageTitle
$runPlugins = false
$menuItemMatchCategory = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Contacts component

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $item, $temp, $this, HTMLHelper\_(), MailHelper\isEmailAddress(), et items.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $category, $id, $item, $menu, $path, category, RouteHelper\getCategoryRoute(), et null.

Documentation des champs

◆ $defaultPageTitle

$defaultPageTitle = 'COM_CONTACT_DEFAULT_PAGE_TITLE'
protected

◆ $extension

$extension = 'com_contact'
protected

◆ $runPlugins

$runPlugins = true
protected

◆ $viewName

$viewName = 'contact'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/View/Category/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Contact
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$form
$item
$return_page = ''
$captchaEnabled = false
$params = null
$user
$contacts
$pageclass_sfx = ''
$menuItemMatchContact = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

HTML Contact View class for the Contact component

Depuis
1.5

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
1.6

Références $app, $category, $id, $item, $menu, $path, $title, Text\_(), elseif, Factory\getApplication(), RouteHelper\getCategoryRoute(), Categories\getInstance(), et null.

Documentation des champs

◆ $captchaEnabled

$captchaEnabled = false
protected

◆ $contacts

$contacts
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $menuItemMatchContact

$menuItemMatchContact = false
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $return_page

$return_page = ''
protected

◆ $state

$state
protected

◆ $user

$user
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/View/Contact/HtmlView.php


Joomla CMS: Référence de la classe VcfView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Contact
  • VcfView
Fonctions membres publiques | Attributs protégés
Référence de la classe VcfView
+ Graphe d'héritage de VcfView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$item
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View to create a VCF for a contact item

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
string A string if successful
Exceptions
GenericDataException

Implémente ViewInterface.

Références $item, et Factory\getApplication().

Documentation des champs

◆ $item

$item
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • VcfView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Featured
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$pagination
$params = null
$pageclass_sfx = ''
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Featured View class

Depuis
1.6

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
1.6

Références $menu, Text\_(), et Factory\getApplication().

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références $app, $category, $i, $item, $items, $n, $params, $state, $temp, HTMLHelper\_(), category, children, ENT_COMPAT, Factory\getApplication(), MailHelper\isEmailAddress(), items, maxLevel, et parent.

Documentation des champs

◆ $items

$items
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination
protected

◆ $params

$params = null
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/View/Featured/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contact
  • Site
  • View
  • Form
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$return_page
$pageclass_sfx
$state
$params
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML Contact View class for the Contact component

Depuis
4.0.0

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void
Exceptions

Références $app, $menu, $title, Text\_(), et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void|boolean
Exceptions

Implémente ViewInterface.

Références $app, $authorised, $canDo, $lang, $user, Text\_(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), et Multilanguage\isEnabled().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $pageclass_sfx

$pageclass_sfx
protected

◆ $params

$params
protected

◆ $return_page

$return_page
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contact/src/View/Form/HtmlView.php


Joomla CMS: Référence de la classe AjaxController

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
  • AjaxController
Fonctions membres publiques
Référence de la classe AjaxController
+ Graphe d'héritage de AjaxController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

fetchAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The article controller for ajax requests

Depuis
3.9.0

Documentation des fonctions membres

◆ fetchAssociations()

fetchAssociations ( )

Method to fetch associations of an article

The method assumes that the following http parameters are passed in an Ajax Get request: token: the form token assocId: the id of the article whose associations are to be returned excludeLang: the association for this language is to be excluded

Renvoie
null
Depuis
3.9.0

Références $lang, $message, Text\_(), Session\checkToken(), elseif, Associations\getAssociations(), Table\getInstance(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/Controller/AjaxController.php


Joomla CMS: Référence de la classe ArticleController

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
  • ArticleController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ArticleController
+ Graphe d'héritage de ArticleController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

postSaveHook (BaseDatabaseModel $model, $validData=array())
allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The article controller

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $data, et ArrayHelper\getValue().

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, $key, $recordId, et $user.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
4.0.0

Références $id, $link, $model, $type, et Route\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Controller/ArticleController.php


Joomla CMS: Référence de la classe ArticlesController

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
  • ArticlesController
Fonctions membres publiques
Référence de la classe ArticlesController
+ Graphe d'héritage de ArticlesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface FeaturedController

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Article', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Articles list controller class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Article',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the JSON-encoded amount of published articles

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Controller/ArticlesController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'articles'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Component Controller

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
BaseController|boolean This object to support chaining.
Depuis
1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'articles'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe FeaturedController

  • Joomla
  • Component
  • Content
  • Administrator
  • Controller
  • FeaturedController
Fonctions membres publiques
Référence de la classe FeaturedController
+ Graphe d'héritage de FeaturedController:
ArticlesController AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

publish ()
getModel ($name='Feature', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de ArticlesController
__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Article', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Featured content controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Feature',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ publish()

publish ( )

Method to publish a list of articles.

Renvoie
void
Depuis
1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeaturedController.php


Joomla CMS: Référence de la classe FeatureEvent

  • Joomla
  • Component
  • Content
  • Administrator
  • Event
  • Model
  • FeatureEvent
Fonctions membres publiques
Référence de la classe FeatureEvent
+ Graphe d'héritage de FeatureEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
setAbort (string $reason)
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for WebAsset events

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
4.0.0

Références $name, $parts, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setAbort()

setAbort ( string $reason )

Set used parameter to true

Paramètres
bool $value The value to set
Renvoie
void
Depuis
4.0.0

Référencé par PlgWorkflowFeaturing\onContentBeforeChangeFeatured().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FeatureEvent.php


Joomla CMS: Référence de la classe ContentComponent

  • Joomla
  • Component
  • Content
  • Administrator
  • Extension
  • ContentComponent
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ContentComponent
+ Graphe d'héritage de ContentComponent:
TagServiceInterface RouterServiceInterface WorkflowServiceInterface AssociationServiceInterface FieldsServiceInterface CategoryServiceInterface BootableExtensionInterface MVCComponent

Fonctions membres publiques

boot (ContainerInterface $container)
validateSection ($section, $item=null)
getContexts ()
getWorkflowContexts ()
getCategoryWorkflowContext (?string $section=null)
getWorkflowTableBySection (?string $section=null)
getModelName ($context)
filterTransitions (array $transitions, int $pk)
countItems (array $items, string $section)
countTagItems (array $items, string $extension)
prepareForm (Form $form, $data)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de CategoryServiceInterface
getCategory (array $options=[], $section='')
- Fonctions membres publiques hérités de AssociationServiceInterface
getAssociationsExtension ()
- Fonctions membres publiques hérités de WorkflowServiceInterface
supportFunctionality ($functionality, $context)
isWorkflowActive ($context)
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Champs de données

CategoryServiceTrait::getStateColumnForSection insteadof | TagServiceTrait
const | CONDITION_NAMES
const | CONDITION_ARCHIVED = 2
const | CONDITION_PUBLISHED = 1
const | CONDITION_UNPUBLISHED = 0
const | CONDITION_TRASHED = -2

Fonctions membres protégées

getTableNameForSection (string $section=null)

Attributs protégés

$supportedFunctionality

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de WorkflowServiceInterface
static getConditions (string $extension)

Description détaillée

Component class for com_content

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

◆ countItems()

countItems | ( | array | $items,
 |  | string | $section
 | ) |  |

Adds Count Items for Category Manager.

Paramètres

Implémente CategoryServiceInterface.

Références $config, et $items.

◆ countTagItems()

countTagItems | ( | array | $items,
 |  | string | $extension
 | ) |  |

Adds Count Items for Tag Manager.

Paramètres

Implémente TagServiceInterface.

Références $config, $extension, $items, $parts, $section, et null.

◆ filterTransitions()

filterTransitions | ( | array | $transitions,
 |  | int | $pk
 | ) |  |

Method to filter transitions by given id of state.

Paramètres
array | $transitions | The Transitions to filter
int | $pk | Id of the state
Renvoie
array
Depuis
4.0.0

Implémente WorkflowServiceInterface.

Références $transitions, et ContentHelper\filterTransitions().

◆ getCategoryWorkflowContext()

getCategoryWorkflowContext ( ?string $section = null )

Returns the workflow context based on the given category section

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Implémente WorkflowServiceInterface.

Références $context.

◆ getContexts()

getContexts ( )

Returns valid contexts

Renvoie
array
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références Text\_(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ getModelName()

getModelName ( $context )

Returns the model name, based on the context

Paramètres
string $context The context of the workflow
Renvoie
string

Implémente WorkflowServiceInterface.

Références $context, $parts, elseif, et Factory\getApplication().

◆ getTableNameForSection()

getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

◆ getWorkflowContexts()

getWorkflowContexts ( )

Returns valid contexts

Renvoie
array
Depuis
4.0.0

Implémente WorkflowServiceInterface.

Références Text\_(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ getWorkflowTableBySection()

getWorkflowTableBySection ( ?string $section = null )

Returns a table name for the state association

Paramètres
string $section An optional section to separate different areas in the component
Renvoie
string
Depuis
4.0.0

Implémente WorkflowServiceInterface.

◆ prepareForm()

prepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Prepares the category form

Paramètres
Form | $form | The form to prepare
array | object | $data | The form data
Renvoie
void

Implémente CategoryServiceInterface.

Références $data, $form, et ContentHelper\onPrepareForm().

◆ validateSection()

validateSection | ( | $section,
 |  | $item = null
 | ) |

Returns a valid section for the given section. If it is not valid then null is returned.

Paramètres
string | $section | The section to get the mapping for
object | $item | The item
Renvoie
string|null The new section
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $section, Factory\getApplication(), et null.

Documentation des champs

◆ $supportedFunctionality

$supportedFunctionality
protected
Valeur initiale :
= [
'core.featured' => true

◆ CONDITION_ARCHIVED

const CONDITION_ARCHIVED = 2

The archived condition

Depuis
4.0.0

Référencé par ArticlesArchiveHelper\getList(), ArchiveModel\getYears(), ArchiveModel\populateState(), et ArticleModel\populateState().

◆ CONDITION_NAMES

const CONDITION_NAMES
Valeur initiale :
= [
self::CONDITION_PUBLISHED => 'JPUBLISHED'

The trashed condition

Depuis
4.0.0

◆ CONDITION_PUBLISHED

const CONDITION_PUBLISHED = 1

The published condition

Depuis
4.0.0

Référencé par StatsHelper\getList(), ArticlesPopularHelper\getList(), ArticlesCategoryHelper\getList(), ArticlesModel\getListQuery(), FeaturedModel\populateState(), ArticleModel\populateState(), et ArticlesModel\populateState().

◆ CONDITION_TRASHED

const CONDITION_TRASHED = -2

The trashed condition

Depuis
4.0.0

Référencé par HtmlView\addToolbar().

◆ CONDITION_UNPUBLISHED

const CONDITION_UNPUBLISHED = 0

The unpublished condition

Depuis
4.0.0

Référencé par ArticlesModel\getListQuery(), et FeaturedModel\populateState().

◆ TagServiceTrait

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentComponent.php


Joomla CMS: Référence de la classe ArticleField

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
  • Modal
  • ArticleField
Fonctions membres protégées | Attributs protégés
Référence de la classe ArticleField
+ Graphe d'héritage de ArticleField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Article'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal article picker.

Depuis
1.6

Documentation des fonctions membres

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.4

Documentation des champs

◆ $type

$type = 'Modal_Article'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticleField.php


Joomla CMS: Référence de la classe AssocField

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
  • AssocField
Fonctions membres publiques | Attributs protégés
Référence de la classe AssocField
+ Graphe d'héritage de AssocField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Assoc'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Assoc Field class. Supports a generic list of options. Displays only when Associations are enabled.

Depuis
4.0.0

Documentation des fonctions membres

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
AssocField::setup()
Depuis
4.0.0

Références $value, et Associations\isEnabled().

Documentation des champs

◆ $type

$type = 'Assoc'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AssocField.php


Joomla CMS: Référence de la classe VotelistField

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
  • VotelistField
Fonctions membres publiques | Attributs protégés
Référence de la classe VotelistField
+ Graphe d'héritage de VotelistField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Votelist'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Votelist Field class.

Depuis
4.0.0

Documentation des fonctions membres

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $value, et PluginHelper\isEnabled().

Documentation des champs

◆ $type

$type = 'Votelist'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • VotelistField.php


Joomla CMS: Référence de la classe VoteradioField

  • Joomla
  • Component
  • Content
  • Administrator
  • Field
  • VoteradioField
Fonctions membres publiques | Attributs protégés
Référence de la classe VoteradioField
+ Graphe d'héritage de VoteradioField:
RadioField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Voteradio'
- Attributs protégés hérités de RadioField
$type = 'Radio'
$layout = 'joomla.form.field.radio.buttons'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de RadioField
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Voteradio Field class.

Depuis
3.8.0

Documentation des fonctions membres

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $value, et PluginHelper\isEnabled().

Documentation des champs

◆ $type

$type = 'Voteradio'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • VoteradioField.php


Joomla CMS: Référence de la classe AssociationsHelper

  • Joomla
  • Component
  • Content
  • Administrator
  • Helper
  • AssociationsHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe AssociationsHelper
+ Graphe d'héritage de AssociationsHelper:
AssociationExtensionHelper AssociationExtensionInterface

Fonctions membres publiques

getAssociationsForItem ($id=0, $view=null)
getAssociations ($typeName, $id)
getItem ($typeName, $id)
getType ($typeName='')
- Fonctions membres publiques hérités de AssociationExtensionHelper
hasAssociationsSupport ()
getItemTypes ()
getAssociationList ($typeName, $itemId)
getType ($typeName='')
getTypeFields ($typeName)
getTypeSupport ($typeName)
getTypeTables ($typeName)
getTypeJoins ($typeName)
getTypeTitle ($typeName)
getTypeFieldName ($typeName, $fieldName)

Attributs protégés

$extension = 'com_content'
$itemTypes = array('article', 'category')
$associationsSupport = true
- Attributs protégés hérités de AssociationExtensionHelper
$extension = 'com_??'
$itemTypes = array()
$associationsSupport = false

Membres hérités additionnels

- Fonctions membres protégées hérités de AssociationExtensionHelper
getSupportTemplate ()
getFieldsTemplate ()

Description détaillée

Content associations helper.

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociations()

getAssociations | ( | $typeName,
 |  | $id
 | ) |

Get the associated items for an item

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $context, $id, $type, extension, et Associations\getAssociations().

◆ getAssociationsForItem()

getAssociationsForItem | ( | $id = 0,
 |  | $view = null
 | ) |

Method to get the associations for a given item.

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
4.0.0

Implémente AssociationExtensionInterface.

Références $id, $view, et AssociationHelper\getAssociations().

◆ getItem()

getItem | ( | $typeName,
 |  | $id
 | ) |

Get item information

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
Table|null
Depuis
3.7.0

Références $id, Table\getInstance(), et null.

◆ getType()

getType ( $typeName = '' )

Get information about the type

Paramètres
string $typeName The item type
Renvoie
array Array of item types
Depuis
3.7.0

Références $fields, et $title.

Documentation des champs

◆ $associationsSupport

boolean $associationsSupport = true
protected

Has the extension association support

Depuis
3.7.0

◆ $extension

array $extension = 'com_content'
protected

The extension name

Depuis
3.7.0

◆ $itemTypes

array $itemTypes = array('article', 'category')
protected

Array of item types

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/Helper/AssociationsHelper.php


Joomla CMS: Référence de la classe ContentHelper

  • Joomla
  • Component
  • Content
  • Administrator
  • Helper
  • ContentHelper
Fonctions membres publiques statiques
Référence de la classe ContentHelper
+ Graphe d'héritage de ContentHelper:
ContentHelper ContentHelper

Fonctions membres publiques statiques

static | canDeleteState (int $id)
static | filterTransitions (array $transitions, int $pk, int $workflowId=0)
static | onPrepareForm (Form $form, $data)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Content component helper.

Depuis
1.6

Documentation des fonctions membres

◆ canDeleteState()

static canDeleteState ( int $id )
static

Check if state can be deleted

Paramètres
int $id Id of state to delete
Renvoie
boolean
Depuis
4.0.0

Références $db, $id, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ filterTransitions()

static filterTransitions | ( | array | $transitions,
 |  | int | $pk,
 |  | int | $workflowId = 0
 | ) |  |
static

Method to filter transitions by given id of state

Paramètres
array | $transitions | Array of transitions
int | $pk | Id of state
int | $workflowId | Id of the workflow
Renvoie
array
Depuis
4.0.0

Références $transitions.

Référencé par ContentComponent\filterTransitions().

◆ onPrepareForm()

static onPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |
static

Prepares a form

Paramètres
Form | $form | The form to change
array | object | $data | The form data
Renvoie
void

Références $category, $component, $data, $db, $field, $form, $option, $query, $title, Text\_(), elseif, Factory\getApplication(), Factory\getDbo(), Factory\getLanguage(), ParameterType\INTEGER, JPATH_ADMINISTRATOR, et Text\sprintf().

Référencé par ContentComponent\prepareForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Helper/ContentHelper.php


Joomla CMS: Référence de la classe ArticleModel

  • Joomla
  • Component
  • Content
  • Administrator
  • Model
  • ArticleModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ArticleModel
+ Graphe d'héritage de ArticleModel:
AdminModel WorkflowModelInterface FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface FeatureModel FormModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
publish (&$pks, $value=1)
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
featured ($pks, $value=0, $featuredUp=null, $featuredDown=null)
hit ()
delete (&$pks)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de WorkflowModelInterface
setUpWorkflow ($extension)
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
getState ($property=null, $default=null)
getName ()
getTable ($name='', $prefix='', $options=array())

Champs de données

$typeAlias = 'com_content.article'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchMove ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
prepareTable ($table)
loadFormData ()
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_CONTENT'
$associationsContext = 'com_content.item'
$event_before_change_featured = null
$event_after_change_featured = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

canCreateCategory ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Item Model for an Article.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
FormFactoryInterface | $formFactory | The form factory.
Depuis
1.6
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Joomla\CMS\MVC\Model\setUpWorkflow().

Documentation des fonctions membres

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move categories to a new category.

Paramètres
integer | $value | The new category ID.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True on success.
Depuis
3.8.6

Références $field, $fields, $value, Text\_(), Factory\getApplication(), FieldsHelper\getFields(), Factory\getUser(), PluginHelper\importPlugin(), et Text\sprintf().

◆ canCreateCategory()

canCreateCategory ( )
private

Is the user allowed to create an on the fly category?

Renvoie
boolean
Depuis
3.6.1

Références Factory\getUser().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state edited.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références $user, et Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean the cache of com_content and content modules

Paramètres
string | $group | The cache group
integer | $clientId

◆ cleanupPostBatchCopy()

cleanupPostBatchCopy | ( | TableInterface | $table,
 |  |  | $newId,
 |  |  | $oldId
 | ) |  |
protected

Function that can be overridden to do any data cleanup after batch copying data

Paramètres
TableInterface | $table | The table object containing the newly created item
integer | $newId | The id of the new item
integer | $oldId | The original item id
Renvoie
void
Depuis
3.8.12

Références $db, $field, $fields, $query, Factory\getApplication(), Joomla\Database\getDatabase(), FieldsHelper\getFields(), ParameterType\INTEGER, ParameterType\NULL, ParameterType\STRING, et Joomla\CMS\MVC\Model\workflowCleanupBatchMove().

◆ delete()

delete ( & $pks )

Delete #__content_frontpage items if the deleted articles was featured

Paramètres
object $pks The primary key related to the contents that was deleted.
Renvoie
boolean
Depuis
3.7.0

Références $db, $query, $return, et Joomla\Database\getDatabase().

◆ featured()

featured | ( | $pks,
 |  | $value = 0,
 |  | $featuredUp = null,
 |  | $featuredDown = null
 | ) |

Method to toggle the featured setting of articles.

Paramètres
array | $pks | The ids of the items to toggle.
integer | $value | The value to toggle to.
string | Date | $featuredUp | The date which item featured up.
string | Date | $featuredDown | The date which item featured down.
Renvoie
boolean True on success.

Références $context, $db, $name, $query, $this, $value, Text\_(), AbstractEvent\create(), Factory\getApplication(), Joomla\Database\getDatabase(), PluginHelper\importPlugin(), ParameterType\INTEGER, ParameterType\NULL, null, ParameterType\STRING, ArrayHelper\toInteger(), et Joomla\CMS\MVC\Model\workflowBeforeStageChange().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $app, $data, $form, $id, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), Joomla\CMS\MVC\Model\loadForm(), null, et value.

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.

Références $assoc, $db, $item, $query, Associations\getAssociations(), Joomla\Database\getDatabase(), if, ParameterType\INTEGER, Associations\isEnabled(), et null.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références Joomla\Database\getDatabase().

◆ hit()

hit ( )

Void hit function for pagebreak when editing content from frontend

Renvoie
void
Depuis
3.6.0

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $data, $filters, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table data prior to saving.

Paramètres
\Joomla\CMS\Table\Table $table A Table object.
Renvoie
void
Depuis
1.6

Références Workflow\CONDITION_PUBLISHED, Factory\getDate(), et null.

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Allows preprocessing of the Form object.

Paramètres
Form | $form | The form object
array | $data | The data to be merged into the form object
string | $group | The plugin group to be executed
Renvoie
void
Depuis
3.0

Références $data, $field, $fields, $form, $language, $languages, Associations\isEnabled(), null, Joomla\CMS\MVC\Model\preprocessForm(), et Joomla\CMS\MVC\Model\workflowPreprocessForm().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $value, et Joomla\CMS\MVC\Model\workflowBeforeStageChange().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFilterInput
Depuis
3.7.0

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $associationsContext

$associationsContext = 'com_content.item'
protected

◆ $event_after_change_featured

$event_after_change_featured = null
protected

◆ $event_before_change_featured

$event_before_change_featured = null
protected

◆ $text_prefix

$text_prefix = 'COM_CONTENT'
protected

◆ $typeAlias

$typeAlias = 'com_content.article'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Model/ArticleModel.php


Joomla CMS: Référence de la classe ArticlesModel

  • Joomla
  • Component
  • Content
  • Administrator
  • Model
  • ArticlesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ArticlesModel
+ Graphe d'héritage de ArticlesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface FeaturedModel

Fonctions membres publiques

__construct ($config=array())
getFilterForm ($data=array(), $loadData=true)
getTransitions ()
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.id', $direction='desc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of article records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6
Voir également

Références $config, Symfony\Contracts\Service\__construct(), et Associations\isEnabled().

Documentation des fonctions membres

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
|null The Form object or null if the form can't be found
Depuis
3.2

Références $data, $form, $ordering, $params, et ComponentHelper\getParams().

◆ getItems()

getItems ( )

Method to get a list of articles. Overridden to add item type alias.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
4.0.0

Implémente ListModelInterface.

Références $item, et $items.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Get the master query for retrieving a list of articles subject to the model state.

Renvoie
Depuis
1.6

Références $db, $groups, $key, $language, $ordering, $params, $published, $query, $state, $type, $user, ContentComponent\CONDITION_PUBLISHED, ContentComponent\CONDITION_UNPUBLISHED, elseif, Joomla\Database\getDatabase(), Table\getInstance(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, PluginHelper\isEnabled(), Associations\isEnabled(), et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTransitions()

getTransitions ( )

Method to get all transitions at once for all articles

Renvoie
array|boolean
Depuis
4.0.0

Références $db, $items, $key, $query, $transitions, $user, Text\_(), ArrayHelper\getColumn(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), JPATH_ADMINISTRATOR, et ArrayHelper\toInteger().

◆ populateState()

populateState | ( | $ordering = 'a.id',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $language, $layout, $ordering, $published, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Model/ArticlesModel.php


Joomla CMS: Référence de la classe FeaturedModel

  • Joomla
  • Component
  • Content
  • Administrator
  • Model
  • FeaturedModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FeaturedModel
+ Graphe d'héritage de FeaturedModel:
ArticlesModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
- Fonctions membres publiques hérités de ArticlesModel
__construct ($config=array())
getFilterForm ($data=array(), $loadData=true)
getTransitions ()
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.title', $direction='asc')
getListQuery ()
- Fonctions membres protégées hérités de ArticlesModel
populateState ($ordering='a.id', $direction='desc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of featured article records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
4.0.0

Références $query, et Joomla\Database\getDatabase().

◆ populateState()

populateState | ( | $ordering = 'a.title',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.5

Références $direction, $ordering, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/Model/FeaturedModel.php


Joomla CMS: Référence de la classe FeatureModel

  • Joomla
  • Component
  • Content
  • Administrator
  • Model
  • FeatureModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FeatureModel
+ Graphe d'héritage de FeatureModel:
ArticleModel AdminModel WorkflowModelInterface FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($type='Featured', $prefix='Administrator', $config=array())
- Fonctions membres publiques hérités de ArticleModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
publish (&$pks, $value=1)
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
featured ($pks, $value=0, $featuredUp=null, $featuredDown=null)
hit ()
delete (&$pks)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de WorkflowModelInterface
setUpWorkflow ($extension)
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
getState ($property=null, $default=null)
getName ()

Fonctions membres protégées

getReorderConditions ($table)
- Fonctions membres protégées hérités de ArticleModel
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchMove ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
prepareTable ($table)
loadFormData ()
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de ArticleModel
$typeAlias = 'com_content.article'
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de ArticleModel
$text_prefix = 'COM_CONTENT'
$associationsContext = 'com_content.item'
$event_before_change_featured = null
$event_after_change_featured = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Feature model.

Depuis
1.6

Documentation des fonctions membres

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

◆ getTable()

getTable | ( | $type = 'Featured',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Returns a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
A database object
Depuis
1.6

Implémente WorkflowModelInterface.

Références $config, $prefix, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FeatureModel.php


Joomla CMS: Référence de la classe AdministratorService

  • Joomla
  • Component
  • Content
  • Administrator
  • Service
  • HTML
  • AdministratorService
Fonctions membres publiques
Référence de la classe AdministratorService

Fonctions membres publiques

association ($articleid)

Description détaillée

Content HTML helper

Depuis
3.0

Documentation des fonctions membres

◆ association()

association ( $articleid )

Render the list of associated items

Paramètres
integer $articleid The article item id
Renvoie
string The language HTML
Exceptions

Références $classes, $content_languages, $db, $html, $item, $items, $languages, $query, $text, $tooltip, $url, Route\_(), ENT_QUOTES, Factory\getApplication(), Associations\getAssociations(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/Service/HTML/AdministratorService.php


Joomla CMS: Référence de la classe Icon

  • Joomla
  • Component
  • Content
  • Administrator
  • Service
  • HTML
  • Icon
Fonctions membres publiques
Référence de la classe Icon

Fonctions membres publiques

create ($category, $params, $attribs=array(), $legacy=false)
edit ($article, $params, $attribs=array(), $legacy=false)
print_screen ($params, $legacy=false)

Description détaillée

Content Component HTML Helper

Depuis
4.0.0

Documentation des fonctions membres

◆ create()

create | ( | $category,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |

Method to generate a link to the create item page for the given category

Paramètres
object | $category | The category information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML markup for the create item link
Depuis
4.0.0

Références $attribs, $button, $category, $params, $text, $uri, $url, Text\_(), Route\_(), HTMLHelper\_(), et Uri\getInstance().

◆ edit()

edit | ( | $article,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |

Display an edit icon for the article.

This icon will not display in a popup window, nor if the article is trashed. Edit access checks must be performed in the calling code.

Paramètres
object | $article | The article information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML for the article edit icon.
Depuis
4.0.0

Références $article, $attribs, $date, $output, $params, $text, $tooltip, $uri, $url, $user, Text\_(), Route\_(), HTMLHelper\_(), Workflow\CONDITION_PUBLISHED, Workflow\CONDITION_UNPUBLISHED, RouteHelper\getArticleRoute(), Uri\getInstance(), Factory\getUser(), LayoutHelper\render(), et Text\sprintf().

◆ print_screen()

print_screen | ( | $params,
 |  | $legacy = false
 | ) |

Method to generate a link to print an article

Paramètres
Registry | $params | The item parameters
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML markup for the popup link
Depuis
4.0.0

Références $params, $text, et LayoutHelper\render().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/Service/HTML/Icon.php


Joomla CMS: Référence de la classe ArticleTable

  • Joomla
  • Component
  • Content
  • Administrator
  • Table
  • ArticleTable
Référence de la classe ArticleTable
+ Graphe d'héritage de ArticleTable:
Content Table VersionableTableInterface TaggableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface TableInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de Content
__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
store ($updateNulls=true)
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()
- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Content
_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Content
$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Article table

Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticleTable.php


Joomla CMS: Référence de la classe FeaturedTable

  • Joomla
  • Component
  • Content
  • Administrator
  • Table
  • FeaturedTable
Fonctions membres publiques
Référence de la classe FeaturedTable
+ Graphe d'héritage de FeaturedTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Featured Table class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
1.6

Références $db, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FeaturedTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Article
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
$eName
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit an article.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions

Références $canDo, $this, $toolbar, $url, $user, $userId, Text\_(), Factory\getApplication(), RouteHelper\getArticleRoute(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), ToolbarHelper\inlinehelp(), ComponentHelper\isEnabled(), PluginHelper\isEnabled(), Associations\isEnabled(), Route\link(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6
Exceptions

Implémente ViewInterface.

Références ContentHelper\getActions(), Factory\getApplication(), et null.

Documentation des champs

◆ $canDo

$canDo
protected

◆ $eName

$eName
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/View/Article/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Articles
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$transitions = []
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of articles.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $alert, $canDo, $messages, $toolbar, $user, Text\_(), ContentComponent\CONDITION_TRASHED, ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références Factory\getApplication(), ComponentHelper\getParams(), hits, PluginHelper\importPlugin(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $transitions

$transitions = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/View/Articles/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Administrator
  • View
  • Featured
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$transitions = []
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of featured articles.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $alert, $canDo, $messages, $toolbar, $user, Text\_(), ContentComponent\CONDITION_TRASHED, ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), ToolbarHelper\help(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références ComponentHelper\getParams(), hits, PluginHelper\importPlugin(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $transitions

$transitions = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/src/View/Featured/HtmlView.php


Joomla CMS: Référence de la classe ArticlesController

  • Joomla
  • Component
  • Content
  • Api
  • Controller
  • ArticlesController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ArticlesController
+ Graphe d'héritage de ArticlesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

preprocessSaveData (array $data)
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'articles'
$default_view = 'articles'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The article controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( )

Article list view amended to add filtering of data

Renvoie
static A BaseController object to support chaining.
Depuis
4.0.0

Références InputFilter\getInstance().

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0

Références $data, $field, et FieldsHelper\getFields().

Documentation des champs

◆ $contentType

$contentType = 'articles'
protected

◆ $default_view

$default_view = 'articles'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_content/src/Controller/ArticlesController.php


Joomla CMS: Référence de la classe ContentHelper

  • Joomla
  • Component
  • Content
  • Api
  • Helper
  • ContentHelper
Fonctions membres publiques statiques
Référence de la classe ContentHelper

Fonctions membres publiques statiques

static resolve (string $uri)

Description détaillée

Content api helper.

Depuis
4.0.0

Documentation des fonctions membres

◆ resolve()

static resolve ( string $uri )
static

Fully Qualified Domain name for the image url

Paramètres
string $uri The uri to resolve
Renvoie
string

Références $uri, et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_content/src/Helper/ContentHelper.php


Joomla CMS: Référence de la classe ContentSerializer

  • Joomla
  • Component
  • Content
  • Api
  • Serializer
  • ContentSerializer
Fonctions membres publiques
Référence de la classe ContentSerializer
+ Graphe d'héritage de ContentSerializer:
JoomlaSerializer AbstractSerializer SerializerInterface

Fonctions membres publiques

languageAssociations ($model)
category ($model)
createdBy ($model)
modifiedBy ($model)
- Fonctions membres publiques hérités de JoomlaSerializer
__construct (string $type)
- Fonctions membres publiques hérités de AbstractSerializer
getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Membres hérités additionnels

- Attributs protégés hérités de AbstractSerializer
$type

Description détaillée

Temporary serializer

Depuis
4.0.0

Documentation des fonctions membres

◆ category()

category ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ createdBy()

createdBy ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ languageAssociations()

languageAssociations ( $model )

Build content relationships by associations

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ modifiedBy()

modifiedBy ( $model )

Build editor relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentSerializer.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Content
  • Api
  • View
  • Articles
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[])
displayList (array $items=null)
displayItem ($item=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
$relationship
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The article view

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config A named configuration array for object construction. contentType: the name (optional) of the content type to use for the serialization
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ displayItem()

displayItem ( $item = null )

Execute and display a template script.

Paramètres
object $item Item
Renvoie
string
Depuis
4.0.0

Références $field, FieldsHelper\getFields(), et Multilanguage\isEnabled().

◆ displayList()

displayList ( array $items = null )

Execute and display a template script.

Paramètres
array | null $items Array of items
Renvoie
string
Depuis
4.0.0

Références $field, et FieldsHelper\getFields().

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $field, $item, Factory\getApplication(), FieldsHelper\getFields(), et PluginHelper\importPlugin().

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'typeAlias',
'asset_id',
'title',
'text',
'tags',
'language',
'state',
'category',
'images',
'metakey',
'metadesc',
'metadata',
'access',
'featured',
'alias',
'note',
'publish_up',
'publish_down',
'urls',
'created',
'created_by',
'created_by_alias',
'modified',
'hits',
'version',
'featured_up',
'featured_down',
]

◆ $relationship

$relationship
protected
Valeur initiale :
= [
'category',
'created_by',
'tags',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/View/Articles/JsonapiView.php


Joomla CMS: Référence de la classe ArticleController

  • Joomla
  • Component
  • Content
  • Site
  • Controller
  • ArticleController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ArticleController
+ Graphe d'héritage de ArticleController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

add ()
edit ($key=null, $urlVar='a_id')
getModel ($name='Form', $prefix='Site', $config=array('ignore_request'=> true))
save ($key=null, $urlVar='a_id')
reload ($key=null, $urlVar='a_id')
vote ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='a_id')
getReturnPage ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$view_item = 'form'
$view_list = 'categories'
$urlVar = 'a.id'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Content article class.

Depuis
1.6.0

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new record.

Renvoie
mixed True if the record can be added, an error object if not.
Depuis
1.6

Références Route\_().

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $data, $user, ArrayHelper\getValue(), et null.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key; default is id.
Renvoie
boolean
Depuis
1.6

Références $data, $key, $recordId, et $user.

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = 'a_id'
 | ) |

Method to edit an existing record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if access level check and checkout passes, false otherwise.
Depuis
1.6

Références $key, $result, et Route\_().

◆ getModel()

getModel | ( | $name = 'Form',
 |  | $prefix = 'Site',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.5

Références $config, $name, et $prefix.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'a_id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

if ($layout) { $append .= '&layout=' . $layout; }

Références $append, $itemId, $recordId, $return, et $tmpl.

◆ getReturnPage()

getReturnPage ( )
protected

Get the return URL.

If a "return" variable has been passed in the request

Renvoie
string The return URL.
Depuis
1.6

Références $return, Uri\base(), Uri\isInternal(), et null.

◆ reload()

reload | ( | $key = null,
 |  | $urlVar = 'a_id'
 | ) |

Method to reload a record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
void
Depuis
3.8.0

Références $key.

◆ save()

save | ( | $key = null,
 |  | $urlVar = 'a_id'
 | ) |

Method to save a record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if successful, false otherwise.
Depuis
1.6

Références $app, $articleId, $item, $key, $lang, $params, $result, Route\_(), elseif, et Multilanguage\isEnabled().

◆ vote()

vote ( )

Method to save a vote.

Renvoie
void
Depuis
1.6

Références $id, $model, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), et Uri\isInternal().

Documentation des champs

◆ $urlVar

$urlVar = 'a.id'
protected

◆ $view_item

$view_item = 'form'
protected

◆ $view_list

$view_list = 'categories'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Controller/ArticleController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Content
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Content Component Controller

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The Input object for the request
Depuis
3.0.1

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), elseif, et Factory\getApplication().

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached.
boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
DisplayController This object to support chaining.
Depuis
1.5

Set the default view name and format from the Request. Note we are using a_id to avoid collisions with the router and the return page. Frontend is a bit messier than the backend.

Références $id, $model, $this, $user, ComponentHelper\getParams(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Content
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

dispatch ()
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Membres hérités additionnels

- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_content

Depuis
4.0.0

Documentation des fonctions membres

◆ dispatch()

dispatch ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AssociationHelper

  • Joomla
  • Component
  • Content
  • Site
  • Helper
  • AssociationHelper
Fonctions membres publiques statiques
Référence de la classe AssociationHelper
+ Graphe d'héritage de AssociationHelper:
CategoryAssociationHelper

Fonctions membres publiques statiques

static | getAssociations ($id=0, $view=null, $layout=null)
static | displayAssociations ($id)
- Fonctions membres publiques statiques hérités de CategoryAssociationHelper
static | getCategoryAssociations ($id=0, $extension='com_content', $layout=null)

Membres hérités additionnels

- Attributs publics statiques hérités de CategoryAssociationHelper
static $category_association = true

Description détaillée

Content Component Association Helper

Depuis
3.0

Documentation des fonctions membres

◆ displayAssociations()

static displayAssociations ( $id )
static

Method to display in frontend the associations for a given article

Paramètres
integer $id Id of the article
Renvoie
array An array containing the association URL and the related language object
Depuis
3.7.0

Références $id, $language, $languages, $return, Multilanguage\getSiteHomePages(), et Factory\getUser().

Référencé par HtmlView\display(), et ArticlesModel\getItems().

◆ getAssociations()

static getAssociations | ( | $id = 0,
 |  | $view = null,
 |  | $layout = null
 | ) |
static

Method to get the associations for a given item

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
string | $layout | View layout
Renvoie
array Array of associations for the item
Depuis
3.0

Références $component, $date, $db, $groups, $id, $item, $layout, $nowDate, $return, $user, $view, Factory\getApplication(), RouteHelper\getArticleRoute(), Associations\getAssociations(), Factory\getDate(), Factory\getDbo(), Factory\getLanguage(), Factory\getUser(), et null.

Référencé par AssociationsHelper\getAssociationsForItem().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/Helper/AssociationHelper.php


Joomla CMS: Référence de la classe QueryHelper

  • Joomla
  • Component
  • Content
  • Site
  • Helper
  • QueryHelper
Fonctions membres publiques statiques
Référence de la classe QueryHelper

Fonctions membres publiques statiques

static | orderbyPrimary ($orderby)
static | orderbySecondary ($orderby, $orderDate='created', DatabaseInterface $db=null)
static | getQueryDate ($orderDate, DatabaseInterface $db=null)
static | buildVotingQuery ($params=null)

Description détaillée

Content Component Query Helper

Depuis
1.5

Documentation des fonctions membres

◆ buildVotingQuery()

static buildVotingQuery ( $params = null )
static

Get join information for the voting query.

Paramètres
\Joomla\Registry\Registry $params An options object for the article.
Renvoie
array A named array with "select" and "join" keys.
Depuis
1.5
Obsolète:
5.0 Deprecated without replacement, not used in core

Références $params, et ComponentHelper\getParams().

◆ getQueryDate()

static getQueryDate | ( |  | $orderDate,
 |  | DatabaseInterface | $db = null
 | ) |  |
static

Translate an order code to a field for date ordering.

Paramètres
string | $orderDate | The ordering code.
DatabaseInterface | $db | The database
Renvoie
string The SQL field(s) to order by.
Depuis
1.6

Références $db, et Factory\getDbo().

Référencé par ArchiveModel\getListQuery().

◆ orderbyPrimary()

static orderbyPrimary ( $orderby )
static

Translate an order code to a field for category ordering.

Paramètres
string $orderby The ordering code.
Renvoie
string The SQL field(s) to order by.
Depuis
1.5

Référencé par CategoryModel\_buildContentOrderBy(), et FeaturedModel\populateState().

◆ orderbySecondary()

static orderbySecondary | ( |  | $orderby,
 |  |  | $orderDate = 'created',
 |  | DatabaseInterface | $db = null
 | ) |  |
static

Translate an order code to a field for article ordering.

Paramètres
string | $orderby | The ordering code.
string | $orderDate | The ordering code for the date.
DatabaseInterface | $db | The database
Renvoie
string The SQL field(s) to order by.
Depuis
1.5

Références $db, Factory\getDbo(), et PluginHelper\isEnabled().

Référencé par CategoryModel\_buildContentOrderBy(), ArchiveModel\populateState(), et FeaturedModel\populateState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • QueryHelper.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • Component
  • Content
  • Site
  • Helper
  • RouteHelper
Fonctions membres publiques statiques
Référence de la classe RouteHelper

Fonctions membres publiques statiques

static | getArticleRoute ($id, $catid=0, $language=0, $layout=null)
static | getCategoryRoute ($catid, $language=0, $layout=null)
static | getFormRoute ($id)

Description détaillée

Content Component Route Helper.

Depuis
1.5

Documentation des fonctions membres

◆ getArticleRoute()

static getArticleRoute | ( | $id,
 |  | $catid = 0,
 |  | $language = 0,
 |  | $layout = null
 | ) |
static

Get the article route.

Paramètres
integer | $id | The route of the content item.
integer | $catid | The category ID.
integer | $language | The language code.
string | $layout | The layout value.
Renvoie
string The article route.
Depuis
1.5

Références $id, $language, $layout, $link, et Multilanguage\isEnabled().

Référencé par HtmlView\addToolbar(), FeedView\display(), HtmlView\display(), Icon\edit(), ConsentBoxField\getAssignedArticleUrl(), AssociationHelper\getAssociations(), TosField\getLabel(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), ArticlesPopularHelper\getList(), ArticlesCategoryHelper\getList(), et FeedView\reconcileNames().

◆ getCategoryRoute()

static getCategoryRoute | ( | $catid,
 |  | $language = 0,
 |  | $layout = null
 | ) |
static

Get the category route.

Paramètres
integer | $catid | The category ID.
integer | $language | The language code.
string | $layout | The layout value.
Renvoie
string The article route.
Depuis
1.5

Références $id, $language, $layout, $link, et Multilanguage\isEnabled().

Référencé par HtmlView\_prepareDocument(), ArticlesCategoryHelper\getList(), et HtmlView\prepareDocument().

◆ getFormRoute()

static getFormRoute ( $id )
static

Get the form route.

Paramètres
integer $id The form ID.
Renvoie
string The article route.
Depuis
1.5

Références $id.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe ArchiveModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • ArchiveModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ArchiveModel
+ Graphe d'héritage de ArchiveModel:
ArticlesModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getData ()
getYears ()
- Fonctions membres publiques hérités de ArticlesModel
__construct ($config=array())
getItems ()
getStart ()
countItemsByMonth ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$_context = 'com_content.archive'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getListQuery ()
- Fonctions membres protégées hérités de ArticlesModel
populateState ($ordering='ordering', $direction='ASC')
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getSlugColumn ($query, $id, $alias)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Content Component Archive Model

Depuis
1.5

Documentation des fonctions membres

◆ getData()

getData ( )

Method to get the archived article list

public

Renvoie
array

Références $app, $limit, $params, $query, et Factory\getApplication().

◆ getListQuery()

getListQuery ( )
protected

Get the master query for retrieving a list of articles subject to the model state.

Renvoie
Depuis
1.6

Références $app, $db, $params, $query, Factory\getApplication(), Joomla\Database\getDatabase(), QueryHelper\getQueryDate(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getSlugColumn()

getSlugColumn | ( | $query,
 |  | $id,
 |  | $alias
 | ) |
private

Generate column expression for slug or catslug.

Paramètres
\Joomla\Database\DatabaseQuery | $query | Current query instance.
string | $id | Column id name.
string | $alias | Column alias name.
Renvoie
string
Depuis
4.0.0

Références $db, $id, $query, et Joomla\Database\getDatabase().

◆ getYears()

getYears ( )

Gets the archived articles years

Renvoie
array
Depuis
3.6.0

Références $db, $nowDate, $query, ContentComponent\CONDITION_ARCHIVED, Joomla\Database\getDatabase(), et Factory\getDate().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | The field to order on.
string | $direction | The direction to order on.
Renvoie
void
Depuis
1.6

Références $app, $itemid, $limit, $params, ContentComponent\CONDITION_ARCHIVED, Factory\getApplication(), Joomla\Database\getDatabase(), QueryHelper\orderbySecondary(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_content.archive'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ArchiveModel.php


Joomla CMS: Référence de la classe ArticleModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • ArticleModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ArticleModel
+ Graphe d'héritage de ArticleModel:
ItemModel BaseDatabaseModel ItemModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItem ($pk=null)
hit ($pk=0)
storeVote ($pk=0, $rate=0)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de ItemModel
getStoreId ($id='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_context = 'com_content.article'
- Attributs protégés hérités de ItemModel
$_item = null
$_context = 'group.type'
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Content Component Article Model

Depuis
1.5

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Cleans the cache of com_content and content modules

Paramètres
string | $group | The cache group
integer | $clientId

◆ getItem()

getItem ( $pk = null )

Method to get article data.

Paramètres
integer $pk The id of the article.
Renvoie
object|boolean Menu item data object on success, boolean false

Implémente ItemModelInterface.

Références $data, $db, $groups, $nowDate, $published, $query, $user, $userId, Text\_(), elseif, Joomla\Database\getDatabase(), Factory\getDate(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, null, et ParameterType\STRING.

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the article.

Paramètres
integer $pk Optional primary key of the article to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.

Références $input, Factory\getApplication(), Table\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Depuis
1.6
Renvoie
void

Références $app, Joomla\Database\Query\$offset, $params, $user, ContentComponent\CONDITION_ARCHIVED, ContentComponent\CONDITION_PUBLISHED, Factory\getApplication(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

◆ storeVote()

storeVote | ( | $pk = 0,
 |  | $rate = 0
 | ) |

Save user vote on article

Paramètres
integer | $pk | Joomla Article Id
integer | $rate | Voting rate
Renvoie
boolean Return true on success

Références $db, $query, $rating, Factory\getApplication(), Joomla\Database\getDatabase(), IpHelper\getIp(), ParameterType\INTEGER, et Text\sprintf().

Documentation des champs

◆ $_context

$_context = 'com_content.article'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/ArticleModel.php


Joomla CMS: Référence de la classe ArticlesModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • ArticlesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ArticlesModel
+ Graphe d'héritage de ArticlesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface ArchiveModel FeaturedModel

Fonctions membres publiques

__construct ($config=array())
getItems ()
getStart ()
countItemsByMonth ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='ordering', $direction='ASC')
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving lists of articles.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ countItemsByMonth()

countItemsByMonth ( )

Count Items by Month

Renvoie
mixed An array of objects on success, false on failure.
Depuis
3.9.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getItems()

getItems ( )

Method to get a list of articles.

Overridden to inject convert the attribs field into a Registry object.

Renvoie
mixed An array of objects on success, false on failure.
Depuis
1.6

For blogs, article params override menu item params only if menu param = 'use_article' Otherwise, menu item params control the layout If menu item is 'use_article' and there is no article param, use global

Compute the asset access permissions. Technically guest could edit an article, but lets not check that to improve performance a little.

Implémente ListModelInterface.

Références $groups, $id, $input, $item, $itemIds, $items, $key, $user, $userId, $value, AssociationHelper\displayAssociations(), elseif, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), Associations\isEnabled(), et null.

◆ getStart()

getStart ( )

Method to get the starting number of items for the data set.

Renvoie
integer The starting number of items available in the data set.
Depuis
3.0.1

Références Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'ordering',
 |  | $direction = 'ASC'
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.0.1

Références $app, $listOrder, $params, $user, $value, ContentComponent\CONDITION_PUBLISHED, Factory\getApplication(), ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/ArticlesModel.php


Joomla CMS: Référence de la classe CategoriesModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • CategoriesModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe CategoriesModel
+ Graphe d'héritage de CategoriesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ($recursive=false)
getParent ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$_context = 'com_content.categories'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_extension = 'com_content'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$_parent = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving lists of article categories.

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( $recursive = false )

Redefine the function and add some properties to make the styling easier

Paramètres
bool $recursive True if you want to return children recursively.
Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6

Références $active, $app, $menu, $options, $params, Factory\getApplication(), Categories\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ getParent()

getParent ( )

Get the parent.

Renvoie
object An array of data items on success, false on failure.
Depuis
1.6

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | The field to order on.
string | $direction | The direction to order on.
Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_content.categories'

◆ $_extension

$_extension = 'com_content'
protected

◆ $_parent

$_parent = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/CategoriesModel.php


Joomla CMS: Référence de la classe CategoryModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • CategoryModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryModel
+ Graphe d'héritage de CategoryModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
getPagination ()
getCategory ()
getParent ()
& getLeftSibling ()
& getRightSibling ()
& getChildren ()
hit ($pk=0)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
_buildContentOrderBy ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_item = null
$_articles = null
$_siblings = null
$_children = null
$_parent = null
$_context = 'com_content.category'
$_category = null
$_categories = null
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving a category, the articles associated with the category, sibling, child and parent categories.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )
Paramètres
array $config An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _buildContentOrderBy()

_buildContentOrderBy ( )
protected

Build the orderby for the query

Renvoie
string $orderby portion of query
Depuis
1.5

Références $app, $db, $itemid, $params, Factory\getApplication(), Joomla\Database\getDatabase(), null, QueryHelper\orderbyPrimary(), et QueryHelper\orderbySecondary().

◆ getCategory()

getCategory ( )

Method to get category data for the current category

Renvoie
object
Depuis
1.5

Références $options, $params, $user, Categories\getInstance(), Joomla\CMS\MVC\Model\getState(), et Factory\getUser().

◆ getChildren()

& getChildren ( )

Get the child categories.

Renvoie
mixed An array of categories or false if an error occurs.
Depuis
1.6

Références Joomla\CMS\Tree\$_children, $params, Joomla\CMS\Categories\getCategory(), Joomla\CMS\MVC\Model\getState(), et ArrayHelper\sortObjects().

◆ getItems()

getItems ( )

Get the articles in the category

Renvoie
array|bool An array of articles or false if an error occurs.
Depuis
1.5

Implémente ListModelInterface.

Références $category, $limit, $model, Factory\getApplication(), Joomla\CMS\Categories\getCategory(), Joomla\CMS\MVC\Model\getState(), et null.

◆ getLeftSibling()

& getLeftSibling ( )

Get the left sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.
Depuis
1.6

Références Joomla\CMS\Categories\getCategory().

◆ getPagination()

getPagination ( )

Method to get a JPagination object for the data set.

Renvoie
A JPagination object for the data set.
Depuis
3.0.1

Références null.

◆ getParent()

getParent ( )

Get the parent category.

Renvoie
mixed An array of categories or false if an error occurs.
Depuis
1.6

Références Joomla\CMS\Categories\getCategory().

◆ getRightSibling()

& getRightSibling ( )

Get the right sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.
Depuis
1.6

Références Joomla\CMS\Categories\getCategory().

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the category.

Paramètres
int $pk Optional primary key of the category to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.

Références $input, Factory\getApplication(), Table\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | The field to order on.
string | $direction | The direction to order on.
Renvoie
void
Depuis
1.6

Références $app, $itemid, $limit, $listOrder, $menu, $params, $user, $value, Factory\getApplication(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_articles

$_articles = null
protected

◆ $_categories

$_categories = null
protected

◆ $_category

$_category = null
protected

◆ $_children

$_children = null
protected

◆ $_context

$_context = 'com_content.category'
protected

◆ $_item

$_item = null
protected

◆ $_parent

$_parent = null
protected

◆ $_siblings

$_siblings = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/CategoryModel.php


Joomla CMS: Référence de la classe FeaturedModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • FeaturedModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe FeaturedModel
+ Graphe d'héritage de FeaturedModel:
ArticlesModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
- Fonctions membres publiques hérités de ArticlesModel
__construct ($config=array())
getItems ()
getStart ()
countItemsByMonth ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$_context = 'com_content.frontpage'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ArticlesModel
populateState ($ordering='ordering', $direction='ASC')
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Frontpage Component Model

Depuis
1.5

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of articles.

Renvoie
mixed An array of objects on success, false on failure.

Implémente ListModelInterface.

Références $limit, $params, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\setState().

◆ getListQuery()

getListQuery ( )
protected

Get the list of items.

Renvoie

Références $query, Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | The field to order on.
string | $direction | The direction to order on.
Renvoie
void
Depuis
1.6

Références $app, $direction, $input, $limit, $menu, $ordering, $params, $user, ContentComponent\CONDITION_PUBLISHED, ContentComponent\CONDITION_UNPUBLISHED, Factory\getApplication(), Joomla\Database\getDatabase(), QueryHelper\orderbyPrimary(), QueryHelper\orderbySecondary(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_content.frontpage'
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/FeaturedModel.php


Joomla CMS: Référence de la classe FormModel

  • Joomla
  • Component
  • Content
  • Site
  • Model
  • FormModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe FormModel
+ Graphe d'héritage de FormModel:
ArticleModel AdminModel WorkflowModelInterface FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItem ($itemId=null)
getReturnPage ()
save ($data)
getForm ($data=[], $loadData=true)
getTable ($name='Article', $prefix='Administrator', $options=array())
- Fonctions membres publiques hérités de ArticleModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
publish (&$pks, $value=1)
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
featured ($pks, $value=0, $featuredUp=null, $featuredDown=null)
hit ()
delete (&$pks)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques hérités de WorkflowModelInterface
setUpWorkflow ($extension)
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
getState ($property=null, $default=null)
getName ()

Champs de données

$typeAlias = 'com_content.article'
- Champs de données hérités de ArticleModel
$typeAlias = 'com_content.article'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

populateState ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de ArticleModel
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchMove ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
prepareTable ($table)
loadFormData ()
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ArticleModel
$text_prefix = 'COM_CONTENT'
$associationsContext = 'com_content.item'
$event_before_change_featured = null
$event_after_change_featured = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Content Component Article Model

Depuis
1.5

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $app, $data, $form, $id, $user, Factory\getApplication(), Associations\getAssociations(), Joomla\CMS\MVC\Model\getState(), et Associations\isEnabled().

◆ getItem()

getItem ( $itemId = null )

Method to get article data.

Paramètres
integer $itemId The id of the article.
Renvoie
mixed Content item data object on success, false on failure.

Références $itemId, $return, $user, $userId, $value, class, elseif, Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et ArrayHelper\toObject().

◆ getReturnPage()

getReturnPage ( )

Get the return URL.

Renvoie
string The return URL.
Depuis
1.6

Références Joomla\CMS\MVC\Model\getState().

◆ getTable()

getTable | ( | $name = 'Article',
 |  | $prefix = 'Administrator',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
4.0.0
Exceptions

Implémente WorkflowModelInterface.

Références $name, $options, et $prefix.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $params, $return, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Allows preprocessing of the JForm object.

Paramètres
Form | $form | The form object
array | $data | The data to be merged into the form object
string | $group | The plugin group to be executed
Renvoie
void
Depuis
3.7.0

Références $data, $db, $form, $params, $query, $result, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, Multilanguage\isEnabled(), Joomla\CMS\MVC\Model\preprocessForm(), et Form\setFieldAttribute().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
3.2

Références $data, Associations\getAssociations(), Multilanguage\isEnabled(), et Associations\isEnabled().

Documentation des champs

◆ $typeAlias

$typeAlias = 'com_content.article'
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Model/FormModel.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • Component
  • Content
  • Site
  • Service
  • Category
Fonctions membres publiques
Référence de la classe Category
+ Graphe d'héritage de Category:
Categories CategoryInterface DatabaseAwareInterface

Fonctions membres publiques

__construct ($options=array())
- Fonctions membres publiques hérités de Categories
__construct ($options)
get ($id='root', $forceload=false)
getExtension ()
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Categories
static | getInstance ($extension, $options=array())
- Attributs publics statiques hérités de Categories
static | $instances = array()
- Fonctions membres protégées hérités de Categories
_load ($id)
- Attributs protégés hérités de Categories
$_nodes
$_checkedCategories
$_extension = null
$_table = null
$_field = null
$_key = null
$_statefield = null
$_options = []

Description détaillée

Content Component Category Tree

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Class constructor

Paramètres
array $options Array of options
Depuis
1.7.0

Références $options, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Service/Category.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Content
  • Site
  • Service
  • Router
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu, CategoryFactoryInterface $categoryFactory, DatabaseInterface $db)
getCategorySegment ($id, $query)
getCategoriesSegment ($id, $query)
getArticleSegment ($id, $query)
getFormSegment ($id, $query)
getCategoryId ($segment, $query)
getCategoriesId ($segment, $query)
getArticleId ($segment, $query)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Attributs protégés

$noIDs = false
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Fonctions membres privées

getCategories (array $options=[])

Attributs privés

$categoryFactory
$categoryCache = []
$db

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class of com_content

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu,
 |  | CategoryFactoryInterface | $categoryFactory,
 |  | DatabaseInterface | $db
 | ) |  |

Content Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with
CategoryFactoryInterface | $categoryFactory | The category object
DatabaseInterface | $db | The database object

Références $app, $article, $category, $db, $form, $menu, $params, $this, Symfony\Contracts\Service\__construct(), et ComponentHelper\getParams().

Documentation des fonctions membres

◆ getArticleId()

getArticleId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for an article

Paramètres
string | $segment | Segment of the article to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query, et ParameterType\INTEGER.

◆ getArticleSegment()

getArticleSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for an article

Paramètres
string | $id | ID of the article to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et ParameterType\INTEGER.

◆ getCategories()

getCategories ( array $options = [] )
private

Method to get categories from cache

Paramètres
array $options The options for retrieving categories
Renvoie
CategoryInterface The object containing categories
Depuis
4.0.0

Références $key, et $options.

◆ getCategoriesId()

getCategoriesId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query.

◆ getCategoriesSegment()

getCategoriesSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et $query.

◆ getCategoryId()

getCategoryId | ( | $segment,
 |  | $query
 | ) |

Method to get the id for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $category, et $query.

◆ getCategorySegment()

getCategorySegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $category, $id, et $path.

◆ getFormSegment()

getFormSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a form

Paramètres
string | $id | ID of the article form to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item
Depuis
3.7.3

Références $id, et $query.

Documentation des champs

◆ $categoryCache

$categoryCache = []
private

◆ $categoryFactory

$categoryFactory
private

◆ $db

$db
private

◆ $noIDs

$noIDs = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Archive
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state = null
$items = array()
$pagination = null
$years = array()
$form = null
$params = null
$filter = ''
$user = null
$pageclass_sfx = ''
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Content component

Depuis
1.5

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $menu, Text\_(), et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions
GenericDataException

Implémente ViewInterface.

Références $form, $i, $item, $items, $params, $results, $state, $user, Text\_(), HTMLHelper\_(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), if, PluginHelper\importPlugin(), items, et null.

Documentation des champs

◆ $filter

$filter = ''
protected

◆ $form

$form = null
protected

◆ $items

$items = array()
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination = null
protected

◆ $params

$params = null
protected

◆ $state

$state = null
protected

◆ $user

$user = null
protected

◆ $years

$years = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Archive/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Article
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$item
$params = null
$print = false
$state
$user = null
$pageclass_sfx = ''
$menuItemMatchArticle = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML Article View class for the Content component

Depuis
1.5

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void

Because the application sets a default page title, we need to get it from the menu item itself

Références $app, $author, $category, $id, $item, $menu, $path, $this, $title, Text\_(), elseif, Factory\getApplication(), RouteHelper\getCategoryRoute(), Categories\getInstance(), null, et Text\sprintf().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Check for no 'access-view' and empty fulltext,

  • Redirect guest users to login
  • Deny access to logged users with 403 code NOTE: we do not recheck for no access-view + show_noauth disabled ... since it was checked above

NOTE: The following code (usually) sets the text to contain the fulltext, but it is the responsibility of the layout to check 'access-view' and only use "introtext" for guests

Implémente ViewInterface.

Références $active, $app, $item, $layout, Joomla\Database\Query\$offset, $params, $results, $return, $temp, $user, Text\_(), Route\_(), AssociationHelper\displayAssociations(), elseif, Factory\getApplication(), RouteHelper\getArticleRoute(), Joomla\CMS\User\getCurrentUser(), Uri\getInstance(), if, PluginHelper\importPlugin(), Associations\isEnabled(), et null.

Documentation des champs

◆ $item

$item
protected

◆ $menuItemMatchArticle

$menuItemMatchArticle = false
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $print

$print = false
protected

◆ $state

$state
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Article/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Categories
  • HtmlView
Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoriesView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$pageHeading = 'JGLOBAL_ARTICLES'
$extension = 'com_content'
- Attributs protégés hérités de CategoriesView
$state
$items
$pageHeading
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de CategoriesView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de CategoriesView
prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Content categories view.

Depuis
1.5

Documentation des champs

◆ $extension

$extension = 'com_content'
protected

◆ $pageHeading

$pageHeading = 'JGLOBAL_ARTICLES'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Categories/HtmlView.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Category
  • FeedView
Fonctions membres protégées | Attributs protégés
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
CategoryFeedView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

reconcileNames ($item)
- Fonctions membres protégées hérités de CategoryFeedView
reconcileNames ($item)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$viewName = 'article'
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de CategoryFeedView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Content component

Depuis
1.5

Documentation des fonctions membres

◆ reconcileNames()

reconcileNames ( $item )
protected

Method to reconcile non-standard names from components to usage in this class. Typically overridden in the component feed view class.

Paramètres
object $item The item for a feed, an element of the $items array.
Renvoie
void
Depuis
3.2

Références $app, $item, $link, $params, Text\_(), Route\_(), HTMLHelper\_(), Factory\getApplication(), RouteHelper\getArticleRoute(), Route\TLS_FORCE, Route\TLS_IGNORE, et true.

Documentation des champs

◆ $viewName

$viewName = 'article'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/View/Category/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Category
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoryView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de CategoryView
commonCategoryDisplay ()
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de CategoryView
prepareDocument ()
addFeed ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$lead_items = array()
$intro_items = array()
$link_items = array()
$extension = 'com_content'
$defaultPageTitle = 'JGLOBAL_ARTICLES'
$viewName = 'article'
- Attributs protégés hérités de CategoryView
$state
$items
$category
$categories
$pagination
$children
$extension
$viewName
$defaultPageTitle
$runPlugins = false
$menuItemMatchCategory = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Content component

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $active, $app, $i, $item, $params, $results, $title, category, elseif, Factory\getApplication(), if, PluginHelper\importPlugin(), PluginHelper\isEnabled(), items, et null.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $category, $id, $item, $menu, $path, category, RouteHelper\getCategoryRoute(), et null.

Documentation des champs

◆ $defaultPageTitle

$defaultPageTitle = 'JGLOBAL_ARTICLES'
protected

◆ $extension

$extension = 'com_content'
protected

◆ $intro_items

$intro_items = array()
protected

◆ $lead_items

$lead_items = array()
protected

◆ $link_items

$link_items = array()
protected

◆ $viewName

$viewName = 'article'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Category/HtmlView.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Featured
  • FeedView
Fonctions membres publiques
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Frontpage View class

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.

Implémente ViewInterface.

Références $app, $author, $description, $item, $link, $params, $rows, $title, Text\_(), Route\_(), HTMLHelper\_(), elseif, ENT_COMPAT, ENT_QUOTES, Factory\getApplication(), RouteHelper\getArticleRoute(), Categories\getInstance(), null, Route\TLS_FORCE, et Route\TLS_IGNORE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_content/src/View/Featured/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Featured
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state = null
$items = null
$pagination = null
$lead_items = array()
$intro_items = array()
$link_items = array()
$db
$user = null
$pageclass_sfx = ''
$params = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

Frontpage View class

Depuis
1.5

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void

Références $attribs, $link, $menu, Text\_(), Route\_(), et Factory\getApplication().

Documentation des champs

◆ $db

$db
protected

◆ $intro_items

$intro_items = array()
protected

◆ $items

$items = null
protected

◆ $lead_items

$lead_items = array()
protected

◆ $link_items

$link_items = array()
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination = null
protected

◆ $params

$params = null
protected

◆ $state

$state = null
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Featured/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Content
  • Site
  • View
  • Form
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$return_page = ''
$state
$params = null
$pageclass_sfx = ''
$user = null
$captchaEnabled = false
$showSaveAsCopy = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML Article View class for the Content component

Depuis
1.5

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $app, $menu, $title, Text\_(), et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void|boolean

Implémente ViewInterface.

Références $app, $authorised, $lang, $params, $tmp, $user, Text\_(), Factory\getApplication(), Factory\getLanguage(), PluginHelper\getPlugin(), et Multilanguage\isEnabled().

Documentation des champs

◆ $captchaEnabled

$captchaEnabled = false
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $return_page

$return_page = ''
protected

◆ $showSaveAsCopy

$showSaveAsCopy = false
protected

◆ $state

$state
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/src/View/Form/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Controller
  • DisplayController
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Contenthistory Controller

Depuis
3.2
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe HistoryController

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Controller
  • HistoryController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HistoryController
+ Graphe d'héritage de HistoryController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='History', $prefix='Administrator', $config=array('ignore_request'=> true))
keep ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Contenthistory list controller class.

Depuis
3.2

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'History',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model
string | $prefix | The prefix for the model
array | $config | An additional array of parameters
Renvoie
The model
Depuis
3.2

Références $config, $name, et $prefix.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références Session\getFormToken().

◆ keep()

keep ( )

Toggles the keep forever value for one or more history rows. If it was Yes, changes to No. If No, changes to Yes.

Renvoie
void
Depuis
3.2

Method to edit an existing record.

Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $model, Text\_(), Route\_(), Joomla\Application\checkToken(), false, Session\getFormToken(), et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/Controller/HistoryController.php


Joomla CMS: Référence de la classe PreviewController

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Controller
  • PreviewController
Fonctions membres publiques
Référence de la classe PreviewController
+ Graphe d'héritage de PreviewController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Preview', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Contenthistory list controller class.

Depuis
3.2

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Preview',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model
string | $prefix | The prefix for the model
array | $config | An additional array of parameters
Renvoie
The model
Depuis
3.2

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PreviewController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_associations

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void
Exceptions
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ContenthistoryHelper

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Helper
  • ContenthistoryHelper
Fonctions membres publiques statiques
Référence de la classe ContenthistoryHelper
+ Graphe d'héritage de ContenthistoryHelper:
ContenthistoryHelper

Fonctions membres publiques statiques

static | createObjectArray ($object)
static | decodeFields ($jsonString)
static | getFormValues ($object, ContentType $typesTable)
static | getFormFile (ContentType $typesTable)
static | getLookupValue ($lookup, $value)
static | hideFields ($object, ContentType $typeTable)
static | loadLanguageFiles ($typeAlias)
static | mergeLabels ($object, $formValues)
static | prepareData (ContentHistory $table)
static | processLookupFields ($object, ContentType $typesTable)

Description détaillée

Categories helper.

Depuis
3.2

Documentation des fonctions membres

◆ createObjectArray()

static createObjectArray ( $object )
static

Method to put all field names, including nested ones, in a single array for easy lookup.

Paramètres
\stdClass $object Standard class object that may contain one level of nested objects.
Renvoie
array Associative array of all field names, including ones in a nested object.
Depuis
3.2

Références $name, $result, $value, et null.

◆ decodeFields()

static decodeFields ( $jsonString )
static

Method to decode JSON-encoded fields in a standard object. Used to unpack JSON strings in the content history data column.

Paramètres
string $jsonString JSON String to convert to an object.
Renvoie
Object with any JSON-encoded fields unpacked.
Depuis
3.2

Références $name, et $value.

◆ getFormFile()

static getFormFile ( ContentType $typesTable )
static

Method to get the XML form file for this component. Used to get translated field names for history preview.

Paramètres
ContentType $typesTable Table object with content history options.
Renvoie
mixed object if successful, false if no model found.
Depuis
3.2

Références $component, $options, $path, $result, File\exists(), JPATH_ADMINISTRATOR, JPATH_ROOT, File\makeSafe(), et Folder\makeSafe().

◆ getFormValues()

static getFormValues | ( |  | $object,
 |  | ContentType | $typesTable
 | ) |  |
static

Method to get field labels for the fields in the JSON-encoded object. First we see if we can find translatable labels for the fields in the object. We translate any we can find and return an array in the format object->name => label.

Paramètres
\stdClass | $object | Standard class object in the format name->value.
ContentType | $typesTable | Table object with content history options.
Renvoie
Contains two associative arrays. $formValues->labels in the format name => label (for example, 'id' => 'Article ID'). $formValues->values in the format name => value (for example, 'state' => 'Published'. This translates the text from the selected option in the form.
Depuis
3.2

Références $field, $label, $name, $result, $xml, Text\_(), et null.

◆ getLookupValue()

static getLookupValue | ( | $lookup,
 |  | $value
 | ) |
static

Method to query the database using values from lookup objects.

Paramètres
\stdClass | $lookup | The std object with the values needed to do the query.
mixed | $value | The value used to find the matching title or name. Typically the id.
Renvoie
mixed Value from database (for example, name or title) on success, false on failure.
Depuis
3.2

Références $db, $query, $result, $value, Factory\getDbo(), et ParameterType\INTEGER.

◆ hideFields()

static hideFields | ( |  | $object,
 |  | ContentType | $typeTable
 | ) |  |
static

Method to remove fields from the object based on values entered in the #__content_types table.

Paramètres
\stdClass | $object | Object to be passed to view layout file.
ContentType | $typeTable | Table object with content history options.
Renvoie
object with hidden fields removed.
Depuis
3.2

Références $field, et $options.

◆ loadLanguageFiles()

static loadLanguageFiles ( $typeAlias )
static

Method to load the language files for the component whose history is being viewed.

Paramètres
string $typeAlias The type alias, for example 'com_content.article'.
Renvoie
void
Depuis
3.2

Loading language file from the administrator/language directory then loading language file from the administrator/components/extension/language directory

Références $component, $lang, Path\clean(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ mergeLabels()

static mergeLabels | ( | $object,
 |  | $formValues
 | ) |
static

Method to create object to pass to the layout. Format is as follows: field is std object with name, value.

Value can be a std object with name, value pairs.

Paramètres
\stdClass | $object | The std object from the JSON string. Can be nested 1 level deep.
\stdClass | $formValues | Standard class of label and value in an associative array.
Renvoie
Object with translated labels where available
Depuis
3.2

Références $name, $result, $value, et null.

◆ prepareData()

static prepareData ( ContentHistory $table )
static

Method to prepare the object for the preview and compare views.

Paramètres
ContentHistory $table Table object loaded with data.
Renvoie
Object ready for the views.
Depuis
3.2

Références Table\getInstance().

◆ processLookupFields()

static processLookupFields | ( |  | $object,
 |  | ContentType | $typesTable
 | ) |  |
static

Method to process any lookup values found in the content_history_options column for this table. This allows category title and user name to be displayed instead of the id column.

Paramètres
\stdClass | $object | The std object from the JSON string. Can be nested 1 level deep.
ContentType | $typesTable | Table object loaded with data.
Renvoie
Object with lookup values inserted.
Depuis
3.2

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContenthistoryHelper.php


Joomla CMS: Référence de la classe CompareModel

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Model
  • CompareModel
Fonctions membres publiques
Référence de la classe CompareModel
+ Graphe d'héritage de CompareModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($type='Contenthistory', $prefix='Joomla\\CMS\\Table\\', $config=array())
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of contenthistory records.

Depuis
3.2

Documentation des fonctions membres

◆ getTable()

getTable | ( | $type = 'Contenthistory',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.2

Références $config, $prefix, $type, et Table\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CompareModel.php


Joomla CMS: Référence de la classe HistoryModel

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Model
  • HistoryModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HistoryModel
+ Graphe d'héritage de HistoryModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
delete (&$pks)
getItems ()
getTable ($type='ContentHistory', $prefix='Joomla\\CMS\\Table\\', $config=array())
keep (&$pks)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
populateState ($ordering='h.save_date', $direction='DESC')
getListQuery ()
getSha1Hash ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of contenthistory records.

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a history record can be deleted. Note that we check whether we have edit permissions for the content item row.

Paramètres
ContentHistory $record A Table object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
3.6

◆ delete()

delete ( & $pks )

Method to delete one or more records from content history table.

Paramètres
array $pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
3.2

Références $i, Text\_(), Log\add(), Factory\getApplication(), et Log\WARNING.

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.4.5
Exceptions
NotAllowed Thrown if not authorised to edit an item

Implémente ListModelInterface.

Références $items, $user, Text\_(), et Factory\getUser().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
3.2

Références $db, $itemId, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\STRING.

◆ getSha1Hash()

getSha1Hash ( )
protected

Get the sha1 hash value for the current item being edited.

Renvoie
string sha1 hash of row data
Depuis
3.2

Références $helper, $result, Table\addIncludePath(), Factory\getApplication(), et JPATH_ADMINISTRATOR.

◆ getTable()

getTable | ( | $type = 'ContentHistory',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.2

Références $config, $prefix, $type, et Table\getInstance().

◆ keep()

keep ( & $pks )

Method to toggle on and off the keep forever value for one or more records from content history table.

Paramètres
array $pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
3.2

Références $i, Text\_(), Log\add(), Factory\getApplication(), et Log\WARNING.

◆ populateState()

populateState | ( | $ordering = 'h.save_date',
 |  | $direction = 'DESC'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.2

Références $direction, $input, $itemId, $ordering, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HistoryModel.php


Joomla CMS: Référence de la classe PreviewModel

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • Model
  • PreviewModel
Fonctions membres publiques
Référence de la classe PreviewModel
+ Graphe d'héritage de PreviewModel:
ItemModel BaseDatabaseModel ItemModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($type='ContentHistory', $prefix='Joomla\\CMS\\Table\\', $config=array())
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de ItemModelInterface
getItem ($pk=null)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de ItemModel
getStoreId ($id='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de ItemModel
$_item = null
$_context = 'group.type'
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of contenthistory records.

Depuis
3.2

Documentation des fonctions membres

◆ getTable()

getTable | ( | $type = 'ContentHistory',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.2

Références $config, $prefix, $type, et Table\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PreviewModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • Compare
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$items
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View class for a list of contenthistory.

Depuis
3.2

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
3.2

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $items

$items
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/View/Compare/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • History
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View class for a list of contenthistory.

Depuis
3.2

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
3.2

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/View/History/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Contenthistory
  • Administrator
  • View
  • Preview
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View class for a list of contenthistory.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
3.2

Implémente ViewInterface.

Références Text\_(), Factory\getLanguage(), JPATH_SITE, et null.

Documentation des champs

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/src/View/Preview/HtmlView.php


Joomla CMS: Référence de la classe HistoryController

  • Joomla
  • Component
  • Contenthistory
  • Api
  • Controller
  • HistoryController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe HistoryController
+ Graphe d'héritage de HistoryController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'history'
$default_view = 'history'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getItemIdFromInput ()
getTypeIdFromInput ()
getTypeAliasFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The history controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getItemIdFromInput()

getItemIdFromInput ( )
private

Get item id from input

Renvoie
string
Depuis
4.0.0

◆ getTypeAliasFromInput()

getTypeAliasFromInput ( )
private

Get type alias from input

Renvoie
string
Depuis
4.0.0

◆ getTypeIdFromInput()

getTypeIdFromInput ( )
private

Get type id from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'history'
protected

◆ $default_view

$default_view = 'history'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_contenthistory/src/Controller/HistoryController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Contenthistory
  • Api
  • View
  • History
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The history view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'ucm_item_id',
'ucm_type_id',
'version_note',
'save_date',
'editor_user_id',
'character_count',
'sha1_hash',
'version_data',
'keep_forever',
'editor',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contenthistory/src/View/History/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Contenthistory
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

History manager master display controller.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
?Input | $input The Input object for the request
Depuis
3.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contenthistory/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Contenthistory
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_contenthistory

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void
Exceptions

◆ getController()

getController | ( | string | $name,
 |  | string | $client = '',
 |  | array | $config = array()
 | ) |  |

Get a controller from the component

Paramètres
string | $name | Controller name
string | $client | Optional client (like Administrator, Site etc.)
array | $config | Optional controller config
Renvoie
BaseController
Depuis
4.0.0

Références $client, $config, et $name.

◆ loadLanguage()

loadLanguage ( )
protected

Load the language

Depuis
4.0.0
Renvoie
void

Références JPATH_ADMINISTRATOR, et JPATH_SITE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_contenthistory/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
addModule ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'cpanel'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Cpanel Controller

Depuis
1.5

Documentation des fonctions membres

◆ addModule()

addModule ( )

Method to add a module to a dashboard

Depuis
4.0.0
Renvoie
void

Références $function, $position, et Route\_().

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Typical view method for MVC based architecture

This function is provide as a default implementation, in most cases you will need to override it in your own controllers.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe url parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticAninstanceofthecurrentobjecttosupportchaining.@since3.0

Documentation des champs

◆ $default_view

$default_view = 'cpanel'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_cpanel/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_cpanel

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void
Exceptions
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_cpanel/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Cpanel
  • Administrator
  • View
  • Cpanel
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$modules = null
$quickicons = null
$position = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

HTML View class for the Cpanel component

Depuis
1.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $app, $component, $icon, $key, $lang, $manifest, $parts, $position, $prefix, $title, Text\_(), elseif, Factory\getApplication(), Factory\getLanguage(), ModuleHelper\getModules(), ToolbarHelper\help(), JPATH_ADMINISTRATOR, JPATH_BASE, ApplicationHelper\stringURLSafe(), et ToolbarHelper\title().

Documentation des champs

◆ $modules

$modules = null
protected

◆ $position

$position = null
protected

◆ $quickicons

$quickicons = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_cpanel/src/View/Cpanel/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'fields'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Fields Controller

Depuis
3.7.0

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Typical view method for MVC based architecture

This function is provide as a default implementation, in most cases you will need to override it in your own controllers.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | bool | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean()@returnBaseController|booleanAControllerobjecttosupportchaining.@since3.7.0

Références $id, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'fields'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe FieldController

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
  • FieldController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe FieldController
+ Graphe d'héritage de FieldController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_FIELDS_FIELD'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Attributs privés

$internalContext
$component

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Field controller

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.7.0

Références $app, $config, $input, $parts, Symfony\Contracts\Service\__construct(), FieldsHelper\extract(), et null.

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
3.7.0

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
3.7.0

Références $data, $key, $recordId, $this, et $user.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
object $model The model.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
3.7.0

Références $model, et Joomla\Application\checkToken().

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
3.7.0

Références $recordId.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
3.7.0

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
3.7.0

Références $item, et $model.

Documentation des champs

◆ $component

$component
private

◆ $internalContext

$internalContext
private

◆ $text_prefix

$text_prefix = 'COM_FIELDS_FIELD'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldController.php


Joomla CMS: Référence de la classe FieldsController

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
  • FieldsController
Fonctions membres publiques | Attributs protégés
Référence de la classe FieldsController
+ Graphe d'héritage de FieldsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Field', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_FIELDS_FIELD'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Fields list controller class.

Depuis
3.7.0

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Field',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model.
string | $prefix | The prefix for the PHP class name.
array | $config | Array of configuration parameters.
Renvoie
Depuis
3.7.0

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_FIELDS_FIELD'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/Controller/FieldsController.php


Joomla CMS: Référence de la classe GroupController

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
  • GroupController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe GroupController
+ Graphe d'héritage de GroupController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='parent_id')
postSaveHook (BaseDatabaseModel $model, $validData=array())
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_FIELDS_GROUP'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Attributs privés

$component = ''

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Group controller

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
3.7.0

Références $app, $config, $input, $parts, Symfony\Contracts\Service\__construct(), et FieldsHelper\extract().

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
3.7.0

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'parent_id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
3.7.0

Références $data, $key, $recordId, $this, et $user.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
object $model The model.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
3.7.0

Références $model, et Joomla\Application\checkToken().

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et $recordId.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
3.7.0

Références $item, et $model.

Documentation des champs

◆ $component

$component = ''
private

◆ $text_prefix

$text_prefix = 'COM_FIELDS_GROUP'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/Controller/GroupController.php


Joomla CMS: Référence de la classe GroupsController

  • Joomla
  • Component
  • Fields
  • Administrator
  • Controller
  • GroupsController
Fonctions membres publiques | Attributs protégés
Référence de la classe GroupsController
+ Graphe d'héritage de GroupsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Group', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_FIELDS_GROUP'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Groups list controller class.

Depuis
3.7.0

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Group',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model.
string | $prefix | The prefix for the PHP class name.
array | $config | Array of configuration parameters.
Renvoie
Depuis
3.7.0

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_FIELDS_GROUP'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/Controller/GroupsController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Fields
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_fields

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void

Références $context, $parts, et FieldsHelper\extract().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe FieldsComponent

  • Joomla
  • Component
  • Fields
  • Administrator
  • Extension
  • FieldsComponent
Fonctions membres protégées
Référence de la classe FieldsComponent
+ Graphe d'héritage de FieldsComponent:
MVCComponent CategoryServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres protégées

getTableNameForSection (string $section=null)

Membres hérités additionnels

- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de CategoryServiceInterface
getCategory (array $options=[], $section='')
countItems (array $items, string $section)
prepareForm (Form $form, $data)

Description détaillée

Component class for com_fields

Depuis
4.0.0

Documentation des fonctions membres

◆ getTableNameForSection()

getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldsComponent.php


Joomla CMS: Référence de la classe ComponentsFieldgroupField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • ComponentsFieldgroupField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentsFieldgroupField
+ Graphe d'héritage de ComponentsFieldgroupField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ComponentsFieldgroup'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Components Fieldgroup field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.7.0

Références $c, $component, $context, $db, $item, $items, $lang, $options, $query, Text\_(), Access\getActionsFromFile(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ComponentsFieldgroup'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentsFieldgroupField.php


Joomla CMS: Référence de la classe ComponentsFieldsField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • ComponentsFieldsField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentsFieldsField
+ Graphe d'héritage de ComponentsFieldsField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ComponentsFields'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Components Fields field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.7.0

Références $c, $component, $context, $db, $item, $items, $lang, $options, $query, Text\_(), Access\getActionsFromFile(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ComponentsFields'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentsFieldsField.php


Joomla CMS: Référence de la classe FieldcontextsField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • FieldcontextsField
Champs de données | Fonctions membres protégées
Référence de la classe FieldcontextsField
+ Graphe d'héritage de FieldcontextsField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Fieldcontexts'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Contexts

Depuis
3.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a generic list. Use the multiple attribute to enable multiselect.

Renvoie
string The field input markup.
Depuis
3.7.0

Références Joomla\Application\getInput().

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.7.0

Références $component, $parts, Factory\getApplication(), et value.

Documentation des champs

◆ $type

$type = 'Fieldcontexts'
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldcontextsField.php


Joomla CMS: Référence de la classe FieldgroupsField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • FieldgroupsField
Champs de données | Fonctions membres protégées
Référence de la classe FieldgroupsField
+ Graphe d'héritage de FieldgroupsField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Fieldgroups'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Groups

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.7.0

Références $context, $db, $option, $options, $query, $user, Joomla\Database\getDatabase(), Factory\getUser(), et ArrayHelper\toInteger().

Documentation des champs

◆ $type

$type = 'Fieldgroups'
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldgroupsField.php


Joomla CMS: Référence de la classe FieldLayoutField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • FieldLayoutField
Fonctions membres protégées | Attributs protégés
Référence de la classe FieldLayoutField
+ Graphe d'héritage de FieldLayoutField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'FieldLayout'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to display a list of the layouts for a field from the extension or template overrides.

Depuis
3.9.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input for a field layout field.

Renvoie
string The field input.
Depuis
3.9.0

Références $attr, $db, $extension, $groups, $html, $i, $query, $selected, $template, $value, Text\_(), HTMLHelper\_(), Path\clean(), Folder\files(), Joomla\Database\getDatabase(), JPATH_SITE, name, Text\sprintf(), et value.

Documentation des champs

◆ $type

$type = 'FieldLayout'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldLayoutField.php


Joomla CMS: Référence de la classe SectionField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • SectionField
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe SectionField
+ Graphe d'héritage de SectionField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'Section'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Section

Depuis
3.7.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a generic list. Use the multiple attribute to enable multiselect.

Renvoie
string The field input markup.
Depuis
3.7.0

Références Factory\getApplication(), et Joomla\Application\getInput().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
3.7.0

Références $return, et $value.

Documentation des champs

◆ $type

$type = 'Section'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SectionField.php


Joomla CMS: Référence de la classe SubfieldsField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • SubfieldsField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe SubfieldsField
+ Graphe d'héritage de SubfieldsField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'Subfields'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$context = ''
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs protégés statiques

static | $customFieldsCache = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Subfields. Represents a list field with the options being all possible custom field types, except the 'subform' custom field type.

Depuis
4.0.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
4.0.0

Références $b, $context, $options, Text\_(), HTMLHelper\_(), Factory\getApplication(), FieldsHelper\getFields(), et null.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.0.0

Références $return, et $value.

Documentation des champs

◆ $context

$context = ''
protected

◆ $customFieldsCache

$customFieldsCache = array()
staticprotected

◆ $type

$type = 'Subfields'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubfieldsField.php


Joomla CMS: Référence de la classe TypeField

  • Joomla
  • Component
  • Fields
  • Administrator
  • Field
  • TypeField
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe TypeField
+ Graphe d'héritage de TypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'Type'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Type

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.7.0

Références $b, $options, HTMLHelper\_(), Factory\getApplication(), et FieldsHelper\getFieldTypes().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
3.7.0

Références $return, et $value.

Documentation des champs

◆ $type

$type = 'Type'
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/Field/TypeField.php


Joomla CMS: Référence de la classe FieldsHelper

  • Joomla
  • Component
  • Fields
  • Administrator
  • Helper
  • FieldsHelper
Fonctions membres publiques statiques | Attributs privés statiques
Référence de la classe FieldsHelper
+ Graphe d'héritage de FieldsHelper:
FieldsHelper

Fonctions membres publiques statiques

static | extract ($contextString, $item=null)
static | getFields ( $context, $item=null, $prepareValue=false, array $valuesToOverride=null, bool $includeSubformFields=false)
static | render ($context, $layoutFile, $displayData)
static | canEditFieldValue ($field)
static | displayFieldOnForm ($field)
static | getAssignedCategoriesIds ($fieldId)
static | getAssignedCategoriesTitles ($fieldId)
static | getFieldsPluginId ()
static | getFieldTypes ()
static | clearFieldsCache ()

Attributs privés statiques

static | $fieldsCache = null
static | $fieldCache = null

Description détaillée

FieldsHelper

Depuis
3.7.0

Documentation des fonctions membres

◆ canEditFieldValue()

static canEditFieldValue ( $field )
static

Return a boolean if the actual logged in user can edit the given field value.

Paramètres
\stdClass $field The field
Renvoie
boolean
Depuis
3.7.0

Références $field, $parts, et Factory\getUser().

Référencé par FieldsPlugin\onCustomFieldsPrepareDom(), et FieldModel\setFieldValue().

◆ clearFieldsCache()

static clearFieldsCache ( )
static

Clears the internal cache for the custom fields.

Renvoie
void
Depuis
3.8.0

Références null.

Référencé par FieldModel\save(), et FieldModel\setFieldValue().

◆ displayFieldOnForm()

static displayFieldOnForm ( $field )
static

Return a boolean based on field (and field group) display / show_on settings

Paramètres
\stdClass $field The field
Renvoie
boolean
Depuis
3.8.7

Références $app, $field, elseif, et Factory\getApplication().

Référencé par FieldsPlugin\onCustomFieldsPrepareDom().

◆ extract()

static extract | ( | $contextString,
 |  | $item = null
 | ) |
static

Extracts the component and section from the context string which has to be in the format component.context.

Paramètres
string | $contextString | contextString
object | $item | optional item object
Renvoie
array|null
Depuis
3.7.0

Références $component, $item, $parts, Factory\getApplication(), et null.

Référencé par GroupController\__construct(), FieldController\__construct(), HtmlView\addToolbar(), FieldModel\canDelete(), FieldModel\canEditState(), Dispatcher\checkAccess(), PrivacyPlugin\createCustomFieldsDomain(), HtmlView\display(), PlgSystemFields\display(), FieldModel\getForm(), FieldsModel\getListQuery(), PlgSystemFields\onContentNormaliseRequestData(), PlgSystemFields\onContentPrepare(), PlgSystemFields\onContentPrepareForm(), FieldsModel\populateState(), FieldModel\populateState(), PlgContentFields\prepare(), et GroupModel\preprocessForm().

◆ getAssignedCategoriesIds()

static getAssignedCategoriesIds ( $fieldId )
static

Gets assigned categories ids for a field

Paramètres

Références $db, $query, et Factory\getDbo().

◆ getAssignedCategoriesTitles()

static getAssignedCategoriesTitles ( $fieldId )
static

Gets assigned categories titles for a field

Paramètres

Références $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ getFields()

static getFields | ( |  | $context,
 |  |  | $item = null,
 |  |  | $prepareValue = false,
 |  | array | $valuesToOverride = null,
 |  | bool | $includeSubformFields = false
 | ) |  |
static

Returns the fields for the given context. If the item is an object the returned fields do have an additional field "value" which represents the value for the given item. If the item has an assigned_cat_ids field, then additionally fields which belong to that category will be returned. Should the value being prepared to be shown in an HTML context then prepareValue must be set to true. No further escaping needs to be done. The values of the fields can be overridden by an associative array where the keys have to be a name and its corresponding value.

Paramètres
string | $context | The context of the content passed to the helper
null | $item | The item being edited in the form
int | bool | $prepareValue | (if int is display event): 1 - AfterTitle, 2 - BeforeDisplay, 3 - AfterDisplay, 0 - OFF
array | null | $valuesToOverride | The values to override
bool | $includeSubformFields | Should I include fields marked as Only Use In Subform?
Renvoie
array
Exceptions

Références $context, $field, $fields, $item, $key, $value, elseif, Factory\getApplication(), PluginHelper\importPlugin(), Multilanguage\isEnabled(), et null.

Référencé par ContactController\_sendEmail(), ArticleModel\batchMove(), ArticleModel\cleanupPostBatchCopy(), PrivacyPlugin\createCustomFieldsDomain(), PlgSystemFields\display(), JsonapiView\displayItem(), JsonapiView\displayList(), SubfieldsField\getOptions(), PlgFieldsSubform\getSubfieldsFromField(), PlgSystemFields\onContentPrepare(), PlgContentFields\prepare(), JsonapiView\prepareItem(), UsersController\preprocessSaveData(), ContactController\preprocessSaveData(), et ArticlesController\preprocessSaveData().

◆ getFieldsPluginId()

static getFieldsPluginId ( )
static

Gets the fields system plugin extension id.

Renvoie
integer The fields system plugin extension id.
Depuis
3.7.0

Références $db, $query, $result, Factory\getApplication(), et Factory\getDbo().

Référencé par HtmlView\display().

◆ getFieldTypes()

static getFieldTypes ( )
static

Loads the fields plugins and returns an array of field types from the plugins.

The returned array contains arrays with the following keys:

  • label: The label of the field
  • type: The type of the field
  • path: The path of the folder where the field can be found
Renvoie
array
Depuis
3.7.0

Références $data, $fields, Factory\getApplication(), PluginHelper\importPlugin(), et null.

Référencé par FieldModel\checkDefaultValue(), et TypeField\getOptions().

◆ render()

static render | ( | $context,
 |  | $layoutFile,
 |  | $displayData
 | ) |
static

Renders the layout file and data on the context and does a fall back to Fields afterwards.

Paramètres
string | $context | The context of the content passed to the helper
string | $layoutFile | layoutFile
array | $displayData | displayData
Renvoie
NULL|string
Depuis
3.7.0

Références $context, $displayData, $parts, $value, null, et LayoutHelper\render().

Référencé par ContactController\_sendEmail(), PlgSystemFields\display(), et PlgContentFields\prepare().

Documentation des champs

◆ $fieldCache

$fieldCache = null
staticprivate

◆ $fieldsCache

$fieldsCache = null
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldsHelper.php


Joomla CMS: Référence de la classe FieldModel

  • Joomla
  • Component
  • Fields
  • Administrator
  • Model
  • FieldModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe FieldModel
+ Graphe d'héritage de FieldModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
save ($data)
getItem ($pk=null)
getTable ($name='Field', $prefix='Administrator', $options=array())
delete (&$pks)
getForm ($data=array(), $loadData=true)
setFieldValue ($fieldId, $itemId, $value)
getFieldValue ($fieldId, $itemId)
getFieldValues (array $fieldIds, $itemId)
cleanupValues ($context, $itemId)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = null
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

generateNewTitle ($categoryId, $name, $title)
canDelete ($record)
canEditState ($record)
populateState ()
getReorderConditions ($table)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
cleanCache ($group=null, $clientId=0)
batchCopy ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_FIELDS'
$batch_copymove = 'group_id'
$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

checkDefaultValue ($data)
getParams ($params)

Attributs privés

$valueCache = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Field Model

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
Depuis
3.7.0
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ batchCopy()

batchCopy | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch copy fields to a new group.

Paramètres
integer | $value | The new value matching a fields group.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
array|boolean new IDs if successful, false otherwise and internal error is set.
Depuis
3.7.0

Références $component, $user, $value, Text\_(), et Factory\getUser().

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move fields to a new group.

Paramètres
integer | $value | The new value matching a fields group.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
3.7.0

Références $context, $user, $value, Text\_(), Factory\getApplication(), et Factory\getUser().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
3.7.0

Références $parts, FieldsHelper\extract(), et Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
3.7.0

Références $parts, $user, FieldsHelper\extract(), et Factory\getUser().

◆ checkDefaultValue()

checkDefaultValue ( $data )
private

Checks if the default value is valid for the given data. If a string is returned then it can be assumed that the default value is invalid.

Paramètres
array $data The data.
Renvoie
true|string true if valid, a string containing the exception message when not.
Depuis
3.7.0

Références $data, $form, $path, $result, $type, Text\_(), FormHelper\addRulePath(), class, Factory\getApplication(), Factory\getContainer(), Joomla\Database\getDatabase(), FieldsHelper\getFieldTypes(), et FormHelper\loadRuleType().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Clean the cache

Paramètres
string | $group | The cache group
integer | $clientId

Références $context, et Factory\getApplication().

◆ cleanupValues()

cleanupValues | ( | $context,
 |  | $itemId
 | ) |

Cleaning up the values for the given item on the context.

Paramètres
string | $context | The context.
string | $itemId | The Item ID.
Renvoie
void
Depuis
3.7.0

Références $context, $itemId, $query, et Joomla\Database\getDatabase().

◆ delete()

delete ( & $pks )

Method to delete one or more records.

Paramètres
array $pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
3.7.0

Références $query, Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $name,
 |  | $title
 | ) |
protected

Method to change the title & name.

Paramètres
integer | $categoryId | The id of the category.
string | $name | The name.
string | $title | The title.
Renvoie
array Contains the modified title and name.
Depuis
3.7.0

Références $name, $title, et StringHelper\increment().

◆ getFieldValue()

getFieldValue | ( | $fieldId,
 |  | $itemId
 | ) |

Returning the value for the given field id, context and item id.

Paramètres
string | $fieldId | The field ID.
string | $itemId | The ID of the item.
Renvoie
NULL|string
Depuis
3.7.0

Références $itemId, et null.

◆ getFieldValues()

getFieldValues | ( | array | $fieldIds,
 |  |  | $itemId
 | ) |  |

Returning the values for the given field ids, context and item id.

Paramètres
array | $fieldIds | The field Ids.
string | $itemId | The ID of the item.
Renvoie
NULL|array
Depuis
3.7.0

Références $data, $itemId, $key, $query, $rows, Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Abstract method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
3.7.0

Implémente FormModelInterface.

Références $context, $data, $form, $parts, FieldsHelper\extract(), Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), PluginHelper\importPlugin(), Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
3.7.0

Références $db, $query, $result, Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et null.

◆ getParams()

getParams ( $params )
private

Converts the unknown params into an object.

Paramètres
mixed $params The params.
Renvoie
Object on success, false on failure.
Depuis
3.7.0

Références $params.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
Table $table A Table object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
3.7.0

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $name = 'Field',
 |  | $prefix = 'Administrator',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.7.0
Exceptions

Références $name, $options, et $prefix.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
3.7.0

Références $app, $data, $filters, $this, Factory\getApplication(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Stock method to auto-populate the model state.

Renvoie
void
Depuis
3.7.0

Références $app, $context, $params, $parts, FieldsHelper\extract(), Factory\getApplication(), ComponentHelper\getParams(), null, et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
3.7.0
Exceptions

Références $component, $data, $form, $key, $lang, $path, $section, Text\_(), Path\clean(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_BASE, null, et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
3.7.0

If the field is only used in subform, set Category to None automatically so that it will only be displayed as part of SubForm on add/edit item screen

If the options have changed, delete the values. This should only apply for list, checkboxes and radio custom field types, because when their options are being changed, their values might get invalid, because e.g. there is a value selected from a list, which is not part of the list anymore. Hence we need to delete all values that are not part of the options anymore. Note: The only field types with fieldparams+options are those above listed plus the subfields type. And we do explicitly not want the values to be deleted when the options of a subfields field are getting changed.

Références $data, $db, $field, $id, $input, $message, $name, $names, $query, $title, FieldsHelper\clearFieldsCache(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), ParameterType\INTEGER, null, ParameterType\STRING, et ArrayHelper\toInteger().

◆ setFieldValue()

setFieldValue | ( | $fieldId,
 |  | $itemId,
 |  | $value
 | ) |

Setting the value for the given field id, context and item id.

Paramètres
string | $fieldId | The field ID.
string | $itemId | The ID of the item.
string | $value | The value.
Renvoie
boolean
Depuis
3.7.0

Références $field, $itemId, $params, $query, $value, FieldsHelper\canEditFieldValue(), FieldsHelper\clearFieldsCache(), elseif, Joomla\Database\getDatabase(), ParameterType\INTEGER, et null.

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFormRule
JFilterInput
Depuis
3.9.23

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage'
)

◆ $batch_copymove

$batch_copymove = 'group_id'
protected

◆ $text_prefix

$text_prefix = 'COM_FIELDS'
protected

◆ $typeAlias

$typeAlias = null

◆ $valueCache

$valueCache = array()
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldModel.php


Joomla CMS: Référence de la classe FieldsModel

  • Joomla
  • Component
  • Fields
  • Administrator
  • Model
  • FieldsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FieldsModel
+ Graphe d'héritage de FieldsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getFilterForm ($data=array(), $loadData=true)
getGroups ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
getListQuery ()
_getList ($query, $limitstart=0, $limit=0)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Fields Model

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
Depuis
3.7.0
Exceptions

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Gets an array of objects from the results of database query.

Paramètres
string | $query | The query.
integer | $limitstart | Offset.
integer | $limit | The number of records.
Renvoie
array An array of results.
Depuis
3.7.0
Exceptions

Références $field, $limit, $query, et $result.

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
|bool the Form object or false
Depuis
3.7.0

Références $data, $form, Joomla\CMS\MVC\Model\getState(), et null.

◆ getGroups()

getGroups ( )

Get the groups for the batch method

Renvoie
array An array of groups
Depuis
3.7.0

Références $context, $db, $query, $user, Joomla\Database\getDatabase(), Factory\getUser(), et ArrayHelper\toInteger().

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
A DatabaseQuery object to retrieve the data set.
Depuis
3.7.0

Références $app, $context, $db, $groups, $language, $parts, $query, $state, $user, elseif, FieldsHelper\extract(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, null, ParameterType\STRING, et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on the model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id An identifier string to generate the store id.
Renvoie
string A store id.
Depuis
3.7.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.7.0

Références $context, $parts, FieldsHelper\extract(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldsModel.php


Joomla CMS: Référence de la classe GroupModel

  • Joomla
  • Component
  • Fields
  • Administrator
  • Model
  • GroupModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe GroupModel
+ Graphe d'héritage de GroupModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

save ($data)
getTable ($name='Group', $prefix='Administrator', $options=array())
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
getItem ($pk=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = null
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
populateState ()
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
loadFormData ()
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Group Model

Depuis
3.7.0

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
3.7.0

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
3.7.0

Références $user, et Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Clean the cache

Paramètres
string | $group | The cache group
integer | $clientId

Références $context, et Factory\getApplication().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Abstract method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
mixed A Form object on success, false on failure
Depuis
3.7.0

Implémente FormModelInterface.

Références $context, $data, $form, $user, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
3.7.0

Références $item, et Joomla\CMS\MVC\Model\getState().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
Table $table A Table object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
3.7.0

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $name = 'Group',
 |  | $prefix = 'Administrator',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.7.0
Exceptions

Références $name, $options, et $prefix.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
3.7.0

Références $app, $context, $data, $filters, Factory\getApplication(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.7.0

Références $context, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Voir également
Depuis
3.7.0
Exceptions

Références $component, $data, $form, $lang, $parts, $path, $section, Text\_(), Path\clean(), FieldsHelper\extract(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_BASE, null, et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
3.7.0

Références $data, $input, et Factory\getApplication().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFormRule
JFilterInput
Depuis
3.9.23

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage'
)

◆ $typeAlias

$typeAlias = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/Model/GroupModel.php


Joomla CMS: Référence de la classe GroupsModel

  • Joomla
  • Component
  • Fields
  • Administrator
  • Model
  • GroupsModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe GroupsModel
+ Graphe d'héritage de GroupsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
getListQuery ()
_getList ($query, $limitstart=0, $limit=0)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$context = 'com_fields.groups'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Groups Model

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
Depuis
3.7.0
Exceptions

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Gets an array of objects from the results of database query.

Paramètres
string | $query | The query.
integer | $limitstart | Offset.
integer | $limit | The number of records.
Renvoie
array An array of results.
Depuis
3.8.7
Exceptions

Références $limit, $query, et $result.

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
A DatabaseQuery object to retrieve the data set.
Depuis
3.7.0

Références $context, $db, $groups, $language, $listDirn, $query, $state, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, ParameterType\STRING, et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on the model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id An identifier string to generate the store id.
Renvoie
string A store id.
Depuis
3.7.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.7.0

Références $context, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $context

$context = 'com_fields.groups'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/Model/GroupsModel.php


Joomla CMS: Référence de la classe FieldsListPlugin

  • Joomla
  • Component
  • Fields
  • Administrator
  • Plugin
  • FieldsListPlugin
Fonctions membres publiques
Référence de la classe FieldsListPlugin
+ Graphe d'héritage de FieldsListPlugin:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface PlgFieldsCheckboxes PlgFieldsList PlgFieldsRadio PlgFieldsSql

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
getOptionsFromField ($field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Base plugin for all list based plugins

Depuis
3.7.0

Documentation des fonctions membres

◆ getOptionsFromField()

getOptionsFromField ( $field )

Returns an array of key values to put in a list from the given field.

Paramètres
\stdClass $field The field.
Renvoie
array
Depuis
3.7.0

Références $data, $field, $option, et $params.

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | \DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
\stdClass | $field | The field.
\DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
Depuis
3.7.0

Références $field, $form, $name, $option, $value, Text\_(), et ENT_COMPAT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldsListPlugin.php


Joomla CMS: Référence de la classe FieldsPlugin

  • Joomla
  • Component
  • Fields
  • Administrator
  • Plugin
  • FieldsPlugin
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FieldsPlugin
+ Graphe d'héritage de FieldsPlugin:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface FieldsListPlugin PlgFieldsCalendar PlgFieldsColor PlgFieldsEditor PlgFieldsImagelist PlgFieldsInteger PlgFieldsMedia PlgFieldsSubform PlgFieldsText PlgFieldsTextarea PlgFieldsUrl PlgFieldsUser PlgFieldsUsergrouplist

Fonctions membres publiques

onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Abstract Fields Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ getFormPath()

getFormPath | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Returns the path of the XML definition file for the field parameters

Paramètres
Form | $form | The form
\stdClass | $data | The data
Renvoie
string
Depuis
4.0.0

Références $data, $form, $path, $type, JPATH_PLUGINS, et null.

◆ isTypeSupported()

isTypeSupported ( $type )
protected

Returns true if the given type is supported by the plugin.

Paramètres
string $type The type
Renvoie
boolean
Depuis
3.7.0

Références $type.

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

The form event. Load additional parameters when available into the field form. Only when the type of the form is of interest.

Paramètres
Form | $form | The form
\stdClass | $data | The data
Renvoie
void
Depuis
3.7.0

Références $data, $form, $path, et null.

◆ onCustomFieldsGetTypes()

onCustomFieldsGetTypes ( )

Returns the custom fields types.

Renvoie
string[][]
Depuis
3.7.0

Références $data, $key, $layout, $path, $root, Folder\files(), JPATH_PLUGINS, et Text\sprintf().

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | \DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
\stdClass | $field | The field.
\DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
Depuis
3.7.0

Références $field, $key, $layout, $params, FieldsHelper\canEditFieldValue(), FieldsHelper\displayFieldOnForm(), et null.

◆ onCustomFieldsPrepareField()

onCustomFieldsPrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Prepares the field value.

Paramètres
string | $context | The context.
\stdclass | $item | The item.
\stdclass | $field | The field.
Renvoie
string
Depuis
3.7.0

Références $field, $output, $params, $path, et PluginHelper\getLayoutPath().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldsPlugin.php


Joomla CMS: Référence de la classe FieldTable

  • Joomla
  • Component
  • Fields
  • Administrator
  • Table
  • FieldTable
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe FieldTable
+ Graphe d'héritage de FieldTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($db=null)
bind ($src, $ignore='')
check ()
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getAssetId ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Fields Table

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $db = null )

Class constructor.

Paramètres
DatabaseDriver $db DatabaseDriver object.
Depuis
3.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
3.7.0

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset under which to register this one. By default, all assets are registered to the ROOT node with ID, which will default to 1 if none exists. The extended class can define a table and id to lookup. If the asset does not exist it will be created.

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | Id to look up
Renvoie
integer
Depuis
3.7.0

Références $assetId, $component, et $id.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table. In tracking the assets a title is kept for each asset so that there is some context available in a unified access manager. Usually this would just return $this->title or $this->name or whatever is being used for the primary name of the row. If this method is not overridden, the asset name is used.

Renvoie
string The string to use as the title in the asset table.

3.7.0

Références $title.

◆ bind()

bind | ( | $src,
 |  | $ignore = ''
 | ) |

Method to bind an associative array or object to the JTable instance.This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
mixed | $src | An associative array or object to bind to the JTable instance.
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
3.7.0
Exceptions

Implémente TableInterface.

Références $i, $option, et $options.

◆ check()

check ( )

Method to perform sanity checks on the JTable instance properties to ensure they are safe to store in the database. Child classes should override this method to make sure the data they are storing in the database is safe and as expected before storage.

Renvoie
boolean True if the instance is sane and able to be stored in the database.

3.7.0

Implémente TableInterface.

Références $date, $title, $user, Text\_(), Factory\getDate(), Factory\getUser(), StringHelper\increment(), language, name, et ApplicationHelper\stringURLSafe().

◆ getAssetId()

getAssetId ( $name )
private

Returns an asset id for the given name or false.

Paramètres
string $name The asset name
Renvoie
number|boolean
Depuis
3.7.0

Références $assetId, $db, $name, $query, $result, Joomla\CMS\MVC\Model\getDbo(), et null.

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
4.0.0

Implémente TableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldTable.php


Joomla CMS: Référence de la classe GroupTable

  • Joomla
  • Component
  • Fields
  • Administrator
  • Table
  • GroupTable
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe GroupTable
+ Graphe d'héritage de GroupTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($db=null)
bind ($src, $ignore='')
check ()
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Groups Table

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $db = null )

Class constructor.

Paramètres
DatabaseDriver $db DatabaseDriver object.
Depuis
3.7.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
3.7.0

Références $component.

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Method to get the parent asset under which to register this one. By default, all assets are registered to the ROOT node with ID, which will default to 1 if none exists. The extended class can define a table and id to lookup. If the asset does not exist it will be created.

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | Id to look up
Renvoie
integer
Depuis
3.7.0

Références $assetId, $component, $db, $id, $query, et Joomla\CMS\MVC\Model\getDbo().

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table. In tracking the assets a title is kept for each asset so that there is some context available in a unified access manager. Usually this would just return $this->title or $this->name or whatever is being used for the primary name of the row. If this method is not overridden, the asset name is used.

Renvoie
string The string to use as the title in the asset table.

3.7.0

Références $title.

◆ bind()

bind | ( | $src,
 |  | $ignore = ''
 | ) |

Method to bind an associative array or object to the JTable instance.This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
mixed | $src | An associative array or object to bind to the JTable instance.
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
3.7.0
Exceptions

Implémente TableInterface.

◆ check()

check ( )

Method to perform sanity checks on the JTable instance properties to ensure they are safe to store in the database. Child classes should override this method to make sure the data they are storing in the database is safe and as expected before storage.

Renvoie
boolean True if the instance is sane and able to be stored in the database.

3.7.0

Implémente TableInterface.

Références $date, $user, Text\_(), Factory\getDate(), Factory\getUser(), et null.

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
4.0.0

Implémente TableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • GroupTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Field
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Field View

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the toolbar.

Renvoie
void
Depuis
3.7.0

Références $canDo, $component, $lang, $section, $title, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), Path\clean(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), ToolbarHelper\help(), JPATH_ADMINISTRATOR, ToolbarHelper\saveGroup(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
HtmlView::loadTemplate()
Depuis
3.7.0

Implémente ViewInterface.

Références ContentHelper\getActions(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/View/Field/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Fields
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Fields View

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the toolbar.

Renvoie
void
Depuis
3.7.0

Références $canDo, $component, $lang, $section, $title, $toolbar, Text\_(), Path\clean(), ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), Factory\getLanguage(), JPATH_ADMINISTRATOR, Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
::loadTemplate()
Depuis
3.7.0

Implémente ViewInterface.

Références $link, Route\_(), Factory\getApplication(), FieldsHelper\getFieldsPluginId(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), items, et Text\sprintf().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/View/Fields/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Group
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Group View

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the toolbar.

Renvoie
void
Depuis
3.7.0

Références $canDo, $component, $lang, $parts, $title, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), Path\clean(), FieldsHelper\extract(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), ToolbarHelper\help(), JPATH_ADMINISTRATOR, ToolbarHelper\saveGroup(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
JViewLegacy::loadTemplate()
Depuis
3.7.0

Implémente ViewInterface.

Références $component, $parts, FieldsHelper\extract(), ContentHelper\getActions(), et Factory\getApplication().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/View/Group/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Fields
  • Administrator
  • View
  • Groups
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Groups View

Depuis
3.7.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the toolbar.

Renvoie
void
Depuis
3.7.0

Références $canDo, $component, $lang, $parts, $title, $toolbar, Text\_(), Path\clean(), FieldsHelper\extract(), ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), Factory\getLanguage(), JPATH_ADMINISTRATOR, Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
HtmlView::loadTemplate()
Depuis
3.7.0

Implémente ViewInterface.

Références $link, Route\_(), Factory\getApplication(), FieldsHelper\getFieldsPluginId(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), items, et Text\sprintf().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/src/View/Groups/HtmlView.php


Joomla CMS: Référence de la classe FieldsController

  • Joomla
  • Component
  • Fields
  • Api
  • Controller
  • FieldsController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe FieldsController
+ Graphe d'héritage de FieldsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'fields'
$default_view = 'fields'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getContextFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The fields controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getContextFromInput()

getContextFromInput ( )
private

Get extension from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'fields'
protected

◆ $default_view

$default_view = 'fields'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_fields/src/Controller/FieldsController.php


Joomla CMS: Référence de la classe GroupsController

  • Joomla
  • Component
  • Fields
  • Api
  • Controller
  • GroupsController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe GroupsController
+ Graphe d'héritage de GroupsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'groups'
$default_view = 'groups'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getContextFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The groups controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getContextFromInput()

getContextFromInput ( )
private

Get extension from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'groups'
protected

◆ $default_view

$default_view = 'groups'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_fields/src/Controller/GroupsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Fields
  • Api
  • View
  • Fields
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The fields view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'typeAlias',
'id',
'asset_id',
'context',
'group_id',
'title',
'name',
'label',
'default_value',
'type',
'note',
'description',
'state',
'required',
'checked_out',
'checked_out_time',
'ordering',
'params',
'fieldparams',
'language',
'created_time',
'created_user_id',
'modified_time',
'modified_by',
'access',
'assigned_cat_ids',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/View/Fields/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Fields
  • Api
  • View
  • Groups
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The groups view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'typeAlias',
'id',
'asset_id',
'context',
'title',
'note',
'description',
'state',
'checked_out',
'checked_out_time',
'ordering',
'params',
'language',
'created',
'created_by',
'modified',
'modified_by',
'access',
'type',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_fields/src/View/Groups/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Fields
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base controller class for Fields Component.

Depuis
3.7.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
\Joomla\CMS\Input\Input | null | $input | The request's input object
Depuis
3.7.0

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), et JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_fields/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Fields
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_fields

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Renvoie
void
Depuis
4.0.0

Références $context, $parts, et FieldsHelper\extract().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_fields/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'index'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base controller class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanAControllerobjecttosupportchainingorfalseonfailure.@since2.5

Références $layout, $link, $view, Text\_(), Route\_(), HTMLHelper\_(), FinderHelper\getFinderPluginId(), PluginHelper\isEnabled(), null, et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'index'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe FilterController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • FilterController
Référence de la classe FilterController
+ Graphe d'héritage de FilterController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Indexer controller class for Finder.

Depuis
2.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • FilterController.php


Joomla CMS: Référence de la classe FiltersController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • FiltersController
Fonctions membres publiques | Attributs protégés
Référence de la classe FiltersController
+ Graphe d'héritage de FiltersController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Filter', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_FINDER_FILTERS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Filters controller class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Filter',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
2.5

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_FINDER_FILTERS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FiltersController.php


Joomla CMS: Référence de la classe IndexController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • IndexController
Fonctions membres publiques
Référence de la classe IndexController
+ Graphe d'héritage de IndexController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Index', $prefix='Administrator', $config=array('ignore_request'=> true))
optimise ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Index controller class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Index',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
2.5

Références $config, $name, et $prefix.

◆ optimise()

optimise ( )

Method to optimise the index by removing orphaned entries.

Renvoie
boolean True on success.
Depuis
4.2.0

Références $message, Text\_(), Joomla\Application\checkToken(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IndexController.php


Joomla CMS: Référence de la classe IndexerController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • IndexerController
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe IndexerController
+ Graphe d'héritage de IndexerController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

start ()
batch ()
optimize ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | sendResponse ($data=null)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())

Membres hérités additionnels

- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Indexer controller class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ batch()

batch ( )

Method to run the next batch of content through the indexer.

Renvoie
void
Depuis
2.5

Références $attributes, $lang, $options, $params, $state, Text\_(), Log\add(), Log\addLogger(), Session\checkToken(), Factory\getLanguage(), ComponentHelper\getParams(), Indexer\getState(), PluginHelper\importPlugin(), Log\INFO, et Indexer\setState().

◆ optimize()

optimize ( )

Method to optimize the index and perform any necessary cleanup.

Renvoie
void
Depuis
2.5

Références $state, Text\_(), Session\checkToken(), Indexer\getState(), et PluginHelper\importPlugin().

◆ sendResponse()

static sendResponse ( $data = null )
static

Method to handle a send a response. The body parameter can be an object for when an error has occurred or a CMSObject for a good response.

Paramètres
\Joomla\CMS\Object\CMSObject | \Exception $data CMSObject on success, on error. [optional]
Renvoie
void
Depuis
2.5

Références $app, $data, $options, $params, Log\add(), Log\addLogger(), Log\ERROR, Factory\getApplication(), ComponentHelper\getParams(), et JDEBUG.

◆ start()

start ( )

Method to start the indexer.

Renvoie
void
Depuis
2.5

Références $options, $params, $state, Text\_(), Log\add(), Log\addLogger(), Session\checkToken(), ComponentHelper\getParams(), Indexer\getState(), PluginHelper\importPlugin(), Log\INFO, Indexer\resetState(), et Text\script().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IndexerController.php


Joomla CMS: Référence de la classe MapsController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • MapsController
Fonctions membres publiques | Attributs protégés
Référence de la classe MapsController
+ Graphe d'héritage de MapsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Maps', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_FINDER_MAPS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Maps controller class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Maps',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_FINDER_MAPS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MapsController.php


Joomla CMS: Référence de la classe SearchesController

  • Joomla
  • Component
  • Finder
  • Administrator
  • Controller
  • SearchesController
Fonctions membres publiques
Référence de la classe SearchesController
+ Graphe d'héritage de SearchesController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

reset ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Methods supporting a list of search terms.

Depuis
4.0.0

Documentation des fonctions membres

◆ reset()

reset ( )

Method to reset the search log table.

Renvoie
void

Références $model, Text\_(), et Session\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SearchesController.php


Joomla CMS: Référence de la classe FinderComponent

  • Joomla
  • Component
  • Finder
  • Administrator
  • Extension
  • FinderComponent
Fonctions membres publiques
Référence de la classe FinderComponent
+ Graphe d'héritage de FinderComponent:
MVCComponent BootableExtensionInterface RouterServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_finder

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références $container, class, et Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FinderComponent.php


Joomla CMS: Référence de la classe BranchesField

  • Joomla
  • Component
  • Finder
  • Administrator
  • Field
  • BranchesField
Fonctions membres publiques | Attributs protégés
Référence de la classe BranchesField
+ Graphe d'héritage de BranchesField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Branches'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Search Branches field for the Finder package.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références HTMLHelper\_(), et Factory\getApplication().

Documentation des champs

◆ $type

$type = 'Branches'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • BranchesField.php


Joomla CMS: Référence de la classe ContentmapField

  • Joomla
  • Component
  • Finder
  • Administrator
  • Field
  • ContentmapField
Champs de données | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ContentmapField
+ Graphe d'héritage de ContentmapField:
GroupedlistField FormField DatabaseAwareInterface

Champs de données

$type = 'ContentMap'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Fonctions membres privées

prepareLevel ($parent, $parents)

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a select grouped list of finder content map.

Depuis
3.6.0

Documentation des fonctions membres

◆ getGroups()

getGroups ( )
protected

Method to get the list of content map options grouped by first level.

Renvoie
array The field option objects as a nested array in groups.
Depuis
3.6.0

Références $db, $groups, $item, $query, et Joomla\Database\getDatabase().

◆ prepareLevel()

prepareLevel | ( | $parent,
 |  | $parents
 | ) |
private

Indenting and translating options for the list

Paramètres
int | $parent | Parent ID to process
array | $parents | Array of arrays of items with parent IDs as keys
Renvoie
array The indented list of entries for this branch
Depuis
4.1.5

Références $item, $key, $lang, $text, Text\_(), HTMLHelper\_(), LanguageHelper\branchLanguageTitle(), LanguageHelper\branchSingular(), et Factory\getLanguage().

Documentation des champs

◆ $type

$type = 'ContentMap'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContentmapField.php


Joomla CMS: Référence de la classe ContenttypesField

  • Joomla
  • Component
  • Finder
  • Administrator
  • Field
  • ContenttypesField
Fonctions membres publiques | Attributs protégés
Référence de la classe ContenttypesField
+ Graphe d'héritage de ContenttypesField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'ContentTypes'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Content Types Filter field for the Finder package.

Depuis
3.6.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.6.0

Références $db, $key, $lang, $options, $query, Text\_(), HTMLHelper\_(), LanguageHelper\branchSingular(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ContentTypes'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContenttypesField.php


Joomla CMS: Référence de la classe SearchfilterField

  • Joomla
  • Component
  • Finder
  • Administrator
  • Field
  • SearchfilterField
Fonctions membres publiques | Attributs protégés
Référence de la classe SearchfilterField
+ Graphe d'héritage de SearchfilterField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'SearchFilter'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Search Filter field for the Finder package.

Depuis
2.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
2.5

Références $db, $options, $query, Text\_(), HTMLHelper\_(), et Joomla\Database\getDatabase().

Documentation des champs

◆ $type

$type = 'SearchFilter'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SearchfilterField.php


Joomla CMS: Référence de la classe FinderHelper

  • Joomla
  • Component
  • Finder
  • Administrator
  • Helper
  • FinderHelper
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe FinderHelper

Fonctions membres publiques statiques

static getFinderPluginId ()

Attributs publics statiques

static $extension = 'com_finder'

Description détaillée

Helper class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getFinderPluginId()

static getFinderPluginId ( )
static

Gets the finder system plugin extension id.

Renvoie
integer The finder system plugin extension id.
Depuis
3.6.0

Références ExtensionHelper\getExtensionRecord(), et null.

Référencé par DisplayController\display(), et HtmlView\display().

Documentation des champs

◆ $extension

$extension = 'com_finder'
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Helper/FinderHelper.php


Joomla CMS: Référence de la classe LanguageHelper

  • Joomla
  • Component
  • Finder
  • Administrator
  • Helper
  • LanguageHelper
Fonctions membres publiques statiques
Référence de la classe LanguageHelper
+ Graphe d'héritage de LanguageHelper:
FinderHelperLanguage

Fonctions membres publiques statiques

static | branchPlural ($branchName)
static | branchSingular ($branchName)
static | branchLanguageTitle ($branchName)
static | loadComponentLanguage ()
static | loadPluginLanguage ()

Description détaillée

Finder language helper class.

Depuis
2.5

Documentation des fonctions membres

◆ branchLanguageTitle()

static branchLanguageTitle ( $branchName )
static

Method to return the language name for a language taxonomy branch.

Paramètres
string $branchName Language branch name.
Renvoie
string The language title.
Depuis
3.6.0

Références $languages, $title, et Text\_().

Référencé par ContentmapField\prepareLevel(), Filter\select(), et Filter\slider().

◆ branchPlural()

static branchPlural ( $branchName )
static

Method to return a plural language code for a taxonomy branch.

Paramètres
string $branchName Branch title.
Renvoie
string Language key code.
Depuis
2.5

Références $return.

Référencé par Query\explained(), Finder\mapslist(), Filter\select(), Filter\slider(), et Finder\typeslist().

◆ branchSingular()

static branchSingular ( $branchName )
static

Method to return a singular language code for a taxonomy branch.

Paramètres
string $branchName Branch name.
Renvoie
string Language key code.
Depuis
2.5

Références $language, $return, Factory\getApplication(), et JDEBUG.

Référencé par Query\explained(), ContenttypesField\getOptions(), ContentmapField\prepareLevel(), Query\processString(), Filter\select(), et Filter\slider().

◆ loadComponentLanguage()

static loadComponentLanguage ( )
static

Method to load Smart Search component language file.

Renvoie
void
Depuis
2.5

Références Factory\getLanguage(), et JPATH_SITE.

◆ loadPluginLanguage()

static loadPluginLanguage ( )
static

Method to load Smart Search plugin language files.

Renvoie
void
Depuis
2.5

Références $db, $lang, $query, Factory\getDbo(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et JPATH_PLUGINS.

Référencé par DisplayController\display(), HtmlView\display(), et Filter\slider().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Helper/LanguageHelper.php


Joomla CMS: Référence de la classe El

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Language
  • El
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe El
+ Graphe d'héritage de El:
Language

Fonctions membres publiques

__construct ($locale=null)
tokenise ($input)
stem ($token)
- Fonctions membres publiques hérités de Language
__construct ($locale=null)
tokenise ($input)
stem ($token)

Champs de données

$language = 'el'
- Champs de données hérités de Language
$language
$spacer = ' '

Fonctions membres protégées

toUpperCase ($token, &$wCase)
toLowerCase ($token, $wCase)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Language
static | getInstance ($language)
- Attributs protégés hérités de Language
$stemmer = null
- Attributs protégés statiques hérités de Language
static | $instances = array()

Description détaillée

Greek language support class for the Finder indexer package.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $locale = null )

Method to construct the language object.

Depuis
4.0.0

Documentation des fonctions membres

◆ stem()

stem ( $token )

Method to stem a token.

Paramètres
string $token The token to stem.
Renvoie
string The stemmed token.
Depuis
4.0.0

Références $suffix.

◆ tokenise()

tokenise ( $input )

Method to tokenise a text string. It takes into account the odd punctuation commonly used in Greek text, mapping it to ASCII punctuation.

Reference: http://www.teicrete.gr/users/kutrulis/Glosika/Stixi.htm

Paramètres
string $input The input to tokenise.
Renvoie
array An array of term strings.
Depuis
4.0.0

Références $input.

◆ toLowerCase()

toLowerCase | ( | $token,
 |  | $wCase
 | ) |
protected

Converts the suppressed uppercase token back to lowercase, using the $wCase map to add back the accents, diaeresis and handle the special case of final sigma (different lowercase glyph than the regular sigma, only used at the end of words).

Paramètres
string | $token | Token to process
array | $wCase | Map of lowercase rules
Renvoie
string
Depuis
4.0.0

Références $i.

◆ toUpperCase()

toUpperCase | ( |  | $token,
 |  | & | $wCase
 | ) |  |
protected

Converts the token to uppercase, suppressing accents and diaeresis. The array $wCase contains a special map of the uppercase rule used to convert each character at each position.

Paramètres
string | $token | Token to process
array | &$wCase | Map of uppercase rules
Renvoie
string
Depuis
4.0.0

Références $i.

Documentation des champs

◆ $language

$language = 'el'
La documentation de cette classe a été générée à partir du fichier suivant :
  • El.php


Joomla CMS: Référence de la classe Zh

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Language
  • Zh
Fonctions membres publiques | Champs de données
Référence de la classe Zh
+ Graphe d'héritage de Zh:
Language

Fonctions membres publiques

__construct ($locale=null)
tokenise ($input)
- Fonctions membres publiques hérités de Language
__construct ($locale=null)
tokenise ($input)
stem ($token)

Champs de données

$language = 'zh'
$spacer = ''
- Champs de données hérités de Language
$language
$spacer = ' '

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Language
static | getInstance ($language)
- Attributs protégés hérités de Language
$stemmer = null
- Attributs protégés statiques hérités de Language
static | $instances = array()

Description détaillée

Chinese (simplified) language support class for the Finder indexer package.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $locale = null )

Method to construct the language object.

Depuis
4.0.0

Documentation des fonctions membres

◆ tokenise()

tokenise ( $input )

Method to tokenise a text string.

Paramètres
string $input The input to tokenise.
Renvoie
array An array of term strings.
Depuis
4.0.0

Références $i, $input, $n, et StringHelper\str_ireplace().

Documentation des champs

◆ $language

$language = 'zh'

◆ $spacer

$spacer = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • Zh.php


Joomla CMS: Référence de la classe Html

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Parser
  • Html
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe Html
+ Graphe d'héritage de Html:
Parser

Fonctions membres publiques

parse ($input)
- Fonctions membres publiques hérités de Parser
parse ($input)

Fonctions membres protégées

process ($input)
- Fonctions membres protégées hérités de Parser
process ($input)

Fonctions membres privées

removeBlocks ($input, $startTag, $endTag)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Parser
static | getInstance ($format)
- Attributs protégés statiques hérités de Parser
static | $instances = array()

Description détaillée

HTML Parser class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ parse()

parse ( $input )

Method to parse input and extract the plain text. Because this method is called from both inside and outside the indexer, it needs to be able to batch out its parsing functionality to deal with the inefficiencies of regular expressions. We will parse recursively in 2KB chunks.

Paramètres
string $input The input to parse.
Renvoie
string The plain text input.
Depuis
2.5

Références $input, et ENT_QUOTES.

◆ process()

process ( $input )
protected

Method to process HTML input and extract the plain text.

Paramètres
string $input The input to process.
Renvoie
string The plain text input.
Depuis
2.5

Références $input.

◆ removeBlocks()

removeBlocks | ( | $input,
 |  | $startTag,
 |  | $endTag
 | ) |
private

Method to remove blocks of text between a start and an end tag. Each block removed is effectively replaced by a single space.

Note: The start tag and the end tag must be different. Note: Blocks must not be nested. Note: This method will function correctly with multi-byte strings.

Paramètres
string | $input | String to be processed.
string | $startTag | String representing the start tag.
string | $endTag | String representing the end tag.
Renvoie
string with blocks removed.
Depuis
3.4

Références $input, Joomla\Database\Query\$offset, $return, et $start.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Html.php


Joomla CMS: Référence de la classe Rtf

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Parser
  • Rtf
Fonctions membres protégées
Référence de la classe Rtf
+ Graphe d'héritage de Rtf:
Parser

Fonctions membres protégées

process ($input)
- Fonctions membres protégées hérités de Parser
process ($input)

Membres hérités additionnels

- Fonctions membres publiques hérités de Parser
parse ($input)
- Fonctions membres publiques statiques hérités de Parser
static | getInstance ($format)
- Attributs protégés statiques hérités de Parser
static | $instances = array()

Description détaillée

RTF Parser class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ process()

process ( $input )
protected

Method to process RTF input and extract the plain text.

Paramètres
string $input The input to process.
Renvoie
string The plain text input.
Depuis
2.5

Références $input.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rtf.php


Joomla CMS: Référence de la classe Txt

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Parser
  • Txt
Fonctions membres protégées
Référence de la classe Txt
+ Graphe d'héritage de Txt:
Parser

Fonctions membres protégées

process ($input)
- Fonctions membres protégées hérités de Parser
process ($input)

Membres hérités additionnels

- Fonctions membres publiques hérités de Parser
parse ($input)
- Fonctions membres publiques statiques hérités de Parser
static | getInstance ($format)
- Attributs protégés statiques hérités de Parser
static | $instances = array()

Description détaillée

Text Parser class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ process()

process ( $input )
protected

Method to process Text input and extract the plain text.

Paramètres
string $input The input to process.
Renvoie
string The plain text input.
Depuis
2.5

Références $input.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Txt.php


Joomla CMS: Référence de la classe Adapter

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Adapter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Adapter
+ Graphe d'héritage de Adapter:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface PlgFinderCategories PlgFinderContacts PlgFinderContent PlgFinderNewsfeeds PlgFinderTags

Fonctions membres publiques

__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Prototype adapter class for the Finder indexer package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |

Method to instantiate the indexer adapter.

Paramètres
object | $subject | The object to observe.
array | $config | An array that holds the plugin configuration.
Depuis
2.5

Références $config, $subject, Symfony\Contracts\Service\__construct(), et Helper\addContentType().

Documentation des fonctions membres

◆ categoryAccessChange()

categoryAccessChange ( $row )
protected

Method to update index data on category access level changes

Paramètres
Table $row A Table object
Renvoie
void
Depuis
2.5

Références $item, $items, $query, et $temp.

◆ categoryStateChange()

categoryStateChange | ( | $pks,
 |  | $value
 | ) |
protected

Method to update index data on category access level changes

Paramètres
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $item, $items, $query, $temp, et $value.

◆ change()

change | ( | $id,
 |  | $property,
 |  | $value
 | ) |
protected

Method to change the value of a content item's property in the links table. This is used to synchronize published and access states that are changed when not editing an item directly.

Paramètres
string | $id | The ID of the item to change.
string | $property | The property that is being changed.
integer | $value | The new value of that property.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $id, $item, $query, $value, et extension.

◆ checkCategoryAccess()

checkCategoryAccess ( $row )
protected

Method to check the existing access level for categories

Paramètres
Table $row A Table object
Renvoie
void
Depuis
2.5

Références $query.

◆ checkItemAccess()

checkItemAccess ( $row )
protected

Method to check the existing access level for items

Paramètres
Table $row A Table object
Renvoie
void
Depuis
2.5

Références $query, et $this.

◆ getContentCount()

getContentCount ( )
protected

Method to get the number of content items available to index.

Renvoie
integer The number of content items available to index.
Depuis
2.5
Exceptions
Exception on database error.

Références $query, et $return.

◆ getItem()

getItem ( $id )
protected

Method to get a content item to index.

Paramètres
integer $id The id of the content item.
Renvoie
Result A Result object.
Depuis
2.5
Exceptions
Exception on database error.

Références $id, $item, $layout, $query, class, et ArrayHelper\toObject().

◆ getItemMenuTitle()

getItemMenuTitle ( $url )
protected

Method to get the page title of any menu item that is linked to the content item, if it exists and is set.

Paramètres
string $url The URL of the item.
Renvoie
mixed The title on success, null if not found.
Depuis
2.5
Exceptions
Exception on database error.

Références $groups, $params, $query, $return, $url, $user, Factory\getUser(), et null.

◆ getItems()

getItems | ( | $offset,
 |  | $limit,
 |  | $query = null
 | ) |
protected

Method to get a list of content items to index.

Paramètres
integer | $offset | The list offset.
integer | $limit | The list limit.
QueryInterface | $query | A QueryInterface object. [optional]
Renvoie
Result[] An array of Result objects.
Depuis
2.5
Exceptions
Exception on database error.

Références $item, $items, $layout, $limit, Joomla\Database\Query\$offset, $query, class, et ArrayHelper\toObject().

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A QueryInterface object. [optional]
Renvoie
QueryInterface A database object.
Depuis
2.5

Références $query.

◆ getPluginType()

getPluginType ( $id )
protected

Method to get the plugin type

Paramètres
integer $id The plugin ID
Renvoie
string The plugin type
Depuis
2.5

Références $id, et $query.

◆ getStateQuery()

getStateQuery ( )
protected

Method to get a SQL query to load the published and access states for an article and category.

Renvoie
QueryInterface A database object.
Depuis
2.5

Références $query.

◆ getTypeId()

getTypeId ( )
protected

Method to get the type id for the adapter content.

Renvoie
integer The numeric type id for the content.
Depuis
2.5
Exceptions
Exception on database error.

Références $query.

◆ getUpdateQueryByIds()

getUpdateQueryByIds ( $ids )
protected

Method to get the query clause for getting items to update by id.

Paramètres
array $ids The ids to load.
Renvoie
QueryInterface A database object.
Depuis
2.5

Références $query.

◆ getUpdateQueryByTime()

getUpdateQueryByTime ( $time )
protected

Method to get the query clause for getting items to update by time.

Paramètres
string $time The modified timestamp.
Renvoie
QueryInterface A database object.
Depuis
2.5

Références $query.

◆ getUrl()

getUrl | ( | $id,
 |  | $extension,
 |  | $view
 | ) |
protected

Method to get the URL for the item. The URL is how we look up the link in the Finder index.

Paramètres
integer | $id | The id of the item.
string | $extension | The extension the category is in.
string | $view | The view for the URL.
Renvoie
string The URL of the item.
Depuis
2.5

Références $extension, $id, et $view.

◆ index()

index ( Result $item )
abstractprotected

Method to index an item.

Paramètres
Result $item The item to index as a Result object.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

◆ itemAccessChange()

itemAccessChange ( $row )
protected

Method to update index data on access level changes

Paramètres
Table $row A Table object
Renvoie
void
Depuis
2.5

Références $item, $query, et $temp.

◆ itemStateChange()

itemStateChange | ( | $pks,
 |  | $value
 | ) |
protected

Method to update index data on published state changes

Paramètres
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $item, $query, $temp, et $value.

◆ onBeforeIndex()

onBeforeIndex ( )

Method to prepare for the indexer to be run. This method will often be used to include dependencies and things of that nature.

Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on error.

Références $context, et Joomla\CMS\MVC\Model\getState().

◆ onBuildIndex()

onBuildIndex ( )

Method to index a batch of content items. This method can be called by the indexer many times throughout the indexing process depending on how much content is available for indexing. It is important to track the progress correctly so we can display it to the user.

Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on error.

Références $context, $i, $items, $limit, $n, Joomla\Database\Query\$offset, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\setState().

◆ onFinderGarbageCollection()

onFinderGarbageCollection ( )

Method to remove outdated index entries

Renvoie
integer
Depuis
4.2.0

Références $db, $item, $items, $query, $this, et extension.

◆ onStartIndex()

onStartIndex ( )

Method to get the adapter state and push it into the indexer.

Renvoie
void
Depuis
2.5
Exceptions
Exception on error.

Références $context, $total, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\setState().

◆ pluginDisable()

pluginDisable ( $pks )
protected

Method to update index data when a plugin is disabled

Paramètres
array $pks A list of primary key ids of the content that has changed state.
Renvoie
void
Depuis
2.5

Références $item, $items, et $query.

◆ reindex()

reindex ( $id )
protected

Method to reindex an item.

Paramètres
integer $id The ID of the item to reindex.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $id, $item, et Taxonomy\removeOrphanNodes().

◆ remove()

remove | ( | $id,
 |  | $removeTaxonomies = true
 | ) |
protected

Method to remove an item from the index.

Paramètres
string | $id | The ID of the item to remove.
bool | $removeTaxonomies | Remove empty taxonomies
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $id, $item, $items, $query, $url, extension, et Factory\getApplication().

◆ setup()

setup ( )
abstractprotected

Method to setup the adapter before indexing.

Renvoie
boolean True on success, false on failure.
Depuis
2.5
Exceptions
Exception on database error.

◆ translateState()

translateState | ( | $item,
 |  | $category = null
 | ) |
protected

Method to translate the native content states into states that the indexer can use.

Paramètres
integer | $item | The item state.
integer | $category | The category state. [optional]
Renvoie
integer The translated indexer state.
Depuis
2.5

Références $category, $item, et null.

Documentation des champs

◆ $context

$context
protected

◆ $db

$db
protected

◆ $extension

$extension
protected

◆ $indexer

$indexer
protected

◆ $layout

$layout
protected

◆ $mime

$mime
protected

◆ $old_access

$old_access
protected

◆ $old_cataccess

$old_cataccess
protected

◆ $state_field

$state_field = 'state'
protected

◆ $table

$table
protected

◆ $type_id

$type_id
protected

◆ $type_title

$type_title
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Adapter.php


Joomla CMS: Référence de la classe Helper

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Helper
Fonctions membres publiques statiques
Référence de la classe Helper

Fonctions membres publiques statiques

static | parse ($input, $format='html')
static | tokenize ($input, $lang, $phrase=false)
static | stem ($token, $lang)
static | addContentType ($title, $mime=null)
static | isCommon ($token, $lang)
static | getCommonWords ($lang)
static | getDefaultLanguage ()
static | getPrimaryLanguage ($lang)
static | getContentExtras (Result $item)
static | prepareContent ($text, $params=null, Result $item=null)

Description détaillée

Helper class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ addContentType()

static addContentType | ( | $title,
 |  | $mime = null
 | ) |
static

Method to add a content type to the database.

Paramètres
string | $title | The type of content. For example: PDF
string | $mime | The mime type of the content. For example: PDF [optional]
Renvoie
integer The id of the content type.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $query, $title, et Factory\getDbo().

Référencé par Adapter\__construct().

◆ getCommonWords()

static getCommonWords ( $lang )
static

Method to get an array of common terms for a language.

Paramètres
string $lang The language to use.
Renvoie
array Array of common terms.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $lang, $query, et Factory\getDbo().

◆ getContentExtras()

static getContentExtras ( Result $item )
static

Method to get extra data for a content before being indexed. This is how we add Comments, Tags, Labels, etc. that should be available to Finder.

Paramètres
Result $item The item to index as a Result object.
Renvoie
boolean True on success, false on failure.
Depuis
2.5
Exceptions
Exception on database error.

Références $item, Factory\getApplication(), et PluginHelper\importPlugin().

◆ getDefaultLanguage()

static getDefaultLanguage ( )
static

Method to get the default language for the site.

Renvoie
string The default language string.
Depuis
2.5

Références $lang, et ComponentHelper\getParams().

Référencé par Query\__construct(), et SuggestionsModel\populateState().

◆ getPrimaryLanguage()

static getPrimaryLanguage ( $lang )
static

Method to parse a language/locale key and return a simple language string.

Paramètres
string $lang The language/locale key. For example: en-GB
Renvoie
string The simple language string. For example: en
Depuis
2.5

Références $data, $lang, StringHelper\strpos(), et StringHelper\substr().

Référencé par Language\getInstance(), et SuggestionsModel\getListQuery().

◆ isCommon()

static isCommon | ( | $token,
 |  | $lang
 | ) |
static

Method to check if a token is common in a language.

Paramètres
string | $token | The token to test.
string | $lang | The language to reference.
Renvoie
boolean True if common, false otherwise.
Depuis
2.5

Références $config, $data, $default, $lang, elseif, ComponentHelper\getParams(), et Multilanguage\isEnabled().

Référencé par Token\__construct().

◆ parse()

static parse | ( | $input,
 |  | $format = 'html'
 | ) |
static

Method to parse input into plain text.

Paramètres
string | $input | The raw input.
string | $format | The format of the input. [optional]
Renvoie
string The parsed input.
Depuis
2.5
Exceptions
Exception on invalid parser.

Références $format, $input, et Parser\getInstance().

Référencé par Indexer\index(), et Indexer\tokenizeToDbShort().

◆ prepareContent()

static prepareContent | ( |  | $text,
 |  |  | $params = null,
 |  | Result | $item = null
 | ) |  |
static

Method to process content text using the onContentPrepare event trigger.

Paramètres
string | $text | The content to process.
Registry | $params | The parameters object. [optional]
Result | $item | The item which get prepared. [optional]
Renvoie
string The processed content.
Depuis
2.5

Références $content, $item, $params, $text, Factory\getApplication(), Table\getInstance(), et PluginHelper\importPlugin().

◆ stem()

static stem | ( | $token,
 |  | $lang
 | ) |
static

Method to get the base word of a token.

Paramètres
string | $token | The token to stem.
string | $lang | The language of the token.
Renvoie
string The root token.
Depuis
2.5

Références $config, $lang, $language, elseif, Language\getInstance(), ComponentHelper\getParams(), et Multilanguage\isEnabled().

Référencé par Token\__construct().

◆ tokenize()

static tokenize | ( | $input,
 |  | $lang,
 |  | $phrase = false
 | ) |
static

Method to tokenize a text string.

Paramètres
string | $input | The input to tokenize.
string | $lang | The language of the input.
boolean | $phrase | Flag to indicate whether input could be a phrase. [optional]
Renvoie
Token[] An array of Token objects.
Depuis
2.5

We want to cache the most common words/tokens. At the same time we don't want to cache too much. The most common words will also be early in the text, so we are dropping all terms/tokens which have been cached later.

Références $config, $i, $input, $key, $lang, $language, $n, $params, $temp, elseif, Language\getInstance(), ComponentHelper\getParams(), et Multilanguage\isEnabled().

Référencé par Query\processString(), et Indexer\tokenizeToDbShort().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Helper.php


Joomla CMS: Référence de la classe Indexer

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Indexer
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Fonctions membres privées
Référence de la classe Indexer

Fonctions membres publiques

__construct (DatabaseInterface $db=null)
index ($item, $format='html')
remove ($linkId, $removeTaxonomies=true)
optimize ()

Fonctions membres publiques statiques

static | getState ()
static | setState ($data)
static | resetState ()

Champs de données

const | TITLE_CONTEXT = 1
const | TEXT_CONTEXT = 2
const | META_CONTEXT = 3
const | PATH_CONTEXT = 4
const | MISC_CONTEXT = 5

Attributs publics statiques

static | $state
static | $profiler

Fonctions membres protégées

tokenizeToDb ($input, $context, $lang, $format, $count=0)
toggleTables ($memory)

Fonctions membres protégées statiques

static getSignature ($item)

Attributs protégés

$db
$addTokensToDbQueryTemplate

Fonctions membres privées

tokenizeToDbShort ($input, $context, $lang, $format, $count)

Description détaillée

Main indexer class for the Finder indexer package.

The indexer class provides the core functionality of the Finder search engine. It is responsible for adding and updating the content links table; extracting and scoring tokens; and maintaining all referential information for the content.

Note: All exceptions thrown from within this class should be caught by the controller.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db = null )

Indexer constructor.

Paramètres
DatabaseInterface $db The database
Depuis
3.8.0

Références $db, class, Factory\getContainer(), et null.

Documentation des fonctions membres

◆ getSignature()

static getSignature ( $item )
staticprotected

Method to get a content item's signature.

Paramètres
object $item The content item to index.
Renvoie
string The content item's signature.
Depuis
2.5

Références $config, $item, $state, et Joomla\CMS\MVC\Model\getState().

◆ getState()

static getState ( )
static

Method to get the indexer state.

Renvoie
object The indexer state object.
Depuis
2.5

Try to calculate the heapsize for the memory table for indexing. If this fails, we fall back on a reasonable small size. We want to prevent the system to fail and block saving content.

In tests, the size of a row seems to have been around 720 bytes. We take 800 to be on the safe side.

Références $data, $db, $state, Factory\getApplication(), Factory\getDate(), Factory\getDbo(), Profiler\getInstance(), ComponentHelper\getParams(), Factory\getSession(), et null.

Référencé par IndexerController\batch(), FinderIndexCommand\index(), IndexerController\optimize(), et IndexerController\start().

◆ index()

index | ( | $item,
 |  | $format = 'html'
 | ) |

Method to index a content item.

Paramètres
Result | $item | The content item to index.
string | $format | The format of the content. [optional]
Renvoie
integer The ID of the record in the links table.
Depuis
2.5
Exceptions

Références $context, $count, $db, $format, $item, $link, $query, $state, Taxonomy\addMap(), Taxonomy\addNestedNode(), Taxonomy\addNode(), Factory\getApplication(), Factory\getDate(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), ParameterType\INTEGER, ParameterType\LARGE_OBJECT, null, Helper\parse(), Taxonomy\removeMaps(), File\stripExt(), et StringHelper\substr().

◆ optimize()

optimize ( )

Method to optimize the index. We use this method to remove unused terms and any other optimizations that might be necessary.

Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $query, Taxonomy\removeOrphanMaps(), et Taxonomy\removeOrphanNodes().

◆ remove()

remove | ( | $linkId,
 |  | $removeTaxonomies = true
 | ) |

Method to remove a link from the index.

Paramètres
integer | $linkId | The id of the link.
bool | $removeTaxonomies | Remove empty taxonomies
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $query, Factory\getApplication(), PluginHelper\importPlugin(), ParameterType\INTEGER, Taxonomy\removeMaps(), et Taxonomy\removeOrphanNodes().

◆ resetState()

static resetState ( )
static

Method to reset the indexer state.

Renvoie
void
Depuis
2.5

Références $state, Factory\getSession(), et null.

Référencé par FinderIndexCommand\index(), et IndexerController\start().

◆ setState()

static setState ( $data )
static

Method to set the indexer state.

Paramètres
CMSObject $data A new indexer state object.
Renvoie
boolean True on success, false on failure.
Depuis
2.5

Références $data, $state, et Factory\getSession().

Référencé par IndexerController\batch().

◆ toggleTables()

toggleTables ( $memory )
protected

Method to switch the token tables from Memory tables to Disk tables when they are close to running out of memory. Since this is not supported/implemented in all DB-drivers, the default is a stub method, which simply returns true.

Paramètres
boolean $memory Flag to control how they should be toggled.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $state, et elseif.

◆ tokenizeToDb()

tokenizeToDb | ( | $input,
 |  | $context,
 |  | $lang,
 |  | $format,
 |  | $count = 0
 | ) |
protected

Method to parse input, tokenize it, and then add it to the database.

Paramètres
mixed | $input | String or resource to use as input. A resource input will automatically be chunked to conserve memory. Strings will be chunked if longer than 2K in size.
integer | $context | The context of the input. See context constants.
string | $lang | The language of the input.
string | $format | The format of the input.
integer | $count | Number of words indexed so far.
Renvoie
integer The number of tokens extracted from the input.
Depuis
2.5

Références $buffer, $context, $count, $format, $input, $lang, null, et StringHelper\trim().

◆ tokenizeToDbShort()

tokenizeToDbShort | ( | $input,
 |  | $context,
 |  | $lang,
 |  | $format,
 |  | $count
 | ) |
private

Method to parse input, tokenise it, then add the tokens to the database.

Paramètres
string | $input | String to parse, tokenise and add to database.
integer | $context | The context of the input. See context constants.
string | $lang | The language of the input.
string | $format | The format of the input.
integer | $count | The number of tokens processed so far.
Renvoie
integer Cumulative number of tokens extracted from the input so far.
Depuis
3.7.0

Références $context, $count, $format, $input, $lang, $params, $query, $state, ComponentHelper\getParams(), null, Helper\parse(), et Helper\tokenize().

Documentation des champs

◆ $addTokensToDbQueryTemplate

$addTokensToDbQueryTemplate
protected

◆ $db

$db
protected

◆ $profiler

$profiler
static

◆ $state

$state
static

◆ META_CONTEXT

const META_CONTEXT = 3

◆ MISC_CONTEXT

const MISC_CONTEXT = 5

◆ PATH_CONTEXT

const PATH_CONTEXT = 4

◆ TEXT_CONTEXT

const TEXT_CONTEXT = 2

◆ TITLE_CONTEXT

const TITLE_CONTEXT = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • Indexer.php


Joomla CMS: Référence de la classe Language

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Language
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques
Référence de la classe Language
+ Graphe d'héritage de Language:
El Zh

Fonctions membres publiques

__construct ($locale=null)
tokenise ($input)
stem ($token)

Fonctions membres publiques statiques

static getInstance ($language)

Champs de données

$language
$spacer = ' '

Attributs protégés

$stemmer = null

Attributs protégés statiques

static $instances = array()

Description détaillée

Language support class for the Finder indexer package.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $locale = null )

Method to construct the language object.

Depuis
4.0.0

Références StemmerFactory\create(), language, et null.

Documentation des fonctions membres

◆ getInstance()

static getInstance ( $language )
static

Method to get a language support object.

Paramètres
string $language The language of the support object.
Renvoie
Language A Language instance.
Depuis
4.0.0

Références $class, $language, et Helper\getPrimaryLanguage().

Référencé par Helper\stem(), et Helper\tokenize().

◆ stem()

stem ( $token )

Method to stem a token.

Paramètres
string $token The token to stem.
Renvoie
string The stemmed token.
Depuis
4.0.0

Références null.

◆ tokenise()

tokenise ( $input )

Method to tokenise a text string.

Paramètres
string $input The input to tokenise.
Renvoie
array An array of term strings.
Depuis
4.0.0

Références $input, ENT_QUOTES, et StringHelper\strtolower().

Documentation des champs

◆ $instances

$instances = array()
staticprotected

◆ $language

$language

◆ $spacer

$spacer = ' '

◆ $stemmer

$stemmer = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Language.php


Joomla CMS: Référence de la classe Parser

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Parser
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe Parser
+ Graphe d'héritage de Parser:
Html Rtf Txt

Fonctions membres publiques

parse ($input)

Fonctions membres publiques statiques

static getInstance ($format)

Fonctions membres protégées

process ($input)

Attributs protégés statiques

static $instances = array()

Description détaillée

Parser base class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ getInstance()

static getInstance ( $format )
static

Method to get a parser, creating it if necessary.

Paramètres
string $format The type of parser to load.
Renvoie
Parser A Parser instance.
Depuis
2.5
Exceptions

Références $class, $format, InputFilter\getInstance(), et Text\sprintf().

Référencé par Helper\parse().

◆ parse()

parse ( $input )

Method to parse input and extract the plain text. Because this method is called from both inside and outside the indexer, it needs to be able to batch out its parsing functionality to deal with the inefficiencies of regular expressions. We will parse recursively in 2KB chunks.

Paramètres
string $input The input to parse.
Renvoie
string The plain text input.
Depuis
2.5

Références $input, $return, $start, et null.

◆ process()

process ( $input )
abstractprotected

Method to process input and extract the plain text.

Paramètres
string $input The input to process.
Renvoie
string The plain text input.
Depuis
2.5

Documentation des champs

◆ $instances

$instances = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Parser.php


Joomla CMS: Référence de la classe Query

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Query
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe Query

Fonctions membres publiques

__construct ($options, DatabaseInterface $db=null)
toUri ($base='')
getExcludedTermIds ()
getIncludedTermIds ()
getRequiredTermIds ()

Champs de données

$search
$input
$language
$mode
$included = array()
$excluded = array()
$ignored = array()
$operators = array()
$highlight = array()
$terms
$empty
$filter
$filters = array()
$date1
$date2
$when1
$when2
$wordmode

Fonctions membres protégées

processStaticTaxonomy ($filterId)
processDynamicTaxonomy ($filters)
processDates ($date1, $date2, $when1, $when2)
processString ($input, $lang, $mode)
getTokenData ($token)

Description détaillée

Query class for the Finder indexer package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $options,
 |  | DatabaseInterface | $db = null
 | ) |  |

Method to instantiate the query object.

Paramètres
array $options An array of query options.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $options, class, elseif, Factory\getContainer(), Helper\getDefaultLanguage(), language, null, et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ getExcludedTermIds()

getExcludedTermIds ( )

Method to get a list of excluded search term ids.

Renvoie
array An array of excluded term ids.
Depuis
2.5

Références $c, $i, $results, et ArrayHelper\toInteger().

◆ getIncludedTermIds()

getIncludedTermIds ( )

Method to get a list of included search term ids.

Renvoie
array An array of included term ids.
Depuis
2.5

Références $c, $i, $key, $results, $value, et ArrayHelper\toInteger().

◆ getRequiredTermIds()

getRequiredTermIds ( )

Method to get a list of required search term ids.

Renvoie
array An array of required term ids.
Depuis
2.5

Références $c, $i, $key, $results, $value, et ArrayHelper\toInteger().

◆ getTokenData()

getTokenData ( $token )
protected

Method to get the base and similar term ids and, if necessary, suggested term data from the database. The terms ids are identified based on a 'like' match in MySQL and/or a common stem. If no term ids could be found, then we know that we will not be able to return any results for that term and we should try to find a similar term to use that we can match so that we can suggest the alternative search query to the user.

Paramètres
Token $token A Token object.
Renvoie
Token A Token object.
Depuis
2.5
Exceptions
Exception on database error.

Références $c, $db, $i, $key, $query, $results, elseif, Joomla\Database\getDatabase(), et ParameterType\STRING.

◆ processDates()

processDates | ( | $date1,
 |  | $date2,
 |  | $when1,
 |  | $when2
 | ) |
protected

Method to process the query date filters to determine start and end date limitations.

Paramètres
string | $date1 | The first date filter.
string | $date2 | The second date filter.
string | $when1 | The first date modifier.
string | $when2 | The second date modifier.
Renvoie
boolean True on success.
Depuis
2.5

Références $date, Joomla\Database\Query\$offset, Text\_(), Factory\getApplication(), Factory\getDate(), null, et StringHelper\strtolower().

◆ processDynamicTaxonomy()

processDynamicTaxonomy ( $filters )
protected

Method to process the dynamic taxonomy input. The dynamic taxonomy input comes in the form of select fields that the user chooses from. The dynamic taxonomy input is processed AFTER the static taxonomy input because the dynamic options can be used to further narrow a static taxonomy filter.

Paramètres
array $filters An array of taxonomy node ids.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $filters, $groups, $query, $result, $results, Joomla\Database\getDatabase(), Factory\getUser(), et ArrayHelper\toInteger().

◆ processStaticTaxonomy()

processStaticTaxonomy ( $filterId )
protected

Method to process the static taxonomy input. The static taxonomy input comes in the form of a pre-defined search filter that is assigned to the search form.

Paramètres
integer $filterId The id of static filter.
Renvoie
boolean True on success, false on failure.
Depuis
2.5
Exceptions
Exception on database error.

Références $db, $filters, $groups, $params, $query, $result, $results, $return, Joomla\Database\getDatabase(), Factory\getUser(), et ArrayHelper\toInteger().

◆ processString()

processString | ( | $input,
 |  | $lang,
 |  | $mode
 | ) |
protected

Method to process the query input string and extract required, optional, and excluded tokens; taxonomy filters; and date filters.

Paramètres
string | $input | The query input string.
string | $lang | The query input language.
string | $mode | The query matching mode.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $c, $date, $i, $input, $key, $lang, $mode, $modifier, Joomla\Database\Query\$offset, $params, $parts, $return, $suffix, $value, Text\_(), LanguageHelper\branchSingular(), elseif, ENT_QUOTES, Factory\getApplication(), Taxonomy\getBranchTitles(), Factory\getDate(), Taxonomy\getNodeByTitle(), ComponentHelper\getParams(), JDEBUG, null, StringHelper\strlen(), StringHelper\strpos(), StringHelper\strtolower(), StringHelper\substr(), et Helper\tokenize().

◆ toUri()

toUri ( $base = '' )

Method to convert the query object into a URI string.

Paramètres
string $base The base URI. [optional]
Renvoie
string The complete query URI.
Depuis
2.5

Références $base, $item, $query, $uri, Factory\getApplication(), Uri\getInstance(), RouteHelper\getItemid(), et null.

Documentation des champs

◆ $date1

$date1

◆ $date2

$date2

◆ $empty

$empty

◆ $excluded

$excluded = array()

◆ $filter

$filter

◆ $filters

$filters = array()

◆ $highlight

$highlight = array()

◆ $ignored

$ignored = array()

◆ $included

$included = array()

◆ $input

$input

◆ $language

$language

◆ $mode

$mode

◆ $operators

$operators = array()

◆ $search

$search

◆ $terms

$terms

◆ $when1

$when1

◆ $when2

$when2

◆ $wordmode

$wordmode
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Query.php


Joomla CMS: Référence de la classe Result

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Result
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe Result
+ Graphe d'héritage de Result:

Fonctions membres publiques

__construct ()
__set ($name, $value)
__get ($name)
__isset ($name)
__unset ($name)
getElement ($name)
getElements ()
setElement ($name, $value)
getInstructions ()
addInstruction ($group, $property)
removeInstruction ($group, $property)
getTaxonomy ($branch=null)
addTaxonomy ($branch, $title, $state=1, $access=1, $language='')
addNestedTaxonomy ($branch, ImmutableNodeInterface $contentNode, $state=1, $access=1, $language='')
setLanguage ()
serialize ()
unserialize ($serialized)
__serialize ()
__unserialize (array $serialized)

Champs de données

$url
$route
$title
$description
$published
$state
$access
$language = '*'
$publish_start_date
$publish_end_date
$start_date
$end_date
$list_price
$sale_price
$type_id
$defaultLanguage

Attributs protégés

$elements = array()
$instructions
$taxonomy = array()

Description détaillée

Result class for the Finder indexer package.

This class uses magic __get() and __set() methods to prevent properties being added that might confuse the system. All properties not explicitly declared will be pushed into the elements array and can be accessed explicitly using the getElement() method.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor

Depuis
3.0.3

Références ComponentHelper\getParams().

Documentation des fonctions membres

◆ __get()

__get ( $name )

The magic get method is used to retrieve additional element values from the elements array.

Paramètres
string $name The name of the element.
Renvoie
mixed The value of the element if set, null otherwise.
Depuis
2.5

Références $name.

◆ __isset()

__isset ( $name )

The magic isset method is used to check the state of additional element values in the elements array.

Paramètres
string $name The name of the element.
Renvoie
boolean True if set, false otherwise.
Depuis
2.5

Références $name.

◆ __serialize()

__serialize ( )

Magic method used for serializing.

Depuis
4.1.3

Références $description, $language, $n, $published, $route, $state, $title, et $url.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

The magic set method is used to push additional values into the elements array in order to preserve the cleanliness of the object.

Paramètres
string | $name | The name of the element.
mixed | $value | The value of the element.
Renvoie
void
Depuis
2.5

Références $name, et $value.

◆ __unserialize()

__unserialize ( array $serialized )

Magic method used for unserializing.

Depuis
4.1.3

Références Taxonomy\getTaxonomy().

◆ __unset()

__unset ( $name )

The magic unset method is used to unset additional element values in the elements array.

Paramètres
string $name The name of the element.
Renvoie
void
Depuis
2.5

Références $name.

◆ addInstruction()

addInstruction | ( | $group,
 |  | $property
 | ) |

Method to add a processing instruction for an item property.

Paramètres
string | $group | The group to associate the property with.
string | $property | The property to process.
Renvoie
void
Depuis
2.5

◆ addNestedTaxonomy()

addNestedTaxonomy | ( |  | $branch,
 |  | ImmutableNodeInterface | $contentNode,
 |  |  | $state = 1,
 |  |  | $access = 1,
 |  |  | $language = ''
 | ) |  |

Method to add a nested taxonomy map for an item.

Paramètres
string | $branch | The title of the taxonomy branch to add the node to.
ImmutableNodeInterface | $contentNode | The node object.
integer | $state | The published state of the taxonomy node. [optional]
integer | $access | The access level of the taxonomy node. [optional]
string | $language | The language of the taxonomy. [optional]
Renvoie
void
Depuis
4.0.0

Références $language, et $state.

◆ addTaxonomy()

addTaxonomy | ( | $branch,
 |  | $title,
 |  | $state = 1,
 |  | $access = 1,
 |  | $language = ''
 | ) |

Method to add a taxonomy map for an item.

Paramètres
string | $branch | The title of the taxonomy branch to add the node to.
string | $title | The title of the taxonomy node.
integer | $state | The published state of the taxonomy node. [optional]
integer | $access | The access level of the taxonomy node. [optional]
string | $language | The language of the taxonomy. [optional]
Renvoie
void
Depuis
2.5

Références $language, $state, et $title.

◆ getElement()

getElement ( $name )

Method to retrieve additional element values from the elements array.

Paramètres
string $name The name of the element.
Renvoie
mixed The value of the element if set, null otherwise.
Depuis
2.5

Références $name, et null.

◆ getElements()

getElements ( )

Method to retrieve all elements.

Renvoie
array The elements
Depuis
3.8.3

◆ getInstructions()

getInstructions ( )

Method to get all processing instructions.

Renvoie
array An array of processing instructions.
Depuis
2.5

◆ getTaxonomy()

getTaxonomy ( $branch = null )

Method to get the taxonomy maps for an item.

Paramètres
string $branch The taxonomy branch to get. [optional]
Renvoie
array An array of taxonomy maps.
Depuis
2.5

Références null.

◆ removeInstruction()

removeInstruction | ( | $group,
 |  | $property
 | ) |

Method to remove a processing instruction for an item property.

Paramètres
string | $group | The group to associate the property with.
string | $property | The property to process.
Renvoie
void
Depuis
2.5

Références $key.

◆ serialize()

serialize ( )

Helper function to serialise the data of a Result object

Renvoie
string The serialised data
Depuis
4.0.0

◆ setElement()

setElement | ( | $name,
 |  | $value
 | ) |

Method to set additional element values in the elements array.

Paramètres
string | $name | The name of the element.
mixed | $value | The value of the element.
Renvoie
void
Depuis
2.5

Références $name, et $value.

◆ setLanguage()

setLanguage ( )

Method to set the item language

Renvoie
void
Depuis
3.0

Références language.

Référencé par PlgFinderTags\index(), PlgFinderContacts\index(), et PlgFinderNewsfeeds\index().

◆ unserialize()

unserialize ( $serialized )

Helper function to unserialise the data for this object

Paramètres
string $serialized Serialised data to unserialise
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $access

$access

◆ $defaultLanguage

$defaultLanguage

◆ $description

$description

◆ $elements

$elements = array()
protected

◆ $end_date

$end_date

◆ $instructions

$instructions
protected
Valeur initiale :
= array(
Indexer::TITLE_CONTEXT => array('title', 'subtitle', 'id'),
Indexer::TEXT_CONTEXT => array('summary', 'body'),
Indexer::META_CONTEXT => array('meta', 'list_price', 'sale_price'),
Indexer::PATH_CONTEXT => array('path', 'alias'),
Indexer::MISC_CONTEXT => array('comments'),
)

◆ $language

$language = '*'

◆ $list_price

$list_price

◆ $publish_end_date

$publish_end_date

◆ $publish_start_date

$publish_start_date

◆ $published

$published

◆ $route

$route

◆ $sale_price

$sale_price

◆ $start_date

$start_date

◆ $state

$state

◆ $taxonomy

$taxonomy = array()
protected

◆ $title

$title

◆ $type_id

$type_id

◆ $url

$url
La documentation de cette classe a été générée à partir du fichier suivant :
  • Result.php


Joomla CMS: Référence de la classe Taxonomy

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Taxonomy
Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres protégées statiques
Référence de la classe Taxonomy

Fonctions membres publiques statiques

static | addBranch ($title, $state=1, $access=1)
static | addNode ($branch, $title, $state=1, $access=1, $language='')
static | addNestedNode ($branch, NodeInterface $node, $state=1, $access=1, $language='', $branchId=null)
static | addMap ($linkId, $nodeId)
static | getBranchTitles ()
static | getNodeByTitle ($branch, $title)
static | removeMaps ($linkId)
static | removeOrphanMaps ()
static | removeOrphanNodes ()
static | getTaxonomy ($id=0)
static | getBranch ($title='')

Attributs publics statiques

static | $taxonomies = array()
static | $branches = array()
static | $nodes = array()

Fonctions membres protégées statiques

static storeNode ($node, $parentId)

Description détaillée

Taxonomy base class for the Finder indexer package.

Depuis
2.5

Documentation des fonctions membres

◆ addBranch()

static addBranch | ( | $title,
 |  | $state = 1,
 |  | $access = 1
 | ) |
static

Method to add a branch to the taxonomy tree.

Paramètres
string | $title | The title of the branch.
integer | $state | The published state of the branch. [optional]
integer | $access | The access state of the branch. [optional]
Renvoie
integer The id of the branch.
Depuis
2.5
Exceptions

Références $state, et $title.

◆ addMap()

static addMap | ( | $linkId,
 |  | $nodeId
 | ) |
static

Method to add a map entry between a link and a taxonomy node.

Paramètres
integer | $linkId | The link to map to.
integer | $nodeId | The node to map to.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions

Références $db, $id, $query, et Factory\getDbo().

Référencé par Indexer\index().

◆ addNestedNode()

static addNestedNode | ( |  | $branch,
 |  | NodeInterface | $node,
 |  |  | $state = 1,
 |  |  | $access = 1,
 |  |  | $language = '',
 |  |  | $branchId = null
 | ) |  |
static

Method to add a nested node to the taxonomy tree.

Paramètres
string | $branch | The title of the branch to store the node in.
NodeInterface | $node | The source-node of the taxonomy node.
integer | $state | The published state of the node. [optional]
integer | $access | The access state of the node. [optional]
string | $language | The language of the node. [optional]
integer | $branchId | ID of a branch if known. [optional]
Renvoie
integer The id of the node.
Depuis
4.0.0

Références $language, $state, $temp, et ImmutableNodeInterface\getParent().

Référencé par Indexer\index().

◆ addNode()

static addNode | ( | $branch,
 |  | $title,
 |  | $state = 1,
 |  | $access = 1,
 |  | $language = ''
 | ) |
static

Method to add a node to the taxonomy tree.

Paramètres
string | $branch | The title of the branch to store the node in.
string | $title | The title of the node.
integer | $state | The published state of the node. [optional]
integer | $access | The access state of the node. [optional]
string | $language | The language of the node. [optional]
Renvoie
integer The id of the node.
Depuis
2.5
Exceptions

Références $language, $state, et $title.

Référencé par Indexer\index().

◆ getBranch()

static getBranch ( $title = '' )
static

Get a taxonomy branch object based on its title or all branches

Paramètres
string $title Title of the branch
Renvoie
object|array The object with the branch data or an array of all branches
Depuis
4.0.0

Références $taxonomies, et $title.

◆ getBranchTitles()

static getBranchTitles ( )
static

Method to get the title of all taxonomy branches.

Renvoie
array An array of branch titles.
Depuis
2.5
Exceptions

Références $db, $groups, $query, Factory\getDbo(), et Factory\getUser().

Référencé par Query\processString().

◆ getNodeByTitle()

static getNodeByTitle | ( | $branch,
 |  | $title
 | ) |
static

Method to find a taxonomy node in a branch.

Paramètres
string | $branch | The branch to search.
string | $title | The title of the node.
Renvoie
mixed Integer id on success, null on no match.
Depuis
2.5
Exceptions

Références $db, $groups, $query, $title, Factory\getDbo(), et Factory\getUser().

Référencé par Query\processString().

◆ getTaxonomy()

static getTaxonomy ( $id = 0 )
static

Get a taxonomy based on its id or all taxonomies

Paramètres
integer $id Id of the taxonomy
Renvoie
object|array A taxonomy object or an array of all taxonomies
Depuis
4.0.0

Références $db, $id, $query, $taxonomies, et Factory\getDbo().

Référencé par Result\__unserialize().

◆ removeMaps()

static removeMaps ( $linkId )
static

Method to remove map entries for a link.

Paramètres
integer $linkId The link to remove.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions

Références $db, $query, et Factory\getDbo().

Référencé par Indexer\index(), et Indexer\remove().

◆ removeOrphanMaps()

static removeOrphanMaps ( )
static

Method to remove orphaned taxonomy maps

Renvoie
integer The number of deleted rows.
Depuis
4.2.0
Exceptions

Références $count, $db, $query, et Factory\getDbo().

Référencé par Indexer\optimize().

◆ removeOrphanNodes()

static removeOrphanNodes ( )
static

Method to remove orphaned taxonomy nodes and branches.

Renvoie
integer The number of deleted rows.
Depuis
2.5
Exceptions

Références $db, $query, et Factory\getDbo().

Référencé par Indexer\optimize(), Adapter\reindex(), et Indexer\remove().

◆ storeNode()

static storeNode | ( | $node,
 |  | $parentId
 | ) |
staticprotected

A helper method to store a node in the taxonomy

Paramètres
object | $node | The node data to include
integer | $parentId | The parent id of the node to add.
Renvoie
integer The id of the inserted node.
Depuis
4.0.0
Exceptions

Références $db, $query, $result, et Factory\getDbo().

Documentation des champs

◆ $branches

$branches = array()
static

◆ $nodes

$nodes = array()
static

◆ $taxonomies

$taxonomies = array()
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Taxonomy.php


Joomla CMS: Référence de la classe Token

  • Joomla
  • Component
  • Finder
  • Administrator
  • Indexer
  • Token
Fonctions membres publiques | Champs de données
Référence de la classe Token

Fonctions membres publiques

__construct ($term, $lang, $spacer=' ')

Champs de données

$term
$stem
$numeric
$common
$phrase
$length
$weight
$language
$matches = array()
$derived
$suggestion

Description détaillée

Token class for the Finder indexer package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $term,
 |  | $lang,
 |  | $spacer = ' '
 | ) |

Method to construct the token object.

Paramètres
mixed | $term | The term as a string for words or an array for phrases.
string | $lang | The simple language identifier.
string | $spacer | The space separator for phrases. [optional]
Depuis
2.5

Références $lang, class, false, Helper\isCommon(), language, Helper\stem(), et StringHelper\strlen().

Documentation des champs

◆ $common

$common

◆ $derived

$derived

◆ $language

$language

◆ $length

$length

◆ $matches

$matches = array()

◆ $numeric

$numeric

◆ $phrase

$phrase

◆ $stem

$stem

◆ $suggestion

$suggestion

◆ $term

$term

◆ $weight

$weight
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Indexer/Token.php


Joomla CMS: Référence de la classe FilterModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • FilterModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe FilterModel
+ Graphe d'héritage de FilterModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getFilter ()
getForm ($data=array(), $loadData=true)
getTotal ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

cleanCache ($group='com_finder', $clientId=0)
loadFormData ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_FINDER'
$context = 'com_finder.filter'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Filter model class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = 'com_finder',
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method.

Paramètres
string | $group | The component name. [optional]
integer | $clientId

◆ getFilter()

getFilter ( )

Method to get the filter data.

Renvoie
FilterTable|boolean The filter data or false on a failure.
Depuis
2.5

Références $return, elseif, et Joomla\CMS\MVC\Model\getState().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form. [optional]
boolean | $loadData | True if the form is to load its own data (default case), false if not. [optional]
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
2.5

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getTotal()

getTotal ( )

Method to get the total indexed items

Renvoie
number the number of indexed items
Depuis
3.5

Références $db, $query, et Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
2.5

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

Documentation des champs

◆ $context

$context = 'com_finder.filter'
protected

◆ $text_prefix

$text_prefix = 'COM_FINDER'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FilterModel.php


Joomla CMS: Référence de la classe FiltersModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • FiltersModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FiltersModel
+ Graphe d'héritage de FiltersModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.title', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Filters model class for Finder.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.7

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
2.5

Références $db, $query, $state, $this, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id. [optional]
Renvoie
string A store id.
Depuis
2.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.title',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field. [optional]
string | $direction | An optional direction. [optional]
Renvoie
void
Depuis
2.5

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FiltersModel.php


Joomla CMS: Référence de la classe IndexerModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • IndexerModel
Référence de la classe IndexerModel
+ Graphe d'héritage de IndexerModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Indexer model class for Finder.

Depuis
2.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • IndexerModel.php


Joomla CMS: Référence de la classe IndexModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • IndexModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe IndexModel
+ Graphe d'héritage de IndexModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
delete (&$pks)
getPluginState ()
getTotalIndexed ()
getTable ($type='Link', $prefix='Administrator', $config=array())
purge ()
publish (&$pks, $value=1)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
getListQuery ()
getStoreId ($id='')
populateState ($ordering='l.title', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$event_after_delete = 'onContentAfterDelete'
$event_before_delete = 'onContentBeforeDelete'
$event_after_purge = 'onFinderIndexAfterPurge'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Index model class for Finder.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.7

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
2.5

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
2.5

Références Factory\getUser().

◆ delete()

delete ( & $pks )

Method to delete one or more records.

Paramètres
array $pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
2.5

Références $context, $i, $name, $result, Text\_(), Factory\getApplication(), et PluginHelper\importPlugin().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
2.5

Références $db, $language, $listOrder, $ordering, $query, $state, $type, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getPluginState()

getPluginState ( )

Method to get the state of the Smart Search Plugins.

Renvoie
array Array of relevant plugins and whether they are enabled or not.
Depuis
2.5

Références $db, $query, et Joomla\Database\getDatabase().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id. [optional]
Renvoie
string A store id.
Depuis
2.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTable()

getTable | ( | $type = 'Link',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Returns a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate. [optional]
string | $prefix | A prefix for the table class name. [optional]
array | $config | Configuration array for model. [optional]
Renvoie
A database object
Depuis
2.5

Références $config, $prefix, et $type.

◆ getTotalIndexed()

getTotalIndexed ( )

Gets the total of indexed items.

Renvoie
integer The total of indexed items.
Depuis
3.6.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ populateState()

populateState | ( | $ordering = 'l.title',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field. [optional]
string | $direction | An optional direction. [optional]
Renvoie
void
Depuis
2.5

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | $pks | A list of the primary keys to change.
integer | $value | The value of the published state. [optional]
Renvoie
boolean True on success.
Depuis
2.5

Références $context, $i, $name, $result, $user, $value, Text\_(), Factory\getApplication(), Factory\getUser(), et PluginHelper\importPlugin().

◆ purge()

purge ( )

Method to purge the index, deleting all links.

Renvoie
boolean True on success, false on failure.
Depuis
2.5
Exceptions

Références $db, $root, Factory\getApplication(), Joomla\Database\getDatabase(), et PluginHelper\importPlugin().

Documentation des champs

◆ $event_after_delete

$event_after_delete = 'onContentAfterDelete'
protected

◆ $event_after_purge

$event_after_purge = 'onFinderIndexAfterPurge'
protected

◆ $event_before_delete

$event_before_delete = 'onContentBeforeDelete'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • IndexModel.php


Joomla CMS: Référence de la classe MapsModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • MapsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MapsModel
+ Graphe d'héritage de MapsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
delete (&$pks)
getTable ($type='Map', $prefix='Administrator', $config=array())
publish (&$pks, $value=1)
purge ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
getListQuery ()
_getListCount ($query)
getStoreId ($id='')
populateState ($ordering='branch_title, a.lft', $direction='ASC')
getEmptyStateQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Maps model for the Finder package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.7

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getListCount()

_getListCount ( $query )
protected

Returns a record count for the query.

Paramètres

Références $query, et Joomla\Database\getDatabase().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
2.5

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
2.5

Références Factory\getUser().

◆ delete()

delete ( & $pks )

Method to delete one or more records.

Paramètres
array $pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
2.5

Références $context, $i, $name, $result, Text\_(), Factory\getApplication(), et PluginHelper\importPlugin().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $query, $title, et Joomla\Database\getDatabase().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
2.5

Références $db, $query, $state, $this, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id. [optional]
Renvoie
string A store id.
Depuis
2.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTable()

getTable | ( | $type = 'Map',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Returns a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate. [optional]
string | $prefix | A prefix for the table class name. [optional]
array | $config | Configuration array for model. [optional]
Renvoie
A database object
Depuis
2.5

Références $config, $prefix, et $type.

◆ populateState()

populateState | ( |  | $ordering = 'branch_title,
 |  | a.lft' | ,
 |  |  | $direction = 'ASC'
 | ) |  |
protected

Method to auto-populate the model state. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field. [optional]
string | $direction | An optional direction. [optional]
Renvoie
void
Depuis
2.5

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | $pks | A list of the primary keys to change.
integer | $value | The value of the published state. [optional]
Renvoie
boolean True on success.
Depuis
2.5

Références $context, $i, $name, $result, $user, $value, Text\_(), Factory\getApplication(), Factory\getUser(), et PluginHelper\importPlugin().

◆ purge()

purge ( )

Method to purge all maps from the taxonomy.

Renvoie
boolean Returns true on success, false on failure.
Depuis
2.5

Références $db, $query, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MapsModel.php


Joomla CMS: Référence de la classe SearchesModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • SearchesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe SearchesModel
+ Graphe d'héritage de SearchesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
reset ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.hits', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of search terms.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Override the parent getItems to inject optional data.

Renvoie
mixed An array of objects on success, false on failure.
Depuis
4.0.0

Implémente ListModelInterface.

Références $item, et $items.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
4.0.0

Références $db, $query, $this, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
4.0.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.hits',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
4.0.0

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ reset()

reset ( )

Method to reset the search log table.

Renvoie
boolean
Depuis
4.0.0

Références $db, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SearchesModel.php


Joomla CMS: Référence de la classe StatisticsModel

  • Joomla
  • Component
  • Finder
  • Administrator
  • Model
  • StatisticsModel
Fonctions membres publiques
Référence de la classe StatisticsModel
+ Graphe d'héritage de StatisticsModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getData ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Statistics model class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getData()

getData ( )

Method to get the component statistics

Renvoie
CMSObject The component statistics
Depuis
2.5

Références $data, $db, $lang, $query, Joomla\Database\getDatabase(), Factory\getLanguage(), PluginHelper\getPlugin(), JPATH_ADMINISTRATOR, et JPATH_PLUGINS.

La documentation de cette classe a été générée à partir du fichier suivant :
  • StatisticsModel.php


Joomla CMS: Référence de la classe Response

  • Joomla
  • Component
  • Finder
  • Administrator
  • Response
  • Response
Fonctions membres publiques
Référence de la classe Response

Fonctions membres publiques

__construct ($state)

Description détaillée

Finder Indexer JSON Response Class

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $state )

Class Constructor

Paramètres
mixed $state The processing state for the indexer
Depuis
2.5

Références $options, $params, $state, $this, Text\_(), Log\add(), Log\addLogger(), elseif, Log\ERROR, Factory\getDate(), ComponentHelper\getParams(), et if.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Response/Response.php


Joomla CMS: Référence de la classe Filter

  • Joomla
  • Component
  • Finder
  • Administrator
  • Service
  • HTML
  • Filter
Fonctions membres publiques
Référence de la classe Filter

Fonctions membres publiques

slider ($options=array())
select ($idxQuery, $options)

Description détaillée

Filter HTML Behaviors for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ select()

select | ( | $idxQuery,
 |  | $options
 | ) |

Method to generate filters using select box dropdown controls.

Paramètres
Query | $idxQuery | A Query object.
array | $options | An array of options.
Renvoie
mixed A rendered HTML widget on success, null otherwise.
Depuis
2.5

Références $active, $db, $groups, $html, $key, $language, $options, $query, $temp, $title, $user, Text\_(), HTMLHelper\_(), LanguageHelper\branchLanguageTitle(), LanguageHelper\branchPlural(), LanguageHelper\branchSingular(), Factory\getApplication(), Factory\getCache(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), Multilanguage\isEnabled(), null, Text\sprintf(), et OutputFilter\stringURLSafe().

◆ slider()

slider ( $options = array() )

Method to generate filters using the slider widget and decorated with the FinderFilter JavaScript behaviors.

Paramètres
array $options An array of configuration options. [optional]
Renvoie
mixed A rendered HTML widget on success, null otherwise.
Depuis
2.5

Références $checked, $db, $groups, $html, $key, $lang, $options, $query, $title, $user, Text\_(), HTMLHelper\_(), LanguageHelper\branchLanguageTitle(), LanguageHelper\branchPlural(), LanguageHelper\branchSingular(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), Multilanguage\isEnabled(), LanguageHelper\loadPluginLanguage(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Filter.php


Joomla CMS: Référence de la classe Finder

  • Joomla
  • Component
  • Finder
  • Administrator
  • Service
  • HTML
  • Finder
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Finder

Fonctions membres publiques

typeslist ()
mapslist ()

Fonctions membres publiques statiques

static statelist ()

Description détaillée

HTML behavior class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ mapslist()

mapslist ( )

Creates a list of maps.

Renvoie
array An array containing the maps that can be selected.
Depuis
2.5

Références $db, $key, $lang, $options, $query, Text\_(), HTMLHelper\_(), LanguageHelper\branchPlural(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), et ArrayHelper\sortObjects().

◆ statelist()

static statelist ( )
static

Creates a list of published states.

Renvoie
array An array containing the states that can be selected.
Depuis
2.5

Références Text\_(), HTMLHelper\_(), et Text\sprintf().

◆ typeslist()

typeslist ( )

Creates a list of types to filter on.

Renvoie
array An array containing the types that can be selected.
Depuis
2.5

Références $db, $key, $lang, $options, $query, $rows, Text\_(), HTMLHelper\_(), LanguageHelper\branchPlural(), Joomla\Database\getDatabase(), Factory\getLanguage(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Finder.php


Joomla CMS: Référence de la classe Query

  • Joomla
  • Component
  • Finder
  • Administrator
  • Service
  • HTML
  • Query
Fonctions membres publiques statiques
Référence de la classe Query

Fonctions membres publiques statiques

static | explained (IndexerQuery $query)
static | suggested (IndexerQuery $query)

Description détaillée

Query HTML behavior class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ explained()

static explained ( IndexerQuery $query )
static

Method to get the explained (human-readable) search query.

Paramètres
IndexerQuery $query A IndexerQuery object to explain.
Renvoie
mixed String if there is data to explain, null otherwise.
Depuis
2.5

Références $date, $id, $key, $lang, $parts, $query, $title, Text\_(), LanguageHelper\branchPlural(), LanguageHelper\branchSingular(), Factory\getApplication(), Factory\getDate(), Factory\getLanguage(), null, et Text\sprintf().

◆ suggested()

static suggested ( IndexerQuery $query )
static

Method to get the suggested search query.

Paramètres
IndexerQuery $query A IndexerQuery object.
Renvoie
mixed String if there is a suggestion, false otherwise.
Depuis
2.5

Références $query.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/Service/HTML/Query.php


Joomla CMS: Référence de la classe FilterTable

  • Joomla
  • Component
  • Finder
  • Administrator
  • Table
  • FilterTable
Fonctions membres publiques | Attributs protégés
Référence de la classe FilterTable
+ Graphe d'héritage de FilterTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
$_jsonEncode = array('params')
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Filter table class for the Finder package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database Driver connector object.
Depuis
2.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Method to perform sanity checks on the instance properties to ensure they are safe to store in the database. Child classes should override this method to make sure the data they are storing in the database is safe and as expected before storage.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Depuis
2.5

Implémente TableInterface.

Références $params, $title, Factory\getDate(), et ApplicationHelper\stringURLSafe().

◆ store()

store ( $updateNulls = true )

Method to store a row in the database from the instance properties. If a primary key value is set the row with that primary key value will be updated with the instance property values. If no primary key value is set a new row will be inserted into the database with the properties from the instance.

Paramètres
boolean $updateNulls True to update fields even if they are null. [optional]
Renvoie
boolean True on success.
Depuis
2.5

Implémente TableInterface.

Références $date, $userId, Text\_(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), et Factory\getUser().

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = array('params')
protected

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FilterTable.php


Joomla CMS: Référence de la classe LinkTable

  • Joomla
  • Component
  • Finder
  • Administrator
  • Table
  • LinkTable
Fonctions membres publiques | Attributs protégés
Référence de la classe LinkTable
+ Graphe d'héritage de LinkTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Link table class for the Finder package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database Driver connector object.
Depuis
2.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
4.0.0

Implémente TableInterface.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_finder/src/Table/LinkTable.php


Joomla CMS: Référence de la classe MapTable

  • Joomla
  • Component
  • Finder
  • Administrator
  • Table
  • MapTable
Fonctions membres publiques
Référence de la classe MapTable
+ Graphe d'héritage de MapTable:
Nested Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Map table class for the Finder package.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database Driver connector object.
Depuis
2.5

Références $db, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ check()

check ( )

Override check function

Renvoie
boolean
Voir également
Table::check()
Depuis
4.0.0

Implémente TableInterface.

Références Text\_(), language, et ApplicationHelper\stringURLSafe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MapTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Filter
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$filter
$form
$item
$state
$total
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Filter view class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Method to configure the toolbar for this view.

Renvoie
void
Depuis
2.5

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Documentation des champs

◆ $filter

$filter
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected

◆ $total

$total
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Filter/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Filters
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$total
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

Filters view class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Method to configure the toolbar for this view.

Renvoie
void
Depuis
2.5

Références $canDo, $toolbar, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $total

$total
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Filters/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Index
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$pluginState
$finderPluginId = 0
$state
$total
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

Index view class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Method to configure the toolbar for this view.

Renvoie
void
Depuis
2.5

Références $canDo, $toolbar, Text\_(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références FinderHelper\getFinderPluginId(), Multilanguage\isEnabled(), PluginHelper\isEnabled(), items, et LanguageHelper\loadPluginLanguage().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $finderPluginId

$finderPluginId = 0
protected

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $pluginState

$pluginState
protected

◆ $state

$state
protected

◆ $total

$total
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Index/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Indexer
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Indexer view class for Finder.

Depuis
2.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Indexer/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Maps
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$total
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

Groups view class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Method to configure the toolbar for this view.

Renvoie
void
Depuis
2.5

Références $canDo, $toolbar, Text\_(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références items, et LanguageHelper\loadPluginLanguage().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $total

$total
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Maps/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Searches
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$enabled
$items
$pagination
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of search terms.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\custom(), ToolbarHelper\divider(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $app, $link, $output, $uri, Text\_(), Route\_(), HTMLHelper\_(), ContentHelper\getActions(), Factory\getApplication(), Uri\getInstance(), items, et Text\sprintf().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $canDo

$canDo
protected

◆ $enabled

$enabled
protected

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Searches/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Administrator
  • View
  • Statistics
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$data
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Statistics view class for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Documentation des champs

◆ $data

$data
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/src/View/Statistics/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Finder
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Finder Component Controller.

Depuis
2.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached. [optional]
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().[optional]@returnstaticThisobjectistosupportchaining.@since2.5

Références $input, LanguageHelper\loadPluginLanguage(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_finder/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe SuggestionsController

  • Joomla
  • Component
  • Finder
  • Site
  • Controller
  • SuggestionsController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe SuggestionsController
+ Graphe d'héritage de SuggestionsController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

suggest ()
opensearchsuggest ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getSuggestions ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Suggestions controller for Finder.

Depuis
2.5

Documentation des fonctions membres

◆ getSuggestions()

getSuggestions ( )
protected

Method to retrieve the data from the database

Renvoie
array The suggested words
Depuis
3.4

Références $model, $params, $return, et ComponentHelper\getParams().

◆ opensearchsuggest()

opensearchsuggest ( )

Method to find search query suggestions for OpenSearch

Renvoie
void
Depuis
4.0.0

Références $app, et $result.

◆ suggest()

suggest ( )

Method to find search query suggestions. Uses awesomplete

Renvoie
void
Depuis
3.4

Références $app.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SuggestionsController.php


Joomla CMS: Référence de la classe FinderHelper

  • Joomla
  • Component
  • Finder
  • Site
  • Helper
  • FinderHelper
Fonctions membres publiques statiques
Référence de la classe FinderHelper

Fonctions membres publiques statiques

static logSearch (Query $searchquery, $resultCount=0)

Description détaillée

Helper class for Joomla! Finder components

Depuis
4.0.0

Documentation des fonctions membres

◆ logSearch()

static logSearch | ( | Query | $searchquery,
 |  |  | $resultCount = 0
 | ) |  |
static

Method to log searches to the database

Paramètres
Query | $searchquery | The search query
integer | $resultCount | The number of results for this search
Renvoie
void
Depuis
4.0.0

Références $db, $query, $temp, Factory\getDbo(), ComponentHelper\getParams(), ParameterType\INTEGER, et ParameterType\LARGE_OBJECT.

Référencé par HtmlView\display().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_finder/src/Helper/FinderHelper.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • Component
  • Finder
  • Site
  • Helper
  • RouteHelper
Fonctions membres publiques statiques
Référence de la classe RouteHelper
+ Graphe d'héritage de RouteHelper:
FinderHelperRoute

Fonctions membres publiques statiques

static | getSearchRoute ($f=null, $q=null)
static | getAdvancedRoute ($f=null, $q=null)
static | getItemid ($query)

Description détaillée

Finder route helper class.

Depuis
2.5

Documentation des fonctions membres

◆ getAdvancedRoute()

static getAdvancedRoute | ( | $f = null,
 |  | $q = null
 | ) |
static

Method to get the route for an advanced search page.

Paramètres
integer | $f | The search filter id. [optional]
string | $q | The search query string. [optional]
Renvoie
string The advanced search route.
Depuis
2.5

Références $item, $query, $uri, Uri\getInstance(), et null.

◆ getItemid()

static getItemid ( $query )
static

Method to get the most appropriate menu item for the route based on the supplied query needles.

Paramètres
array $query An array of URL parameters.
Renvoie
mixed An integer on success, null otherwise.
Depuis
2.5

Références $active, $app, $item, $items, $menu, $query, Factory\getApplication(), ComponentHelper\getComponent(), et null.

Référencé par Query\toUri().

◆ getSearchRoute()

static getSearchRoute | ( | $f = null,
 |  | $q = null
 | ) |
static

Method to get the route for a search page.

Paramètres
integer | $f | The search filter id. [optional]
string | $q | The search query string. [optional]
Renvoie
string The search route.
Depuis
2.5

Références $item, $query, $uri, Uri\getInstance(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_finder/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe SearchModel

  • Joomla
  • Component
  • Finder
  • Site
  • Model
  • SearchModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SearchModel
+ Graphe d'héritage de SearchModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
getQuery ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='', $page=true)
populateState ($ordering=null, $direction=null)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$context = 'com_finder.search'
$searchquery
$excludedTerms = array()
$includedTerms = array()
$requiredTerms = array()
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Search model class for the Finder package.

Depuis
2.5

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get the results of the query.

Renvoie
array An array of Result objects.
Depuis
2.5
Exceptions

Implémente ListModelInterface.

Références $items, $result, $results, et null.

◆ getListQuery()

getListQuery ( )
protected

Method to build a database query to load the list data.

Renvoie
A database query.
Depuis
2.5

If we are not ordering by relevance, we just have to add the unique items to the set.

Références $c, $db, $direction, $groups, $i, $nowDate, $ordering, $query, $taxonomies, $user, elseif, Joomla\Database\getDatabase(), Factory\getDate(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), et Factory\getUser().

◆ getQuery()

getQuery ( )

Method to get the query object.

Renvoie
Query A query object.
Depuis
2.5

◆ getStoreId()

getStoreId | ( | $id = '',
 |  | $page = true
 | ) |
protected

Method to get a store id based on model the configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string | $id | An identifier string to generate the store id. [optional]
boolean | $page | True to store the data paged, false to store all data. [optional]
Renvoie
string A store id.
Depuis
2.5

Références $id, $query, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field. [optional]
string | $direction | An optional direction. [optional]
Renvoie
void
Depuis
2.5

Références $app, $input, $language, $options, $params, $user, Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), Factory\getUser(), Multilanguage\isEnabled(), Joomla\CMS\MVC\Model\setState(), et StringHelper\strtolower().

Documentation des champs

◆ $context

$context = 'com_finder.search'
protected

◆ $excludedTerms

$excludedTerms = array()
protected

◆ $includedTerms

$includedTerms = array()
protected

◆ $requiredTerms

$requiredTerms = array()
protected

◆ $searchquery

$searchquery
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SearchModel.php


Joomla CMS: Référence de la classe SuggestionsModel

  • Joomla
  • Component
  • Finder
  • Site
  • Model
  • SuggestionsModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SuggestionsModel
+ Graphe d'héritage de SuggestionsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering=null, $direction=null)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$context = 'com_finder.suggestions'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Suggestions model class for the Finder package.

Depuis
2.5

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
array An array of data items.
Depuis
2.5

Implémente ListModelInterface.

Références $items.

◆ getListQuery()

getListQuery ( )
protected

Method to build a database query to load the list data.

Renvoie
DatabaseQuery A database query
Depuis
2.5

Références $db, $groups, $lang, $this, $user, Joomla\Database\getDatabase(), Helper\getPrimaryLanguage(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), StringHelper\strtolower(), et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model the configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id An identifier string to generate the store id. [optional]
Renvoie
string A store id.
Depuis
2.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
2.5

Références $app, $input, $lang, $params, $user, Factory\getApplication(), Helper\getDefaultLanguage(), Factory\getLanguage(), ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $context

$context = 'com_finder.suggestions'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SuggestionsModel.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Finder
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Description détaillée

Routing class from com_finder

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu
 | ) |  |

Finder Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with

Références $app, $menu, $this, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_finder/src/Service/Router.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Finder
  • Site
  • View
  • Search
  • FeedView
Fonctions membres publiques
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Search feed view class for the Finder package.

Depuis
2.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références $app, $item, $params, $query, $result, $results, $state, $total, Route\_(), HTMLHelper\_(), ENT_QUOTES, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_finder/src/View/Search/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Finder
  • Site
  • View
  • Search
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView SiteRouterAwareInterface AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de SiteRouterAwareInterface
setSiteRouter (SiteRouter $router)

Fonctions membres protégées

getFields ()
getLayoutFile ($layout=null)
prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$query
$params = null
$state
$user = null
$suggested = false
$explained = null
$pageclass_sfx = ''
$results
$total
$pagination
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Search HTML view class for the Finder package.

Depuis
2.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références $active, $app, $result, HTMLHelper\_(), Factory\getApplication(), Profiler\getInstance(), Joomla\CMS\Router\getSiteRouter(), PluginHelper\importPlugin(), JDEBUG, FinderHelper\logSearch(), et null.

◆ getFields()

getFields ( )
protected

Method to get hidden input fields for a get form so that control variables are not lost upon form submission

Renvoie
string A string of hidden input form fields
Depuis
2.5

Références $fields, $n, $uri, Route\_(), Uri\getInstance(), et null.

◆ getLayoutFile()

getLayoutFile ( $layout = null )
protected

Method to get the layout file for a search result object.

Paramètres
string $layout The layout file to check. [optional]
Renvoie
string The layout file to use.
Depuis
2.5

Références $layout, et Path\find().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
2.5

Références $app, $layout, $menu, $route, Text\_(), Route\_(), elseif, ENT_QUOTES, Factory\getApplication(), et Uri\getInstance().

Documentation des champs

◆ $explained

$explained = null
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination
protected

◆ $params

$params = null
protected

◆ $query

$query
protected

◆ $results

$results
protected

◆ $state

$state
protected

◆ $suggested

$suggested = false
protected

◆ $total

$total
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_finder/src/View/Search/HtmlView.php


Joomla CMS: Référence de la classe OpensearchView

  • Joomla
  • Component
  • Finder
  • Site
  • View
  • Search
  • OpensearchView
Fonctions membres publiques
Référence de la classe OpensearchView
+ Graphe d'héritage de OpensearchView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

OpenSearch View class for Finder

Depuis
2.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl A template file to load. [optional]
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références $active, $app, $params, Route\_(), Factory\getApplication(), Uri\getInstance(), et ComponentHelper\getParams().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OpensearchView.php


Joomla CMS: Référence de la classe DatabaseController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • DatabaseController
Fonctions membres publiques
Référence de la classe DatabaseController
+ Graphe d'héritage de DatabaseController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Installer Database Controller

Depuis
2.5

Documentation des fonctions membres

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $item, $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseController.php


Joomla CMS: Référence de la classe DiscoverController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • DiscoverController
Fonctions membres publiques
Référence de la classe DiscoverController
+ Graphe d'héritage de DiscoverController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Discover Installation Controller

Depuis
1.6

Documentation des fonctions membres

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0

Références $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DiscoverController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Installer Controller

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticThisobjecttosupportchaining.@since1.5

Références $document, $id, $model, $this, $view, Route\_(), et Text\sprintf().

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe InstallController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • InstallController
Fonctions membres publiques
Référence de la classe InstallController
+ Graphe d'héritage de InstallController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

ajax_upload ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Installer controller for Joomla! installer class.

Depuis
1.5

Documentation des fonctions membres

◆ ajax_upload()

ajax_upload ( )

Install an extension from drag & drop ajax upload.

Renvoie
void
Depuis
3.7.0

Références $message, $result, Text\_(), et Session\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallController.php


Joomla CMS: Référence de la classe ManageController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • ManageController
Fonctions membres publiques
Référence de la classe ManageController
+ Graphe d'héritage de ManageController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Installer Manage Controller

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/Controller/ManageController.php


Joomla CMS: Référence de la classe UpdateController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • UpdateController
Fonctions membres publiques
Référence de la classe UpdateController
+ Graphe d'héritage de UpdateController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Installer Update Controller

Depuis
1.6

Documentation des fonctions membres

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_installer/src/Controller/UpdateController.php


Joomla CMS: Référence de la classe UpdatesiteController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • UpdatesiteController
Référence de la classe UpdatesiteController
+ Graphe d'héritage de UpdatesiteController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Controller for a single update site

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdatesiteController.php


Joomla CMS: Référence de la classe UpdatesitesController

  • Joomla
  • Component
  • Installer
  • Administrator
  • Controller
  • UpdatesitesController
Fonctions membres publiques | Attributs protégés
Référence de la classe UpdatesitesController
+ Graphe d'héritage de UpdatesitesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Updatesite', $prefix='Administrator', $config=array('ignore_request'=> true))
delete ()
rebuild ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_INSTALLER_UPDATESITES'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( )

Deletes an update site (if supported).

Renvoie
void
Depuis
3.6
Exceptions

Références Text\_(), Route\_(), et Joomla\Application\checkToken().

◆ getModel()

getModel | ( | $name = 'Updatesite',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
Depuis
4.0.0

Références $config, $name, et $prefix.

◆ rebuild()

rebuild ( )

Rebuild update sites tables.

Renvoie
void
Depuis
3.6

Références Route\_(), et Joomla\Application\checkToken().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_INSTALLER_UPDATESITES'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdatesitesController.php


Joomla CMS: Référence de la classe InstallerComponent

  • Joomla
  • Component
  • Installer
  • Administrator
  • Extension
  • InstallerComponent
Fonctions membres publiques
Référence de la classe InstallerComponent
+ Graphe d'héritage de InstallerComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_installer

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallerComponent.php


Joomla CMS: Référence de la classe ExtensionstatusField

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
  • ExtensionstatusField
Fonctions membres publiques | Attributs protégés
Référence de la classe ExtensionstatusField
+ Graphe d'héritage de ExtensionstatusField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'ExtensionStatus'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Extension Status field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et InstallerHelper\getStateOptions().

Documentation des champs

◆ $type

$type = 'ExtensionStatus'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionstatusField.php


Joomla CMS: Référence de la classe FolderField

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
  • FolderField
Fonctions membres publiques | Attributs protégés
Référence de la classe FolderField
+ Graphe d'héritage de FolderField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Folder'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Folder field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et InstallerHelper\getExtensionGroups().

Documentation des champs

◆ $type

$type = 'Folder'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FolderField.php


Joomla CMS: Référence de la classe LocationField

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
  • LocationField
Fonctions membres publiques | Attributs protégés
Référence de la classe LocationField
+ Graphe d'héritage de LocationField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Location'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Location field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et InstallerHelper\getClientOptions().

Documentation des champs

◆ $type

$type = 'Location'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LocationField.php


Joomla CMS: Référence de la classe PackageField

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
  • PackageField
Fonctions membres protégées
Référence de la classe PackageField
+ Graphe d'héritage de PackageField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Package field.

Selects the extension ID of an extension of the "package" type.

Depuis
4.2.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
4.2.0

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PackageField.php


Joomla CMS: Référence de la classe TypeField

  • Joomla
  • Component
  • Installer
  • Administrator
  • Field
  • TypeField
Fonctions membres publiques | Attributs protégés
Référence de la classe TypeField
+ Graphe d'héritage de TypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Type'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form field for a list of extension types.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et InstallerHelper\getExtensionTypes().

Documentation des champs

◆ $type

$type = 'Type'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_installer/src/Field/TypeField.php


Joomla CMS: Référence de la classe InstallerHelper

  • Joomla
  • Component
  • Installer
  • Administrator
  • Helper
  • InstallerHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe InstallerHelper
+ Graphe d'héritage de InstallerHelper:
InstallerHelper

Fonctions membres publiques statiques

static | getExtensionTypes ()
static | getExtensionGroups ()
static | getClientOptions ()
static | getStateOptions ()
static | getInstallationXML (string $element, string $type, int $clientId=1, ?string $folder=null)
static | getDownloadKey (CMSObject $extension)
static | getExtensionDownloadKey (string $element, string $type, int $clientId=1, ?string $folder=null)
static | getDownloadKeySupportedSites ($onlyEnabled=false)
static | getDownloadKeyExistsSites (bool $exists=true, $onlyEnabled=false)

Fonctions membres protégées statiques

static getUpdateSitesInformation (bool $onlyEnabled)

Description détaillée

Installer helper.

Depuis
1.6

Documentation des fonctions membres

◆ getClientOptions()

static getClientOptions ( )
static

Get a list of filter options for the application clients.

Renvoie
array An array of elements.
Depuis
3.5

Références $options, Text\_(), et HTMLHelper\_().

Référencé par LocationField\getOptions().

◆ getDownloadKey()

static getDownloadKey ( CMSObject $extension )
static

Get the download key of an extension going through their installation xml

Paramètres
CMSObject $extension element of an extension
Renvoie
array An array with the prefix, suffix and value of the download key
Depuis
4.0.0

Références $extension, $prefix, $suffix, $value, et true.

Référencé par UpdatesiteModel\getItem(), et UpdatesitesModel\getItems().

◆ getDownloadKeyExistsSites()

static getDownloadKeyExistsSites | ( | bool | $exists = true,
 |  |  | $onlyEnabled = false
 | ) |  |
static

Returns a list of update site IDs which are missing download keys. By default this returns all qualifying update sites, even if they are not enabled.

Paramètres
bool | $exists | [optional] If true, returns update sites with a valid download key. When false, returns update sites with an invalid / missing download key.
bool | $onlyEnabled | [optional] Set true to only returned enabled update sites.
Renvoie
int[]
Depuis
4.0.0

NOTE: The closures are not inlined because in this case the Joomla Code Style standard produces two mutually exclusive errors, making the file impossible to commit. Using closures in variables makes the code less readable but works around that issue.

Références $extension.

Référencé par UpdatesitesModel\getListQuery().

◆ getDownloadKeySupportedSites()

static getDownloadKeySupportedSites ( $onlyEnabled = false )
static

Returns a list of update site IDs which support download keys. By default this returns all qualifying update sites, even if they are not enabled.

Paramètres
bool $onlyEnabled [optional] Set true to only returned enabled update sites.
Renvoie
int[]
Depuis
4.0.0

NOTE: The closures are not inlined because in this case the Joomla Code Style standard produces two mutually exclusive errors, making the file impossible to commit. Using closures in variables makes the code less readable but works around that issue.

Références $extension.

Référencé par UpdatesitesModel\getListQuery().

◆ getExtensionDownloadKey()

static getExtensionDownloadKey | ( | string | $element,
 |  | string | $type,
 |  | int | $clientId = 1,
 |  | ?string | $folder = null
 | ) |  |
static

Get the download key of an extension given enough information to locate it in the #__extensions table

Paramètres
string | $element | Name of the extension, e.g. com_foo
string | $type | The type of the extension, e.g. component
int | $clientId | [optional] Joomla client for the extension, see the #__extensions table
string | null | $folder | Extension folder, only applies for 'plugin' type
Renvoie
array
Depuis
4.0.0

Références $clientId, $db, $extension, $folder, $query, $type, Factory\getDbo(), ParameterType\INTEGER, et ParameterType\STRING.

◆ getExtensionGroups()

static getExtensionGroups ( )
static

Get a list of filter options for the extension types.

Renvoie
array An array of objects.
Depuis
3.0

Références $db, $folder, $options, $query, HTMLHelper\_(), et Factory\getDbo().

Référencé par FolderField\getOptions().

◆ getExtensionTypes()

static getExtensionTypes ( )
static

Get a list of filter options for the extension types.

Renvoie
array An array of objects.
Depuis
3.0

Références $db, $options, $query, $type, Text\_(), HTMLHelper\_(), et Factory\getDbo().

Référencé par TypeField\getOptions().

◆ getInstallationXML()

static getInstallationXML | ( | string | $element,
 |  | string | $type,
 |  | int | $clientId = 1,
 |  | ?string | $folder = null
 | ) |  |
static

Get a list of filter options for the application statuses.

Paramètres
string | $element | element of an extension
string | $type | type of an extension
integer | $clientId | client_id of an extension
string | $folder | folder of an extension
Renvoie
SimpleXMLElement
Depuis
4.0.0

Références $clientId, $folder, $path, $type, JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, et null.

Référencé par DatabaseModel\compareUpdateVersion(), DatabaseModel\fetchSchemaCache(), et DatabaseModel\fixUpdateVersion().

◆ getStateOptions()

static getStateOptions ( )
static

Get a list of filter options for the application statuses.

Renvoie
array An array of elements.
Depuis
3.5

Références $options, Text\_(), et HTMLHelper\_().

Référencé par ExtensionstatusField\getOptions().

◆ getUpdateSitesInformation()

static getUpdateSitesInformation ( bool $onlyEnabled )
staticprotected

Get information about the update sites

Paramètres
bool $onlyEnabled Only return enabled update sites
Renvoie
CMSObject[] List of update site and linked extension information
Depuis
4.0.0

Références $db, $enabled, $item, $items, $query, Factory\getDbo(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/Helper/InstallerHelper.php


Joomla CMS: Référence de la classe DatabaseModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • DatabaseModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe DatabaseModel
+ Graphe d'héritage de DatabaseModel:
InstallerModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getErrorCount ()
fix ($cids=array())
getItems ()
getSchemaVersion ($extensionId)
fixSchemaVersion ($changeSet, $extensionId)
compareUpdateVersion ($extension)
fixUpdateVersion ($extensionId)
getDefaultTextFilters ()
- Fonctions membres publiques hérités de InstallerModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='name', $direction='asc')
getListQuery ()
mergeSchemaCache ($results)
- Fonctions membres protégées hérités de InstallerModel
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_context = 'com_installer.discover'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

fetchSchemaCache ($cid=0)
getOtherInformationMessage ($status)
getErrorsMessage ($errors)
fixDefaultTextFilters ()

Attributs privés

$changeSetList = array()
$errorCount = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Database Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
ListModel
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ compareUpdateVersion()

compareUpdateVersion ( $extension )

Get current version from #__extensions table.

Paramètres
object $extension data from #__extensions of a single extension.
Renvoie
mixed string message with the errors with the update version or null if none
Depuis
4.0.0

Références $extension, InstallerHelper\getInstallationXML(), null, et Text\sprintf().

◆ fetchSchemaCache()

fetchSchemaCache ( $cid = 0 )
private

Method to populate the schema cache.

Paramètres
integer $cid The extension ID to get the schema for
Renvoie
void
Exceptions

Références $basePath, $db, $result, $results, Text\_(), elseif, Joomla\Database\getDatabase(), InstallerHelper\getInstallationXML(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, JPATH_SITE, null, Joomla\CMS\MVC\Model\setState(), et Text\sprintf().

◆ fix()

fix ( $cids = array() )

Fixes database problems.

Paramètres
array $cids List of the selected extensions to fix
Renvoie
void|boolean
Exceptions

Références $db, $i, et Joomla\Database\getDatabase().

◆ fixDefaultTextFilters()

fixDefaultTextFilters ( )
private

For version 2.5.x only Check if com_config parameters are blank. If so, populate with com_content text filters.

Renvoie
void
Depuis
4.0.0

Références ComponentHelper\getComponent(), et Joomla\Database\getDatabase().

◆ fixSchemaVersion()

fixSchemaVersion | ( | $changeSet,
 |  | $extensionId
 | ) |

Fix schema version if wrong.

Paramètres
ChangeSet | $changeSet | Schema change set.
integer | $extensionId | ID of the extensions.
Renvoie
mixed string schema version if success, false if fail.
Exceptions

Références $db, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ fixUpdateVersion()

fixUpdateVersion ( $extensionId )

Fix Joomla version in #__extensions table if wrong (doesn't equal short version).

Paramètres
integer $extensionId id of the extension
Renvoie
mixed string update version if success, false if fail.
Depuis
4.0.0

Références Joomla\Database\getDatabase(), InstallerHelper\getInstallationXML(), et null.

◆ getDefaultTextFilters()

getDefaultTextFilters ( )

For version 2.5.x only Check if com_config parameters are blank.

Renvoie
string default text filters (if any).
Depuis
4.0.0

Références Joomla\Database\getDatabase().

◆ getErrorCount()

getErrorCount ( )

Method to return the total number of errors in all the extensions, saved in cache.

Renvoie
integer
Exceptions

◆ getErrorsMessage()

getErrorsMessage ( $errors )
private

Get a message with all errors found in a given extension

Paramètres
array $errors data from #__extensions of a single extension.
Renvoie
array List of messages with the errors in the database
Depuis
4.0.0

Références $key, $message1, $message2, $messages, et Text\sprintf().

◆ getItems()

getItems ( )

Gets the changeset array.

Renvoie
array Array with the information of the versions problems, errors and the extensions itself
Exceptions

Implémente ListModelInterface.

Références $results.

◆ getListQuery()

getListQuery ( )
protected

Method to get the database query

Renvoie
DatabaseQuery The database query
Depuis
4.0.0

Références $clientId, $db, $folder, $query, $type, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getOtherInformationMessage()

getOtherInformationMessage ( $status )
private

Get a message of the tables skipped and checked

Paramètres
array $status status of of the update files
Renvoie
array Messages with the errors with the update version
Depuis
4.0.0

Références Text\sprintf().

◆ getSchemaVersion()

getSchemaVersion ( $extensionId )

Get version from #__schemas table.

Paramètres
integer $extensionId id of the extensions.
Renvoie
mixed the return value from the query, or null if the query fails.
Exceptions

Références $db, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ mergeSchemaCache()

mergeSchemaCache ( $results )
protected

Merge the items that will be visible with the changeSet information in cache

Paramètres
array $results extensions returned from parent::getItems().
Renvoie
array the changeSetList of the merged items
Depuis
4.0.0

Références $result, et $results.

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_installer.discover'
protected

◆ $changeSetList

$changeSetList = array()
private

◆ $errorCount

$errorCount = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/Model/DatabaseModel.php


Joomla CMS: Référence de la classe DiscoverModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • DiscoverModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe DiscoverModel
+ Graphe d'héritage de DiscoverModel:
InstallerModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
discover ()
discover_install ()
purge ()
checkExtensions ()
- Fonctions membres publiques hérités de InstallerModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='name', $direction='asc')
getListQuery ()
getEmptyStateQuery ()
- Fonctions membres protégées hérités de InstallerModel
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Discover Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ checkExtensions()

checkExtensions ( )

Checks for not installed extensions in extensions table.

Renvoie
boolean True if there are discovered extensions in the database.
Depuis
4.2.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ discover()

discover ( )

Discover extensions.

Finds uninstalled extensions

Renvoie
int The count of discovered extensions
Depuis
1.6

Références $count, $db, $key, $query, $result, $results, Joomla\Database\getDatabase(), et Installer\getInstance().

◆ discover_install()

discover_install ( )

Installs a discovered extension.

Renvoie
void
Depuis
1.6

Références $app, $id, $input, $result, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\setState(), et ArrayHelper\toInteger().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $query, et Joomla\Database\getDatabase().

◆ getListQuery()

getListQuery ( )
protected

Method to get the database query.

Renvoie
DatabaseQuery The database query
Depuis
3.1

Références $clientId, $db, $folder, $query, $type, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.1

Références $app, $direction, $ordering, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ purge()

purge ( )

Cleans out the list of discovered extensions.

Renvoie
boolean True on success
Depuis
1.6

Références $db, $query, Text\_(), et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DiscoverModel.php


Joomla CMS: Référence de la classe InstallerModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • InstallerModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe InstallerModel
+ Graphe d'héritage de InstallerModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface DatabaseModel DiscoverModel ManageModel UpdatesitesModel

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Extension Manager Abstract Extension Model.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Returns an object list

Paramètres
DatabaseQuery | $query | The query
int | $limitstart | Offset
int | $limit | The number of records
Renvoie
array

Références $db, $field, $i, $item, $key, $limit, $listDirn, $listOrder, $query, $result, $this, $total, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), null, Joomla\CMS\MVC\Model\setState(), et ArrayHelper\sortObjects().

◆ translate()

translate ( & $items )
protected

Translate a list of objects

Paramètres
array $items The array of objects
Renvoie
array The array of translated objects

Références $data, $extension, $item, $items, $key, $lang, $parts, $path, $value, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, JPATH_SITE, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallerModel.php


Joomla CMS: Référence de la classe InstallModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • InstallModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe InstallModel
+ Graphe d'héritage de InstallModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

install ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
_getPackageFromUpload ()
_getPackageFromFolder ()
_getPackageFromUrl ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_table = null
$_url = null
$_context = 'com_installer.install'
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Extension Manager Install Model

Depuis
1.5

Documentation des fonctions membres

◆ _getPackageFromFolder()

_getPackageFromFolder ( )
protected

Install an extension from a directory

Renvoie
array Package details or false on failure
Depuis
1.5

Références $input, $type, Text\_(), Path\clean(), Factory\getApplication(), et null.

◆ _getPackageFromUpload()

_getPackageFromUpload ( )
protected

Works out an installation package from a HTTP upload.

Renvoie
mixed Package definition or false on failure.

Références $config, $input, Text\_(), Factory\getApplication(), null, et File\upload().

◆ _getPackageFromUrl()

_getPackageFromUrl ( )
protected

Install an extension from a URL.

Renvoie
bool|array Package details or false on failure.
Depuis
1.5

Références $input, $uri, $url, Text\_(), et Factory\getApplication().

◆ install()

install ( )

Install an extension from either folder, URL or upload.

Renvoie
boolean
Depuis
1.5

Références $app, $result, $results, $this, Text\_(), Route\_(), Factory\getApplication(), Installer\getInstance(), PluginHelper\importPlugin(), null, Joomla\CMS\MVC\Model\setState(), et Text\sprintf().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_installer.install'
protected

◆ $_table

$_table = null
protected

◆ $_url

$_url = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstallModel.php


Joomla CMS: Référence de la classe LanguagesModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • LanguagesModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe LanguagesModel
+ Graphe d'héritage de LanguagesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getLanguages ()
_getListCount ($query)
getStoreId ($id='')
populateState ($ordering='name', $direction='asc')
compareLanguages ($lang1, $lang2)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getUpdateSite ()

Attributs privés

$languageCount

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Installer Model

Depuis
2.5.7

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getListCount()

_getListCount ( $query )
protected

Returns a record count for the updatesite.

Paramètres
\Joomla\Database\DatabaseQuery | string $query The query.
Renvoie
integer Number of rows for query.
Depuis
3.7.0

◆ compareLanguages()

compareLanguages | ( | $lang1,
 |  | $lang2
 | ) |
protected

Method to compare two languages in order to sort them.

Paramètres
object | $lang1 | The first language.
object | $lang2 | The second language.
Renvoie
integer
Depuis
3.7.0

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.7.0

Implémente ListModelInterface.

◆ getLanguages()

getLanguages ( )
protected

Gets an array of objects from the updatesite.

Renvoie
object[] An array of results.
Depuis
3.0
Exceptions

Références $b, $extension, $key, $language, $languages, $limit, $ordering, $this, $value, Text\_(), Factory\getApplication(), HttpFactory\getHttp(), Joomla\CMS\MVC\Model\getState(), null, Text\sprintf(), et StringHelper\strcmp().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
2.5.7

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getUpdateSite()

getUpdateSite ( )
private

Get the Update Site

Depuis
3.7.0
Renvoie
string The URL of the Accredited Languagepack Updatesite XML

Références $db, $query, et Joomla\Database\getDatabase().

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | list order
string | $direction | direction in the list
Renvoie
void
Depuis
2.5.7

Références $direction, $ordering, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $languageCount

$languageCount
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/Model/LanguagesModel.php


Joomla CMS: Référence de la classe ManageModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • ManageModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ManageModel
+ Graphe d'héritage de ManageModel:
InstallerModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
publish (&$eid=array(), $value=1)
refresh ($eid)
remove ($eid=array())
loadChangelog ($eid, $source)
- Fonctions membres publiques hérités de InstallerModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='name', $direction='asc')
getListQuery ()
- Fonctions membres protégées hérités de InstallerModel
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Manage Model

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Method to get the database query

Renvoie
DatabaseQuery The database query
Depuis
1.6

Références $clientId, $db, $folder, $method, $query, $type, elseif, ExtensionHelper\getCoreExtensionIds(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ loadChangelog()

loadChangelog | ( | $eid,
 |  | $source
 | ) |

Load the changelog details for a given extension.

Paramètres
integer | $eid | The extension ID
string | $source | The view the changelog is for, this is used to determine which version number to show
Renvoie
string The output to show in the modal.
Depuis
4.0.0

Références $db, $extension, $field, $layout, $name, $output, $query, $value, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Exceptions

Références $app, $direction, $ordering, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish | ( | & | $eid = array(),
 |  |  | $value = 1
 | ) |  |

Enable/Disable an extension.

Paramètres
array | $eid | Extension ids to un/publish
int | $value | Publish value
Renvoie
boolean True on success
Exceptions

Références $context, $i, $id, $name, $result, $style, $value, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), et PluginHelper\importPlugin().

◆ refresh()

refresh ( $eid )

Refreshes the cached manifest information for an extension.

Paramètres
int|int[] $eid extension identifier (key in #__extensions)
Renvoie
boolean result of refresh
Depuis
1.6

Références $id, $result, et Installer\getInstance().

◆ remove()

remove ( $eid = array() )

Remove (uninstall) an extension

Paramètres
array $eid An array of identifiers
Renvoie
boolean True on success
Exceptions

Références $app, $id, $result, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Installer\getInstance(), Factory\getUser(), Joomla\CMS\MVC\Model\setState(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ManageModel.php


Joomla CMS: Référence de la classe UpdateModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • UpdateModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe UpdateModel
+ Graphe d'héritage de UpdateModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getDisabledUpdateSites ()
findUpdates ($eid=0, $cacheTimeout=0, $minimumStability=Updater::STABILITY_STABLE)
purge ()
update ($uids, $minimumStability=Updater::STABILITY_STABLE)
getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='u.name', $direction='asc')
getListQuery ()
translate (&$items)
_getList ($query, $limitstart=0, $limit=0)
loadFormData ()
preparePreUpdate ($update, $table)
getEmptyStateQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

install ($update)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Update Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Returns an object list

Paramètres
DatabaseQuery | $query | The query
int | $limitstart | Offset
int | $limit | The number of records
Renvoie
array
Depuis
3.5

Références $db, $limit, $listDirn, $listOrder, $query, $result, $total, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), null, Joomla\CMS\MVC\Model\setState(), et ArrayHelper\sortObjects().

◆ findUpdates()

findUpdates | ( | $eid = 0,
 |  | $cacheTimeout = 0,
 |  | $minimumStability = Updater::STABILITY_STABLE
 | ) |

Finds updates for an extension.

Paramètres
int | $eid | Extension identifier to look for
int | $cacheTimeout | Cache timeout
int | $minimumStability | Minimum stability for updates {
Voir également
Updater} (0=dev, 1=alpha, 2=beta, 3=rc, 4=stable)
Renvoie
boolean Result
Depuis
1.6

Références Updater\getInstance().

◆ getDisabledUpdateSites()

getDisabledUpdateSites ( )

Get the count of disabled update sites

Renvoie
integer
Depuis
3.4

Références $db, $query, et Joomla\Database\getDatabase().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $query, et Joomla\Database\getDatabase().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
2.5.2

Références $data, $form, Form\addFieldPath(), Form\addFormPath(), Form\getInstance(), et Joomla\CMS\MVC\Model\loadFormData().

◆ getListQuery()

getListQuery ( )
protected

Method to get the database query

Renvoie
The database query
Depuis
1.6

Références $clientId, $db, $folder, $query, $type, elseif, Joomla\Database\getDatabase(), ExtensionHelper\getExtensionRecord(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ install()

install ( $update )
private

Handles the actual update installation.

Paramètres
Update $update An update definition
Renvoie
boolean Result of install
Depuis
1.6

Références $app, $check, $config, $name, $result, $url, Text\_(), Factory\getApplication(), Installer\getInstance(), PluginHelper\importPlugin(), Joomla\CMS\MVC\Model\setState(), et Text\sprintf().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
2.5.2

Références $data, et Factory\getApplication().

◆ populateState()

populateState | ( | $ordering = 'u.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $ordering, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preparePreUpdate()

preparePreUpdate | ( | $update,
 |  | $table
 | ) |
protected

Method to add parameters to the update

Paramètres
Update | $update | An update definition
\Joomla\CMS\Table\Update | $table | The update instance from the database
Renvoie
void
Depuis
3.7.0

Références $path, File\exists(), if, PluginHelper\importPlugin(), JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ purge()

purge ( )

Removes all of the updates from the table.

Renvoie
boolean result of operation
Depuis
1.6

Références $db, $query, Text\_(), et Joomla\Database\getDatabase().

◆ translate()

translate ( & $items )
protected

Translate a list of objects

Paramètres
array $items The array of objects
Renvoie
array The array of translated objects
Depuis
3.5

Références $item, $items, $manifest, et Text\_().

◆ update()

update | ( | $uids,
 |  | $minimumStability = Updater::STABILITY_STABLE
 | ) |

Update function.

Sets the "result" state with the result of the operation.

Paramètres
int[] | $uids List of updates to apply
int | $minimumStability | The minimum allowed stability for installed updates {
Voir également
Updater}
Renvoie
void
Depuis
1.6

Références $result, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_installer/src/Model/UpdateModel.php


Joomla CMS: Référence de la classe UpdatesiteModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • UpdatesiteModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe UpdatesiteModel
+ Graphe d'héritage de UpdatesiteModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getItem ($pk=null)
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_installer.updatesite'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

loadFormData ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Item Model for an update site.

Depuis
4.0.0

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Exceptions
Exception
Depuis
4.0.0

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
CMSObject|boolean Object on success, false on failure.
Depuis
4.0.0

Références $db, $extension, $item, $query, Joomla\Database\getDatabase(), InstallerHelper\getDownloadKey(), et ParameterType\INTEGER.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
4.0.0

Références $data, et Joomla\CMS\MVC\Model\preprocessData().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
4.0.0

Références $data, $db, $query, $result, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

Documentation des champs

◆ $typeAlias

$typeAlias = 'com_installer.updatesite'
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdatesiteModel.php


Joomla CMS: Référence de la classe UpdatesitesModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • UpdatesitesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe UpdatesitesModel
+ Graphe d'héritage de UpdatesitesModel:
InstallerModel ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[], MVCFactoryInterface $factory=null)
publish (&$eid=[], $value=1)
delete ($ids=[])
rebuild ()
getItems ()
- Fonctions membres publiques hérités de InstallerModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getJoomlaUpdateSitesIds ($column=0)
populateState ($ordering='name', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de InstallerModel
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Update Sites Model

Depuis
3.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = [],
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Depuis
1.6
Voir également

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( $ids = [] )

Deletes an update site.

Paramètres
array $ids Extension ids to delete.
Renvoie
void
Exceptions
Exception on ACL error
Depuis
3.6

Références $app, $count, $db, $i, $id, $query, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, name, Text\plural(), et Text\sprintf().

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
4.0.0

Implémente ListModelInterface.

Références $data, $item, $items, et InstallerHelper\getDownloadKey().

◆ getJoomlaUpdateSitesIds()

getJoomlaUpdateSitesIds ( $column = 0 )
protected

Fetch the Joomla update sites ids.

Paramètres
integer $column Column to return. 0 for update site ids, 1 for extension ids.
Renvoie
array Array with joomla core update site ids.
Depuis
3.6.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getListQuery()

getListQuery ( )
protected

Method to get the database query

Renvoie
The database query
Depuis
3.4

Note: The search for name, ordering and pagination are processed by the parent InstallerModel class (in extension.php).

Références $clientId, $db, $enabled, $folder, $query, $type, Joomla\Database\getDatabase(), InstallerHelper\getDownloadKeyExistsSites(), InstallerHelper\getDownloadKeySupportedSites(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et null.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.4

Références $default, $direction, $key, $ordering, null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish | ( | & | $eid = [],
 |  |  | $value = 1
 | ) |  |

Enable/Disable an extension.

Paramètres
array | $eid | Extension ids to un/publish
int | $value | Publish value
Renvoie
boolean True on success
Exceptions
Exception on ACL error
Depuis
3.4

Références $i, $id, $result, $value, Text\_(), Joomla\Database\getDatabase(), et Factory\getUser().

◆ rebuild()

rebuild ( )

Rebuild update sites tables.

Renvoie
void
Exceptions
Exception on ACL error
Depuis
3.6

Search if the extension exists in the extensions table. Excluding Joomla core extensions and discovered but not yet installed extensions.

Références $app, $count, $db, $link, $manifest, $name, $query, $type, Text\_(), Route\_(), Folder\files(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), PluginHelper\importPlugin(), PluginHelper\isEnabled(), JPATH_ADMINISTRATOR, JPATH_API, JPATH_SITE, null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdatesitesModel.php


Joomla CMS: Référence de la classe WarningsModel

  • Joomla
  • Component
  • Installer
  • Administrator
  • Model
  • WarningsModel
Fonctions membres publiques | Champs de données
Référence de la classe WarningsModel
+ Graphe d'héritage de WarningsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

return_bytes ($val)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$type = 'warnings'

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Installer Warnings Model

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( )

Load the data.

Renvoie
array Messages
Depuis
1.6

Implémente ListModelInterface.

Références $messages, Text\_(), elseif, Factory\getApplication(), et Text\sprintf().

◆ return_bytes()

return_bytes ( $val )

Return the byte value of a particular string.

Paramètres
string $val String optionally with G, M or K suffix
Renvoie
integer size in bytes
Depuis
1.6

Références $last, et $val.

Documentation des champs

◆ $type

$type = 'warnings'
La documentation de cette classe a été générée à partir du fichier suivant :
  • WarningsModel.php


Joomla CMS: Référence de la classe Manage

  • Joomla
  • Component
  • Installer
  • Administrator
  • Service
  • HTML
  • Manage
Fonctions membres publiques
Référence de la classe Manage

Fonctions membres publiques

state ($value, $i, $enabled=true, $checkbox='cb')

Description détaillée

Installer HTML class.

Depuis
2.5

Documentation des fonctions membres

◆ state()

state | ( | $value,
 |  | $i,
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Returns a published state on a grid.

Paramètres
integer | $value | The state value.
integer | $i | The row index.
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string The Html code
Voir également
JHtmlJGrid::state
Depuis
2.5

Références $enabled, $i, $value, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Manage.php


Joomla CMS: Référence de la classe Updatesites

  • Joomla
  • Component
  • Installer
  • Administrator
  • Service
  • HTML
  • Updatesites
Fonctions membres publiques
Référence de la classe Updatesites

Fonctions membres publiques

state ($value, $i, $enabled=true, $checkbox='cb')

Description détaillée

Installer HTML class.

Depuis
3.5

Documentation des fonctions membres

◆ state()

state | ( | $value,
 |  | $i,
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Returns a published state on a grid.

Paramètres
integer | $value | The state value.
integer | $i | The row index.
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string The HTML code
Voir également
JHtmlJGrid::state()
Depuis
3.5

Références $enabled, $i, $value, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Updatesites.php


Joomla CMS: Référence de la classe UpdatesiteTable

  • Joomla
  • Component
  • Installer
  • Administrator
  • Table
  • UpdatesiteTable
Fonctions membres publiques | Attributs protégés
Référence de la classe UpdatesiteTable
+ Graphe d'héritage de UpdatesiteTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Downloadkey Table class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdatesiteTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Database
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = array()
- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$changeSet = array()
$errorCount = 0
$pagination
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

Extension Manager Database View

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références ToolbarHelper\custom(), ToolbarHelper\divider(), et ToolbarHelper\help().

Documentation des champs

◆ $activeFilters

$activeFilters = array()

◆ $changeSet

$changeSet = array()
protected

◆ $errorCount

$errorCount = 0
protected

◆ $filterForm

$filterForm

◆ $pagination

$pagination
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Database/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Discover
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension Manager Discover View

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.1

Références ToolbarHelper\custom(), ToolbarHelper\divider(), et ToolbarHelper\help().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl Template
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $isEmptyState

$isEmptyState = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Discover/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Install
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension Manager Install View

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), et ToolbarHelper\link().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl Template
Renvoie
void
Depuis
1.5

Implémente ViewInterface.

Références Text\_(), Joomla\CMS\User\getCurrentUser(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Install/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Installer
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView HtmlView

Fonctions membres publiques

__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$state
$showMessage
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension Manager Default View

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = null )

Constructor.

Paramètres
array $config Configuration array
Depuis
1.5

Références $config, Symfony\Contracts\Service\__construct(), Factory\getApplication(), et JPATH_THEMES.

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl Template
Renvoie
void
Depuis
1.5

Implémente ViewInterface.

Références $message1, $message2, et $state.

Documentation des champs

◆ $showMessage

$showMessage

◆ $state

$state
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Installer/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Languages
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Description détaillée

Extension Manager Language Install View

Depuis
2.5.7

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void

Références $canDo, Text\_(), ContentHelper\getActions(), ToolbarHelper\help(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
null $tpl template to display
Renvoie
mixed|void

Implémente ViewInterface.

Références Text\_(), Joomla\CMS\User\getCurrentUser(), et items.

Documentation des champs

◆ $items

$items
protected

◆ $pagination

$pagination
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Languages/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Manage
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Description détaillée

Extension Manager Manage View

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\link().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl Template
Renvoie
mixed|void
Depuis
1.6

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $form

$form
protected

◆ $items

$items
protected

◆ $pagination

$pagination
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Manage/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Update
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$missingDownloadKeys = 0
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Description détaillée

Extension Manager Update View

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références ToolbarHelper\custom(), ToolbarHelper\divider(), et ToolbarHelper\help().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl Template
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références $item, $url, Text\_(), Factory\getApplication(), items, CMSApplicationInterface\MSG_WARNING, et Text\plural().

Documentation des champs

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $missingDownloadKeys

$missingDownloadKeys = 0
protected

◆ $pagination

$pagination
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Update/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Updatesite
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit an update site.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0
Exceptions

Références $app, $canDo, $user, $userId, Text\_(), ToolbarHelper\cancel(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Updatesite/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Updatesites
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$filterForm
$activeFilters = []
- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

Extension Manager Update Sites View

Depuis
3.4

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.4

Références $canDo, $toolbar, ToolbarHelper\custom(), ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\help().

Documentation des champs

◆ $activeFilters

$activeFilters = []

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Updatesites/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Installer
  • Administrator
  • View
  • Warnings
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=null)
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de HtmlView
$state
$showMessage
- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Extension Manager Warning View

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références ToolbarHelper\help().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl Template
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/src/View/Warnings/HtmlView.php


Joomla CMS: Référence de la classe ManageController

  • Joomla
  • Component
  • Installer
  • Api
  • Controller
  • ManageController
Fonctions membres publiques | Attributs protégés
Référence de la classe ManageController
+ Graphe d'héritage de ManageController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'manage'
$default_view = 'manage'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The manage controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( )

Extension list view amended to add filtering of data

Renvoie
static A BaseController object to support chaining.
Depuis
4.0.0

Références $this, null, et Text\sprintf().

Documentation des champs

◆ $contentType

$contentType = 'manage'
protected

◆ $default_view

$default_view = 'manage'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_installer/src/Controller/ManageController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Installer
  • Api
  • View
  • Manage
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The manage view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'type',
'version',
'folder',
'status',
'client_id',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_installer/src/View/Manage/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Joomla! Update Controller

Depuis
2.5.4

Documentation des fonctions membres

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_joomlaupdate/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe UpdateController

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Controller
  • UpdateController
Fonctions membres publiques
Référence de la classe UpdateController
+ Graphe d'héritage de UpdateController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

captive ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Joomla! update controller for the Update view

Depuis
2.5.4

Documentation des fonctions membres

◆ captive()

captive ( )

Checks there is a valid update package and redirects to the captive view for super admin authentication.

Renvoie
void
Depuis
3.6.0

Références Text\_(), Joomla\Application\checkToken(), File\exists(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_joomlaupdate/src/Controller/UpdateController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_admin

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Joomla Update is checked for global core.admin rights - not the usual core.manage for the component

Renvoie
void
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_joomlaupdate/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe UpdateModel

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • Model
  • UpdateModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe UpdateModel
+ Graphe d'héritage de UpdateModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

applyUpdateSite ()
refreshUpdates ($force=false)
getCheckForSelfUpdate ()
getUpdateInformation ()
purge ()
download ()
createRestorationFile ($basename=null)
createUpdateFile ($basename=null)
finaliseUpgrade ()
cleanUp ()
upload ()
captiveLogin ($credentials)
captiveFileExists ()
removePackageFiles ()
getPhpOptions ()
getPhpSettings ()
isDatabaseTypeSupported ()
isPhpVersionSupported ()
getIniParserAvailability ()
getNonCoreExtensions ()
getNonCorePlugins ($folderFilter=['system', 'user', 'authentication', 'actionlog', 'multifactorauth'])
fetchCompatibility ($extensionID, $joomlaTargetVersion)
isTemplateActive ($template)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

downloadPackage ($url, $target)
translateExtensionName (&$item)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

isChecksumValid ($packagefile, $updateObject)
getConfiguredDatabaseType ()
getTargetMinimumPHPVersion ()
getUpdateSitesInfo ($extensionID)
getCollectionDetailsUrls ($updateSiteInfo, $joomlaTargetVersion)
checkCompatibility ($updateFileUrl, $joomlaTargetVersion)

Attributs privés

$updateInformation = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Joomla! update overview Model

Depuis
2.5.4

Documentation des fonctions membres

◆ applyUpdateSite()

applyUpdateSite ( )

Detects if the Joomla! update site currently in use matches the one configured in this component. If they don't match, it changes it.

Renvoie
void
Depuis
2.5.4

"Minor & Patch Release for Current version (recommended and default)". The commented "case" below are for documenting where 'default' and legacy options falls case 'default': case 'lts': case 'sts': (It's shown as "Default" because that option does not exist any more) case 'nochange':

Références $db, $id, $params, $query, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), ExtensionHelper\getExtensionRecord(), ComponentHelper\getParams(), et ParameterType\INTEGER.

◆ captiveFileExists()

captiveFileExists ( )

Does the captive (temporary) file we uploaded before still exist?

Renvoie
boolean
Depuis
3.6.0

Références File\exists(), Factory\getApplication(), et null.

◆ captiveLogin()

captiveLogin ( $credentials )

Checks the super admin credentials are valid for the currently logged in users

Paramètres
array $credentials The credentials to authenticate the user with
Renvoie
boolean
Depuis
3.6.0

Références $user, Authentication\getInstance(), Factory\getUser(), null, et Authentication\STATUS_SUCCESS.

◆ checkCompatibility()

checkCompatibility | ( | $updateFileUrl,
 |  | $joomlaTargetVersion
 | ) |
private

Method to check non core extensions for compatibility.

Paramètres
string | $updateFileUrl | The items update XML url.
string | $joomlaTargetVersion | The Joomla! version to test against
Renvoie
array An array of strings with compatible version numbers
Depuis
3.10.0

Références ComponentHelper\getParams(), et Updater\STABILITY_STABLE.

◆ cleanUp()

cleanUp ( )

Removes the extracted package file and trigger onJoomlaAfterUpdate event.

The onJoomlaAfterUpdate event compares the stored list of files previously overridden with the updated core files, finding out which files have changed during the update, thereby determining how many and which override files need to be checked and possibly updated after the Joomla update.

Renvoie
void
Depuis
2.5.4

Références $app, File\delete(), File\exists(), Factory\getApplication(), PluginHelper\importPlugin(), JPATH_ROOT, et null.

◆ createRestorationFile()

createRestorationFile ( $basename = null )

Backwards compatibility. Use createUpdateFile() instead.

Paramètres
null $basename The basename of the file to create
Renvoie
boolean
Depuis
2.5.1
Obsolète:
5.0

◆ createUpdateFile()

createUpdateFile ( $basename = null )

Create the update.php file and trigger onJoomlaBeforeUpdate event.

The onJoomlaBeforeUpdate event stores the core files for which overrides have been defined. This will be compared in the onJoomlaAfterUpdate event with the current filesystem state, thereby determining how many and which overrides need to be checked and possibly updated after Joomla installed an update.

Paramètres
string $basename Optional base path to the file.
Renvoie
boolean True if successful; false otherwise.
Depuis
2.5.4

Références $app, $config, $data, $filesize, $password, $result, File\delete(), File\exists(), UserHelper\genRandomPassword(), Factory\getApplication(), PluginHelper\importPlugin(), File\invalidateFileCache(), JPATH_SITE, et File\write().

◆ download()

download ( )

Downloads the update package to the site.

Renvoie
array
Depuis
2.5.4

Références HttpFactory\getHttp().

◆ downloadPackage()

downloadPackage | ( | $url,
 |  | $target
 | ) |
protected

Downloads a package file to a specific directory

Paramètres
string | $url | The URL to download from
string | $target | The directory to store the file
Renvoie
boolean True on success
Depuis
2.5.4

Références $result, $target, $url, Log\add(), File\delete(), HttpFactory\getHttp(), Log\INFO, Text\sprintf(), et File\write().

◆ fetchCompatibility()

fetchCompatibility | ( | $extensionID,
 |  | $joomlaTargetVersion
 | ) |

Called by controller's fetchExtensionCompatibility, which is called via AJAX.

Paramètres
string | $extensionID | The ID of the checked extension
string | $joomlaTargetVersion | Target version of Joomla
Renvoie
object
Depuis
3.10.0

◆ finaliseUpgrade()

finaliseUpgrade ( )

Finalise the upgrade.

This method will do the following:

  • Run the schema update SQL files.
  • Run the Joomla post-update script.
  • Update the manifest cache and #__extensions entry for Joomla itself.

It performs essentially the same function as InstallerFile::install() without the file copy.

Renvoie
boolean True on success.
Depuis
2.5.4

Références $db, $id, $manifest, $query, $result, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), ExtensionHelper\getExtensionRecord(), Installer\getInstance(), JPATH_ADMINISTRATOR, JPATH_MANIFESTS, JPATH_ROOT, JLoader\register(), et Text\sprintf().

◆ getCheckForSelfUpdate()

getCheckForSelfUpdate ( )

Makes sure that the Joomla! Update Component Update is in the database and check if there is a new version.

Renvoie
boolean True if there is an update else false
Depuis
4.0.0

Références $db, $query, Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), Updater\getInstance(), ParameterType\INTEGER, null, et Updater\STABILITY_STABLE.

◆ getCollectionDetailsUrls()

getCollectionDetailsUrls | ( | $updateSiteInfo,
 |  | $joomlaTargetVersion
 | ) |
private

Method to get details URLs from a collection update site for given extension and Joomla target version.

Paramètres
array | $updateSiteInfo | The update site and extension information record to process
string | $joomlaTargetVersion | The Joomla! version to test against,
Renvoie
array An array of URLs.
Depuis
3.10.0

Références $attribs, $extension, $key, $return, $value, et null.

◆ getConfiguredDatabaseType()

getConfiguredDatabaseType ( )
private

Returns the configured database type id (mysqli or sqlsrv or ...)

Renvoie
string
Depuis
3.10.0

Références Factory\getApplication().

◆ getIniParserAvailability()

getIniParserAvailability ( )

Checks the availability of the parse_ini_file and parse_ini_string functions.

Renvoie
boolean True if the method exists.
Depuis
3.10.0

Références $i, et $result.

◆ getNonCoreExtensions()

getNonCoreExtensions ( )

Gets an array containing all installed extensions, that are not core extensions.

Renvoie
array name,version,updateserver
Depuis
3.10.0

Références $db, $extension, $query, $rows, Text\_(), ExtensionHelper\getCoreExtensionIds(), Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getDbo().

◆ getNonCorePlugins()

getNonCorePlugins ( $folderFilter = ['system','user','authentication','actionlog','multifactorauth'] )

Gets an array containing all installed and enabled plugins, that are not core plugins.

Paramètres
array $folderFilter Limit the list of plugins to a specific set of folder values
Renvoie
array name,version,updateserver
Depuis
3.10.0

Références $db, $query, $rows, Text\_(), ExtensionHelper\getCoreExtensionIds(), Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getDbo().

◆ getPhpOptions()

getPhpOptions ( )

Gets PHP options.

Renvoie
array Array of PHP config options
Depuis
3.10.0

Références $option, $options, Text\_(), Version\MAJOR_VERSION, null, et Text\sprintf().

◆ getPhpSettings()

getPhpSettings ( )

Gets PHP Settings.

Renvoie
array
Depuis
3.10.0

Références $settings, Text\_(), et Text\sprintf().

◆ getTargetMinimumPHPVersion()

getTargetMinimumPHPVersion ( )
private

Returns the PHP minimum version for the update. Returns JOOMLA_MINIMUM_PHP, if there is no information given.

Renvoie
string
Depuis
3.10.0

Références JOOMLA_MINIMUM_PHP.

◆ getUpdateInformation()

getUpdateInformation ( )

Returns an array with the Joomla! update information.

Renvoie
array
Depuis
2.5.4

Références $db, $id, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), ExtensionHelper\getExtensionRecord(), ComponentHelper\getParams(), ParameterType\INTEGER, null, et Updater\STABILITY_STABLE.

◆ getUpdateSitesInfo()

getUpdateSitesInfo ( $extensionID )
private

Returns records with update sites and extension information for a given extension ID.

Paramètres
int $extensionID The extension ID
Renvoie
array
Depuis
3.10.0

Références $db, $id, $query, $result, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ isChecksumValid()

isChecksumValid | ( | $packagefile,
 |  | $updateObject
 | ) |
private

Return the result of the checksum of a package with the SHA256/SHA384/SHA512 tags in the update server manifest

Paramètres
string | $packagefile | Location of the package to be installed
Update | $updateObject | The Update Object
Renvoie
boolean False in case the validation did not work; true in any other case.
Note
This method has been forked from (JInstallerHelper::isChecksumValid) so it does not depend on an up-to-date InstallerHelper at the update time
Depuis
3.9.0

Références $hash.

◆ isDatabaseTypeSupported()

isDatabaseTypeSupported ( )

Returns true, if J! version is < 4 or current configured database type is compatible with the update.

Renvoie
boolean
Depuis
3.10.0

Références Version\MAJOR_VERSION.

◆ isPhpVersionSupported()

isPhpVersionSupported ( )

Returns true, if current installed php version is compatible with the update.

Renvoie
boolean
Depuis
3.10.0

◆ isTemplateActive()

isTemplateActive ( $template )

Checks whether a given template is active

Paramètres
string $template The template name to be checked
Renvoie
boolean
Depuis
3.10.4

Références $db, $menu, $query, $template, $value, ArrayHelper\getColumn(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getDbo(), et ParameterType\STRING.

◆ purge()

purge ( )

Removes all of the updates from the table and enable all update streams.

Renvoie
boolean Result of operation.
Depuis
3.0

Références $db, $query, Text\_(), Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getDbo().

◆ refreshUpdates()

refreshUpdates ( $force = false )

Makes sure that the Joomla! update cache is up-to-date.

Paramètres
boolean $force Force reload, ignoring the cache timeout.
Renvoie
void
Depuis
2.5.4

Références ExtensionHelper\getExtensionRecord(), Updater\getInstance(), ComponentHelper\getParams(), et Updater\STABILITY_STABLE.

◆ removePackageFiles()

removePackageFiles ( )

Remove the captive (temporary) file we uploaded before and the .

Renvoie
void
Depuis
3.6.0

Références File\delete(), File\exists(), Factory\getApplication(), et null.

◆ translateExtensionName()

translateExtensionName ( & $item )
protected

Translates an extension name

Paramètres
object &$item The extension of which the name needs to be translated
Renvoie
void
Depuis
3.10.0

Références $extension, $item, $lang, $path, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, et JPATH_SITE.

◆ upload()

upload ( )

Uploads what is presumably an update ZIP file under a mangled name in the temporary directory.

Renvoie
void
Depuis
3.6.0

Références $input, $result, Text\_(), Factory\getApplication(), null, et File\upload().

Documentation des champs

◆ $updateInformation

$updateInformation = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_joomlaupdate/src/Model/UpdateModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Joomlaupdate
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
shouldDisplayPreUpdateCheck ()
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$updateInfo = null
$phpOptions = null
$phpSettings = null
$nonCoreExtensions = null
$state
$selfUpdateAvailable = false
$defaultBackendTemplate = 'atum'
$isDefaultBackendTemplate = false
$messagePrefix = ''
$nonCoreCriticalPlugins = []
$noVersionCheck = false
$noBackupCheck = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Joomla! Update's Default View

Depuis
2.5.4

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références Text\_(), ToolbarHelper\custom(), ToolbarHelper\divider(), elseif, Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), ToolbarHelper\help(), ToolbarHelper\link(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Renders the view

Paramètres
string $tpl Template name
Renvoie
void
Depuis
2.5.4

"Minor & Patch Release for Current version (recommended and default)". The commented "case" below are for documenting where 'default' and legacy options falls case 'default': case 'sts': case 'lts': case 'nochange':

Implémente ViewInterface.

Références $language, $model, $option, $params, $this, Text\_(), elseif, Factory\getApplication(), Factory\getLanguage(), ComponentHelper\getParams(), JPATH_ADMINISTRATOR, Version\MAJOR_VERSION, et null.

◆ shouldDisplayPreUpdateCheck()

shouldDisplayPreUpdateCheck ( )

Returns true, if the pre update check should be displayed.

Renvoie
boolean
Depuis
3.10.0

Références Version\MAJOR_VERSION, et Version\MINOR_VERSION.

Documentation des champs

◆ $defaultBackendTemplate

$defaultBackendTemplate = 'atum'
protected

◆ $isDefaultBackendTemplate

$isDefaultBackendTemplate = false
protected

◆ $messagePrefix

$messagePrefix = ''
protected

◆ $noBackupCheck

$noBackupCheck = false
protected

◆ $nonCoreCriticalPlugins

$nonCoreCriticalPlugins = []
protected

◆ $nonCoreExtensions

$nonCoreExtensions = null
protected

◆ $noVersionCheck

$noVersionCheck = false
protected

◆ $phpOptions

$phpOptions = null
protected

◆ $phpSettings

$phpSettings = null
protected

◆ $selfUpdateAvailable

$selfUpdateAvailable = false
protected

◆ $state

$state
protected

◆ $updateInfo

$updateInfo = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_joomlaupdate/src/View/Joomlaupdate/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Update
  • HtmlView
Fonctions membres publiques
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Joomla! Update's Update View

Depuis
2.5.4

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Renders the view.

Paramètres
string $tpl Template name.
Renvoie
void

Implémente ViewInterface.

Références Text\_(), Factory\getApplication(), et ToolbarHelper\title().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_joomlaupdate/src/View/Update/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Joomlaupdate
  • Administrator
  • View
  • Upload
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$updateInfo = null
$selfUpdateAvailable = false
$warnings = []
$noBackupCheck = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Joomla! Update's Update View

Depuis
3.6.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références Text\_(), ToolbarHelper\divider(), Factory\getLanguage(), ToolbarHelper\help(), ToolbarHelper\link(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Renders the view.

Paramètres
string $tpl Template name.
Renvoie
void
Depuis
3.6.0

Implémente ViewInterface.

Références $language, $params, Factory\getLanguage(), ComponentHelper\getParams(), JPATH_ADMINISTRATOR, et null.

Documentation des champs

◆ $noBackupCheck

$noBackupCheck = false
protected

◆ $selfUpdateAvailable

$selfUpdateAvailable = false
protected

◆ $updateInfo

$updateInfo = null
protected

◆ $warnings

$warnings = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_joomlaupdate/src/View/Upload/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'installed'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages Controller.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached.
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'installed'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe InstalledController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • InstalledController
Fonctions membres publiques
Référence de la classe InstalledController
+ Graphe d'héritage de InstalledController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

setDefault ()
switchAdminLanguage ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages Controller.

Depuis
1.5

Documentation des fonctions membres

◆ setDefault()

setDefault ( )

Task to set the default language.

Renvoie
void

Références $clientId, $language, Factory\$language, $model, $type, Text\_(), Joomla\Application\checkToken(), Language\getInstance(), Factory\getLanguage(), Multilanguage\isEnabled(), et JPATH_ADMINISTRATOR.

◆ switchAdminLanguage()

switchAdminLanguage ( )

Task to switch the administrator language.

Renvoie
void

Références $info, $language, Factory\$language, $model, $type, Joomla\Application\checkToken(), Language\getInstance(), Factory\getLanguage(), JPATH_ADMINISTRATOR, LanguageHelper\parseXMLLanguageFile(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InstalledController.php


Joomla CMS: Référence de la classe LanguageController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • LanguageController
Fonctions membres protégées
Référence de la classe LanguageController
+ Graphe d'héritage de LanguageController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres protégées

getRedirectToItemAppend ($recordId=null, $key='lang_id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages list actions controller.

Depuis
1.6

Documentation des fonctions membres

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $key = 'lang_id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
int | $recordId | The primary key id for the item.
string | $key | The name of the primary key variable.
Renvoie
string The arguments to append to the redirect URL.
Depuis
1.6

Références $key, et $recordId.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Controller/LanguageController.php


Joomla CMS: Référence de la classe LanguagesController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • LanguagesController
Fonctions membres publiques
Référence de la classe LanguagesController
+ Graphe d'héritage de LanguagesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Language', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages controller Class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Language',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Controller/LanguagesController.php


Joomla CMS: Référence de la classe OverrideController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • OverrideController
Fonctions membres publiques
Référence de la classe OverrideController
+ Graphe d'héritage de OverrideController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

edit ($key=null, $urlVar=null)
save ($key=null, $urlVar=null)
cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages Override Controller

Depuis
2.5

Documentation des fonctions membres

◆ cancel()

cancel ( $key = null )

Method to cancel an edit.

Paramètres
string $key The name of the primary key of the URL variable (not used here).
Renvoie
void
Depuis
2.5

Références $context, Route\_(), Joomla\Application\checkToken(), et null.

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to edit an existing override.

Paramètres
string | $key | The name of the primary key of the URL variable (not used here).
string | $urlVar | The name of the URL variable if different from the primary key (not used here).
Renvoie
void
Depuis
2.5

Références $context, $recordId, Text\_(), Route\_(), et null.

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to save an override.

Paramètres
string | $key | The name of the primary key of the URL variable (not used here).
string | $urlVar | The name of the URL variable if different from the primary key (not used here).
Renvoie
void
Depuis
2.5

Références $app, $context, $data, $form, $i, $model, $n, $recordId, $task, Text\_(), Route\_(), Joomla\Application\checkToken(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OverrideController.php


Joomla CMS: Référence de la classe OverridesController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • OverridesController
Fonctions membres publiques | Attributs protégés
Référence de la classe OverridesController
+ Graphe d'héritage de OverridesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

delete ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_LANGUAGES_VIEW_OVERRIDES'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages Overrides Controller.

Depuis
2.5

Documentation des fonctions membres

◆ delete()

delete ( )

Method for deleting one or more overrides.

Renvoie
void
Depuis
2.5

Références $model, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\plural().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_LANGUAGES_VIEW_OVERRIDES'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Controller/OverridesController.php


Joomla CMS: Référence de la classe StringsController

  • Joomla
  • Component
  • Languages
  • Administrator
  • Controller
  • StringsController
Fonctions membres publiques
Référence de la classe StringsController
+ Graphe d'héritage de StringsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

refresh ()
search ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Languages Strings JSON Controller

Depuis
2.5

Documentation des fonctions membres

◆ refresh()

refresh ( )

Method for refreshing the cache in the database with the known language strings

Renvoie
void
Depuis
2.5

Refresh cache

Renvoie
static A object to support chaining.
Exceptions

◆ search()

search ( )

Method for searching language strings

Renvoie
void
Depuis
2.5

Search by languages constants

Renvoie
static A object to support chaining.
Exceptions
InvalidParameterException
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Controller/StringsController.php


Joomla CMS: Référence de la classe LanguagesComponent

  • Joomla
  • Component
  • Languages
  • Administrator
  • Extension
  • LanguagesComponent
Fonctions membres publiques
Référence de la classe LanguagesComponent
+ Graphe d'héritage de LanguagesComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_languages

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguagesComponent.php


Joomla CMS: Référence de la classe LanguageclientField

  • Joomla
  • Component
  • Languages
  • Administrator
  • Field
  • LanguageclientField
Fonctions membres protégées | Attributs protégés
Référence de la classe LanguageclientField
+ Graphe d'héritage de LanguageclientField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Languageclient'
$cache = array()
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Client Language List field.

Depuis
3.9.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.9.0

Références $language, $languages, Text\_(), LanguageHelper\getKnownLanguages(), JPATH_ADMINISTRATOR, JPATH_SITE, et Text\sprintf().

Documentation des champs

◆ $cache

$cache = array()
protected

◆ $type

$type = 'Languageclient'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageclientField.php


Joomla CMS: Référence de la classe LanguagesHelper

  • Joomla
  • Component
  • Languages
  • Administrator
  • Helper
  • LanguagesHelper
Fonctions membres publiques statiques
Référence de la classe LanguagesHelper

Fonctions membres publiques statiques

static | filterKey ($value)
static | filterText ($value)

Description détaillée

Languages component helper.

Depuis
1.6

Documentation des fonctions membres

◆ filterKey()

static filterKey ( $value )
static

Filter method for language keys. This method will be called by while filtering the form data.

Paramètres
string $value The language key to filter.
Renvoie
string The filtered language key.
Depuis
2.5

Références $value, InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

◆ filterText()

static filterText ( $value )
static

Filter method for language strings. This method will be called by while filtering the form data.

Paramètres
string $value The language string to filter.
Renvoie
string The filtered language string.
Depuis
2.5

Références $value, InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Helper/LanguagesHelper.php


Joomla CMS: Référence de la classe MultilangstatusHelper

  • Joomla
  • Component
  • Languages
  • Administrator
  • Helper
  • MultilangstatusHelper
Fonctions membres publiques statiques
Référence de la classe MultilangstatusHelper

Fonctions membres publiques statiques

static | getHomes ()
static | getLangswitchers ()
static | getContentlangs ()
static | getStatus ()
static | getContacts ()
static | getDefaultHomeModule ()
static | getModule ($moduleName, $instanceTitle=null)

Description détaillée

Multilang status helper.

Depuis
1.7.1

Documentation des fonctions membres

◆ getContacts()

static getContacts ( )
static

Method to return a list of contact objects.

Renvoie
array of contact objects.

Références $db, $languages, $query, et Factory\getDbo().

Référencé par HtmlView\display().

◆ getContentlangs()

static getContentlangs ( )
static

Method to return a list of published content languages.

Renvoie
array of language objects.

Références $db, $query, et Factory\getDbo().

Référencé par HtmlView\display().

◆ getDefaultHomeModule()

static getDefaultHomeModule ( )
static

Method to get the status of the module displaying the menutype of the default Home page set to All languages.

Renvoie
boolean True if the module is published, false otherwise.
Depuis
3.7.0

Références $db, $menutype, $module, $query, et Factory\getDbo().

Référencé par HtmlView\display().

◆ getHomes()

static getHomes ( )
static

Method to get the number of published home pages.

Renvoie
integer

Références $db, $query, et Factory\getDbo().

Référencé par HtmlView\display().

◆ getLangswitchers()

static getLangswitchers ( )
static

Method to get the number of published language switcher modules.

Renvoie
integer

Références $db, $query, et Factory\getDbo().

Référencé par HtmlView\display().

◆ getModule()

static getModule | ( | $moduleName,
 |  | $instanceTitle = null
 | ) |
static

Get module by name

Paramètres
string | $moduleName | The name of the module
string | $instanceTitle | The title of the module, optional
Renvoie
The Module object
Depuis
3.7.0

Références $db, $modules, $query, Log\add(), Factory\getDbo(), Text\sprintf(), et Log\WARNING.

◆ getStatus()

static getStatus ( )
static

Method to return combined language status.

Renvoie
array of language objects.

Références $db, $query, et Factory\getDbo().

Référencé par HtmlView\display().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MultilangstatusHelper.php


Joomla CMS: Référence de la classe InstalledModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • InstalledModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe InstalledModel
+ Graphe d'héritage de InstalledModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getClient ()
getOption ()
getData ()
getTotal ()
publish ($cid)
switchAdminLanguage ($cid)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='name', $direction='asc')
getStoreId ($id='')
getFolders ()
getPath ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$user = null
$option = null
$data = null
$total = null
$path = null
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Component Languages Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getClient()

getClient ( )

Method to get the client object.

Renvoie
object
Depuis
1.6

Références ApplicationHelper\getClientInfo(), et Joomla\CMS\MVC\Model\getState().

◆ getData()

getData ( )

Method to get Languages item data.

Renvoie
array
Depuis
1.6

Références $clientId, $key, $lang, $languages, $limit, $listDirn, $listOrder, $params, $start, ENT_QUOTES, ApplicationHelper\getClientInfo(), Factory\getLanguage(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), name, null, et ArrayHelper\sortObjects().

◆ getFolders()

getFolders ( )
protected

Method to get the folders.

Renvoie
array Languages folders.
Depuis
1.6

Références $path, et Folder\folders().

◆ getOption()

getOption ( )

Method to get the option.

Renvoie
object
Depuis
1.6

Références $option, et Joomla\CMS\MVC\Model\getState().

◆ getPath()

getPath ( )
protected

Method to get the path.

Renvoie
string The path to the languages folders.
Depuis
1.6

Références $client, $path, LanguageHelper\getLanguagePath(), et path.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getTotal()

getTotal ( )

Method to get the total number of Languages items.

Renvoie
integer
Depuis
1.6

Références $total.

◆ populateState()

populateState | ( | $ordering = 'name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $clientId, $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish ( $cid )

Method to set the default language.

Paramètres
integer $cid Id of the language to publish.
Renvoie
boolean
Depuis
1.6

Références $client, $id, $params, Text\_(), Table\getInstance(), et ComponentHelper\getParams().

◆ switchAdminLanguage()

switchAdminLanguage ( $cid )

Method to switch the administrator language.

Paramètres
string $cid The language tag.
Renvoie
boolean
Depuis
3.5

Références $client, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $data

$data = null
protected

◆ $option

$option = null
protected

◆ $path

$path = null
protected

◆ $total

$total = null
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • InstalledModel.php


Joomla CMS: Référence de la classe LanguageModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • LanguageModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LanguageModel
+ Graphe d'héritage de LanguageModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
getItem ($langId=null)
getForm ($data=array(), $loadData=true)
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
loadFormData ()
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Component Language Model

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method.

Paramètres
string | $group | Optional cache group name.
integer | $clientId

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the group form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A Form object on success, false on failure.
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $langId = null )

Method to get a member item.

Paramètres
integer $langId The id of the member to get.
Renvoie
mixed User data object on success, false on failure.
Depuis
1.0

Références $return, $value, class, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getTable()

getTable | ( | $name = '',
 |  | $prefix = '',
 |  | $options = array()
 | ) |

Override to get the table.

Paramètres
string | $name | Name of the table.
string | $prefix | Table name prefix.
array | $options | Array of options.
Renvoie
Table
Depuis
1.6

Références Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $context, $data, $name, $result, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), Joomla\CMS\MVC\Model\setState(), et ApplicationHelper\stringURLSafe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageModel.php


Joomla CMS: Référence de la classe LanguagesModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • LanguagesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LanguagesModel
+ Graphe d'héritage de LanguagesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
setPublished ($cid, $value=0)
delete ($pks)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.ordering', $direction='asc')
getStoreId ($id='')
getListQuery ()
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Model Class

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method, 2 places for 2 clients.

Paramètres
string | $group | Optional cache group name.
integer | $clientId

◆ delete()

delete ( $pks )

Method to delete records.

Paramètres
array $pks An array of item primary keys.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6

Références $itemId, et Table\getInstance().

◆ getListQuery()

getListQuery ( )
protected

Method to build an SQL query to load the list data.

Renvoie
string An SQL query
Depuis
1.6

Références $db, $published, $query, $this, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.ordering',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ setPublished()

setPublished | ( | $cid,
 |  | $value = 0
 | ) |

Set the published language(s).

Paramètres
array | $cid | An array of language IDs.
integer | $value | The value of the published state.
Renvoie
boolean True on success, false otherwise.
Depuis
1.6

Références $value, et Table\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/Model/LanguagesModel.php


Joomla CMS: Référence de la classe OverrideModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • OverrideModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe OverrideModel
+ Graphe d'héritage de OverrideModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
save ($data, $oppositeClient=false)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Override Model

Depuis
2.5

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A Form object on success, false on failure.
Depuis
2.5

Implémente FormModelInterface.

Références $client, $form, $language, Text\_(), Path\clean(), Language\getInstance(), Joomla\CMS\MVC\Model\getState(), Joomla\CMS\MVC\Model\loadForm(), null, et Text\sprintf().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
string $pk The key name.
Renvoie
mixed Object on success, false otherwise.
Depuis
2.5

Références $input, $oppositeStrings, $result, $strings, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et LanguageHelper\parseIniFile().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
2.5

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
2.5

Références $app, $client, $language, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ save()

save | ( | $data,
 |  | $oppositeClient = false
 | ) |

Method to save the form data.

Paramètres
array | $data | The form data.
boolean | $oppositeClient | Indicates whether the override should not be created for the current client.
Renvoie
boolean True on success, false otherwise.
Depuis
2.5

Références $app, $client, $data, $language, $oppositeClient, $strings, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), LanguageHelper\parseIniFile(), et LanguageHelper\saveToIniFile().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OverrideModel.php


Joomla CMS: Référence de la classe OverridesModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • OverridesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe OverridesModel
+ Graphe d'héritage de OverridesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getOverrides ($all=false)
getTotal ()
delete ($cids)
purge ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='key', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Overrides Model

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
2.5

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( $cids )

Method to delete one or more overrides.

Paramètres
array $cids Array of keys to delete.
Renvoie
integer Number of successfully deleted overrides, boolean false if an error occurred.
Depuis
2.5

Références $app, $client, $key, $strings, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), LanguageHelper\parseIniFile(), et LanguageHelper\saveToIniFile().

◆ getOverrides()

getOverrides ( $all = false )

Retrieves the overrides data

Paramètres
boolean $all True if all overrides shall be returned without considering pagination, defaults to false
Renvoie
array Array of objects containing the overrides of the override.ini file
Depuis
2.5

Références $client, $strings, File\delete(), Joomla\CMS\MVC\Model\getState(), et LanguageHelper\parseIniFile().

◆ getTotal()

getTotal ( )

Method to get the total number of overrides.

Renvoie
integer The total number of overrides.
Depuis
2.5

◆ populateState()

populateState | ( | $ordering = 'key',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
2.5

Références $app, $client, $direction, $language, $ordering, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ purge()

purge ( )

Removes all of the cached strings from the table.

Renvoie
boolean result of operation
Depuis
3.4.2

Références $db, Text\_(), Factory\getApplication(), et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OverridesModel.php


Joomla CMS: Référence de la classe StringsModel

  • Joomla
  • Component
  • Languages
  • Administrator
  • Model
  • StringsModel
Fonctions membres publiques
Référence de la classe StringsModel
+ Graphe d'héritage de StringsModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

refresh ()
search ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Languages Strings Model

Depuis
2.5

Documentation des fonctions membres

◆ refresh()

refresh ( )

Method for refreshing the cache in the database with the known language strings.

Renvoie
boolean| True on success, object otherwise.
Depuis
2.5

Références $app, $base, $client, $db, $key, $language, $path, $query, $strings, Path\clean(), Folder\files(), Factory\getApplication(), Joomla\Database\getDatabase(), JPATH_PLUGINS, null, LanguageHelper\parseIniFile(), et ParameterType\STRING.

◆ search()

search ( )

Method for searching language strings.

Renvoie
array| Array of results on success, object otherwise.
Depuis
2.5

Références $db, $input, $query, $results, Factory\getApplication(), Joomla\Database\getDatabase(), et InputFilter\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StringsModel.php


Joomla CMS: Référence de la classe Languages

  • Joomla
  • Component
  • Languages
  • Administrator
  • Service
  • HTML
  • Languages
Fonctions membres publiques
Référence de la classe Languages

Fonctions membres publiques

published ($published)
id ($rowNum, $language)
clients ()
publishedOptions ()

Description détaillée

Utility class working with languages

Depuis
1.6

Documentation des fonctions membres

◆ clients()

clients ( )

Method to generate an array of clients.

Renvoie
array of client objects.

Références Text\_(), et HTMLHelper\_().

◆ id()

id | ( | $rowNum,
 |  | $language
 | ) |

Method to generate an input radio button.

Paramètres
integer | $rowNum | The row number.
string | $language | Language tag.
Renvoie
string HTML code.

Références $language, et ENT_COMPAT.

◆ published()

published ( $published )

Method to generate an information about the default language.

Paramètres
boolean $published True if the language is the default.
Renvoie
string HTML code.

Références $published, Text\_(), HTMLHelper\_(), et null.

◆ publishedOptions()

publishedOptions ( )

Returns an array of published state filter options.

Renvoie
string The HTML code for the select tag.
Depuis
1.6

Références $options, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Languages.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Installed
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$option = null
$pagination
$rows = null
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Displays a list of the installed languages.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\custom(), ToolbarHelper\divider(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\makeDefault(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse.
Renvoie
void

Implémente ViewInterface.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $option

$option = null
protected

◆ $pagination

$pagination
protected

◆ $rows

$rows = null
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Installed/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Language
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$item
$form
$state
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

HTML View class for the Languages component.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse.
Renvoie
void

Implémente ViewInterface.

Références ContentHelper\getActions().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form

◆ $item

$item

◆ $state

$state
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Language/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Languages
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

HTML Languages View class for the Languages component.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, Text\_(), ToolbarHelper\divider(), ContentHelper\getActions(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse.
Renvoie
void

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Languages/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Multilangstatus
  • HtmlView
Fonctions membres publiques
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Displays the multilang status.

Depuis
1.7.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse.
Renvoie
void

Implémente ViewInterface.

Références MultilangstatusHelper\getContacts(), MultilangstatusHelper\getContentlangs(), MultilangstatusHelper\getDefaultHomeModule(), MultilangstatusHelper\getHomes(), MultilangstatusHelper\getLangswitchers(), ComponentHelper\getParams(), Multilanguage\getSiteHomePages(), MultilangstatusHelper\getStatus(), et Multilanguage\isEnabled().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Multilangstatus/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Override
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a language override

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the page title and toolbar.

Renvoie
void
Depuis
2.5

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Displays the view.

Paramètres
string $tpl The name of the template file to parse
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références $app, Text\_(), Factory\getApplication(), null, et Text\script().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Override/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Languages
  • Administrator
  • View
  • Overrides
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$languages
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View for language overrides list.

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the page title and toolbar.

Renvoie
void
Depuis
2.5

Références $canDo, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Displays the view.

Paramètres
string $tpl The name of the template file to parse.
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $items

$items
protected

◆ $languages

$languages
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_languages/src/View/Overrides/HtmlView.php


Joomla CMS: Référence de la classe LanguagesController

  • Joomla
  • Component
  • Languages
  • Api
  • Controller
  • LanguagesController
Attributs protégés
Référence de la classe LanguagesController
+ Graphe d'héritage de LanguagesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'languages'
$default_view = 'languages'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The languages controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'languages'
protected

◆ $default_view

$default_view = 'languages'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_languages/src/Controller/LanguagesController.php


Joomla CMS: Référence de la classe OverridesController

  • Joomla
  • Component
  • Languages
  • Api
  • Controller
  • OverridesController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe OverridesController
+ Graphe d'héritage de OverridesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
delete ($id=null)
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'overrides'
$default_view = 'overrides'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getClientFromInput ()
getLanguageFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The overrides controller

Depuis
4.0.0

Documentation des fonctions membres

◆ delete()

delete ( $id = null )

Removes an item.

Paramètres
integer $id The primary key to delete item.
Renvoie
void
Depuis
4.0.0

Références $id.

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getClientFromInput()

getClientFromInput ( )
private

Get client code from input

Renvoie
string
Depuis
4.0.0

◆ getLanguageFromInput()

getLanguageFromInput ( )
private

Get language code from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'overrides'
protected

◆ $default_view

$default_view = 'overrides'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_languages/src/Controller/OverridesController.php


Joomla CMS: Référence de la classe StringsController

  • Joomla
  • Component
  • Languages
  • Api
  • Controller
  • StringsController
Attributs protégés
Référence de la classe StringsController
+ Graphe d'héritage de StringsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'strings'
$default_view = 'strings'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The strings controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'strings'
protected

◆ $default_view

$default_view = 'strings'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_languages/src/Controller/StringsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Languages
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The languages view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'asset_id',
'lang_code',
'title',
'title_native',
'sef',
'image',
'description',
'metakey',
'metadesc',
'sitename',
'published',
'access',
'ordering',
'access_level',
'home',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'asset_id',
'lang_code',
'title',
'title_native',
'sef',
'image',
'description',
'metakey',
'metadesc',
'sitename',
'published',
'access',
'ordering',
'access_level',
'home',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_languages/src/View/Languages/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Overrides
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem = ['value']
$fieldsToRenderList = ['value']
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The overrides view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem = ['value']
protected

◆ $fieldsToRenderList

$fieldsToRenderList = ['value']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_languages/src/View/Overrides/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Languages
  • Api
  • View
  • Strings
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The strings view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'string',
'file',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_languages/src/View/Strings/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Login
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
login ()
logout ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Login Controller.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticThisobjecttosupportchaining.@since1.5@throws\Exception

To prevent clickjacking, only allow the login form to be used inside a frame in the same origin. So send a X-Frame-Options HTTP Header with the SAMEORIGIN value.

https://tools.ietf.org/html/rfc7034

Références Text\_().

◆ login()

login ( )

Method to log in a user.

Renvoie
void

Références $app, $model, $return, Joomla\Application\checkToken(), et Uri\isInternal().

◆ logout()

logout ( )

Method to log out a user.

Renvoie
void

Références $app, $model, $options, $result, $return, Joomla\Application\checkToken(), Uri\isInternal(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_login/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Login
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

dispatch ()
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_login

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

com_login does not require check permission, so we override checkAccess method and have it empty

Renvoie
void

◆ dispatch()

dispatch ( )

Dispatch a controller task.

Renvoie
void
Depuis
4.0.0

Implémente DispatcherInterface.

Références $task, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_login/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe LoginModel

  • Joomla
  • Component
  • Login
  • Administrator
  • Model
  • LoginModel
Fonctions membres publiques statiques | Fonctions membres protégées
Référence de la classe LoginModel
+ Graphe d'héritage de LoginModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques statiques

static | getLoginModule ($name='mod_login', $title=null)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static $paths

Description détaillée

Login Model

Depuis
1.5

Documentation des fonctions membres

◆ getLoginModule()

static getLoginModule | ( | $name = 'mod_login',
 |  | $title = null
 | ) |
static

Get the administrator login module by name (real, eg 'login' or folder, eg 'mod_login').

Paramètres
string | $name | The name of the module.
string | $title | The title of the module, optional.
Renvoie
object The Module object.
Depuis
1.7.0

Références $i, $modules, $name, $result, $title, $total, et null.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $input, $return, Factory\getApplication(), Uri\isInternal(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_login/src/Model/LoginModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Login
  • Administrator
  • View
  • Login
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

HTML View class for the Login component

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_login/src/View/Login/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Mails
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'templates'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Mail templates Controller

Depuis
4.0.0

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
BaseController|boolean This object to support chaining.
Depuis
4.0.0

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'templates'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_mails/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe TemplateController

  • Joomla
  • Component
  • Mails
  • Administrator
  • Controller
  • TemplateController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TemplateController
+ Graphe d'héritage de TemplateController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
edit ($key=null, $urlVar=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=[])
getRedirectToItemAppend ($recordId=null, $urlVar='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The template controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = [] )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to edit an existing record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if access level check and checkout passes, false otherwise.
Depuis
4.0.0

Références $context, $language, Text\_(), Route\_(), et null.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
string[] | $recordId The primary key id for the item in the first element and the language of the mail template in the second key.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $language, $recordId, et $return.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_mails/src/Controller/TemplateController.php


Joomla CMS: Référence de la classe MailsHelper

  • Joomla
  • Component
  • Mails
  • Administrator
  • Helper
  • MailsHelper
Fonctions membres publiques statiques
Référence de la classe MailsHelper

Fonctions membres publiques statiques

static | mailtags ($mail, $fieldname)
static | loadTranslationFiles ($extension)

Description détaillée

Mailtags HTML helper class.

Depuis
4.0.0

Documentation des fonctions membres

◆ loadTranslationFiles()

static loadTranslationFiles ( $extension )
static

Load the translation files for an extension

Paramètres
string $extension Extension name
Renvoie
void
Depuis
4.0.0

Références $extension, $lang, $parts, Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, et JPATH_SITE.

Référencé par HtmlView\display().

◆ mailtags()

static mailtags | ( | $mail,
 |  | $fieldname
 | ) |
static

Display a clickable list of tags for a mail template

Paramètres
object | $mail | Row of the mail template.
string | $fieldname | Name of the target field.
Renvoie
string List of tags that can be inserted into a field.
Depuis
4.0.0

Références $html, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MailsHelper.php


Joomla CMS: Référence de la classe TemplateModel

  • Joomla
  • Component
  • Mails
  • Administrator
  • Model
  • TemplateModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe TemplateModel
+ Graphe d'héritage de TemplateModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
getMaster ($pk=null)
getTable ($name='Template', $prefix='Administrator', $options=array())
validate ($form, $data, $group=null)
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_mails.template'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
loadFormData ()
prepareTable ($table)
populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_MAILS'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Item Model for a Mail template.

Depuis
4.0.0

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
4.0.0

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A JForm object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $field, $form, $params, Path\check(), Path\clean(), ComponentHelper\getParams(), JPATH_ROOT, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
CMSObject|boolean Object on success, false on failure.
Depuis
4.0.0

Références $item, $language, $return, class, Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getMaster()

getMaster ( $pk = null )

Get the master data for a mail template.

Paramètres
integer $pk The id of the primary key.
Renvoie
CMSObject|boolean Object on success, false on failure.
Depuis
4.0.0

Références $item, $return, class, Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getTable()

getTable | ( | $name = 'Template',
 |  | $prefix = 'Administrator',
 |  | $options = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
4.0.0
Exceptions

Références $name, $options, et $prefix.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
4.0.0

Références $app, $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Stock method to auto-populate the model state.

Renvoie
void
Depuis
4.0.0

Références $language, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table data prior to saving.

Paramètres
Table $table A reference to a Table object.
Renvoie
void
Depuis
4.0.0

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
4.0.0

Références $context, $data, $key, $language, $name, $result, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), et Joomla\CMS\MVC\Model\setState().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Depuis
4.0.0

Références $data, $form, et Text\_().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_MAILS'
protected

◆ $typeAlias

$typeAlias = 'com_mails.template'
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_mails/src/Model/TemplateModel.php


Joomla CMS: Référence de la classe TemplatesModel

  • Joomla
  • Component
  • Mails
  • Administrator
  • Model
  • TemplatesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TemplatesModel
+ Graphe d'héritage de TemplatesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
getExtensions ()
getLanguages ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of mail template records.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
4.0.0
Exceptions

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getExtensions()

getExtensions ( )

Get list of extensions which are using mail templates

Renvoie
array
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getItems()

getItems ( )

Get a list of mail templates

Renvoie
array
Depuis
4.0.0

Implémente ListModelInterface.

Références $db, $id, $item, $items, $query, et Joomla\Database\getDatabase().

◆ getLanguages()

getLanguages ( )

Get a list of the current content languages

Renvoie
array
Depuis
4.0.0

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
QueryInterface
Depuis
4.0.0

Références $db, $extension, $language, $query, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
4.0.0

Références $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_mails/src/Model/TemplatesModel.php


Joomla CMS: Référence de la classe TemplateTable

  • Joomla
  • Component
  • Mails
  • Administrator
  • Table
  • TemplateTable
Fonctions membres publiques | Attributs protégés
Référence de la classe TemplateTable
+ Graphe d'héritage de TemplateTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_jsonEncode = ['attachments', 'params']
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Mail Table class.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['attachments', 'params']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplateTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Mails
  • Administrator
  • View
  • Template
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$templateData
$master
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a mail template.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $toolbar, Text\_(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $component, $field, $fields, $language, $this, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_SITE, et null.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $master

$master
protected

◆ $state

$state
protected

◆ $templateData

$templateData
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_mails/src/View/Template/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Mails
  • Administrator
  • View
  • Templates
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$languages
$defaultLanguage
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for the mail templates configuration

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $toolbar, $user, Text\_(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $language, ComponentHelper\getParams(), items, et MailsHelper\loadTranslationFiles().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $defaultLanguage

$defaultLanguage
protected

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $languages

$languages
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_mails/src/View/Templates/HtmlView.php


Joomla CMS: Référence de l'interface AdapterInterface

  • Joomla
  • Component
  • Media
  • Administrator
  • Adapter
  • AdapterInterface
Fonctions membres publiques
Référence de l'interface AdapterInterface
+ Graphe d'héritage de AdapterInterface:
LocalAdapter

Fonctions membres publiques

getFile (string $path='/')
getFiles (string $path='/')
getResource (string $path)
createFolder (string $name, string $path)
createFile (string $name, string $path, $data)
updateFile (string $name, string $path, $data)
delete (string $path)
move (string $sourcePath, string $destinationPath, bool $force=false)
copy (string $sourcePath, string $destinationPath, bool $force=false)
getUrl (string $path)
getAdapterName ()
search (string $path, string $needle, bool $recursive=false)

Description détaillée

Media file adapter interface.

Depuis
4.0.0

Documentation des fonctions membres

◆ copy()

copy | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |

Copies a file or folder from source to destination.

It returns the new destination path. This allows the implementation classes to normalise the file name.

Paramètres
string | $sourcePath | The source path
string | $destinationPath | The destination path
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ createFile()

createFile | ( | string | $name,
 |  | string | $path,
 |  |  | $data
 | ) |  |

Creates a file with the given name in the given path with the data.

It returns the new file name. This allows the implementation classes to normalise the file name.

Paramètres
string | $name | The name
string | $path | The folder
string | $data | The data
Renvoie
string
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ createFolder()

createFolder | ( | string | $name,
 |  | string | $path
 | ) |  |

Creates a folder with the given name in the given path.

It returns the new folder name. This allows the implementation classes to normalise the file name.

Paramètres
string | $name | The name
string | $path | The folder
Renvoie
string
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ delete()

delete ( string $path )

Deletes the folder or file of the given path.

Paramètres
string $path The path to the file or folder
Renvoie
void
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ getAdapterName()

getAdapterName ( )

Returns the name of the adapter. It will be shown in the Media Manager

Renvoie
string
Depuis
4.0.0

Implémenté dans LocalAdapter.

◆ getFile()

getFile ( string $path = '/' )

Returns the requested file or folder. The returned object has the following properties available:

  • type: The type can be file or dir
  • name: The name of the file
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

If the path doesn't exist a FileNotFoundException is thrown.

Paramètres
string $path The path to the file or folder
Renvoie
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ getFiles()

getFiles ( string $path = '/' )

Returns the folders and files for the given path. The returned objects have the following properties available:

  • type: The type can be file or dir
  • name: The name of the file
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

If the path doesn't exist a FileNotFoundException is thrown.

Paramètres
string $path The folder
Renvoie
[]
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ getResource()

getResource ( string $path )

Returns a resource for the given path.

Paramètres
string $path The path
Renvoie
resource
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ getUrl()

getUrl ( string $path )

Returns a public url for the given path. This function can be used by the cloud adapter to publish the media file and create a permanent publicly accessible url.

Paramètres
string $path The path to file
Renvoie
string
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ move()

move | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |

Moves a file or folder from source to destination.

It returns the new destination path. This allows the implementation classes to normalise the file name.

Paramètres
string | $sourcePath | The source path
string | $destinationPath | The destination path
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

◆ search()

search | ( | string | $path,
 |  | string | $needle,
 |  | bool | $recursive = false
 | ) |  |

Search for a pattern in a given path

Paramètres
string | $path | The base path for the search
string | $needle | The path to file
bool | $recursive | Do a recursive search
Renvoie
[]
Depuis
4.0.0

Implémenté dans LocalAdapter.

◆ updateFile()

updateFile | ( | string | $name,
 |  | string | $path,
 |  |  | $data
 | ) |  |

Updates the file with the given name in the given path with the data.

Paramètres
string | $name | The name
string | $path | The folder
string | $data | The data
Renvoie
void
Depuis
4.0.0
Exceptions

Implémenté dans LocalAdapter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Adapter/AdapterInterface.php


Joomla CMS: Référence de la classe ApiController

  • Joomla
  • Component
  • Media
  • Administrator
  • Controller
  • ApiController
Fonctions membres publiques | Fonctions membres privées
Référence de la classe ApiController
+ Graphe d'héritage de ApiController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

execute ($task)
getFiles ()
deleteFiles ()
postFiles ()
putFiles ()
getModel ($name='Api', $prefix='Administrator', $config=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres privées

sendResponse ($data=null, int $responseCode=200)
checkContent ()
getAdapter ()
getPath ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Api Media Controller

This is NO public api controller, it is internal for the com_media component only!

Depuis
4.0.0

Documentation des fonctions membres

◆ checkContent()

checkContent ( )
private

Performs various checks if it is allowed to save the content.

Renvoie
void
Depuis
4.0.0
Exceptions

Références $helper, $params, Text\_(), et ComponentHelper\getParams().

◆ deleteFiles()

deleteFiles ( )

Files delete Method

Examples:

  • DELETE an existing folder in a specific folder: index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test /api/files/sampledata/cassiopeia/test
  • DELETE an existing file in a specific folder: index.php?option=com_media&task=api.files&path=/sampledata/cassiopeia/test.jpg /api/files/sampledata/cassiopeia/test.jpg
Renvoie
null
Depuis
4.0.0
Exceptions

Références Text\_(), Joomla\Component\Media\Administrator\Provider\getAdapter(), et null.

◆ execute()

execute ( $task )

Execute a task by triggering a method in the derived class.

Paramètres
string $task The task to perform. If no matching task is found, the '__default' task is executed, if defined.
Renvoie
mixed The value returned by the called method.
Depuis
4.0.0
Exceptions

Implémente ControllerInterface.

Références $data, $method, $task, Text\_(), Session\checkToken(), method, et Text\sprintf().

◆ getAdapter()

getAdapter ( )
private

Get the Adapter.

Renvoie
string
Depuis
4.0.0

Références $parts, et null.

◆ getFiles()

getFiles ( )

Files Get Method

Examples:

  • GET a list of folders below the root: index.php?option=com_media&task=api.files /api/files
  • GET a list of files and subfolders of a given folder: index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia /api/files/sampledata/cassiopeia
  • GET a list of files and subfolders of a given folder for a given search term: use recursive=1 to search recursively in the working directory index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia&search=nasa5 /api/files/sampledata/cassiopeia?search=nasa5 To look up in same working directory set flag recursive=0 index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia&search=nasa5&recursive=0 /api/files/sampledata/cassiopeia?search=nasa5&recursive=0
  • GET file information for a specific file: index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg /api/files/sampledata/cassiopeia/test.jpg
  • GET a temporary URL to a given file index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg&url=1&temp=1 /api/files/sampledata/cassiopeia/test.jpg&url=1&temp=1
  • GET a temporary URL to a given file index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg&url=1 /api/files/sampledata/cassiopeia/test.jpg&url=1
Renvoie
array The data to send with the response
Depuis
4.0.0
Exceptions

Références $options, et Joomla\Component\Media\Administrator\Provider\getAdapter().

◆ getModel()

getModel | ( | $name = 'Api',
 |  | $prefix = 'Administrator',
 |  | $config = []
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
BaseModel|boolean Model object on success; otherwise false on failure.
Depuis
4.0.0

Références $config, $name, et $prefix.

◆ getPath()

getPath ( )
private

Get the Path.

Renvoie
string
Depuis
4.0.0

Références $parts, et null.

◆ postFiles()

postFiles ( )

Files Post Method

Examples:

  • POST a new file or folder into a specific folder, the file or folder information is returned: index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia /api/files/sampledata/cassiopeia

    New file body: { "name": "test.jpg", "content":"base64 encoded image" } New folder body: { "name": "test", }

Renvoie
array The data to send with the response
Depuis
4.0.0
Exceptions

Références $content, $name, $options, $path, Text\_(), et Joomla\Component\Media\Administrator\Provider\getAdapter().

◆ putFiles()

putFiles ( )

Files Put method

Examples:

  • PUT a media file, the file or folder information is returned: index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg /api/files/sampledata/cassiopeia/test.jpg

    Update file body: { "content":"base64 encoded image" }

  • PUT move a file, folder to another one path : will be taken as the source index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg /api/files/sampledata/cassiopeia/test.jpg

    JSON body: { "newPath" : "/path/to/destination", "move" : "1" }

  • PUT copy a file, folder to another one path : will be taken as the source index.php?option=com_media&task=api.files&format=json&path=/sampledata/cassiopeia/test.jpg /api/files/sampledata/cassiopeia/test.jpg

    JSON body: { "newPath" : "/path/to/destination", "move" : "0" }

Renvoie
array The data to send with the response
Depuis
4.0.0
Exceptions

Références $content, $name, $path, Text\_(), Joomla\Component\Media\Administrator\Provider\getAdapter(), et null.

◆ sendResponse()

sendResponse | ( |  | $data = null,
 |  | int | $responseCode = 200
 | ) |  |
private

Send the given data as JSON response in the following format:

{"success":true,"message":"ok","messages":null,"data":[{"type":"dir","name":"banners","path":"//"}]}

Paramètres
mixed | $data | The data to send
integer | $responseCode | The response code
Renvoie
void
Depuis
4.0.0

Références $data.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Controller/ApiController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Media
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getView ($name='', $type='', $prefix='', $config=[])
getModel ($name='', $prefix='', $config=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'media'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Media Manager Component Controller

Depuis
4.0.0

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = '',
 |  | $prefix = '',
 |  | $config = []
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
|boolean Model object on success; otherwise false on failure.
Depuis
3.0

Références $config, et $name.

◆ getView()

getView | ( | $name = '',
 |  | $type = '',
 |  | $prefix = '',
 |  | $config = []
 | ) |

Method to get a reference to the current view and load it if necessary.

Paramètres
string | $name | The view name. Optional, defaults to the controller name.
string | $type | The view type. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for view. Optional.
Renvoie
Reference to the view or an error.
Depuis
3.0
Exceptions

Références $config, $name, et $type.

Documentation des champs

◆ $default_view

$default_view = 'media'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe PluginController

  • Joomla
  • Component
  • Media
  • Administrator
  • Controller
  • PluginController
Fonctions membres publiques | Fonctions membres privées
Référence de la classe PluginController
+ Graphe d'héritage de PluginController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

oauthcallback ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres privées

containsPlugin ($plugins, $pluginName)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Plugin Controller for OAuth2.0 callbacks

This controller handles OAuth2 Callbacks

Depuis
4.0.0

Documentation des fonctions membres

◆ containsPlugin()

containsPlugin | ( | $plugins,
 |  | $pluginName
 | ) |
private

Check whether a plugin exists in given plugin array.

Paramètres
array | $plugins | Array of plugin names
string | $pluginName | Plugin name to look up
Renvoie
bool
Depuis
4.0.0

◆ oauthcallback()

oauthcallback ( )

Handles an OAuth Callback request for a specified plugin.

URLs containing [sitename]/administrator/index.php?option=com_media&task=plugin.oauthcallback &plugin=[plugin_name]

will be handled by this endpoint. It will select the plugin specified by plugin_name and pass all the data received from the provider

Renvoie
void
Depuis
4.0.0

Execute actions defined by the plugin Supported actions

  • close : Closes the current window, use this only for windows opened by javascript
  • redirect : Redirect to a URI defined in 'redirect_uri' parameter, if not fallback to control panel
  • media-manager : Redirect to Media Manager
  • control-panel : Redirect to Control Panel

Close a window opened by developer Use this for close New Windows opened for OAuth Process

Références $input, $message, Route\_(), PluginHelper\getPlugin(), PluginHelper\importPlugin(), PluginHelper\isEnabled(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_media/src/Controller/PluginController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Media
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_media

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void

Références $author, et $user.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AbstractMediaItemValidationEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • AbstractMediaItemValidationEvent
Fonctions membres protégées
Référence de la classe AbstractMediaItemValidationEvent
+ Graphe d'héritage de AbstractMediaItemValidationEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface FetchMediaItemEvent FetchMediaItemsEvent

Fonctions membres protégées

validate (\stdClass $item)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)
- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event to validate media items.

Depuis
4.1.0

Documentation des fonctions membres

◆ validate()

validate ( \stdClass $item )
protected

Validate $item to have all attributes with a valid type.

Properties validated:

  • type: The type can be file or dir
  • name: The name of the item
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

Properties generated:

  • created_date_formatted: DATE_FORMAT_LC5 formatted string based on create_date
  • modified_date_formatted: DATE_FORMAT_LC5 formatted string based on modified_date
Paramètres
\stdClass $item The item to set
Renvoie
void
Depuis
4.1.0
Exceptions

Références $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractMediaItemValidationEvent.php


Joomla CMS: Référence de la classe FetchMediaItemEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • FetchMediaItemEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FetchMediaItemEvent
+ Graphe d'héritage de FetchMediaItemEvent:
AbstractMediaItemValidationEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setItem (\stdClass $item)
- Fonctions membres protégées hérités de AbstractMediaItemValidationEvent
validate (\stdClass $item)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object for fetch media item.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setItem()

setItem ( \stdClass $item )
protected

Validate $item to have all attributes with a valid type

Validation based on ::getFile()

Properties validated:

  • type: The type can be file or dir
  • name: The name of the item
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

Generation based on ::getPathInformation()

Properties generated:

  • created_date_formatted: DATE_FORMAT_LC5 formatted string based on create_date
  • modified_date_formatted: DATE_FORMAT_LC5 formatted string based on modified_date
Paramètres
\stdClass $item The item to set
Renvoie
Depuis
4.1.0
Exceptions

Références $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FetchMediaItemEvent.php


Joomla CMS: Référence de la classe FetchMediaItemsEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • FetchMediaItemsEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FetchMediaItemsEvent
+ Graphe d'héritage de FetchMediaItemsEvent:
AbstractMediaItemValidationEvent AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setItems (array $items)
getItems (array $items)
- Fonctions membres protégées hérités de AbstractMediaItemValidationEvent
validate (\stdClass $item)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object for fetch media items.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( array $items )
protected

Returns the items.

Paramètres
array $items The value to set
Renvoie
array
Depuis
4.1.0

Références $item, $items, et $result.

◆ setItems()

setItems ( array $items )
protected

Validate $item to be an array

Paramètres
array $items The value to set
Renvoie
array
Depuis
4.1.0

Références $item, $items, et $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FetchMediaItemsEvent.php


Joomla CMS: Référence de la classe FetchMediaItemUrlEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • FetchMediaItemUrlEvent
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe FetchMediaItemUrlEvent
+ Graphe d'héritage de FetchMediaItemUrlEvent:
AbstractImmutableEvent AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
- Fonctions membres publiques hérités de AbstractImmutableEvent
__construct (string $name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Fonctions membres protégées

setUrl (string $value)
setPath (string $value)
setAdapter (string $value)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object to set an url.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions

Références $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ setAdapter()

setAdapter ( string $value )
protected

Forbid setting $path

Paramètres
string $value The value to set
Depuis
4.1.0
Exceptions

Références name.

◆ setPath()

setPath ( string $value )
protected

Forbid setting $path

Paramètres
string $value The value to set
Depuis
4.1.0
Exceptions

Références name.

◆ setUrl()

setUrl ( string $value )
protected

Validate $value to be a string

Paramètres
string $value The value to set
Renvoie
string
Depuis
4.1.0

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FetchMediaItemUrlEvent.php


Joomla CMS: Référence de la classe MediaProviderEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • MediaProviderEvent
Fonctions membres publiques | Attributs privés
Référence de la classe MediaProviderEvent
+ Graphe d'héritage de MediaProviderEvent:
AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getProviderManager ()
setProviderManager (ProviderManager $providerManager)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$providerManager = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object to retrieve Media Adapters.

Depuis
4.0.0

Documentation des fonctions membres

◆ getProviderManager()

getProviderManager ( )

Return the ProviderManager

Renvoie
ProviderManager
Depuis
4.0.0

Référencé par PlgFileSystemLocal\onSetupProviders().

◆ setProviderManager()

setProviderManager ( ProviderManager $providerManager )

Set the ProviderManager

Paramètres
ProviderManager $providerManager The Provider Manager to be set
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $providerManager

$providerManager = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaProviderEvent.php


Joomla CMS: Référence de la classe OAuthCallbackEvent

  • Joomla
  • Component
  • Media
  • Administrator
  • Event
  • OAuthCallbackEvent
Fonctions membres publiques | Attributs privés
Référence de la classe OAuthCallbackEvent
+ Graphe d'héritage de OAuthCallbackEvent:
AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getContext ()
setContext ($context)
getInput ()
setInput ($input)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$context = null
$input = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object to retrieve OAuthCallbacks.

Depuis
4.0.0

Documentation des fonctions membres

◆ getContext()

getContext ( )

Get the event context.

Renvoie
string
Depuis
4.0.0

Références $context.

◆ getInput()

getInput ( )

Get the event input.

Renvoie
Input
Depuis
4.0.0

Références $input.

◆ setContext()

setContext ( $context )

Set the event context.

Paramètres
string $context Event context
Renvoie
void
Depuis
4.0.0

Références $context.

◆ setInput()

setInput ( $input )

Set the event input.

Paramètres
Input $input Event input
Renvoie
void
Depuis
4.0.0

Références $input.

Documentation des champs

◆ $context

$context = null
private

◆ $input

$input = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OAuthCallbackEvent.php


Joomla CMS: Référence de la classe FileExistsException

  • Joomla
  • Component
  • Media
  • Administrator
  • Exception
  • FileExistsException
Référence de la classe FileExistsException
+ Graphe d'héritage de FileExistsException:

Description détaillée

Media file exists exception.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • FileExistsException.php


Joomla CMS: Référence de la classe FileNotFoundException

  • Joomla
  • Component
  • Media
  • Administrator
  • Exception
  • FileNotFoundException
Référence de la classe FileNotFoundException
+ Graphe d'héritage de FileNotFoundException:

Description détaillée

Media file not found exception.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Exception/FileNotFoundException.php


Joomla CMS: Référence de la classe InvalidPathException

  • Joomla
  • Component
  • Media
  • Administrator
  • Exception
  • InvalidPathException
Référence de la classe InvalidPathException
+ Graphe d'héritage de InvalidPathException:

Description détaillée

Media invalid path exception.

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidPathException.php


Joomla CMS: Référence de la classe ApiModel

  • Joomla
  • Component
  • Media
  • Administrator
  • Model
  • ApiModel
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ApiModel
+ Graphe d'héritage de ApiModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getFile ($adapter, $path='/', $options=[])
getFiles ($adapter, $path='/', $options=[])
createFolder ($adapter, $name, $path, $override)
createFile ($adapter, $name, $path, $data, $override)
updateFile ($adapter, $name, $path, $data)
delete ($adapter, $path)
copy ($adapter, $sourcePath, $destinationPath, $force=false)
move ($adapter, $sourcePath, $destinationPath, $force=false)
getUrl ($adapter, $path)
search ($adapter, $needle, $path='/', $recursive=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres privées

isMediaFile ($path)

Attributs privés

$allowedExtensions = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Api Model

Depuis
4.0.0

Documentation des fonctions membres

◆ copy()

copy | ( | $adapter,
 |  | $sourcePath,
 |  | $destinationPath,
 |  | $force = false
 | ) |

Copies file or folder from source path to destination path If forced, existing files/folders would be overwritten

Paramètres
string | $adapter | The adapter
string | $sourcePath | Source path of the file or folder (relative)
string | $destinationPath | Destination path(relative)
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Références Joomla\Component\Media\Administrator\Provider\getAdapter().

◆ createFile()

createFile | ( | $adapter,
 |  | $name,
 |  | $path,
 |  | $data,
 |  | $override
 | ) |

Creates a file with the given name in the given path with the data. More information can be found in AdapterInterface::createFile().

Paramètres
string | $adapter | The adapter
string | $name | The name
string | $path | The folder
string | $data | The data
boolean | $override | Should the file being overridden when it exists
Renvoie
string
Depuis
4.0.0
Exceptions

Références $app, $data, $name, $path, $result, Joomla\Component\Media\Administrator\Provider\getAdapter(), Factory\getApplication(), File\getExt(), et PluginHelper\importPlugin().

◆ createFolder()

createFolder | ( | $adapter,
 |  | $name,
 |  | $path,
 |  | $override
 | ) |

Creates a folder with the given name in the given path. More information can be found in AdapterInterface::createFolder().

Paramètres
string | $adapter | The adapter
string | $name | The name
string | $path | The folder
boolean | $override | Should the folder being overridden when it exists
Renvoie
string
Depuis
4.0.0
Exceptions

Références $app, $name, $path, $result, Joomla\Component\Media\Administrator\Provider\getAdapter(), Factory\getApplication(), et PluginHelper\importPlugin().

◆ delete()

delete | ( | $adapter,
 |  | $path
 | ) |

Deletes the folder or file of the given path. More information can be found in AdapterInterface::delete().

Paramètres
string | $adapter | The adapter
string | $path | The path to the file or folder
Renvoie
void
Depuis
4.0.0
Exceptions

Références $app, $path, $result, $this, $type, Joomla\Component\Media\Administrator\Provider\getAdapter(), Factory\getApplication(), et PluginHelper\importPlugin().

◆ getFile()

getFile | ( | $adapter,
 |  | $path = '/',
 |  | $options = []
 | ) |

Returns the requested file or folder information. More information can be found in AdapterInterface::getFile().

Paramètres
string | $adapter | The adapter
string | $path | The path to the file or folder
array | $options | The options
Renvoie
Depuis
4.0.0
Exceptions

Références $options, $path, $this, Joomla\Component\Media\Administrator\Provider\getAdapter(), et Factory\getApplication().

◆ getFiles()

getFiles | ( | $adapter,
 |  | $path = '/',
 |  | $options = []
 | ) |

Returns the folders and files for the given path. More information can be found in AdapterInterface::getFiles().

Paramètres
string | $adapter | The adapter
string | $path | The folder
array | $options | The options
Renvoie
[]
Depuis
4.0.0
Exceptions

Références $key, $options, $path, $this, Joomla\Component\Media\Administrator\Provider\getAdapter(), Factory\getApplication(), et null.

◆ getUrl()

getUrl | ( | $adapter,
 |  | $path
 | ) |

Returns a url for serve media files from adapter. Url must provide a valid image type to be displayed on Joomla! site.

Paramètres
string | $adapter | The adapter
string | $path | The relative path for the file
Renvoie
string Permalink to the relative file
Depuis
4.0.0
Exceptions
FileNotFoundException

Références $path, $url, Joomla\Component\Media\Administrator\Provider\getAdapter(), et Factory\getApplication().

◆ isMediaFile()

isMediaFile ( $path )
private

Checks if the given path is an allowed media file.

Paramètres
string $path The path to file
Renvoie
boolean
Depuis
4.0.0

Références $extension, $images, $mediaTypes, $path, $type, Factory\getApplication(), ComponentHelper\getParams(), et null.

◆ move()

move | ( | $adapter,
 |  | $sourcePath,
 |  | $destinationPath,
 |  | $force = false
 | ) |

Moves file or folder from source path to destination path If forced, existing files/folders would be overwritten

Paramètres
string | $adapter | The adapter
string | $sourcePath | Source path of the file or folder (relative)
string | $destinationPath | Destination path(relative)
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Références Joomla\Component\Media\Administrator\Provider\getAdapter().

◆ search()

search | ( | $adapter,
 |  | $needle,
 |  | $path = '/',
 |  | $recursive = true
 | ) |

Search for a pattern in a given path

Paramètres
string | $adapter | The adapter to work on
string | $needle | The search therm
string | $path | The base path for the search
bool | $recursive | Do a recursive search
Renvoie
[]
Depuis
4.0.0
Exceptions

Références $path, et Joomla\Component\Media\Administrator\Provider\getAdapter().

◆ updateFile()

updateFile | ( | $adapter,
 |  | $name,
 |  | $path,
 |  | $data
 | ) |

Updates the file with the given name in the given path with the data. More information can be found in AdapterInterface::updateFile().

Paramètres
string | $adapter | The adapter
string | $name | The name
string | $path | The folder
string | $data | The data
Renvoie
void
Depuis
4.0.0
Exceptions

Références $app, $data, $name, $path, $result, Joomla\Component\Media\Administrator\Provider\getAdapter(), Factory\getApplication(), File\getExt(), et PluginHelper\importPlugin().

Documentation des champs

◆ $allowedExtensions

$allowedExtensions = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApiModel.php


Joomla CMS: Référence de la classe FileModel

  • Joomla
  • Component
  • Media
  • Administrator
  • Model
  • FileModel
Fonctions membres publiques
Référence de la classe FileModel
+ Graphe d'héritage de FileModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getFileInformation ($path)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

File Model

Depuis
4.0.0

Documentation des fonctions membres

◆ getFileInformation()

getFileInformation ( $path )

Method to get the file information for the given path. Path must be in the format: adapter:path/to/file.extension

Paramètres
string $path The path to get the information from.
Renvoie
An object with file information
Depuis
4.0.0
Voir également
ApiModel::getFile()

Références $path.

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $form, FormHelper\addFormPath(), PluginHelper\importPlugin(), JPATH_ADMINISTRATOR, et Joomla\CMS\MVC\Model\loadForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FileModel.php


Joomla CMS: Référence de la classe MediaModel

  • Joomla
  • Component
  • Media
  • Administrator
  • Model
  • MediaModel
Fonctions membres publiques
Référence de la classe MediaModel
+ Graphe d'héritage de MediaModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getProviders ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Media View Model

Depuis
4.0.0

Documentation des fonctions membres

◆ getProviders()

getProviders ( )

Obtain list of supported providers

Renvoie
array
Depuis
4.0.0

Références $result, $results, et Joomla\Component\Media\Administrator\Provider\getProviderManager().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/Model/MediaModel.php


Joomla CMS: Référence de la classe MediaActionPlugin

  • Joomla
  • Component
  • Media
  • Administrator
  • Plugin
  • MediaActionPlugin
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MediaActionPlugin
+ Graphe d'héritage de MediaActionPlugin:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface PlgMediaActionCrop PlgMediaActionResize PlgMediaActionRotate

Fonctions membres publiques

onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

loadJs ()
loadCss ()
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Media Manager Base Plugin for the media actions

Depuis
4.0.0

Documentation des fonctions membres

◆ loadCss()

loadCss ( )
protected

Load the CSS files of the plugin.

Renvoie
void
Depuis
4.0.0

Références HTMLHelper\_().

◆ loadJs()

loadJs ( )
protected

Load the javascript files of the plugin.

Renvoie
void
Depuis
4.0.0

Références HTMLHelper\_().

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

The form event. Load additional parameters when available into the field form. Only when the type of the form is of interest.

Paramètres
Form | $form | The form
\stdClass | $data | The data
Renvoie
void
Depuis
4.0.0

Références $form, et JPATH_PLUGINS.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaActionPlugin.php


Joomla CMS: Référence de l'interface ProviderInterface

  • Joomla
  • Component
  • Media
  • Administrator
  • Provider
  • ProviderInterface
Fonctions membres publiques
Référence de l'interface ProviderInterface
+ Graphe d'héritage de ProviderInterface:
PlgFileSystemLocal

Fonctions membres publiques

getID ()
getDisplayName ()
getAdapters ()

Description détaillée

Media provider interface.

Depuis
4.0.0

Documentation des fonctions membres

◆ getAdapters()

getAdapters ( )

Returns a list of adapters

Renvoie
AdapterInterface[]
Depuis
4.0.0

Implémenté dans PlgFileSystemLocal.

◆ getDisplayName()

getDisplayName ( )

Returns the display name

Renvoie
string
Depuis
4.0.0

Implémenté dans PlgFileSystemLocal.

◆ getID()

getID ( )

Returns the ID of the provider

Renvoie
string
Depuis
4.0.0

Implémenté dans PlgFileSystemLocal.

Référencé par ProviderManager\registerProvider().

La documentation de cette interface a été générée à partir du fichier suivant :
  • ProviderInterface.php


Joomla CMS: Référence de la classe ProviderManager

  • Joomla
  • Component
  • Media
  • Administrator
  • Provider
  • ProviderManager
Fonctions membres publiques | Attributs privés
Référence de la classe ProviderManager

Fonctions membres publiques

getProviders ()
registerProvider (ProviderInterface $provider)
unregisterProvider (ProviderInterface $provider=null)
getProvider ($id)
getAdapter ($name)

Attributs privés

$providers = []

Description détaillée

Media Adapter Manager

Depuis
4.0.0

Documentation des fonctions membres

◆ getAdapter()

getAdapter ( $name )

Returns an adapter for an account

Paramètres
string $name The name of an adapter
Renvoie
AdapterInterface
Exceptions

Références $name, Text\_(), Joomla\Component\Media\Administrator\Provider\getProvider(), et null.

◆ getProvider()

getProvider ( $id )

Returns the provider for a particular ID

Paramètres
string $id The ID for the provider
Renvoie
ProviderInterface
Exceptions

Références $id, et Text\_().

◆ getProviders()

getProviders ( )

Returns an associative array of adapters with provider name as the key

Renvoie
ProviderInterface[]
Depuis
4.0.0

◆ registerProvider()

registerProvider ( ProviderInterface $provider )

Register a provider into the ProviderManager

Paramètres
ProviderInterface $provider The provider to be registered
Renvoie
void
Depuis
4.0.0

Références ProviderInterface\getID().

◆ unregisterProvider()

unregisterProvider ( ProviderInterface $provider = null )

Unregister a provider from the ProviderManager. When no provider, or null is passed in, then all providers are cleared.

Paramètres
ProviderInterface | null $provider The provider to be unregistered
Renvoie
void
Depuis
4.0.6

Références null.

Documentation des champs

◆ $providers

$providers = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProviderManager.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Media
  • Administrator
  • View
  • File
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View to edit a file.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the toolbar buttons

Renvoie
void
Depuis
4.0.0

Références Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\save(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $input, Text\_(), Factory\getApplication(), ComponentHelper\getParams(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/View/File/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Media
  • Administrator
  • View
  • Media
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$providers = null
$currentPath
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Media List View

Depuis
4.0.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $link, Route\_(), Factory\getApplication(), CMSApplicationInterface\MSG_WARNING, et Text\sprintf().

◆ prepareToolbar()

prepareToolbar ( )
protected

Prepare the toolbar.

Renvoie
void
Depuis
4.0.0

Références $layout, $tmpl, $user, Text\_(), ToolbarHelper\divider(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $currentPath

$currentPath
protected

◆ $providers

$providers = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/src/View/Media/HtmlView.php


Joomla CMS: Référence de la classe AdaptersController

  • Joomla
  • Component
  • Media
  • Api
  • Controller
  • AdaptersController
Fonctions membres publiques | Attributs protégés
Référence de la classe AdaptersController
+ Graphe d'héritage de AdaptersController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($path='')
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'adapters'
$default_view = 'adapters'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Media web service controller.

Depuis
4.1.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $path = '' )

Display one specific adapter.

Paramètres
string $path The path of the file to display. Leave empty if you want to retrieve data from the request.
Renvoie
static A object to support chaining.
Exceptions
InvalidPathException

Documentation des champs

◆ $contentType

$contentType = 'adapters'
protected

◆ $default_view

$default_view = 'adapters'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdaptersController.php


Joomla CMS: Référence de la classe MediaController

  • Joomla
  • Component
  • Media
  • Api
  • Controller
  • MediaController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés statiques
Référence de la classe MediaController
+ Graphe d'héritage de MediaController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
displayItem ($path='')
add ()
edit ()
delete ($id=null)
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
allowDelete ()
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'media'
$default_view = 'media'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

setModelState (array $mappings)
checkContent ()

Attributs privés statiques

static | $listQueryModelStateMap
static | $itemQueryModelStateMap

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Media web service controller.

Depuis
4.1.0

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new file or folder.

Renvoie
void
Depuis
4.1.0
Exceptions
FileExistsException
InvalidPathException
InvalidParameterException

Références $content, $path, et Text\sprintf().

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if it's allowed to add a new file or folder

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.1.0

Références $user.

◆ allowDelete()

allowDelete ( )
protected

Method to check if it's allowed to delete an existing file or folder.

Renvoie
boolean
Depuis
4.1.0

Références $user.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if it's allowed to modify an existing file or folder.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.1.0

Références $user.

◆ checkContent()

checkContent ( )
private

Performs various checks to see if it is allowed to save the content.

Renvoie
void
Depuis
4.1.0
Exceptions

Références $helper, $params, Text\_(), et ComponentHelper\getParams().

◆ delete()

delete ( $id = null )

Method to delete an existing file or folder.

Renvoie
void
Depuis
4.1.0
Exceptions
InvalidPathException

Références $model, et Inflector\singularize().

◆ displayItem()

displayItem ( $path = '' )

Display one specific file or folder.

Paramètres
string $path The path of the file to display. Leave empty if you want to retrieve data from the request.
Renvoie
static A object to support chaining.
Depuis
4.1.0
Exceptions
InvalidPathException

Références $path.

◆ displayList()

displayList ( )

Display a list of files and/or folders.

Renvoie
static A object to support chaining.
Depuis
4.1.0
Exceptions

Références InputFilter\getInstance().

◆ edit()

edit ( )

Method to modify an existing file or folder.

Renvoie
void
Depuis
4.1.0
Exceptions
FileExistsException
InvalidPathException

Références $content, $path, $recordId, et Text\sprintf().

◆ setModelState()

setModelState ( array $mappings )
private

Set model state using a list of mappings between query parameters and model state names.

Paramètres
array $mappings A list of mappings between query parameters and model state names.
Renvoie
void
Depuis
4.1.0

Documentation des champs

◆ $contentType

$contentType = 'media'
protected

◆ $default_view

$default_view = 'media'
protected

◆ $itemQueryModelStateMap

$itemQueryModelStateMap
staticprivate
Valeur initiale :
= [
'path' => [
'name' => 'path'

◆ $listQueryModelStateMap

$listQueryModelStateMap
staticprivate
Valeur initiale :
= [
'path' => [
'name' => 'path'
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediaController.php


Joomla CMS: Référence de la classe AdapterModel

  • Joomla
  • Component
  • Media
  • Api
  • Model
  • AdapterModel
Fonctions membres publiques
Référence de la classe AdapterModel
+ Graphe d'héritage de AdapterModel:
BaseModel CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItem ()
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Media web service model supporting a single adapter item.

Depuis
4.1.0

Documentation des fonctions membres

◆ getItem()

getItem ( )

Method to get a single adapter.

Renvoie
The adapter.
Depuis
4.1.0

Références Joomla\Component\Media\Administrator\Provider\getAdapter(), Joomla\Component\Media\Administrator\Provider\getProvider(), Joomla\CMS\MVC\Model\getState(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AdapterModel.php


Joomla CMS: Référence de la classe AdaptersModel

  • Joomla
  • Component
  • Media
  • Api
  • Model
  • AdaptersModel
Fonctions membres publiques | Attributs privés
Référence de la classe AdaptersModel
+ Graphe d'héritage de AdaptersModel:
BaseModel ListModelInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
getPagination ()
getStart ()
getTotal ()
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Attributs privés

$total = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Media web service model supporting lists of media adapters.

Depuis
4.1.0

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of files and/or folders.

Renvoie
array An array of data items.
Depuis
4.1.0

Implémente ListModelInterface.

Références Joomla\Component\Media\Administrator\Provider\getProviderManager().

◆ getPagination()

getPagination ( )

Method to get a object for the data set.

Renvoie
Pagination A Pagination object for the data set.
Depuis
4.1.0

◆ getStart()

getStart ( )

Method to get the starting number of items for the data set. Because com_media's ApiModel does not support pagination as we know from regular ListModel derived models, we always start at the top.

Renvoie
integer The starting number of items available in the data set.
Depuis
4.1.0

◆ getTotal()

getTotal ( )

Method to get the total number of items for the data set.

Renvoie
integer The total number of items available in the data set.
Depuis
4.1.0

Références $total.

Documentation des champs

◆ $total

$total = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdaptersModel.php


Joomla CMS: Référence de la classe MediaModel

  • Joomla
  • Component
  • Media
  • Api
  • Model
  • MediaModel
Fonctions membres publiques | Attributs privés
Référence de la classe MediaModel
+ Graphe d'héritage de MediaModel:
BaseModel ListModelInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[])
getItems ()
getPagination ()
getStart ()
getTotal ()
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Attributs privés

$mediaApiModel
$total = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Media web service model supporting lists of media items.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of files and/or folders.

Renvoie
array An array of data items.
Depuis
4.1.0

A hacky way to enable the standard jsonapiView::displayList() to create a Pagination object. Because com_media's ApiModel does not support pagination as we know from regular ListModel derived models, we always return all retrieved items.

Implémente ListModelInterface.

Références $options, $path, Joomla\CMS\MVC\Model\getState(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), et Text\sprintf().

◆ getPagination()

getPagination ( )

Method to get a object for the data set.

Renvoie
Pagination A Pagination object for the data set.
Depuis
4.1.0

◆ getStart()

getStart ( )

Method to get the starting number of items for the data set. Because com_media's ApiModel does not support pagination as we know from regular ListModel derived models, we always start at the top.

Renvoie
int The starting number of items available in the data set.
Depuis
4.1.0

◆ getTotal()

getTotal ( )

Method to get the total number of items for the data set.

Renvoie
int The total number of items available in the data set.
Depuis
4.1.0

Références $total.

Documentation des champs

◆ $mediaApiModel

$mediaApiModel
private

◆ $total

$total = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_media/src/Model/MediaModel.php


Joomla CMS: Référence de la classe MediumModel

  • Joomla
  • Component
  • Media
  • Api
  • Model
  • MediumModel
Fonctions membres publiques | Attributs privés
Référence de la classe MediumModel
+ Graphe d'héritage de MediumModel:
BaseModel CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[])
getItem ()
save ($path=null)
delete ()
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Attributs privés

$mediaApiModel

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Media web service model supporting a single media item.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( )

Method to delete an existing file or folder.

Renvoie
void
Depuis
4.1.0
Exceptions
Save

Références $path, Joomla\CMS\MVC\Model\getState(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), et Text\sprintf().

◆ getItem()

getItem ( )

Method to get a single files or folder.

Renvoie
A file or folder object.
Depuis
4.1.0
Exceptions
ResourceNotFound

Références $options, $path, Joomla\CMS\MVC\Model\getState(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), et Text\sprintf().

◆ save()

save ( $path = null )

Method to save a file or folder.

Paramètres
string $path The primary key of the item (if exists)
Renvoie
string The path
Depuis
4.1.0
Exceptions
Save

If we have a (new) path and an old path, we want to move an existing file or folder. This must be done before updating the content of a file, if also requested (see below).

Références $content, $name, $path, Text\_(), Joomla\CMS\MVC\Model\getState(), null, Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), et Text\sprintf().

Documentation des champs

◆ $mediaApiModel

$mediaApiModel
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MediumModel.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Media
  • Api
  • View
  • Adapters
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Media web service view

Depuis
4.1.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'provider_id',
'name',
'path',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'provider_id',
'name',
'path',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_media/src/View/Adapters/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Media
  • Api
  • View
  • Media
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

Media web service view

Depuis
4.1.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.1.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'type',
'name',
'path',
'extension',
'size',
'mime_type',
'width',
'height',
'create_date',
'create_date_formatted',
'modified_date',
'modified_date_formatted',
'thumb_path',
'adapter',
'content',
'url',
'tempUrl',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'type',
'name',
'path',
'extension',
'size',
'mime_type',
'width',
'height',
'create_date',
'create_date_formatted',
'modified_date',
'modified_date_formatted',
'thumb_path',
'adapter',
'content',
'url',
'tempUrl',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_media/src/View/Media/JsonapiView.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Media
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_media

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Depuis
4.0.0
Renvoie
void

Références $user.

◆ getController()

getController | ( | string | $name,
 |  | string | $client = '',
 |  | array | $config = array()
 | ) |  |

Get a controller from the component

Paramètres
string | $name | Controller name
string | $client | Optional client (like Administrator, Site etc.)
array | $config | Optional controller config
Renvoie
BaseController
Depuis
4.0.0

Références $config, $name, et JPATH_ADMINISTRATOR.

◆ loadLanguage()

loadLanguage ( )
protected

Load the language

Depuis
4.0.0
Renvoie
void

Références JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_media/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AjaxController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • AjaxController
Fonctions membres publiques
Référence de la classe AjaxController
+ Graphe d'héritage de AjaxController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

fetchAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The menu controller for ajax requests

Depuis
3.9.0

Documentation des fonctions membres

◆ fetchAssociations()

fetchAssociations ( )

Method to fetch associations of a menu item

The method assumes that the following http parameters are passed in an Ajax Get request: token: the form token assocId: the id of the menu item whose associations are to be returned excludeLang: the association for this language is to be excluded

Renvoie
null
Depuis
3.9.0

Références $lang, $message, Text\_(), Table\addIncludePath(), Session\checkToken(), elseif, Associations\getAssociations(), Table\getInstance(), JPATH_ADMINISTRATOR, null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_menus/src/Controller/AjaxController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'menus'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base controller class for Menu Manager.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
static This object to support chaining.
Depuis
1.5

Références $menuType, $uri, Route\_(), Uri\getInstance(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'menus'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe ItemController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • ItemController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ItemController
+ Graphe d'héritage de ItemController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

add ()
cancel ($key=null)
edit ($key=null, $urlVar=null)
setType ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getMenuTypeId ($menutype)
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Menu ItemModel Controller

Depuis
1.6

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new menu item.

Renvoie
mixed True if the record can be added, otherwise false.
Depuis
1.6

Références $context, $result, et null.

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Extended classes can override this if necessary.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
3.6

Références $data, $menuType, et $user.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you edit a record.

Extended classes can override this if necessary.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key; default is id.
Renvoie
boolean
Depuis
3.6

Références $data, $item, $key, $model, et $user.

◆ cancel()

cancel ( $key = null )

Method to cancel an edit.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
1.6

Références $context, $result, Route\_(), Joomla\Application\checkToken(), false, et null.

◆ edit()

edit | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to edit an existing record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if access level check and checkout passes, false otherwise.
Depuis
1.6

Références $result, et null.

◆ getMenuTypeId()

getMenuTypeId ( $menutype )
protected

Loads the menutype ID by a given menutype string

Paramètres
string $menutype The given menutype
Renvoie
integer
Depuis
3.6

Références $menutype, et $model.

◆ setType()

setType ( )

Sets the type of the menu item currently being edited.

Renvoie
void
Depuis
1.6

Références $app, $component, $data, $recordId, $title, $type, Route\_(), Uri\buildQuery(), Joomla\Application\checkToken(), elseif, ComponentHelper\getComponent(), InputFilter\getInstance(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ItemController.php


Joomla CMS: Référence de la classe ItemsController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • ItemsController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ItemsController
+ Graphe d'héritage de ItemsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Item', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
setDefault ()
publish ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Menu Item Controller

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
1.6

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Item',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the number of published frontend menu items for quickicons

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

◆ publish()

publish ( )

Method to publish a list of items

Renvoie
void
Depuis
3.6.0

Références $data, $model, $task, $value, Text\_(), Route\_(), Log\add(), Joomla\Application\checkToken(), elseif, false, ArrayHelper\getValue(), Text\plural(), et Log\WARNING.

◆ setDefault()

setDefault ( )

Method to set the home property for a list of items

Renvoie
void
Depuis
1.6

Références $app, $data, $model, $task, $value, Text\_(), Route\_(), Joomla\Application\checkToken(), false, ArrayHelper\getValue(), et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/Controller/ItemsController.php


Joomla CMS: Référence de la classe MenuController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • MenuController
Fonctions membres publiques
Référence de la classe MenuController
+ Graphe d'héritage de MenuController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
exportXml ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Menu Type Controller

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Dummy method to redirect back to standard controller

Paramètres
boolean | $cachable | If true, the view output will be cached.
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnvoid@since1.5

Références Route\_().

◆ exportXml()

exportXml ( )

Method to display a menu as preset xml.

Renvoie
boolean True if successful, false otherwise.
Depuis
3.8.0

Références $id, $item, $model, Text\_(), Route\_(), et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuController.php


Joomla CMS: Référence de la classe MenusController

  • Joomla
  • Component
  • Menus
  • Administrator
  • Controller
  • MenusController
Fonctions membres publiques
Référence de la classe MenusController
+ Graphe d'héritage de MenusController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
getModel ($name='Menu', $prefix='Administrator', $config=array('ignore_request'=> true))
resync ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Menu List Controller

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Display the view

Paramètres
boolean | $cachable | If true, the view output will be cached.
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnvoid@since1.6

◆ getModel()

getModel | ( | $name = 'Menu',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ resync()

resync ( )

Temporary method. This should go into the 1.5 to 1.6 upgrade routines.

Renvoie
void
Depuis
1.6
Obsolète:
5.0 Will be removed without replacement as it was only used for the 1.5 to 1.6 upgrade

Références $db, $item, $itemId, $items, $option, $parts, $query, Factory\getDbo(), ParameterType\INTEGER, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/Controller/MenusController.php


Joomla CMS: Référence de la classe MenusComponent

  • Joomla
  • Component
  • Menus
  • Administrator
  • Extension
  • MenusComponent
Fonctions membres publiques
Référence de la classe MenusComponent
+ Graphe d'héritage de MenusComponent:
MVCComponent BootableExtensionInterface AssociationServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de AssociationServiceInterface
getAssociationsExtension ()

Description détaillée

Component class for com_menus

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenusComponent.php


Joomla CMS: Référence de la classe MenuField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • Modal
  • MenuField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MenuField
+ Graphe d'héritage de MenuField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Menu'
$allowSelect = true
$allowClear = true
$allowNew = false
$allowEdit = false
$allowPropagate = false
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal menu item picker.

Depuis
3.7.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.7.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.7.0

Références $name, et $value.

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.7.0

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
3.7.0

Références $return, $value, et Factory\getApplication().

Documentation des champs

◆ $allowClear

$allowClear = true
protected

◆ $allowEdit

$allowEdit = false
protected

◆ $allowNew

$allowNew = false
protected

◆ $allowPropagate

$allowPropagate = false
protected

◆ $allowSelect

$allowSelect = true
protected

◆ $type

$type = 'Modal_Menu'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/Field/Modal/MenuField.php


Joomla CMS: Référence de la classe MenuItemByTypeField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • MenuItemByTypeField
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe MenuItemByTypeField
+ Graphe d'héritage de MenuItemByTypeField:
GroupedlistField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Champs de données

$type = 'MenuItemByType'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
- Fonctions membres protégées hérités de GroupedlistField
getGroups ()
getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$menuType
$clientId
$language
$published
$disable
- Attributs protégés hérités de GroupedlistField
$type = 'Groupedlist'
$layout = 'joomla.form.field.groupedlist'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML grouped select list of menu item grouped by menu

Depuis
3.8.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.8.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.8.0

Références $name, et $value.

◆ getGroups()

getGroups ( )
protected

Method to get the field option groups.

Renvoie
array The field option objects as a nested array in groups.
Depuis
3.8.0

Références $db, $groups, $items, $key, $lang, $link, $menu, $menuType, $query, $this, HTMLHelper\_(), Joomla\Database\getDatabase(), MenusHelper\getMenuLinks(), et language.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
::setup()
Depuis
3.8.0

Références $app, $menuType, $result, $value, Factory\getApplication(), et language.

Documentation des champs

◆ $clientId

$clientId
protected

◆ $disable

$disable
protected

◆ $language

$language
protected

◆ $menuType

$menuType
protected

◆ $published

$published
protected

◆ $type

$type = 'MenuItemByType'
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuItemByTypeField.php


Joomla CMS: Référence de la classe MenuOrderingField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • MenuOrderingField
Fonctions membres protégées | Attributs protégés
Référence de la classe MenuOrderingField
+ Graphe d'héritage de MenuOrderingField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
getInput ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'MenuOrdering'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Menu Ordering field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.7

Références Text\_(), et Joomla\Application\getInput().

◆ getOptions()

getOptions ( )
protected

Method to get the list of siblings in a menu. The method requires that parent be set.

Renvoie
array|boolean The field option objects or false if the parent field has not been set
Depuis
1.7

Références $db, $menuType, $option, $options, $query, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

Documentation des champs

◆ $type

$type = 'MenuOrdering'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuOrderingField.php


Joomla CMS: Référence de la classe MenuParentField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • MenuParentField
Fonctions membres protégées | Attributs protégés
Référence de la classe MenuParentField
+ Graphe d'héritage de MenuParentField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'MenuParent'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Menu Parent field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références $clientId, $db, $i, $id, $menuType, $n, $options, $query, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), ParameterType\INTEGER, level, et text.

Documentation des champs

◆ $type

$type = 'MenuParent'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuParentField.php


Joomla CMS: Référence de la classe MenuPresetField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • MenuPresetField
Fonctions membres protégées | Attributs protégés
Référence de la classe MenuPresetField
+ Graphe d'héritage de MenuPresetField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'MenuPreset'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Administrator Menu Presets list field.

Depuis
3.8.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.8.0

Références $options, Text\_(), HTMLHelper\_(), et MenusHelper\getPresets().

Documentation des champs

◆ $type

$type = 'MenuPreset'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuPresetField.php


Joomla CMS: Référence de la classe MenutypeField

  • Joomla
  • Component
  • Menus
  • Administrator
  • Field
  • MenutypeField
Fonctions membres protégées | Attributs protégés
Référence de la classe MenutypeField
+ Graphe d'héritage de MenutypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'menutype'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Menu Type field.

Depuis
1.6

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
1.6

Références $class, $clientId, $html, $link, $model, $recordId, $required, $size, $value, Text\_(), Route\_(), HTMLHelper\_(), ENT_COMPAT, Factory\getApplication(), MenusHelper\getLinkKey(), ArrayHelper\getValue(), name, null, et value.

Documentation des champs

◆ $type

$type = 'menutype'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenutypeField.php


Joomla CMS: Référence de la classe AssociationsHelper

  • Joomla
  • Component
  • Menus
  • Administrator
  • Helper
  • AssociationsHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe AssociationsHelper
+ Graphe d'héritage de AssociationsHelper:
AssociationExtensionHelper AssociationExtensionInterface

Fonctions membres publiques

getAssociationsForItem ($id=0, $view=null)
getAssociations ($typeName, $id)
getItem ($typeName, $id)
getType ($typeName='')
- Fonctions membres publiques hérités de AssociationExtensionHelper
hasAssociationsSupport ()
getItemTypes ()
getAssociationList ($typeName, $itemId)
getType ($typeName='')
getTypeFields ($typeName)
getTypeSupport ($typeName)
getTypeTables ($typeName)
getTypeJoins ($typeName)
getTypeTitle ($typeName)
getTypeFieldName ($typeName, $fieldName)

Attributs protégés

$extension = 'com_menus'
$itemTypes = array('item')
$associationsSupport = true
- Attributs protégés hérités de AssociationExtensionHelper
$extension = 'com_??'
$itemTypes = array()
$associationsSupport = false

Membres hérités additionnels

- Fonctions membres protégées hérités de AssociationExtensionHelper
getSupportTemplate ()
getFieldsTemplate ()

Description détaillée

Menu associations helper.

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociations()

getAssociations | ( | $typeName,
 |  | $id
 | ) |

Get the associated items for an item

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $context, $id, $type, extension, et Associations\getAssociations().

◆ getAssociationsForItem()

getAssociationsForItem | ( | $id = 0,
 |  | $view = null
 | ) |

Method to get the associations for a given item.

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
4.0.0

Implémente AssociationExtensionInterface.

◆ getItem()

getItem | ( | $typeName,
 |  | $id
 | ) |

Get item information

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
Table|null
Depuis
3.7.0

Références $id, Table\getInstance(), et null.

◆ getType()

getType ( $typeName = '' )

Get information about the type

Paramètres
string $typeName The item type
Renvoie
array Array of item types
Depuis
3.7.0

Références $fields, et $title.

Documentation des champs

◆ $associationsSupport

boolean $associationsSupport = true
protected

Has the extension association support

Depuis
3.7.0

◆ $extension

array $extension = 'com_menus'
protected

The extension name

Depuis
3.7.0

◆ $itemTypes

array $itemTypes = array('item')
protected

Array of item types

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_menus/src/Helper/AssociationsHelper.php


Joomla CMS: Référence de la classe MenusHelper

  • Joomla
  • Component
  • Menus
  • Administrator
  • Helper
  • MenusHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe MenusHelper
+ Graphe d'héritage de MenusHelper:
ContentHelper MenusHelper

Fonctions membres publiques statiques

static | getLinkKey ($request)
static | getMenuTypes ($clientId=0)
static | getMenuLinks ($menuType=null, $parentId=0, $mode=0, $published=array(), $languages=array(), $clientId=0)
static | getAssociations ($pk)
static | getMenuItems ($menutype, $enabledOnly=false, $exclude=array())
static | installPreset ($preset, $menutype)
static | addPreset ($name, $title, $path, $replace=true)
static | getPresets ()
static | loadPreset ($name, $fallback=true, $parent=null)
static | resolveAlias (&$item)
static | preprocess ($item)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Fonctions membres protégées statiques

static | loadXml ($elements, $parent, $replace=array())
static | parseXmlNode ($node, $replace=array())

Attributs protégés statiques

static | $_filter = array('option', 'view', 'layout')
static | $presets = null

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Menus component helper.

Depuis
1.6

Documentation des fonctions membres

◆ addPreset()

static addPreset | ( | $name,
 |  | $title,
 |  | $path,
 |  | $replace = true
 | ) |
static

Add a custom preset externally via plugin or any other means. WARNING: Presets with same name will replace previously added preset except Joomla's default preset (joomla)

Paramètres
string | $name | The unique identifier for the preset.
string | $title | The display label for the preset.
string | $path | The path to the preset file.
bool | $replace | Whether to replace the preset with the same name if any (except 'joomla').
Renvoie
void
Depuis
4.0.0

Références $name, $path, $title, et null.

◆ getAssociations()

static getAssociations ( $pk )
static

Get the associations

Paramètres
integer $pk Menu item id
Renvoie
array
Depuis
3.0

Références Associations\getAssociations().

Référencé par Menus\association(), ItemModel\getItem(), LanguagesHelper\getList(), PlgSystemLanguageFilter\onAfterDispatch(), et PlgSystemLanguageFilter\onUserLogin().

◆ getLinkKey()

static getLinkKey ( $request )
static

Gets a standard form of a link for lookups.

Paramètres
mixed $request A link string or array of request variables.
Renvoie
mixed A link in standard option-view-layout form, or false if the supplied response is invalid.
Depuis
1.6

Références $name, et $value.

Référencé par MenutypesModel\addReverseLookupUrl(), MenutypeField\getInput(), et ItemModel\getItem().

◆ getMenuItems()

static getMenuItems | ( | $menutype,
 |  | $enabledOnly = false,
 |  | $exclude = array()
 | ) |
static

Load the menu items from database for the given menutype

Paramètres
string | $menutype | The selected menu type
boolean | $enabledOnly | Whether to load only enabled/published menu items.
int[] | $exclude The menu items to exclude from the list
Renvoie
AdministratorMenuItem A root node with the menu items as children
Depuis
4.0.0

Références $db, $item, $menutype, $query, $root, Text\_(), class, Factory\getApplication(), Factory\getContainer(), null, et ParameterType\STRING.

Référencé par XmlView\display(), CssMenu\load(), Menu\preprocess(), et CssMenu\preprocess().

◆ getMenuLinks()

static getMenuLinks | ( | $menuType = null,
 |  | $parentId = 0,
 |  | $mode = 0,
 |  | $published = array(),
 |  | $languages = array(),
 |  | $clientId = 0
 | ) |
static

Get a list of menu links for one or all menus.

Paramètres
string | $menuType | An option menu to filter the list on, otherwise all menu with given client id links are returned as a grouped array.
integer | $parentId | An optional parent ID to pivot results around.
integer | $mode | An optional mode. If parent ID is set and mode=2, the parent and children are excluded from the list.
array | $published | An optional array of states
array | $languages | Optional array of specify which languages we want to filter
int | $clientId | Optional client id - viz 0 = site, 1 = administrator, can be NULL for all (used only if menutype not given)
Renvoie
array|boolean
Depuis
1.6

Références $clientId, $db, $languages, $link, $menuType, $menuTypes, $mode, $published, $query, $type, elseif, Factory\getApplication(), Factory\getDbo(), ParameterType\INTEGER, Multilanguage\isEnabled(), null, et ParameterType\STRING.

Référencé par MenuitemField\getGroups(), et MenuItemByTypeField\getGroups().

◆ getMenuTypes()

static getMenuTypes ( $clientId = 0 )
static

Get the menu list for create a menu module

Paramètres
int $clientId Optional client id - viz 0 = site, 1 = administrator, can be NULL for all
Renvoie
array The menu array list
Depuis
1.6

Références $clientId, $db, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ getPresets()

static getPresets ( )
static

Get a list of available presets.

Renvoie
[]
Depuis
4.0.0

Références $app, $component, $folder, $lang, $name, $title, Folder\exists(), Folder\files(), Factory\getApplication(), ComponentHelper\getComponents(), JPATH_ADMINISTRATOR, JPATH_THEMES, null, et File\stripExt().

Référencé par MenuPresetField\getOptions().

◆ installPreset()

static installPreset | ( | $preset,
 |  | $menutype
 | ) |
static

Method to install a preset menu into database and link them to the given menutype

Paramètres
string | $preset | The preset name
string | $menutype | The target menutype
Renvoie
void
Exceptions

Références $menutype, $root, et Text\_().

◆ loadPreset()

static loadPreset | ( | $name,
 |  | $fallback = true,
 |  | $parent = null
 | ) |
static

Load the menu items from a preset file into a hierarchical list of objects

Paramètres
string | $name | The preset name
bool | $fallback | Fallback to default (joomla) preset if the specified one could not be loaded?
AdministratorMenuItem | $parent | Root node of the menu
Renvoie
AdministratorMenuItem
Depuis
4.0.0

Références $name, $xml, elseif, null, et path.

Référencé par CssMenu\load().

◆ loadXml()

static loadXml | ( | $elements,
 |  | $parent,
 |  | $replace = array()
 | ) |
staticprotected

Load a menu tree from an XML file

Paramètres

Following is a repeatable group based on simple database query. This requires sql_* attributes (sql_select and sql_from are required) The values can be used like - "{sql:columnName}" in any attribute of repeated elements. The repeated elements are place inside this xml node but they will be populated in the same level in the rendered menu

Références $db, $item, $query, $result, $results, et Factory\getDbo().

◆ parseXmlNode()

static parseXmlNode | ( | $node,
 |  | $replace = array()
 | ) |
staticprotected

Create a menu item node from an xml element

Paramètres
\SimpleXMLElement | $node | A menuitem element from preset xml
string[] | $replace The values to substitute in the title, link and element texts
Renvoie
Depuis
4.0.0

Références $item, $params, $val, et null.

◆ preprocess()

static preprocess ( $item )
static

Parse the flat list of menu items and prepare the hierarchy of them using parent-child relationship.

Paramètres
AdministratorMenuItem $item Menu item to preprocess
Renvoie
void
Depuis
4.0.0

Références $item, et null.

◆ resolveAlias()

static resolveAlias ( & $item )
static

Method to resolve the menu item alias type menu item

Paramètres
AdministratorMenuItem &$item The alias object
Renvoie
void
Depuis
4.0.0

Références $db, $item, $query, Factory\getDbo(), et ParameterType\INTEGER.

Documentation des champs

◆ $_filter

$_filter = array('option', 'view', 'layout')
staticprotected

◆ $presets

$presets = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenusHelper.php


Joomla CMS: Référence de la classe ItemModel

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
  • ItemModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ItemModel
+ Graphe d'héritage de ItemModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getHelp ()
getItem ($pk=null)
getModules ()
getViewLevels ()
getTable ($type='Menu', $prefix='Administrator', $config=array())
rebuild ()
save ($data)
saveorder ($idArray=null, $lftArray=null)
setHome (&$pks, $value=1)
publish (&$pks, $value=1)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_menus.item'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
batchCopy ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
canSave ($data=array(), $key='id')
loadFormData ()
getReorderConditions ($table)
populateState ()
getMenuType ($menutype)
getMenuTypeId ($menutype)
preprocessForm (Form $form, $data, $group='content')
generateNewTitle ($parentId, $alias, $title)
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$associationsContext = 'com_menus.item'
$text_prefix = 'COM_MENUS_ITEM'
$helpKey = 'Menu_Item:_New_Item'
$helpURL
$helpLocal = false
$batch_copymove = 'menu_id'
$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Menu Item Model for Menus.

Depuis
1.6

Documentation des fonctions membres

◆ batchCopy()

batchCopy | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch copy menu items to a new menu or parent.

Paramètres
integer | $value | The new menu or sub-item.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
mixed An array of new IDs on success, boolean false on failure.
Depuis
1.6

Références $count, $db, $menuType, $parts, $query, $title, $user, $value, Text\_(), Joomla\Database\getDatabase(), Factory\getUser(), ArrayHelper\getValue(), ParameterType\INTEGER, null, et Text\sprintf().

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move menu items to a new menu or parent.

Paramètres
integer | $value | The new menu or sub-item.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True on success.
Depuis
1.6

Références $db, $menuType, $parts, $query, $user, $value, Text\_(), Joomla\Database\getDatabase(), Factory\getUser(), ArrayHelper\getValue(), ParameterType\INTEGER, Text\sprintf(), et ArrayHelper\toInteger().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether the state of a record can be edited.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission for the component.
Depuis
3.6

Références Factory\getUser().

◆ canSave()

canSave | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can save a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean the cache

Paramètres
string | $group | Cache group name.
integer | $clientId

◆ generateNewTitle()

generateNewTitle | ( | $parentId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title & alias.

Paramètres
integer | $parentId | The id of the parent.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
1.6

Références $title, et StringHelper\increment().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
mixed A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $clientId, $data, $form, $item, Joomla\CMS\MVC\Model\getState(), ArrayHelper\getValue(), Joomla\CMS\MVC\Model\loadForm(), Joomla\CMS\MVC\Model\loadFormData(), et Joomla\CMS\MVC\Model\setState().

◆ getHelp()

getHelp ( )

Get the necessary data to load an item help screen.

Renvoie
object An object with key, url, and local properties for loading the item help screen.
Depuis
1.6

◆ getItem()

getItem ( $pk = null )

Method to get a menu item.

Paramètres
integer $pk An optional id of the object to get, otherwise the id from the model state is used.
Renvoie
mixed Menu item data object on success, false on failure.
Depuis
1.6

Références $component, $lang, $link, $result, $this, $type, MenusHelper\getAssociations(), ComponentHelper\getComponent(), Factory\getLanguage(), MenusHelper\getLinkKey(), Joomla\CMS\MVC\Model\getState(), Associations\isEnabled(), JPATH_ADMINISTRATOR, null, Joomla\CMS\MVC\Model\setState(), et ArrayHelper\toObject().

◆ getMenuType()

getMenuType ( $menutype )
protected

Loads the menutype object by a given menutype string

Paramètres
string $menutype The given menutype
Renvoie
Depuis
3.7.0

Références $menutype.

◆ getMenuTypeId()

getMenuTypeId ( $menutype )
protected

Loads the menutype ID by a given menutype string

Paramètres
string $menutype The given menutype
Renvoie
integer
Depuis
3.6

Références $menu, et $menutype.

◆ getModules()

getModules ( )

Get the list of modules not in trash.

Renvoie
mixed An array of module records (id, title, position), or false on error.
Depuis
1.6

Join on the module-to-menu mapping table. We are only interested if the module is displayed on ALL or THIS menu item (or the inverse ID number). sqlsrv changes for modulelink to menu manager

Références $clientId, $db, $id, $query, $result, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get the where clause for the reorder. This ensures that the row will be moved relative to a row with the same menutype.

Paramètres
\Joomla\CMS\Table\Menu $table
Renvoie
array An array of conditions to add to add to ordering queries.
Depuis
1.6

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Menu',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Returns a Table object, always creating it

Paramètres
string | $type | The table type to instantiate.
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
| A database object.
Depuis
1.6

Références $config, $prefix, et $type.

◆ getViewLevels()

getViewLevels ( )

Get the list of all view levels

Renvoie
[]|boolean An array of all view levels (id, title).
Depuis
3.4

Références $db, $query, $result, et Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, $filters, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), null, Joomla\CMS\MVC\Model\preprocessData(), et Joomla\CMS\MVC\Model\setState().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Note: a new menu item will have no field type. The field is required so the user has to change it.

Références $app, $clientId, $link, $menuType, $params, $type, Factory\getApplication(), ComponentHelper\getParams(), null, et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import.
Renvoie
void
Depuis
1.6
Exceptions

Références $base, $clientId, $data, $field, $fields, $form, $helpURL, $language, $languages, $layout, $link, $option, $path, $templatePath, $type, $view, $xml, Text\_(), Path\clean(), elseif, Path\find(), ApplicationHelper\getClientInfo(), Joomla\CMS\MVC\Model\getState(), Associations\isEnabled(), JPATH_ADMINISTRATOR, null, et Joomla\CMS\MVC\Model\preprocessForm().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | $pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
1.6

Références $i, $value, Text\_(), et Factory\getApplication().

◆ rebuild()

rebuild ( )

Method rebuild the entire nested set tree.

Renvoie
boolean Boolean true on success, boolean false
Depuis
1.6

Références $db, $id, $item, $items, $params, $query, Factory\getApplication(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $base, $context, $data, $db, $id, $key, $menuType, $name, $option, $query, $result, $this, $title, Text\_(), Uri\base(), elseif, Factory\getApplication(), Joomla\Database\getDatabase(), Uri\getInstance(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), ParameterType\INTEGER, Associations\isEnabled(), null, Joomla\CMS\MVC\Model\setState(), ParameterType\STRING, et ArrayHelper\toInteger().

◆ saveorder()

saveorder | ( | $idArray = null,
 |  | $lftArray = null
 | ) |

Method to save the reordered nested set tree. First we save the new order values in the lft values of the changed ids. Then we invoke the table rebuild to implement the new ordering.

Paramètres
array | $idArray | Rows identifiers to be reordered
array | $lftArray | lft values of rows to be reordered
Renvoie
boolean false on failure or error, true otherwise.
Depuis
1.6

◆ setHome()

setHome | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the home state of one or more items.

Paramètres
array | $pks | A list of the primary keys to change.
integer | $value | The value of the home state.
Renvoie
boolean True on success.
Depuis
1.6

Références $i, $languages, $value, Text\_(), elseif, Factory\getApplication(), et Text\sprintf().

Documentation des champs

◆ $associationsContext

$associationsContext = 'com_menus.item'
protected

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage'
)

◆ $batch_copymove

$batch_copymove = 'menu_id'
protected

◆ $helpKey

$helpKey = 'Menu_Item:_New_Item'
protected

◆ $helpLocal

$helpLocal = false
protected

◆ $helpURL

$helpURL
protected

◆ $text_prefix

$text_prefix = 'COM_MENUS_ITEM'
protected

◆ $typeAlias

$typeAlias = 'com_menus.item'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/Model/ItemModel.php


Joomla CMS: Référence de la classe ItemsModel

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
  • ItemsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ItemsModel
+ Graphe d'héritage de ItemsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
preprocessForm (Form $form, $data, $group='content')
getMenu ($menuType, $check=false)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Menu Item List Model for Menus.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, Symfony\Contracts\Service\__construct(), et Associations\isEnabled().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.0.1

Implémente ListModelInterface.

Références $client, $extension, $item, $items, $lang, Text\_(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ getListQuery()

getListQuery ( )
protected

Builds an SQL query to load the list data.

Renvoie
A query object.
Depuis
1.6

Références $clientId, $db, $groups, $language, $menuType, $menuTypes, $published, $query, $this, $type, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, et Associations\isEnabled().

◆ getMenu()

getMenu | ( | $menuType,
 |  | $check = false
 | ) |
protected

Get the client id for a menu

Paramètres
string | $menuType | The menutype identifier for the menu
boolean | $check | Flag whether to perform check against ACL as well as existence
Renvoie
integer
Depuis
3.7.0

Références $check, $db, $menuType, $query, Text\_(), Log\add(), elseif, Log\ERROR, Joomla\Database\getDatabase(), et Factory\getUser().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $clientId, $direction, $language, $layout, $menuType, $ordering, $params, $published, elseif, Factory\getApplication(), Factory\getLanguage(), ComponentHelper\getParams(), JPATH_ADMINISTRATOR, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
3.2
Exceptions

Références $clientId, $form, $name, elseif, Joomla\CMS\MVC\Model\getState(), et Form\setFieldAttribute().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ItemsModel.php


Joomla CMS: Référence de la classe MenuModel

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
  • MenuModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MenuModel
+ Graphe d'héritage de MenuModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($type='MenuType', $prefix='\JTable', $config=array())
& getItem ($itemId=null)
getForm ($data=array(), $loadData=true)
validate ($form, $data, $group=null)
save ($data)
delete ($itemIds)
& getModules ()
getExtensionElementsForMenuItems (array $itemIds)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
populateState ()
loadFormData ()
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_MENUS_MENU'
$_context = 'com_menus.menu'
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Menu Item Model for Menus.

Depuis
1.6

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether the state of a record can be edited.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean the cache

Paramètres
string | $group | Cache group name.
integer | $clientId

◆ delete()

delete ( $itemIds )

Method to delete groups.

Paramètres
array $itemIds An array of item ids.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6

Références $itemId, $itemIds, $result, Factory\getApplication(), PluginHelper\importPlugin(), et ArrayHelper\toInteger().

◆ getExtensionElementsForMenuItems()

getExtensionElementsForMenuItems ( array $itemIds )

Returns the extension elements for the given items

Paramètres
array $itemIds The item ids
Renvoie
array
Depuis
4.2.0

Références $db, $itemIds, $query, Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the menu item form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

& getItem ( $itemId = null )

Method to get a menu item.

Paramètres
integer $itemId The id of the menu item to get.
Renvoie
mixed Menu item data object on success, false on failure.
Depuis
1.6

Références $itemId, $return, $value, class, Joomla\CMS\MVC\Model\getState(), et ArrayHelper\toObject().

◆ getModules()

& getModules ( )

Gets a list of all mod_mainmenu modules and collates them by menutype

Renvoie
array
Depuis
1.6

Références $db, $menuType, $module, $modules, $params, $query, $result, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'MenuType',
 |  | $prefix = '\JTable',
 |  | $config = array()
 | ) |

Returns a Table object, always creating it

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object
Depuis
1.6

Références $config, $prefix, $type, et Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $clientId, $id, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $data, $id, $result, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), et Joomla\CMS\MVC\Model\setState().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFormRule
JFilterInput
Depuis
3.9.23

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $_context

$_context = 'com_menus.menu'
protected

◆ $text_prefix

$text_prefix = 'COM_MENUS_MENU'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuModel.php


Joomla CMS: Référence de la classe MenusModel

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
  • MenusModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MenusModel
+ Graphe d'héritage de MenusModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
getModMenuId ()
& getModules ()
getMissingModuleLanguages ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
populateState ($ordering='a.title', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Menu List Model for Menus.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Overrides the getItems method to attach additional metrics to the list.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6.1

Implémente ListModelInterface.

Références $db, $item, $items, $menuTypes, $published, $query, Joomla\Database\getDatabase(), ParameterType\INTEGER, et ParameterType\STRING.

◆ getListQuery()

getListQuery ( )
protected

Method to build an SQL query to load the list data.

Renvoie
string An SQL query
Depuis
1.6

Références $clientId, $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getMissingModuleLanguages()

getMissingModuleLanguages ( )

Returns the missing module languages.

Renvoie
array
Depuis
_DEPLOY_VERSION__

Références $db, $language, $languages, $query, Joomla\Database\getDatabase(), et ModuleHelper\isAdminMultilang().

◆ getModMenuId()

getModMenuId ( )

Gets the extension id of the core mod_menu module.

Renvoie
integer
Depuis
2.5

Références $clientId, $db, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getModules()

& getModules ( )

Gets a list of all mod_mainmenu modules and collates them by menutype

Renvoie
array
Depuis
1.6

Références $model, et $result.

◆ populateState()

populateState | ( | $ordering = 'a.title',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $clientId, $direction, $ordering, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenusModel.php


Joomla CMS: Référence de la classe MenutypesModel

  • Joomla
  • Component
  • Menus
  • Administrator
  • Model
  • MenutypesModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe MenutypesModel
+ Graphe d'héritage de MenutypesModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getReverseLookup ()
getTypeOptions ()
addReverseLookupUrl ($option)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
getTypeOptionsByComponent ($component)
getTypeOptionsFromXml ($file, $component)
getTypeOptionsFromMvc ($component)
getTypeOptionsFromManifest ($component)
getTypeOptionsFromLayouts ($component, $view)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$rlu = array()
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getFolders ($component)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Menu Item Types Model for Menus.

Depuis
1.6

Documentation des fonctions membres

◆ addReverseLookupUrl()

addReverseLookupUrl ( $option )

Method to create the reverse lookup for link-to-name. (can be used from onAfterGetMenuTypeOptions handlers)

Paramètres
CMSObject $option Object with request array or string and title public variables
Renvoie
void
Depuis
3.1

Références $option, et MenusHelper\getLinkKey().

◆ getFolders()

getFolders ( $component )
private

Get the folders with template files for the given component.

Paramètres
string $component Component option as in URLs
Renvoie
array
Depuis
4.0.0

Références $client, $component, Folder\folders(), ApplicationHelper\getClientInfo(), et Joomla\CMS\MVC\Model\getState().

◆ getReverseLookup()

getReverseLookup ( )

Method to get the reverse lookup of the base link URL to Title

Renvoie
array Array of reverse lookup of the base link URL to Title
Depuis
1.6

◆ getTypeOptions()

getTypeOptions ( )

Method to get the available menu item type options.

Renvoie
array Array of groups with menu item types.
Depuis
1.6

Références $component, $db, $lang, $list, $option, $options, $query, $this, Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), et JPATH_ADMINISTRATOR.

◆ getTypeOptionsByComponent()

getTypeOptionsByComponent ( $component )
protected

Get menu types by component.

Paramètres
string $component Component URL option.
Renvoie
array
Depuis
1.6

Références $client, $component, $options, ApplicationHelper\getClientInfo(), et Joomla\CMS\MVC\Model\getState().

◆ getTypeOptionsFromLayouts()

getTypeOptionsFromLayouts | ( | $component,
 |  | $view
 | ) |
protected

Get the menu types from component layouts

Paramètres
string | $component | Component option as in URLs
string | $view | Name of the view
Renvoie
array
Depuis
1.6

Références $client, $component, $folder, $lang, $layout, $menu, $options, $path, $template, $view, $xml, Folder\files(), Folder\folders(), ApplicationHelper\getClientInfo(), Factory\getLanguage(), et Joomla\CMS\MVC\Model\getState().

◆ getTypeOptionsFromManifest()

getTypeOptionsFromManifest ( $component )
protected

Get menu types from Component manifest

Paramètres
string $component Component option like in URLs
Renvoie
array|boolean
Depuis
3.7.0

Références $attributes, $component, $manifest, $options, JPATH_ADMINISTRATOR, et null.

◆ getTypeOptionsFromMvc()

getTypeOptionsFromMvc ( $component )
protected

Get menu types from MVC

Paramètres
string $component Component option like in URLs
Renvoie
array|boolean
Depuis
1.6

Références $component, $menu, $options, $path, $view, $xml, elseif, et Folder\folders().

◆ getTypeOptionsFromXml()

getTypeOptionsFromXml | ( | $file,
 |  | $component
 | ) |
protected

Get the menu types from an XML file

Paramètres
string | $file | File path
string | $component | Component option as in URL
Renvoie
array|boolean
Depuis
1.6

Références $component, $menu, $options, $xml, et elseif.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Renvoie
void
Note
Calling getState in this method will result in recursion.
Depuis
3.0.1

Références $clientId, Factory\getApplication(), et Joomla\CMS\MVC\Model\populateState().

Documentation des champs

◆ $rlu

$rlu = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenutypesModel.php


Joomla CMS: Référence de la classe Menus

  • Joomla
  • Component
  • Menus
  • Administrator
  • Service
  • HTML
  • Menus
Fonctions membres publiques
Référence de la classe Menus

Fonctions membres publiques

association ($itemid)
visibility ($params)

Documentation des fonctions membres

◆ association()

association ( $itemid )

Generate the markup to display the item associations

Paramètres
int $itemid The menu item id
Renvoie
string
Depuis
3.0
Exceptions

Références $classes, $content_languages, $db, $html, $item, $itemid, $items, $languages, $query, $text, $tooltip, $url, Route\_(), ENT_QUOTES, Factory\getApplication(), MenusHelper\getAssociations(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), et Text\sprintf().

◆ visibility()

visibility ( $params )

Returns a visibility state on a grid

Paramètres
integer $params Params of item.
Renvoie
string The Html code
Depuis
3.7.0

Références $params, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Menus.php


Joomla CMS: Référence de la classe MenuTable

  • Joomla
  • Component
  • Menus
  • Administrator
  • Table
  • MenuTable
Fonctions membres publiques
Référence de la classe MenuTable
+ Graphe d'héritage de MenuTable:
Menu Nested Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

delete ($pk=null, $children=false)
check ()
- Fonctions membres publiques hérités de Menu
__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
store ($updateNulls=true)
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Menu
$_supportNullValue = true
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Menu table

Depuis
1.6

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success, false on failure
Voir également
JTable::check
Depuis
4.0.0

Implémente TableInterface.

Références $return, Text\_(), et null.

◆ delete()

delete | ( | $pk = null,
 |  | $children = false
 | ) |

Method to delete a node and, optionally, its child nodes from the table.

Paramètres
integer | $pk | The primary key of the node to delete.
boolean | $children | True to delete child nodes, false to move them up a level.
Renvoie
boolean True on success.
Depuis
2.5

Références $db, $query, $return, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuTable.php


Joomla CMS: Référence de la classe MenuTypeTable

  • Joomla
  • Component
  • Menus
  • Administrator
  • Table
  • MenuTypeTable
Référence de la classe MenuTypeTable
+ Graphe d'héritage de MenuTypeTable:
MenuType Table CMSObject TableInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de MenuType
__construct (DatabaseDriver $db)
check ()
store ($updateNulls=false)
delete ($pk=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de MenuType
_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Menu table

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuTypeTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Item
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$modules
$state
$canDo
$levels
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The HTML Menus Menu Item View.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $clientId, $input, $lang, $url, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\divider(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), ToolbarHelper\help(), ComponentHelper\isEnabled(), Associations\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références Text\_(), ContentHelper\getActions(), Factory\getApplication(), et null.

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $levels

$levels
protected

◆ $modules

$modules
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/View/Item/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Items
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$f_levels
$items
$pagination
$state
$ordering
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The HTML Menus Menu Items View.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, $user, Text\_(), ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références $base, $item, $lang, $layout, $options, $result, $temp, $this, $value, $view, $xml, Text\_(), HTMLHelper\_(), Factory\getApplication(), Factory\getLanguage(), Multilanguage\isEnabled(), items, JPATH_ADMINISTRATOR, JPATH_SITE, null, et Text\sprintf().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $f_levels

$f_levels
protected

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $ordering

$ordering
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/View/Items/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menu
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The HTML Menus Menu Item View.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $input, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références ContentHelper\getActions().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/View/Menu/HtmlView.php


Joomla CMS: Référence de la classe XmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menu
  • XmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe XmlView
+ Graphe d'héritage de XmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addXmlChild ($xml, $item)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The HTML Menus Menu Item View.

Depuis
3.8.0

Documentation des fonctions membres

◆ addXmlChild()

addXmlChild | ( | $xml,
 |  | $item
 | ) |
protected

Add a child node to the xml

Paramètres
\SimpleXMLElement | $xml | The current XML node which would become the parent to the new node
\stdClass | $item | The menuitem object to create the child XML node from
Renvoie
void
Depuis
3.8.0

Références $item, et $xml.

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.8.0

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.
Depuis
3.9.0
Exceptions

Implémente ViewInterface.

Références $app, $item, $menutype, $root, $xml, Text\_(), Route\_(), Log\add(), Log\ERROR, Factory\getApplication(), MenusHelper\getMenuItems(), items, et Log\WARNING.

Documentation des champs

◆ $items

$items
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_menus/src/View/Menu/XmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menus
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$modules
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

The HTML Menus Menu Menus View.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $modules

$modules
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/View/Menus/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Menus
  • Administrator
  • View
  • Menutypes
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
addCustomTypes (&$types)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$recordId
$types
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The HTML Menus Menu Item Types View.

Depuis
1.6

Documentation des fonctions membres

◆ addCustomTypes()

addCustomTypes ( & $types )
protected

Method to add system link types to the link types array

Paramètres
array $types The list of link types
Renvoie
void
Depuis
3.7.0

Références $list, et null.

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.0

Références $title, Text\_(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références $app, $item, $list, $name, $tmp, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $recordId

$recordId
protected

◆ $types

$types
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/src/View/Menutypes/HtmlView.php


Joomla CMS: Référence de la classe ItemsController

  • Joomla
  • Component
  • Menus
  • Api
  • Controller
  • ItemsController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe ItemsController
+ Graphe d'héritage de ItemsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
add ()
edit ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'items'
$default_view = 'items'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getClientIdFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The items controller

Depuis
4.0.0

Documentation des fonctions membres

◆ add()

add ( )

Method to add a new record.

Renvoie
void
Depuis
4.0.0
Exceptions
NotAllowed

Références $data.

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ edit()

edit ( )

Method to edit an existing record.

Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $data.

◆ getClientIdFromInput()

getClientIdFromInput ( )
private

Get client id from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'items'
protected

◆ $default_view

$default_view = 'items'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_menus/src/Controller/ItemsController.php


Joomla CMS: Référence de la classe MenusController

  • Joomla
  • Component
  • Menus
  • Api
  • Controller
  • MenusController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe MenusController
+ Graphe d'héritage de MenusController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'menus'
$default_view = 'menus'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getClientIdFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The menus controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getClientIdFromInput()

getClientIdFromInput ( )
private

Get client id from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'menus'
protected

◆ $default_view

$default_view = 'menus'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_menus/src/Controller/MenusController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Menus
  • Api
  • View
  • Items
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The items view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_menus/src/View/Items/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Menus
  • Api
  • View
  • Menus
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The menus view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'menutype',
'title',
'description',
'client_id',
'count_published',
'count_unpublished',
'count_trashed',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'asset_id',
'menutype',
'title',
'description',
'client_id',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_menus/src/View/Menus/JsonapiView.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Menus
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

checkAccess ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_menus

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

◆ getController()

getController | ( | string | $name,
 |  | string | $client = '',
 |  | array | $config = array()
 | ) |  |

Get a controller from the component

Paramètres
string | $name | Controller name
string | $client | Optional client (like Administrator, Site etc.)
array | $config | Optional controller config
Renvoie
Depuis
4.0.0

Références $client, $config, et $name.

◆ loadLanguage()

loadLanguage ( )
protected

Load the language

Depuis
4.0.0
Renvoie
void

Références JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_menus/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ConfigController

  • Joomla
  • Component
  • Messages
  • Administrator
  • Controller
  • ConfigController
Fonctions membres publiques
Référence de la classe ConfigController
+ Graphe d'héritage de ConfigController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

save ()
cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Messages Component Message Model

Depuis
1.6

Documentation des fonctions membres

◆ cancel()

cancel ( )

Cancel operation.

Renvoie
void
Depuis
4.0.0

Références Route\_().

◆ save()

save ( )

Method to save a record.

Renvoie
boolean
Depuis
1.6

Références $data, $form, $i, $model, $n, Text\_(), Route\_(), Joomla\Application\checkToken(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/Controller/ConfigController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Messages
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'messages'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Messages master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached.
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'messages'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe MessageController

  • Joomla
  • Component
  • Messages
  • Administrator
  • Controller
  • MessageController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MessageController
+ Graphe d'héritage de MessageController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

reply ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowSave ($data, $key='message_id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Messages Component Message Model

Depuis
1.6

Documentation des fonctions membres

◆ allowSave()

allowSave | ( | $data,
 |  | $key = 'message_id'
 | ) |
protected

Method (override) to check if you can save a new or existing record.

Adjusts for the primary key name and hands off to the parent class.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, et $key.

◆ reply()

reply ( )

Reply to an existing message.

This is a simple redirect to the compose form.

Renvoie
void
Depuis
1.6

Références Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_messages/src/Controller/MessageController.php


Joomla CMS: Référence de la classe MessagesController

  • Joomla
  • Component
  • Messages
  • Administrator
  • Controller
  • MessagesController
Fonctions membres publiques
Référence de la classe MessagesController
+ Graphe d'héritage de MessagesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Message', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Messages list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Message',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/Controller/MessagesController.php


Joomla CMS: Référence de la classe MessagesComponent

  • Joomla
  • Component
  • Messages
  • Administrator
  • Extension
  • MessagesComponent
Fonctions membres publiques
Référence de la classe MessagesComponent
+ Graphe d'héritage de MessagesComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_messages

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessagesComponent.php


Joomla CMS: Référence de la classe MessageStatesField

  • Joomla
  • Component
  • Messages
  • Administrator
  • Field
  • MessageStatesField
Fonctions membres protégées | Attributs protégés
Référence de la classe MessageStatesField
+ Graphe d'héritage de MessageStatesField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'MessageStates'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Message States field.

Depuis
3.6.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.6.0

Références MessagesHelper\getStateOptions().

Documentation des champs

◆ $type

$type = 'MessageStates'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MessageStatesField.php


Joomla CMS: Référence de la classe UserMessagesField

  • Joomla
  • Component
  • Messages
  • Administrator
  • Field
  • UserMessagesField
Champs de données | Fonctions membres protégées
Référence de la classe UserMessagesField
+ Graphe d'héritage de UserMessagesField:
UserField FormField DatabaseAwareInterface

Champs de données

$type = 'UserMessages'
- Champs de données hérités de UserField
$type = 'User'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getGroups ()
getExcluded ()
- Fonctions membres protégées hérités de UserField
getInput ()
getGroups ()
getExcluded ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de UserField
setup (\SimpleXMLElement $element, $value, $group=null)
getLayoutData ()
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de UserField
$groups = null
$excluded = null
$layout = 'joomla.form.field.user'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal select of users that have access to com_messages

Depuis
1.6

Documentation des fonctions membres

◆ getExcluded()

getExcluded ( )
protected

Method to get the users to exclude from the list of users

Renvoie
array|null array of users to exclude or null to to not exclude them
Depuis
1.6

Références Factory\getUser().

◆ getGroups()

getGroups ( )
protected

Method to get the filtering groups (null means no filtering)

Renvoie
array|null array of filtering groups or null.
Depuis
1.6

Références $db, $groups, $i, $query, Access\checkGroup(), Factory\getApplication(), Joomla\Database\getDatabase(), et null.

Documentation des champs

◆ $type

$type = 'UserMessages'
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserMessagesField.php


Joomla CMS: Référence de la classe MessagesHelper

  • Joomla
  • Component
  • Messages
  • Administrator
  • Helper
  • MessagesHelper
Fonctions membres publiques statiques
Référence de la classe MessagesHelper

Fonctions membres publiques statiques

static getStateOptions ()

Description détaillée

Messages helper class.

Depuis
1.6

Documentation des fonctions membres

◆ getStateOptions()

static getStateOptions ( )
static

Get a list of filter options for the state of a module.

Renvoie
array An array of elements.
Depuis
1.6

Références $options, Text\_(), et HTMLHelper\_().

Référencé par MessageStatesField\getOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessagesHelper.php


Joomla CMS: Référence de la classe ConfigModel

  • Joomla
  • Component
  • Messages
  • Administrator
  • Model
  • ConfigModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ConfigModel
+ Graphe d'héritage de ConfigModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

& getItem ()
getForm ($data=array(), $loadData=true)
save ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Message configuration model.

Depuis
1.6

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

& getItem ( )

Method to get a single record.

Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $db, $item, $query, $rows, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $params, $user, ComponentHelper\getParams(), Factory\getUser(), et Joomla\CMS\MVC\Model\setState().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $data, $db, $query, $userId, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et ParameterType\STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/Model/ConfigModel.php


Joomla CMS: Référence de la classe MessageModel

  • Joomla
  • Component
  • Messages
  • Administrator
  • Model
  • MessageModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe MessageModel
+ Graphe d'héritage de MessageModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

delete (&$pks)
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
publish (&$pks, $value=1)
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
loadFormData ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$item
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Private Message model.

Depuis
1.6

Documentation des fonctions membres

◆ delete()

delete ( & $pks )

Check that recipient user is the one trying to delete and then call parent delete method

Paramètres
array &$pks An array of record primary keys.
Renvoie
boolean True if successful, false if an error occurs.
Depuis
3.1

Références $i, $user, Text\_(), Log\add(), Factory\getApplication(), Factory\getUser(), et Log\WARNING.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $db, $item, $message, $query, Text\_(), elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et ParameterType\INTEGER.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $input, $user, Factory\getApplication(), Factory\getUser(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Checks that the current user matches the message recipient and calls the parent publish method

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
3.1

Références $i, $user, $value, Text\_(), Log\add(), Factory\getApplication(), Factory\getUser(), et Log\WARNING.

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $app, $config, $data, $key, $lang, $message, $model, $sitename, $subject, Text\_(), Log\add(), ENT_COMPAT, Factory\getApplication(), Factory\getDate(), User\getInstance(), Language\getInstance(), ComponentHelper\getParams(), Factory\getUser(), JPATH_ADMINISTRATOR, Route\link(), Joomla\CMS\MVC\Model\setState(), Route\TLS_FORCE, Route\TLS_IGNORE, et Log\WARNING.

Documentation des champs

◆ $item

$item
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MessageModel.php


Joomla CMS: Référence de la classe MessagesModel

  • Joomla
  • Component
  • Messages
  • Administrator
  • Model
  • MessagesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MessagesModel
+ Graphe d'héritage de MessagesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
purge (int $userId)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.date_time', $direction='desc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Messages Component Messages Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $db, $id, $query, $state, $this, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.date_time',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, et Joomla\CMS\MVC\Model\populateState().

◆ purge()

purge ( int $userId )

Purge the messages table of old messages for the given user ID.

Paramètres
int $userId The user id
Renvoie
void
Depuis
4.2.0

Références $config, $db, $query, $userId, Joomla\Database\getDatabase(), Factory\getDate(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_messages/src/Model/MessagesModel.php


Joomla CMS: Référence de la classe Messages

  • Joomla
  • Component
  • Messages
  • Administrator
  • Service
  • HTML
  • Messages
Fonctions membres publiques
Référence de la classe Messages

Fonctions membres publiques

status ($i, $value=0, $canChange=false)

Description détaillée

JHtml administrator messages class.

Depuis
1.6

Documentation des fonctions membres

◆ status()

status | ( | $i,
 |  | $value = 0,
 |  | $canChange = false
 | ) |

Get the HTML code of the state switcher

Paramètres
int | $i | Row number
int | $value | The state value
boolean | $canChange | Can the user change the state?
Renvoie
string
Depuis
3.4

Références $canChange, $html, $i, $icon, $state, $value, et ArrayHelper\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Messages.php


Joomla CMS: Référence de la classe MessageTable

  • Joomla
  • Component
  • Messages
  • Administrator
  • Table
  • MessageTable
Fonctions membres publiques
Référence de la classe MessageTable
+ Graphe d'héritage de MessageTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Message Table class

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database connector object
Depuis
1.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Validation and filtering.

Renvoie
boolean
Depuis
1.5

Implémente TableInterface.

Références $user, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MessageTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Config
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit messages user configuration.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), Factory\getApplication(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/View/Config/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Message
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Messages component

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $app, Text\_(), ToolbarHelper\cancel(), ToolbarHelper\custom(), Factory\getApplication(), User\getInstance(), ToolbarHelper\help(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références Text\_(), et elseif.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/View/Message/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Messages
  • Administrator
  • View
  • Messages
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of messages.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $state, $toolbar, $user, Text\_(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_messages/src/View/Messages/HtmlView.php


Joomla CMS: Référence de la classe MessagesController

  • Joomla
  • Component
  • Messages
  • Api
  • Controller
  • MessagesController
Attributs protégés
Référence de la classe MessagesController
+ Graphe d'héritage de MessagesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'messages'
$default_view = 'messages'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The messages controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'messages'
protected

◆ $default_view

$default_view = 'messages'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_messages/src/Controller/MessagesController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Messages
  • Api
  • View
  • Messages
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The messages view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'user_id_from',
'user_id_to',
'date_time',
'priority',
'subject',
'message',
'state',
'user_from',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'user_id_from',
'user_id_to',
'date_time',
'priority',
'subject',
'message',
'state',
'user_from',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_messages/src/View/Messages/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Modules
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'modules'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Modules manager master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean()@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $clientId, $id, $layout, $uri, Route\_(), Uri\getInstance(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'modules'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe ModuleController

  • Joomla
  • Component
  • Modules
  • Administrator
  • Controller
  • ModuleController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ModuleController
+ Graphe d'héritage de ModuleController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

add ()
cancel ($key=null)
batch ($model=null)
save ($key=null, $urlVar=null)
orderPosition ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowSave ($data, $key='id')
allowEdit ($data=array(), $key='id')
postSaveHook (BaseDatabaseModel $model, $validData=array())
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Module controller class.

Depuis
1.6

Documentation des fonctions membres

◆ add()

add ( )

Override parent add method.

Renvoie
|void True if the record can be added, a object if not.
Depuis
1.6

Références $app, $params, $result, Text\_(), Route\_(), et null.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method override to check if you can edit an existing record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
3.2

Références $data, $key, et $recordId.

◆ allowSave()

allowSave | ( | $data,
 |  | $key = 'id'
 | ) |
protected

Override parent allowSave method.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, et $key.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
string $model The model
Renvoie
boolean True on success.
Depuis
1.7

Références $model, Route\_(), et Joomla\Application\checkToken().

◆ cancel()

cancel ( $key = null )

Override parent cancel method to reset the add module state.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
1.6

Références $result, $return, Uri\base(), Uri\isInternal(), et null.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et $recordId.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append.

◆ orderPosition()

orderPosition ( )

Method to get the other modules in the same position

Renvoie
string The data for the Ajax request.
Depuis
3.6.3

Références $app, $clientId, $db, $html, $i, $moduleId, $n, $position, $query, $title, Text\_(), Session\checkToken(), ENT_QUOTES, Factory\getDbo(), ParameterType\INTEGER, et Text\sprintf().

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
1.6

Références $model, $task, et null.

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to save a record.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key
Renvoie
boolean True if successful, false otherwise.

Références $data, $item, $key, $model, Form\addFormPath(), Joomla\Application\checkToken(), et JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleController.php


Joomla CMS: Référence de la classe ModulesController

  • Joomla
  • Component
  • Modules
  • Administrator
  • Controller
  • ModulesController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ModulesController
+ Graphe d'héritage de ModulesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

duplicate ()
getModel ($name='Module', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Modules list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ duplicate()

duplicate ( )

Method to clone an existing module.

Renvoie
void
Depuis
1.6

Références $model, Text\_(), Joomla\Application\checkToken(), et Text\plural().

◆ getModel()

getModel | ( | $name = 'Module',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the number of frontend modules

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/Controller/ModulesController.php


Joomla CMS: Référence de la classe ModulesComponent

  • Joomla
  • Component
  • Modules
  • Administrator
  • Extension
  • ModulesComponent
Fonctions membres publiques
Référence de la classe ModulesComponent
+ Graphe d'héritage de ModulesComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_modules

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulesComponent.php


Joomla CMS: Référence de la classe ModulesModuleField

  • Joomla
  • Component
  • Modules
  • Administrator
  • Field
  • ModulesModuleField
Fonctions membres publiques | Attributs protégés
Référence de la classe ModulesModuleField
+ Graphe d'héritage de ModulesModuleField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'ModulesModule'
$client
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Modules Module field.

Depuis
3.4.2

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
4.0.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.4.2

Références $clientId, $options, et ModulesHelper\getModules().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
4.0.0

Références $result, et $value.

Documentation des champs

◆ $client

$client
protected

◆ $type

$type = 'ModulesModule'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulesModuleField.php


Joomla CMS: Référence de la classe ModulesPositioneditField

  • Joomla
  • Component
  • Modules
  • Administrator
  • Field
  • ModulesPositioneditField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ModulesPositioneditField
+ Graphe d'héritage de ModulesPositioneditField:
FormField DatabaseAwareInterface

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ModulesPositionedit'
$layout = 'joomla.form.field.modulespositionedit'
$client
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Edit Modules Position field.

Depuis
4.0.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
4.0.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
4.0.0

Références $clientId, $data, $positions, $renderer, HTMLHelper\_(), et value.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
4.0.0

Références $result, et $value.

Documentation des champs

◆ $client

$client
protected

◆ $layout

$layout = 'joomla.form.field.modulespositionedit'
protected

◆ $type

$type = 'ModulesPositionedit'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulesPositioneditField.php


Joomla CMS: Référence de la classe ModulesPositionField

  • Joomla
  • Component
  • Modules
  • Administrator
  • Field
  • ModulesPositionField
Fonctions membres publiques | Attributs protégés
Référence de la classe ModulesPositionField
+ Graphe d'héritage de ModulesPositionField:
ListField FormField DatabaseAwareInterface ModulesPositionField

Fonctions membres publiques

__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'ModulesPosition'
$client
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Modules Position field.

Depuis
3.4.2

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
4.0.0

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
4.0.0

Références $name, et $value.

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.4.2

Références $clientId, $options, et ModulesHelper\getPositions().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
4.0.0

Références $result, et $value.

Documentation des champs

◆ $client

$client
protected

◆ $type

$type = 'ModulesPosition'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_modules/src/Field/ModulesPositionField.php


Joomla CMS: Référence de la classe ModulesHelper

  • Joomla
  • Component
  • Modules
  • Administrator
  • Helper
  • ModulesHelper
Fonctions membres publiques statiques
Référence de la classe ModulesHelper
+ Graphe d'héritage de ModulesHelper:
ModulesHelper

Fonctions membres publiques statiques

static | getStateOptions ()
static | getClientOptions ()
static | getPositions ($clientId, $editPositions=false)
static | getTemplates ($clientId=0, $state='', $template='')
static | getModules ($clientId)
static | getAssignmentOptions ($clientId)
static | getTranslatedModulePosition ($clientId, $template, $position)
static | isTranslatedText ($langKey, $text)
static | createOption ($value='', $text='')
static | createOptionGroup ($label='', $options=array())

Description détaillée

Modules component helper.

Depuis
1.6

Documentation des fonctions membres

◆ createOption()

static createOption | ( | $value = '',
 |  | $text = ''
 | ) |
static

Create and return a new Option

Paramètres
string | $value | The option value [optional]
string | $text | The option text [optional]
Renvoie
object The option as an object ( instance)
Depuis
3.0

Références $option, $text, et $value.

Référencé par Modules\positions().

◆ createOptionGroup()

static createOptionGroup | ( | $label = '',
 |  | $options = array()
 | ) |
static

Create and return a new Option Group

Paramètres
string | $label | Value and label for group [optional]
array | $options | Array of options to insert into group [optional]
Renvoie
array Return the new group as an array
Depuis
3.0

Références $label, et $options.

Référencé par Modules\positions().

◆ getAssignmentOptions()

static getAssignmentOptions ( $clientId )
static

Get a list of the assignment options for modules to menus.

Paramètres
int $clientId The client id.
Renvoie
array

Références $clientId, $options, et HTMLHelper\_().

◆ getClientOptions()

static getClientOptions ( )
static

Get a list of filter options for the application clients.

Renvoie
array An array of elements.

Références $options, Text\_(), et HTMLHelper\_().

◆ getModules()

static getModules ( $clientId )
static

Get a list of the unique modules installed in the client application.

Paramètres
int $clientId The client id.
Renvoie
array Array of unique modules

Références $clientId, $db, $extension, $i, $lang, $module, $modules, $path, $query, Text\_(), Factory\getDbo(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_SITE, et ArrayHelper\sortObjects().

Référencé par ModulesModuleField\getOptions().

◆ getPositions()

static getPositions | ( | $clientId,
 |  | $editPositions = false
 | ) |
static

Get a list of modules positions

Paramètres
integer | $clientId | Client ID
boolean | $editPositions | Allow to edit the positions
Renvoie
array A list of positions

Références $clientId, $db, $options, $position, $positions, $query, Text\_(), HTMLHelper\_(), elseif, Factory\getApplication(), Factory\getDbo(), et ParameterType\INTEGER.

Référencé par ModulesPositionField\getOptions(), et Modules\positions().

◆ getStateOptions()

static getStateOptions ( )
static

Get a list of filter options for the state of a module.

Renvoie
array An array of elements.

Références $options, Text\_(), et HTMLHelper\_().

◆ getTemplates()

static getTemplates | ( | $clientId = 0,
 |  | $state = '',
 |  | $template = ''
 | ) |
static

Return a list of templates

Paramètres
integer | $clientId | Client ID
string | $state | State
string | $template | Template name
Renvoie
array List of templates

Références $clientId, $db, $query, $state, $template, Factory\getDbo(), et ParameterType\INTEGER.

Référencé par PositionsModel\getItems(), Modules\positions(), ModuleModel\preprocessForm(), et Modules\templates().

◆ getTranslatedModulePosition()

static getTranslatedModulePosition | ( | $clientId,
 |  | $template,
 |  | $position
 | ) |
static

Return a translated module position name

Paramètres
integer | $clientId | Application client id 0: site | 1: admin
string | $template | Template name
string | $position | Position name
Renvoie
string Return a translated position name
Depuis
3.0

Références $clientId, $lang, $path, $position, $template, $text, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_SITE, et null.

Référencé par Modules\positions().

◆ isTranslatedText()

static isTranslatedText | ( | $langKey,
 |  | $text
 | ) |
static

Check if the string was translated

Paramètres
string | $langKey | Language file text key
string | $text | The "translated" text to be checked
Renvoie
boolean Return true for translated text
Depuis
3.0

Références $text.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ModulesHelper.php


Joomla CMS: Référence de la classe ModuleModel

  • Joomla
  • Component
  • Modules
  • Administrator
  • Model
  • ModuleModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe ModuleModel
+ Graphe d'héritage de ModuleModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
delete (&$pks)
duplicate (&$pks)
& getClient ()
getForm ($data=array(), $loadData=true)
getItem ($pk=null)
getHelp ()
getTable ($type='Module', $prefix='JTable', $config=array())
validate ($form, $data, $group=null)
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_modules.module'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

populateState ()
batchCopy ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
canEditState ($record)
generateNewTitle ($categoryId, $title, $position)
loadFormData ()
prepareTable ($table)
preprocessForm (Form $form, $data, $group='content')
getReorderConditions ($table)
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_MODULES'
$helpKey = ''
$helpURL
$batch_copymove = 'position_id'
$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Module model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ batchCopy()

batchCopy | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch copy modules to a new position or current.

Paramètres
integer | $value | The new value matching a module position.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
2.5

Références $data, $db, $i, $menu, $position, $query, $user, $value, Text\_(), elseif, Joomla\Database\getDatabase(), Factory\getUser(), et ParameterType\INTEGER.

◆ batchMove()

batchMove | ( | $value,
 |  | $pks,
 |  | $contexts
 | ) |
protected

Batch move modules to a new position or current.

Paramètres
integer | $value | The new value matching a module position.
array | $pks | An array of row IDs.
array | $contexts | An array of item contexts.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
2.5

Références $position, $user, $value, Text\_(), elseif, et Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state edited.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
3.2

Références Factory\getUser().

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method for different clients

Paramètres
string | $group | The name of the plugin group to import (defaults to null).
integer | $clientId

◆ delete()

delete ( & $pks )

Method to delete rows.

Paramètres
array &$pks An array of item ids.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6
Exceptions

Références $app, $context, $db, $name, $query, $result, $user, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), PluginHelper\importPlugin(), et ParameterType\INTEGER.

◆ duplicate()

duplicate ( & $pks )

Method to duplicate modules.

Paramètres
array &$pks An array of primary key IDs.
Renvoie
boolean Boolean true on success
Depuis
1.6
Exceptions

Références $data, $db, $query, $rows, $user, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, et null.

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $title,
 |  | $position
 | ) |
protected

Method to change the title.

Paramètres
integer | $categoryId | The id of the category. Not used here.
string | $title | The title.
string | $position | The position.
Renvoie
array Contains the modified title.
Depuis
2.5

Références $position, $title, et StringHelper\increment().

◆ getClient()

& getClient ( )

Method to get the client object

Renvoie
void
Depuis
1.6

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Check for existing module Modify the form based on Edit State access controls.

Implémente FormModelInterface.

Références $clientId, $data, $form, $id, $item, $module, $user, Form\addFieldPath(), Factory\getUser(), ArrayHelper\getValue(), ModuleHelper\isAdminMultilang(), JPATH_ADMINISTRATOR, JPATH_SITE, Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getHelp()

getHelp ( )

Get the necessary data to load an item help screen.

Renvoie
object An object with key, url, and local properties for loading the item help screen.
Depuis
1.6

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $client, $db, $extension, $path, $query, $return, Route\_(), class, Path\clean(), elseif, Factory\getApplication(), ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, null, et ArrayHelper\toObject().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Module',
 |  | $prefix = 'JTable',
 |  | $config = array()
 | ) |

Returns a reference to the a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object
Depuis
1.6

Références $config, $prefix, $type, et Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $clientId, $data, $filters, $params, Factory\getApplication(), null, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table prior to saving.

Paramètres
Table $table The database object
Renvoie
void
Depuis
1.6

Références ENT_QUOTES.

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $client, $clientId, $data, $form, $helpURL, $lang, $module, $template, $xml, Text\_(), Form\addFormPath(), Path\clean(), Folder\files(), ApplicationHelper\getClientInfo(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), ModulesHelper\getTemplates(), JPATH_ADMINISTRATOR, JPATH_SITE, et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $context, $data, $db, $input, $name, $query, $result, $this, elseif, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), PluginHelper\importPlugin(), StringHelper\increment(), ParameterType\INTEGER, et Joomla\CMS\MVC\Model\setState().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Loads ContentHelper for filters before validating data.

Paramètres
object | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the group(defaults to null).
Renvoie
mixed Array of filtered data if valid, false otherwise.
Depuis
1.1

Références $data, $form, et Factory\getUser().

Documentation des champs

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage',
)

◆ $batch_copymove

$batch_copymove = 'position_id'
protected

◆ $helpKey

$helpKey = ''
protected

◆ $helpURL

$helpURL
protected

◆ $text_prefix

$text_prefix = 'COM_MODULES'
protected

◆ $typeAlias

$typeAlias = 'com_modules.module'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ModuleModel.php


Joomla CMS: Référence de la classe ModulesModel

  • Joomla
  • Component
  • Modules
  • Administrator
  • Model
  • ModulesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ModulesModel
+ Graphe d'héritage de ModulesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.position', $direction='asc')
getStoreId ($id='')
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
getListQuery ()
getEmptyStateQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Modules Component Module Model

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Returns an object list

Paramètres
DatabaseQuery | $query | The query
int | $limitstart | Offset
int | $limit | The number of records
Renvoie
array

Références $db, $limit, $listDirn, $listOrder, $query, $result, $total, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), null, Joomla\CMS\MVC\Model\setState(), et ArrayHelper\sortObjects().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $clientId, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery

Références $clientId, $db, $groups, $language, $module, $position, $query, $state, $user, elseif, Joomla\Database\getDatabase(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, ParameterType\STRING, et StringHelper\strtolower().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.position',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $clientId, $direction, $layout, $ordering, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ translate()

translate ( & $items )
protected

Translate a list of objects

Paramètres
array &$items The array of objects
Renvoie
array The array of translated objects

Références $extension, $item, $items, $lang, Text\_(), elseif, Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), JPATH_ADMINISTRATOR, et JPATH_SITE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/Model/ModulesModel.php


Joomla CMS: Référence de la classe PositionsModel

  • Joomla
  • Component
  • Modules
  • Administrator
  • Model
  • PositionsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PositionsModel
+ Graphe d'héritage de PositionsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getItems ()
getTotal ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='ordering', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Modules Component Positions Model

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6

Implémente ListModelInterface.

Références $client, $clientId, $db, $direction, $items, $label, $lang, $limit, $ordering, $path, $position, $positions, $query, $state, $template, $type, $value, $xml, Path\clean(), elseif, ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), ModulesHelper\getTemplates(), ParameterType\INTEGER, items, null, et Joomla\CMS\MVC\Model\setState().

◆ getTotal()

getTotal ( )

Method to get the total number of items.

Renvoie
integer The total number of items.
Depuis
1.6

Références $total.

◆ populateState()

populateState | ( | $ordering = 'ordering',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $clientId, $direction, $ordering, $params, $state, $template, $type, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PositionsModel.php


Joomla CMS: Référence de la classe SelectModel

  • Joomla
  • Component
  • Modules
  • Administrator
  • Model
  • SelectModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe SelectModel
+ Graphe d'héritage de SelectModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Module model.

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of items.

Renvoie
mixed An array of objects on success, false on failure.

Implémente ListModelInterface.

Références $client, $item, $items, $lang, $path, $text, Text\_(), Path\clean(), ApplicationHelper\getClientInfo(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), null, et ArrayHelper\sortObjects().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie

Références $clientId, $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $clientId, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_modules/src/Model/SelectModel.php


Joomla CMS: Référence de la classe Modules

  • Joomla
  • Component
  • Modules
  • Administrator
  • Service
  • HTML
  • Modules
Fonctions membres publiques
Référence de la classe Modules

Fonctions membres publiques

templates ($clientId=0, $state='')
types ()
templateStates ()
state ($value, $i, $enabled=true, $checkbox='cb')
positions ($clientId, $state=1, $selectedPosition='')
batchOptions ()
positionList ($clientId=0)

Description détaillée

HTMLHelper module helper class.

Depuis
1.6

Documentation des fonctions membres

◆ batchOptions()

batchOptions ( )

Get a select with the batch action options

Renvoie
void

Références $options, Text\_(), et HTMLHelper\_().

◆ positionList()

positionList ( $clientId = 0 )

Method to get the field options.

Paramètres
integer $clientId The client ID
Renvoie
array The field option objects.
Depuis
2.5
Obsolète:
5.0 Will be removed with no replacement

Références $clientId, $db, $options, $query, Factory\getApplication(), Factory\getDbo(), ParameterType\INTEGER, et text.

◆ positions()

positions | ( | $clientId,
 |  | $state = 1,
 |  | $selectedPosition = ''
 | ) |

Display a batch widget for the module position selector.

Paramètres
integer | $clientId | The client ID.
integer | $state | The state of the module (enabled, unenabled, trashed).
string | $selectedPosition | The currently selected position for the module.
Renvoie
string The necessary positions for the widget.
Depuis
2.5

Références $app, $clientId, $option, $options, $position, $positions, $state, $template, $text, Text\_(), HTMLHelper\_(), ModulesHelper\createOption(), ModulesHelper\createOptionGroup(), Factory\getApplication(), ModulesHelper\getPositions(), TemplatesHelper\getPositions(), ModulesHelper\getTemplates(), ModulesHelper\getTranslatedModulePosition(), et ArrayHelper\sortObjects().

◆ state()

state | ( | $value,
 |  | $i,
 |  | $enabled = true,
 |  | $checkbox = 'cb'
 | ) |

Returns a published state on a grid

Paramètres
integer | $value | The state value.
integer | $i | The row index
boolean | $enabled | An optional setting for access control on the action.
string | $checkbox | An optional prefix for checkboxes.
Renvoie
string The Html code
Voir également
HTMLHelperJGrid::state
Depuis
1.7.1

Références $enabled, $i, $value, et HTMLHelper\_().

◆ templates()

templates | ( | $clientId = 0,
 |  | $state = ''
 | ) |

Builds an array of template options

Paramètres
integer | $clientId | The client id.
string | $state | The state of the template.
Renvoie
array

Références $clientId, $options, $state, $template, HTMLHelper\_(), et ModulesHelper\getTemplates().

◆ templateStates()

templateStates ( )

Builds an array of template state options

Renvoie
array

Références $options, et HTMLHelper\_().

◆ types()

types ( )

Builds an array of template type options

Renvoie
array

Références $options, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Modules.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Module
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a module.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $lang, $url, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Factory\getLanguage(), ToolbarHelper\help(), ToolbarHelper\inlinehelp(), null, ToolbarHelper\saveGroup(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références ContentHelper\getActions().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/View/Module/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Modules
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of modules.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $state, $toolbar, $user, Text\_(), ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

The code below make sure the remembered position will be available from filter dropdown even if there are no modules available for this position. This will make the UI less confusing for users in case there is only one module in the selected position and user:

  1. Edit the module, change it to new position, save it and come back to Modules Management Screen
  2. Or move that module to new position using Batch action

Implémente ViewInterface.

Références $option, Factory\getApplication(), ModuleHelper\isAdminMultilang(), Multilanguage\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/View/Modules/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Modules
  • Administrator
  • View
  • Select
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$modalLink
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Modules component

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $clientId, $layout, $state, Text\_(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références items, et modalLink.

Documentation des champs

◆ $items

$items
protected

◆ $modalLink

$modalLink
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/src/View/Select/HtmlView.php


Joomla CMS: Référence de la classe ModulesController

  • Joomla
  • Component
  • Modules
  • Api
  • Controller
  • ModulesController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe ModulesController
+ Graphe d'héritage de ModulesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'modules'
$default_view = 'modules'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getClientIdFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The modules controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getClientIdFromInput()

getClientIdFromInput ( )
private

Get client id from input

Renvoie
string
Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'modules'
protected

◆ $default_view

$default_view = 'modules'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_modules/src/Controller/ModulesController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Modules
  • Api
  • View
  • Modules
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The modules view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'typeAlias',
'asset_id',
'title',
'note',
'content',
'ordering',
'position',
'checked_out',
'checked_out_time',
'publish_up',
'publish_down',
'published',
'module',
'access',
'showtitle',
'params',
'client_id',
'language',
'assigned',
'assignment',
'xml',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'title',
'note',
'position',
'module',
'language',
'checked_out',
'checked_out_time',
'published',
'enabled',
'access',
'ordering',
'publish_up',
'publish_down',
'language_title',
'language_image',
'editor',
'access_level',
'pages',
'name',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_modules/src/View/Modules/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Modules
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Modules manager master display controller.

Depuis
3.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |
Paramètres
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'default_task', 'model_path', and 'view_path' (this list is not meant to be comprehensive).
MVCFactoryInterface | null | $factory | The factory.
CMSApplication | null | $app | The Application for the dispatcher
Input | null | $input | The Input object for the request
Depuis
3.0

Références $app, $config, $input, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_modules/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Modules
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres publiques

checkAccess ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)

Fonctions membres protégées

loadLanguage ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_modules

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )

Dispatch a controller task. Redirecting the user if appropriate.

Renvoie
void
Depuis
4.0.0

◆ getController()

getController | ( | string | $name,
 |  | string | $client = '',
 |  | array | $config = array()
 | ) |  |

Get a controller from the component

Paramètres
string | $name | Controller name
string | $client | Optional client (like Administrator, Site etc.)
array | $config | Optional controller config
Renvoie
Depuis
4.0.0

Références $client, $config, et $name.

◆ loadLanguage()

loadLanguage ( )
protected

Load the language

Depuis
4.0.0
Renvoie
void

Références JPATH_ADMINISTRATOR.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_modules/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe AjaxController

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Controller
  • AjaxController
Fonctions membres publiques
Référence de la classe AjaxController
+ Graphe d'héritage de AjaxController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

fetchAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The newsfeed controller for ajax requests

Depuis
3.9.0

Documentation des fonctions membres

◆ fetchAssociations()

fetchAssociations ( )

Method to fetch associations of a newsfeed

The method assumes that the following http parameters are passed in an Ajax Get request: token: the form token assocId: the id of the newsfeed whose associations are to be returned excludeLang: the association for this language is to be excluded

Renvoie
null
Depuis
3.9.0

Références $lang, $message, Text\_(), Session\checkToken(), elseif, Associations\getAssociations(), null, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/src/Controller/AjaxController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'newsfeeds'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Newsfeeds master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchaining.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'newsfeeds'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_newsfeeds/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe NewsfeedController

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Controller
  • NewsfeedController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe NewsfeedController
+ Graphe d'héritage de NewsfeedController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Newsfeed controller class.

Depuis
1.6

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method override to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
1.6

Références $data, ArrayHelper\getValue(), et null.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $canEditOwn, $data, $item, $key, $recordId, et $user.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
object $model The model.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
2.5

Références $model, Route\_(), et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedController.php


Joomla CMS: Référence de la classe NewsfeedsController

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Controller
  • NewsfeedsController
Fonctions membres publiques
Référence de la classe NewsfeedsController
+ Graphe d'héritage de NewsfeedsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Newsfeed', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Newsfeeds list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Newsfeed',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedsController.php


Joomla CMS: Référence de la classe NewsfeedsComponent

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Extension
  • NewsfeedsComponent
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe NewsfeedsComponent
+ Graphe d'héritage de NewsfeedsComponent:
MVCComponent BootableExtensionInterface CategoryServiceInterface AssociationServiceInterface RouterServiceInterface TagServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de CategoryServiceInterface
getCategory (array $options=[], $section='')
countItems (array $items, string $section)
prepareForm (Form $form, $data)
- Fonctions membres publiques hérités de AssociationServiceInterface
getAssociationsExtension ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
- Fonctions membres publiques hérités de TagServiceInterface
countTagItems (array $items, string $extension)

Champs de données

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait

Fonctions membres protégées

getTableNameForSection (string $section=null)
getStateColumnForSection (string $section=null)

Description détaillée

Component class for com_newsfeeds

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

◆ getStateColumnForSection()

getStateColumnForSection ( string $section = null )
protected

Returns the state column for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

◆ getTableNameForSection()

getTableNameForSection ( string $section = null )
protected

Returns the table for the count items functions for the given section.

Paramètres
string $section The section
Renvoie
string|null
Depuis
4.0.0

Références $section.

Documentation des champs

◆ TagServiceTrait

CategoryServiceTrait::getStateColumnForSection insteadof TagServiceTrait
La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedsComponent.php


Joomla CMS: Référence de la classe NewsfeedField

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Field
  • Modal
  • NewsfeedField
Fonctions membres protégées | Attributs protégés
Référence de la classe NewsfeedField
+ Graphe d'héritage de NewsfeedField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Modal_Newsfeed'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports a modal newsfeeds picker.

Depuis
1.6

Documentation des fonctions membres

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.4

Documentation des champs

◆ $type

$type = 'Modal_Newsfeed'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedField.php


Joomla CMS: Référence de la classe NewsfeedsField

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Field
  • NewsfeedsField
Fonctions membres protégées | Attributs protégés
Référence de la classe NewsfeedsField
+ Graphe d'héritage de NewsfeedsField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Newsfeeds'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

News Feed List field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références $db, $options, $query, Factory\getApplication(), et Joomla\Database\getDatabase().

Documentation des champs

◆ $type

$type = 'Newsfeeds'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedsField.php


Joomla CMS: Référence de la classe AssociationsHelper

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Helper
  • AssociationsHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe AssociationsHelper
+ Graphe d'héritage de AssociationsHelper:
AssociationExtensionHelper AssociationExtensionInterface

Fonctions membres publiques

getAssociationsForItem ($id=0, $view=null)
getAssociations ($typeName, $id)
getItem ($typeName, $id)
getType ($typeName='')
- Fonctions membres publiques hérités de AssociationExtensionHelper
hasAssociationsSupport ()
getItemTypes ()
getAssociationList ($typeName, $itemId)
getType ($typeName='')
getTypeFields ($typeName)
getTypeSupport ($typeName)
getTypeTables ($typeName)
getTypeJoins ($typeName)
getTypeTitle ($typeName)
getTypeFieldName ($typeName, $fieldName)

Attributs protégés

$extension = 'com_newsfeeds'
$itemTypes = array('newsfeed', 'category')
$associationsSupport = true
- Attributs protégés hérités de AssociationExtensionHelper
$extension = 'com_??'
$itemTypes = array()
$associationsSupport = false

Membres hérités additionnels

- Fonctions membres protégées hérités de AssociationExtensionHelper
getSupportTemplate ()
getFieldsTemplate ()

Description détaillée

Content associations helper.

Depuis
3.7.0

Documentation des fonctions membres

◆ getAssociations()

getAssociations | ( | $typeName,
 |  | $id
 | ) |

Get the associated items for an item

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
array
Depuis
3.7.0

Références $context, $id, $type, extension, et Associations\getAssociations().

◆ getAssociationsForItem()

getAssociationsForItem | ( | $id = 0,
 |  | $view = null
 | ) |

Method to get the associations for a given item.

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
4.0.0

Implémente AssociationExtensionInterface.

Références $id, $view, et AssociationHelper\getAssociations().

◆ getItem()

getItem | ( | $typeName,
 |  | $id
 | ) |

Get item information

Paramètres
string | $typeName | The item type
int | $id | The id of item for which we need the associated items
Renvoie
Table|null
Depuis
3.7.0

Références $id, Table\getInstance(), et null.

◆ getType()

getType ( $typeName = '' )

Get information about the type

Paramètres
string $typeName The item type
Renvoie
array Array of item types
Depuis
3.7.0

Références $fields, et $title.

Documentation des champs

◆ $associationsSupport

boolean $associationsSupport = true
protected

Has the extension association support

Depuis
3.7.0

◆ $extension

array $extension = 'com_newsfeeds'
protected

The extension name

Depuis
3.7.0

◆ $itemTypes

array $itemTypes = array('newsfeed', 'category')
protected

Array of item types

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/src/Helper/AssociationsHelper.php


Joomla CMS: Référence de la classe NewsfeedsHelper

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Helper
  • NewsfeedsHelper
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe NewsfeedsHelper
+ Graphe d'héritage de NewsfeedsHelper:
ContentHelper NewsfeedsHelper

Fonctions membres publiques statiques

static | countItems (&$items)
static | countTagItems (&$items, $extension)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Attributs publics statiques

static $extension = 'com_newsfeeds'

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Newsfeeds component helper.

Depuis
1.6

Documentation des fonctions membres

◆ countItems()

static countItems ( & $items )
static

Adds Count Items for Category Manager.

Paramètres

Références $db, $id, $item, $items, $query, Factory\getDbo(), et ParameterType\INTEGER.

◆ countTagItems()

static countTagItems | ( | & | $items,
 |  |  | $extension
 | ) |  |
static

Adds Count Items for Tag Manager.

Paramètres

Références $db, $extension, $id, $item, $items, $parts, $query, $section, Factory\getDbo(), ParameterType\INTEGER, et null.

Documentation des champs

◆ $extension

$extension = 'com_newsfeeds'
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedsHelper.php


Joomla CMS: Référence de la classe NewsfeedModel

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Model
  • NewsfeedModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe NewsfeedModel
+ Graphe d'héritage de NewsfeedModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
publish (&$pks, $value=1)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_newsfeeds.newsfeed'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
loadFormData ()
prepareTable ($table)
getReorderConditions ($table)
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$associationsContext = 'com_newsfeeds.item'
$text_prefix = 'COM_NEWSFEEDS'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

canCreateCategory ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Newsfeed model.

Depuis
1.6

Documentation des fonctions membres

◆ canCreateCategory()

canCreateCategory ( )
private

Is the user allowed to create an on the fly category?

Renvoie
boolean
Depuis
3.6.1

Références Factory\getUser().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
1.6

Références Factory\getUser().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $data, $form, Factory\getUser(), et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $assoc, $item, Factory\getApplication(), Associations\getAssociations(), Associations\isEnabled(), et null.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $app, $data, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\preprocessData().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table prior to saving.

Paramètres
\Joomla\CMS\Table\Table $table The table object
Renvoie
void

Références $date, $db, $query, $user, ENT_QUOTES, Joomla\Database\getDatabase(), Factory\getDate(), Factory\getUser(), et ApplicationHelper\stringURLSafe().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

A protected method to get a set of ordering conditions.

Paramètres
Form | $form | The form object.
array | $data | The data to be injected into the form
string | $group | The plugin group to process
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références $data, $field, $fields, $form, $language, $languages, Associations\isEnabled(), null, et Joomla\CMS\MVC\Model\preprocessForm().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
1.6

Références $result, et $value.

Documentation des champs

◆ $associationsContext

$associationsContext = 'com_newsfeeds.item'
protected

◆ $text_prefix

$text_prefix = 'COM_NEWSFEEDS'
protected

◆ $typeAlias

$typeAlias = 'com_newsfeeds.newsfeed'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_newsfeeds/src/Model/NewsfeedModel.php


Joomla CMS: Référence de la classe NewsfeedsModel

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Model
  • NewsfeedsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe NewsfeedsModel
+ Graphe d'héritage de NewsfeedsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.name', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of newsfeed records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, Symfony\Contracts\Service\__construct(), et Associations\isEnabled().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie

Références $db, $language, $ordering, $published, $query, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, Associations\isEnabled(), et ArrayHelper\toInteger().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $layout, $ordering, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedsModel.php


Joomla CMS: Référence de la classe AdministratorService

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Service
  • HTML
  • AdministratorService
Fonctions membres publiques
Référence de la classe AdministratorService

Fonctions membres publiques

association ($newsfeedid)

Description détaillée

Utility class for creating HTML Grids.

Depuis
1.5

Documentation des fonctions membres

◆ association()

association ( $newsfeedid )

Get the associated language flags

Paramètres
int $newsfeedid The item id to search associations
Renvoie
string The language HTML
Exceptions

Références $classes, $content_languages, $db, $html, $item, $items, $languages, $query, $text, $tooltip, $url, Route\_(), ENT_QUOTES, Factory\getApplication(), Associations\getAssociations(), Factory\getDbo(), ParameterType\INTEGER, LayoutHelper\render(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/src/Service/HTML/AdministratorService.php


Joomla CMS: Référence de la classe NewsfeedTable

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • Table
  • NewsfeedTable
Fonctions membres publiques | Attributs protégés
Référence de la classe NewsfeedTable
+ Graphe d'héritage de NewsfeedTable:
Table VersionableTableInterface TaggableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface TableInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=true)
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de TaggableTableInterface
getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Attributs protégés

$_supportNullValue = true
$_jsonEncode = array('params', 'metadata', 'images')
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

Newsfeed Table class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check method to ensure data integrity.

Renvoie
boolean True on success.

Implémente TableInterface.

Références $name, Text\_(), Factory\getDate(), hits, language, name, StringHelper\str_ireplace(), et ApplicationHelper\stringURLSafe().

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente TaggableTableInterface.

◆ store()

store ( $updateNulls = true )

Overridden ::store to set modified data.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $date, $user, Text\_(), Factory\getDate(), Table\getInstance(), Factory\getUser(), null, et PunycodeHelper\urlToPunycode().

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = array('params', 'metadata', 'images')
protected

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • View
  • Newsfeed
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$item
$form
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a newsfeed.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $title, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), Associations\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références Factory\getApplication(), et null.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_newsfeeds/src/View/Newsfeed/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Newsfeeds
  • Administrator
  • View
  • Newsfeeds
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View class for a list of newsfeeds.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $state, $toolbar, $user, Text\_(), ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références Factory\getApplication(), Multilanguage\isEnabled(), et items.

Documentation des champs

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_newsfeeds/src/View/Newsfeeds/HtmlView.php


Joomla CMS: Référence de la classe FeedsController

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • Controller
  • FeedsController
Attributs protégés
Référence de la classe FeedsController
+ Graphe d'héritage de FeedsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'newsfeeds'
$default_view = 'feeds'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The feeds controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'newsfeeds'
protected

◆ $default_view

$default_view = 'feeds'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FeedsController.php


Joomla CMS: Référence de la classe NewsfeedSerializer

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • Serializer
  • NewsfeedSerializer
Fonctions membres publiques
Référence de la classe NewsfeedSerializer
+ Graphe d'héritage de NewsfeedSerializer:
JoomlaSerializer AbstractSerializer SerializerInterface

Fonctions membres publiques

languageAssociations ($model)
category ($model)
createdBy ($model)
modifiedBy ($model)
- Fonctions membres publiques hérités de JoomlaSerializer
__construct (string $type)
- Fonctions membres publiques hérités de AbstractSerializer
getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Membres hérités additionnels

- Attributs protégés hérités de AbstractSerializer
$type

Description détaillée

Temporary serializer

Depuis
4.0.0

Documentation des fonctions membres

◆ category()

category ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ createdBy()

createdBy ( $model )

Build category relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ languageAssociations()

languageAssociations ( $model )

Build content relationships by associations

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

◆ modifiedBy()

modifiedBy ( $model )

Build editor relationship

Paramètres
\stdClass $model Item model
Renvoie
Relationship
Depuis
4.0.0

Références $model, Tobscure\JsonApi\addLink(), Route\link(), et Uri\root().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NewsfeedSerializer.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Newsfeeds
  • Api
  • View
  • Feeds
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[])
displayItem ($item=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
$relationship
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The feeds view

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config A named configuration array for object construction. contentType: the name (optional) of the content type to use for the serialization
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ displayItem()

displayItem ( $item = null )

Execute and display a template script.

Paramètres
object $item Item
Renvoie
string
Depuis
4.0.0

Références Multilanguage\isEnabled().

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item, $itemId, $language, et Multilanguage\isEnabled().

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'alias',
'checked_out',
'checked_out_time',
'category',
'numarticles',
'cache_time',
'created_by',
'published',
'access',
'ordering',
'language',
'publish_up',
'publish_down',
'language_title',
'language_image',
'editor',
'access_level',
'category_title',
]

◆ $relationship

$relationship
protected
Valeur initiale :
= [
'category',
'created_by',
'modified_by',
'tags',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/src/View/Feeds/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Newsfeeds Component Controller

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to show a newsfeeds view

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticThisobjecttosupportchaining.@since1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe AssociationHelper

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Helper
  • AssociationHelper
Fonctions membres publiques statiques
Référence de la classe AssociationHelper
+ Graphe d'héritage de AssociationHelper:
CategoryAssociationHelper

Fonctions membres publiques statiques

static | getAssociations ($id=0, $view=null)
- Fonctions membres publiques statiques hérités de CategoryAssociationHelper
static | getCategoryAssociations ($id=0, $extension='com_content', $layout=null)

Membres hérités additionnels

- Attributs publics statiques hérités de CategoryAssociationHelper
static $category_association = true

Description détaillée

Newsfeeds Component Association Helper

Depuis
3.0

Documentation des fonctions membres

◆ getAssociations()

static getAssociations | ( | $id = 0,
 |  | $view = null
 | ) |
static

Method to get the associations for a given item

Paramètres
integer | $id | Id of the item
string | $view | Name of the view
Renvoie
array Array of associations for the item
Depuis
3.0

Références $id, $item, $return, $view, Factory\getApplication(), Associations\getAssociations(), et RouteHelper\getNewsfeedRoute().

Référencé par AssociationsHelper\getAssociationsForItem().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/src/Helper/AssociationHelper.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Helper
  • RouteHelper
Fonctions membres publiques statiques
Référence de la classe RouteHelper
+ Graphe d'héritage de RouteHelper:
NewsfeedsHelperRoute

Fonctions membres publiques statiques

static | getNewsfeedRoute ($id, $catid, $language=0)
static | getCategoryRoute ($catid, $language=0)

Description détaillée

Newsfeeds Component Route Helper

Depuis
1.5

Documentation des fonctions membres

◆ getCategoryRoute()

static getCategoryRoute | ( | $catid,
 |  | $language = 0
 | ) |
static

getCategoryRoute

Paramètres
int | $catid | category id
int | $language | language
Renvoie
string

Références $id, $language, $link, et Multilanguage\isEnabled().

Référencé par HtmlView\_prepareDocument(), et HtmlView\prepareDocument().

◆ getNewsfeedRoute()

static getNewsfeedRoute | ( | $id,
 |  | $catid,
 |  | $language = 0
 | ) |
static

getNewsfeedRoute

Paramètres
int | $id | menu itemid
int | $catid | category id
int | $language | language
Renvoie
string

Références $id, $language, $link, et Multilanguage\isEnabled().

Référencé par AssociationHelper\getAssociations().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe CategoriesModel

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Model
  • CategoriesModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe CategoriesModel
+ Graphe d'héritage de CategoriesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItems ()
getParent ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$_context = 'com_newsfeeds.categories'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getStoreId ($id='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_extension = 'com_newsfeeds'
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$_parent = null
$_items = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving lists of newsfeed categories.

Depuis
1.6

Documentation des fonctions membres

◆ getItems()

getItems ( )

redefine the function and add some properties to make the styling easier

Renvoie
mixed An array of data items on success, false on failure.

Implémente ListModelInterface.

Références $active, $app, $menu, $options, $params, Factory\getApplication(), Categories\getInstance(), Joomla\CMS\MVC\Model\getState(), et null.

◆ getParent()

getParent ( )

get the Parent

Renvoie
null

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field
string | $direction | An optional direction [asc|desc]
Renvoie
void
Exceptions

Références $app, $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_newsfeeds.categories'

◆ $_extension

$_extension = 'com_newsfeeds'
protected

◆ $_items

$_items = null
private

◆ $_parent

$_parent = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Model/CategoriesModel.php


Joomla CMS: Référence de la classe CategoryModel

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Model
  • CategoryModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CategoryModel
+ Graphe d'héritage de CategoryModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
getCategory ()
getParent ()
& getLeftSibling ()
& getRightSibling ()
& getChildren ()
hit ($pk=0)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_item
$_articles
$_siblings
$_children
$_parent
$_category
$_categories
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Newsfeeds Component Category Model

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getCategory()

getCategory ( )

Method to get category data for the current category

Renvoie
object
Depuis
1.5

Références $active, $app, $menu, $options, $params, Factory\getApplication(), Categories\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ getChildren()

& getChildren ( )

Get the child categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Tree\$_children, et Joomla\CMS\Categories\getCategory().

◆ getItems()

getItems ( )

Method to get a list of items.

Renvoie
mixed An array of objects on success, false on failure.

Implémente ListModelInterface.

Références $id, $item, $itemIds, $items, et Joomla\CMS\MVC\Model\getState().

◆ getLeftSibling()

& getLeftSibling ( )

Get the sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ getParent()

getParent ( )

Get the parent category.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ getRightSibling()

& getRightSibling ( )

Get the sibling (adjacent) categories.

Renvoie
mixed An array of categories or false if an error occurs.

Références Joomla\CMS\Categories\getCategory().

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the category.

Paramètres
int $pk Optional primary key of the category to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.

Références $input, Factory\getApplication(), Table\getInstance(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field
string | $direction | An optional direction [asc|desc]
Renvoie
void
Depuis
1.6
Exceptions

Références $app, $id, $limit, $listOrder, $params, $user, Factory\getApplication(), ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_articles

$_articles
protected

◆ $_categories

$_categories
protected

◆ $_category

$_category
protected

◆ $_children

$_children
protected

◆ $_item

$_item
protected

◆ $_parent

$_parent
protected

◆ $_siblings

$_siblings
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Model/CategoryModel.php


Joomla CMS: Référence de la classe NewsfeedModel

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Model
  • NewsfeedModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe NewsfeedModel
+ Graphe d'héritage de NewsfeedModel:
ItemModel BaseDatabaseModel ItemModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

& getItem ($pk=null)
hit ($pk=0)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de ItemModel
getStoreId ($id='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_context = 'com_newsfeeds.newsfeed'
- Attributs protégés hérités de ItemModel
$_item = null
$_context = 'group.type'
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Newsfeeds Component Newsfeed Model

Depuis
1.5

Documentation des fonctions membres

◆ getItem()

& getItem ( $pk = null )

Method to get newsfeed data.

Paramètres
integer $pk The id of the newsfeed.
Renvoie
mixed Menu item data object on success, false on failure.
Depuis
1.6

Implémente ItemModelInterface.

Références $data, $db, $groups, $nowDate, $published, $query, $user, Text\_(), Joomla\Database\getDatabase(), Factory\getDate(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, et null.

◆ hit()

hit ( $pk = 0 )

Increment the hit counter for the newsfeed.

Paramètres
int $pk Optional primary key of the item to increment.
Renvoie
boolean True if successful; false otherwise and internal error set.
Depuis
3.0

Références $input, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, Joomla\Database\Query\$offset, $params, $user, Factory\getApplication(), Factory\getUser(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_newsfeeds.newsfeed'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Model/NewsfeedModel.php


Joomla CMS: Référence de la classe Category

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Service
  • Category
Fonctions membres publiques
Référence de la classe Category
+ Graphe d'héritage de Category:
Categories CategoryInterface DatabaseAwareInterface

Fonctions membres publiques

__construct ($options=array())
- Fonctions membres publiques hérités de Categories
__construct ($options)
get ($id='root', $forceload=false)
getExtension ()
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Categories
static | getInstance ($extension, $options=array())
- Attributs publics statiques hérités de Categories
static | $instances = array()
- Fonctions membres protégées hérités de Categories
_load ($id)
- Attributs protégés hérités de Categories
$_nodes
$_checkedCategories
$_extension = null
$_table = null
$_field = null
$_key = null
$_statefield = null
$_options = []

Description détaillée

Newsfeed Component Category Tree

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = array() )

Constructor

Paramètres
array $options options

Références $options, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Service/Category.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • Service
  • Router
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu, CategoryFactoryInterface $categoryFactory, DatabaseInterface $db)
getCategorySegment ($id, $query)
getCategoriesSegment ($id, $query)
getNewsfeedSegment ($id, $query)
getCategoryId ($segment, $query)
getCategoriesId ($segment, $query)
getNewsfeedId ($segment, $query)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Attributs protégés

$noIDs = false
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Fonctions membres privées

getCategories (array $options=[])

Attributs privés

$categoryFactory
$categoryCache = []
$db

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class from com_newsfeeds

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu,
 |  | CategoryFactoryInterface | $categoryFactory,
 |  | DatabaseInterface | $db
 | ) |  |

Newsfeeds Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with
CategoryFactoryInterface | $categoryFactory | The category object
DatabaseInterface | $db | The database object

Références $app, $category, $db, $menu, $params, $this, Symfony\Contracts\Service\__construct(), et ComponentHelper\getParams().

Documentation des fonctions membres

◆ getCategories()

getCategories ( array $options = [] )
private

Method to get categories from cache

Paramètres
array $options The options for retrieving categories
Renvoie
CategoryInterface The object containing categories
Depuis
4.0.0

Références $key, et $options.

◆ getCategoriesId()

getCategoriesId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query.

◆ getCategoriesSegment()

getCategoriesSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et $query.

◆ getCategoryId()

getCategoryId | ( | $segment,
 |  | $query
 | ) |

Method to get the id for a category

Paramètres
string | $segment | Segment to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $category, et $query.

◆ getCategorySegment()

getCategorySegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a category

Paramètres
string | $id | ID of the category to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $category, $id, et $path.

◆ getNewsfeedId()

getNewsfeedId | ( | $segment,
 |  | $query
 | ) |

Method to get the segment(s) for a newsfeed

Paramètres
string | $segment | Segment of the newsfeed to retrieve the ID for
array | $query | The request that is parsed right now
Renvoie
mixed The id of this item or false

Références $query, et ParameterType\INTEGER.

◆ getNewsfeedSegment()

getNewsfeedSegment | ( | $id,
 |  | $query
 | ) |

Method to get the segment(s) for a newsfeed

Paramètres
string | $id | ID of the newsfeed to retrieve the segments for
array | $query | The request that is built right now
Renvoie
array|string The segments of this item

Références $id, et ParameterType\INTEGER.

Documentation des champs

◆ $categoryCache

$categoryCache = []
private

◆ $categoryFactory

$categoryFactory
private

◆ $db

$db
private

◆ $noIDs

$noIDs = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Categories
  • HtmlView
Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoriesView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$pageHeading = 'COM_NEWSFEEDS_DEFAULT_PAGE_TITLE'
$extension = 'com_newsfeeds'
- Attributs protégés hérités de CategoriesView
$state
$items
$pageHeading
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de CategoriesView
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de CategoriesView
prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Newsfeed categories view.

Depuis
1.5

Documentation des champs

◆ $extension

$extension = 'com_newsfeeds'
protected

◆ $pageHeading

$pageHeading = 'COM_NEWSFEEDS_DEFAULT_PAGE_TITLE'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/View/Categories/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Category
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
CategoryView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de CategoryView
commonCategoryDisplay ()
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de CategoryView
prepareDocument ()
addFeed ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$defaultPageTitle = 'COM_NEWSFEEDS_DEFAULT_PAGE_TITLE'
$extension = 'com_newsfeeds'
$viewName = 'newsfeed'
- Attributs protégés hérités de CategoryView
$state
$items
$category
$categories
$pagination
$children
$extension
$viewName
$defaultPageTitle
$runPlugins = false
$menuItemMatchCategory = false
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Newsfeeds component

Depuis
1.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références $item, $temp, $this, et items.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $category, $id, $item, $menu, $path, $this, category, RouteHelper\getCategoryRoute(), et if.

Documentation des champs

◆ $defaultPageTitle

$defaultPageTitle = 'COM_NEWSFEEDS_DEFAULT_PAGE_TITLE'
protected

◆ $extension

$extension = 'com_newsfeeds'
protected

◆ $viewName

$viewName = 'newsfeed'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/View/Category/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Newsfeeds
  • Site
  • View
  • Newsfeed
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$item
$print
$user = null
$pageclass_sfx = ''
$params
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Newsfeeds component

Depuis
1.0

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
1.6

Références $app, $category, $id, $item, $menu, $path, $this, $title, Text\_(), elseif, Factory\getApplication(), RouteHelper\getCategoryRoute(), Categories\getInstance(), et if.

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références $active, $app, $feed, $item, $layout, $model, $params, $state, $temp, $user, Text\_(), Factory\getApplication(), et Joomla\CMS\User\getCurrentUser().

Documentation des champs

◆ $item

$item
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $print

$print
protected

◆ $state

$state
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_newsfeeds/src/View/Newsfeed/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'plugins'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Plugins master display controller.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'plugins'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_plugins/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe PluginController

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Controller
  • PluginController
Référence de la classe PluginController
+ Graphe d'héritage de PluginController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Plugin controller class.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_plugins/src/Controller/PluginController.php


Joomla CMS: Référence de la classe PluginsController

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Controller
  • PluginsController
Fonctions membres publiques
Référence de la classe PluginsController
+ Graphe d'héritage de PluginsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Plugin', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Plugins list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Plugin',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the number of activated plugins

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_plugins/src/Controller/PluginsController.php


Joomla CMS: Référence de la classe PluginElementField

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Field
  • PluginElementField
Fonctions membres publiques | Attributs protégés
Référence de la classe PluginElementField
+ Graphe d'héritage de PluginElementField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'PluginElement'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Plugin Element field.

Depuis
3.9.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.9.0

Références $options, et PluginsHelper\elementOptions().

Documentation des champs

◆ $type

$type = 'PluginElement'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginElementField.php


Joomla CMS: Référence de la classe PluginorderingField

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Field
  • PluginorderingField
Fonctions membres protégées | Attributs protégés
Référence de la classe PluginorderingField
+ Graphe d'héritage de PluginorderingField:
OrderingField FormField DatabaseAwareInterface

Fonctions membres protégées

getQuery ()
getItemId ()
- Fonctions membres protégées hérités de OrderingField
getInput ()
getQuery ()
getItemId ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Pluginordering'
- Attributs protégés hérités de OrderingField
$type = 'Ordering'
$contentType
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de OrderingField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Supports an HTML select list of plugins.

Depuis
1.6

Documentation des fonctions membres

◆ getItemId()

getItemId ( )
protected

Retrieves the current Item's Id.

Renvoie
integer The current item ID.

◆ getQuery()

getQuery ( )
protected

Builds the query for the ordering list.

Renvoie
The query for the ordering form field.

Références $db, $folder, $query, et Joomla\Database\getDatabase().

Documentation des champs

◆ $type

$type = 'Pluginordering'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginorderingField.php


Joomla CMS: Référence de la classe PluginTypeField

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Field
  • PluginTypeField
Fonctions membres publiques | Attributs protégés
Référence de la classe PluginTypeField
+ Graphe d'héritage de PluginTypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'PluginType'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Plugin Type field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et PluginsHelper\folderOptions().

Documentation des champs

◆ $type

$type = 'PluginType'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginTypeField.php


Joomla CMS: Référence de la classe PluginsHelper

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Helper
  • PluginsHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe PluginsHelper
+ Graphe d'héritage de PluginsHelper:
PluginsHelper

Fonctions membres publiques

parseXMLTemplateFile ($templateBaseDir, $templateDir)

Fonctions membres publiques statiques

static | publishedOptions ()
static | folderOptions ()
static | elementOptions ()

Attributs publics statiques

static $extension = 'com_plugins'

Description détaillée

Plugins component helper.

Depuis
1.6

Documentation des fonctions membres

◆ elementOptions()

static elementOptions ( )
static

Returns a list of elements filter options.

Renvoie
string The HTML code for the select tag

Références $db, $options, $query, Factory\getApplication(), et Factory\getDbo().

Référencé par PluginElementField\getOptions().

◆ folderOptions()

static folderOptions ( )
static

Returns a list of folders filter options.

Renvoie
string The HTML code for the select tag

Références $db, $options, $query, Factory\getApplication(), et Factory\getDbo().

Référencé par PluginTypeField\getOptions().

◆ parseXMLTemplateFile()

parseXMLTemplateFile | ( | $templateBaseDir,
 |  | $templateDir
 | ) |

Parse the template file.

Paramètres
string | $templateBaseDir | Base path to the template directory.
string | $templateDir | Template directory.
Renvoie
CMSObject|bool

Références $data, $key, $value, $xml, Path\clean(), et Installer\parseXMLInstallFile().

◆ publishedOptions()

static publishedOptions ( )
static

Returns an array of standard published state filter options.

Renvoie
array The HTML code for the select tag

Références $options, et HTMLHelper\_().

Documentation des champs

◆ $extension

$extension = 'com_plugins'
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginsHelper.php


Joomla CMS: Référence de la classe PluginModel

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Model
  • PluginModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PluginModel
+ Graphe d'héritage de PluginModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getForm ($data=array(), $loadData=true)
getItem ($pk=null)
getTable ($type='Extension', $prefix='JTable', $config=array())
save ($data)
getHelp ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
populateState ()
preprocessForm (Form $form, $data, $group='content')
getReorderConditions ($table)
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$helpKey = 'Plugins:_Name_of_Plugin'
$helpURL
$_cache
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Plugin model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method, plugins are cached in 2 places for different clients.

Paramètres
string | $group | Cache group name.
integer | $clientId

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure.
Depuis
1.6

Implémente FormModelInterface.

Références $data, $folder, $form, $item, Form\addFieldPath(), ArrayHelper\getValue(), JPATH_PLUGINS, Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getHelp()

getHelp ( )

Get the necessary data to load an item help screen.

Renvoie
object An object with key, url, and local properties for loading the item help screen.
Depuis
1.6

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.

Références $path, $return, class, Path\clean(), Joomla\CMS\MVC\Model\getState(), JPATH_PLUGINS, null, et ArrayHelper\toObject().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
1.6

Références $db, et Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Extension',
 |  | $prefix = 'JTable',
 |  | $config = array()
 | ) |

Returns a reference to the Table object, always creating it.

Paramètres
string | $type | The table type to instantiate.
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object

Références $config, $prefix, $type, et Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Preprocess the form.

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | Cache group name.
Renvoie
mixed True if successful.
Depuis
1.6
Exceptions

Références $app, $data, $db, $folder, $form, $helpURL, $lang, $query, $xml, Text\_(), Route\_(), Path\clean(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, Joomla\CMS\MVC\Model\preprocessForm(), et Text\sprintf().

◆ save()

save ( $data )

Override method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $data.

Documentation des champs

◆ $_cache

$_cache
protected

◆ $helpKey

$helpKey = 'Plugins:_Name_of_Plugin'
protected

◆ $helpURL

$helpURL
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginModel.php


Joomla CMS: Référence de la classe PluginsModel

  • Joomla
  • Component
  • Plugins
  • Administrator
  • Model
  • PluginsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PluginsModel
+ Graphe d'héritage de PluginsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='folder', $direction='asc')
getStoreId ($id='')
_getList ($query, $limitstart=0, $limit=0)
translate (&$items)
getListQuery ()
loadFormData ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of plugin records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Returns an object list.

Paramètres
\Joomla\Database\DatabaseQuery | $query | A database query object.
integer | $limitstart | Offset.
integer | $limit | The number of records.
Renvoie
array

Références $db, $direction, $i, $item, $limit, $ordering, $query, $result, $total, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), null, et ArrayHelper\sortObjects().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie

Références $db, $folder, $published, $query, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
3.5

Références $data, et Joomla\CMS\MVC\Model\loadFormData().

◆ populateState()

populateState | ( | $ordering = 'folder',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ translate()

translate ( & $items )
protected

Translate a list of objects.

Paramètres
array &$items The array of objects.
Renvoie
array The array of translated objects.

Références $extension, $item, $items, $lang, Text\_(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et JPATH_PLUGINS.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PluginsModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Plugins
  • Administrator
  • View
  • Plugin
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$item
$form
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a plugin.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $lang, $url, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Factory\getLanguage(), ToolbarHelper\help(), ToolbarHelper\inlinehelp(), null, ToolbarHelper\save(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_plugins/src/View/Plugin/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Plugins
  • Administrator
  • View
  • Plugins
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of plugins.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, Text\_(), ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_plugins/src/View/Plugins/HtmlView.php


Joomla CMS: Référence de la classe PluginsController

  • Joomla
  • Component
  • Plugins
  • Api
  • Controller
  • PluginsController
Fonctions membres publiques | Attributs protégés
Référence de la classe PluginsController
+ Graphe d'héritage de PluginsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'plugins'
$default_view = 'plugins'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The plugins controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( )

Plugin list view with filtering of data

Renvoie
static A BaseController object to support chaining.
Depuis
4.0.0

Références InputFilter\getInstance().

Documentation des champs

◆ $contentType

$contentType = 'plugins'
protected

◆ $default_view

$default_view = 'plugins'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_plugins/src/Controller/PluginsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Plugins
  • Api
  • View
  • Plugins
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The plugins view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'name',
'type',
'element',
'changelogurl',
'folder',
'client_id',
'enabled',
'access',
'protected',
'checked_out',
'checked_out_time',
'ordering',
'state',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'element',
'folder',
'checked_out',
'checked_out_time',
'enabled',
'access',
'ordering',
'editor',
'access_level',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_plugins/src/View/Plugins/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getMenuBadgeData ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'messages'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Postinstall display controller

Depuis
3.6

Documentation des fonctions membres

◆ getMenuBadgeData()

getMenuBadgeData ( )

Provide the data for a badge in a menu item via JSON

Renvoie
void
Depuis
4.0.0
Exceptions

Références $model, et Text\_().

Documentation des champs

◆ $default_view

$default_view = 'messages'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_postinstall/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe MessageController

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Controller
  • MessageController
Fonctions membres publiques
Référence de la classe MessageController
+ Graphe d'héritage de MessageController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

unpublish ()
republish ()
archive ()
action ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Postinstall message controller.

Depuis
3.2

Documentation des fonctions membres

◆ action()

action ( )

Executes the action associated with an item.

Renvoie
void
Depuis
3.2

Références $helper, $id, $item, $model, Joomla\Application\checkToken(), et File\exists().

◆ archive()

archive ( )

Archives a published post-installation message of the specified extension.

Renvoie
void
Depuis
4.2.0

Références $id, et $model.

◆ republish()

republish ( )

Re-Publishes an archived post-installation message of the specified extension.

Renvoie
void
Depuis
4.2.0

Références $id, et $model.

◆ unpublish()

unpublish ( )

Unpublishes post-installation message of the specified extension.

Renvoie
void
Depuis
3.2

Références $id, et $model.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_postinstall/src/Controller/MessageController.php


Joomla CMS: Référence de la classe PostinstallHelper

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Helper
  • PostinstallHelper
Fonctions membres publiques
Référence de la classe PostinstallHelper

Fonctions membres publiques

parsePath ($path)

Description détaillée

Helper class for postinstall messages

Depuis
3.6

Documentation des fonctions membres

◆ parsePath()

parsePath ( $path )

Method for parsing ini files.

Paramètres
string $path Fancy path.
Renvoie
string Parsed path.
Depuis
3.6

Références $path, elseif, JPATH_ADMINISTRATOR, et JPATH_ROOT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PostinstallHelper.php


Joomla CMS: Référence de la classe MessagesModel

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • Model
  • MessagesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MessagesModel
+ Graphe d'héritage de MessagesModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItem ($id)
unpublishMessage ($id)
archiveMessage ($id)
republishMessage ($id)
getExtensionName ($eid)
resetMessages ($eid)
hideMessages ($eid)
getComponentOptions ()
addPostInstallationMessage (array $options)
getJoomlaFilesExtensionId ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
onProcessList (&$resultArray)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class to manage postinstall messages

Depuis
3.2

Documentation des fonctions membres

◆ addPostInstallationMessage()

addPostInstallationMessage ( array $options )

Adds or updates a post-installation message (PIM) definition. You can use this in your post-installation script using this code:

require_once JPATH_LIBRARIES . '/fof/include.php'; FOFModel::getTmpInstance('Messages', 'PostinstallModel')->addPostInstallationMessage($options);

The $options array contains the following mandatory keys:

extension_id The numeric ID of the extension this message is for (see the #__extensions table)

type One of message, link or action. Their meaning is: message Informative message. The user can dismiss it. link The action button links to a URL. The URL is defined in the action parameter. action A PHP action takes place when the action button is clicked. You need to specify the action_file (RAD path to the PHP file) and action (PHP function name) keys. See below for more information.

title_key The Text language key for the title of this PIM. Example: COM_FOOBAR_POSTINSTALL_MESSAGEONE_TITLE

description_key The Text language key for the main body (description) of this PIM Example: COM_FOOBAR_POSTINSTALL_MESSAGEONE_DESCRIPTION

action_key The Text language key for the action button. Ignored and not required when type=message Example: COM_FOOBAR_POSTINSTALL_MESSAGEONE_ACTION

language_extension The extension name which holds the language keys used above. For example, com_foobar, mod_something, plg_system_whatever, tpl_mytemplate

language_client_id Should we load the frontend (0) or backend (1) language keys?

version_introduced Which was the version of your extension where this message appeared for the first time? Example: 3.2.1

enabled Must be 1 for this message to be enabled. If you omit it, it defaults to 1.

condition_file The RAD path to a PHP file containing a PHP function which determines whether this message should be shown to the user.

Voir également
FOFTemplateUtils::parsePath() for RAD path format. Joomla! will include this file before calling the condition_method. Example: admin://components/com_foobar/helpers/postinstall.php

condition_method The name of a PHP function which will be used to determine whether to show this message to the user. This must be a simple PHP user function (not a class method, static method etc) which returns true to show the message and false to hide it. This function is defined in the condition_file. Example: com_foobar_postinstall_messageone_condition

When type=message no additional keys are required.

When type=link the following additional keys are required:

action The URL which will open when the user clicks on the PIM's action button Example: index.php?option=com_foobar&view=tools&task=installSampleData

When type=action the following additional keys are required:

action_file The RAD path to a PHP file containing a PHP function which performs the action of this PIM.

Voir également
FOFTemplateUtils::parsePath() for RAD path format. Joomla! will include this file before calling the function defined in the action key below. Example: admin://components/com_foobar/helpers/postinstall.php

action The name of a PHP function which will be used to run the action of this PIM. This must be a simple PHP user function (not a class method, static method etc) which returns no result. Example: com_foobar_postinstall_messageone_action

Paramètres
array $options See description
Renvoie
$this
Exceptions

Références $db, $helper, $key, $options, $query, $this, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ archiveMessage()

archiveMessage ( $id )

Archives specified post-install message

Paramètres
integer $id The message id
Renvoie
void
Depuis
4.2.0

Références $db, $id, $query, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ getComponentOptions()

getComponentOptions ( )

Get the dropdown options for the list of component with post-installation messages

Depuis
3.4
Renvoie
array Compatible with JHtmlSelect::genericList

Références $db, $options, $query, HTMLHelper\_(), Factory\getApplication(), Joomla\Database\getDatabase(), JPATH_SITE, et null.

◆ getExtensionName()

getExtensionName ( $eid )

Returns the name of an extension, as registered in the #__extensions table

Paramètres
integer $eid The extension ID
Renvoie
string The extension name
Depuis
3.2

Références $basePath, $db, $extension, $lang, $query, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), ParameterType\INTEGER, JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getItem()

getItem ( $id )

Gets an item with the given id from the database

Paramètres
integer $id The item id
Renvoie
Object
Depuis
3.2

Références $db, $id, $query, $result, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ getJoomlaFilesExtensionId()

getJoomlaFilesExtensionId ( )

Returns the library extension ID.

Renvoie
integer
Depuis
4.0.0

Références ExtensionHelper\getExtensionRecord().

◆ hideMessages()

hideMessages ( $eid )

Hides all messages for an extension

Paramètres
integer $eid The extension ID whose messages we'll hide
Renvoie
mixed False if we fail, a db cursor otherwise
Depuis
3.8.7

Références $db, $query, $result, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ onProcessList()

onProcessList ( & $resultArray )
protected

List post-processing. This is used to run the programmatic display conditions against each list item and decide if we have to show it or not.

Do note that this a core method of the RAD Layer which operates directly on the list it's being fed. A little touch of modern magic.

Paramètres
array &$resultArray A list of items to process
Renvoie
void
Depuis
3.2

Références $hash, $helper, $item, $key, $result, File\exists(), Factory\getApplication(), JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ populateState()

populateState ( )
protected

Method to auto-populate the state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the configuration flag to ignore the request is set.

Renvoie
void
Note
Calling getState in this method will result in recursion.
Depuis
4.0.0

Références Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ republishMessage()

republishMessage ( $id )

Republishes specified post-install message

Paramètres
integer $id The message id
Renvoie
void
Depuis
4.2.0

Références $db, $id, $query, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ resetMessages()

resetMessages ( $eid )

Resets all messages for an extension

Paramètres
integer $eid The extension ID whose messages we'll reset
Renvoie
mixed False if we fail, a db cursor otherwise
Depuis
3.2

Références $db, $query, $result, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ unpublishMessage()

unpublishMessage ( $id )

Unpublishes specified post-install message

Paramètres
integer $id The message id
Renvoie
void

Références $db, $id, $query, Factory\getCache(), Joomla\Database\getDatabase(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_postinstall/src/Model/MessagesModel.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Postinstall
  • Administrator
  • View
  • Messages
  • HtmlView
Fonctions membres privées
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres privées

toolbar ()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Model class to display postinstall messages

Depuis
3.2

Documentation des fonctions membres

◆ toolbar()

toolbar ( )
private

displays the toolbar

Renvoie
void
Depuis
3.6

Références $toolbar, Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), et items.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_postinstall/src/View/Messages/HtmlView.php


Joomla CMS: Référence de la classe ConsentsController

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Controller
  • ConsentsController
Référence de la classe ConsentsController
+ Graphe d'héritage de ConsentsController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Consents management controller class.

Depuis
3.9.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Controller/ConsentsController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'requests'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Privacy Controller

Depuis
3.9.0

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = []
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
$this
Depuis
3.9.0

Références $document, $model, $this, $view, Text\_(), et Route\_().

Documentation des champs

◆ $default_view

$default_view = 'requests'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe RequestController

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Controller
  • RequestController
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RequestController
+ Graphe d'héritage de RequestController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

export ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

postSaveHook (BaseDatabaseModel $model, $validData=[])
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Fonctions membres privées

canTransition ($item, $newStatus)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Request management controller class.

Depuis
3.9.0

Documentation des fonctions membres

◆ canTransition()

canTransition | ( | $item,
 |  | $newStatus
 | ) |
private

Method to determine if an item can transition to the specified status.

Paramètres
object | $item | The item being updated.
string | $newStatus | The new status of the item.
Renvoie
boolean
Depuis
3.9.0

Références $item.

◆ export()

export ( )

Method to export the data for a request.

Renvoie
$this
Depuis
3.9.0

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = []
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
3.9.0

Références $model, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Controller/RequestController.php


Joomla CMS: Référence de la classe RequestsController

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Controller
  • RequestsController
Fonctions membres publiques
Référence de la classe RequestsController
+ Graphe d'héritage de RequestsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Request', $prefix='Administrator', $config=['ignore_request'=> true])
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Requests management controller class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getModel()

getModel | ( |  | $name = 'Request',
 |  |  | $prefix = 'Administrator',
 |  |  | $config = ['ignore_request' =,
 |  | true] |
 | ) |  |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
BaseDatabaseModel|boolean Model object on success; otherwise false on failure.
Depuis
3.9.0

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Controller/RequestsController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Component dispatcher class for com_privacy

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Method to check component access permission

Renvoie
void
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe Domain

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Export
  • Domain
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe Domain

Fonctions membres publiques

addItem (Item $item)
getItems ()

Champs de données

$name
$description

Attributs protégés

$items = []

Description détaillée

Data object representing all data contained in a domain.

A domain is typically a single database table and the items within the domain are separate rows from the table.

Depuis
3.9.0

Documentation des fonctions membres

◆ addItem()

addItem ( Item $item )

Add an item to the domain

Paramètres
Item $item The item to add
Renvoie
void
Depuis
3.9.0

Références $item, et items.

◆ getItems()

getItems ( )

Get the domain's items

Renvoie
Item[]
Depuis
3.9.0

Références $items.

Documentation des champs

◆ $description

$description

◆ $items

$items = []
protected

◆ $name

$name
La documentation de cette classe a été générée à partir du fichier suivant :
  • Domain.php


Joomla CMS: Référence de la classe Field

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Export
  • Field
Champs de données
Référence de la classe Field

Champs de données

$name
$value

Description détaillée

Data object representing a field within an item.

Depuis
3.9.0

Documentation des champs

◆ $name

$name

◆ $value

$value
La documentation de cette classe a été générée à partir du fichier suivant :
  • Field.php


Joomla CMS: Référence de la classe Item

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Export
  • Item
Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe Item

Fonctions membres publiques

addField (Field $field)
getFields ()

Champs de données

$id

Attributs protégés

$fields = []

Description détaillée

Data object representing a single item within a domain.

An item is typically a single row from a database table.

Depuis
3.9.0

Documentation des fonctions membres

◆ addField()

addField ( Field $field )

Add a field to the item

Paramètres
Field $field The field to add
Renvoie
void
Depuis
3.9.0

Références $field, et fields.

◆ getFields()

getFields ( )

Get the item's fields

Renvoie
Field[]
Depuis
3.9.0

Références $fields.

Documentation des champs

◆ $fields

$fields = []
protected

◆ $id

$id
La documentation de cette classe a été générée à partir du fichier suivant :
  • Item.php


Joomla CMS: Référence de la classe PrivacyComponent

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Extension
  • PrivacyComponent
Fonctions membres publiques
Référence de la classe PrivacyComponent
+ Graphe d'héritage de PrivacyComponent:
MVCComponent BootableExtensionInterface RouterServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_privacy

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyComponent.php


Joomla CMS: Référence de la classe RequeststatusField

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Field
  • RequeststatusField
Champs de données | Attributs protégés
Référence de la classe RequeststatusField
+ Graphe d'héritage de RequeststatusField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'RequestStatus'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to load a list of request statuses

Depuis
3.9.0

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= [
'-1' => 'COM_PRIVACY_STATUS_INVALID'

◆ $type

$type = 'RequestStatus'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RequeststatusField.php


Joomla CMS: Référence de la classe RequesttypeField

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Field
  • RequesttypeField
Champs de données | Attributs protégés
Référence de la classe RequesttypeField
+ Graphe d'héritage de RequesttypeField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'RequestType'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Form Field to load a list of request types

Depuis
3.9.0

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= [
'export' => 'COM_PRIVACY_HEADING_REQUEST_TYPE_TYPE_EXPORT'

◆ $type

$type = 'RequestType'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RequesttypeField.php


Joomla CMS: Référence de la classe PrivacyHelper

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Helper
  • PrivacyHelper
Fonctions membres publiques statiques
Référence de la classe PrivacyHelper
+ Graphe d'héritage de PrivacyHelper:
ContentHelper

Fonctions membres publiques statiques

static | renderDataAsXml (array $exportData)
static | getPrivacyConsentPluginId ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Privacy component helper.

Depuis
3.9.0

Documentation des fonctions membres

◆ getPrivacyConsentPluginId()

static getPrivacyConsentPluginId ( )
static

Gets the privacyconsent system plugin extension id.

Renvoie
integer The privacyconsent system plugin extension id.
Depuis
3.9.2

Références $db, $query, et Factory\getDbo().

◆ renderDataAsXml()

static renderDataAsXml ( array $exportData )
static

Render the data request as a XML document.

Paramètres
Domain[] $exportData The data to be exported.
Renvoie
string
Depuis
3.9.0

Références $field, et $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyHelper.php


Joomla CMS: Référence de la classe CapabilitiesModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • CapabilitiesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe CapabilitiesModel
+ Graphe d'héritage de CapabilitiesModel:
BaseModel CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getCapabilities ()
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)

Fonctions membres protégées

populateState ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Capabilities model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getCapabilities()

getCapabilities ( )

Retrieve the extension capabilities.

Renvoie
array
Depuis
3.9.0

Références $app, Text\_(), Factory\getApplication(), PluginHelper\importPlugin(), JPATH_ADMINISTRATOR, et Text\sprintf().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Renvoie
void
Depuis
3.9.0

Références ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CapabilitiesModel.php


Joomla CMS: Référence de la classe ConsentsModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • ConsentsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ConsentsModel
+ Graphe d'héritage de ConsentsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[])
invalidate ($pks)
invalidateAll ($subject)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.id', $direction='desc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Consents management model class.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
3.9.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
DatabaseQuery
Depuis
3.9.0

Références $db, $direction, $ordering, $query, $state, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string
Depuis
3.9.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ invalidate()

invalidate ( $pks )

Method to invalidate specific consents.

Paramètres
array $pks The ids of the consents to invalidate.
Renvoie
boolean True on success.

Références $db, $query, Joomla\Database\getDatabase(), et ArrayHelper\toInteger().

◆ invalidateAll()

invalidateAll ( $subject )

Method to invalidate a group of specific consents.

Paramètres
array $subject The subject of the consents to invalidate.
Renvoie
boolean True on success.

Références $db, $query, $subject, et Joomla\Database\getDatabase().

◆ populateState()

populateState | ( | $ordering = 'a.id',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.9.0

Références $direction, $ordering, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsentsModel.php


Joomla CMS: Référence de la classe ExportModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • ExportModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ExportModel
+ Graphe d'héritage de ExportModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($name='Request', $prefix='Administrator', $options=[])
logExport (RequestTable $request)
logExportEmailed (RequestTable $request)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getActionlogModel ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Export model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getActionlogModel()

getActionlogModel ( )
private

Method to fetch an instance of the action log model.

Renvoie
ActionlogModel
Depuis
4.0.0

Références Factory\getApplication().

◆ getTable()

getTable | ( | $name = 'Request',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Exceptions

Références $name, $options, et $prefix.

◆ logExport()

logExport ( RequestTable $request )

Log the data export to the action log system.

Paramètres
RequestTable $request The request record being processed
Renvoie
void
Depuis
3.9.0

Références $message, $user, et Factory\getUser().

◆ logExportEmailed()

logExportEmailed ( RequestTable $request )

Log the data export email to the action log system.

Paramètres
RequestTable $request The request record being processed
Renvoie
void
Depuis
3.9.0

Références $message, $user, et Factory\getUser().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Renvoie
void
Depuis
3.9.0

Références Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExportModel.php


Joomla CMS: Référence de la classe RemoveModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • RemoveModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RemoveModel
+ Graphe d'héritage de RemoveModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($name='Request', $prefix='Administrator', $options=[])
logRemove (RequestTable $request)
logRemoveBlocked (RequestTable $request, array $reasons)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getActionlogModel ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Remove model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getActionlogModel()

getActionlogModel ( )
private

Method to fetch an instance of the action log model.

Renvoie
ActionlogModel
Depuis
4.0.0

Références Factory\getApplication().

◆ getTable()

getTable | ( | $name = 'Request',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Exceptions

Références $name, $options, et $prefix.

◆ logRemove()

logRemove ( RequestTable $request )

Log the data removal to the action log system.

Paramètres
RequestTable $request The request record being processed
Renvoie
void
Depuis
3.9.0

Références $message, $user, et Factory\getUser().

◆ logRemoveBlocked()

logRemoveBlocked | ( | RequestTable | $request,
 |  | array | $reasons
 | ) |  |

Log the data removal being blocked to the action log system.

Paramètres
RequestTable | $request | The request record being processed
string[] | $reasons The reasons given why the record could not be removed.
Renvoie
void
Depuis
3.9.0

Références $message, $user, et Factory\getUser().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Renvoie
void
Depuis
3.9.0

Références Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RemoveModel.php


Joomla CMS: Référence de la classe RequestModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • RequestModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RequestModel
+ Graphe d'héritage de RequestModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getTable ($name='Request', $prefix='Administrator', $options=[])
save ($data)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

cleanCache ($group='com_privacy')
loadFormData ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getActionlogModel ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Request item model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ cleanCache()

cleanCache ( $group = 'com_privacy' )
protected

Clean the cache

Paramètres
string $group The cache group
Renvoie
void
Depuis
3.9.0

◆ getActionlogModel()

getActionlogModel ( )
private

Method to fetch an instance of the action log model.

Renvoie
ActionlogModel
Depuis
4.0.0

Références Factory\getApplication().

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
3.9.0

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getTable()

getTable | ( | $name = 'Request',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Exceptions

Références $name, $options, et $prefix.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
3.9.0

Références $data, et Factory\getApplication().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success, False on error.
Depuis
3.9.0

Références $data, $key, Text\_(), Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
JFilterInput
Depuis
3.9.0

Références $data, $db, $form, $query, Text\_(), Joomla\Database\getDatabase(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/Model/RequestModel.php


Joomla CMS: Référence de la classe RequestsModel

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Model
  • RequestsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RequestsModel
+ Graphe d'héritage de RequestsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[])
getNumberUrgentRequests ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.id', $direction='desc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Requests management model class.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Depuis
3.9.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Method to get a DatabaseQuery object for retrieving the data set from a database.

Renvoie
DatabaseQuery
Depuis
3.9.0

Références $db, $direction, $ordering, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getNumberUrgentRequests()

getNumberUrgentRequests ( )

Method to return number privacy requests older than X days.

Renvoie
integer
Depuis
3.9.0

Références $db, $now, $params, $query, ComponentHelper\getComponent(), Joomla\Database\getDatabase(), et Factory\getDate().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string
Depuis
3.9.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.id',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.9.0

Références $direction, $ordering, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestsModel.php


Joomla CMS: Référence de la classe PrivacyPlugin

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Plugin
  • PrivacyPlugin
Fonctions membres protégées | Attributs protégés
Référence de la classe PrivacyPlugin
+ Graphe d'héritage de PrivacyPlugin:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface PlgPrivacyActionlogs PlgPrivacyConsents PlgPrivacyContact PlgPrivacyContent PlgPrivacyMessage PlgPrivacyUser

Fonctions membres protégées

createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Base class for privacy plugins

Depuis
3.9.0

Documentation des fonctions membres

◆ createCustomFieldsDomain()

createCustomFieldsDomain | ( | $context,
 |  | $items = array()
 | ) |
protected

Helper function to create the domain for the items custom fields.

Paramètres
string | $context | The context
array | $items | The items
Renvoie
Domain
Depuis
3.9.0

Références $context, $data, $field, $fields, $fieldValue, $item, $items, $parts, $type, FieldsHelper\extract(), et FieldsHelper\getFields().

◆ createDomain()

createDomain | ( | $name,
 |  | $description = ''
 | ) |
protected

Create a new domain object

Paramètres
string | $name | The domain's name
string | $description | The domain's description
Renvoie
Domain
Depuis
3.9.0

Références $description, et $name.

◆ createItemForTable()

createItemForTable ( $table )
protected

Create an item object for a Table object

Paramètres
Table $table The Table object to convert
Renvoie
Item
Depuis
3.9.0

Références $data.

◆ createItemFromArray()

createItemFromArray | ( | array | $data,
 |  |  | $itemId = null
 | ) |  |
protected

Create an item object for an array

Paramètres
array | $data | The array data to convert
integer | null | $itemId | The ID of this item
Renvoie
Item
Depuis
3.9.0

Références $data, $field, $item, $itemId, $key, et $value.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyPlugin.php


Joomla CMS: Référence de la classe Status

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Removal
  • Status
Champs de données
Référence de la classe Status

Champs de données

$canRemove = true
$reason

Description détaillée

Data object communicating the status of whether the data for an information request can be removed.

Typically, this object will only be used to communicate data will be removed.

Depuis
3.9.0

Documentation des champs

◆ $canRemove

$canRemove = true

◆ $reason

$reason
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_privacy/src/Removal/Status.php


Joomla CMS: Référence de la classe Privacy

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Service
  • HTML
  • Privacy
Fonctions membres publiques
Référence de la classe Privacy

Fonctions membres publiques

statusLabel ($status)

Description détaillée

Privacy component HTML helper.

Depuis
3.9.0

Documentation des fonctions membres

◆ statusLabel()

statusLabel ( $status )

Render a status badge

Paramètres
integer $status The item status
Renvoie
string
Depuis
3.9.0

Références Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Privacy.php


Joomla CMS: Référence de la classe ConsentTable

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Table
  • ConsentTable
Fonctions membres publiques
Référence de la classe ConsentTable
+ Graphe d'héritage de ConsentTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=false)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

The class constructor.

Paramètres
DatabaseDriver $db DatabaseInterface connector object.
Depuis
3.9.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ store()

store ( $updateNulls = false )

Method to store a row in the database from the Table instance properties.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.9.0

Implémente TableInterface.

Références $date, et Factory\getDate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsentTable.php


Joomla CMS: Référence de la classe RequestTable

  • Joomla
  • Component
  • Privacy
  • Administrator
  • Table
  • RequestTable
Fonctions membres publiques | Attributs protégés
Référence de la classe RequestTable
+ Graphe d'héritage de RequestTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=true)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

The class constructor.

Paramètres
DatabaseDriver $db DatabaseDriver connector object.
Depuis
3.9.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ store()

store ( $updateNulls = true )

Method to store a row in the database from the Table instance properties.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.9.0

Implémente TableInterface.

Références $date, Factory\getDate(), et null.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Capabilities
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$capabilities
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Capabilities view class

Depuis
3.9.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.9.0

Références Text\_(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
BaseHtmlView::loadTemplate()
Depuis
3.9.0
Exceptions

Implémente ViewInterface.

Documentation des champs

◆ $capabilities

$capabilities
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/View/Capabilities/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Consents
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$activeFilters
$filterForm
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

Consents view class

Depuis
3.9.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.9.0

Références Text\_(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/View/Consents/HtmlView.php


Joomla CMS: Référence de la classe XmlView

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Export
  • XmlView
Référence de la classe XmlView
+ Graphe d'héritage de XmlView:
AbstractView CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_privacy/src/View/Export/XmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Request
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$actionlogs
$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

Request view class

Depuis
3.9.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.9.0

Références $return, Text\_(), Route\_(), ToolbarHelper\cancel(), Factory\getApplication(), Session\getFormToken(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\link(), ToolbarHelper\save(), et ToolbarHelper\title().

Documentation des champs

◆ $actionlogs

$actionlogs
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/View/Request/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Administrator
  • View
  • Requests
  • HtmlView
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Champs de données

$activeFilters
$filterForm
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$sendMailEnabled
$state
$urgentRequestAge
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Description détaillée

Requests view class

Depuis
3.9.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.9.0

Références Text\_(), ToolbarHelper\addNew(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $sendMailEnabled

$sendMailEnabled
protected

◆ $state

$state
protected

◆ $urgentRequestAge

$urgentRequestAge
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_privacy/src/View/Requests/HtmlView.php


Joomla CMS: Référence de la classe ConsentsController

  • Joomla
  • Component
  • Privacy
  • Api
  • Controller
  • ConsentsController
Fonctions membres publiques | Attributs protégés
Référence de la classe ConsentsController
+ Graphe d'héritage de ConsentsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$contentType = 'consents'
$default_view = 'consents'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The consents controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id, et null.

Documentation des champs

◆ $contentType

$contentType = 'consents'
protected

◆ $default_view

$default_view = 'consents'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_privacy/src/Controller/ConsentsController.php


Joomla CMS: Référence de la classe RequestsController

  • Joomla
  • Component
  • Privacy
  • Api
  • Controller
  • RequestsController
Attributs protégés
Référence de la classe RequestsController
+ Graphe d'héritage de RequestsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'requests'
$default_view = 'requests'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The requests controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'requests'
protected

◆ $default_view

$default_view = 'requests'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_privacy/src/Controller/RequestsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Privacy
  • Api
  • View
  • Consents
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The consents view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'user_id',
'state',
'created',
'subject',
'body',
'remind',
'token',
'username',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'user_id',
'state',
'created',
'subject',
'body',
'remind',
'token',
'username',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_privacy/src/View/Consents/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Privacy
  • Api
  • View
  • Requests
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem = ['id', 'typeAlias', 'email', 'requested_at', 'status', 'request_type']
$fieldsToRenderList = ['id', 'email', 'requested_at', 'status', 'request_type']
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The requests view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem = ['id', 'typeAlias', 'email', 'requested_at', 'status', 'request_type']
protected

◆ $fieldsToRenderList

$fieldsToRenderList = ['id', 'email', 'requested_at', 'status', 'request_type']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_privacy/src/View/Requests/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Privacy
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Privacy Controller

Depuis
3.9.0

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = []
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
$this
Depuis
3.9.0

Références $this, $view, et Route\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe RequestController

  • Joomla
  • Component
  • Privacy
  • Site
  • Controller
  • RequestController
Référence de la classe RequestController
+ Graphe d'héritage de RequestController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Request action controller class.

Depuis
3.9.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/Controller/RequestController.php


Joomla CMS: Référence de la classe ConfirmModel

  • Joomla
  • Component
  • Privacy
  • Site
  • Model
  • ConfirmModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ConfirmModel
+ Graphe d'héritage de ConfirmModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getTable ($name='Request', $prefix='Administrator', $options=[])
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getActionlogModel ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Request confirmation model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getActionlogModel()

getActionlogModel ( )
private

Method to fetch an instance of the action log model.

Renvoie
ActionlogModel
Depuis
4.0.0

Références Factory\getApplication().

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
3.9.0

Implémente FormModelInterface.

Références $form, $input, Factory\getApplication(), et Joomla\CMS\MVC\Model\loadForm().

◆ getTable()

getTable | ( | $name = 'Request',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Depuis
3.9.0
Exceptions

Références $name, $options, et $prefix.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.9.0

Références $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfirmModel.php


Joomla CMS: Référence de la classe RemindModel

  • Joomla
  • Component
  • Privacy
  • Site
  • Model
  • RemindModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RemindModel
+ Graphe d'héritage de RemindModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getTable ($name='Consent', $prefix='Administrator', $options=[])
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Remind confirmation model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
3.9.0

Implémente FormModelInterface.

Références $form, $input, Factory\getApplication(), et Joomla\CMS\MVC\Model\loadForm().

◆ getTable()

getTable | ( | $name = 'Consent',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Exceptions

Références $name, $options, et $prefix.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.9.0

Références $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_privacy/src/Model/RemindModel.php


Joomla CMS: Référence de la classe RequestModel

  • Joomla
  • Component
  • Privacy
  • Site
  • Model
  • RequestModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RequestModel
+ Graphe d'héritage de RequestModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=[], $loadData=true)
getTable ($name='Request', $prefix='Administrator', $options=[])
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

getActionlogModel ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Request model class.

Depuis
3.9.0

Documentation des fonctions membres

◆ getActionlogModel()

getActionlogModel ( )
private

Method to fetch an instance of the action log model.

Renvoie
ActionlogModel
Depuis
4.0.0

Références Factory\getApplication().

◆ getForm()

getForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
3.9.0

Implémente FormModelInterface.

Références Joomla\CMS\MVC\Model\loadForm().

◆ getTable()

getTable | ( | $name = 'Request',
 |  | $prefix = 'Administrator',
 |  | $options = []
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $name | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $options | Configuration array for model. Optional.
Renvoie
Table A Table object
Exceptions

Références $name, $options, et $prefix.

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
3.9.0

Références $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/Model/RequestModel.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Privacy
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct ($app=null, $menu=null)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Description détaillée

Routing class from com_privacy

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $app = null,
 |  | $menu = null
 | ) |

Privacy Component router constructor

Paramètres
CMSApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with
Depuis
3.9.0

Références $app, $menu, $this, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Confirm
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$pageclass_sfx
$params
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Request confirmation view class

Depuis
3.9.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
BaseHtmlView::loadTemplate()
Depuis
3.9.0
Exceptions

Implémente ViewInterface.

Références ENT_COMPAT.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
3.9.0

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/View/Confirm/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Remind
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$pageclass_sfx
$params
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Remind confirmation view class

Depuis
3.9.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
BaseHtmlView::loadTemplate()
Depuis
3.9.0
Exceptions

Implémente ViewInterface.

Références ENT_COMPAT.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
3.9.0

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/View/Remind/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Privacy
  • Site
  • View
  • Request
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$pageclass_sfx
$params
$sendMailEnabled
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Request view class

Depuis
3.9.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Voir également
BaseHtmlView::loadTemplate()
Depuis
3.9.0
Exceptions

Implémente ViewInterface.

Références ENT_COMPAT, et Factory\getApplication().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
3.9.0

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx
protected

◆ $params

$params
protected

◆ $sendMailEnabled

$sendMailEnabled
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_privacy/src/View/Request/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'links'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Redirect master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached.
mixed | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $link, $view, Text\_(), Route\_(), HTMLHelper\_(), RedirectHelper\collectUrlsEnabled(), RedirectHelper\getRedirectPluginId(), PluginHelper\isEnabled(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'links'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_redirect/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe LinkController

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Controller
  • LinkController
Référence de la classe LinkController
+ Graphe d'héritage de LinkController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Redirect link controller class.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • LinkController.php


Joomla CMS: Référence de la classe LinksController

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Controller
  • LinksController
Fonctions membres publiques
Référence de la classe LinksController
+ Graphe d'héritage de LinksController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

activate ()
duplicateUrls ()
getModel ($name='Link', $prefix='Administrator', $config=array('ignore_request'=> true))
batch ()
purge ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Redirect link list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ activate()

activate ( )

Method to update a record.

Renvoie
void
Depuis
1.6

Références $model, Text\_(), Joomla\Application\checkToken(), et Text\plural().

◆ batch()

batch ( )

Executes the batch process to add URLs to the database

Renvoie
void

Références $model, $params, $separator, Text\_(), Joomla\Application\checkToken(), ComponentHelper\getParams(), Text\plural(), et Text\sprintf().

◆ duplicateUrls()

duplicateUrls ( )

Method to duplicate URLs in records.

Renvoie
void
Depuis
3.6.0

Références $model, Text\_(), Joomla\Application\checkToken(), et Text\plural().

◆ getModel()

getModel | ( | $name = 'Link',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The name of the model.
string | $prefix | The prefix of the model.
array | $config | An array of settings.
Renvoie
The model instance
Depuis
1.6

Références $config, $name, et $prefix.

◆ purge()

purge ( )

Clean out the unpublished links.

Renvoie
void
Depuis
3.5

Références $message, $model, Text\_(), et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LinksController.php


Joomla CMS: Référence de la classe RedirectComponent

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Extension
  • RedirectComponent
Fonctions membres publiques
Référence de la classe RedirectComponent
+ Graphe d'héritage de RedirectComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_redirect

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectComponent.php


Joomla CMS: Référence de la classe RedirectField

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Field
  • RedirectField
Fonctions membres protégées | Attributs protégés
Référence de la classe RedirectField
+ Graphe d'héritage de RedirectField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Redirect'
$responseMap
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field input markup.

Renvoie
array The field input markup.
Depuis
3.4

Références $key, $options, $value, et HTMLHelper\_().

Documentation des champs

◆ $responseMap

$responseMap
protected

◆ $type

$type = 'Redirect'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectField.php


Joomla CMS: Référence de la classe RedirectHelper

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Helper
  • RedirectHelper
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe RedirectHelper
+ Graphe d'héritage de RedirectHelper:
RedirectHelper

Fonctions membres publiques statiques

static | publishedOptions ()
static | getRedirectPluginId ()
static | collectUrlsEnabled ()

Attributs publics statiques

static $extension = 'com_redirect'

Description détaillée

Redirect component helper.

Depuis
1.6

Documentation des fonctions membres

◆ collectUrlsEnabled()

static collectUrlsEnabled ( )
static

Checks whether the option "Collect URLs" is enabled for the output message

Renvoie
boolean
Depuis
3.4

Références $params, PluginHelper\getPlugin(), et PluginHelper\isEnabled().

Référencé par DisplayController\display(), et HtmlView\display().

◆ getRedirectPluginId()

static getRedirectPluginId ( )
static

Gets the redirect system plugin extension id.

Renvoie
integer The redirect system plugin extension id.
Depuis
3.6.0

Références $db, $query, $result, Factory\getApplication(), et Factory\getDbo().

Référencé par DisplayController\display(), et HtmlView\display().

◆ publishedOptions()

static publishedOptions ( )
static

Returns an array of standard published state filter options.

Renvoie
array An array containing the options
Depuis
1.6

Références $options, et HTMLHelper\_().

Documentation des champs

◆ $extension

$extension = 'com_redirect'
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectHelper.php


Joomla CMS: Référence de la classe LinkModel

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Model
  • LinkModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe LinkModel
+ Graphe d'héritage de LinkModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
activate (&$pks, $url, $comment=null)
duplicateUrls (&$pks, $url, $comment=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
loadFormData ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_REDIRECT'
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Redirect link model.

Depuis
1.6

Documentation des fonctions membres

◆ activate()

activate | ( | & | $pks,
 |  |  | $url,
 |  |  | $comment = null
 | ) |  |

Method to activate links.

Paramètres
array | &$pks | An array of link ids.
string | $url | The new URL to set for the redirect.
string | $comment | A comment for the redirect links.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6

Références $db, $query, $url, $user, Text\_(), HTMLHelper\_(), Joomla\Database\getDatabase(), Factory\getUser(), Text\sprintf(), et ArrayHelper\toInteger().

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

◆ duplicateUrls()

duplicateUrls | ( | & | $pks,
 |  |  | $url,
 |  |  | $comment = null
 | ) |  |

Method to batch update URLs to have new redirect urls and comments. Note will publish any unpublished URLs.

Paramètres
array | &$pks | An array of link ids.
string | $url | The new URL to set for the redirect.
string | $comment | A comment for the redirect links.
Renvoie
boolean Returns true on success, false on failure.
Depuis
3.6.0

Références $date, $db, $query, $url, $user, Text\_(), Joomla\Database\getDatabase(), Factory\getDate(), Factory\getUser(), et ArrayHelper\toInteger().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
A JForm object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $data, $form, ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_REDIRECT'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LinkModel.php


Joomla CMS: Référence de la classe LinksModel

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Model
  • LinksModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LinksModel
+ Graphe d'héritage de LinksModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
purge ()
batchProcess ($batchUrls)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.old_url', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of redirect links.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ batchProcess()

batchProcess ( $batchUrls )

Add the entered URLs into the database

Paramètres
array $batchUrls Array of URLs to enter into the database
Renvoie
boolean

Références $columns, $db, $params, $query, $state, Joomla\Database\getDatabase(), Factory\getDate(), ComponentHelper\getParams(), et ParameterType\INTEGER.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $db, $query, $state, $this, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.old_url',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ purge()

purge ( )

Removes all of the unpublished redirects from the table.

Renvoie
boolean result of operation
Depuis
3.5

Références $db, $query, et Joomla\Database\getDatabase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LinksModel.php


Joomla CMS: Référence de la classe Redirect

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Service
  • HTML
  • Redirect
Fonctions membres publiques
Référence de la classe Redirect

Fonctions membres publiques

published ($value=0, $i=null, $canChange=true)

Description détaillée

Utility class for creating HTML Grids.

Depuis
1.6

Documentation des fonctions membres

◆ published()

published | ( | $value = 0,
 |  | $i = null,
 |  | $canChange = true
 | ) |

Display the published or unpublished state of an item.

Paramètres
int | $value | The state value.
int | $i | The ID of the item.
boolean | $canChange | An optional prefix for the task.
Renvoie
string
Depuis
1.6
Exceptions

Références $canChange, $html, $i, $icon, $state, $value, ArrayHelper\getValue(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Redirect.php


Joomla CMS: Référence de la classe LinkTable

  • Joomla
  • Component
  • Redirect
  • Administrator
  • Table
  • LinkTable
Fonctions membres publiques
Référence de la classe LinkTable
+ Graphe d'héritage de LinkTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Link Table for Redirect.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database object.
Depuis
1.6

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check function

Renvoie
boolean
Depuis
1.6

Implémente TableInterface.

Références $db, $query, $url, $urls, Text\_(), elseif, Joomla\CMS\MVC\Model\getDbo(), et ComponentHelper\getParams().

◆ store()

store ( $updateNulls = false )

Overridden store method to set dates.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $created_date, $date, Factory\getDate(), et modified_date.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_redirect/src/Table/LinkTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Redirect
  • Administrator
  • View
  • Link
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$item
$form
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a redirect link.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

This component does not support Save as Copy due to uniqueness checks. While it can be done, it causes too much confusion if the user does not change the Old URL.

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed False if unsuccessful, otherwise void.
Depuis
1.6

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_redirect/src/View/Link/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Redirect
  • Administrator
  • View
  • Links
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$enabled
$collect_urls_enabled
$redirectPluginId = 0
$items
$pagination
$state
$params
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

View class for a list of redirection links.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $state, $toolbar, Text\_(), elseif, ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions
GenericDataException
Depuis
1.6

Implémente ViewInterface.

Références RedirectHelper\collectUrlsEnabled(), ComponentHelper\getParams(), RedirectHelper\getRedirectPluginId(), PluginHelper\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $collect_urls_enabled

$collect_urls_enabled
protected

◆ $enabled

$enabled
protected

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $params

$params
protected

◆ $redirectPluginId

$redirectPluginId = 0
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_redirect/src/View/Links/HtmlView.php


Joomla CMS: Référence de la classe RedirectController

  • Joomla
  • Component
  • Redirect
  • Api
  • Controller
  • RedirectController
Attributs protégés
Référence de la classe RedirectController
+ Graphe d'héritage de RedirectController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'links'
$default_view = 'redirect'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The redirect controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'links'
protected

◆ $default_view

$default_view = 'redirect'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Redirect
  • Api
  • View
  • Redirect
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The redirect view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'old_url',
'new_url',
'referer',
'comment',
'hits',
'published',
'created_date',
'modified_date',
'header',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'old_url',
'new_url',
'referer',
'comment',
'hits',
'published',
'created_date',
'modified_date',
'header',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_redirect/src/View/Redirect/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'tasks'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

validateEntry (string $layout='edit')

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Default controller for com_scheduler.

Depuis
4.1.0

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |
Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe url parameters and their variable types, for valid values see InputFilter::clean().
Renvoie
BaseController|boolean Returns either a BaseController object to support chaining, or false on failure
Depuis
4.1.0
Exceptions

Références $layout, et Route\_().

◆ validateEntry()

validateEntry ( string $layout = 'edit' )
private

Validates entry to the view

Paramètres
string $layout The layout to validate entry for (defaults to 'edit')
Renvoie
boolean True is entry is valid
Depuis
4.1.0

Références $context, $id, $layout, Text\_(), elseif, et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'tasks'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_scheduler/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe TaskController

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Controller
  • TaskController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TaskController
+ Graphe d'héritage de TaskController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

cancel ($key=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

MVC Controller for the item configuration page (TaskView).

Depuis
4.1.0

Documentation des fonctions membres

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Check if user has the authority to edit an asset

Paramètres
array | $data | Array of input data
string | $key | Name of key for primary key, defaults to 'id'
Renvoie
boolean True if user is allowed to edit record
Depuis
4.1.0

Zero record (id:0), return component edit permission by calling parent controller method ?: Is this the right way to do this?

Références $data, $key, et $recordId.

◆ cancel()

cancel ( $key = null )

Override parent cancel method to reset the add task state

Paramètres
?string $key Primary key from the URL param
Renvoie
boolean True if access level checks pass
Depuis
4.1.0

Références $key, $result, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskController.php


Joomla CMS: Référence de la classe TasksController

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Controller
  • TasksController
Fonctions membres publiques
Référence de la classe TasksController
+ Graphe d'héritage de TasksController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Task', $prefix='Administrator', $config=['ignore_request'=> true])
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

MVC Controller for TasksView.

Depuis
4.1.0

Documentation des fonctions membres

◆ getModel()

getModel | ( |  | $name = 'Task',
 |  |  | $prefix = 'Administrator',
 |  |  | $config = ['ignore_request' =,
 |  | true] |
 | ) |  |

Proxy for the parent method.

Paramètres
string | $name | The name of the model.
string | $prefix | The prefix for the PHP class name.
array | $config | Array of configuration parameters.
Renvoie
BaseDatabaseModel
Depuis
4.1.0

Références $config, $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TasksController.php


Joomla CMS: Référence de la classe ExecuteTaskEvent

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Event
  • ExecuteTaskEvent
Fonctions membres publiques
Référence de la classe ExecuteTaskEvent
+ Graphe d'héritage de ExecuteTaskEvent:
AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=array())
setResult (array $snapshot=[])
getTaskId ()
getRoutineId ()
getResultSnapshot ()
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event class for onExecuteTask event.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = array()
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
4.1.0
Exceptions

Références $name, Symfony\Contracts\Service\__construct(), class, et null.

Documentation des fonctions membres

◆ getResultSnapshot()

getResultSnapshot ( )

Returns the snapshot of the triggered task if available, else an empty array

Renvoie
array The task snapshot if available, else null
Depuis
4.1.0

◆ getRoutineId()

getRoutineId ( )
Renvoie
string The task's 'type'.
Depuis
4.1.0

Référencé par SiteStatus\alterSiteStatus(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ getTaskId()

getTaskId ( )
Renvoie
integer The task's taskId.
Depuis
4.1.0

Référencé par Requests\makeGetRequest().

◆ setResult()

setResult ( array $snapshot = [] )

Sets the task result snapshot and stops event propagation.

Paramètres
array $snapshot The task snapshot.
Renvoie
void
Depuis
4.1.0

Référencé par Joomla\Component\Scheduler\Administrator\Traits\endRoutine().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExecuteTaskEvent.php


Joomla CMS: Référence de la classe SchedulerComponent

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Extension
  • SchedulerComponent
Fonctions membres publiques
Référence de la classe SchedulerComponent
+ Graphe d'héritage de SchedulerComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_scheduler.

Depuis
4.1.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.1.0

Implémente BootableExtensionInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SchedulerComponent.php


Joomla CMS: Référence de la classe CronField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • CronField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe CronField
+ Graphe d'héritage de CronField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'cronIntervals'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs privés

const | SUBTYPES
const | OPTIONS_RANGE
const | PREPARED_RESPONSE_LABELS
$subtype
$wildcard
$onlyNumericLabels

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Multi-select form field, supporting inputs of: minutes, hours, days of week, days of month and months.

Depuis
4.1.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get field options

Renvoie
array Array of objects representing options in the options list
Depuis
4.1.0

Références $i, $options, Text\_(), et HTMLHelper\_().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Override the parent method to set deal with subtypes.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.1.0

Références $value, et null.

Documentation des champs

◆ $onlyNumericLabels

$onlyNumericLabels
private

◆ $subtype

$subtype
private

◆ $type

$type = 'cronIntervals'
protected

◆ $wildcard

$wildcard
private

◆ OPTIONS_RANGE

const OPTIONS_RANGE
private
Valeur initiale :
= [
'minutes' => [0, 59]

◆ PREPARED_RESPONSE_LABELS

const PREPARED_RESPONSE_LABELS
private
Valeur initiale :
= [
'months' => [
'JANUARY', 'FEBRUARY', 'MARCH', 'APRIL', 'MAY', 'JUNE',
'JULY', 'AUGUST', 'SEPTEMBER', 'OCTOBER', 'NOVEMBER', 'DECEMBER',
]

◆ SUBTYPES

const SUBTYPES
private
Valeur initiale :
= [
'minutes',
'hours',
'days_month',
'months',
'days_week',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • CronField.php


Joomla CMS: Référence de la classe ExecutionRuleField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • ExecutionRuleField
Attributs protégés
Référence de la classe ExecutionRuleField
+ Graphe d'héritage de ExecutionRuleField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Attributs protégés

$type = 'ExecutionRule'
$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

A select list containing valid Cron interval types.

Depuis
4.1.0

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= [
'interval-minutes' => 'COM_SCHEDULER_EXECUTION_INTERVAL_MINUTES'

◆ $type

$type = 'ExecutionRule'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExecutionRuleField.php


Joomla CMS: Référence de la classe IntervalField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • IntervalField
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe IntervalField
+ Graphe d'héritage de IntervalField:
NumberField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de NumberField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'Intervals'
$max
$min
$step = 1
- Attributs protégés hérités de NumberField
$type = 'Number'
$max = null
$min = null
$step = 0
$layout = 'joomla.form.field.number'
$parentclass
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Attributs privés

const SUBTYPES

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de NumberField
getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Select style field for interval(s) in minutes, hours, days and months.

Depuis
4.1.0

Documentation des fonctions membres

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Override the parent method to set deal with subtypes.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Depuis
4.1.0

Références $value, null, et FormField\setup().

Documentation des champs

◆ $max

$max
protected

◆ $min

$min
protected

◆ $step

$step = 1
protected

◆ $type

$type = 'Intervals'
protected

◆ SUBTYPES

const SUBTYPES
private
Valeur initiale :
= [
'minutes' => [1, 59]
La documentation de cette classe a été générée à partir du fichier suivant :
  • IntervalField.php


Joomla CMS: Référence de la classe TaskStateField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • TaskStateField
Champs de données | Attributs protégés
Référence de la classe TaskStateField
+ Graphe d'héritage de TaskStateField:
PredefinedlistField ListField FormField DatabaseAwareInterface

Champs de données

$type = 'taskState'
- Champs de données hérités de FormField
$repeat = false

Attributs protégés

$predefinedOptions
- Attributs protégés hérités de PredefinedlistField
$type = 'Predefinedlist'
$predefinedOptions = array()
$translate = true
$optionsFilter = []
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de PredefinedlistField
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres protégées hérités de PredefinedlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de PredefinedlistField
static | $options = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

A predefined list field with all possible states for a com_scheduler entry.

Depuis
4.1.0

Documentation des champs

◆ $predefinedOptions

$predefinedOptions
protected
Valeur initiale :
= [
-2 => 'JTRASHED'

◆ $type

$type = 'taskState'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskStateField.php


Joomla CMS: Référence de la classe TaskTypeField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • TaskTypeField
Fonctions membres protégées | Attributs protégés
Référence de la classe TaskTypeField
+ Graphe d'héritage de TaskTypeField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'taskType'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

A list field with all available task routines.

Depuis
4.1.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get field options

Renvoie
array
Depuis
4.1.0
Exceptions

Références $options, $type, HTMLHelper\_(), et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'taskType'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskTypeField.php


Joomla CMS: Référence de la classe WebcronLinkField

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Field
  • WebcronLinkField
Fonctions membres protégées | Attributs protégés
Référence de la classe WebcronLinkField
+ Graphe d'héritage de WebcronLinkField:
TextField FormField DatabaseAwareInterface

Fonctions membres protégées

getLayoutPaths ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$layout = 'form.field.webcron_link'
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Field to override the text field layout to add a copy-text button, used in the com_scheduler configuration form. This field class is only needed because the layout file is in a non-global directory, so this should be made redundant and removed if/once the layout is shifted to JPATH_SITE/layout/

Depuis
4.1.0

Documentation des fonctions membres

◆ getLayoutPaths()

getLayoutPaths ( )
protected

Override layout paths.

Renvoie
string[]
Depuis
4.1.0

Références JPATH_ADMINISTRATOR.

Documentation des champs

◆ $layout

$layout = 'form.field.webcron_link'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebcronLinkField.php


Joomla CMS: Référence de la classe ExecRuleHelper

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Helper
  • ExecRuleHelper
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ExecRuleHelper

Fonctions membres publiques

__construct ($task)
nextExec (bool $string=true, bool $basisNow=false)

Fonctions membres privées

getFromTask (string $property, $default=null)
dateTimeToSql (\DateTime $dateTime)

Attributs privés

$type
$task
$rule

Description détaillée

Helper class for supporting task execution rules.

Depuis
4.1.0
Voir également
Task} class.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $task )
Paramètres
array | object $task A task entry
Depuis
4.1.0

Références $task, et ArrayHelper\fromObject().

Documentation des fonctions membres

◆ dateTimeToSql()

dateTimeToSql ( \DateTime $dateTime )
private

Returns a sql-formatted string for a DateTime object. Only needed for DateTime objects returned by CronExpression, JDate supports this as class method.

Paramètres
\DateTime $dateTime A DateTime object to format
Renvoie
string
Depuis
4.1.0

Références $db, class, et Factory\getContainer().

◆ getFromTask()

getFromTask | ( | string | $property,
 |  |  | $default = null
 | ) |  |
private

Get a property from the task array

Paramètres
string | $property | The property to get
mixed | $default | The default value returned if property does not exist
Renvoie
mixed
Depuis
4.1.0

Références $default, et ArrayHelper\getValue().

◆ nextExec()

nextExec | ( | bool | $string = true,
 |  | bool | $basisNow = false
 | ) |  |
Paramètres
boolean | $string | If true, an SQL formatted string is returned.
boolean | $basisNow | If true, the current date-time is used as the basis for projecting the next execution.
Renvoie
?Date|string
Depuis
4.1.0
Exceptions

Références Factory\getDate(), et null.

Documentation des champs

◆ $rule

$rule
private

◆ $task

$task
private

◆ $type

$type
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExecRuleHelper.php


Joomla CMS: Référence de la classe SchedulerHelper

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Helper
  • SchedulerHelper
Attributs protégés statiques
Référence de la classe SchedulerHelper

Attributs protégés statiques

static $taskOptionsCache

Description détaillée

The SchedulerHelper class. Provides static methods used across com_scheduler

Depuis
4.1.0

Documentation des champs

◆ $taskOptionsCache

$taskOptionsCache
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SchedulerHelper.php


Joomla CMS: Référence de la classe SelectModel

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Model
  • SelectModel
Fonctions membres publiques | Attributs protégés
Référence de la classe SelectModel
+ Graphe d'héritage de SelectModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), ?MVCFactoryInterface $factory=null)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Attributs protégés

$app
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

The MVC Model for SelectView.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | ?MVCFactoryInterface | $factory = null
 | ) |  |

SelectModel constructor.

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
?MVCFactoryInterface | $factory The factory.
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ getItems()

getItems ( )
Renvoie
TaskOption[] An array of TaskOption objects
Exceptions

Implémente ListModelInterface.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_scheduler/src/Model/SelectModel.php


Joomla CMS: Référence de la classe TaskModel

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Model
  • TaskModel
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe TaskModel
+ Graphe d'héritage de TaskModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
getForm ($data=array(), $loadData=true)
getTable ($name='Task', $prefix='Table', $options=array())
getItem ($pk=null)
getTask (array $options=[])
save ($data)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres publiques statiques

static | configureTaskGetterOptions (OptionsResolver $resolver)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')

Champs de données

const TASK_TABLE = '#__scheduler_tasks'
$typeAlias = 'com_scheduler.task'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
populateState ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

const TASK_STATES
$text_prefix = 'COM_SCHEDULER'
$app
$event_before_unlock = null
$event_unlock = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

processExecutionRules (array $unprocessedRules)
buildExecutionRules (array $executionRules)
wildcardIfMatch (array $target, array $reference, bool $targetToInt=false)

Membres hérités additionnels

- Attributs protégés statiques hérités de BaseModel
static $paths

Description détaillée

MVC Model to interact with the Scheduler DB. Implements methods to add, remove, edit tasks.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

TaskModel constructor. Needed just to set $app

Paramètres
array | $config | An array of configuration options
MVCFactoryInterface | null | $factory | The factory
FormFactoryInterface | null | $formFactory | The form factory
Depuis
4.1.0
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), elseif, et Factory\getApplication().

Documentation des fonctions membres

◆ buildExecutionRules()

buildExecutionRules ( array $executionRules )
private

Private method to build execution expression from input execution rules. This expression is used internally to determine execution times/conditions.

Paramètres
array $executionRules Execution rules from the Task form, post-processing.
Renvoie
array
Depuis
4.1.0
Exceptions

◆ canDelete()

canDelete ( $record )
protected

Determine whether a record may be deleted taking into consideration the user's permissions over the record.

Paramètres
object $record The database row/record in question
Renvoie
boolean True if the record may be deleted
Depuis
4.1.0
Exceptions

◆ configureTaskGetterOptions()

static configureTaskGetterOptions ( OptionsResolver $resolver )
static

Set up an {

Voir également
OptionsResolver} to resolve options compatible with the {
GetTask()} method.
Paramètres
OptionsResolver $resolver The {
Voir également
OptionsResolver} instance to set up.
Renvoie
OptionsResolver
Depuis
4.1.0
Exceptions
AccessException

Références OptionsResolver\setDefaults().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Fetches the form object associated with this model. By default, loads the corresponding data from the DB and binds it with the form.

Paramètres
array | $data | Data that needs to go into the form
bool | $loadData | Should the form load its data from the DB?
Renvoie
Form|boolean A JForm object on success, false on failure.
Depuis
4.1.0
Exceptions

loadForm() (defined by FormBehaviourTrait) also loads the form data by calling loadFormData() : $data [implemented here] and binds it to the form by calling $form->bind($data).

Implémente FormModelInterface.

Références $form, $this, $user, Form\addFieldPath(), Joomla\CMS\MVC\Model\getState(), JPATH_ADMINISTRATOR, Joomla\CMS\MVC\Model\loadForm(), et null.

◆ getItem()

getItem ( $pk = null )

Overloads the parent getItem() method.

Paramètres
integer $pk Primary key
Renvoie
object|boolean Object on success, false on failure
Depuis
4.1.0
Exceptions

Références $item, et $this.

◆ getTable()

getTable | ( | $name = 'Task',
 |  | $prefix = 'Table',
 |  | $options = array()
 | ) |

Don't need to define this method since the parent getTable() implicitly deduces $name and $prefix anyways. This makes the object more transparent though.

Paramètres
string | $name | Name of the table
string | $prefix | Class prefix
array | $options | Model config array
Renvoie
Table
Depuis
4.1.0
Exceptions

Références $name, $options, et $prefix.

◆ getTask()

getTask ( array $options = [] )

Get a task from the database, only if an exclusive "lock" on the task can be acquired. The method supports options to customise the limitations on the fetch.

Paramètres
array $options Array with options to fetch the task:
  1. id: Optional id of the task to fetch.
  2. allowDisabled: If true, disabled tasks can also be fetched. (default: false)
  3. bypassScheduling: If true, tasks that are not due can also be fetched. Should only be true if an id is targeted instead of the task queue. (default: false)
  4. allowConcurrent: If true, fetches even when another task is running ('locked'). (default: false)
  5. includeCliExclusive: If true, can also fetch CLI exclusive tasks. (default: true)
Renvoie
? Task entry as in the database.
Depuis
4.1.0
Exceptions
UndefinedOptionsException|InvalidOptionsException

Références $db, $now, $options, $task, Joomla\Database\getDatabase(), Factory\getDate(), ParameterType\INTEGER, null, et ParameterType\STRING.

◆ populateState()

populateState ( )
protected

Populate the model state, we use these instead of toying with input or the global state

Renvoie
void
Depuis
4.1.0
Exceptions

Références $app, ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
4.1.0
Exceptions

Références $data, $form, PluginHelper\importPlugin(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ processExecutionRules()

processExecutionRules ( array $unprocessedRules )
private

Clean up and standardise execution rules

Paramètres
array $unprocessedRules The form data [? can just replace with execution_interval]
Renvoie
array Processed rules
Depuis
4.1.0

◆ save()

save ( $data )
Paramètres
array $data The form data
Renvoie
boolean True on success, false on failure
Depuis
4.1.0
Exceptions

Références $data, $id, Factory\getDate(), Joomla\CMS\MVC\Model\getState(), et null.

◆ wildcardIfMatch()

wildcardIfMatch | ( | array | $target,
 |  | array | $reference,
 |  | bool | $targetToInt = false
 | ) |  |
private

Determine if an array is populated by all its possible values by comparison to a reference array, if found a match a wildcard '*' is returned.

Paramètres
array | $target | The target array
array | $reference | The reference array, populated by the complete set of possible values in $target
bool | $targetToInt | If true, converts $target array values to integers before comparing
Renvoie
string A wildcard string if $target is fully populated, else $target itself.
Depuis
4.1.0

Références $target.

Documentation des champs

◆ $app

AdministratorApplication $app
protected

The Application object, for convenience

Depuis
4.1.0

◆ $event_before_unlock

$event_before_unlock = null
protected

◆ $event_unlock

$event_unlock = null
protected

◆ $text_prefix

$text_prefix = 'COM_SCHEDULER'
protected

◆ $typeAlias

$typeAlias = 'com_scheduler.task'

◆ TASK_STATES

const TASK_STATES
protected
Valeur initiale :
= [
'enabled' => 1

◆ TASK_TABLE

const TASK_TABLE = '#__scheduler_tasks'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskModel.php


Joomla CMS: Référence de la classe TasksModel

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Model
  • TasksModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe TasksModel
+ Graphe d'héritage de TasksModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=[], MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getStoreId ($id='')
getListQuery ()
_getList ($query, $limitstart=0, $limit=0)
populateState ($ordering='a.title', $direction='ASC')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

attachTaskOptions (array $items)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

The MVC Model for TasksView. Defines methods to deal with operations concerning multiple #__scheduler_tasks entries.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = [],
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | null | $factory | The factory.
Depuis
4.1.0
Exceptions

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getList()

_getList | ( | $query,
 |  | $limitstart = 0,
 |  | $limit = 0
 | ) |
protected

Overloads the parent _getList() method. Takes care of attaching TaskOption objects and sorting by type titles.

Paramètres
DatabaseQuery | $query | The database query to get the list with
int | $limitstart | The list offset
int | $limit | Number of list items to fetch
Renvoie
object[]
Depuis
4.1.0
Exceptions

Références $limit, $listOrder, $query, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ attachTaskOptions()

attachTaskOptions ( array $items )
private

For an array of items, attaches TaskOption objects and (safe) type titles to each.

Paramètres
array $items Array of items, passed by reference
Renvoie
void
Depuis
4.1.0
Exceptions

Références $item, $items, et Text\_().

◆ getListQuery()

getListQuery ( )
protected

Method to create a query for a list of items.

Renvoie
QueryInterface
Depuis
4.1.0
Exceptions

Select the required fields from the table. ? Do we need all these defaults ? ? Does 'list.select' exist ?

Extends query if already filtered.

Paramètres
string | $outerGlue
array | $conditions
string | $innerGlue
Depuis
4.1.0

Références $db, $id, $now, $query, $state, $title, elseif, Joomla\Database\getDatabase(), Factory\getDate(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et ParameterType\STRING.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
4.1.0

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.title',
 |  | $direction = 'ASC'
 | ) |
protected

Proxy for the parent method. Sets ordering defaults.

Paramètres
string | $ordering | Field to order/sort list by
string | $direction | Direction in which to sort list
Renvoie
void
Depuis
4.1.0

Références $direction, $ordering, et Joomla\CMS\MVC\Model\populateState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TasksModel.php


Joomla CMS: Référence de la classe ExecutionRulesRule

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Rule
  • ExecutionRulesRule
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ExecutionRulesRule
+ Graphe d'héritage de ExecutionRulesRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Fonctions membres privées

validateField (\SimpleXMLElement $element, $value, ?string $group=null, ?Form $form=null)

Attributs privés

const | RULE_TYPE_FIELD = "execution_rules.rule-type"
const | CUSTOM_RULE_GROUP = "execution_rules.custom"

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

The ExecutionRulesRule Class. Validates execution rules, with input for other fields as context.

Depuis
4.1.0

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |
Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
?string | $group The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
?Registry | $input An optional Registry object with the entire data set to validate against the entire form.
?Form | $form The form object for which the field is being tested.
Renvoie
boolean
Depuis
4.1.0

Références $form, $input, et $value.

◆ validateField()

validateField | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  | ?string | $group = null,
 |  | ?Form | $form = null
 | ) |  |
private
Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement for the field.
mixed | $value | The field value.
?string | $group The form field group the element belongs to.
Form | null | $form | The Form object against which the field is tested/
Renvoie
boolean True if field is valid
Depuis
4.1.0

Références $form, $value, et null.

Documentation des champs

◆ CUSTOM_RULE_GROUP

const CUSTOM_RULE_GROUP = "execution_rules.custom"
private

◆ RULE_TYPE_FIELD

const RULE_TYPE_FIELD = "execution_rules.rule-type"
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExecutionRulesRule.php


Joomla CMS: Référence de la classe Scheduler

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Scheduler
  • Scheduler
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs privés
Référence de la classe Scheduler

Fonctions membres publiques

fetchTaskRecord (int $id=0, bool $allowDisabled=false)

Champs de données

const | TASK_QUEUE_FILTERS
const const | TASK_QUEUE_LIST_CONFIG

Fonctions membres protégées

configureTaskRunnerOptions (OptionsResolver $resolver)

Attributs privés

const LOG_TEXT

Description détaillée

The Scheduler class provides the core functionality of ComScheduler. Currently, this includes fetching scheduled tasks from the database and execution of any or the next due task. It is planned that this class is extended with C[R]UD methods for scheduled tasks.

Depuis
4.1.0

Documentation des fonctions membres

◆ configureTaskRunnerOptions()

configureTaskRunnerOptions ( OptionsResolver $resolver )
protected

Set up an {

Voir également
OptionsResolver} to resolve options compatible with {
runTask}.
Paramètres
OptionsResolver $resolver The {
Voir également
OptionsResolver} instance to set up.
Renvoie
void
Depuis
4.1.0
Exceptions
AccessException

Références OptionsResolver\setDefaults().

◆ fetchTaskRecord()

fetchTaskRecord | ( | int | $id = 0,
 |  | bool | $allowDisabled = false
 | ) |  |

Fetches a single scheduled task in a Task instance. If no id or title is specified, a due task is returned.

Paramètres
int | $id | The task ID.
bool | $allowDisabled | Allow disabled/trashed tasks?
Renvoie
?object A matching task record, if it exists
Depuis
4.1.0
Exceptions

Références $filters, $id, et null.

Documentation des champs

◆ LOG_TEXT

const LOG_TEXT
private
Valeur initiale :
= [
Status::OK => 'COM_SCHEDULER_SCHEDULER_TASK_COMPLETE'

◆ TASK_QUEUE_FILTERS

const TASK_QUEUE_FILTERS
Valeur initiale :
= [
'due' => 1

Filters for the task queue. Can be used with fetchTaskRecords().

Depuis
4.1.0

◆ TASK_QUEUE_LIST_CONFIG

const const TASK_QUEUE_LIST_CONFIG
Valeur initiale :
= [
'multi_ordering' => ['a.priority DESC ', 'a.next_execution ASC']

List config for the task queue. Can be used with fetchTaskRecords().

Depuis
4.1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Scheduler.php


Joomla CMS: Référence de la classe TaskTable

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Table
  • TaskTable
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe TaskTable
+ Graphe d'héritage de TaskTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=true)
bind ($src, $ignore=array())
unlock (array $pks=[], ?int $userId=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Champs de données

$created
$title
$typeAlias = 'com_scheduler.task'
- Champs de données hérités de Table
$typeAlias = null

Fonctions membres protégées

_getAssetName ()
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
$_jsonEncode = ['params', 'execution_rules', 'cron_rules']
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)

Description détaillée

Table class for tasks scheduled through com_scheduler. The type alias for Task table entries is com_scheduler.task.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

TaskTable constructor override, needed to pass the DB table name and primary key to {

Voir également
Table::__construct()}.
Paramètres
DatabaseDriver $db A database connector object.
Depuis
4.1.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Returns the asset name of the entry as it appears in the {

Voir également
Asset} table.
Renvoie
string The asset name.
Depuis
4.1.0

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Override {

Voir également
Table::bind()} to bind some fields even if they're null given they're present in $src. This override is needed specifically for DATETIME fields, of which the next_execution field is updated to null if a task is configured to execute only on manual trigger.
Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean
Depuis
4.1.0

Implémente TableInterface.

Références $field, et $fields.

◆ check()

check ( )

Overloads {

Voir également
Table::check()} to perform sanity checks on properties and make sure they're safe to store.
Renvoie
boolean True if checks pass.
Depuis
4.1.0
Exceptions

Implémente TableInterface.

Références ENT_QUOTES, Factory\getApplication(), et Factory\getDate().

◆ store()

store ( $updateNulls = true )

Override {

Voir également
Table::store()} to update null fields as a default, which is needed when DATETIME fields need to be updated to NULL. This override is needed because {
AdminModel::save()} does not expose an option to pass true to Table::store(). Also ensures the created and created_by fields are set.
Paramètres
boolean $updateNulls True to update fields even if they're null.
Renvoie
boolean True if successful.
Depuis
4.1.0
Exceptions

Implémente TableInterface.

Références Factory\getApplication(), et Factory\getDate().

◆ unlock()

unlock | ( | array | $pks = [],
 |  | ?int | $userId = null
 | ) |  |

Release pseudo-locks on a set of task records. If an empty set is passed, this method releases lock on its instance primary key, if available.

Paramètres
integer[] | $pks An optional array of primary key values to update. If not set the instance property value is used.
?int | $userId ID of the user unlocking the tasks.
Renvoie
boolean True on success; false if $pks is empty.
Depuis
4.1.0
Exceptions
QueryTypeAlreadyDefinedException|

Références $key, $query, $this, $userId, Text\_(), AbstractEvent\create(), Joomla\CMS\Application\getDispatcher(), et null.

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['params', 'execution_rules', 'cron_rules']
protected

◆ $_supportNullValue

$_supportNullValue = true
protected

◆ $created

$created

◆ $title

$title

◆ $typeAlias

$typeAlias = 'com_scheduler.task'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskTable.php


Joomla CMS: Référence de la classe Status

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Task
  • Status
Champs de données
Référence de la classe Status

Champs de données

const | INVALID_EXIT = -2
const | NO_EXIT = -1
const | RUNNING = 1
const | NO_LOCK = 2
const | NO_RUN = 3
const | NO_RELEASE = 4
const | KNOCKOUT = 5
const | WILL_RESUME = 123
const | TIMEOUT = 124
const | NO_TASK = 125
const | NO_ROUTINE = 127
const | OK = 0

Description détaillée

A namespace mapping Task statuses to integer values.

Depuis
4.1.0

Documentation des champs

◆ INVALID_EXIT

const INVALID_EXIT = -2

Replacement exit code used when a routine returns an invalid (non-integer) exit code.

Depuis
4.1.0

Référencé par Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ KNOCKOUT

const KNOCKOUT = 5

Exit code used when a routine is either "knocked out" by an exception or encounters an exception it cannot handle gracefully. ? Should this be retained ?

Depuis
4.1.0

Référencé par SiteStatus\writeConfigFile().

◆ NO_EXIT

const NO_EXIT = -1

Replacement exit code used when a routine does not return an exit code.

Depuis
4.1.0

Référencé par Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ NO_LOCK

const NO_LOCK = 2

Exit code used on failure to acquire a pseudo-lock.

Depuis
4.1.0

◆ NO_RELEASE

const NO_RELEASE = 4

Exit code used on failure to release lock/update the record.

Depuis
4.1.0

◆ NO_ROUTINE

const NO_ROUTINE = 127

Exit code used when a routine is missing.

Depuis
4.1.0

Référencé par TasksRunCommand\doExecute().

◆ NO_RUN

const NO_RUN = 3

Exit code used on failure to run the task.

Depuis
4.1.0

Référencé par TasksRunCommand\doExecute(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ NO_TASK

const NO_TASK = 125

Exit code when a task does not exist.

Depuis
4.1.0

Référencé par TasksRunCommand\doExecute().

◆ OK

const OK = 0

Exit code on success.

Depuis
4.1.0

Référencé par TasksRunCommand\doExecute(), Joomla\Component\Scheduler\Administrator\Traits\endRoutine(), Task\isSuccess(), DemoTasks\sleep(), DemoTasks\stressMemory(), et SiteStatus\writeConfigFile().

◆ RUNNING

const RUNNING = 1

Status code used when the routine just starts. This is not meant to be an exit code.

Depuis
4.1.0

Référencé par Joomla\Component\Scheduler\Administrator\Traits\startRoutine().

◆ TIMEOUT

const TIMEOUT = 124

Exit code used when a task times out.

Depuis
4.1.0

◆ WILL_RESUME

const WILL_RESUME = 123

Exit code used when a task needs to resume (reschedule it to run a.s.a.p.).

Use this for long running tasks, e.g. batch processing of hundreds or thousands of files, sending newsletters with thousands of subscribers etc. These are tasks which might run out of memory and/or hit a time limit when lazy scheduling or web triggering of tasks is being used. Split them into smaller batches which return Status::WILL_RESUME. When the last batch is executed return Status::OK.

Depuis
4.1.0

Référencé par TasksRunCommand\doExecute(), et Task\isSuccess().

La documentation de cette classe a été générée à partir des fichiers suivants :
  • com_scheduler/src/Task/Status.php
  • Task.php


Joomla CMS: Référence de la classe Task

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Task
  • Task
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe Task
+ Graphe d'héritage de Task:
LoggerAwareInterface

Fonctions membres publiques

__construct (object $record)
getRecord ()
getContent ()
acquireLock ()
releaseLock (bool $update=true)
log (string $message, string $priority='info')
skipExecution ()
isSuccess ()
get (string $path, $default=null)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)

Fonctions membres publiques statiques

static | isValidState (string $state)
static | isValidId (string $id)

Champs de données

const | STATE_ENABLED = 1
const | STATE_DISABLED = 0
const | STATE_TRASHED = -2
const | STATE_MAP
$logCategory

Fonctions membres protégées

dispatchExitEvent ()
set (string $path, $value, string $separator=null)

Attributs protégés

$snapshot = []
$taskRegistry
$app
$db
const EVENTS_MAP

Description détaillée

The Task class defines methods for the execution, logging and related properties of Tasks as supported by com_scheduler, a Task Scheduling component.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( object $record )

Constructor for {

Voir également
Task}.
Paramètres
object $record A task from {
Voir également
TaskTable}.
Depuis
4.1.0
Exceptions

Références $options, Log\addLogger(), Log\ALL, class, Log\createDelegatedLogger(), Factory\getApplication(), Factory\getContainer(), et Psr\Log\setLogger().

Documentation des fonctions membres

◆ acquireLock()

acquireLock ( )

Acquire a pseudo-lock on the task record. ! At the moment, this method is not used anywhere as task locks are already acquired when they're fetched. As such this method is not functional and should not be reviewed until it is updated.

Renvoie
boolean
Depuis
4.1.0
Exceptions

Références $db, $id, $now, $query, Factory\getDate(), ComponentHelper\getParams(), et ParameterType\INTEGER.

◆ dispatchExitEvent()

dispatchExitEvent ( )
protected

Handles task exit (dispatch event).

Renvoie
void
Depuis
4.1.0
Exceptions

Références $this, et AbstractEvent\create().

◆ get()

get | ( | string | $path,
 |  |  | $default = null
 | ) |  |

Get a task property. This method is a proxy to {

Voir également
Registry::get()}.
Paramètres
string | $path | Registry path of the task property.
mixed | $default | Default property to return, if the actual value is null.
Renvoie
mixed The task property.
Depuis
4.1.0

Références $default, et $path.

◆ getContent()

getContent ( )

Get the task execution snapshot. ! Access locations will need updates once a more robust Snapshot container is implemented.

Renvoie
array
Depuis
4.1.0

◆ getRecord()

getRecord ( )

Get the task as a data object that can be stored back in the database. ! This method should be removed or changed as part of a better API implementation for the driver.

Renvoie
object
Depuis
4.1.0

◆ isSuccess()

isSuccess ( )

Was the task successful?

Renvoie
boolean True if the task was successful.
Depuis
4.1.0

Références null, Status\OK, et Status\WILL_RESUME.

◆ isValidId()

static isValidId ( string $id )
static

Static method to determine whether a task id is valid. Note that this does not validate ids against the database, but only verifies that an id may exist.

Paramètres
string $id The task id (as a string).
Renvoie
boolean
Depuis
4.1.0

Références $id.

◆ isValidState()

static isValidState ( string $state )
static

Static method to determine whether an enumerated task state (as a string) is valid.

Paramètres
string $state The task state (enumerated, as a string).
Renvoie
boolean
Depuis
4.1.0

Références $state, ArrayHelper\getValue(), et null.

◆ log()

log | ( | string | $message,
 |  | string | $priority = 'info'
 | ) |  |
Paramètres
string | $message | Log message
string | $priority | Log level, defaults to 'info'
Renvoie
void
Depuis
4.1.0
Exceptions
InvalidArgumentException

Références $message.

◆ releaseLock()

releaseLock ( bool $update = true )

Remove the pseudo-lock and optionally update the task record.

Paramètres
bool $update If true, the record is updated with the snapshot
Renvoie
boolean
Depuis
4.1.0
Exceptions

Références $db, $id, $query, ParameterType\INTEGER, et null.

◆ set()

set | ( | string | $path,
 |  |  | $value,
 |  | string | $separator = null
 | ) |  |
protected

Set a task property. This method is a proxy to {

Voir également
Registry::set()}.
Paramètres
string | $path | Registry path of the task property.
mixed | $value | The value to set to the property.
?string | $separator The key separator.
Renvoie
mixed|null
Depuis
4.1.0

Références $path, $separator, et $value.

◆ skipExecution()

skipExecution ( )

Advance the task entry's next calculated execution, effectively skipping the current execution.

Renvoie
void
Depuis
4.1.0
Exceptions

Références $db, $id, et $query.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected

◆ $logCategory

$logCategory

◆ $snapshot

$snapshot = []
protected

◆ $taskRegistry

$taskRegistry
protected

◆ EVENTS_MAP

const EVENTS_MAP
protected
Valeur initiale :
= [
Status::OK => 'onTaskExecuteSuccess'

◆ STATE_DISABLED

const STATE_DISABLED = 0

Enumerated state for disabled tasks.

Depuis
4.1.0

◆ STATE_ENABLED

const STATE_ENABLED = 1

Enumerated state for enabled tasks.

Depuis
4.1.0

◆ STATE_MAP

const STATE_MAP
Valeur initiale :
= [
self::STATE_TRASHED => 'trashed'

Map state enumerations to logical language adjectives.

Depuis
4.1.0

◆ STATE_TRASHED

const STATE_TRASHED = -2

Enumerated state for trashed tasks.

Depuis
4.1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Task.php


Joomla CMS: Référence de la classe TaskOption

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Task
  • TaskOption
Fonctions membres publiques | Attributs protégés
Référence de la classe TaskOption

Fonctions membres publiques

__construct (string $type, string $langConstPrefix)
__get (string $name)

Attributs protégés

$title
$desc
$id
$langConstPrefix

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $type,
 |  | string | $langConstPrefix
 | ) |  |

TaskOption constructor.

Paramètres
string | $type | A unique ID string for a plugin task routine.
string | $langConstPrefix | The Language constant prefix $p. Expects $p . _TITLE and $p . _DESC to exist.
Depuis
4.1.0

Références $type, et Text\_().

Documentation des fonctions membres

◆ __get()

__get ( string $name )

Magic method to allow read-only access to private properties.

Paramètres
string $name The object property requested.
Renvoie
?string
Depuis
4.1.0

Références $id, $name, $this, Log\add(), null, et Log\WARNING.

Documentation des champs

◆ $desc

$desc
protected

◆ $id

$id
protected

◆ $langConstPrefix

$langConstPrefix
protected

◆ $title

$title
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskOption.php


Joomla CMS: Référence de la classe TaskOptions

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • Task
  • TaskOptions
Fonctions membres publiques | Champs de données
Référence de la classe TaskOptions

Fonctions membres publiques

addOptions (array $taskRoutines)
findOption (?string $routineId)

Champs de données

$options = []

Description détaillée

The TaskOptions class. Used as the subject argument for the onTaskOptionsList event, plugins that support tasks must add them to the object through the addOptions() method.

Depuis
4.1.0

Documentation des fonctions membres

◆ addOptions()

addOptions ( array $taskRoutines )

◆ findOption()

findOption ( ?string $routineId )
Paramètres
?string $routineId A unique identifier for a plugin task routine
Renvoie
?TaskOption A matching TaskOption if available, null otherwise
Depuis
4.1.0

Références $option, et null.

Documentation des champs

◆ $options

$options = []
La documentation de cette classe a été générée à partir du fichier suivant :
  • TaskOptions.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Select
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=[])
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$app
$state
$items
$modalLink
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The MVC View for the routine selection page (SelectView). This view lets the user choose from a list of plugin defined task routines.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = [] )

HtmlView constructor.

Paramètres
array $config A named configuration array for object construction. name: the name (optional) of the view (defaults to the view class name suffix). charset: the character set to use for display escape: the name (optional) of the function to use for escaping strings base_path: the parent path (optional) of the views directory (defaults to the component folder) template_plath: the path (optional) of the layout directory (defaults to base_path + /views/ + view name helper_path: the path (optional) of the helper files (defaults to base_path + /helpers/) layout: the layout (optional) to use to display the view
Depuis
4.1.0
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.1.0

Références $toolbar, Text\_(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )
Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.1.0
Exceptions

Implémente ViewInterface.

Références items, et modalLink.

Documentation des champs

◆ $app

$app
protected

◆ $items

$items
protected

◆ $modalLink

$modalLink
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_scheduler/src/View/Select/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Task
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$app
$form
$item
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

The MVC View for Task configuration page (TaskView).

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Overloads the parent constructor. Just needed to fetch the Application object.

Paramètres
array $config A named configuration array for object construction. name: the name (optional) of the view (defaults to the view class name suffix). charset: the character set to use for display escape: the name (optional) of the function to use for escaping strings base_path: the parent path (optional) of the views directory (defaults to the component folder) template_plath: the path (optional) of the layout directory (defaults to base_path + /views/ + view name helper_path: the path (optional) of the helper files (defaults to base_path + /helpers/) layout: the layout (optional) to use to display the view
Depuis
4.1.0
Exceptions

Références $config, Symfony\Contracts\Service\__construct(), et Factory\getApplication().

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Adds the page title and toolbar

Renvoie
void
Depuis
4.1.0

Références $app, $canDo, $toolbar, Text\_(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )
Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.1.0
Exceptions

Implémente ViewInterface.

Références ContentHelper\getActions().

Documentation des champs

◆ $app

AdministratorApplication $app
protected
Depuis
4.1.0

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_scheduler/src/View/Task/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Scheduler
  • Administrator
  • View
  • Tasks
  • HtmlView
Fonctions membres publiques | Champs de données | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Membres hérités additionnels

- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

MVC View for the Tasks list page.

Depuis
4.1.0

Documentation des fonctions membres

◆ display()

display ( $tpl = null )
Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.1.0
Exceptions

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_scheduler/src/View/Tasks/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Tags
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'tags'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Tags view class for the Tags package.

Depuis
3.1

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since3.1

Références $id, $layout, $this, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'tags'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe TagController

  • Joomla
  • Component
  • Tags
  • Administrator
  • Controller
  • TagController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TagController
+ Graphe d'héritage de TagController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Tag Controller

Depuis
3.1

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
3.1

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
3.1

Références $data, et $key.

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
object $model The model.
Renvoie
boolean True if successful, false otherwise and internal error is set.
Depuis
3.1

Références $model, et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TagController.php


Joomla CMS: Référence de la classe TagsController

  • Joomla
  • Component
  • Tags
  • Administrator
  • Controller
  • TagsController
Fonctions membres publiques
Référence de la classe TagsController
+ Graphe d'héritage de TagsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Tag', $prefix='Administrator', $config=array('ignore_request'=> true))
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Tags List Controller

Depuis
3.1

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Tag',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | An optional associative array of configuration settings.
Renvoie
The model.
Depuis
3.1

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the JSON-encoded amount of published tags for quickicons

Renvoie
void
Depuis
4.1.0

Références $model, $result, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/Controller/TagsController.php


Joomla CMS: Référence de la classe TagsComponent

  • Joomla
  • Component
  • Tags
  • Administrator
  • Extension
  • TagsComponent
Référence de la classe TagsComponent
+ Graphe d'héritage de TagsComponent:
MVCComponent RouterServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_tags

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagsComponent.php


Joomla CMS: Référence de la classe TagModel

  • Joomla
  • Component
  • Tags
  • Administrator
  • Model
  • TagModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe TagModel
+ Graphe d'héritage de TagModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getItem ($pk=null)
getForm ($data=array(), $loadData=true)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_tags.tag'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

canDelete ($record)
populateState ()
loadFormData ()
prepareTable ($table)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$text_prefix = 'COM_TAGS'
$batch_commands
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Tags Component Tag Model

Depuis
3.1

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
3.1

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
bool| A Form object on success, false on failure
Depuis
3.1

Implémente FormModelInterface.

Références $form, $user, Factory\getApplication(), Factory\getUser(), et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a tag.

Paramètres
integer $pk An optional id of the object to get, otherwise the id from the model state is used.
Renvoie
mixed Tag data object on success, false on failure.
Depuis
3.1

Method to get tag data for the current tag or tags

Paramètres
integer $pk An optional ID
Renvoie
array
Depuis
3.1

Références $date, $result, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et null.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
3.1

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Auto-populate the model state.

Note
Calling getState in this method will result in recursion.
Renvoie
void
Depuis
3.1

Références $app, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ prepareTable()

prepareTable ( $table )
protected

Prepare and sanitise the table data prior to saving.

Paramètres
\Joomla\CMS\Table\Table $table A Table object.
Renvoie
void
Depuis
1.6

Documentation des champs

◆ $batch_commands

$batch_commands
protected
Valeur initiale :
= array(
'assetgroup_id' => 'batchAccess',
'language_id' => 'batchLanguage',
)

◆ $text_prefix

$text_prefix = 'COM_TAGS'
protected

◆ $typeAlias

$typeAlias = 'com_tags.tag'
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/Model/TagModel.php


Joomla CMS: Référence de la classe TagsModel

  • Joomla
  • Component
  • Tags
  • Administrator
  • Model
  • TagsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TagsModel
+ Graphe d'héritage de TagsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
countItems (&$items, $extension)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
getEmptyStateQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Tags Component Tags Model

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
MVCFactoryInterface | $factory | The factory.
array | $config | An optional associative array of configuration settings.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ countItems()

countItems | ( | & | $items,
 |  |  | $extension
 | ) |  |

Method to load the countItems method from the extensions

Paramètres

Références $component, $extension, $items, $parts, et Factory\getApplication().

◆ getEmptyStateQuery()

getEmptyStateQuery ( )
protected

Manipulate the query to be used to evaluate if this is an Empty State to provide specific conditions for this extension.

Renvoie
DatabaseQuery
Depuis
4.0.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
3.0.1

Implémente ListModelInterface.

Références $extension, $items, Joomla\CMS\Categories\countItems(), et Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Method to create a query for a list of items.

Renvoie
string
Depuis
3.1

Références $db, $groups, $language, $listDirn, $published, $query, $user, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
3.1

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.1

Références $direction, $extension, $ordering, $params, $parts, ComponentHelper\getParams(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/Model/TagsModel.php


Joomla CMS: Référence de la classe TagTable

  • Joomla
  • Component
  • Tags
  • Administrator
  • Table
  • TagTable
Fonctions membres publiques | Attributs protégés
Référence de la classe TagTable
+ Graphe d'héritage de TagTable:
Nested VersionableTableInterface Table TableInterface CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
check ()
store ($updateNulls=true)
delete ($pk=null, $children=false)
getTypeAlias ()
- Fonctions membres publiques hérités de Nested
debug ($level)
getPath ($pk=null, $diagnostic=false)
getTree ($pk=null, $diagnostic=false)
isLeaf ($pk=null)
setLocation ($referenceId, $position='after')
move ($delta, $where='')
moveByReference ($referenceId, $position='after', $pk=null, $recursiveUpdate=true)
check ()
store ($updateNulls=false)
publish ($pks=null, $state=1, $userId=0)
orderUp ($pk)
orderDown ($pk)
getRootId ()
rebuild ($parentId=null, $leftId=0, $level=0, $path='')
rebuildPath ($pk=null)
reset ()
saveorder ($idArray=null, $lftArray=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_jsonEncode = ['params', 'metadata', 'urls', 'images']
$_supportNullValue = true
- Attributs protégés hérités de Nested
$_location
$_location_id
$_cache = array()
$_debug = 0
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Nested
$parent_id
$level
$lft
$rgt
$alias
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Nested
recursiveUpdatePublishedColumn ($pk, $newState=null)
_getNode ($id, $key=null)
_getTreeRepositionData ($referenceNode, $nodeWidth, $position='before')
_logtable ($showData=true, $showQuery=true)
_runQuery ($query, $errorMessage)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés statiques hérités de Nested
static | $root_id = 0

Description détaillée

Tags table

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Overloaded check method to ensure data integrity.

Renvoie
boolean True on success.
Depuis
3.1
Exceptions

Implémente TableInterface.

Références $title, Factory\getDate(), hits, language, null, path, StringHelper\str_ireplace(), et ApplicationHelper\stringURLSafe().

◆ delete()

delete | ( | $pk = null,
 |  | $children = false
 | ) |

Method to delete a node and, optionally, its child nodes from the table.

Paramètres
integer | $pk | The primary key of the node to delete.
boolean | $children | True to delete child nodes, false to move them up a level.
Renvoie
boolean True on success.
Depuis
3.1

Références $helper, et $return.

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente VersionableTableInterface.

◆ store()

store ( $updateNulls = true )

Overridden ::store to set modified data and user id.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
3.1

Implémente TableInterface.

Références $date, $user, Text\_(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), et Factory\getUser().

Documentation des champs

◆ $_jsonEncode

$_jsonEncode = ['params', 'metadata', 'urls', 'images']
protected

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TagTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Tags
  • Administrator
  • View
  • Tag
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
$assoc
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Tags component

Depuis
3.1

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Depuis
3.1
Renvoie
void

Références $canDo, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Documentation des champs

◆ $assoc

$assoc
protected

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/View/Tag/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Tags
  • Administrator
  • View
  • Tags
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

Tags view class for the Tags package.

Depuis
3.1

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
3.1

Références $canDo, $toolbar, $user, Text\_(), ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.

Implémente ViewInterface.

Références $item, Multilanguage\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_tags/src/View/Tags/HtmlView.php


Joomla CMS: Référence de la classe TagsController

  • Joomla
  • Component
  • Tags
  • Api
  • Controller
  • TagsController
Attributs protégés
Référence de la classe TagsController
+ Graphe d'héritage de TagsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'tags'
$default_view = 'tags'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The tags controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'tags'
protected

◆ $default_view

$default_view = 'tags'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_tags/src/Controller/TagsController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Tags
  • Api
  • View
  • Tags
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The tags view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'title',
'alias',
'note',
'published',
'access',
'description',
'checked_out',
'checked_out_time',
'created_user_id',
'path',
'parent_id',
'level',
'lft',
'rgt',
'language',
'language_title',
'language_image',
'editor',
'author_name',
'access_title',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_tags/src/View/Tags/JsonapiView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Tags
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Tags Component Controller

Depuis
3.1

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
mixed | boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstaticThisobjecttosupportchaining.@since3.1

Références $user.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe TagsController

  • Joomla
  • Component
  • Tags
  • Site
  • Controller
  • TagsController
Fonctions membres publiques
Référence de la classe TagsController
+ Graphe d'héritage de TagsController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

searchAjax ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The Tags List Controller

Depuis
3.1

Documentation des fonctions membres

◆ searchAjax()

searchAjax ( )

Method to search tags with AJAX

Renvoie
void

Références $filters, $results, $user, null, et TagsHelper\searchTags().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Controller/TagsController.php


Joomla CMS: Référence de la classe RouteHelper

  • Joomla
  • Component
  • Tags
  • Site
  • Helper
  • RouteHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe RouteHelper
+ Graphe d'héritage de RouteHelper:
RouteHelper TagsHelperRoute

Fonctions membres publiques statiques

static | getItemRoute ($contentItemId, $contentItemAlias, $contentCatId, $language, $typeAlias, $routerName)
static | getTagRoute ($id)
static | getComponentTagRoute (string $id, string $language=' *')
static | getTagsRoute ()
static | getComponentTagsRoute (string $language=' *')
- Fonctions membres publiques statiques hérités de RouteHelper
static | getCategoryRoute ($catid, $language=0, $extension='')

Fonctions membres protégées statiques

static | _findItem ($needles=null)
- Fonctions membres protégées statiques hérités de RouteHelper
static | lookupItem ($needles=array())

Attributs protégés statiques

static | $lookup
- Attributs protégés statiques hérités de RouteHelper
static | $lookup

Membres hérités additionnels

- Fonctions membres publiques hérités de RouteHelper
getRoute ($id, $typealias, $link='', $language=null, $catid=null)
- Fonctions membres protégées hérités de RouteHelper
findItem ($needles=array())
- Attributs protégés hérités de RouteHelper
$extension
$id
$view

Description détaillée

Tags Component Route Helper.

Depuis
3.1

Documentation des fonctions membres

◆ _findItem()

static _findItem ( $needles = null )
staticprotected

Find Item static function

Paramètres
array $needles Array used to get the language value
Renvoie
null
Exceptions
Exception

Références $active, $component, $id, $item, $items, $lang, $language, $position, $view, elseif, ComponentHelper\getComponent(), AbstractMenu\getInstance(), et null.

◆ getComponentTagRoute()

static getComponentTagRoute | ( | string | $id,
 |  | string | $language = '*'
 | ) |  |
static

Tries to load the router for the component and calls it. Otherwise calls getRoute.

Paramètres
string | $id | The ID of the tag in the format TAG_ID:TAG_ALIAS
string | $language | The language of the tag
Renvoie
string URL link to pass to the router
Depuis
4.2.0
Exceptions
Exception

Références $id, $item, $language, et $link.

◆ getComponentTagsRoute()

static getComponentTagsRoute ( string $language = '*' )
static

Tries to load the router for the tags view.

Paramètres
string $language The language of the tag
Renvoie
string URL link to pass to the router
Depuis
4.2.0
Exceptions
Exception

Références $item, $language, et $link.

◆ getItemRoute()

static getItemRoute | ( | $contentItemId,
 |  | $contentItemAlias,
 |  | $contentCatId,
 |  | $language,
 |  | $typeAlias,
 |  | $routerName
 | ) |
static

Tries to load the router for the component and calls it. Otherwise uses getTagRoute.

Paramètres
integer | $contentItemId | Component item id
string | $contentItemAlias | Component item alias
integer | $contentCatId | Component item category id
string | $language | Component item language
string | $typeAlias | Component type alias
string | $routerName | Component router
Renvoie
string URL link to pass to the router
Depuis
3.1

Références $language, $link, JPATH_BASE, et JLoader\register().

Référencé par TagModel\getItems(), et TagsSimilarHelper\getList().

◆ getTagRoute()

static getTagRoute ( $id )
static

Tries to load the router for the component and calls it. Otherwise calls getRoute.

Paramètres
integer $id The ID of the tag
Renvoie
string URL link to pass to the router
Depuis
3.1
Exceptions
Exception
Obsolète:
5.0.0 Use getComponentTagRoute() instead

Références $id.

◆ getTagsRoute()

static getTagsRoute ( )
static

Tries to load the router for the tags view.

Renvoie
string URL link to pass to the router
Depuis
3.7
Exceptions
Exception
Obsolète:
5.0.0

Documentation des champs

◆ $lookup

$lookup
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Helper/RouteHelper.php


Joomla CMS: Référence de la classe TagModel

  • Joomla
  • Component
  • Tags
  • Site
  • Model
  • TagModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TagModel
+ Graphe d'héritage de TagModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
populateState ($ordering='c.core_title', $direction='ASC')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$tag = null
$items = null
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Tags Component Tag Model

Depuis
3.1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Depuis
1.6

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Method to get a list of items for a list of tags.

Renvoie
mixed An array of objects on success, false on failure.
Depuis
3.1

Implémente ListModelInterface.

Références $item, $items, et RouteHelper\getItemRoute().

◆ getListQuery()

getListQuery ( )
protected

Method to build an SQL query to load the list data of all items with a given tag.

Renvoie
string An SQL query
Depuis
3.1

Références $db, $language, $query, Joomla\Database\getDatabase(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'c.core_title',
 |  | $direction = 'ASC'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
3.1

Références $app, $format, $itemid, $language, $limit, $listOrder, Joomla\Database\Query\$offset, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\setState(), et ArrayHelper\toInteger().

Documentation des champs

◆ $items

$items = null
protected

◆ $tag

$tag = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Model/TagModel.php


Joomla CMS: Référence de la classe TagsModel

  • Joomla
  • Component
  • Tags
  • Site
  • Model
  • TagsModel
Champs de données | Fonctions membres protégées
Référence de la classe TagsModel
+ Graphe d'héritage de TagsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Champs de données

$_context = 'com_tags.tags'

Fonctions membres protégées

populateState ($ordering=null, $direction=null)
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

This models supports retrieving a list of tags.

Depuis
3.1

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Method to build an SQL query to load the list data.

Renvoie
string An SQL query
Depuis
1.6

Références $app, $db, $format, $groups, $language, $limit, Joomla\Database\Query\$offset, $published, $query, $title, $user, Factory\getApplication(), ContentHelper\getCurrentLanguage(), Joomla\Database\getDatabase(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), ParameterType\INTEGER, Joomla\CMS\MVC\Model\setState(), et ParameterType\STRING.

◆ populateState()

populateState | ( | $ordering = null,
 |  | $direction = null
 | ) |
protected

Method to auto-populate the model state.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Note
Calling getState in this method will result in recursion.
Depuis
3.1

Références $app, $itemid, $language, Joomla\Database\Query\$offset, $params, $user, Factory\getApplication(), Factory\getUser(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $_context

$_context = 'com_tags.tags'
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Model/TagsModel.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Tags
  • Site
  • Service
  • Router
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu, ?CategoryFactoryInterface $categoryFactory, DatabaseInterface $db)
build (&$query)
parse (&$segments)
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Fonctions membres protégées

fixSegment ($segment)

Attributs privés

$db

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class from com_tags

Depuis
3.3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu,
 |  | ?CategoryFactoryInterface | $categoryFactory,
 |  | DatabaseInterface | $db
 | ) |  |

Tags Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with
CategoryFactoryInterface | $categoryFactory | The category object
DatabaseInterface | $db | The database object
Depuis
4.0.0

Références $app, $db, $menu, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ build()

build ( & $query )

Build the route for the com_tags component

Paramètres
array &$query An array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $i, $id, $position, $query, $total, $view, null, et ArrayHelper\toInteger().

◆ fixSegment()

fixSegment ( $segment )
protected

Try to add missing id to segment

Paramètres
string $segment One piece of segment of the URL to parse
Renvoie
string The segment with founded id
Depuis
3.7

Références $id, et $query.

◆ parse()

parse ( & $segments )

Parse the segments of a URL.

Paramètres
array &$segments The segments of the URL to parse.
Renvoie
array The URL attributes to be used by the application.
Depuis
3.3

Implémente RouterInterface.

Références $count, $i, $item, et $total.

Documentation des champs

◆ $db

$db
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/Service/Router.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tag
  • FeedView
Fonctions membres publiques
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

HTML View class for the Tags component

Depuis
3.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.

Implémente ViewInterface.

Références $app, $author, $date, $description, $i, $id, $item, $items, $title, Route\_(), elseif, ENT_COMPAT, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_tags/src/View/Tag/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tag
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
getTagsTitle ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$item
$children
$parent
$pagination
$params
$tags_title
$pageclass_sfx = ''
$user = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Tags component

Depuis
3.1

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document.

Renvoie
void

Références $app, $attribs, $link, $menu, $title, Route\_(), elseif, et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
3.1

Implémente ViewInterface.

Références $active, $app, $groups, $item, $items, $layout, $model, $params, $results, $state, $temp, $user, children, Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), PluginHelper\importPlugin(), items, null, et parent.

◆ getTagsTitle()

getTagsTitle ( )
protected

Creates the tags title for the output

Renvoie
string
Depuis
3.1

Références $groups, $item, $user, et Joomla\CMS\User\getCurrentUser().

Documentation des champs

◆ $children

$children
protected

◆ $item

$item
protected

◆ $items

$items
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination
protected

◆ $params

$params
protected

◆ $parent

$parent
protected

◆ $state

$state
protected

◆ $tags_title

$tags_title
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/View/Tag/HtmlView.php


Joomla CMS: Référence de la classe FeedView

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tags
  • FeedView
Fonctions membres publiques
Référence de la classe FeedView
+ Graphe d'héritage de FeedView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

HTML View class for the Tags component all tags view

Depuis
3.1

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.

Implémente ViewInterface.

Références $app, $author, $date, $description, $item, $items, $title, Route\_(), ENT_COMPAT, Factory\getApplication(), et if.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_tags/src/View/Tags/FeedView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Tags
  • Site
  • View
  • Tags
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

_prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$items
$pagination
$params = null
$pageclass_sfx = ''
$user = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

HTML View class for the Tags component

Depuis
3.1

Documentation des fonctions membres

◆ _prepareDocument()

_prepareDocument ( )
protected

Prepares the document

Renvoie
void

Références $attribs, $link, $menu, Text\_(), Route\_(), et Factory\getApplication().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.

Implémente ViewInterface.

Références $active, $layout, $params, $temp, Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), et items.

Documentation des champs

◆ $items

$items
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $pagination

$pagination
protected

◆ $params

$params = null
protected

◆ $state

$state
protected

◆ $user

$user = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_tags/src/View/Tags/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Templates
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'styles'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Templates manager master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().@returnstatic|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $view, Route\_(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'styles'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe StyleController

  • Joomla
  • Component
  • Templates
  • Administrator
  • Controller
  • StyleController
Fonctions membres publiques | Attributs protégés
Référence de la classe StyleController
+ Graphe d'héritage de StyleController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

save ($key=null, $urlVar=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Attributs protégés

$text_prefix = 'COM_TEMPLATES_STYLE'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Template style controller class.

Depuis
1.6

Documentation des fonctions membres

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Method to save a template style.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if successful, false otherwise.
Depuis
1.6

Références $context, $data, $form, $i, $item, $key, $model, $n, $recordId, Text\_(), Form\addFormPath(), Joomla\Application\checkToken(), JPATH_ADMINISTRATOR, null, et Text\sprintf().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_TEMPLATES_STYLE'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StyleController.php


Joomla CMS: Référence de la classe StylesController

  • Joomla
  • Component
  • Templates
  • Administrator
  • Controller
  • StylesController
Fonctions membres publiques
Référence de la classe StylesController
+ Graphe d'héritage de StylesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

duplicate ()
getModel ($name='Style', $prefix='Administrator', $config=array())
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Template styles list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ duplicate()

duplicate ( )

Method to clone and existing template style.

Renvoie
void

Références $model, Text\_(), et Joomla\Application\checkToken().

◆ getModel()

getModel | ( | $name = 'Style',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
BaseDatabaseModel
Depuis
1.6

Références $name, et $prefix.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/Controller/StylesController.php


Joomla CMS: Référence de la classe TemplateController

  • Joomla
  • Component
  • Templates
  • Administrator
  • Controller
  • TemplateController
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TemplateController
+ Graphe d'héritage de TemplateController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
cancel ()
close ()
publish ()
getModel ($name='Template', $prefix='Administrator', $config=array())
overrides ()
delete ()
createFile ()
uploadFile ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

allowEdit ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Template style controller class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
1.6
Voir également
BaseController

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ allowEdit()

allowEdit ( )
protected

Method to check if you can add a new record.

Renvoie
boolean
Depuis
3.2

◆ cancel()

cancel ( )

Method for closing the template.

Renvoie
void
Depuis
3.2

Références Route\_().

◆ close()

close ( )

Method for closing a file.

Renvoie
void
Depuis
3.2

Références $id, $url, et Route\_().

◆ createFile()

createFile ( )

Method for creating a new file.

Renvoie
void
Depuis
3.2

Références $id, $location, $model, $name, $type, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), elseif, InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

◆ delete()

delete ( )

Method for deleting a file.

Renvoie
void
Depuis
3.2

Références $id, $model, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), et elseif.

◆ getModel()

getModel | ( | $name = 'Template',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional (note, the empty array is atypical compared to other models).
Renvoie
The model.
Depuis
3.2

Références $config, $name, et $prefix.

◆ overrides()

overrides ( )

Method for creating override.

Renvoie
void
Depuis
3.2

Références $id, $model, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, et InputFilter\ONLY_BLOCK_DEFINED_TAGS.

◆ publish()

publish ( )

Marked as Checked/Unchecked of override history.

Renvoie
void
Depuis
4.0.0

Références $id, $model, $task, $url, $value, Text\_(), Route\_(), Joomla\Application\checkToken(), elseif, ArrayHelper\getValue(), et Text\plural().

◆ uploadFile()

uploadFile ( )

Method for uploading a file.

Renvoie
void
Depuis
3.2

Références $id, $location, $model, $return, $url, Text\_(), Route\_(), Joomla\Application\checkToken(), InputFilter\getInstance(), InputFilter\ONLY_BLOCK_DEFINED_ATTRIBUTES, InputFilter\ONLY_BLOCK_DEFINED_TAGS, et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_templates/src/Controller/TemplateController.php


Joomla CMS: Référence de la classe TemplatesComponent

  • Joomla
  • Component
  • Templates
  • Administrator
  • Extension
  • TemplatesComponent
Fonctions membres publiques
Référence de la classe TemplatesComponent
+ Graphe d'héritage de TemplatesComponent:
MVCComponent BootableExtensionInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()

Description détaillée

Component class for com_templates

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatesComponent.php


Joomla CMS: Référence de la classe TemplatelocationField

  • Joomla
  • Component
  • Templates
  • Administrator
  • Field
  • TemplatelocationField
Fonctions membres publiques | Attributs protégés
Référence de la classe TemplatelocationField
+ Graphe d'héritage de TemplatelocationField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'TemplateLocation'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Template Location field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
3.5

Références $options, et TemplatesHelper\getClientOptions().

Documentation des champs

◆ $type

$type = 'TemplateLocation'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatelocationField.php


Joomla CMS: Référence de la classe TemplatenameField

  • Joomla
  • Component
  • Templates
  • Administrator
  • Field
  • TemplatenameField
Fonctions membres publiques | Attributs protégés
Référence de la classe TemplatenameField
+ Graphe d'héritage de TemplatenameField:
ListField FormField DatabaseAwareInterface

Fonctions membres publiques

getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$type = 'TemplateName'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Template Name field.

Depuis
3.5

Documentation des fonctions membres

◆ getOptions()

getOptions ( )

Method to get the field options.

Renvoie
array The field option objects.
Depuis
1.6

Références $clientId, $options, Factory\getApplication(), et TemplatesHelper\getTemplateOptions().

Documentation des champs

◆ $type

$type = 'TemplateName'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatenameField.php


Joomla CMS: Référence de la classe TemplateHelper

  • Joomla
  • Component
  • Templates
  • Administrator
  • Helper
  • TemplateHelper
Fonctions membres publiques statiques
Référence de la classe TemplateHelper
+ Graphe d'héritage de TemplateHelper:
TemplateHelper

Fonctions membres publiques statiques

static | getTypeIcon ($fileName)
static | canUpload ($file, $err='')

Description détaillée

Template Helper class.

Depuis
3.2

Documentation des fonctions membres

◆ canUpload()

static canUpload | ( | $file,
 |  | $err = ''
 | ) |
static

Checks if the file can be uploaded

Paramètres
array | $file | File information
string | $err | An error message to be returned
Renvoie
boolean
Depuis
3.2

Références $app, $explodeArray, $format, $i, $maxSize, $params, Text\_(), Factory\getApplication(), File\getExt(), ComponentHelper\getParams(), File\makeSafe(), et null.

Référencé par TemplateModel\uploadFile().

◆ getTypeIcon()

static getTypeIcon ( $fileName )
static

Checks if the file is an image

Paramètres
string $fileName The filename
Renvoie
boolean
Depuis
3.2
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplateHelper.php


Joomla CMS: Référence de la classe TemplatesHelper

  • Joomla
  • Component
  • Templates
  • Administrator
  • Helper
  • TemplatesHelper
Fonctions membres publiques statiques
Référence de la classe TemplatesHelper
+ Graphe d'héritage de TemplatesHelper:
TemplatesHelper

Fonctions membres publiques statiques

static | getClientOptions ()
static | getTemplateOptions ($clientId=' *')
static | parseXMLTemplateFile ($templateBaseDir, $templateDir)
static | getPositions ($clientId, $templateDir)

Description détaillée

Templates component helper.

Depuis
1.6

Documentation des fonctions membres

◆ getClientOptions()

static getClientOptions ( )
static

Get a list of filter options for the application clients.

Renvoie
array An array of HtmlOption elements.

Références $options, Text\_(), et HTMLHelper\_().

Référencé par TemplatelocationField\getOptions().

◆ getPositions()

static getPositions | ( | $clientId,
 |  | $templateDir
 | ) |
static
Paramètres
integer | $clientId
string | $templateDir
Renvoie
boolean|array
Depuis
3.0

Références $clientId, $positions, $xml, Path\clean(), if, JPATH_ADMINISTRATOR, et JPATH_SITE.

Référencé par Modules\positions().

◆ getTemplateOptions()

static getTemplateOptions ( $clientId = '*' )
static

Get a list of filter options for the templates with styles.

Paramètres
mixed $clientId The CMS client id (0:site | 1:administrator) or '*' for all.
Renvoie
array

Références $clientId, $db, $options, $query, Factory\getDbo(), et ParameterType\INTEGER.

Référencé par TemplatenameField\getOptions().

◆ parseXMLTemplateFile()

static parseXMLTemplateFile | ( | $templateBaseDir,
 |  | $templateDir
 | ) |
static
Paramètres
string | $templateBaseDir
string | $templateDir
Renvoie
boolean|CMSObject

Références $data, $key, $value, $xml, Path\clean(), et Installer\parseXMLInstallFile().

Référencé par TemplatesModel\getItems(), TemplateModel\getMediaFiles(), TemplateModel\getTemplate(), Templates\thumb(), et Templates\thumbModal().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplatesHelper.php


Joomla CMS: Référence de la classe StyleModel

  • Joomla
  • Component
  • Templates
  • Administrator
  • Model
  • StyleModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe StyleModel
+ Graphe d'héritage de StyleModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
delete (&$pks)
duplicate (&$pks)
getForm ($data=array(), $loadData=true)
getItem ($pk=null)
save ($data)
setHome ($id=0)
unsetHome ($id=0)
getHelp ()
getAdminTemplate (int $styleId)
getSiteTemplates ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ()
generateNewTitle ($categoryId, $alias, $title)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
cleanCache ($group=null, $clientId=0)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$helpKey = 'Templates:_Edit_Style'
$helpURL
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$_cache = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Template style model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ cleanCache()

cleanCache | ( | $group = null,
 |  | $clientId = 0
 | ) |
protected

Custom clean cache method

Paramètres
string | $group | The cache group
integer | $clientId

◆ delete()

delete ( & $pks )

Method to delete rows.

Paramètres
array &$pks An array of item ids.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6
Exceptions

Références $context, $name, $result, $user, Text\_(), Factory\getApplication(), Factory\getUser(), et PluginHelper\importPlugin().

◆ duplicate()

duplicate ( & $pks )

Method to duplicate styles.

Paramètres
array &$pks An array of primary key IDs.
Renvoie
boolean True if successful.
Exceptions

Références $context, $name, $result, $user, Text\_(), Factory\getApplication(), Factory\getUser(), PluginHelper\importPlugin(), et null.

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title.

Paramètres
integer | $categoryId | The id of the category.
string | $alias | The alias.
string | $title | The title.
Renvoie
string New title.
Depuis
1.7.1

Références $title, et StringHelper\increment().

◆ getAdminTemplate()

getAdminTemplate ( int $styleId )

Returns the back end template for the given style.

Paramètres
int $styleId The style id
Renvoie
stdClass
Depuis
4.2.0

Références $db, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $clientId, $data, $form, $item, $template, Form\addFieldPath(), ArrayHelper\getValue(), JPATH_ADMINISTRATOR, JPATH_SITE, Joomla\CMS\MVC\Model\loadForm(), et Joomla\CMS\MVC\Model\setState().

◆ getHelp()

getHelp ( )

Get the necessary data to load an item help screen.

Renvoie
object An object with key, url, and local properties for loading the item help screen.
Depuis
1.6

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.

Références $client, $path, $return, class, Path\clean(), ApplicationHelper\getClientInfo(), Joomla\CMS\MVC\Model\getState(), null, et ArrayHelper\toObject().

◆ getSiteTemplates()

getSiteTemplates ( )

Returns the front end templates.

Renvoie
array
Depuis
4.2.0

Références $db, $query, et Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note
Calling getState in this method will result in recursion.
Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to allow derived classes to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $client, $clientId, $data, $form, $helpURL, $lang, $template, $xml, Text\_(), Path\clean(), ApplicationHelper\getClientInfo(), Factory\getLanguage(), Joomla\CMS\MVC\Model\getState(), Multilanguage\isEnabled(), Form\loadFile(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.

Références $app, $data, $db, $extension, $n, $query, $result, $user, $userId, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Table\getInstance(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), PluginHelper\importPlugin(), ParameterType\INTEGER, null, Text\plural(), Joomla\CMS\MVC\Model\setState(), et ArrayHelper\toInteger().

◆ setHome()

setHome ( $id = 0 )

Method to set a template style as home.

Paramètres
integer $id The primary key ID for the style.
Renvoie
boolean True if successful.
Exceptions

Références $clientId, $db, $extension, $id, $query, $style, $user, Text\_(), Joomla\Database\getDatabase(), Table\getInstance(), Factory\getUser(), et ParameterType\INTEGER.

◆ unsetHome()

unsetHome ( $id = 0 )

Method to unset a template style as default for a language.

Paramètres
integer $id The primary key ID for the style.
Renvoie
boolean True if successful.
Exceptions

Références $db, $id, $query, $style, $user, Text\_(), elseif, Joomla\Database\getDatabase(), Factory\getUser(), et ParameterType\INTEGER.

Documentation des champs

◆ $_cache

$_cache = array()
private

◆ $helpKey

$helpKey = 'Templates:_Edit_Style'
protected

◆ $helpURL

$helpURL
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StyleModel.php


Joomla CMS: Référence de la classe StylesModel

  • Joomla
  • Component
  • Templates
  • Administrator
  • Model
  • StylesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe StylesModel
+ Graphe d'héritage de StylesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.template', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of template style records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie

Références $clientId, $db, $query, $template, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et StringHelper\strtolower().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.template',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $clientId, $direction, $ordering, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StylesModel.php


Joomla CMS: Référence de la classe TemplateModel

  • Joomla
  • Component
  • Templates
  • Administrator
  • Model
  • TemplateModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe TemplateModel
+ Graphe d'héritage de TemplateModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTemplateList ()
getUpdatedList ($state=false, $all=false, $cleanup=false)
getCoreList ()
prepareCoreFiles ($dir, $element, $template)
publish ($ids, $value, $exid)
getFiles ()
getDirectoryTree ($dir)
getCoreFile ($file, $client_id)
& getTemplate ()
checkNewName ()
getFromName ()
copy ()
cleanup ()
getForm ($data=array(), $loadData=true)
& getSource ()
save ($data)
getOverridesFolder ($name, $path)
getOverridesList ()
createOverride ($override)
createTemplateOverride ($overridePath, $htmlPath)
deleteFile ($file)
createFile ($name, $type, $location)
uploadFile ($file, $location)
createFolder ($name, $location)
deleteFolder ($location)
renameFile ($file, $name)
getImage ()
cropImage ($file, $w, $h, $x, $y)
resizeImage ($file, $width, $height)
getPreview ()
getFont ()
copyFile ($newName, $location, $file)
getArchive ()
extractArchive ($file)
getMediaFiles ()
child ()
getAllTemplateStyles ()
copyStyles ()
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getFile ($path, $name)
storeFileInfo ($path, $name, $template)
populateState ()
fixTemplateName ()
loadFormData ()
checkFormat ($ext)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$template = null
$element = null
$mediaElement = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getSafeName ($name)
validateDate ($date)
getBasePath ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Template model class.

Depuis
1.6

Documentation des fonctions membres

◆ checkFormat()

checkFormat ( $ext )
protected

Check if the extension is allowed and will be shown in the template manager

Paramètres
string $ext The extension to check if it is allowed
Renvoie
boolean true if the extension is allowed false otherwise
Depuis
3.6.0

Références $params, et ComponentHelper\getParams().

◆ checkNewName()

checkNewName ( )

Method to check if new template name already exists

Renvoie
boolean true if name is not used, false otherwise
Depuis
2.5

Références $db, $name, $query, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ child()

child ( )

Method to create the templateDetails.xml for the child template

Renvoie
boolean true if name is not used, false otherwise
Depuis
4.1.0

Références $app, $client, $result, $template, $user, $xml, Text\_(), Path\clean(), File\copy(), Folder\create(), Folder\delete(), Folder\exists(), File\exists(), Factory\getApplication(), ApplicationHelper\getClientInfo(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), et File\write().

◆ cleanup()

cleanup ( )

Method to delete tmp folder

Renvoie
boolean true if delete successful, false otherwise
Depuis
2.5

Références $app, Folder\delete(), Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ copy()

copy ( )

Method to check if new template name already exists

Renvoie
boolean true if name is not used, false otherwise
Depuis
2.5

Références $app, $client, $folder, $languages, $manifest, $template, Text\_(), Path\clean(), Folder\copy(), File\copy(), Folder\create(), Folder\delete(), Folder\exists(), File\exists(), Factory\getApplication(), ApplicationHelper\getClientInfo(), Joomla\CMS\MVC\Model\getState(), et JPATH_SITE.

◆ copyFile()

copyFile | ( | $newName,
 |  | $location,
 |  | $file
 | ) |

Copy a file.

Paramètres
string | $newName | The name of the copied file
string | $location | The final location where the file is to be copied
string | $file | The name and location of the file
Renvoie
boolean true if image resize successful, false otherwise.
Depuis
3.2

Références $app, $explodeArray, $location, $path, Text\_(), Path\clean(), File\copy(), Factory\getApplication(), et Text\sprintf().

◆ copyStyles()

copyStyles ( )

Method to copy selected styles to the child template

Renvoie
boolean true if name is not used, false otherwise
Depuis
4.1.3

Références $app, $columns, $db, $query, $style, $template, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), Text\sprintf(), et ArrayHelper\toInteger().

◆ createFile()

createFile | ( | $name,
 |  | $type,
 |  | $location
 | ) |

Create new file.

Paramètres
string | $name | The name of file.
string | $type | The extension of the file.
string | $location | Location for the new file.
Renvoie
boolean true if file created successfully, false otherwise
Depuis
3.2

Références $app, $base, $check, $location, $name, $type, Text\_(), Path\clean(), Factory\getApplication(), et Text\sprintf().

◆ createFolder()

createFolder | ( | $name,
 |  | $location
 | ) |

Create new folder.

Paramètres
string | $name | The name of the new folder.
string | $location | Location for the new folder.
Renvoie
boolean True if override folder is created successfully, false otherwise
Depuis
3.2

Références $app, $base, $location, $name, $path, Text\_(), Path\clean(), Folder\create(), et Factory\getApplication().

◆ createOverride()

createOverride ( $override )

Create overrides.

Paramètres
string $override The override location.
Renvoie
boolean true if override creation is successful, false otherwise
Depuis
3.2

Références $app, $client, $explodeArray, $name, $path, $return, $size, $template, $url, Text\_(), Path\clean(), Folder\create(), elseif, Folder\exists(), Factory\getApplication(), ApplicationHelper\getClientInfo(), et JPATH_ROOT.

◆ createTemplateOverride()

createTemplateOverride | ( | $overridePath,
 |  | $htmlPath
 | ) |

Create override folder & file

Paramètres
string | $overridePath | The override location
string | $htmlPath | The html location
Renvoie
boolean True on success. False otherwise.

Références $folder, $return, File\copy(), Folder\create(), Folder\exists(), File\exists(), Folder\files(), Folder\folders(), Factory\getDate(), File\getExt(), null, et File\stripExt().

◆ cropImage()

cropImage | ( | $file,
 |  | $w,
 |  | $h,
 |  | $x,
 |  | $y
 | ) |

Crop an image.

Paramètres
string | $file | The name and location of the file
string | $w | width.
string | $h | height.
string | $x | x-coordinate.
string | $y | y-coordinate.
Renvoie
boolean true if image cropped successfully, false otherwise.
Depuis
3.2

Références $app, $image, $path, et Factory\getApplication().

◆ deleteFile()

deleteFile ( $file )

Delete a particular file.

Paramètres
string $file The relative location of the file.
Renvoie
boolean True if file deletion is successful, false otherwise
Depuis
3.2

Références $app, $return, Text\_(), File\delete(), et Factory\getApplication().

◆ deleteFolder()

deleteFolder ( $location )

Delete a folder.

Paramètres
string $location The name and location of the folder.
Renvoie
boolean True if override folder is deleted successfully, false otherwise
Depuis
3.2

Références $app, $base, $location, $path, $return, Text\_(), Path\clean(), Folder\delete(), et Factory\getApplication().

◆ extractArchive()

extractArchive ( $file )

Extract contents of an archive file.

Paramètres
string $file The name and location of the file
Renvoie
boolean true if image extraction is successful, false otherwise.
Depuis
3.2

Références $app, $explodeArray, $i, $path, Text\_(), Path\clean(), et Factory\getApplication().

◆ fixTemplateName()

fixTemplateName ( )
protected

Method to rename the template in the XML files and rename the language files

Renvoie
boolean true if successful, false otherwise
Depuis
2.5

Références $manifest, $result, $template, File\exists(), Folder\files(), Joomla\CMS\MVC\Model\getState(), File\move(), et File\write().

◆ getAllTemplateStyles()

getAllTemplateStyles ( )

Method to get the parent template existing styles

Renvoie
array array of id,titles of the styles
Depuis
4.1.3

Références $db, $query, $template, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ getArchive()

getArchive ( )

Get the compressed files.

Renvoie
array if file exists, false otherwise
Depuis
3.2

Références $app, $i, $path, Text\_(), Path\clean(), et Factory\getApplication().

◆ getBasePath()

getBasePath ( )
private

Method to resolve the base folder.

Renvoie
string The absolute path for the base.
Depuis
4.1.0

Références $app, $this, Factory\getApplication(), et JPATH_ROOT.

◆ getCoreFile()

getCoreFile | ( | $file,
 |  | $client_id
 | ) |

Method to get the core file of override file

Paramètres
string | $file | Override file
integer | $client_id | Client Id
Renvoie
string $corefile The full path and file name for the target file, or boolean false if the file is not found in any of the paths.
Depuis
4.0.0

Références $app, $client, $explodeArray, $folder, $type, Path\clean(), elseif, Path\find(), Factory\getApplication(), ApplicationHelper\getClientInfo(), et JPATH_ROOT.

◆ getCoreList()

getCoreList ( )

Method to get a list of all the core files of override files.

Renvoie
array An array of all core files.
Depuis
4.0.0

Références $app, $b, $client, $path, $template, Path\clean(), Factory\getApplication(), et ApplicationHelper\getClientInfo().

◆ getDirectoryTree()

getDirectoryTree ( $dir )

Get the directory tree.

Paramètres
string $dir The path of the directory to scan
Renvoie
array
Depuis
3.2

Références $dir, $key, $result, $this, $value, et JPATH_ROOT.

◆ getFile()

getFile | ( | $path,
 |  | $name
 | ) |
protected

Internal method to get file properties.

Paramètres
string | $path | The base path.
string | $name | The file name.
Renvoie
object
Depuis
1.6

Références $name, $path, $temp, $this, et JPATH_ROOT.

◆ getFiles()

getFiles ( )

Method to get a list of all the files to edit in a template.

Renvoie
array A nested array of relevant files.
Depuis
1.6

Références $app, $client, $lang, $path, $result, $template, Text\_(), Path\clean(), Factory\getApplication(), ApplicationHelper\getClientInfo(), et Factory\getLanguage().

◆ getFont()

getFont ( )

Rename a file.

Renvoie
mixed array on success, false on failure
Depuis
3.2

Références $app, $client, $explodeArray, $folder, $path, $template, $uri, Text\_(), Path\clean(), Factory\getApplication(), ApplicationHelper\getClientInfo(), et Uri\root().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $app, $db, $form, $query, $state, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\loadForm().

◆ getFromName()

getFromName ( )

Method to check if new template name already exists

Renvoie
string name of current template
Depuis
2.5

◆ getImage()

getImage ( )

Get an image address, height and width.

Renvoie
array an associative array containing image address, height and width.
Depuis
3.2

Références $app, $image, $path, $uri, Text\_(), Path\clean(), Factory\getApplication(), JPATH_ROOT, et Uri\root().

◆ getMediaFiles()

getMediaFiles ( )

Method to get a list of all the files to edit in a template's media folder.

Renvoie
array A nested array of relevant files.
Depuis
4.1.0

Références $app, $path, $result, $template, Text\_(), Path\clean(), Factory\getApplication(), JPATH_ROOT, et TemplatesHelper\parseXMLTemplateFile().

◆ getOverridesFolder()

getOverridesFolder | ( | $name,
 |  | $path
 | ) |

Get overrides folder.

Paramètres
string | $name | The name of override.
string | $path | Location of override.
Renvoie
object containing override name and path.
Depuis
3.2

Références $folder, $name, et $path.

◆ getOverridesList()

getOverridesList ( )

Get a list of overrides.

Renvoie
array containing overrides.
Depuis
3.2

Références $client, $component, $folder, $layout, $module, $modules, $path, $result, $template, $view, Path\clean(), Folder\folders(), ApplicationHelper\getClientInfo(), et JPATH_ROOT.

◆ getPreview()

getPreview ( )

Template preview.

Renvoie
object object containing the id of the template.
Depuis
3.2

Références $app, $db, $query, $result, Text\_(), Factory\getApplication(), et Joomla\Database\getDatabase().

◆ getSafeName()

getSafeName ( $name )
private

Creates a safe file name for the given name.

Paramètres
string $name The filename
Renvoie
string $fileName The filtered name without Date
Depuis
4.0.0

Références $date, $explodeArray, $extension, $name, $size, et File\getExt().

◆ getSource()

& getSource ( )

Method to get a single record.

Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $app, $input, $item, $this, Text\_(), Path\check(), Path\clean(), Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et JPATH_ROOT.

◆ getTemplate()

& getTemplate ( )

Method to get the template information.

Renvoie
mixed Object if successful, false if not and internal error is set.
Depuis
1.6

Références $app, $db, $query, $result, $template, $this, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), if, ParameterType\INTEGER, JPATH_ROOT, et TemplatesHelper\parseXMLTemplateFile().

◆ getTemplateList()

getTemplateList ( )

Method to get all template list.

Renvoie
object stdClass object
Depuis
4.0.0

Références $db, $query, $results, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getUpdatedList()

getUpdatedList | ( | $state = false,
 |  | $all = false,
 |  | $cleanup = false
 | ) |

Method to get all updated file list.

Paramètres
boolean | $state | The optional parameter if you want unchecked list.
boolean | $all | The optional parameter if you want all list.
boolean | $cleanup | The optional parameter if you want to clean record which is no more required.
Renvoie
object stdClass object
Depuis
4.0.0

Références $client, $db, $path, $query, $results, $state, $template, Path\clean(), elseif, ApplicationHelper\getClientInfo(), Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6

Références $app, $params, Factory\getApplication(), ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\setState().

◆ prepareCoreFiles()

prepareCoreFiles | ( | $dir,
 |  | $element,
 |  | $template
 | ) |

Prepare core files.

Paramètres
string | $dir | The path of the directory to scan.
string | $element | The path of the template element.
\stdClass | $template | The stdClass object of template.
Renvoie
array
Depuis
4.0.0

Références $dir, $info, $key, $template, et $value.

◆ publish()

publish | ( | $ids,
 |  | $value,
 |  | $exid
 | ) |

Method to update status of list.

Paramètres
array | $ids | The base path.
array | $value | The file name.
integer | $exid | The template extension id.
Renvoie
integer Number of files changed.
Depuis
4.0.0

Références $db, $id, $result, $value, elseif, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ renameFile()

renameFile | ( | $file,
 |  | $name
 | ) |

Rename a file.

Paramètres
string | $file | The name and location of the old file
string | $name | The new name of the file.
Renvoie
string Encoded string containing the new file location.
Depuis
3.2

Références $app, $explodeArray, $name, $path, $type, Text\_(), et Factory\getApplication().

◆ resizeImage()

resizeImage | ( | $file,
 |  | $width,
 |  | $height
 | ) |

Resize an image.

Paramètres
string | $file | The name and location of the file
string | $width | The new width of the image.
string | $height | The new height of the image.
Renvoie
boolean true if image resize successful, false otherwise.
Depuis
3.2

Références $app, $height, $image, $path, $width, Factory\getApplication(), et Image\SCALE_FILL.

◆ save()

save ( $data )

Method to store the source file contents.

Paramètres
array $data The source data to save.
Renvoie
boolean True on success, false otherwise and internal error set.
Depuis
1.6

Références $app, $data, $explodeArray, $return, $template, $this, $user, Text\_(), Path\clean(), Factory\getApplication(), Path\getPermissions(), PluginHelper\importPlugin(), Path\isOwner(), JPATH_ROOT, null, Path\setPermissions(), Text\sprintf(), et File\write().

◆ storeFileInfo()

storeFileInfo | ( | $path,
 |  | $name,
 |  | $template
 | ) |
protected

Method to store file information.

Paramètres
string | $path | The base path.
string | $name | The file name.
stdClass | $template | The std class object of template.
Renvoie
object stdClass object.
Depuis
4.0.0

Références $name, $path, $temp, $template, et null.

◆ uploadFile()

uploadFile | ( | $file,
 |  | $location
 | ) |

Upload new file.

Paramètres
array | $file | The uploaded file array.
string | $location | Location for the new file.
Renvoie
boolean True if file uploaded successfully, false otherwise
Depuis
3.2

Références $app, $location, $path, $url, Text\_(), TemplateHelper\canUpload(), Path\clean(), Factory\getApplication(), File\makeSafe(), null, et File\upload().

◆ validateDate()

validateDate ( $date )
private

Validate Date in file name.

Paramètres
string $date Date to validate.
Renvoie
boolean Return true if date is valid and false if not.
Depuis
4.0.0

Références $date, et $format.

Documentation des champs

◆ $element

$element = null
protected

◆ $mediaElement

$mediaElement = null
protected

◆ $template

$template = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_templates/src/Model/TemplateModel.php


Joomla CMS: Référence de la classe TemplatesModel

  • Joomla
  • Component
  • Templates
  • Administrator
  • Model
  • TemplatesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TemplatesModel
+ Graphe d'héritage de TemplatesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
updated ($exid)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.element', $direction='asc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of template extension records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Override parent getItems to add extra XML metadata.

Renvoie
array
Depuis
1.6

Implémente ListModelInterface.

Références $client, $item, $items, ApplicationHelper\getClientInfo(), et TemplatesHelper\parseXMLTemplateFile().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
Depuis
1.6

Références $clientId, $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et StringHelper\strtolower().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.element',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $clientId, $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ updated()

updated ( $exid )

Check if template extension have any updated override.

Paramètres
integer $exid Extension id of template.
Renvoie
boolean False if records not found/else integer.
Depuis
4.0.0

Références $db, $query, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/Model/TemplatesModel.php


Joomla CMS: Référence de la classe Templates

  • Joomla
  • Component
  • Templates
  • Administrator
  • Service
  • HTML
  • Templates
Fonctions membres publiques
Référence de la classe Templates

Fonctions membres publiques

thumb ($template, $clientId=0)
thumbModal ($template, $clientId=0)

Description détaillée

Html helper class.

Depuis
1.6

Documentation des fonctions membres

◆ thumb()

thumb | ( | $template,
 |  | $clientId = 0
 | ) |

Display the thumb for the template.

Paramètres
string | object | $template | The name of the template or the template object.
integer | $clientId | The application client ID the template applies to
Renvoie
string The html string
Depuis
1.6
Obsolète:
5.0 The argument $template should be object and $clientId will be removed

Références $client, $html, $template, Text\_(), HTMLHelper\_(), elseif, ApplicationHelper\getClientInfo(), JPATH_ROOT, TemplatesHelper\parseXMLTemplateFile(), et Uri\root().

◆ thumbModal()

thumbModal | ( | $template,
 |  | $clientId = 0
 | ) |

Renders the html for the modal linked to thumb.

Paramètres
string | object | $template | The name of the template or the template object.
integer | $clientId | The application client ID the template applies to
Renvoie
string The html string
Depuis
3.4
Obsolète:
5.0 The argument $template should be object and $clientId will be removed

Références $client, $html, $preview, $template, Text\_(), HTMLHelper\_(), elseif, ApplicationHelper\getClientInfo(), if, JPATH_ROOT, TemplatesHelper\parseXMLTemplateFile(), Uri\root(), et Text\sprintf().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Templates.php


Joomla CMS: Référence de la classe StyleTable

  • Joomla
  • Component
  • Templates
  • Administrator
  • Table
  • StyleTable
Fonctions membres publiques
Référence de la classe StyleTable
+ Graphe d'héritage de StyleTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
bind ($array, $ignore='')
check ()
store ($updateNulls=false)
delete ($pk=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Template style table class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db A database connector object
Depuis
1.6

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ bind()

bind | ( | $array,
 |  | $ignore = ''
 | ) |

Overloaded bind function to pre-process the params.

Paramètres
array | $array | Named array
mixed | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
null|string null if operation was satisfactory, otherwise returns an error
Depuis
1.6

Implémente TableInterface.

Références Text\_().

◆ check()

check ( )

Overloaded check method to ensure data integrity.

Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références Text\_().

◆ delete()

delete ( $pk = null )

Overloaded store method to unsure existence of a default style for a template.

Paramètres
mixed $pk An optional primary key value to delete. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $clientId, $query, $results, Text\_(), et ParameterType\INTEGER.

◆ store()

store ( $updateNulls = false )

Overloaded store method to ensure unicity of default style.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
1.6

Implémente TableInterface.

Références $clientId, $query, et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • StyleTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Style
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$item
$form
$state
$canDo
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a template style.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $lang, $url, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), Factory\getApplication(), Factory\getLanguage(), ToolbarHelper\help(), null, ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références ContentHelper\getActions().

Documentation des champs

◆ $canDo

$canDo
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/View/Style/HtmlView.php


Joomla CMS: Référence de la classe JsonView

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Style
  • JsonView
Fonctions membres publiques | Attributs protégés
Référence de la classe JsonView
+ Graphe d'héritage de JsonView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$item
$form
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

View to edit a template style.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
mixed A string if successful, otherwise an Error object.
Depuis
1.6

Implémente ViewInterface.

Références $app, et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/View/Style/JsonView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Styles
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
$preview
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of template styles.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $clientId, Text\_(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\link(), ToolbarHelper\makeDefault(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références ComponentHelper\getParams(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $preview

$preview

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/View/Styles/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Template
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
directoryTree ($array)
folderTree ($array)
mediaTree ($array)
mediaFolderTree ($array)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$template
$form
$source
$id
$file
$overridesList
$fileName
$type
$image
$preview
$font
$files
$archive
$pluginState
$mediaFiles
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a template style.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Depuis
1.6
Renvoie
void

Références $app, $client, $explodeArray, $this, $user, ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\divider(), elseif, Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), ToolbarHelper\help(), ToolbarHelper\modal(), Uri\root(), ToolbarHelper\save(), Text\sprintf(), et ToolbarHelper\title().

◆ directoryTree()

directoryTree ( $array )
protected

Method for creating the collapsible tree.

Paramètres
array $array The value of the present node for recursion
Renvoie
string
Note
Uses recursion
Depuis
3.2

Références $temp.

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void|boolean

Implémente ViewInterface.

Références $app, $explodeArray, $params, Text\_(), elseif, Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), InputFilter\getInstance(), ComponentHelper\getParams(), image, et PluginHelper\isEnabled().

◆ folderTree()

folderTree ( $array )
protected

Method for listing the folder tree in modals.

Paramètres
array $array The value of the present node for recursion
Renvoie
string
Note
Uses recursion
Depuis
3.2

Références $temp.

◆ mediaFolderTree()

mediaFolderTree ( $array )
protected

Method for listing the folder tree in modals.

Paramètres
array $array The value of the present node for recursion
Renvoie
string
Note
Uses recursion
Depuis
4.1.0

Références $temp.

◆ mediaTree()

mediaTree ( $array )
protected

Method for creating the collapsible tree.

Paramètres
array $array The value of the present node for recursion
Renvoie
string
Note
Uses recursion
Depuis
4.1.0

Références $temp.

Documentation des champs

◆ $archive

$archive
protected

◆ $file

$file
protected

◆ $fileName

$fileName
protected

◆ $files

$files
protected

◆ $font

$font
protected

◆ $form

$form
protected

◆ $id

$id
protected

◆ $image

$image
protected

◆ $mediaFiles

$mediaFiles
protected

◆ $overridesList

$overridesList
protected

◆ $pluginState

$pluginState
protected

◆ $preview

$preview
protected

◆ $source

$source
protected

◆ $state

$state
protected

◆ $template

$template
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/View/Template/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Templates
  • Administrator
  • View
  • Templates
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
$preview
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$file
$pluginState
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of template styles.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $clientId, Text\_(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\link(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.6

Implémente ViewInterface.

Références ComponentHelper\getParams(), PluginHelper\isEnabled(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $file

$file
protected

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $pluginState

$pluginState
protected

◆ $preview

$preview

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/src/View/Templates/HtmlView.php


Joomla CMS: Référence de la classe StylesController

  • Joomla
  • Component
  • Templates
  • Api
  • Controller
  • StylesController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe StylesController
+ Graphe d'héritage de StylesController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayItem ($id=null)
displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

preprocessSaveData (array $data)
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'styles'
$default_view = 'styles'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Fonctions membres privées

getClientIdFromInput ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The styles controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $id = null )

Basic display of an item view

Paramètres
integer $id The primary key to display. Leave empty if you want to retrieve data from the request
Renvoie
static A object to support chaining.
Depuis
4.0.0

Références $id.

◆ displayList()

displayList ( )

Basic display of a list view

Renvoie
static A object to support chaining.
Depuis
4.0.0

◆ getClientIdFromInput()

getClientIdFromInput ( )
private

Get client id from input

Renvoie
string
Depuis
4.0.0

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0
Exceptions
InvalidParameterException

Références $data, $model, et Inflector\singularize().

Documentation des champs

◆ $contentType

$contentType = 'styles'
protected

◆ $default_view

$default_view = 'styles'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_templates/src/Controller/StylesController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Templates
  • Api
  • View
  • Styles
  • JsonapiView
Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The styles view

Depuis
4.0.0

Documentation des fonctions membres

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $item, et $this.

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'template',
'client_id',
'home',
'title',
'params',
'xml',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'template',
'title',
'home',
'client_id',
'language_title',
'image',
'language_sef',
'assigned',
'e_id',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_templates/src/View/Styles/JsonapiView.php


Joomla CMS: Référence de la classe CallbackController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • CallbackController
Fonctions membres publiques
Référence de la classe CallbackController
+ Graphe d'héritage de CallbackController:
BaseController ControllerInterface DispatcherAwareInterface CallbackController

Fonctions membres publiques

__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
callback ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication plugins' AJAX callback controller

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Public constructor

Paramètres
array | $config | Plugin configuration
MVCFactoryInterface | null | $factory | MVC Factory for the com_users component
CMSApplication | null | $app | CMS application object
Input | null | $input | Joomla CMS input object
Depuis
4.2.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ callback()

callback | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Implement a callback feature, typically used for OAuth2 authentication

Paramètres
bool | $cachable | Can this view be cached
array | bool | $urlparams | An array of safe url parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
void
Depuis
4.2.0

The first plugin to handle the request should either redirect or close the application. If we are still here no plugin handled the request successfully. Show an error.

Références $app, $method, Text\_(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/CallbackController.php


Joomla CMS: Référence de la classe CaptiveController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • CaptiveController
Fonctions membres publiques
Référence de la classe CaptiveController
+ Graphe d'héritage de CaptiveController:
BaseController ControllerInterface DispatcherAwareInterface CaptiveController

Fonctions membres publiques

__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Captive Multi-factor Authentication page controller

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Public constructor

Paramètres
array | $config | Plugin configuration
MVCFactoryInterface | null | $factory | MVC Factory for the com_users component
CMSApplication | null | $app | CMS application object
Input | null | $input | Joomla CMS input object
Depuis
4.2.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/CaptiveController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

canView ($view)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$default_view = 'users'
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Users master display controller.

Depuis
1.6

Documentation des fonctions membres

◆ canView()

canView ( $view )
protected

Checks whether a user can see this view.

Paramètres
string $view The view name.
Renvoie
boolean
Depuis
1.6

Références $canDo, $view, et ContentHelper\getActions().

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see Joomla\CMS\Filter\InputFilter::clean().@returnBaseController|booleanThisobjecttosupportchainingorfalseonfailure.@since1.5

Références $id, $layout, $task, $view, Text\_(), Route\_(), elseif, et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'users'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe GroupController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • GroupController
Fonctions membres protégées | Attributs protégés
Référence de la classe GroupController
+ Graphe d'héritage de GroupController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres protégées

allowSave ($data, $key='id')
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_USERS_GROUP'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User view level controller class.

Depuis
1.6

Documentation des fonctions membres

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Overrides Joomla::allowEdit

Checks that non-Super Admins are not editing Super Admins.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, $key, et Access\checkGroup().

◆ allowSave()

allowSave | ( | $data,
 |  | $key = 'id'
 | ) |
protected

Method to check if you can save a new or existing record.

Overrides Joomla::allowSave to check the core.admin permission.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, et $key.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_GROUP'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/Controller/GroupController.php


Joomla CMS: Référence de la classe GroupsController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • GroupsController
Fonctions membres publiques | Attributs protégés
Référence de la classe GroupsController
+ Graphe d'héritage de GroupsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Group', $prefix='Administrator', $config=array('ignore_request'=> true))
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_USERS_GROUPS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User groups list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ checkin()

checkin ( )

Check in of one or more records.

Overrides Joomla::checkin to check the core.admin permission.

Renvoie
boolean True on success
Depuis
1.6

Références Text\_().

◆ delete()

delete ( )

Removes an item.

Overrides Joomla::delete to check the core.admin permission.

Renvoie
void
Depuis
1.6

Références Text\_().

◆ getModel()

getModel | ( | $name = 'Group',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ publish()

publish ( )

Method to publish a list of records.

Overrides Joomla::publish to check the core.admin permission.

Renvoie
void
Depuis
1.6

Références Text\_().

◆ reorder()

reorder ( )

Changes the order of one or more records.

Overrides Joomla::reorder to check the core.admin permission.

Renvoie
boolean True on success
Depuis
1.6

Références Text\_().

◆ saveorder()

saveorder ( )

Method to save the submitted ordering values for records.

Overrides Joomla::saveorder to check the core.admin permission.

Renvoie
boolean True on success
Depuis
1.6

Références Text\_().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_GROUPS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/GroupsController.php


Joomla CMS: Référence de la classe LevelController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • LevelController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe LevelController
+ Graphe d'héritage de LevelController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

delete ()
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowSave ($data, $key='id')
allowEdit ($data=array(), $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_USERS_LEVEL'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User view level controller class.

Depuis
1.6

Documentation des fonctions membres

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Overrides JControllerForm::allowEdit

Checks that non-Super Admins are not editing Super Admins.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
3.8.8

Références $data, $key, Text\_(), Route\_(), et Access\checkGroup().

◆ allowSave()

allowSave | ( | $data,
 |  | $key = 'id'
 | ) |
protected

Method to check if you can save a new or existing record.

Overrides Joomla::allowSave to check the core.admin permission.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
1.6

Références $data, et $key.

◆ delete()

delete ( )

Removes an item.

Overrides Joomla::delete to check the core.admin permission.

Renvoie
void
Depuis
1.6

Références $model, Text\_(), Joomla\Application\checkToken(), elseif, et Text\plural().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_LEVEL'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LevelController.php


Joomla CMS: Référence de la classe LevelsController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • LevelsController
Fonctions membres publiques | Attributs protégés
Référence de la classe LevelsController
+ Graphe d'héritage de LevelsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Level', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_USERS_LEVELS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User view levels list controller class.

Depuis
1.6

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Level',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
1.6

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_LEVELS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/LevelsController.php


Joomla CMS: Référence de la classe MailController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • MailController
Fonctions membres publiques
Référence de la classe MailController
+ Graphe d'héritage de MailController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

send ()
cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Users mail controller.

Depuis
1.6

Documentation des fonctions membres

◆ cancel()

cancel ( )

Cancel the mail

Renvoie
void
Depuis
1.6

Références Joomla\Application\checkToken(), et null.

◆ send()

send ( )

Send the mail

Renvoie
void
Depuis
1.6

Références $model, $type, Route\_(), et Joomla\Application\checkToken().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MailController.php


Joomla CMS: Référence de la classe MethodController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • MethodController
Fonctions membres publiques | Fonctions membres privées
Référence de la classe MethodController
+ Graphe d'héritage de MethodController:
BaseController ControllerInterface DispatcherAwareInterface MethodController

Fonctions membres publiques

__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
execute ($task)
delete ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres privées

assertCanEdit (?User $user=null)
assertCanDelete (?User $user=null)
assertLoggedInUser ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication method controller

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Public constructor

Paramètres
array | $config | Plugin configuration
MVCFactoryInterface | null | $factory | MVC Factory for the com_users component
CMSApplication | null | $app | CMS application object
Input | null | $input | Joomla CMS input object
Depuis
4.2.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ assertCanDelete()

assertCanDelete ( ?User $user = null )
private

Assert that the user can delete MFA records / disable MFA.

Paramètres
User | null $user User record. Null to use current user.
Renvoie
void
Exceptions
RuntimeException|Exception
Depuis
4.2.0

Références $user, et Text\_().

◆ assertCanEdit()

assertCanEdit ( ?User $user = null )
private

Assert that the user can add / edit MFA methods.

Paramètres
User | null $user User record. Null to use current user.
Renvoie
void
Exceptions
RuntimeException|Exception
Depuis
4.2.0

Références $user, et Text\_().

◆ assertLoggedInUser()

assertLoggedInUser ( )
private

Assert that there is a logged in user.

Renvoie
void
Depuis
4.2.0

Références $user, Text\_(), class, et Factory\getContainer().

◆ delete()

delete | ( | $cachable = false,
 |  | $urlparams = []
 | ) |

Delete an existing MFA Method

Paramètres
boolean | $cachable | Ignored. This page is never cached.
boolean | array | $urlparams | Ignored. This page is never cached.
Renvoie
void
Depuis
4.2.0

Références $id, $message, $type, $url, $user, $userId, Text\_(), Route\_(), Joomla\Application\checkToken(), class, Factory\getContainer(), et null.

◆ execute()

execute ( $task )

Execute a task by triggering a Method in the derived class.

Paramètres
string $task The task to perform. If no matching task is found, the '__default' task is executed, if defined.
Renvoie
mixed The value returned by the called Method.
Exceptions
Exception
Depuis
4.2.0

Implémente ControllerInterface.

Références $task.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/MethodController.php


Joomla CMS: Référence de la classe MethodsController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • MethodsController
Fonctions membres publiques | Fonctions membres privées
Référence de la classe MethodsController
+ Graphe d'héritage de MethodsController:
BaseController ControllerInterface DispatcherAwareInterface MethodsController

Fonctions membres publiques

__construct ($config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
display ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres privées

assertLoggedInUser ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication methods selection and management controller

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = [],
 |  | MVCFactoryInterface | $factory = null,
 |  | ?CMSApplication | $app = null,
 |  | ?Input | $input = null
 | ) |  |

Public constructor

Paramètres
array | $config | Plugin configuration
MVCFactoryInterface | null | $factory | MVC Factory for the com_users component
CMSApplication | null | $app | CMS application object
Input | null | $input | Joomla CMS input object
Depuis
4.2.0

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ assertLoggedInUser()

assertLoggedInUser ( )
private

Assert that there is a user currently logged in

Renvoie
void
Depuis
4.2.0

Références $user, Text\_(), class, et Factory\getContainer().

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = []
 | ) |

List all available Multi-factor Authentication Methods available and guide the user to setting them up

Paramètres
bool | $cachable | Can this view be cached
array | $urlparams | An array of safe url parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
void
Depuis
4.2.0

Références $user, $userId, $view, Text\_(), class, Factory\getContainer(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/MethodsController.php


Joomla CMS: Référence de la classe NoteController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • NoteController
Fonctions membres protégées | Attributs protégés
Référence de la classe NoteController
+ Graphe d'héritage de NoteController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres protégées

getRedirectToItemAppend ($recordId=null, $key='id')
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_USERS_NOTE'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User note controller class.

Depuis
2.5

Documentation des fonctions membres

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $key = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $key | The name of the primary key variable.
Renvoie
string The arguments to append to the redirect URL.
Depuis
2.5

Références $append, $key, $recordId, et $userId.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_NOTE'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoteController.php


Joomla CMS: Référence de la classe NotesController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • NotesController
Fonctions membres publiques | Attributs protégés
Référence de la classe NotesController
+ Graphe d'héritage de NotesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

getModel ($name='Note', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_USERS_NOTES'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User notes controller class.

Depuis
2.5

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Note',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Method to get a model object, loading it if required.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
The model.
Depuis
2.5

Références $config, $name, et $prefix.

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_NOTES'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotesController.php


Joomla CMS: Référence de la classe UserController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • UserController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UserController
+ Graphe d'héritage de UserController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

cancel ($key=null)
save ($key=null, $urlVar=null)
batch ($model=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowEdit ($data=array(), $key='id')
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$text_prefix = 'COM_USERS_USER'
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

User controller class.

Depuis
1.6

Documentation des fonctions membres

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Overrides Joomla::allowEdit

Checks that non-Super Admins are not editing Super Admins.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean True if allowed, false otherwise.
Depuis
1.6

Références $data, $key, et Access\check().

◆ batch()

batch ( $model = null )

Method to run batch operations.

Paramètres
object $model The model.
Renvoie
boolean True on success, false on failure
Depuis
2.5

Références $model, Route\_(), et Joomla\Application\checkToken().

◆ cancel()

cancel ( $key = null )

Override parent cancel to redirect when using status edit account.

Paramètres
string $key The name of the primary key of the URL variable.
Renvoie
boolean True if access level checks pass, false otherwise.
Depuis
4.0.0

Références $result, $return, Uri\base(), et Uri\isInternal().

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |
protected

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
3.1

◆ save()

save | ( | $key = null,
 |  | $urlVar = null
 | ) |

Override parent save to redirect when using status edit account.

Paramètres
string | $key | The name of the primary key of the URL variable.
string | $urlVar | The name of the URL variable if different from the primary key (sometimes required to avoid router collisions).
Renvoie
boolean True if successful, false otherwise.
Depuis
4.0.0

Références $key, $result, $return, $task, Uri\base(), et Uri\isInternal().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_USER'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/UserController.php


Joomla CMS: Référence de la classe UsersController

  • Joomla
  • Component
  • Users
  • Administrator
  • Controller
  • UsersController
Fonctions membres publiques | Attributs protégés
Référence de la classe UsersController
+ Graphe d'héritage de UsersController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='User', $prefix='Administrator', $config=array('ignore_request'=> true))
changeBlock ()
activate ()
getQuickiconContent ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$text_prefix = 'COM_USERS_USERS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Users list controller class.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The CMSApplication for the dispatcher
Input | $input | Input
Depuis
1.6
Voir également
BaseController
Exceptions

Références $app, $config, $input, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ activate()

activate ( )

Method to activate a record.

Renvoie
void
Depuis
1.6

Références $model, Text\_(), Joomla\Application\checkToken(), et Text\plural().

◆ changeBlock()

changeBlock ( )

Method to change the block status on a record.

Renvoie
void
Depuis
1.6

Références $model, $task, $value, Text\_(), Joomla\Application\checkToken(), elseif, ArrayHelper\getValue(), et Text\plural().

◆ getModel()

getModel | ( | $name = 'User',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel.

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
object The model.
Depuis
1.6

Références $config, $name, et $prefix.

◆ getQuickiconContent()

getQuickiconContent ( )

Method to get the number of active users

Renvoie
void
Depuis
4.0.0

Références $model, $result, et Text\plural().

Documentation des champs

◆ $text_prefix

$text_prefix = 'COM_USERS_USERS'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Controller/UsersController.php


Joomla CMS: Référence de la classe CaptiveRenderOptions

  • Joomla
  • Component
  • Users
  • Administrator
  • DataShape
  • CaptiveRenderOptions
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe CaptiveRenderOptions
+ Graphe d'héritage de CaptiveRenderOptions:
DataShapeObject

Champs de données

const | FIELD_INPUT = 'input'
const | FIELD_CUSTOM = 'custom'

Fonctions membres protégées

setField_type (string $value)
setInput_attributes (array $value)

Attributs protégés

$pre_message = ''
$field_type = 'input'
$input_type = ''
$input_attributes = []
$placeholder = ''
$label = ''
$html = ''
$post_message = ''
$hide_submit = false
$submit_class = ''
$submit_icon = 'icon icon-rightarrow icon-arrow-right'
$submit_text = 'COM_USERS_MFA_VALIDATE'
$allowEntryBatching = true
$help_url = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de DataShapeObject
__construct (array $array=[])
asArray ()
merge ($newValues)
__get ($name)
__set ($name, $value)
__isset ($name)
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)

Documentation des fonctions membres

◆ setField_type()

setField_type ( string $value )
protected

Setter for the field_type property

Paramètres
string $value One of self::FIELD_INPUT, self::FIELD_CUSTOM
Depuis
4.2.0
Exceptions
InvalidArgumentException

Références $value.

◆ setInput_attributes()

setInput_attributes ( array $value )
protected

Setter for the input_attributes property.

Paramètres
array $value The value to set
Renvoie
void @since 4.2.0

Références $key, et $value.

Documentation des champs

◆ $allowEntryBatching

$allowEntryBatching = true
protected

◆ $field_type

$field_type = 'input'
protected

◆ $help_url

$help_url = ''
protected

◆ $hide_submit

$hide_submit = false
protected

◆ $html

$html = ''
protected

◆ $input_attributes

$input_attributes = []
protected

◆ $input_type

$input_type = ''
protected

◆ $label

$label = ''
protected

◆ $placeholder

$placeholder = ''
protected

◆ $post_message

$post_message = ''
protected

◆ $pre_message

$pre_message = ''
protected

◆ $submit_class

$submit_class = ''
protected

◆ $submit_icon

$submit_icon = 'icon icon-rightarrow icon-arrow-right'
protected

◆ $submit_text

$submit_text = 'COM_USERS_MFA_VALIDATE'
protected

◆ FIELD_CUSTOM

const FIELD_CUSTOM = 'custom'

Display a custom HTML document. Use the html property to set it up.

Depuis
4.2.0

◆ FIELD_INPUT

const FIELD_INPUT = 'input'

Display a standard HTML5 input field. Use the input_type, placeholder and label properties to set it up.

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CaptiveRenderOptions.php


Joomla CMS: Référence de la classe DataShapeObject

  • Joomla
  • Component
  • Users
  • Administrator
  • DataShape
  • DataShapeObject
Fonctions membres publiques
Référence de la classe DataShapeObject
+ Graphe d'héritage de DataShapeObject:
CaptiveRenderOptions MethodDescriptor SetupRenderOptions

Fonctions membres publiques

__construct (array $array=[])
asArray ()
merge ($newValues)
__get ($name)
__set ($name, $value)
__isset ($name)
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)

Description détaillée

Generic helper for handling data shapes in com_users

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $array = [] )

Public constructor

Paramètres
array $array The data to initialise this object with
Depuis
4.2.0

Références $this.

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic getter

Paramètres
string $name The name of the property to retrieve
Renvoie
mixed
Depuis
4.2.0

Références $methodName, $name, et $this.

◆ __isset()

__isset ( $name )

Is a property set?

Paramètres
string $name Property name
Renvoie
boolean Does it exist in the object?
Depuis
4.2.0

Références $methodName, $name, et $this.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Magic Setter

Paramètres
string | $name | The property to set the value for
mixed | $value | The property value to set it to
Renvoie
mixed
Depuis
4.2.0

Références $methodName, $name, $this, et $value.

◆ asArray()

asArray ( )

Get the data shape as a key-value array

Renvoie
array
Depuis
4.2.0

Références $this.

◆ merge()

merge ( $newValues )

Merge another data shape object or key-value array into this object.

Paramètres
array | self $newValues The object or array to merge into self.
Renvoie
$this
Depuis
4.2.0

Références $this.

◆ offsetExists()

offsetExists ( $offset )

Does the property exist (array access)?

Paramètres
string $offset Property name
Renvoie
boolean
Depuis
4.2.0

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Get the value of a property (array access).

Paramètres
string $offset Property name
Renvoie
mixed
Depuis
4.2.0

Références Joomla\Database\Query\$offset.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Set the value of a property (array access).

Paramètres
string | $offset | Property name
mixed | $value | Property value
Renvoie
void
Depuis
4.2.0

Références Joomla\Database\Query\$offset, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Unset a property (array access).

Paramètres
string $offset Property name
Renvoie
mixed
Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DataShapeObject.php


Joomla CMS: Référence de la classe MethodDescriptor

  • Joomla
  • Component
  • Users
  • Administrator
  • DataShape
  • MethodDescriptor
Fonctions membres publiques | Attributs protégés
Référence de la classe MethodDescriptor
+ Graphe d'héritage de MethodDescriptor:
DataShapeObject

Fonctions membres publiques

addActiveMethod (MfaTable $record)
- Fonctions membres publiques hérités de DataShapeObject
__construct (array $array=[])
asArray ()
merge ($newValues)
__get ($name)
__set ($name, $value)
__isset ($name)
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)

Attributs protégés

$name = ''
$display = ''
$shortinfo = ''
$image = ''
$canDisable = true
$allowMultiple = false
$help_url = ''
$allowEntryBatching = false
$active = []

Documentation des fonctions membres

◆ addActiveMethod()

addActiveMethod ( MfaTable $record )

Adds an active MFA method

Paramètres
MfaTable $record The MFA method record to add
Renvoie
void
Depuis
4.2.0

Documentation des champs

◆ $active

$active = []
protected

◆ $allowEntryBatching

$allowEntryBatching = false
protected

◆ $allowMultiple

$allowMultiple = false
protected

◆ $canDisable

$canDisable = true
protected

◆ $display

$display = ''
protected

◆ $help_url

$help_url = ''
protected

◆ $image

$image = ''
protected

◆ $name

$name = ''
protected

◆ $shortinfo

$shortinfo = ''
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MethodDescriptor.php


Joomla CMS: Référence de la classe SetupRenderOptions

  • Joomla
  • Component
  • Users
  • Administrator
  • DataShape
  • SetupRenderOptions
Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe SetupRenderOptions
+ Graphe d'héritage de SetupRenderOptions:
DataShapeObject

Champs de données

const | FIELD_INPUT = 'input'
const | FIELD_CUSTOM = 'custom'

Fonctions membres protégées

setField_type ($value)
setInput_attributes (array $value)

Attributs protégés

$default_title = ''
$pre_message = ''
$table_heading = ''
$tabular_data = []
$hidden_data = []
$field_type = 'input'
$input_type = 'text'
$input_attributes = []
$input_value = ''
$placeholder = ''
$label = ''
$html = ''
$show_submit = true
$submit_class = ''
$submit_icon = 'icon icon-ok'
$submit_text = 'JSAVE'
$post_message = ''
$help_url = ''

Membres hérités additionnels

- Fonctions membres publiques hérités de DataShapeObject
__construct (array $array=[])
asArray ()
merge ($newValues)
__get ($name)
__set ($name, $value)
__isset ($name)
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)

Documentation des fonctions membres

◆ setField_type()

setField_type ( $value )
protected

Setter for the field_type property

Paramètres
string $value One of self::FIELD_INPUT, self::FIELD_CUSTOM
Depuis
4.2.0
Exceptions
InvalidArgumentException

Références $value.

◆ setInput_attributes()

setInput_attributes ( array $value )
protected

Setter for the input_attributes property.

Paramètres
array $value The value to set
Renvoie
void
Depuis
4.2.0

Références $key, et $value.

Documentation des champs

◆ $default_title

$default_title = ''
protected

◆ $field_type

$field_type = 'input'
protected

◆ $help_url

$help_url = ''
protected

◆ $hidden_data

$hidden_data = []
protected

◆ $html

$html = ''
protected

◆ $input_attributes

$input_attributes = []
protected

◆ $input_type

$input_type = 'text'
protected

◆ $input_value

$input_value = ''
protected

◆ $label

$label = ''
protected

◆ $placeholder

$placeholder = ''
protected

◆ $post_message

$post_message = ''
protected

◆ $pre_message

$pre_message = ''
protected

◆ $show_submit

$show_submit = true
protected

◆ $submit_class

$submit_class = ''
protected

◆ $submit_icon

$submit_icon = 'icon icon-ok'
protected

◆ $submit_text

$submit_text = 'JSAVE'
protected

◆ $table_heading

$table_heading = ''
protected

◆ $tabular_data

$tabular_data = []
protected

◆ FIELD_CUSTOM

const FIELD_CUSTOM = 'custom'

Display a custom HTML document. Use the html property to set it up.

Depuis
4.2.0

◆ FIELD_INPUT

const FIELD_INPUT = 'input'

Display a standard HTML5 input field. Use the input_type, placeholder and label properties to set it up.

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SetupRenderOptions.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Users
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_users

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Override checkAccess to allow users edit profile without having to have core.manager permission

Renvoie
void
Depuis
4.0.0

Special case: Multi-factor Authentication

We allow access to all MFA views and tasks. Access control for MFA tasks is performed in the Controllers since what is allowed depends on who is logged in and whose account you are trying to modify. Implementing these checks in the Dispatcher would violate the separation of concerns.

Références $id, $layout, $task, $taskPrefix, $user, $view, et false.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe UsersComponent

  • Joomla
  • Component
  • Users
  • Administrator
  • Extension
  • UsersComponent
Fonctions membres publiques
Référence de la classe UsersComponent
+ Graphe d'héritage de UsersComponent:
MVCComponent BootableExtensionInterface RouterServiceInterface FieldsServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Fonctions membres publiques

boot (ContainerInterface $container)
validateSection ($section, $item=null)
getContexts ()
- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_users

Depuis
4.0.0

Documentation des fonctions membres

◆ boot()

boot ( ContainerInterface $container )

Booting the extension. This is the function to set up the environment of the extension like registering new class loaders, etc.

If required, some initial set up can be done from services of the container, eg. registering HTML services.

Paramètres
ContainerInterface $container The container
Renvoie
void
Depuis
4.0.0

Implémente BootableExtensionInterface.

Références Joomla\CMS\HTML\getRegistry().

◆ getContexts()

getContexts ( )

Returns valid contexts.

Renvoie
array Associative array with contexts as keys and translated strings as values
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $language, Factory\getApplication(), et JPATH_ADMINISTRATOR.

◆ validateSection()

validateSection | ( | $section,
 |  | $item = null
 | ) |

Returns a valid section for the given section. If it is not valid then null is returned.

Paramètres
string | $section | The section to get the mapping for
object | null | $item | The content item or null
Renvoie
string|null The new section or null
Depuis
4.0.0

Implémente FieldsServiceInterface.

Références $section, Factory\getApplication(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UsersComponent.php


Joomla CMS: Référence de la classe GroupparentField

  • Joomla
  • Component
  • Users
  • Administrator
  • Field
  • GroupparentField
Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe GroupparentField
+ Graphe d'héritage de GroupparentField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'GroupParent'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Fonctions membres privées

cleanOptionsChildrenByFather ($userGroupsOptions, $fatherId)

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

User Group Parent field..

Depuis
1.6

Documentation des fonctions membres

◆ cleanOptionsChildrenByFather()

cleanOptionsChildrenByFather | ( | $userGroupsOptions,
 |  | $fatherId
 | ) |
private

Method to clean the Usergroup Options from all children starting by a given father

Paramètres
array | $userGroupsOptions | The usergroup options to clean
integer | $fatherId | The father ID to start with
Renvoie
array The cleaned field options
Depuis
3.9.4

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects
Depuis
1.6

Références $i, $n, $options, Access\checkGroup(), Factory\getApplication(), UserGroupsHelper\getInstance(), Factory\getUser(), et level.

Documentation des champs

◆ $type

$type = 'GroupParent'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • GroupparentField.php


Joomla CMS: Référence de la classe LevelsField

  • Joomla
  • Component
  • Users
  • Administrator
  • Field
  • LevelsField
Fonctions membres protégées | Attributs protégés
Référence de la classe LevelsField
+ Graphe d'héritage de LevelsField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Levels'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Access Levels field.

Depuis
3.6.0

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects
Depuis
3.6.0

Références DebugHelper\getLevelsOptions().

Documentation des champs

◆ $type

$type = 'Levels'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LevelsField.php


Joomla CMS: Référence de la classe ModulesPositionField

  • Joomla
  • Component
  • Users
  • Administrator
  • Field
  • ModulesPositionField
Référence de la classe ModulesPositionField
+ Graphe d'héritage de ModulesPositionField:
ModulesPositionField ListField FormField DatabaseAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de ModulesPositionField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
getOptions ()
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés hérités de ModulesPositionField
$type = 'ModulesPosition'
$client
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Select modules positions.

Reuses the same field from com_modules. Don't lose it; reuse it!

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/Field/ModulesPositionField.php


Joomla CMS: Référence de la classe DebugHelper

  • Joomla
  • Component
  • Users
  • Administrator
  • Helper
  • DebugHelper
Fonctions membres publiques statiques
Référence de la classe DebugHelper
+ Graphe d'héritage de DebugHelper:
UsersHelperDebug

Fonctions membres publiques statiques

static | getComponents ()
static | getDebugActions ($component=null)
static | getLevelsOptions ()

Description détaillée

Users component debugging helper.

Depuis
1.6

Documentation des fonctions membres

◆ getComponents()

static getComponents ( )
static

Get a list of the components.

Renvoie
array
Depuis
1.6

Références $db, $extension, $item, $items, $lang, $query, Text\_(), Factory\getDbo(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et ArrayHelper\sortObjects().

◆ getDebugActions()

static getDebugActions ( $component = null )
static

Get a list of the actions for the component or code actions.

Paramètres
string $component The name of the component.
Renvoie
array
Depuis
1.6

Références $actions, $component, $extension, $field, $lang, $xml, Access\getActionsFromFile(), Factory\getLanguage(), if, JPATH_ADMINISTRATOR, et null.

Référencé par DebuguserModel\getDebugActions(), et DebuggroupModel\getDebugActions().

◆ getLevelsOptions()

static getLevelsOptions ( )
static

Get a list of filter options for the levels.

Renvoie
array An array of elements.

Références $options, HTMLHelper\_(), et Text\sprintf().

Référencé par LevelsField\getOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugHelper.php


Joomla CMS: Référence de la classe Mfa

  • Joomla
  • Component
  • Users
  • Administrator
  • Helper
  • Mfa
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe Mfa

Fonctions membres publiques statiques

static | getMfaMethods ()
static | canAddEditMethod (?User $user=null)
static | canDeleteMethod (?User $user=null)

Attributs protégés statiques

static | $allMFAs = null
static | $isAdmin = null

Description détaillée

Helper functions for captive MFA handling

Depuis
4.2.0

Documentation des fonctions membres

◆ canAddEditMethod()

static canAddEditMethod ( ?User $user = null )
static

Is the current user allowed to add/edit MFA methods for $user?

This is only allowed if I am adding / editing methods for myself.

If the target user is a member of any group disallowed to use MFA this will return false.

Paramètres
User | null $user The user you want to know if we're allowed to edit
Renvoie
boolean
Exceptions
Exception
Depuis
4.2.0

Références $user, class, Factory\getApplication(), Factory\getContainer(), et ComponentHelper\getParams().

◆ canDeleteMethod()

static canDeleteMethod ( ?User $user = null )
static

Is the current user allowed to delete MFA methods / disable MFA for $user?

This is allowed if:

  • The user being queried is the same as the logged-in user
  • The logged-in user is a Super User AND the queried user is NOT a Super User.

Note that Super Users can be edited by their own user only for security reasons. If a Super User gets locked out they must use the Backup Codes to regain access. If that's not possible, they will need to delete their records from the #__user_mfa table.

Paramètres
User | null $user The user being queried.
Renvoie
boolean
Exceptions
Exception
Depuis
4.2.0

Références $user, class, Factory\getApplication(), et Factory\getContainer().

◆ getMfaMethods()

static getMfaMethods ( )
static

Get a list of all of the MFA Methods

Renvoie
MethodDescriptor[]
Depuis
4.2.0

Références $method, $temp, Factory\getApplication(), et PluginHelper\importPlugin().

Documentation des champs

◆ $allMFAs

$allMFAs = null
staticprotected

◆ $isAdmin

$isAdmin = null
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Mfa.php


Joomla CMS: Référence de la classe UsersHelper

  • Joomla
  • Component
  • Users
  • Administrator
  • Helper
  • UsersHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe UsersHelper
+ Graphe d'héritage de UsersHelper:
ContentHelper UsersHelper

Fonctions membres publiques statiques

static | getStateOptions ()
static | getActiveOptions ()
static | getGroups ()
static | getRangeOptions ()
static | getTwoFactorMethods ()
static | getVisibleByGroups ($rules)
static | validateSection ($section)
static | getContexts ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Attributs protégés statiques

static $actions

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)

Description détaillée

Users component helper.

Depuis
1.6

Documentation des fonctions membres

◆ getActiveOptions()

static getActiveOptions ( )
static

Get a list of filter options for the activated state of a user.

Renvoie
array An array of elements.
Depuis
1.6

Références $options, Text\_(), et HTMLHelper\_().

◆ getContexts()

static getContexts ( )
static

Returns valid contexts

Renvoie
array
Depuis
3.7.0
Obsolète:
5.0 Use ::getContexts() instead.

Références Factory\getApplication().

◆ getGroups()

static getGroups ( )
static

Get a list of the user groups for filtering.

Renvoie
array An array of elements.
Depuis
1.6

Références $option, $options, et UserGroupsHelper\getInstance().

◆ getRangeOptions()

static getRangeOptions ( )
static

Creates a list of range options used in filter select list used in com_users on users view

Renvoie
array
Depuis
2.5

Références $options, Text\_(), et HTMLHelper\_().

◆ getStateOptions()

static getStateOptions ( )
static

Get a list of filter options for the blocked state of a user.

Renvoie
array An array of elements.
Depuis
1.6

Références $options, Text\_(), et HTMLHelper\_().

◆ getTwoFactorMethods()

static getTwoFactorMethods ( )
static

No longer used.

Renvoie
array
Depuis
3.2.0
Exceptions

◆ getVisibleByGroups()

static getVisibleByGroups ( $rules )
static

Get a list of the User Groups for Viewing Access Levels

Paramètres
string $rules User Groups in JSON format
Renvoie
string $groups Comma separated list of User Groups
Depuis
3.6

Références $db, $groups, $query, et Factory\getDbo().

◆ validateSection()

static validateSection ( $section )
static

Returns a valid section for users. If it is not valid then null is returned.

Paramètres
string $section The section to get the mapping for
Renvoie
string|null The new section
Depuis
3.7.0
Exceptions

Références $section, Factory\getApplication(), et null.

Documentation des champs

◆ $actions

$actions
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UsersHelper.php


Joomla CMS: Référence de la classe BackupcodesModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • BackupcodesModel
Fonctions membres publiques | Attributs protégés
Référence de la classe BackupcodesModel
+ Graphe d'héritage de BackupcodesModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface BackupcodesModel

Fonctions membres publiques

regenerateBackupCodes (User $user=null)
isBackupCode ($code, ?User $user=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$cache = []
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for managing backup codes

Depuis
4.2.0

Documentation des fonctions membres

◆ isBackupCode()

isBackupCode | ( |  | $code,
 |  | ?User | $user = null
 | ) |  |

Check if the provided string is a backup code. If it is, it will be removed from the list (replaced with an empty string) and the codes will be saved to the database. All comparisons are performed in a timing safe manner.

Paramètres
string | $code | The code to check
User | null | $user | The user to check against
Renvoie
boolean
Exceptions

This is an intentional waste of time, symmetrical to the code above, making sure evaluating each of the total of ten elements takes the same time. This code should never run UNLESS someone messed up with our backup codes array and it no longer contains 10 elements.

Références $i, $result, $user, et Crypt\timingSafeCompare().

◆ regenerateBackupCodes()

regenerateBackupCodes ( User $user = null )

Generate a new set of backup codes for the specified user. The generated codes are immediately saved to the database and the internal cache is updated.

Paramètres
User | null $user Which user to generate codes for?
Renvoie
void
Exceptions

Références $i, $user, class, Factory\getApplication(), et Factory\getContainer().

Documentation des champs

◆ $cache

$cache = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Model/BackupcodesModel.php


Joomla CMS: Référence de la classe CaptiveModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • CaptiveModel
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe CaptiveModel
+ Graphe d'héritage de CaptiveModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface CaptiveModel

Fonctions membres publiques

suppressAllModules (CMSApplication $app=null)
getRecords (User $user=null, bool $includeBackupCodes=false)
loadCaptiveRenderOptions (?MfaTable $record)
getPageTitle ()
translateMethodName (string $name)
getMethodImage (string $name)
onAfterModuleList (Event $event)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$activeMFAMethodNames = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

getActiveMethodNames ()
filterModules (array &$modules)
getAllowedModulePositions ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Captive Multi-factor Authentication page's model

Depuis
4.2.0

Documentation des fonctions membres

◆ filterModules()

filterModules ( array & $modules )
private

This is the Method which actually filters the sites modules based on the allowed module positions specified by the user.

Paramètres
array $modules The list of the site's modules. Passed by reference.
Renvoie
void The by-reference value is modified instead.
Depuis
4.2.0
Exceptions
Exception

Références $module, et $modules.

◆ getActiveMethodNames()

getActiveMethodNames ( )
private

Return all the active MFA Methods' names

Renvoie
array
Depuis
4.2.0

◆ getAllowedModulePositions()

getAllowedModulePositions ( )
private

Get a list of module positions we are allowed to display

Renvoie
array
Exceptions
Exception
Depuis
4.2.0

Références Factory\getApplication(), et ComponentHelper\getParams().

◆ getMethodImage()

getMethodImage ( string $name )

Translate a MFA Method's name into the relative URL if its logo image

Paramètres
string $name The internal MFA Method name
Renvoie
string
Depuis
4.2.0

Références $name, et null.

◆ getPageTitle()

getPageTitle ( )

Returns the title to display in the Captive login page, or an empty string if no title is to be displayed.

Renvoie
string
Depuis
4.2.0

Références Text\_(), et ComponentHelper\getParams().

◆ getRecords()

getRecords | ( | User | $user = null,
 |  | bool | $includeBackupCodes = false
 | ) |  |

Get the MFA records for the user which correspond to active plugins

Paramètres
User | null | $user | The user for which to fetch records. Skip to use the current user.
bool | $includeBackupCodes | Should I include the backup codes record?
Renvoie
array
Exceptions
Exception
Depuis
4.2.0

Références $method, $user, class, Factory\getApplication(), et Factory\getContainer().

◆ loadCaptiveRenderOptions()

loadCaptiveRenderOptions ( ?MfaTable $record )

Load the Captive login page render options for a specific MFA record

Paramètres
MfaTable $record The MFA record to process
Renvoie
CaptiveRenderOptions The rendering options
Depuis
4.2.0

Références $result, $results, Text\_(), et Factory\getApplication().

◆ onAfterModuleList()

onAfterModuleList ( Event $event )

Process the modules list on Joomla! 4.

Joomla! 4.x is passing an Event object. The first argument of the event object is the array of modules. After filtering it we have to overwrite the event argument (NOT just return the new list of modules). If a future version of Joomla! uses immutable events we'll have to use Reflection to do that or Joomla! would have to fix the way this event is handled, taking its return into account. For now, we just abuse the mutable event properties - a feature of the event objects we discussed in the Joomla! 4 Working Group back in August 2015.

Paramètres
Event $event The Joomla! event object
Renvoie
void
Exceptions
Exception
Depuis
4.2.0

Références $modules, AbstractEvent\getArgument(), et Event\setArgument().

◆ suppressAllModules()

suppressAllModules ( CMSApplication $app = null )

Prevents Joomla from displaying any modules.

This is implemented with a trick. If you use jdoc tags to load modules the JDocumentRendererHtmlModules uses JModuleHelper::getModules() to load the list of modules to render. This goes through JModuleHelper::load() which triggers the onAfterModuleList event after cleaning up the module list from duplicates. By resetting the list to an empty array we force Joomla to not display any modules.

Similar code paths are followed by any canonical code which tries to load modules. So even if your template does not use jdoc tags this code will still work as expected.

Paramètres
CMSApplication | null $app The CMS application to manipulate
Renvoie
void
Exceptions
Exception
Depuis
4.2.0

Références $app, $this, et Factory\getApplication().

◆ translateMethodName()

translateMethodName ( string $name )

Translate a MFA Method's name into its human-readable, display name

Paramètres
string $name The internal MFA Method name
Renvoie
string
Depuis
4.2.0

Références $name, Text\_(), et null.

Documentation des champs

◆ $activeMFAMethodNames

$activeMFAMethodNames = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Model/CaptiveModel.php


Joomla CMS: Référence de la classe DebuggroupModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • DebuggroupModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe DebuggroupModel
+ Graphe d'héritage de DebuggroupModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getDebugActions ()
getItems ()
getGroup ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of User ACL permissions

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getDebugActions()

getDebugActions ( )

Get a list of the actions.

Renvoie
array
Depuis
1.6

Références $component, DebugHelper\getDebugActions(), et Joomla\CMS\MVC\Model\getState().

◆ getGroup()

getGroup ( )

Get the group being debugged.

Renvoie
CMSObject
Depuis
1.6

Références $db, $query, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getItems()

getItems ( )

Override getItems method.

Renvoie
array
Depuis
1.6

Implémente ListModelInterface.

Références $actions, $name, Access\checkGroup(), et Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery
Depuis
1.6

Références $component, $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $app, $direction, $layout, $ordering, $params, $value, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebuggroupModel.php


Joomla CMS: Référence de la classe DebuguserModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • DebuguserModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe DebuguserModel
+ Graphe d'héritage de DebuguserModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getDebugActions ()
getItems ()
getUser ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of User ACL permissions

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getDebugActions()

getDebugActions ( )

Get a list of the actions.

Renvoie
array
Depuis
1.6

Références $component, DebugHelper\getDebugActions(), et Joomla\CMS\MVC\Model\getState().

◆ getItems()

getItems ( )

Override getItems method.

Renvoie
array
Depuis
1.6

Implémente ListModelInterface.

Références $actions, $name, $user, $userId, Joomla\CMS\MVC\Model\getState(), et Factory\getUser().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery
Depuis
1.6

Références $component, $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getUser()

getUser ( )

Get the user being debugged.

Renvoie
User
Depuis
1.6

Références $userId, Joomla\CMS\MVC\Model\getState(), et Factory\getUser().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6
Exceptions

Références $app, $direction, $layout, $ordering, $params, $value, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebuguserModel.php


Joomla CMS: Référence de la classe GroupModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • GroupModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe GroupModel
+ Graphe d'héritage de GroupModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($type='Usergroup', $prefix='Joomla\\CMS\\Table\\', $config=array())
getForm ($data=array(), $loadData=true)
save ($data)
delete (&$pks)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
preprocessForm (Form $form, $data, $group='')
generateGroupTitle ($parentId, $title)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

User group model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ delete()

delete ( & $pks )

Method to delete rows.

Paramètres
array &$pks An array of item ids.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6
Exceptions

Références $groups, $i, $user, Text\_(), Access\checkGroup(), elseif, Factory\getApplication(), Access\getGroupsByUser(), Factory\getUser(), et PluginHelper\importPlugin().

◆ generateGroupTitle()

generateGroupTitle | ( | $parentId,
 |  | $title
 | ) |
protected

Method to generate the title of group on Save as Copy action

Paramètres
integer | $parentId | The id of the parent.
string | $title | The title of group
Renvoie
string Contains the modified title.
Depuis
3.3.7

Références $title, et StringHelper\increment().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getTable()

getTable | ( | $type = 'Usergroup',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Returns a reference to the a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object
Depuis
1.6

Références $config, $prefix, $return, $type, et Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6
Exceptions

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = ''
 | ) |  |
protected

Override preprocessForm to load the user plugin group instead of content.

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, class, Joomla\CMS\MVC\Model\preprocessForm(), et ArrayHelper\toObject().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Check the super admin permissions for group We get the parent group permissions and then check the group permissions manually We have to calculate the group permissions manually because we haven't saved the group yet

Check for super-admin changing self to be non-super-admin First, are we a super admin

If we would not otherwise have super admin permissions and the current group does not have super admin permissions, throw an exception

Références $data, Text\_(), Access\checkGroup(), elseif, Factory\getApplication(), Access\getAssetRules(), Access\getGroupsByUser(), Factory\getUser(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/Model/GroupModel.php


Joomla CMS: Référence de la classe GroupsModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • GroupsModel
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe GroupsModel
+ Graphe d'héritage de GroupsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.lft', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Fonctions membres privées

populateExtraData (array $items)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of user group records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getItems()

getItems ( )

Gets the list of groups and adds expensive joins to the result set.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6

Implémente ListModelInterface.

Références $items.

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery

Références $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateExtraData()

populateExtraData ( array $items )
private

Populate level & path for items.

Paramètres
array $items Array of objects
Renvoie
array
Depuis
3.6.3

Références $db, $groups, $item, $items, $query, et Joomla\Database\getDatabase().

◆ populateState()

populateState | ( | $ordering = 'a.lft',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/Model/GroupsModel.php


Joomla CMS: Référence de la classe LevelModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • LevelModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe LevelModel
+ Graphe d'héritage de LevelModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getTable ($type='ViewLevel', $prefix='Joomla\\CMS\\Table\\', $config=array())
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
save ($data)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
loadFormData ()
preprocessForm (Form $form, $data, $group='')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$levelsInUse = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

User view level model.

Depuis
1.6

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission set in the component.
Depuis
1.6

We are looking for the access field. If custom tables are using something other than the 'access' field they are on their own unfortunately. Also make sure the table prefix matches the live db prefix (eg, it is not a "bak_" table)

Références $db, $fields, $groups, $prefix, $query, $this, Text\_(), Access\checkGroup(), Joomla\Database\getDatabase(), Factory\getUser(), null, et Text\sprintf().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références $result.

◆ getTable()

getTable | ( | $type = 'ViewLevel',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Returns a reference to the a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object
Depuis
1.6

Références $config, $prefix, $return, $type, et Table\getInstance().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6
Exceptions

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = ''
 | ) |  |
protected

Method to preprocess the form

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6

Références $data, et InputFilter\getInstance().

◆ validate()

validate | ( | $form,
 |  | $data,
 |  | $group = null
 | ) |

Method to validate the form data.

Paramètres
Form | $form | The form to validate against.
array | $data | The data to validate.
string | $group | The name of the field group to validate.
Renvoie
array|boolean Array of filtered data if valid, false otherwise.
Voir également
Depuis
3.8.8

Références $data, $form, $groups, $i, $n, Text\_(), Access\checkGroup(), elseif, UserGroupsHelper\getInstance(), Factory\getUser(), et ArrayHelper\toInteger().

Documentation des champs

◆ $levelsInUse

$levelsInUse = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • LevelModel.php


Joomla CMS: Référence de la classe LevelsModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • LevelsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LevelsModel
+ Graphe d'héritage de LevelsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
reorder ($pk, $direction=0)
saveorder ($pks, $order)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.ordering', $direction='asc')
getStoreId ($id='')
getListQuery ()
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of user access level records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery

Références $db, $query, $this, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.ordering',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6

Références $direction, $ordering, $params, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ reorder()

reorder | ( | $pk,
 |  | $direction = 0
 | ) |

Method to adjust the ordering of a row.

Paramètres
integer | $pk | The ID of the primary key to move.
integer | $direction | Increment, usually +1 or -1
Renvoie
boolean False on failure or error, true otherwise.

Références $user, Text\_(), Table\getInstance(), Joomla\CMS\MVC\Model\getState(), et Factory\getUser().

◆ saveorder()

saveorder | ( | $pks,
 |  | $order
 | ) |

Saves the manually set order of records.

Paramètres
array | $pks | An array of primary key ids.
integer | $order | Order position
Renvoie
boolean Boolean true on success, boolean false
Exceptions

Références $i, $user, Text\_(), elseif, Factory\getApplication(), Table\getInstance(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LevelsModel.php


Joomla CMS: Référence de la classe MailModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • MailModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MailModel
+ Graphe d'héritage de MailModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
send ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
preprocessForm (Form $form, $data, $group='user')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Users mail model.

Depuis
1.6

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the row form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6
Exceptions

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Method to preprocess the form

Paramètres
Form | $form | A form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

◆ send()

send ( )

Send the email

Renvoie
boolean
Exceptions

Fill the data (specially for the 'mode', 'group' and 'bcc': they could not exist in the array when the box is not checked and in this case, the default value would be used instead of the '0' one)

Références $app, $data, $db, $disabled, $language, $mode, $params, $query, $rows, $subject, $user, Text\_(), Log\add(), elseif, Factory\getApplication(), Joomla\Database\getDatabase(), InputFilter\getInstance(), Factory\getLanguage(), ComponentHelper\getParams(), Factory\getUser(), ParameterType\INTEGER, Text\plural(), et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MailModel.php


Joomla CMS: Référence de la classe MethodModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • MethodModel
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe MethodModel
+ Graphe d'héritage de MethodModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface MethodModel

Fonctions membres publiques

getMethod (string $method)
methodExists (string $method)
getRenderOptions (?User $user=null)
getPageTitle ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Attributs protégés

$mfaMethods = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

populateMfaMethods ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Multi-factor Authentication management model

Depuis
4.2.0

Documentation des fonctions membres

◆ getMethod()

getMethod ( string $method )

Get the specified MFA Method's record

Paramètres
string $method The Method to retrieve.
Renvoie
array
Depuis
4.2.0

Références $method.

◆ getPageTitle()

getPageTitle ( )

Return the title to use for the page

Renvoie
string
Depuis
4.2.0

Références $key, $task, Text\_(), et Joomla\CMS\MVC\Model\getState().

◆ getRenderOptions()

getRenderOptions ( ?User $user = null )
Paramètres
User | null $user The user record. Null to use the currently logged in user.
Renvoie
array
Exceptions
Exception
Depuis
4.2.0

Références $result, $results, $user, Factory\getApplication(), et Factory\getUser().

◆ methodExists()

methodExists ( string $method )

Is the specified MFA Method available?

Paramètres
string $method The Method to check.
Renvoie
boolean
Depuis
4.2.0

Références $method.

◆ populateMfaMethods()

populateMfaMethods ( )
private

Populate the list of MFA Methods

Renvoie
void
Depuis
4.2.0

Références $method, et Text\_().

Documentation des champs

◆ $mfaMethods

$mfaMethods = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Model/MethodModel.php


Joomla CMS: Référence de la classe MethodsModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • MethodsModel
Fonctions membres publiques
Référence de la classe MethodsModel
+ Graphe d'héritage de MethodsModel:
BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface MethodsModel

Fonctions membres publiques

getMethods (?User $user=null)
deleteAll (?User $user=null)
formatRelative (?string $dateTimeText)
setFlag (User $user, bool $flag=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Multi-factor Authentication Methods list page's model

Depuis
4.2.0

Documentation des fonctions membres

◆ deleteAll()

deleteAll ( ?User $user = null )

Delete all Multi-factor Authentication Methods for the given user.

Paramètres
User | null $user The user object to reset MFA for. Null to use the current user.
Renvoie
void
Exceptions
Exception
Depuis
4.2.0

Références $db, $query, $user, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getUser(), et ParameterType\INTEGER.

◆ formatRelative()

formatRelative ( ?string $dateTimeText )

Format a relative timestamp. It deals with timestamps today and yesterday in a special manner. Example returns: Yesterday, 13:12 Today, 08:33 January 1, 2015

Paramètres
string $dateTimeText The database time string to use, e.g. "2017-01-13 13:25:36"
Renvoie
string The formatted, human-readable date
Exceptions
Exception
Depuis
4.2.0

Références $formatString, $user, Text\_(), class, Factory\getApplication(), et Factory\getContainer().

◆ getMethods()

getMethods ( ?User $user = null )

Returns a list of all available MFA methods and their currently active records for a given user.

Paramètres
User | null $user The user object. Skip to use the current user.
Renvoie
array
Exceptions
Exception
Depuis
4.2.0

Références $method, $user, class, Factory\getApplication(), et Factory\getContainer().

◆ setFlag()

setFlag | ( | User | $user,
 |  | bool | $flag = true
 | ) |  |

Set the user's "don't show this again" flag.

Paramètres
User | $user | The user to check
bool | $flag | True to set the flag, false to unset it (it will be set to 0, actually)
Renvoie
void
Depuis
4.2.0

Références $db, $query, $result, $user, Joomla\Database\getDatabase(), ParameterType\INTEGER, et ParameterType\STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/Model/MethodsModel.php


Joomla CMS: Référence de la classe NoteModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • NoteModel
Fonctions membres publiques | Champs de données | Fonctions membres protégées
Référence de la classe NoteModel
+ Graphe d'héritage de NoteModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getItem ($pk=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Champs de données

$typeAlias = 'com_users.note'
- Champs de données hérités de AdminModel
$typeAlias

Fonctions membres protégées

loadFormData ()
populateState ()
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

User note model.

Depuis
2.5

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|bool A Form object on success, false on failure
Depuis
2.5

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
2.5
Exceptions

Références $result, Factory\getApplication(), et PluginHelper\importPlugin().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6
Exceptions

Références $app, $data, $userId, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
2.5
Exceptions

Références $userId, Factory\getApplication(), Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

Documentation des champs

◆ $typeAlias

$typeAlias = 'com_users.note'
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoteModel.php


Joomla CMS: Référence de la classe NotesModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • NotesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe NotesModel
+ Graphe d'héritage de NotesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getUser ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

getListQuery ()
getStoreId ($id='')
populateState ($ordering='a.review_time', $direction='desc')
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

User notes model class.

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery A DatabaseQuery object to retrieve the data set.
Depuis
2.5

Références $db, $published, $query, $this, $userId, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
2.5

Références $id, et Joomla\CMS\MVC\Model\getState().

◆ getUser()

getUser ( )

Gets a user object if the user filter is set.

Renvoie
User The User object
Depuis
2.5

Références $user, et Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 'a.review_time',
 |  | $direction = 'desc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6
Exceptions

Références $direction, $layout, $ordering, Factory\getApplication(), et Joomla\CMS\MVC\Model\populateState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NotesModel.php


Joomla CMS: Référence de la classe UserModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • UserModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UserModel
+ Graphe d'héritage de UserModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($type='User', $prefix='Joomla\\CMS\\Table\\', $config=array())
getItem ($pk=null)
getForm ($data=array(), $loadData=true)
save ($data)
delete (&$pks)
block (&$pks, $value=1)
activate (&$pks)
batch ($commands, $pks, $contexts)
batchReset ($userIds, $action)
batchUser ($groupId, $userIds, $action)
getGroups ()
getAssignedGroups ($userId=null)
getOtpConfig ($userId=null)
setOtpConfig ($userId, $otpConfig)
getOtpConfigEncryptionKey ()
getTwofactorform ($userId=null)
generateOteps ($userId, $count=10)
isValidSecretKey ($userId, $secretKey, $options=array())
isValidOtep ($userId, $otep, $otpConfig=null)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
preprocessForm (Form $form, $data, $group='user')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$_item = null
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

User model.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ activate()

activate ( & $pks )

Method to activate user records.

Paramètres
array &$pks The ids of the items to activate.
Renvoie
boolean True on success.
Depuis
1.6
Exceptions

Références $i, $result, $user, Text\_(), Access\check(), elseif, Factory\getApplication(), Factory\getUser(), PluginHelper\importPlugin(), et null.

◆ batch()

batch | ( | $commands,
 |  | $pks,
 |  | $contexts
 | ) |

Method to perform batch operations on an item or a set of items.

Paramètres
array | $commands | An array of commands to perform.
array | $pks | An array of item ids.
array | $contexts | An array of item contexts.
Renvoie
boolean Returns true on success, false on failure.
Depuis
2.5

Références Text\_(), ArrayHelper\getValue(), et ArrayHelper\toInteger().

◆ batchReset()

batchReset | ( | $userIds,
 |  | $action
 | ) |

Batch flag users as being required to reset their passwords

Paramètres
array | $userIds | An array of user IDs on which to operate
string | $action | The action to perform
Renvoie
boolean True on success, false on failure
Depuis
3.2

Références $db, $query, $value, Text\_(), UserHelper\checkSuperUserInUsers(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ batchUser()

batchUser | ( | $groupId,
 |  | $userIds,
 |  | $action
 | ) |

Perform batch operations

Paramètres
integer | $groupId | The group ID which assignments are being edited
array | $userIds | An array of user IDs on which to operate
string | $action | The action to perform
Renvoie
boolean True on success, false on failure
Depuis
1.6

Références $db, $groups, $id, $query, Text\_(), Access\checkGroup(), UserHelper\checkSuperUserInUsers(), Joomla\Database\getDatabase(), Factory\getUser(), ParameterType\INTEGER, et ArrayHelper\toInteger().

◆ block()

block | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to block user records.

Paramètres
array | &$pks | The ids of the items to publish.
integer | $value | The value of the published state
Renvoie
boolean True on success.
Depuis
1.6
Exceptions

Références $app, $i, $options, $result, $user, $value, Text\_(), Access\check(), elseif, Factory\getApplication(), Factory\getUser(), PluginHelper\importPlugin(), et null.

◆ delete()

delete ( & $pks )

Method to delete rows.

Paramètres
array &$pks An array of item ids.
Renvoie
boolean Returns true on success, false on failure.
Depuis
1.6
Exceptions

Références $i, $user, Text\_(), Access\check(), Factory\getApplication(), Factory\getUser(), et PluginHelper\importPlugin().

◆ generateOteps()

generateOteps | ( | $userId,
 |  | $count = 10
 | ) |

No longer used

Paramètres
integer | $userId | Ignored
integer | $count | Ignored
Renvoie
array Empty array
Depuis
3.2
Obsolète:
4.2.0 Wil be removed in 5.0.

◆ getAssignedGroups()

getAssignedGroups ( $userId = null )

Gets the groups this object is assigned to

Paramètres
integer $userId The user ID to retrieve the groups for
Renvoie
array An array of assigned groups
Depuis
1.6

Références $form, $params, $result, $userId, ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), et UserHelper\getUserGroups().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the record form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

If users without core.manage permission editing their own account, remove some fields which they should not be allowed to change and prevent them to change user name if configured

Implémente FormModelInterface.

Références $form, $user, $userId, ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\loadForm().

◆ getGroups()

getGroups ( )

Gets the available groups.

Renvoie
array An array of groups
Depuis
1.6

Références $model, $user, Factory\getUser(), et null.

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
mixed Object on success, false on failure.
Depuis
1.6

Références Joomla\CMS\MVC\Model\getState(), et null.

◆ getOtpConfig()

getOtpConfig ( $userId = null )

No longer used

Paramètres
integer $userId Ignored
Renvoie
Depuis
3.2
Obsolète:
4.2.0 Will be removed in 5.0

◆ getOtpConfigEncryptionKey()

getOtpConfigEncryptionKey ( )

No longer used

Renvoie
string
Depuis
3.2
Obsolète:
4.2.0 Will be removed in 5.0

Références Factory\getApplication().

◆ getTable()

getTable | ( | $type = 'User',
 |  | $prefix = 'Joomla\\CMS\\Table\\',
 |  | $config = array()
 | ) |

Returns a reference to the a Table object, always creating it.

Paramètres
string | $type | The table type to instantiate
string | $prefix | A prefix for the table class name. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
Table A database object
Depuis
1.6

Références $config, $prefix, $type, et Table\getInstance().

◆ getTwofactorform()

getTwofactorform ( $userId = null )

No longer used

Paramètres
integer $userId Ignored
Renvoie
array Empty array
Depuis
3.2
Exceptions

◆ isValidOtep()

isValidOtep | ( | $userId,
 |  | $otep,
 |  | $otpConfig = null
 | ) |

No longer used

Paramètres
integer | $userId | Ignored
string | $otep | Ignored
object | $otpConfig | Ignored
Renvoie
boolean Always true
Depuis
3.2
Obsolète:
4.2.0 Will be removed in 5.0

◆ isValidSecretKey()

isValidSecretKey | ( | $userId,
 |  | $secretKey,
 |  | $options = array()
 | ) |

No longer used. Always returns true.

Paramètres
integer | $userId | Ignored
string | $secretKey | Ignored
array | $options | Ignored
Renvoie
boolean Always true
Depuis
3.2
Exceptions

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6
Exceptions

Références $data, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessData().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override Joomla::preprocessForm to ensure the correct plugin group is loaded.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
1.6
Exceptions

Références $data, $user, Text\_(), Access\checkGroup(), Factory\getApplication(), User\getInstance(), Joomla\CMS\MVC\Model\getState(), Factory\getUser(), null, et Joomla\CMS\MVC\Model\setState().

◆ setOtpConfig()

setOtpConfig | ( | $userId,
 |  | $otpConfig
 | ) |

No longer used

Paramètres
integer | $userId | Ignored
\stdClass | $otpConfig | Ignored
Renvoie
boolean True on success
Depuis
3.2
Obsolète:
4.2.0 Will be removed in 5.0

Documentation des champs

◆ $_item

$_item = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserModel.php


Joomla CMS: Référence de la classe UsersModel

  • Joomla
  • Component
  • Users
  • Administrator
  • Model
  • UsersModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe UsersModel
+ Graphe d'héritage de UsersModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null)
getItems ()
getFilterForm ($data=[], $loadData=true)
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='a.name', $direction='asc')
getStoreId ($id='')
getListQuery ()
getUserDisplayedGroups ($userId)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$filterForbiddenList = array('groups', 'excluded')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

buildDateRange ($range)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Methods supporting a list of user records.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null
 | ) |  |

Override parent constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ buildDateRange()

buildDateRange ( $range )
private

Construct the date range to filter on.

Paramètres
string $range The textual range to construct the filter for.
Renvoie
array The date range to filter on.
Depuis
3.6.0
Exceptions

Références $app, Joomla\Database\Query\$offset, $range, et Factory\getApplication().

◆ getFilterForm()

getFilterForm | ( | $data = [],
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
Form|null The object or null if the form can't be found
Depuis
4.2.0

Références $data, $form, et PluginHelper\isEnabled().

◆ getItems()

getItems ( )

Gets the list of users and adds expensive joins to the result set.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
1.6

Implémente ListModelInterface.

Références $db, $groups, $item, $items, $query, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )
protected

Build an SQL query to load the list data.

Renvoie
DatabaseQuery
Depuis
1.6

Références $active, $db, $groups, $query, $range, $state, $this, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), ParameterType\INTEGER, et PluginHelper\isEnabled().

◆ getStoreId()

getStoreId ( $id = '' )
protected

Method to get a store id based on model configuration state.

This is necessary because the model is used by the component and different modules that might need different sets of data or different ordering requirements.

Paramètres
string $id A prefix for the store id.
Renvoie
string A store id.
Depuis
1.6

Références $id, Joomla\CMS\MVC\Model\getState(), et PluginHelper\isEnabled().

◆ getUserDisplayedGroups()

getUserDisplayedGroups ( $userId )
protected

SQL server change

Paramètres
integer $userId User identifier
Renvoie
string Groups titles imploded :$

Références $db, $query, $result, $userId, Joomla\Database\getDatabase(), et ParameterType\INTEGER.

◆ populateState()

populateState | ( | $ordering = 'a.name',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
1.6
Exceptions

Références $app, $direction, $groups, $layout, $ordering, $params, Factory\getApplication(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\populateState(), Joomla\CMS\MVC\Model\setState(), et ArrayHelper\toInteger().

Documentation des champs

◆ $filterForbiddenList

$filterForbiddenList = array('groups', 'excluded')
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UsersModel.php


Joomla CMS: Référence de la classe Users

  • Joomla
  • Component
  • Users
  • Administrator
  • Service
  • HTML
  • Users
Fonctions membres publiques
Référence de la classe Users

Fonctions membres publiques

image ($src)
addNote ($userId)
filterNotes ($count, $userId)
notes ($count, $userId)
notesModal ($count, $userId)
blockStates ($self=false)
activateStates ()
value ($value)
spacer ($value)
templatestyle ($value)
admin_language ($value)
language ($value)
editor ($value)

Description détaillée

Extended Utility class for the Users component.

Depuis
2.5

Documentation des fonctions membres

◆ activateStates()

activateStates ( )

Build an array of activate states to be used by jgrid.state,

Renvoie
array a list of possible states to display
Depuis
3.0

◆ addNote()

addNote ( $userId )

Displays an icon to add a note for this user.

Paramètres
integer $userId The user ID
Renvoie
string A link to add a note
Depuis
2.5

Références $title, $userId, Text\_(), et Route\_().

◆ admin_language()

admin_language ( $value )

Get the sanitized language

Paramètres
mixed $value Value of the field
Renvoie
mixed String/void
Depuis
1.6

Références $path, $result, $value, ENT_COMPAT, LanguageHelper\getLanguagePath(), JPATH_ADMINISTRATOR, LanguageHelper\parseXMLLanguageFile(), et value.

◆ blockStates()

blockStates ( $self = false )

Build an array of block/unblock user states to be used by jgrid.state, State options will be different for any user and for currently logged in user

Paramètres
boolean $self True if state array is for currently logged in user
Renvoie
array a list of possible states to display
Depuis
3.0

Références $self.

◆ editor()

editor ( $value )

Get the sanitized editor name

Paramètres
mixed $value Value of the field
Renvoie
mixed String/void
Depuis
1.6

Références $db, $lang, $query, $title, $value, Text\_(), Factory\getDbo(), Factory\getLanguage(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, et value.

◆ filterNotes()

filterNotes | ( | $count,
 |  | $userId
 | ) |

Displays an icon to filter the notes list on this user.

Paramètres
integer | $count | The number of notes for the user
integer | $userId | The user ID
Renvoie
string A link to apply a filter
Depuis
2.5

Références $count, $title, $userId, Text\_(), et Route\_().

◆ image()

image ( $src )

Display an image.

Paramètres
string $src The source of the image
Renvoie
string A element if the specified file exists, otherwise, a null string
Depuis
2.5
Exceptions

Références Path\check(), JPATH_SITE, et Uri\root().

◆ language()

language ( $value )

Get the sanitized language

Paramètres
mixed $value Value of the field
Renvoie
mixed String/void
Depuis
1.6

Références $path, $result, $value, ENT_COMPAT, LanguageHelper\getLanguagePath(), JPATH_SITE, LanguageHelper\parseXMLLanguageFile(), et value.

◆ notes()

notes | ( | $count,
 |  | $userId
 | ) |

Displays a note icon.

Paramètres
integer | $count | The number of notes for the user
integer | $userId | The user ID
Renvoie
string A link to a modal window with the user notes
Depuis
2.5

Références $count, $title, $userId, et Text\plural().

◆ notesModal()

notesModal | ( | $count,
 |  | $userId
 | ) |

Renders the modal html.

Paramètres
integer | $count | The number of notes for the user
integer | $userId | The user ID
Renvoie
string The html for the rendered modal
Depuis
3.4.1

Références $count, $title, $userId, Text\_(), Route\_(), HTMLHelper\_(), et Text\plural().

◆ spacer()

spacer ( $value )

Get the space symbol

Paramètres
mixed $value Value of the field
Renvoie
string
Depuis
1.6

◆ templatestyle()

templatestyle ( $value )

Get the sanitized template style

Paramètres
mixed $value Value of the field
Renvoie
mixed String/void
Depuis
1.6

Références $db, $query, $title, $value, ENT_COMPAT, Factory\getDbo(), ParameterType\INTEGER, et value.

◆ value()

value ( $value )

Get the sanitized value

Paramètres
mixed $value Value of the field
Renvoie
mixed String/void
Depuis
1.6

Références $value, Text\_(), elseif, et ENT_COMPAT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Users.php


Joomla CMS: Référence de la classe Encrypt

  • Joomla
  • Component
  • Users
  • Administrator
  • Service
  • Encrypt
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Encrypt

Fonctions membres publiques

__construct ()
encrypt (string $data)
decrypt (string $data, bool $legacy=false)

Fonctions membres privées

initialize ()
getPassword ()

Attributs privés

$aes

Description détaillée

Data encryption service.

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

EncryptService constructor.

Depuis
4.2.0

Références Laminas\Diactoros\initialize().

Documentation des fonctions membres

◆ decrypt()

decrypt | ( | string | $data,
 |  | bool | $legacy = false
 | ) |  |

Decrypt the ciphertext, prefixed by ###AES128###, and return the plaintext.

Paramètres
string | $data | The ciphertext, prefixed by ###AES128###
bool | $legacy | Use legacy key expansion? Use it to decrypt data encrypted with FOF 3.
Renvoie
string The plaintext data
Depuis
4.2.0

Références $data.

◆ encrypt()

encrypt ( string $data )

Encrypt the plaintext $data and return the ciphertext prefixed by ###AES128###

Paramètres
string $data The plaintext data
Renvoie
string The ciphertext, prefixed by ###AES128###
Depuis
4.2.0

Références $data.

◆ getPassword()

getPassword ( )
private

Returns the password used to encrypt information in the component

Renvoie
string
Depuis
4.2.0

Références Factory\getApplication().

◆ initialize()

initialize ( )
private

Initialize the AES cryptography object

Renvoie
void
Depuis
4.2.0

Références $password.

Documentation des champs

◆ $aes

$aes
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Encrypt.php


Joomla CMS: Référence de la classe MfaTable

  • Joomla
  • Component
  • Users
  • Administrator
  • Table
  • MfaTable
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe MfaTable
+ Graphe d'héritage de MfaTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db, DispatcherInterface $dispatcher=null)
store ($updateNulls=true)
load ($keys=null, $reset=true)
delete ($pk=null)
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Fonctions membres privées

decryptOptions ()
switchDefaultRecord ()
afterDelete ($pk)
getNumRecords (int $userId)

Attributs privés

$deleteFlags = []
$encryptService

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DatabaseDriver | $db,
 |  | DispatcherInterface | $dispatcher = null
 | ) |  |

Table constructor

Paramètres
DatabaseDriver | $db | Database driver object
DispatcherInterface | null | $dispatcher | Events dispatcher object
Depuis
4.2.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ afterDelete()

afterDelete ( $pk )
private

Runs after successfully deleting a record

Paramètres
int | array $pk The promary key of the deleted record
Renvoie
void
Depuis
4.2.0

This was the second to last MFA record in the database (the last one is the backupcodes). Therefore, we need to delete the remaining entry and go away. We don't trigger this if the Method we are deleting was the backupcodes because we might just be regenerating the backup codes.

Références $db, $id, $query, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ decryptOptions()

decryptOptions ( )
private

Decrypt the possibly encrypted options

Renvoie
void
Depuis
4.2.0

Références $this.

◆ delete()

delete ( $pk = null )

Method to delete a row from the database table by primary key value.

Paramètres
mixed $pk An optional primary key value to delete. If not set the instance property value is used.
Renvoie
boolean True on success.
Depuis
4.2.0
Exceptions

Implémente TableInterface.

Références $id, $result, $this, $user, Text\_(), class, elseif, Factory\getApplication(), et Factory\getContainer().

◆ getNumRecords()

getNumRecords ( int $userId )
private

Get the number of MFA records for a give user ID

Paramètres
int $userId The user ID to check
Renvoie
integer
Depuis
4.2.0

Références $db, $query, $userId, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ load()

load | ( | $keys = null,
 |  | $reset = true
 | ) |

Method to load a row from the database by primary key and bind the fields to the Table instance properties.

Paramètres
mixed | $keys | An optional primary key value to load the row by, or an array of fields to match. If not set the instance property value is used.
boolean | $reset | True to reset the default values before loading the new row.
Renvoie
boolean True if successful. False if row not found.
Depuis
4.2.0
Exceptions

Implémente TableInterface.

Références $result.

◆ store()

store ( $updateNulls = true )

Method to store a row in the database from the Table instance properties.

If a primary key value is set the row with that primary key value will be updated with the instance property values. If no primary key value is set a new row will be inserted into the database with the properties from the Table instance.

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
boolean True on success.
Depuis
4.2.0

Implémente TableInterface.

Références $id, $result, false, Date\getInstance(), method, et null.

◆ switchDefaultRecord()

switchDefaultRecord ( )
private

If this record is set to be the default, unset the default flag from the other records for the same user.

Renvoie
void
Depuis
4.2.0

This record is marked as default, therefore we need to unset the default flag from all other records for this user.

Références $db, $query, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected

◆ $deleteFlags

$deleteFlags = []
private

◆ $encryptService

$encryptService
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MfaTable.php


Joomla CMS: Référence de la classe NoteTable

  • Joomla
  • Component
  • Users
  • Administrator
  • Table
  • NoteTable
Fonctions membres publiques | Attributs protégés
Référence de la classe NoteTable
+ Graphe d'héritage de NoteTable:
Table VersionableTableInterface CMSObject TableInterface DispatcherAwareInterface TableInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
store ($updateNulls=true)
check ()
getTypeAlias ()
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Description détaillée

User notes table class

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Constructor

Paramètres
DatabaseDriver $db Database object
Depuis
2.5

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ check()

check ( )

Method to perform sanity checks on the Table instance properties to ensure they are safe to store in the database.

Renvoie
boolean True if the instance is sane and able to be stored in the database.
Depuis
4.0.0

Implémente TableInterface.

◆ getTypeAlias()

getTypeAlias ( )

Get the type alias for the history table

Renvoie
string The alias as described above
Depuis
4.0.0

Implémente VersionableTableInterface.

◆ store()

store ( $updateNulls = true )

Overloaded store method for the notes table.

Paramètres
boolean $updateNulls Toggle whether null values should be updated.
Renvoie
boolean True on success, false on failure.
Depuis
2.5

Implémente TableInterface.

Références $date, $userId, Factory\getDate(), Factory\getUser(), et null.

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoteTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Captive
  • HtmlView
Champs de données
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView

Champs de données

$records = []
$record = null
$renderOptions = null
$title = ''
$isAdmin = false
$allowEntryBatching = false
$mfaMethods
- Champs de données hérités de AbstractView
$document

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication captive page

Depuis
4.2.0

Documentation des champs

◆ $allowEntryBatching

$allowEntryBatching = false

◆ $isAdmin

$isAdmin = false

◆ $mfaMethods

$mfaMethods

◆ $record

$record = null

◆ $records

$records = []

◆ $renderOptions

$renderOptions = null

◆ $title

$title = ''
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Captive/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Debuggroup
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$actions
$items
$pagination
$state
$group
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of User Group ACL permissions.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $this, ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\preferences(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références Text\_(), Joomla\CMS\User\getCurrentUser(), et items.

Documentation des champs

◆ $actions

$actions
protected

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $group

$group
protected

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Debuggroup/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Debuguser
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$actions
$items
$pagination
$state
$user
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of User ACL permissions.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $this, ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\preferences(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références Text\_(), Joomla\CMS\User\getCurrentUser(), et items.

Documentation des champs

◆ $actions

$actions
protected

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $user

$user
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Debuguser/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Group
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a user group.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Group/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Groups
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of user groups.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Groups/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Level
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View to edit a user view level.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions

Références $canDo, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Level/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Levels
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of view levels.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, Text\_(), ToolbarHelper\addNew(), ToolbarHelper\deleteList(), ToolbarHelper\divider(), ContentHelper\getActions(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Levels/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Mail
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Users mail view.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions

Références Text\_(), ToolbarHelper\cancel(), ToolbarHelper\custom(), ToolbarHelper\divider(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\preferences(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Exceptions

Implémente ViewInterface.

Références Route\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Mail/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Method
  • HtmlView
Champs de données
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView

Champs de données

$isAdmin = false
$renderOptions = []
$record = null
$title = ''
$returnURL = null
$user = null
$backupCodes = []
$isEditExisting = false
- Champs de données hérités de AbstractView
$document

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication method add/edit page

Depuis
4.2.0

Documentation des champs

◆ $backupCodes

$backupCodes = []

◆ $isAdmin

$isAdmin = false

◆ $isEditExisting

$isEditExisting = false

◆ $record

$record = null

◆ $renderOptions

$renderOptions = []

◆ $returnURL

$returnURL = null

◆ $title

$title = ''

◆ $user

$user = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Method/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Methods
  • HtmlView
Champs de données
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface HtmlView

Champs de données

$isAdmin = false
$methods = []
$returnURL = null
$mfaActive = false
$defaultMethod = ''
$user = null
$isMandatoryMFASetup = false
- Champs de données hérités de AbstractView
$document

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication methods list page

Depuis
4.2.0

Documentation des champs

◆ $defaultMethod

$defaultMethod = ''

◆ $isAdmin

$isAdmin = false

◆ $isMandatoryMFASetup

$isMandatoryMFASetup = false

◆ $methods

$methods = []

◆ $mfaActive

$mfaActive = false

◆ $returnURL

$returnURL = null

◆ $user

$user = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Methods/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Note
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$state
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

User note edit view

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Display the toolbar.

Renvoie
void
Depuis
2.5
Exceptions

Références $canDo, $input, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\help(), ComponentHelper\isEnabled(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Override the display method for the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
2.5
Exceptions

Implémente ViewInterface.

Documentation des champs

◆ $form

$form
protected

◆ $item

$item
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Note/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Notes
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$user
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Attributs privés

$isEmptyState = false

Description détaillée

User notes list view

Depuis
2.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Display the toolbar.

Renvoie
void
Depuis
2.5

Références $canDo, $toolbar, Text\_(), ContentHelper\getActions(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Override the display method for the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
2.5

Implémente ViewInterface.

Références $item, et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $filterForm

$filterForm

◆ $isEmptyState

$isEmptyState = false
private

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected

◆ $user

$user
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Notes/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • User
  • HtmlView
Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$item
$grouplist
$groups
$state
$mfaConfigurationUI
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de AbstractView
$document

Description détaillée

User view class.

Depuis
1.5

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6
Exceptions

Références $canDo, $user, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), ContentHelper\getActions(), Factory\getApplication(), ToolbarHelper\help(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

Documentation des champs

◆ $form

$form
protected

◆ $grouplist

$grouplist
protected

◆ $groups

$groups
protected

◆ $item

$item
protected

◆ $mfaConfigurationUI

$mfaConfigurationUI
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/User/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Administrator
  • View
  • Users
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$items
$pagination
$state
$canDo
$db
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View class for a list of users.

Depuis
1.6

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
1.6

Références $canDo, $toolbar, $user, Text\_(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void

Implémente ViewInterface.

Références ContentHelper\getActions(), Factory\getDbo(), et items.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $canDo

$canDo
protected

◆ $db

$db
protected

◆ $filterForm

$filterForm

◆ $items

$items
protected

◆ $pagination

$pagination
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/src/View/Users/HtmlView.php


Joomla CMS: Référence de la classe GroupsController

  • Joomla
  • Component
  • Users
  • Api
  • Controller
  • GroupsController
Attributs protégés
Référence de la classe GroupsController
+ Graphe d'héritage de GroupsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'groups'
$default_view = 'groups'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The groups controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'groups'
protected

◆ $default_view

$default_view = 'groups'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_users/src/Controller/GroupsController.php


Joomla CMS: Référence de la classe LevelsController

  • Joomla
  • Component
  • Users
  • Api
  • Controller
  • LevelsController
Attributs protégés
Référence de la classe LevelsController
+ Graphe d'héritage de LevelsController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Attributs protégés

$contentType = 'levels'
$default_view = 'levels'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The levels controller

Depuis
4.0.0

Documentation des champs

◆ $contentType

$contentType = 'levels'
protected

◆ $default_view

$default_view = 'levels'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_users/src/Controller/LevelsController.php


Joomla CMS: Référence de la classe UsersController

  • Joomla
  • Component
  • Users
  • Api
  • Controller
  • UsersController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UsersController
+ Graphe d'héritage de UsersController:
ApiController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

displayList ()
- Fonctions membres publiques hérités de ApiController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
add ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

preprocessSaveData (array $data)
- Fonctions membres protégées hérités de ApiController
allowEdit ($data=array(), $key='id')
allowAdd ($data=array())
preprocessSaveData (array $data)
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$contentType = 'users'
$default_view = 'users'
- Attributs protégés hérités de ApiController
$contentType
$option
$text_prefix
$context
$itemsPerPage = 20
$modelState
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The users controller

Depuis
4.0.0

Documentation des fonctions membres

◆ displayList()

displayList ( )

User list view with filtering of data

Renvoie
static A BaseController object to support chaining.
Depuis
4.0.0
Exceptions
InvalidParameterException

Références elseif, InputFilter\getInstance(), null, et Text\sprintf().

◆ preprocessSaveData()

preprocessSaveData ( array $data )
protected

Method to allow extended classes to manipulate the data to be saved for an extension.

Paramètres
array $data An array of input data.
Renvoie
array
Depuis
4.0.0

Références $data, $field, et FieldsHelper\getFields().

Documentation des champs

◆ $contentType

$contentType = 'users'
protected

◆ $default_view

$default_view = 'users'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • api/components/com_users/src/Controller/UsersController.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Groups
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The groups view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'parent_id',
'lft',
'rgt',
'title',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'parent_id',
'lft',
'rgt',
'title',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/View/Groups/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Levels
  • JsonapiView
Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

The levels view

Depuis
4.0.0

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'title',
'rules'
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'title',
'rules',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/View/Levels/JsonapiView.php


Joomla CMS: Référence de la classe JsonapiView

  • Joomla
  • Component
  • Users
  • Api
  • View
  • Users
  • JsonapiView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe JsonapiView
+ Graphe d'héritage de JsonapiView:
JsonApiView JsonView AbstractView CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

displayList (array $items=null)
displayItem ($item=null)
- Fonctions membres publiques hérités de JsonApiView
__construct ($config=[])
- Fonctions membres publiques hérités de JsonView
__construct ($config=array())
display ($tpl=null)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

prepareItem ($item)
- Fonctions membres protégées hérités de JsonApiView
prepareItem ($item)
queryEncode ($query)
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$fieldsToRenderItem
$fieldsToRenderList
- Attributs protégés hérités de JsonApiView
$type
$relationship = []
$serializer
$fieldsToRenderItem = []
$fieldsToRenderList = []
- Attributs protégés hérités de JsonView
$_basePath = null
$_charset = 'UTF-8'
$_output = array()
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de JsonApiView
$document
- Champs de données hérités de AbstractView
$document

Description détaillée

The users view

Depuis
4.0.0

Documentation des fonctions membres

◆ displayItem()

displayItem ( $item = null )

Execute and display a template script.

Paramètres
object $item Item
Renvoie
string
Depuis
4.0.0

Références $field, et FieldsHelper\getFields().

◆ displayList()

displayList ( array $items = null )

Execute and display a template script.

Paramètres
array | null $items Array of items
Renvoie
string
Depuis
4.0.0

Références $field, et FieldsHelper\getFields().

◆ prepareItem()

prepareItem ( $item )
protected

Prepare item before render.

Paramètres
object $item The model item
Renvoie
object
Depuis
4.0.0

Références $field, $item, et FieldsHelper\getFields().

Documentation des champs

◆ $fieldsToRenderItem

$fieldsToRenderItem
protected
Valeur initiale :
= [
'id',
'groups',
'name',
'username',
'email',
'registerDate',
'lastvisitDate',
'lastResetTime',
'resetCount',
'sendEmail',
'block',
]

◆ $fieldsToRenderList

$fieldsToRenderList
protected
Valeur initiale :
= [
'id',
'name',
'username',
'email',
'group_count',
'group_names',
'registerDate',
'lastvisitDate',
'lastResetTime',
'resetCount',
'sendEmail',
'block',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/View/Users/JsonapiView.php


Joomla CMS: Référence de la classe CallbackController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • CallbackController
Référence de la classe CallbackController
+ Graphe d'héritage de CallbackController:
CallbackController BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de CallbackController
__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
callback ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication plugins' AJAX callback controller

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/CallbackController.php


Joomla CMS: Référence de la classe CaptiveController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • CaptiveController
Fonctions membres publiques
Référence de la classe CaptiveController
+ Graphe d'héritage de CaptiveController:
CaptiveController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

execute ($task)
- Fonctions membres publiques hérités de CaptiveController
__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Captive Multi-factor Authentication page controller

Depuis
4.2.0

Documentation des fonctions membres

◆ execute()

execute ( $task )

Execute a task by triggering a Method in the derived class.

Paramètres
string $task The task to perform.
Renvoie
mixed The value returned by the called Method.
Exceptions

Implémente ControllerInterface.

Références $task, Route\_(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/CaptiveController.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=false)
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Base controller class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = false
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | boolean | $urlparams | An array of safe URL parameters and their variable types, for valid values see Joomla\CMS\Filter\InputFilter::clean().@returnvoid@since1.5@throws\Exception

Références $document, $model, $task, $user, $view, Route\_(), et ComponentHelper\getParams().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe MethodController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • MethodController
Fonctions membres publiques
Référence de la classe MethodController
+ Graphe d'héritage de MethodController:
MethodController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

execute ($task)
- Fonctions membres publiques hérités de MethodController
__construct (array $config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
execute ($task)
delete ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication method controller

Depuis
4.2.0

Documentation des fonctions membres

◆ execute()

execute ( $task )

Execute a task by triggering a Method in the derived class.

Paramètres
string $task The task to perform.
Renvoie
mixed The value returned by the called Method.
Exceptions

Implémente ControllerInterface.

Références $task, Route\_(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/MethodController.php


Joomla CMS: Référence de la classe MethodsController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • MethodsController
Fonctions membres publiques
Référence de la classe MethodsController
+ Graphe d'héritage de MethodsController:
MethodsController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

execute ($task)
- Fonctions membres publiques hérités de MethodsController
__construct ($config=[], MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
display ($cachable=false, $urlparams=[])
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Multi-factor Authentication methods selection and management controller

Depuis
4.2.0

Documentation des fonctions membres

◆ execute()

execute ( $task )

Execute a task by triggering a Method in the derived class.

Paramètres
string $task The task to perform.
Renvoie
mixed The value returned by the called Method.
Exceptions

Implémente ControllerInterface.

Références $task, Route\_(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/MethodsController.php


Joomla CMS: Référence de la classe ProfileController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • ProfileController
Fonctions membres publiques
Référence de la classe ProfileController
+ Graphe d'héritage de ProfileController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

edit ()
cancel ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Profile controller class for Users.

Depuis
1.6

Documentation des fonctions membres

◆ cancel()

cancel ( )

Method to cancel an edit.

Renvoie
void
Depuis
4.0.0

Références Route\_(), Joomla\Application\checkToken(), et null.

◆ edit()

edit ( )

Method to check out a user for editing and redirect to the edit form.

Renvoie
boolean
Depuis
1.6

Références $app, $cookieLogin, $user, $userId, Text\_(), et Route\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ProfileController.php


Joomla CMS: Référence de la classe RegistrationController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • RegistrationController
Référence de la classe RegistrationController
+ Graphe d'héritage de RegistrationController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Registration controller class for Users.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • RegistrationController.php


Joomla CMS: Référence de la classe RemindController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • RemindController
Référence de la classe RemindController
+ Graphe d'héritage de RemindController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Reset controller class for Users.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • RemindController.php


Joomla CMS: Référence de la classe ResetController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • ResetController
Référence de la classe ResetController
+ Graphe d'héritage de ResetController:
BaseController ControllerInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Reset controller class for Users.

Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • ResetController.php


Joomla CMS: Référence de la classe UserController

  • Joomla
  • Component
  • Users
  • Site
  • Controller
  • UserController
Fonctions membres publiques
Référence de la classe UserController
+ Graphe d'héritage de UserController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

login ()
logout ()
menulogout ()
resend ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Registration controller class for Users.

Depuis
1.6

Documentation des fonctions membres

◆ login()

login ( )

Method to log in a user.

Renvoie
void
Depuis
1.6

Références $data, $input, $itemId, $language, $options, Route\_(), Joomla\Application\checkToken(), elseif, Multilanguage\isEnabled(), et Uri\isInternal().

◆ logout()

logout ( )

Method to log out a user.

Renvoie
void
Depuis
1.6

Références $app, $input, $language, $options, $return, Route\_(), Joomla\Application\checkToken(), elseif, Multilanguage\isEnabled(), Uri\isInternal(), null, et Uri\root().

◆ menulogout()

menulogout ( )

Method to logout directly and redirect to page.

Renvoie
void
Depuis
3.5

Références $active, $app, $item, $itemid, $language, $url, Session\getFormToken(), ApplicationHelper\getHash(), Multilanguage\isEnabled(), et Uri\root().

◆ resend()

resend ( )

Method to resend a user.

Renvoie
void
Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Controller/UserController.php


Joomla CMS: Référence de la classe BackupcodesModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • BackupcodesModel
Référence de la classe BackupcodesModel
+ Graphe d'héritage de BackupcodesModel:
BackupcodesModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de BackupcodesModel
regenerateBackupCodes (User $user=null)
isBackupCode ($code, ?User $user=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BackupcodesModel
$cache = []
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model for managing backup codes

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Model/BackupcodesModel.php


Joomla CMS: Référence de la classe CaptiveModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • CaptiveModel
Référence de la classe CaptiveModel
+ Graphe d'héritage de CaptiveModel:
CaptiveModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de CaptiveModel
suppressAllModules (CMSApplication $app=null)
getRecords (User $user=null, bool $includeBackupCodes=false)
loadCaptiveRenderOptions (?MfaTable $record)
getPageTitle ()
translateMethodName (string $name)
getMethodImage (string $name)
onAfterModuleList (Event $event)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de CaptiveModel
$activeMFAMethodNames = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Captive Multi-factor Authentication page's model

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Model/CaptiveModel.php


Joomla CMS: Référence de la classe LoginModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • LoginModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe LoginModel
+ Graphe d'héritage de LoginModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getMenuLanguage (int $id)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
populateState ()
preprocessForm (Form $form, $data, $group='user')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Login model class for Users.

Depuis
1.6

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the login form.

The base form is loaded from XML and then an event is fired for users plugins to extend the form with extra fields.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getMenuLanguage()

getMenuLanguage ( int $id )

Returns the language for the given menu id.

Paramètres
int $id The menu id
Renvoie
string
Depuis
4.2.0

Références $db, $id, $query, Joomla\Database\getDatabase(), ParameterType\INTEGER, et Multilanguage\isEnabled().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
array The default data is an empty array.
Depuis
1.6
Exceptions

Références $app, $data, $input, $return, Factory\getApplication(), Uri\isInternal(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6
Exceptions

Références $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override Joomla::preprocessForm to ensure the correct plugin group is loaded.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Model/LoginModel.php


Joomla CMS: Référence de la classe MethodModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • MethodModel
Référence de la classe MethodModel
+ Graphe d'héritage de MethodModel:
MethodModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de MethodModel
getMethod (string $method)
methodExists (string $method)
getRenderOptions (?User $user=null)
getPageTitle ()
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de MethodModel
$mfaMethods = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Multi-factor Authentication Method management model

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Model/MethodModel.php


Joomla CMS: Référence de la classe MethodsModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • MethodsModel
Référence de la classe MethodsModel
+ Graphe d'héritage de MethodsModel:
MethodsModel BaseDatabaseModel BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de MethodsModel
getMethods (?User $user=null)
deleteAll (?User $user=null)
formatRelative (?string $dateTimeText)
setFlag (User $user, bool $flag=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Multi-factor Authentication Methods list page's model

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Model/MethodsModel.php


Joomla CMS: Référence de la classe ProfileModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • ProfileModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe ProfileModel
+ Graphe d'héritage de ProfileModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
getData ()
getForm ($data=array(), $loadData=true)
save ($data)
getTwofactorform ($userId=null)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
preprocessForm (Form $form, $data, $group='user')
populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$data
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Profile model class for Users.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
FormFactoryInterface | $formFactory | The form factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getData()

getData ( )

Method to get the profile form data.

The base form data is loaded and then an event is fired for users plugins to extend the data.

Renvoie
User
Depuis
1.6
Exceptions

Références $data, $temp, $this, $userId, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et null.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the profile form.

The base form is loaded from XML and then an event is fired for users plugins to extend the form with extra fields.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, ComponentHelper\getParams(), Factory\getUser(), Multilanguage\isEnabled(), Joomla\CMS\MVC\Model\loadForm(), Joomla\CMS\MVC\Model\loadFormData(), et Joomla\CMS\MVC\Model\setState().

◆ getTwofactorform()

getTwofactorform ( $userId = null )

Gets the configuration forms for all two-factor authentication methods in an array.

Paramètres
integer $userId The user ID to load the forms for (optional)
Renvoie
array
Depuis
3.2
Obsolète:
4.2.0 Will be removed in 5.0.

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6
Exceptions

Références $params, $userId, Factory\getApplication(), Factory\getUser(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override preprocessForm to load the user plugin group instead of content.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Exceptions

Références $data, $form, ComponentHelper\getParams(), Factory\getUser(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
mixed The user id on success, false on failure.
Depuis
1.6
Exceptions

Références $data, $user, $userId, PunycodeHelper\emailToPunycode(), Access\getGroupsByUser(), ComponentHelper\getParams(), Joomla\CMS\MVC\Model\getState(), et PluginHelper\importPlugin().

Documentation des champs

◆ $data

$data
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProfileModel.php


Joomla CMS: Référence de la classe RegistrationModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • RegistrationModel
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe RegistrationModel
+ Graphe d'héritage de RegistrationModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
getUserIdFromToken ($token)
activate ($token)
getData ()
getForm ($data=array(), $loadData=true)
register ($temp)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

loadFormData ()
preprocessForm (Form $form, $data, $group='user')
populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Attributs protégés

$data
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Registration model class for Users.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  | FormFactoryInterface | $formFactory = null
 | ) |  |

Constructor.

Paramètres
array | $config | An array of configuration options (name, state, dbo, table_path, ignore_request).
MVCFactoryInterface | $factory | The factory.
FormFactoryInterface | $formFactory | The form factory.
Voir également
Depuis
3.2

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ activate()

activate ( $token )

Method to activate a user account.

Paramètres
string $token The activation token.
Renvoie
mixed False on failure, user object on success.
Depuis
1.6

Références $app, $data, $db, $query, $return, $rows, $user, $userId, Text\_(), Log\add(), MailTemplate\addTemplateData(), Uri\base(), elseif, UserHelper\genRandomPassword(), Factory\getApplication(), Joomla\Database\getDatabase(), ApplicationHelper\getHash(), ComponentHelper\getParams(), Factory\getUser(), PluginHelper\importPlugin(), Route\link(), Text\sprintf(), Route\TLS_FORCE, Route\TLS_IGNORE, et Log\WARNING.

◆ getData()

getData ( )

Method to get the registration form data.

The base form data is loaded and then an event is fired for users plugins to extend the data.

Renvoie
mixed Data object on success, false on failure.
Depuis
1.6
Exceptions

Références $app, $data, $form, $key, $params, $temp, $this, $val, elseif, Factory\getApplication(), ComponentHelper\getParams(), PluginHelper\importPlugin(), et null.

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the registration form.

The base form is loaded from XML and then an event is fired for users plugins to extend the form with extra fields.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\loadForm().

◆ getUserIdFromToken()

getUserIdFromToken ( $token )

Method to get the user ID from the given token

Paramètres
string $token The activation token.
Renvoie
mixed False on failure, id of the user on success
Depuis
3.8.13

Références $db, $query, Joomla\Database\getDatabase(), et Text\sprintf().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
1.6

Références $data, Factory\getLanguage(), Multilanguage\isEnabled(), et Joomla\CMS\MVC\Model\preprocessData().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6
Exceptions

Références $app, $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override preprocessForm to load the user plugin group instead of content.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
1.6
Exceptions

Références $data, $form, ComponentHelper\getParams(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ register()

register ( $temp )

Method to save the form data.

Paramètres
array $temp The form data.
Renvoie
mixed The user id on success, false on failure.
Depuis
1.6
Exceptions

Références $app, $data, $db, $message, $params, $query, $return, $rows, $subject, $temp, $user, Text\_(), Log\add(), MailTemplate\addTemplateData(), elseif, PunycodeHelper\emailToPunycode(), UserHelper\genRandomPassword(), Factory\getApplication(), Joomla\Database\getDatabase(), ApplicationHelper\getHash(), ComponentHelper\getParams(), Factory\getUser(), PluginHelper\importPlugin(), ParameterType\INTEGER, Route\link(), Uri\root(), Text\sprintf(), Route\TLS_FORCE, Route\TLS_IGNORE, et Log\WARNING.

Documentation des champs

◆ $data

$data
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RegistrationModel.php


Joomla CMS: Référence de la classe RemindModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • RemindModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RemindModel
+ Graphe d'héritage de RemindModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
processRemindRequest ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

preprocessForm (Form $form, $data, $group='user')
populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Remind model class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the username remind request form.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|bool A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6
Exceptions

Références $app, $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override preprocessForm to load the user plugin group instead of content.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

◆ processRemindRequest()

processRemindRequest ( $data )

Send the remind username email

Paramètres
array $data Array with the data received from the form
Renvoie
boolean
Depuis
1.6

Références $app, $data, $db, $form, $link, $mode, $query, $return, $user, Text\_(), Route\_(), Log\add(), MailTemplate\addTemplateData(), PunycodeHelper\emailToPunycode(), ArrayHelper\fromObject(), Factory\getApplication(), Joomla\Database\getDatabase(), Text\sprintf(), et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • com_users/src/Model/RemindModel.php


Joomla CMS: Référence de la classe ResetModel

  • Joomla
  • Component
  • Users
  • Site
  • Model
  • ResetModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ResetModel
+ Graphe d'héritage de ResetModel:
FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

getForm ($data=array(), $loadData=true)
getResetCompleteForm ($data=array(), $loadData=true)
getResetConfirmForm ($data=array(), $loadData=true)
processResetComplete ($data)
processResetConfirm ($data)
processResetRequest ($data)
checkResetLimit ($user)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

preprocessForm (Form $form, $data, $group='user')
populateState ()
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Reset model class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ checkResetLimit()

checkResetLimit ( $user )

Method to check if user reset limit has been exceeded within the allowed time period.

Paramètres
User $user User doing the password reset
Renvoie
boolean true if user can do the reset, false if limit exceeded
Depuis
2.5
Exceptions

Références $params, $result, $user, elseif, Factory\getApplication(), et Factory\getDate().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the password reset request form.

The base form is loaded from XML and then an event is fired for users plugins to extend the form with extra fields.

Paramètres
array | $data | An optional array of data for the form to interrogate.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Implémente FormModelInterface.

Références $form, et Joomla\CMS\MVC\Model\loadForm().

◆ getResetCompleteForm()

getResetCompleteForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the password reset complete form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6

Références $form, $options, et Joomla\CMS\MVC\Model\loadForm().

◆ getResetConfirmForm()

getResetConfirmForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Method to get the password reset confirm form.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form A Form object on success, false on failure
Depuis
1.6
Exceptions

Références $form, $options, Factory\getApplication(), et Joomla\CMS\MVC\Model\loadForm().

◆ populateState()

populateState ( )
protected

Method to auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
1.6
Exceptions

Références $params, Factory\getApplication(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'user'
 | ) |  |
protected

Override preprocessForm to load the user plugin group instead of content.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Exceptions

Références $data, $form, et Joomla\CMS\MVC\Model\preprocessForm().

◆ processResetComplete()

processResetComplete ( $data )

Save the new password after reset is done

Paramètres
array $data The data expected for the form.
Renvoie
mixed | boolean
Depuis
1.6
Exceptions

Références $app, $data, $form, $return, $user, $userId, Text\_(), Factory\getApplication(), User\getInstance(), null, et Text\sprintf().

◆ processResetConfirm()

processResetConfirm ( $data )

Receive the reset password request

Paramètres
array $data The data expected for the form.
Renvoie
mixed | boolean
Depuis
1.6
Exceptions

Références $app, $data, $db, $form, $query, $return, $user, Text\_(), Factory\getApplication(), Joomla\Database\getDatabase(), et Text\sprintf().

◆ processResetRequest()

processResetRequest ( $data )

Method to start the password reset process.

Paramètres
array $data The data expected for the form.
Renvoie
mixed | boolean
Depuis
1.6
Exceptions

Références $app, $data, $db, $form, $link, $mode, $query, $return, $user, $userId, Text\_(), Route\_(), Log\add(), MailTemplate\addTemplateData(), PunycodeHelper\emailToPunycode(), UserHelper\genRandomPassword(), Factory\getApplication(), Joomla\Database\getDatabase(), ApplicationHelper\getHash(), User\getInstance(), UserHelper\hashPassword(), Text\plural(), Text\sprintf(), et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ResetModel.php


Joomla CMS: Référence de la classe LoginUniqueFieldRule

  • Joomla
  • Component
  • Users
  • Site
  • Rule
  • LoginUniqueFieldRule
Fonctions membres publiques
Référence de la classe LoginUniqueFieldRule
+ Graphe d'héritage de LoginUniqueFieldRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

FormRule for com_users to be sure only one redirect login field has a value

Depuis
3.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if two fields have a value in order to use only one field. To use this rule, the form XML needs a validate attribute of loginuniquefield and a field attribute that is equal to the field to test against.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.6

Références $form, $input, $this, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LoginUniqueFieldRule.php


Joomla CMS: Référence de la classe LogoutUniqueFieldRule

  • Joomla
  • Component
  • Users
  • Site
  • Rule
  • LogoutUniqueFieldRule
Fonctions membres publiques
Référence de la classe LogoutUniqueFieldRule
+ Graphe d'héritage de LogoutUniqueFieldRule:
FormRule

Fonctions membres publiques

test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)
- Fonctions membres publiques hérités de FormRule
test (\SimpleXMLElement $element, $value, $group=null, Registry $input=null, Form $form=null)

Membres hérités additionnels

- Attributs protégés hérités de FormRule
$regex
$modifiers = ''

Description détaillée

FormRule for com_users to be sure only one redirect logout field has a value

Depuis
3.6

Documentation des fonctions membres

◆ test()

test | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null,
 |  | Registry | $input = null,
 |  | Form | $form = null
 | ) |  |

Method to test if two fields have a value in order to use only one field. To use this rule, the form XML needs a validate attribute of logoutuniquefield and a field attribute that is equal to the field to test against.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Registry | $input | An optional Registry object with the entire data set to validate against the entire form.
Form | $form | The form object for which the field is being tested.
Renvoie
boolean True if the value is valid, false otherwise.
Depuis
3.6

Références $form, $input, $this, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LogoutUniqueFieldRule.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Users
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterView RouterBase RouterInterface

Fonctions membres publiques

__construct (SiteApplication $app, AbstractMenu $menu)
getMethodId ($segment, $query)
getMethodSegment ($id, $query)
- Fonctions membres publiques hérités de RouterView
registerView (RouterViewConfiguration $view)
getViews ()
getPath ($query)
getRules ()
attachRules ($rules)
attachRule (RulesInterface $rule)
detachRule (RulesInterface $rule)
preprocess ($query)
build (&$query)
parse (&$segments)
getName ()
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu
- Attributs protégés hérités de RouterView
$name
$rules = array()
$views = array()

Description détaillée

Routing class from com_users

Depuis
3.2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SiteApplication | $app,
 |  | AbstractMenu | $menu
 | ) |  |

Users Component router constructor

Paramètres
SiteApplication | $app | The application object
AbstractMenu | $menu | The menu object to work with

Références $app, $menu, $method, $this, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getMethodId()

getMethodId | ( | $segment,
 |  | $query
 | ) |

Get the method ID from a URL segment

Paramètres
string | $segment | The URL segment
array | $query | The URL query parameters
Renvoie
integer
Depuis
4.2.0

◆ getMethodSegment()

getMethodSegment | ( | $id,
 |  | $query
 | ) |

Get a segment from a method ID

Paramètres
integer | $id | The method ID
array | $query | The URL query parameters
Renvoie
int[]
Depuis
4.2.0

Références $id.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Captive
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de HtmlView
$records = []
$record = null
$renderOptions = null
$title = ''
$isAdmin = false
$allowEntryBatching = false
$mfaMethods
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication captive page

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Captive/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Login
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$params
$state
$user
$pageclass_sfx = ''
$tfa = false
$extraButtons = []
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Login view class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.5
Exceptions

Implémente ViewInterface.

Références $active, ENT_COMPAT, Factory\getApplication(), et Joomla\CMS\User\getCurrentUser().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
1.6
Exceptions

Références $menu, Text\_(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), et true.

Documentation des champs

◆ $extraButtons

$extraButtons = []
protected

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $state

$state
protected

◆ $tfa

$tfa = false
protected

◆ $user

$user
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Login/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Method
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de HtmlView
$isAdmin = false
$renderOptions = []
$record = null
$title = ''
$returnURL = null
$user = null
$backupCodes = []
$isEditExisting = false
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication method add/edit page

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Method/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Methods
  • HtmlView
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Champs de données hérités de HtmlView
$isAdmin = false
$methods = []
$returnURL = null
$mfaActive = false
$defaultMethod = ''
$user = null
$isMandatoryMFASetup = false
- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

View for Multi-factor Authentication methods list page

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Methods/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Profile
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$data
$form
$params
$state
$db
$pageclass_sfx = ''
$mfaConfigurationUI
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Profile view class for Users.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void|boolean
Depuis
1.6
Exceptions

Implémente ViewInterface.

Références $app, $cookieLogin, $query, $user, Text\_(), Route\_(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), Factory\getDbo(), et PluginHelper\importPlugin().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document

Renvoie
void
Depuis
1.6
Exceptions

Références $menu, $this, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $data

$data
protected

◆ $db

$db
protected

◆ $form

$form
protected

◆ $mfaConfigurationUI

$mfaConfigurationUI
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Profile/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Registration
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$document
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$data
$form
$params
$state
$pageclass_sfx = ''
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Registration view class for Users.

Depuis
1.6

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl The template file to include
Renvoie
void
Depuis
1.6
Exceptions

Implémente ViewInterface.

Références $active, ENT_COMPAT, et Factory\getApplication().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
1.6
Exceptions

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $data

$data
protected

◆ $document

$document

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Registration/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Remind
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$params
$state
$pageclass_sfx = ''
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Remind view class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl The template file to include
Renvoie
mixed
Depuis
1.5
Exceptions

Implémente ViewInterface.

Références $active, ENT_COMPAT, et Factory\getApplication().

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
1.6
Exceptions

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Remind/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Users
  • Site
  • View
  • Reset
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

prepareDocument ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$form
$params
$state
$pageclass_sfx = ''
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

Reset view class for Users.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Method to display the view.

Paramètres
string $tpl The template file to include
Renvoie
mixed
Depuis
1.5

Implémente ViewInterface.

Références $name, et ENT_COMPAT.

◆ prepareDocument()

prepareDocument ( )
protected

Prepares the document.

Renvoie
void
Depuis
1.6
Exceptions

Références $menu, Text\_(), et Factory\getApplication().

Documentation des champs

◆ $form

$form
protected

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_users/src/View/Reset/HtmlView.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • DisplayController
Fonctions membres publiques | Attributs protégés
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Attributs protégés

$default_view = 'workflows'
$extension
$section
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Workflow base controller package.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
BaseController|boolean This object to support chaining.
Depuis
1.5

Références $id, $layout, $url, $view, Route\_(), Inflector\pluralize(), et Text\sprintf().

Documentation des champs

◆ $default_view

$default_view = 'workflows'
protected

◆ $extension

$extension
protected

◆ $section

$section
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe StageController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • StageController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe StageController
+ Graphe d'héritage de StageController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$workflowId
$extension
$section
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The stage controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

Références extension.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
4.0.0

Références $data, $key, $recordId, $this, et $user.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, $recordId, et extension.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et extension.

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected

◆ $workflowId

$workflowId
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StageController.php


Joomla CMS: Référence de la classe StagesController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • StagesController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe StagesController
+ Graphe d'héritage de StagesController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (array $config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Stage', $prefix='Administrator', $config=array('ignore_request'=> true))
setDefault ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$workflowId
$extension
$section
$text_prefix = 'COM_WORKFLOW_STAGES'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

The workflow stages controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Stage',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
The model.
Depuis
4.0.0

Références $config, $name, et $prefix.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références extension.

◆ setDefault()

setDefault ( )

Method to set the home property for a list of items

Renvoie
void
Depuis
4.0.0

Références $data, $id, $model, $task, $value, Text\_(), Route\_(), Joomla\Application\checkToken(), elseif, extension, et ArrayHelper\getValue().

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected

◆ $text_prefix

$text_prefix = 'COM_WORKFLOW_STAGES'
protected

◆ $workflowId

$workflowId
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StagesController.php


Joomla CMS: Référence de la classe TransitionController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • TransitionController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TransitionController
+ Graphe d'héritage de TransitionController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$workflowId
$extension
$section
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Transition controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

Références extension.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
4.0.0

Références $data, $item, $key, $model, $recordId, $this, et $user.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, $extension, et $recordId.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et $extension.

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected

◆ $workflowId

$workflowId
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionController.php


Joomla CMS: Référence de la classe TransitionsController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • TransitionsController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TransitionsController
+ Graphe d'héritage de TransitionsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Transition', $prefix='Administrator', $config=array('ignore_request'=> true))
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$workflowId
$extension
$section
$text_prefix = 'COM_WORKFLOW_TRANSITIONS'
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Workflow Transitions controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Transition',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
The model.
Depuis
4.0.0

Références $config, $name, et $prefix.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et extension.

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected

◆ $text_prefix

$text_prefix = 'COM_WORKFLOW_TRANSITIONS'
protected

◆ $workflowId

$workflowId
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionsController.php


Joomla CMS: Référence de la classe WorkflowController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • WorkflowController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowController
+ Graphe d'héritage de WorkflowController:
FormController BaseController FormFactoryAwareInterface ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres publiques hérités de FormController
__construct ( $config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null, FormFactoryInterface $formFactory=null)
add ()
batch ($model)
cancel ($key=null)
edit ($key=null, $urlVar=null)
getModel ($name='', $prefix='', $config=array('ignore_request'=> true))
save ($key=null, $urlVar=null)
editAssociations ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

allowAdd ($data=array())
allowEdit ($data=array(), $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
- Fonctions membres protégées hérités de FormController
allowAdd ($data=[])
allowEdit ($data=[], $key='id')
allowSave ($data, $key='id')
getRedirectToItemAppend ($recordId=null, $urlVar='id')
getRedirectToListAppend ()
postSaveHook (BaseDatabaseModel $model, $validData=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$extension
$section
- Attributs protégés hérités de FormController
$context
$option
$view_item
$view_list
$text_prefix
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Workflow controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ allowAdd()

allowAdd ( $data = array() )
protected

Method to check if you can add a new record.

Paramètres
array $data An array of input data.
Renvoie
boolean
Depuis
4.0.0

Références extension.

◆ allowEdit()

allowEdit | ( | $data = array(),
 |  | $key = 'id'
 | ) |
protected

Method to check if you can edit a record.

Paramètres
array | $data | An array of input data.
string | $key | The name of the key for the primary key.
Renvoie
boolean
Depuis
4.0.0

Références $data, $key, $recordId, $this, et $user.

◆ getRedirectToItemAppend()

getRedirectToItemAppend | ( | $recordId = null,
 |  | $urlVar = 'id'
 | ) |
protected

Gets the URL arguments to append to an item redirect.

Paramètres
integer | $recordId | The primary key id for the item.
string | $urlVar | The name of the URL variable for the id.
Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, $recordId, et extension.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références $append, et extension.

◆ postSaveHook()

postSaveHook | ( | BaseDatabaseModel | $model,
 |  |  | $validData = array()
 | ) |  |

Function that allows child controller access to model data after the data has been saved.

Paramètres
BaseDatabaseModel | $model | The data model object.
array | $validData | The validated data.
Renvoie
void
Depuis
4.0.0

Références $db, $key, $model, $query, $recordId, $task, $transitions, et ParameterType\INTEGER.

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowController.php


Joomla CMS: Référence de la classe WorkflowsController

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Controller
  • WorkflowsController
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowsController
+ Graphe d'héritage de WorkflowsController:
AdminController BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($config=array(), MVCFactoryInterface $factory=null, $app=null, $input=null)
getModel ($name='Workflow', $prefix='Administrator', $config=array('ignore_request'=> true))
setDefault ()
- Fonctions membres publiques hérités de AdminController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
delete ()
publish ()
reorder ()
saveorder ()
checkin ()
saveOrderAjax ()
runTransition ()
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

getRedirectToListAppend ()
- Fonctions membres protégées hérités de AdminController
postDeleteHook (BaseDatabaseModel $model, $id=null)
getRedirectToListAppend ()
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)

Attributs protégés

$extension
$section
- Attributs protégés hérités de AdminController
$option
$text_prefix
$view_list
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Workflows controller

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $config = array(),
 |  | MVCFactoryInterface | $factory = null,
 |  |  | $app = null,
 |  |  | $input = null
 | ) |  |

Constructor.

Paramètres
array | $config | An optional associative array of configuration settings.
MVCFactoryInterface | $factory | The factory.
CMSApplication | $app | The Application for the dispatcher
Input | $input | Input
Depuis
4.0.0
Exceptions

Références $app, $config, $extension, $input, $parts, Text\_(), Symfony\Contracts\Service\__construct(), et extension.

Documentation des fonctions membres

◆ getModel()

getModel | ( | $name = 'Workflow',
 |  | $prefix = 'Administrator',
 |  | $config = array('ignore_request' => true)
 | ) |

Proxy for getModel

Paramètres
string | $name | The model name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | The array of possible config values. Optional.
Renvoie
The model.
Depuis
4.0.0

Références $config, $name, et $prefix.

◆ getRedirectToListAppend()

getRedirectToListAppend ( )
protected

Gets the URL arguments to append to a list redirect.

Renvoie
string The arguments to append to the redirect URL.
Depuis
4.0.0

Références extension.

◆ setDefault()

setDefault ( )

Method to set the home property for a list of items

Renvoie
void
Depuis
4.0.0

Références $data, $id, $model, $task, $value, Text\_(), Route\_(), Joomla\Application\checkToken(), elseif, extension, et ArrayHelper\getValue().

Documentation des champs

◆ $extension

$extension
protected

◆ $section

$section
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowsController.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
ComponentDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

checkAccess ()
- Fonctions membres protégées hérités de ComponentDispatcher
loadLanguage ()
checkAccess ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ComponentDispatcher
__construct (CMSApplicationInterface $app, Input $input, MVCFactoryInterface $mvcFactory)
dispatch ()
getController (string $name, string $client='', array $config=array())
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Attributs protégés hérités de ComponentDispatcher
$option
$mvcFactory
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

ComponentDispatcher class for com_workflow

Depuis
4.0.0

Documentation des fonctions membres

◆ checkAccess()

checkAccess ( )
protected

Workflows have to check for extension permission

Renvoie
void

Références $extension, et $parts.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ComponentsWorkflowField

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Field
  • ComponentsWorkflowField
Fonctions membres protégées | Attributs protégés
Référence de la classe ComponentsWorkflowField
+ Graphe d'héritage de ComponentsWorkflowField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ComponentsWorkflow'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Components Workflow field.

Depuis
1.6

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get a list of options for a list input.

Renvoie
array An array of JHtml options.
Depuis
3.7.0

Références $c, $component, $context, $db, $item, $items, $lang, $options, $query, Text\_(), Access\getActionsFromFile(), Factory\getApplication(), Joomla\Database\getDatabase(), Factory\getLanguage(), JPATH_ADMINISTRATOR, et ArrayHelper\sortObjects().

Documentation des champs

◆ $type

$type = 'ComponentsWorkflow'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ComponentsWorkflowField.php


Joomla CMS: Référence de la classe WorkflowcontextsField

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Field
  • WorkflowcontextsField
Champs de données | Fonctions membres protégées
Référence de la classe WorkflowcontextsField
+ Graphe d'héritage de WorkflowcontextsField:
ListField FormField DatabaseAwareInterface

Champs de données

$type = 'Workflowcontexts'
- Champs de données hérités de FormField
$repeat = false

Fonctions membres protégées

getInput ()
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Fields Contexts

Depuis
4.0.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for a generic list. Use the multiple attribute to enable multiselect.

Renvoie
string The field input markup.
Depuis
4.0.0

Références Joomla\Application\getInput().

◆ getOptions()

getOptions ( )
protected

Method to get the field options.

Renvoie
array The field option objects.
Depuis
4.0.0

Références $component, $parts, Factory\getApplication(), et value.

Documentation des champs

◆ $type

$type = 'Workflowcontexts'
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowcontextsField.php


Joomla CMS: Référence de la classe StageHelper

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Helper
  • StageHelper
Référence de la classe StageHelper
+ Graphe d'héritage de StageHelper:
ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

The first example class, this is in the same package as declared at the start of file but this example has a defined subpackage

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • StageHelper.php


Joomla CMS: Référence de la classe WorkflowHelper

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Helper
  • WorkflowHelper
Référence de la classe WorkflowHelper
+ Graphe d'héritage de WorkflowHelper:
ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Workflows component helper

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowHelper.php


Joomla CMS: Référence de la classe StageModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • StageModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe StageModel
+ Graphe d'héritage de StageModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

populateState ()
save ($data)
getForm ($data=array(), $loadData=true)
setDefault ($pk, $value=1)
publish (&$pks, $value=1)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

generateNewTitle ($categoryId, $alias, $title)
canDelete ($record)
canEditState ($record)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for stage

Depuis
4.0.0

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
4.0.0

Références $app, $component, $extension, $parts, Text\_(), Factory\getApplication(), Factory\getUser(), et null.

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
4.0.0

Références $app, $context, $extension, $name, $user, Factory\getApplication(), Factory\getUser(), et null.

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title

Paramètres
integer | $categoryId | The id of the category.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
4.0.0

Références $title, et StringHelper\increment().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Abstract method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
Form|boolean A Form object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $canEditState, $data, $form, $id, $item, et Joomla\CMS\MVC\Model\loadForm().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
4.0.0

Références $data, et Factory\getApplication().

◆ populateState()

populateState ( )

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
4.0.0

Références $app, $context, $extension, $name, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form.

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
4.0.0

Références $data, $extension, $form, $parts, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $app, $extension, $i, $value, Text\_(), Factory\getApplication(), et null.

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $app, $context, $data, $input, $key, $name, $parts, $title, $user, Joomla\CMS\MVC\Model\$workflow, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

◆ setDefault()

setDefault | ( | $pk,
 |  | $value = 1
 | ) |

Method to change the home state of one or more items.

Paramètres
array | $pk | A list of the primary keys to change.
integer | $value | The value of the home state.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $this, $value, Text\_(), Log\add(), et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • StageModel.php


Joomla CMS: Référence de la classe StagesModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • StagesModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe StagesModel
+ Graphe d'héritage de StagesModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getTable ($type='Stage', $prefix='Administrator', $config=array())
getListQuery ()
getWorkflow ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='s.ordering', $direction='ASC')
getReorderConditions ($table)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for stages

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
JController
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( )

Method to get the data that should be injected in the form.

Renvoie
string The query to database.
Depuis
4.0.0

Références $db, $query, $this, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
4.0.0

Références Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Stage',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
A Table object
Depuis
4.0.0

Références $config, $prefix, et $type.

◆ getWorkflow()

getWorkflow ( )

Returns a workflow object

Renvoie
object The workflow
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 's.ordering',
 |  | $direction = 'ASC'
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
4.0.0

Références $app, $direction, $extension, $ordering, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StagesModel.php


Joomla CMS: Référence de la classe TransitionModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • TransitionModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TransitionModel
+ Graphe d'héritage de TransitionModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

populateState ()
getItem ($pk=null)
save ($data)
getForm ($data=array(), $loadData=true)
getWorkflow ()
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for transition

Depuis
4.0.0

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
4.0.0

Références $app, $extension, Factory\getApplication(), Factory\getUser(), et null.

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
4.0.0

Références $app, $context, $extension, $name, $user, Factory\getApplication(), Factory\getUser(), et null.

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title

Paramètres
integer | $categoryId | The id of the category.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
4.0.0

Références $title, et StringHelper\increment().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Abstract method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $canEditState, $context, $data, $form, $id, $item, $name, Factory\getApplication(), Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\loadForm().

◆ getItem()

getItem ( $pk = null )

Method to get a single record.

Paramètres
integer $pk The id of the primary key.
Renvoie
|boolean Object on success, false on failure.
Depuis
4.0.0

Références $item.

◆ getWorkflow()

getWorkflow ( )

Références $app, $context, $name, Joomla\CMS\MVC\Model\$workflow, et Factory\getApplication().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
4.0.0

Références $data, et Factory\getApplication().

◆ populateState()

populateState ( )

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
4.0.0

Références $app, $context, $extension, $name, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Trigger the form preparation for the workflow group

Paramètres
Form | $form | A Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Voir également
FormField
Depuis
4.0.0
Exceptions

Références $data, $extension, $form, $parts, Factory\getApplication(), PluginHelper\importPlugin(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $app, $context, $data, $input, $key, $name, $parts, $title, $user, Joomla\CMS\MVC\Model\$workflow, Factory\getApplication(), et Joomla\CMS\MVC\Model\getState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionModel.php


Joomla CMS: Référence de la classe TransitionsModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • TransitionsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TransitionsModel
+ Graphe d'héritage de TransitionsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getTable ($type='Transition', $prefix='Administrator', $config=array())
getListQuery ()
getFilterForm ($data=array(), $loadData=true)
getWorkflow ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='t.ordering', $direction='ASC')
getReorderConditions ($table)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for transitions

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
JController
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
|boolean The Form object or false on error
Depuis
4.0.0

Références $data, $form, $id, Joomla\Database\getDatabase(), et Joomla\CMS\MVC\Model\getState().

◆ getListQuery()

getListQuery ( )

Method to get the data that should be injected in the form.

Renvoie
string The query to database.
Depuis
4.0.0

Références $db, $query, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
4.0.0

Références Joomla\Database\getDatabase().

◆ getTable()

getTable | ( | $type = 'Transition',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
A Table object
Depuis
4.0.0

Références $config, $prefix, et $type.

◆ getWorkflow()

getWorkflow ( )

Returns a workflow object

Renvoie
object The workflow
Depuis
4.0.0

Références Joomla\CMS\MVC\Model\getState().

◆ populateState()

populateState | ( | $ordering = 't.ordering',
 |  | $direction = 'ASC'
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
4.0.0

Références $app, $direction, $extension, $ordering, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionsModel.php


Joomla CMS: Référence de la classe WorkflowModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • WorkflowModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe WorkflowModel
+ Graphe d'héritage de WorkflowModel:
AdminModel FormModel BaseDatabaseModel FormFactoryAwareInterface FormModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

populateState ()
save ($data)
getForm ($data=array(), $loadData=true)
setDefault ($pk, $value=1)
publish (&$pks, $value=1)
- Fonctions membres publiques hérités de AdminModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
batch ($commands, $pks, $contexts)
checkin ($pks=array())
checkout ($pk=null)
delete (&$pks)
getItem ($pk=null)
publish (&$pks, $value=1)
reorder ($pks, $delta=0)
save ($data)
saveorder ($pks=array(), $order=null)
generateTitle ($categoryId, $table)
initBatch ()
editAssociations ($data)
- Fonctions membres publiques hérités de FormModel
__construct ($config=array(), MVCFactoryInterface $factory=null, FormFactoryInterface $formFactory=null)
checkin ($pk=null)
checkout ($pk=null)
validate ($form, $data, $group=null)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

generateNewTitle ($categoryId, $alias, $title)
loadFormData ()
preprocessForm (Form $form, $data, $group='content')
getReorderConditions ($table)
canDelete ($record)
canEditState ($record)
- Fonctions membres protégées hérités de AdminModel
batchAccess ($value, $pks, $contexts)
batchCopy ($value, $pks, $contexts)
cleanupPostBatchCopy (TableInterface $table, $newId, $oldId)
batchLanguage ($value, $pks, $contexts)
batchMove ($value, $pks, $contexts)
batchTag ($value, $pks, $contexts)
canDelete ($record)
canEditState ($record)
generateNewTitle ($categoryId, $alias, $title)
getReorderConditions ($table)
populateState ()
prepareTable ($table)
checkCategoryId ($categoryId)
redirectToAssociations ($data)
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Champs de données hérités de AdminModel
$typeAlias
- Attributs protégés hérités de AdminModel
$text_prefix = null
$event_after_delete = null
$event_after_save = null
$event_before_delete = null
$event_before_save = null
$event_before_change_state = null
$event_change_state = null
$event_before_batch = null
$batch_copymove = 'category_id'
$batch_commands
$associationsContext = null
$batchSet = null
$user = null
$table = null
$tableClassName = null
$contentType = null
$type = null
- Attributs protégés hérités de FormModel
$events_map = null
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for workflow

Depuis
4.0.0

Documentation des fonctions membres

◆ canDelete()

canDelete ( $record )
protected

Method to test whether a record can be deleted.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to delete the record. Defaults to the permission for the component.
Depuis
4.0.0

Références Factory\getUser().

◆ canEditState()

canEditState ( $record )
protected

Method to test whether a record can have its state changed.

Paramètres
object $record A record object.
Renvoie
boolean True if allowed to change the state of the record. Defaults to the permission set in the component.
Depuis
4.0.0

Références $user, et Factory\getUser().

◆ generateNewTitle()

generateNewTitle | ( | $categoryId,
 |  | $alias,
 |  | $title
 | ) |
protected

Method to change the title

Paramètres
integer | $categoryId | The id of the category.
string | $alias | The alias.
string | $title | The title.
Renvoie
array Contains the modified title and alias.
Depuis
4.0.0

Références $title, et StringHelper\increment().

◆ getForm()

getForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Abstract method for getting the form from the model.

Paramètres
array | $data | Data for the form.
boolean | $loadData | True if the form is to load its own data (default case), false if not.
Renvoie
|boolean A Form object on success, false on failure
Depuis
4.0.0

Implémente FormModelInterface.

Références $canEditState, $data, $form, $id, $item, Factory\getDate(), et Joomla\CMS\MVC\Model\loadForm().

◆ getReorderConditions()

getReorderConditions ( $table )
protected

A protected method to get a set of ordering conditions.

Paramètres
object $table A record object.
Renvoie
array An array of conditions to add to ordering queries.
Depuis
4.0.0

Références $db, et Joomla\Database\getDatabase().

◆ loadFormData()

loadFormData ( )
protected

Method to get the data that should be injected in the form.

Renvoie
mixed The data for the form.
Depuis
4.0.0

Références $data, et Factory\getApplication().

◆ populateState()

populateState ( )

Auto-populate the model state.

Note. Calling getState in this method will result in recursion.

Renvoie
void
Depuis
4.0.0

Références $app, $context, $extension, $name, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

◆ preprocessForm()

preprocessForm | ( | Form | $form,
 |  |  | $data,
 |  |  | $group = 'content'
 | ) |  |
protected

Method to preprocess the form.

Paramètres
Form | $form | Form object.
mixed | $data | The data expected for the form.
string | $group | The name of the plugin group to import (defaults to "content").
Renvoie
void
Depuis
4.0.0

Références $data, $extension, $form, $parts, Factory\getApplication(), et Joomla\CMS\MVC\Model\preprocessForm().

◆ publish()

publish | ( | & | $pks,
 |  |  | $value = 1
 | ) |  |

Method to change the published state of one or more records.

Paramètres
array | &$pks | A list of the primary keys to change.
integer | $value | The value of the published state.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $date, $i, $value, Text\_(), Factory\getApplication(), et Factory\getDate().

◆ save()

save ( $data )

Method to save the form data.

Paramètres
array $data The form data.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $app, $context, $data, $extension, $input, $key, $name, $result, $title, $user, Factory\getApplication(), Joomla\CMS\MVC\Model\getState(), et null.

◆ setDefault()

setDefault | ( | $pk,
 |  | $value = 1
 | ) |

Method to change the default state of one item.

Paramètres
array | $pk | A list of the primary keys to change.
integer | $value | The value of the home state.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $date, $this, $value, Text\_(), Log\add(), Factory\getDate(), et Log\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowModel.php


Joomla CMS: Référence de la classe WorkflowsModel

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Model
  • WorkflowsModel
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe WorkflowsModel
+ Graphe d'héritage de WorkflowsModel:
ListModel BaseDatabaseModel FormFactoryAwareInterface ListModelInterface BaseModel DatabaseModelInterface DispatcherAwareInterface CurrentUserInterface CacheControllerFactoryAwareInterface DatabaseAwareInterface CMSObject ModelInterface StatefulModelInterface

Fonctions membres publiques

__construct ($config=array())
getTable ($type='Workflow', $prefix='Administrator', $config=array())
getItems ()
getFilterForm ($data=array(), $loadData=true)
getListQuery ()
- Fonctions membres publiques hérités de ListModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getIsEmptyState ()
getActiveFilters ()
getItems ()
getPagination ()
getTotal ()
getStart ()
getFilterForm ($data=array(), $loadData=true)
getUserStateFromRequest ($key, $request, $default=null, $type='none', $resetPage=true)
- Fonctions membres publiques hérités de BaseDatabaseModel
__construct ($config=array(), MVCFactoryInterface $factory=null)
getTable ($name='', $prefix='', $options=array())
isCheckedOut ($item)
getDbo ()
setDbo (DatabaseInterface $db=null)
__get ($name)
- Fonctions membres publiques hérités de BaseModel
__construct ($config=array())
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de StatefulModelInterface
getState ($property=null, $default=null)
setState ($property, $value=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)
- Fonctions membres publiques hérités de CacheControllerFactoryAwareInterface
setCacheControllerFactory (CacheControllerFactoryInterface $factory)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Fonctions membres publiques hérités de FormFactoryAwareInterface
setFormFactory (FormFactoryInterface $factory)

Fonctions membres protégées

populateState ($ordering='w.ordering', $direction='asc')
countItems ($items)
- Fonctions membres protégées hérités de ListModel
getEmptyStateQuery ()
_getListQuery ()
getListQuery ()
getStoreId ($id='')
loadFormData ()
populateState ($ordering=null, $direction=null)
refineSearchStringToRegex ($search, $regexDelimiter='/')
- Fonctions membres protégées hérités de BaseDatabaseModel
_getList ($query, $limitstart=0, $limit=0)
_getListCount ($query)
_createTable ($name, $prefix='Table', $config=array())
bootComponent ($component)
dispatchEvent (EventInterface $event)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseModel
static | addIncludePath ($path='', $prefix='')
- Attributs protégés hérités de ListModel
$cache = array()
$context = null
$filter_fields = array()
$query = array()
$lastQueryStoreId = null
$filterFormName = null
$htmlFormName = 'adminForm'
$filterBlacklist = array()
$filterForbiddenList = array()
$listBlacklist = array('select')
$listForbiddenList = array('select')
- Attributs protégés hérités de BaseDatabaseModel
$option = null
$event_clean_cache = null
- Attributs protégés hérités de BaseModel
$name
- Attributs protégés hérités de CMSObject
$_errors = array()
- Attributs protégés statiques hérités de BaseModel
static | $paths

Description détaillée

Model class for workflows

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $config = array() )

Constructor.

Paramètres
array $config An optional associative array of configuration settings.
Voir également
JController
Depuis
4.0.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ countItems()

countItems ( $items )
protected

Add the number of transitions and states to all workflow items

Paramètres
array $items The workflow items
Renvoie
mixed An array of data items on success, false on failure.
Depuis
4.0.0

Références $db, $item, $items, $query, $transitions, et Joomla\Database\getDatabase().

◆ getFilterForm()

getFilterForm | ( | $data = array(),
 |  | $loadData = true
 | ) |

Get the filter form

Paramètres
array | $data | data
boolean | $loadData | load current data
Renvoie
|bool the Form object or false
Depuis
4.0.0

Références $data, $form, Joomla\CMS\MVC\Model\getState(), et null.

◆ getItems()

getItems ( )

Method to get an array of data items.

Renvoie
mixed An array of data items on success, false on failure.
Depuis
4.0.0

Implémente ListModelInterface.

Références $items, et Joomla\CMS\Categories\countItems().

◆ getListQuery()

getListQuery ( )

Method to get the data that should be injected in the form.

Renvoie
string The query to database.
Depuis
4.0.0

Références $db, $extension, $query, elseif, Joomla\Database\getDatabase(), Joomla\CMS\MVC\Model\getState(), et ParameterType\INTEGER.

◆ getTable()

getTable | ( | $type = 'Workflow',
 |  | $prefix = 'Administrator',
 |  | $config = array()
 | ) |

Method to get a table object, load it if necessary.

Paramètres
string | $type | The table name. Optional.
string | $prefix | The class prefix. Optional.
array | $config | Configuration array for model. Optional.
Renvoie
A Table object
Depuis
4.0.0

Références $config, $prefix, et $type.

◆ populateState()

populateState | ( | $ordering = 'w.ordering',
 |  | $direction = 'asc'
 | ) |
protected

Method to auto-populate the model state.

This method should only be called once per instantiation and is designed to be called on the first call to the getState() method unless the model configuration flag to ignore the request is set.

Note. Calling getState in this method will result in recursion.

Paramètres
string | $ordering | An optional ordering field.
string | $direction | An optional direction (asc|desc).
Renvoie
void
Depuis
4.0.0

Références $app, $direction, $extension, $ordering, $parts, Factory\getApplication(), null, Joomla\CMS\MVC\Model\populateState(), et Joomla\CMS\MVC\Model\setState().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowsModel.php


Joomla CMS: Référence de la classe StageTable

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Table
  • StageTable
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe StageTable
+ Graphe d'héritage de StageTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
delete ($pk=null)
check ()
store ($updateNulls=true)
bind ($src, $ignore=array())
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Stage table

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )
Paramètres
DatabaseDriver $db Database connector object
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
4.0.0

Références $extension, $parts, Joomla\CMS\MVC\Model\$workflow, et Joomla\CMS\MVC\Model\getDbo().

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Get the parent asset id for the record

Paramètres
Table | null | $table | A Table object for the asset parent.
integer | null | $id | The id for the asset
Renvoie
integer The id of the asset's parent
Depuis
4.0.0

Références $assetId, $extension, $id, $name, $parts, Joomla\CMS\MVC\Model\$workflow, et Joomla\CMS\MVC\Model\getDbo().

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
4.0.0

Références $title.

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Method to bind an associative array or object to the Table instance. This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
4.0.0
Exceptions

Implémente TableInterface.

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success
Voir également
Table::check()
Depuis
4.0.0

Implémente TableInterface.

Références $db, $id, $query, Text\_(), elseif, Joomla\CMS\MVC\Model\getDbo(), et ParameterType\INTEGER.

◆ delete()

delete ( $pk = null )

Deletes workflow with transition and stages.

Paramètres
int $pk Extension ids to delete.
Renvoie
boolean True on success.
Depuis
4.0.0
Exceptions

Implémente TableInterface.

Références $app, $db, $query, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getDbo(), ParameterType\INTEGER, et Text\sprintf().

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
4.0.0

Implémente TableInterface.

Références Joomla\CMS\MVC\Model\getDbo().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StageTable.php


Joomla CMS: Référence de la classe TransitionTable

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Table
  • TransitionTable
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TransitionTable
+ Graphe d'héritage de TransitionTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
bind ($src, $ignore=array())
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
delete ($pk=null)
getKeyName ()
store ($updateNulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
$_jsonEncode
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Transition table

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )
Paramètres
DatabaseDriver $db Database connector object
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
4.0.0

Références $extension, $parts, Joomla\CMS\MVC\Model\$workflow, et Joomla\CMS\MVC\Model\getDbo().

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Get the parent asset id for the record

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | The id for the asset
Renvoie
integer The id of the asset's parent
Depuis
4.0.0

Références $assetId, $extension, $id, $name, $parts, Joomla\CMS\MVC\Model\$workflow, et Joomla\CMS\MVC\Model\getDbo().

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
4.0.0

Références $title.

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Method to bind an associative array or object to the Table instance. This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
4.0.0
Exceptions

Implémente TableInterface.

Documentation des champs

◆ $_jsonEncode

$_jsonEncode
protected
Valeur initiale :
= [
'options'
]

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TransitionTable.php


Joomla CMS: Référence de la classe WorkflowTable

  • Joomla
  • Component
  • Workflow
  • Administrator
  • Table
  • WorkflowTable
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe WorkflowTable
+ Graphe d'héritage de WorkflowTable:
Table CMSObject TableInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DatabaseDriver $db)
delete ($pk=null)
check ()
store ($updateNulls=true)
bind ($src, $ignore=array())
- Fonctions membres publiques hérités de Table
__construct ($table, $key, DatabaseDriver $db, DispatcherInterface $dispatcher=null)
getFields ($reload=false)
appendPrimaryKeys ($query, $pk=null)
getTableName ()
getKeyName ($multiple=false)
getId ()
getDbo ()
setDbo (DatabaseDriver $db)
setRules ($input)
getRules ()
reset ()
bind ($src, $ignore=array())
load ($keys=null, $reset=true)
check ()
save ($src, $orderingFilter='', $ignore='')
checkOut ($userId, $pk=null)
checkIn ($pk=null)
hasPrimaryKey ()
hit ($pk=null)
isCheckedOut ($with=0, $against=null)
getNextOrder ($where='')
getPrimaryKey (array $keys=array())
reorder ($where='')
move ($delta, $where='')
publish ($pks=null, $state=1, $userId=0)
getColumnAlias ($column)
setColumnAlias ($column, $columnAlias)
hasField ($key)
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de TableInterface
getKeyName ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

_getAssetName ()
_getAssetTitle ()
_getAssetParentId (Table $table=null, $id=null)
- Fonctions membres protégées hérités de Table
_getAssetName ()
_getAssetTitle ()
_lock ()
_unlock ()

Attributs protégés

$_supportNullValue = true
- Attributs protégés hérités de Table
$_tbl = ''
$_tbl_key = ''
$_tbl_keys = array()
$_db
$_trackAssets = false
$_rules
$_locked = false
$_autoincrement = true
$_columnAlias = array()
$_jsonEncode = array()
$_supportNullValue = false
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Table
static | getInstance ($type, $prefix='JTable', $config=array())
static | addIncludePath ($path=null)
- Champs de données hérités de Table
$typeAlias = null

Description détaillée

Workflow table

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )
Paramètres
DatabaseDriver $db Database connector object
Depuis
4.0.0

Références $db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ _getAssetName()

_getAssetName ( )
protected

Method to compute the default name of the asset. The default name is in the form table_name.id where id is the value of the primary key of the table.

Renvoie
string
Depuis
4.0.0

Références $extension, $parts, et extension.

◆ _getAssetParentId()

_getAssetParentId | ( | Table | $table = null,
 |  |  | $id = null
 | ) |  |
protected

Get the parent asset id for the record

Paramètres
Table | $table | A Table object for the asset parent.
integer | $id | The id for the asset
Renvoie
integer The id of the asset's parent
Depuis
4.0.0

Références $assetId, $extension, $id, $parts, $query, $result, extension, Joomla\CMS\MVC\Model\getDbo(), et null.

◆ _getAssetTitle()

_getAssetTitle ( )
protected

Method to return the title to use for the asset table.

Renvoie
string
Depuis
4.0.0

Références $title.

◆ bind()

bind | ( | $src,
 |  | $ignore = array()
 | ) |

Method to bind an associative array or object to the Table instance. This method only binds properties that are publicly accessible and optionally takes an array of properties to ignore when binding.

Paramètres
array | object | $src | An associative array or object to bind to the Table instance.
array | string | $ignore | An optional array or space separated list of properties to ignore while binding.
Renvoie
boolean True on success.
Depuis
4.0.0
Exceptions

Implémente TableInterface.

◆ check()

check ( )

Overloaded check function

Renvoie
boolean True on success
Voir également
Table::check()
Depuis
4.0.0

Implémente TableInterface.

Références $db, $id, $query, Text\_(), elseif, et Joomla\CMS\MVC\Model\getDbo().

◆ delete()

delete ( $pk = null )

Deletes workflow with transition and states.

Paramètres
int $pk Extension ids to delete.
Renvoie
boolean
Depuis
4.0.0
Exceptions

Implémente TableInterface.

Références $app, $db, $query, Text\_(), Factory\getApplication(), Joomla\CMS\MVC\Model\getDbo(), ParameterType\INTEGER, et Text\sprintf().

◆ store()

store ( $updateNulls = true )

Overloaded store function

Paramètres
boolean $updateNulls True to update fields even if they are null.
Renvoie
mixed False on failure, positive integer on success.
Voir également
Table::store()
Depuis
4.0.0

Implémente TableInterface.

Références $date, $this, $user, Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), et Factory\getUser().

Documentation des champs

◆ $_supportNullValue

$_supportNullValue = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WorkflowTable.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Stage
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$form
$item
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View class to add or edit a stage of a workflow

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $canDo, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), extension, ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display item view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $parts, et extension.

Documentation des champs

◆ $extension

$extension
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $section

$section
protected

◆ $state

$state
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Stage/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Stages
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$stages
$stage
$sidebar
$pagination
$workflow
$workflowID
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Stages view class for the Workflow package.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $canDo, $toolbar, $user, Text\_(), Route\_(), extension, ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), Factory\getLanguage(), ToolbarHelper\link(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $parts, Joomla\CMS\MVC\Model\$workflow, extension, et Factory\getApplication().

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $extension

$extension
protected

◆ $filterForm

$filterForm

◆ $pagination

$pagination
protected

◆ $section

$section
protected

◆ $sidebar

$sidebar
protected

◆ $stage

$stage
protected

◆ $stages

$stages
protected

◆ $workflow

$workflow
protected

◆ $workflowID

$workflowID
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Stages/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Transition
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$form
$item
$app
$input
$workflowID
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View class to add or edit a transition of a workflow

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $canCreate, $canDo, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), ToolbarHelper\divider(), extension, ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\save(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display item view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $parts, extension, et Factory\getApplication().

Documentation des champs

◆ $app

$app
protected

◆ $extension

$extension
protected

◆ $form

$form
protected

◆ $input

$input
protected

◆ $item

$item
protected

◆ $section

$section
protected

◆ $state

$state
protected

◆ $workflowID

$workflowID
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Transition/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Transitions
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$transitions
$state
$sidebar
$pagination
$workflow
$workflowID
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Transitions view class for the Workflow package.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $canDo, $toolbar, $user, Text\_(), Route\_(), extension, ContentHelper\getActions(), Joomla\CMS\User\getCurrentUser(), Toolbar\getInstance(), Factory\getLanguage(), ToolbarHelper\link(), Text\sprintf(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $parts, et extension.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $extension

$extension
protected

◆ $filterForm

$filterForm

◆ $pagination

$pagination
protected

◆ $section

$section
protected

◆ $sidebar

$sidebar
protected

◆ $state

$state
protected

◆ $transitions

$transitions
protected

◆ $workflow

$workflow
protected

◆ $workflowID

$workflowID
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Transitions/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Workflow
  • HtmlView
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$state
$form
$item
$workflowID
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document

Description détaillée

View class to add or edit a workflow

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Références $canDo, $user, $userId, Text\_(), ToolbarHelper\apply(), ToolbarHelper\cancel(), extension, ContentHelper\getActions(), Factory\getApplication(), Joomla\CMS\User\getCurrentUser(), ToolbarHelper\saveGroup(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display item view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $parts, et extension.

Documentation des champs

◆ $extension

$extension
protected

◆ $form

$form
protected

◆ $item

$item
protected

◆ $section

$section
protected

◆ $state

$state
protected

◆ $workflowID

$workflowID
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Workflow/HtmlView.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Workflow
  • Administrator
  • View
  • Workflows
  • HtmlView
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Champs de données

$filterForm
$activeFilters
- Champs de données hérités de AbstractView
$document

Fonctions membres protégées

addToolbar ()
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Attributs protégés

$workflows
$state
$pagination
$sidebar
$extension
$section
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Description détaillée

Workflows view class for the Workflow package.

Depuis
4.0.0

Documentation des fonctions membres

◆ addToolbar()

addToolbar ( )
protected

Add the page title and toolbar.

Renvoie
void
Depuis
4.0.0

Add the page title and toolbar.

Renvoie
void
Exceptions

Références $canDo, $toolbar, $user, Text\_(), extension, ContentHelper\getActions(), Factory\getApplication(), Toolbar\getInstance(), et ToolbarHelper\title().

◆ display()

display ( $tpl = null )

Display the view

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
4.0.0

Implémente ViewInterface.

Références $extension, $parts, et extension.

Documentation des champs

◆ $activeFilters

$activeFilters

◆ $extension

$extension
protected

◆ $filterForm

$filterForm

◆ $pagination

$pagination
protected

◆ $section

$section
protected

◆ $sidebar

$sidebar
protected

◆ $state

$state
protected

◆ $workflows

$workflows
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_workflow/src/View/Workflows/HtmlView.php


Joomla CMS: Référence de la classe WrapperComponent

  • Joomla
  • Component
  • Wrapper
  • Administrator
  • Extension
  • WrapperComponent
Référence de la classe WrapperComponent
+ Graphe d'héritage de WrapperComponent:
MVCComponent RouterServiceInterface Component MVCFactoryServiceInterface ComponentInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de Component
__construct (ComponentDispatcherFactoryInterface $dispatcherFactory)
getDispatcher (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de MVCFactoryServiceInterface
getMVCFactory ()
- Fonctions membres publiques hérités de RouterServiceInterface
createRouter (CMSApplicationInterface $application, AbstractMenu $menu)

Description détaillée

Component class for com_wrapper

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • WrapperComponent.php


Joomla CMS: Référence de la classe DisplayController

  • Joomla
  • Component
  • Wrapper
  • Site
  • Controller
  • DisplayController
Fonctions membres publiques
Référence de la classe DisplayController
+ Graphe d'héritage de DisplayController:
BaseController ControllerInterface DispatcherAwareInterface

Fonctions membres publiques

display ($cachable=false, $urlparams=array())
- Fonctions membres publiques hérités de BaseController
__construct ($config=array(), MVCFactoryInterface $factory=null, ?CMSApplication $app=null, ?Input $input=null)
addViewPath ($path)
execute ($task)
getModel ($name='', $prefix='', $config=array())
getName ()
getTask ()
getTasks ()
getView ($name='', $type='', $prefix='', $config=array())
redirect ()
registerDefaultTask ($method)
registerTask ($task, $method)
unregisterTask ($task)
setMessage ($text, $type='message')
checkToken ($method='post', $redirect=true)
setRedirect ($url, $msg=null, $type=null)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de BaseController
static | addModelPath ($path, $prefix='')
static | createFileName ($type, $parts=array())
static | getInstance ($prefix, $config=array())
- Fonctions membres protégées hérités de BaseController
addPath ($type, $path)
checkEditId ($context, $id)
createModel ($name, $prefix='', $config=array())
createView ($name, $prefix='', $type='', $config=array())
holdEditId ($context, $id)
releaseEditId ($context, $id)
setPath ($type, $path)
- Attributs protégés hérités de BaseController
$basePath
$default_view
$doTask
$message
$messageType
$methods
$name
$model_prefix
$paths
$redirect
$task
$taskMap
$input
$factory
$app
- Attributs protégés statiques hérités de BaseController
static | $instance
static | $views

Description détaillée

Content Component Controller

Depuis
1.5

Documentation des fonctions membres

◆ display()

display | ( | $cachable = false,
 |  | $urlparams = array()
 | ) |

Method to display a view.

Paramètres
boolean | $cachable | If true, the view output will be cached
array | $urlparams | An array of safe URL parameters and their variable types, for valid values see JFilterInput::clean().
Renvoie
BaseController This object to support chaining.
Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_wrapper/src/Controller/DisplayController.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Component
  • Wrapper
  • Site
  • Service
  • Router
Fonctions membres publiques
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterBase RouterInterface

Fonctions membres publiques

build (&$query)
parse (&$segments)
- Fonctions membres publiques hérités de RouterBase
__construct ($app=null, $menu=null)
preprocess ($query)

Membres hérités additionnels

- Champs de données hérités de RouterBase
$app
$menu

Description détaillée

Routing class from com_wrapper

Depuis
3.3

Documentation des fonctions membres

◆ build()

build ( & $query )

Build the route for the com_wrapper component

Paramètres
array $query An array of URL arguments
Renvoie
array The URL arguments to use to assemble the subsequent URL.
Depuis
3.3

Implémente RouterInterface.

Références $query.

◆ parse()

parse ( & $segments )

Parse the segments of a URL.

Paramètres
array $segments The segments of the URL to parse.
Renvoie
array The URL attributes to be used by the application.
Depuis
3.3

Implémente RouterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_wrapper/src/Service/Router.php


Joomla CMS: Référence de la classe HtmlView

  • Joomla
  • Component
  • Wrapper
  • Site
  • View
  • Wrapper
  • HtmlView
Fonctions membres publiques | Attributs protégés
Référence de la classe HtmlView
+ Graphe d'héritage de HtmlView:
HtmlView AbstractView CurrentUserInterface CMSObject ViewInterface DispatcherAwareInterface

Fonctions membres publiques

display ($tpl=null)
- Fonctions membres publiques hérités de HtmlView
__construct ($config=array())
display ($tpl=null)
escape ($var)
getLayout ()
getLayoutTemplate ()
setLayout ($layout)
setLayoutExt ($value)
addTemplatePath ($path)
addHelperPath ($path)
loadTemplate ($tpl=null)
loadHelper ($hlp=null)
getForm ()
setDocumentTitle ($title)
- Fonctions membres publiques hérités de AbstractView
__construct ($config=array())
display ($tpl=null)
get ($property, $default=null)
getModel ($name=null)
setModel ($model, $default=false)
getName ()
- Fonctions membres publiques hérités de CMSObject
__construct ($properties=null)
__toString ()
def ($property, $default=null)
get ($property, $default=null)
getProperties ($public=true)
getError ($i=null, $toString=true)
getErrors ()
set ($property, $value=null)
setProperties ($properties)
setError ($error)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de CurrentUserInterface
setCurrentUser (User $currentUser)

Attributs protégés

$pageclass_sfx = ''
$params = null
$wrapper = null
- Attributs protégés hérités de HtmlView
$_basePath = null
$_layout = 'default'
$_layoutExt = 'php'
$_layoutTemplate = '_'
$_path = array('template' => array(), 'helper' => array())
$_template = null
$_output = null
$_charset = 'UTF-8'
- Attributs protégés hérités de AbstractView
$option = null
$_name = null
$_models = array()
$_defaultModel = null
- Attributs protégés hérités de CMSObject
$_errors = array()

Membres hérités additionnels

- Champs de données hérités de AbstractView
$document
- Fonctions membres protégées hérités de HtmlView
_setPath ($type, $path)
_addPath ($type, $path)
_createFileName ($type, $parts=array())
- Fonctions membres protégées hérités de AbstractView
dispatchEvent (EventInterface $event)

Description détaillée

Wrapper view class.

Depuis
1.5

Documentation des fonctions membres

◆ display()

display ( $tpl = null )

Execute and display a template script.

Paramètres
string $tpl The name of the template file to parse; automatically searches through the template paths.
Renvoie
void
Depuis
1.5

Implémente ViewInterface.

Références $params, $url, $wrapper, elseif, Factory\getApplication(), et Uri\getInstance().

Documentation des champs

◆ $pageclass_sfx

$pageclass_sfx = ''
protected

◆ $params

$params = null
protected

◆ $wrapper

$wrapper = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_wrapper/src/View/Wrapper/HtmlView.php


Joomla CMS: Référence de la classe AbstractCommand

  • Joomla
  • Console
  • Command
  • AbstractCommand
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe AbstractCommand
+ Graphe d'héritage de AbstractCommand:
AddUserCommand AddUserToGroupCommand ChangeUserPasswordCommand CheckJoomlaUpdatesCommand CheckUpdatesCommand CleanCacheCommand DeleteUserCommand ExtensionDiscoverCommand ExtensionDiscoverInstallCommand ExtensionInstallCommand ExtensionRemoveCommand ExtensionsListCommand FinderIndexCommand GetConfigurationCommand ListUserCommand RemoveOldFilesCommand RemoveUserFromGroupCommand SessionGcCommand SessionMetadataGcCommand SetConfigurationCommand SiteDownCommand SiteUpCommand TasksListCommand TasksRunCommand TasksStateCommand UpdateCoreCommand HelpCommand ListCommand ExportCommand ImportCommand DebugEventDispatcherCommand DebugRouterCommand CreateSessionTableCommand

Fonctions membres publiques

__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres publiques statiques

static getDefaultName ()

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static $defaultName

Attributs privés

$aliases = []
$application
$applicationDefinitionMerged = false
$applicationDefinitionMergedWithArgs = false
$definition
$description = ''
$help = ''
$helperSet
$hidden = false
$name
$synopsis = []

Description détaillée

Base command class for a Joomla! command line application.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?string $name = null )

Command constructor.

Paramètres
string | null $name The name of the command; if the name is empty and no default is set, a name must be set in the configure() method
Depuis
2.0.0

Références AbstractCommand\$name, AbstractCommand\configure(), null, et AbstractCommand\setName().

Documentation des fonctions membres

◆ addArgument()

addArgument | ( | string | $name,
 |  | ?int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |

Adds an argument to the input definition.

Paramètres
string | $name | The argument name
integer | $mode | The argument mode: InputArgument::REQUIRED or InputArgument::OPTIONAL
string | $description | A description text
mixed | $default | The default value (for InputArgument::OPTIONAL mode only)
Renvoie
$this
Depuis
2.0.0

Références $default, AbstractCommand\$description, $mode, AbstractCommand\$name, et $this.

Référencé par ListCommand\configure(), et DebugEventDispatcherCommand\configure().

◆ addOption()

addOption | ( | string | $name,
 |  |  | $shortcut = null,
 |  | ?int | $mode = null,
 |  |  | $description = '',
 |  |  | $default = null
 | ) |  |

Adds an option to the input definition.

Paramètres
string | $name | The option name
string | array | $shortcut | The shortcuts, can be null, a string of shortcuts delimited by | or an array of shortcuts
integer | $mode | The option mode: One of the VALUE_* constants
string | $description | A description text
mixed | $default | The default value (must be null for InputOption::VALUE_NONE)
Renvoie
$this
Depuis
2.0.0

Références $default, AbstractCommand\$description, $mode, AbstractCommand\$name, et $this.

Référencé par DebugRouterCommand\configure(), ExportCommand\configure(), et ImportCommand\configure().

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Référencé par AbstractCommand\__construct().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
abstractprotected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

Référencé par AbstractCommand\execute().

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Executes the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

Références $input, $output, InputInterface\bind(), AbstractCommand\doExecute(), AbstractCommand\getDefinition(), AbstractCommand\getName(), AbstractCommand\getSynopsis(), AbstractCommand\initialise(), AbstractCommand\mergeApplicationDefinition(), null, et InputInterface\validate().

Référencé par Application\runCommand().

◆ getAliases()

getAliases ( )

Get the command's aliases.

Renvoie
string[]
Depuis
2.0.0

Références AbstractCommand\$aliases.

Référencé par Application\addCommand(), TextDescriptor\describeConsoleCommand(), et TextDescriptor\getCommandAliasesText().

◆ getApplication()

getApplication ( )

Get the application object.

Renvoie
Application The application object.
Depuis
2.0.0
Exceptions

Références AbstractCommand\$application, et $this.

Référencé par AbstractCommand\mergeApplicationDefinition().

◆ getDefaultName()

static getDefaultName ( )
static

Get the default command name for this class.

This allows a command name to defined and referenced without instantiating the full command class.

Renvoie
string|null
Depuis
2.0.0

Références $class, $r, et null.

Référencé par SiteDownCommand\doExecute(), SiteUpCommand\doExecute(), et Application\register().

◆ getDefinition()

getDefinition ( )

Gets the InputDefinition attached to this command.

Renvoie
InputDefinition
Depuis
2.0.0

Références AbstractCommand\$definition.

Référencé par Application\addCommand(), TextDescriptor\describeConsoleCommand(), AbstractCommand\execute(), AbstractCommand\getSynopsis(), AbstractCommand\mergeApplicationDefinition(), et Application\runCommand().

◆ getDescription()

getDescription ( )

Get the command's description.

Renvoie
string
Depuis
2.0.0

Références AbstractCommand\$description.

Référencé par AbstractCommand\getProcessedHelp().

◆ getHelp()

getHelp ( )

Get the command's help.

Renvoie
string
Depuis
2.0.0

Références AbstractCommand\$help.

Référencé par AbstractCommand\getProcessedHelp().

◆ getHelperSet()

getHelperSet ( )

Get the command's input helper set.

Renvoie
HelperSet|null
Depuis
2.0.0

Références AbstractCommand\$helperSet.

Référencé par Application\runCommand().

◆ getName()

getName ( )

Get the command's name.

Renvoie
string|null
Depuis
2.0.0

Références AbstractCommand\$name.

Référencé par Application\addCommand(), AbstractCommand\execute(), AbstractCommand\getProcessedHelp(), et AbstractCommand\getSynopsis().

◆ getProcessedHelp()

getProcessedHelp ( )

Returns the processed help for the command.

This method is used to replace placeholders in commands with the real values. By default, this supports command.name% and command.full_name.

Renvoie
string
Depuis
2.0.0

Références AbstractCommand\$name, AbstractCommand\getDescription(), AbstractCommand\getHelp(), et AbstractCommand\getName().

Référencé par TextDescriptor\describeConsoleCommand().

◆ getSynopsis()

getSynopsis ( bool $short = false )

Get the command's synopsis.

Paramètres
boolean $short Flag indicating whether the short or long version of the synopsis should be returned
Renvoie
string
Depuis
2.0.0

Références $key, AbstractCommand\getDefinition(), et AbstractCommand\getName().

Référencé par TextDescriptor\describeConsoleCommand(), et AbstractCommand\execute().

◆ initialise()

initialise | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal hook to initialise the command after the input has been bound and before the input is validated.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
void
Depuis
2.0.0

Référencé par AbstractCommand\execute().

◆ isEnabled()

isEnabled ( )

Check if the command is enabled in this environment.

Renvoie
boolean
Depuis
2.0.0

Référencé par Application\addCommand().

◆ isHidden()

isHidden ( )

Check if the command is hidden from the command listing.

Renvoie
boolean
Depuis
2.0.0

Références AbstractCommand\$hidden.

◆ mergeApplicationDefinition()

mergeApplicationDefinition ( bool $mergeArgs = true )
final

Merges the application definition with the command definition.

Paramètres
boolean $mergeArgs Flag indicating whether the application's definition arguments should be merged
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\getApplication(), et AbstractCommand\getDefinition().

Référencé par TextDescriptor\describeConsoleCommand(), AbstractCommand\execute(), et Application\runCommand().

◆ setAliases()

setAliases ( array $aliases )

Set the command's aliases.

Paramètres
string[] $aliases The command aliases
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$aliases.

◆ setApplication()

setApplication ( ?Application $application = null )

Set the command's application.

Paramètres
Application $application The command's application
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$application, null, et AbstractCommand\setHelperSet().

Référencé par Application\addCommand().

◆ setDefinition()

setDefinition ( $definition )

Sets the input definition for the command.

Paramètres
array | InputDefinition $definition Either an InputDefinition object or an array of objects to write to the definition.
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$definition.

◆ setDescription()

setDescription ( string $description )

Sets the description for the command.

Paramètres
string $description The description for the command
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$description, et description.

Référencé par ListCommand\configure(), HelpCommand\configure(), DebugEventDispatcherCommand\configure(), DebugRouterCommand\configure(), CreateSessionTableCommand\configure(), ExportCommand\configure(), et ImportCommand\configure().

◆ setHelp()

setHelp ( string $help )

Sets the help for the command.

Paramètres
string $help The help for the command
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$help.

Référencé par ListCommand\configure(), HelpCommand\configure(), DebugEventDispatcherCommand\configure(), et DebugRouterCommand\configure().

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet )

Set the command's input helper set.

Paramètres
HelperSet $helperSet The helper set.
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$helperSet.

Référencé par AbstractCommand\setApplication().

◆ setHidden()

setHidden ( bool $hidden )

Set whether this command is hidden from the command listing.

Paramètres
boolean $hidden Flag if this command is hidden.
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$hidden.

◆ setName()

setName ( string $name )

Set the command's name.

Paramètres
string $name The command name
Renvoie
void
Depuis
2.0.0

Références AbstractCommand\$name, et name.

Référencé par AbstractCommand\__construct().

Documentation des champs

◆ $aliases

$aliases = []
private

Référencé par AbstractCommand\getAliases(), et AbstractCommand\setAliases().

◆ $application

$application
private

Référencé par AbstractCommand\getApplication(), et AbstractCommand\setApplication().

◆ $applicationDefinitionMerged

$applicationDefinitionMerged = false
private

◆ $applicationDefinitionMergedWithArgs

$applicationDefinitionMergedWithArgs = false
private

◆ $defaultName

$defaultName
staticprotected

◆ $definition

$definition
private

Référencé par AbstractCommand\getDefinition(), et AbstractCommand\setDefinition().

◆ $description

$description = ''
private

Référencé par AbstractCommand\addArgument(), AbstractCommand\addOption(), AbstractCommand\getDescription(), et AbstractCommand\setDescription().

◆ $help

$help = ''
private

Référencé par AbstractCommand\getHelp(), et AbstractCommand\setHelp().

◆ $helperSet

$helperSet
private

Référencé par AbstractCommand\getHelperSet(), et AbstractCommand\setHelperSet().

◆ $hidden

$hidden = false
private

Référencé par AbstractCommand\isHidden(), et AbstractCommand\setHidden().

◆ $name

$name
private

Référencé par AbstractCommand\__construct(), AbstractCommand\addArgument(), AbstractCommand\addOption(), AbstractCommand\getName(), AbstractCommand\getProcessedHelp(), et AbstractCommand\setName().

◆ $synopsis

$synopsis = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractCommand.php


Joomla CMS: Référence de la classe HelpCommand

  • Joomla
  • Console
  • Command
  • HelpCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe HelpCommand
+ Graphe d'héritage de HelpCommand:
AbstractCommand

Fonctions membres publiques

setCommand (AbstractCommand $command)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'help'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Attributs privés

$command

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Command to render a command's help data.

Depuis
2.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références name, AbstractCommand\setDescription(), et AbstractCommand\setHelp().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

◆ setCommand()

setCommand ( AbstractCommand $command )

Set the command whose help is being presented.

Paramètres
AbstractCommand $command The command to process help for.
Renvoie
void
Depuis
2.0.0

Documentation des champs

◆ $command

$command
private

◆ $defaultName

$defaultName = 'help'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Command/HelpCommand.php


Joomla CMS: Référence de la classe ListCommand

  • Joomla
  • Console
  • Command
  • ListCommand
Fonctions membres protégées | Attributs protégés statiques
Référence de la classe ListCommand
+ Graphe d'héritage de ListCommand:
AbstractCommand

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'list'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Command listing all available commands.

Depuis
2.0.0

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\addArgument(), InputArgument\OPTIONAL, AbstractCommand\setDescription(), et AbstractCommand\setHelp().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

Documentation des champs

◆ $defaultName

$defaultName = 'list'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Command/ListCommand.php


Joomla CMS: Référence de la classe ApplicationDescription

  • Joomla
  • Console
  • Descriptor
  • ApplicationDescription
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe ApplicationDescription

Fonctions membres publiques

__construct (Application $application, string $namespace='', bool $showHidden=false)
getNamespaces ()
getCommands ()
getCommand (string $name)

Champs de données

const GLOBAL_NAMESPACE = '_global'

Fonctions membres privées

extractNamespace (string $name, ?int $limit=null)
inspectApplication ()
sortCommands (array $commands)

Attributs privés

$aliases
$application
$commands
$namespace = ''
$namespaces
$showHidden

Description détaillée

Describes an application.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Application | $application,
 |  | string | $namespace = '',
 |  | bool | $showHidden = false
 | ) |  |

Constructor.

Paramètres
Application | $application | The application being described.
string | $namespace | The command namespace to process.
boolean | $showHidden | Flag indicating hidden commands should be displayed.
Depuis
2.0.0

Références ApplicationDescription\$application, ApplicationDescription\$namespace, et ApplicationDescription\$showHidden.

Documentation des fonctions membres

◆ extractNamespace()

extractNamespace | ( | string | $name,
 |  | ?int | $limit = null
 | ) |  |
private

Returns the namespace part of the command name.

Paramètres
string | $name | The command name to process
integer | $limit | The maximum number of parts of the namespace
Renvoie
string
Depuis
2.0.0

Références $limit, $name, $parts, et null.

Référencé par ApplicationDescription\sortCommands().

◆ getCommand()

getCommand ( string $name )

Get a command by name.

Paramètres
string $name The name of the command to retrieve.
Renvoie
AbstractCommand
Depuis
2.0.0
Exceptions
CommandNotFoundException

Références $name.

◆ getCommands()

getCommands ( )

Get the application's commands.

Renvoie
AbstractCommand[]
Depuis
2.0.0

Références ApplicationDescription\$commands, ApplicationDescription\inspectApplication(), et null.

◆ getNamespaces()

getNamespaces ( )

Get the application's command namespaces.

Renvoie
array[]
Depuis
2.0.0

Références ApplicationDescription\$namespaces, ApplicationDescription\inspectApplication(), et null.

◆ inspectApplication()

inspectApplication ( )
private

Inspects the application.

Renvoie
void
Depuis
2.0.0

Références ApplicationDescription\$commands, $name, $names, ApplicationDescription\$namespace, $this, et ApplicationDescription\sortCommands().

Référencé par ApplicationDescription\getCommands(), et ApplicationDescription\getNamespaces().

◆ sortCommands()

sortCommands ( array $commands )
private

Sort a set of commands.

Paramètres
AbstractCommand[] $commands The commands to sort.
Renvoie
AbstractCommand[][]
Depuis
2.0.0

Références ApplicationDescription\$commands, $key, $name, et ApplicationDescription\extractNamespace().

Référencé par ApplicationDescription\inspectApplication().

Documentation des champs

◆ $aliases

$aliases
private

◆ $application

$application
private

Référencé par ApplicationDescription\__construct().

◆ $commands

$commands
private

Référencé par ApplicationDescription\getCommands(), ApplicationDescription\inspectApplication(), et ApplicationDescription\sortCommands().

◆ $namespace

$namespace = ''
private

Référencé par ApplicationDescription\__construct(), et ApplicationDescription\inspectApplication().

◆ $namespaces

$namespaces
private

Référencé par ApplicationDescription\getNamespaces().

◆ $showHidden

$showHidden
private

Référencé par ApplicationDescription\__construct().

◆ GLOBAL_NAMESPACE

const GLOBAL_NAMESPACE = '_global'

Référencé par TextDescriptor\describeJoomlaApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Descriptor/ApplicationDescription.php


Joomla CMS: Référence de la classe TextDescriptor

  • Joomla
  • Console
  • Descriptor
  • TextDescriptor
Fonctions membres publiques | Fonctions membres privées
Référence de la classe TextDescriptor
+ Graphe d'héritage de TextDescriptor:
TextDescriptor Descriptor DescriptorInterface

Fonctions membres publiques

describe (OutputInterface $output, $object, array $options=[])
- Fonctions membres publiques hérités de Descriptor
describe (OutputInterface $output, object $object, array $options=[])

Fonctions membres privées

getCommandAliasesText (AbstractCommand $command)
describeConsoleCommand (AbstractCommand $command, array $options)
describeJoomlaApplication (Application $app, array $options)
getColumnWidth (array $commands)
writeText ($content, array $options=[])

Membres hérités additionnels

- Fonctions membres protégées hérités de TextDescriptor
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Fonctions membres protégées hérités de Descriptor
write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Attributs protégés hérités de Descriptor
$output

Description détaillée

Text object descriptor.

Depuis
2.0.0

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  |  | $object,
 |  | array | $options = []
 | ) |  |

Describes an object.

Paramètres
OutputInterface | $output | The output object to use.
object | $object | The object to describe.
array | $options | Descriptor options.
Renvoie
void
Depuis
2.0.0

Références $options, Descriptor\$output, TextDescriptor\describeConsoleCommand(), et TextDescriptor\describeJoomlaApplication().

◆ describeConsoleCommand()

describeConsoleCommand | ( | AbstractCommand | $command,
 |  | array | $options
 | ) |  |
private

Describes a command.

Paramètres
AbstractCommand | $command | The command being described.
array | $options | Descriptor options.
Renvoie
void
Depuis
2.0.0

Références $options, TextDescriptor\describeInputDefinition(), AbstractCommand\getAliases(), AbstractCommand\getDefinition(), AbstractCommand\getProcessedHelp(), AbstractCommand\getSynopsis(), AbstractCommand\mergeApplicationDefinition(), et TextDescriptor\writeText().

Référencé par TextDescriptor\describe().

◆ describeJoomlaApplication()

describeJoomlaApplication | ( | Application | $app,
 |  | array | $options
 | ) |  |
private

Describes an application.

Paramètres
Application | $app | The application being described.
array | $options | Descriptor options.
Renvoie
void
Depuis
2.0.0

Références $app, $description, $name, $namespace, $options, $version, $width, TextDescriptor\describeInputDefinition(), TextDescriptor\getColumnWidth(), TextDescriptor\getCommandAliasesText(), ApplicationDescription\GLOBAL_NAMESPACE, StringHelper\strlen(), et TextDescriptor\writeText().

Référencé par TextDescriptor\describe().

◆ getColumnWidth()

getColumnWidth ( array $commands )
private

Calculate the column width for a group of commands.

Paramètres
AbstractCommand[]|string[] $commands The commands to use for processing a width.
Renvoie
integer
Depuis
2.0.0

Références StringHelper\strlen().

Référencé par TextDescriptor\describeJoomlaApplication().

◆ getCommandAliasesText()

getCommandAliasesText ( AbstractCommand $command )
private

Formats command aliases to show them in the command description.

Paramètres
AbstractCommand $command The command to process
Renvoie
string
Depuis
2.0.0

Références $text, et AbstractCommand\getAliases().

Référencé par TextDescriptor\describeJoomlaApplication().

◆ writeText()

writeText | ( |  | $content,
 |  | array | $options = []
 | ) |  |
private

Writes text to the output.

Paramètres
string | $content | The message.
array | $options | The options to use for formatting the output.
Renvoie
void
Depuis
2.0.0

Références $content, $options, et Descriptor\write().

Référencé par TextDescriptor\describeConsoleCommand(), et TextDescriptor\describeJoomlaApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Descriptor/TextDescriptor.php


Joomla CMS: Référence de la classe ApplicationErrorEvent

  • Joomla
  • Console
  • Event
  • ApplicationErrorEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ApplicationErrorEvent
+ Graphe d'héritage de ApplicationErrorEvent:
ConsoleEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (\Throwable $error, Application $application, ?AbstractCommand $command=null)
getError ()
getExitCode ()
setError (\Throwable $error)
setExitCode (int $exitCode)
- Fonctions membres publiques hérités de ConsoleEvent
__construct (string $name, Application $application, ?AbstractCommand $command=null)
getApplication ()
getCommand ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$error
$exitCode

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event triggered when an uncaught Throwable is received by the application.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Throwable | $error,
 |  | Application | $application,
 |  | ?AbstractCommand | $command = null
 | ) |  |

Event constructor.

Paramètres
\Throwable | $error | The Throwable object with the error data.
Application | $application | The active application.
AbstractCommand | null | $command | The command being executed.
Depuis
2.0.0

Références ConsoleEvent\$application, ConsoleEvent\$command, ApplicationErrorEvent\$error, Symfony\Contracts\Service\__construct(), et ConsoleEvents\APPLICATION_ERROR.

Documentation des fonctions membres

◆ getError()

getError ( )

Get the error object.

Renvoie
Depuis
2.0.0

Références ApplicationErrorEvent\$error.

◆ getExitCode()

getExitCode ( )

Gets the exit code.

Renvoie
integer
Depuis
2.0.0

◆ setError()

setError ( \Throwable $error )

Set the error object.

Paramètres
\Throwable $error The error object to set to the event.
Renvoie
void
Depuis
2.0.0

Références ApplicationErrorEvent\$error.

◆ setExitCode()

setExitCode ( int $exitCode )

Sets the exit code.

Paramètres
integer $exitCode The command exit code.
Renvoie
void
Depuis
2.0.0

Références ApplicationErrorEvent\$exitCode, et $r.

Documentation des champs

◆ $error

$error
private

Référencé par ApplicationErrorEvent\__construct(), ApplicationErrorEvent\getError(), et ApplicationErrorEvent\setError().

◆ $exitCode

$exitCode
private

Référencé par ApplicationErrorEvent\setExitCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • console/src/Event/ApplicationErrorEvent.php


Joomla CMS: Référence de la classe BeforeCommandExecuteEvent

  • Joomla
  • Console
  • Event
  • BeforeCommandExecuteEvent
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe BeforeCommandExecuteEvent
+ Graphe d'héritage de BeforeCommandExecuteEvent:
ConsoleEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (Application $application, ?AbstractCommand $command=null)
disableCommand ()
enableCommand ()
isCommandEnabled ()
- Fonctions membres publiques hérités de ConsoleEvent
__construct (string $name, Application $application, ?AbstractCommand $command=null)
getApplication ()
getCommand ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Champs de données

const RETURN_CODE_DISABLED = 113

Attributs privés

$commandEnabled = true

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event triggered before a command is executed.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Application | $application,
 |  | ?AbstractCommand | $command = null
 | ) |  |

Event constructor.

Paramètres
Application | $application | The active application.
AbstractCommand | null | $command | The command being executed.
Depuis
2.0.0

Références ConsoleEvent\$application, ConsoleEvent\$command, Symfony\Contracts\Service\__construct(), et ConsoleEvents\BEFORE_COMMAND_EXECUTE.

Documentation des fonctions membres

◆ disableCommand()

disableCommand ( )

Disable the command.

Renvoie
void
Depuis
2.0.0

◆ enableCommand()

enableCommand ( )

Enable the command.

Renvoie
void
Depuis
2.0.0

◆ isCommandEnabled()

isCommandEnabled ( )

Check if the command is enabled.

Renvoie
boolean
Depuis
2.0.0

Références BeforeCommandExecuteEvent\$commandEnabled.

Documentation des champs

◆ $commandEnabled

$commandEnabled = true
private

Référencé par BeforeCommandExecuteEvent\isCommandEnabled().

◆ RETURN_CODE_DISABLED

const RETURN_CODE_DISABLED = 113

Référencé par Application\runCommand().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BeforeCommandExecuteEvent.php


Joomla CMS: Référence de la classe CommandErrorEvent

  • Joomla
  • Console
  • Event
  • CommandErrorEvent
Fonctions membres publiques | Attributs privés
Référence de la classe CommandErrorEvent
+ Graphe d'héritage de CommandErrorEvent:
ConsoleEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (\Throwable $error, Application $application, ?AbstractCommand $command=null)
getError ()
getExitCode ()
setError (\Throwable $error)
setExitCode (int $exitCode)
- Fonctions membres publiques hérités de ConsoleEvent
__construct (string $name, Application $application, ?AbstractCommand $command=null)
getApplication ()
getCommand ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$error
$exitCode

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event triggered when an uncaught Throwable is received by the application from a command.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Throwable | $error,
 |  | Application | $application,
 |  | ?AbstractCommand | $command = null
 | ) |  |

Event constructor.

Paramètres
\Throwable | $error | The Throwable object with the error data.
Application | $application | The active application.
AbstractCommand | null | $command | The command being executed.
Depuis
2.0.0

Références ConsoleEvent\$application, ConsoleEvent\$command, CommandErrorEvent\$error, Symfony\Contracts\Service\__construct(), et ConsoleEvents\COMMAND_ERROR.

Documentation des fonctions membres

◆ getError()

getError ( )

Get the error object.

Renvoie
Depuis
2.0.0

Références CommandErrorEvent\$error.

◆ getExitCode()

getExitCode ( )

Gets the exit code.

Renvoie
integer
Depuis
2.0.0

Références CommandErrorEvent\$exitCode, et null.

◆ setError()

setError ( \Throwable $error )

Set the error object.

Paramètres
\Throwable $error The error object to set to the event.
Renvoie
void
Depuis
2.0.0

Références CommandErrorEvent\$error.

◆ setExitCode()

setExitCode ( int $exitCode )

Sets the exit code.

Paramètres
integer $exitCode The command exit code.
Renvoie
void
Depuis
2.0.0

Références CommandErrorEvent\$exitCode, et $r.

Documentation des champs

◆ $error

$error
private

Référencé par CommandErrorEvent\__construct(), CommandErrorEvent\getError(), et CommandErrorEvent\setError().

◆ $exitCode

$exitCode
private

Référencé par CommandErrorEvent\getExitCode(), et CommandErrorEvent\setExitCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CommandErrorEvent.php


Joomla CMS: Référence de la classe ConsoleEvent

  • Joomla
  • Console
  • Event
  • ConsoleEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ConsoleEvent
+ Graphe d'héritage de ConsoleEvent:
Event AbstractEvent EventInterface ApplicationErrorEvent BeforeCommandExecuteEvent CommandErrorEvent TerminateEvent

Fonctions membres publiques

__construct (string $name, Application $application, ?AbstractCommand $command=null)
getApplication ()
getCommand ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$application
$command

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Base event class for console events.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | Application | $application,
 |  | ?AbstractCommand | $command = null
 | ) |  |

Event constructor.

Paramètres
string | $name | The event name.
Application | $application | The active application.
AbstractCommand | null | $command | The command being executed.
Depuis
2.0.0

Références ConsoleEvent\$application, ConsoleEvent\$command, AbstractEvent\$name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getApplication()

getApplication ( )

Get the active application.

Renvoie
Application
Depuis
2.0.0

Références ConsoleEvent\$application.

◆ getCommand()

getCommand ( )

Get the command being executed.

Renvoie
AbstractCommand|null
Depuis
2.0.0

Références ConsoleEvent\$command.

Documentation des champs

◆ $application

$application
private

Référencé par TerminateEvent\__construct(), BeforeCommandExecuteEvent\__construct(), ApplicationErrorEvent\__construct(), ConsoleEvent\__construct(), CommandErrorEvent\__construct(), et ConsoleEvent\getApplication().

◆ $command

$command
private

Référencé par TerminateEvent\__construct(), BeforeCommandExecuteEvent\__construct(), ApplicationErrorEvent\__construct(), ConsoleEvent\__construct(), CommandErrorEvent\__construct(), et ConsoleEvent\getCommand().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Event/ConsoleEvent.php


Joomla CMS: Référence de la classe TerminateEvent

  • Joomla
  • Console
  • Event
  • TerminateEvent
Fonctions membres publiques | Attributs privés
Référence de la classe TerminateEvent
+ Graphe d'héritage de TerminateEvent:
ConsoleEvent Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (int $exitCode, Application $application, ?AbstractCommand $command=null)
getExitCode ()
setExitCode (int $exitCode)
- Fonctions membres publiques hérités de ConsoleEvent
__construct (string $name, Application $application, ?AbstractCommand $command=null)
getApplication ()
getCommand ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$exitCode

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event triggered immediately before the process is terminated.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $exitCode,
 |  | Application | $application,
 |  | ?AbstractCommand | $command = null
 | ) |  |

Event constructor.

Paramètres
integer | $exitCode | The Throwable object with the error data.
Application | $application | The active application.
AbstractCommand | null | $command | The command being executed.
Depuis
2.0.0

Références ConsoleEvent\$application, ConsoleEvent\$command, TerminateEvent\$exitCode, Symfony\Contracts\Service\__construct(), et ConsoleEvents\TERMINATE.

Documentation des fonctions membres

◆ getExitCode()

getExitCode ( )

Gets the exit code.

Renvoie
integer
Depuis
2.0.0

Références TerminateEvent\$exitCode.

◆ setExitCode()

setExitCode ( int $exitCode )

Sets the exit code.

Paramètres
integer $exitCode The command exit code.
Renvoie
void
Depuis
2.0.0

Références TerminateEvent\$exitCode.

Documentation des champs

◆ $exitCode

$exitCode
private

Référencé par TerminateEvent\__construct(), TerminateEvent\getExitCode(), et TerminateEvent\setExitCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TerminateEvent.php


Joomla CMS: Référence de la classe NamespaceNotFoundException

  • Joomla
  • Console
  • Exception
  • NamespaceNotFoundException
Référence de la classe NamespaceNotFoundException
+ Graphe d'héritage de NamespaceNotFoundException:
CommandNotFoundException InvalidArgumentException ExceptionInterface ExceptionInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de CommandNotFoundException
__construct (string $message, array $alternatives=[], int $code=0, \Throwable $previous=null)
getAlternatives ()

Description détaillée

Exception indicating a missing command namespace.

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Exception/NamespaceNotFoundException.php


Joomla CMS: Référence de la classe DescriptorHelper

  • Joomla
  • Console
  • Helper
  • DescriptorHelper
Fonctions membres publiques
Référence de la classe DescriptorHelper
+ Graphe d'héritage de DescriptorHelper:
Helper HelperInterface

Fonctions membres publiques

describe (OutputInterface $output, $object, array $options=[])
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

Describes an object.

Depuis
2.0.0

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  |  | $object,
 |  | array | $options = []
 | ) |  |

Describes an object if supported.

Paramètres
OutputInterface | $output | The output object to use.
object | $object | The object to describe.
array | $options | Options for the descriptor.
Renvoie
void
Depuis
_2.0.0

Références $options, et $output.

◆ getName()

getName ( )

Returns the canonical name of this helper.

Renvoie
string The canonical name
Depuis
_2.0.0

Implémente HelperInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/Helper/DescriptorHelper.php


Joomla CMS: Référence de la classe ContainerLoader

  • Joomla
  • Console
  • Loader
  • ContainerLoader
Fonctions membres publiques | Attributs privés
Référence de la classe ContainerLoader
+ Graphe d'héritage de ContainerLoader:
LoaderInterface

Fonctions membres publiques

__construct (ContainerInterface $container, array $commandMap)
get (string $name)
getNames ()
has ($name)

Attributs privés

$container
$commandMap

Description détaillée

PSR-11 compatible command loader.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ContainerInterface | $container,
 |  | array | $commandMap
 | ) |  |

Constructor.

Paramètres
ContainerInterface | $container | A container from which to load command services.
array | $commandMap | An array with command names as keys and service IDs as values.
Depuis
2.0.0

Références ContainerLoader\$commandMap, et ContainerLoader\$container.

Documentation des fonctions membres

◆ get()

get ( string $name )

Loads a command.

Paramètres
string $name The command to load.
Renvoie
AbstractCommand
Depuis
2.0.0
Exceptions
CommandNotFoundException

Implémente LoaderInterface.

Références $name, et ContainerLoader\has().

◆ getNames()

getNames ( )

Get the names of the registered commands.

Renvoie
string[]
Depuis
2.0.0

Implémente LoaderInterface.

◆ has()

has ( $name )

Checks if a command exists.

Paramètres
string $name The command to check.
Renvoie
boolean
Depuis
2.0.0

Implémente LoaderInterface.

Références $name.

Référencé par ContainerLoader\get().

Documentation des champs

◆ $commandMap

$commandMap
private

Référencé par ContainerLoader\__construct().

◆ $container

$container
private

Référencé par ContainerLoader\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerLoader.php


Joomla CMS: Référence de l'interface LoaderInterface

  • Joomla
  • Console
  • Loader
  • LoaderInterface
Fonctions membres publiques
Référence de l'interface LoaderInterface
+ Graphe d'héritage de LoaderInterface:
WritableLoaderInterface ContainerLoader WritableContainerLoader

Fonctions membres publiques

get (string $name)
getNames ()
has ($name)

Description détaillée

Interface defining a command loader.

Depuis
2.0.0

Documentation des fonctions membres

◆ get()

get ( string $name )

Loads a command.

Paramètres
string $name The command to load.
Renvoie
AbstractCommand
Depuis
2.0.0
Exceptions
CommandNotFoundException

Implémenté dans WritableContainerLoader, et ContainerLoader.

◆ getNames()

getNames ( )

Get the names of the registered commands.

Renvoie
string[]
Depuis
2.0.0

Implémenté dans WritableContainerLoader, et ContainerLoader.

◆ has()

has ( $name )

Checks if a command exists.

Paramètres
string $name The command to check.
Renvoie
boolean
Depuis
2.0.0

Implémenté dans WritableContainerLoader, et ContainerLoader.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LoaderInterface.php


Joomla CMS: Référence de la classe Application

  • Joomla
  • Console
  • Application
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Application
+ Graphe d'héritage de Application:
AbstractApplication ConfigurationAwareApplicationInterface LoggerAwareInterface DispatcherAwareInterface ApplicationInterface ConsoleApplication

Fonctions membres publiques

__construct (?InputInterface $input=null, ?OutputInterface $output=null, ?Registry $config=null)
addCommand (AbstractCommand $command)
execute ()
findNamespace (string $namespace)
getAllCommands (string $namespace='')
getCommands ()
getConsoleInput ()
getConsoleOutput ()
getDefinition ()
getHelperSet ()
getLongVersion ()
getName ()
getNamespaces ()
getVersion ()
hasCommand (string $name)
renderThrowable (\Throwable $throwable)
setAutoExit (bool $autoExit)
setCatchThrowables (bool $catchThrowables)
setCommandLoader (Loader\LoaderInterface $loader)
setHelperSet (HelperSet $helperSet)
setName (string $name)
setVersion (string $version)
shouldAutoExit ()
shouldCatchThrowables ()
- Fonctions membres publiques hérités de AbstractApplication
__construct (Registry $config=null)
close ($code=0)
execute ()
get ($key, $default=null)
getLogger ()
set ($key, $value=null)
setConfiguration (Registry $config)
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

configureIO ()
doExecute ()
getCommandName (InputInterface $input)
getDefaultCommands ()
getDefaultInputDefinition ()
getDefaultHelperSet ()
initialise ()
doRenderThrowable (\Throwable $throwable, OutputInterface $output)
runCommand (AbstractCommand $command, InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractApplication
dispatchEvent (string $eventName, ?EventInterface $event=null)
doExecute ()
initialise ()

Fonctions membres privées

splitStringByWidth (string $string, int $width)
extractAllNamespaces (string $name)
extractNamespace (string $name, ?int $limit=null)
initCommands ()

Attributs privés

$autoExit = true
$catchThrowables = true
$commands = []
$commandLoader
$consoleInput
$consoleOutput
$defaultCommand = 'list'
$definition
$helperSet
$initialised = false
$name = ''
$runningCommand
$terminal
$version = ''
$wantsHelp = false

Membres hérités additionnels

- Attributs protégés hérités de AbstractApplication
$config

Description détaillée

Base application class for a Joomla! command line application.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?InputInterface | $input = null,
 |  | ?OutputInterface | $output = null,
 |  | ?Registry | $config = null
 | ) |  |

Class constructor.

Paramètres
InputInterface | $input | An optional argument to provide dependency injection for the application's input object. If the argument is an InputInterface object that object will become the application's input object, otherwise a default input object is created.
OutputInterface | $output | An optional argument to provide dependency injection for the application's output object. If the argument is an OutputInterface object that object will become the application's output object, otherwise a default output object is created.
Registry | $config | An optional argument to provide dependency injection for the application's config object. If the argument is a Registry object that object will become the application's config object, otherwise a default config object is created.
Depuis
2.0.0

Références AbstractApplication\$config, $input, $output, Symfony\Contracts\Service\__construct(), et AbstractApplication\close().

Documentation des fonctions membres

◆ addCommand()

addCommand ( AbstractCommand $command )

Adds a command object.

If a command with the same name already exists, it will be overridden. If the command is not enabled it will not be added.

Paramètres
AbstractCommand $command The command to add to the application.
Renvoie
AbstractCommand
Depuis
2.0.0
Exceptions
LogicException

Références $this, AbstractCommand\getAliases(), AbstractCommand\getDefinition(), AbstractCommand\getName(), Application\initCommands(), AbstractCommand\isEnabled(), et AbstractCommand\setApplication().

Référencé par Application\initCommands().

◆ configureIO()

configureIO ( )
protected

Configures the console input and output instances for the process.

Renvoie
void
Depuis
2.0.0

Références elseif, OutputInterface\VERBOSITY_DEBUG, OutputInterface\VERBOSITY_QUIET, OutputInterface\VERBOSITY_VERBOSE, et OutputInterface\VERBOSITY_VERY_VERBOSE.

Référencé par Application\execute().

◆ doExecute()

doExecute ( )
protected

Method to run the application routines.

Renvoie
integer The exit code for the application
Depuis
2.0.0
Exceptions

Références Application\$consoleInput, Application\$consoleOutput, Application\$defaultCommand, Application\$definition, $input, Application\$name, $output, $this, block, ConsoleEvents\COMMAND_ERROR, AbstractApplication\dispatchEvent(), Application\getCommandName(), Application\getDefinition(), Application\getLongVersion(), null, InputArgument\OPTIONAL, et Application\runCommand().

Référencé par Application\execute().

◆ doRenderThrowable()

doRenderThrowable | ( | \Throwable | $throwable,
 |  | OutputInterface | $output
 | ) |  |
protected

Handles recursively rendering error messages for a Throwable and all previous Throwables contained within.

Paramètres
\Throwable | $throwable | The Throwable object to render the message for.
OutputInterface | $output | The output object to send the message to.
Renvoie
void
Depuis
2.0.0

Références $class, $count, $function, $i, $message, $messages, $output, $title, $type, $width, OutputFormatter\escape(), Application\splitStringByWidth(), StringHelper\strlen(), et OutputInterface\VERBOSITY_QUIET.

Référencé par Application\renderThrowable().

◆ execute()

execute ( )

Execute the application.

Renvoie
void
Depuis
2.0.0
Exceptions

Implémente ApplicationInterface.

Références $errorHandler, $this, ApplicationEvents\AFTER_EXECUTE, ConsoleEvents\APPLICATION_ERROR, ApplicationEvents\BEFORE_EXECUTE, AbstractApplication\close(), Application\configureIO(), AbstractApplication\dispatchEvent(), Application\doExecute(), elseif, null, Application\renderThrowable(), Application\shouldAutoExit(), et Application\shouldCatchThrowables().

◆ extractAllNamespaces()

extractAllNamespaces ( string $name )
private

Returns all namespaces of the command name.

Paramètres
string $name The full name of the command
Renvoie
string[]
Depuis
2.0.0

Références Application\$name, et $parts.

Référencé par Application\getNamespaces().

◆ extractNamespace()

extractNamespace | ( | string | $name,
 |  | ?int | $limit = null
 | ) |  |
private

Returns the namespace part of the command name.

Paramètres
string | $name | The command name to process
integer | $limit | The maximum number of parts of the namespace
Renvoie
string
Depuis
2.0.0

Références $limit, Application\$name, $parts, et null.

Référencé par Application\getAllCommands().

◆ findNamespace()

findNamespace ( string $namespace )

Finds a registered namespace by a name.

Paramètres
string $namespace A namespace to search for
Renvoie
string
Depuis
2.0.0
Exceptions
NamespaceNotFoundException When namespace is incorrect or ambiguous

Références $namespace, et Application\getNamespaces().

◆ getAllCommands()

getAllCommands ( string $namespace = '' )

Gets all commands, including those available through a command loader, optionally filtered on a command namespace.

Paramètres
string $namespace An optional command namespace to filter by.
Renvoie
AbstractCommand[]
Depuis
2.0.0

Références Application\$commands, Application\$name, $namespace, Application\extractNamespace(), et Application\initCommands().

Référencé par Application\getNamespaces().

◆ getCommandName()

getCommandName ( InputInterface $input )
protected

Get the name of the command to run.

Paramètres
InputInterface $input The input to read the argument from
Renvoie
string|null
Depuis
2.0.0

Références $input.

Référencé par Application\doExecute().

◆ getCommands()

getCommands ( )

Get the registered commands.

This method only retrieves commands which have been explicitly registered. To get all commands including those from a command loader, use the getAllCommands() method.

Renvoie
AbstractCommand[]
Depuis
2.0.0

Références Application\$commands.

◆ getConsoleInput()

getConsoleInput ( )

Get the console input handler.

Renvoie
InputInterface
Depuis
2.0.0

Références Application\$consoleInput.

◆ getConsoleOutput()

getConsoleOutput ( )

Get the console output handler.

Renvoie
OutputInterface
Depuis
2.0.0

Références Application\$consoleOutput.

◆ getDefaultCommands()

getDefaultCommands ( )
protected

Get the commands which should be registered by default to the application.

Renvoie
AbstractCommand[]
Depuis
2.0.0

Référencé par Application\initCommands().

◆ getDefaultHelperSet()

getDefaultHelperSet ( )
protected

Builds the default helper set.

Renvoie
HelperSet
Depuis
2.0.0

Référencé par Application\getHelperSet().

◆ getDefaultInputDefinition()

getDefaultInputDefinition ( )
protected

Builds the default input definition.

Renvoie
InputDefinition
Depuis
2.0.0

Références InputArgument\REQUIRED, et InputOption\VALUE_NONE.

Référencé par Application\getDefinition().

◆ getDefinition()

getDefinition ( )

Gets the InputDefinition related to this Application.

Renvoie
InputDefinition
Depuis
2.0.0

Références Application\$definition, et Application\getDefaultInputDefinition().

Référencé par Application\doExecute().

◆ getHelperSet()

getHelperSet ( )

Get the helper set associated with the application.

Renvoie
HelperSet

Références Application\$helperSet, et Application\getDefaultHelperSet().

◆ getLongVersion()

getLongVersion ( )

Get the long version string for the application.

Typically, this is the application name and version and is used in the application help output.

Renvoie
string
Depuis
2.0.0

Références Application\$name, Application\getName(), et Application\getVersion().

Référencé par Application\doExecute().

◆ getName()

getName ( )

Get the name of the application.

Renvoie
string
Depuis
2.0.0

Références Application\$name.

Référencé par Application\getLongVersion(), et Application\renderThrowable().

◆ getNamespaces()

getNamespaces ( )

Returns an array of all unique namespaces used by currently registered commands.

Note that this does not include the global namespace which always exists.

Renvoie
string[]
Depuis
2.0.0

Références Application\extractAllNamespaces(), et Application\getAllCommands().

Référencé par Application\findNamespace().

◆ getVersion()

getVersion ( )

Get the version of the application.

Renvoie
string
Depuis
2.0.0

Références Application\$version.

Référencé par Application\getLongVersion().

◆ hasCommand()

hasCommand ( string $name )

Check if the application has a command with the given name.

Paramètres
string $name The name of the command to check for existence.
Renvoie
boolean
Depuis
2.0.0

Références Application\$name, et Application\initCommands().

◆ initCommands()

initCommands ( )
private

Internal function to initialise the command store, this allows the store to be lazy loaded only when needed.

Renvoie
void
Depuis
2.0.0

Références Application\addCommand(), et Application\getDefaultCommands().

Référencé par Application\addCommand(), Application\getAllCommands(), et Application\hasCommand().

◆ initialise()

initialise ( )
protected

Custom initialisation method.

Renvoie
void
Depuis
2.0.0

◆ renderThrowable()

renderThrowable ( \Throwable $throwable )

Renders an error message for a Throwable object

Paramètres
\Throwable $throwable The Throwable object to render the message for.
Renvoie
void
Depuis
2.0.0

Références Application\$consoleOutput, $output, Application\doRenderThrowable(), ConsoleOutputInterface\getErrorOutput(), Application\getName(), null, et OutputInterface\VERBOSITY_QUIET.

Référencé par Application\execute().

◆ runCommand()

runCommand | ( | AbstractCommand | $command,
 |  | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Run the given command.

Paramètres
AbstractCommand | $command | The command to run.
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer
Depuis
2.0.0
Exceptions

Références $helper, $input, $output, $this, ConsoleEvents\BEFORE_COMMAND_EXECUTE, ConsoleEvents\COMMAND_ERROR, AbstractApplication\dispatchEvent(), AbstractCommand\execute(), AbstractCommand\getDefinition(), Joomla\CMS\Application\getDispatcher(), AbstractCommand\getHelperSet(), AbstractCommand\mergeApplicationDefinition(), null, BeforeCommandExecuteEvent\RETURN_CODE_DISABLED, et ConsoleEvents\TERMINATE.

Référencé par Application\doExecute().

◆ setAutoExit()

setAutoExit ( bool $autoExit )

Set whether the application should auto exit.

Paramètres
boolean $autoExit The auto exit state.
Renvoie
void
Depuis
2.0.0

Références Application\$autoExit.

◆ setCatchThrowables()

setCatchThrowables ( bool $catchThrowables )

Set whether the application should catch Throwables.

Paramètres
boolean $catchThrowables The catch Throwables state.
Renvoie
void
Depuis
2.0.0

Références Application\$catchThrowables.

◆ setCommandLoader()

setCommandLoader ( Loader\LoaderInterface $loader )

Set the command loader.

Paramètres
Loader\LoaderInterface $loader The new command loader.
Renvoie
void
Depuis
2.0.0

Références $loader.

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet )

Set the application's helper set.

Paramètres
HelperSet $helperSet The new HelperSet.
Renvoie
void
Depuis
2.0.0

Références Application\$helperSet.

◆ setName()

setName ( string $name )

Set the name of the application.

Paramètres
string $name The new application name.
Renvoie
void
Depuis
2.0.0

Références Application\$name, et name.

◆ setVersion()

setVersion ( string $version )

Set the version of the application.

Paramètres
string $version The new application version.
Renvoie
void
Depuis
2.0.0

Références Application\$version.

◆ shouldAutoExit()

shouldAutoExit ( )

Get the application's auto exit state.

Renvoie
boolean
Depuis
2.0.0

Références Application\$autoExit.

Référencé par Application\execute().

◆ shouldCatchThrowables()

shouldCatchThrowables ( )

Get the application's catch Throwables state.

Renvoie
boolean
Depuis
2.0.0

Références Application\$catchThrowables.

Référencé par Application\execute().

◆ splitStringByWidth()

splitStringByWidth | ( | string | $string,
 |  | int | $width
 | ) |  |
private

Splits a string for a specified width for use in an output.

Paramètres
string | $string | The string to split.
integer | $width | The maximum width of the output.
Renvoie
string[]
Depuis
2.0.0

Références Joomla\Database\Query\$offset, $width, et null.

Référencé par Application\doRenderThrowable().

Documentation des champs

◆ $autoExit

$autoExit = true
private

Référencé par Application\setAutoExit(), et Application\shouldAutoExit().

◆ $catchThrowables

$catchThrowables = true
private

Référencé par Application\setCatchThrowables(), et Application\shouldCatchThrowables().

◆ $commandLoader

$commandLoader
private

◆ $commands

$commands = []
private

Référencé par Application\getAllCommands(), et Application\getCommands().

◆ $consoleInput

$consoleInput
private

Référencé par Application\doExecute(), et Application\getConsoleInput().

◆ $consoleOutput

$consoleOutput
private

Référencé par Application\doExecute(), Application\getConsoleOutput(), et Application\renderThrowable().

◆ $defaultCommand

$defaultCommand = 'list'
private

Référencé par Application\doExecute().

◆ $definition

$definition
private

Référencé par Application\doExecute(), et Application\getDefinition().

◆ $helperSet

$helperSet
private

Référencé par Application\getHelperSet(), et Application\setHelperSet().

◆ $initialised

$initialised = false
private

◆ $name

$name = ''
private

Référencé par Application\doExecute(), Application\extractAllNamespaces(), Application\extractNamespace(), Application\getAllCommands(), Application\getLongVersion(), Application\getName(), Application\hasCommand(), et Application\setName().

◆ $runningCommand

$runningCommand
private

◆ $terminal

$terminal
private

◆ $version

$version = ''
private

Référencé par Application\getVersion(), et Application\setVersion().

◆ $wantsHelp

$wantsHelp = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/console/src/Application.php


Joomla CMS: Référence de la classe ConsoleEvents

  • Joomla
  • Console
  • ConsoleEvents
Champs de données
Référence de la classe ConsoleEvents

Champs de données

const | APPLICATION_ERROR = 'console.application_error'
const | BEFORE_COMMAND_EXECUTE = 'console.before_command_execute'
const | COMMAND_ERROR = 'console.command_error'
const | TERMINATE = 'console.terminate'

Description détaillée

Class defining the events available in the console application.

Depuis
2.0.0

Documentation des champs

◆ APPLICATION_ERROR

const APPLICATION_ERROR = 'console.application_error'

Référencé par ApplicationErrorEvent\__construct(), et Application\execute().

◆ BEFORE_COMMAND_EXECUTE

const BEFORE_COMMAND_EXECUTE = 'console.before_command_execute'

Référencé par BeforeCommandExecuteEvent\__construct(), et Application\runCommand().

◆ COMMAND_ERROR

const COMMAND_ERROR = 'console.command_error'

Référencé par CommandErrorEvent\__construct(), Application\doExecute(), et Application\runCommand().

◆ TERMINATE

const TERMINATE = 'console.terminate'

Référencé par TerminateEvent\__construct(), et Application\runCommand().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/console/src/ConsoleEvents.php


Joomla CMS: Référence de la classe Crypto

  • Joomla
  • Crypt
  • Cipher
  • Crypto
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe Crypto
+ Graphe d'héritage de Crypto:
CipherInterface

Fonctions membres publiques

decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=[])

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Joomla cipher for encryption, decryption and key generation via the php-encryption library.

Depuis
2.0.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
2.0.0
Exceptions
DecryptionException | if the data cannot be decrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, et $key.

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
2.0.0
Exceptions
EncryptionException | if the data cannot be encrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, et $key.

◆ generateKey()

generateKey ( array $options = [] )

Method to generate a new encryption key object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
2.0.0
Exceptions
InvalidKeyException if the key cannot be generated

Implémente CipherInterface.

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
2.0.0

Implémente CipherInterface.

Références RuntimeTests\runtimeTest().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/crypt/src/Cipher/Crypto.php


Joomla CMS: Référence de la classe OpenSSL

  • Joomla
  • Crypt
  • Cipher
  • OpenSSL
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe OpenSSL
+ Graphe d'héritage de OpenSSL:
CipherInterface

Fonctions membres publiques

__construct (string $iv, string $method)
decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=[])

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$iv
$method

Description détaillée

Joomla cipher for encryption, decryption and key generation via the openssl extension.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $iv,
 |  | string | $method
 | ) |  |

Instantiate the cipher.

Paramètres
string | $iv | The initialisation vector to use
string | $method | The encryption method to use
Depuis
2.0.0

Références OpenSSL\$iv, OpenSSL\$method, et method.

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
2.0.0
Exceptions
DecryptionException | if the data cannot be decrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, OpenSSL\$iv, $key, Key\getPrivate(), et method.

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
2.0.0
Exceptions
EncryptionException | if the data cannot be encrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, OpenSSL\$iv, $key, Key\getPrivate(), et method.

◆ generateKey()

generateKey ( array $options = [] )

Method to generate a new encryption key object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
2.0.0
Exceptions
InvalidKeyException if the key cannot be generated

Implémente CipherInterface.

Références $options.

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
2.0.0

Implémente CipherInterface.

Documentation des champs

◆ $iv

$iv
private

Référencé par OpenSSL\__construct(), OpenSSL\decrypt(), et OpenSSL\encrypt().

◆ $method

$method
private

Référencé par OpenSSL\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/crypt/src/Cipher/OpenSSL.php


Joomla CMS: Référence de la classe Sodium

  • Joomla
  • Crypt
  • Cipher
  • Sodium
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Sodium
+ Graphe d'héritage de Sodium:
CipherInterface

Fonctions membres publiques

decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=[])
setNonce ($nonce)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$nonce

Description détaillée

Cipher for sodium algorithm encryption, decryption and key generation.

Depuis
1.4.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
1.4.0
Exceptions
DecryptionException | if the data cannot be decrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, $key, et class.

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
1.4.0
Exceptions
EncryptionException | if the data cannot be encrypted
InvalidKeyTypeException | if the key is not valid for the cipher

Implémente CipherInterface.

Références $data, $key, et class.

◆ generateKey()

generateKey ( array $options = [] )

Method to generate a new encryption key object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
1.4.0
Exceptions
InvalidKeyException | if the key cannot be generated
UnsupportedCipherException | if the cipher is not supported on the current environment

Implémente CipherInterface.

Références class.

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
2.0.0

Implémente CipherInterface.

Références class.

◆ setNonce()

setNonce ( $nonce )

Set the nonce to use for encrypting/decrypting messages

Paramètres
string $nonce The message nonce
Renvoie
void
Depuis
1.4.0

Références Sodium\$nonce.

Documentation des champs

◆ $nonce

$nonce
private

Référencé par Sodium\setNonce().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Sodium.php


Joomla CMS: Référence de l'interface CryptExceptionInterface

  • Joomla
  • Crypt
  • Exception
  • CryptExceptionInterface
Référence de l'interface CryptExceptionInterface
+ Graphe d'héritage de CryptExceptionInterface:
DecryptionException EncryptionException InvalidKeyException InvalidKeyTypeException UnsupportedCipherException

Description détaillée

Interface defining all crypt package exceptions

Depuis
2.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • CryptExceptionInterface.php


Joomla CMS: Référence de la classe DecryptionException

  • Joomla
  • Crypt
  • Exception
  • DecryptionException
Référence de la classe DecryptionException
+ Graphe d'héritage de DecryptionException:
CryptExceptionInterface

Description détaillée

Exception representing an error decrypting data

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DecryptionException.php


Joomla CMS: Référence de la classe EncryptionException

  • Joomla
  • Crypt
  • Exception
  • EncryptionException
Référence de la classe EncryptionException
+ Graphe d'héritage de EncryptionException:
CryptExceptionInterface

Description détaillée

Exception representing an error encrypting data

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • EncryptionException.php


Joomla CMS: Référence de la classe InvalidKeyException

  • Joomla
  • Crypt
  • Exception
  • InvalidKeyException
Référence de la classe InvalidKeyException
+ Graphe d'héritage de InvalidKeyException:
CryptExceptionInterface

Description détaillée

Exception representing an error generating an encryption key

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidKeyException.php


Joomla CMS: Référence de la classe InvalidKeyTypeException

  • Joomla
  • Crypt
  • Exception
  • InvalidKeyTypeException
Fonctions membres publiques
Référence de la classe InvalidKeyTypeException
+ Graphe d'héritage de InvalidKeyTypeException:
CryptExceptionInterface

Fonctions membres publiques

__construct ($expectedKeyType, $actualKeyType)

Description détaillée

Exception representing an invalid Joomla type for a cipher

Depuis
1.4.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $expectedKeyType,
 |  | $actualKeyType
 | ) |

InvalidKeyTypeException constructor.

Paramètres
string | $expectedKeyType | The expected key type.
string | $actualKeyType | The actual key type.
Depuis
1.4.0

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidKeyTypeException.php


Joomla CMS: Référence de la classe UnsupportedCipherException

  • Joomla
  • Crypt
  • Exception
  • UnsupportedCipherException
Fonctions membres publiques
Référence de la classe UnsupportedCipherException
+ Graphe d'héritage de UnsupportedCipherException:
CryptExceptionInterface

Fonctions membres publiques

__construct (string $class)

Description détaillée

Exception representing an error encrypting data

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $class )

UnsupportedCipherException constructor.

Paramètres
string $class The class name of the unsupported cipher.
Depuis
2.0.0

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedCipherException.php


Joomla CMS: Référence de l'interface CipherInterface

  • Joomla
  • Crypt
  • CipherInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface CipherInterface
+ Graphe d'héritage de CipherInterface:
CryptoCipher SodiumCipher Crypto OpenSSL Sodium

Fonctions membres publiques

decrypt ($data, Key $key)
encrypt ($data, Key $key)
generateKey (array $options=[])

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Joomla Framework Cipher interface.

Depuis
1.0

Documentation des fonctions membres

◆ decrypt()

decrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to decrypt a data string.

Paramètres
string | $data | The encrypted string to decrypt.
Key | $key | The key[/pair] object to use for decryption.
Renvoie
string The decrypted data string.
Depuis
1.0
Exceptions
DecryptionException | if the data cannot be decrypted
InvalidKeyTypeException | if the key is not valid for the cipher
UnsupportedCipherException | if the cipher is not supported on the current environment

Implémenté dans OpenSSL, Sodium, SodiumCipher, Crypto, et CryptoCipher.

◆ encrypt()

encrypt | ( |  | $data,
 |  | Key | $key
 | ) |  |

Method to encrypt a data string.

Paramètres
string | $data | The data string to encrypt.
Key | $key | The key[/pair] object to use for encryption.
Renvoie
string The encrypted data string.
Depuis
1.0
Exceptions
EncryptionException | if the data cannot be encrypted
InvalidKeyTypeException | if the key is not valid for the cipher
UnsupportedCipherException | if the cipher is not supported on the current environment

Implémenté dans Sodium, OpenSSL, SodiumCipher, Crypto, et CryptoCipher.

◆ generateKey()

generateKey ( array $options = [] )

Method to generate a new encryption key[/pair] object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
1.0
Exceptions
InvalidKeyException | if the key cannot be generated
UnsupportedCipherException | if the cipher is not supported on the current environment

Implémenté dans Sodium, OpenSSL, SodiumCipher, Crypto, et CryptoCipher.

◆ isSupported()

static isSupported ( )
static

Check if the cipher is supported in this environment.

Renvoie
boolean
Depuis
2.0.0

Implémenté dans Sodium, OpenSSL, Crypto, SodiumCipher, et CryptoCipher.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CipherInterface.php


Joomla CMS: Référence de la classe Crypt

  • Joomla
  • Crypt
  • Crypt
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Crypt
+ Graphe d'héritage de Crypt:
Crypt

Fonctions membres publiques

__construct (?CipherInterface $cipher=null, ?Key $key=null)
decrypt ($data)
encrypt ($data)
generateKey (array $options=[])
setKey (Key $key)

Fonctions membres publiques statiques

static genRandomBytes ($length=16)

Attributs privés

$cipher
$key

Description détaillée

Crypt is a Joomla Framework class for handling basic encryption/decryption of data.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?CipherInterface | $cipher = null,
 |  | ?Key | $key = null
 | ) |  |

Object Constructor takes an optional key to be used for encryption/decryption. If no key is given then the secret word from the configuration object is used.

Paramètres
CipherInterface | $cipher | The encryption cipher object.
Key | $key | The encryption key[/pair)].
Depuis
1.0

Références Crypt\$cipher, Crypt\$key, et Crypt\generateKey().

Documentation des fonctions membres

◆ decrypt()

decrypt ( $data )

Method to decrypt a data string.

Paramètres
string $data The encrypted string to decrypt.
Renvoie
string The decrypted data string.
Depuis
1.0
Exceptions
DecryptionException | if the data cannot be decrypted
InvalidKeyTypeException | if the key is not valid for the cipher
UnsupportedCipherException | if the cipher is not supported on the current environment

Références $data.

◆ encrypt()

encrypt ( $data )

Method to encrypt a data string.

Paramètres
string $data The data string to encrypt.
Renvoie
string The encrypted data string.
Depuis
1.0
Exceptions
EncryptionException | if the data cannot be encrypted
InvalidKeyTypeException | if the key is not valid for the cipher
UnsupportedCipherException | if the cipher is not supported on the current environment

Références $data.

◆ generateKey()

generateKey ( array $options = [] )

Method to generate a new encryption key[/pair] object.

Paramètres
array $options Key generation options.
Renvoie
Key
Depuis
1.0
Exceptions
InvalidKeyException | if the key cannot be generated
UnsupportedCipherException | if the cipher is not supported on the current environment

Références $options.

Référencé par Crypt\__construct().

◆ genRandomBytes()

static genRandomBytes ( $length = 16 )
static

Generate random bytes.

Paramètres
integer $length Length of the random data to generate
Renvoie
string Random binary data
Depuis
1.0

Référencé par UserHelper\genRandomPassword(), PlgUserToken\getDefaultProfileFieldValues(), et Path\isOwner().

◆ setKey()

setKey ( Key $key )

Method to set the encryption key[/pair] object.

Paramètres
Key $key The key object to set.
Renvoie
Crypt Instance of $this to allow chaining.
Depuis
1.0

Références Crypt\$key, et $this.

Documentation des champs

◆ $cipher

$cipher
private

Référencé par Crypt\__construct().

◆ $key

$key
private

Référencé par Crypt\__construct(), et Crypt\setKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/crypt/src/Crypt.php


Joomla CMS: Référence de la classe Key

  • Joomla
  • Crypt
  • Key
Fonctions membres publiques | Attributs privés
Référence de la classe Key

Fonctions membres publiques

__construct (string $type, string $private, string $public)
getPrivate ()
getPublic ()
getType ()

Attributs privés

$private
$public
$type

Description détaillée

Encryption key object for the Joomla Framework.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $type,
 |  | string | $private,
 |  | string | $public
 | ) |  |

Constructor.

Paramètres
string | $type | The key type.
string | $private | The private key.
string | $public | The public key.
Depuis
1.0

Références Key\$private, Key\$public, et Key\$type.

Documentation des fonctions membres

◆ getPrivate()

getPrivate ( )

Retrieve the private key

Renvoie
string
Depuis
2.0.0

Références Key\$private.

Référencé par OpenSSL\decrypt(), et OpenSSL\encrypt().

◆ getPublic()

getPublic ( )

Retrieve the public key

Renvoie
string
Depuis
2.0.0

Références Key\$public.

◆ getType()

getType ( )

Retrieve the key type

Renvoie
string
Depuis
2.0.0

Références Key\$type.

Documentation des champs

◆ $private

$private
private

Référencé par Key\__construct(), et Key\getPrivate().

◆ $public

$public
private

Référencé par Key\__construct(), et Key\getPublic().

◆ $type

$type
private

Référencé par Key\__construct(), et Key\getType().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/crypt/src/Key.php


Joomla CMS: Référence de la classe DataObject

  • Joomla
  • Data
  • DataObject
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe DataObject
+ Graphe d'héritage de DataObject:
DumpableInterface

Fonctions membres publiques

__construct ($properties=[])
__get ($property)
__isset ($property)
__set ($property, $value)
__unset ($property)
bind ($properties, $updateNulls=true)
dump ($depth=3, \SplObjectStorage $dumped=null)
getIterator ()
jsonSerialize ()
count ()

Fonctions membres protégées

dumpProperty ($property, $depth, \SplObjectStorage $dumped)
getProperty ($property)
setProperty ($property, $value)

Attributs privés

$properties = []

Description détaillée

DataObject is a class that is used to store data but allowing you to access the data by mimicking the way PHP handles class properties.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $properties = [] )

The class constructor.

Paramètres
mixed $properties Either an associative array or another object by which to set the initial properties of the new object.
Depuis
1.0
Exceptions

Références DataObject\$properties, et DataObject\bind().

Documentation des fonctions membres

◆ __get()

__get ( $property )

The magic get method is used to get a data property.

This method is a public proxy for the protected getProperty method.

Note: Magic __get does not allow recursive calls. This can be tricky because the error generated by recursing into __get is "Undefined property: {CLASS}::{PROPERTY}" which is misleading. This is relevant for this class because requesting a non-visible property can trigger a call to a sub-function. If that references the property directly in the object, it will cause a recursion into __get.

Paramètres
string $property The name of the data property.
Renvoie
mixed The value of the data property, or null if the data property does not exist.
Voir également
DataObject::getProperty()
Depuis
1.0

Références DataObject\getProperty().

◆ __isset()

__isset ( $property )

The magic isset method is used to check the state of an object property.

Paramètres
string $property The name of the data property.
Renvoie
boolean
Depuis
1.0

◆ __set()

__set | ( | $property,
 |  | $value
 | ) |

The magic set method is used to set a data property.

This is a public proxy for the protected setProperty method.

Paramètres
string | $property | The name of the data property.
mixed | $value | The value to give the data property.
Renvoie
void
Voir également
DataObject::setProperty()
Depuis
1.0

Références $value, et DataObject\setProperty().

◆ __unset()

__unset ( $property )

The magic unset method is used to unset a data property.

Paramètres
string $property The name of the data property.
Renvoie
void
Depuis
1.0

◆ bind()

bind | ( | $properties,
 |  | $updateNulls = true
 | ) |

Binds an array or object to this object.

Paramètres
mixed | $properties | An associative array of properties or an object.
boolean | $updateNulls | True to bind null values, false to ignore null values.
Renvoie
$this
Depuis
1.0
Exceptions

Références DataObject\$properties, $this, $value, elseif, null, et DataObject\setProperty().

Référencé par DataObject\__construct().

◆ count()

count ( )

Count the number of data properties.

Renvoie
integer The number of data properties.
Depuis
1.0

◆ dump()

dump | ( |  | $depth = 3,
 |  | \SplObjectStorage | $dumped = null
 | ) |  |

Dumps the data properties into an object, recursively if appropriate.

Paramètres
integer | $depth | The maximum depth of recursion (default = 3). For example, a depth of 0 will return a stdClass with all the properties in native form. A depth of 1 will recurse into the first level of properties only.
\SplObjectStorage | $dumped | An array of already serialized objects that is used to avoid infinite loops.
Renvoie
Depuis
1.0

Implémente DumpableInterface.

Références $this, DataObject\dumpProperty(), et null.

Référencé par DataObject\getIterator(), et DataObject\jsonSerialize().

◆ dumpProperty()

dumpProperty | ( |  | $property,
 |  |  | $depth,
 |  | \SplObjectStorage | $dumped
 | ) |  |
protected

Dumps a data property.

If recursion is set, this method will dump any object implementing DumpableInterface (like DataObject and DataSet); it will convert a DateTimeInterface object to a string; and it will convert a Joomla to an object.

Paramètres
string | $property | The name of the data property.
integer | $depth | The current depth of recursion (a value of 0 will ignore recursion).
\SplObjectStorage | $dumped | An array of already serialized objects that is used to avoid infinite loops.
Renvoie
mixed The value of the dumped property.
Depuis
1.0

Références $value, elseif, et DataObject\getProperty().

Référencé par DataObject\dump().

◆ getIterator()

getIterator ( )

Gets this object represented as an ArrayIterator.

This allows the data properties to be access via a foreach statement.

Renvoie
Voir également
IteratorAggregate::getIterator()
Depuis
1.0

Références DataObject\dump().

◆ getProperty()

getProperty ( $property )
protected

Gets a data property.

Paramètres
string $property The name of the data property.
Renvoie
mixed The value of the data property.
Voir également
DataObject::__get()
Depuis
1.0

Références null.

Référencé par DataObject\__get(), et DataObject\dumpProperty().

◆ jsonSerialize()

jsonSerialize ( )

Gets the data properties in a form that can be serialised to JSON format.

Renvoie
string
Depuis
1.0

Références DataObject\dump().

◆ setProperty()

setProperty | ( | $property,
 |  | $value
 | ) |
protected

Sets a data property.

If the name of the property starts with a null byte, this method will return null.

Paramètres
string | $property | The name of the data property.
mixed | $value | The value to give the data property.
Renvoie
mixed The value of the data property.
Voir également
DataObject::__set()
Depuis
1.0

Références $value.

Référencé par DataObject\__set(), et DataObject\bind().

Documentation des champs

◆ $properties

$properties = []
private

Référencé par DataObject\__construct(), et DataObject\bind().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DataObject.php


Joomla CMS: Référence de la classe DataSet

  • Joomla
  • Data
  • DataSet
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe DataSet
+ Graphe d'héritage de DataSet:
DumpableInterface

Fonctions membres publiques

__construct (array $objects=[])
__call ($method, $arguments=[])
__get ($property)
__isset ($property)
__set ($property, $value)
__unset ($property)
getObjectsKeys ($type='all')
toArray ($associative=true,... $keys)
count ()
clear ()
current ()
dump ($depth=3, \SplObjectStorage $dumped=null)
jsonSerialize ()
key ()
keys ()
walk (callable $funcname)
next ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $object)
offsetUnset ($offset)
rewind ()
valid ()

Fonctions membres privées

initialise (array $input=[])

Attributs privés

$current = false
$objects = []

Description détaillée

DataSet is a collection class that allows the developer to operate on a set of DataObjects as if they were in a typical PHP array.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $objects = [] )

The class constructor.

Paramètres
DataObject[] $objects An array of DataObject objects to bind to the data set.
Depuis
1.0
Exceptions

Références DataSet\$objects, et DataSet\initialise().

Documentation des fonctions membres

◆ __call()

__call | ( | $method,
 |  | $arguments = []
 | ) |

The magic call method is used to call object methods using the iterator.

Example: $array = $objectList->foo('bar');

The object list will iterate over its objects and see if each object has a callable 'foo' method. If so, it will pass the argument list and assemble any return values. If an object does not have a callable method no return value is recorded. The keys of the objects and the result array are maintained.

Paramètres
string | $method | The name of the method called.
array | $arguments | The arguments of the method called.
Renvoie
array An array of values returned by the methods called on the objects in the data set.
Depuis
1.0

Références $key, $method, et $return.

◆ __get()

__get ( $property )

The magic get method is used to get a list of properties from the objects in the data set.

Example: $array = $dataSet->foo;

This will return a column of the values of the 'foo' property in all the objects (or values determined by custom property setters in the individual DataObject's). The result array will contain an entry for each object in the list (compared to __call which may not). The keys of the objects and the result array are maintained.

Paramètres
string $property The name of the data property.
Renvoie
array An associative array of the values.
Depuis
1.0

Références $key, et $return.

◆ __isset()

__isset ( $property )

The magic isset method is used to check the state of an object property using the iterator.

Example: $array = isset($objectList->foo);

Paramètres
string $property The name of the property.
Renvoie
boolean True if the property is set in any of the objects in the data set.
Depuis
1.0

Références $return.

◆ __set()

__set | ( | $property,
 |  | $value
 | ) |

The magic set method is used to set an object property using the iterator.

Example: $objectList->foo = 'bar';

This will set the 'foo' property to 'bar' in all of the objects (or a value determined by custom property setters in the DataObject).

Paramètres
string | $property | The name of the property.
mixed | $value | The value to give the data property.
Renvoie
void
Depuis
1.0

Références $value.

◆ __unset()

__unset ( $property )

The magic unset method is used to unset an object property using the iterator.

Example: unset($objectList->foo);

This will unset all of the 'foo' properties in the list of DataObject's.

Paramètres
string $property The name of the property.
Renvoie
void
Depuis
1.0

◆ clear()

clear ( )

Clears the objects in the data set.

Renvoie
DataSet Returns itself to allow chaining.
Depuis
1.0

Références $this, et DataSet\rewind().

◆ count()

count ( )

Gets the number of data objects in the set.

Renvoie
integer The number of objects.
Depuis
1.0

◆ current()

current ( )

Get the current data object in the set.

Renvoie
DataObject|false The current object, or false if the array is empty or the pointer is beyond the end of the elements.
Depuis
1.0

Références DataSet\$current.

◆ dump()

dump | ( |  | $depth = 3,
 |  | \SplObjectStorage | $dumped = null
 | ) |  |

Dumps the data object in the set, recursively if appropriate.

Paramètres
integer | $depth | The maximum depth of recursion (default = 3). For example, a depth of 0 will return a stdClass with all the properties in native form. A depth of 1 will recurse into the first level of properties only.
\SplObjectStorage | $dumped | An array of already serialized objects that is used to avoid infinite loops.
Renvoie
array An associative array of the data objects in the set, dumped as a simple PHP stdClass object.
Voir également
DataObject::dump()
Depuis
1.0

Implémente DumpableInterface.

Références $key, DataSet\$objects, $this, et null.

◆ getObjectsKeys()

getObjectsKeys ( $type = 'all' )

Gets an array of keys, existing in objects

Paramètres
string $type Selection type 'all' or 'common'
Renvoie
array Array of keys
Depuis
1.2.0
Exceptions

Références $function, $type, elseif, et null.

Référencé par DataSet\toArray().

◆ initialise()

initialise ( array $input = [] )
private

Initialises the list with an array of objects.

Paramètres
array $input An array of objects.
Renvoie
void
Depuis
1.0
Exceptions

Références $input, $key, $this, null, et DataSet\rewind().

Référencé par DataSet\__construct().

◆ jsonSerialize()

jsonSerialize ( )

Gets the data set in a form that can be serialised to JSON format.

Note that this method will not return an associative array, otherwise it would be encoded into an object. JSON decoders do not consistently maintain the order of associative keys, whereas they do maintain the order of arrays.

Renvoie
array
Depuis
1.0

Références $return.

◆ key()

key ( )

Gets the key of the current object in the iterator.

Renvoie
integer|false The object key on success; false on failure.
Depuis
1.0

Références DataSet\$current.

◆ keys()

keys ( )

Gets the array of keys for all the objects in the iterator (emulates array_keys).

Renvoie
array The array of keys
Depuis
1.0

Référencé par DataSet\next(), DataSet\offsetUnset(), et DataSet\rewind().

◆ next()

next ( )

Advances the iterator to the next object in the iterator.

Renvoie
void
Depuis
1.0

Références $position, DataSet\keys(), et null.

◆ offsetExists()

offsetExists ( $offset )

Checks whether an offset exists in the iterator.

Paramètres
mixed $offset The object offset.
Renvoie
boolean
Depuis
1.0

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Gets an offset in the iterator.

Paramètres
mixed $offset The object offset.
Renvoie
DataObject|null
Depuis
1.0

Références Joomla\Database\Query\$offset, et null.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $object
 | ) |

Sets an offset in the iterator.

Paramètres
mixed | $offset | The object offset.
DataObject | $object | The object object.
Renvoie
void
Depuis
1.0
Exceptions

Références Joomla\Database\Query\$offset, class, et null.

◆ offsetUnset()

offsetUnset ( $offset )

Unsets an offset in the iterator.

Paramètres
mixed $offset The object offset.
Renvoie
void
Depuis
1.0

Références Joomla\Database\Query\$offset, $position, $this, et DataSet\keys().

◆ rewind()

rewind ( )

Rewinds the iterator to the first object.

Renvoie
void
Depuis
1.0

Références DataSet\keys().

Référencé par DataSet\clear(), et DataSet\initialise().

◆ toArray()

toArray | ( | $associative = true,
 |  | $keys
 | ) |

Gets all objects as an array

Paramètres
boolean | $associative | Option to set return mode: associative or numeric array.
string | ...$keys Unlimited optional property names to extract from objects.
Renvoie
array Returns an array according to defined options.
Depuis
1.2.0

Références $i, $key, $return, DataSet\getObjectsKeys(), et null.

◆ valid()

valid ( )

Validates the iterator.

Renvoie
boolean
Depuis
1.0

◆ walk()

walk ( callable $funcname )

Applies a function to every object in the set (emulates array_walk).

Paramètres
callable $funcname Callback function.
Renvoie
boolean
Depuis
1.2.0
Exceptions

Références $key.

Documentation des champs

◆ $current

$current = false
private

Référencé par DataSet\current(), et DataSet\key().

◆ $objects

$objects = []
private

Référencé par DataSet\__construct(), et DataSet\dump().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/data/src/DataSet.php


Joomla CMS: Référence de l'interface DumpableInterface

  • Joomla
  • Data
  • DumpableInterface
Fonctions membres publiques
Référence de l'interface DumpableInterface
+ Graphe d'héritage de DumpableInterface:
DataObject DataSet

Fonctions membres publiques

dump ($depth=3, \SplObjectStorage $dumped=null)

Description détaillée

An interface to define if an object is dumpable.

Depuis
1.0

Documentation des fonctions membres

◆ dump()

dump | ( |  | $depth = 3,
 |  | \SplObjectStorage | $dumped = null
 | ) |  |

Dumps the data properties into an object, recursively if appropriate.

Paramètres
integer | $depth | The maximum depth of recursion. For example, a depth of 0 will return a stdClass with all the properties in native form. A depth of 1 will recurse into the first level of properties only.
\SplObjectStorage | $dumped | An array of already serialized objects that is used to avoid infinite loops.
Renvoie
Depuis
1.0

Implémenté dans DataSet, et DataObject.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DumpableInterface.php


Joomla CMS: Référence de la classe ExportCommand

  • Joomla
  • Database
  • Command
  • ExportCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe ExportCommand
+ Graphe d'héritage de ExportCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseDriver $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'database:export'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Attributs privés

$db

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for exporting the database

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Instantiate the command.

Paramètres
DatabaseDriver $db Database connector
Depuis
2.0.0

Références ExportCommand\$db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\addOption(), null, AbstractCommand\setDescription(), InputOption\VALUE_NONE, InputOption\VALUE_OPTIONAL, et InputOption\VALUE_REQUIRED.

Documentation des champs

◆ $db

$db
private

Référencé par ExportCommand\__construct().

◆ $defaultName

$defaultName = 'database:export'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExportCommand.php


Joomla CMS: Référence de la classe ImportCommand

  • Joomla
  • Database
  • Command
  • ImportCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ImportCommand
+ Graphe d'héritage de ImportCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseDriver $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

doExecute (InputInterface $input, OutputInterface $output)
configure ()
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'database:import'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

checkZipFile (string $archive)

Attributs privés

$db

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Console command for importing the database

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseDriver $db )

Instantiate the command.

Paramètres
DatabaseDriver $db Database connector
Depuis
2.0.0

Références ImportCommand\$db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ checkZipFile()

checkZipFile ( string $archive )
private

Checks if the zip file contains database export files

Paramètres
string $archive A zip archive to analyze
Renvoie
void
Depuis
2.0.0
Exceptions

Référencé par ImportCommand\doExecute().

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\addOption(), null, AbstractCommand\setDescription(), InputOption\VALUE_OPTIONAL, et InputOption\VALUE_REQUIRED.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

Références $input, $output, ImportCommand\checkZipFile(), class, Folder\create(), Folder\delete(), Folder\files(), et File\stripExt().

Documentation des champs

◆ $db

$db
private

Référencé par ImportCommand\__construct().

◆ $defaultName

$defaultName = 'database:import'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ImportCommand.php


Joomla CMS: Référence de la classe ConnectionEvent

  • Joomla
  • Database
  • Event
  • ConnectionEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ConnectionEvent
+ Graphe d'héritage de ConnectionEvent:
Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $name, DatabaseInterface $driver)
getDriver ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$driver

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Database connection event

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | DatabaseInterface | $driver
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
DatabaseInterface | $driver | The DatabaseInterface object for this event.
Depuis
2.0.0

Références ConnectionEvent\$driver, AbstractEvent\$name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getDriver()

getDriver ( )

Retrieve the DatabaseInterface object attached to this event.

Renvoie
DatabaseInterface
Depuis
2.0.0

Références ConnectionEvent\$driver.

Référencé par PlgSystemDebug\onAfterDisconnect().

Documentation des champs

◆ $driver

$driver
private

Référencé par ConnectionEvent\__construct(), et ConnectionEvent\getDriver().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionEvent.php


Joomla CMS: Référence de la classe ConnectionFailureException

  • Joomla
  • Database
  • Exception
  • ConnectionFailureException
Fonctions membres publiques
Référence de la classe ConnectionFailureException
+ Graphe d'héritage de ConnectionFailureException:

Fonctions membres publiques

__construct ($message='', $code=0, \Exception $previous=null)

Description détaillée

Exception class defining an error connecting to the database platform

Depuis
1.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = '',
 |  |  | $code = 0,
 |  | \Exception | $previous = null
 | ) |  |

Construct the exception

Paramètres
string | $message | The Exception message to throw. [optional]
integer | $code | The Exception code. [optional]
Exception | $previous | The previous exception used for the exception chaining. [optional]
Depuis
2.0.0

Références $message, Symfony\Contracts\Service\__construct(), et code.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionFailureException.php


Joomla CMS: Référence de la classe DatabaseNotFoundException

  • Joomla
  • Database
  • Exception
  • DatabaseNotFoundException
Référence de la classe DatabaseNotFoundException
+ Graphe d'héritage de DatabaseNotFoundException:

Description détaillée

No database is available.

Depuis
2.1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseNotFoundException.php


Joomla CMS: Référence de la classe ExecutionFailureException

  • Joomla
  • Database
  • Exception
  • ExecutionFailureException
Fonctions membres publiques | Attributs privés
Référence de la classe ExecutionFailureException
+ Graphe d'héritage de ExecutionFailureException:

Fonctions membres publiques

__construct ($query, $message='', $code=0, \Exception $previous=null)
getQuery ()

Attributs privés

$query

Description détaillée

Exception class defining an error executing a statement

Depuis
1.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $query,
 |  |  | $message = '',
 |  |  | $code = 0,
 |  | \Exception | $previous = null
 | ) |  |

Construct the exception

Paramètres
string | $query | The SQL statement that was executed.
string | $message | The Exception message to throw. [optional]
integer | $code | The Exception code. [optional]
Exception | $previous | The previous exception used for the exception chaining. [optional]
Depuis
1.5.0

Références $message, ExecutionFailureException\$query, Symfony\Contracts\Service\__construct(), et code.

Documentation des fonctions membres

◆ getQuery()

getQuery ( )

Get the SQL statement that was executed

Renvoie
string
Depuis
1.5.0

Références ExecutionFailureException\$query.

Documentation des champs

◆ $query

$query
private

Référencé par ExecutionFailureException\__construct(), et ExecutionFailureException\getQuery().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExecutionFailureException.php


Joomla CMS: Référence de la classe PrepareStatementFailureException

  • Joomla
  • Database
  • Exception
  • PrepareStatementFailureException
Fonctions membres publiques
Référence de la classe PrepareStatementFailureException
+ Graphe d'héritage de PrepareStatementFailureException:

Fonctions membres publiques

__construct ($message='', $code=0, \Exception $previous=null)

Description détaillée

Exception class defining an error preparing the SQL statement for execution

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = '',
 |  |  | $code = 0,
 |  | \Exception | $previous = null
 | ) |  |

Construct the exception

Paramètres
string | $message | The Exception message to throw. [optional]
integer | $code | The Exception code. [optional]
Exception | $previous | The previous exception used for the exception chaining. [optional]
Depuis
2.0.0

Références $message, Symfony\Contracts\Service\__construct(), et code.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrepareStatementFailureException.php


Joomla CMS: Référence de la classe QueryTypeAlreadyDefinedException

  • Joomla
  • Database
  • Exception
  • QueryTypeAlreadyDefinedException
Référence de la classe QueryTypeAlreadyDefinedException
+ Graphe d'héritage de QueryTypeAlreadyDefinedException:

Description détaillée

Exception class defining an exception when attempting to change a query type

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • QueryTypeAlreadyDefinedException.php


Joomla CMS: Référence de la classe UnknownTypeException

  • Joomla
  • Database
  • Exception
  • UnknownTypeException
Référence de la classe UnknownTypeException
+ Graphe d'héritage de UnknownTypeException:

Description détaillée

Class representing an unknown type for a given database driver.

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnknownTypeException.php


Joomla CMS: Référence de la classe UnsupportedAdapterException

  • Joomla
  • Database
  • Exception
  • UnsupportedAdapterException
Référence de la classe UnsupportedAdapterException
+ Graphe d'héritage de UnsupportedAdapterException:

Description détaillée

Exception class defining an unsupported database object

Depuis
1.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedAdapterException.php


Joomla CMS: Référence de la classe ChainedMonitor

  • Joomla
  • Database
  • Monitor
  • ChainedMonitor
Fonctions membres publiques | Attributs privés
Référence de la classe ChainedMonitor
+ Graphe d'héritage de ChainedMonitor:
QueryMonitorInterface

Fonctions membres publiques

addMonitor (QueryMonitorInterface $monitor)
startQuery (string $sql, ?array $boundParams=null)
stopQuery ()

Attributs privés

$monitors = []

Description détaillée

Chained query monitor allowing multiple monitors to be executed.

Depuis
2.0.0

Documentation des fonctions membres

◆ addMonitor()

addMonitor ( QueryMonitorInterface $monitor )

Register a monitor to the chain.

Paramètres
QueryMonitorInterface $monitor The monitor to add.
Renvoie
void
Depuis
2.0.0

◆ startQuery()

startQuery | ( | string | $sql,
 |  | ?array | $boundParams = null
 | ) |  |

Act on a query being started.

Paramètres
string | $sql | The SQL to be executed.
object[]|null | $boundParams List of bound params, used with the query. Each item is an object that holds: value, dataType
Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

Références $sql.

◆ stopQuery()

stopQuery ( )

Act on a query being stopped.

Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

Documentation des champs

◆ $monitors

$monitors = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ChainedMonitor.php


Joomla CMS: Référence de la classe DebugMonitor

  • Joomla
  • Database
  • Monitor
  • DebugMonitor
Fonctions membres publiques | Attributs privés
Référence de la classe DebugMonitor
+ Graphe d'héritage de DebugMonitor:
QueryMonitorInterface

Fonctions membres publiques

startQuery (string $sql, ?array $boundParams=null)
stopQuery ()
getCallStacks ()
getLogs ()
getBoundParams ()
getMemoryLogs ()
getTimings ()

Attributs privés

$callStacks = []
$logs = []
$boundParams = []
$memoryLogs = []
$timings = []

Description détaillée

Query monitor handling logging of queries.

Depuis
2.0.0

Documentation des fonctions membres

◆ getBoundParams()

getBoundParams ( )

Get the logged bound params.

Renvoie
array
Depuis
2.0.0

Références DebugMonitor\$boundParams.

◆ getCallStacks()

getCallStacks ( )

Get the logged call stacks.

Renvoie
array
Depuis
2.0.0

Références DebugMonitor\$callStacks.

◆ getLogs()

getLogs ( )

Get the logged queries.

Renvoie
array
Depuis
2.0.0

Références DebugMonitor\$logs.

◆ getMemoryLogs()

getMemoryLogs ( )

Get the logged memory logs.

Renvoie
array
Depuis
2.0.0

Références DebugMonitor\$memoryLogs.

◆ getTimings()

getTimings ( )

Get the logged timings.

Renvoie
array
Depuis
2.0.0

Références DebugMonitor\$timings.

◆ startQuery()

startQuery | ( | string | $sql,
 |  | ?array | $boundParams = null
 | ) |  |

Act on a query being started.

Paramètres
string | $sql | The SQL to be executed.
object[]|null | $boundParams List of bound params, used with the query. Each item is an object that holds: value, dataType
Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

Références DebugMonitor\$boundParams, et $sql.

◆ stopQuery()

stopQuery ( )

Act on a query being stopped.

Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

Documentation des champs

◆ $boundParams

$boundParams = []
private

Référencé par DebugMonitor\getBoundParams(), et DebugMonitor\startQuery().

◆ $callStacks

$callStacks = []
private

Référencé par DebugMonitor\getCallStacks().

◆ $logs

$logs = []
private

Référencé par DebugMonitor\getLogs().

◆ $memoryLogs

$memoryLogs = []
private

Référencé par DebugMonitor\getMemoryLogs().

◆ $timings

$timings = []
private

Référencé par DebugMonitor\getTimings().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugMonitor.php


Joomla CMS: Référence de la classe LoggingMonitor

  • Joomla
  • Database
  • Monitor
  • LoggingMonitor
Fonctions membres publiques
Référence de la classe LoggingMonitor
+ Graphe d'héritage de LoggingMonitor:
QueryMonitorInterface LoggerAwareInterface

Fonctions membres publiques

startQuery (string $sql, ?array $boundParams=null)
stopQuery ()
- Fonctions membres publiques hérités de LoggerAwareInterface
setLogger (LoggerInterface $logger)

Description détaillée

Query monitor handling logging of queries.

Depuis
2.0.0

Documentation des fonctions membres

◆ startQuery()

startQuery | ( | string | $sql,
 |  | ?array | $boundParams = null
 | ) |  |

Act on a query being started.

Paramètres
string | $sql | The SQL to be executed.
object[]|null | $boundParams List of bound params, used with the query. Each item is an object that holds: value, dataType
Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

Références $sql.

◆ stopQuery()

stopQuery ( )

Act on a query being stopped.

Renvoie
void
Depuis
2.0.0

Implémente QueryMonitorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LoggingMonitor.php


Joomla CMS: Référence de la classe MysqlDriver

  • Joomla
  • Database
  • Mysql
  • MysqlDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe MysqlDriver
+ Graphe d'héritage de MysqlDriver:
PdoDriver UTF8MB4SupportInterface DatabaseDriver DatabaseInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (array $options)
connect ()
convertUtf8mb4QueryToUtf8 ($query)
select ($database)
getAlterDbCharacterSet ($dbName)
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableCreate ($tables)
getTableColumns ($table, $typeOnly=true)
getTableKeys ($table)
getTableList ()
getVersion ()
getMinimum ()
getNullDate ()
hasUTF8mb4Support ()
isMariaDb ()
lockTable ($table)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
insertObject ($table, &$object, $key=null)
escape ($text, $extra=false)
unlockTables ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
- Fonctions membres publiques hérités de PdoDriver
__construct (array $options)
__destruct ()
connect ()
escape ($text, $extra=false)
execute ()
getOption ($key)
getVersion ()
getConnectedQuery ()
setOption ($key, $value)
connected ()
insertid ()
select ($database)
setUtf ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
__sleep ()
__wakeup ()
- Fonctions membres publiques hérités de DatabaseDriver
__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de UTF8MB4SupportInterface
hasUtf8mb4Support ()

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de PdoDriver
static | isSupported ()
- Fonctions membres publiques statiques hérités de DatabaseDriver
static | getInstance (array $options=[])
static | splitSql ($sql)

Champs de données

$name = 'mysql'
- Champs de données hérités de PdoDriver
$name = 'pdo'
- Champs de données hérités de DatabaseDriver
$serverType

Fonctions membres protégées

getCreateDatabaseQuery ($options, $utf)
- Fonctions membres protégées hérités de PdoDriver
prepareStatement (string $query)
- Fonctions membres protégées hérités de DatabaseDriver
dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)

Attributs protégés

$nameQuote = '`'
$nullDate = '0000-00-00 00:00:00'
$utf8mb4 = false
$mariadb = false
- Attributs protégés hérités de PdoDriver
$connection
$nameQuote = "'"
$nullDate = '0000-00-00 00:00:00'
- Attributs protégés hérités de DatabaseDriver
$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Attributs protégés statiques

static | $dbMinimum = '5.6'
static | $dbMinMariadb = '10.0'
static | $defaultCipherSuite
- Attributs protégés statiques hérités de DatabaseDriver
static | $connectors = []
static | $instances = []
static | $dbMinimum

Description détaillée

MySQL database driver supporting PDO based connections

1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options )

Constructor.

Paramètres
array $options Array of database options with keys: host, user, password, database, select.
Depuis
1.0

sql_mode to MySql 5.7.8+ default strict mode minus ONLY_FULL_GROUP_BY

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-8.html#mysqld-5-7-8-sql-mode

Références DatabaseDriver\$options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void Returns void if the database connected successfully.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $key, $value, DatabaseDriver\getConnection(), MysqlDriver\getVersion(), et null.

Référencé par MysqlDriver\escape(), MysqlDriver\getTableColumns(), MysqlDriver\getTableCreate(), MysqlDriver\getTableKeys(), MysqlDriver\getTableList(), MysqlDriver\getVersion(), MysqlDriver\isConnectionEncryptionSupported(), MysqlDriver\isMariaDb(), MysqlDriver\transactionCommit(), MysqlDriver\transactionRollback(), et MysqlDriver\transactionStart().

◆ convertUtf8mb4QueryToUtf8()

convertUtf8mb4QueryToUtf8 ( $query )

Automatically downgrade a CREATE TABLE or ALTER TABLE query from utf8mb4 (UTF-8 Multibyte) to plain utf8.

Used when the server doesn't support UTF-8 Multibyte.

Paramètres
string $query The query to convert
Renvoie
string The converted query
Depuis
1.4.0

Implémente UTF8MB4SupportInterface.

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Method to escape a string for usage in an SQL statement.

Oracle escaping reference: http://www.orafaq.com/wiki/SQL_FAQ#How_does_one_escape_special_characters_when_writing_SQL_queries.3F

SQLite escaping notes: http://www.sqlite.org/faq.html#q14

Method body is as implemented by the Zend Framework

Note: Using query objects with bound variables is preferable to the below.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Unused optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0

Implémente DatabaseInterface.

Références $result, $text, et MysqlDriver\connect().

◆ getAlterDbCharacterSet()

getAlterDbCharacterSet ( $dbName )

Return the query string to alter the database character set.

Paramètres
string $dbName The database name
Renvoie
string The query that alter the database query string
Depuis
2.0.0

◆ getCollation()

getCollation ( )

Method to get the database collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database (string) or boolean false if not supported.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

◆ getConnectionCollation()

getConnectionCollation ( )

Method to get the database connection collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database connection (string) or boolean false if not supported.
Depuis
1.6.0
Exceptions

Implémente DatabaseInterface.

◆ getConnectionEncryption()

getConnectionEncryption ( )

Method to get the database encryption details (cipher and protocol) in use.

Renvoie
string The database encryption details.
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

◆ getCreateDatabaseQuery()

getCreateDatabaseQuery | ( | $options,
 |  | $utf
 | ) |
protected

Return the query string to create new Database.

Paramètres
stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
string The query that creates database
Depuis
2.0.0

Références DatabaseDriver\$options, DatabaseDriver\$utf, et DatabaseDriver\quoteName().

◆ getMinimum()

getMinimum ( )

Get the minimum supported database version.

Renvoie
string
Depuis
2.0.0

Implémente DatabaseInterface.

◆ getNullDate()

getNullDate ( )

Get the null or zero representation of a timestamp for the database driver.

Renvoie
string
Depuis
2.0.0

Implémente DatabaseInterface.

Références MysqlDriver\$nullDate.

◆ getTableColumns()

getTableColumns | ( | $table,
 |  | $typeOnly = true
 | ) |

Retrieves field information about a given table.

Paramètres
string | $table | The name of the database table.
boolean | $typeOnly | True to only return field types.
Renvoie
array An array of fields for the database table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $field, $fields, $result, MysqlDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

Référencé par MysqlDriver\insertObject().

◆ getTableCreate()

getTableCreate ( $tables )

Shows the table CREATE statement that creates the given tables.

Paramètres
array | string $tables A table name or a list of table names.
Renvoie
array A list of the create SQL for the tables.
Depuis
1.0
Exceptions

Références $result, MysqlDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getTableKeys()

getTableKeys ( $table )

Get the details list of keys for a table.

Paramètres
string $table The name of the table.
Renvoie
array An array of the column specification for the table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqlDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getTableList()

getTableList ( )

Method to get an array of all tables in the database.

Renvoie
array An array of all the tables in the database.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqlDriver\connect(), et DatabaseDriver\setQuery().

◆ getVersion()

getVersion ( )

Get the version of the database connector.

Renvoie
string The database connector version.
Depuis
2.0.0

Implémente DatabaseInterface.

Références $version, MysqlDriver\connect(), et PdoDriver\getOption().

Référencé par MysqlDriver\connect().

◆ hasUTF8mb4Support()

hasUTF8mb4Support ( )

Determine whether the database engine support the UTF-8 Multibyte (utf8mb4) character encoding.

Renvoie
boolean True if the database engine supports UTF-8 Multibyte.
Depuis
2.0.0

Références MysqlDriver\$utf8mb4.

◆ insertObject()

insertObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key = null
 | ) |  |

Inserts a row into a table based on an object's properties.

Paramètres
string | $table | The name of the database table to insert into.
object | $object | A reference to an object whose public properties match the table fields.
string | $key | The name of the primary key. If provided the object property is updated.
Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $fields, $id, $key, $query, DatabaseDriver\getQuery(), MysqlDriver\getTableColumns(), PdoDriver\insertid(), null, DatabaseDriver\quote(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ isConnectionEncryptionSupported()

isConnectionEncryptionSupported ( )

Method to test if the database TLS connections encryption are supported.

Renvoie
boolean Whether the database supports TLS connections encryption.
Depuis
2.0.0

Implémente DatabaseInterface.

Références MysqlDriver\connect(), et DatabaseDriver\setQuery().

◆ isMariaDb()

isMariaDb ( )

Determine if the database engine is MariaDB.

Renvoie
boolean
Depuis
2.0.0

Références MysqlDriver\$mariadb, et MysqlDriver\connect().

◆ isSupported()

static isSupported ( )
static

Test to see if the MySQL connector is available.

Renvoie
boolean True on success, false otherwise.
Depuis
1.0

Implémente DatabaseInterface.

Référencé par Database\register().

◆ lockTable()

lockTable ( $table )

Locks a table in the database.

Paramètres
string $table The name of the table to unlock.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ renameTable()

renameTable | ( | $oldTable,
 |  | $newTable,
 |  | $backup = null,
 |  | $prefix = null
 | ) |

Renames a table in the database.

Paramètres
string | $oldTable | The name of the table to be renamed
string | $newTable | The new name for the table.
string | $backup | Not used by MySQL.
string | $prefix | Not used by MySQL.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ select()

select ( $database )

Select a database for use.

Paramètres
string $database The name of the database to select for use.
Renvoie
boolean
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqlDriver\connect().

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqlDriver\connect(), PdoDriver\execute(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$transactionDepth, MysqlDriver\connect(), PdoDriver\execute(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ unlockTables()

unlockTables ( )

Unlocks tables in the database.

Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, et DatabaseDriver\setQuery().

Documentation des champs

◆ $dbMinimum

$dbMinimum = '5.6'
staticprotected

◆ $dbMinMariadb

$dbMinMariadb = '10.0'
staticprotected

◆ $defaultCipherSuite

$defaultCipherSuite
staticprotected
Valeur initiale :
= [
'AES128-GCM-SHA256',
'AES256-GCM-SHA384',
'AES128-CBC-SHA256',
'AES256-CBC-SHA384',
'DES-CBC3-SHA',
]

◆ $mariadb

$mariadb = false
protected

Référencé par MysqlDriver\isMariaDb().

◆ $name

$name = 'mysql'

◆ $nameQuote

$nameQuote = '`'
protected

◆ $nullDate

$nullDate = '0000-00-00 00:00:00'
protected

Référencé par MysqlDriver\getNullDate().

◆ $utf8mb4

$utf8mb4 = false
protected

Référencé par MysqlDriver\hasUTF8mb4Support().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqlDriver.php


Joomla CMS: Référence de la classe MysqlExporter

  • Joomla
  • Database
  • Mysql
  • MysqlExporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MysqlExporter
+ Graphe d'héritage de MysqlExporter:
DatabaseExporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseExporter
__construct ()
__toString ()
asXml ()
check ()
from ($from)
setDbo (DatabaseInterface $db)
withStructure ($setting=true)
withData ($setting=false)

Fonctions membres protégées

buildXml ()
buildXmlStructure ()
- Fonctions membres protégées hérités de DatabaseExporter
buildXml ()
buildXmlStructure ()
getGenericTableName ($table)
buildXmlData ()

Membres hérités additionnels

- Attributs protégés hérités de DatabaseExporter
$asFormat = 'xml'
$cache = ['columns' => []
$db
$from = []
$options

Description détaillée

MySQL Database Exporter.

Depuis
1.0

Documentation des fonctions membres

◆ buildXml()

buildXml ( )
protected

Builds the XML data for the tables to export.

Renvoie
string An XML string
Depuis
1.0
Exceptions

Références $buffer, DatabaseExporter\buildXmlData(), et MysqlExporter\buildXmlStructure().

◆ buildXmlStructure()

buildXmlStructure ( )
protected

Builds the XML structure to export.

Renvoie
array An array of XML lines (strings).
Depuis
1.0
Exceptions

Références $buffer, $field, $fields, $key, ENT_COMPAT, DatabaseExporter\from(), et DatabaseExporter\getGenericTableName().

Référencé par MysqlExporter\buildXml().

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.0
Exceptions

Références $this, et DatabaseExporter\from().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqlExporter.php


Joomla CMS: Référence de la classe MysqlImporter

  • Joomla
  • Database
  • Mysql
  • MysqlImporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MysqlImporter
+ Graphe d'héritage de MysqlImporter:
DatabaseImporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseImporter
__construct ()
asXml ()
check ()
from ($from)
importData ()
mergeStructure ()
setDbo (DatabaseInterface $db)
withStructure ($setting=true)

Fonctions membres protégées

getAddKeySql ($table, $keys)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getColumnSql (\SimpleXMLElement $field)
getDropKeySql ($table, $name)
getDropPrimaryKeySql ($table)
getKeyLookup ($keys)
getKeySql ($columns)
xmlToCreate (\SimpleXMLElement $table)
- Fonctions membres protégées hérités de DatabaseImporter
getAddColumnSql ($table, \SimpleXMLElement $field)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getDropColumnSql ($table, $name)
getKeyLookup ($keys)
getRealTableName ($table)
xmlToCreate (\SimpleXMLElement $table)

Membres hérités additionnels

- Attributs protégés hérités de DatabaseImporter
$cache = ['columns' => []
$db
$from = []
$asFormat = 'xml'
$options

Description détaillée

MySQL Database Importer.

Depuis
1.0

Documentation des fonctions membres

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.0
Exceptions

Références $this, et DatabaseImporter\from().

◆ getAddKeySql()

getAddKeySql | ( | $table,
 |  | $keys
 | ) |
protected

Get the SQL syntax to add a key.

Paramètres
string | $table | The table name.
array | $keys | An array of the fields pertaining to this key.
Renvoie
string
Depuis
1.0

Références MysqlImporter\getKeySql().

Référencé par MysqlImporter\getAlterTableSql().

◆ getAlterTableSql()

getAlterTableSql ( \SimpleXMLElement $structure )
protected

Get alters for table if there is a difference.

Paramètres
\SimpleXMLElement $structure The XML structure of the table.
Renvoie
array
Depuis
1.0

Références $field, $i, $name, DatabaseImporter\getAddColumnSql(), MysqlImporter\getAddKeySql(), MysqlImporter\getChangeColumnSql(), DatabaseImporter\getDropColumnSql(), MysqlImporter\getDropKeySql(), MysqlImporter\getDropPrimaryKeySql(), MysqlImporter\getKeyLookup(), et DatabaseImporter\getRealTableName().

◆ getChangeColumnSql()

getChangeColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the syntax to alter a column.

Paramètres
string | $table | The name of the database table to alter.
\SimpleXMLElement | $field | The XML definition for the field.
Renvoie
string
Depuis
1.0

Références $field, et MysqlImporter\getColumnSql().

Référencé par MysqlImporter\getAlterTableSql().

◆ getColumnSql()

getColumnSql ( \SimpleXMLElement $field )
protected

Get the SQL syntax for a single column that would be included in a table create or alter statement.

Paramètres
\SimpleXMLElement $field The XML field definition.
Renvoie
string
Depuis
1.0

Références $field, $sql, et null.

Référencé par MysqlImporter\getChangeColumnSql(), et MysqlImporter\xmlToCreate().

◆ getDropKeySql()

getDropKeySql | ( | $table,
 |  | $name
 | ) |
protected

Get the SQL syntax to drop a key.

Paramètres
string | $table | The table name.
string | $name | The name of the key to drop.
Renvoie
string
Depuis
1.0

Références $name.

Référencé par MysqlImporter\getAlterTableSql().

◆ getDropPrimaryKeySql()

getDropPrimaryKeySql ( $table )
protected

Get the SQL syntax to drop a key.

Paramètres
string $table The table name.
Renvoie
string
Depuis
1.0

Référencé par MysqlImporter\getAlterTableSql().

◆ getKeyLookup()

getKeyLookup ( $keys )
protected

Get the details list of keys for a table.

Paramètres
array $keys An array of objects that comprise the keys for the table.
Renvoie
array The lookup array. array({key name} => array(object, ...))
Depuis
1.0
Exceptions

Références $key.

Référencé par MysqlImporter\getAlterTableSql(), et MysqlImporter\xmlToCreate().

◆ getKeySql()

getKeySql ( $columns )
protected

Get the SQL syntax for a key.

Paramètres
array $columns An array of SimpleXMLElement objects comprising the key.
Renvoie
string
Depuis
1.0

Références $columns, $prefix, et elseif.

Référencé par MysqlImporter\getAddKeySql(), et MysqlImporter\xmlToCreate().

◆ xmlToCreate()

xmlToCreate ( \SimpleXMLElement $table )
protected

Get the SQL syntax to add a table.

Paramètres
\SimpleXMLElement $table The table information.
Renvoie
string
Depuis
2.0.0
Exceptions

Références $field, $key, MysqlImporter\getColumnSql(), MysqlImporter\getKeyLookup(), et MysqlImporter\getKeySql().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqlImporter.php


Joomla CMS: Référence de la classe MysqlQuery

  • Joomla
  • Database
  • Mysql
  • MysqlQuery
Attributs protégés
Référence de la classe MysqlQuery
+ Graphe d'héritage de MysqlQuery:
PdoQuery DatabaseQuery QueryInterface PreparableInterface LimitableInterface

Attributs protégés

$nullDatetimeList = ['0000-00-00 00:00:00', '1000-01-01 00:00:00']
- Attributs protégés hérités de PdoQuery
$nullDatetimeList = ['0000-00-00 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Membres hérités additionnels

- Fonctions membres publiques hérités de PdoQuery
castAsChar ($value, $len=null)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres publiques hérités de QueryInterface
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)
- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Description détaillée

MySQL Query Building Class.

Depuis
1.0

Documentation des champs

◆ $nullDatetimeList

$nullDatetimeList = ['0000-00-00 00:00:00', '1000-01-01 00:00:00']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqlQuery.php


Joomla CMS: Référence de la classe MysqliDriver

  • Joomla
  • Database
  • Mysqli
  • MysqliDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe MysqliDriver
+ Graphe d'héritage de MysqliDriver:
DatabaseDriver UTF8MB4SupportInterface DatabaseInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (array $options)
connect ()
convertUtf8mb4QueryToUtf8 ($query)
disconnect ()
escape ($text, $extra=false)
connected ()
getAlterDbCharacterSet ($dbName)
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableCreate ($tables)
getTableColumns ($table, $typeOnly=true)
getTableKeys ($table)
getTableList ()
getVersion ()
getMinimum ()
hasUTF8mb4Support ()
isMariaDb ()
insertid ()
insertObject ($table, &$object, $key=null)
lockTable ($table)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
select ($database)
setUtf ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
unlockTables ()
getNullDate ()
- Fonctions membres publiques hérités de DatabaseDriver
__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de UTF8MB4SupportInterface
hasUtf8mb4Support ()

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de DatabaseDriver
static | getInstance (array $options=[])
static | splitSql ($sql)

Champs de données

$name = 'mysqli'
- Champs de données hérités de DatabaseDriver
$serverType

Fonctions membres protégées

getCreateDatabaseQuery ($options, $utf)
executeUnpreparedQuery ($sql)
prepareStatement (string $query)
- Fonctions membres protégées hérités de DatabaseDriver
dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)

Attributs protégés

$connection
$nameQuote = '`'
$nullDate = '0000-00-00 00:00:00'
$utf8mb4 = false
$mariadb = false
- Attributs protégés hérités de DatabaseDriver
$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Attributs protégés statiques

static | $dbMinimum = '5.6'
static | $dbMinMariadb = '10.0'
- Attributs protégés statiques hérités de DatabaseDriver
static | $connectors = []
static | $instances = []
static | $dbMinimum

Fonctions membres privées

serverClaimsUtf8mb4Support ()

Description détaillée

MySQLi Database Driver

1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options )

Constructor.

Paramètres
array $options List of options used to configure the connection
Depuis
1.0

sql_mode to MySql 5.7.8+ default strict mode minus ONLY_FULL_GROUP_BY

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-8.html#mysqld-5-7-8-sql-mode

Références DatabaseDriver\$options, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void Returns void if the database connected successfully.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, elseif, null, et MysqliDriver\select().

Référencé par MysqliDriver\escape(), MysqliDriver\executeUnpreparedQuery(), MysqliDriver\getCollation(), MysqliDriver\getConnectionCollation(), MysqliDriver\getConnectionEncryption(), MysqliDriver\getTableColumns(), MysqliDriver\getTableCreate(), MysqliDriver\getTableKeys(), MysqliDriver\getTableList(), MysqliDriver\getVersion(), MysqliDriver\insertid(), MysqliDriver\isConnectionEncryptionSupported(), MysqliDriver\isMariaDb(), MysqliDriver\select(), MysqliDriver\setUtf(), MysqliDriver\transactionCommit(), MysqliDriver\transactionRollback(), et MysqliDriver\transactionStart().

◆ connected()

connected ( )

Determines if the connection to the server is active.

Renvoie
boolean True if connected to the database engine.
Depuis
1.0

Implémente DatabaseInterface.

Référencé par MysqliDriver\executeUnpreparedQuery().

◆ convertUtf8mb4QueryToUtf8()

convertUtf8mb4QueryToUtf8 ( $query )

Automatically downgrade a CREATE TABLE or ALTER TABLE query from utf8mb4 (UTF-8 Multibyte) to plain utf8.

Used when the server doesn't support UTF-8 Multibyte.

Paramètres
string $query The query to convert
Renvoie
string The converted query
Depuis
1.4.0

Implémente UTF8MB4SupportInterface.

Références $query.

◆ disconnect()

disconnect ( )

Disconnects the database.

Renvoie
void
Depuis
1.0

Implémente DatabaseInterface.

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Method to escape a string for usage in an SQL statement.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0

Implémente DatabaseInterface.

Références $result, $text, et MysqliDriver\connect().

Référencé par MysqliDriver\getTableColumns(), et MysqliDriver\getTableCreate().

◆ executeUnpreparedQuery()

executeUnpreparedQuery ( $sql )
protected

Internal method to execute queries which cannot be run as prepared statements.

Paramètres
string $sql SQL statement to execute.
Renvoie
boolean
Depuis
1.5.0

Références DatabaseDriver\$cursor, DatabaseDriver\$errorMsg, DatabaseDriver\$errorNum, DatabaseDriver\$sql, MysqliDriver\connect(), MysqliDriver\connected(), DatabaseDriver\freeResult(), et null.

Référencé par MysqliDriver\lockTable(), MysqliDriver\transactionRollback(), et MysqliDriver\unlockTables().

◆ getAlterDbCharacterSet()

getAlterDbCharacterSet ( $dbName )

Return the query string to alter the database character set.

Paramètres
string $dbName The database name
Renvoie
string The query that alter the database query string
Depuis
2.0.0

Références DatabaseDriver\quoteName().

◆ getCollation()

getCollation ( )

Method to get the database collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database (string) or boolean false if not supported.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), et DatabaseDriver\setQuery().

◆ getConnectionCollation()

getConnectionCollation ( )

Method to get the database connection collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database connection (string) or boolean false if not supported.
Depuis
1.6.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), et DatabaseDriver\setQuery().

◆ getConnectionEncryption()

getConnectionEncryption ( )

Method to get the database encryption details (cipher and protocol) in use.

Renvoie
string The database encryption details.
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), et DatabaseDriver\setQuery().

◆ getCreateDatabaseQuery()

getCreateDatabaseQuery | ( | $options,
 |  | $utf
 | ) |
protected

Return the query string to create new Database.

Paramètres
stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
string The query that creates database
Depuis
2.0.0

Références DatabaseDriver\$options, DatabaseDriver\$utf, et DatabaseDriver\quoteName().

◆ getMinimum()

getMinimum ( )

Get the minimum supported database version.

Renvoie
string
Depuis
2.0.0

Implémente DatabaseInterface.

◆ getNullDate()

getNullDate ( )

Get the null or zero representation of a timestamp for the database driver.

Renvoie
string
Depuis
2.0.0

Implémente DatabaseInterface.

Références MysqliDriver\$nullDate.

◆ getTableColumns()

getTableColumns | ( | $table,
 |  | $typeOnly = true
 | ) |

Retrieves field information about a given table.

Paramètres
string | $table | The name of the database table.
boolean | $typeOnly | True to only return field types.
Renvoie
array An array of fields for the database table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $field, $fields, $result, MysqliDriver\connect(), MysqliDriver\escape(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

Référencé par MysqliDriver\insertObject().

◆ getTableCreate()

getTableCreate ( $tables )

Shows the table CREATE statement that creates the given tables.

Paramètres
mixed $tables A table name or a list of table names.
Renvoie
array A list of the create SQL for the tables.
Depuis
1.0
Exceptions

Références $result, MysqliDriver\connect(), MysqliDriver\escape(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getTableKeys()

getTableKeys ( $table )

Get the details list of keys for a table.

Paramètres
string $table The name of the table.
Renvoie
array An array of the column specification for the table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getTableList()

getTableList ( )

Method to get an array of all tables in the database.

Renvoie
array An array of all the tables in the database.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), et DatabaseDriver\setQuery().

◆ getVersion()

getVersion ( )

Get the version of the database connector.

Renvoie
string The database connector version.
Depuis
1.0

Implémente DatabaseInterface.

Références MysqliDriver\connect().

Référencé par MysqliDriver\serverClaimsUtf8mb4Support().

◆ hasUTF8mb4Support()

hasUTF8mb4Support ( )

Determine whether the database engine support the UTF-8 Multibyte (utf8mb4) character encoding.

Renvoie
boolean True if the database engine supports UTF-8 Multibyte.
Depuis
2.0.0

Références MysqliDriver\$utf8mb4.

◆ insertid()

insertid ( )

Method to get the auto-incremented value from the last INSERT statement.

Renvoie
mixed The value of the auto-increment field from the last inserted row. If the value is greater than maximal int value, it will return a string.
Depuis
1.0

Implémente DatabaseInterface.

Références MysqliDriver\connect().

Référencé par MysqliDriver\insertObject().

◆ insertObject()

insertObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key = null
 | ) |  |

Inserts a row into a table based on an object's properties.

Paramètres
string | $table | The name of the database table to insert into.
object | $object | A reference to an object whose public properties match the table fields.
string | $key | The name of the primary key. If provided the object property is updated.
Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $fields, $id, $key, $query, DatabaseDriver\getQuery(), MysqliDriver\getTableColumns(), MysqliDriver\insertid(), null, DatabaseDriver\quote(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ isConnectionEncryptionSupported()

isConnectionEncryptionSupported ( )

Method to test if the database TLS connections encryption are supported.

Renvoie
boolean Whether the database supports TLS connections encryption.
Depuis
2.0.0

Implémente DatabaseInterface.

Références MysqliDriver\connect(), et DatabaseDriver\setQuery().

◆ isMariaDb()

isMariaDb ( )

Determine if the database engine is MariaDB.

Renvoie
boolean
Depuis
2.0.0

Références MysqliDriver\$mariadb, et MysqliDriver\connect().

◆ isSupported()

static isSupported ( )
static

Test to see if the MySQLi connector is available.

Renvoie
boolean True on success, false otherwise.
Depuis
1.0

Implémente DatabaseInterface.

◆ lockTable()

lockTable ( $table )

Locks a table in the database.

Paramètres
string $table The name of the table to unlock.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, MysqliDriver\executeUnpreparedQuery(), DatabaseDriver\quoteName(), et DatabaseDriver\replacePrefix().

◆ prepareStatement()

prepareStatement ( string $query )
protected

Prepares a SQL statement for execution

Paramètres
string $query The SQL query to be prepared.
Renvoie
StatementInterface
Depuis
2.0.0
Exceptions
PrepareStatementFailureException

Références $query.

◆ renameTable()

renameTable | ( | $oldTable,
 |  | $newTable,
 |  | $backup = null,
 |  | $prefix = null
 | ) |

Renames a table in the database.

Paramètres
string | $oldTable | The name of the table to be renamed
string | $newTable | The new name for the table.
string | $backup | Not used by MySQL.
string | $prefix | Not used by MySQL.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, et DatabaseDriver\setQuery().

◆ select()

select ( $database )

Select a database for use.

Paramètres
string $database The name of the database to select for use.
Renvoie
boolean True if the database was successfully selected.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$database, et MysqliDriver\connect().

Référencé par MysqliDriver\connect().

◆ serverClaimsUtf8mb4Support()

serverClaimsUtf8mb4Support ( )
private

Does the database server claim to have support for UTF-8 Multibyte (utf8mb4) collation?

libmysql supports utf8mb4 since 5.5.3 (same version as the MySQL server). mysqlnd supports utf8mb4 since 5.0.9.

Renvoie
boolean
Depuis
1.4.0

Références MysqliDriver\getVersion().

◆ setUtf()

setUtf ( )

Set the connection to use UTF-8 character encoding.

Renvoie
boolean True on success.
Depuis
1.0

Références $result, et MysqliDriver\connect().

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect().

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références MysqliDriver\connect(), MysqliDriver\executeUnpreparedQuery(), et DatabaseDriver\quoteName().

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$transactionDepth, et MysqliDriver\connect().

◆ unlockTables()

unlockTables ( )

Unlocks tables in the database.

Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, et MysqliDriver\executeUnpreparedQuery().

Documentation des champs

◆ $connection

$connection
protected

◆ $dbMinimum

$dbMinimum = '5.6'
staticprotected

◆ $dbMinMariadb

$dbMinMariadb = '10.0'
staticprotected

◆ $mariadb

$mariadb = false
protected

Référencé par MysqliDriver\isMariaDb().

◆ $name

$name = 'mysqli'

◆ $nameQuote

$nameQuote = '`'
protected

◆ $nullDate

$nullDate = '0000-00-00 00:00:00'
protected

Référencé par MysqliDriver\getNullDate().

◆ $utf8mb4

$utf8mb4 = false
protected

Référencé par MysqliDriver\hasUTF8mb4Support().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliDriver.php


Joomla CMS: Référence de la classe MysqliExporter

  • Joomla
  • Database
  • Mysqli
  • MysqliExporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MysqliExporter
+ Graphe d'héritage de MysqliExporter:
DatabaseExporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseExporter
__construct ()
__toString ()
asXml ()
check ()
from ($from)
setDbo (DatabaseInterface $db)
withStructure ($setting=true)
withData ($setting=false)

Fonctions membres protégées

buildXml ()
buildXmlStructure ()
- Fonctions membres protégées hérités de DatabaseExporter
buildXml ()
buildXmlStructure ()
getGenericTableName ($table)
buildXmlData ()

Membres hérités additionnels

- Attributs protégés hérités de DatabaseExporter
$asFormat = 'xml'
$cache = ['columns' => []
$db
$from = []
$options

Description détaillée

MySQLi Database Exporter.

Depuis
1.0

Documentation des fonctions membres

◆ buildXml()

buildXml ( )
protected

Builds the XML data for the tables to export.

Renvoie
string An XML string
Depuis
1.0
Exceptions

Références $buffer, DatabaseExporter\buildXmlData(), et MysqliExporter\buildXmlStructure().

◆ buildXmlStructure()

buildXmlStructure ( )
protected

Builds the XML structure to export.

Renvoie
array An array of XML lines (strings).
Depuis
1.0
Exceptions

Références $buffer, $field, $fields, $key, ENT_COMPAT, DatabaseExporter\from(), et DatabaseExporter\getGenericTableName().

Référencé par MysqliExporter\buildXml().

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.0
Exceptions

Références $this, et DatabaseExporter\from().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliExporter.php


Joomla CMS: Référence de la classe MysqliImporter

  • Joomla
  • Database
  • Mysqli
  • MysqliImporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe MysqliImporter
+ Graphe d'héritage de MysqliImporter:
DatabaseImporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseImporter
__construct ()
asXml ()
check ()
from ($from)
importData ()
mergeStructure ()
setDbo (DatabaseInterface $db)
withStructure ($setting=true)

Fonctions membres protégées

xmlToCreate (\SimpleXMLElement $table)
getAddKeySql ($table, $keys)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getColumnSql (\SimpleXMLElement $field)
getDropKeySql ($table, $name)
getDropPrimaryKeySql ($table)
getKeyLookup ($keys)
getKeySql ($columns)
- Fonctions membres protégées hérités de DatabaseImporter
getAddColumnSql ($table, \SimpleXMLElement $field)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getDropColumnSql ($table, $name)
getKeyLookup ($keys)
getRealTableName ($table)
xmlToCreate (\SimpleXMLElement $table)

Membres hérités additionnels

- Attributs protégés hérités de DatabaseImporter
$cache = ['columns' => []
$db
$from = []
$asFormat = 'xml'
$options

Description détaillée

MySQLi Database Importer.

Depuis
1.0

Documentation des fonctions membres

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.0
Exceptions

Références $this, et DatabaseImporter\from().

◆ getAddKeySql()

getAddKeySql | ( | $table,
 |  | $keys
 | ) |
protected

Get the SQL syntax to add a key.

Paramètres
string | $table | The table name.
array | $keys | An array of the fields pertaining to this key.
Renvoie
string
Depuis
1.0

Références MysqliImporter\getKeySql().

Référencé par MysqliImporter\getAlterTableSql().

◆ getAlterTableSql()

getAlterTableSql ( \SimpleXMLElement $structure )
protected

Get alters for table if there is a difference.

Paramètres
\SimpleXMLElement $structure The XML structure of the table.
Renvoie
array
Depuis
1.0

Références $field, $i, $name, DatabaseImporter\getAddColumnSql(), MysqliImporter\getAddKeySql(), MysqliImporter\getChangeColumnSql(), DatabaseImporter\getDropColumnSql(), MysqliImporter\getDropKeySql(), MysqliImporter\getDropPrimaryKeySql(), MysqliImporter\getKeyLookup(), et DatabaseImporter\getRealTableName().

◆ getChangeColumnSql()

getChangeColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the syntax to alter a column.

Paramètres
string | $table | The name of the database table to alter.
\SimpleXMLElement | $field | The XML definition for the field.
Renvoie
string
Depuis
1.0

Références $field, et MysqliImporter\getColumnSql().

Référencé par MysqliImporter\getAlterTableSql().

◆ getColumnSql()

getColumnSql ( \SimpleXMLElement $field )
protected

Get the SQL syntax for a single column that would be included in a table create or alter statement.

Paramètres
\SimpleXMLElement $field The XML field definition.
Renvoie
string
Depuis
1.0

Références $field, $sql, et null.

Référencé par MysqliImporter\getChangeColumnSql(), et MysqliImporter\xmlToCreate().

◆ getDropKeySql()

getDropKeySql | ( | $table,
 |  | $name
 | ) |
protected

Get the SQL syntax to drop a key.

Paramètres
string | $table | The table name.
string | $name | The name of the key to drop.
Renvoie
string
Depuis
1.0

Références $name.

Référencé par MysqliImporter\getAlterTableSql().

◆ getDropPrimaryKeySql()

getDropPrimaryKeySql ( $table )
protected

Get the SQL syntax to drop a key.

Paramètres
string $table The table name.
Renvoie
string
Depuis
1.0

Référencé par MysqliImporter\getAlterTableSql().

◆ getKeyLookup()

getKeyLookup ( $keys )
protected

Get the details list of keys for a table.

Paramètres
array $keys An array of objects that comprise the keys for the table.
Renvoie
array The lookup array. array({key name} => array(object, ...))
Depuis
1.0

Références $key.

Référencé par MysqliImporter\getAlterTableSql(), et MysqliImporter\xmlToCreate().

◆ getKeySql()

getKeySql ( $columns )
protected

Get the SQL syntax for a key.

Paramètres
array $columns An array of SimpleXMLElement objects comprising the key.
Renvoie
string
Depuis
1.0

Références $columns, $prefix, et elseif.

Référencé par MysqliImporter\getAddKeySql(), et MysqliImporter\xmlToCreate().

◆ xmlToCreate()

xmlToCreate ( \SimpleXMLElement $table )
protected

Get the SQL syntax to add a table.

Paramètres
\SimpleXMLElement $table The table information.
Renvoie
string
Depuis
1.4.0
Exceptions

Références $field, $key, MysqliImporter\getColumnSql(), MysqliImporter\getKeyLookup(), et MysqliImporter\getKeySql().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliImporter.php


Joomla CMS: Référence de la classe MysqliQuery

  • Joomla
  • Database
  • Mysqli
  • MysqliQuery
Attributs protégés
Référence de la classe MysqliQuery
+ Graphe d'héritage de MysqliQuery:
DatabaseQuery QueryInterface PreparableInterface LimitableInterface

Attributs protégés

$nullDatetimeList = ['0000-00-00 00:00:00', '1000-01-01 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Membres hérités additionnels

- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres publiques hérités de QueryInterface
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)
- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Description détaillée

MySQLi Query Building Class.

Depuis
1.0

Documentation des champs

◆ $nullDatetimeList

$nullDatetimeList = ['0000-00-00 00:00:00', '1000-01-01 00:00:00']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliQuery.php


Joomla CMS: Référence de la classe MysqliStatement

  • Joomla
  • Database
  • Mysqli
  • MysqliStatement
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe MysqliStatement
+ Graphe d'héritage de MysqliStatement:
StatementInterface

Fonctions membres publiques

__construct (\mysqli $connection, string $query)
prepareParameterKeyMapping ($sql)
bindParam ($parameter, &$variable, string $dataType=ParameterType::STRING, ?int $length=null, ?array $driverOptions=null)
closeCursor ()
errorCode ()
errorInfo ()
execute (?array $parameters=null)
fetch (?int $fetchStyle=null, int $cursorOrientation=FetchOrientation::NEXT, int $cursorOffset=0)
fetchColumn ($columnIndex=0)
rowCount ()
setFetchMode (int $fetchMode,... $args)

Attributs protégés

$bindedValues
$parameterKeyMapping
$parameterTypeMapping
$columnNames
$connection
$defaultFetchStyle = FetchMode::MIXED
$query
$rowBindedValues
$statement
$typesKeyMapping

Fonctions membres privées

bindValues (array $values)
fetchData ()

Attributs privés

$result = false

Description détaillée

MySQLi Database Statement.

This class is modeled on

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \mysqli | $connection,
 |  | string | $query
 | ) |  |

Constructor.

Paramètres
\mysqli | $connection | The database connection resource
string | $query | The query this statement will process
Depuis
2.0.0
Exceptions
PrepareStatementFailureException

Références MysqliStatement\$connection, MysqliStatement\$query, $this, et MysqliStatement\prepareParameterKeyMapping().

Documentation des fonctions membres

◆ bindParam()

bindParam | ( |  | $parameter,
 |  | & | $variable,
 |  | string | $dataType = ParameterType::STRING,
 |  | ?int | $length = null,
 |  | ?array | $driverOptions = null
 | ) |  |

Binds a parameter to the specified variable name.

Paramètres
string | integer | $parameter | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $variable | Name of the PHP variable to bind to the SQL statement parameter.
integer | $dataType | Constant corresponding to a SQL datatype, this should be the processed type from the QueryInterface.
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

◆ bindValues()

bindValues ( array $values )
private

Binds a array of values to bound parameters.

Paramètres
array $values The values to bind to the statement
Renvoie
boolean
Depuis
2.0.0

Références $key, $params, et $value.

Référencé par MysqliStatement\execute().

◆ closeCursor()

closeCursor ( )

Closes the cursor, enabling the statement to be executed again.

Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

◆ errorCode()

errorCode ( )

Fetches the SQLSTATE associated with the last operation on the statement handle.

Renvoie
string
Depuis
2.0.0

Implémente StatementInterface.

◆ errorInfo()

errorInfo ( )

Fetches extended error information associated with the last operation on the statement handle.

Renvoie
array
Depuis
2.0.0

Implémente StatementInterface.

◆ execute()

execute ( ?array $parameters = null )

Executes a prepared statement

Paramètres
array | null $parameters An array of values with as many elements as there are bound parameters in the SQL statement being executed.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

Références MysqliStatement\$columnNames, $key, $parameters, $params, $this, $value, MysqliStatement\bindValues(), elseif, et null.

◆ fetch()

fetch | ( | ?int | $fetchStyle = null,
 |  | int | $cursorOrientation = FetchOrientation::NEXT,
 |  | int | $cursorOffset = 0
 | ) |  |

Fetches the next row from a result set

Paramètres
integer | null | $fetchStyle | Controls how the next row will be returned to the caller. This value must be one of the FetchMode constants, defaulting to value of FetchMode::MIXED.
integer | $cursorOrientation | For a StatementInterface object representing a scrollable cursor, this value determines which row will be returned to the caller. This value must be one of the FetchOrientation constants, defaulting to FetchOrientation::NEXT.
integer | $cursorOffset | For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::ABS, this value specifies the absolute number of the row in the result set that shall be fetched. For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::REL, this value specifies the row to fetch relative to the cursor position before fetch() was called.
Renvoie
mixed The return value of this function on success depends on the fetch type. In all cases, boolean false is returned on failure.
Depuis
2.0.0

Implémente StatementInterface.

Références MysqliStatement\$defaultFetchStyle, $this, FetchMode\ASSOCIATIVE, FetchMode\COLUMN, MysqliStatement\fetchColumn(), MysqliStatement\fetchData(), FetchMode\MIXED, null, FetchMode\NUMERIC, et FetchMode\STANDARD_OBJECT.

Référencé par MysqliStatement\fetchColumn().

◆ fetchColumn()

fetchColumn ( $columnIndex = 0 )

Returns a single column from the next row of a result set

Paramètres
integer $columnIndex 0-indexed number of the column you wish to retrieve from the row. If no value is supplied, the first column is retrieved.
Renvoie
mixed Returns a single column from the next row of a result set or boolean false if there are no more rows.
Depuis
2.0.0

Références MysqliStatement\fetch(), null, et FetchMode\NUMERIC.

Référencé par MysqliStatement\fetch().

◆ fetchData()

fetchData ( )
private

Fetch the data from the statement.

Renvoie
array|boolean
Depuis
2.0.0

Références $return.

Référencé par MysqliStatement\fetch().

◆ prepareParameterKeyMapping()

prepareParameterKeyMapping ( $sql )

Replace named parameters with numbered parameters

Paramètres
string $sql The SQL statement to prepare.
Renvoie
string The processed SQL statement.
Depuis
2.0.0

Références $i, $n, et $sql.

Référencé par MysqliStatement\__construct().

◆ rowCount()

rowCount ( )

Returns the number of rows affected by the last SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémente StatementInterface.

◆ setFetchMode()

setFetchMode | ( | int | $fetchMode,
 |  |  | $args
 | ) |  |

Sets the fetch mode to use while iterating this statement.

Paramètres
integer | $fetchMode | The fetch mode, must be one of the FetchMode constants.
mixed | ...$args Optional mode-specific arguments.
Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

Documentation des champs

◆ $bindedValues

$bindedValues
protected

◆ $columnNames

$columnNames
protected

Référencé par MysqliStatement\execute().

◆ $connection

$connection
protected

Référencé par MysqliStatement\__construct().

◆ $defaultFetchStyle

$defaultFetchStyle = FetchMode::MIXED
protected

Référencé par MysqliStatement\fetch().

◆ $parameterKeyMapping

$parameterKeyMapping
protected

◆ $parameterTypeMapping

$parameterTypeMapping
protected
Valeur initiale :
= [
ParameterType::BOOLEAN => 'i'

◆ $query

$query
protected

Référencé par MysqliStatement\__construct().

◆ $result

$result = false
private

◆ $rowBindedValues

$rowBindedValues
protected

◆ $statement

$statement
protected

◆ $typesKeyMapping

$typesKeyMapping
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliStatement.php


Joomla CMS: Référence de la classe PdoDriver

  • Joomla
  • Database
  • Pdo
  • PdoDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe PdoDriver
+ Graphe d'héritage de PdoDriver:
DatabaseDriver DatabaseInterface DispatcherAwareInterface MysqlDriver PgsqlDriver SqliteDriver

Fonctions membres publiques

__construct (array $options)
__destruct ()
connect ()
escape ($text, $extra=false)
execute ()
getOption ($key)
getVersion ()
getConnectedQuery ()
setOption ($key, $value)
connected ()
insertid ()
select ($database)
setUtf ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
__sleep ()
__wakeup ()
- Fonctions membres publiques hérités de DatabaseDriver
__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DatabaseInterface
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableColumns ($table, $typeOnly=true)
getTableKeys ($tables)
getTableList ()
lockTable ($tableName)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
unlockTables ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de DatabaseDriver
static | getInstance (array $options=[])
static | splitSql ($sql)

Champs de données

$name = 'pdo'
- Champs de données hérités de DatabaseDriver
$serverType

Fonctions membres protégées

prepareStatement (string $query)
- Fonctions membres protégées hérités de DatabaseDriver
dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)

Attributs protégés

$connection
$nameQuote = "'"
$nullDate = '0000-00-00 00:00:00'
- Attributs protégés hérités de DatabaseDriver
$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Membres hérités additionnels

- Attributs protégés statiques hérités de DatabaseDriver
static | $connectors = []
static | $instances = []
static | $dbMinimum

Description détaillée

Joomla Framework PDO Database Driver Class

1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options )

Constructor.

Paramètres
array $options List of options used to configure the connection
Depuis
1.0

Références DatabaseDriver\$options, Symfony\Contracts\Service\__construct(), et null.

Référencé par PdoDriver\__wakeup().

◆ __destruct()

__destruct ( )

Destructor.

Depuis
1.0

Références DatabaseDriver\disconnect().

Documentation des fonctions membres

◆ __sleep()

__sleep ( )

PDO does not support serialize

Renvoie
array
Depuis
1.0

Références $this.

◆ __wakeup()

__wakeup ( )

Wake up after serialization

Renvoie
void
Depuis
1.0

Références PdoDriver\__construct().

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void Returns void if the database connected successfully.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $format, $key, $this, $value, DatabaseDriver\dispatchEvent(), null, DatabaseEvents\POST_CONNECT, et PdoDriver\setOption().

Référencé par PdoDriver\execute(), PdoDriver\getOption(), PdoDriver\getVersion(), PdoDriver\insertid(), PdoDriver\select(), PdoDriver\setOption(), PdoDriver\transactionCommit(), PdoDriver\transactionRollback(), et PdoDriver\transactionStart().

◆ connected()

connected ( )

Determines if the connection to the server is active.

Renvoie
boolean True if connected to the database engine.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$limit, DatabaseDriver\$offset, DatabaseDriver\$sql, DatabaseDriver\$statement, PdoDriver\getConnectedQuery(), Joomla\Database\Query\limit(), DatabaseDriver\loadResult(), Joomla\Database\Query\offset(), et DatabaseDriver\setQuery().

Référencé par PdoDriver\execute().

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Method to escape a string for usage in an SQL statement.

Oracle escaping reference: http://www.orafaq.com/wiki/SQL_FAQ#How_does_one_escape_special_characters_when_writing_SQL_queries.3F

SQLite escaping notes: http://www.sqlite.org/faq.html#q14

Method body is as implemented by the Zend Framework

Note: Using query objects with bound variables is preferable to the below.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Unused optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0

Implémente DatabaseInterface.

Références $text.

Référencé par PgsqlDriver\renameTable().

◆ execute()

execute ( )

Execute the SQL statement.

Renvoie
boolean
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$errorMsg, DatabaseDriver\$errorNum, $key, DatabaseDriver\$sql, PdoDriver\connect(), PdoDriver\connected(), null, et DatabaseDriver\replacePrefix().

Référencé par PgsqlDriver\transactionRollback(), MysqlDriver\transactionRollback(), PgsqlDriver\transactionStart(), MysqlDriver\transactionStart(), et PgsqlDriver\updateObject().

◆ getConnectedQuery()

getConnectedQuery ( )

Get a query to run and verify the database is operational.

Renvoie
string The query to check the health of the DB.
Depuis
1.0

Référencé par PdoDriver\connected().

◆ getOption()

getOption ( $key )

Retrieve a PDO database connection attribute https://www.php.net/manual/en/pdo.getattribute.php

Usage: $db->getOption(PDO::ATTR_CASE);

Paramètres
mixed $key One of the PDO::ATTR_* Constants
Renvoie
mixed
Depuis
1.0

Références $key, et PdoDriver\connect().

Référencé par SqliteDriver\getTableColumns(), SqliteDriver\getTableKeys(), MysqlDriver\getVersion(), et PdoDriver\getVersion().

◆ getVersion()

getVersion ( )

Get the version of the database connector.

Renvoie
string The database connector version.
Depuis
1.5.0

Implémente DatabaseInterface.

Références PdoDriver\connect(), et PdoDriver\getOption().

Référencé par PgsqlDriver\getConnectionEncryption().

◆ insertid()

insertid ( )

Method to get the auto-incremented value from the last INSERT statement.

Renvoie
string The value of the auto-increment field from the last inserted row.
Depuis
1.0

Implémente DatabaseInterface.

Références PdoDriver\connect().

Référencé par MysqlDriver\insertObject().

◆ isSupported()

static isSupported ( )
static

Test to see if the PDO extension is available. Override as needed to check for specific PDO Drivers.

Renvoie
boolean True on success, false otherwise.
Depuis
1.0

Implémente DatabaseInterface.

◆ prepareStatement()

prepareStatement ( string $query )
protected

Prepares a SQL statement for execution

Paramètres
string $query The SQL query to be prepared.
Renvoie
StatementInterface
Depuis
2.0.0
Exceptions
PrepareStatementFailureException

Références $query, et $this.

◆ select()

select ( $database )

Select a database for use.

Paramètres
string $database The name of the database to select for use.
Renvoie
boolean True if the database was successfully selected.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PdoDriver\connect().

Référencé par PgsqlDriver\renameTable().

◆ setOption()

setOption | ( | $key,
 |  | $value
 | ) |

Sets an attribute on the PDO database handle. https://www.php.net/manual/en/pdo.setattribute.php

Usage: $db->setOption(PDO::ATTR_CASE, PDO::CASE_UPPER);

Paramètres
integer | $key | One of the PDO::ATTR_* Constants
mixed | $value | One of the associated PDO Constants related to the particular attribute key.
Renvoie
boolean
Depuis
1.0

Références $key, $value, et PdoDriver\connect().

Référencé par PdoDriver\connect(), SqliteDriver\getTableColumns(), et SqliteDriver\getTableKeys().

◆ setUtf()

setUtf ( )

Set the connection to use UTF-8 character encoding.

Renvoie
boolean True on success.
Depuis
1.0

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PdoDriver\connect().

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PdoDriver\connect().

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PdoDriver\connect().

Documentation des champs

◆ $connection

$connection
protected

◆ $name

$name = 'pdo'

◆ $nameQuote

$nameQuote = "'"
protected

◆ $nullDate

$nullDate = '0000-00-00 00:00:00'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PdoDriver.php


Joomla CMS: Référence de la classe PdoQuery

  • Joomla
  • Database
  • Pdo
  • PdoQuery
Fonctions membres publiques | Attributs protégés
Référence de la classe PdoQuery
+ Graphe d'héritage de PdoQuery:
DatabaseQuery QueryInterface PreparableInterface LimitableInterface MysqlQuery PgsqlQuery SqliteQuery

Fonctions membres publiques

castAsChar ($value, $len=null)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres publiques hérités de QueryInterface
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)

Attributs protégés

$nullDatetimeList = ['0000-00-00 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Membres hérités additionnels

- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Description détaillée

PDO Query Building Class.

Depuis
1.0

Documentation des fonctions membres

◆ castAsChar()

castAsChar | ( | $value,
 |  | $len = null
 | ) |

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAsChar('a')); $query->select($query->castAsChar('a', 40));

Paramètres
string | $value | The value to cast as a char.
string | $len | The length of the char.
Renvoie
string Returns the cast value.
Depuis
1.8.0

Références $value.

Documentation des champs

◆ $nullDatetimeList

$nullDatetimeList = ['0000-00-00 00:00:00']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PdoQuery.php


Joomla CMS: Référence de la classe PdoStatement

  • Joomla
  • Database
  • Pdo
  • PdoStatement
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PdoStatement
+ Graphe d'héritage de PdoStatement:
StatementInterface

Fonctions membres publiques

__construct (\PDOStatement $pdoStatement)
bindParam ($parameter, &$variable, string $dataType=ParameterType::STRING, ?int $length=null, ?array $driverOptions=null)
closeCursor ()
errorCode ()
errorInfo ()
execute (?array $parameters=null)
fetch (?int $fetchStyle=null, int $cursorOrientation=FetchOrientation::NEXT, int $cursorOffset=0)
rowCount ()
setFetchMode (int $fetchMode,... $args)

Attributs protégés

$pdoStatement

Fonctions membres privées

convertFetchMode (int $mode)
convertParameterType (string $type)

Attributs privés

const | FETCH_MODE_MAP
const | PARAMETER_TYPE_MAP

Description détaillée

PDO Database Statement.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \PDOStatement $pdoStatement )

Statement constructor

Paramètres
\PDOStatement $pdoStatement The decorated PDOStatement object.
Depuis
2.0.0

Références PdoStatement\$pdoStatement.

Documentation des fonctions membres

◆ bindParam()

bindParam | ( |  | $parameter,
 |  | & | $variable,
 |  | string | $dataType = ParameterType::STRING,
 |  | ?int | $length = null,
 |  | ?array | $driverOptions = null
 | ) |  |

Binds a parameter to the specified variable name.

Paramètres
string | integer | $parameter | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $variable | Name of the PHP variable to bind to the SQL statement parameter.
string | $dataType | Constant corresponding to a SQL datatype, this should be the processed type from the QueryInterface.
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

Références $type, et PdoStatement\convertParameterType().

◆ closeCursor()

closeCursor ( )

Closes the cursor, enabling the statement to be executed again.

Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

◆ convertFetchMode()

convertFetchMode ( int $mode )
private

Converts the database API's fetch mode to a PDO fetch mode

Paramètres
integer $mode Fetch mode to convert
Renvoie
integer
Depuis
2.0.0
Exceptions

Références $mode.

Référencé par PdoStatement\fetch(), et PdoStatement\setFetchMode().

◆ convertParameterType()

convertParameterType ( string $type )
private

Converts the database API's parameter type to a PDO parameter type

Paramètres
string $type Parameter type to convert
Renvoie
integer
Depuis
2.0.0
Exceptions

Références $type.

Référencé par PdoStatement\bindParam().

◆ errorCode()

errorCode ( )

Fetches the SQLSTATE associated with the last operation on the statement handle.

Renvoie
string
Depuis
2.0.0

Implémente StatementInterface.

◆ errorInfo()

errorInfo ( )

Fetches extended error information associated with the last operation on the statement handle.

Renvoie
array
Depuis
2.0.0

Implémente StatementInterface.

◆ execute()

execute ( ?array $parameters = null )

Executes a prepared statement

Paramètres
array | null $parameters An array of values with as many elements as there are bound parameters in the SQL statement being executed.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

Références $parameters.

◆ fetch()

fetch | ( | ?int | $fetchStyle = null,
 |  | int | $cursorOrientation = FetchOrientation::NEXT,
 |  | int | $cursorOffset = 0
 | ) |  |

Fetches the next row from a result set

Paramètres
integer | null | $fetchStyle | Controls how the next row will be returned to the caller. This value must be one of the FetchMode constants, defaulting to value of FetchMode::MIXED.
integer | $cursorOrientation | For a StatementInterface object representing a scrollable cursor, this value determines which row will be returned to the caller. This value must be one of the FetchOrientation constants, defaulting to FetchOrientation::NEXT.
integer | $cursorOffset | For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::ABS, this value specifies the absolute number of the row in the result set that shall be fetched. For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::REL, this value specifies the row to fetch relative to the cursor position before fetch() was called.
Renvoie
mixed The return value of this function on success depends on the fetch type. In all cases, boolean false is returned on failure.
Depuis
2.0.0

Implémente StatementInterface.

Références PdoStatement\convertFetchMode(), et null.

◆ rowCount()

rowCount ( )

Returns the number of rows affected by the last SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémente StatementInterface.

◆ setFetchMode()

setFetchMode | ( | int | $fetchMode,
 |  |  | $args
 | ) |  |

Sets the fetch mode to use while iterating this statement.

Paramètres
integer | $fetchMode | The fetch mode, must be one of the FetchMode constants.
mixed | ...$args Optional mode-specific arguments.
Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

Références PdoStatement\convertFetchMode().

Documentation des champs

◆ $pdoStatement

$pdoStatement
protected

Référencé par PdoStatement\__construct().

◆ FETCH_MODE_MAP

const FETCH_MODE_MAP
private
Valeur initiale :
= [
FetchMode::ASSOCIATIVE => \PDO::FETCH_ASSOC

◆ PARAMETER_TYPE_MAP

const PARAMETER_TYPE_MAP
private
Valeur initiale :
= [
ParameterType::BOOLEAN => \PDO::PARAM_BOOL
La documentation de cette classe a été générée à partir du fichier suivant :
  • PdoStatement.php


Joomla CMS: Référence de la classe PgsqlDriver

  • Joomla
  • Database
  • Pgsql
  • PgsqlDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe PgsqlDriver
+ Graphe d'héritage de PgsqlDriver:
PdoDriver DatabaseDriver DatabaseInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($options)
connect ()
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableCreate ($tables)
getTableColumns ($table, $typeOnly=true)
getTableKeys ($table)
getNamesKey ($table, $indKey)
getTableList ()
getTableSequences ($table)
getSequenceLastValue ($sequence)
getSequenceIsCalled ($sequence)
lockTable ($tableName)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
sqlValue ($columns, $fieldName, $fieldValue)
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
insertObject ($table, &$object, $key=null)
showTables ()
getStringPositionSql ($substring, $string)
getRandom ()
getAlterDbCharacterSet ($dbName)
getCreateDbQuery ($options, $utf)
replacePrefix ($sql, $prefix='#__')
unlockTables ()
updateObject ($table, &$object, $key, $nulls=false)
quoteBinary ($data)
decodeBinary ($data)
- Fonctions membres publiques hérités de PdoDriver
__construct (array $options)
__destruct ()
connect ()
escape ($text, $extra=false)
execute ()
getOption ($key)
getVersion ()
getConnectedQuery ()
setOption ($key, $value)
connected ()
insertid ()
select ($database)
setUtf ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
__sleep ()
__wakeup ()
- Fonctions membres publiques hérités de DatabaseDriver
__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de PdoDriver
static | isSupported ()
- Fonctions membres publiques statiques hérités de DatabaseDriver
static | getInstance (array $options=[])
static | splitSql ($sql)

Champs de données

$name = 'pgsql'
- Champs de données hérités de PdoDriver
$name = 'pdo'
- Champs de données hérités de DatabaseDriver
$serverType

Attributs protégés

$nameQuote = '"'
$nullDate = '1970-01-01 00:00:00'
$concat_operator = '||'
- Attributs protégés hérités de PdoDriver
$connection
$nameQuote = "'"
$nullDate = '0000-00-00 00:00:00'
- Attributs protégés hérités de DatabaseDriver
$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Attributs protégés statiques

static | $dbMinimum = '9.4.0'
- Attributs protégés statiques hérités de DatabaseDriver
static | $connectors = []
static | $instances = []
static | $dbMinimum

Fonctions membres privées

getDefaultSchema ()

Membres hérités additionnels

- Fonctions membres protégées hérités de PdoDriver
prepareStatement (string $query)
- Fonctions membres protégées hérités de DatabaseDriver
dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)

Description détaillée

PostgreSQL PDO Database Driver

Depuis
1.5.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options )

Database object constructor

Paramètres
array $options List of options used to configure the connection
Depuis
1.5.0

Références DatabaseDriver\$options, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\getConnection(), et DatabaseDriver\setQuery().

Référencé par PgsqlDriver\getNamesKey(), PgsqlDriver\getSequenceIsCalled(), PgsqlDriver\getSequenceLastValue(), PgsqlDriver\getTableColumns(), PgsqlDriver\getTableKeys(), PgsqlDriver\renameTable(), PgsqlDriver\transactionCommit(), PgsqlDriver\transactionRollback(), et PgsqlDriver\transactionStart().

◆ decodeBinary()

decodeBinary ( $data )

Replace special placeholder representing binary field with the original string.

Paramètres
string | resource $data Encoded string or resource.
Renvoie
string The original string.
Depuis
1.7.0

Implémente DatabaseInterface.

Références $data.

◆ getAlterDbCharacterSet()

getAlterDbCharacterSet ( $dbName )

Get the query string to alter the database character set.

Paramètres
string $dbName The database name
Renvoie
string The query that alter the database query string
Depuis
1.5.0

Références DatabaseDriver\quote(), et DatabaseDriver\quoteName().

◆ getCollation()

getCollation ( )

Method to get the database collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database or boolean false if not supported.
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\loadAssocList(), et DatabaseDriver\setQuery().

◆ getConnectionCollation()

getConnectionCollation ( )

Method to get the database connection collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database connection (string) or boolean false if not supported.
Depuis
1.6.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\loadAssocList(), et DatabaseDriver\setQuery().

◆ getConnectionEncryption()

getConnectionEncryption ( )

Method to get the database encryption details (cipher and protocol) in use.

Renvoie
string The database encryption details.
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $query, DatabaseDriver\getQuery(), PdoDriver\getVersion(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getCreateDbQuery()

getCreateDbQuery | ( | $options,
 |  | $utf
 | ) |

Get the query string to create new Database in correct PostgreSQL syntax.

Paramètres
object | $options | object coming from "initialise" function to pass user and database name to database driver.
boolean | $utf | True if the database supports the UTF-8 character set, not used in PostgreSQL "CREATE DATABASE" query.
Renvoie
string The query that creates database, owned by $options['user']
Depuis
1.5.0

Références DatabaseDriver\$options, $query, DatabaseDriver\$utf, DatabaseDriver\quote(), et DatabaseDriver\quoteName().

◆ getDefaultSchema()

getDefaultSchema ( )
private

Internal function to get the name of the default schema for the current PostgreSQL connection. That is the schema where tables are created by Joomla.

Renvoie
string
Depuis
1.8.0

Références DatabaseDriver\loadResult(), et DatabaseDriver\setQuery().

Référencé par PgsqlDriver\getTableColumns().

◆ getNamesKey()

getNamesKey | ( | $table,
 |  | $indKey
 | ) |

Get the list of column names this index indexes.

Paramètres
string | $table | The name of the table.
string | $indKey | The list of column numbers for the table
Renvoie
string A list of the column names for the table.
Depuis
2.0.0
Exceptions

Références $query, PgsqlDriver\connect(), DatabaseDriver\getQuery(), DatabaseDriver\loadResult(), DatabaseDriver\quote(), PgsqlDriver\replacePrefix(), et DatabaseDriver\setQuery().

◆ getRandom()

getRandom ( )

Generate a random value

Renvoie
float The random generated number
Depuis
1.5.0

Références DatabaseDriver\loadAssoc(), et DatabaseDriver\setQuery().

◆ getSequenceIsCalled()

getSequenceIsCalled ( $sequence )

Method to get the is_called attribute of a sequence.

Paramètres
string $sequence The name of the sequence.
Renvoie
boolean The is_called attribute of the sequence.
Depuis
2.0.0
Exceptions

Références $query, PgsqlDriver\connect(), DatabaseDriver\getQuery(), DatabaseDriver\loadResult(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getSequenceLastValue()

getSequenceLastValue ( $sequence )

Method to get the last value of a sequence in the database.

Paramètres
string $sequence The name of the sequence.
Renvoie
integer The last value of the sequence.
Depuis
2.0.0
Exceptions

Références $query, PgsqlDriver\connect(), DatabaseDriver\getQuery(), DatabaseDriver\loadResult(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ getStringPositionSql()

getStringPositionSql | ( | $substring,
 |  | $string
 | ) |

Get the substring position inside a string

Paramètres
string | $substring | The string being sought
string | $string | The string/column being searched
Renvoie
integer The position of $substring in $string
Depuis
1.5.0

Références $position, DatabaseDriver\loadRow(), et DatabaseDriver\setQuery().

◆ getTableColumns()

getTableColumns | ( | $table,
 |  | $typeOnly = true
 | ) |

Retrieves field information about a given table.

Paramètres
string | $table | The name of the database table.
boolean | $typeOnly | True to only return field types.
Renvoie
array An array of fields for the database table.
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $field, $fields, $result, PgsqlDriver\connect(), PgsqlDriver\getDefaultSchema(), DatabaseDriver\loadObjectList(), null, DatabaseDriver\quote(), PgsqlDriver\replacePrefix(), et DatabaseDriver\setQuery().

Référencé par PgsqlDriver\insertObject(), et PgsqlDriver\updateObject().

◆ getTableCreate()

getTableCreate ( $tables )

Shows the table CREATE statement that creates the given tables.

This is unsupported by PostgreSQL.

Paramètres
mixed $tables A table name or a list of table names.
Renvoie
string An empty string because this function is not supported by PostgreSQL.
Depuis
1.5.0
Exceptions

◆ getTableKeys()

getTableKeys ( $table )

Get the details list of keys for a table.

Paramètres
string $table The name of the table.
Renvoie
array An array of the column specification for the table.
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références PgsqlDriver\connect(), PgsqlDriver\getTableList(), DatabaseDriver\loadObjectList(), DatabaseDriver\quote(), PgsqlDriver\replacePrefix(), et DatabaseDriver\setQuery().

◆ getTableList()

getTableList ( )

Method to get an array of all tables in the database.

Renvoie
array An array of all the tables in the database.
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $query, DatabaseDriver\getQuery(), DatabaseDriver\loadColumn(), DatabaseDriver\quote(), et DatabaseDriver\setQuery().

Référencé par PgsqlDriver\getTableKeys(), PgsqlDriver\getTableSequences(), et PgsqlDriver\renameTable().

◆ getTableSequences()

getTableSequences ( $table )

Get the details list of sequences for a table.

Paramètres
string $table The name of the table.
Renvoie
array An array of sequences specification for the table.
Depuis
1.5.0
Exceptions

Références PgsqlDriver\$name, $query, DatabaseDriver\getQuery(), PgsqlDriver\getTableList(), DatabaseDriver\loadObjectList(), DatabaseDriver\quote(), DatabaseDriver\quoteName(), PgsqlDriver\replacePrefix(), et DatabaseDriver\setQuery().

◆ insertObject()

insertObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key = null
 | ) |  |

Inserts a row into a table based on an object's properties.

Paramètres
string | $table | The name of the database table to insert into.
object | $object | A reference to an object whose public properties match the table fields.
string | $key | The name of the primary key. If provided the object property is updated.
Renvoie
boolean True on success.
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $columns, $fields, $key, $query, DatabaseDriver\getQuery(), PgsqlDriver\getTableColumns(), null, DatabaseDriver\quoteName(), DatabaseDriver\setQuery(), et PgsqlDriver\sqlValue().

◆ isConnectionEncryptionSupported()

isConnectionEncryptionSupported ( )

Method to test if the database TLS connections encryption are supported.

Renvoie
boolean Whether the database supports TLS connections encryption.
Depuis
2.0.0

Implémente DatabaseInterface.

Références DatabaseDriver\setQuery().

◆ isSupported()

static isSupported ( )
static

Test to see if the PostgreSQL connector is available.

Renvoie
boolean True on success, false otherwise.
Depuis
1.5.0

Implémente DatabaseInterface.

◆ lockTable()

lockTable ( $tableName )

Locks a table in the database.

Paramètres
string $tableName The name of the table to unlock.
Renvoie
$this
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $this, DatabaseDriver\quoteName(), DatabaseDriver\setQuery(), et PgsqlDriver\transactionStart().

◆ quoteBinary()

quoteBinary ( $data )

Quotes a binary string to database requirements for use in database queries.

Paramètres
string $data A binary string to quote.
Renvoie
string The binary quoted input string.
Depuis
1.7.0

Implémente DatabaseInterface.

Références $data.

◆ renameTable()

renameTable | ( | $oldTable,
 |  | $newTable,
 |  | $backup = null,
 |  | $prefix = null
 | ) |

Renames a table in the database.

Paramètres
string | $oldTable | The name of the table to be renamed
string | $newTable | The new name for the table.
string | $backup | Not used by PostgreSQL.
string | $prefix | Not used by PostgreSQL.
Renvoie
$this
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $this, PgsqlDriver\connect(), PdoDriver\escape(), DatabaseDriver\getQuery(), PgsqlDriver\getTableList(), DatabaseDriver\loadColumn(), DatabaseDriver\quote(), PgsqlDriver\replacePrefix(), PdoDriver\select(), et DatabaseDriver\setQuery().

◆ replacePrefix()

replacePrefix | ( | $sql,
 |  | $prefix = '#__'
 | ) |

This function replaces a string identifier with the configured table prefix.

Paramètres
string | $sql | The SQL statement to prepare.
string | $prefix | The table prefix.
Renvoie
string The processed SQL statement.
Depuis
1.5.0

Implémente DatabaseInterface.

Références $prefix, et DatabaseDriver\$sql.

Référencé par PgsqlDriver\getNamesKey(), PgsqlDriver\getTableColumns(), PgsqlDriver\getTableKeys(), PgsqlDriver\getTableSequences(), et PgsqlDriver\renameTable().

◆ showTables()

showTables ( )

Returns an array containing database's table list.

Renvoie
array The database's table list.
Depuis
1.5.0

Références $query, DatabaseDriver\getQuery(), DatabaseDriver\loadColumn(), DatabaseDriver\quote(), et DatabaseDriver\setQuery().

◆ sqlValue()

sqlValue | ( | $columns,
 |  | $fieldName,
 |  | $fieldValue
 | ) |

This function return a field value as a prepared string to be used in a SQL statement.

Paramètres
array | $columns | Array of table's column returned by ::getTableColumns.
string | $fieldName | The table field's name.
string | $fieldValue | The variable value to quote and return.
Renvoie
string The quoted string.
Depuis
1.5.0

Références $columns, $fieldValue, $val, elseif, DatabaseDriver\getNullDate(), et DatabaseDriver\quote().

Référencé par PgsqlDriver\insertObject(), et PgsqlDriver\updateObject().

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PgsqlDriver\connect().

Référencé par PgsqlDriver\unlockTables().

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références PgsqlDriver\connect(), PdoDriver\execute(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$transactionDepth, PgsqlDriver\connect(), PdoDriver\execute(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

Référencé par PgsqlDriver\lockTable().

◆ unlockTables()

unlockTables ( )

Unlocks tables in the database, this command does not exist in PostgreSQL, it is automatically done on commit or rollback.

Renvoie
$this
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $this, et PgsqlDriver\transactionCommit().

◆ updateObject()

updateObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key,
 |  |  | $nulls = false
 | ) |  |

Updates a row in a table based on an object's properties.

Paramètres
string | $table | The name of the database table to update.
object | $object | A reference to an object whose public properties match the table fields.
array | string | $key | The name of the primary key.
boolean | $nulls | True to update null fields or false to ignore them.
Renvoie
boolean
Depuis
1.5.0
Exceptions

Implémente DatabaseInterface.

Références $columns, $fields, $key, DatabaseDriver\$statement, $val, PdoDriver\execute(), PgsqlDriver\getTableColumns(), null, DatabaseDriver\quoteName(), DatabaseDriver\setQuery(), et PgsqlDriver\sqlValue().

Documentation des champs

◆ $concat_operator

$concat_operator = '||'
protected

◆ $dbMinimum

$dbMinimum = '9.4.0'
staticprotected

◆ $name

$name = 'pgsql'

Référencé par PgsqlDriver\getTableSequences().

◆ $nameQuote

$nameQuote = '"'
protected

◆ $nullDate

$nullDate = '1970-01-01 00:00:00'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PgsqlDriver.php


Joomla CMS: Référence de la classe PgsqlExporter

  • Joomla
  • Database
  • Pgsql
  • PgsqlExporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PgsqlExporter
+ Graphe d'héritage de PgsqlExporter:
DatabaseExporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseExporter
__construct ()
__toString ()
asXml ()
check ()
from ($from)
setDbo (DatabaseInterface $db)
withStructure ($setting=true)
withData ($setting=false)

Fonctions membres protégées

buildXml ()
buildXmlStructure ()
buildXmlData ()
- Fonctions membres protégées hérités de DatabaseExporter
buildXml ()
buildXmlStructure ()
getGenericTableName ($table)
buildXmlData ()

Membres hérités additionnels

- Attributs protégés hérités de DatabaseExporter
$asFormat = 'xml'
$cache = ['columns' => []
$db
$from = []
$options

Description détaillée

PDO PostgreSQL Database Exporter.

Depuis
1.5.0

Documentation des fonctions membres

◆ buildXml()

buildXml ( )
protected

Builds the XML data for the tables to export.

Renvoie
string An XML string
Depuis
1.0
Exceptions

Références $buffer, PgsqlExporter\buildXmlData(), et PgsqlExporter\buildXmlStructure().

◆ buildXmlData()

buildXmlData ( )
protected

Builds the XML data to export.

Renvoie
array An array of XML lines (strings).
Depuis
2.0.0
Exceptions

Référencé par PgsqlExporter\buildXml().

◆ buildXmlStructure()

buildXmlStructure ( )
protected

Builds the XML structure to export.

Renvoie
array An array of XML lines (strings).
Depuis
1.0
Exceptions

Références $buffer, $field, $fields, $key, DatabaseExporter\from(), et DatabaseExporter\getGenericTableName().

Référencé par PgsqlExporter\buildXml().

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.5.0
Exceptions
La documentation de cette classe a été générée à partir du fichier suivant :
  • PgsqlExporter.php


Joomla CMS: Référence de la classe PgsqlImporter

  • Joomla
  • Database
  • Pgsql
  • PgsqlImporter
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PgsqlImporter
+ Graphe d'héritage de PgsqlImporter:
DatabaseImporter

Fonctions membres publiques

check ()
- Fonctions membres publiques hérités de DatabaseImporter
__construct ()
asXml ()
check ()
from ($from)
importData ()
mergeStructure ()
setDbo (DatabaseInterface $db)
withStructure ($setting=true)

Fonctions membres protégées

getAddIndexSql (\SimpleXMLElement $field)
getAlterTableSql (\SimpleXMLElement $structure)
getDropSequenceSql ($name)
getAddSequenceSql (\SimpleXMLElement $field)
getChangeSequenceSql (\SimpleXMLElement $field)
getSetvalSequenceSql ($field)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getAlterColumnSql ($table, \SimpleXMLElement $field)
getColumnSql (\SimpleXMLElement $field)
getDropIndexSql ($name)
getDropPrimaryKeySql ($table, $name)
getKeyLookup ($keys)
getAddUniqueSql ($table, $key)
getSeqLookup ($sequences)
xmlToCreate (\SimpleXMLElement $table)
- Fonctions membres protégées hérités de DatabaseImporter
getAddColumnSql ($table, \SimpleXMLElement $field)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getDropColumnSql ($table, $name)
getKeyLookup ($keys)
getRealTableName ($table)
xmlToCreate (\SimpleXMLElement $table)

Membres hérités additionnels

- Attributs protégés hérités de DatabaseImporter
$cache = ['columns' => []
$db
$from = []
$asFormat = 'xml'
$options

Description détaillée

PDO PostgreSQL Database Importer.

Depuis
1.5.0

Documentation des fonctions membres

◆ check()

check ( )

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.5.0
Exceptions

Références $this, et DatabaseImporter\from().

◆ getAddIndexSql()

getAddIndexSql ( \SimpleXMLElement $field )
protected

Get the SQL syntax to add an index.

Paramètres
\SimpleXMLElement $field The XML index definition.
Renvoie
string
Depuis
1.0

Références $field.

◆ getAddSequenceSql()

getAddSequenceSql ( \SimpleXMLElement $field )
protected

Get the syntax to add a sequence.

Paramètres
\SimpleXMLElement $field The XML definition for the sequence.
Renvoie
string
Depuis
1.0

Références $field, et $sql.

Référencé par PgsqlImporter\getAlterTableSql().

◆ getAddUniqueSql()

getAddUniqueSql | ( | $table,
 |  | $key
 | ) |
protected

Get the SQL syntax to add a unique constraint for a table key.

Paramètres
string | $table | The table name.
array | $key | The key.
Renvoie
string
Depuis
2.0.0

◆ getAlterColumnSql()

getAlterColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the SQL syntax for a single column that would be included in a table create statement.

Paramètres
string | $table | The name of the database table to alter.
\SimpleXMLElement | $field | The XML field definition.
Renvoie
string
Depuis
1.0

◆ getAlterTableSql()

getAlterTableSql ( \SimpleXMLElement $structure )
protected

Get alters for table if there is a difference.

Paramètres
\SimpleXMLElement $structure The XML structure of the table.
Renvoie
array
Depuis
1.0

Références $field, $i, $name, DatabaseImporter\getAddColumnSql(), PgsqlImporter\getAddSequenceSql(), PgsqlImporter\getChangeColumnSql(), PgsqlImporter\getChangeSequenceSql(), DatabaseImporter\getDropColumnSql(), PgsqlImporter\getDropIndexSql(), PgsqlImporter\getDropPrimaryKeySql(), PgsqlImporter\getDropSequenceSql(), PgsqlImporter\getKeyLookup(), DatabaseImporter\getRealTableName(), PgsqlImporter\getSeqLookup(), et PgsqlImporter\getSetvalSequenceSql().

◆ getChangeColumnSql()

getChangeColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the syntax to alter a column.

Paramètres
string | $table | The name of the database table to alter.
\SimpleXMLElement | $field | The XML definition for the field.
Renvoie
string
Depuis
1.0

Référencé par PgsqlImporter\getAlterTableSql().

◆ getChangeSequenceSql()

getChangeSequenceSql ( \SimpleXMLElement $field )
protected

Get the syntax to alter a sequence.

Paramètres
\SimpleXMLElement $field The XML definition for the sequence.
Renvoie
string
Depuis
1.0

Références $field, et $sql.

Référencé par PgsqlImporter\getAlterTableSql().

◆ getColumnSql()

getColumnSql ( \SimpleXMLElement $field )
protected

Get the SQL syntax for a single column that would be included in a table create statement.

Paramètres
\SimpleXMLElement $field The XML field definition.
Renvoie
string
Depuis
1.0

◆ getDropIndexSql()

getDropIndexSql ( $name )
protected

Get the SQL syntax to drop an index.

Paramètres
string $name The name of the key to drop.
Renvoie
string
Depuis
1.0

Référencé par PgsqlImporter\getAlterTableSql().

◆ getDropPrimaryKeySql()

getDropPrimaryKeySql | ( | $table,
 |  | $name
 | ) |
protected

Get the SQL syntax to drop a key.

Paramètres
string | $table | The table name.
string | $name | The constraint name.
Renvoie
string
Depuis
1.0

Référencé par PgsqlImporter\getAlterTableSql().

◆ getDropSequenceSql()

getDropSequenceSql ( $name )
protected

Get the SQL syntax to drop a sequence.

Paramètres
string $name The name of the sequence to drop.
Renvoie
string
Depuis
1.0

Références $name.

Référencé par PgsqlImporter\getAlterTableSql().

◆ getKeyLookup()

getKeyLookup ( $keys )
protected

Get the details list of keys for a table.

Paramètres
array $keys An array of objects that comprise the keys for the table.
Renvoie
array The lookup array. array({key name} => array(object, ...))
Depuis
1.2.0

Référencé par PgsqlImporter\getAlterTableSql().

◆ getSeqLookup()

getSeqLookup ( $sequences )
protected

Get the details list of sequences for a table.

Paramètres
array $sequences An array of objects that comprise the sequences for the table.
Renvoie
array The lookup array. array({key name} => array(object, ...))
Depuis
1.0

Référencé par PgsqlImporter\getAlterTableSql().

◆ getSetvalSequenceSql()

getSetvalSequenceSql ( $field )
protected

Get the syntax to setval a sequence.

Paramètres
\SimpleXMLElement $field The XML definition for the sequence.
Renvoie
string
Depuis
2.0.0

Références $field.

Référencé par PgsqlImporter\getAlterTableSql().

◆ xmlToCreate()

xmlToCreate ( \SimpleXMLElement $table )
protected

Get the SQL syntax to add a table.

Paramètres
\SimpleXMLElement $table The table information.
Renvoie
string
Depuis
2.0.0
Exceptions
La documentation de cette classe a été générée à partir du fichier suivant :
  • PgsqlImporter.php


Joomla CMS: Référence de la classe PgsqlQuery

  • Joomla
  • Database
  • Pgsql
  • PgsqlQuery
Fonctions membres publiques | Attributs protégés
Référence de la classe PgsqlQuery
+ Graphe d'héritage de PgsqlQuery:
PdoQuery DatabaseQuery QueryInterface PreparableInterface LimitableInterface

Fonctions membres publiques

castAsChar ($value, $length=null)
- Fonctions membres publiques hérités de PdoQuery
castAsChar ($value, $len=null)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres publiques hérités de QueryInterface
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)

Attributs protégés

$nullDatetimeList = ['1970-01-01 00:00:00']
- Attributs protégés hérités de PdoQuery
$nullDatetimeList = ['0000-00-00 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Membres hérités additionnels

- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Documentation des fonctions membres

◆ castAsChar()

castAsChar | ( | $value,
 |  | $length = null
 | ) |

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAsChar('a')); $query->select($query->castAsChar('a', 40));

Paramètres
string | $value | The value to cast as a char.
string | $length | The length of the char.
Renvoie
string Returns the cast value.
Depuis
1.8.0

Références $value.

Documentation des champs

◆ $nullDatetimeList

$nullDatetimeList = ['1970-01-01 00:00:00']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PgsqlQuery.php


Joomla CMS: Référence de l'interface LimitableInterface

  • Joomla
  • Database
  • Query
  • LimitableInterface
Fonctions membres publiques
Référence de l'interface LimitableInterface
+ Graphe d'héritage de LimitableInterface:
QueryInterface DatabaseQuery MysqliQuery PdoQuery SqlsrvQuery MysqlQuery PgsqlQuery SqliteQuery SqlazureQuery

Fonctions membres publiques

processLimit ($query, $limit, $offset=0)
setLimit ($limit=0, $offset=0)

Description détaillée

Joomla Database Query LimitableInterface.

Depuis
1.0
Obsolète:
3.0 Capabilities will be required in Joomla

Documentation des fonctions membres

◆ processLimit()

processLimit | ( | $query,
 |  | $limit,
 |  | $offset = 0
 | ) |

Method to modify a query already in string format with the needed additions to make the query limited to a particular number of results, or start at a particular offset.

Paramètres
string | $query | The query in string format
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
string
Depuis
1.0

Implémenté dans SqlsrvQuery, et SqliteQuery.

Référencé par DatabaseQuery\__toString().

◆ setLimit()

setLimit | ( | $limit = 0,
 |  | $offset = 0
 | ) |

Sets the offset and limit for the result set, if the database driver supports it.

Usage: $query->setLimit(100, 0); (retrieve 100 rows, starting at first record) $query->setLimit(50, 50); (retrieve 50 rows, starting at 50th record)

Paramètres
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
$this
Depuis
1.0

Implémenté dans DatabaseQuery.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LimitableInterface.php


Joomla CMS: Référence de l'interface PreparableInterface

  • Joomla
  • Database
  • Query
  • PreparableInterface
Fonctions membres publiques
Référence de l'interface PreparableInterface
+ Graphe d'héritage de PreparableInterface:
QueryInterface DatabaseQuery MysqliQuery PdoQuery SqlsrvQuery MysqlQuery PgsqlQuery SqliteQuery SqlazureQuery

Fonctions membres publiques

bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
& getBounded ($key=null)

Description détaillée

Joomla Database Query Preparable Interface.

Adds bind/unbind methods as well as a getBounded() method to retrieve the stored bounded variables on demand prior to query execution.

Depuis
1.0
Obsolète:
3.0 Capabilities will be required in Joomla

Documentation des fonctions membres

◆ bind()

bind | ( |  | $key,
 |  | & | $value,
 |  |  | $dataType = ParameterType::STRING,
 |  |  | $length = 0,
 |  |  | $driverOptions = []
 | ) |  |

Method to add a variable to an internal array that will be bound to a prepared SQL statement before query execution.

Paramètres
array | string | integer | $key | The key that will be used in your SQL query to reference the value. Usually of the form ':key', but can also be an integer.
mixed | $value | The value that will be bound. It can be an array, in this case it has to be same length of $key; The value is passed by reference to support output parameters such as those possible with stored procedures.
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $key
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
$this
Depuis
1.0

Implémenté dans DatabaseQuery.

◆ getBounded()

& getBounded ( $key = null )

Retrieves the bound parameters array when key is null and returns it by reference. If a key is provided then that item is returned.

Paramètres
mixed $key The bounded variable key to retrieve.
Renvoie
mixed
Depuis
1.0

Implémenté dans DatabaseQuery.

◆ unbind()

unbind ( $key )

Method to unbind a bound variable.

Paramètres
array | string | integer $key The key or array of keys to unbind.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

La documentation de cette interface a été générée à partir du fichier suivant :
  • PreparableInterface.php


Joomla CMS: Référence de la classe QueryElement

  • Joomla
  • Database
  • Query
  • QueryElement
Fonctions membres publiques | Attributs protégés
Référence de la classe QueryElement

Fonctions membres publiques

__construct ($name, $elements, $glue=',')
__toString ()
append ($elements)
getElements ()
getGlue ()
getName ()
setName ($name)
__clone ()

Attributs protégés

$name
$elements = []
$glue

Description détaillée

Query Element Class.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $name,
 |  | $elements,
 |  | $glue = ','
 | ) |

Constructor.

Paramètres
string | $name | The name of the element.
string[]|string | $elements String or array.
string | $glue | The glue for elements.
Depuis
1.0

Références QueryElement\$elements, QueryElement\$glue, QueryElement\$name, QueryElement\append(), et name.

Documentation des fonctions membres

◆ __clone()

__clone ( )

Method to provide basic copy support.

Any object pushed into the data of this class should have its own __clone() implementation. This method does not support copying objects in a multidimensional array.

Renvoie
void
Depuis
1.0

Références $i, $this, et elseif.

◆ __toString()

__toString ( )

Magic function to convert the query element to a string.

Renvoie
string
Depuis
1.0

Références name.

◆ append()

append ( $elements )

Appends element parts to the internal list.

Paramètres
string[]|string $elements String or array.
Renvoie
void
Depuis
1.0

Références QueryElement\$elements.

Référencé par QueryElement\__construct().

◆ getElements()

getElements ( )

Gets the elements of this element.

Renvoie
string[]
Depuis
1.0

Références QueryElement\$elements.

◆ getGlue()

getGlue ( )

Gets the glue of this element.

Renvoie
string Glue of the element.
Depuis
2.0.0

Références QueryElement\$glue.

◆ getName()

getName ( )

Gets the name of this element.

Renvoie
string Name of the element.
Depuis
1.7.0

Références QueryElement\$name.

◆ setName()

setName ( $name )

Sets the name of this element.

Paramètres
string $name Name of the element.
Renvoie
$this
Depuis
1.3.0

Références QueryElement\$name, $this, et name.

Documentation des champs

◆ $elements

$elements = []
protected

Référencé par QueryElement\__construct(), QueryElement\append(), et QueryElement\getElements().

◆ $glue

$glue
protected

Référencé par QueryElement\__construct(), et QueryElement\getGlue().

◆ $name

$name
protected

Référencé par QueryElement\__construct(), QueryElement\getName(), et QueryElement\setName().

La documentation de cette classe a été générée à partir du fichier suivant :
  • QueryElement.php


Joomla CMS: Référence de la classe DatabaseProvider

  • Joomla
  • Database
  • Service
  • DatabaseProvider
Référence de la classe DatabaseProvider
+ Graphe d'héritage de DatabaseProvider:
ServiceProviderInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de ServiceProviderInterface
register (Container $container)

Description détaillée

Database service provider

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseProvider.php


Joomla CMS: Référence de la classe SqlazureDriver

  • Joomla
  • Database
  • Sqlazure
  • SqlazureDriver
Champs de données
Référence de la classe SqlazureDriver
+ Graphe d'héritage de SqlazureDriver:

Champs de données

$name = 'sqlazure'

Description détaillée

SQL Azure Database Driver

1.0

Documentation des champs

◆ $name

$name = 'sqlazure'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlazureDriver.php


Joomla CMS: Référence de la classe SqlazureQuery

  • Joomla
  • Database
  • Sqlazure
  • SqlazureQuery
Référence de la classe SqlazureQuery
+ Graphe d'héritage de SqlazureQuery:
SqlsrvQuery DatabaseQuery QueryInterface PreparableInterface LimitableInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de SqlsrvQuery
__toString ()
castAs (string $type, string $value, ?string $length=null)
charLength ($field, $operator=null, $condition=null)
concatenate ($values, $separator=null)
currentTimestamp ()
length ($value)
group ($columns)
groupConcat ($expression, $separator=',')
rand ()
findInSet ($value, $set)
processLimit ($query, $limit, $offset=0)
union ($query, $distinct=true)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres protégées hérités de SqlsrvQuery
fixSelectAliases ()
fixGroupColumns ($selectColumns)
splitSqlExpression ($string)
- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)
- Attributs protégés hérités de SqlsrvQuery
$nullDatetimeList = ['1900-01-01 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Description détaillée

SQL Azure Query Building Class.

Depuis
1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlazureQuery.php


Joomla CMS: Référence de la classe SqliteDriver

  • Joomla
  • Database
  • Sqlite
  • SqliteDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés
Référence de la classe SqliteDriver
+ Graphe d'héritage de SqliteDriver:
PdoDriver DatabaseDriver DatabaseInterface DispatcherAwareInterface

Fonctions membres publiques

__destruct ()
alterDbCharacterSet ($dbName)
connect ()
createDatabase ($options, $utf=true)
escape ($text, $extra=false)
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableCreate ($tables)
getTableColumns ($table, $typeOnly=true)
getTableKeys ($table)
getTableList ()
getVersion ()
select ($database)
setUtf ()
lockTable ($table)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
truncateTable ($table)
unlockTables ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
- Fonctions membres publiques hérités de PdoDriver
__construct (array $options)
__destruct ()
connect ()
escape ($text, $extra=false)
execute ()
getOption ($key)
getVersion ()
getConnectedQuery ()
setOption ($key, $value)
connected ()
insertid ()
select ($database)
setUtf ()
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
__sleep ()
__wakeup ()
- Fonctions membres publiques hérités de DatabaseDriver
__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | isSupported ()
- Fonctions membres publiques statiques hérités de PdoDriver
static | isSupported ()
- Fonctions membres publiques statiques hérités de DatabaseDriver
static | getInstance (array $options=[])
static | splitSql ($sql)

Champs de données

$name = 'sqlite'
- Champs de données hérités de PdoDriver
$name = 'pdo'
- Champs de données hérités de DatabaseDriver
$serverType

Attributs protégés

$nameQuote = '`'
- Attributs protégés hérités de PdoDriver
$connection
$nameQuote = "'"
$nullDate = '0000-00-00 00:00:00'
- Attributs protégés hérités de DatabaseDriver
$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Membres hérités additionnels

- Fonctions membres protégées hérités de PdoDriver
prepareStatement (string $query)
- Fonctions membres protégées hérités de DatabaseDriver
dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)
- Attributs protégés statiques hérités de DatabaseDriver
static | $connectors = []
static | $instances = []
static | $dbMinimum

Description détaillée

SQLite database driver supporting PDO based connections

1.0

Documentation des constructeurs et destructeur

◆ __destruct()

__destruct ( )

Destructor.

Depuis
1.0

Références DatabaseDriver\disconnect().

Documentation des fonctions membres

◆ alterDbCharacterSet()

alterDbCharacterSet ( $dbName )

Alter database's character set.

Paramètres
string $dbName The database name that will be altered
Renvoie
boolean|resource
Depuis
2.0.0
Exceptions

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void Returns void if the database connected successfully.
Depuis
2.0.0
Exceptions
RuntimeException

Implémente DatabaseInterface.

Références null.

Référencé par SqliteDriver\getTableColumns(), SqliteDriver\getTableCreate(), SqliteDriver\getTableKeys(), SqliteDriver\getTableList(), SqliteDriver\getVersion(), SqliteDriver\select(), SqliteDriver\setUtf(), SqliteDriver\transactionCommit(), SqliteDriver\transactionRollback(), et SqliteDriver\transactionStart().

◆ createDatabase()

createDatabase | ( | $options,
 |  | $utf = true
 | ) |

Create a new database using information from $options object.

Paramètres
\stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
boolean|resource
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Method to escape a string for usage in an SQLite statement.

Note: Using query objects with bound variables is preferable to the below.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Unused optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0

Implémente DatabaseInterface.

Références $text.

◆ getCollation()

getCollation ( )

Method to get the database collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database or boolean false if not supported.
Depuis
1.0

Implémente DatabaseInterface.

◆ getConnectionCollation()

getConnectionCollation ( )

Method to get the database connection collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database connection (string) or boolean false if not supported.
Depuis
1.6.0
Exceptions

Implémente DatabaseInterface.

◆ getConnectionEncryption()

getConnectionEncryption ( )

Method to get the database encryption details (cipher and protocol) in use.

Renvoie
string The database encryption details.
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

◆ getTableColumns()

getTableColumns | ( | $table,
 |  | $typeOnly = true
 | ) |

Retrieves field information about a given table.

Paramètres
string | $table | The name of the database table.
boolean | $typeOnly | True to only return field types.
Renvoie
array An array of fields for the database table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $columns, $field, $fields, SqliteDriver\connect(), PdoDriver\getOption(), PdoDriver\setOption(), et DatabaseDriver\setQuery().

◆ getTableCreate()

getTableCreate ( $tables )

Shows the table CREATE statement that creates the given tables.

Note: Doesn't appear to have support in SQLite

Paramètres
mixed $tables A table name or a list of table names.
Renvoie
array A list of the create SQL for the tables.
Depuis
1.0
Exceptions

Références SqliteDriver\connect().

◆ getTableKeys()

getTableKeys ( $table )

Get the details list of keys for a table.

Paramètres
string $table The name of the table.
Renvoie
array An array of the column specification for the table.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $rows, SqliteDriver\connect(), PdoDriver\getOption(), PdoDriver\setOption(), et DatabaseDriver\setQuery().

◆ getTableList()

getTableList ( )

Method to get an array of all tables in the database (schema).

Renvoie
array An array of all the tables in the database.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $query, $type, SqliteDriver\connect(), DatabaseDriver\getQuery(), et DatabaseDriver\setQuery().

◆ getVersion()

getVersion ( )

Get the version of the database connector.

Renvoie
string The database connector version.
Depuis
1.0

Implémente DatabaseInterface.

Références SqliteDriver\connect(), et DatabaseDriver\setQuery().

◆ isConnectionEncryptionSupported()

isConnectionEncryptionSupported ( )

Method to test if the database TLS connections encryption are supported.

Renvoie
boolean Whether the database supports TLS connections encryption.
Depuis
2.0.0

Implémente DatabaseInterface.

◆ isSupported()

static isSupported ( )
static

Test to see if the PDO ODBC connector is available.

Renvoie
boolean True on success, false otherwise.
Depuis
1.0

Implémente DatabaseInterface.

◆ lockTable()

lockTable ( $table )

Locks a table in the database.

Paramètres
string $table The name of the table to unlock.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this.

◆ renameTable()

renameTable | ( | $oldTable,
 |  | $newTable,
 |  | $backup = null,
 |  | $prefix = null
 | ) |

Renames a table in the database.

Paramètres
string | $oldTable | The name of the table to be renamed
string | $newTable | The new name for the table.
string | $backup | Not used by Sqlite.
string | $prefix | Not used by Sqlite.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this, et DatabaseDriver\setQuery().

◆ select()

select ( $database )

Select a database for use.

Paramètres
string $database The name of the database to select for use.
Renvoie
boolean True if the database was successfully selected.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références SqliteDriver\connect().

◆ setUtf()

setUtf ( )

Set the connection to use UTF-8 character encoding.

Returns false automatically for the Oracle driver since you can only set the character set when the connection is created.

Renvoie
boolean True on success.
Depuis
1.0

Références SqliteDriver\connect().

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références SqliteDriver\connect().

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références SqliteDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\$transactionDepth, SqliteDriver\connect(), DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ truncateTable()

truncateTable ( $table )

Method to truncate a table.

Paramètres
string $table The table to truncate
Renvoie
void
Depuis
1.2.1
Exceptions

Implémente DatabaseInterface.

Références DatabaseDriver\quoteName(), et DatabaseDriver\setQuery().

◆ unlockTables()

unlockTables ( )

Unlocks tables in the database.

Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $this.

Documentation des champs

◆ $name

$name = 'sqlite'

◆ $nameQuote

$nameQuote = '`'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqliteDriver.php


Joomla CMS: Référence de la classe SqliteQuery

  • Joomla
  • Database
  • Sqlite
  • SqliteQuery
Fonctions membres publiques
Référence de la classe SqliteQuery
+ Graphe d'héritage de SqliteQuery:
PdoQuery DatabaseQuery QueryInterface PreparableInterface LimitableInterface

Fonctions membres publiques

__toString ()
charLength ($field, $operator=null, $condition=null)
concatenate ($values, $separator=null)
processLimit ($query, $limit, $offset=0)
selectRowNumber ($orderBy, $orderColumnAlias)
union ($query, $distinct=true)
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de PdoQuery
castAsChar ($value, $len=null)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)

Membres hérités additionnels

- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)
- Attributs protégés hérités de PdoQuery
$nullDatetimeList = ['0000-00-00 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Description détaillée

SQLite Query Building Class.

Depuis
1.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic function to convert the query to a string.

Renvoie
string The completed query.
Depuis
2.0.0

Implémente QueryInterface.

Références DatabaseQuery\$db, DatabaseQuery\$element, $fields, DatabaseQuery\$join, $key, DatabaseQuery\$limit, DatabaseQuery\$offset, DatabaseQuery\$order, $query, DatabaseQuery\$querySet, DatabaseQuery\$select, $value, DatabaseQuery\$where, Joomla\Database\Query\__toString(), DatabaseQuery\columns(), DatabaseQuery\from(), DatabaseQuery\join(), Joomla\Database\Query\limit(), DatabaseQuery\merge(), null, Joomla\Database\Query\offset(), DatabaseQuery\order(), SqliteQuery\processLimit(), DatabaseQuery\select(), SqliteQuery\selectRowNumber(), et DatabaseQuery\update().

◆ charLength()

charLength | ( | $field,
 |  | $operator = null,
 |  | $condition = null
 | ) |

Gets the number of characters in a string.

Note, use 'length' to find the number of bytes in a string.

Usage: $query->select($query->charLength('a'));

Paramètres
string | $field | A value.
string | null | $operator | Comparison operator between charLength integer value and $condition
string | null | $condition | Integer value to compare charLength with.
Renvoie
string The required char length call.
Depuis
1.1.0

Implémente QueryInterface.

Références $field, et null.

◆ concatenate()

concatenate | ( | $values,
 |  | $separator = null
 | ) |

Concatenates an array of column names or values.

Usage: $query->select($query->concatenate(array('a', 'b')));

Paramètres
string[] | $values An array of values to concatenate.
string | null | $separator | As separator to place between each value.
Renvoie
string The concatenated values.
Depuis
1.1.0

Implémente QueryInterface.

Références $separator, DatabaseQuery\$values, null, et DatabaseQuery\quote().

◆ groupConcat()

groupConcat | ( | $expression,
 |  | $separator = ','
 | ) |

Aggregate function to get input values concatenated into a string, separated by delimiter

Usage: $query->groupConcat('id', ',');

Paramètres
string | $expression | The expression to apply concatenation to, this may be a column name or complex SQL statement.
string | $separator | The delimiter of each concatenated value
Renvoie
string Input values concatenated into a string, separated by delimiter
Depuis
2.0.0

Implémente QueryInterface.

Références $separator, et DatabaseQuery\quote().

◆ processLimit()

processLimit | ( | $query,
 |  | $limit,
 |  | $offset = 0
 | ) |

Method to modify a query already in string format with the needed additions to make the query limited to a particular number of results, or start at a particular offset.

Paramètres
string | $query | The query in string format
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
string
Depuis
1.0

Implémente LimitableInterface.

Références DatabaseQuery\$limit, DatabaseQuery\$offset, et $query.

Référencé par SqliteQuery\__toString().

◆ selectRowNumber()

selectRowNumber | ( | $orderBy,
 |  | $orderColumnAlias
 | ) |

Return the number of the current row.

Usage: $query->select('id'); $query->selectRowNumber('ordering,publish_up DESC', 'new_ordering'); $query->from('#__content');

Paramètres
string | $orderBy | An expression of ordering for window function.
string | $orderColumnAlias | An alias for new ordering column.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente QueryInterface.

Références $this, et DatabaseQuery\validateRowNumber().

Référencé par SqliteQuery\__toString().

◆ union()

union | ( | $query,
 |  | $distinct = true
 | ) |

Add a query to UNION with the current query.

Usage: $query->union('SELECT name FROM #__foo') $query->union('SELECT name FROM #__foo', true)

Paramètres
DatabaseQuery | string | $query | The DatabaseQuery object or string to union.
boolean | $distinct | True to only return distinct rows from the union.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $query, et DatabaseQuery\merge().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SqliteQuery.php


Joomla CMS: Référence de la classe SqlsrvQuery

  • Joomla
  • Database
  • Sqlsrv
  • SqlsrvQuery
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe SqlsrvQuery
+ Graphe d'héritage de SqlsrvQuery:
DatabaseQuery QueryInterface PreparableInterface LimitableInterface SqlazureQuery

Fonctions membres publiques

__toString ()
castAs (string $type, string $value, ?string $length=null)
charLength ($field, $operator=null, $condition=null)
concatenate ($values, $separator=null)
currentTimestamp ()
length ($value)
group ($columns)
groupConcat ($expression, $separator=',')
rand ()
findInSet ($value, $set)
processLimit ($query, $limit, $offset=0)
union ($query, $distinct=true)
- Fonctions membres publiques hérités de DatabaseQuery
__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)

Fonctions membres protégées

fixSelectAliases ()
fixGroupColumns ($selectColumns)
splitSqlExpression ($string)
- Fonctions membres protégées hérités de DatabaseQuery
merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Attributs protégés

$nullDatetimeList = ['1900-01-01 00:00:00']
- Attributs protégés hérités de DatabaseQuery
$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Description détaillée

SQL Server Query Building Class.

Depuis
1.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic function to convert the query to a string.

Renvoie
string The completed query.
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$alias, DatabaseQuery\$columns, DatabaseQuery\$element, DatabaseQuery\$from, DatabaseQuery\$join, $query, DatabaseQuery\$querySet, DatabaseQuery\$sql, DatabaseQuery\$update, Joomla\Database\Query\__toString(), DatabaseQuery\alias(), DatabaseQuery\columns(), elseif, SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\fixSelectAliases(), DatabaseQuery\from(), SqlsrvQuery\group(), DatabaseQuery\having(), DatabaseQuery\insert(), DatabaseQuery\join(), Joomla\Database\Query\limit(), DatabaseQuery\merge(), null, Joomla\Database\Query\offset(), DatabaseQuery\order(), SqlsrvQuery\processLimit(), DatabaseQuery\select(), DatabaseQuery\selectRowNumber(), DatabaseQuery\update(), DatabaseQuery\values(), et DatabaseQuery\where().

◆ castAs()

castAs | ( | string | $type,
 |  | string | $value,
 |  | ?string | $length = null
 | ) |  |

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAs('CHAR', 'a'));

Paramètres
string | $type | The type of string to cast as.
string | $value | The value to cast as a char.
string | $length | The value to cast as a char.
Renvoie
string SQL statement to cast the value as a char type.
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$type, $value, et Joomla\Database\Query\castAs().

◆ charLength()

charLength | ( | $field,
 |  | $operator = null,
 |  | $condition = null
 | ) |

Gets the function to determine the length of a character string.

Paramètres
string | $field | A value.
string | null | $operator | Comparison operator between charLength integer value and $condition
string | null | $condition | Integer value to compare charLength with.
Renvoie
string The required char length call.
Depuis
1.0

Implémente QueryInterface.

Références $field, et null.

◆ concatenate()

concatenate | ( | $values,
 |  | $separator = null
 | ) |

Concatenates an array of column names or values.

Paramètres
string[] | $values An array of values to concatenate.
string | null | $separator | As separator to place between each value.
Renvoie
string The concatenated values.
Depuis
1.0

Implémente QueryInterface.

Références $separator, DatabaseQuery\$values, null, et DatabaseQuery\quote().

◆ currentTimestamp()

currentTimestamp ( )

Gets the current date and time.

Renvoie
string
Depuis
1.0

Implémente QueryInterface.

◆ findInSet()

findInSet | ( | $value,
 |  | $set
 | ) |

Find a value in a varchar used like a set.

Ensure that the value is an integer before passing to the method.

Usage: $query->findInSet((int) $parent->id, 'a.assigned_cat_ids')

Paramètres
string | $value | The value to search for.
string | $set | The set of values.
Renvoie
string A representation of the MySQL find_in_set() function for the driver.
Depuis
1.5.0

Implémente QueryInterface.

◆ fixGroupColumns()

fixGroupColumns ( $selectColumns )
protected

Add missing columns names to GROUP BY clause.

Paramètres
array[] $selectColumns Array of columns from splitSqlExpression method.
Renvoie
$this
Depuis
2.0.0

Références DatabaseQuery\$alias, $dir, $i, DatabaseQuery\$join, $name, $size, $this, DatabaseQuery\$type, elseif, DatabaseQuery\from(), SqlsrvQuery\group(), DatabaseQuery\join(), DatabaseQuery\order(), et SqlsrvQuery\splitSqlExpression().

Référencé par SqlsrvQuery\__toString().

◆ fixSelectAliases()

fixSelectAliases ( )
protected

Add required aliases to columns for select statement in subquery.

Renvoie
array[] Array of columns with added missing aliases.
Depuis
2.0.0

Références DatabaseQuery\$columns, $i, $size, elseif, DatabaseQuery\quoteName(), DatabaseQuery\select(), et SqlsrvQuery\splitSqlExpression().

Référencé par SqlsrvQuery\__toString().

◆ group()

group ( $columns )

Add a grouping column to the GROUP clause of the query.

Usage: $query->group('id');

Paramètres
mixed $columns A string or array of ordering columns.
Renvoie
SqlsrvQuery Returns this object to allow chaining.
Depuis
1.5.0

Implémente QueryInterface.

Références DatabaseQuery\$alias, $cols, DatabaseQuery\$columns, DatabaseQuery\$join, $key, $name, $this, DatabaseQuery\$type, DatabaseQuery\from(), DatabaseQuery\join(), et DatabaseQuery\select().

Référencé par SqlsrvQuery\__toString(), et SqlsrvQuery\fixGroupColumns().

◆ groupConcat()

groupConcat | ( | $expression,
 |  | $separator = ','
 | ) |

Aggregate function to get input values concatenated into a string, separated by delimiter

Usage: $query->groupConcat('id', ',');

Paramètres
string | $expression | The expression to apply concatenation to, this may be a column name or complex SQL statement.
string | $separator | The delimiter of each concatenated value
Renvoie
string Input values concatenated into a string, separated by delimiter
Depuis
2.0.0

Implémente QueryInterface.

Références $separator, et DatabaseQuery\quote().

◆ length()

length ( $value )

Get the length of a string in bytes.

Paramètres
string $value The string to measure.
Renvoie
integer
Depuis
1.0

Implémente QueryInterface.

Références $value.

◆ processLimit()

processLimit | ( | $query,
 |  | $limit,
 |  | $offset = 0
 | ) |

Method to modify a query already in string format with the needed additions to make the query limited to a particular number of results, or start at a particular offset.

Paramètres
string | $query | The query in string format
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
string
Depuis
2.0.0

Implémente LimitableInterface.

Références DatabaseQuery\$limit, DatabaseQuery\$offset, $position, $query, et elseif.

Référencé par SqlsrvQuery\__toString().

◆ rand()

rand ( )

Get the function to return a random floating-point value

Usage: $query->rand();

Renvoie
string
Depuis
1.5.0

Implémente QueryInterface.

◆ splitSqlExpression()

splitSqlExpression ( $string )
protected

Split a string of sql expression into an array of individual columns. Single line or line end comments and multi line comments are stripped off. Always return at least one column.

Paramètres
string $string Input string of sql expression like select expression.
Renvoie
array[] The columns from the input string separated into an array.
Depuis
2.0.0

Références DatabaseQuery\$columns, $i, $n, $start, elseif, et null.

Référencé par SqlsrvQuery\fixGroupColumns(), et SqlsrvQuery\fixSelectAliases().

◆ union()

union | ( | $query,
 |  | $distinct = true
 | ) |

Add a query to UNION with the current query.

Usage: $query->union('SELECT name FROM #__foo') $query->union('SELECT name FROM #__foo', true)

Paramètres
DatabaseQuery | string | $query | The DatabaseQuery object or string to union.
boolean | $distinct | True to only return distinct rows from the union.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $query, et DatabaseQuery\merge().

Documentation des champs

◆ $nullDatetimeList

$nullDatetimeList = ['1900-01-01 00:00:00']
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlsrvQuery.php


Joomla CMS: Référence de la classe SqlsrvStatement

  • Joomla
  • Database
  • Sqlsrv
  • SqlsrvStatement
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe SqlsrvStatement
+ Graphe d'héritage de SqlsrvStatement:
StatementInterface

Fonctions membres publiques

__construct ($connection, string $query)
prepareParameterKeyMapping ($sql)
bindParam ($parameter, &$variable, string $dataType=ParameterType::STRING, ?int $length=null, ?array $driverOptions=null)
closeCursor ()
errorCode ()
errorInfo ()
execute (?array $parameters=null)
fetch (?int $fetchStyle=null, int $cursorOrientation=FetchOrientation::NEXT, int $cursorOffset=0)
fetchColumn ($columnIndex=0)
rowCount ()
setFetchMode (int $fetchMode,... $args)

Attributs protégés

$connection
$defaultFetchStyle = FetchMode::MIXED
$defaultObjectClass = \stdClass::class
$query
$statement
$typesKeyMapping
$parameterKeyMapping
$parameterTypeMapping

Fonctions membres privées

bindValue ($parameter, $variable, $dataType=ParameterType::STRING)
prepare ()

Attributs privés

$fetchMap
$result = false
$bindedValues = []

Description détaillée

SQL Server Database Statement.

This class is modeled on

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $connection,
 |  | string | $query
 | ) |  |

Constructor.

Paramètres
resource | $connection | The database connection resource
string | $query | The query this statement will process
Depuis
2.0.0
Exceptions
PrepareStatementFailureException

Références SqlsrvStatement\$connection, ParameterType\BOOLEAN, ParameterType\INTEGER, ParameterType\LARGE_OBJECT, ParameterType\NULL, SqlsrvStatement\prepareParameterKeyMapping(), et ParameterType\STRING.

Documentation des fonctions membres

◆ bindParam()

bindParam | ( |  | $parameter,
 |  | & | $variable,
 |  | string | $dataType = ParameterType::STRING,
 |  | ?int | $length = null,
 |  | ?array | $driverOptions = null
 | ) |  |

Binds a parameter to the specified variable name.

Paramètres
string | integer | $parameter | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $variable | Name of the PHP variable to bind to the SQL statement parameter.
string | $dataType | Constant corresponding to a SQL datatype, this should be the processed type from the QueryInterface.
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

Références null.

◆ bindValue()

bindValue | ( | $parameter,
 |  | $variable,
 |  | $dataType = ParameterType::STRING
 | ) |
private

Binds a value to the specified variable.

Paramètres
string | integer | $parameter | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $variable | Name of the PHP variable to bind to the SQL statement parameter.
string | $dataType | Constant corresponding to a SQL datatype, this should be the processed type from the QueryInterface.
Renvoie
void
Depuis
2.0.0

Référencé par SqlsrvStatement\execute().

◆ closeCursor()

closeCursor ( )

Closes the cursor, enabling the statement to be executed again.

Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

◆ errorCode()

errorCode ( )

Fetches the SQLSTATE associated with the last operation on the statement handle.

Renvoie
string
Depuis
2.0.0

Implémente StatementInterface.

◆ errorInfo()

errorInfo ( )

Fetches extended error information associated with the last operation on the statement handle.

Renvoie
array
Depuis
2.0.0

Implémente StatementInterface.

Référencé par SqlsrvStatement\execute(), et SqlsrvStatement\prepare().

◆ execute()

execute ( ?array $parameters = null )

Executes a prepared statement

Paramètres
array | null $parameters An array of values with as many elements as there are bound parameters in the SQL statement being executed.
Renvoie
boolean
Depuis
2.0.0

Implémente StatementInterface.

Références $key, $parameters, $val, SqlsrvStatement\bindValue(), SqlsrvStatement\errorInfo(), null, et SqlsrvStatement\prepare().

◆ fetch()

fetch | ( | ?int | $fetchStyle = null,
 |  | int | $cursorOrientation = FetchOrientation::NEXT,
 |  | int | $cursorOffset = 0
 | ) |  |

Fetches the next row from a result set

Paramètres
integer | null | $fetchStyle | Controls how the next row will be returned to the caller. This value must be one of the FetchMode constants, defaulting to value of FetchMode::MIXED.
integer | $cursorOrientation | For a StatementInterface object representing a scrollable cursor, this value determines which row will be returned to the caller. This value must be one of the FetchOrientation constants, defaulting to FetchOrientation::NEXT.
integer | $cursorOffset | For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::ABS, this value specifies the absolute number of the row in the result set that shall be fetched. For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::REL, this value specifies the row to fetch relative to the cursor position before fetch() was called.
Renvoie
mixed The return value of this function on success depends on the fetch type. In all cases, boolean false is returned on failure.
Depuis
2.0.0

Implémente StatementInterface.

Références SqlsrvStatement\$defaultFetchStyle, FetchMode\COLUMN, FetchMode\CUSTOM_OBJECT, SqlsrvStatement\fetchColumn(), et FetchMode\STANDARD_OBJECT.

Référencé par SqlsrvStatement\fetchColumn().

◆ fetchColumn()

fetchColumn ( $columnIndex = 0 )

Returns a single column from the next row of a result set

Paramètres
integer $columnIndex 0-indexed number of the column you wish to retrieve from the row. If no value is supplied, the first column is retrieved.
Renvoie
mixed Returns a single column from the next row of a result set or boolean false if there are no more rows.
Depuis
2.0.0

Références SqlsrvStatement\fetch(), et null.

Référencé par SqlsrvStatement\fetch().

◆ prepare()

prepare ( )
private

Prepares the SQL Server statement resource for execution

Renvoie
resource
Depuis
2.0.0

Références $key, $options, $params, SqlsrvStatement\$statement, $value, SqlsrvStatement\errorInfo(), et ParameterType\LARGE_OBJECT.

Référencé par SqlsrvStatement\execute().

◆ prepareParameterKeyMapping()

prepareParameterKeyMapping ( $sql )

Replace named parameters with numbered parameters

Paramètres
string $sql The SQL statement to prepare.
Renvoie
string The processed SQL statement.
Depuis
2.0.0

Références $i, $n, et $sql.

Référencé par SqlsrvStatement\__construct().

◆ rowCount()

rowCount ( )

Returns the number of rows affected by the last SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémente StatementInterface.

◆ setFetchMode()

setFetchMode | ( | int | $fetchMode,
 |  |  | $args
 | ) |  |

Sets the fetch mode to use while iterating this statement.

Paramètres
integer | $fetchMode | The fetch mode, must be one of the FetchMode constants.
mixed | ...$args Optional mode-specific arguments.
Renvoie
void
Depuis
2.0.0

Implémente StatementInterface.

Documentation des champs

◆ $bindedValues

$bindedValues = []
private

◆ $connection

$connection
protected

Référencé par SqlsrvStatement\__construct().

◆ $defaultFetchStyle

$defaultFetchStyle = FetchMode::MIXED
protected

Référencé par SqlsrvStatement\fetch().

◆ $defaultObjectClass

$defaultObjectClass = \stdClass::class
protected

◆ $fetchMap

$fetchMap
private
Valeur initiale :
= [
FetchMode::MIXED => SQLSRV_FETCH_BOTH

◆ $parameterKeyMapping

$parameterKeyMapping
protected

◆ $parameterTypeMapping

$parameterTypeMapping
protected
Valeur initiale :
= [
ParameterType::BOOLEAN => ParameterType::BOOLEAN

◆ $query

$query
protected

◆ $result

$result = false
private

◆ $statement

$statement
protected

Référencé par SqlsrvStatement\prepare().

◆ $typesKeyMapping

$typesKeyMapping
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • SqlsrvStatement.php


Joomla CMS: Référence de l'interface DatabaseAwareInterface

  • Joomla
  • Database
  • DatabaseAwareInterface
Fonctions membres publiques
Référence de l'interface DatabaseAwareInterface
+ Graphe d'héritage de DatabaseAwareInterface:
Categories FormField EmailRule ExistsRule UserIdRule UsernameRule LanguagesModel Installer InstallerAdapter BaseDatabaseModel ArticlesLatestHelper ArticlesNewsHelper CredentialRepository

Fonctions membres publiques

setDatabase (DatabaseInterface $db)

Description détaillée

Defines the interface for a DatabaseInterface aware class.

Depuis
2.1.0

Documentation des fonctions membres

◆ setDatabase()

setDatabase ( DatabaseInterface $db )

Set the database.

Paramètres
DatabaseInterface $db The database.
Renvoie
void
Depuis
2.1.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • DatabaseAwareInterface.php


Joomla CMS: Référence de la classe DatabaseDriver

  • Joomla
  • Database
  • DatabaseDriver
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Attributs privés
Référence de la classe DatabaseDriver
+ Graphe d'héritage de DatabaseDriver:
DatabaseInterface DispatcherAwareInterface MysqliDriver PdoDriver MysqlDriver PgsqlDriver SqliteDriver

Fonctions membres publiques

__get ($name)
__construct (array $options)
__destruct ()
alterDbCharacterSet ($dbName)
createDatabase ($options, $utf=true)
disconnect ()
dropTable ($table, $ifExists=true)
execute ()
getAffectedRows ()
getConnection ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNumRows ()
getServerType ()
getNullDate ()
getPrefix ()
getExporter ()
getImporter ()
getQuery ($new=false)
getIterator ($column=null, $class=\stdClass::class)
getTableCreate ($tables)
hasUtfSupport ()
insertObject ($table, &$object, $key=null)
isMinimumVersion ()
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
q ($text, $escape=true)
quote ($text, $escape=true)
quoteBinary ($data)
decodeBinary ($data)
qn ($name, $as=null)
quoteName ($name, $as=null)
replacePrefix ($sql, $prefix='#__')
getMonitor ()
setMonitor (QueryMonitorInterface $monitor=null)
setQuery ($query, $offset=0, $limit=0)
setUtf ()
truncateTable ($table)
updateObject ($table, &$object, $key, $nulls=false)
- Fonctions membres publiques hérités de DatabaseInterface
connect ()
connected ()
escape ($text, $extra=false)
getCollation ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
getTableColumns ($table, $typeOnly=true)
getTableKeys ($tables)
getTableList ()
getVersion ()
insertid ()
lockTable ($tableName)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
select ($database)
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
unlockTables ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres publiques statiques

static | getInstance (array $options=[])
static | splitSql ($sql)
- Fonctions membres publiques statiques hérités de DatabaseInterface
static | isSupported ()

Champs de données

$serverType

Fonctions membres protégées

dispatchEvent (EventInterface $event)
fetchArray ()
fetchAssoc ()
fetchObject ()
freeResult ()
getAlterDbCharacterSet ($dbName)
getCreateDatabaseQuery ($options, $utf)
getDatabase ()
prepareStatement (string $query)
quoteNameString ($name, $asSinglePart=false)
quoteNameStr ($strArr)

Attributs protégés

$name
$connection
$count = 0
$cursor
$executed = false
$limit = 0
$nameQuote
$nullDate
$offset = 0
$options
$sql
$statement
$tablePrefix
$utf = true
$errorNum = 0
$errorMsg
$transactionDepth = 0
$factory
$monitor

Attributs protégés statiques

static | $connectors = []
static | $instances = []
static | $dbMinimum

Attributs privés

$database

Description détaillée

Joomla Framework Database Driver Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options )

Constructor.

Paramètres
array $options List of options used to configure the connection
Depuis
1.0

Références $options, et null.

◆ __destruct()

__destruct ( )

Destructor.

Depuis
2.0.0

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic method to access properties of the database driver.

Paramètres
string $name The name of the property.
Renvoie
mixed A value if the property name is valid, null otherwise.
Depuis
1.4.0
Obsolète:
3.0 This is a B/C proxy since $this->name was previously public

Références $name, et class.

◆ alterDbCharacterSet()

alterDbCharacterSet ( $dbName )

Alter database's character set.

Paramètres
string $dbName The database name that will be altered
Renvoie
boolean|resource
Depuis
2.0.0
Exceptions

Références null.

◆ createDatabase()

createDatabase | ( | $options,
 |  | $utf = true
 | ) |

Create a new database using information from $options object.

Paramètres
\stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
boolean|resource
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $options, et null.

◆ decodeBinary()

decodeBinary ( $data )

Replace special placeholder representing binary field with the original string.

Paramètres
string | resource $data Encoded string or resource.
Renvoie
string The original string.
Depuis
1.7.0

Implémente DatabaseInterface.

Références $data.

◆ disconnect()

disconnect ( )

Disconnects the database.

Renvoie
void
Depuis
2.0.0

Implémente DatabaseInterface.

Références $this, et null.

Référencé par SqliteDriver\__destruct(), et PdoDriver\__destruct().

◆ dispatchEvent()

dispatchEvent ( EventInterface $event )
protected

Dispatch an event.

Paramètres
EventInterface $event The event to dispatch
Renvoie
void
Depuis
2.0.0

Références Joomla\CMS\Application\getDispatcher(), et EventInterface\getName().

Référencé par PdoDriver\connect().

◆ dropTable()

dropTable | ( | $table,
 |  | $ifExists = true
 | ) |

Drops a table from the database.

Paramètres
string | $table | The name of the database table to drop.
boolean | $ifExists | Optionally specify that the table must exist before it is dropped.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $this.

◆ execute()

execute ( )

Execute the SQL statement.

Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémente DatabaseInterface.

Références $key, $sql, et null.

◆ fetchArray()

fetchArray ( )
protected

Method to fetch a row from the result set cursor as an array.

Renvoie
mixed Either the next row from the result set or false if there are no more rows.
Depuis
1.0

◆ fetchAssoc()

fetchAssoc ( )
protected

Method to fetch a row from the result set cursor as an associative array.

Renvoie
mixed Either the next row from the result set or false if there are no more rows.
Depuis
1.0

◆ fetchObject()

fetchObject ( )
protected

Method to fetch a row from the result set cursor as an object.

Note, the fetch mode should be configured before calling this method using StatementInterface::setFetchMode().

Renvoie
mixed Either the next row from the result set or false if there are no more rows.
Depuis
1.0

◆ freeResult()

freeResult ( )
protected

Method to free up the memory used for the result set.

Renvoie
void
Depuis
1.0

Référencé par MysqliDriver\executeUnpreparedQuery().

◆ getAffectedRows()

getAffectedRows ( )

Get the number of affected rows for the previous executed SQL statement.

Renvoie
integer The number of affected rows in the previous operation
Depuis
2.0.0

Implémente DatabaseInterface.

◆ getAlterDbCharacterSet()

getAlterDbCharacterSet ( $dbName )
protected

Return the query string to alter the database character set.

Paramètres
string $dbName The database name
Renvoie
string The query that alter the database query string
Depuis
1.6.0

◆ getConnection()

getConnection ( )

Method that provides access to the underlying database connection.

Renvoie
resource The underlying database connection resource.
Depuis
1.0

Implémente DatabaseInterface.

Référencé par PgsqlDriver\connect(), et MysqlDriver\connect().

◆ getCount()

getCount ( )

Get the total number of SQL statements executed by the database driver.

Renvoie
integer
Depuis
1.0

Implémente DatabaseInterface.

Références $count.

◆ getCreateDatabaseQuery()

getCreateDatabaseQuery | ( | $options,
 |  | $utf
 | ) |
protected

Return the query string to create new Database.

Paramètres
stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
string The query that creates database
Depuis
2.0.0

Références $options.

◆ getDatabase()

getDatabase ( )
protected

Gets the name of the database used by this connection.

Renvoie
string
Depuis
1.0

◆ getDateFormat()

getDateFormat ( )

Returns a PHP date() function compliant date format for the database driver.

Renvoie
string
Depuis
1.0

Implémente DatabaseInterface.

◆ getExporter()

getExporter ( )

Gets an exporter class object.

Renvoie
DatabaseExporter An exporter object.
Depuis
1.0
Exceptions

Références $this, et name.

◆ getImporter()

getImporter ( )

Gets an importer class object.

Renvoie
DatabaseImporter
Depuis
1.0

Références $this, et name.

◆ getInstance()

static getInstance ( array $options = [] )
static

Method to return a DatabaseDriver instance based on the given options.

There are three global options and then the rest are specific to the database driver.

  • The 'driver' option defines which DatabaseDriver class is used for the connection – the default is 'mysqli'.
  • The 'database' option determines which database is to be used for the connection.
  • The 'select' option determines whether the connector should automatically select the chosen database.

Instances are unique to the given options and new objects are only created when a unique options array is passed into the method. This ensures that we don't end up with unnecessary database connection resources.

Paramètres
array $options Parameters to be passed to the database driver.
Renvoie
DatabaseDriver
Depuis
1.0
Exceptions

Références DatabaseDriver\$options, class, et null.

Référencé par SetConfigurationCommand\checkDb(), DatabaseLogger\connect(), DatabaseModel\createDatabase(), Factory\createDbo(), DatabaseHelper\getDbo(), Database\register(), et ApplicationModel\save().

◆ getIterator()

getIterator | ( | $column = null,
 |  | $class = \stdClass::class
 | ) |

Get a new iterator on the current query.

Paramètres
string | $column | An option column to use as the iterator key.
string | $class | The class of object that is returned.
Renvoie
DatabaseIterator
Depuis
1.0

Calling setQuery free's the statement from the iterator which will break the iterator. So we set statement to null so that freeResult on the statement here has no affect. If you unset the iterator object then that will close the cursor and free the result.

Références $class, name, et null.

◆ getMinimum()

getMinimum ( )

Get the minimum supported database version.

Renvoie
string
Depuis
1.0

Implémente DatabaseInterface.

◆ getMonitor()

getMonitor ( )

Get the query monitor.

Renvoie
QueryMonitorInterface|null The query monitor or null if not set.
Depuis
2.0.0

◆ getName()

getName ( )

Get the name of the database driver.

If $this->name is not set it will try guessing the driver name from the class name.

Renvoie
string
Depuis
1.4.0

Implémente DatabaseInterface.

Références $name, $this, et name.

◆ getNullDate()

getNullDate ( )

Get the null or zero representation of a timestamp for the database driver.

Renvoie
string
Depuis
1.0

Implémente DatabaseInterface.

Référencé par PgsqlDriver\sqlValue().

◆ getNumRows()

getNumRows ( )

Get the number of returned rows for the previous executed SQL statement.

Renvoie
integer The number of returned rows.
Depuis
2.0.0

Implémente DatabaseInterface.

◆ getPrefix()

getPrefix ( )

Get the common table prefix for the database driver.

Renvoie
string The common database table prefix.
Depuis
1.0

◆ getQuery()

getQuery ( $new = false )

Get the current query object or a new DatabaseQuery object.

Paramètres
boolean $new False to return the current query object, True to return a new DatabaseQuery object.
Renvoie
DatabaseQuery
Depuis
1.0

Implémente DatabaseInterface.

Références $sql, $this, et name.

Référencé par PgsqlDriver\getConnectionEncryption(), PgsqlDriver\getNamesKey(), PgsqlDriver\getSequenceIsCalled(), PgsqlDriver\getSequenceLastValue(), SqliteDriver\getTableList(), PgsqlDriver\getTableList(), PgsqlDriver\getTableSequences(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), PgsqlDriver\renameTable(), et PgsqlDriver\showTables().

◆ getServerType()

getServerType ( )

Get the server family type.

If $this->serverType is not set it will attempt guessing the server family type from the driver name. If this is not possible the driver name will be returned instead.

Renvoie
string
Depuis
1.4.0

Implémente DatabaseInterface.

Références $name, et elseif.

◆ getTableCreate()

getTableCreate ( $tables )
abstract

Shows the table CREATE statement that creates the given tables.

Paramètres
mixed $tables A table name or a list of table names.
Renvoie
array A list of the create SQL for the tables.
Depuis
1.0
Exceptions

◆ hasUtfSupport()

hasUtfSupport ( )

Determine whether or not the database engine supports UTF-8 character encoding.

Renvoie
boolean True if the database engine supports UTF-8 character encoding.
Depuis
1.0

Implémente DatabaseInterface.

◆ insertObject()

insertObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key = null
 | ) |  |

Inserts a row into a table based on an object's properties.

Paramètres
string | $table | The name of the database table to insert into.
object | $object | A reference to an object whose public properties match the table fields.
string | $key | The name of the primary key. If provided the object property is updated.
Renvoie
boolean
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $fields, $id, $key, $query, et null.

◆ isMinimumVersion()

isMinimumVersion ( )

Method to check whether the installed database version is supported by the database driver

Renvoie
boolean True if the database version is supported
Depuis
1.0

Implémente DatabaseInterface.

◆ loadAssoc()

loadAssoc ( )

Method to get the first row of the result set from the database query as an associative array of ['field_name' => 'row_value'].

Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références null.

Référencé par PgsqlDriver\getRandom().

◆ loadAssocList()

loadAssocList | ( | $key = null,
 |  | $column = null
 | ) |

Method to get an array of the result set rows from the database query where each row is an associative array of ['field_name' => 'row_value']. The array of rows can optionally be keyed by a field name, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field name can result in unwanted behavior and should be avoided.

Paramètres
string | $key | The name of a field on which to key the result array.
string | $column | An optional column name. Instead of the whole row, only this column value will be in the result array.
Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $key, et $value.

Référencé par PgsqlDriver\getCollation(), et PgsqlDriver\getConnectionCollation().

◆ loadColumn()

loadColumn ( $offset = 0 )

Method to get an array of values from the $offset field in each row of the result set from the database query.

Paramètres
integer $offset The row offset to use to build the result array.
Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références Joomla\Database\Query\$offset.

Référencé par PgsqlDriver\getTableList(), PgsqlDriver\renameTable(), et PgsqlDriver\showTables().

◆ loadObject()

loadObject ( $class = \stdClass::class )

Method to get the first row of the result set from the database query as an object.

Paramètres
string $class The class name to use for the returned row object.
Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $class, class, et null.

◆ loadObjectList()

loadObjectList | ( | $key = '',
 |  | $class = \stdClass::class
 | ) |

Method to get an array of the result set rows from the database query where each row is an object. The array of objects can optionally be keyed by a field name, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field name can result in unwanted behavior and should be avoided.

Paramètres
string | $key | The name of a field on which to key the result array.
string | $class | The class name to use for the returned row objects.
Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $class, $key, et class.

Référencé par PgsqlDriver\getTableColumns(), PgsqlDriver\getTableKeys(), et PgsqlDriver\getTableSequences().

◆ loadResult()

loadResult ( )

Method to get the first field of the first row of the result set from the database query.

Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références null.

Référencé par PdoDriver\connected(), PgsqlDriver\getDefaultSchema(), PgsqlDriver\getNamesKey(), PgsqlDriver\getSequenceIsCalled(), et PgsqlDriver\getSequenceLastValue().

◆ loadRow()

loadRow ( )

Method to get the first row of the result set from the database query as an array.

Columns are indexed numerically so the first column in the result set would be accessible via $row[0], etc.

Renvoie
mixed The return value or null if the query failed.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références null.

Référencé par PgsqlDriver\getStringPositionSql().

◆ loadRowList()

loadRowList ( $key = null )

Method to get an array of the result set rows from the database query where each row is an array. The array of objects can optionally be keyed by a field offset, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field can result in unwanted behavior and should be avoided.

Paramètres
string $key The name of a field on which to key the result array.
Renvoie
array An array of results.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $key, et null.

◆ prepareStatement()

prepareStatement ( string $query )
abstractprotected

Prepares a SQL statement for execution

Paramètres
string $query The SQL query to be prepared.
Renvoie
StatementInterface
Depuis
2.0.0
Exceptions
PrepareStatementFailureException

◆ q()

q | ( | $text,
 |  | $escape = true
 | ) |

Alias for quote method

Paramètres
array | string | $text | A string or an array of strings to quote.
boolean | $escape | True (default) to escape the string, false to leave it unchanged.
Renvoie
string The quoted input string.
Depuis
1.0

Références $text.

◆ qn()

qn | ( | $name,
 |  | $as = null
 | ) |

Alias for quoteName method

Paramètres
array | string | $name | The identifier name to wrap in quotes, or an array of identifier names to wrap in quotes. Each type supports dot-notation name.
array | string | $as | The AS query part associated to $name. It can be string or array, in latter case it has to be same length of $name; if is null there will not be any AS part for string or array element.
Renvoie
array|string The quote wrapped name, same type of $name.
Depuis
1.0

Références $name.

◆ quote()

quote | ( | $text,
 |  | $escape = true
 | ) |

Quotes and optionally escapes a string to database requirements for use in database queries.

Paramètres
array | string | $text | A string or an array of strings to quote.
boolean | $escape | True (default) to escape the string, false to leave it unchanged.
Renvoie
string The quoted input string.
Depuis
1.0

Implémente DatabaseInterface.

Références $text.

Référencé par PgsqlDriver\getAlterDbCharacterSet(), PgsqlDriver\getCreateDbQuery(), PgsqlDriver\getNamesKey(), PgsqlDriver\getTableColumns(), PgsqlDriver\getTableKeys(), PgsqlDriver\getTableList(), PgsqlDriver\getTableSequences(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\renameTable(), PgsqlDriver\showTables(), et PgsqlDriver\sqlValue().

◆ quoteBinary()

quoteBinary ( $data )

Quotes a binary string to database requirements for use in database queries.

Paramètres
string $data A binary string to quote.
Renvoie
string The binary quoted input string.
Depuis
1.7.0

Implémente DatabaseInterface.

Références $data.

◆ quoteName()

quoteName | ( | $name,
 |  | $as = null
 | ) |

Wrap an SQL statement identifier name such as column, table or database names in quotes to prevent injection risks and reserved word conflicts.

Paramètres
array | string | $name | The identifier name to wrap in quotes, or an array of identifier names to wrap in quotes. Each type supports dot-notation name.
array | string | $as | The AS query part associated to $name. It can be string or array, in latter case it has to be same length of $name; if is null there will not be any AS part for string or array element.
Renvoie
array|string The quote wrapped name, same type of $name.
Depuis
1.0

Implémente DatabaseInterface.

Références $count, $i, $name, elseif, et null.

Référencé par MysqliDriver\getAlterDbCharacterSet(), PgsqlDriver\getAlterDbCharacterSet(), PgsqlDriver\getConnectionEncryption(), MysqlDriver\getCreateDatabaseQuery(), MysqliDriver\getCreateDatabaseQuery(), PgsqlDriver\getCreateDbQuery(), PgsqlDriver\getSequenceIsCalled(), PgsqlDriver\getSequenceLastValue(), MysqlDriver\getTableColumns(), MysqliDriver\getTableColumns(), MysqlDriver\getTableCreate(), MysqliDriver\getTableCreate(), MysqlDriver\getTableKeys(), MysqliDriver\getTableKeys(), PgsqlDriver\getTableSequences(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), PgsqlDriver\lockTable(), MysqlDriver\lockTable(), MysqliDriver\lockTable(), MysqlDriver\renameTable(), SqliteDriver\transactionRollback(), PgsqlDriver\transactionRollback(), MysqlDriver\transactionRollback(), MysqliDriver\transactionRollback(), SqliteDriver\transactionStart(), PgsqlDriver\transactionStart(), MysqlDriver\transactionStart(), SqliteDriver\truncateTable(), et PgsqlDriver\updateObject().

◆ quoteNameStr()

quoteNameStr ( $strArr )
protected

Quote strings coming from quoteName call.

Paramètres
array $strArr Array of strings coming from quoteName dot-explosion.
Renvoie
string Dot-imploded string of quoted parts.
Depuis
1.0
Obsolète:
2.0 Use quoteNameString instead

Références $parts, et null.

◆ quoteNameString()

quoteNameString | ( | $name,
 |  | $asSinglePart = false
 | ) |
protected

Quote string coming from quoteName call.

Paramètres
string | $name | Identifier name to be quoted.
boolean | $asSinglePart | Treat the name as a single part of the identifier.
Renvoie
string Quoted identifier string.
Depuis
1.7.0

Références $name.

◆ replacePrefix()

replacePrefix | ( | $sql,
 |  | $prefix = '#__'
 | ) |

This function replaces a string identifier with the configured table prefix.

Paramètres
string | $sql | The SQL statement to prepare.
string | $prefix | The table prefix.
Renvoie
string The processed SQL statement.
Depuis
1.0

Implémente DatabaseInterface.

Références $n, $prefix, et $sql.

Référencé par PdoDriver\execute(), et MysqliDriver\lockTable().

◆ setMonitor()

setMonitor ( QueryMonitorInterface $monitor = null )

Set a query monitor.

Paramètres
QueryMonitorInterface | null $monitor The query monitor.
Renvoie
$this
Depuis
2.0.0

Références $this.

◆ setQuery()

setQuery | ( | $query,
 |  | $offset = 0,
 |  | $limit = 0
 | ) |

Sets the SQL statement string for later execution.

Paramètres
string | QueryInterface | $query | The SQL statement to set either as a Query object or a string.
integer | $offset | The affected row offset to set. {
Obsolète:
3.0 Use LimitableInterface::setLimit() instead}
Paramètres
integer $limit The maximum affected rows to set. {
Obsolète:
3.0 Use LimitableInterface::setLimit() instead}
Renvoie
$this
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $limit, Joomla\Database\Query\$offset, $query, $sql, $this, class, elseif, Joomla\Database\Query\limit(), et Joomla\Database\Query\offset().

Référencé par PgsqlDriver\connect(), PdoDriver\connected(), PgsqlDriver\getCollation(), MysqliDriver\getCollation(), PgsqlDriver\getConnectionCollation(), MysqliDriver\getConnectionCollation(), PgsqlDriver\getConnectionEncryption(), MysqliDriver\getConnectionEncryption(), PgsqlDriver\getDefaultSchema(), PgsqlDriver\getNamesKey(), PgsqlDriver\getRandom(), PgsqlDriver\getSequenceIsCalled(), PgsqlDriver\getSequenceLastValue(), PgsqlDriver\getStringPositionSql(), PgsqlDriver\getTableColumns(), SqliteDriver\getTableColumns(), MysqlDriver\getTableColumns(), MysqliDriver\getTableColumns(), MysqlDriver\getTableCreate(), MysqliDriver\getTableCreate(), SqliteDriver\getTableKeys(), PgsqlDriver\getTableKeys(), MysqlDriver\getTableKeys(), MysqliDriver\getTableKeys(), SqliteDriver\getTableList(), PgsqlDriver\getTableList(), MysqlDriver\getTableList(), MysqliDriver\getTableList(), PgsqlDriver\getTableSequences(), SqliteDriver\getVersion(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), PgsqlDriver\isConnectionEncryptionSupported(), MysqlDriver\isConnectionEncryptionSupported(), MysqliDriver\isConnectionEncryptionSupported(), PgsqlDriver\lockTable(), MysqlDriver\lockTable(), SqliteDriver\renameTable(), PgsqlDriver\renameTable(), MysqlDriver\renameTable(), MysqliDriver\renameTable(), PgsqlDriver\showTables(), SqliteDriver\transactionRollback(), PgsqlDriver\transactionRollback(), MysqlDriver\transactionRollback(), SqliteDriver\transactionStart(), PgsqlDriver\transactionStart(), MysqlDriver\transactionStart(), SqliteDriver\truncateTable(), MysqlDriver\unlockTables(), et PgsqlDriver\updateObject().

◆ setUtf()

setUtf ( )
abstract

Set the connection to use UTF-8 character encoding.

Renvoie
boolean True on success.
Depuis
1.0

◆ splitSql()

static splitSql ( $sql )
static

Splits a string of multiple queries into an array of individual queries.

Paramètres
string $sql Input SQL string with which to split into individual queries.
Renvoie
array
Depuis
1.0

Références $i, $query, DatabaseDriver\$sql, $start, et elseif.

Référencé par DatabaseHandler\createDatabaseTable(), et ChangeSet\getUpdateQueries().

◆ truncateTable()

truncateTable ( $table )

Method to truncate a table.

Paramètres
string $table The table to truncate
Renvoie
void
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

◆ updateObject()

updateObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key,
 |  |  | $nulls = false
 | ) |  |

Updates a row in a table based on an object's properties.

Paramètres
string | $table | The name of the database table to update.
object | $object | A reference to an object whose public properties match the table fields.
array | string | $key | The name of the primary key.
boolean | $nulls | True to update null fields or false to ignore them.
Renvoie
boolean True on success.
Depuis
1.0
Exceptions

Implémente DatabaseInterface.

Références $fields, $key, $val, et null.

Documentation des champs

◆ $connection

$connection
protected

◆ $connectors

$connectors = []
staticprotected

◆ $count

$count = 0
protected

◆ $cursor

$cursor
protected

Référencé par MysqliDriver\executeUnpreparedQuery().

◆ $database

$database
private

Référencé par MysqliDriver\select().

◆ $dbMinimum

$dbMinimum
staticprotected

◆ $errorMsg

$errorMsg
protected

Référencé par PdoDriver\execute(), et MysqliDriver\executeUnpreparedQuery().

◆ $errorNum

$errorNum = 0
protected

Référencé par PdoDriver\execute(), et MysqliDriver\executeUnpreparedQuery().

◆ $executed

$executed = false
protected

◆ $factory

$factory
protected

◆ $instances

$instances = []
staticprotected

◆ $limit

$limit = 0
protected

Référencé par PdoDriver\connected().

◆ $monitor

$monitor
protected

◆ $name

$name
protected

◆ $nameQuote

$nameQuote
protected

◆ $nullDate

$nullDate
protected

◆ $offset

$offset = 0
protected

Référencé par PdoDriver\connected().

◆ $options

$options
protected

Référencé par PdoDriver\__construct(), PgsqlDriver\__construct(), MysqliDriver\__construct(), MysqlDriver\__construct(), MysqlDriver\getCreateDatabaseQuery(), MysqliDriver\getCreateDatabaseQuery(), PgsqlDriver\getCreateDbQuery(), et DatabaseDriver\getInstance().

◆ $serverType

$serverType

◆ $sql

$sql
protected

Référencé par PdoDriver\connected(), PdoDriver\execute(), MysqliDriver\executeUnpreparedQuery(), PgsqlDriver\replacePrefix(), et DatabaseDriver\splitSql().

◆ $statement

$statement
protected

Référencé par PdoDriver\connected(), et PgsqlDriver\updateObject().

◆ $tablePrefix

$tablePrefix
protected

◆ $transactionDepth

$transactionDepth = 0
protected

Référencé par SqliteDriver\transactionStart(), PgsqlDriver\transactionStart(), MysqlDriver\transactionStart(), et MysqliDriver\transactionStart().

◆ $utf

$utf = true
protected

Référencé par MysqlDriver\getCreateDatabaseQuery(), MysqliDriver\getCreateDatabaseQuery(), et PgsqlDriver\getCreateDbQuery().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseDriver.php


Joomla CMS: Référence de la classe DatabaseEvents

  • Joomla
  • Database
  • DatabaseEvents
Champs de données | Fonctions membres privées
Référence de la classe DatabaseEvents

Champs de données

const | POST_CONNECT = 'onAfterConnect'
const | POST_DISCONNECT = 'onAfterDisconnect'

Fonctions membres privées

__construct ()

Description détaillée

Class defining the events dispatched by the database API

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ POST_CONNECT

const POST_CONNECT = 'onAfterConnect'

Référencé par PdoDriver\connect().

◆ POST_DISCONNECT

const POST_DISCONNECT = 'onAfterDisconnect'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseEvents.php


Joomla CMS: Référence de la classe DatabaseExporter

  • Joomla
  • Database
  • DatabaseExporter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DatabaseExporter
+ Graphe d'héritage de DatabaseExporter:
MysqlExporter MysqliExporter PgsqlExporter

Fonctions membres publiques

__construct ()
__toString ()
asXml ()
check ()
from ($from)
setDbo (DatabaseInterface $db)
withStructure ($setting=true)
withData ($setting=false)

Fonctions membres protégées

buildXml ()
buildXmlStructure ()
getGenericTableName ($table)
buildXmlData ()

Attributs protégés

$asFormat = 'xml'
$cache = ['columns' => []
$db
$from = []
$options

Description détaillée

Joomla Framework Database Exporter Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor.

Sets up the default options for the exporter.

Depuis
1.0

Références DatabaseExporter\asXml(), DatabaseExporter\withData(), et DatabaseExporter\withStructure().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic function to exports the data to a string.

Renvoie
string
Depuis
1.0

Références $buffer, DatabaseExporter\buildXml(), et DatabaseExporter\check().

◆ asXml()

asXml ( )

Set the output option for the exporter to XML format.

Renvoie
$this
Depuis
1.0

Références $this.

Référencé par DatabaseExporter\__construct().

◆ buildXml()

buildXml ( )
abstractprotected

Builds the XML data for the tables to export.

Renvoie
string An XML string
Depuis
1.0
Exceptions

Référencé par DatabaseExporter\__toString().

◆ buildXmlData()

buildXmlData ( )
protected

Builds the XML data to export.

Renvoie
array An array of XML lines (strings).
Depuis
2.0.0
Exceptions

Références $buffer, $field, $fields, $key, $rows, $value, ENT_COMPAT, DatabaseExporter\from(), et DatabaseExporter\getGenericTableName().

Référencé par MysqlExporter\buildXml(), et MysqliExporter\buildXml().

◆ buildXmlStructure()

buildXmlStructure ( )
abstractprotected

Builds the XML structure to export.

Renvoie
array An array of XML lines (strings).
Depuis
1.0
Exceptions

◆ check()

check ( )
abstract

Checks if all data and options are in order prior to exporting.

Renvoie
$this
Depuis
1.0
Exceptions

Référencé par DatabaseExporter\__toString().

◆ from()

from ( $from )

Specifies a list of table names to export.

Paramètres
string[]|string $from The name of a single table, or an array of the table names to export.
Renvoie
$this
Depuis
1.0
Exceptions

Références DatabaseExporter\$from, $this, et elseif.

Référencé par DatabaseExporter\buildXmlData(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), PgsqlExporter\buildXmlStructure(), MysqlExporter\check(), et MysqliExporter\check().

◆ getGenericTableName()

getGenericTableName ( $table )
protected

Get the generic name of the table, converting the database prefix to the wildcard string.

Paramètres
string $table The name of the table.
Renvoie
string The name of the table with the database prefix replaced with #__.
Depuis
1.0

Références $prefix.

Référencé par DatabaseExporter\buildXmlData(), PgsqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), et MysqlExporter\buildXmlStructure().

◆ setDbo()

setDbo ( DatabaseInterface $db )

Sets the database connector to use for importing structure and/or data.

Paramètres
DatabaseInterface $db The database connector.
Renvoie
$this
Depuis
1.0

Références DatabaseExporter\$db, et $this.

◆ withData()

withData ( $setting = false )

Sets an internal option to export the data of the input table(s).

Paramètres
boolean $setting True to export the data, false to not.
Renvoie
$this
Depuis
2.0.0

Références $this.

Référencé par DatabaseExporter\__construct().

◆ withStructure()

withStructure ( $setting = true )

Sets an internal option to export the structure of the input table(s).

Paramètres
boolean $setting True to export the structure, false to not.
Renvoie
$this
Depuis
1.0

Références $this.

Référencé par DatabaseExporter\__construct().

Documentation des champs

◆ $asFormat

$asFormat = 'xml'
protected

◆ $cache

$cache = ['columns' => []
protected

◆ $db

$db
protected

Référencé par DatabaseExporter\setDbo().

◆ $from

$from = []
protected

Référencé par DatabaseExporter\from().

◆ $options

$options
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseExporter.php


Joomla CMS: Référence de la classe DatabaseFactory

  • Joomla
  • Database
  • DatabaseFactory
Fonctions membres publiques
Référence de la classe DatabaseFactory

Fonctions membres publiques

getDriver (string $name='mysqli', array $options=[])
getIterator (string $name, StatementInterface $statement, ?string $column=null, string $class=\stdClass::class)
getQuery (string $name, ?DatabaseInterface $db=null)

Description détaillée

Joomla Framework Database Factory class

Depuis
1.0

Documentation des fonctions membres

◆ getDriver()

getDriver | ( | string | $name = 'mysqli',
 |  | array | $options = []
 | ) |  |

Method to return a database driver based on the given options.

There are three global options and then the rest are specific to the database driver. The 'database' option determines which database is to be used for the connection. The 'select' option determines whether the connector should automatically select the chosen database.

Paramètres
string | $name | Name of the database driver you'd like to instantiate
array | $options | Parameters to be passed to the database driver.
Renvoie
DatabaseInterface
Depuis
1.0
Exceptions
Exception

Références $class, $name, $options, $this, et null.

◆ getIterator()

getIterator | ( | string | $name,
 |  | StatementInterface | $statement,
 |  | ?string | $column = null,
 |  | string | $class = \stdClass::class
 | ) |  |

Get a new iterator on the current query.

Paramètres
string | $name | Name of the driver you want an iterator for.
StatementInterface | $statement | Statement holding the result set to be iterated.
string | null | $column | An optional column to use as the iterator key.
string | $class | The class of object that is returned.
Renvoie
DatabaseIterator
Depuis
2.0.0

Références $class, $name, et class.

◆ getQuery()

getQuery | ( | string | $name,
 |  | ?DatabaseInterface | $db = null
 | ) |  |

Get the current query object or a new Query object.

Paramètres
string | $name | Name of the driver you want an query object for.
DatabaseInterface | null | $db | Optional database driver to inject into the query object.
Renvoie
QueryInterface
Depuis
1.0
Exceptions
Exception

Références $class, $db, et $name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseFactory.php


Joomla CMS: Référence de la classe DatabaseImporter

  • Joomla
  • Database
  • DatabaseImporter
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DatabaseImporter
+ Graphe d'héritage de DatabaseImporter:
MysqlImporter MysqliImporter PgsqlImporter

Fonctions membres publiques

__construct ()
asXml ()
check ()
from ($from)
importData ()
mergeStructure ()
setDbo (DatabaseInterface $db)
withStructure ($setting=true)

Fonctions membres protégées

getAddColumnSql ($table, \SimpleXMLElement $field)
getAlterTableSql (\SimpleXMLElement $structure)
getChangeColumnSql ($table, \SimpleXMLElement $field)
getDropColumnSql ($table, $name)
getKeyLookup ($keys)
getRealTableName ($table)
xmlToCreate (\SimpleXMLElement $table)

Attributs protégés

$cache = ['columns' => []
$db
$from = []
$asFormat = 'xml'
$options

Description détaillée

Joomla Framework Database Importer Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor.

Sets up the default options for the importer.

Depuis
1.0

Références DatabaseImporter\asXml(), et DatabaseImporter\withStructure().

Documentation des fonctions membres

◆ asXml()

asXml ( )

Set the output option for the importer to XML format.

Renvoie
$this
Depuis
1.0

Références $this.

Référencé par DatabaseImporter\__construct().

◆ check()

check ( )
abstract

Checks if all data and options are in order prior to importer.

Renvoie
$this
Depuis
1.0
Exceptions

◆ from()

from ( $from )

Specifies the data source to import.

Paramètres
\SimpleXMLElement | string $from The data source to import, either as a SimpleXMLElement object or XML string.
Renvoie
$this
Depuis
1.0

Références DatabaseImporter\$from, et $this.

Référencé par MysqliImporter\check(), PgsqlImporter\check(), MysqlImporter\check(), et DatabaseImporter\importData().

◆ getAddColumnSql()

getAddColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the SQL syntax to add a column.

Paramètres
string | $table | The table name.
\SimpleXMLElement | $field | The XML field definition.
Renvoie
string
Depuis
1.0

Références $field.

Référencé par PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), et MysqliImporter\getAlterTableSql().

◆ getAlterTableSql()

getAlterTableSql ( \SimpleXMLElement $structure )
abstractprotected

Get alters for table if there is a difference.

Paramètres
\SimpleXMLElement $structure The XML structure of the table.
Renvoie
array
Depuis
2.0.0

◆ getChangeColumnSql()

getChangeColumnSql | ( |  | $table,
 |  | \SimpleXMLElement | $field
 | ) |  |
protected

Get the syntax to alter a column.

Paramètres
string | $table | The name of the database table to alter.
\SimpleXMLElement | $field | The XML definition for the field.
Renvoie
string
Depuis
1.0

Références $field.

◆ getDropColumnSql()

getDropColumnSql | ( | $table,
 |  | $name
 | ) |
protected

Get the SQL syntax to drop a column.

Paramètres
string | $table | The table name.
string | $name | The name of the field to drop.
Renvoie
string
Depuis
1.0

Références $name.

Référencé par PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), et MysqliImporter\getAlterTableSql().

◆ getKeyLookup()

getKeyLookup ( $keys )
protected

Get the details list of keys for a table.

Paramètres
array $keys An array of objects that comprise the keys for the table.
Renvoie
array The lookup array. array({key name} => array(object, ...))
Depuis
1.0

Références $key.

◆ getRealTableName()

getRealTableName ( $table )
protected

Get the real name of the table, converting the prefix wildcard string if present.

Paramètres
string $table The name of the table.
Renvoie
string The real name of the table.
Depuis
1.0

Références $prefix.

Référencé par PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), MysqliImporter\getAlterTableSql(), et DatabaseImporter\importData().

◆ importData()

importData ( )

Import the data from the source into the existing tables.

Renvoie
void
Note
Currently only supports XML format.
Depuis
2.0.0
Exceptions

Références $data, DatabaseImporter\$from, $rows, $xml, DatabaseImporter\from(), et DatabaseImporter\getRealTableName().

◆ mergeStructure()

mergeStructure ( )

Merges the incoming structure definition with the existing structure.

Renvoie
void
Note
Currently only supports XML format.
Depuis
1.0
Exceptions

Références $query, $sql, et $xml.

◆ setDbo()

setDbo ( DatabaseInterface $db )

Sets the database connector to use for exporting structure and/or data.

Paramètres
DatabaseInterface $db The database connector.
Renvoie
$this
Depuis
1.0

Références $db, et $this.

◆ withStructure()

withStructure ( $setting = true )

Sets an internal option to merge the structure based on the input data.

Paramètres
boolean $setting True to import the structure, false to not.
Renvoie
$this
Depuis
1.0

Références $this.

Référencé par DatabaseImporter\__construct().

◆ xmlToCreate()

xmlToCreate ( \SimpleXMLElement $table )
abstractprotected

Get the SQL syntax to add a table.

Paramètres
\SimpleXMLElement $table The table information.
Renvoie
string
Depuis
2.0.0
Exceptions

Documentation des champs

◆ $asFormat

$asFormat = 'xml'
protected

◆ $cache

$cache = ['columns' => []
protected

◆ $db

$db
protected

◆ $from

$from = []
protected

Référencé par DatabaseImporter\from(), et DatabaseImporter\importData().

◆ $options

$options
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseImporter.php


Joomla CMS: Référence de l'interface DatabaseInterface

  • Joomla
  • Database
  • DatabaseInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface DatabaseInterface
+ Graphe d'héritage de DatabaseInterface:
DatabaseDriver MysqliDriver PdoDriver MysqlDriver PgsqlDriver SqliteDriver

Fonctions membres publiques

connect ()
connected ()
createDatabase ($options, $utf=true)
decodeBinary ($data)
disconnect ()
dropTable ($table, $ifExists=true)
escape ($text, $extra=false)
execute ()
getAffectedRows ()
getCollation ()
getConnection ()
getConnectionCollation ()
getConnectionEncryption ()
isConnectionEncryptionSupported ()
isMinimumVersion ()
getCount ()
getDateFormat ()
getMinimum ()
getName ()
getNullDate ()
getNumRows ()
getQuery ($new=false)
getServerType ()
getTableColumns ($table, $typeOnly=true)
getTableKeys ($tables)
getTableList ()
getVersion ()
hasUtfSupport ()
insertid ()
insertObject ($table, &$object, $key=null)
loadAssoc ()
loadAssocList ($key=null, $column=null)
loadColumn ($offset=0)
loadObject ($class=\stdClass::class)
loadObjectList ($key='', $class=\stdClass::class)
loadResult ()
loadRow ()
loadRowList ($key=null)
lockTable ($tableName)
quote ($text, $escape=true)
quoteBinary ($data)
quoteName ($name, $as=null)
renameTable ($oldTable, $newTable, $backup=null, $prefix=null)
replacePrefix ($sql, $prefix='#__')
select ($database)
setQuery ($query, $offset=0, $limit=0)
transactionCommit ($toSavepoint=false)
transactionRollback ($toSavepoint=false)
transactionStart ($asSavepoint=false)
truncateTable ($table)
unlockTables ()
updateObject ($table, &$object, $key, $nulls=false)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Joomla Framework Database Interface

Depuis
1.0

Documentation des fonctions membres

◆ connect()

connect ( )

Connects to the database if needed.

Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PdoDriver, PgsqlDriver, et SqliteDriver.

◆ connected()

connected ( )

Determines if the connection to the server is active.

Renvoie
boolean
Depuis
2.0.0

Implémenté dans PdoDriver, et MysqliDriver.

◆ createDatabase()

createDatabase | ( | $options,
 |  | $utf = true
 | ) |

Create a new database using information from $options object.

Paramètres
\stdClass | $options | Object used to pass user and database name to database driver. This object must have "db_name" and "db_user" set.
boolean | $utf | True if the database supports the UTF-8 character set.
Renvoie
boolean|resource
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver, et SqliteDriver.

◆ decodeBinary()

decodeBinary ( $data )

Replace special placeholder representing binary field with the original string.

Paramètres
string | resource $data Encoded string or resource.
Renvoie
string The original string.
Depuis
1.7.0

Implémenté dans DatabaseDriver, et PgsqlDriver.

◆ disconnect()

disconnect ( )

Disconnects the database.

Renvoie
void
Depuis
2.0.0

Implémenté dans DatabaseDriver, et MysqliDriver.

◆ dropTable()

dropTable | ( | $table,
 |  | $ifExists = true
 | ) |

Drops a table from the database.

Paramètres
string | $table | The name of the database table to drop.
boolean | $ifExists | Optionally specify that the table must exist before it is dropped.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Escapes a string for usage in an SQL statement.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
2.0.0

Implémenté dans MysqlDriver, PdoDriver, MysqliDriver, et SqliteDriver.

◆ execute()

execute ( )

Execute the SQL statement.

Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver, et PdoDriver.

◆ getAffectedRows()

getAffectedRows ( )

Get the number of affected rows for the previous executed SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getCollation()

getCollation ( )

Method to get the database collation in use by sampling a text field of a table in the database.

Renvoie
string|boolean The collation in use by the database or boolean false if not supported.
Depuis
2.0.0

Implémenté dans MysqliDriver, MysqlDriver, SqliteDriver, et PgsqlDriver.

◆ getConnection()

getConnection ( )

Method that provides access to the underlying database connection.

Renvoie
resource The underlying database connection resource.
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getConnectionCollation()

getConnectionCollation ( )

Method to get the database connection collation, as reported by the driver.

If the connector doesn't support reporting this value please return an empty string.

Renvoie
string
Depuis
2.0.0

Implémenté dans MysqliDriver, MysqlDriver, SqliteDriver, et PgsqlDriver.

◆ getConnectionEncryption()

getConnectionEncryption ( )

Method to get the database encryption details (cipher and protocol) in use.

Renvoie
string The database encryption details.
Depuis
2.0.0

Implémenté dans MysqliDriver, MysqlDriver, SqliteDriver, et PgsqlDriver.

◆ getCount()

getCount ( )

Get the total number of SQL statements executed by the database driver.

Renvoie
integer
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getDateFormat()

getDateFormat ( )

Returns a PHP date() function compliant date format for the database driver.

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getMinimum()

getMinimum ( )

Get the minimum supported database version.

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseDriver, MysqliDriver, et MysqlDriver.

◆ getName()

getName ( )

Get the name of the database driver.

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getNullDate()

getNullDate ( )

Get the null or zero representation of a timestamp for the database driver.

Renvoie
string
Depuis
2.0.0

Implémenté dans MysqliDriver, DatabaseDriver, et MysqlDriver.

◆ getNumRows()

getNumRows ( )

Get the number of returned rows for the previous executed SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getQuery()

getQuery ( $new = false )

Get the current query object or a new QueryInterface object.

Paramètres
boolean $new False to return the current query object, True to return a new QueryInterface object.
Renvoie
QueryInterface
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ getServerType()

getServerType ( )

Get the server family type.

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ getTableColumns()

getTableColumns | ( | $table,
 |  | $typeOnly = true
 | ) |

Retrieves field information about the given tables.

Paramètres
string | $table | The name of the database table.
boolean | $typeOnly | True (default) to only return field types.
Renvoie
array
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, SqliteDriver, et PgsqlDriver.

◆ getTableKeys()

getTableKeys ( $tables )

Retrieves field information about the given tables.

Paramètres
mixed $tables A table name or a list of table names.
Renvoie
array
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PgsqlDriver, et SqliteDriver.

◆ getTableList()

getTableList ( )

Method to get an array of all tables in the database.

Renvoie
array
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PgsqlDriver, et SqliteDriver.

◆ getVersion()

getVersion ( )

Get the version of the database connector.

Renvoie
string
Depuis
2.0.0

Implémenté dans MysqliDriver, PdoDriver, MysqlDriver, et SqliteDriver.

◆ hasUtfSupport()

hasUtfSupport ( )

Determine whether or not the database engine supports UTF-8 character encoding.

Renvoie
boolean True if the database engine supports UTF-8 character encoding.
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ insertid()

insertid ( )

Method to get the auto-incremented value from the last INSERT statement.

Renvoie
mixed The value of the auto-increment field from the last inserted row.
Depuis
2.0.0

Implémenté dans MysqliDriver, et PdoDriver.

◆ insertObject()

insertObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key = null
 | ) |  |

Inserts a row into a table based on an object's properties.

Paramètres
string | $table | The name of the database table to insert into.
object | $object | A reference to an object whose public properties match the table fields.
string | $key | The name of the primary key. If provided the object property is updated.
Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver, PgsqlDriver, MysqliDriver, et MysqlDriver.

◆ isConnectionEncryptionSupported()

isConnectionEncryptionSupported ( )

Method to test if the database TLS connections encryption are supported.

Renvoie
boolean Whether the database supports TLS connections encryption.
Depuis
2.0.0

Implémenté dans MysqliDriver, MysqlDriver, SqliteDriver, et PgsqlDriver.

◆ isMinimumVersion()

isMinimumVersion ( )

Method to check whether the installed database version is supported by the database driver

Renvoie
boolean True if the database version is supported
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ isSupported()

static isSupported ( )
static

Test to see if the connector is available.

Renvoie
boolean
Depuis
1.0

Implémenté dans PgsqlDriver, PdoDriver, SqliteDriver, MysqliDriver, et MysqlDriver.

◆ loadAssoc()

loadAssoc ( )

Method to get the first row of the result set from the database query as an associative array of ['field_name' => 'row_value'].

Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadAssocList()

loadAssocList | ( | $key = null,
 |  | $column = null
 | ) |

Method to get an array of the result set rows from the database query where each row is an associative array of ['field_name' => 'row_value']. The array of rows can optionally be keyed by a field name, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field name can result in unwanted behavior and should be avoided.

Paramètres
string | $key | The name of a field on which to key the result array.
string | $column | An optional column name. Instead of the whole row, only this column value will be in the result array.
Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadColumn()

loadColumn ( $offset = 0 )

Method to get an array of values from the $offset field in each row of the result set from the database query.

Paramètres
integer $offset The row offset to use to build the result array.
Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadObject()

loadObject ( $class = \stdClass::class )

Method to get the first row of the result set from the database query as an object.

Paramètres
string $class The class name to use for the returned row object.
Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadObjectList()

loadObjectList | ( | $key = '',
 |  | $class = \stdClass::class
 | ) |

Method to get an array of the result set rows from the database query where each row is an object. The array of objects can optionally be keyed by a field name, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field name can result in unwanted behavior and should be avoided.

Paramètres
string | $key | The name of a field on which to key the result array.
string | $class | The class name to use for the returned row objects.
Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadResult()

loadResult ( )

Method to get the first field of the first row of the result set from the database query.

Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadRow()

loadRow ( )

Method to get the first row of the result set from the database query as an array.

Columns are indexed numerically so the first column in the result set would be accessible via $row[0], etc.

Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ loadRowList()

loadRowList ( $key = null )

Method to get an array of the result set rows from the database query where each row is an array. The array of objects can optionally be keyed by a field offset, but defaults to a sequential numeric array.

NOTE: Choosing to key the result array by a non-unique field can result in unwanted behavior and should be avoided.

Paramètres
string $key The name of a field on which to key the result array.
Renvoie
mixed The return value or null if the query failed.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver.

◆ lockTable()

lockTable ( $tableName )

Locks a table in the database.

Paramètres
string $tableName The name of the table to unlock.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PgsqlDriver, et SqliteDriver.

◆ quote()

quote | ( | $text,
 |  | $escape = true
 | ) |

Quotes and optionally escapes a string to database requirements for use in database queries.

Paramètres
array | string | $text | A string or an array of strings to quote.
boolean | $escape | True (default) to escape the string, false to leave it unchanged.
Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ quoteBinary()

quoteBinary ( $data )

Quotes a binary string to database requirements for use in database queries.

Paramètres
string $data A binary string to quote.
Renvoie
string The binary quoted input string.
Depuis
1.7.0

Implémenté dans DatabaseDriver, et PgsqlDriver.

◆ quoteName()

quoteName | ( | $name,
 |  | $as = null
 | ) |

Wrap an SQL statement identifier name such as column, table or database names in quotes to prevent injection risks and reserved word conflicts.

Paramètres
array | string | $name | The identifier name to wrap in quotes, or an array of identifier names to wrap in quotes. Each type supports dot-notation name.
array | string | $as | The AS query part associated to $name. It can be string or array, in latter case it has to be same length of $name; if is null there will not be any AS part for string or array element.
Renvoie
array|string The quote wrapped name, same type of $name.
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ renameTable()

renameTable | ( | $oldTable,
 |  | $newTable,
 |  | $backup = null,
 |  | $prefix = null
 | ) |

Renames a table in the database.

Paramètres
string | $oldTable | The name of the table to be renamed
string | $newTable | The new name for the table.
string | $backup | Table prefix
string | $prefix | For the table - used to rename constraints in non-mysql databases
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PgsqlDriver, et SqliteDriver.

◆ replacePrefix()

replacePrefix | ( | $sql,
 |  | $prefix = '#__'
 | ) |

This function replaces a string identifier with the configured table prefix.

Paramètres
string | $sql | The SQL statement to prepare.
string | $prefix | The table prefix.
Renvoie
string The processed SQL statement.
Depuis
2.0.0

Implémenté dans DatabaseDriver, et PgsqlDriver.

◆ select()

select ( $database )

Select a database for use.

Paramètres
string $database The name of the database to select for use.
Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, PdoDriver, SqliteDriver, et MysqlDriver.

◆ setQuery()

setQuery | ( | $query,
 |  | $offset = 0,
 |  | $limit = 0
 | ) |

Sets the SQL statement string for later execution.

Paramètres
mixed | $query | The SQL statement to set either as a Query object or a string.
integer | $offset | The affected row offset to set. {
Obsolète:
3.0 Use LimitableInterface::setLimit() instead}
Paramètres
integer $limit The maximum affected rows to set. {
Obsolète:
3.0 Use LimitableInterface::setLimit() instead}
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseDriver.

◆ transactionCommit()

transactionCommit ( $toSavepoint = false )

Method to commit a transaction.

Paramètres
boolean $toSavepoint If true, commit to the last savepoint.
Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PdoDriver, PgsqlDriver, et SqliteDriver.

◆ transactionRollback()

transactionRollback ( $toSavepoint = false )

Method to roll back a transaction.

Paramètres
boolean $toSavepoint If true, rollback to the last savepoint.
Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PdoDriver, PgsqlDriver, et SqliteDriver.

◆ transactionStart()

transactionStart ( $asSavepoint = false )

Method to initialize a transaction.

Paramètres
boolean $asSavepoint If true and a transaction is already active, a savepoint will be created.
Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, MysqlDriver, PdoDriver, PgsqlDriver, et SqliteDriver.

◆ truncateTable()

truncateTable ( $table )

Method to truncate a table.

Paramètres
string $table The table to truncate
Renvoie
void
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver, et SqliteDriver.

◆ unlockTables()

unlockTables ( )

Unlocks tables in the database.

Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans MysqliDriver, PgsqlDriver, MysqlDriver, et SqliteDriver.

◆ updateObject()

updateObject | ( |  | $table,
 |  | & | $object,
 |  |  | $key,
 |  |  | $nulls = false
 | ) |  |

Updates a row in a table based on an object's properties.

Paramètres
string | $table | The name of the database table to update.
object | $object | A reference to an object whose public properties match the table fields.
array | string | $key | The name of the primary key.
boolean | $nulls | True to update null fields or false to ignore them.
Renvoie
boolean
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseDriver, et PgsqlDriver.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DatabaseInterface.php


Joomla CMS: Référence de la classe DatabaseIterator

  • Joomla
  • Database
  • DatabaseIterator
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe DatabaseIterator
+ Graphe d'héritage de DatabaseIterator:

Fonctions membres publiques

__construct (StatementInterface $statement, $column=null, $class=\stdClass::class)
__destruct ()
count ()
current ()
key ()
next ()
rewind ()
valid ()

Fonctions membres protégées

fetchObject ()
freeResult ()

Attributs protégés

$class
$statement

Attributs privés

$column
$current
$key
$fetched = 0

Description détaillée

Joomla Framework Database Driver Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | StatementInterface | $statement,
 |  |  | $column = null,
 |  |  | $class = \stdClass::class
 | ) |  |

Database iterator constructor.

Paramètres
StatementInterface | $statement | The statement holding the result set to iterate.
string | $column | An option column to use as the iterator key.
string | $class | The class of object that is returned.
Depuis
1.0
Exceptions

Références DatabaseIterator\$class, DatabaseIterator\$column, DatabaseIterator\$statement, $this, class, FetchMode\CUSTOM_OBJECT, DatabaseIterator\next(), et FetchMode\STANDARD_OBJECT.

◆ __destruct()

__destruct ( )

Database iterator destructor.

Depuis
1.0

Références DatabaseIterator\freeResult().

Documentation des fonctions membres

◆ count()

count ( )

Get the number of rows in the result set for the executed SQL given by the cursor.

Renvoie
integer The number of rows in the result set.
Voir également
Countable::count()
Depuis
1.0

◆ current()

current ( )

The current element in the iterator.

Renvoie
object
Voir également
Iterator::current()
Depuis
1.0

Références DatabaseIterator\$current.

◆ fetchObject()

fetchObject ( )
protected

Method to fetch a row from the result set cursor as an object.

Renvoie
mixed Either the next row from the result set or false if there are no more rows.
Depuis
1.0

Référencé par DatabaseIterator\next().

◆ freeResult()

freeResult ( )
protected

Method to free up the memory used for the result set.

Renvoie
void
Depuis
1.0

Référencé par DatabaseIterator\__destruct().

◆ key()

key ( )

The key of the current element in the iterator.

Renvoie
scalar
Voir également
Iterator::key()
Depuis
1.0

Références DatabaseIterator\$key.

Référencé par DatabaseIterator\next().

◆ next()

next ( )

Moves forward to the next result from the SQL query.

Renvoie
void
Voir également
Iterator::next()
Depuis
1.0

Références DatabaseIterator\$fetched, $this, DatabaseIterator\fetchObject(), et DatabaseIterator\key().

Référencé par DatabaseIterator\__construct().

◆ rewind()

rewind ( )

Rewinds the iterator.

This iterator cannot be rewound.

Renvoie
void
Voir également
Iterator::rewind()
Depuis
1.0

◆ valid()

valid ( )

Checks if the current position of the iterator is valid.

Renvoie
boolean
Voir également
Iterator::valid()
Depuis
1.0

Documentation des champs

◆ $class

$class
protected

Référencé par DatabaseIterator\__construct().

◆ $column

$column
private

Référencé par DatabaseIterator\__construct().

◆ $current

$current
private

Référencé par DatabaseIterator\current().

◆ $fetched

$fetched = 0
private

Référencé par DatabaseIterator\next().

◆ $key

$key
private

Référencé par DatabaseIterator\key().

◆ $statement

$statement
protected

Référencé par DatabaseIterator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseIterator.php


Joomla CMS: Référence de la classe DatabaseQuery

  • Joomla
  • Database
  • DatabaseQuery
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe DatabaseQuery
+ Graphe d'héritage de DatabaseQuery:
QueryInterface PreparableInterface LimitableInterface MysqliQuery PdoQuery SqlsrvQuery MysqlQuery PgsqlQuery SqliteQuery SqlazureQuery

Fonctions membres publiques

__construct (DatabaseInterface $db=null)
__toString ()
__get ($name)
call ($columns)
castAs (string $type, string $value, ?string $length=null)
castAsChar ($value)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
dateAdd ($date, $interval, $datePart)
dateFormat ()
dump ()
delete ($table=null)
e ($text, $extra=false)
escape ($text, $extra=false)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
innerJoin ($table, $condition=null)
outerJoin ($table, $condition=null)
leftJoin ($table, $condition=null)
rightJoin ($table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
q ($text, $escape=true)
quote ($text, $escape=true)
qn ($name, $as=null)
quoteName ($name, $as=null)
rand ()
regexp ($value)
select ($columns)
set ($conditions, $glue=',')
setLimit ($limit=0, $offset=0)
setQuery ($sql)
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
orWhere ($conditions, $glue='AND')
andWhere ($conditions, $glue='OR')
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
bindArray (array $values, $dataType=ParameterType::INTEGER)
__clone ()
& getBounded ($key=null)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
format ($format)
selectRowNumber ($orderBy, $orderColumnAlias)
- Fonctions membres publiques hérités de QueryInterface
groupConcat ($expression, $separator=',')
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)

Fonctions membres protégées

merge ($name, $query)
validateRowNumber ($orderBy, $orderColumnAlias)

Attributs protégés

$bounded = []
$parameterMapping
$db
$sql
$type = ''
$alias = null
$element
$select
$delete
$update
$insert
$from
$join
$set
$where
$group
$having
$columns
$values
$order
$autoIncrementField = false
$call
$exec
$merge
$querySet
$selectRowNumber
$nullDatetimeList = []
$offset
$limit
$preparedIndex = 0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db = null )

Class constructor.

Paramètres
DatabaseInterface $db The database driver.
Depuis
1.0

Références DatabaseQuery\$db.

Documentation des fonctions membres

◆ __clone()

__clone ( )

Method to provide basic copy support.

Any object pushed into the data of this class should have its own __clone() implementation. This method does not support copying objects in a multidimensional array.

Renvoie
void
Depuis
1.0

Références DatabaseQuery\$element, $i, $this, et elseif.

◆ __get()

__get ( $name )

Magic function to get protected variable value

Paramètres
string $name The name of the variable.
Renvoie
mixed
Depuis
1.0

Références $name, et $this.

◆ __toString()

__toString ( )

Magic function to convert the query to a string.

Renvoie
string The completed query.
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$alias, DatabaseQuery\$element, DatabaseQuery\$join, $query, DatabaseQuery\$querySet, $this, DatabaseQuery\alias(), DatabaseQuery\call(), DatabaseQuery\columns(), elseif, DatabaseQuery\exec(), DatabaseQuery\from(), DatabaseQuery\group(), DatabaseQuery\having(), DatabaseQuery\insert(), DatabaseQuery\join(), Joomla\Database\Query\limit(), DatabaseQuery\merge(), null, Joomla\Database\Query\offset(), DatabaseQuery\order(), LimitableInterface\processLimit(), DatabaseQuery\select(), DatabaseQuery\selectRowNumber(), DatabaseQuery\update(), DatabaseQuery\values(), et DatabaseQuery\where().

◆ alias()

alias ( $alias )

Add alias for current query.

Usage: $query->select('*')->from('#__a')->alias('subquery');

Paramètres
string $alias Alias used for a JDatabaseQuery.
Renvoie
$this
Depuis
2.0.0

Implémente QueryInterface.

Références DatabaseQuery\$alias, et $this.

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ andWhere()

andWhere | ( | $conditions,
 |  | $glue = 'OR'
 | ) |

Extend the WHERE clause with an AND and a single condition or an array of conditions.

Usage: $query->where(array('a = 1', 'b = 2'))->andWhere(array('c = 3', 'd = 4')); will produce: WHERE ((a = 1 AND b = 2) AND (c = 3 OR d = 4)

Paramètres
mixed | $conditions | A string or array of WHERE conditions.
string | $glue | The glue by which to join the conditions. Defaults to OR.
Renvoie
$this
Depuis
1.3.0

Références DatabaseQuery\extendWhere().

◆ bind()

bind | ( |  | $key,
 |  | & | $value,
 |  |  | $dataType = ParameterType::STRING,
 |  |  | $length = 0,
 |  |  | $driverOptions = []
 | ) |  |

Method to add a variable to an internal array that will be bound to a prepared SQL statement before query execution.

Paramètres
array | string | integer | $key | The key that will be used in your SQL query to reference the value. Usually of the form ':key', but can also be an integer.
mixed | $value | The value that will be bound. It can be an array, in this case it has to be same length of $key; The value is passed by reference to support output parameters such as those possible with stored procedures.
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $key
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
$this
Depuis
1.5.0
Exceptions

Implémente PreparableInterface.

Références $count, $key, $this, et $value.

Référencé par DatabaseQuery\bindArray().

◆ bindArray()

bindArray | ( | array | $values,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Binds an array of values and returns an array of prepared parameter names.

Note that all values must be the same data type.

Usage: $query->where('column in (' . implode(',', $query->bindArray($keyValues, $dataType)) . ')');

Paramètres
array | $values | Values to bind
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $key
Renvoie
array An array with parameter names
Depuis
2.0.0

Implémente QueryInterface.

Références $i, DatabaseQuery\$preparedIndex, DatabaseQuery\$values, et DatabaseQuery\bind().

Référencé par DatabaseQuery\whereIn(), et DatabaseQuery\whereNotIn().

◆ call()

call ( $columns )

Add a single column, or array of columns to the CALL clause of the query.

Usage: $query->call('a.*')->call('b.id'); $query->call(array('a.*', 'b.id'));

Paramètres
mixed $columns A string or an array of field names.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ castAs()

castAs | ( | string | $type,
 |  | string | $value,
 |  | ?string | $length = null
 | ) |  |

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAs('CHAR', 'a'));

Paramètres
string | $type | The type of string to cast as.
string | $value | The value to cast as a char.
string | $length | Optionally specify the length of the field (if the type supports it otherwise ignored).
Renvoie
string SQL statement to cast the value as a char type.
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$type, et $value.

Référencé par DatabaseQuery\castAsChar().

◆ castAsChar()

castAsChar ( $value )

Casts a value to a char.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAsChar('a'));

Paramètres
string $value The value to cast as a char.
Renvoie
string SQL statement to cast the value as a char type.
Depuis
1.0
Obsolète:
3.0 Use $query->castAs('CHAR', $value)

Références $value, et DatabaseQuery\castAs().

◆ charLength()

charLength | ( | $field,
 |  | $operator = null,
 |  | $condition = null
 | ) |

Gets the number of characters in a string.

Note, use 'length' to find the number of bytes in a string.

Usage: $query->select($query->charLength('a'));

Paramètres
string | $field | A value.
string | null | $operator | Comparison operator between charLength integer value and $condition
string | null | $condition | Integer value to compare charLength with.
Renvoie
string The required char length call.
Depuis
1.0

Implémente QueryInterface.

Références $field, et null.

◆ clear()

clear ( $clause = null )

Clear data from the query or a specific clause of the query.

Paramètres
string $clause Optionally, the name of the clause to clear, or nothing to clear the whole query.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, DatabaseQuery\alias(), DatabaseQuery\call(), DatabaseQuery\columns(), DatabaseQuery\exec(), DatabaseQuery\from(), DatabaseQuery\group(), DatabaseQuery\having(), DatabaseQuery\insert(), DatabaseQuery\join(), Joomla\Database\Query\limit(), DatabaseQuery\merge(), null, Joomla\Database\Query\offset(), DatabaseQuery\order(), DatabaseQuery\querySet(), DatabaseQuery\select(), DatabaseQuery\selectRowNumber(), DatabaseQuery\update(), DatabaseQuery\values(), et DatabaseQuery\where().

◆ columns()

columns ( $columns )

Adds a column, or array of column names that would be used for an INSERT INTO statement.

Paramètres
array | string $columns A column name, or array of column names.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ concatenate()

concatenate | ( | $values,
 |  | $separator = null
 | ) |

Concatenates an array of column names or values.

Usage: $query->select($query->concatenate(array('a', 'b')));

Paramètres
string[] | $values An array of values to concatenate.
string | null | $separator | As separator to place between each value.
Renvoie
string The concatenated values.
Depuis
1.0

Implémente QueryInterface.

Références $separator, DatabaseQuery\$values, null, et DatabaseQuery\quote().

◆ currentTimestamp()

currentTimestamp ( )

Gets the current date and time.

Usage: $query->where('published_up < '.$query->currentTimestamp());

Renvoie
string
Depuis
1.0

Implémente QueryInterface.

◆ dateAdd()

dateAdd | ( | $date,
 |  | $interval,
 |  | $datePart
 | ) |

Add to the current date and time.

Usage: $query->select($query->dateAdd());

Prefixing the interval with a - (negative sign) will cause subtraction to be used. Note: Not all drivers support all units.

Paramètres
string | $date | The db quoted string representation of the date to add to. May be date or datetime
string | $interval | The string representation of the appropriate number of units
string | $datePart | The part of the date to perform the addition on
Renvoie
string The string with the appropriate sql for addition of dates

1.5.0

Références $date.

◆ dateFormat()

dateFormat ( )

Returns a PHP date() function compliant date format for the database driver.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the getDateFormat method directly.

Renvoie
string The format string.
Depuis
1.0
Exceptions

Références class.

◆ day()

day ( $date )

Used to get a string to extract day from date column.

Usage: $query->select($query->day($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing day to be extracted.
Renvoie
string Returns string to extract day from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

◆ delete()

delete ( $table = null )

Add a table name to the DELETE clause of the query.

Usage: $query->delete('#__a')->where('id = 1');

Paramètres
string $table The name of the table to delete from.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références $this, DatabaseQuery\from(), et null.

◆ dump()

dump ( )

Creates a HTML formatted dump of the query for debugging purposes.

Usage: echo $query->dump();

Renvoie
string
Depuis
1.0
Obsolète:
3.0 Deprecated without replacement

Références $this.

◆ e()

e | ( | $text,
 |  | $extra = false
 | ) |

Alias for escape method

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0
Exceptions

Références $text, et DatabaseQuery\escape().

◆ escape()

escape | ( | $text,
 |  | $extra = false
 | ) |

Method to escape a string for usage in an SQL statement.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the escape method directly.

Note that 'e' is an alias for this method as it is in DatabaseDriver.

Paramètres
string | $text | The string to be escaped.
boolean | $extra | Optional parameter to provide extra escaping.
Renvoie
string The escaped string.
Depuis
1.0
Exceptions

Références $text, et class.

Référencé par DatabaseQuery\e().

◆ exec()

exec ( $columns )

Add a single column, or array of columns to the EXEC clause of the query.

Usage: $query->exec('a.*')->exec('b.id'); $query->exec(array('a.*', 'b.id'));

Paramètres
array | string $columns A string or an array of field names.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ extendWhere()

extendWhere | ( | $outerGlue,
 |  | $conditions,
 |  | $innerGlue = 'AND'
 | ) |

Extend the WHERE clause with a single condition or an array of conditions, with a potentially different logical operator from the one in the current WHERE clause.

Usage: $query->where(array('a = 1', 'b = 2'))->extendWhere('XOR', array('c = 3', 'd = 4')); will produce: WHERE ((a = 1 AND b = 2) XOR (c = 3 AND d = 4)

Paramètres
string | $outerGlue | The glue by which to join the conditions to the current WHERE conditions.
mixed | $conditions | A string or array of WHERE conditions.
string | $innerGlue | The glue by which to join the conditions. Defaults to AND.
Renvoie
$this
Depuis
1.3.0

Implémente QueryInterface.

Références $this, et DatabaseQuery\where().

Référencé par DatabaseQuery\andWhere(), et DatabaseQuery\orWhere().

◆ findInSet()

findInSet | ( | $value,
 |  | $set
 | ) |

Find a value in a varchar used like a set.

Ensure that the value is an integer before passing to the method.

Usage: $query->findInSet((int) $parent->id, 'a.assigned_cat_ids')

Paramètres
string | $value | The value to search for.
string | $set | The set of values.
Renvoie
string A representation of the MySQL find_in_set() function for the driver.
Depuis
1.5.0

Implémente QueryInterface.

◆ format()

format ( $format )

Find and replace sprintf-like tokens in a format string. Each token takes one of the following forms: %% - A literal percent character. %[t] - Where [t] is a type specifier. %[n]$[x] - Where [n] is an argument specifier and [t] is a type specifier.

Types: a - Numeric: Replacement text is coerced to a numeric type but not quoted or escaped. e - Escape: Replacement text is passed to $this->escape(). E - Escape (extra): Replacement text is passed to $this->escape() with true as the second argument. n - Name Quote: Replacement text is passed to $this->quoteName(). q - Quote: Replacement text is passed to $this->quote(). Q - Quote (no escape): Replacement text is passed to $this->quote() with false as the second argument. r - Raw: Replacement text is used as-is. (Be careful)

Date Types:

  • Replacement text automatically quoted (use uppercase for Name Quote).
  • Replacement text should be a string in date format or name of a date column. y/Y - Year m/M - Month d/D - Day h/H - Hour i/I - Minute s/S - Second

Invariable Types:

  • Takes no argument.
  • Argument index not incremented. t - Replacement text is the result of $this->currentTimestamp(). z - Replacement text is the result of $this->nullDate(false). Z - Replacement text is the result of $this->nullDate(true).

Usage: $query->format('SELECT %1$n FROM %2$n WHERE %3$n = %4$a', 'foo', '#__foo', 'bar', 1); Returns: SELECT foo FROM #__foo WHERE bar = 1

Notes: The argument specifier is optional but recommended for clarity. The argument index used for unspecified tokens is incremented only when used.

Paramètres
string $format The formatting string.
Renvoie
string Returns a string produced according to the formatting string.
Depuis
1.0

Regexp to find an replace all tokens. Matched fields: 0: Full token 1: Everything following '' 2: Everything following '' unless '' 3: Argument specifier and '$' 4: Argument specifier 5: Type specifier 6: '' if full token is '%'

Références $format, $i, $query, $this, et null.

◆ from()

from ( $table )

Add a table to the FROM clause of the query.

Usage: $query->select('*')->from('#__a'); $query->select('*')->from($subquery->alias('a'));

Paramètres
string | DatabaseQuery $table The name of the table or a DatabaseQuery object (or a child of it) with alias set.
Renvoie
$this
Depuis
1.0
Exceptions

Implémente QueryInterface.

Références $this, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), DatabaseQuery\delete(), SqlsrvQuery\fixGroupColumns(), et SqlsrvQuery\group().

◆ getBounded()

& getBounded ( $key = null )

Retrieves the bound parameters array when key is null and returns it by reference. If a key is provided then that item is returned.

Paramètres
mixed $key The bounded variable key to retrieve.
Renvoie
mixed
Depuis
1.5.0

Implémente PreparableInterface.

Références DatabaseQuery\$bounded, et $key.

◆ group()

group ( $columns )

Add a grouping column to the GROUP clause of the query.

Usage: $query->group('id');

Paramètres
array | string $columns A string or array of ordering columns.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ having()

having | ( | $conditions,
 |  | $glue = 'AND'
 | ) |

A conditions to the HAVING clause of the query.

Usage: $query->group('id')->having('COUNT(id) > 5');

Paramètres
array | string | $conditions | A string or array of columns.
string | $glue | The glue by which to join the conditions. Defaults to AND.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, et null.

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ hour()

hour ( $date )

Used to get a string to extract hour from date column.

Usage: $query->select($query->hour($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing hour to be extracted.
Renvoie
string Returns string to extract hour from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

◆ innerJoin()

innerJoin | ( | $table,
 |  | $condition = null
 | ) |

Add an INNER JOIN clause to the query.

Usage: $query->innerJoin('b', 'b.id = a.id')->innerJoin('c', 'c.id = b.id');

Paramètres
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
1.0

Références DatabaseQuery\join().

◆ insert()

insert | ( | $table,
 |  | $incrementField = false
 | ) |

Add a table name to the INSERT clause of the query.

Usage: $query->insert('#__a')->set('id = 1'); $query->insert('#__a')->columns('id, title')->values('1,2')->values('3,4'); $query->insert('#__a')->columns('id, title')->values(array('1,2', '3,4'));

Paramètres
string | $table | The name of the table to insert data into.
boolean | $incrementField | The name of the field to auto increment.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références $this, et null.

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ isNullDatetime()

isNullDatetime ( $column )

Generate a SQL statement to check if column represents a zero or null datetime.

Usage: $query->where($query->isNullDatetime('modified_date'));

Paramètres
string $column A column name.
Renvoie
string
Depuis
2.0.0

Implémente QueryInterface.

Références $this, et class.

◆ join()

join | ( | $type,
 |  | $table,
 |  | $condition = null
 | ) |

Add a JOIN clause to the query.

Usage: $query->join('INNER', 'b', 'b.id = a.id);

Paramètres
string | $type | The type of join. This string is prepended to the JOIN keyword.
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, DatabaseQuery\$type, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\group(), DatabaseQuery\innerJoin(), DatabaseQuery\leftJoin(), DatabaseQuery\outerJoin(), et DatabaseQuery\rightJoin().

◆ leftJoin()

leftJoin | ( | $table,
 |  | $condition = null
 | ) |

Add a LEFT JOIN clause to the query.

Usage: $query->leftJoin('b', 'b.id = a.id')->leftJoin('c', 'c.id = b.id');

Paramètres
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
1.0

Références DatabaseQuery\join().

◆ length()

length ( $value )

Get the length of a string in bytes.

Note, use 'charLength' to find the number of characters in a string.

Usage: query->where($query->length('a').' > 3');

Paramètres
string $value The string to measure.
Renvoie
integer
Depuis
1.0

Implémente QueryInterface.

Références $value.

◆ merge()

merge | ( | $name,
 |  | $query
 | ) |
protected

Combine a select statement to the current query by one of the set operators. Operators: UNION, UNION ALL, EXCEPT or INTERSECT.

Paramètres
string | $name | The name of the set operator with parentheses.
DatabaseQuery | string | $query | The DatabaseQuery object or string.
Renvoie
$this
Depuis
2.0.0

Références $name, $query, et $this.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), SqliteQuery\union(), SqlsrvQuery\union(), et DatabaseQuery\union().

◆ minute()

minute ( $date )

Used to get a string to extract minute from date column.

Usage: $query->select($query->minute($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing minute to be extracted.
Renvoie
string Returns string to extract minute from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

◆ month()

month ( $date )

Used to get a string to extract month from date column.

Usage: $query->select($query->month($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing month to be extracted.
Renvoie
string Returns string to extract month from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

◆ nullDate()

nullDate ( $quoted = true )

Get the null or zero representation of a timestamp for the database driver.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the nullDate method directly.

Usage: $query->where('modified_date <> '.$query->nullDate());

Paramètres
boolean $quoted Optionally wraps the null date in database quotes (true by default).
Renvoie
string Null or zero representation of a timestamp.
Depuis
1.0
Exceptions

Implémente QueryInterface.

Références $result, et class.

◆ order()

order ( $columns )

Add a ordering column to the ORDER clause of the query.

Usage: $query->order('foo')->order('bar'); $query->order(array('foo','bar'));

Paramètres
array | string $columns A string or array of ordering columns.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), et SqlsrvQuery\fixGroupColumns().

◆ orWhere()

orWhere | ( | $conditions,
 |  | $glue = 'AND'
 | ) |

Extend the WHERE clause with an OR and a single condition or an array of conditions.

Usage: $query->where(array('a = 1', 'b = 2'))->orWhere(array('c = 3', 'd = 4')); will produce: WHERE ((a = 1 AND b = 2) OR (c = 3 AND d = 4)

Paramètres
mixed | $conditions | A string or array of WHERE conditions.
string | $glue | The glue by which to join the conditions. Defaults to AND.
Renvoie
$this
Depuis
1.3.0

Références DatabaseQuery\extendWhere().

◆ outerJoin()

outerJoin | ( | $table,
 |  | $condition = null
 | ) |

Add an OUTER JOIN clause to the query.

Usage: $query->outerJoin('b', 'b.id = a.id')->leftJoin('c', 'c.id = b.id');

Paramètres
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
1.0

Références DatabaseQuery\join().

◆ q()

q | ( | $text,
 |  | $escape = true
 | ) |

Alias for quote method

Paramètres
array | string | $text | A string or an array of strings to quote.
boolean | $escape | True (default) to escape the string, false to leave it unchanged.
Renvoie
string The quoted input string.
Depuis
1.0
Exceptions

Références $text, et DatabaseQuery\quote().

◆ qn()

qn | ( | $name,
 |  | $as = null
 | ) |

Alias for quoteName method

Paramètres
array | string | $name | The identifier name to wrap in quotes, or an array of identifier names to wrap in quotes. Each type supports dot-notation name.
array | string | $as | The AS query part associated to $name. It can be string or array, in latter case it has to be same length of $name; if is null there will not be any AS part for string or array element.
Renvoie
array|string The quote wrapped name, same type of $name.
Depuis
1.0
Exceptions

Références $name, et DatabaseQuery\quoteName().

◆ querySet()

querySet ( $query )

Set a single query to the query set. On this type of DatabaseQuery you can use union(), unionAll(), order() and setLimit()

Usage: $query->querySet($query2->select('name')->from('#__foo')->order('id DESC')->setLimit(1)) ->unionAll($query3->select('name')->from('#__foo')->order('id')->setLimit(1)) ->order('name') ->setLimit(1)

Paramètres
DatabaseQuery $query The DatabaseQuery object or string.
Renvoie
$this
Depuis
2.0.0

Implémente QueryInterface.

Références $query, et $this.

Référencé par DatabaseQuery\clear().

◆ quote()

quote | ( | $text,
 |  | $escape = true
 | ) |

Method to quote and optionally escape a string to database requirements for insertion into the database.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the quote method directly.

Note that 'q' is an alias for this method as it is in DatabaseDriver.

Usage: $query->quote('fulltext'); $query->q('fulltext'); $query->q(array('option', 'fulltext'));

Paramètres
array | string | $text | A string or an array of strings to quote.
boolean | $escape | True (default) to escape the string, false to leave it unchanged.
Renvoie
string The quoted input string.
Depuis
1.0
Exceptions

Références $text, et class.

Référencé par SqliteQuery\concatenate(), SqlsrvQuery\concatenate(), DatabaseQuery\concatenate(), SqliteQuery\groupConcat(), SqlsrvQuery\groupConcat(), et DatabaseQuery\q().

◆ quoteName()

quoteName | ( | $name,
 |  | $as = null
 | ) |

Wrap an SQL statement identifier name such as column, table or database names in quotes to prevent injection risks and reserved word conflicts.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the quoteName method directly.

Note that 'qn' is an alias for this method as it is in DatabaseDriver.

Usage: $query->quoteName('#__a'); $query->qn('#__a');

Paramètres
array | string | $name | The identifier name to wrap in quotes, or an array of identifier names to wrap in quotes. Each type supports dot-notation name.
array | string | $as | The AS query part associated to $name. It can be string or array, in latter case it has to be same length of $name; if is null there will not be any AS part for string or array element.
Renvoie
array|string The quote wrapped name, same type of $name.
Depuis
1.0
Exceptions

Références $name, et class.

Référencé par SqlsrvQuery\fixSelectAliases(), et DatabaseQuery\qn().

◆ rand()

rand ( )

Get the function to return a random floating-point value

Usage: $query->rand();

Renvoie
string
Depuis
1.5.0

Implémente QueryInterface.

◆ regexp()

regexp ( $value )

Get the regular expression operator

Usage: $query->where('field ' . $query->regexp($search));

Paramètres
string $value The regex pattern.
Renvoie
string
Depuis
1.5.0

Implémente QueryInterface.

Références $value.

◆ rightJoin()

rightJoin | ( | $table,
 |  | $condition = null
 | ) |

Add a RIGHT JOIN clause to the query.

Usage: $query->rightJoin('b', 'b.id = a.id')->rightJoin('c', 'c.id = b.id');

Paramètres
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
1.0

Références DatabaseQuery\join().

◆ second()

second ( $date )

Used to get a string to extract seconds from date column.

Usage: $query->select($query->second($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing second to be extracted.
Renvoie
string Returns string to extract second from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

◆ select()

select ( $columns )

Add a single column, or array of columns to the SELECT clause of the query.

Note that you must not mix insert, update, delete and select method calls when building a query. The select method can, however, be called multiple times in the same query.

Usage: $query->select('a.*')->select('b.id'); $query->select(array('a.*', 'b.id'));

Paramètres
array | string $columns A string or an array of field names.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références DatabaseQuery\$columns, $this, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), SqlsrvQuery\fixSelectAliases(), SqlsrvQuery\group(), et DatabaseQuery\selectRowNumber().

◆ selectRowNumber()

selectRowNumber | ( | $orderBy,
 |  | $orderColumnAlias
 | ) |

Return the number of the current row.

Usage: $query->select('id'); $query->selectRowNumber('ordering,publish_up DESC', 'new_ordering'); $query->from('#__content');

Paramètres
string | $orderBy | An expression of ordering for window function.
string | $orderColumnAlias | An alias for new ordering column.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente QueryInterface.

Références DatabaseQuery\select(), et DatabaseQuery\validateRowNumber().

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), et DatabaseQuery\validateRowNumber().

◆ set()

set | ( | $conditions,
 |  | $glue = ','
 | ) |

Add a single condition string, or an array of strings to the SET clause of the query.

Usage: $query->set('a = 1')->set('b = 2'); $query->set(array('a = 1', 'b = 2');

Paramètres
array | string | $conditions | A string or array of string conditions.
string | $glue | The glue by which to join the condition strings. Defaults to ,. Note that the glue is set on first use and cannot be changed.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, et null.

◆ setLimit()

setLimit | ( | $limit = 0,
 |  | $offset = 0
 | ) |

Sets the offset and limit for the result set, if the database driver supports it.

Usage: $query->setLimit(100, 0); (retrieve 100 rows, starting at first record) $query->setLimit(50, 50); (retrieve 50 rows, starting at 50th record)

Paramètres
integer | $limit | The limit for the result set
integer | $offset | The offset for the result set
Renvoie
$this
Depuis
2.0.0

Implémente LimitableInterface.

Références DatabaseQuery\$limit, DatabaseQuery\$offset, $this, Joomla\Database\Query\limit(), et Joomla\Database\Query\offset().

◆ setQuery()

setQuery ( $sql )

Allows a direct query to be provided to the database driver's setQuery() method, but still allow queries to have bounded variables.

Usage: $query->setQuery('select * from #__users');

Paramètres
DatabaseQuery | string $sql A SQL query string or DatabaseQuery object
Renvoie
$this
Depuis
1.0

Références DatabaseQuery\$sql, et $this.

◆ toQuerySet()

toQuerySet ( )

Create a DatabaseQuery object of type querySet from current query.

Usage: $query->select('name')->from('#__foo')->order('id DESC')->setLimit(1) ->toQuerySet() ->unionAll($query2->select('name')->from('#__foo')->order('id')->setLimit(1)) ->order('name') ->setLimit(1)

Renvoie
DatabaseQuery A new object of the DatabaseQuery.
Depuis
2.0.0

Implémente QueryInterface.

Références $this.

◆ unbind()

unbind ( $key )

Method to unbind a bound variable.

Paramètres
array | string | integer $key The key or array of keys to unbind.
Renvoie
$this
Depuis
2.0.0

Implémente PreparableInterface.

Références $key, et $this.

◆ union()

union | ( | $query,
 |  | $distinct = true
 | ) |

Add a query to UNION with the current query.

Usage: $query->union('SELECT name FROM #__foo') $query->union('SELECT name FROM #__foo', true)

Paramètres
DatabaseQuery | string | $query | The DatabaseQuery object or string to union.
boolean | $distinct | True to only return distinct rows from the union.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $query, et DatabaseQuery\merge().

◆ unionAll()

unionAll ( $query )

Add a query to UNION ALL with the current query.

Usage: $query->unionAll('SELECT name FROM #__foo')

Paramètres
DatabaseQuery | string $query The DatabaseQuery object or string to union.
Renvoie
$this
Voir également
union
Depuis
1.5.0

Implémente QueryInterface.

Références $query.

◆ update()

update ( $table )

Add a table name to the UPDATE clause of the query.

Usage: $query->update('#__foo')->set(...);

Paramètres
string $table A table to update.
Renvoie
$this
Depuis
1.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémente QueryInterface.

Références $this, et null.

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ validateRowNumber()

validateRowNumber | ( | $orderBy,
 |  | $orderColumnAlias
 | ) |
protected

Validate arguments which are passed to selectRowNumber method and set up common variables.

Paramètres
string | $orderBy | An expression of ordering for window function.
string | $orderColumnAlias | An alias for new ordering column.
Renvoie
void
Depuis
2.0.0
Exceptions

Références DatabaseQuery\selectRowNumber().

Référencé par SqliteQuery\selectRowNumber(), et DatabaseQuery\selectRowNumber().

◆ values()

values ( $values )

Adds a tuple, or array of tuples that would be used as values for an INSERT INTO statement.

Usage: $query->values('1,2,3')->values('4,5,6'); $query->values(array('1,2,3', '4,5,6'));

Paramètres
array | string $values A single tuple, or array of tuples.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, DatabaseQuery\$values, et null.

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), et DatabaseQuery\clear().

◆ where()

where | ( | $conditions,
 |  | $glue = 'AND'
 | ) |

Add a single condition, or an array of conditions to the WHERE clause of the query.

Usage: $query->where('a = 1')->where('b = 2'); $query->where(array('a = 1', 'b = 2'));

Paramètres
array | string | $conditions | A string or array of where conditions.
string | $glue | The glue by which to join the conditions. Defaults to AND. Note that the glue is set on first use and cannot be changed.
Renvoie
$this
Depuis
1.0

Implémente QueryInterface.

Références $this, et null.

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\clear(), DatabaseQuery\extendWhere(), DatabaseQuery\whereIn(), et DatabaseQuery\whereNotIn().

◆ whereIn()

whereIn | ( | string | $keyName,
 |  | array | $keyValues,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Add a WHERE IN statement to the query.

Note that all values must be the same data type.

Usage $query->whereIn('id', [1, 2, 3]);

Paramètres
string | $keyName | Key name for the where clause
array | $keyValues | Array of values to be matched
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $keyValues
Renvoie
$this
Depuis
2.0.0

Implémente QueryInterface.

Références DatabaseQuery\bindArray(), et DatabaseQuery\where().

◆ whereNotIn()

whereNotIn | ( | string | $keyName,
 |  | array | $keyValues,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Add a WHERE NOT IN statement to the query.

Note that all values must be the same data type.

Usage $query->whereNotIn('id', [1, 2, 3]);

Paramètres
string | $keyName | Key name for the where clause
array | $keyValues | Array of values to be matched
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $keyValues
Renvoie
$this
Depuis
2.0.0

Implémente QueryInterface.

Références DatabaseQuery\bindArray(), et DatabaseQuery\where().

◆ year()

year ( $date )

Used to get a string to extract year from date column.

Usage: $query->select($query->year($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing year to be extracted.
Renvoie
string Returns string to extract year from a date.
Depuis
1.0

Implémente QueryInterface.

Références $date.

Documentation des champs

◆ $alias

$alias = null
protected

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\__toString(), DatabaseQuery\alias(), SqlsrvQuery\fixGroupColumns(), et SqlsrvQuery\group().

◆ $autoIncrementField

$autoIncrementField = false
protected

◆ $bounded

$bounded = []
protected

Référencé par DatabaseQuery\getBounded().

◆ $call

$call
protected

◆ $columns

$columns
protected

Référencé par SqlsrvQuery\__toString(), DatabaseQuery\call(), DatabaseQuery\columns(), DatabaseQuery\exec(), SqlsrvQuery\fixSelectAliases(), SqlsrvQuery\group(), DatabaseQuery\group(), DatabaseQuery\order(), DatabaseQuery\select(), et SqlsrvQuery\splitSqlExpression().

◆ $db

$db
protected

Référencé par DatabaseQuery\__construct(), et SqliteQuery\__toString().

◆ $delete

$delete
protected

◆ $element

$element
protected

Référencé par DatabaseQuery\__clone(), SqliteQuery\__toString(), SqlsrvQuery\__toString(), et DatabaseQuery\__toString().

◆ $exec

$exec
protected

◆ $from

$from
protected

Référencé par SqlsrvQuery\__toString().

◆ $group

$group
protected

◆ $having

$having
protected

◆ $insert

$insert
protected

◆ $join

$join
protected

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), DatabaseQuery\__toString(), SqlsrvQuery\fixGroupColumns(), et SqlsrvQuery\group().

◆ $limit

$limit
protected

Référencé par SqliteQuery\__toString(), SqliteQuery\processLimit(), SqlsrvQuery\processLimit(), et DatabaseQuery\setLimit().

◆ $merge

$merge
protected

◆ $nullDatetimeList

$nullDatetimeList = []
protected

◆ $offset

$offset
protected

Référencé par SqliteQuery\__toString(), SqliteQuery\processLimit(), SqlsrvQuery\processLimit(), et DatabaseQuery\setLimit().

◆ $order

$order
protected

Référencé par SqliteQuery\__toString().

◆ $parameterMapping

$parameterMapping
protected
Valeur initiale :
= [
ParameterType::BOOLEAN => ParameterType::BOOLEAN

◆ $preparedIndex

$preparedIndex = 0
protected

Référencé par DatabaseQuery\bindArray().

◆ $querySet

$querySet
protected

Référencé par SqliteQuery\__toString(), SqlsrvQuery\__toString(), et DatabaseQuery\__toString().

◆ $select

$select
protected

Référencé par SqliteQuery\__toString().

◆ $selectRowNumber

$selectRowNumber
protected

◆ $set

$set
protected

◆ $sql

$sql
protected

Référencé par SqlsrvQuery\__toString(), et DatabaseQuery\setQuery().

◆ $type

$type = ''
protected

Référencé par SqlsrvQuery\castAs(), DatabaseQuery\castAs(), SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\group(), et DatabaseQuery\join().

◆ $update

$update
protected

Référencé par SqlsrvQuery\__toString().

◆ $values

$values
protected

Référencé par DatabaseQuery\bindArray(), SqliteQuery\concatenate(), SqlsrvQuery\concatenate(), DatabaseQuery\concatenate(), et DatabaseQuery\values().

◆ $where

$where
protected

Référencé par SqliteQuery\__toString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseQuery.php


Joomla CMS: Référence de la classe FetchMode

  • Joomla
  • Database
  • FetchMode
Champs de données | Fonctions membres privées
Référence de la classe FetchMode

Champs de données

const | ASSOCIATIVE = 2
const | NUMERIC = 3
const | MIXED = 4
const | STANDARD_OBJECT = 5
const | COLUMN = 7
const | CUSTOM_OBJECT = 8

Fonctions membres privées

__construct ()

Description détaillée

Class defining the fetch mode for prepared statements

The values of the constants in this class match the PDO::FETCH_* constants.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ ASSOCIATIVE

const ASSOCIATIVE = 2

Référencé par MysqliStatement\fetch().

◆ COLUMN

const COLUMN = 7

Référencé par SqlsrvStatement\fetch(), et MysqliStatement\fetch().

◆ CUSTOM_OBJECT

const CUSTOM_OBJECT = 8

Référencé par DatabaseIterator\__construct(), et SqlsrvStatement\fetch().

◆ MIXED

const MIXED = 4

Référencé par MysqliStatement\fetch().

◆ NUMERIC

const NUMERIC = 3

Référencé par MysqliStatement\fetch(), et MysqliStatement\fetchColumn().

◆ STANDARD_OBJECT

const STANDARD_OBJECT = 5

Référencé par DatabaseIterator\__construct(), SqlsrvStatement\fetch(), et MysqliStatement\fetch().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FetchMode.php


Joomla CMS: Référence de la classe FetchOrientation

  • Joomla
  • Database
  • FetchOrientation
Champs de données | Fonctions membres privées
Référence de la classe FetchOrientation

Champs de données

const | NEXT = 0
const | PRIOR = 1
const | FIRST = 2
const | LAST = 3
const | ABS = 4
const | REL = 5

Fonctions membres privées

__construct ()

Description détaillée

Class defining the fetch orientation for prepared statements

The values of the constants in this class match the PDO::FETCH_ORI_* constants.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ ABS

const ABS = 4

◆ FIRST

const FIRST = 2

◆ LAST

const LAST = 3

◆ NEXT

const NEXT = 0

◆ PRIOR

const PRIOR = 1

◆ REL

const REL = 5
La documentation de cette classe a été générée à partir du fichier suivant :
  • FetchOrientation.php


Joomla CMS: Référence de la classe ParameterType

  • Joomla
  • Database
  • ParameterType
Champs de données | Fonctions membres privées
Référence de la classe ParameterType

Champs de données

const | BOOLEAN = 'boolean'
const | INTEGER = 'int'
const | LARGE_OBJECT = 'lob'
const | NULL = 'null'
const | STRING = 'string'

Fonctions membres privées

__construct ()

Description détaillée

Class defining the parameter types for prepared statements

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ BOOLEAN

const BOOLEAN = 'boolean'

Référencé par SqlsrvStatement\__construct().

◆ INTEGER

const INTEGER = 'int'

Référencé par SqlsrvStatement\__construct(), Category\_getAssetParentId(), Content\_getAssetParentId(), PackageAdapter\_getExtensionId(), Categories\_load(), ModuleAdapter\_rollback_menu(), ModuleAdapter\_rollback_module(), ComponentAdapter\_updateMenus(), Installer\abort(), Task\acquireLock(), PlgSampledataMultilang\addAssociations(), PlgSampledataMultilang\addModuleInModuleMenu(), MessagesModel\addPostInstallationMessage(), UserHelper\addUserToGroup(), MfaTable\afterDelete(), UpdateModel\applyUpdateSite(), MessagesModel\archiveMessage(), AdministratorService\association(), Menus\association(), ModuleModel\batchCopy(), ItemModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), CategoryModel\batchFlipordering(), ItemModel\batchMove(), CategoryModel\batchMove(), LinksModel\batchProcess(), UserModel\batchReset(), UserModel\batchUser(), ContactModel\buildContactExtendedData(), ContentHelper\canDeleteState(), Category\categories(), Usergroup\check(), MenuType\check(), ViewLevel\check(), StageTable\check(), User\check(), Installer\cleanDiscoveredExtension(), ArticleModel\cleanupPostBatchCopy(), BannerModel\click(), BannerTable\clicks(), DatabaseHandler\close(), NewsfeedsHelper\countItems(), HtmlDocument\countMenuChildren(), NewsfeedsHelper\countTagItems(), Workflow\createAssociation(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), MetadataManager\createSessionRecord(), MenuTable\delete(), StageTable\delete(), WorkflowTable\delete(), UCMContent\delete(), UpdatesitesModel\delete(), StyleTable\delete(), TracksModel\delete(), MenuType\delete(), Usergroup\delete(), ModuleModel\delete(), User\delete(), AdminModel\delete(), MethodsModel\deleteAll(), CoreContent\deleteByContentId(), MetadataManager\deletePriorTo(), DeleteUserCommand\doExecute(), ModuleModel\duplicate(), ContactModel\featured(), ArticleModel\featured(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), DatabaseModel\fixSchemaVersion(), StyleModel\getAdminTemplate(), TemplateModel\getAllTemplateStyles(), Router\getArticleId(), Router\getArticleSegment(), Access\getAssetRules(), FieldsHelper\getAssignedCategoriesTitles(), ConsentBoxField\getAssignedMenuItemUrl(), Workflow\getAssociation(), AssociationsHelper\getAssociationHtmlList(), CategoriesHelper\getAssociations(), Associations\getAssociations(), TracksModel\getCategoryName(), UpdateModel\getCheckForSelfUpdate(), TracksModel\getClientName(), Router\getContactId(), Router\getContactSegment(), ExtensionHelper\getCoreExtensionIds(), Workflow\getDefaultStageByCategory(), ModulesModel\getEmptyStateQuery(), InstallerHelper\getExtensionDownloadKey(), MessagesModel\getExtensionName(), ExtensionHelper\getExtensionRecord(), DebuggroupModel\getGroup(), MenuField\getGroups(), TemplatestyleField\getGroups(), Access\getGroupsByUser(), Access\getGroupTitle(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), RulesField\getInput(), ConfigModel\getItem(), MessagesModel\getItem(), NewsfeedModel\getItem(), UpdatesiteModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), FieldModel\getItem(), ArticleModel\getItem(), ModuleModel\getItem(), InstallerScript\getItemArray(), MenusModel\getItems(), PositionsModel\getItems(), ClientsModel\getItems(), TagsHelper\getItemTags(), TosField\getLabel(), PlgSampledataMultilang\getLanguageList(), PrivacyField\getLayoutData(), TermsField\getLayoutData(), TagsSimilarHelper\getList(), RequestsModel\getListQuery(), ConsentsModel\getListQuery(), NotesModel\getListQuery(), FeaturedModel\getListQuery(), SelectModel\getListQuery(), ActionlogsModel\getListQuery(), ArchiveModel\getListQuery(), TracksModel\getListQuery(), DiscoverModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), LevelsModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), StylesModel\getListQuery(), TemplatesModel\getListQuery(), GroupsModel\getListQuery(), StagesModel\getListQuery(), TransitionsModel\getListQuery(), LinksModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), MenusModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), DebuguserModel\getListQuery(), PluginsModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), ActionlogsModel\getLogsForItem(), ContenthistoryHelper\getLookupValue(), LoginModel\getMenuLanguage(), MenusHelper\getMenuLinks(), MenusHelper\getMenuTypes(), MenusModel\getModMenuId(), ItemModel\getModules(), Router\getNewsfeedId(), Router\getNewsfeedSegment(), MfaTable\getNumRecords(), MenuParentField\getOptions(), MenuOrderingField\getOptions(), TransitionField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), ModulesHelper\getPositions(), UCMContent\getPrimaryKey(), OrderingField\getQuery(), DatabaseModel\getSchemaVersion(), Updater\getSitesWithUpdates(), TagsHelper\getTagItemsQuery(), TaskModel\getTask(), TemplateModel\getTemplate(), TemplatesHelper\getTemplateOptions(), ModulesHelper\getTemplates(), ChromestyleField\getTemplates(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), UCMType\getType(), TemplateModel\getUpdatedList(), UpdateModel\getUpdateInformation(), UpdateAdapter\getUpdateSiteName(), Updater\getUpdateSites(), UpdateModel\getUpdateSitesInfo(), InstallerHelper\getUpdateSitesInformation(), UsersModel\getUserDisplayedGroups(), Access\getUsersByGroup(), Workflow\getValidTransition(), MessagesModel\hideMessages(), BannersModel\impress(), Indexer\index(), Token\isTokenEnabledForUser(), Menu\linkOptions(), User\load(), UserGroupsHelper\load(), ManageModel\loadChangelog(), FinderHelper\logSearch(), Menu\menuItems(), Menu\menus(), PlgUserProfile\onContentPrepareData(), PlgFinderCategories\onFinderChangeState(), ContentHelper\onPrepareForm(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgUserToken\onUserAfterDelete(), PlgUserProfile\onUserAfterDelete(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), Category\options(), Tag\options(), Menu\ordering(), ModuleController\orderPosition(), TemplateAdapter\parseQueries(), Installer\parseSchemaUpdates(), Modules\positionList(), WorkflowController\postSaveHook(), FormModel\preprocessForm(), TemplateModel\publish(), MessagesModel\purge(), Usergroup\rebuild(), ItemModel\rebuild(), RegistrationModel\register(), Task\releaseLock(), Indexer\remove(), MessagesModel\republishMessage(), MessagesModel\resetMessages(), LanguageAdapter\resetUserLanguage(), MenusHelper\resolveAlias(), MenusController\resync(), FieldModel\save(), ConfigModel\save(), UpdatesiteModel\save(), StyleModel\save(), CategoryModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), TagsHelper\searchTags(), MailModel\send(), FieldModel\setFieldValue(), MethodsModel\setFlag(), StyleModel\setHome(), User\setLastVisit(), InstallerScript\setParams(), Installer\setSchemaVersion(), StyleTable\store(), Menu\store(), User\store(), CoreContent\storeUcmBase(), ArticleModel\storeVote(), MfaTable\switchDefaultRecord(), TagsHelper\tagDeleteInstances(), Tag\tags(), Users\templatestyle(), UsernameRule\test(), UserIdRule\test(), EmailRule\test(), UpdateAdapter\toggleUpdateSite(), MessagesModel\unpublishMessage(), StyleModel\unsetHome(), TagsHelper\unTagItem(), Workflow\updateAssociations(), TemplatesModel\updated(), Updater\updateLastCheckTimestamp(), MetadataManager\updateSessionRecord(), et DatabaseHandler\write().

◆ LARGE_OBJECT

const LARGE_OBJECT = 'lob'

Référencé par SqlsrvStatement\__construct(), Indexer\index(), FinderHelper\logSearch(), et SqlsrvStatement\prepare().

◆ NULL

const NULL = 'null'

Référencé par SqlsrvStatement\__construct(), ArticleModel\cleanupPostBatchCopy(), et ArticleModel\featured().

◆ STRING

const STRING = 'string'

Référencé par SqlsrvStatement\__construct(), Categories\_load(), PlgSampledataMultilang\addAssociations(), TagsHelper\addTagMapping(), ContactModel\buildContactExtendedData(), ArticleModel\cleanupPostBatchCopy(), TagsHelper\convertPathsToNames(), Versioning\delete(), ContentHistory\deleteOldVersions(), ArticleModel\featured(), Versioning\get(), ExtensionHelper\getCoreExtensionIds(), InstallerHelper\getExtensionDownloadKey(), ContentHistory\getHashMatch(), ArticleModel\getItem(), InstallerScript\getItemArray(), MenusModel\getItems(), TagsHelper\getItemTags(), TagsPopularHelper\getList(), TagsSimilarHelper\getList(), ArticlesArchiveHelper\getList(), BannersModel\getListQuery(), FeaturedModel\getListQuery(), TagsModel\getListQuery(), TasksModel\getListQuery(), GroupsModel\getListQuery(), FieldsModel\getListQuery(), ModulesModel\getListQuery(), HistoryModel\getListQuery(), MenusHelper\getMenuItems(), MenusHelper\getMenuLinks(), TagField\getOptions(), CategoryeditField\getOptions(), PlgSystemUpdatenotification\getSuperUsers(), TagsHelper\getTagItemsQuery(), TaskModel\getTask(), MailTemplate\getTemplate(), Query\getTokenData(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), TagsHelper\getTypes(), UpdateModel\isTemplateActive(), Token\isTokenEnabledForUser(), PlgUserToken\onUserAfterDelete(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), Category\options(), Tag\options(), TemplateAdapter\parseQueries(), Access\preloadComponents(), StringsModel\refresh(), FieldModel\save(), ConfigModel\save(), CategoryModel\save(), AdminModel\save(), ItemModel\save(), TagsHelper\searchTags(), et MethodsModel\setFlag().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ParameterType.php


Joomla CMS: Référence de l'interface QueryInterface

  • Joomla
  • Database
  • QueryInterface
Fonctions membres publiques
Référence de l'interface QueryInterface
+ Graphe d'héritage de QueryInterface:
PreparableInterface LimitableInterface DatabaseQuery MysqliQuery PdoQuery SqlsrvQuery MysqlQuery PgsqlQuery SqliteQuery SqlazureQuery

Fonctions membres publiques

__toString ()
call ($columns)
castAs (string $type, string $value, ?string $length=null)
charLength ($field, $operator=null, $condition=null)
clear ($clause=null)
columns ($columns)
concatenate ($values, $separator=null)
currentTimestamp ()
delete ($table=null)
exec ($columns)
findInSet ($value, $set)
from ($table)
alias ($alias)
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
group ($columns)
groupConcat ($expression, $separator=',')
having ($conditions, $glue='AND')
insert ($table, $incrementField=false)
join ($type, $table, $condition=null)
length ($value)
nullDate ($quoted=true)
isNullDatetime ($column)
order ($columns)
rand ()
regexp ($value)
select ($columns)
selectRowNumber ($orderBy, $orderColumnAlias)
set ($conditions, $glue=',')
update ($table)
values ($values)
where ($conditions, $glue='AND')
whereIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
whereNotIn (string $keyName, array $keyValues, $dataType=ParameterType::INTEGER)
extendWhere ($outerGlue, $conditions, $innerGlue='AND')
bindArray (array $values, $dataType=ParameterType::INTEGER)
union ($query, $distinct=true)
unionAll ($query)
querySet ($query)
toQuerySet ()
- Fonctions membres publiques hérités de PreparableInterface
bind ($key, &$value, $dataType=ParameterType::STRING, $length=0, $driverOptions=[])
unbind ($key)
& getBounded ($key=null)
- Fonctions membres publiques hérités de LimitableInterface
processLimit ($query, $limit, $offset=0)
setLimit ($limit=0, $offset=0)

Description détaillée

Joomla Framework Query Building Interface.

Depuis
2.0.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Convert the query object to a string.

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseQuery, SqlsrvQuery, et SqliteQuery.

◆ alias()

alias ( $alias )

Add alias for current query.

Usage: $query->select('*')->from('#__a')->alias('subquery');

Paramètres
string $alias Alias used for a JDatabaseQuery.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ bindArray()

bindArray | ( | array | $values,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Binds an array of values and returns an array of prepared parameter names.

Note that all values must be the same data type.

Usage: $query->whereIn('column in (' . implode(',', $query->bindArray($keyValues, $dataType)) . ')');

Paramètres
array | $values | Values to bind
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $key
Renvoie
array An array with parameter names
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ call()

call ( $columns )

Add a single column, or array of columns to the CALL clause of the query.

Usage: $query->call('a.*')->call('b.id'); $query->call(array('a.*', 'b.id'));

Paramètres
array | string $columns A string or an array of field names.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ castAs()

castAs | ( | string | $type,
 |  | string | $value,
 |  | ?string | $length = null
 | ) |  |

Casts a value to a specified type.

Ensure that the value is properly quoted before passing to the method.

Usage: $query->select($query->castAs('CHAR', 'a'));

Paramètres
string | $type | The type of string to cast as.
string | $value | The value to cast as a char.
string | $length | Optionally specify the length of the field (if the type supports it otherwise ignored).
Renvoie
string SQL statement to cast the value as a char type.
Depuis
2.0.0
Exceptions
UnknownTypeException When unsupported cast for a database driver

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ charLength()

charLength | ( | $field,
 |  | $operator = null,
 |  | $condition = null
 | ) |

Gets the number of characters in a string.

Note, use 'length' to find the number of bytes in a string.

Usage: $query->select($query->charLength('a'));

Paramètres
string | $field | A value.
string | null | $operator | Comparison operator between charLength integer value and $condition
string | null | $condition | Integer value to compare charLength with.
Renvoie
string SQL statement to get the length of a character.
Depuis
2.0.0

Implémenté dans DatabaseQuery, SqlsrvQuery, et SqliteQuery.

◆ clear()

clear ( $clause = null )

Clear data from the query or a specific clause of the query.

Paramètres
string $clause Optionally, the name of the clause to clear, or nothing to clear the whole query.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ columns()

columns ( $columns )

Adds a column, or array of column names that would be used for an INSERT INTO statement.

Paramètres
array | string $columns A column name, or array of column names.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ concatenate()

concatenate | ( | $values,
 |  | $separator = null
 | ) |

Concatenates an array of column names or values.

Usage: $query->select($query->concatenate(array('a', 'b')));

Paramètres
string[] | $values An array of values to concatenate.
string | null | $separator | As separator to place between each value.
Renvoie
string SQL statement representing the concatenated values.
Depuis
2.0.0

Implémenté dans DatabaseQuery, SqlsrvQuery, et SqliteQuery.

◆ currentTimestamp()

currentTimestamp ( )

Gets the current date and time.

Usage: $query->where('published_up < '.$query->currentTimestamp());

Renvoie
string SQL statement to get the current timestamp.
Depuis
2.0.0

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ day()

day ( $date )

Used to get a string to extract day from date column.

Usage: $query->select($query->day($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing day to be extracted.
Renvoie
string SQL statement to get the day from a date value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ delete()

delete ( $table = null )

Add a table name to the DELETE clause of the query.

Usage: $query->delete('#__a')->where('id = 1');

Paramètres
string $table The name of the table to delete from.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ exec()

exec ( $columns )

Add a single column, or array of columns to the EXEC clause of the query.

Usage: $query->exec('a.*')->exec('b.id'); $query->exec(array('a.*', 'b.id'));

Paramètres
array | string $columns A string or an array of field names.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ extendWhere()

extendWhere | ( | $outerGlue,
 |  | $conditions,
 |  | $innerGlue = 'AND'
 | ) |

Extend the WHERE clause with a single condition or an array of conditions, with a potentially different logical operator from the one in the current WHERE clause.

Usage: $query->where(array('a = 1', 'b = 2'))->extendWhere('XOR', array('c = 3', 'd = 4')); will produce: WHERE ((a = 1 AND b = 2) XOR (c = 3 AND d = 4)

Paramètres
string | $outerGlue | The glue by which to join the conditions to the current WHERE conditions.
mixed | $conditions | A string or array of WHERE conditions.
string | $innerGlue | The glue by which to join the conditions. Defaults to AND.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ findInSet()

findInSet | ( | $value,
 |  | $set
 | ) |

Find a value in a varchar used like a set.

Ensure that the value is an integer before passing to the method.

Usage: $query->findInSet((int) $parent->id, 'a.assigned_cat_ids')

Paramètres
string | $value | The value to search for.
string | $set | The set of values.
Renvoie
string A representation of the MySQL find_in_set() function for the driver.
Depuis
2.0.0

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ from()

from ( $table )

Add a table to the FROM clause of the query.

Usage: $query->select('*')->from('#__a'); $query->select('*')->from($subquery->alias('a'));

Paramètres
string | QueryInterface $table The name of the table or a QueryInterface object (or a child of it) with alias set.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ group()

group ( $columns )

Add a grouping column to the GROUP clause of the query.

Usage: $query->group('id');

Paramètres
array | string $columns A string or array of ordering columns.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ groupConcat()

groupConcat | ( | $expression,
 |  | $separator = ','
 | ) |

Aggregate function to get input values concatenated into a string, separated by delimiter

Usage: $query->groupConcat('id', ',');

Paramètres
string | $expression | The expression to apply concatenation to, this may be a column name or complex SQL statement.
string | $separator | The delimiter of each concatenated value
Renvoie
string Input values concatenated into a string, separated by delimiter
Depuis
2.0.0

Implémenté dans SqlsrvQuery, et SqliteQuery.

◆ having()

having | ( | $conditions,
 |  | $glue = 'AND'
 | ) |

A conditions to the HAVING clause of the query.

Usage: $query->group('id')->having('COUNT(id) > 5');

Paramètres
array | string | $conditions | A string or array of columns.
string | $glue | The glue by which to join the conditions. Defaults to AND.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ hour()

hour ( $date )

Used to get a string to extract hour from date column.

Usage: $query->select($query->hour($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing hour to be extracted.
Renvoie
string SQL statement to get the hour from a date/time value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ insert()

insert | ( | $table,
 |  | $incrementField = false
 | ) |

Add a table name to the INSERT clause of the query.

Usage: $query->insert('#__a')->set('id = 1'); $query->insert('#__a')->columns('id, title')->values('1,2')->values('3,4'); $query->insert('#__a')->columns('id, title')->values(array('1,2', '3,4'));

Paramètres
string | $table | The name of the table to insert data into.
boolean | $incrementField | The name of the field to auto increment.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ isNullDatetime()

isNullDatetime ( $column )

Generate a SQL statement to check if column represents a zero or null datetime.

Usage: $query->where($query->isNullDatetime('modified_date'));

Paramètres
string $column A column name.
Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ join()

join | ( | $type,
 |  | $table,
 |  | $condition = null
 | ) |

Add a JOIN clause to the query.

Usage: $query->join('INNER', 'b', 'b.id = a.id);

Paramètres
string | $type | The type of join. This string is prepended to the JOIN keyword.
string | $table | The name of table.
string | $condition | The join condition.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ length()

length ( $value )

Get the length of a string in bytes.

Note, use 'charLength' to find the number of characters in a string.

Usage: query->where($query->length('a').' > 3');

Paramètres
string $value The string to measure.
Renvoie
integer
Depuis
2.0.0

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ minute()

minute ( $date )

Used to get a string to extract minute from date column.

Usage: $query->select($query->minute($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing minute to be extracted.
Renvoie
string SQL statement to get the minute from a date/time value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ month()

month ( $date )

Used to get a string to extract month from date column.

Usage: $query->select($query->month($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing month to be extracted.
Renvoie
string SQL statement to get the month from a date value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ nullDate()

nullDate ( $quoted = true )

Get the null or zero representation of a timestamp for the database driver.

This method is provided for use where the query object is passed to a function for modification. If you have direct access to the database object, it is recommended you use the nullDate method directly.

Usage: $query->where('modified_date <> '.$query->nullDate());

Paramètres
boolean $quoted Optionally wraps the null date in database quotes (true by default).
Renvoie
string Null or zero representation of a timestamp.
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseQuery.

◆ order()

order ( $columns )

Add an ordering column to the ORDER clause of the query.

Usage: $query->order('foo')->order('bar'); $query->order(array('foo','bar'));

Paramètres
array | string $columns A string or array of ordering columns.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ querySet()

querySet ( $query )

Set a single query to the query set. On this type of DatabaseQuery you can use union(), unionAll(), order() and setLimit()

Usage: $query->querySet($query2->select('name')->from('#__foo')->order('id DESC')->setLimit(1)) ->unionAll($query3->select('name')->from('#__foo')->order('id')->setLimit(1)) ->order('name') ->setLimit(1)

Paramètres
DatabaseQuery | string $query The DatabaseQuery object or string.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ rand()

rand ( )

Get the function to return a random floating-point value

Usage: $query->rand();

Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseQuery, et SqlsrvQuery.

◆ regexp()

regexp ( $value )

Get the regular expression operator

Usage: $query->where('field ' . $query->regexp($search));

Paramètres
string $value The regex pattern.
Renvoie
string
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ second()

second ( $date )

Used to get a string to extract seconds from date column.

Usage: $query->select($query->second($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing second to be extracted.
Renvoie
string SQL statement to get the second from a date/time value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ select()

select ( $columns )

Add a single column, or array of columns to the SELECT clause of the query.

Usage: $query->select('a.*')->select('b.id'); $query->select(array('a.*', 'b.id'));

Paramètres
array | string $columns A string or an array of field names.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ selectRowNumber()

selectRowNumber | ( | $orderBy,
 |  | $orderColumnAlias
 | ) |

Return the number of the current row.

Usage: $query->select('id'); $query->selectRowNumber('ordering,publish_up DESC', 'new_ordering'); $query->from('#__content');

Paramètres
string | $orderBy | An expression of ordering for window function.
string | $orderColumnAlias | An alias for new ordering column.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans DatabaseQuery, et SqliteQuery.

◆ set()

set | ( | $conditions,
 |  | $glue = ','
 | ) |

Add a single condition string, or an array of strings to the SET clause of the query.

Usage: $query->set('a = 1')->set('b = 2'); $query->set(array('a = 1', 'b = 2');

Paramètres
array | string | $conditions | A string or array of string conditions.
string | $glue | The glue by which to join the condition strings. Defaults to ,. Note that the glue is set on first use and cannot be changed.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ toQuerySet()

toQuerySet ( )

Create a DatabaseQuery object of type querySet from current query.

Usage: $query->select('name')->from('#__foo')->order('id DESC')->setLimit(1) ->toQuerySet() ->unionAll($query2->select('name')->from('#__foo')->order('id')->setLimit(1)) ->order('name') ->setLimit(1)

Renvoie
DatabaseQuery A new object of the DatabaseQuery.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ union()

union | ( | $query,
 |  | $distinct = true
 | ) |

Add a query to UNION with the current query.

Usage: $query->union('SELECT name FROM #__foo') $query->union('SELECT name FROM #__foo', true)

Paramètres
DatabaseQuery | string | $query | The DatabaseQuery object or string to union.
boolean | $distinct | True to only return distinct rows from the union.
Renvoie
$this
Depuis
1.0

Implémenté dans DatabaseQuery, SqlsrvQuery, et SqliteQuery.

◆ unionAll()

unionAll ( $query )

Add a query to UNION ALL with the current query.

Usage: $query->unionAll('SELECT name FROM #__foo')

Paramètres
DatabaseQuery | string $query The DatabaseQuery object or string to union.
Renvoie
$this
Voir également
union
Depuis
1.5.0

Implémenté dans DatabaseQuery.

◆ update()

update ( $table )

Add a table name to the UPDATE clause of the query.

Usage: $query->update('#__foo')->set(...);

Paramètres
string $table A table to update.
Renvoie
$this
Depuis
2.0.0
Exceptions
QueryTypeAlreadyDefinedException if the query type has already been defined

Implémenté dans DatabaseQuery.

◆ values()

values ( $values )

Adds a tuple, or array of tuples that would be used as values for an INSERT INTO statement.

Usage: $query->values('1,2,3')->values('4,5,6'); $query->values(array('1,2,3', '4,5,6'));

Paramètres
array | string $values A single tuple, or array of tuples.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ where()

where | ( | $conditions,
 |  | $glue = 'AND'
 | ) |

Add a single condition, or an array of conditions to the WHERE clause of the query.

Usage: $query->where('a = 1')->where('b = 2'); $query->where(array('a = 1', 'b = 2'));

Paramètres
array | string | $conditions | A string or array of where conditions.
string | $glue | The glue by which to join the conditions. Defaults to AND. Note that the glue is set on first use and cannot be changed.
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ whereIn()

whereIn | ( | string | $keyName,
 |  | array | $keyValues,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Add a WHERE IN statement to the query.

Note that all values must be the same data type.

Usage $query->whereIn('id', [1, 2, 3]);

Paramètres
string | $keyName | Key name for the where clause
array | $keyValues | Array of values to be matched
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $keyValues
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ whereNotIn()

whereNotIn | ( | string | $keyName,
 |  | array | $keyValues,
 |  |  | $dataType = ParameterType::INTEGER
 | ) |  |

Add a WHERE NOT IN statement to the query.

Note that all values must be the same data type.

Usage $query->whereNotIn('id', [1, 2, 3]);

Paramètres
string | $keyName | Key name for the where clause
array | $keyValues | Array of values to be matched
array | string | $dataType | Constant corresponding to a SQL datatype. It can be an array, in this case it has to be same length of $keyValues
Renvoie
$this
Depuis
2.0.0

Implémenté dans DatabaseQuery.

◆ year()

year ( $date )

Used to get a string to extract year from date column.

Usage: $query->select($query->year($query->quoteName('dateColumn')));

Paramètres
string $date Date column containing year to be extracted.
Renvoie
string SQL statement to get the year from a date value.
Depuis
2.0.0

Implémenté dans DatabaseQuery.

La documentation de cette interface a été générée à partir du fichier suivant :
  • joomla/database/src/QueryInterface.php


Joomla CMS: Référence de l'interface QueryMonitorInterface

  • Joomla
  • Database
  • QueryMonitorInterface
Fonctions membres publiques
Référence de l'interface QueryMonitorInterface
+ Graphe d'héritage de QueryMonitorInterface:
ChainedMonitor DebugMonitor LoggingMonitor

Fonctions membres publiques

startQuery (string $sql, ?array $boundParams=null)
stopQuery ()

Description détaillée

Interface defining a query monitor.

Depuis
2.0.0

Documentation des fonctions membres

◆ startQuery()

startQuery | ( | string | $sql,
 |  | ?array | $boundParams = null
 | ) |  |

Act on a query being started.

Paramètres
string | $sql | The SQL to be executed.
object[]|null | $boundParams List of bound params, used with the query. Each item is an object that holds: value, dataType
Renvoie
void
Depuis
2.0.0

Implémenté dans DebugMonitor, ChainedMonitor, et LoggingMonitor.

◆ stopQuery()

stopQuery ( )

Act on a query being stopped.

Renvoie
void
Depuis
2.0.0

Implémenté dans DebugMonitor, ChainedMonitor, et LoggingMonitor.

La documentation de cette interface a été générée à partir du fichier suivant :
  • QueryMonitorInterface.php


Joomla CMS: Référence de l'interface StatementInterface

  • Joomla
  • Database
  • StatementInterface
Fonctions membres publiques
Référence de l'interface StatementInterface
+ Graphe d'héritage de StatementInterface:
MysqliStatement PdoStatement SqlsrvStatement

Fonctions membres publiques

bindParam ($parameter, &$variable, string $dataType=ParameterType::STRING, ?int $length=null, ?array $driverOptions=null)
closeCursor ()
errorCode ()
errorInfo ()
execute (?array $parameters=null)
fetch (?int $fetchStyle=null, int $cursorOrientation=FetchOrientation::NEXT, int $cursorOffset=0)
rowCount ()
setFetchMode (int $fetchMode,... $args)

Description détaillée

Interface defining a query statement.

This interface is a partial standalone implementation of PDOStatement.

Depuis
2.0.0

Documentation des fonctions membres

◆ bindParam()

bindParam | ( |  | $parameter,
 |  | & | $variable,
 |  | string | $dataType = ParameterType::STRING,
 |  | ?int | $length = null,
 |  | ?array | $driverOptions = null
 | ) |  |

Binds a parameter to the specified variable name.

Paramètres
string | integer | $parameter | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $variable | Name of the PHP variable to bind to the SQL statement parameter.
string | $dataType | Constant corresponding to a SQL datatype, this should be the processed type from the QueryInterface.
integer | $length | The length of the variable. Usually required for OUTPUT parameters.
array | $driverOptions | Optional driver options to be used.
Renvoie
boolean
Depuis
2.0.0

Implémenté dans SqlsrvStatement, MysqliStatement, et PdoStatement.

◆ closeCursor()

closeCursor ( )

Closes the cursor, enabling the statement to be executed again.

Renvoie
void
Depuis
2.0.0

Implémenté dans MysqliStatement, SqlsrvStatement, et PdoStatement.

◆ errorCode()

errorCode ( )

Fetches the SQLSTATE associated with the last operation on the statement handle.

Renvoie
string
Depuis
2.0.0

Implémenté dans MysqliStatement, SqlsrvStatement, et PdoStatement.

◆ errorInfo()

errorInfo ( )

Fetches extended error information associated with the last operation on the statement handle.

Renvoie
array
Depuis
2.0.0

Implémenté dans SqlsrvStatement, MysqliStatement, et PdoStatement.

◆ execute()

execute ( ?array $parameters = null )

Executes a prepared statement

Paramètres
array | null $parameters An array of values with as many elements as there are bound parameters in the SQL statement being executed.
Renvoie
boolean
Depuis
2.0.0

Implémenté dans SqlsrvStatement, MysqliStatement, et PdoStatement.

◆ fetch()

fetch | ( | ?int | $fetchStyle = null,
 |  | int | $cursorOrientation = FetchOrientation::NEXT,
 |  | int | $cursorOffset = 0
 | ) |  |

Fetches the next row from a result set

Paramètres
integer | null | $fetchStyle | Controls how the next row will be returned to the caller. This value must be one of the FetchMode constants, defaulting to value of FetchMode::MIXED.
integer | $cursorOrientation | For a StatementInterface object representing a scrollable cursor, this value determines which row will be returned to the caller. This value must be one of the FetchOrientation constants, defaulting to FetchOrientation::NEXT.
integer | $cursorOffset | For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::ABS, this value specifies the absolute number of the row in the result set that shall be fetched. For a StatementInterface object representing a scrollable cursor for which the cursorOrientation parameter is set to FetchOrientation::REL, this value specifies the row to fetch relative to the cursor position before fetch() was called.
Renvoie
mixed The return value of this function on success depends on the fetch type. In all cases, boolean false is returned on failure.
Depuis
2.0.0

Implémenté dans MysqliStatement, SqlsrvStatement, et PdoStatement.

◆ rowCount()

rowCount ( )

Returns the number of rows affected by the last SQL statement.

Renvoie
integer
Depuis
2.0.0

Implémenté dans MysqliStatement, SqlsrvStatement, et PdoStatement.

◆ setFetchMode()

setFetchMode | ( | int | $fetchMode,
 |  |  | $args
 | ) |  |

Sets the fetch mode to use while iterating this statement.

Paramètres
integer | $fetchMode | The fetch mode, must be one of the FetchMode constants.
mixed | ...$args Optional mode-specific arguments.
Renvoie
void
Depuis
2.0.0

Implémenté dans MysqliStatement, SqlsrvStatement, et PdoStatement.

La documentation de cette interface a été générée à partir du fichier suivant :
  • StatementInterface.php


Joomla CMS: Référence de l'interface UTF8MB4SupportInterface

  • Joomla
  • Database
  • UTF8MB4SupportInterface
Fonctions membres publiques
Référence de l'interface UTF8MB4SupportInterface
+ Graphe d'héritage de UTF8MB4SupportInterface:
MysqlDriver MysqliDriver

Fonctions membres publiques

convertUtf8mb4QueryToUtf8 ($query)
hasUtf8mb4Support ()

Description détaillée

Interface defining a driver which has support for the MySQL utf8mb4 character set

Depuis
2.0.0

Documentation des fonctions membres

◆ convertUtf8mb4QueryToUtf8()

convertUtf8mb4QueryToUtf8 ( $query )

Automatically downgrade a CREATE TABLE or ALTER TABLE query from utf8mb4 (UTF-8 Multibyte) to plain utf8.

Used when the server doesn't support UTF-8 Multibyte.

Paramètres
string $query The query to convert
Renvoie
string The converted query
Depuis
2.0.0

Implémenté dans MysqliDriver, et MysqlDriver.

◆ hasUtf8mb4Support()

hasUtf8mb4Support ( )

Check whether the database engine supports the UTF-8 Multibyte (utf8mb4) character encoding.

Renvoie
boolean True if the database engine supports UTF-8 Multibyte.
Depuis
2.0.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • UTF8MB4SupportInterface.php


Joomla CMS: Référence de la classe ContainerNotFoundException

  • Joomla
  • DI
  • Exception
  • ContainerNotFoundException
Référence de la classe ContainerNotFoundException
+ Graphe d'héritage de ContainerNotFoundException:
ContainerExceptionInterface

Description détaillée

No container is available.

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerNotFoundException.php


Joomla CMS: Référence de la classe DependencyResolutionException

  • Joomla
  • DI
  • Exception
  • DependencyResolutionException
Référence de la classe DependencyResolutionException
+ Graphe d'héritage de DependencyResolutionException:
ContainerExceptionInterface

Description détaillée

Exception class for handling errors in resolving a dependency

Depuis
1.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • DependencyResolutionException.php


Joomla CMS: Référence de la classe KeyNotFoundException

  • Joomla
  • DI
  • Exception
  • KeyNotFoundException
Référence de la classe KeyNotFoundException
+ Graphe d'héritage de KeyNotFoundException:
NotFoundExceptionInterface ContainerExceptionInterface

Description détaillée

No entry was found in the container.

Depuis
1.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyNotFoundException.php


Joomla CMS: Référence de la classe ProtectedKeyException

  • Joomla
  • DI
  • Exception
  • ProtectedKeyException
Référence de la classe ProtectedKeyException
+ Graphe d'héritage de ProtectedKeyException:
ContainerExceptionInterface

Description détaillée

Attempt to set the value of a protected key, which already is set

Depuis
1.5.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProtectedKeyException.php


Joomla CMS: Référence de la classe Container

  • Joomla
  • DI
  • Container
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe Container
+ Graphe d'héritage de Container:
ContainerInterface

Fonctions membres publiques

__construct (?ContainerInterface $parent=null)
get ($resourceName)
has ($resourceName)
exists ($key)
alias ($alias, $key)
isShared (string $resourceName)
isProtected (string $resourceName)
tag ($tag, array $keys)
getTagged ($tag)
buildObject ($resourceName, $shared=false)
buildSharedObject ($resourceName)
createChild ()
extend ($resourceName, callable $callable)
set ($key, $value, $shared=false, $protected=false)
protect ($key, $value, $shared=false)
share ($key, $value, $protected=false)
getResource (string $key, bool $bail=false)
getNewInstance ($key)
registerServiceProvider (ServiceProviderInterface $provider)
getKeys ()
- Fonctions membres publiques hérités de ContainerInterface
get (string $id)
has (string $id)

Fonctions membres protégées

resolveAlias ($resourceName)

Attributs protégés

$aliases = []
$resources = []
$parent
$tags = []

Fonctions membres privées

hasFlag (string $resourceName, string $method, bool $default=true)
getMethodArgs (\ReflectionMethod $method)

Description détaillée

The Container class.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?ContainerInterface $parent = null )

Constructor for the DI Container

Paramètres
ContainerInterface | null $parent Parent for hierarchical containers.
Depuis
1.0

Références Container\$parent, et parent.

Documentation des fonctions membres

◆ alias()

alias | ( | $alias,
 |  | $key
 | ) |

Create an alias for a given key for easy access.

Paramètres
string | $alias | The alias name
string | $key | The key to alias
Renvoie
$this
Depuis
1.0

Références $key, et $this.

◆ buildObject()

buildObject | ( | $resourceName,
 |  | $shared = false
 | ) |

Build an object of the requested class

Creates an instance of the class specified by $resourceName with all dependencies injected. If the dependencies cannot be completely resolved, a DependencyResolutionException is thrown.

Paramètres
string | $resourceName | The class name to build.
boolean | $shared | True to create a shared resource.
Renvoie
object|false Instance of class specified by $resourceName with all dependencies injected. Returns an object if the class exists and false otherwise
Depuis
1.0
Exceptions
DependencyResolutionException if the object could not be built (due to missing information)

Références $key, Container\getMethodArgs(), Container\has(), null, et Container\resolveAlias().

Référencé par Container\buildSharedObject(), et Container\getMethodArgs().

◆ buildSharedObject()

buildSharedObject ( $resourceName )

Convenience method for building a shared object.

Paramètres
string $resourceName The class name to build.
Renvoie
object|false Instance of class specified by $resourceName with all dependencies injected. Returns an object if the class exists and false otherwise
Depuis
1.0

Références Container\buildObject().

◆ createChild()

createChild ( )

Create a child Container with a new property scope that has the ability to access the parent scope when resolving.

Renvoie
Container A new container with the current as a parent
Depuis
1.0

Références $this.

◆ exists()

exists ( $key )

Method to check if specified dataStore key exists.

Paramètres
string $key Name of the dataStore key to check.
Renvoie
boolean True for success
Depuis
1.0
Obsolète:
3.0 Use ContainerInterface::has() instead

Références $key, class, et Container\has().

◆ extend()

extend | ( |  | $resourceName,
 |  | callable | $callable
 | ) |  |

Extend a defined service Closure by wrapping the existing one with a new callable function.

This works very similar to a decorator pattern. Note that this only works on service Closures that have been defined in the current container, not parent containers.

Paramètres
string | $resourceName | The unique identifier for the Closure or property.
callable | $callable | A callable to wrap the original service Closure.
Renvoie
void
Depuis
1.0
Exceptions
KeyNotFoundException

Références $c, $key, Container\getResource(), et Container\resolveAlias().

◆ get()

get ( $resourceName )

Retrieve a resource

Paramètres
string $resourceName Name of the resource to get.
Renvoie
mixed The requested resource
Depuis
1.0
Exceptions
KeyNotFoundException

Références $key, parent, et Container\resolveAlias().

Référencé par ServiceProviderInterface\register(), et ComponentDispatcherFactory\register().

◆ getKeys()

getKeys ( )

Retrieve the keys for services assigned to this container.

Renvoie
array
Depuis
1.5.0

◆ getMethodArgs()

getMethodArgs ( \ReflectionMethod $method )
private

Build an array of method arguments.

Paramètres
\ReflectionMethod $method Method for which to build the argument array.
Renvoie
array Array of arguments to pass to the method.
Depuis
1.0
Exceptions
DependencyResolutionException

Références $message, $method, Container\buildObject(), Container\getResource(), et null.

Référencé par Container\buildObject().

◆ getNewInstance()

getNewInstance ( $key )

Method to force the container to return a new instance of the results of the callback for requested $key.

Paramètres
string $key Name of the resources key to get.
Renvoie
mixed Results of running the callback for the specified key.
Depuis
1.0

Références $key, Container\getResource(), et Container\resolveAlias().

◆ getResource()

getResource | ( | string | $key,
 |  | bool | $bail = false
 | ) |  |

Get the raw data assigned to a key.

Paramètres
string | $key | The key for which to get the stored item.
boolean | $bail | Throw an exception, if the key is not found
Renvoie
ContainerResource|null The resource if present, or null if instructed to not bail
Depuis
2.0.0
Exceptions
KeyNotFoundException

Références $key, $this, null, parent, ContainerResource\PROTECT, et ContainerResource\SHARE.

Référencé par Container\extend(), Container\getMethodArgs(), et Container\getNewInstance().

◆ getTagged()

getTagged ( $tag )

Fetch all services registered to the given tag.

Paramètres
string $tag The tag name
Renvoie
array The resolved services for the given tag
Depuis
1.5.0

◆ has()

has ( $resourceName )

Check if specified resource exists.

Paramètres
string $resourceName Name of the resource to check.
Renvoie
boolean true if key is defined, false otherwise
Depuis
1.5.0

Références $key, parent, et Container\resolveAlias().

Référencé par Container\buildObject(), Container\exists(), et Container\set().

◆ hasFlag()

hasFlag | ( | string | $resourceName,
 |  | string | $method,
 |  | bool | $default = true
 | ) |  |
private

Check whether a flag (i.e., one of 'shared' or 'protected') is set

Paramètres
string | $resourceName | Name of the resource to check.
string | $method | Method to delegate to
boolean | $default | Default return value
Renvoie
boolean
Depuis
2.0.0
Exceptions
KeyNotFoundException

Références $default, $key, $method, parent, et Container\resolveAlias().

Référencé par Container\isProtected(), et Container\isShared().

◆ isProtected()

isProtected ( string $resourceName )

Check whether a resource is protected

Paramètres
string $resourceName Name of the resource to check.
Renvoie
boolean
Depuis
2.0.0

Références Container\hasFlag().

Référencé par Container\set().

◆ isShared()

isShared ( string $resourceName )

Check whether a resource is shared

Paramètres
string $resourceName Name of the resource to check.
Renvoie
boolean
Depuis
2.0.0

Références Container\hasFlag().

◆ protect()

protect | ( | $key,
 |  | $value,
 |  | $shared = false
 | ) |

Shortcut method for creating protected keys.

Paramètres
string | $key | Name of dataStore key to set.
mixed | $value | Callable function to run or string to retrive when requesting the specified $key.
boolean | $shared | True to create and store a shared instance.
Renvoie
$this
Depuis
1.0

Références $key, et $value.

◆ registerServiceProvider()

registerServiceProvider ( ServiceProviderInterface $provider )

Register a service provider to the container.

Paramètres
ServiceProviderInterface $provider The service provider to register.
Renvoie
$this
Depuis
1.0

Références $this, et ServiceProviderInterface\register().

◆ resolveAlias()

resolveAlias ( $resourceName )
protected

Resolve a resource name.

If the resource name is an alias, the corresponding key is returned. If the resource name is not an alias, the resource name is returned unchanged.

Paramètres
string $resourceName The key to search for.
Renvoie
string
Depuis
1.0

Référencé par Container\buildObject(), Container\extend(), Container\get(), Container\getNewInstance(), Container\has(), Container\hasFlag(), Container\set(), et Container\tag().

◆ set()

set | ( | $key,
 |  | $value,
 |  | $shared = false,
 |  | $protected = false
 | ) |

Set a resource to the container. If the value is null the resource is removed.

Paramètres
string | $key | Name of resources key to set.
mixed | $value | Callable function to run or string to retrive when requesting the specified $key.
boolean | $shared | True to create and store a shared instance.
boolean | $protected | True to protect this item from being overwritten. Useful for services.
Renvoie
$this
Depuis
1.0
Exceptions
ProtectedKeyException Thrown if the provided key is already set and is protected.

Références $key, $mode, $this, $value, Container\has(), Container\isProtected(), ContainerResource\NO_PROTECT, ContainerResource\NO_SHARE, null, ContainerResource\PROTECT, Container\resolveAlias(), et ContainerResource\SHARE.

◆ share()

share | ( | $key,
 |  | $value,
 |  | $protected = false
 | ) |

Shortcut method for creating shared keys.

Paramètres
string | $key | Name of dataStore key to set.
mixed | $value | Callable function to run or string to retrive when requesting the specified $key.
boolean | $protected | True to protect this item from being overwritten. Useful for services.
Renvoie
$this
Depuis
1.0

Références $key, et $value.

◆ tag()

tag | ( |  | $tag,
 |  | array | $keys
 | ) |  |

Assign a tag to services.

Paramètres
string | $tag | The tag name
array | $keys | The service keys to tag
Renvoie
$this
Depuis
1.5.0

Références $key, $this, et Container\resolveAlias().

Documentation des champs

◆ $aliases

$aliases = []
protected

◆ $parent

$parent
protected

Référencé par Container\__construct().

◆ $resources

$resources = []
protected

◆ $tags

$tags = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/di/src/Container.php


Joomla CMS: Référence de l'interface ContainerAwareInterface

  • Joomla
  • DI
  • ContainerAwareInterface
Fonctions membres publiques
Référence de l'interface ContainerAwareInterface
+ Graphe d'héritage de ContainerAwareInterface:
CMSApplication SessionGcCommand InstallerAdapter SessionFactory ContainerAwareToolbarFactory AdministratorApplication ApiApplication SiteApplication InstallationApplication ComponentAdapter FileAdapter LanguageAdapter LibraryAdapter ModuleAdapter PackageAdapter PluginAdapter TemplateAdapter

Fonctions membres publiques

setContainer (Container $container)

Description détaillée

Defines the interface for a Container Aware class.

Depuis
1.0

Documentation des fonctions membres

◆ setContainer()

setContainer ( Container $container )

Set the DI container.

Paramètres
Container $container The DI container.
Renvoie
mixed
Depuis
1.0
La documentation de cette interface a été générée à partir du fichier suivant :
  • ContainerAwareInterface.php


Joomla CMS: Référence de la classe ContainerResource

  • Joomla
  • DI
  • ContainerResource
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe ContainerResource

Fonctions membres publiques

__construct (Container $container, $value, int $mode=0)
isShared ()
isProtected ()
getInstance ()
getFactory ()
reset ()

Champs de données

const | NO_SHARE = 0
const | SHARE = 1
const | NO_PROTECT = 0
const | PROTECT = 2

Attributs privés

$container
$instance
$factory
$shared = false
$protected = false

Description détaillée

Defines the representation of a resource.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Container | $container,
 |  |  | $value,
 |  | int | $mode = 0
 | ) |  |

Create a resource representation

Paramètres
Container | $container | The container
mixed | $value | The resource or its factory closure
integer | $mode | Resource mode, defaults to Resource::NO_SHARE | Resource::NO_PROTECT
Depuis
2.0.0

Références ContainerResource\$container, $mode, et $value.

Documentation des fonctions membres

◆ getFactory()

getFactory ( )

Get the factory

Renvoie
callable
Depuis
2.0.0

Références ContainerResource\$factory.

◆ getInstance()

getInstance ( )

Get an instance of the resource

If a factory was provided, the resource is created and - if it is a shared resource - cached internally. If the resource was provided directly, that resource is returned.

Renvoie
mixed
Depuis
2.0.0

Références ContainerResource\$factory, ContainerResource\$instance, ContainerResource\isShared(), et null.

◆ isProtected()

isProtected ( )

Check whether the resource is protected

Renvoie
boolean
Depuis
2.0.0

Références ContainerResource\$protected.

Référencé par ContainerResource\reset().

◆ isShared()

isShared ( )

Check whether the resource is shared

Renvoie
boolean
Depuis
2.0.0

Références ContainerResource\$shared.

Référencé par ContainerResource\getInstance(), et ContainerResource\reset().

◆ reset()

reset ( )

Reset the resource

The instance cache is cleared, so that the next call to get() returns a new instance. This has an effect on shared, non-protected resources only.

Renvoie
boolean True if the resource was reset, false otherwise
Depuis
2.0.0

Références ContainerResource\isProtected(), ContainerResource\isShared(), et null.

Documentation des champs

◆ $container

$container
private

Référencé par ContainerResource\__construct().

◆ $factory

$factory
private

Référencé par ContainerResource\getFactory(), et ContainerResource\getInstance().

◆ $instance

$instance
private

Référencé par ContainerResource\getInstance().

◆ $protected

$protected = false
private

Référencé par ContainerResource\isProtected().

◆ $shared

$shared = false
private

Référencé par ContainerResource\isShared().

◆ NO_PROTECT

const NO_PROTECT = 0

Defines the resource as non-protected

integer

Depuis
2.0.0

Référencé par Container\set().

◆ NO_SHARE

const NO_SHARE = 0

Defines the resource as non-shared

integer

Depuis
2.0.0

Référencé par Container\set().

◆ PROTECT

const PROTECT = 2

Defines the resource as protected

integer

Depuis
2.0.0

Référencé par Container\getResource(), et Container\set().

◆ SHARE

const SHARE = 1

Defines the resource as shared

integer

Depuis
2.0.0

Référencé par Container\getResource(), et Container\set().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerResource.php


Joomla CMS: Référence de l'interface ServiceProviderInterface

  • Joomla
  • DI
  • ServiceProviderInterface
Fonctions membres publiques
Référence de l'interface ServiceProviderInterface
+ Graphe d'héritage de ServiceProviderInterface:
CategoryFactory ComponentDispatcherFactory HelperFactory Module ModuleDispatcherFactory MVCFactory RouterFactory Application Application Authentication CacheController Config Console Database Dispatcher Document Form HTMLRegistry Language Logger Menu Pathway Router Session Toolbar User WebAssetRegistry DatabaseProvider

Fonctions membres publiques

register (Container $container)

Description détaillée

Defines the interface for a Service Provider.

Depuis
1.0

Documentation des fonctions membres

◆ register()

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
1.0

Implémenté dans Application, MVCFactory, RouterFactory, CategoryFactory, ComponentDispatcherFactory, HelperFactory, ModuleDispatcherFactory, Console, Authentication, Application, Router, Database, Menu, Module, Document, Form, User, CacheController, Dispatcher, Language, Logger, Pathway, Toolbar, Config, HTMLRegistry, et WebAssetRegistry.

Référencé par Container\registerServiceProvider().

La documentation de cette interface a été générée à partir du fichier suivant :
  • joomla/di/src/ServiceProviderInterface.php


Joomla CMS: Référence de la classe DebugEventDispatcherCommand

  • Joomla
  • Event
  • Command
  • DebugEventDispatcherCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées
Référence de la classe DebugEventDispatcherCommand
+ Graphe d'héritage de DebugEventDispatcherCommand:
AbstractCommand DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'debug:event-dispatcher'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

formatCallable ($callable)
renderEventListenerTable (array $eventListeners, SymfonyStyle $io)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Command listing information about the application's event dispatcher.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DispatcherInterface $dispatcher )

Instantiate the command.

Paramètres
DispatcherInterface $dispatcher The application event dispatcher.
Depuis
2.0.0

Références Symfony\Contracts\Service\__construct(), et DispatcherAwareInterface\setDispatcher().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\addArgument(), InputArgument\OPTIONAL, AbstractCommand\setDescription(), et AbstractCommand\setHelp().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

◆ formatCallable()

formatCallable ( $callable )
private

Formats a callable resource to be displayed in the console output

Paramètres
callable $callable A callable resource to format
Renvoie
string
Depuis
2.0.0
Exceptions

◆ renderEventListenerTable()

renderEventListenerTable | ( | array | $eventListeners,
 |  | SymfonyStyle | $io
 | ) |  |
private

Renders the table of listeners for an event

Paramètres
array | $eventListeners | The listeners for an event
SymfonyStyle | $io | The I/O helper
Renvoie
void
Depuis
2.0.0

Documentation des champs

◆ $defaultName

$defaultName = 'debug:event-dispatcher'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugEventDispatcherCommand.php


Joomla CMS: Référence de la classe AbstractEvent

  • Joomla
  • Event
  • AbstractEvent
Fonctions membres publiques | Attributs protégés
Référence de la classe AbstractEvent
+ Graphe d'héritage de AbstractEvent:
EventInterface Event EventImmutable ApplicationEvent AbstractEvent ConsoleEvent ConnectionEvent SessionEvent ApplicationErrorEvent AbstractImmutableEvent ErrorEvent GenericEvent MediaProviderEvent OAuthCallbackEvent ExecuteTaskEvent QuickIconsEvent ApplicationErrorEvent BeforeCommandExecuteEvent CommandErrorEvent TerminateEvent

Fonctions membres publiques

__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs protégés

$name
$arguments
$stopped = false

Description détaillée

Implementation of EventInterface.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Depuis
1.0

Références AbstractEvent\$arguments, AbstractEvent\$name, et name.

Documentation des fonctions membres

◆ __serialize()

__serialize ( )

Serialize the event.

Renvoie
array The data to be serialized
Depuis
2.0.0

Références AbstractEvent\$arguments, AbstractEvent\$name, et AbstractEvent\$stopped.

Référencé par AbstractEvent\serialize().

◆ __unserialize()

__unserialize ( array $data )

Unserialize the event.

Paramètres
array $data The serialized event.
Renvoie
void
Depuis
2.0.0

Références $data, et name.

Référencé par AbstractEvent\unserialize().

◆ count()

count ( )

Count the number of arguments.

Renvoie
integer The number of arguments.
Depuis
1.0

◆ getArgument()

getArgument | ( | $name,
 |  | $default = null
 | ) |

Get an event argument value.

Paramètres
string | $name | The argument name.
mixed | $default | The default value if not found.
Renvoie
mixed The argument value or the default value.
Depuis
1.0

Implémente EventInterface.

Références $default, et AbstractEvent\$name.

Référencé par Editor\__construct(), Shortcut\addShortcuts(), AbstractEvent\offsetGet(), CaptiveModel\onAfterModuleList(), et PackageAdapter\onExtensionAfterInstall().

◆ getArguments()

getArguments ( )

Get all event arguments.

Renvoie
array An associative array of argument names as keys and their values as values.
Depuis
1.0

Références AbstractEvent\$arguments.

Référencé par CMSPlugin\registerLegacyListener().

◆ getName()

getName ( )

Get the event name.

Renvoie
string The event name.
Depuis
1.0

Implémente EventInterface.

Références AbstractEvent\$name.

◆ hasArgument()

hasArgument ( $name )

Tell if the given event argument exists.

Paramètres
string $name The argument name.
Renvoie
boolean True if it exists, false otherwise.
Depuis
1.0

Références AbstractEvent\$name.

Référencé par AbstractEvent\offsetExists().

◆ isStopped()

isStopped ( )

Tell if the event propagation is stopped.

Renvoie
boolean True if stopped, false otherwise.
Depuis
1.0

Implémente EventInterface.

◆ offsetExists()

offsetExists ( $name )

Tell if the given event argument exists.

Paramètres
string $name The argument name.
Renvoie
boolean True if it exists, false otherwise.
Depuis
1.0

Références AbstractEvent\$name, et AbstractEvent\hasArgument().

◆ offsetGet()

offsetGet ( $name )

Get an event argument value.

Paramètres
string $name The argument name.
Renvoie
mixed The argument value or null if not existing.
Depuis
1.0

Références AbstractEvent\$name, et AbstractEvent\getArgument().

◆ serialize()

serialize ( )

Serialize the event.

Renvoie
string The serialized event.
Depuis
1.0

Références AbstractEvent\__serialize().

◆ stopPropagation()

stopPropagation ( )

Stops the propagation of the event to further event listeners.

Renvoie
void
Depuis
2.0.0

Implémente EventInterface.

Référencé par Event\stop().

◆ unserialize()

unserialize ( $serialized )

Unserialize the event.

Paramètres
string $serialized The serialized event.
Renvoie
void
Depuis
1.0

Références AbstractEvent\__unserialize().

Documentation des champs

◆ $arguments

$arguments
protected

Référencé par EventImmutable\__construct(), AbstractEvent\__construct(), AbstractEvent\__serialize(), Event\clearArguments(), et AbstractEvent\getArguments().

◆ $name

$name
protected

Référencé par SessionEvent\__construct(), ApplicationEvent\__construct(), ConnectionEvent\__construct(), EventImmutable\__construct(), ConsoleEvent\__construct(), AbstractEvent\__construct(), AbstractEvent\__serialize(), Event\addArgument(), AbstractEvent\getArgument(), AbstractEvent\getName(), AbstractEvent\hasArgument(), AbstractEvent\offsetExists(), AbstractEvent\offsetGet(), EventImmutable\offsetSet(), Event\offsetSet(), EventImmutable\offsetUnset(), Event\offsetUnset(), Event\removeArgument(), et Event\setArgument().

◆ $stopped

$stopped = false
protected

Référencé par AbstractEvent\__serialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/event/src/AbstractEvent.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Event
  • Dispatcher
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
DispatcherInterface

Fonctions membres publiques

setEvent (EventInterface $event)
addEvent (EventInterface $event)
hasEvent ($event)
getEvent ($name, $default=null)
removeEvent ($event)
getEvents ()
clearEvents ()
countEvents ()
addListener (string $eventName, callable $callback, int $priority=0)
getListenerPriority ($eventName, callable $callback)
getListeners (?string $event=null)
hasListener (callable $callback, ?string $eventName=null)
removeListener (string $eventName, callable $listener)
clearListeners ($event=null)
countListeners ($event)
addSubscriber (SubscriberInterface $subscriber)
removeSubscriber (SubscriberInterface $subscriber)
dispatch (string $name, ?EventInterface $event=null)
triggerEvent ($event)

Attributs protégés

$events = []
$listeners = []

Fonctions membres privées

getDefaultEvent (string $name)

Description détaillée

Implementation of a DispatcherInterface supporting prioritized listeners.

Depuis
1.0

Documentation des fonctions membres

◆ addEvent()

addEvent ( EventInterface $event )

Add an event to this dispatcher, only if it is not existing.

Paramètres
EventInterface $event The event.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références $this, et EventInterface\getName().

◆ addListener()

addListener | ( | string | $eventName,
 |  | callable | $callback,
 |  | int | $priority = 0
 | ) |  |

Attaches a listener to an event

Paramètres
string | $eventName | The event to listen to.
callable | $callback | A callable function
integer | $priority | The priority at which the $callback executed
Renvoie
boolean
Depuis
1.0

Implémente DispatcherInterface.

Références ListenersPriorityQueue\add().

Référencé par Dispatcher\addSubscriber().

◆ addSubscriber()

addSubscriber ( SubscriberInterface $subscriber )

Adds an event subscriber.

Paramètres
SubscriberInterface $subscriber The subscriber.
Renvoie
void
Depuis
2.0.0

Implémente DispatcherInterface.

Références $params, Dispatcher\addListener(), SubscriberInterface\getSubscribedEvents(), et Priority\NORMAL.

◆ clearEvents()

clearEvents ( )

Clear all events.

Renvoie
EventInterface[] The old events.
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références Dispatcher\$events.

◆ clearListeners()

clearListeners ( $event = null )

Clear the listeners in this dispatcher.

If an event is specified, the listeners will be cleared only for that event.

Paramètres
string $event The event name.
Renvoie
$this
Depuis
1.0

Implémente DispatcherInterface.

Références $this.

◆ countEvents()

countEvents ( )

Count the number of registered event.

Renvoie
integer The numer of registered events.
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

◆ countListeners()

countListeners ( $event )

Count the number of registered listeners for the given event.

Paramètres
string $event The event name.
Renvoie
integer
Depuis
1.0

Implémente DispatcherInterface.

◆ dispatch()

dispatch | ( | string | $name,
 |  | ?EventInterface | $event = null
 | ) |  |

Dispatches an event to all registered listeners.

Paramètres
string | $name | The name of the event to dispatch.
EventInterface | $event | The event to pass to the event handlers/listeners. If not supplied, an empty EventInterface instance is created. Note, not passing an event is deprecated and will be required as of 3.0.
Renvoie
EventInterface
Depuis
2.0.0

Implémente DispatcherInterface.

Références Dispatcher\getDefaultEvent().

Référencé par Dispatcher\triggerEvent().

◆ getDefaultEvent()

getDefaultEvent ( string $name )
private

Get an event object for the specified event name

Paramètres
string $name The event name to get an EventInterface object for
Renvoie
EventInterface
Depuis
2.0.0
Obsolète:
3.0 Default event objects will no longer be supported

Références $name.

Référencé par Dispatcher\dispatch(), et Dispatcher\triggerEvent().

◆ getEvent()

getEvent | ( | $name,
 |  | $default = null
 | ) |

Get the event object identified by the given name.

Paramètres
string | $name | The event name.
mixed | $default | The default value if the event was not registered.
Renvoie
EventInterface|mixed The event of the default value.
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références $default, et $name.

◆ getEvents()

getEvents ( )

Get the registered events.

Renvoie
EventInterface[] The registered event.
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références Dispatcher\$events.

◆ getListenerPriority()

getListenerPriority | ( |  | $eventName,
 |  | callable | $callback
 | ) |  |

Get the priority of the given listener for the given event.

Paramètres
string | $eventName | The event to listen to.
callable | $callback | A callable function
Renvoie
mixed The listener priority or null if the listener doesn't exist.
Depuis
1.0

◆ getListeners()

getListeners ( ?string $event = null )

Get the listeners registered to the given event.

Paramètres
string | null $event The event to fetch listeners for or null to fetch all listeners
Renvoie
callable[] An array of registered listeners sorted according to their priorities.
Depuis
1.0

Implémente DispatcherInterface.

Références Dispatcher\$listeners, et null.

◆ hasEvent()

hasEvent ( $event )

Tell if the given event has been added to this dispatcher.

Paramètres
EventInterface | string $event The event object or name.
Renvoie
boolean True if the listener has the given event, false otherwise.
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

◆ hasListener()

hasListener | ( | callable | $callback,
 |  | ?string | $eventName = null
 | ) |  |

Tell if the given listener has been added.

If an event is specified, it will tell if the listener is registered for that event.

Paramètres
callable | $callback | The callable to check is listening to the event.
string | $eventName | An optional event name to check a listener is subscribed to.
Renvoie
boolean True if the listener is registered, false otherwise.
Depuis
1.0

Implémente DispatcherInterface.

◆ removeEvent()

removeEvent ( $event )

Remove an event from this dispatcher. The registered listeners will remain.

Paramètres
EventInterface | string $event The event object or name.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références $this.

◆ removeListener()

removeListener | ( | string | $eventName,
 |  | callable | $listener
 | ) |  |

Removes an event listener from the specified event.

Paramètres
string | $eventName | The event to remove a listener from.
callable | $listener | The listener to remove.
Renvoie
void
Depuis
2.0.0

Implémente DispatcherInterface.

Référencé par Dispatcher\removeSubscriber().

◆ removeSubscriber()

removeSubscriber ( SubscriberInterface $subscriber )

Removes an event subscriber.

Paramètres
SubscriberInterface $subscriber The subscriber.
Renvoie
void
Depuis
2.0.0

Implémente DispatcherInterface.

Références $params, SubscriberInterface\getSubscribedEvents(), et Dispatcher\removeListener().

◆ setEvent()

setEvent ( EventInterface $event )

Set an event to the dispatcher. It will replace any event with the same name.

Paramètres
EventInterface $event The event.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Default event objects will no longer be supported

Références $this, et EventInterface\getName().

◆ triggerEvent()

triggerEvent ( $event )

Trigger an event.

Paramètres
EventInterface | string $event The event object or name.
Renvoie
EventInterface The event after being passed through all listeners.
Depuis
1.0
Obsolète:
3.0 Use dispatch() instead.

Références class, Dispatcher\dispatch(), et Dispatcher\getDefaultEvent().

Documentation des champs

◆ $events

$events = []
protected

Référencé par Dispatcher\clearEvents(), et Dispatcher\getEvents().

◆ $listeners

$listeners = []
protected

Référencé par Dispatcher\getListeners().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/event/src/Dispatcher.php


Joomla CMS: Référence de l'interface DispatcherAwareInterface

  • Joomla
  • Event
  • DispatcherAwareInterface
Fonctions membres publiques
Référence de l'interface DispatcherAwareInterface
+ Graphe d'héritage de DispatcherAwareInterface:
AbstractApplication BaseApplication CliApplication ConsoleApplication EventAwareInterface Captcha Editor PluginInterface BaseController BaseDatabaseModel AbstractView CMSPlugin Table WebAssetRegistry DatabaseDriver DebugEventDispatcherCommand Session

Fonctions membres publiques

setDispatcher (DispatcherInterface $dispatcher)

Description détaillée

Interface to be implemented by classes depending on a dispatcher.

Depuis
1.0

Documentation des fonctions membres

◆ setDispatcher()

setDispatcher ( DispatcherInterface $dispatcher )

Set the dispatcher to use.

Paramètres
DispatcherInterface $dispatcher The dispatcher to use.
Renvoie
DispatcherAwareInterface This method is chainable.
Depuis
1.0

Référencé par DebugEventDispatcherCommand\__construct(), et Session\__construct().

La documentation de cette interface a été générée à partir du fichier suivant :
  • DispatcherAwareInterface.php


Joomla CMS: Référence de l'interface DispatcherInterface

  • Joomla
  • Event
  • DispatcherInterface
Fonctions membres publiques
Référence de l'interface DispatcherInterface
+ Graphe d'héritage de DispatcherInterface:
Dispatcher

Fonctions membres publiques

dispatch (string $name, ?EventInterface $event=null)
addListener (string $eventName, callable $callback, int $priority=0)
clearListeners ($event=null)
countListeners ($event)
getListeners (?string $event=null)
hasListener (callable $callback, ?string $eventName=null)
removeListener (string $eventName, callable $listener)
addSubscriber (SubscriberInterface $subscriber)
removeSubscriber (SubscriberInterface $subscriber)

Description détaillée

Interface for event dispatchers.

Depuis
1.0

Documentation des fonctions membres

◆ addListener()

addListener | ( | string | $eventName,
 |  | callable | $callback,
 |  | int | $priority = 0
 | ) |  |

Attaches a listener to an event

Paramètres
string | $eventName | The event to listen to.
callable | $callback | A callable function.
integer | $priority | The priority at which the $callback executed.
Renvoie
boolean
Depuis
2.0.0

Implémenté dans Dispatcher.

Référencé par Session\buildSession().

◆ addSubscriber()

addSubscriber ( SubscriberInterface $subscriber )

Adds an event subscriber.

Paramètres
SubscriberInterface $subscriber The subscriber.
Renvoie
void
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ clearListeners()

clearListeners ( $event = null )

Clear the listeners in this dispatcher.

If an event is specified, the listeners will be cleared only for that event.

Paramètres
string $event The event name.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ countListeners()

countListeners ( $event )

Count the number of registered listeners for the given event.

Paramètres
string $event The event name.
Renvoie
integer
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ dispatch()

dispatch | ( | string | $name,
 |  | ?EventInterface | $event = null
 | ) |  |

Dispatches an event to all registered listeners.

Paramètres
string | $name | The name of the event to dispatch.
EventInterface | $event | The event to pass to the event handlers/listeners. If not supplied, an empty EventInterface instance is created. Note, not passing an event is deprecated and will be required as of 3.0.
Renvoie
EventInterface
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ getListeners()

getListeners ( ?string $event = null )

Get the listeners registered to the given event.

Paramètres
string | null $event The event to fetch listeners for or null to fetch all listeners
Renvoie
callable[] An array of registered listeners sorted according to their priorities.
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ hasListener()

hasListener | ( | callable | $callback,
 |  | ?string | $eventName = null
 | ) |  |

Tell if the given listener has been added.

If an event is specified, it will tell if the listener is registered for that event.

Paramètres
callable | $callback | The callable to check is listening to the event.
string | null | $eventName | An optional event name to check a listener is subscribed to.
Renvoie
boolean True if the listener is registered, false otherwise.
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ removeListener()

removeListener | ( | string | $eventName,
 |  | callable | $listener
 | ) |  |

Removes an event listener from the specified event.

Paramètres
string | $eventName | The event to remove a listener from.
callable | $listener | The listener to remove.
Renvoie
void
Depuis
2.0.0

Implémenté dans Dispatcher.

◆ removeSubscriber()

removeSubscriber ( SubscriberInterface $subscriber )

Removes an event subscriber.

Paramètres
SubscriberInterface $subscriber The subscriber.
Renvoie
void
Depuis
2.0.0

Implémenté dans Dispatcher.

La documentation de cette interface a été générée à partir du fichier suivant :
  • vendor/joomla/event/src/DispatcherInterface.php


Joomla CMS: Référence de la classe Event

  • Joomla
  • Event
  • Event
Fonctions membres publiques
Référence de la classe Event
+ Graphe d'héritage de Event:
AbstractEvent EventInterface ApplicationEvent AbstractEvent ConsoleEvent ConnectionEvent SessionEvent ApplicationErrorEvent AbstractImmutableEvent ErrorEvent GenericEvent MediaProviderEvent OAuthCallbackEvent ExecuteTaskEvent QuickIconsEvent ApplicationErrorEvent BeforeCommandExecuteEvent CommandErrorEvent TerminateEvent

Fonctions membres publiques

addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Default Event class.

Depuis
1.0

Documentation des fonctions membres

◆ addArgument()

addArgument | ( | $name,
 |  | $value
 | ) |

Add an event argument, only if it is not existing.

Paramètres
string | $name | The argument name.
mixed | $value | The argument value.
Renvoie
$this
Depuis
1.0

Références AbstractEvent\$name, $this, et $value.

Référencé par PlgSystemSchedulerunner\runTestCron().

◆ clearArguments()

clearArguments ( )

Clear all event arguments.

Renvoie
array The old arguments.
Depuis
1.0

Références AbstractEvent\$arguments.

◆ offsetSet()

offsetSet | ( | $name,
 |  | $value
 | ) |

Set the value of an event argument.

Paramètres
string | $name | The argument name.
mixed | $value | The argument value.
Renvoie
void
Depuis
1.0
Exceptions
InvalidArgumentException If the argument name is null.

Références AbstractEvent\$name, $value, null, et Event\setArgument().

◆ offsetUnset()

offsetUnset ( $name )

Remove an event argument.

Paramètres
string $name The argument name.
Renvoie
void
Depuis
1.0

Références AbstractEvent\$name, et Event\removeArgument().

◆ removeArgument()

removeArgument ( $name )

Remove an event argument.

Paramètres
string $name The argument name.
Renvoie
mixed The old argument value or null if it is not existing.
Depuis
1.0

Références AbstractEvent\$name, $return, et null.

Référencé par Event\offsetUnset().

◆ setArgument()

setArgument | ( | $name,
 |  | $value
 | ) |

Add argument to event.

Paramètres
string | $name | Argument name.
mixed | $value | Value.
Renvoie
$this
Depuis
1.0

Références AbstractEvent\$name, $this, et $value.

Référencé par Shortcut\addShortcuts(), Event\offsetSet(), et CaptiveModel\onAfterModuleList().

◆ stop()

stop ( )

Stop the event propagation.

Renvoie
void
Depuis
1.0
Obsolète:
3.0 Use stopPropogation instead

Références class, et AbstractEvent\stopPropagation().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Event.php


Joomla CMS: Référence de la classe EventImmutable

  • Joomla
  • Event
  • EventImmutable
Fonctions membres publiques | Attributs privés
Référence de la classe EventImmutable
+ Graphe d'héritage de EventImmutable:
AbstractEvent EventInterface

Fonctions membres publiques

__construct ($name, array $arguments=[])
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$constructed = false

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Implementation of an immutable Event. An immutable event cannot be modified after instanciation :

  • its propagation cannot be stopped
  • its arguments cannot be modified

You may want to use this event when you want to ensure that the listeners won't manipulate it.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $name,
 |  | array | $arguments = []
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
array | $arguments | The event arguments.
Exceptions
BadMethodCallException
Depuis
1.0

Références AbstractEvent\$arguments, AbstractEvent\$name, Symfony\Contracts\Service\__construct(), et name.

Documentation des fonctions membres

◆ offsetSet()

offsetSet | ( | $name,
 |  | $value
 | ) |

Set the value of an event argument.

Paramètres
string | $name | The argument name.
mixed | $value | The argument value.
Renvoie
void
Depuis
1.0
Exceptions
BadMethodCallException

Références AbstractEvent\$name, et name.

◆ offsetUnset()

offsetUnset ( $name )

Remove an event argument.

Paramètres
string $name The argument name.
Renvoie
void
Exceptions
BadMethodCallException
Depuis
1.0

Références AbstractEvent\$name, et name.

Documentation des champs

◆ $constructed

$constructed = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • EventImmutable.php


Joomla CMS: Référence de l'interface EventInterface

  • Joomla
  • Event
  • EventInterface
Fonctions membres publiques
Référence de l'interface EventInterface
+ Graphe d'héritage de EventInterface:
AbstractEvent Event EventImmutable ApplicationEvent AbstractEvent ConsoleEvent ConnectionEvent SessionEvent ApplicationErrorEvent AbstractImmutableEvent ErrorEvent GenericEvent MediaProviderEvent OAuthCallbackEvent ExecuteTaskEvent QuickIconsEvent ApplicationErrorEvent BeforeCommandExecuteEvent CommandErrorEvent TerminateEvent

Fonctions membres publiques

getArgument ($name, $default=null)
getName ()
isStopped ()
stopPropagation ()

Description détaillée

Interface for events. An event has a name and its propagation can be stopped.

Depuis
1.0

Documentation des fonctions membres

◆ getArgument()

getArgument | ( | $name,
 |  | $default = null
 | ) |

Get an event argument value.

Paramètres
string | $name | The argument name.
mixed | $default | The default value if not found.
Renvoie
mixed The argument value or the default value.
Depuis
2.0.0

Implémenté dans AbstractEvent, et AbstractEvent.

Référencé par Joomla\Component\Scheduler\Administrator\Traits\advertiseRoutines(), PlgWorkflowPublishing\onContentBeforeChangeState(), PlgWorkflowNotification\onContentPrepareForm(), PlgWorkflowPublishing\onContentPrepareForm(), PlgWorkflowFeaturing\onContentPrepareForm(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), et PlgWorkflowPublishing\onContentVersioningPrepareTable().

◆ getName()

getName ( )

Get the event name.

Renvoie
string The event name.
Depuis
1.0

Implémenté dans AbstractEvent.

Référencé par Dispatcher\addEvent(), AbstractView\dispatchEvent(), BaseDatabaseModel\dispatchEvent(), DatabaseDriver\dispatchEvent(), et Dispatcher\setEvent().

◆ isStopped()

isStopped ( )

Tell if the event propagation is stopped.

Renvoie
boolean True if stopped, false otherwise.
Depuis
1.0

Implémenté dans AbstractEvent.

◆ stopPropagation()

stopPropagation ( )

Stops the propagation of the event to further event listeners.

Renvoie
void
Depuis
2.0.0

Implémenté dans AbstractEvent.

La documentation de cette interface a été générée à partir du fichier suivant :
  • EventInterface.php


Joomla CMS: Référence de la classe LazyServiceEventListener

  • Joomla
  • Event
  • LazyServiceEventListener
Fonctions membres publiques | Attributs privés
Référence de la classe LazyServiceEventListener

Fonctions membres publiques

__construct (ContainerInterface $container, string $serviceId, string $method='')
__invoke (EventInterface $event)

Attributs privés

$container
$serviceId
$method

Description détaillée

Decorator for an event listener to be pulled from the service container.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ContainerInterface | $container,
 |  | string | $serviceId,
 |  | string | $method = ''
 | ) |  |

Constructor.

Paramètres
ContainerInterface | $container | The service container to load the service from when it shall be executed
string | $serviceId | The ID of the service from the container to be used
string | $method | The method from the service to be called if necessary. If left empty, the service must be a callable; (i.e. have an __invoke() method on a class)
Depuis
2.0.0
Exceptions

Références LazyServiceEventListener\$container, LazyServiceEventListener\$method, LazyServiceEventListener\$serviceId, class, et method.

Documentation des fonctions membres

◆ __invoke()

__invoke ( EventInterface $event )

Load a service from the container to listen to an event.

Paramètres
EventInterface $event The event to process
Renvoie
void
Depuis
2.0.0
Exceptions

Références $this, class, et method.

Documentation des champs

◆ $container

$container
private

Référencé par LazyServiceEventListener\__construct().

◆ $method

$method
private

Référencé par LazyServiceEventListener\__construct().

◆ $serviceId

$serviceId
private

Référencé par LazyServiceEventListener\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LazyServiceEventListener.php


Joomla CMS: Référence de la classe ListenersPriorityQueue

  • Joomla
  • Event
  • ListenersPriorityQueue
Fonctions membres publiques | Attributs privés
Référence de la classe ListenersPriorityQueue
+ Graphe d'héritage de ListenersPriorityQueue:

Fonctions membres publiques

add (callable $callback, int $priority)
remove (callable $callback)
has (callable $callback)
getPriority (callable $callback, $default=null)
getAll ()
getIterator ()
count ()

Attributs privés

$listeners = []

Description détaillée

A class containing an inner listeners priority queue that can be iterated multiple times.

Depuis
1.0

Documentation des fonctions membres

◆ add()

add | ( | callable | $callback,
 |  | int | $priority
 | ) |  |

Add a listener with the given priority only if not already present.

Paramètres
callable | $callback | A callable function acting as an event listener.
integer | $priority | The listener priority.
Renvoie
$this
Depuis
1.0

Références $this.

Référencé par Dispatcher\addListener().

◆ count()

count ( )

Count the number of listeners in the queue.

Renvoie
integer The number of listeners in the queue.
Depuis
1.0

Références $count.

◆ getAll()

getAll ( )

Get all listeners contained in this queue, sorted according to their priority.

Renvoie
callable[] An array of listeners.
Depuis
1.0

Référencé par ListenersPriorityQueue\getIterator().

◆ getIterator()

getIterator ( )

Get the priority queue.

Renvoie
Depuis
1.0

Références ListenersPriorityQueue\getAll().

◆ getPriority()

getPriority | ( | callable | $callback,
 |  |  | $default = null
 | ) |  |

Get the priority of the given listener.

Paramètres
callable | $callback | A callable function acting as an event listener.
mixed | $default | The default value to return if the listener doesn't exist.
Renvoie
mixed The listener priority if it exists or the specified default value
Depuis
1.0

Références $default, $key, et ListenersPriorityQueue\$listeners.

◆ has()

has ( callable $callback )

Tell if the listener exists in the queue.

Paramètres
callable $callback A callable function acting as an event listener.
Renvoie
boolean True if it exists, false otherwise.
Depuis
1.0

Références $key, et ListenersPriorityQueue\$listeners.

◆ remove()

remove ( callable $callback )

Remove a listener from the queue.

Paramètres
callable $callback A callable function acting as an event listener.
Renvoie
$this
Depuis
1.0

Références $key, ListenersPriorityQueue\$listeners, et $this.

Documentation des champs

◆ $listeners

$listeners = []
private

Référencé par ListenersPriorityQueue\getPriority(), ListenersPriorityQueue\has(), et ListenersPriorityQueue\remove().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ListenersPriorityQueue.php


Joomla CMS: Référence de la classe Priority

  • Joomla
  • Event
  • Priority
Champs de données | Fonctions membres privées
Référence de la classe Priority

Champs de données

const | MIN = -3
const | LOW = -2
const | BELOW_NORMAL = -1
const | NORMAL = 0
const | ABOVE_NORMAL = 1
const | HIGH = 2
const | MAX = 3

Fonctions membres privées

__construct ()

Description détaillée

An enumeration of priorities for event listeners that you are encouraged to use when adding them in the Dispatcher.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Disallow instantiation of this class

Depuis
1.0

Documentation des champs

◆ ABOVE_NORMAL

const ABOVE_NORMAL = 1

◆ BELOW_NORMAL

const BELOW_NORMAL = -1

◆ HIGH

const HIGH = 2

Référencé par Session\buildSession().

◆ LOW

const LOW = -2

Référencé par Cache\getSubscribedEvents().

◆ MAX

const MAX = 3

◆ MIN

const MIN = -3

◆ NORMAL

const NORMAL = 0

Référencé par Dispatcher\addSubscriber().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Priority.php


Joomla CMS: Référence de l'interface SubscriberInterface

  • Joomla
  • Event
  • SubscriberInterface
Fonctions membres publiques statiques
Référence de l'interface SubscriberInterface
+ Graphe d'héritage de SubscriberInterface:
Taggable Versionable Email Fixed Totp Webauthn Yubikey Joomlaupdate Cache Shortcut Webauthn Checkfiles DemoTasks Requests SiteStatus PlgSystemDebug PlgSystemHttpHeaders PlgSystemJooa11y PlgSystemRedirect PlgSystemSchedulerunner PlgSystemTasknotification PlgWorkflowFeaturing PlgWorkflowNotification PlgWorkflowPublishing

Fonctions membres publiques statiques

static getSubscribedEvents ()

Description détaillée

Interface for event subscribers.

Depuis
2.0.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

The array keys are event names and the value can be:

  • The method name to call (priority defaults to 0)
  • An array composed of the method name to call and the priority

For instance:

  • array('eventName' => 'methodName')
  • array('eventName' => array('methodName', $priority))
Renvoie
array
Depuis
2.0.0

Implémenté dans PlgSystemHttpHeaders, Webauthn, PlgSystemDebug, Cache, Email, PlgSystemTasknotification, Fixed, PlgWorkflowFeaturing, Totp, Yubikey, PlgWorkflowPublishing, SiteStatus, DemoTasks, Webauthn, PlgSystemSchedulerunner, PlgWorkflowNotification, PlgSystemRedirect, Checkfiles, Joomlaupdate, Shortcut, Requests, PlgSystemJooa11y, Taggable, et Versionable.

Référencé par Dispatcher\addSubscriber(), et Dispatcher\removeSubscriber().

La documentation de cette interface a été générée à partir du fichier suivant :
  • SubscriberInterface.php


Joomla CMS: Référence de la classe FtpClient

  • Joomla
  • Filesystem
  • Clients
  • FtpClient
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe FtpClient

Fonctions membres publiques

__construct (array $options=[])
__destruct ()
setOptions (array $options)
connect ($host='127.0.0.1', $port=21)
isConnected ()
login ($user='anonymous', $pass='jftp @joomla.org')
quit ()
pwd ()
syst ()
chdir ($path)
reinit ()
rename ($from, $to)
chmod ($path, $mode)
delete ($path)
mkdir ($path)
restart ($point)
create ($path)
read ($remote, &$buffer)
get ($local, $remote)
store ($local, $remote=null)
write ($remote, $buffer)
listNames ($path=null)
listDetails ($path=null, $type='all')

Fonctions membres publiques statiques

static getInstance ($host='127.0.0.1', $port='21', array $options=[], $user=null, $pass=null)

Fonctions membres protégées

_putCmd ($cmd, $expectedResponse)
_verifyResponse ($expected)
_passive ()
_findMode ($fileName)
_mode ($mode)

Attributs protégés statiques

static $instances = []

Attributs privés

$conn
$dataconn
$pasv
$response
$responseCode
$responseMsg
$timeout = 15
$type
$autoAscii
$lineEndings = ['UNIX' => "\n"

Description détaillée

FTP client class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = [] )

FtpClient object constructor

Paramètres
array $options Associative array of options to set
Depuis
1.0

Références $options, et FtpClient\setOptions().

◆ __destruct()

__destruct ( )

FtpClient object destructor

Closes an existing connection, if we have one

Depuis
1.0

Références FtpClient\quit().

Documentation des fonctions membres

◆ _findMode()

_findMode ( $fileName )
protected

Method to find out the correct transfer mode for a specific file

Paramètres
string $fileName Name of the file
Renvoie
integer Transfer-mode for this filetype [FTP_ASCII|FTP_BINARY]
Depuis
1.0

Références $mode, et elseif.

Référencé par FtpClient\get(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ _mode()

_mode ( $mode )
protected

Set transfer mode

Paramètres
integer $mode Integer representation of data transfer mode [1:Binary|0:Ascii] Defined constants can also be used [FTP_BINARY|FTP_ASCII]
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $mode, et FtpClient\_putCmd().

Référencé par FtpClient\get(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ _passive()

_passive ( )
protected

Set server to passive mode and open a data port connection

Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $parts, FtpClient\$timeout, et null.

Référencé par FtpClient\create(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ _putCmd()

_putCmd | ( | $cmd,
 |  | $expectedResponse
 | ) |
protected

Send command to the FTP server and validate an expected response code

Paramètres
string | $cmd | Command to send to the FTP server
mixed | $expectedResponse | Integer response code or array of integer response codes
Renvoie
boolean True if command executed successfully
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_verifyResponse().

Référencé par FtpClient\_mode(), FtpClient\chdir(), FtpClient\chmod(), FtpClient\create(), FtpClient\delete(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\login(), FtpClient\mkdir(), FtpClient\pwd(), FtpClient\read(), FtpClient\reinit(), FtpClient\rename(), FtpClient\restart(), FtpClient\store(), FtpClient\syst(), et FtpClient\write().

◆ _verifyResponse()

_verifyResponse ( $expected )
protected

Verify the response code from the server and log response if flag is set

Paramètres
mixed $expected Integer response code or array of integer response codes
Renvoie
boolean True if response code from the server is expected
Depuis
1.0
Exceptions
FilesystemException

Références $parts, FtpClient\$timeout, et null.

Référencé par FtpClient\_putCmd(), FtpClient\connect(), FtpClient\create(), FtpClient\get(), FtpClient\listDetails(), FtpClient\listNames(), FtpClient\read(), FtpClient\store(), et FtpClient\write().

◆ chdir()

chdir ( $path )

Method to change the current working directory on the FTP server

Paramètres
string $path Path to change into on the server
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $path, et FtpClient\_putCmd().

◆ chmod()

chmod | ( | $path,
 |  | $mode
 | ) |

Method to change mode for a path on the FTP server

Paramètres
string | $path | Path to change mode on
mixed | $mode | Octal value to change mode to, e.g. '0777', 0777 or 511 (string or integer)
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $mode, $path, et FtpClient\_putCmd().

◆ connect()

connect | ( | $host = '127.0.0.1',
 |  | $port = 21
 | ) |

Method to connect to a FTP server

Paramètres
string | $host | Host to connect to [Default: 127.0.0.1]
integer | $port | Port to connect on [Default: port 21]
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_verifyResponse(), et null.

◆ create()

create ( $path )

Method to create an empty file on the FTP server

Paramètres
string $path Path local file to store on the FTP server
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $buffer, $path, FtpClient\_passive(), FtpClient\_putCmd(), et FtpClient\_verifyResponse().

◆ delete()

delete ( $path )

Method to delete a path [file/folder] on the FTP server

Paramètres
string $path Path to delete
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $path, et FtpClient\_putCmd().

◆ get()

get | ( | $local,
 |  | $remote
 | ) |

Method to get a file from the FTP server and save it to a local file

Paramètres
string | $local | Local path to save remote file to
string | $remote | Path to remote file to get on the FTP server
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $buffer, $mode, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), et FtpClient\_verifyResponse().

◆ getInstance()

static getInstance | ( |  | $host = '127.0.0.1',
 |  |  | $port = '21',
 |  | array | $options = [],
 |  |  | $user = null,
 |  |  | $pass = null
 | ) |  |
static

Returns the global FTP connector object, only creating it if it doesn't already exist.

You may optionally specify a username and password in the parameters. If you do so, you may not login() again with different credentials using the same object. If you do not use this option, you must quit() the current connection when you are done, to free it for use by others.

Paramètres
string | $host | Host to connect to
string | $port | Port to connect to
array | $options | Array with any of these options: type=>[FTP_AUTOASCII|FTP_ASCII|FTP_BINARY], timeout=>(int)
string | $user | Username to use for a connection
string | $pass | Password to use for a connection
Renvoie
FtpClient The FTP Client object.
Depuis
1.0

Références $options, $return, $user, FtpClient\isConnected(), et null.

◆ isConnected()

isConnected ( )

Method to determine if the object is connected to an FTP server

Renvoie
boolean True if connected
Depuis
1.0

Référencé par FtpClient\getInstance().

◆ listDetails()

listDetails | ( | $path = null,
 |  | $type = 'all'
 | ) |

Method to list the contents of a directory on the FTP server

Paramètres
string | $path | Path to the local file to be stored on the FTP server
string | $type | Return type [raw|all|folders|files]
Renvoie
string[] If $type is raw: string Directory listing, otherwise array of string with file-names
Depuis
1.0
Exceptions
FilesystemException

Références $data, $path, FtpClient\$type, FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), et null.

Référencé par FtpClient\listNames().

◆ listNames()

listNames ( $path = null )

Method to list the filenames of the contents of a directory on the FTP server

Note: Some servers also return folder names. However, to be sure to list folders on all servers, you should use listDetails() instead if you also need to deal with folders

Paramètres
string $path Path local file to store on the FTP server
Renvoie
string Directory listing
Depuis
1.0
Exceptions
FilesystemException

Références $data, $key, $list, $path, FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), FtpClient\listDetails(), et null.

◆ login()

login | ( | $user = 'anonymous',
 |  | $pass = 'jftp@joomla.org'
 | ) |

Method to login to a server once connected

Paramètres
string | $user | Username to login to the server
string | $pass | Password to login to the server
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $user, et FtpClient\_putCmd().

◆ mkdir()

mkdir ( $path )

Method to create a directory on the FTP server

Paramètres
string $path Directory to create
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $path, et FtpClient\_putCmd().

◆ pwd()

pwd ( )

Method to retrieve the current working directory on the FTP server

Renvoie
string Current working directory
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_putCmd(), et null.

◆ quit()

quit ( )

Method to quit and close the connection

Renvoie
boolean True if successful
Depuis
1.0

Référencé par FtpClient\__destruct().

◆ read()

read | ( |  | $remote,
 |  | & | $buffer
 | ) |  |

Method to read a file from the FTP server's contents into a buffer

Paramètres
string | $remote | Path to remote file to read on the FTP server
string | $buffer | Buffer variable to read file contents into
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $buffer, $mode, $os, $tmp, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), et FtpClient\_verifyResponse().

◆ reinit()

reinit ( )

Method to reinitialise the server, ie. need to login again

NOTE: This command not available on all servers

Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_putCmd().

◆ rename()

rename | ( | $from,
 |  | $to
 | ) |

Method to rename a file/folder on the FTP server

Paramètres
string | $from | Path to change file/folder from
string | $to | Path to change file/folder to
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_putCmd().

◆ restart()

restart ( $point )

Method to restart data transfer at a given byte

Paramètres
integer $point Byte to restart transfer at
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\_putCmd().

◆ setOptions()

setOptions ( array $options )

Set client options

Paramètres
array $options Associative array of options to set
Renvoie
boolean True if successful
Depuis
1.0

Références $options.

Référencé par FtpClient\__construct().

◆ store()

store | ( | $local,
 |  | $remote = null
 | ) |

Method to store a file to the FTP server

Paramètres
string | $local | Path to local file to store on the FTP server
string | $remote | FTP path to file to create
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $mode, $result, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), FtpClient\_verifyResponse(), et null.

◆ syst()

syst ( )

Method to system string from the FTP server

Renvoie
string System identifier string
Depuis
1.0
Exceptions
FilesystemException

Références FtpClient\$response, FtpClient\_putCmd(), et elseif.

◆ write()

write | ( | $remote,
 |  | $buffer
 | ) |

Method to write a string to the FTP server

Paramètres
string | $remote | FTP path to file to write to
string | $buffer | Contents to write to the FTP server
Renvoie
boolean True if successful
Depuis
1.0
Exceptions
FilesystemException

Références $buffer, $mode, $result, $tmp, FtpClient\_findMode(), FtpClient\_mode(), FtpClient\_passive(), FtpClient\_putCmd(), et FtpClient\_verifyResponse().

Documentation des champs

◆ $autoAscii

$autoAscii
private
Valeur initiale :
= [
'asp',
'bat',
'c',
'cpp',
'csv',
'h',
'htm',
'html',
'shtml',
'ini',
'inc',
'log',
'php',
'php3',
'pl',
'perl',
'sh',
'sql',
'txt',
'xhtml',
'xml',
]

◆ $conn

$conn
private

◆ $dataconn

$dataconn
private

◆ $instances

$instances = []
staticprotected

◆ $lineEndings

$lineEndings = ['UNIX' => "\n"
private

◆ $pasv

$pasv
private

◆ $response

$response
private

Référencé par FtpClient\syst().

◆ $responseCode

$responseCode
private

◆ $responseMsg

$responseMsg
private

◆ $timeout

$timeout = 15
private

Référencé par FtpClient\_passive(), et FtpClient\_verifyResponse().

◆ $type

$type
private

Référencé par FtpClient\listDetails().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Clients/FtpClient.php


Joomla CMS: Référence de la classe FilesystemException

  • Joomla
  • Filesystem
  • Exception
  • FilesystemException
Fonctions membres publiques
Référence de la classe FilesystemException
+ Graphe d'héritage de FilesystemException:

Fonctions membres publiques

__construct ($message="", $code=0, \Throwable $previous=null)

Description détaillée

Exception class for handling errors in the Filesystem package

Depuis
1.2.0 2.0.1 If the message containes a full path, the root path (JPATH_ROOT) is removed from it to avoid any full path disclosure. Before 2.0.1, the path was propagated as provided.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $message = "",
 |  |  | $code = 0,
 |  | \Throwable | $previous = null
 | ) |  |

Constructor.

Paramètres
string | $message | The message
integer | $code | The code
\Throwable | null | $previous | A previous exception

Références $message, Symfony\Contracts\Service\__construct(), et Path\removeRoot().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FilesystemException.php


Joomla CMS: Référence de la classe StringWrapper

  • Joomla
  • Filesystem
  • Stream
  • StringWrapper
Fonctions membres publiques | Attributs protégés
Référence de la classe StringWrapper

Fonctions membres publiques

stream_open ($path, $mode, $options, &$openedPath)
stream_stat ()
url_stat ($path, $flags=0)
stream_read ($count)
stream_write ($data)
stream_tell ()
stream_eof ()
stream_seek ($offset, $whence)
stream_flush ()

Attributs protégés

$currentString
$path
$mode
$options
$openedPath
$pos
$len
$stat

Description détaillée

String Stream Wrapper

This class allows you to use a PHP string in the same way that you would normally use a regular stream wrapper

Depuis
1.3.0

Documentation des fonctions membres

◆ stream_eof()

stream_eof ( )

End of field check

Renvoie
boolean True if at end of field.
Depuis
1.3.0

◆ stream_flush()

stream_flush ( )

Stream flush, always returns true.

Renvoie
boolean
Depuis
1.3.0
Note
Data storage is not supported

◆ stream_open()

stream_open | ( |  | $path,
 |  |  | $mode,
 |  |  | $options,
 |  | & | $openedPath
 | ) |  |

Method to open a file or URL.

Paramètres
string | $path | The stream path.
string | $mode | Not used.
integer | $options | Not used.
string | $openedPath | Not used.
Renvoie
boolean
Depuis
1.3.0

Références StringWrapper\$path, et StringWrapper\url_stat().

◆ stream_read()

stream_read ( $count )

Method to read a given number of bytes starting at the current position and moving to the end of the string defined by the current position plus the given number.

Paramètres
integer $count Bytes of data from the current position should be returned.
Renvoie
string

1.3.0

Références $count, et $result.

◆ stream_seek()

stream_seek | ( | $offset,
 |  | $whence
 | ) |

Stream offset

Paramètres
integer | $offset | The starting offset.
integer | $whence | SEEK_SET, SEEK_CUR, SEEK_END
Renvoie
boolean True on success.
Depuis
1.3.0

Références Joomla\Database\Query\$offset.

◆ stream_stat()

stream_stat ( )

Method to retrieve information from a file resource

Renvoie
array

1.3.0

Références StringWrapper\$stat.

◆ stream_tell()

stream_tell ( )

Method to get the current position

Renvoie
integer The position
Depuis
1.3.0

Références StringWrapper\$pos.

◆ stream_write()

stream_write ( $data )

Stream write, always returning false.

Paramètres
string $data The data to write.
Renvoie
boolean
Depuis
1.3.0
Note
Updating the string is not supported.

◆ url_stat()

url_stat | ( | $path,
 |  | $flags = 0
 | ) |

Method to retrieve information about a file.

Paramètres
string | $path | File path or URL to stat
integer | $flags | Additional flags set by the streams API
Renvoie
array

1.3.0

Références $now, StringWrapper\$path, et StringWrapper\$stat.

Référencé par StringWrapper\stream_open().

Documentation des champs

◆ $currentString

$currentString
protected

◆ $len

$len
protected

◆ $mode

$mode
protected

◆ $openedPath

$openedPath
protected

◆ $options

$options
protected

◆ $path

$path
protected

Référencé par StringWrapper\stream_open(), et StringWrapper\url_stat().

◆ $pos

$pos
protected

Référencé par StringWrapper\stream_tell().

◆ $stat

$stat
protected

Référencé par StringWrapper\stream_stat(), et StringWrapper\url_stat().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StringWrapper.php


Joomla CMS: Référence de la classe StringController

  • Joomla
  • Filesystem
  • Support
  • StringController
Fonctions membres publiques statiques | Attributs privés statiques
Référence de la classe StringController

Fonctions membres publiques statiques

static | _getArray ()
static | getArray ()
static | createRef ($reference, &$string)
static | getRef ($reference)

Attributs privés statiques

static $strings = []

Description détaillée

String Controller

Depuis
1.0

Documentation des fonctions membres

◆ _getArray()

static _getArray ( )
static

Defines a variable as an array

Renvoie
array
Depuis
1.0
Obsolète:
2.0 Use getArray instead.

◆ createRef()

static createRef | ( |  | $reference,
 |  | & | $string
 | ) |  |
static

Create a reference

Paramètres
string | $reference | The key
string | $string | The value
Renvoie
void
Depuis
1.0

Références $strings.

◆ getArray()

static getArray ( )
static

Defines a variable as an array

Renvoie
array
Depuis
1.4.0

Références $strings.

◆ getRef()

static getRef ( $reference )
static

Get reference

Paramètres
string $reference The key for the reference.
Renvoie
mixed False if not set, reference if it exists
Depuis
1.0

Références $strings.

Documentation des champs

◆ $strings

$strings = []
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Support/StringController.php


Joomla CMS: Référence de la classe Buffer

  • Joomla
  • Filesystem
  • Buffer
Fonctions membres publiques | Champs de données
Référence de la classe Buffer

Fonctions membres publiques

stream_open ($path, $mode, $options, &$openedPath)
stream_read ($count)
stream_write ($data)
stream_tell ()
stream_eof ()
stream_seek ($offset, $whence)

Champs de données

$position = 0
$name
$buffers = []

Description détaillée

Generic Buffer stream handler

This class provides a generic buffer stream. It can be used to store/retrieve/manipulate string buffers with the standard PHP filesystem I/O methods.

Depuis
1.0

Documentation des fonctions membres

◆ stream_eof()

stream_eof ( )

Function to test for end of file pointer

Renvoie
boolean True if the pointer is at the end of the stream
Voir également
streamWrapper::stream_eof
Depuis
1.0

Références name.

◆ stream_open()

stream_open | ( |  | $path,
 |  |  | $mode,
 |  |  | $options,
 |  | & | $openedPath
 | ) |  |

Function to open file or url

Paramètres
string | $path | The URL that was passed
string | $mode | Mode used to open the file
Voir également
fopen
Paramètres
integer | $options | Flags used by the API, may be STREAM_USE_PATH and STREAM_REPORT_ERRORS
string | $openedPath | Full path of the resource. Used with STREAN_USE_PATH option
Renvoie
boolean
Depuis
1.0
Voir également
streamWrapper::stream_open

Références Buffer\$name, $path, $url, name, et null.

◆ stream_read()

stream_read ( $count )

Read stream

Paramètres
integer $count How many bytes of data from the current position should be returned.
Renvoie
mixed The data from the stream up to the specified number of bytes (all data if the total number of bytes in the stream is less than $count. Null if the stream is empty.
Voir également
streamWrapper::stream_read
Depuis
1.0

Références $count, et name.

◆ stream_seek()

stream_seek | ( | $offset,
 |  | $whence
 | ) |

The read write position updates in response to $offset and $whence

Paramètres
integer | $offset | The offset in bytes
integer | $whence | Position the offset is added to Options are SEEK_SET, SEEK_CUR, and SEEK_END
Renvoie
boolean True if updated
Voir également
streamWrapper::stream_seek
Depuis
1.0

Références Joomla\Database\Query\$offset, et name.

◆ stream_tell()

stream_tell ( )

Function to get the current position of the stream

Renvoie
integer
Voir également
streamWrapper::stream_tell
Depuis
1.0

Références Buffer\$position.

◆ stream_write()

stream_write ( $data )

Write stream

Paramètres
string $data The data to write to the stream.
Renvoie
integer
Voir également
streamWrapper::stream_write
Depuis
1.0

Références $data, Buffer\$name, et name.

Documentation des champs

◆ $buffers

$buffers = []

◆ $name

$name

Référencé par Buffer\stream_open(), et Buffer\stream_write().

◆ $position

$position = 0

Référencé par Buffer\stream_tell().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Buffer.php


Joomla CMS: Référence de la classe File

  • Joomla
  • Filesystem
  • File
Fonctions membres publiques statiques
Référence de la classe File

Fonctions membres publiques statiques

static | stripExt ($file)
static | makeSafe ($file, array $stripChars=['#^\.#'])
static | copy ($src, $dest, $path=null, $useStreams=false)
static | delete ($file)
static | move ($src, $dest, $path='', $useStreams=false)
static | write ($file, &$buffer, $useStreams=false, $appendToFile=false)
static | upload ($src, $dest, $useStreams=false)
static | invalidateFileCache ($file)

Description détaillée

A File handling class

Depuis
1.0

Documentation des fonctions membres

◆ copy()

static copy | ( | $src,
 |  | $dest,
 |  | $path = null,
 |  | $useStreams = false
 | ) |
static

Copies a file

Paramètres
string | $src | The path to the source file
string | $dest | The path to the destination file
string | $path | An optional base path to prefix to the file names
boolean | $useStreams | True to use streams
Renvoie
boolean True on success
Depuis
1.0
Exceptions
FilesystemException

Références $path, Laminas\Diactoros\$stream, Path\clean(), Stream\getStream(), null, et Path\removeRoot().

Référencé par Archive\extract().

◆ delete()

static delete ( $file )
static

Delete a file or array of files

Paramètres
mixed $file The file name or an array of file names
Renvoie
boolean True on success
Depuis
1.0
Exceptions
FilesystemException

Références Path\canChmod(), et Path\clean().

Référencé par Patcher\apply(), Folder\delete(), et Path\isOwner().

◆ invalidateFileCache()

static invalidateFileCache ( $file )
static

Invalidate any opcache for a newly written file immediately, if opcache* functions exist and if this was a PHP file.

Paramètres
string $file The path to the file just written to, to flush from opcache
Renvoie
void

Références $info.

◆ makeSafe()

static makeSafe | ( |  | $file,
 |  | array | $stripChars = ['#^\.#']
 | ) |  |
static

Makes the file name safe to use

Paramètres
string | $file | The name of the file [not full path]
array | $stripChars | Array of regex (by default will remove any leading periods)
Renvoie
string The sanitised string
Depuis
1.0

◆ move()

static move | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $useStreams = false
 | ) |
static

Moves a file

Paramètres
string | $src | The path to the source file
string | $dest | The path to the destination file
string | $path | An optional base path to prefix to the file names
boolean | $useStreams | True to use streams
Renvoie
boolean True on success
Depuis
1.0
Exceptions
FilesystemException

Références $path, Laminas\Diactoros\$stream, Path\clean(), Stream\getStream(), et null.

◆ stripExt()

static stripExt ( $file )
static

Strips the last extension off of a file name

Paramètres
string $file The file name
Renvoie
string The file name without the extension
Depuis
1.0

Référencé par ImportCommand\doExecute(), et FilelistField\getOptions().

◆ upload()

static upload | ( | $src,
 |  | $dest,
 |  | $useStreams = false
 | ) |
static

Moves an uploaded file to a destination folder

Paramètres
string | $src | The name of the php (temporary) uploaded file
string | $dest | The path (including filename) to move the uploaded file to
boolean | $useStreams | True to use streams
Renvoie
boolean True on success
Depuis
1.0
Exceptions
FilesystemException

Références $baseDir, Laminas\Diactoros\$stream, Path\clean(), Folder\create(), Stream\getStream(), null, et Path\setPermissions().

◆ write()

static write | ( |  | $file,
 |  | & | $buffer,
 |  |  | $useStreams = false,
 |  |  | $appendToFile = false
 | ) |  |
static

Write contents to a file

Paramètres
string | $file | The full file path
string | $buffer | The buffer to write
boolean | $useStreams | Use streams
boolean | $appendToFile | Append to the file and not overwrite it.
Renvoie
boolean True on success
Depuis
1.0

Références $buffer, Laminas\Diactoros\$stream, Path\clean(), Folder\create(), et Stream\getStream().

Référencé par Patcher\apply(), Zip\createZipFile(), Bzip2\extract(), Gzip\extract(), Tar\extract(), Zip\extractCustom(), Zip\extractNative(), Path\isOwner(), Requests\makeGetRequest(), et SiteStatus\writeConfigFile().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/File.php


Joomla CMS: Référence de la classe Folder

  • Joomla
  • Filesystem
  • Folder
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Folder

Fonctions membres publiques statiques

static | copy ($src, $dest, $path='', $force=false, $useStreams=false)
static | create ($path='', $mode=0755)
static | delete ($path)
static | move ($src, $dest, $path='', $useStreams=false)
static | files ($path, $filter='.', $recurse=false, $full=false, $exclude=['.svn', 'CVS', '.DS_Store', '__MACOSX'], $excludeFilter=['^\..*', '.*~'])
static | folders ($path, $filter='.', $recurse=false, $full=false, $exclude=['.svn', 'CVS', '.DS_Store', '__MACOSX'], $excludeFilter=['^\..*'])
static | listFolderTree ($path, $filter, $maxLevel=3, $level=0, $parent=0)
static | makeSafe ($path)

Fonctions membres protégées statiques

static _items ($path, $filter, $recurse, $full, $exclude, $excludeFilterString, $findfiles)

Description détaillée

A Folder handling class

Depuis
1.0

Documentation des fonctions membres

◆ _items()

static _items | ( | $path,
 |  | $filter,
 |  | $recurse,
 |  | $full,
 |  | $exclude,
 |  | $excludeFilterString,
 |  | $findfiles
 | ) |
staticprotected

Function to read the files/folders in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for file names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the file.
array | $exclude | Array with names of files which should not be shown in the result.
string | $excludeFilterString | Regexp of files to exclude
boolean | $findfiles | True to read the files, false to read the folders
Renvoie
array Files.
Depuis
1.0

Références $path, et Path\clean().

◆ copy()

static copy | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $force = false,
 |  | $useStreams = false
 | ) |
static

Copy a folder.

Paramètres
string | $src | The path to the source folder.
string | $dest | The path to the destination folder.
string | $path | An optional base path to prefix to the file names.
boolean | $force | Force copy.
boolean | $useStreams | Optionally force folder/file overwrites.
Renvoie
boolean True on success.
Depuis
1.0
Exceptions
FilesystemException

Références $path, Path\clean(), Stream\getStream(), et null.

◆ create()

static create | ( | $path = '',
 |  | $mode = 0755
 | ) |
static

Create a folder – and all necessary parent folders.

Paramètres
string | $path | A path to create from the base path.
integer | $mode | Directory permissions to set for folders created. 0755 by default.
Renvoie
boolean True if successful.
Depuis
1.0
Exceptions
FilesystemException

Références $mode, $path, Path\clean(), et null.

Référencé par ImportCommand\doExecute(), Archive\extract(), Tar\extract(), Zip\extractCustom(), Zip\extractNative(), File\upload(), et File\write().

◆ delete()

static delete ( $path )
static

Delete a folder.

Paramètres
string $path The path to the folder to delete.
Renvoie
boolean True on success.
Depuis
1.0
Exceptions
FilesystemException

Références $folder, $path, Path\clean(), File\delete(), elseif, et Path\removeRoot().

Référencé par ImportCommand\doExecute().

◆ files()

static files | ( |  | $path,
 |  |  | $filter = '.',
 |  |  | $recurse = false,
 |  |  | $full = false,
 |  |  | $exclude = ['.svn',
 |  | 'CVS' | ,
 |  | '.DS_Store' | ,
 |  | '__MACOSX'] | ,
 |  |  | $excludeFilter = ['^\..*',
 |  | '.*~'] |
 | ) |  |
static

Utility function to read the files in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for file names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the file.
array | $exclude | Array with names of files which should not be shown in the result.
array | $excludeFilter | Array of filter to exclude
Renvoie
array Files in the given folder.
Depuis
1.0
Exceptions

Références $path, Path\clean(), et Path\removeRoot().

Référencé par Checkfiles\checkImages(), et ImportCommand\doExecute().

◆ folders()

static folders | ( |  | $path,
 |  |  | $filter = '.',
 |  |  | $recurse = false,
 |  |  | $full = false,
 |  |  | $exclude = ['.svn',
 |  | 'CVS' | ,
 |  | '.DS_Store' | ,
 |  | '__MACOSX'] | ,
 |  |  | $excludeFilter = ['^\..*']
 | ) |  |
static

Utility function to read the folders in a folder.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for folder names.
mixed | $recurse | True to recursively search into sub-folders, or an integer to specify the maximum depth.
boolean | $full | True to return the full path to the folders.
array | $exclude | Array with names of folders which should not be shown in the result.
array | $excludeFilter | Array with regular expressions matching folders which should not be shown in the result.
Renvoie
array Folders in the given folder.
Depuis
1.0
Exceptions

Références $path, Path\clean(), et Path\removeRoot().

◆ listFolderTree()

static listFolderTree | ( | $path,
 |  | $filter,
 |  | $maxLevel = 3,
 |  | $level = 0,
 |  | $parent = 0
 | ) |
static

Lists folder in format suitable for tree display.

Paramètres
string | $path | The path of the folder to read.
string | $filter | A filter for folder names.
integer | $maxLevel | The maximum number of levels to recursively read, defaults to three.
integer | $level | The current level, optional.
integer | $parent | Unique identifier of the parent folder, if any.
Renvoie
array Folders in the given folder.
Depuis
1.0

Références $id, $name, $path, Path\clean(), et JPATH_ROOT.

◆ makeSafe()

static makeSafe ( $path )
static

Makes path name safe to use.

Paramètres
string $path The full path to sanitise.
Renvoie
string The sanitised string.
Depuis
1.0

Références $path.

◆ move()

static move | ( | $src,
 |  | $dest,
 |  | $path = '',
 |  | $useStreams = false
 | ) |
static

Moves a folder.

Paramètres
string | $src | The path to the source folder.
string | $dest | The path to the destination folder.
string | $path | An optional base path to prefix to the file names.
boolean | $useStreams | Optionally use streams.
Renvoie
string|boolean Error message on false or boolean true on success.
Depuis
1.0

Références $path, Path\clean(), et Stream\getStream().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Folder.php


Joomla CMS: Référence de la classe Helper

  • Joomla
  • Filesystem
  • Helper
Fonctions membres publiques statiques
Référence de la classe Helper

Fonctions membres publiques statiques

static | remotefsize ($url)
static | ftpChmod ($url, $mode)
static | getWriteModes ()
static | getSupported ()
static | getTransports ()
static | getFilters ()
static | isJoomlaStream ($streamname)

Description détaillée

File system helper

Holds support functions for the filesystem, particularly the stream

Depuis
1.0

Documentation des fonctions membres

◆ ftpChmod()

static ftpChmod | ( | $url,
 |  | $mode
 | ) |
static

Quick FTP chmod

Paramètres
string | $url | Link identifier
integer | $mode | The new permissions, given as an octal value.
Renvoie
integer|boolean

1.0

Références $mode, $path, $url, $user, et null.

Référencé par Stream\chmod().

◆ getFilters()

static getFilters ( )
static

Returns a list of filters

Renvoie
array
Depuis
1.0

◆ getSupported()

static getSupported ( )
static

Stream and Filter Support Operations

Returns the supported streams, in addition to direct file access Also includes Joomla! streams as well as PHP streams

Renvoie
array Streams
Depuis
1.0

◆ getTransports()

static getTransports ( )
static

Returns a list of transports

Renvoie
array
Depuis
1.0

◆ getWriteModes()

static getWriteModes ( )
static

Modes that require a write operation

Renvoie
array
Depuis
1.0

Référencé par Stream\_getFilename().

◆ isJoomlaStream()

static isJoomlaStream ( $streamname )
static

Determine if a stream is a Joomla stream.

Paramètres
string $streamname The name of a stream
Renvoie
boolean True for a Joomla Stream
Depuis
1.0

Référencé par Stream\open().

◆ remotefsize()

static remotefsize ( $url )
static

Remote file size function for streams that don't support it

Paramètres
string $url TODO Add text
Renvoie
mixed

1.0

Références $path, $url, $user, et null.

Référencé par Stream\filesize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/filesystem/src/Helper.php


Joomla CMS: Référence de la classe Patcher

  • Joomla
  • Filesystem
  • Patcher
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Patcher

Fonctions membres publiques

reset ()
apply ()
addFile ($filename, $root, $strip=0)
add ($udiff, $root, $strip=0)

Fonctions membres publiques statiques

static getInstance ()

Champs de données

const | SRC_FILE = '/^---\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'
const | DST_FILE = '/^\\+\\+\\+\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'
const | HUNK = '/@@ -(\\d+)(,(\\d+))?\\s+\\+(\\d+)(,(\\d+))?\\s+@@($)/A'
const | SPLIT = '/(\r\n)|(\r)|(\n)/'

Fonctions membres protégées

__construct ()
applyHunk (&$lines, $src, $dst, $srcLine, $srcSize, $dstLine, $dstSize)
& getSource ($src)
& getDestination ($dst, $src)

Fonctions membres protégées statiques

static | splitLines ($data)
static | findHeader (&$lines, &$src, &$dst)
static | findHunk (&$lines, &$srcLine, &$srcSize, &$dstLine, &$dstSize)

Attributs protégés

$sources = []
$destinations = []
$removals = []
$patches = []

Attributs protégés statiques

static $instance

Description détaillée

A Unified Diff Format Patcher class

This has been derived from the PhpPatcher version 0.1.1 written by Giuseppe Mazzotta 1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor

The constructor is protected to force the use of Patcher::getInstance()

Depuis
1.0

Documentation des fonctions membres

◆ add()

add | ( | $udiff,
 |  | $root,
 |  | $strip = 0
 | ) |

Add a unified diff string to the patcher

Paramètres
string | $udiff | Unified diff input string
string | $root | The files root path
integer | $strip | The number of '/' to strip
Renvoie
Patcher $this for chaining
Depuis
1.0

Références $root, et $this.

Référencé par Patcher\addFile().

◆ addFile()

addFile | ( | $filename,
 |  | $root,
 |  | $strip = 0
 | ) |

Add a unified diff file to the patcher

Paramètres
string | $filename | Path to the unified diff file
string | $root | The files root path
integer | $strip | The number of '/' to strip
Renvoie
Patcher $this for chaining
Depuis
1.0

Références $root, et Patcher\add().

◆ apply()

apply ( )

Apply the patches

Renvoie
integer The number of files patched
Depuis
1.0
Exceptions

Références $content, Patcher\applyHunk(), File\delete(), null, et File\write().

◆ applyHunk()

applyHunk | ( | & | $lines,
 |  |  | $src,
 |  |  | $dst,
 |  |  | $srcLine,
 |  |  | $srcSize,
 |  |  | $dstLine,
 |  |  | $dstSize
 | ) |  |
protected

Apply the patch

Paramètres
array | $lines | The udiff array of lines
string | $src | The source file
string | $dst | The destination file
string | $srcLine | The beginning of the patch for the source file
string | $srcSize | The size of the patch for the source file
string | $dstLine | The beginning of the patch for the destination file
string | $dstSize | The size of the patch for the destination file
Renvoie
void
Depuis
1.0
Exceptions

Références elseif, Patcher\getDestination(), Patcher\getSource(), et Path\removeRoot().

Référencé par Patcher\apply().

◆ findHeader()

static findHeader | ( | & | $lines,
 |  | & | $src,
 |  | & | $dst
 | ) |  |
staticprotected

Find the diff header

The internal array pointer of $lines is on the next line after the finding

Paramètres
array | $lines | The udiff array of lines
string | $src | The source file
string | $dst | The destination file
Renvoie
boolean TRUE in case of success, FALSE in case of failure
Depuis
1.0
Exceptions

◆ findHunk()

static findHunk | ( | & | $lines,
 |  | & | $srcLine,
 |  | & | $srcSize,
 |  | & | $dstLine,
 |  | & | $dstSize
 | ) |  |
staticprotected

Find the next hunk of difference

The internal array pointer of $lines is on the next line after the finding

Paramètres
array | $lines | The udiff array of lines
string | $srcLine | The beginning of the patch for the source file
string | $srcSize | The size of the patch for the source file
string | $dstLine | The beginning of the patch for the destination file
string | $dstSize | The size of the patch for the destination file
Renvoie
boolean TRUE in case of success, false in case of failure
Depuis
1.0
Exceptions

◆ getDestination()

& getDestination | ( | $dst,
 |  | $src
 | ) |
protected

Get the lines of a destination file

Paramètres
string | $dst | The path of a destination file
string | $src | The path of a source file
Renvoie
array The lines of the destination file
Depuis
1.0

Références Patcher\getSource().

Référencé par Patcher\applyHunk().

◆ getInstance()

static getInstance ( )
static

Method to get a patcher

Renvoie
Patcher an instance of the patcher
Depuis
1.0

◆ getSource()

& getSource ( $src )
protected

Get the lines of a source file

Paramètres
string $src The path of a file
Renvoie
array The lines of the source file
Depuis
1.0

Références null.

Référencé par Patcher\applyHunk(), et Patcher\getDestination().

◆ reset()

reset ( )

Reset the pacher

Renvoie
Patcher This object for chaining
Depuis
1.0

Références $this.

◆ splitLines()

static splitLines ( $data )
staticprotected

Separate CR or CRLF lines

Paramètres
string $data Input string
Renvoie
array The lines of the input destination file
Depuis
1.0

Références $data.

Documentation des champs

◆ $destinations

$destinations = []
protected

◆ $instance

$instance
staticprotected

◆ $patches

$patches = []
protected

◆ $removals

$removals = []
protected

◆ $sources

$sources = []
protected

◆ DST_FILE

const DST_FILE = '/^\\+\\+\\+\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'

◆ HUNK

const HUNK = '/@@ -(\\d+)(,(\\d+))?\\s+\\+(\\d+)(,(\\d+))?\\s+@@($)/A'

◆ SPLIT

const SPLIT = '/(\r\n)|(\r)|(\n)/'

◆ SRC_FILE

const SRC_FILE = '/^---\\s+(\\S+)\s+\\d{1,4}-\\d{1,2}-\\d{1,2}\\s+\\d{1,2}:\\d{1,2}:\\d{1,2}(\\.\\d+)?\\s+(\+|-)\\d{4}/A'
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Patcher.php


Joomla CMS: Référence de la classe Path

  • Joomla
  • Filesystem
  • Path
Fonctions membres publiques statiques
Référence de la classe Path

Fonctions membres publiques statiques

static | canChmod ($path)
static | setPermissions ($path, $filemode='0644', $foldermode='0755')
static | getPermissions ($path)
static | check ($path, $basePath='')
static | clean ($path, $ds=\DIRECTORY_SEPARATOR)
static | isOwner ($path)
static | find ($paths, $file)
static | resolve ($path)
static | removeRoot ($message, $rootDirectory=null)

Description détaillée

A Path handling class

Depuis
1.0

Documentation des fonctions membres

◆ canChmod()

static canChmod ( $path )
static

Checks if a path's permissions can be changed.

Paramètres
string $path Path to check.
Renvoie
boolean True if path can have mode changed.
Depuis
1.0

Références $path.

Référencé par File\delete().

◆ check()

static check | ( | $path,
 |  | $basePath = ''
 | ) |
static

Checks for snooping outside of the file system root.

Paramètres
string | $path | A file system path to check.
string | $basePath | The base path of the system
Renvoie
string A cleaned version of the path or exit on error.
Depuis
1.0
Exceptions
FilesystemException

Références $basePath, et $path.

Référencé par Checkfiles\checkImages().

◆ clean()

static clean | ( | $path,
 |  | $ds = \DIRECTORY_SEPARATOR
 | ) |
static

Function to strip additional / or \ in a path name.

Paramètres
string | $path | The path to clean.
string | $ds | Directory separator (optional).
Renvoie
string The cleaned path.
Depuis
1.0
Exceptions

Références $path, et Laminas\Diactoros\$stream.

Référencé par Folder\_items(), Folder\copy(), File\copy(), Folder\create(), File\delete(), Folder\delete(), Tar\extract(), Zip\extractCustom(), Folder\files(), Folder\folders(), Tar\isBelow(), Zip\isBelow(), Folder\listFolderTree(), Requests\makeGetRequest(), File\move(), Folder\move(), File\upload(), et File\write().

◆ find()

static find | ( | $paths,
 |  | $file
 | ) |
static

Searches the directory paths for a given file.

Paramètres
mixed | $paths | A path string or array of path strings to search in
string | $file | The file name to look for.
Renvoie
string|boolean The full path and file name for the target file, or boolean false if the file is not found in any of the paths.
Depuis
1.0

Références $path.

◆ getPermissions()

static getPermissions ( $path )
static

Get the permissions of the file/folder at a give path.

Paramètres
string $path The path of a file/folder.
Renvoie
string Filesystem permissions.
Depuis
1.0

Références $i, $mode, et $path.

◆ isOwner()

static isOwner ( $path )
static

Method to determine if script owns the path.

Paramètres
string $path Path to check ownership.
Renvoie
boolean True if the php script owns the path passed.
Depuis
1.0

Références $dir, $path, $return, $tmp, File\delete(), et File\write().

Référencé par SiteStatus\writeConfigFile().

◆ removeRoot()

static removeRoot | ( | $message,
 |  | $rootDirectory = null
 | ) |
static

Remove all references to root directory path and the system tmp path from a message

Paramètres
string | $message | The message to be cleaned
string | $rootDirectory | Optional root directory, defaults to JPATH_ROOT
Renvoie
string
Depuis
2.0.1

Références $dir, $message, et JPATH_ROOT.

Référencé par FilesystemException\__construct(), Patcher\applyHunk(), File\copy(), Folder\delete(), Folder\files(), et Folder\folders().

◆ resolve()

static resolve ( $path )
static

Resolves /./, /../ and multiple / in a string and returns the resulting absolute path, inspired by Flysystem Removes trailing slashes

Paramètres
string $path A path to resolve
Renvoie
string The resolved path
Depuis
1.6.0

Références $parts, et $path.

Référencé par Tar\isBelow(), et Zip\isBelow().

◆ setPermissions()

static setPermissions | ( | $path,
 |  | $filemode = '0644',
 |  | $foldermode = '0755'
 | ) |
static

Chmods files and directories recursively to given permissions.

Paramètres
string | $path | Root path to begin changing mode [without trailing slash].
string | $filemode | Octal representation of the value to change file mode to [null = no change].
string | $foldermode | Octal representation of the value to change folder mode to [null = no change].
Renvoie
boolean True if successful [one fail means the whole operation failed].
Depuis
1.0

Références $path.

Référencé par File\upload(), et SiteStatus\writeConfigFile().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Path.php


Joomla CMS: Référence de la classe Stream

  • Joomla
  • Filesystem
  • Stream
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe Stream

Fonctions membres publiques

__construct ($writeprefix='', $readprefix='', $context=[])
__destruct ()
open ($filename, $mode='r', $useIncludePath=false, $context=null, $usePrefix=false, $relative=false, $detectprocessingmode=false)
close ()
eof ()
filesize ()
gets ($length=0)
read ($length=0)
seek ($offset, $whence=\SEEK_SET)
tell ()
write (&$string, $length=0, $chunk=0)
chmod ($filename='', $mode=0)
get_meta_data ()
_buildContext ()
setContextOptions ($context)
addContextEntry ($wrapper, $name, $value)
deleteContextEntry ($wrapper, $name)
applyContextToStream ()
appendFilter ($filtername, $readWrite=\STREAM_FILTER_READ, $params=[])
prependFilter ($filtername, $readWrite=\STREAM_FILTER_READ, $params=[])
removeFilter (&$resource, $byindex=false)
copy ($src, $dest, $context=null, $usePrefix=true, $relative=false)
move ($src, $dest, $context=null, $usePrefix=true, $relative=false)
delete ($filename, $context=null, $usePrefix=true, $relative=false)
upload ($src, $dest, $context=null, $usePrefix=true, $relative=false)
writeFile ($filename, &$buffer, $appendToFile=false)
_getFilename ($filename, $mode, $usePrefix, $relative)
getFileHandle ()
set ($property, $value=null)
get ($property, $default=null)

Fonctions membres publiques statiques

static getStream ($usePrefix=true, $ua=null, $uamask=false)

Attributs protégés

$filemode = 0644
$dirmode = 0755
$chunksize = 8192
$filename
$writeprefix
$readprefix
$processingmethod = 'f'
$filters = []
$fh
$filesize
$context
$contextOptions
$openmode

Description détaillée

Joomla! Stream Interface

The Joomla! stream interface is designed to handle files as streams where as the legacy JFile static class treated files in a rather atomic manner.

This class adheres to the stream wrapper operations:

https://www.php.net/manual/en/intro.stream.php PHP Stream Manual https://www.php.net/manual/en/wrappers.php Stream Wrappers https://www.php.net/manual/en/filters.php Stream Filters https://www.php.net/manual/en/transports.php Socket Transports (used by some options, particularly HTTP proxy) 1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $writeprefix = '',
 |  | $readprefix = '',
 |  | $context = []
 | ) |

Constructor

Paramètres
string | $writeprefix | Prefix of the stream (optional). Unlike the JPATH_*, this has a final path separator!
string | $readprefix | The read prefix (optional).
array | $context | The context options (optional).
Depuis
1.0

Références Stream\$context, Stream\$readprefix, Stream\$writeprefix, et Stream\_buildContext().

◆ __destruct()

__destruct ( )

Destructor

Depuis
1.0

Références Stream\close().

Documentation des fonctions membres

◆ _buildContext()

_buildContext ( )

Stream contexts Builds the context from the array

Renvoie
void
Depuis
1.0

Références null.

Référencé par Stream\__construct(), Stream\addContextEntry(), Stream\deleteContextEntry(), et Stream\setContextOptions().

◆ _getFilename()

_getFilename | ( | $filename,
 |  | $mode,
 |  | $usePrefix,
 |  | $relative
 | ) |

Determine the appropriate 'filename' of a file

Paramètres
string | $filename | Original filename of the file
string | $mode | Mode string to retrieve the filename
boolean | $usePrefix | Controls the use of a prefix
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
string
Depuis
1.0

Références Stream\$filename, $mode, Stream\$readprefix, Laminas\Diactoros\$stream, Stream\$writeprefix, Helper\getWriteModes(), et JPATH_ROOT.

Référencé par Stream\copy(), Stream\delete(), Stream\move(), et Stream\open().

◆ addContextEntry()

addContextEntry | ( | $wrapper,
 |  | $name,
 |  | $value
 | ) |

Adds a particular options to the context

Paramètres
string | $wrapper | The wrapper to use
string | $name | The option to set
string | $value | The value of the option
Renvoie
void

Stream Context Creation https://www.php.net/manual/en/context.php Context Options for various streams 1.0

Références $name, $value, $wrapper, et Stream\_buildContext().

◆ appendFilter()

appendFilter | ( | $filtername,
 |  | $readWrite = \STREAM_FILTER_READ,
 |  | $params = []
 | ) |

Stream filters Append a filter to the chain

Paramètres
string | $filtername | The key name of the filter.
integer | $readWrite | Optional. Defaults to STREAM_FILTER_READ.
array | $params | An array of params for the stream_filter_append call.
Renvoie
resource|boolean

1.0 FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références $params, et null.

◆ applyContextToStream()

applyContextToStream ( )

Applies the current context to the stream

Use this to change the values of the context after you've opened a stream

Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références null.

◆ chmod()

chmod | ( | $filename = '',
 |  | $mode = 0
 | ) |

Chmod wrapper

Paramètres
string | $filename | File name.
mixed | $mode | Mode to use.
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$filemode, Stream\$filename, $mode, Helper\ftpChmod(), et null.

Référencé par Stream\close(), Stream\copy(), Stream\move(), et Stream\writeFile().

◆ close()

close ( )

Attempt to close a file handle

Will return false if it failed and true on success If the file is not open the system will return true, this function destroys the file handle as well

Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\chmod(), et null.

Référencé par Stream\__destruct(), et Stream\writeFile().

◆ copy()

copy | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Copy a file from src to dest

Paramètres
string | $src | The file path to copy from.
string | $dest | The file path to copy to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$context, Stream\_getFilename(), Stream\chmod(), elseif, et null.

Référencé par Stream\upload().

◆ delete()

delete | ( | $filename,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Delete a file

Paramètres
string | $filename | The file path to delete.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$context, Stream\$filename, Stream\_getFilename(), elseif, et null.

◆ deleteContextEntry()

deleteContextEntry | ( | $wrapper,
 |  | $name
 | ) |

Deletes a particular setting from a context

Paramètres
string | $wrapper | The wrapper to use
string | $name | The option to unset
Renvoie
void

1.0

Références $name, $wrapper, et Stream\_buildContext().

◆ eof()

eof ( )

Work out if we're at the end of the file for a stream

Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références null.

Référencé par Stream\read().

◆ filesize()

filesize ( )

Retrieve the file size of the path

Renvoie
integer|boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$filesize, null, et Helper\remotefsize().

Référencé par Stream\read().

◆ get()

get | ( | $property,
 |  | $default = null
 | ) |

Returns a property of the object or the default value if the property is not set.

Paramètres
string | $property | The name of the property.
mixed | $default | The default value.
Renvoie
mixed The value of the property.
Depuis
1.0

Références $default.

◆ get_meta_data()

get_meta_data ( )

Get the stream metadata

Renvoie
array header/metadata

1.0 FilesystemException

◆ getFileHandle()

getFileHandle ( )

Return the internal file handle

Renvoie
File handler
Depuis
1.0

Références Stream\$fh.

◆ gets()

gets ( $length = 0 )

Get a line from the stream source.

Paramètres
integer $length The number of bytes (optional) to read.
Renvoie
string
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références null.

◆ getStream()

static getStream | ( | $usePrefix = true,
 |  | $ua = null,
 |  | $uamask = false
 | ) |
static

Creates a new stream object with appropriate prefix

Paramètres
boolean | $usePrefix | Prefix the connections for writing
string | $ua | UA User agent to use
boolean | $uamask | User agent masking (prefix Mozilla)
Renvoie
Stream
Voir également
Stream
Depuis
1.0

Références Stream\$context, et JPATH_ROOT.

Référencé par Folder\copy(), File\copy(), Bzip2\extract(), Gzip\extract(), File\move(), Folder\move(), File\upload(), et File\write().

◆ move()

move | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Moves a file

Paramètres
string | $src | The file path to move from.
string | $dest | The file path to move to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$context, Stream\_getFilename(), Stream\chmod(), elseif, et null.

◆ open()

open | ( | $filename,
 |  | $mode = 'r',
 |  | $useIncludePath = false,
 |  | $context = null,
 |  | $usePrefix = false,
 |  | $relative = false,
 |  | $detectprocessingmode = false
 | ) |

Generic File Operations

Open a stream with some lazy loading smarts

Paramètres
string | $filename | Filename
string | $mode | Mode string to use
boolean | $useIncludePath | Use the PHP include path
resource | $context | Context to use when opening
boolean | $usePrefix | Use a prefix to open the file
boolean | $relative | Filename is a relative path (if false, strips JPATH_ROOT to make it relative)
boolean | $detectprocessingmode | Detect the processing method for the file and use the appropriate function to handle output automatically
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$context, Stream\$filename, $mode, $url, __DIR__, Stream\_getFilename(), elseif, Helper\isJoomlaStream(), et null.

Référencé par Stream\writeFile().

◆ prependFilter()

prependFilter | ( | $filtername,
 |  | $readWrite = \STREAM_FILTER_READ,
 |  | $params = []
 | ) |

Prepend a filter to the chain

Paramètres
string | $filtername | The key name of the filter.
integer | $readWrite | Optional. Defaults to STREAM_FILTER_READ.
array | $params | An array of params for the stream_filter_prepend call.
Renvoie
resource|boolean

1.0 FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références $params, et null.

◆ read()

read ( $length = 0 )

Read a file

Handles user space streams appropriately otherwise any read will return 8192

Paramètres
integer $length Length of data to read
Renvoie
string

1.0 FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$filesize, Stream\eof(), Stream\filesize(), et null.

◆ removeFilter()

removeFilter | ( | & | $resource,
 |  |  | $byindex = false
 | ) |  |

Remove a filter, either by resource (handed out from the append or prepend function) or via getting the filter list)

Paramètres
resource | $resource | The resource.
boolean | $byindex | The index of the filter.
Renvoie
boolean Result of operation
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références null.

◆ seek()

seek | ( | $offset,
 |  | $whence = \SEEK_SET
 | ) |

Seek the file

Note: the return value is different to that of fseek

Paramètres
integer | $offset | Offset to use when seeking.
integer | $whence | Seek mode to use.
Renvoie
boolean True on success, false on failure

1.0 FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Joomla\Database\Query\$offset, et null.

◆ set()

set | ( | $property,
 |  | $value = null
 | ) |

Modifies a property of the object, creating it if it does not already exist.

Paramètres
string | $property | The name of the property.
mixed | $value | The value of the property to set.
Renvoie
mixed Previous value of the property.
Depuis
1.0

Références $value, et null.

◆ setContextOptions()

setContextOptions ( $context )

Updates the context to the array

Format is the same as the options for stream_context_create

Paramètres
array $context Options to create the context with
Renvoie
void

1.0

Références Stream\$context, et Stream\_buildContext().

◆ tell()

tell ( )

Returns the current position of the file read/write pointer.

Renvoie
integer
Depuis
1.0
Exceptions
FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références null.

◆ upload()

upload | ( | $src,
 |  | $dest,
 |  | $context = null,
 |  | $usePrefix = true,
 |  | $relative = false
 | ) |

Upload a file

Paramètres
string | $src | The file path to copy from (usually a temp folder).
string | $dest | The file path to copy to.
resource | $context | A valid context resource (optional) created with stream_context_create.
boolean | $usePrefix | Controls the use of a prefix (optional).
boolean | $relative | Determines if the filename given is relative. Relative paths do not have JPATH_ROOT stripped.
Renvoie
boolean
Depuis
1.0
Exceptions
FilesystemException

Références Stream\$context, et Stream\copy().

◆ write()

write | ( | & | $string,
 |  |  | $length = 0,
 |  |  | $chunk = 0
 | ) |  |

File write

Whilst this function accepts a reference, the underlying fwrite will do a copy! This will roughly double the memory allocation for any write you do. Specifying chunked will get around this by only writing in specific chunk sizes. This defaults to 8192 which is a sane number to use most of the time (change the default with Stream::set('chunksize', newsize);) Note: This doesn't support gzip/bzip2 writing like reading does

Paramètres
string | $string | Reference to the string to write.
integer | $length | Length of the string to write.
integer | $chunk | Size of chunks to write in.
Renvoie
boolean

1.0 FilesystemException

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références Stream\$chunksize, $start, et null.

Référencé par Stream\writeFile().

◆ writeFile()

writeFile | ( |  | $filename,
 |  | & | $buffer,
 |  |  | $appendToFile = false
 | ) |  |

Writes a chunk of data to a file.

Paramètres
string | $filename | The file name.
string | $buffer | The data to write to the file.
boolean | $appendToFile | Append to the file and not overwrite it.
Renvoie
boolean
Depuis
1.0

Références $buffer, Stream\$filename, $result, Stream\chmod(), Stream\close(), Stream\open(), et Stream\write().

Documentation des champs

◆ $chunksize

$chunksize = 8192
protected

Référencé par Stream\write().

◆ $context

$context
protected

Référencé par Stream\__construct(), Stream\copy(), Stream\delete(), Stream\getStream(), Stream\move(), Stream\open(), Stream\setContextOptions(), et Stream\upload().

◆ $contextOptions

$contextOptions
protected

◆ $dirmode

$dirmode = 0755
protected

◆ $fh

$fh
protected

Référencé par Stream\getFileHandle().

◆ $filemode

$filemode = 0644
protected

Référencé par Stream\chmod().

◆ $filename

$filename
protected

Référencé par Stream\_getFilename(), Stream\chmod(), Stream\delete(), Stream\open(), et Stream\writeFile().

◆ $filesize

$filesize
protected

Référencé par Stream\filesize(), et Stream\read().

◆ $filters

$filters = []
protected

◆ $openmode

$openmode
protected

◆ $processingmethod

$processingmethod = 'f'
protected

◆ $readprefix

$readprefix
protected

Référencé par Stream\__construct(), et Stream\_getFilename().

◆ $writeprefix

$writeprefix
protected

Référencé par Stream\__construct(), et Stream\_getFilename().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filesystem/src/Stream.php


Joomla CMS: Référence de la classe InputFilter

  • Joomla
  • Filter
  • InputFilter
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe InputFilter
+ Graphe d'héritage de InputFilter:
InputFilter

Fonctions membres publiques

__construct (array $tagsArray=[], array $attrArray=[], $tagsMethod=self::ONLY_ALLOW_DEFINED_TAGS, $attrMethod=self::ONLY_ALLOW_DEFINED_ATTRIBUTES, $xssAuto=1)
clean ($source, $type='string')

Fonctions membres publiques statiques

static checkAttribute ($attrSubSet)

Champs de données

const | ONLY_ALLOW_DEFINED_TAGS = 0
const | ONLY_BLOCK_DEFINED_TAGS = 1
const | ONLY_ALLOW_DEFINED_ATTRIBUTES = 0
const | ONLY_BLOCK_DEFINED_ATTRIBUTES = 1
$tagsArray
$attrArray
$tagsMethod
$attrMethod
$xssAuto
$blockedTags
$blockedAttributes

Fonctions membres protégées

remove ($source)
cleanTags ($source)
cleanAttributes (array $attrSet)
decode ($source)
escapeAttributeValues ($source)
stripCssExpressions ($source)

Fonctions membres privées

cleanInt ($source)
cleanInteger ($source)
cleanUint ($source)
cleanFloat ($source)
cleanDouble ($source)
cleanBool ($source)
cleanBoolean ($source)
cleanWord ($source)
cleanAlnum ($source)
cleanCmd ($source)
cleanBase64 ($source)
cleanString ($source)
cleanHtml ($source)
cleanPath ($source)
cleanTrim ($source)
cleanUsername ($source)

Attributs privés

$blockedChars

Description détaillée

InputFilter is a class for filtering input from any data source

Forked from the php input filter library by: Daniel Morris dan@r.nosp@m.ootc.nosp@m.ube.c.nosp@m.om Original Contributors: Gianpaolo Racca, Ghislain Picard, Marco Wandschneider, Chris Tobin and Andrew Eddie.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $tagsArray = [],
 |  | array | $attrArray = [],
 |  |  | $tagsMethod = self::ONLY_ALLOW_DEFINED_TAGS,
 |  |  | $attrMethod = self::ONLY_ALLOW_DEFINED_ATTRIBUTES,
 |  |  | $xssAuto = 1
 | ) |  |

Constructor for InputFilter class.

Paramètres
array | $tagsArray | List of permitted HTML tags
array | $attrArray | List of permitted HTML tag attributes
integer | $tagsMethod | Method for filtering tags, should be one of the ONLY_*_DEFINED_TAGS constants
integer | $attrMethod | Method for filtering attributes, should be one of the ONLY_*_DEFINED_ATTRIBUTES constants
integer | $xssAuto | Only auto clean essentials = 0, Allow clean blocked tags/attributes = 1
Depuis
1.0

Références InputFilter\$attrArray, InputFilter\$attrMethod, InputFilter\$tagsArray, InputFilter\$tagsMethod, et InputFilter\$xssAuto.

Documentation des fonctions membres

◆ checkAttribute()

static checkAttribute ( $attrSubSet )
static

Function to determine if contents of an attribute are safe

Paramètres
array $attrSubSet A 2 element array for attribute's name, value
Renvoie
boolean True if bad code is detected
Depuis
1.0

Références ENT_QUOTES.

Référencé par ContactTable\check().

◆ clean()

clean | ( | $source,
 |  | $type = 'string'
 | ) |

Cleans the given input source based on the instance configuration and specified data type

Paramètres
string|string[]|object | $source Input string/array-of-string/object to be 'cleaned'
string | $type | The return type for the variable: INT: An integer UINT: An unsigned integer FLOAT: A floating point number BOOLEAN: A boolean value WORD: A string containing A-Z or underscores only (not case sensitive) ALNUM: A string containing A-Z or 0-9 only (not case sensitive) CMD: A string containing A-Z, 0-9, underscores, periods or hyphens (not case sensitive) BASE64: A string containing A-Z, 0-9, forward slashes, plus or equals (not case sensitive) STRING: A fully decoded and sanitised string (default) HTML: A sanitised string ARRAY: An array PATH: A sanitised file path TRIM: A string trimmed from normal, non-breaking and multibyte spaces USERNAME: Do not use (use an application specific filter) RAW: The raw string is returned with no filtering unknown: An unknown filter will act like STRING. If the input is an array it will return an array of fully decoded and sanitised strings.
Renvoie
mixed 'Cleaned' version of the $source parameter
Depuis
1.0

Références $key, $method, $result, $this, $type, $value, et InputFilter\cleanString().

◆ cleanAlnum()

cleanAlnum ( $source )
private

Alphanumerical filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ cleanAttributes()

cleanAttributes ( array $attrSet )
protected

Internal method to strip a tag of disallowed attributes

Paramètres
array $attrSet Array of attribute pairs to filter
Renvoie
array Filtered array of attribute pairs
Depuis
1.0

Références $count, $i, elseif, et ENT_QUOTES.

Référencé par InputFilter\cleanTags().

◆ cleanBase64()

cleanBase64 ( $source )
private

Base64 filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ cleanBool()

cleanBool ( $source )
private

Boolean filter

Paramètres
string $source The string to be filtered
Renvoie
boolean The filtered value

Référencé par InputFilter\cleanBoolean().

◆ cleanBoolean()

cleanBoolean ( $source )
private

Alias for cleanBool()

Paramètres
string $source The string to be filtered
Renvoie
boolean The filtered value

Références InputFilter\cleanBool().

◆ cleanCmd()

cleanCmd ( $source )
private

Command filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

Références $result.

◆ cleanDouble()

cleanDouble ( $source )
private

Alias for cleanFloat()

Paramètres
string $source The string to be filtered
Renvoie
float The filtered value

Références InputFilter\cleanFloat().

◆ cleanFloat()

cleanFloat ( $source )
private

Float filter

Paramètres
string $source The string to be filtered
Renvoie
float The filtered value

Référencé par InputFilter\cleanDouble().

◆ cleanHtml()

cleanHtml ( $source )
private

HTML filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ cleanInt()

cleanInt ( $source )
private

Integer filter

Paramètres
string $source The string to be filtered
Renvoie
integer The filtered value

Référencé par InputFilter\cleanInteger().

◆ cleanInteger()

cleanInteger ( $source )
private

Alias for cleanInt()

Paramètres
string $source The string to be filtered
Renvoie
integer The filtered value

Références InputFilter\cleanInt().

◆ cleanPath()

cleanPath ( $source )
private

Path filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ cleanString()

cleanString ( $source )
private

String filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

Références InputFilter\decode().

Référencé par InputFilter\clean().

◆ cleanTags()

cleanTags ( $source )
protected

Internal method to strip a string of disallowed tags

Paramètres
string $source Input string to be 'cleaned'
Renvoie
string 'Cleaned' version of input parameter
Depuis
1.0

Références $attr, $count, $i, $tagName, InputFilter\cleanAttributes(), InputFilter\escapeAttributeValues(), null, StringHelper\strlen(), StringHelper\strpos(), et StringHelper\substr().

Référencé par InputFilter\remove().

◆ cleanTrim()

cleanTrim ( $source )
private

Trim filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

Références $result, et StringHelper\trim().

◆ cleanUint()

cleanUint ( $source )
private

Unsigned integer filter

Paramètres
string $source The string to be filtered
Renvoie
integer The filtered value

◆ cleanUsername()

cleanUsername ( $source )
private

Username filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ cleanWord()

cleanWord ( $source )
private

Word filter

Paramètres
string $source The string to be filtered
Renvoie
string The filtered string

◆ decode()

decode ( $source )
protected

Try to convert to plaintext

Paramètres
string $source The source string.
Renvoie
string Plaintext string
Depuis
1.0
Obsolète:
This method will be removed once support for PHP 5.3 is discontinued.

Références ENT_QUOTES.

Référencé par InputFilter\cleanString().

◆ escapeAttributeValues()

escapeAttributeValues ( $source )
protected

Escape < > and " inside attribute values

Paramètres
string $source The source string.
Renvoie
string Filtered string
Depuis
1.0

Références InputFilter\stripCssExpressions(), StringHelper\strlen(), et StringHelper\substr().

Référencé par InputFilter\cleanTags().

◆ remove()

remove ( $source )
protected

Internal method to iteratively remove all unwanted tags and attributes

Paramètres
string $source Input string to be 'cleaned'
Renvoie
string 'Cleaned' version of input parameter
Depuis
1.0

Références $temp, et InputFilter\cleanTags().

◆ stripCssExpressions()

stripCssExpressions ( $source )
protected

Remove CSS Expressions in the form of <property>:expression(...)

Paramètres
string $source The source string.
Renvoie
string Filtered string
Depuis
1.0

Référencé par InputFilter\escapeAttributeValues().

Documentation des champs

◆ $attrArray

$attrArray

Référencé par InputFilter\__construct().

◆ $attrMethod

$attrMethod

Référencé par InputFilter\__construct().

◆ $blockedAttributes

$blockedAttributes
Valeur initiale :
= [
'action',
'background',
'codebase',
'dynsrc',
'formaction',
'lowsrc',
]

◆ $blockedChars

$blockedChars
private
Valeur initiale :
= [
'&tab;',
'&space;',
'&colon;',
'&column;',
]

◆ $blockedTags

$blockedTags
Valeur initiale :
= [
'applet',
'body',
'bgsound',
'base',
'basefont',
'canvas',
'embed',
'frame',
'frameset',
'head',
'html',
'id',
'iframe',
'ilayer',
'layer',
'link',
'meta',
'name',
'object',
'script',
'style',
'title',
'xml',
]

◆ $tagsArray

$tagsArray

Référencé par InputFilter\__construct().

◆ $tagsMethod

$tagsMethod

Référencé par InputFilter\__construct().

◆ $xssAuto

$xssAuto

Référencé par InputFilter\__construct().

◆ ONLY_ALLOW_DEFINED_ATTRIBUTES

const ONLY_ALLOW_DEFINED_ATTRIBUTES = 0

◆ ONLY_ALLOW_DEFINED_TAGS

const ONLY_ALLOW_DEFINED_TAGS = 0

◆ ONLY_BLOCK_DEFINED_ATTRIBUTES

const ONLY_BLOCK_DEFINED_ATTRIBUTES = 1

Référencé par TemplateController\createFile(), CMSApplication\enqueueMessage(), SafehtmlFilter\filter(), LanguagesHelper\filterKey(), LanguagesHelper\filterText(), ComponentHelper\filterText(), TemplateController\overrides(), et TemplateController\uploadFile().

◆ ONLY_BLOCK_DEFINED_TAGS

const ONLY_BLOCK_DEFINED_TAGS = 1

Référencé par TemplateController\createFile(), CMSApplication\enqueueMessage(), SafehtmlFilter\filter(), LanguagesHelper\filterKey(), LanguagesHelper\filterText(), ComponentHelper\filterText(), TemplateController\overrides(), et TemplateController\uploadFile().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filter/src/InputFilter.php


Joomla CMS: Référence de la classe OutputFilter

  • Joomla
  • Filter
  • OutputFilter
Fonctions membres publiques statiques | Attributs privés statiques
Référence de la classe OutputFilter
+ Graphe d'héritage de OutputFilter:
OutputFilter

Fonctions membres publiques statiques

static | objectHtmlSafe (&$mixed, $quoteStyle=\ENT_QUOTES, $excludeKeys='')
static | linkXhtmlSafe ($input)
static | stringUrlSafe ($string, $language='')
static | stringUrlUnicodeSlug ($string)
static | ampReplace ($text)
static | cleanText (&$text)
static | setLanguage (Language $language)
static | stripImages ($string)
static | stripIframes ($string)

Attributs privés statiques

static $language

Description détaillée

OutputFilter is a class for processing an output string for "safe" display

Depuis
1.0

Documentation des fonctions membres

◆ ampReplace()

static ampReplace ( $text )
static

Makes a string safe for XHTML output by escaping ampersands.

Paramètres
string $text Text to process
Renvoie
string Processed string.
Depuis
1.0

Références $text.

Référencé par ApplicationModel\save().

◆ cleanText()

static cleanText ( & $text )
static

Cleans text of all formatting and scripting code.

Paramètres
string $text Text to clean
Renvoie
string Cleaned text.
Depuis
1.0

Références $text, et ENT_COMPAT.

◆ linkXhtmlSafe()

static linkXhtmlSafe ( $input )
static

Makes a string safe for XHTML output by escaping ampersands in links.

Paramètres
string $input String to process
Renvoie
string Processed string
Depuis
1.0

Références $input.

◆ objectHtmlSafe()

static objectHtmlSafe | ( | & | $mixed,
 |  |  | $quoteStyle = \ENT_QUOTES,
 |  |  | $excludeKeys = ''
 | ) |  |
static

Makes an object safe to display in forms.

Object parameters that are non-string, array, object or start with underscore will be converted

Paramètres
object | $mixed | An object to be parsed
integer | $quoteStyle | The optional quote style for the htmlspecialchars function
mixed | $excludeKeys | An optional string single field name or array of field names not to be parsed (eg, for a textarea)
Renvoie
void
Depuis
1.0

Références null.

◆ setLanguage()

static setLanguage ( Language $language )
static

Set a Language instance for use

Paramètres
Language $language The Language instance to use.
Renvoie
void
Depuis
2.0.0

Références $language, et OutputFilter\$language.

◆ stringUrlSafe()

static stringUrlSafe | ( | $string,
 |  | $language = ''
 | ) |
static

Generates a URL safe version of the specified string with language transliteration.

This method processes a string and replaces all accented UTF-8 characters by unaccented ASCII-7 "equivalents"; whitespaces are replaced by hyphens and the string is lowercased.

Paramètres
string | $string | String to process
string | $language | Language to transliterate to
Renvoie
string Processed string
Depuis
1.0

Références $language, OutputFilter\$language, et StringHelper\strtolower().

◆ stringUrlUnicodeSlug()

static stringUrlUnicodeSlug ( $string )
static

Generates a URL safe version of the specified string with unicode character replacement.

Paramètres
string $string String to process
Renvoie
string Processed string
Depuis
1.0

Références StringHelper\strtolower().

Référencé par ApplicationHelper\stringURLSafe().

◆ stripIframes()

static stripIframes ( $string )
static

Strips <iframe> tags from a string.

Paramètres
string $string Sting to be cleaned.
Renvoie
string Cleaned string
Depuis
1.0

◆ stripImages()

static stripImages ( $string )
static

Strips <img> tags from a string.

Paramètres
string $string Sting to be cleaned.
Renvoie
string Cleaned string
Depuis
1.0

Documentation des champs

◆ $language

$language
staticprivate

Référencé par OutputFilter\setLanguage(), et OutputFilter\stringUrlSafe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/filter/src/OutputFilter.php


Joomla CMS: Référence de la classe InvalidResponseCodeException

  • Joomla
  • Http
  • Exception
  • InvalidResponseCodeException
Référence de la classe InvalidResponseCodeException
+ Graphe d'héritage de InvalidResponseCodeException:
ClientExceptionInterface

Description détaillée

Exception representing an invalid or undefined HTTP response code

Depuis
1.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidResponseCodeException.php


Joomla CMS: Référence de la classe UnexpectedResponseException

  • Joomla
  • Http
  • Exception
  • UnexpectedResponseException
Fonctions membres publiques | Attributs privés
Référence de la classe UnexpectedResponseException
+ Graphe d'héritage de UnexpectedResponseException:
ClientExceptionInterface

Fonctions membres publiques

__construct (Response $response, $message='', $code=0, \Exception $previous=null)
getResponse ()

Attributs privés

$response

Description détaillée

Exception representing an unexpected response

Depuis
1.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Response | $response,
 |  |  | $message = '',
 |  |  | $code = 0,
 |  | \Exception | $previous = null
 | ) |  |

Constructor

Paramètres
Response | $response | The Response object.
string | $message | The Exception message to throw.
integer | $code | The Exception code.
\Exception | $previous | The previous exception used for the exception chaining.
Depuis
1.2.0

Références $message, UnexpectedResponseException\$response, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getResponse()

getResponse ( )

Get the Response object.

Renvoie
Response
Depuis
1.2.0

Références UnexpectedResponseException\$response.

Documentation des champs

◆ $response

$response
private

Référencé par UnexpectedResponseException\__construct(), et UnexpectedResponseException\getResponse().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnexpectedResponseException.php


Joomla CMS: Référence de la classe Curl

  • Joomla
  • Http
  • Transport
  • Curl
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe Curl
+ Graphe d'héritage de Curl:
AbstractTransport TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

setCAOptionAndValue ($ch)
getResponse ($content, $info)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Fonctions membres privées

mapProtocolVersion (string $version)
redirectsAllowed ()

Membres hérités additionnels

- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using cURL.

Depuis
1.0

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | $content,
 |  | $info
 | ) |
protected

Method to get a response object from a server response.

Paramètres
string | $content | The complete server response, including headers as a string if the response has no errors.
array | $info | The cURL request information.
Renvoie
Response
Depuis
1.0
Exceptions
InvalidResponseCodeException

Références $content, $info, Symfony\Component\Console\Tester\$statusCode, null, et AbstractTransport\processHeaders().

Référencé par Curl\request().

◆ isSupported()

static isSupported ( )
static

Method to check if HTTP transport cURL is available for use

Renvoie
boolean True if available, else false
Depuis
1.0

Implémente TransportInterface.

◆ mapProtocolVersion()

mapProtocolVersion ( string $version )
private

Get the cURL constant for a HTTP protocol version

Paramètres
string $version The HTTP protocol version to use
Renvoie
integer
Depuis
1.3.1

Références $version.

Référencé par Curl\request().

◆ redirectsAllowed()

redirectsAllowed ( )
private

Check if redirects are allowed

Renvoie
boolean
Depuis
1.2.1

Référencé par Curl\request().

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.0
Exceptions

Implémente TransportInterface.

Références $content, $data, $header, $info, $key, $message, $method, AbstractTransport\$options, $uri, $value, AbstractTransport\getOption(), Curl\getResponse(), CaBundle\getSystemCaRootBundlePath(), Curl\mapProtocolVersion(), Curl\redirectsAllowed(), et Curl\setCAOptionAndValue().

◆ setCAOptionAndValue()

setCAOptionAndValue ( $ch )
protected

Configure the cURL resources with the appropriate root certificates.

Paramètres
resource $ch The cURL resource you want to configure the certificates on.
Renvoie
void
Depuis
1.3.2

Références AbstractTransport\getOption(), et CaBundle\getSystemCaRootBundlePath().

Référencé par Curl\request().

La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/http/src/Transport/Curl.php


Joomla CMS: Référence de la classe Socket

  • Joomla
  • Http
  • Transport
  • Socket
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Socket
+ Graphe d'héritage de Socket:
AbstractTransport TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getResponse ($content)
connect (UriInterface $uri, $timeout=null)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Attributs protégés

$connections
- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using sockets directly.

Depuis
1.0

Documentation des fonctions membres

◆ connect()

connect | ( | UriInterface | $uri,
 |  |  | $timeout = null
 | ) |  |
protected

Method to connect to a server and get the resource.

Paramètres
UriInterface | $uri | The URI to connect with.
integer | $timeout | Read timeout in seconds.
Renvoie
resource Socket connection resource.
Depuis
1.0
Exceptions

Références $key, $uri, elseif, et null.

Référencé par Socket\request().

◆ getResponse()

getResponse ( $content )
protected

Method to get a response object from a server response.

Paramètres
string $content The complete server response, including headers.
Renvoie
Response
Depuis
1.0
Exceptions

Références $content, Symfony\Component\Console\Tester\$statusCode, et AbstractTransport\processHeaders().

Référencé par Socket\request().

◆ isSupported()

static isSupported ( )
static

Method to check if http transport socket available for use

Renvoie
boolean True if available else false
Depuis
1.0

Implémente TransportInterface.

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.0
Exceptions

Implémente TransportInterface.

Références $content, $data, $header, $key, $method, $path, $uri, $value, Socket\connect(), AbstractTransport\getOption(), Socket\getResponse(), et null.

Documentation des champs

◆ $connections

$connections
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/http/src/Transport/Socket.php


Joomla CMS: Référence de la classe Stream

  • Joomla
  • Http
  • Transport
  • Stream
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées
Référence de la classe Stream
+ Graphe d'héritage de Stream:
AbstractTransport TransportInterface

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)
- Fonctions membres publiques hérités de AbstractTransport
__construct ($options=[])

Fonctions membres publiques statiques

static isSupported ()

Fonctions membres protégées

getResponse (array $headers, $body)
- Fonctions membres protégées hérités de AbstractTransport
getOption (string $key, $default=null)
processHeaders (array $headers)

Membres hérités additionnels

- Attributs protégés hérités de AbstractTransport
$options

Description détaillée

HTTP transport class for using PHP streams.

Depuis
1.0

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | array | $headers,
 |  |  | $body
 | ) |  |
protected

Method to get a response object from a server response.

Paramètres
array | $headers | The response headers as an array.
string | $body | The response body as a string.
Renvoie
Response
Depuis
1.0
Exceptions
InvalidResponseCodeException

Références Symfony\Component\Console\Tester\$statusCode, et AbstractTransport\processHeaders().

Référencé par Stream\request().

◆ isSupported()

static isSupported ( )
static

Method to check if http transport stream available for use

Renvoie
boolean True if available else false
Depuis
1.0

Implémente TransportInterface.

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.0
Exceptions

Implémente TransportInterface.

Références $content, $context, $data, $header, $key, $method, AbstractTransport\$options, Laminas\Diactoros\$stream, $uri, $value, elseif, AbstractTransport\getOption(), Stream\getResponse(), et CaBundle\getSystemCaRootBundlePath().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/http/src/Transport/Stream.php


Joomla CMS: Référence de la classe AbstractTransport

  • Joomla
  • Http
  • AbstractTransport
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractTransport
+ Graphe d'héritage de AbstractTransport:
TransportInterface CurlTransport SocketTransport StreamTransport Curl Socket Stream

Fonctions membres publiques

__construct ($options=[])
- Fonctions membres publiques hérités de TransportInterface
request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)

Fonctions membres protégées

getOption (string $key, $default=null)
processHeaders (array $headers)

Attributs protégés

$options

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de TransportInterface
static isSupported ()

Description détaillée

Abstract transport class.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options = [] )

Constructor.

Paramètres
array | \ArrayAccess $options Client options array.
Depuis
2.0.0
Exceptions

Références AbstractTransport\$options, et $this.

Documentation des fonctions membres

◆ getOption()

getOption | ( | string | $key,
 |  |  | $default = null
 | ) |  |
protected

Get an option from the HTTP transport.

Paramètres
string | $key | The name of the option to get.
mixed | $default | The default value if the option is not set.
Renvoie
mixed The option value.
Depuis
2.0.0

Références $default, et $key.

Référencé par Curl\request(), Stream\request(), Socket\request(), et Curl\setCAOptionAndValue().

◆ processHeaders()

processHeaders ( array $headers )
protected

Processes the headers from a transport's response data.

Paramètres
array $headers The headers to process.
Renvoie
array
Depuis
2.0.0

Références $header.

Référencé par Socket\getResponse(), Stream\getResponse(), et Curl\getResponse().

Documentation des champs

◆ $options

$options
protected

Référencé par AbstractTransport\__construct(), Curl\request(), et Stream\request().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractTransport.php


Joomla CMS: Référence de la classe Http

  • Joomla
  • Http
  • Http
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Http
+ Graphe d'héritage de Http:
ClientInterface Http

Fonctions membres publiques

__construct ($options=[], TransportInterface $transport=null)
getOption ($key, $default=null)
setOption ($key, $value)
options ($url, array $headers=[], $timeout=null)
head ($url, array $headers=[], $timeout=null)
get ($url, array $headers=[], $timeout=null)
post ($url, $data, array $headers=[], $timeout=null)
put ($url, $data, array $headers=[], $timeout=null)
delete ($url, array $headers=[], $timeout=null, $data=null)
trace ($url, array $headers=[], $timeout=null)
patch ($url, $data, array $headers=[], $timeout=null)
sendRequest (RequestInterface $request)

Fonctions membres protégées

makeTransportRequest ($method, $url, $data=null, array $headers=[], $timeout=null)

Attributs protégés

$options
$transport

Description détaillée

HTTP client class.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $options = [],
 |  | TransportInterface | $transport = null
 | ) |  |

Constructor.

Paramètres
array | \ArrayAccess | $options | Client options array. If the registry contains any headers.* elements, these will be added to the request headers.
TransportInterface | $transport | The HTTP transport object.
Depuis
1.0
Exceptions

Références Http\$options, Http\$transport, class, et Http\options().

Documentation des fonctions membres

◆ delete()

delete | ( |  | $url,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $data = null
 | ) |  |

Method to send the DELETE command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
mixed | $data | Either an associative array or a string to be sent with the request.
Renvoie
Response
Depuis
1.0

Références $url, et Http\makeTransportRequest().

◆ get()

get | ( |  | $url,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the GET command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $url, Http\makeTransportRequest(), et null.

◆ getOption()

getOption | ( | $key,
 |  | $default = null
 | ) |

Get an option from the HTTP client.

Paramètres
string | $key | The name of the option to get.
mixed | $default | The default value if the option is not set.
Renvoie
mixed The option value.
Depuis
1.0

Références $default, $key, et Http\options().

◆ head()

head | ( |  | $url,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the HEAD command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $url, Http\makeTransportRequest(), et null.

◆ makeTransportRequest()

makeTransportRequest | ( |  | $method,
 |  |  | $url,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |
protected

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
string | UriInterface | $url | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0
Exceptions

Références $data, $key, $method, $temp, $url, $val, class, elseif, null, et Http\options().

Référencé par Http\delete(), Http\get(), Http\head(), Http\options(), Http\patch(), Http\post(), Http\put(), Http\sendRequest(), et Http\trace().

◆ options()

options | ( |  | $url,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the OPTIONS command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $url, Http\makeTransportRequest(), et null.

Référencé par Http\__construct(), Http\getOption(), Http\makeTransportRequest(), et Http\setOption().

◆ patch()

patch | ( |  | $url,
 |  |  | $data,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the PATCH command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $url, et Http\makeTransportRequest().

◆ post()

post | ( |  | $url,
 |  |  | $data,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the POST command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $data, $url, et Http\makeTransportRequest().

◆ put()

put | ( |  | $url,
 |  |  | $data,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the PUT command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $data, $url, et Http\makeTransportRequest().

◆ sendRequest()

sendRequest ( RequestInterface $request )

Sends a PSR-7 request and returns a PSR-7 response.

Paramètres
RequestInterface $request The PSR-7 request object.
Renvoie
ResponseInterface|Response
Depuis
2.0.0

Implémente ClientInterface.

Références $data, MessageInterface\getBody(), MessageInterface\getHeaders(), RequestInterface\getMethod(), RequestInterface\getUri(), Http\makeTransportRequest(), et null.

◆ setOption()

setOption | ( | $key,
 |  | $value
 | ) |

Set an option for the HTTP client.

Paramètres
string | $key | The name of the option to set.
mixed | $value | The option value to set.
Renvoie
$this
Depuis
1.0

Références $key, $this, $value, et Http\options().

◆ trace()

trace | ( |  | $url,
 |  | array | $headers = [],
 |  |  | $timeout = null
 | ) |  |

Method to send the TRACE command to the server.

Paramètres
string | UriInterface | $url | The URI to the resource to request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
Renvoie
Response
Depuis
1.0

Références $url, Http\makeTransportRequest(), et null.

Documentation des champs

◆ $options

$options
protected

Référencé par Http\__construct().

◆ $transport

$transport
protected

Référencé par Http\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/http/src/Http.php


Joomla CMS: Référence de la classe HttpFactory

  • Joomla
  • Http
  • HttpFactory
Fonctions membres publiques
Référence de la classe HttpFactory

Fonctions membres publiques

getHttp ($options=[], $adapters=null)
getAvailableDriver ($options=[], $default=null)

Description détaillée

HTTP factory class.

Depuis
1.0

Documentation des fonctions membres

◆ getAvailableDriver()

static getAvailableDriver | ( | $options = [],
 |  | $default = null
 | ) |

Finds an available TransportInterface object for communication

Paramètres
array | \ArrayAccess | $options | Options for creating TransportInterface object
array | string | $default | Adapter (string) or queue of adapters (array) to use
Renvoie
TransportInterface|boolean Interface sub-class or boolean false if no adapters are available
Depuis
1.0
Exceptions

Références $class, $default, $options, et null.

Référencé par HttpFactory\getHttp().

◆ getHttp()

getHttp | ( | $options = [],
 |  | $adapters = null
 | ) |

Method to create an Http instance.

Paramètres
array | \ArrayAccess | $options | Client options array.
array | string | $adapters | Adapter (string) or queue of adapters (array) to use for communication.
Renvoie
Http
Depuis
1.0
Exceptions

Références $options, et HttpFactory\getAvailableDriver().

Référencé par Client\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/http/src/HttpFactory.php


Joomla CMS: Référence de la classe Response

  • Joomla
  • Http
  • Response
Fonctions membres publiques
Référence de la classe Response
+ Graphe d'héritage de Response:
Response ResponseInterface MessageInterface Response

Fonctions membres publiques

__get ($name)
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Documentation des fonctions membres

◆ __get()

__get ( $name )

Magic getter for backward compatibility with the 1.x API

Paramètres
string $name The variable to return
Renvoie
mixed
Depuis
2.0.0
Obsolète:
3.0 Access data via the PSR-7 ResponseInterface instead

Références $name, MessageInterface\getBody(), MessageInterface\getHeaders(), et Response\getStatusCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/http/src/Response.php


Joomla CMS: Référence de l'interface TransportInterface

  • Joomla
  • Http
  • TransportInterface
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de l'interface TransportInterface
+ Graphe d'héritage de TransportInterface:
TransportInterface AbstractTransport CurlTransport SocketTransport StreamTransport CurlTransport SocketTransport StreamTransport Curl Socket Stream

Fonctions membres publiques

request ($method, UriInterface $uri, $data=null, array $headers=[], $timeout=null, $userAgent=null)

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

HTTP transport class interface.

Depuis
1.0

Documentation des fonctions membres

◆ isSupported()

static isSupported ( )
static

Method to check if HTTP transport layer available for using

Renvoie
boolean True if available else false
Depuis
1.0

Implémenté dans Socket, Curl, CurlTransport, SocketTransport, Stream, et StreamTransport.

◆ request()

request | ( |  | $method,
 |  | UriInterface | $uri,
 |  |  | $data = null,
 |  | array | $headers = [],
 |  |  | $timeout = null,
 |  |  | $userAgent = null
 | ) |  |

Send a request to the server and return a Response object with the response.

Paramètres
string | $method | The HTTP method for sending the request.
UriInterface | $uri | The URI to the resource to request.
mixed | $data | Either an associative array or a string to be sent with the request.
array | $headers | An array of request headers to send with the request.
integer | $timeout | Read timeout in seconds.
string | $userAgent | The optional user agent string to send with the request.
Renvoie
Response
Depuis
1.0

Implémenté dans SocketTransport, CurlTransport, StreamTransport, Socket, Stream, et Curl.

La documentation de cette interface a été générée à partir du fichier suivant :
  • vendor/joomla/http/src/TransportInterface.php


Joomla CMS: Référence de la classe Cookie

  • Joomla
  • Input
  • Cookie
Fonctions membres publiques
Référence de la classe Cookie
+ Graphe d'héritage de Cookie:
Input

Fonctions membres publiques

__construct ($source=null, array $options=[])
set ($name, $value, $options=[])
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Membres hérités additionnels

- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input Cookie Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $source = null,
 |  | array | $options = []
 | ) |  |

Constructor.

Paramètres
array | null | $source | Source data (Optional, default is $_COOKIE)
array | $options | Array of configuration parameters (Optional)
Depuis
1.0

Références Input\$options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ set()

set | ( | $name,
 |  | $value,
 |  | $options = []
 | ) |

Sets a value

Paramètres
string | $name | Name of the value to set.
mixed | $value | Value to assign to the input.
array | $options | An associative array which may have any of the keys expires, path, domain, secure, httponly and samesite. The values have the same meaning as described for the parameters with the same name. The value of the samesite element should be either Lax or Strict. If any of the allowed options are not given, their default values are the same as the default values of the explicit parameters. If the samesite element is omitted, no SameSite cookie attribute is set.
Renvoie
void

https://php.net/manual/en/function.setcookie.php 1.0 As of 1.4.0, the (name, value, expire, path, domain, secure, httpOnly) signature is deprecated and will not be supported when support for PHP 7.2 and earlier is dropped

Références $name, Input\$options, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/input/src/Cookie.php


Joomla CMS: Référence de la classe Files

  • Joomla
  • Input
  • Files
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Files
+ Graphe d'héritage de Files:
Input

Fonctions membres publiques

__construct ($source=null, array $options=[])
get ($name, $default=null, $filter='cmd')
set ($name, $value)
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Fonctions membres protégées

decodeData (array $data)

Attributs protégés

$decodedData = []
- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input Files Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $source = null,
 |  | array | $options = []
 | ) |  |

The class constructor.

Paramètres
array | null | $source | Source data (Optional, default is $_FILES)
array | $options | Array of configuration parameters (Optional)
Depuis
1.0

Références Input\$options, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decodeData()

decodeData ( array $data )
protected

Method to decode a data array.

Paramètres
array $data The data array to decode.
Renvoie
array
Depuis
1.0

Références Input\$data, et $result.

Référencé par Files\get().

◆ get()

get | ( | $name,
 |  | $default = null,
 |  | $filter = 'cmd'
 | ) |

Gets a value from the input data.

Paramètres
string | $name | The name of the input property (usually the name of the files INPUT tag) to get.
mixed | $default | The default value to return if the named property does not exist.
string | $filter | The filter to apply to the value.
Renvoie
mixed The filtered input value.
Voir également
::clean()
Depuis
1.0

Références $default, $name, $results, et Files\decodeData().

◆ set()

set | ( | $name,
 |  | $value
 | ) |

Sets a value.

Paramètres
string | $name | The name of the input property to set.
mixed | $value | The value to assign to the input property.
Renvoie
void
Depuis
1.0

Documentation des champs

◆ $decodedData

$decodedData = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/input/src/Files.php


Joomla CMS: Référence de la classe Input

  • Joomla
  • Input
  • Input
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe Input
+ Graphe d'héritage de Input:
Input Cookie Files Json Cli Cookie Files Json

Fonctions membres publiques

__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Attributs protégés

$options = []
$filter
$data = []
$inputs = []

Attributs privés

const ALLOWED_GLOBALS = ['REQUEST', 'GET', 'POST', 'FILES', 'SERVER', 'ENV']

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $source = null,
 |  | array | $options = []
 | ) |  |

Constructor.

Paramètres
array | null | $source | Optional source data. If omitted, a copy of the server variable '_REQUEST' is used.
array | $options | An optional associative array of configuration parameters: filter: An instance of Filter. If omitted, a default filter is initialised.
Depuis
1.0

Références Input\$options.

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $arguments
 | ) |

Magic method to get filtered input data.

Paramètres
string | $name | Name of the filter type prefixed with 'get'.
array | $arguments | [0] The name of the variable [1] The default value.
Renvoie
mixed The filtered input value.
Depuis
1.0

Références $default, Input\$filter, $name, et null.

◆ __get()

__get ( $name )

Magic method to get an input object

Paramètres
mixed $name Name of the input object to retrieve.
Renvoie
Input The request input object
Depuis
1.0

Références $className, $name, Input\$options, et null.

◆ count()

count ( )

Get the number of variables.

Renvoie
integer The number of variables in the input.
Depuis
1.0
Voir également
Countable::count()

◆ def()

def | ( | $name,
 |  | $value
 | ) |

Define a value. The value will only be set if there's no value for the name or if it is null.

Paramètres
string | $name | Name of the value to define.
mixed | $value | Value to assign to the input.
Renvoie
void
Depuis
1.0

Références $name, et $value.

◆ exists()

exists ( $name )

Check if a value name exists.

Paramètres
string $name Value name
Renvoie
boolean
Depuis
1.2.0

Références $name.

Référencé par Input\get().

◆ get()

get | ( | $name,
 |  | $default = null,
 |  | $filter = 'cmd'
 | ) |

Gets a value from the input data.

Paramètres
string | $name | Name of the value to get.
mixed | $default | Default value to return if variable does not exist.
string | $filter | Filter to apply to the value.
Renvoie
mixed The filtered input value.
Voir également
::clean()
Depuis
1.0

Références $default, Input\$filter, $name, et Input\exists().

◆ getArray()

getArray | ( | array | $vars = [],
 |  |  | $datasource = null
 | ) |  |

Gets an array of values from the request.

Paramètres
array | $vars | Associative array of keys and filter types to apply. If empty and datasource is null, all the input data will be returned but filtered using the default case in InputFilter::clean.
mixed | $datasource | Array to retrieve data from, or null
Renvoie
mixed The filtered input data.
Depuis
1.0

Références Input\$data, $results, elseif, et null.

◆ getInputForRequestMethod()

getInputForRequestMethod ( )

Get the Input instance holding the data for the current request method

Renvoie
Input
Depuis
1.3.0

Références $this, et Input\getMethod().

◆ getMethod()

getMethod ( )

Gets the request method.

Renvoie
string The request method.
Depuis
1.0

Référencé par Input\getInputForRequestMethod().

◆ set()

set | ( | $name,
 |  | $value
 | ) |

Sets a value

Paramètres
string | $name | Name of the value to set.
mixed | $value | Value to assign to the input.
Renvoie
void
Depuis
1.0

Références $name, et $value.

Documentation des champs

◆ $data

$data = []
protected

Référencé par Files\decodeData(), et Input\getArray().

◆ $filter

$filter
protected

Référencé par Input\__call(), et Input\get().

◆ $inputs

$inputs = []
protected

◆ $options

$options = []
protected

Référencé par Cookie\__construct(), Files\__construct(), Json\__construct(), Input\__construct(), Input\__get(), et Cookie\set().

◆ ALLOWED_GLOBALS

const ALLOWED_GLOBALS = ['REQUEST', 'GET', 'POST', 'FILES', 'SERVER', 'ENV']
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/input/src/Input.php


Joomla CMS: Référence de la classe Json

  • Joomla
  • Input
  • Json
Fonctions membres publiques | Attributs privés
Référence de la classe Json
+ Graphe d'héritage de Json:
Input

Fonctions membres publiques

__construct ($source=null, array $options=[])
getRaw ()
- Fonctions membres publiques hérités de Input
__construct ($source=null, array $options=[])
__get ($name)
count ()
get ($name, $default=null, $filter='cmd')
getArray (array $vars=[], $datasource=null)
getInputForRequestMethod ()
set ($name, $value)
def ($name, $value)
exists ($name)
__call ($name, $arguments)
getMethod ()

Attributs privés

$raw

Membres hérités additionnels

- Attributs protégés hérités de Input
$options = []
$filter
$data = []
$inputs = []

Description détaillée

Joomla! Input JSON Class

This class decodes a JSON string from the raw request data and makes it available via the standard Input interface.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $source = null,
 |  | array | $options = []
 | ) |  |

Constructor.

Paramètres
array | null | $source | Source data (Optional, default is the raw HTTP input decoded from JSON)
array | $options | Array of configuration parameters (Optional)
Depuis
1.0

Références Input\$options, Symfony\Contracts\Service\__construct(), et null.

Documentation des fonctions membres

◆ getRaw()

getRaw ( )

Gets the raw JSON string from the request.

Renvoie
string The raw JSON string from the request.
Depuis
1.0

Références Json\$raw.

Documentation des champs

◆ $raw

$raw
private

Référencé par Json\getRaw().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/input/src/Json.php


Joomla CMS: Référence de la classe LdapClient

  • Joomla
  • Ldap
  • LdapClient
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe LdapClient

Fonctions membres publiques

__construct ($configObj=null)
__destruct ()
connect ()
close ()
setDn ($username, $nosub=0)
getDn ()
anonymous_bind ()
bind ($username=null, $password=null, $nosub=0)
unbind ()
simple_search ($search)
search (array $filters, $dnoverride=null, array $attributes=array())
replace ($dn, $attribute)
modify ($dn, $attribute)
remove ($dn, $attribute)
compare ($dn, $attribute, $value)
read ($dn)
delete ($dn)
create ($dn, array $entries)
add ($dn, array $entry)
rename ($dn, $newdn, $newparent, $deleteolddn)
escape ($value, $ignore='', $flags=0)
getErrorMsg ()
isConnected ()

Fonctions membres publiques statiques

static | ipToNetAddress ($ip)
static | ldapNetAddr ($networkaddress)
static | generatePassword ($password, $type='md5')

Champs de données

$host = null
$auth_method = null
$port = null
$base_dn = null
$users_dn = null
$search_string = null
$use_ldapV3 = null
$no_referrals = null
$negotiate_tls = null
$username = null
$password = null

Attributs privés

$resource = null
$dn = null
$isBound = false

Description détaillée

LDAP client class

Depuis
1.0
Obsolète:
The joomla/ldap package is deprecated

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $configObj = null )

Constructor

Paramètres
object $configObj An object of configuration variables
Depuis
1.0

Références $this.

◆ __destruct()

__destruct ( )

Class destructor.

Depuis
1.3.0

Références LdapClient\close().

Documentation des fonctions membres

◆ add()

add | ( |  | $dn,
 |  | array | $entry
 | ) |  |

Add attribute values to current attributes

Paramètres
string | $dn | The DN of the entry to add the attribute
array | $entry | An array of arrays with attributes to add
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ anonymous_bind()

anonymous_bind ( )

Anonymously binds to LDAP directory

Renvoie
boolean
Depuis
1.0

Références LdapClient\$isBound, LdapClient\connect(), et LdapClient\isConnected().

◆ bind()

bind | ( | $username = null,
 |  | $password = null,
 |  | $nosub = 0
 | ) |

Binds to the LDAP directory

Paramètres
string | $username | The username
string | $password | The password
string $nosub ...
Renvoie
boolean
Depuis
1.0

Références LdapClient\$isBound, LdapClient\$password, LdapClient\$username, LdapClient\connect(), LdapClient\getDn(), LdapClient\isConnected(), et LdapClient\setDn().

◆ close()

close ( )

Close the connection

Renvoie
void
Depuis
1.0

Références LdapClient\isConnected(), null, et LdapClient\unbind().

Référencé par LdapClient\__destruct().

◆ compare()

compare | ( | $dn,
 |  | $attribute,
 |  | $value
 | ) |

Compare value of attribute found in entry specified with DN

Paramètres
string | $dn | The DN which contains the attribute you want to compare
string | $attribute | The attribute whose value you want to compare
string | $value | The value you want to check against the LDAP attribute
Renvoie
boolean|integer Boolean result of the comparison or -1 on error
Depuis
1.0

Références LdapClient\$dn, $value, et LdapClient\isConnected().

◆ connect()

connect ( )

Connect to an LDAP server

Renvoie
boolean
Depuis
1.0

Référencé par LdapClient\anonymous_bind(), et LdapClient\bind().

◆ create()

create | ( |  | $dn,
 |  | array | $entries
 | ) |  |

Add entries to LDAP directory

Paramètres
string | $dn | The DN where you want to put the object
array | $entries | An array of arrays describing the object to add
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ delete()

delete ( $dn )

Delete an entry from a directory

Paramètres
string $dn The DN of the object you want to delete
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ escape()

escape | ( | $value,
 |  | $ignore = '',
 |  | $flags = 0
 | ) |

Escape a string

Paramètres
string | $value | The subject string
string | $ignore | Characters to ignore when escaping.
integer | $flags | The context the escaped string will be used in LDAP_ESCAPE_FILTER or LDAP_ESCAPE_DN
Renvoie
string
Depuis
1.2.0

Références $value.

◆ generatePassword()

static generatePassword | ( | $password,
 |  | $type = 'md5'
 | ) |
static

Generates a LDAP compatible password

Paramètres
string | $password | Clear text password to encrypt
string | $type | Type of password hash, either md5 or SHA
Renvoie
string
Depuis
1.0

Références LdapClient\$password, et $type.

◆ getDn()

getDn ( )

Get the configured DN

Renvoie
string
Depuis
1.0

Références LdapClient\$dn.

Référencé par LdapClient\bind().

◆ getErrorMsg()

getErrorMsg ( )

Return the LDAP error message of the last LDAP command

Renvoie
string
Depuis
1.0

Références LdapClient\isConnected().

◆ ipToNetAddress()

static ipToNetAddress ( $ip )
static

Converts a dot notation IP address to net address (e.g. for Netware, etc)

Paramètres
string $ip IP Address (e.g. xxx.xxx.xxx.xxx)
Renvoie
string
Depuis
1.0

Références $parts, et $tmp.

◆ isConnected()

isConnected ( )

Check if the connection is established

Renvoie
boolean
Depuis
1.3.0

Référencé par LdapClient\add(), LdapClient\anonymous_bind(), LdapClient\bind(), LdapClient\close(), LdapClient\compare(), LdapClient\create(), LdapClient\delete(), LdapClient\getErrorMsg(), LdapClient\modify(), LdapClient\read(), LdapClient\remove(), LdapClient\rename(), LdapClient\replace(), et LdapClient\search().

◆ ldapNetAddr()

static ldapNetAddr ( $networkaddress )
static

Extract readable network address from the LDAP encoded networkAddress attribute.

Please keep this document block and author attribution in place.

Novell Docs, see: http://developer.novell.com/ndk/doc/ndslib/schm_enu/data/sdk5624.html#sdk5624 for Address types: http://developer.novell.com/ndk/doc/ndslib/index.html?page=/ndk/doc/ndslib/schm_enu/data/sdk4170.html LDAP Format, String: taggedData = uint32String "#" octetstring byte 0 = uint32String = Address Type: 0= IPX Address; 1 = IP Address byte 1 = char = "#" - separator byte 2+ = octetstring - the ordinal value of the address Note: with eDirectory 8.6.2, the IP address (type 1) returns correctly, however, an IPX address does not seem to. eDir 8.7 may correct this. Enhancement made by Merijn van de Schoot: If addresstype is 8 (UDP) or 9 (TCP) do some additional parsing like still returning the IP address

Paramètres
string $networkaddress The network address
Renvoie
array
Auteur
Jay Burrell, Systems & Networks, Mississippi State University
Depuis
1.0

Références $i.

◆ modify()

modify | ( | $dn,
 |  | $attribute
 | ) |

Modify an LDAP entry

Paramètres
string | $dn | The DN which contains the attribute you want to modify
string | $attribute | The attribute values you want to modify
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ read()

read ( $dn )

Read attributes of a given DN

Paramètres
string $dn The DN of the object you want to read
Renvoie
array|boolean Array of attributes for the given DN or boolean false on failure
Depuis
1.0

Références $base, LdapClient\$dn, $result, et LdapClient\isConnected().

◆ remove()

remove | ( | $dn,
 |  | $attribute
 | ) |

Delete attribute values from current attributes

Paramètres
string | $dn | The DN which contains the attribute you want to remove
string | $attribute | The attribute values you want to remove
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ rename()

rename | ( | $dn,
 |  | $newdn,
 |  | $newparent,
 |  | $deleteolddn
 | ) |

Modify the name of an entry

Paramètres
string | $dn | The DN of the entry at the moment
string | $newdn | The DN of the entry should be (only cn=newvalue)
string | $newparent | The full DN of the parent (null by default)
boolean | $deleteolddn | Delete the old values (default)
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ replace()

replace | ( | $dn,
 |  | $attribute
 | ) |

Replace attribute values with new ones

Paramètres
string | $dn | The DN which contains the attribute you want to replace
string | $attribute | The attribute values you want to replace
Renvoie
boolean
Depuis
1.0

Références LdapClient\$dn, et LdapClient\isConnected().

◆ search()

search | ( | array | $filters,
 |  |  | $dnoverride = null,
 |  | array | $attributes = array()
 | ) |  |

Performs an LDAP search

Paramètres
array | $filters | Search Filters (array of strings)
string | $dnoverride | DN Override
array | $attributes | An array of attributes to return (if empty, all fields are returned).
Renvoie
array Multidimensional array of results
Depuis
1.0

Références $attributes, LdapClient\$base_dn, $count, LdapClient\$dn, $filters, $i, $result, et LdapClient\isConnected().

Référencé par LdapClient\simple_search().

◆ setDn()

setDn | ( | $username,
 |  | $nosub = 0
 | ) |

Sets the DN with some template replacements

Paramètres
string $username The username
string $nosub ...
Renvoie
void
Depuis
1.0

Références LdapClient\$username, et elseif.

Référencé par LdapClient\bind().

◆ simple_search()

simple_search ( $search )

Perform an LDAP search using comma separated search strings

Paramètres
string $search search string of search values
Renvoie
array Search results
Depuis
1.0

Références $key, $result, $results, et LdapClient\search().

◆ unbind()

unbind ( )

Unbinds from the LDAP directory

Renvoie
boolean
Depuis
1.3.0

Référencé par LdapClient\close().

Documentation des champs

◆ $auth_method

$auth_method = null

◆ $base_dn

$base_dn = null

Référencé par LdapClient\search().

◆ $dn

$dn = null
private

Référencé par LdapClient\add(), LdapClient\compare(), LdapClient\create(), LdapClient\delete(), LdapClient\getDn(), LdapClient\modify(), LdapClient\read(), LdapClient\remove(), LdapClient\rename(), LdapClient\replace(), et LdapClient\search().

◆ $host

$host = null

◆ $isBound

$isBound = false
private

Référencé par LdapClient\anonymous_bind(), et LdapClient\bind().

◆ $negotiate_tls

$negotiate_tls = null

◆ $no_referrals

$no_referrals = null

◆ $password

$password = null

Référencé par LdapClient\bind(), et LdapClient\generatePassword().

◆ $port

$port = null

◆ $resource

$resource = null
private

◆ $search_string

$search_string = null

◆ $use_ldapV3

$use_ldapV3 = null

◆ $username

$username = null

Référencé par LdapClient\bind(), et LdapClient\setDn().

◆ $users_dn

$users_dn = null
La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapClient.php


Joomla CMS: Référence de la classe ArticlesArchiveHelper

  • Joomla
  • Module
  • ArticlesArchive
  • Site
  • Helper
  • ArticlesArchiveHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesArchiveHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_articles_archive

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Retrieve list of archived articles

Paramètres
\Joomla\Registry\Registry &$params module parameters
Renvoie
array
Depuis
1.5

Références $app, $date, $db, $i, $item, $itemid, $menu, $params, $query, $rows, Text\_(), Route\_(), HTMLHelper\_(), ContentComponent\CONDITION_ARCHIVED, Factory\getApplication(), Factory\getDate(), Factory\getDbo(), Factory\getLanguage(), Text\sprintf(), et ParameterType\STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesArchiveHelper.php


Joomla CMS: Référence de la classe ArticlesCategoriesHelper

  • Joomla
  • Module
  • ArticlesCategories
  • Site
  • Helper
  • ArticlesCategoriesHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesCategoriesHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_articles_categories

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Get list of articles

Paramètres
\Joomla\Registry\Registry &$params module parameters
Renvoie
array
Depuis
1.5

Références $category, $count, $items, $options, $params, Categories\getInstance(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesCategoriesHelper.php


Joomla CMS: Référence de la classe ArticlesCategoryHelper

  • Joomla
  • Module
  • ArticlesCategory
  • Site
  • Helper
  • ArticlesCategoryHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesCategoryHelper

Fonctions membres publiques statiques

static | getList (&$params)
static | _cleanIntrotext ($introtext)
static | truncate ($html, $maxLength=0)
static | groupBy ($list, $fieldName, $direction, $fieldNameToKeep=null)
static | groupByDate ($list, $direction='ksort', $type='year', $monthYearFormat='F Y', $field='created')
static | groupByTags ($list, $direction='ksort')

Description détaillée

Helper for mod_articles_category

Depuis
1.6

Documentation des fonctions membres

◆ _cleanIntrotext()

static _cleanIntrotext ( $introtext )
static

Strips unnecessary tags from the introtext

Paramètres
string $introtext introtext to sanitize
Renvoie
mixed|string
Depuis
1.6

◆ getList()

static getList ( & $params )
static

Get a list of articles from a specific category

Paramètres
\Joomla\Registry\Registry &$params object holding the models parameters
Renvoie
mixed
Depuis
1.6

Références $app, $article, $authorised, $category, $input, $item, $items, $menu, $mode, $option, $ordering, $params, $view, Route\_(), HTMLHelper\_(), ContentComponent\CONDITION_PUBLISHED, elseif, Factory\getApplication(), RouteHelper\getArticleRoute(), Access\getAuthorisedViewLevels(), RouteHelper\getCategoryRoute(), Factory\getDbo(), ComponentHelper\getParams(), Factory\getUser(), PluginHelper\isEnabled(), et Joomla\Database\Query\rand().

◆ groupBy()

static groupBy | ( | $list,
 |  | $fieldName,
 |  | $direction,
 |  | $fieldNameToKeep = null
 | ) |
static

Groups items by field

Paramètres
array | $list | list of items
string | $fieldName | name of field that is used for grouping
string | $direction | ordering direction
null | $fieldNameToKeep | field name to keep
Renvoie
array
Depuis
1.6

Références $direction, $grouped, $item, $key, $list, et null.

◆ groupByDate()

static groupByDate | ( | $list,
 |  | $direction = 'ksort',
 |  | $type = 'year',
 |  | $monthYearFormat = 'F Y',
 |  | $field = 'created'
 | ) |
static

Groups items by date

Paramètres
array | $list | list of items
string | $direction | ordering direction
string | $type | type of grouping
string | $monthYearFormat | date format to use
string | $field | date field to group by
Renvoie
array
Depuis
1.6

Références $date, $direction, $grouped, $item, $items, $key, $list, $type, et StringHelper\substr().

◆ groupByTags()

static groupByTags | ( | $list,
 |  | $direction = 'ksort'
 | ) |
static

Groups items by tags

Paramètres
array | $list | list of items
string | $direction | ordering direction
Renvoie
array
Depuis
3.9.0

Références $direction, $grouped, $item, et $list.

◆ truncate()

static truncate | ( | $html,
 |  | $maxLength = 0
 | ) |
static

Method to truncate introtext

The goal is to get the proper length plain text string with as much of the html intact as possible with all tags properly closed.

Paramètres
string | $html | The content of the introtext to be truncated
integer | $maxLength | The maximum number of characters to render
Renvoie
string The truncated string
Depuis
1.6

Références $html, et HTMLHelper\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesCategoryHelper.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Module
  • ArticlesLatest
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
AbstractModuleDispatcher HelperFactoryAwareInterface Dispatcher DispatcherInterface

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de AbstractModuleDispatcher
getLayoutData ()
loadLanguage ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractModuleDispatcher
__construct (\stdClass $module, CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de DispatcherInterface
dispatch ()
- Fonctions membres publiques hérités de HelperFactoryAwareInterface
setHelperFactory (HelperFactory $helper)
- Attributs protégés hérités de AbstractModuleDispatcher
$module
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Dispatcher class for mod_articles_latest

Depuis
4.2.0

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Returns the layout data.

Renvoie
array
Depuis
4.2.0

Références $data, et Joomla\CMS\Helper\getHelperFactory().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_articles_latest/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ArticlesLatestHelper

  • Joomla
  • Module
  • ArticlesLatest
  • Site
  • Helper
  • ArticlesLatestHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesLatestHelper
+ Graphe d'héritage de ArticlesLatestHelper:
DatabaseAwareInterface

Fonctions membres publiques statiques

static getList (Registry $params, ArticlesModel $model)

Membres hérités additionnels

- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Description détaillée

Helper for mod_articles_latest

Depuis
1.6

Documentation des fonctions membres

◆ getList()

static getList | ( | Registry | $params,
 |  | ArticlesModel | $model
 | ) |  |
static

Retrieve a list of articles

Paramètres
Registry | $params | The module parameters.
ArticlesModel | $model | The model.
Renvoie
mixed
Depuis
1.6
Obsolète:
5.0 Use the none static function getArticles

Références $params, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesLatestHelper.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Module
  • ArticlesNews
  • Site
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
AbstractModuleDispatcher HelperFactoryAwareInterface Dispatcher DispatcherInterface

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de AbstractModuleDispatcher
getLayoutData ()
loadLanguage ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractModuleDispatcher
__construct (\stdClass $module, CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de DispatcherInterface
dispatch ()
- Fonctions membres publiques hérités de HelperFactoryAwareInterface
setHelperFactory (HelperFactory $helper)
- Attributs protégés hérités de AbstractModuleDispatcher
$module
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Dispatcher class for mod_articles_news

Depuis
4.2.0

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Returns the layout data.

Renvoie
array
Depuis
4.2.0

Références $data, et Joomla\CMS\Helper\getHelperFactory().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_articles_news/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe ArticlesNewsHelper

  • Joomla
  • Module
  • ArticlesNews
  • Site
  • Helper
  • ArticlesNewsHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesNewsHelper
+ Graphe d'héritage de ArticlesNewsHelper:
DatabaseAwareInterface

Fonctions membres publiques statiques

static getList (&$params)

Membres hérités additionnels

- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Description détaillée

Helper for mod_articles_news

Depuis
1.6

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Get a list of the latest articles from the article model

Paramètres
\Joomla\Registry\Registry &$params object holding the models parameters
Renvoie
mixed
Depuis
1.6
Obsolète:
5.0 Use the none static function getArticles

Références $params, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesNewsHelper.php


Joomla CMS: Référence de la classe ArticlesPopularHelper

  • Joomla
  • Module
  • ArticlesPopular
  • Site
  • Helper
  • ArticlesPopularHelper
Fonctions membres publiques statiques
Référence de la classe ArticlesPopularHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_articles_popular

Depuis
1.6

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Get a list of popular articles from the articles model

Paramètres
\Joomla\Registry\Registry &$params object holding the models parameters
Renvoie
mixed

Références $app, $authorised, $item, $items, $model, $params, Route\_(), ContentComponent\CONDITION_PUBLISHED, Factory\getApplication(), RouteHelper\getArticleRoute(), Access\getAuthorisedViewLevels(), ComponentHelper\getParams(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArticlesPopularHelper.php


Joomla CMS: Référence de la classe BannersHelper

  • Joomla
  • Module
  • Banners
  • Site
  • Helper
  • BannersHelper
Fonctions membres publiques statiques
Référence de la classe BannersHelper

Fonctions membres publiques statiques

static getList (Registry $params, BannersModel $model, CMSApplication $app)

Description détaillée

Helper for mod_banners

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static getList | ( | Registry | $params,
 |  | BannersModel | $model,
 |  | CMSApplication | $app
 | ) |  |
static

Retrieve list of banners

Paramètres
Registry | $params | The module parameters
BannersModel | $model | The model
CMSApplication | $app | The application
Renvoie
mixed

Références $app, $config, $keywords, $model, $params, Browser\getInstance(), et ComponentHelper\getParams().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_banners/src/Helper/BannersHelper.php


Joomla CMS: Référence de la classe BreadcrumbsHelper

  • Joomla
  • Module
  • Breadcrumbs
  • Site
  • Helper
  • BreadcrumbsHelper
Fonctions membres publiques statiques
Référence de la classe BreadcrumbsHelper

Fonctions membres publiques statiques

static | getList (Registry $params, CMSApplication $app)
static | getHome (Registry $params, CMSApplication $app)
static | setSeparator ($custom=null)

Description détaillée

Helper for mod_breadcrumbs

Depuis
1.5

Documentation des fonctions membres

◆ getHome()

static getHome | ( | Registry | $params,
 |  | CMSApplication | $app
 | ) |  |
static

Retrieve home item (start page)

Paramètres
Registry | $params | The module parameters
CMSApplication | $app | The application
Renvoie
object
Depuis
4.2.0

Références $app, $item, $menu, $params, Text\_(), ENT_COMPAT, et Multilanguage\isEnabled().

◆ getList()

static getList | ( | Registry | $params,
 |  | CMSApplication | $app
 | ) |  |
static

Retrieve breadcrumb items

Paramètres
Registry | $params | The module parameters
CMSApplication | $app | The application
Renvoie
array

Références $app, $count, $i, $items, $params, ENT_COMPAT, et name.

◆ setSeparator()

static setSeparator ( $custom = null )
static

Set the breadcrumbs separator for the breadcrumbs display.

Paramètres
string $custom Custom xhtml compliant string to separate the items of the breadcrumbs
Renvoie
string Separator string
Depuis
1.5

Références $lang, HTMLHelper\_(), ENT_COMPAT, Factory\getApplication(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BreadcrumbsHelper.php


Joomla CMS: Référence de la classe FeedHelper

  • Joomla
  • Module
  • Feed
  • Administrator
  • Helper
  • FeedHelper
Fonctions membres publiques statiques
Référence de la classe FeedHelper

Fonctions membres publiques statiques

static getFeed ($params)

Description détaillée

Helper for mod_feed

Depuis
1.5

Documentation des fonctions membres

◆ getFeed()

static getFeed ( $params )
static

Method to load a feed.

Paramètres
\Joomla\Registry\Registry $params The parameters object.
Renvoie
|string Return a JFeedReader object or a string message if error.
Depuis
1.5

Références $feed, $params, $rssurl, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/modules/mod_feed/src/Helper/FeedHelper.php


Joomla CMS: Référence de la classe FeedHelper

  • Joomla
  • Module
  • Feed
  • Site
  • Helper
  • FeedHelper
Fonctions membres publiques statiques
Référence de la classe FeedHelper

Fonctions membres publiques statiques

static getFeed ($params)

Description détaillée

Helper for mod_feed

Depuis
1.5

Documentation des fonctions membres

◆ getFeed()

static getFeed ( $params )
static

Retrieve feed information

Paramètres
\Joomla\Registry\Registry $params module parameters
Renvoie
|string

Références $feed, $params, $rssurl, et Text\_().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_feed/src/Helper/FeedHelper.php


Joomla CMS: Référence de la classe FinderHelper

  • Joomla
  • Module
  • Finder
  • Site
  • Helper
  • FinderHelper
Fonctions membres publiques statiques
Référence de la classe FinderHelper

Fonctions membres publiques statiques

static | getGetFields ($route=null, $paramItem=0)
static | getQuery ($params)

Description détaillée

Finder module helper.

Depuis
2.5

Documentation des fonctions membres

◆ getGetFields()

static getGetFields | ( | $route = null,
 |  | $paramItem = 0
 | ) |
static

Method to get hidden input fields for a get form so that control variables are not lost upon form submission.

Paramètres
string | $route | The route to the page. [optional]
integer | $paramItem | The menu item ID. (
Depuis
3.1) [optional]
Renvoie
string A string of hidden input form fields
Depuis
2.5

Références $fields, $n, $route, $uri, Route\_(), et Uri\getInstance().

◆ getQuery()

static getQuery ( $params )
static

Get Smart Search query object.

Paramètres
\Joomla\Registry\Registry $params Module parameters.
Renvoie
Query object
Depuis
2.5

Références $options, $params, class, Factory\getApplication(), Factory\getContainer(), InputFilter\getInstance(), et ArrayHelper\toInteger().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_finder/src/Helper/FinderHelper.php


Joomla CMS: Référence de la classe LanguagesHelper

  • Joomla
  • Module
  • Languages
  • Site
  • Helper
  • LanguagesHelper
Fonctions membres publiques statiques
Référence de la classe LanguagesHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_languages

Depuis
1.6

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Gets a list of available languages

Paramètres
\Joomla\Registry\Registry &$params module params
Renvoie
array

Références $active, $app, $assoc, $class, $component, $default, $i, $item, $itemid, $lang, $language, $languages, $menu, $multilang, $option, $sitelangs, $user, Route\_(), elseif, Factory\getApplication(), MenusHelper\getAssociations(), Uri\getInstance(), Factory\getLanguage(), LanguageHelper\getMetadata(), Factory\getUser(), Multilanguage\isEnabled(), Associations\isEnabled(), JPATH_SITE, et JLoader\register().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_languages/src/Helper/LanguagesHelper.php


Joomla CMS: Référence de la classe LatestHelper

  • Joomla
  • Module
  • Latest
  • Administrator
  • Helper
  • LatestHelper
Fonctions membres publiques statiques
Référence de la classe LatestHelper

Fonctions membres publiques statiques

static | getList (Registry &$params, ArticlesModel $model)
static | getTitle ($params)

Description détaillée

Helper for mod_latest

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static getList | ( | Registry & | $params,
 |  | ArticlesModel | $model
 | ) |  |
static

Get a list of articles.

Paramètres
Registry | &$params | The module parameters.
ArticlesModel | $model | The model.
Renvoie
mixed An array of articles, or false on error.

Références $item, $items, $model, $params, $user, $userId, Route\_(), Factory\getUser(), et null.

◆ getTitle()

static getTitle ( $params )
static

Get the alternate title for the module.

Paramètres
\Joomla\Registry\Registry $params The module parameters.
Renvoie
string The alternate title for the module.

Références $category, $params, $title, $type, Text\_(), Categories\getInstance(), null, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LatestHelper.php


Joomla CMS: Référence de la classe LatestActionsHelper

  • Joomla
  • Module
  • LatestActions
  • Administrator
  • Helper
  • LatestActionsHelper
Fonctions membres publiques statiques
Référence de la classe LatestActionsHelper

Fonctions membres publiques statiques

static getTitle ($params)

Description détaillée

Helper for mod_latestactions

Depuis
3.9.0

Documentation des fonctions membres

◆ getTitle()

static getTitle ( $params )
static

Get the alternate title for the module

Paramètres
Registry $params The module parameters.
Renvoie
string The alternate title for the module.
Depuis
3.9.1

Références $params, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LatestActionsHelper.php


Joomla CMS: Référence de la classe LoggedHelper

  • Joomla
  • Module
  • Logged
  • Administrator
  • Helper
  • LoggedHelper
Fonctions membres publiques statiques
Référence de la classe LoggedHelper

Fonctions membres publiques statiques

static | getList (Registry $params, CMSApplication $app, DatabaseInterface $db)
static | getTitle ($params)

Description détaillée

Helper for mod_logged

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static getList | ( | Registry | $params,
 |  | CMSApplication | $app,
 |  | DatabaseInterface | $db
 | ) |  |
static

Get a list of logged users.

Paramètres
Registry | $params | The module parameters
CMSApplication | $app | The application
DatabaseInterface | $db | The database
Renvoie
mixed An array of users, or false on error.
Exceptions

Références $app, $db, $params, $query, $result, $results, $user, Route\_(), et Session\getFormToken().

◆ getTitle()

static getTitle ( $params )
static

Get the alternate title for the module

Paramètres
\Joomla\Registry\Registry $params The module parameters.
Renvoie
string The alternate title for the module.

Références $params, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LoggedHelper.php


Joomla CMS: Référence de la classe LoginHelper

  • Joomla
  • Module
  • Login
  • Administrator
  • Helper
  • LoginHelper
Fonctions membres publiques statiques
Référence de la classe LoginHelper

Fonctions membres publiques statiques

static | getLanguageList ()
static | getReturnUri ()

Description détaillée

Helper for mod_login

Depuis
1.6

Documentation des fonctions membres

◆ getLanguageList()

static getLanguageList ( )
static

Get an HTML select list of the available languages.

Renvoie
string

Références $b, $language, $languages, Text\_(), HTMLHelper\_(), LanguageHelper\createLanguageList(), Factory\getApplication(), JPATH_ADMINISTRATOR, et null.

◆ getReturnUri()

static getReturnUri ( )
static

Get the redirect URI after login.

Renvoie
string

Références $return, $uri, et Uri\getInstance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/modules/mod_login/src/Helper/LoginHelper.php


Joomla CMS: Référence de la classe LoginHelper

  • Joomla
  • Module
  • Login
  • Site
  • Helper
  • LoginHelper
Fonctions membres publiques statiques
Référence de la classe LoginHelper

Fonctions membres publiques statiques

static | getReturnUrl ($params, $type)
static | getType ()
static | getRegistrationUrl ($params)

Description détaillée

Helper for mod_login

Depuis
1.5

Documentation des fonctions membres

◆ getRegistrationUrl()

static getRegistrationUrl ( $params )
static

Retrieve the URL for the registration page

Paramètres
\Joomla\Registry\Registry $params module parameters
Renvoie
string

Références $item, $params, Factory\getApplication(), et Multilanguage\isEnabled().

◆ getReturnUrl()

static getReturnUrl | ( | $params,
 |  | $type
 | ) |
static

Retrieve the URL where the user should be returned after logging in

Paramètres
\Joomla\Registry\Registry | $params | module parameters
string | $type | return type
Renvoie
string

Références $item, $lang, $params, $type, $url, Factory\getApplication(), Uri\getInstance(), et Multilanguage\isEnabled().

◆ getType()

static getType ( )
static

Returns the current users type

Renvoie
string

Références $user, et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • modules/mod_login/src/Helper/LoginHelper.php


Joomla CMS: Référence de la classe CssMenu

  • Joomla
  • Module
  • Menu
  • Administrator
  • Menu
  • CssMenu
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe CssMenu

Fonctions membres publiques

__construct (CMSApplication $application)
load ($params, $enabled)
renderSubmenu ($layoutFile, $node)
getIconClass ($node)
getCounter ()

Fonctions membres protégées

check ($node, Registry $params)
preprocess ($parent)

Attributs protégés

$root
$nodes = []
$params
$enabled
$application
$counter = 0

Description détaillée

Tree based class to render the admin menu

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CMSApplication $application )

CssMenu constructor.

Paramètres
CMSApplication $application The application
Depuis
4.0.0

Documentation des fonctions membres

◆ check()

check | ( |  | $node,
 |  | Registry | $params
 | ) |  |
protected

Check the flat list of menu items for important links

Paramètres
AdministratorMenuItem | $node | The menu items array
Registry | $params | Module options
Renvoie
boolean Whether to show recovery menu
Depuis
3.8.0

Références $items, $menutype, $message, $params, $uri, Text\_(), Uri\getInstance(), Table\getInstance(), et Text\sprintf().

◆ getCounter()

getCounter ( )

Create unique identifier

Renvoie
string
Depuis
4.0.0

Références counter.

◆ getIconClass()

getIconClass ( $node )

Method to get the CSS class name for an icon identifier or create one if a custom image path is passed as the identifier

Paramètres
AdministratorMenuItem $node Node to get icon data from
Renvoie
string CSS class name
Depuis
3.8.0

Références $class, $html, et null.

◆ load()

load | ( | $params,
 |  | $enabled
 | ) |

Populate the menu items in the menu tree object

Paramètres
Registry | $params | Menu configuration parameters
bool | $enabled | Whether the menu should be enabled or disabled
Renvoie
AdministratorMenuItem Root node of the menu tree
Depuis
3.7.0

Références $enabled, $heading, $menutype, $name, $params, $root, $uri, Uri\getInstance(), MenusHelper\getMenuItems(), et MenusHelper\loadPreset().

◆ preprocess()

preprocess ( $parent )
protected

Filter and perform other preparatory tasks for loaded menu items based on access rights and module configurations for display

Paramètres
AdministratorMenuItem $parent A menu item to process
Renvoie
array
Depuis
3.8.0

Trigger onPreprocessMenuItems for the current level of backend menu items. $children is an array of AdministratorMenuItem objects. A plugin can traverse the whole tree, but new nodes will only be run through this method if their parents have not been processed yet.

If component is passed in the link via option variable, we set $item->element to this value for further processing. It is needed for links from menu items of third party extensions link to Joomla! core components like com_categories, com_fields...

Références $c, $item, $language, $last, $option, $parts, $query, $this, $uri, $user, Joomla\CMS\MVC\Model\$workflow, Text\_(), elseif, MenusHelper\getMenuItems(), ComponentHelper\getParams(), ComponentHelper\isEnabled(), Associations\isEnabled(), JPATH_ADMINISTRATOR, null, et ArrayHelper\sortObjects().

◆ renderSubmenu()

renderSubmenu | ( | $layoutFile,
 |  | $node
 | ) |

Method to render a given level of a menu using provided layout file

Paramètres
string | $layoutFile | The layout file to be used to render
AdministratorMenuItem | $node | Node to render the children of
Renvoie
void
Depuis
3.8.0

Documentation des champs

◆ $application

$application
protected

◆ $counter

$counter = 0
protected

◆ $enabled

$enabled
protected

◆ $nodes

$nodes = []
protected

◆ $params

$params
protected

◆ $root

$root
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CssMenu.php


Joomla CMS: Référence de la classe MenuHelper

  • Joomla
  • Module
  • Menu
  • Site
  • Helper
  • MenuHelper
Fonctions membres publiques statiques
Référence de la classe MenuHelper

Fonctions membres publiques statiques

static | getBase (&$params)
static | getActive (&$params)
static | getDefault ()

Description détaillée

Helper for mod_menu

Depuis
1.5

Documentation des fonctions membres

◆ getActive()

static getActive ( & $params )
static

Get active menu item.

Paramètres
\Joomla\Registry\Registry &$params The module options.
Renvoie
object
Depuis
3.0.2

Références $menu, et Factory\getApplication().

◆ getBase()

static getBase ( & $params )
static

Get base menu item.

Paramètres
\Joomla\Registry\Registry &$params The module options.
Renvoie
object
Depuis
3.0.2

Références $base, $params, et Factory\getApplication().

◆ getDefault()

static getDefault ( )
static

Get default menu item (home page) for current language.

Renvoie
object

Références $menu, Factory\getApplication(), Factory\getLanguage(), et Multilanguage\isEnabled().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MenuHelper.php


Joomla CMS: Référence de la classe PopularHelper

  • Joomla
  • Module
  • Popular
  • Administrator
  • Helper
  • PopularHelper
Fonctions membres publiques statiques
Référence de la classe PopularHelper

Fonctions membres publiques statiques

static | getList (Registry &$params, ArticlesModel $model)
static | getTitle ($params)

Description détaillée

Helper for mod_popular

Depuis
1.6

Documentation des fonctions membres

◆ getList()

static getList | ( | Registry & | $params,
 |  | ArticlesModel | $model
 | ) |  |
static

Get a list of the most popular articles.

Paramètres
Registry | &$params | The module parameters.
ArticlesModel | $model | The model.
Renvoie
mixed An array of articles, or false on error.
Exceptions

Références $item, $items, $model, $params, $user, $userId, Route\_(), Factory\getUser(), et null.

◆ getTitle()

static getTitle ( $params )
static

Get the alternate title for the module

Paramètres
Registry $params The module parameters.
Renvoie
string The alternate title for the module.

Références $category, $params, $title, Text\_(), Categories\getInstance(), null, et Text\plural().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PopularHelper.php


Joomla CMS: Référence de la classe PrivacyDashboardHelper

  • Joomla
  • Module
  • PrivacyDashboard
  • Administrator
  • Helper
  • PrivacyDashboardHelper
Fonctions membres publiques statiques
Référence de la classe PrivacyDashboardHelper

Fonctions membres publiques statiques

static getData ()

Description détaillée

Helper class for admin privacy dashboard module

Depuis
3.9.0

Documentation des fonctions membres

◆ getData()

static getData ( )
static

Method to retrieve information about the site privacy requests

Renvoie
array Array containing site privacy requests
Depuis
3.9.0

Références $db, $query, et Factory\getDbo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyDashboardHelper.php


Joomla CMS: Référence de la classe PrivacyStatusHelper

  • Joomla
  • Module
  • PrivacyStatus
  • Administrator
  • Helper
  • PrivacyStatusHelper
Fonctions membres publiques statiques
Référence de la classe PrivacyStatusHelper

Fonctions membres publiques statiques

static | getPrivacyPolicyInfo ()
static | getRequestFormPublished ()
static | getNumberUrgentRequests ()

Description détaillée

Helper class for admin privacy status module

Depuis
4.0.0

Documentation des fonctions membres

◆ getNumberUrgentRequests()

static getNumberUrgentRequests ( )
static

Method to return number privacy requests older than X days.

Renvoie
integer
Depuis
4.0.0

Références $db, $now, $params, $query, ComponentHelper\getComponent(), Factory\getDate(), et Factory\getDbo().

◆ getPrivacyPolicyInfo()

static getPrivacyPolicyInfo ( )
static

Get the information about the published privacy policy

Renvoie
array Array containing a status of whether a privacy policy is set and a link to the policy document for editing
Depuis
4.0.0

Références Factory\getApplication(), et PluginHelper\importPlugin().

◆ getRequestFormPublished()

static getRequestFormPublished ( )
static

Check whether there is a menu item for the request form

Renvoie
array Array containing a status of whether a menu is published for the request form and its current link
Depuis
4.0.0

Références $db, $itemId, $lang, $params, $query, Factory\getApplication(), Factory\getDbo(), ComponentHelper\getParams(), Multilanguage\isEnabled(), Route\link(), Route\TLS_FORCE, et Route\TLS_IGNORE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyStatusHelper.php


Joomla CMS: Référence de la classe Dispatcher

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Dispatcher
  • Dispatcher
Fonctions membres protégées
Référence de la classe Dispatcher
+ Graphe d'héritage de Dispatcher:
AbstractModuleDispatcher Dispatcher DispatcherInterface

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de AbstractModuleDispatcher
getLayoutData ()
loadLanguage ()
- Fonctions membres protégées hérités de Dispatcher
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractModuleDispatcher
__construct (\stdClass $module, CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de Dispatcher
__construct (CMSApplicationInterface $app, Input $input)
- Fonctions membres publiques hérités de DispatcherInterface
dispatch ()
- Attributs protégés hérités de AbstractModuleDispatcher
$module
- Attributs protégés hérités de Dispatcher
$app
$input

Description détaillée

Dispatcher class for mod_quickicon

Depuis
4.0.0

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Returns the layout data.

Renvoie
array
Depuis
4.0.0

Références $data, et $helper.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/modules/mod_quickicon/src/Dispatcher/Dispatcher.php


Joomla CMS: Référence de la classe QuickIconsEvent

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Event
  • QuickIconsEvent
Fonctions membres publiques | Attributs privés
Référence de la classe QuickIconsEvent
+ Graphe d'héritage de QuickIconsEvent:
AbstractEvent Event AbstractEvent EventInterface

Fonctions membres publiques

getContext ()
setContext ($context)
- Fonctions membres publiques hérités de AbstractEvent
__construct (string $name, array $arguments=[])
getArgument ($name, $default=null)
setArgument ($name, $value)
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$context

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractEvent
static create (string $eventName, array $arguments=[])
- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Event object for retrieving pluggable quick icons

Depuis
4.0.0

Documentation des fonctions membres

◆ getContext()

getContext ( )

Get the event context

Renvoie
string
Depuis
4.0.0

Références $context.

Référencé par Joomlaupdate\getCoreUpdateNotification().

◆ setContext()

setContext ( $context )

Set the event context

Paramètres
string $context The event context
Renvoie
string
Depuis
4.0.0

Références $context.

Documentation des champs

◆ $context

$context
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • QuickIconsEvent.php


Joomla CMS: Référence de la classe QuickIconHelper

  • Joomla
  • Module
  • Quickicon
  • Administrator
  • Helper
  • QuickIconHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe QuickIconHelper

Fonctions membres publiques

getButtons (Registry $params, CMSApplication $application=null)

Attributs protégés

$buttons = array()

Description détaillée

Helper for mod_quickicon

Depuis
1.6

Documentation des fonctions membres

◆ getButtons()

getButtons | ( | Registry | $params,
 |  | CMSApplication | $application = null
 | ) |  |

Helper method to return button list.

This method returns the array by reference so it can be used to add custom buttons or remove default ones.

Paramètres
Registry | $params | The module parameters
CMSApplication | $application | The application
Renvoie
array An array of buttons
Depuis
1.6

Références $context, $default, $icon, $key, $params, $tmp, Route\_(), Factory\getApplication(), PluginHelper\importPlugin(), et null.

Documentation des champs

◆ $buttons

$buttons = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • QuickIconHelper.php


Joomla CMS: Référence de la classe RandomImageHelper

  • Joomla
  • Module
  • RandomImage
  • Site
  • Helper
  • RandomImageHelper
Fonctions membres publiques statiques
Référence de la classe RandomImageHelper

Fonctions membres publiques statiques

static | getRandomImage (&$params, $images)
static | getImages (&$params, $folder)
static | getFolder (&$params)

Description détaillée

Helper for mod_random_image

Depuis
1.5

Documentation des fonctions membres

◆ getFolder()

static getFolder ( & $params )
static

Get sanitized folder

Paramètres
\Joomla\Registry\Registry &$params module params objects
Renvoie
mixed

Références $folder, $params, Uri\base(), JPATH_BASE, JPATH_SITE, et StringHelper\strpos().

◆ getImages()

static getImages | ( | & | $params,
 |  |  | $folder
 | ) |  |
static

Retrieves images from a specific folder

Paramètres
\Joomla\Registry\Registry | &$params | module params
string | $folder | folder to get the images from
Renvoie
array

Références $dir, $folder, $i, $images, $img, $params, $type, et JPATH_BASE.

◆ getRandomImage()

static getRandomImage | ( | & | $params,
 |  |  | $images
 | ) |  |
static

Retrieves a random image

Paramètres
\Joomla\Registry\Registry | &$params | module parameters object
array | $images | list of images
Renvoie
mixed

Références $height, $i, $image, $images, $params, $size, $width, JPATH_BASE, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RandomImageHelper.php


Joomla CMS: Référence de la classe RelatedItemsHelper

  • Joomla
  • Module
  • RelatedItems
  • Site
  • Helper
  • RelatedItemsHelper
Référence de la classe RelatedItemsHelper

Description détaillée

Helper for mod_related_items

Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • RelatedItemsHelper.php


Joomla CMS: Référence de la classe SampledataHelper

  • Joomla
  • Module
  • Sampledata
  • Administrator
  • Helper
  • SampledataHelper
Fonctions membres publiques statiques
Référence de la classe SampledataHelper

Fonctions membres publiques statiques

static getList ()

Description détaillée

Helper for mod_sampledata

Depuis
3.8.0

Documentation des fonctions membres

◆ getList()

static getList ( )
static

Get a list of sampledata.

Renvoie
mixed An array of sampledata, or false on error.
Depuis
3.8.0

Références AbstractEvent\create(), Factory\getApplication(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SampledataHelper.php


Joomla CMS: Référence de la classe StatsHelper

  • Joomla
  • Module
  • Stats
  • Site
  • Helper
  • StatsHelper
Fonctions membres publiques statiques
Référence de la classe StatsHelper

Fonctions membres publiques statiques

static & getList (&$params)

Description détaillée

Helper for mod_stats

Depuis
1.5

Documentation des fonctions membres

◆ getList()

static& getList ( & $params )
static

Get list of stats

Paramètres
\Joomla\Registry\Registry &$params module parameters
Renvoie
array

Références $app, $db, $i, $items, $params, $query, $rows, $serverinfo, $siteinfo, Text\_(), HTMLHelper\_(), ContentComponent\CONDITION_PUBLISHED, Factory\getApplication(), Factory\getDbo(), et PluginHelper\importPlugin().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StatsHelper.php


Joomla CMS: Référence de la classe StatsAdminHelper

  • Joomla
  • Module
  • StatsAdmin
  • Administrator
  • Helper
  • StatsAdminHelper
Fonctions membres publiques statiques
Référence de la classe StatsAdminHelper

Fonctions membres publiques statiques

static getStats (Registry $params, CMSApplication $app, DatabaseInterface $db)

Description détaillée

Helper class for admin stats module

Depuis
3.0

Documentation des fonctions membres

◆ getStats()

static getStats | ( | Registry | $params,
 |  | CMSApplication | $app,
 |  | DatabaseInterface | $db
 | ) |  |
static

Method to retrieve information about the site

Paramètres
Registry | $params | The module parameters
CMSApplication | $app | The application
DatabaseInterface | $db | The database
Renvoie
array Array containing site information
Depuis
3.0

Références $app, $db, $i, $items, $params, $query, $rows, $serverinfo, $siteinfo, $user, Text\_(), Route\_(), PluginHelper\importPlugin(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • StatsAdminHelper.php


Joomla CMS: Référence de la classe Menu

  • Joomla
  • Module
  • Submenu
  • Administrator
  • Menu
  • Menu
Fonctions membres publiques statiques
Référence de la classe Menu

Fonctions membres publiques statiques

static preprocess ($parent)

Description détaillée

Helper class to handle permissions in mod_submenu

Depuis
4.0.0

Documentation des fonctions membres

◆ preprocess()

static preprocess ( $parent )
static

Filter and perform other preparatory tasks for loaded menu items based on access rights and module configurations for display

Paramètres
MenuItem $parent A menu item to process
Renvoie
void
Depuis
4.0.0

Trigger onPreprocessMenuItems for the current level of backend menu items. $children is an array of MenuItem objects. A plugin can traverse the whole tree, but new nodes will only be run through this method if their parents have not been processed yet.

This is needed to populate the element property when the component is no longer installed but its core menu items are left behind.

Références $app, $c, $iconImage, $item, $language, $option, $parts, $query, $temp, $uri, $user, Joomla\CMS\MVC\Model\$workflow, Text\_(), elseif, Factory\getApplication(), Factory\getLanguage(), MenusHelper\getMenuItems(), ComponentHelper\getParams(), ComponentHelper\isEnabled(), Associations\isEnabled(), JPATH_ADMINISTRATOR, null, et ArrayHelper\sortObjects().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/modules/mod_submenu/src/Menu/Menu.php


Joomla CMS: Référence de la classe SyndicateHelper

  • Joomla
  • Module
  • Syndicate
  • Site
  • Helper
  • SyndicateHelper
Fonctions membres publiques statiques
Référence de la classe SyndicateHelper

Fonctions membres publiques statiques

static getLink (Registry $params, HtmlDocument $document)

Description détaillée

Helper for mod_syndicate

Depuis
1.5

Documentation des fonctions membres

◆ getLink()

static getLink | ( | Registry | $params,
 |  | HtmlDocument | $document
 | ) |  |
static

Gets the link

Paramètres
Registry | $params | The module parameters
HtmlDocument | $document | The document
Renvoie
string|null The link as a string, if found
Depuis
1.5

Références $document, $link, $params, $value, null, et ArrayHelper\toString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SyndicateHelper.php


Joomla CMS: Référence de la classe TagsPopularHelper

  • Joomla
  • Module
  • TagsPopular
  • Site
  • Helper
  • TagsPopularHelper
Fonctions membres publiques statiques
Référence de la classe TagsPopularHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_tags_popular

Depuis
3.1

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Get list of popular tags

Paramètres
\Joomla\Registry\Registry &$params module parameters
Renvoie
mixed
Depuis
3.1

Références $db, $groups, $key, $language, $nowDate, $params, $query, $results, $user, Factory\getApplication(), ContentHelper\getCurrentLanguage(), Factory\getDate(), Factory\getDbo(), ComponentHelper\getParams(), Factory\getUser(), et ParameterType\STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TagsPopularHelper.php


Joomla CMS: Référence de la classe TagsSimilarHelper

  • Joomla
  • Module
  • TagsSimilar
  • Site
  • Helper
  • TagsSimilarHelper
Fonctions membres publiques statiques
Référence de la classe TagsSimilarHelper

Fonctions membres publiques statiques

static getList (&$params)

Description détaillée

Helper for mod_tags_similar

Depuis
3.1

Documentation des fonctions membres

◆ getList()

static getList ( & $params )
static

Get a list of tags

Paramètres
Registry &$params Module parameters
Renvoie
array

Références $app, $db, $groups, $id, $language, $now, $option, $ordering, $params, $prefix, $query, $result, $results, $user, $view, Text\_(), elseif, Factory\getApplication(), ContentHelper\getCurrentLanguage(), Factory\getDate(), Factory\getDbo(), RouteHelper\getItemRoute(), ComponentHelper\getParams(), Factory\getUser(), ParameterType\INTEGER, et ParameterType\STRING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TagsSimilarHelper.php


Joomla CMS: Référence de la classe UsersLatestHelper

  • Joomla
  • Module
  • UsersLatest
  • Site
  • Helper
  • UsersLatestHelper
Fonctions membres publiques statiques
Référence de la classe UsersLatestHelper

Fonctions membres publiques statiques

static getUsers ($params)

Description détaillée

Helper for mod_users_latest

Depuis
1.6

Documentation des fonctions membres

◆ getUsers()

static getUsers ( $params )
static

Get users sorted by activation date

Paramètres
\Joomla\Registry\Registry $params module parameters
Renvoie
array The array of users
Depuis
1.6

Références $db, $groups, $params, $query, $user, Text\_(), Factory\getApplication(), Factory\getDbo(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UsersLatestHelper.php


Joomla CMS: Référence de la classe VersionHelper

  • Joomla
  • Module
  • Version
  • Administrator
  • Helper
  • VersionHelper
Fonctions membres publiques statiques
Référence de la classe VersionHelper

Fonctions membres publiques statiques

static getVersion ()

Description détaillée

Helper for mod_version

Depuis
1.6

Documentation des fonctions membres

◆ getVersion()

static getVersion ( )
static

Get the Joomla version number.

Renvoie
string String containing the current Joomla version.

Références $version.

La documentation de cette classe a été générée à partir du fichier suivant :
  • VersionHelper.php


Joomla CMS: Référence de la classe WhosonlineHelper

  • Joomla
  • Module
  • Whosonline
  • Site
  • Helper
  • WhosonlineHelper
Fonctions membres publiques statiques
Référence de la classe WhosonlineHelper

Fonctions membres publiques statiques

static | getOnlineCount ()
static | getOnlineUserNames ($params)

Description détaillée

Helper for mod_whosonline

Depuis
1.5

Documentation des fonctions membres

◆ getOnlineCount()

static getOnlineCount ( )
static

Show online count

Renvoie
array The number of Users and Guests online.
Depuis
1.5

Références $db, $query, $result, Factory\getApplication(), et Factory\getDbo().

◆ getOnlineUserNames()

static getOnlineUserNames ( $params )
static

Show online member names

Paramètres
mixed $params The parameters
Renvoie
array (array) $db->loadObjectList() The names of the online users.
Depuis
1.5

Références $db, $groups, $params, $query, $user, Factory\getApplication(), Factory\getDbo(), et Factory\getUser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WhosonlineHelper.php


Joomla CMS: Référence de la classe WrapperHelper

  • Joomla
  • Module
  • Wrapper
  • Site
  • Helper
  • WrapperHelper
Fonctions membres publiques statiques
Référence de la classe WrapperHelper

Fonctions membres publiques statiques

static getParams (&$params)

Description détaillée

Helper for mod_wrapper

Depuis
1.5

Documentation des fonctions membres

◆ getParams()

static getParams ( & $params )
static

Gets the parameters for the wrapper

Paramètres
mixed &$params The parameters set in the administrator section
Renvoie
mixed &$params The modified parameters
Depuis
1.5

Références $load, $params, $url, elseif, et Factory\getApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • WrapperHelper.php


Joomla CMS: Référence de la classe Client

  • Joomla
  • OAuth1
  • Client
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées
Référence de la classe Client

Fonctions membres publiques

__construct (SessionAwareWebApplicationInterface $application, Http $client=null, Input $input=null, $options=[], $version='1.0a')
authenticate ()
oauthRequest ($url, $method, $parameters, $data=[], $headers=[])
validateResponse ($url, $response)
toUrl ($url, $parameters)
safeEncode ($data)
verifyCredentials ()
getOption ($key, $default=null)
setOption ($key, $value)
getToken ()
setToken ($token)

Fonctions membres publiques statiques

static generateNonce ()

Attributs protégés

$options
$token = []
$client
$input
$application
$version

Fonctions membres privées

generateRequestToken ()
authorise ()
generateAccessToken ()
createHeader (array $parameters)
signRequest (string $url, string $method, array $parameters)
baseString (string $url, string $method, array $parameters)
prepareSigningKey ()

Description détaillée

Joomla Framework class for interacting with an OAuth 1.0 and 1.0a server.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SessionAwareWebApplicationInterface | $application,
 |  | Http | $client = null,
 |  | Input | $input = null,
 |  |  | $options = [],
 |  |  | $version = '1.0a'
 | ) |  |

Constructor.

Paramètres
SessionAwareWebApplicationInterface | $application | The application object
Http | $client | The HTTP client object.
Input | $input | The input object
array | \ArrayAccess | $options | OAuth1 Client options.
string | $version | Specify the OAuth version. By default we are using 1.0a.
Depuis
1.0

Références Client\$application, Client\$client, Client\$input, Client\$options, Client\$version, et HttpFactory\getHttp().

Documentation des fonctions membres

◆ authenticate()

authenticate ( )

Method to form the oauth flow.

Renvoie
array|null The access token.
Depuis
1.0
Exceptions

Références Client\$token, Client\authorise(), Client\generateAccessToken(), Client\generateRequestToken(), null, et Client\verifyCredentials().

◆ authorise()

authorise ( )
private

Method used to authorise the application.

Renvoie
void
Depuis
1.1.2

Références $scope, $url, et Client\getOption().

Référencé par Client\authenticate().

◆ baseString()

baseString | ( | string | $url,
 |  | string | $method,
 |  | array | $parameters
 | ) |  |
private

Prepare the signature base string.

Paramètres
string | $url | The URL to sign.
string | $method | The request method.
array | $parameters | Array containing request parameters.
Renvoie
string The base string.
Depuis
1.1.2

Références $base, $key, $method, $parameters, $params, $url, $value, et Client\safeEncode().

Référencé par Client\signRequest().

◆ createHeader()

createHeader ( array $parameters )
private

Method used to create the header for the POST request.

Paramètres
array $parameters Array containing request parameters.
Renvoie
string The header.
Depuis
1.1.2

Références $header, $key, $parameters, $value, et Client\safeEncode().

Référencé par Client\oauthRequest().

◆ generateAccessToken()

generateAccessToken ( )
private

Method used to get an access token.

Renvoie
void
Depuis
1.1.2

Références $parameters, $params, Client\getOption(), et Client\oauthRequest().

Référencé par Client\authenticate().

◆ generateNonce()

static generateNonce ( )
static

Method used to generate the current nonce.

Renvoie
string The current nonce.
Depuis
1.0

Référencé par Client\oauthRequest().

◆ generateRequestToken()

generateRequestToken ( )
private

Method used to get a request token.

Renvoie
void
Depuis
1.1.2
Exceptions

Références $parameters, $params, Client\getOption(), et Client\oauthRequest().

Référencé par Client\authenticate().

◆ getOption()

getOption | ( | $key,
 |  | $default = null
 | ) |

Get an option from the OAuth1 Client instance.

Paramètres
string | $key | The name of the option to get
mixed | $default | Optional default value if the option does not exist
Renvoie
mixed The option value
Depuis
1.0

Références $default, et $key.

Référencé par Client\authorise(), Client\generateAccessToken(), Client\generateRequestToken(), Client\oauthRequest(), et Client\prepareSigningKey().

◆ getToken()

getToken ( )

Get the oauth token key or secret.

Renvoie
array The oauth token key and secret.
Depuis
1.0

Références Client\$token.

◆ oauthRequest()

oauthRequest | ( | $url,
 |  | $method,
 |  | $parameters,
 |  | $data = [],
 |  | $headers = []
 | ) |

Method used to make an OAuth request.

Paramètres
string | $url | The request URL.
string | $method | The request method.
array | $parameters | Array containing request parameters.
mixed | $data | The POST request data.
array | $headers | An array of name-value pairs to include in the header of the request
Renvoie
Depuis
1.0
Exceptions

Références $data, $method, $parameters, $url, Client\createHeader(), Client\generateNonce(), Client\getOption(), Client\signRequest(), Client\toUrl(), et Client\validateResponse().

Référencé par Client\generateAccessToken(), et Client\generateRequestToken().

◆ prepareSigningKey()

prepareSigningKey ( )
private

Prepares the OAuth signing key.

Renvoie
string The prepared signing key.
Depuis
1.1.2

Références Client\getOption(), et Client\safeEncode().

Référencé par Client\signRequest().

◆ safeEncode()

safeEncode ( $data )

Encodes the string or array passed in a way compatible with OAuth. If an array is passed each array value will will be encoded.

Paramètres
mixed $data The scalar or array to encode.
Renvoie
string $data encoded in a way compatible with OAuth.
Depuis
1.0

Références $data, et $this.

Référencé par Client\baseString(), Client\createHeader(), Client\prepareSigningKey(), et Client\signRequest().

◆ setOption()

setOption | ( | $key,
 |  | $value
 | ) |

Set an option for the OAuth1 Client instance.

Paramètres
string | $key | The name of the option to set
mixed | $value | The option value to set
Renvoie
$this
Depuis
1.0

Références $key, $this, et $value.

◆ setToken()

setToken ( $token )

Set the oauth token.

Paramètres
array $token The access token key and secret.
Renvoie
$this
Depuis
1.0

Références $this, et Client\$token.

◆ signRequest()

signRequest | ( | string | $url,
 |  | string | $method,
 |  | array | $parameters
 | ) |  |
private

Method used to sign requests.

Paramètres
string | $url | The URL to sign.
string | $method | The request method.
array | $parameters | Array containing request parameters.
Renvoie
array The array containing the request parameters, including signature.
Depuis
1.1.2

Références $base, $method, $parameters, Client\baseString(), Client\prepareSigningKey(), et Client\safeEncode().

Référencé par Client\oauthRequest().

◆ toUrl()

toUrl | ( | $url,
 |  | $parameters
 | ) |

Method to create the URL formed string with the parameters.

Paramètres
string | $url | The request URL.
array | $parameters | Array containing request parameters.
Renvoie
string The formed URL.
Depuis
1.0

Références $parameters, $uri, et $url.

Référencé par Client\oauthRequest().

◆ validateResponse()

validateResponse | ( | $url,
 |  | $response
 | ) |
abstract

Method to validate a response.

Paramètres
string | $url | The request URL.
Response | $response | The response to validate.
Renvoie
void
Depuis
1.0
Exceptions

Référencé par Client\oauthRequest().

◆ verifyCredentials()

verifyCredentials ( )
abstract

Returns an HTTP 200 OK response code and a representation of the requesting user if authentication was successful; returns a 401 status code and an error message if not.

Renvoie
array The decoded JSON response
Depuis
1.0

Référencé par Client\authenticate().

Documentation des champs

◆ $application

$application
protected

Référencé par Client\__construct().

◆ $client

$client
protected

Référencé par Client\__construct().

◆ $input

$input
protected

Référencé par Client\__construct().

◆ $options

$options
protected

Référencé par Client\__construct().

◆ $token

$token = []
protected

Référencé par Client\authenticate(), Client\getToken(), et Client\setToken().

◆ $version

$version
protected

Référencé par Client\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • oauth1/src/Client.php


Joomla CMS: Référence de la classe Client

  • Joomla
  • OAuth2
  • Client
Fonctions membres publiques | Attributs protégés
Référence de la classe Client

Fonctions membres publiques

__construct ($options=[], Http $http=null, Input $input=null, WebApplicationInterface $application=null)
authenticate ()
isAuthenticated ()
createUrl ()
query ($url, $data=null, $headers=[], $method='get', $timeout=null)
getOption ($key, $default=null)
setOption ($key, $value)
getToken ()
setToken ($value)
refreshToken ($token=null)

Attributs protégés

$options
$http
$input
$application

Description détaillée

Joomla Framework class for interacting with an OAuth 2.0 server.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $options = [],
 |  | Http | $http = null,
 |  | Input | $input = null,
 |  | WebApplicationInterface | $application = null
 | ) |  |

Constructor.

Paramètres
array | \ArrayAccess | $options | OAuth2 Client options object
Http | $http | The HTTP client object
Input | $input | The input object
WebApplicationInterface | $application | The application object
Depuis
1.0

Références Client\$application, Client\$http, Client\$input, Client\$options, et HttpFactory\getHttp().

Documentation des fonctions membres

◆ authenticate()

authenticate ( )

Get the access token or redirect to the authentication URL.

Renvoie
array|boolean The access token or false on failure
Depuis
1.0
Exceptions
UnexpectedResponseException

Références $data, class, Client\createUrl(), Client\getOption(), et Client\setToken().

◆ createUrl()

createUrl ( )

Create the URL for authentication.

Renvoie
string
Depuis
1.0
Exceptions

Références $key, $scope, $state, $url, $value, et Client\getOption().

Référencé par Client\authenticate().

◆ getOption()

getOption | ( | $key,
 |  | $default = null
 | ) |

Get an option from the OAuth2 Client instance.

Paramètres
string | $key | The name of the option to get
mixed | $default | Optional default value, returned if the requested option does not exist.
Renvoie
mixed The option value
Depuis
1.0

Références $default, et $key.

Référencé par Client\authenticate(), Client\createUrl(), Client\getToken(), Client\query(), et Client\refreshToken().

◆ getToken()

getToken ( )

Get the access token from the Client instance.

Renvoie
array The access token
Depuis
1.0

Références Client\getOption().

Référencé par Client\isAuthenticated(), Client\query(), et Client\refreshToken().

◆ isAuthenticated()

isAuthenticated ( )

Verify if the client has been authenticated

Renvoie
boolean Is authenticated
Depuis
1.0

Références Client\getToken().

◆ query()

query | ( | $url,
 |  | $data = null,
 |  | $headers = [],
 |  | $method = 'get',
 |  | $timeout = null
 | ) |

Send a signed OAuth request.

Paramètres
string | $url | The URL for the request
mixed | $data | Either an associative array or a string to be sent with the request
array | $headers | The headers to send with the request
string | $method | The method with which to send the request
integer | $timeout | The timeout for the request
Renvoie
Depuis
1.0
Exceptions

Références $data, $method, $url, elseif, Client\getOption(), Client\getToken(), et Client\refreshToken().

◆ refreshToken()

refreshToken ( $token = null )

Refresh the access token instance.

Paramètres
string $token The refresh token
Renvoie
array The new access token
Depuis
1.0
Exceptions
UnexpectedResponseException

Références $data, Client\getOption(), Client\getToken(), et Client\setToken().

Référencé par Client\query().

◆ setOption()

setOption | ( | $key,
 |  | $value
 | ) |

Set an option for the OAuth2 Client instance.

Paramètres
string | $key | The name of the option to set
mixed | $value | The option value to set
Renvoie
Client This object for method chaining
Depuis
1.0

Références $key, $this, et $value.

Référencé par Client\setToken().

◆ setToken()

setToken ( $value )

Set an option for the Client instance.

Paramètres
array $value The access token
Renvoie
Client This object for method chaining
Depuis
1.0

Références $this, $value, et Client\setOption().

Référencé par Client\authenticate(), et Client\refreshToken().

Documentation des champs

◆ $application

$application
protected

Référencé par Client\__construct().

◆ $http

$http
protected

Référencé par Client\__construct().

◆ $input

$input
protected

Référencé par Client\__construct().

◆ $options

$options
protected

Référencé par Client\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • oauth2/src/Client.php


Joomla CMS: Référence de la classe Joomla

  • Joomla
  • Plugin
  • Actionlog
  • Joomla
  • Extension
  • Joomla
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe Joomla
+ Graphe d'héritage de Joomla:
ActionLogPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config)
onContentAfterSave ($context, $article, $isNew)
onContentAfterDelete ($context, $article)
onContentChangeState ($context, $pks, $value)
onApplicationAfterSave ($config)
onExtensionAfterInstall ($installer, $eid)
onExtensionAfterUninstall ($installer, $eid, $result)
onExtensionAfterUpdate ($installer, $eid)
onExtensionAfterSave ($context, $table, $isNew)
onExtensionAfterDelete ($context, $table)
onUserAfterSave ($user, $isnew, $success, $msg)
onUserAfterDelete ($user, $success, $msg)
onUserAfterSaveGroup ($context, $table, $isNew)
onUserAfterDeleteGroup ($group, $success, $msg)
onUserAfterLogin ($options)
onUserLoginFailure ($response)
onUserLogout ($user, $options=array())
onUserAfterRemind ($user)
onAfterCheckin ($table)
onAfterLogPurge ($group='')
onAfterLogExport ($group='')
onAfterPurge ($group='all')
onAfterDispatch ()
onJoomlaAfterUpdate ($oldVersion=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

checkLoggable ($extension)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$loggableExtensions = []
$contextAliases = ['com_content.form' => 'com_content.article']
$loggableApi = false
$loggableVerbs = []
- Attributs protégés hérités de ActionLogPlugin
$app
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getActionLogParams ($context)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Joomla! Users Actions Logging Plugin.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
Depuis
3.9.0

Références $config, $params, Symfony\Contracts\Service\__construct(), et ComponentHelper\getComponent().

Documentation des fonctions membres

◆ checkLoggable()

checkLoggable ( $extension )
protected

Function to check if a component is loggable or not

Paramètres
string $extension The extension that triggered the event
Renvoie
boolean
Depuis
3.9.0

Références $extension.

Référencé par Joomla\onAfterCheckin(), Joomla\onAfterDispatch(), Joomla\onAfterPurge(), Joomla\onApplicationAfterSave(), Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), Joomla\onContentChangeState(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterSave(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), Joomla\onUserAfterDelete(), Joomla\onUserAfterDeleteGroup(), Joomla\onUserAfterLogin(), Joomla\onUserAfterRemind(), Joomla\onUserAfterSave(), Joomla\onUserAfterSaveGroup(), Joomla\onUserLoginFailure(), et Joomla\onUserLogout().

◆ getActionLogParams()

getActionLogParams ( $context )
private

Returns the action log params for the given context.

Paramètres
string $context The context of the action log
Renvoie
stdClass The params
Depuis
4.2.0

Références $component, $context, CMSPlugin\getApplication(), et null.

Référencé par Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), Joomla\onContentChangeState(), Joomla\onExtensionAfterDelete(), et Joomla\onExtensionAfterSave().

◆ onAfterCheckin()

onAfterCheckin ( $table )

On after Check-in request

Method is called after user request to check-in items.

Paramètres
array $table Holds the table name.
Renvoie
void
Depuis
3.9.3

Références $context, $message, $user, Joomla\checkLoggable(), Joomla\Database\getDatabase(), et Factory\getUser().

◆ onAfterDispatch()

onAfterDispatch ( )

On after Api dispatched

Method is called after user perform an API request better on onAfterDispatch.

Renvoie
void
Depuis
4.0.0

Références $context, $message, $user, Joomla\checkLoggable(), ENT_QUOTES, et CMSPlugin\getApplication().

◆ onAfterLogExport()

onAfterLogExport ( $group = '' )

On after log export

Method is called after user request to export action log items.

Paramètres
array $group Holds the group name.
Renvoie
void
Depuis
3.9.4

Références $context, $message, $user, CMSPlugin\getApplication(), et Factory\getUser().

◆ onAfterLogPurge()

onAfterLogPurge ( $group = '' )

On after log action purge

Method is called after user request to clean action log items.

Paramètres
array $group Holds the group name.
Renvoie
void
Depuis
3.9.4

Références $context, $message, $user, CMSPlugin\getApplication(), et Factory\getUser().

◆ onAfterPurge()

onAfterPurge ( $group = 'all' )

On after Cache purge

Method is called after user request to clean cached items.

Paramètres
string $group Holds the group name.
Renvoie
void
Depuis
3.9.4

Références $context, $message, $user, Joomla\checkLoggable(), CMSPlugin\getApplication(), et Factory\getUser().

◆ onApplicationAfterSave()

onApplicationAfterSave ( $config )

On Saving application configuration logging method Method is called when the application config is being saved

Paramètres
\Joomla\Registry\Registry $config Registry object with the new config
Renvoie
void
Depuis
3.9.0

Références $message, $option, Joomla\checkLoggable(), et CMSPlugin\getApplication().

◆ onContentAfterDelete()

onContentAfterDelete | ( | $context,
 |  | $article
 | ) |

After delete content logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called right after the content is deleted

Paramètres
string | $context | The context of the content passed to the plugin
object | $article | A JTableContent object
Renvoie
void
Depuis
3.9.0

Références $article, $context, $id, $message, $option, $params, Joomla\checkLoggable(), Joomla\getActionLogParams(), CMSPlugin\getApplication(), et null.

◆ onContentAfterSave()

onContentAfterSave | ( | $context,
 |  | $article,
 |  | $isNew
 | ) |

After save content logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called right after the content is saved

Paramètres
string | $context | The context of the content passed to the plugin
object | $article | A JTableContent object
boolean | $isNew | If the content is just about to be created
Renvoie
void
Depuis
3.9.0

Références $article, $context, $id, $message, $option, $params, Joomla\checkLoggable(), Joomla\getActionLogParams(), CMSPlugin\getApplication(), ActionlogsHelper\getContentTypeLink(), et null.

◆ onContentChangeState()

onContentChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

On content change status logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called when the status of the article is changed

Paramètres
string | $context | The context of the content passed to the plugin
array | $pks | An array of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
3.9.0

Références $context, $db, $items, $message, $messages, $option, $params, $query, $value, Joomla\checkLoggable(), Joomla\getActionLogParams(), CMSPlugin\getApplication(), ActionlogsHelper\getContentTypeLink(), Joomla\Database\getDatabase(), null, et ArrayHelper\toInteger().

◆ onExtensionAfterDelete()

onExtensionAfterDelete | ( | $context,
 |  | $table
 | ) |

On Deleting extensions logging method Method is called when an extension is being deleted

Paramètres
string | $context | The extension
Table | $table | DataBase Table object
Renvoie
void
Depuis
3.9.0

Références $context, $message, $params, Joomla\checkLoggable(), Joomla\getActionLogParams(), CMSPlugin\getApplication(), et null.

◆ onExtensionAfterInstall()

onExtensionAfterInstall | ( | $installer,
 |  | $eid
 | ) |

On installing extensions logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called when an extension is installed

Paramètres
Installer | $installer | Installer object
integer | $eid | Extension Identifier
Renvoie
void
Depuis
3.9.0

Références $context, $manifest, $message, Joomla\checkLoggable(), CMSPlugin\getApplication(), et null.

◆ onExtensionAfterSave()

onExtensionAfterSave | ( | $context,
 |  | $table,
 |  | $isNew
 | ) |

On Saving extensions logging method Method is called when an extension is being saved

Paramètres
string | $context | The extension
Table | $table | DataBase Table object
boolean | $isNew | If the extension is new or not
Renvoie
void
Depuis
3.9.0

Références $context, $message, $option, $params, Joomla\checkLoggable(), Joomla\getActionLogParams(), CMSPlugin\getApplication(), ActionlogsHelper\getContentTypeLink(), et null.

◆ onExtensionAfterUninstall()

onExtensionAfterUninstall | ( | $installer,
 |  | $eid,
 |  | $result
 | ) |

On uninstalling extensions logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called when an extension is uninstalled

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
integer | $result | Installation result
Renvoie
void
Depuis
3.9.0

Références $context, $manifest, $message, $result, Joomla\checkLoggable(), CMSPlugin\getApplication(), et null.

◆ onExtensionAfterUpdate()

onExtensionAfterUpdate | ( | $installer,
 |  | $eid
 | ) |

On updating extensions logging method This method adds a record to #__action_logs contains (message, date, context, user) Method is called when an extension is updated

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
Renvoie
void
Depuis
3.9.0

Références $context, $manifest, $message, Joomla\checkLoggable(), CMSPlugin\getApplication(), et null.

◆ onJoomlaAfterUpdate()

onJoomlaAfterUpdate ( $oldVersion = null )

On after CMS Update

Method is called after user update the CMS.

Paramètres
string $oldVersion The Joomla version before the update
Renvoie
void
Depuis
3.9.21

Références $context, $message, $user, CMSPlugin\getApplication(), et Factory\getUser().

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

On deleting user data logging method

Method is called after user data is deleted from the database

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Depuis
3.9.0

Références $context, $message, $user, Joomla\checkLoggable(), et CMSPlugin\getApplication().

◆ onUserAfterDeleteGroup()

onUserAfterDeleteGroup | ( | $group,
 |  | $success,
 |  | $msg
 | ) |

On deleting user group data logging method

Method is called after user group is deleted from the database

Paramètres
array | $group | Holds the group data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Depuis
3.9.0

Références $context, $message, Joomla\checkLoggable(), et CMSPlugin\getApplication().

◆ onUserAfterLogin()

onUserAfterLogin ( $options )

Method to log user login success action

Paramètres
array $options Array holding options (user, responseType)
Renvoie
void
Depuis
3.9.0

Références $context, $loggedInUser, $message, $options, $this, et Joomla\checkLoggable().

◆ onUserAfterRemind()

onUserAfterRemind ( $user )

On after Remind username request

Method is called after user request to remind their username.

Paramètres
array $user Holds the user data.
Renvoie
void
Depuis
3.9.0

Références $context, $message, $user, Joomla\checkLoggable(), et CMSPlugin\getApplication().

◆ onUserAfterSave()

onUserAfterSave | ( | $user,
 |  | $isnew,
 |  | $success,
 |  | $msg
 | ) |

On saving user data logging method

Method is called after user data is stored in the database. This method logs who created/edited any user's data

Paramètres
array | $user | Holds the new user data.
boolean | $isnew | True if a new user is stored.
boolean | $success | True if user was successfully stored in the database.
string | $msg | Message.
Renvoie
void
Depuis
3.9.0

Références $context, $message, $task, $user, $userId, Joomla\checkLoggable(), elseif, CMSPlugin\getApplication(), et Factory\getUser().

◆ onUserAfterSaveGroup()

onUserAfterSaveGroup | ( | $context,
 |  | $table,
 |  | $isNew
 | ) |

On after save user group data logging method

Method is called after user group is stored into the database

Paramètres
string | $context | The context
Table | $table | DataBase Table object
boolean | $isNew | Is new or not
Renvoie
void
Depuis
3.9.0

Références $context, $message, Joomla\checkLoggable(), et CMSPlugin\getApplication().

◆ onUserLoginFailure()

onUserLoginFailure ( $response )

Method to log user login failed action

Paramètres
array $response Array of response data.
Renvoie
void
Depuis
3.9.0

Références $context, $db, $loggedInUser, $message, $query, $this, Joomla\checkLoggable(), et Joomla\Database\getDatabase().

◆ onUserLogout()

onUserLogout | ( | $user,
 |  | $options = array()
 | ) |

Method to log user's logout action

Paramètres
array | $user | Holds the user data
array | $options | Array holding options (remember, autoregister, group)
Renvoie
void
Depuis
3.9.0

Références $context, $message, $this, $user, Joomla\checkLoggable(), et User\getInstance().

Documentation des champs

◆ $contextAliases

$contextAliases = ['com_content.form' => 'com_content.article']
protected

◆ $loggableApi

$loggableApi = false
protected

◆ $loggableExtensions

$loggableExtensions = []
protected

◆ $loggableVerbs

$loggableVerbs = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Joomla.php


Joomla CMS: Référence de la classe Basic

  • Joomla
  • Plugin
  • ApiAuthentication
  • Basic
  • Extension
  • Basic
Fonctions membres publiques | Attributs privés
Référence de la classe Basic
+ Graphe d'héritage de Basic:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, UserFactoryInterface $userFactory)
onUserAuthenticate ($credentials, $options, &$response)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs privés

$userFactory

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Joomla Authentication plugin

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | UserFactoryInterface | $userFactory
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
UserFactoryInterface | $userFactory | The user factory
Depuis
4.2.0

Références $config, Joomla\CMS\Application\$userFactory, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ onUserAuthenticate()

onUserAuthenticate | ( |  | $credentials,
 |  |  | $options,
 |  | & | $response
 | ) |  |

This method should handle any authentication and report back to the subject

Paramètres
array | $credentials | Array holding the user credentials
array | $options | Array of extra options
object | &$response | Authentication response object
Renvoie
void
Depuis
4.0.0

Références $db, $password, $query, $result, $user, Joomla\Database\getDatabase(), UserHelper\hashPassword(), Authentication\STATUS_FAILURE, et Authentication\STATUS_SUCCESS.

Documentation des champs

◆ $userFactory

$userFactory
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/api-authentication/basic/src/Extension/Basic.php


Joomla CMS: Référence de la classe Token

  • Joomla
  • Plugin
  • ApiAuthentication
  • Token
  • Extension
  • Token
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Token
+ Graphe d'héritage de Token:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, UserFactoryInterface $userFactory, InputFilter $filter)
onUserAuthenticate ($credentials, $options, &$response)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres privées

getTokenSeedForUser (int $userId)
isTokenEnabledForUser (int $userId)
getAllowedUserGroups ()
isInAllowedUserGroup ($userId)

Attributs privés

$profileKeyPrefix = 'joomlatoken'
$allowedAlgos = ['sha256', 'sha512']
$userFactory
$filter

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Joomla Token Authentication plugin

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | UserFactoryInterface | $userFactory,
 |  | InputFilter | $filter
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
UserFactoryInterface | $userFactory | The user factory
InputFilter | $filter | The input filter
Depuis
4.2.0

Références $config, Joomla\CMS\Application\$userFactory, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAllowedUserGroups()

getAllowedUserGroups ( )
private

Get the configured user groups which are allowed to have access to tokens.

Renvoie
int[]
Depuis
4.0.0

◆ getTokenSeedForUser()

getTokenSeedForUser ( int $userId )
private

Retrieve the token seed string for the given user ID.

Paramètres
int $userId The numeric user ID to return the token seed string for.
Renvoie
string|null Null if there is no token configured or the user doesn't exist.
Depuis
4.0.0

Références $db, $query, $userId, Joomla\Database\getDatabase(), ParameterType\INTEGER, null, et ParameterType\STRING.

◆ isInAllowedUserGroup()

isInAllowedUserGroup ( $userId )
private

Is the user with the given ID in the allowed User Groups with access to tokens?

Paramètres
int $userId The user ID to check
Renvoie
boolean False when doesn't belong to allowed user groups, user not found, or guest
Depuis
4.0.0

Références $groups, $user, et $userId.

◆ isTokenEnabledForUser()

isTokenEnabledForUser ( int $userId )
private

Is the token enabled for a given user ID? If the user does not exist or has no token it returns false.

Paramètres
int $userId The User ID to check whether the token is enabled on their account.
Renvoie
boolean
Depuis
4.0.0

Références $db, $query, $userId, $value, Joomla\Database\getDatabase(), ParameterType\INTEGER, et ParameterType\STRING.

◆ onUserAuthenticate()

onUserAuthenticate | ( |  | $credentials,
 |  |  | $options,
 |  | & | $response
 | ) |  |

This method should handle any authentication and report back to the subject

Paramètres
array | $credentials | Array holding the user credentials
array | $options | Array of extra options
object | $response | Authentication response object
Renvoie
void
Depuis
4.0.0

First look for an HTTP Authorization header with the following format: Authorization: Bearer <token> Do keep in mind that Bearer is case-sensitive. Whitespace between Bearer and the token, as well as any whitespace following the token is discarded.

Deconstruct the decoded token string to its three discrete parts: algorithm, user ID and HMAC of the token string saved in the database.

Verify the HMAC algorithm requested in the token string is allowed

Make sure the user ID is an integer

Calculate the reference token data HMAC

Can we log in?

DO NOT concatenate in a single line. Due to boolean short-circuit evaluation it might make timing attacks possible. Using separate lines of code with the previously calculated boolean value to the right hand side forces PHP to evaluate the conditions in approximately constant time.

DO NOT try to be smart and do an early return when either of the individual conditions are not met. There's a reason we only return after checking all three conditions: it prevents timing attacks.

Références $enabled, $parts, $user, $userId, Authentication\STATUS_DENIED, Authentication\STATUS_FAILURE, Authentication\STATUS_SUCCESS, et Crypt\timingSafeCompare().

Documentation des champs

◆ $allowedAlgos

$allowedAlgos = ['sha256', 'sha512']
private

◆ $filter

$filter
private

◆ $profileKeyPrefix

$profileKeyPrefix = 'joomlatoken'
private

◆ $userFactory

$userFactory
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/api-authentication/token/src/Extension/Token.php


Joomla CMS: Référence de la classe Taggable

  • Joomla
  • Plugin
  • Behaviour
  • Taggable
  • Extension
  • Taggable
Fonctions membres publiques statiques
Référence de la classe Taggable
+ Graphe d'héritage de Taggable:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques statiques

static getSubscribedEvents ()

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Implements the Taggable behaviour which allows extensions to automatically support tags for their content items.

This plugin supersedes JHelperObserverTags.

Depuis
4.0.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Taggable.php


Joomla CMS: Référence de la classe Versionable

  • Joomla
  • Plugin
  • Behaviour
  • Versionable
  • Extension
  • Versionable
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Versionable
+ Graphe d'héritage de Versionable:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, InputFilter $filter, CMSHelper $helper)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs privés

$filter
$helper

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Implements the Versionable behaviour which allows extensions to automatically support content history for their content items.

This plugin supersedes JTableObserverContenthistory.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | InputFilter | $filter,
 |  | CMSHelper | $helper
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
InputFilter | $filter | The input filter
CMSHelper | $helper | The CMS helper
Depuis
4.0.0

Références $config, $helper, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

Documentation des champs

◆ $filter

$filter
private

◆ $helper

$helper
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Versionable.php


Joomla CMS: Référence de la classe ConsentBoxField

  • Joomla
  • Plugin
  • Content
  • ConfirmConsent
  • Field
  • ConsentBoxField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe ConsentBoxField
+ Graphe d'héritage de ConsentBoxField:
CheckboxesField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

__set ($name, $value)
__get ($name)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de CheckboxesField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getLabel ()
getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de CheckboxesField
getInput ()
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'ConsentBox'
$forceMultiple = false
$articleid
$menuItemId
$privacyType
- Attributs protégés hérités de CheckboxesField
$type = 'Checkboxes'
$layout = 'joomla.form.field.checkboxes'
$forceMultiple = true
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Fonctions membres privées

getAssignedArticleUrl ()
getAssignedMenuItemUrl ()

Membres hérités additionnels

- Champs de données hérités de CheckboxesField
$checkedOptions
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Consentbox Field class for the Confirm Consent Plugin.

Depuis
3.9.1

Documentation des fonctions membres

◆ __get()

__get ( $name )

Method to get certain otherwise inaccessible properties from the form field object.

Paramètres
string $name The property name for which to get the value.
Renvoie
mixed The property value or null.
Depuis
3.9.1

Références $name.

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Method to set certain otherwise inaccessible properties of the form field object.

Paramètres
string | $name | The property name for which to set the value.
mixed | $value | The value of the property.
Renvoie
void
Depuis
3.9.1

Références $name, et $value.

◆ getAssignedArticleUrl()

getAssignedArticleUrl ( )
private

Return the url of the assigned article based on the current user language

Renvoie
string Returns the link to the article
Depuis
3.9.1

Références $article, $db, $query, Route\_(), RouteHelper\getArticleRoute(), Associations\getAssociations(), Joomla\Database\getDatabase(), Factory\getLanguage(), Associations\isEnabled(), et language.

◆ getAssignedMenuItemUrl()

getAssignedMenuItemUrl ( )
private

Get privacy menu item URL. If the site is a multilingual website and there is associated menu item for the current language, the URL of the associated menu item will be returned.

Renvoie
string
Depuis
4.0.0

Références $db, $itemId, $query, Route\_(), Associations\getAssociations(), Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, Multilanguage\isEnabled(), et Associations\isEnabled().

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
4.0.0

Références HTMLHelper\_(), et Joomla\Application\getInput().

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.9.1

Références $attribs, $data, $position, et HTMLHelper\_().

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.9.1

Références $data.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
::setup()
Depuis
3.9.1

Références $return, et $value.

Documentation des champs

◆ $articleid

$articleid
protected

◆ $forceMultiple

$forceMultiple = false
protected

◆ $menuItemId

$menuItemId
protected

◆ $privacyType

$privacyType
protected

◆ $type

$type = 'ConsentBox'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsentBoxField.php


Joomla CMS: Référence de la classe FontsField

  • Joomla
  • Plugin
  • Editors
  • CodeMirror
  • Field
  • FontsField
Fonctions membres protégées | Attributs protégés
Référence de la classe FontsField
+ Graphe d'héritage de FontsField:
ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Fonts'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Documentation des fonctions membres

◆ getOptions()

getOptions ( )
protected

Method to get the list of fonts field options.

Renvoie
array The field option objects.
Depuis
3.4

Références $info, $key, $options, HTMLHelper\_(), et JPATH_PLUGINS.

Documentation des champs

◆ $type

$type = 'Fonts'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • FontsField.php


Joomla CMS: Référence de la classe TemplatesListField

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
  • Field
  • TemplatesListField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe TemplatesListField
+ Graphe d'héritage de TemplatesListField:
FolderlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
getOptions ()
- Fonctions membres publiques hérités de FolderlistField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FolderlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'templatesList'
- Attributs protégés hérités de FolderlistField
$type = 'Folderlist'
$folderFilter
$exclude
$recursive
$hideNone = false
$hideDefault = false
$directory
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Generates the list of directories available for template snippets.

Depuis
4.1.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for the list of directories.

Renvoie
string The field input markup.
Depuis
4.1.0

Références HTMLHelper\_(), name, et value.

◆ getOptions()

getOptions ( )

Method to get the directories options.

Renvoie
array The dirs option objects.
Depuis
4.1.0

Références $options, Text\_(), et JPATH_ROOT.

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
::setup()
Depuis
4.1.0

Références $return, et $value.

Documentation des champs

◆ $type

$type = 'templatesList'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TemplateslistField.php


Joomla CMS: Référence de la classe TinymcebuilderField

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
  • Field
  • TinymcebuilderField
Fonctions membres protégées | Attributs protégés
Référence de la classe TinymcebuilderField
+ Graphe d'héritage de TinymcebuilderField:
FormField DatabaseAwareInterface

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'tinymcebuilder'
$layout = 'plugins.editors.tinymce.field.tinymcebuilder'
$layoutData = array()
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.7.0

Références $control, $data, $i, $language, elseif, Factory\getApplication(), Form\getInstance(), Factory\getLanguage(), PluginHelper\getPlugin(), JDEBUG, JPATH_PLUGINS, JPATH_ROOT, name, Text\sprintf(), et value.

Documentation des champs

◆ $layout

$layout = 'plugins.editors.tinymce.field.tinymcebuilder'
protected

◆ $layoutData

$layoutData = array()
protected

◆ $type

$type = 'tinymcebuilder'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TinymcebuilderField.php


Joomla CMS: Référence de la classe UploaddirsField

  • Joomla
  • Plugin
  • Editors
  • TinyMCE
  • Field
  • UploaddirsField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe UploaddirsField
+ Graphe d'héritage de UploaddirsField:
FolderlistField ListField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
getOptions ()
- Fonctions membres publiques hérités de FolderlistField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
- Fonctions membres protégées hérités de FolderlistField
getOptions ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'uploaddirs'
- Attributs protégés hérités de FolderlistField
$type = 'Folderlist'
$folderFilter
$exclude
$recursive
$hideNone = false
$hideDefault = false
$directory
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup for the list of directories.

Renvoie
string The field input markup.
Depuis
3.7.0

Références $html, $options, HTMLHelper\_(), name, et value.

◆ getOptions()

getOptions ( )

Method to get the directories options.

Renvoie
array The dirs option objects.
Depuis
3.7.0

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a JForm object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
::setup()
Depuis
3.7.0

Références $return, $value, et ComponentHelper\getParams().

Documentation des champs

◆ $type

$type = 'uploaddirs'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UploaddirsField.php


Joomla CMS: Référence de la classe LocalAdapter

  • Joomla
  • Plugin
  • Filesystem
  • Local
  • Adapter
  • LocalAdapter
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe LocalAdapter
+ Graphe d'héritage de LocalAdapter:
AdapterInterface

Fonctions membres publiques

__construct (string $rootPath, string $filePath)
getFile (string $path='/')
getFiles (string $path='/')
getResource (string $path)
createFolder (string $name, string $path)
createFile (string $name, string $path, $data)
updateFile (string $name, string $path, $data)
delete (string $path)
copy (string $sourcePath, string $destinationPath, bool $force=false)
move (string $sourcePath, string $destinationPath, bool $force=false)
getUrl (string $path)
getAdapterName ()
search (string $path, string $needle, bool $recursive=false)

Fonctions membres privées

getPathInformation (string $path)
getDate ($date=null)
copyFile (string $sourcePath, string $destinationPath, bool $force=false)
copyFolder (string $sourcePath, string $destinationPath, bool $force=false)
moveFile (string $sourcePath, string $destinationPath, bool $force=false)
moveFolder (string $sourcePath, string $destinationPath, bool $force=false)
rglob (string $pattern, int $flags=0)
getEncodedPath (string $path)
getSafeName (string $name)
checkContent (string $localPath, string $mediaContent)
getFileName (string $path)
getLocalPath (string $path)

Attributs privés

$rootPath = null
$filePath = null

Description détaillée

Local file adapter.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $rootPath,
 |  | string | $filePath
 | ) |  |

The absolute root path in the local file system.

Paramètres
string | $rootPath | The root path
string | $filePath | The file path of media folder
Depuis
4.0.0

Références Path\clean().

Documentation des fonctions membres

◆ checkContent()

checkContent | ( | string | $localPath,
 |  | string | $mediaContent
 | ) |  |
private

Performs various check if it is allowed to save the content with the given name.

Paramètres
string | $localPath | The local path
string | $mediaContent | The media content
Renvoie
void
Depuis
4.0.0
Exceptions

Références $helper, $name, Text\_(), Path\clean(), File\delete(), File\getExt(), et File\write().

◆ copy()

copy | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |

Copies a file or folder from source to destination.

It returns the new destination path. This allows the implementation classes to normalise the file name.

Paramètres
string | $sourcePath | The source path
string | $destinationPath | The destination path
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $name, et Path\clean().

◆ copyFile()

copyFile | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |
private

Copies a file

Paramètres
string | $sourcePath | Source path of the file or directory
string | $destinationPath | Destination path of the file or directory
bool | $force | Set true to overwrite files or directories
Renvoie
void
Depuis
4.0.0
Exceptions

Références File\copy().

◆ copyFolder()

copyFolder | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |
private

Copies a folder

Paramètres
string | $sourcePath | Source path of the file or directory
string | $destinationPath | Destination path of the file or directory
bool | $force | Set true to overwrite files or directories
Renvoie
void
Depuis
4.0.0
Exceptions

Références Folder\copy(), et File\delete().

◆ createFile()

createFile | ( | string | $name,
 |  | string | $path,
 |  |  | $data
 | ) |  |

Creates a file with the given name in the given path with the data.

It returns the new file name. This allows the implementation classes to normalise the file name.

Paramètres
string | $name | The name
string | $path | The folder
string | $data | The data
Renvoie
string
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $data, $name, $path, et File\write().

◆ createFolder()

createFolder | ( | string | $name,
 |  | string | $path
 | ) |  |

Creates a folder with the given name in the given path.

It returns the new folder name. This allows the implementation classes to normalise the file name.

Paramètres
string | $name | The name
string | $path | The folder
Renvoie
string
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $name, $path, et Folder\create().

◆ delete()

delete ( string $path )

Deletes the folder or file of the given path.

Paramètres
string $path The path to the file or folder
Renvoie
void
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $path, File\delete(), Folder\delete(), Folder\exists(), et File\exists().

◆ getAdapterName()

getAdapterName ( )

Returns the name of this adapter.

Renvoie
string
Depuis
4.0.0

Implémente AdapterInterface.

◆ getDate()

getDate ( $date = null )
private

Returns a Date with the correct Joomla timezone for the given date.

Paramètres
string $date The date to create a Date from
Renvoie
Date
Depuis
4.0.0

Références $date, $user, Factory\getApplication(), Factory\getDate(), et Factory\getUser().

◆ getEncodedPath()

getEncodedPath ( string $path )
private

Replace spaces on a path with %20

Paramètres
string $path The Path to be encoded
Renvoie
string
Depuis
4.0.0
Exceptions
FileNotFoundException

Références $path.

◆ getFile()

getFile ( string $path = '/' )

Returns the requested file or folder. The returned object has the following properties available:

  • type: The type can be file or dir
  • name: The name of the file
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

If the path doesn't exist a FileNotFoundException is thrown.

Paramètres
string $path The path to the file or folder
Renvoie
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $basePath, et $path.

◆ getFileName()

getFileName ( string $path )
private

Returns the file name of the given path.

Paramètres
string $path The path
Renvoie
string
Depuis
4.0.0
Exceptions

Références $path, et Path\clean().

◆ getFiles()

getFiles ( string $path = '/' )

Returns the folders and files for the given path. The returned objects have the following properties available:

  • type: The type can be file or dir
  • name: The name of the file
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available

If the path doesn't exist a FileNotFoundException is thrown.

Paramètres
string $path The folder
Renvoie
[]
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $basePath, $data, $folder, $path, Path\clean(), Folder\files(), et Folder\folders().

◆ getLocalPath()

getLocalPath ( string $path )
private

Returns the local filesystem path for the given path.

Throws an InvalidPathException if the path is invalid.

Paramètres
string $path The path
Renvoie
string
Depuis
4.0.0
Exceptions
InvalidPathException

Références $path, et Path\check().

◆ getPathInformation()

getPathInformation ( string $path )
private

Returns the folder or file information for the given path. The returned object has the following properties:

  • type: The type can be file or dir
  • name: The name of the file
  • path: The relative path to the root
  • extension: The file extension
  • size: The size of the file
  • create_date: The date created
  • modified_date: The date modified
  • mime_type: The mime type
  • width: The width, when available
  • height: The height, when available
  • thumb_path The thumbnail path of file, when available
Paramètres
string $path The folder
Renvoie
Depuis
4.0.0

Références $path, Text\_(), HTMLHelper\_(), Path\clean(), File\getExt(), Image\getImageFileProperties(), MediaHelper\getMimeType(), et MediaHelper\isImage().

◆ getResource()

getResource ( string $path )

Returns a resource to download the path.

Paramètres
string $path The path to download
Renvoie
resource
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $path.

◆ getSafeName()

getSafeName ( string $name )
private

Creates a safe file name for the given name.

Paramètres
string $name The filename
Renvoie
string
Depuis
4.0.0
Exceptions

Références $extension, $name, Text\_(), File\getExt(), File\makeSafe(), et PunycodeHelper\toPunycode().

◆ getUrl()

getUrl ( string $path )

Returns a url which can be used to display an image from within the "images" directory.

Paramètres
string $path Path of the file relative to adapter
Renvoie
string
Depuis
4.0.0

Implémente AdapterInterface.

Références $path, et Uri\root().

◆ move()

move | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |

Moves a file or folder from source to destination.

It returns the new destination path. This allows the implementation classes to normalise the file name.

Paramètres
string | $sourcePath | The source path
string | $destinationPath | The destination path
bool | $force | Force to overwrite
Renvoie
string
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $name, Text\_(), et Path\clean().

◆ moveFile()

moveFile | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |
private

Moves a file

Paramètres
string | $sourcePath | Absolute path of source
string | $destinationPath | Absolute path of destination
bool | $force | Set true to overwrite file if exists
Renvoie
void
Depuis
4.0.0
Exceptions

Références MediaHelper\checkFileExtension(), et File\move().

◆ moveFolder()

moveFolder | ( | string | $sourcePath,
 |  | string | $destinationPath,
 |  | bool | $force = false
 | ) |  |
private

Moves a folder from source to destination

Paramètres
string | $sourcePath | Source path of the file or directory
string | $destinationPath | Destination path of the file or directory
bool | $force | Set true to overwrite files or directories
Renvoie
void
Depuis
4.0.0
Exceptions

Références $value, Folder\copy(), File\delete(), Folder\delete(), et Folder\move().

◆ rglob()

rglob | ( | string | $pattern,
 |  | int | $flags = 0
 | ) |  |
private

Do a recursive search on a given path

Paramètres
string | $pattern | The pattern for search
int | $flags | Flags for search
Renvoie
array
Depuis
4.0.0

Références $dir.

◆ search()

search | ( | string | $path,
 |  | string | $needle,
 |  | bool | $recursive = false
 | ) |  |

Search for a pattern in a given path

Paramètres
string | $path | The base path for the search
string | $needle | The path to file
bool | $recursive | Do a recursive search
Renvoie
[]
Depuis
4.0.0

Implémente AdapterInterface.

Références $path, $result, $results, et Path\clean().

◆ updateFile()

updateFile | ( | string | $name,
 |  | string | $path,
 |  |  | $data
 | ) |  |

Updates the file with the given name in the given path with the data.

Paramètres
string | $name | The name
string | $path | The folder
string | $data | The data
Renvoie
void
Depuis
4.0.0
Exceptions

Implémente AdapterInterface.

Références $data, $name, $path, File\exists(), et File\write().

Documentation des champs

◆ $filePath

$filePath = null
private

◆ $rootPath

$rootPath = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LocalAdapter.php


Joomla CMS: Référence de la classe Email

  • Joomla
  • Plugin
  • Multifactorauth
  • Email
  • Extension
  • Email
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Email
+ Graphe d'héritage de Email:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserMultifactorGetMethod (GetMethod $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$allowLegacyListeners = false
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

decodeRecordOptions (MfaTable $record)
sendCode (string $key, ?User $user=null)

Attributs privés

const | CODE_LENGTH = 6
const | SECRET_KEY_LENGTH = 20
$mfaMethodName = 'email'

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Multi-factor Authentication using a Validation Code sent by Email.

Requires entering a 6-digit code sent to the user through email. These codes change automatically on a frequency set in the plugin options (30 seconds to 5 minutes, default 2 minutes).

Depuis
4.2.0

Documentation des fonctions membres

◆ decodeRecordOptions()

decodeRecordOptions ( MfaTable $record )
private

Decodes the options from a record into an options object.

Paramètres
MfaTable $record The record to decode
Renvoie
array
Depuis
4.2.0

Références $options.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ onUserMultifactorGetMethod()

onUserMultifactorGetMethod ( GetMethod $event )

Gets the identity of this MFA Method

Paramètres
GetMethod $event The event we are handling
Renvoie
void
Depuis
4.2.0

Références Text\_(), et ResultAwareInterface\addResult().

◆ sendCode()

sendCode | ( | string | $key,
 |  | ?User | $user = null
 | ) |  |
private

Creates a new TOTP code based on secret key $key and sends it to the user via email.

Paramètres
string | $key | The TOTP secret key
User | null | $user | The Joomla! user to use
Renvoie
void
Exceptions
Exception
Depuis
4.2.0

Références $key, $subject, $user, $value, Text\_(), Log\add(), MailTemplate\addRecipient(), Uri\base(), class, Factory\getContainer(), Factory\getMailer(), et Log\WARNING.

Documentation des champs

◆ $allowLegacyListeners

$allowLegacyListeners = false
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $mfaMethodName

$mfaMethodName = 'email'
private

◆ CODE_LENGTH

const CODE_LENGTH = 6
private

Generated OTP length. Constant: 6 numeric digits.

Depuis
4.2.0

◆ SECRET_KEY_LENGTH

const SECRET_KEY_LENGTH = 20
private

Length of the secret key used for generating the OTPs. Constant: 20 characters.

Depuis
4.2.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/multifactorauth/email/src/Extension/Email.php


Joomla CMS: Référence de la classe Fixed

  • Joomla
  • Plugin
  • Multifactorauth
  • Fixed
  • Extension
  • Fixed
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Fixed
+ Graphe d'héritage de Fixed:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserMultifactorGetMethod (GetMethod $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
$allowLegacyListeners = false
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

decodeRecordOptions (MfaTable $record)

Attributs privés

$mfaMethodName = 'fixed'

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Multi-factor Authentication using a fixed code.

Requires a static string (password), different for each user. It effectively works as a second password. The fixed code is stored hashed, like a regular password.

This is NOT to be used on production sites. It serves as a demonstration plugin and as a template for developers to create their own custom Multi-factor Authentication plugins.

Depuis
4.2.0

Documentation des fonctions membres

◆ decodeRecordOptions()

decodeRecordOptions ( MfaTable $record )
private

Decodes the options from a record into an options object.

Paramètres
MfaTable $record The record to decode options for
Renvoie
object
Depuis
4.2.0

Références $options.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ onUserMultifactorGetMethod()

onUserMultifactorGetMethod ( GetMethod $event )

Gets the identity of this MFA Method

Paramètres
GetMethod $event The event we are handling
Renvoie
void
Depuis
4.2.0

Références Text\_(), et ResultAwareInterface\addResult().

Documentation des champs

◆ $allowLegacyListeners

$allowLegacyListeners = false
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $mfaMethodName

$mfaMethodName = 'fixed'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Fixed.php


Joomla CMS: Référence de la classe Totp

  • Joomla
  • Plugin
  • Multifactorauth
  • Totp
  • Extension
  • Totp
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Totp
+ Graphe d'héritage de Totp:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserMultifactorGetMethod (GetMethod $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
$allowLegacyListeners = false
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

decodeRecordOptions (MfaTable $record)

Attributs privés

$mfaMethodName = 'totp'

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Multi-factor Authentication using Google Authenticator TOTP Plugin

Depuis
3.2

Documentation des fonctions membres

◆ decodeRecordOptions()

decodeRecordOptions ( MfaTable $record )
private

Decodes the options from a record into an options object.

Paramètres
MfaTable $record The record to decode options for
Renvoie
array
Depuis
4.2.0

Références $options.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ onUserMultifactorGetMethod()

onUserMultifactorGetMethod ( GetMethod $event )

Gets the identity of this MFA Method

Paramètres
GetMethod $event The event we are handling
Renvoie
void
Depuis
4.2.0

Références Text\_(), et ResultAwareInterface\addResult().

Documentation des champs

◆ $allowLegacyListeners

$allowLegacyListeners = false
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $mfaMethodName

$mfaMethodName = 'totp'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/multifactorauth/totp/src/Extension/Totp.php


Joomla CMS: Référence de la classe Webauthn

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Extension
  • Webauthn
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe Webauthn
+ Graphe d'héritage de Webauthn:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserMultifactorGetMethod (GetMethod $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

$mfaMethodName = 'webauthn'

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla Multi-factor Authentication plugin for WebAuthn

Depuis
4.2.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ onUserMultifactorGetMethod()

onUserMultifactorGetMethod ( GetMethod $event )

Gets the identity of this MFA Method

Paramètres
GetMethod $event The event we are handling
Renvoie
void
Depuis
4.2.0

Références Text\_(), et ResultAwareInterface\addResult().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $mfaMethodName

$mfaMethodName = 'webauthn'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • multifactorauth/webauthn/src/Extension/Webauthn.php


Joomla CMS: Référence de la classe Credentials

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Helper
  • Credentials
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Credentials

Fonctions membres publiques statiques

static | requestAttestation (User $user)
static | verifyAttestation (string $data)

Fonctions membres privées statiques

static | getAvatar (User $user, int $size=64)
static | getUserEntity (User $user)
static | getPubKeyDescriptorsForUser (User $user)

Description détaillée

Helper class to aid in credentials creation (link an authenticator to a user account)

Depuis
4.2.0

Documentation des fonctions membres

◆ getAvatar()

static getAvatar | ( | User | $user,
 |  | int | $size = 64
 | ) |  |
staticprivate

Get the user's avatar (through Gravatar)

Paramètres
User | $user | The Joomla user object
int | $size | The dimensions of the image to fetch (default: 64 pixels)
Renvoie
string The URL to the user's avatar
Depuis
4.2.0

Références $size, $user, et Uri\getInstance().

◆ getPubKeyDescriptorsForUser()

static getPubKeyDescriptorsForUser ( User $user )
staticprivate

Returns an array of the PK credential descriptors (registered authenticators) for the given user.

Paramètres
User $user The user to get the descriptors for
Renvoie
PublicKeyCredentialDescriptor[]
Depuis
4.2.0

Références $user.

◆ getUserEntity()

static getUserEntity ( User $user )
staticprivate

Get a WebAuthn user entity for a Joomla user

Paramètres
User $user The user to get an entity for
Renvoie
PublicKeyCredentialUserEntity
Depuis
4.2.0

Références $user.

◆ requestAttestation()

static requestAttestation ( User $user )
static

Authenticator registration step 1: create a public key for credentials attestation.

The result is a JSON string which can be used in Javascript code with navigator.credentials.create().

Paramètres
User $user The Joomla user to create the public key for
Renvoie
string
Exceptions
Exception On error
Depuis
4.2.0

Références $user, PublicKeyCredentialCreationOptions\ATTESTATION_CONVEYANCE_PREFERENCE_NONE, AuthenticatorSelectionCriteria\AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE, Factory\getApplication(), et AuthenticatorSelectionCriteria\USER_VERIFICATION_REQUIREMENT_PREFERRED.

◆ verifyAttestation()

static verifyAttestation ( string $data )
static

Authenticator registration step 2: verify the credentials attestation by the authenticator

This returns the attested credential data on success.

An exception will be returned on error. Also, under very rare conditions, you may receive NULL instead of attested credential data which means that something was off in the returned data from the browser.

Paramètres
string $data The JSON-encoded data returned by the browser during the authentication flow
Renvoie
AttestedCredentialData|null
Exceptions
Exception When something does not check out
Depuis
4.2.0

Références $data, Text\_(), class, ServerRequestFactory\fromGlobals(), Factory\getApplication(), Factory\getContainer(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Credentials.php


Joomla CMS: Référence de la classe AndroidKeyAttestationStatementSupport

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Hotfix
  • AndroidKeyAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AndroidKeyAttestationStatementSupport
+ Graphe d'héritage de AndroidKeyAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

checkCertificateAndGetPublicKey (string $certificate, string $clientDataHash, AuthenticatorData $authenticatorData)

Attributs privés

$decoder
$metadataStatementRepository

Description détaillée

We had to fork the key attestation support object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The AndroidKeyAttestationStatementSupport class forces an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support class to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |
Paramètres
Decoder | null | $decoder | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Références null.

Documentation des fonctions membres

◆ checkCertificateAndGetPublicKey()

checkCertificateAndGetPublicKey | ( | string | $certificate,
 |  | string | $clientDataHash,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private
Paramètres
string | $certificate | Obvious
string | $clientDataHash | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
void
Exceptions

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références $extension, class, Key\createFromData(), Assertion\eq(), ASNObject\fromBinary(), AuthenticatorData\getAttestedCredentialData(), Assertion\isArray(), Assertion\isInstanceOf(), Assertion\isResource(), Assertion\keyExists(), Assertion\notNull(), et Assertion\true().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
Paramètres
string | $clientDataJSONHash | Obvious
AttestationStatement | $attestationStatement | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
boolean
Exceptions

Implémente AttestationStatementSupport.

Références CertificateToolbox\checkAttestationMedata(), class, AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Algorithms\getOpensslAlgorithmFor(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )
Paramètres
array $attestation Obvious
Renvoie
AttestationStatement
Exceptions

Implémente AttestationStatementSupport.

Références $key, CertificateToolbox\convertAllDERToPEM(), AttestationStatement\createBasic(), Assertion\greaterThan(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )
Renvoie
string
Depuis
4.2.0

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

◆ $metadataStatementRepository

$metadataStatementRepository
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/multifactorauth/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php


Joomla CMS: Référence de la classe FidoU2FAttestationStatementSupport

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Hotfix
  • FidoU2FAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FidoU2FAttestationStatementSupport
+ Graphe d'héritage de FidoU2FAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

extractPublicKey (?string $publicKey)
checkCertificate (string $publicKey)

Attributs privés

$decoder
$metadataStatementRepository

Description détaillée

We had to fork the key attestation support object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The FidoU2FAttestationStatementSupport class forces an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support class to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |
Paramètres
Decoder | null | $decoder | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Références null.

Documentation des fonctions membres

◆ checkCertificate()

checkCertificate ( string $publicKey )
private
Paramètres
string $publicKey Obvious
Renvoie
void
Exceptions

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références class, Assertion\eq(), Assertion\isInstanceOf(), Assertion\isResource(), et Assertion\keyExists().

◆ extractPublicKey()

extractPublicKey ( ?string $publicKey )
private
Paramètres
string | null $publicKey Obvious
Renvoie
string
Exceptions

Références class, Ec2Key\CURVE_P256, Ec2Key\DATA_CURVE, Assertion\isInstanceOf(), Assertion\notNull(), Assertion\true(), et Key\TYPE.

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
Paramètres
string | $clientDataJSONHash | Obvious
AttestationStatement | $attestationStatement | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
boolean
Exceptions

Implémente AttestationStatementSupport.

Références CertificateToolbox\checkAttestationMedata(), class, Assertion\eq(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getRpIdHash(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )
Paramètres
array $attestation Obvious
Renvoie
AttestationStatement
Exceptions

Implémente AttestationStatementSupport.

Références $key, CertificateToolbox\convertAllDERToPEM(), Assertion\count(), AttestationStatement\createBasic(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )
Renvoie
string
Depuis
4.2.0

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

◆ $metadataStatementRepository

$metadataStatementRepository
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/multifactorauth/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php


Joomla CMS: Référence de la classe Server

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • Hotfix
  • Server
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Server
+ Graphe d'héritage de Server:
Server

Fonctions membres publiques

__construct (PublicKeyCredentialRpEntity $relayingParty, PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?MetadataStatementRepository $metadataStatementRepository)
setSelectedAlgorithms (array $selectedAlgorithms)
setTokenBindingHandler (TokenBindingNotSupportedHandler $tokenBindingHandler)
addAlgorithm (string $alias, Algorithm $algorithm)
setExtensionOutputCheckerHandler (ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
generatePublicKeyCredentialRequestOptions (?string $userVerification=PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED, array $allowedPublicKeyDescriptors=[], ?AuthenticationExtensionsClientInputs $extensions=null)
generatePublicKeyCredentialCreationOptions (PublicKeyCredentialUserEntity $userEntity, ?string $attestationMode=PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE, array $excludedPublicKeyDescriptors=[], ?AuthenticatorSelectionCriteria $criteria=null, ?AuthenticationExtensionsClientInputs $extensions=null)
loadAndCheckAttestationResponse (string $data, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $serverRequest)
loadAndCheckAssertionResponse (string $data, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ?PublicKeyCredentialUserEntity $userEntity, ServerRequestInterface $serverRequest)
enforceAndroidSafetyNetVerification (ClientInterface $client, string $apiKey, RequestFactoryInterface $requestFactory)
- Fonctions membres publiques hérités de Server
__construct (PublicKeyCredentialRpEntity $relayingParty, PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?MetadataStatementRepository $metadataStatementRepository)
setSelectedAlgorithms (array $selectedAlgorithms)
setTokenBindingHandler (TokenBindingNotSupportedHandler $tokenBindingHandler)
addAlgorithm (string $alias, Algorithm $algorithm)
setExtensionOutputCheckerHandler (ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
generatePublicKeyCredentialCreationOptions (PublicKeyCredentialUserEntity $userEntity, ?string $attestationMode=PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE, array $excludedPublicKeyDescriptors=[], ?AuthenticatorSelectionCriteria $criteria=null, ?AuthenticationExtensionsClientInputs $extensions=null)
generatePublicKeyCredentialRequestOptions (?string $userVerification=PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED, array $allowedPublicKeyDescriptors=[], ?AuthenticationExtensionsClientInputs $extensions=null)
loadAndCheckAttestationResponse (string $data, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $serverRequest)
loadAndCheckAssertionResponse (string $data, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ?PublicKeyCredentialUserEntity $userEntity, ServerRequestInterface $serverRequest)
enforceAndroidSafetyNetVerification (ClientInterface $client, string $apiKey, RequestFactoryInterface $requestFactory)

Champs de données

$timeout = 60000
$challengeSize = 32
- Champs de données hérités de Server
$timeout = 60000
$challengeSize = 32

Fonctions membres privées

getAttestationStatementSupportManager ()

Attributs privés

$rpEntity
$coseAlgorithmManagerFactory
$publicKeyCredentialSourceRepository
$tokenBindingHandler
$extensionOutputCheckerHandler
$selectedAlgorithms
$metadataStatementRepository
$httpClient
$googleApiKey
$requestFactory

Description détaillée

Customised WebAuthn server object.

We had to fork the server object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The FidoU2FAttestationStatementSupport and AndroidKeyAttestationStatementSupport classes force an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support classes to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

The assertions objects, however, are injected to the attestation support manager in a private method of the Server object. Because literally everything in this class is private we have no option than to fork the entire class to apply our two forked attestation support classes.

This is marked as deprecated because we'll be able to upgrade the WebAuthn library on Joomla 5.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PublicKeyCredentialRpEntity | $relayingParty,
 |  | PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository,
 |  | ?MetadataStatementRepository | $metadataStatementRepository
 | ) |  |

Overridden constructor.

Paramètres
PublicKeyCredentialRpEntity | $relayingParty | Obvious
PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Documentation des fonctions membres

◆ addAlgorithm()

addAlgorithm | ( | string | $alias,
 |  | Algorithm | $algorithm
 | ) |  |
Paramètres
string | $alias | Obvious
Algorithm | $algorithm | Obvious
Renvoie
void
Depuis
4.2.0

◆ enforceAndroidSafetyNetVerification()

enforceAndroidSafetyNetVerification | ( | ClientInterface | $client,
 |  | string | $apiKey,
 |  | RequestFactoryInterface | $requestFactory
 | ) |  |
Paramètres
ClientInterface | $client | Obvious
string | $apiKey | Obvious
RequestFactoryInterface | $requestFactory | Obvious
Renvoie
void
Depuis
4.2.0

Références $client.

◆ generatePublicKeyCredentialCreationOptions()

generatePublicKeyCredentialCreationOptions | ( | PublicKeyCredentialUserEntity | $userEntity,
 |  | ?string | $attestationMode = PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE,
 |  | array | $excludedPublicKeyDescriptors = [],
 |  | ?AuthenticatorSelectionCriteria | $criteria = null,
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
PublicKeyCredentialUserEntity | $userEntity | Obvious
string | null | $attestationMode | Obvious
PublicKeyCredentialDescriptor[] | $excludedPublicKeyDescriptors Obvious
AuthenticatorSelectionCriteria | null | $criteria | Obvious
AuthenticationExtensionsClientInputs | null | $extensions | Obvious
Renvoie
PublicKeyCredentialCreationOptions
Exceptions

Références PublicKeyCredentialDescriptor\CREDENTIAL_TYPE_PUBLIC_KEY.

◆ generatePublicKeyCredentialRequestOptions()

generatePublicKeyCredentialRequestOptions | ( | ?string | $userVerification = PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED,
 |  | array | $allowedPublicKeyDescriptors = [],
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
string | null | $userVerification | Obvious
PublicKeyCredentialDescriptor[] | $allowedPublicKeyDescriptors Obvious
AuthenticationExtensionsClientInputs | null | $extensions | Obvious
Renvoie
PublicKeyCredentialRequestOptions
Exceptions

◆ getAttestationStatementSupportManager()

getAttestationStatementSupportManager ( )
private
Renvoie
AttestationStatementSupportManager
Depuis
4.2.0

Work around a third party library (web-token/jwt-signature-algorithm-eddsa) bug.

On PHP 8 libsodium is compiled into PHP, it is not an extension. However, the third party library does not check if the libsodium function are available; it checks if the "sodium" extension is loaded. This of course causes an immediate failure with a Runtime exception EVEN IF the attested data isn't attested by Android Safety Net. Therefore we have to not even load the AndroidSafetyNetAttestationStatementSupport class in this case...

Références null.

◆ loadAndCheckAssertionResponse()

loadAndCheckAssertionResponse | ( | string | $data,
 |  | PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions,
 |  | ?PublicKeyCredentialUserEntity | $userEntity,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |
Paramètres
string | $data | Obvious
PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions | Obvious
PublicKeyCredentialUserEntity | null | $userEntity | Obvious
ServerRequestInterface | $serverRequest | Obvious
Renvoie
PublicKeyCredentialSource
Exceptions

Références $data, $this, AuthenticatorAssertionResponseValidator\check(), class, PublicKeyCredentialUserEntity\getId(), Assertion\isInstanceOf(), et null.

◆ loadAndCheckAttestationResponse()

loadAndCheckAttestationResponse | ( | string | $data,
 |  | PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |
Paramètres
string | $data | Obvious
PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions | Obvious
ServerRequestInterface | $serverRequest | Obvious
Renvoie
PublicKeyCredentialSource
Exceptions

Références $data, class, et Assertion\isInstanceOf().

◆ setExtensionOutputCheckerHandler()

setExtensionOutputCheckerHandler ( ExtensionOutputCheckerHandler $extensionOutputCheckerHandler )
Paramètres
ExtensionOutputCheckerHandler $extensionOutputCheckerHandler Obvious
Renvoie
void
Depuis
4.2.0

◆ setSelectedAlgorithms()

setSelectedAlgorithms ( array $selectedAlgorithms )
Paramètres
string[] $selectedAlgorithms Obvious
Renvoie
void
Depuis
4.2.0

◆ setTokenBindingHandler()

setTokenBindingHandler ( TokenBindingNotSupportedHandler $tokenBindingHandler )
Paramètres
TokenBindingNotSupportedHandler $tokenBindingHandler Obvious
Renvoie
void
Depuis
4.2.0

Documentation des champs

◆ $challengeSize

$challengeSize = 32

◆ $coseAlgorithmManagerFactory

$coseAlgorithmManagerFactory
private

◆ $extensionOutputCheckerHandler

$extensionOutputCheckerHandler
private

◆ $googleApiKey

$googleApiKey
private

◆ $httpClient

$httpClient
private

◆ $metadataStatementRepository

$metadataStatementRepository
private

◆ $publicKeyCredentialSourceRepository

$publicKeyCredentialSourceRepository
private

◆ $requestFactory

$requestFactory
private

◆ $rpEntity

$rpEntity
private

◆ $selectedAlgorithms

$selectedAlgorithms
private

◆ $timeout

$timeout = 60000

◆ $tokenBindingHandler

$tokenBindingHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/multifactorauth/webauthn/src/Hotfix/Server.php


Joomla CMS: Référence de la classe CredentialRepository

  • Joomla
  • Plugin
  • Multifactorauth
  • Webauthn
  • CredentialRepository
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe CredentialRepository
+ Graphe d'héritage de CredentialRepository:
PublicKeyCredentialSourceRepository

Fonctions membres publiques

__construct (int $userId=0)
findOneByCredentialId (string $publicKeyCredentialId)
- Fonctions membres publiques hérités de PublicKeyCredentialSourceRepository
findAllForUserEntity (PublicKeyCredentialUserEntity $publicKeyCredentialUserEntity)
saveCredentialSource (PublicKeyCredentialSource $publicKeyCredentialSource)

Fonctions membres privées

attestedCredentialToPublicKeyCredentialSource (AttestedCredentialData $record, int $userId)

Attributs privés

$userId = 0

Description détaillée

Implementation of the credentials repository for the WebAuthn library.

Important assumption: interaction with Webauthn through the library is only performed for the currently logged in user. Therefore all Methods which take a credential ID work by checking the Joomla MFA records of the current user only. This is a necessity. The records are stored encrypted, therefore we cannot do a partial search in the table. We have to load the records, decrypt them and inspect them. We cannot do that for thousands of records but we CAN do that for the few records each user has under their account.

This behavior can be changed by passing a user ID in the constructor of the class.

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( int $userId = 0 )

CredentialRepository constructor.

Paramètres
int $userId The user ID this repository will be working with.
Exceptions

Références $user, $userId, class, Factory\getApplication(), et Factory\getContainer().

Documentation des fonctions membres

◆ attestedCredentialToPublicKeyCredentialSource()

attestedCredentialToPublicKeyCredentialSource | ( | AttestedCredentialData | $record,
 |  | int | $userId
 | ) |  |
private

Converts a legacy AttestedCredentialData object stored in the database into a PublicKeyCredentialSource object.

This makes several assumptions which can be problematic and the reason why the WebAuthn library version 2 moved away from attested credentials to public key credential sources:

  • The credential is always of the public key type (that's safe as the only option supported)
  • You can access it with any kind of authenticator transport: USB, NFC, Internal or Bluetooth LE (possibly dangerous)
  • There is no attestations (generally safe since browsers don't seem to support attestation yet)
  • There is no trust path (generally safe since browsers don't seem to provide one)
  • No counter was stored (dangerous since it can lead to replay attacks).
Paramètres
AttestedCredentialData | $record | Legacy attested credential data object
int | $userId | User ID we are getting the credential source for
Renvoie
PublicKeyCredentialSource
Depuis
4.2.0

Références $userId, PublicKeyCredentialDescriptor\AUTHENTICATOR_TRANSPORT_BLE, PublicKeyCredentialDescriptor\AUTHENTICATOR_TRANSPORT_INTERNAL, PublicKeyCredentialDescriptor\AUTHENTICATOR_TRANSPORT_NFC, PublicKeyCredentialDescriptor\AUTHENTICATOR_TRANSPORT_USB, PublicKeyCredentialDescriptor\CREDENTIAL_TYPE_PUBLIC_KEY, AttestedCredentialData\getAaguid(), AttestedCredentialData\getCredentialId(), AttestedCredentialData\getCredentialPublicKey(), et AttestationStatement\TYPE_NONE.

◆ findOneByCredentialId()

findOneByCredentialId ( string $publicKeyCredentialId )

Finds a WebAuthn record given a credential ID

Paramètres
string $publicKeyCredentialId The public credential ID to look for
Renvoie
PublicKeyCredentialSource|null
Depuis
4.2.0

Returns a PublicKeyCredentialSource object given the public key credential ID

Paramètres
string $publicKeyCredentialId The identified of the public key credential we're searching for
Renvoie
PublicKeyCredentialSource|null
Depuis
4.0.0

Implémente PublicKeyCredentialSourceRepository.

Références null.

Documentation des champs

◆ $userId

$userId = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • multifactorauth/webauthn/src/CredentialRepository.php


Joomla CMS: Référence de la classe Yubikey

  • Joomla
  • Plugin
  • Multifactorauth
  • Yubikey
  • Extension
  • Yubikey
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Yubikey
+ Graphe d'héritage de Yubikey:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserMultifactorGetMethod (GetMethod $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
$allowLegacyListeners = false
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

validateYubikeyOtp (string $otp)
decodeRecordOptions (MfaTable $record)
validateAgainstRecord (MfaTable $record, string $code)

Attributs privés

$mfaMethodName = 'yubikey'

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Multi-factor Authentication using Yubikey Plugin

Depuis
4.2.0

Documentation des fonctions membres

◆ decodeRecordOptions()

decodeRecordOptions ( MfaTable $record )
private

Decodes the options from a record into an options object.

Paramètres
MfaTable $record The record to decode
Renvoie
array
Depuis
4.2.0

Références $options.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ onUserMultifactorGetMethod()

onUserMultifactorGetMethod ( GetMethod $event )

Gets the identity of this MFA Method

Paramètres
GetMethod $event The event we are handling
Renvoie
void
Depuis
4.2.0

Références Text\_(), et ResultAwareInterface\addResult().

◆ validateAgainstRecord()

validateAgainstRecord | ( | MfaTable | $record,
 |  | string | $code
 | ) |  |
private
Paramètres
MfaTable | $record | The record to validate against
string | $code | The code given to us by the user
Renvoie
boolean
Exceptions
Exception
Depuis
4.2.0

Références $options.

◆ validateYubikeyOtp()

validateYubikeyOtp ( string $otp )
private

Validates a Yubikey OTP against the Yubikey servers

Paramètres
string $otp The OTP generated by your Yubikey
Renvoie
boolean True if it's a valid OTP
Exceptions
Exception
Depuis
4.2.0

Références $data, $parts, $uri, HttpFactory\getHttp(), Uri\getInstance(), et null.

Documentation des champs

◆ $allowLegacyListeners

$allowLegacyListeners = false
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $mfaMethodName

$mfaMethodName = 'yubikey'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Yubikey.php


Joomla CMS: Référence de la classe Joomlaupdate

  • Joomla
  • Plugin
  • Quickicon
  • Joomlaupdate
  • Extension
  • Joomlaupdate
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe Joomlaupdate
+ Graphe d'héritage de Joomlaupdate:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct ($subject, Document $document, $config=array())
getCoreUpdateNotification (QuickIconsEvent $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

$document

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! update notification plugin

Depuis
2.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $subject,
 |  | Document | $document,
 |  |  | $config = array()
 | ) |  |

Constructor

Paramètres
DispatcherInterface | $subject | The object to observe
Document | $document | The document
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'group', 'params', 'language' (this list is not meant to be comprehensive).
Depuis
4.0.0

Références $config, $document, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getCoreUpdateNotification()

getCoreUpdateNotification ( QuickIconsEvent $event )

This method is called when the Quick Icons module is constructing its set of icons. You can return an array which defines a single icon and it will be rendered right after the stock Quick Icons.

Paramètres
QuickIconsEvent $event The event object
Renvoie
void
Depuis
4.0.0

Références $context, $result, Text\_(), Uri\base(), AbstractEvent\getArgument(), QuickIconsEvent\getContext(), Session\getFormToken(), Text\script(), et AbstractEvent\setArgument().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $document

$document
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Joomlaupdate.php


Joomla CMS: Référence de la classe Cache

  • Joomla
  • Plugin
  • System
  • Cache
  • Extension
  • Cache
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Cache
+ Graphe d'héritage de Cache:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config, DocumentFactoryInterface $documentFactory, CacheControllerFactoryInterface $cacheControllerFactory, ?Profiler $profiler, ?SiteRouter $router)
onAfterRoute (Event $event)
onAfterRender (Event $event)
onAfterRespond (Event $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres privées

appStateSupportsCaching ()
getCacheController ()
getCacheKey ()
isExcluded ()

Attributs privés

$cache
$documentFactory
$cacheControllerFactory
$profiler
$router

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Joomla! Page Cache Plugin.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config,
 |  | DocumentFactoryInterface | $documentFactory,
 |  | CacheControllerFactoryInterface | $cacheControllerFactory,
 |  | ?Profiler | $profiler,
 |  | ?SiteRouter | $router
 | ) |  |

Constructor

Paramètres
DispatcherInterface | $subject | The object to observe
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'group', 'params', 'language' (this list is not meant to be comprehensive).
DocumentFactoryInterface | $documentFactory | The application's document factory
CacheControllerFactoryInterface | $cacheControllerFactory | Cache controller factory
Profiler | null | $profiler | The application profiler
SiteRouter | null | $router | The frontend router
Depuis
4.2.0

Références $config, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ appStateSupportsCaching()

appStateSupportsCaching ( )
private

Does the current application state allow for caching?

The following conditions must be met:

  • This is the frontend application. This plugin does not apply to other applications.
  • This is a GET request. This plugin does not apply to POST, PUT etc.
  • There is no currently logged in user (pages might have user–specific content).
  • The message queue is empty.

The first two tests are cached to make early returns possible; these conditions cannot change throughout the lifetime of the request.

The other two tests MUST NOT be cached because auto–login plugins may fire anytime within the application lifetime logging in a user and messages can be generated anytime within the application's lifetime.

Renvoie
boolean
Depuis
4.2.0

Références null.

◆ getCacheController()

getCacheController ( )
private

Get the cache controller

Renvoie
CacheController
Depuis
4.2.0

Références $options.

◆ getCacheKey()

getCacheKey ( )
private

Get a cache key for the current page based on the url and possible other factors.

Renvoie
string
Depuis
3.7

Références $key, $parts, Uri\getInstance(), et PluginHelper\importPlugin().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of CMS events this plugin will listen to and the respective handlers.

Renvoie
array
Depuis
4.2.0

Note that onAfterRender and onAfterRespond must be the last handlers to run for this plugin to operate as expected. These handlers put pages into cache. We must make sure that a. the page SHOULD be cached and b. we are caching the complete page, as it's output to the browser.

Implémente SubscriberInterface.

Références Priority\LOW.

◆ isExcluded()

isExcluded ( )
private

Check if the page is excluded from the cache or not.

Renvoie
boolean True if the page is excluded else false
Depuis
3.5

Références $active, $results, Uri\getInstance(), et PluginHelper\importPlugin().

◆ onAfterRender()

onAfterRender ( Event $event )

After Render Event. Check whether the current page is excluded from cache.

Paramètres
Event $event The CMS event we are handling.
Renvoie
void
Depuis
3.9.12

◆ onAfterRespond()

onAfterRespond ( Event $event )

After Respond Event. Stores page in cache.

Paramètres
Event $event The application event we are handling.
Renvoie
void
Depuis
1.5

Références Laminas\Diactoros\getBody().

◆ onAfterRoute()

onAfterRoute ( Event $event )

Returns a cached page if the current URL exists in the cache.

Paramètres
Event $event The Joomla event being handled
Renvoie
void
Depuis
4.0.0

Références $data, $document, $results, PluginHelper\importPlugin(), et JDEBUG.

Documentation des champs

◆ $cache

$cache
private

◆ $cacheControllerFactory

$cacheControllerFactory
private

◆ $documentFactory

$documentFactory
private

◆ $profiler

$profiler
private

◆ $router

$router
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/cache/src/Extension/Cache.php


Joomla CMS: Référence de la classe InfoCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • InfoCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe InfoCollector
+ Graphe d'héritage de InfoCollector:
AbstractDataCollector AssetProvider DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

__construct (Registry $params, $requestId)
getName ()
getWidgets ()
getAssets ()
collect ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

getIdentityInfo (User $identity)
getResponseInfo (ResponseInterface $response)
getTemplateInfo ($template)
getDatabaseInfo (array $info)

Attributs privés

$name = 'info'
$requestId

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

InfoDataCollector

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Registry | $params,
 |  |  | $requestId
 | ) |  |

InfoDataCollector constructor.

Paramètres
Registry | $params | Parameters
string | $requestId | Request ID
Depuis
4.0.0

Références $params, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

SiteApplication|AdministratorApplication $application

Implémente DataCollectorInterface.

Références $model, et Factory\getApplication().

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
Depuis
4.0.0
Renvoie
array

Implémente AssetProvider.

Références Uri\root().

◆ getDatabaseInfo()

getDatabaseInfo ( array $info )
private

Get database info.

Paramètres
array $info General information.
Depuis
4.0.0
Renvoie
array

Références $info.

◆ getIdentityInfo()

getIdentityInfo ( User $identity )
private

Get Identity info.

Paramètres
User $identity The identity.
Depuis
4.0.0
Renvoie
array

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getResponseInfo()

getResponseInfo ( ResponseInterface $response )
private

Get response info.

Paramètres
ResponseInterface $response The response.
Depuis
4.0.0
Renvoie
array

Références ResponseInterface\getStatusCode().

◆ getTemplateInfo()

getTemplateInfo ( $template )
private

Get template info.

Paramètres
object $template The template.
Depuis
4.0.0
Renvoie
array

Références $template.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références $name.

Documentation des champs

◆ $name

$name = 'info'
private

◆ $requestId

$requestId
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • InfoCollector.php


Joomla CMS: Référence de la classe LanguageErrorsCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • LanguageErrorsCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe LanguageErrorsCollector
+ Graphe d'héritage de LanguageErrorsCollector:
AbstractDataCollector AssetProvider DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

getData ()
getCount ()

Attributs privés

$name = 'languageErrors'
$count = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

LanguageErrorsDataCollector

Depuis
4.0.0

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

Références DataCollector\getXdebugLinkTemplate(), et JPATH_ROOT.

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
Depuis
4.0.0
Renvoie
array

Implémente AssetProvider.

Références Uri\root().

◆ getCount()

getCount ( )
private

Get a count value.

Renvoie
int
Depuis
4.0.0

Références $count.

◆ getData()

getData ( )
private

Collect data.

Renvoie
array
Depuis
4.0.0

Références Factory\getLanguage().

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références name.

Documentation des champs

◆ $count

$count = 0
private

◆ $name

$name = 'languageErrors'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageErrorsCollector.php


Joomla CMS: Référence de la classe LanguageFilesCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • LanguageFilesCollector
Fonctions membres publiques | Attributs privés
Référence de la classe LanguageFilesCollector
+ Graphe d'héritage de LanguageFilesCollector:
AbstractDataCollector AssetProvider DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs privés

$name = 'languageFiles'
$count = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

LanguageFilesDataCollector

Depuis
4.0.0

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

Références $count, $extension, Factory\getLanguage(), DataCollector\getXdebugLinkTemplate(), et JPATH_ROOT.

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
Depuis
4.0.0
Renvoie
array

Implémente AssetProvider.

Références Uri\root().

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références $name, et name.

Documentation des champs

◆ $count

$count = 0
private

◆ $name

$name = 'languageFiles'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageFilesCollector.php


Joomla CMS: Référence de la classe LanguageStringsCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • LanguageStringsCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe LanguageStringsCollector
+ Graphe d'héritage de LanguageStringsCollector:
AbstractDataCollector AssetProvider DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

getData ()
getCount ()

Attributs privés

$name = 'languageStrings'

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

LanguageStringsDataCollector

Depuis
4.0.0

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

◆ getAssets()

getAssets ( )

Returns an array with the following keys:

  • base_path
  • base_url
  • css: an array of filenames
  • js: an array of filenames
Depuis
4.0.0
Renvoie
array

Implémente AssetProvider.

Références Uri\root().

◆ getCount()

getCount ( )
private

Get a count value.

Renvoie
integer
Depuis
4.0.0

Références Factory\getLanguage().

◆ getData()

getData ( )
private

Collect data.

Renvoie
array
Depuis
4.0.0

Références $class, $data, $i, $item, $location, class, Factory\getLanguage(), DataCollector\getXdebugLinkTemplate(), et JPATH_ROOT.

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références name.

Documentation des champs

◆ $name

$name = 'languageStrings'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageStringsCollector.php


Joomla CMS: Référence de la classe ProfileCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • ProfileCollector
Fonctions membres publiques | Attributs protégés
Référence de la classe ProfileCollector
+ Graphe d'héritage de ProfileCollector:
AbstractDataCollector DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

__construct (Registry $params)
startMeasure ($name, $label=null, $collector=null)
hasStartedMeasure ($name)
stopMeasure ($name, array $params=[])
addMeasure ($label, $start, $end, array $params=[], $collector=null)
measure ($label, \Closure $closure, $collector=null)
getMeasures ()
getRequestStartTime ()
getRequestEndTime ()
getRequestDuration ()
collect ()
getName ()
getWidgets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs protégés

$requestStartTime
$requestEndTime
$startedMeasures = []
$measures = []
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Description détaillée

Collects info about the request duration as well as providing a way to log duration of any operations

Depuis
version

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Registry $params )

Constructor.

Paramètres
Registry $params Parameters.
Depuis
4.0.0

Références $params, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addMeasure()

addMeasure | ( |  | $label,
 |  |  | $start,
 |  |  | $end,
 |  | array | $params = [],
 |  |  | $collector = null
 | ) |  |

Adds a measure

Paramètres
string | $label | A label.
float | $start | Start of request.
float | $end | End of request.
array | $params | Parameters.
string | null | $collector | A collector.
Depuis
4.0.0
Renvoie
void

Références $label, $params, $start, et DataCollector\getDataFormatter().

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

Références $b, $label, $name, $start, DataCollector\getDataFormatter(), et Profiler\getInstance().

◆ getMeasures()

getMeasures ( )

Returns an array of all measures

Depuis
4.0.0
Renvoie
array

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

◆ getRequestDuration()

getRequestDuration ( )

Returns the duration of a request

Depuis
4.0.0
Renvoie
float

Références null.

◆ getRequestEndTime()

getRequestEndTime ( )

Returns the request end time

Depuis
4.0.0
Renvoie
float

◆ getRequestStartTime()

getRequestStartTime ( )

Returns the request start time

Depuis
4.0.0
Renvoie
float

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

◆ hasStartedMeasure()

hasStartedMeasure ( $name )

Check a measure exists

Paramètres
string $name Group name.
Depuis
4.0.0
Renvoie
bool

Références $name.

◆ measure()

measure | ( |  | $label,
 |  | \Closure | $closure,
 |  |  | $collector = null
 | ) |  |

Utility function to measure the execution of a Closure

Paramètres
string | $label | A label.
\Closure | $closure | A closure.
string | null | $collector | A collector.
Depuis
4.0.0
Renvoie
void

Références $label, $name, $params, et $result.

◆ startMeasure()

startMeasure | ( | $name,
 |  | $label = null,
 |  | $collector = null
 | ) |

Starts a measure.

Paramètres
string | $name | Internal name, used to stop the measure
string | null | $label | Public name
string | null | $collector | The source of the collector
Depuis
4.0.0
Renvoie
void

Références $label, $name, et $start.

◆ stopMeasure()

stopMeasure | ( |  | $name,
 |  | array | $params = []
 | ) |  |

Stops a measure.

Paramètres
string | $name | Measurement name.
array | $params | Parameters
Depuis
4.0.0
Exceptions
DebugBarException
Renvoie
void

Références $name, et $params.

Documentation des champs

◆ $measures

$measures = []
protected

◆ $requestEndTime

$requestEndTime
protected

◆ $requestStartTime

$requestStartTime
protected

◆ $startedMeasures

$startedMeasures = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProfileCollector.php


Joomla CMS: Référence de la classe QueryCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • QueryCollector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe QueryCollector
+ Graphe d'héritage de QueryCollector:
AbstractDataCollector AssetProvider DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

__construct (Registry $params, DebugMonitor $queryMonitor, array $profiles, array $explains)
collect ()
getName ()
getWidgets ()
getAssets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Fonctions membres privées

getStatements ()

Attributs privés

$name = 'queries'
$queryMonitor
$profiles
$explains
$accumulatedDuration = 0
$accumulatedMemory = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

QueryDataCollector

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Registry | $params,
 |  | DebugMonitor | $queryMonitor,
 |  | array | $profiles,
 |  | array | $explains
 | ) |  |

Constructor.

Paramètres
Registry | $params | Parameters.
DebugMonitor | $queryMonitor | Query monitor.
array | $profiles | Profile data.
array | $explains | Explain data
Depuis
4.0.0

Références $params, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

Références DataCollector\getDataFormatter(), DataCollector\getXdebugLinkTemplate(), et JPATH_ROOT.

◆ getAssets()

getAssets ( )

Assets for the collector.

Depuis
4.0.0
Renvoie
array

Implémente AssetProvider.

Références Uri\root().

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getStatements()

getStatements ( )
private

Prepare the executed statements data.

Depuis
4.0.0
Renvoie
array

Références $class, $i, $id, $item, $location, class, et DataCollector\getDataFormatter().

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références name.

Documentation des champs

◆ $accumulatedDuration

$accumulatedDuration = 0
private

◆ $accumulatedMemory

$accumulatedMemory = 0
private

◆ $explains

$explains
private

◆ $name

$name = 'queries'
private

◆ $profiles

$profiles
private

◆ $queryMonitor

$queryMonitor
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • QueryCollector.php


Joomla CMS: Référence de la classe SessionCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • DataCollector
  • SessionCollector
Fonctions membres publiques | Attributs privés
Référence de la classe SessionCollector
+ Graphe d'héritage de SessionCollector:
AbstractDataCollector DataCollector Renderable DataCollectorInterface

Fonctions membres publiques

collect ()
getName ()
getWidgets ()
- Fonctions membres publiques hérités de AbstractDataCollector
__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)

Attributs privés

$name = 'session'

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractDataCollector
static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()
- Attributs protégés hérités de AbstractDataCollector
$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Description détaillée

SessionDataCollector

Depuis
4.0.0

Documentation des fonctions membres

◆ collect()

collect ( )

Called by the DebugBar when data needs to be collected

Depuis
4.0.0
Renvoie
array Collected data

Implémente DataCollectorInterface.

Références $data, $key, $value, Factory\getApplication(), DataCollector\getDataFormatter(), et Joomla\Application\getSession().

◆ getName()

getName ( )

Returns the unique name of the collector

Depuis
4.0.0
Renvoie
string

Implémente DataCollectorInterface.

Références $name.

◆ getWidgets()

getWidgets ( )

Returns a hash where keys are control names and their values an array of options as defined in {

Voir également
::addControl()}
Depuis
4.0.0
Renvoie
array

Implémente Renderable.

Références name.

Documentation des champs

◆ $name

$name = 'session'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionCollector.php


Joomla CMS: Référence de la classe FileStorage

  • Joomla
  • Plugin
  • System
  • Debug
  • Storage
  • FileStorage
Fonctions membres publiques
Référence de la classe FileStorage
+ Graphe d'héritage de FileStorage:
FileStorage StorageInterface

Fonctions membres publiques

save ($id, $data)
get ($id)
find (array $filters=[], $max=20, $offset=0)
makeFilename ($id)
- Fonctions membres publiques hérités de FileStorage
__construct ($dirname)
save ($id, $data)
get ($id)
find (array $filters=array(), $max=20, $offset=0)
clear ()
makeFilename ($id)

Membres hérités additionnels

- Fonctions membres protégées hérités de FileStorage
filter ($meta, $filters)
- Attributs protégés hérités de FileStorage
$dirname

Description détaillée

Stores collected data into files

Depuis
4.0.0

Documentation des fonctions membres

◆ find()

find | ( | array | $filters = [],
 |  |  | $max = 20,
 |  |  | $offset = 0
 | ) |  |

Returns a metadata about collected data

Paramètres
array | $filters | Filtering options
integer | $max | The limit, items per page
integer | $offset | The offset
Renvoie
array
Depuis
4.0.0

Implémente StorageInterface.

Références $b, $data, $filters, $i, Joomla\Database\Query\$offset, $results, et null.

◆ get()

get ( $id )

Returns collected data with the specified id

Paramètres
string $id The log id
Renvoie
array
Depuis
4.0.0

Implémente StorageInterface.

Références $id.

◆ makeFilename()

makeFilename ( $id )

Get a full path to the file

Paramètres
string $id The log id
Renvoie
string
Depuis
4.0.0

Références $id.

◆ save()

save | ( | $id,
 |  | $data
 | ) |

Saves collected data

Paramètres
string | $id | The log id
string | $data | The log data
Renvoie
void
Depuis
4.0.0

Implémente StorageInterface.

Références $data, $id, Folder\create(), et File\write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/debug/src/Storage/FileStorage.php


Joomla CMS: Référence de la classe AbstractDataCollector

  • Joomla
  • Plugin
  • System
  • Debug
  • AbstractDataCollector
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés statiques
Référence de la classe AbstractDataCollector
+ Graphe d'héritage de AbstractDataCollector:
DataCollector Renderable DataCollectorInterface InfoCollector LanguageErrorsCollector LanguageFilesCollector LanguageStringsCollector ProfileCollector QueryCollector SessionCollector

Fonctions membres publiques

__construct (Registry $params)
getDataFormatter ()
formatPath ($path)
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataCollector
setDataFormatter (DataFormatterInterface $formater)
getDataFormatter ()
getXdebugLink ($file, $line=1)
setVarDumper (DebugBarVarDumper $varDumper)
getVarDumper ()
formatVar ($var)
formatDuration ($seconds)
formatBytes ($size, $precision=2)
getXdebugLinkTemplate ()
setXdebugLinkTemplate ($xdebugLinkTemplate, $shouldUseAjax=false)
getXdebugShouldUseAjax ()
getXdebugReplacements ()
setXdebugReplacements ($xdebugReplacements)
setXdebugReplacement ($serverPath, $replacement)
- Fonctions membres publiques hérités de DataCollectorInterface
collect ()
getName ()
- Fonctions membres publiques hérités de Renderable
getWidgets ()

Fonctions membres publiques statiques

static | getDefaultDataFormatter ()
- Fonctions membres publiques statiques hérités de DataCollector
static | setDefaultDataFormatter (DataFormatterInterface $formater)
static | getDefaultDataFormatter ()
static | setDefaultVarDumper (DebugBarVarDumper $varDumper)
static | getDefaultVarDumper ()

Attributs protégés

$params
- Attributs protégés hérités de DataCollector
$dataFormater
$varDumper
$xdebugLinkTemplate = ''
$xdebugShouldUseAjax = false
$xdebugReplacements = array()

Attributs privés statiques

static $defaultDataFormatter

Description détaillée

AbstractDataCollector

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Registry $params )

AbstractDataCollector constructor.

Paramètres
Registry $params Parameters.
Depuis
4.0.0

Références $params.

Documentation des fonctions membres

◆ formatCallerInfo()

formatCallerInfo ( array $call )

Format a string from back trace.

Paramètres
array $call The array to format
Renvoie
string
Depuis
4.0.0

◆ formatPath()

formatPath ( $path )

Strip the Joomla! root path.

Paramètres
string $path The path.
Renvoie
string
Depuis
4.0.0

Références $path.

◆ getDataFormatter()

getDataFormatter ( )

Get a data formatter.

Depuis
4.0.0
Renvoie
DataFormatter

Références null.

◆ getDefaultDataFormatter()

static getDefaultDataFormatter ( )
static

Returns the default data formatter

Depuis
4.0.0
Renvoie
DataFormatter

Références null.

Documentation des champs

◆ $defaultDataFormatter

$defaultDataFormatter
staticprivate

◆ $params

$params
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractDataCollector.php


Joomla CMS: Référence de la classe DataFormatter

  • Joomla
  • Plugin
  • System
  • Debug
  • DataFormatter
Fonctions membres publiques
Référence de la classe DataFormatter
+ Graphe d'héritage de DataFormatter:
DataFormatter DataFormatterInterface

Fonctions membres publiques

formatPath ($path, $replacement='')
formatCallerInfo (array $call)
- Fonctions membres publiques hérités de DataFormatter
__construct ()
formatVar ($data)
formatDuration ($seconds)
formatBytes ($size, $precision=2)

Description détaillée

DataFormatter

Depuis
4.0.0

Documentation des fonctions membres

◆ formatCallerInfo()

formatCallerInfo ( array $call )

Format a string from back trace.

Paramètres
array $call The array to format
Renvoie
string
Depuis
4.0.0

Références elseif.

◆ formatPath()

formatPath | ( | $path,
 |  | $replacement = ''
 | ) |

Strip the root path.

Paramètres
string | $path | The path.
string | $replacement | The replacement
Renvoie
string
Depuis
4.0.0

Références $path, et JPATH_ROOT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/debug/src/DataFormatter.php


Joomla CMS: Référence de la classe JavascriptRenderer

  • Joomla
  • Plugin
  • System
  • Debug
  • JavascriptRenderer
Fonctions membres publiques
Référence de la classe JavascriptRenderer
+ Graphe d'héritage de JavascriptRenderer:
JavascriptRenderer

Fonctions membres publiques

__construct (DebugBar $debugBar, $baseUrl=null, $basePath=null)
renderHead ()
render ($initialize=true, $renderStackedData=true)
- Fonctions membres publiques hérités de JavascriptRenderer
__construct (DebugBar $debugBar, $baseUrl=null, $basePath=null)
setOptions (array $options)
setBasePath ($path)
getBasePath ()
setBaseUrl ($url)
getBaseUrl ()
setIncludeVendors ($enabled=true)
areVendorsIncluded ()
disableVendor ($name)
setJavascriptClass ($className)
getJavascriptClass ()
setVariableName ($name)
getVariableName ()
setInitialization ($init)
getInitialization ()
setEnableJqueryNoConflict ($enabled=true)
isJqueryNoConflictEnabled ()
setUseRequireJs ($enabled=true)
isRequireJsUsed ()
addControl ($name, array $options)
disableControl ($name)
getControls ()
ignoreCollector ($name)
getIgnoredCollectors ()
setAjaxHandlerClass ($className)
getAjaxHandlerClass ()
setBindAjaxHandlerToFetch ($bind=true)
isAjaxHandlerBoundToFetch ()
setBindAjaxHandlerToJquery ($bind=true)
isAjaxHandlerBoundToJquery ()
setBindAjaxHandlerToXHR ($bind=true)
isAjaxHandlerBoundToXHR ()
setAjaxHandlerAutoShow ($autoShow=true)
isAjaxHandlerAutoShow ()
setOpenHandlerClass ($className)
getOpenHandlerClass ()
setOpenHandlerUrl ($url)
getOpenHandlerUrl ()
setCspNonce ($nonce=null)
getCspNonce ()
addAssets ($cssFiles, $jsFiles, $basePath=null, $baseUrl=null)
addInlineAssets ($inlineCss, $inlineJs, $inlineHead)
getAssets ($type=null, $relativeTo=self::RELATIVE_PATH)
getAsseticCollection ($type=null)
dumpCssAssets ($targetFilename=null)
dumpJsAssets ($targetFilename=null)
dumpHeadAssets ($targetFilename=null)
renderHead ()
renderOnShutdown ($here=true, $initialize=true, $renderStackedData=true, $head=false)
renderOnShutdownWithHead ($here=true, $initialize=true, $renderStackedData=true)
replaceTagInBuffer ($here=true, $initialize=true, $renderStackedData=true, $head=false)
render ($initialize=true, $renderStackedData=true)

Membres hérités additionnels

- Champs de données hérités de JavascriptRenderer
const | INITIALIZE_CONSTRUCTOR = 2
const | INITIALIZE_CONTROLS = 4
const | REPLACEABLE_TAG = "{--DEBUGBAR_OB_START_REPLACE_ME--}"
const | RELATIVE_PATH = 'path'
const | RELATIVE_URL = 'url'
- Fonctions membres protégées hérités de JavascriptRenderer
getRelativeRoot ($relativeTo, $basePath, $baseUrl)
makeUriRelativeTo ($uri, $root)
filterAssetArray ($array, $type='')
createAsseticCollection ($files=null, $content=null)
dumpAssets ($files=null, $content=null, $targetFilename=null, $useRequireJs=false)
getJsInitializationCode ()
getJsControlsDefinitionCode ($varname)
getAddDatasetCode ($requestId, $data, $suffix=null)
getNonceAttribute ()
- Attributs protégés hérités de JavascriptRenderer
$debugBar
$baseUrl
$basePath
$cssVendors
$jsVendors
$includeVendors = true
$cssFiles = array('debugbar.css', 'widgets.css', 'openhandler.css')
$jsFiles = array('debugbar.js', 'widgets.js', 'openhandler.js')
$additionalAssets = array()
$javascriptClass = 'PhpDebugBar.DebugBar'
$variableName = 'phpdebugbar'
$enableJqueryNoConflict = true
$useRequireJs = false
$initialization
$controls = array()
$ignoredCollectors = array()
$ajaxHandlerClass = 'PhpDebugBar.AjaxHandler'
$ajaxHandlerBindToFetch = false
$ajaxHandlerBindToJquery = true
$ajaxHandlerBindToXHR = false
$ajaxHandlerAutoShow = true
$openHandlerClass = 'PhpDebugBar.OpenHandler'
$openHandlerUrl
$cspNonce

Description détaillée

Custom JavascriptRenderer for DebugBar

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DebugBar | $debugBar,
 |  |  | $baseUrl = null,
 |  |  | $basePath = null
 | ) |  |

Class constructor.

Paramètres
\DebugBar\DebugBar | $debugBar | DebugBar instance
string | $baseUrl | The base URL from which assets will be served
string | $basePath | The path which assets are relative to
Depuis
4.0.0

Références $basePath, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ render()

render | ( | $initialize = true,
 |  | $renderStackedData = true
 | ) |

Returns the code needed to display the debug bar

AJAX request should not render the initialization code.

Paramètres
boolean | $initialize | Whether or not to render the debug bar initialization code
boolean | $renderStackedData | Whether or not to render the stacked data
Renvoie
string
Depuis
4.0.0

Références $data, $doc, $id, $suffix, Factory\getApplication(), et null.

◆ renderHead()

renderHead ( )

Renders the html to include needed assets

Only useful if Assetic is not used

Renvoie
string
Depuis
4.0.0

Références $content, $doc, $html, Factory\getApplication(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/debug/src/JavascriptRenderer.php


Joomla CMS: Référence de la classe JoomlaHttpDriver

  • Joomla
  • Plugin
  • System
  • Debug
  • JoomlaHttpDriver
Fonctions membres publiques | Attributs privés
Référence de la classe JoomlaHttpDriver
+ Graphe d'héritage de JoomlaHttpDriver:
HttpDriverInterface

Fonctions membres publiques

__construct (CMSApplicationInterface $app)
setHeaders (array $headers)
isSessionStarted ()
setSessionValue ($name, $value)
hasSessionValue ($name)
getSessionValue ($name)
deleteSessionValue ($name)

Attributs privés

$app
$session
$dummySession = []

Description détaillée

Joomla HTTP driver for DebugBar

Depuis
4.1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CMSApplicationInterface $app )

Constructor.

Paramètres
CMSApplicationInterface $app
Depuis
4.1.5

Références $app.

Documentation des fonctions membres

◆ deleteSessionValue()

deleteSessionValue ( $name )

Deletes a value from the session

Paramètres
string $name
Depuis
4.1.5

Implémente HttpDriverInterface.

Références $name.

◆ getSessionValue()

getSessionValue ( $name )

Returns a value from the session

Paramètres
string $name
Renvoie
mixed
Depuis
4.1.5

Implémente HttpDriverInterface.

Références $name, et null.

◆ hasSessionValue()

hasSessionValue ( $name )

Checks if a value is in the session

Paramètres
string $name
Renvoie
boolean
Depuis
4.1.5

Implémente HttpDriverInterface.

Références $name.

◆ isSessionStarted()

isSessionStarted ( )

Checks if the session is started

Renvoie
boolean
Depuis
4.1.5

Implémente HttpDriverInterface.

◆ setHeaders()

setHeaders ( array $headers )

Sets HTTP headers

Paramètres
array $headers
Depuis
4.1.5

Implémente HttpDriverInterface.

Références $name, et $value.

◆ setSessionValue()

setSessionValue | ( | $name,
 |  | $value
 | ) |

Sets a value in the session

Paramètres
string | $name
string | $value
Depuis
4.1.5

Implémente HttpDriverInterface.

Références $name, et $value.

Documentation des champs

◆ $app

$app
private

◆ $dummySession

$dummySession = []
private

◆ $session

$session
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • JoomlaHttpDriver.php


Joomla CMS: Référence de la classe PrivacyField

  • Joomla
  • Plugin
  • System
  • PrivacyConsent
  • Field
  • PrivacyField
Fonctions membres protégées | Attributs protégés
Référence de la classe PrivacyField
+ Graphe d'héritage de PrivacyField:
RadioField ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLabel ()
getLayoutData ()
- Fonctions membres protégées hérités de RadioField
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'privacy'
- Attributs protégés hérités de RadioField
$type = 'Radio'
$layout = 'joomla.form.field.radio.buttons'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides input for privacy

Depuis
3.9.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.9.0

Références Joomla\Application\getInput().

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.9.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.9.4

Références $article, $data, $db, $link, $query, Text\_(), Factory\getApplication(), RouteHelper\getArticleRoute(), Joomla\Database\getDatabase(), ParameterType\INTEGER, Multilanguage\isEnabled(), et value.

Documentation des champs

◆ $type

$type = 'privacy'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivacyField.php


Joomla CMS: Référence de la classe Shortcut

  • Joomla
  • Plugin
  • System
  • Shortcut
  • Extension
  • Shortcut
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe Shortcut
+ Graphe d'héritage de Shortcut:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

initialize ()
addShortcuts (Event $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Shortcut plugin to add accessible keyboard shortcuts to the administrator templates.

Depuis
4.2.0

Documentation des fonctions membres

◆ addShortcuts()

addShortcuts ( Event $event )

Add default shortcuts to the document

Paramètres
Event $event The event
Renvoie
void
Depuis
4.2.0

Références Text\_(), Route\_(), AbstractEvent\getArgument(), et Event\setArgument().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

The array keys are event names and the value can be:

  • The method name to call (priority defaults to 0)
  • An array composed of the method name to call and the priority

For instance:

  • array('eventName' => 'methodName')
  • array('eventName' => array('methodName', $priority))
Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

◆ initialize()

initialize ( )

Add the javascript for the shortcuts

Renvoie
void
Depuis
4.2.0

Références $context, $document, $wa, Joomla\CMS\Application\getDispatcher(), et Text\script().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Shortcut.php


Joomla CMS: Référence de la classe AbstractStatsField

  • Joomla
  • Plugin
  • System
  • Stats
  • Field
  • AbstractStatsField
Fonctions membres protégées
Référence de la classe AbstractStatsField
+ Graphe d'héritage de AbstractStatsField:
FormField DatabaseAwareInterface DataField UniqueidField

Fonctions membres protégées

getLayoutPaths ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Base field for the Stats Plugin.

Depuis
3.5

Documentation des fonctions membres

◆ getLayoutPaths()

getLayoutPaths ( )
protected

Get the layouts paths

Renvoie
array
Depuis
3.5

Références $template, Factory\getApplication(), JPATH_ADMINISTRATOR, JPATH_PLUGINS, et JPATH_SITE.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractStatsField.php


Joomla CMS: Référence de la classe DataField

  • Joomla
  • Plugin
  • System
  • Stats
  • Field
  • DataField
Fonctions membres protégées | Attributs protégés
Référence de la classe DataField
+ Graphe d'héritage de DataField:
AbstractStatsField FormField DatabaseAwareInterface

Fonctions membres protégées

getLayoutData ()
- Fonctions membres protégées hérités de AbstractStatsField
getLayoutPaths ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Data'
$layout = 'field.data'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Unique ID Field class for the Stats Plugin.

Depuis
3.5

Documentation des fonctions membres

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.5

Références $data, $result, Factory\getApplication(), et PluginHelper\importPlugin().

Documentation des champs

◆ $layout

$layout = 'field.data'
protected

◆ $type

$type = 'Data'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DataField.php


Joomla CMS: Référence de la classe UniqueidField

  • Joomla
  • Plugin
  • System
  • Stats
  • Field
  • UniqueidField
Attributs protégés
Référence de la classe UniqueidField
+ Graphe d'héritage de UniqueidField:
AbstractStatsField FormField DatabaseAwareInterface

Attributs protégés

$type = 'Uniqueid'
$layout = 'field.uniqueid'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de AbstractStatsField
getLayoutPaths ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Unique ID Field class for the Stats Plugin.

Depuis
3.5

Documentation des champs

◆ $layout

$layout = 'field.uniqueid'
protected

◆ $type

$type = 'Uniqueid'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • UniqueidField.php


Joomla CMS: Référence de la classe Webauthn

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Extension
  • Webauthn
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe Webauthn
+ Graphe d'héritage de Webauthn:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, array $config=[], Authentication $authHelper=null)
getAuthenticationHelper ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
$allowLegacyListeners = false
$authenticationHelper
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

WebAuthn Passwordless Login plugin

The plugin features are broken down into Traits for the sole purpose of making an otherwise supermassive class somewhat manageable. You can find the Traits inside the Webauthn/PluginTraits folder.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  | array | $config = [],
 |  | Authentication | $authHelper = null
 | ) |  |

Constructor. Loads the language files as well.

Paramètres
DispatcherInterface | $subject | The object to observe
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'group', 'params', 'language (this list is not meant to be comprehensive).
Authentication | null | $authHelper | The WebAuthn helper object
Depuis
4.0.0

Note: Do NOT try to load the language in the constructor. This is called before Joomla initializes the application language. Therefore the temporary Joomla language object and all loaded strings in it will be destroyed on application initialization. As a result we need to call loadLanguage() in each method individually, even though all methods make use of language strings.

Références $config, $subject, Symfony\Contracts\Service\__construct(), Log\addLogger(), Log\ALERT, Log\ALL, Log\CRITICAL, Log\EMERGENCY, Log\ERROR, et JDEBUG.

Documentation des fonctions membres

◆ getAuthenticationHelper()

getAuthenticationHelper ( )

Returns the Authentication helper object

Renvoie
Authentication
Depuis
4.2.0

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.2.0

Implémente SubscriberInterface.

Références $app, et Factory\getApplication().

Documentation des champs

◆ $allowLegacyListeners

$allowLegacyListeners = false
protected

◆ $authenticationHelper

$authenticationHelper
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • system/webauthn/src/Extension/Webauthn.php


Joomla CMS: Référence de la classe WebauthnField

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Field
  • WebauthnField
Attributs protégés
Référence de la classe WebauthnField
+ Graphe d'héritage de WebauthnField:
FormField DatabaseAwareInterface

Attributs protégés

$type = 'Webauthn'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Custom Joomla Form Field to display the WebAuthn interface

Depuis
4.0.0

Documentation des champs

◆ $type

$type = 'Webauthn'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • WebauthnField.php


Joomla CMS: Référence de la classe AndroidKeyAttestationStatementSupport

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Hotfix
  • AndroidKeyAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AndroidKeyAttestationStatementSupport
+ Graphe d'héritage de AndroidKeyAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

checkCertificateAndGetPublicKey (string $certificate, string $clientDataHash, AuthenticatorData $authenticatorData)

Attributs privés

$decoder
$metadataStatementRepository

Description détaillée

We had to fork the key attestation support object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The AndroidKeyAttestationStatementSupport class forces an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support class to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |
Paramètres
Decoder | null | $decoder | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Références null.

Documentation des fonctions membres

◆ checkCertificateAndGetPublicKey()

checkCertificateAndGetPublicKey | ( | string | $certificate,
 |  | string | $clientDataHash,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private
Paramètres
string | $certificate | Obvious
string | $clientDataHash | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
void
Exceptions

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références $extension, class, Key\createFromData(), Assertion\eq(), ASNObject\fromBinary(), AuthenticatorData\getAttestedCredentialData(), Assertion\isArray(), Assertion\isInstanceOf(), Assertion\isResource(), Assertion\keyExists(), Assertion\notNull(), et Assertion\true().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
Paramètres
string | $clientDataJSONHash | Obvious
AttestationStatement | $attestationStatement | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
boolean
Exceptions

Implémente AttestationStatementSupport.

Références CertificateToolbox\checkAttestationMedata(), class, AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Algorithms\getOpensslAlgorithmFor(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )
Paramètres
array $attestation Obvious
Renvoie
AttestationStatement
Exceptions

Implémente AttestationStatementSupport.

Références $key, CertificateToolbox\convertAllDERToPEM(), AttestationStatement\createBasic(), Assertion\greaterThan(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )
Renvoie
string
Depuis
4.2.0

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

◆ $metadataStatementRepository

$metadataStatementRepository
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php


Joomla CMS: Référence de la classe FidoU2FAttestationStatementSupport

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Hotfix
  • FidoU2FAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FidoU2FAttestationStatementSupport
+ Graphe d'héritage de FidoU2FAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

extractPublicKey (?string $publicKey)
checkCertificate (string $publicKey)

Attributs privés

$decoder
$metadataStatementRepository

Description détaillée

We had to fork the key attestation support object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The FidoU2FAttestationStatementSupport class forces an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support class to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |
Paramètres
Decoder | null | $decoder | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Références null.

Documentation des fonctions membres

◆ checkCertificate()

checkCertificate ( string $publicKey )
private
Paramètres
string $publicKey Obvious
Renvoie
void
Exceptions

PhpElementIsNotAvailableInCurrentPhpVersionInspection

Références class, Assertion\eq(), Assertion\isInstanceOf(), Assertion\isResource(), et Assertion\keyExists().

◆ extractPublicKey()

extractPublicKey ( ?string $publicKey )
private
Paramètres
string | null $publicKey Obvious
Renvoie
string
Exceptions

Références class, Ec2Key\CURVE_P256, Ec2Key\DATA_CURVE, Assertion\isInstanceOf(), Assertion\notNull(), Assertion\true(), et Key\TYPE.

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
Paramètres
string | $clientDataJSONHash | Obvious
AttestationStatement | $attestationStatement | Obvious
AuthenticatorData | $authenticatorData | Obvious
Renvoie
boolean
Exceptions

Implémente AttestationStatementSupport.

Références CertificateToolbox\checkAttestationMedata(), class, Assertion\eq(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getRpIdHash(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )
Paramètres
array $attestation Obvious
Renvoie
AttestationStatement
Exceptions

Implémente AttestationStatementSupport.

Références $key, CertificateToolbox\convertAllDERToPEM(), Assertion\count(), AttestationStatement\createBasic(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )
Renvoie
string
Depuis
4.2.0

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

◆ $metadataStatementRepository

$metadataStatementRepository
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php


Joomla CMS: Référence de la classe Server

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Hotfix
  • Server
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Server
+ Graphe d'héritage de Server:
Server

Fonctions membres publiques

__construct (PublicKeyCredentialRpEntity $relayingParty, PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?MetadataStatementRepository $metadataStatementRepository)
setSelectedAlgorithms (array $selectedAlgorithms)
setTokenBindingHandler (TokenBindingNotSupportedHandler $tokenBindingHandler)
addAlgorithm (string $alias, Algorithm $algorithm)
setExtensionOutputCheckerHandler (ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
generatePublicKeyCredentialRequestOptions (?string $userVerification=PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED, array $allowedPublicKeyDescriptors=[], ?AuthenticationExtensionsClientInputs $extensions=null)
generatePublicKeyCredentialCreationOptions (PublicKeyCredentialUserEntity $userEntity, ?string $attestationMode=PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE, array $excludedPublicKeyDescriptors=[], ?AuthenticatorSelectionCriteria $criteria=null, ?AuthenticationExtensionsClientInputs $extensions=null)
loadAndCheckAttestationResponse (string $data, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $serverRequest)
loadAndCheckAssertionResponse (string $data, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ?PublicKeyCredentialUserEntity $userEntity, ServerRequestInterface $serverRequest)
enforceAndroidSafetyNetVerification (ClientInterface $client, string $apiKey, RequestFactoryInterface $requestFactory)
- Fonctions membres publiques hérités de Server
__construct (PublicKeyCredentialRpEntity $relayingParty, PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?MetadataStatementRepository $metadataStatementRepository)
setSelectedAlgorithms (array $selectedAlgorithms)
setTokenBindingHandler (TokenBindingNotSupportedHandler $tokenBindingHandler)
addAlgorithm (string $alias, Algorithm $algorithm)
setExtensionOutputCheckerHandler (ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
generatePublicKeyCredentialCreationOptions (PublicKeyCredentialUserEntity $userEntity, ?string $attestationMode=PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE, array $excludedPublicKeyDescriptors=[], ?AuthenticatorSelectionCriteria $criteria=null, ?AuthenticationExtensionsClientInputs $extensions=null)
generatePublicKeyCredentialRequestOptions (?string $userVerification=PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED, array $allowedPublicKeyDescriptors=[], ?AuthenticationExtensionsClientInputs $extensions=null)
loadAndCheckAttestationResponse (string $data, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $serverRequest)
loadAndCheckAssertionResponse (string $data, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ?PublicKeyCredentialUserEntity $userEntity, ServerRequestInterface $serverRequest)
enforceAndroidSafetyNetVerification (ClientInterface $client, string $apiKey, RequestFactoryInterface $requestFactory)

Champs de données

$timeout = 60000
$challengeSize = 32
- Champs de données hérités de Server
$timeout = 60000
$challengeSize = 32

Fonctions membres privées

getAttestationStatementSupportManager ()

Attributs privés

$rpEntity
$coseAlgorithmManagerFactory
$publicKeyCredentialSourceRepository
$tokenBindingHandler
$extensionOutputCheckerHandler
$selectedAlgorithms
$metadataStatementRepository
$httpClient
$googleApiKey
$requestFactory

Description détaillée

Customised WebAuthn server object.

We had to fork the server object from the WebAuthn server package to address an issue with PHP 8.

We are currently using an older version of the WebAuthn library (2.x) which was written before PHP 8 was developed. We cannot upgrade the WebAuthn library to a newer major version because of Joomla's Semantic Versioning promise.

The FidoU2FAttestationStatementSupport and AndroidKeyAttestationStatementSupport classes force an assertion on the result of the openssl_pkey_get_public() function, assuming it will return a resource. However, starting with PHP 8.0 this function returns an OpenSSLAsymmetricKey object and the assertion fails. As a result, you cannot use Android or FIDO U2F keys with WebAuthn.

The assertion check is in a private method, therefore we have to fork both attestation support classes to change the assertion. The assertion takes place through a third party library we cannot (and should not!) modify.

The assertions objects, however, are injected to the attestation support manager in a private method of the Server object. Because literally everything in this class is private we have no option than to fork the entire class to apply our two forked attestation support classes.

This is marked as deprecated because we'll be able to upgrade the WebAuthn library on Joomla 5.

Depuis
4.2.0
Obsolète:
5.0 We will upgrade the WebAuthn library to version 3 or later and this will go away.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PublicKeyCredentialRpEntity | $relayingParty,
 |  | PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository,
 |  | ?MetadataStatementRepository | $metadataStatementRepository
 | ) |  |

Overridden constructor.

Paramètres
PublicKeyCredentialRpEntity | $relayingParty | Obvious
PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository | Obvious
MetadataStatementRepository | null | $metadataStatementRepository | Obvious
Depuis
4.2.0

Documentation des fonctions membres

◆ addAlgorithm()

addAlgorithm | ( | string | $alias,
 |  | Algorithm | $algorithm
 | ) |  |
Paramètres
string | $alias | Obvious
Algorithm | $algorithm | Obvious
Renvoie
void
Depuis
4.2.0

◆ enforceAndroidSafetyNetVerification()

enforceAndroidSafetyNetVerification | ( | ClientInterface | $client,
 |  | string | $apiKey,
 |  | RequestFactoryInterface | $requestFactory
 | ) |  |
Paramètres
ClientInterface | $client | Obvious
string | $apiKey | Obvious
RequestFactoryInterface | $requestFactory | Obvious
Renvoie
void
Depuis
4.2.0

Références $client.

◆ generatePublicKeyCredentialCreationOptions()

generatePublicKeyCredentialCreationOptions | ( | PublicKeyCredentialUserEntity | $userEntity,
 |  | ?string | $attestationMode = PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE,
 |  | array | $excludedPublicKeyDescriptors = [],
 |  | ?AuthenticatorSelectionCriteria | $criteria = null,
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
PublicKeyCredentialUserEntity | $userEntity | Obvious
string | null | $attestationMode | Obvious
PublicKeyCredentialDescriptor[] | $excludedPublicKeyDescriptors Obvious
AuthenticatorSelectionCriteria | null | $criteria | Obvious
AuthenticationExtensionsClientInputs | null | $extensions | Obvious
Renvoie
PublicKeyCredentialCreationOptions
Exceptions

Références PublicKeyCredentialDescriptor\CREDENTIAL_TYPE_PUBLIC_KEY.

◆ generatePublicKeyCredentialRequestOptions()

generatePublicKeyCredentialRequestOptions | ( | ?string | $userVerification = PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED,
 |  | array | $allowedPublicKeyDescriptors = [],
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
string | null | $userVerification | Obvious
PublicKeyCredentialDescriptor[] | $allowedPublicKeyDescriptors Obvious
AuthenticationExtensionsClientInputs | null | $extensions | Obvious
Renvoie
PublicKeyCredentialRequestOptions
Exceptions

◆ getAttestationStatementSupportManager()

getAttestationStatementSupportManager ( )
private
Renvoie
AttestationStatementSupportManager
Depuis
4.2.0

Work around a third party library (web-token/jwt-signature-algorithm-eddsa) bug.

On PHP 8 libsodium is compiled into PHP, it is not an extension. However, the third party library does not check if the libsodium function are available; it checks if the "sodium" extension is loaded. This of course causes an immediate failure with a Runtime exception EVEN IF the attested data isn't attested by Android Safety Net. Therefore we have to not even load the AndroidSafetyNetAttestationStatementSupport class in this case...

Références null.

◆ loadAndCheckAssertionResponse()

loadAndCheckAssertionResponse | ( | string | $data,
 |  | PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions,
 |  | ?PublicKeyCredentialUserEntity | $userEntity,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |
Paramètres
string | $data | Obvious
PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions | Obvious
PublicKeyCredentialUserEntity | null | $userEntity | Obvious
ServerRequestInterface | $serverRequest | Obvious
Renvoie
PublicKeyCredentialSource
Exceptions

Références $data, $this, AuthenticatorAssertionResponseValidator\check(), class, PublicKeyCredentialUserEntity\getId(), Assertion\isInstanceOf(), et null.

◆ loadAndCheckAttestationResponse()

loadAndCheckAttestationResponse | ( | string | $data,
 |  | PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |
Paramètres
string | $data | Obvious
PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions | Obvious
ServerRequestInterface | $serverRequest | Obvious
Renvoie
PublicKeyCredentialSource
Exceptions

Références $data, class, et Assertion\isInstanceOf().

◆ setExtensionOutputCheckerHandler()

setExtensionOutputCheckerHandler ( ExtensionOutputCheckerHandler $extensionOutputCheckerHandler )
Paramètres
ExtensionOutputCheckerHandler $extensionOutputCheckerHandler Obvious
Renvoie
void
Depuis
4.2.0

◆ setSelectedAlgorithms()

setSelectedAlgorithms ( array $selectedAlgorithms )
Paramètres
string[] $selectedAlgorithms Obvious
Renvoie
void
Depuis
4.2.0

◆ setTokenBindingHandler()

setTokenBindingHandler ( TokenBindingNotSupportedHandler $tokenBindingHandler )
Paramètres
TokenBindingNotSupportedHandler $tokenBindingHandler Obvious
Renvoie
void
Depuis
4.2.0

Documentation des champs

◆ $challengeSize

$challengeSize = 32

◆ $coseAlgorithmManagerFactory

$coseAlgorithmManagerFactory
private

◆ $extensionOutputCheckerHandler

$extensionOutputCheckerHandler
private

◆ $googleApiKey

$googleApiKey
private

◆ $httpClient

$httpClient
private

◆ $metadataStatementRepository

$metadataStatementRepository
private

◆ $publicKeyCredentialSourceRepository

$publicKeyCredentialSourceRepository
private

◆ $requestFactory

$requestFactory
private

◆ $rpEntity

$rpEntity
private

◆ $selectedAlgorithms

$selectedAlgorithms
private

◆ $timeout

$timeout = 60000

◆ $tokenBindingHandler

$tokenBindingHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/webauthn/src/Hotfix/Server.php


Joomla CMS: Référence de la classe Authentication

  • Joomla
  • Plugin
  • System
  • Webauthn
  • Authentication
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Authentication

Fonctions membres publiques

__construct (ApplicationInterface $app=null, SessionInterface $session=null, PublicKeyCredentialSourceRepository $credRepo=null, ?MetadataStatementRepository $mdsRepo=null)
getKnownAuthenticators ()
getCredentialsRepository ()
getMetadataRepository ()
getPubKeyCreationOptions (User $user)
getPubkeyRequestOptions (User $user)
validateAssertionResponse (string $data, User $user)
hasAttestationSupport ()
setAttestationSupport (bool $attestationSupport)

Fonctions membres privées

getSiteIcon ()
getUserEntity (User $user)
getAvatar (User $user, int $size=64)
getPubKeyDescriptorsForUser (User $user)
getPKCredentialRequestOptions ()
getWebauthnServer ()

Attributs privés

$credentialsRepository
$app
$session
$metadataRepository
$attestationSupport = true

Description détaillée

Helper class to aid in credentials creation (link an authenticator to a user account)

Depuis
4.2.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ApplicationInterface | $app = null,
 |  | SessionInterface | $session = null,
 |  | PublicKeyCredentialSourceRepository | $credRepo = null,
 |  | ?MetadataStatementRepository | $mdsRepo = null
 | ) |  |

Public constructor.

Paramètres
ApplicationInterface | null | $app | The app we are running in
SessionInterface | null | $session | The app session object
PublicKeyCredentialSourceRepository | null | $credRepo | Credentials repo
MetadataStatementRepository | null | $mdsRepo | Authenticator metadata repo
Depuis
4.2.0

Références $app.

Documentation des fonctions membres

◆ getAvatar()

getAvatar | ( | User | $user,
 |  | int | $size = 64
 | ) |  |
private

Get the user's avatar (through Gravatar)

Paramètres
User | $user | The Joomla user object
int | $size | The dimensions of the image to fetch (default: 64 pixels)
Renvoie
string The URL to the user's avatar
Depuis
4.2.0

Références $size, $user, et Uri\getInstance().

◆ getCredentialsRepository()

getCredentialsRepository ( )

Returns the Public Key credential source repository object

Renvoie
PublicKeyCredentialSourceRepository|null
Depuis
4.2.0

◆ getKnownAuthenticators()

getKnownAuthenticators ( )

Get the known FIDO authenticators and their metadata

Renvoie
object[]
Depuis
4.2.0

Références $image, $return, Text\_(), HTMLHelper\_(), JPATH_BASE, JPATH_ROOT, et Uri\root().

◆ getMetadataRepository()

getMetadataRepository ( )

Returns the authenticator metadata repository object

Renvoie
MetadataStatementRepository|null
Depuis
4.2.0

◆ getPKCredentialRequestOptions()

getPKCredentialRequestOptions ( )
private

Retrieve the public key credential request options saved in the session.

If they do not exist or are corrupt it is a hacking attempt and we politely tell the attacker to go away.

Renvoie
PublicKeyCredentialRequestOptions
Exceptions
Exception
Depuis
4.2.0

Références Text\_(), Log\add(), Log\NOTICE, et null.

◆ getPubKeyCreationOptions()

getPubKeyCreationOptions ( User $user )

Generate the public key creation options.

This is used for the first step of attestation (key registration).

The PK creation options and the user ID are stored in the session.

Paramètres
User $user The Joomla user to create the public key for
Renvoie
PublicKeyCredentialCreationOptions
Exceptions
Exception
Depuis
4.2.0

We will only ask for attestation information if our MDS is guaranteed not empty.

We check that by trying to load a known good AAGUID (Yubico Security Key NFC). If it's missing, we have failed to load the MDS data e.g. we could not contact the server, it was taking too long, the cache is unwritable etc. In this case asking for attestation conveyance would cause the attestation to fail (since we cannot verify its signature). Therefore we have to ask for no attestation to be conveyed. The downside is that in this case we do not have any information about the make and model of the authenticator. So be it! After all, that's a convenience feature for us.

Références $user, PublicKeyCredentialCreationOptions\ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT, PublicKeyCredentialCreationOptions\ATTESTATION_CONVEYANCE_PREFERENCE_NONE, AuthenticatorSelectionCriteria\AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE, et AuthenticatorSelectionCriteria\USER_VERIFICATION_REQUIREMENT_PREFERRED.

◆ getPubKeyDescriptorsForUser()

getPubKeyDescriptorsForUser ( User $user )
private

Returns an array of the PK credential descriptors (registered authenticators) for the given user.

Paramètres
User $user The Joomla user to get the PK descriptors for
Renvoie
PublicKeyCredentialDescriptor[]
Depuis
4.2.0

Références $user.

◆ getPubkeyRequestOptions()

getPubkeyRequestOptions ( User $user )

Get the public key request options.

This is used in the first step of the assertion (login) flow.

Paramètres
User $user The Joomla user to get the PK request options for
Renvoie
PublicKeyCredentialRequestOptions
Exceptions
Exception
Depuis
4.2.0

Références $user, Log\add(), Log\DEBUG, et PublicKeyCredentialRequestOptions\USER_VERIFICATION_REQUIREMENT_PREFERRED.

◆ getSiteIcon()

getSiteIcon ( )
private

Try to find the site's favicon in the site's root, images, media, templates or current template directory.

Renvoie
string|null
Depuis
4.2.0

Références $path, Uri\base(), JPATH_BASE, et null.

◆ getUserEntity()

getUserEntity ( User $user )
private

Returns a User Entity object given a Joomla user

Paramètres
User $user The Joomla user to get the user entity for
Renvoie
PublicKeyCredentialUserEntity
Depuis
4.2.0

Références $user.

◆ getWebauthnServer()

getWebauthnServer ( )
private

Get the WebAuthn library's Server object which facilitates WebAuthn operations

Renvoie
Server
Exceptions
Exception
Depuis
4.2.0

Références Uri\getInstance().

◆ hasAttestationSupport()

hasAttestationSupport ( )

Get the authentiactor attestation support.

Renvoie
boolean
Depuis
4.2.0

◆ setAttestationSupport()

setAttestationSupport ( bool $attestationSupport )

Change the authenticator attestation support.

Paramètres
bool $attestationSupport The desired setting
Renvoie
void
Depuis
4.2.0

◆ validateAssertionResponse()

validateAssertionResponse | ( | string | $data,
 |  | User | $user
 | ) |  |

Validate the authenticator assertion.

This is used in the second step of the assertion (login) flow. The server verifies that the assertion generated by the authenticator has not been tampered with.

Paramètres
string | $data | The data
User | $user | The user we are trying to log in
Renvoie
PublicKeyCredentialSource
Exceptions
Exception
Depuis
4.2.0

Références $data, $user, Text\_(), Log\add(), ServerRequestFactory\fromGlobals(), Log\NOTICE, et null.

Documentation des champs

◆ $app

$app
private

◆ $attestationSupport

$attestationSupport = true
private

◆ $credentialsRepository

$credentialsRepository
private

◆ $metadataRepository

$metadataRepository
private

◆ $session

$session
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/webauthn/src/Authentication.php


Joomla CMS: Référence de la classe CredentialRepository

  • Joomla
  • Plugin
  • System
  • Webauthn
  • CredentialRepository
Fonctions membres publiques | Fonctions membres privées
Référence de la classe CredentialRepository
+ Graphe d'héritage de CredentialRepository:
PublicKeyCredentialSourceRepository DatabaseAwareInterface

Fonctions membres publiques

__construct (DatabaseInterface $db=null)
getUserHandleFor (string $credentialId)
getHandleFromUserId (int $id)
- Fonctions membres publiques hérités de PublicKeyCredentialSourceRepository
findOneByCredentialId (string $publicKeyCredentialId)
findAllForUserEntity (PublicKeyCredentialUserEntity $publicKeyCredentialUserEntity)
saveCredentialSource (PublicKeyCredentialSource $publicKeyCredentialSource)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres privées

encryptCredential (string $credential)
decryptCredential (string $credential)
formatDate ($date, ?string $format=null, bool $tzAware=true)

Description détaillée

Handles the storage of WebAuthn credentials in the database

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db = null )

Public constructor.

Paramètres
DatabaseInterface | null $db The database driver object to use for persistence.
Depuis
4.2.0

Références $db, et Joomla\Database\setDatabase().

Documentation des fonctions membres

◆ decryptCredential()

decryptCredential ( string $credential )
private

Decrypt the credential source if it was already encrypted in the database

Paramètres
string $credential The encrypted credential source, base64 encoded
Renvoie
string The decrypted, JSON-encoded credential source
Depuis
4.0.0

Références $key.

◆ encryptCredential()

encryptCredential ( string $credential )
private

Encrypt the credential source before saving it to the database

Paramètres
string $credential The unencrypted, JSON-encoded credential source
Renvoie
string The encrypted credential source, base64 encoded
Depuis
4.0.0

Références $key.

◆ formatDate()

formatDate | ( |  | $date,
 |  | ?string | $format = null,
 |  | bool | $tzAware = true
 | ) |  |
private

Format a date for display.

The $tzAware parameter defines whether the formatted date will be timezone-aware. If set to false the formatted date will be rendered in the UTC timezone. If set to true the code will automatically try to use the logged in user's timezone or, if none is set, the site's default timezone (Server Timezone). If set to a positive integer the same thing will happen but for the specified user ID instead of the currently logged in user.

Paramètres
string | \DateTime | $date | The date to format
string | null | $format | The format string, default is Joomla's DATE_FORMAT_LC6 (usually "Y-m-d H:i:s")
bool | $tzAware | Should the format be timezone aware? See notes above.
Renvoie
string
Depuis
4.2.0

Références $date, $format, $user, $userId, Text\_(), class, Factory\getApplication(), Factory\getContainer(), et null.

◆ getHandleFromUserId()

getHandleFromUserId ( int $id )

Return a user handle given an integer Joomla user ID. We use the HMAC-SHA-256 of the user ID with the site's secret as the key. Using it instead of SHA-512 is on purpose! WebAuthn only allows user handles up to 64 bytes long.

Paramètres
int $id The user ID to convert
Renvoie
string The user handle (HMAC-SHA-256 of the user ID)
Depuis
4.0.0

Références $data, $id, et $key.

◆ getUserHandleFor()

getUserHandleFor ( string $credentialId )

Return the user handle for the stored credential given its ID.

The user handle must not be personally identifiable. Per https://w3c.github.io/webauthn/#user-handle it is acceptable to have a salted hash with a salt private to our server, e.g. Joomla's secret. The only immutable information in Joomla is the user ID so that's what we will be using.

Paramètres
string $credentialId The credential ID to get the user handle for
Renvoie
string
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • system/webauthn/src/CredentialRepository.php


Joomla CMS: Référence de la classe MetadataRepository

  • Joomla
  • Plugin
  • System
  • Webauthn
  • MetadataRepository
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe MetadataRepository
+ Graphe d'héritage de MetadataRepository:
MetadataStatementRepository

Fonctions membres publiques

findOneByAAGUID (string $aaguid)
getKnownAuthenticators ()

Fonctions membres privées

load ()

Attributs privés

$mdsCache = []
$mdsMap = []
$loaded = false

Description détaillée

Authenticator metadata repository.

This repository contains the metadata of all FIDO authenticators as published by the FIDO Alliance in their MDS version 3.0.

Voir également
https://fidoalliance.org/metadata/
Depuis
4.2.0

Documentation des fonctions membres

◆ findOneByAAGUID()

findOneByAAGUID ( string $aaguid )

Find an authenticator metadata statement given an AAGUID

Paramètres
string $aaguid The AAGUID to find
Renvoie
MetadataStatement|null The metadata statement; null if the AAGUID is unknown
Depuis
4.2.0

Implémente MetadataStatementRepository.

Références null.

◆ getKnownAuthenticators()

getKnownAuthenticators ( )

Get basic information of the known FIDO authenticators by AAGUID

Renvoie
object[]
Depuis
4.2.0

Références $return, et null.

◆ load()

load ( )
private

Load the authenticator metadata cache

Renvoie
void
Depuis
4.2.0

This prevents an error when we're asking for attestation on authenticators which don't allow it. We are really not interested in the attestation per se, but requiring an attestation is the only way we can get the AAGUID of the authenticator.

Références MetadataStatement\createFromArray(), Configuration\forUnsecuredSigner(), JPATH_PLUGINS, et null.

Documentation des champs

◆ $loaded

$loaded = false
private

◆ $mdsCache

$mdsCache = []
private

◆ $mdsMap

$mdsMap = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataRepository.php


Joomla CMS: Référence de la classe Checkfiles

  • Joomla
  • Plugin
  • Task
  • Checkfiles
  • Extension
  • Checkfiles
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe Checkfiles
+ Graphe d'héritage de Checkfiles:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, string $rootDirectory)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

const static getSubscribedEvents ()

Fonctions membres protégées

checkImages (ExecuteTaskEvent $event)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

const TASKS_MAP
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

$rootDirectory

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Task plugin with routines that offer checks on files. At the moment, offers a single routine to check and resize image files in a directory.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | string | $rootDirectory
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
string | $rootDirectory | The root directory to look for images
Depuis
4.2.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ checkImages()

checkImages ( ExecuteTaskEvent $event )
protected
Paramètres
ExecuteTaskEvent $event The onExecuteTask event
Renvoie
integer The exit code
Depuis
4.1.0
Exceptions
RuntimeException
LogicException

Références $height, $image, $limit, $params, $path, $width, Path\check(), Folder\files(), AbstractEvent\getArgument(), Image\getImageFileProperties(), et Joomla\Component\Scheduler\Administrator\Traits\logTask().

◆ getSubscribedEvents()

const static getSubscribedEvents ( )
static
Renvoie
string[]
Depuis
4.1.0

Implémente SubscriberInterface.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $rootDirectory

$rootDirectory
private

◆ TASKS_MAP

const TASKS_MAP
protected
Valeur initiale :
= [
'checkfiles.imagesize' => [
'langConstPrefix' => 'PLG_TASK_CHECK_FILES_TASK_IMAGE_SIZE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Checkfiles.php


Joomla CMS: Référence de la classe DemoTasks

  • Joomla
  • Plugin
  • Task
  • DemoTasks
  • Extension
  • DemoTasks
Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe DemoTasks
+ Graphe d'héritage de DemoTasks:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

sleep (ExecuteTaskEvent $event)
stressMemory (ExecuteTaskEvent $event)
stressMemoryRemoveLimit (ExecuteTaskEvent $event)
getMemoryLimit ()

Attributs privés

const TASKS_MAP

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

A demo task plugin. Offers 3 task routines and demonstrates the use of {

Voir également
TaskPluginTrait}, {
ExecuteTaskEvent}.
Depuis
4.1.0

Documentation des fonctions membres

◆ getMemoryLimit()

getMemoryLimit ( )
private

Processes the PHP ini memory_limit setting, returning the memory limit in KB

Renvoie
float
Depuis
4.1.0

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static
Renvoie
string[]
Depuis
4.1.0

Implémente SubscriberInterface.

◆ sleep()

sleep ( ExecuteTaskEvent $event )
private
Paramètres
ExecuteTaskEvent $event The onExecuteTask event.
Renvoie
integer The routine exit code.
Depuis
4.1.0
Exceptions
Exception

Références AbstractEvent\getArgument(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), et Status\OK.

◆ stressMemory()

stressMemory ( ExecuteTaskEvent $event )
private

Standard routine method for the memory test routine.

Paramètres
ExecuteTaskEvent $event The onExecuteTask event.
Renvoie
integer The routine exit code.
Depuis
4.1.0
Exceptions
Exception

Références $i, Joomla\Component\Scheduler\Administrator\Traits\logTask(), et Status\OK.

◆ stressMemoryRemoveLimit()

stressMemoryRemoveLimit ( ExecuteTaskEvent $event )
private

Standard routine method for the memory test routine, also attempts to override the memory limit set by the PHP INI.

Paramètres
ExecuteTaskEvent $event The onExecuteTask event.
Renvoie
integer The routine exit code.
Depuis
4.1.0
Exceptions
Exception

Références Joomla\Component\Scheduler\Administrator\Traits\logTask().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ TASKS_MAP

const TASKS_MAP
private
Valeur initiale :
= [
'demoTask_r1.sleep' => [
'langConstPrefix' => 'PLG_TASK_DEMO_TASKS_TASK_SLEEP'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DemoTasks.php


Joomla CMS: Référence de la classe Requests

  • Joomla
  • Plugin
  • Task
  • Requests
  • Extension
  • Requests
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe Requests
+ Graphe d'héritage de Requests:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, HttpFactory $httpFactory, string $rootDirectory)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

const static getSubscribedEvents ()

Fonctions membres protégées

makeGetRequest (ExecuteTaskEvent $event)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

const TASKS_MAP
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

$httpFactory
$rootDirectory

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Task plugin with routines to make HTTP requests. At the moment, offers a single routine for GET requests.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | HttpFactory | $httpFactory,
 |  | string | $rootDirectory
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
HttpFactory | $httpFactory | The http factory
string | $rootDirectory | The root directory to store the output file in
Depuis
4.2.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getSubscribedEvents()

const static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
string[]
Depuis
4.1.0

Implémente SubscriberInterface.

◆ makeGetRequest()

makeGetRequest ( ExecuteTaskEvent $event )
protected

Standard routine method for the get request routine.

Paramètres
ExecuteTaskEvent $event The onExecuteTask event
Renvoie
integer The exit code
Depuis
4.1.0
Exceptions
Exception

Références $id, $params, $url, Path\clean(), AbstractEvent\getArgument(), ExecuteTaskEvent\getTaskId(), if, Joomla\Component\Scheduler\Administrator\Traits\logTask(), et File\write().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $httpFactory

$httpFactory
private

◆ $rootDirectory

$rootDirectory
private

◆ TASKS_MAP

const TASKS_MAP
protected
Valeur initiale :
= [
'plg_task_requests_task_get' => [
'langConstPrefix' => 'PLG_TASK_REQUESTS_TASK_GET_REQUEST'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Requests.php


Joomla CMS: Référence de la classe SiteStatus

  • Joomla
  • Plugin
  • Task
  • SiteStatus
  • Extension
  • SiteStatus
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe SiteStatus
+ Graphe d'héritage de SiteStatus:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (DispatcherInterface $dispatcher, array $config, array $oldConfig, string $configFile)
alterSiteStatus (ExecuteTaskEvent $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

const TASKS_MAP
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

writeConfigFile (Registry $config)

Attributs privés

$oldConfig
$configFile

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Task plugin with routines to change the offline status of the site. These routines can be used to control planned maintenance periods and related operations.

Depuis
4.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DispatcherInterface | $dispatcher,
 |  | array | $config,
 |  | array | $oldConfig,
 |  | string | $configFile
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $dispatcher | The dispatcher
array | $config | An optional associative array of configuration settings
array | $oldConfig | The old config
string | $configFile | The config
Depuis
4.2.0

Références $config, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ alterSiteStatus()

alterSiteStatus ( ExecuteTaskEvent $event )
Paramètres
ExecuteTaskEvent $event The onExecuteTask event
Renvoie
void
Depuis
4.1.0
Exceptions
Exception

Références $config, Joomla\Component\Scheduler\Administrator\Traits\endRoutine(), ExecuteTaskEvent\getRoutineId(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), et Joomla\Component\Scheduler\Administrator\Traits\startRoutine().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static
Renvoie
string[]
Depuis
4.1.0

Implémente SubscriberInterface.

◆ writeConfigFile()

writeConfigFile ( Registry $config )
private

Method to write the configuration to a file.

Paramètres
Registry $config A Registry object containing all global config data.
Renvoie
integer The task exit code
Depuis
4.1.0
Exceptions
Exception

Références $config, $configuration, Path\isOwner(), Status\KNOCKOUT, Joomla\Component\Scheduler\Administrator\Traits\logTask(), Status\OK, Path\setPermissions(), et File\write().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $configFile

$configFile
private

◆ $oldConfig

$oldConfig
private

◆ TASKS_MAP

const TASKS_MAP
protected
Valeur initiale :
= [
'plg_task_toggle_offline' => [
'langConstPrefix' => 'PLG_TASK_SITE_STATUS'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SiteStatus.php


Joomla CMS: Référence de la classe TosField

  • Joomla
  • Plugin
  • User
  • Profile
  • Field
  • TosField
Fonctions membres protégées | Attributs protégés
Référence de la classe TosField
+ Graphe d'héritage de TosField:
RadioField ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getLabel ()
- Fonctions membres protégées hérités de RadioField
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'Tos'
- Attributs protégés hérités de RadioField
$type = 'Radio'
$layout = 'joomla.form.field.radio.buttons'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides input for TOS

Depuis
2.5.5

Documentation des fonctions membres

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
2.5.5

Références $article, $attribs, $class, $db, $label, $link, $query, $text, $url, Text\_(), Route\_(), HTMLHelper\_(), description, ENT_COMPAT, RouteHelper\getArticleRoute(), Associations\getAssociations(), Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, Associations\isEnabled(), et language.

Documentation des champs

◆ $type

$type = 'Tos'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TosField.php


Joomla CMS: Référence de la classe TermsField

  • Joomla
  • Plugin
  • User
  • Terms
  • Field
  • TermsField
Fonctions membres protégées | Attributs protégés
Référence de la classe TermsField
+ Graphe d'héritage de TermsField:
RadioField ListField FormField DatabaseAwareInterface

Fonctions membres protégées

getInput ()
getLabel ()
getLayoutData ()
- Fonctions membres protégées hérités de RadioField
getLayoutData ()
- Fonctions membres protégées hérités de ListField
getInput ()
getOptions ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$type = 'terms'
- Attributs protégés hérités de RadioField
$type = 'Radio'
$layout = 'joomla.form.field.radio.buttons'
- Attributs protégés hérités de ListField
$type = 'List'
$layout = 'joomla.form.field.list'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Membres hérités additionnels

- Fonctions membres publiques hérités de ListField
addOption ($text, $attributes=array())
__get ($name)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)
- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Provides input for privacyterms

Depuis
3.9.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
3.9.0

Références Joomla\Application\getInput().

◆ getLabel()

getLabel ( )
protected

Method to get the field label markup.

Renvoie
string The field label markup.
Depuis
3.9.0

◆ getLayoutData()

getLayoutData ( )
protected

Method to get the data to be passed to the layout for rendering.

Renvoie
array
Depuis
3.9.4

Références $article, $data, $db, $query, Text\_(), Factory\getApplication(), RouteHelper\getArticleRoute(), Associations\getAssociations(), Joomla\Database\getDatabase(), Factory\getLanguage(), ParameterType\INTEGER, Associations\isEnabled(), language, et value.

Documentation des champs

◆ $type

$type = 'terms'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • TermsField.php


Joomla CMS: Référence de la classe JoomlatokenField

  • Joomla
  • Plugin
  • User
  • Token
  • Field
  • JoomlatokenField
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe JoomlatokenField
+ Graphe d'héritage de JoomlatokenField:
TextField FormField DatabaseAwareInterface

Fonctions membres publiques

setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de TextField
__get ($name)
__set ($name, $value)
setup (\SimpleXMLElement $element, $value, $group=null)
- Fonctions membres publiques hérités de FormField
__construct ($form=null)
__get ($name)
__set ($name, $value)
setForm (Form $form)
setup (\SimpleXMLElement $element, $value, $group=null)
setValue ($value)
getAttribute ($name, $default=null)
getDataAttributes ()
renderDataAttributes ()
render ($layoutId, $data=array())
renderField ($options=array())
filter ($value, $group=null, Registry $input=null)
validate ($value, $group=null, Registry $input=null)
postProcess ($value, $group=null, Registry $input=null)
- Fonctions membres publiques hérités de DatabaseAwareInterface
setDatabase (DatabaseInterface $db)

Fonctions membres protégées

getInput ()
getLayoutData ()
getLayoutPaths ()
- Fonctions membres protégées hérités de TextField
getInput ()
getOptions ()
getLayoutData ()
- Fonctions membres protégées hérités de FormField
getId ($fieldId, $fieldName)
getInput ()
getTitle ()
getLabel ()
getName ($fieldName)
getFieldName ($fieldName)
getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
isDebugEnabled ()

Attributs protégés

$layout = 'plugins.user.token.token'
- Attributs protégés hérités de TextField
$type = 'Text'
$maxLength
$inputmode
$dirname
$addonBefore
$addonAfter
$layout = 'joomla.form.field.text'
- Attributs protégés hérités de FormField
$description
$hint
$autocomplete = 'on'
$spellcheck = true
$autofocus = false
$element
$form
$formControl
$hidden = false
$hiddenLabel = false
$hiddenDescription = false
$translateLabel = true
$translateDescription = true
$translateHint = true
$id
$input
$label
$multiple = false
$pattern
$validationtext
$name
$fieldname
$group
$required = false
$disabled = false
$readonly = false
$type
$validate
$value
$default
$size
$class
$labelclass
$onchange
$onclick
$showon
$parentclass
$layout
$renderLayout = 'joomla.form.renderfield'
$renderLabelLayout = 'joomla.form.renderlabel'
$dataAttributes = array()

Fonctions membres privées

getTokenForDisplay (string $tokenSeed)

Membres hérités additionnels

- Champs de données hérités de FormField
$repeat = false
- Attributs protégés statiques hérités de FormField
static | $count = 0
static | $generated_fieldname = '__field'

Description détaillée

Joomlatoken field class

Depuis
4.0.0

Documentation des fonctions membres

◆ getInput()

getInput ( )
protected

Method to get the field input markup.

Renvoie
string The field input markup.
Depuis
4.0.0

Références Joomla\Application\getInput().

◆ getLayoutData()

getLayoutData ( )
protected

Get the data for the layout

Renvoie
array
Depuis
4.0.0

Références $data, et value.

◆ getLayoutPaths()

getLayoutPaths ( )
protected

Get the layout paths

Renvoie
array
Depuis
4.0.0

Références $template, Factory\getApplication(), JPATH_SITE, et JPATH_THEMES.

◆ getTokenForDisplay()

getTokenForDisplay ( string $tokenSeed )
private

Returns the token formatted suitably for the user to copy.

Paramètres
string $tokenSeed The token seed data stored in the database
Renvoie
string
Depuis
4.0.0

Références $message, $userId, Factory\getApplication(), et Factory\getUser().

◆ setup()

setup | ( | \SimpleXMLElement | $element,
 |  |  | $value,
 |  |  | $group = null
 | ) |  |

Method to attach a Form object to the field.

Paramètres
\SimpleXMLElement | $element | The SimpleXMLElement object representing the <field> tag for the form field object.
mixed | $value | The form field value to validate.
string | $group | The field name group control value. This acts as an array container for the field. For example if the field has name="foo" and the group value is set to "bar" then the full field name would end up being "bar[foo]".
Renvoie
boolean True on success.
Voir également
FormField::setup()
Depuis
4.0.0

Security and privacy precaution: do not display the token field when the user being edited is not the same as the logged in user. Tokens are conceptually a combination of a username and password, therefore they should be treated in the same mode of confidentiality and privacy as passwords i.e. you can reset them for other users but NOT be able to see them, thus preventing impersonation attacks by a malicious administrator.

Références $userId, $value, et Factory\getUser().

Documentation des champs

◆ $layout

$layout = 'plugins.user.token.token'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JoomlatokenField.php


Joomla CMS: Référence de la classe Ini

  • Joomla
  • Registry
  • Format
  • Ini
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe Ini
+ Graphe d'héritage de Ini:
FormatInterface

Fonctions membres publiques

objectToString ($object, array $options=[])
stringToObject ($data, array $options=[])

Fonctions membres protégées

getValueAsIni ($value)

Attributs protégés statiques

static | $options
static | $cache = []

Description détaillée

INI format handler for Registry.

Depuis
1.0

Documentation des fonctions membres

◆ getValueAsIni()

getValueAsIni ( $value )
protected

Method to get a value in an INI format.

Paramètres
mixed $value The value to convert to INI format.
Renvoie
string The value in INI format.
Depuis
1.0

Références $value.

Référencé par Ini\objectToString().

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $options = []
 | ) |  |

Converts an object into an INI formatted string

  • Unfortunately, there is no way to have ini values nested further than two levels deep. Therefore we will only go through the first two levels of the object.
Paramètres
object | $object | Data source object.
array | $options | Options used by the formatter.
Renvoie
string INI formatted string.
Depuis
1.0

Implémente FormatInterface.

Références $assoc, $item, $key, $last, $options, Ini\$options, $value, elseif, Ini\getValueAsIni(), et ArrayHelper\isAssociative().

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = []
 | ) |  |

Parse an INI formatted string and convert it into an object.

Paramètres
string | $data | INI formatted string to convert.
array | $options | An array of options used by the formatter, or a boolean setting to process sections.
Renvoie
object Data object.
Depuis
1.0

Implémente FormatInterface.

Références $data, $hash, $key, $options, Ini\$options, $section, $value, et elseif.

Documentation des champs

◆ $cache

$cache = []
staticprotected

◆ $options

$options
staticprotected
Valeur initiale :
= [
'supportArrayValues' => false

Référencé par Ini\objectToString(), et Ini\stringToObject().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ini.php


Joomla CMS: Référence de la classe Json

  • Joomla
  • Registry
  • Format
  • Json
Fonctions membres publiques
Référence de la classe Json
+ Graphe d'héritage de Json:
FormatInterface

Fonctions membres publiques

objectToString ($object, array $options=[])
stringToObject ($data, array $options=['processSections'=> false])
- Fonctions membres publiques hérités de FormatInterface
stringToObject ($data, array $options=[])

Description détaillée

JSON format handler for Registry.

Depuis
1.0

Documentation des fonctions membres

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $options = []
 | ) |  |

Converts an object into a JSON formatted string.

Paramètres
object | $object | Data source object.
array | $options | Options used by the formatter.
Renvoie
string JSON formatted string.
Depuis
1.0

Implémente FormatInterface.

Références $options.

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = ['processSections' =,
 |  | false] |
 | ) |  |

Parse a JSON formatted string and convert it into an object.

If the string is not in JSON format, this method will attempt to parse it as INI format.

Paramètres
string | $data | JSON formatted string to convert.
array | $options | Options used by the formatter.
Renvoie
object Data object.
Depuis
1.0
Exceptions

Références $data, $options, Factory\getFormat(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/registry/src/Format/Json.php


Joomla CMS: Référence de la classe Php

  • Joomla
  • Registry
  • Format
  • Php
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Php
+ Graphe d'héritage de Php:
FormatInterface

Fonctions membres publiques

objectToString ($object, array $params=[])
stringToObject ($data, array $options=[])

Fonctions membres protégées

formatValue ($value)
getArrayString ($a)

Description détaillée

PHP class format handler for Registry

Depuis
1.0

Documentation des fonctions membres

◆ formatValue()

formatValue ( $value )
protected

Format a value for the string conversion

Paramètres
mixed $value The value to format
Renvoie
mixed The formatted value
Depuis
2.0.0

Références $value, et Php\getArrayString().

Référencé par Php\getArrayString(), et Php\objectToString().

◆ getArrayString()

getArrayString ( $a )
protected

Method to get an array as an exported string.

Paramètres
array $a The array to get as a string.
Renvoie
string
Depuis
1.0

Références $i, et Php\formatValue().

Référencé par Php\formatValue().

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $params = []
 | ) |  |

Converts an object into a php class string.

  • NOTE: Only one depth level is supported.
Paramètres
object | $object | Data Source Object
array | $params | Parameters used by the formatter
Renvoie
string Config class formatted string
Depuis
1.0

Implémente FormatInterface.

Références $class, $params, et Php\formatValue().

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = []
 | ) |  |

Parse a PHP class formatted string and convert it into an object.

Paramètres
string | $data | PHP Class formatted string to convert.
array | $options | Options used by the formatter.
Renvoie
object Data object.
Depuis
1.0

Implémente FormatInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Php.php


Joomla CMS: Référence de la classe Xml

  • Joomla
  • Registry
  • Format
  • Xml
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe Xml
+ Graphe d'héritage de Xml:
FormatInterface

Fonctions membres publiques

objectToString ($object, array $options=[])
stringToObject ($data, array $options=[])

Fonctions membres protégées

getValueFromNode ($node)
getXmlChildren (SimpleXMLElement $node, $var, $nodeName)

Description détaillée

XML format handler for Registry.

Depuis
1.0

Documentation des fonctions membres

◆ getValueFromNode()

getValueFromNode ( $node )
protected

Method to get a PHP native value for a SimpleXMLElement object. – called recursively

Paramètres
object $node SimpleXMLElement object for which to get the native value.
Renvoie
mixed Native value of the SimpleXMLElement object.
Depuis
1.0

Références $value.

Référencé par Xml\stringToObject().

◆ getXmlChildren()

getXmlChildren | ( | SimpleXMLElement | $node,
 |  |  | $var,
 |  |  | $nodeName
 | ) |  |
protected

Method to build a level of the XML string – called recursively

Paramètres
SimpleXMLElement | $node | SimpleXMLElement object to attach children.
object | $var | Object that represents a node of the XML document.
string | $nodeName | The name to use for node elements.
Renvoie
void
Depuis
1.0

Références $n.

Référencé par Xml\objectToString().

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $options = []
 | ) |  |

Converts an object into an XML formatted string.

  • If more than two levels of nested groups are necessary, since INI is not useful, XML or another format should be used.
Paramètres
object | $object | Data source object.
array | $options | Options used by the formatter.
Renvoie
string XML formatted string.
Depuis
1.0

Implémente FormatInterface.

Références $options, $root, et Xml\getXmlChildren().

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = []
 | ) |  |

Parse a XML formatted string and convert it into an object.

Paramètres
string | $data | XML formatted string to convert.
array | $options | Options used by the formatter.
Renvoie
object Data object.
Depuis
1.0

Implémente FormatInterface.

Références $data, $xml, et Xml\getValueFromNode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/registry/src/Format/Xml.php


Joomla CMS: Référence de la classe Yaml

  • Joomla
  • Registry
  • Format
  • Yaml
Fonctions membres publiques | Attributs privés
Référence de la classe Yaml
+ Graphe d'héritage de Yaml:
FormatInterface

Fonctions membres publiques

__construct ()
objectToString ($object, array $options=[])
stringToObject ($data, array $options=[])

Attributs privés

$parser
$dumper

Description détaillée

YAML format handler for Registry.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Construct to set up the parser and dumper

Depuis
1.0

Références class.

Documentation des fonctions membres

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $options = []
 | ) |  |

Converts an object into a YAML formatted string. We use json_* to convert the passed object to an array.

Paramètres
object | $object | Data source object.
array | $options | Options used by the formatter.
Renvoie
string YAML formatted string.
Depuis
1.0

Implémente FormatInterface.

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = []
 | ) |  |

Parse a YAML formatted string and convert it into an object. We use the json_* methods to convert the parsed YAML array to an object.

Paramètres
string | $data | YAML formatted string to convert.
array | $options | Options used by the formatter.
Renvoie
object Data object.
Depuis
1.0

Implémente FormatInterface.

Références $data.

Documentation des champs

◆ $dumper

$dumper
private

◆ $parser

$parser
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/registry/src/Format/Yaml.php


Joomla CMS: Référence de la classe Factory

  • Joomla
  • Registry
  • Factory
Fonctions membres publiques statiques
Référence de la classe Factory

Fonctions membres publiques statiques

static getFormat ($type, array $options=[])

Description détaillée

Factory class to fetch Registry objects

Depuis
1.5.0

Documentation des fonctions membres

◆ getFormat()

static getFormat | ( |  | $type,
 |  | array | $options = []
 | ) |  |
static

Returns a FormatInterface object, only creating it if it doesn't already exist.

Paramètres
string | $type | The format to load
array | $options | Additional options to configure the object
Renvoie
FormatInterface Registry format handler
Depuis
1.5.0
Exceptions

Références $class, $namespace, $options, et $type.

Référencé par Registry\loadString(), et Json\stringToObject().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/registry/src/Factory.php


Joomla CMS: Référence de l'interface FormatInterface

  • Joomla
  • Registry
  • FormatInterface
Fonctions membres publiques
Référence de l'interface FormatInterface
+ Graphe d'héritage de FormatInterface:
Ini Json Php Xml Yaml

Fonctions membres publiques

objectToString ($object, array $options=[])
stringToObject ($data, array $options=[])

Description détaillée

Interface defining a format object

Depuis
1.5.0

Documentation des fonctions membres

◆ objectToString()

objectToString | ( |  | $object,
 |  | array | $options = []
 | ) |  |

Converts an object into a formatted string.

Paramètres
object | $object | Data Source Object.
array | $options | An array of options for the formatter.
Renvoie
string Formatted string.
Depuis
1.5.0

Implémenté dans Yaml, Ini, Xml, Json, et Php.

◆ stringToObject()

stringToObject | ( |  | $data,
 |  | array | $options = []
 | ) |  |

Converts a formatted string into an object.

Paramètres
string | $data | Formatted string
array | $options | An array of options for the formatter.
Renvoie
object Data Object
Depuis
1.5.0

Implémenté dans Ini, Yaml, Php, et Xml.

La documentation de cette interface a été générée à partir du fichier suivant :
  • FormatInterface.php


Joomla CMS: Référence de la classe Registry

  • Joomla
  • Registry
  • Registry
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe Registry
+ Graphe d'héritage de Registry:

Fonctions membres publiques

__construct ($data=null)
__clone ()
__toString ()
count ()
jsonSerialize ()
def ($key, $default='')
exists ($path)
get ($path, $default=null)
getIterator ()
loadArray (array $array, $flattened=false, $separator=null)
loadObject ($object)
loadFile ($file, $format='JSON', array $options=[])
loadString ($data, $format='JSON', array $options=[])
merge (Registry $source, $recursive=false)
extract ($path)
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)
set ($path, $value, $separator=null)
append ($path, $value)
remove ($path)
toArray ()
toObject ()
toString ($format='JSON', array $options=[])
flatten ($separator=null)

Champs de données

$separator = '.'

Fonctions membres protégées

bindData ($parent, $data, $recursive=true, $allowNull=true)
asArray ($data)
toFlatten ($separator=null, $data=null, array &$array=[], $prefix='')

Attributs protégés

$data
$initialized = false

Description détaillée

Registry class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $data = null )

Constructor

Paramètres
mixed $data The data to bind to the new Registry object.
Depuis
1.0

Références Registry\$data, Registry\bindData(), elseif, Registry\loadString(), et Registry\merge().

Documentation des fonctions membres

◆ __clone()

__clone ( )

Magic function to clone the registry object.

Renvoie
void
Depuis
1.0

◆ __toString()

__toString ( )

Magic function to render this object as a string using default args of toString method.

Renvoie
string
Depuis
1.0

Références Registry\toString().

◆ append()

append | ( | $path,
 |  | $value
 | ) |

Append value to a path in registry

Paramètres
string | $path | Parent registry Path (e.g. joomla.content.showauthor)
mixed | $value | Value of entry
Renvoie
mixed The value of the that has been set.
Depuis
1.4.0

Références $data, $i, $n, $path, $result, et null.

◆ asArray()

asArray ( $data )
protected

Method to recursively convert an object of data to an array.

Paramètres
object $data An object of data to return as an array.
Renvoie
array Array representation of the input object.
Depuis
1.0

Références $data.

◆ bindData()

bindData | ( | $parent,
 |  | $data,
 |  | $recursive = true,
 |  | $allowNull = true
 | ) |
protected

Method to recursively bind data to a parent object.

Paramètres
object | $parent | The parent object on which to attach the data values.
mixed | $data | An array or object of data to bind to the parent object.
boolean | $recursive | True to support recursive bindData.
boolean | $allowNull | True to allow null values.
Renvoie
void
Depuis
1.0

Références $data, et null.

Référencé par Registry\__construct(), Registry\loadArray(), Registry\loadObject(), et Registry\merge().

◆ count()

count ( )

Count elements of the data object

Renvoie
integer The custom count as an integer.

1.3.0

Référencé par Registry\set().

◆ def()

def | ( | $key,
 |  | $default = ''
 | ) |

Sets a default value if not already assigned.

Paramètres
string | $key | The name of the parameter.
mixed | $default | An optional value for the parameter.
Renvoie
mixed The value set, or the default if the value was not previously set (or null).
Depuis
1.0

Références $default, $key, et $value.

◆ exists()

exists ( $path )

Check if a registry path exists.

Paramètres
string $path Registry path (e.g. joomla.content.showauthor)
Renvoie
boolean
Depuis
1.0

Références Registry\$data, $n, et $path.

Référencé par Registry\offsetExists().

◆ extract()

extract ( $path )

Method to extract a sub-registry from path

Paramètres
string $path Registry path (e.g. joomla.content.showauthor)
Renvoie
Registry Registry object (empty if no data is present)
Depuis
1.2.0

Références Registry\$data, et $path.

◆ flatten()

flatten ( $separator = null )

Dump to one dimension array.

Paramètres
string $separator The key separator.
Renvoie
string[] Dumped array.
Depuis
1.3.0

Références $separator.

◆ get()

get | ( | $path,
 |  | $default = null
 | ) |

Get a registry value.

Paramètres
string | $path | Registry path (e.g. joomla.content.showauthor)
mixed | $default | Optional default value, returned if the internal value is null.
Renvoie
mixed Value of entry or null
Depuis
1.0

Références Registry\$data, $default, $n, $path, et null.

◆ getIterator()

getIterator ( )

Gets this object represented as an ArrayIterator.

This allows the data properties to be accessed via a foreach statement.

Renvoie
This object represented as an ArrayIterator.
Voir également
IteratorAggregate::getIterator()
Depuis
1.3.0

◆ jsonSerialize()

jsonSerialize ( )

Implementation for the JsonSerializable interface. Allows us to pass Registry objects to json_encode.

Renvoie
object
Depuis
1.0
Note
The interface is only present in PHP 5.4 and up.

Références Registry\$data.

◆ loadArray()

loadArray | ( | array | $array,
 |  |  | $flattened = false,
 |  |  | $separator = null
 | ) |  |

Load an associative array of values into the default namespace

Paramètres
array | $array | Associative array of value to load
boolean | $flattened | Load from a one-dimensional array
string | $separator | The key separator
Renvoie
$this
Depuis
1.0

Références Registry\$separator, $this, et Registry\bindData().

◆ loadFile()

loadFile | ( |  | $file,
 |  |  | $format = 'JSON',
 |  | array | $options = []
 | ) |  |

Load the contents of a file into the registry

Paramètres
string | $file | Path to file to load
string | $format | Format of the file [optional: defaults to JSON]
array | $options | Options used by the formatter
Renvoie
$this
Depuis
1.0

Références Registry\$data, $format, $options, et Registry\loadString().

◆ loadObject()

loadObject ( $object )

Load the public variables of the object into the default namespace.

Paramètres
object $object The object holding the publics to load
Renvoie
$this
Depuis
1.0

Références $this, et Registry\bindData().

Référencé par Registry\loadString().

◆ loadString()

loadString | ( |  | $data,
 |  |  | $format = 'JSON',
 |  | array | $options = []
 | ) |  |

Load a string into the registry

Paramètres
string | $data | String to load into the registry
string | $format | Format of the string
array | $options | Options used by the formatter
Renvoie
$this
Depuis
1.0

Références Registry\$data, $format, $options, $this, Factory\getFormat(), et Registry\loadObject().

Référencé par Registry\__construct(), et Registry\loadFile().

◆ merge()

merge | ( | Registry | $source,
 |  |  | $recursive = false
 | ) |  |

Merge a Registry object into this one

Paramètres
Registry | $source | Source Registry object to merge.
boolean | $recursive | True to support recursive merge the children values.
Renvoie
$this
Depuis
1.0

Références $this, Registry\bindData(), et Registry\toArray().

Référencé par Registry\__construct().

◆ offsetExists()

offsetExists ( $offset )

Checks whether an offset exists in the iterator.

Paramètres
mixed $offset The array offset.
Renvoie
boolean True if the offset exists, false otherwise.
Depuis
1.0

Références Joomla\Database\Query\$offset, et Registry\exists().

◆ offsetGet()

offsetGet ( $offset )

Gets an offset in the iterator.

Paramètres
mixed $offset The array offset.
Renvoie
mixed The array value if it exists, null otherwise.
Depuis
1.0

Références Joomla\Database\Query\$offset.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Sets an offset in the iterator.

Paramètres
mixed | $offset | The array offset.
mixed | $value | The array value.
Renvoie
void
Depuis
1.0

Références Joomla\Database\Query\$offset, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Unsets an offset in the iterator.

Paramètres
mixed $offset The array offset.
Renvoie
void
Depuis
1.0

Références Joomla\Database\Query\$offset.

◆ remove()

remove ( $path )

Delete a registry value

Paramètres
string $path Registry Path (e.g. joomla.content.showauthor)
Renvoie
mixed The value of the removed node or null if not set
Depuis
1.6.0

Références $data, $i, $n, $path, $result, et null.

◆ set()

set | ( | $path,
 |  | $value,
 |  | $separator = null
 | ) |

Set a registry value.

Paramètres
string | $path | Registry Path (e.g. joomla.content.showauthor)
mixed | $value | Value of entry
string | $separator | The key separator
Renvoie
mixed The value of the that has been set.
Depuis
1.0

Références Registry\$data, $i, $n, $path, Registry\$separator, et Registry\count().

◆ toArray()

toArray ( )

Transforms a namespace to an array

Renvoie
array An associative array holding the namespace data
Depuis
1.0

Référencé par Registry\merge().

◆ toFlatten()

toFlatten | ( |  | $separator = null,
 |  |  | $data = null,
 |  | array & | $array = [],
 |  |  | $prefix = ''
 | ) |  |
protected

Method to recursively convert data to one dimension array.

Paramètres
string | $separator | The key separator.
array | object | $data | Data source of this scope.
array | $array | The result array, it is passed by reference.
string | $prefix | Last level key prefix.
Renvoie
void
Depuis
1.3.0

Références $data, $key, $prefix, et $separator.

◆ toObject()

toObject ( )

Transforms a namespace to an object

Renvoie
object An an object holding the namespace data
Depuis
1.0

Références $data.

◆ toString()

toString | ( |  | $format = 'JSON',
 |  | array | $options = []
 | ) |  |

Get a namespace in a given string format

Paramètres
string | $format | Format to return the string in
array | $options | Parameters used by the formatter, see formatters for more info
Renvoie
string Namespace in string format
Depuis
1.0

Références $format, et $options.

Référencé par Registry\__toString().

Documentation des champs

◆ $data

$data
protected

Référencé par Registry\__construct(), Registry\exists(), Registry\extract(), Registry\get(), Registry\jsonSerialize(), Registry\loadFile(), Registry\loadString(), et Registry\set().

◆ $initialized

$initialized = false
protected

◆ $separator

$separator = '.'

Référencé par Registry\loadArray(), et Registry\set().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/registry/src/Registry.php


Joomla CMS: Référence de la classe DebugRouterCommand

  • Joomla
  • Router
  • Command
  • DebugRouterCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe DebugRouterCommand
+ Graphe d'héritage de DebugRouterCommand:
AbstractCommand

Fonctions membres publiques

__construct (RouterInterface $router)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'debug:router'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Fonctions membres privées

formatCallable ($callable)
formatValue ($value)

Attributs privés

$router

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Command listing information about the application's router.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( RouterInterface $router )

Instantiate the command.

Paramètres
RouterInterface $router The application router.
Depuis
2.0.0

Références DebugRouterCommand\$router, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\addOption(), null, AbstractCommand\setDescription(), AbstractCommand\setHelp(), et InputOption\VALUE_NONE.

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

◆ formatCallable()

formatCallable ( $callable )
private

Formats a callable resource to be displayed in the console output

Paramètres
callable $callable A callable resource to format
Renvoie
string
Depuis
2.0.0
Exceptions

◆ formatValue()

formatValue ( $value )
private

Formats a value as string.

Paramètres
mixed $value A value to format
Renvoie
string
Depuis
2.0.0
Note
This method is based on ::formatValue()

Documentation des champs

◆ $defaultName

$defaultName = 'debug:router'
staticprotected

◆ $router

$router
private

Référencé par DebugRouterCommand\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugRouterCommand.php


Joomla CMS: Référence de la classe MethodNotAllowedException

  • Joomla
  • Router
  • Exception
  • MethodNotAllowedException
Fonctions membres publiques | Attributs protégés
Référence de la classe MethodNotAllowedException
+ Graphe d'héritage de MethodNotAllowedException:

Fonctions membres publiques

__construct (array $allowedMethods, $message=null, $code=405, \Exception $previous=null)
getAllowedMethods ()

Attributs protégés

$allowedMethods = []

Description détaillée

Exception defining a method not allowed error.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $allowedMethods,
 |  |  | $message = null,
 |  |  | $code = 405,
 |  | \Exception | $previous = null
 | ) |  |

Constructor.

Paramètres
array | $allowedMethods | The allowed methods for the route.
null | $message | The Exception message to throw.
integer | $code | The Exception code.
\Exception | $previous | The previous throwable used for the exception chaining.

Références MethodNotAllowedException\$allowedMethods, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAllowedMethods()

getAllowedMethods ( )

Gets the allowed HTTP methods.

Renvoie
array
Depuis
2.0.0

Références MethodNotAllowedException\$allowedMethods.

Documentation des champs

◆ $allowedMethods

$allowedMethods = []
protected

Référencé par MethodNotAllowedException\__construct(), et MethodNotAllowedException\getAllowedMethods().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MethodNotAllowedException.php


Joomla CMS: Référence de la classe RouteNotFoundException

  • Joomla
  • Router
  • Exception
  • RouteNotFoundException
Référence de la classe RouteNotFoundException
+ Graphe d'héritage de RouteNotFoundException:

Description détaillée

Exception defining a route not found error.

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/router/src/Exception/RouteNotFoundException.php


Joomla CMS: Référence de la classe ResolvedRoute

  • Joomla
  • Router
  • ResolvedRoute
Fonctions membres publiques | Attributs privés
Référence de la classe ResolvedRoute

Fonctions membres publiques

__construct ($controller, array $routeVariables, string $uri)
getController ()
getRouteVariables ()
getUri ()

Attributs privés

$controller
$routeVariables
$uri

Description détaillée

An object representing a resolved route.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $controller,
 |  | array | $routeVariables,
 |  | string | $uri
 | ) |  |

Constructor.

Paramètres
mixed | $controller | The controller which handles this route
array | $routeVariables | The variables matched by the route
string | $uri | The URI for this route
Depuis
2.0.0

Références ResolvedRoute\$controller, ResolvedRoute\$routeVariables, et ResolvedRoute\$uri.

Documentation des fonctions membres

◆ getController()

getController ( )

Retrieve the controller which handles this route

Renvoie
mixed
Depuis
2.0.0

Références ResolvedRoute\$controller.

◆ getRouteVariables()

getRouteVariables ( )

Retrieve the variables matched by the route

Renvoie
array
Depuis
2.0.0

Références ResolvedRoute\$routeVariables.

◆ getUri()

getUri ( )

Retrieve the URI for this route

Renvoie
string
Depuis
2.0.0

Références ResolvedRoute\$uri.

Documentation des champs

◆ $controller

$controller
private

Référencé par ResolvedRoute\__construct(), et ResolvedRoute\getController().

◆ $routeVariables

$routeVariables
private

Référencé par ResolvedRoute\__construct(), et ResolvedRoute\getRouteVariables().

◆ $uri

$uri
private

Référencé par ResolvedRoute\__construct(), et ResolvedRoute\getUri().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ResolvedRoute.php


Joomla CMS: Référence de la classe Route

  • Joomla
  • Router
  • Route
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe Route
+ Graphe d'héritage de Route:

Fonctions membres publiques

__construct (array $methods, string $pattern, $controller, array $rules=[], array $defaults=[])
getController ()
getDefaults ()
getMethods ()
getPattern ()
getRegex ()
getRouteVariables ()
getRules ()
setController ($controller)
setDefaults (array $defaults)
setMethods (array $methods)
setPattern (string $pattern)
setRegex (string $regex)
setRouteVariables (array $routeVariables)
setRules (array $rules)
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)

Fonctions membres protégées

buildRegexAndVarList ()

Attributs privés

$controller
$defaults = []
$methods
$pattern
$regex
$routeVariables = []
$rules = []

Description détaillée

An object representing a route definition.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $methods,
 |  | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Constructor.

Paramètres
array | $methods | The HTTP methods this route supports
string | $pattern | The route pattern to use for matching
mixed | $controller | The controller which handles this route
array | $rules | An array of regex rules keyed using the route variables
array | $defaults | The default variables defined by the route
Depuis
2.0.0

Références Route\$controller, Route\$defaults, Route\$rules, Route\setController(), Route\setDefaults(), Route\setMethods(), Route\setPattern(), et Route\setRules().

Documentation des fonctions membres

◆ __serialize()

__serialize ( )

Serialize the route.

Renvoie
array The data to be serialized
Depuis
2.0.0

Références Route\$controller, class, Route\getController(), Route\getDefaults(), Route\getMethods(), Route\getPattern(), Route\getRegex(), Route\getRouteVariables(), et Route\getRules().

Référencé par Route\serialize().

◆ __unserialize()

__unserialize ( array $data )

Unserialize the route.

Paramètres
array $data The serialized route.
Renvoie
void
Depuis
2.0.0

Références $data.

Référencé par Route\unserialize().

◆ buildRegexAndVarList()

buildRegexAndVarList ( )
protected

Parse the route's pattern to extract the named variables and build a proper regular expression for use when parsing the routes.

Renvoie
void
Depuis
2.0.0

Références Route\$pattern, Route\$regex, elseif, Route\getPattern(), Route\getRules(), Route\setRegex(), et Route\setRouteVariables().

Référencé par Route\getRegex(), et Route\getRouteVariables().

◆ getController()

getController ( )

Retrieve the controller which handles this route

Renvoie
mixed
Depuis
2.0.0

Références Route\$controller.

Référencé par Route\__serialize().

◆ getDefaults()

getDefaults ( )

Retrieve the default variables defined by the route

Renvoie
array
Depuis
2.0.0

Références Route\$defaults.

Référencé par Route\__serialize().

◆ getMethods()

getMethods ( )

Retrieve the HTTP methods this route supports

Renvoie
string[]
Depuis
2.0.0

Références Route\$methods.

Référencé par Route\__serialize().

◆ getPattern()

getPattern ( )

Retrieve the route pattern to use for matching

Renvoie
string
Depuis
2.0.0

Références Route\$pattern.

Référencé par Route\__serialize(), et Route\buildRegexAndVarList().

◆ getRegex()

getRegex ( )

Retrieve the path regex this route processes

Renvoie
string
Depuis
2.0.0

Références Route\$regex, et Route\buildRegexAndVarList().

Référencé par Route\__serialize().

◆ getRouteVariables()

getRouteVariables ( )

Retrieve the variables defined by the route

Renvoie
array
Depuis
2.0.0

Références Route\$routeVariables, et Route\buildRegexAndVarList().

Référencé par Route\__serialize().

◆ getRules()

getRules ( )

Retrieve the regex rules keyed using the route variables

Renvoie
array
Depuis
2.0.0

Références Route\$rules.

Référencé par Route\__serialize(), et Route\buildRegexAndVarList().

◆ serialize()

serialize ( )

Serialize the route.

Renvoie
string The serialized route.
Depuis
2.0.0

Références Route\__serialize().

◆ setController()

setController ( $controller )

Set the controller which handles this route

Paramètres
mixed $controller The controller which handles this route
Renvoie
$this
Depuis
2.0.0

Références Route\$controller, et $this.

Référencé par Route\__construct().

◆ setDefaults()

setDefaults ( array $defaults )

Set the default variables defined by the route

Paramètres
array $defaults The default variables defined by the route
Renvoie
$this
Depuis
2.0.0

Références Route\$defaults, et $this.

Référencé par Route\__construct().

◆ setMethods()

setMethods ( array $methods )

Set the HTTP methods this route supports

Paramètres
array $methods The HTTP methods this route supports
Renvoie
$this
Depuis
2.0.0

Références Route\$methods, et $this.

Référencé par Route\__construct().

◆ setPattern()

setPattern ( string $pattern )

Set the route pattern to use for matching

Paramètres
string $pattern The route pattern to use for matching
Renvoie
$this
Depuis
2.0.0

Références Route\$pattern, $this, Route\setRegex(), et Route\setRouteVariables().

Référencé par Route\__construct().

◆ setRegex()

setRegex ( string $regex )

Set the path regex this route processes

Paramètres
string $regex The path regex this route processes
Renvoie
$this
Depuis
2.0.0

Références Route\$regex, et $this.

Référencé par Route\buildRegexAndVarList(), et Route\setPattern().

◆ setRouteVariables()

setRouteVariables ( array $routeVariables )

Set the variables defined by the route

Paramètres
array $routeVariables The variables defined by the route
Renvoie
$this
Depuis
2.0.0

Références Route\$routeVariables, et $this.

Référencé par Route\buildRegexAndVarList(), et Route\setPattern().

◆ setRules()

setRules ( array $rules )

Set the regex rules keyed using the route variables

Paramètres
array $rules The rules defined by the route
Renvoie
$this
Depuis
2.0.0

Références Route\$rules, et $this.

Référencé par Route\__construct().

◆ unserialize()

unserialize ( $serialized )

Unserialize the route.

Paramètres
string $serialized The serialized route.
Renvoie
void
Depuis
1.0

Références Route\__unserialize().

Documentation des champs

◆ $controller

$controller
private

Référencé par Route\__construct(), Route\__serialize(), Route\getController(), et Route\setController().

◆ $defaults

$defaults = []
private

Référencé par Route\__construct(), Route\getDefaults(), et Route\setDefaults().

◆ $methods

$methods
private

Référencé par Route\getMethods(), et Route\setMethods().

◆ $pattern

$pattern
private

Référencé par Route\buildRegexAndVarList(), Route\getPattern(), et Route\setPattern().

◆ $regex

$regex
private

Référencé par Route\buildRegexAndVarList(), Route\getRegex(), et Route\setRegex().

◆ $routeVariables

$routeVariables = []
private

Référencé par Route\getRouteVariables(), et Route\setRouteVariables().

◆ $rules

$rules = []
private

Référencé par Route\__construct(), Route\getRules(), et Route\setRules().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/router/src/Route.php


Joomla CMS: Référence de la classe Router

  • Joomla
  • Router
  • Router
Fonctions membres publiques | Attributs protégés
Référence de la classe Router
+ Graphe d'héritage de Router:
RouterInterface

Fonctions membres publiques

__construct (array $routes=[])
addRoute (Route $route)
addRoutes (array $routes)
getRoutes ()
parseRoute ($route, $method='GET')
get (string $pattern, $controller, array $rules=[], array $defaults=[])
post (string $pattern, $controller, array $rules=[], array $defaults=[])
put (string $pattern, $controller, array $rules=[], array $defaults=[])
delete (string $pattern, $controller, array $rules=[], array $defaults=[])
head (string $pattern, $controller, array $rules=[], array $defaults=[])
options (string $pattern, $controller, array $rules=[], array $defaults=[])
trace (string $pattern, $controller, array $rules=[], array $defaults=[])
patch (string $pattern, $controller, array $rules=[], array $defaults=[])
all (string $pattern, $controller, array $rules=[], array $defaults=[])
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)

Attributs protégés

$routes = []

Description détaillée

A path router.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $routes = [] )

Constructor.

Paramètres
Route[]|array[] $routes A list of route maps or Route objects to add to the router.
Depuis
1.0

Références Router\$routes, et Router\addRoutes().

Documentation des fonctions membres

◆ __serialize()

__serialize ( )

Serialize the router.

Renvoie
array The data to be serialized
Depuis
2.0.0

Références Router\$routes.

Référencé par Router\serialize().

◆ __unserialize()

__unserialize ( array $data )

Unserialize the router.

Paramètres
array $data The serialized router.
Renvoie
void
Depuis
2.0.0

Références $data.

Référencé par Router\unserialize().

◆ addRoute()

addRoute ( Route $route )

Add a route to the router.

Paramètres
Route $route The route definition
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références $route, et $this.

Référencé par Router\addRoutes(), Router\all(), Router\delete(), Router\get(), Router\head(), Router\options(), Router\patch(), Router\post(), Router\put(), et Router\trace().

◆ addRoutes()

addRoutes ( array $routes )

Add an array of route maps or objects to the router.

Paramètres
Route[]|array[] $routes A list of route maps or Route objects to add to the router.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente RouterInterface.

Références $route, Router\$routes, $this, et Router\addRoute().

Référencé par Router\__construct().

◆ all()

all | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a route to the router that accepts all request methods.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ delete()

delete | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a DELETE route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ get()

get | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a GET route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ getRoutes()

getRoutes ( )

Get the routes registered with this router.

Renvoie
Route[]
Depuis
2.0.0

Implémente RouterInterface.

Références Router\$routes.

◆ head()

head | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a HEAD route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ options()

options | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a OPTIONS route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ parseRoute()

parseRoute | ( | $route,
 |  | $method = 'GET'
 | ) |

Parse the given route and return the information about the route, including the controller assigned to the route.

Paramètres
string | $route | The route string for which to find and execute a controller.
string | $method | Request method to match, should be a valid HTTP request method.
Renvoie
ResolvedRoute
Depuis
1.0
Exceptions
Exception

Implémente RouterInterface.

Références $i, $method, et $route.

◆ patch()

patch | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a PATCH route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ post()

post | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a POST route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ put()

put | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a PUT route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ serialize()

serialize ( )

Serialize the router.

Renvoie
string The serialized router.
Depuis
2.0.0

Références Router\__serialize().

◆ trace()

trace | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a TRACE route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémente RouterInterface.

Références Router\addRoute().

◆ unserialize()

unserialize ( $serialized )

Unserialize the router.

Paramètres
string $serialized The serialized router.
Renvoie
void
Depuis
2.0.0

Références Router\__unserialize().

Documentation des champs

◆ $routes

$routes = []
protected

Référencé par Router\__construct(), Router\__serialize(), Router\addRoutes(), et Router\getRoutes().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/joomla/router/src/Router.php


Joomla CMS: Référence de l'interface RouterInterface

  • Joomla
  • Router
  • RouterInterface
Fonctions membres publiques
Référence de l'interface RouterInterface
+ Graphe d'héritage de RouterInterface:
Router

Fonctions membres publiques

addRoute (Route $route)
addRoutes (array $routes)
getRoutes ()
parseRoute ($route, $method='GET')
get (string $pattern, $controller, array $rules=[], array $defaults=[])
post (string $pattern, $controller, array $rules=[], array $defaults=[])
put (string $pattern, $controller, array $rules=[], array $defaults=[])
delete (string $pattern, $controller, array $rules=[], array $defaults=[])
head (string $pattern, $controller, array $rules=[], array $defaults=[])
options (string $pattern, $controller, array $rules=[], array $defaults=[])
trace (string $pattern, $controller, array $rules=[], array $defaults=[])
patch (string $pattern, $controller, array $rules=[], array $defaults=[])
all (string $pattern, $controller, array $rules=[], array $defaults=[])

Description détaillée

Interface defining a HTTP path router.

Depuis
2.0.0

Documentation des fonctions membres

◆ addRoute()

addRoute ( Route $route )

Add a route to the router.

Paramètres
Route $route The route definition
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ addRoutes()

addRoutes ( array $routes )

Add an array of route maps or objects to the router.

Paramètres
Route[]|array[] $routes A list of route maps or Route objects to add to the router.
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémenté dans Router.

◆ all()

all | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a route to the router that accepts all request methods.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ delete()

delete | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a DELETE route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ get()

get | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a GET route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ getRoutes()

getRoutes ( )

Get the routes registered with this router.

Renvoie
Route[]
Depuis
2.0.0

Implémenté dans Router.

◆ head()

head | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a HEAD route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ options()

options | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a OPTIONS route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ parseRoute()

parseRoute | ( | $route,
 |  | $method = 'GET'
 | ) |

Parse the given route and return the information about the route, including the controller assigned to the route.

Paramètres
string | $route | The route string for which to find and execute a controller.
string | $method | Request method to match, should be a valid HTTP request method.
Renvoie
ResolvedRoute
Depuis
2.0.0
Exceptions
Exception

Implémenté dans Router.

◆ patch()

patch | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a PATCH route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ post()

post | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a POST route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ put()

put | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a PUT route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

◆ trace()

trace | ( | string | $pattern,
 |  |  | $controller,
 |  | array | $rules = [],
 |  | array | $defaults = []
 | ) |  |

Add a TRACE route to the router.

Paramètres
string | $pattern | The route pattern to use for matching.
mixed | $controller | The controller to map to the given pattern.
array | $rules | An array of regex rules keyed using the route variables.
array | $defaults | An array of default values that are used when the URL is matched.
Renvoie
$this
Depuis
2.0.0

Implémenté dans Router.

La documentation de cette interface a été générée à partir du fichier suivant :
  • vendor/joomla/router/src/RouterInterface.php


Joomla CMS: Référence de la classe CreateSessionTableCommand

  • Joomla
  • Session
  • Command
  • CreateSessionTableCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Attributs privés
Référence de la classe CreateSessionTableCommand
+ Graphe d'héritage de CreateSessionTableCommand:
AbstractCommand

Fonctions membres publiques

__construct (DatabaseInterface $db)
- Fonctions membres publiques hérités de AbstractCommand
__construct (?string $name=null)
addArgument (string $name, ?int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, ?int $mode=null, $description='', $default=null)
execute (InputInterface $input, OutputInterface $output)
getAliases ()
getApplication ()
getDefinition ()
getDescription ()
getHelp ()
getHelperSet ()
getName ()
getProcessedHelp ()
getSynopsis (bool $short=false)
isEnabled ()
isHidden ()
mergeApplicationDefinition (bool $mergeArgs=true)
setAliases (array $aliases)
setApplication (?Application $application=null)
setDefinition ($definition)
setDescription (string $description)
setHelp (string $help)
setHelperSet (HelperSet $helperSet)
setHidden (bool $hidden)
setName (string $name)

Fonctions membres protégées

configure ()
doExecute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de AbstractCommand
configure ()
doExecute (InputInterface $input, OutputInterface $output)
initialise (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'session:create-table'
- Attributs protégés statiques hérités de AbstractCommand
static | $defaultName

Attributs privés

$db

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractCommand
static getDefaultName ()

Description détaillée

Command used to create the session database table.

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Instantiate the command.

Paramètres
DatabaseInterface $db Database connector
Depuis
2.0.0

Références CreateSessionTableCommand\$db, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Configure the command.

Renvoie
void
Depuis
2.0.0

Références AbstractCommand\setDescription().

◆ doExecute()

doExecute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Internal function to execute the command.

Paramètres
InputInterface | $input | The input to inject into the command.
OutputInterface | $output | The output to inject into the command.
Renvoie
integer The command exit code
Depuis
2.0.0

Références $input, et $output.

Documentation des champs

◆ $db

$db
private

Référencé par CreateSessionTableCommand\__construct().

◆ $defaultName

$defaultName = 'session:create-table'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • CreateSessionTableCommand.php


Joomla CMS: Référence de la classe CreateSessionTableException

  • Joomla
  • Session
  • Exception
  • CreateSessionTableException
Référence de la classe CreateSessionTableException
+ Graphe d'héritage de CreateSessionTableException:

Description détaillée

Exception thrown when the database session table cannot be created

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • CreateSessionTableException.php


Joomla CMS: Référence de la classe InvalidSessionException

  • Joomla
  • Session
  • Exception
  • InvalidSessionException
Référence de la classe InvalidSessionException
+ Graphe d'héritage de InvalidSessionException:

Description détaillée

Exception thrown when a session validator fails

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidSessionException.php


Joomla CMS: Référence de la classe UnsupportedDatabaseDriverException

  • Joomla
  • Session
  • Exception
  • UnsupportedDatabaseDriverException
Référence de la classe UnsupportedDatabaseDriverException
+ Graphe d'héritage de UnsupportedDatabaseDriverException:

Description détaillée

Exception thrown when the database driver is unsupported

Depuis
2.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedDatabaseDriverException.php


Joomla CMS: Référence de la classe ApcuHandler

  • Joomla
  • Session
  • Handler
  • ApcuHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe ApcuHandler
+ Graphe d'héritage de ApcuHandler:
HandlerInterface

Fonctions membres publiques

__construct (array $options=[])
close ()
destroy ($session_id)
gc ($maxlifetime)
open ($save_path, $session_id)
read ($session_id)
write ($session_id, $session_data)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$prefix

Description détaillée

APCu session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = [] )

Constructor

Paramètres
array $options Associative array of options to configure the handler
Depuis
2.0.0

Références $options.

Documentation des fonctions membres

◆ close()

close ( )

Close the session

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ destroy()

destroy ( $session_id )

Destroy a session

Paramètres
integer $session_id The session ID being destroyed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ gc()

gc ( $maxlifetime )

Cleanup old sessions

Paramètres
integer $maxlifetime Sessions that have not updated for the last maxlifetime seconds will be removed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

◆ open()

open | ( | $save_path,
 |  | $session_id
 | ) |

Initialize session

Paramètres
string | $save_path | The path where to store/retrieve the session
string | $session_id | The session id
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ read()

read ( $session_id )

Read session data

Paramètres
string $session_id The session id to read data for
Renvoie
string The session data
Depuis
2.0.0

◆ write()

write | ( | $session_id,
 |  | $session_data
 | ) |

Write session data

Paramètres
string | $session_id | The session id
string | $session_data | The encoded session data
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Documentation des champs

◆ $prefix

$prefix
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ApcuHandler.php


Joomla CMS: Référence de la classe DatabaseHandler

  • Joomla
  • Session
  • Handler
  • DatabaseHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe DatabaseHandler
+ Graphe d'héritage de DatabaseHandler:
HandlerInterface

Fonctions membres publiques

__construct (DatabaseInterface $db)
close ()
createDatabaseTable ()
destroy ($session_id)
gc ($maxlifetime)
open ($save_path, $session_id)
read ($session_id)
write ($session_id, $session_data)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$db
$gcCalled = false
$gcLifetime

Description détaillée

Database session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( DatabaseInterface $db )

Constructor

Paramètres
DatabaseInterface $db Database connector
Depuis
2.0.0

Références DatabaseHandler\$db.

Documentation des fonctions membres

◆ close()

close ( )

Close the session

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Références $query, ParameterType\INTEGER, et null.

◆ createDatabaseTable()

createDatabaseTable ( )

Creates the session database table

Renvoie
boolean
Depuis
2.0.0
Exceptions
CreateSessionTableException
UnsupportedDatabaseDriverException

Références $path, $query, __DIR__, et DatabaseDriver\splitSql().

◆ destroy()

destroy ( $session_id )

Destroy a session

Paramètres
integer $session_id The session ID being destroyed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Références $query.

◆ gc()

gc ( $maxlifetime )

Cleanup old sessions

Paramètres
integer $maxlifetime Sessions that have not updated for the last maxlifetime seconds will be removed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

Références class.

◆ open()

open | ( | $save_path,
 |  | $session_id
 | ) |

Initialize session

Paramètres
string | $save_path | The path where to store/retrieve the session
string | $session_id | The session id
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ read()

read ( $session_id )

Read session data

Paramètres
string $session_id The session id to read data for
Renvoie
string The session data
Depuis
2.0.0

Références $query.

◆ write()

write | ( | $session_id,
 |  | $session_data
 | ) |

Write session data

Paramètres
string | $session_id | The session id
string | $session_data | The encoded session data
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Références $query, et ParameterType\INTEGER.

Documentation des champs

◆ $db

$db
private

Référencé par DatabaseHandler\__construct().

◆ $gcCalled

$gcCalled = false
private

◆ $gcLifetime

$gcLifetime
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • DatabaseHandler.php


Joomla CMS: Référence de la classe FilesystemHandler

  • Joomla
  • Session
  • Handler
  • FilesystemHandler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe FilesystemHandler
+ Graphe d'héritage de FilesystemHandler:
HandlerInterface

Fonctions membres publiques

__construct (string $path='')

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Filesystem session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $path = '' )

Constructor

Paramètres
string $path Path of directory to save session files. Leave null to use the PHP configured path.
Depuis
2.0.0
Exceptions

Références $baseDir, $count, et $path.

Documentation des fonctions membres

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FilesystemHandler.php


Joomla CMS: Référence de la classe MemcachedHandler

  • Joomla
  • Session
  • Handler
  • MemcachedHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe MemcachedHandler
+ Graphe d'héritage de MemcachedHandler:
HandlerInterface

Fonctions membres publiques

__construct (\Memcached $memcached, array $options=[])
close ()
destroy ($session_id)
gc ($maxlifetime)
open ($save_path, $session_id)
read ($session_id)
write ($session_id, $session_data)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$memcached
$prefix
$ttl

Description détaillée

Memcached session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Memcached | $memcached,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
\Memcached | $memcached | A Memcached instance
array | $options | Associative array of options to configure the handler
Depuis
2.0.0

Références MemcachedHandler\$memcached, et $options.

Documentation des fonctions membres

◆ close()

close ( )

Close the session

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ destroy()

destroy ( $session_id )

Destroy a session

Paramètres
integer $session_id The session ID being destroyed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ gc()

gc ( $maxlifetime )

Cleanup old sessions

Paramètres
integer $maxlifetime Sessions that have not updated for the last maxlifetime seconds will be removed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

◆ open()

open | ( | $save_path,
 |  | $session_id
 | ) |

Initialize session

Paramètres
string | $save_path | The path where to store/retrieve the session
string | $session_id | The session id
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ read()

read ( $session_id )

Read session data

Paramètres
string $session_id The session id to read data for
Renvoie
string The session data
Depuis
2.0.0

◆ write()

write | ( | $session_id,
 |  | $session_data
 | ) |

Write session data

Paramètres
string | $session_id | The session id
string | $session_data | The encoded session data
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Documentation des champs

◆ $memcached

$memcached
private

Référencé par MemcachedHandler\__construct().

◆ $prefix

$prefix
private

◆ $ttl

$ttl
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • MemcachedHandler.php


Joomla CMS: Référence de la classe RedisHandler

  • Joomla
  • Session
  • Handler
  • RedisHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe RedisHandler
+ Graphe d'héritage de RedisHandler:
HandlerInterface

Fonctions membres publiques

__construct (\Redis $redis, array $options=[])
close ()
destroy ($session_id)
gc ($maxlifetime)
open ($save_path, $session_id)
read ($session_id)
write ($session_id, $session_data)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$prefix
$redis
$ttl

Description détaillée

Redis session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | \Redis | $redis,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
\Redis | $redis | A Redis instance
array | $options | Associative array of options to configure the handler
Depuis
2.0.0

Références $options, et RedisHandler\$redis.

Documentation des fonctions membres

◆ close()

close ( )

Close the session

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ destroy()

destroy ( $session_id )

Destroy a session, called automatically when running session_regenerate_id().

Paramètres
integer $session_id The session ID being destroyed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ gc()

gc ( $maxlifetime )

Cleanup old sessions

Paramètres
integer $maxlifetime Sessions that have not updated for the last maxlifetime seconds will be removed
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

◆ open()

open | ( | $save_path,
 |  | $session_id
 | ) |

Initialize session

Paramètres
string | $save_path | The path where to store/retrieve the session
string | $session_id | The session id
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

◆ read()

read ( $session_id )

Read session data

Paramètres
string $session_id The session id to read data for
Renvoie
string The session data
Depuis
2.0.0

◆ write()

write | ( | $session_id,
 |  | $session_data
 | ) |

Write session data

Paramètres
string | $session_id | The session id
string | $session_data | The encoded session data
Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Documentation des champs

◆ $prefix

$prefix
private

◆ $redis

$redis
private

Référencé par RedisHandler\__construct().

◆ $ttl

$ttl
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedisHandler.php


Joomla CMS: Référence de la classe WincacheHandler

  • Joomla
  • Session
  • Handler
  • WincacheHandler
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe WincacheHandler
+ Graphe d'héritage de WincacheHandler:
HandlerInterface

Fonctions membres publiques

__construct ()

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Wincache session storage handler

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Constructor

Depuis
2.0.0

Documentation des fonctions membres

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available

Renvoie
boolean True on success, false otherwise
Depuis
2.0.0

Implémente HandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • WincacheHandler.php


Joomla CMS: Référence de la classe NativeStorage

  • Joomla
  • Session
  • Storage
  • NativeStorage
Fonctions membres publiques | Attributs privés
Référence de la classe NativeStorage
+ Graphe d'héritage de NativeStorage:
StorageInterface JoomlaStorage

Fonctions membres publiques

__construct (?\SessionHandlerInterface $handler=null, array $options=[])
all ()
clear ()
close ()
gc ()
abort ()
get (string $name, $default)
getHandler ()
getId ()
getName ()
has (string $name)
isActive ()
isStarted ()
remove (string $name)
regenerate (bool $destroy=false)
set (string $name, $value=null)
setHandler (?\SessionHandlerInterface $handler=null)
setId (string $id)
setName (string $name)
setOptions (array $options)
start ()

Attributs privés

$active = false
$closed = false
$handler
$started = false

Description détaillée

Base class providing a session store

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?\SessionHandlerInterface | $handler = null,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
\SessionHandlerInterface | $handler | Session save handler
array | $options | Session options
Depuis
1.0

Références NativeStorage\$handler, $options, NativeStorage\setHandler(), et NativeStorage\setOptions().

Documentation des fonctions membres

◆ abort()

abort ( )

Aborts the current session

Renvoie
boolean
Voir également
session_abort()
Depuis
2.0.0

Implémente StorageInterface.

Références NativeStorage\isStarted().

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array
Depuis
2.0.0

Implémente StorageInterface.

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
2.0.0

Implémente StorageInterface.

◆ close()

close ( )

Writes session data and ends session

Renvoie
void
Voir également
session_write_close()
Depuis
2.0.0

Implémente StorageInterface.

◆ gc()

gc ( )

Perform session data garbage collection

Renvoie
integer|boolean Number of deleted sessions on success or boolean false on failure or if the function is unsupported
Voir également
session_gc()
Depuis
2.0.0

Implémente StorageInterface.

Références NativeStorage\isStarted(), et NativeStorage\start().

◆ get()

get | ( | string | $name,
 |  |  | $default
 | ) |  |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
2.0.0

Implémente StorageInterface.

Références $default, $name, NativeStorage\isStarted(), et NativeStorage\start().

◆ getHandler()

getHandler ( )

Gets the save handler instance

Renvoie
|null
Depuis
2.0.0

Références NativeStorage\$handler.

◆ getId()

getId ( )

Get the session ID

Renvoie
string The session ID
Depuis
2.0.0

Implémente StorageInterface.

◆ getName()

getName ( )

Get the session name

Renvoie
string The session name
Depuis
2.0.0

Implémente StorageInterface.

◆ has()

has ( string $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Références $name, NativeStorage\isStarted(), et NativeStorage\start().

◆ isActive()

isActive ( )

Check if the session is active

Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Référencé par NativeStorage\regenerate(), NativeStorage\setHandler(), NativeStorage\setId(), NativeStorage\setName(), NativeStorage\setOptions(), et NativeStorage\start().

◆ isStarted()

isStarted ( )

Check if the session is started

Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Références NativeStorage\$started.

Référencé par NativeStorage\abort(), NativeStorage\gc(), NativeStorage\get(), NativeStorage\has(), NativeStorage\remove(), NativeStorage\set(), et NativeStorage\start().

◆ regenerate()

regenerate ( bool $destroy = false )

Regenerates the session ID that represents this storage.

This method must invoke session_regenerate_id($destroy) unless this interface is used for a storage object designed for unit or functional testing where a real PHP session would interfere with testing.

Paramètres
boolean $destroy Destroy session when regenerating?
Renvoie
boolean True on success
Voir également
session_regenerate_id()
Depuis
2.0.0

Implémente StorageInterface.

Références NativeStorage\isActive().

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
2.0.0

Implémente StorageInterface.

Références $name, NativeStorage\isStarted(), null, et NativeStorage\start().

◆ set()

set | ( | string | $name,
 |  |  | $value = null
 | ) |  |

Set data into the session store

Paramètres
string | $name | Name of a variable
mixed | $value | Value of a variable
Renvoie
mixed Old value of a variable
Depuis
2.0.0

Implémente StorageInterface.

Références $name, $value, NativeStorage\isStarted(), null, et NativeStorage\start().

◆ setHandler()

setHandler ( ?\SessionHandlerInterface $handler = null )

Registers session save handler as a PHP session handler

Paramètres
\SessionHandlerInterface $handler The save handler to use
Renvoie
$this
Depuis
2.0.0
Exceptions

Références NativeStorage\$handler, $this, et NativeStorage\isActive().

Référencé par NativeStorage\__construct().

◆ setId()

setId ( string $id )

Set the session ID

Paramètres
string $id The session ID
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente StorageInterface.

Références $id, $this, et NativeStorage\isActive().

◆ setName()

setName ( string $name )

Set the session name

Paramètres
string $name The session name
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente StorageInterface.

Références $name, $this, et NativeStorage\isActive().

◆ setOptions()

setOptions ( array $options )

Sets session.* ini variables.

For convenience we omit 'session.' from the beginning of the keys. Explicitly ignores other ini keys.

Paramètres
array $options Session ini directives array(key => value).
Renvoie
$this
Note
Based on ::setOptions()
Voir également
http://php.net/session.configuration
Depuis
2.0.0

Références $key, $options, $this, $value, et NativeStorage\isActive().

Référencé par NativeStorage\__construct().

◆ start()

start ( )

Start a session

Renvoie
void
Depuis
2.0.0

Implémente StorageInterface.

Références NativeStorage\isActive(), et NativeStorage\isStarted().

Référencé par NativeStorage\gc(), NativeStorage\get(), NativeStorage\has(), NativeStorage\remove(), et NativeStorage\set().

Documentation des champs

◆ $active

$active = false
private

◆ $closed

$closed = false
private

◆ $handler

$handler
private

Référencé par NativeStorage\__construct(), NativeStorage\getHandler(), et NativeStorage\setHandler().

◆ $started

$started = false
private

Référencé par NativeStorage\isStarted().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NativeStorage.php


Joomla CMS: Référence de la classe RuntimeStorage

  • Joomla
  • Session
  • Storage
  • RuntimeStorage
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe RuntimeStorage
+ Graphe d'héritage de RuntimeStorage:
StorageInterface

Fonctions membres publiques

all ()
clear ()
close ()
gc ()
abort ()
get (string $name, $default)
getId ()
getName ()
has (string $name)
isActive ()
isStarted ()
remove (string $name)
regenerate (bool $destroy=false)
set (string $name, $value=null)
setId (string $id)
setName (string $name)
start ()

Fonctions membres privées

generateId ()

Attributs privés

$active = false
$closed = false
$data = []
$id = ''
$name = 'MockSession'
$started = false

Description détaillée

Session storage object that stores objects in Runtime memory. This is designed for use in CLI Apps, including unit testing applications in PHPUnit.

Depuis
2.0.0

Documentation des fonctions membres

◆ abort()

abort ( )

Aborts the current session

Renvoie
boolean
Voir également
session_abort()
Depuis
2.0.0

Implémente StorageInterface.

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array

Implémente StorageInterface.

Références RuntimeStorage\$data.

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
2.0.0

Implémente StorageInterface.

◆ close()

close ( )

Writes session data and ends session

Renvoie
void
Voir également
session_write_close()
Depuis
2.0.0

Implémente StorageInterface.

◆ gc()

gc ( )

Perform session data garbage collection

Renvoie
integer|boolean Number of deleted sessions on success or boolean false on failure or if the function is unsupported
Voir également
session_gc()
Depuis
2.0.0

Implémente StorageInterface.

◆ generateId()

generateId ( )
private

Generates a session ID

Renvoie
string
Depuis
2.0.0

Référencé par RuntimeStorage\regenerate(), et RuntimeStorage\start().

◆ get()

get | ( | string | $name,
 |  |  | $default
 | ) |  |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
2.0.0

Implémente StorageInterface.

Références $default, RuntimeStorage\$name, RuntimeStorage\isStarted(), et RuntimeStorage\start().

◆ getId()

getId ( )

Get the session ID

Renvoie
string The session ID
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$id.

◆ getName()

getName ( )

Get the session name

Renvoie
string The session name
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$name.

◆ has()

has ( string $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$name, RuntimeStorage\isStarted(), et RuntimeStorage\start().

◆ isActive()

isActive ( )

Check if the session is active

Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$started.

Référencé par RuntimeStorage\regenerate(), RuntimeStorage\setId(), RuntimeStorage\setName(), et RuntimeStorage\start().

◆ isStarted()

isStarted ( )

Check if the session is started

Renvoie
boolean
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$started.

Référencé par RuntimeStorage\get(), RuntimeStorage\has(), RuntimeStorage\remove(), RuntimeStorage\set(), et RuntimeStorage\start().

◆ regenerate()

regenerate ( bool $destroy = false )

Regenerates the session ID that represents this storage.

This method must invoke session_regenerate_id($destroy) unless this interface is used for a storage object designed for unit or functional testing where a real PHP session would interfere with testing.

Paramètres
boolean $destroy Destroy session when regenerating?
Renvoie
boolean True on success
Voir également
session_regenerate_id()
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\generateId(), et RuntimeStorage\isActive().

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$name, RuntimeStorage\isStarted(), null, et RuntimeStorage\start().

◆ set()

set | ( | string | $name,
 |  |  | $value = null
 | ) |  |

Set data into the session store

Paramètres
string | $name | Name of a variable
mixed | $value | Value of a variable
Renvoie
mixed Old value of a variable
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\$name, $value, RuntimeStorage\isStarted(), null, et RuntimeStorage\start().

◆ setId()

setId ( string $id )

Set the session ID

Paramètres
string $id The session ID
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente StorageInterface.

Références RuntimeStorage\$id, $this, et RuntimeStorage\isActive().

Référencé par RuntimeStorage\start().

◆ setName()

setName ( string $name )

Set the session name

Paramètres
string $name The session name
Renvoie
$this
Depuis
2.0.0
Exceptions

Implémente StorageInterface.

Références RuntimeStorage\$name, $this, RuntimeStorage\isActive(), et name.

◆ start()

start ( )

Start a session

Renvoie
void
Depuis
2.0.0

Implémente StorageInterface.

Références RuntimeStorage\generateId(), RuntimeStorage\isActive(), RuntimeStorage\isStarted(), et RuntimeStorage\setId().

Référencé par RuntimeStorage\get(), RuntimeStorage\has(), RuntimeStorage\remove(), et RuntimeStorage\set().

Documentation des champs

◆ $active

$active = false
private

◆ $closed

$closed = false
private

◆ $data

$data = []
private

Référencé par RuntimeStorage\all().

◆ $id

$id = ''
private

Référencé par RuntimeStorage\getId(), et RuntimeStorage\setId().

◆ $name

$name = 'MockSession'
private

Référencé par RuntimeStorage\get(), RuntimeStorage\getName(), RuntimeStorage\has(), RuntimeStorage\remove(), RuntimeStorage\set(), et RuntimeStorage\setName().

◆ $started

$started = false
private

Référencé par RuntimeStorage\isActive(), et RuntimeStorage\isStarted().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RuntimeStorage.php


Joomla CMS: Référence de la classe AddressValidator

  • Joomla
  • Session
  • Validator
  • AddressValidator
Fonctions membres publiques | Attributs privés
Référence de la classe AddressValidator
+ Graphe d'héritage de AddressValidator:
ValidatorInterface

Fonctions membres publiques

__construct (Input $input, SessionInterface $session)
validate (bool $restart=false)

Attributs privés

$input
$session

Description détaillée

Interface for validating a part of the session

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input,
 |  | SessionInterface | $session
 | ) |  |

Constructor

Paramètres
Input | $input | The input object
SessionInterface | $session | DispatcherInterface for the session to use.
Depuis
2.0.0

Références AddressValidator\$input, et AddressValidator\$session.

Documentation des fonctions membres

◆ validate()

validate ( bool $restart = false )

Validates the session

Paramètres
boolean $restart Flag if the session should be restarted
Renvoie
void
Depuis
2.0.0
Exceptions
InvalidSessionException

Implémente ValidatorInterface.

Références elseif, IpHelper\getIp(), et null.

Documentation des champs

◆ $input

$input
private

Référencé par AddressValidator\__construct().

◆ $session

$session
private

Référencé par AddressValidator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AddressValidator.php


Joomla CMS: Référence de la classe ForwardedValidator

  • Joomla
  • Session
  • Validator
  • ForwardedValidator
Fonctions membres publiques | Attributs privés
Référence de la classe ForwardedValidator
+ Graphe d'héritage de ForwardedValidator:
ValidatorInterface

Fonctions membres publiques

__construct (Input $input, SessionInterface $session)
validate (bool $restart=false)

Attributs privés

$input
$session

Description détaillée

Interface for validating a part of the session

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Input | $input,
 |  | SessionInterface | $session
 | ) |  |

Constructor

Paramètres
Input | $input | The input object
SessionInterface | $session | DispatcherInterface for the session to use.
Depuis
2.0.0

Références ForwardedValidator\$input, et ForwardedValidator\$session.

Documentation des fonctions membres

◆ validate()

validate ( bool $restart = false )

Validates the session

Paramètres
boolean $restart Flag if the session should be restarted
Renvoie
void
Depuis
2.0.0

Implémente ValidatorInterface.

Références null.

Documentation des champs

◆ $input

$input
private

Référencé par ForwardedValidator\__construct().

◆ $session

$session
private

Référencé par ForwardedValidator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ForwardedValidator.php


Joomla CMS: Référence de l'interface HandlerInterface

  • Joomla
  • Session
  • HandlerInterface
Fonctions membres publiques statiques
Référence de l'interface HandlerInterface
+ Graphe d'héritage de HandlerInterface:
ApcuHandler DatabaseHandler FilesystemHandler MemcachedHandler RedisHandler WincacheHandler

Fonctions membres publiques statiques

static isSupported ()

Description détaillée

Interface defining Joomla! session handlers

Depuis
2.0.0

Documentation des fonctions membres

◆ isSupported()

static isSupported ( )
static

Test to see if the HandlerInterface is available.

Renvoie
boolean True on success, false otherwise.
Depuis
2.0.0

Implémenté dans DatabaseHandler, RedisHandler, MemcachedHandler, ApcuHandler, FilesystemHandler, et WincacheHandler.

La documentation de cette interface a été générée à partir du fichier suivant :
  • session/src/HandlerInterface.php


Joomla CMS: Référence de la classe Session

  • Joomla
  • Session
  • Session
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Session
+ Graphe d'héritage de Session:
SessionInterface DispatcherAwareInterface Session

Fonctions membres publiques

__construct (StorageInterface $store=null, DispatcherInterface $dispatcher=null, array $options=[])
addValidator (ValidatorInterface $validator)
getExpire ()
getState ()
getToken ($forceNew=false)
hasToken ($token, $forceExpire=true)
getIterator ()
getName ()
setName (string $name)
getId ()
setId (string $id)
isActive ()
isNew ()
isStarted ()
get ($name, $default=null)
set ($name, $value=null)
has ($name)
remove (string $name)
clear ()
all ()
start ()
destroy ()
restart ()
fork ($destroy=false)
close ()
gc ()
abort ()
- Fonctions membres publiques hérités de SessionInterface
fork ()
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)

Fonctions membres protégées

createToken ()
setCounter ()
setExpire ($expire)
setState ($state)
setTimers ()
setOptions (array $options)
validate ($restart=false)

Attributs protégés

$state = SessionState::INACTIVE
$expire = 900
$store
$sessionValidators = []

Description détaillée

Class for managing HTTP sessions

Provides access to session-state values as well as session-level settings and lifetime management methods. Based on the standard PHP session handling mechanism it provides more advanced features such as expire timeouts.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | StorageInterface | $store = null,
 |  | DispatcherInterface | $dispatcher = null,
 |  | array | $options = []
 | ) |  |

Constructor

Paramètres
StorageInterface | $store | A StorageInterface implementation.
DispatcherInterface | $dispatcher | DispatcherInterface for the session to use.
array $options Optional parameters. Supported keys include:
  • name: The session name
  • id: The session ID
  • expire: The session lifetime in seconds
Depuis
1.0

Références $options, Session\$store, SessionState\INACTIVE, DispatcherAwareInterface\setDispatcher(), Session\setOptions(), et Session\setState().

Documentation des fonctions membres

◆ abort()

abort ( )

Aborts the current session

Renvoie
boolean
Voir également
session_abort()
Depuis
2.0.0

Implémente SessionInterface.

Références Session\isActive().

◆ addValidator()

addValidator ( ValidatorInterface $validator )

Adds a validator to the session

Paramètres
ValidatorInterface $validator The session validator
Renvoie
void
Depuis
2.0.0

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array
Depuis
2.0.0

Implémente SessionInterface.

Références Session\isActive(), et Session\start().

Référencé par Session\getIterator(), et Session\restart().

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
1.0

Implémente SessionInterface.

Références Session\isActive(), et Session\start().

Référencé par Session\destroy().

◆ close()

close ( )

Writes session data and ends session

Session data is usually stored after your script terminated without the need to call Session::close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

Renvoie
void
Voir également
session_write_close()
Depuis
1.0

Implémente SessionInterface.

Références SessionState\CLOSED, et Session\setState().

◆ createToken()

createToken ( )
protected

Create a token string

Renvoie
string
Depuis
1.3.1

Référencé par Session\getToken().

◆ destroy()

destroy ( )

Frees all session variables and destroys all data registered to a session

This method resets the $_SESSION variable and destroys all of the data associated with the current session in its storage (file or DB). It forces new session to be started after this method is called.

Renvoie
boolean
Voir également
session_destroy()
session_unset()
Depuis
1.0

Implémente SessionInterface.

Références Session\clear(), SessionState\DESTROYED, SessionInterface\fork(), Session\getState(), et Session\setState().

Référencé par Session\restart(), et Session\start().

◆ fork()

fork ( $destroy = false )

Create a new session and copy variables from the old one

Paramètres
boolean $destroy Whether to delete the old session or leave it to garbage collection.
Renvoie
boolean True on success
Depuis
1.0

Références $result, et Session\setTimers().

◆ gc()

gc ( )

Perform session data garbage collection

Renvoie
integer|boolean Number of deleted sessions on success or boolean false on failure or if the function is unsupported
Voir également
session_gc()
Depuis
2.0.0

Implémente SessionInterface.

Références Session\isActive(), et Session\start().

◆ get()

get | ( | $name,
 |  | $default = null
 | ) |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
1.0

Implémente SessionInterface.

Références $default, $name, Session\isActive(), et Session\start().

◆ getExpire()

getExpire ( )

Get expiration time in seconds

Renvoie
integer The session expiration time in seconds
Depuis
1.0

Implémente SessionInterface.

Références Session\$expire.

Référencé par Session\setOptions().

◆ getId()

getId ( )

Get session id

Renvoie
string The session id
Depuis
1.0

Implémente SessionInterface.

◆ getIterator()

getIterator ( )

Retrieve an external iterator.

Renvoie
Return an ArrayIterator of $_SESSION.
Depuis
1.0

Références Session\all().

◆ getName()

getName ( )

Get session name

Renvoie
string The session name
Depuis
1.0

Implémente SessionInterface.

Référencé par JoomlaStorage\clear(), et JoomlaStorage\start().

◆ getState()

getState ( )

Get current state of session

Renvoie
string The session state
Depuis
1.0

Références Session\$state.

Référencé par Session\destroy(), Session\isActive(), Session\restart(), et Session\start().

◆ getToken()

getToken ( $forceNew = false )

Get a session token.

Tokens are used to secure forms from spamming attacks. Once a token has been generated the system will check the request to see if it is present, if not it will invalidate the session.

Paramètres
boolean $forceNew If true, forces a new token to be created
Renvoie
string
Depuis
1.0

Implémente SessionInterface.

Références Session\createToken(), et Session\has().

◆ has()

has ( $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean True if the variable exists
Depuis
1.0

Implémente SessionInterface.

Références $name, Session\isActive(), et Session\start().

Référencé par Session\getToken(), et Session\setTimers().

◆ hasToken()

hasToken | ( | $token,
 |  | $forceExpire = true
 | ) |

Check if the session has the given token.

Paramètres
string | $token | Hashed token to be verified
boolean | $forceExpire | If true, expires the session
Renvoie
boolean
Depuis
1.0

Implémente SessionInterface.

Références $result, SessionState\EXPIRED, et Session\setState().

◆ isActive()

isActive ( )

Check if the session is active

Renvoie
boolean
Depuis
1.0

Implémente SessionInterface.

Références SessionState\ACTIVE, et Session\getState().

Référencé par JoomlaStorage\__construct(), Session\abort(), Session\all(), Session\clear(), Session\gc(), Session\get(), Session\has(), Session\remove(), Session\set(), et JoomlaStorage\setCookieParams().

◆ isNew()

isNew ( )

Check whether this session is currently created

Renvoie
boolean
Depuis
1.0

Implémente SessionInterface.

◆ isStarted()

isStarted ( )

Check if the session is started

Renvoie
boolean
Depuis
2.0.0

Implémente SessionInterface.

Référencé par JoomlaStorage\get(), JoomlaStorage\has(), JoomlaStorage\remove(), JoomlaStorage\set(), et Session\start().

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
2.0.0

Implémente SessionInterface.

Références $name, Session\isActive(), et Session\start().

◆ restart()

restart ( )

Restart an expired or locked session.

Renvoie
boolean True on success
Voir également
destroy
Depuis
1.0

Implémente SessionInterface.

Références $data, $key, $this, $value, SessionState\ACTIVE, Session\all(), class, Session\destroy(), SessionState\DESTROYED, Session\getState(), SessionEvents\RESTART, Session\setCounter(), Session\setState(), Session\setTimers(), et Session\validate().

Référencé par Session\start().

◆ set()

set | ( | $name,
 |  | $value = null
 | ) |

Set data into the session store.

Paramètres
string | $name | Name of a variable.
mixed | $value | Value of a variable.
Renvoie
mixed Old value of a variable.
Depuis
1.0

Implémente SessionInterface.

Références $name, $value, Session\isActive(), et Session\start().

◆ setCounter()

setCounter ( )
protected

Set counter of session usage

Renvoie
boolean True on success
Depuis
1.0

Référencé par Session\restart(), et Session\start().

◆ setExpire()

setExpire ( $expire )
protected

Set the session expiration

Paramètres
integer $expire Maximum age of unused session in seconds
Renvoie
$this
Depuis
1.3.0

Références Session\$expire, et $this.

Référencé par Session\setOptions().

◆ setId()

setId ( string $id )

Set the session ID

Paramètres
string $id The session ID
Renvoie
$this
Depuis
2.0.0

Implémente SessionInterface.

Références $id, et $this.

Référencé par Session\setOptions(), et JoomlaStorage\start().

◆ setName()

setName ( string $name )

Set the session name

Paramètres
string $name The session name
Renvoie
$this
Depuis
2.0.0

Implémente SessionInterface.

Références $name, et $this.

Référencé par Session\setOptions().

◆ setOptions()

setOptions ( array $options )
protected

Set additional session options

Paramètres
array $options List of parameter
Renvoie
boolean True on success
Depuis
1.0

Références $options, Session\getExpire(), Session\setExpire(), Session\setId(), et Session\setName().

Référencé par JoomlaStorage\__construct(), et Session\__construct().

◆ setState()

setState ( $state )
protected

Set the session state

Paramètres
string $state Internal state
Renvoie
$this
Depuis
1.3.0

Références Session\$state, et $this.

Référencé par Session\__construct(), Session\close(), Session\destroy(), Session\hasToken(), Session\restart(), Session\start(), et Session\validate().

◆ setTimers()

setTimers ( )
protected

Set the session timers

Renvoie
boolean True on success
Depuis
1.0

Références $start, et Session\has().

Référencé par Session\fork(), Session\restart(), et Session\start().

◆ start()

start ( )

Start a session.

Renvoie
void
Depuis
1.0

Implémente SessionInterface.

Références $this, SessionState\ACTIVE, class, Session\destroy(), SessionState\EXPIRED, Session\getState(), Session\isStarted(), Session\restart(), Session\setCounter(), Session\setState(), Session\setTimers(), SessionEvents\START, et Session\validate().

Référencé par Session\all(), Session\clear(), Session\gc(), JoomlaStorage\get(), Session\get(), JoomlaStorage\has(), Session\has(), JoomlaStorage\remove(), Session\remove(), JoomlaStorage\set(), et Session\set().

◆ validate()

validate ( $restart = false )
protected

Do some checks for security reasons

If one check fails, session data has to be cleaned.

Paramètres
boolean $restart Reactivate session
Renvoie
boolean True on success
Voir également
http://shiflett.org/articles/the-truth-about-sessions
Depuis
1.0

Références SessionState\ACTIVE, SessionState\ERROR, SessionState\EXPIRED, et Session\setState().

Référencé par Session\restart(), et Session\start().

Documentation des champs

◆ $expire

$expire = 900
protected

Référencé par Session\getExpire(), et Session\setExpire().

◆ $sessionValidators

$sessionValidators = []
protected

◆ $state

$state = SessionState::INACTIVE
protected

Référencé par Session\getState(), et Session\setState().

◆ $store

$store
protected

Référencé par Session\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/session/src/Session.php


Joomla CMS: Référence de la classe SessionEvent

  • Joomla
  • Session
  • SessionEvent
Fonctions membres publiques | Attributs privés
Référence de la classe SessionEvent
+ Graphe d'héritage de SessionEvent:
Event AbstractEvent EventInterface

Fonctions membres publiques

__construct (string $name, SessionInterface $session)
getSession ()
- Fonctions membres publiques hérités de Event
addArgument ($name, $value)
setArgument ($name, $value)
removeArgument ($name)
clearArguments ()
stop ()
offsetSet ($name, $value)
offsetUnset ($name)
- Fonctions membres publiques hérités de AbstractEvent
__construct ($name, array $arguments=[])
getName ()
getArgument ($name, $default=null)
hasArgument ($name)
getArguments ()
isStopped ()
stopPropagation ()
count ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $data)
offsetExists ($name)
offsetGet ($name)

Attributs privés

$session

Membres hérités additionnels

- Attributs protégés hérités de AbstractEvent
$name
$arguments
$stopped = false

Description détaillée

Class representing a Session event

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | SessionInterface | $session
 | ) |  |

Constructor.

Paramètres
string | $name | The event name.
SessionInterface | $session | The SessionInterface object for this event.
Depuis
2.0.0

Références AbstractEvent\$name, SessionEvent\$session, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getSession()

getSession ( )

Retrieve the SessionInterface object attached to this event.

Renvoie
SessionInterface
Depuis
2.0.0

Références SessionEvent\$session.

Référencé par InstallationApplication\afterSessionStart(), WebApplication\afterSessionStart(), et MetadataManagerListener\onAfterSessionStart().

Documentation des champs

◆ $session

$session
private

Référencé par SessionEvent\__construct(), et SessionEvent\getSession().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionEvent.php


Joomla CMS: Référence de la classe SessionEvents

  • Joomla
  • Session
  • SessionEvents
Champs de données | Fonctions membres privées
Référence de la classe SessionEvents

Champs de données

const | START = 'session.start'
const | RESTART = 'session.restart'

Fonctions membres privées

__construct ()

Description détaillée

Class defining the events dispatched by the session API

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ RESTART

const RESTART = 'session.restart'

Référencé par Session\restart().

◆ START

const START = 'session.start'

Référencé par Session\buildSession(), et Session\start().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionEvents.php


Joomla CMS: Référence de l'interface SessionInterface

  • Joomla
  • Session
  • SessionInterface
Fonctions membres publiques
Référence de l'interface SessionInterface
+ Graphe d'héritage de SessionInterface:
Session Session

Fonctions membres publiques

getExpire ()
getName ()
setName (string $name)
getId ()
setId (string $id)
isActive ()
isNew ()
isStarted ()
getToken ($forceNew=false)
hasToken ($token, $forceExpire=true)
get ($name, $default=null)
set ($name, $value=null)
has ($name)
remove (string $name)
clear ()
all ()
start ()
destroy ()
restart ()
fork ()
close ()
gc ()
abort ()

Description détaillée

Interface defining a Joomla! Session object

Depuis
2.0.0

Documentation des fonctions membres

◆ abort()

abort ( )

Aborts the current session

Renvoie
boolean
Voir également
session_abort()
Depuis
2.0.0

Implémenté dans Session.

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array
Depuis
2.0.0

Implémenté dans Session.

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
2.0.0

Implémenté dans Session, et Session.

◆ close()

close ( )

Writes session data and ends session

Session data is usually stored after your script terminated without the need to call SessionInterface::close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

Renvoie
void
Voir également
session_write_close()
Depuis
2.0.0

Implémenté dans Session.

◆ destroy()

destroy ( )

Frees all session variables and destroys all data registered to a session

This method resets the $_SESSION variable and destroys all of the data associated with the current session in its storage (file or DB). It forces new session to be started after this method is called. It does not unset the session cookie.

Renvoie
boolean
Voir également
session_destroy()
session_unset()
Depuis
2.0.0

Implémenté dans Session.

◆ fork()

fork ( )

Create a new session and copy variables from the old one

Renvoie
boolean
Depuis
2.0.0

Référencé par Session\destroy().

◆ gc()

gc ( )

Perform session data garbage collection

Renvoie
integer|boolean Number of deleted sessions on success or boolean false on failure or if the function is unsupported
Voir également
session_gc()
Depuis
2.0.0

Implémenté dans Session.

◆ get()

get | ( | $name,
 |  | $default = null
 | ) |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
2.0.0

Implémenté dans Session, et Session.

Référencé par MetadataManager\createSessionRecord().

◆ getExpire()

getExpire ( )

Get expiration time in seconds

Renvoie
integer The session expiration time in seconds
Depuis
2.0.0

Implémenté dans Session.

◆ getId()

getId ( )

Get the session ID

Renvoie
string The session ID
Depuis
2.0.0

Implémenté dans Session.

Référencé par MetadataManager\createOrUpdateRecord(), MetadataManager\createRecordIfNonExisting(), MetadataManager\createSessionRecord(), et MetadataManager\updateSessionRecord().

◆ getName()

getName ( )

Get the session name

Renvoie
string The session name
Depuis
2.0.0

Implémenté dans Session.

◆ getToken()

getToken ( $forceNew = false )

Get a session token.

Tokens are used to secure forms from spamming attacks. Once a token has been generated the system will check the request to see if it is present, if not it will invalidate the session.

Paramètres
boolean $forceNew If true, forces a new token to be created
Renvoie
string
Depuis
2.0.0

Implémenté dans Session.

◆ has()

has ( $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean True if the variable exists
Depuis
2.0.0

Implémenté dans Session, et Session.

◆ hasToken()

hasToken | ( | $token,
 |  | $forceExpire = true
 | ) |

Check if the session has the given token.

Paramètres
string | $token | Hashed token to be verified
boolean | $forceExpire | If true, expires the session
Renvoie
boolean
Depuis
2.0.0

Implémenté dans Session.

◆ isActive()

isActive ( )

Check if the session is active

Renvoie
boolean
Depuis
2.0.0

Implémenté dans Session.

◆ isNew()

isNew ( )

Check whether this session is newly created

Renvoie
boolean
Depuis
2.0.0

Implémenté dans Session.

Référencé par MetadataManager\createSessionRecord().

◆ isStarted()

isStarted ( )

Check if the session is started

Renvoie
boolean
Depuis
2.0.0

Implémenté dans Session.

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
2.0.0

Implémenté dans Session.

◆ restart()

restart ( )

Restart an expired or locked session

Renvoie
boolean True on success
Voir également
destroy
Depuis
2.0.0

Implémenté dans Session.

◆ set()

set | ( | $name,
 |  | $value = null
 | ) |

Set data into the session store

Paramètres
string | $name | Name of a variable.
mixed | $value | Value of a variable.
Renvoie
mixed Old value of a variable.
Depuis
2.0.0

Implémenté dans Session, et Session.

◆ setId()

setId ( string $id )

Set the session ID

Paramètres
string $id The session ID
Renvoie
$this
Depuis
2.0.0

Implémenté dans Session.

◆ setName()

setName ( string $name )

Set the session name

Paramètres
string $name The session name
Renvoie
$this
Depuis
2.0.0

Implémenté dans Session.

◆ start()

start ( )

Start a session

Renvoie
void
Depuis
2.0.0

Implémenté dans Session.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SessionInterface.php


Joomla CMS: Référence de la classe SessionState

  • Joomla
  • Session
  • SessionState
Champs de données | Fonctions membres privées
Référence de la classe SessionState

Champs de données

const | ACTIVE = 'active'
const | CLOSED = 'closed'
const | DESTROYED = 'destroyed'
const | ERROR = 'error'
const | EXPIRED = 'expired'
const | INACTIVE = 'inactive'

Fonctions membres privées

__construct ()

Description détaillée

Class defining the various states of a session

Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
2.0.0

Documentation des champs

◆ ACTIVE

const ACTIVE = 'active'

Référencé par Session\isActive(), Session\restart(), Session\start(), et Session\validate().

◆ CLOSED

const CLOSED = 'closed'

Référencé par Session\close().

◆ DESTROYED

const DESTROYED = 'destroyed'

Référencé par Session\destroy(), et Session\restart().

◆ ERROR

const ERROR = 'error'

Référencé par Session\validate().

◆ EXPIRED

const EXPIRED = 'expired'

Référencé par Session\hasToken(), Session\start(), et Session\validate().

◆ INACTIVE

const INACTIVE = 'inactive'

Référencé par Session\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SessionState.php


Joomla CMS: Référence de l'interface StorageInterface

  • Joomla
  • Session
  • StorageInterface
Fonctions membres publiques
Référence de l'interface StorageInterface
+ Graphe d'héritage de StorageInterface:
NativeStorage RuntimeStorage JoomlaStorage

Fonctions membres publiques

getName ()
setName (string $name)
getId ()
setId (string $id)
isActive ()
isStarted ()
get (string $name, $default)
set (string $name, $value)
has (string $name)
remove (string $name)
clear ()
all ()
start ()
regenerate (bool $destroy=false)
close ()
gc ()
abort ()

Description détaillée

Interface defining a Joomla! session storage object

Depuis
2.0.0

Documentation des fonctions membres

◆ abort()

abort ( )

Aborts the current session

Renvoie
boolean
Voir également
session_abort()
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ all()

all ( )

Retrieves all variables from the session store

Renvoie
array
Depuis
2.0.0

Implémenté dans JoomlaStorage, NativeStorage, et RuntimeStorage.

◆ clear()

clear ( )

Clears all variables from the session store

Renvoie
void
Depuis
2.0.0

Implémenté dans JoomlaStorage, NativeStorage, et RuntimeStorage.

◆ close()

close ( )

Writes session data and ends session

Renvoie
void
Voir également
session_write_close()
Depuis
2.0.0

Implémenté dans JoomlaStorage, NativeStorage, et RuntimeStorage.

◆ gc()

gc ( )

Perform session data garbage collection

Renvoie
integer|boolean Number of deleted sessions on success or boolean false on failure or if the function is unsupported
Voir également
session_gc()
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ get()

get | ( | string | $name,
 |  |  | $default
 | ) |  |

Get data from the session store

Paramètres
string | $name | Name of a variable
mixed | $default | Default value of a variable if not set
Renvoie
mixed Value of a variable
Depuis
2.0.0

Implémenté dans NativeStorage, RuntimeStorage, et JoomlaStorage.

◆ getId()

getId ( )

Get the session ID

Renvoie
string The session ID
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ getName()

getName ( )

Get the session name

Renvoie
string The session name
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ has()

has ( string $name )

Check whether data exists in the session store

Paramètres
string $name Name of variable
Renvoie
boolean
Depuis
2.0.0

Implémenté dans NativeStorage, RuntimeStorage, et JoomlaStorage.

◆ isActive()

isActive ( )

Check if the session is active

Renvoie
boolean
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ isStarted()

isStarted ( )

Check if the session is started

Renvoie
boolean
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ regenerate()

regenerate ( bool $destroy = false )

Regenerates the session ID that represents this storage.

This method must invoke session_regenerate_id($destroy) unless this interface is used for a storage object designed for unit or functional testing where a real PHP session would interfere with testing.

Paramètres
boolean $destroy Destroy session when regenerating?
Renvoie
boolean True on success
Voir également
session_regenerate_id()
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ remove()

remove ( string $name )

Unset a variable from the session store

Paramètres
string $name Name of variable
Renvoie
mixed The value from session or NULL if not set
Depuis
2.0.0

Implémenté dans NativeStorage, RuntimeStorage, et JoomlaStorage.

◆ set()

set | ( | string | $name,
 |  |  | $value
 | ) |  |

Set data into the session store

Paramètres
string | $name | Name of a variable
mixed | $value | Value of a variable
Renvoie
mixed Old value of a variable
Depuis
2.0.0

Implémenté dans NativeStorage, RuntimeStorage, et JoomlaStorage.

◆ setId()

setId ( string $id )

Set the session ID

Paramètres
string $id The session ID
Renvoie
$this
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ setName()

setName ( string $name )

Set the session name

Paramètres
string $name The session name
Renvoie
$this
Depuis
2.0.0

Implémenté dans NativeStorage, et RuntimeStorage.

◆ start()

start ( )

Start a session

Renvoie
void
Depuis
2.0.0

Implémenté dans NativeStorage, RuntimeStorage, et JoomlaStorage.

La documentation de cette interface a été générée à partir du fichier suivant :
  • joomla/session/src/StorageInterface.php


Joomla CMS: Référence de l'interface ValidatorInterface

  • Joomla
  • Session
  • ValidatorInterface
Fonctions membres publiques
Référence de l'interface ValidatorInterface
+ Graphe d'héritage de ValidatorInterface:
AddressValidator ForwardedValidator

Fonctions membres publiques

validate (bool $restart=false)

Description détaillée

Interface for validating a part of the session

Depuis
2.0.0

Documentation des fonctions membres

◆ validate()

validate ( bool $restart = false )

Validates the session

Paramètres
boolean $restart Flag if the session should be restarted
Renvoie
void
Depuis
2.0.0
Exceptions
Exception

Implémenté dans AddressValidator, et ForwardedValidator.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ValidatorInterface.php


Joomla CMS: Référence de la classe Inflector

  • Joomla
  • String
  • Inflector
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés statiques
Référence de la classe Inflector
+ Graphe d'héritage de Inflector:
Inflector

Fonctions membres publiques

addCountableRule ($data)
addWord ($singular, $plural='')
addPluraliseRule ($data)
addSingulariseRule ($data)
isCountable ($word)
isPlural ($word)
isSingular ($word)
toPlural ($word)
toSingular ($word)

Fonctions membres publiques statiques

static | getInstance ($new=false)
- Fonctions membres publiques statiques hérités de Inflector
static | tableize (string $word)
static | classify (string $word)
static | camelize (string $word)
static | ucwords (string $string, string $delimiters=" \\\B-")
static | reset ()
static | rules (string $type, iterable $rules, bool $reset=false)
static | pluralize (string $word)
static | singularize (string $word)

Fonctions membres privées

static addRule ($data, string $ruleType)

Attributs privés statiques

static | $instance
static | $countable

Description détaillée

Joomla Framework String Inflector Class

The Inflector transforms words

Depuis
1.0

Documentation des fonctions membres

◆ addCountableRule()

addCountableRule ( $data )

Adds a countable word.

Paramètres
mixed $data A string or an array of strings to add.
Renvoie
$this
Depuis
1.0

Références $data, $this, et Inflector\addRule().

◆ addPluraliseRule()

addPluraliseRule ( $data )

Adds a pluralisation rule.

Paramètres
mixed $data A string or an array of regex rules to add.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Use Doctrine::rules() instead.

Références $data, $this, Inflector\addRule(), et class.

◆ addRule()

static addRule | ( |  | $data,
 |  | string | $ruleType
 | ) |  |
private

Adds inflection regex rules to the inflector.

Paramètres
mixed | $data | A string or an array of strings or regex rules to add.
string | $ruleType | The rule type: singular | plural | countable
Renvoie
void
Depuis
1.0
Exceptions

Références $data, et elseif.

Référencé par Inflector\addCountableRule(), Inflector\addPluraliseRule(), et Inflector\addSingulariseRule().

◆ addSingulariseRule()

addSingulariseRule ( $data )

Adds a singularisation rule.

Paramètres
mixed $data A string or an array of regex rules to add.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Use Doctrine::rules() instead.

Références $data, $this, Inflector\addRule(), et class.

◆ addWord()

addWord | ( | $singular,
 |  | $plural = ''
 | ) |

Adds a specific singular-plural pair for a word.

Paramètres
string | $singular | The singular form of the word.
string | $plural | The plural form of the word. If omitted, it is assumed the singular and plural are identical.
Renvoie
$this
Depuis
1.0
Obsolète:
3.0 Use Doctrine::rules() instead.

Références $this, et class.

◆ getInstance()

static getInstance ( $new = false )
static

Gets an instance of the Inflector singleton.

Paramètres
boolean $new If true (default is false), returns a new instance regardless if one exists. This argument is mainly used for testing.
Renvoie
static
Depuis
1.0
Obsolète:
3.0 Use static methods without a class instance instead.

◆ isCountable()

isCountable ( $word )

Checks if a word is countable.

Paramètres
string $word The string input.
Renvoie
boolean True if word is countable, false otherwise.
Depuis
1.0

◆ isPlural()

isPlural ( $word )

Checks if a word is in a plural form.

Paramètres
string $word The string input.
Renvoie
boolean True if word is plural, false if not.
Depuis
1.0

Références Inflector\toPlural(), et Inflector\toSingular().

◆ isSingular()

isSingular ( $word )

Checks if a word is in a singular form.

Paramètres
string $word The string input.
Renvoie
boolean True if word is singular, false if not.
Depuis
1.0

Références Inflector\toSingular().

◆ toPlural()

toPlural ( $word )

Converts a word into its plural form.

Paramètres
string $word The singular word to pluralise.
Renvoie
string The word in plural form.
Depuis
1.0
Obsolète:
3.0 Use Doctrine::pluralize() instead.

Références class.

Référencé par Inflector\isPlural().

◆ toSingular()

toSingular ( $word )

Converts a word into its singular form.

Paramètres
string $word The plural word to singularise.
Renvoie
string The word in singular form.
Depuis
1.0
Obsolète:
3.0 Use Doctrine::singularize() instead.

Références class.

Référencé par Inflector\isPlural(), et Inflector\isSingular().

Documentation des champs

◆ $countable

$countable
staticprivate
Valeur initiale :
= [
'rules' => [
'id',
'hits',
'clicks',
]

◆ $instance

$instance
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • joomla/string/src/Inflector.php


Joomla CMS: Référence de la classe Normalise

  • Joomla
  • String
  • Normalise
Fonctions membres publiques statiques
Référence de la classe Normalise

Fonctions membres publiques statiques

static | fromCamelCase ($input, $grouped=false)
static | toCamelCase ($input)
static | toDashSeparated ($input)
static | toSpaceSeparated ($input)
static | toUnderscoreSeparated ($input)
static | toVariable ($input)
static | toKey ($input)

Description détaillée

Joomla Framework String Normalise Class

Depuis
1.0

Documentation des fonctions membres

◆ fromCamelCase()

static fromCamelCase | ( | $input,
 |  | $grouped = false
 | ) |
static

Method to convert a string from camel case.

This method offers two modes. Grouped allows for splitting on groups of uppercase characters as follows:

"FooBarABCDef" becomes array("Foo", "Bar", "ABC", "Def") "JFooBar" becomes array("J", "Foo", "Bar") "J001FooBar002" becomes array("J001", "Foo", "Bar002") "abcDef" becomes array("abc", "Def") "abc_defGhi_Jkl" becomes array("abc_def", "Ghi_Jkl") "ThisIsA_NASAAstronaut" becomes array("This", "Is", "A_NASA", "Astronaut")) "JohnFitzgerald_Kennedy" becomes array("John", "Fitzgerald_Kennedy"))

Non-grouped will split strings at each uppercase character.

Paramètres
string | $input | The string input (ASCII only).
boolean | $grouped | Optionally allows splitting on groups of uppercase characters.
Renvoie
array|string The space separated string, as an array if grouped.
Depuis
1.0

Références $grouped, et $input.

Référencé par FormField\__construct(), et AbstractEvent\create().

◆ toCamelCase()

static toCamelCase ( $input )
static

Method to convert a string into camel case.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The camel case string.
Depuis
1.0

Références $input.

◆ toDashSeparated()

static toDashSeparated ( $input )
static

Method to convert a string into dash separated form.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The dash separated string.
Depuis
1.0

Références $input.

◆ toKey()

static toKey ( $input )
static

Method to convert a string into key form.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The key string.
Depuis
1.0

Références $input.

◆ toSpaceSeparated()

static toSpaceSeparated ( $input )
static

Method to convert a string into space separated form.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The space separated string.
Depuis
1.0

Références $input.

Référencé par FormHelper\loadClass().

◆ toUnderscoreSeparated()

static toUnderscoreSeparated ( $input )
static

Method to convert a string into underscore separated form.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The underscore separated string.
Depuis
1.0

Références $input.

◆ toVariable()

static toVariable ( $input )
static

Method to convert a string into variable form.

Paramètres
string $input The string input (ASCII only).
Renvoie
string The variable string.
Depuis
1.0

Références $input.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Normalise.php


Joomla CMS: Référence de la classe StringHelper

  • Joomla
  • String
  • StringHelper
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe StringHelper

Fonctions membres publiques statiques

static static | increment ($string, $style='default', $n=0)
static | is_ascii ($str)
static | ord ($chr)
static | strpos ($str, $search, $offset=false)
static | strrpos ($str, $search, $offset=0)
static | substr ($str, $offset, $length=false)
static | strtolower ($str)
static | strtoupper ($str)
static | strlen ($str)
static | str_ireplace ($search, $replace, $str, $count=null)
static | str_pad ($input, $length, $padStr=' ', $type=STR_PAD_RIGHT)
static | str_split ($str, $splitLen=1)
static | strcasecmp ($str1, $str2, $locale=false)
static | strcmp ($str1, $str2, $locale=false)
static | strcspn ($str, $mask, $start=null, $length=null)
static | stristr ($str, $search)
static | strrev ($str)
static | strspn ($str, $mask, $start=null, $length=null)
static | substr_replace ($str, $repl, $start, $length=null)
static | ltrim ($str, $charlist=false)
static | rtrim ($str, $charlist=false)
static | trim ($str, $charlist=false)
static | ucfirst ($str, $delimiter=null, $newDelimiter=null)
static | ucwords ($str)
static | transcode ($source, $fromEncoding, $toEncoding)
static | valid ($str)
static | compliant ($str)
static | unicode_to_utf8 ($str)
static | unicode_to_utf16 ($str)

Attributs protégés statiques

static $incrementStyles

Description détaillée

String handling class for UTF-8 data wrapping the phputf8 library. All functions assume the validity of UTF-8 strings.

Depuis
1.3.0

Documentation des fonctions membres

◆ compliant()

static compliant ( $str )
static

Tests whether a string complies as UTF-8.

This will be much faster than StringHelper::valid() but will pass five and six octet UTF-8 sequences, which are not supported by Unicode and so cannot be displayed correctly in a browser. In other words it is not as strict as StringHelper::valid() but it's faster. If you use it to validate user input, you place yourself at the risk that attackers will be able to inject 5 and 6 byte sequences (which may or may not be a significant risk, depending on what you are are doing).

Paramètres
string $str UTF-8 string to check
Renvoie
boolean TRUE if string is valid UTF-8
Voir également
StringHelper::valid 1.3.0

Références utf8_compliant().

◆ increment()

static static increment | ( | $string,
 |  | $style = 'default',
 |  | $n = 0
 | ) |
static

Increments a trailing number in a string.

Used to easily create distinct labels when copying objects. The method has the following styles:

default: "Label" becomes "Label (2)" dash: "Label" becomes "Label-2"

Paramètres
string | $string | The source string.
string | null | $style | The the style (default|dash).
integer | $n | If supplied, this number is used for the copy, otherwise it is the 'next' number.
Renvoie
string The incremented string.
Depuis
1.3.0

Références $n, et $style.

Référencé par FieldTable\check(), GroupModel\generateGroupTitle(), StageModel\generateNewTitle(), WorkflowModel\generateNewTitle(), TransitionModel\generateNewTitle(), StyleModel\generateNewTitle(), FieldModel\generateNewTitle(), ModuleModel\generateNewTitle(), AdminModel\generateNewTitle(), CategoryModel\generateNewTitle(), ItemModel\generateNewTitle(), et ModuleModel\save().

◆ is_ascii()

static is_ascii ( $str )
static

Tests whether a string contains only 7bit ASCII bytes.

You might use this to conditionally check whether a string needs handling as UTF-8 or not, potentially offering performance benefits by using the native PHP equivalent if it's just ASCII e.g.;

if (StringHelper::is_ascii($someString)) { // It's just ASCII - use the native PHP version $someString = strtolower($someString); } else { $someString = StringHelper::strtolower($someString); }

Paramètres
string $str The string to test.
Renvoie
boolean True if the string is all ASCII
Depuis
1.3.0

Références utf8_is_ascii().

◆ ltrim()

static ltrim | ( | $str,
 |  | $charlist = false
 | ) |
static

UTF-8 aware replacement for ltrim()

Strip whitespace (or other characters) from the beginning of a string. You only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise ltrim will work normally on a UTF-8 string.

Paramètres
string | $str | The string to be trimmed
string | boolean | $charlist | The optional charlist of additional characters to trim
Renvoie
string The trimmed string

1.3.0

Références utf8_ltrim().

◆ ord()

static ord ( $chr )
static

UTF-8 aware alternative to ord()

Returns the unicode ordinal for a character.

Paramètres
string $chr UTF-8 encoded character
Renvoie
integer Unicode ordinal for the character

1.4.0

Références utf8_ord().

Référencé par OutputFilter\stringJSSafe().

◆ rtrim()

static rtrim | ( | $str,
 |  | $charlist = false
 | ) |
static

UTF-8 aware replacement for rtrim()

Strip whitespace (or other characters) from the end of a string. You only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise rtrim will work normally on a UTF-8 string.

Paramètres
string | $str | The string to be trimmed
string | boolean | $charlist | The optional charlist of additional characters to trim
Renvoie
string The trimmed string

1.3.0

Références utf8_rtrim().

◆ str_ireplace()

static str_ireplace | ( | $search,
 |  | $replace,
 |  | $str,
 |  | $count = null
 | ) |
static

UTF-8 aware alternative to str_ireplace()

Case-insensitive version of str_replace()

Paramètres
string | $search | String to search
string | $replace | Existing string to replace
string | $str | New string to replace with
integer | null | boolean | $count | Optional count value to be passed by referene
Renvoie
string UTF-8 String

1.3.0

Références $count, et utf8_ireplace().

Référencé par TagTable\check(), NewsfeedTable\check(), CoreContent\check(), ContactTable\check(), Content\check(), et Zh\tokenise().

◆ str_pad()

static str_pad | ( | $input,
 |  | $length,
 |  | $padStr = ' ',
 |  | $type = STR_PAD_RIGHT
 | ) |
static

UTF-8 aware alternative to str_pad()

Pad a string to a certain length with another string. $padStr may contain multi-byte characters.

Paramètres
string | $input | The input string.
integer | $length | If the value is negative, less than, or equal to the length of the input string, no padding takes place.
string | $padStr | The string may be truncated if the number of padding characters can't be evenly divided by the string's length.
integer | $type | The type of padding to apply
Renvoie
string

1.4.0

Références $input, $type, et utf8_str_pad().

◆ str_split()

static str_split | ( | $str,
 |  | $splitLen = 1
 | ) |
static

UTF-8 aware alternative to str_split()

Convert a string to an array.

Paramètres
string | $str | UTF-8 encoded string to process
integer | $splitLen | Number to characters to split string by
Renvoie
array|string|boolean

1.3.0

Références utf8_str_split().

◆ strcasecmp()

static strcasecmp | ( | $str1,
 |  | $str2,
 |  | $locale = false
 | ) |
static

UTF-8/LOCALE aware alternative to strcasecmp()

A case insensitive string comparison.

Paramètres
string | $str1 | string 1 to compare
string | $str2 | string 2 to compare
string | boolean | $locale | The locale used by strcoll or false to use classical comparison
Renvoie
integer < 0 if str1 is less than str2; > 0 if str1 is greater than str2, and 0 if they are equal.

https://www.php.net/strcoll https://www.php.net/setlocale 1.3.0

Références elseif, StringHelper\stristr(), utf8_strcasecmp(), et utf8_strtolower().

Référencé par ArrayHelper\sortObjects().

◆ strcmp()

static strcmp | ( | $str1,
 |  | $str2,
 |  | $locale = false
 | ) |
static

UTF-8/LOCALE aware alternative to strcmp()

A case sensitive string comparison.

Paramètres
string | $str1 | string 1 to compare
string | $str2 | string 2 to compare
mixed | $locale | The locale used by strcoll or false to use classical comparison
Renvoie
integer < 0 if str1 is less than str2; > 0 if str1 is greater than str2, and 0 if they are equal.

https://www.php.net/strcoll https://www.php.net/setlocale 1.3.0

Références elseif, et StringHelper\stristr().

Référencé par LanguagesModel\getLanguages(), et ArrayHelper\sortObjects().

◆ strcspn()

static strcspn | ( | $str,
 |  | $mask,
 |  | $start = null,
 |  | $length = null
 | ) |
static

UTF-8 aware alternative to strcspn()

Find length of initial segment not matching mask.

Paramètres
string | $str | The string to process
string | $mask | The mask
integer | boolean | $start | Optional starting character position (in characters)
integer | boolean | $length | Optional length
Renvoie
integer The length of the initial segment of str1 which does not contain any of the characters in str2

1.3.0

Références $start, et utf8_strcspn().

◆ stristr()

static stristr | ( | $str,
 |  | $search
 | ) |
static

UTF-8 aware alternative to stristr()

Returns all of haystack from the first occurrence of needle to the end. Needle and haystack are examined in a case-insensitive manner to find the first occurrence of a string using case insensitive comparison.

Paramètres
string | $str | The haystack
string | $search | The needle
Renvoie
string|boolean

1.3.0

Références utf8_stristr().

Référencé par StringHelper\strcasecmp(), StringHelper\strcmp(), ContactEmailRule\test(), ContactEmailSubjectRule\test(), et ContactEmailMessageRule\test().

◆ strlen()

static strlen ( $str )
static

UTF-8 aware alternative to strlen()

Returns the number of characters in the string (NOT THE NUMBER OF BYTES).

Paramètres
string $str UTF-8 string.
Renvoie
integer Number of UTF-8 characters in string.

1.3.0

Références utf8_strlen().

Référencé par Token\__construct(), User\check(), InputFilter\cleanTags(), TextDescriptor\describeJoomlaApplication(), Application\doRenderThrowable(), InputFilter\escapeAttributeValues(), TextDescriptor\getColumnWidth(), et Query\processString().

◆ strpos()

static strpos | ( | $str,
 |  | $search,
 |  | $offset = false
 | ) |
static

UTF-8 aware alternative to strpos()

Find position of first occurrence of a string.

Paramètres
string | $str | String being examined
string | $search | String being searched for
integer | null | boolean | $offset | Optional, specifies the position from which the search should be performed
Renvoie
integer|boolean Number of characters before the first match or FALSE on failure

1.3.0

Références Joomla\Database\Query\$offset, et utf8_strpos().

Référencé par InputFilter\cleanTags(), RandomImageHelper\getFolder(), ActionlogsHelper\getHumanReadableLogMessage(), Helper\getPrimaryLanguage(), HelpModel\getToc(), et Query\processString().

◆ strrev()

static strrev ( $str )
static

UTF-8 aware alternative to strrev()

Reverse a string.

Paramètres
string $str String to be reversed
Renvoie
string The string in reverse character order

1.3.0

Références utf8_strrev().

◆ strrpos()

static strrpos | ( | $str,
 |  | $search,
 |  | $offset = 0
 | ) |
static

UTF-8 aware alternative to strrpos()

Finds position of last occurrence of a string.

Paramètres
string | $str | String being examined.
string | $search | String being searched for.
integer | $offset | Offset from the left of the string.
Renvoie
integer|boolean Number of characters before the last match or false on failure

1.3.0

Références Joomla\Database\Query\$offset, et utf8_strrpos().

◆ strspn()

static strspn | ( | $str,
 |  | $mask,
 |  | $start = null,
 |  | $length = null
 | ) |
static

UTF-8 aware alternative to strspn()

Find length of initial segment matching mask.

Paramètres
string | $str | The haystack
string | $mask | The mask
integer | null | $start | Start optional
integer | null | $length | Length optional
Renvoie
integer

1.3.0

Références $start, null, et utf8_strspn().

◆ strtolower()

static strtolower ( $str )
static

UTF-8 aware alternative to strtolower()

Make a string lowercase

Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings

Paramètres
string $str String being processed
Renvoie
string|boolean Either string in lowercase or FALSE is UTF-8 invalid

1.3.0

Références utf8_strtolower().

Référencé par SuggestionsModel\getListQuery(), TracksModel\getListQuery(), StylesModel\getListQuery(), TemplatesModel\getListQuery(), ModulesModel\getListQuery(), HelpModel\getToc(), SearchModel\populateState(), Query\processDates(), Query\processString(), SiteApplication\route(), CMSApplication\route(), OutputFilter\stringURLSafe(), OutputFilter\stringUrlSafe(), OutputFilter\stringUrlUnicodeSlug(), Language\tokenise(), et Language\transliterate().

◆ strtoupper()

static strtoupper ( $str )
static

UTF-8 aware alternative to strtoupper()

Make a string uppercase

Note: The concept of a characters "case" only exists is some alphabets such as Latin, Greek, Cyrillic, Armenian and archaic Georgian - it does not exist in the Chinese alphabet, for example. See Unicode Standard Annex #21: Case Mappings

Paramètres
string $str String being processed
Renvoie
string|boolean Either string in uppercase or FALSE is UTF-8 invalid

1.3.0

Références utf8_strtoupper().

◆ substr()

static substr | ( | $str,
 |  | $offset,
 |  | $length = false
 | ) |
static

UTF-8 aware alternative to substr()

Return part of a string given character offset (and optionally length).

Paramètres
string | $str | String being processed
integer | $offset | Number of UTF-8 characters offset (from left)
integer | null | boolean | $length | Optional length in UTF-8 characters from offset
Renvoie
string|boolean

1.3.0

Références Joomla\Database\Query\$offset, et utf8_substr().

Référencé par InputFilter\cleanTags(), InputFilter\escapeAttributeValues(), Helper\getPrimaryLanguage(), ArticlesCategoryHelper\groupByDate(), Indexer\index(), et Query\processString().

◆ substr_replace()

static substr_replace | ( | $str,
 |  | $repl,
 |  | $start,
 |  | $length = null
 | ) |
static

UTF-8 aware alternative to substr_replace()

Replace text within a portion of a string.

Paramètres
string | $str | The haystack
string | $repl | The replacement string
integer | $start | Start
integer | boolean | null | $length | Length (optional)
Renvoie
string

1.3.0

Références $start, et utf8_substr_replace().

◆ transcode()

static transcode | ( | $source,
 |  | $fromEncoding,
 |  | $toEncoding
 | ) |
static

Transcode a string.

Paramètres
string | $source | The string to transcode.
string | $fromEncoding | The source encoding.
string | $toEncoding | The target encoding.
Renvoie
string|null The transcoded string, or null if the source was not a string.

1.3.0

◆ trim()

static trim | ( | $str,
 |  | $charlist = false
 | ) |
static

UTF-8 aware replacement for trim()

Strip whitespace (or other characters) from the beginning and end of a string. You only need to use this if you are supplying the charlist optional arg and it contains UTF-8 characters. Otherwise trim will work normally on a UTF-8 string

Paramètres
string | $str | The string to be trimmed
string | boolean | $charlist | The optional charlist of additional characters to trim
Renvoie
string The trimmed string

1.3.0

Références utf8_trim().

Référencé par InputFilter\cleanTrim(), et Indexer\tokenizeToDb().

◆ ucfirst()

static ucfirst | ( | $str,
 |  | $delimiter = null,
 |  | $newDelimiter = null
 | ) |
static

UTF-8 aware alternative to ucfirst()

Make a string's first character uppercase or all words' first character uppercase.

Paramètres
string | $str | String to be processed
string | null | $delimiter | The words delimiter (null means do not split the string)
string | null | $newDelimiter | The new words delimiter (null means equal to $delimiter)
Renvoie
string If $delimiter is null, return the string with first character as upper case (if applicable) else consider the string of words separated by the delimiter, apply the ucfirst to each words and return the string with the new delimiter

1.3.0

Références null, et utf8_ucfirst().

Référencé par FormField\__construct(), et FormHelper\loadClass().

◆ ucwords()

static ucwords ( $str )
static

UTF-8 aware alternative to ucwords()

Uppercase the first character of each word in a string.

Paramètres
string $str String to be processed
Renvoie
string String with first char of each word uppercase

1.3.0

Références utf8_ucwords().

◆ unicode_to_utf16()

static unicode_to_utf16 ( $str )
static

Converts Unicode sequences to UTF-16 string.

Paramètres
string $str Unicode string to convert
Renvoie
string UTF-16 string
Depuis
1.3.0

◆ unicode_to_utf8()

static unicode_to_utf8 ( $str )
static

Converts Unicode sequences to UTF-8 string.

Paramètres
string $str Unicode string to convert
Renvoie
string UTF-8 string
Depuis
1.3.0

◆ valid()

static valid ( $str )
static

Tests a string as to whether it's valid UTF-8 and supported by the Unicode standard.

Note: this function has been modified to simple return true or false.

Paramètres
string $str UTF-8 encoded string.
Renvoie
boolean true if valid
Auteur
hsivo.nosp@m.nen@.nosp@m.iki.f.nosp@m.i compliant 1.3.0

Références utf8_is_valid().

Référencé par UrlRule\test().

Documentation des champs

◆ $incrementStyles

$incrementStyles
staticprotected
Valeur initiale :
= [
'dash' => [
'#-(\d+)$#',
'-%d',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/string/src/StringHelper.php


Joomla CMS: Référence de la classe AbstractUri

  • Joomla
  • Uri
  • AbstractUri
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe AbstractUri
+ Graphe d'héritage de AbstractUri:
UriInterface Uri UriImmutable Uri

Fonctions membres publiques

__construct ($uri=null)
__toString ()
toString ($parts=['scheme', 'user', 'pass', 'host', 'port', 'path', 'query', 'fragment'])
render ($parts=self::ALL)
hasVar ($name)
getVar ($name, $default=null)
getQuery ($toArray=false)
getScheme ()
getUser ()
getPass ()
getHost ()
getPort ()
getPath ()
getFragment ()
isSsl ()

Fonctions membres protégées

parse ($uri)
cleanPath ($path)

Fonctions membres protégées statiques

static buildQuery (array $params)

Attributs protégés

$uri
$scheme
$host
$port
$user
$pass
$path
$query
$fragment
$vars = []

Membres hérités additionnels

- Champs de données hérités de UriInterface
const | SCHEME = 1
const | USER = 2
const | PASS = 4
const | HOST = 8
const | PORT = 16
const | PATH = 32
const | QUERY = 64
const | FRAGMENT = 128
const | ALL = 255

Description détaillée

Base Joomla Uri Class

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $uri = null )

Constructor.

You can pass a URI string to the constructor to initialise a specific URI.

Paramètres
string $uri The optional URI string
Depuis
1.0

Références AbstractUri\$uri, null, et AbstractUri\parse().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic method to get the string representation of the UriInterface object.

Renvoie
string
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\toString().

◆ buildQuery()

static buildQuery ( array $params )
staticprotected

Build a query from an array (reverse of the PHP parse_str()).

Paramètres
array $params The array of key => value pairs to return as a query string.
Renvoie
string The resulting query string.
Voir également
parse_str()
Depuis
1.0

Références $params.

◆ cleanPath()

cleanPath ( $path )
protected

Resolves //, ../ and ./ from a path and returns the result.

For example: /foo/bar/../boo.php => /foo/boo.php /foo/bar/../../boo.php => /boo.php /foo/bar/.././/boo.php => /foo/boo.php

Paramètres
string $path The URI path to clean.
Renvoie
string Cleaned and resolved URI path.
Depuis
1.0

Références $i, $n, AbstractUri\$path, et elseif.

Référencé par Uri\setPath().

◆ getFragment()

getFragment ( )

Get the URI anchor string

Renvoie
string The URI anchor string.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$fragment.

◆ getHost()

getHost ( )

Get the URI host

Renvoie
string The hostname/IP or null if no hostname/IP was specified.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$host.

◆ getPass()

getPass ( )

Get the URI password

Renvoie
string The password, or null if no password was specified.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$pass.

◆ getPath()

getPath ( )

Gets the URI path string

Renvoie
string The URI path string.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$path.

◆ getPort()

getPort ( )

Get the URI port

Renvoie
integer The port number, or null if no port was specified.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$port.

◆ getQuery()

getQuery ( $toArray = false )

Returns flat query string.

Paramètres
boolean $toArray True to return the query as a key => value pair array.
Renvoie
string|array Query string or Array of parts in query string depending on the function param
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$query, AbstractUri\$vars, et null.

Référencé par AbstractUri\render().

◆ getScheme()

getScheme ( )

Get the URI scheme (protocol)

Renvoie
string The URI scheme.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$scheme.

Référencé par AbstractUri\isSsl().

◆ getUser()

getUser ( )

Get the URI username

Renvoie
string The username, or null if no username was specified.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\$user.

◆ getVar()

getVar | ( | $name,
 |  | $default = null
 | ) |

Returns a query variable by name.

Paramètres
string | $name | Name of the query variable to get.
string | $default | Default value to return if the variable is not set.
Renvoie
mixed Requested query variable if present otherwise the default value.
Depuis
1.0

Implémente UriInterface.

Références $default, et $name.

◆ hasVar()

hasVar ( $name )

Checks if variable exists.

Paramètres
string $name Name of the query variable to check.
Renvoie
boolean True if the variable exists.
Depuis
1.0

Implémente UriInterface.

Références $name.

◆ isSsl()

isSsl ( )

Checks whether the current URI is using HTTPS.

Renvoie
boolean True if using SSL via HTTPS.
Depuis
1.0

Implémente UriInterface.

Références AbstractUri\getScheme().

◆ parse()

parse ( $uri )
protected

Parse a given URI and populate the class fields.

Paramètres
string $uri The URI string to parse.
Renvoie
boolean True on success.
Depuis
1.0

Références $key, $parts, AbstractUri\$uri, $value, et UriHelper\parse_url().

Référencé par AbstractUri\__construct().

◆ render()

render ( $parts = self::ALL )

Returns full uri string.

Paramètres
integer $parts A bitmask specifying the parts to render.
Renvoie
string The rendered URI string.
Depuis
1.2.0

Références $parts, AbstractUri\$query, AbstractUri\$uri, AbstractUri\getQuery(), et path.

Référencé par AbstractUri\toString().

◆ toString()

toString | ( |  | $parts = ['scheme',
 |  | 'user' | ,
 |  | 'pass' | ,
 |  | 'host' | ,
 |  | 'port' | ,
 |  | 'path' | ,
 |  | 'query' | ,
 |  | 'fragment'] |
 | ) |  |

Returns full URI string.

Paramètres
array $parts An array of strings specifying the parts to render.
Renvoie
string The rendered URI string.
Depuis
1.0

Implémente UriInterface.

Références $parts, et AbstractUri\render().

Référencé par AbstractUri\__toString().

Documentation des champs

◆ $fragment

$fragment
protected

Référencé par AbstractUri\getFragment().

◆ $host

$host
protected

Référencé par AbstractUri\getHost(), et Uri\setHost().

◆ $pass

$pass
protected

Référencé par AbstractUri\getPass(), et Uri\setPass().

◆ $path

$path
protected

Référencé par AbstractUri\cleanPath(), AbstractUri\getPath(), et Uri\setPath().

◆ $port

$port
protected

Référencé par AbstractUri\getPort(), et Uri\setPort().

◆ $query

$query
protected

Référencé par AbstractUri\getQuery(), AbstractUri\render(), et Uri\setQuery().

◆ $scheme

$scheme
protected

Référencé par AbstractUri\getScheme(), et Uri\setScheme().

◆ $uri

$uri
protected

Référencé par UriImmutable\__construct(), AbstractUri\__construct(), AbstractUri\parse(), et AbstractUri\render().

◆ $user

$user
protected

Référencé par AbstractUri\getUser(), et Uri\setUser().

◆ $vars

$vars = []
protected

Référencé par AbstractUri\getQuery().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractUri.php


Joomla CMS: Référence de la classe Uri

  • Joomla
  • Uri
  • Uri
Fonctions membres publiques
Référence de la classe Uri
+ Graphe d'héritage de Uri:
AbstractUri UriInterface Uri

Fonctions membres publiques

setVar ($name, $value)
delVar ($name)
setQuery ($query)
setScheme ($scheme)
setUser ($user)
setPass ($pass)
setHost ($host)
setPort ($port)
setPath ($path)
setFragment ($anchor)
- Fonctions membres publiques hérités de AbstractUri
__construct ($uri=null)
__toString ()
toString ($parts=['scheme', 'user', 'pass', 'host', 'port', 'path', 'query', 'fragment'])
render ($parts=self::ALL)
hasVar ($name)
getVar ($name, $default=null)
getQuery ($toArray=false)
getScheme ()
getUser ()
getPass ()
getHost ()
getPort ()
getPath ()
getFragment ()
isSsl ()

Membres hérités additionnels

- Champs de données hérités de UriInterface
const | SCHEME = 1
const | USER = 2
const | PASS = 4
const | HOST = 8
const | PORT = 16
const | PATH = 32
const | QUERY = 64
const | FRAGMENT = 128
const | ALL = 255
- Fonctions membres protégées hérités de AbstractUri
parse ($uri)
cleanPath ($path)
- Fonctions membres protégées statiques hérités de AbstractUri
static | buildQuery (array $params)
- Attributs protégés hérités de AbstractUri
$uri
$scheme
$host
$port
$user
$pass
$path
$query
$fragment
$vars = []

Description détaillée

Uri Class

This class parses a URI and provides a common interface for the Joomla Framework to access and manipulate a URI.

Depuis
1.0

Documentation des fonctions membres

◆ delVar()

delVar ( $name )

Removes an item from the query string variables if it exists

Paramètres
string $name Name of variable to remove.
Renvoie
void
Depuis
1.0

Références $name, et null.

◆ setFragment()

setFragment ( $anchor )

Set the URI anchor string

Paramètres
string $anchor The URI anchor string.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références $this.

◆ setHost()

setHost ( $host )

Set the URI host

Paramètres
string $host The URI host.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références AbstractUri\$host, et $this.

◆ setPass()

setPass ( $pass )

Set the URI password

Paramètres
string $pass The URI password.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références AbstractUri\$pass, et $this.

◆ setPath()

setPath ( $path )

Set the URI path string

Paramètres
string $path The URI path string.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références AbstractUri\$path, $this, AbstractUri\cleanPath(), et path.

◆ setPort()

setPort ( $port )

Set the URI port

Paramètres
integer $port The URI port number.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références AbstractUri\$port, et $this.

◆ setQuery()

setQuery ( $query )

Sets the query to a supplied string in format foo=bar&x=y

Paramètres
array | string $query The query string or array.
Renvoie
void
Depuis
1.0

Références AbstractUri\$query, et null.

◆ setScheme()

setScheme ( $scheme )

Set the URI scheme (protocol)

Paramètres
string $scheme The URI scheme.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références AbstractUri\$scheme, et $this.

◆ setUser()

setUser ( $user )

Set the URI username

Paramètres
string $user The URI username.
Renvoie
Uri This method supports chaining.
Depuis
1.0

Références $this, et AbstractUri\$user.

◆ setVar()

setVar | ( | $name,
 |  | $value
 | ) |

Adds a query variable and value, replacing the value if it already exists and returning the old value

Paramètres
string | $name | Name of the query variable to set.
string | $value | Value of the query variable.
Renvoie
string Previous value for the query variable.
Depuis
1.0

Références $name, $tmp, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/joomla/uri/src/Uri.php


Joomla CMS: Référence de la classe UriHelper

  • Joomla
  • Uri
  • UriHelper
Fonctions membres publiques statiques
Référence de la classe UriHelper

Fonctions membres publiques statiques

static parse_url ($url, $component=-1)

Description détaillée

Uri Helper

This class provides a UTF-8 safe version of parse_url().

Depuis
1.0

Documentation des fonctions membres

◆ parse_url()

static parse_url | ( | $url,
 |  | $component = -1
 | ) |
static

Does a UTF-8 safe version of PHP parse_url function

Paramètres
string | $url | URL to parse
integer | $component | Retrieve just a specific URL component
Renvoie
array|boolean Associative array or false if badly formed URL.

1.0

Références $component, $parts, $result, et $url.

Référencé par AbstractUri\parse(), UrlRule\test(), PunycodeHelper\urlToPunycode(), et PunycodeHelper\urlToUTF8().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UriHelper.php


Joomla CMS: Référence de la classe UriImmutable

  • Joomla
  • Uri
  • UriImmutable
Fonctions membres publiques | Attributs privés
Référence de la classe UriImmutable
+ Graphe d'héritage de UriImmutable:
AbstractUri UriInterface

Fonctions membres publiques

__set ($name, $value)
__construct ($uri=null)
- Fonctions membres publiques hérités de AbstractUri
__construct ($uri=null)
__toString ()
toString ($parts=['scheme', 'user', 'pass', 'host', 'port', 'path', 'query', 'fragment'])
render ($parts=self::ALL)
hasVar ($name)
getVar ($name, $default=null)
getQuery ($toArray=false)
getScheme ()
getUser ()
getPass ()
getHost ()
getPort ()
getPath ()
getFragment ()
isSsl ()

Attributs privés

$constructed = false

Membres hérités additionnels

- Champs de données hérités de UriInterface
const | SCHEME = 1
const | USER = 2
const | PASS = 4
const | HOST = 8
const | PORT = 16
const | PATH = 32
const | QUERY = 64
const | FRAGMENT = 128
const | ALL = 255
- Fonctions membres protégées hérités de AbstractUri
parse ($uri)
cleanPath ($path)
- Fonctions membres protégées statiques hérités de AbstractUri
static | buildQuery (array $params)
- Attributs protégés hérités de AbstractUri
$uri
$scheme
$host
$port
$user
$pass
$path
$query
$fragment
$vars = []

Description détaillée

UriImmutable Class

This is an immutable version of the AbstractUri class.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $uri = null )

This is a special constructor that prevents calling the __construct method again.

Paramètres
string $uri The optional URI string
Depuis
1.0
Exceptions

Références AbstractUri\$uri, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __set()

__set | ( | $name,
 |  | $value
 | ) |

Prevent setting undeclared properties.

Paramètres
string | $name | This is an immutable object, setting $name is not allowed.
mixed | $value | This is an immutable object, setting $value is not allowed.
Renvoie
void This method always throws an exception.
Depuis
1.0
Exceptions

Documentation des champs

◆ $constructed

$constructed = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • UriImmutable.php


Joomla CMS: Référence de l'interface UriInterface

  • Joomla
  • Uri
  • UriInterface
Fonctions membres publiques | Champs de données
Référence de l'interface UriInterface
+ Graphe d'héritage de UriInterface:
AbstractUri Uri UriImmutable Uri

Fonctions membres publiques

__toString ()
toString ($parts=['scheme', 'user', 'pass', 'host', 'port', 'path', 'query', 'fragment'])
hasVar ($name)
getVar ($name, $default=null)
getQuery ($toArray=false)
getScheme ()
getUser ()
getPass ()
getHost ()
getPort ()
getPath ()
getFragment ()
isSsl ()

Champs de données

const | SCHEME = 1
const | USER = 2
const | PASS = 4
const | HOST = 8
const | PORT = 16
const | PATH = 32
const | QUERY = 64
const | FRAGMENT = 128
const | ALL = 255

Description détaillée

Uri Interface

Interface for read-only access to URIs.

Depuis
1.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Magic method to get the string representation of the URI object.

Renvoie
string
Depuis
1.0

Implémenté dans AbstractUri.

◆ getFragment()

getFragment ( )

Get the URI archor string

Renvoie
string The URI anchor string.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getHost()

getHost ( )

Get the URI host

Renvoie
string The hostname/IP or null if no hostname/IP was specified.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getPass()

getPass ( )

Get the URI password

Renvoie
string The password, or null if no password was specified.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getPath()

getPath ( )

Gets the URI path string

Renvoie
string The URI path string.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getPort()

getPort ( )

Get the URI port

Renvoie
integer The port number, or null if no port was specified.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getQuery()

getQuery ( $toArray = false )

Returns flat query string.

Paramètres
boolean $toArray True to return the query as a key => value pair array.
Renvoie
array|string Query string, optionally as an array.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getScheme()

getScheme ( )

Get the URI scheme (protocol)

Renvoie
string The URI scheme.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getUser()

getUser ( )

Get the URI username

Renvoie
string The username, or null if no username was specified.
Depuis
1.0

Implémenté dans AbstractUri.

◆ getVar()

getVar | ( | $name,
 |  | $default = null
 | ) |

Returns a query variable by name.

Paramètres
string | $name | Name of the query variable to get.
string | $default | Default value to return if the variable is not set.
Renvoie
mixed Requested query variable if present otherwise the default value.
Depuis
1.0

Implémenté dans AbstractUri.

◆ hasVar()

hasVar ( $name )

Checks if variable exists.

Paramètres
string $name Name of the query variable to check.
Renvoie
boolean True if the variable exists.
Depuis
1.0

Implémenté dans AbstractUri.

◆ isSsl()

isSsl ( )

Checks whether the current URI is using HTTPS.

Renvoie
boolean True if using SSL via HTTPS.
Depuis
1.0

Implémenté dans AbstractUri.

◆ toString()

toString | ( |  | $parts = ['scheme',
 |  | 'user' | ,
 |  | 'pass' | ,
 |  | 'host' | ,
 |  | 'port' | ,
 |  | 'path' | ,
 |  | 'query' | ,
 |  | 'fragment'] |
 | ) |  |

Returns full URI string.

Paramètres
array $parts An array of strings specifying the parts to render.
Renvoie
string The rendered URI string.
Depuis
1.0

Implémenté dans AbstractUri.

Documentation des champs

◆ ALL

const ALL = 255

◆ FRAGMENT

const FRAGMENT = 128

◆ HOST

const HOST = 8

◆ PASS

const PASS = 4

◆ PATH

const PATH = 32

◆ PORT

const PORT = 16

◆ QUERY

const QUERY = 64

◆ SCHEME

const SCHEME = 1

◆ USER

const USER = 2
La documentation de cette interface a été générée à partir du fichier suivant :
  • joomla/uri/src/UriInterface.php


Joomla CMS: Référence de la classe ArrayHelper

  • Joomla
  • Utilities
  • ArrayHelper
Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques
Référence de la classe ArrayHelper

Fonctions membres publiques statiques

static | toInteger ($array, $default=null)
static | toObject (array $array, $class='stdClass', $recursive=true)
static | toString (array $array, $innerGlue='=', $outerGlue=' ', $keepOuterKey=false)
static | fromObject ($source, $recurse=true, $regex=null)
static | addColumn (array $array, array $column, $colName, $keyCol=null)
static | dropColumn (array $array, $colName)
static | getColumn (array $array, $valueCol, $keyCol=null)
static | getValue ($array, $name, $default=null, $type='')
static | invert (array $array)
static | isAssociative ($array)
static | pivot (array $source, $key=null)
static | sortObjects (array $a, $k, $direction=1, $caseSensitive=true, $locale=false)
static | arrayUnique (array $array)
static | arraySearch ($needle, array $haystack, $caseSensitive=true)
static | flatten ($array, $separator='.', $prefix='')
static | mergeRecursive (... $args)

Fonctions membres privées

__construct ()

Fonctions membres privées statiques

static arrayFromObject ($item, $recurse, $regex)

Description détaillée

ArrayHelper is an array utility class for doing all sorts of odds and ends with arrays.

Depuis
1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
1.0

Documentation des fonctions membres

◆ addColumn()

static addColumn | ( | array | $array,
 |  | array | $column,
 |  |  | $colName,
 |  |  | $keyCol = null
 | ) |  |
static

Adds a column to an array of arrays or objects

Paramètres
array | $array | The source array
array | $column | The array to be used as new column
string | $colName | The index of the new column or name of the new object property
string | $keyCol | The index of the column or name of object property to be used for mapping with the new column
Renvoie
array An array with the new column added to the source array
Depuis
1.5.0
Voir également
https://www.php.net/manual/en/language.types.array.php

Références $i, $item, $result, $subject, $value, et null.

◆ arrayFromObject()

static arrayFromObject | ( | $item,
 |  | $recurse,
 |  | $regex
 | ) |
staticprivate

Utility function to map an object or array to an array

Paramètres
mixed | $item | The source object or array
boolean | $recurse | True to recurse through multi-level objects
string | $regex | An optional regular expression to match on field names
Renvoie
array
Depuis
1.0

Références $item, et $result.

◆ arraySearch()

static arraySearch | ( |  | $needle,
 |  | array | $haystack,
 |  |  | $caseSensitive = true
 | ) |  |
static

An improved array_search that allows for partial matching of strings values in associative arrays.

Paramètres
string | $needle | The text to search for within the array.
array | $haystack | Associative array to search in to find $needle.
boolean | $caseSensitive | True to search case sensitive, false otherwise.
Renvoie
mixed Returns the matching array $key if found, otherwise false.
Depuis
1.0

Références $key, et $value.

◆ arrayUnique()

static arrayUnique ( array $array )
static

Multidimensional array safe unique test

Paramètres
array $array The array to make unique.
Renvoie
array
Voir également
https://www.php.net/manual/en/function.array-unique.php
Depuis
1.0

◆ dropColumn()

static dropColumn | ( | array | $array,
 |  |  | $colName
 | ) |  |
static

Remove a column from an array of arrays or objects

Paramètres
array | $array | The source array
string | $colName | The index of the column or name of object property to be removed
Renvoie
array Column of values from the source array
Depuis
1.5.0
Voir également
https://www.php.net/manual/en/language.types.array.php

Références $i, $item, $result, et elseif.

Référencé par PlgPrivacyUser\createNotesDomain().

◆ flatten()

static flatten | ( | $array,
 |  | $separator = '.',
 |  | $prefix = ''
 | ) |
static

Method to recursively convert data to a one dimension array.

Paramètres
array | object | $array | The array or object to convert.
string | $separator | The key separator.
string | $prefix | Last level key prefix.
Renvoie
array
Depuis
1.3.0

Références $key, $prefix, $result, $separator, et elseif.

◆ fromObject()

static fromObject | ( | $source,
 |  | $recurse = true,
 |  | $regex = null
 | ) |
static

Utility function to map an object to an array

Paramètres
object | $source | The source object
boolean | $recurse | True to recurse through multi-level objects
string | $regex | An optional regular expression to match on field names
Renvoie
array
Depuis
1.0

Référencé par ExecRuleHelper\__construct(), AssociationExtensionHelper\getAssociationList(), ApplicationModel\getData(), ItemlanguageField\getOptions(), RemindModel\processRemindRequest(), ApplicationModel\removeroot(), ApplicationModel\save(), et DatabaseHelper\validateConnectionParameters().

◆ getColumn()

static getColumn | ( | array | $array,
 |  |  | $valueCol,
 |  |  | $keyCol = null
 | ) |  |
static

Extracts a column from an array of arrays or objects

Paramètres
array | $array | The source array
string | $valueCol | The index of the column or name of object property to be used as value It may also be NULL to return complete arrays or objects (this is useful together with $keyCol to reindex the array).
string | $keyCol | The index of the column or name of object property to be used as key
Renvoie
array Column of values from the source array
Depuis
1.0
Voir également
https://www.php.net/manual/en/language.types.array.php
https://www.php.net/manual/en/function.array-column.php

Référencé par TagField\getOptions(), ArticlesModel\getTransitions(), et UpdateModel\isTemplateActive().

◆ getValue()

static getValue | ( | $array,
 |  | $name,
 |  | $default = null,
 |  | $type = ''
 | ) |
static

Utility function to return a value from a named array or a specified default

Paramètres
array | \ArrayAccess | $array | A named array or object that implements ArrayAccess
string | $name | The key to search for (this can be an array index or a dot separated key sequence as in Registry)
mixed | $default | The default value to give if no key found
string | $type | Return type for the variable (INT, FLOAT, STRING, WORD, BOOLEAN, ARRAY)
Renvoie
mixed
Depuis
1.0
Exceptions

Références $default, $name, $result, $type, elseif, et null.

Référencé par NewsfeedController\allowAdd(), ContactController\allowAdd(), BannerController\allowAdd(), ArticleController\allowAdd(), AdminModel\batch(), UserModel\batch(), ItemModel\batchCopy(), CategoryModel\batchCopy(), ItemModel\batchMove(), User\bind(), UsersController\changeBlock(), AdministratorService\featured(), Workflow\getConditionName(), PluginModel\getForm(), StyleModel\getForm(), ItemModel\getForm(), ModuleModel\getForm(), ExecRuleHelper\getFromTask(), MenutypeField\getInput(), Joomla\Component\Scheduler\Administrator\Traits\getRoutineId(), Task\isValidState(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), PlgUserProfile\onUserAfterDelete(), PlgUserProfile\onUserAfterSave(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), Redirect\published(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), et Messages\status().

◆ invert()

static invert ( array $array )
static

Takes an associative array of arrays and inverts the array keys to values using the array values as keys.

Example: $input = array( 'New' => array('1000', '1500', '1750'), 'Used' => array('3000', '4000', '5000', '6000') ); $output = ArrayHelper::invert($input);

Output would be equal to: $output = array( '1000' => 'New', '1500' => 'New', '1750' => 'New', '3000' => 'Used', '4000' => 'Used', '5000' => 'Used', '6000' => 'Used' );

Paramètres
array $array The source array.
Renvoie
array
Depuis
1.0

Références $base, $key, et $return.

◆ isAssociative()

static isAssociative ( $array )
static

Method to determine if an array is an associative array.

Paramètres
array $array An array to test.
Renvoie
boolean
Depuis
1.0

Référencé par Form\bindLevel(), et Ini\objectToString().

◆ mergeRecursive()

static mergeRecursive ( $args )
static

Merge array recursively.

Paramètres
array ...$args Array list to be merged.
Renvoie
array Merged array.
Depuis
2.0.0
Exceptions

Références $i, $key, $result, et $value.

Référencé par ToolbarButton\__construct(), et ActionButton\render().

◆ pivot()

static pivot | ( | array | $source,
 |  |  | $key = null
 | ) |  |
static

Pivots an array to create a reverse lookup of an array of scalars, arrays or objects.

Paramètres
array | $source | The source array.
string | $key | Where the elements of the source array are objects or arrays, the key to pivot on.
Renvoie
array An array of arrays pivoted either on the value of the keys, or an individual key of an object or array.
Depuis
1.0

Références $key, $result, $value, et elseif.

◆ sortObjects()

static sortObjects | ( | array | $a,
 |  |  | $k,
 |  |  | $direction = 1,
 |  |  | $caseSensitive = true,
 |  |  | $locale = false
 | ) |  |
static

Utility function to sort an array of objects on a given field

Paramètres
array | $a | An array of objects
mixed | $k | The key (string) or an array of keys to sort on
mixed | $direction | Direction (integer) or an array of direction to sort in [1 = Ascending] [-1 = Descending]
mixed | $caseSensitive | Boolean or array of booleans to let sort occur case sensitive or insensitive
mixed | $locale | Boolean or array of booleans to let sort occur using the locale language or not
Renvoie
array
Depuis
1.0

Références $b, $count, $direction, $i, $key, elseif, StringHelper\strcasecmp(), et StringHelper\strcmp().

Référencé par InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), CategoryModel\getChildren(), DebugHelper\getComponents(), CacheModel\getData(), InstalledModel\getData(), SelectModel\getItems(), ModulesHelper\getModules(), ComponentsField\getOptions(), ComponentsCategoryField\getOptions(), ConfigComponentsField\getOptions(), ComponentsWorkflowField\getOptions(), ContenttypesField\getOptions(), TaskTypeField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), Finder\mapslist(), Modules\positions(), Menu\preprocess(), et CssMenu\preprocess().

◆ toInteger()

static toInteger | ( | $array,
 |  | $default = null
 | ) |
static

Function to convert array to integer values

Paramètres
array | $array | The source array to convert
int | array | $default | A default value to assign if $array is not an array
Renvoie
array
Depuis
1.0

Références $default, et null.

Référencé par PlgContentJoomla\_countItemsInStage(), LinkModel\activate(), AdministratorService\association(), AdminModel\batch(), UserModel\batch(), ItemModel\batchMove(), CategoryModel\batchMove(), UserModel\batchReset(), UserModel\batchUser(), User\bind(), Router\build(), Category\categories(), TemplateModel\copyStyles(), MenuModel\delete(), ActionlogsModel\delete(), FieldModel\delete(), AdminModel\delete(), Workflow\deleteAssociation(), DiscoverModel\discover_install(), LinkModel\duplicateUrls(), Workflow\executeTransition(), ContactModel\featured(), ArticleModel\featured(), IntarrayFilter\filter(), Query\getExcludedTermIds(), MenuModel\getExtensionElementsForMenuItems(), FieldModel\getFieldValues(), FieldsModel\getGroups(), Access\getGroupsByUser(), Query\getIncludedTermIds(), CategoryModel\getItem(), BannersModel\getListQuery(), SuggestionsModel\getListQuery(), GroupsModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), FeaturedModel\getListQuery(), CategoriesModel\getListQuery(), ArticlesModel\getListQuery(), ActionlogsModel\getLogDataQuery(), FieldgroupsField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), FinderHelper\getQuery(), Query\getRequiredTermIds(), TagsHelper\getTagIds(), TagsHelper\getTagItemsQuery(), TagsHelper\getTagNames(), ArticlesModel\getTransitions(), TagsHelper\getTypes(), Access\getUsersByGroup(), Workflow\getValidTransition(), ConsentsModel\invalidate(), Joomla\onContentChangeState(), PlgContentJoomla\onContentChangeState(), Category\options(), Tag\options(), UsersModel\populateState(), TagModel\populateState(), Query\processDynamicTaxonomy(), Query\processStaticTaxonomy(), Nested\publish(), FieldModel\save(), StyleModel\save(), CategoryModel\save(), AdminModel\save(), ItemModel\save(), TagsHelper\searchTags(), UserHelper\setUserGroups(), Tag\tags(), TagsHelper\unTagItem(), Workflow\updateAssociations(), et LevelModel\validate().

◆ toObject()

static toObject | ( | array | $array,
 |  |  | $class = 'stdClass',
 |  |  | $recursive = true
 | ) |  |
static

Utility function to map an array to a stdClass object.

Paramètres
array | $array | The array to map.
string | $class | Name of the class to create
boolean | $recursive | Convert also any array inside the main array
Renvoie
object
Depuis
1.0

Références $class.

Référencé par FormModel\getItem(), LanguageModel\getItem(), MenuModel\getItem(), TemplateModel\getItem(), PluginModel\getItem(), StyleModel\getItem(), Adapter\getItem(), ItemModel\getItem(), ModuleModel\getItem(), AdminModel\getItem(), Adapter\getItems(), TemplateModel\getMaster(), DatabaseModel\handleOldDatabase(), DatabaseModel\initialise(), GroupModel\preprocessForm(), ConfigurationModel\setup(), et SetupModel\validateDbConnection().

◆ toString()

static toString | ( | array | $array,
 |  |  | $innerGlue = '=',
 |  |  | $outerGlue = ' ',
 |  |  | $keepOuterKey = false
 | ) |  |
static

Utility function to map an array to a string.

Paramètres
array | $array | The array to map.
string | $innerGlue | The glue (optional, defaults to '=') between the key and the value.
string | $outerGlue | The glue (optional, defaults to ' ') between array elements.
boolean | $keepOuterKey | True if final key should be kept.
Renvoie
string
Depuis
1.0
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $item, $key, et $output.

Référencé par Select\genericlist(), SyndicateHelper\getLink(), Select\groupedlist(), HTMLHelper\iframe(), HTMLHelper\link(), Select\radiolist(), ToolbarButton\renderButton(), et Form\token().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArrayHelper.php


Joomla CMS: Référence de la classe IpHelper

  • Joomla
  • Utilities
  • IpHelper
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées | Attributs privés statiques
Référence de la classe IpHelper

Fonctions membres publiques statiques

static | getIp ()
static | setIp ($ip)
static | isIPv6 ($ip)
static | IPinList ($ip, $ipTable='')
static | workaroundIPIssues ()
static | setAllowIpOverrides ($newState)

Fonctions membres protégées statiques

static | detectAndCleanIP ()
static | detectIP ()
static | inetToBits ($inet)
static | checkIPv6CIDR ($ip, $cidrnet)

Fonctions membres privées

__construct ()

Attributs privés statiques

static | $ip = null
static | $allowIpOverrides = false

Description détaillée

IpHelper is a utility class for processing IP addresses

Depuis
1.6.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor to prevent instantiation of this class

Depuis
1.6.0

Documentation des fonctions membres

◆ checkIPv6CIDR()

static checkIPv6CIDR | ( | $ip,
 |  | $cidrnet
 | ) |
staticprotected

Checks if an IPv6 address $ip is part of the IPv6 CIDR block $cidrnet

Paramètres
string | $ip | The IPv6 address to check, e.g. 21DA:00D3:0000:2F3B:02AC:00FF:FE28:9C5A
string | $cidrnet | The IPv6 CIDR block, e.g. 21DA:00D3:0000:2F3B::/64
Renvoie
boolean
Depuis
1.6.0

Références IpHelper\$ip.

◆ detectAndCleanIP()

static detectAndCleanIP ( )
staticprotected

Gets the visitor's IP address.

Automatically handles reverse proxies reporting the IPs of intermediate devices, like load balancers. Examples:

  • https://www.akeebabackup.com/support/admin-tools/13743-double-ip-adresses-in-security-exception-log-warnings.html
  • https://stackoverflow.com/questions/2422395/why-is-request-envremote-addr-returning-two-ips

The solution used is assuming that the last IP address is the external one.

Renvoie
string
Depuis
1.6.0

Références IpHelper\$ip.

◆ detectIP()

static detectIP ( )
staticprotected

Gets the visitor's IP address

Renvoie
string
Depuis
1.6.0

◆ getIp()

static getIp ( )
static

Get the current visitor's IP address

Renvoie
string
Depuis
1.6.0

Références IpHelper\$ip, et null.

Référencé par ActionlogModel\addLog(), ArticleModel\storeVote(), et AddressValidator\validate().

◆ inetToBits()

static inetToBits ( $inet )
staticprotected

Converts inet_pton output to bits string

Paramètres
string $inet The in_addr representation of an IPv4 or IPv6 address
Renvoie
string
Depuis
1.6.0

◆ IPinList()

static IPinList | ( | $ip,
 |  | $ipTable = ''
 | ) |
static

Checks if an IP is contained in a list of IPs or IP expressions

Paramètres
string | $ip | The IPv4/IPv6 address to check
array | string | $ipTable | An IP expression (or a comma-separated or array list of IP expressions) to check against
Renvoie
boolean
Depuis
1.6.0

Références $base, $i, IpHelper\$ip, $val, et elseif.

◆ isIPv6()

static isIPv6 ( $ip )
static

Is it an IPv6 IP address?

Paramètres
string $ip An IPv4 or IPv6 address
Renvoie
boolean
Depuis
1.6.0

Références IpHelper\$ip.

◆ setAllowIpOverrides()

static setAllowIpOverrides ( $newState )
static

Should I allow the remote client's IP to be overridden by an X-Forwarded-For or Client-Ip HTTP header?

Paramètres
boolean $newState True to allow the override
Renvoie
void
Depuis
1.6.0

Références true.

◆ setIp()

static setIp ( $ip )
static

Set the IP address of the current visitor

Paramètres
string $ip The visitor's IP address
Renvoie
void
Depuis
1.6.0

Références IpHelper\$ip.

◆ workaroundIPIssues()

static workaroundIPIssues ( )
static

Works around the REMOTE_ADDR not containing the user's IP

Renvoie
void
Depuis
1.6.0

Références IpHelper\$ip, et elseif.

Documentation des champs

◆ $allowIpOverrides

$allowIpOverrides = false
staticprivate

◆ $ip

$ip = null
staticprivate

Référencé par IpHelper\checkIPv6CIDR(), IpHelper\detectAndCleanIP(), IpHelper\getIp(), IpHelper\IPinList(), IpHelper\isIPv6(), IpHelper\setIp(), et IpHelper\workaroundIPIssues().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IpHelper.php


Joomla CMS: Référence de la classe BigInteger

  • Jose
  • Component
  • Core
  • Util
  • BigInteger
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe BigInteger

Fonctions membres publiques

toBytes ()
add (self $y)
subtract (self $y)
multiply (self $x)
divide (self $x)
modPow (self $e, self $n)
mod (self $d)
modInverse (BigInteger $m)
compare (self $y)
equals (self $y)
gcd (self $y)
lowerThan (self $y)
isEven ()
get ()

Fonctions membres publiques statiques

static | createFromBinaryString (string $value)
static | createFromDecimal (int $value)
static | createFromBigInteger (BrickBigInteger $value)
static | random (self $y)

Fonctions membres privées

__construct (BrickBigInteger $value)

Attributs privés

$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( BrickBigInteger $value )
private

Références BigInteger\$value, et value.

Documentation des fonctions membres

◆ add()

add ( self $y )

Adds two BigIntegers.

Paramètres
BigInteger $y
Renvoie
BigInteger

Références BigInteger\$value, et value.

◆ compare()

compare ( self $y )

Compares two numbers.

Paramètres
BigInteger $y

Références value.

◆ createFromBigInteger()

static createFromBigInteger ( BrickBigInteger $value )
static
Renvoie
BigInteger

Références BigInteger\$value.

◆ createFromBinaryString()

static createFromBinaryString ( string $value )
static
Renvoie
BigInteger

Références $data, et BigInteger\$value.

Référencé par RSAKey\convertBase64StringToBigInteger(), PSSRSA\exponentiate(), PSSRSA\sign(), RSA\signWithPKCS15(), RSA\signWithPSS(), PSSRSA\verify(), RSA\verifyWithPKCS15(), et RSA\verifyWithPSS().

◆ createFromDecimal()

static createFromDecimal ( int $value )
static
Renvoie
BigInteger

Références BigInteger\$value.

Référencé par PSSRSA\exponentiate(), et RSAKey\exponentiate().

◆ divide()

divide ( self $x )

Divides two BigIntegers.

Paramètres
BigInteger $x
Renvoie
BigInteger

Références BigInteger\$value, et value.

◆ equals()

equals ( self $y )
Paramètres
BigInteger $y

Références value.

◆ gcd()

gcd ( self $y )
Paramètres
BigInteger $y
Renvoie
BigInteger

Références value.

◆ get()

get ( )

Références BigInteger\$value.

◆ isEven()

isEven ( )

Références value.

◆ lowerThan()

lowerThan ( self $y )
Paramètres
BigInteger $y

Références value.

◆ mod()

mod ( self $d )

Performs modular exponentiation.

Paramètres
BigInteger $d
Renvoie
BigInteger

Références BigInteger\$value, et value.

◆ modInverse()

modInverse ( BigInteger $m )

Références value.

◆ modPow()

modPow | ( | self | $e,
 |  | self | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
BigInteger | $e
BigInteger | $n
Renvoie
BigInteger

Références $n, BigInteger\$value, et value.

◆ multiply()

multiply ( self $x )

Multiplies two BigIntegers.

Paramètres
BigInteger $x
Renvoie
BigInteger

Références BigInteger\$value, et value.

◆ random()

static random ( self $y )
static
Paramètres
BigInteger $y
Renvoie
BigInteger

◆ subtract()

subtract ( self $y )

Subtracts two BigIntegers.

Paramètres
BigInteger $y
Renvoie
BigInteger

Références BigInteger\$value, et value.

◆ toBytes()

toBytes ( )

Converts a BigInteger to a binary string.

Références $temp, et value.

Référencé par PSSRSA\convertIntegerToOctetString(), et RSA\convertIntegerToOctetString().

Documentation des champs

◆ $value

$value
private

Référencé par BigInteger\__construct(), BigInteger\add(), BigInteger\createFromBigInteger(), BigInteger\createFromBinaryString(), BigInteger\createFromDecimal(), BigInteger\divide(), BigInteger\get(), BigInteger\mod(), BigInteger\modPow(), BigInteger\multiply(), et BigInteger\subtract().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-core/Util/BigInteger.php


Joomla CMS: Référence de la classe ECKey

  • Jose
  • Component
  • Core
  • Util
  • ECKey
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe ECKey

Fonctions membres publiques statiques

static | convertToPEM (JWK $jwk)
static | convertPublicKeyToPEM (JWK $jwk)
static | convertPrivateKeyToPEM (JWK $jwk)
static | createECKey (string $curve, array $values=[])

Fonctions membres privées statiques

static | getNistCurveSize (string $curve)
static | createECKeyUsingOpenSSL (string $curve)
static | getOpensslCurveName (string $curve)
static | p256PublicKey ()
static | p256KPublicKey ()
static | p384PublicKey ()
static | p521PublicKey ()
static | p256PrivateKey (JWK $jwk)
static | p256KPrivateKey (JWK $jwk)
static | p384PrivateKey (JWK $jwk)
static | p521PrivateKey (JWK $jwk)
static | getKey (JWK $jwk)

Documentation des fonctions membres

◆ convertPrivateKeyToPEM()

static convertPrivateKeyToPEM ( JWK $jwk )
static
Exceptions
InvalidArgumentException if the curve is not supported

Références JWK\get().

Référencé par ECDSA\sign().

◆ convertPublicKeyToPEM()

static convertPublicKeyToPEM ( JWK $jwk )
static
Exceptions
InvalidArgumentException if the curve is not supported

Références JWK\get().

Référencé par ECDSA\verify().

◆ convertToPEM()

static convertToPEM ( JWK $jwk )
static

Références JWK\has().

◆ createECKey()

static createECKey | ( | string | $curve,
 |  | array | $values = []
 | ) |  |
static

Creates a EC key with the given curve and additional values.

Paramètres
string | $curve | The curve
array | $values | values to configure the key

◆ createECKeyUsingOpenSSL()

static createECKeyUsingOpenSSL ( string $curve )
staticprivate
Exceptions
RuntimeException | if the extension OpenSSL is not available
RuntimeException | if the key cannot be created

Références $key, $result, et Base64Url\encode().

◆ getKey()

static getKey ( JWK $jwk )
staticprivate

Références Base64Url\decode(), et JWK\get().

◆ getNistCurveSize()

static getNistCurveSize ( string $curve )
staticprivate
Exceptions
InvalidArgumentException if the curve is not supported

◆ getOpensslCurveName()

static getOpensslCurveName ( string $curve )
staticprivate
Exceptions
InvalidArgumentException if the curve is not supported

◆ p256KPrivateKey()

static p256KPrivateKey ( JWK $jwk )
staticprivate

Références Base64Url\decode(), et JWK\get().

◆ p256KPublicKey()

static p256KPublicKey ( )
staticprivate

◆ p256PrivateKey()

static p256PrivateKey ( JWK $jwk )
staticprivate

Références Base64Url\decode(), et JWK\get().

◆ p256PublicKey()

static p256PublicKey ( )
staticprivate

◆ p384PrivateKey()

static p384PrivateKey ( JWK $jwk )
staticprivate

Références Base64Url\decode(), et JWK\get().

◆ p384PublicKey()

static p384PublicKey ( )
staticprivate

◆ p521PrivateKey()

static p521PrivateKey ( JWK $jwk )
staticprivate

Références Base64Url\decode(), et JWK\get().

◆ p521PublicKey()

static p521PublicKey ( )
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • ECKey.php


Joomla CMS: Référence de la classe ECSignature

  • Jose
  • Component
  • Core
  • Util
  • ECSignature
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe ECSignature

Fonctions membres publiques statiques

static | toAsn1 (string $signature, int $length)
static | fromAsn1 (string $signature, int $length)

Fonctions membres privées statiques

static | octetLength (string $data)
static | preparePositiveInteger (string $data)
static | readAsn1Content (string $message, int &$position, int $length)
static | readAsn1Integer (string $message, int &$position)
static | retrievePositiveInteger (string $data)

Attributs privés

const | ASN1_SEQUENCE = '30'
const | ASN1_INTEGER = '02'
const | ASN1_MAX_SINGLE_BYTE = 128
const | ASN1_LENGTH_2BYTES = '81'
const | ASN1_BIG_INTEGER_LIMIT = '7f'
const | ASN1_NEGATIVE_INTEGER = '00'
const | BYTE_SIZE = 2

Documentation des fonctions membres

◆ fromAsn1()

static fromAsn1 | ( | string | $signature,
 |  | int | $length
 | ) |  |
static
Exceptions
InvalidArgumentException if the signature is not an ASN.1 sequence

Références $message, et $position.

Référencé par ECDSA\sign().

◆ octetLength()

static octetLength ( string $data )
staticprivate

Références $data.

◆ preparePositiveInteger()

static preparePositiveInteger ( string $data )
staticprivate

Références $data, et null.

◆ readAsn1Content()

static readAsn1Content | ( | string | $message,
 |  | int & | $position,
 |  | int | $length
 | ) |  |
staticprivate

Références $content, $message, et $position.

◆ readAsn1Integer()

static readAsn1Integer | ( | string | $message,
 |  | int & | $position
 | ) |  |
staticprivate
Exceptions
InvalidArgumentException if the data is not an integer

Références $message, et $position.

◆ retrievePositiveInteger()

static retrievePositiveInteger ( string $data )
staticprivate

Références $data, et null.

◆ toAsn1()

static toAsn1 | ( | string | $signature,
 |  | int | $length
 | ) |  |
static
Exceptions
InvalidArgumentException if the length of the signature is invalid

Références null.

Référencé par ECDSA\verify().

Documentation des champs

◆ ASN1_BIG_INTEGER_LIMIT

const ASN1_BIG_INTEGER_LIMIT = '7f'
private

◆ ASN1_INTEGER

const ASN1_INTEGER = '02'
private

◆ ASN1_LENGTH_2BYTES

const ASN1_LENGTH_2BYTES = '81'
private

◆ ASN1_MAX_SINGLE_BYTE

const ASN1_MAX_SINGLE_BYTE = 128
private

◆ ASN1_NEGATIVE_INTEGER

const ASN1_NEGATIVE_INTEGER = '00'
private

◆ ASN1_SEQUENCE

const ASN1_SEQUENCE = '30'
private

◆ BYTE_SIZE

const BYTE_SIZE = 2
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-core/Util/ECSignature.php


Joomla CMS: Référence de la classe Hash

  • Jose
  • Component
  • Core
  • Util
  • Hash
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Hash

Fonctions membres publiques

getLength ()
hash (string $text)
name ()
t ()

Fonctions membres publiques statiques

static | sha1 ()
static | sha256 ()
static | sha384 ()
static | sha512 ()

Fonctions membres privées

__construct (string $hash, int $length, string $t)

Attributs privés

$hash
$t
$length

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $hash,
 |  | int | $length,
 |  | string | $t
 | ) |  |
private

Références Hash\$hash, Hash\$length, Hash\$t, Hash\hash(), et Hash\t().

Documentation des fonctions membres

◆ getLength()

getLength ( )

Références Hash\$length.

Référencé par PSSRSA\getMGF1(), et RSA\getMGF1().

◆ hash()

hash ( string $text )

Compute the HMAC.

Référencé par Hash\__construct(), PSSRSA\getMGF1(), et RSA\getMGF1().

◆ name()

name ( )

Références Hash\$hash.

◆ sha1()

static sha1 ( )
static
Renvoie
Hash

◆ sha256()

static sha256 ( )
static
Renvoie
Hash

Référencé par PS256\getHashAlgorithm().

◆ sha384()

static sha384 ( )
static
Renvoie
Hash

Référencé par PS384\getHashAlgorithm().

◆ sha512()

static sha512 ( )
static
Renvoie
Hash

Référencé par PS512\getHashAlgorithm().

◆ t()

t ( )

Références Hash\$t.

Référencé par Hash\__construct().

Documentation des champs

◆ $hash

$hash
private

Référencé par Hash\__construct(), Hash\name(), RSA\signWithPKCS15(), RSA\signWithPSS(), RSA\verifyWithPKCS15(), et RSA\verifyWithPSS().

◆ $length

$length
private

Référencé par Hash\__construct(), et Hash\getLength().

◆ $t

$t
private

Référencé par Hash\__construct(), et Hash\t().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-core/Util/Hash.php


Joomla CMS: Référence de la classe JsonConverter

  • Jose
  • Component
  • Core
  • Util
  • JsonConverter
Fonctions membres publiques statiques
Référence de la classe JsonConverter

Fonctions membres publiques statiques

static | encode ($payload)
static | decode (string $payload)

Documentation des fonctions membres

◆ decode()

static decode ( string $payload )
static
Exceptions
RuntimeException if the payload cannot be decoded
Renvoie
mixed

Référencé par JSONGeneralSerializer\processHeaders(), CompactSerializer\unserialize(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), et AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ encode()

static encode ( $payload )
static
Paramètres
mixed $payload
Exceptions
RuntimeException if the payload cannot be encoded

Références $data.

Référencé par JSONFlattenedSerializer\serialize(), et JSONGeneralSerializer\serialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonConverter.php


Joomla CMS: Référence de la classe KeyChecker

  • Jose
  • Component
  • Core
  • Util
  • KeyChecker
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe KeyChecker

Fonctions membres publiques statiques

static | checkKeyUsage (JWK $key, string $usage)
static | checkKeyAlgorithm (JWK $key, string $algorithm)

Fonctions membres privées statiques

static | checkOperation (JWK $key, string $usage)
static | checkUsage (JWK $key, string $usage)

Documentation des fonctions membres

◆ checkKeyAlgorithm()

static checkKeyAlgorithm | ( | JWK | $key,
 |  | string | $algorithm
 | ) |  |
static
Exceptions
InvalidArgumentException if the key is not suitable for the selected algorithm

Références $key.

Référencé par JWSBuilder\addSignature(), et JWSVerifier\verifySignature().

◆ checkKeyUsage()

static checkKeyUsage | ( | JWK | $key,
 |  | string | $usage
 | ) |  |
static

Références $key.

Référencé par JWSBuilder\addSignature(), et JWSVerifier\verifySignature().

◆ checkOperation()

static checkOperation | ( | JWK | $key,
 |  | string | $usage
 | ) |  |
staticprivate
Exceptions
InvalidArgumentException if the key is not suitable for the selected operation

Références $key.

◆ checkUsage()

static checkUsage | ( | JWK | $key,
 |  | string | $usage
 | ) |  |
staticprivate
Exceptions
InvalidArgumentException if the key is not suitable for the selected operation

Références $key.

La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyChecker.php


Joomla CMS: Référence de la classe RSAKey

  • Jose
  • Component
  • Core
  • Util
  • RSAKey
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe RSAKey

Fonctions membres publiques

getModulus ()
getModulusLength ()
getExponent ()
getPublicExponent ()
getPrivateExponent ()
getPrimes ()
getExponents ()
getCoefficient ()
isPublic ()
toArray ()
toPEM ()

Fonctions membres publiques statiques

static | createFromJWK (JWK $jwk)
static | toPublic (self $private)
static | exponentiate (self $key, BigInteger $c)

Fonctions membres privées

__construct (JWK $data)
populateBigIntegers ()
convertBase64StringToBigInteger (string $value)
initPublicKey ()
initPrivateKey ()
fromBase64ToInteger ($value)

Attributs privés

$sequence
$private
$values
$modulus
$modulus_length
$public_exponent
$private_exponent
$primes = []
$exponents = []
$coefficient

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( JWK $data )
private

Références $data, et RSAKey\populateBigIntegers().

Documentation des fonctions membres

◆ convertBase64StringToBigInteger()

convertBase64StringToBigInteger ( string $value )
private

Références $value, BigInteger\createFromBinaryString(), et Base64Url\decode().

Référencé par RSAKey\populateBigIntegers().

◆ createFromJWK()

static createFromJWK ( JWK $jwk )
static
Renvoie
RSAKey

Référencé par RSAPSS\sign(), RSAPKCS1\sign(), RSA\sign(), RSAPSS\verify(), RSAPKCS1\verify(), et RSA\verify().

◆ exponentiate()

static exponentiate | ( | self | $key,
 |  | BigInteger | $c
 | ) |  |
static

Exponentiate with or without Chinese Remainder Theorem. Operation with primes 'p' and 'q' is appox. 2x faster.

Paramètres
RSAKey $key
Exceptions
RuntimeException if the exponentiation cannot be achieved

Références $c, $key, BigInteger\createFromDecimal(), et null.

Référencé par RSA\signWithPKCS15(), RSA\signWithPSS(), RSA\verifyWithPKCS15(), et RSA\verifyWithPSS().

◆ fromBase64ToInteger()

fromBase64ToInteger ( $value )
private
Paramètres
string $value
Renvoie
string

Références $value, et Base64Url\decode().

Référencé par RSAKey\initPrivateKey(), et RSAKey\initPublicKey().

◆ getCoefficient()

getCoefficient ( )

Références RSAKey\$coefficient.

◆ getExponent()

getExponent ( )

Références RSAKey\getPrivateExponent(), RSAKey\getPublicExponent(), et null.

◆ getExponents()

getExponents ( )
Renvoie
BigInteger[]

Références RSAKey\$exponents.

◆ getModulus()

getModulus ( )

Références RSAKey\$modulus.

Référencé par RSAKey\populateBigIntegers().

◆ getModulusLength()

getModulusLength ( )

Références RSAKey\$modulus_length.

◆ getPrimes()

getPrimes ( )
Renvoie
BigInteger[]

Références RSAKey\$primes.

◆ getPrivateExponent()

getPrivateExponent ( )

Références RSAKey\$private_exponent.

Référencé par RSAKey\getExponent().

◆ getPublicExponent()

getPublicExponent ( )

Références RSAKey\$public_exponent.

Référencé par RSAKey\getExponent().

◆ initPrivateKey()

initPrivateKey ( )
private

Références $n, et RSAKey\fromBase64ToInteger().

Référencé par RSAKey\toPEM().

◆ initPublicKey()

initPublicKey ( )
private

Références $n, et RSAKey\fromBase64ToInteger().

Référencé par RSAKey\toPEM().

◆ isPublic()

isPublic ( )

Référencé par RSAKey\populateBigIntegers().

◆ populateBigIntegers()

populateBigIntegers ( )
private

Références RSAKey\convertBase64StringToBigInteger(), RSAKey\getModulus(), et RSAKey\isPublic().

Référencé par RSAKey\__construct().

◆ toArray()

toArray ( )

Références RSAKey\$values.

◆ toPEM()

toPEM ( )

Références $result, RSAKey\initPrivateKey(), RSAKey\initPublicKey(), et null.

◆ toPublic()

static toPublic ( self $private )
static
Paramètres
RSAKey $private
Renvoie
RSAKey

Références $data, $key, et RSAKey\$private.

Documentation des champs

◆ $coefficient

$coefficient
private

Référencé par RSAKey\getCoefficient().

◆ $exponents

$exponents = []
private

Référencé par RSAKey\getExponents().

◆ $modulus

$modulus
private

Référencé par RSAKey\getModulus().

◆ $modulus_length

$modulus_length
private

Référencé par RSAKey\getModulusLength().

◆ $primes

$primes = []
private

Référencé par RSAKey\getPrimes().

◆ $private

$private
private

Référencé par RSAKey\toPublic().

◆ $private_exponent

$private_exponent
private

Référencé par RSAKey\getPrivateExponent().

◆ $public_exponent

$public_exponent
private

Référencé par RSAKey\getPublicExponent().

◆ $sequence

$sequence
private

◆ $values

$values
private

Référencé par RSAKey\toArray().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSAKey.php


Joomla CMS: Référence de l'interface Algorithm

  • Jose
  • Component
  • Core
  • Algorithm
Fonctions membres publiques
Référence de l'interface Algorithm
+ Graphe d'héritage de Algorithm:
MacAlgorithm SignatureAlgorithm HMAC ECDSA EdDSA None RSA RSAPKCS1 RSAPSS HS1 HS256 HS256_64 HS384 HS512 ES256 ES256K ES384 ES512 RS1 RS256 RS384 RS512 PS256 PS384 PS512

Fonctions membres publiques

name ()
allowedKeyTypes ()

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémenté dans EdDSA, ECDSA, RSA, HMAC, RSAPKCS1, RSAPSS, et None.

Référencé par JWKSet\canKeyBeUsedWithAlgorithm().

◆ name()

name ( )

Returns the name of the algorithm.

Implémenté dans EdDSA, None, HS256_64, HS256, HS384, HS512, ES256, ES384, ES512, ES256K, HS1, RS1, PS256, PS384, PS512, RS256, RS384, et RS512.

Référencé par AlgorithmManager\add(), et JWKSet\canKeyBeUsedWithAlgorithm().

La documentation de cette interface a été générée à partir du fichier suivant :
  • web-token/jwt-core/Algorithm.php


Joomla CMS: Référence de la classe AlgorithmManager

  • Jose
  • Component
  • Core
  • AlgorithmManager
Fonctions membres publiques | Attributs privés
Référence de la classe AlgorithmManager

Fonctions membres publiques

__construct (array $algorithms)
has (string $algorithm)
list ()
get (string $algorithm)
add (Algorithm $algorithm)

Attributs privés

$algorithms = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $algorithms )
Paramètres
Algorithm[] $algorithms

Références AlgorithmManager\$algorithms, et AlgorithmManager\add().

Documentation des fonctions membres

◆ add()

add ( Algorithm $algorithm )

Adds an algorithm to the manager.

Références $name, et Algorithm\name().

Référencé par AlgorithmManager\__construct().

◆ get()

get ( string $algorithm )

Returns the algorithm if supported, otherwise throw an exception.

Paramètres
string $algorithm The algorithm
Exceptions
InvalidArgumentException if the algorithm is not supported

Références AlgorithmManager\has().

◆ has()

has ( string $algorithm )

Returns true if the algorithm is supported.

Paramètres
string $algorithm The algorithm

Référencé par AlgorithmManager\get().

◆ list()

list ( )

Returns the list of names of supported algorithms.

Renvoie
string[]

Documentation des champs

◆ $algorithms

$algorithms = []
private

Référencé par AlgorithmManager\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AlgorithmManager.php


Joomla CMS: Référence de la classe AlgorithmManagerFactory

  • Jose
  • Component
  • Core
  • AlgorithmManagerFactory
Fonctions membres publiques | Attributs privés
Référence de la classe AlgorithmManagerFactory

Fonctions membres publiques

add (string $alias, Algorithm $algorithm)
aliases ()
all ()
create (array $aliases)

Attributs privés

$algorithms = []

Documentation des fonctions membres

◆ add()

add | ( | string | $alias,
 |  | Algorithm | $algorithm
 | ) |  |

Adds an algorithm.

Each algorithm is identified by an alias hence it is allowed to have the same algorithm twice (or more). This can be helpful when an algorithm have several configuration options.

◆ aliases()

aliases ( )

Returns the list of aliases.

Renvoie
string[]

◆ all()

all ( )

Returns all algorithms supported by this factory. This is an associative array. Keys are the aliases of the algorithms.

Renvoie
Algorithm[]

Références AlgorithmManagerFactory\$algorithms.

◆ create()

create ( array $aliases )

Create an algorithm manager using the given aliases.

Paramètres
string[] $aliases
Exceptions
InvalidArgumentException if the alias is invalid or is not supported

Références AlgorithmManagerFactory\$algorithms.

Documentation des champs

◆ $algorithms

$algorithms = []
private

Référencé par AlgorithmManagerFactory\all(), et AlgorithmManagerFactory\create().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AlgorithmManagerFactory.php


Joomla CMS: Référence de la classe JWK

  • Jose
  • Component
  • Core
  • JWK
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe JWK
+ Graphe d'héritage de JWK:

Fonctions membres publiques

__construct (array $values)
jsonSerialize ()
get (string $key)
has (string $key)
all ()
thumbprint (string $hash_algorithm)
toPublic ()

Fonctions membres publiques statiques

static createFromJson (string $json)

Attributs privés

$values = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $values )

Creates a JWK object using the given values. The member "kty" is mandatory. Other members are NOT checked.

Exceptions
InvalidArgumentException if the key parameter "kty" is missing

Références JWK\$values.

Documentation des fonctions membres

◆ all()

all ( )

Get all values stored in the JWK object.

Renvoie
array Values of the JWK object

Références JWK\$values.

◆ createFromJson()

static createFromJson ( string $json )
static

Creates a JWK object using the given Json string.

Exceptions
InvalidArgumentException if the data is not valid
Renvoie
JWK

Références $data.

◆ get()

get ( string $key )

Get the value with a specific key.

Paramètres
string $key The key
Exceptions
InvalidArgumentException if the key does not exist
Renvoie
null|mixed

Références $key, et JWK\has().

Référencé par ECKey\convertPrivateKeyToPEM(), ECKey\convertPublicKeyToPEM(), ECKey\getKey(), ECKey\p256KPrivateKey(), ECKey\p256PrivateKey(), ECKey\p384PrivateKey(), ECKey\p521PrivateKey(), et JWKSet\with().

◆ has()

has ( string $key )

Returns true if the JWK has the value identified by.

Paramètres
string $key The key

Références $key.

Référencé par ECKey\convertToPEM(), JWK\get(), HMAC\getKey(), et JWKSet\with().

◆ jsonSerialize()

jsonSerialize ( )

Returns the values to be serialized.

Références JWK\$values.

◆ thumbprint()

thumbprint ( string $hash_algorithm )

Returns the thumbprint of the key.

Voir également
https://tools.ietf.org/html/rfc7638
Exceptions
InvalidArgumentException if the hashing function is not supported

Références $input, JWK\$values, et Base64Url\encode().

◆ toPublic()

toPublic ( )

Returns the associated public key. This method has no effect for:

  • public keys
  • shared keys
  • unknown keys.

Known keys are "oct", "RSA", "EC" and "OKP".

Renvoie
JWK

Références JWK\$values.

Documentation des champs

◆ $values

$values = []
private

Référencé par JWK\__construct(), JWK\all(), JWK\jsonSerialize(), JWK\thumbprint(), et JWK\toPublic().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWK.php


Joomla CMS: Référence de la classe JWKSet

  • Jose
  • Component
  • Core
  • JWKSet
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe JWKSet
+ Graphe d'héritage de JWKSet:

Fonctions membres publiques

__construct (array $keys)
all ()
with (JWK $jwk)
without ($key)
has ($index)
get ($index)
jsonSerialize ()
count ($mode=COUNT_NORMAL)
selectKey (string $type, ?Algorithm $algorithm=null, array $restrictions=[])
getIterator ()

Fonctions membres publiques statiques

static | createFromKeyData (array $data)
static | createFromJson (string $json)
static | sortKeys (array $a, array $b)

Fonctions membres privées

canKeyBeUsedFor (string $type, JWK $key)
canKeyBeUsedWithAlgorithm (?Algorithm $algorithm, JWK $key)
doesKeySatisfyRestrictions (array $restrictions, JWK $key)

Fonctions membres privées statiques

static convertKeyOpsToKeyUse (array $key_ops)

Attributs privés

$keys = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $keys )
Paramètres
JWK[] $keys
Exceptions
InvalidArgumentException if the list is invalid

Références $key, et JWKSet\$keys.

Documentation des fonctions membres

◆ all()

all ( )

Returns an array of keys stored in the key set.

Renvoie
JWK[]

Références JWKSet\$keys.

Référencé par JWSVerifier\verifySignature().

◆ canKeyBeUsedFor()

canKeyBeUsedFor | ( | string | $type,
 |  | JWK | $key
 | ) |  |
private
Exceptions
InvalidArgumentException if the key does not fulfill with the "key_ops" constraint
Renvoie
bool|int

Références $key, et $type.

Référencé par JWKSet\selectKey().

◆ canKeyBeUsedWithAlgorithm()

canKeyBeUsedWithAlgorithm | ( | ?Algorithm | $algorithm,
 |  | JWK | $key
 | ) |  |
private
Renvoie
bool|int

Références $key, Algorithm\allowedKeyTypes(), Algorithm\name(), et null.

Référencé par JWKSet\selectKey().

◆ convertKeyOpsToKeyUse()

static convertKeyOpsToKeyUse ( array $key_ops )
staticprivate
Exceptions
InvalidArgumentException if the key operation is not supported

◆ count()

count ( $mode = COUNT_NORMAL )

Returns the number of keys in the key set.

Paramètres
int $mode

Références $mode.

Référencé par JWKSet\selectKey(), et JWSVerifier\verifyWithKeySet().

◆ createFromJson()

static createFromJson ( string $json )
static

Creates a JWKSet object using the given Json string.

Exceptions
InvalidArgumentException if the data is not valid
Renvoie
JWKSet

Références $data.

◆ createFromKeyData()

static createFromKeyData ( array $data )
static

Creates a JWKSet object using the given values.

Exceptions
InvalidArgumentException if the keyset is not valid
Renvoie
JWKSet

Références $data, et $key.

◆ doesKeySatisfyRestrictions()

doesKeySatisfyRestrictions | ( | array | $restrictions,
 |  | JWK | $key
 | ) |  |
private

Références $key.

Référencé par JWKSet\selectKey().

◆ get()

get ( $index )

Returns the key with the given index. Throws an exception if the index is not present in the key store.

Paramètres
int | string $index
Exceptions
InvalidArgumentException if the index is not defined

Références JWKSet\has().

◆ getIterator()

getIterator ( )

Internal method only. Should not be used.

◆ has()

has ( $index )

Returns true if the key set contains a key with the given index.

Paramètres
int | string $index

Référencé par JWKSet\get(), et JWKSet\without().

◆ jsonSerialize()

jsonSerialize ( )

Returns the values to be serialized.

◆ selectKey()

selectKey | ( | string | $type,
 |  | ?Algorithm | $algorithm = null,
 |  | array | $restrictions = []
 | ) |  |

Try to find a key that fits on the selected requirements. Returns null if not found.

Paramètres
string | $type | Must be 'sig' (signature) or 'enc' (encryption)
null | Algorithm | $algorithm | Specifies the algorithm to be used
array | $restrictions | More restrictions such as 'kid' or 'kty'
Exceptions
InvalidArgumentException if the key type is not valid (must be "sig" or "enc")

Références $key, $result, $this, $type, JWKSet\canKeyBeUsedFor(), JWKSet\canKeyBeUsedWithAlgorithm(), JWKSet\count(), JWKSet\doesKeySatisfyRestrictions(), et null.

◆ sortKeys()

static sortKeys | ( | array | $a,
 |  | array | $b
 | ) |  |
static

Internal method only. Should not be used.

Références $b.

◆ with()

with ( JWK $jwk )

Add key to store in the key set. This method is immutable and will return a new object.

Renvoie
JWKSet

Références $this, JWK\get(), et JWK\has().

◆ without()

without ( $key )

Remove key from the key set. This method is immutable and will return a new object.

Paramètres
int | string $key Key to remove from the key set
Renvoie
JWKSet

Références $key, $this, et JWKSet\has().

Documentation des champs

◆ $keys

$keys = []
private

Référencé par JWKSet\__construct(), et JWKSet\all().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWKSet.php


Joomla CMS: Référence de l'interface JWT

  • Jose
  • Component
  • Core
  • JWT
Fonctions membres publiques
Référence de l'interface JWT
+ Graphe d'héritage de JWT:
JWS

Fonctions membres publiques

getPayload ()

Documentation des fonctions membres

◆ getPayload()

getPayload ( )

Returns the payload of the JWT. null is a valid payload (e.g. JWS with detached payload).

Implémenté dans JWS.

La documentation de cette interface a été générée à partir du fichier suivant :
  • JWT.php


Joomla CMS: Référence de la classe RSA

  • Jose
  • Component
  • Signature
  • Algorithm
  • Util
  • RSA
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques
Référence de la classe RSA

Fonctions membres publiques statiques

static | sign (RSAKey $key, string $message, string $hash, int $mode)
static | signWithPSS (RSAKey $key, string $message, string $hash)
static | signWithPKCS15 (RSAKey $key, string $message, string $hash)
static | verify (RSAKey $key, string $message, string $signature, string $hash, int $mode)
static | verifyWithPSS (RSAKey $key, string $message, string $signature, string $hash)
static | verifyWithPKCS15 (RSAKey $key, string $message, string $signature, string $hash)

Champs de données

const | SIGNATURE_PSS = 1
const | SIGNATURE_PKCS1 = 2

Fonctions membres privées statiques

static | convertIntegerToOctetString (BigInteger $x, int $xLen)
static | getMGF1 (string $mgfSeed, int $maskLen, Hash $mgfHash)
static | encodeEMSAPSS (string $message, int $modulusLength, Hash $hash)
static | verifyEMSAPSS (string $m, string $em, int $emBits, Hash $hash)
static | encodeEMSA15 (string $m, int $emBits, Hash $hash)

Documentation des fonctions membres

◆ convertIntegerToOctetString()

static convertIntegerToOctetString | ( | BigInteger | $x,
 |  | int | $xLen
 | ) |  |
staticprivate
Exceptions
RuntimeException if the value cannot be converted

Références BigInteger\toBytes().

◆ encodeEMSA15()

static encodeEMSA15 | ( | string | $m,
 |  | int | $emBits,
 |  | Hash | $hash
 | ) |  |
staticprivate
Exceptions
RuntimeException if the value cannot be encoded

Références $hash.

◆ encodeEMSAPSS()

static encodeEMSAPSS | ( | string | $message,
 |  | int | $modulusLength,
 |  | Hash | $hash
 | ) |  |
staticprivate

EMSA-PSS-ENCODE.

Exceptions
RuntimeException if the message length is invalid

Références $db, $hash, et $message.

◆ getMGF1()

static getMGF1 | ( | string | $mgfSeed,
 |  | int | $maskLen,
 |  | Hash | $mgfHash
 | ) |  |
staticprivate

MGF1.

Références $c, $count, $i, Hash\getLength(), et Hash\hash().

◆ sign()

static sign | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $hash,
 |  | int | $mode
 | ) |  |
static
Exceptions
RuntimeException | if the data cannot be signed
InvalidArgumentException | if the signature mode is not supported

Références $hash, $key, $message, $mode, et $result.

◆ signWithPKCS15()

static signWithPKCS15 | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $hash
 | ) |  |
static

Create a signature.

Obsolète:
Please use openssl_sign

Références Hash\$hash, $key, $message, BigInteger\createFromBinaryString(), et RSAKey\exponentiate().

◆ signWithPSS()

static signWithPSS | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $hash
 | ) |  |
static

Create a signature.

Références Hash\$hash, $key, $message, BigInteger\createFromBinaryString(), et RSAKey\exponentiate().

◆ verify()

static verify | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $signature,
 |  | string | $hash,
 |  | int | $mode
 | ) |  |
static
Exceptions
InvalidArgumentException if the signature mode is not supported

Références $hash, $key, $message, et $mode.

◆ verifyEMSAPSS()

static verifyEMSAPSS | ( | string | $m,
 |  | string | $em,
 |  | int | $emBits,
 |  | Hash | $hash
 | ) |  |
staticprivate

EMSA-PSS-VERIFY.

Exceptions
InvalidArgumentException if the signature cannot be verified

Références $db, $hash, $temp, et null.

◆ verifyWithPKCS15()

static verifyWithPKCS15 | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $signature,
 |  | string | $hash
 | ) |  |
static

Verifies a signature.

Obsolète:
Please use openssl_sign
Exceptions
RuntimeException if the signature cannot be verified

Références Hash\$hash, $key, $message, BigInteger\createFromBinaryString(), et RSAKey\exponentiate().

◆ verifyWithPSS()

static verifyWithPSS | ( | RSAKey | $key,
 |  | string | $message,
 |  | string | $signature,
 |  | string | $hash
 | ) |  |
static

Verifies a signature.

Exceptions
RuntimeException if the signature cannot be verified

Références Hash\$hash, $key, $message, BigInteger\createFromBinaryString(), et RSAKey\exponentiate().

Documentation des champs

◆ SIGNATURE_PKCS1

const SIGNATURE_PKCS1 = 2

Use the PKCS#1.

◆ SIGNATURE_PSS

const SIGNATURE_PSS = 1

Probabilistic Signature Scheme.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/Util/RSA.php


Joomla CMS: Référence de la classe ECDSA

  • Jose
  • Component
  • Signature
  • Algorithm
  • ECDSA
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe ECDSA
+ Graphe d'héritage de ECDSA:
SignatureAlgorithm Algorithm ES256 ES256K ES384 ES512

Fonctions membres publiques

__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)
- Fonctions membres publiques hérités de Algorithm
name ()

Fonctions membres protégées

getHashAlgorithm ()
getSignaturePartLength ()

Fonctions membres privées

checkKey (JWK $key)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par ECDSA\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private

Références $key, et ECDSA\allowedKeyTypes().

Référencé par ECDSA\sign(), et ECDSA\verify().

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par ECDSA\sign(), et ECDSA\verify().

◆ getSignaturePartLength()

getSignaturePartLength ( )
abstractprotected

Référencé par ECDSA\sign(), et ECDSA\verify().

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input

Implémente SignatureAlgorithm.

Références $input, $key, ECDSA\checkKey(), ECKey\convertPrivateKeyToPEM(), ECSignature\fromAsn1(), ECDSA\getHashAlgorithm(), et ECDSA\getSignaturePartLength().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémente SignatureAlgorithm.

Références $input, $key, ECDSA\checkKey(), ECKey\convertPublicKeyToPEM(), ECDSA\getHashAlgorithm(), ECDSA\getSignaturePartLength(), et ECSignature\toAsn1().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-ecdsa/ECDSA.php


Joomla CMS: Référence de la classe EdDSA

  • Jose
  • Component
  • Signature
  • Algorithm
  • EdDSA
Fonctions membres publiques | Fonctions membres privées
Référence de la classe EdDSA
+ Graphe d'héritage de EdDSA:
SignatureAlgorithm Algorithm

Fonctions membres publiques

__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)
name ()

Fonctions membres privées

checkKey (JWK $key)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

EdDSA constructor.

Exceptions
RuntimeException if the extension "sodium" is not available

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par EdDSA\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private
Exceptions
InvalidArgumentException | if the key type is not valid
InvalidArgumentException | if a mandatory key parameter is missing
InvalidArgumentException | if the curve is not suuported

Références $key, et EdDSA\allowedKeyTypes().

Référencé par EdDSA\sign(), et EdDSA\verify().

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |
Exceptions
InvalidArgumentException | if the key is not private
InvalidArgumentException | if the curve is not supported

Implémente SignatureAlgorithm.

Références $input, $key, EdDSA\checkKey(), et Base64Url\decode().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |
Exceptions
InvalidArgumentException if the curve is not supported

Implémente SignatureAlgorithm.

Références $input, $key, EdDSA\checkKey(), et Base64Url\decode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-eddsa/EdDSA.php


Joomla CMS: Référence de la classe ES256

  • Jose
  • Component
  • Signature
  • Algorithm
  • ES256
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ES256
+ Graphe d'héritage de ES256:
ECDSA SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de ECDSA
__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)

Fonctions membres protégées

getHashAlgorithm ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getHashAlgorithm ()
getSignaturePartLength ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-ecdsa/ES256.php


Joomla CMS: Référence de la classe ES256K

  • Jose
  • Component
  • Signature
  • Algorithm
  • ES256K
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ES256K
+ Graphe d'héritage de ES256K:
ECDSA SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de ECDSA
__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)

Fonctions membres protégées

getHashAlgorithm ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getHashAlgorithm ()
getSignaturePartLength ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-experimental/ES256K.php


Joomla CMS: Référence de la classe ES384

  • Jose
  • Component
  • Signature
  • Algorithm
  • ES384
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ES384
+ Graphe d'héritage de ES384:
ECDSA SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de ECDSA
__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)

Fonctions membres protégées

getHashAlgorithm ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getHashAlgorithm ()
getSignaturePartLength ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-ecdsa/ES384.php


Joomla CMS: Référence de la classe ES512

  • Jose
  • Component
  • Signature
  • Algorithm
  • ES512
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ES512
+ Graphe d'héritage de ES512:
ECDSA SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de ECDSA
__construct ()
allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)

Fonctions membres protégées

getHashAlgorithm ()
getSignaturePartLength ()
- Fonctions membres protégées hérités de ECDSA
getHashAlgorithm ()
getSignaturePartLength ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getSignaturePartLength()

getSignaturePartLength ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-ecdsa/ES512.php


Joomla CMS: Référence de la classe HMAC

  • Jose
  • Component
  • Signature
  • Algorithm
  • HMAC
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HMAC
+ Graphe d'héritage de HMAC:
MacAlgorithm Algorithm HS1 HS256 HS256_64 HS384 HS512

Fonctions membres publiques

allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)
- Fonctions membres publiques hérités de Algorithm
name ()

Fonctions membres protégées

getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par HMAC\getKey().

◆ getHashAlgorithm()

getHashAlgorithm ( )
abstractprotected

Référencé par HMAC\hash().

◆ getKey()

getKey ( JWK $key )
protected
Exceptions
InvalidArgumentException if the key is invalid

Références $key, HMAC\allowedKeyTypes(), Base64Url\decode(), et JWK\has().

Référencé par HMAC\hash().

◆ hash()

hash | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to hash the data
string | $input | The input

Implémente MacAlgorithm.

Références HMAC\getHashAlgorithm(), et HMAC\getKey().

Référencé par HMAC\verify().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to hash the data
string | $input | The input
string | $signature | The signature to verify

Implémente MacAlgorithm.

Références $input, et HMAC\hash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HMAC.php


Joomla CMS: Référence de la classe HS1

  • Jose
  • Component
  • Signature
  • Algorithm
  • HS1
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HS1
+ Graphe d'héritage de HS1:
HMAC MacAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de HMAC
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de HMAC
getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HS1.php


Joomla CMS: Référence de la classe HS256

  • Jose
  • Component
  • Signature
  • Algorithm
  • HS256
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HS256
+ Graphe d'héritage de HS256:
HMAC MacAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de HMAC
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)

Fonctions membres protégées

getHashAlgorithm ()
getKey (JWK $key)
- Fonctions membres protégées hérités de HMAC
getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getKey()

getKey ( JWK $key )
protected
Exceptions
InvalidArgumentException if the key is invalid

Références $key.

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-hmac/HS256.php


Joomla CMS: Référence de la classe HS256_64

  • Jose
  • Component
  • Signature
  • Algorithm
  • HS256_64
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HS256_64
+ Graphe d'héritage de HS256_64:
HMAC MacAlgorithm Algorithm

Fonctions membres publiques

hash (JWK $key, string $input)
name ()
- Fonctions membres publiques hérités de HMAC
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)

Fonctions membres protégées

getHashAlgorithm ()
- Fonctions membres protégées hérités de HMAC
getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ hash()

hash | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to hash the data
string | $input | The input

Implémente MacAlgorithm.

Références $input, et $key.

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HS256_64.php


Joomla CMS: Référence de la classe HS384

  • Jose
  • Component
  • Signature
  • Algorithm
  • HS384
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HS384
+ Graphe d'héritage de HS384:
HMAC MacAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de HMAC
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)

Fonctions membres protégées

getHashAlgorithm ()
getKey (JWK $key)
- Fonctions membres protégées hérités de HMAC
getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getKey()

getKey ( JWK $key )
protected
Exceptions
InvalidArgumentException if the key is invalid

Références $key.

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-hmac/HS384.php


Joomla CMS: Référence de la classe HS512

  • Jose
  • Component
  • Signature
  • Algorithm
  • HS512
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe HS512
+ Graphe d'héritage de HS512:
HMAC MacAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de HMAC
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
hash (JWK $key, string $input)

Fonctions membres protégées

getHashAlgorithm ()
getKey (JWK $key)
- Fonctions membres protégées hérités de HMAC
getKey (JWK $key)
getHashAlgorithm ()

Documentation des fonctions membres

◆ getHashAlgorithm()

getHashAlgorithm ( )
protected

◆ getKey()

getKey ( JWK $key )
protected
Exceptions
InvalidArgumentException if the key is invalid

Références $key.

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-hmac/HS512.php


Joomla CMS: Référence de l'interface MacAlgorithm

  • Jose
  • Component
  • Signature
  • Algorithm
  • MacAlgorithm
Fonctions membres publiques
Référence de l'interface MacAlgorithm
+ Graphe d'héritage de MacAlgorithm:
Algorithm HMAC HS1 HS256 HS256_64 HS384 HS512

Fonctions membres publiques

hash (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)
- Fonctions membres publiques hérités de Algorithm
name ()
allowedKeyTypes ()

Documentation des fonctions membres

◆ hash()

hash | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to hash the data
string | $input | The input

Implémenté dans HMAC, et HS256_64.

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to hash the data
string | $input | The input
string | $signature | The signature to verify

Implémenté dans HMAC.

La documentation de cette interface a été générée à partir du fichier suivant :
  • MacAlgorithm.php


Joomla CMS: Référence de la classe None

  • Jose
  • Component
  • Signature
  • Algorithm
  • None
Fonctions membres publiques | Fonctions membres privées
Référence de la classe None
+ Graphe d'héritage de None:
SignatureAlgorithm Algorithm

Fonctions membres publiques

allowedKeyTypes ()
sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)
name ()

Fonctions membres privées

checkKey (JWK $key)

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par None\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private
Exceptions
InvalidArgumentException if the key type is invalid

Références $key, et None\allowedKeyTypes().

Référencé par None\sign().

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input

Implémente SignatureAlgorithm.

Références None\checkKey().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémente SignatureAlgorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-none/None.php


Joomla CMS: Référence de la classe PS256

  • Jose
  • Component
  • Signature
  • Algorithm
  • PS256
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PS256
+ Graphe d'héritage de PS256:
RSAPSS SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPSS
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPSS
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/PS256.php


Joomla CMS: Référence de la classe PS384

  • Jose
  • Component
  • Signature
  • Algorithm
  • PS384
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PS384
+ Graphe d'héritage de PS384:
RSAPSS SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPSS
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPSS
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/PS384.php


Joomla CMS: Référence de la classe PS512

  • Jose
  • Component
  • Signature
  • Algorithm
  • PS512
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe PS512
+ Graphe d'héritage de PS512:
RSAPSS SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPSS
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPSS
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/PS512.php


Joomla CMS: Référence de la classe RS1

  • Jose
  • Component
  • Signature
  • Algorithm
  • RS1
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RS1
+ Graphe d'héritage de RS1:
RSAPKCS1 SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPKCS1
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPKCS1
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-experimental/RS1.php


Joomla CMS: Référence de la classe RS256

  • Jose
  • Component
  • Signature
  • Algorithm
  • RS256
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RS256
+ Graphe d'héritage de RS256:
RSAPKCS1 SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPKCS1
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPKCS1
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/RS256.php


Joomla CMS: Référence de la classe RS384

  • Jose
  • Component
  • Signature
  • Algorithm
  • RS384
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RS384
+ Graphe d'héritage de RS384:
RSAPKCS1 SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPKCS1
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPKCS1
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/RS384.php


Joomla CMS: Référence de la classe RS512

  • Jose
  • Component
  • Signature
  • Algorithm
  • RS512
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe RS512
+ Graphe d'héritage de RS512:
RSAPKCS1 SignatureAlgorithm Algorithm

Fonctions membres publiques

name ()
- Fonctions membres publiques hérités de RSAPKCS1
allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)

Fonctions membres protégées

getAlgorithm ()
- Fonctions membres protégées hérités de RSAPKCS1
getAlgorithm ()

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )
protected

◆ name()

name ( )

Returns the name of the algorithm.

Implémente Algorithm.

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/RS512.php


Joomla CMS: Référence de la classe RSA

  • Jose
  • Component
  • Signature
  • Algorithm
  • RSA
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RSA
+ Graphe d'héritage de RSA:
SignatureAlgorithm Algorithm

Fonctions membres publiques

allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)
- Fonctions membres publiques hérités de Algorithm
name ()

Fonctions membres protégées

getAlgorithm ()
getSignatureMethod ()

Fonctions membres privées

checkKey (JWK $key)

Description détaillée

Obsolète:
Please use either RSAPSS or RSAPKCS1 depending on the padding mode

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par RSA\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private
Exceptions
InvalidArgumentException | if the key type is not allowed
InvalidArgumentException | if the key is invalid

Références $key, et RSA\allowedKeyTypes().

Référencé par RSA\sign(), et RSA\verify().

◆ getAlgorithm()

getAlgorithm ( )
abstractprotected

Référencé par RSA\sign(), et RSA\verify().

◆ getSignatureMethod()

getSignatureMethod ( )
abstractprotected

Référencé par RSA\sign(), et RSA\verify().

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |
Exceptions
InvalidArgumentException if the key is not private

Implémente SignatureAlgorithm.

Références $input, $key, RSA\checkKey(), RSAKey\createFromJWK(), RSA\getAlgorithm(), et RSA\getSignatureMethod().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémente SignatureAlgorithm.

Références $input, $key, RSA\checkKey(), RSAKey\createFromJWK(), RSA\getAlgorithm(), et RSA\getSignatureMethod().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature-algorithm-rsa/RSA.php


Joomla CMS: Référence de la classe RSAPKCS1

  • Jose
  • Component
  • Signature
  • Algorithm
  • RSAPKCS1
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RSAPKCS1
+ Graphe d'héritage de RSAPKCS1:
SignatureAlgorithm Algorithm RS1 RS256 RS384 RS512

Fonctions membres publiques

allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)
- Fonctions membres publiques hérités de Algorithm
name ()

Fonctions membres protégées

getAlgorithm ()

Fonctions membres privées

checkKey (JWK $key)

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par RSAPKCS1\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private
Exceptions
InvalidArgumentException | if the key type is not allowed
InvalidArgumentException | if the key is not valid

Références $key, et RSAPKCS1\allowedKeyTypes().

Référencé par RSAPKCS1\sign(), et RSAPKCS1\verify().

◆ getAlgorithm()

getAlgorithm ( )
abstractprotected

Référencé par RSAPKCS1\sign(), et RSAPKCS1\verify().

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |
Exceptions
InvalidArgumentException | if the key is not private
InvalidArgumentException | if the data cannot be signed

Implémente SignatureAlgorithm.

Références $input, $key, $result, RSAPKCS1\checkKey(), RSAKey\createFromJWK(), et RSAPKCS1\getAlgorithm().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémente SignatureAlgorithm.

Références $input, $key, RSAPKCS1\checkKey(), RSAKey\createFromJWK(), et RSAPKCS1\getAlgorithm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSAPKCS1.php


Joomla CMS: Référence de la classe RSAPSS

  • Jose
  • Component
  • Signature
  • Algorithm
  • RSAPSS
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe RSAPSS
+ Graphe d'héritage de RSAPSS:
SignatureAlgorithm Algorithm PS256 PS384 PS512

Fonctions membres publiques

allowedKeyTypes ()
verify (JWK $key, string $input, string $signature)
sign (JWK $key, string $input)
- Fonctions membres publiques hérités de Algorithm
name ()

Fonctions membres protégées

getAlgorithm ()

Fonctions membres privées

checkKey (JWK $key)

Documentation des fonctions membres

◆ allowedKeyTypes()

allowedKeyTypes ( )

Returns the key types suitable for this algorithm (e.g. "oct", "RSA"...).

Renvoie
string[]

Implémente Algorithm.

Référencé par RSAPSS\checkKey().

◆ checkKey()

checkKey ( JWK $key )
private
Exceptions
InvalidArgumentException | if the key type is not allowed
InvalidArgumentException | if the key is not valid

Références $key, et RSAPSS\allowedKeyTypes().

Référencé par RSAPSS\sign(), et RSAPSS\verify().

◆ getAlgorithm()

getAlgorithm ( )
abstractprotected

Référencé par RSAPSS\sign(), et RSAPSS\verify().

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |
Exceptions
InvalidArgumentException if the key is not private

Implémente SignatureAlgorithm.

Références $input, $key, RSAPSS\checkKey(), RSAKey\createFromJWK(), et RSAPSS\getAlgorithm().

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémente SignatureAlgorithm.

Références $input, $key, RSAPSS\checkKey(), RSAKey\createFromJWK(), et RSAPSS\getAlgorithm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSAPSS.php


Joomla CMS: Référence de l'interface SignatureAlgorithm

  • Jose
  • Component
  • Signature
  • Algorithm
  • SignatureAlgorithm
Fonctions membres publiques
Référence de l'interface SignatureAlgorithm
+ Graphe d'héritage de SignatureAlgorithm:
Algorithm ECDSA EdDSA None RSA RSAPKCS1 RSAPSS ES256 ES256K ES384 ES512 RS1 RS256 RS384 RS512 PS256 PS384 PS512

Fonctions membres publiques

sign (JWK $key, string $input)
verify (JWK $key, string $input, string $signature)
- Fonctions membres publiques hérités de Algorithm
name ()
allowedKeyTypes ()

Documentation des fonctions membres

◆ sign()

sign | ( | JWK | $key,
 |  | string | $input
 | ) |  |

Sign the input.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input

Implémenté dans EdDSA, RSA, RSAPKCS1, RSAPSS, ECDSA, et None.

◆ verify()

verify | ( | JWK | $key,
 |  | string | $input,
 |  | string | $signature
 | ) |  |

Verify the signature of data.

Paramètres
JWK | $key | The private key used to sign the data
string | $input | The input
string | $signature | The signature to verify

Implémenté dans EdDSA, ECDSA, None, RSA, RSAPKCS1, et RSAPSS.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SignatureAlgorithm.php


Joomla CMS: Référence de la classe CompactSerializer

  • Jose
  • Component
  • Signature
  • Serializer
  • CompactSerializer
Fonctions membres publiques | Champs de données
Référence de la classe CompactSerializer
+ Graphe d'héritage de CompactSerializer:
Serializer JWSSerializer

Fonctions membres publiques

displayName ()
name ()
serialize (JWS $jws, ?int $signatureIndex=null)
unserialize (string $input)

Champs de données

const NAME = 'jws_compact'

Membres hérités additionnels

- Fonctions membres protégées hérités de Serializer
isPayloadEncoded (array $protectedHeader)

Documentation des fonctions membres

◆ displayName()

displayName ( )

Implémente JWSSerializer.

◆ name()

name ( )

The name of the serialization.

Implémente JWSSerializer.

◆ serialize()

serialize | ( | JWS | $jws,
 |  | ?int | $signatureIndex = null
 | ) |  |
Exceptions
LogicException | if the JWS has unprotected header (invalid for compact JSON)
LogicException | if the payload is not encoded but contains unauthorized characters

Implémente JWSSerializer.

Références Base64Url\encode(), JWS\getEncodedPayload(), JWS\getPayload(), JWS\getSignature(), Serializer\isPayloadEncoded(), et null.

◆ unserialize()

unserialize ( string $input )
Exceptions
InvalidArgumentException if the input is invalid

Implémente JWSSerializer.

Références $input, $parts, Base64Url\decode(), JsonConverter\decode(), Serializer\isPayloadEncoded(), et null.

Documentation des champs

◆ NAME

const NAME = 'jws_compact'
La documentation de cette classe a été générée à partir du fichier suivant :
  • CompactSerializer.php


Joomla CMS: Référence de la classe JSONFlattenedSerializer

  • Jose
  • Component
  • Signature
  • Serializer
  • JSONFlattenedSerializer
Fonctions membres publiques | Champs de données
Référence de la classe JSONFlattenedSerializer
+ Graphe d'héritage de JSONFlattenedSerializer:
Serializer JWSSerializer

Fonctions membres publiques

displayName ()
name ()
serialize (JWS $jws, ?int $signatureIndex=null)
unserialize (string $input)

Champs de données

const NAME = 'jws_json_flattened'

Membres hérités additionnels

- Fonctions membres protégées hérités de Serializer
isPayloadEncoded (array $protectedHeader)

Documentation des fonctions membres

◆ displayName()

displayName ( )

Implémente JWSSerializer.

◆ name()

name ( )

The name of the serialization.

Implémente JWSSerializer.

◆ serialize()

serialize | ( | JWS | $jws,
 |  | ?int | $signatureIndex = null
 | ) |  |

Converts a JWS into a string.

Implémente JWSSerializer.

Références $data, $header, JsonConverter\encode(), Base64Url\encode(), JWS\getEncodedPayload(), JWS\getSignature(), et null.

◆ unserialize()

unserialize ( string $input )
Exceptions
InvalidArgumentException | if the input is not supported
InvalidArgumentException | if the JWS header is invalid

Implémente JWSSerializer.

Références $data, $header, $input, JsonConverter\decode(), Base64Url\decode(), Serializer\isPayloadEncoded(), et null.

Documentation des champs

◆ NAME

const NAME = 'jws_json_flattened'
La documentation de cette classe a été générée à partir du fichier suivant :
  • JSONFlattenedSerializer.php


Joomla CMS: Référence de la classe JSONGeneralSerializer

  • Jose
  • Component
  • Signature
  • Serializer
  • JSONGeneralSerializer
Fonctions membres publiques | Champs de données | Fonctions membres privées
Référence de la classe JSONGeneralSerializer
+ Graphe d'héritage de JSONGeneralSerializer:
Serializer JWSSerializer

Fonctions membres publiques

displayName ()
name ()
serialize (JWS $jws, ?int $signatureIndex=null)
unserialize (string $input)

Champs de données

const NAME = 'jws_json_general'

Fonctions membres privées

processIsPayloadEncoded (?bool $isPayloadEncoded, array $protectedHeader)
processHeaders (array $signature)
processPayload (?string $rawPayload, ?bool $isPayloadEncoded)
checkPayloadEncoding (JWS $jws)

Membres hérités additionnels

- Fonctions membres protégées hérités de Serializer
isPayloadEncoded (array $protectedHeader)

Documentation des fonctions membres

◆ checkPayloadEncoding()

checkPayloadEncoding ( JWS $jws )
private

Références JWS\getSignatures(), JWS\isPayloadDetached(), Serializer\isPayloadEncoded(), et null.

Référencé par JSONGeneralSerializer\serialize().

◆ displayName()

displayName ( )

Implémente JWSSerializer.

◆ name()

name ( )

The name of the serialization.

Implémente JWSSerializer.

◆ processHeaders()

processHeaders ( array $signature )
private

Références $header, JsonConverter\decode(), Base64Url\decode(), et null.

Référencé par JSONGeneralSerializer\unserialize().

◆ processIsPayloadEncoded()

processIsPayloadEncoded | ( | ?bool | $isPayloadEncoded,
 |  | array | $protectedHeader
 | ) |  |
private
Exceptions
InvalidArgumentException if the payload encoding is invalid

Références Serializer\isPayloadEncoded(), et null.

Référencé par JSONGeneralSerializer\unserialize().

◆ processPayload()

processPayload | ( | ?string | $rawPayload,
 |  | ?bool | $isPayloadEncoded
 | ) |  |
private

Références Base64Url\decode(), et null.

Référencé par JSONGeneralSerializer\unserialize().

◆ serialize()

serialize | ( | JWS | $jws,
 |  | ?int | $signatureIndex = null
 | ) |  |
Exceptions
LogicException if no signature is attached

Implémente JWSSerializer.

Références $data, $key, $tmp, $value, JSONGeneralSerializer\checkPayloadEncoding(), JWS\countSignatures(), JsonConverter\encode(), Base64Url\encode(), JWS\getEncodedPayload(), JWS\getSignatures(), et JWS\isPayloadDetached().

◆ unserialize()

unserialize ( string $input )
Exceptions
InvalidArgumentException if the input is not supported

Implémente JWSSerializer.

Références $data, $header, $input, JsonConverter\decode(), Base64Url\decode(), null, JSONGeneralSerializer\processHeaders(), JSONGeneralSerializer\processIsPayloadEncoded(), et JSONGeneralSerializer\processPayload().

Documentation des champs

◆ NAME

const NAME = 'jws_json_general'
La documentation de cette classe a été générée à partir du fichier suivant :
  • JSONGeneralSerializer.php


Joomla CMS: Référence de l'interface JWSSerializer

  • Jose
  • Component
  • Signature
  • Serializer
  • JWSSerializer
Fonctions membres publiques
Référence de l'interface JWSSerializer
+ Graphe d'héritage de JWSSerializer:
Serializer CompactSerializer JSONFlattenedSerializer JSONGeneralSerializer

Fonctions membres publiques

name ()
displayName ()
serialize (JWS $jws, ?int $signatureIndex=null)
unserialize (string $input)

Documentation des fonctions membres

◆ displayName()

displayName ( )

Implémenté dans JSONGeneralSerializer, CompactSerializer, et JSONFlattenedSerializer.

◆ name()

name ( )

The name of the serialization.

Implémenté dans JSONGeneralSerializer, CompactSerializer, et JSONFlattenedSerializer.

Référencé par JWSSerializerManagerFactory\add(), et JWSSerializerManager\add().

◆ serialize()

serialize | ( | JWS | $jws,
 |  | ?int | $signatureIndex = null
 | ) |  |

Converts a JWS into a string.

Implémenté dans JSONGeneralSerializer, CompactSerializer, et JSONFlattenedSerializer.

◆ unserialize()

unserialize ( string $input )

Loads data and return a JWS object.

Paramètres
string $input A string that represents a JWS

Implémenté dans JSONGeneralSerializer, JSONFlattenedSerializer, et CompactSerializer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • JWSSerializer.php


Joomla CMS: Référence de la classe JWSSerializerManager

  • Jose
  • Component
  • Signature
  • Serializer
  • JWSSerializerManager
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe JWSSerializerManager

Fonctions membres publiques

__construct (array $serializers)
list ()
serialize (string $name, JWS $jws, ?int $signatureIndex=null)
unserialize (string $input, ?string &$name=null)

Fonctions membres privées

add (JWSSerializer $serializer)

Attributs privés

$serializers = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $serializers )
Paramètres
JWSSerializer[] $serializers

Références JWSSerializerManager\$serializers, et JWSSerializerManager\add().

Documentation des fonctions membres

◆ add()

add ( JWSSerializer $serializer )
private

Références JWSSerializer\name().

Référencé par JWSSerializerManager\__construct().

◆ list()

list ( )
Renvoie
string[]

◆ serialize()

serialize | ( | string | $name,
 |  | JWS | $jws,
 |  | ?int | $signatureIndex = null
 | ) |  |

Converts a JWS into a string.

Exceptions
InvalidArgumentException if the serializer is not supported

Références $name.

◆ unserialize()

unserialize | ( | string | $input,
 |  | ?string & | $name = null
 | ) |  |

Loads data and return a JWS object.

Paramètres
string | $input | A string that represents a JWS
null | string | $name | the name of the serializer if the input is unserialized
Exceptions
InvalidArgumentException if the input is not supported

Références $input, et $name.

Documentation des champs

◆ $serializers

$serializers = []
private

Référencé par JWSSerializerManager\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSSerializerManager.php


Joomla CMS: Référence de la classe JWSSerializerManagerFactory

  • Jose
  • Component
  • Signature
  • Serializer
  • JWSSerializerManagerFactory
Fonctions membres publiques | Attributs privés
Référence de la classe JWSSerializerManagerFactory

Fonctions membres publiques

create (array $names)
names ()
all ()
add (JWSSerializer $serializer)

Attributs privés

$serializers = []

Documentation des fonctions membres

◆ add()

add ( JWSSerializer $serializer )

Références JWSSerializer\name().

◆ all()

all ( )
Renvoie
JWSSerializer[]

Références JWSSerializerManagerFactory\$serializers.

◆ create()

create ( array $names )
Paramètres
string[] $names
Exceptions
InvalidArgumentException if the serializer is not supported

Références $name, $names, et JWSSerializerManagerFactory\$serializers.

◆ names()

names ( )
Renvoie
string[]

Documentation des champs

◆ $serializers

$serializers = []
private

Référencé par JWSSerializerManagerFactory\all(), et JWSSerializerManagerFactory\create().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSSerializerManagerFactory.php


Joomla CMS: Référence de la classe Serializer

  • Jose
  • Component
  • Signature
  • Serializer
  • Serializer
Fonctions membres protégées
Référence de la classe Serializer
+ Graphe d'héritage de Serializer:
JWSSerializer CompactSerializer JSONFlattenedSerializer JSONGeneralSerializer

Fonctions membres protégées

isPayloadEncoded (array $protectedHeader)

Membres hérités additionnels

- Fonctions membres publiques hérités de JWSSerializer
name ()
displayName ()
serialize (JWS $jws, ?int $signatureIndex=null)
unserialize (string $input)

Documentation des fonctions membres

◆ isPayloadEncoded()

isPayloadEncoded ( array $protectedHeader )
protected

Référencé par JSONGeneralSerializer\checkPayloadEncoding(), JSONGeneralSerializer\processIsPayloadEncoded(), CompactSerializer\serialize(), CompactSerializer\unserialize(), et JSONFlattenedSerializer\unserialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature/Serializer/Serializer.php


Joomla CMS: Référence de la classe JWS

  • Jose
  • Component
  • Signature
  • JWS
Fonctions membres publiques | Attributs privés
Référence de la classe JWS
+ Graphe d'héritage de JWS:
JWT

Fonctions membres publiques

__construct (?string $payload, ?string $encodedPayload=null, bool $isPayloadDetached=false)
getPayload ()
isPayloadDetached ()
getEncodedPayload ()
getSignatures ()
getSignature (int $id)
addSignature (string $signature, array $protectedHeader, ?string $encodedProtectedHeader, array $header=[])
countSignatures ()
split ()

Attributs privés

$isPayloadDetached = false
$encodedPayload
$signatures = []
$payload

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?string | $payload,
 |  | ?string | $encodedPayload = null,
 |  | bool | $isPayloadDetached = false
 | ) |  |

Références JWS\$encodedPayload, JWS\$isPayloadDetached, JWS\$payload, et JWS\isPayloadDetached().

Documentation des fonctions membres

◆ addSignature()

addSignature | ( | string | $signature,
 |  | array | $protectedHeader,
 |  | ?string | $encodedProtectedHeader,
 |  | array | $header = []
 | ) |  |

This method adds a signature to the JWS object. Its returns a new JWS object.

Références $header, et $this.

◆ countSignatures()

countSignatures ( )

Returns the number of signature associated with the JWS.

Référencé par JWSLoader\loadAndVerifyWithKeySet(), JSONGeneralSerializer\serialize(), et JWSVerifier\verifyWithKeySet().

◆ getEncodedPayload()

getEncodedPayload ( )

Returns the Base64Url encoded payload. If the payload is detached, this method returns null.

Références JWS\$encodedPayload, JWS\isPayloadDetached(), et null.

Référencé par JWSVerifier\getInputToVerify(), JSONFlattenedSerializer\serialize(), CompactSerializer\serialize(), et JSONGeneralSerializer\serialize().

◆ getPayload()

getPayload ( )

Returns the payload of the JWT. null is a valid payload (e.g. JWS with detached payload).

Implémente JWT.

Références JWS\$payload.

Référencé par JWSVerifier\checkPayload(), JWSVerifier\getInputToVerify(), et CompactSerializer\serialize().

◆ getSignature()

getSignature ( int $id )

Returns the signature at the given index.

Exceptions
InvalidArgumentException if the signature index does not exist

Références $id.

Référencé par JSONFlattenedSerializer\serialize(), CompactSerializer\serialize(), et JWSVerifier\verifyWithKeySet().

◆ getSignatures()

getSignatures ( )

Returns the signatures associated with the JWS.

Renvoie
Signature[]

Références JWS\$signatures.

Référencé par JSONGeneralSerializer\checkPayloadEncoding(), et JSONGeneralSerializer\serialize().

◆ isPayloadDetached()

isPayloadDetached ( )

Returns true if the payload is detached.

Références JWS\$isPayloadDetached.

Référencé par JWS\__construct(), JSONGeneralSerializer\checkPayloadEncoding(), JWS\getEncodedPayload(), et JSONGeneralSerializer\serialize().

◆ split()

split ( )

This method splits the JWS into a list of JWSs. It is only useful when the JWS contains more than one signature (JSON General Serialization).

Renvoie
JWS[]

Références JWS\$encodedPayload, JWS\$isPayloadDetached, JWS\$payload, et $result.

Documentation des champs

◆ $encodedPayload

$encodedPayload
private

Référencé par JWS\__construct(), JWS\getEncodedPayload(), et JWS\split().

◆ $isPayloadDetached

$isPayloadDetached = false
private

Référencé par JWS\__construct(), JWS\isPayloadDetached(), et JWS\split().

◆ $payload

$payload
private

Référencé par JWS\__construct(), JWS\getPayload(), et JWS\split().

◆ $signatures

$signatures = []
private

Référencé par JWS\getSignatures().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWS.php


Joomla CMS: Référence de la classe JWSBuilder

  • Jose
  • Component
  • Signature
  • JWSBuilder
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe JWSBuilder

Fonctions membres publiques

__construct (AlgorithmManager $signatureAlgorithmManager)
getSignatureAlgorithmManager ()
create ()
withPayload (string $payload, bool $isPayloadDetached=false)
addSignature (JWK $signatureKey, array $protectedHeader, array $header=[])

Attributs protégés

$payload
$isPayloadDetached
$signatures = []
$isPayloadEncoded

Fonctions membres privées

checkIfPayloadIsEncoded (array $protectedHeader)
checkB64AndCriticalHeader (array $protectedHeader)
findSignatureAlgorithm (JWK $key, array $protectedHeader, array $header)
checkDuplicatedHeaderParameters (array $header1, array $header2)

Attributs privés

$signatureAlgorithmManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( AlgorithmManager $signatureAlgorithmManager )

Références JWSBuilder\$signatureAlgorithmManager.

Documentation des fonctions membres

◆ addSignature()

addSignature | ( | JWK | $signatureKey,
 |  | array | $protectedHeader,
 |  | array | $header = []
 | ) |  |

Adds the information needed to compute the signature. This method will return a new JWSBuilder object.

Exceptions
InvalidArgumentException if the payload encoding is inconsistent
Renvoie
JWSBuilder

Références $header, JWSBuilder\$isPayloadEncoded, $this, JWSBuilder\checkB64AndCriticalHeader(), JWSBuilder\checkDuplicatedHeaderParameters(), JWSBuilder\checkIfPayloadIsEncoded(), KeyChecker\checkKeyAlgorithm(), KeyChecker\checkKeyUsage(), elseif, JWSBuilder\findSignatureAlgorithm(), et null.

◆ checkB64AndCriticalHeader()

checkB64AndCriticalHeader ( array $protectedHeader )
private
Exceptions
LogicException if the header parameter "crit" is missing, invalid or does not contain "b64" when "b64" is set

Référencé par JWSBuilder\addSignature().

◆ checkDuplicatedHeaderParameters()

checkDuplicatedHeaderParameters | ( | array | $header1,
 |  | array | $header2
 | ) |  |
private
Exceptions
InvalidArgumentException if the header contains duplicated entries

Référencé par JWSBuilder\addSignature().

◆ checkIfPayloadIsEncoded()

checkIfPayloadIsEncoded ( array $protectedHeader )
private

Référencé par JWSBuilder\addSignature().

◆ create()

create ( )

Reset the current data.

Renvoie
JWSBuilder

Références $this, et null.

Référencé par JWSBuilderFactory\create().

◆ findSignatureAlgorithm()

findSignatureAlgorithm | ( | JWK | $key,
 |  | array | $protectedHeader,
 |  | array | $header
 | ) |  |
private
Exceptions
InvalidArgumentException if the header parameter "alg" is missing or the algorithm is not allowed/not supported
Renvoie
MacAlgorithm|SignatureAlgorithm

Références $header, et $key.

Référencé par JWSBuilder\addSignature().

◆ getSignatureAlgorithmManager()

getSignatureAlgorithmManager ( )

Returns the algorithm manager associated to the builder.

Références JWSBuilder\$signatureAlgorithmManager.

◆ withPayload()

withPayload | ( | string | $payload,
 |  | bool | $isPayloadDetached = false
 | ) |  |

Set the payload. This method will return a new JWSBuilder object.

Exceptions
InvalidArgumentException if the payload is not UTF-8 encoded
Renvoie
JWSBuilder

Références JWSBuilder\$isPayloadDetached, JWSBuilder\$payload, et $this.

Documentation des champs

◆ $isPayloadDetached

$isPayloadDetached
protected

Référencé par JWSBuilder\withPayload().

◆ $isPayloadEncoded

$isPayloadEncoded
protected

Référencé par JWSBuilder\addSignature().

◆ $payload

$payload
protected

Référencé par JWSBuilder\withPayload().

◆ $signatureAlgorithmManager

$signatureAlgorithmManager
private

Référencé par JWSBuilder\__construct(), et JWSBuilder\getSignatureAlgorithmManager().

◆ $signatures

$signatures = []
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSBuilder.php


Joomla CMS: Référence de la classe JWSBuilderFactory

  • Jose
  • Component
  • Signature
  • JWSBuilderFactory
Fonctions membres publiques | Attributs privés
Référence de la classe JWSBuilderFactory

Fonctions membres publiques

__construct (AlgorithmManagerFactory $signatureAlgorithmManagerFactory)
create (array $algorithms)

Attributs privés

$signatureAlgorithmManagerFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( AlgorithmManagerFactory $signatureAlgorithmManagerFactory )

Références JWSBuilderFactory\$signatureAlgorithmManagerFactory.

Documentation des fonctions membres

◆ create()

create ( array $algorithms )

This method creates a JWSBuilder using the given algorithm aliases.

Paramètres
string[] $algorithms

Références JWSBuilder\create().

Documentation des champs

◆ $signatureAlgorithmManagerFactory

$signatureAlgorithmManagerFactory
private

Référencé par JWSBuilderFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSBuilderFactory.php


Joomla CMS: Référence de la classe JWSLoader

  • Jose
  • Component
  • Signature
  • JWSLoader
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe JWSLoader

Fonctions membres publiques

__construct (JWSSerializerManager $serializerManager, JWSVerifier $jwsVerifier, ?HeaderCheckerManager $headerCheckerManager)
getJwsVerifier ()
getHeaderCheckerManager ()
getSerializerManager ()
loadAndVerifyWithKey (string $token, JWK $key, ?int &$signature, ?string $payload=null)
loadAndVerifyWithKeySet (string $token, JWKSet $keyset, ?int &$signature, ?string $payload=null)

Fonctions membres privées

processSignature (JWS $jws, JWKSet $keyset, int $signature, ?string $payload)

Attributs privés

$jwsVerifier
$headerCheckerManager
$serializerManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | JWSSerializerManager | $serializerManager,
 |  | JWSVerifier | $jwsVerifier,
 |  | ?HeaderCheckerManager | $headerCheckerManager
 | ) |  |

JWSLoader constructor.

Références JWSLoader\$headerCheckerManager, JWSLoader\$jwsVerifier, et JWSLoader\$serializerManager.

Documentation des fonctions membres

◆ getHeaderCheckerManager()

getHeaderCheckerManager ( )

Returns the Header Checker Manager associated to the JWSLoader.

Références JWSLoader\$headerCheckerManager.

◆ getJwsVerifier()

getJwsVerifier ( )

Returns the JWSVerifier associated to the JWSLoader.

Références JWSLoader\$jwsVerifier.

◆ getSerializerManager()

getSerializerManager ( )

Returns the JWSSerializer associated to the JWSLoader.

Références JWSLoader\$serializerManager.

◆ loadAndVerifyWithKey()

loadAndVerifyWithKey | ( | string | $token,
 |  | JWK | $key,
 |  | ?int & | $signature,
 |  | ?string | $payload = null
 | ) |  |

This method will try to load and verify the token using the given key. It returns a JWS and will populate the $signature variable in case of success, otherwise an exception is thrown.

Exceptions
Exception if the token cannot be loaded or verified

Références $key, et JWSLoader\loadAndVerifyWithKeySet().

◆ loadAndVerifyWithKeySet()

loadAndVerifyWithKeySet | ( | string | $token,
 |  | JWKSet | $keyset,
 |  | ?int & | $signature,
 |  | ?string | $payload = null
 | ) |  |

This method will try to load and verify the token using the given key set. It returns a JWS and will populate the $signature variable in case of success, otherwise an exception is thrown.

Exceptions
Exception if the token cannot be loaded or verified

Références $i, JWS\countSignatures(), et JWSLoader\processSignature().

Référencé par JWSLoader\loadAndVerifyWithKey().

◆ processSignature()

processSignature | ( | JWS | $jws,
 |  | JWKSet | $keyset,
 |  | int | $signature,
 |  | ?string | $payload
 | ) |  |
private

Références null.

Référencé par JWSLoader\loadAndVerifyWithKeySet().

Documentation des champs

◆ $headerCheckerManager

$headerCheckerManager
private

Référencé par JWSLoader\__construct(), et JWSLoader\getHeaderCheckerManager().

◆ $jwsVerifier

$jwsVerifier
private

Référencé par JWSLoader\__construct(), et JWSLoader\getJwsVerifier().

◆ $serializerManager

$serializerManager
private

Référencé par JWSLoader\__construct(), et JWSLoader\getSerializerManager().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSLoader.php


Joomla CMS: Référence de la classe JWSLoaderFactory

  • Jose
  • Component
  • Signature
  • JWSLoaderFactory
Fonctions membres publiques | Attributs privés
Référence de la classe JWSLoaderFactory

Fonctions membres publiques

__construct (JWSSerializerManagerFactory $jwsSerializerManagerFactory, JWSVerifierFactory $jwsVerifierFactory, ?HeaderCheckerManagerFactory $headerCheckerManagerFactory)
create (array $serializers, array $algorithms, array $headerCheckers=[])

Attributs privés

$jwsVerifierFactory
$jwsSerializerManagerFactory
$headerCheckerManagerFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | JWSSerializerManagerFactory | $jwsSerializerManagerFactory,
 |  | JWSVerifierFactory | $jwsVerifierFactory,
 |  | ?HeaderCheckerManagerFactory | $headerCheckerManagerFactory
 | ) |  |

Références JWSLoaderFactory\$headerCheckerManagerFactory, JWSLoaderFactory\$jwsSerializerManagerFactory, et JWSLoaderFactory\$jwsVerifierFactory.

Documentation des fonctions membres

◆ create()

create | ( | array | $serializers,
 |  | array | $algorithms,
 |  | array | $headerCheckers = []
 | ) |  |

Creates a JWSLoader using the given serializer aliases, signature algorithm aliases and (optionally) the header checker aliases.

Références null.

Documentation des champs

◆ $headerCheckerManagerFactory

$headerCheckerManagerFactory
private

Référencé par JWSLoaderFactory\__construct().

◆ $jwsSerializerManagerFactory

$jwsSerializerManagerFactory
private

Référencé par JWSLoaderFactory\__construct().

◆ $jwsVerifierFactory

$jwsVerifierFactory
private

Référencé par JWSLoaderFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSLoaderFactory.php


Joomla CMS: Référence de la classe JWSTokenSupport

  • Jose
  • Component
  • Signature
  • JWSTokenSupport
Fonctions membres publiques
Référence de la classe JWSTokenSupport
+ Graphe d'héritage de JWSTokenSupport:

Fonctions membres publiques

supports (JWT $jwt)
retrieveTokenHeaders (JWT $jwt, int $index, array &$protectedHeader, array &$unprotectedHeader)

Documentation des fonctions membres

◆ retrieveTokenHeaders()

retrieveTokenHeaders | ( | JWT | $jwt,
 |  | int | $index,
 |  | array & | $protectedHeader,
 |  | array & | $unprotectedHeader
 | ) |  |
Exceptions
InvalidArgumentException if the signature index does not exist

◆ supports()

supports ( JWT $jwt )
La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSTokenSupport.php


Joomla CMS: Référence de la classe JWSVerifier

  • Jose
  • Component
  • Signature
  • JWSVerifier
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe JWSVerifier

Fonctions membres publiques

__construct (AlgorithmManager $signatureAlgorithmManager)
getSignatureAlgorithmManager ()
verifyWithKey (JWS $jws, JWK $jwk, int $signature, ?string $detachedPayload=null)
verifyWithKeySet (JWS $jws, JWKSet $jwkset, int $signatureIndex, ?string $detachedPayload=null, JWK &$jwk=null)

Fonctions membres privées

verifySignature (JWS $jws, JWKSet $jwkset, Signature $signature, ?string $detachedPayload=null, JWK &$successJwk=null)
getInputToVerify (JWS $jws, Signature $signature, ?string $detachedPayload)
checkPayload (JWS $jws, ?string $detachedPayload=null)
getAlgorithm (Signature $signature)
isPayloadEmpty (?string $payload)

Attributs privés

$signatureAlgorithmManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( AlgorithmManager $signatureAlgorithmManager )

JWSVerifier constructor.

Références JWSVerifier\$signatureAlgorithmManager.

Documentation des fonctions membres

◆ checkPayload()

checkPayload | ( | JWS | $jws,
 |  | ?string | $detachedPayload = null
 | ) |  |
private
Exceptions
InvalidArgumentException if the payload is set when a detached payload is provided or no payload is defined

Références JWS\getPayload(), JWSVerifier\isPayloadEmpty(), et null.

Référencé par JWSVerifier\verifyWithKeySet().

◆ getAlgorithm()

getAlgorithm ( Signature $signature )
private
Exceptions
InvalidArgumentException if the header parameter "alg" is missing or invalid
Renvoie
MacAlgorithm|SignatureAlgorithm

Références Signature\getHeader(), et Signature\getProtectedHeader().

Référencé par JWSVerifier\verifySignature().

◆ getInputToVerify()

getInputToVerify | ( | JWS | $jws,
 |  | Signature | $signature,
 |  | ?string | $detachedPayload
 | ) |  |
private

Références Base64Url\encode(), JWS\getEncodedPayload(), Signature\getEncodedProtectedHeader(), JWS\getPayload(), Signature\getProtectedHeaderParameter(), Signature\hasProtectedHeaderParameter(), JWSVerifier\isPayloadEmpty(), et null.

Référencé par JWSVerifier\verifySignature().

◆ getSignatureAlgorithmManager()

getSignatureAlgorithmManager ( )

Returns the algorithm manager associated to the JWSVerifier.

Références JWSVerifier\$signatureAlgorithmManager.

◆ isPayloadEmpty()

isPayloadEmpty ( ?string $payload )
private

Références null.

Référencé par JWSVerifier\checkPayload(), et JWSVerifier\getInputToVerify().

◆ verifySignature()

verifySignature | ( | JWS | $jws,
 |  | JWKSet | $jwkset,
 |  | Signature | $signature,
 |  | ?string | $detachedPayload = null,
 |  | JWK & | $successJwk = null
 | ) |  |
private

Références $input, JWKSet\all(), KeyChecker\checkKeyAlgorithm(), KeyChecker\checkKeyUsage(), JWSVerifier\getAlgorithm(), JWSVerifier\getInputToVerify(), et Signature\getSignature().

Référencé par JWSVerifier\verifyWithKeySet().

◆ verifyWithKey()

verifyWithKey | ( | JWS | $jws,
 |  | JWK | $jwk,
 |  | int | $signature,
 |  | ?string | $detachedPayload = null
 | ) |  |

This method will try to verify the JWS object using the given key and for the given signature. It returns true if the signature is verified, otherwise false.

Renvoie
bool true if the verification of the signature succeeded, else false

Références JWSVerifier\verifyWithKeySet().

◆ verifyWithKeySet()

verifyWithKeySet | ( | JWS | $jws,
 |  | JWKSet | $jwkset,
 |  | int | $signatureIndex,
 |  | ?string | $detachedPayload = null,
 |  | JWK & | $jwk = null
 | ) |  |

This method will try to verify the JWS object using the given key set and for the given signature. It returns true if the signature is verified, otherwise false.

Paramètres
JWS | $jws | A JWS object
JWKSet | $jwkset | The signature will be verified using keys in the key set
JWK | $jwk | The key used to verify the signature in case of success
null | string | $detachedPayload | If not null, the value must be the detached payload encoded in Base64 URL safe. If the input contains a payload, throws an exception.
Exceptions
InvalidArgumentException | if there is no key in the keyset
InvalidArgumentException | if the token does not contain any signature
Renvoie
bool true if the verification of the signature succeeded, else false

Références JWSVerifier\checkPayload(), JWKSet\count(), JWS\countSignatures(), JWS\getSignature(), et JWSVerifier\verifySignature().

Référencé par JWSVerifier\verifyWithKey().

Documentation des champs

◆ $signatureAlgorithmManager

$signatureAlgorithmManager
private

Référencé par JWSVerifier\__construct(), et JWSVerifier\getSignatureAlgorithmManager().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSVerifier.php


Joomla CMS: Référence de la classe JWSVerifierFactory

  • Jose
  • Component
  • Signature
  • JWSVerifierFactory
Fonctions membres publiques | Attributs privés
Référence de la classe JWSVerifierFactory

Fonctions membres publiques

__construct (AlgorithmManagerFactory $algorithmManagerFactory)
create (array $algorithms)

Attributs privés

$algorithmManagerFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( AlgorithmManagerFactory $algorithmManagerFactory )

Références JWSVerifierFactory\$algorithmManagerFactory.

Documentation des fonctions membres

◆ create()

create ( array $algorithms )

Creates a JWSVerifier using the given signature algorithm aliases.

Paramètres
string[] $algorithms

Documentation des champs

◆ $algorithmManagerFactory

$algorithmManagerFactory
private

Référencé par JWSVerifierFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JWSVerifierFactory.php


Joomla CMS: Référence de la classe Signature

  • Jose
  • Component
  • Signature
  • Signature
Fonctions membres publiques | Attributs privés
Référence de la classe Signature

Fonctions membres publiques

__construct (string $signature, array $protectedHeader, ?string $encodedProtectedHeader, array $header)
getProtectedHeader ()
getHeader ()
getEncodedProtectedHeader ()
getProtectedHeaderParameter (string $key)
hasProtectedHeaderParameter (string $key)
getHeaderParameter (string $key)
hasHeaderParameter (string $key)
getSignature ()

Attributs privés

$encodedProtectedHeader
$protectedHeader
$header
$signature

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $signature,
 |  | array | $protectedHeader,
 |  | ?string | $encodedProtectedHeader,
 |  | array | $header
 | ) |  |

Références Signature\$encodedProtectedHeader, Signature\$header, Signature\$protectedHeader, Signature\$signature, et null.

Documentation des fonctions membres

◆ getEncodedProtectedHeader()

getEncodedProtectedHeader ( )

The protected header associated with the signature.

Références Signature\$encodedProtectedHeader.

Référencé par JWSVerifier\getInputToVerify().

◆ getHeader()

getHeader ( )

The unprotected header associated with the signature.

Références Signature\$header.

Référencé par JWSVerifier\getAlgorithm().

◆ getHeaderParameter()

getHeaderParameter ( string $key )

Returns the value of the unprotected header of the specified key.

Paramètres
string $key The key
Renvoie
null|mixed Header value

Références $key, et Signature\hasHeaderParameter().

◆ getProtectedHeader()

getProtectedHeader ( )

The protected header associated with the signature.

Références Signature\$protectedHeader.

Référencé par JWSVerifier\getAlgorithm(), Signature\getProtectedHeaderParameter(), et Signature\hasProtectedHeaderParameter().

◆ getProtectedHeaderParameter()

getProtectedHeaderParameter ( string $key )

Returns the value of the protected header of the specified key.

Paramètres
string $key The key
Exceptions
InvalidArgumentException if the header parameter does not exist
Renvoie
null|mixed Header value

Références $key, Signature\getProtectedHeader(), et Signature\hasProtectedHeaderParameter().

Référencé par JWSVerifier\getInputToVerify().

◆ getSignature()

getSignature ( )

Returns the value of the signature.

Références Signature\$signature.

Référencé par JWSVerifier\verifySignature().

◆ hasHeaderParameter()

hasHeaderParameter ( string $key )

Returns true if the unprotected header has the given parameter.

Paramètres
string $key The key

Références $key.

Référencé par Signature\getHeaderParameter().

◆ hasProtectedHeaderParameter()

hasProtectedHeaderParameter ( string $key )

Returns true if the protected header has the given parameter.

Paramètres
string $key The key

Références $key, et Signature\getProtectedHeader().

Référencé par JWSVerifier\getInputToVerify(), et Signature\getProtectedHeaderParameter().

Documentation des champs

◆ $encodedProtectedHeader

$encodedProtectedHeader
private

Référencé par Signature\__construct(), et Signature\getEncodedProtectedHeader().

◆ $header

$header
private

Référencé par Signature\__construct(), et Signature\getHeader().

◆ $protectedHeader

$protectedHeader
private

Référencé par Signature\__construct(), et Signature\getProtectedHeader().

◆ $signature

$signature
private

Référencé par Signature\__construct(), et Signature\getSignature().

La documentation de cette classe a été générée à partir du fichier suivant :
  • web-token/jwt-signature/Signature.php


Joomla CMS: Référence de la classe DeserializationException

  • Laminas
  • Diactoros
  • Exception
  • DeserializationException
Fonctions membres publiques statiques
Référence de la classe DeserializationException
+ Graphe d'héritage de DeserializationException:
ExceptionInterface

Fonctions membres publiques statiques

static | forInvalidHeader ()
static | forInvalidHeaderContinuation ()
static | forRequestFromArray (Throwable $previous)
static | forResponseFromArray (Throwable $previous)
static | forUnexpectedCarriageReturn ()
static | forUnexpectedEndOfHeaders ()
static | forUnexpectedLineFeed ()

Documentation des fonctions membres

◆ forInvalidHeader()

static forInvalidHeader ( )
static

Référencé par AbstractSerializer\splitStream().

◆ forInvalidHeaderContinuation()

static forInvalidHeaderContinuation ( )
static

Référencé par AbstractSerializer\splitStream().

◆ forRequestFromArray()

static forRequestFromArray ( Throwable $previous )
static

Référencé par ArraySerializer\fromArray().

◆ forResponseFromArray()

static forResponseFromArray ( Throwable $previous )
static

Référencé par ArraySerializer\fromArray().

◆ forUnexpectedCarriageReturn()

static forUnexpectedCarriageReturn ( )
static

Référencé par AbstractSerializer\getLine().

◆ forUnexpectedEndOfHeaders()

static forUnexpectedEndOfHeaders ( )
static

Référencé par AbstractSerializer\getLine().

◆ forUnexpectedLineFeed()

static forUnexpectedLineFeed ( )
static

Référencé par AbstractSerializer\getLine().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Exception/DeserializationException.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Laminas
  • Diactoros
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
DeserializationException InvalidArgumentException InvalidStreamPointerPositionException SerializationException UnreadableStreamException UnrecognizedProtocolVersionException UnrewindableStreamException UnseekableStreamException UntellableStreamException UnwritableStreamException UploadedFileAlreadyMovedException UploadedFileErrorException

Description détaillée

Marker interface for package-specific exceptions.

La documentation de cette interface a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Laminas
  • Diactoros
  • Exception
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
ExceptionInterface
La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Exception/InvalidArgumentException.php


Joomla CMS: Référence de la classe InvalidStreamPointerPositionException

  • Laminas
  • Diactoros
  • Exception
  • InvalidStreamPointerPositionException
Fonctions membres publiques
Référence de la classe InvalidStreamPointerPositionException
+ Graphe d'héritage de InvalidStreamPointerPositionException:
ExceptionInterface

Fonctions membres publiques

__construct (string $message='Invalid pointer position', $code=0, Throwable $previous=null)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message = 'Invalid pointer position',
 |  |  | $code = 0,
 |  | Throwable | $previous = null
 | ) |  |

Références $message, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidStreamPointerPositionException.php


Joomla CMS: Référence de la classe SerializationException

  • Laminas
  • Diactoros
  • Exception
  • SerializationException
Fonctions membres publiques statiques
Référence de la classe SerializationException
+ Graphe d'héritage de SerializationException:
ExceptionInterface

Fonctions membres publiques statiques

static | forInvalidRequestLine ()
static | forInvalidStatusLine ()

Documentation des fonctions membres

◆ forInvalidRequestLine()

static forInvalidRequestLine ( )
static

Référencé par Serializer\getRequestLine().

◆ forInvalidStatusLine()

static forInvalidStatusLine ( )
static

Référencé par Serializer\getStatusLine().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SerializationException.php


Joomla CMS: Référence de la classe UnreadableStreamException

  • Laminas
  • Diactoros
  • Exception
  • UnreadableStreamException
Fonctions membres publiques statiques
Référence de la classe UnreadableStreamException
+ Graphe d'héritage de UnreadableStreamException:
ExceptionInterface

Fonctions membres publiques statiques

static | dueToConfiguration ()
static | dueToMissingResource ()
static | dueToPhpError ()
static | forCallbackStream ()

Documentation des fonctions membres

◆ dueToConfiguration()

static dueToConfiguration ( )
static

Référencé par Stream\getContents(), et Stream\read().

◆ dueToMissingResource()

static dueToMissingResource ( )
static

Référencé par Stream\read().

◆ dueToPhpError()

static dueToPhpError ( )
static

Référencé par Stream\getContents(), et Stream\read().

◆ forCallbackStream()

static forCallbackStream ( )
static

Référencé par CallbackStream\read().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnreadableStreamException.php


Joomla CMS: Référence de la classe UnrecognizedProtocolVersionException

  • Laminas
  • Diactoros
  • Exception
  • UnrecognizedProtocolVersionException
Fonctions membres publiques statiques
Référence de la classe UnrecognizedProtocolVersionException
+ Graphe d'héritage de UnrecognizedProtocolVersionException:
ExceptionInterface

Fonctions membres publiques statiques

static forVersion (string $version)

Documentation des fonctions membres

◆ forVersion()

static forVersion ( string $version )
static

Références $version.

Référencé par Laminas\Diactoros\marshalProtocolVersionFromSapi().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnrecognizedProtocolVersionException.php


Joomla CMS: Référence de la classe UnrewindableStreamException

  • Laminas
  • Diactoros
  • Exception
  • UnrewindableStreamException
Fonctions membres publiques statiques
Référence de la classe UnrewindableStreamException
+ Graphe d'héritage de UnrewindableStreamException:
ExceptionInterface

Fonctions membres publiques statiques

static forCallbackStream ()

Documentation des fonctions membres

◆ forCallbackStream()

static forCallbackStream ( )
static

Référencé par CallbackStream\rewind().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnrewindableStreamException.php


Joomla CMS: Référence de la classe UnseekableStreamException

  • Laminas
  • Diactoros
  • Exception
  • UnseekableStreamException
Fonctions membres publiques statiques
Référence de la classe UnseekableStreamException
+ Graphe d'héritage de UnseekableStreamException:
ExceptionInterface

Fonctions membres publiques statiques

static | dueToConfiguration ()
static | dueToMissingResource ()
static | dueToPhpError ()
static | forCallbackStream ()

Documentation des fonctions membres

◆ dueToConfiguration()

static dueToConfiguration ( )
static

Référencé par Stream\seek().

◆ dueToMissingResource()

static dueToMissingResource ( )
static

Référencé par Stream\seek().

◆ dueToPhpError()

static dueToPhpError ( )
static

Référencé par Stream\seek().

◆ forCallbackStream()

static forCallbackStream ( )
static

Référencé par CallbackStream\seek().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnseekableStreamException.php


Joomla CMS: Référence de la classe UntellableStreamException

  • Laminas
  • Diactoros
  • Exception
  • UntellableStreamException
Fonctions membres publiques statiques
Référence de la classe UntellableStreamException
+ Graphe d'héritage de UntellableStreamException:
ExceptionInterface

Fonctions membres publiques statiques

static | dueToMissingResource ()
static | dueToPhpError ()
static | forCallbackStream ()

Documentation des fonctions membres

◆ dueToMissingResource()

static dueToMissingResource ( )
static

Référencé par Stream\tell().

◆ dueToPhpError()

static dueToPhpError ( )
static

Référencé par Stream\tell().

◆ forCallbackStream()

static forCallbackStream ( )
static

Référencé par CallbackStream\tell().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UntellableStreamException.php


Joomla CMS: Référence de la classe UnwritableStreamException

  • Laminas
  • Diactoros
  • Exception
  • UnwritableStreamException
Fonctions membres publiques statiques
Référence de la classe UnwritableStreamException
+ Graphe d'héritage de UnwritableStreamException:
ExceptionInterface

Fonctions membres publiques statiques

static | dueToConfiguration ()
static | dueToMissingResource ()
static | dueToPhpError ()
static | forCallbackStream ()

Documentation des fonctions membres

◆ dueToConfiguration()

static dueToConfiguration ( )
static

Référencé par Stream\write().

◆ dueToMissingResource()

static dueToMissingResource ( )
static

Référencé par Stream\write().

◆ dueToPhpError()

static dueToPhpError ( )
static

Référencé par Stream\write().

◆ forCallbackStream()

static forCallbackStream ( )
static

Référencé par CallbackStream\write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnwritableStreamException.php


Joomla CMS: Référence de la classe UploadedFileAlreadyMovedException

  • Laminas
  • Diactoros
  • Exception
  • UploadedFileAlreadyMovedException
Fonctions membres publiques
Référence de la classe UploadedFileAlreadyMovedException
+ Graphe d'héritage de UploadedFileAlreadyMovedException:
ExceptionInterface

Fonctions membres publiques

__construct (string $message='Cannot retrieve stream after it has already moved', $code=0, Throwable $previous=null)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message = 'Cannot retrieve stream after it has already moved',
 |  |  | $code = 0,
 |  | Throwable | $previous = null
 | ) |  |

Références $message, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UploadedFileAlreadyMovedException.php


Joomla CMS: Référence de la classe UploadedFileErrorException

  • Laminas
  • Diactoros
  • Exception
  • UploadedFileErrorException
Fonctions membres publiques statiques
Référence de la classe UploadedFileErrorException
+ Graphe d'héritage de UploadedFileErrorException:
ExceptionInterface

Fonctions membres publiques statiques

static | forUnmovableFile ()
static | dueToStreamUploadError (string $error)
static | dueToUnwritablePath ()
static | dueToUnwritableTarget (string $targetDirectory)

Documentation des fonctions membres

◆ dueToStreamUploadError()

static dueToStreamUploadError ( string $error )
static

Référencé par UploadedFile\getStream(), et UploadedFile\moveTo().

◆ dueToUnwritablePath()

static dueToUnwritablePath ( )
static

Référencé par UploadedFile\writeFile().

◆ dueToUnwritableTarget()

static dueToUnwritableTarget ( string $targetDirectory )
static

Référencé par UploadedFile\moveTo().

◆ forUnmovableFile()

static forUnmovableFile ( )
static

Référencé par UploadedFile\moveTo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UploadedFileErrorException.php


Joomla CMS: Référence de la classe ArraySerializer

  • Laminas
  • Diactoros
  • Request
  • ArraySerializer
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe ArraySerializer

Fonctions membres publiques statiques

static | toArray (RequestInterface $request)
static | fromArray (array $serializedRequest)

Fonctions membres privées statiques

static getValueFromKey (array $data, string $key, string $message=null)

Description détaillée

Serialize or deserialize request messages to/from arrays.

This class provides functionality for serializing a RequestInterface instance to an array, as well as the reverse operation of creating a Request instance from an array representing a message.

Documentation des fonctions membres

◆ fromArray()

static fromArray ( array $serializedRequest )
static

Deserialize a request array to a request instance.

Exceptions
Exception

Références Laminas\Diactoros\$method, Laminas\Diactoros\$requestTarget, Laminas\Diactoros\$uri, et DeserializationException\forRequestFromArray().

◆ getValueFromKey()

static getValueFromKey | ( | array | $data,
 |  | string | $key,
 |  | string | $message = null
 | ) |  |
staticprivate
Renvoie
mixed
Exceptions
Exception

Références $data, $key, $message, et null.

◆ toArray()

static toArray ( RequestInterface $request )
static

Serialize a request message to an array.

Références MessageInterface\getBody(), MessageInterface\getHeaders(), RequestInterface\getMethod(), MessageInterface\getProtocolVersion(), RequestInterface\getRequestTarget(), et RequestInterface\getUri().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Request/ArraySerializer.php


Joomla CMS: Référence de la classe Serializer

  • Laminas
  • Diactoros
  • Request
  • Serializer
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Serializer
+ Graphe d'héritage de Serializer:
AbstractSerializer

Fonctions membres publiques statiques

static | fromString (string $message)
static | fromStream (StreamInterface $stream)
static | toString (RequestInterface $request)

Fonctions membres privées statiques

static | getRequestLine (StreamInterface $stream)
static | createUriFromRequestTarget (string $requestTarget)

Membres hérités additionnels

- Champs de données hérités de AbstractSerializer
const | CR = "\r"
const | EOL = "\r\n"
const | LF = "\n"
- Fonctions membres protégées statiques hérités de AbstractSerializer
static | getLine (StreamInterface $stream)
static | splitStream (StreamInterface $stream)
static | serializeHeaders (array $headers)
static | filterHeader ($header)

Description détaillée

Serialize (cast to string) or deserialize (cast string to Request) messages.

This class provides functionality for serializing a RequestInterface instance to a string, as well as the reverse operation of creating a Request instance from a string/stream representing a message.

Documentation des fonctions membres

◆ createUriFromRequestTarget()

static createUriFromRequestTarget ( string $requestTarget )
staticprivate

Create and return a Uri instance based on the provided request target.

If the request target is of authority or asterisk form, an empty Uri instance is returned; otherwise, the value is used to create and return a new Uri instance.

Références Laminas\Diactoros\$requestTarget.

◆ fromStream()

static fromStream ( StreamInterface $stream )
static

Deserialize a request stream to a request instance.

Exceptions
Exception

Références Laminas\Diactoros\$method, Laminas\Diactoros\$requestTarget, Laminas\Diactoros\$stream, Laminas\Diactoros\$uri, et $version.

◆ fromString()

static fromString ( string $message )
static

Deserialize a request string to a request instance.

Internally, casts the message to a stream and invokes fromStream().

Exceptions
Exception

Références $message, et Laminas\Diactoros\$stream.

◆ getRequestLine()

static getRequestLine ( StreamInterface $stream )
staticprivate

Retrieve the components of the request line.

Retrieves the first line of the stream and parses it, raising an exception if it does not follow specifications; if valid, returns a list with the method, target, and version, in that order.

Exceptions
Exception

Références Laminas\Diactoros\$stream, et SerializationException\forInvalidRequestLine().

◆ toString()

static toString ( RequestInterface $request )
static

Serialize a request message to a string.

Références $format, MessageInterface\getBody(), MessageInterface\getHeaders(), RequestInterface\getMethod(), MessageInterface\getProtocolVersion(), et RequestInterface\getRequestTarget().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Request/Serializer.php


Joomla CMS: Référence de la classe ArraySerializer

  • Laminas
  • Diactoros
  • Response
  • ArraySerializer
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe ArraySerializer

Fonctions membres publiques statiques

static | toArray (ResponseInterface $response)
static | fromArray (array $serializedResponse)

Fonctions membres privées statiques

static getValueFromKey (array $data, string $key, string $message=null)

Description détaillée

Serialize or deserialize response messages to/from arrays.

This class provides functionality for serializing a ResponseInterface instance to an array, as well as the reverse operation of creating a Response instance from an array representing a message.

Documentation des fonctions membres

◆ fromArray()

static fromArray ( array $serializedResponse )
static

Deserialize a response array to a response instance.

Exceptions
Exception

Références Response\$reasonPhrase, Response\$statusCode, et DeserializationException\forResponseFromArray().

◆ getValueFromKey()

static getValueFromKey | ( | array | $data,
 |  | string | $key,
 |  | string | $message = null
 | ) |  |
staticprivate
Paramètres
array | $data
string | $key
string | $message
Renvoie
mixed
Exceptions
Exception

Références $data, $key, $message, et null.

◆ toArray()

static toArray ( ResponseInterface $response )
static

Serialize a response message to an array.

Références MessageInterface\getBody(), MessageInterface\getHeaders(), MessageInterface\getProtocolVersion(), ResponseInterface\getReasonPhrase(), et ResponseInterface\getStatusCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Response/ArraySerializer.php


Joomla CMS: Référence de la classe EmptyResponse

  • Laminas
  • Diactoros
  • Response
  • EmptyResponse
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe EmptyResponse
+ Graphe d'héritage de EmptyResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct (int $status=204, array $headers=[])
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Fonctions membres publiques statiques

static withHeaders (array $headers)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

A class representing empty HTTP responses.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $status = 204,
 |  | array | $headers = []
 | ) |  |

Create an empty response with the given status code.

Paramètres
int | $status | Status code for the response, if any.
array | $headers | Headers for the response, if any.

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ withHeaders()

static withHeaders ( array $headers )
static

Create an empty response with the given headers.

Paramètres
array $headers Headers for the response.
Renvoie
EmptyResponse
La documentation de cette classe a été générée à partir du fichier suivant :
  • EmptyResponse.php


Joomla CMS: Référence de la classe HtmlResponse

  • Laminas
  • Diactoros
  • Response
  • HtmlResponse
Fonctions membres publiques | Fonctions membres privées
Référence de la classe HtmlResponse
+ Graphe d'héritage de HtmlResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct ($html, int $status=200, array $headers=[])
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Fonctions membres privées

createBody ($html)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

HTML response.

Allows creating a response by passing an HTML string to the constructor; by default, sets a status code of 200 and sets the Content-Type header to text/html.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $html,
 |  | int | $status = 200,
 |  | array | $headers = []
 | ) |  |

Create an HTML response.

Produces an HTML response with a Content-Type of text/html and a default status of 200.

Paramètres
string | StreamInterface | $html | HTML or stream for the message body.
int | $status | Integer status code for the response; 200 by default.
array | $headers | Array of headers to use at initialization.
Exceptions
Exception

Références $html, Symfony\Contracts\Service\__construct(), et HtmlResponse\createBody().

Documentation des fonctions membres

◆ createBody()

createBody ( $html )
private

Create the message body.

Paramètres
string | StreamInterface $html
Exceptions
Exception

Références $html.

Référencé par HtmlResponse\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlResponse.php


Joomla CMS: Référence de la classe JsonResponse

  • Laminas
  • Diactoros
  • Response
  • JsonResponse
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe JsonResponse
+ Graphe d'héritage de JsonResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct ( $data, int $status=200, array $headers=[], int $encodingOptions=self::DEFAULT_JSON_FLAGS)
getPayload ()
withPayload ($data)
getEncodingOptions ()
withEncodingOptions (int $encodingOptions)
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Champs de données

const | DEFAULT_JSON_FLAGS = 79
- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Fonctions membres privées

createBodyFromJson (string $json)
jsonEncode ($data, int $encodingOptions)
setPayload ($data)
updateBodyFor (JsonResponse $toUpdate)

Attributs privés

$payload
$encodingOptions

Description détaillée

JSON response.

Allows creating a response by passing data to the constructor; by default, serializes the data to JSON, sets a status code of 200 and sets the Content-Type header to application/json.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $data,
 |  | int | $status = 200,
 |  | array | $headers = [],
 |  | int | $encodingOptions = self::DEFAULT_JSON_FLAGS
 | ) |  |

Create a JSON response with the given data.

Default JSON encoding is performed with the following options, which produces RFC4627-compliant JSON, capable of embedding into HTML.

  • JSON_HEX_TAG
  • JSON_HEX_APOS
  • JSON_HEX_AMP
  • JSON_HEX_QUOT
  • JSON_UNESCAPED_SLASHES
Paramètres
mixed | $data | Data to convert to JSON.
int | $status | Integer status code for the response; 200 by default.
array | $headers | Array of headers to use at initialization.
int | $encodingOptions | JSON encoding options to use.
Exceptions
Exception

Références $data, JsonResponse\$encodingOptions, Symfony\Contracts\Service\__construct(), JsonResponse\createBodyFromJson(), JsonResponse\jsonEncode(), et JsonResponse\setPayload().

Documentation des fonctions membres

◆ createBodyFromJson()

createBodyFromJson ( string $json )
private

Référencé par JsonResponse\__construct(), et JsonResponse\updateBodyFor().

◆ getEncodingOptions()

getEncodingOptions ( )

Références JsonResponse\$encodingOptions.

◆ getPayload()

getPayload ( )
Renvoie
mixed

Références JsonResponse\$payload.

◆ jsonEncode()

jsonEncode | ( |  | $data,
 |  | int | $encodingOptions
 | ) |  |
private

Encode the provided data to JSON.

Paramètres
mixed $data
Exceptions
Exception

Références $data, JsonResponse\$encodingOptions, et null.

Référencé par JsonResponse\__construct(), et JsonResponse\updateBodyFor().

◆ setPayload()

setPayload ( $data )
private
Paramètres
mixed $data

Références $data.

Référencé par JsonResponse\__construct().

◆ updateBodyFor()

updateBodyFor ( JsonResponse $toUpdate )
private

Update the response body for the given instance.

Paramètres
self $toUpdate Instance to update.
Renvoie
JsonResponse Returns a new instance with an updated body.

Références JsonResponse\createBodyFromJson(), JsonResponse\jsonEncode(), et MessageInterface\withBody().

Référencé par JsonResponse\withEncodingOptions(), et JsonResponse\withPayload().

◆ withEncodingOptions()

withEncodingOptions ( int $encodingOptions )

Références JsonResponse\$encodingOptions, $this, et JsonResponse\updateBodyFor().

◆ withPayload()

withPayload ( $data )
Paramètres
mixed $data

Références $data, $this, et JsonResponse\updateBodyFor().

Documentation des champs

◆ $encodingOptions

$encodingOptions
private

Référencé par JsonResponse\__construct(), JsonResponse\getEncodingOptions(), JsonResponse\jsonEncode(), et JsonResponse\withEncodingOptions().

◆ $payload

$payload
private

Référencé par JsonResponse\getPayload().

◆ DEFAULT_JSON_FLAGS

const DEFAULT_JSON_FLAGS = 79

Default flags for json_encode; value of:

JSON_HEX_TAG | JSON_HEX_APOS | JSON_HEX_AMP | JSON_HEX_QUOT | JSON_UNESCAPED_SLASHES

int

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/laminas/laminas-diactoros/src/Response/JsonResponse.php


Joomla CMS: Référence de la classe RedirectResponse

  • Laminas
  • Diactoros
  • Response
  • RedirectResponse
Fonctions membres publiques
Référence de la classe RedirectResponse
+ Graphe d'héritage de RedirectResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct ($uri, int $status=302, array $headers=[])
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

Produce a redirect response.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $uri,
 |  | int | $status = 302,
 |  | array | $headers = []
 | ) |  |

Create a redirect response.

Produces a redirect response with a Location header and the given status (302 by default).

Note: this method overwrites the location $headers value.

Paramètres
string | UriInterface | $uri | URI for the Location header.
int | $status | Integer status code for the redirect; 302 by default.
array | $headers | Array of headers to use at initialization.

Références Laminas\Diactoros\$uri, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RedirectResponse.php


Joomla CMS: Référence de la classe Serializer

  • Laminas
  • Diactoros
  • Response
  • Serializer
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Serializer
+ Graphe d'héritage de Serializer:
AbstractSerializer

Fonctions membres publiques statiques

static | fromString (string $message)
static | fromStream (StreamInterface $stream)
static | toString (ResponseInterface $response)

Fonctions membres privées statiques

static getStatusLine (StreamInterface $stream)

Membres hérités additionnels

- Champs de données hérités de AbstractSerializer
const | CR = "\r"
const | EOL = "\r\n"
const | LF = "\n"
- Fonctions membres protégées statiques hérités de AbstractSerializer
static | getLine (StreamInterface $stream)
static | splitStream (StreamInterface $stream)
static | serializeHeaders (array $headers)
static | filterHeader ($header)

Documentation des fonctions membres

◆ fromStream()

static fromStream ( StreamInterface $stream )
static

Parse a response from a stream.

Exceptions
Exception

Références Response\$reasonPhrase, Laminas\Diactoros\$stream, et $version.

◆ fromString()

static fromString ( string $message )
static

Deserialize a response string to a response instance.

Exceptions
Exception

Références $message, et Laminas\Diactoros\$stream.

◆ getStatusLine()

static getStatusLine ( StreamInterface $stream )
staticprivate

Retrieve the status line for the message.

Renvoie
array Array with three elements: 0 => version, 1 => status, 2 => reason
Exceptions
Exception

Références Laminas\Diactoros\$stream, et SerializationException\forInvalidStatusLine().

◆ toString()

static toString ( ResponseInterface $response )
static

Create a string representation of a response.

Références $format, Response\$reasonPhrase, MessageInterface\getBody(), MessageInterface\getHeaders(), MessageInterface\getProtocolVersion(), ResponseInterface\getReasonPhrase(), et ResponseInterface\getStatusCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Response/Serializer.php


Joomla CMS: Référence de la classe TextResponse

  • Laminas
  • Diactoros
  • Response
  • TextResponse
Fonctions membres publiques | Fonctions membres privées
Référence de la classe TextResponse
+ Graphe d'héritage de TextResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct ($text, int $status=200, array $headers=[])
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Fonctions membres privées

createBody ($text)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

Plain text response.

Allows creating a response by passing a string to the constructor; by default, sets a status code of 200 and sets the Content-Type header to text/plain.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $text,
 |  | int | $status = 200,
 |  | array | $headers = []
 | ) |  |

Create a plain text response.

Produces a text response with a Content-Type of text/plain and a default status of 200.

Paramètres
string | StreamInterface | $text | String or stream for the message body.
int | $status | Integer status code for the response; 200 by default.
array | $headers | Array of headers to use at initialization.
Exceptions
Exception

Références $text, Symfony\Contracts\Service\__construct(), et TextResponse\createBody().

Documentation des fonctions membres

◆ createBody()

createBody ( $text )
private

Create the message body.

Paramètres
string | StreamInterface $text
Exceptions
Exception

Références $text.

Référencé par TextResponse\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TextResponse.php


Joomla CMS: Référence de la classe XmlResponse

  • Laminas
  • Diactoros
  • Response
  • XmlResponse
Fonctions membres publiques | Fonctions membres privées
Référence de la classe XmlResponse
+ Graphe d'héritage de XmlResponse:
Response ResponseInterface MessageInterface

Fonctions membres publiques

__construct ( $xml, int $status=200, array $headers=[])
- Fonctions membres publiques hérités de Response
__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Fonctions membres privées

createBody ($xml)

Membres hérités additionnels

- Champs de données hérités de Response
const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Description détaillée

XML response.

Allows creating a response by passing an XML string to the constructor; by default, sets a status code of 200 and sets the Content-Type header to application/xml.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $xml,
 |  | int | $status = 200,
 |  | array | $headers = []
 | ) |  |

Create an XML response.

Produces an XML response with a Content-Type of application/xml and a default status of 200.

Paramètres
string | StreamInterface | $xml | String or stream for the message body.
int | $status | Integer status code for the response; 200 by default.
array | $headers | Array of headers to use at initialization.
Exceptions
Exception

Références $xml, Symfony\Contracts\Service\__construct(), et XmlResponse\createBody().

Documentation des fonctions membres

◆ createBody()

createBody ( $xml )
private

Create the message body.

Paramètres
string | StreamInterface $xml
Exceptions
Exception

Références $xml.

Référencé par XmlResponse\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlResponse.php


Joomla CMS: Référence de la classe AbstractSerializer

  • Laminas
  • Diactoros
  • AbstractSerializer
Champs de données | Fonctions membres protégées statiques
Référence de la classe AbstractSerializer
+ Graphe d'héritage de AbstractSerializer:
Serializer Serializer

Champs de données

const | CR = "\r"
const | EOL = "\r\n"
const | LF = "\n"

Fonctions membres protégées statiques

static | getLine (StreamInterface $stream)
static | splitStream (StreamInterface $stream)
static | serializeHeaders (array $headers)
static | filterHeader ($header)

Description détaillée

Provides base functionality for request and response de/serialization strategies, including functionality for retrieving a line at a time from the message, splitting headers from the body, and serializing headers.

Documentation des fonctions membres

◆ filterHeader()

static filterHeader ( $header )
staticprotected

Filter a header name to wordcase

Références $header.

◆ getLine()

static getLine ( StreamInterface $stream )
staticprotected

Retrieve a single line from the stream.

Retrieves a line from the stream; a line is defined as a sequence of characters ending in a CRLF sequence.

Exceptions
Exception

Références Laminas\Diactoros\$stream, DeserializationException\forUnexpectedCarriageReturn(), DeserializationException\forUnexpectedEndOfHeaders(), et DeserializationException\forUnexpectedLineFeed().

◆ serializeHeaders()

static serializeHeaders ( array $headers )
staticprotected

Serialize headers to string values.

Références $header, et $value.

◆ splitStream()

static splitStream ( StreamInterface $stream )
staticprotected

Split the stream into headers and body content.

Returns an array containing two elements

  • The first is an array of headers
  • The second is a StreamInterface containing the body content
Exceptions
Exception

Références Laminas\Diactoros\$stream, $value, DeserializationException\forInvalidHeader(), et DeserializationException\forInvalidHeaderContinuation().

Documentation des champs

◆ CR

const CR = "\r"

◆ EOL

const EOL = "\r\n"

◆ LF

const LF = "\n"
La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/AbstractSerializer.php


Joomla CMS: Référence de la classe CallbackStream

  • Laminas
  • Diactoros
  • CallbackStream
Fonctions membres publiques | Attributs protégés
Référence de la classe CallbackStream
+ Graphe d'héritage de CallbackStream:
StreamInterface

Fonctions membres publiques

__construct (callable $callback)
__toString ()
close ()
detach ()
attach (callable $callback)
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Attributs protégés

$callback

Description détaillée

Implementation of PSR HTTP streams

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( callable $callback )
Paramètres
callable $callback
Exceptions
Exception

Références CallbackStream\attach().

Documentation des fonctions membres

◆ __toString()

__toString ( )

{Reads all data from the stream into a string, from the beginning to end.This method MUST attempt to seek to the beginning of the stream before reading data and read the stream until the end is reached.Warning: This could attempt to load a large amount of data into memory.This method MUST NOT raise an exception in order to conform with PHP's string casting operations.

Voir également
http://php.net/manual/en/language.oop5.magic.php#object.tostring
Renvoie
string
}

Implémente StreamInterface.

Références CallbackStream\getContents().

◆ attach()

attach ( callable $callback )

Attach a new callback to the instance.

Références CallbackStream\$callback.

Référencé par CallbackStream\__construct().

◆ close()

close ( )

{Closes the stream and any underlying resources.

Renvoie
void
}

Implémente StreamInterface.

Références null.

◆ detach()

detach ( )

{Separates any underlying resources from the stream.After the stream has been detached, the stream is in an unusable state.

Renvoie
resource|null Underlying PHP stream, if any
}

Implémente StreamInterface.

Références CallbackStream\$callback, et null.

Référencé par CallbackStream\getContents().

◆ eof()

eof ( )

{Returns true if the stream is at the end of the stream.

Renvoie
bool
}

Implémente StreamInterface.

Référencé par CallbackStream\getMetadata().

◆ getContents()

getContents ( )

{Returns the remaining contents in a string

Renvoie
string
Exceptions
}

Implémente StreamInterface.

Références CallbackStream\$callback, et CallbackStream\detach().

Référencé par CallbackStream\__toString().

◆ getMetadata()

getMetadata ( $key = null )

{Get stream metadata as an associative array or retrieve a specific key.The keys returned are identical to the keys returned from PHP's stream_get_meta_data() function.string $key Specific metadata to retrieve. array|mixed|null Returns an associative array if no key is provided. Returns a specific key value if a key is provided and the value is found, or null if the key is not found.}

Implémente StreamInterface.

Références $key, CallbackStream\eof(), false, et null.

◆ getSize()

getSize ( )

{Get the size of the stream if known.

Renvoie
int|null Returns the size in bytes if known, or null if unknown.
}

Implémente StreamInterface.

Références null.

◆ isReadable()

isReadable ( )

{Returns whether or not the stream is readable.

Renvoie
bool
}

Implémente StreamInterface.

◆ isSeekable()

isSeekable ( )

{Returns whether or not the stream is seekable.

Renvoie
bool
}

Implémente StreamInterface.

◆ isWritable()

isWritable ( )

{Returns whether or not the stream is writable.

Renvoie
bool
}

Implémente StreamInterface.

◆ read()

read ( $length )

{Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions
}

Implémente StreamInterface.

Références UnreadableStreamException\forCallbackStream().

◆ rewind()

rewind ( )

{Seek to the beginning of the stream.If the stream is not seekable, this method will raise an exception; otherwise, it will perform a seek(0).

Voir également
seek() on failure.
}

Implémente StreamInterface.

Références UnrewindableStreamException\forCallbackStream().

◆ seek()

seek | ( | $offset,
 |  | $whence = SEEK_SET
 | ) |

{Seek to a position in the stream.int $offset Stream offset int $whence Specifies how the cursor position will be calculated based on the seek offset. Valid values are identical to the built-in PHP $whence values for fseek(). SEEK_SET: Set position equal to offset bytes SEEK_CUR: Set position to current location plus offset SEEK_END: Set position to end-of-stream plus offset. on failure.}

Implémente StreamInterface.

Références UnseekableStreamException\forCallbackStream().

◆ tell()

tell ( )

{Returns the current position of the file read/write pointer

Renvoie
int Position of the file pointer
Exceptions
}

Implémente StreamInterface.

Références UntellableStreamException\forCallbackStream().

◆ write()

write ( $string )

{Write data to the stream.

Paramètres
string $string The string that is to be written.
Renvoie
int Returns the number of bytes written to the stream.
Exceptions
}

Implémente StreamInterface.

Références UnwritableStreamException\forCallbackStream().

Documentation des champs

◆ $callback

$callback
protected

Référencé par CallbackStream\attach(), CallbackStream\detach(), et CallbackStream\getContents().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CallbackStream.php


Joomla CMS: Référence de la classe ConfigProvider

  • Laminas
  • Diactoros
  • ConfigProvider
Fonctions membres publiques
Référence de la classe ConfigProvider

Fonctions membres publiques

__invoke ()
getDependencies ()

Documentation des fonctions membres

◆ __invoke()

__invoke ( )

Retrieve configuration for laminas-diactoros.

Renvoie
array

Références ConfigProvider\getDependencies().

◆ getDependencies()

getDependencies ( )

Returns the container dependencies. Maps factory interfaces to factories.

Références class.

Référencé par ConfigProvider\__invoke().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigProvider.php


Joomla CMS: Référence de la classe HeaderSecurity

  • Laminas
  • Diactoros
  • HeaderSecurity
Fonctions membres publiques statiques | Fonctions membres privées
Référence de la classe HeaderSecurity

Fonctions membres publiques statiques

static | filter (string $value)
static | isValid ($value)
static | assertValid ($value)
static | assertValidName ($name)

Fonctions membres privées

__construct ()

Description détaillée

Provide security tools around HTTP headers to prevent common injection vectors.

Code is largely lifted from the Laminas implementation in Laminas, released with the copyright and license below.

Copyright
Copyright (c) 2005-2015 Laminas (https://www.zend.com) https://getlaminas.org/license/new-bsd New BSD License

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Private constructor; non-instantiable.

Documentation des fonctions membres

◆ assertValid()

static assertValid ( $value )
static

Assert a header value is valid.

Paramètres
mixed $value Value to be tested. This method asserts it is a string or number.
Exceptions
Exception

Références $value.

Référencé par Laminas\Diactoros\filterHeaderValue().

◆ assertValidName()

static assertValidName ( $name )
static

Assert whether or not a header name is valid.

Voir également
http://tools.ietf.org/html/rfc7230#section-3.2
Paramètres
mixed $name
Exceptions
Exception

Références $name.

Référencé par Laminas\Diactoros\assertHeader().

◆ filter()

static filter ( string $value )
static

Filter a header value

Ensures CRLF header injection vectors are filtered.

Per RFC 7230, only VISIBLE ASCII characters, spaces, and horizontal tabs are allowed in values; header continuations MUST consist of a single CRLF sequence followed by a space or horizontal tab.

This method filters any values not allowed from the string, and is lossy.

Voir également
http://en.wikipedia.org/wiki/HTTP_response_splitting

Références $i, et $value.

◆ isValid()

static isValid ( $value )
static

Validate a header value.

Per RFC 7230, only VISIBLE ASCII characters, spaces, and horizontal tabs are allowed in values; header continuations MUST consist of a single CRLF sequence followed by a space or horizontal tab.

Paramètres
string | int | float $value
Voir également
http://en.wikipedia.org/wiki/HTTP_response_splitting

Références $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HeaderSecurity.php


Joomla CMS: Référence de la classe Module

  • Laminas
  • Diactoros
  • Module
Fonctions membres publiques
Référence de la classe Module

Fonctions membres publiques

getConfig ()

Documentation des fonctions membres

◆ getConfig()

getConfig ( )
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/laminas/laminas-diactoros/src/Module.php


Joomla CMS: Référence de la classe PhpInputStream

  • Laminas
  • Diactoros
  • PhpInputStream
Fonctions membres publiques | Attributs privés
Référence de la classe PhpInputStream
+ Graphe d'héritage de PhpInputStream:
Stream StreamInterface

Fonctions membres publiques

__construct ($stream='php://input')
__toString ()
isWritable ()
read ($length)
getContents ($maxLength=-1)
- Fonctions membres publiques hérités de Stream
__construct ($stream, string $mode='r')
__toString ()
close ()
detach ()
attach ($resource, string $mode='r')
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Attributs privés

$cache = ''
$reachedEof = false

Membres hérités additionnels

- Attributs protégés hérités de Stream
$resource
$stream

Description détaillée

Caching version of php://input

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $stream = 'php://input' )
Paramètres
string | resource $stream

Références Stream\$stream, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

{Reads all data from the stream into a string, from the beginning to end.This method MUST attempt to seek to the beginning of the stream before reading data and read the stream until the end is reached.Warning: This could attempt to load a large amount of data into memory.This method MUST NOT raise an exception in order to conform with PHP's string casting operations.

Voir également
http://php.net/manual/en/language.oop5.magic.php#object.tostring
Renvoie
string
}

Implémente StreamInterface.

Références PhpInputStream\$cache, et Stream\getContents().

◆ getContents()

getContents ( $maxLength = -1 )

{}

Références PhpInputStream\$cache, et Stream\eof().

◆ isWritable()

isWritable ( )

{Returns whether or not the stream is writable.

Renvoie
bool
}

Implémente StreamInterface.

◆ read()

read ( $length )

{Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions
}

Implémente StreamInterface.

Références $content, et Stream\eof().

Documentation des champs

◆ $cache

$cache = ''
private

Référencé par PhpInputStream\__toString(), et PhpInputStream\getContents().

◆ $reachedEof

$reachedEof = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpInputStream.php


Joomla CMS: Référence de la classe RelativeStream

  • Laminas
  • Diactoros
  • RelativeStream
Fonctions membres publiques | Attributs privés
Référence de la classe RelativeStream
+ Graphe d'héritage de RelativeStream:
StreamInterface

Fonctions membres publiques

__construct (StreamInterface $decoratedStream, ?int $offset)
__toString ()
close ()
detach ()
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Attributs privés

$decoratedStream
$offset

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | StreamInterface | $decoratedStream,
 |  | ?int | $offset
 | ) |  |

Class constructor

Paramètres
StreamInterface | $decoratedStream
int | $offset

Références RelativeStream\$decoratedStream, RelativeStream\$offset, et Joomla\Database\Query\offset().

Documentation des fonctions membres

◆ __toString()

__toString ( )

{Reads all data from the stream into a string, from the beginning to end.This method MUST attempt to seek to the beginning of the stream before reading data and read the stream until the end is reached.Warning: This could attempt to load a large amount of data into memory.This method MUST NOT raise an exception in order to conform with PHP's string casting operations.

Voir également
http://php.net/manual/en/language.oop5.magic.php#object.tostring
Renvoie
string
}

Implémente StreamInterface.

Références RelativeStream\getContents(), RelativeStream\isSeekable(), et RelativeStream\seek().

◆ close()

close ( )

{Closes the stream and any underlying resources.

Renvoie
void
}

Implémente StreamInterface.

◆ detach()

detach ( )

{Separates any underlying resources from the stream.After the stream has been detached, the stream is in an unusable state.

Renvoie
resource|null Underlying PHP stream, if any
}

Implémente StreamInterface.

◆ eof()

eof ( )

{Returns true if the stream is at the end of the stream.

Renvoie
bool
}

Implémente StreamInterface.

◆ getContents()

getContents ( )

{Returns the remaining contents in a string

Renvoie
string
Exceptions
}

Implémente StreamInterface.

Références RelativeStream\tell().

Référencé par RelativeStream\__toString().

◆ getMetadata()

getMetadata ( $key = null )

{Get stream metadata as an associative array or retrieve a specific key.The keys returned are identical to the keys returned from PHP's stream_get_meta_data() function.string $key Specific metadata to retrieve. array|mixed|null Returns an associative array if no key is provided. Returns a specific key value if a key is provided and the value is found, or null if the key is not found.}

Implémente StreamInterface.

Références $key.

◆ getSize()

getSize ( )

{Get the size of the stream if known.

Renvoie
int|null Returns the size in bytes if known, or null if unknown.
}

Implémente StreamInterface.

Références RelativeStream\$offset.

◆ isReadable()

isReadable ( )

{Returns whether or not the stream is readable.

Renvoie
bool
}

Implémente StreamInterface.

◆ isSeekable()

isSeekable ( )

{Returns whether or not the stream is seekable.

Renvoie
bool
}

Implémente StreamInterface.

Référencé par RelativeStream\__toString().

◆ isWritable()

isWritable ( )

{Returns whether or not the stream is writable.

Renvoie
bool
}

Implémente StreamInterface.

◆ read()

read ( $length )

{Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions
}

Implémente StreamInterface.

Références RelativeStream\tell().

◆ rewind()

rewind ( )

{Seek to the beginning of the stream.If the stream is not seekable, this method will raise an exception; otherwise, it will perform a seek(0).

Voir également
seek() on failure.
}

Implémente StreamInterface.

Références RelativeStream\seek().

◆ seek()

seek | ( | $offset,
 |  | $whence = SEEK_SET
 | ) |

{Seek to a position in the stream.int $offset Stream offset int $whence Specifies how the cursor position will be calculated based on the seek offset. Valid values are identical to the built-in PHP $whence values for fseek(). SEEK_SET: Set position equal to offset bytes SEEK_CUR: Set position to current location plus offset SEEK_END: Set position to end-of-stream plus offset. on failure.}

Implémente StreamInterface.

Références RelativeStream\$offset, et Joomla\Database\Query\offset().

Référencé par RelativeStream\__toString(), et RelativeStream\rewind().

◆ tell()

tell ( )

{Returns the current position of the file read/write pointer

Renvoie
int Position of the file pointer
Exceptions
}

Implémente StreamInterface.

Références RelativeStream\$offset.

Référencé par RelativeStream\getContents(), RelativeStream\read(), et RelativeStream\write().

◆ write()

write ( $string )

{Write data to the stream.

Paramètres
string $string The string that is to be written.
Renvoie
int Returns the number of bytes written to the stream.
Exceptions
}

Implémente StreamInterface.

Références RelativeStream\tell().

Documentation des champs

◆ $decoratedStream

$decoratedStream
private

Référencé par RelativeStream\__construct().

◆ $offset

$offset
private

Référencé par RelativeStream\__construct(), RelativeStream\getSize(), RelativeStream\seek(), et RelativeStream\tell().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RelativeStream.php


Joomla CMS: Référence de la classe Request

  • Laminas
  • Diactoros
  • Request
Fonctions membres publiques
Référence de la classe Request
+ Graphe d'héritage de Request:
RequestInterface MessageInterface

Fonctions membres publiques

__construct ($uri=null, string $method=null, $body='php://temp', array $headers=[])
getHeaders ()
getHeader ($header)
- Fonctions membres publiques hérités de RequestInterface
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
hasHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

HTTP Request encapsulation

Requests are considered immutable; all methods that might change state are implemented such that they retain the internal state of the current message and return a new instance that contains the changed state.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $uri = null,
 |  | string | $method = null,
 |  |  | $body = 'php://temp',
 |  | array | $headers = []
 | ) |  |
Paramètres
null | string | UriInterface | $uri | URI for the request, if any.
null | string | $method | HTTP method for the request, if any.
string | resource | StreamInterface | $body | Message body, if any.
array | $headers | Headers for the message, if any.
Exceptions
Exception

Références Laminas\Diactoros\$method, Laminas\Diactoros\$uri, et Laminas\Diactoros\initialize().

Documentation des fonctions membres

◆ getHeader()

getHeader ( $header )

{Retrieves a message header value by the given case-insensitive name.This method returns an array of all the header values of the given case-insensitive header name.If the header does not appear in the message, this method MUST return an empty array.

Paramètres
string $name Case-insensitive header field name.
Renvoie
string[] An array of string values as provided for the given header. If the header does not appear in the message, this method MUST return an empty array.
}

Implémente MessageInterface.

Références $header, Laminas\Diactoros\getHostFromUri(), et MessageInterface\hasHeader().

◆ getHeaders()

getHeaders ( )

{Retrieves all message header values.The keys represent the header name as it will be sent over the wire, and each value is an array of strings associated with the header.

// Represent the headers as a string
foreach ($message->getHeaders() as $name => $values) {
    echo $name . ": " . implode(", ", $values);
}

// Emit headers iteratively:
foreach ($message->getHeaders() as $name => $values) {
    foreach ($values as $value) {
        header(sprintf('%s: %s', $name, $value), false);
    }
}
While header names are not case-sensitive, getHeaders() will preserve the exact case in which headers were originally specified.
Renvoie
string[][] Returns an associative array of the message's headers. Each key MUST be a header name, and each value MUST be an array of strings for that header.
}

Implémente MessageInterface.

Références Laminas\Diactoros\getHostFromUri(), et MessageInterface\hasHeader().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/Request.php


Joomla CMS: Référence de la classe RequestFactory

  • Laminas
  • Diactoros
  • RequestFactory
Fonctions membres publiques
Référence de la classe RequestFactory
+ Graphe d'héritage de RequestFactory:
RequestFactoryInterface

Fonctions membres publiques

createRequest (string $method, $uri)

Documentation des fonctions membres

◆ createRequest()

createRequest | ( | string | $method,
 |  |  | $uri
 | ) |  |

Create a new request.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
Renvoie
RequestInterface

Implémente RequestFactoryInterface.

Références Laminas\Diactoros\$method, et Laminas\Diactoros\$uri.

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/RequestFactory.php


Joomla CMS: Référence de la classe Response

  • Laminas
  • Diactoros
  • Response
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Response
+ Graphe d'héritage de Response:
ResponseInterface MessageInterface Response EmptyResponse HtmlResponse JsonResponse RedirectResponse TextResponse XmlResponse Response

Fonctions membres publiques

__construct ($body='php://memory', int $status=200, array $headers=[])
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Champs de données

const | MIN_STATUS_CODE_VALUE = 100
const | MAX_STATUS_CODE_VALUE = 599

Fonctions membres privées

setStatusCode ($code, $reasonPhrase='')

Attributs privés

$phrases
$reasonPhrase
$statusCode

Description détaillée

HTTP response encapsulation.

Responses are considered immutable; all methods that might change state are implemented such that they retain the internal state of the current message and return a new instance that contains the changed state.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $body = 'php://memory',
 |  | int | $status = 200,
 |  | array | $headers = []
 | ) |  |
Paramètres
string | resource | StreamInterface | $body | Stream identifier and/or actual stream resource
int | $status | Status code for the response, if any.
array | $headers | Headers for the response, if any.
Exceptions
Exception

Références Laminas\Diactoros\getStream(), Laminas\Diactoros\setHeaders(), et Response\setStatusCode().

Documentation des fonctions membres

◆ getReasonPhrase()

getReasonPhrase ( )

{Gets the response reason phrase associated with the status code.Because a reason phrase is not a required element in a response status line, the reason phrase value MAY be null. Implementations MAY choose to return the default RFC 7231 recommended reason phrase (or those listed in the IANA HTTP Status Code Registry) for the response's status code. http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml string Reason phrase; must return an empty string if none present.}

Implémente ResponseInterface.

Références Response\$reasonPhrase.

◆ getStatusCode()

getStatusCode ( )

{Gets the response status code.The status code is a 3-digit integer result code of the server's attempt to understand and satisfy the request.

Renvoie
int Status code.
}

Implémente ResponseInterface.

Références Response\$statusCode.

Référencé par Response\__get().

◆ setStatusCode()

setStatusCode | ( | $code,
 |  | $reasonPhrase = ''
 | ) |
private

Set a valid status code.

Paramètres
int | $code
string | $reasonPhrase
Exceptions
Exception

Références Response\$reasonPhrase.

Référencé par Response\__construct().

◆ withStatus()

withStatus | ( | $code,
 |  | $reasonPhrase = ''
 | ) |

{Return an instance with the specified status code and, optionally, reason phrase.If no reason phrase is specified, implementations MAY choose to default to the RFC 7231 or IANA recommended reason phrase for the response's status code.This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated status and reason phrase. http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml int $code The 3-digit integer result code to set. string $reasonPhrase The reason phrase to use with the provided status code; if none is provided, implementations MAY use the defaults as suggested in the HTTP specification. static For invalid status code arguments.}

Implémente ResponseInterface.

Références Response\$reasonPhrase, et $this.

Documentation des champs

◆ $phrases

$phrases
private
Valeur initiale :
= [
100 => 'Continue'

◆ $reasonPhrase

$reasonPhrase
private

Référencé par ArraySerializer\fromArray(), Serializer\fromStream(), Response\getReasonPhrase(), Response\setStatusCode(), Serializer\toString(), et Response\withStatus().

◆ $statusCode

$statusCode
private

Référencé par ArraySerializer\fromArray(), et Response\getStatusCode().

◆ MAX_STATUS_CODE_VALUE

const MAX_STATUS_CODE_VALUE = 599

◆ MIN_STATUS_CODE_VALUE

const MIN_STATUS_CODE_VALUE = 100
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/laminas/laminas-diactoros/src/Response.php


Joomla CMS: Référence de la classe ResponseFactory

  • Laminas
  • Diactoros
  • ResponseFactory
Fonctions membres publiques
Référence de la classe ResponseFactory
+ Graphe d'héritage de ResponseFactory:
ResponseFactoryInterface

Fonctions membres publiques

createResponse (int $code=200, string $reasonPhrase='')

Documentation des fonctions membres

◆ createResponse()

createResponse | ( | int | $code = 200,
 |  | string | $reasonPhrase = ''
 | ) |  |

Create a new response.

Paramètres
int | $code | HTTP status code; defaults to 200
string | $reasonPhrase | Reason phrase to associate with status code in generated response; if none is provided implementations MAY use the defaults as suggested in the HTTP specification.
Renvoie
ResponseInterface

Implémente ResponseFactoryInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/ResponseFactory.php


Joomla CMS: Référence de la classe ServerRequest

  • Laminas
  • Diactoros
  • ServerRequest
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ServerRequest
+ Graphe d'héritage de ServerRequest:
ServerRequestInterface RequestInterface MessageInterface

Fonctions membres publiques

__construct (array $serverParams=[], array $uploadedFiles=[], $uri=null, string $method=null, $body='php://input', array $headers=[], array $cookies=[], array $queryParams=[], $parsedBody=null, string $protocol='1.1')
getServerParams ()
getUploadedFiles ()
withUploadedFiles (array $uploadedFiles)
getCookieParams ()
withCookieParams (array $cookies)
getQueryParams ()
withQueryParams (array $query)
getParsedBody ()
withParsedBody ($data)
getAttributes ()
getAttribute ($attribute, $default=null)
withAttribute ($attribute, $value)
withoutAttribute ($attribute)
- Fonctions membres publiques hérités de RequestInterface
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Fonctions membres privées

validateUploadedFiles (array $uploadedFiles)

Attributs privés

$attributes = []
$cookieParams = []
$parsedBody
$queryParams = []
$serverParams
$uploadedFiles

Description détaillée

Server-side HTTP request

Extends the Request definition to add methods for accessing incoming data, specifically server parameters, cookies, matched path parameters, query string arguments, body parameters, and upload file information.

"Attributes" are discovered via decomposing the request (and usually specifically the URI path), and typically will be injected by the application.

Requests are considered immutable; all methods that might change state are implemented such that they retain the internal state of the current message and return a new instance that contains the changed state.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $serverParams = [],
 |  | array | $uploadedFiles = [],
 |  |  | $uri = null,
 |  | string | $method = null,
 |  |  | $body = 'php://input',
 |  | array | $headers = [],
 |  | array | $cookies = [],
 |  | array | $queryParams = [],
 |  |  | $parsedBody = null,
 |  | string | $protocol = '1.1'
 | ) |  |
Paramètres
array | $serverParams | Server parameters, typically from $_SERVER
array | $uploadedFiles | Upload file information, a tree of UploadedFiles
null | string | UriInterface | $uri | URI for the request, if any.
null | string | $method | HTTP method for the request, if any.
string | resource | StreamInterface | $body | Message body, if any.
array | $headers | Headers for the message, if any.
array | $cookies | Cookies for the message, if any.
array | $queryParams | Query params for the message, if any.
null | array | object | $parsedBody | The deserialized body parameters, if any.
string | $protocol | HTTP protocol version.
Exceptions
Exception

Références Laminas\Diactoros\$method, ServerRequest\$parsedBody, Laminas\Diactoros\$protocol, ServerRequest\$queryParams, ServerRequest\$serverParams, ServerRequest\$uploadedFiles, Laminas\Diactoros\$uri, Laminas\Diactoros\initialize(), et ServerRequest\validateUploadedFiles().

Documentation des fonctions membres

◆ getAttribute()

getAttribute | ( | $attribute,
 |  | $default = null
 | ) |

{Retrieve a single derived request attribute.Retrieves a single derived request attribute as described in getAttributes(). If the attribute has not been previously set, returns the default value as provided.This method obviates the need for a hasAttribute() method, as it allows specifying a default value to return if the attribute is not found.

Voir également
getAttributes()
Paramètres
string | $name | The attribute name.
mixed | $default | Default value to return if the attribute does not exist.
Renvoie
mixed
}

Implémente ServerRequestInterface.

Références $default.

◆ getAttributes()

getAttributes ( )

{Retrieve attributes derived from the request.The request "attributes" may be used to allow injection of any parameters derived from the request: e.g., the results of path match operations; the results of decrypting cookies; the results of deserializing non-form-encoded message bodies; etc. Attributes will be application and request specific, and CAN be mutable.

Renvoie
array Attributes derived from the request.
}

Implémente ServerRequestInterface.

Références ServerRequest\$attributes.

◆ getCookieParams()

getCookieParams ( )

{Retrieve cookies.Retrieves cookies sent by the client to the server.The data MUST be compatible with the structure of the $_COOKIE superglobal.

Renvoie
array
}

Implémente ServerRequestInterface.

Références ServerRequest\$cookieParams.

◆ getParsedBody()

getParsedBody ( )

{Retrieve any parameters provided in the request body.If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, this method MUST return the contents of $_POST.Otherwise, this method may return any results of deserializing the request body content; as parsing returns structured content, the potential types MUST be arrays or objects only. A null value indicates the absence of body content.

Renvoie
null|array|object The deserialized body parameters, if any. These will typically be an array or object.
}

Implémente ServerRequestInterface.

Références ServerRequest\$parsedBody.

◆ getQueryParams()

getQueryParams ( )

{Retrieve query string arguments.Retrieves the deserialized query string arguments, if any.Note: the query params might not be in sync with the URI or server params. If you need to ensure you are only getting the original values, you may need to parse the query string from getUri()->getQuery() or from the QUERY_STRING server param.

Renvoie
array
}

Implémente ServerRequestInterface.

Références ServerRequest\$queryParams.

◆ getServerParams()

getServerParams ( )

{Retrieve server parameters.Retrieves data related to the incoming request environment, typically derived from PHP's $_SERVER superglobal. The data IS NOT REQUIRED to originate from $_SERVER.

Renvoie
array
}

Implémente ServerRequestInterface.

Références ServerRequest\$serverParams.

◆ getUploadedFiles()

getUploadedFiles ( )

{Retrieve normalized file upload data.This method returns upload metadata in a normalized tree, with each leaf an instance of Psr.These values MAY be prepared from $_FILES or the message body during instantiation, or MAY be injected via withUploadedFiles().

Renvoie
array An array tree of UploadedFileInterface instances; an empty array MUST be returned if no data is present.
}

Implémente ServerRequestInterface.

Références ServerRequest\$uploadedFiles.

◆ validateUploadedFiles()

validateUploadedFiles ( array $uploadedFiles )
private

Recursively validate the structure in an uploaded files array.

Exceptions
Exception

Références ServerRequest\$uploadedFiles.

Référencé par ServerRequest\__construct(), et ServerRequest\withUploadedFiles().

◆ withAttribute()

withAttribute | ( | $attribute,
 |  | $value
 | ) |

{Return an instance with the specified derived request attribute.This method allows setting a single derived request attribute as described in getAttributes().This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated attribute.

Voir également
getAttributes()
Paramètres
string | $name | The attribute name.
mixed | $value | The value of the attribute.
Renvoie
static
}

Implémente ServerRequestInterface.

Références $this, et $value.

◆ withCookieParams()

withCookieParams ( array $cookies )

{Return an instance with the specified cookies.The data IS NOT REQUIRED to come from the $_COOKIE superglobal, but MUST be compatible with the structure of $_COOKIE. Typically, this data will be injected at instantiation.This method MUST NOT update the related Cookie header of the request instance, nor related values in the server params.This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated cookie values.

Paramètres
array $cookies Array of key/value pairs representing cookies.
Renvoie
static
}

Implémente ServerRequestInterface.

Références $this.

◆ withoutAttribute()

withoutAttribute ( $attribute )

{Return an instance that removes the specified derived request attribute.This method allows removing a single derived request attribute as described in getAttributes().This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that removes the attribute.

Voir également
getAttributes()
Paramètres
string $name The attribute name.
Renvoie
static
}

Implémente ServerRequestInterface.

Références $this.

◆ withParsedBody()

withParsedBody ( $data )

{Return an instance with the specified body parameters.These MAY be injected during instantiation.If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, use this method ONLY to inject the contents of $_POST.The data IS NOT REQUIRED to come from $_POST, but MUST be the results of deserializing the request body content. Deserialization/parsing returns structured data, and, as such, this method ONLY accepts arrays or objects, or a null value if nothing was available to parse.As an example, if content negotiation determines that the request data is a JSON payload, this method could be used to create a request instance with the deserialized parameters.This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
null | array | object $data The deserialized body data. This will typically be in an array or object.
Renvoie
static
Exceptions
}

Implémente ServerRequestInterface.

Références $data, $this, et null.

◆ withQueryParams()

withQueryParams ( array $query )

{Return an instance with the specified query string arguments.These values SHOULD remain immutable over the course of the incoming request. They MAY be injected during instantiation, such as from PHP's $_GET superglobal, or MAY be derived from some other value such as the URI. In cases where the arguments are parsed from the URI, the data MUST be compatible with what PHP's parse_str() would return for purposes of how duplicate query parameters are handled, and how nested sets are handled.Setting query string arguments MUST NOT change the URI stored by the request, nor the values in the server params.This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated query string arguments.

Paramètres
array $query Array of query string arguments, typically from $_GET.
Renvoie
static
}

Implémente ServerRequestInterface.

Références $query, et $this.

◆ withUploadedFiles()

withUploadedFiles ( array $uploadedFiles )

{Create a new instance with the specified uploaded files.This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
array $uploadedFiles An array tree of UploadedFileInterface instances.
Renvoie
static
Exceptions
}

Implémente ServerRequestInterface.

Références $this, ServerRequest\$uploadedFiles, et ServerRequest\validateUploadedFiles().

Documentation des champs

◆ $attributes

$attributes = []
private

Référencé par ServerRequest\getAttributes().

◆ $cookieParams

$cookieParams = []
private

Référencé par ServerRequest\getCookieParams().

◆ $parsedBody

$parsedBody
private

Référencé par ServerRequest\__construct(), et ServerRequest\getParsedBody().

◆ $queryParams

$queryParams = []
private

Référencé par ServerRequest\__construct(), et ServerRequest\getQueryParams().

◆ $serverParams

$serverParams
private

Référencé par ServerRequest\__construct(), et ServerRequest\getServerParams().

◆ $uploadedFiles

$uploadedFiles
private

Référencé par ServerRequest\__construct(), ServerRequest\getUploadedFiles(), ServerRequest\validateUploadedFiles(), et ServerRequest\withUploadedFiles().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/ServerRequest.php


Joomla CMS: Référence de la classe ServerRequestFactory

  • Laminas
  • Diactoros
  • ServerRequestFactory
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés statiques
Référence de la classe ServerRequestFactory
+ Graphe d'héritage de ServerRequestFactory:
ServerRequestFactoryInterface

Fonctions membres publiques

createServerRequest (string $method, $uri, array $serverParams=[])

Fonctions membres publiques statiques

static fromGlobals (array $server=null, array $query=null, array $body=null, array $cookies=null, array $files=null)

Attributs privés statiques

static $apacheRequestHeaders = 'apache_request_headers'

Description détaillée

Class for marshaling a request object from the current PHP environment.

Logic largely refactored from the Laminas Laminas class.

Copyright
Copyright (c) 2005-2015 Laminas (https://www.zend.com) https://getlaminas.org/license/new-bsd New BSD License

Documentation des fonctions membres

◆ createServerRequest()

createServerRequest | ( | string | $method,
 |  |  | $uri,
 |  | array | $serverParams = []
 | ) |  |

Create a new server request.Note that server-params are taken precisely as given - no parsing/processing of the given values is performed, and, in particular, no attempt is made to determine the HTTP method or URI, which must be provided explicitly.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
array | $serverParams | Array of SAPI parameters with which to seed the generated request instance.
Renvoie
ServerRequestInterface

Implémente ServerRequestFactoryInterface.

Références Laminas\Diactoros\$method, et Laminas\Diactoros\$uri.

◆ fromGlobals()

static fromGlobals | ( | array | $server = null,
 |  | array | $query = null,
 |  | array | $body = null,
 |  | array | $cookies = null,
 |  | array | $files = null
 | ) |  |
static

Create a request from the supplied superglobal values.

If any argument is not supplied, the corresponding superglobal value will be used.

The ServerRequest created is then passed to the fromServer() method in order to marshal the request URI and headers.

Voir également
fromServer()
Paramètres
array | $server | $_SERVER superglobal
array | $query | $_GET superglobal
array | $body | $_POST superglobal
array | $cookies | $_COOKIE superglobal
array | $files | $_FILES superglobal
Renvoie
ServerRequest

Références $query, Laminas\Diactoros\marshalHeadersFromSapi(), Laminas\Diactoros\marshalMethodFromSapi(), Laminas\Diactoros\marshalProtocolVersionFromSapi(), Laminas\Diactoros\marshalUriFromSapi(), Laminas\Diactoros\normalizeServer(), Laminas\Diactoros\normalizeUploadedFiles(), null, et Laminas\Diactoros\parseCookieHeader().

Référencé par Authentication\validateAssertionResponse(), et Credentials\verifyAttestation().

Documentation des champs

◆ $apacheRequestHeaders

$apacheRequestHeaders = 'apache_request_headers'
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • ServerRequestFactory.php


Joomla CMS: Référence de la classe Stream

  • Laminas
  • Diactoros
  • Stream
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Stream
+ Graphe d'héritage de Stream:
StreamInterface PhpInputStream

Fonctions membres publiques

__construct ($stream, string $mode='r')
__toString ()
close ()
detach ()
attach ($resource, string $mode='r')
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Attributs protégés

$resource
$stream

Fonctions membres privées

setStream ($stream, string $mode='r')
isValidStreamResourceType ($resource)

Attributs privés

const ALLOWED_STREAM_RESOURCE_TYPES = ['gd', 'stream']

Description détaillée

Implementation of PSR HTTP streams

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $stream,
 |  | string | $mode = 'r'
 | ) |  |
Paramètres
string | resource | $stream
string | $mode | Mode with which to open stream
Exceptions
Exception

Références $mode, Stream\$stream, et Stream\setStream().

Documentation des fonctions membres

◆ __toString()

__toString ( )

{Reads all data from the stream into a string, from the beginning to end.This method MUST attempt to seek to the beginning of the stream before reading data and read the stream until the end is reached.Warning: This could attempt to load a large amount of data into memory.This method MUST NOT raise an exception in order to conform with PHP's string casting operations.

Voir également
http://php.net/manual/en/language.oop5.magic.php#object.tostring
Renvoie
string
}

Implémente StreamInterface.

Références Stream\getContents(), Stream\isReadable(), Stream\isSeekable(), et Stream\rewind().

◆ attach()

attach | ( |  | $resource,
 |  | string | $mode = 'r'
 | ) |  |

Attach a new stream/resource to the instance.

Paramètres
string | resource | $resource
string | $mode
Exceptions
Exception

Références $mode, Stream\$resource, et Stream\setStream().

◆ close()

close ( )

{Closes the stream and any underlying resources.

Renvoie
void
}

Implémente StreamInterface.

Références Stream\$resource, et Stream\detach().

◆ detach()

detach ( )

{Separates any underlying resources from the stream.After the stream has been detached, the stream is in an unusable state.

Renvoie
resource|null Underlying PHP stream, if any
}

Implémente StreamInterface.

Références Stream\$resource, et null.

Référencé par Stream\close().

◆ eof()

eof ( )

{Returns true if the stream is at the end of the stream.

Renvoie
bool
}

Implémente StreamInterface.

Référencé par PhpInputStream\getContents(), et PhpInputStream\read().

◆ getContents()

getContents ( )

{Returns the remaining contents in a string

Renvoie
string
Exceptions
}

Implémente StreamInterface.

Références $result, UnreadableStreamException\dueToConfiguration(), UnreadableStreamException\dueToPhpError(), et Stream\isReadable().

Référencé par PhpInputStream\__toString(), et Stream\__toString().

◆ getMetadata()

getMetadata ( $key = null )

{Get stream metadata as an associative array or retrieve a specific key.The keys returned are identical to the keys returned from PHP's stream_get_meta_data() function.string $key Specific metadata to retrieve. array|mixed|null Returns an associative array if no key is provided. Returns a specific key value if a key is provided and the value is found, or null if the key is not found.}

Implémente StreamInterface.

Références $key, et null.

◆ getSize()

getSize ( )

{Get the size of the stream if known.

Renvoie
int|null Returns the size in bytes if known, or null if unknown.
}

Implémente StreamInterface.

Références null.

◆ isReadable()

isReadable ( )

{Returns whether or not the stream is readable.

Renvoie
bool
}

Implémente StreamInterface.

Références $mode.

Référencé par Stream\__toString(), Stream\getContents(), et Stream\read().

◆ isSeekable()

isSeekable ( )

{Returns whether or not the stream is seekable.

Renvoie
bool
}

Implémente StreamInterface.

Référencé par Stream\__toString(), et Stream\seek().

◆ isValidStreamResourceType()

isValidStreamResourceType ( $resource )
private

Determine if a resource is one of the resource types allowed to instantiate a Stream

Paramètres
resource $resource Stream resource.

Références Stream\$resource.

Référencé par Stream\setStream().

◆ isWritable()

isWritable ( )

{Returns whether or not the stream is writable.

Renvoie
bool
}

Implémente StreamInterface.

Références $mode.

Référencé par Stream\write().

◆ read()

read ( $length )

{Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions
}

Implémente StreamInterface.

Références $result, UnreadableStreamException\dueToConfiguration(), UnreadableStreamException\dueToMissingResource(), UnreadableStreamException\dueToPhpError(), et Stream\isReadable().

◆ rewind()

rewind ( )

{Seek to the beginning of the stream.If the stream is not seekable, this method will raise an exception; otherwise, it will perform a seek(0).

Voir également
seek() on failure.
}

Implémente StreamInterface.

Références Stream\seek().

Référencé par Stream\__toString().

◆ seek()

seek | ( | $offset,
 |  | $whence = SEEK_SET
 | ) |

{Seek to a position in the stream.int $offset Stream offset int $whence Specifies how the cursor position will be calculated based on the seek offset. Valid values are identical to the built-in PHP $whence values for fseek(). SEEK_SET: Set position equal to offset bytes SEEK_CUR: Set position to current location plus offset SEEK_END: Set position to end-of-stream plus offset. on failure.}

Implémente StreamInterface.

Références Joomla\Database\Query\$offset, $result, UnseekableStreamException\dueToConfiguration(), UnseekableStreamException\dueToMissingResource(), UnseekableStreamException\dueToPhpError(), et Stream\isSeekable().

Référencé par Stream\rewind().

◆ setStream()

setStream | ( |  | $stream,
 |  | string | $mode = 'r'
 | ) |  |
private

Set the internal stream resource.

Paramètres
string | resource | $stream | String stream target or stream resource.
string | $mode | Resource mode for stream target.
Exceptions
Exception

Références $mode, Stream\$resource, Stream\$stream, Stream\isValidStreamResourceType(), et null.

Référencé par Stream\__construct(), et Stream\attach().

◆ tell()

tell ( )

{Returns the current position of the file read/write pointer

Renvoie
int Position of the file pointer
Exceptions
}

Implémente StreamInterface.

Références $result, UntellableStreamException\dueToMissingResource(), et UntellableStreamException\dueToPhpError().

◆ write()

write ( $string )

{Write data to the stream.

Paramètres
string $string The string that is to be written.
Renvoie
int Returns the number of bytes written to the stream.
Exceptions
}

Implémente StreamInterface.

Références $result, UnwritableStreamException\dueToConfiguration(), UnwritableStreamException\dueToMissingResource(), UnwritableStreamException\dueToPhpError(), et Stream\isWritable().

Documentation des champs

◆ $resource

$resource
protected

Référencé par Stream\attach(), Stream\close(), Stream\detach(), Stream\isValidStreamResourceType(), et Stream\setStream().

◆ $stream

$stream
protected

Référencé par PhpInputStream\__construct(), Stream\__construct(), et Stream\setStream().

◆ ALLOWED_STREAM_RESOURCE_TYPES

const ALLOWED_STREAM_RESOURCE_TYPES = ['gd', 'stream']
private

A list of allowed stream resource types that are allowed to instantiate a Stream

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/laminas/laminas-diactoros/src/Stream.php


Joomla CMS: Référence de la classe StreamFactory

  • Laminas
  • Diactoros
  • StreamFactory
Fonctions membres publiques
Référence de la classe StreamFactory
+ Graphe d'héritage de StreamFactory:
StreamFactoryInterface

Fonctions membres publiques

createStream (string $content='')
createStreamFromFile (string $file, string $mode='r')
createStreamFromResource ($resource)

Documentation des fonctions membres

◆ createStream()

createStream ( string $content = '' )

Create a new stream from a string.The stream SHOULD be created with a temporary resource.

Paramètres
string $content String content with which to populate the stream.
Renvoie
StreamInterface

Implémente StreamFactoryInterface.

Références $content, et StreamFactory\createStreamFromResource().

◆ createStreamFromFile()

createStreamFromFile | ( | string | $file,
 |  | string | $mode = 'r'
 | ) |  |

Create a stream from an existing file.The file MUST be opened using the given mode, which may be any mode supported by the fopen function.The $filename MAY be any string supported by fopen().

Paramètres
string | $filename | Filename or stream URI to use as basis of stream.
string | $mode | Mode with which to open the underlying filename/stream.
Renvoie
StreamInterface
Exceptions

Implémente StreamFactoryInterface.

Références $mode.

◆ createStreamFromResource()

createStreamFromResource ( $resource )

Create a new stream from an existing resource.The stream MUST be readable and may be writable.

Paramètres
resource $resource PHP resource to use as basis of stream.
Renvoie
StreamInterface

Implémente StreamFactoryInterface.

Référencé par StreamFactory\createStream().

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/StreamFactory.php


Joomla CMS: Référence de la classe UploadedFile

  • Laminas
  • Diactoros
  • UploadedFile
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe UploadedFile
+ Graphe d'héritage de UploadedFile:
UploadedFileInterface

Fonctions membres publiques

__construct ( $streamOrFile, int $size, int $errorStatus, string $clientFilename=null, string $clientMediaType=null)
getStream ()
moveTo ($targetPath)
getSize ()
getError ()
getClientFilename ()
getClientMediaType ()

Champs de données

const | ERROR_MESSAGES
const | UPLOAD_ERR_INI_SIZE

Fonctions membres privées

writeFile (string $path)

Attributs privés

$clientFilename
$clientMediaType
$error
$file
$moved = false
$size
$stream

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $streamOrFile,
 |  | int | $size,
 |  | int | $errorStatus,
 |  | string | $clientFilename = null,
 |  | string | $clientMediaType = null
 | ) |  |
Paramètres
string | resource | $streamOrFile
int | $size
int | $errorStatus
string | null | $clientFilename
string | null | $clientMediaType
Exceptions
Exception

Références UploadedFile\$clientFilename, UploadedFile\$clientMediaType, et UploadedFile\$size.

Documentation des fonctions membres

◆ getClientFilename()

getClientFilename ( )

{Retrieve the filename sent by the client.Do not trust the value returned by this method. A client could send a malicious filename with the intention to corrupt or hack your application.Implementations SHOULD return the value stored in the "name" key of the file in the $_FILES array.

Renvoie
string|null The filename sent by the client or null if none was provided.
}

Renvoie
string|null The filename sent by the client or null if none was provided.

Implémente UploadedFileInterface.

Références UploadedFile\$clientFilename.

◆ getClientMediaType()

getClientMediaType ( )

{Retrieve the media type sent by the client.Do not trust the value returned by this method. A client could send a malicious media type with the intention to corrupt or hack your application.Implementations SHOULD return the value stored in the "type" key of the file in the $_FILES array.

Renvoie
string|null The media type sent by the client or null if none was provided.
}

Implémente UploadedFileInterface.

Références UploadedFile\$clientMediaType.

◆ getError()

getError ( )

{Retrieve the error associated with the uploaded file.The return value MUST be one of PHP's UPLOAD_ERR_XXX constants.If the file was uploaded successfully, this method MUST return UPLOAD_ERR_OK.Implementations SHOULD return the value stored in the "error" key of the file in the $_FILES array.

Voir également
http://php.net/manual/en/features.file-upload.errors.php
Renvoie
int One of PHP's UPLOAD_ERR_XXX constants.
}

Voir également
http://php.net/manual/en/features.file-upload.errors.php
Renvoie
int One of PHP's UPLOAD_ERR_XXX constants.

Implémente UploadedFileInterface.

Références UploadedFile\$error.

◆ getSize()

getSize ( )

{Retrieve the file size.Implementations SHOULD return the value stored in the "size" key of the file in the $_FILES array if available, as PHP calculates this based on the actual size transmitted.

Renvoie
int|null The file size in bytes or null if unknown.
}

Renvoie
int|null The file size in bytes or null if unknown.

Implémente UploadedFileInterface.

Références UploadedFile\$size.

◆ getStream()

getStream ( )

{Retrieve a stream representing the uploaded file.This method MUST return a StreamInterface instance, representing the uploaded file. The purpose of this method is to allow utilizing native PHP stream functionality to manipulate the file upload, such as stream_copy_to_stream() (though the result will need to be decorated in a native PHP stream wrapper to work with such functions).If the moveTo() method has been called previously, this method MUST raise an exception.

Renvoie
StreamInterface Stream representation of the uploaded file.
Exceptions
}

Exceptions
Exception

Implémente UploadedFileInterface.

Références UploadedFile\$stream, et UploadedFileErrorException\dueToStreamUploadError().

Référencé par UploadedFile\writeFile().

◆ moveTo()

moveTo ( $targetPath )

{Move the uploaded file to a new location.Use this method as an alternative to move_uploaded_file(). This method is guaranteed to work in both SAPI and non-SAPI environments. Implementations must determine which environment they are in, and use the appropriate method (move_uploaded_file(), rename(), or a stream operation) to perform the operation.$targetPath may be an absolute path, or a relative path. If it is a relative path, resolution should be the same as used by PHP's rename() function.The original file or stream MUST be removed on completion.If this method is called more than once, any subsequent calls MUST raise an exception.When used in an SAPI environment where $_FILES is populated, when writing files via moveTo(), is_uploaded_file() and move_uploaded_file() SHOULD be used to ensure permissions and upload status are verified correctly.If you wish to move to a stream, use getStream(), as SAPI operations cannot guarantee writing to stream destinations.

Voir également
http://php.net/is_uploaded_file
http://php.net/move_uploaded_file
Paramètres
string $targetPath Path to which to move the uploaded file.
Exceptions
}

Voir également
http://php.net/is_uploaded_file
http://php.net/move_uploaded_file
Paramètres
string $targetPath Path to which to move the uploaded file.
Exceptions
Exception

Implémente UploadedFileInterface.

Références UploadedFileErrorException\dueToStreamUploadError(), UploadedFileErrorException\dueToUnwritableTarget(), UploadedFileErrorException\forUnmovableFile(), et UploadedFile\writeFile().

◆ writeFile()

writeFile ( string $path )
private

Write internal stream to given path

Paramètres
string $path

Références $path, UploadedFile\$stream, UploadedFileErrorException\dueToUnwritablePath(), et UploadedFile\getStream().

Référencé par UploadedFile\moveTo().

Documentation des champs

◆ $clientFilename

$clientFilename
private

Référencé par UploadedFile\__construct(), et UploadedFile\getClientFilename().

◆ $clientMediaType

$clientMediaType
private

Référencé par UploadedFile\__construct(), et UploadedFile\getClientMediaType().

◆ $error

$error
private

Référencé par UploadedFile\getError().

◆ $file

$file
private

◆ $moved

$moved = false
private

◆ $size

$size
private

Référencé par UploadedFile\__construct(), et UploadedFile\getSize().

◆ $stream

$stream
private

Référencé par UploadedFile\getStream(), et UploadedFile\writeFile().

◆ ERROR_MESSAGES

const ERROR_MESSAGES
Valeur initiale :
= [
UPLOAD_ERR_OK => 'There is no error, the file uploaded with success'

◆ UPLOAD_ERR_INI_SIZE

const UPLOAD_ERR_INI_SIZE
Valeur initiale :
=> 'The uploaded file exceeds the upload_max_filesize directive in php.ini',
UPLOAD_ERR_FORM_SIZE => 'The uploaded file exceeds the MAX_FILE_SIZE directive that was '
. 'specified in the HTML form',
UPLOAD_ERR_PARTIAL => 'The uploaded file was only partially uploaded',
UPLOAD_ERR_NO_FILE => 'No file was uploaded',
UPLOAD_ERR_NO_TMP_DIR => 'Missing a temporary folder',
UPLOAD_ERR_CANT_WRITE => 'Failed to write file to disk',
UPLOAD_ERR_EXTENSION => 'A PHP extension stopped the file upload.',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/UploadedFile.php


Joomla CMS: Référence de la classe UploadedFileFactory

  • Laminas
  • Diactoros
  • UploadedFileFactory
Fonctions membres publiques
Référence de la classe UploadedFileFactory
+ Graphe d'héritage de UploadedFileFactory:
UploadedFileFactoryInterface

Fonctions membres publiques

createUploadedFile (StreamInterface $stream, int $size=null, int $error=UPLOAD_ERR_OK, string $clientFilename=null, string $clientMediaType=null)

Documentation des fonctions membres

◆ createUploadedFile()

createUploadedFile | ( | StreamInterface | $stream,
 |  | int | $size = null,
 |  | int | $error = UPLOAD_ERR_OK,
 |  | string | $clientFilename = null,
 |  | string | $clientMediaType = null
 | ) |  |

Create a new uploaded file.If a size is not provided it will be determined by checking the size of the file.

Voir également
http://php.net/manual/features.file-upload.post-method.php
http://php.net/manual/features.file-upload.errors.php
Paramètres
StreamInterface | $stream | Underlying stream representing the uploaded file content.
int | $size | in bytes
int | $error | PHP file upload error
string | $clientFilename | Filename as provided by the client, if any.
string | $clientMediaType | Media type as provided by the client, if any.
Renvoie
UploadedFileInterface
Exceptions

Implémente UploadedFileFactoryInterface.

Références $size, Laminas\Diactoros\$stream, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UploadedFileFactory.php


Joomla CMS: Référence de la classe Uri

  • Laminas
  • Diactoros
  • Uri
Fonctions membres publiques | Champs de données | Attributs protégés | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe Uri
+ Graphe d'héritage de Uri:
UriInterface

Fonctions membres publiques

__construct (string $uri='')
__clone ()
__toString ()
getScheme ()
getAuthority ()
getUserInfo ()
getHost ()
getPort ()
getPath ()
getQuery ()
getFragment ()
withScheme ($scheme)
withUserInfo ($user, $password=null)
withHost ($host)
withPort ($port)
withPath ($path)
withQuery ($query)
withFragment ($fragment)

Champs de données

const | CHAR_SUB_DELIMS = '!\$&\'\(\)\*\+,;='
const | CHAR_UNRESERVED = 'a-zA-Z0-9_\-\.~\pL'

Attributs protégés

$allowedSchemes

Fonctions membres privées

parseUri (string $uri)
isNonStandardPort (string $scheme, string $host, ?int $port)
filterScheme (string $scheme)
filterUserInfoPart (string $part)
filterPath (string $path)
filterInvalidUtf8 (string $string)
filterQuery (string $query)
splitQueryValue (string $value)
filterFragment (string $fragment)
filterQueryOrFragment (string $value)
urlEncodeChar (array $matches)

Fonctions membres privées statiques

static createUriString (string $scheme, string $authority, string $path, string $query, string $fragment)

Attributs privés

$scheme = ''
$userInfo = ''
$host = ''
$port
$path = ''
$query = ''
$fragment = ''
$uriString

Description détaillée

Implementation of Psr.

Provides a value object representing a URI for HTTP requests.

Instances of this class are considered immutable; all methods that might change state are implemented such that they retain the internal state of the current instance and return a new instance that contains the changed state.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $uri = '' )

Références Laminas\Diactoros\$uri, et Uri\parseUri().

Documentation des fonctions membres

◆ __clone()

__clone ( )

Operations to perform on clone.

Since cloning usually is for purposes of mutation, we reset the $uriString property so it will be re-calculated.

Références null.

◆ __toString()

__toString ( )

{Return the string representation as a URI reference.Depending on which components of the URI are present, the resulting string is either a full URI or relative reference according to RFC 3986, Section 4.1. The method concatenates the various components of the URI, using the appropriate delimiters:

  • If a scheme is present, it MUST be suffixed by ":".
  • If an authority is present, it MUST be prefixed by "//".
  • The path can be concatenated without delimiters. But there are two cases where the path has to be adjusted to make the URI reference valid as PHP does not allow to throw an exception in __toString():
    • If the path is rootless and an authority is present, the path MUST be prefixed by "/".
    • If the path is starting with more than one "/" and no authority is present, the starting slashes MUST be reduced to one.
  • If a query is present, it MUST be prefixed by "?".
  • If a fragment is present, it MUST be prefixed by "#".
Voir également
http://tools.ietf.org/html/rfc3986#section-4.1
Renvoie
string
}

Implémente UriInterface.

Références Uri\$uriString, Uri\getAuthority(), Uri\getPath(), et null.

◆ createUriString()

static createUriString | ( | string | $scheme,
 |  | string | $authority,
 |  | string | $path,
 |  | string | $query,
 |  | string | $fragment
 | ) |  |
staticprivate

Create a URI string from its various parts

Références Uri\$fragment, Uri\$path, Uri\$query, Uri\$scheme, et Laminas\Diactoros\$uri.

◆ filterFragment()

filterFragment ( string $fragment )
private

Filter a fragment value to ensure it is properly encoded.

Références Uri\$fragment, et Uri\filterQueryOrFragment().

Référencé par Uri\parseUri(), et Uri\withFragment().

◆ filterInvalidUtf8()

filterInvalidUtf8 ( string $string )
private

Encode invalid UTF-8 characters in given string. All other characters are unchanged.

Références $i, et Uri\urlEncodeChar().

Référencé par Uri\filterPath(), Uri\filterQueryOrFragment(), et Uri\filterUserInfoPart().

◆ filterPath()

filterPath ( string $path )
private

Filters the path of a URI to ensure it is properly encoded.

Références Uri\$path, $this, et Uri\filterInvalidUtf8().

Référencé par Uri\parseUri(), et Uri\withPath().

◆ filterQuery()

filterQuery ( string $query )
private

Filter a query string to ensure it is propertly encoded.

Ensures that the values in the query string are properly urlencoded.

Références $key, $parts, Uri\$query, $value, Uri\filterQueryOrFragment(), null, et Uri\splitQueryValue().

Référencé par Uri\parseUri(), et Uri\withQuery().

◆ filterQueryOrFragment()

filterQueryOrFragment ( string $value )
private

Filter a query string key or value, or a fragment.

Références $this, $value, et Uri\filterInvalidUtf8().

Référencé par Uri\filterFragment(), et Uri\filterQuery().

◆ filterScheme()

filterScheme ( string $scheme )
private

Filters the scheme to ensure it is a valid scheme.

Paramètres
string $scheme Scheme name.
Renvoie
string Filtered scheme.

Références Uri\$scheme.

Référencé par Uri\parseUri(), et Uri\withScheme().

◆ filterUserInfoPart()

filterUserInfoPart ( string $part )
private

Filters a part of user info in a URI to ensure it is properly encoded.

Paramètres
string $part
Renvoie
string

Références $this, et Uri\filterInvalidUtf8().

Référencé par Uri\parseUri(), et Uri\withUserInfo().

◆ getAuthority()

getAuthority ( )

{Retrieve the authority component of the URI.If no authority information is present, this method MUST return an empty string.The authority syntax of the URI is:

[user-info@]host[:port]
If the port component is not set or is the standard port for the current scheme, it SHOULD NOT be included.
Voir également
https://tools.ietf.org/html/rfc3986#section-3.2
Renvoie
string The URI authority, in "[user-info@]host[:port]" format.
}

Implémente UriInterface.

Références Uri\$host, Uri\$port, et Uri\isNonStandardPort().

Référencé par Uri\__toString().

◆ getFragment()

getFragment ( )

{Retrieve the fragment component of the URI.If no fragment is present, this method MUST return an empty string.The leading "#" character is not part of the fragment and MUST NOT be added.The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.5.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.5
Renvoie
string The URI fragment.
}

Implémente UriInterface.

Références Uri\$fragment.

◆ getHost()

getHost ( )

{Retrieve the host component of the URI.If no host is present, this method MUST return an empty string.The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.2.2.

Voir également
http://tools.ietf.org/html/rfc3986#section-3.2.2
Renvoie
string The URI host.
}

Implémente UriInterface.

Références Uri\$host.

◆ getPath()

getPath ( )

{Retrieve the path component of the URI.The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.Normally, the empty path "" and absolute path "/" are considered equal as defined in RFC 7230 Section 2.7.3. But this method MUST NOT automatically do this normalization because in contexts with a trimmed base path, e.g. the front controller, this difference becomes significant. It's the task of the user to handle both "" and "/".The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.3.As an example, if the value should include a slash ("/") not intended as delimiter between path segments, that value MUST be passed in encoded form (e.g., "%2F") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.3
Renvoie
string The URI path.
}

Implémente UriInterface.

Références Uri\$path.

Référencé par Uri\__toString().

◆ getPort()

getPort ( )

{Retrieve the port component of the URI.If a port is present, and it is non-standard for the current scheme, this method MUST return it as an integer. If the port is the standard port used with the current scheme, this method SHOULD return null.If no port is present, and no scheme is present, this method MUST return a null value.If no port is present, but a scheme is present, this method MAY return the standard port for that scheme, but SHOULD return null.

Renvoie
null|int The URI port.
}

Implémente UriInterface.

Références Uri\isNonStandardPort(), et null.

◆ getQuery()

getQuery ( )

{Retrieve the query string of the URI.If no query string is present, this method MUST return an empty string.The leading "?" character is not part of the query and MUST NOT be added.The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.4.As an example, if a value in a key/value pair of the query string should include an ampersand ("&") not intended as a delimiter between values, that value MUST be passed in encoded form (e.g., "%26") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.4
Renvoie
string The URI query string.
}

Implémente UriInterface.

Références Uri\$query.

◆ getScheme()

getScheme ( )

{Retrieve the scheme component of the URI.If no scheme is present, this method MUST return an empty string.The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.1.The trailing ":" character is not part of the scheme and MUST NOT be added.

Voir également
https://tools.ietf.org/html/rfc3986#section-3.1
Renvoie
string The URI scheme.
}

Implémente UriInterface.

Références Uri\$scheme.

◆ getUserInfo()

getUserInfo ( )

Retrieve the user-info part of the URI.

This value is percent-encoded, per RFC 3986 Section 3.2.1.

{Retrieve the user information component of the URI.If no user information is present, this method MUST return an empty string.If a user is present in the URI, this will return that value; additionally, if the password is also present, it will be appended to the user value, with a colon (":") separating the values.The trailing "@" character is not part of the user information and MUST NOT be added.

Renvoie
string The URI user information, in "username[:password]" format.
}

Implémente UriInterface.

Références Uri\$userInfo.

◆ isNonStandardPort()

isNonStandardPort | ( | string | $scheme,
 |  | string | $host,
 |  | ?int | $port
 | ) |  |
private

Is a given port non-standard for the current scheme?

Références Uri\$host, Uri\$port, Uri\$scheme, et null.

Référencé par Uri\getAuthority(), et Uri\getPort().

◆ parseUri()

parseUri ( string $uri )
private

Parse a URI into its parts, and set the properties

Références $parts, Laminas\Diactoros\$uri, Uri\filterFragment(), Uri\filterPath(), Uri\filterQuery(), Uri\filterScheme(), Uri\filterUserInfoPart(), null, et path.

Référencé par Uri\__construct().

◆ splitQueryValue()

splitQueryValue ( string $value )
private

Split a query value into a key/value tuple.

Paramètres
string $value
Renvoie
array A value with exactly two elements, key and value

Références $data, $value, et null.

Référencé par Uri\filterQuery().

◆ urlEncodeChar()

urlEncodeChar ( array $matches )
private

URL encode a character returned by a regex.

Référencé par Uri\filterInvalidUtf8().

◆ withFragment()

withFragment ( $fragment )

{Return an instance with the specified URI fragment.This method MUST retain the state of the current instance, and return an instance that contains the specified URI fragment.Users can provide both encoded and decoded fragment characters. Implementations ensure the correct encoding as outlined in getFragment().An empty fragment value is equivalent to removing the fragment.

Paramètres
string $fragment The fragment to use with the new instance.
Renvoie
static A new instance with the specified fragment.
}

Implémente UriInterface.

Références Uri\$fragment, $this, et Uri\filterFragment().

◆ withHost()

withHost ( $host )

{Return an instance with the specified host.This method MUST retain the state of the current instance, and return an instance that contains the specified host.An empty host value is equivalent to removing the host.

Paramètres
string $host The hostname to use with the new instance.
Renvoie
static A new instance with the specified host.
Exceptions
}

Implémente UriInterface.

Références Uri\$host, et $this.

◆ withPath()

withPath ( $path )

{Return an instance with the specified path.This method MUST retain the state of the current instance, and return an instance that contains the specified path.The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.If the path is intended to be domain-relative rather than path relative then it must begin with a slash ("/"). Paths not starting with a slash ("/") are assumed to be relative to some base path known to the application or consumer.Users can provide both encoded and decoded path characters. Implementations ensure the correct encoding as outlined in getPath().

Paramètres
string $path The path to use with the new instance.
Renvoie
static A new instance with the specified path.
Exceptions
}

Implémente UriInterface.

Références Uri\$path, $this, Uri\filterPath(), et path.

◆ withPort()

withPort ( $port )

{Return an instance with the specified port.This method MUST retain the state of the current instance, and return an instance that contains the specified port.Implementations MUST raise an exception for ports outside the established TCP and UDP port ranges.A null value provided for the port is equivalent to removing the port information.

Paramètres
null | int $port The port to use with the new instance; a null value removes the port information.
Renvoie
static A new instance with the specified port.
Exceptions
}

Implémente UriInterface.

Références Uri\$port, $this, et null.

◆ withQuery()

withQuery ( $query )

{Return an instance with the specified query string.This method MUST retain the state of the current instance, and return an instance that contains the specified query string.Users can provide both encoded and decoded query characters. Implementations ensure the correct encoding as outlined in getQuery().An empty query string value is equivalent to removing the query string.

Paramètres
string $query The query string to use with the new instance.
Renvoie
static A new instance with the specified query string.
Exceptions
}

Implémente UriInterface.

Références Uri\$query, $this, et Uri\filterQuery().

◆ withScheme()

withScheme ( $scheme )

{Return an instance with the specified scheme.This method MUST retain the state of the current instance, and return an instance that contains the specified scheme.Implementations MUST support the schemes "http" and "https" case insensitively, and MAY accommodate other schemes if required.An empty scheme is equivalent to removing the scheme.

Paramètres
string $scheme The scheme to use with the new instance.
Renvoie
static A new instance with the specified scheme.
Exceptions
}

Implémente UriInterface.

Références Uri\$scheme, $this, et Uri\filterScheme().

◆ withUserInfo()

withUserInfo | ( | $user,
 |  | $password = null
 | ) |

Create and return a new instance containing the provided user credentials.

The value will be percent-encoded in the new instance, but with measures taken to prevent double-encoding.

{Return an instance with the specified user information.This method MUST retain the state of the current instance, and return an instance that contains the specified user information.Password is optional, but the user information MUST include the user; an empty string for the user is equivalent to removing user information.

Paramètres
string | $user | The user name to use for authority.
null | string | $password | The password associated with $user.
Renvoie
static A new instance with the specified user information.
}

Implémente UriInterface.

Références $info, $password, $this, $user, Uri\filterUserInfoPart(), et null.

Documentation des champs

◆ $allowedSchemes

$allowedSchemes
protected
Valeur initiale :
= [
'http' => 80

◆ $fragment

$fragment = ''
private

Référencé par Uri\createUriString(), Uri\filterFragment(), Uri\getFragment(), et Uri\withFragment().

◆ $host

$host = ''
private

Référencé par Uri\getAuthority(), Uri\getHost(), Uri\isNonStandardPort(), et Uri\withHost().

◆ $path

$path = ''
private

Référencé par Uri\createUriString(), Uri\filterPath(), Uri\getPath(), et Uri\withPath().

◆ $port

$port
private

Référencé par Uri\getAuthority(), Uri\isNonStandardPort(), et Uri\withPort().

◆ $query

$query = ''
private

Référencé par Uri\createUriString(), Uri\filterQuery(), Uri\getQuery(), et Uri\withQuery().

◆ $scheme

$scheme = ''
private

Référencé par Uri\createUriString(), Uri\filterScheme(), Uri\getScheme(), Uri\isNonStandardPort(), et Uri\withScheme().

◆ $uriString

$uriString
private

Référencé par Uri\__toString().

◆ $userInfo

$userInfo = ''
private

Référencé par Uri\getUserInfo().

◆ CHAR_SUB_DELIMS

const CHAR_SUB_DELIMS = '!\$&\'\(\)\*\+,;='

Sub-delimiters used in user info, query strings and fragments.

string

◆ CHAR_UNRESERVED

const CHAR_UNRESERVED = 'a-zA-Z0-9_\-\.~\pL'

Unreserved characters used in user info, paths, query strings, and fragments.

string

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/laminas/laminas-diactoros/src/Uri.php


Joomla CMS: Référence de la classe UriFactory

  • Laminas
  • Diactoros
  • UriFactory
Fonctions membres publiques
Référence de la classe UriFactory
+ Graphe d'héritage de UriFactory:
UriFactoryInterface

Fonctions membres publiques

createUri (string $uri='')

Documentation des fonctions membres

◆ createUri()

createUri ( string $uri = '' )

Create a new URI.

Paramètres
string $uri
Renvoie
UriInterface
Exceptions

Implémente UriFactoryInterface.

Références Laminas\Diactoros\$uri.

La documentation de cette classe a été générée à partir du fichier suivant :
  • laminas/laminas-diactoros/src/UriFactory.php


Joomla CMS: Référence de la classe Autoloader

  • Laminas
  • ZendFrameworkBridge
  • Autoloader
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Autoloader

Fonctions membres publiques statiques

static load ()

Fonctions membres privées statiques

static | getClassLoader ()
static | createPrependAutoloader (array $namespaces, ClassLoader $classLoader, ArrayObject $loaded)
static | createAppendAutoloader (array $namespaces, ArrayObject $loaded)

Description détaillée

Alias legacy Zend Framework project classes/interfaces/traits to Laminas equivalents.

Documentation des fonctions membres

◆ createAppendAutoloader()

static createAppendAutoloader | ( | array | $namespaces,
 |  | ArrayObject | $loaded
 | ) |  |
staticprivate
Renvoie
callable
Paramètres
string $class Class name to autoload
Renvoie
void

Références $check, $class, et $i.

◆ createPrependAutoloader()

static createPrependAutoloader | ( | array | $namespaces,
 |  | ClassLoader | $classLoader,
 |  | ArrayObject | $loaded
 | ) |  |
staticprivate
Renvoie
callable
Paramètres
string $class Class name to autoload
Renvoie
void

Références $check, $class, $i, et ClassLoader\loadClass().

◆ getClassLoader()

static getClassLoader ( )
staticprivate
Renvoie
ClassLoader
Exceptions
RuntimeException

Références __DIR__.

◆ load()

static load ( )
static

Attach autoloaders for managing legacy ZF artifacts.

We attach two autoloaders:

  • The first is prepended to handle new classes and add aliases for legacy classes. PHP expects any interfaces implemented, classes extended, or traits used when declaring class_alias() to exist and/or be autoloadable already at the time of declaration. If not, it will raise a fatal error. This autoloader helps mitigate errors in such situations.
  • The second is appended in order to create aliases for legacy classes.

Références RewriteRules\namespaceReverse(), et RewriteRules\namespaceRewrite().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Autoloader.php


Joomla CMS: Référence de la classe ConfigPostProcessor

  • Laminas
  • ZendFrameworkBridge
  • ConfigPostProcessor
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe ConfigPostProcessor

Fonctions membres publiques

__construct ()
__invoke (array $config, array $keys=[])

Fonctions membres publiques statiques

static merge (array $a, array $b)

Champs de données

const SERVICE_MANAGER_KEYS_OF_INTEREST

Fonctions membres privées

replace ($value, array $keys, $key=null)
replacementRuleMatch ($value, $key=null)
fallbackReplacement ($value)
replaceExactValue ($value)
replaceDependencyConfiguration (array $config)
replaceDependencyAliases (array $aliases)
replaceDependencyInvokables (array $config)
noopReplacement ($value)
replaceDependencyFactories (array $config)
replaceDependencyServices (array $config)

Attributs privés

$exactReplacements
$replacements
$rulesets

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références $key, $this, $value, et null.

Documentation des fonctions membres

◆ __invoke()

__invoke | ( | array | $config,
 |  | array | $keys = []
 | ) |  |
Paramètres
string[] $keys Hierarchy of keys, for determining location in nested configuration.
Renvoie
array

Références $config, $key, $value, null, et ConfigPostProcessor\replace().

Référencé par ConfigPostProcessor\replaceDependencyConfiguration(), et ConfigPostProcessor\replaceDependencyServices().

◆ fallbackReplacement()

fallbackReplacement ( $value )
private

Replace a value using the translation table, if the value is a string.

Paramètres
mixed $value
Renvoie
mixed

Références $value.

◆ merge()

static merge | ( | array | $a,
 |  | array | $b
 | ) |  |
static

Merge two arrays together.

If an integer key exists in both arrays, the value from the second array will be appended to the first array. If both values are arrays, they are merged together, else the value of the second array overwrites the one of the first array.

Based on zend-stdlib Zend::merge

Copyright
Copyright (c) 2005-2015 Zend Technologies USA Inc. (http://www.zend.com)
Renvoie
array

Références $b, $key, $value, et null.

◆ noopReplacement()

noopReplacement ( $value )
private
Paramètres
mixed $value
Renvoie
mixed Returns $value verbatim.

Références $value.

◆ replace()

replace | ( |  | $value,
 |  | array | $keys,
 |  |  | $key = null
 | ) |  |
private

Perform substitutions as needed on an individual value.

The $key is provided to allow fine-grained selection of rewrite rules.

Paramètres
mixed | $value
string[] | $keys Key hierarchy
null | int | string | $key
Renvoie
mixed

Références $key, $value, et ConfigPostProcessor\replacementRuleMatch().

Référencé par ConfigPostProcessor\__invoke().

◆ replaceDependencyAliases()

replaceDependencyAliases ( array $aliases )
private

Rewrite dependency aliases array

In this case, we want to keep the alias as-is, but rewrite the target.

We need also provide an additional alias if the alias key is a legacy class.

Renvoie
array

Références $name, et $target.

Référencé par ConfigPostProcessor\replaceDependencyConfiguration().

◆ replaceDependencyConfiguration()

replaceDependencyConfiguration ( array $config )
private

Références $config, $data, $key, ConfigPostProcessor\__invoke(), ConfigPostProcessor\replaceDependencyAliases(), ConfigPostProcessor\replaceDependencyFactories(), ConfigPostProcessor\replaceDependencyInvokables(), et ConfigPostProcessor\replaceDependencyServices().

◆ replaceDependencyFactories()

replaceDependencyFactories ( array $config )
private

Références $config.

Référencé par ConfigPostProcessor\replaceDependencyConfiguration().

◆ replaceDependencyInvokables()

replaceDependencyInvokables ( array $config )
private

Rewrite dependency invokables array

In this case, we want to keep the alias as-is, but rewrite the target.

We need also provide an additional alias if invokable is defined with an alias which is a legacy class.

Renvoie
array

Références $config, et $target.

Référencé par ConfigPostProcessor\replaceDependencyConfiguration().

◆ replaceDependencyServices()

replaceDependencyServices ( array $config )
private

Références $config, et ConfigPostProcessor\__invoke().

Référencé par ConfigPostProcessor\replaceDependencyConfiguration().

◆ replaceExactValue()

replaceExactValue ( $value )
private

Replace a value matched exactly.

Paramètres
mixed $value
Renvoie
mixed

Références $value.

◆ replacementRuleMatch()

replacementRuleMatch | ( | $value,
 |  | $key = null
 | ) |
private
Paramètres
mixed | $value
null | int | string | $key
Renvoie
callable Callable to invoke with value

Références $key, $result, $this, et $value.

Référencé par ConfigPostProcessor\replace().

Documentation des champs

◆ $exactReplacements

$exactReplacements
private
Valeur initiale :
= [
'zend-expressive' => 'mezzio'

◆ $replacements

$replacements
private

◆ $rulesets

$rulesets
private

◆ SERVICE_MANAGER_KEYS_OF_INTEREST

const SERVICE_MANAGER_KEYS_OF_INTEREST
Valeur initiale :
= [
'aliases' => true
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfigPostProcessor.php


Joomla CMS: Référence de la classe Module

  • Laminas
  • ZendFrameworkBridge
  • Module
Fonctions membres publiques
Référence de la classe Module

Fonctions membres publiques

init ($moduleManager)

Documentation des fonctions membres

◆ init()

init ( $moduleManager )

Initialize the module.

Type-hinting deliberately omitted to allow unit testing without dependencies on packages that do not exist yet.

Paramètres
ModuleManager $moduleManager

Références $this.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/laminas/laminas-zendframework-bridge/src/Module.php


Joomla CMS: Référence de la classe Replacements

  • Laminas
  • ZendFrameworkBridge
  • Replacements
Fonctions membres publiques | Attributs privés
Référence de la classe Replacements

Fonctions membres publiques

__construct (array $additionalReplacements=[])
replace ($value)

Attributs privés

$replacements

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $additionalReplacements = [] )

Références __DIR__.

Documentation des fonctions membres

◆ replace()

replace ( $value )
Paramètres
string $value
Renvoie
string

Références $value.

Documentation des champs

◆ $replacements

$replacements
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Replacements.php


Joomla CMS: Référence de la classe RewriteRules

  • Laminas
  • ZendFrameworkBridge
  • RewriteRules
Fonctions membres publiques statiques
Référence de la classe RewriteRules

Fonctions membres publiques statiques

static | namespaceRewrite ()
static | namespaceReverse ()

Documentation des fonctions membres

◆ namespaceReverse()

static namespaceReverse ( )
static
Renvoie
array

Référencé par Autoloader\load().

◆ namespaceRewrite()

static namespaceRewrite ( )
static
Renvoie
array

Référencé par Autoloader\load().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RewriteRules.php


Joomla CMS: Référence de la classe Basic

  • Lcobucci
  • JWT
  • Claim
  • Basic
Fonctions membres publiques | Attributs privés
Référence de la classe Basic
+ Graphe d'héritage de Basic:
Claim EqualsTo GreaterOrEqualsTo LesserOrEqualsTo

Fonctions membres publiques

__construct ($name, $value)
getName ()
getValue ()
jsonSerialize ()
__toString ()

Attributs privés

$name
$value

Description détaillée

The default claim

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $name,
 |  | $value
 | ) |

Initializes the claim

Paramètres
string | $name
mixed | $value

Références Basic\$name, Basic\$value, name, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

{Returns the string representation of the claim

Renvoie
string
}

Implémente Claim.

Références Basic\$value.

◆ getName()

getName ( )

{Returns the claim name

Renvoie
string
}

Implémente Claim.

Références Basic\$name.

Référencé par EqualsTo\validate(), LesserOrEqualsTo\validate(), et GreaterOrEqualsTo\validate().

◆ getValue()

getValue ( )

{Returns the claim value

Renvoie
mixed
}

Implémente Claim.

Références Basic\$value.

Référencé par EqualsTo\validate(), LesserOrEqualsTo\validate(), et GreaterOrEqualsTo\validate().

◆ jsonSerialize()

jsonSerialize ( )

{}

Références Basic\$value.

Documentation des champs

◆ $name

$name
private

Référencé par Basic\__construct(), et Basic\getName().

◆ $value

$value
private

Référencé par Basic\__construct(), Basic\__toString(), Basic\getValue(), et Basic\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/lcobucci/jwt/src/Claim/Basic.php


Joomla CMS: Référence de la classe EqualsTo

  • Lcobucci
  • JWT
  • Claim
  • EqualsTo
Fonctions membres publiques
Référence de la classe EqualsTo
+ Graphe d'héritage de EqualsTo:
Basic Claim Validatable Claim

Fonctions membres publiques

validate (ValidationData $data)
- Fonctions membres publiques hérités de Basic
__construct ($name, $value)
getName ()
getValue ()
jsonSerialize ()
__toString ()

Description détaillée

Validatable claim that checks if value is strictly equals to the given data

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des fonctions membres

◆ validate()

validate ( ValidationData $data )

{Returns if claim is valid according with given data

Paramètres
ValidationData $data
Renvoie
boolean
}

Implémente Validatable.

Références $data, $this, ValidationData\get(), Basic\getName(), et Basic\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EqualsTo.php


Joomla CMS: Référence de la classe Factory

  • Lcobucci
  • JWT
  • Claim
  • Factory
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Factory

Fonctions membres publiques

__construct (array $callbacks=[])
create ($name, $value)

Fonctions membres privées

createGreaterOrEqualsTo ($name, $value)
createLesserOrEqualsTo ($name, $value)
createEqualsTo ($name, $value)
createBasic ($name, $value)

Attributs privés

$callbacks

Description détaillée

Class that create claims

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $callbacks = [] )

Initializes the factory, registering the default callbacks

Paramètres
array $callbacks

Références Factory\$callbacks, et $this.

Documentation des fonctions membres

◆ create()

create | ( | $name,
 |  | $value
 | ) |

Create a new claim

Paramètres
string | $name
mixed | $value
Renvoie
Claim

Références $name, $value, RegisteredClaims\AUDIENCE, Factory\createBasic(), et RegisteredClaims\DATE_CLAIMS.

◆ createBasic()

createBasic | ( | $name,
 |  | $value
 | ) |
private

Creates a basic claim

Paramètres
string | $name
mixed | $value
Renvoie
Basic

Références $name, et $value.

Référencé par Factory\create().

◆ createEqualsTo()

createEqualsTo | ( | $name,
 |  | $value
 | ) |
private

Creates a claim that can be compared (equals)

Paramètres
string | $name
mixed | $value
Renvoie
EqualsTo

Références $name, et $value.

◆ createGreaterOrEqualsTo()

createGreaterOrEqualsTo | ( | $name,
 |  | $value
 | ) |
private

Creates a claim that can be compared (greator or equals)

Paramètres
string | $name
mixed | $value
Renvoie
GreaterOrEqualsTo

Références $name, et $value.

◆ createLesserOrEqualsTo()

createLesserOrEqualsTo | ( | $name,
 |  | $value
 | ) |
private

Creates a claim that can be compared (greator or equals)

Paramètres
string | $name
mixed | $value
Renvoie
LesserOrEqualsTo

Références $name, et $value.

Documentation des champs

◆ $callbacks

$callbacks
private

Référencé par Factory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/lcobucci/jwt/src/Claim/Factory.php


Joomla CMS: Référence de la classe GreaterOrEqualsTo

  • Lcobucci
  • JWT
  • Claim
  • GreaterOrEqualsTo
Fonctions membres publiques
Référence de la classe GreaterOrEqualsTo
+ Graphe d'héritage de GreaterOrEqualsTo:
Basic Claim Validatable Claim

Fonctions membres publiques

validate (ValidationData $data)
- Fonctions membres publiques hérités de Basic
__construct ($name, $value)
getName ()
getValue ()
jsonSerialize ()
__toString ()

Description détaillée

Validatable claim that checks if value is greater or equals the given data

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des fonctions membres

◆ validate()

validate ( ValidationData $data )

{Returns if claim is valid according with given data

Paramètres
ValidationData $data
Renvoie
boolean
}

Implémente Validatable.

Références $data, $this, ValidationData\get(), Basic\getName(), et Basic\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • GreaterOrEqualsTo.php


Joomla CMS: Référence de la classe LesserOrEqualsTo

  • Lcobucci
  • JWT
  • Claim
  • LesserOrEqualsTo
Fonctions membres publiques
Référence de la classe LesserOrEqualsTo
+ Graphe d'héritage de LesserOrEqualsTo:
Basic Claim Validatable Claim

Fonctions membres publiques

validate (ValidationData $data)
- Fonctions membres publiques hérités de Basic
__construct ($name, $value)
getName ()
getValue ()
jsonSerialize ()
__toString ()

Description détaillée

Validatable claim that checks if value is lesser or equals to the given data

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des fonctions membres

◆ validate()

validate ( ValidationData $data )

{Returns if claim is valid according with given data

Paramètres
ValidationData $data
Renvoie
boolean
}

Implémente Validatable.

Références $data, $this, ValidationData\get(), Basic\getName(), et Basic\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LesserOrEqualsTo.php


Joomla CMS: Référence de l'interface Validatable

  • Lcobucci
  • JWT
  • Claim
  • Validatable
Fonctions membres publiques
Référence de l'interface Validatable
+ Graphe d'héritage de Validatable:
EqualsTo GreaterOrEqualsTo LesserOrEqualsTo

Fonctions membres publiques

validate (ValidationData $data)

Description détaillée

Basic interface for validatable token claims

Obsolète:
This interface will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des fonctions membres

◆ validate()

validate ( ValidationData $data )

Returns if claim is valid according with given data

Paramètres
ValidationData $data
Renvoie
boolean

Implémenté dans EqualsTo, GreaterOrEqualsTo, et LesserOrEqualsTo.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Validatable.php


Joomla CMS: Référence de la classe CannotDecodeContent

  • Lcobucci
  • JWT
  • Encoding
  • CannotDecodeContent
Fonctions membres publiques statiques
Référence de la classe CannotDecodeContent
+ Graphe d'héritage de CannotDecodeContent:

Fonctions membres publiques statiques

static | jsonIssues (JsonException $previous)
static | invalidBase64String ()

Documentation des fonctions membres

◆ invalidBase64String()

static invalidBase64String ( )
static
Renvoie
self

Référencé par InMemory\base64Encoded().

◆ jsonIssues()

static jsonIssues ( JsonException $previous )
static
Paramètres
JsonException $previous
Renvoie
self

Référencé par Decoder\jsonDecode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CannotDecodeContent.php


Joomla CMS: Référence de la classe CannotEncodeContent

  • Lcobucci
  • JWT
  • Encoding
  • CannotEncodeContent
Fonctions membres publiques statiques
Référence de la classe CannotEncodeContent
+ Graphe d'héritage de CannotEncodeContent:

Fonctions membres publiques statiques

static jsonIssues (JsonException $previous)

Documentation des fonctions membres

◆ jsonIssues()

static jsonIssues ( JsonException $previous )
static
Paramètres
JsonException $previous
Renvoie
self

Référencé par Encoder\jsonEncode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CannotEncodeContent.php


Joomla CMS: Référence de la classe Decoder

  • Lcobucci
  • JWT
  • Parsing
  • Decoder
Fonctions membres publiques
Référence de la classe Decoder

Fonctions membres publiques

jsonDecode ($json)
base64UrlDecode ($data)

Description détaillée

Class that decodes data according with the specs of RFC-4648

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

http://tools.ietf.org/html/rfc4648#section-5

Documentation des fonctions membres

◆ base64UrlDecode()

base64UrlDecode ( $data )

Decodes from base64url

Paramètres
string $data
Renvoie
string

Références $data.

◆ jsonDecode()

jsonDecode ( $json )

Decodes from JSON, validating the errors (will return an associative array instead of objects)

Paramètres
string $json
Renvoie
mixed
Exceptions
RuntimeException When something goes wrong while decoding

Références $data, et CannotDecodeContent\jsonIssues().

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Parsing/Decoder.php


Joomla CMS: Référence de la classe Encoder

  • Lcobucci
  • JWT
  • Parsing
  • Encoder
Fonctions membres publiques
Référence de la classe Encoder

Fonctions membres publiques

jsonEncode ($data)
base64UrlEncode ($data)

Description détaillée

Class that encodes data according with the specs of RFC-4648

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

http://tools.ietf.org/html/rfc4648#section-5

Documentation des fonctions membres

◆ base64UrlEncode()

base64UrlEncode ( $data )

Encodes to base64url

Paramètres
string $data
Renvoie
string

Références $data.

◆ jsonEncode()

jsonEncode ( $data )

Encodes to JSON, validating the errors

Paramètres
mixed $data
Renvoie
string
Exceptions
RuntimeException When something goes wrong while encoding

Références $data, et CannotEncodeContent\jsonIssues().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Encoder.php


Joomla CMS: Référence de la classe ConversionFailed

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • ConversionFailed
Fonctions membres publiques statiques
Référence de la classe ConversionFailed
+ Graphe d'héritage de ConversionFailed:

Fonctions membres publiques statiques

static | invalidLength ()
static | incorrectStartSequence ()
static | integerExpected ()

Documentation des fonctions membres

◆ incorrectStartSequence()

static incorrectStartSequence ( )
static
Renvoie
self

Référencé par MultibyteStringConverter\fromAsn1().

◆ integerExpected()

static integerExpected ( )
static
Renvoie
self

Référencé par MultibyteStringConverter\readAsn1Integer().

◆ invalidLength()

static invalidLength ( )
static
Renvoie
self

Référencé par MultibyteStringConverter\toAsn1().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConversionFailed.php


Joomla CMS: Référence de la classe MultibyteStringConverter

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • MultibyteStringConverter
Fonctions membres publiques | Champs de données | Fonctions membres privées statiques
Référence de la classe MultibyteStringConverter
+ Graphe d'héritage de MultibyteStringConverter:
SignatureConverter

Fonctions membres publiques

toAsn1 ($signature, $length)
fromAsn1 ($signature, $length)

Champs de données

const | ASN1_SEQUENCE = '30'
const | ASN1_INTEGER = '02'
const | ASN1_MAX_SINGLE_BYTE = 128
const | ASN1_LENGTH_2BYTES = '81'
const | ASN1_BIG_INTEGER_LIMIT = '7f'
const | ASN1_NEGATIVE_INTEGER = '00'
const | BYTE_SIZE = 2

Fonctions membres privées statiques

static | octetLength ($data)
static | preparePositiveInteger ($data)
static | readAsn1Content ($message, &$position, $length)
static | readAsn1Integer ($message, &$position)
static | retrievePositiveInteger ($data)

Description détaillée

ECDSA signature converter using ext-mbstring

Documentation des fonctions membres

◆ fromAsn1()

fromAsn1 | ( | $signature,
 |  | $length
 | ) |

Converts the signature generated by OpenSSL into what JWA defines

Paramètres
string | $signature
int | $length
Renvoie
string

Implémente SignatureConverter.

Références $message, $position, et ConversionFailed\incorrectStartSequence().

◆ octetLength()

static octetLength ( $data )
staticprivate

Références $data.

◆ preparePositiveInteger()

static preparePositiveInteger ( $data )
staticprivate

Références $data, et null.

◆ readAsn1Content()

static readAsn1Content | ( |  | $message,
 |  | & | $position,
 |  |  | $length
 | ) |  |
staticprivate

Références $content, $message, et $position.

◆ readAsn1Integer()

static readAsn1Integer | ( |  | $message,
 |  | & | $position
 | ) |  |
staticprivate

Références $message, $position, et ConversionFailed\integerExpected().

◆ retrievePositiveInteger()

static retrievePositiveInteger ( $data )
staticprivate

Références $data, et null.

◆ toAsn1()

toAsn1 | ( | $points,
 |  | $length
 | ) |

Converts the JWA signature into something OpenSSL understands

Paramètres
string | $points
int | $length
Renvoie
string

Implémente SignatureConverter.

Références ConversionFailed\invalidLength(), et null.

Documentation des champs

◆ ASN1_BIG_INTEGER_LIMIT

const ASN1_BIG_INTEGER_LIMIT = '7f'

◆ ASN1_INTEGER

const ASN1_INTEGER = '02'

◆ ASN1_LENGTH_2BYTES

const ASN1_LENGTH_2BYTES = '81'

◆ ASN1_MAX_SINGLE_BYTE

const ASN1_MAX_SINGLE_BYTE = 128

◆ ASN1_NEGATIVE_INTEGER

const ASN1_NEGATIVE_INTEGER = '00'

◆ ASN1_SEQUENCE

const ASN1_SEQUENCE = '30'

◆ BYTE_SIZE

const BYTE_SIZE = 2
La documentation de cette classe a été générée à partir du fichier suivant :
  • MultibyteStringConverter.php


Joomla CMS: Référence de la classe Sha256

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • Sha256
Fonctions membres publiques
Référence de la classe Sha256
+ Graphe d'héritage de Sha256:
Ecdsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
getKeyLength ()
- Fonctions membres publiques hérités de Ecdsa
__construct (SignatureConverter $converter=null)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyLength ()
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for ECDSA SHA-256

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

◆ getKeyLength()

getKeyLength ( )

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ecdsa/Sha256.php


Joomla CMS: Référence de la classe Sha384

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • Sha384
Fonctions membres publiques
Référence de la classe Sha384
+ Graphe d'héritage de Sha384:
Ecdsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
getKeyLength ()
- Fonctions membres publiques hérités de Ecdsa
__construct (SignatureConverter $converter=null)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyLength ()
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for ECDSA SHA-384

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

◆ getKeyLength()

getKeyLength ( )

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ecdsa/Sha384.php


Joomla CMS: Référence de la classe Sha512

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • Sha512
Fonctions membres publiques
Référence de la classe Sha512
+ Graphe d'héritage de Sha512:
Ecdsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
getKeyLength ()
- Fonctions membres publiques hérités de Ecdsa
__construct (SignatureConverter $converter=null)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyLength ()
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for ECDSA SHA-512

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

◆ getKeyLength()

getKeyLength ( )

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ecdsa/Sha512.php


Joomla CMS: Référence de l'interface SignatureConverter

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
  • SignatureConverter
Fonctions membres publiques
Référence de l'interface SignatureConverter
+ Graphe d'héritage de SignatureConverter:
MultibyteStringConverter

Fonctions membres publiques

fromAsn1 ($signature, $length)
toAsn1 ($points, $length)

Description détaillée

Manipulates the result of a ECDSA signature (points R and S) according to the JWA specs.

OpenSSL creates a signature using the ASN.1 format and, according the JWA specs, the signature for JWTs must be the concatenated values of points R and S (in big-endian octet order).

Documentation des fonctions membres

◆ fromAsn1()

fromAsn1 | ( | $signature,
 |  | $length
 | ) |

Converts the signature generated by OpenSSL into what JWA defines

Paramètres
string | $signature
int | $length
Renvoie
string

Implémenté dans MultibyteStringConverter.

◆ toAsn1()

toAsn1 | ( | $points,
 |  | $length
 | ) |

Converts the JWA signature into something OpenSSL understands

Paramètres
string | $points
int | $length
Renvoie
string

Implémenté dans MultibyteStringConverter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SignatureConverter.php


Joomla CMS: Référence de la classe Sha256

  • Lcobucci
  • JWT
  • Signer
  • Hmac
  • Sha256
Fonctions membres publiques
Référence de la classe Sha256
+ Graphe d'héritage de Sha256:
Hmac BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Hmac
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for HMAC SHA-256

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Hmac/Sha256.php


Joomla CMS: Référence de la classe Sha384

  • Lcobucci
  • JWT
  • Signer
  • Hmac
  • Sha384
Fonctions membres publiques
Référence de la classe Sha384
+ Graphe d'héritage de Sha384:
Hmac BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Hmac
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for HMAC SHA-384

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Hmac/Sha384.php


Joomla CMS: Référence de la classe Sha512

  • Lcobucci
  • JWT
  • Signer
  • Hmac
  • Sha512
Fonctions membres publiques
Référence de la classe Sha512
+ Graphe d'héritage de Sha512:
Hmac BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Hmac
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for HMAC SHA-512

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Hmac/Sha512.php


Joomla CMS: Référence de la classe InMemory

  • Lcobucci
  • JWT
  • Signer
  • Key
  • InMemory
Fonctions membres publiques statiques
Référence de la classe InMemory
+ Graphe d'héritage de InMemory:
Key

Fonctions membres publiques statiques

static | plainText ($contents, $passphrase='')
static | base64Encoded ($contents, $passphrase='')
static | file ($path, $passphrase='')

Membres hérités additionnels

- Fonctions membres publiques hérités de Key
__construct ($content, $passphrase='')
contents ()
passphrase ()
getContent ()
getPassphrase ()
- Attributs protégés hérités de Key
$content

Documentation des fonctions membres

◆ base64Encoded()

static base64Encoded | ( | $contents,
 |  | $passphrase = ''
 | ) |
static
Paramètres
string | $contents
string | $passphrase
Renvoie
self

Références Key\$passphrase, et CannotDecodeContent\invalidBase64String().

◆ file()

static file | ( | $path,
 |  | $passphrase = ''
 | ) |
static
Paramètres
string | $path
string | $passphrase
Renvoie
InMemory
Exceptions
FileCouldNotBeRead

Références Key\$passphrase, et $path.

◆ plainText()

static plainText | ( | $contents,
 |  | $passphrase = ''
 | ) |
static
Paramètres
string | $contents
string | $passphrase
Renvoie
self

Références Key\$passphrase.

Référencé par Configuration\forUnsecuredSigner().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InMemory.php


Joomla CMS: Référence de la classe LocalFileReference

  • Lcobucci
  • JWT
  • Signer
  • Key
  • LocalFileReference
Fonctions membres publiques statiques | Champs de données
Référence de la classe LocalFileReference
+ Graphe d'héritage de LocalFileReference:
Key

Fonctions membres publiques statiques

static file ($path, $passphrase='')

Champs de données

const PATH_PREFIX = 'file://'

Membres hérités additionnels

- Fonctions membres publiques hérités de Key
__construct ($content, $passphrase='')
contents ()
passphrase ()
getContent ()
getPassphrase ()
- Attributs protégés hérités de Key
$content

Description détaillée

Obsolète:
Use ::file() instead

Documentation des fonctions membres

◆ file()

static file | ( | $path,
 |  | $passphrase = ''
 | ) |
static
Paramètres
string | $path
string | $passphrase
Renvoie
self
Exceptions
FileCouldNotBeRead

Références Key\$passphrase, et $path.

Documentation des champs

◆ PATH_PREFIX

const PATH_PREFIX = 'file://'
La documentation de cette classe a été générée à partir du fichier suivant :
  • LocalFileReference.php


Joomla CMS: Référence de la classe Sha256

  • Lcobucci
  • JWT
  • Signer
  • Rsa
  • Sha256
Fonctions membres publiques
Référence de la classe Sha256
+ Graphe d'héritage de Sha256:
Rsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Rsa
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for RSA SHA-256

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rsa/Sha256.php


Joomla CMS: Référence de la classe Sha384

  • Lcobucci
  • JWT
  • Signer
  • Rsa
  • Sha384
Fonctions membres publiques
Référence de la classe Sha384
+ Graphe d'héritage de Sha384:
Rsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Rsa
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for RSA SHA-384

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rsa/Sha384.php


Joomla CMS: Référence de la classe Sha512

  • Lcobucci
  • JWT
  • Signer
  • Rsa
  • Sha512
Fonctions membres publiques
Référence de la classe Sha512
+ Graphe d'héritage de Sha512:
Rsa OpenSSL BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
getAlgorithm ()
- Fonctions membres publiques hérités de Rsa
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Description détaillée

Signer for RSA SHA-512

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getAlgorithm()

getAlgorithm ( )

{}

◆ getAlgorithmId()

getAlgorithmId ( )

{Returns the algorithm id

Renvoie
string
}

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rsa/Sha512.php


Joomla CMS: Référence de la classe BaseSigner

  • Lcobucci
  • JWT
  • Signer
  • BaseSigner
Fonctions membres publiques | Fonctions membres privées
Référence de la classe BaseSigner
+ Graphe d'héritage de BaseSigner:
Signer Hmac None OpenSSL Sha256 Sha384 Sha512 Ecdsa Rsa Sha256 Sha384 Sha512 Sha256 Sha384 Sha512

Fonctions membres publiques

modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de Signer
getAlgorithmId ()

Fonctions membres privées

getKey ($key)

Description détaillée

Base class for signers

Obsolète:
This class will be removed on v4
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ createHash()

createHash | ( |  | $payload,
 |  | Key | $key
 | ) |  |
abstract

Creates a hash with the given data

Référencé par BaseSigner\sign().

◆ doVerify()

doVerify | ( |  | $expected,
 |  |  | $payload,
 |  | Key | $key
 | ) |  |
abstract

Performs the signature verification

Référencé par BaseSigner\verify().

◆ getKey()

getKey ( $key )
private
Paramètres
Key | string $key
Renvoie
Key

Références $key.

Référencé par BaseSigner\sign(), et BaseSigner\verify().

◆ modifyHeader()

modifyHeader ( array & $headers )

{Apply changes on headers according with algorithm

Paramètres
array $headers
}

Implémente Signer.

Références Signer\getAlgorithmId().

◆ sign()

sign | ( | $payload,
 |  | $key
 | ) |

{Returns a signature for given data

Paramètres
string | $payload
Key | string | $key
Renvoie
Signature
Exceptions
InvalidArgumentException When given key is invalid
}

Implémente Signer.

Références $key, BaseSigner\createHash(), et BaseSigner\getKey().

◆ verify()

verify | ( | $expected,
 |  | $payload,
 |  | $key
 | ) |

{Returns if the expected hash matches with the data and key

Paramètres
string | $expected
string | $payload
Key | string | $key
Renvoie
boolean
Exceptions
InvalidArgumentException When given key is invalid
}

Implémente Signer.

Références $key, BaseSigner\doVerify(), et BaseSigner\getKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseSigner.php


Joomla CMS: Référence de la classe CannotSignPayload

  • Lcobucci
  • JWT
  • Signer
  • CannotSignPayload
Fonctions membres publiques statiques
Référence de la classe CannotSignPayload
+ Graphe d'héritage de CannotSignPayload:

Fonctions membres publiques statiques

static errorHappened ($error)

Documentation des fonctions membres

◆ errorHappened()

static errorHappened ( $error )
static

string $error

Renvoie
self

Référencé par OpenSSL\createHash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CannotSignPayload.php


Joomla CMS: Référence de la classe Ecdsa

  • Lcobucci
  • JWT
  • Signer
  • Ecdsa
Fonctions membres publiques | Attributs privés
Référence de la classe Ecdsa
+ Graphe d'héritage de Ecdsa:
OpenSSL BaseSigner Signer Sha256 Sha384 Sha512

Fonctions membres publiques

__construct (SignatureConverter $converter=null)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyLength ()
getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de Signer
getAlgorithmId ()

Attributs privés

$converter

Description détaillée

Base class for ECDSA signers

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( SignatureConverter $converter = null )

Références Ecdsa\$converter.

Documentation des fonctions membres

◆ createHash()

createHash | ( |  | $payload,
 |  | Key | $key
 | ) |  |

{}

Références $key, et Ecdsa\getKeyLength().

◆ doVerify()

doVerify | ( |  | $expected,
 |  |  | $payload,
 |  | Key | $key
 | ) |  |

{}

Références $key, et $this.

◆ getKeyLength()

getKeyLength ( )
abstract

Returns the length of each point in the signature, so that we can calculate and verify R and S points properly

Référencé par Ecdsa\createHash().

◆ getKeyType()

getKeyType ( )
final

{}

Documentation des champs

◆ $converter

$converter
private

Référencé par Ecdsa\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ecdsa.php


Joomla CMS: Référence de la classe Hmac

  • Lcobucci
  • JWT
  • Signer
  • Hmac
Fonctions membres publiques
Référence de la classe Hmac
+ Graphe d'héritage de Hmac:
BaseSigner Signer Sha256 Sha384 Sha512

Fonctions membres publiques

createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de Signer
getAlgorithmId ()

Description détaillée

Base class for hmac signers

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ createHash()

createHash | ( |  | $payload,
 |  | Key | $key
 | ) |  |

{}

Références $key, et Hmac\getAlgorithm().

Référencé par Hmac\doVerify().

◆ doVerify()

doVerify | ( |  | $expected,
 |  |  | $payload,
 |  | Key | $key
 | ) |  |

{}

Références $key, et Hmac\createHash().

◆ getAlgorithm()

getAlgorithm ( )
abstract

Returns the algorithm name

Référencé par Hmac\createHash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Signer/Hmac.php


Joomla CMS: Référence de la classe InvalidKeyProvided

  • Lcobucci
  • JWT
  • Signer
  • InvalidKeyProvided
Fonctions membres publiques statiques
Référence de la classe InvalidKeyProvided
+ Graphe d'héritage de InvalidKeyProvided:

Fonctions membres publiques statiques

static | cannotBeParsed ($details)
static | incompatibleKey ()

Documentation des fonctions membres

◆ cannotBeParsed()

static cannotBeParsed ( $details )
static
Paramètres
string $details
Renvoie
self

Référencé par OpenSSL\validateKey().

◆ incompatibleKey()

static incompatibleKey ( )
static
Renvoie
self

Référencé par OpenSSL\validateKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidKeyProvided.php


Joomla CMS: Référence de la classe Key

  • Lcobucci
  • JWT
  • Signer
  • Key
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Key
+ Graphe d'héritage de Key:
InMemory LocalFileReference

Fonctions membres publiques

__construct ($content, $passphrase='')
contents ()
passphrase ()
getContent ()
getPassphrase ()

Attributs protégés

$content

Fonctions membres privées

setContent ($content)
readFile ($content)

Attributs privés

$passphrase

Description détaillée

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
3.0.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $content,
 |  | $passphrase = ''
 | ) |
Paramètres
string | $content
string | $passphrase

Références Key\$content, Key\$passphrase, Key\passphrase(), et Key\setContent().

Documentation des fonctions membres

◆ contents()

contents ( )
Renvoie
string

Références Key\$content.

◆ getContent()

getContent ( )
Obsolète:
This method is no longer part of the public interface
Voir également
Key::contents()
Renvoie
string

Références Key\$content.

Référencé par OpenSSL\createHash(), et OpenSSL\doVerify().

◆ getPassphrase()

getPassphrase ( )
Obsolète:
This method is no longer part of the public interface
Voir également
Key::passphrase()
Renvoie
string

Références Key\$passphrase.

◆ passphrase()

passphrase ( )
Renvoie
string

Références Key\$passphrase.

Référencé par Key\__construct().

◆ readFile()

readFile ( $content )
private
Paramètres
string $content
Renvoie
string
Exceptions
InvalidArgumentException

Références Key\$content, et $path.

Référencé par Key\setContent().

◆ setContent()

setContent ( $content )
private
Paramètres
string $content
Exceptions
InvalidArgumentException

Références Key\$content, content, et Key\readFile().

Référencé par Key\__construct().

Documentation des champs

◆ $content

$content
protected

Référencé par Key\__construct(), Key\contents(), Key\getContent(), Key\readFile(), et Key\setContent().

◆ $passphrase

$passphrase
private

Référencé par Key\__construct(), InMemory\base64Encoded(), LocalFileReference\file(), InMemory\file(), Key\getPassphrase(), Key\passphrase(), et InMemory\plainText().

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Signer/Key.php


Joomla CMS: Référence de la classe Keychain

  • Lcobucci
  • JWT
  • Signer
  • Keychain
Fonctions membres publiques
Référence de la classe Keychain

Fonctions membres publiques

getPrivateKey ($key, $passphrase=null)
getPublicKey ($certificate)

Description détaillée

A utilitarian class that encapsulates the retrieval of public and private keys

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0
Obsolète:
Since we've removed OpenSSL from ECDSA there's no reason to use this class

Documentation des fonctions membres

◆ getPrivateKey()

getPrivateKey | ( | $key,
 |  | $passphrase = null
 | ) |

Returns a private key from file path or content

Paramètres
string | $key
string | $passphrase
Renvoie
Key

Références $key.

◆ getPublicKey()

getPublicKey ( $certificate )

Returns a public key from file path or content

Paramètres
string $certificate
Renvoie
Key
La documentation de cette classe a été générée à partir du fichier suivant :
  • Keychain.php


Joomla CMS: Référence de la classe None

  • Lcobucci
  • JWT
  • Signer
  • None
Fonctions membres publiques
Référence de la classe None
+ Graphe d'héritage de None:
BaseSigner Signer

Fonctions membres publiques

getAlgorithmId ()
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)

Documentation des fonctions membres

◆ createHash()

createHash | ( |  | $payload,
 |  | Key | $key
 | ) |  |

◆ doVerify()

doVerify | ( |  | $expected,
 |  |  | $payload,
 |  | Key | $key
 | ) |  |

◆ getAlgorithmId()

getAlgorithmId ( )

Returns the algorithm id

Renvoie
string

Implémente Signer.

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Signer/None.php


Joomla CMS: Référence de la classe OpenSSL

  • Lcobucci
  • JWT
  • Signer
  • OpenSSL
Fonctions membres publiques | Fonctions membres privées
Référence de la classe OpenSSL
+ Graphe d'héritage de OpenSSL:
BaseSigner Signer Ecdsa Rsa Sha256 Sha384 Sha512 Sha256 Sha384 Sha512

Fonctions membres publiques

createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de Signer
getAlgorithmId ()

Fonctions membres privées

getPrivateKey ($pem, $passphrase)
getPublicKey ($pem)
validateKey ($key)

Documentation des fonctions membres

◆ createHash()

createHash | ( |  | $payload,
 |  | Key | $key
 | ) |  |

Références $key, CannotSignPayload\errorHappened(), OpenSSL\getAlgorithm(), Key\getContent(), et OpenSSL\getPrivateKey().

◆ doVerify()

doVerify | ( |  | $expected,
 |  |  | $payload,
 |  | Key | $key
 | ) |  |
Paramètres
$expected
$payload
$key
Renvoie
bool

Références $result, OpenSSL\getAlgorithm(), Key\getContent(), et OpenSSL\getPublicKey().

◆ getAlgorithm()

getAlgorithm ( )
abstract

Returns which algorithm to be used to create/verify the signature (using OpenSSL constants)

Référencé par OpenSSL\createHash(), et OpenSSL\doVerify().

◆ getKeyType()

getKeyType ( )
abstract

Returns the type of key to be used to create/verify the signature (using OpenSSL constants)

Référencé par OpenSSL\validateKey().

◆ getPrivateKey()

getPrivateKey | ( | $pem,
 |  | $passphrase
 | ) |
private
Paramètres
string | $pem
string | $passphrase
Renvoie
resource

Références OpenSSL\validateKey().

Référencé par OpenSSL\createHash().

◆ getPublicKey()

getPublicKey ( $pem )
private
Paramètres
string $pem
Renvoie
resource

Références OpenSSL\validateKey().

Référencé par OpenSSL\doVerify().

◆ validateKey()

validateKey ( $key )
private

Raises an exception when the key type is not the expected type

Paramètres
resource | bool $key
Exceptions
InvalidArgumentException

Références $key, InvalidKeyProvided\cannotBeParsed(), OpenSSL\getKeyType(), et InvalidKeyProvided\incompatibleKey().

Référencé par OpenSSL\getPrivateKey(), et OpenSSL\getPublicKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/lcobucci/jwt/src/Signer/OpenSSL.php


Joomla CMS: Référence de la classe Rsa

  • Lcobucci
  • JWT
  • Signer
  • Rsa
Fonctions membres publiques
Référence de la classe Rsa
+ Graphe d'héritage de Rsa:
OpenSSL BaseSigner Signer Sha256 Sha384 Sha512

Fonctions membres publiques

getKeyType ()
- Fonctions membres publiques hérités de OpenSSL
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
getKeyType ()
getAlgorithm ()
- Fonctions membres publiques hérités de BaseSigner
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)
createHash ($payload, Key $key)
doVerify ($expected, $payload, Key $key)
- Fonctions membres publiques hérités de Signer
getAlgorithmId ()

Description détaillée

Base class for RSASSA-PKCS1 signers

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.1.0

Documentation des fonctions membres

◆ getKeyType()

getKeyType ( )
final
La documentation de cette classe a été générée à partir du fichier suivant :
  • Rsa.php


Joomla CMS: Référence de la classe DataSet

  • Lcobucci
  • JWT
  • Token
  • DataSet
Fonctions membres publiques | Attributs privés
Référence de la classe DataSet

Fonctions membres publiques

__construct (array $data, $encoded)
get ($name, $default=null)
has ($name)
all ()
toString ()

Attributs privés

$data
$encoded

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $data,
 |  |  | $encoded
 | ) |  |
Paramètres
array<string,mixed> | $data
string | $encoded

Références DataSet\$data, et DataSet\$encoded.

Documentation des fonctions membres

◆ all()

all ( )
Renvoie
array<string, mixed>

Références DataSet\$data.

◆ get()

get | ( | $name,
 |  | $default = null
 | ) |
Paramètres
string | $name
mixed | null | $default
Renvoie
mixed|null

Références $default, $name, et DataSet\has().

◆ has()

has ( $name )
Paramètres
string $name
Renvoie
bool

Références $name.

Référencé par DataSet\get().

◆ toString()

toString ( )
Renvoie
string

Références DataSet\$encoded.

Référencé par Builder\getToken().

Documentation des champs

◆ $data

$data
private

Référencé par DataSet\__construct(), et DataSet\all().

◆ $encoded

$encoded
private

Référencé par DataSet\__construct(), et DataSet\toString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Token/DataSet.php


Joomla CMS: Référence de la classe InvalidTokenStructure

  • Lcobucci
  • JWT
  • Token
  • InvalidTokenStructure
Fonctions membres publiques statiques
Référence de la classe InvalidTokenStructure
+ Graphe d'héritage de InvalidTokenStructure:

Fonctions membres publiques statiques

static | missingOrNotEnoughSeparators ()
static | arrayExpected ($part)
static | dateIsNotParseable ($value)

Documentation des fonctions membres

◆ arrayExpected()

static arrayExpected ( $part )
static
Paramètres
string $part
Renvoie
self

◆ dateIsNotParseable()

static dateIsNotParseable ( $value )
static
Paramètres
string $value
Renvoie
self

Références $value.

◆ missingOrNotEnoughSeparators()

static missingOrNotEnoughSeparators ( )
static
Renvoie
self

Référencé par Parser\splitJwt().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidTokenStructure.php


Joomla CMS: Référence de la classe RegisteredClaimGiven

  • Lcobucci
  • JWT
  • Token
  • RegisteredClaimGiven
Fonctions membres publiques statiques | Champs de données
Référence de la classe RegisteredClaimGiven
+ Graphe d'héritage de RegisteredClaimGiven:

Fonctions membres publiques statiques

static forClaim ($name)

Champs de données

const DEFAULT_MESSAGE

Documentation des fonctions membres

◆ forClaim()

static forClaim ( $name )
static
Paramètres
string $name
Renvoie
self

Références $name.

Documentation des champs

◆ DEFAULT_MESSAGE

const DEFAULT_MESSAGE
Valeur initiale :
= 'Builder#withClaim() is meant to be used for non-registered claims, '
. 'check the documentation on how to set claim "%s"'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RegisteredClaimGiven.php


Joomla CMS: Référence de l'interface RegisteredClaims

  • Lcobucci
  • JWT
  • Token
  • RegisteredClaims
Champs de données
Référence de l'interface RegisteredClaims

Champs de données

const | ALL
const | DATE_CLAIMS
const | AUDIENCE = 'aud'
const | EXPIRATION_TIME = 'exp'
const | ID = 'jti'
const | ISSUED_AT = 'iat'
const | ISSUER = 'iss'
const | NOT_BEFORE = 'nbf'
const | SUBJECT = 'sub'

Description détaillée

Defines the list of claims that are registered in the IANA "JSON Web Token Claims" registry

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1

Documentation des champs

◆ ALL

const ALL
Valeur initiale :
= [
self::AUDIENCE,
self::EXPIRATION_TIME,
self::ID,
self::ISSUED_AT,
self::ISSUER,
self::NOT_BEFORE,
self::SUBJECT,
]

Référencé par Token\getHeaders(), et Builder\withClaim().

◆ AUDIENCE

const AUDIENCE = 'aud'

Identifies the recipients that the JWT is intended for

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1.3

Référencé par Parser\convertItems(), Builder\convertItems(), Factory\create(), Builder\forwardCallToCorrectClaimMethod(), Token\getClaim(), Token\isPermittedFor(), et Builder\permittedFor().

◆ DATE_CLAIMS

const DATE_CLAIMS
Valeur initiale :
= [
self::ISSUED_AT,
self::NOT_BEFORE,
self::EXPIRATION_TIME,
]

Référencé par Parser\convertItems(), Builder\convertItems(), Factory\create(), et Token\getClaim().

◆ EXPIRATION_TIME

const EXPIRATION_TIME = 'exp'

Identifies the expiration time on or after which the JWT MUST NOT be accepted for processing

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1.4

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Token\isExpired().

◆ ID

const ID = 'jti'

Provides a unique identifier for the JWT

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1.7

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Token\isIdentifiedBy().

◆ ISSUED_AT

const ISSUED_AT = 'iat'

Identifies the time at which the JWT was issued

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1.6

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Token\hasBeenIssuedBefore().

◆ ISSUER

const ISSUER = 'iss'

Identifies the principal that issued the JWT

Voir également
https://tools.ietf.org/html/rfc7519#section-4.1.1

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Token\hasBeenIssuedBy().

◆ NOT_BEFORE

const NOT_BEFORE = 'nbf'

Identifies the time before which the JWT MUST NOT be accepted for processing

https://tools.ietf.org/html/rfc7519#section-4.1.5

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Token\isMinimumTimeBefore().

◆ SUBJECT

const SUBJECT = 'sub'

Identifies the principal that is the subject of the JWT.

https://tools.ietf.org/html/rfc7519#section-4.1.2

Référencé par Token\isRelatedTo().

La documentation de cette interface a été générée à partir du fichier suivant :
  • RegisteredClaims.php


Joomla CMS: Référence de la classe UnsupportedHeaderFound

  • Lcobucci
  • JWT
  • Token
  • UnsupportedHeaderFound
Fonctions membres publiques statiques
Référence de la classe UnsupportedHeaderFound
+ Graphe d'héritage de UnsupportedHeaderFound:

Fonctions membres publiques statiques

static encryption ()

Documentation des fonctions membres

◆ encryption()

static encryption ( )
static
Renvoie
self

Référencé par Parser\parseHeader().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedHeaderFound.php


Joomla CMS: Référence de la classe IdentifiedBy

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • IdentifiedBy
Fonctions membres publiques | Attributs privés
Référence de la classe IdentifiedBy
+ Graphe d'héritage de IdentifiedBy:
Constraint

Fonctions membres publiques

__construct ($id)
assert (Token $token)

Attributs privés

$id

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $id )
Paramètres
string $id

Références IdentifiedBy\$id.

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références $this, et Token\isIdentifiedBy().

Documentation des champs

◆ $id

$id
private

Référencé par IdentifiedBy\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IdentifiedBy.php


Joomla CMS: Référence de la classe IssuedBy

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • IssuedBy
Fonctions membres publiques | Attributs privés
Référence de la classe IssuedBy
+ Graphe d'héritage de IssuedBy:
Constraint

Fonctions membres publiques

__construct (... $issuers)
assert (Token $token)

Attributs privés

$issuers

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $issuers )
Paramètres
list<string> $issuers

Références IssuedBy\$issuers.

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références Token\hasBeenIssuedBy().

Documentation des champs

◆ $issuers

$issuers
private

Référencé par IssuedBy\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • IssuedBy.php


Joomla CMS: Référence de la classe LeewayCannotBeNegative

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • LeewayCannotBeNegative
Fonctions membres publiques statiques
Référence de la classe LeewayCannotBeNegative
+ Graphe d'héritage de LeewayCannotBeNegative:

Fonctions membres publiques statiques

static create ()

Documentation des fonctions membres

◆ create()

static create ( )
static
Renvoie
self

Référencé par ValidAt\guardLeeway().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LeewayCannotBeNegative.php


Joomla CMS: Référence de la classe PermittedFor

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • PermittedFor
Fonctions membres publiques | Attributs privés
Référence de la classe PermittedFor
+ Graphe d'héritage de PermittedFor:
Constraint

Fonctions membres publiques

__construct ($audience)
assert (Token $token)

Attributs privés

$audience

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $audience )

Références PermittedFor\$audience.

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références $this, et Token\isPermittedFor().

Documentation des champs

◆ $audience

$audience
private

Référencé par PermittedFor\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PermittedFor.php


Joomla CMS: Référence de la classe RelatedTo

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • RelatedTo
Fonctions membres publiques | Attributs privés
Référence de la classe RelatedTo
+ Graphe d'héritage de RelatedTo:
Constraint

Fonctions membres publiques

__construct ($subject)
assert (Token $token)

Attributs privés

$subject

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $subject )

Références RelatedTo\$subject.

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références $this, et Token\isRelatedTo().

Documentation des champs

◆ $subject

$subject
private

Référencé par RelatedTo\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RelatedTo.php


Joomla CMS: Référence de la classe SignedWith

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • SignedWith
Fonctions membres publiques | Attributs privés
Référence de la classe SignedWith
+ Graphe d'héritage de SignedWith:
Constraint

Fonctions membres publiques

__construct (Signer $signer, Signer\Key $key)
assert (Token $token)

Attributs privés

$signer
$key

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Signer | $signer,
 |  | Signer\Key | $key
 | ) |  |

Références SignedWith\$key, et SignedWith\$signer.

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références SignedWith\$key, Token\getPayload(), Token\headers(), et Token\signature().

Documentation des champs

◆ $key

$key
private

Référencé par SignedWith\__construct(), et SignedWith\assert().

◆ $signer

$signer
private

Référencé par SignedWith\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SignedWith.php


Joomla CMS: Référence de la classe ValidAt

  • Lcobucci
  • JWT
  • Validation
  • Constraint
  • ValidAt
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ValidAt
+ Graphe d'héritage de ValidAt:
Constraint

Fonctions membres publiques

__construct (Clock $clock, DateInterval $leeway=null)
assert (Token $token)

Fonctions membres privées

guardLeeway (DateInterval $leeway=null)
assertExpiration (Token $token, DateTimeInterface $now)
assertMinimumTime (Token $token, DateTimeInterface $now)
assertIssueTime (Token $token, DateTimeInterface $now)

Attributs privés

$clock
$leeway

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Clock | $clock,
 |  | DateInterval | $leeway = null
 | ) |  |

Références ValidAt\$clock, ValidAt\$leeway, et ValidAt\guardLeeway().

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémente Constraint.

Références $now, $this, ValidAt\assertExpiration(), ValidAt\assertIssueTime(), et ValidAt\assertMinimumTime().

◆ assertExpiration()

assertExpiration | ( | Token | $token,
 |  | DateTimeInterface | $now
 | ) |  |
private
Exceptions
ConstraintViolation

Références $now, et Token\isExpired().

Référencé par ValidAt\assert().

◆ assertIssueTime()

assertIssueTime | ( | Token | $token,
 |  | DateTimeInterface | $now
 | ) |  |
private
Exceptions
ConstraintViolation

Références $now, et Token\hasBeenIssuedBefore().

Référencé par ValidAt\assert().

◆ assertMinimumTime()

assertMinimumTime | ( | Token | $token,
 |  | DateTimeInterface | $now
 | ) |  |
private
Exceptions
ConstraintViolation

Références $now, et Token\isMinimumTimeBefore().

Référencé par ValidAt\assert().

◆ guardLeeway()

guardLeeway ( DateInterval $leeway = null )
private
Renvoie
DateInterval

Références ValidAt\$leeway, LeewayCannotBeNegative\create(), et null.

Référencé par ValidAt\__construct().

Documentation des champs

◆ $clock

$clock
private

Référencé par ValidAt\__construct().

◆ $leeway

$leeway
private

Référencé par ValidAt\__construct(), et ValidAt\guardLeeway().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ValidAt.php


Joomla CMS: Référence de l'interface Constraint

  • Lcobucci
  • JWT
  • Validation
  • Constraint
Fonctions membres publiques
Référence de l'interface Constraint
+ Graphe d'héritage de Constraint:
IdentifiedBy IssuedBy PermittedFor RelatedTo SignedWith ValidAt

Fonctions membres publiques

assert (Token $token)

Documentation des fonctions membres

◆ assert()

assert ( Token $token )
Exceptions
ConstraintViolation

Implémenté dans ValidAt, SignedWith, IdentifiedBy, IssuedBy, PermittedFor, et RelatedTo.

Référencé par Validator\checkConstraint().

La documentation de cette interface a été générée à partir du fichier suivant :
  • Constraint.php


Joomla CMS: Référence de la classe ConstraintViolation

  • Lcobucci
  • JWT
  • Validation
  • ConstraintViolation
Référence de la classe ConstraintViolation
+ Graphe d'héritage de ConstraintViolation:
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConstraintViolation.php


Joomla CMS: Référence de la classe NoConstraintsGiven

  • Lcobucci
  • JWT
  • Validation
  • NoConstraintsGiven
Référence de la classe NoConstraintsGiven
+ Graphe d'héritage de NoConstraintsGiven:
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoConstraintsGiven.php


Joomla CMS: Référence de la classe RequiredConstraintsViolated

  • Lcobucci
  • JWT
  • Validation
  • RequiredConstraintsViolated
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe RequiredConstraintsViolated
+ Graphe d'héritage de RequiredConstraintsViolated:

Fonctions membres publiques

violations ()

Fonctions membres publiques statiques

static fromViolations (ConstraintViolation ... $violations)

Fonctions membres privées statiques

static buildMessage (array $violations)

Attributs privés

$violations = []

Documentation des fonctions membres

◆ buildMessage()

static buildMessage ( array $violations )
staticprivate
Paramètres
ConstraintViolation[] $violations
Renvoie
string

Références $message, et RequiredConstraintsViolated\$violations.

◆ fromViolations()

static fromViolations ( ConstraintViolation ... $violations )
static
Paramètres
ConstraintViolation ...$violations
Renvoie
self

Références RequiredConstraintsViolated\$violations.

Référencé par Validator\assert().

◆ violations()

violations ( )
Renvoie
ConstraintViolation[]

Références RequiredConstraintsViolated\$violations.

Documentation des champs

◆ $violations

$violations = []
private

Référencé par RequiredConstraintsViolated\buildMessage(), RequiredConstraintsViolated\fromViolations(), et RequiredConstraintsViolated\violations().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RequiredConstraintsViolated.php


Joomla CMS: Référence de la classe Validator

  • Lcobucci
  • JWT
  • Validation
  • Validator
Fonctions membres publiques | Fonctions membres privées
Référence de la classe Validator
+ Graphe d'héritage de Validator:
Validator

Fonctions membres publiques

assert (Token $token, Constraint ... $constraints)
validate (Token $token, Constraint ... $constraints)

Fonctions membres privées

checkConstraint (Constraint $constraint, Token $token, array &$violations)

Documentation des fonctions membres

◆ assert()

assert | ( | Token | $token,
 |  | Constraint ... | $constraints
 | ) |  |
Exceptions
RequiredConstraintsViolated
NoConstraintsGiven

Implémente Validator.

Références Validator\checkConstraint(), et RequiredConstraintsViolated\fromViolations().

◆ checkConstraint()

checkConstraint | ( | Constraint | $constraint,
 |  | Token | $token,
 |  | array & | $violations
 | ) |  |
private
Paramètres
ConstraintViolation[] $violations

Références Constraint\assert().

Référencé par Validator\assert().

◆ validate()

validate | ( | Token | $token,
 |  | Constraint ... | $constraints
 | ) |  |
Renvoie
bool
Exceptions
NoConstraintsGiven

Implémente Validator.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Validation/Validator.php


Joomla CMS: Référence de la classe Builder

  • Lcobucci
  • JWT
  • Builder
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Builder

Fonctions membres publiques

__construct (Encoder $encoder=null, ClaimFactory $claimFactory=null)
canOnlyBeUsedBy ($audience, $replicateAsHeader=false)
permittedFor (... $audiences)
setAudience ($audience, $replicateAsHeader=false)
expiresAt ($expiration, $replicateAsHeader=false)
setExpiration ($expiration, $replicateAsHeader=false)
identifiedBy ($id, $replicateAsHeader=false)
setId ($id, $replicateAsHeader=false)
issuedAt ($issuedAt, $replicateAsHeader=false)
setIssuedAt ($issuedAt, $replicateAsHeader=false)
issuedBy ($issuer, $replicateAsHeader=false)
setIssuer ($issuer, $replicateAsHeader=false)
canOnlyBeUsedAfter ($notBefore, $replicateAsHeader=false)
setNotBefore ($notBefore, $replicateAsHeader=false)
relatedTo ($subject, $replicateAsHeader=false)
setSubject ($subject, $replicateAsHeader=false)
withHeader ($name, $value)
setHeader ($name, $value)
with ($name, $value)
withClaim ($name, $value)
set ($name, $value)
sign (Signer $signer, $key)
unsign ()
getToken (Signer $signer=null, Key $key=null)

Fonctions membres protégées

setRegisteredClaim ($name, $value, $replicate)

Fonctions membres privées

convertToDate ($value)
configureClaim ($name, $value)
forwardCallToCorrectClaimMethod ($name, $value)
convertItems (array $items)
createSignature ($payload, Signer $signer=null, Key $key=null)

Attributs privés

$headers = ['typ'=> 'JWT'
$claims = []
$encoder
$claimFactory
$signer
$key

Description détaillée

This class makes easier the token creation process

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Encoder | $encoder = null,
 |  | ClaimFactory | $claimFactory = null
 | ) |  |

Initializes a new builder

Paramètres
Encoder | $encoder
ClaimFactory | $claimFactory

Références Builder\$claimFactory, et Builder\$encoder.

Documentation des fonctions membres

◆ canOnlyBeUsedAfter()

canOnlyBeUsedAfter | ( | $notBefore,
 |  | $replicateAsHeader = false
 | ) |

Configures the time before which the token cannot be accepted

Paramètres
int | DateTimeImmutable | $notBefore
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\convertToDate(), et Builder\setRegisteredClaim().

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setNotBefore().

◆ canOnlyBeUsedBy()

canOnlyBeUsedBy | ( | $audience,
 |  | $replicateAsHeader = false
 | ) |

Configures the audience

Obsolète:
This method has been wrongly added and doesn't exist on v4
Voir également
Builder::permittedFor()
Paramètres
string | $audience
bool | $replicateAsHeader
Renvoie
Builder

Références Builder\permittedFor().

◆ configureClaim()

configureClaim | ( | $name,
 |  | $value
 | ) |
private
Paramètres
string | $name
mixed | $value
Renvoie
Builder

Références $name, $this, et $value.

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setRegisteredClaim().

◆ convertItems()

convertItems ( array $items )
private
Paramètres
array<string,mixed> $items
Renvoie
array<string, mixed>

Références $items, $name, RegisteredClaims\AUDIENCE, et RegisteredClaims\DATE_CLAIMS.

◆ convertToDate()

convertToDate ( $value )
private
Paramètres
int | DateTimeImmutable $value
Renvoie
DateTimeImmutable

Références $value.

Référencé par Builder\canOnlyBeUsedAfter(), Builder\expiresAt(), et Builder\issuedAt().

◆ createSignature()

createSignature | ( |  | $payload,
 |  | Signer | $signer = null,
 |  | Key | $key = null
 | ) |  |
private
Paramètres
string $payload
Renvoie
Signature

Références $hash, Builder\$key, Builder\$signer, Signature\fromEmptyData(), et null.

Référencé par Builder\getToken().

◆ expiresAt()

expiresAt | ( | $expiration,
 |  | $replicateAsHeader = false
 | ) |

Configures the expiration time

Paramètres
int | DateTimeImmutable | $expiration
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\convertToDate(), et Builder\setRegisteredClaim().

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setExpiration().

◆ forwardCallToCorrectClaimMethod()

forwardCallToCorrectClaimMethod | ( | $name,
 |  | $value
 | ) |
private

Références $name, $value, RegisteredClaims\AUDIENCE, Builder\canOnlyBeUsedAfter(), Builder\configureClaim(), RegisteredClaims\EXPIRATION_TIME, Builder\expiresAt(), RegisteredClaims\ID, Builder\identifiedBy(), RegisteredClaims\ISSUED_AT, Builder\issuedAt(), Builder\issuedBy(), RegisteredClaims\ISSUER, RegisteredClaims\NOT_BEFORE, et Builder\permittedFor().

Référencé par Builder\set(), et Builder\withClaim().

◆ getToken()

getToken | ( | Signer | $signer = null,
 |  | Key | $key = null
 | ) |  |

Returns the resultant token

Renvoie
Token

Références Builder\$claims, Builder\$headers, Builder\$key, Builder\$signer, $this, Builder\createSignature(), null, et DataSet\toString().

◆ identifiedBy()

identifiedBy | ( | $id,
 |  | $replicateAsHeader = false
 | ) |

Configures the token id

Paramètres
string | $id
boolean | $replicateAsHeader
Renvoie
Builder

Références $id, et Builder\setRegisteredClaim().

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setId().

◆ issuedAt()

issuedAt | ( | $issuedAt,
 |  | $replicateAsHeader = false
 | ) |

Configures the time that the token was issued

Paramètres
int | DateTimeImmutable | $issuedAt
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\convertToDate(), et Builder\setRegisteredClaim().

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setIssuedAt().

◆ issuedBy()

issuedBy | ( | $issuer,
 |  | $replicateAsHeader = false
 | ) |

Configures the issuer

Paramètres
string | $issuer
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\setRegisteredClaim().

Référencé par Builder\forwardCallToCorrectClaimMethod(), et Builder\setIssuer().

◆ permittedFor()

permittedFor ( $audiences )

Configures the audience

Paramètres
list<string|bool> $audiences A list of audiences and, optionally, the instruction to replicate as header
Renvoie
Builder

Références RegisteredClaims\AUDIENCE, et Builder\setRegisteredClaim().

Référencé par Builder\canOnlyBeUsedBy(), Builder\forwardCallToCorrectClaimMethod(), et Builder\setAudience().

◆ relatedTo()

relatedTo | ( | $subject,
 |  | $replicateAsHeader = false
 | ) |

Configures the subject

Paramètres
string | $subject
boolean | $replicateAsHeader
Renvoie
Builder

Références $subject, et Builder\setRegisteredClaim().

Référencé par Builder\setSubject().

◆ set()

set | ( | $name,
 |  | $value
 | ) |

Configures a claim item

Obsolète:
This method will be removed on v4
Voir également
Builder::withClaim()
Paramètres
string | $name
mixed | $value
Renvoie
Builder

Références $name, $value, et Builder\forwardCallToCorrectClaimMethod().

◆ setAudience()

setAudience | ( | $audience,
 |  | $replicateAsHeader = false
 | ) |

Configures the audience

Obsolète:
This method will be removed on v4
Voir également
Builder::permittedFor()
Paramètres
string | $audience
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\permittedFor().

◆ setExpiration()

setExpiration | ( | $expiration,
 |  | $replicateAsHeader = false
 | ) |

Configures the expiration time

Obsolète:
This method will be removed on v4
Voir également
Builder::expiresAt()
Paramètres
int | DateTimeImmutable | $expiration
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\expiresAt().

◆ setHeader()

setHeader | ( | $name,
 |  | $value
 | ) |

Configures a header item

Obsolète:
This method will be removed on v4
Voir également
Builder::withHeader()
Paramètres
string | $name
mixed | $value
Renvoie
Builder

Références $name, $value, et Builder\withHeader().

◆ setId()

setId | ( | $id,
 |  | $replicateAsHeader = false
 | ) |

Configures the token id

Obsolète:
This method will be removed on v4
Voir également
Builder::identifiedBy()
Paramètres
string | $id
boolean | $replicateAsHeader
Renvoie
Builder

Références $id, et Builder\identifiedBy().

◆ setIssuedAt()

setIssuedAt | ( | $issuedAt,
 |  | $replicateAsHeader = false
 | ) |

Configures the time that the token was issued

Obsolète:
This method will be removed on v4
Voir également
Builder::issuedAt()
Paramètres
int | DateTimeImmutable | $issuedAt
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\issuedAt().

◆ setIssuer()

setIssuer | ( | $issuer,
 |  | $replicateAsHeader = false
 | ) |

Configures the issuer

Obsolète:
This method will be removed on v4
Voir également
Builder::issuedBy()
Paramètres
string | $issuer
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\issuedBy().

◆ setNotBefore()

setNotBefore | ( | $notBefore,
 |  | $replicateAsHeader = false
 | ) |

Configures the time before which the token cannot be accepted

Obsolète:
This method will be removed on v4
Voir également
Builder::canOnlyBeUsedAfter()
Paramètres
int | DateTimeImmutable | $notBefore
boolean | $replicateAsHeader
Renvoie
Builder

Références Builder\canOnlyBeUsedAfter().

◆ setRegisteredClaim()

setRegisteredClaim | ( | $name,
 |  | $value,
 |  | $replicate
 | ) |
protected

Configures a registered claim

Paramètres
string | $name
mixed | $value
boolean | $replicate
Renvoie
Builder

Références $name, $this, $value, et Builder\configureClaim().

Référencé par Builder\canOnlyBeUsedAfter(), Builder\expiresAt(), Builder\identifiedBy(), Builder\issuedAt(), Builder\issuedBy(), Builder\permittedFor(), et Builder\relatedTo().

◆ setSubject()

setSubject | ( | $subject,
 |  | $replicateAsHeader = false
 | ) |

Configures the subject

Obsolète:
This method will be removed on v4
Voir également
Builder::relatedTo()
Paramètres
string | $subject
boolean | $replicateAsHeader
Renvoie
Builder

Références $subject, et Builder\relatedTo().

◆ sign()

sign | ( | Signer | $signer,
 |  |  | $key
 | ) |  |

Signs the data

Obsolète:
This method will be removed on v4
Voir également
Builder::getToken()
Paramètres
Signer | $signer
Key | string | $key
Renvoie
Builder

Références Builder\$key, Builder\$signer, et $this.

◆ unsign()

unsign ( )

Removes the signature from the builder

Obsolète:
This method will be removed on v4
Voir également
Builder::getToken()
Renvoie
Builder

Références $this, et null.

◆ with()

with | ( | $name,
 |  | $value
 | ) |

Configures a claim item

Obsolète:
This method has been wrongly added and doesn't exist on v4
Voir également
Builder::withClaim()
Paramètres
string | $name
mixed | $value
Renvoie
Builder

Références $name, $value, et Builder\withClaim().

◆ withClaim()

withClaim | ( | $name,
 |  | $value
 | ) |

Configures a claim item

Paramètres
string | $name
mixed | $value
Renvoie
Builder
Exceptions
RegisteredClaimGiven

Références $name, $value, RegisteredClaims\ALL, et Builder\forwardCallToCorrectClaimMethod().

Référencé par Builder\with().

◆ withHeader()

withHeader | ( | $name,
 |  | $value
 | ) |

Configures a header item

Paramètres
string | $name
mixed | $value
Renvoie
Builder

Références $name, $this, et $value.

Référencé par Builder\setHeader().

Documentation des champs

◆ $claimFactory

$claimFactory
private

Référencé par Builder\__construct().

◆ $claims

$claims = []
private

Référencé par Builder\getToken().

◆ $encoder

$encoder
private

Référencé par Builder\__construct().

◆ $headers

$headers = ['typ'=> 'JWT'
private

Référencé par Builder\getToken().

◆ $key

$key
private

Référencé par Builder\createSignature(), Builder\getToken(), et Builder\sign().

◆ $signer

$signer
private

Référencé par Builder\createSignature(), Builder\getToken(), et Builder\sign().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Builder.php


Joomla CMS: Référence de l'interface Claim

  • Lcobucci
  • JWT
  • Claim
Fonctions membres publiques
Référence de l'interface Claim
+ Graphe d'héritage de Claim:
Basic EqualsTo GreaterOrEqualsTo LesserOrEqualsTo EqualsTo GreaterOrEqualsTo LesserOrEqualsTo

Fonctions membres publiques

getName ()
getValue ()
__toString ()

Description détaillée

Basic interface for token claims

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns the string representation of the claim

Renvoie
string

Implémenté dans Basic.

◆ getName()

getName ( )

Returns the claim name

Renvoie
string

Implémenté dans Basic.

◆ getValue()

getValue ( )

Returns the claim value

Renvoie
mixed

Implémenté dans Basic.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Claim.php


Joomla CMS: Référence de la classe Configuration

  • Lcobucci
  • JWT
  • Configuration
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Configuration

Fonctions membres publiques

setBuilderFactory (callable $builderFactory)
builder ()
parser ()
setParser (Parser $parser)
signer ()
signingKey ()
verificationKey ()
validator ()
setValidator (Validator $validator)
validationConstraints ()
setValidationConstraints (Constraint ... $validationConstraints)

Fonctions membres publiques statiques

static | forAsymmetricSigner (Signer $signer, Key $signingKey, Key $verificationKey, Encoder $encoder=null, Decoder $decoder=null)
static | forSymmetricSigner (Signer $signer, Key $key, Encoder $encoder=null, Decoder $decoder=null)
static | forUnsecuredSigner (Encoder $encoder=null, Decoder $decoder=null)

Fonctions membres privées

__construct (Signer $signer, Key $signingKey, Key $verificationKey, Encoder $encoder=null, Decoder $decoder=null)

Attributs privés

$parser
$signer
$signingKey
$verificationKey
$validator
$builderFactory
$validationConstraints = []

Description détaillée

Configuration container for the JWT Builder and Parser

Serves like a small DI container to simplify the creation and usage of the objects.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Signer | $signer,
 |  | Key | $signingKey,
 |  | Key | $verificationKey,
 |  | Encoder | $encoder = null,
 |  | Decoder | $decoder = null
 | ) |  |
private

Références Configuration\$signer, Configuration\$signingKey, Configuration\$verificationKey, Configuration\parser(), Configuration\signer(), Configuration\signingKey(), Configuration\validator(), et Configuration\verificationKey().

Documentation des fonctions membres

◆ builder()

builder ( )
Renvoie
Builder

Références Configuration\$builderFactory.

◆ forAsymmetricSigner()

static forAsymmetricSigner | ( | Signer | $signer,
 |  | Key | $signingKey,
 |  | Key | $verificationKey,
 |  | Encoder | $encoder = null,
 |  | Decoder | $decoder = null
 | ) |  |
static
Renvoie
self

Références Configuration\$signer, Configuration\$signingKey, et Configuration\$verificationKey.

◆ forSymmetricSigner()

static forSymmetricSigner | ( | Signer | $signer,
 |  | Key | $key,
 |  | Encoder | $encoder = null,
 |  | Decoder | $decoder = null
 | ) |  |
static
Renvoie
self

Références $key, et Configuration\$signer.

◆ forUnsecuredSigner()

static forUnsecuredSigner | ( | Encoder | $encoder = null,
 |  | Decoder | $decoder = null
 | ) |  |
static
Renvoie
self

Références $key, et InMemory\plainText().

Référencé par MetadataRepository\load().

◆ parser()

parser ( )
Renvoie
Parser

Références Configuration\$parser.

Référencé par Configuration\__construct(), et Configuration\setParser().

◆ setBuilderFactory()

setBuilderFactory ( callable $builderFactory )
Paramètres
callable() Builder $builderFactory

Références Configuration\$builderFactory.

◆ setParser()

setParser ( Parser $parser )

Références Configuration\$parser, et Configuration\parser().

◆ setValidationConstraints()

setValidationConstraints ( Constraint ... $validationConstraints )

Références Configuration\$validationConstraints, et Configuration\validationConstraints().

◆ setValidator()

setValidator ( Validator $validator )

Références Configuration\$validator, et Configuration\validator().

◆ signer()

signer ( )
Renvoie
Signer

Références Configuration\$signer.

Référencé par Configuration\__construct().

◆ signingKey()

signingKey ( )
Renvoie
Key

Références Configuration\$signingKey.

Référencé par Configuration\__construct().

◆ validationConstraints()

validationConstraints ( )
Renvoie
Constraint[]

Références Configuration\$validationConstraints.

Référencé par Configuration\setValidationConstraints().

◆ validator()

validator ( )
Renvoie
Validator

Références Configuration\$validator.

Référencé par Configuration\__construct(), et Configuration\setValidator().

◆ verificationKey()

verificationKey ( )
Renvoie
Key

Références Configuration\$verificationKey.

Référencé par Configuration\__construct().

Documentation des champs

◆ $builderFactory

$builderFactory
private

Référencé par Configuration\builder(), et Configuration\setBuilderFactory().

◆ $parser

$parser
private

Référencé par Configuration\parser(), et Configuration\setParser().

◆ $signer

$signer
private

Référencé par Configuration\__construct(), Configuration\forAsymmetricSigner(), Configuration\forSymmetricSigner(), et Configuration\signer().

◆ $signingKey

$signingKey
private

Référencé par Configuration\__construct(), Configuration\forAsymmetricSigner(), et Configuration\signingKey().

◆ $validationConstraints

$validationConstraints = []
private

Référencé par Configuration\setValidationConstraints(), et Configuration\validationConstraints().

◆ $validator

$validator
private

Référencé par Configuration\setValidator(), et Configuration\validator().

◆ $verificationKey

$verificationKey
private

Référencé par Configuration\__construct(), Configuration\forAsymmetricSigner(), et Configuration\verificationKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/lcobucci/jwt/src/Configuration.php


Joomla CMS: Référence de la classe Parser

  • Lcobucci
  • JWT
  • Parser
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Parser

Fonctions membres publiques

__construct (Decoder $decoder=null)
parse ($jwt)

Fonctions membres protégées

splitJwt ($jwt)
parseHeader ($data)
parseClaims ($data)
parseSignature (array $header, $data)

Fonctions membres privées

convertItems (array $items)

Attributs privés

$decoder

Description détaillée

This class parses the JWT strings and convert them into tokens

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Decoder $decoder = null )

Initializes the object

Paramètres
Decoder $decoder

Références Parser\$decoder.

Documentation des fonctions membres

◆ convertItems()

convertItems ( array $items )
private
Paramètres
array<string,mixed> $items
Renvoie
array<string, mixed>

Références $items, $name, RegisteredClaims\AUDIENCE, et RegisteredClaims\DATE_CLAIMS.

Référencé par Parser\parseClaims(), et Parser\parseHeader().

◆ parse()

parse ( $jwt )

Parses the JWT and returns a token

Paramètres
string $jwt
Renvoie
Token
Exceptions
InvalidArgumentException | When JWT is not a string or is invalid.
RuntimeException | When something goes wrong while decoding

Références $data, $header, $name, $value, Parser\parseClaims(), Parser\parseHeader(), Parser\parseSignature(), et Parser\splitJwt().

◆ parseClaims()

parseClaims ( $data )
protected

Parses the claim set from a string

Paramètres
string $data
Renvoie
array

Références $data, $this, et Parser\convertItems().

Référencé par Parser\parse().

◆ parseHeader()

parseHeader ( $data )
protected

Parses the header from a string

Paramètres
string $data
Renvoie
array
Exceptions
UnsupportedHeaderFound When an invalid header is informed

Références $data, $header, $this, Parser\convertItems(), et UnsupportedHeaderFound\encryption().

Référencé par Parser\parse().

◆ parseSignature()

parseSignature | ( | array | $header,
 |  |  | $data
 | ) |  |
protected

Returns the signature from given data

Paramètres
array | $header
string | $data
Renvoie
Signature

Références $data, $hash, $header, et Signature\fromEmptyData().

Référencé par Parser\parse().

◆ splitJwt()

splitJwt ( $jwt )
protected

Splits the JWT string into an array

Paramètres
string $jwt
Renvoie
array
Exceptions
InvalidArgumentException When JWT is not a string or is invalid

Références $data, et InvalidTokenStructure\missingOrNotEnoughSeparators().

Référencé par Parser\parse().

Documentation des champs

◆ $decoder

$decoder
private

Référencé par Parser\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/lcobucci/jwt/src/Parser.php


Joomla CMS: Référence de la classe Signature

  • Lcobucci
  • JWT
  • Signature
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe Signature

Fonctions membres publiques

__construct ($hash, $encoded='')
verify (Signer $signer, $payload, $key)
__toString ()
hash ()
toString ()

Fonctions membres publiques statiques

static fromEmptyData ()

Attributs protégés

$hash

Attributs privés

$encoded

Description détaillée

This class represents a token signature

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $hash,
 |  | $encoded = ''
 | ) |

Initializes the object

Paramètres
string | $hash
string | $encoded

Références Signature\$encoded, Signature\$hash, et Signature\hash().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns the current hash as a string representation of the signature

Obsolète:
This method has been removed from the public API in v4
Voir également
Signature::hash()
Renvoie
string

Références Signature\$hash.

◆ fromEmptyData()

static fromEmptyData ( )
static
Renvoie
self

Référencé par Token\__construct(), Builder\createSignature(), et Parser\parseSignature().

◆ hash()

hash ( )
Renvoie
string

Références Signature\$hash.

Référencé par Signature\__construct(), et Signature\verify().

◆ toString()

toString ( )
Renvoie
string

Références Signature\$encoded.

◆ verify()

verify | ( | Signer | $signer,
 |  |  | $payload,
 |  |  | $key
 | ) |  |

Verifies if the current hash matches with with the result of the creation of a new signature with given data

Paramètres
Signer | $signer
string | $payload
Key | string | $key
Renvoie
boolean

Références $key, Signature\hash(), et Signer\verify().

Documentation des champs

◆ $encoded

$encoded
private

Référencé par Signature\__construct(), et Signature\toString().

◆ $hash

$hash
protected

Référencé par Signature\__construct(), Signature\__toString(), et Signature\hash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • lcobucci/jwt/src/Signature.php


Joomla CMS: Référence de l'interface Signer

  • Lcobucci
  • JWT
  • Signer
Fonctions membres publiques
Référence de l'interface Signer
+ Graphe d'héritage de Signer:
BaseSigner Hmac None OpenSSL Sha256 Sha384 Sha512 Ecdsa Rsa Sha256 Sha384 Sha512 Sha256 Sha384 Sha512

Fonctions membres publiques

getAlgorithmId ()
modifyHeader (array &$headers)
sign ($payload, $key)
verify ($expected, $payload, $key)

Description détaillée

Basic interface for token signers

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des fonctions membres

◆ getAlgorithmId()

getAlgorithmId ( )

Returns the algorithm id

Renvoie
string

Implémenté dans Sha256, Sha384, Sha512, Sha256, Sha384, Sha512, Sha256, Sha384, Sha512, et None.

Référencé par BaseSigner\modifyHeader(), et Token\verify().

◆ modifyHeader()

modifyHeader ( array & $headers )

Apply changes on headers according with algorithm

Paramètres
array $headers

Implémenté dans BaseSigner.

◆ sign()

sign | ( | $payload,
 |  | $key
 | ) |

Returns a signature for given data

Paramètres
string | $payload
Key | string | $key
Renvoie
Signature
Exceptions
InvalidArgumentException When given key is invalid

Implémenté dans BaseSigner.

◆ verify()

verify | ( | $expected,
 |  | $payload,
 |  | $key
 | ) |

Returns if the expected hash matches with the data and key

Paramètres
string | $expected
string | $payload
Key | string | $key
Renvoie
boolean
Exceptions
InvalidArgumentException When given key is invalid

Implémenté dans BaseSigner.

Référencé par Signature\verify().

La documentation de cette interface a été générée à partir du fichier suivant :
  • Signer.php


Joomla CMS: Référence de la classe Token

  • Lcobucci
  • JWT
  • Token
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Token

Fonctions membres publiques

__construct ( $headers=['alg'=> 'none'], $claims=[], Signature $signature=null, array $payload=['', ''], Factory $claimFactory=null)
headers ()
getHeaders ()
hasHeader ($name)
getHeader ($name, $default=null)
claims ()
getClaims ()
hasClaim ($name)
getClaim ($name, $default=null)
verify (Signer $signer, $key)
validate (ValidationData $data)
isExpired (DateTimeInterface $now=null)
isPermittedFor ($audience)
isIdentifiedBy ($id)
isRelatedTo ($subject)
hasBeenIssuedBy (... $issuers)
hasBeenIssuedBefore (DateTimeInterface $now)
isMinimumTimeBefore (DateTimeInterface $now)
getPayload ()
payload ()
signature ()
__toString ()
toString ()

Fonctions membres privées

convertToDataSet ($data, $payload)
getValidatableClaims ()

Attributs privés

$headers
$claims
$signature
$claimFactory

Description détaillée

Basic structure of the JWT

Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
0.1.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $headers = ['alg' =,
 |  | 'none'] | ,
 |  |  | $claims = [],
 |  | Signature | $signature = null,
 |  | array | $payload = ['',
 |  | ''] | ,
 |  | Factory | $claimFactory = null
 | ) |  |

Initializes the object

Paramètres
array | DataSet | $headers
array | DataSet | $claims
Signature | null | $signature
array | $payload
Factory | null | $claimFactory

Références Token\$claimFactory, Token\$claims, Token\$headers, Token\$signature, Token\claims(), Token\convertToDataSet(), Signature\fromEmptyData(), Token\headers(), et Token\signature().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns an encoded representation of the token

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::toString()
Renvoie
string

Références Token\toString().

◆ claims()

claims ( )
Renvoie
DataSet

Références Token\$claims.

Référencé par Token\__construct(), Token\getClaim(), Token\getClaims(), Token\getHeaders(), Token\hasBeenIssuedBefore(), Token\hasBeenIssuedBy(), Token\hasClaim(), Token\isExpired(), Token\isIdentifiedBy(), Token\isMinimumTimeBefore(), Token\isPermittedFor(), Token\isRelatedTo(), Token\payload(), et Token\toString().

◆ convertToDataSet()

convertToDataSet | ( | $data,
 |  | $payload
 | ) |
private
Paramètres
array | DataSet | $data
string | $payload

Références $data.

Référencé par Token\__construct().

◆ getClaim()

getClaim | ( | $name,
 |  | $default = null
 | ) |

Returns the value of a token claim

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::claims()
DataSet::get()
Paramètres
string | $name
mixed | $default
Renvoie
mixed
Exceptions
OutOfBoundsException

Références $default, $name, $value, RegisteredClaims\AUDIENCE, Token\claims(), et RegisteredClaims\DATE_CLAIMS.

◆ getClaims()

getClaims ( )

Returns the token claim set

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::claims()
Renvoie
array

Références $items, $name, $value, et Token\claims().

Référencé par Token\getValidatableClaims().

◆ getHeader()

getHeader | ( | $name,
 |  | $default = null
 | ) |

Returns the value of a token header

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::headers()
DataSet::has()
Paramètres
string | $name
mixed | $default
Renvoie
mixed
Exceptions
OutOfBoundsException

Références $default, $name, et Token\headers().

◆ getHeaders()

getHeaders ( )

Returns the token headers

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::headers()
Renvoie
array

Références $items, $name, $value, RegisteredClaims\ALL, Token\claims(), et Token\headers().

◆ getPayload()

getPayload ( )

Returns the token payload

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::payload()
Renvoie
string

Références Token\payload().

Référencé par SignedWith\assert(), et Token\verify().

◆ getValidatableClaims()

getValidatableClaims ( )
private

Yields the validatable claims

Renvoie
Generator

Références Token\getClaims().

Référencé par Token\validate().

◆ hasBeenIssuedBefore()

hasBeenIssuedBefore ( DateTimeInterface $now )
Paramètres
DateTimeInterface $now
Renvoie
bool

Références $now, Token\claims(), et RegisteredClaims\ISSUED_AT.

Référencé par ValidAt\assertIssueTime().

◆ hasBeenIssuedBy()

hasBeenIssuedBy ( $issuers )
Paramètres
list<string> $issuers
Renvoie
bool

Références Token\claims(), et RegisteredClaims\ISSUER.

Référencé par IssuedBy\assert().

◆ hasClaim()

hasClaim ( $name )

Returns if the claim is configured

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::claims()
DataSet::has()
Paramètres
string $name
Renvoie
boolean

Références $name, et Token\claims().

◆ hasHeader()

hasHeader ( $name )

Returns if the header is configured

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Token::headers()
DataSet::has()
Paramètres
string $name
Renvoie
boolean

Références $name, et Token\headers().

◆ headers()

headers ( )
Renvoie
DataSet

Références Token\$headers.

Référencé par Token\__construct(), SignedWith\assert(), Token\getHeader(), Token\getHeaders(), Token\hasHeader(), Token\payload(), Token\toString(), et Token\verify().

◆ isExpired()

isExpired ( DateTimeInterface $now = null )

Determine if the token is expired.

Paramètres
DateTimeInterface | null $now Defaults to the current time.
Renvoie
bool

Références $now, Token\claims(), RegisteredClaims\EXPIRATION_TIME, et null.

Référencé par ValidAt\assertExpiration().

◆ isIdentifiedBy()

isIdentifiedBy ( $id )
Paramètres
string $id
Renvoie
bool

Références $id, Token\claims(), et RegisteredClaims\ID.

Référencé par IdentifiedBy\assert().

◆ isMinimumTimeBefore()

isMinimumTimeBefore ( DateTimeInterface $now )
Paramètres
DateTimeInterface $now
Renvoie
bool

Références Token\claims(), et RegisteredClaims\NOT_BEFORE.

Référencé par ValidAt\assertMinimumTime().

◆ isPermittedFor()

isPermittedFor ( $audience )
Paramètres
string $audience
Renvoie
bool

Références RegisteredClaims\AUDIENCE, et Token\claims().

Référencé par PermittedFor\assert().

◆ isRelatedTo()

isRelatedTo ( $subject )
Paramètres
string $subject
Renvoie
bool

Références $subject, Token\claims(), et RegisteredClaims\SUBJECT.

Référencé par RelatedTo\assert().

◆ payload()

payload ( )

Returns the token payload

Renvoie
string

Références Token\claims(), et Token\headers().

Référencé par Token\getPayload().

◆ signature()

signature ( )
Renvoie
Signature

Références Token\$signature.

Référencé par Token\__construct(), SignedWith\assert(), Token\toString(), et Token\verify().

◆ toString()

toString ( )
Renvoie
string

Références Token\claims(), Token\headers(), et Token\signature().

Référencé par Token\__toString().

◆ validate()

validate ( ValidationData $data )

Validates if the token is valid

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Paramètres
ValidationData $data
Renvoie
boolean

Références $data, et Token\getValidatableClaims().

◆ verify()

verify | ( | Signer | $signer,
 |  |  | $key
 | ) |  |

Verify if the key matches with the one that created the signature

Obsolète:
This method has been removed from the interface in v4.0
Voir également
Paramètres
Signer | $signer
Key | string | $key
Renvoie
boolean

Références $key, Signer\getAlgorithmId(), Token\getPayload(), Token\headers(), et Token\signature().

Documentation des champs

◆ $claimFactory

$claimFactory
private

Référencé par Token\__construct().

◆ $claims

$claims
private

Référencé par Token\__construct(), et Token\claims().

◆ $headers

$headers
private

Référencé par Token\__construct(), et Token\headers().

◆ $signature

$signature
private

Référencé par Token\__construct(), et Token\signature().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/lcobucci/jwt/src/Token.php


Joomla CMS: Référence de la classe ValidationData

  • Lcobucci
  • JWT
  • ValidationData
Fonctions membres publiques | Attributs privés
Référence de la classe ValidationData

Fonctions membres publiques

__construct ($currentTime=null, $leeway=0)
setId ($id)
setIssuer ($issuer)
setAudience ($audience)
setSubject ($subject)
setCurrentTime ($currentTime)
get ($name)
has ($name)

Attributs privés

$items
$leeway

Description détaillée

Class that wraps validation values

Obsolète:
This component has been removed from the interface in v4.0
Voir également
Auteur
Luís Otávio Cobucci Oblonczyk lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com
Depuis
2.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $currentTime = null,
 |  | $leeway = 0
 | ) |

Initializes the object

Paramètres
int | $currentTime
int | $leeway

Références ValidationData\$leeway, items, null, et ValidationData\setCurrentTime().

Documentation des fonctions membres

◆ get()

get ( $name )

Returns the requested item

Paramètres
string $name
Renvoie
mixed

Références $name, items, et null.

Référencé par EqualsTo\validate(), LesserOrEqualsTo\validate(), et GreaterOrEqualsTo\validate().

◆ has()

has ( $name )

Returns if the item is present

Paramètres
string $name
Renvoie
boolean

Références $name, et items.

◆ setAudience()

setAudience ( $audience )

Configures the audience

Paramètres
string $audience

Références items.

◆ setCurrentTime()

setCurrentTime ( $currentTime )

Configures the time that "iat", "nbf" and "exp" should be based on

Paramètres
int $currentTime

Références ValidationData\$leeway, et items.

Référencé par ValidationData\__construct().

◆ setId()

setId ( $id )

Configures the id

Paramètres
string $id

Références $id, et items.

◆ setIssuer()

setIssuer ( $issuer )

Configures the issuer

Paramètres
string $issuer

Références items.

◆ setSubject()

setSubject ( $subject )

Configures the subject

Paramètres
string $subject

Références $subject, et items.

Documentation des champs

◆ $items

$items
private

◆ $leeway

$leeway
private

Référencé par ValidationData\__construct(), et ValidationData\setCurrentTime().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ValidationData.php


Joomla CMS: Référence de l'interface Validator

  • Lcobucci
  • JWT
  • Validator
Fonctions membres publiques
Référence de l'interface Validator
+ Graphe d'héritage de Validator:
Validator

Fonctions membres publiques

assert (Token $token, Constraint ... $constraints)
validate (Token $token, Constraint ... $constraints)

Documentation des fonctions membres

◆ assert()

assert | ( | Token | $token,
 |  | Constraint ... | $constraints
 | ) |  |
Exceptions
RequiredConstraintsViolated
NoConstraintsGiven

Implémenté dans Validator.

◆ validate()

validate | ( | Token | $token,
 |  | Constraint ... | $constraints
 | ) |  |
Renvoie
bool
Exceptions
NoConstraintsGiven

Implémenté dans Validator.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Validator.php


Joomla CMS: Référence de l'interface Exception

  • Negotiation
  • Exception
  • Exception
Référence de l'interface Exception
+ Graphe d'héritage de Exception:
InvalidArgument InvalidHeader InvalidLanguage InvalidMediaType
La documentation de cette interface a été générée à partir du fichier suivant :
  • willdurand/negotiation/src/Negotiation/Exception/Exception.php


Joomla CMS: Référence de la classe InvalidArgument

  • Negotiation
  • Exception
  • InvalidArgument
Référence de la classe InvalidArgument
+ Graphe d'héritage de InvalidArgument:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidArgument.php


Joomla CMS: Référence de la classe InvalidHeader

  • Negotiation
  • Exception
  • InvalidHeader
Référence de la classe InvalidHeader
+ Graphe d'héritage de InvalidHeader:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidHeader.php


Joomla CMS: Référence de la classe InvalidLanguage

  • Negotiation
  • Exception
  • InvalidLanguage
Référence de la classe InvalidLanguage
+ Graphe d'héritage de InvalidLanguage:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidLanguage.php


Joomla CMS: Référence de la classe InvalidMediaType

  • Negotiation
  • Exception
  • InvalidMediaType
Référence de la classe InvalidMediaType
+ Graphe d'héritage de InvalidMediaType:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidMediaType.php


Joomla CMS: Référence de la classe AbstractNegotiator

  • Negotiation
  • AbstractNegotiator
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe AbstractNegotiator
+ Graphe d'héritage de AbstractNegotiator:
CharsetNegotiator EncodingNegotiator LanguageNegotiator Negotiator

Fonctions membres publiques

getBest ($header, array $priorities, $strict=false)
getOrderedElements ($header)

Fonctions membres protégées

acceptFactory ($header)
match (AcceptHeader $header, AcceptHeader $priority, $index)

Fonctions membres privées

parseHeader ($header)
findMatches (array $headerParts, array $priorities)

Documentation des fonctions membres

◆ acceptFactory()

acceptFactory ( $header )
abstractprotected
Paramètres
string $header accept header part or server priority
Renvoie
AcceptHeader Parsed header object

◆ findMatches()

findMatches | ( | array | $headerParts,
 |  | array | $priorities
 | ) |  |
private
Paramètres
AcceptHeader[] | $headerParts
Priority[] | $priorities Configured priorities
Renvoie
AcceptMatch[] Headers matched

Références null.

◆ getBest()

getBest | ( |  | $header,
 |  | array | $priorities,
 |  |  | $strict = false
 | ) |  |
Paramètres
string | $header | A string containing an Accept|Accept-* header.
array | $priorities | A set of server priorities.
Renvoie
AcceptHeader|null best matching type

Références $header, et null.

◆ getOrderedElements()

getOrderedElements ( $header )
Paramètres
string $header A string containing an Accept|Accept-* header.
Renvoie
AcceptHeader[] An ordered list of accept header elements

Références $b, $header, et $key.

◆ match()

match | ( | AcceptHeader | $header,
 |  | AcceptHeader | $priority,
 |  |  | $index
 | ) |  |
protected
Paramètres
AcceptHeader | $header
AcceptHeader | $priority
integer | $index
Renvoie
AcceptMatch|null Headers matched

Références $header, et null.

◆ parseHeader()

parseHeader ( $header )
private
Paramètres
string $header A string that contains an Accept* header.
Renvoie
AcceptHeader[]

Références $header.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractNegotiator.php


Joomla CMS: Référence de la classe Accept

  • Negotiation
  • Accept
Fonctions membres publiques | Attributs privés
Référence de la classe Accept
+ Graphe d'héritage de Accept:
BaseAccept AcceptHeader

Fonctions membres publiques

__construct ($value)
getSubPart ()
getBasePart ()
- Fonctions membres publiques hérités de BaseAccept
__construct ($value)
getNormalizedValue ()
getValue ()
getType ()
getQuality ()
getParameters ()
getParameter ($key, $default=null)
hasParameter ($key)

Attributs privés

$basePart
$subPart

Membres hérités additionnels

- Attributs protégés hérités de BaseAccept
$type

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )

Références $parts, $value, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getBasePart()

getBasePart ( )
Renvoie
string

◆ getSubPart()

getSubPart ( )
Renvoie
string

Documentation des champs

◆ $basePart

$basePart
private

◆ $subPart

$subPart
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Accept.php


Joomla CMS: Référence de la classe AcceptCharset

  • Negotiation
  • AcceptCharset
Référence de la classe AcceptCharset
+ Graphe d'héritage de AcceptCharset:
BaseAccept AcceptHeader

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseAccept
__construct ($value)
getNormalizedValue ()
getValue ()
getType ()
getQuality ()
getParameters ()
getParameter ($key, $default=null)
hasParameter ($key)
- Attributs protégés hérités de BaseAccept
$type
La documentation de cette classe a été générée à partir du fichier suivant :
  • AcceptCharset.php


Joomla CMS: Référence de la classe AcceptEncoding

  • Negotiation
  • AcceptEncoding
Référence de la classe AcceptEncoding
+ Graphe d'héritage de AcceptEncoding:
BaseAccept AcceptHeader

Membres hérités additionnels

- Fonctions membres publiques hérités de BaseAccept
__construct ($value)
getNormalizedValue ()
getValue ()
getType ()
getQuality ()
getParameters ()
getParameter ($key, $default=null)
hasParameter ($key)
- Attributs protégés hérités de BaseAccept
$type
La documentation de cette classe a été générée à partir du fichier suivant :
  • AcceptEncoding.php


Joomla CMS: Référence de l'interface AcceptHeader

  • Negotiation
  • AcceptHeader
Référence de l'interface AcceptHeader
+ Graphe d'héritage de AcceptHeader:
Accept AcceptCharset AcceptEncoding AcceptLanguage
La documentation de cette interface a été générée à partir du fichier suivant :
  • AcceptHeader.php


Joomla CMS: Référence de la classe AcceptLanguage

  • Negotiation
  • AcceptLanguage
Fonctions membres publiques | Attributs privés
Référence de la classe AcceptLanguage
+ Graphe d'héritage de AcceptLanguage:
BaseAccept AcceptHeader

Fonctions membres publiques

__construct ($value)
getSubPart ()
getBasePart ()
- Fonctions membres publiques hérités de BaseAccept
__construct ($value)
getNormalizedValue ()
getValue ()
getType ()
getQuality ()
getParameters ()
getParameter ($key, $default=null)
hasParameter ($key)

Attributs privés

$language
$script
$region

Membres hérités additionnels

- Attributs protégés hérités de BaseAccept
$type

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )

Références $parts, $value, Symfony\Contracts\Service\__construct(), elseif, et language.

Documentation des fonctions membres

◆ getBasePart()

getBasePart ( )
Renvoie
string

Références $language.

◆ getSubPart()

getSubPart ( )
Renvoie
string

Documentation des champs

◆ $language

$language
private

◆ $region

$region
private

◆ $script

$script
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AcceptLanguage.php


Joomla CMS: Référence de la classe AcceptMatch

  • Negotiation
  • AcceptMatch
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe AcceptMatch

Fonctions membres publiques

__construct ($quality, $score, $index)

Fonctions membres publiques statiques

static | compare (AcceptMatch $a, AcceptMatch $b)
static | reduce (array $carry, AcceptMatch $match)

Champs de données

$quality
$score
$index

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $quality,
 |  | $score,
 |  | $index
 | ) |

Documentation des fonctions membres

◆ compare()

static compare | ( | AcceptMatch | $a,
 |  | AcceptMatch | $b
 | ) |  |
static
Paramètres
AcceptMatch | $a
AcceptMatch | $b
Renvoie
int

Références $b.

◆ reduce()

static reduce | ( | array | $carry,
 |  | AcceptMatch | $match
 | ) |  |
static
Paramètres
array | $carry | reduced array
AcceptMatch | $match | match to be reduced
Renvoie
AcceptMatch[]

Documentation des champs

◆ $index

$index

◆ $quality

$quality

◆ $score

$score
La documentation de cette classe a été générée à partir du fichier suivant :
  • AcceptMatch.php


Joomla CMS: Référence de la classe BaseAccept

  • Negotiation
  • BaseAccept
Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe BaseAccept
+ Graphe d'héritage de BaseAccept:
Accept AcceptCharset AcceptEncoding AcceptLanguage

Fonctions membres publiques

__construct ($value)
getNormalizedValue ()
getValue ()
getType ()
getQuality ()
getParameters ()
getParameter ($key, $default=null)
hasParameter ($key)

Attributs protégés

$type

Fonctions membres privées

parseParameters ($acceptPart)
buildParametersString ($parameters)

Attributs privés

$quality = 1.0
$normalized
$value
$parameters

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )
Paramètres
string $value

Références $parameters, $type, $value, et value.

Documentation des fonctions membres

◆ buildParametersString()

buildParametersString ( $parameters )
private
Paramètres
string $parameters
Renvoie
string

Références $key, $parameters, $parts, et $val.

◆ getNormalizedValue()

getNormalizedValue ( )
Renvoie
string

◆ getParameter()

getParameter | ( | $key,
 |  | $default = null
 | ) |
Paramètres
string | $key
mixed | $default
Renvoie
string|null

Références $default, et $key.

◆ getParameters()

getParameters ( )
Renvoie
array

Références $parameters.

◆ getQuality()

getQuality ( )
Renvoie
float

◆ getType()

getType ( )
Renvoie
string

Références $type.

◆ getValue()

getValue ( )
Renvoie
string

Références $value.

◆ hasParameter()

hasParameter ( $key )
Paramètres
string $key
Renvoie
boolean

Références $key.

◆ parseParameters()

parseParameters ( $acceptPart )
private
Paramètres
string | null $acceptPart
Renvoie
array

Références $key, $parameters, $parts, $type, et null.

Documentation des champs

◆ $normalized

$normalized
private

◆ $parameters

$parameters
private

◆ $quality

$quality = 1.0
private

◆ $type

$type
protected

◆ $value

$value
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseAccept.php


Joomla CMS: Référence de la classe CharsetNegotiator

  • Negotiation
  • CharsetNegotiator
Fonctions membres protégées
Référence de la classe CharsetNegotiator
+ Graphe d'héritage de CharsetNegotiator:
AbstractNegotiator

Fonctions membres protégées

acceptFactory ($accept)
- Fonctions membres protégées hérités de AbstractNegotiator
acceptFactory ($header)
match (AcceptHeader $header, AcceptHeader $priority, $index)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractNegotiator
getBest ($header, array $priorities, $strict=false)
getOrderedElements ($header)

Documentation des fonctions membres

◆ acceptFactory()

acceptFactory ( $accept )
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • CharsetNegotiator.php


Joomla CMS: Référence de la classe EncodingNegotiator

  • Negotiation
  • EncodingNegotiator
Fonctions membres protégées
Référence de la classe EncodingNegotiator
+ Graphe d'héritage de EncodingNegotiator:
AbstractNegotiator

Fonctions membres protégées

acceptFactory ($accept)
- Fonctions membres protégées hérités de AbstractNegotiator
acceptFactory ($header)
match (AcceptHeader $header, AcceptHeader $priority, $index)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractNegotiator
getBest ($header, array $priorities, $strict=false)
getOrderedElements ($header)

Documentation des fonctions membres

◆ acceptFactory()

acceptFactory ( $accept )
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • EncodingNegotiator.php


Joomla CMS: Référence de la classe LanguageNegotiator

  • Negotiation
  • LanguageNegotiator
Fonctions membres protégées
Référence de la classe LanguageNegotiator
+ Graphe d'héritage de LanguageNegotiator:
AbstractNegotiator

Fonctions membres protégées

acceptFactory ($accept)
match (AcceptHeader $acceptLanguage, AcceptHeader $priority, $index)
- Fonctions membres protégées hérités de AbstractNegotiator
acceptFactory ($header)
match (AcceptHeader $header, AcceptHeader $priority, $index)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractNegotiator
getBest ($header, array $priorities, $strict=false)
getOrderedElements ($header)

Documentation des fonctions membres

◆ acceptFactory()

acceptFactory ( $accept )
protected

{}

◆ match()

match | ( | AcceptHeader | $acceptLanguage,
 |  | AcceptHeader | $priority,
 |  |  | $index
 | ) |  |
protected

{}

Références null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • LanguageNegotiator.php


Joomla CMS: Référence de la classe Negotiator

  • Negotiation
  • Negotiator
Fonctions membres protégées
Référence de la classe Negotiator
+ Graphe d'héritage de Negotiator:
AbstractNegotiator

Fonctions membres protégées

acceptFactory ($accept)
match (AcceptHeader $accept, AcceptHeader $priority, $index)
splitSubPart ($subPart)
- Fonctions membres protégées hérités de AbstractNegotiator
acceptFactory ($header)
match (AcceptHeader $header, AcceptHeader $priority, $index)

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractNegotiator
getBest ($header, array $priorities, $strict=false)
getOrderedElements ($header)

Documentation des fonctions membres

◆ acceptFactory()

acceptFactory ( $accept )
protected

{}

◆ match()

match | ( | AcceptHeader | $accept,
 |  | AcceptHeader | $priority,
 |  |  | $index
 | ) |  |
protected

{}

Références null.

◆ splitSubPart()

splitSubPart ( $subPart )
protected

Split a subpart into the subpart and "plus" part.

For media-types of the form "application/vnd.example+json", matching should allow wildcards for either the portion before the "+" or after. This method splits the subpart to allow such matching.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Negotiator.php


Joomla CMS: Référence de la classe HttplugFactory

  • Nyholm
  • Psr7
  • Factory
  • HttplugFactory
Fonctions membres publiques
Référence de la classe HttplugFactory
+ Graphe d'héritage de HttplugFactory:
MessageFactory StreamFactory UriFactory RequestFactory ResponseFactory

Fonctions membres publiques

createRequest ($method, $uri, array $headers=[], $body=null, $protocolVersion='1.1')
createResponse ($statusCode=200, $reasonPhrase=null, array $headers=[], $body=null, $version='1.1')
createStream ($body=null)
createUri ($uri='')

Description détaillée

Auteur
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des fonctions membres

◆ createRequest()

createRequest | ( |  | $method,
 |  |  | $uri,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  |  | $protocolVersion = '1.1'
 | ) |  |

Creates a new PSR-7 request.

Paramètres
string | $method
string | UriInterface | $uri
array | $headers
resource | string | StreamInterface | null | $body
string | $protocolVersion
Renvoie
RequestInterface

Implémente RequestFactory.

Références $method, et Nyholm\Psr7\$uri.

◆ createResponse()

createResponse | ( |  | $statusCode = 200,
 |  |  | $reasonPhrase = null,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  |  | $protocolVersion = '1.1'
 | ) |  |

Creates a new PSR-7 response.

Paramètres
int | $statusCode
string | null | $reasonPhrase
array | $headers
resource | string | StreamInterface | null | $body
string | $protocolVersion
Renvoie
ResponseInterface

Implémente ResponseFactory.

Références Symfony\Component\Console\Tester\$statusCode, et $version.

◆ createStream()

createStream ( $body = null )

Creates a new PSR-7 stream.

Paramètres
string | resource | StreamInterface | null $body
Renvoie
StreamInterface
Exceptions

Implémente StreamFactory.

Références Stream\create().

◆ createUri()

createUri ( $uri = '' )

Creates an PSR-7 URI.

Paramètres
string | UriInterface $uri
Renvoie
UriInterface
Exceptions

Implémente UriFactory.

Références Nyholm\Psr7\$uri.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HttplugFactory.php


Joomla CMS: Référence de la classe Psr17Factory

  • Nyholm
  • Psr7
  • Factory
  • Psr17Factory
Fonctions membres publiques
Référence de la classe Psr17Factory
+ Graphe d'héritage de Psr17Factory:
RequestFactoryInterface ResponseFactoryInterface ServerRequestFactoryInterface StreamFactoryInterface UploadedFileFactoryInterface UriFactoryInterface

Fonctions membres publiques

createRequest (string $method, $uri)
createResponse (int $code=200, string $reasonPhrase='')
createStream (string $content='')
createStreamFromFile (string $filename, string $mode='r')
createStreamFromResource ($resource)
createUploadedFile (StreamInterface $stream, int $size=null, int $error=\UPLOAD_ERR_OK, string $clientFilename=null, string $clientMediaType=null)
createUri (string $uri='')
createServerRequest (string $method, $uri, array $serverParams=[])

Description détaillée

Auteur
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des fonctions membres

◆ createRequest()

createRequest | ( | string | $method,
 |  |  | $uri
 | ) |  |

Create a new request.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
Renvoie
RequestInterface

Implémente RequestFactoryInterface.

Références $method, et Nyholm\Psr7\$uri.

◆ createResponse()

createResponse | ( | int | $code = 200,
 |  | string | $reasonPhrase = ''
 | ) |  |

Create a new response.

Paramètres
int | $code | HTTP status code; defaults to 200
string | $reasonPhrase | Reason phrase to associate with status code in generated response; if none is provided implementations MAY use the defaults as suggested in the HTTP specification.
Renvoie
ResponseInterface

Implémente ResponseFactoryInterface.

Références null.

◆ createServerRequest()

createServerRequest | ( | string | $method,
 |  |  | $uri,
 |  | array | $serverParams = []
 | ) |  |

Create a new server request.

Note that server-params are taken precisely as given - no parsing/processing of the given values is performed, and, in particular, no attempt is made to determine the HTTP method or URI, which must be provided explicitly.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
array | $serverParams | Array of SAPI parameters with which to seed the generated request instance.
Renvoie
ServerRequestInterface

Implémente ServerRequestFactoryInterface.

Références $method, Nyholm\Psr7\$uri, et null.

◆ createStream()

createStream ( string $content = '' )

Create a new stream from a string.

The stream SHOULD be created with a temporary resource.

Paramètres
string $content String content with which to populate the stream.
Renvoie
StreamInterface

Implémente StreamFactoryInterface.

Références $content, et Stream\create().

◆ createStreamFromFile()

createStreamFromFile | ( | string | $filename,
 |  | string | $mode = 'r'
 | ) |  |

Create a stream from an existing file.

The file MUST be opened using the given mode, which may be any mode supported by the fopen function.

The $filename MAY be any string supported by fopen().

Paramètres
string | $filename | Filename or stream URI to use as basis of stream.
string | $mode | Mode with which to open the underlying filename/stream.
Renvoie
StreamInterface
Exceptions

Implémente StreamFactoryInterface.

Références $mode, et Stream\create().

◆ createStreamFromResource()

createStreamFromResource ( $resource )

Create a new stream from an existing resource.

The stream MUST be readable and may be writable.

Paramètres
resource $resource PHP resource to use as basis of stream.
Renvoie
StreamInterface

Implémente StreamFactoryInterface.

Références Stream\create().

◆ createUploadedFile()

createUploadedFile | ( | StreamInterface | $stream,
 |  | int | $size = null,
 |  | int | $error = \UPLOAD_ERR_OK,
 |  | string | $clientFilename = null,
 |  | string | $clientMediaType = null
 | ) |  |

Create a new uploaded file.

If a size is not provided it will be determined by checking the size of the file.

Voir également
http://php.net/manual/features.file-upload.post-method.php
http://php.net/manual/features.file-upload.errors.php
Paramètres
StreamInterface | $stream | Underlying stream representing the uploaded file content.
int | $size | in bytes
int | $error | PHP file upload error
string | $clientFilename | Filename as provided by the client, if any.
string | $clientMediaType | Media type as provided by the client, if any.
Renvoie
UploadedFileInterface
Exceptions

Implémente UploadedFileFactoryInterface.

Références $size, Nyholm\Psr7\$stream, et null.

◆ createUri()

createUri ( string $uri = '' )

Create a new URI.

Paramètres
string $uri
Renvoie
UriInterface
Exceptions

Implémente UriFactoryInterface.

Références Nyholm\Psr7\$uri.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Psr17Factory.php


Joomla CMS: Référence de la classe Request

  • Nyholm
  • Psr7
  • Request
Fonctions membres publiques
Référence de la classe Request
+ Graphe d'héritage de Request:
RequestInterface MessageInterface

Fonctions membres publiques

__construct (string $method, $uri, array $headers=[], $body=null, string $version='1.1')
- Fonctions membres publiques hérités de RequestInterface
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

Auteur
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $method,
 |  |  | $uri,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  | string | $version = '1.1'
 | ) |  |
Paramètres
string | $method | HTTP method
string | UriInterface | $uri | URI
array | $headers | Request headers
string | resource | StreamInterface | null | $body | Request body
string | $version | Protocol version

Références $method, Nyholm\Psr7\$uri, $version, Stream\create(), MessageInterface\hasHeader(), method, null, Nyholm\Psr7\setHeaders(), et Nyholm\Psr7\updateHostFromUri().

La documentation de cette classe a été générée à partir du fichier suivant :
  • nyholm/psr7/src/Request.php


Joomla CMS: Référence de la classe Response

  • Nyholm
  • Psr7
  • Response
Fonctions membres publiques | Attributs privés
Référence de la classe Response
+ Graphe d'héritage de Response:
ResponseInterface MessageInterface

Fonctions membres publiques

__construct (int $status=200, array $headers=[], $body=null, string $version='1.1', string $reason=null)
getStatusCode ()
getReasonPhrase ()
withStatus ($code, $reasonPhrase='')
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Attributs privés

const PHRASES
$reasonPhrase = ''
$statusCode

Description détaillée

Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $status = 200,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  | string | $version = '1.1',
 |  | string | $reason = null
 | ) |  |
Paramètres
int | $status | Status code
array | $headers | Response headers
string | resource | StreamInterface | null | $body | Response body
string | $version | Protocol version
string | null | $reason | Reason phrase (when empty a default will be used based on the status code)

Références $version, Stream\create(), null, et Nyholm\Psr7\setHeaders().

Documentation des fonctions membres

◆ getReasonPhrase()

getReasonPhrase ( )

Gets the response reason phrase associated with the status code.

Because a reason phrase is not a required element in a response status line, the reason phrase value MAY be null. Implementations MAY choose to return the default RFC 7231 recommended reason phrase (or those listed in the IANA HTTP Status Code Registry) for the response's status code.

http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml string Reason phrase; must return an empty string if none present.

Implémente ResponseInterface.

Références Response\$reasonPhrase.

◆ getStatusCode()

getStatusCode ( )

Gets the response status code.

The status code is a 3-digit integer result code of the server's attempt to understand and satisfy the request.

Renvoie
int Status code.

Implémente ResponseInterface.

Références Response\$statusCode.

◆ withStatus()

withStatus | ( | $code,
 |  | $reasonPhrase = ''
 | ) |

Return an instance with the specified status code and, optionally, reason phrase.

If no reason phrase is specified, implementations MAY choose to default to the RFC 7231 or IANA recommended reason phrase for the response's status code.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated status and reason phrase.

http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml int $code The 3-digit integer result code to set. string $reasonPhrase The reason phrase to use with the provided status code; if none is provided, implementations MAY use the defaults as suggested in the HTTP specification. static For invalid status code arguments.

Implémente ResponseInterface.

Références Response\$reasonPhrase, $this, et null.

Documentation des champs

◆ $reasonPhrase

$reasonPhrase = ''
private

Référencé par Response\getReasonPhrase(), et Response\withStatus().

◆ $statusCode

$statusCode
private

Référencé par Response\getStatusCode().

◆ PHRASES

const PHRASES
private
Valeur initiale :
= [
100 => 'Continue'
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/nyholm/psr7/src/Response.php


Joomla CMS: Référence de la classe ServerRequest

  • Nyholm
  • Psr7
  • ServerRequest
Fonctions membres publiques | Attributs privés
Référence de la classe ServerRequest
+ Graphe d'héritage de ServerRequest:
ServerRequestInterface RequestInterface MessageInterface

Fonctions membres publiques

__construct (string $method, $uri, array $headers=[], $body=null, string $version='1.1', array $serverParams=[])
getServerParams ()
getUploadedFiles ()
withUploadedFiles (array $uploadedFiles)
getCookieParams ()
withCookieParams (array $cookies)
getQueryParams ()
withQueryParams (array $query)
getParsedBody ()
withParsedBody ($data)
getAttributes ()
getAttribute ($attribute, $default=null)
withAttribute ($attribute, $value)
withoutAttribute ($attribute)
- Fonctions membres publiques hérités de RequestInterface
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Attributs privés

$attributes = []
$cookieParams = []
$parsedBody
$queryParams = []
$serverParams
$uploadedFiles = []

Description détaillée

Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $method,
 |  |  | $uri,
 |  | array | $headers = [],
 |  |  | $body = null,
 |  | string | $version = '1.1',
 |  | array | $serverParams = []
 | ) |  |
Paramètres
string | $method | HTTP method
string | UriInterface | $uri | URI
array | $headers | Request headers
string | resource | StreamInterface | null | $body | Request body
string | $version | Protocol version
array | $serverParams | Typically the $_SERVER superglobal

Références $method, ServerRequest\$serverParams, Nyholm\Psr7\$uri, $version, Stream\create(), MessageInterface\hasHeader(), method, null, Nyholm\Psr7\setHeaders(), et Nyholm\Psr7\updateHostFromUri().

Documentation des fonctions membres

◆ getAttribute()

getAttribute | ( | $attribute,
 |  | $default = null
 | ) |
Renvoie
mixed

Implémente ServerRequestInterface.

Références $default.

◆ getAttributes()

getAttributes ( )

Retrieve attributes derived from the request.

The request "attributes" may be used to allow injection of any parameters derived from the request: e.g., the results of path match operations; the results of decrypting cookies; the results of deserializing non-form-encoded message bodies; etc. Attributes will be application and request specific, and CAN be mutable.

Renvoie
array Attributes derived from the request.

Implémente ServerRequestInterface.

Références ServerRequest\$attributes.

◆ getCookieParams()

getCookieParams ( )

Retrieve cookies.

Retrieves cookies sent by the client to the server.

The data MUST be compatible with the structure of the $_COOKIE superglobal.

Renvoie
array

Implémente ServerRequestInterface.

Références ServerRequest\$cookieParams.

◆ getParsedBody()

getParsedBody ( )

Retrieve any parameters provided in the request body.

If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, this method MUST return the contents of $_POST.

Otherwise, this method may return any results of deserializing the request body content; as parsing returns structured content, the potential types MUST be arrays or objects only. A null value indicates the absence of body content.

Renvoie
null|array|object The deserialized body parameters, if any. These will typically be an array or object.

Implémente ServerRequestInterface.

Références ServerRequest\$parsedBody.

◆ getQueryParams()

getQueryParams ( )

Retrieve query string arguments.

Retrieves the deserialized query string arguments, if any.

Note: the query params might not be in sync with the URI or server params. If you need to ensure you are only getting the original values, you may need to parse the query string from getUri()->getQuery() or from the QUERY_STRING server param.

Renvoie
array

Implémente ServerRequestInterface.

Références ServerRequest\$queryParams.

◆ getServerParams()

getServerParams ( )

Retrieve server parameters.

Retrieves data related to the incoming request environment, typically derived from PHP's $_SERVER superglobal. The data IS NOT REQUIRED to originate from $_SERVER.

Renvoie
array

Implémente ServerRequestInterface.

Références ServerRequest\$serverParams.

◆ getUploadedFiles()

getUploadedFiles ( )

Retrieve normalized file upload data.

This method returns upload metadata in a normalized tree, with each leaf an instance of Psr.

These values MAY be prepared from $_FILES or the message body during instantiation, or MAY be injected via withUploadedFiles().

Renvoie
array An array tree of UploadedFileInterface instances; an empty array MUST be returned if no data is present.

Implémente ServerRequestInterface.

Références ServerRequest\$uploadedFiles.

◆ withAttribute()

withAttribute | ( | $name,
 |  | $value
 | ) |

Return an instance with the specified derived request attribute.

This method allows setting a single derived request attribute as described in getAttributes().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated attribute.

Voir également
getAttributes()
Paramètres
string | $name | The attribute name.
mixed | $value | The value of the attribute.
Renvoie
static

Implémente ServerRequestInterface.

Références $this, et $value.

◆ withCookieParams()

withCookieParams ( array $cookies )

Return an instance with the specified cookies.

The data IS NOT REQUIRED to come from the $_COOKIE superglobal, but MUST be compatible with the structure of $_COOKIE. Typically, this data will be injected at instantiation.

This method MUST NOT update the related Cookie header of the request instance, nor related values in the server params.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated cookie values.

Paramètres
array $cookies Array of key/value pairs representing cookies.
Renvoie
static

Implémente ServerRequestInterface.

Références $this.

◆ withoutAttribute()

withoutAttribute ( $name )

Return an instance that removes the specified derived request attribute.

This method allows removing a single derived request attribute as described in getAttributes().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that removes the attribute.

Voir également
getAttributes()
Paramètres
string $name The attribute name.
Renvoie
static

Implémente ServerRequestInterface.

Références $this.

◆ withParsedBody()

withParsedBody ( $data )

Return an instance with the specified body parameters.

These MAY be injected during instantiation.

If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, use this method ONLY to inject the contents of $_POST.

The data IS NOT REQUIRED to come from $_POST, but MUST be the results of deserializing the request body content. Deserialization/parsing returns structured data, and, as such, this method ONLY accepts arrays or objects, or a null value if nothing was available to parse.

As an example, if content negotiation determines that the request data is a JSON payload, this method could be used to create a request instance with the deserialized parameters.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
null | array | object $data The deserialized body data. This will typically be in an array or object.
Renvoie
static
Exceptions

Implémente ServerRequestInterface.

Références $data, $this, et null.

◆ withQueryParams()

withQueryParams ( array $query )

Return an instance with the specified query string arguments.

These values SHOULD remain immutable over the course of the incoming request. They MAY be injected during instantiation, such as from PHP's $_GET superglobal, or MAY be derived from some other value such as the URI. In cases where the arguments are parsed from the URI, the data MUST be compatible with what PHP's parse_str() would return for purposes of how duplicate query parameters are handled, and how nested sets are handled.

Setting query string arguments MUST NOT change the URI stored by the request, nor the values in the server params.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated query string arguments.

Paramètres
array $query Array of query string arguments, typically from $_GET.
Renvoie
static

Implémente ServerRequestInterface.

Références $query, et $this.

◆ withUploadedFiles()

withUploadedFiles ( array $uploadedFiles )

Create a new instance with the specified uploaded files.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
array $uploadedFiles An array tree of UploadedFileInterface instances.
Renvoie
static
Exceptions

Implémente ServerRequestInterface.

Références $this, et ServerRequest\$uploadedFiles.

Documentation des champs

◆ $attributes

$attributes = []
private

Référencé par ServerRequest\getAttributes().

◆ $cookieParams

$cookieParams = []
private

Référencé par ServerRequest\getCookieParams().

◆ $parsedBody

$parsedBody
private

Référencé par ServerRequest\getParsedBody().

◆ $queryParams

$queryParams = []
private

Référencé par ServerRequest\getQueryParams().

◆ $serverParams

$serverParams
private

Référencé par ServerRequest\__construct(), et ServerRequest\getServerParams().

◆ $uploadedFiles

$uploadedFiles = []
private

Référencé par ServerRequest\getUploadedFiles(), et ServerRequest\withUploadedFiles().

La documentation de cette classe a été générée à partir du fichier suivant :
  • nyholm/psr7/src/ServerRequest.php


Joomla CMS: Référence de la classe Stream

  • Nyholm
  • Psr7
  • Stream
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Stream
+ Graphe d'héritage de Stream:
StreamInterface

Fonctions membres publiques

__destruct ()
__toString ()
close ()
detach ()
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=\SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Fonctions membres publiques statiques

static create ($body='')

Fonctions membres privées

const __construct ()
getUri ()

Attributs privés

$stream
$seekable
$readable
$writable
$uri
$size
const READ_WRITE_HASH

Description détaillée

Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

const __construct ( )
private

◆ __destruct()

__destruct ( )

Closes the stream when the destructed.

Références Stream\close().

Documentation des fonctions membres

◆ __toString()

__toString ( )
Renvoie
string

Implémente StreamInterface.

Références $errorHandler, Stream\getContents(), Stream\isSeekable(), null, et Stream\seek().

◆ close()

close ( )

Closes the stream and any underlying resources.

Renvoie
void

Implémente StreamInterface.

Références Stream\detach().

Référencé par Stream\__destruct().

◆ create()

static create ( $body = '' )
static

Creates a new PSR-7 stream.

Paramètres
string | resource | StreamInterface $body
Exceptions

Référencé par Request\__construct(), Response\__construct(), ServerRequest\__construct(), UploadedFile\__construct(), HttplugFactory\createStream(), Psr17Factory\createStream(), Psr17Factory\createStreamFromFile(), Psr17Factory\createStreamFromResource(), Nyholm\Psr7\getBody(), UploadedFile\getStream(), et UploadedFile\moveTo().

◆ detach()

detach ( )

Separates any underlying resources from the stream.

After the stream has been detached, the stream is in an unusable state.

Renvoie
resource|null Underlying PHP stream, if any

Implémente StreamInterface.

Références $result, Stream\$stream, et null.

Référencé par Stream\close().

◆ eof()

eof ( )

Returns true if the stream is at the end of the stream.

Renvoie
bool

Implémente StreamInterface.

◆ getContents()

getContents ( )

Returns the remaining contents in a string

Renvoie
string
Exceptions

Implémente StreamInterface.

Référencé par Stream\__toString().

◆ getMetadata()

getMetadata ( $key = null )
Renvoie
mixed

Implémente StreamInterface.

Références $key, et null.

Référencé par Stream\getUri().

◆ getSize()

getSize ( )

Get the size of the stream if known.

Renvoie
int|null Returns the size in bytes if known, or null if unknown.

Implémente StreamInterface.

Références Stream\$size, Stream\$uri, Stream\getUri(), et null.

◆ getUri()

getUri ( )
private

Références Stream\$uri, et Stream\getMetadata().

Référencé par Stream\getSize().

◆ isReadable()

isReadable ( )

Returns whether or not the stream is readable.

Renvoie
bool

Implémente StreamInterface.

Références Stream\$readable.

◆ isSeekable()

isSeekable ( )

Returns whether or not the stream is seekable.

Renvoie
bool

Implémente StreamInterface.

Références Stream\$seekable.

Référencé par Stream\__toString().

◆ isWritable()

isWritable ( )

Returns whether or not the stream is writable.

Renvoie
bool

Implémente StreamInterface.

Références Stream\$writable.

◆ read()

read ( $length )

Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions

Implémente StreamInterface.

Références $result.

◆ rewind()

rewind ( )

Seek to the beginning of the stream.

If the stream is not seekable, this method will raise an exception; otherwise, it will perform a seek(0).

Voir également
seek() on failure.

Implémente StreamInterface.

Références Stream\seek().

◆ seek()

seek | ( | $offset,
 |  | $whence = \SEEK_SET
 | ) |

Seek to a position in the stream.

int $offset Stream offset int $whence Specifies how the cursor position will be calculated based on the seek offset. Valid values are identical to the built-in PHP $whence values for fseek(). SEEK_SET: Set position equal to offset bytes SEEK_CUR: Set position to current location plus offset SEEK_END: Set position to end-of-stream plus offset. on failure.

Implémente StreamInterface.

Références Joomla\Database\Query\$offset.

Référencé par Stream\__toString(), et Stream\rewind().

◆ tell()

tell ( )

Returns the current position of the file read/write pointer

Renvoie
int Position of the file pointer
Exceptions

Implémente StreamInterface.

Références $result.

◆ write()

write ( $string )

Write data to the stream.

Paramètres
string $string The string that is to be written.
Renvoie
int Returns the number of bytes written to the stream.
Exceptions

Implémente StreamInterface.

Références $result, et null.

Documentation des champs

◆ $readable

$readable
private

Référencé par Stream\isReadable().

◆ $seekable

$seekable
private

Référencé par Stream\isSeekable().

◆ $size

$size
private

Référencé par Stream\getSize().

◆ $stream

$stream
private

Référencé par Stream\detach().

◆ $uri

$uri
private

Référencé par Stream\getSize(), et Stream\getUri().

◆ $writable

$writable
private

Référencé par Stream\isWritable().

◆ READ_WRITE_HASH

const READ_WRITE_HASH
private
Valeur initiale :
= [
'read' => [
'r' => true
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/nyholm/psr7/src/Stream.php


Joomla CMS: Référence de la classe UploadedFile

  • Nyholm
  • Psr7
  • UploadedFile
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe UploadedFile
+ Graphe d'héritage de UploadedFile:
UploadedFileInterface

Fonctions membres publiques

__construct ($streamOrFile, $size, $errorStatus, $clientFilename=null, $clientMediaType=null)
getStream ()
moveTo ($targetPath)
getSize ()
getError ()
getClientFilename ()
getClientMediaType ()

Champs de données

const UPLOAD_ERR_INI_SIZE

Fonctions membres privées

validateActive ()

Attributs privés

const ERRORS
$clientFilename
$clientMediaType
$error
$file
$moved = false
$size
$stream

Description détaillée

Auteur
Michael Dowling and contributors to guzzlehttp/psr7
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $streamOrFile,
 |  | $size,
 |  | $errorStatus,
 |  | $clientFilename = null,
 |  | $clientMediaType = null
 | ) |
Paramètres
StreamInterface | string | resource | $streamOrFile
int | $size
int | $errorStatus
string | null | $clientFilename
string | null | $clientMediaType

Références UploadedFile\$clientFilename, UploadedFile\$clientMediaType, UploadedFile\$size, Stream\create(), elseif, et null.

Documentation des fonctions membres

◆ getClientFilename()

getClientFilename ( )

Retrieve the filename sent by the client.

Do not trust the value returned by this method. A client could send a malicious filename with the intention to corrupt or hack your application.

Implementations SHOULD return the value stored in the "name" key of the file in the $_FILES array.

Renvoie
string|null The filename sent by the client or null if none was provided.

Implémente UploadedFileInterface.

Références UploadedFile\$clientFilename.

◆ getClientMediaType()

getClientMediaType ( )

Retrieve the media type sent by the client.

Do not trust the value returned by this method. A client could send a malicious media type with the intention to corrupt or hack your application.

Implementations SHOULD return the value stored in the "type" key of the file in the $_FILES array.

Renvoie
string|null The media type sent by the client or null if none was provided.

Implémente UploadedFileInterface.

Références UploadedFile\$clientMediaType.

◆ getError()

getError ( )

Retrieve the error associated with the uploaded file.

The return value MUST be one of PHP's UPLOAD_ERR_XXX constants.

If the file was uploaded successfully, this method MUST return UPLOAD_ERR_OK.

Implementations SHOULD return the value stored in the "error" key of the file in the $_FILES array.

Voir également
http://php.net/manual/en/features.file-upload.errors.php
Renvoie
int One of PHP's UPLOAD_ERR_XXX constants.

Implémente UploadedFileInterface.

Références UploadedFile\$error.

◆ getSize()

getSize ( )

Retrieve the file size.

Implementations SHOULD return the value stored in the "size" key of the file in the $_FILES array if available, as PHP calculates this based on the actual size transmitted.

Renvoie
int|null The file size in bytes or null if unknown.

Implémente UploadedFileInterface.

Références UploadedFile\$size.

◆ getStream()

getStream ( )

Retrieve a stream representing the uploaded file.

This method MUST return a StreamInterface instance, representing the uploaded file. The purpose of this method is to allow utilizing native PHP stream functionality to manipulate the file upload, such as stream_copy_to_stream() (though the result will need to be decorated in a native PHP stream wrapper to work with such functions).

If the moveTo() method has been called previously, this method MUST raise an exception.

Renvoie
StreamInterface Stream representation of the uploaded file.
Exceptions

Implémente UploadedFileInterface.

Références UploadedFile\$stream, Stream\create(), et UploadedFile\validateActive().

Référencé par UploadedFile\moveTo().

◆ moveTo()

moveTo ( $targetPath )

Move the uploaded file to a new location.

Use this method as an alternative to move_uploaded_file(). This method is guaranteed to work in both SAPI and non-SAPI environments. Implementations must determine which environment they are in, and use the appropriate method (move_uploaded_file(), rename(), or a stream operation) to perform the operation.

$targetPath may be an absolute path, or a relative path. If it is a relative path, resolution should be the same as used by PHP's rename() function.

The original file or stream MUST be removed on completion.

If this method is called more than once, any subsequent calls MUST raise an exception.

When used in an SAPI environment where $_FILES is populated, when writing files via moveTo(), is_uploaded_file() and move_uploaded_file() SHOULD be used to ensure permissions and upload status are verified correctly.

If you wish to move to a stream, use getStream(), as SAPI operations cannot guarantee writing to stream destinations.

Voir également
http://php.net/is_uploaded_file
http://php.net/move_uploaded_file
Paramètres
string $targetPath Path to which to move the uploaded file.
Exceptions

Implémente UploadedFileInterface.

Références UploadedFile\$stream, Stream\create(), UploadedFile\getStream(), null, et UploadedFile\validateActive().

◆ validateActive()

validateActive ( )
private
Exceptions

Référencé par UploadedFile\getStream(), et UploadedFile\moveTo().

Documentation des champs

◆ $clientFilename

$clientFilename
private

Référencé par UploadedFile\__construct(), et UploadedFile\getClientFilename().

◆ $clientMediaType

$clientMediaType
private

Référencé par UploadedFile\__construct(), et UploadedFile\getClientMediaType().

◆ $error

$error
private

Référencé par UploadedFile\getError().

◆ $file

$file
private

◆ $moved

$moved = false
private

◆ $size

$size
private

Référencé par UploadedFile\__construct(), et UploadedFile\getSize().

◆ $stream

$stream
private

Référencé par UploadedFile\getStream(), et UploadedFile\moveTo().

◆ ERRORS

const ERRORS
private
Valeur initiale :
= [
\UPLOAD_ERR_OK => 1

◆ UPLOAD_ERR_INI_SIZE

const UPLOAD_ERR_INI_SIZE
Valeur initiale :
=> 1,
\UPLOAD_ERR_FORM_SIZE => 1,
\UPLOAD_ERR_PARTIAL => 1,
\UPLOAD_ERR_NO_FILE => 1,
\UPLOAD_ERR_NO_TMP_DIR => 1,
\UPLOAD_ERR_CANT_WRITE => 1,
\UPLOAD_ERR_EXTENSION => 1,
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • nyholm/psr7/src/UploadedFile.php


Joomla CMS: Référence de la classe Uri

  • Nyholm
  • Psr7
  • Uri
Fonctions membres publiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe Uri
+ Graphe d'héritage de Uri:
UriInterface

Fonctions membres publiques

__construct (string $uri='')
__toString ()
getScheme ()
getAuthority ()
getUserInfo ()
getHost ()
getPort ()
getPath ()
getQuery ()
getFragment ()
withScheme ($scheme)
withUserInfo ($user, $password=null)
withHost ($host)
withPort ($port)
withPath ($path)
withQuery ($query)
withFragment ($fragment)

Fonctions membres privées

filterPort ($port)
filterPath ($path)
filterQueryAndFragment ($str)

Fonctions membres privées statiques

static | createUriString (string $scheme, string $authority, string $path, string $query, string $fragment)
static | isNonStandardPort (string $scheme, int $port)
static | rawurlencodeMatchZero (array $match)

Attributs privés

const | SCHEMES = ['http' => 80
const const | CHAR_UNRESERVED = 'a-zA-Z0-9_\-\.~'
const | CHAR_SUB_DELIMS = '!\$&\'\(\)\*\+,;='
$scheme = ''
$userInfo = ''
$host = ''
$port
$path = ''
$query = ''
$fragment = ''

Description détaillée

PSR-7 URI implementation.

Auteur
Michael Dowling
Tobias Schultze
Matthew Weier O'Phinney
Tobias Nyholm tobia.nosp@m.s.ny.nosp@m.holm@.nosp@m.gmai.nosp@m.l.com
Martijn van der Ven marti.nosp@m.jn@v.nosp@m.ander.nosp@m.ven..nosp@m.se

This class should never be extended. See https://github.com/Nyholm/psr7/blob/master/doc/final.md

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $uri = '' )

Références $parts, Nyholm\Psr7\$uri, Uri\filterPath(), Uri\filterPort(), Uri\filterQueryAndFragment(), null, et path.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Return the string representation as a URI reference.

Depending on which components of the URI are present, the resulting string is either a full URI or relative reference according to RFC 3986, Section 4.1. The method concatenates the various components of the URI, using the appropriate delimiters:

  • If a scheme is present, it MUST be suffixed by ":".
  • If an authority is present, it MUST be prefixed by "//".
  • The path can be concatenated without delimiters. But there are two cases where the path has to be adjusted to make the URI reference valid as PHP does not allow to throw an exception in __toString():
    • If the path is rootless and an authority is present, the path MUST be prefixed by "/".
    • If the path is starting with more than one "/" and no authority is present, the starting slashes MUST be reduced to one.
  • If a query is present, it MUST be prefixed by "?".
  • If a fragment is present, it MUST be prefixed by "#".
Voir également
http://tools.ietf.org/html/rfc3986#section-4.1
Renvoie
string

Implémente UriInterface.

Références Uri\getAuthority(), et path.

◆ createUriString()

static createUriString | ( | string | $scheme,
 |  | string | $authority,
 |  | string | $path,
 |  | string | $query,
 |  | string | $fragment
 | ) |  |
staticprivate

Create a URI string from its various parts.

Références Uri\$fragment, Uri\$path, Uri\$query, Uri\$scheme, Nyholm\Psr7\$uri, et elseif.

◆ filterPath()

filterPath ( $path )
private

Références Uri\$path.

Référencé par Uri\__construct(), et Uri\withPath().

◆ filterPort()

filterPort ( $port )
private

Références Uri\$port, et null.

Référencé par Uri\__construct(), et Uri\withPort().

◆ filterQueryAndFragment()

filterQueryAndFragment ( $str )
private

Référencé par Uri\__construct(), Uri\withFragment(), et Uri\withQuery().

◆ getAuthority()

getAuthority ( )

Retrieve the authority component of the URI.

If no authority information is present, this method MUST return an empty string.

The authority syntax of the URI is:

[user-info@]host[:port]

If the port component is not set or is the standard port for the current scheme, it SHOULD NOT be included.

Voir également
https://tools.ietf.org/html/rfc3986#section-3.2
Renvoie
string The URI authority, in "[user-info@]host[:port]" format.

Implémente UriInterface.

Références Uri\$host, Uri\$port, et null.

Référencé par Uri\__toString().

◆ getFragment()

getFragment ( )

Retrieve the fragment component of the URI.

If no fragment is present, this method MUST return an empty string.

The leading "#" character is not part of the fragment and MUST NOT be added.

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.5.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.5
Renvoie
string The URI fragment.

Implémente UriInterface.

Références Uri\$fragment.

◆ getHost()

getHost ( )

Retrieve the host component of the URI.

If no host is present, this method MUST return an empty string.

The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.2.2.

Voir également
http://tools.ietf.org/html/rfc3986#section-3.2.2
Renvoie
string The URI host.

Implémente UriInterface.

Références Uri\$host.

◆ getPath()

getPath ( )

Retrieve the path component of the URI.

The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.

Normally, the empty path "" and absolute path "/" are considered equal as defined in RFC 7230 Section 2.7.3. But this method MUST NOT automatically do this normalization because in contexts with a trimmed base path, e.g. the front controller, this difference becomes significant. It's the task of the user to handle both "" and "/".

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.3.

As an example, if the value should include a slash ("/") not intended as delimiter between path segments, that value MUST be passed in encoded form (e.g., "%2F") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.3
Renvoie
string The URI path.

Implémente UriInterface.

Références Uri\$path.

◆ getPort()

getPort ( )

Retrieve the port component of the URI.

If a port is present, and it is non-standard for the current scheme, this method MUST return it as an integer. If the port is the standard port used with the current scheme, this method SHOULD return null.

If no port is present, and no scheme is present, this method MUST return a null value.

If no port is present, but a scheme is present, this method MAY return the standard port for that scheme, but SHOULD return null.

Renvoie
null|int The URI port.

Implémente UriInterface.

Références Uri\$port.

◆ getQuery()

getQuery ( )

Retrieve the query string of the URI.

If no query string is present, this method MUST return an empty string.

The leading "?" character is not part of the query and MUST NOT be added.

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.4.

As an example, if a value in a key/value pair of the query string should include an ampersand ("&") not intended as a delimiter between values, that value MUST be passed in encoded form (e.g., "%26") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.4
Renvoie
string The URI query string.

Implémente UriInterface.

Références Uri\$query.

◆ getScheme()

getScheme ( )

Retrieve the scheme component of the URI.

If no scheme is present, this method MUST return an empty string.

The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.1.

The trailing ":" character is not part of the scheme and MUST NOT be added.

Voir également
https://tools.ietf.org/html/rfc3986#section-3.1
Renvoie
string The URI scheme.

Implémente UriInterface.

Références Uri\$scheme.

◆ getUserInfo()

getUserInfo ( )

Retrieve the user information component of the URI.

If no user information is present, this method MUST return an empty string.

If a user is present in the URI, this will return that value; additionally, if the password is also present, it will be appended to the user value, with a colon (":") separating the values.

The trailing "@" character is not part of the user information and MUST NOT be added.

Renvoie
string The URI user information, in "username[:password]" format.

Implémente UriInterface.

Références Uri\$userInfo.

◆ isNonStandardPort()

static isNonStandardPort | ( | string | $scheme,
 |  | int | $port
 | ) |  |
staticprivate

Is a given port non-standard for the current scheme?

Références Uri\$port, et Uri\$scheme.

◆ rawurlencodeMatchZero()

static rawurlencodeMatchZero ( array $match )
staticprivate

◆ withFragment()

withFragment ( $fragment )

Return an instance with the specified URI fragment.

This method MUST retain the state of the current instance, and return an instance that contains the specified URI fragment.

Users can provide both encoded and decoded fragment characters. Implementations ensure the correct encoding as outlined in getFragment().

An empty fragment value is equivalent to removing the fragment.

Paramètres
string $fragment The fragment to use with the new instance.
Renvoie
static A new instance with the specified fragment.

Implémente UriInterface.

Références Uri\$fragment, $this, et Uri\filterQueryAndFragment().

◆ withHost()

withHost ( $host )

Return an instance with the specified host.

This method MUST retain the state of the current instance, and return an instance that contains the specified host.

An empty host value is equivalent to removing the host.

Paramètres
string $host The hostname to use with the new instance.
Renvoie
static A new instance with the specified host.
Exceptions

Implémente UriInterface.

Références Uri\$host, et $this.

◆ withPath()

withPath ( $path )

Return an instance with the specified path.

This method MUST retain the state of the current instance, and return an instance that contains the specified path.

The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.

If the path is intended to be domain-relative rather than path relative then it must begin with a slash ("/"). Paths not starting with a slash ("/") are assumed to be relative to some base path known to the application or consumer.

Users can provide both encoded and decoded path characters. Implementations ensure the correct encoding as outlined in getPath().

Paramètres
string $path The path to use with the new instance.
Renvoie
static A new instance with the specified path.
Exceptions

Implémente UriInterface.

Références Uri\$path, $this, Uri\filterPath(), et path.

◆ withPort()

withPort ( $port )

Return an instance with the specified port.

This method MUST retain the state of the current instance, and return an instance that contains the specified port.

Implementations MUST raise an exception for ports outside the established TCP and UDP port ranges.

A null value provided for the port is equivalent to removing the port information.

Paramètres
null | int $port The port to use with the new instance; a null value removes the port information.
Renvoie
static A new instance with the specified port.
Exceptions

Implémente UriInterface.

Références Uri\$port, $this, et Uri\filterPort().

◆ withQuery()

withQuery ( $query )

Return an instance with the specified query string.

This method MUST retain the state of the current instance, and return an instance that contains the specified query string.

Users can provide both encoded and decoded query characters. Implementations ensure the correct encoding as outlined in getQuery().

An empty query string value is equivalent to removing the query string.

Paramètres
string $query The query string to use with the new instance.
Renvoie
static A new instance with the specified query string.
Exceptions

Implémente UriInterface.

Références Uri\$query, $this, et Uri\filterQueryAndFragment().

◆ withScheme()

withScheme ( $scheme )

Return an instance with the specified scheme.

This method MUST retain the state of the current instance, and return an instance that contains the specified scheme.

Implementations MUST support the schemes "http" and "https" case insensitively, and MAY accommodate other schemes if required.

An empty scheme is equivalent to removing the scheme.

Paramètres
string $scheme The scheme to use with the new instance.
Renvoie
static A new instance with the specified scheme.
Exceptions

Implémente UriInterface.

Références Uri\$scheme, et $this.

◆ withUserInfo()

withUserInfo | ( | $user,
 |  | $password = null
 | ) |

Return an instance with the specified user information.

This method MUST retain the state of the current instance, and return an instance that contains the specified user information.

Password is optional, but the user information MUST include the user; an empty string for the user is equivalent to removing user information.

Paramètres
string | $user | The user name to use for authority.
null | string | $password | The password associated with $user.
Renvoie
static A new instance with the specified user information.

Implémente UriInterface.

Références $info, $password, $this, $user, et null.

Documentation des champs

◆ $fragment

$fragment = ''
private

Référencé par Uri\createUriString(), Uri\getFragment(), et Uri\withFragment().

◆ $host

$host = ''
private

Référencé par Uri\getAuthority(), Uri\getHost(), et Uri\withHost().

◆ $path

$path = ''
private

Référencé par Uri\createUriString(), Uri\filterPath(), Uri\getPath(), et Uri\withPath().

◆ $port

$port
private

Référencé par Uri\filterPort(), Uri\getAuthority(), Uri\getPort(), Uri\isNonStandardPort(), et Uri\withPort().

◆ $query

$query = ''
private

Référencé par Uri\createUriString(), Uri\getQuery(), et Uri\withQuery().

◆ $scheme

$scheme = ''
private

Référencé par Uri\createUriString(), Uri\getScheme(), Uri\isNonStandardPort(), et Uri\withScheme().

◆ $userInfo

$userInfo = ''
private

Référencé par Uri\getUserInfo().

◆ CHAR_SUB_DELIMS

const CHAR_SUB_DELIMS = '!\$&\'\(\)\*\+,;='
private

◆ CHAR_UNRESERVED

const const CHAR_UNRESERVED = 'a-zA-Z0-9_\-\.~'
private

◆ SCHEMES

const SCHEMES = ['http' => 80
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/nyholm/psr7/src/Uri.php


Joomla CMS: Référence de la classe Base32

  • ParagonIE
  • ConstantTime
  • Base32
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Base32
+ Graphe d'héritage de Base32:
EncoderInterface Base32Hex

Fonctions membres publiques statiques

static | decode (string $encodedString, bool $strictPadding=false)
static | decodeUpper (string $src, bool $strictPadding=false)
static | encode (string $binString)
static | encodeUnpadded (string $src)
static | encodeUpper (string $src)
static | encodeUpperUnpadded (string $src)
static | decodeNoPadding (string $encodedString, bool $upper=false)

Fonctions membres protégées statiques

static | decode5Bits (int $src)
static | decode5BitsUpper (int $src)
static | encode5Bits (int $src)
static | encode5BitsUpper (int $src)

Documentation des fonctions membres

◆ decode()

static decode | ( | string | $encodedString,
 |  | bool | $strictPadding = false
 | ) |  |
static

Decode a Base32-encoded string into raw binary

Paramètres
string | $encodedString
bool | $strictPadding
Renvoie
string

Implémente EncoderInterface.

Référencé par Encoding\base32Decode(), et Encoding\base32HexDecode().

◆ decode5Bits()

static decode5Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 5-bit integers into 8-bit integers.

Paramètres
int $src
Renvoie
int

◆ decode5BitsUpper()

static decode5BitsUpper ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 5-bit integers into 8-bit integers.

Uppercase variant.

Paramètres
int $src
Renvoie
int

◆ decodeNoPadding()

static decodeNoPadding | ( | string | $encodedString,
 |  | bool | $upper = false
 | ) |  |
static
Paramètres
string | $encodedString
bool | $upper
Renvoie
string

Références Binary\safeStrlen().

◆ decodeUpper()

static decodeUpper | ( | string | $src,
 |  | bool | $strictPadding = false
 | ) |  |
static

Decode an uppercase Base32-encoded string into raw binary

Paramètres
string | $src
bool | $strictPadding
Renvoie
string

Référencé par RFC4648\base32Decode(), Encoding\base32DecodeUpper(), RFC4648\base32HexDecode(), et Encoding\base32HexDecodeUpper().

◆ encode()

static encode ( string $binString )
static

Encode into Base32 (RFC 4648)

Paramètres
string $binString
Renvoie
string
Exceptions
TypeError

Implémente EncoderInterface.

Référencé par Encoding\base32Encode(), et Encoding\base32HexEncode().

◆ encode5Bits()

static encode5Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 5-bit integers.

Paramètres
int $src
Renvoie
string

◆ encode5BitsUpper()

static encode5BitsUpper ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 5-bit integers.

Uppercase variant.

Paramètres
int $src
Renvoie
string

◆ encodeUnpadded()

static encodeUnpadded ( string $src )
static

Encode into Base32 (RFC 4648)

Paramètres
string $src
Renvoie
string
Exceptions
TypeError

◆ encodeUpper()

static encodeUpper ( string $src )
static

Encode into uppercase Base32 (RFC 4648)

Paramètres
string $src
Renvoie
string
Exceptions
TypeError

Référencé par RFC4648\base32Encode(), Encoding\base32EncodeUpper(), RFC4648\base32HexEncode(), et Encoding\base32HexEncodeUpper().

◆ encodeUpperUnpadded()

static encodeUpperUnpadded ( string $src )
static

Encode into uppercase Base32 (RFC 4648)

Paramètres
string $src
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/paragonie/constant_time_encoding/src/Base32.php


Joomla CMS: Référence de la classe Base32Hex

  • ParagonIE
  • ConstantTime
  • Base32Hex
Fonctions membres protégées statiques
Référence de la classe Base32Hex
+ Graphe d'héritage de Base32Hex:
Base32 EncoderInterface

Fonctions membres protégées statiques

static | decode5Bits (int $src)
static | decode5BitsUpper (int $src)
static | encode5Bits (int $src)
static | encode5BitsUpper (int $src)
- Fonctions membres protégées statiques hérités de Base32
static | decode5Bits (int $src)
static | decode5BitsUpper (int $src)
static | encode5Bits (int $src)
static | encode5BitsUpper (int $src)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Base32
static | decode (string $encodedString, bool $strictPadding=false)
static | decodeUpper (string $src, bool $strictPadding=false)
static | encode (string $binString)
static | encodeUnpadded (string $src)
static | encodeUpper (string $src)
static | encodeUpperUnpadded (string $src)
static | decodeNoPadding (string $encodedString, bool $upper=false)

Documentation des fonctions membres

◆ decode5Bits()

static decode5Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 5-bit integers into 8-bit integers.

Paramètres
int $src
Renvoie
int

◆ decode5BitsUpper()

static decode5BitsUpper ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 5-bit integers into 8-bit integers.

Paramètres
int $src
Renvoie
int

◆ encode5Bits()

static encode5Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 5-bit integers.

Paramètres
int $src
Renvoie
string

◆ encode5BitsUpper()

static encode5BitsUpper ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 5-bit integers.

Uppercase variant.

Paramètres
int $src
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base32Hex.php


Joomla CMS: Référence de la classe Base64

  • ParagonIE
  • ConstantTime
  • Base64
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Base64
+ Graphe d'héritage de Base64:
EncoderInterface Base64DotSlash Base64DotSlashOrdered Base64UrlSafe

Fonctions membres publiques statiques

static | encode (string $binString)
static | encodeUnpadded (string $src)
static | decodeNoPadding (string $encodedString)
- Fonctions membres publiques statiques hérités de EncoderInterface
static | decode (string $encodedString, bool $strictPadding=false)

Fonctions membres protégées statiques

static | decode6Bits (int $src)
static | encode6Bits (int $src)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [A-Z] [a-z] [0-9] + / 0x41-0x5a, 0x61-0x7a, 0x30-0x39, 0x2b, 0x2f

Paramètres
int $src
Renvoie
int

◆ decodeNoPadding()

static decodeNoPadding ( string $encodedString )
static
Paramètres
string $encodedString
Renvoie
string

Références Binary\safeStrlen().

◆ encode()

static encode ( string $binString )
static

Encode into Base64

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $binString
Renvoie
string
Exceptions
TypeError

Implémente EncoderInterface.

Référencé par RFC4648\base64Encode(), Encoding\base64Encode(), Encoding\base64EncodeDotSlash(), Encoding\base64EncodeDotSlashOrdered(), RFC4648\base64UrlSafeEncode(), X509\saveCRL(), X509\saveCSR(), X509\saveSPKAC(), X509\saveX509(), PKCS1\wrapPrivateKey(), OpenSSH\wrapPrivateKey(), PuTTY\wrapPrivateKey(), PKCS8\wrapPrivateKey(), PKCS1\wrapPublicKey(), PuTTY\wrapPublicKey(), et PKCS8\wrapPublicKey().

◆ encode6Bits()

static encode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string

◆ encodeUnpadded()

static encodeUnpadded ( string $src )
static

Encode into Base64, no = padding

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64.php


Joomla CMS: Référence de la classe Base64DotSlash

  • ParagonIE
  • ConstantTime
  • Base64DotSlash
Fonctions membres protégées statiques
Référence de la classe Base64DotSlash
+ Graphe d'héritage de Base64DotSlash:
Base64 EncoderInterface

Fonctions membres protégées statiques

static | decode6Bits (int $src)
static | encode6Bits (int $src)
- Fonctions membres protégées statiques hérités de Base64
static | decode6Bits (int $src)
static | encode6Bits (int $src)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Base64
static | encode (string $binString)
static | encodeUnpadded (string $src)
static | decodeNoPadding (string $encodedString)
- Fonctions membres publiques statiques hérités de EncoderInterface
static | decode (string $encodedString, bool $strictPadding=false)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: ./ [A-Z] [a-z] [0-9] 0x2e-0x2f, 0x41-0x5a, 0x61-0x7a, 0x30-0x39

Paramètres
int $src
Renvoie
int

◆ encode6Bits()

static encode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64DotSlash.php


Joomla CMS: Référence de la classe Base64DotSlashOrdered

  • ParagonIE
  • ConstantTime
  • Base64DotSlashOrdered
Fonctions membres protégées statiques
Référence de la classe Base64DotSlashOrdered
+ Graphe d'héritage de Base64DotSlashOrdered:
Base64 EncoderInterface

Fonctions membres protégées statiques

static | decode6Bits (int $src)
static | encode6Bits (int $src)
- Fonctions membres protégées statiques hérités de Base64
static | decode6Bits (int $src)
static | encode6Bits (int $src)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Base64
static | encode (string $binString)
static | encodeUnpadded (string $src)
static | decodeNoPadding (string $encodedString)
- Fonctions membres publiques statiques hérités de EncoderInterface
static | decode (string $encodedString, bool $strictPadding=false)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [.-9] [A-Z] [a-z] 0x2e-0x39, 0x41-0x5a, 0x61-0x7a

Paramètres
int $src
Renvoie
int

◆ encode6Bits()

static encode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64DotSlashOrdered.php


Joomla CMS: Référence de la classe Base64UrlSafe

  • ParagonIE
  • ConstantTime
  • Base64UrlSafe
Fonctions membres protégées statiques
Référence de la classe Base64UrlSafe
+ Graphe d'héritage de Base64UrlSafe:
Base64 EncoderInterface

Fonctions membres protégées statiques

static | decode6Bits (int $src)
static | encode6Bits (int $src)
- Fonctions membres protégées statiques hérités de Base64
static | decode6Bits (int $src)
static | encode6Bits (int $src)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Base64
static | encode (string $binString)
static | encodeUnpadded (string $src)
static | decodeNoPadding (string $encodedString)
- Fonctions membres publiques statiques hérités de EncoderInterface
static | decode (string $encodedString, bool $strictPadding=false)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [A-Z] [a-z] [0-9] - _ 0x41-0x5a, 0x61-0x7a, 0x30-0x39, 0x2d, 0x5f

Paramètres
int $src
Renvoie
int

◆ encode6Bits()

static encode6Bits ( int $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Base64UrlSafe.php


Joomla CMS: Référence de la classe Binary

  • ParagonIE
  • ConstantTime
  • Binary
Fonctions membres publiques statiques
Référence de la classe Binary

Fonctions membres publiques statiques

static | safeStrlen (string $str)
static | safeSubstr (string $str, int $start=0, $length=null)

Documentation des fonctions membres

◆ safeStrlen()

static safeStrlen ( string $str )
static

Safe string length

mbstring.func_overload

Paramètres
string $str
Renvoie
int

-suppress RedundantCast

Référencé par Base32\decodeNoPadding(), et Base64\decodeNoPadding().

◆ safeSubstr()

static safeSubstr | ( | string | $str,
 |  | int | $start = 0,
 |  |  | $length = null
 | ) |  |
static

Safe substring

mbstring.func_overload

boolean $exists

Paramètres
string | $str
int | $start
?int | $length
Renvoie
string
Exceptions
TypeError

Références $start, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/constant_time_encoding/src/Binary.php


Joomla CMS: Référence de l'interface EncoderInterface

  • ParagonIE
  • ConstantTime
  • EncoderInterface
Fonctions membres publiques statiques
Référence de l'interface EncoderInterface
+ Graphe d'héritage de EncoderInterface:
Base32 Base64 Hex Base32Hex Base64DotSlash Base64DotSlashOrdered Base64UrlSafe

Fonctions membres publiques statiques

static | encode (string $binString)
static | decode (string $encodedString, bool $strictPadding=false)

Documentation des fonctions membres

◆ decode()

static decode | ( | string | $encodedString,
 |  | bool | $strictPadding = false
 | ) |  |
static

Convert a binary string into a hexadecimal string without cache-timing leaks

Paramètres
string | $encodedString
bool | $strictPadding | Error on invalid padding
Renvoie
string (raw binary)

Implémenté dans Base32.

Référencé par RFC4648\base16Decode(), RFC4648\base64Decode(), Encoding\base64Decode(), Encoding\base64DecodeDotSlash(), Encoding\base64DecodeDotSlashOrdered(), RFC4648\base64UrlSafeDecode(), ASN1\extractBER(), PuTTY\generateV2Key(), Encoding\hexDecode(), Encoding\hexDecodeUpper(), OpenSSH\load(), PKCS1\load(), PuTTY\load(), et X509\loadSPKAC().

◆ encode()

static encode ( string $binString )
static

Convert a binary string into a hexadecimal string without cache-timing leaks

Paramètres
string $binString (raw binary)
Renvoie
string

Implémenté dans Base32, et Base64.

Référencé par phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), X509\getDN(), Encoding\hexEncode(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), PKCS1\wrapPrivateKey(), et PuTTY\wrapPrivateKey().

La documentation de cette interface a été générée à partir du fichier suivant :
  • EncoderInterface.php


Joomla CMS: Référence de la classe Encoding

  • ParagonIE
  • ConstantTime
  • Encoding
Fonctions membres publiques statiques
Référence de la classe Encoding

Fonctions membres publiques statiques

static | base32Encode (string $str)
static | base32EncodeUpper (string $str)
static | base32Decode (string $str)
static | base32DecodeUpper (string $str)
static | base32HexEncode (string $str)
static | base32HexEncodeUpper (string $str)
static | base32HexDecode (string $str)
static | base32HexDecodeUpper (string $str)
static | base64Encode (string $str)
static | base64Decode (string $str)
static | base64EncodeDotSlash (string $str)
static | base64DecodeDotSlash (string $str)
static | base64EncodeDotSlashOrdered (string $str)
static | base64DecodeDotSlashOrdered (string $str)
static | hexEncode (string $bin_string)
static | hexDecode (string $hex_string)
static | hexEncodeUpper (string $bin_string)
static | hexDecodeUpper (string $bin_string)

Documentation des fonctions membres

◆ base32Decode()

static base32Decode ( string $str )
static

RFC 4648 Base32 decoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decode().

◆ base32DecodeUpper()

static base32DecodeUpper ( string $str )
static

RFC 4648 Base32 decoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decodeUpper().

◆ base32Encode()

static base32Encode ( string $str )
static

RFC 4648 Base32 encoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encode().

◆ base32EncodeUpper()

static base32EncodeUpper ( string $str )
static

RFC 4648 Base32 encoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encodeUpper().

◆ base32HexDecode()

static base32HexDecode ( string $str )
static

RFC 4648 Base32Hex decoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decode().

◆ base32HexDecodeUpper()

static base32HexDecodeUpper ( string $str )
static

RFC 4648 Base32Hex decoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decodeUpper().

◆ base32HexEncode()

static base32HexEncode ( string $str )
static

RFC 4648 Base32 encoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encode().

◆ base32HexEncodeUpper()

static base32HexEncodeUpper ( string $str )
static

RFC 4648 Base32Hex encoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encodeUpper().

◆ base64Decode()

static base64Decode ( string $str )
static

RFC 4648 Base64 decoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références EncoderInterface\decode().

◆ base64DecodeDotSlash()

static base64DecodeDotSlash ( string $str )
static

Decode from base64 to raw binary

Base64 character set "./[A-Z][a-z][0-9]"

Paramètres
string $str
Renvoie
string
Exceptions

Références EncoderInterface\decode().

◆ base64DecodeDotSlashOrdered()

static base64DecodeDotSlashOrdered ( string $str )
static

Decode from base64 to raw binary

Base64 character set "[.-9][A-Z][a-z]" or "./[0-9][A-Z][a-z]"

Paramètres
string $str
Renvoie
string
Exceptions

Références EncoderInterface\decode().

◆ base64Encode()

static base64Encode ( string $str )
static

RFC 4648 Base64 encoding

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base64\encode().

◆ base64EncodeDotSlash()

static base64EncodeDotSlash ( string $str )
static

Encode into Base64

Base64 character set "./[A-Z][a-z][0-9]"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base64\encode().

◆ base64EncodeDotSlashOrdered()

static base64EncodeDotSlashOrdered ( string $str )
static

Encode into Base64

Base64 character set "[.-9][A-Z][a-z]" or "./[0-9][A-Z][a-z]"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base64\encode().

◆ hexDecode()

static hexDecode ( string $hex_string )
static

Convert a hexadecimal string into a binary string without cache-timing leaks

Paramètres
string $hex_string
Renvoie
string (raw binary)
Exceptions

Références EncoderInterface\decode().

◆ hexDecodeUpper()

static hexDecodeUpper ( string $bin_string )
static

Convert a binary string into a hexadecimal string without cache-timing leaks

Paramètres
string $bin_string (raw binary)
Renvoie
string

Références EncoderInterface\decode().

◆ hexEncode()

static hexEncode ( string $bin_string )
static

Convert a binary string into a hexadecimal string without cache-timing leaks

Paramètres
string $bin_string (raw binary)
Renvoie
string
Exceptions
TypeError

Références EncoderInterface\encode().

◆ hexEncodeUpper()

static hexEncodeUpper ( string $bin_string )
static

Convert a binary string into a hexadecimal string without cache-timing leaks

Paramètres
string $bin_string (raw binary)
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/constant_time_encoding/src/Encoding.php


Joomla CMS: Référence de la classe Hex

  • ParagonIE
  • ConstantTime
  • Hex
Référence de la classe Hex
+ Graphe d'héritage de Hex:
EncoderInterface

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de EncoderInterface
static | encode (string $binString)
static | decode (string $encodedString, bool $strictPadding=false)
La documentation de cette classe a été générée à partir du fichier suivant :
  • Hex.php


Joomla CMS: Référence de la classe RFC4648

  • ParagonIE
  • ConstantTime
  • RFC4648
Fonctions membres publiques statiques
Référence de la classe RFC4648

Fonctions membres publiques statiques

static | base64Encode (string $str)
static | base64Decode (string $str)
static | base64UrlSafeEncode (string $str)
static | base64UrlSafeDecode (string $str)
static | base32Encode (string $str)
static | base32Decode (string $str)
static | base32HexEncode (string $str)
static | base32HexDecode (string $str)
static | base16Encode (string $str)
static | base16Decode (string $str)

Documentation des fonctions membres

◆ base16Decode()

static base16Decode ( string $str )
static

RFC 4648 Base16 decoding

"666F6F" -> "foo"

Paramètres
string $str
Renvoie
string

Références EncoderInterface\decode().

◆ base16Encode()

static base16Encode ( string $str )
static

RFC 4648 Base16 decoding

"foo" -> "666F6F"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

◆ base32Decode()

static base32Decode ( string $str )
static

RFC 4648 Base32 encoding

"MZXW6===" -> "foo"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decodeUpper().

◆ base32Encode()

static base32Encode ( string $str )
static

RFC 4648 Base32 encoding

"foo" -> "MZXW6==="

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encodeUpper().

◆ base32HexDecode()

static base32HexDecode ( string $str )
static

RFC 4648 Base32-Hex decoding

"CPNMU===" -> "foo"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\decodeUpper().

◆ base32HexEncode()

static base32HexEncode ( string $str )
static

RFC 4648 Base32-Hex encoding

"foo" -> "CPNMU==="

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base32\encodeUpper().

◆ base64Decode()

static base64Decode ( string $str )
static

RFC 4648 Base64 decoding

"Zm9v" -> "foo"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références EncoderInterface\decode().

◆ base64Encode()

static base64Encode ( string $str )
static

RFC 4648 Base64 encoding

"foo" -> "Zm9v"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base64\encode().

◆ base64UrlSafeDecode()

static base64UrlSafeDecode ( string $str )
static

RFC 4648 Base64 (URL Safe) decoding

"Zm9v" -> "foo"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références EncoderInterface\decode().

◆ base64UrlSafeEncode()

static base64UrlSafeEncode ( string $str )
static

RFC 4648 Base64 (URL Safe) encoding

"foo" -> "Zm9v"

Paramètres
string $str
Renvoie
string
Exceptions
TypeError

Références Base64\encode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RFC4648.php


Joomla CMS: Référence de la classe Ctx

  • ParagonIE
  • Sodium
  • Core
  • ChaCha20
  • Ctx
Référence de la classe Ctx
+ Graphe d'héritage de Ctx:
ParagonIE_Sodium_Core_ChaCha20_Ctx ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
$container
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/ChaCha20/Ctx.php


Joomla CMS: Référence de la classe IetfCtx

  • ParagonIE
  • Sodium
  • Core
  • ChaCha20
  • IetfCtx
Référence de la classe IetfCtx
+ Graphe d'héritage de IetfCtx:
ParagonIE_Sodium_Core_ChaCha20_IetfCtx ParagonIE_Sodium_Core_ChaCha20_Ctx ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_ChaCha20_IetfCtx
__construct ($key='', $iv='', $counter='')
- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
$container
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/ChaCha20/IetfCtx.php


Joomla CMS: Référence de la classe Cached

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
  • Cached
Référence de la classe Cached
+ Graphe d'héritage de Cached:
ParagonIE_Sodium_Core_Curve25519_Ge_Cached

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Ge_Cached
__construct (ParagonIE_Sodium_Core_Curve25519_Fe $YplusX=null, ParagonIE_Sodium_Core_Curve25519_Fe $YminusX=null, ParagonIE_Sodium_Core_Curve25519_Fe $Z=null, ParagonIE_Sodium_Core_Curve25519_Fe $T2d=null)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_Ge_Cached
$YplusX
$YminusX
$Z
$T2d
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Ge/Cached.php


Joomla CMS: Référence de la classe P1p1

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
  • P1p1
Référence de la classe P1p1
+ Graphe d'héritage de P1p1:
ParagonIE_Sodium_Core_Curve25519_Ge_P1p1

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P1p1
__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null, ParagonIE_Sodium_Core_Curve25519_Fe $t=null)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P1p1
$X
$Y
$Z
$T
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Ge/P1p1.php


Joomla CMS: Référence de la classe P2

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
  • P2
Référence de la classe P2
+ Graphe d'héritage de P2:
ParagonIE_Sodium_Core_Curve25519_Ge_P2

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P2
__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P2
$X
$Y
$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Ge/P2.php


Joomla CMS: Référence de la classe P3

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
  • P3
Référence de la classe P3
+ Graphe d'héritage de P3:
ParagonIE_Sodium_Core_Curve25519_Ge_P3

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P3
__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null, ParagonIE_Sodium_Core_Curve25519_Fe $t=null)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_Ge_P3
$X
$Y
$Z
$T
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Ge/P3.php


Joomla CMS: Référence de la classe Precomp

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Ge
  • Precomp
Référence de la classe Precomp
+ Graphe d'héritage de Precomp:
ParagonIE_Sodium_Core_Curve25519_Ge_Precomp

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
__construct (ParagonIE_Sodium_Core_Curve25519_Fe $yplusx=null, ParagonIE_Sodium_Core_Curve25519_Fe $yminusx=null, ParagonIE_Sodium_Core_Curve25519_Fe $xy2d=null)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
$yplusx
$yminusx
$xy2d
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Ge/Precomp.php


Joomla CMS: Référence de la classe Fe

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • Fe
Référence de la classe Fe
+ Graphe d'héritage de Fe:
ParagonIE_Sodium_Core_Curve25519_Fe

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Curve25519_Fe
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)
__debugInfo ()
- Attributs protégés hérités de ParagonIE_Sodium_Core_Curve25519_Fe
$container = array()
$size = 10
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/Fe.php


Joomla CMS: Référence de la classe H

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
  • H
Référence de la classe H
+ Graphe d'héritage de H:
ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Curve25519/H.php


Joomla CMS: Référence de la classe State

  • ParagonIE
  • Sodium
  • Core
  • Poly1305
  • State
Référence de la classe State
+ Graphe d'héritage de State:
ParagonIE_Sodium_Core_Poly1305_State ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_Poly1305_State
__construct ($key='')
__destruct ()
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Poly1305_State
$h
$r
$pad
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés hérités de ParagonIE_Sodium_Core_Poly1305_State
$buffer = array()
$final = false
$leftover = 0
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Poly1305/State.php


Joomla CMS: Référence de la classe BLAKE2b

  • ParagonIE
  • Sodium
  • Core
  • BLAKE2b
Référence de la classe BLAKE2b
+ Graphe d'héritage de BLAKE2b:
ParagonIE_Sodium_Core_BLAKE2b ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_BLAKE2b
static | new64 ($high, $low)
static | pseudoConstructor ()
static | G ($r, $i, $a, $b, $c, $d, SplFixedArray $v, SplFixedArray $m)
static | increment_counter ($ctx, $inc)
static | update (SplFixedArray $ctx, SplFixedArray $p, $plen)
static | finish (SplFixedArray $ctx, SplFixedArray $out)
static | init ( $key=null, $outlen=64, $salt=null, $personal=null)
static | stringToSplFixedArray ($str='')
static | stringToContext ($string)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_BLAKE2b
const | BLOCKBYTES = 128
const | OUTBYTES = 64
const | KEYBYTES = 64
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_BLAKE2b
static | to64 ($num)
static | add64 ($x, $y)
static | add364 ($x, $y, $z)
static | xor64 (SplFixedArray $x, SplFixedArray $y)
static | flatten64 ($x)
static | context ()
static | compress (SplFixedArray $ctx, SplFixedArray $buf)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_BLAKE2b
static | $iv
static | $sigma
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/BLAKE2b.php


Joomla CMS: Référence de la classe ChaCha20

  • ParagonIE
  • Sodium
  • Core
  • ChaCha20
Référence de la classe ChaCha20
+ Graphe d'héritage de ChaCha20:
ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_ChaCha20
static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/namespaced/Core/ChaCha20.php


Joomla CMS: Référence de la classe Curve25519

  • ParagonIE
  • Sodium
  • Core
  • Curve25519
Référence de la classe Curve25519
+ Graphe d'héritage de Curve25519:
ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/namespaced/Core/Curve25519.php


Joomla CMS: Référence de la classe Ed25519

  • ParagonIE
  • Sodium
  • Core
  • Ed25519
Référence de la classe Ed25519
+ Graphe d'héritage de Ed25519:
ParagonIE_Sodium_Core_Ed25519 ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Ed25519
static | keypair ()
static | secretkey ($keypair)
static | publickey ($keypair)
static | pk_to_curve25519 ($pk)
static | sk_to_pk ($sk)
static | sign_detached ($message, $sk)
static | scalar_complement ($s)
static | scalar_random ()
static | scalar_negate ($s)
static | scalar_add ($a, $b)
static | scalar_sub ($x, $y)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Ed25519
const | KEYPAIR_BYTES = 96
const | SEED_BYTES = 32
const | SCALAR_BYTES = 32
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/namespaced/Core/Ed25519.php


Joomla CMS: Référence de la classe HChaCha20

  • ParagonIE
  • Sodium
  • Core
  • HChaCha20
Référence de la classe HChaCha20
+ Graphe d'héritage de HChaCha20:
ParagonIE_Sodium_Core_HChaCha20 ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_ChaCha20
static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20Bytes (array $ctx)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/HChaCha20.php


Joomla CMS: Référence de la classe HSalsa20

  • ParagonIE
  • Sodium
  • Core
  • HSalsa20
Référence de la classe HSalsa20
+ Graphe d'héritage de HSalsa20:
ParagonIE_Sodium_Core_HSalsa20 ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HSalsa20
static | hsalsa20 ($in, $k, $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Salsa20
static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/HSalsa20.php


Joomla CMS: Référence de la classe Poly1305

  • ParagonIE
  • Sodium
  • Core
  • Poly1305
Référence de la classe Poly1305
+ Graphe d'héritage de Poly1305:
ParagonIE_Sodium_Core_Poly1305 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Poly1305
static | onetimeauth ($m, $key)
static | onetimeauth_verify ($mac, $m, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Poly1305
const | BLOCK_SIZE = 16
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/Poly1305.php


Joomla CMS: Référence de la classe Salsa20

  • ParagonIE
  • Sodium
  • Core
  • Salsa20
Référence de la classe Salsa20
+ Graphe d'héritage de Salsa20:
ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Salsa20
static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/namespaced/Core/Salsa20.php


Joomla CMS: Référence de la classe SipHash

  • ParagonIE
  • Sodium
  • Core
  • SipHash
Référence de la classe SipHash
+ Graphe d'héritage de SipHash:
ParagonIE_Sodium_Core_SipHash ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_SipHash
static | sipRound (array $v)
static | rotl_64 ($int0, $int1, $c)
static | sipHash24 ($in, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/SipHash.php


Joomla CMS: Référence de la classe Util

  • ParagonIE
  • Sodium
  • Core
  • Util
Référence de la classe Util
+ Graphe d'héritage de Util:
ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/namespaced/Core/Util.php


Joomla CMS: Référence de la classe X25519

  • ParagonIE
  • Sodium
  • Core
  • X25519
Référence de la classe X25519
+ Graphe d'héritage de X25519:
ParagonIE_Sodium_Core_X25519 ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_X25519
static | fe_cswap (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g, $b=0)
static | edwards_to_montgomery (ParagonIE_Sodium_Core_Curve25519_Fe $edwardsY, ParagonIE_Sodium_Core_Curve25519_Fe $edwardsZ)
static | crypto_scalarmult_curve25519_ref10_base ($n)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/X25519.php


Joomla CMS: Référence de la classe XChaCha20

  • ParagonIE
  • Sodium
  • Core
  • XChaCha20
Référence de la classe XChaCha20
+ Graphe d'héritage de XChaCha20:
ParagonIE_Sodium_Core_XChaCha20 ParagonIE_Sodium_Core_HChaCha20 ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_XChaCha20
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len=64, $nonce='', $key='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_ChaCha20
static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20Bytes (array $ctx)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Core/XChaCha20.php


Joomla CMS: Référence de la classe Xsalsa20

  • ParagonIE
  • Sodium
  • Core
  • Xsalsa20
Référence de la classe Xsalsa20
+ Graphe d'héritage de Xsalsa20:
ParagonIE_Sodium_Core_XSalsa20 ParagonIE_Sodium_Core_HSalsa20 ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_XSalsa20
static | xsalsa20 ($len, $nonce, $key)
static | xsalsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HSalsa20
static | hsalsa20 ($in, $k, $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Salsa20
static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • Xsalsa20.php


Joomla CMS: Référence de la classe Compat

  • ParagonIE
  • Sodium
  • Compat
Référence de la classe Compat
+ Graphe d'héritage de Compat:
ParagonIE_Sodium_Compat

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Compat
static | add (&$val, $addv)
static | bin2hex ($string)
static | compare ($left, $right)
static | crypto_aead_aes256gcm_is_available ()
static | crypto_aead_aes256gcm_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_aes256gcm_keygen ()
static | crypto_aead_chacha20poly1305_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_ietf_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_keygen ()
static | crypto_aead_chacha20poly1305_ietf_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_ietf_keygen ()
static | crypto_aead_xchacha20poly1305_ietf_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='', $dontFallback=false)
static | crypto_aead_xchacha20poly1305_ietf_encrypt ( $plaintext='', $assocData='', $nonce='', $key='', $dontFallback=false)
static | crypto_aead_xchacha20poly1305_ietf_keygen ()
static | crypto_auth ($message, $key)
static | crypto_auth_keygen ()
static | crypto_auth_verify ($mac, $message, $key)
static | crypto_box ($plaintext, $nonce, $keypair)
static | crypto_box_seal ($plaintext, $publicKey)
static | crypto_box_seal_open ($ciphertext, $keypair)
static | crypto_box_keypair ()
static | crypto_box_keypair_from_secretkey_and_publickey ($secretKey, $publicKey)
static | crypto_box_open ($ciphertext, $nonce, $keypair)
static | crypto_box_publickey ($keypair)
static | crypto_box_publickey_from_secretkey ($secretKey)
static | crypto_box_secretkey ($keypair)
static | crypto_box_seed_keypair ($seed)
static | crypto_generichash ($message, $key='', $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_final (&$ctx, $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_init ($key='', $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_init_salt_personal ( $key='', $length=self::CRYPTO_GENERICHASH_BYTES, $salt='', $personal='')
static | crypto_generichash_update (&$ctx, $message)
static | crypto_generichash_keygen ()
static | crypto_kdf_derive_from_key ( $subkey_len, $subkey_id, $context, $key)
static | crypto_kdf_keygen ()
static | crypto_kx ($my_secret, $their_public, $client_public, $server_public, $dontFallback=false)
static | crypto_kx_seed_keypair ($seed)
static | crypto_kx_keypair ()
static | crypto_kx_client_session_keys ($keypair, $serverPublicKey)
static | crypto_kx_server_session_keys ($keypair, $clientPublicKey)
static | crypto_kx_secretkey ($kp)
static | crypto_kx_publickey ($kp)
static | crypto_pwhash ($outlen, $passwd, $salt, $opslimit, $memlimit, $alg=null)
static | crypto_pwhash_is_available ()
static | crypto_pwhash_str ($passwd, $opslimit, $memlimit)
static | crypto_pwhash_str_verify ($passwd, $hash)
static | crypto_pwhash_scryptsalsa208sha256 ($outlen, $passwd, $salt, $opslimit, $memlimit)
static | crypto_pwhash_scryptsalsa208sha256_is_available ()
static | crypto_pwhash_scryptsalsa208sha256_str ($passwd, $opslimit, $memlimit)
static | crypto_pwhash_scryptsalsa208sha256_str_verify ($passwd, $hash)
static | crypto_scalarmult ($secretKey, $publicKey)
static | crypto_scalarmult_base ($secretKey)
static | crypto_secretbox ($plaintext, $nonce, $key)
static | crypto_secretbox_open ($ciphertext, $nonce, $key)
static | crypto_secretbox_keygen ()
static | crypto_secretbox_xchacha20poly1305 ($plaintext, $nonce, $key)
static | crypto_secretbox_xchacha20poly1305_open ($ciphertext, $nonce, $key)
static | crypto_secretstream_xchacha20poly1305_init_push ($key)
static | crypto_secretstream_xchacha20poly1305_init_pull ($header, $key)
static | crypto_secretstream_xchacha20poly1305_push (&$state, $msg, $aad='', $tag=0)
static | crypto_secretstream_xchacha20poly1305_pull (&$state, $msg, $aad='')
static | crypto_secretstream_xchacha20poly1305_keygen ()
static | crypto_secretstream_xchacha20poly1305_rekey (&$state)
static | crypto_shorthash ($message, $key)
static | crypto_shorthash_keygen ()
static | crypto_sign ($message, $secretKey)
static | crypto_sign_open ($signedMessage, $publicKey)
static | crypto_sign_keypair ()
static | crypto_sign_keypair_from_secretkey_and_publickey ($sk, $pk)
static | crypto_sign_seed_keypair ($seed)
static | crypto_sign_publickey ($keypair)
static | crypto_sign_publickey_from_secretkey ($secretKey)
static | crypto_sign_secretkey ($keypair)
static | crypto_sign_detached ($message, $secretKey)
static | crypto_sign_verify_detached ($signature, $message, $publicKey)
static | crypto_sign_ed25519_pk_to_curve25519 ($pk)
static | crypto_sign_ed25519_sk_to_curve25519 ($sk)
static | crypto_stream ($len, $nonce, $key)
static | crypto_stream_xor ($message, $nonce, $key)
static | crypto_stream_keygen ()
static | crypto_stream_xchacha20 ($len, $nonce, $key, $dontFallback=false)
static | crypto_stream_xchacha20_xor ($message, $nonce, $key, $dontFallback=false)
static | crypto_stream_xchacha20_keygen ()
static | hex2bin ($string)
static | increment (&$var)
static | is_zero ($str)
static | library_version_major ()
static | library_version_minor ()
static | memzero (&$var)
static | unpad ($padded, $blockSize, $dontFallback=false)
static | polyfill_is_fast ()
static | randombytes_uniform ($range)
static | randombytes_random16 ()
static | ristretto255_is_valid_point ($p, $dontFallback=false)
static | ristretto255_add ($p, $q, $dontFallback=false)
static | ristretto255_sub ($p, $q, $dontFallback=false)
static | ristretto255_from_hash ($r, $dontFallback=false)
static | ristretto255_random ($dontFallback=false)
static | ristretto255_scalar_random ($dontFallback=false)
static | ristretto255_scalar_invert ($s, $dontFallback=false)
static | ristretto255_scalar_negate ($s, $dontFallback=false)
static | ristretto255_scalar_complement ($s, $dontFallback=false)
static | ristretto255_scalar_add ($x, $y, $dontFallback=false)
static | ristretto255_scalar_sub ($x, $y, $dontFallback=false)
static | ristretto255_scalar_mul ($x, $y, $dontFallback=false)
static | scalarmult_ristretto255 ($n, $p, $dontFallback=false)
static | scalarmult_ristretto255_base ($n, $dontFallback=false)
static | ristretto255_scalar_reduce ($s, $dontFallback=false)
static | sub (&$val, $addv)
static | version_string ()
- Champs de données hérités de ParagonIE_Sodium_Compat
const | LIBRARY_MAJOR_VERSION = 9
const | LIBRARY_MINOR_VERSION = 1
const | LIBRARY_VERSION_MAJOR = 9
const | LIBRARY_VERSION_MINOR = 1
const | VERSION_STRING = 'polyfill-1.0.8'
const | BASE64_VARIANT_ORIGINAL = 1
const | BASE64_VARIANT_ORIGINAL_NO_PADDING = 3
const | BASE64_VARIANT_URLSAFE = 5
const | BASE64_VARIANT_URLSAFE_NO_PADDING = 7
const | CRYPTO_AEAD_AES256GCM_KEYBYTES = 32
const | CRYPTO_AEAD_AES256GCM_NSECBYTES = 0
const | CRYPTO_AEAD_AES256GCM_NPUBBYTES = 12
const | CRYPTO_AEAD_AES256GCM_ABYTES = 16
const | CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = 32
const | CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = 0
const | CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = 8
const | CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = 16
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = 32
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = 0
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = 12
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = 16
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES = 32
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES = 0
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES = 24
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES = 16
const | CRYPTO_AUTH_BYTES = 32
const | CRYPTO_AUTH_KEYBYTES = 32
const | CRYPTO_BOX_SEALBYTES = 16
const | CRYPTO_BOX_SECRETKEYBYTES = 32
const | CRYPTO_BOX_PUBLICKEYBYTES = 32
const | CRYPTO_BOX_KEYPAIRBYTES = 64
const | CRYPTO_BOX_MACBYTES = 16
const | CRYPTO_BOX_NONCEBYTES = 24
const | CRYPTO_BOX_SEEDBYTES = 32
const | CRYPTO_CORE_RISTRETTO255_BYTES = 32
const | CRYPTO_CORE_RISTRETTO255_SCALARBYTES = 32
const | CRYPTO_CORE_RISTRETTO255_HASHBYTES = 64
const | CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES = 64
const | CRYPTO_KDF_BYTES_MIN = 16
const | CRYPTO_KDF_BYTES_MAX = 64
const | CRYPTO_KDF_CONTEXTBYTES = 8
const | CRYPTO_KDF_KEYBYTES = 32
const | CRYPTO_KX_BYTES = 32
const | CRYPTO_KX_PRIMITIVE = 'x25519blake2b'
const | CRYPTO_KX_SEEDBYTES = 32
const | CRYPTO_KX_KEYPAIRBYTES = 64
const | CRYPTO_KX_PUBLICKEYBYTES = 32
const | CRYPTO_KX_SECRETKEYBYTES = 32
const | CRYPTO_KX_SESSIONKEYBYTES = 32
const | CRYPTO_GENERICHASH_BYTES = 32
const | CRYPTO_GENERICHASH_BYTES_MIN = 16
const | CRYPTO_GENERICHASH_BYTES_MAX = 64
const | CRYPTO_GENERICHASH_KEYBYTES = 32
const | CRYPTO_GENERICHASH_KEYBYTES_MIN = 16
const | CRYPTO_GENERICHASH_KEYBYTES_MAX = 64
const | CRYPTO_PWHASH_SALTBYTES = 16
const | CRYPTO_PWHASH_STRPREFIX = '$argon2id$'
const | CRYPTO_PWHASH_ALG_ARGON2I13 = 1
const | CRYPTO_PWHASH_ALG_ARGON2ID13 = 2
const | CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE = 33554432
const | CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE = 4
const | CRYPTO_PWHASH_MEMLIMIT_MODERATE = 134217728
const | CRYPTO_PWHASH_OPSLIMIT_MODERATE = 6
const | CRYPTO_PWHASH_MEMLIMIT_SENSITIVE = 536870912
const | CRYPTO_PWHASH_OPSLIMIT_SENSITIVE = 8
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES = 32
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX = '$7$'
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE = 534288
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE = 16777216
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE = 33554432
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE = 1073741824
const | CRYPTO_SCALARMULT_BYTES = 32
const | CRYPTO_SCALARMULT_SCALARBYTES = 32
const | CRYPTO_SCALARMULT_RISTRETTO255_BYTES = 32
const | CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES = 32
const | CRYPTO_SHORTHASH_BYTES = 8
const | CRYPTO_SHORTHASH_KEYBYTES = 16
const | CRYPTO_SECRETBOX_KEYBYTES = 32
const | CRYPTO_SECRETBOX_MACBYTES = 16
const | CRYPTO_SECRETBOX_NONCEBYTES = 24
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES = 17
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES = 24
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES = 32
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH = 0
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL = 1
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY = 2
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL = 3
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX = 0x3fffffff80
const | CRYPTO_SIGN_BYTES = 64
const | CRYPTO_SIGN_SEEDBYTES = 32
const | CRYPTO_SIGN_PUBLICKEYBYTES = 32
const | CRYPTO_SIGN_SECRETKEYBYTES = 64
const | CRYPTO_SIGN_KEYPAIRBYTES = 96
const | CRYPTO_STREAM_KEYBYTES = 32
const | CRYPTO_STREAM_NONCEBYTES = 24
const | CRYPTO_STREAM_XCHACHA20_KEYBYTES = 32
const | CRYPTO_STREAM_XCHACHA20_NONCEBYTES = 24
- Attributs publics statiques hérités de ParagonIE_Sodium_Compat
static | $disableFallbackForUnitTests = false
static | $fastMult = false
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Compat
static | use_fallback ($sodium_func_name='')
static | useNewSodiumAPI ()
La documentation de cette classe a été générée à partir du fichier suivant :
  • namespaced/Compat.php


Joomla CMS: Référence de la classe Crypto

  • ParagonIE
  • Sodium
  • Crypto
Référence de la classe Crypto
+ Graphe d'héritage de Crypto:
ParagonIE_Sodium_Crypto

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Crypto
static | aead_xchacha20poly1305_ietf_decrypt ( $message='', $ad='', $nonce='', $key='')
static | aead_xchacha20poly1305_ietf_encrypt ( $message='', $ad='', $nonce='', $key='')
static | auth ($message, $key)
static | auth_verify ($mac, $message, $key)
static | box ($plaintext, $nonce, $keypair)
static | box_beforenm ($sk, $pk)
static | box_keypair ()
static | box_seed_keypair ($seed)
static | box_keypair_from_secretkey_and_publickey ($sKey, $pKey)
static | box_secretkey ($keypair)
static | box_publickey ($keypair)
static | box_publickey_from_secretkey ($sKey)
static | box_open ($ciphertext, $nonce, $keypair)
static | keyExchange ($my_sk, $their_pk, $client_pk, $server_pk)
static | scalarmult ($sKey, $pKey)
static | scalarmult_base ($secret)
static | secretstream_xchacha20poly1305_init_push ($key)
static | secretstream_xchacha20poly1305_init_pull ($key, $header)
static | secretstream_xchacha20poly1305_rekey (&$state)
static | sign_detached ($message, $sk)
static | sign ($message, $sk)
static | sign_open ($signedMessage, $pk)
static | sign_verify_detached ($signature, $message, $pk)
- Champs de données hérités de ParagonIE_Sodium_Crypto
const | aead_chacha20poly1305_KEYBYTES = 32
const | aead_chacha20poly1305_NSECBYTES = 0
const | aead_chacha20poly1305_NPUBBYTES = 8
const | aead_chacha20poly1305_ABYTES = 16
const | aead_chacha20poly1305_IETF_KEYBYTES = 32
const | aead_chacha20poly1305_IETF_NSECBYTES = 0
const | aead_chacha20poly1305_IETF_NPUBBYTES = 12
const | aead_chacha20poly1305_IETF_ABYTES = 16
const | aead_xchacha20poly1305_IETF_KEYBYTES = 32
const | aead_xchacha20poly1305_IETF_NSECBYTES = 0
const | aead_xchacha20poly1305_IETF_NPUBBYTES = 24
const | aead_xchacha20poly1305_IETF_ABYTES = 16
const | box_curve25519xsalsa20poly1305_SEEDBYTES = 32
const | box_curve25519xsalsa20poly1305_PUBLICKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_SECRETKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_BEFORENMBYTES = 32
const | box_curve25519xsalsa20poly1305_NONCEBYTES = 24
const | box_curve25519xsalsa20poly1305_MACBYTES = 16
const | box_curve25519xsalsa20poly1305_BOXZEROBYTES = 16
const | box_curve25519xsalsa20poly1305_ZEROBYTES = 32
const | onetimeauth_poly1305_BYTES = 16
const | onetimeauth_poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_NONCEBYTES = 24
const | secretbox_xsalsa20poly1305_MACBYTES = 16
const | secretbox_xsalsa20poly1305_BOXZEROBYTES = 16
const | secretbox_xsalsa20poly1305_ZEROBYTES = 32
const | secretbox_xchacha20poly1305_KEYBYTES = 32
const | secretbox_xchacha20poly1305_NONCEBYTES = 24
const | secretbox_xchacha20poly1305_MACBYTES = 16
const | secretbox_xchacha20poly1305_BOXZEROBYTES = 16
const | secretbox_xchacha20poly1305_ZEROBYTES = 32
const | stream_salsa20_KEYBYTES = 32
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Crypto
static | scalarmult_throw_if_zero ($q)
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/paragonie/sodium_compat/namespaced/Crypto.php


Joomla CMS: Référence de la classe File

  • ParagonIE
  • Sodium
  • File
Référence de la classe File
+ Graphe d'héritage de File:
ParagonIE_Sodium_File ParagonIE_Sodium_Core_Util

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_File
const | BUFFER_SIZE = 8192
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_File
static | box_encrypt ($ifp, $ofp, $mlen, $nonce, $boxKeypair)
static | box_decrypt ($ifp, $ofp, $mlen, $nonce, $boxKeypair)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/paragonie/sodium_compat/namespaced/File.php


Joomla CMS: Référence de la classe Exception

  • PHPMailer
  • PHPMailer
  • Exception
Fonctions membres publiques
Référence de la classe Exception
+ Graphe d'héritage de Exception:

Fonctions membres publiques

errorMessage ()

Description détaillée

PHPMailer exception handler.

Auteur
Marcus Bointon phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k

Documentation des fonctions membres

◆ errorMessage()

errorMessage ( )

Prettify error message output.

Renvoie
string

Références ENT_COMPAT.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpmailer/phpmailer/src/Exception.php


Joomla CMS: Référence de la classe OAuth

  • PHPMailer
  • PHPMailer
  • OAuth
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe OAuth
+ Graphe d'héritage de OAuth:
OAuthTokenProvider

Fonctions membres publiques

__construct ($options)
getOauth64 ()

Fonctions membres protégées

getGrant ()
getToken ()

Attributs protégés

$provider
$oauthToken
$oauthUserEmail = ''
$oauthClientSecret = ''
$oauthClientId = ''
$oauthRefreshToken = ''

Description détaillée

OAuth - OAuth2 authentication wrapper class. Uses the oauth2-client package from the League of Extraordinary Packages.

Voir également
http://oauth2-client.thephpleague.com
Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $options )

OAuth constructor.

Paramètres
array $options Associative array containing provider, userName, clientSecret, clientId and refreshToken elements

Références $options.

Documentation des fonctions membres

◆ getGrant()

getGrant ( )
protected

Get a new RefreshToken.

Renvoie
RefreshToken

Référencé par OAuth\getToken().

◆ getOauth64()

getOauth64 ( )

Generate a base64-encoded OAuth token.

Renvoie
string

Implémente OAuthTokenProvider.

Références OAuth\getToken(), et null.

◆ getToken()

getToken ( )
protected

Get a new AccessToken.

Renvoie
AccessToken

Références OAuth\getGrant().

Référencé par OAuth\getOauth64().

Documentation des champs

◆ $oauthClientId

$oauthClientId = ''
protected

◆ $oauthClientSecret

$oauthClientSecret = ''
protected

◆ $oauthRefreshToken

$oauthRefreshToken = ''
protected

◆ $oauthToken

$oauthToken
protected

◆ $oauthUserEmail

$oauthUserEmail = ''
protected

◆ $provider

$provider
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • OAuth.php


Joomla CMS: Référence de l'interface OAuthTokenProvider

  • PHPMailer
  • PHPMailer
  • OAuthTokenProvider
Fonctions membres publiques
Référence de l'interface OAuthTokenProvider
+ Graphe d'héritage de OAuthTokenProvider:
OAuth

Fonctions membres publiques

getOauth64 ()

Description détaillée

OAuthTokenProvider - OAuth2 token provider interface. Provides base64 encoded OAuth2 auth strings for SMTP authentication.

Voir également
OAuth
SMTP::authenticate()
Auteur
Peter Scopes (pdscopes)
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k

Documentation des fonctions membres

◆ getOauth64()

getOauth64 ( )

Generate a base64-encoded OAuth token ensuring that the access token has not expired. The string to be base 64 encoded should be in the form: "user=<user_email_address>\001auth=Bearer <access_token>\001\001"

Renvoie
string

Implémenté dans OAuth.

La documentation de cette interface a été générée à partir du fichier suivant :
  • OAuthTokenProvider.php


Joomla CMS: Référence de la classe PHPMailer

  • PHPMailer
  • PHPMailer
  • PHPMailer
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques | Fonctions membres privées
Référence de la classe PHPMailer
+ Graphe d'héritage de PHPMailer:
Mail

Fonctions membres publiques

__construct ($exceptions=null)
__destruct ()
isHTML ($isHtml=true)
isSMTP ()
isMail ()
isSendmail ()
isQmail ()
addAddress ($address, $name='')
addCC ($address, $name='')
addBCC ($address, $name='')
addReplyTo ($address, $name='')
setFrom ($address, $name='', $auto=true)
getLastMessageID ()
punyencodeAddress ($address)
send ()
preSend ()
postSend ()
getSMTPInstance ()
setSMTPInstance (SMTP $smtp)
smtpConnect ($options=null)
smtpClose ()
setLanguage ($langcode='en', $lang_path='')
getTranslations ()
addrAppend ($type, $addr)
addrFormat ($addr)
wrapText ($message, $length, $qp_mode=false)
utf8CharBoundary ($encodedText, $maxLength)
setWordWrap ()
createHeader ()
getMailMIME ()
getSentMIMEMessage ()
createBody ()
headerLine ($name, $value)
textLine ($value)
addAttachment ( $path, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='attachment')
getAttachments ()
encodeString ($str, $encoding=self::ENCODING_BASE64)
encodeHeader ($str, $position='text')
hasMultiBytes ($str)
has8bitChars ($text)
base64EncodeWrapMB ($str, $linebreak=null)
encodeQP ($string)
encodeQ ($str, $position='text')
addStringAttachment ( $string, $filename, $encoding=self::ENCODING_BASE64, $type='', $disposition='attachment')
addEmbeddedImage ( $path, $cid, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='inline')
addStringEmbeddedImage ( $string, $cid, $name='', $encoding=self::ENCODING_BASE64, $type='', $disposition='inline')
inlineImageExists ()
attachmentExists ()
alternativeExists ()
clearQueuedAddresses ($kind)
clearAddresses ()
clearCCs ()
clearBCCs ()
clearReplyTos ()
clearAllRecipients ()
clearAttachments ()
clearCustomHeaders ()
isError ()
addCustomHeader ($name, $value=null)
getCustomHeaders ()
msgHTML ($message, $basedir='', $advanced=false)
html2text ($html, $advanced=false)
set ($name, $value='')
secureHeader ($str)
sign ($cert_filename, $key_filename, $key_pass, $extracerts_filename='')
DKIM_QP ($txt)
DKIM_Sign ($signHeader)
DKIM_HeaderC ($signHeader)
DKIM_BodyC ($body)
DKIM_Add ($headers_line, $subject, $body)
getToAddresses ()
getCcAddresses ()
getBccAddresses ()
getReplyToAddresses ()
getAllRecipientAddresses ()
getOAuth ()
setOAuth (OAuthTokenProvider $oauth)

Fonctions membres publiques statiques

static | parseAddresses ($addrstr, $useimap=true, $charset=self::CHARSET_ISO88591)
static | validateAddress ($address, $patternselect=null)
static | idnSupported ()
static | rfcDate ()
static | isValidHost ($host)
static | _mime_types ($ext='')
static | filenameToType ($filename)
static | mb_pathinfo ($path, $options=null)
static | normalizeBreaks ($text, $breaktype=null)
static | stripTrailingWSP ($text)
static | getLE ()
static | hasLineLongerThanMax ($str)
static | quotedString ($str)

Champs de données

const | CHARSET_ASCII = 'us-ascii'
const | CHARSET_ISO88591 = 'iso-8859-1'
const | CHARSET_UTF8 = 'utf-8'
const | CONTENT_TYPE_PLAINTEXT = 'text/plain'
const | CONTENT_TYPE_TEXT_CALENDAR = 'text/calendar'
const | CONTENT_TYPE_TEXT_HTML = 'text/html'
const | CONTENT_TYPE_MULTIPART_ALTERNATIVE = 'multipart/alternative'
const | CONTENT_TYPE_MULTIPART_MIXED = 'multipart/mixed'
const | CONTENT_TYPE_MULTIPART_RELATED = 'multipart/related'
const | ENCODING_7BIT = '7bit'
const | ENCODING_8BIT = '8bit'
const | ENCODING_BASE64 = 'base64'
const | ENCODING_BINARY = 'binary'
const | ENCODING_QUOTED_PRINTABLE = 'quoted-printable'
const | ENCRYPTION_STARTTLS = 'tls'
const | ENCRYPTION_SMTPS = 'ssl'
const | ICAL_METHOD_REQUEST = 'REQUEST'
const | ICAL_METHOD_PUBLISH = 'PUBLISH'
const | ICAL_METHOD_REPLY = 'REPLY'
const | ICAL_METHOD_ADD = 'ADD'
const | ICAL_METHOD_CANCEL = 'CANCEL'
const | ICAL_METHOD_REFRESH = 'REFRESH'
const | ICAL_METHOD_COUNTER = 'COUNTER'
const | ICAL_METHOD_DECLINECOUNTER = 'DECLINECOUNTER'
$Priority
$CharSet = self::CHARSET_ISO88591
$ContentType = self::CONTENT_TYPE_PLAINTEXT
$Encoding = self::ENCODING_8BIT
$ErrorInfo = ''
$From = ''
$FromName = ''
$Sender = ''
$Subject = ''
$Body = ''
$AltBody = ''
$Ical = ''
$WordWrap = 0
$Mailer = 'mail'
$Sendmail = '/usr/sbin/sendmail'
$UseSendmailOptions = true
$ConfirmReadingTo = ''
$Hostname = ''
$MessageID = ''
$MessageDate = ''
$Host = 'localhost'
$Port = 25
$Helo = ''
$SMTPSecure = ''
$SMTPAutoTLS = true
$SMTPAuth = false
$SMTPOptions = []
$Username = ''
$Password = ''
$AuthType = ''
$Timeout = 300
$dsn = ''
$SMTPDebug = 0
$Debugoutput = 'echo'
$SMTPKeepAlive = false
$SingleTo = false
$do_verp = false
$AllowEmpty = false
$DKIM_selector = ''
$DKIM_identity = ''
$DKIM_passphrase = ''
$DKIM_domain = ''
$DKIM_copyHeaderFields = true
$DKIM_extraHeaders = []
$DKIM_private = ''
$DKIM_private_string = ''
$action_function = ''
$XMailer = ''
const | VERSION = '6.6.0'
const | STOP_MESSAGE = 0
const | STOP_CONTINUE = 1
const | STOP_CRITICAL = 2
const | CRLF = "\r\n"
const | FWS = ' '
const | MAIL_MAX_LINE_LENGTH = 63
const | MAX_LINE_LENGTH = 998
const | STD_LINE_LENGTH = 76

Attributs publics statiques

static $validator = 'php'

Fonctions membres protégées

edebug ($str)
addOrEnqueueAnAddress ($kind, $address, $name)
addAnAddress ($kind, $address, $name='')
sendmailSend ($header, $body)
mailSend ($header, $body)
smtpSend ($header, $body)
generateId ()
getBoundary ($boundary, $charSet, $contentType, $encoding)
endBoundary ($boundary)
setMessageType ()
attachAll ($disposition_type, $boundary)
encodeFile ($path, $encoding=self::ENCODING_BASE64)
validateEncoding ($encoding)
cidExists ($cid)
setError ($msg)
serverHostname ()
lang ($key)
doCallback ($isSent, $to, $cc, $bcc, $subject, $body, $from, $extra)

Fonctions membres protégées statiques

static | isShellSafe ($string)
static | isPermittedPath ($path)
static | fileIsAccessible ($path)
static | setLE ($le)

Attributs protégés

$MIMEBody = ''
$MIMEHeader = ''
$mailHeader = ''
$oauth
$SingleToArray = []
$smtp
$to = []
$cc = []
$bcc = []
$ReplyTo = []
$all_recipients = []
$RecipientsQueue = []
$ReplyToQueue = []
$attachment = []
$CustomHeader = []
$lastMessageID = ''
$message_type = ''
$boundary = []
$language = []
$error_count = 0
$sign_cert_file = ''
$sign_key_file = ''
$sign_extracerts_file = ''
$sign_key_pass = ''
$exceptions = false
$uniqueid = ''

Attributs protégés statiques

static | $IcalMethods
static | $LE = self::CRLF

Fonctions membres privées

mailPassthru ($to, $subject, $body, $header, $params)
getSmtpErrorMessage ($base_key)

Description détaillée

PHPMailer - PHP email creation and transport class.

Auteur
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et
Brent R. Matzelle (original founder)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $exceptions = null )

Constructor.

Paramètres
bool $exceptions Should we throw external exceptions?

Références PHPMailer\$exceptions, et null.

◆ __destruct()

__destruct ( )

Destructor.

Références PHPMailer\smtpClose().

Documentation des fonctions membres

◆ _mime_types()

static _mime_types ( $ext = '' )
static

Get the MIME type for a file extension.

Paramètres
string $ext File extension
Renvoie
string MIME type of file

◆ addAddress()

addAddress | ( | $address,
 |  | $name = ''
 | ) |

Add a "To" address.

Paramètres
string | $address | The email address to send to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, et PHPMailer\addOrEnqueueAnAddress().

◆ addAnAddress()

addAnAddress | ( | $kind,
 |  | $address,
 |  | $name = ''
 | ) |
protected

Add an address to one of the recipient arrays or to the ReplyTo array. Addresses that have been added already return false, but do not throw exceptions.

Paramètres
string | $kind | One of 'to', 'cc', 'bcc', or 'ReplyTo'
string | $address | The email address to send, resp. to reply to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, PHPMailer\edebug(), elseif, PHPMailer\lang(), et PHPMailer\setError().

◆ addAttachment()

addAttachment | ( | $path,
 |  | $name = '',
 |  | $encoding = self::ENCODING_BASE64,
 |  | $type = '',
 |  | $disposition = 'attachment'
 | ) |

Add an attachment from a path on the filesystem. Never use a user-supplied path to a file! Returns false if the file could not be found or read. Explicitly does not support passing URLs; PHPMailer is not an HTTP client. If you need to do that, fetch the resource yourself and pass it in via a local file or string.

Paramètres
string | $path | Path to the attachment
string | $name | Overrides the attachment name
string | $encoding | File encoding (see $Encoding)
string | $type | MIME type, e.g. image/jpeg; determined automatically from $path if not specified
string | $disposition | Disposition to use
Exceptions
Exception
Renvoie
bool

Références $name, $path, $type, PHPMailer\edebug(), PHPMailer\lang(), PHPMailer\setError(), et PHPMailer\validateEncoding().

◆ addBCC()

addBCC | ( | $address,
 |  | $name = ''
 | ) |

Add a "BCC" address.

Paramètres
string | $address | The email address to send to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, et PHPMailer\addOrEnqueueAnAddress().

◆ addCC()

addCC | ( | $address,
 |  | $name = ''
 | ) |

Add a "CC" address.

Paramètres
string | $address | The email address to send to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, et PHPMailer\addOrEnqueueAnAddress().

◆ addCustomHeader()

addCustomHeader | ( | $name,
 |  | $value = null
 | ) |

Add a custom header. $name value can be overloaded to contain both header name and value (name:value).

Paramètres
string | $name | Custom header name
string | null | $value | Header value
Exceptions
Exception

Références $name, $value, PHPMailer\lang(), et null.

◆ addEmbeddedImage()

addEmbeddedImage | ( | $path,
 |  | $cid,
 |  | $name = '',
 |  | $encoding = self::ENCODING_BASE64,
 |  | $type = '',
 |  | $disposition = 'inline'
 | ) |

Add an embedded (inline) attachment from a file. This can include images, sounds, and just about any other document type. These differ from 'regular' attachments in that they are intended to be displayed inline with the message, not just attached for download. This is used in HTML messages that embed the images the HTML refers to using the $cid value. Never use a user-supplied path to a file!

Paramètres
string | $path | Path to the attachment
string | $cid | Content ID of the attachment; Use this to reference the content when using an embedded image in HTML
string | $name | Overrides the attachment name
string | $encoding | File encoding (see $Encoding)
string | $type | File MIME type
string | $disposition | Disposition to use
Exceptions
Exception
Renvoie
bool True on successfully adding an attachment

Références $name, $path, $type, PHPMailer\edebug(), PHPMailer\lang(), PHPMailer\setError(), et PHPMailer\validateEncoding().

Référencé par PHPMailer\msgHTML().

◆ addOrEnqueueAnAddress()

addOrEnqueueAnAddress | ( | $kind,
 |  | $address,
 |  | $name
 | ) |
protected

Add an address to one of the recipient arrays or to the ReplyTo array. Because PHPMailer can't validate addresses with an IDN without knowing the PHPMailer::$CharSet (that can still be modified after calling this function), addition of such addresses is delayed until send(). Addresses that have been added already return false, but do not throw exceptions.

Paramètres
string | $kind | One of 'to', 'cc', 'bcc', or 'ReplyTo'
string | $address | The email address to send, resp. to reply to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, $params, $this, PHPMailer\edebug(), elseif, PHPMailer\has8bitChars(), PHPMailer\lang(), et PHPMailer\setError().

Référencé par PHPMailer\addAddress(), PHPMailer\addBCC(), PHPMailer\addCC(), et PHPMailer\addReplyTo().

◆ addrAppend()

addrAppend | ( | $type,
 |  | $addr
 | ) |

Create recipient headers.

Paramètres
string | $type
array | $addr | An array of recipients, where each recipient is a 2-element indexed array with element 0 containing an address and element 1 containing a name, like: [['joe@e.nosp@m.xamp.nosp@m.le.co.nosp@m.m', 'Joe User'], ['zoe@e.nosp@m.xamp.nosp@m.le.co.nosp@m.m', 'Zoe User']]
Renvoie
string

Références $type, et PHPMailer\addrFormat().

Référencé par PHPMailer\createHeader().

◆ addReplyTo()

addReplyTo | ( | $address,
 |  | $name = ''
 | ) |

Add a "Reply-To" address.

Paramètres
string | $address | The email address to reply to
string | $name
Exceptions
Exception
Renvoie
bool true on success, false if address already used or invalid in some way

Références $name, et PHPMailer\addOrEnqueueAnAddress().

◆ addrFormat()

addrFormat ( $addr )

Format an address for use in a message header.

Paramètres
array $addr A 2-element indexed array, element 0 containing an address, element 1 containing a name like ['joe@e.nosp@m.xamp.nosp@m.le.co.nosp@m.m', 'Joe User']
Renvoie
string

Références PHPMailer\encodeHeader(), et PHPMailer\secureHeader().

Référencé par PHPMailer\addrAppend(), PHPMailer\createHeader(), et PHPMailer\mailSend().

◆ addStringAttachment()

addStringAttachment | ( | $string,
 |  | $filename,
 |  | $encoding = self::ENCODING_BASE64,
 |  | $type = '',
 |  | $disposition = 'attachment'
 | ) |

Add a string or binary attachment (non-filesystem). This method can be used to attach ascii or binary data, such as a BLOB record from a database.

Paramètres
string | $string | String attachment data
string | $filename | Name of the attachment
string | $encoding | File encoding (see $Encoding)
string | $type | File extension (MIME) type
string | $disposition | Disposition to use
Exceptions
Exception
Renvoie
bool True on successfully adding an attachment

Références $type, PHPMailer\edebug(), PHPMailer\lang(), PHPMailer\setError(), et PHPMailer\validateEncoding().

◆ addStringEmbeddedImage()

addStringEmbeddedImage | ( | $string,
 |  | $cid,
 |  | $name = '',
 |  | $encoding = self::ENCODING_BASE64,
 |  | $type = '',
 |  | $disposition = 'inline'
 | ) |

Add an embedded stringified attachment. This can include images, sounds, and just about any other document type. If your filename doesn't contain an extension, be sure to set the $type to an appropriate MIME type.

Paramètres
string | $string | The attachment binary data
string | $cid | Content ID of the attachment; Use this to reference the content when using an embedded image in HTML
string | $name | A filename for the attachment. If this contains an extension, PHPMailer will attempt to set a MIME type for the attachment. For example 'file.jpg' would get an 'image/jpeg' MIME type.
string | $encoding | File encoding (see $Encoding), defaults to 'base64'
string | $type | MIME type - will be used in preference to any automatically derived type
string | $disposition | Disposition to use
Exceptions
Exception
Renvoie
bool True on successfully adding an attachment

Références $name, $type, PHPMailer\edebug(), PHPMailer\lang(), PHPMailer\setError(), et PHPMailer\validateEncoding().

Référencé par PHPMailer\msgHTML().

◆ alternativeExists()

alternativeExists ( )

Check if this message has an alternative body set.

Renvoie
bool

Référencé par PHPMailer\msgHTML(), et PHPMailer\setMessageType().

◆ attachAll()

attachAll | ( | $disposition_type,
 |  | $boundary
 | ) |
protected

Attach all file, string, and binary attachments to the message. Returns an empty string on failure.

Paramètres
string | $disposition_type
string | $boundary
Exceptions
Exception
Renvoie
string

Références PHPMailer\$attachment, PHPMailer\$boundary, $name, $path, $type, PHPMailer\encodeFile(), PHPMailer\encodeHeader(), PHPMailer\encodeString(), PHPMailer\isError(), et PHPMailer\secureHeader().

Référencé par PHPMailer\createBody().

◆ attachmentExists()

attachmentExists ( )

Check if an attachment (non-inline) is present.

Renvoie
bool

Références PHPMailer\$attachment.

Référencé par PHPMailer\setMessageType().

◆ base64EncodeWrapMB()

base64EncodeWrapMB | ( | $str,
 |  | $linebreak = null
 | ) |

Encode and wrap long multibyte strings for mail headers without breaking lines within a character. Adapted from a function by paravoid.

Voir également
http://www.php.net/manual/en/function.mb-encode-mimeheader.php#60283
Paramètres
string | $str | multi-byte text to wrap encode
string | $linebreak | string to use as linefeed/end-of-line
Renvoie
string

Références $i, Joomla\Database\Query\$offset, $start, et null.

Référencé par PHPMailer\encodeHeader().

◆ cidExists()

cidExists ( $cid )
protected

Check if an embedded attachment is present with this cid.

Paramètres
string $cid
Renvoie
bool

Références PHPMailer\$attachment.

Référencé par PHPMailer\msgHTML().

◆ clearAddresses()

clearAddresses ( )

Clear all To recipients.

Références PHPMailer\$to, et PHPMailer\clearQueuedAddresses().

◆ clearAllRecipients()

clearAllRecipients ( )

Clear all recipient types.

◆ clearAttachments()

clearAttachments ( )

Clear all filesystem, string, and binary attachments.

◆ clearBCCs()

clearBCCs ( )

Clear all BCC recipients.

Références PHPMailer\$bcc, et PHPMailer\clearQueuedAddresses().

◆ clearCCs()

clearCCs ( )

Clear all CC recipients.

Références PHPMailer\$cc, et PHPMailer\clearQueuedAddresses().

◆ clearCustomHeaders()

clearCustomHeaders ( )

Clear all custom headers.

◆ clearQueuedAddresses()

clearQueuedAddresses ( $kind )

Clear queued addresses of given kind.

Paramètres
string $kind 'to', 'cc', or 'bcc'

Références $params.

Référencé par PHPMailer\clearAddresses(), PHPMailer\clearBCCs(), et PHPMailer\clearCCs().

◆ clearReplyTos()

clearReplyTos ( )

Clear all ReplyTo recipients.

◆ createBody()

createBody ( )

Assemble the message body. Returns an empty string on failure.

Exceptions
Exception
Renvoie
string The assembled message body

Références PHPMailer\$CharSet, PHPMailer\$Encoding, $method, $parts, PHPMailer\$uniqueid, PHPMailer\attachAll(), elseif, PHPMailer\encodeString(), PHPMailer\endBoundary(), PHPMailer\generateId(), PHPMailer\getBoundary(), PHPMailer\getMailMIME(), PHPMailer\has8bitChars(), PHPMailer\headerLine(), PHPMailer\isError(), PHPMailer\lang(), PHPMailer\setWordWrap(), et PHPMailer\textLine().

◆ createHeader()

createHeader ( )

Assemble message headers.

Renvoie
string The assembled headers

Références $header, PHPMailer\$MessageID, $result, PHPMailer\addrAppend(), PHPMailer\addrFormat(), elseif, PHPMailer\encodeHeader(), PHPMailer\getMailMIME(), PHPMailer\headerLine(), null, PHPMailer\secureHeader(), et PHPMailer\serverHostname().

◆ DKIM_Add()

DKIM_Add | ( | $headers_line,
 |  | $subject,
 |  | $body
 | ) |

Create the DKIM header and body in a new message header.

Paramètres
string | $headers_line | Header lines
string | $subject | Subject
string | $body | Body
Exceptions
Exception
Renvoie
string

Références $header, $subject, PHPMailer\DKIM_BodyC(), PHPMailer\DKIM_HeaderC(), PHPMailer\DKIM_QP(), PHPMailer\DKIM_Sign(), et elseif.

◆ DKIM_BodyC()

DKIM_BodyC ( $body )

Generate a DKIM canonicalization body. Uses the 'simple' algorithm from RFC6376 section 3.4.3. Canonicalized bodies should always use CRLF, regardless of mailer setting.

Voir également
https://tools.ietf.org/html/rfc6376#section-3.4.3
Paramètres
string $body Message Body
Renvoie
string

Référencé par PHPMailer\DKIM_Add().

◆ DKIM_HeaderC()

DKIM_HeaderC ( $signHeader )

Generate a DKIM canonicalization header. Uses the 'relaxed' algorithm from RFC6376 section 3.4.2. Canonicalized headers should always use CRLF, regardless of mailer setting.

Voir également
https://tools.ietf.org/html/rfc6376#section-3.4.2
Paramètres
string $signHeader Header
Renvoie
string

Références $heading, $key, et $value.

Référencé par PHPMailer\DKIM_Add().

◆ DKIM_QP()

DKIM_QP ( $txt )

Quoted-Printable-encode a DKIM header.

Paramètres
string $txt
Renvoie
string

Références $i.

Référencé par PHPMailer\DKIM_Add().

◆ DKIM_Sign()

DKIM_Sign ( $signHeader )

Generate a DKIM signature.

Paramètres
string $signHeader
Exceptions
Exception
Renvoie
string The DKIM signature value

Références PHPMailer\lang().

Référencé par PHPMailer\DKIM_Add().

◆ doCallback()

doCallback | ( | $isSent,
 |  | $to,
 |  | $cc,
 |  | $bcc,
 |  | $subject,
 |  | $body,
 |  | $from,
 |  | $extra
 | ) |
protected

Perform a callback.

Paramètres
bool | $isSent
array | $to
array | $cc
array | $bcc
string | $subject
string | $body
string | $from
array | $extra

Références PHPMailer\$bcc, PHPMailer\$cc, $subject, et PHPMailer\$to.

Référencé par PHPMailer\mailSend(), et PHPMailer\smtpSend().

◆ edebug()

edebug ( $str )
protected

Output debugging info via a user-defined method. Only generates output if debug output is enabled.

Voir également
PHPMailer::$Debugoutput
PHPMailer::$SMTPDebug
Paramètres
string $str

ForgottenDebugOutputInspection

Références ENT_QUOTES.

Référencé par PHPMailer\addAnAddress(), PHPMailer\addAttachment(), PHPMailer\addEmbeddedImage(), PHPMailer\addOrEnqueueAnAddress(), PHPMailer\addStringAttachment(), PHPMailer\addStringEmbeddedImage(), PHPMailer\encodeFile(), PHPMailer\mailPassthru(), et PHPMailer\smtpConnect().

◆ encodeFile()

encodeFile | ( | $path,
 |  | $encoding = self::ENCODING_BASE64
 | ) |
protected

Encode a file attachment in requested format. Returns an empty string on failure.

Paramètres
string | $path | The full path to the file
string | $encoding | The encoding to use; one of 'base64', '7bit', '8bit', 'binary', 'quoted-printable'
Renvoie
string

Références $path, PHPMailer\edebug(), PHPMailer\encodeString(), PHPMailer\lang(), et PHPMailer\setError().

Référencé par PHPMailer\attachAll().

◆ encodeHeader()

encodeHeader | ( | $str,
 |  | $position = 'text'
 | ) |

Encode a header value (not including its label) optimally. Picks shortest of Q, B, or none. Result includes folding if needed. See RFC822 definitions for phrase, comment and text positions.

Paramètres
string | $str | The header value to encode
string | $position | What context the string will be used in
Renvoie
string

Références PHPMailer\$CharSet, $position, PHPMailer\base64EncodeWrapMB(), elseif, PHPMailer\encodeQ(), PHPMailer\has8bitChars(), PHPMailer\hasMultiBytes(), et PHPMailer\wrapText().

Référencé par PHPMailer\addrFormat(), PHPMailer\attachAll(), PHPMailer\createHeader(), et PHPMailer\mailPassthru().

◆ encodeQ()

encodeQ | ( | $str,
 |  | $position = 'text'
 | ) |

Encode a string using Q encoding.

Voir également
http://tools.ietf.org/html/rfc2047#section-4.2
Paramètres
string | $str | the text to encode
string | $position | Where the text is going to be used, see the RFC for what that means
Renvoie
string

Références $position.

Référencé par PHPMailer\encodeHeader().

◆ encodeQP()

encodeQP ( $string )

Encode a string in quoted-printable format. According to RFC2045 section 6.7.

Paramètres
string $string The text to encode
Renvoie
string

Référencé par PHPMailer\encodeString().

◆ encodeString()

encodeString | ( | $str,
 |  | $encoding = self::ENCODING_BASE64
 | ) |

Encode a string in requested format. Returns an empty string on failure.

Paramètres
string | $str | The text to encode
string | $encoding | The encoding to use; one of 'base64', '7bit', '8bit', 'binary', 'quoted-printable'
Exceptions
Exception
Renvoie
string

Références PHPMailer\encodeQP(), PHPMailer\lang(), et PHPMailer\setError().

Référencé par PHPMailer\attachAll(), PHPMailer\createBody(), et PHPMailer\encodeFile().

◆ endBoundary()

endBoundary ( $boundary )
protected

Return the end of a message boundary.

Paramètres
string $boundary
Renvoie
string

Références PHPMailer\$boundary.

Référencé par PHPMailer\createBody().

◆ fileIsAccessible()

static fileIsAccessible ( $path )
staticprotected

Check whether a file path is safe, accessible, and readable.

Paramètres
string $path A relative or absolute path to a file
Renvoie
bool

Références $path.

◆ filenameToType()

static filenameToType ( $filename )
static

Map a file name to a MIME type. Defaults to 'application/octet-stream', i.e.. arbitrary binary data.

Paramètres
string $filename A file name or full path, does not need to exist as a file
Renvoie
string

◆ generateId()

generateId ( )
protected

Create a unique ID to use for boundaries.

Renvoie
string

CryptographicallySecureRandomnessInspection

Références elseif.

Référencé par PHPMailer\createBody().

◆ getAllRecipientAddresses()

getAllRecipientAddresses ( )

Allows for public read access to 'all_recipients' property. Before the send() call, queued addresses (i.e. with IDN) are not yet included.

Renvoie
array

Références PHPMailer\$all_recipients.

◆ getAttachments()

getAttachments ( )

Return the array of attachments.

Renvoie
array

Références PHPMailer\$attachment.

◆ getBccAddresses()

getBccAddresses ( )

Allows for public read access to 'bcc' property. Before the send() call, queued addresses (i.e. with IDN) are not yet included.

Renvoie
array

Références PHPMailer\$bcc.

◆ getBoundary()

getBoundary | ( | $boundary,
 |  | $charSet,
 |  | $contentType,
 |  | $encoding
 | ) |
protected

Return the start of a message boundary.

Paramètres
string | $boundary
string | $charSet
string | $contentType
string | $encoding
Renvoie
string

Références PHPMailer\$boundary, PHPMailer\$CharSet, PHPMailer\$ContentType, PHPMailer\$Encoding, $result, PHPMailer\headerLine(), et PHPMailer\textLine().

Référencé par PHPMailer\createBody().

◆ getCcAddresses()

getCcAddresses ( )

Allows for public read access to 'cc' property. Before the send() call, queued addresses (i.e. with IDN) are not yet included.

Renvoie
array

Références PHPMailer\$cc.

◆ getCustomHeaders()

getCustomHeaders ( )

Returns all custom headers.

Renvoie
array

Références PHPMailer\$CustomHeader.

◆ getLastMessageID()

getLastMessageID ( )

Return the Message-ID header of the last email. Technically this is the value from the last time the headers were created, but it's also the message ID of the last sent message except in pathological cases.

Renvoie
string

◆ getLE()

static getLE ( )
static

Return the current line break format string.

Renvoie
string

◆ getMailMIME()

getMailMIME ( )

Get the message MIME type headers.

Renvoie
string

Références $result, PHPMailer\headerLine(), et PHPMailer\textLine().

Référencé par PHPMailer\createBody(), et PHPMailer\createHeader().

◆ getOAuth()

getOAuth ( )

Get the OAuthTokenProvider instance.

Renvoie
OAuthTokenProvider

Références PHPMailer\$oauth.

◆ getReplyToAddresses()

getReplyToAddresses ( )

Allows for public read access to 'ReplyTo' property. Before the send() call, queued addresses (i.e. with IDN) are not yet included.

Renvoie
array

Références PHPMailer\$ReplyTo.

◆ getSentMIMEMessage()

getSentMIMEMessage ( )

Returns the whole MIME message. Includes complete headers and body. Only valid post preSend().

Voir également
PHPMailer::preSend()
Renvoie
string

Références PHPMailer\$MIMEBody.

◆ getSmtpErrorMessage()

getSmtpErrorMessage ( $base_key )
private

Build an error message starting with a generic one and adding details if possible.

Paramètres
string $base_key
Renvoie
string

Références $message, et PHPMailer\lang().

Référencé par PHPMailer\smtpConnect().

◆ getSMTPInstance()

getSMTPInstance ( )

Get an instance to use for SMTP operations. Override this function to load your own SMTP implementation, or set one with setSMTPInstance.

Renvoie
SMTP

Références PHPMailer\$smtp.

Référencé par PHPMailer\smtpConnect().

◆ getToAddresses()

getToAddresses ( )

Allows for public read access to 'to' property. Before the send() call, queued addresses (i.e. with IDN) are not yet included.

Renvoie
array

Références PHPMailer\$to.

◆ getTranslations()

getTranslations ( )

Get the array of strings for the current language.

Renvoie
array

Références PHPMailer\$language, language, et PHPMailer\setLanguage().

◆ has8bitChars()

has8bitChars ( $text )

Does a string contain any 8-bit chars (in any charset)?

Paramètres
string $text
Renvoie
bool

Références $text.

Référencé par PHPMailer\addOrEnqueueAnAddress(), PHPMailer\createBody(), et PHPMailer\encodeHeader().

◆ hasLineLongerThanMax()

static hasLineLongerThanMax ( $str )
static

Detect if a string contains a line longer than the maximum line length allowed by RFC 2822 section 2.1.1.

Paramètres
string $str
Renvoie
bool

◆ hasMultiBytes()

hasMultiBytes ( $str )

Check if a string contains multi-byte characters.

Paramètres
string $str multi-byte text to wrap encode
Renvoie
bool

Référencé par PHPMailer\encodeHeader().

◆ headerLine()

headerLine | ( | $name,
 |  | $value
 | ) |

Format a header line.

Paramètres
string | $name
string | int | $value
Renvoie
string

Références $name, et $value.

Référencé par PHPMailer\createBody(), PHPMailer\createHeader(), PHPMailer\getBoundary(), et PHPMailer\getMailMIME().

◆ html2text()

html2text | ( | $html,
 |  | $advanced = false
 | ) |

Convert an HTML string into plain text. This is used by msgHTML(). Note - older versions of this function used a bundled advanced converter which was removed for license reasons in #232. Example usage:

//Use default conversion
$plain = $mail->html2text($html);
//Use your own custom converter
$plain = $mail->html2text($html, function($html) {
$converter = new MyHtml2text($html);
return $converter->get_text();
});
Paramètres
string | $html | The HTML text to convert
bool | callable | $advanced | Any boolean value to use the internal converter, or provide your own callable for custom conversion. Never pass user-supplied data into this parameter
Renvoie
string

Références $html, et ENT_QUOTES.

Référencé par PHPMailer\msgHTML().

◆ idnSupported()

static idnSupported ( )
static

Tells whether IDNs (Internationalized Domain Names) are supported or not. This requires the intl and mbstring PHP extensions.

Renvoie
bool true if required functions for IDN support are present

◆ inlineImageExists()

inlineImageExists ( )

Check if an inline attachment is present.

Renvoie
bool

Références PHPMailer\$attachment.

Référencé par PHPMailer\setMessageType().

◆ isError()

isError ( )

Check if an error occurred.

Renvoie
bool True if an error did occur

Référencé par PHPMailer\attachAll(), et PHPMailer\createBody().

◆ isHTML()

isHTML ( $isHtml = true )

Sets message type to HTML or plain.

Paramètres
bool $isHtml True for HTML mode

Référencé par PHPMailer\msgHTML().

◆ isMail()

isMail ( )

Send messages using PHP's mail() function.

Référencé par Mail\useSendmail(), et Mail\useSmtp().

◆ isPermittedPath()

static isPermittedPath ( $path )
staticprotected

Check whether a file path is of a permitted type. Used to reject URLs and phar files from functions that access local file paths, such as addAttachment.

Paramètres
string $path A relative or absolute path to a file
Renvoie
bool

Références $path.

◆ isQmail()

isQmail ( )

Send messages using qmail.

◆ isSendmail()

isSendmail ( )

Send messages using $Sendmail.

◆ isShellSafe()

static isShellSafe ( $string )
staticprotected

Fix CVE-2016-10033 and CVE-2016-10045 by disallowing potentially unsafe shell characters. Note that escapeshellarg and escapeshellcmd are inadequate for our purposes, especially on Windows.

Voir également
https://github.com/PHPMailer/PHPMailer/issues/924 CVE-2016-10045 bug report
Paramètres
string $string The string to be validated
Renvoie
bool

◆ isSMTP()

isSMTP ( )

Send messages using SMTP.

Référencé par Mail\useSmtp().

◆ isValidHost()

static isValidHost ( $host )
static

Validate whether a string contains a valid value to use as a hostname or IP address. IPv6 addresses must include [], e.g. [::1], not just ::1.

Paramètres
string $host The host name or IP address to check
Renvoie
bool

◆ lang()

lang ( $key )
protected

Get an error message in the current language.

Paramètres
string $key
Renvoie
string

Références $key, language, et PHPMailer\setLanguage().

Référencé par PHPMailer\addAnAddress(), PHPMailer\addAttachment(), PHPMailer\addCustomHeader(), PHPMailer\addEmbeddedImage(), PHPMailer\addOrEnqueueAnAddress(), PHPMailer\addStringAttachment(), PHPMailer\addStringEmbeddedImage(), PHPMailer\createBody(), PHPMailer\DKIM_Sign(), PHPMailer\encodeFile(), PHPMailer\encodeString(), PHPMailer\getSmtpErrorMessage(), PHPMailer\mailSend(), PHPMailer\set(), PHPMailer\setError(), PHPMailer\smtpConnect(), et PHPMailer\smtpSend().

◆ mailPassthru()

mailPassthru | ( | $to,
 |  | $subject,
 |  | $body,
 |  | $header,
 |  | $params
 | ) |
private

Call mail() in a safe_mode-aware fashion. Also, unless sendmail_path points to sendmail (or something that claims to be sendmail), don't pass params (not a perfect fix, but it will do).

Paramètres
string | $to | To
string | $subject | Subject
string | $body | Message Body
string | $header | Additional Header(s)
string | null | $params | Params
Renvoie
bool

Références $header, $params, $result, $subject, PHPMailer\$to, PHPMailer\edebug(), PHPMailer\encodeHeader(), null, et PHPMailer\secureHeader().

Référencé par PHPMailer\mailSend().

◆ mailSend()

mailSend | ( | $header,
 |  | $body
 | ) |
protected

Send mail using the PHP mail() function.

Voir également
http://www.php.net/manual/en/book.mail.php
Paramètres
string | $header | The message headers
string | $body | The message body
Exceptions
Exception
Renvoie
bool

Références $header, $params, $result, PHPMailer\$to, PHPMailer\addrFormat(), PHPMailer\doCallback(), PHPMailer\lang(), PHPMailer\mailPassthru(), et null.

◆ mb_pathinfo()

static mb_pathinfo | ( | $path,
 |  | $options = null
 | ) |
static

Multi-byte-safe pathinfo replacement. Drop-in replacement for pathinfo(), but multibyte- and cross-platform-safe.

Voir également
http://www.php.net/manual/en/function.pathinfo.php#107461
Paramètres
string | $path | A filename or path, does not need to exist as a file
int | string | $options | Either a PATHINFO_* constant, or a string name to return only the specified piece
Renvoie
string|array

Références $options, et $path.

◆ msgHTML()

msgHTML | ( | $message,
 |  | $basedir = '',
 |  | $advanced = false
 | ) |

Create a message body from an HTML string. Automatically inlines images and creates a plain-text version by converting the HTML, overwriting any existing values in Body and AltBody. Do not source $message content from user input! $basedir is prepended when handling relative URLs, e.g.

and must not be empty will look for an image file in $basedir/images/a.png and convert it to inline. If you don't provide a $basedir, relative paths will be left untouched (and thus probably break in email) Converts data-uri images into embedded attachments. If you don't want to apply these transformations to your HTML, just set Body and AltBody directly.

Paramètres
string | $message | HTML message string
string | $basedir | Absolute path to a base directory to prepend to relative paths to images
bool | callable | $advanced | Whether to use the internal HTML to text converter or your own custom converter
Renvoie
string The transformed message body
Exceptions
Exception
Voir également
PHPMailer::html2text()

Références PHPMailer\$Body, $data, $images, $message, $url, PHPMailer\addEmbeddedImage(), PHPMailer\addStringEmbeddedImage(), PHPMailer\alternativeExists(), PHPMailer\cidExists(), elseif, PHPMailer\html2text(), et PHPMailer\isHTML().

◆ normalizeBreaks()

static normalizeBreaks | ( | $text,
 |  | $breaktype = null
 | ) |
static

Normalize line breaks in a string. Converts UNIX LF, Mac CR and Windows CRLF line breaks into a single line break format. Defaults to CRLF (for message bodies) and preserves consecutive breaks.

Paramètres
string | $text
string | $breaktype | What kind of line break to use; defaults to static::$LE
Renvoie
string

Références $text, et null.

◆ parseAddresses()

static parseAddresses | ( | $addrstr,
 |  | $useimap = true,
 |  | $charset = self::CHARSET_ISO88591
 | ) |
static

Parse and validate a string containing one or more RFC822-style comma-separated email addresses of the form "display name <address>" into an array of name/address pairs. Uses the imap_rfc822_parse_adrlist function if the IMAP extension is available. Note that quotes in the name part are removed.

Voir également
http://www.andrew.cmu.edu/user/agreen1/testing/mrbs/web/Mail/RFC822.php A more careful implementation
Paramètres
string | $addrstr | The address list string
bool | $useimap | Whether to use the IMAP extension to parse the list
string | $charset | The charset to use when decoding the address list string.
Renvoie
array

Références $list, et $name.

◆ postSend()

postSend ( )

Actually send a message via the selected mechanism.

Exceptions
Exception
Renvoie
bool

◆ preSend()

preSend ( )

Prepare a message for sending.

Exceptions
Exception
Renvoie
bool

◆ punyencodeAddress()

punyencodeAddress ( $address )

Converts IDN in given email address to its ASCII form, also known as punycode, if possible. Important: Address must be passed in same encoding as currently set in PHPMailer::$CharSet. This function silently returns unmodified address if:

  • No conversion is necessary (i.e. domain name is not an IDN, or is already in ASCII form)
  • Conversion to punycode is impossible (e.g. required PHP functions are not available) or fails for any reason (e.g. domain contains characters not allowed in an IDN).
Voir également
PHPMailer::$CharSet
Paramètres
string $address The email address to convert
Renvoie
string The encoded address in ASCII form

◆ quotedString()

static quotedString ( $str )
static

If a string contains any "special" characters, double-quote the name, and escape any double quotes with a backslash.

Paramètres
string $str
Renvoie
string
Voir également
RFC822 3.4.1

◆ rfcDate()

static rfcDate ( )
static

Return an RFC 822 formatted date.

Renvoie
string

◆ secureHeader()

secureHeader ( $str )

Strip newlines to prevent header injection.

Paramètres
string $str
Renvoie
string

Référencé par PHPMailer\addrFormat(), PHPMailer\attachAll(), PHPMailer\createHeader(), et PHPMailer\mailPassthru().

◆ send()

send ( )

Create a message and send it. Uses the sending method specified by $Mailer.

Exceptions
Exception
Renvoie
bool false on error - See the ErrorInfo property for details of the error

◆ sendmailSend()

sendmailSend | ( | $header,
 |  | $body
 | ) |
protected

Send mail using the $Sendmail program.

Voir également
PHPMailer::$Sendmail
Paramètres
string | $header | The message headers
string | $body | The message body
Exceptions
Exception
Renvoie
bool

Références $header.

◆ serverHostname()

serverHostname ( )
protected

Get the server hostname. Returns 'localhost.localdomain' if unknown.

Renvoie
string

Références PHPMailer\$Hostname, $result, et elseif.

Référencé par PHPMailer\createHeader(), et PHPMailer\smtpConnect().

◆ set()

set | ( | $name,
 |  | $value = ''
 | ) |

Set or reset instance properties. You should avoid this function - it's more verbose, less efficient, more error-prone and harder to debug than setting properties directly. Usage Example: ‘$mail->set('SMTPSecure’, static::ENCRYPTION_STARTTLS);` is the same as: $mail->SMTPSecure = static::ENCRYPTION_STARTTLS;.

Paramètres
string | $name | The property name to set
mixed | $value | The value to set the property to
Renvoie
bool

Références $name, $this, $value, PHPMailer\lang(), et PHPMailer\setError().

◆ setError()

setError ( $msg )
protected

Add an error message to the error container.

Paramètres
string $msg

Références PHPMailer\$error_count, PHPMailer\lang(), et null.

Référencé par PHPMailer\addAnAddress(), PHPMailer\addAttachment(), PHPMailer\addEmbeddedImage(), PHPMailer\addOrEnqueueAnAddress(), PHPMailer\addStringAttachment(), PHPMailer\addStringEmbeddedImage(), PHPMailer\encodeFile(), PHPMailer\encodeString(), PHPMailer\set(), et PHPMailer\smtpSend().

◆ setFrom()

setFrom | ( | $address,
 |  | $name = '',
 |  | $auto = true
 | ) |

Set the From and FromName properties.

Paramètres
string | $address
string | $name
bool | $auto | Whether to also set the Sender address, defaults to true
Exceptions
Exception
Renvoie
bool

Référencé par Mail\setSender().

◆ setLanguage()

setLanguage | ( | $langcode = 'en',
 |  | $lang_path = ''
 | ) |

Set the language for error messages. The default language is English.

Paramètres
string | $langcode | ISO 639-1 2-character language code (e.g. French is "fr") Optionally, the language code can be enhanced with a 4-character script annotation and/or a 2-character country annotation.
string | $lang_path | Path to the language file directory, with trailing separator (slash) Do not set this from user input!
Renvoie
bool Returns true if the requested language was loaded, false otherwise.

Références $PHPMAILER_LANG, __DIR__, et language.

Référencé par PHPMailer\getTranslations(), et PHPMailer\lang().

◆ setLE()

static setLE ( $le )
staticprotected

Set the line break format string, e.g. "\r\n".

Paramètres
string $le

◆ setMessageType()

setMessageType ( )
protected

Set the message type. PHPMailer only supports some preset message types, not arbitrary MIME structures.

Références $type, PHPMailer\alternativeExists(), PHPMailer\attachmentExists(), et PHPMailer\inlineImageExists().

◆ setOAuth()

setOAuth ( OAuthTokenProvider $oauth )

Set an OAuthTokenProvider instance.

Références PHPMailer\$oauth.

◆ setSMTPInstance()

setSMTPInstance ( SMTP $smtp )

Provide an instance to use for SMTP operations.

Renvoie
SMTP

Références PHPMailer\$smtp.

◆ setWordWrap()

setWordWrap ( )

Apply word wrapping to the message body. Wraps the message body to the number of chars set in the WordWrap property. You should only do this to plain-text bodies as wrapping HTML tags may break them. This is called automatically by createBody(), so you don't need to call it yourself.

Références PHPMailer\wrapText().

Référencé par PHPMailer\createBody().

◆ sign()

sign | ( | $cert_filename,
 |  | $key_filename,
 |  | $key_pass,
 |  | $extracerts_filename = ''
 | ) |

Set the public and private key files and password for S/MIME signing.

Paramètres
string | $cert_filename
string | $key_filename
string | $key_pass | Password for private key
string | $extracerts_filename | Optional path to chain certificate

◆ smtpClose()

smtpClose ( )

Close the active SMTP session if one exists.

Références null.

Référencé par PHPMailer\__destruct().

◆ smtpConnect()

smtpConnect ( $options = null )

Initiate a connection to an SMTP server. Returns false if the operation failed.

Paramètres
array $options An array of options compatible with stream_context_create()
Exceptions
Exception
Renvoie
bool

Références PHPMailer\$Helo, $message, $options, PHPMailer\$Port, $prefix, PHPMailer\$SMTPOptions, PHPMailer\$SMTPSecure, $this, PHPMailer\edebug(), elseif, PHPMailer\getSmtpErrorMessage(), PHPMailer\getSMTPInstance(), PHPMailer\lang(), null, et PHPMailer\serverHostname().

Référencé par PHPMailer\smtpSend().

◆ smtpSend()

smtpSend | ( | $header,
 |  | $body
 | ) |
protected

Send mail via SMTP. Returns false if there is a bad MAIL FROM, RCPT, or DATA input.

Voir également
PHPMailer::setSMTPInstance() to use a different class.
Paramètres
string | $header | The message headers
string | $body | The message body
Exceptions
Exception
Renvoie
bool

Références PHPMailer\$From, $header, PHPMailer\$Sender, $this, PHPMailer\$to, PHPMailer\doCallback(), PHPMailer\lang(), PHPMailer\setError(), et PHPMailer\smtpConnect().

◆ stripTrailingWSP()

static stripTrailingWSP ( $text )
static

Remove trailing breaks from a string.

Paramètres
string $text
Renvoie
string The text to remove breaks from

Références $text.

◆ textLine()

textLine ( $value )

Return a formatted mail line.

Paramètres
string $value
Renvoie
string

Références $value.

Référencé par PHPMailer\createBody(), PHPMailer\getBoundary(), et PHPMailer\getMailMIME().

◆ utf8CharBoundary()

utf8CharBoundary | ( | $encodedText,
 |  | $maxLength
 | ) |

Find the last character boundary prior to $maxLength in a utf-8 quoted-printable encoded string. Original written by Colin Brown.

Paramètres
string | $encodedText | utf-8 QP text
int | $maxLength | Find the last character boundary prior to this length
Renvoie
int

Références elseif.

Référencé par PHPMailer\wrapText().

◆ validateAddress()

static validateAddress | ( | $address,
 |  | $patternselect = null
 | ) |
static

Check that a string looks like an email address. Validation patterns supported:

  • auto Pick best pattern automatically;
  • pcre8 Use the squiloople.com pattern, requires PCRE > 8.0;
  • pcre Use old PCRE implementation;
  • php Use PHP built-in FILTER_VALIDATE_EMAIL;
  • html5 Use the pattern given by the HTML5 spec for 'email' type form input elements.
  • noregex Don't use a regex: super fast, really dumb. Alternatively you may pass in a callable to inject your own validator, for example:
PHPMailer::validateAddress('user@example.com', function($address) {
return (strpos($address, '@') !== false);
});

You can also set the PHPMailer::$validator static to a callable, allowing built-in methods to use your validator.

Paramètres
string | $address | The email address to check
string | callable | $patternselect | Which pattern to use
Renvoie
bool

◆ validateEncoding()

validateEncoding ( $encoding )
protected

Validate encodings.

Paramètres
string $encoding
Renvoie
bool

Référencé par PHPMailer\addAttachment(), PHPMailer\addEmbeddedImage(), PHPMailer\addStringAttachment(), et PHPMailer\addStringEmbeddedImage().

◆ wrapText()

wrapText | ( | $message,
 |  | $length,
 |  | $qp_mode = false
 | ) |

Word-wrap message. For use with mailers that do not automatically perform wrapping and for quoted-printable encoded messages. Original written by philippe.

Paramètres
string | $message | The message to wrap
int | $length | The line length to wrap to
bool | $qp_mode | Whether to run in Quoted-Printable mode
Renvoie
string

Références $message, elseif, et PHPMailer\utf8CharBoundary().

Référencé par PHPMailer\encodeHeader(), et PHPMailer\setWordWrap().

Documentation des champs

◆ $action_function

$action_function = ''

◆ $all_recipients

$all_recipients = []
protected

Référencé par PHPMailer\getAllRecipientAddresses().

◆ $AllowEmpty

$AllowEmpty = false

◆ $AltBody

$AltBody = ''

◆ $attachment

$attachment = []
protected

Référencé par MailTemplate\addAttachment(), PHPMailer\attachAll(), PHPMailer\attachmentExists(), PHPMailer\cidExists(), PHPMailer\getAttachments(), PHPMailer\inlineImageExists(), et Mail\sendMail().

◆ $AuthType

$AuthType = ''

◆ $bcc

$bcc = []
protected

Référencé par Mail\addBcc(), PHPMailer\clearBCCs(), PHPMailer\doCallback(), PHPMailer\getBccAddresses(), et Mail\sendMail().

◆ $Body

$Body = ''

Référencé par PHPMailer\msgHTML().

◆ $boundary

$boundary = []
protected

Référencé par PHPMailer\attachAll(), PHPMailer\endBoundary(), et PHPMailer\getBoundary().

◆ $cc

$cc = []
protected

Référencé par Mail\addCc(), PHPMailer\clearCCs(), PHPMailer\doCallback(), PHPMailer\getCcAddresses(), et Mail\sendMail().

◆ $CharSet

$CharSet = self::CHARSET_ISO88591

Référencé par PHPMailer\createBody(), PHPMailer\encodeHeader(), et PHPMailer\getBoundary().

◆ $ConfirmReadingTo

$ConfirmReadingTo = ''

◆ $ContentType

$ContentType = self::CONTENT_TYPE_PLAINTEXT

Référencé par PHPMailer\getBoundary().

◆ $CustomHeader

$CustomHeader = []
protected

Référencé par PHPMailer\getCustomHeaders().

◆ $Debugoutput

$Debugoutput = 'echo'

◆ $DKIM_copyHeaderFields

$DKIM_copyHeaderFields = true

◆ $DKIM_domain

$DKIM_domain = ''

◆ $DKIM_extraHeaders

$DKIM_extraHeaders = []

◆ $DKIM_identity

$DKIM_identity = ''

◆ $DKIM_passphrase

$DKIM_passphrase = ''

◆ $DKIM_private

$DKIM_private = ''

◆ $DKIM_private_string

$DKIM_private_string = ''

◆ $DKIM_selector

$DKIM_selector = ''

◆ $do_verp

$do_verp = false

◆ $dsn

$dsn = ''

Comma separated list of DSN notifications 'NEVER' under no circumstances a DSN must be returned to the sender. If you use NEVER all other notifications will be ignored. 'SUCCESS' will notify you when your mail has arrived at its destination. 'FAILURE' will arrive if an error occurred during delivery. 'DELAY' will notify you if there is an unusual delay in delivery, but the actual delivery's outcome (success or failure) is not yet decided.

Voir également
https://tools.ietf.org/html/rfc3461 See section 4.1 for more information about NOTIFY

◆ $Encoding

$Encoding = self::ENCODING_8BIT

Référencé par PHPMailer\createBody(), et PHPMailer\getBoundary().

◆ $error_count

$error_count = 0
protected

Référencé par PHPMailer\setError().

◆ $ErrorInfo

$ErrorInfo = ''

◆ $exceptions

$exceptions = false
protected

Référencé par PHPMailer\__construct(), et Mail\getInstance().

◆ $From

$From = ''

Référencé par PHPMailer\smtpSend().

◆ $FromName

$FromName = ''

◆ $Helo

$Helo = ''

Référencé par PHPMailer\smtpConnect().

◆ $Host

$Host = 'localhost'

◆ $Hostname

$Hostname = ''

Référencé par PHPMailer\serverHostname().

◆ $Ical

$Ical = ''

◆ $IcalMethods

$IcalMethods
staticprotected
Valeur initiale :
= [
self::ICAL_METHOD_REQUEST,
self::ICAL_METHOD_PUBLISH,
self::ICAL_METHOD_REPLY,
self::ICAL_METHOD_ADD,
self::ICAL_METHOD_CANCEL,
self::ICAL_METHOD_REFRESH,
self::ICAL_METHOD_COUNTER,
self::ICAL_METHOD_DECLINECOUNTER,
]

◆ $language

$language = []
protected

Référencé par MailTemplate\__construct(), MailTemplate\getTemplate(), et PHPMailer\getTranslations().

◆ $lastMessageID

$lastMessageID = ''
protected

◆ $LE

$LE = self::CRLF
staticprotected

◆ $Mailer

$Mailer = 'mail'

◆ $mailHeader

$mailHeader = ''
protected

◆ $message_type

$message_type = ''
protected

◆ $MessageDate

$MessageDate = ''

◆ $MessageID

$MessageID = ''

Référencé par PHPMailer\createHeader().

◆ $MIMEBody

$MIMEBody = ''
protected

Référencé par PHPMailer\getSentMIMEMessage().

◆ $MIMEHeader

$MIMEHeader = ''
protected

◆ $oauth

$oauth
protected

Référencé par PHPMailer\getOAuth(), et PHPMailer\setOAuth().

◆ $Password

$Password = ''

◆ $Port

$Port = 25

Référencé par PHPMailer\smtpConnect().

◆ $Priority

$Priority

◆ $RecipientsQueue

$RecipientsQueue = []
protected

◆ $ReplyTo

$ReplyTo = []
protected

Référencé par PHPMailer\getReplyToAddresses().

◆ $ReplyToQueue

$ReplyToQueue = []
protected

◆ $Sender

$Sender = ''

Référencé par PHPMailer\smtpSend().

◆ $Sendmail

$Sendmail = '/usr/sbin/sendmail'

◆ $sign_cert_file

$sign_cert_file = ''
protected

◆ $sign_extracerts_file

$sign_extracerts_file = ''
protected

◆ $sign_key_file

$sign_key_file = ''
protected

◆ $sign_key_pass

$sign_key_pass = ''
protected

◆ $SingleTo

$SingleTo = false

◆ $SingleToArray

$SingleToArray = []
protected

◆ $smtp

$smtp
protected

Référencé par PHPMailer\getSMTPInstance(), et PHPMailer\setSMTPInstance().

◆ $SMTPAuth

$SMTPAuth = false

◆ $SMTPAutoTLS

$SMTPAutoTLS = true

◆ $SMTPDebug

$SMTPDebug = 0

◆ $SMTPKeepAlive

$SMTPKeepAlive = false

◆ $SMTPOptions

$SMTPOptions = []

Référencé par PHPMailer\smtpConnect().

◆ $SMTPSecure

$SMTPSecure = ''

Référencé par PHPMailer\smtpConnect().

◆ $Subject

$Subject = ''

◆ $Timeout

$Timeout = 300

◆ $to

$to = []
protected

Référencé par Mail\add(), PHPMailer\clearAddresses(), PHPMailer\doCallback(), PHPMailer\getToAddresses(), PHPMailer\mailPassthru(), PHPMailer\mailSend(), et PHPMailer\smtpSend().

◆ $uniqueid

$uniqueid = ''
protected

Référencé par PHPMailer\createBody().

◆ $Username

$Username = ''

◆ $UseSendmailOptions

$UseSendmailOptions = true

◆ $validator

$validator = 'php'
static

◆ $WordWrap

$WordWrap = 0

◆ $XMailer

$XMailer = ''

◆ CHARSET_ASCII

const CHARSET_ASCII = 'us-ascii'

◆ CHARSET_ISO88591

const CHARSET_ISO88591 = 'iso-8859-1'

◆ CHARSET_UTF8

const CHARSET_UTF8 = 'utf-8'

◆ CONTENT_TYPE_MULTIPART_ALTERNATIVE

const CONTENT_TYPE_MULTIPART_ALTERNATIVE = 'multipart/alternative'

◆ CONTENT_TYPE_MULTIPART_MIXED

const CONTENT_TYPE_MULTIPART_MIXED = 'multipart/mixed'

◆ CONTENT_TYPE_MULTIPART_RELATED

const CONTENT_TYPE_MULTIPART_RELATED = 'multipart/related'

◆ CONTENT_TYPE_PLAINTEXT

const CONTENT_TYPE_PLAINTEXT = 'text/plain'

◆ CONTENT_TYPE_TEXT_CALENDAR

const CONTENT_TYPE_TEXT_CALENDAR = 'text/calendar'

◆ CONTENT_TYPE_TEXT_HTML

const CONTENT_TYPE_TEXT_HTML = 'text/html'

◆ CRLF

const CRLF = "\r\n"

The SMTP standard CRLF line break. If you want to change line break format, change static::$LE, not this.

◆ ENCODING_7BIT

const ENCODING_7BIT = '7bit'

◆ ENCODING_8BIT

const ENCODING_8BIT = '8bit'

◆ ENCODING_BASE64

const ENCODING_BASE64 = 'base64'

◆ ENCODING_BINARY

const ENCODING_BINARY = 'binary'

◆ ENCODING_QUOTED_PRINTABLE

const ENCODING_QUOTED_PRINTABLE = 'quoted-printable'

◆ ENCRYPTION_SMTPS

const ENCRYPTION_SMTPS = 'ssl'

◆ ENCRYPTION_STARTTLS

const ENCRYPTION_STARTTLS = 'tls'

◆ FWS

const FWS = ' '

"Folding White Space" a white space string used for line folding.

◆ ICAL_METHOD_ADD

const ICAL_METHOD_ADD = 'ADD'

◆ ICAL_METHOD_CANCEL

const ICAL_METHOD_CANCEL = 'CANCEL'

◆ ICAL_METHOD_COUNTER

const ICAL_METHOD_COUNTER = 'COUNTER'

◆ ICAL_METHOD_DECLINECOUNTER

const ICAL_METHOD_DECLINECOUNTER = 'DECLINECOUNTER'

◆ ICAL_METHOD_PUBLISH

const ICAL_METHOD_PUBLISH = 'PUBLISH'

◆ ICAL_METHOD_REFRESH

const ICAL_METHOD_REFRESH = 'REFRESH'

◆ ICAL_METHOD_REPLY

const ICAL_METHOD_REPLY = 'REPLY'

◆ ICAL_METHOD_REQUEST

const ICAL_METHOD_REQUEST = 'REQUEST'

◆ MAIL_MAX_LINE_LENGTH

const MAIL_MAX_LINE_LENGTH = 63

◆ MAX_LINE_LENGTH

const MAX_LINE_LENGTH = 998

◆ STD_LINE_LENGTH

const STD_LINE_LENGTH = 76

◆ STOP_CONTINUE

const STOP_CONTINUE = 1

◆ STOP_CRITICAL

const STOP_CRITICAL = 2

◆ STOP_MESSAGE

const STOP_MESSAGE = 0

◆ VERSION

const VERSION = '6.6.0'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PHPMailer.php


Joomla CMS: Référence de la classe POP3

  • PHPMailer
  • PHPMailer
  • POP3
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe POP3

Fonctions membres publiques

authorise ($host, $port=false, $timeout=false, $username='', $password='', $debug_level=0)
connect ($host, $port=false, $tval=30)
login ($username='', $password='')
disconnect ()
getErrors ()

Fonctions membres publiques statiques

static popBeforeSmtp ( $host, $port=false, $timeout=false, $username='', $password='', $debug_level=0)

Champs de données

const | VERSION = '6.6.0'
const | DEFAULT_PORT = 110
const | DEFAULT_TIMEOUT = 30
$do_debug = self::DEBUG_OFF
$host
$port
$tval
$username
$password
const | LE = "\r\n"
const | DEBUG_OFF = 0
const | DEBUG_SERVER = 1
const | DEBUG_CLIENT = 2

Fonctions membres protégées

getResponse ($size=128)
sendString ($string)
checkResponse ($string)
setError ($error)
catchWarning ($errno, $errstr, $errfile, $errline)

Attributs protégés

$pop_conn
$connected = false
$errors = []

Description détaillée

PHPMailer POP-Before-SMTP Authentication Class. Specifically for PHPMailer to use for RFC1939 POP-before-SMTP authentication. 1) This class does not support APOP authentication. 2) Opening and closing lots of POP3 connections can be quite slow. If you need to send a batch of emails then just perform the authentication once at the start, and then loop through your mail sending script. Providing this process doesn't take longer than the verification period lasts on your POP3 server, you should be fine. 3) This is really ancient technology; you should only need to use it to talk to very old systems. 4) This POP3 class is deliberately lightweight and incomplete, implementing just enough to do authentication. If you want a more complete class there are other POP3 classes for PHP available.

Auteur
Richard Davey (original author) rich@.nosp@m.core.nosp@m.php.c.nosp@m.o.uk
Marcus Bointon (Synchro/coolbru) phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k
Jim Jagielski (jimjag) jimja.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om
Andy Prevost (codeworxtech) codew.nosp@m.orxt.nosp@m.ech@u.nosp@m.sers.nosp@m..sour.nosp@m.cefo.nosp@m.rge.n.nosp@m.et

Documentation des fonctions membres

◆ authorise()

authorise | ( | $host,
 |  | $port = false,
 |  | $timeout = false,
 |  | $username = '',
 |  | $password = '',
 |  | $debug_level = 0
 | ) |

Authenticate with a POP3 server. A connect, login, disconnect sequence appropriate for POP-before SMTP authorisation.

Paramètres
string | $host | The hostname to connect to
int | bool | $port | The port number to connect to
int | bool | $timeout | The timeout value
string | $username
string | $password
int | $debug_level
Renvoie
bool

Références POP3\$host, POP3\$password, POP3\$port, $result, POP3\$username, POP3\connect(), POP3\disconnect(), et POP3\login().

◆ catchWarning()

catchWarning | ( | $errno,
 |  | $errstr,
 |  | $errfile,
 |  | $errline
 | ) |
protected

POP3 connection error handler.

Paramètres
int | $errno
string | $errstr
string | $errfile
int | $errline

Références POP3\setError().

◆ checkResponse()

checkResponse ( $string )
protected

Checks the POP3 server response. Looks for for +OK or -ERR.

Paramètres
string $string
Renvoie
bool

Références POP3\setError().

Référencé par POP3\connect(), et POP3\login().

◆ connect()

connect | ( | $host,
 |  | $port = false,
 |  | $tval = 30
 | ) |

Connect to a POP3 server.

Paramètres
string | $host
int | bool | $port
int | $tval
Renvoie
bool

Références POP3\$host, POP3\$port, $this, POP3\$tval, POP3\checkResponse(), POP3\getResponse(), et POP3\setError().

Référencé par POP3\authorise().

◆ disconnect()

disconnect ( )

Disconnect from the POP3 server.

Références POP3\getResponse(), et POP3\sendString().

Référencé par POP3\authorise().

◆ getErrors()

getErrors ( )

Get an array of error messages, if any.

Renvoie
array

Références POP3\$errors.

◆ getResponse()

getResponse ( $size = 128 )
protected

Get a response from the POP3 server.

Paramètres
int $size The maximum number of bytes to retrieve
Renvoie
string

Références $size.

Référencé par POP3\connect(), POP3\disconnect(), et POP3\login().

◆ login()

login | ( | $username = '',
 |  | $password = ''
 | ) |

Log in to the POP3 server. Does not support APOP (RFC 2828, 4949).

Paramètres
string | $username
string | $password
Renvoie
bool

Références POP3\$password, POP3\$username, POP3\checkResponse(), POP3\getResponse(), POP3\sendString(), et POP3\setError().

Référencé par POP3\authorise().

◆ popBeforeSmtp()

static popBeforeSmtp | ( | $host,
 |  | $port = false,
 |  | $timeout = false,
 |  | $username = '',
 |  | $password = '',
 |  | $debug_level = 0
 | ) |
static

Simple static wrapper for all-in-one POP before SMTP.

Paramètres
string | $host | The hostname to connect to
int | bool | $port | The port number to connect to
int | bool | $timeout | The timeout value
string | $username
string | $password
int | $debug_level
Renvoie
bool

Références POP3\$host, POP3\$password, POP3\$port, et POP3\$username.

◆ sendString()

sendString ( $string )
protected

Send raw data to the POP3 server.

Paramètres
string $string
Renvoie
int

Référencé par POP3\disconnect(), et POP3\login().

◆ setError()

setError ( $error )
protected

Add an error to the internal error store. Also display debug output if it's enabled.

Paramètres
string $error

Référencé par POP3\catchWarning(), POP3\checkResponse(), POP3\connect(), et POP3\login().

Documentation des champs

◆ $connected

$connected = false
protected

◆ $do_debug

$do_debug = self::DEBUG_OFF

◆ $errors

$errors = []
protected

Référencé par POP3\getErrors().

◆ $host

$host

Référencé par POP3\authorise(), POP3\connect(), et POP3\popBeforeSmtp().

◆ $password

$password

Référencé par POP3\authorise(), POP3\login(), et POP3\popBeforeSmtp().

◆ $pop_conn

$pop_conn
protected

◆ $port

$port

Référencé par POP3\authorise(), POP3\connect(), et POP3\popBeforeSmtp().

◆ $tval

$tval

Référencé par POP3\connect().

◆ $username

$username

Référencé par POP3\authorise(), POP3\login(), et POP3\popBeforeSmtp().

◆ DEBUG_CLIENT

const DEBUG_CLIENT = 2

◆ DEBUG_OFF

const DEBUG_OFF = 0

◆ DEBUG_SERVER

const DEBUG_SERVER = 1

◆ DEFAULT_PORT

const DEFAULT_PORT = 110

◆ DEFAULT_TIMEOUT

const DEFAULT_TIMEOUT = 30

◆ LE

const LE = "\r\n"

Line break constant.

◆ VERSION

const VERSION = '6.6.0'
La documentation de cette classe a été générée à partir du fichier suivant :
  • POP3.php


Joomla CMS: Référence de la classe SMTP

  • PHPMailer
  • PHPMailer
  • SMTP
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe SMTP

Fonctions membres publiques

connect ($host, $port=null, $timeout=30, $options=[])
startTLS ()
authenticate ( $username, $password, $authtype=null, $OAuth=null)
connected ()
close ()
data ($msg_data)
hello ($host='')
mail ($from)
quit ($close_on_error=true)
recipient ($address, $dsn='')
reset ()
sendAndMail ($from)
verify ($name)
noop ()
turn ()
client_send ($data, $command='')
getError ()
getServerExtList ()
getServerExt ($name)
getLastReply ()
setVerp ($enabled=false)
getVerp ()
setDebugOutput ($method='echo')
getDebugOutput ()
setDebugLevel ($level=0)
getDebugLevel ()
setTimeout ($timeout=0)
getTimeout ()
getLastTransactionID ()

Champs de données

const | VERSION = '6.6.0'
const | LE = "\r\n"
const | DEFAULT_PORT = 25
const | MAX_LINE_LENGTH = 998
const | MAX_REPLY_LENGTH = 512
const | DEBUG_OFF = 0
const | DEBUG_CLIENT = 1
const | DEBUG_SERVER = 2
const | DEBUG_CONNECTION = 3
const | DEBUG_LOWLEVEL = 4
$do_debug = self::DEBUG_OFF
$Debugoutput = 'echo'
$do_verp = false
$Timeout = 300
$Timelimit = 300

Fonctions membres protégées

edebug ($str, $level=0)
getSMTPConnection ($host, $port=null, $timeout=30, $options=[])
hmac ($data, $key)
sendHello ($hello, $host)
parseHelloFields ($type)
sendCommand ($command, $commandstring, $expect)
get_lines ()
setError ($message, $detail='', $smtp_code='', $smtp_code_ex='')
errorHandler ($errno, $errmsg, $errfile='', $errline=0)
recordLastTransactionID ()

Attributs protégés

$smtp_transaction_id_patterns
$last_smtp_transaction_id
$smtp_conn
$error
$helo_rply
$server_caps
$last_reply = ''

Description détaillée

PHPMailer RFC821 SMTP email transport class. Implements RFC 821 SMTP commands and provides some utility methods for sending mail to an SMTP server.

Auteur
Chris Ryan
Marcus Bointon phpma.nosp@m.iler.nosp@m.@sync.nosp@m.hrom.nosp@m.edia..nosp@m.co.u.nosp@m.k

Documentation des fonctions membres

◆ authenticate()

authenticate | ( | $username,
 |  | $password,
 |  | $authtype = null,
 |  | $OAuth = null
 | ) |

Perform SMTP authentication. Must be run after hello().

Voir également
hello()
Paramètres
string | $username | The user name
string | $password | The password
string | $authtype | The auth type (CRAM-MD5, PLAIN, LOGIN, XOAUTH2)
OAuthTokenProvider | $OAuth | An optional OAuthTokenProvider instance for XOAUTH2 authentication
Renvoie
bool True if successfully authenticated

Références $method, $password, SMTP\edebug(), elseif, SMTP\hmac(), null, SMTP\sendCommand(), et SMTP\setError().

◆ client_send()

client_send | ( | $data,
 |  | $command = ''
 | ) |

Send raw data to the server.

Paramètres
string | $data | The data to send
string | $command | Optionally, the command this is part of, used only for controlling debug output
Renvoie
int|bool The number of bytes sent to the server or false on error

Références $data, $result, $this, et SMTP\edebug().

Référencé par SMTP\data(), et SMTP\sendCommand().

◆ close()

close ( )

Close the socket and clean up the state of the class. Don't use this function without first trying to use QUIT.

Voir également
quit()

Références SMTP\edebug(), null, et SMTP\setError().

Référencé par SMTP\connect(), SMTP\connected(), et SMTP\quit().

◆ connect()

connect | ( | $host,
 |  | $port = null,
 |  | $timeout = 30,
 |  | $options = []
 | ) |

Connect to an SMTP server.

Paramètres
string | $host | SMTP server IP or host name
int | $port | The port number to connect to
int | $timeout | How long to wait for the connection to open
array | $options | An array of options for stream_context_create()
Renvoie
bool

Références $options, SMTP\close(), SMTP\connected(), SMTP\edebug(), SMTP\get_lines(), SMTP\getSMTPConnection(), SMTP\quit(), et SMTP\setError().

◆ connected()

connected ( )

Check connection state.

Renvoie
bool True if connected

Références SMTP\close(), et SMTP\edebug().

Référencé par SMTP\connect(), et SMTP\sendCommand().

◆ data()

data ( $msg_data )

Send an SMTP DATA command. Issues a data command and sends the msg_data to the server, finalizing the mail transaction. $msg_data is the message that is to be send with the headers. Each header needs to be on a single line followed by a <CRLF> with the message headers and the message body being separated by an additional <CRLF>. Implements RFC 821: DATA <CRLF>.

Paramètres
string $msg_data Message data to send
Renvoie
bool

Références $field, $result, SMTP\$Timelimit, SMTP\client_send(), SMTP\recordLastTransactionID(), et SMTP\sendCommand().

◆ edebug()

edebug | ( | $str,
 |  | $level = 0
 | ) |
protected

Output debugging info via a user-selected method.

Paramètres
string | $str | Debug string to output
int | $level | The debug level of this message; see DEBUG_* constants
Voir également
SMTP::$Debugoutput
SMTP::$do_debug

Références ENT_QUOTES.

Référencé par SMTP\authenticate(), SMTP\client_send(), SMTP\close(), SMTP\connect(), SMTP\connected(), SMTP\errorHandler(), SMTP\get_lines(), SMTP\getSMTPConnection(), SMTP\sendCommand(), et SMTP\turn().

◆ errorHandler()

errorHandler | ( | $errno,
 |  | $errmsg,
 |  | $errfile = '',
 |  | $errline = 0
 | ) |
protected

Reports an error number and string.

Paramètres
int | $errno | The error number returned by PHP
string | $errmsg | The error message returned by PHP
string | $errfile | The file the error occurred in
int | $errline | The line number the error occurred on

Références SMTP\edebug(), et SMTP\setError().

◆ get_lines()

get_lines ( )
protected

Read the SMTP server's response. Either before eof or socket timeout occurs on the operation. With SMTP we can tell if we have more lines to read if the 4th character is '-' symbol. If it is a space then we don't need to read anything else.

Renvoie
string

Références $data, $info, $message, $n, SMTP\$smtp_conn, $this, SMTP\$Timelimit, SMTP\edebug(), SMTP\getError(), null, et SMTP\setError().

Référencé par SMTP\connect(), et SMTP\sendCommand().

◆ getDebugLevel()

getDebugLevel ( )

Get debug output level.

Renvoie
int

Références SMTP\$do_debug.

◆ getDebugOutput()

getDebugOutput ( )

Get debug output method.

Renvoie
string

Références SMTP\$Debugoutput.

◆ getError()

getError ( )

Get the latest error.

Renvoie
array

Références SMTP\$error.

Référencé par SMTP\get_lines().

◆ getLastReply()

getLastReply ( )

Get the last reply from the server.

Renvoie
string

Références SMTP\$last_reply.

Référencé par SMTP\recordLastTransactionID().

◆ getLastTransactionID()

getLastTransactionID ( )

Get the queue/transaction ID of the last SMTP transaction If no reply has been received yet, it will return null. If no pattern was matched, it will return false.

Renvoie
bool|string|null
Voir également
recordLastTransactionID()

Références SMTP\$last_smtp_transaction_id.

◆ getServerExt()

getServerExt ( $name )

Get metadata about the SMTP server from its HELO/EHLO response. The method works in three ways, dependent on argument value and current state:

  1. HELO/EHLO has not been sent - returns null and populates $this->error.
  2. HELO has been sent - $name == 'HELO': returns server name $name == 'EHLO': returns boolean false $name == any other string: returns null and populates $this->error
  3. EHLO has been sent - $name == 'HELO'|'EHLO': returns the server name $name == any other string: if extension $name exists, returns True or its options (e.g. AUTH mechanisms supported). Otherwise returns False.
Paramètres
string $name Name of SMTP extension or 'HELO'|'EHLO'
Renvoie
string|bool|null

Références $name, null, et SMTP\setError().

◆ getServerExtList()

getServerExtList ( )

Get SMTP extensions available on the server.

Renvoie
array|null

Références SMTP\$server_caps.

◆ getSMTPConnection()

getSMTPConnection | ( | $host,
 |  | $port = null,
 |  | $timeout = 30,
 |  | $options = []
 | ) |
protected

Create connection to the SMTP server.

Paramètres
string | $host | SMTP server IP or host name
int | $port | The port number to connect to
int | $timeout | How long to wait for the connection to open
array | $options | An array of options for stream_context_create()
Renvoie
false|resource

Références $options, $this, SMTP\edebug(), null, et SMTP\setError().

Référencé par SMTP\connect().

◆ getTimeout()

getTimeout ( )

Get SMTP timeout.

Renvoie
int

Références SMTP\$Timeout.

◆ getVerp()

getVerp ( )

Get VERP address generation mode.

Renvoie
bool

Références SMTP\$do_verp.

◆ hello()

hello ( $host = '' )

Send an SMTP HELO or EHLO command. Used to identify the sending server to the receiving server. This makes sure that client and server are in a known state. Implements RFC 821: HELO <SP> <domain> <CRLF> and RFC 2821 EHLO.

Paramètres
string $host The host name or IP to connect to
Renvoie
bool

Références SMTP\sendHello().

◆ hmac()

hmac | ( | $data,
 |  | $key
 | ) |
protected

Calculate an MD5 HMAC hash. Works like hash_hmac('md5', $data, $key) in case that function is not available.

Paramètres
string | $data | The data to hash
string | $key | The key to hash with
Renvoie
string

Références $data, et $key.

Référencé par SMTP\authenticate().

◆ mail()

mail ( $from )

Send an SMTP MAIL command. Starts a mail transaction from the email address specified in $from. Returns true if successful or false otherwise. If True the mail transaction is started and then one or more recipient commands may be called followed by a data command. Implements RFC 821: MAIL <SP> FROM:<reverse-path> <CRLF>.

Paramètres
string $from Source address of this message
Renvoie
bool

Références SMTP\sendCommand().

◆ noop()

noop ( )

Send an SMTP NOOP command. Used to keep keep-alives alive, doesn't actually do anything.

Renvoie
bool

Références SMTP\sendCommand().

◆ parseHelloFields()

parseHelloFields ( $type )
protected

Parse a reply to HELO/EHLO command to discover server extensions. In case of HELO, the only parameter that can be discovered is a server name.

Paramètres
string $type HELO or EHLO

Références $fields, $n, $name, et $type.

Référencé par SMTP\sendHello().

◆ quit()

quit ( $close_on_error = true )

Send an SMTP QUIT command. Closes the socket if there is no error or the $close_on_error argument is true. Implements from RFC 821: QUIT <CRLF>.

Paramètres
bool $close_on_error Should the connection close if an error occurs?
Renvoie
bool

Références SMTP\$error, SMTP\close(), et SMTP\sendCommand().

Référencé par SMTP\connect().

◆ recipient()

recipient | ( | $address,
 |  | $dsn = ''
 | ) |

Send an SMTP RCPT command. Sets the TO argument to $toaddr. Returns true if the recipient was accepted false if it was rejected. Implements from RFC 821: RCPT <SP> TO:<forward-path> <CRLF>.

Paramètres
string | $address | The address the message is being sent to
string | $dsn | Comma separated list of DSN notifications. NEVER, SUCCESS, FAILURE or DELAY. If you specify NEVER all other notifications are ignored.
Renvoie
bool

Références $value, et SMTP\sendCommand().

◆ recordLastTransactionID()

recordLastTransactionID ( )
protected

Extract and return the ID of the last SMTP transaction based on a list of patterns provided in SMTP::$smtp_transaction_id_patterns. Relies on the host providing the ID in response to a DATA command. If no reply has been received yet, it will return null. If no pattern was matched, it will return false.

Renvoie
bool|string|null

Références SMTP\$last_smtp_transaction_id, SMTP\getLastReply(), et null.

Référencé par SMTP\data().

◆ reset()

reset ( )

Send an SMTP RSET command. Abort any transaction that is currently in progress. Implements RFC 821: RSET <CRLF>.

Renvoie
bool True on success

Références SMTP\sendCommand().

◆ sendAndMail()

sendAndMail ( $from )

Send an SMTP SAML command. Starts a mail transaction from the email address specified in $from. Returns true if successful or false otherwise. If True the mail transaction is started and then one or more recipient commands may be called followed by a data command. This command will send the message to the users terminal if they are logged in and send them an email. Implements RFC 821: SAML <SP> FROM:<reverse-path> <CRLF>.

Paramètres
string $from The address the message is from
Renvoie
bool

Références SMTP\sendCommand().

◆ sendCommand()

sendCommand | ( | $command,
 |  | $commandstring,
 |  | $expect
 | ) |
protected

Send a command to an SMTP server and check its return code.

Paramètres
string | $command | The command name - not sent to the server
string | $commandstring | The actual command to send
int | array | $expect | One or more expected integer success codes
Renvoie
bool True on success

Références SMTP\client_send(), SMTP\connected(), SMTP\edebug(), SMTP\get_lines(), null, et SMTP\setError().

Référencé par SMTP\authenticate(), SMTP\data(), SMTP\mail(), SMTP\noop(), SMTP\quit(), SMTP\recipient(), SMTP\reset(), SMTP\sendAndMail(), SMTP\sendHello(), SMTP\startTLS(), et SMTP\verify().

◆ sendHello()

sendHello | ( | $hello,
 |  | $host
 | ) |
protected

Send an SMTP HELO or EHLO command. Low-level implementation used by hello().

Paramètres
string | $hello | The HELO string
string | $host | The hostname to say we are
Renvoie
bool
Voir également
hello()

Références SMTP\$last_reply, null, SMTP\parseHelloFields(), et SMTP\sendCommand().

Référencé par SMTP\hello().

◆ setDebugLevel()

setDebugLevel ( $level = 0 )

Set debug output level.

Paramètres
int $level

◆ setDebugOutput()

setDebugOutput ( $method = 'echo' )

Set debug output method.

Paramètres
string | callable $method The name of the mechanism to use for debugging output, or a callable to handle it

Références $method.

◆ setError()

setError | ( | $message,
 |  | $detail = '',
 |  | $smtp_code = '',
 |  | $smtp_code_ex = ''
 | ) |
protected

Set error messages and codes.

Paramètres
string | $message | The error message
string | $detail | Further detail on the error
string | $smtp_code | An associated SMTP error code
string | $smtp_code_ex | Extended SMTP code

Références $message.

Référencé par SMTP\authenticate(), SMTP\close(), SMTP\connect(), SMTP\errorHandler(), SMTP\get_lines(), SMTP\getServerExt(), SMTP\getSMTPConnection(), SMTP\sendCommand(), et SMTP\turn().

◆ setTimeout()

setTimeout ( $timeout = 0 )

Set SMTP timeout.

Paramètres
int $timeout The timeout duration in seconds

◆ setVerp()

setVerp ( $enabled = false )

Enable or disable VERP address generation.

Paramètres
bool $enabled

Références $enabled.

◆ startTLS()

startTLS ( )

Initiate a TLS (encrypted) session.

Renvoie
bool

Références $this, et SMTP\sendCommand().

◆ turn()

turn ( )

Send an SMTP TURN command. This is an optional command for SMTP that this class does not support. This method is here to make the RFC821 Definition complete for this class and may be implemented in future. Implements from RFC 821: TURN <CRLF>.

Renvoie
bool

Références SMTP\edebug(), et SMTP\setError().

◆ verify()

verify ( $name )

Send an SMTP VRFY command.

Paramètres
string $name The name to verify
Renvoie
bool

Références SMTP\sendCommand().

Documentation des champs

◆ $Debugoutput

$Debugoutput = 'echo'

Référencé par SMTP\getDebugOutput().

◆ $do_debug

$do_debug = self::DEBUG_OFF

Référencé par SMTP\getDebugLevel().

◆ $do_verp

$do_verp = false

Référencé par SMTP\getVerp().

◆ $error

$error
protected
Valeur initiale :
= [
'error' => ''

Référencé par SMTP\getError(), et SMTP\quit().

◆ $helo_rply

$helo_rply
protected

◆ $last_reply

$last_reply = ''
protected

Référencé par SMTP\getLastReply(), et SMTP\sendHello().

◆ $last_smtp_transaction_id

$last_smtp_transaction_id
protected

Référencé par SMTP\getLastTransactionID(), et SMTP\recordLastTransactionID().

◆ $server_caps

$server_caps
protected

Référencé par SMTP\getServerExtList().

◆ $smtp_conn

$smtp_conn
protected

Référencé par SMTP\get_lines().

◆ $smtp_transaction_id_patterns

$smtp_transaction_id_patterns
protected
Valeur initiale :
= [
'exim' => '/[\d]{3} OK id=(.*)/'

◆ $Timelimit

$Timelimit = 300

Référencé par SMTP\data(), et SMTP\get_lines().

◆ $Timeout

$Timeout = 300

Référencé par SMTP\getTimeout().

◆ DEBUG_CLIENT

const DEBUG_CLIENT = 1

◆ DEBUG_CONNECTION

const DEBUG_CONNECTION = 3

◆ DEBUG_LOWLEVEL

const DEBUG_LOWLEVEL = 4

◆ DEBUG_OFF

const DEBUG_OFF = 0

◆ DEBUG_SERVER

const DEBUG_SERVER = 2

◆ DEFAULT_PORT

const DEFAULT_PORT = 25

◆ LE

const LE = "\r\n"

◆ MAX_LINE_LENGTH

const MAX_LINE_LENGTH = 998

◆ MAX_REPLY_LENGTH

const MAX_REPLY_LENGTH = 512

◆ VERSION

const VERSION = '6.6.0'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SMTP.php


Joomla CMS: Référence de la classe Strings

  • phpseclib3
  • Common
  • Functions
  • Strings
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Strings

Fonctions membres publiques statiques

static | shift (&$string, $index=1)
static | pop (&$string, $index=1)
static | unpackSSH2 ($format, &$data)
static | packSSH2 ($format,... $elements)
static | bits2bin ($x)
static | bin2bits ($x, $trim=true)
static | switchEndianness ($x)
static | increment_str (&$var)
static | is_stringable ($var)

Fonctions membres privées statiques

static formatPack ($format)

Documentation des fonctions membres

◆ bin2bits()

static bin2bits | ( | $x,
 |  | $trim = true
 | ) |
static

Convert bits to binary data

public

Paramètres
string $x
Renvoie
string

Références $mod.

Référencé par BinaryField\base256ToBase2(), et Engine\toBits().

◆ bits2bin()

static bits2bin ( $x )
static

Convert binary data into bits

bin2hex / hex2bin refer to base-256 encoded data as binary, whilst decbin / bindec refer to base-2 encoded data as binary. For the purposes of this function, bin refers to base-256 encoded data whilst bits refers to base-2 encoded data

public

Paramètres
string $x
Renvoie
string

Références $parts.

Référencé par Engine\__construct(), et BinaryField\base2ToBase256().

◆ formatPack()

static formatPack ( $format )
staticprivate

Expand a pack string

Converts C5 to CCCCC, for example.

private

Paramètres
string $format
Renvoie
string

Références $format, $i, et $parts.

◆ increment_str()

static increment_str ( & $var )
static

Increment the current string

Paramètres
string $var
Renvoie
string public

Références $i, et $temp.

Référencé par SymmetricKey\decrypt(), SymmetricKey\encrypt(), SymmetricKey\openssl_ctr_process(), et SSH2\send_binary_packet().

◆ is_stringable()

static is_stringable ( $var )
static

Find whether the type of a variable is string (or could be converted to one)

Paramètres
mixed $var
Renvoie
bool -assert-if-true string| $var

Référencé par XML\load(), OpenSSH\load(), PKCS8\load(), PSS\load(), PKCS1\load(), PuTTY\load(), SSH2\login_helper(), PKCS8\preParse(), et SSH2\sublogin().

◆ packSSH2()

static packSSH2 | ( | $format,
 |  | $elements
 | ) |
static

Create SSH2-style string

Paramètres
string | $format
string|int|float|array|bool | ...$elements public
Renvoie
string

Références $format, $i, et $result.

Référencé par SFTP\chdir(), SFTP\chgrp(), SFTP\chown(), SFTP\delete_recursive(), SSH2\disconnect_helper(), SSH2\exec(), SSH2\filter(), SFTP\get(), SFTP\init_sftp_connection(), SSH2\initShell(), SFTP\is_readable(), SFTP\is_writable(), SSH2\key_exchange(), SSH2\keyboard_interactive_login(), SSH2\keyboard_interactive_process(), PuTTY\load(), SSH2\login_helper(), SFTP\mkdir_helper(), SFTP\partial_init_sftp_connection(), SSH2\ping(), SSH2\privatekey_login(), SFTP\put(), SFTP\readlink(), SFTP\readlist(), SFTP\realpath(), SFTP\rename(), SSH2\requestAgentForwarding(), SFTP\rmdir(), SSH2\save(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), SSH2\send_channel_packet(), SFTP\setstat(), SFTP\setstat_recursive(), PrivateKey\sign(), Identity\sign(), SSH2\startSubsystem(), SFTP\stat_helper(), SFTP\symlink(), SFTP\touch(), SFTP\truncate(), OpenSSH\wrapPrivateKey(), et PuTTY\wrapPrivateKey().

◆ pop()

static pop | ( | & | $string,
 |  |  | $index = 1
 | ) |  |
static

String Pop

Inspired by array_pop

Paramètres
string | $string
int | $index | public
Renvoie
string

Référencé par Salsa20\crypt(), SymmetricKey\encrypt(), SymmetricKey\openssl_ctr_process(), et SymmetricKey\openssl_ofb_process().

◆ shift()

static shift | ( | & | $string,
 |  |  | $index = 1
 | ) |  |
static

String Shift

Inspired by array_shift

Paramètres
string | $string
int | $index | public
Renvoie
string

Référencé par SSH2\append_log(), Salsa20\crypt(), ASN1\decodeLength(), SymmetricKey\decrypt(), Prime\derivePoint(), Rijndael\encrypt(), SymmetricKey\encrypt(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), SSH2\filter(), SSH2\format_log(), SSH2\key_exchange(), OpenSSH\load(), PuTTY\load(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), SymmetricKey\poly1305(), SSH2\read(), PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PuTTY\savePrivateKey(), PuTTY\savePublicKey(), SSH2\send_channel_packet(), et Hash\sha512().

◆ switchEndianness()

static switchEndianness ( $x )
static

Switch Endianness Bit Order

public

Paramètres
string $x
Renvoie
string

Références $b, $i, et $r.

Référencé par SymmetricKey\ghash(), et SymmetricKey\setupGCM().

◆ unpackSSH2()

static unpackSSH2 | ( |  | $format,
 |  | & | $data
 | ) |  |
static

Parse SSH2-style string

Returns either an array or a boolean if $data is malformed.

Valid characters for $format are as follows:

C = byte b = boolean (true/false) N = uint32 Q = uint64 s = string i = mpint L = name-list

uint64 is not supported.

Paramètres
string | $format
string | $data
Renvoie
mixed

Références $data, $format, $i, $result, et $temp.

Référencé par SFTP\close_handle(), SFTP\delete(), SSH2\filter(), SSH2\get_channel_packet(), SSH2\getServerPublicHostKey(), SFTP\init_sftp_connection(), SSH2\key_exchange(), SSH2\keyboard_interactive_process(), SSH2\load(), PuTTY\load(), OpenSSH\load(), SFTP\logError(), SSH2\login_helper(), SFTP\mkdir_helper(), SFTP\parseAttributes(), SFTP\parseTime(), SFTP\partial_init_sftp_connection(), SSH2\privatekey_login(), SFTP\read_put_responses(), SFTP\readlink(), SFTP\readlist(), SFTP\realpath(), SFTP\rename(), Agent\requestIdentities(), SFTP\rmdir(), SFTP\setstat(), Identity\sign(), SFTP\symlink(), et PublicKey\verify().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Strings.php


Joomla CMS: Référence de la classe OpenSSH

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
  • OpenSSH
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe OpenSSH

Fonctions membres publiques statiques

static | setComment ($comment)
static | load ($key, $password='')
static | setBinaryOutput ($enabled)

Fonctions membres protégées statiques

static wrapPrivateKey ($publicKey, $privateKey, $password, $options)

Attributs protégés statiques

static | $comment = 'phpseclib-generated-key'
static | $binary = false

Fonctions membres privées statiques

static checkType ($candidate)

Documentation des fonctions membres

◆ checkType()

static checkType ( $candidate )
staticprivate

Checks to see if the type is valid

private

Paramètres
string $candidate

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

$type can be either ssh-dss or ssh-rsa

public

Paramètres
string | $key
string | $password
Renvoie
array

Références OpenSSH\$comment, $key, $parts, $type, EncoderInterface\decode(), Strings\is_stringable(), Strings\shift(), et Strings\unpackSSH2().

◆ setBinaryOutput()

static setBinaryOutput ( $enabled )
static

Toggle between binary and printable keys

Printable keys are what are generated by default. These are the ones that go in $HOME/.ssh/authorized_key.

public

Paramètres
bool $enabled

Références $enabled.

◆ setComment()

static setComment ( $comment )
static

Sets the default comment

public

Paramètres
string $comment

Références OpenSSH\$comment.

◆ wrapPrivateKey()

static wrapPrivateKey | ( | $publicKey,
 |  | $privateKey,
 |  | $password,
 |  | $options
 | ) |
staticprotected

Wrap a private key appropriately

public

Paramètres
string | $publicKey
string | $privateKey
string | $password
array | $options
Renvoie
string

Références OpenSSH\$comment, $i, $key, $options, $password, Base64\encode(), Strings\packSSH2(), et Random\string().

Documentation des champs

◆ $binary

$binary = false
staticprotected

◆ $comment

$comment = 'phpseclib-generated-key'
staticprotected

Référencé par OpenSSH\load(), OpenSSH\setComment(), et OpenSSH\wrapPrivateKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Common/Formats/Keys/OpenSSH.php


Joomla CMS: Référence de la classe PKCS

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
  • PKCS
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PKCS
+ Graphe d'héritage de PKCS:
PKCS1 PKCS8

Fonctions membres publiques statiques

static | requirePEM ()
static | requireDER ()
static | requireAny ()

Champs de données

const | MODE_ANY = 0
const | MODE_PEM = 1
const | MODE_DER = 2

Attributs protégés statiques

static $format = self::MODE_ANY

Documentation des fonctions membres

◆ requireAny()

static requireAny ( )
static

Accept any format and auto detect the format

This is the default setting

public

Références $format.

◆ requireDER()

static requireDER ( )
static

Require raw DER's be supplied

public

Références $format.

◆ requirePEM()

static requirePEM ( )
static

Require base64-encoded PEM's be supplied

public

Références $format.

Documentation des champs

◆ $format

$format = self::MODE_ANY
staticprotected

◆ MODE_ANY

const MODE_ANY = 0

Auto-detect the format

◆ MODE_DER

const MODE_DER = 2

Require raw DER's be supplied

◆ MODE_PEM

const MODE_PEM = 1

Require base64-encoded PEM's be supplied

La documentation de cette classe a été générée à partir du fichier suivant :
  • PKCS.php


Joomla CMS: Référence de la classe PKCS1

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
  • PKCS1
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe PKCS1
+ Graphe d'héritage de PKCS1:
PKCS

Fonctions membres publiques statiques

static | setEncryptionAlgorithm ($algo)
- Fonctions membres publiques statiques hérités de PKCS
static | requirePEM ()
static | requireDER ()
static | requireAny ()

Fonctions membres protégées statiques

static | load ($key, $password)
static | wrapPrivateKey ($key, $type, $password, array $options=[])
static | wrapPublicKey ($key, $type)

Fonctions membres privées statiques

static | getEncryptionMode ($mode)
static | getEncryptionObject ($algo)
static | generateSymmetricKey ($password, $iv, $length)

Attributs privés statiques

static $defaultEncryptionAlgorithm = 'AES-128-CBC'

Membres hérités additionnels

- Champs de données hérités de PKCS
const | MODE_ANY = 0
const | MODE_PEM = 1
const | MODE_DER = 2
- Attributs protégés statiques hérités de PKCS
static | $format = self::MODE_ANY

Documentation des fonctions membres

◆ generateSymmetricKey()

static generateSymmetricKey | ( | $password,
 |  | $iv,
 |  | $length
 | ) |
staticprivate

Generate a symmetric key for PKCS#1 keys

private

Paramètres
string | $password
string | $iv
int | $length
Renvoie
string

Références $password.

◆ getEncryptionMode()

static getEncryptionMode ( $mode )
staticprivate

Returns the mode constant corresponding to the mode string

public

Paramètres
string $mode
Renvoie
int
Exceptions

Références $mode.

◆ getEncryptionObject()

static getEncryptionObject ( $algo )
staticprivate

Returns a cipher object corresponding to a string

public

Paramètres
string $algo
Renvoie
string
Exceptions

◆ load()

static load | ( | $key,
 |  | $password
 | ) |
staticprotected

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $format, $key, $password, EncoderInterface\decode(), elseif, ASN1\extractBER(), et Strings\is_stringable().

◆ setEncryptionAlgorithm()

static setEncryptionAlgorithm ( $algo )
static

Sets the default encryption algorithm

public

Paramètres
string $algo

◆ wrapPrivateKey()

static wrapPrivateKey | ( |  | $key,
 |  |  | $type,
 |  |  | $password,
 |  | array | $options = []
 | ) |  |
staticprotected

Wrap a private key appropriately

public

Paramètres
string | $key
string | $type
string | $password
array | $options | optional
Renvoie
string

Références $key, $options, $password, EncoderInterface\encode(), Base64\encode(), et Random\string().

◆ wrapPublicKey()

static wrapPublicKey | ( | $key,
 |  | $type
 | ) |
staticprotected

Wrap a public key appropriately

public

Paramètres
string | $key
string | $type
Renvoie
string

Références $key, et Base64\encode().

Documentation des champs

◆ $defaultEncryptionAlgorithm

$defaultEncryptionAlgorithm = 'AES-128-CBC'
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • Common/Formats/Keys/PKCS1.php


Joomla CMS: Référence de la classe PKCS8

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
  • PKCS8
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe PKCS8
+ Graphe d'héritage de PKCS8:
PKCS

Fonctions membres publiques statiques

static | setEncryptionAlgorithm ($algo)
static | setEncryptionScheme ($algo)
static | setIterationCount ($count)
static | setPRF ($algo)
static | extractEncryptionAlgorithm ($key)
- Fonctions membres publiques statiques hérités de PKCS
static | requirePEM ()
static | requireDER ()
static | requireAny ()

Fonctions membres protégées statiques

static | load ($key, $password='')
static | wrapPrivateKey ($key, $attr, $params, $password, $oid=null, $publicKey='', array $options=[])
static | wrapPublicKey ($key, $params, $oid=null)

Fonctions membres privées statiques

static | getPBES1EncryptionObject ($algo)
static | getPBES1Hash ($algo)
static | getPBES1KDF ($algo)
static | getPBES2EncryptionObject ($algo)
static | initialize_static_variables ()
static | preParse (&$key)

Attributs privés statiques

static | $defaultEncryptionAlgorithm = 'id-PBES2'
static | $defaultEncryptionScheme = 'aes128-CBC-PAD'
static | $defaultPRF = 'id-hmacWithSHA256'
static | $defaultIterationCount = 2048
static | $oidsLoaded = false

Membres hérités additionnels

- Champs de données hérités de PKCS
const | MODE_ANY = 0
const | MODE_PEM = 1
const | MODE_DER = 2
- Attributs protégés statiques hérités de PKCS
static | $format = self::MODE_ANY

Documentation des fonctions membres

◆ extractEncryptionAlgorithm()

static extractEncryptionAlgorithm ( $key )
static

Returns the encryption parameters used by the key

Paramètres
string $key
Renvoie
array

Références $key, $r, ASN1\asn1map(), et ASN1\decodeBER().

◆ getPBES1EncryptionObject()

static getPBES1EncryptionObject ( $algo )
staticprivate

Returns a SymmetricKey object based on a PBES1 $algo

Renvoie
public
Paramètres
string $algo

◆ getPBES1Hash()

static getPBES1Hash ( $algo )
staticprivate

Returns a hash based on a PBES1 $algo

Renvoie
string public
Paramètres
string $algo

◆ getPBES1KDF()

static getPBES1KDF ( $algo )
staticprivate

Returns a KDF baesd on a PBES1 $algo

Renvoie
string public
Paramètres
string $algo

◆ getPBES2EncryptionObject()

static getPBES2EncryptionObject ( $algo )
staticprivate

Returns a SymmetricKey object baesd on a PBES2 $algo

Renvoie
SymmetricKey public
Paramètres
string $algo

◆ initialize_static_variables()

static initialize_static_variables ( )
staticprivate

Initialize static variables

private

Références phpseclib3\Crypt\EC\Formats\Keys\$childOIDsLoaded, et ASN1\loadOIDs().

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
staticprotected

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $hash, $key, $params, $password, $temp, ASN1\asn1map(), et ASN1\decodeBER().

◆ preParse()

static preParse ( & $key )
staticprivate

Perform some preliminary parsing of the key

Paramètres
string $key
Renvoie
array

Références $format, $key, ASN1\decodeBER(), elseif, ASN1\extractBER(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et Strings\is_stringable().

◆ setEncryptionAlgorithm()

static setEncryptionAlgorithm ( $algo )
static

Sets the default encryption algorithm

public

Paramètres
string $algo

◆ setEncryptionScheme()

static setEncryptionScheme ( $algo )
static

Sets the default encryption algorithm for PBES2

public

Paramètres
string $algo

◆ setIterationCount()

static setIterationCount ( $count )
static

Sets the iteration count

public

Paramètres
int $count

Références $count.

◆ setPRF()

static setPRF ( $algo )
static

Sets the PRF for PBES2

public

Paramètres
string $algo

◆ wrapPrivateKey()

static wrapPrivateKey | ( |  | $key,
 |  |  | $attr,
 |  |  | $params,
 |  |  | $password,
 |  |  | $oid = null,
 |  |  | $publicKey = '',
 |  | array | $options = []
 | ) |  |
staticprotected

Wrap a private key appropriately

public

Paramètres
string | $key
string | $attr
mixed | $params
string | $password
string | $oid | optional
string | $publicKey | optional
array | $options | optional
Renvoie
string

Références $attr, $hash, $key, $oid, $options, $params, $password, Base64\encode(), ASN1\encodeDER(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), null, et Random\string().

◆ wrapPublicKey()

static wrapPublicKey | ( | $key,
 |  | $params,
 |  | $oid = null
 | ) |
staticprotected

Wrap a public key appropriately

public

Paramètres
string | $key
mixed | $params
string | $oid
Renvoie
string

Références $key, $oid, $params, Base64\encode(), ASN1\encodeDER(), et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

Documentation des champs

◆ $defaultEncryptionAlgorithm

$defaultEncryptionAlgorithm = 'id-PBES2'
staticprivate

◆ $defaultEncryptionScheme

$defaultEncryptionScheme = 'aes128-CBC-PAD'
staticprivate

◆ $defaultIterationCount

$defaultIterationCount = 2048
staticprivate

◆ $defaultPRF

$defaultPRF = 'id-hmacWithSHA256'
staticprivate

◆ $oidsLoaded

$oidsLoaded = false
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • Common/Formats/Keys/PKCS8.php


Joomla CMS: Référence de la classe PuTTY

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Keys
  • PuTTY
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe PuTTY

Fonctions membres publiques statiques

static | setComment ($comment)
static | setVersion ($version)
static | load ($key, $password)

Fonctions membres protégées statiques

static | wrapPrivateKey ($public, $private, $type, $password, array $options=[])
static | wrapPublicKey ($key, $type)

Fonctions membres privées statiques

static | generateV2Key ($password, $length)
static | generateV3Key ($password, $flavour, $memory, $passes, $salt)

Attributs privés statiques

static | $comment = 'phpseclib-generated-key'
static | $version = 2

Documentation des fonctions membres

◆ generateV2Key()

static generateV2Key | ( | $password,
 |  | $length
 | ) |
staticprivate

Generate a symmetric key for PuTTY v2 keys

private

Paramètres
string | $password
int | $length
Renvoie
string

Références $password, $temp, et EncoderInterface\decode().

◆ generateV3Key()

static generateV3Key | ( | $password,
 |  | $flavour,
 |  | $memory,
 |  | $passes,
 |  | $salt
 | ) |
staticprivate

Generate a symmetric key for PuTTY v3 keys

private

Paramètres
string | $password
string | $flavour
int | $memory
int | $passes
string | $salt
Renvoie
array

Références $password, $temp, SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13, et SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13.

◆ load()

static load | ( | $key,
 |  | $password
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password
Renvoie
array

Références $data, $hash, $key, Joomla\Database\Query\$offset, $password, $type, PuTTY\$version, EncoderInterface\decode(), Strings\is_stringable(), Strings\packSSH2(), et Strings\shift().

◆ setComment()

static setComment ( $comment )
static

Sets the default comment

public

Paramètres
string $comment

Références PuTTY\$comment.

◆ setVersion()

static setVersion ( $version )
static

Sets the default version

public

Paramètres
int $version

Références PuTTY\$version, et $version.

◆ wrapPrivateKey()

static wrapPrivateKey | ( |  | $public,
 |  |  | $private,
 |  |  | $type,
 |  |  | $password,
 |  | array | $options = []
 | ) |  |
staticprotected

Wrap a private key appropriately

private

Paramètres
string | $public
string | $private
string | $type
string | $password
array | $options | optional
Renvoie
string

Références PuTTY\$comment, $hash, $key, $options, $password, $type, PuTTY\$version, $version, EncoderInterface\encode(), Base64\encode(), Strings\packSSH2(), et Random\string().

◆ wrapPublicKey()

static wrapPublicKey | ( | $key,
 |  | $type
 | ) |
staticprotected

Wrap a public key appropriately

This is basically the format described in RFC 4716 (https://tools.ietf.org/html/rfc4716)

private

Paramètres
string | $key
string | $type
Renvoie
string

Références $key, $type, et Base64\encode().

Documentation des champs

◆ $comment

$comment = 'phpseclib-generated-key'
staticprivate

Référencé par PuTTY\setComment(), et PuTTY\wrapPrivateKey().

◆ $version

$version = 2
staticprivate

Référencé par PuTTY\load(), PuTTY\setVersion(), et PuTTY\wrapPrivateKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Common/Formats/Keys/PuTTY.php


Joomla CMS: Référence de la classe Raw

  • phpseclib3
  • Crypt
  • Common
  • Formats
  • Signature
  • Raw
Fonctions membres publiques statiques
Référence de la classe Raw

Fonctions membres publiques statiques

static | load ($sig)
static | save (BigInteger $r, BigInteger $s)

Documentation des fonctions membres

◆ load()

static load ( $sig )
static

Loads a signature

public

Paramètres
array $sig
Renvoie
array|bool

◆ save()

static save | ( | BigInteger | $r,
 |  | BigInteger | $s
 | ) |  |
static

Returns a signature in the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $r
\phpseclib3\Math\BigInteger | $s
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Common/Formats/Signature/Raw.php


Joomla CMS: Référence de la classe AsymmetricKey

  • phpseclib3
  • Crypt
  • Common
  • AsymmetricKey
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe AsymmetricKey
+ Graphe d'héritage de AsymmetricKey:
DH DSA EC RSA Parameters PrivateKey PublicKey Parameters PrivateKey PublicKey Parameters PrivateKey PublicKey PrivateKey PublicKey

Fonctions membres publiques

toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Fonctions membres publiques statiques

static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()

Fonctions membres protégées

__construct ()
computek ($h1)
bits2int ($in)

Fonctions membres protégées statiques

static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)

Attributs protégés

$format
$hash

Attributs protégés statiques

static | $zero
static | $one
static | $engines = []

Fonctions membres privées

int2octets ($v)
bits2octets ($in)

Fonctions membres privées statiques

static loadPlugins ($format)

Attributs privés

$hmac
$comment

Attributs privés statiques

static | $plugins = []
static | $invisiblePlugins = []
static | $signatureFormats = []
static | $signatureFileFormats = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

The constructor

Références phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

Documentation des fonctions membres

◆ __toString()

__toString ( )

__toString() magic method

Renvoie
string

Références AsymmetricKey\toString().

◆ addFileFormat()

static addFileFormat ( $fullname )
static

Add a fileformat plugin

The plugin needs to either already be loaded or be auto-loadable. Loading a plugin whose shortname overwrite an existing shortname will overwrite the old plugin.

Voir également
self::load()
Paramètres
string $fullname public
Renvoie
bool

Références $name, et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ bits2int()

bits2int ( $in )
protected

Bit String to Integer

private

Paramètres
string $in
Renvoie

Référencé par AsymmetricKey\bits2octets(), AsymmetricKey\computek(), PrivateKey\sign(), et PublicKey\verify().

◆ bits2octets()

bits2octets ( $in )
private

Bit String to Octet String

private

Paramètres
string $in
Renvoie
string

Références AsymmetricKey\bits2int(), et AsymmetricKey\int2octets().

Référencé par AsymmetricKey\computek().

◆ computek()

computek ( $h1 )
protected

Compute the pseudorandom k for signature generation, using the process specified for deterministic DSA.

public

Paramètres
string $h1
Renvoie
string

Références AsymmetricKey\bits2int(), AsymmetricKey\bits2octets(), et AsymmetricKey\int2octets().

◆ getComment()

getComment ( )

Returns the key's comment

Not all key formats support comments. If you want to set a comment use toString()

public

Renvoie
null|string

Références AsymmetricKey\$comment.

◆ getHash()

getHash ( )

Returns the hash algorithm currently being used

public

Références AsymmetricKey\$hash.

◆ getLoadedFormat()

getLoadedFormat ( )

Returns the format of the loaded key.

If the key that was loaded wasn't in a valid or if the key was auto-generated with RSA::createKey() then this will throw an exception.

Voir également
self::load() public
Renvoie
mixed

◆ getSupportedKeyFormats()

static getSupportedKeyFormats ( )
static

Returns a list of supported formats.

public

Renvoie
array

Références phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ initialize_static_variables()

static initialize_static_variables ( )
staticprotected

Initialize static variables

◆ int2octets()

int2octets ( $v )
private

Integer to Octet String

private

Paramètres
\phpseclib3\Math\BigInteger $v
Renvoie
string

Références elseif.

Référencé par AsymmetricKey\bits2octets(), et AsymmetricKey\computek().

◆ load()

static load | ( | $key,
 |  | $password = false
 | ) |
static

Load the key

Paramètres
string | $key
string | $password | optional
Renvoie
AsymmetricKey

Références AsymmetricKey\$comment, AsymmetricKey\$format, $key, $password, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), null, et PrivateKey\withPassword().

Référencé par DSA\getParameters(), EC\getParameters(), PublicKeyLoader\load(), et DH\load().

◆ loadFormat()

static loadFormat | ( | $type,
 |  | $key,
 |  | $password = false
 | ) |
static

Load the key, assuming a specific format

Paramètres
string | $type
string | $key
string | $password | optional
Renvoie
static

Références AsymmetricKey\$format, $key, $password, $type, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et PrivateKey\withPassword().

Référencé par EC\createKey(), PrivateKey\getPublicKey(), X509\getPublicKey(), SSH2\getServerPublicHostKey(), et X509\validateSignatureHelper().

◆ loadParameters()

static loadParameters ( $key )
static

Loads parameters

Renvoie
AsymmetricKey public
Paramètres
string | array $key

Références $key.

◆ loadParametersFormat()

static loadParametersFormat | ( | $type,
 |  | $key
 | ) |
static

Loads parameters

Renvoie
AsymmetricKey public
Paramètres
string | $type
string | array | $key

Références $key, et $type.

◆ loadPlugins()

static loadPlugins ( $format )
staticprivate

Load Plugins

private

Paramètres
string $format

Références AsymmetricKey\$format, $name, $type, et __DIR__.

◆ loadPrivateKey()

static loadPrivateKey | ( | $key,
 |  | $password = ''
 | ) |
static

Loads a private key

Renvoie
PrivateKey public
Paramètres
string | array | $key
string | $password | optional

Références $key, et $password.

◆ loadPrivateKeyFormat()

static loadPrivateKeyFormat | ( | $type,
 |  | $key,
 |  | $password = false
 | ) |
static

Loads a private key

Renvoie
PrivateKey public
Paramètres
string | $type
string | $key
string | $password | optional

Références $key, $password, et $type.

◆ loadPublicKey()

static loadPublicKey ( $key )
static

Loads a public key

Renvoie
PublicKey public
Paramètres
string | array $key

Références $key.

◆ loadPublicKeyFormat()

static loadPublicKeyFormat | ( | $type,
 |  | $key
 | ) |
static

Loads a public key

Renvoie
PublicKey public
Paramètres
string | $type
string | $key

Références $key, et $type.

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |
abstract
Paramètres
string $type
Renvoie
string

Référencé par AsymmetricKey\__toString(), et phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam().

◆ useBestEngine()

static useBestEngine ( )
static

Tests engine validity

public

◆ useInternalEngine()

static useInternalEngine ( )
static

Flag to use internal engine only (useful for unit testing)

public

Références false.

◆ validatePlugin()

static validatePlugin | ( | $format,
 |  | $type,
 |  | $method = null
 | ) |
staticprotected

Validate Plugin

private

Paramètres
string | $format
string | $type
string | $method | optional
Renvoie
mixed

Références AsymmetricKey\$format, $method, et $type.

◆ withHash()

withHash ( $hash )

Determines which hashing function should be used

public

Paramètres
string $hash

Références AsymmetricKey\$hash, et $this.

Documentation des champs

◆ $comment

$comment
private

Référencé par AsymmetricKey\getComment(), OpenSSH\load(), AsymmetricKey\load(), et OpenSSH\savePublicKey().

◆ $engines

$engines = []
staticprotected

◆ $format

$format
protected

Référencé par PublicKey\asPrivateKey(), AsymmetricKey\load(), AsymmetricKey\loadFormat(), AsymmetricKey\loadPlugins(), PrivateKey\sign(), AsymmetricKey\validatePlugin(), PublicKey\verify(), et DSA\withSignatureFormat().

◆ $hash

$hash
protected

Référencé par Ed448\extractSecret(), Ed25519\extractSecret(), AsymmetricKey\getHash(), PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PrivateKey\sign(), PublicKey\verify(), EC\withHash(), AsymmetricKey\withHash(), RSA\withHash(), et RSA\withMGFHash().

◆ $hmac

$hmac
private

◆ $invisiblePlugins

$invisiblePlugins = []
staticprivate

◆ $one

$one
staticprotected

Référencé par DH\createKey(), Base\createRandomMultiplier(), et Raw\load().

◆ $plugins

$plugins = []
staticprivate

◆ $signatureFileFormats

$signatureFileFormats = []
staticprivate

◆ $signatureFormats

$signatureFormats = []
staticprivate

◆ $zero

$zero
staticprotected

Référencé par KoblitzPrime\extendedGCD(), KoblitzPrime\multiplyAddPoints(), Prime\multiplyAddPoints(), et Base\rangeCheck().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AsymmetricKey.php


Joomla CMS: Référence de la classe BlockCipher

  • phpseclib3
  • Crypt
  • Common
  • BlockCipher
Référence de la classe BlockCipher
+ Graphe d'héritage de BlockCipher:
SymmetricKey Blowfish DES RC2 Rijndael Twofish TripleDES AES

Membres hérités additionnels

- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false
La documentation de cette classe a été générée à partir du fichier suivant :
  • BlockCipher.php


Joomla CMS: Référence de l'interface PrivateKey

  • phpseclib3
  • Crypt
  • Common
  • PrivateKey
Fonctions membres publiques
Référence de l'interface PrivateKey
+ Graphe d'héritage de PrivateKey:
PrivateKey PrivateKey PrivateKey Identity

Fonctions membres publiques

sign ($message)
getPublicKey ()
toString ($type, array $options=[])
withPassword ($password=false)

Documentation des fonctions membres

◆ getPublicKey()

getPublicKey ( )

Implémenté dans PrivateKey, PrivateKey, et PrivateKey.

Référencé par SSH2\privatekey_login().

◆ sign()

sign ( $message )

Implémenté dans PrivateKey, Identity, PrivateKey, et PrivateKey.

Référencé par SSH2\privatekey_login().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Implémenté dans PrivateKey, Identity, PrivateKey, et PrivateKey.

◆ withPassword()

withPassword ( $password = false )
Paramètres
string | false $password
Renvoie
mixed

Implémenté dans Identity.

Référencé par AsymmetricKey\load(), AsymmetricKey\loadFormat(), et PrivateKey\sign().

La documentation de cette interface a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/Common/PrivateKey.php


Joomla CMS: Référence de l'interface PublicKey

  • phpseclib3
  • Crypt
  • Common
  • PublicKey
Fonctions membres publiques
Référence de l'interface PublicKey
+ Graphe d'héritage de PublicKey:
PublicKey PublicKey PublicKey

Fonctions membres publiques

verify ($message, $signature)
toString ($type, array $options=[])
getFingerprint ($algorithm)

Documentation des fonctions membres

◆ getFingerprint()

getFingerprint ( $algorithm )

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Implémenté dans PublicKey, PublicKey, et PublicKey.

◆ verify()

verify | ( | $message,
 |  | $signature
 | ) |

Implémenté dans PublicKey, PublicKey, et PublicKey.

La documentation de cette interface a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/Common/PublicKey.php


Joomla CMS: Référence de la classe StreamCipher

  • phpseclib3
  • Crypt
  • Common
  • StreamCipher
Fonctions membres publiques | Attributs protégés
Référence de la classe StreamCipher
+ Graphe d'héritage de StreamCipher:
SymmetricKey RC4 Salsa20 ChaCha20

Fonctions membres publiques

__construct ()
usesIV ()
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Attributs protégés

$block_size = 0
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Default Constructor.

Voir également
__construct()
Renvoie

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ usesIV()

usesIV ( )

Stream ciphers not use an IV

public

Renvoie
bool

Documentation des champs

◆ $block_size

$block_size = 0
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • StreamCipher.php


Joomla CMS: Référence de la classe SymmetricKey

  • phpseclib3
  • Crypt
  • Common
  • SymmetricKey
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe SymmetricKey
+ Graphe d'héritage de SymmetricKey:
BlockCipher StreamCipher Blowfish DES RC2 Rijndael Twofish RC4 Salsa20 TripleDES AES ChaCha20

Fonctions membres publiques

__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Champs de données

const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Fonctions membres protégées

getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Fonctions membres protégées statiques

static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Attributs protégés

$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

openssl_ctr_process ($plaintext, &$encryptIV, &$buffer)
openssl_ofb_process ($plaintext, &$encryptIV, &$buffer)
setupGCM ()
ghash ($x)

Fonctions membres privées statiques

static | pkcs12helper ($n, $hashObj, $i, $d, $count)
static | len64 ($str)

Attributs privés

$enmcrypt
$demcrypt
$enchanged = true
$dechanged = true
$ecb
$padding = true
$paddable = false
$preferredEngine
$password_default_salt = 'phpseclib/salt'
$openssl_emulate_ctr = false
$skip_key_adjustment = false
$h
$origIV = false

Attributs privés statiques

static | $gcmField
static | $poly1305Field

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

$mode could be:

  • ecb
  • cbc
  • ctr
  • cfb
  • cfb8
  • ofb
  • ofb8
  • gcm
Paramètres
string $mode public
Exceptions
BadModeException if an invalid / unsupported mode is provided

Références SymmetricKey\$mode.

Documentation des fonctions membres

◆ createInlineCryptFunction()

createInlineCryptFunction ( $cipher_code )
protected

Setup the performance-optimized function for de/encrypt()

Stores the created (or existing) callback function-name in $this->inline_crypt

Internally for phpseclib developers:

_setupInlineCrypt() would be called only if:

- $this->engine === self::ENGINE_EVAL

- each time on _setup(), after(!) _setupKey()

This ensures that _setupInlineCrypt() has always a
full ready2go initializated internal cipher $engine state
where, for example, the keys already expanded,
keys/block_size calculated and such.

It is, each time if called, the responsibility of _setupInlineCrypt():

- to set $this->inline_crypt to a valid and fully working callback function
  as a (faster) replacement for encrypt() / decrypt()

- NOT to create unlimited callback functions (for memory reasons!)
  no matter how often _setupInlineCrypt() would be called. At some
  point of amount they must be generic re-useable.

- the code of _setupInlineCrypt() it self,
  and the generated callback code,
  must be, in following order:
  - 100% safe
  - 100% compatible to encrypt()/decrypt()
  - using only php5+ features/lang-constructs/php-extensions if
    compatibility (down to php4) or fallback is provided
  - readable/maintainable/understandable/commented and... not-cryptic-styled-code :-)
  - >= 10% faster than encrypt()/decrypt() [which is, by the way,
    the reason for the existence of _setupInlineCrypt() :-)]
  - memory-nice
  - short (as good as possible)

Note: - _setupInlineCrypt() is using _createInlineCryptFunction() to create the full callback function code.

  • In case of using inline crypting, _setupInlineCrypt() must extend by the child * class.
  • The following variable names are reserved:
    • $_* (all variable names prefixed with an underscore)
    • $self (object reference to it self. Do not use $this, but $self instead)
    • $in (the content of $in has to en/decrypt by the generated code)
  • The callback function should not use the 'return' statement, but en/decrypt'ing the content of $in only

{ Creates the performance-optimized function for en/decrypt()

Internally for phpseclib developers:

_createInlineCryptFunction():

  • merge the $cipher_code [setup'ed by _setupInlineCrypt()] with the current [$this->]mode of operation code
  • create the $inline function, which called by encrypt() / decrypt() as its replacement to speed up the en/decryption operations.
  • return the name of the created $inline callback function
  • used to speed up en/decryption

The main reason why can speed up things [up to 50%] this way are:

  • using variables more effective then regular. (ie no use of expensive arrays but integers $k_0, $k_1 ... or even, for example, the pure $key[] values hardcoded)
  • avoiding 1000's of function calls of ie _encryptBlock() but inlining the crypt operations. in the mode of operation for() loop.
  • full loop unroll the (sometimes key-dependent) rounds avoiding this way ++$i counters and runtime-if's etc...

The basic code architectur of the generated $inline en/decrypt() lambda function, in pseudo php, is:

+-------------------------------------------------------------------------------------------—+ | callback $inline = create_function: | | lambda_function_0001_crypt_ECB($action, $text) | | { | | INSERT PHP CODE OF: | | $cipher_code['init_crypt']; // general init code. | | // ie: $sbox'es declarations used for |

// encrypt and decrypt'ing.
switch ($action) {
case 'encrypt':
INSERT PHP CODE OF:
$cipher_code['init_encrypt']; // encrypt sepcific init code.
ie: specified $key or $box
declarations for encrypt'ing.
foreach ($ciphertext) {
$in = $block_size of $ciphertext;
INSERT PHP CODE OF:
$cipher_code['encrypt_block']; // encrypt's (string) $in, which is always:
// strlen($in) == $this->block_size
// here comes the cipher algorithm in action
// for encryption.
// $cipher_code['encrypt_block'] has to
// encrypt the content of the $in variable
$plaintext .= $in;
}
return $plaintext;
case 'decrypt':
INSERT PHP CODE OF:
$cipher_code['init_decrypt']; // decrypt sepcific init code
ie: specified $key or $box
declarations for decrypt'ing.
foreach ($plaintext) {
$in = $block_size of $plaintext;
INSERT PHP CODE OF:
$cipher_code['decrypt_block']; // decrypt's (string) $in, which is always
// strlen($in) == $this->block_size
// here comes the cipher algorithm in action
// for decryption.
// $cipher_code['decrypt_block'] has to
// decrypt the content of the $in variable
$ciphertext .= $in;
}
return $ciphertext;
}
}

+-------------------------------------------------------------------------------------------—+

See also the *::_setupInlineCrypt()'s for productive inline $cipher_code's how they works.

Structure of: $cipher_code = [ 'init_crypt' => (string) '', // optional 'init_encrypt' => (string) '', // optional 'init_decrypt' => (string) '', // optional 'encrypt_block' => (string) '', // required 'decrypt_block' => (string) '' // required ];

Voir également
self::setupInlineCrypt()
self::encrypt()
self::decrypt()
Paramètres
array $cipher_code private
Renvoie
string (the name of the created callback function)

Références SymmetricKey\$block_size, $this, et class.

Référencé par Blowfish\setupInlineCrypt(), RC2\setupInlineCrypt(), Twofish\setupInlineCrypt(), Rijndael\setupInlineCrypt(), et DES\setupInlineCrypt().

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

If strlen($ciphertext) is not a multiple of the block size, null bytes will be added to the end of the string until it is.

{

Références SymmetricKey\$block_size, $buffer, SymmetricKey\$debuffer, SymmetricKey\$decryptIV, $i, SymmetricKey\$inline_crypt, SymmetricKey\$iv, SymmetricKey\$key, SymmetricKey\$newtag, Joomla\Database\Query\$offset, $start, $this, SymmetricKey\decryptBlock(), elseif, SymmetricKey\encryptBlock(), SymmetricKey\getIV(), SymmetricKey\ghash(), Strings\increment_str(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), SymmetricKey\poly1305(), SymmetricKey\setup(), Strings\shift(), et SymmetricKey\unpad().

◆ decryptBlock()

decryptBlock ( $in )
abstractprotected

Decrypts a block

Note: Must be extended by the child * class

private

Paramètres
string $in
Renvoie
string

Référencé par SymmetricKey\decrypt().

◆ disableContinuousBuffer()

disableContinuousBuffer ( )

Treat consecutive packets as if they are a discontinuous buffer.

The default behavior.

{

Références SymmetricKey\setEngine().

◆ disablePadding()

disablePadding ( )

Do not pad packets.

Voir également
self::enablePadding() public

◆ enableContinuousBuffer()

enableContinuousBuffer ( )

Treat consecutive "packets" as if they are a continuous buffer.

Say you have a 32-byte plaintext $plaintext. Using the default behavior, the two following code snippets will yield different outputs:

echo $rijndael->encrypt(substr($plaintext, 0, 16)); echo $rijndael->encrypt(substr($plaintext, 16, 16)); echo $rijndael->encrypt($plaintext);

The solution is to enable the continuous buffer. Although this will resolve the above discrepancy, it creates another, as demonstrated with the following:

$rijndael->encrypt(substr($plaintext, 0, 16)); echo $rijndael->decrypt($rijndael->encrypt(substr($plaintext, 16, 16))); echo $rijndael->decrypt($rijndael->encrypt(substr($plaintext, 16, 16)));

With the continuous buffer disabled, these would yield the same output. With it enabled, they yield different outputs. The reason is due to the fact that the initialization vector's change after every encryption / decryption round when the continuous buffer is enabled. When it's disabled, they remain constant.

Put another way, when the continuous buffer is enabled, the state of the *() object changes after each encryption / decryption round, whereas otherwise, it'd remain constant. For this reason, it's recommended that continuous buffers not be used. They do offer better security and are, in fact, sometimes required (SSH uses them), however, they are also less intuitive and more likely to cause you problems.

{

Références SymmetricKey\setEngine().

◆ enablePadding()

enablePadding ( )

Pad "packets".

Block ciphers working by encrypting between their specified [$this->]block_size at a time If you ever need to encrypt or decrypt something that isn't of the proper length, it becomes necessary to pad the input so that it is of the proper length.

Padding is enabled by default. Sometimes, however, it is undesirable to pad strings. Such is the case in SSH, where "packets" are padded with random bytes before being encrypted. Unpad these packets and you risk stripping away characters that shouldn't be stripped away. (SSH knows how many bytes are added because the length is transmitted separately)

Voir également
self::disablePadding() public

◆ enablePoly1305()

enablePoly1305 ( )

Enables Poly1305 mode.

Once enabled Poly1305 cannot be disabled.

public

Exceptions

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

$plaintext will be padded with additional bytes such that it's length is a multiple of the block size. Other cipher implementations may or may not pad in the same manner. Other common approaches to padding and the reasons why it's necessary are discussed in the following URL:

http://www.di-mgt.com.au/cryptopad.html

An alternative to padding is to, separately, send the length of the file. This is what SSH, in fact, does. strlen($plaintext) will still need to be a multiple of the block size, however, arbitrary values can be added to make it that length.

{

Références SymmetricKey\$block_size, $buffer, $c, SymmetricKey\$enbuffer, SymmetricKey\$encryptIV, $i, SymmetricKey\$inline_crypt, SymmetricKey\$iv, SymmetricKey\$key, $result, $size, $start, $this, elseif, SymmetricKey\encryptBlock(), SymmetricKey\getIV(), SymmetricKey\ghash(), Strings\increment_str(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), SymmetricKey\pad(), SymmetricKey\poly1305(), Strings\pop(), SymmetricKey\setup(), et Strings\shift().

◆ encryptBlock()

encryptBlock ( $in )
abstractprotected

Encrypts a block

Note: Must be extended by the child * class

private

Paramètres
string $in
Renvoie
string

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ getBlockLength()

getBlockLength ( )

Returns the current block length in bits

public

Renvoie
int

◆ getBlockLengthInBytes()

getBlockLengthInBytes ( )

Returns the current block length in bytes

public

Renvoie
int

Références SymmetricKey\$block_size.

◆ getEngine()

getEngine ( )

Returns the engine currently being utilized

Voir également
self::setEngine() public

Références SymmetricKey\$engine.

◆ getIV()

getIV ( $iv )
protected

Get the IV

mcrypt requires an IV even if ECB is used

Voir également
self::encrypt()
self::decrypt()
Paramètres
string $iv
Renvoie
string private

Références SymmetricKey\$iv.

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ getKeyLength()

getKeyLength ( )

Returns the current key length in bits

public

Renvoie
int

Référencé par Rijndael\decrypt(), Rijndael\encrypt(), et Rijndael\isValidEngineHelper().

◆ getMode()

getMode ( )

Return the mode

You can do $obj instanceof AES or whatever to get the cipher but you can't do that to get the mode

public

Renvoie
string

Références SymmetricKey\$mode.

◆ getTag()

getTag ( $length = 16 )

Get the authentication tag

Only used in GCM or Poly1305 mode

Voir également
self::encrypt()
Paramètres
int $length optional
Renvoie
string public
Exceptions

◆ ghash()

ghash ( $x )
private

Performs GHASH operation

See https://nvlpubs.nist.gov/nistpubs/Legacy/SP/nistspecialpublication800-38d.pdf#page=20 for more info

Voir également
self::decrypt()
self::encrypt() private
Paramètres
string $x
Renvoie
string

Références SymmetricKey\$h, $n, $temp, et Strings\switchEndianness().

Référencé par SymmetricKey\decrypt(), SymmetricKey\encrypt(), et SymmetricKey\setupGCM().

◆ isValidEngine()

isValidEngine ( $engine )

Test for engine validity

Voir également
self::__construct()
Paramètres
string $engine public
Renvoie
bool

Références SymmetricKey\$engine, et SymmetricKey\isValidEngineHelper().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

Voir également
self::__construct()
Paramètres
int $engine private
Renvoie
bool

Références SymmetricKey\$engine, $result, et $this.

Référencé par SymmetricKey\isValidEngine(), et SymmetricKey\setEngine().

◆ len64()

static len64 ( $str )
staticprivate

Returns the bit length of a string in a packed format

Voir également
self::decrypt()
self::encrypt()
self::setupGCM() private
Paramètres
string $str
Renvoie
string

◆ nullPad128()

static nullPad128 ( $str )
staticprotected

NULL pads a string to be a multiple of 128

Voir également
self::decrypt()
self::encrypt()
self::setupGCM() private
Paramètres
string $str
Renvoie
string

◆ openssl_ctr_process()

openssl_ctr_process | ( |  | $plaintext,
 |  | & | $encryptIV,
 |  | & | $buffer
 | ) |  |
private

OpenSSL CTR Processor

PHP's OpenSSL bindings do not operate in continuous mode so we'll wrap around it. Since the keystream for CTR is the same for both encrypting and decrypting this function is re-used by both SymmetricKey::encrypt() and SymmetricKey::decrypt(). Also, OpenSSL doesn't implement CTR for all of it's symmetric ciphers so this function will emulate CTR with ECB when necessary.

Voir également
self::encrypt()
self::decrypt()
Paramètres
string | $plaintext
string | $encryptIV
array | $buffer
Renvoie
string private

Références SymmetricKey\$block_size, $buffer, SymmetricKey\$encryptIV, $i, SymmetricKey\$key, $start, $temp, elseif, Strings\increment_str(), Strings\pop(), et Strings\shift().

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ openssl_ofb_process()

openssl_ofb_process | ( |  | $plaintext,
 |  | & | $encryptIV,
 |  | & | $buffer
 | ) |  |
private

OpenSSL OFB Processor

PHP's OpenSSL bindings do not operate in continuous mode so we'll wrap around it. Since the keystream for OFB is the same for both encrypting and decrypting this function is re-used by both SymmetricKey::encrypt() and SymmetricKey::decrypt().

Voir également
self::encrypt()
self::decrypt()
Paramètres
string | $plaintext
string | $encryptIV
array | $buffer
Renvoie
string private

Références SymmetricKey\$block_size, $buffer, SymmetricKey\$encryptIV, SymmetricKey\$key, Strings\pop(), et Strings\shift().

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ openssl_translate_mode()

openssl_translate_mode ( )
protected

phpseclib <-> OpenSSL Mode Mapper

May need to be overwritten by classes extending this one in some cases

Renvoie
string private

Référencé par TripleDES\isValidEngineHelper(), Rijndael\isValidEngineHelper(), RC2\isValidEngineHelper(), Blowfish\isValidEngineHelper(), et DES\isValidEngineHelper().

◆ pad()

pad ( $text )
protected

Pads a string

Pads a string using the RSA PKCS padding standards so that its length is a multiple of the blocksize. $this->block_size - (strlen($text) % $this->block_size) bytes are added, each of which is equal to chr($this->block_size - (strlen($text) % $this->block_size)

If padding is disabled and $text is not a multiple of the blocksize, the string will be padded regardless and padding will, hence forth, be enabled.

Voir également
self::unpad()
Paramètres
string $text
Exceptions

Références SymmetricKey\$block_size, et $text.

Référencé par TripleDES\encrypt(), et SymmetricKey\encrypt().

◆ pkcs12helper()

static pkcs12helper | ( | $n,
 |  | $hashObj,
 |  | $i,
 |  | $d,
 |  | $count
 | ) |
staticprivate

PKCS#12 KDF Helper Function

As discussed here:

https://tools.ietf.org/html/rfc7292#appendix-B

Voir également
self::setPassword() private
Paramètres
int | $n
\phpseclib3\Crypt\Hash | $hashObj
string | $i
string | $d
int | $count
Renvoie
string $a

Références $b, $c, $count, $i, $n, et $temp.

◆ poly1305()

poly1305 ( $text )
protected

Calculates Poly1305 MAC

On my system ChaCha20, with libsodium, takes 0.5s. With this custom Poly1305 implementation it takes 1.2s.

Voir également
self::decrypt()
self::encrypt() private
Paramètres
string $text
Renvoie
string

Références $n, SymmetricKey\$poly1305Key, $r, $text, et Strings\shift().

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ safe_intval()

static safe_intval ( $x )
staticprotected

Convert float to int

On ARM CPUs converting floats to ints doesn't always work

private

Paramètres
string $x
Renvoie
int

◆ safe_intval_inline()

static safe_intval_inline ( )
staticprotected

eval()'able string for in-line float to int

private

Renvoie
string

◆ setAAD()

setAAD ( $aad )

Sets additional authenticated data

setAAD() is only used by gcm or in poly1305 mode

public

Paramètres
string $aad
Exceptions

Références SymmetricKey\$aad.

◆ setEngine()

setEngine ( )
protected

Sets the engine as appropriate

Voir également
self::__construct() private

Références SymmetricKey\$engine, SymmetricKey\$preferredEngine, $temp, SymmetricKey\isValidEngineHelper(), et null.

Référencé par SymmetricKey\disableContinuousBuffer(), SymmetricKey\enableContinuousBuffer(), Rijndael\setBlockLength(), Salsa20\setCounter(), TripleDES\setKey(), RC2\setKey(), SymmetricKey\setKey(), Salsa20\setNonce(), ChaCha20\setNonce(), SymmetricKey\setNonce(), et SymmetricKey\setPreferredEngine().

◆ setIV()

setIV ( $iv )

Sets the initialization vector.

setIV() is not required when ecb or gcm modes are being used.

{

Références SymmetricKey\$iv, et SymmetricKey\usesIV().

Référencé par SymmetricKey\setPassword().

◆ setKey()

setKey ( $key )

Sets the key.

The min/max length(s) of the key depends on the cipher which is used. If the key not fits the length(s) of the cipher it will paded with null bytes up to the closest valid key length. If the key is more than max length, we trim the excess bits.

If the key is not explicitly set, it'll be assumed to be all null bytes.

{

Références SymmetricKey\$key, et SymmetricKey\setEngine().

Référencé par SymmetricKey\setPassword().

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Keys with explicitly set lengths need to be treated accordingly

public

Paramètres
int $length

◆ setNonce()

setNonce ( $nonce )

Sets the nonce.

setNonce() is only required when gcm is used

public

Paramètres
string $nonce
Exceptions

Références SymmetricKey\$nonce, et SymmetricKey\setEngine().

◆ setPassword()

setPassword | ( | $password,
 |  | $method = 'pbkdf2',
 |  | $func_args
 | ) |

Sets the password.

Depending on what $method is set to, setPassword()'s (optional) parameters are as follows: pbkdf2 or pbkdf1: $hash, $salt, $count, $dkLen

Where $hash (default = sha1) currently supports the following hashes: see: Crypt/Hash.php

{

Références $count, $hash, $i, SymmetricKey\$key, $method, $password, SymmetricKey\$password_default_salt, SymmetricKey\setIV(), SymmetricKey\setKey(), et SymmetricKey\usesIV().

◆ setPoly1305Key()

setPoly1305Key ( $key = null )

Enables Poly1305 mode.

Once enabled Poly1305 cannot be disabled. If $key is not passed then an attempt to call createPoly1305Key will be made.

public

Paramètres
string $key optional
Exceptions

Références SymmetricKey\$key.

Référencé par Salsa20\createPoly1305Key().

◆ setPreferredEngine()

setPreferredEngine ( $engine )

Sets the preferred crypt engine

Currently, $engine could be:

  • libsodium[very fast]
  • OpenSSL [very fast]
  • mcrypt [fast]
  • Eval [slow]
  • PHP [slowest]

If the preferred crypt engine is not available the fastest available one will be used

Voir également
self::__construct()
Paramètres
string $engine public

Références SymmetricKey\$engine, et SymmetricKey\setEngine().

◆ setTag()

setTag ( $tag )

Sets the authentication tag

Only used in GCM mode

Voir également
self::decrypt()
Paramètres
string $tag public
Exceptions

Références $this.

◆ setup()

setup ( )
protected

Setup the self::ENGINE_INTERNAL $engine

(re)init, if necessary, the internal cipher $engine and flush all $buffers Used (only) if $engine == self::ENGINE_INTERNAL

_setup() will be called each time if $changed === true typically this happens when using one or more of following public methods:

  • setKey()
  • setIV()
  • disableContinuousBuffer()
  • First run of encrypt() / decrypt() with no init-settings

{

Références SymmetricKey\$iv, SymmetricKey\$origIV, $this, SymmetricKey\setupGCM(), SymmetricKey\setupKey(), et SymmetricKey\usesNonce().

Référencé par RC4\crypt(), SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ setupGCM()

setupGCM ( )
private

Sets up GCM parameters

See steps 1-2 of https://nvlpubs.nist.gov/nistpubs/Legacy/SP/nistspecialpublication800-38d.pdf#page=23 for more info

private

Références SymmetricKey\$key, $this, SymmetricKey\ghash(), et Strings\switchEndianness().

Référencé par SymmetricKey\setup().

◆ setupKey()

setupKey ( )
abstractprotected

Setup the key (expansion)

Only used if $engine == self::ENGINE_INTERNAL

Note: Must extend by the child * class

Voir également
self::setup() private

Référencé par SymmetricKey\setup().

◆ unpad()

unpad ( $text )
protected

Unpads a string.

If padding is enabled and the reported padding length is invalid the encryption key will be assumed to be wrong and false will be returned.

Voir également
self::pad()
Paramètres
string $text
Exceptions

Références $text.

Référencé par TripleDES\decrypt(), et SymmetricKey\decrypt().

◆ usesIV()

usesIV ( )

Returns whether or not the algorithm uses an IV

public

Renvoie
bool

Référencé par SymmetricKey\setIV(), et SymmetricKey\setPassword().

◆ usesNonce()

usesNonce ( )

Returns whether or not the algorithm uses a nonce

public

Renvoie
bool

Référencé par SymmetricKey\setup().

Documentation des champs

◆ $aad

$aad = ''
protected

Référencé par ChaCha20\decrypt_with_libsodium(), ChaCha20\encrypt_with_libsodium(), et SymmetricKey\setAAD().

◆ $block_size

$block_size = 16
protected

Référencé par SymmetricKey\createInlineCryptFunction(), SymmetricKey\decrypt(), SymmetricKey\encrypt(), SymmetricKey\getBlockLengthInBytes(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), SymmetricKey\pad(), et Rijndael\setupKey().

◆ $cfb_init_len

$cfb_init_len = 600
protected

◆ $changed

$changed = true
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt
protected

◆ $cipher_name_openssl

$cipher_name_openssl
protected

◆ $cipher_name_openssl_ecb

$cipher_name_openssl_ecb
protected

◆ $continuousBuffer

$continuousBuffer = false
protected

Référencé par ChaCha20\isValidEngineHelper().

◆ $debuffer

$debuffer
protected

Référencé par SymmetricKey\decrypt().

◆ $dechanged

$dechanged = true
private

◆ $decryptIV

$decryptIV
protected

Référencé par SymmetricKey\decrypt().

◆ $demcrypt

$demcrypt
private

◆ $ecb

$ecb
private

◆ $enbuffer

$enbuffer
protected

Référencé par SymmetricKey\encrypt().

◆ $enchanged

$enchanged = true
private

◆ $encryptIV

$encryptIV
protected

Référencé par SymmetricKey\encrypt(), SymmetricKey\openssl_ctr_process(), et SymmetricKey\openssl_ofb_process().

◆ $engine

$engine
protected

Référencé par SymmetricKey\getEngine(), SymmetricKey\isValidEngine(), ChaCha20\isValidEngineHelper(), RC4\isValidEngineHelper(), TripleDES\isValidEngineHelper(), Rijndael\isValidEngineHelper(), RC2\isValidEngineHelper(), Blowfish\isValidEngineHelper(), DES\isValidEngineHelper(), SymmetricKey\isValidEngineHelper(), SymmetricKey\setEngine(), TripleDES\setPreferredEngine(), et SymmetricKey\setPreferredEngine().

◆ $enmcrypt

$enmcrypt
private

◆ $explicit_key_length

$explicit_key_length = false
protected

◆ $gcmField

$gcmField
staticprivate

◆ $h

$h
private

Référencé par SymmetricKey\ghash().

◆ $inline_crypt

$inline_crypt
protected

Référencé par SymmetricKey\decrypt(), et SymmetricKey\encrypt().

◆ $iv

$iv = false
protected

Référencé par Salsa20\crypt(), SymmetricKey\decrypt(), SymmetricKey\encrypt(), SymmetricKey\getIV(), TripleDES\setIV(), SymmetricKey\setIV(), et SymmetricKey\setup().

◆ $key

$key = false
protected

Référencé par SymmetricKey\decrypt(), ChaCha20\decrypt_with_libsodium(), SymmetricKey\encrypt(), ChaCha20\encrypt_with_libsodium(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), Salsa20\setKey(), AES\setKey(), Rijndael\setKey(), TripleDES\setKey(), Twofish\setKey(), DES\setKey(), SymmetricKey\setKey(), Salsa20\setNonce(), SymmetricKey\setPassword(), SymmetricKey\setPoly1305Key(), Salsa20\setup(), ChaCha20\setup(), SymmetricKey\setupGCM(), Blowfish\setupKey(), Twofish\setupKey(), Rijndael\setupKey(), et DES\setupKey().

◆ $mode

$mode
protected

Référencé par TripleDES\__construct(), Rijndael\__construct(), RC2\__construct(), Blowfish\__construct(), Twofish\__construct(), DES\__construct(), SymmetricKey\__construct(), RC4\crypt(), Salsa20\crypt(), SymmetricKey\getMode(), TripleDES\isValidEngineHelper(), et DES\processBlock().

◆ $newtag

$newtag = false
protected

Référencé par Salsa20\decrypt(), SymmetricKey\decrypt(), et ChaCha20\decrypt_with_libsodium().

◆ $nonce

$nonce = false
protected

Référencé par ChaCha20\decrypt_with_libsodium(), ChaCha20\encrypt_with_libsodium(), Salsa20\setNonce(), ChaCha20\setNonce(), SymmetricKey\setNonce(), et ChaCha20\setup().

◆ $nonIVChanged

$nonIVChanged = true
protected

◆ $oldtag

$oldtag = false
protected

◆ $openssl_emulate_ctr

$openssl_emulate_ctr = false
private

◆ $origIV

$origIV = false
private

Référencé par SymmetricKey\setup().

◆ $paddable

$paddable = false
private

◆ $padding

$padding = true
private

◆ $password_default_salt

$password_default_salt = 'phpseclib/salt'
private

Référencé par SymmetricKey\setPassword().

◆ $poly1305Field

$poly1305Field
staticprivate

◆ $poly1305Key

$poly1305Key
protected

Référencé par SymmetricKey\poly1305().

◆ $preferredEngine

$preferredEngine
private

Référencé par SymmetricKey\setEngine().

◆ $skip_key_adjustment

$skip_key_adjustment = false
private

◆ $usePoly1305

$usePoly1305 = false
protected

◆ ENGINE_EVAL

const ENGINE_EVAL = 2

Base value for the eval() implementation $engine switch

private

Voir également
__construct()

◆ ENGINE_INTERNAL

const const ENGINE_INTERNAL = 1

Base value for the internal implementation $engine switch

private

Voir également
__construct()

◆ ENGINE_LIBSODIUM

const ENGINE_LIBSODIUM = 5

Base value for the libsodium implementation $engine switch

private

Voir également
__construct()

◆ ENGINE_MAP

const ENGINE_MAP
Valeur initiale :
= [
self::ENGINE_INTERNAL => 'PHP'

Engine Reverse Map

private

Voir également
::getEngine()

◆ ENGINE_MCRYPT

const ENGINE_MCRYPT = 3

Base value for the mcrypt implementation $engine switch

private

Voir également
__construct()

◆ ENGINE_OPENSSL

const ENGINE_OPENSSL = 4

Base value for the openssl implementation $engine switch

private

Voir également
__construct()

◆ ENGINE_OPENSSL_GCM

const ENGINE_OPENSSL_GCM = 6

Base value for the openssl / gcm implementation $engine switch

private

Voir également
__construct()

◆ MODE_CBC

const MODE_CBC = 2

Encrypt / decrypt using the Code Book Chaining mode.

public ::encrypt() ::decrypt()

◆ MODE_CFB

const MODE_CFB = 3

Encrypt / decrypt using the Cipher Feedback mode.

public ::encrypt() ::decrypt()

◆ MODE_CFB8

const MODE_CFB8 = 7

Encrypt / decrypt using the Cipher Feedback mode (8bit)

public

Voir également
::encrypt()
::decrypt()

◆ MODE_CTR

const MODE_CTR = -1

Encrypt / decrypt using the Counter mode.

Set to -1 since that's what Crypt/Random.php uses to index the CTR mode.

public ::encrypt() ::decrypt()

◆ MODE_ECB

const MODE_ECB = 1

Encrypt / decrypt using the Electronic Code Book mode.

public ::encrypt() ::decrypt()

◆ MODE_GCM

const MODE_GCM = 5

Encrypt / decrypt using Galois/Counter mode.

public ::encrypt() ::decrypt()

◆ MODE_MAP

const MODE_MAP
Valeur initiale :
= [
'ctr' => self::MODE_CTR

Mode Map

private

Voir également
__construct()

◆ MODE_OFB

const MODE_OFB = 4

Encrypt / decrypt using the Output Feedback mode.

public ::encrypt() ::decrypt()

◆ MODE_OFB8

const MODE_OFB8 = 8

Encrypt / decrypt using the Output Feedback mode (8bit)

public

Voir également
::encrypt()
::decrypt()

◆ MODE_STREAM

const MODE_STREAM = 6

Encrypt / decrypt using streaming mode.

public

Voir également
::encrypt()
::decrypt()
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/Common/SymmetricKey.php


Joomla CMS: Référence de la classe PKCS1

  • phpseclib3
  • Crypt
  • DH
  • Formats
  • Keys
  • PKCS1
Fonctions membres publiques statiques
Référence de la classe PKCS1
+ Graphe d'héritage de PKCS1:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | saveParameters (BigInteger $prime, BigInteger $base, array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, ASN1\asn1map(), et ASN1\decodeBER().

◆ saveParameters()

static saveParameters | ( | BigInteger | $prime,
 |  | BigInteger | $base,
 |  | array | $options = []
 | ) |  |
static

Convert EC parameters to the appropriate format

public

Renvoie
string

Références DH\$base, $params, DH\$prime, et ASN1\encodeDER().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DH/Formats/Keys/PKCS1.php


Joomla CMS: Référence de la classe PKCS8

  • phpseclib3
  • Crypt
  • DH
  • Formats
  • Keys
  • PKCS8
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PKCS8
+ Graphe d'héritage de PKCS8:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $prime, BigInteger $base, BigInteger $privateKey, BigInteger $publicKey, $password='', array $options=[])
static | savePublicKey (BigInteger $prime, BigInteger $base, BigInteger $publicKey, array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | OID_NAME = 'dhKeyAgreement'
const | OID_VALUE = '1.2.840.113549.1.3.1'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $childOIDsLoaded = false
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, $type, ASN1\asn1map(), ASN1\decodeBER(), et Strings\is_stringable().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $prime,
 |  | BigInteger | $base,
 |  | BigInteger | $privateKey,
 |  | BigInteger | $publicKey,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $prime
\phpseclib3\Math\BigInteger | $base
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Math\BigInteger | $publicKey
string | $password | optional
array | $options | optional
Renvoie
string

Références DH\$base, $key, $options, $params, $password, DH\$prime, ASN1\encodeDER(), null, et ASN1\TYPE_INTEGER.

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $prime,
 |  | BigInteger | $base,
 |  | BigInteger | $publicKey,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $prime
\phpseclib3\Math\BigInteger | $base
\phpseclib3\Math\BigInteger | $publicKey
array | $options | optional
Renvoie
string

Références DH\$base, $key, $params, DH\$prime, ASN1\encodeDER(), et ASN1\TYPE_INTEGER.

Documentation des champs

◆ $childOIDsLoaded

$childOIDsLoaded = false
staticprotected

◆ OID_NAME

const OID_NAME = 'dhKeyAgreement'

◆ OID_VALUE

const OID_VALUE = '1.2.840.113549.1.3.1'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DH/Formats/Keys/PKCS8.php


Joomla CMS: Référence de la classe Parameters

  • phpseclib3
  • Crypt
  • DH
  • Parameters
Fonctions membres publiques
Référence de la classe Parameters
+ Graphe d'héritage de Parameters:
DH AsymmetricKey

Fonctions membres publiques

toString ($type='PKCS1', array $options=[])
- Fonctions membres publiques hérités de DH
withHash ($hash)
getHash ()
getParameters ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DH
static | createParameters (... $args)
static | createKey (Parameters $params, $length=0)
static | computeSecret ($private, $public)
static | load ($key, $password=false)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DH
const | ALGORITHM = 'DH'
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DH
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de DH
$prime
$base
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toString()

toString | ( |  | $type = 'PKCS1',
 |  | array | $options = []
 | ) |  |

Returns the parameters

Paramètres
string | $type
array | $options | optional
Renvoie
string

Références $options, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DH/Parameters.php


Joomla CMS: Référence de la classe PrivateKey

  • phpseclib3
  • Crypt
  • DH
  • PrivateKey
Fonctions membres publiques | Attributs protégés
Référence de la classe PrivateKey
+ Graphe d'héritage de PrivateKey:
DH AsymmetricKey

Fonctions membres publiques

getPublicKey ()
toString ($type, array $options=[])
- Fonctions membres publiques hérités de DH
withHash ($hash)
getHash ()
getParameters ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Attributs protégés

$privateKey
$publicKey
- Attributs protégés hérités de DH
$prime
$base
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DH
static | createParameters (... $args)
static | createKey (Parameters $params, $length=0)
static | computeSecret ($private, $public)
static | load ($key, $password=false)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DH
const | ALGORITHM = 'DH'
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DH
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ getPublicKey()

getPublicKey ( )

Returns the public key

public

Renvoie
DH

Références $key, $type, et AsymmetricKey\loadFormat().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the private key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Références $options, et $type.

Documentation des champs

◆ $privateKey

$privateKey
protected

◆ $publicKey

$publicKey
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DH/PrivateKey.php


Joomla CMS: Référence de la classe PublicKey

  • phpseclib3
  • Crypt
  • DH
  • PublicKey
Fonctions membres publiques
Référence de la classe PublicKey
+ Graphe d'héritage de PublicKey:
DH AsymmetricKey

Fonctions membres publiques

toString ($type, array $options=[])
toBigInteger ()
- Fonctions membres publiques hérités de DH
withHash ($hash)
getHash ()
getParameters ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DH
static | createParameters (... $args)
static | createKey (Parameters $params, $length=0)
static | computeSecret ($private, $public)
static | load ($key, $password=false)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DH
const | ALGORITHM = 'DH'
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DH
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de DH
$prime
$base
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toBigInteger()

toBigInteger ( )

Returns the public key as a BigInteger

Renvoie

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the public key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Références $options, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DH/PublicKey.php


Joomla CMS: Référence de la classe OpenSSH

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • OpenSSH
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe OpenSSH
+ Graphe d'héritage de OpenSSH:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, array $options=[])
static | savePrivateKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, BigInteger $x, $password='', array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Attributs protégés statiques

static | $types = ['ssh-dss']
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références AsymmetricKey\$comment, DSA\$g, $key, DSA\$p, $password, DSA\$q, $type, DSA\$y, et Strings\unpackSSH2().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | BigInteger | $x,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
\phpseclib3\Math\BigInteger | $x
string | $password | optional
array | $options | optional
Renvoie
string

Références DSA\$g, $options, DSA\$p, $password, DSA\$q, DSA\$y, et Strings\packSSH2().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
array | $options | optional
Renvoie
string

Références AsymmetricKey\$comment, DSA\$g, $options, DSA\$p, DSA\$q, DSA\$y, et Strings\packSSH2().

Documentation des champs

◆ $types

$types = ['ssh-dss']
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/OpenSSH.php


Joomla CMS: Référence de la classe PKCS1

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • PKCS1
Fonctions membres publiques statiques
Référence de la classe PKCS1
+ Graphe d'héritage de PKCS1:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | saveParameters (BigInteger $p, BigInteger $q, BigInteger $g)
static | savePrivateKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, BigInteger $x, $password='', array $options=[])
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, ASN1\asn1map(), et ASN1\decodeBER().

◆ saveParameters()

static saveParameters | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g
 | ) |  |
static

Convert DSA parameters to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
Renvoie
string

Références DSA\$g, $key, DSA\$p, DSA\$q, et ASN1\encodeDER().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | BigInteger | $x,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
\phpseclib3\Math\BigInteger | $x
string | $password | optional
array | $options | optional
Renvoie
string

Références DSA\$g, $key, $options, DSA\$p, $password, DSA\$q, DSA\$y, et ASN1\encodeDER().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
Renvoie
string

Références $key, DSA\$y, et ASN1\encodeDER().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/PKCS1.php


Joomla CMS: Référence de la classe PKCS8

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • PKCS8
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PKCS8
+ Graphe d'héritage de PKCS8:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, BigInteger $x, $password='', array $options=[])
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | OID_NAME = 'id-dsa'
const | OID_VALUE = '1.2.840.10040.4.1'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $childOIDsLoaded = false
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, $type, ASN1\asn1map(), ASN1\decodeBER(), et Strings\is_stringable().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | BigInteger | $x,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
\phpseclib3\Math\BigInteger | $x
string | $password | optional
array | $options | optional
Renvoie
string

Références DSA\$g, $key, $options, DSA\$p, $params, $password, DSA\$q, ASN1\encodeDER(), et null.

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
array | $options | optional
Renvoie
string

Références DSA\$g, $key, DSA\$p, $params, DSA\$q, DSA\$y, et ASN1\encodeDER().

Documentation des champs

◆ $childOIDsLoaded

$childOIDsLoaded = false
staticprotected

◆ OID_NAME

const OID_NAME = 'id-dsa'

◆ OID_VALUE

const OID_VALUE = '1.2.840.10040.4.1'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/PKCS8.php


Joomla CMS: Référence de la classe PuTTY

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • PuTTY
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PuTTY
+ Graphe d'héritage de PuTTY:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, BigInteger $x, $password=false, array $options=[])
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | PUBLIC_HANDLER = 'phpseclib3\Crypt\DSA\Formats\Keys\OpenSSH'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $types = ['ssh-dss']
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références DSA\$g, $key, DSA\$p, $password, DSA\$q, DSA\$y, et Strings\unpackSSH2().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | BigInteger | $x,
 |  |  | $password = false,
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
\phpseclib3\Math\BigInteger | $x
string | $password | optional
array | $options | optional
Renvoie
string

Références DSA\$g, $options, DSA\$p, $password, DSA\$q, DSA\$y, et Strings\packSSH2().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
Renvoie
string

Références DSA\$g, DSA\$p, DSA\$q, DSA\$y, et Strings\packSSH2().

Documentation des champs

◆ $types

$types = ['ssh-dss']
staticprotected

◆ PUBLIC_HANDLER

const PUBLIC_HANDLER = 'phpseclib3\Crypt\DSA\Formats\Keys\OpenSSH'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/PuTTY.php


Joomla CMS: Référence de la classe Raw

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • Raw
Fonctions membres publiques statiques
Référence de la classe Raw

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y, BigInteger $x, $password='')
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y)

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
array | $key
string | $password | optional
Renvoie
array

Références $key, et $options.

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y,
 |  | BigInteger | $x,
 |  |  | $password = ''
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
\phpseclib3\Math\BigInteger | $x
string | $password | optional
Renvoie
string

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/Raw.php


Joomla CMS: Référence de la classe XML

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Keys
  • XML
Fonctions membres publiques statiques
Référence de la classe XML

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (BigInteger $p, BigInteger $q, BigInteger $g, BigInteger $y)

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $temp, $value, et Strings\is_stringable().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $p,
 |  | BigInteger | $q,
 |  | BigInteger | $g,
 |  | BigInteger | $y
 | ) |  |
static

Convert a public key to the appropriate format

See https://www.w3.org/TR/xmldsig-core/#sec-DSAKeyValue

public

Paramètres
\phpseclib3\Math\BigInteger | $p
\phpseclib3\Math\BigInteger | $q
\phpseclib3\Math\BigInteger | $g
\phpseclib3\Math\BigInteger | $y
Renvoie
string

Références DSA\$g, DSA\$p, DSA\$q, et DSA\$y.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Keys/XML.php


Joomla CMS: Référence de la classe ASN1

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Signature
  • ASN1
Fonctions membres publiques statiques
Référence de la classe ASN1

Fonctions membres publiques statiques

static | load ($sig)
static | save (BigInteger $r, BigInteger $s)

Documentation des fonctions membres

◆ load()

static load ( $sig )
static

Loads a signature

public

Paramètres
string $sig
Renvoie
array|bool

◆ save()

static save | ( | BigInteger | $r,
 |  | BigInteger | $s
 | ) |  |
static

Returns a signature in the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $r
\phpseclib3\Math\BigInteger | $s
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/DSA/Formats/Signature/ASN1.php


Joomla CMS: Référence de la classe Raw

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Signature
  • Raw
Référence de la classe Raw
+ Graphe d'héritage de Raw:
Montgomery Base PHP Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA/Formats/Signature/Raw.php


Joomla CMS: Référence de la classe SSH2

  • phpseclib3
  • Crypt
  • DSA
  • Formats
  • Signature
  • SSH2
Fonctions membres publiques statiques
Référence de la classe SSH2

Fonctions membres publiques statiques

static | load ($sig)
static | save (BigInteger $r, BigInteger $s)

Documentation des fonctions membres

◆ load()

static load ( $sig )
static

Loads a signature

public

Paramètres
string $sig
Renvoie
mixed

Références $result, $type, et Strings\unpackSSH2().

◆ save()

static save | ( | BigInteger | $r,
 |  | BigInteger | $s
 | ) |  |
static

Returns a signature in the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $r
\phpseclib3\Math\BigInteger | $s
Renvoie
string

Références $r, BigInteger\getLength(), Strings\packSSH2(), et BigInteger\toBytes().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/DSA/Formats/Signature/SSH2.php


Joomla CMS: Référence de la classe Parameters

  • phpseclib3
  • Crypt
  • DSA
  • Parameters
Fonctions membres publiques
Référence de la classe Parameters
+ Graphe d'héritage de Parameters:
DSA AsymmetricKey

Fonctions membres publiques

toString ($type='PKCS1', array $options=[])
- Fonctions membres publiques hérités de DSA
getLength ()
getEngine ()
getParameters ()
withSignatureFormat ($format)
getSignatureFormat ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DSA
static | createParameters ($L=2048, $N=224)
static | createKey (... $args)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DSA
const | ALGORITHM = 'DSA'
- Fonctions membres protégées hérités de DSA
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DSA
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de DSA
$p
$q
$g
$y
$sigFormat
$shortFormat
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toString()

toString | ( |  | $type = 'PKCS1',
 |  | array | $options = []
 | ) |  |

Returns the parameters

Paramètres
string | $type
array | $options | optional
Renvoie
string

Références $options, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DSA/Parameters.php


Joomla CMS: Référence de la classe PrivateKey

  • phpseclib3
  • Crypt
  • DSA
  • PrivateKey
Fonctions membres publiques | Attributs protégés
Référence de la classe PrivateKey
+ Graphe d'héritage de PrivateKey:
DSA PrivateKey AsymmetricKey

Fonctions membres publiques

getPublicKey ()
sign ($message)
toString ($type, array $options=[])
- Fonctions membres publiques hérités de DSA
getLength ()
getEngine ()
getParameters ()
withSignatureFormat ($format)
getSignatureFormat ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PrivateKey
withPassword ($password=false)

Attributs protégés

$x
- Attributs protégés hérités de DSA
$p
$q
$g
$y
$sigFormat
$shortFormat
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DSA
static | createParameters ($L=2048, $N=224)
static | createKey (... $args)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DSA
const | ALGORITHM = 'DSA'
- Fonctions membres protégées hérités de DSA
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DSA
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ getPublicKey()

getPublicKey ( )

Returns the public key

If you do "openssl rsa -in private.rsa -pubout -outform PEM" you get a PKCS8 formatted key that contains a publicKeyAlgorithm AlgorithmIdentifier and a publicKey BIT STRING. An AlgorithmIdentifier contains an OID and a parameters field. With RSA public keys this parameters field is NULL. With DSA PKCS8 public keys it is not - it contains the p, q and g variables. The publicKey BIT STRING contains, simply, the y variable. This can be verified by getting a DSA PKCS8 public key:

"openssl dsa -in private.dsa -pubout -outform PEM"

ie. just swap out rsa with dsa in the rsa command above.

A PKCS1 public key corresponds to the publicKey portion of the PKCS8 key. In the case of RSA the publicKey portion /is/ the key. In the case of DSA it is not. You cannot verify a signature without the parameters and the PKCS1 DSA public key format does not include the parameters.

Voir également
self::getPrivateKey() public
Renvoie
mixed

Implémente PrivateKey.

Références $key, $type, AsymmetricKey\loadFormat(), DSA\withSignatureFormat(), et y.

◆ sign()

sign ( $message )

Create a signature

Voir également
self::verify() public
Paramètres
string $message
Renvoie
mixed

Implémente PrivateKey.

Références AsymmetricKey\$format, $message, $r, $result, DSA\$sigFormat, $temp, AsymmetricKey\bits2int(), BigInteger\randomRange(), et PrivateKey\toString().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the private key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PrivateKey.

Références $options, $type, et y.

Référencé par PrivateKey\sign().

Documentation des champs

◆ $x

$x
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DSA/PrivateKey.php


Joomla CMS: Référence de la classe PublicKey

  • phpseclib3
  • Crypt
  • DSA
  • PublicKey
Fonctions membres publiques
Référence de la classe PublicKey
+ Graphe d'héritage de PublicKey:
DSA PublicKey AsymmetricKey

Fonctions membres publiques

verify ($message, $signature)
toString ($type, array $options=[])
- Fonctions membres publiques hérités de DSA
getLength ()
getEngine ()
getParameters ()
withSignatureFormat ($format)
getSignatureFormat ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PublicKey
getFingerprint ($algorithm)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DSA
static | createParameters ($L=2048, $N=224)
static | createKey (... $args)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de DSA
const | ALGORITHM = 'DSA'
- Fonctions membres protégées hérités de DSA
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de DSA
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de DSA
$p
$q
$g
$y
$sigFormat
$shortFormat
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the public key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PublicKey.

Références $options, $type, et y.

Référencé par PublicKey\verify().

◆ verify()

verify | ( | $message,
 |  | $signature
 | ) |

Verify a signature

Voir également
self::verify() public
Paramètres
string | $message
string | $signature
Renvoie
mixed

Implémente PublicKey.

Références AsymmetricKey\$format, $message, $params, $r, $result, DSA\$sigFormat, AsymmetricKey\bits2int(), PublicKey\toString(), et y.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/DSA/PublicKey.php


Joomla CMS: Référence de la classe Base

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • Base
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe Base
+ Graphe d'héritage de Base:
Binary Montgomery Prime TwistedEdwards sect113r1 sect113r2 sect131r1 sect131r2 sect163k1 sect163r1 sect163r2 sect193r1 sect193r2 sect233k1 sect233r1 sect239k1 sect283k1 sect283r1 sect409k1 sect409r1 sect571k1 sect571r1 Curve25519 Curve448 KoblitzPrime brainpoolP160r1 brainpoolP160t1 brainpoolP192r1 brainpoolP192t1 brainpoolP224r1 brainpoolP224t1 brainpoolP256r1 brainpoolP256t1 brainpoolP320r1 brainpoolP320t1 brainpoolP384r1 brainpoolP384t1 brainpoolP512r1 brainpoolP512t1 prime192v2 prime192v3 prime239v1 prime239v2 prime239v3 secp112r1 secp112r2 secp128r1 secp128r2 secp160r1 secp160r2 secp192r1 secp224r1 secp256r1 secp384r1 secp521r1 Ed25519 Ed448

Fonctions membres publiques

randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Attributs protégés

$doubles
$order
$factory

Attributs privés

$naf

Documentation des fonctions membres

◆ convertInteger()

convertInteger ( BigInteger $x )

Converts a BigInteger to a integer

Renvoie
object

Références EC\$x.

Référencé par Prime\derivePoint().

◆ convertToAffine()

convertToAffine ( array $p )

Returns the affine point

Renvoie
object[]

Référencé par Base\multiplyAddPoints(), et Base\multiplyPoint().

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to a jacobian coordinate

Renvoie
object[]

Référencé par Base\multiplyAddPoints(), et Base\multiplyPoint().

◆ createRandomMultiplier()

createRandomMultiplier ( )

Creates a random scalar multiplier

Renvoie
BigInteger

Références AsymmetricKey\$one, et BigInteger\randomRange().

◆ getLength()

getLength ( )

Returns the length, in bits, of the modulo

Renvoie
integer

◆ getLengthInBytes()

getLengthInBytes ( )

Returns the length, in bytes, of the modulo

Renvoie
integer

◆ getOrder()

getOrder ( )

Returns the Order

Renvoie

Références Base\$order.

◆ multiplyAddPoints()

multiplyAddPoints | ( | array | $points,
 |  | array | $scalars
 | ) |  |

Multiply and Add Points

Renvoie
int[]

Références $r, Base\convertToAffine(), Base\convertToInternal(), et Base\multiplyPoint().

◆ multiplyPoint()

multiplyPoint | ( | array | $p,
 |  | BigInteger | $d
 | ) |  |

Multiply a point on the curve by a scalar

Uses the montgomery ladder technique as described here:

https://en.wikipedia.org/wiki/Elliptic_curve_point_multiplication#Montgomery_ladder https://github.com/phpecc/phpecc/issues/16#issuecomment-59176772

Renvoie
array

Références $i, $r, Base\convertToAffine(), Base\convertToInternal(), et BigInteger\toBits().

Référencé par KoblitzPrime\multiplyAddPoints(), et Base\multiplyAddPoints().

◆ negatePoint()

negatePoint ( array $p )

Negates a point

Renvoie
object[]

Références $temp.

Référencé par KoblitzPrime\multiplyAddPoints(), et Prime\multiplyAddPoints().

◆ randomInteger()

randomInteger ( )

Returns a random integer

Renvoie
object

◆ rangeCheck()

rangeCheck ( BigInteger $x )

Performs range check

Références $this, EC\$x, et AsymmetricKey\$zero.

◆ setOrder()

setOrder ( BigInteger $order )

Sets the Order

Références Base\$order.

Référencé par brainpoolP160r1\__construct(), sect571r1\__construct(), sect571k1\__construct(), sect409r1\__construct(), sect409k1\__construct(), sect283r1\__construct(), sect283k1\__construct(), sect239k1\__construct(), sect233r1\__construct(), sect233k1\__construct(), sect193r2\__construct(), sect193r1\__construct(), sect163r2\__construct(), sect163r1\__construct(), sect163k1\__construct(), sect131r2\__construct(), sect131r1\__construct(), sect113r2\__construct(), sect113r1\__construct(), secp521r1\__construct(), secp384r1\__construct(), brainpoolP192t1\__construct(), brainpoolP256t1\__construct(), Curve448\__construct(), secp224k1\__construct(), secp224r1\__construct(), secp192k1\__construct(), secp160r2\__construct(), secp160r1\__construct(), secp160k1\__construct(), secp128r2\__construct(), secp128r1\__construct(), secp112r2\__construct(), secp112r1\__construct(), prime239v3\__construct(), prime239v2\__construct(), prime239v1\__construct(), prime192v3\__construct(), brainpoolP320r1\__construct(), secp256r1\__construct(), prime192v2\__construct(), brainpoolP224r1\__construct(), Curve25519\__construct(), brainpoolP512t1\__construct(), brainpoolP512r1\__construct(), brainpoolP384t1\__construct(), brainpoolP320t1\__construct(), brainpoolP384r1\__construct(), brainpoolP192r1\__construct(), brainpoolP224t1\__construct(), brainpoolP256r1\__construct(), secp192r1\__construct(), secp256k1\__construct(), Ed448\__construct(), brainpoolP160t1\__construct(), et Ed25519\__construct().

◆ setReduction()

setReduction ( callable $func )

Use a custom defined modular reduction function

Renvoie
object

Documentation des champs

◆ $doubles

$doubles
protected

◆ $factory

$factory
protected

◆ $naf

$naf
private

Référencé par Prime\multiplyAddPoints().

◆ $order

$order
protected

Référencé par Base\getOrder(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/EC/BaseCurves/Base.php


Joomla CMS: Référence de la classe Binary

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • Binary
Fonctions membres publiques | Attributs protégés
Référence de la classe Binary
+ Graphe d'héritage de Binary:
Base sect113r1 sect113r2 sect131r1 sect131r2 sect163k1 sect163r1 sect163r2 sect193r1 sect193r2 sect233k1 sect233r1 sect239k1 sect283k1 sect283r1 sect409k1 sect409r1 sect571k1 sect571r1

Fonctions membres publiques

setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Attributs protégés

$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des fonctions membres

◆ addPoint()

addPoint | ( | array | $p,
 |  | array | $q
 | ) |  |

Adds two points on the curve

Renvoie
FiniteField[]

Références Binary\$a, Binary\$b, $c, $g, $i, Binary\$p, EC\$q, $this, et Binary\doublePoint().

◆ convertToAffine()

convertToAffine ( array $p )

Returns the affine point

A Jacobian Coordinate is of the form (x, y, z). To convert a Jacobian Coordinate to an Affine Point you do (x / z^2, y / z^3)

Renvoie
[]

Références Binary\$p, et EC\$x.

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to a jacobian coordinate

Renvoie
[]

Références Binary\$one, et Binary\$p.

◆ derivePoint()

derivePoint ( $m )

Returns the X coordinate and the derived Y coordinate

Not supported because it is covered by patents. Quoting https://www.openssl.org/docs/man1.1.0/apps/ecparam.html ,

"Due to patent issues the compressed option is disabled by default for binary curves and can be enabled by defining the preprocessor macro OPENSSL_EC_BIN_PT_COMP at compile time."

Renvoie
array

◆ doublePoint()

doublePoint ( array $p )

Doubles a point on a curve

Renvoie
FiniteField[]

Références Binary\$a, Binary\$b, $c, Binary\$p, et $this.

Référencé par Binary\addPoint().

◆ getA()

getA ( )

Returns the a coefficient

Renvoie

Références Binary\$a.

◆ getB()

getB ( )

Returns the a coefficient

Renvoie

Références Binary\$b.

◆ getBasePoint()

getBasePoint ( )

Retrieve the base point as an array

Renvoie
array

Références Binary\$p.

◆ getModulo()

getModulo ( )

Returns the modulo

Renvoie

Références Binary\$modulo.

◆ setBasePoint()

setBasePoint | ( | $x,
 |  | $y
 | ) |

Set x and y coordinates for the base point

Paramètres
string | BinaryInteger | $x
string | BinaryInteger | $y

Références EC\$x.

Référencé par sect113r1\__construct(), sect571r1\__construct(), sect571k1\__construct(), sect409r1\__construct(), sect409k1\__construct(), sect283r1\__construct(), sect283k1\__construct(), sect239k1\__construct(), sect233r1\__construct(), sect233k1\__construct(), sect193r2\__construct(), sect193r1\__construct(), sect163r2\__construct(), sect163r1\__construct(), sect163k1\__construct(), sect131r2\__construct(), sect131r1\__construct(), et sect113r2\__construct().

◆ setCoefficients()

setCoefficients | ( | $a,
 |  | $b
 | ) |

Set coefficients a and b

Paramètres
string | $a
string | $b

Références Binary\$a, et Binary\$b.

Référencé par sect113r1\__construct(), sect571r1\__construct(), sect571k1\__construct(), sect409r1\__construct(), sect409k1\__construct(), sect283r1\__construct(), sect283k1\__construct(), sect239k1\__construct(), sect233r1\__construct(), sect233k1\__construct(), sect193r2\__construct(), sect193r1\__construct(), sect163r2\__construct(), sect163r1\__construct(), sect163k1\__construct(), sect131r2\__construct(), sect131r1\__construct(), et sect113r2\__construct().

◆ setModulo()

setModulo ( $modulo )

Sets the modulo

Références Binary\$modulo.

Référencé par sect113r1\__construct(), sect571r1\__construct(), sect571k1\__construct(), sect409r1\__construct(), sect409k1\__construct(), sect283r1\__construct(), sect283k1\__construct(), sect239k1\__construct(), sect233r1\__construct(), sect233k1\__construct(), sect193r2\__construct(), sect193r1\__construct(), sect163r2\__construct(), sect163r1\__construct(), sect163k1\__construct(), sect131r2\__construct(), sect131r1\__construct(), et sect113r2\__construct().

◆ verifyPoint()

verifyPoint ( array $p )

Tests whether or not the x / y values satisfy the equation

Renvoie
boolean

Références Binary\$p, et EC\$x.

Documentation des champs

◆ $a

$a
protected

Référencé par Binary\addPoint(), Binary\doublePoint(), Binary\getA(), et Binary\setCoefficients().

◆ $b

$b
protected

Référencé par Binary\addPoint(), Binary\doublePoint(), Binary\getB(), et Binary\setCoefficients().

◆ $factory

$factory
protected

◆ $modulo

$modulo
protected

Référencé par Binary\getModulo(), et Binary\setModulo().

◆ $one

$one
protected

Référencé par Binary\convertToInternal().

◆ $order

$order
protected

◆ $p

$p
protected

Référencé par Binary\addPoint(), Binary\convertToAffine(), Binary\convertToInternal(), Binary\doublePoint(), Binary\getBasePoint(), et Binary\verifyPoint().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/BaseCurves/Binary.php


Joomla CMS: Référence de la classe KoblitzPrime

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • KoblitzPrime
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe KoblitzPrime
+ Graphe d'héritage de KoblitzPrime:
Prime Base secp160k1 secp192k1 secp224k1 secp256k1

Fonctions membres publiques

multiplyAddPoints (array $points, array $scalars)
verifyPoint (array $p)
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Fonctions membres protégées

doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)

Fonctions membres protégées statiques

static extendedGCD (BigInteger $u, BigInteger $v)

Membres hérités additionnels

- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des fonctions membres

◆ doublePointHelper()

doublePointHelper ( array $p )
protected

Returns the numerator and denominator of the slope

Renvoie
FiniteField[]

Références Prime\$p.

◆ extendedGCD()

static extendedGCD | ( | BigInteger | $u,
 |  | BigInteger | $v
 | ) |  |
staticprotected

Calculates the parameters needed from the Euclidean algorithm as discussed at http://diamond.boisestate.edu/~liljanab/MATH308/GuideToECC.pdf#page=148

Paramètres
BigInteger | $u
BigInteger | $v
Renvoie
BigInteger[]

Références Prime\$a, Prime\$b, $c, Prime\$one, EC\$q, $temp, AsymmetricKey\$zero, BigInteger\bitwise_rightShift(), BigInteger\compare(), BigInteger\divide(), BigInteger\equals(), BigInteger\getLength(), et BigInteger\multiply().

◆ jacobianDoublePoint()

jacobianDoublePoint ( array $p )
protected

Doubles a jacobian coordinate on the curve

See http://hyperelliptic.org/EFD/g1p/auto-shortw-jacobian-0.html#doubling-dbl-2009-l

Renvoie
FiniteField[]

Références Prime\$a, Prime\$b, $c, et Prime\$p.

◆ jacobianDoublePointMixed()

jacobianDoublePointMixed ( array $p )
protected

Doubles a "fresh" jacobian coordinate on the curve

See http://hyperelliptic.org/EFD/g1p/auto-shortw-jacobian-0.html#doubling-mdbl-2007-bl

Renvoie
FiniteField[]

Références Prime\$p.

◆ multiplyAddPoints()

multiplyAddPoints | ( | array | $points,
 |  | array | $scalars
 | ) |  |

Multiply and Add Points

Uses a efficiently computable endomorphism to achieve a slight speedup

Adapted from https://git.io/vxbrP

Renvoie
int[]

Références Prime\$factory, $i, Prime\$one, Prime\$order, Prime\$p, $r, Prime\$two, AsymmetricKey\$zero, Base\multiplyPoint(), et Base\negatePoint().

◆ verifyPoint()

verifyPoint ( array $p )

Tests whether or not the x / y values satisfy the equation

Renvoie
boolean

Références Prime\$p, $temp, et EC\$x.

La documentation de cette classe a été générée à partir du fichier suivant :
  • KoblitzPrime.php


Joomla CMS: Référence de la classe Montgomery

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • Montgomery
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe Montgomery
+ Graphe d'héritage de Montgomery:
Base Curve25519 Curve448

Fonctions membres publiques

setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a)
setBasePoint ($x, $y)
getBasePoint ()
multiplyPoint (array $p, BigInteger $d)
convertToInternal (array $p)
convertToAffine (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Attributs protégés

$factory
$a
$a24
$zero
$one
$p
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Fonctions membres privées

doubleAndAddPoint (array $p, array $q, PrimeInteger $x1)

Documentation des fonctions membres

◆ convertToAffine()

convertToAffine ( array $p )

Returns the affine point

Renvoie
[]

Références Montgomery\$p, et EC\$x.

Référencé par Montgomery\multiplyPoint().

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to an XZ coordinate

From https://hyperelliptic.org/EFD/g1p/auto-montgom-xz.html

XZ coordinates represent x y as X Z satsfying the following equations:

x=X/Z

Renvoie
[]

Références Montgomery\$one, Montgomery\$p, et Montgomery\$zero.

Référencé par Montgomery\multiplyPoint().

◆ doubleAndAddPoint()

doubleAndAddPoint | ( | array | $p,
 |  | array | $q,
 |  | PrimeInteger | $x1
 | ) |  |
private

Doubles and adds a point on a curve

See https://tools.ietf.org/html/draft-ietf-tls-curve25519-01#appendix-A.1.3

Renvoie
FiniteField[][]

Références Montgomery\$a, $b, $c, Montgomery\$p, EC\$q, $temp, $this, et class.

Référencé par Montgomery\multiplyPoint().

◆ getBasePoint()

getBasePoint ( )

Retrieve the base point as an array

Renvoie
array

Références Montgomery\$p.

◆ multiplyPoint()

multiplyPoint | ( | array | $p,
 |  | BigInteger | $d
 | ) |  |

Multiply a point on the curve by a scalar

Uses the montgomery ladder technique as described here:

https://en.wikipedia.org/wiki/Elliptic_curve_point_multiplication#Montgomery_ladder https://github.com/phpecc/phpecc/issues/16#issuecomment-59176772

Renvoie
array

Références $b, $i, Montgomery\$one, Montgomery\$p, EC\$x, Montgomery\$zero, Montgomery\convertToAffine(), Montgomery\convertToInternal(), Montgomery\doubleAndAddPoint(), et BigInteger\toBits().

◆ setBasePoint()

setBasePoint | ( | $x,
 |  | $y
 | ) |

Set x and y coordinates for the base point

Paramètres
BigInteger | PrimeInteger | $x
BigInteger | PrimeInteger | $y
Renvoie
PrimeInteger[]

Références EC\$x.

◆ setCoefficients()

setCoefficients ( BigInteger $a )

Set coefficients a

Références Montgomery\$a.

◆ setModulo()

setModulo ( BigInteger $modulo )

Sets the modulo

Références Montgomery\$modulo.

Référencé par Curve25519\__construct(), et Curve448\__construct().

Documentation des champs

◆ $a

$a
protected

Référencé par Montgomery\doubleAndAddPoint(), et Montgomery\setCoefficients().

◆ $a24

$a24
protected

◆ $factory

$factory
protected

◆ $modulo

$modulo
protected

Référencé par Montgomery\setModulo().

◆ $one

$one
protected

Référencé par Montgomery\convertToInternal(), et Montgomery\multiplyPoint().

◆ $order

$order
protected

◆ $p

$p
protected

Référencé par Montgomery\convertToAffine(), Montgomery\convertToInternal(), Montgomery\doubleAndAddPoint(), Montgomery\getBasePoint(), Curve25519\multiplyPoint(), Curve448\multiplyPoint(), et Montgomery\multiplyPoint().

◆ $zero

$zero
protected

Référencé par Montgomery\convertToInternal(), et Montgomery\multiplyPoint().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/EC/BaseCurves/Montgomery.php


Joomla CMS: Référence de la classe Prime

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • Prime
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Fonctions membres privées statiques
Référence de la classe Prime
+ Graphe d'héritage de Prime:
Base KoblitzPrime brainpoolP160r1 brainpoolP160t1 brainpoolP192r1 brainpoolP192t1 brainpoolP224r1 brainpoolP224t1 brainpoolP256r1 brainpoolP256t1 brainpoolP320r1 brainpoolP320t1 brainpoolP384r1 brainpoolP384t1 brainpoolP512r1 brainpoolP512t1 prime192v2 prime192v3 prime239v1 prime239v2 prime239v3 secp112r1 secp112r2 secp128r1 secp128r2 secp160r1 secp160r2 secp192r1 secp224r1 secp256r1 secp384r1 secp521r1

Fonctions membres publiques

setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Fonctions membres protégées

jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)

Attributs protégés

$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Fonctions membres privées

getNAFPoints ($point, $wnd)

Fonctions membres privées statiques

static getJSFPoints (Integer $k1, Integer $k2)

Documentation des fonctions membres

◆ addPoint()

addPoint | ( | array | $p,
 |  | array | $q
 | ) |  |

Adds two points on the curve

Renvoie
FiniteField[]

Références Prime\$p, EC\$q, EC\$x, Prime\doublePointHelper(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), et Prime\jacobianAddPointMixedXY().

Référencé par Prime\getNAFPoints(), et Prime\multiplyAddPoints().

◆ convertToAffine()

convertToAffine ( array $p )

Returns the affine point

A Jacobian Coordinate is of the form (x, y, z). To convert a Jacobian Coordinate to an Affine Point you do (x / z^2, y / z^3)

Renvoie
[]

Références Prime\$p, et EC\$x.

Référencé par Prime\multiplyAddPoints().

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to a jacobian coordinate

Renvoie
[]

Références Prime\$one, et Prime\$p.

Référencé par Prime\multiplyAddPoints().

◆ derivePoint()

derivePoint ( $m )

Returns the X coordinate and the derived Y coordinate

Renvoie
array

Références Prime\$b, $temp, EC\$x, Base\convertInteger(), et Strings\shift().

◆ doublePoint()

doublePoint ( array $p )

Doubles a point on a curve

Renvoie
FiniteField[]

Références Prime\$p, EC\$x, Prime\doublePointHelper(), Prime\jacobianDoublePoint(), et Prime\jacobianDoublePointMixed().

Référencé par Prime\getNAFPoints(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), Prime\jacobianAddPointMixedXY(), et Prime\multiplyAddPoints().

◆ doublePointHelper()

doublePointHelper ( array $p )
protected

Returns the numerator and denominator of the slope

Renvoie
FiniteField[]

Références Prime\$p.

Référencé par Prime\addPoint(), et Prime\doublePoint().

◆ getA()

getA ( )

Returns the a coefficient

Renvoie

Références Prime\$a.

◆ getB()

getB ( )

Returns the a coefficient

Renvoie

Références Prime\$b.

◆ getBasePoint()

getBasePoint ( )

Retrieve the base point as an array

Renvoie
array

Références Prime\$p.

◆ getJSFPoints()

static getJSFPoints | ( | Integer | $k1,
 |  | Integer | $k2
 | ) |  |
staticprivate

Precomputes points in Joint Sparse Form

Adapted from https://git.io/vxrpD

Renvoie
int[]

Références Prime\$three, Integer\compare(), et Integer\toBigInteger().

◆ getModulo()

getModulo ( )

Returns the modulo

Renvoie

Références Prime\$modulo.

◆ getNAFPoints()

getNAFPoints | ( | $point,
 |  | $wnd
 | ) |
private

Precomputes NAF points

Adapted from https://git.io/vxY1f

Renvoie
int[]

Références $i, Prime\addPoint(), Prime\doublePoint(), et null.

Référencé par Prime\multiplyAddPoints().

◆ jacobianAddPoint()

jacobianAddPoint | ( | array | $p,
 |  | array | $q
 | ) |  |
protected

Adds two jacobian coordinates on the curve

Renvoie
FiniteField[]

Références Prime\$p, EC\$q, $r, $this, et Prime\doublePoint().

Référencé par Prime\addPoint().

◆ jacobianAddPointMixedX()

jacobianAddPointMixedX | ( | array | $p,
 |  | array | $q
 | ) |  |
protected

Adds one "fresh" jacobian form on the curve

The second parameter should be the "fresh" one

Renvoie
FiniteField[]

Références Prime\$p, EC\$q, $r, $this, et Prime\doublePoint().

Référencé par Prime\addPoint().

◆ jacobianAddPointMixedXY()

jacobianAddPointMixedXY | ( | array | $p,
 |  | array | $q
 | ) |  |
protected

Adds two "fresh" jacobian form on the curve

Renvoie
FiniteField[]

Références Prime\$p, EC\$q, $r, $this, et Prime\doublePoint().

Référencé par Prime\addPoint().

◆ jacobianDoublePoint()

jacobianDoublePoint ( array $p )
protected

Doubles a jacobian coordinate on the curve

Renvoie
FiniteField[]

Références Prime\$p, et EC\$x.

Référencé par Prime\doublePoint().

◆ jacobianDoublePointMixed()

jacobianDoublePointMixed ( array $p )
protected

Doubles a "fresh" jacobian coordinate on the curve

Renvoie
FiniteField[]

Références Prime\$p, et EC\$x.

Référencé par Prime\doublePoint().

◆ multiplyAddPoints()

multiplyAddPoints | ( | array | $points,
 |  | array | $scalars
 | ) |  |

Multiply and Add Points

Adapted from https://git.io/vxPUH

Renvoie
int[]

Références Prime\$a, Prime\$b, $i, Base\$naf, Prime\$p, $temp, AsymmetricKey\$zero, Prime\addPoint(), Prime\convertToAffine(), Prime\convertToInternal(), Prime\doublePoint(), Prime\getNAFPoints(), Base\negatePoint(), et null.

◆ setBasePoint()

setBasePoint | ( | $x,
 |  | $y
 | ) |

Set x and y coordinates for the base point

Paramètres
BigInteger | PrimeInteger | $x
BigInteger | PrimeInteger | $y
Renvoie
PrimeInteger[]

Références EC\$x.

Référencé par brainpoolP160r1\__construct(), secp521r1\__construct(), secp384r1\__construct(), brainpoolP192t1\__construct(), brainpoolP256t1\__construct(), secp224r1\__construct(), secp224k1\__construct(), prime192v3\__construct(), secp192k1\__construct(), secp160r2\__construct(), secp160r1\__construct(), secp160k1\__construct(), secp128r2\__construct(), secp128r1\__construct(), secp112r2\__construct(), secp112r1\__construct(), prime239v3\__construct(), prime239v2\__construct(), secp256r1\__construct(), prime239v1\__construct(), prime192v2\__construct(), brainpoolP512t1\__construct(), brainpoolP512r1\__construct(), brainpoolP384t1\__construct(), brainpoolP384r1\__construct(), brainpoolP320t1\__construct(), brainpoolP320r1\__construct(), brainpoolP224r1\__construct(), brainpoolP256r1\__construct(), brainpoolP224t1\__construct(), brainpoolP192r1\__construct(), secp192r1\__construct(), secp256k1\__construct(), et brainpoolP160t1\__construct().

◆ setCoefficients()

setCoefficients | ( | BigInteger | $a,
 |  | BigInteger | $b
 | ) |  |

Set coefficients a and b

Références Prime\$a, et Prime\$b.

Référencé par brainpoolP160r1\__construct(), secp521r1\__construct(), secp384r1\__construct(), brainpoolP192t1\__construct(), brainpoolP256t1\__construct(), secp224r1\__construct(), secp224k1\__construct(), prime192v3\__construct(), secp192k1\__construct(), secp160r2\__construct(), secp160r1\__construct(), secp160k1\__construct(), secp128r2\__construct(), secp128r1\__construct(), secp112r2\__construct(), secp112r1\__construct(), prime239v3\__construct(), prime239v2\__construct(), secp256r1\__construct(), prime239v1\__construct(), prime192v2\__construct(), brainpoolP512t1\__construct(), brainpoolP512r1\__construct(), brainpoolP384t1\__construct(), brainpoolP384r1\__construct(), brainpoolP320t1\__construct(), brainpoolP320r1\__construct(), brainpoolP224r1\__construct(), brainpoolP256r1\__construct(), brainpoolP224t1\__construct(), brainpoolP192r1\__construct(), secp192r1\__construct(), secp256k1\__construct(), et brainpoolP160t1\__construct().

◆ setModulo()

setModulo ( BigInteger $modulo )

Sets the modulo

Références Prime\$modulo.

Référencé par brainpoolP160r1\__construct(), secp521r1\__construct(), secp384r1\__construct(), brainpoolP192t1\__construct(), brainpoolP256t1\__construct(), secp224r1\__construct(), secp224k1\__construct(), prime192v3\__construct(), secp192k1\__construct(), secp160r2\__construct(), secp160r1\__construct(), secp160k1\__construct(), secp128r2\__construct(), secp128r1\__construct(), secp112r2\__construct(), secp112r1\__construct(), prime239v3\__construct(), prime239v2\__construct(), secp256r1\__construct(), prime239v1\__construct(), prime192v2\__construct(), brainpoolP512t1\__construct(), brainpoolP512r1\__construct(), brainpoolP384t1\__construct(), brainpoolP384r1\__construct(), brainpoolP320t1\__construct(), brainpoolP320r1\__construct(), brainpoolP224r1\__construct(), brainpoolP256r1\__construct(), brainpoolP224t1\__construct(), brainpoolP192r1\__construct(), secp192r1\__construct(), secp256k1\__construct(), et brainpoolP160t1\__construct().

◆ verifyPoint()

verifyPoint ( array $p )

Tests whether or not the x / y values satisfy the equation

Renvoie
boolean

Références Prime\$p, $temp, et EC\$x.

Documentation des champs

◆ $a

$a
protected

Référencé par KoblitzPrime\extendedGCD(), Prime\getA(), KoblitzPrime\jacobianDoublePoint(), Prime\multiplyAddPoints(), et Prime\setCoefficients().

◆ $b

$b
protected

Référencé par Prime\derivePoint(), KoblitzPrime\extendedGCD(), Prime\getB(), KoblitzPrime\jacobianDoublePoint(), Prime\multiplyAddPoints(), et Prime\setCoefficients().

◆ $eight

$eight
protected

◆ $factory

$factory
protected

Référencé par KoblitzPrime\multiplyAddPoints().

◆ $four

$four
protected

◆ $modulo

$modulo
protected

Référencé par secp192r1\__construct(), Prime\getModulo(), et Prime\setModulo().

◆ $one

$one
protected

Référencé par Prime\convertToInternal(), KoblitzPrime\extendedGCD(), et KoblitzPrime\multiplyAddPoints().

◆ $order

$order
protected

Référencé par KoblitzPrime\multiplyAddPoints().

◆ $p

$p
protected

Référencé par Prime\addPoint(), Prime\convertToAffine(), Prime\convertToInternal(), Prime\doublePoint(), KoblitzPrime\doublePointHelper(), Prime\doublePointHelper(), Prime\getBasePoint(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), Prime\jacobianAddPointMixedXY(), KoblitzPrime\jacobianDoublePoint(), Prime\jacobianDoublePoint(), KoblitzPrime\jacobianDoublePointMixed(), Prime\jacobianDoublePointMixed(), KoblitzPrime\multiplyAddPoints(), Prime\multiplyAddPoints(), KoblitzPrime\verifyPoint(), et Prime\verifyPoint().

◆ $three

$three
protected

Référencé par Prime\getJSFPoints().

◆ $two

$two
protected

Référencé par KoblitzPrime\multiplyAddPoints().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Prime.php


Joomla CMS: Référence de la classe TwistedEdwards

  • phpseclib3
  • Crypt
  • EC
  • BaseCurves
  • TwistedEdwards
Fonctions membres publiques | Attributs protégés
Référence de la classe TwistedEdwards
+ Graphe d'héritage de TwistedEdwards:
Base Ed25519 Ed448

Fonctions membres publiques

setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $d)
setBasePoint ($x, $y)
getA ()
getD ()
getBasePoint ()
convertToAffine (array $p)
getModulo ()
verifyPoint (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Attributs protégés

$modulo
$a
$d
$p
$zero
$one
$two
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des fonctions membres

◆ convertToAffine()

convertToAffine ( array $p )

Returns the affine point

Renvoie
[]

Références TwistedEdwards\$p, et EC\$x.

◆ getA()

getA ( )

Returns the a coefficient

Renvoie

Références TwistedEdwards\$a.

◆ getBasePoint()

getBasePoint ( )

Retrieve the base point as an array

Renvoie
array

Références TwistedEdwards\$p.

◆ getD()

getD ( )

Returns the a coefficient

Renvoie

Références TwistedEdwards\$d.

◆ getModulo()

getModulo ( )

Returns the modulo

Renvoie

Références TwistedEdwards\$modulo.

Référencé par Ed448\recoverX(), et Ed25519\recoverX().

◆ setBasePoint()

setBasePoint | ( | $x,
 |  | $y
 | ) |

Set x and y coordinates for the base point

Références EC\$x.

Référencé par Ed448\__construct(), et Ed25519\__construct().

◆ setCoefficients()

setCoefficients | ( | BigInteger | $a,
 |  | BigInteger | $d
 | ) |  |

Set coefficients a and b

Références TwistedEdwards\$a, et TwistedEdwards\$d.

Référencé par Ed448\__construct(), et Ed25519\__construct().

◆ setModulo()

setModulo ( BigInteger $modulo )

Sets the modulo

Références TwistedEdwards\$modulo.

Référencé par Ed448\__construct(), et Ed25519\__construct().

◆ verifyPoint()

verifyPoint ( array $p )

Tests whether or not the x / y values satisfy the equation

Renvoie
boolean

Références TwistedEdwards\$p, et EC\$x.

Documentation des champs

◆ $a

$a
protected

Référencé par Ed448\addPoint(), Ed25519\addPoint(), Ed25519\doublePoint(), TwistedEdwards\getA(), et TwistedEdwards\setCoefficients().

◆ $d

$d
protected

Référencé par Ed448\addPoint(), Ed25519\addPoint(), Ed448\doublePoint(), TwistedEdwards\getD(), et TwistedEdwards\setCoefficients().

◆ $modulo

$modulo
protected

Référencé par TwistedEdwards\getModulo(), et TwistedEdwards\setModulo().

◆ $one

$one
protected

Référencé par Ed448\convertToInternal(), et Ed25519\convertToInternal().

◆ $p

$p
protected

Référencé par Ed448\addPoint(), Ed25519\addPoint(), TwistedEdwards\convertToAffine(), Ed448\convertToInternal(), Ed25519\convertToInternal(), Ed448\doublePoint(), Ed25519\doublePoint(), TwistedEdwards\getBasePoint(), et TwistedEdwards\verifyPoint().

◆ $two

$two
protected

◆ $zero

$zero
protected

Référencé par Ed448\convertToInternal(), Ed25519\convertToInternal(), Ed448\recoverX(), et Ed25519\recoverX().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TwistedEdwards.php


Joomla CMS: Référence de la classe brainpoolP160r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP160r1
Fonctions membres publiques
Référence de la classe brainpoolP160r1
+ Graphe d'héritage de brainpoolP160r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP160r1.php


Joomla CMS: Référence de la classe brainpoolP160t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP160t1
Fonctions membres publiques
Référence de la classe brainpoolP160t1
+ Graphe d'héritage de brainpoolP160t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP160t1.php


Joomla CMS: Référence de la classe brainpoolP192r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP192r1
Fonctions membres publiques
Référence de la classe brainpoolP192r1
+ Graphe d'héritage de brainpoolP192r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP192r1.php


Joomla CMS: Référence de la classe brainpoolP192t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP192t1
Fonctions membres publiques
Référence de la classe brainpoolP192t1
+ Graphe d'héritage de brainpoolP192t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP192t1.php


Joomla CMS: Référence de la classe brainpoolP224r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP224r1
Fonctions membres publiques
Référence de la classe brainpoolP224r1
+ Graphe d'héritage de brainpoolP224r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP224r1.php


Joomla CMS: Référence de la classe brainpoolP224t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP224t1
Fonctions membres publiques
Référence de la classe brainpoolP224t1
+ Graphe d'héritage de brainpoolP224t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP224t1.php


Joomla CMS: Référence de la classe brainpoolP256r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP256r1
Fonctions membres publiques
Référence de la classe brainpoolP256r1
+ Graphe d'héritage de brainpoolP256r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP256r1.php


Joomla CMS: Référence de la classe brainpoolP256t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP256t1
Fonctions membres publiques
Référence de la classe brainpoolP256t1
+ Graphe d'héritage de brainpoolP256t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP256t1.php


Joomla CMS: Référence de la classe brainpoolP320r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP320r1
Fonctions membres publiques
Référence de la classe brainpoolP320r1
+ Graphe d'héritage de brainpoolP320r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP320r1.php


Joomla CMS: Référence de la classe brainpoolP320t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP320t1
Fonctions membres publiques
Référence de la classe brainpoolP320t1
+ Graphe d'héritage de brainpoolP320t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP320t1.php


Joomla CMS: Référence de la classe brainpoolP384r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP384r1
Fonctions membres publiques
Référence de la classe brainpoolP384r1
+ Graphe d'héritage de brainpoolP384r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP384r1.php


Joomla CMS: Référence de la classe brainpoolP384t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP384t1
Fonctions membres publiques
Référence de la classe brainpoolP384t1
+ Graphe d'héritage de brainpoolP384t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP384t1.php


Joomla CMS: Référence de la classe brainpoolP512r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP512r1
Fonctions membres publiques
Référence de la classe brainpoolP512r1
+ Graphe d'héritage de brainpoolP512r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP512r1.php


Joomla CMS: Référence de la classe brainpoolP512t1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • brainpoolP512t1
Fonctions membres publiques
Référence de la classe brainpoolP512t1
+ Graphe d'héritage de brainpoolP512t1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • brainpoolP512t1.php


Joomla CMS: Référence de la classe Curve25519

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • Curve25519
Fonctions membres publiques
Référence de la classe Curve25519
+ Graphe d'héritage de Curve25519:
Montgomery Base

Fonctions membres publiques

__construct ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
- Fonctions membres publiques hérités de Montgomery
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a)
setBasePoint ($x, $y)
getBasePoint ()
multiplyPoint (array $p, BigInteger $d)
convertToInternal (array $p)
convertToAffine (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Montgomery
$factory
$a
$a24
$zero
$one
$p
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Montgomery\setModulo(), et Base\setOrder().

Documentation des fonctions membres

◆ createRandomMultiplier()

createRandomMultiplier ( )

Creates a random scalar multiplier

Renvoie
BigInteger

Références BigInteger\random().

◆ multiplyPoint()

multiplyPoint | ( | array | $p,
 |  | BigInteger | $d
 | ) |  |

Multiply a point on the curve by a scalar

Modifies the scalar as described at https://tools.ietf.org/html/rfc7748#page-8

Renvoie
array

Références Montgomery\$p, et BigInteger\toBytes().

◆ rangeCheck()

rangeCheck ( BigInteger $x )

Performs range check

Références EC\$x.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Curve25519.php


Joomla CMS: Référence de la classe Curve448

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • Curve448
Fonctions membres publiques
Référence de la classe Curve448
+ Graphe d'héritage de Curve448:
Montgomery Base

Fonctions membres publiques

__construct ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
- Fonctions membres publiques hérités de Montgomery
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a)
setBasePoint ($x, $y)
getBasePoint ()
multiplyPoint (array $p, BigInteger $d)
convertToInternal (array $p)
convertToAffine (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Montgomery
$factory
$a
$a24
$zero
$one
$p
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Montgomery\setModulo(), et Base\setOrder().

Documentation des fonctions membres

◆ createRandomMultiplier()

createRandomMultiplier ( )

Creates a random scalar multiplier

Renvoie
BigInteger

Références BigInteger\random().

◆ multiplyPoint()

multiplyPoint | ( | array | $p,
 |  | BigInteger | $d
 | ) |  |

Multiply a point on the curve by a scalar

Modifies the scalar as described at https://tools.ietf.org/html/rfc7748#page-8

Renvoie
array

Références Montgomery\$p, et BigInteger\toBytes().

◆ rangeCheck()

rangeCheck ( BigInteger $x )

Performs range check

Références EC\$x.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Curve448.php


Joomla CMS: Référence de la classe Ed25519

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • Ed25519
Fonctions membres publiques | Champs de données
Référence de la classe Ed25519
+ Graphe d'héritage de Ed25519:
TwistedEdwards Base

Fonctions membres publiques

__construct ()
recoverX (BigInteger $y, $sign)
extractSecret ($str)
encodePoint ($point)
createRandomMultiplier ()
convertToInternal (array $p)
doublePoint (array $p)
addPoint (array $p, array $q)
- Fonctions membres publiques hérités de TwistedEdwards
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $d)
setBasePoint ($x, $y)
getA ()
getD ()
getBasePoint ()
convertToAffine (array $p)
getModulo ()
verifyPoint (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Champs de données

const | HASH = 'sha512'
const | SIZE = 32

Membres hérités additionnels

- Attributs protégés hérités de TwistedEdwards
$modulo
$a
$d
$p
$zero
$one
$two
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références TwistedEdwards\setBasePoint(), TwistedEdwards\setCoefficients(), TwistedEdwards\setModulo(), et Base\setOrder().

Documentation des fonctions membres

◆ addPoint()

addPoint | ( | array | $p,
 |  | array | $q
 | ) |  |

Adds two points on the curve

Renvoie
FiniteField[]

Références TwistedEdwards\$a, $b, $c, TwistedEdwards\$d, $g, TwistedEdwards\$p, EC\$q, et Ed25519\doublePoint().

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to an extended homogeneous coordinate

From https://tools.ietf.org/html/rfc8032#section-5.1.4 :

A point (x,y) is represented in extended homogeneous coordinates (X, Y, Z, T), with x = X/Z, y = Y/Z, x * y = T/Z.

Renvoie
[]

Références TwistedEdwards\$one, TwistedEdwards\$p, et TwistedEdwards\$zero.

◆ createRandomMultiplier()

createRandomMultiplier ( )

Creates a random scalar multiplier

Renvoie

Références Ed25519\extractSecret(), et Random\string().

◆ doublePoint()

doublePoint ( array $p )

Doubles a point on a curve

Renvoie
FiniteField[]

Références TwistedEdwards\$a, $b, $c, $g, TwistedEdwards\$p, et $temp.

Référencé par Ed25519\addPoint().

◆ encodePoint()

encodePoint ( $point )

Encode a point as a string

Paramètres
array $point
Renvoie
string

Références EC\$x.

◆ extractSecret()

extractSecret ( $str )

Extract Secret Scalar

Implements steps 1-3 at https://tools.ietf.org/html/rfc8032#section-5.1.5

Used by the various key handlers

Paramètres
string $str
Renvoie

Références AsymmetricKey\$hash.

Référencé par Ed25519\createRandomMultiplier().

◆ recoverX()

recoverX | ( | BigInteger | $y,
 |  |  | $sign
 | ) |  |

Recover X from Y

Implements steps 2-4 at https://tools.ietf.org/html/rfc8032#section-5.1.3

Used by EC\Keys\Common.php

Paramètres
BigInteger | $y
boolean | $sign
Renvoie
object[]

Références $temp, $this, EC\$x, TwistedEdwards\$zero, TwistedEdwards\getModulo(), et BigInteger\multiply().

Documentation des champs

◆ HASH

const HASH = 'sha512'

◆ SIZE

const SIZE = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Ed25519.php


Joomla CMS: Référence de la classe Ed448

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • Ed448
Fonctions membres publiques | Champs de données
Référence de la classe Ed448
+ Graphe d'héritage de Ed448:
TwistedEdwards Base

Fonctions membres publiques

__construct ()
recoverX (BigInteger $y, $sign)
extractSecret ($str)
encodePoint ($point)
createRandomMultiplier ()
convertToInternal (array $p)
doublePoint (array $p)
addPoint (array $p, array $q)
- Fonctions membres publiques hérités de TwistedEdwards
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $d)
setBasePoint ($x, $y)
getA ()
getD ()
getBasePoint ()
convertToAffine (array $p)
getModulo ()
verifyPoint (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Champs de données

const | HASH = 'shake256-912'
const | SIZE = 57

Membres hérités additionnels

- Attributs protégés hérités de TwistedEdwards
$modulo
$a
$d
$p
$zero
$one
$two
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références TwistedEdwards\setBasePoint(), TwistedEdwards\setCoefficients(), TwistedEdwards\setModulo(), et Base\setOrder().

Documentation des fonctions membres

◆ addPoint()

addPoint | ( | array | $p,
 |  | array | $q
 | ) |  |

Adds two points on the curve

Renvoie
FiniteField[]

Références TwistedEdwards\$a, $b, $c, TwistedEdwards\$d, $g, TwistedEdwards\$p, EC\$q, et Ed448\doublePoint().

◆ convertToInternal()

convertToInternal ( array $p )

Converts an affine point to an extended homogeneous coordinate

From https://tools.ietf.org/html/rfc8032#section-5.2.4 :

A point (x,y) is represented in extended homogeneous coordinates (X, Y, Z, T), with x = X/Z, y = Y/Z, x * y = T/Z.

Renvoie
[]

Références TwistedEdwards\$one, TwistedEdwards\$p, et TwistedEdwards\$zero.

◆ createRandomMultiplier()

createRandomMultiplier ( )

Creates a random scalar multiplier

Renvoie

Références Ed448\extractSecret(), et Random\string().

◆ doublePoint()

doublePoint ( array $p )

Doubles a point on a curve

Renvoie
FiniteField[]

Références $b, $c, TwistedEdwards\$d, et TwistedEdwards\$p.

Référencé par Ed448\addPoint().

◆ encodePoint()

encodePoint ( $point )

Encode a point as a string

Paramètres
array $point
Renvoie
string

Références EC\$x.

◆ extractSecret()

extractSecret ( $str )

Extract Secret Scalar

Implements steps 1-3 at https://tools.ietf.org/html/rfc8032#section-5.2.5

Used by the various key handlers

Paramètres
string $str
Renvoie

Références AsymmetricKey\$hash.

Référencé par Ed448\createRandomMultiplier().

◆ recoverX()

recoverX | ( | BigInteger | $y,
 |  |  | $sign
 | ) |  |

Recover X from Y

Implements steps 2-4 at https://tools.ietf.org/html/rfc8032#section-5.2.3

Used by EC\Keys\Common.php

Paramètres
BigInteger | $y
boolean | $sign
Renvoie
object[]

Références $this, EC\$x, TwistedEdwards\$zero, TwistedEdwards\getModulo(), et BigInteger\multiply().

Documentation des champs

◆ HASH

const HASH = 'shake256-912'

◆ SIZE

const SIZE = 57
La documentation de cette classe a été générée à partir du fichier suivant :
  • Ed448.php


Joomla CMS: Référence de la classe nistb233

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistb233
Référence de la classe nistb233
+ Graphe d'héritage de nistb233:
sect233r1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect233r1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistb233.php


Joomla CMS: Référence de la classe nistb409

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistb409
Référence de la classe nistb409
+ Graphe d'héritage de nistb409:
sect409r1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect409r1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistb409.php


Joomla CMS: Référence de la classe nistk163

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistk163
Référence de la classe nistk163
+ Graphe d'héritage de nistk163:
sect163k1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect163k1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistk163.php


Joomla CMS: Référence de la classe nistk233

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistk233
Référence de la classe nistk233
+ Graphe d'héritage de nistk233:
sect233k1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect233k1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistk233.php


Joomla CMS: Référence de la classe nistk283

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistk283
Référence de la classe nistk283
+ Graphe d'héritage de nistk283:
sect283k1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect283k1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistk283.php


Joomla CMS: Référence de la classe nistk409

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistk409
Référence de la classe nistk409
+ Graphe d'héritage de nistk409:
sect409k1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect409k1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistk409.php


Joomla CMS: Référence de la classe nistp192

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistp192
Référence de la classe nistp192
+ Graphe d'héritage de nistp192:
secp192r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp192r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistp192.php


Joomla CMS: Référence de la classe nistp224

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistp224
Référence de la classe nistp224
+ Graphe d'héritage de nistp224:
secp224r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp224r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistp224.php


Joomla CMS: Référence de la classe nistp256

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistp256
Référence de la classe nistp256
+ Graphe d'héritage de nistp256:
secp256r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp256r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistp256.php


Joomla CMS: Référence de la classe nistp384

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistp384
Référence de la classe nistp384
+ Graphe d'héritage de nistp384:
secp384r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp384r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistp384.php


Joomla CMS: Référence de la classe nistp521

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistp521
Référence de la classe nistp521
+ Graphe d'héritage de nistp521:
secp521r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp521r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistp521.php


Joomla CMS: Référence de la classe nistt571

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • nistt571
Référence de la classe nistt571
+ Graphe d'héritage de nistt571:
sect571k1 Binary Base

Membres hérités additionnels

- Fonctions membres publiques hérités de sect571k1
__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • nistt571.php


Joomla CMS: Référence de la classe prime192v1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime192v1
Référence de la classe prime192v1
+ Graphe d'héritage de prime192v1:
secp192r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp192r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • prime192v1.php


Joomla CMS: Référence de la classe prime192v2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime192v2
Fonctions membres publiques
Référence de la classe prime192v2
+ Graphe d'héritage de prime192v2:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • prime192v2.php


Joomla CMS: Référence de la classe prime192v3

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime192v3
Fonctions membres publiques
Référence de la classe prime192v3
+ Graphe d'héritage de prime192v3:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • prime192v3.php


Joomla CMS: Référence de la classe prime239v1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime239v1
Fonctions membres publiques
Référence de la classe prime239v1
+ Graphe d'héritage de prime239v1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • prime239v1.php


Joomla CMS: Référence de la classe prime239v2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime239v2
Fonctions membres publiques
Référence de la classe prime239v2
+ Graphe d'héritage de prime239v2:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • prime239v2.php


Joomla CMS: Référence de la classe prime239v3

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime239v3
Fonctions membres publiques
Référence de la classe prime239v3
+ Graphe d'héritage de prime239v3:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • prime239v3.php


Joomla CMS: Référence de la classe prime256v1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • prime256v1
Référence de la classe prime256v1
+ Graphe d'héritage de prime256v1:
secp256r1 Prime Base

Membres hérités additionnels

- Fonctions membres publiques hérités de secp256r1
__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory
La documentation de cette classe a été générée à partir du fichier suivant :
  • prime256v1.php


Joomla CMS: Référence de la classe secp112r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp112r1
Fonctions membres publiques
Référence de la classe secp112r1
+ Graphe d'héritage de secp112r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp112r1.php


Joomla CMS: Référence de la classe secp112r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp112r2
Fonctions membres publiques
Référence de la classe secp112r2
+ Graphe d'héritage de secp112r2:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp112r2.php


Joomla CMS: Référence de la classe secp128r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp128r1
Fonctions membres publiques
Référence de la classe secp128r1
+ Graphe d'héritage de secp128r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp128r1.php


Joomla CMS: Référence de la classe secp128r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp128r2
Fonctions membres publiques
Référence de la classe secp128r2
+ Graphe d'héritage de secp128r2:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp128r2.php


Joomla CMS: Référence de la classe secp160k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp160k1
Fonctions membres publiques
Référence de la classe secp160k1
+ Graphe d'héritage de secp160k1:
KoblitzPrime Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de KoblitzPrime
multiplyAddPoints (array $points, array $scalars)
verifyPoint (array $p)
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de KoblitzPrime
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées statiques hérités de KoblitzPrime
static extendedGCD (BigInteger $u, BigInteger $v)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp160k1.php


Joomla CMS: Référence de la classe secp160r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp160r1
Fonctions membres publiques
Référence de la classe secp160r1
+ Graphe d'héritage de secp160r1:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp160r1.php


Joomla CMS: Référence de la classe secp160r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp160r2
Fonctions membres publiques
Référence de la classe secp160r2
+ Graphe d'héritage de secp160r2:
Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp160r2.php


Joomla CMS: Référence de la classe secp192k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp192k1
Fonctions membres publiques
Référence de la classe secp192k1
+ Graphe d'héritage de secp192k1:
KoblitzPrime Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de KoblitzPrime
multiplyAddPoints (array $points, array $scalars)
verifyPoint (array $p)
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de KoblitzPrime
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées statiques hérités de KoblitzPrime
static extendedGCD (BigInteger $u, BigInteger $v)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp192k1.php


Joomla CMS: Référence de la classe secp192r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp192r1
Fonctions membres publiques
Référence de la classe secp192r1
+ Graphe d'héritage de secp192r1:
Prime Base nistp192 prime192v1

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\$modulo, Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp192r1.php


Joomla CMS: Référence de la classe secp224k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp224k1
Fonctions membres publiques
Référence de la classe secp224k1
+ Graphe d'héritage de secp224k1:
KoblitzPrime Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de KoblitzPrime
multiplyAddPoints (array $points, array $scalars)
verifyPoint (array $p)
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de KoblitzPrime
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées statiques hérités de KoblitzPrime
static extendedGCD (BigInteger $u, BigInteger $v)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp224k1.php


Joomla CMS: Référence de la classe secp224r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp224r1
Fonctions membres publiques
Référence de la classe secp224r1
+ Graphe d'héritage de secp224r1:
Prime Base nistp224

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp224r1.php


Joomla CMS: Référence de la classe secp256k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp256k1
Fonctions membres publiques
Référence de la classe secp256k1
+ Graphe d'héritage de secp256k1:
KoblitzPrime Prime Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de KoblitzPrime
multiplyAddPoints (array $points, array $scalars)
verifyPoint (array $p)
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de KoblitzPrime
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Fonctions membres protégées statiques hérités de KoblitzPrime
static extendedGCD (BigInteger $u, BigInteger $v)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp256k1.php


Joomla CMS: Référence de la classe secp256r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp256r1
Fonctions membres publiques
Référence de la classe secp256r1
+ Graphe d'héritage de secp256r1:
Prime Base nistp256 prime256v1

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp256r1.php


Joomla CMS: Référence de la classe secp384r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp384r1
Fonctions membres publiques
Référence de la classe secp384r1
+ Graphe d'héritage de secp384r1:
Prime Base nistp384

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp384r1.php


Joomla CMS: Référence de la classe secp521r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • secp521r1
Fonctions membres publiques
Référence de la classe secp521r1
+ Graphe d'héritage de secp521r1:
Prime Base nistp521

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Prime
setModulo (BigInteger $modulo)
setCoefficients (BigInteger $a, BigInteger $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
multiplyAddPoints (array $points, array $scalars)
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Fonctions membres protégées hérités de Prime
jacobianAddPointMixedXY (array $p, array $q)
jacobianAddPointMixedX (array $p, array $q)
jacobianAddPoint (array $p, array $q)
doublePointHelper (array $p)
jacobianDoublePoint (array $p)
jacobianDoublePointMixed (array $p)
- Attributs protégés hérités de Prime
$factory
$a
$b
$p
$one
$two
$three
$four
$eight
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Prime\setBasePoint(), Prime\setCoefficients(), Prime\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • secp521r1.php


Joomla CMS: Référence de la classe sect113r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect113r1
Fonctions membres publiques
Référence de la classe sect113r1
+ Graphe d'héritage de sect113r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect113r1.php


Joomla CMS: Référence de la classe sect113r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect113r2
Fonctions membres publiques
Référence de la classe sect113r2
+ Graphe d'héritage de sect113r2:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect113r2.php


Joomla CMS: Référence de la classe sect131r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect131r1
Fonctions membres publiques
Référence de la classe sect131r1
+ Graphe d'héritage de sect131r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect131r1.php


Joomla CMS: Référence de la classe sect131r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect131r2
Fonctions membres publiques
Référence de la classe sect131r2
+ Graphe d'héritage de sect131r2:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect131r2.php


Joomla CMS: Référence de la classe sect163k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect163k1
Fonctions membres publiques
Référence de la classe sect163k1
+ Graphe d'héritage de sect163k1:
Binary Base nistk163

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect163k1.php


Joomla CMS: Référence de la classe sect163r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect163r1
Fonctions membres publiques
Référence de la classe sect163r1
+ Graphe d'héritage de sect163r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect163r1.php


Joomla CMS: Référence de la classe sect163r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect163r2
Fonctions membres publiques
Référence de la classe sect163r2
+ Graphe d'héritage de sect163r2:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect163r2.php


Joomla CMS: Référence de la classe sect193r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect193r1
Fonctions membres publiques
Référence de la classe sect193r1
+ Graphe d'héritage de sect193r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect193r1.php


Joomla CMS: Référence de la classe sect193r2

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect193r2
Fonctions membres publiques
Référence de la classe sect193r2
+ Graphe d'héritage de sect193r2:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect193r2.php


Joomla CMS: Référence de la classe sect233k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect233k1
Fonctions membres publiques
Référence de la classe sect233k1
+ Graphe d'héritage de sect233k1:
Binary Base nistk233

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect233k1.php


Joomla CMS: Référence de la classe sect233r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect233r1
Fonctions membres publiques
Référence de la classe sect233r1
+ Graphe d'héritage de sect233r1:
Binary Base nistb233

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect233r1.php


Joomla CMS: Référence de la classe sect239k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect239k1
Fonctions membres publiques
Référence de la classe sect239k1
+ Graphe d'héritage de sect239k1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect239k1.php


Joomla CMS: Référence de la classe sect283k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect283k1
Fonctions membres publiques
Référence de la classe sect283k1
+ Graphe d'héritage de sect283k1:
Binary Base nistk283

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect283k1.php


Joomla CMS: Référence de la classe sect283r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect283r1
Fonctions membres publiques
Référence de la classe sect283r1
+ Graphe d'héritage de sect283r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect283r1.php


Joomla CMS: Référence de la classe sect409k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect409k1
Fonctions membres publiques
Référence de la classe sect409k1
+ Graphe d'héritage de sect409k1:
Binary Base nistk409

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect409k1.php


Joomla CMS: Référence de la classe sect409r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect409r1
Fonctions membres publiques
Référence de la classe sect409r1
+ Graphe d'héritage de sect409r1:
Binary Base nistb409

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect409r1.php


Joomla CMS: Référence de la classe sect571k1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect571k1
Fonctions membres publiques
Référence de la classe sect571k1
+ Graphe d'héritage de sect571k1:
Binary Base nistt571

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect571k1.php


Joomla CMS: Référence de la classe sect571r1

  • phpseclib3
  • Crypt
  • EC
  • Curves
  • sect571r1
Fonctions membres publiques
Référence de la classe sect571r1
+ Graphe d'héritage de sect571r1:
Binary Base

Fonctions membres publiques

__construct ()
- Fonctions membres publiques hérités de Binary
setModulo (... $modulo)
setCoefficients ($a, $b)
setBasePoint ($x, $y)
getBasePoint ()
addPoint (array $p, array $q)
doublePoint (array $p)
derivePoint ($m)
verifyPoint (array $p)
getModulo ()
getA ()
getB ()
convertToAffine (array $p)
convertToInternal (array $p)
- Fonctions membres publiques hérités de Base
randomInteger ()
convertInteger (BigInteger $x)
getLengthInBytes ()
getLength ()
multiplyPoint (array $p, BigInteger $d)
createRandomMultiplier ()
rangeCheck (BigInteger $x)
setOrder (BigInteger $order)
getOrder ()
setReduction (callable $func)
convertToAffine (array $p)
convertToInternal (array $p)
negatePoint (array $p)
multiplyAddPoints (array $points, array $scalars)

Membres hérités additionnels

- Attributs protégés hérités de Binary
$factory
$a
$b
$p
$one
$modulo
$order
- Attributs protégés hérités de Base
$doubles
$order
$factory

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références Binary\setBasePoint(), Binary\setCoefficients(), Binary\setModulo(), et Base\setOrder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • sect571r1.php


Joomla CMS: Référence de la classe libsodium

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • libsodium
Fonctions membres publiques statiques | Champs de données
Référence de la classe libsodium

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (Ed25519 $curve, array $publicKey)
static | savePrivateKey (BigInteger $privateKey, Ed25519 $curve, array $publicKey, $password='')

Champs de données

const IS_INVISIBLE = true

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références EC\$curve, $key, et phpseclib3\Crypt\EC\Formats\Keys\extractPoint().

Référencé par OpenSSH\load().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | Ed25519 | $curve,
 |  | array | $publicKey,
 |  |  | $password = ''
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\Curves\Ed25519 | $curve

Références EC\$curve, et $password.

◆ savePublicKey()

static savePublicKey | ( | Ed25519 | $curve,
 |  | array | $publicKey
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\Curves\Ed25519 $curve

Références EC\$curve.

Documentation des champs

◆ IS_INVISIBLE

const IS_INVISIBLE = true

Is invisible flag

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • libsodium.php


Joomla CMS: Référence de la classe MontgomeryPrivate

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • MontgomeryPrivate
Fonctions membres publiques statiques | Champs de données
Référence de la classe MontgomeryPrivate

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (MontgomeryCurve $curve, array $publicKey)
static | savePrivateKey (BigInteger $privateKey, MontgomeryCurve $curve, array $publicKey, $password='')

Champs de données

const IS_INVISIBLE = true

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références EC\$curve, et $key.

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | MontgomeryCurve | $curve,
 |  | array | $publicKey,
 |  |  | $password = ''
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\BaseCurves\Montgomery | $curve

Références $password, et BigInteger\toBytes().

◆ savePublicKey()

static savePublicKey | ( | MontgomeryCurve | $curve,
 |  | array | $publicKey
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Montgomery $curve

Documentation des champs

◆ IS_INVISIBLE

const IS_INVISIBLE = true

Is invisible flag

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • MontgomeryPrivate.php


Joomla CMS: Référence de la classe MontgomeryPublic

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • MontgomeryPublic
Fonctions membres publiques statiques | Champs de données
Référence de la classe MontgomeryPublic

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (MontgomeryCurve $curve, array $publicKey)

Champs de données

const IS_INVISIBLE = true

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références EC\$curve, et $key.

◆ savePublicKey()

static savePublicKey | ( | MontgomeryCurve | $curve,
 |  | array | $publicKey
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Montgomery $curve

Documentation des champs

◆ IS_INVISIBLE

const IS_INVISIBLE = true

Is invisible flag

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • MontgomeryPublic.php


Joomla CMS: Référence de la classe OpenSSH

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • OpenSSH
Fonctions membres publiques statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe OpenSSH
+ Graphe d'héritage de OpenSSH:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (BaseCurve $curve, array $publicKey, array $options=[])
static | savePrivateKey (BigInteger $privateKey, BaseCurve $curve, array $publicKey, $password='', array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Attributs protégés statiques

static | $types
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Fonctions membres privées statiques

static getAlias (BaseCurve $curve)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ getAlias()

static getAlias ( BaseCurve $curve )
staticprivate

Returns the alias that corresponds to a curve

Renvoie
string

Références EC\$curve, $i, $name, $oid, et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références AsymmetricKey\$comment, EC\$curve, EC\$curveName, $key, $password, $type, phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), libsodium\load(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), Strings\shift(), et Strings\unpackSSH2().

Référencé par PuTTY\load().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | BaseCurve | $curve,
 |  | array | $publicKey,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\Curves\Ed25519 | $curve

Références EC\$curve, $options, $password, et Strings\packSSH2().

◆ savePublicKey()

static savePublicKey | ( | BaseCurve | $curve,
 |  | array | $publicKey,
 |  | array | $options = []
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base $curve

Références AsymmetricKey\$comment, EC\$curve, $key, $options, et Strings\packSSH2().

Référencé par PuTTY\savePrivateKey(), et PuTTY\savePublicKey().

Documentation des champs

◆ $types

$types
staticprotected
Valeur initiale :
= [
'ecdsa-sha2-nistp256',
'ecdsa-sha2-nistp384',
'ecdsa-sha2-nistp521',
'ssh-ed25519'
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Keys/OpenSSH.php


Joomla CMS: Référence de la classe PKCS1

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • PKCS1
Fonctions membres publiques statiques
Référence de la classe PKCS1
+ Graphe d'héritage de PKCS1:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | saveParameters (BaseCurve $curve, array $options=[])
static | savePrivateKey (BigInteger $privateKey, BaseCurve $curve, array $publicKey, $password='', array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, ASN1\asn1map(), ASN1\decodeBER(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), Strings\is_stringable(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), et ECParameters\MAP.

◆ saveParameters()

static saveParameters | ( | BaseCurve | $curve,
 |  | array | $options = []
 | ) |  |
static

Convert EC parameters to the appropriate format

public

Renvoie
string

Références EC\$curve, $key, $options, phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | BaseCurve | $curve,
 |  | array | $publicKey,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve

Références EC\$curve, $key, $options, $password, ASN1\encodeDER(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et BigInteger\toBytes().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Keys/PKCS1.php


Joomla CMS: Référence de la classe PKCS8

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • PKCS8
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques
Référence de la classe PKCS8
+ Graphe d'héritage de PKCS8:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (BaseCurve $curve, array $publicKey, array $options=[])
static | savePrivateKey (BigInteger $privateKey, BaseCurve $curve, array $publicKey, $password='', array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | OID_NAME = ['id-ecPublicKey', 'id-Ed25519', 'id-Ed448']
const | OID_VALUE = ['1.2.840.10045.2.1', '1.3.101.112', '1.3.101.113']
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres privées statiques

static loadEdDSA (array $key)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $params, $password, $type, ASN1\asn1map(), ASN1\decodeBER(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), Strings\is_stringable(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), et ECParameters\MAP.

◆ loadEdDSA()

static loadEdDSA ( array $key )
staticprivate

Break a public or private EdDSA key down into its constituent components

Renvoie
array

Références $key, et phpseclib3\Crypt\EC\Formats\Keys\extractPoint().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | BaseCurve | $curve,
 |  | array | $publicKey,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve

Références EC\$curve, $key, $options, $params, $password, ASN1\encodeDER(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), null, et BigInteger\toBytes().

◆ savePublicKey()

static savePublicKey | ( | BaseCurve | $curve,
 |  | array | $publicKey,
 |  | array | $options = []
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base $curve

Références EC\$curve, $key, $options, $params, phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et null.

Documentation des champs

◆ OID_NAME

const OID_NAME = ['id-ecPublicKey', 'id-Ed25519', 'id-Ed448']

◆ OID_VALUE

const OID_VALUE = ['1.2.840.10045.2.1', '1.3.101.112', '1.3.101.113']
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Keys/PKCS8.php


Joomla CMS: Référence de la classe PuTTY

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • PuTTY
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PuTTY
+ Graphe d'héritage de PuTTY:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $privateKey, BaseCurve $curve, array $publicKey, $password=false, array $options=[])
static | savePublicKey (BaseCurve $curve, array $publicKey)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | PUBLIC_HANDLER = 'phpseclib3\Crypt\EC\Formats\Keys\OpenSSH'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $types
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, $temp, OpenSSH\load(), Strings\packSSH2(), Strings\shift(), et Strings\unpackSSH2().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $privateKey,
 |  | BaseCurve | $curve,
 |  | array | $publicKey,
 |  |  | $password = false,
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $privateKey
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve

Références EC\$curve, $name, $options, $password, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), Strings\packSSH2(), OpenSSH\savePublicKey(), Strings\shift(), BigInteger\toBits(), et BigInteger\toBytes().

◆ savePublicKey()

static savePublicKey | ( | BaseCurve | $curve,
 |  | array | $publicKey
 | ) |  |
static

Convert an EC public key to the appropriate format

public

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base $curve

Références EC\$curve, $type, OpenSSH\savePublicKey(), et Strings\shift().

Documentation des champs

◆ $types

$types
staticprotected
Valeur initiale :
= [
'ecdsa-sha2-nistp256',
'ecdsa-sha2-nistp384',
'ecdsa-sha2-nistp521',
'ssh-ed25519'
]

◆ PUBLIC_HANDLER

const PUBLIC_HANDLER = 'phpseclib3\Crypt\EC\Formats\Keys\OpenSSH'
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Keys/PuTTY.php


Joomla CMS: Référence de la classe XML

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Keys
  • XML
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe XML

Fonctions membres publiques statiques

static | load ($key, $password='')
static | setNamespace ($namespace)
static | enableRFC4050Syntax ()
static | disableRFC4050Syntax ()
static | savePublicKey (BaseCurve $curve, array $publicKey, array $options=[])

Fonctions membres privées statiques

static | query ($xpath, $name, $error=null, $decode=true)
static | isolateNamespace ($xml, $ns)
static | decodeValue ($value)
static | extractPointRFC4050 (\DOMXPath $xpath, BaseCurve $curve)
static | loadCurveByParam (\DOMXPath $xpath)
static | loadCurveByParamRFC4050 (\DOMXPath $xpath)
static | encodeXMLParameters (BaseCurve $curve, $pre, array $options=[])

Attributs privés statiques

static | $namespace
static | $rfc4050 = false

Documentation des fonctions membres

◆ decodeValue()

static decodeValue ( $value )
staticprivate

Decodes the value

Paramètres
string $value

Références $value.

◆ disableRFC4050Syntax()

static disableRFC4050Syntax ( )
static

Uses the XML syntax specified in https://www.w3.org/TR/xmldsig-core/#sec-ECParameters

◆ enableRFC4050Syntax()

static enableRFC4050Syntax ( )
static

Uses the XML syntax specified in https://tools.ietf.org/html/rfc4050

◆ encodeXMLParameters()

static encodeXMLParameters | ( | BaseCurve | $curve,
 |  |  | $pre,
 |  | array | $options = []
 | ) |  |
staticprivate

Encode Parameters

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve
string | $pre
array | $options | optional
Renvoie
string|false

Références $b, EC\$curve, $options, $result, $temp, EC\$x, $xml, et phpseclib3\Crypt\EC\Formats\Keys\encodeParameters().

◆ extractPointRFC4050()

static extractPointRFC4050 | ( | \DOMXPath | $xpath,
 |  | BaseCurve | $curve
 | ) |  |
staticprivate

Extract points from an XML document

Paramètres
\DOMXPath | $xpath
\phpseclib3\Crypt\EC\BaseCurves\Base | $curve
Renvoie
object[]

Références EC\$curve, et EC\$x.

◆ isolateNamespace()

static isolateNamespace | ( | $xml,
 |  | $ns
 | ) |
staticprivate

Finds the first element in the relevant namespace, strips the namespacing and returns the XML for that element.

Paramètres
string | $xml
string | $ns

Références $xml.

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références EC\$curve, $key, EC\$QA, $temp, phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), Strings\is_stringable(), et phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam().

◆ loadCurveByParam()

static loadCurveByParam ( \DOMXPath $xpath )
staticprivate

Returns an instance of based on the curve parameters

Paramètres
\DomXPath $xpath
Renvoie
|false

Références $b, $base, EC\$curve, $name, $oid, $params, $query, $result, $type, et phpseclib3\Crypt\EC\Formats\Keys\extractPoint().

◆ loadCurveByParamRFC4050()

static loadCurveByParamRFC4050 ( \DOMXPath $xpath )
staticprivate

Returns an instance of based on the curve parameters

Paramètres
\DomXPath $xpath
Renvoie
|false

Références $b, EC\$curve, $query, $result, $type, et EC\$x.

◆ query()

static query | ( | $xpath,
 |  | $name,
 |  | $error = null,
 |  | $decode = true
 | ) |
staticprivate

Case-insensitive xpath query

Paramètres
\DOMXPath | $xpath
string | $name
string | $error | optional
bool | $decode | optional
Renvoie

Références $name, $names, $query, et $result.

◆ savePublicKey()

static savePublicKey | ( | BaseCurve | $curve,
 |  | array | $publicKey,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

Paramètres
\phpseclib3\Crypt\EC\BaseCurves\Base $curve

Références EC\$curve, $namespace, $options, et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ setNamespace()

static setNamespace ( $namespace )
static

Sets the namespace. dsig11 is the most common one.

Set to null to unset. Used only for creating public keys.

Paramètres
string $namespace

Références $namespace, et XML\$namespace.

Documentation des champs

◆ $namespace

$namespace
staticprivate

Référencé par XML\setNamespace().

◆ $rfc4050

$rfc4050 = false
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Keys/XML.php


Joomla CMS: Référence de la classe ASN1

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Signature
  • ASN1
Fonctions membres publiques statiques
Référence de la classe ASN1

Fonctions membres publiques statiques

static | load ($sig)
static | save (BigInteger $r, BigInteger $s)

Documentation des fonctions membres

◆ load()

static load ( $sig )
static

Loads a signature

public

Paramètres
string $sig
Renvoie
array

◆ save()

static save | ( | BigInteger | $r,
 |  | BigInteger | $s
 | ) |  |
static

Returns a signature in the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $r
\phpseclib3\Math\BigInteger | $s
Renvoie
string
La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/EC/Formats/Signature/ASN1.php


Joomla CMS: Référence de la classe Raw

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Signature
  • Raw
Référence de la classe Raw
+ Graphe d'héritage de Raw:
Montgomery Base PHP Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC/Formats/Signature/Raw.php


Joomla CMS: Référence de la classe SSH2

  • phpseclib3
  • Crypt
  • EC
  • Formats
  • Signature
  • SSH2
Fonctions membres publiques statiques
Référence de la classe SSH2

Fonctions membres publiques statiques

static | load ($sig)
static | save (BigInteger $r, BigInteger $s, $curve)

Documentation des fonctions membres

◆ load()

static load ( $sig )
static

Loads a signature

public

Paramètres
string $sig
Renvoie
mixed

Références $result, $type, et Strings\unpackSSH2().

◆ save()

static save | ( | BigInteger | $r,
 |  | BigInteger | $s,
 |  |  | $curve
 | ) |  |
static

Returns a signature in the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $r
\phpseclib3\Math\BigInteger | $s
string | $curve
Renvoie
string

Références EC\$curve, $r, et Strings\packSSH2().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypt/EC/Formats/Signature/SSH2.php


Joomla CMS: Référence de la classe Parameters

  • phpseclib3
  • Crypt
  • EC
  • Parameters
Fonctions membres publiques
Référence de la classe Parameters
+ Graphe d'héritage de Parameters:
EC AsymmetricKey

Fonctions membres publiques

toString ($type='PKCS1', array $options=[])
- Fonctions membres publiques hérités de EC
getCurve ()
getLength ()
getEngine ()
getEncodedCoordinates ()
getParameters ($type='PKCS1')
withSignatureFormat ($format)
getSignatureFormat ()
withContext ($context=null)
getContext ()
withHash ($hash)
__toString ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de EC
static | createKey ($curve)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de EC
const | ALGORITHM = 'EC'
- Fonctions membres protégées hérités de EC
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de EC
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de EC
$QA
$curve
$format
$shortFormat
$q
$x
$context
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toString()

toString | ( |  | $type = 'PKCS1',
 |  | array | $options = []
 | ) |  |

Returns the parameters

Paramètres
string | $type
array | $options | optional
Renvoie
string

Références $options, et $type.

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/Parameters.php


Joomla CMS: Référence de la classe PrivateKey

  • phpseclib3
  • Crypt
  • EC
  • PrivateKey
Fonctions membres publiques | Attributs protégés
Référence de la classe PrivateKey
+ Graphe d'héritage de PrivateKey:
EC PrivateKey AsymmetricKey

Fonctions membres publiques

multiply ($coordinates)
sign ($message)
toString ($type, array $options=[])
getPublicKey ()
- Fonctions membres publiques hérités de EC
getCurve ()
getLength ()
getEngine ()
getEncodedCoordinates ()
getParameters ($type='PKCS1')
withSignatureFormat ($format)
getSignatureFormat ()
withContext ($context=null)
getContext ()
withHash ($hash)
__toString ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PrivateKey
withPassword ($password=false)

Attributs protégés

$dA
- Attributs protégés hérités de EC
$QA
$curve
$format
$shortFormat
$q
$x
$context
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de EC
static | createKey ($curve)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de EC
const | ALGORITHM = 'EC'
- Fonctions membres protégées hérités de EC
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de EC
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ getPublicKey()

getPublicKey ( )

Returns the public key

Voir également
self::getPrivateKey() public
Renvoie
mixed

Implémente PrivateKey.

Références EC\$format, $key, $type, AsymmetricKey\loadFormat(), et EC\withSignatureFormat().

◆ multiply()

multiply ( $coordinates )

Multiplies an encoded point by the private key

Used by ECDH

Paramètres
string $coordinates
Renvoie
string

Références phpseclib3\Crypt\EC\Formats\Keys\extractPoint().

◆ sign()

sign ( $message )

Create a signature

Voir également
self::verify() public
Paramètres
string $message
Renvoie
mixed

Implémente PrivateKey.

Références EC\$context, EC\$curve, PrivateKey\$dA, EC\$format, AsymmetricKey\$hash, $message, $r, $result, EC\$shortFormat, $temp, $this, EC\$x, EC\getCurve(), Strings\packSSH2(), BigInteger\randomRange(), PrivateKey\toString(), et PrivateKey\withPassword().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the private key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PrivateKey.

Références $options, et $type.

Référencé par PrivateKey\sign().

Documentation des champs

◆ $dA

$dA
protected

Référencé par PrivateKey\sign().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/PrivateKey.php


Joomla CMS: Référence de la classe PublicKey

  • phpseclib3
  • Crypt
  • EC
  • PublicKey
Fonctions membres publiques
Référence de la classe PublicKey
+ Graphe d'héritage de PublicKey:
EC PublicKey AsymmetricKey

Fonctions membres publiques

verify ($message, $signature)
toString ($type, array $options=[])
- Fonctions membres publiques hérités de EC
getCurve ()
getLength ()
getEngine ()
getEncodedCoordinates ()
getParameters ($type='PKCS1')
withSignatureFormat ($format)
getSignatureFormat ()
withContext ($context=null)
getContext ()
withHash ($hash)
__toString ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PublicKey
getFingerprint ($algorithm)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de EC
static | createKey ($curve)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de EC
const | ALGORITHM = 'EC'
- Fonctions membres protégées hérités de EC
__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de EC
static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de EC
$QA
$curve
$format
$shortFormat
$q
$x
$context
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the public key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PublicKey.

Références $options, et $type.

Référencé par PublicKey\verify().

◆ verify()

verify | ( | $message,
 |  | $signature
 | ) |

Verify a signature

Voir également
self::verify() public
Paramètres
string | $message
string | $signature
Renvoie
mixed

Implémente PublicKey.

Références EC\$context, EC\$curve, EC\$format, AsymmetricKey\$hash, $message, $params, EC\$QA, $r, $result, EC\$shortFormat, phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), PublicKey\toString(), et Strings\unpackSSH2().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/EC/PublicKey.php


Joomla CMS: Référence de la classe MSBLOB

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • MSBLOB
Fonctions membres publiques statiques | Champs de données
Référence de la classe MSBLOB

Fonctions membres publiques statiques

static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='')
static | savePublicKey (BigInteger $n, BigInteger $e)

Champs de données

const | PRIVATEKEYBLOB = 0x7
const | PUBLICKEYBLOB = 0x6
const | PUBLICKEYBLOBEX = 0xA
const | CALG_RSA_KEYX = 0x0000A400
const | CALG_RSA_SIGN = 0x00002400
const | RSA1 = 0x31415352
const | RSA2 = 0x32415352

Documentation des fonctions membres

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = ''
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
Renvoie
string

Références $key, $n, $password, et BigInteger\toBytes().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
Renvoie
string

Références $key, et $n.

Documentation des champs

◆ CALG_RSA_KEYX

const CALG_RSA_KEYX = 0x0000A400

RSA public key exchange algorithm

private

◆ CALG_RSA_SIGN

const CALG_RSA_SIGN = 0x00002400

RSA public key exchange algorithm

private

◆ PRIVATEKEYBLOB

const PRIVATEKEYBLOB = 0x7

Public/Private Key Pair

private

◆ PUBLICKEYBLOB

const PUBLICKEYBLOB = 0x6

Public Key

private

◆ PUBLICKEYBLOBEX

const PUBLICKEYBLOBEX = 0xA

Public Key

private

◆ RSA1

const RSA1 = 0x31415352

Public Key

private

◆ RSA2

const RSA2 = 0x32415352

Private Key

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • MSBLOB.php


Joomla CMS: Référence de la classe OpenSSH

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • OpenSSH
Fonctions membres publiques statiques | Attributs protégés statiques
Référence de la classe OpenSSH
+ Graphe d'héritage de OpenSSH:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePublicKey (BigInteger $n, BigInteger $e, array $options=[])
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Attributs protégés statiques

static | $types = ['ssh-rsa']
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références AsymmetricKey\$comment, $key, RSA\$modulus, Engine\$one, $password, $temp, $type, et Strings\unpackSSH2().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
string

Références $n, $options, $password, et Strings\packSSH2().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
array | $options | optional
Renvoie
string

Références AsymmetricKey\$comment, $n, $options, et Strings\packSSH2().

Documentation des champs

◆ $types

$types = ['ssh-rsa']
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/OpenSSH.php


Joomla CMS: Référence de la classe PKCS1

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • PKCS1
Fonctions membres publiques statiques
Référence de la classe PKCS1
+ Graphe d'héritage de PKCS1:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
static | savePublicKey (BigInteger $n, BigInteger $e)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, ASN1\asn1map(), ASN1\decodeBER(), elseif, et Strings\is_stringable().

Référencé par PKCS8\load(), et PSS\load().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
string

Références $i, $key, $n, $options, $password, et ASN1\encodeDER().

Référencé par PKCS8\savePrivateKey(), et PSS\savePrivateKey().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
Renvoie
string

Références $key, $n, et ASN1\encodeDER().

Référencé par PKCS8\savePublicKey(), et PSS\savePublicKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/PKCS1.php


Joomla CMS: Référence de la classe PKCS8

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • PKCS8
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PKCS8
+ Graphe d'héritage de PKCS8:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
static | savePublicKey (BigInteger $n, BigInteger $e, array $options=[])
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | OID_NAME = 'rsaEncryption'
const | OID_VALUE = '1.2.840.113549.1.1.1'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $childOIDsLoaded = false
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $password, $result, $type, elseif, Strings\is_stringable(), et PKCS1\load().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
string

Références $key, $n, $options, $password, ASN1\extractBER(), null, et PKCS1\savePrivateKey().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
array | $options | optional
Renvoie
string

Références $key, $n, ASN1\extractBER(), null, et PKCS1\savePublicKey().

Documentation des champs

◆ $childOIDsLoaded

$childOIDsLoaded = false
staticprotected

◆ OID_NAME

const OID_NAME = 'rsaEncryption'

◆ OID_VALUE

const OID_VALUE = '1.2.840.113549.1.1.1'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/PKCS8.php


Joomla CMS: Référence de la classe PSS

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • PSS
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe PSS
+ Graphe d'héritage de PSS:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
static | savePublicKey (BigInteger $n, BigInteger $e, array $options=[])
static | savePSSParams (array $options)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | OID_NAME = 'id-RSASSA-PSS'
const | OID_VALUE = '1.2.840.113549.1.1.10'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $childOIDsLoaded = false
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Fonctions membres privées statiques

static initialize_static_variables ()

Attributs privés statiques

static $oidsLoaded = false

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ initialize_static_variables()

static initialize_static_variables ( )
staticprivate

Initialize static variables

Références ASN1\loadOIDs().

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $params, $password, $result, $type, ASN1\asn1map(), ASN1\decodeBER(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), Strings\is_stringable(), PKCS1\load(), et PHP\toString().

Référencé par X509\sign().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
string

Références $key, $n, $options, $params, $password, ASN1\extractBER(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), null, et PKCS1\savePrivateKey().

◆ savePSSParams()

static savePSSParams ( array $options )
static

Encodes PSS parameters

public

Paramètres
array $options
Renvoie
string

Références $options, $params, $temp, et ASN1\encodeDER().

Référencé par X509\sign().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | array | $options = []
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
array | $options | optional
Renvoie
string

Références $key, $n, $options, $params, ASN1\extractBER(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et PKCS1\savePublicKey().

Documentation des champs

◆ $childOIDsLoaded

$childOIDsLoaded = false
staticprotected

◆ $oidsLoaded

$oidsLoaded = false
staticprivate

◆ OID_NAME

const OID_NAME = 'id-RSASSA-PSS'

◆ OID_VALUE

const OID_VALUE = '1.2.840.113549.1.1.10'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PSS.php


Joomla CMS: Référence de la classe PuTTY

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • PuTTY
Fonctions membres publiques statiques | Champs de données | Attributs protégés statiques
Référence de la classe PuTTY
+ Graphe d'héritage de PuTTY:
Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
static | savePublicKey (BigInteger $n, BigInteger $e)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | PUBLIC_HANDLER = 'phpseclib3\Crypt\RSA\Formats\Keys\OpenSSH'
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Attributs protégés statiques

static | $types = ['ssh-rsa']
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, RSA\$modulus, Engine\$one, $password, $result, $temp, et Strings\unpackSSH2().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
string

Références $n, $options, $password, et Strings\packSSH2().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
Renvoie
string

Références $n, et Strings\packSSH2().

Documentation des champs

◆ $types

$types = ['ssh-rsa']
staticprotected

◆ PUBLIC_HANDLER

const PUBLIC_HANDLER = 'phpseclib3\Crypt\RSA\Formats\Keys\OpenSSH'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/PuTTY.php


Joomla CMS: Référence de la classe Raw

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • Raw
Fonctions membres publiques statiques
Référence de la classe Raw

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='', array $options=[])
static | savePublicKey (BigInteger $n, BigInteger $e)

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, AsymmetricKey\$one, $temp, et elseif.

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = '',
 |  | array | $options = []
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
array | $options | optional
Renvoie
array

Références $n, et $password.

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
Renvoie
array

Références $n.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/Raw.php


Joomla CMS: Référence de la classe XML

  • phpseclib3
  • Crypt
  • RSA
  • Formats
  • Keys
  • XML
Fonctions membres publiques statiques
Référence de la classe XML

Fonctions membres publiques statiques

static | load ($key, $password='')
static | savePrivateKey (BigInteger $n, BigInteger $e, BigInteger $d, array $primes, array $exponents, array $coefficients, $password='')
static | savePublicKey (BigInteger $n, BigInteger $e)

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = ''
 | ) |
static

Break a public or private key down into its constituent components

public

Paramètres
string | $key
string | $password | optional
Renvoie
array

Références $key, $temp, $value, et Strings\is_stringable().

◆ savePrivateKey()

static savePrivateKey | ( | BigInteger | $n,
 |  | BigInteger | $e,
 |  | BigInteger | $d,
 |  | array | $primes,
 |  | array | $exponents,
 |  | array | $coefficients,
 |  |  | $password = ''
 | ) |  |
static

Convert a private key to the appropriate format.

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
\phpseclib3\Math\BigInteger | $d
array | $primes
array | $exponents
array | $coefficients
string | $password | optional
Renvoie
string

Références $n, $password, et BigInteger\toBytes().

◆ savePublicKey()

static savePublicKey | ( | BigInteger | $n,
 |  | BigInteger | $e
 | ) |  |
static

Convert a public key to the appropriate format

public

Paramètres
\phpseclib3\Math\BigInteger | $n
\phpseclib3\Math\BigInteger | $e
Renvoie
string

Références $n, et BigInteger\toBytes().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RSA/Formats/Keys/XML.php


Joomla CMS: Référence de la classe PrivateKey

  • phpseclib3
  • Crypt
  • RSA
  • PrivateKey
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe PrivateKey
+ Graphe d'héritage de PrivateKey:
RSA PrivateKey AsymmetricKey

Fonctions membres publiques

sign ($message)
decrypt ($ciphertext)
getPublicKey ()
toString ($type, array $options=[])
- Fonctions membres publiques hérités de RSA
getLength ()
withHash ($hash)
withMGFHash ($hash)
getMGFHash ()
withSaltLength ($sLen)
getSaltLength ()
withLabel ($label)
getLabel ()
withPadding ($padding)
getPadding ()
getEngine ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PrivateKey
withPassword ($password=false)

Fonctions membres protégées

exponentiate (BigInteger $x)
- Fonctions membres protégées hérités de RSA
__construct ()
i2osp ($x, $xLen)
os2ip ($x)
emsa_pkcs1_v1_5_encode ($m, $emLen)
emsa_pkcs1_v1_5_encode_without_null ($m, $emLen)
mgf1 ($mgfSeed, $maskLen)
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)

Attributs protégés

$primes
$exponents
$coefficients
$publicExponent = false
- Attributs protégés hérités de RSA
$encryptionPadding = self::ENCRYPTION_OAEP
$signaturePadding = self::SIGNATURE_PSS
$hLen
$sLen
$label = ''
$mgfHash
$mgfHLen
$modulus
$k
$exponent
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Fonctions membres privées

rsadp ($c)
rsasp1 ($m)
blind ($x, $r, $i)
emsa_pss_encode ($m, $emBits)
rsassa_pss_sign ($m)
rsassa_pkcs1_v1_5_sign ($m)
rsaes_pkcs1_v1_5_decrypt ($c)
rsaes_oaep_decrypt ($c)
raw_encrypt ($m)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RSA
static | setExponent ($val)
static | setSmallestPrime ($val)
static | setOpenSSLConfigPath ($val)
static | enableBlinding ()
static | disableBlinding ()
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de RSA
const | ALGORITHM = 'RSA'
const | ENCRYPTION_OAEP = 1
const | ENCRYPTION_PKCS1 = 2
const | ENCRYPTION_NONE = 4
const | SIGNATURE_PSS = 16
const | SIGNATURE_RELAXED_PKCS1 = 32
const | SIGNATURE_PKCS1 = 64
- Fonctions membres protégées statiques hérités de RSA
static | onLoad ($components)
static | initialize_static_variables ()
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés statiques hérités de RSA
static | $enableBlinding = true
static | $configFile
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ blind()

blind | ( | $x,
 |  | $r,
 |  | $i
 | ) |
private

Performs RSA Blinding

Protects against timing attacks by employing RSA Blinding. Returns $x->modPow($this->exponents[$i], $this->primes[$i])

private

Paramètres
\phpseclib3\Math\BigInteger | $x
\phpseclib3\Math\BigInteger | $r
int | $i
Renvoie

Références $i, $r, et $this.

Référencé par PrivateKey\exponentiate().

◆ decrypt()

decrypt ( $ciphertext )

Decryption

Voir également
self::encrypt() public
Paramètres
string $ciphertext
Renvoie
bool|string

Références PrivateKey\raw_encrypt(), PrivateKey\rsaes_oaep_decrypt(), et PrivateKey\rsaes_pkcs1_v1_5_decrypt().

◆ emsa_pss_encode()

emsa_pss_encode | ( | $m,
 |  | $emBits
 | ) |
private

EMSA-PSS-ENCODE

See RFC3447#section-9.1.1.

Renvoie
string private
Paramètres
string $m
Exceptions

Références $db, RSA\$hLen, RSA\$sLen, RSA\mgf1(), null, et Random\string().

Référencé par PrivateKey\rsassa_pss_sign().

◆ exponentiate()

exponentiate ( BigInteger $x )
protected

Exponentiate

Paramètres
\phpseclib3\Math\BigInteger $x
Renvoie

Références $i, $r, $this, PrivateKey\blind(), BigInteger\modPow(), et BigInteger\randomRange().

Référencé par PrivateKey\rsadp(), et PrivateKey\rsasp1().

◆ getPublicKey()

getPublicKey ( )

Returns the public key

public

Renvoie
mixed

Implémente PrivateKey.

Références $key, $type, AsymmetricKey\loadFormat(), RSA\withMGFHash(), et RSA\withSaltLength().

◆ raw_encrypt()

raw_encrypt ( $m )
private

Raw Encryption / Decryption

Doesn't use padding and is not recommended.

private

Paramètres
string $m
Renvoie
bool|string
Exceptions

Références $temp, RSA\i2osp(), RSA\os2ip(), et PrivateKey\rsadp().

Référencé par PrivateKey\decrypt().

◆ rsadp()

rsadp ( $c )
private

RSADP

See RFC3447#section-5.1.2.

private

Paramètres
\phpseclib3\Math\BigInteger $c
Renvoie
bool|

Références $c, et PrivateKey\exponentiate().

Référencé par PrivateKey\raw_encrypt(), PrivateKey\rsaes_oaep_decrypt(), et PrivateKey\rsaes_pkcs1_v1_5_decrypt().

◆ rsaes_oaep_decrypt()

rsaes_oaep_decrypt ( $c )
private

RSAES-OAEP-DECRYPT

See RFC3447#section-7.1.2. The fact that the error messages aren't distinguishable from one another hinders debugging, but, to quote from RFC3447::section-7.1.2:

Note. Care must be taken to ensure that an opponent cannot distinguish the different error conditions in Step 3.g, whether by error message or timing, or, more generally, learn partial information about the encoded message EM. Otherwise an opponent may be able to obtain useful information about the decryption of the ciphertext C, leading to a chosen-ciphertext attack such as the one observed by Manger [36].

private

Paramètres
string $c
Renvoie
bool|string

Références $c, $db, $i, Joomla\Database\Query\$offset, RSA\i2osp(), RSA\mgf1(), RSA\os2ip(), et PrivateKey\rsadp().

Référencé par PrivateKey\decrypt().

◆ rsaes_pkcs1_v1_5_decrypt()

rsaes_pkcs1_v1_5_decrypt ( $c )
private

RSAES-PKCS1-V1_5-DECRYPT

See RFC3447#section-7.2.2.

private

Paramètres
string $c
Renvoie
bool|string

Références $c, RSA\i2osp(), RSA\os2ip(), et PrivateKey\rsadp().

Référencé par PrivateKey\decrypt().

◆ rsasp1()

rsasp1 ( $m )
private

RSASP1

See RFC3447#section-5.2.1.

private

Paramètres
\phpseclib3\Math\BigInteger $m
Renvoie
bool|

Références PrivateKey\exponentiate().

Référencé par PrivateKey\rsassa_pkcs1_v1_5_sign(), et PrivateKey\rsassa_pss_sign().

◆ rsassa_pkcs1_v1_5_sign()

rsassa_pkcs1_v1_5_sign ( $m )
private

RSASSA-PKCS1-V1_5-SIGN

See RFC3447#section-8.2.1.

private

Paramètres
string $m
Exceptions

Références RSA\emsa_pkcs1_v1_5_encode(), RSA\i2osp(), RSA\os2ip(), et PrivateKey\rsasp1().

Référencé par PrivateKey\sign().

◆ rsassa_pss_sign()

rsassa_pss_sign ( $m )
private

RSASSA-PSS-SIGN

See RFC3447#section-8.1.1.

private

Paramètres
string $m
Renvoie
bool|string

Références PrivateKey\emsa_pss_encode(), RSA\i2osp(), RSA\os2ip(), et PrivateKey\rsasp1().

Référencé par PrivateKey\sign().

◆ sign()

sign ( $message )

Create a signature

Voir également
self::verify() public
Paramètres
string $message
Renvoie
string

Implémente PrivateKey.

Références $message, PrivateKey\rsassa_pkcs1_v1_5_sign(), et PrivateKey\rsassa_pss_sign().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the private key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PrivateKey.

Références $options, $type, class, et RSA\getSaltLength().

Documentation des champs

◆ $coefficients

$coefficients
protected

◆ $exponents

$exponents
protected

◆ $primes

$primes
protected

◆ $publicExponent

$publicExponent = false
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/RSA/PrivateKey.php


Joomla CMS: Référence de la classe PublicKey

  • phpseclib3
  • Crypt
  • RSA
  • PublicKey
Fonctions membres publiques | Fonctions membres privées
Référence de la classe PublicKey
+ Graphe d'héritage de PublicKey:
RSA PublicKey AsymmetricKey

Fonctions membres publiques

verify ($message, $signature)
encrypt ($plaintext)
toString ($type, array $options=[])
asPrivateKey ()
- Fonctions membres publiques hérités de RSA
getLength ()
withHash ($hash)
withMGFHash ($hash)
getMGFHash ()
withSaltLength ($sLen)
getSaltLength ()
withLabel ($label)
getLabel ()
withPadding ($padding)
getPadding ()
getEngine ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()
- Fonctions membres publiques hérités de PublicKey
getFingerprint ($algorithm)

Fonctions membres privées

exponentiate (BigInteger $x)
rsavp1 ($s)
rsassa_pkcs1_v1_5_verify ($m, $s)
rsassa_pkcs1_v1_5_relaxed_verify ($m, $s)
emsa_pss_verify ($m, $em, $emBits)
rsassa_pss_verify ($m, $s)
rsaes_pkcs1_v1_5_encrypt ($m, $pkcs15_compat=false)
rsaes_oaep_encrypt ($m)
rsaep ($m)
raw_encrypt ($m)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RSA
static | setExponent ($val)
static | setSmallestPrime ($val)
static | setOpenSSLConfigPath ($val)
static | enableBlinding ()
static | disableBlinding ()
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()
- Champs de données hérités de RSA
const | ALGORITHM = 'RSA'
const | ENCRYPTION_OAEP = 1
const | ENCRYPTION_PKCS1 = 2
const | ENCRYPTION_NONE = 4
const | SIGNATURE_PSS = 16
const | SIGNATURE_RELAXED_PKCS1 = 32
const | SIGNATURE_PKCS1 = 64
- Fonctions membres protégées hérités de RSA
__construct ()
i2osp ($x, $xLen)
os2ip ($x)
emsa_pkcs1_v1_5_encode ($m, $emLen)
emsa_pkcs1_v1_5_encode_without_null ($m, $emLen)
mgf1 ($mgfSeed, $maskLen)
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Fonctions membres protégées statiques hérités de RSA
static | onLoad ($components)
static | initialize_static_variables ()
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)
- Attributs protégés hérités de RSA
$encryptionPadding = self::ENCRYPTION_OAEP
$signaturePadding = self::SIGNATURE_PSS
$hLen
$sLen
$label = ''
$mgfHash
$mgfHLen
$modulus
$k
$exponent
- Attributs protégés hérités de AsymmetricKey
$format
$hash
- Attributs protégés statiques hérités de RSA
static | $enableBlinding = true
static | $configFile
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ asPrivateKey()

asPrivateKey ( )

Converts a public key to a private key

Renvoie
RSA

Références RSA\$exponent, AsymmetricKey\$format, RSA\$k, RSA\$modulus, RSA\withMGFHash(), et RSA\withSaltLength().

◆ emsa_pss_verify()

emsa_pss_verify | ( | $m,
 |  | $em,
 |  | $emBits
 | ) |
private

EMSA-PSS-VERIFY

See RFC3447#section-9.1.2.

private

Paramètres
string | $m
string | $em
int | $emBits
Renvoie
string

Références $db, RSA\$hLen, RSA\$sLen, $temp, RSA\mgf1(), et null.

Référencé par PublicKey\rsassa_pss_verify().

◆ encrypt()

encrypt ( $plaintext )

Encryption

Both self::PADDING_OAEP and self::PADDING_PKCS1 both place limits on how long $plaintext can be. If $plaintext exceeds those limits it will be broken up so that it does and the resultant ciphertext's will be concatenated together.

Voir également
self::decrypt() public
Paramètres
string $plaintext
Renvoie
bool|string
Exceptions

Références PublicKey\raw_encrypt(), PublicKey\rsaes_oaep_encrypt(), et PublicKey\rsaes_pkcs1_v1_5_encrypt().

◆ exponentiate()

exponentiate ( BigInteger $x )
private

Exponentiate

Paramètres
\phpseclib3\Math\BigInteger $x
Renvoie

Références BigInteger\modPow().

Référencé par PublicKey\rsaep(), et PublicKey\rsavp1().

◆ raw_encrypt()

raw_encrypt ( $m )
private

Raw Encryption / Decryption

Doesn't use padding and is not recommended.

private

Paramètres
string $m
Renvoie
bool|string
Exceptions

Références $temp, RSA\i2osp(), RSA\os2ip(), et PublicKey\rsaep().

Référencé par PublicKey\encrypt().

◆ rsaep()

rsaep ( $m )
private

RSAEP

See RFC3447#section-5.1.1.

private

Paramètres
\phpseclib3\Math\BigInteger $m
Renvoie
bool|

Références PublicKey\exponentiate().

Référencé par PublicKey\raw_encrypt(), PublicKey\rsaes_oaep_encrypt(), et PublicKey\rsaes_pkcs1_v1_5_encrypt().

◆ rsaes_oaep_encrypt()

rsaes_oaep_encrypt ( $m )
private

RSAES-OAEP-ENCRYPT

See RFC3447#section-7.1.1 and {http://en.wikipedia.org/wiki/Optimal_Asymmetric_Encryption_Padding OAES}.

private

Paramètres
string $m
Exceptions

Références $c, $db, RSA\i2osp(), RSA\mgf1(), RSA\os2ip(), PublicKey\rsaep(), et Random\string().

Référencé par PublicKey\encrypt().

◆ rsaes_pkcs1_v1_5_encrypt()

rsaes_pkcs1_v1_5_encrypt | ( | $m,
 |  | $pkcs15_compat = false
 | ) |
private

RSAES-PKCS1-V1_5-ENCRYPT

See RFC3447#section-7.2.1.

private

Paramètres
string | $m
bool | $pkcs15_compat | optional
Exceptions

Références $c, $temp, $type, RSA\i2osp(), RSA\os2ip(), PublicKey\rsaep(), et Random\string().

Référencé par PublicKey\encrypt().

◆ rsassa_pkcs1_v1_5_relaxed_verify()

rsassa_pkcs1_v1_5_relaxed_verify | ( | $m,
 |  | $s
 | ) |
private

RSASSA-PKCS1-V1_5-VERIFY (relaxed matching)

Per RFC3447#page-43 PKCS1 v1.5 specified the use BER encoding rather than DER encoding that PKCS1 v2.0 specified. This means that under rare conditions you can have a perfectly valid v1.5 signature that fails to validate with _rsassa_pkcs1_v1_5_verify(). PKCS1 v2.1 also recommends that if you're going to validate these types of signatures you "should indicate whether the underlying BER encoding is a DER encoding and hence whether the signature is valid with respect to the specification given in [PKCS1 v2.0+]". so if you do $rsa->getLastPadding() and get RSA::PADDING_RELAXED_PKCS1 back instead of RSA::PADDING_PKCS1... that means BER encoding was used.

private

Paramètres
string | $m
string | $s
Renvoie
bool

Références AsymmetricKey\$hash, ASN1\asn1map(), ASN1\decodeBER(), RSA\i2osp(), ASN1\loadOIDs(), RSA\os2ip(), PublicKey\rsavp1(), et Strings\shift().

Référencé par PublicKey\verify().

◆ rsassa_pkcs1_v1_5_verify()

rsassa_pkcs1_v1_5_verify | ( | $m,
 |  | $s
 | ) |
private

RSASSA-PKCS1-V1_5-VERIFY

See RFC3447#section-8.2.2.

private

Paramètres
string | $m
string | $s
Exceptions

Références RSA\emsa_pkcs1_v1_5_encode(), RSA\emsa_pkcs1_v1_5_encode_without_null(), RSA\i2osp(), RSA\os2ip(), et PublicKey\rsavp1().

Référencé par PublicKey\verify().

◆ rsassa_pss_verify()

rsassa_pss_verify | ( | $m,
 |  | $s
 | ) |
private

RSASSA-PSS-VERIFY

See RFC3447#section-8.1.2.

private

Paramètres
string | $m
string | $s
Renvoie
bool|string

Références PublicKey\emsa_pss_verify(), RSA\i2osp(), RSA\os2ip(), et PublicKey\rsavp1().

Référencé par PublicKey\verify().

◆ rsavp1()

rsavp1 ( $s )
private

RSAVP1

See RFC3447#section-5.2.2.

private

Paramètres
\phpseclib3\Math\BigInteger $s
Renvoie
bool|

Références PublicKey\exponentiate().

Référencé par PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PublicKey\rsassa_pkcs1_v1_5_verify(), et PublicKey\rsassa_pss_verify().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the public key

The public key is only returned under two circumstances - if the private key had the public key embedded within it or if the public key was set via setPublicKey(). If the currently loaded key is supposed to be the public key this function won't return it since this library, for the most part, doesn't distinguish between public and private keys.

Paramètres
string | $type
array | $options | optional
Renvoie
mixed

Implémente PublicKey.

Références $options, $type, class, et RSA\getSaltLength().

◆ verify()

verify | ( | $message,
 |  | $signature
 | ) |

Verifies a signature

Voir également
self::sign()
Paramètres
string | $message
string | $signature
Renvoie
bool

Implémente PublicKey.

Références $message, PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PublicKey\rsassa_pkcs1_v1_5_verify(), et PublicKey\rsassa_pss_verify().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/RSA/PublicKey.php


Joomla CMS: Référence de la classe AES

  • phpseclib3
  • Crypt
  • AES
Fonctions membres publiques
Référence de la classe AES
+ Graphe d'héritage de AES:
Rijndael BlockCipher SymmetricKey

Fonctions membres publiques

setBlockLength ($length)
setKeyLength ($length)
setKey ($key)
- Fonctions membres publiques hérités de Rijndael
__construct ($mode)
setKeyLength ($length)
setKey ($key)
setBlockLength ($length)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées hérités de Rijndael
isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setup ()
setupKey ()
& getTables ()
& getInvTables ()
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)
- Attributs protégés hérités de Rijndael
$cipher_name_mcrypt = 'rijndael-128'
$key_length = 16
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Documentation des fonctions membres

◆ setBlockLength()

setBlockLength ( $length )

Dummy function

Since extends , this function is, technically, available, but it doesn't do anything.

Voir également
::setBlockLength() public
Paramètres
int $length
Exceptions

◆ setKey()

setKey ( $key )

Sets the key.

Rijndael supports five different key lengths, AES only supports three.

Voir également
:setKey()
setKeyLength() public
Paramètres
string $key
Exceptions

Références SymmetricKey\$key.

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length

Valid key lengths are 128, 192, and 256. Set the link to bool(false) to disable a fixed key length

Voir également
:setKeyLength() public
Paramètres
int $length
Exceptions
La documentation de cette classe a été générée à partir du fichier suivant :
  • AES.php


Joomla CMS: Référence de la classe Blowfish

  • phpseclib3
  • Crypt
  • Blowfish
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés | Attributs privés statiques
Référence de la classe Blowfish
+ Graphe d'héritage de Blowfish:
BlockCipher SymmetricKey

Fonctions membres publiques

__construct ($mode)
setKeyLength ($length)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Fonctions membres protégées

isValidEngineHelper ($engine)
setupKey ()
encryptBlock ($in)
decryptBlock ($in)
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$block_size = 8
$cipher_name_mcrypt = 'blowfish'
$cfb_init_len = 500
$key_length = 16
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Attributs privés

$bctx
$kl

Attributs privés statiques

static | $sbox0
static | $sbox1
static | $sbox2
static | $sbox3
static | $parray

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Paramètres
string $mode public
Exceptions

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

private

Paramètres
string $in
Renvoie
string

Références $i, et $r.

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

private

Paramètres
string $in
Renvoie
string

Références $i, et $r.

Référencé par Blowfish\setupKey().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
::isValidEngine()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine, et SymmetricKey\openssl_translate_mode().

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Key lengths can be between 32 and 448 bits.

public

Paramètres
int $length

◆ setupInlineCrypt()

setupInlineCrypt ( )
protected

Setup the performance-optimized function for de/encrypt()

Voir également
::_setupInlineCrypt() private

Références $i, et SymmetricKey\createInlineCryptFunction().

◆ setupKey()

setupKey ( )
protected

Setup the key (expansion)

Voir également
::_setupKey() private

Références $data, $i, SymmetricKey\$key, $r, et Blowfish\encryptBlock().

Documentation des champs

◆ $bctx

$bctx
private

◆ $block_size

$block_size = 8
protected

◆ $cfb_init_len

$cfb_init_len = 500
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'blowfish'
protected

◆ $key_length

$key_length = 16
protected

The Key Length (in bytes) {

◆ $kl

$kl
private

◆ $parray

$parray
staticprivate
Valeur initiale :
= [
0x243f6a88, 0x85a308d3, 0x13198a2e, 0x03707344, 0xa4093822, 0x299f31d0,
0x082efa98, 0xec4e6c89, 0x452821e6, 0x38d01377, 0xbe5466cf, 0x34e90c6c,
0xc0ac29b7, 0xc97c50dd, 0x3f84d5b5, 0xb5470917, 0x9216d5d9, 0x8979fb1b
]

◆ $sbox0

$sbox0
staticprivate

◆ $sbox1

$sbox1
staticprivate

◆ $sbox2

$sbox2
staticprivate

◆ $sbox3

$sbox3
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • Blowfish.php


Joomla CMS: Référence de la classe ChaCha20

  • phpseclib3
  • Crypt
  • ChaCha20
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Fonctions membres privées
Référence de la classe ChaCha20
+ Graphe d'héritage de ChaCha20:
Salsa20 StreamCipher SymmetricKey

Fonctions membres publiques

encrypt ($plaintext)
decrypt ($ciphertext)
setNonce ($nonce)
- Fonctions membres publiques hérités de Salsa20
usesNonce ()
setKey ($key)
setNonce ($nonce)
setCounter ($counter)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de StreamCipher
__construct ()
usesIV ()
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Fonctions membres protégées

isValidEngineHelper ($engine)
setup ()
- Fonctions membres protégées hérités de Salsa20
createPoly1305Key ()
setup ()
setupKey ()
encryptBlock ($in)
decryptBlock ($in)
poly1305 ($ciphertext)
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Fonctions membres protégées statiques

static | quarterRound (&$a, &$b, &$c, &$d)
static | doubleRound (&$x0, &$x1, &$x2, &$x3, &$x4, &$x5, &$x6, &$x7, &$x8, &$x9, &$x10, &$x11, &$x12, &$x13, &$x14, &$x15)
static | salsa20 ($x)
- Fonctions membres protégées statiques hérités de Salsa20
static | leftRotate ($x, $n)
static | quarterRound (&$a, &$b, &$c, &$d)
static | doubleRound (&$x0, &$x1, &$x2, &$x3, &$x4, &$x5, &$x6, &$x7, &$x8, &$x9, &$x10, &$x11, &$x12, &$x13, &$x14, &$x15)
static | salsa20 ($x)
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Attributs protégés

$cipher_name_openssl = 'chacha20'
- Attributs protégés hérités de Salsa20
$p1 = false
$p2 = false
$key_length = 32
$enbuffer
$debuffer
$counter = 0
$usingGeneratedPoly1305Key = false
- Attributs protégés hérités de StreamCipher
$block_size = 0
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

encrypt_with_libsodium ($plaintext)
decrypt_with_libsodium ($ciphertext)

Membres hérités additionnels

- Champs de données hérités de Salsa20
const | ENCRYPT = 0
const | DECRYPT = 1
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Documentation des fonctions membres

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

$this->decrypt($this->encrypt($plaintext)) == $this->encrypt($this->encrypt($plaintext)). At least if the continuous buffer is disabled.

Voir également
::encrypt()
self::crypt()
Paramètres
string $ciphertext
Renvoie
string $plaintext

Références ChaCha20\decrypt_with_libsodium(), et ChaCha20\setup().

◆ decrypt_with_libsodium()

decrypt_with_libsodium ( $ciphertext )
private

Decrypts a message with libsodium

Voir également
self::decrypt()
Paramètres
string $ciphertext
Renvoie
string $text

Références SymmetricKey\$aad, SymmetricKey\$key, SymmetricKey\$newtag, SymmetricKey\$nonce, $params, et Salsa20\poly1305().

Référencé par ChaCha20\decrypt().

◆ doubleRound()

static doubleRound | ( | & | $x0,
 |  | & | $x1,
 |  | & | $x2,
 |  | & | $x3,
 |  | & | $x4,
 |  | & | $x5,
 |  | & | $x6,
 |  | & | $x7,
 |  | & | $x8,
 |  | & | $x9,
 |  | & | $x10,
 |  | & | $x11,
 |  | & | $x12,
 |  | & | $x13,
 |  | & | $x14,
 |  | & | $x15
 | ) |  |
staticprotected

The doubleround function

Paramètres
int | $x0 | (by reference)
int | $x1 | (by reference)
int | $x2 | (by reference)
int | $x3 | (by reference)
int | $x4 | (by reference)
int | $x5 | (by reference)
int | $x6 | (by reference)
int | $x7 | (by reference)
int | $x8 | (by reference)
int | $x9 | (by reference)
int | $x10 | (by reference)
int | $x11 | (by reference)
int | $x12 | (by reference)
int | $x13 | (by reference)
int | $x14 | (by reference)
int | $x15 | (by reference)

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Voir également
::decrypt()
self::crypt()
Paramètres
string $plaintext
Renvoie
string $ciphertext

Références ChaCha20\encrypt_with_libsodium(), et ChaCha20\setup().

◆ encrypt_with_libsodium()

encrypt_with_libsodium ( $plaintext )
private

Encrypts a message with libsodium

Voir également
self::encrypt()
Paramètres
string $plaintext
Renvoie
string $text

Références SymmetricKey\$aad, SymmetricKey\$key, SymmetricKey\$nonce, $params, et Salsa20\poly1305().

Référencé par ChaCha20\encrypt().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
__construct()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$continuousBuffer, SymmetricKey\$engine, et counter.

◆ quarterRound()

static quarterRound | ( | & | $a,
 |  | & | $b,
 |  | & | $c,
 |  | & | $d
 | ) |  |
staticprotected

The quarterround function

Paramètres
int | $a
int | $b
int | $c
int | $d

Références $b, et $c.

◆ salsa20()

static salsa20 ( $x )
staticprotected

The Salsa20 hash function function

On my laptop this loop unrolled / function dereferenced version of parent::salsa20 encrypts 1mb of text in 0.65s vs the 0.85s that it takes with the parent method.

If we were free to assume that the host OS would always be 64-bits then the if condition in leftRotate could be eliminated and we could knock this done to 0.60s.

For comparison purposes, RC4 takes 0.16s and AES in CTR mode with the Eval engine takes 0.48s. AES in CTR mode with the PHP engine takes 1.19s. Salsa20 / ChaCha20 do not benefit as much from the Eval approach due to the fact that there are a lot less variables to de-reference, fewer loops to unroll, etc

Paramètres
string $x

◆ setNonce()

setNonce ( $nonce )

Sets the nonce.

Paramètres
string $nonce

Références SymmetricKey\$nonce, et SymmetricKey\setEngine().

◆ setup()

setup ( )
protected

Setup the self::ENGINE_INTERNAL $engine

(re)init, if necessary, the internal cipher $engine

_setup() will be called each time if $changed === true typically this happens when using one or more of following public methods:

  • setKey()
  • setNonce()
  • First run of encrypt() / decrypt() with no init-settings
Voir également
self::setKey()
self::setNonce()
self::disableContinuousBuffer()

Références Salsa20\$counter, SymmetricKey\$key, SymmetricKey\$nonce, Salsa20\$p2, et Salsa20\createPoly1305Key().

Référencé par ChaCha20\decrypt(), et ChaCha20\encrypt().

Documentation des champs

◆ $cipher_name_openssl

$cipher_name_openssl = 'chacha20'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/ChaCha20.php


Joomla CMS: Référence de la classe DES

  • phpseclib3
  • Crypt
  • DES
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe DES
+ Graphe d'héritage de DES:
BlockCipher SymmetricKey TripleDES

Fonctions membres publiques

__construct ($mode)
setKey ($key)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Champs de données

const | ENCRYPT = 0
const | DECRYPT = 1
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Fonctions membres protégées

isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$block_size = 8
$key_length = 8
$cipher_name_mcrypt = 'des'
$openssl_mode_names
$cfb_init_len = 500
$des_rounds = 1
$key_length_max = 8
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Attributs protégés statiques

static | $shuffle
static | $ipmap
static | $invipmap
static | $sbox1
static | $sbox2
static | $sbox3
static | $sbox4
static | $sbox5
static | $sbox6
static | $sbox7
static | $sbox8

Fonctions membres privées

processBlock ($block, $mode)

Attributs privés

$keys

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Paramètres
string $mode public
Exceptions
BadModeException if an invalid / unsupported mode is provided

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

Voir également
::decryptBlock()
::decrypt()
self::decrypt() private
Paramètres
string $in
Renvoie
string

Références DES\processBlock().

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

Voir également
::encryptBlock()
::encrypt()
self::encrypt() private
Paramètres
string $in
Renvoie
string

Références DES\processBlock().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
::isValidEngine()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine, et SymmetricKey\openssl_translate_mode().

◆ processBlock()

processBlock | ( | $block,
 |  | $mode
 | ) |
private

Encrypts or decrypts a 64-bit block

$mode should be either self::ENCRYPT or self::DECRYPT. See Feistel.png to get a general idea of what this function does.

Voir également
self::encryptBlock()
self::decryptBlock() private
Paramètres
string | $block
int | $mode
Renvoie
string

Références DES\$des_rounds, $i, DES\$keys, SymmetricKey\$mode, $r, DES\$sbox1, DES\$sbox2, DES\$sbox3, DES\$sbox4, DES\$sbox5, DES\$sbox6, DES\$sbox7, et DES\$sbox8.

Référencé par DES\decryptBlock(), et DES\encryptBlock().

◆ setKey()

setKey ( $key )

Sets the key.

Keys must be 64-bits long or 8 bytes long.

DES also requires that every eighth bit be a parity bit, however, we'll ignore that.

Voir également
::setKey() public
Paramètres
string $key

Références SymmetricKey\$key, et $this.

◆ setupInlineCrypt()

setupInlineCrypt ( )
protected

Setup the performance-optimized function for de/encrypt()

Voir également
::setupInlineCrypt() private

Références $c, DES\$des_rounds, $i, $r, et SymmetricKey\createInlineCryptFunction().

◆ setupKey()

setupKey ( )
protected

Creates the key schedule

Voir également
::setupKey() private

Références $c, DES\$des_rounds, $i, SymmetricKey\$key, DES\$keys, et $r.

Documentation des champs

◆ $block_size

$block_size = 8
protected

◆ $cfb_init_len

$cfb_init_len = 500
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'des'
protected

◆ $des_rounds

$des_rounds = 1
protected

Référencé par DES\processBlock(), DES\setupInlineCrypt(), et DES\setupKey().

◆ $invipmap

$invipmap
staticprotected

◆ $ipmap

$ipmap
staticprotected

◆ $key_length

$key_length = 8
protected

◆ $key_length_max

$key_length_max = 8
protected

◆ $keys

$keys
private

Référencé par DES\processBlock(), et DES\setupKey().

◆ $openssl_mode_names

$openssl_mode_names
protected
Valeur initiale :
= [
self::MODE_ECB => 'des-ecb'

◆ $sbox1

$sbox1
staticprotected
Valeur initiale :
= [
0x00808200, 0x00000000, 0x00008000, 0x00808202,
0x00808002, 0x00008202, 0x00000002, 0x00008000,
0x00000200, 0x00808200, 0x00808202, 0x00000200,
0x00800202, 0x00808002, 0x00800000, 0x00000002,
0x00000202, 0x00800200, 0x00800200, 0x00008200,
0x00008200, 0x00808000, 0x00808000, 0x00800202,
0x00008002, 0x00800002, 0x00800002, 0x00008002,
0x00000000, 0x00000202, 0x00008202, 0x00800000,
0x00008000, 0x00808202, 0x00000002, 0x00808000,
0x00808200, 0x00800000, 0x00800000, 0x00000200,
0x00808002, 0x00008000, 0x00008200, 0x00800002,
0x00000200, 0x00000002, 0x00800202, 0x00008202,
0x00808202, 0x00008002, 0x00808000, 0x00800202,
0x00800002, 0x00000202, 0x00008202, 0x00808200,
0x00000202, 0x00800200, 0x00800200, 0x00000000,
0x00008002, 0x00008200, 0x00000000, 0x00808002
]

Référencé par DES\processBlock().

◆ $sbox2

$sbox2
staticprotected
Valeur initiale :
= [
0x40084010, 0x40004000, 0x00004000, 0x00084010,
0x00080000, 0x00000010, 0x40080010, 0x40004010,
0x40000010, 0x40084010, 0x40084000, 0x40000000,
0x40004000, 0x00080000, 0x00000010, 0x40080010,
0x00084000, 0x00080010, 0x40004010, 0x00000000,
0x40000000, 0x00004000, 0x00084010, 0x40080000,
0x00080010, 0x40000010, 0x00000000, 0x00084000,
0x00004010, 0x40084000, 0x40080000, 0x00004010,
0x00000000, 0x00084010, 0x40080010, 0x00080000,
0x40004010, 0x40080000, 0x40084000, 0x00004000,
0x40080000, 0x40004000, 0x00000010, 0x40084010,
0x00084010, 0x00000010, 0x00004000, 0x40000000,
0x00004010, 0x40084000, 0x00080000, 0x40000010,
0x00080010, 0x40004010, 0x40000010, 0x00080010,
0x00084000, 0x00000000, 0x40004000, 0x00004010,
0x40000000, 0x40080010, 0x40084010, 0x00084000
]

Référencé par DES\processBlock().

◆ $sbox3

$sbox3
staticprotected
Valeur initiale :
= [
0x00000104, 0x04010100, 0x00000000, 0x04010004,
0x04000100, 0x00000000, 0x00010104, 0x04000100,
0x00010004, 0x04000004, 0x04000004, 0x00010000,
0x04010104, 0x00010004, 0x04010000, 0x00000104,
0x04000000, 0x00000004, 0x04010100, 0x00000100,
0x00010100, 0x04010000, 0x04010004, 0x00010104,
0x04000104, 0x00010100, 0x00010000, 0x04000104,
0x00000004, 0x04010104, 0x00000100, 0x04000000,
0x04010100, 0x04000000, 0x00010004, 0x00000104,
0x00010000, 0x04010100, 0x04000100, 0x00000000,
0x00000100, 0x00010004, 0x04010104, 0x04000100,
0x04000004, 0x00000100, 0x00000000, 0x04010004,
0x04000104, 0x00010000, 0x04000000, 0x04010104,
0x00000004, 0x00010104, 0x00010100, 0x04000004,
0x04010000, 0x04000104, 0x00000104, 0x04010000,
0x00010104, 0x00000004, 0x04010004, 0x00010100
]

Référencé par DES\processBlock().

◆ $sbox4

$sbox4
staticprotected
Valeur initiale :
= [
0x80401000, 0x80001040, 0x80001040, 0x00000040,
0x00401040, 0x80400040, 0x80400000, 0x80001000,
0x00000000, 0x00401000, 0x00401000, 0x80401040,
0x80000040, 0x00000000, 0x00400040, 0x80400000,
0x80000000, 0x00001000, 0x00400000, 0x80401000,
0x00000040, 0x00400000, 0x80001000, 0x00001040,
0x80400040, 0x80000000, 0x00001040, 0x00400040,
0x00001000, 0x00401040, 0x80401040, 0x80000040,
0x00400040, 0x80400000, 0x00401000, 0x80401040,
0x80000040, 0x00000000, 0x00000000, 0x00401000,
0x00001040, 0x00400040, 0x80400040, 0x80000000,
0x80401000, 0x80001040, 0x80001040, 0x00000040,
0x80401040, 0x80000040, 0x80000000, 0x00001000,
0x80400000, 0x80001000, 0x00401040, 0x80400040,
0x80001000, 0x00001040, 0x00400000, 0x80401000,
0x00000040, 0x00400000, 0x00001000, 0x00401040
]

Référencé par DES\processBlock().

◆ $sbox5

$sbox5
staticprotected
Valeur initiale :
= [
0x00000080, 0x01040080, 0x01040000, 0x21000080,
0x00040000, 0x00000080, 0x20000000, 0x01040000,
0x20040080, 0x00040000, 0x01000080, 0x20040080,
0x21000080, 0x21040000, 0x00040080, 0x20000000,
0x01000000, 0x20040000, 0x20040000, 0x00000000,
0x20000080, 0x21040080, 0x21040080, 0x01000080,
0x21040000, 0x20000080, 0x00000000, 0x21000000,
0x01040080, 0x01000000, 0x21000000, 0x00040080,
0x00040000, 0x21000080, 0x00000080, 0x01000000,
0x20000000, 0x01040000, 0x21000080, 0x20040080,
0x01000080, 0x20000000, 0x21040000, 0x01040080,
0x20040080, 0x00000080, 0x01000000, 0x21040000,
0x21040080, 0x00040080, 0x21000000, 0x21040080,
0x01040000, 0x00000000, 0x20040000, 0x21000000,
0x00040080, 0x01000080, 0x20000080, 0x00040000,
0x00000000, 0x20040000, 0x01040080, 0x20000080
]

Référencé par DES\processBlock().

◆ $sbox6

$sbox6
staticprotected
Valeur initiale :
= [
0x10000008, 0x10200000, 0x00002000, 0x10202008,
0x10200000, 0x00000008, 0x10202008, 0x00200000,
0x10002000, 0x00202008, 0x00200000, 0x10000008,
0x00200008, 0x10002000, 0x10000000, 0x00002008,
0x00000000, 0x00200008, 0x10002008, 0x00002000,
0x00202000, 0x10002008, 0x00000008, 0x10200008,
0x10200008, 0x00000000, 0x00202008, 0x10202000,
0x00002008, 0x00202000, 0x10202000, 0x10000000,
0x10002000, 0x00000008, 0x10200008, 0x00202000,
0x10202008, 0x00200000, 0x00002008, 0x10000008,
0x00200000, 0x10002000, 0x10000000, 0x00002008,
0x10000008, 0x10202008, 0x00202000, 0x10200000,
0x00202008, 0x10202000, 0x00000000, 0x10200008,
0x00000008, 0x00002000, 0x10200000, 0x00202008,
0x00002000, 0x00200008, 0x10002008, 0x00000000,
0x10202000, 0x10000000, 0x00200008, 0x10002008
]

Référencé par DES\processBlock().

◆ $sbox7

$sbox7
staticprotected
Valeur initiale :
= [
0x00100000, 0x02100001, 0x02000401, 0x00000000,
0x00000400, 0x02000401, 0x00100401, 0x02100400,
0x02100401, 0x00100000, 0x00000000, 0x02000001,
0x00000001, 0x02000000, 0x02100001, 0x00000401,
0x02000400, 0x00100401, 0x00100001, 0x02000400,
0x02000001, 0x02100000, 0x02100400, 0x00100001,
0x02100000, 0x00000400, 0x00000401, 0x02100401,
0x00100400, 0x00000001, 0x02000000, 0x00100400,
0x02000000, 0x00100400, 0x00100000, 0x02000401,
0x02000401, 0x02100001, 0x02100001, 0x00000001,
0x00100001, 0x02000000, 0x02000400, 0x00100000,
0x02100400, 0x00000401, 0x00100401, 0x02100400,
0x00000401, 0x02000001, 0x02100401, 0x02100000,
0x00100400, 0x00000000, 0x00000001, 0x02100401,
0x00000000, 0x00100401, 0x02100000, 0x00000400,
0x02000001, 0x02000400, 0x00000400, 0x00100001
]

Référencé par DES\processBlock().

◆ $sbox8

$sbox8
staticprotected
Valeur initiale :
= [
0x08000820, 0x00000800, 0x00020000, 0x08020820,
0x08000000, 0x08000820, 0x00000020, 0x08000000,
0x00020020, 0x08020000, 0x08020820, 0x00020800,
0x08020800, 0x00020820, 0x00000800, 0x00000020,
0x08020000, 0x08000020, 0x08000800, 0x00000820,
0x00020800, 0x00020020, 0x08020020, 0x08020800,
0x00000820, 0x00000000, 0x00000000, 0x08020020,
0x08000020, 0x08000800, 0x00020820, 0x00020000,
0x00020820, 0x00020000, 0x08020800, 0x00000800,
0x00000020, 0x08020020, 0x00000800, 0x00020820,
0x08000800, 0x00000020, 0x08000020, 0x08020000,
0x08020020, 0x08000000, 0x00020000, 0x08000820,
0x00000000, 0x08020820, 0x00020020, 0x08000020,
0x08020000, 0x08000800, 0x08000820, 0x00000000,
0x08020820, 0x00020800, 0x00020800, 0x00000820,
0x00000820, 0x00020020, 0x08000000, 0x08020800
]

Référencé par DES\processBlock().

◆ $shuffle

$shuffle
staticprotected

◆ DECRYPT

const DECRYPT = 1

Contains $keys[self::DECRYPT]

private

Voir également
::setupKey()
::processBlock()

◆ ENCRYPT

const ENCRYPT = 0

Contains $keys[self::ENCRYPT]

private

Voir également
::setupKey()
::processBlock()
La documentation de cette classe a été générée à partir du fichier suivant :
  • DES.php


Joomla CMS: Référence de la classe DH

  • phpseclib3
  • Crypt
  • DH
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe DH
+ Graphe d'héritage de DH:
AsymmetricKey Parameters PrivateKey PublicKey

Fonctions membres publiques

withHash ($hash)
getHash ()
getParameters ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Fonctions membres publiques statiques

static | createParameters (... $args)
static | createKey (Parameters $params, $length=0)
static | computeSecret ($private, $public)
static | load ($key, $password=false)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()

Champs de données

const ALGORITHM = 'DH'

Fonctions membres protégées statiques

static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)

Attributs protégés

$prime
$base
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Membres hérités additionnels

- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des fonctions membres

◆ computeSecret()

static computeSecret | ( | $private,
 |  | $public
 | ) |
static

Compute Shared Secret

Paramètres
PrivateKey | EC | $private
PublicKey | BigInteger | string | $public | public
Renvoie
mixed

Référencé par SSH2\key_exchange().

◆ createKey()

static createKey | ( | Parameters | $params,
 |  |  | $length = 0
 | ) |  |
static

Create public / private key pair.

The rationale for the second parameter is described in http://tools.ietf.org/html/rfc4419#section-6.2 :

"To increase the speed of the key exchange, both client and server may reduce the size of their private exponents. It should be at least twice as long as the key material that is generated from the shared secret. For more details, see the paper by van Oorschot and Wiener [VAN-OORSCHOT]."

$length is in bits

Paramètres
Parameters | $params
int | $length | optional public
Renvoie
DH

Références $key, AsymmetricKey\$one, $params, et BigInteger\randomRange().

Référencé par SSH2\key_exchange().

◆ createParameters()

static createParameters ( $args )
static

Create DH parameters

This method is a bit polymorphic. It can take any of the following:

  • two BigInteger's (prime and base)
  • an integer representing the size of the prime in bits (the base is assumed to be 2)
  • a string (eg. diffie-hellman-group14-sha1)

public

Renvoie
Parameters

Références $params, DH\$prime, elseif, et BigInteger\randomPrime().

Référencé par SSH2\key_exchange().

◆ getHash()

getHash ( )

Returns the hash algorithm currently being used

public

◆ getParameters()

getParameters ( )

Returns the parameters

A public / private key is only returned if the currently loaded "key" contains an x or y value.

Voir également
self::getPublicKey() public
Renvoie
mixed

Références $key, et $type.

◆ load()

static load | ( | $key,
 |  | $password = false
 | ) |
static

Load the key

Paramètres
string | $key
string | $password | optional
Renvoie
AsymmetricKey

Références $key, $password, et AsymmetricKey\load().

◆ onLoad()

static onLoad ( $components )
staticprotected

OnLoad Handler

Renvoie
bool protected
Paramètres
array $components

◆ withHash()

withHash ( $hash )

Determines which hashing function should be used

public

Paramètres
string $hash

Documentation des champs

◆ $base

$base
protected

Référencé par PKCS1\saveParameters(), PKCS8\savePrivateKey(), et PKCS8\savePublicKey().

◆ $prime

$prime
protected

Référencé par DH\createParameters(), PKCS1\saveParameters(), PKCS8\savePrivateKey(), et PKCS8\savePublicKey().

◆ ALGORITHM

const ALGORITHM = 'DH'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DH.php


Joomla CMS: Référence de la classe DSA

  • phpseclib3
  • Crypt
  • DSA
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés
Référence de la classe DSA
+ Graphe d'héritage de DSA:
AsymmetricKey Parameters PrivateKey PublicKey

Fonctions membres publiques

getLength ()
getEngine ()
getParameters ()
withSignatureFormat ($format)
getSignatureFormat ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Fonctions membres publiques statiques

static | createParameters ($L=2048, $N=224)
static | createKey (... $args)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()

Champs de données

const ALGORITHM = 'DSA'

Fonctions membres protégées

__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)

Fonctions membres protégées statiques

static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)

Attributs protégés

$p
$q
$g
$y
$sigFormat
$shortFormat
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Membres hérités additionnels

- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor

PublicKey and PrivateKey objects can only be created from abstract RSA class

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createKey()

static createKey ( $args )
static

Create public / private key pair.

This method is a bit polymorphic. It can take a DSA/Parameters object, L / N as two distinct parameters or no parameters (at which point L and N will be generated with this method)

Returns the private key, from which the publickey can be extracted

Paramètres
int[] ...$args public
Renvoie
DSA

Références $params, elseif, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), BigInteger\randomRange(), et DSA\withSignatureFormat().

◆ createParameters()

static createParameters | ( | $L = 2048,
 |  | $N = 224
 | ) |
static

Create DSA parameters

public

Paramètres
int | $L
int | $N
Renvoie
|bool

Références $c, DSA\$g, DSA\$p, DSA\$q, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), BigInteger\random(), et BigInteger\randomPrime().

◆ getEngine()

getEngine ( )

Returns the current engine being used

Voir également
self::useInternalEngine()
self::useBestEngine() public
Renvoie
string

◆ getLength()

getLength ( )

Returns the key size

More specifically, this L (the length of DSA Prime P) and N (the length of DSA Group Order q)

public

Renvoie
array

◆ getParameters()

getParameters ( )

Returns the parameters

A public / private key is only returned if the currently loaded "key" contains an x or y value.

Voir également
self::getPublicKey() public
Renvoie
mixed

Références $key, $type, AsymmetricKey\load(), et DSA\withSignatureFormat().

◆ getSignatureFormat()

getSignatureFormat ( )

Returns the signature format currently being used

public

Références DSA\$shortFormat.

◆ onLoad()

static onLoad ( $components )
staticprotected

OnLoad Handler

Renvoie
bool protected
Paramètres
array $components

Références elseif.

◆ withSignatureFormat()

withSignatureFormat ( $format )

Determines the signature padding mode

Valid values are: ASN1, SSH2, Raw

public

Paramètres
string $format

Références AsymmetricKey\$format, et $this.

Référencé par DSA\createKey(), DSA\getParameters(), et PrivateKey\getPublicKey().

Documentation des champs

◆ $g

$g
protected

Référencé par DSA\createParameters(), OpenSSH\load(), PuTTY\load(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), XML\savePublicKey(), et PKCS8\savePublicKey().

◆ $p

$p
protected

Référencé par DSA\createParameters(), OpenSSH\load(), PuTTY\load(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), XML\savePublicKey(), et PKCS8\savePublicKey().

◆ $q

$q
protected

Référencé par DSA\createParameters(), OpenSSH\load(), PuTTY\load(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), XML\savePublicKey(), et PKCS8\savePublicKey().

◆ $shortFormat

$shortFormat
protected

Référencé par DSA\getSignatureFormat().

◆ $sigFormat

$sigFormat
protected

Référencé par PrivateKey\sign(), et PublicKey\verify().

◆ $y

$y
protected

Référencé par OpenSSH\load(), PuTTY\load(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), XML\savePublicKey(), PKCS1\savePublicKey(), et PKCS8\savePublicKey().

◆ ALGORITHM

const ALGORITHM = 'DSA'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSA.php


Joomla CMS: Référence de la classe EC

  • phpseclib3
  • Crypt
  • EC
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs privés
Référence de la classe EC
+ Graphe d'héritage de EC:
AsymmetricKey Parameters PrivateKey PublicKey

Fonctions membres publiques

getCurve ()
getLength ()
getEngine ()
getEncodedCoordinates ()
getParameters ($type='PKCS1')
withSignatureFormat ($format)
getSignatureFormat ()
withContext ($context=null)
getContext ()
withHash ($hash)
__toString ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Fonctions membres publiques statiques

static | createKey ($curve)
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()

Champs de données

const ALGORITHM = 'EC'

Fonctions membres protégées

__construct ()
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)

Fonctions membres protégées statiques

static | onLoad ($components)
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)

Attributs protégés

$QA
$curve
$format
$shortFormat
$q
$x
$context
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Attributs privés

$curveName

Membres hérités additionnels

- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor

PublicKey and PrivateKey objects can only be created from abstract RSA class

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

__toString() magic method

Renvoie
string

Références Joomla\Database\Query\__toString().

◆ createKey()

static createKey ( $curve )
static

Create public / private key pair.

public

Paramètres
string $curve
Renvoie

Références EC\$curve, EC\$curveName, EC\$QA, elseif, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et AsymmetricKey\loadFormat().

Référencé par SSH2\key_exchange().

◆ getContext()

getContext ( )

Returns the signature format currently being used

public

Références EC\$context.

◆ getCurve()

getCurve ( )

Returns the curve

Returns a string if it's a named curve, an array if not

public

Renvoie
string|array

Références EC\$curveName, $params, ASN1\asn1map(), ASN1\decodeBER(), ASN1\extractBER(), EC\getParameters(), ECParameters\MAP, et phpseclib3\Crypt\EC\Formats\Keys\useSpecifiedCurve().

Référencé par PrivateKey\sign().

◆ getEncodedCoordinates()

getEncodedCoordinates ( )

Returns the public key coordinates as a string

Used by ECDH

Renvoie
string

◆ getEngine()

getEngine ( )

Returns the current engine being used

Voir également
self::useInternalEngine()
self::useBestEngine() public
Renvoie
string

◆ getLength()

getLength ( )

Returns the key size

Quoting https://tools.ietf.org/html/rfc5656#section-2,

"The size of a set of elliptic curve domain parameters on a prime curve is defined as the number of bits in the binary representation of the field order, commonly denoted by p. Size on a characteristic-2 curve is defined as the number of bits in the binary representation of the field, commonly denoted by m. A set of elliptic curve domain parameters defines a group of order n generated by a base point P"

public

Renvoie
int

◆ getParameters()

getParameters ( $type = 'PKCS1' )

Returns the parameters

Voir également
self::getPublicKey() public
Paramètres
string $type optional
Renvoie
mixed

Références $key, $type, AsymmetricKey\load(), et EC\withSignatureFormat().

Référencé par EC\getCurve().

◆ getSignatureFormat()

getSignatureFormat ( )

Returns the signature format currently being used

public

Références EC\$shortFormat.

◆ onLoad()

static onLoad ( $components )
staticprotected

OnLoad Handler

Renvoie
bool protected
Paramètres
array $components

◆ withContext()

withContext ( $context = null )

Sets the context

Used by Ed25519 / Ed448.

Voir également
self::sign()
self::verify() public
Paramètres
string $context optional

Références EC\$context, $this, et null.

◆ withHash()

withHash ( $hash )

Determines which hashing function should be used

public

Paramètres
string $hash

Références AsymmetricKey\$hash.

◆ withSignatureFormat()

withSignatureFormat ( $format )

Determines the signature padding mode

Valid values are: ASN1, SSH2, Raw

public

Paramètres
string $format

Références EC\$format, et $this.

Référencé par EC\getParameters(), et PrivateKey\getPublicKey().

Documentation des champs

◆ $context

$context
protected

Référencé par EC\getContext(), PrivateKey\sign(), PublicKey\verify(), et EC\withContext().

◆ $curve

$curve
protected

Référencé par EC\createKey(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), XML\encodeXMLParameters(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), XML\extractPointRFC4050(), OpenSSH\getAlias(), MontgomeryPublic\load(), libsodium\load(), MontgomeryPrivate\load(), OpenSSH\load(), XML\load(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), XML\loadCurveByParam(), XML\loadCurveByParamRFC4050(), SSH2\save(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), libsodium\savePrivateKey(), PKCS1\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS8\savePrivateKey(), libsodium\savePublicKey(), PuTTY\savePublicKey(), OpenSSH\savePublicKey(), PKCS8\savePublicKey(), XML\savePublicKey(), phpseclib3\Crypt\EC\Formats\Keys\setImplicitCurve(), PrivateKey\sign(), et PublicKey\verify().

◆ $curveName

$curveName
private

Référencé par EC\createKey(), EC\getCurve(), et OpenSSH\load().

◆ $format

$format
protected

Référencé par PrivateKey\getPublicKey(), PrivateKey\sign(), PublicKey\verify(), et EC\withSignatureFormat().

◆ $q

$q
protected

Référencé par Binary\addPoint(), Ed448\addPoint(), Ed25519\addPoint(), Prime\addPoint(), Montgomery\doubleAndAddPoint(), KoblitzPrime\extendedGCD(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), et Prime\jacobianAddPointMixedXY().

◆ $QA

$QA
protected

Référencé par EC\createKey(), XML\load(), et PublicKey\verify().

◆ $shortFormat

$shortFormat
protected

Référencé par EC\getSignatureFormat(), PrivateKey\sign(), et PublicKey\verify().

◆ $x

$x
protected

Référencé par Prime\addPoint(), Base\convertInteger(), TwistedEdwards\convertToAffine(), Montgomery\convertToAffine(), Binary\convertToAffine(), Prime\convertToAffine(), Prime\derivePoint(), Prime\doublePoint(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), Ed448\encodePoint(), Ed25519\encodePoint(), XML\encodeXMLParameters(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), XML\extractPointRFC4050(), Prime\jacobianDoublePoint(), Prime\jacobianDoublePointMixed(), XML\loadCurveByParamRFC4050(), Montgomery\multiplyPoint(), Curve25519\rangeCheck(), Curve448\rangeCheck(), Base\rangeCheck(), Ed448\recoverX(), Ed25519\recoverX(), Binary\setBasePoint(), TwistedEdwards\setBasePoint(), Montgomery\setBasePoint(), Prime\setBasePoint(), PrivateKey\sign(), TwistedEdwards\verifyPoint(), KoblitzPrime\verifyPoint(), Binary\verifyPoint(), et Prime\verifyPoint().

◆ ALGORITHM

const ALGORITHM = 'EC'
La documentation de cette classe a été générée à partir du fichier suivant :
  • EC.php


Joomla CMS: Référence de la classe Hash

  • phpseclib3
  • Crypt
  • Hash
Fonctions membres publiques | Champs de données | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe Hash

Fonctions membres publiques

__construct ($hash='sha256')
setKey ($key=false)
setNonce ($nonce=false)
getHash ()
setHash ($hash)
hash ($text)
getLength ()
getLengthInBytes ()
getBlockLength ()
getBlockLengthInBytes ()
__toString ()

Champs de données

const | PADDING_KECCAK = 1
const | PADDING_SHA3 = 2
const | PADDING_SHAKE = 3

Fonctions membres privées

computeKey ()
kdf ($index, $numbytes)
pdf ()
uhash ($m, $taglen)

Fonctions membres privées statiques

static | L1Hash ($k, $m)
static | nh ($k, $m, $length)
static | L2Hash ($k, $m)
static | poly ($wordbits, $maxwordrange, $k, $m)
static | L3Hash ($k1, $k2, $m)
static | sha3_pad ($padLength, $padType)
static | sha3_32 ($p, $c, $r, $d, $padType)
static | processSHA3Block32 (&$s)
static | rotateLeft32 ($x, $shift)
static | sha3_64 ($p, $c, $r, $d, $padType)
static | processSHA3Block64 (&$s)
static | rotateLeft64 ($x, $shift)
static | sha512 ($m, $hash)

Attributs privés

$paddingType = 0
$hashParam
$length
$algo
$key = false
$nonce = false
$parameters = []
$computedKey = false
$opad
$ipad
$recomputeAESKey
$c
$pad

Attributs privés statiques

static | $factory36
static | $factory64
static | $factory128
static | $offset64
static | $offset128
static | $marker64
static | $marker128
static | $maxwordrange64
static | $maxwordrange128

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $hash = 'sha256' )

#- Default Constructor.

Paramètres
string $hash public

Références $hash, et Hash\setHash().

Documentation des fonctions membres

◆ __toString()

__toString ( )

__toString() magic method

Références Hash\getHash().

◆ computeKey()

computeKey ( )
private

Pre-compute the key used by the HMAC

Quoting http://tools.ietf.org/html/rfc2104#section-2, "Applications that use keys longer than B bytes will first hash the key using H and then use the resultant L byte string as the actual key to HMAC."

As documented in https://www.reddit.com/r/PHP/comments/9nct2l/symfonypolyfill_hash_pbkdf2_correct_fix_for/ when doing an HMAC multiple times it's faster to compute the hash once instead of computing it during every call

private

Références Hash\$key, Hash\getBlockLengthInBytes(), et Hash\hash().

Référencé par Hash\setHash(), et Hash\setKey().

◆ getBlockLength()

getBlockLength ( )

Returns the block length (in bits)

public

Renvoie
int

◆ getBlockLengthInBytes()

getBlockLengthInBytes ( )

Returns the block length (in bytes)

public

Renvoie
int

Référencé par Hash\computeKey().

◆ getHash()

getHash ( )

Gets the hash function.

As set by the constructor or by the setHash() method.

public

Renvoie
string

Références Hash\$hashParam.

Référencé par Hash\__toString().

◆ getLength()

getLength ( )

Returns the hash length (in bits)

public

Renvoie
int

◆ getLengthInBytes()

getLengthInBytes ( )

Returns the hash length (in bytes)

public

Renvoie
int

Références Hash\$length.

◆ hash()

hash ( $text )

Compute the Hash / HMAC / UMAC.

public

Paramètres
string $text
Renvoie
string

Références Hash\$algo, $b, Hash\$key, Hash\$maxwordrange128, Hash\$maxwordrange64, $output, Hash\$pad, $temp, $text, Hash\pdf(), et Hash\uhash().

Référencé par Hash\computeKey().

◆ kdf()

kdf | ( | $index,
 |  | $numbytes
 | ) |
private

KDF: Key-Derivation Function

The key-derivation function generates pseudorandom bits used to key the hash functions.

Paramètres
int | $index | a non-negative integer less than 2^64
int | $numbytes | a non-negative integer less than 2^64
Renvoie
string string of length numbytes bytes

Référencé par Hash\pdf(), et Hash\uhash().

◆ L1Hash()

static L1Hash | ( | $k,
 |  | $m
 | ) |
staticprivate

L1-HASH Algorithm

The first-layer hash breaks the message into 1024-byte chunks and hashes each with a function called NH. Concatenating the results forms a string, which is up to 128 times shorter than the original.

Paramètres
string | $k | string of length 1024 bytes.
string | $m | string of length less than 2^67 bits.
Renvoie
string string of length (8 * ceil(bitlength(M)/8192)) bytes.

Références $i, Hash\$length, et Hash\$pad.

◆ L2Hash()

static L2Hash | ( | $k,
 |  | $m
 | ) |
staticprivate

L2-HASH: Second-Layer Hash

The second-layer rehashes the L1-HASH output using a polynomial hash called POLY. If the L1-HASH output is long, then POLY is called once on a prefix of the L1-HASH output and called using different settings on the remainder. (This two-step hashing of the L1-HASH output is needed only if the message length is greater than 16 megabytes.) Careful implementation of POLY is necessary to avoid a possible timing attack (see Section 6.6 for more information).

Paramètres
string | $k | string of length 24 bytes.
string | $m | string of length less than 2^64 bytes.
Renvoie
string string of length 16 bytes.

Références Hash\$length, et Hash\$pad.

◆ L3Hash()

static L3Hash | ( | $k1,
 |  | $k2,
 |  | $m
 | ) |
staticprivate

L3-HASH: Third-Layer Hash

The output from L2-HASH is 16 bytes long. This final hash function hashes the 16-byte string to a fixed length of 4 bytes.

Paramètres
string | $k1 | string of length 64 bytes.
string | $k2 | string of length 4 bytes.
string | $m | string of length 16 bytes.
Renvoie
string string of length 4 bytes.

Références $i.

◆ nh()

static nh | ( | $k,
 |  | $m,
 |  | $length
 | ) |
staticprivate

NH Algorithm

Paramètres
string | $k | string of length 1024 bytes.
string | $m | string with length divisible by 32 bytes.
Renvoie
string string of length 8 bytes.

Références $i, Hash\$length, et $temp.

◆ pdf()

pdf ( )
private

PDF Algorithm

Renvoie
string string of length taglen bytes.

Références Hash\$c, Hash\$key, $last, Hash\$length, Hash\$nonce, et Hash\kdf().

Référencé par Hash\hash().

◆ poly()

static poly | ( | $wordbits,
 |  | $maxwordrange,
 |  | $k,
 |  | $m
 | ) |
staticprivate

POLY Algorithm

Paramètres
int | $wordbits | the integer 64 or 128.
BigInteger | $maxwordrange | positive integer less than 2^wordbits.
BigInteger | $k | integer in the range 0 ... prime(wordbits) - 1.
string | $m | string with length divisible by (wordbits / 8) bytes.
Renvoie
integer in the range 0 ... prime(wordbits) - 1.

Références Joomla\Database\Query\$offset.

◆ processSHA3Block32()

static processSHA3Block32 ( & $s )
staticprivate

32-bit block processing method for SHA3

private

Paramètres
array $s

Références $i, et $temp.

◆ processSHA3Block64()

static processSHA3Block64 ( & $s )
staticprivate

64-bit block processing method for SHA3

private

Paramètres
array $s

Références $i, et $temp.

◆ rotateLeft32()

static rotateLeft32 | ( | $x,
 |  | $shift
 | ) |
staticprivate

Rotate 32-bit int

private

Paramètres
array | $x
int | $shift

◆ rotateLeft64()

static rotateLeft64 | ( | $x,
 |  | $shift
 | ) |
staticprivate

Rotate 64-bit int

private

Paramètres
int | $x
int | $shift

◆ setHash()

setHash ( $hash )

Sets the hash function.

public

Paramètres
string $hash

Références $b, $hash, $i, Hash\$length, Hash\$paddingType, et Hash\computeKey().

Référencé par Hash\__construct().

◆ setKey()

setKey ( $key = false )

Sets the key for HMACs

Keys can be of any length.

public

Paramètres
string $key

Références Hash\$key, et Hash\computeKey().

◆ setNonce()

setNonce ( $nonce = false )

Sets the nonce for UMACs

Keys can be of any length.

public

Paramètres
string $nonce

Références Hash\$nonce.

◆ sha3_32()

static sha3_32 | ( | $p,
 |  | $c,
 |  | $r,
 |  | $d,
 |  | $padType
 | ) |
staticprivate

Pure-PHP 32-bit implementation of SHA3

Whereas BigInteger.php's 32-bit engine works on PHP 64-bit this 32-bit implementation of SHA3 will not work on PHP 64-bit. This is because this implementation employees bitwise NOTs and bitwise left shifts. And the round constants only work on 32-bit PHP. eg. dechex(-2147483648) returns 80000000 on 32-bit PHP and FFFFFFFF80000000 on 64-bit PHP. Sure, we could do bitwise ANDs but that would slow things down.

SHA512 requires BigInteger to simulate 64-bit unsigned integers because SHA2 employees addition whereas SHA3 just employees bitwise operators. PHP64 only supports signed 64-bit integers, which complicates addition, whereas that limitation isn't an issue for SHA3.

In https://ws680.nist.gov/publication/get_pdf.cfm?pub_id=919061#page=16 KECCAK[C] is defined as "the KECCAK instance with KECCAK-f[1600] as the underlying permutation and capacity c". This is relevant because, altho the KECCAK standard defines a mode (KECCAK-f[800]) designed for 32-bit machines that mode is incompatible with SHA3

private

Paramètres
string | $p
int | $c
int | $r
int | $d
int | $padType

Références $i, $n, et $r.

◆ sha3_64()

static sha3_64 | ( | $p,
 |  | $c,
 |  | $r,
 |  | $d,
 |  | $padType
 | ) |
staticprivate

Pure-PHP 64-bit implementation of SHA3

private

Paramètres
string | $p
int | $c
int | $r
int | $d
int | $padType

Références $i, $n, et $r.

◆ sha3_pad()

static sha3_pad | ( | $padLength,
 |  | $padType
 | ) |
staticprivate

Pads SHA3 based on the mode

private

Paramètres
int | $padLength
int | $padType
Renvoie
string

Références $temp.

◆ sha512()

static sha512 | ( | $m,
 |  | $hash
 | ) |
staticprivate

Pure-PHP implementation of SHA512

private

Paramètres
string | $m
array | $hash
Renvoie
string

Références $b, Hash\$c, $g, $hash, $i, Hash\$length, $temp, et Strings\shift().

◆ uhash()

uhash | ( | $m,
 |  | $taglen
 | ) |
private

UHASH Algorithm

Paramètres
string | $m | string of length less than 2^67 bits.
int | $taglen | the integer 4, 8, 12 or 16.
Renvoie
string string of length taglen bytes.

Références $b, Hash\$c, $i, et Hash\kdf().

Référencé par Hash\hash().

Documentation des champs

◆ $algo

$algo
private

Référencé par Hash\hash().

◆ $c

$c
private

Référencé par Hash\pdf(), Hash\sha512(), et Hash\uhash().

◆ $computedKey

$computedKey = false
private

◆ $factory128

$factory128
staticprivate

◆ $factory36

$factory36
staticprivate

◆ $factory64

$factory64
staticprivate

◆ $hashParam

$hashParam
private

Référencé par Hash\getHash().

◆ $ipad

$ipad
private

◆ $key

$key = false
private

Référencé par Hash\computeKey(), Hash\hash(), Hash\pdf(), et Hash\setKey().

◆ $length

$length
private

Référencé par Hash\getLengthInBytes(), Hash\L1Hash(), Hash\L2Hash(), Hash\nh(), Hash\pdf(), Hash\setHash(), et Hash\sha512().

◆ $marker128

$marker128
staticprivate

◆ $marker64

$marker64
staticprivate

◆ $maxwordrange128

$maxwordrange128
staticprivate

Référencé par Hash\hash().

◆ $maxwordrange64

$maxwordrange64
staticprivate

Référencé par Hash\hash().

◆ $nonce

$nonce = false
private

Référencé par Hash\pdf(), et Hash\setNonce().

◆ $offset128

$offset128
staticprivate

◆ $offset64

$offset64
staticprivate

◆ $opad

$opad
private

◆ $pad

$pad
private

Référencé par Hash\hash(), Hash\L1Hash(), et Hash\L2Hash().

◆ $paddingType

$paddingType = 0
private

Référencé par Hash\setHash().

◆ $parameters

$parameters = []
private

◆ $recomputeAESKey

$recomputeAESKey
private

◆ PADDING_KECCAK

const PADDING_KECCAK = 1

Padding Types

private

◆ PADDING_SHA3

const PADDING_SHA3 = 2

Padding Types

private

◆ PADDING_SHAKE

const PADDING_SHAKE = 3

Padding Types

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/Hash.php


Joomla CMS: Référence de la classe PublicKeyLoader

  • phpseclib3
  • Crypt
  • PublicKeyLoader
Fonctions membres publiques statiques
Référence de la classe PublicKeyLoader

Fonctions membres publiques statiques

static | load ($key, $password=false)
static | loadPrivateKey ($key, $password=false)
static | loadPublicKey ($key)
static | loadParameters ($key)

Documentation des fonctions membres

◆ load()

static load | ( | $key,
 |  | $password = false
 | ) |
static

Loads a public or private key

Renvoie
AsymmetricKey public
Paramètres
string | array | $key
string | $password | optional

Références $key, $password, et AsymmetricKey\load().

Référencé par X509\computeKeyIdentifier(), et Agent\requestIdentities().

◆ loadParameters()

static loadParameters ( $key )
static

Loads parameters

Renvoie
AsymmetricKey public
Paramètres
string | array $key

Références $key.

◆ loadPrivateKey()

static loadPrivateKey | ( | $key,
 |  | $password = false
 | ) |
static

Loads a private key

Renvoie
PrivateKey public
Paramètres
string | array | $key
string | $password | optional

Références $key, et $password.

◆ loadPublicKey()

static loadPublicKey ( $key )
static

Loads a public key

Renvoie
PublicKey public
Paramètres
string | array $key

Références $key.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyLoader.php


Joomla CMS: Référence de la classe Random

  • phpseclib3
  • Crypt
  • Random
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Random

Fonctions membres publiques statiques

static string ($length)

Fonctions membres privées statiques

static safe_serialize (&$arr)

Documentation des fonctions membres

◆ safe_serialize()

static safe_serialize ( & $arr )
staticprivate

Safely serialize variables

If a class has a private __sleep() it'll emit a warning

Renvoie
mixed
Paramètres
mixed $arr

Références $key.

◆ string()

static string ( $length )
static

Generate a random string.

Although microoptimizations are generally discouraged as they impair readability this function is ripe with microoptimizations because this function has the potential of being called a huge number of times. eg. for RSA key generation.

Paramètres
int $length
Exceptions

Références $i, $key, $r, et $result.

Référencé par Ed448\createRandomMultiplier(), Ed25519\createRandomMultiplier(), PrivateKey\emsa_pss_encode(), SSH2\key_exchange(), PublicKey\rsaes_oaep_encrypt(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), SSH2\send_binary_packet(), X509\sign(), PKCS1\wrapPrivateKey(), OpenSSH\wrapPrivateKey(), PuTTY\wrapPrivateKey(), et PKCS8\wrapPrivateKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Random.php


Joomla CMS: Référence de la classe RC2

  • phpseclib3
  • Crypt
  • RC2
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés | Attributs privés statiques
Référence de la classe RC2
+ Graphe d'héritage de RC2:
BlockCipher SymmetricKey

Fonctions membres publiques

__construct ($mode)
setKeyLength ($length)
getKeyLength ()
setKey ($key, $t1=false)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Fonctions membres protégées

isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$block_size = 8
$key
$key_length = 16
$cipher_name_mcrypt = 'rc2'
$cfb_init_len = 500
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Attributs privés

$orig_key
$skip_key_adjustment = true
$default_key_length = 1024
$current_key_length
$keys

Attributs privés statiques

static | $pitable
static | $invpitable

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Paramètres
string $mode public
Exceptions

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

Mostly a wrapper for ::decrypt, with some additional OpenSSL handling code

Voir également
self::encrypt() public
Paramètres
string $ciphertext
Renvoie
string $plaintext

Références RC2\$key, RC2\$orig_key, $result, et $temp.

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

Voir également
::decryptBlock()
::decrypt() private
Paramètres
string $in
Renvoie
string

Références $actions, RC2\$keys, et $limit.

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Mostly a wrapper for ::encrypt, with some additional OpenSSL handling code

Voir également
self::decrypt() public
Paramètres
string $plaintext
Renvoie
string $ciphertext

Références RC2\$key, RC2\$orig_key, $result, et $temp.

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

Voir également
::encryptBlock()
::encrypt() private
Paramètres
string $in
Renvoie
string

Références $actions, RC2\$keys, et $limit.

◆ getKeyLength()

getKeyLength ( )

Returns the current key length

public

Renvoie
int

Références RC2\$current_key_length.

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
__construct()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine, et SymmetricKey\openssl_translate_mode().

◆ setKey()

setKey | ( | $key,
 |  | $t1 = false
 | ) |

Sets the key.

Keys can be of any length. RC2, itself, uses 8 to 1024 bit keys (eg. strlen($key) <= 128), however, we only use the first 128 bytes if $key has more then 128 bytes in it, and set $key to a single null byte if it is empty.

Voir également
::setKey() public
Paramètres
string | $key
int | boolean | $t1 | optional Effective key length in bits.
Exceptions

Références RC2\$default_key_length, $i, RC2\$key, RC2\$pitable, et SymmetricKey\setEngine().

Référencé par RC2\setupKey().

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Valid key lengths are 8 to 1024. Calling this function after setting the key has no effect until the next ::setKey() call.

public

Paramètres
int $length in bits
Exceptions

◆ setupInlineCrypt()

setupInlineCrypt ( )
protected

Setup the performance-optimized function for de/encrypt()

Voir également
::setupInlineCrypt() private

Références $actions, RC2\$keys, $limit, et SymmetricKey\createInlineCryptFunction().

◆ setupKey()

setupKey ( )
protected

Creates the key schedule

Voir également
::setupKey() private

Références RC2\setKey().

Documentation des champs

◆ $block_size

$block_size = 8
protected

◆ $cfb_init_len

$cfb_init_len = 500
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'rc2'
protected

◆ $current_key_length

$current_key_length
private

The key length in bits.

{

Référencé par RC2\getKeyLength().

◆ $default_key_length

$default_key_length = 1024
private

The key length in bits.

{

Référencé par RC2\setKey().

◆ $invpitable

$invpitable
staticprivate

◆ $key

$key
protected

Référencé par RC2\decrypt(), RC2\encrypt(), et RC2\setKey().

◆ $key_length

$key_length = 16
protected

◆ $keys

$keys
private

Référencé par RC2\decryptBlock(), RC2\encryptBlock(), et RC2\setupInlineCrypt().

◆ $orig_key

$orig_key
private

Référencé par RC2\decrypt(), et RC2\encrypt().

◆ $pitable

$pitable
staticprivate

Référencé par RC2\setKey().

◆ $skip_key_adjustment

$skip_key_adjustment = true
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • RC2.php


Joomla CMS: Référence de la classe RC4

  • phpseclib3
  • Crypt
  • RC4
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe RC4
+ Graphe d'héritage de RC4:
StreamCipher SymmetricKey

Fonctions membres publiques

setKeyLength ($length)
setKey ($key)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de StreamCipher
__construct ()
usesIV ()
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Champs de données

const | ENCRYPT = 0
const | DECRYPT = 1
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Fonctions membres protégées

isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$key_length = 128
$cipher_name_mcrypt = 'arcfour'
$key
- Attributs protégés hérités de StreamCipher
$block_size = 0
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

crypt ($text, $mode)

Attributs privés

$stream

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des fonctions membres

◆ crypt()

crypt | ( | $text,
 |  | $mode
 | ) |
private

Encrypts or decrypts a message.

Voir également
self::encrypt()
self::decrypt() private
Paramètres
string | $text
int | $mode
Renvoie
string $text

Références $i, SymmetricKey\$mode, RC4\$stream, $text, et SymmetricKey\setup().

Référencé par RC4\decrypt(), et RC4\encrypt().

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

$this->decrypt($this->encrypt($plaintext)) == $this->encrypt($this->encrypt($plaintext)). At least if the continuous buffer is disabled.

Voir également
::encrypt()
self::crypt() public
Paramètres
string $ciphertext
Renvoie
string $plaintext

Références RC4\crypt().

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

private

Paramètres
string $in

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Voir également
::decrypt()
self::crypt() public
Paramètres
string $plaintext
Renvoie
string $ciphertext

Références RC4\crypt().

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

private

Paramètres
string $in

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
__construct()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine.

◆ setKey()

setKey ( $key )

Sets the key length

Keys can be between 1 and 256 bytes long.

public

Paramètres
string $key

Références RC4\$key.

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length

Keys can be between 1 and 256 bytes long.

public

Paramètres
int $length
Exceptions

◆ setupKey()

setupKey ( )
protected

Setup the key (expansion)

Voir également
::_setupKey() private

Références $i, RC4\$key, et $temp.

Documentation des champs

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'arcfour'
protected

◆ $key

$key
protected

Référencé par RC4\setKey(), et RC4\setupKey().

◆ $key_length

$key_length = 128
protected

◆ $stream

$stream
private

Référencé par RC4\crypt().

◆ DECRYPT

const DECRYPT = 1

private

Voir également
::_crypt()

◆ ENCRYPT

const ENCRYPT = 0

private

Voir également
::_crypt()
La documentation de cette classe a été générée à partir du fichier suivant :
  • RC4.php


Joomla CMS: Référence de la classe Rijndael

  • phpseclib3
  • Crypt
  • Rijndael
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Rijndael
+ Graphe d'héritage de Rijndael:
BlockCipher SymmetricKey AES

Fonctions membres publiques

__construct ($mode)
setKeyLength ($length)
setKey ($key)
setBlockLength ($length)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Fonctions membres protégées

isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setup ()
setupKey ()
& getTables ()
& getInvTables ()
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$cipher_name_mcrypt = 'rijndael-128'
$key_length = 16
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

subWord ($word)

Attributs privés

$w
$dw
$Nb = 4
$Nk = 4
$Nr
$c
$kl

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Paramètres
string $mode public
Exceptions

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

Voir également
self::encrypt()
parent::decrypt() public
Paramètres
string $ciphertext
Renvoie
string

Références SymmetricKey\getKeyLength(), et Rijndael\setup().

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

private

Paramètres
string $in
Renvoie
string

Références Rijndael\$c, Rijndael\$dw, $i, Rijndael\$Nb, Rijndael\$Nr, $state, $temp, et Rijndael\getInvTables().

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Voir également
self::decrypt()
parent::encrypt() public
Paramètres
string $plaintext
Renvoie
string

Références SymmetricKey\getKeyLength(), Rijndael\setup(), et Strings\shift().

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

private

Paramètres
string $in
Renvoie
string

Références Rijndael\$c, $i, Rijndael\$Nb, Rijndael\$Nr, $state, $temp, Rijndael\$w, et Rijndael\getTables().

◆ getInvTables()

& getInvTables ( )
protected

Provides the inverse mixColumns and inverse sboxes tables

Voir également
self::decryptBlock()
self::setupInlineCrypt()
self::setupKey() private
Renvoie
array &$tables

Référencé par Rijndael\decryptBlock(), et Rijndael\setupKey().

◆ getTables()

& getTables ( )
protected

Provides the mixColumns and sboxes tables

Voir également
self::encryptBlock()
self::setupInlineCrypt()
self::subWord() private
Renvoie
array &$tables

Référencé par Rijndael\encryptBlock().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
__construct()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine, SymmetricKey\getKeyLength(), et SymmetricKey\openssl_translate_mode().

◆ setBlockLength()

setBlockLength ( $length )

Sets the block length

Valid block lengths are 128, 160, 192, 224, and 256.

public

Paramètres
int $length

Références SymmetricKey\setEngine().

◆ setKey()

setKey ( $key )

Sets the key.

Rijndael supports five different key lengths

Voir également
setKeyLength() public
Paramètres
string $key
Exceptions

Références SymmetricKey\$key.

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Valid key lengths are 128, 160, 192, 224, and 256.

Note: phpseclib extends Rijndael (and AES) for using 160- and 224-bit keys but they are officially not defined and the most (if not all) implementations are not able using 160/224-bit keys but round/pad them up to 192/256 bits as, for example, mcrypt will do.

That said, if you want be compatible with other Rijndael and AES implementations, you should not setKeyLength(160) or setKeyLength(224).

Additional: In case of 160- and 224-bit keys, phpseclib will/can, for that reason, not use the mcrypt php extension, even if available. This results then in slower encryption.

public

Exceptions

◆ setup()

setup ( )
protected

Setup the self::ENGINE_INTERNAL $engine

(re)init, if necessary, the internal cipher $engine and flush all $buffers Used (only) if $engine == self::ENGINE_INTERNAL

_setup() will be called each time if $changed === true typically this happens when using one or more of following public methods:

  • setKey()
  • setIV()
  • disableContinuousBuffer()
  • First run of encrypt() / decrypt() with no init-settings

{

Référencé par Rijndael\decrypt(), et Rijndael\encrypt().

◆ setupInlineCrypt()

setupInlineCrypt ( )
protected

Setup the performance-optimized function for de/encrypt()

Voir également
::setupInlineCrypt() private

Références Rijndael\$c, Rijndael\$dw, $i, Rijndael\$Nb, Rijndael\$Nr, Rijndael\$w, et SymmetricKey\createInlineCryptFunction().

◆ setupKey()

setupKey ( )
protected

Setup the key (expansion)

Voir également
::setupKey() private

Références SymmetricKey\$block_size, Rijndael\$c, Rijndael\$dw, $i, SymmetricKey\$key, Rijndael\$key_length, Rijndael\$Nk, $r, $temp, Rijndael\$w, elseif, Rijndael\getInvTables(), et Rijndael\subWord().

◆ subWord()

subWord ( $word )
private

Performs S-Box substitutions

Renvoie
array private
Paramètres
int $word

Référencé par Rijndael\setupKey().

Documentation des champs

◆ $c

$c
private

Référencé par Rijndael\decryptBlock(), Rijndael\encryptBlock(), Rijndael\setupInlineCrypt(), et Rijndael\setupKey().

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'rijndael-128'
protected

◆ $dw

$dw
private

Référencé par Rijndael\decryptBlock(), Rijndael\setupInlineCrypt(), et Rijndael\setupKey().

◆ $key_length

$key_length = 16
protected

The Key Length (in bytes)

{

Référencé par Rijndael\setupKey().

◆ $kl

$kl
private

◆ $Nb

$Nb = 4
private

The Block Length divided by 32

{

Référencé par Rijndael\decryptBlock(), Rijndael\encryptBlock(), et Rijndael\setupInlineCrypt().

◆ $Nk

$Nk = 4
private

Référencé par Rijndael\setupKey().

◆ $Nr

$Nr
private

The Number of Rounds

{

Référencé par Rijndael\decryptBlock(), Rijndael\encryptBlock(), et Rijndael\setupInlineCrypt().

◆ $w

$w
private

Référencé par Rijndael\encryptBlock(), Rijndael\setupInlineCrypt(), et Rijndael\setupKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Rijndael.php


Joomla CMS: Référence de la classe RSA

  • phpseclib3
  • Crypt
  • RSA
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques | Attributs privés statiques
Référence de la classe RSA
+ Graphe d'héritage de RSA:
AsymmetricKey PrivateKey PublicKey

Fonctions membres publiques

getLength ()
withHash ($hash)
withMGFHash ($hash)
getMGFHash ()
withSaltLength ($sLen)
getSaltLength ()
withLabel ($label)
getLabel ()
withPadding ($padding)
getPadding ()
getEngine ()
- Fonctions membres publiques hérités de AsymmetricKey
toString ($type, array $options=[])
getLoadedFormat ()
getComment ()
__toString ()
withHash ($hash)
getHash ()

Fonctions membres publiques statiques

static | setExponent ($val)
static | setSmallestPrime ($val)
static | setOpenSSLConfigPath ($val)
static | enableBlinding ()
static | disableBlinding ()
- Fonctions membres publiques statiques hérités de AsymmetricKey
static | load ($key, $password=false)
static | loadPrivateKey ($key, $password='')
static | loadPublicKey ($key)
static | loadParameters ($key)
static | loadFormat ($type, $key, $password=false)
static | loadPrivateKeyFormat ($type, $key, $password=false)
static | loadPublicKeyFormat ($type, $key)
static | loadParametersFormat ($type, $key)
static | getSupportedKeyFormats ()
static | addFileFormat ($fullname)
static | useBestEngine ()
static | useInternalEngine ()

Champs de données

const | ALGORITHM = 'RSA'
const | ENCRYPTION_OAEP = 1
const | ENCRYPTION_PKCS1 = 2
const | ENCRYPTION_NONE = 4
const | SIGNATURE_PSS = 16
const | SIGNATURE_RELAXED_PKCS1 = 32
const | SIGNATURE_PKCS1 = 64

Fonctions membres protégées

__construct ()
i2osp ($x, $xLen)
os2ip ($x)
emsa_pkcs1_v1_5_encode ($m, $emLen)
emsa_pkcs1_v1_5_encode_without_null ($m, $emLen)
mgf1 ($mgfSeed, $maskLen)
- Fonctions membres protégées hérités de AsymmetricKey
__construct ()
computek ($h1)
bits2int ($in)

Fonctions membres protégées statiques

static | onLoad ($components)
static | initialize_static_variables ()
- Fonctions membres protégées statiques hérités de AsymmetricKey
static | initialize_static_variables ()
static | validatePlugin ($format, $type, $method=null)

Attributs protégés

$encryptionPadding = self::ENCRYPTION_OAEP
$signaturePadding = self::SIGNATURE_PSS
$hLen
$sLen
$label = ''
$mgfHash
$mgfHLen
$modulus
$k
$exponent
- Attributs protégés hérités de AsymmetricKey
$format
$hash

Attributs protégés statiques

static | $enableBlinding = true
static | $configFile
- Attributs protégés statiques hérités de AsymmetricKey
static | $zero
static | $one
static | $engines = []

Attributs privés statiques

static | $defaultExponent = 65537
static | $smallestPrime = 4096

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
protected

Constructor

PublicKey and PrivateKey objects can only be created from abstract RSA class

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ disableBlinding()

static disableBlinding ( )
static

Disable RSA Blinding

public

◆ emsa_pkcs1_v1_5_encode()

emsa_pkcs1_v1_5_encode | ( | $m,
 |  | $emLen
 | ) |
protected

EMSA-PKCS1-V1_5-ENCODE

See RFC3447#section-9.2.

private

Paramètres
string | $m
int | $emLen
Exceptions

Référencé par PrivateKey\rsassa_pkcs1_v1_5_sign(), et PublicKey\rsassa_pkcs1_v1_5_verify().

◆ emsa_pkcs1_v1_5_encode_without_null()

emsa_pkcs1_v1_5_encode_without_null | ( | $m,
 |  | $emLen
 | ) |
protected

EMSA-PKCS1-V1_5-ENCODE (without NULL)

Quoting https://tools.ietf.org/html/rfc8017#page-65,

"The parameters field associated with id-sha1, id-sha224, id-sha256, id-sha384, id-sha512, id-sha512/224, and id-sha512/256 should generally be omitted, but if present, it shall have a value of type NULL"

private

Paramètres
string | $m
int | $emLen
Renvoie
string

Référencé par PublicKey\rsassa_pkcs1_v1_5_verify().

◆ enableBlinding()

static enableBlinding ( )
static

Enable RSA Blinding

public

◆ getEngine()

getEngine ( )

Returns the current engine being used

OpenSSL is only used in this class (and it's subclasses) for key generation Even then it depends on the parameters you're using. It's not used for multi-prime RSA nor is it used if the key length is outside of the range supported by OpenSSL

Voir également
self::useInternalEngine()
self::useBestEngine() public
Renvoie
string

◆ getLabel()

getLabel ( )

Returns the label currently being used

public

Références RSA\$label.

◆ getLength()

getLength ( )

Returns the key size

More specifically, this returns the size of the modulo in bits.

public

Renvoie
int

◆ getMGFHash()

getMGFHash ( )

Returns the MGF hash algorithm currently being used

public

Références RSA\$mgfHash.

◆ getPadding()

getPadding ( )

Returns the padding currently being used

public

Références RSA\$encryptionPadding.

◆ getSaltLength()

getSaltLength ( )

Returns the salt length currently being used

public

Références RSA\$hLen, et null.

Référencé par PublicKey\toString(), et PrivateKey\toString().

◆ i2osp()

i2osp | ( | $x,
 |  | $xLen
 | ) |
protected

Integer-to-Octet-String primitive

See RFC3447#section-4.1.

private

Paramètres
bool | \phpseclib3\Math\BigInteger | $x
int | $xLen
Renvoie
bool|string

Référencé par PrivateKey\raw_encrypt(), PublicKey\raw_encrypt(), PrivateKey\rsaes_oaep_decrypt(), PublicKey\rsaes_oaep_encrypt(), PrivateKey\rsaes_pkcs1_v1_5_decrypt(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PrivateKey\rsassa_pkcs1_v1_5_sign(), PublicKey\rsassa_pkcs1_v1_5_verify(), PrivateKey\rsassa_pss_sign(), et PublicKey\rsassa_pss_verify().

◆ initialize_static_variables()

static initialize_static_variables ( )
staticprotected

Initialize static variables

Références phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ mgf1()

mgf1 | ( | $mgfSeed,
 |  | $maskLen
 | ) |
protected

MGF1

See RFC3447#appendix-B.2.1.

private

Paramètres
string | $mgfSeed
int | $maskLen
Renvoie
string

Références $c, $count, et $i.

Référencé par PrivateKey\emsa_pss_encode(), PublicKey\emsa_pss_verify(), PrivateKey\rsaes_oaep_decrypt(), et PublicKey\rsaes_oaep_encrypt().

◆ onLoad()

static onLoad ( $components )
staticprotected

OnLoad Handler

Renvoie
bool protected
Paramètres
array $components

Références $key, et class.

◆ os2ip()

os2ip ( $x )
protected

Octet-String-to-Integer primitive

See RFC3447#section-4.2.

private

Paramètres
string $x
Renvoie

Référencé par PrivateKey\raw_encrypt(), PublicKey\raw_encrypt(), PrivateKey\rsaes_oaep_decrypt(), PublicKey\rsaes_oaep_encrypt(), PrivateKey\rsaes_pkcs1_v1_5_decrypt(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), PublicKey\rsassa_pkcs1_v1_5_relaxed_verify(), PrivateKey\rsassa_pkcs1_v1_5_sign(), PublicKey\rsassa_pkcs1_v1_5_verify(), PrivateKey\rsassa_pss_sign(), et PublicKey\rsassa_pss_verify().

◆ setExponent()

static setExponent ( $val )
static

Sets the public exponent for key generation

This will be 65537 unless changed.

public

Paramètres
int $val

Références $val.

◆ setOpenSSLConfigPath()

static setOpenSSLConfigPath ( $val )
static

Sets the OpenSSL config file path

Set to the empty string to use the default config file

public

Paramètres
string $val

Références $val.

◆ setSmallestPrime()

static setSmallestPrime ( $val )
static

Sets the smallest prime number in bits. Used for key generation

This will be 4096 unless changed.

public

Paramètres
int $val

Références $val.

◆ withHash()

withHash ( $hash )

Determines which hashing function should be used

Used with signature production / verification and (if the encryption mode is self::PADDING_OAEP) encryption and decryption.

public

Paramètres
string $hash

Références AsymmetricKey\$hash, et $this.

◆ withLabel()

withLabel ( $label )

Determines the label

Used by RSA::PADDING_OAEP

To quote from RFC3447#page-17:

Both the encryption and the decryption operations of RSAES-OAEP take the value of a label L as input. In this version of PKCS #1, L is the empty string; other uses of the label are outside the scope of this document.

public

Paramètres
string $label

Références RSA\$label, et $this.

◆ withMGFHash()

withMGFHash ( $hash )

Determines which hashing function should be used for the mask generation function

The mask generation function is used by self::PADDING_OAEP and self::PADDING_PSS and although it's best if Hash and MGFHash are set to the same thing this is not a requirement.

public

Paramètres
string $hash

Références AsymmetricKey\$hash, et $this.

Référencé par PublicKey\asPrivateKey(), et PrivateKey\getPublicKey().

◆ withPadding()

withPadding ( $padding )

Determines the padding modes

Example: $key->withPadding(RSA::ENCRYPTION_PKCS1 | RSA::SIGNATURE_PKCS1);

public

Paramètres
int $padding

Références RSA\$encryptionPadding, $selected, RSA\$signaturePadding, et $this.

◆ withSaltLength()

withSaltLength ( $sLen )

Determines the salt length

Used by RSA::PADDING_PSS

To quote from RFC3447#page-38:

Typical salt lengths in octets are hLen (the length of the output of the hash function Hash) and 0.

public

Paramètres
int $sLen

Références RSA\$sLen, et $this.

Référencé par PublicKey\asPrivateKey(), et PrivateKey\getPublicKey().

Documentation des champs

◆ $configFile

$configFile
staticprotected

◆ $defaultExponent

$defaultExponent = 65537
staticprivate

◆ $enableBlinding

$enableBlinding = true
staticprotected

◆ $encryptionPadding

$encryptionPadding = self::ENCRYPTION_OAEP
protected

Référencé par RSA\getPadding(), et RSA\withPadding().

◆ $exponent

$exponent
protected

Référencé par PublicKey\asPrivateKey().

◆ $hLen

$hLen
protected

Référencé par PrivateKey\emsa_pss_encode(), PublicKey\emsa_pss_verify(), et RSA\getSaltLength().

◆ $k

$k
protected

Référencé par PublicKey\asPrivateKey().

◆ $label

$label = ''
protected

Référencé par RSA\getLabel(), et RSA\withLabel().

◆ $mgfHash

$mgfHash
protected

Référencé par RSA\getMGFHash().

◆ $mgfHLen

$mgfHLen
protected

◆ $modulus

$modulus
protected

Référencé par PublicKey\asPrivateKey(), OpenSSH\load(), et PuTTY\load().

◆ $signaturePadding

$signaturePadding = self::SIGNATURE_PSS
protected

Référencé par RSA\withPadding().

◆ $sLen

$sLen
protected

Référencé par PrivateKey\emsa_pss_encode(), PublicKey\emsa_pss_verify(), et RSA\withSaltLength().

◆ $smallestPrime

$smallestPrime = 4096
staticprivate

◆ ALGORITHM

const ALGORITHM = 'RSA'

◆ ENCRYPTION_NONE

const ENCRYPTION_NONE = 4

Do not use any padding

Although this method is not recommended it can none-the-less sometimes be useful if you're trying to decrypt some legacy stuff, if you're trying to diagnose why an encrypted message isn't decrypting, etc.

public

Voir également
self::encrypt()
self::decrypt()

◆ ENCRYPTION_OAEP

const ENCRYPTION_OAEP = 1

Use Optimal Asymmetric Encryption Padding (OAEP) for encryption / decryption.

Uses sha256 by default

Voir également
self::setHash()
self::setMGFHash() public
self::encrypt()
self::decrypt()

◆ ENCRYPTION_PKCS1

const ENCRYPTION_PKCS1 = 2

Use PKCS#1 padding.

Although self::PADDING_OAEP / self::PADDING_PSS offers more security, including PKCS#1 padding is necessary for purposes of backwards compatibility with protocols (like SSH-1) written before OAEP's introduction.

public

Voir également
self::encrypt()
self::decrypt()

◆ SIGNATURE_PKCS1

const SIGNATURE_PKCS1 = 64

Use PKCS#1 padding for signature verification

Voir également
self::sign()
self::verify()
self::setHash() public

Référencé par X509\getPublicKey(), SSH2\getServerPublicHostKey(), SSH2\privatekey_login(), X509\validateSignatureHelper(), et Identity\withPadding().

◆ SIGNATURE_PSS

const SIGNATURE_PSS = 16

Use the Probabilistic Signature Scheme for signing

Uses sha256 and 0 as the salt length

Voir également
self::setSaltLength()
self::setMGFHash()
self::setHash()
self::sign()
self::verify()
self::setHash() public

Référencé par X509\formatSubjectPublicKey(), et X509\identifySignatureAlgorithm().

◆ SIGNATURE_RELAXED_PKCS1

const SIGNATURE_RELAXED_PKCS1 = 32

Use a relaxed version of PKCS#1 padding for signature verification

Voir également
self::sign()
self::verify()
self::setHash() public

Référencé par Identity\withPadding().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/RSA.php


Joomla CMS: Référence de la classe Salsa20

  • phpseclib3
  • Crypt
  • Salsa20
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Fonctions membres privées
Référence de la classe Salsa20
+ Graphe d'héritage de Salsa20:
StreamCipher SymmetricKey ChaCha20

Fonctions membres publiques

usesNonce ()
setKey ($key)
setNonce ($nonce)
setCounter ($counter)
encrypt ($plaintext)
decrypt ($ciphertext)
- Fonctions membres publiques hérités de StreamCipher
__construct ()
usesIV ()
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Champs de données

const | ENCRYPT = 0
const | DECRYPT = 1
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Fonctions membres protégées

createPoly1305Key ()
setup ()
setupKey ()
encryptBlock ($in)
decryptBlock ($in)
poly1305 ($ciphertext)
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Fonctions membres protégées statiques

static | leftRotate ($x, $n)
static | quarterRound (&$a, &$b, &$c, &$d)
static | doubleRound (&$x0, &$x1, &$x2, &$x3, &$x4, &$x5, &$x6, &$x7, &$x8, &$x9, &$x10, &$x11, &$x12, &$x13, &$x14, &$x15)
static | salsa20 ($x)
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Attributs protégés

$p1 = false
$p2 = false
$key_length = 32
$enbuffer
$debuffer
$counter = 0
$usingGeneratedPoly1305Key = false
- Attributs protégés hérités de StreamCipher
$block_size = 0
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

crypt ($text, $mode)

Documentation des fonctions membres

◆ createPoly1305Key()

createPoly1305Key ( )
protected

Creates a Poly1305 key using the method discussed in RFC8439

See https://tools.ietf.org/html/rfc8439#section-2.6.1

Références $c, $this, counter, et SymmetricKey\setPoly1305Key().

Référencé par Salsa20\setup(), et ChaCha20\setup().

◆ crypt()

crypt | ( | $text,
 |  | $mode
 | ) |
private

Encrypts or decrypts a message.

Voir également
self::encrypt()
self::decrypt()
Paramètres
string | $text
int | $mode
Renvoie
string $text

Références $buffer, Salsa20\$counter, Salsa20\$debuffer, Salsa20\$enbuffer, $i, SymmetricKey\$iv, SymmetricKey\$mode, Salsa20\$p2, $temp, $text, counter, elseif, Strings\pop(), Salsa20\setup(), et Strings\shift().

Référencé par Salsa20\decrypt(), et Salsa20\encrypt().

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

$this->decrypt($this->encrypt($plaintext)) == $this->encrypt($this->encrypt($plaintext)). At least if the continuous buffer is disabled.

Voir également
::encrypt()
self::crypt()
Paramètres
string $ciphertext
Renvoie
string $plaintext

Références SymmetricKey\$newtag, Salsa20\crypt(), et Salsa20\poly1305().

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

Paramètres
string $in

◆ doubleRound()

static doubleRound | ( | & | $x0,
 |  | & | $x1,
 |  | & | $x2,
 |  | & | $x3,
 |  | & | $x4,
 |  | & | $x5,
 |  | & | $x6,
 |  | & | $x7,
 |  | & | $x8,
 |  | & | $x9,
 |  | & | $x10,
 |  | & | $x11,
 |  | & | $x12,
 |  | & | $x13,
 |  | & | $x14,
 |  | & | $x15
 | ) |  |
staticprotected

The doubleround function

Paramètres
int | $x0 | (by reference)
int | $x1 | (by reference)
int | $x2 | (by reference)
int | $x3 | (by reference)
int | $x4 | (by reference)
int | $x5 | (by reference)
int | $x6 | (by reference)
int | $x7 | (by reference)
int | $x8 | (by reference)
int | $x9 | (by reference)
int | $x10 | (by reference)
int | $x11 | (by reference)
int | $x12 | (by reference)
int | $x13 | (by reference)
int | $x14 | (by reference)
int | $x15 | (by reference)

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Voir également
::decrypt()
self::crypt()
Paramètres
string $plaintext
Renvoie
string $ciphertext

Références Salsa20\crypt(), et Salsa20\poly1305().

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

Paramètres
string $in

◆ leftRotate()

static leftRotate | ( | $x,
 |  | $n
 | ) |
staticprotected

Left Rotate

Paramètres
int | $x
int | $n
Renvoie
int

Références $n.

◆ poly1305()

poly1305 ( $ciphertext )
protected

Calculates Poly1305 MAC

Voir également
self::decrypt()
self::encrypt() private
Paramètres
string $ciphertext
Renvoie
string

Référencé par Salsa20\decrypt(), ChaCha20\decrypt_with_libsodium(), Salsa20\encrypt(), et ChaCha20\encrypt_with_libsodium().

◆ quarterRound()

static quarterRound | ( | & | $a,
 |  | & | $b,
 |  | & | $c,
 |  | & | $d
 | ) |  |
staticprotected

The quarterround function

Paramètres
int | $a
int | $b
int | $c
int | $d

Références $b, et $c.

◆ salsa20()

static salsa20 ( $x )
staticprotected

The Salsa20 hash function function

Paramètres
string $x

Références $i.

◆ setCounter()

setCounter ( $counter )

Sets the counter.

Paramètres
int $counter

Références Salsa20\$counter, counter, et SymmetricKey\setEngine().

◆ setKey()

setKey ( $key )

Sets the key.

Paramètres
string $key
Exceptions

Références SymmetricKey\$key.

◆ setNonce()

setNonce ( $nonce )

Sets the nonce.

Paramètres
string $nonce

Références SymmetricKey\$key, SymmetricKey\$nonce, et SymmetricKey\setEngine().

◆ setup()

setup ( )
protected

Setup the self::ENGINE_INTERNAL $engine

(re)init, if necessary, the internal cipher $engine

_setup() will be called each time if $changed === true typically this happens when using one or more of following public methods:

  • setKey()
  • setNonce()
  • First run of encrypt() / decrypt() with no init-settings
Voir également
self::setKey()
self::setNonce()
self::disableContinuousBuffer()

Références Salsa20\$counter, SymmetricKey\$key, et Salsa20\createPoly1305Key().

Référencé par Salsa20\crypt().

◆ setupKey()

setupKey ( )
protected

Setup the key (expansion)

◆ usesNonce()

usesNonce ( )

Salsa20 uses a nonce

Renvoie
bool

Documentation des champs

◆ $counter

$counter = 0
protected

Référencé par Salsa20\crypt(), Salsa20\setCounter(), Salsa20\setup(), et ChaCha20\setup().

◆ $debuffer

$debuffer
protected

Référencé par Salsa20\crypt().

◆ $enbuffer

$enbuffer
protected

Référencé par Salsa20\crypt().

◆ $key_length

$key_length = 32
protected

◆ $p1

$p1 = false
protected

◆ $p2

$p2 = false
protected

Référencé par Salsa20\crypt(), et ChaCha20\setup().

◆ $usingGeneratedPoly1305Key

$usingGeneratedPoly1305Key = false
protected

◆ DECRYPT

const DECRYPT = 1

private

Voir également
::crypt()

◆ ENCRYPT

const ENCRYPT = 0

private

Voir également
::crypt()
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Crypt/Salsa20.php


Joomla CMS: Référence de la classe TripleDES

  • phpseclib3
  • Crypt
  • TripleDES
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe TripleDES
+ Graphe d'héritage de TripleDES:
DES BlockCipher SymmetricKey

Fonctions membres publiques

__construct ($mode)
setIV ($iv)
setKeyLength ($length)
setKey ($key)
encrypt ($plaintext)
decrypt ($ciphertext)
enableContinuousBuffer ()
disableContinuousBuffer ()
setPreferredEngine ($engine)
- Fonctions membres publiques hérités de DES
__construct ($mode)
setKey ($key)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Champs de données

const | MODE_3CBC = -2
const | MODE_CBC3 = self::MODE_CBC
- Champs de données hérités de DES
const | ENCRYPT = 0
const | DECRYPT = 1
- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP

Fonctions membres protégées

isValidEngineHelper ($engine)
setupKey ()
- Fonctions membres protégées hérités de DES
isValidEngineHelper ($engine)
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$key_length = 24
$cipher_name_mcrypt = 'tripledes'
$cfb_init_len = 750
$key_length_max = 24
- Attributs protégés hérités de DES
$block_size = 8
$key_length = 8
$cipher_name_mcrypt = 'des'
$openssl_mode_names
$cfb_init_len = 500
$des_rounds = 1
$key_length_max = 8
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Attributs privés

$mode_3cbc
$des

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)
- Attributs protégés statiques hérités de DES
static | $shuffle
static | $ipmap
static | $invipmap
static | $sbox1
static | $sbox2
static | $sbox3
static | $sbox4
static | $sbox5
static | $sbox6
static | $sbox7
static | $sbox8

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Determines whether or not the mcrypt or OpenSSL extensions should be used.

$mode could be:

  • ecb
  • cbc
  • ctr
  • cfb
  • ofb
  • 3cbc
  • cbc3 (same as cbc)
Voir également
__construct()
__construct()
Paramètres
string $mode public

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decrypt()

decrypt ( $ciphertext )

Decrypts a message.

Voir également
::decrypt() public
Paramètres
string $ciphertext
Renvoie
string $plaintext

Références TripleDES\encrypt(), et SymmetricKey\unpad().

Référencé par TripleDES\encrypt().

◆ disableContinuousBuffer()

disableContinuousBuffer ( )

Treat consecutive packets as if they are a discontinuous buffer.

The default behavior.

Voir également
::disableContinuousBuffer()
self::enableContinuousBuffer() public

◆ enableContinuousBuffer()

enableContinuousBuffer ( )

Treat consecutive "packets" as if they are a continuous buffer.

Say you have a 16-byte plaintext $plaintext. Using the default behavior, the two following code snippets will yield different outputs:

echo $des->encrypt(substr($plaintext, 0, 8)); echo $des->encrypt(substr($plaintext, 8, 8)); echo $des->encrypt($plaintext);

The solution is to enable the continuous buffer. Although this will resolve the above discrepancy, it creates another, as demonstrated with the following:

$des->encrypt(substr($plaintext, 0, 8)); echo $des->decrypt($des->encrypt(substr($plaintext, 8, 8))); echo $des->decrypt($des->encrypt(substr($plaintext, 8, 8)));

With the continuous buffer disabled, these would yield the same output. With it enabled, they yield different outputs. The reason is due to the fact that the initialization vector's change after every encryption / decryption round when the continuous buffer is enabled. When it's disabled, they remain constant.

Put another way, when the continuous buffer is enabled, the state of the () object changes after each encryption / decryption round, whereas otherwise, it'd remain constant. For this reason, it's recommended that continuous buffers not be used. They do offer better security and are, in fact, sometimes required (SSH uses them), however, they are also less intuitive and more likely to cause you problems.

Voir également
::enableContinuousBuffer()
self::disableContinuousBuffer() public

◆ encrypt()

encrypt ( $plaintext )

Encrypts a message.

Voir également
::encrypt() public
Paramètres
string $plaintext
Renvoie
string $cipertext

Références TripleDES\decrypt(), et SymmetricKey\pad().

Référencé par TripleDES\decrypt().

◆ isValidEngineHelper()

isValidEngineHelper ( $engine )
protected

Test for engine validity

This is mainly just a wrapper to set things up for ::isValidEngine()

Voir également
__construct()
Paramètres
int $engine protected
Renvoie
bool

Références SymmetricKey\$engine, SymmetricKey\$mode, et SymmetricKey\openssl_translate_mode().

◆ setIV()

setIV ( $iv )

Sets the initialization vector.

SetIV is not required when ::MODE_ECB is being used.

Voir également
::setIV() public
Paramètres
string $iv

Références SymmetricKey\$iv.

◆ setKey()

setKey ( $key )

Sets the key.

Triple DES can use 128-bit (eg. strlen($key) == 16) or 192-bit (eg. strlen($key) == 24) keys.

DES also requires that every eighth bit be a parity bit, however, we'll ignore that.

public

Voir également
::setKey()
::setKey()
Exceptions

Références SymmetricKey\$key, et SymmetricKey\setEngine().

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Valid key lengths are 128 and 192 bits.

If you want to use a 64-bit key use DES.php

Voir également
:setKeyLength() public
Exceptions

◆ setPreferredEngine()

setPreferredEngine ( $engine )

Sets the internal crypt engine

Voir également
__construct()
::setPreferredEngine()
Paramètres
int $engine public

Références SymmetricKey\$engine.

◆ setupKey()

setupKey ( )
protected

Creates the key schedule

Voir également
::setupKey()
::setupKey() private

Documentation des champs

◆ $cfb_init_len

$cfb_init_len = 750
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'tripledes'
protected

◆ $des

$des
private

◆ $key_length

$key_length = 24
protected

◆ $key_length_max

$key_length_max = 24
protected

◆ $mode_3cbc

$mode_3cbc
private

◆ MODE_3CBC

const MODE_3CBC = -2

Encrypt / decrypt using inner chaining

Inner chaining is used by SSH-1 and is generally considered to be less secure then outer chaining (self::MODE_CBC3).

◆ MODE_CBC3

const MODE_CBC3 = self::MODE_CBC

Encrypt / decrypt using outer chaining

Outer chaining is used by SSH-2 and when the mode is set to ::MODE_CBC.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TripleDES.php


Joomla CMS: Référence de la classe Twofish

  • phpseclib3
  • Crypt
  • Twofish
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe Twofish
+ Graphe d'héritage de Twofish:
BlockCipher SymmetricKey

Fonctions membres publiques

__construct ($mode)
setKeyLength ($length)
setKey ($key)
- Fonctions membres publiques hérités de SymmetricKey
__construct ($mode)
setIV ($iv)
enablePoly1305 ()
setPoly1305Key ($key=null)
setNonce ($nonce)
setAAD ($aad)
usesIV ()
usesNonce ()
getKeyLength ()
getBlockLength ()
getBlockLengthInBytes ()
setKeyLength ($length)
setKey ($key)
setPassword ($password, $method='pbkdf2',... $func_args)
encrypt ($plaintext)
decrypt ($ciphertext)
getTag ($length=16)
setTag ($tag)
enablePadding ()
disablePadding ()
enableContinuousBuffer ()
disableContinuousBuffer ()
isValidEngine ($engine)
setPreferredEngine ($engine)
getEngine ()
getMode ()

Fonctions membres protégées

setupKey ()
encryptBlock ($in)
decryptBlock ($in)
setupInlineCrypt ()
- Fonctions membres protégées hérités de SymmetricKey
getIV ($iv)
openssl_translate_mode ()
isValidEngineHelper ($engine)
setEngine ()
encryptBlock ($in)
decryptBlock ($in)
setupKey ()
setup ()
pad ($text)
unpad ($text)
createInlineCryptFunction ($cipher_code)
poly1305 ($text)

Attributs protégés

$cipher_name_mcrypt = 'twofish'
$cfb_init_len = 800
$key_length = 16
- Attributs protégés hérités de SymmetricKey
$mode
$block_size = 16
$key = false
$iv = false
$encryptIV
$decryptIV
$continuousBuffer = false
$enbuffer
$debuffer
$cfb_init_len = 600
$changed = true
$nonIVChanged = true
$engine
$cipher_name_mcrypt
$cipher_name_openssl
$cipher_name_openssl_ecb
$inline_crypt
$explicit_key_length = false
$aad = ''
$newtag = false
$oldtag = false
$poly1305Key
$usePoly1305 = false
$nonce = false

Fonctions membres privées

mdsrem ($A, $B)

Attributs privés

$K = []
$S0 = []
$S1 = []
$S2 = []
$S3 = []
$kl

Attributs privés statiques

static | $q0
static | $q1
static | $m0
static | $m1
static | $m2
static | $m3

Membres hérités additionnels

- Champs de données hérités de SymmetricKey
const | MODE_CTR = -1
const | MODE_ECB = 1
const | MODE_CBC = 2
const | MODE_CFB = 3
const | MODE_CFB8 = 7
const | MODE_OFB8 = 8
const | MODE_OFB = 4
const | MODE_GCM = 5
const | MODE_STREAM = 6
const | MODE_MAP
const const | ENGINE_INTERNAL = 1
const | ENGINE_EVAL = 2
const | ENGINE_MCRYPT = 3
const | ENGINE_OPENSSL = 4
const | ENGINE_LIBSODIUM = 5
const | ENGINE_OPENSSL_GCM = 6
const | ENGINE_MAP
- Fonctions membres protégées statiques hérités de SymmetricKey
static | safe_intval ($x)
static | safe_intval_inline ()
static | nullPad128 ($str)

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $mode )

Default Constructor.

Paramètres
string $mode public
Exceptions
BadModeException if an invalid / unsupported mode is provided

Références SymmetricKey\$mode, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ decryptBlock()

decryptBlock ( $in )
protected

Decrypts a block

private

Paramètres
string $in
Renvoie
string

Références Twofish\$K, Twofish\$S0, Twofish\$S1, Twofish\$S2, et Twofish\$S3.

◆ encryptBlock()

encryptBlock ( $in )
protected

Encrypts a block

private

Paramètres
string $in
Renvoie
string

Références Twofish\$K, Twofish\$S0, Twofish\$S1, Twofish\$S2, et Twofish\$S3.

◆ mdsrem()

mdsrem | ( | $A,
 |  | $B
 | ) |
private

_mdsrem function using by the twofish cipher algorithm

private

Paramètres
string | $A
string | $B
Renvoie
array

Références $i.

Référencé par Twofish\setupKey().

◆ setKey()

setKey ( $key )

Sets the key.

Rijndael supports five different key lengths

Voir également
setKeyLength() public
Paramètres
string $key
Exceptions

Références SymmetricKey\$key.

◆ setKeyLength()

setKeyLength ( $length )

Sets the key length.

Valid key lengths are 128, 192 or 256 bits

public

Paramètres
int $length

◆ setupInlineCrypt()

setupInlineCrypt ( )
protected

Setup the performance-optimized function for de/encrypt()

Voir également
::_setupInlineCrypt() private

Références $i, Twofish\$K, et SymmetricKey\createInlineCryptFunction().

◆ setupKey()

setupKey ( )
protected

Setup the key (expansion)

Voir également
::_setupKey() private

Références $i, Twofish\$K, SymmetricKey\$key, Twofish\$m0, Twofish\$m1, Twofish\$m2, Twofish\$m3, Twofish\$q0, Twofish\$q1, Twofish\$S0, Twofish\$S1, Twofish\$S2, Twofish\$S3, et Twofish\mdsrem().

Documentation des champs

◆ $cfb_init_len

$cfb_init_len = 800
protected

◆ $cipher_name_mcrypt

$cipher_name_mcrypt = 'twofish'
protected

◆ $K

$K = []
private

Référencé par Twofish\decryptBlock(), Twofish\encryptBlock(), Twofish\setupInlineCrypt(), et Twofish\setupKey().

◆ $key_length

$key_length = 16
protected

◆ $kl

$kl
private

◆ $m0

$m0
staticprivate

Référencé par Twofish\setupKey().

◆ $m1

$m1
staticprivate

Référencé par Twofish\setupKey().

◆ $m2

$m2
staticprivate

Référencé par Twofish\setupKey().

◆ $m3

$m3
staticprivate

Référencé par Twofish\setupKey().

◆ $q0

$q0
staticprivate

Référencé par Twofish\setupKey().

◆ $q1

$q1
staticprivate

Référencé par Twofish\setupKey().

◆ $S0

$S0 = []
private

Référencé par Twofish\decryptBlock(), Twofish\encryptBlock(), et Twofish\setupKey().

◆ $S1

$S1 = []
private

Référencé par Twofish\decryptBlock(), Twofish\encryptBlock(), et Twofish\setupKey().

◆ $S2

$S2 = []
private

Référencé par Twofish\decryptBlock(), Twofish\encryptBlock(), et Twofish\setupKey().

◆ $S3

$S3 = []
private

Référencé par Twofish\decryptBlock(), Twofish\encryptBlock(), et Twofish\setupKey().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Twofish.php


Joomla CMS: Référence de la classe BadConfigurationException

  • phpseclib3
  • Exception
  • BadConfigurationException
Référence de la classe BadConfigurationException
+ Graphe d'héritage de BadConfigurationException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • BadConfigurationException.php


Joomla CMS: Référence de la classe BadDecryptionException

  • phpseclib3
  • Exception
  • BadDecryptionException
Référence de la classe BadDecryptionException
+ Graphe d'héritage de BadDecryptionException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • BadDecryptionException.php


Joomla CMS: Référence de la classe BadModeException

  • phpseclib3
  • Exception
  • BadModeException
Référence de la classe BadModeException
+ Graphe d'héritage de BadModeException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • BadModeException.php


Joomla CMS: Référence de la classe ConnectionClosedException

  • phpseclib3
  • Exception
  • ConnectionClosedException
Référence de la classe ConnectionClosedException
+ Graphe d'héritage de ConnectionClosedException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionClosedException.php


Joomla CMS: Référence de la classe FileNotFoundException

  • phpseclib3
  • Exception
  • FileNotFoundException
Référence de la classe FileNotFoundException
+ Graphe d'héritage de FileNotFoundException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/phpseclib/phpseclib/phpseclib/Exception/FileNotFoundException.php


Joomla CMS: Référence de la classe InconsistentSetupException

  • phpseclib3
  • Exception
  • InconsistentSetupException
Référence de la classe InconsistentSetupException
+ Graphe d'héritage de InconsistentSetupException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • InconsistentSetupException.php


Joomla CMS: Référence de la classe InsufficientSetupException

  • phpseclib3
  • Exception
  • InsufficientSetupException
Référence de la classe InsufficientSetupException
+ Graphe d'héritage de InsufficientSetupException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • InsufficientSetupException.php


Joomla CMS: Référence de la classe NoKeyLoadedException

  • phpseclib3
  • Exception
  • NoKeyLoadedException
Référence de la classe NoKeyLoadedException
+ Graphe d'héritage de NoKeyLoadedException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoKeyLoadedException.php


Joomla CMS: Référence de la classe NoSupportedAlgorithmsException

  • phpseclib3
  • Exception
  • NoSupportedAlgorithmsException
Référence de la classe NoSupportedAlgorithmsException
+ Graphe d'héritage de NoSupportedAlgorithmsException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoSupportedAlgorithmsException.php


Joomla CMS: Référence de la classe UnableToConnectException

  • phpseclib3
  • Exception
  • UnableToConnectException
Référence de la classe UnableToConnectException
+ Graphe d'héritage de UnableToConnectException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnableToConnectException.php


Joomla CMS: Référence de la classe UnsupportedAlgorithmException

  • phpseclib3
  • Exception
  • UnsupportedAlgorithmException
Référence de la classe UnsupportedAlgorithmException
+ Graphe d'héritage de UnsupportedAlgorithmException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedAlgorithmException.php


Joomla CMS: Référence de la classe UnsupportedCurveException

  • phpseclib3
  • Exception
  • UnsupportedCurveException
Référence de la classe UnsupportedCurveException
+ Graphe d'héritage de UnsupportedCurveException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedCurveException.php


Joomla CMS: Référence de la classe UnsupportedFormatException

  • phpseclib3
  • Exception
  • UnsupportedFormatException
Référence de la classe UnsupportedFormatException
+ Graphe d'héritage de UnsupportedFormatException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • UnsupportedFormatException.php


Joomla CMS: Référence de la classe UnsupportedOperationException

  • phpseclib3
  • Exception
  • UnsupportedOperationException
Référence de la classe UnsupportedOperationException
+ Graphe d'héritage de UnsupportedOperationException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Exception/UnsupportedOperationException.php


Joomla CMS: Référence de la classe AccessDescription

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AccessDescription
Champs de données
Référence de la classe AccessDescription

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • AccessDescription.php


Joomla CMS: Référence de la classe AdministrationDomainName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AdministrationDomainName
Champs de données
Référence de la classe AdministrationDomainName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • AdministrationDomainName.php


Joomla CMS: Référence de la classe AlgorithmIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AlgorithmIdentifier
Champs de données
Référence de la classe AlgorithmIdentifier

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AlgorithmIdentifier.php


Joomla CMS: Référence de la classe AnotherName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AnotherName
Champs de données
Référence de la classe AnotherName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • AnotherName.php


Joomla CMS: Référence de la classe Attribute

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Attribute
Champs de données
Référence de la classe Attribute

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attribute.php


Joomla CMS: Référence de la classe Attributes

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Attributes
Champs de données
Référence de la classe Attributes

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SET
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attributes.php


Joomla CMS: Référence de la classe AttributeType

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AttributeType
Champs de données
Référence de la classe AttributeType

Champs de données

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttributeType.php


Joomla CMS: Référence de la classe AttributeTypeAndValue

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AttributeTypeAndValue
Champs de données
Référence de la classe AttributeTypeAndValue

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AttributeTypeAndValue.php


Joomla CMS: Référence de la classe AttributeValue

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AttributeValue
Champs de données
Référence de la classe AttributeValue

Champs de données

const MAP = ['type' => ASN1::TYPE_ANY]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_ANY]
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttributeValue.php


Joomla CMS: Référence de la classe AuthorityInfoAccessSyntax

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AuthorityInfoAccessSyntax
Champs de données
Référence de la classe AuthorityInfoAccessSyntax

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthorityInfoAccessSyntax.php


Joomla CMS: Référence de la classe AuthorityKeyIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • AuthorityKeyIdentifier
Champs de données
Référence de la classe AuthorityKeyIdentifier

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthorityKeyIdentifier.php


Joomla CMS: Référence de la classe BaseDistance

  • phpseclib3
  • File
  • ASN1
  • Maps
  • BaseDistance
Champs de données
Référence de la classe BaseDistance

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • BaseDistance.php


Joomla CMS: Référence de la classe BasicConstraints

  • phpseclib3
  • File
  • ASN1
  • Maps
  • BasicConstraints
Champs de données
Référence de la classe BasicConstraints

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • BasicConstraints.php


Joomla CMS: Référence de la classe BuiltInDomainDefinedAttribute

  • phpseclib3
  • File
  • ASN1
  • Maps
  • BuiltInDomainDefinedAttribute
Champs de données
Référence de la classe BuiltInDomainDefinedAttribute

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • BuiltInDomainDefinedAttribute.php


Joomla CMS: Référence de la classe BuiltInDomainDefinedAttributes

  • phpseclib3
  • File
  • ASN1
  • Maps
  • BuiltInDomainDefinedAttributes
Champs de données
Référence de la classe BuiltInDomainDefinedAttributes

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • BuiltInDomainDefinedAttributes.php


Joomla CMS: Référence de la classe BuiltInStandardAttributes

  • phpseclib3
  • File
  • ASN1
  • Maps
  • BuiltInStandardAttributes
Champs de données
Référence de la classe BuiltInStandardAttributes

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • BuiltInStandardAttributes.php


Joomla CMS: Référence de la classe Certificate

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Certificate
Champs de données
Référence de la classe Certificate

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Certificate.php


Joomla CMS: Référence de la classe CertificateIssuer

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificateIssuer
Champs de données
Référence de la classe CertificateIssuer

Champs de données

const MAP = GeneralNames::MAP

Documentation des champs

◆ MAP

const MAP = GeneralNames::MAP
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateIssuer.php


Joomla CMS: Référence de la classe CertificateList

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificateList
Champs de données
Référence de la classe CertificateList

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateList.php


Joomla CMS: Référence de la classe CertificatePolicies

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificatePolicies
Champs de données
Référence de la classe CertificatePolicies

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificatePolicies.php


Joomla CMS: Référence de la classe CertificateSerialNumber

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificateSerialNumber
Champs de données
Référence de la classe CertificateSerialNumber

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateSerialNumber.php


Joomla CMS: Référence de la classe CertificationRequest

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificationRequest
Champs de données
Référence de la classe CertificationRequest

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificationRequest.php


Joomla CMS: Référence de la classe CertificationRequestInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertificationRequestInfo
Champs de données
Référence de la classe CertificationRequestInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificationRequestInfo.php


Joomla CMS: Référence de la classe CertPolicyId

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CertPolicyId
Champs de données
Référence de la classe CertPolicyId

Champs de données

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertPolicyId.php


Joomla CMS: Référence de la classe Characteristic_two

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Characteristic_two
Champs de données
Référence de la classe Characteristic_two

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Characteristic_two.php


Joomla CMS: Référence de la classe CountryName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CountryName
Champs de données
Référence de la classe CountryName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CountryName.php


Joomla CMS: Référence de la classe CPSuri

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CPSuri
Champs de données
Référence de la classe CPSuri

Champs de données

const MAP = ['type' => ASN1::TYPE_IA5_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_IA5_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • CPSuri.php


Joomla CMS: Référence de la classe CRLDistributionPoints

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CRLDistributionPoints
Champs de données
Référence de la classe CRLDistributionPoints

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • CRLDistributionPoints.php


Joomla CMS: Référence de la classe CRLNumber

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CRLNumber
Champs de données
Référence de la classe CRLNumber

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • CRLNumber.php


Joomla CMS: Référence de la classe CRLReason

  • phpseclib3
  • File
  • ASN1
  • Maps
  • CRLReason
Champs de données
Référence de la classe CRLReason

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_ENUMERATED
La documentation de cette classe a été générée à partir du fichier suivant :
  • CRLReason.php


Joomla CMS: Référence de la classe Curve

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Curve
Champs de données
Référence de la classe Curve

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Curve.php


Joomla CMS: Référence de la classe DHParameter

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DHParameter
Champs de données
Référence de la classe DHParameter

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DHParameter.php


Joomla CMS: Référence de la classe DigestInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DigestInfo
Champs de données
Référence de la classe DigestInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DigestInfo.php


Joomla CMS: Référence de la classe DirectoryString

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DirectoryString
Champs de données
Référence de la classe DirectoryString

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DirectoryString.php


Joomla CMS: Référence de la classe DisplayText

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DisplayText
Champs de données
Référence de la classe DisplayText

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DisplayText.php


Joomla CMS: Référence de la classe DistributionPoint

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DistributionPoint
Champs de données
Référence de la classe DistributionPoint

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DistributionPoint.php


Joomla CMS: Référence de la classe DistributionPointName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DistributionPointName
Champs de données
Référence de la classe DistributionPointName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DistributionPointName.php


Joomla CMS: Référence de la classe DSAParams

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DSAParams
Champs de données
Référence de la classe DSAParams

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSAParams.php


Joomla CMS: Référence de la classe DSAPrivateKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DSAPrivateKey
Champs de données
Référence de la classe DSAPrivateKey

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSAPrivateKey.php


Joomla CMS: Référence de la classe DSAPublicKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DSAPublicKey
Champs de données
Référence de la classe DSAPublicKey

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • DSAPublicKey.php


Joomla CMS: Référence de la classe DssSigValue

  • phpseclib3
  • File
  • ASN1
  • Maps
  • DssSigValue
Champs de données
Référence de la classe DssSigValue

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • DssSigValue.php


Joomla CMS: Référence de la classe EcdsaSigValue

  • phpseclib3
  • File
  • ASN1
  • Maps
  • EcdsaSigValue
Champs de données
Référence de la classe EcdsaSigValue

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • EcdsaSigValue.php


Joomla CMS: Référence de la classe ECParameters

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ECParameters
Champs de données
Référence de la classe ECParameters

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE

Référencé par phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), EC\getCurve(), PKCS1\load(), et PKCS8\load().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ECParameters.php


Joomla CMS: Référence de la classe ECPoint

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ECPoint
Champs de données
Référence de la classe ECPoint

Champs de données

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • ECPoint.php


Joomla CMS: Référence de la classe ECPrivateKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ECPrivateKey
Champs de données
Référence de la classe ECPrivateKey

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • ECPrivateKey.php


Joomla CMS: Référence de la classe EDIPartyName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • EDIPartyName
Champs de données
Référence de la classe EDIPartyName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • EDIPartyName.php


Joomla CMS: Référence de la classe EncryptedData

  • phpseclib3
  • File
  • ASN1
  • Maps
  • EncryptedData
Champs de données
Référence de la classe EncryptedData

Champs de données

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • EncryptedData.php


Joomla CMS: Référence de la classe EncryptedPrivateKeyInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • EncryptedPrivateKeyInfo
Champs de données
Référence de la classe EncryptedPrivateKeyInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • EncryptedPrivateKeyInfo.php


Joomla CMS: Référence de la classe Extension

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Extension
Champs de données
Référence de la classe Extension

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Extension.php


Joomla CMS: Référence de la classe ExtensionAttribute

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ExtensionAttribute
Champs de données
Référence de la classe ExtensionAttribute

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionAttribute.php


Joomla CMS: Référence de la classe ExtensionAttributes

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ExtensionAttributes
Champs de données
Référence de la classe ExtensionAttributes

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SET
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionAttributes.php


Joomla CMS: Référence de la classe Extensions

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Extensions
Champs de données
Référence de la classe Extensions

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Extensions.php


Joomla CMS: Référence de la classe ExtKeyUsageSyntax

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ExtKeyUsageSyntax
Champs de données
Référence de la classe ExtKeyUsageSyntax

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtKeyUsageSyntax.php


Joomla CMS: Référence de la classe FieldElement

  • phpseclib3
  • File
  • ASN1
  • Maps
  • FieldElement
Champs de données
Référence de la classe FieldElement

Champs de données

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldElement.php


Joomla CMS: Référence de la classe FieldID

  • phpseclib3
  • File
  • ASN1
  • Maps
  • FieldID
Champs de données
Référence de la classe FieldID

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • FieldID.php


Joomla CMS: Référence de la classe GeneralName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • GeneralName
Champs de données
Référence de la classe GeneralName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralName.php


Joomla CMS: Référence de la classe GeneralNames

  • phpseclib3
  • File
  • ASN1
  • Maps
  • GeneralNames
Champs de données
Référence de la classe GeneralNames

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralNames.php


Joomla CMS: Référence de la classe GeneralSubtree

  • phpseclib3
  • File
  • ASN1
  • Maps
  • GeneralSubtree
Champs de données
Référence de la classe GeneralSubtree

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralSubtree.php


Joomla CMS: Référence de la classe GeneralSubtrees

  • phpseclib3
  • File
  • ASN1
  • Maps
  • GeneralSubtrees
Champs de données
Référence de la classe GeneralSubtrees

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • GeneralSubtrees.php


Joomla CMS: Référence de la classe HashAlgorithm

  • phpseclib3
  • File
  • ASN1
  • Maps
  • HashAlgorithm
Champs de données
Référence de la classe HashAlgorithm

Champs de données

const MAP = AlgorithmIdentifier::MAP

Documentation des champs

◆ MAP

const MAP = AlgorithmIdentifier::MAP
La documentation de cette classe a été générée à partir du fichier suivant :
  • HashAlgorithm.php


Joomla CMS: Référence de la classe HoldInstructionCode

  • phpseclib3
  • File
  • ASN1
  • Maps
  • HoldInstructionCode
Champs de données
Référence de la classe HoldInstructionCode

Champs de données

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • HoldInstructionCode.php


Joomla CMS: Référence de la classe InvalidityDate

  • phpseclib3
  • File
  • ASN1
  • Maps
  • InvalidityDate
Champs de données
Référence de la classe InvalidityDate

Champs de données

const MAP = ['type' => ASN1::TYPE_GENERALIZED_TIME]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_GENERALIZED_TIME]
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidityDate.php


Joomla CMS: Référence de la classe IssuerAltName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • IssuerAltName
Champs de données
Référence de la classe IssuerAltName

Champs de données

const MAP = GeneralNames::MAP

Documentation des champs

◆ MAP

const MAP = GeneralNames::MAP
La documentation de cette classe a été générée à partir du fichier suivant :
  • IssuerAltName.php


Joomla CMS: Référence de la classe IssuingDistributionPoint

  • phpseclib3
  • File
  • ASN1
  • Maps
  • IssuingDistributionPoint
Champs de données
Référence de la classe IssuingDistributionPoint

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • IssuingDistributionPoint.php


Joomla CMS: Référence de la classe KeyIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • KeyIdentifier
Champs de données
Référence de la classe KeyIdentifier

Champs de données

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyIdentifier.php


Joomla CMS: Référence de la classe KeyPurposeId

  • phpseclib3
  • File
  • ASN1
  • Maps
  • KeyPurposeId
Champs de données
Référence de la classe KeyPurposeId

Champs de données

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyPurposeId.php


Joomla CMS: Référence de la classe KeyUsage

  • phpseclib3
  • File
  • ASN1
  • Maps
  • KeyUsage
Champs de données
Référence de la classe KeyUsage

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_BIT_STRING
La documentation de cette classe a été générée à partir du fichier suivant :
  • KeyUsage.php


Joomla CMS: Référence de la classe MaskGenAlgorithm

  • phpseclib3
  • File
  • ASN1
  • Maps
  • MaskGenAlgorithm
Champs de données
Référence de la classe MaskGenAlgorithm

Champs de données

const MAP = AlgorithmIdentifier::MAP

Documentation des champs

◆ MAP

const MAP = AlgorithmIdentifier::MAP
La documentation de cette classe a été générée à partir du fichier suivant :
  • MaskGenAlgorithm.php


Joomla CMS: Référence de la classe Name

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Name
Champs de données
Référence de la classe Name

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Name.php


Joomla CMS: Référence de la classe NameConstraints

  • phpseclib3
  • File
  • ASN1
  • Maps
  • NameConstraints
Champs de données
Référence de la classe NameConstraints

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • NameConstraints.php


Joomla CMS: Référence de la classe netscape_ca_policy_url

  • phpseclib3
  • File
  • ASN1
  • Maps
  • netscape_ca_policy_url
Champs de données
Référence de la classe netscape_ca_policy_url

Champs de données

const MAP = ['type' => ASN1::TYPE_IA5_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_IA5_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • netscape_ca_policy_url.php


Joomla CMS: Référence de la classe netscape_cert_type

  • phpseclib3
  • File
  • ASN1
  • Maps
  • netscape_cert_type
Champs de données
Référence de la classe netscape_cert_type

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_BIT_STRING
La documentation de cette classe a été générée à partir du fichier suivant :
  • netscape_cert_type.php


Joomla CMS: Référence de la classe netscape_comment

  • phpseclib3
  • File
  • ASN1
  • Maps
  • netscape_comment
Champs de données
Référence de la classe netscape_comment

Champs de données

const MAP = ['type' => ASN1::TYPE_IA5_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_IA5_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • netscape_comment.php


Joomla CMS: Référence de la classe NetworkAddress

  • phpseclib3
  • File
  • ASN1
  • Maps
  • NetworkAddress
Champs de données
Référence de la classe NetworkAddress

Champs de données

const MAP = ['type' => ASN1::TYPE_NUMERIC_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_NUMERIC_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • NetworkAddress.php


Joomla CMS: Référence de la classe NoticeReference

  • phpseclib3
  • File
  • ASN1
  • Maps
  • NoticeReference
Champs de données
Référence de la classe NoticeReference

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoticeReference.php


Joomla CMS: Référence de la classe NumericUserIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • NumericUserIdentifier
Champs de données
Référence de la classe NumericUserIdentifier

Champs de données

const MAP = ['type' => ASN1::TYPE_NUMERIC_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_NUMERIC_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • NumericUserIdentifier.php


Joomla CMS: Référence de la classe OneAsymmetricKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • OneAsymmetricKey
Champs de données
Référence de la classe OneAsymmetricKey

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • OneAsymmetricKey.php


Joomla CMS: Référence de la classe ORAddress

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ORAddress
Champs de données
Référence de la classe ORAddress

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • ORAddress.php


Joomla CMS: Référence de la classe OrganizationalUnitNames

  • phpseclib3
  • File
  • ASN1
  • Maps
  • OrganizationalUnitNames
Champs de données
Référence de la classe OrganizationalUnitNames

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • OrganizationalUnitNames.php


Joomla CMS: Référence de la classe OrganizationName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • OrganizationName
Champs de données
Référence de la classe OrganizationName

Champs de données

const MAP = ['type' => ASN1::TYPE_PRINTABLE_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_PRINTABLE_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • OrganizationName.php


Joomla CMS: Référence de la classe OtherPrimeInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • OtherPrimeInfo
Champs de données
Référence de la classe OtherPrimeInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • OtherPrimeInfo.php


Joomla CMS: Référence de la classe OtherPrimeInfos

  • phpseclib3
  • File
  • ASN1
  • Maps
  • OtherPrimeInfos
Champs de données
Référence de la classe OtherPrimeInfos

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • OtherPrimeInfos.php


Joomla CMS: Référence de la classe PBEParameter

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PBEParameter
Champs de données
Référence de la classe PBEParameter

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PBEParameter.php


Joomla CMS: Référence de la classe PBES2params

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PBES2params
Champs de données
Référence de la classe PBES2params

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PBES2params.php


Joomla CMS: Référence de la classe PBKDF2params

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PBKDF2params
Champs de données
Référence de la classe PBKDF2params

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PBKDF2params.php


Joomla CMS: Référence de la classe PBMAC1params

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PBMAC1params
Champs de données
Référence de la classe PBMAC1params

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PBMAC1params.php


Joomla CMS: Référence de la classe Pentanomial

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Pentanomial
Champs de données
Référence de la classe Pentanomial

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Pentanomial.php


Joomla CMS: Référence de la classe PersonalName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PersonalName
Champs de données
Référence de la classe PersonalName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SET
La documentation de cette classe a été générée à partir du fichier suivant :
  • PersonalName.php


Joomla CMS: Référence de la classe PKCS9String

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PKCS9String
Champs de données
Référence de la classe PKCS9String

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PKCS9String.php


Joomla CMS: Référence de la classe PolicyInformation

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PolicyInformation
Champs de données
Référence de la classe PolicyInformation

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PolicyInformation.php


Joomla CMS: Référence de la classe PolicyMappings

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PolicyMappings
Champs de données
Référence de la classe PolicyMappings

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PolicyMappings.php


Joomla CMS: Référence de la classe PolicyQualifierId

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PolicyQualifierId
Champs de données
Référence de la classe PolicyQualifierId

Champs de données

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OBJECT_IDENTIFIER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • PolicyQualifierId.php


Joomla CMS: Référence de la classe PolicyQualifierInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PolicyQualifierInfo
Champs de données
Référence de la classe PolicyQualifierInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PolicyQualifierInfo.php


Joomla CMS: Référence de la classe PostalAddress

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PostalAddress
Champs de données
Référence de la classe PostalAddress

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PostalAddress.php


Joomla CMS: Référence de la classe Prime_p

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Prime_p
Champs de données
Référence de la classe Prime_p

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • Prime_p.php


Joomla CMS: Référence de la classe PrivateDomainName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PrivateDomainName
Champs de données
Référence de la classe PrivateDomainName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivateDomainName.php


Joomla CMS: Référence de la classe PrivateKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PrivateKey
Champs de données
Référence de la classe PrivateKey

Champs de données

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_OCTET_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PrivateKey.php


Joomla CMS: Référence de la classe PrivateKeyInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PrivateKeyInfo
Champs de données
Référence de la classe PrivateKeyInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivateKeyInfo.php


Joomla CMS: Référence de la classe PrivateKeyUsagePeriod

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PrivateKeyUsagePeriod
Champs de données
Référence de la classe PrivateKeyUsagePeriod

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrivateKeyUsagePeriod.php


Joomla CMS: Référence de la classe PublicKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PublicKey
Champs de données
Référence de la classe PublicKey

Champs de données

const MAP = ['type' => ASN1::TYPE_BIT_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_BIT_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PublicKey.php


Joomla CMS: Référence de la classe PublicKeyAndChallenge

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PublicKeyAndChallenge
Champs de données
Référence de la classe PublicKeyAndChallenge

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyAndChallenge.php


Joomla CMS: Référence de la classe PublicKeyInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • PublicKeyInfo
Champs de données
Référence de la classe PublicKeyInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyInfo.php


Joomla CMS: Référence de la classe RC2CBCParameter

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RC2CBCParameter
Champs de données
Référence de la classe RC2CBCParameter

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RC2CBCParameter.php


Joomla CMS: Référence de la classe RDNSequence

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RDNSequence
Champs de données
Référence de la classe RDNSequence

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RDNSequence.php


Joomla CMS: Référence de la classe ReasonFlags

  • phpseclib3
  • File
  • ASN1
  • Maps
  • ReasonFlags
Champs de données
Référence de la classe ReasonFlags

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_BIT_STRING
La documentation de cette classe a été générée à partir du fichier suivant :
  • ReasonFlags.php


Joomla CMS: Référence de la classe RelativeDistinguishedName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RelativeDistinguishedName
Champs de données
Référence de la classe RelativeDistinguishedName

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SET
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/File/ASN1/Maps/RelativeDistinguishedName.php


Joomla CMS: Référence de la classe RevokedCertificate

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RevokedCertificate
Champs de données
Référence de la classe RevokedCertificate

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RevokedCertificate.php


Joomla CMS: Référence de la classe RSAPrivateKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RSAPrivateKey
Champs de données
Référence de la classe RSAPrivateKey

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSAPrivateKey.php


Joomla CMS: Référence de la classe RSAPublicKey

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RSAPublicKey
Champs de données
Référence de la classe RSAPublicKey

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSAPublicKey.php


Joomla CMS: Référence de la classe RSASSA_PSS_params

  • phpseclib3
  • File
  • ASN1
  • Maps
  • RSASSA_PSS_params
Champs de données
Référence de la classe RSASSA_PSS_params

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • RSASSA_PSS_params.php


Joomla CMS: Référence de la classe SignedPublicKeyAndChallenge

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SignedPublicKeyAndChallenge
Champs de données
Référence de la classe SignedPublicKeyAndChallenge

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • SignedPublicKeyAndChallenge.php


Joomla CMS: Référence de la classe SpecifiedECDomain

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SpecifiedECDomain
Champs de données
Référence de la classe SpecifiedECDomain

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • SpecifiedECDomain.php


Joomla CMS: Référence de la classe SubjectAltName

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SubjectAltName
Champs de données
Référence de la classe SubjectAltName

Champs de données

const MAP = GeneralNames::MAP

Documentation des champs

◆ MAP

const MAP = GeneralNames::MAP
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubjectAltName.php


Joomla CMS: Référence de la classe SubjectDirectoryAttributes

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SubjectDirectoryAttributes
Champs de données
Référence de la classe SubjectDirectoryAttributes

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubjectDirectoryAttributes.php


Joomla CMS: Référence de la classe SubjectInfoAccessSyntax

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SubjectInfoAccessSyntax
Champs de données
Référence de la classe SubjectInfoAccessSyntax

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubjectInfoAccessSyntax.php


Joomla CMS: Référence de la classe SubjectPublicKeyInfo

  • phpseclib3
  • File
  • ASN1
  • Maps
  • SubjectPublicKeyInfo
Champs de données
Référence de la classe SubjectPublicKeyInfo

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubjectPublicKeyInfo.php


Joomla CMS: Référence de la classe TBSCertificate

  • phpseclib3
  • File
  • ASN1
  • Maps
  • TBSCertificate
Champs de données
Référence de la classe TBSCertificate

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • TBSCertificate.php


Joomla CMS: Référence de la classe TBSCertList

  • phpseclib3
  • File
  • ASN1
  • Maps
  • TBSCertList
Champs de données
Référence de la classe TBSCertList

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • TBSCertList.php


Joomla CMS: Référence de la classe TerminalIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • TerminalIdentifier
Champs de données
Référence de la classe TerminalIdentifier

Champs de données

const MAP = ['type' => ASN1::TYPE_PRINTABLE_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_PRINTABLE_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • TerminalIdentifier.php


Joomla CMS: Référence de la classe Time

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Time
Champs de données
Référence de la classe Time

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_CHOICE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Time.php


Joomla CMS: Référence de la classe Trinomial

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Trinomial
Champs de données
Référence de la classe Trinomial

Champs de données

const MAP = ['type' => ASN1::TYPE_INTEGER]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_INTEGER]
La documentation de cette classe a été générée à partir du fichier suivant :
  • Trinomial.php


Joomla CMS: Référence de la classe UniqueIdentifier

  • phpseclib3
  • File
  • ASN1
  • Maps
  • UniqueIdentifier
Champs de données
Référence de la classe UniqueIdentifier

Champs de données

const MAP = ['type' => ASN1::TYPE_BIT_STRING]

Documentation des champs

◆ MAP

const MAP = ['type' => ASN1::TYPE_BIT_STRING]
La documentation de cette classe a été générée à partir du fichier suivant :
  • UniqueIdentifier.php


Joomla CMS: Référence de la classe UserNotice

  • phpseclib3
  • File
  • ASN1
  • Maps
  • UserNotice
Champs de données
Référence de la classe UserNotice

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • UserNotice.php


Joomla CMS: Référence de la classe Validity

  • phpseclib3
  • File
  • ASN1
  • Maps
  • Validity
Champs de données
Référence de la classe Validity

Champs de données

const MAP

Documentation des champs

◆ MAP

const MAP
Valeur initiale :
= [
'type' => ASN1::TYPE_SEQUENCE
La documentation de cette classe a été générée à partir du fichier suivant :
  • Validity.php


Joomla CMS: Référence de la classe Element

  • phpseclib3
  • File
  • ASN1
  • Element
Fonctions membres publiques | Champs de données
Référence de la classe Element

Fonctions membres publiques

__construct ($encoded)

Champs de données

$element

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $encoded )

Constructor

Paramètres
string $encoded
Renvoie
public

Références ASN1\$encoded.

Documentation des champs

◆ $element

$element
La documentation de cette classe a été générée à partir du fichier suivant :
  • Element.php


Joomla CMS: Référence de la classe ANSI

  • phpseclib3
  • File
  • ANSI
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ANSI

Fonctions membres publiques

__construct ()
setDimensions ($x, $y)
setHistory ($history)
loadString ($source)
appendString ($source)
getScreen ()
getHistory ()

Fonctions membres privées

newLine ()
processCoordinate ($last_attr, $cur_attr, $char)
getScreenHelper ()

Attributs privés

$max_x
$max_y
$max_history
$history
$history_attrs
$x
$y
$old_x
$old_y
$base_attr_cell
$attr_cell
$attr_row
$screen
$attrs
$ansi
$tokenization

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Default Constructor.

Renvoie
public

Références ANSI\$attr_cell, ANSI\setDimensions(), et ANSI\setHistory().

Documentation des fonctions membres

◆ appendString()

appendString ( $source )

Appdend a string

Paramètres
string $source public

Références ANSI\$ansi, ANSI\$attr_cell, ANSI\$attr_row, ANSI\$base_attr_cell, $i, $mod, $temp, ANSI\$x, ANSI\$y, ANSI\newLine(), et y.

Référencé par ANSI\loadString().

◆ getHistory()

getHistory ( )

Returns the current screen and the x previous lines

public

Renvoie
string

Références $i.

◆ getScreen()

getScreen ( )

Returns the current screen

public

Renvoie
string

◆ getScreenHelper()

getScreenHelper ( )
private

Returns the current screen without preformating

private

Renvoie
string

Références $i, et $output.

◆ loadString()

loadString ( $source )

Load a string

Paramètres
string $source public

Références ANSI\appendString(), et ANSI\setDimensions().

◆ newLine()

newLine ( )
private

Add a new line

Also update the $this->screen and $this->history buffers

private

Références y.

Référencé par ANSI\appendString().

◆ processCoordinate()

processCoordinate | ( | $last_attr,
 |  | $cur_attr,
 |  | $char
 | ) |
private

Returns the current coordinate without preformating

private

Paramètres
\stdClass | $last_attr
\stdClass | $cur_attr
string | $char
Renvoie
string

Références $output.

◆ setDimensions()

setDimensions | ( | $x,
 |  | $y
 | ) |

Set terminal width and height

Resets the screen as well

Paramètres
int | $x
int | $y | public

Références ANSI\$x, ANSI\$y, et y.

Référencé par ANSI\__construct(), et ANSI\loadString().

◆ setHistory()

setHistory ( $history )

Set the number of lines that should be logged past the terminal height

Paramètres
int $history public

Références ANSI\$history.

Référencé par ANSI\__construct().

Documentation des champs

◆ $ansi

$ansi
private

Référencé par ANSI\appendString().

◆ $attr_cell

$attr_cell
private

Référencé par ANSI\__construct(), et ANSI\appendString().

◆ $attr_row

$attr_row
private

Référencé par ANSI\appendString().

◆ $attrs

$attrs
private

◆ $base_attr_cell

$base_attr_cell
private

Référencé par ANSI\appendString().

◆ $history

$history
private

Référencé par ANSI\setHistory().

◆ $history_attrs

$history_attrs
private

◆ $max_history

$max_history
private

◆ $max_x

$max_x
private

◆ $max_y

$max_y
private

◆ $old_x

$old_x
private

◆ $old_y

$old_y
private

◆ $screen

$screen
private

◆ $tokenization

$tokenization
private

◆ $x

$x
private

Référencé par ANSI\appendString(), et ANSI\setDimensions().

◆ $y

$y
private

Référencé par ANSI\appendString(), et ANSI\setDimensions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ANSI.php


Joomla CMS: Référence de la classe ASN1

  • phpseclib3
  • File
  • ASN1
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe ASN1

Fonctions membres publiques statiques

static | decodeBER ($encoded)
static | asn1map ($decoded, $mapping, $special=[])
static | decodeLength (&$string)
static | encodeDER ($source, $mapping, $special=[])
static | decodeOID ($content)
static | encodeOID ($source)
static | setTimeFormat ($format)
static | loadOIDs ($oids)
static | setFilters ($filters)
static | convert ($in, $from=self::TYPE_UTF8_STRING, $to=self::TYPE_UTF8_STRING)
static | extractBER ($str)
static | encodeLength ($length)
static | getOID ($name)

Champs de données

const | CLASS_UNIVERSAL = 0
const | CLASS_APPLICATION = 1
const | CLASS_CONTEXT_SPECIFIC = 2
const | CLASS_PRIVATE = 3
const | TYPE_BOOLEAN = 1
const | TYPE_INTEGER = 2
const | TYPE_BIT_STRING = 3
const | TYPE_OCTET_STRING = 4
const | TYPE_NULL = 5
const | TYPE_OBJECT_IDENTIFIER = 6
const | TYPE_REAL = 9
const | TYPE_ENUMERATED = 10
const | TYPE_UTF8_STRING = 12
const | TYPE_SEQUENCE = 16
const | TYPE_SET = 17
const | TYPE_NUMERIC_STRING = 18
const | TYPE_PRINTABLE_STRING = 19
const | TYPE_TELETEX_STRING = 20
const | TYPE_VIDEOTEX_STRING = 21
const | TYPE_IA5_STRING = 22
const | TYPE_UTC_TIME = 23
const | TYPE_GENERALIZED_TIME = 24
const | TYPE_GRAPHIC_STRING = 25
const | TYPE_VISIBLE_STRING = 26
const | TYPE_GENERAL_STRING = 27
const | TYPE_UNIVERSAL_STRING = 28
const | TYPE_BMP_STRING = 30
const | TYPE_CHOICE = -1
const | TYPE_ANY = -2
const | ANY_MAP
const | STRING_TYPE_SIZE

Fonctions membres privées statiques

static | encode_der ($source, $mapping, $idx=null, $special=[])
static | decodeTime ($content, $tag)

Attributs privés statiques

static | $oids = []
static | $reverseOIDs = []
static | $format = 'D, d M Y H:i:s O'
static | $filters
static | $location
static | $encoded

Documentation des fonctions membres

◆ asn1map()

static asn1map | ( | $decoded,
 |  | $mapping,
 |  | $special = []
 | ) |
static

ASN.1 Map

Provides an ASN.1 semantic mapping ($mapping) from a parsed BER-encoding to a human readable format.

"Special" mappings may be applied on a per tag-name basis via $special.

Paramètres
array | $decoded
array | $mapping
array | $special
Renvoie
array|bool|Element|string|null public

Références $content, $format, $i, $key, $n, Joomla\Database\Query\$offset, $option, $size, $temp, $value, elseif, et null.

Référencé par X509\computeKeyIdentifier(), PKCS8\extractEncryptionAlgorithm(), X509\formatSubjectPublicKey(), EC\getCurve(), X509\getDNProp(), PKCS1\load(), PSS\load(), PKCS8\load(), X509\loadCRL(), X509\loadCSR(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), X509\loadSPKAC(), X509\loadX509(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutAttributes(), et PublicKey\rsassa_pkcs1_v1_5_relaxed_verify().

◆ convert()

static convert | ( | $in,
 |  | $from = self::TYPE_UTF8_STRING,
 |  | $to = self::TYPE_UTF8_STRING
 | ) |
static

String type conversion

This is a lazy conversion, dealing only with character size. No real conversion table is used.

Paramètres
string | $in
int | $from
int | $to
Renvoie
string public

Références $c, et $i.

Référencé par X509\getDN(), et X509\getDNProp().

◆ decodeBER()

static decodeBER ( $encoded )
static

Parse BER-encoding

Serves a similar purpose to openssl's asn1parse

Paramètres
Element | string $encoded
Renvoie
array public

Références ASN1\$encoded.

Référencé par X509\computeKeyIdentifier(), PKCS8\extractEncryptionAlgorithm(), X509\formatSubjectPublicKey(), EC\getCurve(), X509\getDNProp(), PKCS1\load(), PSS\load(), PKCS8\load(), X509\loadCRL(), X509\loadCSR(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), X509\loadSPKAC(), X509\loadX509(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutAttributes(), PKCS8\preParse(), et PublicKey\rsassa_pkcs1_v1_5_relaxed_verify().

◆ decodeLength()

static decodeLength ( & $string )
static

DER-decode the length

DER supports lengths up to (2**8)**127, however, we'll only support lengths up to (2**8)**4. See X.690 paragraph 8.1.3 for more information.

public

Paramètres
string $string
Renvoie
int

Références $temp, et Strings\shift().

◆ decodeOID()

static decodeOID ( $content )
static

BER-decode the OID

Called by _decode_ber()

public

Paramètres
string $content
Renvoie
string

Références $content, $n, $oid, et $temp.

◆ decodeTime()

static decodeTime | ( | $content,
 |  | $tag
 | ) |
staticprivate

BER-decode the time

Called by _decode_ber() and in the case of implicit tags asn1map().

private

Paramètres
string | $content
int | $tag
Renvoie
|false

Références $content, ASN1\$format, $prefix, et elseif.

◆ encode_der()

static encode_der | ( | $source,
 |  | $mapping,
 |  | $idx = null,
 |  | $special = []
 | ) |
staticprivate

ASN.1 Encode (Helper function)

Paramètres
Element | string | array | null | $source
array | $mapping
int | $idx
array | $special
Renvoie
string private

Références $content, $date, $filters, ASN1\$filters, ASN1\$format, $i, $key, $location, Joomla\Database\Query\$offset, $size, $temp, $value, et null.

◆ encodeDER()

static encodeDER | ( | $source,
 |  | $mapping,
 |  | $special = []
 | ) |
static

ASN.1 Encode

DER-encodes an ASN.1 semantic mapping ($mapping). Some libraries would probably call this function an ASN.1 compiler.

"Special" mappings can be applied via $special.

Paramètres
Element | string | array | $source
array | $mapping
array | $special
Renvoie
string public

Références $location, et null.

Référencé par phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), X509\getDN(), X509\loadCSR(), X509\loadSPKAC(), X509\loadX509(), X509\mapInAttributes(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), X509\saveCRL(), X509\saveCSR(), PKCS1\saveParameters(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), PSS\savePSSParams(), PKCS1\savePublicKey(), PKCS8\savePublicKey(), X509\saveSPKAC(), X509\saveX509(), PKCS8\wrapPrivateKey(), et PKCS8\wrapPublicKey().

◆ encodeLength()

static encodeLength ( $length )
static

DER-encode the length

DER supports lengths up to (2**8)**127, however, we'll only support lengths up to (2**8)**4. See X.690 paragraph 8.1.3 for more information.

public

Paramètres
int $length
Renvoie
string

Références $temp.

Référencé par X509\setEndDate().

◆ encodeOID()

static encodeOID ( $source )
static

DER-encode the OID

Called by _encode_der()

public

Paramètres
string $source
Renvoie
string

Références $oid, $parts, $temp, et $value.

◆ extractBER()

static extractBER ( $str )
static

Extract raw BER from Base64 encoding

private

Paramètres
string $str
Renvoie
string

Références $temp, et EncoderInterface\decode().

Référencé par X509\computeKeyIdentifier(), EC\getCurve(), PKCS1\load(), X509\loadCRL(), X509\loadCSR(), X509\loadX509(), PKCS8\preParse(), PKCS8\savePrivateKey(), PSS\savePrivateKey(), PKCS8\savePublicKey(), et PSS\savePublicKey().

◆ getOID()

static getOID ( $name )
static

Returns the OID corresponding to a name

What's returned in the associative array returned by loadX509() (or load*()) is either a name or an OID if no OID to name mapping is available. The problem with this is that what may be an unmapped OID in one version of phpseclib may not be unmapped in the next version, so apps that are looking at this OID may not be able to work from version to version.

This method will return the OID if a name is passed to it and if no mapping is avialable it'll assume that what's being passed to it already is an OID and return that instead. A few examples.

getOID('2.16.840.1.101.3.4.2.1') == '2.16.840.1.101.3.4.2.1' getOID('id-sha256') == '2.16.840.1.101.3.4.2.1' getOID('zzz') == 'zzz'

public

Paramètres
string $name
Renvoie
string

Références $name.

◆ loadOIDs()

static loadOIDs ( $oids )
static

Load OIDs

Load the relevant OIDs for a particular ASN.1 semantic mapping. Previously loaded OIDs are retained.

public

Paramètres
array $oids

Références ASN1\$oids.

Référencé par X509\__construct(), phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), PSS\initialize_static_variables(), PKCS8\initialize_static_variables(), et PublicKey\rsassa_pkcs1_v1_5_relaxed_verify().

◆ setFilters()

static setFilters ( $filters )
static

Set filters

See , etc, for an example. Previously loaded filters are not retained.

public

Paramètres
array $filters

Références $filters, et ASN1\$filters.

Référencé par X509\getDN(), X509\getDNProp(), X509\saveCRL(), X509\saveCSR(), et X509\saveX509().

◆ setTimeFormat()

static setTimeFormat ( $format )
static

Set the time format

Sets the time / date format for asn1map().

public

Paramètres
string $format

Références $format, et ASN1\$format.

Documentation des champs

◆ $encoded

$encoded
staticprivate

Référencé par Element\__construct(), et ASN1\decodeBER().

◆ $filters

$filters
staticprivate

Référencé par ASN1\encode_der(), et ASN1\setFilters().

◆ $format

$format = 'D, d M Y H:i:s O'
staticprivate

Référencé par ASN1\decodeTime(), ASN1\encode_der(), et ASN1\setTimeFormat().

◆ $location

$location
staticprivate

◆ $oids

$oids = []
staticprivate

Référencé par ASN1\loadOIDs().

◆ $reverseOIDs

$reverseOIDs = []
staticprivate

◆ ANY_MAP

const ANY_MAP
Valeur initiale :
= [
self::TYPE_BOOLEAN => true

Référencé par X509\getDN(), et X509\getDNProp().

◆ CLASS_APPLICATION

const CLASS_APPLICATION = 1

◆ CLASS_CONTEXT_SPECIFIC

const CLASS_CONTEXT_SPECIFIC = 2

Référencé par X509\mapOutExtensions().

◆ CLASS_PRIVATE

const CLASS_PRIVATE = 3

◆ CLASS_UNIVERSAL

const CLASS_UNIVERSAL = 0

◆ STRING_TYPE_SIZE

const STRING_TYPE_SIZE
Valeur initiale :
= [
self::TYPE_UTF8_STRING => 0

Référencé par X509\getDN(), et X509\getDNProp().

◆ TYPE_ANY

const TYPE_ANY = -2

◆ TYPE_BIT_STRING

const TYPE_BIT_STRING = 3

Référencé par X509\computeKeyIdentifier().

◆ TYPE_BMP_STRING

const TYPE_BMP_STRING = 30

◆ TYPE_BOOLEAN

const TYPE_BOOLEAN = 1

◆ TYPE_CHOICE

const TYPE_CHOICE = -1

◆ TYPE_ENUMERATED

const TYPE_ENUMERATED = 10

◆ TYPE_GENERAL_STRING

const TYPE_GENERAL_STRING = 27

◆ TYPE_GENERALIZED_TIME

const TYPE_GENERALIZED_TIME = 24

Référencé par X509\setEndDate().

◆ TYPE_GRAPHIC_STRING

const TYPE_GRAPHIC_STRING = 25

◆ TYPE_IA5_STRING

const TYPE_IA5_STRING = 22

Référencé par X509\saveX509().

◆ TYPE_INTEGER

const TYPE_INTEGER = 2

Référencé par PKCS8\savePrivateKey(), et PKCS8\savePublicKey().

◆ TYPE_NULL

const TYPE_NULL = 5

Référencé par X509\saveCRL().

◆ TYPE_NUMERIC_STRING

const TYPE_NUMERIC_STRING = 18

◆ TYPE_OBJECT_IDENTIFIER

const TYPE_OBJECT_IDENTIFIER = 6

◆ TYPE_OCTET_STRING

const TYPE_OCTET_STRING = 4

◆ TYPE_PRINTABLE_STRING

const TYPE_PRINTABLE_STRING = 19

◆ TYPE_REAL

const TYPE_REAL = 9

◆ TYPE_SEQUENCE

const TYPE_SEQUENCE = 16

◆ TYPE_SET

const TYPE_SET = 17

◆ TYPE_TELETEX_STRING

const TYPE_TELETEX_STRING = 20

◆ TYPE_UNIVERSAL_STRING

const TYPE_UNIVERSAL_STRING = 28

◆ TYPE_UTC_TIME

const TYPE_UTC_TIME = 23

◆ TYPE_UTF8_STRING

const TYPE_UTF8_STRING = 12

Référencé par X509\getDN(), X509\getDNProp(), X509\saveCRL(), X509\saveCSR(), et X509\saveX509().

◆ TYPE_VIDEOTEX_STRING

const TYPE_VIDEOTEX_STRING = 21

◆ TYPE_VISIBLE_STRING

const TYPE_VISIBLE_STRING = 26
La documentation de cette classe a été générée à partir du fichier suivant :
  • File/ASN1.php


Joomla CMS: Référence de la classe X509

  • phpseclib3
  • File
  • X509
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe X509

Fonctions membres publiques

__construct ()
loadX509 ($cert, $mode=self::FORMAT_AUTO_DETECT)
saveX509 ($cert, $format=self::FORMAT_PEM)
loadCA ($cert)
validateURL ($url)
validateDate ($date=null)
validateSignature ($caonly=true)
setDNProp ($propName, $propValue, $type='utf8String')
removeDNProp ($propName)
getDNProp ($propName, $dn=null, $withType=false)
setDN ($dn, $merge=false, $type='utf8String')
getDN ($format=self::DN_ARRAY, $dn=null)
getIssuerDN ($format=self::DN_ARRAY)
getSubjectDN ($format=self::DN_ARRAY)
getIssuerDNProp ($propName, $withType=false)
getSubjectDNProp ($propName, $withType=false)
getChain ()
& getCurrentCert ()
setPublicKey (PublicKey $key)
setPrivateKey (PrivateKey $key)
setChallenge ($challenge)
getPublicKey ()
loadCSR ($csr, $mode=self::FORMAT_AUTO_DETECT)
saveCSR ($csr, $format=self::FORMAT_PEM)
loadSPKAC ($spkac)
saveSPKAC ($spkac, $format=self::FORMAT_PEM)
loadCRL ($crl, $mode=self::FORMAT_AUTO_DETECT)
saveCRL ($crl, $format=self::FORMAT_PEM)
sign ($issuer, $subject)
signCSR ()
signSPKAC ()
signCRL ($issuer, $crl)
setStartDate ($date)
setEndDate ($date)
setSerialNumber ($serial, $base=-256)
makeCA ()
removeExtension ($id)
getExtension ($id, $cert=null, $path=null)
getExtensions ($cert=null, $path=null)
setExtension ($id, $value, $critical=false, $replace=true)
removeAttribute ($id, $disposition=self::ATTR_ALL)
getAttribute ($id, $disposition=self::ATTR_ALL, $csr=null)
getAttributes ($csr=null)
setAttribute ($id, $value, $disposition=self::ATTR_ALL)
setKeyIdentifier ($value)
computeKeyIdentifier ($key=null, $method=1)
setDomain (... $domains)
setIPAddress (... $ipAddresses)
revoke ($serial, $date=null)
unrevoke ($serial)
getRevoked ($serial)
listRevoked ($crl=null)
removeRevokedCertificateExtension ($serial, $id)
getRevokedCertificateExtension ($serial, $id, $crl=null)
getRevokedCertificateExtensions ($serial, $crl=null)
setRevokedCertificateExtension ($serial, $id, $value, $critical=false, $replace=true)
setExtensionValue ($id, $value, $critical=false, $replace=false)

Fonctions membres publiques statiques

static | setRecurLimit ($count)
static | disableURLFetch ()
static | enableURLFetch ()
static | decodeIP ($ip)
static | decodeNameConstraintIP ($ip)
static | encodeIP ($ip)
static | registerExtension ($id, array $mapping)
static | getRegisteredExtension ($id)

Champs de données

const | VALIDATE_SIGNATURE_BY_CA = 1
const | DN_ARRAY = 0
const | DN_STRING = 1
const | DN_ASN1 = 2
const | DN_OPENSSL = 3
const | DN_CANON = 4
const | DN_HASH = 5
const | FORMAT_PEM = 0
const | FORMAT_DER = 1
const | FORMAT_SPKAC = 2
const | FORMAT_AUTO_DETECT = 3
const | ATTR_ALL = -1
const | ATTR_APPEND = -2
const | ATTR_REPLACE = -3

Fonctions membres privées

mapInExtensions (&$root, $path)
mapOutExtensions (&$root, $path)
mapInAttributes (&$root, $path)
mapOutAttributes (&$root, $path)
mapInDNs (&$root, $path)
mapOutDNs (&$root, $path)
getMapping ($extnId)
testForIntermediate ($caonly, $count)
validateSignatureCountable ($caonly, $count)
validateSignatureHelper ($publicKeyAlgorithm, $publicKey, $signatureAlgorithm, $signature, $signatureSubject)
translateDNProp ($propName)
timeField ($date)
isSubArrayValid ($root, $path)
& subArrayUnchecked (&$root, $path, $create=false)
& subArray (&$root, $path, $create=false)
& extensions (&$root, $path=null, $create=false)
removeExtensionHelper ($id, $path=null)
getExtensionHelper ($id, $cert=null, $path=null)
getExtensionsHelper ($cert=null, $path=null)
setExtensionHelper ($id, $value, $critical=false, $replace=true, $path=null)
formatSubjectPublicKey ()
dnsName ($domain)
iPAddress ($address)
revokedCertificate (&$rclist, $serial, $create=false)

Fonctions membres privées statiques

static | fetchURL ($url)
static | identifySignatureAlgorithm (PrivateKey $key)

Attributs privés

$dn
$publicKey
$privateKey
$oids
$CAs
$currentCert
$signatureSubject
$startDate
$endDate
$serialNumber
$currentKeyIdentifier
$caFlag = false
$challenge
$extensionValues = []
$ipAddresses = null
$domains = null

Attributs privés statiques

static | $oidsLoaded = false
static | $recur_limit = 5
static | $disable_url_fetch = false
static | $extensions = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Default Constructor.

Renvoie
public

Références ASN1\loadOIDs().

Documentation des fonctions membres

◆ computeKeyIdentifier()

computeKeyIdentifier | ( | $key = null,
 |  | $method = 1
 | ) |

Compute a public key identifier.

Although key identifiers may be set to any unique value, this function computes key identifiers from public key according to the two recommended methods (4.2.1.2 RFC 3280). Highly polymorphic: try to accept all possible forms of key:

  • Key object
  • object with public or private key defined
  • Certificate or CSR array
  • object
  • PEM or DER string
Paramètres
mixed | $key | optional
int | $method | optional public
Renvoie
string binary key identifier

Références $hash, $key, $method, $this, ASN1\asn1map(), ASN1\decodeBER(), ASN1\extractBER(), PublicKeyLoader\load(), et ASN1\TYPE_BIT_STRING.

Référencé par X509\sign().

◆ decodeIP()

static decodeIP ( $ip )
static

Decodes an IP address

Takes in a base64 encoded "blob" and returns a human readable IP address

Paramètres
string $ip private
Renvoie
string

◆ decodeNameConstraintIP()

static decodeNameConstraintIP ( $ip )
static

Decodes an IP address in a name constraints extension

Takes in a base64 encoded "blob" and returns a human readable IP address / mask

Paramètres
string $ip private
Renvoie
array

Références $size.

◆ disableURLFetch()

static disableURLFetch ( )
static

Prevents URIs from being automatically retrieved

public

◆ dnsName()

dnsName ( $domain )
private

Helper function to build domain array

private

Paramètres
string $domain
Renvoie
array

◆ enableURLFetch()

static enableURLFetch ( )
static

Allows URIs to be automatically retrieved

public

◆ encodeIP()

static encodeIP ( $ip )
static

Encodes an IP address

Takes a human readable IP address into a base64-encoded "blob"

Paramètres
string | array $ip private
Renvoie
string

◆ extensions()

& extensions | ( | & | $root,
 |  |  | $path = null,
 |  |  | $create = false
 | ) |  |
private

Get a reference to an extension subarray

Paramètres
array | $root
string | $path | optional absolute path with / as component separator
bool | $create | optional private
Renvoie
array|false

Références $attributes, X509\$currentCert, X509\$extensions, $key, $path, $root, $value, et X509\subArray().

Référencé par X509\getExtensionHelper(), X509\getExtensionsHelper(), X509\removeExtensionHelper(), et X509\setExtensionHelper().

◆ fetchURL()

static fetchURL ( $url )
staticprivate

Fetches a URL

Paramètres
string $url private
Renvoie
bool|string

Références $data, $parts, $temp, et $url.

◆ formatSubjectPublicKey()

formatSubjectPublicKey ( )
private

Format a public key as appropriate

private

Renvoie
array|false

Références $format, X509\$publicKey, ASN1\asn1map(), ASN1\decodeBER(), et RSA\SIGNATURE_PSS.

Référencé par X509\signCSR(), et X509\signSPKAC().

◆ getAttribute()

getAttribute | ( | $id,
 |  | $disposition = self::ATTR_ALL,
 |  | $csr = null
 | ) |

Get a CSR attribute

Returns the attribute if it exists and false if not

Paramètres
string | $id
int | $disposition | optional
array | $csr | optional public
Renvoie
mixed

Références $attributes, X509\$currentCert, $id, $key, $n, et X509\subArray().

◆ getAttributes()

getAttributes ( $csr = null )

Returns a list of all CSR attributes in use

Paramètres
array $csr optional public
Renvoie
array

Références $attributes, X509\$currentCert, et X509\subArray().

◆ getChain()

getChain ( )

Get the certificate chain for the current cert

public

Renvoie
mixed

Références X509\$currentCert, $i, $key, $value, et X509\getExtension().

◆ getCurrentCert()

& getCurrentCert ( )

Returns the current cert

public

Renvoie
array|bool

Références X509\$currentCert.

◆ getDN()

getDN | ( | $format = self::DN_ARRAY,
 |  | $dn = null
 | ) |

Get the Distinguished Name for a certificates subject

Paramètres
mixed | $format | optional
array | $dn | optional public
Renvoie
array|bool|string

Références $attr, $desc, X509\$dn, $field, $filters, $format, $hash, $i, $output, $result, $start, $type, $value, ASN1\ANY_MAP, ASN1\convert(), elseif, EncoderInterface\encode(), ASN1\encodeDER(), X509\mapOutDNs(), ASN1\setFilters(), ASN1\STRING_TYPE_SIZE, et ASN1\TYPE_UTF8_STRING.

Référencé par X509\getIssuerDN(), X509\getSubjectDN(), et X509\validateSignatureCountable().

◆ getDNProp()

getDNProp | ( | $propName,
 |  | $dn = null,
 |  | $withType = false
 | ) |

Get Distinguished Name properties

Paramètres
string | $propName
array | $dn | optional
bool | $withType | optional
Renvoie
mixed public

Références X509\$dn, $filters, $i, $result, $type, ASN1\ANY_MAP, ASN1\asn1map(), ASN1\convert(), ASN1\decodeBER(), elseif, X509\getMapping(), X509\mapOutDNs(), ASN1\setFilters(), ASN1\STRING_TYPE_SIZE, X509\translateDNProp(), et ASN1\TYPE_UTF8_STRING.

Référencé par X509\getIssuerDNProp(), X509\getSubjectDNProp(), et X509\validateURL().

◆ getExtension()

getExtension | ( | $id,
 |  | $cert = null,
 |  | $path = null
 | ) |

Get a certificate, CSR or CRL Extension

Returns the extension if it exists and false if not

Paramètres
string | $id
array | $cert | optional
string | $path | public
Renvoie
mixed

Références $id, $path, et X509\getExtensionHelper().

Référencé par X509\getChain(), X509\getRevokedCertificateExtension(), X509\loadX509(), X509\sign(), X509\signCRL(), X509\testForIntermediate(), X509\validateSignatureCountable(), et X509\validateURL().

◆ getExtensionHelper()

getExtensionHelper | ( | $id,
 |  | $cert = null,
 |  | $path = null
 | ) |
private

Get an Extension

Returns the extension if it exists and false if not

Paramètres
string | $id
array | $cert | optional
string | $path | optional private
Renvoie
mixed

Références X509\$extensions, $id, $key, $path, $value, et X509\extensions().

Référencé par X509\getExtension().

◆ getExtensions()

getExtensions | ( | $cert = null,
 |  | $path = null
 | ) |

Returns a list of all extensions in use in certificate, CSR or CRL

Paramètres
array | $cert | optional
string | $path | optional public
Renvoie
array

Références $path, et X509\getExtensionsHelper().

Référencé par X509\getRevokedCertificateExtensions().

◆ getExtensionsHelper()

getExtensionsHelper | ( | $cert = null,
 |  | $path = null
 | ) |
private

Returns a list of all extensions in use

Paramètres
array | $cert | optional
string | $path | optional private
Renvoie
array

Références $extension, X509\$extensions, $path, et X509\extensions().

Référencé par X509\getExtensions().

◆ getIssuerDN()

getIssuerDN ( $format = self::DN_ARRAY )

Get the Distinguished Name for a certificate/crl issuer

Paramètres
int $format optional public
Renvoie
mixed

Références $format, et X509\getDN().

Référencé par X509\validateSignatureCountable().

◆ getIssuerDNProp()

getIssuerDNProp | ( | $propName,
 |  | $withType = false
 | ) |

Get an individual Distinguished Name property for a certificate/crl issuer

Paramètres
string | $propName
bool | $withType | optional public
Renvoie
mixed

Références X509\getDNProp().

◆ getMapping()

getMapping ( $extnId )
private

Associate an extension ID to an extension mapping

Paramètres
string $extnId private
Renvoie
mixed

Référencé par X509\getDNProp(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutAttributes(), X509\mapOutDNs(), et X509\mapOutExtensions().

◆ getPublicKey()

getPublicKey ( )

Gets the public key

Returns a object or a false.

public

Renvoie
mixed

Références $key, $path, X509\$publicKey, AsymmetricKey\loadFormat(), RSA\SIGNATURE_PKCS1, et X509\subArray().

Référencé par X509\loadCSR(), et X509\loadSPKAC().

◆ getRegisteredExtension()

static getRegisteredExtension ( $id )
static

Register the mapping for a custom/unsupported extension.

Paramètres
string $id
Renvoie
array|null

Références $id, et null.

◆ getRevoked()

getRevoked ( $serial )

Get a revoked certificate.

Paramètres
string $serial public
Renvoie
mixed

Références $i, X509\revokedCertificate(), et X509\subArray().

◆ getRevokedCertificateExtension()

getRevokedCertificateExtension | ( | $serial,
 |  | $id,
 |  | $crl = null
 | ) |

Get a Revoked Certificate Extension

Returns the extension if it exists and false if not

Paramètres
string | $serial
string | $id
array | $crl | optional public
Renvoie
mixed

Références X509\$currentCert, $i, $id, X509\getExtension(), X509\revokedCertificate(), et X509\subArray().

◆ getRevokedCertificateExtensions()

getRevokedCertificateExtensions | ( | $serial,
 |  | $crl = null
 | ) |

Returns a list of all extensions in use for a given revoked certificate

Paramètres
string | $serial
array | $crl | optional public
Renvoie
array|bool

Références X509\$currentCert, $i, X509\getExtensions(), X509\revokedCertificate(), et X509\subArray().

◆ getSubjectDN()

getSubjectDN ( $format = self::DN_ARRAY )

Get the Distinguished Name for a certificate/csr subject Alias of getDN()

Paramètres
int $format optional public
Renvoie
mixed

Références $format, et X509\getDN().

◆ getSubjectDNProp()

getSubjectDNProp | ( | $propName,
 |  | $withType = false
 | ) |

Get an individual Distinguished Name property for a certificate/csr subject

Paramètres
string | $propName
bool | $withType | optional public
Renvoie
mixed

Références X509\getDNProp(), et null.

◆ identifySignatureAlgorithm()

static identifySignatureAlgorithm ( PrivateKey $key )
staticprivate

Identify signature algorithm from key settings

Paramètres
PrivateKey $key private
Exceptions

Références $key, et RSA\SIGNATURE_PSS.

◆ iPAddress()

iPAddress ( $address )
private

Helper function to build IP Address array

(IPv6 is not currently supported)

private

Paramètres
string $address
Renvoie
array

◆ isSubArrayValid()

isSubArrayValid | ( | $root,
 |  | $path
 | ) |
private

Check for validity of subarray

This is intended for use in conjunction with _subArrayUnchecked(), implementing the checks included in _subArray() but without copying a potentially large array by passing its reference by-value to is_array().

Paramètres
array | $root
string | $path
Renvoie
boolean private

Références $i, $path, et $root.

Référencé par X509\loadCRL(), X509\loadX509(), et X509\mapInAttributes().

◆ listRevoked()

listRevoked ( $crl = null )

List revoked certificates

Paramètres
array $crl optional public
Renvoie
array|bool

Références X509\$currentCert, $result, et X509\subArray().

◆ loadCA()

loadCA ( $cert )

Load an X.509 certificate as a certificate authority

Paramètres
string $cert public
Renvoie
bool

Références X509\$currentCert, X509\$currentKeyIdentifier, X509\$dn, X509\$signatureSubject, et X509\loadX509().

◆ loadCRL()

loadCRL | ( | $crl,
 |  | $mode = self::FORMAT_AUTO_DETECT
 | ) |

Load a Certificate Revocation List

Paramètres
string | $crl
int | $mode
Renvoie
mixed public

Références $extension, $i, $mode, ASN1\asn1map(), ASN1\decodeBER(), ASN1\extractBER(), X509\isSubArrayValid(), X509\mapInDNs(), X509\mapInExtensions(), null, et X509\subArrayUnchecked().

Référencé par X509\signCRL().

◆ loadCSR()

loadCSR | ( | $csr,
 |  | $mode = self::FORMAT_AUTO_DETECT
 | ) |

Load a Certificate Signing Request

Paramètres
string | $csr
int | $mode
Renvoie
mixed public

Références $key, $mode, ASN1\asn1map(), ASN1\decodeBER(), ASN1\encodeDER(), ASN1\extractBER(), X509\getPublicKey(), X509\mapInAttributes(), X509\mapInDNs(), et null.

Référencé par X509\signCSR().

◆ loadSPKAC()

loadSPKAC ( $spkac )

Load a SPKAC CSR

SPKAC's are produced by the HTML5 keygen element:

https://developer.mozilla.org/en-US/docs/HTML/Element/keygen

Paramètres
string $spkac public
Renvoie
mixed

Références $key, $temp, ASN1\asn1map(), EncoderInterface\decode(), ASN1\decodeBER(), ASN1\encodeDER(), X509\getPublicKey(), et null.

Référencé par X509\signSPKAC().

◆ loadX509()

loadX509 | ( | $cert,
 |  | $mode = self::FORMAT_AUTO_DETECT
 | ) |

Load X.509 certificate

Returns an associative array describing the X.509 cert or a false if the cert failed to load

Paramètres
string | $cert
int | $mode | public
Renvoie
mixed

Références X509\$currentKeyIdentifier, $key, $mode, ASN1\asn1map(), ASN1\decodeBER(), ASN1\encodeDER(), ASN1\extractBER(), X509\getExtension(), X509\isSubArrayValid(), X509\mapInDNs(), X509\mapInExtensions(), et null.

Référencé par X509\loadCA(), et X509\sign().

◆ makeCA()

makeCA ( )

Turns the certificate into a certificate authority

public

◆ mapInAttributes()

mapInAttributes | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map attribute values from ANY type to attribute-specific internal format.

Paramètres
array | $root | (by reference)
string | $path | private

Références $attributes, $i, $id, $path, $root, $value, ASN1\asn1map(), ASN1\decodeBER(), elseif, ASN1\encodeDER(), X509\getMapping(), X509\isSubArrayValid(), X509\mapInExtensions(), et X509\subArray().

Référencé par X509\loadCSR().

◆ mapInDNs()

mapInDNs | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map DN values from ANY type to DN-specific internal format.

Paramètres
array | $root | (by reference)
string | $path | private

Références $i, $path, $root, $type, $value, ASN1\asn1map(), ASN1\decodeBER(), X509\getMapping(), et X509\subArray().

Référencé par X509\loadCRL(), X509\loadCSR(), et X509\loadX509().

◆ mapInExtensions()

mapInExtensions | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map extension values from octet string to extension-specific internal format.

Paramètres
array | $root | (by reference)
string | $path | private

Références X509\$extensions, $i, $id, $path, $root, $value, ASN1\asn1map(), class, ASN1\decodeBER(), X509\getMapping(), et X509\subArrayUnchecked().

Référencé par X509\loadCRL(), X509\loadX509(), et X509\mapInAttributes().

◆ mapOutAttributes()

mapOutAttributes | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map attribute values from attribute-specific internal format to ANY type.

Paramètres
array | $root | (by reference)
string | $path | private

Références $attributes, $i, $id, $path, $root, $size, $temp, ASN1\asn1map(), ASN1\decodeBER(), elseif, ASN1\encodeDER(), X509\getMapping(), X509\mapOutExtensions(), et X509\subArray().

Référencé par X509\saveCSR().

◆ mapOutDNs()

mapOutDNs | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map DN values from DN-specific internal format to ANY type.

Paramètres
array | $root | (by reference)
string | $path | private

Références $i, $path, $root, $size, $type, $value, ASN1\encodeDER(), X509\getMapping(), et X509\subArray().

Référencé par X509\getDN(), X509\getDNProp(), X509\saveCRL(), X509\saveCSR(), et X509\saveX509().

◆ mapOutExtensions()

mapOutExtensions | ( | & | $root,
 |  |  | $path
 | ) |  |
private

Map extension values from extension-specific internal format to octet string.

Paramètres
array | $root | (by reference)
string | $path | private

Références $data, X509\$extensions, $i, $id, $key, $path, $root, $size, $temp, $value, class, ASN1\CLASS_CONTEXT_SPECIFIC, ASN1\encodeDER(), X509\getMapping(), et X509\subArray().

Référencé par X509\mapOutAttributes(), X509\saveCRL(), et X509\saveX509().

◆ registerExtension()

static registerExtension | ( |  | $id,
 |  | array | $mapping
 | ) |  |
static

Register the mapping for a custom/unsupported extension.

Paramètres
string | $id
array | $mapping

Références $id.

◆ removeAttribute()

removeAttribute | ( | $id,
 |  | $disposition = self::ATTR_ALL
 | ) |

Remove a CSR attribute.

Paramètres
string | $id
int | $disposition | optional public
Renvoie
bool

Références $attributes, $id, $key, $n, $result, et X509\subArray().

Référencé par X509\setAttribute().

◆ removeDNProp()

removeDNProp ( $propName )

Remove Distinguished Name properties

Paramètres
string $propName public

Références X509\$dn, $i, $size, et X509\translateDNProp().

Référencé par X509\setDomain().

◆ removeExtension()

removeExtension ( $id )

Remove a certificate, CSR or CRL Extension

Paramètres
string $id public
Renvoie
bool

Références $id, et X509\removeExtensionHelper().

Référencé par X509\sign(), et X509\signCRL().

◆ removeExtensionHelper()

removeExtensionHelper | ( | $id,
 |  | $path = null
 | ) |
private

Remove an Extension

Paramètres
string | $id
string | $path | optional private
Renvoie
bool

Références X509\$extensions, $id, $key, $path, $result, $value, et X509\extensions().

Référencé par X509\removeExtension(), et X509\removeRevokedCertificateExtension().

◆ removeRevokedCertificateExtension()

removeRevokedCertificateExtension | ( | $serial,
 |  | $id
 | ) |

Remove a Revoked Certificate Extension

Paramètres
string | $serial
string | $id | public
Renvoie
bool

Références $i, $id, X509\removeExtensionHelper(), X509\revokedCertificate(), et X509\subArray().

◆ revoke()

revoke | ( | $serial,
 |  | $date = null
 | ) |

Revoke a certificate.

Paramètres
string | $serial
string | $date | optional public
Renvoie
bool

Références $date, $i, X509\revokedCertificate(), X509\subArray(), et X509\timeField().

◆ revokedCertificate()

revokedCertificate | ( | & | $rclist,
 |  |  | $serial,
 |  |  | $create = false
 | ) |  |
private

Get the index of a revoked certificate.

Paramètres
array | $rclist
string | $serial
bool | $create | optional private
Renvoie
int|false

Références $i, et X509\timeField().

Référencé par X509\getRevoked(), X509\getRevokedCertificateExtension(), X509\getRevokedCertificateExtensions(), X509\removeRevokedCertificateExtension(), X509\revoke(), X509\setRevokedCertificateExtension(), et X509\unrevoke().

◆ saveCRL()

saveCRL | ( | $crl,
 |  | $format = self::FORMAT_PEM
 | ) |

Save Certificate Revocation List.

Paramètres
array | $crl
int | $format | optional public
Renvoie
string

Références $extension, $filters, $format, $i, Base64\encode(), ASN1\encodeDER(), X509\mapOutDNs(), X509\mapOutExtensions(), ASN1\setFilters(), X509\subArray(), ASN1\TYPE_NULL, et ASN1\TYPE_UTF8_STRING.

Référencé par X509\signCRL().

◆ saveCSR()

saveCSR | ( | $csr,
 |  | $format = self::FORMAT_PEM
 | ) |

Save CSR request

Paramètres
array | $csr
int | $format | optional public
Renvoie
string

Références $filters, $format, Base64\encode(), ASN1\encodeDER(), X509\mapOutAttributes(), X509\mapOutDNs(), ASN1\setFilters(), X509\subArray(), et ASN1\TYPE_UTF8_STRING.

Référencé par X509\signCSR().

◆ saveSPKAC()

saveSPKAC | ( | $spkac,
 |  | $format = self::FORMAT_PEM
 | ) |

Save a SPKAC CSR request

Paramètres
array | $spkac
int | $format | optional public
Renvoie
string

Références $format, Base64\encode(), ASN1\encodeDER(), et X509\subArray().

Référencé par X509\signSPKAC().

◆ saveX509()

saveX509 | ( | $cert,
 |  | $format = self::FORMAT_PEM
 | ) |

Save X.509 certificate

Paramètres
array | $cert
int | $format | optional public
Renvoie
string

Références $extension, $filters, $format, Base64\encode(), ASN1\encodeDER(), X509\mapOutDNs(), X509\mapOutExtensions(), null, ASN1\setFilters(), X509\subArray(), ASN1\TYPE_IA5_STRING, et ASN1\TYPE_UTF8_STRING.

Référencé par X509\sign().

◆ setAttribute()

setAttribute | ( | $id,
 |  | $value,
 |  | $disposition = self::ATTR_ALL
 | ) |

Set a CSR attribute

Paramètres
string | $id
mixed | $value
int | $disposition | optional public
Renvoie
bool

Références $attributes, $id, $key, $last, $n, $value, X509\removeAttribute(), et X509\subArray().

◆ setChallenge()

setChallenge ( $challenge )

Set challenge

Used for SPKAC CSR's

Paramètres
string $challenge public

Références X509\$challenge.

◆ setDN()

setDN | ( | $dn,
 |  | $merge = false,
 |  | $type = 'utf8String'
 | ) |

Set a Distinguished Name

Paramètres
mixed | $dn
bool | $merge | optional
string | $type | optional public
Renvoie
bool

Références X509\$dn, $i, $results, $type, $value, null, et X509\setDNProp().

◆ setDNProp()

setDNProp | ( | $propName,
 |  | $propValue,
 |  | $type = 'utf8String'
 | ) |

Set a Distinguished Name property

Paramètres
string | $propName
mixed | $propValue
string | $type | optional public
Renvoie
bool

Références $type, et X509\translateDNProp().

Référencé par X509\setDN(), et X509\setDomain().

◆ setDomain()

setDomain ( $domains )

Set the domain name's which the cert is to be valid for

Paramètres
mixed ...$domains public
Renvoie
void

Références X509\$domains, X509\removeDNProp(), et X509\setDNProp().

◆ setEndDate()

setEndDate ( $date )

Set certificate end date

Paramètres
\DateTimeInterface | string $date public

Références $date, $temp, ASN1\encodeLength(), et ASN1\TYPE_GENERALIZED_TIME.

◆ setExtension()

setExtension | ( | $id,
 |  | $value,
 |  | $critical = false,
 |  | $replace = true
 | ) |

Set a certificate, CSR or CRL Extension

Paramètres
string | $id
mixed | $value
bool | $critical | optional
bool | $replace | optional public
Renvoie
bool

Références $id, $value, et X509\setExtensionHelper().

Référencé par X509\sign(), et X509\signCRL().

◆ setExtensionHelper()

setExtensionHelper | ( | $id,
 |  | $value,
 |  | $critical = false,
 |  | $replace = true,
 |  | $path = null
 | ) |
private

Set an Extension

Paramètres
string | $id
mixed | $value
bool | $critical | optional
bool | $replace | optional
string | $path | optional private
Renvoie
bool

Références X509\$extensions, $id, $key, $path, $value, et X509\extensions().

Référencé par X509\setExtension(), et X509\setRevokedCertificateExtension().

◆ setExtensionValue()

setExtensionValue | ( | $id,
 |  | $value,
 |  | $critical = false,
 |  | $replace = false
 | ) |

Register the mapping for a custom/unsupported extension.

Paramètres
string | $id
mixed | $value
bool | $critical
bool | $replace

Références $id.

◆ setIPAddress()

setIPAddress ( $ipAddresses )

Set the IP Addresses's which the cert is to be valid for

public

Paramètres
mixed[] ...$ipAddresses

Références X509\$ipAddresses.

◆ setKeyIdentifier()

setKeyIdentifier ( $value )

Sets the subject key identifier

This is used by the id-ce-authorityKeyIdentifier and the id-ce-subjectKeyIdentifier extensions.

Paramètres
string $value public

Références $value.

◆ setPrivateKey()

setPrivateKey ( PrivateKey $key )

Set private key

Key needs to be a object

Paramètres
PrivateKey $key public

Références $key.

◆ setPublicKey()

setPublicKey ( PublicKey $key )

Set public key

Key needs to be a object

Paramètres
PublicKey $key public
Renvoie
void

Références $key.

◆ setRecurLimit()

static setRecurLimit ( $count )
static

Sets the recursion limit

When validating a signature it may be necessary to download intermediate certs from URI's. An intermediate cert that linked to itself would result in an infinite loop so to prevent that we set a recursion limit. A negative number means that there is no recursion limit.

Paramètres
int $count public

Références $count.

◆ setRevokedCertificateExtension()

setRevokedCertificateExtension | ( | $serial,
 |  | $id,
 |  | $value,
 |  | $critical = false,
 |  | $replace = true
 | ) |

Set a Revoked Certificate Extension

Paramètres
string | $serial
string | $id
mixed | $value
bool | $critical | optional
bool | $replace | optional public
Renvoie
bool

Références $i, $id, $value, X509\revokedCertificate(), X509\setExtensionHelper(), et X509\subArray().

◆ setSerialNumber()

setSerialNumber | ( | $serial,
 |  | $base = -256
 | ) |

Set Serial Number

Paramètres
string | $serial
int | $base | optional public

Références $base.

◆ setStartDate()

setStartDate ( $date )

Set certificate start date

Paramètres
\DateTimeInterface | string $date public

Références $date.

◆ sign()

sign | ( | $issuer,
 |  | $subject
 | ) |

Sign an X.509 certificate

$issuer's private key needs to be loaded. $subject can be either an existing X.509 cert (if you want to resign it), a CSR or something with the DN and public key explicitly set.

Paramètres
\phpseclib3\File\X509 | $issuer
\phpseclib3\File\X509 | $subject | public
Renvoie
mixed

Références X509\$currentCert, X509\$endDate, X509\$ipAddresses, $r, $result, X509\$serialNumber, X509\$signatureSubject, X509\$startDate, $subject, X509\computeKeyIdentifier(), elseif, X509\getExtension(), PSS\load(), X509\loadX509(), null, X509\removeExtension(), PSS\savePSSParams(), X509\saveX509(), X509\setExtension(), Random\string(), et X509\timeField().

◆ signCRL()

signCRL | ( | $issuer,
 |  | $crl
 | ) |

Sign a CRL

$issuer's private key needs to be loaded.

Paramètres
\phpseclib3\File\X509 | $issuer
\phpseclib3\File\X509 | $crl | public
Renvoie
mixed

Références X509\$currentCert, $result, X509\$serialNumber, X509\$signatureSubject, $version, elseif, X509\getExtension(), X509\loadCRL(), null, X509\removeExtension(), X509\saveCRL(), X509\setExtension(), et X509\timeField().

◆ signCSR()

signCSR ( )

Sign a CSR

public

Renvoie
mixed

Références X509\$currentCert, X509\$dn, X509\$publicKey, $result, X509\$signatureSubject, X509\formatSubjectPublicKey(), X509\loadCSR(), null, et X509\saveCSR().

◆ signSPKAC()

signSPKAC ( )

Sign a SPKAC

public

Renvoie
mixed

Références X509\$currentCert, X509\$publicKey, $result, X509\$signatureSubject, X509\formatSubjectPublicKey(), X509\loadSPKAC(), null, et X509\saveSPKAC().

◆ subArray()

& subArray | ( | & | $root,
 |  |  | $path,
 |  |  | $create = false
 | ) |  |
private

Get a reference to a subarray

Paramètres
array | $root
string | $path | absolute path with / as component separator
bool | $create | optional private
Renvoie
array|false

Références $i, $path, et $root.

Référencé par X509\extensions(), X509\getAttribute(), X509\getAttributes(), X509\getPublicKey(), X509\getRevoked(), X509\getRevokedCertificateExtension(), X509\getRevokedCertificateExtensions(), X509\listRevoked(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), X509\removeAttribute(), X509\removeRevokedCertificateExtension(), X509\revoke(), X509\saveCRL(), X509\saveCSR(), X509\saveSPKAC(), X509\saveX509(), X509\setAttribute(), X509\setRevokedCertificateExtension(), et X509\unrevoke().

◆ subArrayUnchecked()

& subArrayUnchecked | ( | & | $root,
 |  |  | $path,
 |  |  | $create = false
 | ) |  |
private

Get a reference to a subarray

This variant of _subArray() does no is_array() checking, so $root should be checked with _isSubArrayValid() first.

This is here for performance reasons: Passing a reference (i.e. $root) by-value (i.e. to is_array()) creates a copy. If $root is an especially large array, this is expensive.

Paramètres
array | $root
string | $path | absolute path with / as component separator
bool | $create | optional private
Renvoie
array|false

Références $i, $path, et $root.

Référencé par X509\loadCRL(), et X509\mapInExtensions().

◆ testForIntermediate()

testForIntermediate | ( | $caonly,
 |  | $count
 | ) |
private

Validates an intermediate cert as identified via authority info access extension

See https://tools.ietf.org/html/rfc4325 for more info

Paramètres
bool | $caonly
int | $count | private
Renvoie
bool

Références X509\$CAs, $count, $opts, $url, et X509\getExtension().

Référencé par X509\validateSignatureCountable().

◆ timeField()

timeField ( $date )
private

Helper function to build a time field according to RFC 3280 section

  • 4.1.2.5 Validity
  • 5.1.2.4 This Update
  • 5.1.2.5 Next Update
  • 5.1.2.6 Revoked Certificates by choosing utcTime iff year of date given is before 2050 and generalTime else.
Paramètres
string $date in format date('D, d M Y H:i:s O') private
Renvoie
array|Element

Références $date.

Référencé par X509\revoke(), X509\revokedCertificate(), X509\sign(), et X509\signCRL().

◆ translateDNProp()

translateDNProp ( $propName )
private

"Normalizes" a Distinguished Name property

Paramètres
string $propName private
Renvoie
mixed

Référencé par X509\getDNProp(), X509\removeDNProp(), et X509\setDNProp().

◆ unrevoke()

unrevoke ( $serial )

Unrevoke a certificate.

Paramètres
string $serial public
Renvoie
bool

Références $i, X509\revokedCertificate(), et X509\subArray().

◆ validateDate()

validateDate ( $date = null )

Validate a date

If $date isn't defined it is assumed to be the current date.

Paramètres
\DateTimeInterface | string $date optional public
Renvoie
bool

Références $date.

◆ validateSignature()

validateSignature ( $caonly = true )

Validate a signature

Works on X.509 certs, CSR's and CRL's. Returns true if the signature is verified, false if it is not correct or null on error

By default returns false for self-signed certs. Call validateSignature(false) to make this support self-signed.

The behavior of this function is inspired by openssl_verify.

Paramètres
bool $caonly optional public
Renvoie
mixed

Références X509\validateSignatureCountable().

Référencé par X509\validateSignatureCountable().

◆ validateSignatureCountable()

validateSignatureCountable | ( | $caonly,
 |  | $count
 | ) |
private

Validate a signature

Performs said validation whilst keeping track of how many times validation method is called

Paramètres
bool | $caonly
int | $count | private
Renvoie
mixed

Références $count, X509\$currentCert, $i, elseif, X509\getDN(), X509\getExtension(), X509\getIssuerDN(), null, X509\testForIntermediate(), X509\validateSignature(), et X509\validateSignatureHelper().

Référencé par X509\validateSignature().

◆ validateSignatureHelper()

validateSignatureHelper | ( | $publicKeyAlgorithm,
 |  | $publicKey,
 |  | $signatureAlgorithm,
 |  | $signature,
 |  | $signatureSubject
 | ) |
private

Validates a signature

Returns true if the signature is verified and false if it is not correct. If the algorithms are unsupposed an exception is thrown.

Paramètres
string | $publicKeyAlgorithm
string | $publicKey
string | $signatureAlgorithm
string | $signature
string | $signatureSubject | private
Exceptions

Références $key, X509\$publicKey, X509\$signatureSubject, AsymmetricKey\loadFormat(), et RSA\SIGNATURE_PKCS1.

Référencé par X509\validateSignatureCountable().

◆ validateURL()

validateURL ( $url )

Validate an X.509 certificate against a URL

From RFC2818 "HTTP over TLS":

Matching is performed using the matching rules specified by [RFC2459]. If more than one identity of a given type is present in the certificate (e.g., more than one dNSName name, a match in any one of the set is considered acceptable.) Names may contain the wildcard character * which is considered to match any single domain name component or component fragment. E.g., *.a.com matches foo.a.com but not bar.foo.a.com. f*.com matches foo.com but not bar.com.

Paramètres
string $url public
Renvoie
bool

Références $key, $name, $names, $url, $value, X509\getDNProp(), et X509\getExtension().

Documentation des champs

◆ $caFlag

$caFlag = false
private

◆ $CAs

$CAs
private

Référencé par X509\testForIntermediate().

◆ $challenge

$challenge
private

Référencé par X509\setChallenge().

◆ $currentCert

$currentCert
private

Référencé par X509\extensions(), X509\getAttribute(), X509\getAttributes(), X509\getChain(), X509\getCurrentCert(), X509\getRevokedCertificateExtension(), X509\getRevokedCertificateExtensions(), X509\listRevoked(), X509\loadCA(), X509\sign(), X509\signCRL(), X509\signCSR(), X509\signSPKAC(), et X509\validateSignatureCountable().

◆ $currentKeyIdentifier

$currentKeyIdentifier
private

Référencé par X509\loadCA(), et X509\loadX509().

◆ $disable_url_fetch

$disable_url_fetch = false
staticprivate

◆ $dn

$dn
private

Référencé par X509\getDN(), X509\getDNProp(), X509\loadCA(), X509\removeDNProp(), X509\setDN(), et X509\signCSR().

◆ $domains

$domains = null
private

Référencé par X509\setDomain().

◆ $endDate

$endDate
private

Référencé par X509\sign().

◆ $extensions

$extensions = []
staticprivate

Référencé par X509\extensions(), X509\getExtensionHelper(), X509\getExtensionsHelper(), X509\mapInExtensions(), X509\mapOutExtensions(), X509\removeExtensionHelper(), et X509\setExtensionHelper().

◆ $extensionValues

$extensionValues = []
private

◆ $ipAddresses

$ipAddresses = null
private

Référencé par X509\setIPAddress(), et X509\sign().

◆ $oids

$oids
private

◆ $oidsLoaded

$oidsLoaded = false
staticprivate

◆ $privateKey

$privateKey
private

◆ $publicKey

$publicKey
private

Référencé par X509\formatSubjectPublicKey(), X509\getPublicKey(), X509\signCSR(), X509\signSPKAC(), et X509\validateSignatureHelper().

◆ $recur_limit

$recur_limit = 5
staticprivate

◆ $serialNumber

$serialNumber
private

Référencé par X509\sign(), et X509\signCRL().

◆ $signatureSubject

$signatureSubject
private

Référencé par X509\loadCA(), X509\sign(), X509\signCRL(), X509\signCSR(), X509\signSPKAC(), et X509\validateSignatureHelper().

◆ $startDate

$startDate
private

Référencé par X509\sign().

◆ ATTR_ALL

const ATTR_ALL = -1

Attribute value disposition. If disposition is >= 0, this is the index of the target value.

◆ ATTR_APPEND

const ATTR_APPEND = -2

◆ ATTR_REPLACE

const ATTR_REPLACE = -3

◆ DN_ARRAY

const DN_ARRAY = 0

Return internal array representation

public

Voir également
::getDN()

◆ DN_ASN1

const DN_ASN1 = 2

Return ASN.1 name string

public

Voir également
::getDN()

◆ DN_CANON

const DN_CANON = 4

Return canonical ASN.1 RDNs string

public

Voir également
::getDN()

◆ DN_HASH

const DN_HASH = 5

Return name hash for file indexing

public

Voir également
::getDN()

◆ DN_OPENSSL

const DN_OPENSSL = 3

Return OpenSSL compatible array

public

Voir également
::getDN()

◆ DN_STRING

const DN_STRING = 1

Return string

public

Voir également
::getDN()

◆ FORMAT_AUTO_DETECT

const FORMAT_AUTO_DETECT = 3

Auto-detect the format

Used only by the load*() functions

public

Voir également
::saveX509()
::saveCSR()
::saveCRL()

◆ FORMAT_DER

const FORMAT_DER = 1

Save as DER

public

Voir également
::saveX509()
::saveCSR()
::saveCRL()

◆ FORMAT_PEM

const FORMAT_PEM = 0

Save as PEM

ie. a base64-encoded PEM with a header and a footer

public

Voir également
::saveX509()
::saveCSR()
::saveCRL()

◆ FORMAT_SPKAC

const FORMAT_SPKAC = 2

Save as a SPKAC

public

Voir également
::saveX509()
::saveCSR()
::saveCRL()

Only works on CSRs. Not currently supported.

◆ VALIDATE_SIGNATURE_BY_CA

const VALIDATE_SIGNATURE_BY_CA = 1

Flag to only accept signatures signed by certificate authorities

Not really used anymore but retained all the same to suppress E_NOTICEs from old installs

public

La documentation de cette classe a été générée à partir du fichier suivant :
  • X509.php


Joomla CMS: Référence de la classe Barrett

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
  • Barrett
Champs de données | Fonctions membres protégées statiques | Fonctions membres privées statiques
Référence de la classe Barrett
+ Graphe d'héritage de Barrett:
Base BCMath Engine DefaultEngine

Champs de données

const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de BCMath
const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées statiques

static | reduce ($n, $m)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (BCMath $x, BCMath $e, BCMath $n, $class)
static | prepareReduce ($x, $n, $class)
static | multiplyReduce ($x, $y, $n, $class)
static | squareReduce ($x, $n, $class)
- Fonctions membres protégées statiques hérités de BCMath
static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Fonctions membres privées statiques

static regularBarrett ($x, $n)

Membres hérités additionnels

- Fonctions membres publiques hérités de BCMath
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de BCMath
static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Fonctions membres protégées hérités de BCMath
initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ reduce()

static reduce | ( | $n,
 |  | $m
 | ) |
staticprotected

Barrett Modular Reduction

See HAC 14.3.3 / MPM 6.2.5 for more information. Modified slightly, so as not to require negative numbers (initially, this script didn't support negative numbers).

Employs "folding", as described at thesis-149.pdf#page=66. To quote from it, "the idea [behind folding] is to find a value x' such that x (mod m) = x' (mod m), with x' being smaller than x."

Unfortunately, the "Barrett Reduction with Folding" algorithm described in thesis-149.pdf is not, as written, all that usable on account of (1) its not using reasonable radix points as discussed in MPM 6.2.2 and (2) the fact that, even with reasonable radix points, it only works when there are an even number of digits in the denominator. The reason for (2) is that (x >> 1) + (x >> 1) != x / 2 + x / 2. If x is even, they're the same, but if x is odd, they're not. See the in-line comments for details.

Paramètres
string | $n
string | $m
Renvoie
string

Références $key, $n, $result, et $temp.

◆ regularBarrett()

static regularBarrett | ( | $x,
 |  | $n
 | ) |
staticprivate

(Regular) Barrett Modular Reduction

For numbers with more than four digits BigInteger::_barrett() is faster. The difference between that and this is that this function does not fold the denominator into a smaller form.

Paramètres
string | $x
string | $n
Renvoie
string

Références $key, $n, $result, et $temp.

Documentation des champs

◆ DATA

const DATA = 1

$cache[self::DATA] contains the cached data.

private

◆ VARIABLE

const VARIABLE = 0

Cache constants

$cache[self::VARIABLE] tells us whether or not the cached data is still valid.

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • BCMath/Reductions/Barrett.php


Joomla CMS: Référence de la classe EvalBarrett

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
  • EvalBarrett
Fonctions membres protégées statiques | Attributs privés statiques
Référence de la classe EvalBarrett
+ Graphe d'héritage de EvalBarrett:
Base BCMath Engine

Fonctions membres protégées statiques

static | reduce ($n, $m)
static | generateCustomReduction (BCMath $m, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (BCMath $x, BCMath $e, BCMath $n, $class)
static | prepareReduce ($x, $n, $class)
static | multiplyReduce ($x, $y, $n, $class)
static | squareReduce ($x, $n, $class)
- Fonctions membres protégées statiques hérités de BCMath
static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Attributs privés statiques

static $custom_reduction

Membres hérités additionnels

- Fonctions membres publiques hérités de BCMath
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de BCMath
static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de BCMath
const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de BCMath
initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ generateCustomReduction()

static generateCustomReduction | ( | BCMath | $m,
 |  |  | $class
 | ) |  |
staticprotected

Generate Custom Reduction

Paramètres
BCMath | $m
string | $class
Renvoie
callable|void

Références $result, et $temp.

◆ reduce()

static reduce | ( | $n,
 |  | $m
 | ) |
staticprotected

Barrett Modular Reduction

This calls a dynamically generated loop unrolled function that's specific to a given modulo. Array lookups are avoided as are if statements testing for how many bits the host OS supports, etc.

Paramètres
string | $n
string | $m
Renvoie
string

Références $n.

Documentation des champs

◆ $custom_reduction

$custom_reduction
staticprivate

Custom Reduction Function

Voir également
self::generateCustomReduction
La documentation de cette classe a été générée à partir du fichier suivant :
  • BCMath/Reductions/EvalBarrett.php


Joomla CMS: Référence de la classe Base

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Base
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques
Référence de la classe Base
+ Graphe d'héritage de Base:
BCMath Engine Barrett EvalBarrett DefaultEngine

Fonctions membres publiques statiques

static | isValidEngine ()
- Fonctions membres publiques statiques hérités de BCMath
static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de BCMath
const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées statiques

static | powModHelper (BCMath $x, BCMath $e, BCMath $n, $class)
static | prepareReduce ($x, $n, $class)
static | multiplyReduce ($x, $y, $n, $class)
static | squareReduce ($x, $n, $class)
- Fonctions membres protégées statiques hérités de BCMath
static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de BCMath
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de BCMath
initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool

Références class.

◆ multiplyReduce()

static multiplyReduce | ( | $x,
 |  | $y,
 |  | $n,
 |  | $class
 | ) |
staticprotected

Modular multiply

Paramètres
string | $x
string | $y
string | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
string

Références $n.

◆ powModHelper()

static powModHelper | ( | BCMath | $x,
 |  | BCMath | $e,
 |  | BCMath | $n,
 |  |  | $class
 | ) |  |
staticprotected

Performs modular exponentiation.

Paramètres
BCMath | $x
BCMath | $e
BCMath | $n
string | $class
Renvoie
BCMath

Références $class, $n, $temp, et BCMath\normalize().

Référencé par BCMath\powModInner().

◆ prepareReduce()

static prepareReduce | ( | $x,
 |  | $n,
 |  | $class
 | ) |
staticprotected

Modular reduction preparation

Paramètres
string | $x
string | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
string

Références $n.

◆ squareReduce()

static squareReduce | ( | $x,
 |  | $n,
 |  | $class
 | ) |
staticprotected

Modular square

Paramètres
string | $x
string | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
string

Références $n.

Documentation des champs

◆ DATA

const DATA = 1

$cache[self::DATA] contains the cached data.

private

◆ VARIABLE

const VARIABLE = 0

Cache constants

$cache[self::VARIABLE] tells us whether or not the cached data is still valid.

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • Math/BigInteger/Engines/BCMath/Base.php


Joomla CMS: Référence de la classe BuiltIn

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • BuiltIn
Fonctions membres protégées statiques
Référence de la classe BuiltIn
+ Graphe d'héritage de BuiltIn:
BCMath Engine

Fonctions membres protégées statiques

static | powModHelper (BCMath $x, BCMath $e, BCMath $n)
- Fonctions membres protégées statiques hérités de BCMath
static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de BCMath
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de BCMath
static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de BCMath
const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de BCMath
initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ powModHelper()

static powModHelper | ( | BCMath | $x,
 |  | BCMath | $e,
 |  | BCMath | $n
 | ) |  |
staticprotected

Performs modular exponentiation.

Paramètres
BCMath | $x
BCMath | $e
BCMath | $n
Renvoie
BCMath

Références $n, $temp, et BCMath\normalize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BuiltIn.php


Joomla CMS: Référence de la classe DefaultEngine

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • DefaultEngine
Référence de la classe DefaultEngine
+ Graphe d'héritage de DefaultEngine:
Barrett Base BCMath Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de BCMath
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de BCMath
static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Barrett
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de BCMath
const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de BCMath
initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Barrett
static | reduce ($n, $m)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (BCMath $x, BCMath $e, BCMath $n, $class)
static | prepareReduce ($x, $n, $class)
static | multiplyReduce ($x, $y, $n, $class)
static | squareReduce ($x, $n, $class)
- Fonctions membres protégées statiques hérités de BCMath
static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • BCMath/DefaultEngine.php


Joomla CMS: Référence de la classe OpenSSL

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
  • OpenSSL
Référence de la classe OpenSSL
+ Graphe d'héritage de OpenSSL:
Montgomery Base PHP Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/BCMath/OpenSSL.php


Joomla CMS: Référence de la classe DefaultEngine

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • GMP
  • DefaultEngine
Fonctions membres protégées statiques
Référence de la classe DefaultEngine
+ Graphe d'héritage de DefaultEngine:
GMP Engine

Fonctions membres protégées statiques

static | powModHelper (GMP $x, GMP $e, GMP $n)
- Fonctions membres protégées statiques hérités de GMP
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de GMP
__construct ($x=0, $base=10)
toString ()
toBits ($twos_compliment=false)
toBytes ($twos_compliment=false)
add (GMP $y)
subtract (GMP $y)
multiply (GMP $x)
divide (GMP $y)
compare (GMP $y)
equals (GMP $x)
modInverse (GMP $n)
extendedGCD (GMP $n)
gcd (GMP $n)
abs ()
bitwise_and (GMP $x)
bitwise_or (GMP $x)
bitwise_xor (GMP $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
modPow (GMP $e, GMP $n)
powMod (GMP $e, GMP $n)
pow (GMP $n)
between (GMP $min, GMP $max)
createRecurringModuloFunction ()
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de GMP
static | isValidEngine ()
static | randomRangePrime (GMP $min, GMP $max)
static | randomRange (GMP $min, GMP $max)
static | min (GMP ... $nums)
static | max (GMP ... $nums)
static | scan1divide (GMP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de GMP
const | FAST_BITWISE = true
const | ENGINE_DIR = 'GMP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de GMP
initialize ($base)
powModInner (GMP $e, GMP $n)
normalize (GMP $result)
make_odd ()
testPrimality ($t)
rootInner ($n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ powModHelper()

static powModHelper | ( | GMP | $x,
 |  | GMP | $e,
 |  | GMP | $n
 | ) |  |
staticprotected

Performs modular exponentiation.

Paramètres
GMP | $x
GMP | $e
GMP | $n
Renvoie
GMP

Références $n, $temp, et GMP\normalize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • GMP/DefaultEngine.php


Joomla CMS: Référence de la classe Barrett

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • Barrett
Fonctions membres protégées statiques | Fonctions membres privées statiques
Référence de la classe Barrett
+ Graphe d'héritage de Barrett:
Base PHP Engine

Fonctions membres protégées statiques

static | reduce (array $n, array $m, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Fonctions membres privées statiques

static | regularBarrett (array $x, array $n, $class)
static | multiplyLower (array $x_value, $x_negative, array $y_value, $y_negative, $stop, $class)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ multiplyLower()

static multiplyLower | ( | array | $x_value,
 |  |  | $x_negative,
 |  | array | $y_value,
 |  |  | $y_negative,
 |  |  | $stop,
 |  |  | $class
 | ) |  |
staticprivate

Performs long multiplication up to $stop digits

If you're going to be doing array_slice($product->value, 0, $stop), some cycles can be saved.

Voir également
self::regularBarrett()
Paramètres
array | $x_value
bool | $x_negative
array | $y_value
bool | $y_negative
int | $stop
string | $class
Renvoie
array

Références $i, $temp, et false.

◆ reduce()

static reduce | ( | array | $n,
 |  | array | $m,
 |  |  | $class
 | ) |  |
staticprotected

Barrett Modular Reduction

See HAC 14.3.3 / MPM 6.2.5 for more information. Modified slightly, so as not to require negative numbers (initially, this script didn't support negative numbers).

Employs "folding", as described at thesis-149.pdf#page=66. To quote from it, "the idea [behind folding] is to find a value x' such that x (mod m) = x' (mod m), with x' being smaller than x."

Unfortunately, the "Barrett Reduction with Folding" algorithm described in thesis-149.pdf is not, as written, all that usable on account of (1) its not using reasonable radix points as discussed in MPM 6.2.2 and (2) the fact that, even with reasonable radix points, it only works when there are an even number of digits in the denominator. The reason for (2) is that (x >> 1) + (x >> 1) != x / 2 + x / 2. If x is even, they're the same, but if x is odd, they're not. See the in-line comments for details.

Paramètres
array | $n
array | $m
class-string<PHP> | $class
Renvoie
array

Références $class, $key, $n, $result, et $temp.

◆ regularBarrett()

static regularBarrett | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprivate

(Regular) Barrett Modular Reduction

For numbers with more than four digits BigInteger::_barrett() is faster. The difference between that and this is that this function does not fold the denominator into a smaller form.

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, $key, $n, $result, et $temp.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP/Reductions/Barrett.php


Joomla CMS: Référence de la classe Classic

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • Classic
Fonctions membres protégées statiques
Référence de la classe Classic
+ Graphe d'héritage de Classic:
Base PHP Engine

Fonctions membres protégées statiques

static | reduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ reduce()

static reduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Regular Division

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, $n, et $temp.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Classic.php


Joomla CMS: Référence de la classe EvalBarrett

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • EvalBarrett
Fonctions membres protégées statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe EvalBarrett
+ Graphe d'héritage de EvalBarrett:
Base PHP Engine DefaultEngine

Fonctions membres protégées statiques

static | reduce (array $n, array $m, $class)
static | generateCustomReduction (PHP $m, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Fonctions membres privées statiques

static | generateInlineTrim ($name)
static | generateInlineMultiply ($input, array $arr, $output, $class)
static | generateInlineAdd ($x, $y, $result, $class)
static | generateInlineSubtract2 ($known, $unknown, $result, $class)
static | generateInlineSubtract1 ($unknown, array $known, $result, $class)
static | generateInlineCompare (array $known, $unknown, $subcode)
static | float2string ($num)

Attributs privés statiques

static $custom_reduction

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ float2string()

static float2string ( $num )
staticprivate

Convert a float to a string

If you do echo floatval(pow(2, 52)) you'll get 4.6116860184274E+18. It /can/ be displayed without a loss of precision but displayed in this way there will be precision loss, hence the need for this method.

Paramètres
int | float $num
Renvoie
string

Références $temp, et PHP\abs().

◆ generateCustomReduction()

static generateCustomReduction | ( | PHP | $m,
 |  |  | $class
 | ) |  |
staticprotected

Generate Custom Reduction

Paramètres
PHP | $m
string | $class
Renvoie
callable

Références $class.

◆ generateInlineAdd()

static generateInlineAdd | ( | $x,
 |  | $y,
 |  | $result,
 |  | $class
 | ) |
staticprivate

Inline Addition

Paramètres
string | $x
string | $y
string | $result
string | $class
Renvoie
string

Références $result.

◆ generateInlineCompare()

static generateInlineCompare | ( | array | $known,
 |  |  | $unknown,
 |  |  | $subcode
 | ) |  |
staticprivate

Inline Comparison

If $unknown >= $known then loop

Paramètres
array | $known
string | $unknown
string | $subcode
Renvoie
string

Références $i.

◆ generateInlineMultiply()

static generateInlineMultiply | ( |  | $input,
 |  | array | $arr,
 |  |  | $output,
 |  |  | $class
 | ) |  |
staticprivate

Inline Multiply (unknown, known)

Paramètres
string | $input
array | $arr
string | $output
string | $class
Renvoie
string

Références $i, $input, et $output.

◆ generateInlineSubtract1()

static generateInlineSubtract1 | ( |  | $unknown,
 |  | array | $known,
 |  |  | $result,
 |  |  | $class
 | ) |  |
staticprivate

Inline Subtraction 1

For when $unknown is more digits than $known. This is the easier use case to optimize for.

Paramètres
string | $unknown
array | $known
string | $result
string | $class
Renvoie
string

Références $i, et $result.

◆ generateInlineSubtract2()

static generateInlineSubtract2 | ( | $known,
 |  | $unknown,
 |  | $result,
 |  | $class
 | ) |
staticprivate

Inline Subtraction 2

For when $known is more digits than $unknown. This is the harder use case to optimize for.

Paramètres
string | $known
string | $unknown
string | $result
string | $class
Renvoie
string

Références $result.

◆ generateInlineTrim()

static generateInlineTrim ( $name )
staticprivate

Inline Trim

Removes leading zeros

Paramètres
string $name
Renvoie
string

Références $name.

◆ reduce()

static reduce | ( | array | $n,
 |  | array | $m,
 |  |  | $class
 | ) |  |
staticprotected

Barrett Modular Reduction

This calls a dynamically generated loop unrolled function that's specific to a given modulo. Array lookups are avoided as are if statements testing for how many bits the host OS supports, etc.

Paramètres
array | $n
array | $m
string | $class
Renvoie
array

Références $n.

Documentation des champs

◆ $custom_reduction

$custom_reduction
staticprivate

Custom Reduction Function

Voir également
self::generateCustomReduction
La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP/Reductions/EvalBarrett.php


Joomla CMS: Référence de la classe Montgomery

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • Montgomery
Fonctions membres protégées statiques
Référence de la classe Montgomery
+ Graphe d'héritage de Montgomery:
Montgomery Base PHP Engine MontgomeryMult

Fonctions membres protégées statiques

static | prepareReduce (array $x, array $n, $class)
static | reduce (array $x, array $n, $class)
static | modInverse67108864 (array $x, $class)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ modInverse67108864()

static modInverse67108864 | ( | array | $x,
 |  |  | $class
 | ) |  |
staticprotected

Modular Inverse of a number mod 2**26 (eg. 67108864)

Based off of the bnpInvDigit function implemented and justified in the following URL:

http://www-cs-students.stanford.edu/~tjw/jsbn/jsbn.js

The following URL provides more info:

http://groups.google.com/group/sci.crypt/msg/7a137205c1be7d85

As for why we do all the bitmasking... strange things can happen when converting from floats to ints. For instance, on some computers, var_dump((int) -4294967297) yields int(-1) and on others, it yields int(-2147483648). To avoid problems stemming from this, we use bitmasks to guarantee that ints aren't auto-converted to floats. The outermost bitmask is present because without it, there's no guarantee that the "residue" returned would be the so-called "common residue". We use fmod, in the last step, because the maximum possible $x is 26 bits and the maximum $result is 16 bits. Thus, we have to be able to handle up to 40 bits, which only 64-bit floating points will support.

Thanks to Pedro Gimeno Fortea for input!

Paramètres
array | $x
string | $class
Renvoie
int

Références $result.

◆ prepareReduce()

static prepareReduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Prepare a number for use in Montgomery Modular Reductions

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, $n, et $temp.

◆ reduce()

static reduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Montgomery Multiply

Interleaves the montgomery reduction and long multiplication algorithms together as described in HAC 14.36

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, $i, $key, $n, $result, et $temp.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Math/BigInteger/Engines/PHP/Reductions/Montgomery.php


Joomla CMS: Référence de la classe MontgomeryMult

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • MontgomeryMult
Fonctions membres publiques statiques
Référence de la classe MontgomeryMult
+ Graphe d'héritage de MontgomeryMult:
Montgomery Montgomery Base PHP Engine

Fonctions membres publiques statiques

static | multiplyReduce (array $x, array $y, array $m, $class)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | prepareReduce (array $x, array $n, $class)
static | reduce (array $x, array $n, $class)
static | modInverse67108864 (array $x, $class)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ multiplyReduce()

static multiplyReduce | ( | array | $x,
 |  | array | $y,
 |  | array | $m,
 |  |  | $class
 | ) |  |
static

Montgomery Multiply

Interleaves the montgomery reduction and long multiplication algorithms together as described in HAC 14.36

Voir également
self::_prepMontgomery()
self::_montgomery() private
Paramètres
array | $x
array | $y
array | $m
class-string<PHP> | $class
Renvoie
array

Références $class, $i, $key, $n, $temp, et BigInteger\max().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MontgomeryMult.php


Joomla CMS: Référence de la classe PowerOfTwo

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
  • PowerOfTwo
Fonctions membres protégées statiques
Référence de la classe PowerOfTwo
+ Graphe d'héritage de PowerOfTwo:
Base PHP Engine

Fonctions membres protégées statiques

static | prepareReduce (array $x, array $n, $class)
static | reduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ prepareReduce()

static prepareReduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Prepare a number for use in Montgomery Modular Reductions

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, et $n.

◆ reduce()

static reduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Power Of Two Reduction

Paramètres
array | $x
array | $n
string | $class
Renvoie
array

Références $class, $n, $result, et $temp.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PowerOfTwo.php


Joomla CMS: Référence de la classe Base

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Base
Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques
Référence de la classe Base
+ Graphe d'héritage de Base:
PHP Engine Montgomery Barrett Classic EvalBarrett PowerOfTwo PKCS1 PKCS8 OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PSS PuTTY OpenSSL OpenSSL Montgomery DefaultEngine

Fonctions membres publiques statiques

static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées statiques

static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool

Références class.

◆ multiplyReduce()

static multiplyReduce | ( | array | $x,
 |  | array | $y,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Modular multiply

Paramètres
array | $x
array | $y
array | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
array

Références $class, $n, et $temp.

◆ powModHelper()

static powModHelper | ( | PHP | $x,
 |  | PHP | $e,
 |  | PHP | $n,
 |  |  | $class
 | ) |  |
staticprotected

Performs modular exponentiation.

The most naive approach to modular exponentiation has very unreasonable requirements, and and although the approach involving repeated squaring does vastly better, it, too, is impractical for our purposes. The reason being that division - by far the most complicated and time-consuming of the basic operations (eg. +,-,*,/) - occurs multiple times within it.

Modular reductions resolve this issue. Although an individual modular reduction takes more time then an individual division, when performed in succession (with the same modulo), they're a lot faster.

The two most commonly used modular reductions are Barrett and Montgomery reduction. Montgomery reduction, although faster, only works when the gcd of the modulo and of the base being used is 1. In RSA, when the base is a power of two, the modulo - a product of two primes - is always going to have a gcd of 1 (because the product of two odd numbers is odd), but what about when RSA isn't used?

In contrast, Barrett reduction has no such constraint. As such, some bigint implementations perform a Barrett reduction after every operation in the modpow function. Others perform Barrett reductions when the modulo is even and Montgomery reductions when the modulo is odd. BigInteger.java's modPow method, however, uses a trick involving the Chinese Remainder Theorem to factor the even modulo into two numbers - one odd and the other, a power of two - and recombine them, later. This is the method that this modPow function uses. Montgomery Reduction with Even Modulus elaborates.

Paramètres
PHP | $x
PHP | $e
PHP | $n
string | $class
Renvoie
PHP

Références $class, $n, $temp, et PHP\normalize().

Référencé par PHP\powModInner().

◆ prepareReduce()

static prepareReduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Modular reduction preparation

Paramètres
array | $x
array | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
array

Références $class, et $n.

◆ squareReduce()

static squareReduce | ( | array | $x,
 |  | array | $n,
 |  |  | $class
 | ) |  |
staticprotected

Modular square

Paramètres
array | $x
array | $n
string | $class
Voir également
self::slidingWindow()
Renvoie
array

Références $class, et $n.

Documentation des champs

◆ DATA

const DATA = 1

$cache[self::DATA] contains the cached data.

private

◆ VARIABLE

const VARIABLE = 0

Cache constants

$cache[self::VARIABLE] tells us whether or not the cached data is still valid.

private

La documentation de cette classe a été générée à partir du fichier suivant :
  • Math/BigInteger/Engines/PHP/Base.php


Joomla CMS: Référence de la classe DefaultEngine

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • DefaultEngine
Référence de la classe DefaultEngine
+ Graphe d'héritage de DefaultEngine:
EvalBarrett Base PHP Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de EvalBarrett
static | reduce (array $n, array $m, $class)
static | generateCustomReduction (PHP $m, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP/DefaultEngine.php


Joomla CMS: Référence de la classe Montgomery

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • Montgomery
Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe Montgomery
+ Graphe d'héritage de Montgomery:
Base PHP Engine PKCS1 PKCS8 OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PSS PuTTY OpenSSL OpenSSL Montgomery

Fonctions membres publiques statiques

static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Fonctions membres protégées statiques

static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool

Références class.

◆ slidingWindow()

static slidingWindow | ( | Engine | $x,
 |  | Engine | $e,
 |  | Engine | $n,
 |  |  | $class
 | ) |  |
staticprotected

Performs modular exponentiation.

T of Engine

Paramètres
Engine | $x
Engine | $e
Engine | $n
class-string<T> | $class
Renvoie
T

Références $class, $i, $n, $result, et $temp.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Math/BigInteger/Engines/PHP/Montgomery.php


Joomla CMS: Référence de la classe OpenSSL

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
  • OpenSSL
Référence de la classe OpenSSL
+ Graphe d'héritage de OpenSSL:
Montgomery Base PHP Engine

Membres hérités additionnels

- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)
- Fonctions membres publiques statiques hérités de Montgomery
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de Base
static | isValidEngine ()
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)
- Champs de données hérités de Base
const | VARIABLE = 0
const | DATA = 1
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)
- Fonctions membres protégées statiques hérités de Montgomery
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
- Fonctions membres protégées statiques hérités de Base
static | powModHelper (PHP $x, PHP $e, PHP $n, $class)
static | prepareReduce (array $x, array $n, $class)
static | multiplyReduce (array $x, array $y, array $n, $class)
static | squareReduce (array $x, array $n, $class)
- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/PHP/OpenSSL.php


Joomla CMS: Référence de la classe BCMath

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • BCMath
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe BCMath
+ Graphe d'héritage de BCMath:
Engine Base BuiltIn Barrett EvalBarrett DefaultEngine

Fonctions membres publiques

__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
add (BCMath $y)
subtract (BCMath $y)
multiply (BCMath $x)
divide (BCMath $y)
modInverse (BCMath $n)
extendedGCD (BCMath $n)
abs ()
bitwise_and (BCMath $x)
bitwise_or (BCMath $x)
bitwise_xor (BCMath $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
compare (BCMath $y)
equals (BCMath $x)
modPow (BCMath $e, BCMath $n)
powMod (BCMath $e, BCMath $n)
pow (BCMath $n)
between (BCMath $min, BCMath $max)
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | isValidEngine ()
static | randomRangePrime (BCMath $min, BCMath $max)
static | randomRange (BCMath $min, BCMath $max)
static | scan1divide (BCMath $r)
static | min (BCMath ... $nums)
static | max (BCMath ... $nums)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | FAST_BITWISE = false
const | ENGINE_DIR = 'BCMath'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées

initialize ($base)
powModInner (BCMath $e, BCMath $n)
normalize (BCMath $result)
make_odd ()
testSmallPrimes ()
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Fonctions membres protégées statiques

static | setBitmask ($bits)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $x = 0,
 |  | $base = 10
 | ) |

Default constructor

Paramètres
mixed | $x | integer Base-10 number or base-$base number if $base set.
int | $base
Voir également
parent::__construct()

Références $base, Symfony\Contracts\Service\__construct(), class, et value.

Documentation des fonctions membres

◆ abs()

abs ( )

Absolute value.

Renvoie
BCMath

Références $temp, Engine\$value, et value.

Référencé par BCMath\initialize().

◆ add()

add ( BCMath $y )

Adds two BigIntegers.

Paramètres
BCMath $y
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ between()

between | ( | BCMath | $min,
 |  | BCMath | $max
 | ) |  |

Tests BigInteger to see if it is between two integers, inclusive

Paramètres
BCMath | $min
BCMath | $max
Renvoie
bool

Références BCMath\compare().

◆ bitwise_and()

bitwise_and ( BCMath $x )

Logical And

Paramètres
BCMath $x
Renvoie
BCMath

Références Engine\bitwiseAndHelper().

◆ bitwise_leftShift()

bitwise_leftShift ( $shift )

Logical Left Shift

Shifts BigInteger's by $shift bits, effectively multiplying by 2**$shift.

Paramètres
int $shift
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ bitwise_or()

bitwise_or ( BCMath $x )

Logical Or

Paramètres
BCMath $x
Renvoie
BCMath

Références Engine\bitwiseXorHelper().

◆ bitwise_rightShift()

bitwise_rightShift ( $shift )

Logical Right Shift

Shifts BigInteger's by $shift bits, effectively dividing by 2**$shift.

Paramètres
int $shift
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ bitwise_xor()

bitwise_xor ( BCMath $x )

Logical Exclusive Or

Paramètres
BCMath $x
Renvoie
BCMath

Références Engine\bitwiseXorHelper().

◆ compare()

compare ( BCMath $y )

Compares two numbers.

Although one might think !$x->compare($y) means $x != $y, it, in fact, means the opposite. The reason for this is demonstrated thusly:

$x >

y

x->compare($y) > 0 $x <

y

x->compare($y) < 0 $x ==

y

x->compare($y) == 0

Note how the same comparison operator is used. If you want to test for equality, use $x->equals($y).

{

Références value.

Référencé par BCMath\between().

◆ divide()

divide ( BCMath $y )

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Paramètres
BCMath $y
Renvoie
array{static, static}

Références BCMath\normalize(), et value.

◆ equals()

equals ( BCMath $x )

Tests the equality of two numbers.

If you need to see if one number is greater than or less than another number, use BigInteger::compare()

Paramètres
BCMath $x
Renvoie
bool

Références value.

◆ extendedGCD()

extendedGCD ( BCMath $n )

Calculates the greatest common divisor and Bezout's identity.

Say you have 693 and 609. The GCD is 21. Bezout's identity states that there exist integers x and y such that 693*x + 609*y == 21. In point of fact, there are actually an infinite number of x and y combinations and which combination is returned is dependent upon which mode is in use. See Bezout's identity - Wikipedia for more information.

Paramètres
BCMath $n
Renvoie
array{gcd: static, x: static, y: static}

Références $b, $c, $n, $temp, Engine\$value, et BCMath\normalize().

◆ initialize()

initialize ( $base )
protected

Initialize a BCMath BigInteger Engine instance

Paramètres
int $base
Voir également
parent::__construct()

Références $base, $i, $temp, Engine\$value, BCMath\abs(), et value.

◆ isNegative()

isNegative ( )

Is Negative?

Renvoie
bool

Références value.

◆ isOdd()

isOdd ( )

Is Odd?

Renvoie
bool

Références value.

Référencé par BCMath\make_odd().

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool
Voir également
parent::__construct()

◆ make_odd()

make_odd ( )
protected

Make the current number odd

If the current number is odd it'll be unchanged. If it's even, one will be added to it.

Voir également
self::randomPrime()

Références BCMath\isOdd(), et value.

◆ max()

static max ( BCMath ... $nums )
static

Return the maximum BigInteger between an arbitrary number of BigIntegers.

Paramètres
BCMath ...$nums
Renvoie
BCMath

◆ min()

static min ( BCMath ... $nums )
static

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
BCMath ...$nums
Renvoie
BCMath

◆ modInverse()

modInverse ( BCMath $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
BCMath $n
Renvoie
false|BCMath

Références $n.

◆ modPow()

modPow | ( | BCMath | $e,
 |  | BCMath | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
BCMath | $e
BCMath | $n
Renvoie
BCMath

Références $n, et Engine\powModOuter().

◆ multiply()

multiply ( BCMath $x )

Multiplies two BigIntegers.

Paramètres
BCMath $x
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ negate()

negate ( )

Negate

Given $k, returns -$k

Renvoie
BCMath

Références $temp, $this, Engine\$value, et value.

◆ normalize()

normalize ( BCMath $result )
protected

Normalize

Removes leading zeros and truncates (if necessary) to maintain the appropriate precision

Paramètres
BCMath $result
Renvoie
BCMath

Références Engine\$bitmask, Engine\$precision, et $result.

Référencé par BCMath\add(), BCMath\bitwise_leftShift(), BCMath\bitwise_rightShift(), BCMath\divide(), BCMath\extendedGCD(), BCMath\multiply(), BCMath\pow(), BuiltIn\powModHelper(), Base\powModHelper(), et BCMath\subtract().

◆ pow()

pow ( BCMath $n )

Performs exponentiation.

Paramètres
BCMath $n
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ powMod()

powMod | ( | BCMath | $e,
 |  | BCMath | $n
 | ) |  |

Performs modular exponentiation.

Alias for modPow().

Paramètres
BCMath | $e
BCMath | $n
Renvoie
BCMath

Références $n, et Engine\powModOuter().

◆ powModInner()

powModInner | ( | BCMath | $e,
 |  | BCMath | $n
 | ) |  |
protected

Performs modular exponentiation.

Paramètres
BCMath | $e
BCMath | $n
Renvoie
BCMath

Références $class, $n, $this, class, et Base\powModHelper().

◆ randomRange()

static randomRange | ( | BCMath | $min,
 |  | BCMath | $max
 | ) |  |
static

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
BCMath | $min
BCMath | $max
Renvoie
BCMath

◆ randomRangePrime()

static randomRangePrime | ( | BCMath | $min,
 |  | BCMath | $max
 | ) |  |
static

Generate a random prime number between a range

If there's not a prime within the given range, false will be returned.

Paramètres
BCMath | $min
BCMath | $max
Renvoie
false|BCMath

◆ scan1divide()

static scan1divide ( BCMath $r )
static

Scan for 1 and right shift by that amount

ie. $s = gmp_scan1($n, 0) and $r = gmp_div_q($n, gmp_pow(gmp_init('2'), $s));

Paramètres
BCMath $r
Renvoie
int
Voir également
self::isPrime()

Références $r.

◆ setBitmask()

static setBitmask ( $bits )
staticprotected

Set Bitmask

Paramètres
int $bits
Renvoie
Engine
Voir également
self::setPrecision()

Références $temp, et class.

◆ subtract()

subtract ( BCMath $y )

Subtracts two BigIntegers.

Paramètres
BCMath $y
Renvoie
BCMath

Références $temp, BCMath\normalize(), et value.

◆ testBit()

testBit ( $x )

Tests if a bit is set

Renvoie
bool

Références value.

◆ testSmallPrimes()

testSmallPrimes ( )
protected

Test the number against small primes.

Voir également
self::isPrime()

Références $r, Engine\$value, et value.

◆ toBytes()

toBytes ( $twos_compliment = false )

Converts a BigInteger to a byte string (eg. base-256).

Paramètres
bool $twos_compliment
Renvoie
string

Références $temp, Engine\$value, et Engine\toBytesHelper().

◆ toString()

toString ( )

Converts a BigInteger to a base-10 number.

Renvoie
string

Références value.

Documentation des champs

◆ ENGINE_DIR

const ENGINE_DIR = 'BCMath'

Engine Directory

Voir également
parent::setModExpEngine protected

◆ FAST_BITWISE

const FAST_BITWISE = false

Can Bitwise operations be done fast?

Voir également
parent::bitwise_leftRotate()
parent::bitwise_rightRotate() protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/Math/BigInteger/Engines/BCMath.php


Joomla CMS: Référence de la classe Engine

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • Engine
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Engine
+ Graphe d'héritage de Engine:
BCMath GMP PHP Base BuiltIn DefaultEngine PHP32 PHP64 Base Barrett EvalBarrett Montgomery Barrett Classic EvalBarrett PowerOfTwo DefaultEngine PKCS1 PKCS8 OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PSS PuTTY OpenSSL OpenSSL Montgomery DefaultEngine

Fonctions membres publiques

__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const PRIMES

Fonctions membres protégées

toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Fonctions membres protégées statiques

static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Attributs protégés

$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex

Attributs protégés statiques

static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $x = 0,
 |  | $base = 10
 | ) |

Default constructor

Paramètres
int | numeric-string | $x | integer Base-10 number or base-$base number if $base set.
int | $base

Références $base, Engine\$is_negative, $temp, BigInteger\abs(), BigInteger\add(), Strings\bits2bin(), class, Laminas\Diactoros\initialize(), null, et value.

Documentation des fonctions membres

◆ __debugInfo()

__debugInfo ( )

__debugInfo() magic method

Will be called, automatically, when print_r() or var_dump() are called

Renvoie
array

Références Engine\$precision, $result, class, et Engine\toHex().

◆ __sleep()

__sleep ( )

Serialize

Will be called, automatically, when serialize() is called on a BigInteger object.

Renvoie
array

Références Engine\toHex().

◆ __toString()

__toString ( )

Converts a BigInteger to a base-10 number.

Renvoie
string

Références BigInteger\toString().

◆ __wakeup()

__wakeup ( )

Serialize

Will be called, automatically, when unserialize() is called on a BigInteger object.

Renvoie
void

Références Engine\$hex, $temp, Engine\setPrecision(), et value.

◆ base256_lshift()

static base256_lshift | ( | & | $x,
 |  |  | $shift
 | ) |  |
staticprotected

Logical Left Shift

Shifts binary strings $shift bits, essentially multiplying by 2**$shift.

Paramètres
string | $x
int | $shift
Renvoie
void

Références $i, et $temp.

◆ bitwise_leftRotate()

bitwise_leftRotate ( $shift )

Logical Left Rotate

Instead of the top x bits being dropped they're appended to the shifted bit string.

Paramètres
int $shift
Renvoie
Engine

Références $i, Engine\$precision, $result, $temp, $this, BigInteger\bitwise_leftShift(), BigInteger\bitwise_rightShift(), et BigInteger\toBytes().

Référencé par Engine\bitwise_rightRotate().

◆ bitwise_not()

bitwise_not ( )

Logical Not

Renvoie
Engine|string

Références $temp, class, et BigInteger\toBytes().

◆ bitwise_rightRotate()

bitwise_rightRotate ( $shift )

Logical Right Rotate

Instead of the bottom x bits being dropped they're prepended to the shifted bit string.

Paramètres
int $shift
Renvoie
Engine

Références Engine\bitwise_leftRotate().

◆ bitwise_split()

bitwise_split ( $split )

Bitwise Split

Splits BigInteger's into chunks of $split bits

Paramètres
int $split
Renvoie
Engine[]

Références $this, et class.

◆ bitwiseAndHelper()

bitwiseAndHelper ( Engine $x )
protected

Logical And

Paramètres
Engine $x
Renvoie
Engine

Références BigInteger\max(), et BigInteger\toBytes().

Référencé par PHP32\bitwise_and(), PHP64\bitwise_and(), et BCMath\bitwise_and().

◆ bitwiseOrHelper()

bitwiseOrHelper ( Engine $x )
protected

Logical Or

Paramètres
Engine $x
Renvoie
Engine

Références BigInteger\max(), et BigInteger\toBytes().

Référencé par PHP32\bitwise_or(), et PHP64\bitwise_or().

◆ bitwiseXorHelper()

bitwiseXorHelper ( Engine $x )
protected

Logical Exclusive Or

Paramètres
Engine $x
Renvoie
Engine

Références BigInteger\max(), et BigInteger\toBytes().

Référencé par BCMath\bitwise_or(), PHP32\bitwise_xor(), PHP64\bitwise_xor(), et BCMath\bitwise_xor().

◆ createRecurringModuloFunction()

createRecurringModuloFunction ( )

Create Recurring Modulo Function

Sometimes it may be desirable to do repeated modulos with the same number outside of modular exponentiation

Renvoie
callable

Références $class, $n, $this, Engine\$value, et class.

◆ extendedGCDHelper()

extendedGCDHelper ( Engine $n )
protected

Calculates the greatest common divisor and Bezout's identity.

Paramètres
Engine $n
Renvoie
array{gcd: Engine, x: Engine, y: Engine}

Références $b, $c, $n, Engine\$one, $temp, $this, et Engine\$zero.

Référencé par PHP32\extendedGCD(), et PHP64\extendedGCD().

◆ getLength()

getLength ( )

Return the size of a BigInteger in bits

Renvoie
int

Références Engine\toBits().

◆ getLengthInBytes()

getLengthInBytes ( )

Return the size of a BigInteger in bytes

Renvoie
int

Références BigInteger\toBytes().

Référencé par Engine\setupIsPrime().

◆ getPrecision()

getPrecision ( )

Get Precision

Returns the precision if it exists, -1 if it doesn't

Renvoie
int

Références Engine\$precision.

◆ isPrime()

isPrime ( $t = false )

Checks a numer to see if it's prime

Assuming the $t parameter is not set, this function has an error rate of 2**-80. The main motivation for the $t parameter is distributability. BigInteger::randomPrime() can be distributed across multiple pageloads on a website instead of just one.

Paramètres
int | bool $t
Renvoie
bool

Références Engine\setupIsPrime(), et Engine\testPrimality().

Référencé par Engine\randomRangePrimeOuter().

◆ jsonSerialize()

jsonSerialize ( )

JSON Serialize

Will be called, automatically, when json_encode() is called on a BigInteger object.

Références Engine\$precision, $result, et Engine\toHex().

◆ maxHelper()

static maxHelper ( array $nums )
staticprotected

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
array $nums
Renvoie
Engine

Références $i.

◆ minHelper()

static minHelper ( array $nums )
staticprotected

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
array $nums
Renvoie
Engine

Références $i.

◆ minMaxBits()

static minMaxBits ( $bits )
static

Returns the smallest and largest n-bit number

Paramètres
int $bits
Renvoie
array{min: static, max: static}

◆ powModOuter()

powModOuter | ( | Engine | $e,
 |  | Engine | $n
 | ) |  |
protected

Performs some pre-processing for powMod

Paramètres
Engine | $e
Engine | $n
Renvoie
static|false

Références $n, $temp, et BigInteger\modInverse().

Référencé par PHP32\modPow(), PHP64\modPow(), GMP\modPow(), BCMath\modPow(), PHP32\powMod(), PHP64\powMod(), GMP\powMod(), et BCMath\powMod().

◆ randomRangeHelper()

static randomRangeHelper | ( | Engine | $min,
 |  | Engine | $max
 | ) |  |
staticprotected

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
Engine | $min
Engine | $max
Renvoie
Engine

Références $size, $temp, class, et elseif.

◆ randomRangePrimeInner()

static randomRangePrimeInner | ( | Engine | $x,
 |  | Engine | $min,
 |  | Engine | $max
 | ) |  |
staticprotected

Performs some post-processing for randomRangePrime

Paramètres
Engine | $x
Engine | $min
Engine | $max
Renvoie
static|false

Références class.

◆ randomRangePrimeOuter()

static randomRangePrimeOuter | ( | Engine | $min,
 |  | Engine | $max
 | ) |  |
staticprotected

Performs some pre-processing for randomRangePrime

Paramètres
Engine | $min
Engine | $max
Renvoie
static|false

Références $temp, elseif, et Engine\isPrime().

◆ root()

root ( $n = 2 )

Calculates the nth root of a biginteger.

Paramètres
int $n
Renvoie
Engine

Références Engine\rootHelper().

◆ rootHelper()

rootHelper ( $n )
protected

Performs a few preliminary checks on root

Paramètres
int $n
Renvoie
Engine

Références $n, class, BigInteger\compare(), et Engine\rootInner().

Référencé par Engine\root().

◆ rootInner()

rootInner ( $n )
protected

Calculates the nth root of a biginteger.

Returns the nth root of a positive biginteger, where n defaults to 2

{

Références $g, $n, $root, $step, $this, et class.

Référencé par Engine\rootHelper().

◆ setBitmask()

static setBitmask ( $bits )
staticprotected

Set Bitmask

Renvoie
static
Paramètres
int $bits
Voir également
self::setPrecision()

◆ setModExpEngine()

static setModExpEngine ( $engine )
static

Sets engine type.

Throws an exception if the type is invalid

Paramètres
class-string<Engine> $engine

Références class.

◆ setPrecision()

setPrecision ( $bits )

Set Precision

Some bitwise operations give different results depending on the precision being used. Examples include left shift, not, and rotates.

Paramètres
int $bits

Références $temp, $this, et value.

Référencé par Engine\__wakeup().

◆ setupIsPrime()

setupIsPrime ( )
protected

Sets the $t parameter for primality testing

Renvoie
int

Références Engine\getLengthInBytes().

Référencé par Engine\isPrime().

◆ slidingWindow()

static slidingWindow | ( | Engine | $x,
 |  | Engine | $e,
 |  | Engine | $n,
 |  |  | $class
 | ) |  |
staticprotected

Sliding Window k-ary Modular Exponentiation

Based on HAC 14.85 / MPM 7.7. In a departure from those algorithims, however, this function performs a modular reduction after every multiplication and squaring operation. As such, this function has the same preconditions that the reductions being used do.

T of Engine

Paramètres
Engine | $x
Engine | $e
Engine | $n
class-string<T> | $class
Renvoie
T

Références $class, $i, $n, $result, $temp, class, et Engine\toBits().

◆ testPrimality()

testPrimality ( $t )
protected

Tests Primality

Uses the Miller-Rabin primality test. See HAC 4.24 for more info.

Paramètres
int $t
Renvoie
bool

Références $i, $n, $r, $this, et class.

Référencé par Engine\isPrime().

◆ toBits()

toBits ( $twos_compliment = false )

Converts a BigInteger to a bit string (eg. base-2).

Negative numbers are saved as positive numbers, unless $twos_compliment is set to true, at which point, they're saved as two's compliment.

Paramètres
bool $twos_compliment
Renvoie
string

Références Engine\$hex, $result, Strings\bin2bits(), BigInteger\compare(), et BigInteger\toBytes().

Référencé par Engine\getLength(), et Engine\slidingWindow().

◆ toBytesHelper()

toBytesHelper ( )
protected

Converts a BigInteger to a byte string (eg. base-256).

Negative numbers are saved as positive numbers, unless $twos_compliment is set to true, at which point, they're saved as two's compliment.

Renvoie
string

Références $temp, $this, BigInteger\add(), et BigInteger\compare().

Référencé par BCMath\toBytes(), GMP\toBytes(), et PHP\toBytes().

◆ toHex()

toHex ( $twos_compliment = false )

Converts a BigInteger to a hex string (eg. base-16).

Paramètres
bool $twos_compliment
Renvoie
string

Références BigInteger\toBytes().

Référencé par Engine\__debugInfo(), Engine\__sleep(), Engine\jsonSerialize(), et GMP\toBits().

Documentation des champs

◆ $bitmask

$bitmask = false
protected

Référencé par GMP\normalize(), BCMath\normalize(), et PHP\normalize().

◆ $hex

$hex
protected

Référencé par Engine\__wakeup(), GMP\toBits(), et Engine\toBits().

◆ $is_negative

$is_negative
protected

Référencé par Engine\__construct(), et PHP\isNegative().

◆ $isValidEngine

$isValidEngine
staticprotected

◆ $modexpEngine

$modexpEngine
staticprotected

◆ $one

$one = []
staticprotected

Référencé par Engine\extendedGCDHelper(), OpenSSH\load(), et PuTTY\load().

◆ $precision

$precision = -1
protected

Référencé par Engine\__debugInfo(), Engine\bitwise_leftRotate(), Engine\getPrecision(), Engine\jsonSerialize(), GMP\normalize(), BCMath\normalize(), et PHP\normalize().

◆ $reduce

$reduce
protected

◆ $two

$two = []
staticprotected

◆ $value

$value
protected

Référencé par BCMath\abs(), PHP\abs(), PHP\addHelper(), PHP\baseSquare(), PHP\bitwise_leftShift(), PHP\bitwise_rightShift(), PHP\bitwise_small_split(), PHP\bitwise_split(), GMP\createRecurringModuloFunction(), Engine\createRecurringModuloFunction(), BCMath\extendedGCD(), PHP32\initialize(), PHP64\initialize(), BCMath\initialize(), GMP\initialize(), PHP\initialize(), PHP\karatsubaSquare(), BCMath\negate(), GMP\negate(), PHP\normalize(), BCMath\testSmallPrimes(), PHP\testSmallPrimes(), BCMath\toBytes(), GMP\toString(), et PHP\trim().

◆ $zero

$zero = []
staticprotected

Référencé par Engine\extendedGCDHelper().

◆ PRIMES

const PRIMES
Valeur initiale :
= [
3, 5, 7, 11, 13, 17, 19, 23, 29, 31, 37, 41, 43, 47, 53, 59,
61, 67, 71, 73, 79, 83, 89, 97, 101, 103, 107, 109, 113, 127, 131, 137,
139, 149, 151, 157, 163, 167, 173, 179, 181, 191, 193, 197, 199, 211, 223, 227,
229, 233, 239, 241, 251, 257, 263, 269, 271, 277, 281, 283, 293, 307, 311, 313,
317, 331, 337, 347, 349, 353, 359, 367, 373, 379, 383, 389, 397, 401, 409, 419,
421, 431, 433, 439, 443, 449, 457, 461, 463, 467, 479, 487, 491, 499, 503, 509,
521, 523, 541, 547, 557, 563, 569, 571, 577, 587, 593, 599, 601, 607, 613, 617,
619, 631, 641, 643, 647, 653, 659, 661, 673, 677, 683, 691, 701, 709, 719, 727,
733, 739, 743, 751, 757, 761, 769, 773, 787, 797, 809, 811, 821, 823, 827, 829,
839, 853, 857, 859, 863, 877, 881, 883, 887, 907, 911, 919, 929, 937, 941, 947,
953, 967, 971, 977, 983, 991, 997,
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • Engine.php


Joomla CMS: Référence de la classe GMP

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • GMP
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques
Référence de la classe GMP
+ Graphe d'héritage de GMP:
Engine DefaultEngine

Fonctions membres publiques

__construct ($x=0, $base=10)
toString ()
toBits ($twos_compliment=false)
toBytes ($twos_compliment=false)
add (GMP $y)
subtract (GMP $y)
multiply (GMP $x)
divide (GMP $y)
compare (GMP $y)
equals (GMP $x)
modInverse (GMP $n)
extendedGCD (GMP $n)
gcd (GMP $n)
abs ()
bitwise_and (GMP $x)
bitwise_or (GMP $x)
bitwise_xor (GMP $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
modPow (GMP $e, GMP $n)
powMod (GMP $e, GMP $n)
pow (GMP $n)
between (GMP $min, GMP $max)
createRecurringModuloFunction ()
isOdd ()
testBit ($x)
isNegative ()
negate ()
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | isValidEngine ()
static | randomRangePrime (GMP $min, GMP $max)
static | randomRange (GMP $min, GMP $max)
static | min (GMP ... $nums)
static | max (GMP ... $nums)
static | scan1divide (GMP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | FAST_BITWISE = true
const | ENGINE_DIR = 'GMP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées

initialize ($base)
powModInner (GMP $e, GMP $n)
normalize (GMP $result)
make_odd ()
testPrimality ($t)
rootInner ($n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Fonctions membres protégées statiques

static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Membres hérités additionnels

- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $x = 0,
 |  | $base = 10
 | ) |

Default constructor

Paramètres
mixed | $x | integer Base-10 number or base-$base number if $base set.
int | $base
Voir également
parent::__construct()

Références $base, Symfony\Contracts\Service\__construct(), class, et value.

Documentation des fonctions membres

◆ abs()

abs ( )

Absolute value.

Renvoie
GMP public

Références $temp, et value.

Référencé par GMP\initialize().

◆ add()

add ( GMP $y )

Adds two BigIntegers.

Paramètres
GMP $y
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ between()

between | ( | GMP | $min,
 |  | GMP | $max
 | ) |  |

Tests BigInteger to see if it is between two integers, inclusive

Paramètres
GMP | $min
GMP | $max
Renvoie
bool

Références GMP\compare().

◆ bitwise_and()

bitwise_and ( GMP $x )

Logical And

Paramètres
GMP $x
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ bitwise_leftShift()

bitwise_leftShift ( $shift )

Logical Left Shift

Shifts BigInteger's by $shift bits, effectively multiplying by 2**$shift.

Paramètres
int $shift
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ bitwise_or()

bitwise_or ( GMP $x )

Logical Or

Paramètres
GMP $x
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ bitwise_rightShift()

bitwise_rightShift ( $shift )

Logical Right Shift

Shifts BigInteger's by $shift bits, effectively dividing by 2**$shift.

Paramètres
int $shift
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ bitwise_xor()

bitwise_xor ( GMP $x )

Logical Exclusive Or

Paramètres
GMP $x
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ compare()

compare ( GMP $y )

Compares two numbers.

Although one might think !$x->compare($y) means $x != $y, it, in fact, means the opposite. The reason for this is demonstrated thusly:

$x >

y

x->compare($y) > 0 $x <

y

x->compare($y) < 0 $x ==

y

x->compare($y) == 0

Note how the same comparison operator is used. If you want to test for equality, use $x->equals($y).

{

Références $r, et value.

Référencé par GMP\between(), et GMP\toBits().

◆ createRecurringModuloFunction()

createRecurringModuloFunction ( )

Create Recurring Modulo Function

Sometimes it may be desirable to do repeated modulos with the same number outside of modular exponentiation

Renvoie
callable

Références $temp, et Engine\$value.

◆ divide()

divide ( GMP $y )

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Paramètres
GMP $y
Renvoie
array{GMP, GMP}

Références GMP\normalize(), et value.

◆ equals()

equals ( GMP $x )

Tests the equality of two numbers.

If you need to see if one number is greater than or less than another number, use BigInteger::compare()

Paramètres
GMP $x
Renvoie
bool

Références value.

◆ extendedGCD()

extendedGCD ( GMP $n )

Calculates the greatest common divisor and Bezout's identity.

Say you have 693 and 609. The GCD is 21. Bezout's identity states that there exist integers x and y such that 693*x + 609*y == 21. In point of fact, there are actually an infinite number of x and y combinations and which combination is returned is dependent upon which mode is in use. See Bezout's identity - Wikipedia for more information.

Paramètres
GMP $n
Renvoie
GMP[]

Références $g, GMP\normalize(), et value.

◆ gcd()

gcd ( GMP $n )

Calculates the greatest common divisor

Say you have 693 and 609. The GCD is 21.

Paramètres
GMP $n
Renvoie
GMP

Références $r, GMP\normalize(), et value.

◆ initialize()

initialize ( $base )
protected

Initialize a GMP BigInteger Engine instance

Paramètres
int $base
Voir également
parent::__construct()

Références $base, $temp, Engine\$value, GMP\abs(), et value.

◆ isNegative()

isNegative ( )

Is Negative?

Renvoie
bool

Références value.

◆ isOdd()

isOdd ( )

Is Odd?

Renvoie
bool

Références value.

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool
Voir également
parent::__construct()

◆ make_odd()

make_odd ( )
protected

Make the current number odd

If the current number is odd it'll be unchanged. If it's even, one will be added to it.

Voir également
self::randomPrime()

Références value.

◆ max()

static max ( GMP ... $nums )
static

Return the maximum BigInteger between an arbitrary number of BigIntegers.

Paramètres
GMP ...$nums
Renvoie
GMP

◆ min()

static min ( GMP ... $nums )
static

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
GMP ...$nums
Renvoie
GMP

◆ modInverse()

modInverse ( GMP $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
GMP $n
Renvoie
false|GMP

Références $temp, false, GMP\normalize(), et value.

◆ modPow()

modPow | ( | GMP | $e,
 |  | GMP | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
GMP | $e
GMP | $n
Renvoie
GMP

Références $n, et Engine\powModOuter().

◆ multiply()

multiply ( GMP $x )

Multiplies two BigIntegers.

Paramètres
GMP $x
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ negate()

negate ( )

Negate

Given $k, returns -$k

Renvoie
GMP

Références $temp, $this, et Engine\$value.

◆ normalize()

normalize ( GMP $result )
protected

Normalize

Removes leading zeros and truncates (if necessary) to maintain the appropriate precision

Paramètres
GMP $result
Renvoie
GMP

Références Engine\$bitmask, Engine\$precision, et $result.

Référencé par GMP\add(), GMP\bitwise_and(), GMP\bitwise_leftShift(), GMP\bitwise_or(), GMP\bitwise_rightShift(), GMP\bitwise_xor(), GMP\divide(), GMP\extendedGCD(), GMP\gcd(), GMP\modInverse(), GMP\multiply(), GMP\pow(), DefaultEngine\powModHelper(), GMP\rootInner(), et GMP\subtract().

◆ pow()

pow ( GMP $n )

Performs exponentiation.

Paramètres
GMP $n
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ powMod()

powMod | ( | GMP | $e,
 |  | GMP | $n
 | ) |  |

Performs modular exponentiation.

Alias for modPow().

Paramètres
GMP | $e
GMP | $n
Renvoie
GMP

Références $n, et Engine\powModOuter().

◆ powModInner()

powModInner | ( | GMP | $e,
 |  | GMP | $n
 | ) |  |
protected

Performs modular exponentiation.

Paramètres
GMP | $e
GMP | $n
Renvoie
GMP

Références $class, $n, $this, et class.

◆ randomRange()

static randomRange | ( | GMP | $min,
 |  | GMP | $max
 | ) |  |
static

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
GMP | $min
GMP | $max
Renvoie
GMP

◆ randomRangePrime()

static randomRangePrime | ( | GMP | $min,
 |  | GMP | $max
 | ) |  |
static

Generate a random prime number between a range

If there's not a prime within the given range, false will be returned.

Paramètres
GMP | $min
GMP | $max
Renvoie
false|GMP

◆ randomRangePrimeInner()

static randomRangePrimeInner | ( | Engine | $x,
 |  | Engine | $min,
 |  | Engine | $max
 | ) |  |
staticprotected

Performs some post-processing for randomRangePrime

Paramètres
Engine | $x
Engine | $min
Engine | $max
Renvoie
GMP

Références value.

◆ rootInner()

rootInner ( $n )
protected

Calculates the nth root of a biginteger.

Returns the nth root of a positive biginteger, where n defaults to 2

Paramètres
int $n
Renvoie
GMP

Références $n, $root, GMP\normalize(), et value.

◆ scan1divide()

static scan1divide ( GMP $r )
static

Scan for 1 and right shift by that amount

ie. $s = gmp_scan1($n, 0) and $r = gmp_div_q($n, gmp_pow(gmp_init('2'), $s));

Paramètres
GMP $r
Renvoie
int

Références $r.

◆ subtract()

subtract ( GMP $y )

Subtracts two BigIntegers.

Paramètres
GMP $y
Renvoie
GMP

Références $temp, GMP\normalize(), et value.

◆ testBit()

testBit ( $x )

Tests if a bit is set

Renvoie
bool

Références value.

◆ testPrimality()

testPrimality ( $t )
protected

Tests Primality

Paramètres
int $t
Renvoie
bool

Références value.

◆ toBits()

toBits ( $twos_compliment = false )

Converts a BigInteger to a bit string (eg. base-2).

Negative numbers are saved as positive numbers, unless $twos_compliment is set to true, at which point, they're saved as two's compliment.

Paramètres
bool $twos_compliment
Renvoie
string

Références Engine\$hex, GMP\compare(), et Engine\toHex().

◆ toBytes()

toBytes ( $twos_compliment = false )

Converts a BigInteger to a byte string (eg. base-256).

Paramètres
bool $twos_compliment
Renvoie
string

Références $temp, Engine\toBytesHelper(), et value.

◆ toString()

toString ( )

Converts a BigInteger to a base-10 number.

Renvoie
string

Références Engine\$value.

Documentation des champs

◆ ENGINE_DIR

const ENGINE_DIR = 'GMP'

Engine Directory

Voir également
parent::setModExpEngine protected

◆ FAST_BITWISE

const FAST_BITWISE = true

Can Bitwise operations be done fast?

Voir également
parent::bitwise_leftRotate()
parent::bitwise_rightRotate() protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • GMP.php


Joomla CMS: Référence de la classe OpenSSL

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • OpenSSL
Fonctions membres publiques statiques
Référence de la classe OpenSSL

Fonctions membres publiques statiques

static | isValidEngine ()
static | powModHelper (Engine $x, Engine $e, Engine $n)

Documentation des fonctions membres

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Renvoie
bool

Références class.

◆ powModHelper()

static powModHelper | ( | Engine | $x,
 |  | Engine | $e,
 |  | Engine | $n
 | ) |  |
static

Performs modular exponentiation.

Paramètres
Engine | $x
Engine | $e
Engine | $n
Renvoie
Engine

Références $class, $key, $n, et $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/OpenSSL.php


Joomla CMS: Référence de la classe PHP

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres protégées statiques | Fonctions membres privées | Fonctions membres privées statiques
Référence de la classe PHP
+ Graphe d'héritage de PHP:
Engine PHP32 PHP64 Base Montgomery Barrett Classic EvalBarrett PowerOfTwo PKCS1 PKCS8 OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PuTTY Raw OpenSSH PKCS1 PKCS8 PSS PuTTY OpenSSL OpenSSL Montgomery DefaultEngine

Fonctions membres publiques

__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées

initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Fonctions membres protégées statiques

static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)

Fonctions membres privées

bitwise_small_split ($split)

Fonctions membres privées statiques

static | karatsuba (array $x_value, array $y_value)
static | divide_digit (array $dividend, $divisor)
static | int2bytes ($x)

Membres hérités additionnels

- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $x = 0,
 |  | $base = 10
 | ) |

Default constructor

Paramètres
mixed | $x | integer Base-10 number or base-$base number if $base set.
int | $base
Renvoie
PHP
Voir également
parent::__construct()

Références $base, Symfony\Contracts\Service\__construct(), class, et value.

Documentation des fonctions membres

◆ abs()

abs ( )

Absolute value.

Renvoie
PHP

Références $temp, et Engine\$value.

Référencé par EvalBarrett\float2string(), et PHP\initialize().

◆ addHelper()

static addHelper | ( | array | $x_value,
 |  |  | $x_negative,
 |  | array | $y_value,
 |  |  | $y_negative
 | ) |  |
staticprotected

Performs addition.

Paramètres
array | $x_value
bool | $x_negative
array | $y_value
bool | $y_negative
Renvoie
array

Références $i, $size, $temp, Engine\$value, elseif, et false.

◆ array_repeat()

static array_repeat | ( | $input,
 |  | $multiplier
 | ) |
staticprotected

Array Repeat

Paramètres
int | $input
int | $multiplier
Renvoie
array

Références $input.

◆ baseSquare()

static baseSquare ( array $value )
staticprotected

Performs traditional squaring on two BigIntegers

Squaring can be done faster than multiplying a number by itself can be. See HAC 14.2.4 / MPM 5.3 for more information.

Paramètres
array $value
Renvoie
array

Références $i, $temp, et Engine\$value.

◆ bitwise_leftShift()

bitwise_leftShift ( $shift )

Logical Left Shift

Shifts BigInteger's by $shift bits, effectively multiplying by 2**$shift.

Paramètres
int $shift
Renvoie
PHP

Références $temp, Engine\$value, et PHP\normalize().

◆ bitwise_rightShift()

bitwise_rightShift ( $shift )

Logical Right Shift

Shifts BigInteger's by $shift bits, effectively dividing by 2**$shift.

Paramètres
int $shift
Renvoie
PHP

Références $temp, Engine\$value, et PHP\normalize().

◆ bitwise_small_split()

bitwise_small_split ( $split )
private

Bitwise Split where $split < static::BASE

Paramètres
int $split
Renvoie
list<int>

Références $i, $val, Engine\$value, et elseif.

Référencé par PHP\bitwise_split(), et PHP\toBytes().

◆ bitwise_split()

bitwise_split ( $split )

Bitwise Split

Splits BigInteger's into chunks of $split bits

Paramètres
int $split
Renvoie
list<static>

Références $i, $temp, $val, Engine\$value, $width, et PHP\bitwise_small_split().

◆ compareHelper()

static compareHelper | ( | array | $x_value,
 |  |  | $x_negative,
 |  | array | $y_value,
 |  |  | $y_negative
 | ) |  |
staticprotected

Compares two numbers.

Paramètres
array | $x_value
bool | $x_negative
array | $y_value
bool | $y_negative
Renvoie
int
Voir également
static::compare()

Références $i, $result, $size, et BigInteger\max().

Référencé par PHP32\compare().

◆ convertToObj()

convertToObj ( array $arr )
protected

Convert an array / boolean to a PHP BigInteger object

Paramètres
array $arr
Renvoie
static

Références $result, et PHP\normalize().

Référencé par PHP32\add(), PHP64\add(), PHP32\multiply(), PHP64\multiply(), PHP32\subtract(), et PHP64\subtract().

◆ divide_digit()

static divide_digit | ( | array | $dividend,
 |  |  | $divisor
 | ) |  |
staticprivate

Divides a BigInteger by a regular integer

abc / x = a00 / x + b0 / x + c / x

Paramètres
array | $dividend
int | $divisor
Renvoie
array

Références $i, $result, et $temp.

Référencé par PHP\divideHelper().

◆ divideHelper()

divideHelper ( PHP $y )
protected

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Renvoie
array{static, static}

Références $i, $r, $temp, $this, class, PHP\divide_digit(), PHP\normalize(), et value.

Référencé par PHP32\divide(), et PHP64\divide().

◆ initialize()

initialize ( $base )
protected

Initialize a PHP BigInteger Engine instance

Paramètres
int $base
Voir également
parent::__construct()

Références $base, $temp, Engine\$value, PHP\abs(), PHP\int2bytes(), et value.

◆ int2bytes()

static int2bytes ( $x )
staticprivate

Converts 32-bit integers to bytes.

Paramètres
int $x
Renvoie
string

Référencé par PHP\initialize().

◆ isNegative()

isNegative ( )

Is Negative?

Renvoie
bool

Références Engine\$is_negative.

◆ isOdd()

isOdd ( )

Is Odd?

Renvoie
bool

Références value.

◆ karatsuba()

static karatsuba | ( | array | $x_value,
 |  | array | $y_value
 | ) |  |
staticprivate

Performs Karatsuba multiplication on two BigIntegers

See Karatsuba algorithm and MPM 5.2.3.

Paramètres
array | $x_value
array | $y_value
Renvoie
array

Références $temp, et BigInteger\min().

◆ karatsubaSquare()

static karatsubaSquare ( array $value )
staticprotected

Performs Karatsuba "squaring" on two BigIntegers

See Karatsuba algorithm and MPM 5.3.4.

Paramètres
array $value
Renvoie
array

Références $temp, et Engine\$value.

◆ lshift()

lshift ( $shift )
protected

Logical Left Shift

Shifts BigInteger's by $shift bits.

Paramètres
int $shift

Références $i, $temp, et value.

◆ make_odd()

make_odd ( )
protected

Make the current number odd

If the current number is odd it'll be unchanged. If it's even, one will be added to it.

Voir également
self::randomPrime()

Références value.

◆ multiplyHelper()

static multiplyHelper | ( | array | $x_value,
 |  |  | $x_negative,
 |  | array | $y_value,
 |  |  | $y_negative
 | ) |  |
staticprotected

Performs multiplication.

Paramètres
array | $x_value
bool | $x_negative
array | $y_value
bool | $y_negative
Renvoie
array

Références false, et BigInteger\min().

◆ negate()

negate ( )

Negate

Given $k, returns -$k

Renvoie
static

Références $temp, et $this.

◆ normalize()

normalize ( PHP $result )
protected

Normalize

Removes leading zeros and truncates (if necessary) to maintain the appropriate precision

Paramètres
PHP $result
Renvoie
static

Références Engine\$bitmask, $i, Engine\$precision, $result, Engine\$value, et BigInteger\min().

Référencé par PHP\bitwise_leftShift(), PHP\bitwise_rightShift(), PHP\convertToObj(), PHP\divideHelper(), et Base\powModHelper().

◆ pad()

pad ( $str )
protected

Pads strings so that unpack may be used on them

Paramètres
string $str
Renvoie
string

◆ powHelper()

powHelper ( PHP $n )
protected

Performs exponentiation.

Paramètres
PHP $n
Renvoie
PHP

Références $n, $temp, $this, et class.

Référencé par PHP32\pow(), et PHP64\pow().

◆ powModInner()

powModInner | ( | PHP | $e,
 |  | PHP | $n
 | ) |  |
protected

Performs modular exponentiation.

Paramètres
PHP | $e
PHP | $n
Renvoie
PHP

Références $class, $n, $this, class, et Base\powModHelper().

◆ regularMultiply()

static regularMultiply | ( | array | $x_value,
 |  | array | $y_value
 | ) |  |
staticprotected

Performs long multiplication on two BigIntegers

Modeled after 'multiply' in MutableBigInteger.java.

Paramètres
array | $x_value
array | $y_value
Renvoie
array

Références $i, et $temp.

◆ rshift()

rshift ( $shift )
protected

Logical Right Shift

Shifts BigInteger's by $shift bits.

Paramètres
int $shift

Références $i, $temp, et value.

◆ scan1divide()

static scan1divide ( PHP $r )
static

Scan for 1 and right shift by that amount

ie. $s = gmp_scan1($n, 0) and $r = gmp_div_q($n, gmp_pow(gmp_init('2'), $s));

Paramètres
PHP $r
Renvoie
int
Voir également
self::isPrime()

Références $i, $r, et $temp.

◆ square()

static square ( array $x )
staticprotected

Performs squaring

Paramètres
list<static> $x
Renvoie
list<static>

◆ subtractHelper()

static subtractHelper | ( | array | $x_value,
 |  |  | $x_negative,
 |  | array | $y_value,
 |  |  | $y_negative
 | ) |  |
static

Performs subtraction.

Paramètres
array | $x_value
bool | $x_negative
array | $y_value
bool | $y_negative
Renvoie
array

Références $i, $temp, elseif, et false.

◆ testBit()

testBit ( $x )

Tests if a bit is set

Renvoie
bool

Références value.

◆ testSmallPrimes()

testSmallPrimes ( )
protected

Test the number against small primes.

Voir également
self::isPrime()

Références $r, Engine\$value, et value.

◆ toBytes()

toBytes ( $twos_compliment = false )

Converts a BigInteger to a byte string (eg. base-256).

Paramètres
bool $twos_compliment
Renvoie
string

Références $result, PHP\bitwise_small_split(), Engine\toBytesHelper(), et value.

◆ toString()

toString ( )

Converts a BigInteger to a base-10 number.

Renvoie
string

Références $mod, $result, $temp, $this, et value.

Référencé par PSS\load().

◆ trim()

static trim ( array $value )
staticprotected

Trim

Removes leading zeros

Paramètres
list<static> $value
Renvoie
list<static>

Références $i, et Engine\$value.

Documentation des champs

◆ ENGINE_DIR

const ENGINE_DIR = 'PHP'

Engine Directory

Voir également
parent::setModExpEngine protected

◆ FAST_BITWISE

const FAST_BITWISE = true

Can Bitwise operations be done fast?

Voir également
parent::bitwise_leftRotate()
parent::bitwise_rightRotate() protected

◆ KARATSUBA_CUTOFF

const KARATSUBA_CUTOFF = 25

#- Karatsuba Cutoff

At what point do we switch between Karatsuba multiplication and schoolbook long multiplication?

private

◆ SIGN

const SIGN = 1

$result[self::SIGN] contains the sign.

◆ VALUE

const VALUE = 0

#+ Array constants

Rather than create a thousands and thousands of new BigInteger objects in repeated function calls to add() and multiply() or whatever, we'll just work directly on arrays, taking them in as parameters and returning them.

protected $result[self::VALUE] contains the value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP.php


Joomla CMS: Référence de la classe PHP32

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP32
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe PHP32
+ Graphe d'héritage de PHP32:
PHP Engine

Fonctions membres publiques

add (PHP32 $y)
subtract (PHP32 $y)
multiply (PHP32 $y)
divide (PHP32 $y)
modInverse (PHP32 $n)
extendedGCD (PHP32 $n)
gcd (PHP32 $n)
bitwise_and (PHP32 $x)
bitwise_or (PHP32 $x)
bitwise_xor (PHP32 $x)
compare (PHP32 $y)
equals (PHP32 $x)
modPow (PHP32 $e, PHP32 $n)
powMod (PHP32 $e, PHP32 $n)
pow (PHP32 $n)
between (PHP32 $min, PHP32 $max)
- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | isValidEngine ()
static | randomRangePrime (PHP32 $min, PHP32 $max)
static | randomRange (PHP32 $min, PHP32 $max)
static | min (PHP32 ... $nums)
static | max (PHP32 ... $nums)
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | BASE = 26
const | BASE_FULL = 0x4000000
const | MAX_DIGIT = 0x3FFFFFF
const | MSB = 0x2000000
const | MAX10 = 10000000
const | MAX10LEN = 7
const | MAX_DIGIT2 = 4503599627370496
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées

initialize ($base)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ add()

add ( PHP32 $y )

Adds two BigIntegers.

Paramètres
PHP32 $y
Renvoie
PHP32

Références $temp, PHP\convertToObj(), et value.

◆ between()

between | ( | PHP32 | $min,
 |  | PHP32 | $max
 | ) |  |

Tests BigInteger to see if it is between two integers, inclusive

Paramètres
PHP32 | $min
PHP32 | $max
Renvoie
bool

Références PHP32\compare().

◆ bitwise_and()

bitwise_and ( PHP32 $x )

Logical And

Paramètres
PHP32 $x
Renvoie
PHP32

Références Engine\bitwiseAndHelper().

◆ bitwise_or()

bitwise_or ( PHP32 $x )

Logical Or

Paramètres
PHP32 $x
Renvoie
PHP32

Références Engine\bitwiseOrHelper().

◆ bitwise_xor()

bitwise_xor ( PHP32 $x )

Logical Exclusive Or

Paramètres
PHP32 $x
Renvoie
PHP32

Références Engine\bitwiseXorHelper().

◆ compare()

compare ( PHP32 $y )

Compares two numbers.

Although one might think !$x->compare($y) means $x != $y, it, in fact, means the opposite. The reason for this is demonstrated thusly:

$x >

y

x->compare($y) > 0 $x <

y

x->compare($y) < 0 $x ==

y

x->compare($y) == 0

Note how the same comparison operator is used. If you want to test for equality, use $x->equals($y).

{

Références PHP\compareHelper(), et value.

Référencé par PHP32\between().

◆ divide()

divide ( PHP32 $y )

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Paramètres
PHP32 $y
Renvoie
array{PHP32, PHP32}

Références PHP\divideHelper().

◆ equals()

equals ( PHP32 $x )

Tests the equality of two numbers.

If you need to see if one number is greater than or less than another number, use BigInteger::compare()

Paramètres
PHP32 $x
Renvoie
bool

Références value.

◆ extendedGCD()

extendedGCD ( PHP32 $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
PHP32 $n
Renvoie
PHP32[]

Références Engine\extendedGCDHelper().

Référencé par PHP32\gcd().

◆ gcd()

gcd ( PHP32 $n )

Calculates the greatest common divisor

Say you have 693 and 609. The GCD is 21.

Paramètres
PHP32 $n
Renvoie
PHP32

Références PHP32\extendedGCD().

◆ initialize()

initialize ( $base )
protected

Initialize a PHP32 BigInteger Engine instance

Paramètres
int $base
Voir également
parent::initialize()

Références $base, $i, $step, $val, Engine\$value, Laminas\Diactoros\initialize(), et value.

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Voir également
parent::__construct()
Renvoie
bool

◆ max()

static max ( PHP32 ... $nums )
static

Return the maximum BigInteger between an arbitrary number of BigIntegers.

Paramètres
PHP32 ...$nums
Renvoie
PHP32

◆ min()

static min ( PHP32 ... $nums )
static

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
PHP32 ...$nums
Renvoie
PHP32

◆ modInverse()

modInverse ( PHP32 $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
PHP32 $n
Renvoie
false|PHP32

Références $n.

◆ modPow()

modPow | ( | PHP32 | $e,
 |  | PHP32 | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
PHP32 | $e
PHP32 | $n
Renvoie
PHP32

Références $n, et Engine\powModOuter().

◆ multiply()

multiply ( PHP32 $y )

Multiplies two BigIntegers.

Paramètres
PHP32 $y
Renvoie
PHP32

Références $temp, PHP\convertToObj(), et value.

◆ pow()

pow ( PHP32 $n )

Performs exponentiation.

Paramètres
PHP32 $n
Renvoie
PHP32

Références PHP\powHelper().

◆ powMod()

powMod | ( | PHP32 | $e,
 |  | PHP32 | $n
 | ) |  |

Performs modular exponentiation.

Alias for modPow().

Paramètres
PHP32 | $e
PHP32 | $n
Renvoie
PHP32

Références $n, et Engine\powModOuter().

◆ randomRange()

static randomRange | ( | PHP32 | $min,
 |  | PHP32 | $max
 | ) |  |
static

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
PHP32 | $min
PHP32 | $max
Renvoie
PHP32

◆ randomRangePrime()

static randomRangePrime | ( | PHP32 | $min,
 |  | PHP32 | $max
 | ) |  |
static

Generate a random prime number between a range

If there's not a prime within the given range, false will be returned.

Paramètres
PHP32 | $min
PHP32 | $max
Renvoie
false|PHP32

◆ subtract()

subtract ( PHP32 $y )

Subtracts two BigIntegers.

Paramètres
PHP32 $y
Renvoie
PHP32

Références $temp, PHP\convertToObj(), et value.

Documentation des champs

◆ BASE

const BASE = 26

◆ BASE_FULL

const BASE_FULL = 0x4000000

◆ MAX10

const MAX10 = 10000000

MAX10 in greatest MAX10LEN satisfying MAX10 = 10**MAX10LEN <= 2**BASE.

◆ MAX10LEN

const MAX10LEN = 7

MAX10LEN in greatest MAX10LEN satisfying MAX10 = 10**MAX10LEN <= 2**BASE.

◆ MAX_DIGIT

const MAX_DIGIT = 0x3FFFFFF

◆ MAX_DIGIT2

const MAX_DIGIT2 = 4503599627370496

◆ MSB

const MSB = 0x2000000
La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP32.php


Joomla CMS: Référence de la classe PHP64

  • phpseclib3
  • Math
  • BigInteger
  • Engines
  • PHP64
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées
Référence de la classe PHP64
+ Graphe d'héritage de PHP64:
PHP Engine

Fonctions membres publiques

add (PHP64 $y)
subtract (PHP64 $y)
multiply (PHP64 $y)
divide (PHP64 $y)
modInverse (PHP64 $n)
extendedGCD (PHP64 $n)
gcd (PHP64 $n)
bitwise_and (PHP64 $x)
bitwise_or (PHP64 $x)
bitwise_xor (PHP64 $x)
compare (PHP64 $y)
equals (PHP64 $x)
modPow (PHP64 $e, PHP64 $n)
powMod (PHP64 $e, PHP64 $n)
pow (PHP64 $n)
between (PHP64 $min, PHP64 $max)
- Fonctions membres publiques hérités de PHP
__construct ($x=0, $base=10)
toString ()
toBytes ($twos_compliment=false)
abs ()
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
isOdd ()
testBit ($x)
isNegative ()
negate ()
bitwise_split ($split)
- Fonctions membres publiques hérités de Engine
__construct ($x=0, $base=10)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
__sleep ()
__wakeup ()
jsonSerialize ()
__toString ()
__debugInfo ()
setPrecision ($bits)
getPrecision ()
bitwise_not ()
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | isValidEngine ()
static | randomRangePrime (PHP64 $min, PHP64 $max)
static | randomRange (PHP64 $min, PHP64 $max)
static | min (PHP64 ... $nums)
static | max (PHP64 ... $nums)
- Fonctions membres publiques statiques hérités de PHP
static | subtractHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | scan1divide (PHP $r)
- Fonctions membres publiques statiques hérités de Engine
static | setModExpEngine ($engine)
static | minMaxBits ($bits)

Champs de données

const | BASE = 31
const | BASE_FULL = 0x80000000
const | MAX_DIGIT = 0x7FFFFFFF
const | MSB = 0x40000000
const | MAX10 = 1000000000
const | MAX10LEN = 9
const | MAX_DIGIT2 = 4611686018427387904
- Champs de données hérités de PHP
const | VALUE = 0
const | SIGN = 1
const | KARATSUBA_CUTOFF = 25
const | FAST_BITWISE = true
const | ENGINE_DIR = 'PHP'
- Champs de données hérités de Engine
const | PRIMES

Fonctions membres protégées

initialize ($base)
- Fonctions membres protégées hérités de PHP
initialize ($base)
pad ($str)
divideHelper (PHP $y)
convertToObj (array $arr)
normalize (PHP $result)
lshift ($shift)
rshift ($shift)
powModInner (PHP $e, PHP $n)
make_odd ()
testSmallPrimes ()
powHelper (PHP $n)
- Fonctions membres protégées hérités de Engine
toBytesHelper ()
powModOuter (Engine $e, Engine $n)
setupIsPrime ()
testPrimality ($t)
rootHelper ($n)
rootInner ($n)
extendedGCDHelper (Engine $n)
bitwiseAndHelper (Engine $x)
bitwiseOrHelper (Engine $x)
bitwiseXorHelper (Engine $x)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de PHP
static | addHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | multiplyHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | regularMultiply (array $x_value, array $y_value)
static | compareHelper (array $x_value, $x_negative, array $y_value, $y_negative)
static | trim (array $value)
static | array_repeat ($input, $multiplier)
static | square (array $x)
static | baseSquare (array $value)
static | karatsubaSquare (array $value)
- Fonctions membres protégées statiques hérités de Engine
static | setBitmask ($bits)
static | base256_lshift (&$x, $shift)
static | slidingWindow (Engine $x, Engine $e, Engine $n, $class)
static | randomRangePrimeOuter (Engine $min, Engine $max)
static | randomRangeHelper (Engine $min, Engine $max)
static | randomRangePrimeInner (Engine $x, Engine $min, Engine $max)
static | minHelper (array $nums)
static | maxHelper (array $nums)
- Attributs protégés hérités de Engine
$value
$is_negative
$precision = -1
$bitmask = false
$reduce
$hex
- Attributs protégés statiques hérités de Engine
static | $zero = []
static | $one = []
static | $two = []
static | $modexpEngine
static | $isValidEngine

Documentation des fonctions membres

◆ add()

add ( PHP64 $y )

Adds two BigIntegers.

Paramètres
PHP64 $y
Renvoie
PHP64

Références $temp, PHP\convertToObj(), et value.

◆ between()

between | ( | PHP64 | $min,
 |  | PHP64 | $max
 | ) |  |

Tests BigInteger to see if it is between two integers, inclusive

Paramètres
PHP64 | $min
PHP64 | $max
Renvoie
bool

Références PHP64\compare().

◆ bitwise_and()

bitwise_and ( PHP64 $x )

Logical And

Paramètres
PHP64 $x
Renvoie
PHP64

Références Engine\bitwiseAndHelper().

◆ bitwise_or()

bitwise_or ( PHP64 $x )

Logical Or

Paramètres
PHP64 $x
Renvoie
PHP64

Références Engine\bitwiseOrHelper().

◆ bitwise_xor()

bitwise_xor ( PHP64 $x )

Logical Exclusive Or

Paramètres
PHP64 $x
Renvoie
PHP64

Références Engine\bitwiseXorHelper().

◆ compare()

compare ( PHP64 $y )

Compares two numbers.

Although one might think !$x->compare($y) means $x != $y, it, in fact, means the opposite. The reason for this is demonstrated thusly:

$x >

y

x->compare($y) > 0 $x <

y

x->compare($y) < 0 $x ==

y

x->compare($y) == 0

Note how the same comparison operator is used. If you want to test for equality, use $x->equals($y).

{

Références value.

Référencé par PHP64\between().

◆ divide()

divide ( PHP64 $y )

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Paramètres
PHP64 $y
Renvoie
array{PHP64, PHP64}

Références PHP\divideHelper().

◆ equals()

equals ( PHP64 $x )

Tests the equality of two numbers.

If you need to see if one number is greater than or less than another number, use BigInteger::compare()

Paramètres
PHP64 $x
Renvoie
bool

Références value.

◆ extendedGCD()

extendedGCD ( PHP64 $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
PHP64 $n
Renvoie
PHP64[]

Références Engine\extendedGCDHelper().

Référencé par PHP64\gcd().

◆ gcd()

gcd ( PHP64 $n )

Calculates the greatest common divisor

Say you have 693 and 609. The GCD is 21.

Paramètres
PHP64 $n
Renvoie
PHP64

Références PHP64\extendedGCD().

◆ initialize()

initialize ( $base )
protected

Initialize a PHP64 BigInteger Engine instance

Paramètres
int $base
Voir également
parent::initialize()

Références $base, $i, $step, $temp, $val, Engine\$value, Laminas\Diactoros\initialize(), et value.

◆ isValidEngine()

static isValidEngine ( )
static

Test for engine validity

Voir également
parent::__construct()
Renvoie
bool

◆ max()

static max ( PHP64 ... $nums )
static

Return the maximum BigInteger between an arbitrary number of BigIntegers.

Paramètres
PHP64 ...$nums
Renvoie
PHP64

◆ min()

static min ( PHP64 ... $nums )
static

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
PHP64 ...$nums
Renvoie
PHP64

◆ modInverse()

modInverse ( PHP64 $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
PHP64 $n
Renvoie
false|PHP64

Références $n.

◆ modPow()

modPow | ( | PHP64 | $e,
 |  | PHP64 | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
PHP64 | $e
PHP64 | $n
Renvoie
PHP64

Références $n, et Engine\powModOuter().

◆ multiply()

multiply ( PHP64 $y )

Multiplies two BigIntegers.

Paramètres
PHP64 $y
Renvoie
PHP64

Références $temp, PHP\convertToObj(), et value.

◆ pow()

pow ( PHP64 $n )

Performs exponentiation.

Paramètres
PHP64 $n
Renvoie
PHP64

Références PHP\powHelper().

◆ powMod()

powMod | ( | PHP64 | $e,
 |  | PHP64 | $n
 | ) |  |

Performs modular exponentiation.

Alias for modPow().

Paramètres
PHP64 | $e
PHP64 | $n
Renvoie
PHP64|false

Références $n, et Engine\powModOuter().

◆ randomRange()

static randomRange | ( | PHP64 | $min,
 |  | PHP64 | $max
 | ) |  |
static

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
PHP64 | $min
PHP64 | $max
Renvoie
PHP64

◆ randomRangePrime()

static randomRangePrime | ( | PHP64 | $min,
 |  | PHP64 | $max
 | ) |  |
static

Generate a random prime number between a range

If there's not a prime within the given range, false will be returned.

Paramètres
PHP64 | $min
PHP64 | $max
Renvoie
false|PHP64

◆ subtract()

subtract ( PHP64 $y )

Subtracts two BigIntegers.

Paramètres
PHP64 $y
Renvoie
PHP64

Références $temp, PHP\convertToObj(), et value.

Documentation des champs

◆ BASE

const BASE = 31

◆ BASE_FULL

const BASE_FULL = 0x80000000

◆ MAX10

const MAX10 = 1000000000

MAX10 in greatest MAX10LEN satisfying MAX10 = 10**MAX10LEN <= 2**BASE.

◆ MAX10LEN

const MAX10LEN = 9

MAX10LEN in greatest MAX10LEN satisfying MAX10 = 10**MAX10LEN <= 2**BASE.

◆ MAX_DIGIT

const MAX_DIGIT = 0x7FFFFFFF

◆ MAX_DIGIT2

const MAX_DIGIT2 = 4611686018427387904

◆ MSB

const MSB = 0x40000000
La documentation de cette classe a été générée à partir du fichier suivant :
  • PHP64.php


Joomla CMS: Référence de la classe Integer

  • phpseclib3
  • Math
  • BinaryField
  • Integer
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe Integer
+ Graphe d'héritage de Integer:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ($instanceID, $num='')
equals (self $x)
compare (self $x)
add (self $y)
subtract (self $x)
multiply (self $y)
modInverse ()
divide (self $x)
negate ()
toBytes ()
toHex ()
toBits ()
toBigInteger ()
__toString ()
__debugInfo ()
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()
- Fonctions membres publiques hérités de CBORObject
getNormalizedData (bool $ignoreTags=false)

Fonctions membres publiques statiques

static | setModulo ($instanceID, $modulo)
static | setRecurringModuloFunction ($instanceID, callable $function)
static | getModulo ($instanceID)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Attributs protégés

$value
$instanceID
- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Attributs protégés statiques

static | $modulo
static | $reduce

Fonctions membres privées statiques

static | checkInstance (self $x, self $y)
static | deg ($x)
static | polynomialDivide ($x, $y)
static | regularPolynomialMultiply ($x, $y)
static | polynomialMultiply ($x, $y)
static | subMultiply ($x, $y)
static | subAdd2 ($x, $y)
static | subAdd3 ($x, $y, $z)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $instanceID,
 |  | $num = ''
 | ) |

Default constructor

Références Integer\$instanceID, Integer\$reduce, et value.

Documentation des fonctions membres

◆ __debugInfo()

__debugInfo ( )

__debugInfo() magic method

public

Références Integer\toHex().

◆ __toString()

__toString ( )

__toString() magic method

public

Implémente CBORObject.

Références Integer\toBigInteger().

◆ add()

add ( self $y )

Adds two BinaryFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $this, et value.

Référencé par Integer\subtract().

◆ checkInstance()

static checkInstance | ( | self | $x,
 |  | self | $y
 | ) |  |
staticprivate

Tests a parameter to see if it's of the right instance

Throws an exception if the incorrect class is being utilized

◆ compare()

compare ( self $x )

Compares two numbers.

Renvoie
int

Références $b, $this, et Integer\$value.

Référencé par Prime\getJSFPoints().

◆ deg()

static deg ( $x )
staticprivate

Returns the degree of the polynomial

Paramètres
string $x
Renvoie
int

◆ divide()

divide ( self $x )

Divides two PrimeFieldIntegers.

Renvoie
static

Références $this, et Integer\multiply().

◆ equals()

equals ( self $x )

Tests the equality of two numbers.

Renvoie
bool

Références $this, et value.

◆ getModulo()

static getModulo ( $instanceID )
static

Returns the modulo

Renvoie
string

Références Integer\$instanceID.

Référencé par BinaryField\getLength(), et BinaryField\getLengthInBytes().

◆ modInverse()

modInverse ( )

Returns the modular inverse of a BinaryFieldInteger

Renvoie
static

Références Integer\$instanceID, $r, $temp, et Integer\$value.

◆ multiply()

multiply ( self $y )

Multiplies two BinaryFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $this, et value.

Référencé par Integer\divide().

◆ negate()

negate ( )

Negate

A negative number can be written as 0-12. With modulos, 0 is the same thing as the modulo so 0-12 is the same thing as modulo-12

Renvoie
object

Références Integer\$instanceID, et value.

◆ polynomialDivide()

static polynomialDivide | ( | $x,
 |  | $y
 | ) |
staticprivate

Perform polynomial division

Renvoie
string[] https://en.wikipedia.org/wiki/Polynomial_greatest_common_divisor#Euclidean_division

Références $r, et BinaryField\base2ToBase256().

◆ polynomialMultiply()

static polynomialMultiply | ( | $x,
 |  | $y
 | ) |
staticprivate

Perform polynomial multiplation

Uses karatsuba multiplication to reduce x-bit multiplications to a series of 32-bit multiplications

Renvoie
string https://en.wikipedia.org/wiki/Karatsuba_algorithm

◆ regularPolynomialMultiply()

static regularPolynomialMultiply | ( | $x,
 |  | $y
 | ) |
staticprivate

Perform polynomial multiplation in the traditional way

Renvoie
string https://en.wikipedia.org/wiki/Finite_field_arithmetic#Multiplication

Références $i, $result, $size, $temp, BinaryField\base256ToBase2(), et BinaryField\base2ToBase256().

◆ setModulo()

static setModulo | ( | $instanceID,
 |  | $modulo
 | ) |
static

Set the modulo for a given instance

Paramètres
int | $instanceID
string | $modulo

Références Integer\$instanceID, et Integer\$modulo.

Référencé par BinaryField\__construct().

◆ setRecurringModuloFunction()

static setRecurringModuloFunction | ( |  | $instanceID,
 |  | callable | $function
 | ) |  |
static

Set the modulo for a given instance

Références $function, et Integer\$instanceID.

Référencé par BinaryField\__construct().

◆ subAdd2()

static subAdd2 | ( | $x,
 |  | $y
 | ) |
staticprivate

Adds two numbers

Paramètres
string | $x
string | $y
Renvoie
string

◆ subAdd3()

static subAdd3 | ( | $x,
 |  | $y,
 |  | $z
 | ) |
staticprivate

Adds three numbers

Paramètres
string | $x
string | $y
Renvoie
string

◆ subMultiply()

static subMultiply | ( | $x,
 |  | $y
 | ) |
staticprivate

Perform polynomial multiplication on 2x 32-bit numbers, returning a 64-bit number

Paramètres
string | $x
string | $y
Renvoie
string https://www.bearssl.org/constanttime.html#ghash-for-gcm

◆ subtract()

subtract ( self $x )

Subtracts two BinaryFieldIntegers.

Renvoie
static

Références Integer\add().

◆ toBigInteger()

toBigInteger ( )

Converts an Integer to a BigInteger

Renvoie
string

Références value.

Référencé par Integer\__toString(), et Prime\getJSFPoints().

◆ toBits()

toBits ( )

Converts an Integer to a bit string (eg. base-2).

Renvoie
string

Références BinaryField\base256ToBase2(), et value.

◆ toBytes()

toBytes ( )

Converts an Integer to a byte string (eg. base-256).

Renvoie
string

Références value.

Référencé par Integer\toHex().

◆ toHex()

toHex ( )

Converts an Integer to a hex string (eg. base-16).

Renvoie
string

Références Integer\toBytes().

Référencé par Integer\__debugInfo().

Documentation des champs

◆ $instanceID

$instanceID
protected

Référencé par Integer\__construct(), Integer\add(), Integer\getModulo(), Integer\modInverse(), Integer\multiply(), Integer\negate(), Integer\setModulo(), et Integer\setRecurringModuloFunction().

◆ $modulo

$modulo
staticprotected

Référencé par Integer\setModulo().

◆ $reduce

$reduce
staticprotected

Référencé par Integer\__construct().

◆ $value

$value
protected

Référencé par Integer\compare(), et Integer\modInverse().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Math/BinaryField/Integer.php


Joomla CMS: Référence de la classe Integer

  • phpseclib3
  • Math
  • Common
  • FiniteField
  • Integer
Fonctions membres publiques
Référence de la classe Integer
+ Graphe d'héritage de Integer:

Fonctions membres publiques

jsonSerialize ()
toHex ()

Documentation des fonctions membres

◆ jsonSerialize()

jsonSerialize ( )

JSON Serialize

Will be called, automatically, when json_encode() is called on a BigInteger object.

PHP Serialize isn't supported because unserializing would require the factory be serialized as well and that just sounds like too much

Références Integer\toHex().

◆ toHex()

toHex ( )
abstract

Converts an Integer to a hex string (eg. base-16).

Renvoie
string

Référencé par Integer\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Math/Common/FiniteField/Integer.php


Joomla CMS: Référence de la classe FiniteField

  • phpseclib3
  • Math
  • Common
  • FiniteField
Référence de la classe FiniteField
+ Graphe d'héritage de FiniteField:
BinaryField PrimeField
La documentation de cette classe a été générée à partir du fichier suivant :
  • FiniteField.php


Joomla CMS: Référence de la classe Integer

  • phpseclib3
  • Math
  • PrimeField
  • Integer
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs protégés statiques
Référence de la classe Integer
+ Graphe d'héritage de Integer:
TagObject AbstractCBORObject CBORObject

Fonctions membres publiques

__construct ($instanceID, BigInteger $num=null)
equals (self $x)
compare (self $x)
add (self $x)
subtract (self $x)
multiply (self $x)
divide (self $x)
pow (BigInteger $x)
squareRoot ()
isOdd ()
negate ()
toBytes ()
toHex ()
toBits ()
getNAF ($w=1)
toBigInteger ()
__toString ()
__debugInfo ()
- Fonctions membres publiques hérités de TagObject
__construct (int $additionalInformation, ?string $data, CBORObject $object)
__toString ()
getValue ()
- Fonctions membres publiques hérités de AbstractCBORObject
__construct (int $majorType, int $additionalInformation)
__toString ()
getMajorType ()
getAdditionalInformation ()
- Fonctions membres publiques hérités de CBORObject
getNormalizedData (bool $ignoreTags=false)

Fonctions membres publiques statiques

static | setModulo ($instanceID, BigInteger $modulo)
static | setRecurringModuloFunction ($instanceID, callable $function)
static | cleanupCache ($instanceID)
static | getModulo ($instanceID)
static | checkInstance (self $x, self $y)
- Fonctions membres publiques statiques hérités de TagObject
static | getTagId ()
static | createFromLoadedData (int $additionalInformation, ?string $data, CBORObject $object)

Attributs protégés

$value
$instanceID
- Attributs protégés hérités de TagObject
$data
$object
- Attributs protégés hérités de AbstractCBORObject
$additionalInformation

Attributs protégés statiques

static | $modulo
static | $reduce
static | $zero

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $instanceID,
 |  | BigInteger | $num = null
 | ) |  |

Default constructor

Paramètres
int $instanceID

Références Integer\$instanceID, Integer\$reduce, class, et value.

Documentation des fonctions membres

◆ __debugInfo()

__debugInfo ( )

__debugInfo() magic method

public

Renvoie
array

Références Integer\toHex().

◆ __toString()

__toString ( )

__toString() magic method

public

Renvoie
string

Implémente CBORObject.

Références Integer\$value.

◆ add()

add ( self $x )

Adds two PrimeFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $temp, $this, et value.

◆ checkInstance()

static checkInstance | ( | self | $x,
 |  | self | $y
 | ) |  |
static

Tests a parameter to see if it's of the right instance

Throws an exception if the incorrect class is being utilized

Renvoie
void

◆ cleanupCache()

static cleanupCache ( $instanceID )
static

Delete the modulo for a given instance

Références Integer\$instanceID.

Référencé par PrimeField\__destruct().

◆ compare()

compare ( self $x )

Compares two numbers.

Renvoie
int

Références $this, et value.

◆ divide()

divide ( self $x )

Divides two PrimeFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $this, et value.

◆ equals()

equals ( self $x )

Tests the equality of two numbers.

Renvoie
bool

Références $this, et value.

Référencé par Integer\squareRoot().

◆ getModulo()

static getModulo ( $instanceID )
static

Returns the modulo

Paramètres
int $instanceID
Renvoie
BigInteger

Références Integer\$instanceID.

Référencé par PrimeField\getLength(), PrimeField\getLengthInBytes(), et PrimeField\randomInteger().

◆ getNAF()

getNAF ( $w = 1 )

Returns the w-ary non-adjacent form (wNAF)

Paramètres
int $w optional
Renvoie
array<int, int>

Références $i, class, et Integer\toBigInteger().

◆ isOdd()

isOdd ( )

Is Odd?

Renvoie
bool

Références value.

◆ multiply()

multiply ( self $x )

Multiplies two PrimeFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $this, et value.

◆ negate()

negate ( )

Negate

A negative number can be written as 0-12. With modulos, 0 is the same thing as the modulo so 0-12 is the same thing as modulo-12

Renvoie
static

Références Integer\$instanceID, et value.

◆ pow()

pow ( BigInteger $x )

Performs power operation on a PrimeFieldInteger.

Renvoie
static

Références Integer\$instanceID, $temp, et value.

◆ setModulo()

static setModulo | ( |  | $instanceID,
 |  | BigInteger | $modulo
 | ) |  |
static

Set the modulo for a given instance

Paramètres
int $instanceID
Renvoie
void

Références Integer\$instanceID, et Integer\$modulo.

Référencé par PrimeField\__construct().

◆ setRecurringModuloFunction()

static setRecurringModuloFunction | ( |  | $instanceID,
 |  | callable | $function
 | ) |  |
static

Set the modulo for a given instance

Paramètres
int $instanceID
Renvoie
void

Références $function, Integer\$instanceID, et class.

Référencé par PrimeField\__construct().

◆ squareRoot()

squareRoot ( )

Calculates the square root

static|false

Références $b, $c, $i, Integer\$instanceID, $r, Integer\$reduce, $temp, Integer\equals(), BigInteger\scan1divide(), et value.

◆ subtract()

subtract ( self $x )

Subtracts two PrimeFieldIntegers.

Renvoie
static

Références Integer\$instanceID, $temp, $this, et value.

◆ toBigInteger()

toBigInteger ( )

Converts an Integer to a BigInteger

Renvoie
BigInteger

Références Integer\$value.

Référencé par Integer\getNAF().

◆ toBits()

toBits ( )

Converts an Integer to a bit string (eg. base-2).

Renvoie
string

Références Integer\$instanceID, et value.

◆ toBytes()

toBytes ( )

Converts an Integer to a byte string (eg. base-256).

Renvoie
string

Références Integer\$instanceID, et value.

Référencé par Integer\toHex().

◆ toHex()

toHex ( )

Converts an Integer to a hex string (eg. base-16).

Renvoie
string

Références Integer\toBytes().

Référencé par Integer\__debugInfo().

Documentation des champs

◆ $instanceID

$instanceID
protected

Référencé par Integer\__construct(), Integer\add(), Integer\cleanupCache(), Integer\divide(), Integer\getModulo(), Integer\multiply(), Integer\negate(), Integer\pow(), Integer\setModulo(), Integer\setRecurringModuloFunction(), Integer\squareRoot(), Integer\subtract(), Integer\toBits(), et Integer\toBytes().

◆ $modulo

$modulo
staticprotected

Référencé par Integer\setModulo().

◆ $reduce

$reduce
staticprotected

Référencé par Integer\__construct(), et Integer\squareRoot().

◆ $value

$value
protected

Référencé par Integer\__toString(), et Integer\toBigInteger().

◆ $zero

$zero
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Math/PrimeField/Integer.php


Joomla CMS: Référence de la classe BigInteger

  • phpseclib3
  • Math
  • BigInteger
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe BigInteger
+ Graphe d'héritage de BigInteger:

Fonctions membres publiques

__construct ($x=0, $base=10)
toString ()
__toString ()
__debugInfo ()
toBytes ($twos_compliment=false)
toHex ($twos_compliment=false)
toBits ($twos_compliment=false)
add (BigInteger $y)
subtract (BigInteger $y)
multiply (BigInteger $x)
divide (BigInteger $y)
modInverse (BigInteger $n)
gcd (BigInteger $n)
abs ()
setPrecision ($bits)
getPrecision ()
__sleep ()
__wakeup ()
jsonSerialize ()
powMod (BigInteger $e, BigInteger $n)
modPow (BigInteger $e, BigInteger $n)
compare (BigInteger $y)
equals (BigInteger $x)
bitwise_not ()
bitwise_and (BigInteger $x)
bitwise_or (BigInteger $x)
bitwise_xor (BigInteger $x)
bitwise_rightShift ($shift)
bitwise_leftShift ($shift)
bitwise_leftRotate ($shift)
bitwise_rightRotate ($shift)
getLength ()
getLengthInBytes ()
isPrime ($t=false)
root ($n=2)
pow (BigInteger $n)
between (BigInteger $min, BigInteger $max)
__clone ()
isOdd ()
testBit ($x)
isNegative ()
negate ()
createRecurringModuloFunction ()
bitwise_split ($split)

Fonctions membres publiques statiques

static | getEngine ()
static | random ($size)
static | randomPrime ($size)
static | randomRangePrime (BigInteger $min, BigInteger $max)
static | randomRange (BigInteger $min, BigInteger $max)
static | min (BigInteger ... $nums)
static | max (BigInteger ... $nums)
static | scan1divide (BigInteger $r)

Fonctions membres privées statiques

static initialize_static_variables ()

Attributs privés

$value
$hex
$precision

Attributs privés statiques

static | $mainEngine
static | $engines

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $x = 0,
 |  | $base = 10
 | ) |

Converts base-2, base-10, base-16, and binary strings (base-256) to BigIntegers.

If the second parameter - $base - is negative, then it will be assumed that the number's are encoded using two's compliment. The sole exception to this is -10, which is treated the same as 10 is.

Paramètres
string | int | BigInteger\Engines\Engine | $x | Base-10 number or base-$base number if $base set.
int | $base

Références $base, elseif, phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables(), et value.

Documentation des fonctions membres

◆ __clone()

__clone ( )

Clone

Références BigInteger\$value, et value.

◆ __debugInfo()

__debugInfo ( )

__debugInfo() magic method

Will be called, automatically, when print_r() or var_dump() are called

Références value.

◆ __sleep()

__sleep ( )

Serialize

Will be called, automatically, when serialize() is called on a BigInteger object.

__sleep() / __wakeup() have been around since PHP 4.0

was introduced in PHP 5.1 and deprecated in PHP 8.1: https://wiki.php.net/rfc/phase_out_serializable

__serialize() / __unserialize() were introduced in PHP 7.4: https://wiki.php.net/rfc/custom_object_serialization

Renvoie
array

Références BigInteger\getPrecision(), et BigInteger\toHex().

◆ __toString()

__toString ( )

__toString() magic method

Références BigInteger\$value.

◆ __wakeup()

__wakeup ( )

Serialize

Will be called, automatically, when unserialize() is called on a BigInteger object.

Références BigInteger\$hex, $temp, BigInteger\setPrecision(), et value.

◆ abs()

abs ( )

Absolute value.

Renvoie
BigInteger public

Références value.

Référencé par Engine\__construct().

◆ add()

add ( BigInteger $y )

Adds two BigIntegers.

Paramètres
BigInteger $y
Renvoie
BigInteger

Références value.

Référencé par Engine\__construct(), et Engine\toBytesHelper().

◆ between()

between | ( | BigInteger | $min,
 |  | BigInteger | $max
 | ) |  |

Tests BigInteger to see if it is between two integers, inclusive

Paramètres
BigInteger | $min
BigInteger | $max
Renvoie
bool

Références value.

◆ bitwise_and()

bitwise_and ( BigInteger $x )

Logical And

Paramètres
BigInteger $x
Renvoie
BigInteger

Références value.

◆ bitwise_leftRotate()

bitwise_leftRotate ( $shift )

Logical Left Rotate

Instead of the top x bits being dropped they're appended to the shifted bit string.

Paramètres
int $shift
Renvoie
BigInteger

Références value.

◆ bitwise_leftShift()

bitwise_leftShift ( $shift )

Logical Left Shift

Shifts BigInteger's by $shift bits, effectively multiplying by 2**$shift.

Paramètres
int $shift
Renvoie
BigInteger

Références value.

Référencé par Engine\bitwise_leftRotate().

◆ bitwise_not()

bitwise_not ( )

Logical Not

Renvoie
BigInteger

Références value.

◆ bitwise_or()

bitwise_or ( BigInteger $x )

Logical Or

Paramètres
BigInteger $x
Renvoie
BigInteger

Références value.

◆ bitwise_rightRotate()

bitwise_rightRotate ( $shift )

Logical Right Rotate

Instead of the bottom x bits being dropped they're prepended to the shifted bit string.

Paramètres
int $shift
Renvoie
BigInteger

Références value.

◆ bitwise_rightShift()

bitwise_rightShift ( $shift )

Logical Right Shift

Shifts BigInteger's by $shift bits, effectively dividing by 2**$shift.

Paramètres
int $shift
Renvoie
BigInteger

Références value.

Référencé par Engine\bitwise_leftRotate(), et KoblitzPrime\extendedGCD().

◆ bitwise_split()

bitwise_split ( $split )

Bitwise Split

Splits BigInteger's into chunks of $split bits

Paramètres
int $split
Renvoie
BigInteger[]

Références $val, et value.

◆ bitwise_xor()

bitwise_xor ( BigInteger $x )

Logical Exclusive Or

Paramètres
BigInteger $x
Renvoie
BigInteger

Références value.

◆ compare()

compare ( BigInteger $y )

Compares two numbers.

Although one might think !$x->compare($y) means $x != $y, it, in fact, means the opposite. The reason for this is demonstrated thusly:

$x >

y

x->compare($y) > 0 $x <

y

x->compare($y) < 0 $x ==

y

x->compare($y) == 0

Note how the same comparison operator is used. If you want to test for equality, use $x->equals($y).

{

Références value.

Référencé par KoblitzPrime\extendedGCD(), Engine\rootHelper(), Engine\toBits(), et Engine\toBytesHelper().

◆ createRecurringModuloFunction()

createRecurringModuloFunction ( )

Create Recurring Modulo Function

Sometimes it may be desirable to do repeated modulos with the same number outside of modular exponentiation

Renvoie
callable

Références value.

Référencé par PrimeField\__construct().

◆ divide()

divide ( BigInteger $y )

Divides two BigIntegers.

Returns an array whose first element contains the quotient and whose second element contains the "common residue". If the remainder would be positive, the "common residue" and the remainder are the same. If the remainder would be negative, the "common residue" is equal to the sum of the remainder and the divisor (basically, the "common residue" is the first positive modulo).

Here's an example: <?php $a = new ('10'); $b = new ('20');

list($quotient, $remainder) = $a->divide($b);

echo $quotient->toString(); // outputs 0 echo "\r\n"; echo $remainder->toString(); // outputs 10 ?>

Paramètres
BigInteger $y
Renvoie
BigInteger[]

Références $r, et value.

Référencé par KoblitzPrime\extendedGCD().

◆ equals()

equals ( BigInteger $x )

Tests the equality of two numbers.

If you need to see if one number is greater than or less than another number, use BigInteger::compare()

Paramètres
BigInteger $x
Renvoie
bool

Références value.

Référencé par KoblitzPrime\extendedGCD().

◆ gcd()

gcd ( BigInteger $n )

Calculates the greatest common divisor

Say you have 693 and 609. The GCD is 21.

Paramètres
BigInteger $n
Renvoie
BigInteger

Références value.

◆ getEngine()

static getEngine ( )
static

Returns the engine type

Renvoie
string[]

Références phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

◆ getLength()

getLength ( )

Return the size of a BigInteger in bits

Renvoie
int

Références value.

Référencé par KoblitzPrime\extendedGCD(), et SSH2\save().

◆ getLengthInBytes()

getLengthInBytes ( )

Return the size of a BigInteger in bytes

Renvoie
int

Références value.

◆ getPrecision()

getPrecision ( )

Get Precision

Returns the precision if it exists, false if it doesn't

Renvoie
int|bool

Références value.

Référencé par BigInteger\__sleep(), et BigInteger\jsonSerialize().

◆ initialize_static_variables()

static initialize_static_variables ( )
staticprivate

Initialize static variables

Références BigInteger\$engines.

◆ isNegative()

isNegative ( )

Is Negative?

Renvoie
bool

Références value.

◆ isOdd()

isOdd ( )

Is Odd?

Renvoie
bool

Références value.

◆ isPrime()

isPrime ( $t = false )

Checks a numer to see if it's prime

Assuming the $t parameter is not set, this function has an error rate of 2**-80. The main motivation for the $t parameter is distributability. BigInteger::randomPrime() can be distributed across multiple pageloads on a website instead of just one.

Paramètres
int | bool $t
Renvoie
bool

Références value.

◆ jsonSerialize()

jsonSerialize ( )

JSON Serialize

Will be called, automatically, when json_encode() is called on a BigInteger object.

Références $result, BigInteger\getPrecision(), et BigInteger\toHex().

◆ max()

static max ( BigInteger ... $nums )
static

Return the maximum BigInteger between an arbitrary number of BigIntegers.

Paramètres
BigInteger ...$nums
Renvoie
BigInteger

Références $class.

Référencé par Engine\bitwiseAndHelper(), Engine\bitwiseOrHelper(), Engine\bitwiseXorHelper(), PHP\compareHelper(), et MontgomeryMult\multiplyReduce().

◆ min()

static min ( BigInteger ... $nums )
static

Return the minimum BigInteger between an arbitrary number of BigIntegers.

Paramètres
BigInteger ...$nums
Renvoie
BigInteger

Références $class.

Référencé par PHP\karatsuba(), PHP\multiplyHelper(), et PHP\normalize().

◆ modInverse()

modInverse ( BigInteger $n )

Calculates modular inverses.

Say you have (30 mod 17 * x mod 17) mod 17 == 1. x can be found using modular inverses.

Paramètres
BigInteger $n
Renvoie
BigInteger

Références value.

Référencé par Engine\powModOuter().

◆ modPow()

modPow | ( | BigInteger | $e,
 |  | BigInteger | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
BigInteger | $e
BigInteger | $n
Renvoie
BigInteger

Références $n, et value.

Référencé par PublicKey\exponentiate(), et PrivateKey\exponentiate().

◆ multiply()

multiply ( BigInteger $x )

Multiplies two BigIntegers

Paramètres
BigInteger $x
Renvoie
BigInteger

Références value.

Référencé par KoblitzPrime\extendedGCD(), Ed448\recoverX(), et Ed25519\recoverX().

◆ negate()

negate ( )

Negate

Given $k, returns -$k

Renvoie
BigInteger

Références value.

◆ pow()

pow ( BigInteger $n )

Performs exponentiation.

Paramètres
BigInteger $n
Renvoie
BigInteger

Références value.

◆ powMod()

powMod | ( | BigInteger | $e,
 |  | BigInteger | $n
 | ) |  |

Performs modular exponentiation.

Paramètres
BigInteger | $e
BigInteger | $n
Renvoie
BigInteger

Références $n, et value.

◆ random()

static random ( $size )
static

Generates a random number of a certain size

Bit length is equal to $size

Paramètres
int $size
Renvoie
BigInteger

Références $class, $size, et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

Référencé par DSA\createParameters(), Curve25519\createRandomMultiplier(), et Curve448\createRandomMultiplier().

◆ randomPrime()

static randomPrime ( $size )
static

Generates a random prime number of a certain size

Bit length is equal to $size

Paramètres
int $size
Renvoie
BigInteger

Références $class, $size, et phpseclib3\Crypt\EC\Formats\Keys\initialize_static_variables().

Référencé par DH\createParameters(), et DSA\createParameters().

◆ randomRange()

static randomRange | ( | BigInteger | $min,
 |  | BigInteger | $max
 | ) |  |
static

Generate a random number between a range

Returns a random number between $min and $max where $min and $max can be defined using one of the two methods:

BigInteger::randomRange($min, $max) BigInteger::randomRange($max, $min)

Paramètres
BigInteger | $min
BigInteger | $max
Renvoie
BigInteger

Références $class.

Référencé par DSA\createKey(), DH\createKey(), Base\createRandomMultiplier(), PrivateKey\exponentiate(), PrimeField\randomInteger(), BinaryField\randomInteger(), et PrivateKey\sign().

◆ randomRangePrime()

static randomRangePrime | ( | BigInteger | $min,
 |  | BigInteger | $max
 | ) |  |
static

Generate a random prime number between a range

If there's not a prime within the given range, false will be returned.

Paramètres
BigInteger | $min
BigInteger | $max
Renvoie
false|BigInteger

Références $class.

◆ root()

root ( $n = 2 )

Calculates the nth root of a biginteger.

Returns the nth root of a positive biginteger, where n defaults to 2

Paramètres
int $n optional
Renvoie
BigInteger

Références value.

◆ scan1divide()

static scan1divide ( BigInteger $r )
static

Scan for 1 and right shift by that amount

ie. $s = gmp_scan1($n, 0) and $r = gmp_div_q($n, gmp_pow(gmp_init('2'), $s));

Paramètres
BigInteger $r
Renvoie
int

Références $class, et $r.

Référencé par Integer\squareRoot().

◆ setPrecision()

setPrecision ( $bits )

Set Precision

Some bitwise operations give different results depending on the precision being used. Examples include left shift, not, and rotates.

Paramètres
int $bits

Références value.

Référencé par BigInteger\__wakeup().

◆ subtract()

subtract ( BigInteger $y )

Subtracts two BigIntegers.

Paramètres
BigInteger $y
Renvoie
BigInteger

Références value.

◆ testBit()

testBit ( $x )

Tests if a bit is set

Paramètres
int $x
Renvoie
bool

Références value.

◆ toBits()

toBits ( $twos_compliment = false )

Converts a BigInteger to a bit string (eg. base-2).

Negative numbers are saved as positive numbers, unless $twos_compliment is set to true, at which point, they're saved as two's compliment.

Paramètres
bool $twos_compliment
Renvoie
string

Références value.

Référencé par Base\multiplyPoint(), Montgomery\multiplyPoint(), et PuTTY\savePrivateKey().

◆ toBytes()

toBytes ( $twos_compliment = false )

Converts a BigInteger to a byte string (eg. base-256).

Paramètres
bool $twos_compliment
Renvoie
string

Références value.

Référencé par Engine\bitwise_leftRotate(), Engine\bitwise_not(), Engine\bitwiseAndHelper(), Engine\bitwiseOrHelper(), Engine\bitwiseXorHelper(), Engine\getLengthInBytes(), Curve25519\multiplyPoint(), Curve448\multiplyPoint(), SSH2\save(), MontgomeryPrivate\savePrivateKey(), PuTTY\savePrivateKey(), XML\savePrivateKey(), PKCS1\savePrivateKey(), MSBLOB\savePrivateKey(), PKCS8\savePrivateKey(), XML\savePublicKey(), Engine\toBits(), et Engine\toHex().

◆ toHex()

toHex ( $twos_compliment = false )

Converts a BigInteger to a hex string (eg. base-16).

Paramètres
bool $twos_compliment
Renvoie
string

Références value.

Référencé par BigInteger\__sleep(), et BigInteger\jsonSerialize().

◆ toString()

toString ( )

Converts a BigInteger to a base-10 number.

Renvoie
string

Références value.

Référencé par Engine\__toString().

Documentation des champs

◆ $engines

$engines
staticprivate

Référencé par BigInteger\initialize_static_variables().

◆ $hex

$hex
private

Référencé par BigInteger\__wakeup().

◆ $mainEngine

$mainEngine
staticprivate

◆ $precision

$precision
private

◆ $value

$value
private

Référencé par BigInteger\__clone(), et BigInteger\__toString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • phpseclib/phpseclib/phpseclib/Math/BigInteger.php


Joomla CMS: Référence de la classe BinaryField

  • phpseclib3
  • Math
  • BinaryField
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés | Attributs privés statiques
Référence de la classe BinaryField
+ Graphe d'héritage de BinaryField:
FiniteField

Fonctions membres publiques

__construct (... $indices)
newInteger ($num)
randomInteger ()
getLengthInBytes ()
getLength ()

Fonctions membres publiques statiques

static | base2ToBase256 ($x, $size=null)
static | base256ToBase2 ($x)

Attributs protégés

$instanceID

Attributs privés

$randomMax

Attributs privés statiques

static $instanceCounter = 0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $indices )

Default constructor

Références $c, $g, $i, $r, $temp, $val, Integer\setModulo(), et Integer\setRecurringModuloFunction().

Documentation des fonctions membres

◆ base256ToBase2()

static base256ToBase2 ( $x )
static

Converts a base-256 string to a base-2 string

Paramètres
string $x
Renvoie
string

Références Strings\bin2bits().

Référencé par Integer\regularPolynomialMultiply(), et Integer\toBits().

◆ base2ToBase256()

static base2ToBase256 | ( | $x,
 |  | $size = null
 | ) |
static

Converts a base-2 string to a base-256 string

Paramètres
string | $x
int | null | $size
Renvoie
string

Références $size, et Strings\bits2bin().

Référencé par Integer\polynomialDivide(), et Integer\regularPolynomialMultiply().

◆ getLength()

getLength ( )

Returns the length of the modulo in bits

Renvoie
int

Références Integer\getModulo().

◆ getLengthInBytes()

getLengthInBytes ( )

Returns the length of the modulo in bytes

Renvoie
int

Références Integer\getModulo().

◆ newInteger()

newInteger ( $num )

Returns an instance of a dynamically generated PrimeFieldInteger class

Paramètres
string $num
Renvoie
Integer

◆ randomInteger()

randomInteger ( )

Returns an integer on the finite field between one and the prime modulo

Renvoie
Integer

Références BigInteger\randomRange().

Documentation des champs

◆ $instanceCounter

$instanceCounter = 0
staticprivate

◆ $instanceID

$instanceID
protected

◆ $randomMax

$randomMax
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • BinaryField.php


Joomla CMS: Référence de la classe PrimeField

  • phpseclib3
  • Math
  • PrimeField
Fonctions membres publiques | Attributs protégés | Attributs privés statiques
Référence de la classe PrimeField
+ Graphe d'héritage de PrimeField:
FiniteField

Fonctions membres publiques

__construct (BigInteger $modulo)
setReduction (\Closure $func)
newInteger (BigInteger $num)
randomInteger ()
getLengthInBytes ()
getLength ()
__destruct ()

Attributs protégés

$instanceID

Attributs privés statiques

static $instanceCounter = 0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( BigInteger $modulo )

Default constructor

Références BigInteger\createRecurringModuloFunction(), Integer\setModulo(), et Integer\setRecurringModuloFunction().

◆ __destruct()

__destruct ( )

Destructor

Références Integer\cleanupCache().

Documentation des fonctions membres

◆ getLength()

getLength ( )

Returns the length of the modulo in bits

Renvoie
int

Références Integer\getModulo().

◆ getLengthInBytes()

getLengthInBytes ( )

Returns the length of the modulo in bytes

Renvoie
int

Références Integer\getModulo().

◆ newInteger()

newInteger ( BigInteger $num )

Returns an instance of a dynamically generated PrimeFieldInteger class

Renvoie
Integer

◆ randomInteger()

randomInteger ( )

Returns an integer on the finite field between one and the prime modulo

Renvoie
Integer

Références Integer\getModulo(), et BigInteger\randomRange().

◆ setReduction()

setReduction ( \Closure $func )

Use a custom defined modular reduction function

Renvoie
void

Références $this.

Documentation des champs

◆ $instanceCounter

$instanceCounter = 0
staticprivate

◆ $instanceID

$instanceID
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PrimeField.php


Joomla CMS: Référence de la classe Stream

  • phpseclib3
  • Net
  • SFTP
  • Stream
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Stream

Fonctions membres publiques

__construct ()
__call ($name, $arguments)

Fonctions membres publiques statiques

static register ($protocol='sftp')

Champs de données

$context

Attributs publics statiques

static $instances

Fonctions membres protégées

parse_path ($path)

Fonctions membres privées

_stream_open ($path, $mode, $options, &$opened_path)
_stream_read ($count)
_stream_write ($data)
_stream_tell ()
_stream_eof ()
_stream_seek ($offset, $whence)
_stream_metadata ($path, $option, $var)
_stream_cast ($cast_as)
_stream_lock ($operation)
_rename ($path_from, $path_to)
_dir_opendir ($path, $options)
_dir_readdir ()
_dir_rewinddir ()
_dir_closedir ()
_mkdir ($path, $mode, $options)
_rmdir ($path, $options)
_stream_flush ()
_stream_stat ()
_unlink ($path)
_url_stat ($path, $flags)
_stream_truncate ($new_size)
_stream_set_option ($option, $arg1, $arg2)
_stream_close ()

Attributs privés

$sftp
$path
$mode
$pos
$size
$entries
$eof
$notification

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

The Constructor

public

Documentation des fonctions membres

◆ __call()

__call | ( | $name,
 |  | $arguments
 | ) |

__call Magic Method

When you're utilizing an SFTP stream you're not calling the methods in this class directly - PHP is calling them for you. Which kinda begs the question... what methods is PHP calling and what parameters is it passing to them? This function lets you figure that out.

If NET_SFTP_STREAM_LOGGING is defined all calls will be output on the screen and then (regardless of whether or not NET_SFTP_STREAM_LOGGING is enabled) the parameters will be passed through to the appropriate method.

Paramètres
string | $name
array | $arguments
Renvoie
mixed public

Références $i, $last, $name, et $this.

◆ _dir_closedir()

_dir_closedir ( )
private

Close directory handle

Renvoie
bool public

◆ _dir_opendir()

_dir_opendir | ( | $path,
 |  | $options
 | ) |
private

Open directory handle

The only $options is "whether or not to enforce safe_mode (0x04)". Since safe mode was deprecated in 5.3 and removed in 5.4 I'm just going to ignore it.

Also, nlist() is the best that this function is realistically going to be able to do. When an SFTP client sends a SSH_FXP_READDIR packet you don't generally get info on just one file but on multiple files. Quoting the SFTP specs:

The SSH_FXP_NAME response has the following format:

uint32     id
uint32     count
repeats count times:
        string     filename
        string     longname
        ATTRS      attrs
Paramètres
string | $path
int | $options
Renvoie
bool public

Références Stream\$path, et Stream\parse_path().

◆ _dir_readdir()

_dir_readdir ( )
private

Read entry from directory handle

Renvoie
mixed public

◆ _dir_rewinddir()

_dir_rewinddir ( )
private

Rewind directory handle

Renvoie
bool public

◆ _mkdir()

_mkdir | ( | $path,
 |  | $mode,
 |  | $options
 | ) |
private

Create a directory

Only valid $options is STREAM_MKDIR_RECURSIVE

Paramètres
string | $path
int | $mode
int | $options
Renvoie
bool public

Références Stream\$mode, $options, Stream\$path, et Stream\parse_path().

◆ _rename()

_rename | ( | $path_from,
 |  | $path_to
 | ) |
private

Renames a file or directory

Attempts to rename oldname to newname, moving it between directories if necessary. If newname exists, it will be overwritten. This is a departure from what does.

Paramètres
string | $path_from
string | $path_to
Renvoie
bool public

Références Stream\parse_path().

◆ _rmdir()

_rmdir | ( | $path,
 |  | $options
 | ) |
private

Removes a directory

Only valid $options is STREAM_MKDIR_RECURSIVE per http://php.net/streamwrapper.rmdir, however, http://php.net/rmdir does not have a $recursive parameter as mkdir() does so I don't know how STREAM_MKDIR_RECURSIVE is supposed to be set. Also, when I try it out with rmdir() I get 8 as $options. What does 8 correspond to?

Paramètres
string | $path
int | $options
Renvoie
bool public

Références Stream\$path, et Stream\parse_path().

◆ _stream_cast()

_stream_cast ( $cast_as )
private

Retrieve the underlaying resource

Paramètres
int $cast_as
Renvoie
resource public

◆ _stream_close()

_stream_close ( )
private

Close an resource

public

◆ _stream_eof()

_stream_eof ( )
private

Tests for end-of-file on a file pointer

In my testing there are four classes functions that normally effect the pointer: fseek, fputs / fwrite, fgets / fread and ftruncate.

Only fgets / fread, however, results in feof() returning true. do fputs($fp, 'aaa') on a blank file and feof() will return false. do fread($fp, 1) and feof() will then return true. do fseek($fp, 10) on ablank file and feof() will return false. do fread($fp, 1) and feof() will then return true.

Renvoie
bool public

Références Stream\$eof.

◆ _stream_flush()

_stream_flush ( )
private

Flushes the output

See http://php.net/fflush. Always returns true because doesn't cache stuff before writing

Renvoie
bool public

◆ _stream_lock()

_stream_lock ( $operation )
private

Advisory file locking

Paramètres
int $operation
Renvoie
bool public

◆ _stream_metadata()

_stream_metadata | ( | $path,
 |  | $option,
 |  | $var
 | ) |
private

Change stream options

Paramètres
string | $path
int | $option
mixed | $var
Renvoie
bool public

Références $option, Stream\$path, null, et Stream\parse_path().

◆ _stream_open()

_stream_open | ( |  | $path,
 |  |  | $mode,
 |  |  | $options,
 |  | & | $opened_path
 | ) |  |
private

Opens file or URL

Paramètres
string | $path
string | $mode
int | $options
string | $opened_path
Renvoie
bool public

Références Stream\$mode, Stream\$path, Stream\$size, Stream\parse_path(), et path.

◆ _stream_read()

_stream_read ( $count )
private

Read from stream

Paramètres
int $count
Renvoie
mixed public

Références $count, $result, et path.

◆ _stream_seek()

_stream_seek | ( | $offset,
 |  | $whence
 | ) |
private

Seeks to specific location in a stream

Paramètres
int | $offset
int | $whence
Renvoie
bool public

Références Joomla\Database\Query\$offset, Stream\$pos, et Stream\$size.

◆ _stream_set_option()

_stream_set_option | ( | $option,
 |  | $arg1,
 |  | $arg2
 | ) |
private

Change stream options

STREAM_OPTION_WRITE_BUFFER isn't supported for the same reason stream_flush isn't. The other two aren't supported because of limitations in .

Paramètres
int | $option
int | $arg1
int | $arg2
Renvoie
bool public

◆ _stream_stat()

_stream_stat ( )
private

Retrieve information about a file resource

Renvoie
mixed public

Références $results, et path.

◆ _stream_tell()

_stream_tell ( )
private

Retrieve the current position of a stream

Renvoie
int public

Références Stream\$pos.

◆ _stream_truncate()

_stream_truncate ( $new_size )
private

Truncate stream

Paramètres
int $new_size
Renvoie
bool public

Références $this.

◆ _stream_write()

_stream_write ( $data )
private

Write to stream

Paramètres
string $data
Renvoie
int|false public

Références $data, Stream\$pos, $result, path, et SFTP\SOURCE_STRING.

◆ _unlink()

_unlink ( $path )
private

Delete a file

Paramètres
string $path
Renvoie
bool public

Références Stream\$path, et Stream\parse_path().

◆ _url_stat()

_url_stat | ( | $path,
 |  | $flags
 | ) |
private

Retrieve information about a file

Ignores the STREAM_URL_STAT_QUIET flag because the entirety of is quiet by default might be worthwhile to reconstruct bits 12-16 (ie. the file type) if mode doesn't have them but we'll cross that bridge when and if it's reached

Paramètres
string | $path
int | $flags
Renvoie
mixed public

Références Stream\$path, $results, et Stream\parse_path().

◆ parse_path()

parse_path ( $path )
protected

Path Parser

Extract a path from a URI and actually connect to an SSH server if appropriate

If "notification" is set as a context parameter the message code for successful login is NET_SSH2_MSG_USERAUTH_SUCCESS. For a failed login it's NET_SSH2_MSG_USERAUTH_FAILURE.

Paramètres
string $path
Renvoie
string private

Références Stream\$context, SSH2\$host, Stream\$path, SSH2\$port, $query, Stream\$sftp, $user, elseif, et SSH2\getConnectionByResourceId().

Référencé par Stream\_dir_opendir(), Stream\_mkdir(), Stream\_rename(), Stream\_rmdir(), Stream\_stream_metadata(), Stream\_stream_open(), Stream\_unlink(), et Stream\_url_stat().

◆ register()

static register ( $protocol = 'sftp' )
static

Registers this class as a URL wrapper.

Paramètres
string $protocol The wrapper name to be registered.
Renvoie
bool True on success, false otherwise. public

Références Laminas\Diactoros\$protocol.

Documentation des champs

◆ $context

$context

Référencé par Stream\parse_path().

◆ $entries

$entries
private

◆ $eof

$eof
private

Référencé par Stream\_stream_eof().

◆ $instances

$instances
static

◆ $mode

$mode
private

Référencé par Stream\_mkdir(), et Stream\_stream_open().

◆ $notification

$notification
private

◆ $path

$path
private

Référencé par Stream\_dir_opendir(), Stream\_mkdir(), Stream\_rmdir(), Stream\_stream_metadata(), Stream\_stream_open(), Stream\_unlink(), Stream\_url_stat(), et Stream\parse_path().

◆ $pos

$pos
private

Référencé par Stream\_stream_seek(), Stream\_stream_tell(), et Stream\_stream_write().

◆ $sftp

$sftp
private

Référencé par Stream\parse_path().

◆ $size

$size
private

Référencé par Stream\_stream_open(), et Stream\_stream_seek().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php


Joomla CMS: Référence de la classe SFTP

  • phpseclib3
  • Net
  • SFTP
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe SFTP
+ Graphe d'héritage de SFTP:
SSH2

Fonctions membres publiques

__construct ($host, $port=22, $timeout=10)
disableStatCache ()
enableStatCache ()
clearStatCache ()
enablePathCanonicalization ()
disablePathCanonicalization ()
enableArbitraryLengthPackets ()
disableArbitraryLengthPackets ()
pwd ()
realpath ($path)
chdir ($dir)
nlist ($dir='.', $recursive=false)
rawlist ($dir='.', $recursive=false)
setListOrder (... $args)
stat ($filename)
lstat ($filename)
truncate ($filename, $new_size)
touch ($filename, $time=null, $atime=null)
chown ($filename, $uid, $recursive=false)
chgrp ($filename, $gid, $recursive=false)
chmod ($mode, $filename, $recursive=false)
readlink ($link)
symlink ($target, $link)
mkdir ($dir, $mode=-1, $recursive=false)
rmdir ($dir)
put ($remote_file, $data, $mode=self::SOURCE_STRING, $start=-1, $local_start=-1, $progressCallback=null)
get ($remote_file, $local_file=false, $offset=0, $length=-1, $progressCallback=null)
delete ($path, $recursive=true)
file_exists ($path)
is_dir ($path)
is_file ($path)
is_link ($path)
is_readable ($path)
is_writable ($path)
is_writeable ($path)
fileatime ($path)
filemtime ($path)
fileperms ($path)
fileowner ($path)
filegroup ($path)
filesize ($path)
filetype ($path)
rename ($oldname, $newname)
getSFTPLog ()
getSFTPErrors ()
getLastSFTPError ()
getSupportedVersions ()
getNegotiatedVersion ()
setPreferredVersion ($version)
enableDatePreservation ()
disableDatePreservation ()
- Fonctions membres publiques hérités de SSH2
sendIdentificationStringFirst ()
sendIdentificationStringLast ()
sendKEXINITFirst ()
sendKEXINITLast ()
login ($username,... $args)
setTimeout ($timeout)
setKeepAlive ($interval)
getStdError ()
exec ($command, callable $callback=null)
requestAgentForwarding ()
read ($expect='', $mode=self::READ_SIMPLE)
write ($cmd)
startSubsystem ($subsystem)
stopSubsystem ()
reset ()
isTimeout ()
disconnect ()
__destruct ()
isConnected ()
isAuthenticated ()
ping ()
enableQuietMode ()
disableQuietMode ()
isQuietModeEnabled ()
enablePTY ()
disablePTY ()
isPTYEnabled ()
getLog ()
getErrors ()
getLastError ()
getServerIdentification ()
getServerAlgorithms ()
getAlgorithmsNegotiated ()
setTerminal ($term)
setPreferredAlgorithms (array $methods)
getBannerMessage ()
getServerPublicHostKey ()
getExitStatus ()
getWindowColumns ()
getWindowRows ()
setWindowColumns ($value)
setWindowRows ($value)
setWindowSize ($columns=80, $rows=24)
__toString ()
getResourceId ()
getAuthMethodsToContinue ()
enableSmartMFA ()
disableSmartMFA ()

Champs de données

const | CHANNEL = 0x100
const | SOURCE_LOCAL_FILE = 1
const | SOURCE_STRING = 2
const | SOURCE_CALLBACK = 16
const | RESUME = 4
const | RESUME_START = 8
- Champs de données hérités de SSH2
const | NET_SSH2_COMPRESSION_NONE = 1
const | NET_SSH2_COMPRESSION_ZLIB = 2
const | NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH = 3
const | MASK_CONSTRUCTOR = 0x00000001
const | MASK_CONNECTED = 0x00000002
const | MASK_LOGIN_REQ = 0x00000004
const | MASK_LOGIN = 0x00000008
const | MASK_SHELL = 0x00000010
const | MASK_WINDOW_ADJUST = 0x00000020
const | CHANNEL_EXEC = 1
const | CHANNEL_SHELL = 2
const | CHANNEL_SUBSYSTEM = 3
const | CHANNEL_AGENT_FORWARD = 4
const | CHANNEL_KEEP_ALIVE = 5
const | LOG_SIMPLE = 1
const | LOG_COMPLEX = 2
const | LOG_REALTIME = 3
const | LOG_REALTIME_FILE = 4
const | LOG_MAX_SIZE = 1048576
const | READ_SIMPLE = 1
const | READ_REGEX = 2
const | READ_NEXT = 3
$fsock

Fonctions membres protégées

parseAttributes (&$response)
reset_connection ($reason)
disconnect_helper ($reason)
- Fonctions membres protégées hérités de SSH2
sublogin ($username,... $args)
reset_connection ($reason)
get_channel_packet ($client_channel, $skip_extended=false)
send_binary_packet ($data, $logged=null)
send_channel_packet ($client_channel, $data)
disconnect_helper ($reason)
define_array (... $args)
format_log ($message_log, $message_number_log)

Attributs protégés

$sortOptions = []
- Attributs protégés hérités de SSH2
$bitmap = 0
$server_identifier = false
$server_channels = []
$channel_status = []
$window_size = 0x7FFFFFFF
$window_size_server_to_client = []
$timeout
$curTimeout
$preferred_signature_format = false
$auth = []

Fonctions membres privées

precheck ()
partial_init_sftp_connection ()
init_sftp_connection ()
logError ($response, $status=-1)
nlist_helper ($dir, $recursive, $relativeDir)
readlist ($dir, $raw=true)
comparator ($a, $b)
update_stat_cache ($path, $value)
remove_from_stat_cache ($path)
query_stat_cache ($path)
stat_helper ($filename, $type)
setstat ($filename, $attr, $recursive)
setstat_recursive ($path, $attr, &$i)
mkdir_helper ($dir, $mode)
read_put_responses ($i)
close_handle ($handle)
delete_recursive ($path, &$i)
get_stat_cache_prop ($path, $prop)
get_lstat_cache_prop ($path, $prop)
get_xstat_cache_prop ($path, $prop, $type)
parseTime ($key, $flags, &$response)
parseMode ($mode)
parseLongname ($longname)
send_sftp_packet ($type, $data, $request_id=1)

Attributs privés

$packet_types = []
$status_codes = []
$attributes
$open_flags
$open_flags5
$file_types
$use_request_id = false
$packet_type = -1
$packet_buffer = ''
$extensions = []
$version
$defaultVersion
$preferredVersion = 3
$pwd = false
$packet_type_log = []
$packet_log = []
$sftp_errors = []
$stat_cache = []
$max_sftp_packet
$use_stat_cache = true
$canonicalize_paths = true
$requestBuffer = []
$preserveTime = false
$allow_arbitrary_length_packets = false
$channel_close = false
$partial_init = false

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de SSH2
static | setCryptoEngine ($engine)
static | getSupportedKEXAlgorithms ()
static | getSupportedHostKeyAlgorithms ()
static | getSupportedEncryptionAlgorithms ()
static | getSupportedMACAlgorithms ()
static | getSupportedCompressionAlgorithms ()
static | getConnectionByResourceId ($id)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $host,
 |  | $port = 22,
 |  | $timeout = 10
 | ) |

Default Constructor.

Connects to an SFTP server

Paramètres
string | $host
int | $port
int | $timeout | public

Références SSH2\$host, SSH2\$port, SSH2\$timeout, Symfony\Contracts\Service\__construct(), et SSH2\define_array().

Documentation des fonctions membres

◆ chdir()

chdir ( $dir )

Changes the current directory

Paramètres
string $dir
Exceptions

Références $dir, SFTP\close_handle(), elseif, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\pwd(), SFTP\query_stat_cache(), SFTP\realpath(), SFTP\send_sftp_packet(), et SFTP\update_stat_cache().

Référencé par SFTP\lstat(), et SFTP\stat().

◆ chgrp()

chgrp | ( | $filename,
 |  | $gid,
 |  | $recursive = false
 | ) |

Changes file or directory group

$gid should be an int for SFTPv3 and a string for SFTPv4+. Ideally the string would be of the form "user@dns_domain" but it does not need to be. ‘$sftp->getSupportedVersions()['version’]` will return the specific version that's being used.

Returns true on success or false on error.

Paramètres
string | $filename
int | string | $gid
bool | $recursive
Renvoie
bool public

Références $attr, Strings\packSSH2(), et SFTP\setstat().

◆ chmod()

chmod | ( | $mode,
 |  | $filename,
 |  | $recursive = false
 | ) |

Set permissions on a file.

Returns the new file permissions on success or false on error. If $recursive is true than this just returns true or false.

Paramètres
int | $mode
string | $filename
bool | $recursive
Exceptions

Références $attr, $mode, $temp, SFTP\logError(), SFTP\parseAttributes(), SFTP\realpath(), SFTP\send_sftp_packet(), et SFTP\setstat().

Référencé par SFTP\mkdir_helper().

◆ chown()

chown | ( | $filename,
 |  | $uid,
 |  | $recursive = false
 | ) |

Changes file or directory owner

$uid should be an int for SFTPv3 and a string for SFTPv4+. Ideally the string would be of the form "user@dns_domain" but it does not need to be. ‘$sftp->getSupportedVersions()['version’]` will return the specific version that's being used.

Returns true on success or false on error.

Paramètres
string | $filename
int | string | $uid
bool | $recursive
Renvoie
bool public

Références $attr, Strings\packSSH2(), et SFTP\setstat().

◆ clearStatCache()

clearStatCache ( )

Clear the stat cache

public

◆ close_handle()

close_handle ( $handle )
private

Close handle

Paramètres
string $handle
Renvoie
bool
Exceptions

Références SFTP\logError(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

Référencé par SFTP\chdir(), SFTP\get(), SFTP\put(), SFTP\readlist(), et SFTP\touch().

◆ comparator()

comparator | ( | $a,
 |  | $b
 | ) |
private

Compares two rawlist entries using parameters set by setListOrder()

Intended for use with uasort()

Paramètres
array | $a
array | $b
Renvoie
int private

Références $b, $result, et $sort.

◆ delete()

delete | ( | $path,
 |  | $recursive = true
 | ) |

Deletes a file on the SFTP server.

Paramètres
string | $path
bool | $recursive
Renvoie
bool
Exceptions

Références $i, $path, $result, SFTP\delete_recursive(), SFTP\logError(), SFTP\precheck(), SFTP\read_put_responses(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

◆ delete_recursive()

delete_recursive | ( |  | $path,
 |  | & | $i
 | ) |  |
private

Recursively deletes directories on the SFTP server

Minimizes directory lookups and SSH_FXP_STATUS requests for speed.

Paramètres
string | $path
int | $i
Renvoie
bool private

Références $i, $path, $temp, Strings\packSSH2(), SFTP\read_put_responses(), SFTP\readlist(), SFTP\remove_from_stat_cache(), et SFTP\send_sftp_packet().

Référencé par SFTP\delete().

◆ disableArbitraryLengthPackets()

disableArbitraryLengthPackets ( )

Disable arbitrary length packets

public

◆ disableDatePreservation()

disableDatePreservation ( )

Disable Date Preservation

public

◆ disablePathCanonicalization()

disablePathCanonicalization ( )

Enable path canonicalization

public

◆ disableStatCache()

disableStatCache ( )

Disable the stat cache

public

◆ disconnect_helper()

disconnect_helper ( $reason )
protected

Disconnect

Paramètres
int $reason
Renvoie
false protected

◆ enableArbitraryLengthPackets()

enableArbitraryLengthPackets ( )

Enable arbitrary length packets

public

◆ enableDatePreservation()

enableDatePreservation ( )

Enable Date Preservation

public

◆ enablePathCanonicalization()

enablePathCanonicalization ( )

Enable path canonicalization

public

◆ enableStatCache()

enableStatCache ( )

Enable the stat cache

public

◆ file_exists()

file_exists ( $path )

Checks whether a file or directory exists

Paramètres
string $path
Renvoie
bool public

Références $path, $result, SFTP\precheck(), SFTP\query_stat_cache(), SFTP\realpath(), et SFTP\stat().

◆ fileatime()

fileatime ( $path )

Gets last access time of file

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ filegroup()

filegroup ( $path )

Gets file group

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ filemtime()

filemtime ( $path )

Gets file modification time

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ fileowner()

fileowner ( $path )

Gets file owner

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ fileperms()

fileperms ( $path )

Gets file permissions

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ filesize()

filesize ( $path )

Gets file size

Paramètres
string $path
Renvoie
mixed public

Références $path, et SFTP\get_stat_cache_prop().

◆ filetype()

filetype ( $path )

Gets file type

Paramètres
string $path
Renvoie
string|false public

Références $path, $type, et SFTP\get_stat_cache_prop().

◆ get()

get | ( | $remote_file,
 |  | $local_file = false,
 |  | $offset = 0,
 |  | $length = -1,
 |  | $progressCallback = null
 | ) |

Downloads a file from the SFTP server.

Returns a string containing the contents of $remote_file if $local_file is left undefined or a boolean false if the operation was unsuccessful. If $local_file is defined, returns true or false depending on the success of the operation.

$offset and $length can be used to download files in chunks.

Paramètres
string | $remote_file
string | bool | resource | callable | $local_file
int | $offset
int | $length
callable | null | $progressCallback
Exceptions

Références $content, $i, SFTP\$max_sftp_packet, Joomla\Database\Query\$offset, $start, $temp, SFTP\close_handle(), elseif, SFTP\init_sftp_connection(), SFTP\logError(), null, Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), SFTP\send_sftp_packet(), SFTP\stat(), et SFTP\touch().

◆ get_lstat_cache_prop()

get_lstat_cache_prop | ( | $path,
 |  | $prop
 | ) |
private

Return an lstat properity

Uses cache if appropriate.

Paramètres
string | $path
string | $prop
Renvoie
mixed private

Références $path, et SFTP\get_xstat_cache_prop().

Référencé par SFTP\is_link().

◆ get_stat_cache_prop()

get_stat_cache_prop | ( | $path,
 |  | $prop
 | ) |
private

Return a stat properity

Uses cache if appropriate.

Paramètres
string | $path
string | $prop
Renvoie
mixed private

Références $path, et SFTP\get_xstat_cache_prop().

Référencé par SFTP\fileatime(), SFTP\filegroup(), SFTP\filemtime(), SFTP\fileowner(), SFTP\fileperms(), SFTP\filesize(), SFTP\filetype(), SFTP\is_dir(), et SFTP\is_file().

◆ get_xstat_cache_prop()

get_xstat_cache_prop | ( | $path,
 |  | $prop,
 |  | $type
 | ) |
private

Return a stat or lstat properity

Uses cache if appropriate.

Paramètres
string | $path
string | $prop
string | $type
Renvoie
mixed private

Références $path, $result, $type, SFTP\precheck(), SFTP\query_stat_cache(), et SFTP\realpath().

Référencé par SFTP\get_lstat_cache_prop(), et SFTP\get_stat_cache_prop().

◆ getLastSFTPError()

getLastSFTPError ( )

Returns the last error

Renvoie
string public

◆ getNegotiatedVersion()

getNegotiatedVersion ( )

Get supported SFTP versions

Renvoie
int|false public

Références $version.

◆ getSFTPErrors()

getSFTPErrors ( )

Returns all errors

Renvoie
array public

◆ getSFTPLog()

getSFTPLog ( )

Returns a log of the packets that have been sent and received.

Returns a string if NET_SFTP_LOGGING == self::LOG_COMPLEX, an array if NET_SFTP_LOGGING == self::LOG_SIMPLE and false if !defined('NET_SFTP_LOGGING')

public

Renvoie
array|string

◆ getSupportedVersions()

getSupportedVersions ( )

Get supported SFTP versions

Renvoie
array public

Références $temp, et SSH2\MASK_LOGIN.

◆ init_sftp_connection()

init_sftp_connection ( )
private

(Re)initializes the SFTP channel

Renvoie
bool private

Références SFTP\$defaultVersion, SFTP\logError(), Strings\packSSH2(), SFTP\partial_init_sftp_connection(), SFTP\pwd(), SFTP\realpath(), SFTP\send_sftp_packet(), Strings\unpackSSH2(), et SFTP\update_stat_cache().

Référencé par SFTP\get(), et SFTP\precheck().

◆ is_dir()

is_dir ( $path )

Tells whether the filename is a directory

Paramètres
string $path
Renvoie
bool public

Références $path, $result, et SFTP\get_stat_cache_prop().

◆ is_file()

is_file ( $path )

Tells whether the filename is a regular file

Paramètres
string $path
Renvoie
bool public

Références $path, $result, et SFTP\get_stat_cache_prop().

Référencé par SFTP\put().

◆ is_link()

is_link ( $path )

Tells whether the filename is a symbolic link

Paramètres
string $path
Renvoie
bool public

Références $path, $result, et SFTP\get_lstat_cache_prop().

◆ is_readable()

is_readable ( $path )

Tells whether a file exists and is readable

Paramètres
string $path
Renvoie
bool public

Références $path, Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), et SFTP\send_sftp_packet().

◆ is_writable()

is_writable ( $path )

Tells whether the filename is writable

Paramètres
string $path
Renvoie
bool public

Références $path, Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), et SFTP\send_sftp_packet().

Référencé par SFTP\is_writeable().

◆ is_writeable()

is_writeable ( $path )

Tells whether the filename is writeable

Alias of is_writable

Paramètres
string $path
Renvoie
bool public

Références $path, et SFTP\is_writable().

◆ logError()

logError | ( | $response,
 |  | $status = -1
 | ) |
private

Logs errors

Paramètres
string | $response
int | $status | private

Références $message, et Strings\unpackSSH2().

Référencé par SFTP\chdir(), SFTP\chmod(), SFTP\close_handle(), SFTP\delete(), SFTP\get(), SFTP\init_sftp_connection(), SFTP\mkdir_helper(), SFTP\put(), SFTP\read_put_responses(), SFTP\readlink(), SFTP\readlist(), SFTP\realpath(), SFTP\rmdir(), SFTP\setstat(), SFTP\stat_helper(), SFTP\symlink(), et SFTP\touch().

◆ lstat()

lstat ( $filename )

Returns general information about a file or symbolic link.

Returns an array on success and false otherwise.

Paramètres
string $filename
Renvoie
array|false public

Références SFTP\$pwd, $result, SFTP\chdir(), SFTP\precheck(), SFTP\pwd(), SFTP\query_stat_cache(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\stat_helper(), et SFTP\update_stat_cache().

Référencé par SFTP\rawlist(), et SFTP\update_stat_cache().

◆ mkdir()

mkdir | ( | $dir,
 |  | $mode = -1,
 |  | $recursive = false
 | ) |

Creates a directory.

Paramètres
string | $dir
int | $mode
bool | $recursive
Renvoie
bool public

Références $dir, $i, $mode, $result, $temp, SFTP\mkdir_helper(), SFTP\precheck(), et SFTP\realpath().

◆ mkdir_helper()

mkdir_helper | ( | $dir,
 |  | $mode
 | ) |
private

Helper function for directory creation

Paramètres
string | $dir
int | $mode
Renvoie
bool private

Références $dir, $mode, SFTP\chmod(), SFTP\logError(), Strings\packSSH2(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

Référencé par SFTP\mkdir().

◆ nlist()

nlist | ( | $dir = '.',
 |  | $recursive = false
 | ) |

Returns a list of files in the given directory

Paramètres
string | $dir
bool | $recursive
Renvoie
array|false public

Références $dir, et SFTP\nlist_helper().

◆ nlist_helper()

nlist_helper | ( | $dir,
 |  | $recursive,
 |  | $relativeDir
 | ) |
private

Helper method for nlist

Paramètres
string | $dir
bool | $recursive
string | $relativeDir
Renvoie
array|false private

Références $dir, $result, $temp, $value, SFTP\query_stat_cache(), SFTP\readlist(), et SFTP\realpath().

Référencé par SFTP\nlist().

◆ parseAttributes()

parseAttributes ( & $response )
protected

Parse Attributes

See '7. File Attributes' of draft-ietf-secsh-filexfer-13 for more info.

Paramètres
string $response
Renvoie
array private

Références $attr, $count, $i, $key, $result, $type, $value, et Strings\unpackSSH2().

Référencé par SFTP\chmod(), SFTP\readlist(), et SFTP\stat_helper().

◆ parseLongname()

parseLongname ( $longname )
private

Parse Longname

SFTPv3 doesn't provide any easy way of identifying a file type. You could try to open a file as a directory and see if an error is returned or you could try to parse the SFTPv3-specific longname field of the SSH_FXP_NAME packet. That's what this function does. The result is returned using the SFTPv4 type constants.

If the longname is in an unrecognized format bool(false) is returned.

Paramètres
string $longname
Renvoie
mixed private

Référencé par SFTP\readlist().

◆ parseMode()

parseMode ( $mode )
private

Attempt to identify the file type

Quoting the SFTP RFC, "Implementations MUST NOT send bits that are not defined" but they seem to anyway

Paramètres
int $mode
Renvoie
int private

Références $mode.

◆ parseTime()

parseTime | ( |  | $key,
 |  |  | $flags,
 |  | & | $response
 | ) |  |
private

Parse Time

See '7.7. Times' of draft-ietf-secsh-filexfer-13 for more info.

Paramètres
string | $key
int | $flags
string | $response
Renvoie
array private

Références $attr, $key, et Strings\unpackSSH2().

◆ partial_init_sftp_connection()

partial_init_sftp_connection ( )
private

Partially initialize an SFTP connection

Exceptions

Références $key, $value, SSH2\$window_size, elseif, SSH2\get_channel_packet(), SSH2\isTimeout(), Strings\packSSH2(), SSH2\send_binary_packet(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

Référencé par SFTP\init_sftp_connection().

◆ precheck()

precheck ( )
private

Check a few things before SFTP functions are called

Renvoie
bool public

Références SFTP\init_sftp_connection(), SSH2\MASK_LOGIN, et SFTP\pwd().

Référencé par SFTP\chdir(), SFTP\delete(), SFTP\file_exists(), SFTP\get(), SFTP\get_xstat_cache_prop(), SFTP\is_readable(), SFTP\is_writable(), SFTP\lstat(), SFTP\mkdir(), SFTP\put(), SFTP\pwd(), SFTP\readlink(), SFTP\readlist(), SFTP\realpath(), SFTP\rmdir(), SFTP\setstat(), SFTP\stat(), SFTP\symlink(), et SFTP\touch().

◆ put()

put | ( | $remote_file,
 |  | $data,
 |  | $mode = self::SOURCE_STRING,
 |  | $start = -1,
 |  | $local_start = -1,
 |  | $progressCallback = null
 | ) |

Uploads a file to the SFTP server.

By default, ::put() does not read from the local filesystem. $data is dumped directly into $remote_file. So, for example, if you set $data to 'filename.ext' and then do get(), you will get a file, twelve bytes long, containing 'filename.ext' as its contents.

Setting $mode to self::SOURCE_LOCAL_FILE will change the above behavior. With self::SOURCE_LOCAL_FILE, $remote_file will contain as many bytes as filename.ext does on your local filesystem. If your filename.ext is 1MB then that is how large $remote_file will be, as well.

Setting $mode to self::SOURCE_CALLBACK will use $data as callback function, which gets only one parameter – number of bytes to return, and returns a string if there is some data or null if there is no more data

If $data is a resource then it'll be used as a resource instead.

Currently, only binary mode is supported. As such, if the line endings need to be adjusted, you will need to take care of that, yourself.

$mode can take an additional two parameters - self::RESUME and self::RESUME_START. These are bitwise AND'd with $mode. So if you want to resume upload of a 300mb file on the local file system you'd set $mode to the following:

self::SOURCE_LOCAL_FILE | self::RESUME

If you wanted to simply append the full contents of a local file to the full contents of a remote file you'd replace self::RESUME with self::RESUME_START.

If $mode & (self::RESUME | self::RESUME_START) then self::RESUME_START will be assumed.

$start and $local_start give you more fine grained control over this process and take precident over self::RESUME when they're non-negative. ie. $start could let you write at the end of a file (like self::RESUME) or in the middle of one. $local_start could let you start your reading from the end of a file (like self::RESUME_START) or in the middle of one.

Setting $local_start to > 0 or $mode | self::RESUME_START doesn't do anything unless $mode | self::SOURCE_LOCAL_FILE.

{

Références $attr, $data, $i, $info, SFTP\$max_sftp_packet, $mode, Joomla\Database\Query\$offset, $result, $size, $start, $temp, SFTP\close_handle(), elseif, SFTP\is_file(), SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\read_put_responses(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\send_sftp_packet(), SFTP\setstat(), SFTP\SOURCE_LOCAL_FILE, et SFTP\stat().

◆ pwd()

pwd ( )

Returns the current directory name

Renvoie
string|bool public

Références SFTP\$pwd, et SFTP\precheck().

Référencé par SFTP\chdir(), SFTP\init_sftp_connection(), SFTP\lstat(), SFTP\precheck(), SFTP\realpath(), et SFTP\stat().

◆ query_stat_cache()

query_stat_cache ( $path )
private

Checks cache for path

Mainly used by file_exists

Paramètres
string $path
Renvoie
mixed private

Références $dir, $path, SFTP\$stat_cache, $temp, et null.

Référencé par SFTP\chdir(), SFTP\file_exists(), SFTP\get_xstat_cache_prop(), SFTP\lstat(), SFTP\nlist_helper(), SFTP\rawlist(), et SFTP\stat().

◆ rawlist()

rawlist | ( | $dir = '.',
 |  | $recursive = false
 | ) |

Returns a detailed list of files in the given directory

Paramètres
string | $dir
bool | $recursive
Renvoie
array|false public

Références $dir, $key, $value, SFTP\lstat(), SFTP\query_stat_cache(), SFTP\readlist(), et SFTP\realpath().

◆ read_put_responses()

read_put_responses ( $i )
private

Reads multiple successive SSH_FXP_WRITE responses

Sending an SSH_FXP_WRITE packet and immediately reading its response isn't as efficient as blindly sending out $i SSH_FXP_WRITEs, in succession, and then reading $i responses.

Paramètres
int $i
Renvoie
bool
Exceptions

Références $i, SFTP\logError(), et Strings\unpackSSH2().

Référencé par SFTP\delete(), SFTP\delete_recursive(), SFTP\put(), SFTP\setstat(), et SFTP\setstat_recursive().

◆ readlink()

readlink ( $link )

Return the target of a symbolic link

Paramètres
string $link
Exceptions

Références $count, $link, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

◆ readlist()

readlist | ( | $dir,
 |  | $raw = true
 | ) |
private

Reads a list, be it detailed or not, of files in the given directory

Paramètres
string | $dir
bool | $raw
Renvoie
array|false
Exceptions

Références SFTP\$attributes, $count, $dir, $i, $temp, $this, SFTP\close_handle(), SFTP\logError(), Strings\packSSH2(), SFTP\parseAttributes(), SFTP\parseLongname(), SFTP\precheck(), SFTP\realpath(), SFTP\send_sftp_packet(), Strings\unpackSSH2(), et SFTP\update_stat_cache().

Référencé par SFTP\delete_recursive(), SFTP\nlist_helper(), SFTP\rawlist(), et SFTP\setstat_recursive().

◆ realpath()

realpath ( $path )

Canonicalize the Server-Side Path Name

SFTP doesn't provide a mechanism by which the current working directory can be changed, so we'll emulate it. Returns the absolute (canonicalized) path.

If canonicalize_paths has been disabled using disablePathCanonicalization(), $path is returned as-is.

Voir également
self::chdir()
self::disablePathCanonicalization()
Paramètres
string $path
Exceptions

Références $dir, $path, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\pwd(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

Référencé par SFTP\chdir(), SFTP\chmod(), SFTP\delete(), SFTP\file_exists(), SFTP\get(), SFTP\get_xstat_cache_prop(), SFTP\init_sftp_connection(), SFTP\is_readable(), SFTP\is_writable(), SFTP\lstat(), SFTP\mkdir(), SFTP\nlist_helper(), SFTP\put(), SFTP\rawlist(), SFTP\readlink(), SFTP\readlist(), SFTP\rmdir(), SFTP\setstat(), SFTP\stat(), SFTP\symlink(), et SFTP\touch().

◆ remove_from_stat_cache()

remove_from_stat_cache ( $path )
private

Remove files / directories from cache

Paramètres
string $path
Renvoie
bool private

Références $dir, $i, $path, SFTP\$stat_cache, et $temp.

Référencé par SFTP\delete(), SFTP\delete_recursive(), SFTP\lstat(), SFTP\put(), SFTP\rmdir(), SFTP\setstat(), et SFTP\stat().

◆ rename()

rename | ( | $oldname,
 |  | $newname
 | ) |

Renames a file or a directory on the SFTP server.

If the file already exists this will return false

Paramètres
string | $oldname
string | $newname
Renvoie
bool
Exceptions

Références Strings\packSSH2(), et Strings\unpackSSH2().

◆ reset_connection()

reset_connection ( $reason )
protected

Resets a connection for re-use

Paramètres
int $reason private

◆ rmdir()

rmdir ( $dir )

Removes a directory.

Paramètres
string $dir
Exceptions

Références $dir, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

◆ send_sftp_packet()

send_sftp_packet | ( | $type,
 |  | $data,
 |  | $request_id = 1
 | ) |
private

Sends SFTP Packets

See '6. General Packet Format' of draft-ietf-secsh-filexfer-13 for more info.

Paramètres
int | $type
string | $data
int | $request_id
Voir également
self::_get_sftp_packet()
self::send_channel_packet()
Renvoie
void private

Références $data, $start, et $type.

Référencé par SFTP\chdir(), SFTP\chmod(), SFTP\close_handle(), SFTP\delete(), SFTP\delete_recursive(), SFTP\get(), SFTP\init_sftp_connection(), SFTP\is_readable(), SFTP\is_writable(), SFTP\mkdir_helper(), SFTP\partial_init_sftp_connection(), SFTP\put(), SFTP\readlink(), SFTP\readlist(), SFTP\realpath(), SFTP\rmdir(), SFTP\setstat(), SFTP\setstat_recursive(), SFTP\stat_helper(), SFTP\symlink(), et SFTP\touch().

◆ setListOrder()

setListOrder ( $args )

Defines how nlist() and rawlist() will be sorted - if at all.

If sorting is enabled directories and files will be sorted independently with directories appearing before files in the resultant array that is returned.

Any parameter returned by stat is a valid sort parameter for this function. Filename comparisons are case insensitive.

Examples:

$sftp->setListOrder('filename', SORT_ASC); $sftp->setListOrder('size', SORT_DESC, 'filename', SORT_ASC); $sftp->setListOrder(true); Separates directories from files but doesn't do any sorting beyond that $sftp->setListOrder(); Don't do any sort of sorting

Paramètres
string ...$args public

Références $i.

◆ setPreferredVersion()

setPreferredVersion ( $version )

Set preferred version

If you're preferred version isn't supported then the highest supported version of SFTP will be utilized. Set to null or false or int(0) to unset the preferred version

Paramètres
int $version public

Références $version.

◆ setstat()

setstat | ( | $filename,
 |  | $attr,
 |  | $recursive
 | ) |
private

Sets information about a file

Paramètres
string | $filename
string | $attr
bool | $recursive
Exceptions

Références $attr, $i, $result, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\read_put_responses(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\send_sftp_packet(), SFTP\setstat_recursive(), et Strings\unpackSSH2().

Référencé par SFTP\chgrp(), SFTP\chmod(), SFTP\chown(), SFTP\put(), SFTP\setstat_recursive(), SFTP\touch(), et SFTP\truncate().

◆ setstat_recursive()

setstat_recursive | ( |  | $path,
 |  |  | $attr,
 |  | & | $i
 | ) |  |
private

Recursively sets information on directories on the SFTP server

Minimizes directory lookups and SSH_FXP_STATUS requests for speed.

Paramètres
string | $path
string | $attr
int | $i
Renvoie
bool private

Références $attr, $i, $path, $temp, Strings\packSSH2(), SFTP\read_put_responses(), SFTP\readlist(), SFTP\send_sftp_packet(), et SFTP\setstat().

Référencé par SFTP\setstat().

◆ stat()

stat ( $filename )

Returns general information about a file.

Returns an array on success and false otherwise.

Paramètres
string $filename
Renvoie
array|false public

Références SFTP\$pwd, $result, SFTP\chdir(), SFTP\precheck(), SFTP\pwd(), SFTP\query_stat_cache(), SFTP\realpath(), SFTP\remove_from_stat_cache(), SFTP\stat_helper(), et SFTP\update_stat_cache().

Référencé par SFTP\file_exists(), SFTP\get(), SFTP\put(), et SFTP\update_stat_cache().

◆ stat_helper()

stat_helper | ( | $filename,
 |  | $type
 | ) |
private

Returns general information about a file or symbolic link

Determines information without calling ::realpath(). The second parameter can be either NET_SFTP_STAT or NET_SFTP_LSTAT.

Paramètres
string | $filename
int | $type
Exceptions

Références $type, SFTP\logError(), Strings\packSSH2(), SFTP\parseAttributes(), et SFTP\send_sftp_packet().

Référencé par SFTP\lstat(), et SFTP\stat().

◆ symlink()

symlink | ( | $target,
 |  | $link
 | ) |

Create a symlink

symlink() creates a symbolic link to the existing target with the specified name link.

Paramètres
string | $target
string | $link
Exceptions

Références $link, $target, $type, SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), SFTP\send_sftp_packet(), et Strings\unpackSSH2().

◆ touch()

touch | ( | $filename,
 |  | $time = null,
 |  | $atime = null
 | ) |

Sets access and modification time of file.

If the file does not exist, it will be created.

Paramètres
string | $filename
int | $time
int | $atime
Exceptions

Références $attr, SFTP\close_handle(), SFTP\logError(), Strings\packSSH2(), SFTP\precheck(), SFTP\realpath(), SFTP\send_sftp_packet(), et SFTP\setstat().

Référencé par SFTP\get().

◆ truncate()

truncate | ( | $filename,
 |  | $new_size
 | ) |

Truncates a file to a given length

Paramètres
string | $filename
int | $new_size
Renvoie
bool public

Références $attr, Strings\packSSH2(), et SFTP\setstat().

◆ update_stat_cache()

update_stat_cache | ( | $path,
 |  | $value
 | ) |
private

Save files / directories to cache

Paramètres
string | $path
mixed | $value | private

Références $dir, $i, $path, SFTP\$stat_cache, $temp, $value, SFTP\lstat(), et SFTP\stat().

Référencé par SFTP\chdir(), SFTP\init_sftp_connection(), SFTP\lstat(), SFTP\readlist(), et SFTP\stat().

Documentation des champs

◆ $allow_arbitrary_length_packets

$allow_arbitrary_length_packets = false
private

◆ $attributes

$attributes
private

Référencé par SFTP\readlist().

◆ $canonicalize_paths

$canonicalize_paths = true
private

◆ $channel_close

$channel_close = false
private

◆ $defaultVersion

$defaultVersion
private

Référencé par SFTP\init_sftp_connection().

◆ $extensions

$extensions = []
private

◆ $file_types

$file_types
private

◆ $max_sftp_packet

$max_sftp_packet
private

Référencé par SFTP\get(), et SFTP\put().

◆ $open_flags

$open_flags
private

◆ $open_flags5

$open_flags5
private

◆ $packet_buffer

$packet_buffer = ''
private

◆ $packet_log

$packet_log = []
private

◆ $packet_type

$packet_type = -1
private

◆ $packet_type_log

$packet_type_log = []
private

◆ $packet_types

$packet_types = []
private

◆ $partial_init

$partial_init = false
private

◆ $preferredVersion

$preferredVersion = 3
private

◆ $preserveTime

$preserveTime = false
private

◆ $pwd

$pwd = false
private

Référencé par SFTP\lstat(), SFTP\pwd(), et SFTP\stat().

◆ $requestBuffer

$requestBuffer = []
private

◆ $sftp_errors

$sftp_errors = []
private

◆ $sortOptions

$sortOptions = []
protected

◆ $stat_cache

$stat_cache = []
private

Référencé par SFTP\query_stat_cache(), SFTP\remove_from_stat_cache(), et SFTP\update_stat_cache().

◆ $status_codes

$status_codes = []
private

◆ $use_request_id

$use_request_id = false
private

◆ $use_stat_cache

$use_stat_cache = true
private

◆ $version

$version
private

◆ CHANNEL

const CHANNEL = 0x100

SFTP channel constant

::exec() uses 0 and ::read() / ::write() use 1.

Voir également
::send_channel_packet()
::get_channel_packet() private

◆ RESUME

const RESUME = 4

Resumes an upload

public

Voir également
::put()

◆ RESUME_START

const RESUME_START = 8

Append a local file to an already existing remote file

public

Voir également
::put()

◆ SOURCE_CALLBACK

const SOURCE_CALLBACK = 16

Reads data from callback: function callback($length) returns string to proceed, null for EOF

public

Voir également
::put()

◆ SOURCE_LOCAL_FILE

const SOURCE_LOCAL_FILE = 1

Reads data from a local file.

public

Voir également
::put()

Référencé par SFTP\put().

◆ SOURCE_STRING

const SOURCE_STRING = 2

Reads data from a string.

public

Voir également
::put()

Référencé par Stream\_stream_write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SFTP.php


Joomla CMS: Référence de la classe SSH2

  • phpseclib3
  • Net
  • SSH2
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe SSH2
+ Graphe d'héritage de SSH2:
SFTP

Fonctions membres publiques

sendIdentificationStringFirst ()
sendIdentificationStringLast ()
sendKEXINITFirst ()
sendKEXINITLast ()
login ($username,... $args)
setTimeout ($timeout)
setKeepAlive ($interval)
getStdError ()
exec ($command, callable $callback=null)
requestAgentForwarding ()
read ($expect='', $mode=self::READ_SIMPLE)
write ($cmd)
startSubsystem ($subsystem)
stopSubsystem ()
reset ()
isTimeout ()
disconnect ()
__destruct ()
isConnected ()
isAuthenticated ()
ping ()
enableQuietMode ()
disableQuietMode ()
isQuietModeEnabled ()
enablePTY ()
disablePTY ()
isPTYEnabled ()
getLog ()
getErrors ()
getLastError ()
getServerIdentification ()
getServerAlgorithms ()
getAlgorithmsNegotiated ()
setTerminal ($term)
setPreferredAlgorithms (array $methods)
getBannerMessage ()
getServerPublicHostKey ()
getExitStatus ()
getWindowColumns ()
getWindowRows ()
setWindowColumns ($value)
setWindowRows ($value)
setWindowSize ($columns=80, $rows=24)
__toString ()
getResourceId ()
getAuthMethodsToContinue ()
enableSmartMFA ()
disableSmartMFA ()

Fonctions membres publiques statiques

static | setCryptoEngine ($engine)
static | getSupportedKEXAlgorithms ()
static | getSupportedHostKeyAlgorithms ()
static | getSupportedEncryptionAlgorithms ()
static | getSupportedMACAlgorithms ()
static | getSupportedCompressionAlgorithms ()
static | getConnectionByResourceId ($id)

Champs de données

const | NET_SSH2_COMPRESSION_NONE = 1
const | NET_SSH2_COMPRESSION_ZLIB = 2
const | NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH = 3
const | MASK_CONSTRUCTOR = 0x00000001
const | MASK_CONNECTED = 0x00000002
const | MASK_LOGIN_REQ = 0x00000004
const | MASK_LOGIN = 0x00000008
const | MASK_SHELL = 0x00000010
const | MASK_WINDOW_ADJUST = 0x00000020
const | CHANNEL_EXEC = 1
const | CHANNEL_SHELL = 2
const | CHANNEL_SUBSYSTEM = 3
const | CHANNEL_AGENT_FORWARD = 4
const | CHANNEL_KEEP_ALIVE = 5
const | LOG_SIMPLE = 1
const | LOG_COMPLEX = 2
const | LOG_REALTIME = 3
const | LOG_REALTIME_FILE = 4
const | LOG_MAX_SIZE = 1048576
const | READ_SIMPLE = 1
const | READ_REGEX = 2
const | READ_NEXT = 3
$fsock

Fonctions membres protégées

sublogin ($username,... $args)
reset_connection ($reason)
get_channel_packet ($client_channel, $skip_extended=false)
send_binary_packet ($data, $logged=null)
send_channel_packet ($client_channel, $data)
disconnect_helper ($reason)
define_array (... $args)
format_log ($message_log, $message_number_log)

Attributs protégés

$bitmap = 0
$server_identifier = false
$server_channels = []
$channel_status = []
$window_size = 0x7FFFFFFF
$window_size_server_to_client = []
$timeout
$curTimeout
$preferred_signature_format = false
$auth = []

Fonctions membres privées

connect ()
generate_identifier ()
key_exchange ($kexinit_payload_server=false)
encryption_algorithm_to_key_size ($algorithm)
login_helper ($username, $password=null)
keyboard_interactive_login ($username, $password)
keyboard_interactive_process (... $responses)
ssh_agent_login ($username, Agent $agent)
privatekey_login ($username, PrivateKey $privatekey)
initShell ()
get_interactive_channel ()
get_open_channel ()
reconnect ()
read_remaining_bytes ($remaining_length)
filter ($payload, $skip_channel_filter)
append_log ($message_number, $message)
close_channel ($client_channel, $want_reply=false)
on_channel_open ()
updateLogHistory ($old, $new)

Fonctions membres privées statiques

static | encryption_algorithm_to_crypt_instance ($algorithm)
static | mac_algorithm_to_hash_instance ($algorithm)
static | bad_algorithm_candidate ($algorithm)
static | array_intersect_first ($array1, $array2)

Attributs privés

$identifier
$errors = []
$kex_algorithms = false
$kex_algorithm = false
$kex_dh_group_size_min = 1536
$kex_dh_group_size_preferred = 2048
$kex_dh_group_size_max = 4096
$server_host_key_algorithms = false
$encryption_algorithms_client_to_server = false
$encryption_algorithms_server_to_client = false
$mac_algorithms_client_to_server = false
$mac_algorithms_server_to_client = false
$compression_algorithms_client_to_server = false
$compression_algorithms_server_to_client = false
$languages_server_to_client = false
$languages_client_to_server = false
$preferred = []
$encrypt_block_size = 8
$decrypt_block_size = 8
$decrypt = false
$decryptName
$decryptInvocationCounter
$decryptFixedPart
$lengthDecrypt = false
$encrypt = false
$encryptName
$encryptInvocationCounter
$encryptFixedPart
$lengthEncrypt = false
$hmac_create = false
$hmac_create_name
$hmac_create_etm
$hmac_check = false
$hmac_check_name
$hmac_check_etm
$hmac_size = false
$server_public_host_key
$session_id = false
$exchange_hash = false
$message_numbers = []
$disconnect_reasons = []
$channel_open_failure_reasons = []
$terminal_modes = []
$channel_extended_data_type_codes = []
$send_seq_no = 0
$get_seq_no = 0
$channel_buffers = []
$packet_size_client_to_server = []
$message_number_log = []
$message_log = []
$window_resize = 0x40000000
$window_size_client_to_server = []
$signature = ''
$signature_format = ''
$interactiveBuffer = ''
$log_size
$keepAlive
$realtime_log_file
$realtime_log_size
$signature_validated = false
$realtime_log_wrap
$quiet_mode = false
$last_packet
$exit_status
$request_pty = false
$in_request_pty_exec = false
$in_subsystem
$stdErrorLog
$last_interactive_response = ''
$keyboard_requests_responses = []
$banner_message = ''
$is_timeout = false
$log_boundary = ':'
$log_long_width = 65
$log_short_width = 16
$host
$port
$windowColumns = 80
$windowRows = 24
$agent
$send_id_string_first = true
$send_kex_first = true
$bad_key_size_fix = false
$retry_connect = false
$binary_packet_buffer = false
$term = 'vt100'
$auth_methods_to_continue = null
$compress = self::NET_SSH2_COMPRESSION_NONE
$decompress = self::NET_SSH2_COMPRESSION_NONE
$compress_context
$decompress_context
$regenerate_compression_context = false
$regenerate_decompression_context = false
$smartMFA = true

Attributs privés statiques

static | $crypto_engine = false
static | $connections

Documentation des constructeurs et destructeur

◆ __destruct()

__destruct ( )

Destructor.

Will be called, automatically, if you're supporting just PHP5. If you're supporting PHP4, you'll need to call disconnect().

public

Références SSH2\disconnect().

Documentation des fonctions membres

◆ __toString()

__toString ( )

To String Magic Method

Renvoie
string public

Références SSH2\getResourceId().

◆ append_log()

append_log | ( | $message_number,
 |  | $message
 | ) |
private

Logs data packets

Makes sure that only the last 1MB worth of packets will be logged

Paramètres
string | $message_number
string | $message | private

Références $message, $start, $temp, SSH2\format_log(), et Strings\shift().

Référencé par SSH2\connect(), et SSH2\send_binary_packet().

◆ array_intersect_first()

static array_intersect_first | ( | $array1,
 |  | $array2
 | ) |
staticprivate

Returns the first value of the intersection of two arrays or false if the intersection is empty. The order is defined by the first parameter.

Paramètres
array | $array1
array | $array2
Renvoie
mixed False if intersection is empty, else intersected value. private

Références $value.

◆ bad_algorithm_candidate()

static bad_algorithm_candidate ( $algorithm )
staticprivate

◆ close_channel()

close_channel | ( | $client_channel,
 |  | $want_reply = false
 | ) |
private

Closes and flushes a channel

doesn't properly close most channels. For exec() channels are normally closed by the server and for SFTP channels are presumably closed when the client disconnects. This functions is intended for SCP more than anything.

Paramètres
int | $client_channel
bool | $want_reply
Renvoie
void private

Références SSH2\disconnect(), SSH2\get_channel_packet(), SSH2\MASK_SHELL, et SSH2\send_binary_packet().

Référencé par SSH2\disablePTY(), SSH2\exec(), SSH2\get_channel_packet(), SSH2\ping(), SSH2\reset(), et SSH2\stopSubsystem().

◆ connect()

connect ( )
private

Connect to an SSHv2 server

Exceptions

Références $data, SSH2\$fsock, SSH2\$host, SSH2\$port, $start, $temp, SSH2\$timeout, SSH2\append_log(), SSH2\generate_identifier(), SSH2\key_exchange(), et null.

Référencé par SSH2\getAlgorithmsNegotiated(), SSH2\getServerAlgorithms(), SSH2\getServerIdentification(), SSH2\getServerPublicHostKey(), SSH2\login_helper(), SSH2\reconnect(), et SSH2\sublogin().

◆ define_array()

define_array ( $args )
protected

Define Array

Takes any number of arrays whose indices are integers and whose values are strings and defines a bunch of named constants from it, using the value as the name of the constant and the index as the value of the constant. If any of the constants that would be defined already exists, none of the constants will be defined.

Paramètres
mixed[] ...$args protected

Références $key, et $value.

Référencé par SFTP\__construct().

◆ disablePTY()

disablePTY ( )

Disable request-pty when using exec()

public

Références SSH2\close_channel().

◆ disableQuietMode()

disableQuietMode ( )

Disable Quiet Mode

Show stderr in output

public

◆ disableSmartMFA()

disableSmartMFA ( )

Disables "smart" multi-factor authentication (MFA)

◆ disconnect()

disconnect ( )

Disconnect

public

Références SSH2\disconnect_helper(), et SSH2\getResourceId().

Référencé par SSH2\__destruct(), et SSH2\close_channel().

◆ disconnect_helper()

disconnect_helper ( $reason )
protected

Disconnect

Paramètres
int $reason
Renvoie
false protected

Références $data, Strings\packSSH2(), et SSH2\send_binary_packet().

Référencé par SSH2\disconnect(), SSH2\exec(), SSH2\filter(), SSH2\get_channel_packet(), SSH2\getServerPublicHostKey(), SSH2\key_exchange(), SSH2\login_helper(), SSH2\privatekey_login(), SSH2\read_remaining_bytes(), et SSH2\reset_connection().

◆ enablePTY()

enablePTY ( )

Enable request-pty when using exec()

public

◆ enableQuietMode()

enableQuietMode ( )

Enable Quiet Mode

Suppress stderr from output

public

◆ enableSmartMFA()

enableSmartMFA ( )

Enables "smart" multi-factor authentication (MFA)

◆ encryption_algorithm_to_crypt_instance()

static encryption_algorithm_to_crypt_instance ( $algorithm )
staticprivate

Maps an encryption algorithm name to an instance of a subclass of .

Paramètres
string $algorithm Name of the encryption algorithm
Renvoie
SymmetricKey|null private

Références null.

◆ encryption_algorithm_to_key_size()

encryption_algorithm_to_key_size ( $algorithm )
private

Maps an encryption algorithm name to the number of key bytes.

Paramètres
string $algorithm Name of the encryption algorithm
Renvoie
int|null Number of bytes as an integer or null for unknown private

Références null.

Référencé par SSH2\key_exchange().

◆ exec()

exec | ( |  | $command,
 |  | callable | $callback = null
 | ) |  |

Execute Command

If $callback is set to false then ::get_channel_packet(self::CHANNEL_EXEC) will need to be called manually. In all likelihood, this is not a feature you want to be taking advantage of.

Paramètres
string $command
Renvoie
string|bool -return ($callback is callable ? bool : string|bool)
Exceptions

Références $output, $temp, SSH2\$terminal_modes, SSH2\$timeout, SSH2\$window_size, SSH2\close_channel(), SSH2\disconnect_helper(), SSH2\get_channel_packet(), SSH2\isAuthenticated(), Strings\packSSH2(), SSH2\send_binary_packet(), et true.

◆ filter()

filter | ( | $payload,
 |  | $skip_channel_filter
 | ) |
private

Filter Binary Packets

Because some binary packets need to be ignored...

Voir également
self::_get_binary_packet()
Paramètres
string | $payload
bool | $skip_channel_filter
Renvoie
string|bool private

Références $data, $message, SSH2\$window_size, SSH2\disconnect_helper(), SSH2\get_channel_packet(), SSH2\isAuthenticated(), SSH2\key_exchange(), Strings\packSSH2(), SSH2\send_binary_packet(), Strings\shift(), et Strings\unpackSSH2().

◆ format_log()

format_log | ( | $message_log,
 |  | $message_number_log
 | ) |
protected

Formats a log for printing

Paramètres
array | $message_log
array | $message_number_log | private
Renvoie
string

Références $i, SSH2\$message_log, SSH2\$message_number_log, $output, et Strings\shift().

Référencé par SSH2\append_log(), et SSH2\getLog().

◆ generate_identifier()

generate_identifier ( )
private

Generates the SSH identifier

You should overwrite this method in your own class if you want to use another identifier

protected

Renvoie
string

Références SSH2\$identifier, et elseif.

Référencé par SSH2\connect().

◆ get_channel_packet()

get_channel_packet | ( | $client_channel,
 |  | $skip_extended = false
 | ) |
protected

Gets channel data

Returns the data as a string. bool(true) is returned if:

  • the server closes the channel
  • if the connection times out
  • if the channel status is CHANNEL_OPEN and the response was CHANNEL_OPEN_CONFIRMATION
  • if the channel status is CHANNEL_REQUEST and the response was CHANNEL_SUCCESS

bool(false) is returned if:

  • if the channel status is CHANNEL_REQUEST and the response was CHANNEL_FAILURE
Paramètres
int | $client_channel
bool | $skip_extended
Renvoie
mixed
Exceptions

Références SSH2\$binary_packet_buffer, $data, $i, $result, $type, $value, SSH2\$window_resize, SSH2\$window_size, SSH2\close_channel(), SSH2\disconnect_helper(), SSH2\MASK_SHELL, SSH2\on_channel_open(), SSH2\send_binary_packet(), SSH2\send_channel_packet(), true, et Strings\unpackSSH2().

Référencé par SSH2\close_channel(), SSH2\exec(), SSH2\filter(), SSH2\initShell(), SFTP\partial_init_sftp_connection(), SSH2\ping(), SSH2\read(), SSH2\requestAgentForwarding(), SSH2\send_channel_packet(), et SSH2\startSubsystem().

◆ get_interactive_channel()

get_interactive_channel ( )
private

Return the channel to be used with read() / write()

Voir également
self::read()
self::write()
Renvoie
int public

Référencé par SSH2\read(), SSH2\reset(), et SSH2\write().

◆ get_open_channel()

get_open_channel ( )
private

Return an available open channel

Renvoie
int public

Référencé par SSH2\requestAgentForwarding().

◆ getAlgorithmsNegotiated()

getAlgorithmsNegotiated ( )

Return list of negotiated algorithms

Uses the same format as https://www.php.net/ssh2-methods-negotiated

Renvoie
array public

Références SSH2\$compress, SSH2\$decompress, SSH2\$decryptName, SSH2\$encryptName, SSH2\$hmac_check_name, SSH2\$hmac_create_name, SSH2\$kex_algorithm, SSH2\$signature_format, et SSH2\connect().

◆ getAuthMethodsToContinue()

getAuthMethodsToContinue ( )

Return the list of authentication methods that may productively continue authentication.

Voir également
https://tools.ietf.org/html/rfc4252#section-5.1
Renvoie
array|null

Références SSH2\$auth_methods_to_continue.

◆ getBannerMessage()

getBannerMessage ( )

Returns the banner message.

Quoting from the RFC, "in some jurisdictions, sending a warning message before authentication may be relevant for getting legal protection."

Renvoie
string public

Références SSH2\$banner_message.

◆ getConnectionByResourceId()

static getConnectionByResourceId ( $id )
static

Return existing connection

Paramètres
string $id
Renvoie
bool|SSH2 will return false if no such connection

Références $id.

Référencé par Stream\parse_path().

◆ getErrors()

getErrors ( )

Returns all errors

Renvoie
string[] public

Références SSH2\$errors.

◆ getExitStatus()

getExitStatus ( )

Returns the exit status of an SSH command or false.

Renvoie
false|int public

Références SSH2\$exit_status.

◆ getLastError()

getLastError ( )

Returns the last error

Renvoie
string public

Références $count.

◆ getLog()

getLog ( )

Returns a log of the packets that have been sent and received.

Returns a string if NET_SSH2_LOGGING == self::LOG_COMPLEX, an array if NET_SSH2_LOGGING == self::LOG_SIMPLE and false if !defined('NET_SSH2_LOGGING')

public

Renvoie
array|false|string

Références SSH2\$message_number_log, et SSH2\format_log().

◆ getResourceId()

getResourceId ( )

Get Resource ID

We use {} because that symbols should not be in URL according to RFC. It will safe us from any conflicts, because otherwise regexp will match all alphanumeric domains.

Renvoie
string

Références $this.

Référencé par SSH2\__toString(), et SSH2\disconnect().

◆ getServerAlgorithms()

getServerAlgorithms ( )

Returns a list of algorithms the server supports

Renvoie
array public

Références SSH2\$compression_algorithms_client_to_server, SSH2\$compression_algorithms_server_to_client, SSH2\$encryption_algorithms_client_to_server, SSH2\$encryption_algorithms_server_to_client, SSH2\$kex_algorithms, SSH2\$languages_client_to_server, SSH2\$languages_server_to_client, SSH2\$mac_algorithms_client_to_server, SSH2\$mac_algorithms_server_to_client, SSH2\$server_host_key_algorithms, et SSH2\connect().

◆ getServerIdentification()

getServerIdentification ( )

Return the server identification.

Renvoie
string|false public

Références SSH2\$server_identifier, et SSH2\connect().

◆ getServerPublicHostKey()

getServerPublicHostKey ( )

Returns the server public host key.

Caching this the first time you connect to a server and checking the result on subsequent connections is recommended. Returns false if the server signature is not signed correctly with the public host key.

Renvoie
string|false
Exceptions

Références $hash, $key, SSH2\$server_public_host_key, SSH2\$signature, $this, SSH2\connect(), SSH2\disconnect_helper(), AsymmetricKey\loadFormat(), RSA\SIGNATURE_PKCS1, et Strings\unpackSSH2().

◆ getStdError()

getStdError ( )

Get the output from stdError

public

Références SSH2\$stdErrorLog.

◆ getSupportedCompressionAlgorithms()

static getSupportedCompressionAlgorithms ( )
static

Returns a list of compression algorithms that phpseclib supports

Renvoie
array public

Référencé par SSH2\key_exchange().

◆ getSupportedEncryptionAlgorithms()

static getSupportedEncryptionAlgorithms ( )
static

Returns a list of symmetric key algorithms that phpseclib supports

Renvoie
array public

Référencé par SSH2\key_exchange().

◆ getSupportedHostKeyAlgorithms()

static getSupportedHostKeyAlgorithms ( )
static

Returns a list of host key algorithms that phpseclib supports

Renvoie
array public

Référencé par SSH2\key_exchange().

◆ getSupportedKEXAlgorithms()

static getSupportedKEXAlgorithms ( )
static

Returns a list of KEX algorithms that phpseclib supports

Renvoie
array public

Références SSH2\$kex_algorithms.

Référencé par SSH2\key_exchange().

◆ getSupportedMACAlgorithms()

static getSupportedMACAlgorithms ( )
static

Returns a list of MAC algorithms that phpseclib supports

Renvoie
array public

Référencé par SSH2\key_exchange().

◆ getWindowColumns()

getWindowColumns ( )

Returns the number of columns for the terminal window size.

Renvoie
int public

Références SSH2\$windowColumns.

◆ getWindowRows()

getWindowRows ( )

Returns the number of rows for the terminal window size.

Renvoie
int public

Références SSH2\$windowRows.

◆ initShell()

initShell ( )
private

Creates an interactive shell

Voir également
self::read()
self::write()
Renvoie
bool
Exceptions

Références SSH2\$terminal_modes, SSH2\$window_size, SSH2\get_channel_packet(), Strings\packSSH2(), et SSH2\send_binary_packet().

Référencé par SSH2\read(), et SSH2\write().

◆ isAuthenticated()

isAuthenticated ( )

Have you successfully been logged in?

Renvoie
bool public

Référencé par SSH2\exec(), SSH2\filter(), SSH2\ping(), SSH2\read(), SSH2\send_binary_packet(), et SSH2\write().

◆ isConnected()

isConnected ( )

Is the connection still active?

Renvoie
bool public

◆ isPTYEnabled()

isPTYEnabled ( )

Returns whether request-pty is enabled or not

Voir également
self::enablePTY()
self::disablePTY() public
Renvoie
bool

Références SSH2\$request_pty.

◆ isQuietModeEnabled()

isQuietModeEnabled ( )

Returns whether Quiet Mode is enabled or not

Voir également
self::enableQuietMode()
self::disableQuietMode() public
Renvoie
bool

Références SSH2\$quiet_mode.

◆ isTimeout()

isTimeout ( )

Is timeout?

Did exec() or read() return because they timed out or because they encountered the end?

public

Références SSH2\$is_timeout.

Référencé par SFTP\partial_init_sftp_connection().

◆ key_exchange()

key_exchange ( $kexinit_payload_server = false )
private

Key Exchange

Renvoie
bool
Paramètres
string | bool $kexinit_payload_server optional
Exceptions

Références $data, SSH2\$decrypt, SSH2\$encrypt, SSH2\$exchange_hash, $g, SSH2\$kex_algorithms, $key, $params, SSH2\$preferred, SSH2\$server_host_key_algorithms, SSH2\$server_public_host_key, $temp, $type, DH\computeSecret(), EC\createKey(), DH\createKey(), DH\createParameters(), SSH2\disconnect_helper(), elseif, SSH2\encryption_algorithm_to_key_size(), SSH2\getSupportedCompressionAlgorithms(), SSH2\getSupportedEncryptionAlgorithms(), SSH2\getSupportedHostKeyAlgorithms(), SSH2\getSupportedKEXAlgorithms(), SSH2\getSupportedMACAlgorithms(), null, Strings\packSSH2(), SSH2\send_binary_packet(), Strings\shift(), Random\string(), Strings\unpackSSH2(), et SSH2\updateLogHistory().

Référencé par SSH2\connect(), et SSH2\filter().

◆ keyboard_interactive_login()

keyboard_interactive_login | ( | $username,
 |  | $password
 | ) |
private

Login via keyboard-interactive authentication

See RFC4256 for details. This is not a full-featured keyboard-interactive authenticator.

Paramètres
string | $username
string | array | $password
Renvoie
bool private

Références $password, SSH2\keyboard_interactive_process(), Strings\packSSH2(), et SSH2\send_binary_packet().

Référencé par SSH2\login_helper().

◆ keyboard_interactive_process()

keyboard_interactive_process ( $responses )
private

Handle the keyboard-interactive requests / responses.

Paramètres
string|array ...$responses
Renvoie
bool
Exceptions

Références $i, $key, SSH2\$last_interactive_response, $type, $value, Strings\packSSH2(), SSH2\send_binary_packet(), Strings\unpackSSH2(), et SSH2\updateLogHistory().

Référencé par SSH2\keyboard_interactive_login(), et SSH2\login_helper().

◆ login()

login | ( | $username,
 |  | $args
 | ) |

Login

The $password parameter can be a plaintext password, a |EC|DSA object, a object or an array

Paramètres
string | $username
string|AsymmetricKey|array[]|Agent|null | ...$args
Renvoie
bool
Voir également
self::_login() public

Références null, et SSH2\sublogin().

Référencé par SSH2\reconnect().

◆ login_helper()

login_helper | ( | $username,
 |  | $password = null
 | ) |
private

Login Helper

{

Références $message, $password, $type, SSH2\connect(), SSH2\disconnect_helper(), false, Strings\is_stringable(), SSH2\keyboard_interactive_login(), SSH2\keyboard_interactive_process(), null, Strings\packSSH2(), SSH2\privatekey_login(), SSH2\send_binary_packet(), SSH2\ssh_agent_login(), Strings\unpackSSH2(), et SSH2\updateLogHistory().

Référencé par SSH2\sublogin().

◆ mac_algorithm_to_hash_instance()

static mac_algorithm_to_hash_instance ( $algorithm )
staticprivate

Maps an encryption algorithm name to an instance of a subclass of .

Paramètres
string $algorithm Name of the encryption algorithm
Renvoie
array{Hash, int}|null private

◆ on_channel_open()

on_channel_open ( )
private

Helper function for agent->on_channel_open()

Used when channels are created to inform agent of said channel opening. Must be called after channel open confirmation received

private

Références $this.

Référencé par SSH2\get_channel_packet().

◆ ping()

ping ( )

Pings a server connection, or tries to reconnect if the connection has gone down

Inspired by http://php.net/manual/en/mysqli.ping.php

Renvoie
bool

Références SSH2\$window_size, SSH2\close_channel(), SSH2\get_channel_packet(), SSH2\isAuthenticated(), Strings\packSSH2(), SSH2\reconnect(), et SSH2\send_binary_packet().

◆ privatekey_login()

privatekey_login | ( |  | $username,
 |  | PrivateKey | $privatekey
 | ) |  |
private

Login with an RSA private key

{

Références $hash, SSH2\$signature, $type, SSH2\disconnect_helper(), elseif, PrivateKey\getPublicKey(), Strings\packSSH2(), SSH2\send_binary_packet(), PrivateKey\sign(), RSA\SIGNATURE_PKCS1, Strings\unpackSSH2(), et SSH2\updateLogHistory().

Référencé par SSH2\login_helper(), et SSH2\ssh_agent_login().

◆ read()

read | ( | $expect = '',
 |  | $mode = self::READ_SIMPLE
 | ) |

Returns the output of an interactive shell

Returns when there's a match for $expect, which can take the form of a string literal or, if $mode == self::READ_REGEX, a regular expression.

Voir également
self::write()
Paramètres
string | $expect
int | $mode
Renvoie
string|bool|null
Exceptions

Références $mode, SSH2\$timeout, SSH2\get_channel_packet(), SSH2\get_interactive_channel(), SSH2\initShell(), SSH2\isAuthenticated(), et Strings\shift().

◆ read_remaining_bytes()

read_remaining_bytes ( $remaining_length )
private

Read Remaining Bytes

Voir également
self::get_binary_packet()
Paramètres
int $remaining_length
Renvoie
string private

Références $buffer, $temp, SSH2\disconnect_helper(), SSH2\MASK_LOGIN, et SSH2\reset_connection().

◆ reconnect()

reconnect ( )
private

In situ reconnect method

Renvoie
boolean

Références SSH2\$auth, $result, SSH2\connect(), SSH2\login(), et SSH2\reset_connection().

Référencé par SSH2\ping().

◆ requestAgentForwarding()

requestAgentForwarding ( )

Request agent forwarding of remote server

Renvoie
bool public

Références SSH2\get_channel_packet(), SSH2\get_open_channel(), Strings\packSSH2(), et SSH2\send_binary_packet().

◆ reset()

reset ( )

Closes a channel

If read() timed out you might want to just close the channel and have it auto-restart on the next read() call

public

Références SSH2\close_channel(), et SSH2\get_interactive_channel().

◆ reset_connection()

reset_connection ( $reason )
protected

Resets a connection for re-use

Paramètres
int $reason private

Références SSH2\disconnect_helper().

Référencé par SSH2\read_remaining_bytes(), et SSH2\reconnect().

◆ send_binary_packet()

send_binary_packet | ( | $data,
 |  | $logged = null
 | ) |
protected

Sends Binary Packets

See '6. Binary Packet Protocol' of rfc4253 for more info.

Paramètres
string | $data
string | $logged
Voir également
self::_get_binary_packet()
Renvoie
void private

Références $data, SSH2\$encrypt_block_size, $header, $start, $temp, SSH2\append_log(), class, Strings\increment_str(), SSH2\isAuthenticated(), et Random\string().

Référencé par SSH2\close_channel(), SSH2\disconnect_helper(), SSH2\exec(), SSH2\filter(), SSH2\get_channel_packet(), SSH2\initShell(), SSH2\key_exchange(), SSH2\keyboard_interactive_login(), SSH2\keyboard_interactive_process(), SSH2\login_helper(), SFTP\partial_init_sftp_connection(), SSH2\ping(), SSH2\privatekey_login(), SSH2\requestAgentForwarding(), SSH2\send_channel_packet(), et SSH2\startSubsystem().

◆ send_channel_packet()

send_channel_packet | ( | $client_channel,
 |  | $data
 | ) |
protected

Sends channel data

Spans multiple SSH_MSG_CHANNEL_DATAs if appropriate

Paramètres
int | $client_channel
string | $data
Renvoie
void

Références $data, $temp, SSH2\get_channel_packet(), Strings\packSSH2(), SSH2\send_binary_packet(), et Strings\shift().

Référencé par SSH2\get_channel_packet(), et SSH2\write().

◆ sendIdentificationStringFirst()

sendIdentificationStringFirst ( )

Send Identification String First

https://tools.ietf.org/html/rfc4253#section-4.2 says "when the connection has been established, both sides MUST send an identification string". It does not say which side sends it first. In theory it shouldn't matter but it is a fact of life that some SSH servers are simply buggy

public

◆ sendIdentificationStringLast()

sendIdentificationStringLast ( )

Send Identification String Last

https://tools.ietf.org/html/rfc4253#section-4.2 says "when the connection has been established, both sides MUST send an identification string". It does not say which side sends it first. In theory it shouldn't matter but it is a fact of life that some SSH servers are simply buggy

public

◆ sendKEXINITFirst()

sendKEXINITFirst ( )

Send SSH_MSG_KEXINIT First

https://tools.ietf.org/html/rfc4253#section-7.1 says "key exchange begins by each sending sending the [SSH_MSG_KEXINIT] packet". It does not say which side sends it first. In theory it shouldn't matter but it is a fact of life that some SSH servers are simply buggy

public

◆ sendKEXINITLast()

sendKEXINITLast ( )

Send SSH_MSG_KEXINIT Last

https://tools.ietf.org/html/rfc4253#section-7.1 says "key exchange begins by each sending sending the [SSH_MSG_KEXINIT] packet". It does not say which side sends it first. In theory it shouldn't matter but it is a fact of life that some SSH servers are simply buggy

public

◆ setCryptoEngine()

static setCryptoEngine ( $engine )
static

Set Crypto Engine Mode

Possible $engine values: OpenSSL, mcrypt, Eval, PHP

Paramètres
int $engine public

◆ setKeepAlive()

setKeepAlive ( $interval )

Set Keep Alive

Sends an SSH2_MSG_IGNORE message every x seconds, if x is a positive non-zero number.

Paramètres
int $interval public

◆ setPreferredAlgorithms()

setPreferredAlgorithms ( array $methods )

Accepts an associative array with up to four parameters as described at https://www.php.net/manual/en/function.ssh2-connect.php

Paramètres
array $methods public

Références $key, et SSH2\$preferred.

◆ setTerminal()

setTerminal ( $term )

Allows you to set the terminal

Paramètres
string $term public

Références SSH2\$term.

◆ setTimeout()

setTimeout ( $timeout )

Set Timeout

$ssh->exec('ping 127.0.0.1'); on a Linux host will never return and will run indefinitely. setTimeout() makes it so it'll timeout. Setting $timeout to false or 0 will mean there is no timeout.

Paramètres
mixed $timeout public

Références SSH2\$timeout.

◆ setWindowColumns()

setWindowColumns ( $value )

Sets the number of columns for the terminal window size.

Paramètres
int $value public

Références $value.

◆ setWindowRows()

setWindowRows ( $value )

Sets the number of rows for the terminal window size.

Paramètres
int $value public

Références $value.

◆ setWindowSize()

setWindowSize | ( | $columns = 80,
 |  | $rows = 24
 | ) |

Sets the number of columns and rows for the terminal window size.

Paramètres
int | $columns
int | $rows | public

Références $columns, et $rows.

◆ ssh_agent_login()

ssh_agent_login | ( |  | $username,
 |  | Agent | $agent
 | ) |  |
private

Login with an ssh-agent provided key

Paramètres
string | $username
\phpseclib3\System\SSH\Agent | $agent
Renvoie
bool private

Références SSH2\$agent, $key, et SSH2\privatekey_login().

Référencé par SSH2\login_helper().

◆ startSubsystem()

startSubsystem ( $subsystem )

Start a subsystem.

Right now only one subsystem at a time is supported. To support multiple subsystem's stopSubsystem() could accept a string that contained the name of the subsystem, but at that point, only one subsystem of each type could be opened. To support multiple subsystem's of the same name maybe it'd be best if startSubsystem() generated a new channel id and returns that and then that that was passed into stopSubsystem() but that'll be saved for a future date and implemented if there's sufficient demand for such a feature.

Voir également
self::stopSubsystem()
Paramètres
string $subsystem
Renvoie
bool public

Références SSH2\$window_size, SSH2\get_channel_packet(), Strings\packSSH2(), et SSH2\send_binary_packet().

◆ stopSubsystem()

stopSubsystem ( )

Stops a subsystem.

Voir également
self::startSubsystem()
Renvoie
bool public

Références SSH2\close_channel().

◆ sublogin()

sublogin | ( | $username,
 |  | $args
 | ) |
protected

Login Helper

Paramètres
string | $username
string | ...$args
Renvoie
bool
Voir également
self::_login_helper() private

Références $key, $method, SSH2\connect(), Strings\is_stringable(), et SSH2\login_helper().

Référencé par SSH2\login().

◆ updateLogHistory()

updateLogHistory | ( | $old,
 |  | $new
 | ) |
private

Référencé par SSH2\key_exchange(), SSH2\keyboard_interactive_process(), SSH2\login_helper(), et SSH2\privatekey_login().

◆ write()

write ( $cmd )

Inputs a command into an interactive shell.

Voir également
SSH2::read()
Paramètres
string $cmd
Renvoie
void
Exceptions

Références SSH2\get_interactive_channel(), SSH2\initShell(), SSH2\isAuthenticated(), et SSH2\send_channel_packet().

Documentation des champs

◆ $agent

$agent
private

Référencé par SSH2\ssh_agent_login().

◆ $auth

$auth = []
protected

Référencé par SSH2\reconnect().

◆ $auth_methods_to_continue

$auth_methods_to_continue = null
private

Référencé par SSH2\getAuthMethodsToContinue().

◆ $bad_key_size_fix

$bad_key_size_fix = false
private

◆ $banner_message

$banner_message = ''
private

Référencé par SSH2\getBannerMessage().

◆ $binary_packet_buffer

$binary_packet_buffer = false
private

Référencé par SSH2\get_channel_packet().

◆ $bitmap

$bitmap = 0
protected

◆ $channel_buffers

$channel_buffers = []
private

◆ $channel_extended_data_type_codes

$channel_extended_data_type_codes = []
private

◆ $channel_open_failure_reasons

$channel_open_failure_reasons = []
private

◆ $channel_status

$channel_status = []
protected

◆ $compress

$compress = self::NET_SSH2_COMPRESSION_NONE
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $compress_context

$compress_context
private

◆ $compression_algorithms_client_to_server

$compression_algorithms_client_to_server = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $compression_algorithms_server_to_client

$compression_algorithms_server_to_client = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $connections

$connections
staticprivate

◆ $crypto_engine

$crypto_engine = false
staticprivate

◆ $curTimeout

$curTimeout
protected

Current Timeout

Voir également
self::get_channel_packet() private

◆ $decompress

$decompress = self::NET_SSH2_COMPRESSION_NONE
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $decompress_context

$decompress_context
private

◆ $decrypt

$decrypt = false
private

Référencé par SSH2\key_exchange().

◆ $decrypt_block_size

$decrypt_block_size = 8
private

◆ $decryptFixedPart

$decryptFixedPart
private

◆ $decryptInvocationCounter

$decryptInvocationCounter
private

◆ $decryptName

$decryptName
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $disconnect_reasons

$disconnect_reasons = []
private

◆ $encrypt

$encrypt = false
private

Référencé par SSH2\key_exchange().

◆ $encrypt_block_size

$encrypt_block_size = 8
private

Référencé par SSH2\send_binary_packet().

◆ $encryptFixedPart

$encryptFixedPart
private

◆ $encryptInvocationCounter

$encryptInvocationCounter
private

◆ $encryption_algorithms_client_to_server

$encryption_algorithms_client_to_server = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $encryption_algorithms_server_to_client

$encryption_algorithms_server_to_client = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $encryptName

$encryptName
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $errors

$errors = []
private

Référencé par SSH2\getErrors().

◆ $exchange_hash

$exchange_hash = false
private

Référencé par SSH2\key_exchange().

◆ $exit_status

$exit_status
private

Référencé par SSH2\getExitStatus().

◆ $fsock

$fsock

Référencé par SSH2\connect().

◆ $get_seq_no

$get_seq_no = 0
private

◆ $hmac_check

$hmac_check = false
private

◆ $hmac_check_etm

$hmac_check_etm
private

◆ $hmac_check_name

$hmac_check_name
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $hmac_create

$hmac_create = false
private

◆ $hmac_create_etm

$hmac_create_etm
private

◆ $hmac_create_name

$hmac_create_name
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $hmac_size

$hmac_size = false
private

◆ $host

$host
private

Référencé par SFTP\__construct(), SSH2\connect(), et Stream\parse_path().

◆ $identifier

$identifier
private

Référencé par SSH2\generate_identifier().

◆ $in_request_pty_exec

$in_request_pty_exec = false
private

◆ $in_subsystem

$in_subsystem
private

◆ $interactiveBuffer

$interactiveBuffer = ''
private

◆ $is_timeout

$is_timeout = false
private

Référencé par SSH2\isTimeout().

◆ $keepAlive

$keepAlive
private

Keep Alive Interval

Voir également
self::setKeepAlive() private

◆ $kex_algorithm

$kex_algorithm = false
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $kex_algorithms

$kex_algorithms = false
private

Référencé par SSH2\getServerAlgorithms(), SSH2\getSupportedKEXAlgorithms(), et SSH2\key_exchange().

◆ $kex_dh_group_size_max

$kex_dh_group_size_max = 4096
private

◆ $kex_dh_group_size_min

$kex_dh_group_size_min = 1536
private

◆ $kex_dh_group_size_preferred

$kex_dh_group_size_preferred = 2048
private

◆ $keyboard_requests_responses

$keyboard_requests_responses = []
private

◆ $languages_client_to_server

$languages_client_to_server = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $languages_server_to_client

$languages_server_to_client = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $last_interactive_response

$last_interactive_response = ''
private

Référencé par SSH2\keyboard_interactive_process().

◆ $last_packet

$last_packet
private

◆ $lengthDecrypt

$lengthDecrypt = false
private

◆ $lengthEncrypt

$lengthEncrypt = false
private

◆ $log_boundary

$log_boundary = ':'
private

◆ $log_long_width

$log_long_width = 65
private

◆ $log_short_width

$log_short_width = 16
private

◆ $log_size

$log_size
private

◆ $mac_algorithms_client_to_server

$mac_algorithms_client_to_server = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $mac_algorithms_server_to_client

$mac_algorithms_server_to_client = false
private

Référencé par SSH2\getServerAlgorithms().

◆ $message_log

$message_log = []
private

Référencé par SSH2\format_log().

◆ $message_number_log

$message_number_log = []
private

Référencé par SSH2\format_log(), et SSH2\getLog().

◆ $message_numbers

$message_numbers = []
private

◆ $packet_size_client_to_server

$packet_size_client_to_server = []
private

◆ $port

$port
private

Référencé par SFTP\__construct(), SSH2\connect(), et Stream\parse_path().

◆ $preferred

$preferred = []
private

Référencé par SSH2\key_exchange(), et SSH2\setPreferredAlgorithms().

◆ $preferred_signature_format

$preferred_signature_format = false
protected

◆ $quiet_mode

$quiet_mode = false
private

Flag to suppress stderr from output

Voir également
self::enableQuietMode() private

Référencé par SSH2\isQuietModeEnabled().

◆ $realtime_log_file

$realtime_log_file
private

◆ $realtime_log_size

$realtime_log_size
private

◆ $realtime_log_wrap

$realtime_log_wrap
private

Real-time log file wrap boolean

Voir également
self::_append_log() private

◆ $regenerate_compression_context

$regenerate_compression_context = false
private

◆ $regenerate_decompression_context

$regenerate_decompression_context = false
private

◆ $request_pty

$request_pty = false
private

Référencé par SSH2\isPTYEnabled().

◆ $retry_connect

$retry_connect = false
private

◆ $send_id_string_first

$send_id_string_first = true
private

◆ $send_kex_first

$send_kex_first = true
private

◆ $send_seq_no

$send_seq_no = 0
private

◆ $server_channels

$server_channels = []
protected

◆ $server_host_key_algorithms

$server_host_key_algorithms = false
private

Référencé par SSH2\getServerAlgorithms(), et SSH2\key_exchange().

◆ $server_identifier

$server_identifier = false
protected

Référencé par SSH2\getServerIdentification().

◆ $server_public_host_key

$server_public_host_key
private

Référencé par SSH2\getServerPublicHostKey(), et SSH2\key_exchange().

◆ $session_id

$session_id = false
private

◆ $signature

$signature = ''
private

Référencé par SSH2\getServerPublicHostKey(), et SSH2\privatekey_login().

◆ $signature_format

$signature_format = ''
private

Référencé par SSH2\getAlgorithmsNegotiated().

◆ $signature_validated

$signature_validated = false
private

◆ $smartMFA

$smartMFA = true
private

◆ $stdErrorLog

$stdErrorLog
private

Référencé par SSH2\getStdError().

◆ $term

$term = 'vt100'
private

Référencé par SSH2\setTerminal().

◆ $terminal_modes

$terminal_modes = []
private

Référencé par SSH2\exec(), et SSH2\initShell().

◆ $timeout

$timeout
protected

Timeout

Voir également
self::setTimeout() private

Référencé par SFTP\__construct(), SSH2\connect(), SSH2\exec(), SSH2\read(), et SSH2\setTimeout().

◆ $window_resize

$window_resize = 0x40000000
private

Référencé par SSH2\get_channel_packet().

◆ $window_size

$window_size = 0x7FFFFFFF
protected

Référencé par SSH2\exec(), SSH2\filter(), SSH2\get_channel_packet(), SSH2\initShell(), SFTP\partial_init_sftp_connection(), SSH2\ping(), et SSH2\startSubsystem().

◆ $window_size_client_to_server

$window_size_client_to_server = []
private

◆ $window_size_server_to_client

$window_size_server_to_client = []
protected

◆ $windowColumns

$windowColumns = 80
private

Référencé par SSH2\getWindowColumns().

◆ $windowRows

$windowRows = 24
private

Référencé par SSH2\getWindowRows().

◆ CHANNEL_AGENT_FORWARD

const CHANNEL_AGENT_FORWARD = 4

◆ CHANNEL_EXEC

const CHANNEL_EXEC = 1

◆ CHANNEL_KEEP_ALIVE

const CHANNEL_KEEP_ALIVE = 5

◆ CHANNEL_SHELL

const CHANNEL_SHELL = 2

◆ CHANNEL_SUBSYSTEM

const CHANNEL_SUBSYSTEM = 3

◆ LOG_COMPLEX

const LOG_COMPLEX = 2

Returns the message content

public

Voir également
::getLog()

◆ LOG_MAX_SIZE

const LOG_MAX_SIZE = 1048576

Make sure that the log never gets larger than this

public

Voir également
::getLog()

◆ LOG_REALTIME

const LOG_REALTIME = 3

Outputs the content real-time

public

Voir également
::getLog()

◆ LOG_REALTIME_FILE

const LOG_REALTIME_FILE = 4

Dumps the content real-time to a file

public

Voir également
::getLog()

◆ LOG_SIMPLE

const LOG_SIMPLE = 1

Returns the message numbers

public

Voir également
::getLog()

◆ MASK_CONNECTED

const MASK_CONNECTED = 0x00000002

◆ MASK_CONSTRUCTOR

const MASK_CONSTRUCTOR = 0x00000001

#-

◆ MASK_LOGIN

const MASK_LOGIN = 0x00000008

Référencé par SFTP\getSupportedVersions(), SFTP\precheck(), et SSH2\read_remaining_bytes().

◆ MASK_LOGIN_REQ

const MASK_LOGIN_REQ = 0x00000004

◆ MASK_SHELL

const MASK_SHELL = 0x00000010

Référencé par SSH2\close_channel(), et SSH2\get_channel_packet().

◆ MASK_WINDOW_ADJUST

const MASK_WINDOW_ADJUST = 0x00000020

◆ NET_SSH2_COMPRESSION_NONE

const NET_SSH2_COMPRESSION_NONE = 1

#+ Compression Types

private No compression

◆ NET_SSH2_COMPRESSION_ZLIB

const NET_SSH2_COMPRESSION_ZLIB = 2

zlib compression

◆ NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH

const NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH = 3

zlib@.nosp@m.open.nosp@m.ssh.c.nosp@m.om

◆ READ_NEXT

const READ_NEXT = 3

Returns whenever a data packet is received.

Some data packets may only contain a single character so it may be necessary to call read() multiple times when using this option

public

Voir également
::read()

◆ READ_REGEX

const READ_REGEX = 2

Returns when a string matching the regular expression $expect is found

public

Voir également
::read()

◆ READ_SIMPLE

const READ_SIMPLE = 1

Returns when a string matching $expect exactly is found

public

Voir également
::read()
La documentation de cette classe a été générée à partir du fichier suivant :
  • Net/SSH2.php


Joomla CMS: Référence de la classe Identity

  • phpseclib3
  • System
  • SSH
  • Agent
  • Identity
Fonctions membres publiques | Champs de données | Attributs privés | Attributs privés statiques
Référence de la classe Identity
+ Graphe d'héritage de Identity:
PrivateKey

Fonctions membres publiques

static __construct ($fsock)
withPublicKey ($key)
withPublicKeyBlob ($key_blob)
getPublicKey ($type='PKCS8')
withHash ($hash)
withPadding ($padding)
withSignatureFormat ($format)
getCurve ()
sign ($message)
toString ($type, array $options=[])
withPassword ($password=false)
- Fonctions membres publiques hérités de PrivateKey
getPublicKey ()

Champs de données

const | SSH_AGENT_RSA2_256 = 2
const | SSH_AGENT_RSA2_512 = 4

Attributs privés

$key
$key_blob
$fsock
$flags = 0

Attributs privés statiques

static $curveAliases

Documentation des constructeurs et destructeur

◆ __construct()

static __construct ( $fsock )

Default Constructor.

Paramètres
resource $fsock private

Références Identity\$fsock.

Documentation des fonctions membres

◆ getCurve()

getCurve ( )

Returns the curve

Returns a string if it's a named curve, an array if not

public

Renvoie
string|array

◆ getPublicKey()

getPublicKey ( $type = 'PKCS8' )

Get Public Key

Wrapper for $this->key->getPublicKey()

Paramètres
string $type optional
Renvoie
mixed public

Références Identity\$key.

◆ sign()

sign ( $message )

Create a signature

See "2.6.2 Protocol 2 private key signature request"

Paramètres
string $message
Renvoie
string
Exceptions

Implémente PrivateKey.

Références $message, $type, Strings\packSSH2(), Agent\SSH_AGENT_SIGN_RESPONSE, Agent\SSH_AGENTC_SIGN_REQUEST, et Strings\unpackSSH2().

◆ toString()

toString | ( |  | $type,
 |  | array | $options = []
 | ) |  |

Returns the private key

Paramètres
string | $type
array | $options | optional
Renvoie
string

Implémente PrivateKey.

◆ withHash()

withHash ( $hash )

Sets the hash

Paramètres
string $hash public

Références $hash, et $this.

◆ withPadding()

withPadding ( $padding )

Sets the padding

Only PKCS1 padding is supported

Paramètres
string $padding public

Références $this, RSA\SIGNATURE_PKCS1, et RSA\SIGNATURE_RELAXED_PKCS1.

◆ withPassword()

withPassword ( $password = false )

Sets the password

public

Paramètres
string | bool $password
Renvoie
never

Implémente PrivateKey.

◆ withPublicKey()

withPublicKey ( $key )

Set Public Key

Called by ::requestIdentities()

Paramètres
\phpseclib3\Crypt\Common\PublicKey $key private

Références Identity\$key, et $this.

◆ withPublicKeyBlob()

withPublicKeyBlob ( $key_blob )

Set Public Key

Called by ::requestIdentities(). The key blob could be extracted from $this->key but this saves a small amount of computation.

Paramètres
string $key_blob private

Références Identity\$key_blob, et $this.

◆ withSignatureFormat()

withSignatureFormat ( $format )

Determines the signature padding mode

Valid values are: ASN1, SSH2, Raw

public

Paramètres
string $format

Références $format, et $this.

Documentation des champs

◆ $curveAliases

$curveAliases
staticprivate
Valeur initiale :
= [
'secp256r1' => 'nistp256'

◆ $flags

$flags = 0
private

◆ $fsock

$fsock
private

Référencé par Identity\__construct().

◆ $key

$key
private

Référencé par Identity\getPublicKey(), et Identity\withPublicKey().

◆ $key_blob

$key_blob
private

Référencé par Identity\withPublicKeyBlob().

◆ SSH_AGENT_RSA2_256

const SSH_AGENT_RSA2_256 = 2

◆ SSH_AGENT_RSA2_512

const SSH_AGENT_RSA2_512 = 4
La documentation de cette classe a été générée à partir du fichier suivant :
  • Identity.php


Joomla CMS: Référence de la classe Agent

  • phpseclib3
  • System
  • SSH
  • Agent
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Agent

Fonctions membres publiques

__construct ($address=null)
requestIdentities ()
startSSHForwarding ()
registerChannelOpen ($ssh)
forwardData ($data)

Champs de données

const | SSH_AGENTC_REQUEST_IDENTITIES = 11
const | SSH_AGENT_IDENTITIES_ANSWER = 12
const | SSH_AGENTC_SIGN_REQUEST = 13
const | SSH_AGENT_SIGN_RESPONSE = 14
const | FORWARD_NONE = 0
const | FORWARD_REQUEST = 1
const | FORWARD_ACTIVE = 2
const | SSH_AGENT_FAILURE = 5

Fonctions membres privées

request_forwarding ($ssh)

Attributs privés

$fsock
$forward_status = self::FORWARD_NONE
$socket_buffer = ''
$expected_bytes = 0
$request_channel

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $address = null )

Default Constructor

Renvoie
Exceptions

Documentation des fonctions membres

◆ forwardData()

forwardData ( $data )

Forward data to SSH Agent and return data reply

Paramètres
string $data
Renvoie
string Data from SSH Agent
Exceptions

Références $data.

◆ registerChannelOpen()

registerChannelOpen ( $ssh )

On successful channel open

This method is called upon successful channel open to give the SSH Agent an opportunity to take further action. i.e. request agent forwarding

Paramètres
\phpseclib3\Net\SSH2 $ssh private

Références Agent\request_forwarding().

◆ request_forwarding()

request_forwarding ( $ssh )
private

Request agent forwarding of remote server

Paramètres
\phpseclib3\Net\SSH2 $ssh
Renvoie
bool private

Référencé par Agent\registerChannelOpen().

◆ requestIdentities()

requestIdentities ( )

Request Identities

See "2.5.2 Requesting a list of protocol 2 keys" Returns an array containing zero or more objects

Renvoie
array
Exceptions

Références $i, $key, $temp, $type, PublicKeyLoader\load(), et Strings\unpackSSH2().

◆ startSSHForwarding()

startSSHForwarding ( )

Signal that agent forwarding should be requested when a channel is opened

Renvoie
void public

Documentation des champs

◆ $expected_bytes

$expected_bytes = 0
private

◆ $forward_status

$forward_status = self::FORWARD_NONE
private

◆ $fsock

$fsock
private

◆ $request_channel

$request_channel
private

◆ $socket_buffer

$socket_buffer = ''
private

◆ FORWARD_ACTIVE

const FORWARD_ACTIVE = 2

◆ FORWARD_NONE

const FORWARD_NONE = 0

◆ FORWARD_REQUEST

const FORWARD_REQUEST = 1

◆ SSH_AGENT_FAILURE

const SSH_AGENT_FAILURE = 5

Unused

◆ SSH_AGENT_IDENTITIES_ANSWER

const SSH_AGENT_IDENTITIES_ANSWER = 12

◆ SSH_AGENT_SIGN_RESPONSE

const SSH_AGENT_SIGN_RESPONSE = 14

Référencé par Identity\sign().

◆ SSH_AGENTC_REQUEST_IDENTITIES

const SSH_AGENTC_REQUEST_IDENTITIES = 11

◆ SSH_AGENTC_SIGN_REQUEST

const SSH_AGENTC_SIGN_REQUEST = 13

Référencé par Identity\sign().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Agent.php


Joomla CMS: Référence de l'interface ContainerExceptionInterface

  • Psr
  • Container
  • ContainerExceptionInterface
Référence de l'interface ContainerExceptionInterface
+ Graphe d'héritage de ContainerExceptionInterface:
ContainerNotFoundException DependencyResolutionException ProtectedKeyException NotFoundExceptionInterface KeyNotFoundException

Description détaillée

Base interface representing a generic exception in a container.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ContainerExceptionInterface.php


Joomla CMS: Référence de l'interface ContainerInterface

  • Psr
  • Container
  • ContainerInterface
Fonctions membres publiques
Référence de l'interface ContainerInterface
+ Graphe d'héritage de ContainerInterface:
Container ServiceProviderInterface

Fonctions membres publiques

get (string $id)
has (string $id)

Description détaillée

Describes the interface of a container that exposes methods to read its entries.

Documentation des fonctions membres

◆ get()

get ( string $id )

Finds an entry of the container by its identifier and returns it.

Paramètres
string $id Identifier of the entry to look for.
Exceptions
NotFoundExceptionInterface | No entry was found for this identifier.
ContainerExceptionInterface | Error while retrieving the entry.
Renvoie
mixed Entry.

◆ has()

has ( string $id )

Returns true if the container can return an entry for the given identifier. Returns false otherwise.

has($id) returning true does not mean that get($id) will not throw an exception. It does however mean that get($id) will not throw a NotFoundExceptionInterface.

Paramètres
string $id Identifier of the entry to look for.
Renvoie
bool
La documentation de cette interface a été générée à partir du fichier suivant :
  • ContainerInterface.php


Joomla CMS: Référence de l'interface NotFoundExceptionInterface

  • Psr
  • Container
  • NotFoundExceptionInterface
Référence de l'interface NotFoundExceptionInterface
+ Graphe d'héritage de NotFoundExceptionInterface:
ContainerExceptionInterface KeyNotFoundException

Description détaillée

No entry was found in the container.

La documentation de cette interface a été générée à partir du fichier suivant :
  • NotFoundExceptionInterface.php


Joomla CMS: Référence de l'interface ClientExceptionInterface

  • Psr
  • Http
  • Client
  • ClientExceptionInterface
Référence de l'interface ClientExceptionInterface
+ Graphe d'héritage de ClientExceptionInterface:
InvalidResponseCodeException UnexpectedResponseException NetworkExceptionInterface RequestExceptionInterface

Description détaillée

Every HTTP client related exception MUST implement this interface.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ClientExceptionInterface.php


Joomla CMS: Référence de l'interface ClientInterface

  • Psr
  • Http
  • Client
  • ClientInterface
Fonctions membres publiques
Référence de l'interface ClientInterface
+ Graphe d'héritage de ClientInterface:
Http Http

Fonctions membres publiques

sendRequest (RequestInterface $request)

Documentation des fonctions membres

◆ sendRequest()

sendRequest ( RequestInterface $request )

Sends a PSR-7 request and returns a PSR-7 response.

Paramètres
RequestInterface $request
Renvoie
ResponseInterface
Exceptions

Implémenté dans Http.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ClientInterface.php


Joomla CMS: Référence de l'interface NetworkExceptionInterface

  • Psr
  • Http
  • Client
  • NetworkExceptionInterface
Fonctions membres publiques
Référence de l'interface NetworkExceptionInterface
+ Graphe d'héritage de NetworkExceptionInterface:
ClientExceptionInterface

Fonctions membres publiques

getRequest ()

Description détaillée

Thrown when the request cannot be completed because of network issues.

There is no response object as this exception is thrown when no response has been received.

Example: the target host name can not be resolved or the connection failed.

Documentation des fonctions membres

◆ getRequest()

getRequest ( )

Returns the request.

The request object MAY be a different object from the one passed to ClientInterface::sendRequest()

Renvoie
RequestInterface
La documentation de cette interface a été générée à partir du fichier suivant :
  • NetworkExceptionInterface.php


Joomla CMS: Référence de l'interface RequestExceptionInterface

  • Psr
  • Http
  • Client
  • RequestExceptionInterface
Fonctions membres publiques
Référence de l'interface RequestExceptionInterface
+ Graphe d'héritage de RequestExceptionInterface:
ClientExceptionInterface

Fonctions membres publiques

getRequest ()

Description détaillée

Exception for when a request failed.

Examples:

  • Request is invalid (e.g. method is missing)
  • Runtime request errors (e.g. the body stream is not seekable)

Documentation des fonctions membres

◆ getRequest()

getRequest ( )

Returns the request.

The request object MAY be a different object from the one passed to ClientInterface::sendRequest()

Renvoie
RequestInterface
La documentation de cette interface a été générée à partir du fichier suivant :
  • RequestExceptionInterface.php


Joomla CMS: Référence de l'interface MessageInterface

  • Psr
  • Http
  • Message
  • MessageInterface
Fonctions membres publiques
Référence de l'interface MessageInterface
+ Graphe d'héritage de MessageInterface:
RequestInterface ResponseInterface Request Request ServerRequestInterface Response Response ServerRequest ServerRequest Response EmptyResponse HtmlResponse JsonResponse RedirectResponse TextResponse XmlResponse

Fonctions membres publiques

getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

HTTP messages consist of requests from a client to a server and responses from a server to a client. This interface defines the methods common to each.

Messages are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current message and return an instance that contains the changed state.

http://www.ietf.org/rfc/rfc7231.txt

Documentation des fonctions membres

◆ getBody()

getBody ( )

Gets the body of the message.

Renvoie
StreamInterface Returns the body as a stream.

Référencé par Response\__get(), AndroidSafetyNetAttestationStatementSupport\getResponseBody(), Http\sendRequest(), ArraySerializer\toArray(), et Serializer\toString().

◆ getHeader()

getHeader ( $name )

Retrieves a message header value by the given case-insensitive name.

This method returns an array of all the header values of the given case-insensitive header name.

If the header does not appear in the message, this method MUST return an empty array.

Paramètres
string $name Case-insensitive header field name.
Renvoie
string[] An array of string values as provided for the given header. If the header does not appear in the message, this method MUST return an empty array.

Implémenté dans Request.

Référencé par AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse().

◆ getHeaderLine()

getHeaderLine ( $name )

Retrieves a comma-separated string of the values for a single header.

This method returns all of the header values of the given case-insensitive header name as a string concatenated together using a comma.

NOTE: Not all header values may be appropriately represented using comma concatenation. For such headers, use getHeader() instead and supply your own delimiter when concatenating.

If the header does not appear in the message, this method MUST return an empty string.

Paramètres
string $name Case-insensitive header field name.
Renvoie
string A string of values as provided for the given header concatenated together using a comma. If the header does not appear in the message, this method MUST return an empty string.

◆ getHeaders()

getHeaders ( )

Retrieves all message header values.

The keys represent the header name as it will be sent over the wire, and each value is an array of strings associated with the header.

// Represent the headers as a string
foreach ($message->getHeaders() as $name => $values) {
    echo $name . ": " . implode(", ", $values);
}

// Emit headers iteratively:
foreach ($message->getHeaders() as $name => $values) {
    foreach ($values as $value) {
        header(sprintf('%s: %s', $name, $value), false);
    }
}

While header names are not case-sensitive, getHeaders() will preserve the exact case in which headers were originally specified.

Renvoie
string[][] Returns an associative array of the message's headers. Each key MUST be a header name, and each value MUST be an array of strings for that header.

Implémenté dans Request.

Référencé par Response\__get(), Http\sendRequest(), ArraySerializer\toArray(), et Serializer\toString().

◆ getProtocolVersion()

getProtocolVersion ( )

Retrieves the HTTP protocol version as a string.

The string MUST contain only the HTTP version number (e.g., "1.1", "1.0").

Renvoie
string HTTP protocol version.

Référencé par ArraySerializer\toArray(), et Serializer\toString().

◆ hasHeader()

hasHeader ( $name )

Checks if a header exists by the given case-insensitive name.

Paramètres
string $name Case-insensitive header field name.
Renvoie
bool Returns true if any header names match the given header name using a case-insensitive string comparison. Returns false if no matching header name is found in the message.

Référencé par Request\__construct(), ServerRequest\__construct(), AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), Request\getHeader(), et Request\getHeaders().

◆ withAddedHeader()

withAddedHeader | ( | $name,
 |  | $value
 | ) |

Return an instance with the specified header appended with the given value.

Existing values for the specified header will be maintained. The new value(s) will be appended to the existing list. If the header did not exist previously, it will be added.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new header and/or value.

Paramètres
string | $name | Case-insensitive header field name to add.
string|string[] | $value Header value(s).
Renvoie
static
Exceptions

◆ withBody()

withBody ( StreamInterface $body )

Return an instance with the specified message body.

The body MUST be a StreamInterface object.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return a new instance that has the new body stream.

Paramètres
StreamInterface $body Body.
Renvoie
static
Exceptions

Référencé par JsonResponse\updateBodyFor().

◆ withHeader()

withHeader | ( | $name,
 |  | $value
 | ) |

Return an instance with the provided value replacing the specified header.

While header names are case-insensitive, the casing of the header will be preserved by this function, and returned from getHeaders().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new and/or updated header and value.

Paramètres
string | $name | Case-insensitive header field name.
string|string[] | $value Header value(s).
Renvoie
static
Exceptions

◆ withoutHeader()

withoutHeader ( $name )

Return an instance without the specified header.

Header resolution MUST be done without case-sensitivity.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that removes the named header.

Paramètres
string $name Case-insensitive header field name to remove.
Renvoie
static

◆ withProtocolVersion()

withProtocolVersion ( $version )

Return an instance with the specified HTTP protocol version.

The version string MUST contain only the HTTP version number (e.g., "1.1", "1.0").

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new protocol version.

Paramètres
string $version HTTP protocol version
Renvoie
static
La documentation de cette interface a été générée à partir du fichier suivant :
  • MessageInterface.php


Joomla CMS: Référence de l'interface RequestFactoryInterface

  • Psr
  • Http
  • Message
  • RequestFactoryInterface
Fonctions membres publiques
Référence de l'interface RequestFactoryInterface
+ Graphe d'héritage de RequestFactoryInterface:
RequestFactory Psr17Factory

Fonctions membres publiques

createRequest (string $method, $uri)

Documentation des fonctions membres

◆ createRequest()

createRequest | ( | string | $method,
 |  |  | $uri
 | ) |  |

Create a new request.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
Renvoie
RequestInterface

Implémenté dans RequestFactory, et Psr17Factory.

Référencé par MetadataStatementFetcher\fetch().

La documentation de cette interface a été générée à partir du fichier suivant :
  • RequestFactoryInterface.php


Joomla CMS: Référence de l'interface RequestInterface

  • Psr
  • Http
  • Message
  • RequestInterface
Fonctions membres publiques
Référence de l'interface RequestInterface
+ Graphe d'héritage de RequestInterface:
MessageInterface Request Request ServerRequestInterface ServerRequest ServerRequest

Fonctions membres publiques

getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

Representation of an outgoing, client-side request.

Per the HTTP specification, this interface includes properties for each of the following:

  • Protocol version
  • HTTP method
  • URI
  • Headers
  • Message body

During construction, implementations MUST attempt to set the Host header from a provided URI if no Host header is provided.

Requests are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current message and return an instance that contains the changed state.

Documentation des fonctions membres

◆ getMethod()

getMethod ( )

Retrieves the HTTP method of the request.

Renvoie
string Returns the request method.

Référencé par Http\sendRequest(), ArraySerializer\toArray(), et Serializer\toString().

◆ getRequestTarget()

getRequestTarget ( )

Retrieves the message's request target.

Retrieves the message's request-target either as it will appear (for clients), as it appeared at request (for servers), or as it was specified for the instance (see withRequestTarget()).

In most cases, this will be the origin-form of the composed URI, unless a value was provided to the concrete implementation (see withRequestTarget() below).

If no URI is available, and no request-target has been specifically provided, this method MUST return the string "/".

Renvoie
string

Référencé par ArraySerializer\toArray(), et Serializer\toString().

◆ getUri()

getUri ( )

Retrieves the URI instance.

This method MUST return a UriInterface instance.

UriInterface Returns a UriInterface instance representing the URI of the request.

Référencé par AuthenticatorAttestationResponseValidator\check(), AuthenticatorAssertionResponseValidator\check(), Http\sendRequest(), et ArraySerializer\toArray().

◆ withMethod()

withMethod ( $method )

Return an instance with the provided HTTP method.

While HTTP method names are typically all uppercase characters, HTTP method names are case-sensitive and thus implementations SHOULD NOT modify the given string.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the changed request method.

Paramètres
string $method Case-sensitive method.
Renvoie
static
Exceptions

◆ withRequestTarget()

withRequestTarget ( $requestTarget )

Return an instance with the specific request-target.

If the request needs a non-origin-form request-target — e.g., for specifying an absolute-form, authority-form, or asterisk-form — this method may be used to create an instance with the specified request-target, verbatim.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the changed request target.

(for the various request-target forms allowed in request messages) mixed $requestTarget static

◆ withUri()

withUri | ( | UriInterface | $uri,
 |  |  | $preserveHost = false
 | ) |  |

Returns an instance with the provided URI.

This method MUST update the Host header of the returned request by default if the URI contains a host component. If the URI does not contain a host component, any pre-existing Host header MUST be carried over to the returned request.

You can opt-in to preserving the original state of the Host header by setting $preserveHost to true. When $preserveHost is set to true, this method interacts with the Host header in the following ways:

  • If the Host header is missing or empty, and the new URI contains a host component, this method MUST update the Host header in the returned request.
  • If the Host header is missing or empty, and the new URI does not contain a host component, this method MUST NOT update the Host header in the returned request.
  • If a Host header is present and non-empty, this method MUST NOT update the Host header in the returned request.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the new UriInterface instance.

UriInterface $uri New request URI to use. bool $preserveHost Preserve the original state of the Host header. static

La documentation de cette interface a été générée à partir du fichier suivant :
  • RequestInterface.php


Joomla CMS: Référence de l'interface ResponseFactoryInterface

  • Psr
  • Http
  • Message
  • ResponseFactoryInterface
Fonctions membres publiques
Référence de l'interface ResponseFactoryInterface
+ Graphe d'héritage de ResponseFactoryInterface:
ResponseFactory Psr17Factory

Fonctions membres publiques

createResponse (int $code=200, string $reasonPhrase='')

Documentation des fonctions membres

◆ createResponse()

createResponse | ( | int | $code = 200,
 |  | string | $reasonPhrase = ''
 | ) |  |

Create a new response.

Paramètres
int | $code | HTTP status code; defaults to 200
string | $reasonPhrase | Reason phrase to associate with status code in generated response; if none is provided implementations MAY use the defaults as suggested in the HTTP specification.
Renvoie
ResponseInterface

Implémenté dans Psr17Factory, et ResponseFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ResponseFactoryInterface.php


Joomla CMS: Référence de l'interface ResponseInterface

  • Psr
  • Http
  • Message
  • ResponseInterface
Fonctions membres publiques
Référence de l'interface ResponseInterface
+ Graphe d'héritage de ResponseInterface:
MessageInterface Response Response Response EmptyResponse HtmlResponse JsonResponse RedirectResponse TextResponse XmlResponse Response

Fonctions membres publiques

getStatusCode ()
withStatus ($code, $reasonPhrase='')
getReasonPhrase ()
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

Representation of an outgoing, server-side response.

Per the HTTP specification, this interface includes properties for each of the following:

  • Protocol version
  • Status code and reason phrase
  • Headers
  • Message body

Responses are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current message and return an instance that contains the changed state.

Documentation des fonctions membres

◆ getReasonPhrase()

getReasonPhrase ( )

Gets the response reason phrase associated with the status code.

Because a reason phrase is not a required element in a response status line, the reason phrase value MAY be null. Implementations MAY choose to return the default RFC 7231 recommended reason phrase (or those listed in the IANA HTTP Status Code Registry) for the response's status code.

http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml string Reason phrase; must return an empty string if none present.

Implémenté dans Response, et Response.

Référencé par ArraySerializer\toArray(), et Serializer\toString().

◆ getStatusCode()

getStatusCode ( )

Gets the response status code.

The status code is a 3-digit integer result code of the server's attempt to understand and satisfy the request.

Renvoie
int Status code.

Implémenté dans Response, et Response.

Référencé par AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), InfoCollector\getResponseInfo(), ArraySerializer\toArray(), et Serializer\toString().

◆ withStatus()

withStatus | ( | $code,
 |  | $reasonPhrase = ''
 | ) |

Return an instance with the specified status code and, optionally, reason phrase.

If no reason phrase is specified, implementations MAY choose to default to the RFC 7231 or IANA recommended reason phrase for the response's status code.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated status and reason phrase.

http://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml int $code The 3-digit integer result code to set. string $reasonPhrase The reason phrase to use with the provided status code; if none is provided, implementations MAY use the defaults as suggested in the HTTP specification. static For invalid status code arguments.

Implémenté dans Response, et Response.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ResponseInterface.php


Joomla CMS: Référence de l'interface ServerRequestFactoryInterface

  • Psr
  • Http
  • Message
  • ServerRequestFactoryInterface
Fonctions membres publiques
Référence de l'interface ServerRequestFactoryInterface
+ Graphe d'héritage de ServerRequestFactoryInterface:
ServerRequestFactory Psr17Factory

Fonctions membres publiques

createServerRequest (string $method, $uri, array $serverParams=[])

Documentation des fonctions membres

◆ createServerRequest()

createServerRequest | ( | string | $method,
 |  |  | $uri,
 |  | array | $serverParams = []
 | ) |  |

Create a new server request.

Note that server-params are taken precisely as given - no parsing/processing of the given values is performed, and, in particular, no attempt is made to determine the HTTP method or URI, which must be provided explicitly.

Paramètres
string | $method | The HTTP method associated with the request.
UriInterface | string | $uri | The URI associated with the request. If the value is a string, the factory MUST create a UriInterface instance based on it.
array | $serverParams | Array of SAPI parameters with which to seed the generated request instance.
Renvoie
ServerRequestInterface

Implémenté dans ServerRequestFactory, et Psr17Factory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ServerRequestFactoryInterface.php


Joomla CMS: Référence de l'interface ServerRequestInterface

  • Psr
  • Http
  • Message
  • ServerRequestInterface
Fonctions membres publiques
Référence de l'interface ServerRequestInterface
+ Graphe d'héritage de ServerRequestInterface:
RequestInterface MessageInterface ServerRequest ServerRequest

Fonctions membres publiques

getServerParams ()
getCookieParams ()
withCookieParams (array $cookies)
getQueryParams ()
withQueryParams (array $query)
getUploadedFiles ()
withUploadedFiles (array $uploadedFiles)
getParsedBody ()
withParsedBody ($data)
getAttributes ()
getAttribute ($name, $default=null)
withAttribute ($name, $value)
withoutAttribute ($name)
- Fonctions membres publiques hérités de RequestInterface
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
- Fonctions membres publiques hérités de MessageInterface
getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($name)
getHeader ($name)
getHeaderLine ($name)
withHeader ($name, $value)
withAddedHeader ($name, $value)
withoutHeader ($name)
getBody ()
withBody (StreamInterface $body)

Description détaillée

Representation of an incoming, server-side HTTP request.

Per the HTTP specification, this interface includes properties for each of the following:

  • Protocol version
  • HTTP method
  • URI
  • Headers
  • Message body

Additionally, it encapsulates all data as it has arrived to the application from the CGI and/or PHP environment, including:

  • The values represented in $_SERVER.
  • Any cookies provided (generally via $_COOKIE)
  • Query string arguments (generally via $_GET, or as parsed via parse_str())
  • Upload files, if any (as represented by $_FILES)
  • Deserialized body parameters (generally from $_POST)

$_SERVER values MUST be treated as immutable, as they represent application state at the time of request; as such, no methods are provided to allow modification of those values. The other values provide such methods, as they can be restored from $_SERVER or the request body, and may need treatment during the application (e.g., body parameters may be deserialized based on content type).

Additionally, this interface recognizes the utility of introspecting a request to derive and match additional parameters (e.g., via URI path matching, decrypting cookie values, deserializing non-form-encoded body content, matching authorization headers to users, etc). These parameters are stored in an "attributes" property.

Requests are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current message and return an instance that contains the changed state.

Documentation des fonctions membres

◆ getAttribute()

getAttribute | ( | $name,
 |  | $default = null
 | ) |

Retrieve a single derived request attribute.

Retrieves a single derived request attribute as described in getAttributes(). If the attribute has not been previously set, returns the default value as provided.

This method obviates the need for a hasAttribute() method, as it allows specifying a default value to return if the attribute is not found.

Voir également
getAttributes()
Paramètres
string | $name | The attribute name.
mixed | $default | Default value to return if the attribute does not exist.
Renvoie
mixed

Implémenté dans ServerRequest, et ServerRequest.

◆ getAttributes()

getAttributes ( )

Retrieve attributes derived from the request.

The request "attributes" may be used to allow injection of any parameters derived from the request: e.g., the results of path match operations; the results of decrypting cookies; the results of deserializing non-form-encoded message bodies; etc. Attributes will be application and request specific, and CAN be mutable.

Renvoie
array Attributes derived from the request.

Implémenté dans ServerRequest, et ServerRequest.

◆ getCookieParams()

getCookieParams ( )

Retrieve cookies.

Retrieves cookies sent by the client to the server.

The data MUST be compatible with the structure of the $_COOKIE superglobal.

Renvoie
array

Implémenté dans ServerRequest, et ServerRequest.

◆ getParsedBody()

getParsedBody ( )

Retrieve any parameters provided in the request body.

If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, this method MUST return the contents of $_POST.

Otherwise, this method may return any results of deserializing the request body content; as parsing returns structured content, the potential types MUST be arrays or objects only. A null value indicates the absence of body content.

Renvoie
null|array|object The deserialized body parameters, if any. These will typically be an array or object.

Implémenté dans ServerRequest, et ServerRequest.

◆ getQueryParams()

getQueryParams ( )

Retrieve query string arguments.

Retrieves the deserialized query string arguments, if any.

Note: the query params might not be in sync with the URI or server params. If you need to ensure you are only getting the original values, you may need to parse the query string from getUri()->getQuery() or from the QUERY_STRING server param.

Renvoie
array

Implémenté dans ServerRequest, et ServerRequest.

◆ getServerParams()

getServerParams ( )

Retrieve server parameters.

Retrieves data related to the incoming request environment, typically derived from PHP's $_SERVER superglobal. The data IS NOT REQUIRED to originate from $_SERVER.

Renvoie
array

Implémenté dans ServerRequest, et ServerRequest.

◆ getUploadedFiles()

getUploadedFiles ( )

Retrieve normalized file upload data.

This method returns upload metadata in a normalized tree, with each leaf an instance of Psr.

These values MAY be prepared from $_FILES or the message body during instantiation, or MAY be injected via withUploadedFiles().

Renvoie
array An array tree of UploadedFileInterface instances; an empty array MUST be returned if no data is present.

Implémenté dans ServerRequest, et ServerRequest.

◆ withAttribute()

withAttribute | ( | $name,
 |  | $value
 | ) |

Return an instance with the specified derived request attribute.

This method allows setting a single derived request attribute as described in getAttributes().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated attribute.

Voir également
getAttributes()
Paramètres
string | $name | The attribute name.
mixed | $value | The value of the attribute.
Renvoie
static

Implémenté dans ServerRequest, et ServerRequest.

◆ withCookieParams()

withCookieParams ( array $cookies )

Return an instance with the specified cookies.

The data IS NOT REQUIRED to come from the $_COOKIE superglobal, but MUST be compatible with the structure of $_COOKIE. Typically, this data will be injected at instantiation.

This method MUST NOT update the related Cookie header of the request instance, nor related values in the server params.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated cookie values.

Paramètres
array $cookies Array of key/value pairs representing cookies.
Renvoie
static

Implémenté dans ServerRequest, et ServerRequest.

◆ withoutAttribute()

withoutAttribute ( $name )

Return an instance that removes the specified derived request attribute.

This method allows removing a single derived request attribute as described in getAttributes().

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that removes the attribute.

Voir également
getAttributes()
Paramètres
string $name The attribute name.
Renvoie
static

Implémenté dans ServerRequest, et ServerRequest.

◆ withParsedBody()

withParsedBody ( $data )

Return an instance with the specified body parameters.

These MAY be injected during instantiation.

If the request Content-Type is either application/x-www-form-urlencoded or multipart/form-data, and the request method is POST, use this method ONLY to inject the contents of $_POST.

The data IS NOT REQUIRED to come from $_POST, but MUST be the results of deserializing the request body content. Deserialization/parsing returns structured data, and, as such, this method ONLY accepts arrays or objects, or a null value if nothing was available to parse.

As an example, if content negotiation determines that the request data is a JSON payload, this method could be used to create a request instance with the deserialized parameters.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
null | array | object $data The deserialized body data. This will typically be in an array or object.
Renvoie
static
Exceptions

Implémenté dans ServerRequest, et ServerRequest.

◆ withQueryParams()

withQueryParams ( array $query )

Return an instance with the specified query string arguments.

These values SHOULD remain immutable over the course of the incoming request. They MAY be injected during instantiation, such as from PHP's $_GET superglobal, or MAY be derived from some other value such as the URI. In cases where the arguments are parsed from the URI, the data MUST be compatible with what PHP's parse_str() would return for purposes of how duplicate query parameters are handled, and how nested sets are handled.

Setting query string arguments MUST NOT change the URI stored by the request, nor the values in the server params.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated query string arguments.

Paramètres
array $query Array of query string arguments, typically from $_GET.
Renvoie
static

Implémenté dans ServerRequest, et ServerRequest.

◆ withUploadedFiles()

withUploadedFiles ( array $uploadedFiles )

Create a new instance with the specified uploaded files.

This method MUST be implemented in such a way as to retain the immutability of the message, and MUST return an instance that has the updated body parameters.

Paramètres
array $uploadedFiles An array tree of UploadedFileInterface instances.
Renvoie
static
Exceptions

Implémenté dans ServerRequest, et ServerRequest.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ServerRequestInterface.php


Joomla CMS: Référence de l'interface StreamFactoryInterface

  • Psr
  • Http
  • Message
  • StreamFactoryInterface
Fonctions membres publiques
Référence de l'interface StreamFactoryInterface
+ Graphe d'héritage de StreamFactoryInterface:
StreamFactory Psr17Factory

Fonctions membres publiques

createStream (string $content='')
createStreamFromFile (string $filename, string $mode='r')
createStreamFromResource ($resource)

Documentation des fonctions membres

◆ createStream()

createStream ( string $content = '' )

Create a new stream from a string.

The stream SHOULD be created with a temporary resource.

Paramètres
string $content String content with which to populate the stream.
Renvoie
StreamInterface

Implémenté dans Psr17Factory, et StreamFactory.

◆ createStreamFromFile()

createStreamFromFile | ( | string | $filename,
 |  | string | $mode = 'r'
 | ) |  |

Create a stream from an existing file.

The file MUST be opened using the given mode, which may be any mode supported by the fopen function.

The $filename MAY be any string supported by fopen().

Paramètres
string | $filename | Filename or stream URI to use as basis of stream.
string | $mode | Mode with which to open the underlying filename/stream.
Renvoie
StreamInterface
Exceptions

Implémenté dans StreamFactory, et Psr17Factory.

◆ createStreamFromResource()

createStreamFromResource ( $resource )

Create a new stream from an existing resource.

The stream MUST be readable and may be writable.

Paramètres
resource $resource PHP resource to use as basis of stream.
Renvoie
StreamInterface

Implémenté dans Psr17Factory, et StreamFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • StreamFactoryInterface.php


Joomla CMS: Référence de l'interface StreamInterface

  • Psr
  • Http
  • Message
  • StreamInterface
Fonctions membres publiques
Référence de l'interface StreamInterface
+ Graphe d'héritage de StreamInterface:
CallbackStream RelativeStream Stream Stream PhpInputStream

Fonctions membres publiques

__toString ()
close ()
detach ()
getSize ()
tell ()
eof ()
isSeekable ()
seek ($offset, $whence=SEEK_SET)
rewind ()
isWritable ()
write ($string)
isReadable ()
read ($length)
getContents ()
getMetadata ($key=null)

Description détaillée

Describes a data stream.

Typically, an instance will wrap a PHP stream; this interface provides a wrapper around the most common operations, including serialization of the entire stream to a string.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Reads all data from the stream into a string, from the beginning to end.

This method MUST attempt to seek to the beginning of the stream before reading data and read the stream until the end is reached.

Warning: This could attempt to load a large amount of data into memory.

This method MUST NOT raise an exception in order to conform with PHP's string casting operations.

Voir également
http://php.net/manual/en/language.oop5.magic.php#object.tostring
Renvoie
string

Implémenté dans Stream, Stream, RelativeStream, CallbackStream, et PhpInputStream.

◆ close()

close ( )

Closes the stream and any underlying resources.

Renvoie
void

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ detach()

detach ( )

Separates any underlying resources from the stream.

After the stream has been detached, the stream is in an unusable state.

Renvoie
resource|null Underlying PHP stream, if any

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ eof()

eof ( )

Returns true if the stream is at the end of the stream.

Renvoie
bool

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ getContents()

getContents ( )

Returns the remaining contents in a string

Renvoie
string
Exceptions

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ getMetadata()

getMetadata ( $key = null )

Get stream metadata as an associative array or retrieve a specific key.

The keys returned are identical to the keys returned from PHP's stream_get_meta_data() function.

string $key Specific metadata to retrieve. array|mixed|null Returns an associative array if no key is provided. Returns a specific key value if a key is provided and the value is found, or null if the key is not found.

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ getSize()

getSize ( )

Get the size of the stream if known.

Renvoie
int|null Returns the size in bytes if known, or null if unknown.

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ isReadable()

isReadable ( )

Returns whether or not the stream is readable.

Renvoie
bool

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ isSeekable()

isSeekable ( )

Returns whether or not the stream is seekable.

Renvoie
bool

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ isWritable()

isWritable ( )

Returns whether or not the stream is writable.

Renvoie
bool

Implémenté dans Stream, Stream, RelativeStream, CallbackStream, et PhpInputStream.

◆ read()

read ( $length )

Read data from the stream.

Paramètres
int $length Read up to $length bytes from the object and return them. Fewer than $length bytes may be returned if underlying stream call returns fewer bytes.
Renvoie
string Returns the data read from the stream, or an empty string if no bytes are available.
Exceptions

Implémenté dans Stream, Stream, RelativeStream, CallbackStream, et PhpInputStream.

◆ rewind()

rewind ( )

Seek to the beginning of the stream.

If the stream is not seekable, this method will raise an exception; otherwise, it will perform a seek(0).

Voir également
seek() on failure.

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ seek()

seek | ( | $offset,
 |  | $whence = SEEK_SET
 | ) |

Seek to a position in the stream.

int $offset Stream offset int $whence Specifies how the cursor position will be calculated based on the seek offset. Valid values are identical to the built-in PHP $whence values for fseek(). SEEK_SET: Set position equal to offset bytes SEEK_CUR: Set position to current location plus offset SEEK_END: Set position to end-of-stream plus offset. on failure.

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ tell()

tell ( )

Returns the current position of the file read/write pointer

Renvoie
int Position of the file pointer
Exceptions

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

◆ write()

write ( $string )

Write data to the stream.

Paramètres
string $string The string that is to be written.
Renvoie
int Returns the number of bytes written to the stream.
Exceptions

Implémenté dans Stream, Stream, RelativeStream, et CallbackStream.

La documentation de cette interface a été générée à partir du fichier suivant :
  • StreamInterface.php


Joomla CMS: Référence de l'interface UploadedFileFactoryInterface

  • Psr
  • Http
  • Message
  • UploadedFileFactoryInterface
Fonctions membres publiques
Référence de l'interface UploadedFileFactoryInterface
+ Graphe d'héritage de UploadedFileFactoryInterface:
UploadedFileFactory Psr17Factory

Fonctions membres publiques

createUploadedFile (StreamInterface $stream, int $size=null, int $error=\UPLOAD_ERR_OK, string $clientFilename=null, string $clientMediaType=null)

Documentation des fonctions membres

◆ createUploadedFile()

createUploadedFile | ( | StreamInterface | $stream,
 |  | int | $size = null,
 |  | int | $error = \UPLOAD_ERR_OK,
 |  | string | $clientFilename = null,
 |  | string | $clientMediaType = null
 | ) |  |

Create a new uploaded file.

If a size is not provided it will be determined by checking the size of the file.

Voir également
http://php.net/manual/features.file-upload.post-method.php
http://php.net/manual/features.file-upload.errors.php
Paramètres
StreamInterface | $stream | Underlying stream representing the uploaded file content.
int | $size | in bytes
int | $error | PHP file upload error
string | $clientFilename | Filename as provided by the client, if any.
string | $clientMediaType | Media type as provided by the client, if any.
Renvoie
UploadedFileInterface
Exceptions

Implémenté dans Psr17Factory, et UploadedFileFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UploadedFileFactoryInterface.php


Joomla CMS: Référence de l'interface UploadedFileInterface

  • Psr
  • Http
  • Message
  • UploadedFileInterface
Fonctions membres publiques
Référence de l'interface UploadedFileInterface
+ Graphe d'héritage de UploadedFileInterface:
UploadedFile UploadedFile

Fonctions membres publiques

getStream ()
moveTo ($targetPath)
getSize ()
getError ()
getClientFilename ()
getClientMediaType ()

Description détaillée

Value object representing a file uploaded through an HTTP request.

Instances of this interface are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current instance and return an instance that contains the changed state.

Documentation des fonctions membres

◆ getClientFilename()

getClientFilename ( )

Retrieve the filename sent by the client.

Do not trust the value returned by this method. A client could send a malicious filename with the intention to corrupt or hack your application.

Implementations SHOULD return the value stored in the "name" key of the file in the $_FILES array.

Renvoie
string|null The filename sent by the client or null if none was provided.

Implémenté dans UploadedFile, et UploadedFile.

◆ getClientMediaType()

getClientMediaType ( )

Retrieve the media type sent by the client.

Do not trust the value returned by this method. A client could send a malicious media type with the intention to corrupt or hack your application.

Implementations SHOULD return the value stored in the "type" key of the file in the $_FILES array.

Renvoie
string|null The media type sent by the client or null if none was provided.

Implémenté dans UploadedFile, et UploadedFile.

◆ getError()

getError ( )

Retrieve the error associated with the uploaded file.

The return value MUST be one of PHP's UPLOAD_ERR_XXX constants.

If the file was uploaded successfully, this method MUST return UPLOAD_ERR_OK.

Implementations SHOULD return the value stored in the "error" key of the file in the $_FILES array.

Voir également
http://php.net/manual/en/features.file-upload.errors.php
Renvoie
int One of PHP's UPLOAD_ERR_XXX constants.

Implémenté dans UploadedFile, et UploadedFile.

◆ getSize()

getSize ( )

Retrieve the file size.

Implementations SHOULD return the value stored in the "size" key of the file in the $_FILES array if available, as PHP calculates this based on the actual size transmitted.

Renvoie
int|null The file size in bytes or null if unknown.

Implémenté dans UploadedFile, et UploadedFile.

◆ getStream()

getStream ( )

Retrieve a stream representing the uploaded file.

This method MUST return a StreamInterface instance, representing the uploaded file. The purpose of this method is to allow utilizing native PHP stream functionality to manipulate the file upload, such as stream_copy_to_stream() (though the result will need to be decorated in a native PHP stream wrapper to work with such functions).

If the moveTo() method has been called previously, this method MUST raise an exception.

Renvoie
StreamInterface Stream representation of the uploaded file.
Exceptions

Implémenté dans UploadedFile, et UploadedFile.

◆ moveTo()

moveTo ( $targetPath )

Move the uploaded file to a new location.

Use this method as an alternative to move_uploaded_file(). This method is guaranteed to work in both SAPI and non-SAPI environments. Implementations must determine which environment they are in, and use the appropriate method (move_uploaded_file(), rename(), or a stream operation) to perform the operation.

$targetPath may be an absolute path, or a relative path. If it is a relative path, resolution should be the same as used by PHP's rename() function.

The original file or stream MUST be removed on completion.

If this method is called more than once, any subsequent calls MUST raise an exception.

When used in an SAPI environment where $_FILES is populated, when writing files via moveTo(), is_uploaded_file() and move_uploaded_file() SHOULD be used to ensure permissions and upload status are verified correctly.

If you wish to move to a stream, use getStream(), as SAPI operations cannot guarantee writing to stream destinations.

Voir également
http://php.net/is_uploaded_file
http://php.net/move_uploaded_file
Paramètres
string $targetPath Path to which to move the uploaded file.
Exceptions

Implémenté dans UploadedFile, et UploadedFile.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UploadedFileInterface.php


Joomla CMS: Référence de l'interface UriFactoryInterface

  • Psr
  • Http
  • Message
  • UriFactoryInterface
Fonctions membres publiques
Référence de l'interface UriFactoryInterface
+ Graphe d'héritage de UriFactoryInterface:
UriFactory Psr17Factory

Fonctions membres publiques

createUri (string $uri='')

Documentation des fonctions membres

◆ createUri()

createUri ( string $uri = '' )

Create a new URI.

Paramètres
string $uri
Renvoie
UriInterface
Exceptions

Implémenté dans Psr17Factory, et UriFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UriFactoryInterface.php


Joomla CMS: Référence de l'interface UriInterface

  • Psr
  • Http
  • Message
  • UriInterface
Fonctions membres publiques
Référence de l'interface UriInterface
+ Graphe d'héritage de UriInterface:
Uri Uri

Fonctions membres publiques

getScheme ()
getAuthority ()
getUserInfo ()
getHost ()
getPort ()
getPath ()
getQuery ()
getFragment ()
withScheme ($scheme)
withUserInfo ($user, $password=null)
withHost ($host)
withPort ($port)
withPath ($path)
withQuery ($query)
withFragment ($fragment)
__toString ()

Description détaillée

Value object representing a URI.

This interface is meant to represent URIs according to RFC 3986 and to provide methods for most common operations. Additional functionality for working with URIs can be provided on top of the interface or externally. Its primary use is for HTTP requests, but may also be used in other contexts.

Instances of this interface are considered immutable; all methods that might change state MUST be implemented such that they retain the internal state of the current instance and return an instance that contains the changed state.

Typically the Host header will be also be present in the request message. For server-side requests, the scheme will typically be discoverable in the server parameters.

(the URI specification)

Documentation des fonctions membres

◆ __toString()

__toString ( )

Return the string representation as a URI reference.

Depending on which components of the URI are present, the resulting string is either a full URI or relative reference according to RFC 3986, Section 4.1. The method concatenates the various components of the URI, using the appropriate delimiters:

  • If a scheme is present, it MUST be suffixed by ":".
  • If an authority is present, it MUST be prefixed by "//".
  • The path can be concatenated without delimiters. But there are two cases where the path has to be adjusted to make the URI reference valid as PHP does not allow to throw an exception in __toString():
    • If the path is rootless and an authority is present, the path MUST be prefixed by "/".
    • If the path is starting with more than one "/" and no authority is present, the starting slashes MUST be reduced to one.
  • If a query is present, it MUST be prefixed by "?".
  • If a fragment is present, it MUST be prefixed by "#".
Voir également
http://tools.ietf.org/html/rfc3986#section-4.1
Renvoie
string

Implémenté dans Uri, et Uri.

◆ getAuthority()

getAuthority ( )

Retrieve the authority component of the URI.

If no authority information is present, this method MUST return an empty string.

The authority syntax of the URI is:

[user-info@]host[:port]

If the port component is not set or is the standard port for the current scheme, it SHOULD NOT be included.

Voir également
https://tools.ietf.org/html/rfc3986#section-3.2
Renvoie
string The URI authority, in "[user-info@]host[:port]" format.

Implémenté dans Uri, et Uri.

◆ getFragment()

getFragment ( )

Retrieve the fragment component of the URI.

If no fragment is present, this method MUST return an empty string.

The leading "#" character is not part of the fragment and MUST NOT be added.

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.5.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.5
Renvoie
string The URI fragment.

Implémenté dans Uri, et Uri.

◆ getHost()

getHost ( )

Retrieve the host component of the URI.

If no host is present, this method MUST return an empty string.

The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.2.2.

Voir également
http://tools.ietf.org/html/rfc3986#section-3.2.2
Renvoie
string The URI host.

Implémenté dans Uri, et Uri.

◆ getPath()

getPath ( )

Retrieve the path component of the URI.

The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.

Normally, the empty path "" and absolute path "/" are considered equal as defined in RFC 7230 Section 2.7.3. But this method MUST NOT automatically do this normalization because in contexts with a trimmed base path, e.g. the front controller, this difference becomes significant. It's the task of the user to handle both "" and "/".

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.3.

As an example, if the value should include a slash ("/") not intended as delimiter between path segments, that value MUST be passed in encoded form (e.g., "%2F") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.3
Renvoie
string The URI path.

Implémenté dans Uri, et Uri.

◆ getPort()

getPort ( )

Retrieve the port component of the URI.

If a port is present, and it is non-standard for the current scheme, this method MUST return it as an integer. If the port is the standard port used with the current scheme, this method SHOULD return null.

If no port is present, and no scheme is present, this method MUST return a null value.

If no port is present, but a scheme is present, this method MAY return the standard port for that scheme, but SHOULD return null.

Renvoie
null|int The URI port.

Implémenté dans Uri, et Uri.

◆ getQuery()

getQuery ( )

Retrieve the query string of the URI.

If no query string is present, this method MUST return an empty string.

The leading "?" character is not part of the query and MUST NOT be added.

The value returned MUST be percent-encoded, but MUST NOT double-encode any characters. To determine what characters to encode, please refer to RFC 3986, Sections 2 and 3.4.

As an example, if a value in a key/value pair of the query string should include an ampersand ("&") not intended as a delimiter between values, that value MUST be passed in encoded form (e.g., "%26") to the instance.

Voir également
https://tools.ietf.org/html/rfc3986#section-2
https://tools.ietf.org/html/rfc3986#section-3.4
Renvoie
string The URI query string.

Implémenté dans Uri, et Uri.

◆ getScheme()

getScheme ( )

Retrieve the scheme component of the URI.

If no scheme is present, this method MUST return an empty string.

The value returned MUST be normalized to lowercase, per RFC 3986 Section 3.1.

The trailing ":" character is not part of the scheme and MUST NOT be added.

Voir également
https://tools.ietf.org/html/rfc3986#section-3.1
Renvoie
string The URI scheme.

Implémenté dans Uri, et Uri.

◆ getUserInfo()

getUserInfo ( )

Retrieve the user information component of the URI.

If no user information is present, this method MUST return an empty string.

If a user is present in the URI, this will return that value; additionally, if the password is also present, it will be appended to the user value, with a colon (":") separating the values.

The trailing "@" character is not part of the user information and MUST NOT be added.

Renvoie
string The URI user information, in "username[:password]" format.

Implémenté dans Uri, et Uri.

◆ withFragment()

withFragment ( $fragment )

Return an instance with the specified URI fragment.

This method MUST retain the state of the current instance, and return an instance that contains the specified URI fragment.

Users can provide both encoded and decoded fragment characters. Implementations ensure the correct encoding as outlined in getFragment().

An empty fragment value is equivalent to removing the fragment.

Paramètres
string $fragment The fragment to use with the new instance.
Renvoie
static A new instance with the specified fragment.

Implémenté dans Uri, et Uri.

◆ withHost()

withHost ( $host )

Return an instance with the specified host.

This method MUST retain the state of the current instance, and return an instance that contains the specified host.

An empty host value is equivalent to removing the host.

Paramètres
string $host The hostname to use with the new instance.
Renvoie
static A new instance with the specified host.
Exceptions

Implémenté dans Uri, et Uri.

◆ withPath()

withPath ( $path )

Return an instance with the specified path.

This method MUST retain the state of the current instance, and return an instance that contains the specified path.

The path can either be empty or absolute (starting with a slash) or rootless (not starting with a slash). Implementations MUST support all three syntaxes.

If the path is intended to be domain-relative rather than path relative then it must begin with a slash ("/"). Paths not starting with a slash ("/") are assumed to be relative to some base path known to the application or consumer.

Users can provide both encoded and decoded path characters. Implementations ensure the correct encoding as outlined in getPath().

Paramètres
string $path The path to use with the new instance.
Renvoie
static A new instance with the specified path.
Exceptions

Implémenté dans Uri, et Uri.

◆ withPort()

withPort ( $port )

Return an instance with the specified port.

This method MUST retain the state of the current instance, and return an instance that contains the specified port.

Implementations MUST raise an exception for ports outside the established TCP and UDP port ranges.

A null value provided for the port is equivalent to removing the port information.

Paramètres
null | int $port The port to use with the new instance; a null value removes the port information.
Renvoie
static A new instance with the specified port.
Exceptions

Implémenté dans Uri, et Uri.

◆ withQuery()

withQuery ( $query )

Return an instance with the specified query string.

This method MUST retain the state of the current instance, and return an instance that contains the specified query string.

Users can provide both encoded and decoded query characters. Implementations ensure the correct encoding as outlined in getQuery().

An empty query string value is equivalent to removing the query string.

Paramètres
string $query The query string to use with the new instance.
Renvoie
static A new instance with the specified query string.
Exceptions

Implémenté dans Uri, et Uri.

◆ withScheme()

withScheme ( $scheme )

Return an instance with the specified scheme.

This method MUST retain the state of the current instance, and return an instance that contains the specified scheme.

Implementations MUST support the schemes "http" and "https" case insensitively, and MAY accommodate other schemes if required.

An empty scheme is equivalent to removing the scheme.

Paramètres
string $scheme The scheme to use with the new instance.
Renvoie
static A new instance with the specified scheme.
Exceptions

Implémenté dans Uri, et Uri.

◆ withUserInfo()

withUserInfo | ( | $user,
 |  | $password = null
 | ) |

Return an instance with the specified user information.

This method MUST retain the state of the current instance, and return an instance that contains the specified user information.

Password is optional, but the user information MUST include the user; an empty string for the user is equivalent to removing user information.

Paramètres
string | $user | The user name to use for authority.
null | string | $password | The password associated with $user.
Renvoie
static A new instance with the specified user information.

Implémenté dans Uri, et Uri.

La documentation de cette interface a été générée à partir du fichier suivant :
  • psr/http-message/src/UriInterface.php


Joomla CMS: Référence de l'interface EvolvableLinkInterface

  • Psr
  • Link
  • EvolvableLinkInterface
Fonctions membres publiques
Référence de l'interface EvolvableLinkInterface
+ Graphe d'héritage de EvolvableLinkInterface:
LinkInterface Link Link

Fonctions membres publiques

withHref ($href)
withRel ($rel)
withoutRel ($rel)
withAttribute ($attribute, $value)
withoutAttribute ($attribute)
- Fonctions membres publiques hérités de LinkInterface
getHref ()
isTemplated ()
getRels ()
getAttributes ()

Description détaillée

An evolvable link value object.

Documentation des fonctions membres

◆ withAttribute()

withAttribute | ( | $attribute,
 |  | $value
 | ) |

Returns an instance with the specified attribute added.

If the specified attribute is already present, it will be overwritten with the new value.

Paramètres
string | $attribute | The attribute to include.
string | $value | The value of the attribute to set.
Renvoie
static

Implémenté dans Link.

◆ withHref()

withHref ( $href )

Returns an instance with the specified href.

Paramètres
string $href The href value to include. It must be one of:
  • An absolute URI, as defined by RFC 5988.
  • A relative URI, as defined by RFC 5988. The base of the relative link is assumed to be known based on context by the client.
  • A URI template as defined by RFC 6570.
  • An object implementing __toString() that produces one of the above values.

An implementing library SHOULD evaluate a passed object to a string immediately rather than waiting for it to be returned later.

Renvoie
static

Implémenté dans Link.

◆ withoutAttribute()

withoutAttribute ( $attribute )

Returns an instance with the specified attribute excluded.

If the specified attribute is not present, this method MUST return normally without errors.

Paramètres
string $attribute The attribute to remove.
Renvoie
static

Implémenté dans Link.

◆ withoutRel()

withoutRel ( $rel )

Returns an instance with the specified relationship excluded.

If the specified rel is already not present, this method MUST return normally without errors.

Paramètres
string $rel The relationship value to exclude.
Renvoie
static

Implémenté dans Link.

◆ withRel()

withRel ( $rel )

Returns an instance with the specified relationship included.

If the specified rel is already present, this method MUST return normally without errors, but without adding the rel a second time.

Paramètres
string $rel The relationship value to add.
Renvoie
static

Implémenté dans Link.

La documentation de cette interface a été générée à partir du fichier suivant :
  • EvolvableLinkInterface.php


Joomla CMS: Référence de l'interface EvolvableLinkProviderInterface

  • Psr
  • Link
  • EvolvableLinkProviderInterface
Fonctions membres publiques
Référence de l'interface EvolvableLinkProviderInterface
+ Graphe d'héritage de EvolvableLinkProviderInterface:
LinkProviderInterface GenericLinkProvider GenericLinkProvider

Fonctions membres publiques

withLink (LinkInterface $link)
withoutLink (LinkInterface $link)
- Fonctions membres publiques hérités de LinkProviderInterface
getLinks ()
getLinksByRel ($rel)

Description détaillée

An evolvable link provider value object.

Documentation des fonctions membres

◆ withLink()

withLink ( LinkInterface $link )

Returns an instance with the specified link included.

If the specified link is already present, this method MUST return normally without errors. The link is present if $link is === identical to a link object already in the collection.

Paramètres
LinkInterface $link A link object that should be included in this collection.
Renvoie
static

Implémenté dans GenericLinkProvider.

◆ withoutLink()

withoutLink ( LinkInterface $link )

Returns an instance with the specifed link removed.

If the specified link is not present, this method MUST return normally without errors. The link is present if $link is === identical to a link object already in the collection.

Paramètres
LinkInterface $link The link to remove.
Renvoie
static

Implémenté dans GenericLinkProvider.

La documentation de cette interface a été générée à partir du fichier suivant :
  • EvolvableLinkProviderInterface.php


Joomla CMS: Référence de l'interface LinkInterface

  • Psr
  • Link
  • LinkInterface
Fonctions membres publiques
Référence de l'interface LinkInterface
+ Graphe d'héritage de LinkInterface:
EvolvableLinkInterface Link Link

Fonctions membres publiques

getHref ()
isTemplated ()
getRels ()
getAttributes ()

Description détaillée

A readable link object.

Documentation des fonctions membres

◆ getAttributes()

getAttributes ( )

Returns a list of attributes that describe the target URI.

Renvoie
array A key-value list of attributes, where the key is a string and the value is either a PHP primitive or an array of PHP strings. If no values are found an empty array MUST be returned.

Implémenté dans Link.

◆ getHref()

getHref ( )

Returns the target of the link.

The target link must be one of:

  • An absolute URI, as defined by RFC 5988.
  • A relative URI, as defined by RFC 5988. The base of the relative link is assumed to be known based on context by the client.
  • A URI template as defined by RFC 6570.

If a URI template is returned, isTemplated() MUST return True.

Renvoie
string

Implémenté dans Link.

◆ getRels()

getRels ( )

Returns the relationship type(s) of the link.

This method returns 0 or more relationship types for a link, expressed as an array of strings.

Renvoie
string[]

Implémenté dans Link.

◆ isTemplated()

isTemplated ( )

Returns whether or not this is a templated link.

Renvoie
bool True if this link object is templated, False otherwise.

Implémenté dans Link.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LinkInterface.php


Joomla CMS: Référence de l'interface LinkProviderInterface

  • Psr
  • Link
  • LinkProviderInterface
Fonctions membres publiques
Référence de l'interface LinkProviderInterface
+ Graphe d'héritage de LinkProviderInterface:
EvolvableLinkProviderInterface GenericLinkProvider GenericLinkProvider

Fonctions membres publiques

getLinks ()
getLinksByRel ($rel)

Description détaillée

A link provider object.

Documentation des fonctions membres

◆ getLinks()

getLinks ( )

Returns an iterable of LinkInterface objects.

The iterable may be an array or any PHP object. If no links are available, an empty array or MUST be returned.

Renvoie
LinkInterface[]|

Implémenté dans GenericLinkProvider.

Référencé par AddLinkHeaderListener\onKernelResponse().

◆ getLinksByRel()

getLinksByRel ( $rel )

Returns an iterable of LinkInterface objects that have a specific relationship.

The iterable may be an array or any PHP object. If no links with that relationship are available, an empty array or MUST be returned.

Renvoie
LinkInterface[]|

Implémenté dans GenericLinkProvider.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LinkProviderInterface.php


Joomla CMS: Référence de la classe AbstractLogger

  • Psr
  • Log
  • AbstractLogger
Fonctions membres publiques
Référence de la classe AbstractLogger
+ Graphe d'héritage de AbstractLogger:
LoggerInterface MessagesCollector DelegatingPsrLogger NullLogger ConsoleLogger BufferingLogger SlimCollector SwiftLogCollector

Fonctions membres publiques

emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())
- Fonctions membres publiques hérités de LoggerInterface
log ($level, $message, array $context=array())

Description détaillée

This is a simple Logger implementation that other Loggers can inherit from.

It simply delegates all log-level-specific methods to the log method to reduce boilerplate code that a simple Logger that does the same thing with messages regardless of the error level has to implement.

Documentation des fonctions membres

◆ alert()

alert | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Action must be taken immediately.

Example: Entire website down, database unavailable, etc. This should trigger the SMS alerts and wake you up.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\ALERT, et LoggerInterface\log().

◆ critical()

critical | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Critical conditions.

Example: Application component unavailable, unexpected exception.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\CRITICAL, et LoggerInterface\log().

◆ debug()

debug | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Detailed debug information.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\DEBUG, et LoggerInterface\log().

◆ emergency()

emergency | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

System is unusable.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\EMERGENCY, et LoggerInterface\log().

◆ error()

error | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Runtime errors that do not require immediate action but should typically be logged and monitored.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\ERROR, et LoggerInterface\log().

◆ info()

info | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Interesting events.

Example: User logs in, SQL logs.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LogLevel\INFO, et LoggerInterface\log().

◆ notice()

notice | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Normal but significant events.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LoggerInterface\log(), et LogLevel\NOTICE.

◆ warning()

warning | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Exceptional occurrences that are not errors.

Example: Use of deprecated APIs, poor use of an API, undesirable things that are not necessarily wrong.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémente LoggerInterface.

Références $context, $message, LoggerInterface\log(), et LogLevel\WARNING.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractLogger.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Psr
  • Log
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • psr/log/Psr/Log/InvalidArgumentException.php


Joomla CMS: Référence de l'interface LoggerAwareInterface

  • Psr
  • Log
  • LoggerAwareInterface
Fonctions membres publiques
Référence de l'interface LoggerAwareInterface
+ Graphe d'héritage de LoggerAwareInterface:
AbstractApplication Task LoggingMonitor AbstractWebApplication BaseApplication CliApplication Application WebApplication WebApplication DaemonApplication ConsoleApplication CMSApplication AdministratorApplication ApiApplication SiteApplication InstallationApplication

Fonctions membres publiques

setLogger (LoggerInterface $logger)

Description détaillée

Describes a logger-aware instance.

Documentation des fonctions membres

◆ setLogger()

setLogger ( LoggerInterface $logger )

Sets a logger instance on the object.

Paramètres
LoggerInterface $logger
Renvoie
void

Référencé par AbstractApplication\getLogger().

La documentation de cette interface a été générée à partir du fichier suivant :
  • LoggerAwareInterface.php


Joomla CMS: Référence de l'interface LoggerInterface

  • Psr
  • Log
  • LoggerInterface
Fonctions membres publiques
Référence de l'interface LoggerInterface
+ Graphe d'héritage de LoggerInterface:
AbstractLogger MessagesCollector DelegatingPsrLogger NullLogger ConsoleLogger BufferingLogger SlimCollector SwiftLogCollector

Fonctions membres publiques

emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())
log ($level, $message, array $context=array())

Description détaillée

Describes a logger instance.

The message MUST be a string or object implementing __toString().

The message MAY contain placeholders in the form: {foo} where foo will be replaced by the context data in key "foo".

The context array can contain arbitrary data. The only assumption that can be made by implementors is that if an Exception instance is given to produce a stack trace, it MUST be in a key named "exception".

See https://github.com/php-fig/fig-standards/blob/master/accepted/PSR-3-logger-interface.md for the full interface specification.

Documentation des fonctions membres

◆ alert()

alert | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Action must be taken immediately.

Example: Entire website down, database unavailable, etc. This should trigger the SMS alerts and wake you up.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ critical()

critical | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Critical conditions.

Example: Application component unavailable, unexpected exception.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ debug()

debug | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Detailed debug information.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ emergency()

emergency | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

System is unusable.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ error()

error | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Runtime errors that do not require immediate action but should typically be logged and monitored.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ info()

info | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Interesting events.

Example: User logs in, SQL logs.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = array()
 | ) |  |

Logs with an arbitrary level.

Paramètres
mixed | $level
string | $message
mixed[] | $context
Renvoie
void
Exceptions

Implémenté dans MessagesCollector, DelegatingPsrLogger, ConsoleLogger, NullLogger, et BufferingLogger.

Référencé par AbstractLogger\alert(), AbstractLogger\critical(), AbstractLogger\debug(), AbstractLogger\emergency(), AbstractLogger\error(), AbstractLogger\info(), AbstractLogger\notice(), et AbstractLogger\warning().

◆ notice()

notice | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Normal but significant events.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

◆ warning()

warning | ( |  | $message,
 |  | array | $context = array()
 | ) |  |

Exceptional occurrences that are not errors.

Example: Use of deprecated APIs, poor use of an API, undesirable things that are not necessarily wrong.

Paramètres
string | $message
mixed[] | $context
Renvoie
void

Implémenté dans AbstractLogger.

La documentation de cette interface a été générée à partir du fichier suivant :
  • LoggerInterface.php


Joomla CMS: Référence de la classe LogLevel

  • Psr
  • Log
  • LogLevel
Champs de données
Référence de la classe LogLevel

Champs de données

const | EMERGENCY = 'emergency'
const | ALERT = 'alert'
const | CRITICAL = 'critical'
const | ERROR = 'error'
const | WARNING = 'warning'
const | NOTICE = 'notice'
const | INFO = 'info'
const | DEBUG = 'debug'

Description détaillée

Describes log levels.

Documentation des champs

◆ ALERT

const ALERT = 'alert'

Référencé par AbstractLogger\alert(), PropelCollector\convertLogLevel(), et SlimCollector\getLevelName().

◆ CRITICAL

const CRITICAL = 'critical'

Référencé par PropelCollector\convertLogLevel(), AbstractLogger\critical(), et SlimCollector\getLevelName().

◆ DEBUG

const DEBUG = 'debug'

Référencé par PropelCollector\convertLogLevel(), AbstractLogger\debug(), SlimCollector\getLevelName(), et ErrorHandler\handleError().

◆ EMERGENCY

const EMERGENCY = 'emergency'

Référencé par PropelCollector\convertLogLevel(), AbstractLogger\emergency(), et SlimCollector\getLevelName().

◆ ERROR

const ERROR = 'error'

Référencé par PropelCollector\convertLogLevel(), AbstractLogger\error(), et SlimCollector\getLevelName().

◆ INFO

const INFO = 'info'

Référencé par SlimCollector\getLevelName(), Propel2Collector\getStatements(), et AbstractLogger\info().

◆ NOTICE

const NOTICE = 'notice'

Référencé par PropelCollector\convertLogLevel(), SlimCollector\getLevelName(), et AbstractLogger\notice().

◆ WARNING

const WARNING = 'warning'

Référencé par PropelCollector\convertLogLevel(), SlimCollector\getLevelName(), et AbstractLogger\warning().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LogLevel.php


Joomla CMS: Référence de la classe NullLogger

  • Psr
  • Log
  • NullLogger
Fonctions membres publiques
Référence de la classe NullLogger
+ Graphe d'héritage de NullLogger:
AbstractLogger LoggerInterface

Fonctions membres publiques

log ($level, $message, array $context=array())
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Description détaillée

This Logger can be used to avoid conditional log calls.

Logging should always be optional, and if no logger is provided to your library creating a NullLogger instance to have something to throw logs at is a good way to avoid littering your code with if ($this->logger) { } blocks.

Documentation des fonctions membres

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = array()
 | ) |  |

Logs with an arbitrary level.

Paramètres
mixed | $level
string | $message
array | $context
Renvoie
void
Exceptions

Implémente LoggerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NullLogger.php


Joomla CMS: Référence de la classe DefaultUuidBuilder

  • Ramsey
  • Uuid
  • Builder
  • DefaultUuidBuilder
Fonctions membres publiques | Attributs privés
Référence de la classe DefaultUuidBuilder
+ Graphe d'héritage de DefaultUuidBuilder:
UuidBuilderInterface

Fonctions membres publiques

__construct (NumberConverterInterface $converter)
build (CodecInterface $codec, array $fields)

Attributs privés

$converter

Description détaillée

DefaultUuidBuilder is the default UUID builder for ramsey/uuid; it builds instances of Uuid objects

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( NumberConverterInterface $converter )

Constructs the DefaultUuidBuilder

Paramètres
NumberConverterInterface $converter The number converter to use when constructing the Uuid

Références DefaultUuidBuilder\$converter.

Documentation des fonctions membres

◆ build()

build | ( | CodecInterface | $codec,
 |  | array | $fields
 | ) |  |

Builds a Uuid

Paramètres
CodecInterface | $codec | The codec to use for building this Uuid
array | $fields | An array of fields from which to construct the Uuid; see {
Voir également
::getFieldsHex()} for array structure.
Renvoie
Uuid

Implémente UuidBuilderInterface.

Références $fields.

Documentation des champs

◆ $converter

$converter
private

Référencé par DefaultUuidBuilder\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DefaultUuidBuilder.php


Joomla CMS: Référence de la classe DegradedUuidBuilder

  • Ramsey
  • Uuid
  • Builder
  • DegradedUuidBuilder
Fonctions membres publiques | Attributs privés
Référence de la classe DegradedUuidBuilder
+ Graphe d'héritage de DegradedUuidBuilder:
UuidBuilderInterface

Fonctions membres publiques

__construct (NumberConverterInterface $converter)
build (CodecInterface $codec, array $fields)

Attributs privés

$converter

Description détaillée

DegradedUuidBuilder builds instances of DegradedUuid

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( NumberConverterInterface $converter )

Constructs the DegradedUuidBuilder

Paramètres
NumberConverterInterface $converter The number converter to use when constructing the DegradedUuid

Références DegradedUuidBuilder\$converter.

Documentation des fonctions membres

◆ build()

build | ( | CodecInterface | $codec,
 |  | array | $fields
 | ) |  |

Builds a DegradedUuid

Paramètres
CodecInterface | $codec | The codec to use for building this DegradedUuid
array | $fields | An array of fields from which to construct the DegradedUuid; see {
Voir également
::getFieldsHex()} for array structure.
Renvoie
DegradedUuid

Implémente UuidBuilderInterface.

Références $fields.

Documentation des champs

◆ $converter

$converter
private

Référencé par DegradedUuidBuilder\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DegradedUuidBuilder.php


Joomla CMS: Référence de l'interface UuidBuilderInterface

  • Ramsey
  • Uuid
  • Builder
  • UuidBuilderInterface
Fonctions membres publiques
Référence de l'interface UuidBuilderInterface
+ Graphe d'héritage de UuidBuilderInterface:
DefaultUuidBuilder DegradedUuidBuilder

Fonctions membres publiques

build (CodecInterface $codec, array $fields)

Description détaillée

UuidBuilderInterface builds instances UuidInterface

Documentation des fonctions membres

◆ build()

build | ( | CodecInterface | $codec,
 |  | array | $fields
 | ) |  |

Builds an instance of a UuidInterface

Paramètres
CodecInterface | $codec | The codec to use for building this UuidInterface instance
array | $fields | An array of fields from which to construct a UuidInterface instance; see {
Voir également
::getFieldsHex()} for array structure.
Renvoie
UuidInterface

Implémenté dans DefaultUuidBuilder, et DegradedUuidBuilder.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UuidBuilderInterface.php


Joomla CMS: Référence de l'interface CodecInterface

  • Ramsey
  • Uuid
  • Codec
  • CodecInterface
Fonctions membres publiques
Référence de l'interface CodecInterface
+ Graphe d'héritage de CodecInterface:
StringCodec GuidStringCodec OrderedTimeCodec TimestampFirstCombCodec TimestampLastCombCodec

Fonctions membres publiques

encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)

Description détaillée

CodecInterface represents a UUID coder-decoder

Documentation des fonctions membres

◆ decode()

decode ( $encodedUuid )

Decodes a string representation of a UUID into a UuidInterface object instance

Paramètres
string $encodedUuid
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémenté dans StringCodec, GuidStringCodec, et TimestampFirstCombCodec.

◆ decodeBytes()

decodeBytes ( $bytes )

Decodes a binary representation of a UUID into a UuidInterface object instance

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException
InvalidArgumentException if string has not 16 characters

Implémenté dans StringCodec, TimestampFirstCombCodec, GuidStringCodec, et OrderedTimeCodec.

◆ encode()

encode ( UuidInterface $uuid )

Encodes a UuidInterface as a string representation of a UUID

Paramètres
UuidInterface $uuid
Renvoie
string Hexadecimal string representation of a UUID

Implémenté dans StringCodec, GuidStringCodec, et TimestampFirstCombCodec.

◆ encodeBinary()

encodeBinary ( UuidInterface $uuid )

Encodes a UuidInterface as a binary representation of a UUID

Paramètres
UuidInterface $uuid
Renvoie
string Binary string representation of a UUID

Implémenté dans StringCodec, GuidStringCodec, TimestampFirstCombCodec, et OrderedTimeCodec.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CodecInterface.php


Joomla CMS: Référence de la classe GuidStringCodec

  • Ramsey
  • Uuid
  • Codec
  • GuidStringCodec
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe GuidStringCodec
+ Graphe d'héritage de GuidStringCodec:
StringCodec CodecInterface

Fonctions membres publiques

encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)
- Fonctions membres publiques hérités de StringCodec
__construct (UuidBuilderInterface $builder)
encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)

Fonctions membres protégées

swapFields (array &$components)
- Fonctions membres protégées hérités de StringCodec
getBuilder ()
extractComponents ($encodedUuid)
getFields (array $components)

Description détaillée

GuidStringCodec encodes and decodes globally unique identifiers (GUID)

https://en.wikipedia.org/wiki/Globally_unique_identifier

Documentation des fonctions membres

◆ decode()

decode ( $encodedUuid )

Decodes a string representation of a GUID into a UuidInterface object instance

Paramètres
string $encodedUuid
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente CodecInterface.

Références $this, StringCodec\extractComponents(), StringCodec\getBuilder(), StringCodec\getFields(), et GuidStringCodec\swapFields().

◆ decodeBytes()

decodeBytes ( $bytes )

Decodes a binary representation of a GUID into a UuidInterface object instance

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente CodecInterface.

◆ encode()

encode ( UuidInterface $uuid )

Encodes a UuidInterface as a string representation of a GUID

Paramètres
UuidInterface $uuid
Renvoie
string Hexadecimal string representation of a GUID

Implémente CodecInterface.

Références UuidInterface\getFieldsHex(), et GuidStringCodec\swapFields().

◆ encodeBinary()

encodeBinary ( UuidInterface $uuid )

Encodes a UuidInterface as a binary representation of a GUID

Paramètres
UuidInterface $uuid
Renvoie
string Binary string representation of a GUID

Implémente CodecInterface.

Références UuidInterface\getFieldsHex().

◆ swapFields()

swapFields ( array & $components )
protected

Swaps fields to support GUID byte order

Paramètres
array $components An array of UUID components (the UUID exploded on its dashes)
Renvoie
void

Référencé par GuidStringCodec\decode(), et GuidStringCodec\encode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • GuidStringCodec.php


Joomla CMS: Référence de la classe OrderedTimeCodec

  • Ramsey
  • Uuid
  • Codec
  • OrderedTimeCodec
Fonctions membres publiques
Référence de la classe OrderedTimeCodec
+ Graphe d'héritage de OrderedTimeCodec:
StringCodec CodecInterface

Fonctions membres publiques

encodeBinary (UuidInterface $uuid)
decodeBytes ($bytes)
- Fonctions membres publiques hérités de StringCodec
__construct (UuidBuilderInterface $builder)
encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)

Membres hérités additionnels

- Fonctions membres protégées hérités de StringCodec
getBuilder ()
extractComponents ($encodedUuid)
getFields (array $components)

Description détaillée

OrderedTimeCodec optimizes the bytes to increment UUIDs when time goes by, to improve database INSERTs. The string value will be unchanged from StringCodec. Only works for UUID type 1.

Documentation des fonctions membres

◆ decodeBytes()

decodeBytes ( $bytes )

Decodes an optimized binary representation of a UUID into a UuidInterface object instance

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidArgumentException if string has not 16 characters

Implémente CodecInterface.

Références StringCodec\decode().

◆ encodeBinary()

encodeBinary ( UuidInterface $uuid )

Encodes a UuidInterface as an optimized binary representation of a UUID

Paramètres
UuidInterface $uuid
Renvoie
string Binary string representation of a UUID

Implémente CodecInterface.

Références $fields, et UuidInterface\getFieldsHex().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OrderedTimeCodec.php


Joomla CMS: Référence de la classe StringCodec

  • Ramsey
  • Uuid
  • Codec
  • StringCodec
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe StringCodec
+ Graphe d'héritage de StringCodec:
CodecInterface GuidStringCodec OrderedTimeCodec TimestampFirstCombCodec TimestampLastCombCodec

Fonctions membres publiques

__construct (UuidBuilderInterface $builder)
encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)

Fonctions membres protégées

getBuilder ()
extractComponents ($encodedUuid)
getFields (array $components)

Attributs privés

$builder

Description détaillée

StringCodec encodes and decodes RFC 4122 UUIDs

http://tools.ietf.org/html/rfc4122

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( UuidBuilderInterface $builder )

Constructs a StringCodec for use encoding and decoding UUIDs

Paramètres
UuidBuilderInterface $builder The UUID builder to use when encoding UUIDs

Références StringCodec\$builder.

Documentation des fonctions membres

◆ decode()

decode ( $encodedUuid )

Decodes a string representation of a UUID into a UuidInterface object instance

Paramètres
string $encodedUuid
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente CodecInterface.

Références $fields, $this, StringCodec\extractComponents(), et StringCodec\getFields().

Référencé par OrderedTimeCodec\decodeBytes(), et StringCodec\decodeBytes().

◆ decodeBytes()

decodeBytes ( $bytes )

Decodes a binary representation of a UUID into a UuidInterface object instance

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidArgumentException if string has not 16 characters

Implémente CodecInterface.

Références StringCodec\decode().

◆ encode()

encode ( UuidInterface $uuid )

Encodes a UuidInterface as a string representation of a UUID

Paramètres
UuidInterface $uuid
Renvoie
string Hexadecimal string representation of a UUID

Implémente CodecInterface.

Références $fields, et UuidInterface\getFieldsHex().

◆ encodeBinary()

encodeBinary ( UuidInterface $uuid )

Encodes a UuidInterface as a binary representation of a UUID

Paramètres
UuidInterface $uuid
Renvoie
string Binary string representation of a UUID

Implémente CodecInterface.

Références UuidInterface\getHex().

◆ extractComponents()

extractComponents ( $encodedUuid )
protected

Returns an array of UUID components (the UUID exploded on its dashes)

Paramètres
string $encodedUuid
Renvoie
array
Exceptions
InvalidUuidStringException

Références Uuid\isValid().

Référencé par GuidStringCodec\decode(), TimestampFirstCombCodec\decode(), et StringCodec\decode().

◆ getBuilder()

getBuilder ( )
protected

Returns the UUID builder

Renvoie
UuidBuilderInterface

Références StringCodec\$builder.

Référencé par GuidStringCodec\decode(), et TimestampFirstCombCodec\decode().

◆ getFields()

getFields ( array $components )
protected

Returns the fields that make up this UUID

Voir également
::getFieldsHex()
Paramètres
array $components
Renvoie
array

Référencé par GuidStringCodec\decode(), TimestampFirstCombCodec\decode(), et StringCodec\decode().

Documentation des champs

◆ $builder

$builder
private

Référencé par StringCodec\__construct(), et StringCodec\getBuilder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StringCodec.php


Joomla CMS: Référence de la classe TimestampFirstCombCodec

  • Ramsey
  • Uuid
  • Codec
  • TimestampFirstCombCodec
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe TimestampFirstCombCodec
+ Graphe d'héritage de TimestampFirstCombCodec:
StringCodec CodecInterface

Fonctions membres publiques

encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)
- Fonctions membres publiques hérités de StringCodec
__construct (UuidBuilderInterface $builder)
encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)

Fonctions membres protégées

swapTimestampAndRandomBits (array &$components)
- Fonctions membres protégées hérités de StringCodec
getBuilder ()
extractComponents ($encodedUuid)
getFields (array $components)

Description détaillée

TimestampFirstCombCodec encodes and decodes COMB UUIDs which have the timestamp as the first 48 bits. To be used with MySQL, PostgreSQL, Oracle.

Documentation des fonctions membres

◆ decode()

decode ( $encodedUuid )

Decodes a string representation of timestamp first COMB UUID into a UuidInterface object instance

Paramètres
string $encodedUuid
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente CodecInterface.

Références $this, StringCodec\extractComponents(), StringCodec\getBuilder(), StringCodec\getFields(), et TimestampFirstCombCodec\swapTimestampAndRandomBits().

Référencé par TimestampFirstCombCodec\decodeBytes().

◆ decodeBytes()

decodeBytes ( $bytes )

Decodes a binary representation of timestamp first COMB UUID into a UuidInterface object instance

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente CodecInterface.

Références TimestampFirstCombCodec\decode().

◆ encode()

encode ( UuidInterface $uuid )

Encodes a UuidInterface as a string representation of a timestamp first COMB UUID

Paramètres
UuidInterface $uuid
Renvoie
string Hexadecimal string representation of a GUID

Implémente CodecInterface.

Références UuidInterface\getFieldsHex(), et TimestampFirstCombCodec\swapTimestampAndRandomBits().

Référencé par TimestampFirstCombCodec\encodeBinary().

◆ encodeBinary()

encodeBinary ( UuidInterface $uuid )

Encodes a UuidInterface as a binary representation of timestamp first COMB UUID

Paramètres
UuidInterface $uuid
Renvoie
string Binary string representation of timestamp first COMB UUID

Implémente CodecInterface.

Références TimestampFirstCombCodec\encode().

◆ swapTimestampAndRandomBits()

swapTimestampAndRandomBits ( array & $components )
protected

Swaps the first 48 bits with the last 48 bits

Paramètres
array $components An array of UUID components (the UUID exploded on its dashes)
Renvoie
void

Référencé par TimestampFirstCombCodec\decode(), et TimestampFirstCombCodec\encode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TimestampFirstCombCodec.php


Joomla CMS: Référence de la classe TimestampLastCombCodec

  • Ramsey
  • Uuid
  • Codec
  • TimestampLastCombCodec
Référence de la classe TimestampLastCombCodec
+ Graphe d'héritage de TimestampLastCombCodec:
StringCodec CodecInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de StringCodec
__construct (UuidBuilderInterface $builder)
encode (UuidInterface $uuid)
encodeBinary (UuidInterface $uuid)
decode ($encodedUuid)
decodeBytes ($bytes)
- Fonctions membres protégées hérités de StringCodec
getBuilder ()
extractComponents ($encodedUuid)
getFields (array $components)

Description détaillée

TimestampLastCombCodec encodes and decodes COMB UUIDs which have the timestamp as the last 48 bits. To be used with MSSQL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TimestampLastCombCodec.php


Joomla CMS: Référence de la classe BigNumberConverter

  • Ramsey
  • Uuid
  • Converter
  • Number
  • BigNumberConverter
Fonctions membres publiques
Référence de la classe BigNumberConverter
+ Graphe d'héritage de BigNumberConverter:
NumberConverterInterface

Fonctions membres publiques

fromHex ($hex)
toHex ($integer)

Description détaillée

BigNumberConverter converts UUIDs from hexadecimal characters into moontoast/math BigNumber representations of integers and vice versa

Documentation des fonctions membres

◆ fromHex()

fromHex ( $hex )

Converts a hexadecimal number into a Moontoast\Math\BigNumber representation

Paramètres
string $hex The hexadecimal string representation to convert
Renvoie
BigNumber

Implémente NumberConverterInterface.

◆ toHex()

toHex ( $integer )

Converts an integer or Moontoast\Math\BigNumber integer representation into a hexadecimal string representation

Paramètres
int | string | BigNumber $integer An integer or Moontoast\Math\BigNumber
Renvoie
string Hexadecimal string

Implémente NumberConverterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BigNumberConverter.php


Joomla CMS: Référence de la classe DegradedNumberConverter

  • Ramsey
  • Uuid
  • Converter
  • Number
  • DegradedNumberConverter
Fonctions membres publiques
Référence de la classe DegradedNumberConverter
+ Graphe d'héritage de DegradedNumberConverter:
NumberConverterInterface

Fonctions membres publiques

fromHex ($hex)
toHex ($integer)

Description détaillée

DegradedNumberConverter throws UnsatisfiedDependencyException exceptions if attempting to use number conversion functionality in an environment that does not support large integers (i.e. when moontoast/math is not available)

Documentation des fonctions membres

◆ fromHex()

fromHex ( $hex )

Throws an UnsatisfiedDependencyException

Paramètres
string $hex The hexadecimal string representation to convert
Renvoie
void
Exceptions
UnsatisfiedDependencyException

Implémente NumberConverterInterface.

◆ toHex()

toHex ( $integer )

Throws an UnsatisfiedDependencyException

Paramètres
mixed $integer An integer representation to convert
Renvoie
void
Exceptions
UnsatisfiedDependencyException

Implémente NumberConverterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DegradedNumberConverter.php


Joomla CMS: Référence de la classe BigNumberTimeConverter

  • Ramsey
  • Uuid
  • Converter
  • Time
  • BigNumberTimeConverter
Fonctions membres publiques
Référence de la classe BigNumberTimeConverter
+ Graphe d'héritage de BigNumberTimeConverter:
TimeConverterInterface

Fonctions membres publiques

calculateTime ($seconds, $microSeconds)

Description détaillée

BigNumberTimeConverter uses the moontoast/math library's BigNumber to provide facilities for converting parts of time into representations that may be used in UUIDs

Documentation des fonctions membres

◆ calculateTime()

calculateTime | ( | $seconds,
 |  | $microSeconds
 | ) |

Uses the provided seconds and micro-seconds to calculate the time_low, time_mid, and time_high fields used by RFC 4122 version 1 UUIDs

Paramètres
string | $seconds
string | $microSeconds
Renvoie
string[] An array containing low, mid, and high keys http://tools.ietf.org/html/rfc4122#section-4.2.2

Implémente TimeConverterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • BigNumberTimeConverter.php


Joomla CMS: Référence de la classe DegradedTimeConverter

  • Ramsey
  • Uuid
  • Converter
  • Time
  • DegradedTimeConverter
Fonctions membres publiques
Référence de la classe DegradedTimeConverter
+ Graphe d'héritage de DegradedTimeConverter:
TimeConverterInterface

Fonctions membres publiques

calculateTime ($seconds, $microSeconds)

Description détaillée

DegradedTimeConverter throws UnsatisfiedDependencyException exceptions if attempting to use time conversion functionality in an environment that does not support large integers (i.e. when moontoast/math is not available)

Documentation des fonctions membres

◆ calculateTime()

calculateTime | ( | $seconds,
 |  | $microSeconds
 | ) |

Throws an UnsatisfiedDependencyException

Paramètres
string | $seconds
string | $microSeconds
Renvoie
void
Exceptions
UnsatisfiedDependencyException if called on a 32-bit system and Moontoast\Math\BigNumber is not present

Implémente TimeConverterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DegradedTimeConverter.php


Joomla CMS: Référence de la classe PhpTimeConverter

  • Ramsey
  • Uuid
  • Converter
  • Time
  • PhpTimeConverter
Fonctions membres publiques
Référence de la classe PhpTimeConverter
+ Graphe d'héritage de PhpTimeConverter:
TimeConverterInterface

Fonctions membres publiques

calculateTime ($seconds, $microSeconds)

Description détaillée

PhpTimeConverter uses built-in PHP functions and standard math operations available to the PHP programming language to provide facilities for converting parts of time into representations that may be used in UUIDs

Documentation des fonctions membres

◆ calculateTime()

calculateTime | ( | $seconds,
 |  | $microSeconds
 | ) |

Uses the provided seconds and micro-seconds to calculate the time_low, time_mid, and time_high fields used by RFC 4122 version 1 UUIDs

Paramètres
string | $seconds
string | $microSeconds
Renvoie
string[] An array containing low, mid, and high keys http://tools.ietf.org/html/rfc4122#section-4.2.2

Implémente TimeConverterInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpTimeConverter.php


Joomla CMS: Référence de l'interface NumberConverterInterface

  • Ramsey
  • Uuid
  • Converter
  • NumberConverterInterface
Fonctions membres publiques
Référence de l'interface NumberConverterInterface
+ Graphe d'héritage de NumberConverterInterface:
BigNumberConverter DegradedNumberConverter

Fonctions membres publiques

fromHex ($hex)
toHex ($integer)

Description détaillée

NumberConverterInterface converts UUIDs from hexadecimal characters into representations of integers and vice versa

Documentation des fonctions membres

◆ fromHex()

fromHex ( $hex )

Converts a hexadecimal number into an integer representation of the number

The integer representation returned may be an object or a string representation of the integer, depending on the implementation.

Paramètres
string $hex The hexadecimal string representation to convert
Renvoie
mixed
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Implémenté dans DegradedNumberConverter, et BigNumberConverter.

◆ toHex()

toHex ( $integer )

Converts an integer representation into a hexadecimal string representation of the number

Paramètres
mixed $integer An integer representation to convert; this may be a true integer, a string integer, or a object representation that this converter can understand
Renvoie
string Hexadecimal string
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Implémenté dans DegradedNumberConverter, et BigNumberConverter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • NumberConverterInterface.php


Joomla CMS: Référence de l'interface TimeConverterInterface

  • Ramsey
  • Uuid
  • Converter
  • TimeConverterInterface
Fonctions membres publiques
Référence de l'interface TimeConverterInterface
+ Graphe d'héritage de TimeConverterInterface:
BigNumberTimeConverter DegradedTimeConverter PhpTimeConverter

Fonctions membres publiques

calculateTime ($seconds, $microSeconds)

Description détaillée

TimeConverterInterface provides facilities for converting parts of time into representations that may be used in UUIDs

Documentation des fonctions membres

◆ calculateTime()

calculateTime | ( | $seconds,
 |  | $microSeconds
 | ) |

Uses the provided seconds and micro-seconds to calculate the time_low, time_mid, and time_high fields used by RFC 4122 version 1 UUIDs

Paramètres
string | $seconds
string | $microSeconds
Renvoie
string[] An array guaranteed to contain low, mid, and hi keys
Exceptions
UnsatisfiedDependencyException if called on a 32-bit system and Moontoast\Math\BigNumber is not present http://tools.ietf.org/html/rfc4122#section-4.2.2

Implémenté dans BigNumberTimeConverter, DegradedTimeConverter, et PhpTimeConverter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TimeConverterInterface.php


Joomla CMS: Référence de la classe InvalidUuidStringException

  • Ramsey
  • Uuid
  • Exception
  • InvalidUuidStringException
Référence de la classe InvalidUuidStringException
+ Graphe d'héritage de InvalidUuidStringException:

Description détaillée

Thrown to indicate that the parsed UUID string is invalid.

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidUuidStringException.php


Joomla CMS: Référence de la classe UnsatisfiedDependencyException

  • Ramsey
  • Uuid
  • Exception
  • UnsatisfiedDependencyException
Référence de la classe UnsatisfiedDependencyException
+ Graphe d'héritage de UnsatisfiedDependencyException:

Description détaillée

Thrown to indicate that the requested operation has dependencies that have not been satisfied.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/ramsey/uuid/src/Exception/UnsatisfiedDependencyException.php


Joomla CMS: Référence de la classe UnsupportedOperationException

  • Ramsey
  • Uuid
  • Exception
  • UnsupportedOperationException
Référence de la classe UnsupportedOperationException
+ Graphe d'héritage de UnsupportedOperationException:

Description détaillée

Thrown to indicate that the requested operation is not supported.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ramsey/uuid/src/Exception/UnsupportedOperationException.php


Joomla CMS: Référence de la classe CombGenerator

  • Ramsey
  • Uuid
  • Generator
  • CombGenerator
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe CombGenerator
+ Graphe d'héritage de CombGenerator:
RandomGeneratorInterface

Fonctions membres publiques

__construct (RandomGeneratorInterface $generator, NumberConverterInterface $numberConverter)
generate ($length)

Champs de données

const TIMESTAMP_BYTES = 6

Fonctions membres privées

timestamp ()

Attributs privés

$randomGenerator
$converter

Description détaillée

CombGenerator provides functionality to generate COMB (combined GUID/timestamp) sequential UUIDs

https://en.wikipedia.org/wiki/Globally_unique_identifier#Sequential_algorithms

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | RandomGeneratorInterface | $generator,
 |  | NumberConverterInterface | $numberConverter
 | ) |  |

Constructs a CombGenerator using a random-number generator and a number converter

Paramètres
RandomGeneratorInterface | $generator | Random-number generator for the non-time part.
NumberConverterInterface | $numberConverter | Instance of number converter.

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string
Exceptions
UnsatisfiedDependencyException | if Moontoast\Math\BigNumber is not present
InvalidArgumentException | if length is not a positive integer
Exception

Implémente RandomGeneratorInterface.

Références $hash, et $this.

◆ timestamp()

timestamp ( )
private

Returns current timestamp as integer, precise to 0.00001 seconds

Renvoie
string

Documentation des champs

◆ $converter

$converter
private

◆ $randomGenerator

$randomGenerator
private

◆ TIMESTAMP_BYTES

const TIMESTAMP_BYTES = 6
La documentation de cette classe a été générée à partir du fichier suivant :
  • CombGenerator.php


Joomla CMS: Référence de la classe DefaultTimeGenerator

  • Ramsey
  • Uuid
  • Generator
  • DefaultTimeGenerator
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe DefaultTimeGenerator
+ Graphe d'héritage de DefaultTimeGenerator:
TimeGeneratorInterface

Fonctions membres publiques

__construct (NodeProviderInterface $nodeProvider, TimeConverterInterface $timeConverter, TimeProviderInterface $timeProvider)
generate ($node=null, $clockSeq=null)

Fonctions membres protégées

getValidNode ($node)

Attributs privés

$nodeProvider
$timeConverter
$timeProvider

Description détaillée

DefaultTimeGenerator provides functionality to generate strings of binary data for version 1 UUIDs based on a host ID, sequence number, and the current time

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | NodeProviderInterface | $nodeProvider,
 |  | TimeConverterInterface | $timeConverter,
 |  | TimeProviderInterface | $timeProvider
 | ) |  |

Constructs a DefaultTimeGenerator using a node provider, time converter, and time provider

Paramètres
NodeProviderInterface | $nodeProvider
TimeConverterInterface | $timeConverter
TimeProviderInterface | $timeProvider

Références DefaultTimeGenerator\$nodeProvider, DefaultTimeGenerator\$timeConverter, et DefaultTimeGenerator\$timeProvider.

Documentation des fonctions membres

◆ generate()

generate | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID from a host ID, sequence number, and the current time

If $node is not given, we will attempt to obtain the local hardware address. If $clockSeq is given, it is used as the sequence number; otherwise a random 14-bit sequence number is chosen.

Paramètres
int | string | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
string A binary string
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Implémente TimeGeneratorInterface.

Références BinaryUtils\applyVariant(), BinaryUtils\applyVersion(), DefaultTimeGenerator\getValidNode(), et null.

◆ getValidNode()

getValidNode ( $node )
protected

Uses the node provider given when constructing this instance to get the node ID (usually a MAC address)

Paramètres
string | int $node A node value that may be used to override the node provider
Renvoie
string Hexadecimal representation of the node ID
Exceptions
InvalidArgumentException
Exception

Références null.

Référencé par DefaultTimeGenerator\generate().

Documentation des champs

◆ $nodeProvider

$nodeProvider
private

Référencé par DefaultTimeGenerator\__construct().

◆ $timeConverter

$timeConverter
private

Référencé par DefaultTimeGenerator\__construct().

◆ $timeProvider

$timeProvider
private

Référencé par DefaultTimeGenerator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DefaultTimeGenerator.php


Joomla CMS: Référence de la classe MtRandGenerator

  • Ramsey
  • Uuid
  • Generator
  • MtRandGenerator
Fonctions membres publiques
Référence de la classe MtRandGenerator
+ Graphe d'héritage de MtRandGenerator:
RandomGeneratorInterface

Fonctions membres publiques

generate ($length)

Description détaillée

MtRandRandomGenerator provides functionality to generate strings of random binary data using the mt_rand() PHP function

Obsolète:
The mt_rand() function is not a reliable source of randomness. The default RandomBytesGenerator, which uses the random_bytes() function, is recommended as the safest and most reliable source of randomness. This generator will be removed in ramsey/uuid 4.0.0. http://php.net/mt_rand

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string

Implémente RandomGeneratorInterface.

Références $i.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MtRandGenerator.php


Joomla CMS: Référence de la classe OpenSslGenerator

  • Ramsey
  • Uuid
  • Generator
  • OpenSslGenerator
Fonctions membres publiques
Référence de la classe OpenSslGenerator
+ Graphe d'héritage de OpenSslGenerator:
RandomGeneratorInterface

Fonctions membres publiques

generate ($length)

Description détaillée

OpenSslRandomGenerator provides functionality to generate strings of random binary data using the openssl_random_pseudo_bytes() PHP function

The use of this generator requires PHP to be compiled using the --with-openssl option.

Obsolète:
The openssl_random_pseudo_bytes() function is not a reliable source of randomness. The default RandomBytesGenerator, which uses the random_bytes() function, is recommended as the safest and most reliable source of randomness. This generator will be removed in ramsey/uuid 4.0.0. http://php.net/openssl_random_pseudo_bytes

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string

Implémente RandomGeneratorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • OpenSslGenerator.php


Joomla CMS: Référence de la classe PeclUuidRandomGenerator

  • Ramsey
  • Uuid
  • Generator
  • PeclUuidRandomGenerator
Fonctions membres publiques
Référence de la classe PeclUuidRandomGenerator
+ Graphe d'héritage de PeclUuidRandomGenerator:
RandomGeneratorInterface

Fonctions membres publiques

generate ($length)

Description détaillée

PeclUuidRandomGenerator provides functionality to generate strings of random binary data using the PECL UUID PHP extension

https://pecl.php.net/package/uuid

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string

Implémente RandomGeneratorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PeclUuidRandomGenerator.php


Joomla CMS: Référence de la classe PeclUuidTimeGenerator

  • Ramsey
  • Uuid
  • Generator
  • PeclUuidTimeGenerator
Fonctions membres publiques
Référence de la classe PeclUuidTimeGenerator
+ Graphe d'héritage de PeclUuidTimeGenerator:
TimeGeneratorInterface

Fonctions membres publiques

generate ($node=null, $clockSeq=null)

Description détaillée

PeclUuidTimeGenerator provides functionality to generate strings of binary data for version 1 UUIDs using the PECL UUID PHP extension

https://pecl.php.net/package/uuid

Documentation des fonctions membres

◆ generate()

generate | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID using the PECL UUID extension

Paramètres
int | string | $node | Not used in this context
int | $clockSeq | Not used in this context
Renvoie
string A binary string

Implémente TimeGeneratorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • PeclUuidTimeGenerator.php


Joomla CMS: Référence de la classe RandomBytesGenerator

  • Ramsey
  • Uuid
  • Generator
  • RandomBytesGenerator
Fonctions membres publiques
Référence de la classe RandomBytesGenerator
+ Graphe d'héritage de RandomBytesGenerator:
RandomGeneratorInterface

Fonctions membres publiques

generate ($length)

Description détaillée

RandomBytesGenerator provides functionality to generate strings of random binary data using random_bytes() function in PHP 7+ or paragonie/random_compat

https://github.com/paragonie/random_compat

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string
Exceptions
Exception if it was not possible to gather sufficient entropy

Implémente RandomGeneratorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RandomBytesGenerator.php


Joomla CMS: Référence de la classe RandomGeneratorFactory

  • Ramsey
  • Uuid
  • Generator
  • RandomGeneratorFactory
Fonctions membres publiques statiques
Référence de la classe RandomGeneratorFactory

Fonctions membres publiques statiques

static getGenerator ()

Description détaillée

A factory for retrieving a random generator, based on the environment

Documentation des fonctions membres

◆ getGenerator()

static getGenerator ( )
static

Returns a default random generator, based on the current environment

Renvoie
RandomGeneratorInterface
La documentation de cette classe a été générée à partir du fichier suivant :
  • RandomGeneratorFactory.php


Joomla CMS: Référence de l'interface RandomGeneratorInterface

  • Ramsey
  • Uuid
  • Generator
  • RandomGeneratorInterface
Fonctions membres publiques
Référence de l'interface RandomGeneratorInterface
+ Graphe d'héritage de RandomGeneratorInterface:
CombGenerator MtRandGenerator OpenSslGenerator PeclUuidRandomGenerator RandomBytesGenerator RandomLibAdapter SodiumRandomGenerator

Fonctions membres publiques

generate ($length)

Description détaillée

RandomGeneratorInterface provides functionality to generate strings of random binary data

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string
Exceptions
UnsatisfiedDependencyException | if Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Implémenté dans CombGenerator, RandomLibAdapter, OpenSslGenerator, SodiumRandomGenerator, MtRandGenerator, RandomBytesGenerator, et PeclUuidRandomGenerator.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RandomGeneratorInterface.php


Joomla CMS: Référence de la classe RandomLibAdapter

  • Ramsey
  • Uuid
  • Generator
  • RandomLibAdapter
Fonctions membres publiques | Attributs privés
Référence de la classe RandomLibAdapter
+ Graphe d'héritage de RandomLibAdapter:
RandomGeneratorInterface

Fonctions membres publiques

__construct (Generator $generator=null)
generate ($length)

Attributs privés

$generator

Description détaillée

RandomLibAdapter provides functionality to generate strings of random binary data using the paragonie/random-lib library

https://packagist.org/packages/paragonie/random-lib

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Generator $generator = null )

Constructs a RandomLibAdapter using a RandomLib\Generator

By default, if no Generator is passed in, this creates a high-strength generator to use when generating random binary data.

Paramètres
Generator $generator An paragonie/random-lib Generator

Références RandomLibAdapter\$generator, et null.

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string

Implémente RandomGeneratorInterface.

Documentation des champs

◆ $generator

$generator
private

Référencé par RandomLibAdapter\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RandomLibAdapter.php


Joomla CMS: Référence de la classe SodiumRandomGenerator

  • Ramsey
  • Uuid
  • Generator
  • SodiumRandomGenerator
Fonctions membres publiques
Référence de la classe SodiumRandomGenerator
+ Graphe d'héritage de SodiumRandomGenerator:
RandomGeneratorInterface

Fonctions membres publiques

generate ($length)

Description détaillée

SodiumRandomGenerator provides functionality to generate strings of random binary data using the PECL libsodium extension

Obsolète:
As of PHP 7.2.0, the libsodium extension is bundled with PHP, and the random_bytes() PHP function is now the recommended method for generating random byes. The default RandomBytesGenerator uses the random_bytes() function. This generator will be removed in ramsey/uuid 4.0.0. https://paragonie.com/book/pecl-libsodium

Documentation des fonctions membres

◆ generate()

generate ( $length )

Generates a string of random binary data of the specified length

Paramètres
integer $length The number of bytes of random binary data to generate
Renvoie
string A binary string

Implémente RandomGeneratorInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SodiumRandomGenerator.php


Joomla CMS: Référence de la classe TimeGeneratorFactory

  • Ramsey
  • Uuid
  • Generator
  • TimeGeneratorFactory
Fonctions membres publiques | Attributs privés
Référence de la classe TimeGeneratorFactory

Fonctions membres publiques

__construct (NodeProviderInterface $nodeProvider, TimeConverterInterface $timeConverter, TimeProviderInterface $timeProvider)
getGenerator ()

Attributs privés

$nodeProvider
$timeConverter
$timeProvider

Description détaillée

A factory for retrieving a time generator, based on the environment

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | NodeProviderInterface | $nodeProvider,
 |  | TimeConverterInterface | $timeConverter,
 |  | TimeProviderInterface | $timeProvider
 | ) |  |

Constructs a TimeGeneratorFactory using a node provider, time converter, and time provider

Paramètres
NodeProviderInterface | $nodeProvider
TimeConverterInterface | $timeConverter
TimeProviderInterface | $timeProvider

Références TimeGeneratorFactory\$nodeProvider, TimeGeneratorFactory\$timeConverter, et TimeGeneratorFactory\$timeProvider.

Documentation des fonctions membres

◆ getGenerator()

getGenerator ( )

Returns a default time generator, based on the current environment

Renvoie
TimeGeneratorInterface

Documentation des champs

◆ $nodeProvider

$nodeProvider
private

Référencé par TimeGeneratorFactory\__construct().

◆ $timeConverter

$timeConverter
private

Référencé par TimeGeneratorFactory\__construct().

◆ $timeProvider

$timeProvider
private

Référencé par TimeGeneratorFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TimeGeneratorFactory.php


Joomla CMS: Référence de l'interface TimeGeneratorInterface

  • Ramsey
  • Uuid
  • Generator
  • TimeGeneratorInterface
Fonctions membres publiques
Référence de l'interface TimeGeneratorInterface
+ Graphe d'héritage de TimeGeneratorInterface:
DefaultTimeGenerator PeclUuidTimeGenerator

Fonctions membres publiques

generate ($node=null, $clockSeq=null)

Description détaillée

TimeGeneratorInterface provides functionality to generate strings of binary data for version 1 UUIDs based on a host ID, sequence number, and the current time

Documentation des fonctions membres

◆ generate()

generate | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID from a host ID, sequence number, and the current time

Paramètres
int | string | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
string A binary string
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Implémenté dans DefaultTimeGenerator, et PeclUuidTimeGenerator.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TimeGeneratorInterface.php


Joomla CMS: Référence de la classe FallbackNodeProvider

  • Ramsey
  • Uuid
  • Provider
  • Node
  • FallbackNodeProvider
Fonctions membres publiques | Attributs privés
Référence de la classe FallbackNodeProvider
+ Graphe d'héritage de FallbackNodeProvider:
NodeProviderInterface

Fonctions membres publiques

__construct (array $providers)
getNode ()

Attributs privés

$nodeProviders

Description détaillée

FallbackNodeProvider attempts to gain the system host ID from an array of providers, falling back to the next in line in the event a host ID can not be obtained

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $providers )

Constructs a FallbackNodeProvider using an array of node providers

Paramètres
NodeProviderInterface[] $providers Array of node providers

Documentation des fonctions membres

◆ getNode()

getNode ( )

Returns the system node ID by iterating over an array of node providers and returning the first non-empty value found

Renvoie
string System node ID as a hexadecimal string
Exceptions
Exception

Implémente NodeProviderInterface.

Références null.

Documentation des champs

◆ $nodeProviders

$nodeProviders
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • FallbackNodeProvider.php


Joomla CMS: Référence de la classe RandomNodeProvider

  • Ramsey
  • Uuid
  • Provider
  • Node
  • RandomNodeProvider
Fonctions membres publiques
Référence de la classe RandomNodeProvider
+ Graphe d'héritage de RandomNodeProvider:
NodeProviderInterface

Fonctions membres publiques

getNode ()

Description détaillée

RandomNodeProvider provides functionality to generate a random node ID, in the event that the node ID could not be obtained from the host system

http://tools.ietf.org/html/rfc4122#section-4.5

Documentation des fonctions membres

◆ getNode()

getNode ( )

Returns the system node ID

Renvoie
string System node ID as a hexadecimal string
Exceptions
Exception if it was not possible to gather sufficient entropy

Implémente NodeProviderInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RandomNodeProvider.php


Joomla CMS: Référence de la classe SystemNodeProvider

  • Ramsey
  • Uuid
  • Provider
  • Node
  • SystemNodeProvider
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe SystemNodeProvider
+ Graphe d'héritage de SystemNodeProvider:
NodeProviderInterface

Fonctions membres publiques

getNode ()

Fonctions membres protégées

getIfconfig ()
getSysfs ()

Description détaillée

SystemNodeProvider provides functionality to get the system node ID (MAC address) using external system calls

Documentation des fonctions membres

◆ getIfconfig()

getIfconfig ( )
protected

Returns the network interface configuration for the system

Renvoie
string

Référencé par SystemNodeProvider\getNode().

◆ getNode()

getNode ( )

Returns the system node ID

Renvoie
string|false System node ID as a hexadecimal string, or false if it is not found

Implémente NodeProviderInterface.

Références SystemNodeProvider\getIfconfig(), SystemNodeProvider\getSysfs(), et null.

◆ getSysfs()

getSysfs ( )
protected

Returns mac address from the first system interface via the sysfs interface

Renvoie
string|bool

Référencé par SystemNodeProvider\getNode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SystemNodeProvider.php


Joomla CMS: Référence de la classe FixedTimeProvider

  • Ramsey
  • Uuid
  • Provider
  • Time
  • FixedTimeProvider
Fonctions membres publiques | Attributs privés
Référence de la classe FixedTimeProvider
+ Graphe d'héritage de FixedTimeProvider:
TimeProviderInterface

Fonctions membres publiques

__construct (array $timestamp)
setUsec ($value)
setSec ($value)
currentTime ()

Attributs privés

$fixedTime

Description détaillée

FixedTimeProvider uses an previously-generated timestamp to provide the time

This provider allows the use of a previously-generated timestamp, such as one stored in a database, when creating version 1 UUIDs.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $timestamp )

Constructs a FixedTimeProvider using the provided $timestamp

Paramètres
int[] Array containing sec and usec components of a timestamp
Exceptions
InvalidArgumentException if the $timestamp does not contain sec or usec components

Documentation des fonctions membres

◆ currentTime()

currentTime ( )

Returns a timestamp array

Renvoie
int[] Array containing sec and usec components of a timestamp

Implémente TimeProviderInterface.

Références FixedTimeProvider\$fixedTime.

◆ setSec()

setSec ( $value )

Sets the sec component of the timestamp

Paramètres
int $value The sec value to set

Références $value.

◆ setUsec()

setUsec ( $value )

Sets the usec component of the timestamp

Paramètres
int $value The usec value to set

Références $value.

Documentation des champs

◆ $fixedTime

$fixedTime
private

Référencé par FixedTimeProvider\currentTime().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FixedTimeProvider.php


Joomla CMS: Référence de la classe SystemTimeProvider

  • Ramsey
  • Uuid
  • Provider
  • Time
  • SystemTimeProvider
Fonctions membres publiques
Référence de la classe SystemTimeProvider
+ Graphe d'héritage de SystemTimeProvider:
TimeProviderInterface

Fonctions membres publiques

currentTime ()

Description détaillée

SystemTimeProvider uses built-in PHP functions to provide the time

Documentation des fonctions membres

◆ currentTime()

currentTime ( )

Returns a timestamp array

Renvoie
int[] Array containing sec and usec components of a timestamp

Implémente TimeProviderInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SystemTimeProvider.php


Joomla CMS: Référence de l'interface NodeProviderInterface

  • Ramsey
  • Uuid
  • Provider
  • NodeProviderInterface
Fonctions membres publiques
Référence de l'interface NodeProviderInterface
+ Graphe d'héritage de NodeProviderInterface:
FallbackNodeProvider RandomNodeProvider SystemNodeProvider

Fonctions membres publiques

getNode ()

Description détaillée

NodeProviderInterface provides functionality to get the node ID (or host ID in the form of the system's MAC address) from a specific type of node provider

Documentation des fonctions membres

◆ getNode()

getNode ( )

Returns the system node ID

Renvoie
string System node ID as a hexadecimal string
Exceptions
Exception if it was not possible to gather sufficient entropy

Implémenté dans FallbackNodeProvider, RandomNodeProvider, et SystemNodeProvider.

La documentation de cette interface a été générée à partir du fichier suivant :
  • NodeProviderInterface.php


Joomla CMS: Référence de l'interface TimeProviderInterface

  • Ramsey
  • Uuid
  • Provider
  • TimeProviderInterface
Fonctions membres publiques
Référence de l'interface TimeProviderInterface
+ Graphe d'héritage de TimeProviderInterface:
FixedTimeProvider SystemTimeProvider

Fonctions membres publiques

currentTime ()

Description détaillée

TimeProviderInterface provides functionality to get the time from a specific type of time provider

Documentation des fonctions membres

◆ currentTime()

currentTime ( )

Returns a timestamp array

Renvoie
int[] Array guaranteed to contain sec and usec components of a timestamp

Implémenté dans FixedTimeProvider, et SystemTimeProvider.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TimeProviderInterface.php


Joomla CMS: Référence de la classe BinaryUtils

  • Ramsey
  • Uuid
  • BinaryUtils
Fonctions membres publiques statiques
Référence de la classe BinaryUtils

Fonctions membres publiques statiques

static | applyVariant ($clockSeqHi)
static | applyVersion ($timeHi, $version)

Description détaillée

Provides binary math utilities

Documentation des fonctions membres

◆ applyVariant()

static applyVariant ( $clockSeqHi )
static

Applies the RFC 4122 variant field to the clock_seq_hi_and_reserved field

Paramètres
$clockSeqHi
Renvoie
int The high field of the clock sequence multiplexed with the variant http://tools.ietf.org/html/rfc4122#section-4.1.1

Référencé par DefaultTimeGenerator\generate(), et UuidFactory\uuidFromHashedName().

◆ applyVersion()

static applyVersion | ( | $timeHi,
 |  | $version
 | ) |
static

Applies the RFC 4122 version number to the time_hi_and_version field

Paramètres
string | $timeHi
integer | $version
Renvoie
int The high field of the timestamp multiplexed with the version number http://tools.ietf.org/html/rfc4122#section-4.1.3

Références $version.

Référencé par DefaultTimeGenerator\generate(), et UuidFactory\uuidFromHashedName().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BinaryUtils.php


Joomla CMS: Référence de la classe DegradedUuid

  • Ramsey
  • Uuid
  • DegradedUuid
Fonctions membres publiques
Référence de la classe DegradedUuid
+ Graphe d'héritage de DegradedUuid:
Uuid UuidInterface

Fonctions membres publiques

getDateTime ()
getFields ()
getNode ()
getTimeLow ()
getTimestamp ()
- Fonctions membres publiques hérités de Uuid
__construct (array $fields, NumberConverterInterface $converter, CodecInterface $codec)
__toString ()
jsonSerialize ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $serialized)
compareTo (UuidInterface $other)
equals ($other)
getBytes ()
getClockSeqHiAndReserved ()
getClockSeqHiAndReservedHex ()
getClockSeqLow ()
getClockSeqLowHex ()
getClockSequence ()
getClockSequenceHex ()
getNumberConverter ()
getDateTime ()
getFields ()
getFieldsHex ()
getHex ()
getInteger ()
getLeastSignificantBits ()
getLeastSignificantBitsHex ()
getMostSignificantBits ()
getMostSignificantBitsHex ()
getNode ()
getNodeHex ()
getTimeHiAndVersion ()
getTimeHiAndVersionHex ()
getTimeLow ()
getTimeLowHex ()
getTimeMid ()
getTimeMidHex ()
getTimestamp ()
getTimestampHex ()
getUrn ()
getVariant ()
getVersion ()
toString ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Uuid
static | getFactory ()
static | setFactory (UuidFactoryInterface $factory)
static | fromBytes ($bytes)
static | fromString ($name)
static | fromInteger ($integer)
static | isValid ($uuid)
static | uuid1 ($node=null, $clockSeq=null)
static | uuid3 ($ns, $name)
static | uuid4 ()
static | uuid5 ($ns, $name)
- Champs de données hérités de Uuid
const | NAMESPACE_DNS = '6ba7b810-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_URL = '6ba7b811-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_OID = '6ba7b812-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_X500 = '6ba7b814-9dad-11d1-80b4-00c04fd430c8'
const | NIL = '00000000-0000-0000-0000-000000000000'
const | RESERVED_NCS = 0
const | RFC_4122 = 2
const | RESERVED_MICROSOFT = 6
const | RESERVED_FUTURE = 7
const | VALID_PATTERN = '^[0-9A-Fa-f]{8}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{12}$'
const | UUID_TYPE_TIME = 1
const | UUID_TYPE_IDENTIFIER = 2
const | UUID_TYPE_HASH_MD5 = 3
const | UUID_TYPE_RANDOM = 4
const | UUID_TYPE_HASH_SHA1 = 5
- Attributs protégés hérités de Uuid
$codec
$fields
$converter

Description détaillée

DegradedUuid represents an RFC 4122 UUID on 32-bit systems

Voir également
Uuid

Documentation des fonctions membres

◆ getDateTime()

getDateTime ( )

Returns a PHP DateTime object representing the timestamp associated with this UUID.The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
DateTime A PHP DateTime representation of the date
Exceptions
UnsupportedOperationException | If this UUID is not a version 1 UUID
UnsatisfiedDependencyException | if called in a 32-bit system and Moontoast\Math\BigNumber is not present

Implémente UuidInterface.

Références Uuid\getTimestampHex(), et Uuid\getVersion().

◆ getFields()

getFields ( )

For degraded UUIDs, throws an UnsatisfiedDependencyException when called on a 32-bit system

Exceptions
UnsatisfiedDependencyException if called on a 32-bit system

◆ getNode()

getNode ( )

For degraded UUIDs, throws an UnsatisfiedDependencyException when called on a 32-bit system

Exceptions
UnsatisfiedDependencyException if called on a 32-bit system

◆ getTimeLow()

getTimeLow ( )

For degraded UUIDs, throws an UnsatisfiedDependencyException when called on a 32-bit system

Exceptions
UnsatisfiedDependencyException if called on a 32-bit system

◆ getTimestamp()

getTimestamp ( )

For degraded UUIDs, throws an UnsatisfiedDependencyException when called on a 32-bit system

Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system
UnsupportedOperationException | If this UUID is not a version 1 UUID

Références Uuid\getVersion().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DegradedUuid.php


Joomla CMS: Référence de la classe FeatureSet

  • Ramsey
  • Uuid
  • FeatureSet
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe FeatureSet

Fonctions membres publiques

__construct ( $useGuids=false, $force32Bit=false, $forceNoBigNumber=false, $ignoreSystemNode=false, $enablePecl=false)
getBuilder ()
getCodec ()
getNodeProvider ()
getNumberConverter ()
getRandomGenerator ()
getTimeGenerator ()
setTimeProvider (TimeProviderInterface $timeProvider)

Fonctions membres protégées

buildCodec ($useGuids=false)
buildNodeProvider ()
buildNumberConverter ()
buildRandomGenerator ()
buildTimeGenerator (TimeProviderInterface $timeProvider)
buildTimeConverter ()
buildUuidBuilder ()
hasBigNumber ()
is64BitSystem ()

Attributs privés

$disableBigNumber = false
$disable64Bit = false
$ignoreSystemNode = false
$enablePecl = false
$builder
$codec
$nodeProvider
$numberConverter
$randomGenerator
$timeGenerator

Description détaillée

FeatureSet detects and exposes available features in the current environment (32- or 64-bit, available dependencies, etc.)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $useGuids = false,
 |  | $force32Bit = false,
 |  | $forceNoBigNumber = false,
 |  | $ignoreSystemNode = false,
 |  | $enablePecl = false
 | ) |

Constructs a FeatureSet for use by a UuidFactory to determine or set features available to the environment

Paramètres
bool | $useGuids | Whether to build UUIDs using the GuidStringCodec
bool | $force32Bit | Whether to force the use of 32-bit functionality (primarily for testing purposes)
bool | $forceNoBigNumber | Whether to disable the use of moontoast/math BigNumber (primarily for testing purposes)
bool | $ignoreSystemNode | Whether to disable attempts to check for the system host ID (primarily for testing purposes)
bool | $enablePecl | Whether to enable the use of the PeclUuidTimeGenerator to generate version 1 UUIDs

Références FeatureSet\$enablePecl, FeatureSet\$ignoreSystemNode, FeatureSet\buildCodec(), FeatureSet\buildNodeProvider(), FeatureSet\buildNumberConverter(), FeatureSet\buildRandomGenerator(), FeatureSet\buildUuidBuilder(), et FeatureSet\setTimeProvider().

Documentation des fonctions membres

◆ buildCodec()

buildCodec ( $useGuids = false )
protected

Determines which UUID coder-decoder to use and returns the configured codec for this environment

Paramètres
bool $useGuids Whether to build UUIDs using the GuidStringCodec
Renvoie
CodecInterface

Référencé par FeatureSet\__construct().

◆ buildNodeProvider()

buildNodeProvider ( )
protected

Determines which system node ID provider to use and returns the configured system node ID provider for this environment

Renvoie
NodeProviderInterface

Référencé par FeatureSet\__construct().

◆ buildNumberConverter()

buildNumberConverter ( )
protected

Determines which number converter to use and returns the configured number converter for this environment

Renvoie
NumberConverterInterface

Références FeatureSet\hasBigNumber().

Référencé par FeatureSet\__construct().

◆ buildRandomGenerator()

buildRandomGenerator ( )
protected

Determines which random UUID generator to use and returns the configured random UUID generator for this environment

Renvoie
RandomGeneratorInterface

Référencé par FeatureSet\__construct().

◆ buildTimeConverter()

buildTimeConverter ( )
protected

Determines which time converter to use and returns the configured time converter for this environment

Renvoie
TimeConverterInterface

Références FeatureSet\hasBigNumber(), et FeatureSet\is64BitSystem().

Référencé par FeatureSet\buildTimeGenerator().

◆ buildTimeGenerator()

buildTimeGenerator ( TimeProviderInterface $timeProvider )
protected

Determines which time-based UUID generator to use and returns the configured time-based UUID generator for this environment

Paramètres
TimeProviderInterface $timeProvider
Renvoie
TimeGeneratorInterface

Références FeatureSet\buildTimeConverter().

Référencé par FeatureSet\setTimeProvider().

◆ buildUuidBuilder()

buildUuidBuilder ( )
protected

Determines which UUID builder to use and returns the configured UUID builder for this environment

Renvoie
UuidBuilderInterface

Références FeatureSet\is64BitSystem().

Référencé par FeatureSet\__construct().

◆ getBuilder()

getBuilder ( )

Returns the builder configured for this environment

Renvoie
UuidBuilderInterface

Références FeatureSet\$builder.

◆ getCodec()

getCodec ( )

Returns the UUID UUID coder-decoder configured for this environment

Renvoie
CodecInterface

Références FeatureSet\$codec.

◆ getNodeProvider()

getNodeProvider ( )

Returns the system node ID provider configured for this environment

Renvoie
NodeProviderInterface

Références FeatureSet\$nodeProvider.

◆ getNumberConverter()

getNumberConverter ( )

Returns the number converter configured for this environment

Renvoie
NumberConverterInterface

Références FeatureSet\$numberConverter.

◆ getRandomGenerator()

getRandomGenerator ( )

Returns the random UUID generator configured for this environment

Renvoie
RandomGeneratorInterface

Références FeatureSet\$randomGenerator.

◆ getTimeGenerator()

getTimeGenerator ( )

Returns the time-based UUID generator configured for this environment

Renvoie
TimeGeneratorInterface

Références FeatureSet\$timeGenerator.

◆ hasBigNumber()

hasBigNumber ( )
protected

Returns true if the system has Moontoast\Math\BigNumber

Renvoie
bool

Références FeatureSet\$disableBigNumber.

Référencé par FeatureSet\buildNumberConverter(), et FeatureSet\buildTimeConverter().

◆ is64BitSystem()

is64BitSystem ( )
protected

Returns true if the system is 64-bit, false otherwise

Renvoie
bool

Références FeatureSet\$disable64Bit.

Référencé par FeatureSet\buildTimeConverter(), et FeatureSet\buildUuidBuilder().

◆ setTimeProvider()

setTimeProvider ( TimeProviderInterface $timeProvider )

Sets the time provider for use in this environment

Paramètres
TimeProviderInterface $timeProvider

Références FeatureSet\buildTimeGenerator().

Référencé par FeatureSet\__construct().

Documentation des champs

◆ $builder

$builder
private

Référencé par FeatureSet\getBuilder().

◆ $codec

$codec
private

Référencé par FeatureSet\getCodec().

◆ $disable64Bit

$disable64Bit = false
private

Référencé par FeatureSet\is64BitSystem().

◆ $disableBigNumber

$disableBigNumber = false
private

Référencé par FeatureSet\hasBigNumber().

◆ $enablePecl

$enablePecl = false
private

Référencé par FeatureSet\__construct().

◆ $ignoreSystemNode

$ignoreSystemNode = false
private

Référencé par FeatureSet\__construct().

◆ $nodeProvider

$nodeProvider
private

Référencé par FeatureSet\getNodeProvider().

◆ $numberConverter

$numberConverter
private

Référencé par FeatureSet\getNumberConverter().

◆ $randomGenerator

$randomGenerator
private

Référencé par FeatureSet\getRandomGenerator().

◆ $timeGenerator

$timeGenerator
private

Référencé par FeatureSet\getTimeGenerator().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FeatureSet.php


Joomla CMS: Référence de la classe Uuid

  • Ramsey
  • Uuid
  • Uuid
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés | Attributs privés statiques
Référence de la classe Uuid
+ Graphe d'héritage de Uuid:
UuidInterface DegradedUuid

Fonctions membres publiques

__construct (array $fields, NumberConverterInterface $converter, CodecInterface $codec)
__toString ()
jsonSerialize ()
serialize ()
__serialize ()
unserialize ($serialized)
__unserialize (array $serialized)
compareTo (UuidInterface $other)
equals ($other)
getBytes ()
getClockSeqHiAndReserved ()
getClockSeqHiAndReservedHex ()
getClockSeqLow ()
getClockSeqLowHex ()
getClockSequence ()
getClockSequenceHex ()
getNumberConverter ()
getDateTime ()
getFields ()
getFieldsHex ()
getHex ()
getInteger ()
getLeastSignificantBits ()
getLeastSignificantBitsHex ()
getMostSignificantBits ()
getMostSignificantBitsHex ()
getNode ()
getNodeHex ()
getTimeHiAndVersion ()
getTimeHiAndVersionHex ()
getTimeLow ()
getTimeLowHex ()
getTimeMid ()
getTimeMidHex ()
getTimestamp ()
getTimestampHex ()
getUrn ()
getVariant ()
getVersion ()
toString ()

Fonctions membres publiques statiques

static | getFactory ()
static | setFactory (UuidFactoryInterface $factory)
static | fromBytes ($bytes)
static | fromString ($name)
static | fromInteger ($integer)
static | isValid ($uuid)
static | uuid1 ($node=null, $clockSeq=null)
static | uuid3 ($ns, $name)
static | uuid4 ()
static | uuid5 ($ns, $name)

Champs de données

const | NAMESPACE_DNS = '6ba7b810-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_URL = '6ba7b811-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_OID = '6ba7b812-9dad-11d1-80b4-00c04fd430c8'
const | NAMESPACE_X500 = '6ba7b814-9dad-11d1-80b4-00c04fd430c8'
const | NIL = '00000000-0000-0000-0000-000000000000'
const | RESERVED_NCS = 0
const | RFC_4122 = 2
const | RESERVED_MICROSOFT = 6
const | RESERVED_FUTURE = 7
const | VALID_PATTERN = '^[0-9A-Fa-f]{8}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{12}$'
const | UUID_TYPE_TIME = 1
const | UUID_TYPE_IDENTIFIER = 2
const | UUID_TYPE_HASH_MD5 = 3
const | UUID_TYPE_RANDOM = 4
const | UUID_TYPE_HASH_SHA1 = 5

Attributs protégés

$codec
$fields
$converter

Attributs privés statiques

static $factory = null

Description détaillée

Represents a universally unique identifier (UUID), according to RFC 4122.

This class provides immutable UUID objects (the Uuid class) and the static methods uuid1(), uuid3(), uuid4(), and uuid5() for generating version 1, 3, 4, and 5 UUIDs as specified in RFC 4122.

If all you want is a unique ID, you should probably call uuid1() or uuid4(). Note that uuid1() may compromise privacy since it creates a UUID containing the computer’s network address. uuid4() creates a random UUID.

http://en.wikipedia.org/wiki/Universally_unique_identifier http://docs.python.org/3/library/uuid.html http://docs.oracle.com/javase/6/docs/api/java/util/UUID.html

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $fields,
 |  | NumberConverterInterface | $converter,
 |  | CodecInterface | $codec
 | ) |  |

Creates a universally unique identifier (UUID) from an array of fields.

Unless you're making advanced use of this library to generate identifiers that deviate from RFC 4122, you probably do not want to instantiate a UUID directly. Use the static methods, instead:

use Ramsey\Uuid\Uuid;
$timeBasedUuid = Uuid::uuid1();
$namespaceMd5Uuid = Uuid::uuid3(Uuid::NAMESPACE_URL, 'http://php.net/');
$randomUuid = Uuid::uuid4();
$namespaceSha1Uuid = Uuid::uuid5(Uuid::NAMESPACE_URL, 'http://php.net/');
Paramètres
array $fields An array of fields from which to construct a UUID; see {
Voir également
::getFieldsHex()} for array structure.
Paramètres
NumberConverterInterface | $converter | The number converter to use for converting hex values to/from integers.
CodecInterface | $codec | The codec to use when encoding or decoding UUID strings.

Références Uuid\$codec, Uuid\$converter, Uuid\$fields, et fields.

Documentation des fonctions membres

◆ __serialize()

__serialize ( )
Renvoie
array{string: string}

Références Uuid\toString().

◆ __toString()

__toString ( )

Converts this UUID object to a string when the object is used in any string context.

Renvoie
string http://www.php.net/manual/en/language.oop5.magic.php#object.tostring

Références Uuid\toString().

◆ __unserialize()

__unserialize ( array $serialized )
Paramètres
array{string string} $serialized
Renvoie
void
Exceptions
InvalidUuidStringException

Références Uuid\unserialize().

◆ compareTo()

compareTo ( UuidInterface $other )

Compares this UUID to the specified UUID.

The first of two UUIDs is greater than the second if the most significant field in which the UUIDs differ is greater for the first UUID.

  • Q. What's the value of being able to sort UUIDs?
  • A. Use them as keys in a B-Tree or similar mapping.
Paramètres
UuidInterface $other UUID to which this UUID is compared
Renvoie
int -1, 0 or 1 as this UUID is less than, equal to, or greater than $uuid

Implémente UuidInterface.

Références UuidInterface\getLeastSignificantBitsHex(), Uuid\getLeastSignificantBitsHex(), UuidInterface\getMostSignificantBitsHex(), et Uuid\getMostSignificantBitsHex().

Référencé par Uuid\equals().

◆ equals()

equals ( $other )

Compares this object to the specified object.

The result is true if and only if the argument is not null, is a UUID object, has the same variant, and contains the same value, bit for bit, as this UUID.

Paramètres
object $other
Renvoie
bool True if $other is equal to this UUID

Implémente UuidInterface.

Références Uuid\compareTo().

◆ fromBytes()

static fromBytes ( $bytes )
static

Creates a UUID from a byte string.

Paramètres
string $bytes
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException
InvalidArgumentException

Référencé par AttestationObjectLoader\load().

◆ fromInteger()

static fromInteger ( $integer )
static

Creates a UUID from a 128-bit integer string.

Paramètres
string $integer String representation of 128-bit integer
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidUuidStringException

◆ fromString()

static fromString ( $name )
static

Creates a UUID from the string standard representation.

Paramètres
string $name A string that specifies a UUID
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Références $name.

◆ getBytes()

getBytes ( )

Returns the UUID as a 16-byte string (containing the six integer fields in big-endian byte order).

Renvoie
string

Implémente UuidInterface.

Références $this.

◆ getClockSeqHiAndReserved()

getClockSeqHiAndReserved ( )

Returns the high field of the clock sequence multiplexed with the variant (bits 65-72 of the UUID).

Renvoie
int Unsigned 8-bit integer value of clock_seq_hi_and_reserved

Références Uuid\getClockSeqHiAndReservedHex().

Référencé par Uuid\getClockSequence(), Uuid\getFields(), et Uuid\getVariant().

◆ getClockSeqHiAndReservedHex()

getClockSeqHiAndReservedHex ( )

Returns the high field of the clock sequence multiplexed with the variant (bits 65-72 of the UUID).

Renvoie
string Hexadecimal value of clock_seq_hi_and_reserved

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getClockSeqHiAndReserved().

◆ getClockSeqLow()

getClockSeqLow ( )

Returns the low field of the clock sequence (bits 73-80 of the UUID).

Renvoie
int Unsigned 8-bit integer value of clock_seq_low

Références Uuid\getClockSeqLowHex().

Référencé par Uuid\getClockSequence(), et Uuid\getFields().

◆ getClockSeqLowHex()

getClockSeqLowHex ( )

Returns the low field of the clock sequence (bits 73-80 of the UUID).

Renvoie
string Hexadecimal value of clock_seq_low

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getClockSeqLow().

◆ getClockSequence()

getClockSequence ( )

Returns the clock sequence value associated with this UUID.

For UUID version 1, the clock sequence is used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.

For UUID version 3 or 5, the clock sequence is a 14-bit value constructed from a name as described in RFC 4122, Section 4.3.

For UUID version 4, clock sequence is a randomly or pseudo-randomly generated 14-bit value as described in RFC 4122, Section 4.4.

Renvoie
int Unsigned 14-bit integer value of clock sequence http://tools.ietf.org/html/rfc4122#section-4.1.5

Références Uuid\getClockSeqHiAndReserved(), et Uuid\getClockSeqLow().

Référencé par Uuid\getClockSequenceHex().

◆ getClockSequenceHex()

getClockSequenceHex ( )

Returns the clock sequence value associated with this UUID.

Renvoie
string Hexadecimal value of clock sequence

Implémente UuidInterface.

Références Uuid\getClockSequence().

◆ getDateTime()

getDateTime ( )

Returns a PHP DateTime object representing the timestamp associated with this UUID.The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
DateTime A PHP DateTime representation of the date
Exceptions
UnsupportedOperationException | If this UUID is not a version 1 UUID
UnsatisfiedDependencyException | if called in a 32-bit system and Moontoast\Math\BigNumber is not present

Implémente UuidInterface.

Références Uuid\getTimestamp(), et Uuid\getVersion().

◆ getFactory()

static getFactory ( )
static

Returns the currently set factory used to create UUIDs.

Renvoie
UuidFactoryInterface

◆ getFields()

getFields ( )

Returns an array of the fields of this UUID, with keys named according to the RFC 4122 names for the fields.

  • time_low: The low field of the timestamp, an unsigned 32-bit integer
  • time_mid: The middle field of the timestamp, an unsigned 16-bit integer
  • time_hi_and_version: The high field of the timestamp multiplexed with the version number, an unsigned 16-bit integer
  • clock_seq_hi_and_reserved: The high field of the clock sequence multiplexed with the variant, an unsigned 8-bit integer
  • clock_seq_low: The low field of the clock sequence, an unsigned 8-bit integer
  • node: The spatially unique node identifier, an unsigned 48-bit integer
Renvoie
array The UUID fields represented as integer values http://tools.ietf.org/html/rfc4122#section-4.1.2

Références Uuid\getClockSeqHiAndReserved(), Uuid\getClockSeqLow(), Uuid\getNode(), Uuid\getTimeHiAndVersion(), Uuid\getTimeLow(), et Uuid\getTimeMid().

◆ getFieldsHex()

getFieldsHex ( )

Returns an array of the fields of this UUID, with keys named according to the RFC 4122 names for the fields.

  • time_low: The low field of the timestamp, an unsigned 32-bit integer
  • time_mid: The middle field of the timestamp, an unsigned 16-bit integer
  • time_hi_and_version: The high field of the timestamp multiplexed with the version number, an unsigned 16-bit integer
  • clock_seq_hi_and_reserved: The high field of the clock sequence multiplexed with the variant, an unsigned 8-bit integer
  • clock_seq_low: The low field of the clock sequence, an unsigned 8-bit integer
  • node: The spatially unique node identifier, an unsigned 48-bit integer
Renvoie
array The UUID fields represented as hexadecimal values

Implémente UuidInterface.

Références Uuid\$fields.

◆ getHex()

getHex ( )

Returns the hexadecimal value of the UUID.

Renvoie
string

Implémente UuidInterface.

Références Uuid\toString().

Référencé par Uuid\getInteger().

◆ getInteger()

getInteger ( )

Returns the integer value of the UUID, converted to an appropriate number representation.

Renvoie
mixed Converted representation of the unsigned 128-bit integer value
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Implémente UuidInterface.

Références Uuid\getHex().

◆ getLeastSignificantBits()

getLeastSignificantBits ( )

Returns the least significant 64 bits of this UUID's 128 bit value.

Renvoie
mixed Converted representation of the unsigned 64-bit integer value
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Références Uuid\getLeastSignificantBitsHex().

◆ getLeastSignificantBitsHex()

getLeastSignificantBitsHex ( )

Returns the least significant 64 bits of this UUID's 128 bit value.

Renvoie
string Hexadecimal value of least significant bits

Implémente UuidInterface.

Références fields.

Référencé par Uuid\compareTo(), et Uuid\getLeastSignificantBits().

◆ getMostSignificantBits()

getMostSignificantBits ( )

Returns the most significant 64 bits of this UUID's 128 bit value.

Renvoie
mixed Converted representation of the unsigned 64-bit integer value
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Références Uuid\getMostSignificantBitsHex().

◆ getMostSignificantBitsHex()

getMostSignificantBitsHex ( )

Returns the most significant 64 bits of this UUID's 128 bit value.

Renvoie
string Hexadecimal value of most significant bits

Implémente UuidInterface.

Références fields.

Référencé par Uuid\compareTo(), et Uuid\getMostSignificantBits().

◆ getNode()

getNode ( )

Returns the node value associated with this UUID

For UUID version 1, the node field consists of an IEEE 802 MAC address, usually the host address. For systems with multiple IEEE 802 addresses, any available one can be used. The lowest addressed octet (octet number 10) contains the global/local bit and the unicast/multicast bit, and is the first octet of the address transmitted on an 802.3 LAN.

For systems with no IEEE address, a randomly or pseudo-randomly generated value may be used; see RFC 4122, Section 4.5. The multicast bit must be set in such addresses, in order that they will never conflict with addresses obtained from network cards.

For UUID version 3 or 5, the node field is a 48-bit value constructed from a name as described in RFC 4122, Section 4.3.

For UUID version 4, the node field is a randomly or pseudo-randomly generated 48-bit value as described in RFC 4122, Section 4.4.

Renvoie
int Unsigned 48-bit integer value of node http://tools.ietf.org/html/rfc4122#section-4.1.6

Références Uuid\getNodeHex().

Référencé par Uuid\getFields().

◆ getNodeHex()

getNodeHex ( )

Returns the node value associated with this UUID

For UUID version 1, the node field consists of an IEEE 802 MAC address, usually the host address. For systems with multiple IEEE 802 addresses, any available one can be used. The lowest addressed octet (octet number 10) contains the global/local bit and the unicast/multicast bit, and is the first octet of the address transmitted on an 802.3 LAN.

For systems with no IEEE address, a randomly or pseudo-randomly generated value may be used; see RFC 4122, Section 4.5. The multicast bit must be set in such addresses, in order that they will never conflict with addresses obtained from network cards.

For UUID version 3 or 5, the node field is a 48-bit value constructed from a name as described in RFC 4122, Section 4.3.

For UUID version 4, the node field is a randomly or pseudo-randomly generated 48-bit value as described in RFC 4122, Section 4.4.

Renvoie
string Hexadecimal value of node http://tools.ietf.org/html/rfc4122#section-4.1.6

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getNode().

◆ getNumberConverter()

getNumberConverter ( )

Returns the number converter to use for converting hex values to/from integers.

Renvoie
NumberConverterInterface

Implémente UuidInterface.

Références Uuid\$converter.

◆ getTimeHiAndVersion()

getTimeHiAndVersion ( )

Returns the high field of the timestamp multiplexed with the version number (bits 49-64 of the UUID).

Renvoie
int Unsigned 16-bit integer value of time_hi_and_version

Références Uuid\getTimeHiAndVersionHex().

Référencé par Uuid\getFields(), Uuid\getTimestampHex(), et Uuid\getVersion().

◆ getTimeHiAndVersionHex()

getTimeHiAndVersionHex ( )

Returns the high field of the timestamp multiplexed with the version number (bits 49-64 of the UUID).

Renvoie
string Hexadecimal value of time_hi_and_version

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getTimeHiAndVersion().

◆ getTimeLow()

getTimeLow ( )

Returns the low field of the timestamp (the first 32 bits of the UUID).

Renvoie
int Unsigned 32-bit integer value of time_low

Références Uuid\getTimeLowHex().

Référencé par Uuid\getFields().

◆ getTimeLowHex()

getTimeLowHex ( )

Returns the low field of the timestamp (the first 32 bits of the UUID).

Renvoie
string Hexadecimal value of time_low

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getTimeLow().

◆ getTimeMid()

getTimeMid ( )

Returns the middle field of the timestamp (bits 33-48 of the UUID).

Renvoie
int Unsigned 16-bit integer value of time_mid

Références Uuid\getTimeMidHex().

Référencé par Uuid\getFields().

◆ getTimeMidHex()

getTimeMidHex ( )

Returns the middle field of the timestamp (bits 33-48 of the UUID).

Renvoie
string Hexadecimal value of time_mid

Implémente UuidInterface.

Références fields.

Référencé par Uuid\getTimeMid().

◆ getTimestamp()

getTimestamp ( )

Returns the timestamp value associated with this UUID.

The 60 bit timestamp value is constructed from the time_low, time_mid, and time_hi fields of this UUID. The resulting timestamp is measured in 100-nanosecond units since midnight, October 15, 1582 UTC.

The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
int Unsigned 60-bit integer value of the timestamp
Exceptions
UnsupportedOperationException If this UUID is not a version 1 UUID http://tools.ietf.org/html/rfc4122#section-4.1.4

Références Uuid\getTimestampHex(), et Uuid\getVersion().

Référencé par Uuid\getDateTime().

◆ getTimestampHex()

getTimestampHex ( )

Returns the timestamp value associated with this UUID.The 60 bit timestamp value is constructed from the time_low, time_mid, and time_hi fields of this UUID. The resulting timestamp is measured in 100-nanosecond units since midnight, October 15, 1582 UTC.The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
string Hexadecimal value of the timestamp
Exceptions
UnsupportedOperationException If this UUID is not a version 1 UUID http://tools.ietf.org/html/rfc4122#section-4.1.4

Implémente UuidInterface.

Références fields, Uuid\getTimeHiAndVersion(), et Uuid\getVersion().

Référencé par DegradedUuid\getDateTime(), et Uuid\getTimestamp().

◆ getUrn()

getUrn ( )

Returns the string representation of the UUID as a URN.

Renvoie
string http://en.wikipedia.org/wiki/Uniform_Resource_Name

Implémente UuidInterface.

Références Uuid\toString().

◆ getVariant()

getVariant ( )

Returns the variant number associated with this UUID.

The variant number describes the layout of the UUID. The variant number has the following meaning:

  • 0 - Reserved for NCS backward compatibility
  • 2 - The RFC 4122 variant (used by this class)
  • 6 - Reserved, Microsoft Corporation backward compatibility
  • 7 - Reserved for future definition
Renvoie
int http://tools.ietf.org/html/rfc4122#section-4.1.1

Implémente UuidInterface.

Références Uuid\getClockSeqHiAndReserved().

Référencé par Uuid\getVersion().

◆ getVersion()

getVersion ( )

Returns the version number associated with this UUID.

The version number describes how this UUID was generated and has the following meaning:

  • 1 - Time-based UUID
  • 2 - DCE security UUID
  • 3 - Name-based UUID hashed with MD5
  • 4 - Randomly generated UUID
  • 5 - Name-based UUID hashed with SHA-1

Returns null if this UUID is not an RFC 4122 variant, since version is only meaningful for this variant.

Renvoie
int|null http://tools.ietf.org/html/rfc4122#section-4.1.3

Implémente UuidInterface.

Références Uuid\getTimeHiAndVersion(), Uuid\getVariant(), et null.

Référencé par DegradedUuid\getDateTime(), Uuid\getDateTime(), DegradedUuid\getTimestamp(), Uuid\getTimestamp(), et Uuid\getTimestampHex().

◆ isValid()

static isValid ( $uuid )
static

Check if a string is a valid UUID.

Paramètres
string $uuid The string UUID to test
Renvoie
boolean

Référencé par StringCodec\extractComponents().

◆ jsonSerialize()

jsonSerialize ( )

Converts this UUID object to a string when the object is serialized with json_encode()

Renvoie
string http://php.net/manual/en/class.jsonserializable.php

Références Uuid\toString().

◆ serialize()

serialize ( )

Converts this UUID object to a string when the object is serialized with serialize()

Renvoie
string http://php.net/manual/en/class.serializable.php

Références Uuid\toString().

◆ setFactory()

static setFactory ( UuidFactoryInterface $factory )
static

Sets the factory used to create UUIDs.

Paramètres
UuidFactoryInterface $factory

Références Uuid\$factory.

◆ toString()

toString ( )

Converts this UUID into a string representation.

Renvoie
string

Implémente UuidInterface.

Références $this.

Référencé par Uuid\__serialize(), Uuid\__toString(), Uuid\getHex(), Uuid\getUrn(), Uuid\jsonSerialize(), et Uuid\serialize().

◆ unserialize()

unserialize ( $serialized )

Re-constructs the object from its serialized form.

Paramètres
string $serialized InvalidUuidStringException

Références fields.

Référencé par Uuid\__unserialize().

◆ uuid1()

static uuid1 | ( | $node = null,
 |  | $clockSeq = null
 | ) |
static

Generate a version 1 UUID from a host ID, sequence number, and the current time.

Paramètres
int | string | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Référencé par Ramsey\Uuid\v1().

◆ uuid3()

static uuid3 | ( | $ns,
 |  | $name
 | ) |
static

Generate a version 3 UUID based on the MD5 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Références $name.

Référencé par Ramsey\Uuid\v3().

◆ uuid4()

static uuid4 ( )
static

Generate a version 4 (random) UUID.

Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception

Référencé par Ramsey\Uuid\v4().

◆ uuid5()

static uuid5 | ( | $ns,
 |  | $name
 | ) |
static

Generate a version 5 UUID based on the SHA-1 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Références $name.

Référencé par Ramsey\Uuid\v5().

Documentation des champs

◆ $codec

$codec
protected

Référencé par Uuid\__construct().

◆ $converter

$converter
protected

Référencé par Uuid\__construct(), et Uuid\getNumberConverter().

◆ $factory

$factory = null
staticprivate

Référencé par Uuid\setFactory().

◆ $fields

$fields
protected
Valeur initiale :
= [
'time_low' => '00000000'

Référencé par Uuid\__construct(), et Uuid\getFieldsHex().

◆ NAMESPACE_DNS

const NAMESPACE_DNS = '6ba7b810-9dad-11d1-80b4-00c04fd430c8'

When this namespace is specified, the name string is a fully-qualified domain name. http://tools.ietf.org/html/rfc4122#appendix-C

◆ NAMESPACE_OID

const NAMESPACE_OID = '6ba7b812-9dad-11d1-80b4-00c04fd430c8'

When this namespace is specified, the name string is an ISO OID. http://tools.ietf.org/html/rfc4122#appendix-C

◆ NAMESPACE_URL

const NAMESPACE_URL = '6ba7b811-9dad-11d1-80b4-00c04fd430c8'

When this namespace is specified, the name string is a URL. http://tools.ietf.org/html/rfc4122#appendix-C

◆ NAMESPACE_X500

const NAMESPACE_X500 = '6ba7b814-9dad-11d1-80b4-00c04fd430c8'

When this namespace is specified, the name string is an X.500 DN in DER or a text output format. http://tools.ietf.org/html/rfc4122#appendix-C

◆ NIL

const NIL = '00000000-0000-0000-0000-000000000000'

The nil UUID is special form of UUID that is specified to have all 128 bits set to zero. http://tools.ietf.org/html/rfc4122#section-4.1.7

◆ RESERVED_FUTURE

const RESERVED_FUTURE = 7

Reserved for future definition. http://tools.ietf.org/html/rfc4122#section-4.1.1

◆ RESERVED_MICROSOFT

const RESERVED_MICROSOFT = 6

Reserved for Microsoft compatibility. http://tools.ietf.org/html/rfc4122#section-4.1.1

◆ RESERVED_NCS

const RESERVED_NCS = 0

Reserved for NCS compatibility. http://tools.ietf.org/html/rfc4122#section-4.1.1

◆ RFC_4122

const RFC_4122 = 2

Specifies the UUID layout given in RFC 4122. http://tools.ietf.org/html/rfc4122#section-4.1.1

◆ UUID_TYPE_HASH_MD5

const UUID_TYPE_HASH_MD5 = 3

Version 3 (name-based and hashed with MD5) UUID object constant identifier

◆ UUID_TYPE_HASH_SHA1

const UUID_TYPE_HASH_SHA1 = 5

Version 5 (name-based and hashed with SHA1) UUID object constant identifier

◆ UUID_TYPE_IDENTIFIER

const UUID_TYPE_IDENTIFIER = 2

Version 2 (identifier-based) UUID object constant identifier

◆ UUID_TYPE_RANDOM

const UUID_TYPE_RANDOM = 4

Version 4 (random) UUID object constant identifier

◆ UUID_TYPE_TIME

const UUID_TYPE_TIME = 1

Version 1 (time-based) UUID object constant identifier

◆ VALID_PATTERN

const VALID_PATTERN = '^[0-9A-Fa-f]{8}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{4}-[0-9A-Fa-f]{12}$'

Regular expression pattern for matching a valid UUID of any variant.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Uuid.php


Joomla CMS: Référence de la classe UuidFactory

  • Ramsey
  • Uuid
  • UuidFactory
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe UuidFactory
+ Graphe d'héritage de UuidFactory:
UuidFactoryInterface

Fonctions membres publiques

__construct (FeatureSet $features=null)
getCodec ()
setCodec (CodecInterface $codec)
getNodeProvider ()
getRandomGenerator ()
getTimeGenerator ()
setTimeGenerator (TimeGeneratorInterface $generator)
getNumberConverter ()
setRandomGenerator (RandomGeneratorInterface $generator)
setNumberConverter (NumberConverterInterface $converter)
getUuidBuilder ()
setUuidBuilder (UuidBuilderInterface $builder)
fromBytes ($bytes)
fromString ($uuid)
fromInteger ($integer)
uuid1 ($node=null, $clockSeq=null)
uuid3 ($ns, $name)
uuid4 ()
uuid5 ($ns, $name)
uuid (array $fields)

Fonctions membres protégées

uuidFromNsAndName ($ns, $name, $version, $hashFunction)
uuidFromHashedName ($hash, $version)

Attributs privés

$codec = null
$nodeProvider = null
$numberConverter = null
$randomGenerator = null
$timeGenerator = null
$uuidBuilder = null

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( FeatureSet $features = null )

Constructs a UuidFactory for creating Ramsey\Uuid\UuidInterface instances

Paramètres
FeatureSet $features A set of features for use when creating UUIDs

Documentation des fonctions membres

◆ fromBytes()

fromBytes ( $bytes )

Creates a UUID from a byte string.

Paramètres
string $bytes A 16-byte string representation of a UUID
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException
InvalidArgumentException if string has not 16 characters

Implémente UuidFactoryInterface.

◆ fromInteger()

fromInteger ( $integer )

Creates a Uuid from an integer representationThe integer representation may be a real integer, a string integer, or an integer representation supported by a configured number converter.

Paramètres
mixed $integer The integer to use when creating a Uuid from an integer; may be of any type understood by the configured number converter
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidUuidStringException

Implémente UuidFactoryInterface.

Références UuidFactory\fromString().

◆ fromString()

fromString ( $uuid )

Creates a UUID from the string standard representation

Paramètres
string $uuid A string representation of a UUID
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente UuidFactoryInterface.

Référencé par UuidFactory\fromInteger().

◆ getCodec()

getCodec ( )

Returns the UUID coder-decoder used by this factory

Renvoie
CodecInterface

Références UuidFactory\$codec.

◆ getNodeProvider()

getNodeProvider ( )

Returns the system node ID provider used by this factory

Renvoie
NodeProviderInterface

Références UuidFactory\$nodeProvider.

◆ getNumberConverter()

getNumberConverter ( )

Returns the number converter used by this factory

Renvoie
NumberConverterInterface

Références UuidFactory\$numberConverter.

◆ getRandomGenerator()

getRandomGenerator ( )

Returns the random UUID generator used by this factory

Renvoie
RandomGeneratorInterface

Références UuidFactory\$randomGenerator.

◆ getTimeGenerator()

getTimeGenerator ( )

Returns the time-based UUID generator used by this factory

Renvoie
TimeGeneratorInterface

Références UuidFactory\$timeGenerator.

◆ getUuidBuilder()

getUuidBuilder ( )

Returns the UUID builder this factory uses when creating Uuid instances

Renvoie
UuidBuilderInterface $builder

Références UuidFactory\$uuidBuilder.

◆ setCodec()

setCodec ( CodecInterface $codec )

Sets the UUID coder-decoder used by this factory

Paramètres
CodecInterface $codec

Références UuidFactory\$codec.

◆ setNumberConverter()

setNumberConverter ( NumberConverterInterface $converter )

Sets the number converter this factory will use

Paramètres
NumberConverterInterface $converter

◆ setRandomGenerator()

setRandomGenerator ( RandomGeneratorInterface $generator )

Sets the random UUID generator this factory will use to generate version 4 UUIDs

Paramètres
RandomGeneratorInterface $generator

◆ setTimeGenerator()

setTimeGenerator ( TimeGeneratorInterface $generator )

Sets the time-based UUID generator this factory will use to generate version 1 UUIDs

Paramètres
TimeGeneratorInterface $generator

◆ setUuidBuilder()

setUuidBuilder ( UuidBuilderInterface $builder )

Sets the UUID builder this factory will use when creating Uuid instances

Paramètres
UuidBuilderInterface $builder

◆ uuid()

uuid ( array $fields )

Returns a Uuid

Uses the configured builder and codec and the provided array of hexadecimal value UUID fields to construct a Uuid object.

Paramètres
array $fields An array of fields from which to construct a UUID; see {
Voir également
::getFieldsHex()} for array structure.
Renvoie
UuidInterface

Références $fields.

Référencé par UuidFactory\uuidFromHashedName().

◆ uuid1()

uuid1 | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID from a host ID, sequence number, and the current time.

Paramètres
int | string | null | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | null | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Implémente UuidFactoryInterface.

Références UuidFactory\uuidFromHashedName().

◆ uuid3()

uuid3 | ( | $ns,
 |  | $name
 | ) |

Generate a version 3 UUID based on the MD5 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente UuidFactoryInterface.

Références $name, et UuidFactory\uuidFromNsAndName().

◆ uuid4()

uuid4 ( )

Generate a version 4 (random) UUID.

Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception

Implémente UuidFactoryInterface.

Références UuidFactory\uuidFromHashedName().

◆ uuid5()

uuid5 | ( | $ns,
 |  | $name
 | ) |

Generate a version 5 UUID based on the SHA-1 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémente UuidFactoryInterface.

Références $name, et UuidFactory\uuidFromNsAndName().

◆ uuidFromHashedName()

uuidFromHashedName | ( | $hash,
 |  | $version
 | ) |
protected

Returns a Uuid created from $hash with the version field set to $version and the variant field set for RFC 4122

Paramètres
string | $hash | The hash to use when creating the UUID
int | $version | The UUID version to set for this hash (1, 3, 4, or 5)
Renvoie
UuidInterface

Références $fields, $hash, $version, BinaryUtils\applyVariant(), BinaryUtils\applyVersion(), et UuidFactory\uuid().

Référencé par UuidFactory\uuid1(), UuidFactory\uuid4(), et UuidFactory\uuidFromNsAndName().

◆ uuidFromNsAndName()

uuidFromNsAndName | ( | $ns,
 |  | $name,
 |  | $version,
 |  | $hashFunction
 | ) |
protected

Returns a version 3 or 5 namespaced Uuid

Paramètres
string | UuidInterface | $ns | The UUID namespace to use
string | $name | The string to hash together with the namespace
int | $version | The version of UUID to create (3 or 5)
string | $hashFunction | The hash function to use when hashing together the namespace and name
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Références $hash, $name, $version, et UuidFactory\uuidFromHashedName().

Référencé par UuidFactory\uuid3(), et UuidFactory\uuid5().

Documentation des champs

◆ $codec

$codec = null
private

Référencé par UuidFactory\getCodec(), et UuidFactory\setCodec().

◆ $nodeProvider

$nodeProvider = null
private

Référencé par UuidFactory\getNodeProvider().

◆ $numberConverter

$numberConverter = null
private

Référencé par UuidFactory\getNumberConverter().

◆ $randomGenerator

$randomGenerator = null
private

Référencé par UuidFactory\getRandomGenerator().

◆ $timeGenerator

$timeGenerator = null
private

Référencé par UuidFactory\getTimeGenerator().

◆ $uuidBuilder

$uuidBuilder = null
private

Référencé par UuidFactory\getUuidBuilder().

La documentation de cette classe a été générée à partir du fichier suivant :
  • UuidFactory.php


Joomla CMS: Référence de l'interface UuidFactoryInterface

  • Ramsey
  • Uuid
  • UuidFactoryInterface
Fonctions membres publiques
Référence de l'interface UuidFactoryInterface
+ Graphe d'héritage de UuidFactoryInterface:
UuidFactory

Fonctions membres publiques

uuid1 ($node=null, $clockSeq=null)
uuid3 ($ns, $name)
uuid4 ()
uuid5 ($ns, $name)
fromBytes ($bytes)
fromString ($uuid)
fromInteger ($integer)

Description détaillée

UuidFactoryInterface defines common functionality all UuidFactory instances must implement

Documentation des fonctions membres

◆ fromBytes()

fromBytes ( $bytes )

Creates a UUID from a byte string.

Paramètres
string $bytes A 16-byte string representation of a UUID
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException
InvalidArgumentException if string has not 16 characters

Implémenté dans UuidFactory.

◆ fromInteger()

fromInteger ( $integer )

Creates a Uuid from an integer representation

The integer representation may be a real integer, a string integer, or an integer representation supported by a configured number converter.

Paramètres
mixed $integer The integer to use when creating a Uuid from an integer; may be of any type understood by the configured number converter
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidUuidStringException

Implémenté dans UuidFactory.

◆ fromString()

fromString ( $uuid )

Creates a UUID from the string standard representation

Paramètres
string $uuid A string representation of a UUID
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémenté dans UuidFactory.

◆ uuid1()

uuid1 | ( | $node = null,
 |  | $clockSeq = null
 | ) |

Generate a version 1 UUID from a host ID, sequence number, and the current time.

Paramètres
int | string | null | $node | A 48-bit number representing the hardware address This number may be represented as an integer or a hexadecimal string.
int | null | $clockSeq | A 14-bit number used to help avoid duplicates that could arise when the clock is set backwards in time or if the node ID changes.
Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException | if called on a 32-bit system and Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception | if it was not possible to gather sufficient entropy

Implémenté dans UuidFactory.

◆ uuid3()

uuid3 | ( | $ns,
 |  | $name
 | ) |

Generate a version 3 UUID based on the MD5 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémenté dans UuidFactory.

◆ uuid4()

uuid4 ( )

Generate a version 4 (random) UUID.

Renvoie
UuidInterface
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present
InvalidArgumentException
Exception

Implémenté dans UuidFactory.

◆ uuid5()

uuid5 | ( | $ns,
 |  | $name
 | ) |

Generate a version 5 UUID based on the SHA-1 hash of a namespace identifier (which is a UUID) and a name (which is a string).

Paramètres
string | UuidInterface | $ns | The UUID namespace in which to create the named UUID
string | $name | The name to create a UUID for
Renvoie
UuidInterface
Exceptions
InvalidUuidStringException

Implémenté dans UuidFactory.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UuidFactoryInterface.php


Joomla CMS: Référence de l'interface UuidInterface

  • Ramsey
  • Uuid
  • UuidInterface
Fonctions membres publiques
Référence de l'interface UuidInterface
+ Graphe d'héritage de UuidInterface:
Uuid DegradedUuid

Fonctions membres publiques

compareTo (UuidInterface $other)
equals ($other)
getBytes ()
getNumberConverter ()
getHex ()
getFieldsHex ()
getClockSeqHiAndReservedHex ()
getClockSeqLowHex ()
getClockSequenceHex ()
getDateTime ()
getInteger ()
getLeastSignificantBitsHex ()
getMostSignificantBitsHex ()
getNodeHex ()
getTimeHiAndVersionHex ()
getTimeLowHex ()
getTimeMidHex ()
getTimestampHex ()
getUrn ()
getVariant ()
getVersion ()
toString ()

Description détaillée

UuidInterface defines common functionality for all universally unique identifiers (UUIDs)

Documentation des fonctions membres

◆ compareTo()

compareTo ( UuidInterface $other )

Compares this UUID to the specified UUID.

The first of two UUIDs is greater than the second if the most significant field in which the UUIDs differ is greater for the first UUID.

  • Q. What's the value of being able to sort UUIDs?
  • A. Use them as keys in a B-Tree or similar mapping.
Paramètres
UuidInterface $other UUID to which this UUID is compared
Renvoie
int -1, 0 or 1 as this UUID is less than, equal to, or greater than $uuid

Implémenté dans Uuid.

◆ equals()

equals ( $other )

Compares this object to the specified object.

The result is true if and only if the argument is not null, is a UUID object, has the same variant, and contains the same value, bit for bit, as this UUID.

Paramètres
object $other
Renvoie
bool True if $other is equal to this UUID

Implémenté dans Uuid.

◆ getBytes()

getBytes ( )

Returns the UUID as a 16-byte string (containing the six integer fields in big-endian byte order).

Renvoie
string

Implémenté dans Uuid.

◆ getClockSeqHiAndReservedHex()

getClockSeqHiAndReservedHex ( )

Returns the high field of the clock sequence multiplexed with the variant (bits 65-72 of the UUID).

Renvoie
string Hexadecimal value of clock_seq_hi_and_reserved

Implémenté dans Uuid.

◆ getClockSeqLowHex()

getClockSeqLowHex ( )

Returns the low field of the clock sequence (bits 73-80 of the UUID).

Renvoie
string Hexadecimal value of clock_seq_low

Implémenté dans Uuid.

◆ getClockSequenceHex()

getClockSequenceHex ( )

Returns the clock sequence value associated with this UUID.

Renvoie
string Hexadecimal value of clock sequence

Implémenté dans Uuid.

◆ getDateTime()

getDateTime ( )

Returns a PHP DateTime object representing the timestamp associated with this UUID.

The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
DateTime A PHP DateTime representation of the date
Exceptions
UnsupportedOperationException | If this UUID is not a version 1 UUID
UnsatisfiedDependencyException | if called in a 32-bit system and Moontoast\Math\BigNumber is not present

Implémenté dans Uuid, et DegradedUuid.

◆ getFieldsHex()

getFieldsHex ( )

Returns an array of the fields of this UUID, with keys named according to the RFC 4122 names for the fields.

  • time_low: The low field of the timestamp, an unsigned 32-bit integer
  • time_mid: The middle field of the timestamp, an unsigned 16-bit integer
  • time_hi_and_version: The high field of the timestamp multiplexed with the version number, an unsigned 16-bit integer
  • clock_seq_hi_and_reserved: The high field of the clock sequence multiplexed with the variant, an unsigned 8-bit integer
  • clock_seq_low: The low field of the clock sequence, an unsigned 8-bit integer
  • node: The spatially unique node identifier, an unsigned 48-bit integer
Renvoie
array The UUID fields represented as hexadecimal values

Implémenté dans Uuid.

Référencé par TimestampFirstCombCodec\encode(), GuidStringCodec\encode(), StringCodec\encode(), OrderedTimeCodec\encodeBinary(), et GuidStringCodec\encodeBinary().

◆ getHex()

getHex ( )

Returns the hexadecimal value of the UUID.

Renvoie
string

Implémenté dans Uuid.

Référencé par StringCodec\encodeBinary().

◆ getInteger()

getInteger ( )

Returns the integer value of the UUID, converted to an appropriate number representation.

Renvoie
mixed Converted representation of the unsigned 128-bit integer value
Exceptions
UnsatisfiedDependencyException if Moontoast\Math\BigNumber is not present

Implémenté dans Uuid.

◆ getLeastSignificantBitsHex()

getLeastSignificantBitsHex ( )

Returns the least significant 64 bits of this UUID's 128 bit value.

Renvoie
string Hexadecimal value of least significant bits

Implémenté dans Uuid.

Référencé par Uuid\compareTo().

◆ getMostSignificantBitsHex()

getMostSignificantBitsHex ( )

Returns the most significant 64 bits of this UUID's 128 bit value.

Renvoie
string Hexadecimal value of most significant bits

Implémenté dans Uuid.

Référencé par Uuid\compareTo().

◆ getNodeHex()

getNodeHex ( )

Returns the node value associated with this UUID

For UUID version 1, the node field consists of an IEEE 802 MAC address, usually the host address. For systems with multiple IEEE 802 addresses, any available one can be used. The lowest addressed octet (octet number 10) contains the global/local bit and the unicast/multicast bit, and is the first octet of the address transmitted on an 802.3 LAN.

For systems with no IEEE address, a randomly or pseudo-randomly generated value may be used; see RFC 4122, Section 4.5. The multicast bit must be set in such addresses, in order that they will never conflict with addresses obtained from network cards.

For UUID version 3 or 5, the node field is a 48-bit value constructed from a name as described in RFC 4122, Section 4.3.

For UUID version 4, the node field is a randomly or pseudo-randomly generated 48-bit value as described in RFC 4122, Section 4.4.

Renvoie
string Hexadecimal value of node http://tools.ietf.org/html/rfc4122#section-4.1.6

Implémenté dans Uuid.

◆ getNumberConverter()

getNumberConverter ( )

Returns the number converter to use for converting hex values to/from integers.

Renvoie
NumberConverterInterface

Implémenté dans Uuid.

◆ getTimeHiAndVersionHex()

getTimeHiAndVersionHex ( )

Returns the high field of the timestamp multiplexed with the version number (bits 49-64 of the UUID).

Renvoie
string Hexadecimal value of time_hi_and_version

Implémenté dans Uuid.

◆ getTimeLowHex()

getTimeLowHex ( )

Returns the low field of the timestamp (the first 32 bits of the UUID).

Renvoie
string Hexadecimal value of time_low

Implémenté dans Uuid.

◆ getTimeMidHex()

getTimeMidHex ( )

Returns the middle field of the timestamp (bits 33-48 of the UUID).

Renvoie
string Hexadecimal value of time_mid

Implémenté dans Uuid.

◆ getTimestampHex()

getTimestampHex ( )

Returns the timestamp value associated with this UUID.

The 60 bit timestamp value is constructed from the time_low, time_mid, and time_hi fields of this UUID. The resulting timestamp is measured in 100-nanosecond units since midnight, October 15, 1582 UTC.

The timestamp value is only meaningful in a time-based UUID, which has version type 1. If this UUID is not a time-based UUID then this method throws UnsupportedOperationException.

Renvoie
string Hexadecimal value of the timestamp
Exceptions
UnsupportedOperationException If this UUID is not a version 1 UUID http://tools.ietf.org/html/rfc4122#section-4.1.4

Implémenté dans Uuid.

◆ getUrn()

getUrn ( )

Returns the string representation of the UUID as a URN.

Renvoie
string http://en.wikipedia.org/wiki/Uniform_Resource_Name

Implémenté dans Uuid.

◆ getVariant()

getVariant ( )

Returns the variant number associated with this UUID.

The variant number describes the layout of the UUID. The variant number has the following meaning:

  • 0 - Reserved for NCS backward compatibility
  • 2 - The RFC 4122 variant (used by this class)
  • 6 - Reserved, Microsoft Corporation backward compatibility
  • 7 - Reserved for future definition
Renvoie
int http://tools.ietf.org/html/rfc4122#section-4.1.1

Implémenté dans Uuid.

◆ getVersion()

getVersion ( )

Returns the version number associated with this UUID.

The version number describes how this UUID was generated and has the following meaning:

  • 1 - Time-based UUID
  • 2 - DCE security UUID
  • 3 - Name-based UUID hashed with MD5
  • 4 - Randomly generated UUID
  • 5 - Name-based UUID hashed with SHA-1

Returns null if this UUID is not an RFC 4122 variant, since version is only meaningful for this variant.

Renvoie
int|null http://tools.ietf.org/html/rfc4122#section-4.1.3

Implémenté dans Uuid.

◆ toString()

toString ( )

Converts this UUID into a string representation.

Renvoie
string

Implémenté dans Uuid.

La documentation de cette interface a été générée à partir du fichier suivant :
  • UuidInterface.php


Joomla CMS: Référence de la classe Curl

  • ReCaptcha
  • RequestMethod
  • Curl
Fonctions membres publiques
Référence de la classe Curl

Fonctions membres publiques

init ($url=null)
setoptArray ($ch, array $options)
exec ($ch)
close ($ch)

Description détaillée

Convenience wrapper around the cURL functions to allow mocking.

Documentation des fonctions membres

◆ close()

close ( $ch )
Voir également
http://php.net/curl_close
Paramètres
resource $ch

◆ exec()

exec ( $ch )
Voir également
http://php.net/curl_exec
Paramètres
resource $ch
Renvoie
mixed

◆ init()

init ( $url = null )
Voir également
http://php.net/curl_init
Paramètres
string $url
Renvoie
resource cURL handle

Références $url.

◆ setoptArray()

setoptArray | ( |  | $ch,
 |  | array | $options
 | ) |  |
Voir également
http://php.net/curl_setopt_array
Paramètres
resource | $ch
array | $options
Renvoie
bool

Références $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • google/recaptcha/src/ReCaptcha/RequestMethod/Curl.php


Joomla CMS: Référence de la classe CurlPost

  • ReCaptcha
  • RequestMethod
  • CurlPost
Fonctions membres publiques | Attributs privés
Référence de la classe CurlPost
+ Graphe d'héritage de CurlPost:
RequestMethod

Fonctions membres publiques

__construct (Curl $curl=null, $siteVerifyUrl=null)
submit (RequestParameters $params)

Attributs privés

$curl
$siteVerifyUrl

Description détaillée

Sends cURL request to the reCAPTCHA service. Note: this requires the cURL extension to be enabled in PHP

Voir également
http://php.net/manual/en/book.curl.php

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Curl | $curl = null,
 |  |  | $siteVerifyUrl = null
 | ) |  |

Only needed if you want to override the defaults

Paramètres
Curl | $curl | Curl resource
string | $siteVerifyUrl | URL for reCAPTCHA siteverify API

Références CurlPost\$curl, CurlPost\$siteVerifyUrl, et ReCaptcha\SITE_VERIFY_URL.

Documentation des fonctions membres

◆ submit()

submit ( RequestParameters $params )

Submit the cURL request with the specified parameters.

Paramètres
RequestParameters $params Request parameters
Renvoie
string Body of the reCAPTCHA response

Implémente RequestMethod.

Références $options, $params, et true.

Documentation des champs

◆ $curl

$curl
private

Référencé par CurlPost\__construct().

◆ $siteVerifyUrl

$siteVerifyUrl
private

Référencé par CurlPost\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CurlPost.php


Joomla CMS: Référence de la classe Post

  • ReCaptcha
  • RequestMethod
  • Post
Fonctions membres publiques | Attributs privés
Référence de la classe Post
+ Graphe d'héritage de Post:
RequestMethod

Fonctions membres publiques

__construct ($siteVerifyUrl=null)
submit (RequestParameters $params)

Attributs privés

$siteVerifyUrl

Description détaillée

Sends POST requests to the reCAPTCHA service.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $siteVerifyUrl = null )

Only needed if you want to override the defaults

Paramètres
string $siteVerifyUrl URL for reCAPTCHA siteverify API

Références Post\$siteVerifyUrl, et ReCaptcha\SITE_VERIFY_URL.

Documentation des fonctions membres

◆ submit()

submit ( RequestParameters $params )

Submit the POST request with the specified parameters.

Paramètres
RequestParameters $params Request parameters
Renvoie
string Body of the reCAPTCHA response

Implémente RequestMethod.

Références $context, $options, et $params.

Documentation des champs

◆ $siteVerifyUrl

$siteVerifyUrl
private

Référencé par Post\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Post.php


Joomla CMS: Référence de la classe Socket

  • ReCaptcha
  • RequestMethod
  • Socket
Fonctions membres publiques | Attributs privés
Référence de la classe Socket

Fonctions membres publiques

fsockopen ($hostname, $port=-1, &$errno=0, &$errstr='', $timeout=null)
fwrite ($string, $length=null)
fgets ($length=null)
feof ()
fclose ()

Attributs privés

$handle = null

Description détaillée

Convenience wrapper around native socket and file functions to allow for mocking.

Documentation des fonctions membres

◆ fclose()

fclose ( )

fclose

Voir également
http://php.net/fclose
Renvoie
bool

◆ feof()

feof ( )

feof

Voir également
http://php.net/feof
Renvoie
bool

◆ fgets()

fgets ( $length = null )

fgets

Voir également
http://php.net/fgets
Paramètres
int $length
Renvoie
string

◆ fsockopen()

fsockopen | ( |  | $hostname,
 |  |  | $port = -1,
 |  | & | $errno = 0,
 |  | & | $errstr = '',
 |  |  | $timeout = null
 | ) |  |

fsockopen

Voir également
http://php.net/fsockopen
Paramètres
string | $hostname
int | $port
int | $errno
string | $errstr
float | $timeout
Renvoie
resource

Références Socket\$handle.

◆ fwrite()

fwrite | ( | $string,
 |  | $length = null
 | ) |

fwrite

Voir également
http://php.net/fwrite
Paramètres
string | $string
int | $length
Renvoie
int | bool

Documentation des champs

◆ $handle

$handle = null
private

Référencé par Socket\fsockopen().

La documentation de cette classe a été générée à partir du fichier suivant :
  • google/recaptcha/src/ReCaptcha/RequestMethod/Socket.php


Joomla CMS: Référence de la classe SocketPost

  • ReCaptcha
  • RequestMethod
  • SocketPost
Fonctions membres publiques | Attributs privés
Référence de la classe SocketPost
+ Graphe d'héritage de SocketPost:
RequestMethod

Fonctions membres publiques

__construct (Socket $socket=null, $siteVerifyUrl=null)
submit (RequestParameters $params)

Attributs privés

$socket

Description détaillée

Sends a POST request to the reCAPTCHA service, but makes use of fsockopen() instead of get_file_contents(). This is to account for people who may be on servers where allow_url_open is disabled.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Socket | $socket = null,
 |  |  | $siteVerifyUrl = null
 | ) |  |

Only needed if you want to override the defaults

Paramètres
\ReCaptcha\RequestMethod\Socket | $socket | optional socket, injectable for testing
string | $siteVerifyUrl | URL for reCAPTCHA siteverify API

Références SocketPost\$socket, et ReCaptcha\SITE_VERIFY_URL.

Documentation des fonctions membres

◆ submit()

submit ( RequestParameters $params )

Submit the POST request with the specified parameters.

Paramètres
RequestParameters $params Request parameters
Renvoie
string Body of the reCAPTCHA response

Implémente RequestMethod.

Références $content, $params, et $parts.

Documentation des champs

◆ $socket

$socket
private

Référencé par SocketPost\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SocketPost.php


Joomla CMS: Référence de la classe ReCaptcha

  • ReCaptcha
  • ReCaptcha
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe ReCaptcha

Fonctions membres publiques

__construct ($secret, RequestMethod $requestMethod=null)
verify ($response, $remoteIp=null)
setExpectedHostname ($hostname)
setExpectedApkPackageName ($apkPackageName)
setExpectedAction ($action)
setScoreThreshold ($threshold)
setChallengeTimeout ($timeoutSeconds)

Champs de données

const | VERSION = 'php_1.2.4'
const | SITE_VERIFY_URL = 'https://www.google.com/recaptcha/api/siteverify'
const | E_INVALID_JSON = 'invalid-json'
const | E_CONNECTION_FAILED = 'connection-failed'
const | E_BAD_RESPONSE = 'bad-response'
const | E_UNKNOWN_ERROR = 'unknown-error'
const | E_MISSING_INPUT_RESPONSE = 'missing-input-response'
const | E_HOSTNAME_MISMATCH = 'hostname-mismatch'
const | E_APK_PACKAGE_NAME_MISMATCH = 'apk_package_name-mismatch'
const | E_ACTION_MISMATCH = 'action-mismatch'
const | E_SCORE_THRESHOLD_NOT_MET = 'score-threshold-not-met'
const | E_CHALLENGE_TIMEOUT = 'challenge-timeout'

Attributs privés

$secret
$requestMethod

Description détaillée

reCAPTCHA client.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $secret,
 |  | RequestMethod | $requestMethod = null
 | ) |  |

Create a configured instance to use the reCAPTCHA service.

Paramètres
string | $secret | The shared key between your site and reCAPTCHA.
RequestMethod | $requestMethod | method used to send the request. Defaults to POST.
Exceptions

Documentation des fonctions membres

◆ setChallengeTimeout()

setChallengeTimeout ( $timeoutSeconds )

Provide a timeout in seconds to test against the challenge timestamp in verify()

Paramètres
int $timeoutSeconds Expected hostname
Renvoie
ReCaptcha Current instance for fluent interface

Références $this.

◆ setExpectedAction()

setExpectedAction ( $action )

Provide an action to match against in verify() This should be set per page.

Paramètres
string $action Expected action
Renvoie
ReCaptcha Current instance for fluent interface

Références $this.

◆ setExpectedApkPackageName()

setExpectedApkPackageName ( $apkPackageName )

Provide an APK package name to match against in verify()

Paramètres
string $apkPackageName Expected APK package name
Renvoie
ReCaptcha Current instance for fluent interface

Références $this.

◆ setExpectedHostname()

setExpectedHostname ( $hostname )

Provide a hostname to match against in verify() This should be without a protocol or trailing slash, e.g. www.google.com

Paramètres
string $hostname Expected hostname
Renvoie
ReCaptcha Current instance for fluent interface

Références $this.

◆ setScoreThreshold()

setScoreThreshold ( $threshold )

Provide a threshold to meet or exceed in verify() Threshold should be a float between 0 and 1 which will be tested as response >= threshold.

Paramètres
float $threshold Expected threshold
Renvoie
ReCaptcha Current instance for fluent interface

Références $this.

◆ verify()

verify | ( | $response,
 |  | $remoteIp = null
 | ) |

Calls the reCAPTCHA siteverify API to verify whether the user passes CAPTCHA test and additionally runs any specified additional checks

Paramètres
string | $response | The user response token provided by reCAPTCHA, verifying the user on your site.
string | $remoteIp | The end user's IP address.
Renvoie
Response Response from the service.

Références $params, et Response\fromJson().

Documentation des champs

◆ $requestMethod

$requestMethod
private

◆ $secret

$secret
private

◆ E_ACTION_MISMATCH

const E_ACTION_MISMATCH = 'action-mismatch'

Expected action did not match string

◆ E_APK_PACKAGE_NAME_MISMATCH

const E_APK_PACKAGE_NAME_MISMATCH = 'apk_package_name-mismatch'

Expected APK package name did not match string

◆ E_BAD_RESPONSE

const E_BAD_RESPONSE = 'bad-response'

Did not receive a 200 from the service string

◆ E_CHALLENGE_TIMEOUT

const E_CHALLENGE_TIMEOUT = 'challenge-timeout'

Challenge timeout string

◆ E_CONNECTION_FAILED

const E_CONNECTION_FAILED = 'connection-failed'

Could not connect to service string

◆ E_HOSTNAME_MISMATCH

const E_HOSTNAME_MISMATCH = 'hostname-mismatch'

Expected hostname did not match string

◆ E_INVALID_JSON

const E_INVALID_JSON = 'invalid-json'

Invalid JSON received string

◆ E_MISSING_INPUT_RESPONSE

const E_MISSING_INPUT_RESPONSE = 'missing-input-response'

ReCAPTCHA response not provided string

◆ E_SCORE_THRESHOLD_NOT_MET

const E_SCORE_THRESHOLD_NOT_MET = 'score-threshold-not-met'

Score threshold not met string

◆ E_UNKNOWN_ERROR

const E_UNKNOWN_ERROR = 'unknown-error'

Not a success, but no error codes received! string

◆ SITE_VERIFY_URL

const SITE_VERIFY_URL = 'https://www.google.com/recaptcha/api/siteverify'

URL for reCAPTCHA siteverify API string

Référencé par Post\__construct(), SocketPost\__construct(), et CurlPost\__construct().

◆ VERSION

const VERSION = 'php_1.2.4'

Version of this client library. string

La documentation de cette classe a été générée à partir du fichier suivant :
  • ReCaptcha.php


Joomla CMS: Référence de l'interface RequestMethod

  • ReCaptcha
  • RequestMethod
Fonctions membres publiques
Référence de l'interface RequestMethod
+ Graphe d'héritage de RequestMethod:
HttpBridgePostRequestMethod CurlPost Post SocketPost

Fonctions membres publiques

submit (RequestParameters $params)

Description détaillée

Method used to send the request to the service.

Documentation des fonctions membres

◆ submit()

submit ( RequestParameters $params )

Submit the request with the specified parameters.

Paramètres
RequestParameters $params Request parameters
Renvoie
string Body of the reCAPTCHA response

Implémenté dans CurlPost, SocketPost, Post, et HttpBridgePostRequestMethod.

La documentation de cette interface a été générée à partir du fichier suivant :
  • RequestMethod.php


Joomla CMS: Référence de la classe RequestParameters

  • ReCaptcha
  • RequestParameters
Fonctions membres publiques | Attributs privés
Référence de la classe RequestParameters

Fonctions membres publiques

__construct ($secret, $response, $remoteIp=null, $version=null)
toArray ()
toQueryString ()

Attributs privés

$secret
$response
$remoteIp
$version

Description détaillée

Stores and formats the parameters for the request to the reCAPTCHA service.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $secret,
 |  | $response,
 |  | $remoteIp = null,
 |  | $version = null
 | ) |

Initialise parameters.

Paramètres
string | $secret | Site secret.
string | $response | Value from g-captcha-response form field.
string | $remoteIp | User's IP address.
string | $version | Version of this client library.

Références $version.

Documentation des fonctions membres

◆ toArray()

toArray ( )

Array representation.

Renvoie
array Array formatted parameters.

Références $params, et $version.

◆ toQueryString()

toQueryString ( )

Query string representation for HTTP request.

Renvoie
string Query string formatted parameters.

Documentation des champs

◆ $remoteIp

$remoteIp
private

◆ $response

$response
private

◆ $secret

$secret
private

◆ $version

$version
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestParameters.php


Joomla CMS: Référence de la classe Response

  • ReCaptcha
  • Response
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Response

Fonctions membres publiques

__construct ($success, array $errorCodes=array(), $hostname=null, $challengeTs=null, $apkPackageName=null, $score=null, $action=null)
isSuccess ()
getErrorCodes ()
getHostname ()
getChallengeTs ()
getApkPackageName ()
getScore ()
getAction ()
toArray ()

Fonctions membres publiques statiques

static fromJson ($json)

Attributs privés

$success = false
$errorCodes = array()
$hostname
$challengeTs
$apkPackageName
$score
$action

Description détaillée

The response returned from the service.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $success,
 |  | array | $errorCodes = array(),
 |  |  | $hostname = null,
 |  |  | $challengeTs = null,
 |  |  | $apkPackageName = null,
 |  |  | $score = null,
 |  |  | $action = null
 | ) |  |

Constructor.

Paramètres
boolean | $success
string | $hostname
string | $challengeTs
string | $apkPackageName
float | $score
string | $action
array | $errorCodes

Documentation des fonctions membres

◆ fromJson()

static fromJson ( $json )
static

Build the response from the expected JSON returned by the service.

Paramètres
string $json
Renvoie

Références null.

Référencé par ReCaptcha\verify().

◆ getAction()

getAction ( )

Get action

Renvoie
string

◆ getApkPackageName()

getApkPackageName ( )

Get APK package name

Renvoie
string

◆ getChallengeTs()

getChallengeTs ( )

Get challenge timestamp

Renvoie
string

◆ getErrorCodes()

getErrorCodes ( )

Get error codes.

Renvoie
array

◆ getHostname()

getHostname ( )

Get hostname.

Renvoie
string

◆ getScore()

getScore ( )

Get score

Renvoie
float

◆ isSuccess()

isSuccess ( )

Is success?

Renvoie
boolean

◆ toArray()

toArray ( )

Documentation des champs

◆ $action

$action
private

◆ $apkPackageName

$apkPackageName
private

◆ $challengeTs

$challengeTs
private

◆ $errorCodes

$errorCodes = array()
private

◆ $hostname

$hostname
private

◆ $score

$score
private

◆ $success

$success = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/google/recaptcha/src/ReCaptcha/Response.php


Joomla CMS: Référence de la classe AsCommand

  • Symfony
  • Component
  • Console
  • Attribute
  • AsCommand
Fonctions membres publiques
Référence de la classe AsCommand

Fonctions membres publiques

__construct (public string $name, public ?string $description=null, array $aliases=[], bool $hidden=false,)

Description détaillée

Service tag to autoconfigure commands.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | public string | $name,
 |  | public ?string | $description = null,
 |  | array | $aliases = [],
 |  | bool | $hidden = false
 | ) |  |

Références $name, et name.

La documentation de cette classe a été générée à partir du fichier suivant :
  • AsCommand.php


Joomla CMS: Référence de la classe GithubActionReporter

  • Symfony
  • Component
  • Console
  • CI
  • GithubActionReporter
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe GithubActionReporter

Fonctions membres publiques

__construct (OutputInterface $output)
error (string $message, string $file=null, int $line=null, int $col=null)
warning (string $message, string $file=null, int $line=null, int $col=null)
debug (string $message, string $file=null, int $line=null, int $col=null)

Fonctions membres publiques statiques

static isGithubActionEnvironment ()

Champs de données

const r

Fonctions membres privées

log (string $type, string $message, string $file=null, int $line=null, int $col=null)

Attributs privés

$output
const | ESCAPED_DATA
const | ESCAPED_PROPERTIES

Description détaillée

Utility class for Github actions.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( OutputInterface $output )

Références GithubActionReporter\$output.

Documentation des fonctions membres

◆ debug()

debug | ( | string | $message,
 |  | string | $file = null,
 |  | int | $line = null,
 |  | int | $col = null
 | ) |  |

Output a debug log using the Github annotations format.

Voir également
https://docs.github.com/en/free-pro-team@latest/actions/reference/workflow-commands-for-github-actions#setting-a-debug-message

Références GithubActionReporter\log().

◆ error()

error | ( | string | $message,
 |  | string | $file = null,
 |  | int | $line = null,
 |  | int | $col = null
 | ) |  |

Output an error using the Github annotations format.

Voir également
https://docs.github.com/en/free-pro-team@latest/actions/reference/workflow-commands-for-github-actions#setting-an-error-message

Références GithubActionReporter\log().

◆ isGithubActionEnvironment()

static isGithubActionEnvironment ( )
static

Référencé par LintCommand\execute().

◆ log()

log | ( | string | $type,
 |  | string | $message,
 |  | string | $file = null,
 |  | int | $line = null,
 |  | int | $col = null
 | ) |  |
private

Références $message, et $type.

Référencé par GithubActionReporter\debug(), GithubActionReporter\error(), et GithubActionReporter\warning().

◆ warning()

warning | ( | string | $message,
 |  | string | $file = null,
 |  | int | $line = null,
 |  | int | $col = null
 | ) |  |

Output a warning using the Github annotations format.

Voir également
https://docs.github.com/en/free-pro-team@latest/actions/reference/workflow-commands-for-github-actions#setting-a-warning-message

Références GithubActionReporter\log().

Documentation des champs

◆ $output

$output
private

Référencé par GithubActionReporter\__construct().

◆ ESCAPED_DATA

const ESCAPED_DATA
private
Valeur initiale :
= [
'%' => '%25'
Voir également
https://github.com/actions/toolkit/blob/5e5e1b7aacba68a53836a34db4a288c3c1c1585b/packages/core/src/command.ts#L80-L85

◆ ESCAPED_PROPERTIES

const ESCAPED_PROPERTIES
private
Valeur initiale :
= [
'%' => '%25'
Voir également
https://github.com/actions/toolkit/blob/5e5e1b7aacba68a53836a34db4a288c3c1c1585b/packages/core/src/command.ts#L87-L94

◆ r

const r
Valeur initiale :
=> '%0D',
"\n" => '%0A',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • GithubActionReporter.php


Joomla CMS: Référence de la classe Command

  • Symfony
  • Component
  • Console
  • Command
  • Command
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe Command
+ Graphe d'héritage de Command:
CompleteCommand DumpCompletionCommand HelpCommand LazyCommand ListCommand SingleCommandApplication ServerDumpCommand LintCommand

Fonctions membres publiques

__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres publiques statiques

static | getDefaultName ()
static | getDefaultDescription ()

Champs de données

const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName
static | $defaultDescription

Fonctions membres privées

validateName (string $name)

Attributs privés

$application
$name
$processTitle
$aliases = []
$definition
$hidden = false
$help = ''
$description = ''
$fullDefinition
$ignoreValidationErrors = false
$code
$synopsis = []
$usages = []
$helperSet

Description détaillée

Base class for all commands.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $name = null )
Paramètres
string | null $name The name of the command; passing null means it must be set in configure()
Exceptions
LogicException When the command name is empty

Références Command\$aliases, Command\$name, Command\configure(), description, null, Command\setAliases(), Command\setDescription(), Command\setHidden(), et Command\setName().

Documentation des fonctions membres

◆ addArgument()

addArgument | ( | string | $name,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |

Adds an argument.

Paramètres
int | null | $mode | The argument mode: InputArgument::REQUIRED or InputArgument::OPTIONAL
mixed | $default | The default value (for InputArgument::OPTIONAL mode only)
Exceptions
InvalidArgumentException When argument mode is not valid
Renvoie
$this

Références $default, Command\$description, $mode, Command\$name, $this, et null.

◆ addOption()

addOption | ( | string | $name,
 |  |  | $shortcut = null,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |

Adds an option.

Paramètres
string | array | null | $shortcut | The shortcuts, can be null, a string of shortcuts delimited by | or an array of shortcuts
int | null | $mode | The option mode: One of the InputOption::VALUE_* constants
mixed | $default | The default value (must be null for InputOption::VALUE_NONE)
Exceptions
InvalidArgumentException If option mode is invalid or incompatible
Renvoie
$this

Références $default, Command\$description, $mode, Command\$name, $this, et null.

◆ addUsage()

addUsage ( string $usage )

Add a command usage example, it'll be prefixed with the command name.

Renvoie
$this

Références $this, et name.

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Adds suggestions to $suggestions for the current completion input (e.g. option or argument).

◆ configure()

configure ( )
protected

Configures the current command.

Référencé par Command\__construct().

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Executes the current command.

This method is not abstract because you can use this class as a concrete class. In this case, instead of defining the execute() method, you set the code to execute by passing a Closure to the setCode() method.

Renvoie
int 0 if everything went fine, or an exit code
Exceptions
LogicException When this abstract method is not implemented
Voir également
setCode()

Référencé par Command\run().

◆ getAliases()

getAliases ( )

Returns the aliases for the command.

Renvoie
array

Références Command\$aliases.

Référencé par Application\add(), MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), LazyCommand\getCommand(), TextDescriptor\getCommandAliasesText(), JsonDescriptor\getCommandData(), et XmlDescriptor\getCommandDocument().

◆ getApplication()

getApplication ( )

Gets the application instance for this command.

Renvoie
Application|null

Références Command\$application.

Référencé par HelpCommand\complete(), CompleteCommand\createCompletionInput(), HelpCommand\execute(), DumpCompletionCommand\execute(), CompleteCommand\findCommand(), et LazyCommand\getCommand().

◆ getDefaultDescription()

static getDefaultDescription ( )
static

Références $class, $r, class, Fig\Link\getAttributes(), et null.

◆ getDefaultName()

static getDefaultName ( )
static
Renvoie
string|null

Références $class, $r, class, Fig\Link\getAttributes(), et null.

◆ getDefinition()

getDefinition ( )

Gets the InputDefinition attached to this Command.

Renvoie
InputDefinition

Références Command\getNativeDefinition().

Référencé par Application\add(), CompleteCommand\createCompletionInput(), MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), Application\doRunCommand(), JsonDescriptor\getCommandData(), XmlDescriptor\getCommandDocument(), et Command\run().

◆ getDescription()

getDescription ( )

Returns the description for the command.

Renvoie
string

Références Command\$description.

Référencé par MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), LazyCommand\getCommand(), JsonDescriptor\getCommandData(), XmlDescriptor\getCommandDocument(), et Command\getProcessedHelp().

◆ getHelp()

getHelp ( )

Returns the help for the command.

Renvoie
string

Références Command\$help.

Référencé par Command\getProcessedHelp().

◆ getHelper()

getHelper ( string $name )

Gets a helper instance by name.

Renvoie
mixed
Exceptions
LogicException | if no HelperSet is defined
InvalidArgumentException | if the helper is not defined

Références Command\$name, et null.

◆ getHelperSet()

getHelperSet ( )

Gets the helper set.

Renvoie
HelperSet|null

Références Command\$helperSet.

Référencé par Application\doRunCommand(), et LazyCommand\getCommand().

◆ getName()

getName ( )

Returns the command name.

Renvoie
string|null

Références Command\$name.

Référencé par Application\add(), Application\complete(), MarkdownDescriptor\describeCommand(), LazyCommand\getCommand(), JsonDescriptor\getCommandData(), XmlDescriptor\getCommandDocument(), Symfony\Component\Console\Command\lock(), SingleCommandApplication\run(), et Command\run().

◆ getNativeDefinition()

getNativeDefinition ( )

Gets the InputDefinition to be used to create representations of this Command.

Can be overridden to provide the original command representation when it would otherwise be changed by merging with the application InputDefinition.

This method is not part of public API and should not be used directly.

Renvoie
InputDefinition

Références Command\$definition, class, et null.

Référencé par Command\getDefinition().

◆ getProcessedHelp()

getProcessedHelp ( )

Returns the processed help for the command replacing the command.name% and command.full_name% patterns with the real values dynamically.

Renvoie
string

Références Command\$name, Command\getDescription(), et Command\getHelp().

Référencé par MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), JsonDescriptor\getCommandData(), et XmlDescriptor\getCommandDocument().

◆ getSynopsis()

getSynopsis ( bool $short = false )

Returns the synopsis for the command.

Paramètres
bool $short Whether to show the short version of the synopsis (with options folded) or not
Renvoie
string

Références $key, et name.

Référencé par MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), JsonDescriptor\getCommandData(), et XmlDescriptor\getCommandDocument().

◆ getUsages()

getUsages ( )

Returns alternative usages of the command.

Renvoie
array

Références Command\$usages.

Référencé par MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), JsonDescriptor\getCommandData(), et XmlDescriptor\getCommandDocument().

◆ ignoreValidationErrors()

ignoreValidationErrors ( )

Ignores validation errors.

This is mainly useful for the help command.

Référencé par HelpCommand\configure(), et Command\run().

◆ initialize()

initialize | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Initializes the command after the input has been bound and before the input is validated.

This is mainly useful when a lot of commands extends one main command where some things need to be initialized based on the input arguments and options.

Voir également
InputInterface::bind()
InputInterface::validate()

Référencé par Command\run().

◆ interact()

interact | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Interacts with the user.

This method is executed before the InputDefinition is validated. This means that this is the only place where the command can interactively ask for values of missing required arguments.

Référencé par Command\run().

◆ isEnabled()

isEnabled ( )

Checks whether the command is enabled or not in the current environment.

Override this to check for x or y and return false if the command cannot run properly under the current conditions.

Renvoie
bool

Référencé par Application\add().

◆ isHidden()

isHidden ( )
Renvoie
bool whether the command should be publicly shown or not

Références Command\$hidden.

Référencé par Application\complete(), LazyCommand\getCommand(), JsonDescriptor\getCommandData(), et XmlDescriptor\getCommandDocument().

◆ mergeApplicationDefinition()

mergeApplicationDefinition ( bool $mergeArgs = true )

Merges the application definition with the command definition.

This method is not part of public API and should not be used directly.

Paramètres
bool $mergeArgs Whether to merge or not the Application definition arguments to Command definition arguments

Références null.

Référencé par MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), Application\doRunCommand(), JsonDescriptor\getCommandData(), XmlDescriptor\getCommandDocument(), et Command\run().

◆ run()

run | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Runs the command.

The code to execute is either defined directly with the setCode() method or by overriding the execute() method in a sub-class.

Renvoie
int The command exit code
Exceptions

Références Command\$code, $input, $output, Symfony\Component\Console\Tester\$statusCode, InputInterface\bind(), class, code, elseif, Command\execute(), Command\getDefinition(), Command\getName(), Command\ignoreValidationErrors(), Command\initialize(), Command\interact(), Command\mergeApplicationDefinition(), null, InputInterface\validate(), et OutputInterface\VERBOSITY_VERY_VERBOSE.

Référencé par Application\doRunCommand().

◆ setAliases()

setAliases ( iterable $aliases )

Sets the aliases for the command.

Paramètres
string[] $aliases An array of aliases for the command
Renvoie
$this
Exceptions
InvalidArgumentException When an alias is invalid

Références Command\$aliases, $list, $this, et Command\validateName().

Référencé par Command\__construct().

◆ setApplication()

setApplication ( Application $application = null )

Références Command\$application, null, et Command\setHelperSet().

Référencé par Application\add().

◆ setCode()

setCode ( callable $code )

Sets the code to execute when running this command.

If this method is used, it overrides the code defined in the execute() method.

Paramètres
callable $code A callable(InputInterface $input, OutputInterface $output)
Renvoie
$this
Exceptions
InvalidArgumentException
Voir également
execute()

Références $c, Command\$code, $r, $this, code, et null.

◆ setDefinition()

setDefinition ( $definition )

Sets an array of argument and option instances.

Paramètres
array | InputDefinition $definition An array of argument and option instances or a definition instance
Renvoie
$this

Références Command\$definition, $this, et null.

◆ setDescription()

setDescription ( string $description )

Sets the description for the command.

Renvoie
$this

Références Command\$description, $this, et description.

Référencé par Command\__construct().

◆ setHelp()

setHelp ( string $help )

Sets the help for the command.

Renvoie
$this

Références Command\$help, et $this.

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet )

Références Command\$helperSet.

Référencé par Command\setApplication().

◆ setHidden()

setHidden ( bool $hidden )
Paramètres
bool $hidden Whether or not the command should be hidden from the list of commands The default value will be true in Symfony 6.0
Renvoie
$this

since Symfony 5.1

Références Command\$hidden, et $this.

Référencé par Command\__construct().

◆ setName()

setName ( string $name )

Sets the name of the command.

This method can set both the namespace and the name if you separate them by a colon (:)

$command->setName('foo:bar');
Renvoie
$this
Exceptions
InvalidArgumentException When the name is invalid

Références Command\$name, $this, name, et Command\validateName().

Référencé par LazyCommand\__construct(), Command\__construct(), et SingleCommandApplication\run().

◆ setProcessTitle()

setProcessTitle ( string $title )

Sets the process title of the command.

This feature should be used only when creating a long process command, like a daemon.

Renvoie
$this

Références $this, et $title.

◆ validateName()

validateName ( string $name )
private

Validates a command name.

It must be non-empty and parts can optionally be separated by ":".

Exceptions
InvalidArgumentException When the name is invalid

Références Command\$name.

Référencé par Command\setAliases(), et Command\setName().

Documentation des champs

◆ $aliases

$aliases = []
private

Référencé par LazyCommand\__construct(), Command\__construct(), Command\getAliases(), et Command\setAliases().

◆ $application

$application
private

Référencé par Command\getApplication(), SingleCommandApplication\run(), LazyCommand\setApplication(), et Command\setApplication().

◆ $code

$code
private

Référencé par Command\run(), et Command\setCode().

◆ $defaultDescription

$defaultDescription
staticprotected

◆ $defaultName

$defaultName
staticprotected

◆ $definition

$definition
private

Référencé par Command\getNativeDefinition(), LazyCommand\setDefinition(), et Command\setDefinition().

◆ $description

$description = ''
private

Référencé par LazyCommand\__construct(), LazyCommand\addArgument(), Command\addArgument(), LazyCommand\addOption(), Command\addOption(), Command\getDescription(), et Command\setDescription().

◆ $fullDefinition

$fullDefinition
private

◆ $help

$help = ''
private

Référencé par Command\getHelp(), et Command\setHelp().

◆ $helperSet

$helperSet
private

Référencé par Command\getHelperSet(), LazyCommand\setHelperSet(), et Command\setHelperSet().

◆ $hidden

$hidden = false
private

Référencé par Command\isHidden(), et Command\setHidden().

◆ $ignoreValidationErrors

$ignoreValidationErrors = false
private

◆ $name

$name
private

Référencé par LintCommand\__construct(), Command\__construct(), Command\addArgument(), Command\addOption(), Command\getHelper(), Command\getName(), Command\getProcessedHelp(), Symfony\Component\Console\Command\lock(), Command\setName(), et Command\validateName().

◆ $processTitle

$processTitle
private

◆ $synopsis

$synopsis = []
private

◆ $usages

$usages = []
private

Référencé par Command\getUsages().

◆ FAILURE

const FAILURE = 1

Référencé par CommandIsSuccessful\additionalFailureDescription(), SessionGcCommand\doExecute(), SessionMetadataGcCommand\doExecute(), ChangeUserPasswordCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), AddUserCommand\doExecute(), et ExtensionDiscoverInstallCommand\doExecute().

◆ INVALID

const INVALID = 2

Référencé par CommandIsSuccessful\additionalFailureDescription().

◆ SUCCESS

const SUCCESS = 0

Référencé par CheckUpdatesCommand\doExecute(), RemoveOldFilesCommand\doExecute(), SessionGcCommand\doExecute(), ListUserCommand\doExecute(), ChangeUserPasswordCommand\doExecute(), ExtensionDiscoverListCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), CheckJoomlaUpdatesCommand\doExecute(), AddUserCommand\doExecute(), ExtensionDiscoverCommand\doExecute(), FinderIndexCommand\doExecute(), ExtensionDiscoverInstallCommand\doExecute(), ExtensionsListCommand\doExecute(), et CommandIsSuccessful\matches().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Command.php


Joomla CMS: Référence de la classe CompleteCommand

  • Symfony
  • Component
  • Console
  • Command
  • CompleteCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe CompleteCommand
+ Graphe d'héritage de CompleteCommand:
Command

Fonctions membres publiques

__construct (array $completionOutputs=[])
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
initialize (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = '|_complete'
static | $defaultDescription = 'Internal command to provide shell completion suggestions'
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Fonctions membres privées

createCompletionInput (InputInterface $input)
findCommand (CompletionInput $completionInput, OutputInterface $output)
log ($messages)

Attributs privés

$completionOutputs
$isDebug = false

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2

Description détaillée

Responsible for providing the values to the shell completion.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $completionOutputs = [] )
Paramètres
array<string,class-string<CompletionOutputInterface>> $completionOutputs A list of additional completion outputs, with shell name as key and FQCN as value

Références CompleteCommand\$completionOutputs, Symfony\Contracts\Service\__construct(), et class.

Documentation des fonctions membres

◆ configure()

configure ( )
protected

Références $this, InputOption\VALUE_IS_ARRAY, et InputOption\VALUE_REQUIRED.

◆ createCompletionInput()

createCompletionInput ( InputInterface $input )
private

Références $input, CompletionInput\fromTokens(), Command\getApplication(), et Command\getDefinition().

◆ findCommand()

findCommand | ( | CompletionInput | $completionInput,
 |  | OutputInterface | $output
 | ) |  |
private

Références Command\getApplication(), ArgvInput\getFirstArgument(), et null.

◆ initialize()

initialize | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

◆ log()

log ( $messages )
private

Références $messages.

Documentation des champs

◆ $completionOutputs

$completionOutputs
private

Référencé par CompleteCommand\__construct().

◆ $defaultDescription

$defaultDescription = 'Internal command to provide shell completion suggestions'
staticprotected

◆ $defaultName

$defaultName = '|_complete'
staticprotected

◆ $isDebug

$isDebug = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • CompleteCommand.php


Joomla CMS: Référence de la classe DumpCompletionCommand

  • Symfony
  • Component
  • Console
  • Command
  • DumpCompletionCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Fonctions membres privées statiques
Référence de la classe DumpCompletionCommand
+ Graphe d'héritage de DumpCompletionCommand:
Command

Fonctions membres publiques

complete (CompletionInput $input, CompletionSuggestions $suggestions)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'completion'
static | $defaultDescription = 'Dump the shell completion script'
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Fonctions membres privées

tailDebugLog (string $commandName, OutputInterface $output)
getSupportedShells ()

Fonctions membres privées statiques

static guessShell ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2

Description détaillée

Dumps the completion script for the current shell.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des fonctions membres

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Références $input, DumpCompletionCommand\getSupportedShells(), et CompletionSuggestions\suggestValues().

◆ configure()

configure ( )
protected

Références $this, null, InputArgument\OPTIONAL, path, et InputOption\VALUE_NONE.

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Références $input, $output, __DIR__, Command\getApplication(), DumpCompletionCommand\getSupportedShells(), et DumpCompletionCommand\tailDebugLog().

◆ getSupportedShells()

getSupportedShells ( )
private
Renvoie
string[]

Références __DIR__.

Référencé par DumpCompletionCommand\complete(), et DumpCompletionCommand\execute().

◆ guessShell()

static guessShell ( )
staticprivate

◆ tailDebugLog()

tailDebugLog | ( | string | $commandName,
 |  | OutputInterface | $output
 | ) |  |
private

Références $output, $type, et null.

Référencé par DumpCompletionCommand\execute().

Documentation des champs

◆ $defaultDescription

$defaultDescription = 'Dump the shell completion script'
staticprotected

◆ $defaultName

$defaultName = 'completion'
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • DumpCompletionCommand.php


Joomla CMS: Référence de la classe HelpCommand

  • Symfony
  • Component
  • Console
  • Command
  • HelpCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe HelpCommand
+ Graphe d'héritage de HelpCommand:
Command

Fonctions membres publiques

setCommand (Command $command)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs privés

$command

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Description détaillée

HelpCommand displays the help for a given command.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Références $helper, $input, Command\getApplication(), et CompletionSuggestions\suggestValues().

◆ configure()

configure ( )
protected

{}

Références $this, Command\ignoreValidationErrors(), null, InputArgument\OPTIONAL, InputOption\VALUE_NONE, et InputOption\VALUE_REQUIRED.

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

{}

Références $helper, $input, $output, Command\getApplication(), InputInterface\getArgument(), et null.

◆ setCommand()

setCommand ( Command $command )

Références HelpCommand\$command.

Documentation des champs

◆ $command

$command
private

Référencé par HelpCommand\setCommand().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Command/HelpCommand.php


Joomla CMS: Référence de la classe LazyCommand

  • Symfony
  • Component
  • Console
  • Command
  • LazyCommand
Fonctions membres publiques | Attributs privés
Référence de la classe LazyCommand
+ Graphe d'héritage de LazyCommand:
Command

Fonctions membres publiques

__construct (string $name, array $aliases, string $description, bool $isHidden, \Closure $commandFactory, ?bool $isEnabled=true)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setProcessTitle (string $title)
setHelp (string $help)
getHelp ()
getProcessedHelp ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)
getCommand ()
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Attributs privés

$command
$isEnabled

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | array | $aliases,
 |  | string | $description,
 |  | bool | $isHidden,
 |  | \Closure | $commandFactory,
 |  | ?bool | $isEnabled = true
 | ) |  |

Références Command\$aliases, Command\$description, LazyCommand\$isEnabled, LazyCommand\isEnabled(), et Command\setName().

Documentation des fonctions membres

◆ addArgument()

addArgument | ( | string | $name,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |
Renvoie
$this

Références $default, Command\$description, $mode, $this, et LazyCommand\getCommand().

◆ addOption()

addOption | ( | string | $name,
 |  |  | $shortcut = null,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |
Renvoie
$this

Références $default, Command\$description, $mode, $this, et LazyCommand\getCommand().

◆ addUsage()

addUsage ( string $usage )
Renvoie
$this

Références $this, et LazyCommand\getCommand().

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Références LazyCommand\getCommand().

◆ getCommand()

getCommand ( )

Références LazyCommand\$command, Command\getAliases(), Command\getApplication(), Command\getDescription(), Command\getHelperSet(), Command\getName(), Command\isHidden(), et null.

Référencé par LazyCommand\addArgument(), LazyCommand\addOption(), LazyCommand\addUsage(), LazyCommand\complete(), LazyCommand\getDefinition(), LazyCommand\getHelp(), LazyCommand\getHelper(), LazyCommand\getNativeDefinition(), LazyCommand\getProcessedHelp(), LazyCommand\getSynopsis(), LazyCommand\getUsages(), LazyCommand\ignoreValidationErrors(), LazyCommand\isEnabled(), LazyCommand\mergeApplicationDefinition(), LazyCommand\run(), LazyCommand\setCode(), LazyCommand\setDefinition(), LazyCommand\setHelp(), et LazyCommand\setProcessTitle().

◆ getDefinition()

getDefinition ( )

Références LazyCommand\getCommand().

◆ getHelp()

getHelp ( )

Références LazyCommand\getCommand().

◆ getHelper()

getHelper ( string $name )
Renvoie
mixed

Références LazyCommand\getCommand().

◆ getNativeDefinition()

getNativeDefinition ( )

Références LazyCommand\getCommand().

◆ getProcessedHelp()

getProcessedHelp ( )

Références LazyCommand\getCommand().

◆ getSynopsis()

getSynopsis ( bool $short = false )

Références LazyCommand\getCommand().

◆ getUsages()

getUsages ( )

Références LazyCommand\getCommand().

◆ ignoreValidationErrors()

ignoreValidationErrors ( )

Références LazyCommand\getCommand().

◆ isEnabled()

isEnabled ( )

Références LazyCommand\getCommand().

Référencé par LazyCommand\__construct().

◆ mergeApplicationDefinition()

mergeApplicationDefinition ( bool $mergeArgs = true )

Références LazyCommand\getCommand().

◆ run()

run | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Références $output, et LazyCommand\getCommand().

◆ setApplication()

setApplication ( Application $application = null )

Références Command\$application, et parent.

◆ setCode()

setCode ( callable $code )
Renvoie
$this

Références $this, et LazyCommand\getCommand().

◆ setDefinition()

setDefinition ( $definition )
Renvoie
$this

Références Command\$definition, $this, et LazyCommand\getCommand().

◆ setHelp()

setHelp ( string $help )
Renvoie
$this

Références $this, et LazyCommand\getCommand().

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet )

Références Command\$helperSet, et parent.

◆ setProcessTitle()

setProcessTitle ( string $title )
Renvoie
$this

Références $this, et LazyCommand\getCommand().

Documentation des champs

◆ $command

$command
private

Référencé par LazyCommand\getCommand().

◆ $isEnabled

$isEnabled
private

Référencé par LazyCommand\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LazyCommand.php


Joomla CMS: Référence de la classe ListCommand

  • Symfony
  • Component
  • Console
  • Command
  • ListCommand
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ListCommand
+ Graphe d'héritage de ListCommand:
Command

Fonctions membres publiques

complete (CompletionInput $input, CompletionSuggestions $suggestions)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Description détaillée

ListCommand displays the list of all available commands for the application.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

◆ configure()

configure ( )
protected

{}

Références $this, null, InputArgument\OPTIONAL, InputOption\VALUE_NONE, et InputOption\VALUE_REQUIRED.

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Command/ListCommand.php


Joomla CMS: Référence de l'interface SignalableCommandInterface

  • Symfony
  • Component
  • Console
  • Command
  • SignalableCommandInterface
Fonctions membres publiques
Référence de l'interface SignalableCommandInterface

Fonctions membres publiques

getSubscribedSignals ()
handleSignal (int $signal)

Description détaillée

Interface for command reacting to signal.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rix.i.nosp@m.nfo

Documentation des fonctions membres

◆ getSubscribedSignals()

getSubscribedSignals ( )

Returns the list of signals to subscribe.

◆ handleSignal()

handleSignal ( int $signal )

The method will be called when the application is signaled.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SignalableCommandInterface.php


Joomla CMS: Référence de l'interface CommandLoaderInterface

  • Symfony
  • Component
  • Console
  • CommandLoader
  • CommandLoaderInterface
Fonctions membres publiques
Référence de l'interface CommandLoaderInterface
+ Graphe d'héritage de CommandLoaderInterface:
ContainerCommandLoader FactoryCommandLoader

Fonctions membres publiques

get (string $name)
has (string $name)
getNames ()

Description détaillée

Auteur
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des fonctions membres

◆ get()

get ( string $name )

Loads a command.

Renvoie
Command
Exceptions
CommandNotFoundException

Implémenté dans FactoryCommandLoader, et ContainerCommandLoader.

◆ getNames()

getNames ( )
Renvoie
string[]

Implémenté dans ContainerCommandLoader, et FactoryCommandLoader.

◆ has()

has ( string $name )

Checks if a command exists.

Renvoie
bool

Implémenté dans ContainerCommandLoader, et FactoryCommandLoader.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CommandLoaderInterface.php


Joomla CMS: Référence de la classe ContainerCommandLoader

  • Symfony
  • Component
  • Console
  • CommandLoader
  • ContainerCommandLoader
Fonctions membres publiques | Attributs privés
Référence de la classe ContainerCommandLoader
+ Graphe d'héritage de ContainerCommandLoader:
CommandLoaderInterface

Fonctions membres publiques

__construct (ContainerInterface $container, array $commandMap)
get (string $name)
has (string $name)
getNames ()

Attributs privés

$container
$commandMap

Description détaillée

Loads commands from a PSR-11 container.

Auteur
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ContainerInterface | $container,
 |  | array | $commandMap
 | ) |  |
Paramètres
array $commandMap An array with command names as keys and service ids as values

Références ContainerCommandLoader\$commandMap, et ContainerCommandLoader\$container.

Documentation des fonctions membres

◆ get()

get ( string $name )

{Loads a command.

Renvoie
Command
Exceptions
CommandNotFoundException
}

Implémente CommandLoaderInterface.

Références $name, et ContainerCommandLoader\has().

◆ getNames()

getNames ( )

{

Renvoie
string[]
}

Implémente CommandLoaderInterface.

◆ has()

has ( string $name )

{Checks if a command exists.

Renvoie
bool
}

Implémente CommandLoaderInterface.

Références $name.

Référencé par ContainerCommandLoader\get().

Documentation des champs

◆ $commandMap

$commandMap
private

Référencé par ContainerCommandLoader\__construct().

◆ $container

$container
private

Référencé par ContainerCommandLoader\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContainerCommandLoader.php


Joomla CMS: Référence de la classe FactoryCommandLoader

  • Symfony
  • Component
  • Console
  • CommandLoader
  • FactoryCommandLoader
Fonctions membres publiques | Attributs privés
Référence de la classe FactoryCommandLoader
+ Graphe d'héritage de FactoryCommandLoader:
CommandLoaderInterface

Fonctions membres publiques

__construct (array $factories)
has (string $name)
get (string $name)
getNames ()

Attributs privés

$factories

Description détaillée

A simple command loader using factories to instantiate commands lazily.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $factories )
Paramètres
callable[] $factories Indexed by command names

Références FactoryCommandLoader\$factories.

Documentation des fonctions membres

◆ get()

get ( string $name )

{Loads a command.

Renvoie
Command
Exceptions
CommandNotFoundException
}

Implémente CommandLoaderInterface.

Références $name.

◆ getNames()

getNames ( )

{

Renvoie
string[]
}

Implémente CommandLoaderInterface.

◆ has()

has ( string $name )

{Checks if a command exists.

Renvoie
bool
}

Implémente CommandLoaderInterface.

Références $name.

Documentation des champs

◆ $factories

$factories
private

Référencé par FactoryCommandLoader\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FactoryCommandLoader.php


Joomla CMS: Référence de la classe BashCompletionOutput

  • Symfony
  • Component
  • Console
  • Completion
  • Output
  • BashCompletionOutput
Fonctions membres publiques
Référence de la classe BashCompletionOutput
+ Graphe d'héritage de BashCompletionOutput:
CompletionOutputInterface

Fonctions membres publiques

write (CompletionSuggestions $suggestions, OutputInterface $output)

Description détaillée

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des fonctions membres

◆ write()

write | ( | CompletionSuggestions | $suggestions,
 |  | OutputInterface | $output
 | ) |  |

Implémente CompletionOutputInterface.

Références $option, $output, CompletionSuggestions\getOptionSuggestions(), et CompletionSuggestions\getValueSuggestions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BashCompletionOutput.php


Joomla CMS: Référence de l'interface CompletionOutputInterface

  • Symfony
  • Component
  • Console
  • Completion
  • Output
  • CompletionOutputInterface
Fonctions membres publiques
Référence de l'interface CompletionOutputInterface
+ Graphe d'héritage de CompletionOutputInterface:
BashCompletionOutput

Fonctions membres publiques

write (CompletionSuggestions $suggestions, OutputInterface $output)

Description détaillée

Transforms the {

Voir également
CompletionSuggestions} object into output readable by the shell completion.
Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des fonctions membres

◆ write()

write | ( | CompletionSuggestions | $suggestions,
 |  | OutputInterface | $output
 | ) |  |

Implémenté dans BashCompletionOutput.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CompletionOutputInterface.php


Joomla CMS: Référence de la classe CompletionInput

  • Symfony
  • Component
  • Console
  • Completion
  • CompletionInput
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe CompletionInput
+ Graphe d'héritage de CompletionInput:
ArgvInput Input InputInterface StreamableInputInterface InputInterface

Fonctions membres publiques

bind (InputDefinition $definition)
getCompletionType ()
getCompletionName ()
getCompletionValue ()
mustSuggestOptionValuesFor (string $optionName)
mustSuggestArgumentValuesFor (string $argumentName)
__toString ()
- Fonctions membres publiques hérités de ArgvInput
__construct (array $argv=null, InputDefinition $definition=null)
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
__toString ()
- Fonctions membres publiques hérités de Input
__construct (InputDefinition $definition=null)
bind (InputDefinition $definition)
validate ()
isInteractive ()
setInteractive (bool $interactive)
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
escapeToken (string $token)
setStream ($stream)
getStream ()

Fonctions membres publiques statiques

static | fromString (string $inputStr, int $currentIndex)
static | fromTokens (array $tokens, int $currentIndex)

Champs de données

const | TYPE_ARGUMENT_VALUE = 'argument_value'
const | TYPE_OPTION_VALUE = 'option_value'
const | TYPE_OPTION_NAME = 'option_name'
const | TYPE_NONE = 'none'

Fonctions membres protégées

parseToken (string $token, bool $parseOptions)
- Fonctions membres protégées hérités de ArgvInput
setTokens (array $tokens)
parse ()
parseToken (string $token, bool $parseOptions)
- Fonctions membres protégées hérités de Input
parse ()

Fonctions membres privées

getOptionFromToken (string $optionToken)
getRelevantToken ()
isCursorFree ()

Attributs privés

$tokens
$currentIndex
$completionType
$completionName = null
$completionValue = ''

Membres hérités additionnels

- Attributs protégés hérités de Input
$definition
$stream
$options = []
$arguments = []
$interactive = true

Description détaillée

An input specialized for shell completion.

This input allows unfinished option names or values and exposes what kind of completion is expected.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références $i.

◆ bind()

bind ( InputDefinition $definition )

{Binds the current Input instance with the given arguments and options.

Exceptions
RuntimeException
}

Implémente InputInterface.

Références Input\$definition, $option, $optionValue, CompletionInput\getOptionFromToken(), CompletionInput\getRelevantToken(), CompletionInput\isCursorFree(), et null.

◆ fromString()

static fromString | ( | string | $inputStr,
 |  | int | $currentIndex
 | ) |  |
static

Converts a terminal string into tokens.

This is required for shell completions without COMP_WORDS support.

Références CompletionInput\$currentIndex, et CompletionInput\$tokens.

◆ fromTokens()

static fromTokens | ( | array | $tokens,
 |  | int | $currentIndex
 | ) |  |
static

Create an input based on an COMP_WORDS token list.

Paramètres
string[] | $tokens the set of split tokens (e.g. COMP_WORDS or argv)
$currentIndex | the index of the cursor (e.g. COMP_CWORD)

Références CompletionInput\$currentIndex, $input, et CompletionInput\$tokens.

Référencé par CommandCompletionTester\complete(), et CompleteCommand\createCompletionInput().

◆ getCompletionName()

getCompletionName ( )

The name of the input option or argument when completing a value.

Renvoie
string|null returns null when completing an option name

Références CompletionInput\$completionName.

Référencé par CompletionInput\mustSuggestArgumentValuesFor(), et CompletionInput\mustSuggestOptionValuesFor().

◆ getCompletionType()

getCompletionType ( )

Returns the type of completion required.

TYPE_ARGUMENT_VALUE when completing the value of an input argument TYPE_OPTION_VALUE when completing the value of an input option TYPE_OPTION_NAME when completing the name of an input option TYPE_NONE when nothing should be completed

Renvoie
string One of self::TYPE_* constants. TYPE_OPTION_NAME and TYPE_NONE are already implemented by the Console component

Références CompletionInput\$completionType.

Référencé par Application\complete(), CompletionInput\mustSuggestArgumentValuesFor(), et CompletionInput\mustSuggestOptionValuesFor().

◆ getCompletionValue()

getCompletionValue ( )

The value already typed by the user (or empty string).

Références CompletionInput\$completionValue.

◆ getOptionFromToken()

getOptionFromToken ( string $optionToken )
private

Références null.

Référencé par CompletionInput\bind().

◆ getRelevantToken()

getRelevantToken ( )
private

The token of the cursor, or the last token if the cursor is at the end of the input.

Références CompletionInput\$currentIndex, et CompletionInput\isCursorFree().

Référencé par CompletionInput\bind().

◆ isCursorFree()

isCursorFree ( )
private

Whether the cursor is "free" (i.e. at the end of the input preceded by a space).

Référencé par CompletionInput\bind(), et CompletionInput\getRelevantToken().

◆ mustSuggestArgumentValuesFor()

mustSuggestArgumentValuesFor ( string $argumentName )

Références CompletionInput\getCompletionName(), et CompletionInput\getCompletionType().

◆ mustSuggestOptionValuesFor()

mustSuggestOptionValuesFor ( string $optionName )

Références CompletionInput\getCompletionName(), et CompletionInput\getCompletionType().

◆ parseToken()

parseToken | ( | string | $token,
 |  | bool | $parseOptions
 | ) |  |
protected

Documentation des champs

◆ $completionName

$completionName = null
private

Référencé par CompletionInput\getCompletionName().

◆ $completionType

$completionType
private

Référencé par CompletionInput\getCompletionType().

◆ $completionValue

$completionValue = ''
private

Référencé par CompletionInput\getCompletionValue().

◆ $currentIndex

$currentIndex
private

Référencé par CompletionInput\fromString(), CompletionInput\fromTokens(), et CompletionInput\getRelevantToken().

◆ $tokens

$tokens
private

Référencé par CompletionInput\fromString(), et CompletionInput\fromTokens().

◆ TYPE_ARGUMENT_VALUE

const TYPE_ARGUMENT_VALUE = 'argument_value'

Référencé par Application\complete().

◆ TYPE_NONE

const TYPE_NONE = 'none'

◆ TYPE_OPTION_NAME

const TYPE_OPTION_NAME = 'option_name'

Référencé par Application\complete().

◆ TYPE_OPTION_VALUE

const TYPE_OPTION_VALUE = 'option_value'
La documentation de cette classe a été générée à partir du fichier suivant :
  • CompletionInput.php


Joomla CMS: Référence de la classe CompletionSuggestions

  • Symfony
  • Component
  • Console
  • Completion
  • CompletionSuggestions
Fonctions membres publiques | Attributs privés
Référence de la classe CompletionSuggestions

Fonctions membres publiques

suggestValue ($value)
suggestValues (array $values)
suggestOption (InputOption $option)
suggestOptions (array $options)
getOptionSuggestions ()
getValueSuggestions ()

Attributs privés

$valueSuggestions = []
$optionSuggestions = []

Description détaillée

Stores all completion suggestions for the current input.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des fonctions membres

◆ getOptionSuggestions()

getOptionSuggestions ( )
Renvoie
InputOption[]

Références CompletionSuggestions\$optionSuggestions.

Référencé par BashCompletionOutput\write().

◆ getValueSuggestions()

getValueSuggestions ( )
Renvoie
Suggestion[]

Références CompletionSuggestions\$valueSuggestions.

Référencé par BashCompletionOutput\write().

◆ suggestOption()

suggestOption ( InputOption $option )

Add a suggestion for an input option name.

Renvoie
$this

Références $option, et $this.

Référencé par CompletionSuggestions\suggestOptions().

◆ suggestOptions()

suggestOptions ( array $options )

Add multiple suggestions for input option names at once.

Paramètres
InputOption[] $options
Renvoie
$this

Références $option, $options, $this, et CompletionSuggestions\suggestOption().

Référencé par Application\complete().

◆ suggestValue()

suggestValue ( $value )

Add a suggested value for an input option or argument.

Paramètres
string | Suggestion $value
Renvoie
$this

Références $this, et $value.

Référencé par CompletionSuggestions\suggestValues().

◆ suggestValues()

suggestValues ( array $values )

Add multiple suggested values at once for an input option or argument.

Paramètres
list<string|Suggestion> $values
Renvoie
$this

Références $this, $value, et CompletionSuggestions\suggestValue().

Référencé par DumpCompletionCommand\complete(), HelpCommand\complete(), ServerDumpCommand\complete(), LintCommand\complete(), et Application\complete().

Documentation des champs

◆ $optionSuggestions

$optionSuggestions = []
private

Référencé par CompletionSuggestions\getOptionSuggestions().

◆ $valueSuggestions

$valueSuggestions = []
private

Référencé par CompletionSuggestions\getValueSuggestions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CompletionSuggestions.php


Joomla CMS: Référence de la classe Suggestion

  • Symfony
  • Component
  • Console
  • Completion
  • Suggestion
Fonctions membres publiques | Attributs privés
Référence de la classe Suggestion

Fonctions membres publiques

__construct (string $value)
getValue ()
__toString ()

Attributs privés

$value

Description détaillée

Represents a single suggested value.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $value )

Références Suggestion\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références Suggestion\getValue().

◆ getValue()

getValue ( )

Références Suggestion\$value.

Référencé par Suggestion\__toString().

Documentation des champs

◆ $value

$value
private

Référencé par Suggestion\__construct(), et Suggestion\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Suggestion.php


Joomla CMS: Référence de la classe AddConsoleCommandPass

  • Symfony
  • Component
  • Console
  • DependencyInjection
  • AddConsoleCommandPass
Fonctions membres publiques | Attributs privés
Référence de la classe AddConsoleCommandPass
+ Graphe d'héritage de AddConsoleCommandPass:

Fonctions membres publiques

__construct (string $commandLoaderServiceId='console.command_loader', string $commandTag='console.command', string $noPreloadTag='container.no_preload', string $privateTagName='container.private')
process (ContainerBuilder $container)

Attributs privés

$commandLoaderServiceId
$commandTag
$noPreloadTag
$privateTagName

Description détaillée

Registers console commands.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $commandLoaderServiceId = 'console.command_loader',
 |  | string | $commandTag = 'console.command',
 |  | string | $noPreloadTag = 'container.no_preload',
 |  | string | $privateTagName = 'container.private'
 | ) |  |

Références AddConsoleCommandPass\$commandLoaderServiceId, AddConsoleCommandPass\$commandTag, AddConsoleCommandPass\$noPreloadTag, et AddConsoleCommandPass\$privateTagName.

Documentation des fonctions membres

◆ process()

process ( ContainerBuilder $container )

Références $class, $container, $description, $id, $r, class, et null.

Documentation des champs

◆ $commandLoaderServiceId

$commandLoaderServiceId
private

Référencé par AddConsoleCommandPass\__construct().

◆ $commandTag

$commandTag
private

Référencé par AddConsoleCommandPass\__construct().

◆ $noPreloadTag

$noPreloadTag
private

Référencé par AddConsoleCommandPass\__construct().

◆ $privateTagName

$privateTagName
private

Référencé par AddConsoleCommandPass\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AddConsoleCommandPass.php


Joomla CMS: Référence de la classe ApplicationDescription

  • Symfony
  • Component
  • Console
  • Descriptor
  • ApplicationDescription
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe ApplicationDescription

Fonctions membres publiques

__construct (Application $application, string $namespace=null, bool $showHidden=false)
getNamespaces ()
getCommands ()
getCommand (string $name)

Champs de données

const GLOBAL_NAMESPACE = '_global'

Fonctions membres privées

sortCommands (array $commands)

Attributs privés

$application
$namespace
$showHidden
$namespaces
$commands
$aliases

Description détaillée

Auteur
Jean-François Simon jeanf.nosp@m.ranc.nosp@m.ois.s.nosp@m.imon.nosp@m.@sens.nosp@m.iola.nosp@m.bs.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Application | $application,
 |  | string | $namespace = null,
 |  | bool | $showHidden = false
 | ) |  |

Références ApplicationDescription\$application, ApplicationDescription\$namespace, et ApplicationDescription\$showHidden.

Documentation des fonctions membres

◆ getCommand()

getCommand ( string $name )
Exceptions
CommandNotFoundException

Références $name.

◆ getCommands()

getCommands ( )
Renvoie
Command[]

Références ApplicationDescription\$commands, et null.

◆ getNamespaces()

getNamespaces ( )

Références ApplicationDescription\$namespaces, et null.

◆ sortCommands()

sortCommands ( array $commands )
private

Références ApplicationDescription\$commands, $key, et $name.

Documentation des champs

◆ $aliases

$aliases
private

◆ $application

$application
private

Référencé par ApplicationDescription\__construct().

◆ $commands

$commands
private

Référencé par ApplicationDescription\getCommands(), et ApplicationDescription\sortCommands().

◆ $namespace

$namespace
private

Référencé par ApplicationDescription\__construct().

◆ $namespaces

$namespaces
private

Référencé par ApplicationDescription\getNamespaces().

◆ $showHidden

$showHidden
private

Référencé par ApplicationDescription\__construct().

◆ GLOBAL_NAMESPACE

const GLOBAL_NAMESPACE = '_global'

Référencé par MarkdownDescriptor\describeApplication(), et TextDescriptor\describeApplication().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Descriptor/ApplicationDescription.php


Joomla CMS: Référence de la classe Descriptor

  • Symfony
  • Component
  • Console
  • Descriptor
  • Descriptor
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Descriptor
+ Graphe d'héritage de Descriptor:
DescriptorInterface JsonDescriptor MarkdownDescriptor TextDescriptor XmlDescriptor TextDescriptor

Fonctions membres publiques

describe (OutputInterface $output, object $object, array $options=[])

Fonctions membres protégées

write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])

Attributs protégés

$output

Description détaillée

Auteur
Jean-François Simon jeanf.nosp@m.ranc.nosp@m.ois.s.nosp@m.imon.nosp@m.@sens.nosp@m.iola.nosp@m.bs.co.nosp@m.m

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | object | $object,
 |  | array | $options = []
 | ) |  |

{}

Implémente DescriptorInterface.

Références $options, Descriptor\$output, Descriptor\describeApplication(), Descriptor\describeCommand(), Descriptor\describeInputArgument(), Descriptor\describeInputDefinition(), et Descriptor\describeInputOption().

◆ describeApplication()

describeApplication | ( | Application | $application,
 |  | array | $options = []
 | ) |  |
abstractprotected

Describes an Application instance.

Référencé par Descriptor\describe().

◆ describeCommand()

describeCommand | ( | Command | $command,
 |  | array | $options = []
 | ) |  |
abstractprotected

Describes a Command instance.

Référencé par Descriptor\describe().

◆ describeInputArgument()

describeInputArgument | ( | InputArgument | $argument,
 |  | array | $options = []
 | ) |  |
abstractprotected

Describes an InputArgument instance.

Référencé par Descriptor\describe().

◆ describeInputDefinition()

describeInputDefinition | ( | InputDefinition | $definition,
 |  | array | $options = []
 | ) |  |
abstractprotected

Describes an InputDefinition instance.

Référencé par Descriptor\describe().

◆ describeInputOption()

describeInputOption | ( | InputOption | $option,
 |  | array | $options = []
 | ) |  |
abstractprotected

Describes an InputOption instance.

Référencé par Descriptor\describe().

◆ write()

write | ( | string | $content,
 |  | bool | $decorated = false
 | ) |  |
protected

Writes content to output.

Références $content, OutputInterface\OUTPUT_NORMAL, et OutputInterface\OUTPUT_RAW.

Référencé par JsonDescriptor\writeData(), XmlDescriptor\writeDocument(), et TextDescriptor\writeText().

Documentation des champs

◆ $output

$output
protected

Référencé par MarkdownDescriptor\describe(), TextDescriptor\describe(), et Descriptor\describe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Descriptor.php


Joomla CMS: Référence de l'interface DescriptorInterface

  • Symfony
  • Component
  • Console
  • Descriptor
  • DescriptorInterface
Fonctions membres publiques
Référence de l'interface DescriptorInterface
+ Graphe d'héritage de DescriptorInterface:
Descriptor JsonDescriptor MarkdownDescriptor TextDescriptor XmlDescriptor TextDescriptor

Fonctions membres publiques

describe (OutputInterface $output, object $object, array $options=[])

Description détaillée

Descriptor interface.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | object | $object,
 |  | array | $options = []
 | ) |  |

Implémenté dans Descriptor, et MarkdownDescriptor.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DescriptorInterface.php


Joomla CMS: Référence de la classe JsonDescriptor

  • Symfony
  • Component
  • Console
  • Descriptor
  • JsonDescriptor
Fonctions membres protégées | Fonctions membres privées
Référence de la classe JsonDescriptor
+ Graphe d'héritage de JsonDescriptor:
Descriptor DescriptorInterface

Fonctions membres protégées

describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Fonctions membres protégées hérités de Descriptor
write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])

Fonctions membres privées

writeData (array $data, array $options)
getInputArgumentData (InputArgument $argument)
getInputOptionData (InputOption $option, bool $negated=false)
getInputDefinitionData (InputDefinition $definition)
getCommandData (Command $command, bool $short=false)

Membres hérités additionnels

- Fonctions membres publiques hérités de Descriptor
describe (OutputInterface $output, object $object, array $options=[])
- Attributs protégés hérités de Descriptor
$output

Description détaillée

JSON descriptor.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ describeApplication()

describeApplication | ( | Application | $application,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $data, $description, $options, JsonDescriptor\getCommandData(), Application\getName(), Application\getVersion(), null, et JsonDescriptor\writeData().

◆ describeCommand()

describeCommand | ( | Command | $command,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, JsonDescriptor\getCommandData(), et JsonDescriptor\writeData().

◆ describeInputArgument()

describeInputArgument | ( | InputArgument | $argument,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, JsonDescriptor\getInputArgumentData(), et JsonDescriptor\writeData().

◆ describeInputDefinition()

describeInputDefinition | ( | InputDefinition | $definition,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, JsonDescriptor\getInputDefinitionData(), et JsonDescriptor\writeData().

◆ describeInputOption()

describeInputOption | ( | InputOption | $option,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $option, $options, JsonDescriptor\getInputOptionData(), et JsonDescriptor\writeData().

◆ getCommandData()

getCommandData | ( | Command | $command,
 |  | bool | $short = false
 | ) |  |
private

Références $data, Command\getAliases(), Command\getDefinition(), Command\getDescription(), JsonDescriptor\getInputDefinitionData(), Command\getName(), Command\getProcessedHelp(), Command\getSynopsis(), Command\getUsages(), Command\isHidden(), et Command\mergeApplicationDefinition().

Référencé par JsonDescriptor\describeApplication(), et JsonDescriptor\describeCommand().

◆ getInputArgumentData()

getInputArgumentData ( InputArgument $argument )
private

Références InputArgument\getDefault(), InputArgument\getDescription(), InputArgument\getName(), InputArgument\isArray(), et InputArgument\isRequired().

Référencé par JsonDescriptor\describeInputArgument(), et JsonDescriptor\getInputDefinitionData().

◆ getInputDefinitionData()

getInputDefinitionData ( InputDefinition $definition )
private

Références $name, $option, InputDefinition\getArguments(), JsonDescriptor\getInputArgumentData(), JsonDescriptor\getInputOptionData(), et InputDefinition\getOptions().

Référencé par JsonDescriptor\describeInputDefinition(), et JsonDescriptor\getCommandData().

◆ getInputOptionData()

getInputOptionData | ( | InputOption | $option,
 |  | bool | $negated = false
 | ) |  |
private

Références $option.

Référencé par JsonDescriptor\describeInputOption(), et JsonDescriptor\getInputDefinitionData().

◆ writeData()

writeData | ( | array | $data,
 |  | array | $options
 | ) |  |
private

Writes data as json.

Références $options, et Descriptor\write().

Référencé par JsonDescriptor\describeApplication(), JsonDescriptor\describeCommand(), JsonDescriptor\describeInputArgument(), JsonDescriptor\describeInputDefinition(), et JsonDescriptor\describeInputOption().

La documentation de cette classe a été générée à partir du fichier suivant :
  • JsonDescriptor.php


Joomla CMS: Référence de la classe MarkdownDescriptor

  • Symfony
  • Component
  • Console
  • Descriptor
  • MarkdownDescriptor
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe MarkdownDescriptor
+ Graphe d'héritage de MarkdownDescriptor:
Descriptor DescriptorInterface

Fonctions membres publiques

describe (OutputInterface $output, object $object, array $options=[])
- Fonctions membres publiques hérités de Descriptor
describe (OutputInterface $output, object $object, array $options=[])

Fonctions membres protégées

write (string $content, bool $decorated=true)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Fonctions membres protégées hérités de Descriptor
write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])

Fonctions membres privées

getApplicationTitle (Application $application)

Membres hérités additionnels

- Attributs protégés hérités de Descriptor
$output

Description détaillée

Markdown descriptor.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | object | $object,
 |  | array | $options = []
 | ) |  |

{}

Implémente DescriptorInterface.

Références $options, et Descriptor\$output.

◆ describeApplication()

describeApplication | ( | Application | $application,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $description, $namespace, $options, $title, MarkdownDescriptor\describeCommand(), MarkdownDescriptor\getApplicationTitle(), ApplicationDescription\GLOBAL_NAMESPACE, null, Helper\width(), et MarkdownDescriptor\write().

◆ describeCommand()

describeCommand | ( | Command | $command,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, MarkdownDescriptor\describeInputDefinition(), Command\getAliases(), Command\getDefinition(), Command\getDescription(), Command\getName(), Command\getProcessedHelp(), Command\getSynopsis(), Command\getUsages(), Command\mergeApplicationDefinition(), Helper\width(), et MarkdownDescriptor\write().

Référencé par MarkdownDescriptor\describeApplication().

◆ describeInputArgument()

describeInputArgument | ( | InputArgument | $argument,
 |  | array | $options = []
 | ) |  |
protected

{}

Références InputArgument\getDefault(), InputArgument\getDescription(), InputArgument\getName(), InputArgument\isArray(), InputArgument\isRequired(), et MarkdownDescriptor\write().

Référencé par MarkdownDescriptor\describeInputDefinition().

◆ describeInputDefinition()

describeInputDefinition | ( | InputDefinition | $definition,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $option, MarkdownDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputOption(), InputDefinition\getArguments(), InputDefinition\getOptions(), null, et MarkdownDescriptor\write().

Référencé par MarkdownDescriptor\describeCommand().

◆ describeInputOption()

describeInputOption | ( | InputOption | $option,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $name, $option, InputOption\getDescription(), et MarkdownDescriptor\write().

Référencé par MarkdownDescriptor\describeInputDefinition().

◆ getApplicationTitle()

getApplicationTitle ( Application $application )
private

Références Application\getName(), et Application\getVersion().

Référencé par MarkdownDescriptor\describeApplication().

◆ write()

write | ( | string | $content,
 |  | bool | $decorated = true
 | ) |  |
protected

{}

Références $content.

Référencé par MarkdownDescriptor\describeApplication(), MarkdownDescriptor\describeCommand(), MarkdownDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputDefinition(), et MarkdownDescriptor\describeInputOption().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MarkdownDescriptor.php


Joomla CMS: Référence de la classe TextDescriptor

  • Symfony
  • Component
  • Console
  • Descriptor
  • TextDescriptor
Fonctions membres protégées | Fonctions membres privées
Référence de la classe TextDescriptor
+ Graphe d'héritage de TextDescriptor:
Descriptor DescriptorInterface TextDescriptor

Fonctions membres protégées

describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Fonctions membres protégées hérités de Descriptor
write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])

Fonctions membres privées

writeText (string $content, array $options=[])
getCommandAliasesText (Command $command)
formatDefaultValue ($default)
getColumnWidth (array $commands)
calculateTotalWidthForOptions (array $options)

Membres hérités additionnels

- Fonctions membres publiques hérités de Descriptor
describe (OutputInterface $output, object $object, array $options=[])
- Attributs protégés hérités de Descriptor
$output

Description détaillée

Text descriptor.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ calculateTotalWidthForOptions()

calculateTotalWidthForOptions ( array $options )
private
Paramètres
InputOption[] $options

Références $option, $options, elseif, et Helper\width().

Référencé par TextDescriptor\describeInputDefinition(), et TextDescriptor\describeInputOption().

◆ describeApplication()

describeApplication | ( | Application | $application,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $description, $name, $namespace, $options, $width, TextDescriptor\describeInputDefinition(), TextDescriptor\getColumnWidth(), TextDescriptor\getCommandAliasesText(), Application\getDefinition(), Application\getHelp(), ApplicationDescription\GLOBAL_NAMESPACE, null, Helper\width(), et TextDescriptor\writeText().

◆ describeCommand()

describeCommand | ( | Command | $command,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $description, $options, TextDescriptor\describeInputDefinition(), OutputFormatter\escape(), Command\getAliases(), Command\getDefinition(), Command\getDescription(), Command\getProcessedHelp(), Command\getSynopsis(), Command\getUsages(), Command\mergeApplicationDefinition(), et TextDescriptor\writeText().

◆ describeInputArgument()

describeInputArgument | ( | InputArgument | $argument,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $default, $options, TextDescriptor\formatDefaultValue(), InputArgument\getDefault(), InputArgument\getDescription(), InputArgument\getName(), null, Helper\width(), et TextDescriptor\writeText().

Référencé par TextDescriptor\describeInputDefinition().

◆ describeInputDefinition()

describeInputDefinition | ( | InputDefinition | $definition,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $option, $options, TextDescriptor\calculateTotalWidthForOptions(), TextDescriptor\describeInputArgument(), TextDescriptor\describeInputOption(), InputDefinition\getArguments(), InputDefinition\getOptions(), Helper\width(), et TextDescriptor\writeText().

Référencé par TextDescriptor\describeApplication(), TextDescriptor\describeCommand(), TextDescriptor\describeConsoleCommand(), et TextDescriptor\describeJoomlaApplication().

◆ describeInputOption()

describeInputOption | ( | InputOption | $option,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $default, $option, $options, $value, TextDescriptor\calculateTotalWidthForOptions(), TextDescriptor\formatDefaultValue(), InputOption\getDefault(), null, Helper\width(), et TextDescriptor\writeText().

Référencé par TextDescriptor\describeInputDefinition().

◆ formatDefaultValue()

formatDefaultValue ( $default )
private

Formats input option/argument default value.

Paramètres
mixed $default

Références $default, $key, $value, elseif, et OutputFormatter\escape().

Référencé par TextDescriptor\describeInputArgument(), et TextDescriptor\describeInputOption().

◆ getColumnWidth()

getColumnWidth ( array $commands )
private
Paramètres
array<Command|string> $commands

Références Helper\width().

Référencé par TextDescriptor\describeApplication().

◆ getCommandAliasesText()

getCommandAliasesText ( Command $command )
private

Formats command aliases to show them in the command description.

Références $text, et Command\getAliases().

Référencé par TextDescriptor\describeApplication().

◆ writeText()

writeText | ( | string | $content,
 |  | array | $options = []
 | ) |  |
private

{}

Références $content, $options, et Descriptor\write().

Référencé par TextDescriptor\describeApplication(), TextDescriptor\describeCommand(), TextDescriptor\describeInputArgument(), TextDescriptor\describeInputDefinition(), et TextDescriptor\describeInputOption().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Descriptor/TextDescriptor.php


Joomla CMS: Référence de la classe XmlDescriptor

  • Symfony
  • Component
  • Console
  • Descriptor
  • XmlDescriptor
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées
Référence de la classe XmlDescriptor
+ Graphe d'héritage de XmlDescriptor:
Descriptor DescriptorInterface

Fonctions membres publiques

getInputDefinitionDocument (InputDefinition $definition)
getCommandDocument (Command $command, bool $short=false)
getApplicationDocument (Application $application, string $namespace=null, bool $short=false)
- Fonctions membres publiques hérités de Descriptor
describe (OutputInterface $output, object $object, array $options=[])

Fonctions membres protégées

describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])
- Fonctions membres protégées hérités de Descriptor
write (string $content, bool $decorated=false)
describeInputArgument (InputArgument $argument, array $options=[])
describeInputOption (InputOption $option, array $options=[])
describeInputDefinition (InputDefinition $definition, array $options=[])
describeCommand (Command $command, array $options=[])
describeApplication (Application $application, array $options=[])

Fonctions membres privées

appendDocument (\DOMNode $parentNode, \DOMNode $importedParent)
writeDocument (\DOMDocument $dom)
getInputArgumentDocument (InputArgument $argument)
getInputOptionDocument (InputOption $option)

Membres hérités additionnels

- Attributs protégés hérités de Descriptor
$output

Description détaillée

XML descriptor.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ appendDocument()

appendDocument | ( | \DOMNode | $parentNode,
 |  | \DOMNode | $importedParent
 | ) |  |
private

Appends document children to parent node.

Référencé par XmlDescriptor\getApplicationDocument(), XmlDescriptor\getCommandDocument(), et XmlDescriptor\getInputDefinitionDocument().

◆ describeApplication()

describeApplication | ( | Application | $application,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, XmlDescriptor\getApplicationDocument(), null, et XmlDescriptor\writeDocument().

◆ describeCommand()

describeCommand | ( | Command | $command,
 |  | array | $options = []
 | ) |  |
protected

{}

Références $options, XmlDescriptor\getCommandDocument(), et XmlDescriptor\writeDocument().

◆ describeInputArgument()

describeInputArgument | ( | InputArgument | $argument,
 |  | array | $options = []
 | ) |  |
protected

{}

Références XmlDescriptor\getInputArgumentDocument(), et XmlDescriptor\writeDocument().

◆ describeInputDefinition()

describeInputDefinition | ( | InputDefinition | $definition,
 |  | array | $options = []
 | ) |  |
protected

{}

Références XmlDescriptor\getInputDefinitionDocument(), et XmlDescriptor\writeDocument().

◆ describeInputOption()

describeInputOption | ( | InputOption | $option,
 |  | array | $options = []
 | ) |  |
protected

{}

Références XmlDescriptor\getInputOptionDocument(), et XmlDescriptor\writeDocument().

◆ getApplicationDocument()

getApplicationDocument | ( | Application | $application,
 |  | string | $namespace = null,
 |  | bool | $short = false
 | ) |  |

Références $description, $name, $namespace, XmlDescriptor\appendDocument(), XmlDescriptor\getCommandDocument(), Application\getName(), et Application\getVersion().

Référencé par XmlDescriptor\describeApplication().

◆ getCommandDocument()

getCommandDocument | ( | Command | $command,
 |  | bool | $short = false
 | ) |  |

Références XmlDescriptor\appendDocument(), Command\getAliases(), Command\getDefinition(), Command\getDescription(), XmlDescriptor\getInputDefinitionDocument(), Command\getName(), Command\getProcessedHelp(), Command\getSynopsis(), Command\getUsages(), Command\isHidden(), et Command\mergeApplicationDefinition().

Référencé par XmlDescriptor\describeCommand(), et XmlDescriptor\getApplicationDocument().

◆ getInputArgumentDocument()

getInputArgumentDocument ( InputArgument $argument )
private

Références $default, InputArgument\getDefault(), InputArgument\getDescription(), InputArgument\getName(), InputArgument\isArray(), et InputArgument\isRequired().

Référencé par XmlDescriptor\describeInputArgument(), et XmlDescriptor\getInputDefinitionDocument().

◆ getInputDefinitionDocument()

getInputDefinitionDocument ( InputDefinition $definition )

Références $option, XmlDescriptor\appendDocument(), InputDefinition\getArguments(), XmlDescriptor\getInputArgumentDocument(), XmlDescriptor\getInputOptionDocument(), et InputDefinition\getOptions().

Référencé par XmlDescriptor\describeInputDefinition(), et XmlDescriptor\getCommandDocument().

◆ getInputOptionDocument()

getInputOptionDocument ( InputOption $option )
private

Références $default, et $option.

Référencé par XmlDescriptor\describeInputOption(), et XmlDescriptor\getInputDefinitionDocument().

◆ writeDocument()

writeDocument ( \DOMDocument $dom )
private

Writes DOM document.

Références Descriptor\write().

Référencé par XmlDescriptor\describeApplication(), XmlDescriptor\describeCommand(), XmlDescriptor\describeInputArgument(), XmlDescriptor\describeInputDefinition(), et XmlDescriptor\describeInputOption().

La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlDescriptor.php


Joomla CMS: Référence de la classe ConsoleCommandEvent

  • Symfony
  • Component
  • Console
  • Event
  • ConsoleCommandEvent
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe ConsoleCommandEvent
+ Graphe d'héritage de ConsoleCommandEvent:
ConsoleEvent

Fonctions membres publiques

disableCommand ()
enableCommand ()
commandShouldRun ()
- Fonctions membres publiques hérités de ConsoleEvent
__construct (?Command $command, InputInterface $input, OutputInterface $output)
getCommand ()
getInput ()
getOutput ()

Champs de données

const RETURN_CODE_DISABLED = 113

Attributs privés

$commandShouldRun = true

Membres hérités additionnels

- Attributs protégés hérités de ConsoleEvent
$command

Description détaillée

Allows to do things before the command is executed, like skipping the command or changing the input.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ commandShouldRun()

commandShouldRun ( )

Returns true if the command is runnable, false otherwise.

Références ConsoleCommandEvent\$commandShouldRun.

Référencé par ConsoleCommandEvent\disableCommand(), et ConsoleCommandEvent\enableCommand().

◆ disableCommand()

disableCommand ( )

Disables the command, so it won't be run.

Références ConsoleCommandEvent\commandShouldRun().

◆ enableCommand()

enableCommand ( )

Références ConsoleCommandEvent\commandShouldRun().

Documentation des champs

◆ $commandShouldRun

$commandShouldRun = true
private

Indicates if the command should be run or skipped.

Référencé par ConsoleCommandEvent\commandShouldRun().

◆ RETURN_CODE_DISABLED

const RETURN_CODE_DISABLED = 113

The return code for skipped commands, this will also be passed into the terminate event.

Référencé par Application\doRunCommand().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleCommandEvent.php


Joomla CMS: Référence de la classe ConsoleErrorEvent

  • Symfony
  • Component
  • Console
  • Event
  • ConsoleErrorEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ConsoleErrorEvent
+ Graphe d'héritage de ConsoleErrorEvent:
ConsoleEvent

Fonctions membres publiques

__construct (InputInterface $input, OutputInterface $output, \Throwable $error, Command $command=null)
getError ()
setError (\Throwable $error)
setExitCode (int $exitCode)
getExitCode ()
- Fonctions membres publiques hérités de ConsoleEvent
__construct (?Command $command, InputInterface $input, OutputInterface $output)
getCommand ()
getInput ()
getOutput ()

Attributs privés

$error
$exitCode

Membres hérités additionnels

- Attributs protégés hérités de ConsoleEvent
$command

Description détaillée

Allows to handle throwables thrown while running a command.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | InputInterface | $input,
 |  | OutputInterface | $output,
 |  | \Throwable | $error,
 |  | Command | $command = null
 | ) |  |

Références ConsoleEvent\$command, ConsoleErrorEvent\$error, ConsoleEvent\$input, ConsoleEvent\$output, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getError()

getError ( )

Références ConsoleErrorEvent\$error.

Référencé par ErrorListener\onConsoleError().

◆ getExitCode()

getExitCode ( )

◆ setError()

setError ( \Throwable $error )

Références ConsoleErrorEvent\$error.

◆ setExitCode()

setExitCode ( int $exitCode )

Références ConsoleErrorEvent\$exitCode, et $r.

Documentation des champs

◆ $error

$error
private

Référencé par ConsoleErrorEvent\__construct(), ConsoleErrorEvent\getError(), et ConsoleErrorEvent\setError().

◆ $exitCode

$exitCode
private

Référencé par ConsoleErrorEvent\setExitCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleErrorEvent.php


Joomla CMS: Référence de la classe ConsoleEvent

  • Symfony
  • Component
  • Console
  • Event
  • ConsoleEvent
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe ConsoleEvent
+ Graphe d'héritage de ConsoleEvent:
ConsoleCommandEvent ConsoleErrorEvent ConsoleSignalEvent ConsoleTerminateEvent

Fonctions membres publiques

__construct (?Command $command, InputInterface $input, OutputInterface $output)
getCommand ()
getInput ()
getOutput ()

Attributs protégés

$command

Attributs privés

$input
$output

Description détaillée

Allows to inspect input and output of a command.

Auteur
Francesco Levorato git@f.nosp@m.levo.nosp@m.ur.ne.nosp@m.t

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Command | $command,
 |  | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Références ConsoleEvent\$command, ConsoleEvent\$input, et ConsoleEvent\$output.

Documentation des fonctions membres

◆ getCommand()

getCommand ( )

Gets the command that is executed.

Renvoie
Command|null

Références ConsoleEvent\$command.

Référencé par ErrorListener\getInputString().

◆ getInput()

getInput ( )

Gets the input instance.

Renvoie
InputInterface

Références ConsoleEvent\$input.

Référencé par ErrorListener\getInputString().

◆ getOutput()

getOutput ( )

Gets the output instance.

Renvoie
OutputInterface

Références ConsoleEvent\$output.

Documentation des champs

◆ $command

$command
protected

Référencé par ConsoleSignalEvent\__construct(), ConsoleTerminateEvent\__construct(), ConsoleErrorEvent\__construct(), ConsoleEvent\__construct(), et ConsoleEvent\getCommand().

◆ $input

$input
private

Référencé par ConsoleSignalEvent\__construct(), ConsoleTerminateEvent\__construct(), ConsoleErrorEvent\__construct(), ConsoleEvent\__construct(), et ConsoleEvent\getInput().

◆ $output

$output
private

Référencé par ConsoleSignalEvent\__construct(), ConsoleTerminateEvent\__construct(), ConsoleErrorEvent\__construct(), ConsoleEvent\__construct(), et ConsoleEvent\getOutput().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Event/ConsoleEvent.php


Joomla CMS: Référence de la classe ConsoleSignalEvent

  • Symfony
  • Component
  • Console
  • Event
  • ConsoleSignalEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ConsoleSignalEvent
+ Graphe d'héritage de ConsoleSignalEvent:
ConsoleEvent

Fonctions membres publiques

__construct (Command $command, InputInterface $input, OutputInterface $output, int $handlingSignal)
getHandlingSignal ()
- Fonctions membres publiques hérités de ConsoleEvent
__construct (?Command $command, InputInterface $input, OutputInterface $output)
getCommand ()
getInput ()
getOutput ()

Attributs privés

$handlingSignal

Membres hérités additionnels

- Attributs protégés hérités de ConsoleEvent
$command

Description détaillée

Auteur
marie marie.nosp@m.@use.nosp@m.rs.no.nosp@m.repl.nosp@m.y.git.nosp@m.hub..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Command | $command,
 |  | InputInterface | $input,
 |  | OutputInterface | $output,
 |  | int | $handlingSignal
 | ) |  |

Références ConsoleEvent\$command, ConsoleSignalEvent\$handlingSignal, ConsoleEvent\$input, ConsoleEvent\$output, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getHandlingSignal()

getHandlingSignal ( )

Références ConsoleSignalEvent\$handlingSignal.

Documentation des champs

◆ $handlingSignal

$handlingSignal
private

Référencé par ConsoleSignalEvent\__construct(), et ConsoleSignalEvent\getHandlingSignal().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleSignalEvent.php


Joomla CMS: Référence de la classe ConsoleTerminateEvent

  • Symfony
  • Component
  • Console
  • Event
  • ConsoleTerminateEvent
Fonctions membres publiques | Attributs privés
Référence de la classe ConsoleTerminateEvent
+ Graphe d'héritage de ConsoleTerminateEvent:
ConsoleEvent

Fonctions membres publiques

__construct (Command $command, InputInterface $input, OutputInterface $output, int $exitCode)
setExitCode (int $exitCode)
getExitCode ()
- Fonctions membres publiques hérités de ConsoleEvent
__construct (?Command $command, InputInterface $input, OutputInterface $output)
getCommand ()
getInput ()
getOutput ()

Attributs privés

$exitCode

Membres hérités additionnels

- Attributs protégés hérités de ConsoleEvent
$command

Description détaillée

Allows to manipulate the exit code of a command after its execution.

Auteur
Francesco Levorato git@f.nosp@m.levo.nosp@m.ur.ne.nosp@m.t

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Command | $command,
 |  | InputInterface | $input,
 |  | OutputInterface | $output,
 |  | int | $exitCode
 | ) |  |

Références ConsoleEvent\$command, ConsoleEvent\$input, ConsoleEvent\$output, Symfony\Contracts\Service\__construct(), et ConsoleTerminateEvent\setExitCode().

Documentation des fonctions membres

◆ getExitCode()

getExitCode ( )

Références ConsoleTerminateEvent\$exitCode.

Référencé par ErrorListener\onConsoleTerminate().

◆ setExitCode()

setExitCode ( int $exitCode )

Références ConsoleTerminateEvent\$exitCode.

Référencé par ConsoleTerminateEvent\__construct().

Documentation des champs

◆ $exitCode

$exitCode
private

Référencé par ConsoleTerminateEvent\getExitCode(), et ConsoleTerminateEvent\setExitCode().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleTerminateEvent.php


Joomla CMS: Référence de la classe ErrorListener

  • Symfony
  • Component
  • Console
  • EventListener
  • ErrorListener
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe ErrorListener
+ Graphe d'héritage de ErrorListener:

Fonctions membres publiques

__construct (LoggerInterface $logger=null)
onConsoleError (ConsoleErrorEvent $event)
onConsoleTerminate (ConsoleTerminateEvent $event)

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres privées statiques

static getInputString (ConsoleEvent $event)

Attributs privés

$logger

Description détaillée

Auteur
James Halsall james.nosp@m..t.h.nosp@m.alsal.nosp@m.l@go.nosp@m.oglem.nosp@m.ail..nosp@m.com
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( LoggerInterface $logger = null )

Références ErrorListener\$logger.

Documentation des fonctions membres

◆ getInputString()

static getInputString ( ConsoleEvent $event )
staticprivate

Références $input, ConsoleEvent\getCommand(), ConsoleEvent\getInput(), et null.

Référencé par ErrorListener\onConsoleError(), et ErrorListener\onConsoleTerminate().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Références ConsoleEvents\ERROR, et ConsoleEvents\TERMINATE.

◆ onConsoleError()

onConsoleError ( ConsoleErrorEvent $event )

Références ConsoleErrorEvent\getError(), ErrorListener\getInputString(), et null.

◆ onConsoleTerminate()

onConsoleTerminate ( ConsoleTerminateEvent $event )

Références ConsoleTerminateEvent\getExitCode(), ErrorListener\getInputString(), et null.

Documentation des champs

◆ $logger

$logger
private

Référencé par ErrorListener\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ErrorListener.php


Joomla CMS: Référence de la classe CommandNotFoundException

  • Symfony
  • Component
  • Console
  • Exception
  • CommandNotFoundException
Fonctions membres publiques | Attributs privés
Référence de la classe CommandNotFoundException
+ Graphe d'héritage de CommandNotFoundException:
InvalidArgumentException ExceptionInterface ExceptionInterface NamespaceNotFoundException NamespaceNotFoundException

Fonctions membres publiques

__construct (string $message, array $alternatives=[], int $code=0, \Throwable $previous=null)
getAlternatives ()

Attributs privés

$alternatives

Description détaillée

Represents an incorrect command name typed in the console.

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | array | $alternatives = [],
 |  | int | $code = 0,
 |  | \Throwable | $previous = null
 | ) |  |
Paramètres
string | $message | Exception message to throw
string[] | $alternatives List of similar defined names
int | $code | Exception code
\Throwable | null | $previous | Previous exception used for the exception chaining

Références CommandNotFoundException\$alternatives, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAlternatives()

getAlternatives ( )
Renvoie
string[]

Références CommandNotFoundException\$alternatives.

Documentation des champs

◆ $alternatives

$alternatives
private

Référencé par CommandNotFoundException\__construct(), et CommandNotFoundException\getAlternatives().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CommandNotFoundException.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Symfony
  • Component
  • Console
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
CommandNotFoundException InvalidArgumentException InvalidOptionException LogicException MissingInputException RuntimeException NamespaceNotFoundException NamespaceNotFoundException CommandNotFoundException InvalidOptionException MissingInputException NamespaceNotFoundException NamespaceNotFoundException

Description détaillée

ExceptionInterface.

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/console/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Symfony
  • Component
  • Console
  • Exception
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
ExceptionInterface CommandNotFoundException InvalidOptionException NamespaceNotFoundException NamespaceNotFoundException

Description détaillée

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Exception/InvalidArgumentException.php


Joomla CMS: Référence de la classe InvalidOptionException

  • Symfony
  • Component
  • Console
  • Exception
  • InvalidOptionException
Référence de la classe InvalidOptionException
+ Graphe d'héritage de InvalidOptionException:
InvalidArgumentException ExceptionInterface ExceptionInterface

Description détaillée

Represents an incorrect option name typed in the console.

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidOptionException.php


Joomla CMS: Référence de la classe LogicException

  • Symfony
  • Component
  • Console
  • Exception
  • LogicException
Référence de la classe LogicException
+ Graphe d'héritage de LogicException:
ExceptionInterface

Description détaillée

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et
La documentation de cette classe a été générée à partir du fichier suivant :
  • LogicException.php


Joomla CMS: Référence de la classe MissingInputException

  • Symfony
  • Component
  • Console
  • Exception
  • MissingInputException
Référence de la classe MissingInputException
+ Graphe d'héritage de MissingInputException:
RuntimeException ExceptionInterface ExceptionInterface

Description détaillée

Represents failure to read input from stdin.

Auteur
Gabriel Ostrolucký gabri.nosp@m.el.o.nosp@m.strol.nosp@m.ucky.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • MissingInputException.php


Joomla CMS: Référence de la classe NamespaceNotFoundException

  • Symfony
  • Component
  • Console
  • Exception
  • NamespaceNotFoundException
Référence de la classe NamespaceNotFoundException
+ Graphe d'héritage de NamespaceNotFoundException:
CommandNotFoundException InvalidArgumentException ExceptionInterface ExceptionInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de CommandNotFoundException
__construct (string $message, array $alternatives=[], int $code=0, \Throwable $previous=null)
getAlternatives ()

Description détaillée

Represents an incorrect namespace typed in the console.

Auteur
Pierre du Plessis pdple.nosp@m.s@gm.nosp@m.ail.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Exception/NamespaceNotFoundException.php


Joomla CMS: Référence de la classe RuntimeException

  • Symfony
  • Component
  • Console
  • Exception
  • RuntimeException
Référence de la classe RuntimeException
+ Graphe d'héritage de RuntimeException:
ExceptionInterface MissingInputException

Description détaillée

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et
La documentation de cette classe a été générée à partir du fichier suivant :
  • console/Exception/RuntimeException.php


Joomla CMS: Référence de la classe NullOutputFormatter

  • Symfony
  • Component
  • Console
  • Formatter
  • NullOutputFormatter
Fonctions membres publiques | Attributs privés
Référence de la classe NullOutputFormatter
+ Graphe d'héritage de NullOutputFormatter:
OutputFormatterInterface

Fonctions membres publiques

format (?string $message)
getStyle (string $name)
hasStyle (string $name)
isDecorated ()
setDecorated (bool $decorated)
setStyle (string $name, OutputFormatterStyleInterface $style)

Attributs privés

$style

Description détaillée

Auteur
Tien Xuan Vo tien..nosp@m.xuan.nosp@m..vo@g.nosp@m.mail.nosp@m..com

Documentation des fonctions membres

◆ format()

format ( ?string $message )

{Formats a message according to the given styles.

Renvoie
string|null
}

Implémente OutputFormatterInterface.

Références null.

◆ getStyle()

getStyle ( string $name )

{Gets style options from style with specified name.

Renvoie
OutputFormatterStyleInterface
Exceptions
}

Implémente OutputFormatterInterface.

◆ hasStyle()

hasStyle ( string $name )

{Checks if output formatter has style with specified name.

Renvoie
bool
}

Implémente OutputFormatterInterface.

◆ isDecorated()

isDecorated ( )

{Whether the output will decorate messages.

Renvoie
bool
}

Implémente OutputFormatterInterface.

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputFormatterInterface.

◆ setStyle()

setStyle | ( | string | $name,
 |  | OutputFormatterStyleInterface | $style
 | ) |  |

{Sets a new style.}

Implémente OutputFormatterInterface.

Documentation des champs

◆ $style

$style
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • NullOutputFormatter.php


Joomla CMS: Référence de la classe NullOutputFormatterStyle

  • Symfony
  • Component
  • Console
  • Formatter
  • NullOutputFormatterStyle
Fonctions membres publiques
Référence de la classe NullOutputFormatterStyle
+ Graphe d'héritage de NullOutputFormatterStyle:
OutputFormatterStyleInterface

Fonctions membres publiques

apply (string $text)
setBackground (string $color=null)
setForeground (string $color=null)
setOption (string $option)
setOptions (array $options)
unsetOption (string $option)

Description détaillée

Auteur
Tien Xuan Vo tien..nosp@m.xuan.nosp@m..vo@g.nosp@m.mail.nosp@m..com

Documentation des fonctions membres

◆ apply()

apply ( string $text )

{Applies the style to a given text.

Renvoie
string
}

Implémente OutputFormatterStyleInterface.

Références $text.

◆ setBackground()

setBackground ( string $color = null )

{Sets style background color.}

Implémente OutputFormatterStyleInterface.

◆ setForeground()

setForeground ( string $color = null )

{Sets style foreground color.}

Implémente OutputFormatterStyleInterface.

◆ setOption()

setOption ( string $option )

{Sets some specific style option.}

Implémente OutputFormatterStyleInterface.

◆ setOptions()

setOptions ( array $options )

{Sets multiple style options at once.}

Implémente OutputFormatterStyleInterface.

◆ unsetOption()

unsetOption ( string $option )

{Unsets some specific style option.}

Implémente OutputFormatterStyleInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NullOutputFormatterStyle.php


Joomla CMS: Référence de la classe OutputFormatter

  • Symfony
  • Component
  • Console
  • Formatter
  • OutputFormatter
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe OutputFormatter
+ Graphe d'héritage de OutputFormatter:
WrappableOutputFormatterInterface OutputFormatterInterface

Fonctions membres publiques

__clone ()
__construct (bool $decorated=false, array $styles=[])
setDecorated (bool $decorated)
isDecorated ()
setStyle (string $name, OutputFormatterStyleInterface $style)
hasStyle (string $name)
getStyle (string $name)
format (?string $message)
formatAndWrap (?string $message, int $width)
getStyleStack ()

Fonctions membres publiques statiques

static | escape (string $text)
static | escapeTrailingBackslash (string $text)

Fonctions membres privées

createStyleFromString (string $string)
applyCurrentStyle (string $text, string $current, int $width, int &$currentLineLength)

Attributs privés

$decorated
$styles = []
$styleStack

Description détaillée

Formatter class for console output.

Auteur
Konstantin Kudryashov ever..nosp@m.zet@.nosp@m.gmail.nosp@m..com
Roland Franssen frans.nosp@m.sen..nosp@m.rolan.nosp@m.d@gm.nosp@m.ail.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | bool | $decorated = false,
 |  | array | $styles = []
 | ) |  |

Initializes console output formatter.

Paramètres
OutputFormatterStyleInterface[] $styles Array of "name => FormatterStyle" instances

Références OutputFormatter\$decorated, $name, $style, OutputFormatter\$styles, et OutputFormatter\setStyle().

Documentation des fonctions membres

◆ __clone()

__clone ( )

Références $key, OutputFormatter\$styleStack, et $value.

◆ applyCurrentStyle()

applyCurrentStyle | ( | string | $text,
 |  | string | $current,
 |  | int | $width,
 |  | int & | $currentLineLength
 | ) |  |
private

Applies current style from stack to text, if must be applied.

Références $i, $prefix, $text, $width, et OutputFormatter\isDecorated().

Référencé par OutputFormatter\formatAndWrap().

◆ createStyleFromString()

createStyleFromString ( string $string )
private

Tries to create new style instance from string.

Références $option, $options, $style, $url, elseif, et null.

Référencé par OutputFormatter\formatAndWrap().

◆ escape()

static escape ( string $text )
static

Escapes "<" and ">" special chars in given text.

Renvoie
string

Références $text.

Référencé par SymfonyStyle\createBlock(), TextDescriptor\describeCommand(), Application\doRenderThrowable(), FormatterHelper\formatBlock(), TextDescriptor\formatDefaultValue(), Application\renderThrowable(), et SymfonyQuestionHelper\writePrompt().

◆ escapeTrailingBackslash()

static escapeTrailingBackslash ( string $text )
static

Escapes trailing "\" in given text.

Références $text.

Référencé par QuestionHelper\autocomplete(), SymfonyStyle\section(), SymfonyStyle\title(), et SymfonyQuestionHelper\writePrompt().

◆ format()

format ( ?string $message )

{Formats a message according to the given styles.

Renvoie
string|null
}

Implémente OutputFormatterInterface.

Références OutputFormatter\formatAndWrap().

◆ formatAndWrap()

formatAndWrap | ( | ?string | $message,
 |  | int | $width
 | ) |  |

{Formats a message according to the given styles, wrapping at $width (0 means no wrapping).}

Implémente WrappableOutputFormatterInterface.

Références $i, $message, Joomla\Database\Query\$offset, $output, $style, $text, $width, OutputFormatter\applyCurrentStyle(), OutputFormatter\createStyleFromString(), elseif, et null.

Référencé par OutputFormatter\format().

◆ getStyle()

getStyle ( string $name )

{Gets style options from style with specified name.

Renvoie
OutputFormatterStyleInterface
Exceptions
}

Implémente OutputFormatterInterface.

Références $name, et OutputFormatter\hasStyle().

◆ getStyleStack()

getStyleStack ( )
Renvoie
OutputFormatterStyleStack

Références OutputFormatter\$styleStack.

◆ hasStyle()

hasStyle ( string $name )

{Checks if output formatter has style with specified name.

Renvoie
bool
}

Implémente OutputFormatterInterface.

Références $name.

Référencé par OutputFormatter\getStyle().

◆ isDecorated()

isDecorated ( )

{Whether the output will decorate messages.

Renvoie
bool
}

Implémente OutputFormatterInterface.

Références OutputFormatter\$decorated.

Référencé par OutputFormatter\applyCurrentStyle().

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputFormatterInterface.

Références OutputFormatter\$decorated.

◆ setStyle()

setStyle | ( | string | $name,
 |  | OutputFormatterStyleInterface | $style
 | ) |  |

{Sets a new style.}

Implémente OutputFormatterInterface.

Références $name, et $style.

Référencé par OutputFormatter\__construct().

Documentation des champs

◆ $decorated

$decorated
private

Référencé par OutputFormatter\__construct(), OutputFormatter\isDecorated(), et OutputFormatter\setDecorated().

◆ $styles

$styles = []
private

Référencé par OutputFormatter\__construct().

◆ $styleStack

$styleStack
private

Référencé par OutputFormatter\__clone(), et OutputFormatter\getStyleStack().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OutputFormatter.php


Joomla CMS: Référence de l'interface OutputFormatterInterface

  • Symfony
  • Component
  • Console
  • Formatter
  • OutputFormatterInterface
Fonctions membres publiques
Référence de l'interface OutputFormatterInterface
+ Graphe d'héritage de OutputFormatterInterface:
NullOutputFormatter WrappableOutputFormatterInterface OutputFormatter

Fonctions membres publiques

setDecorated (bool $decorated)
isDecorated ()
setStyle (string $name, OutputFormatterStyleInterface $style)
hasStyle (string $name)
getStyle (string $name)
format (?string $message)

Description détaillée

Formatter interface for console output.

Auteur
Konstantin Kudryashov ever..nosp@m.zet@.nosp@m.gmail.nosp@m..com

Documentation des fonctions membres

◆ format()

format ( ?string $message )

Formats a message according to the given styles.

Renvoie
string|null

Implémenté dans OutputFormatter, et NullOutputFormatter.

Référencé par Helper\removeDecoration().

◆ getStyle()

getStyle ( string $name )

Gets style options from style with specified name.

Renvoie
OutputFormatterStyleInterface
Exceptions

Implémenté dans OutputFormatter, et NullOutputFormatter.

◆ hasStyle()

hasStyle ( string $name )

Checks if output formatter has style with specified name.

Renvoie
bool

Implémenté dans OutputFormatter, et NullOutputFormatter.

◆ isDecorated()

isDecorated ( )

Whether the output will decorate messages.

Renvoie
bool

Implémenté dans OutputFormatter, et NullOutputFormatter.

Référencé par Helper\removeDecoration().

◆ setDecorated()

setDecorated ( bool $decorated )

Sets the decorated flag.

Implémenté dans OutputFormatter, et NullOutputFormatter.

Référencé par Helper\removeDecoration().

◆ setStyle()

setStyle | ( | string | $name,
 |  | OutputFormatterStyleInterface | $style
 | ) |  |

Sets a new style.

Implémenté dans OutputFormatter, et NullOutputFormatter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • OutputFormatterInterface.php


Joomla CMS: Référence de la classe OutputFormatterStyle

  • Symfony
  • Component
  • Console
  • Formatter
  • OutputFormatterStyle
Fonctions membres publiques | Attributs privés
Référence de la classe OutputFormatterStyle
+ Graphe d'héritage de OutputFormatterStyle:
OutputFormatterStyleInterface

Fonctions membres publiques

__construct (string $foreground=null, string $background=null, array $options=[])
setForeground (string $color=null)
setBackground (string $color=null)
setHref (string $url)
setOption (string $option)
unsetOption (string $option)
setOptions (array $options)
apply (string $text)

Attributs privés

$color
$foreground
$background
$options
$href
$handlesHrefGracefully

Description détaillée

Formatter style class for defining styles.

Auteur
Konstantin Kudryashov ever..nosp@m.zet@.nosp@m.gmail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $foreground = null,
 |  | string | $background = null,
 |  | array | $options = []
 | ) |  |

Initializes output formatter style.

Paramètres
string | null | $foreground | The style foreground color name
string | null | $background | The style background color name

Références OutputFormatterStyle\$background, OutputFormatterStyle\$foreground, OutputFormatterStyle\$options, et color.

Documentation des fonctions membres

◆ apply()

apply ( string $text )

{Applies the style to a given text.

Renvoie
string
}

Implémente OutputFormatterStyleInterface.

Références $text, color, et null.

◆ setBackground()

setBackground ( string $color = null )

{Sets style background color.}

Implémente OutputFormatterStyleInterface.

Références OutputFormatterStyle\$color, et color.

◆ setForeground()

setForeground ( string $color = null )

{Sets style foreground color.}

Implémente OutputFormatterStyleInterface.

Références OutputFormatterStyle\$color, et color.

◆ setHref()

setHref ( string $url )

Références $url.

◆ setOption()

setOption ( string $option )

{Sets some specific style option.}

Implémente OutputFormatterStyleInterface.

Références $option, et color.

◆ setOptions()

setOptions ( array $options )

{Sets multiple style options at once.}

Implémente OutputFormatterStyleInterface.

Références OutputFormatterStyle\$options, et color.

◆ unsetOption()

unsetOption ( string $option )

{Unsets some specific style option.}

Implémente OutputFormatterStyleInterface.

Références $option, et color.

Documentation des champs

◆ $background

$background
private

Référencé par OutputFormatterStyle\__construct().

◆ $color

$color
private

Référencé par OutputFormatterStyle\setBackground(), et OutputFormatterStyle\setForeground().

◆ $foreground

$foreground
private

Référencé par OutputFormatterStyle\__construct().

◆ $handlesHrefGracefully

$handlesHrefGracefully
private

◆ $href

$href
private

◆ $options

$options
private

Référencé par OutputFormatterStyle\__construct(), et OutputFormatterStyle\setOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OutputFormatterStyle.php


Joomla CMS: Référence de l'interface OutputFormatterStyleInterface

  • Symfony
  • Component
  • Console
  • Formatter
  • OutputFormatterStyleInterface
Fonctions membres publiques
Référence de l'interface OutputFormatterStyleInterface
+ Graphe d'héritage de OutputFormatterStyleInterface:
NullOutputFormatterStyle OutputFormatterStyle

Fonctions membres publiques

setForeground (string $color=null)
setBackground (string $color=null)
setOption (string $option)
unsetOption (string $option)
setOptions (array $options)
apply (string $text)

Description détaillée

Formatter style interface for defining styles.

Auteur
Konstantin Kudryashov ever..nosp@m.zet@.nosp@m.gmail.nosp@m..com

Documentation des fonctions membres

◆ apply()

apply ( string $text )

Applies the style to a given text.

Renvoie
string

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

◆ setBackground()

setBackground ( string $color = null )

Sets style background color.

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

◆ setForeground()

setForeground ( string $color = null )

Sets style foreground color.

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

◆ setOption()

setOption ( string $option )

Sets some specific style option.

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

◆ setOptions()

setOptions ( array $options )

Sets multiple style options at once.

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

◆ unsetOption()

unsetOption ( string $option )

Unsets some specific style option.

Implémenté dans OutputFormatterStyle, et NullOutputFormatterStyle.

La documentation de cette interface a été générée à partir du fichier suivant :
  • OutputFormatterStyleInterface.php


Joomla CMS: Référence de la classe OutputFormatterStyleStack

  • Symfony
  • Component
  • Console
  • Formatter
  • OutputFormatterStyleStack
Fonctions membres publiques | Attributs privés
Référence de la classe OutputFormatterStyleStack
+ Graphe d'héritage de OutputFormatterStyleStack:
ResetInterface

Fonctions membres publiques

__construct (OutputFormatterStyleInterface $emptyStyle=null)
reset ()
push (OutputFormatterStyleInterface $style)
pop (OutputFormatterStyleInterface $style=null)
getCurrent ()
setEmptyStyle (OutputFormatterStyleInterface $emptyStyle)
getEmptyStyle ()

Attributs privés

$styles
$emptyStyle

Description détaillée

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( OutputFormatterStyleInterface $emptyStyle = null )

Références OutputFormatterStyleStack\$emptyStyle, et OutputFormatterStyleStack\reset().

Documentation des fonctions membres

◆ getCurrent()

getCurrent ( )

Computes current style with stacks top codes.

Renvoie
OutputFormatterStyle

Références OutputFormatterStyleStack\$emptyStyle.

◆ getEmptyStyle()

getEmptyStyle ( )
Renvoie
OutputFormatterStyleInterface

Références OutputFormatterStyleStack\$emptyStyle.

◆ pop()

pop ( OutputFormatterStyleInterface $style = null )

Pops a style from the stack.

Renvoie
OutputFormatterStyleInterface
Exceptions
InvalidArgumentException When style tags incorrectly nested

Références OutputFormatterStyleStack\$emptyStyle, $style, et null.

◆ push()

push ( OutputFormatterStyleInterface $style )

Pushes a style in the stack.

Références $style.

◆ reset()

reset ( )

Resets stack (ie. empty internal arrays).

Implémente ResetInterface.

Référencé par OutputFormatterStyleStack\__construct().

◆ setEmptyStyle()

setEmptyStyle ( OutputFormatterStyleInterface $emptyStyle )
Renvoie
$this

Références OutputFormatterStyleStack\$emptyStyle, et $this.

Documentation des champs

◆ $emptyStyle

$emptyStyle
private

Référencé par OutputFormatterStyleStack\__construct(), OutputFormatterStyleStack\getCurrent(), OutputFormatterStyleStack\getEmptyStyle(), OutputFormatterStyleStack\pop(), et OutputFormatterStyleStack\setEmptyStyle().

◆ $styles

$styles
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OutputFormatterStyleStack.php


Joomla CMS: Référence de l'interface WrappableOutputFormatterInterface

  • Symfony
  • Component
  • Console
  • Formatter
  • WrappableOutputFormatterInterface
Fonctions membres publiques
Référence de l'interface WrappableOutputFormatterInterface
+ Graphe d'héritage de WrappableOutputFormatterInterface:
OutputFormatterInterface OutputFormatter

Fonctions membres publiques

formatAndWrap (?string $message, int $width)
- Fonctions membres publiques hérités de OutputFormatterInterface
setDecorated (bool $decorated)
isDecorated ()
setStyle (string $name, OutputFormatterStyleInterface $style)
hasStyle (string $name)
getStyle (string $name)
format (?string $message)

Description détaillée

Formatter interface for console output that supports word wrapping.

Auteur
Roland Franssen frans.nosp@m.sen..nosp@m.rolan.nosp@m.d@gm.nosp@m.ail.c.nosp@m.om

Documentation des fonctions membres

◆ formatAndWrap()

formatAndWrap | ( | ?string | $message,
 |  | int | $width
 | ) |  |

Formats a message according to the given styles, wrapping at $width (0 means no wrapping).

Implémenté dans OutputFormatter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • WrappableOutputFormatterInterface.php


Joomla CMS: Référence de la classe DebugFormatterHelper

  • Symfony
  • Component
  • Console
  • Helper
  • DebugFormatterHelper
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe DebugFormatterHelper
+ Graphe d'héritage de DebugFormatterHelper:
Helper HelperInterface

Fonctions membres publiques

start (string $id, string $message, string $prefix='RUN')
progress (string $id, string $buffer, bool $error=false, string $prefix='OUT', string $errorPrefix='ERR')
stop (string $id, string $message, bool $successful, string $prefix='RES')
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Fonctions membres privées

getBorder (string $id)

Attributs privés

const COLORS = ['black', 'red', 'green', 'yellow', 'blue', 'magenta', 'cyan', 'white', 'default']
$started = []
$count = -1

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

Helps outputting debug information when running an external program from a command.

An external program can be a Process, an HTTP request, or anything else.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ getBorder()

getBorder ( string $id )
private

Références $id.

Référencé par DebugFormatterHelper\progress(), DebugFormatterHelper\start(), et DebugFormatterHelper\stop().

◆ getName()

getName ( )

{Returns the canonical name of this helper.

Renvoie
string
}

Implémente HelperInterface.

◆ progress()

progress | ( | string | $id,
 |  | string | $buffer,
 |  | bool | $error = false,
 |  | string | $prefix = 'OUT',
 |  | string | $errorPrefix = 'ERR'
 | ) |  |

Adds progress to a formatting session.

Renvoie
string

Références $buffer, $id, $message, $prefix, et DebugFormatterHelper\getBorder().

◆ start()

start | ( | string | $id,
 |  | string | $message,
 |  | string | $prefix = 'RUN'
 | ) |  |

Starts a debug formatting session.

Renvoie
string

Références $id, $message, $prefix, et DebugFormatterHelper\getBorder().

◆ stop()

stop | ( | string | $id,
 |  | string | $message,
 |  | bool | $successful,
 |  | string | $prefix = 'RES'
 | ) |  |

Stops a formatting session.

Renvoie
string

Références $id, $message, $prefix, et DebugFormatterHelper\getBorder().

Documentation des champs

◆ $count

$count = -1
private

◆ $started

$started = []
private

◆ COLORS

const COLORS = ['black', 'red', 'green', 'yellow', 'blue', 'magenta', 'cyan', 'white', 'default']
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugFormatterHelper.php


Joomla CMS: Référence de la classe DescriptorHelper

  • Symfony
  • Component
  • Console
  • Helper
  • DescriptorHelper
Fonctions membres publiques | Attributs privés
Référence de la classe DescriptorHelper
+ Graphe d'héritage de DescriptorHelper:
Helper HelperInterface

Fonctions membres publiques

__construct ()
describe (OutputInterface $output, ?object $object, array $options=[])
register (string $format, DescriptorInterface $descriptor)
getName ()
getFormats ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Attributs privés

$descriptors = []

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

This class adds helper method to describe objects in various formats.

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références $this.

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | ?object | $object,
 |  | array | $options = []
 | ) |  |

Describes an object if supported.

Available options are:

  • format: string, the output format name
  • raw_text: boolean, sets output type as raw
Exceptions
InvalidArgumentException when the given format is not supported

Références $options, et $output.

◆ getFormats()

getFormats ( )

◆ getName()

getName ( )

{Returns the canonical name of this helper.

Renvoie
string
}

Implémente HelperInterface.

◆ register()

register | ( | string | $format,
 |  | DescriptorInterface | $descriptor
 | ) |  |

Registers a descriptor.

Renvoie
$this

Références $format, et $this.

Documentation des champs

◆ $descriptors

$descriptors = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/Helper/DescriptorHelper.php


Joomla CMS: Référence de la classe Dumper

  • Symfony
  • Component
  • Console
  • Helper
  • Dumper
Fonctions membres publiques | Attributs privés
Référence de la classe Dumper

Fonctions membres publiques

__construct (OutputInterface $output, CliDumper $dumper=null, ClonerInterface $cloner=null)
__invoke ($var)

Attributs privés

$output
$dumper
$cloner
$handler

Description détaillée

Auteur
Roland Franssen frans.nosp@m.sen..nosp@m.rolan.nosp@m.d@gm.nosp@m.ail.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | OutputInterface | $output,
 |  | CliDumper | $dumper = null,
 |  | ClonerInterface | $cloner = null
 | ) |  |

Références Dumper\$cloner, Dumper\$dumper, Dumper\$output, $this, class, AbstractDumper\DUMP_COMMA_SEPARATOR, AbstractDumper\DUMP_LIGHT_ARRAY, et null.

Documentation des fonctions membres

◆ __invoke()

__invoke ( $var )

Documentation des champs

◆ $cloner

$cloner
private

Référencé par Dumper\__construct().

◆ $dumper

$dumper
private

Référencé par Dumper\__construct().

◆ $handler

$handler
private

◆ $output

$output
private

Référencé par Dumper\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • console/Helper/Dumper.php


Joomla CMS: Référence de la classe FormatterHelper

  • Symfony
  • Component
  • Console
  • Helper
  • FormatterHelper
Fonctions membres publiques
Référence de la classe FormatterHelper
+ Graphe d'héritage de FormatterHelper:
Helper HelperInterface

Fonctions membres publiques

formatSection (string $section, string $message, string $style='info')
formatBlock ($messages, string $style, bool $large=false)
truncate (string $message, int $length, string $suffix='...')
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

The Formatter class provides helpers to format messages.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ formatBlock()

formatBlock | ( |  | $messages,
 |  | string | $style,
 |  | bool | $large = false
 | ) |  |

Formats a message as a block of text.

Paramètres
string | array $messages The message to write in the block
Renvoie
string

Références $i, $message, $messages, $style, OutputFormatter\escape(), et width.

◆ formatSection()

formatSection | ( | string | $section,
 |  | string | $message,
 |  | string | $style = 'info'
 | ) |  |

Formats a message within a section.

Renvoie
string

Références $message, $section, et $style.

◆ getName()

getName ( )

{Returns the canonical name of this helper.

Renvoie
string
}

Implémente HelperInterface.

◆ truncate()

truncate | ( | string | $message,
 |  | int | $length,
 |  | string | $suffix = '...'
 | ) |  |

Truncates a message to the given length.

Renvoie
string

Références $message, $suffix, et width.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FormatterHelper.php


Joomla CMS: Référence de la classe Helper

  • Symfony
  • Component
  • Console
  • Helper
  • Helper
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe Helper
+ Graphe d'héritage de Helper:
HelperInterface DescriptorHelper DebugFormatterHelper DescriptorHelper FormatterHelper InputAwareHelper ProcessHelper QuestionHelper SymfonyQuestionHelper

Fonctions membres publiques

setHelperSet (HelperSet $helperSet=null)
getHelperSet ()
- Fonctions membres publiques hérités de HelperInterface
getName ()

Fonctions membres publiques statiques

static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)

Attributs protégés

$helperSet = null

Description détaillée

Helper is the base class for all helper classes.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ formatMemory()

static formatMemory ( int $memory )
static

Référencé par ProgressIndicator\initPlaceholderFormatters(), et ProgressBar\initPlaceholderFormatters().

◆ formatTime()

static formatTime ( $secs )
static

Références $format.

Référencé par ProgressIndicator\initPlaceholderFormatters(), et ProgressBar\initPlaceholderFormatters().

◆ getHelperSet()

getHelperSet ( )

{Gets the helper set associated with this helper.

Renvoie
HelperSet|null
}

Implémente HelperInterface.

Références Helper\$helperSet.

Référencé par ProcessHelper\run(), ProcessHelper\wrapCallback(), et QuestionHelper\writeError().

◆ length()

static length ( ?string $string )
static

Returns the length of a string, using mb_strlen if it is available. The length is related to how many bytes the string will use.

Références null.

Référencé par ProgressBar\initPlaceholderFormatters(), et Table\renderCell().

◆ removeDecoration()

static removeDecoration | ( | OutputFormatterInterface | $formatter,
 |  | ?string | $string
 | ) |  |
static

Références OutputFormatterInterface\format(), OutputFormatterInterface\isDecorated(), et OutputFormatterInterface\setDecorated().

Référencé par ProgressBar\buildLine(), Table\calculateColumnsWidth(), SymfonyStyle\createBlock(), Table\getCellWidth(), ConsoleSectionOutput\getDisplayLength(), ProgressBar\initPlaceholderFormatters(), ProgressBar\overwrite(), Table\renderCell(), Table\renderRowSeparator(), SymfonyStyle\section(), et SymfonyStyle\title().

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet = null )

{Sets the helper set associated with this helper.}

Implémente HelperInterface.

Références Helper\$helperSet.

◆ strlen()

static strlen ( ?string $string )
static

Returns the length of a string, using mb_strwidth if it is available.

Obsolète:
since Symfony 5.3
Renvoie
int

Références width.

Référencé par QuestionHelper\autocomplete(), QuestionHelper\doAsk(), et Table\renderCell().

◆ strlenWithoutDecoration()

static strlenWithoutDecoration | ( | OutputFormatterInterface | $formatter,
 |  | ?string | $string
 | ) |  |
static
Obsolète:
since Symfony 5.3

Références width.

◆ substr()

static substr | ( | ?string | $string,
 |  | int | $from,
 |  | int | $length = null
 | ) |  |
static

Returns the subset of a string, using mb_substr if it is available.

Renvoie
string

Références null.

Référencé par QuestionHelper\autocomplete(), Application\find(), QuestionHelper\getHiddenResponse(), et Table\renderRowSeparator().

◆ width()

static width ( ?string $string )
static

Returns the width of a string, using mb_strwidth if it is available. The width is how many characters positions the string will use.

Références null.

Référencé par QuestionHelper\autocomplete(), ProgressBar\buildLine(), Table\calculateColumnsWidth(), TextDescriptor\calculateTotalWidthForOptions(), SymfonyStyle\createBlock(), MarkdownDescriptor\describeApplication(), TextDescriptor\describeApplication(), MarkdownDescriptor\describeCommand(), TextDescriptor\describeInputArgument(), TextDescriptor\describeInputDefinition(), TextDescriptor\describeInputOption(), Application\doRenderThrowable(), Application\find(), Table\getCellWidth(), Table\getColumnSeparatorWidth(), TextDescriptor\getColumnWidth(), ConsoleSectionOutput\getDisplayLength(), ProgressBar\overwrite(), Table\renderRowSeparator(), SymfonyStyle\section(), ProgressBar\setMaxSteps(), et SymfonyStyle\title().

Documentation des champs

◆ $helperSet

$helperSet = null
protected

Référencé par Helper\getHelperSet(), et Helper\setHelperSet().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/console/Helper/Helper.php


Joomla CMS: Référence de l'interface HelperInterface

  • Symfony
  • Component
  • Console
  • Helper
  • HelperInterface
Fonctions membres publiques
Référence de l'interface HelperInterface
+ Graphe d'héritage de HelperInterface:
Helper DescriptorHelper DebugFormatterHelper DescriptorHelper FormatterHelper InputAwareHelper ProcessHelper QuestionHelper SymfonyQuestionHelper

Fonctions membres publiques

setHelperSet (HelperSet $helperSet=null)
getHelperSet ()
getName ()

Description détaillée

HelperInterface is the interface all helpers must implement.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ getHelperSet()

getHelperSet ( )

Gets the helper set associated with this helper.

Renvoie
HelperSet|null

Implémenté dans Helper.

◆ getName()

getName ( )

Returns the canonical name of this helper.

Renvoie
string

Implémenté dans ProcessHelper, DebugFormatterHelper, QuestionHelper, FormatterHelper, DescriptorHelper, et DescriptorHelper.

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet = null )

Sets the helper set associated with this helper.

Implémenté dans Helper.

La documentation de cette interface a été générée à partir du fichier suivant :
  • HelperInterface.php


Joomla CMS: Référence de la classe HelperSet

  • Symfony
  • Component
  • Console
  • Helper
  • HelperSet
Fonctions membres publiques | Attributs privés
Référence de la classe HelperSet
+ Graphe d'héritage de HelperSet:

Fonctions membres publiques

__construct (array $helpers=[])
set (HelperInterface $helper, string $alias=null)
has (string $name)
get (string $name)
setCommand (Command $command=null)
getCommand ()
getIterator ()

Attributs privés

$helpers = []
$command

Description détaillée

HelperSet represents a set of helpers to be used with a command.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

<string, Helper>

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $helpers = [] )
Paramètres
Helper[] $helpers An array of helper

Références $helper, HelperSet\$helpers, et null.

Documentation des fonctions membres

◆ get()

get ( string $name )

Gets a helper value.

Renvoie
HelperInterface
Exceptions
InvalidArgumentException if the helper is not defined

Références $name, et HelperSet\has().

◆ getCommand()

getCommand ( )

Gets the command associated with this helper set.

Renvoie
Command
Obsolète:
since Symfony 5.4

Références HelperSet\$command.

◆ getIterator()

getIterator ( )
Renvoie
<string, Helper>

◆ has()

has ( string $name )

Returns true if the helper if defined.

Renvoie
bool

Références $name.

Référencé par HelperSet\get().

◆ set()

set | ( | HelperInterface | $helper,
 |  | string | $alias = null
 | ) |  |

Références $helper, $this, et null.

◆ setCommand()

setCommand ( Command $command = null )
Obsolète:
since Symfony 5.4

Références HelperSet\$command.

Documentation des champs

◆ $command

$command
private

Référencé par HelperSet\getCommand(), et HelperSet\setCommand().

◆ $helpers

$helpers = []
private

Référencé par HelperSet\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • HelperSet.php


Joomla CMS: Référence de la classe InputAwareHelper

  • Symfony
  • Component
  • Console
  • Helper
  • InputAwareHelper
Fonctions membres publiques | Attributs protégés
Référence de la classe InputAwareHelper
+ Graphe d'héritage de InputAwareHelper:
Helper InputAwareInterface HelperInterface

Fonctions membres publiques

setInput (InputInterface $input)
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()
- Fonctions membres publiques hérités de HelperInterface
getName ()

Attributs protégés

$input
- Attributs protégés hérités de Helper
$helperSet = null

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)

Description détaillée

An implementation of InputAwareInterface for Helpers.

Auteur
Wouter J waldi.nosp@m.o.we.nosp@m.bdesi.nosp@m.gn@g.nosp@m.mail..nosp@m.com

Documentation des fonctions membres

◆ setInput()

setInput ( InputInterface $input )

{Sets the Console Input.}

Implémente InputAwareInterface.

Références InputAwareHelper\$input.

Documentation des champs

◆ $input

$input
protected

Référencé par InputAwareHelper\setInput().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InputAwareHelper.php


Joomla CMS: Référence de la classe ProcessHelper

  • Symfony
  • Component
  • Console
  • Helper
  • ProcessHelper
Fonctions membres publiques | Fonctions membres privées
Référence de la classe ProcessHelper
+ Graphe d'héritage de ProcessHelper:
Helper HelperInterface

Fonctions membres publiques

run (OutputInterface $output, $cmd, string $error=null, callable $callback=null, int $verbosity=OutputInterface::VERBOSITY_VERY_VERBOSE)
mustRun (OutputInterface $output, $cmd, string $error=null, callable $callback=null)
wrapCallback (OutputInterface $output, Process $process, callable $callback=null)
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Fonctions membres privées

escapeString (string $str)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

The ProcessHelper class provides helpers to run external processes.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ escapeString()

escapeString ( string $str )
private

Référencé par ProcessHelper\run(), et ProcessHelper\wrapCallback().

◆ getName()

getName ( )

{Returns the canonical name of this helper.

Renvoie
string
}

Implémente HelperInterface.

◆ mustRun()

mustRun | ( | OutputInterface | $output,
 |  |  | $cmd,
 |  | string | $error = null,
 |  | callable | $callback = null
 | ) |  |

Runs the process.

This is identical to run() except that an exception is thrown if the process exits with a non-zero exit code.

Paramètres
array | Process | $cmd | An instance of Process or a command to run
callable | null | $callback | A PHP callback to run whenever there is some output available on STDOUT or STDERR
Exceptions
ProcessFailedException
Voir également
run()

Références ProcessHelper\run().

◆ run()

run | ( | OutputInterface | $output,
 |  |  | $cmd,
 |  | string | $error = null,
 |  | callable | $callback = null,
 |  | int | $verbosity = OutputInterface::VERBOSITY_VERY_VERBOSE
 | ) |  |

Runs an external process.

Paramètres
array | Process | $cmd | An instance of Process or an array of the command and arguments
callable | null | $callback | A PHP callback to run whenever there is some output available on STDOUT or STDERR

Références $message, $output, class, elseif, ProcessHelper\escapeString(), Helper\getHelperSet(), null, et ProcessHelper\wrapCallback().

Référencé par ProcessHelper\mustRun().

◆ wrapCallback()

wrapCallback | ( | OutputInterface | $output,
 |  | Process | $process,
 |  | callable | $callback = null
 | ) |  |

Wraps a Process callback to add debugging output.

Références $buffer, $output, $type, ProcessHelper\escapeString(), Helper\getHelperSet(), et null.

Référencé par ProcessHelper\run().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ProcessHelper.php


Joomla CMS: Référence de la classe ProgressBar

  • Symfony
  • Component
  • Console
  • Helper
  • ProgressBar
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe ProgressBar

Fonctions membres publiques

__construct (OutputInterface $output, int $max=0, float $minSecondsBetweenRedraws=1/25)
setMessage (string $message, string $name='message')
getMessage (string $name='message')
getStartTime ()
getMaxSteps ()
getProgress ()
getProgressPercent ()
getBarOffset ()
getEstimated ()
getRemaining ()
setBarWidth (int $size)
getBarWidth ()
setBarCharacter (string $char)
getBarCharacter ()
setEmptyBarCharacter (string $char)
getEmptyBarCharacter ()
setProgressCharacter (string $char)
getProgressCharacter ()
setFormat (string $format)
setRedrawFrequency (?int $freq)
minSecondsBetweenRedraws (float $seconds)
maxSecondsBetweenRedraws (float $seconds)
iterate (iterable $iterable, int $max=null)
start (int $max=null)
advance (int $step=1)
setOverwrite (bool $overwrite)
setProgress (int $step)
setMaxSteps (int $max)
finish ()
display ()
clear ()

Fonctions membres publiques statiques

static | setPlaceholderFormatterDefinition (string $name, callable $callable)
static | getPlaceholderFormatterDefinition (string $name)
static | setFormatDefinition (string $name, string $format)
static | getFormatDefinition (string $name)

Champs de données

const | FORMAT_VERBOSE = 'verbose'
const | FORMAT_VERY_VERBOSE = 'very_verbose'
const | FORMAT_DEBUG = 'debug'
const | FORMAT_NORMAL = 'normal'

Fonctions membres privées

getStepWidth ()
setRealFormat (string $format)
overwrite (string $message)
determineBestFormat ()
buildLine ()

Fonctions membres privées statiques

static | initPlaceholderFormatters ()
static | initFormats ()

Attributs privés

const | FORMAT_VERBOSE_NOMAX = 'verbose_nomax'
const | FORMAT_VERY_VERBOSE_NOMAX = 'very_verbose_nomax'
const | FORMAT_DEBUG_NOMAX = 'debug_nomax'
const | FORMAT_NORMAL_NOMAX = 'normal_nomax'
$barWidth = 28
$barChar
$emptyBarChar = '-'
$progressChar = '>'
$format
$internalFormat
$redrawFreq = 1
$writeCount
$lastWriteTime
$minSecondsBetweenRedraws = 0
$maxSecondsBetweenRedraws = 1
$output
$step = 0
$max
$startTime
$stepWidth
$percent = 0.0
$formatLineCount
$messages = []
$overwrite = true
$terminal
$previousMessage
$cursor

Attributs privés statiques

static | $formatters
static | $formats

Description détaillée

The ProgressBar provides helpers to display progress output.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Chris Jones leeke.nosp@m.d@gm.nosp@m.ail.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | OutputInterface | $output,
 |  | int | $max = 0,
 |  | float | $minSecondsBetweenRedraws = 1 / 25
 | ) |  |
Paramètres
int $max Maximum steps (0 if unknown)

Références ProgressBar\$max, ProgressBar\$minSecondsBetweenRedraws, ProgressBar\$output, ProgressBar\minSecondsBetweenRedraws(), null, ProgressBar\overwrite(), et ProgressBar\setMaxSteps().

Documentation des fonctions membres

◆ advance()

advance ( int $step = 1 )

Advances the progress output X steps.

Paramètres
int $step Number of steps to advance

Références ProgressBar\$step, et ProgressBar\setProgress().

Référencé par ProgressBar\iterate().

◆ buildLine()

buildLine ( )
private

Références $text, $this, elseif, Helper\removeDecoration(), ProgressBar\setBarWidth(), et Helper\width().

Référencé par ProgressBar\display().

◆ clear()

clear ( )

Removes the progress bar from the current line.

This is useful if you wish to write some output while a progress bar is running. Call display() to show the progress bar again.

Références ProgressBar\determineBestFormat(), null, ProgressBar\overwrite(), et ProgressBar\setRealFormat().

◆ determineBestFormat()

determineBestFormat ( )
private

Références OutputInterface\VERBOSITY_DEBUG, OutputInterface\VERBOSITY_VERBOSE, et OutputInterface\VERBOSITY_VERY_VERBOSE.

Référencé par ProgressBar\clear(), et ProgressBar\display().

◆ display()

display ( )

Outputs the current progress string.

Références ProgressBar\buildLine(), ProgressBar\determineBestFormat(), null, ProgressBar\overwrite(), ProgressBar\setRealFormat(), et OutputInterface\VERBOSITY_QUIET.

Référencé par ProgressBar\setProgress(), et ProgressBar\start().

◆ finish()

finish ( )

Finishes the progress output.

Références ProgressBar\$step, ProgressBar\overwrite(), et ProgressBar\setProgress().

Référencé par ProgressBar\iterate().

◆ getBarCharacter()

getBarCharacter ( )

Références ProgressBar\$emptyBarChar.

◆ getBarOffset()

getBarOffset ( )

Références null.

◆ getBarWidth()

getBarWidth ( )

Références ProgressBar\$barWidth.

Référencé par ProgressBar\initPlaceholderFormatters().

◆ getEmptyBarCharacter()

getEmptyBarCharacter ( )

Références ProgressBar\$emptyBarChar.

◆ getEstimated()

getEstimated ( )

◆ getFormatDefinition()

static getFormatDefinition ( string $name )
static

Gets the format for a given name.

Paramètres
string $name The format name

Références $name, et null.

◆ getMaxSteps()

getMaxSteps ( )

Références ProgressBar\$max.

◆ getMessage()

getMessage ( string $name = 'message' )

Références $name.

◆ getPlaceholderFormatterDefinition()

static getPlaceholderFormatterDefinition ( string $name )
static

Gets the placeholder formatter for a given name.

Paramètres
string $name The placeholder name (including the delimiter char like %)

Références $name, et null.

◆ getProgress()

getProgress ( )

Références ProgressBar\$step.

◆ getProgressCharacter()

getProgressCharacter ( )

Références ProgressBar\$progressChar.

◆ getProgressPercent()

getProgressPercent ( )

Références ProgressBar\$percent.

◆ getRemaining()

getRemaining ( )

◆ getStartTime()

getStartTime ( )

Références ProgressBar\$startTime.

◆ getStepWidth()

getStepWidth ( )
private

Références ProgressBar\$stepWidth.

◆ initFormats()

static initFormats ( )
staticprivate

◆ initPlaceholderFormatters()

static initPlaceholderFormatters ( )
staticprivate

Références $display, ProgressBar\$output, Helper\formatMemory(), Helper\formatTime(), ProgressBar\getBarWidth(), Helper\length(), et Helper\removeDecoration().

◆ iterate()

iterate | ( | iterable | $iterable,
 |  | int | $max = null
 | ) |  |

Returns an iterator that will automatically update the progress bar when iterated.

Paramètres
int | null $max Number of steps to complete the bar (0 if indeterminate), if null it will be inferred from $iterable

Références $key, ProgressBar\$max, $value, ProgressBar\advance(), ProgressBar\finish(), et ProgressBar\start().

◆ maxSecondsBetweenRedraws()

maxSecondsBetweenRedraws ( float $seconds )

Référencé par ProgressBar\setProgress().

◆ minSecondsBetweenRedraws()

minSecondsBetweenRedraws ( float $seconds )

Référencé par ProgressBar\__construct(), et ProgressBar\setProgress().

◆ overwrite()

overwrite ( string $message )
private

Overwrites a previous message to the output.

Références ProgressBar\$formatLineCount, $i, $message, ProgressBar\$writeCount, elseif, null, Helper\removeDecoration(), et Helper\width().

Référencé par ProgressBar\__construct(), ProgressBar\clear(), ProgressBar\display(), ProgressBar\finish(), et ProgressBar\setOverwrite().

◆ setBarCharacter()

setBarCharacter ( string $char )

◆ setBarWidth()

setBarWidth ( int $size )

Références $size.

Référencé par ProgressBar\buildLine().

◆ setEmptyBarCharacter()

setEmptyBarCharacter ( string $char )

◆ setFormat()

setFormat ( string $format )

Références ProgressBar\$format, et null.

◆ setFormatDefinition()

static setFormatDefinition | ( | string | $name,
 |  | string | $format
 | ) |  |
static

Sets a format for a given name.

This method also allow you to override an existing format.

Paramètres
string | $name | The format name
string | $format | A format string

Références ProgressBar\$format, et $name.

Référencé par UpdateCoreCommand\configureIO().

◆ setMaxSteps()

setMaxSteps ( int $max )

Références ProgressBar\$max, null, et Helper\width().

Référencé par ProgressBar\__construct(), et ProgressBar\start().

◆ setMessage()

setMessage | ( | string | $message,
 |  | string | $name = 'message'
 | ) |  |

Associates a text with a named placeholder.

The text is displayed when the progress bar is rendered but only when the corresponding placeholder is part of the custom format line (by wrapping the name with %).

Paramètres
string | $message | The text to associate with the placeholder
string | $name | The name of the placeholder

Références $message, et $name.

◆ setOverwrite()

setOverwrite ( bool $overwrite )

Sets whether to overwrite the progressbar, false for new line.

Références ProgressBar\$overwrite, et ProgressBar\overwrite().

◆ setPlaceholderFormatterDefinition()

static setPlaceholderFormatterDefinition | ( | string | $name,
 |  | callable | $callable
 | ) |  |
static

Sets a placeholder formatter for a given name.

This method also allow you to override an existing placeholder.

Paramètres
string | $name | The placeholder name (including the delimiter char like %)
callable | $callable | A PHP callable

Références $name.

◆ setProgress()

setProgress ( int $step )

Références ProgressBar\$lastWriteTime, ProgressBar\$redrawFreq, ProgressBar\$step, ProgressBar\display(), elseif, ProgressBar\maxSecondsBetweenRedraws(), et ProgressBar\minSecondsBetweenRedraws().

Référencé par ProgressBar\advance(), et ProgressBar\finish().

◆ setProgressCharacter()

setProgressCharacter ( string $char )

◆ setRealFormat()

setRealFormat ( string $format )
private

Références ProgressBar\$format, elseif, et null.

Référencé par ProgressBar\clear(), et ProgressBar\display().

◆ setRedrawFrequency()

setRedrawFrequency ( ?int $freq )

Sets the redraw frequency.

Paramètres
int | null $freq The frequency in steps

Références null.

◆ start()

start ( int $max = null )

Starts the progress output.

Paramètres
int | null $max Number of steps to complete the bar (0 if indeterminate), null to leave unchanged

Références ProgressBar\$max, ProgressBar\display(), null, et ProgressBar\setMaxSteps().

Référencé par ProgressBar\iterate().

Documentation des champs

◆ $barChar

$barChar
private

◆ $barWidth

$barWidth = 28
private

Référencé par ProgressBar\getBarWidth().

◆ $cursor

$cursor
private

◆ $emptyBarChar

$emptyBarChar = '-'
private

Référencé par ProgressBar\getBarCharacter(), et ProgressBar\getEmptyBarCharacter().

◆ $format

$format
private

Référencé par ProgressBar\setFormat(), ProgressBar\setFormatDefinition(), et ProgressBar\setRealFormat().

◆ $formatLineCount

$formatLineCount
private

Référencé par ProgressBar\overwrite().

◆ $formats

$formats
staticprivate

◆ $formatters

$formatters
staticprivate

◆ $internalFormat

$internalFormat
private

◆ $lastWriteTime

$lastWriteTime
private

Référencé par ProgressBar\setProgress().

◆ $max

$max
private

Référencé par ProgressBar\__construct(), ProgressBar\getMaxSteps(), ProgressBar\iterate(), ProgressBar\setMaxSteps(), et ProgressBar\start().

◆ $maxSecondsBetweenRedraws

$maxSecondsBetweenRedraws = 1
private

◆ $messages

$messages = []
private

◆ $minSecondsBetweenRedraws

$minSecondsBetweenRedraws = 0
private

Référencé par ProgressBar\__construct().

◆ $output

$output
private

Référencé par ProgressBar\__construct(), et ProgressBar\initPlaceholderFormatters().

◆ $overwrite

$overwrite = true
private

Référencé par ProgressBar\setOverwrite().

◆ $percent

$percent = 0.0
private

Référencé par ProgressBar\getProgressPercent().

◆ $previousMessage

$previousMessage
private

◆ $progressChar

$progressChar = '>'
private

Référencé par ProgressBar\getProgressCharacter().

◆ $redrawFreq

$redrawFreq = 1
private

Référencé par ProgressBar\setProgress().

◆ $startTime

$startTime
private

Référencé par ProgressBar\getStartTime().

◆ $step

$step = 0
private

Référencé par ProgressBar\advance(), ProgressBar\finish(), ProgressBar\getProgress(), et ProgressBar\setProgress().

◆ $stepWidth

$stepWidth
private

Référencé par ProgressBar\getStepWidth().

◆ $terminal

$terminal
private

◆ $writeCount

$writeCount
private

Référencé par ProgressBar\overwrite().

◆ FORMAT_DEBUG

const FORMAT_DEBUG = 'debug'

◆ FORMAT_DEBUG_NOMAX

const FORMAT_DEBUG_NOMAX = 'debug_nomax'
private

◆ FORMAT_NORMAL

const FORMAT_NORMAL = 'normal'

◆ FORMAT_NORMAL_NOMAX

const FORMAT_NORMAL_NOMAX = 'normal_nomax'
private

◆ FORMAT_VERBOSE

const FORMAT_VERBOSE = 'verbose'

◆ FORMAT_VERBOSE_NOMAX

const FORMAT_VERBOSE_NOMAX = 'verbose_nomax'
private

◆ FORMAT_VERY_VERBOSE

const FORMAT_VERY_VERBOSE = 'very_verbose'

◆ FORMAT_VERY_VERBOSE_NOMAX

const FORMAT_VERY_VERBOSE_NOMAX = 'very_verbose_nomax'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProgressBar.php


Joomla CMS: Référence de la classe ProgressIndicator

  • Symfony
  • Component
  • Console
  • Helper
  • ProgressIndicator
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe ProgressIndicator

Fonctions membres publiques

__construct (OutputInterface $output, string $format=null, int $indicatorChangeInterval=100, array $indicatorValues=null)
setMessage (?string $message)
start (string $message)
advance ()
finish (string $message)

Fonctions membres publiques statiques

static | getFormatDefinition (string $name)
static | setPlaceholderFormatterDefinition (string $name, callable $callable)
static | getPlaceholderFormatterDefinition (string $name)

Fonctions membres privées

display ()
determineBestFormat ()
overwrite (string $message)
getCurrentTimeInMilliseconds ()

Fonctions membres privées statiques

static initPlaceholderFormatters ()

Attributs privés

const | FORMATS
const | $output
$startTime
$format
$message
$indicatorValues
$indicatorCurrent
$indicatorChangeInterval
$indicatorUpdateTime
$started = false

Attributs privés statiques

static $formatters

Description détaillée

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | OutputInterface | $output,
 |  | string | $format = null,
 |  | int | $indicatorChangeInterval = 100,
 |  | array | $indicatorValues = null
 | ) |  |
Paramètres
int | $indicatorChangeInterval | Change interval in milliseconds
array | null | $indicatorValues | Animated indicator characters

Références ProgressIndicator\$format, ProgressIndicator\$indicatorChangeInterval, ProgressIndicator\$indicatorValues, ProgressIndicator\$output, ProgressIndicator\determineBestFormat(), et null.

Documentation des fonctions membres

◆ advance()

advance ( )

Advances the indicator.

Références ProgressIndicator\$indicatorChangeInterval, ProgressIndicator\$indicatorCurrent, ProgressIndicator\display(), et ProgressIndicator\getCurrentTimeInMilliseconds().

◆ determineBestFormat()

determineBestFormat ( )
private

Références OutputInterface\VERBOSITY_DEBUG, OutputInterface\VERBOSITY_VERBOSE, et OutputInterface\VERBOSITY_VERY_VERBOSE.

Référencé par ProgressIndicator\__construct().

◆ display()

display ( )
private

Références $this, ProgressIndicator\overwrite(), et OutputInterface\VERBOSITY_QUIET.

Référencé par ProgressIndicator\advance(), ProgressIndicator\finish(), ProgressIndicator\setMessage(), et ProgressIndicator\start().

◆ finish()

finish ( string $message )

Finish the indicator with message.

Paramètres
$message

Références ProgressIndicator\$message, et ProgressIndicator\display().

◆ getCurrentTimeInMilliseconds()

getCurrentTimeInMilliseconds ( )
private

Référencé par ProgressIndicator\advance(), et ProgressIndicator\start().

◆ getFormatDefinition()

static getFormatDefinition ( string $name )
static

Gets the format for a given name.

Renvoie
string|null

Références $name, et null.

◆ getPlaceholderFormatterDefinition()

static getPlaceholderFormatterDefinition ( string $name )
static

Gets the placeholder formatter for a given name (including the delimiter char like %).

Renvoie
callable|null

Références $name, et null.

◆ initPlaceholderFormatters()

static initPlaceholderFormatters ( )
staticprivate

Références Helper\formatMemory(), et Helper\formatTime().

◆ overwrite()

overwrite ( string $message )
private

Overwrites a previous message to the output.

Références ProgressIndicator\$message.

Référencé par ProgressIndicator\display().

◆ setMessage()

setMessage ( ?string $message )

Sets the current indicator message.

Références ProgressIndicator\$message, et ProgressIndicator\display().

◆ setPlaceholderFormatterDefinition()

static setPlaceholderFormatterDefinition | ( | string | $name,
 |  | callable | $callable
 | ) |  |
static

Sets a placeholder formatter for a given name.

This method also allow you to override an existing placeholder.

Références $name.

◆ start()

start ( string $message )

Starts the indicator output.

Références ProgressIndicator\$indicatorChangeInterval, ProgressIndicator\$message, ProgressIndicator\display(), et ProgressIndicator\getCurrentTimeInMilliseconds().

Documentation des champs

◆ $format

$format
private

Référencé par ProgressIndicator\__construct().

◆ $formatters

$formatters
staticprivate

◆ $indicatorChangeInterval

$indicatorChangeInterval
private

Référencé par ProgressIndicator\__construct(), ProgressIndicator\advance(), et ProgressIndicator\start().

◆ $indicatorCurrent

$indicatorCurrent
private

Référencé par ProgressIndicator\advance().

◆ $indicatorUpdateTime

$indicatorUpdateTime
private

◆ $indicatorValues

$indicatorValues
private

Référencé par ProgressIndicator\__construct().

◆ $message

$message
private

Référencé par ProgressIndicator\finish(), ProgressIndicator\overwrite(), ProgressIndicator\setMessage(), et ProgressIndicator\start().

◆ $output

const $output
private
Valeur initiale :
=> ' %message%',
'verbose' => ' %indicator% %message% (%elapsed:6s%)',
'verbose_no_ansi' => ' %message% (%elapsed:6s%)',
'very_verbose' => ' %indicator% %message% (%elapsed:6s%, %memory:6s%)',
'very_verbose_no_ansi' => ' %message% (%elapsed:6s%, %memory:6s%)',
]

Référencé par ProgressIndicator\__construct().

◆ $started

$started = false
private

◆ $startTime

$startTime
private

◆ FORMATS

const FORMATS
private
Valeur initiale :
= [
'normal' => ' %indicator% %message%'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ProgressIndicator.php


Joomla CMS: Référence de la classe QuestionHelper

  • Symfony
  • Component
  • Console
  • Helper
  • QuestionHelper
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe QuestionHelper
+ Graphe d'héritage de QuestionHelper:
Helper HelperInterface SymfonyQuestionHelper

Fonctions membres publiques

ask (InputInterface $input, OutputInterface $output, Question $question)
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()

Fonctions membres publiques statiques

static | disableStty ()
- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)

Fonctions membres protégées

writePrompt (OutputInterface $output, Question $question)
formatChoiceQuestionChoices (ChoiceQuestion $question, string $tag)
writeError (OutputInterface $output, \Exception $error)

Fonctions membres privées

doAsk (OutputInterface $output, Question $question)
getDefaultAnswer (Question $question)
autocomplete (OutputInterface $output, Question $question, $inputStream, callable $autocomplete)
mostRecentlyEnteredValue (string $entered)
getHiddenResponse (OutputInterface $output, $inputStream, bool $trimmable=true)
validateAttempts (callable $interviewer, OutputInterface $output, Question $question)
isInteractiveInput ($inputStream)
readInput ($inputStream, Question $question)
setIOCodepage ()
resetIOCodepage (int $cp, $input)
cloneInputStream ($inputStream)

Attributs privés

$inputStream

Attributs privés statiques

static | $stty = true
static | $stdinIsInteractive

Membres hérités additionnels

- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

The QuestionHelper class provides helpers to interact with the user.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ ask()

ask | ( | InputInterface | $input,
 |  | OutputInterface | $output,
 |  | Question | $question
 | ) |  |

Asks a question to the user.

Renvoie
mixed The user answer
Exceptions
RuntimeException If there is no data to read in the input stream

Références $input, $output, Laminas\Diactoros\$stream, QuestionHelper\doAsk(), QuestionHelper\getDefaultAnswer(), Question\getValidator(), null, et QuestionHelper\validateAttempts().

◆ autocomplete()

autocomplete | ( | OutputInterface | $output,
 |  | Question | $question,
 |  |  | $inputStream,
 |  | callable | $autocomplete
 | ) |  |
private

Autocompletes a question.

Paramètres
resource $inputStream

Références $autocomplete, $c, $i, QuestionHelper\$inputStream, $output, $r, $value, elseif, OutputFormatter\escapeTrailingBackslash(), Question\getDefault(), QuestionHelper\mostRecentlyEnteredValue(), null, Helper\strlen(), Helper\substr(), et Helper\width().

Référencé par QuestionHelper\doAsk().

◆ cloneInputStream()

cloneInputStream ( $inputStream )
private

Clones an input stream in order to act on one instance of the same stream without affecting the other instance.

Paramètres
resource $inputStream The handler resource
Renvoie
resource|null The cloned resource, null in case it could not be cloned

Références QuestionHelper\$inputStream, $mode, Joomla\Database\Query\$offset, $uri, et null.

Référencé par QuestionHelper\readInput().

◆ disableStty()

static disableStty ( )
static

Prevents usage of stty.

◆ doAsk()

doAsk | ( | OutputInterface | $output,
 |  | Question | $question
 | ) |  |
private

Asks the question to the user.

Renvoie
mixed
Exceptions
RuntimeException In case the fallback is deactivated and the response cannot be hidden

Références $autocomplete, QuestionHelper\$inputStream, $output, QuestionHelper\autocomplete(), Question\getAutocompleterCallback(), Question\getDefault(), QuestionHelper\getHiddenResponse(), Question\getNormalizer(), Terminal\hasSttyAvailable(), Question\isHidden(), Question\isHiddenFallback(), Question\isTrimmable(), null, QuestionHelper\readInput(), Helper\strlen(), et QuestionHelper\writePrompt().

Référencé par QuestionHelper\ask().

◆ formatChoiceQuestionChoices()

formatChoiceQuestionChoices | ( | ChoiceQuestion | $question,
 |  | string | $tag
 | ) |  |
protected
Renvoie
string[]

Références $key, $messages, $value, ChoiceQuestion\getChoices(), et width.

Référencé par SymfonyQuestionHelper\writePrompt(), et QuestionHelper\writePrompt().

◆ getDefaultAnswer()

getDefaultAnswer ( Question $question )
private
Renvoie
mixed

Références $default, elseif, Question\getDefault(), Question\getValidator(), Question\isTrimmable(), et null.

Référencé par QuestionHelper\ask().

◆ getHiddenResponse()

getHiddenResponse | ( | OutputInterface | $output,
 |  |  | $inputStream,
 |  | bool | $trimmable = true
 | ) |  |
private

Gets a hidden response from user.

Paramètres
resource | $inputStream | The handler resource
bool | $trimmable | Is the answer trimmable
Exceptions
RuntimeException In case the fallback is deactivated and the response cannot be hidden

Références QuestionHelper\$inputStream, $output, $value, __DIR__, elseif, Terminal\hasSttyAvailable(), QuestionHelper\isInteractiveInput(), et Helper\substr().

Référencé par QuestionHelper\doAsk().

◆ getName()

getName ( )

{Returns the canonical name of this helper.

Renvoie
string
}

Implémente HelperInterface.

◆ isInteractiveInput()

isInteractiveInput ( $inputStream )
private

Références QuestionHelper\$inputStream, $output, et null.

Référencé par QuestionHelper\getHiddenResponse().

◆ mostRecentlyEnteredValue()

mostRecentlyEnteredValue ( string $entered )
private

Référencé par QuestionHelper\autocomplete().

◆ readInput()

readInput | ( |  | $inputStream,
 |  | Question | $question
 | ) |  |
private

Reads one or more lines of input and returns what is read.

Paramètres
resource | $inputStream | The handler resource
Question | $question | The question being asked
Renvoie
string|false The input received, false in case input could not be read

Références QuestionHelper\$inputStream, QuestionHelper\cloneInputStream(), Question\isMultiline(), null, QuestionHelper\resetIOCodepage(), et QuestionHelper\setIOCodepage().

Référencé par QuestionHelper\doAsk().

◆ resetIOCodepage()

resetIOCodepage | ( | int | $cp,
 |  |  | $input
 | ) |  |
private

Sets console I/O to the specified code page and converts the user input.

Paramètres
string | false $input
Renvoie
string|false

Références $input.

Référencé par QuestionHelper\readInput().

◆ setIOCodepage()

setIOCodepage ( )
private

Sets console I/O to the host code page.

Renvoie
int Previous code page in IBM/EBCDIC format

Référencé par QuestionHelper\readInput().

◆ validateAttempts()

validateAttempts | ( | callable | $interviewer,
 |  | OutputInterface | $output,
 |  | Question | $question
 | ) |  |
private

Validates an attempt.

Paramètres
callable $interviewer A callable that will ask for a question and return the result
Renvoie
mixed The validated response
Exceptions

Références Question\getMaxAttempts(), Question\getValidator(), null, et QuestionHelper\writeError().

Référencé par QuestionHelper\ask().

◆ writeError()

writeError | ( | OutputInterface | $output,
 |  | \Exception | $error
 | ) |  |
protected

Outputs an error message.

Références $message, $output, Helper\getHelperSet(), Symfony\Contracts\Service\has(), et null.

Référencé par QuestionHelper\validateAttempts().

◆ writePrompt()

writePrompt | ( | OutputInterface | $output,
 |  | Question | $question
 | ) |  |
protected

Outputs the question prompt.

Références $message, $output, QuestionHelper\formatChoiceQuestionChoices(), et Question\getQuestion().

Référencé par QuestionHelper\doAsk().

Documentation des champs

◆ $inputStream

$inputStream
private

Référencé par QuestionHelper\autocomplete(), QuestionHelper\cloneInputStream(), QuestionHelper\doAsk(), QuestionHelper\getHiddenResponse(), QuestionHelper\isInteractiveInput(), et QuestionHelper\readInput().

◆ $stdinIsInteractive

$stdinIsInteractive
staticprivate

◆ $stty

$stty = true
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • QuestionHelper.php


Joomla CMS: Référence de la classe SymfonyQuestionHelper

  • Symfony
  • Component
  • Console
  • Helper
  • SymfonyQuestionHelper
Fonctions membres protégées | Fonctions membres privées
Référence de la classe SymfonyQuestionHelper
+ Graphe d'héritage de SymfonyQuestionHelper:
QuestionHelper Helper HelperInterface

Fonctions membres protégées

writePrompt (OutputInterface $output, Question $question)
writeError (OutputInterface $output, \Exception $error)
- Fonctions membres protégées hérités de QuestionHelper
writePrompt (OutputInterface $output, Question $question)
formatChoiceQuestionChoices (ChoiceQuestion $question, string $tag)
writeError (OutputInterface $output, \Exception $error)

Fonctions membres privées

getEofShortcut ()

Membres hérités additionnels

- Fonctions membres publiques hérités de QuestionHelper
ask (InputInterface $input, OutputInterface $output, Question $question)
getName ()
- Fonctions membres publiques hérités de Helper
setHelperSet (HelperSet $helperSet=null)
getHelperSet ()
- Fonctions membres publiques statiques hérités de QuestionHelper
static | disableStty ()
- Fonctions membres publiques statiques hérités de Helper
static | strlen (?string $string)
static | width (?string $string)
static | length (?string $string)
static | substr (?string $string, int $from, int $length=null)
static | formatTime ($secs)
static | formatMemory (int $memory)
static | strlenWithoutDecoration (OutputFormatterInterface $formatter, ?string $string)
static | removeDecoration (OutputFormatterInterface $formatter, ?string $string)
- Attributs protégés hérités de Helper
$helperSet = null

Description détaillée

Symfony Style Guide compliant question helper.

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des fonctions membres

◆ getEofShortcut()

getEofShortcut ( )
private

Référencé par SymfonyQuestionHelper\writePrompt().

◆ writeError()

writeError | ( | OutputInterface | $output,
 |  | \Exception | $error
 | ) |  |
protected

{}

Références $output.

◆ writePrompt()

writePrompt | ( | OutputInterface | $output,
 |  | Question | $question
 | ) |  |
protected

{}

Références $default, $key, $output, $text, $value, OutputFormatter\escape(), OutputFormatter\escapeTrailingBackslash(), QuestionHelper\formatChoiceQuestionChoices(), Question\getDefault(), SymfonyQuestionHelper\getEofShortcut(), Question\getQuestion(), Question\isMultiline(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • SymfonyQuestionHelper.php


Joomla CMS: Référence de la classe Table

  • Symfony
  • Component
  • Console
  • Helper
  • Table
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe Table

Fonctions membres publiques

__construct (OutputInterface $output)
setStyle ($name)
getStyle ()
setColumnStyle (int $columnIndex, $name)
getColumnStyle (int $columnIndex)
setColumnWidth (int $columnIndex, int $width)
setColumnWidths (array $widths)
setColumnMaxWidth (int $columnIndex, int $width)
setHeaders (array $headers)
setRows (array $rows)
addRows (array $rows)
addRow ($row)
appendRow ($row)
setRow ($column, array $row)
setHeaderTitle (?string $title)
setFooterTitle (?string $title)
setHorizontal (bool $horizontal=true)
render ()

Fonctions membres publiques statiques

static | setStyleDefinition (string $name, TableStyle $style)
static | getStyleDefinition (string $name)

Fonctions membres privées

renderRowSeparator (int $type=self::SEPARATOR_MID, string $title=null, string $titleFormat=null)
renderColumnSeparator (int $type=self::BORDER_OUTSIDE)
renderRow (array $row, string $cellFormat, string $firstCellFormat=null)
renderCell (array $row, int $column, string $cellFormat)
calculateNumberOfColumns (array $rows)
calculateRowCount ()
fillNextRows (array $rows, int $line)
fillCells (iterable $row)
copyRow (array $rows, int $line)
getNumberOfColumns (array $row)
getRowColumns (array $row)
calculateColumnsWidth (iterable $rows)
getColumnSeparatorWidth ()
getCellWidth (array $row, int $column)
cleanup ()
resolveStyle ($name)

Fonctions membres privées statiques

static initStyles ()

Attributs privés

const | SEPARATOR_TOP = 0
const | SEPARATOR_TOP_BOTTOM = 1
const | SEPARATOR_MID = 2
const | SEPARATOR_BOTTOM = 3
const | BORDER_OUTSIDE = 0
const | BORDER_INSIDE = 1
$headerTitle
$footerTitle
$headers = []
$rows = []
$horizontal = false
$effectiveColumnWidths = []
$numberOfColumns
$output
$style
$columnStyles = []
$columnWidths = []
$columnMaxWidths = []
$rendered = false

Attributs privés statiques

static $styles

Description détaillée

Provides helpers to display a table.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Саша Стаменковић umpir.nosp@m.sky@.nosp@m.gmail.nosp@m..com
Abdellatif Ait boudad a.ait.nosp@m.boud.nosp@m.ad@gm.nosp@m.ail..nosp@m.com
Max Grigorian maxak.nosp@m.awiz.nosp@m.ard@g.nosp@m.mail.nosp@m..com
Dany Maillard danym.nosp@m.aill.nosp@m.ard93.nosp@m.b@gm.nosp@m.ail.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( OutputInterface $output )

Références Table\$output, et Table\setStyle().

Documentation des fonctions membres

◆ addRow()

addRow ( $row )
Renvoie
$this

Références $this.

Référencé par Table\addRows(), et Table\appendRow().

◆ addRows()

addRows ( array $rows )
Renvoie
$this

Références Table\$rows, $this, et Table\addRow().

Référencé par Table\setRows().

◆ appendRow()

appendRow ( $row )

Adds a row to the table, and re-renders the table.

Renvoie
$this

Références $this, Table\addRow(), Table\calculateRowCount(), class, et Table\render().

◆ calculateColumnsWidth()

calculateColumnsWidth ( iterable $rows )
private

Calculates columns widths.

Références $content, $i, Table\$numberOfColumns, $position, Table\$rows, Table\getCellWidth(), Helper\removeDecoration(), et Helper\width().

Référencé par Table\render().

◆ calculateNumberOfColumns()

calculateNumberOfColumns ( array $rows )
private

Calculate number of columns for this table.

Références $columns, Table\$rows, et Table\getNumberOfColumns().

Référencé par Table\render().

◆ calculateRowCount()

calculateRowCount ( )
private

Référencé par Table\appendRow().

◆ cleanup()

cleanup ( )
private

Called after rendering to cleanup cache data.

Références null.

Référencé par Table\render().

◆ copyRow()

copyRow | ( | array | $rows,
 |  | int | $line
 | ) |  |
private

Références Table\$rows.

Référencé par Table\fillNextRows().

◆ fillCells()

fillCells ( iterable $row )
private

fill cells for a row that contains colspan > 1.

Références $position, et TableCell\getColspan().

◆ fillNextRows()

fillNextRows | ( | array | $rows,
 |  | int | $line
 | ) |  |
private

fill rows that contains rowspan > 1.

Exceptions
InvalidArgumentException

Références Table\$numberOfColumns, Table\$rows, $value, Table\copyRow(), Table\getNumberOfColumns(), TableCell\getRowspan(), et null.

◆ getCellWidth()

getCellWidth | ( | array | $row,
 |  | int | $column
 | ) |  |
private

Références Helper\removeDecoration(), et Helper\width().

Référencé par Table\calculateColumnsWidth().

◆ getColumnSeparatorWidth()

getColumnSeparatorWidth ( )
private

Références Helper\width().

Référencé par Table\renderCell().

◆ getColumnStyle()

getColumnStyle ( int $columnIndex )

Gets the current style for a column.

If style was not set, it returns the global table style.

Renvoie
TableStyle

Références Table\getStyle().

Référencé par Table\renderCell().

◆ getNumberOfColumns()

getNumberOfColumns ( array $row )
private

Gets number of columns by row.

Références $columns.

Référencé par Table\calculateNumberOfColumns(), et Table\fillNextRows().

◆ getRowColumns()

getRowColumns ( array $row )
private

Gets list of columns for the given row.

Références $columns, et TableCell\getColspan().

Référencé par Table\renderRow().

◆ getStyle()

getStyle ( )

Gets the current table style.

Renvoie
TableStyle

Références Table\$style.

Référencé par Table\getColumnStyle().

◆ getStyleDefinition()

static getStyleDefinition ( string $name )
static

Gets a style definition by name.

Renvoie
TableStyle

Références $name.

Référencé par SymfonyStyle\createTable().

◆ initStyles()

static initStyles ( )
staticprivate
Renvoie
array<string, TableStyle>

◆ render()

render ( )

Renders table to output.

Example:

+---------------+-----------------------+------------------+
| ISBN          | Title                 | Author           |
+---------------+-----------------------+------------------+
| 99921-58-10-7 | Divine Comedy         | Dante Alighieri  |
| 9971-5-0210-0 | A Tale of Two Cities  | Charles Dickens  |
| 960-425-059-0 | The Lord of the Rings | J. R. R. Tolkien |
+---------------+-----------------------+------------------+

Références $header, Table\$horizontal, $i, Table\$rows, Table\calculateColumnsWidth(), Table\calculateNumberOfColumns(), Table\cleanup(), elseif, null, Table\renderRow(), et Table\renderRowSeparator().

Référencé par Table\appendRow().

◆ renderCell()

renderCell | ( | array | $row,
 |  | int | $column,
 |  | string | $cellFormat
 | ) |  |
private

Renders table cell with padding.

Références $content, Table\$style, $width, TableCell\getColspan(), Table\getColumnSeparatorWidth(), Table\getColumnStyle(), TableCell\getStyle(), Helper\length(), null, Helper\removeDecoration(), et Helper\strlen().

Référencé par Table\renderRow().

◆ renderColumnSeparator()

renderColumnSeparator ( int $type = self::BORDER_OUTSIDE )
private

Renders vertical column separator.

Références $type.

Référencé par Table\renderRow().

◆ renderRow()

renderRow | ( | array | $row,
 |  | string | $cellFormat,
 |  | string | $firstCellFormat = null
 | ) |  |
private

Renders table row.

Example:

| 9971-5-0210-0 | A Tale of Two Cities  | Charles Dickens  |

Références $columns, $i, $last, Table\getRowColumns(), Table\renderCell(), et Table\renderColumnSeparator().

Référencé par Table\render().

◆ renderRowSeparator()

renderRowSeparator | ( | int | $type = self::SEPARATOR_MID,
 |  | string | $title = null,
 |  | string | $titleFormat = null
 | ) |  |
private

Renders horizontal header separator.

Example:

+-----+-----------+-------+

Références $count, Table\$horizontal, $limit, $title, $type, elseif, null, Helper\removeDecoration(), Helper\substr(), et Helper\width().

Référencé par Table\render().

◆ resolveStyle()

resolveStyle ( $name )
private

Références $name.

Référencé par Table\setColumnStyle(), et Table\setStyle().

◆ setColumnMaxWidth()

setColumnMaxWidth | ( | int | $columnIndex,
 |  | int | $width
 | ) |  |

Sets the maximum width of a column.

Any cell within this column which contents exceeds the specified width will be wrapped into multiple lines, while formatted strings are preserved.

Renvoie
$this

Références $this, $width, et class.

◆ setColumnStyle()

setColumnStyle | ( | int | $columnIndex,
 |  |  | $name
 | ) |  |

Sets table column style.

Paramètres
TableStyle | string $name The style name or a TableStyle instance
Renvoie
$this

Références $name, $this, et Table\resolveStyle().

◆ setColumnWidth()

setColumnWidth | ( | int | $columnIndex,
 |  | int | $width
 | ) |  |

Sets the minimum width of a column.

Renvoie
$this

Références $this, et $width.

Référencé par Table\setColumnWidths().

◆ setColumnWidths()

setColumnWidths ( array $widths )

Sets the minimum width of all columns.

Renvoie
$this

Références $this, $width, et Table\setColumnWidth().

◆ setFooterTitle()

setFooterTitle ( ?string $title )
Renvoie
$this

Références $this, et $title.

◆ setHeaders()

setHeaders ( array $headers )
Renvoie
$this

Références Table\$headers, et $this.

◆ setHeaderTitle()

setHeaderTitle ( ?string $title )
Renvoie
$this

Références $this, et $title.

◆ setHorizontal()

setHorizontal ( bool $horizontal = true )
Renvoie
$this

Références Table\$horizontal, et $this.

◆ setRow()

setRow | ( |  | $column,
 |  | array | $row
 | ) |  |
Renvoie
$this

Références $this.

◆ setRows()

setRows ( array $rows )

Références Table\addRows().

◆ setStyle()

setStyle ( $name )

Sets table style.

Paramètres
TableStyle | string $name The style name or a TableStyle instance
Renvoie
$this

Références $name, $this, et Table\resolveStyle().

Référencé par Table\__construct().

◆ setStyleDefinition()

static setStyleDefinition | ( | string | $name,
 |  | TableStyle | $style
 | ) |  |
static

Sets a style definition.

Références $name, et Table\$style.

Documentation des champs

◆ $columnMaxWidths

$columnMaxWidths = []
private

◆ $columnStyles

$columnStyles = []
private

◆ $columnWidths

$columnWidths = []
private

◆ $effectiveColumnWidths

$effectiveColumnWidths = []
private

Column widths cache.

◆ $footerTitle

$footerTitle
private

◆ $headers

$headers = []
private

Table headers.

Référencé par Table\setHeaders().

◆ $headerTitle

$headerTitle
private

◆ $horizontal

$horizontal = false
private

Référencé par Table\render(), Table\renderRowSeparator(), et Table\setHorizontal().

◆ $numberOfColumns

$numberOfColumns
private

Référencé par Table\calculateColumnsWidth(), et Table\fillNextRows().

◆ $output

$output
private

Référencé par Table\__construct().

◆ $rendered

$rendered = false
private

◆ $rows

$rows = []
private

Table rows.

Référencé par Table\addRows(), Table\calculateColumnsWidth(), Table\calculateNumberOfColumns(), Table\copyRow(), Table\fillNextRows(), et Table\render().

◆ $style

$style
private

Référencé par Table\getStyle(), Table\renderCell(), et Table\setStyleDefinition().

◆ $styles

$styles
staticprivate

◆ BORDER_INSIDE

const BORDER_INSIDE = 1
private

◆ BORDER_OUTSIDE

const BORDER_OUTSIDE = 0
private

◆ SEPARATOR_BOTTOM

const SEPARATOR_BOTTOM = 3
private

◆ SEPARATOR_MID

const SEPARATOR_MID = 2
private

◆ SEPARATOR_TOP

const SEPARATOR_TOP = 0
private

◆ SEPARATOR_TOP_BOTTOM

const SEPARATOR_TOP_BOTTOM = 1
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/symfony/console/Helper/Table.php


Joomla CMS: Référence de la classe TableCell

  • Symfony
  • Component
  • Console
  • Helper
  • TableCell
Fonctions membres publiques | Attributs privés
Référence de la classe TableCell
+ Graphe d'héritage de TableCell:
TableSeparator

Fonctions membres publiques

__construct (string $value='', array $options=[])
__toString ()
getColspan ()
getRowspan ()
getStyle ()

Attributs privés

$value
$options

Description détaillée

Auteur
Abdellatif Ait boudad a.ait.nosp@m.boud.nosp@m.ad@gm.nosp@m.ail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $value = '',
 |  | array | $options = []
 | ) |  |

Références TableCell\$options, TableCell\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns the cell value.

Renvoie
string

Références TableCell\$value.

◆ getColspan()

getColspan ( )

Gets number of colspan.

Renvoie
int

Référencé par Table\fillCells(), Table\getRowColumns(), et Table\renderCell().

◆ getRowspan()

getRowspan ( )

Gets number of rowspan.

Renvoie
int

Référencé par Table\fillNextRows().

◆ getStyle()

getStyle ( )

Référencé par Table\renderCell().

Documentation des champs

◆ $options

$options
private
Valeur initiale :
= [
'rowspan' => 1

Référencé par TableSeparator\__construct(), et TableCell\__construct().

◆ $value

$value
private

Référencé par TableCell\__construct(), et TableCell\__toString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TableCell.php


Joomla CMS: Référence de la classe TableCellStyle

  • Symfony
  • Component
  • Console
  • Helper
  • TableCellStyle
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe TableCellStyle

Fonctions membres publiques

const __construct (array $options=[])
getOptions ()
getTagOptions ()
getPadByAlign ()
getCellFormat ()

Champs de données

const DEFAULT_ALIGN = 'left'

Attributs privés

const | TAG_OPTIONS
const | ALIGN_MAP
const | $options

Description détaillée

Auteur
Yewhen Khoptynskyi khopt.nosp@m.ynsk.nosp@m.yi@gm.nosp@m.ail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

const __construct ( array $options = [] )

Références TableCellStyle\$options.

Documentation des fonctions membres

◆ getCellFormat()

getCellFormat ( )

Références TableCellStyle\getOptions().

◆ getOptions()

getOptions ( )

Références TableCellStyle\$options.

Référencé par TableCellStyle\getCellFormat(), TableCellStyle\getPadByAlign(), et TableCellStyle\getTagOptions().

◆ getPadByAlign()

getPadByAlign ( )
Renvoie
int

Références TableCellStyle\getOptions().

◆ getTagOptions()

getTagOptions ( )

Gets options we need for tag for example fg, bg.

Renvoie
string[]

Références $key, et TableCellStyle\getOptions().

Documentation des champs

◆ $options

const $options
private
Valeur initiale :
= [
'fg' => 'default'

Référencé par TableCellStyle\__construct(), et TableCellStyle\getOptions().

◆ ALIGN_MAP

const ALIGN_MAP
private
Valeur initiale :
= [
'left' => \STR_PAD_RIGHT

◆ DEFAULT_ALIGN

const DEFAULT_ALIGN = 'left'

◆ TAG_OPTIONS

const TAG_OPTIONS
private
Valeur initiale :
= [
'fg',
'bg',
'options',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • TableCellStyle.php


Joomla CMS: Référence de la classe TableRows

  • Symfony
  • Component
  • Console
  • Helper
  • TableRows
Fonctions membres publiques | Attributs privés
Référence de la classe TableRows
+ Graphe d'héritage de TableRows:

Fonctions membres publiques

__construct (\Closure $generator)
getIterator ()

Attributs privés

$generator

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \Closure $generator )

Références TableRows\$generator.

Documentation des fonctions membres

◆ getIterator()

getIterator ( )

Documentation des champs

◆ $generator

$generator
private

Référencé par TableRows\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TableRows.php


Joomla CMS: Référence de la classe TableSeparator

  • Symfony
  • Component
  • Console
  • Helper
  • TableSeparator
Fonctions membres publiques
Référence de la classe TableSeparator
+ Graphe d'héritage de TableSeparator:
TableCell

Fonctions membres publiques

__construct (array $options=[])
- Fonctions membres publiques hérités de TableCell
__construct (string $value='', array $options=[])
__toString ()
getColspan ()
getRowspan ()
getStyle ()

Description détaillée

Marks a row as being a separator.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $options = [] )

Références TableCell\$options, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TableSeparator.php


Joomla CMS: Référence de la classe TableStyle

  • Symfony
  • Component
  • Console
  • Helper
  • TableStyle
Fonctions membres publiques | Attributs privés
Référence de la classe TableStyle

Fonctions membres publiques

setPaddingChar (string $paddingChar)
getPaddingChar ()
setHorizontalBorderChars (string $outside, string $inside=null)
setVerticalBorderChars (string $outside, string $inside=null)
getBorderChars ()
setCrossingChars (string $cross, string $topLeft, string $topMid, string $topRight, string $midRight, string $bottomRight, string $bottomMid, string $bottomLeft, string $midLeft, string $topLeftBottom=null, string $topMidBottom=null, string $topRightBottom=null)
setDefaultCrossingChar (string $char)
getCrossingChar ()
getCrossingChars ()
setCellHeaderFormat (string $cellHeaderFormat)
getCellHeaderFormat ()
setCellRowFormat (string $cellRowFormat)
getCellRowFormat ()
setCellRowContentFormat (string $cellRowContentFormat)
getCellRowContentFormat ()
setBorderFormat (string $borderFormat)
getBorderFormat ()
setPadType (int $padType)
getPadType ()
getHeaderTitleFormat ()
setHeaderTitleFormat (string $format)
getFooterTitleFormat ()
setFooterTitleFormat (string $format)

Attributs privés

$paddingChar = ' '
$horizontalOutsideBorderChar = '-'
$horizontalInsideBorderChar = '-'
$verticalOutsideBorderChar = '|'
$verticalInsideBorderChar = '|'
$crossingChar = '+'
$crossingTopRightChar = '+'
$crossingTopMidChar = '+'
$crossingTopLeftChar = '+'
$crossingMidRightChar = '+'
$crossingBottomRightChar = '+'
$crossingBottomMidChar = '+'
$crossingBottomLeftChar = '+'
$crossingMidLeftChar = '+'
$crossingTopLeftBottomChar = '+'
$crossingTopMidBottomChar = '+'
$crossingTopRightBottomChar = '+'
$headerTitleFormat = '<fg=black;bg=white;options=bold> %s </>'
$footerTitleFormat = '<fg=black;bg=white;options=bold> %s </>'
$cellHeaderFormat = '<info>%s</info>'
$cellRowFormat = '%s'
$cellRowContentFormat = ' %s '
$borderFormat = '%s'
$padType = \STR_PAD_RIGHT

Description détaillée

Defines the styles for a Table.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Саша Стаменковић umpir.nosp@m.sky@.nosp@m.gmail.nosp@m..com
Dany Maillard danym.nosp@m.aill.nosp@m.ard93.nosp@m.b@gm.nosp@m.ail.c.nosp@m.om

Documentation des fonctions membres

◆ getBorderChars()

getBorderChars ( )

Gets border characters.

Références TableStyle\$horizontalInsideBorderChar, TableStyle\$horizontalOutsideBorderChar, TableStyle\$verticalInsideBorderChar, et TableStyle\$verticalOutsideBorderChar.

◆ getBorderFormat()

getBorderFormat ( )

Gets table border format.

Renvoie
string

Références TableStyle\$borderFormat.

◆ getCellHeaderFormat()

getCellHeaderFormat ( )

Gets header cell format.

Renvoie
string

Références TableStyle\$cellHeaderFormat.

◆ getCellRowContentFormat()

getCellRowContentFormat ( )

Gets row cell content format.

Renvoie
string

Références TableStyle\$cellRowContentFormat.

◆ getCellRowFormat()

getCellRowFormat ( )

Gets row cell format.

Renvoie
string

Références TableStyle\$cellRowFormat.

◆ getCrossingChar()

getCrossingChar ( )

Gets crossing character.

Renvoie
string

Références TableStyle\$crossingChar.

◆ getCrossingChars()

getCrossingChars ( )

Gets crossing characters.

Références TableStyle\$crossingBottomLeftChar, TableStyle\$crossingBottomMidChar, TableStyle\$crossingBottomRightChar, TableStyle\$crossingChar, TableStyle\$crossingMidLeftChar, TableStyle\$crossingMidRightChar, TableStyle\$crossingTopLeftBottomChar, TableStyle\$crossingTopLeftChar, TableStyle\$crossingTopMidBottomChar, TableStyle\$crossingTopMidChar, TableStyle\$crossingTopRightBottomChar, et TableStyle\$crossingTopRightChar.

◆ getFooterTitleFormat()

getFooterTitleFormat ( )

Références TableStyle\$footerTitleFormat.

◆ getHeaderTitleFormat()

getHeaderTitleFormat ( )

Références TableStyle\$headerTitleFormat.

◆ getPaddingChar()

getPaddingChar ( )

Gets padding character, used for cell padding.

Renvoie
string

Références TableStyle\$paddingChar.

◆ getPadType()

getPadType ( )

Gets cell padding type.

Renvoie
int

Références TableStyle\$padType.

◆ setBorderFormat()

setBorderFormat ( string $borderFormat )

Sets table border format.

Renvoie
$this

Références TableStyle\$borderFormat, et $this.

◆ setCellHeaderFormat()

setCellHeaderFormat ( string $cellHeaderFormat )

Sets header cell format.

Renvoie
$this

Références TableStyle\$cellHeaderFormat, et $this.

◆ setCellRowContentFormat()

setCellRowContentFormat ( string $cellRowContentFormat )

Sets row cell content format.

Renvoie
$this

Références TableStyle\$cellRowContentFormat, et $this.

◆ setCellRowFormat()

setCellRowFormat ( string $cellRowFormat )

Sets row cell format.

Renvoie
$this

Références TableStyle\$cellRowFormat, et $this.

◆ setCrossingChars()

setCrossingChars | ( | string | $cross,
 |  | string | $topLeft,
 |  | string | $topMid,
 |  | string | $topRight,
 |  | string | $midRight,
 |  | string | $bottomRight,
 |  | string | $bottomMid,
 |  | string | $bottomLeft,
 |  | string | $midLeft,
 |  | string | $topLeftBottom = null,
 |  | string | $topMidBottom = null,
 |  | string | $topRightBottom = null
 | ) |  |

Sets crossing characters.

Example: 1═══════════════2══════════════════════════2══════════════════3 ║ ISBN │ Title │ Author ║ 8'══════════════0'═════════════════════════0'═════════════════4' ║ 99921-58-10-7 │ Divine Comedy │ Dante Alighieri ║ ║ 9971-5-0210-0 │ A Tale of Two Cities │ Charles Dickens ║ 8───────────────0──────────────────────────0──────────────────4 ║ 960-425-059-0 │ The Lord of the Rings │ J. R. R. Tolkien ║ ║ 80-902734-1-6 │ And Then There Were None │ Agatha Christie ║ 7═══════════════6══════════════════════════6══════════════════5

Paramètres
string | $cross | Crossing char (see #0 of example)
string | $topLeft | Top left char (see #1 of example)
string | $topMid | Top mid char (see #2 of example)
string | $topRight | Top right char (see #3 of example)
string | $midRight | Mid right char (see #4 of example)
string | $bottomRight | Bottom right char (see #5 of example)
string | $bottomMid | Bottom mid char (see #6 of example)
string | $bottomLeft | Bottom left char (see #7 of example)
string | $midLeft | Mid left char (see #8 of example)
string | null | $topLeftBottom | Top left bottom char (see #8' of example), equals to $midLeft if null
string | null | $topMidBottom | Top mid bottom char (see #0' of example), equals to $cross if null
string | null | $topRightBottom | Top right bottom char (see #4' of example), equals to $midRight if null
Renvoie
$this

Références $this.

Référencé par TableStyle\setDefaultCrossingChar().

◆ setDefaultCrossingChar()

setDefaultCrossingChar ( string $char )

Sets default crossing character used for each cross.

Voir également
setCrossingChars() for setting each crossing individually.

Références TableStyle\setCrossingChars().

◆ setFooterTitleFormat()

setFooterTitleFormat ( string $format )
Renvoie
$this

Références $format, et $this.

◆ setHeaderTitleFormat()

setHeaderTitleFormat ( string $format )
Renvoie
$this

Références $format, et $this.

◆ setHorizontalBorderChars()

setHorizontalBorderChars | ( | string | $outside,
 |  | string | $inside = null
 | ) |  |

Sets horizontal border characters.

╔═══════════════╤══════════════════════════╤══════════════════╗ 1 ISBN 2 Title │ Author ║ ╠═══════════════╪══════════════════════════╪══════════════════╣ ║ 99921-58-10-7 │ Divine Comedy │ Dante Alighieri ║ ║ 9971-5-0210-0 │ A Tale of Two Cities │ Charles Dickens ║ ║ 960-425-059-0 │ The Lord of the Rings │ J. R. R. Tolkien ║ ║ 80-902734-1-6 │ And Then There Were None │ Agatha Christie ║ ╚═══════════════╧══════════════════════════╧══════════════════╝

Renvoie
$this

Références $this.

◆ setPaddingChar()

setPaddingChar ( string $paddingChar )

Sets padding character, used for cell padding.

Renvoie
$this

Références TableStyle\$paddingChar, et $this.

◆ setPadType()

setPadType ( int $padType )

Sets cell padding type.

Renvoie
$this

Références TableStyle\$padType, et $this.

◆ setVerticalBorderChars()

setVerticalBorderChars | ( | string | $outside,
 |  | string | $inside = null
 | ) |  |

Sets vertical border characters.

╔═══════════════╤══════════════════════════╤══════════════════╗ ║ ISBN │ Title │ Author ║ ╠═══════1═══════╪══════════════════════════╪══════════════════╣ ║ 99921-58-10-7 │ Divine Comedy │ Dante Alighieri ║ ║ 9971-5-0210-0 │ A Tale of Two Cities │ Charles Dickens ║ ╟───────2───────┼──────────────────────────┼──────────────────╢ ║ 960-425-059-0 │ The Lord of the Rings │ J. R. R. Tolkien ║ ║ 80-902734-1-6 │ And Then There Were None │ Agatha Christie ║ ╚═══════════════╧══════════════════════════╧══════════════════╝

Renvoie
$this

Références $this.

Documentation des champs

◆ $borderFormat

$borderFormat = '%s'
private

Référencé par TableStyle\getBorderFormat(), et TableStyle\setBorderFormat().

◆ $cellHeaderFormat

$cellHeaderFormat = '<info>%s</info>'
private

Référencé par TableStyle\getCellHeaderFormat(), et TableStyle\setCellHeaderFormat().

◆ $cellRowContentFormat

$cellRowContentFormat = ' %s '
private

Référencé par TableStyle\getCellRowContentFormat(), et TableStyle\setCellRowContentFormat().

◆ $cellRowFormat

$cellRowFormat = '%s'
private

Référencé par TableStyle\getCellRowFormat(), et TableStyle\setCellRowFormat().

◆ $crossingBottomLeftChar

$crossingBottomLeftChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingBottomMidChar

$crossingBottomMidChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingBottomRightChar

$crossingBottomRightChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingChar

$crossingChar = '+'
private

Référencé par TableStyle\getCrossingChar(), et TableStyle\getCrossingChars().

◆ $crossingMidLeftChar

$crossingMidLeftChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingMidRightChar

$crossingMidRightChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopLeftBottomChar

$crossingTopLeftBottomChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopLeftChar

$crossingTopLeftChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopMidBottomChar

$crossingTopMidBottomChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopMidChar

$crossingTopMidChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopRightBottomChar

$crossingTopRightBottomChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $crossingTopRightChar

$crossingTopRightChar = '+'
private

Référencé par TableStyle\getCrossingChars().

◆ $footerTitleFormat

$footerTitleFormat = '<fg=black;bg=white;options=bold> %s </>'
private

Référencé par TableStyle\getFooterTitleFormat().

◆ $headerTitleFormat

$headerTitleFormat = '<fg=black;bg=white;options=bold> %s </>'
private

Référencé par TableStyle\getHeaderTitleFormat().

◆ $horizontalInsideBorderChar

$horizontalInsideBorderChar = '-'
private

Référencé par TableStyle\getBorderChars().

◆ $horizontalOutsideBorderChar

$horizontalOutsideBorderChar = '-'
private

Référencé par TableStyle\getBorderChars().

◆ $paddingChar

$paddingChar = ' '
private

Référencé par TableStyle\getPaddingChar(), et TableStyle\setPaddingChar().

◆ $padType

$padType = \STR_PAD_RIGHT
private

Référencé par TableStyle\getPadType(), et TableStyle\setPadType().

◆ $verticalInsideBorderChar

$verticalInsideBorderChar = '|'
private

Référencé par TableStyle\getBorderChars().

◆ $verticalOutsideBorderChar

$verticalOutsideBorderChar = '|'
private

Référencé par TableStyle\getBorderChars().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TableStyle.php


Joomla CMS: Référence de la classe ArgvInput

  • Symfony
  • Component
  • Console
  • Input
  • ArgvInput
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe ArgvInput
+ Graphe d'héritage de ArgvInput:
Input InputInterface StreamableInputInterface InputInterface CompletionInput StringInput

Fonctions membres publiques

__construct (array $argv=null, InputDefinition $definition=null)
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
__toString ()
- Fonctions membres publiques hérités de Input
__construct (InputDefinition $definition=null)
bind (InputDefinition $definition)
validate ()
isInteractive ()
setInteractive (bool $interactive)
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
escapeToken (string $token)
setStream ($stream)
getStream ()

Fonctions membres protégées

setTokens (array $tokens)
parse ()
parseToken (string $token, bool $parseOptions)
- Fonctions membres protégées hérités de Input
parse ()

Fonctions membres privées

parseShortOption (string $token)
parseShortOptionSet (string $name)
parseLongOption (string $token)
parseArgument (string $token)
addShortOption (string $shortcut, $value)
addLongOption (string $name, $value)

Attributs privés

$tokens
$parsed

Membres hérités additionnels

- Attributs protégés hérités de Input
$definition
$stream
$options = []
$arguments = []
$interactive = true

Description détaillée

ArgvInput represents an input coming from the CLI arguments.

Usage:

$input = new ArgvInput();

By default, the ‘$_SERVER['argv’]` array is used for the input values.

This can be overridden by explicitly passing the input values in the constructor:

$input = new ArgvInput($_SERVER['argv']);

If you pass it yourself, don't forget that the first element of the array is the name of the running application.

When passing an argument to the constructor, be sure that it respects the same rules as the argv one. It's almost always better to use the StringInput when you want to provide your own input.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Voir également
http://www.gnu.org/software/libc/manual/html_node/Argument-Syntax.html
http://www.opengroup.org/onlinepubs/009695399/basedefs/xbd_chap12.html#tag_12_02

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $argv = null,
 |  | InputDefinition | $definition = null
 | ) |  |

Références $argv, Input\$definition, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns a stringified representation of the args passed to the command.

Renvoie
string

Références ArgvInput\$tokens, et Input\escapeToken().

◆ addLongOption()

addLongOption | ( | string | $name,
 |  |  | $value
 | ) |  |
private

Adds a long option value.

Exceptions
RuntimeException When option given doesn't exist

Références $name, $option, $value, et null.

Référencé par ArgvInput\addShortOption(), ArgvInput\parseLongOption(), et ArgvInput\parseShortOptionSet().

◆ addShortOption()

addShortOption | ( | string | $shortcut,
 |  |  | $value
 | ) |  |
private

Adds a short option value.

Exceptions
RuntimeException When option given doesn't exist

Références $value, et ArgvInput\addLongOption().

Référencé par ArgvInput\parseShortOption().

◆ getFirstArgument()

getFirstArgument ( )

{Returns the first argument from the raw parameters (not parsed).

Renvoie
string|null
}

Implémente InputInterface.

Références $i, $name, elseif, et null.

Référencé par CompleteCommand\findCommand().

◆ getParameterOption()

getParameterOption | ( |  | $values,
 |  |  | $default = false,
 |  | bool | $onlyParams = false
 | ) |  |

{Returns the value of a raw option (not parsed).This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The value(s) to look for in the raw parameters (can be an array)
string | bool | int | float | array | null | $default | The default value to return if no result is found
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
mixed
}

Implémente InputInterface.

Références $default, ArgvInput\$tokens, et $value.

◆ hasParameterOption()

hasParameterOption | ( |  | $values,
 |  | bool | $onlyParams = false
 | ) |  |

{Returns true if the raw parameters (not parsed) contain a value.This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The values to look for in the raw parameters (can be an array)
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
bool
}

Implémente InputInterface.

Références $value.

◆ parse()

parse ( )
protected

{}

Références ArgvInput\$tokens, null, et ArgvInput\parseToken().

◆ parseArgument()

parseArgument ( string $token )
private

Parses an argument.

Exceptions
RuntimeException When too many arguments are given

Références $c, $key, $message, elseif, et null.

Référencé par ArgvInput\parseToken().

◆ parseLongOption()

parseLongOption ( string $token )
private

Parses a long option.

Références $name, $value, ArgvInput\addLongOption(), et null.

Référencé par ArgvInput\parseToken().

◆ parseShortOption()

parseShortOption ( string $token )
private

Parses a short option.

Références $name, ArgvInput\addShortOption(), null, et ArgvInput\parseShortOptionSet().

Référencé par ArgvInput\parseToken().

◆ parseShortOptionSet()

parseShortOptionSet ( string $name )
private

Parses a short option set.

Exceptions
RuntimeException When option given doesn't exist

Références $i, $name, $option, ArgvInput\addLongOption(), et null.

Référencé par ArgvInput\parseShortOption().

◆ parseToken()

parseToken | ( | string | $token,
 |  | bool | $parseOptions
 | ) |  |
protected

Références elseif, ArgvInput\parseArgument(), ArgvInput\parseLongOption(), et ArgvInput\parseShortOption().

Référencé par ArgvInput\parse().

◆ setTokens()

setTokens ( array $tokens )
protected

Références ArgvInput\$tokens.

Référencé par StringInput\__construct().

Documentation des champs

◆ $parsed

$parsed
private

◆ $tokens

$tokens
private

Référencé par ArgvInput\__toString(), ArgvInput\getParameterOption(), ArgvInput\parse(), ArgvInput\setTokens(), et StringInput\tokenize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArgvInput.php


Joomla CMS: Référence de la classe ArrayInput

  • Symfony
  • Component
  • Console
  • Input
  • ArrayInput
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe ArrayInput
+ Graphe d'héritage de ArrayInput:
Input InputInterface StreamableInputInterface InputInterface

Fonctions membres publiques

__construct (array $parameters, InputDefinition $definition=null)
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
__toString ()
- Fonctions membres publiques hérités de Input
__construct (InputDefinition $definition=null)
bind (InputDefinition $definition)
validate ()
isInteractive ()
setInteractive (bool $interactive)
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
escapeToken (string $token)
setStream ($stream)
getStream ()

Fonctions membres protégées

parse ()
- Fonctions membres protégées hérités de Input
parse ()

Fonctions membres privées

addShortOption (string $shortcut, $value)
addLongOption (string $name, $value)
addArgument ($name, $value)

Attributs privés

$parameters

Membres hérités additionnels

- Attributs protégés hérités de Input
$definition
$stream
$options = []
$arguments = []
$interactive = true

Description détaillée

ArrayInput represents an input provided as an array.

Usage:

$input = new ArrayInput(['command' => 'foo:bar', 'foo' => 'bar', '--bar' => 'foobar']);
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $parameters,
 |  | InputDefinition | $definition = null
 | ) |  |

Références Input\$definition, ArrayInput\$parameters, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Returns a stringified representation of the args passed to the command.

Renvoie
string

Références $params, $this, $val, et Input\escapeToken().

◆ addArgument()

addArgument | ( | $name,
 |  | $value
 | ) |
private

Adds an argument value.

Paramètres
string | int | $name | The argument name
mixed | $value | The value for the argument
Exceptions
InvalidArgumentException When argument given doesn't exist

Références $name, et $value.

Référencé par ArrayInput\parse().

◆ addLongOption()

addLongOption | ( | string | $name,
 |  |  | $value
 | ) |  |
private

Adds a long option value.

Exceptions
InvalidOptionException | When option given doesn't exist
InvalidOptionException | When a required value is missing

Références $name, $option, $value, et null.

Référencé par ArrayInput\addShortOption(), et ArrayInput\parse().

◆ addShortOption()

addShortOption | ( | string | $shortcut,
 |  |  | $value
 | ) |  |
private

Adds a short option value.

Exceptions
InvalidOptionException When option given doesn't exist

Références $value, et ArrayInput\addLongOption().

Référencé par ArrayInput\parse().

◆ getFirstArgument()

getFirstArgument ( )

{Returns the first argument from the raw parameters (not parsed).

Renvoie
string|null
}

Implémente InputInterface.

Références $value, et null.

◆ getParameterOption()

getParameterOption | ( |  | $values,
 |  |  | $default = false,
 |  | bool | $onlyParams = false
 | ) |  |

{Returns the value of a raw option (not parsed).This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The value(s) to look for in the raw parameters (can be an array)
string | bool | int | float | array | null | $default | The default value to return if no result is found
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
mixed
}

Implémente InputInterface.

Références $default, et elseif.

◆ hasParameterOption()

hasParameterOption | ( |  | $values,
 |  | bool | $onlyParams = false
 | ) |  |

{Returns true if the raw parameters (not parsed) contain a value.This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The values to look for in the raw parameters (can be an array)
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
bool
}

Implémente InputInterface.

◆ parse()

parse ( )
protected

{}

Références $key, $value, ArrayInput\addArgument(), ArrayInput\addLongOption(), ArrayInput\addShortOption(), et elseif.

Documentation des champs

◆ $parameters

$parameters
private

Référencé par ArrayInput\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ArrayInput.php


Joomla CMS: Référence de la classe Input

  • Symfony
  • Component
  • Console
  • Input
  • Input
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Input
+ Graphe d'héritage de Input:
InputInterface StreamableInputInterface InputInterface ArgvInput ArrayInput CompletionInput StringInput

Fonctions membres publiques

__construct (InputDefinition $definition=null)
bind (InputDefinition $definition)
validate ()
isInteractive ()
setInteractive (bool $interactive)
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
escapeToken (string $token)
setStream ($stream)
getStream ()
- Fonctions membres publiques hérités de InputInterface
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)

Fonctions membres protégées

parse ()

Attributs protégés

$definition
$stream
$options = []
$arguments = []
$interactive = true

Description détaillée

Input is the base class for all concrete Input classes.

Three concrete classes are provided by default:

  • ArgvInput: The input comes from the CLI arguments (argv)
  • StringInput: The input is provided as a string
  • ArrayInput: The input is provided as an array
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( InputDefinition $definition = null )

Références Input\$definition, Input\bind(), null, et Input\validate().

Documentation des fonctions membres

◆ bind()

bind ( InputDefinition $definition )

{Binds the current Input instance with the given arguments and options.

Exceptions
RuntimeException
}

Implémente InputInterface.

Références Input\$definition, et Input\parse().

Référencé par Input\__construct().

◆ escapeToken()

escapeToken ( string $token )

Escapes a token through escapeshellarg if it contains unsafe chars.

Renvoie
string

Référencé par ArrayInput\__toString(), et ArgvInput\__toString().

◆ getArgument()

getArgument ( string $name )

{Returns the argument value for a given argument name.

Renvoie
mixed
Exceptions
InvalidArgumentException When argument given doesn't exist
}

Implémente InputInterface.

Références $name.

◆ getArguments()

getArguments ( )

{Returns all the given arguments merged with the default values.

Renvoie
array<string|bool|int|float|array|null>
}

Implémente InputInterface.

Références Input\$arguments.

◆ getOption()

getOption ( string $name )

{Returns the option value for a given option name.

Renvoie
mixed
Exceptions
InvalidArgumentException When option given doesn't exist
}

Implémente InputInterface.

Références $name, $value, et null.

◆ getOptions()

getOptions ( )

{Returns all the given options merged with the default values.

Renvoie
array<string|bool|int|float|array|null>
}

Implémente InputInterface.

Références Input\$options.

◆ getStream()

getStream ( )

{Returns the input stream.

Renvoie
resource|null
}

Implémente StreamableInputInterface.

Références Input\$stream.

◆ hasArgument()

hasArgument ( string $name )

{Returns true if an InputArgument object exists by name or position.

Renvoie
bool
}

Implémente InputInterface.

Références $name.

◆ hasOption()

hasOption ( string $name )

{Returns true if an InputOption object exists by name.

Renvoie
bool
}

Implémente InputInterface.

Références $name.

◆ isInteractive()

isInteractive ( )

{Is this input means interactive?

Renvoie
bool
}

Implémente InputInterface.

Références Input\$interactive.

◆ parse()

parse ( )
abstractprotected

Processes command line arguments.

Référencé par Input\bind().

◆ setArgument()

setArgument | ( | string | $name,
 |  |  | $value
 | ) |  |

{Sets an argument value by name.

Paramètres
mixed $value The argument value
Exceptions
InvalidArgumentException When argument given doesn't exist
}

Implémente InputInterface.

Références $name, et $value.

◆ setInteractive()

setInteractive ( bool $interactive )

{Sets the input interactivity.}

Implémente InputInterface.

Références Input\$interactive.

◆ setOption()

setOption | ( | string | $name,
 |  |  | $value
 | ) |  |

{Sets an option value by name.

Paramètres
mixed $value The option value
Exceptions
InvalidArgumentException When option given doesn't exist
}

Implémente InputInterface.

Références $name, $value, et elseif.

◆ setStream()

setStream ( $stream )

{Sets the input stream to read from when interacting with the user.This is mainly useful for testing purpose.

Paramètres
resource $stream The input stream
}

Implémente StreamableInputInterface.

Références Input\$stream.

◆ validate()

validate ( )

{Validates the input.

Exceptions
RuntimeException When not enough arguments are given
}

Implémente InputInterface.

Références Input\$arguments, et Input\$definition.

Référencé par Input\__construct().

Documentation des champs

◆ $arguments

$arguments = []
protected

Référencé par Input\getArguments(), et Input\validate().

◆ $definition

$definition
protected

Référencé par ArrayInput\__construct(), Input\__construct(), ArgvInput\__construct(), Input\bind(), CompletionInput\bind(), et Input\validate().

◆ $interactive

$interactive = true
protected

Référencé par Input\isInteractive(), et Input\setInteractive().

◆ $options

$options = []
protected

Référencé par Input\getOptions().

◆ $stream

$stream
protected

Référencé par Input\getStream(), et Input\setStream().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/symfony/console/Input/Input.php


Joomla CMS: Référence de la classe InputArgument

  • Symfony
  • Component
  • Console
  • Input
  • InputArgument
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe InputArgument

Fonctions membres publiques

__construct (string $name, int $mode=null, string $description='', $default=null)
getName ()
isRequired ()
isArray ()
setDefault ($default=null)
getDefault ()
getDescription ()

Champs de données

const | REQUIRED = 1
const | OPTIONAL = 2
const | IS_ARRAY = 4

Attributs privés

$name
$mode
$default
$description

Description détaillée

Represents a command line argument.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |
Paramètres
string | $name | The argument name
int | null | $mode | The argument mode: self::REQUIRED or self::OPTIONAL
string | $description | A description text
string | bool | int | float | array | null | $default | The default value (for self::OPTIONAL mode only)
Exceptions
InvalidArgumentException When argument mode is not valid

Références InputArgument\$default, InputArgument\$description, InputArgument\$mode, InputArgument\$name, description, elseif, name, null, et InputArgument\setDefault().

Documentation des fonctions membres

◆ getDefault()

getDefault ( )

Returns the default value.

Renvoie
string|bool|int|float|array|null

Références InputArgument\$default.

Référencé par TextDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputArgument(), JsonDescriptor\getInputArgumentData(), et XmlDescriptor\getInputArgumentDocument().

◆ getDescription()

getDescription ( )

Returns the description text.

Renvoie
string

Références InputArgument\$description.

Référencé par TextDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputArgument(), JsonDescriptor\getInputArgumentData(), et XmlDescriptor\getInputArgumentDocument().

◆ getName()

getName ( )

Returns the argument name.

Renvoie
string

Références InputArgument\$name.

Référencé par InputDefinition\addArgument(), TextDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputArgument(), JsonDescriptor\getInputArgumentData(), et XmlDescriptor\getInputArgumentDocument().

◆ isArray()

isArray ( )

Returns true if the argument can take multiple values.

Renvoie
bool true if mode is self::IS_ARRAY, false otherwise

Références InputArgument\$mode.

Référencé par InputDefinition\addArgument(), MarkdownDescriptor\describeInputArgument(), JsonDescriptor\getInputArgumentData(), XmlDescriptor\getInputArgumentDocument(), et InputArgument\setDefault().

◆ isRequired()

isRequired ( )

Returns true if the argument is required.

Renvoie
bool true if parameter mode is self::REQUIRED, false otherwise

Références InputArgument\$mode.

Référencé par InputDefinition\addArgument(), MarkdownDescriptor\describeInputArgument(), JsonDescriptor\getInputArgumentData(), et XmlDescriptor\getInputArgumentDocument().

◆ setDefault()

setDefault ( $default = null )

Sets the default value.

Paramètres
string | bool | int | float | array | null $default
Exceptions
LogicException When incorrect default value is given

Références InputArgument\$default, elseif, InputArgument\isArray(), et null.

Référencé par InputArgument\__construct().

Documentation des champs

◆ $default

$default
private

Référencé par InputArgument\__construct(), InputArgument\getDefault(), et InputArgument\setDefault().

◆ $description

$description
private

Référencé par InputArgument\__construct(), et InputArgument\getDescription().

◆ $mode

$mode
private

Référencé par InputArgument\__construct(), InputArgument\isArray(), et InputArgument\isRequired().

◆ $name

$name
private

Référencé par InputArgument\__construct(), et InputArgument\getName().

◆ IS_ARRAY

const IS_ARRAY = 4

Référencé par LintCommand\configure(), et SetConfigurationCommand\configure().

◆ OPTIONAL

const OPTIONAL = 2

Référencé par HelpCommand\configure(), ListCommand\configure(), DumpCompletionCommand\configure(), DebugEventDispatcherCommand\configure(), CleanCacheCommand\configure(), FinderIndexCommand\configure(), Application\doExecute(), et Application\doRun().

◆ REQUIRED

const REQUIRED = 1

Référencé par ExtensionRemoveCommand\configure(), SetConfigurationCommand\configure(), ConsoleApplication\getDefaultInputDefinition(), et Application\getDefaultInputDefinition().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InputArgument.php


Joomla CMS: Référence de l'interface InputAwareInterface

  • Symfony
  • Component
  • Console
  • Input
  • InputAwareInterface
Fonctions membres publiques
Référence de l'interface InputAwareInterface
+ Graphe d'héritage de InputAwareInterface:
InputAwareHelper

Fonctions membres publiques

setInput (InputInterface $input)

Description détaillée

InputAwareInterface should be implemented by classes that depends on the Console Input.

Auteur
Wouter J waldi.nosp@m.o.we.nosp@m.bdesi.nosp@m.gn@g.nosp@m.mail..nosp@m.com

Documentation des fonctions membres

◆ setInput()

setInput ( InputInterface $input )

Sets the Console Input.

Implémenté dans InputAwareHelper.

La documentation de cette interface a été générée à partir du fichier suivant :
  • InputAwareInterface.php


Joomla CMS: Référence de la classe InputDefinition

  • Symfony
  • Component
  • Console
  • Input
  • InputDefinition
Fonctions membres publiques | Attributs privés
Référence de la classe InputDefinition

Fonctions membres publiques

__construct (array $definition=[])
setDefinition (array $definition)
setArguments (array $arguments=[])
addArguments (?array $arguments=[])
addArgument (InputArgument $argument)
getArgument ($name)
hasArgument ($name)
getArguments ()
getArgumentCount ()
getArgumentRequiredCount ()
getArgumentDefaults ()
setOptions (array $options=[])
addOptions (array $options=[])
addOption (InputOption $option)
getOption (string $name)
hasOption (string $name)
getOptions ()
hasShortcut (string $name)
hasNegation (string $name)
getOptionForShortcut (string $shortcut)
getOptionDefaults ()
shortcutToName (string $shortcut)
negationToName (string $negation)
getSynopsis (bool $short=false)

Attributs privés

$arguments
$requiredCount
$lastArrayArgument
$lastOptionalArgument
$options
$negations
$shortcuts

Description détaillée

A InputDefinition represents a set of valid command line arguments and options.

Usage:

$definition = new InputDefinition([
    new InputArgument('name', InputArgument::REQUIRED),
    new InputOption('foo', 'f', InputOption::VALUE_REQUIRED),
]);
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $definition = [] )
Paramètres
array $definition An array of InputArgument and InputOption instance

Références InputDefinition\setDefinition().

Documentation des fonctions membres

◆ addArgument()

addArgument ( InputArgument $argument )
Exceptions
LogicException When incorrect argument is given

Références InputDefinition\$lastOptionalArgument, InputDefinition\$requiredCount, InputArgument\getName(), InputArgument\isArray(), InputArgument\isRequired(), et null.

Référencé par InputDefinition\addArguments().

◆ addArguments()

addArguments ( ?array $arguments = [] )

Adds an array of InputArgument objects.

Paramètres
InputArgument[] $arguments An array of InputArgument objects

Références InputDefinition\$arguments, InputDefinition\addArgument(), et null.

Référencé par InputDefinition\setArguments().

◆ addOption()

addOption ( InputOption $option )
Exceptions
LogicException When option given already exist

Références $option, et $this.

Référencé par InputDefinition\addOptions().

◆ addOptions()

addOptions ( array $options = [] )

Adds an array of InputOption objects.

Paramètres
InputOption[] $options An array of InputOption objects

Références $option, InputDefinition\$options, et InputDefinition\addOption().

Référencé par InputDefinition\setOptions().

◆ getArgument()

getArgument ( $name )

Returns an InputArgument by name or by position.

Paramètres
string | int $name The InputArgument name or position
Renvoie
InputArgument
Exceptions
InvalidArgumentException When argument given doesn't exist

Références InputDefinition\$arguments, $name, et InputDefinition\hasArgument().

◆ getArgumentCount()

getArgumentCount ( )

Returns the number of InputArguments.

Renvoie
int

Références null.

◆ getArgumentDefaults()

getArgumentDefaults ( )
Renvoie
array<string|bool|int|float|array|null>

◆ getArgumentRequiredCount()

getArgumentRequiredCount ( )

Returns the number of required InputArguments.

Renvoie
int

Références InputDefinition\$requiredCount.

◆ getArguments()

getArguments ( )

Gets the array of InputArgument objects.

Renvoie
InputArgument[]

Références InputDefinition\$arguments.

Référencé par MarkdownDescriptor\describeInputDefinition(), TextDescriptor\describeInputDefinition(), JsonDescriptor\getInputDefinitionData(), XmlDescriptor\getInputDefinitionDocument(), et InputDefinition\getSynopsis().

◆ getOption()

getOption ( string $name )

Returns an InputOption by name.

Renvoie
InputOption
Exceptions
InvalidArgumentException When option given doesn't exist

Références $name, et InputDefinition\hasOption().

Référencé par InputDefinition\getOptionForShortcut().

◆ getOptionDefaults()

getOptionDefaults ( )
Renvoie
array<string|bool|int|float|array|null>

Références $option.

◆ getOptionForShortcut()

getOptionForShortcut ( string $shortcut )

Gets an InputOption by shortcut.

Renvoie
InputOption

Références InputDefinition\getOption(), et InputDefinition\shortcutToName().

◆ getOptions()

getOptions ( )

Gets the array of InputOption objects.

Renvoie
InputOption[]

Références InputDefinition\$options.

Référencé par MarkdownDescriptor\describeInputDefinition(), TextDescriptor\describeInputDefinition(), JsonDescriptor\getInputDefinitionData(), XmlDescriptor\getInputDefinitionDocument(), et InputDefinition\getSynopsis().

◆ getSynopsis()

getSynopsis ( bool $short = false )

Gets the synopsis.

Renvoie
string

Références $option, $value, elseif, InputDefinition\getArguments(), et InputDefinition\getOptions().

◆ hasArgument()

hasArgument ( $name )

Returns true if an InputArgument object exists by name or position.

Paramètres
string | int $name The InputArgument name or position
Renvoie
bool

Références InputDefinition\$arguments, et $name.

Référencé par InputDefinition\getArgument().

◆ hasNegation()

hasNegation ( string $name )

Returns true if an InputOption object exists by negated name.

Références $name.

◆ hasOption()

hasOption ( string $name )

Returns true if an InputOption object exists by name.

This method can't be used to check if the user included the option when executing the command (use getOption() instead).

Renvoie
bool

Références $name.

Référencé par InputDefinition\getOption().

◆ hasShortcut()

hasShortcut ( string $name )

Returns true if an InputOption object exists by shortcut.

Renvoie
bool

Références $name.

◆ negationToName()

negationToName ( string $negation )

Returns the InputOption name given a negation.

Exceptions
InvalidArgumentException When option given does not exist

◆ setArguments()

setArguments ( array $arguments = [] )

Sets the InputArgument objects.

Paramètres
InputArgument[] $arguments An array of InputArgument objects

Références InputDefinition\$arguments, InputDefinition\addArguments(), et null.

Référencé par InputDefinition\setDefinition().

◆ setDefinition()

setDefinition ( array $definition )

Sets the definition of the input.

Références InputDefinition\$arguments, $item, InputDefinition\$options, InputDefinition\setArguments(), et InputDefinition\setOptions().

Référencé par InputDefinition\__construct().

◆ setOptions()

setOptions ( array $options = [] )

Sets the InputOption objects.

Paramètres
InputOption[] $options An array of InputOption objects

Références InputDefinition\$options, et InputDefinition\addOptions().

Référencé par InputDefinition\setDefinition().

◆ shortcutToName()

shortcutToName ( string $shortcut )

Returns the InputOption name given a shortcut.

Exceptions
InvalidArgumentException When option given does not exist

Référencé par InputDefinition\getOptionForShortcut().

Documentation des champs

◆ $arguments

$arguments
private

Référencé par InputDefinition\addArguments(), InputDefinition\getArgument(), InputDefinition\getArguments(), InputDefinition\hasArgument(), InputDefinition\setArguments(), et InputDefinition\setDefinition().

◆ $lastArrayArgument

$lastArrayArgument
private

◆ $lastOptionalArgument

$lastOptionalArgument
private

Référencé par InputDefinition\addArgument().

◆ $negations

$negations
private

◆ $options

$options
private

Référencé par InputDefinition\addOptions(), InputDefinition\getOptions(), InputDefinition\setDefinition(), et InputDefinition\setOptions().

◆ $requiredCount

$requiredCount
private

Référencé par InputDefinition\addArgument(), et InputDefinition\getArgumentRequiredCount().

◆ $shortcuts

$shortcuts
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • InputDefinition.php


Joomla CMS: Référence de l'interface InputInterface

  • Symfony
  • Component
  • Console
  • Input
  • InputInterface
Fonctions membres publiques
Référence de l'interface InputInterface
+ Graphe d'héritage de InputInterface:
Input StreamableInputInterface ArgvInput ArrayInput Input CompletionInput StringInput ArgvInput ArrayInput CompletionInput StringInput

Fonctions membres publiques

getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
bind (InputDefinition $definition)
validate ()
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
isInteractive ()
setInteractive (bool $interactive)

Description détaillée

InputInterface is the interface implemented by all input classes.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ bind()

bind ( InputDefinition $definition )

Binds the current Input instance with the given arguments and options.

Exceptions
RuntimeException

Implémenté dans CompletionInput, et Input.

Référencé par Application\doRun(), AbstractCommand\execute(), et Command\run().

◆ getArgument()

getArgument ( string $name )

Returns the argument value for a given argument name.

Renvoie
mixed
Exceptions
InvalidArgumentException When argument given doesn't exist

Implémenté dans Input.

Référencé par HelpCommand\execute().

◆ getArguments()

getArguments ( )

Returns all the given arguments merged with the default values.

Renvoie
array<string|bool|int|float|array|null>

Implémenté dans Input.

◆ getFirstArgument()

getFirstArgument ( )

Returns the first argument from the raw parameters (not parsed).

Renvoie
string|null

Implémenté dans ArgvInput, et ArrayInput.

◆ getOption()

getOption ( string $name )

Returns the option value for a given option name.

Renvoie
mixed
Exceptions
InvalidArgumentException When option given doesn't exist

Implémenté dans Input.

◆ getOptions()

getOptions ( )

Returns all the given options merged with the default values.

Renvoie
array<string|bool|int|float|array|null>

Implémenté dans Input.

◆ getParameterOption()

getParameterOption | ( |  | $values,
 |  |  | $default = false,
 |  | bool | $onlyParams = false
 | ) |  |

Returns the value of a raw option (not parsed).

This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The value(s) to look for in the raw parameters (can be an array)
string | bool | int | float | array | null | $default | The default value to return if no result is found
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
mixed

Implémenté dans ArgvInput, et ArrayInput.

◆ hasArgument()

hasArgument ( string $name )

Returns true if an InputArgument object exists by name or position.

Renvoie
bool

Implémenté dans Input.

◆ hasOption()

hasOption ( string $name )

Returns true if an InputOption object exists by name.

Renvoie
bool

Implémenté dans Input.

◆ hasParameterOption()

hasParameterOption | ( |  | $values,
 |  | bool | $onlyParams = false
 | ) |  |

Returns true if the raw parameters (not parsed) contain a value.

This method is to be used to introspect the input parameters before they have been validated. It must be used carefully. Does not necessarily return the correct result for short options when multiple flags are combined in the same option.

Paramètres
string | array | $values | The values to look for in the raw parameters (can be an array)
bool | $onlyParams | Only check real parameters, skip those following an end of options (–) signal
Renvoie
bool

Implémenté dans ArgvInput, et ArrayInput.

◆ isInteractive()

isInteractive ( )

Is this input means interactive?

Renvoie
bool

Implémenté dans Input.

◆ setArgument()

setArgument | ( | string | $name,
 |  |  | $value
 | ) |  |

Sets an argument value by name.

Paramètres
mixed $value The argument value
Exceptions
InvalidArgumentException When argument given doesn't exist

Implémenté dans Input.

◆ setInteractive()

setInteractive ( bool $interactive )

Sets the input interactivity.

Implémenté dans Input.

◆ setOption()

setOption | ( | string | $name,
 |  |  | $value
 | ) |  |

Sets an option value by name.

Paramètres
mixed $value The option value
Exceptions
InvalidArgumentException When option given doesn't exist

Implémenté dans Input.

◆ validate()

validate ( )

Validates the input.

Exceptions
RuntimeException When not enough arguments are given

Implémenté dans Input.

Référencé par AbstractCommand\execute(), et Command\run().

La documentation de cette interface a été générée à partir du fichier suivant :
  • InputInterface.php


Joomla CMS: Référence de la classe InputOption

  • Symfony
  • Component
  • Console
  • Input
  • InputOption
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe InputOption

Fonctions membres publiques

__construct (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
getShortcut ()
getName ()
acceptValue ()
isValueRequired ()
isValueOptional ()
isArray ()
isNegatable ()
setDefault ($default=null)
getDefault ()
getDescription ()
equals (self $option)

Champs de données

const | VALUE_NONE = 1
const | VALUE_REQUIRED = 2
const | VALUE_OPTIONAL = 4
const | VALUE_IS_ARRAY = 8
const | VALUE_NEGATABLE = 16

Attributs privés

$name
$shortcut
$mode
$default
$description

Description détaillée

Represents a command line option.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  |  | $shortcut = null,
 |  | int | $mode = null,
 |  | string | $description = '',
 |  |  | $default = null
 | ) |  |
Paramètres
string | array | null | $shortcut | The shortcuts, can be null, a string of shortcuts delimited by | or an array of shortcuts
int | null | $mode | The option mode: One of the VALUE_* constants
string | bool | int | float | array | null | $default | The default value (must be null for self::VALUE_NONE)
Exceptions
InvalidArgumentException If option mode is invalid or incompatible

Références InputOption\$default, InputOption\$description, InputOption\$mode, InputOption\$name, InputOption\$shortcut, InputOption\acceptValue(), description, elseif, InputOption\isArray(), InputOption\isNegatable(), name, null, et InputOption\setDefault().

Documentation des fonctions membres

◆ acceptValue()

acceptValue ( )

Returns true if the option accepts a value.

Renvoie
bool true if value mode is not self::VALUE_NONE, false otherwise

Références InputOption\isValueOptional(), et InputOption\isValueRequired().

Référencé par InputOption\__construct(), et InputOption\setDefault().

◆ equals()

equals ( self $option )

Checks whether the given option equals this one.

Renvoie
bool

Références $option, InputOption\getDefault(), InputOption\getName(), InputOption\getShortcut(), InputOption\isArray(), InputOption\isNegatable(), InputOption\isValueOptional(), et InputOption\isValueRequired().

◆ getDefault()

getDefault ( )

Returns the default value.

Renvoie
string|bool|int|float|array|null

Références InputOption\$default.

Référencé par TextDescriptor\describeInputOption(), et InputOption\equals().

◆ getDescription()

getDescription ( )

Returns the description text.

Renvoie
string

Références InputOption\$description.

Référencé par MarkdownDescriptor\describeInputOption().

◆ getName()

getName ( )

Returns the option name.

Renvoie
string

Références InputOption\$name.

Référencé par InputOption\equals().

◆ getShortcut()

getShortcut ( )

Returns the option shortcut.

Renvoie
string|null

Références InputOption\$shortcut.

Référencé par InputOption\equals().

◆ isArray()

isArray ( )

Returns true if the option can take multiple values.

Renvoie
bool true if mode is self::VALUE_IS_ARRAY, false otherwise

Références InputOption\$mode.

Référencé par InputOption\__construct(), InputOption\equals(), et InputOption\setDefault().

◆ isNegatable()

isNegatable ( )

Références InputOption\$mode.

Référencé par InputOption\__construct(), InputOption\equals(), et InputOption\setDefault().

◆ isValueOptional()

isValueOptional ( )

Returns true if the option takes an optional value.

Renvoie
bool true if value mode is self::VALUE_OPTIONAL, false otherwise

Références InputOption\$mode.

Référencé par InputOption\acceptValue(), et InputOption\equals().

◆ isValueRequired()

isValueRequired ( )

Returns true if the option requires a value.

Renvoie
bool true if value mode is self::VALUE_REQUIRED, false otherwise

Références InputOption\$mode.

Référencé par InputOption\acceptValue(), et InputOption\equals().

◆ setDefault()

setDefault ( $default = null )
Paramètres
string | bool | int | float | array | null $default

Références InputOption\$default, InputOption\acceptValue(), elseif, InputOption\isArray(), InputOption\isNegatable(), et null.

Référencé par InputOption\__construct().

Documentation des champs

◆ $default

$default
private

Référencé par InputOption\__construct(), InputOption\getDefault(), et InputOption\setDefault().

◆ $description

$description
private

Référencé par InputOption\__construct(), et InputOption\getDescription().

◆ $mode

$mode
private

Référencé par InputOption\__construct(), InputOption\isArray(), InputOption\isNegatable(), InputOption\isValueOptional(), et InputOption\isValueRequired().

◆ $name

$name
private

Référencé par InputOption\__construct(), et InputOption\getName().

◆ $shortcut

$shortcut
private

Référencé par InputOption\__construct(), et InputOption\getShortcut().

◆ VALUE_IS_ARRAY

const VALUE_IS_ARRAY = 8

The option accepts multiple values (e.g. –dir=/foo –dir=/bar).

Référencé par CompleteCommand\configure(), et LintCommand\configure().

◆ VALUE_NEGATABLE

const VALUE_NEGATABLE = 16

The option may have either positive or negative value (e.g. –ansi or –no-ansi).

Référencé par LintCommand\configure(), et Application\getDefaultInputDefinition().

◆ VALUE_NONE

const VALUE_NONE = 1

Do not accept input for the option (e.g. –yell). This is the default behavior of options.

Référencé par ListCommand\configure(), HelpCommand\configure(), DumpCompletionCommand\configure(), DebugRouterCommand\configure(), RemoveOldFilesCommand\configure(), TasksRunCommand\configure(), ExportCommand\configure(), ConsoleApplication\getDefaultInputDefinition(), et Application\getDefaultInputDefinition().

◆ VALUE_OPTIONAL

const VALUE_OPTIONAL = 4

The option may or may not have a value (e.g. –yell or –yell=loud).

Référencé par SessionGcCommand\configure(), ChangeUserPasswordCommand\configure(), ExportCommand\configure(), DeleteUserCommand\configure(), ImportCommand\configure(), AddUserToGroupCommand\configure(), RemoveUserFromGroupCommand\configure(), AddUserCommand\configure(), et ConsoleApplication\getDefaultInputDefinition().

◆ VALUE_REQUIRED

const VALUE_REQUIRED = 2

A value must be passed when the option is used (e.g. –iterations=5 or -i5).

Référencé par ListCommand\configure(), HelpCommand\configure(), CompleteCommand\configure(), LintCommand\configure(), ServerDumpCommand\configure(), ExtensionInstallCommand\configure(), ExtensionDiscoverInstallCommand\configure(), ExtensionsListCommand\configure(), TasksRunCommand\configure(), FinderIndexCommand\configure(), ExportCommand\configure(), TasksStateCommand\configure(), ImportCommand\configure(), et GetConfigurationCommand\configure().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InputOption.php


Joomla CMS: Référence de l'interface StreamableInputInterface

  • Symfony
  • Component
  • Console
  • Input
  • StreamableInputInterface
Fonctions membres publiques
Référence de l'interface StreamableInputInterface
+ Graphe d'héritage de StreamableInputInterface:
InputInterface Input ArgvInput ArrayInput CompletionInput StringInput

Fonctions membres publiques

setStream ($stream)
getStream ()
- Fonctions membres publiques hérités de InputInterface
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
bind (InputDefinition $definition)
validate ()
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
isInteractive ()
setInteractive (bool $interactive)

Description détaillée

StreamableInputInterface is the interface implemented by all input classes that have an input stream.

Auteur
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des fonctions membres

◆ getStream()

getStream ( )

Returns the input stream.

Renvoie
resource|null

Implémenté dans Input.

◆ setStream()

setStream ( $stream )

Sets the input stream to read from when interacting with the user.

This is mainly useful for testing purpose.

Paramètres
resource $stream The input stream

Implémenté dans Input.

La documentation de cette interface a été générée à partir du fichier suivant :
  • StreamableInputInterface.php


Joomla CMS: Référence de la classe StringInput

  • Symfony
  • Component
  • Console
  • Input
  • StringInput
Fonctions membres publiques | Champs de données | Fonctions membres privées
Référence de la classe StringInput
+ Graphe d'héritage de StringInput:
ArgvInput Input InputInterface StreamableInputInterface InputInterface

Fonctions membres publiques

__construct (string $input)
- Fonctions membres publiques hérités de ArgvInput
__construct (array $argv=null, InputDefinition $definition=null)
getFirstArgument ()
hasParameterOption ($values, bool $onlyParams=false)
getParameterOption ($values, $default=false, bool $onlyParams=false)
__toString ()
- Fonctions membres publiques hérités de Input
__construct (InputDefinition $definition=null)
bind (InputDefinition $definition)
validate ()
isInteractive ()
setInteractive (bool $interactive)
getArguments ()
getArgument (string $name)
setArgument (string $name, $value)
hasArgument (string $name)
getOptions ()
getOption (string $name)
setOption (string $name, $value)
hasOption (string $name)
escapeToken (string $token)
setStream ($stream)
getStream ()

Champs de données

const | REGEX_STRING = '([^\s]+?)(?:\s|(?<!\\\\)"|(?<!\\\\)\'|$)'
const | REGEX_UNQUOTED_STRING = '([^\s\\\\]+?)'
const | REGEX_QUOTED_STRING = '(?:"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')'

Fonctions membres privées

tokenize (string $input)

Membres hérités additionnels

- Fonctions membres protégées hérités de ArgvInput
setTokens (array $tokens)
parse ()
parseToken (string $token, bool $parseOptions)
- Fonctions membres protégées hérités de Input
parse ()
- Attributs protégés hérités de Input
$definition
$stream
$options = []
$arguments = []
$interactive = true

Description détaillée

StringInput represents an input provided as a string.

Usage:

$input = new StringInput('foo --bar="foobar"');
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $input )
Paramètres
string $input A string representing the parameters from the CLI

Références Symfony\Contracts\Service\__construct(), ArgvInput\setTokens(), et StringInput\tokenize().

Documentation des fonctions membres

◆ tokenize()

tokenize ( string $input )
private

Tokenizes a string.

Exceptions
InvalidArgumentException When unable to parse input (should never happen)

Références $input, ArgvInput\$tokens, elseif, et null.

Référencé par StringInput\__construct().

Documentation des champs

◆ REGEX_QUOTED_STRING

const REGEX_QUOTED_STRING = '(?:"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')'

◆ REGEX_STRING

const REGEX_STRING = '([^\s]+?)(?:\s|(?<!\\\\)"|(?<!\\\\)\'|$)'

◆ REGEX_UNQUOTED_STRING

const REGEX_UNQUOTED_STRING = '([^\s\\\\]+?)'
La documentation de cette classe a été générée à partir du fichier suivant :
  • StringInput.php


Joomla CMS: Référence de la classe ConsoleLogger

  • Symfony
  • Component
  • Console
  • Logger
  • ConsoleLogger
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe ConsoleLogger
+ Graphe d'héritage de ConsoleLogger:
AbstractLogger LoggerInterface

Fonctions membres publiques

__construct (OutputInterface $output, array $verbosityLevelMap=[], array $formatLevelMap=[])
log ($level, $message, array $context=[])
hasErrored ()
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Champs de données

const | INFO = 'info'
const | ERROR = 'error'

Fonctions membres privées

interpolate (string $message, array $context)

Attributs privés

$output
$verbosityLevelMap
$formatLevelMap
$errored = false

Description détaillée

PSR-3 compliant console logger.

Auteur
Kévin Dunglas dungl.nosp@m.as@g.nosp@m.mail..nosp@m.com
Voir également
https://www.php-fig.org/psr/psr-3/

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | OutputInterface | $output,
 |  | array | $verbosityLevelMap = [],
 |  | array | $formatLevelMap = []
 | ) |  |

Références ConsoleLogger\$formatLevelMap, ConsoleLogger\$output, et ConsoleLogger\$verbosityLevelMap.

Documentation des fonctions membres

◆ hasErrored()

hasErrored ( )

Returns true when any messages have been logged at error levels.

Renvoie
bool

Références ConsoleLogger\$errored.

◆ interpolate()

interpolate | ( | string | $message,
 |  | array | $context
 | ) |  |
private

Interpolates context values into the message placeholders.

Auteur
PHP Framework Interoperability Group

Références $context, $key, $message, $val, elseif, et null.

Référencé par ConsoleLogger\log().

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = []
 | ) |  |

{Logs with an arbitrary level.

Paramètres
mixed | $level
string | $message
mixed[] | $context
Renvoie
void
Exceptions
}

Renvoie
void

Implémente LoggerInterface.

Références $context, $message, ConsoleLogger\$output, et ConsoleLogger\interpolate().

Documentation des champs

◆ $errored

$errored = false
private

Référencé par ConsoleLogger\hasErrored().

◆ $formatLevelMap

$formatLevelMap
private
Valeur initiale :
= [
LogLevel::EMERGENCY => self::ERROR

Référencé par ConsoleLogger\__construct().

◆ $output

$output
private

Référencé par ConsoleLogger\__construct(), et ConsoleLogger\log().

◆ $verbosityLevelMap

$verbosityLevelMap
private
Valeur initiale :
= [
LogLevel::EMERGENCY => OutputInterface::VERBOSITY_NORMAL

Référencé par ConsoleLogger\__construct().

◆ ERROR

const ERROR = 'error'

◆ INFO

const INFO = 'info'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleLogger.php


Joomla CMS: Référence de la classe BufferedOutput

  • Symfony
  • Component
  • Console
  • Output
  • BufferedOutput
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe BufferedOutput
+ Graphe d'héritage de BufferedOutput:
Output OutputInterface

Fonctions membres publiques

fetch ()
- Fonctions membres publiques hérités de Output
__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

doWrite (string $message, bool $newline)
- Fonctions membres protégées hérités de Output
doWrite (string $message, bool $newline)

Attributs privés

$buffer = ''

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

Auteur
Jean-François Simon conta.nosp@m.ct@j.nosp@m.fsimo.nosp@m.n.fr

Documentation des fonctions membres

◆ doWrite()

doWrite | ( | string | $message,
 |  | bool | $newline
 | ) |  |
protected

{}

Références $message.

◆ fetch()

fetch ( )

Empties buffer and returns its content.

Renvoie
string

Références BufferedOutput\$buffer, et $content.

Documentation des champs

◆ $buffer

$buffer = ''
private

Référencé par BufferedOutput\fetch().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BufferedOutput.php


Joomla CMS: Référence de la classe ConsoleOutput

  • Symfony
  • Component
  • Console
  • Output
  • ConsoleOutput
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe ConsoleOutput
+ Graphe d'héritage de ConsoleOutput:
StreamOutput ConsoleOutputInterface Output OutputInterface OutputInterface

Fonctions membres publiques

__construct (int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=null, OutputFormatterInterface $formatter=null)
section ()
setDecorated (bool $decorated)
setFormatter (OutputFormatterInterface $formatter)
setVerbosity (int $level)
getErrorOutput ()
setErrorOutput (OutputInterface $error)
- Fonctions membres publiques hérités de StreamOutput
__construct ($stream, int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=null, OutputFormatterInterface $formatter=null)
getStream ()
- Fonctions membres publiques hérités de Output
__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

hasStdoutSupport ()
hasStderrSupport ()
- Fonctions membres protégées hérités de StreamOutput
doWrite (string $message, bool $newline)
hasColorSupport ()
- Fonctions membres protégées hérités de Output
doWrite (string $message, bool $newline)

Fonctions membres privées

isRunningOS400 ()
openOutputStream ()
openErrorStream ()

Attributs privés

$stderr
$consoleSectionOutputs = []

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

ConsoleOutput is the default class for all CLI output. It uses STDOUT and STDERR.

This class is a convenient wrapper around StreamOutput for both STDOUT and STDERR.

$output = new ConsoleOutput();

This is equivalent to:

$output = new StreamOutput(fopen('php://stdout', 'w'));
$stdErr = new StreamOutput(fopen('php://stderr', 'w'));
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $verbosity = self::VERBOSITY_NORMAL,
 |  | bool | $decorated = null,
 |  | OutputFormatterInterface | $formatter = null
 | ) |  |
Paramètres
int | $verbosity | The verbosity level (one of the VERBOSITY constants in OutputInterface)
bool | null | $decorated | Whether to decorate messages (null for auto-guessing)
OutputFormatterInterface | null | $formatter | Output formatter instance (null to use default OutputFormatter)

Références Output\$formatter, Output\$verbosity, Symfony\Contracts\Service\__construct(), Output\getFormatter(), Output\isDecorated(), null, ConsoleOutput\openErrorStream(), ConsoleOutput\openOutputStream(), et ConsoleOutput\setDecorated().

Documentation des fonctions membres

◆ getErrorOutput()

getErrorOutput ( )

{Gets the OutputInterface for errors.

Renvoie
OutputInterface
}

Implémente ConsoleOutputInterface.

Références ConsoleOutput\$stderr.

◆ hasStderrSupport()

hasStderrSupport ( )
protected

Returns true if current environment supports writing console output to STDERR.

Renvoie
bool

Références ConsoleOutput\isRunningOS400().

Référencé par ConsoleOutput\openErrorStream().

◆ hasStdoutSupport()

hasStdoutSupport ( )
protected

Returns true if current environment supports writing console output to STDOUT.

Renvoie
bool

Références ConsoleOutput\isRunningOS400().

Référencé par ConsoleOutput\openOutputStream().

◆ isRunningOS400()

isRunningOS400 ( )
private

Checks if current executing environment is IBM iSeries (OS400), which doesn't properly convert character-encodings between ASCII to EBCDIC.

Référencé par ConsoleOutput\hasStderrSupport(), et ConsoleOutput\hasStdoutSupport().

◆ openErrorStream()

openErrorStream ( )
private
Renvoie
resource

Références ConsoleOutput\hasStderrSupport().

Référencé par ConsoleOutput\__construct().

◆ openOutputStream()

openOutputStream ( )
private
Renvoie
resource

Références ConsoleOutput\hasStdoutSupport().

Référencé par ConsoleOutput\__construct().

◆ section()

section ( )

Creates a new output section.

Implémente ConsoleOutputInterface.

Références Output\getFormatter(), StreamOutput\getStream(), Output\getVerbosity(), et Output\isDecorated().

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputInterface.

Référencé par ConsoleOutput\__construct().

◆ setErrorOutput()

setErrorOutput ( OutputInterface $error )

{}

Implémente ConsoleOutputInterface.

◆ setFormatter()

setFormatter ( OutputFormatterInterface $formatter )

{}

Implémente OutputInterface.

Références Output\$formatter.

◆ setVerbosity()

setVerbosity ( int $level )

{Sets the verbosity of the output.}

Implémente OutputInterface.

Documentation des champs

◆ $consoleSectionOutputs

$consoleSectionOutputs = []
private

◆ $stderr

$stderr
private

Référencé par ConsoleOutput\getErrorOutput().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleOutput.php


Joomla CMS: Référence de l'interface ConsoleOutputInterface

  • Symfony
  • Component
  • Console
  • Output
  • ConsoleOutputInterface
Fonctions membres publiques
Référence de l'interface ConsoleOutputInterface
+ Graphe d'héritage de ConsoleOutputInterface:
OutputInterface ConsoleOutput

Fonctions membres publiques

getErrorOutput ()
setErrorOutput (OutputInterface $error)
section ()
- Fonctions membres publiques hérités de OutputInterface
write ($messages, bool $newline=false, int $options=0)
writeln ($messages, int $options=0)
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
setDecorated (bool $decorated)
isDecorated ()
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

ConsoleOutputInterface is the interface implemented by ConsoleOutput class. This adds information about stderr and section output stream.

Auteur
Dariusz Górecki darek.nosp@m..krk.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des fonctions membres

◆ getErrorOutput()

getErrorOutput ( )

Gets the OutputInterface for errors.

Renvoie
OutputInterface

Implémenté dans ConsoleOutput.

Référencé par Application\renderThrowable().

◆ section()

section ( )

Implémenté dans ConsoleOutput.

Référencé par SymfonyStyle\createTable().

◆ setErrorOutput()

setErrorOutput ( OutputInterface $error )

Implémenté dans ConsoleOutput.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ConsoleOutputInterface.php


Joomla CMS: Référence de la classe ConsoleSectionOutput

  • Symfony
  • Component
  • Console
  • Output
  • ConsoleSectionOutput
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe ConsoleSectionOutput
+ Graphe d'héritage de ConsoleSectionOutput:
StreamOutput Output OutputInterface

Fonctions membres publiques

__construct ($stream, array &$sections, int $verbosity, bool $decorated, OutputFormatterInterface $formatter)
clear (int $lines=null)
overwrite ($message)
getContent ()
addContent (string $input)
- Fonctions membres publiques hérités de StreamOutput
__construct ($stream, int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=null, OutputFormatterInterface $formatter=null)
getStream ()
- Fonctions membres publiques hérités de Output
__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

doWrite (string $message, bool $newline)
- Fonctions membres protégées hérités de StreamOutput
doWrite (string $message, bool $newline)
hasColorSupport ()
- Fonctions membres protégées hérités de Output
doWrite (string $message, bool $newline)

Fonctions membres privées

popStreamContentUntilCurrentSection (int $numberOfLinesToClearFromCurrentSection=0)
getDisplayLength (string $text)

Attributs privés

$content = []
$lines = 0
$sections
$terminal

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

Auteur
Pierre du Plessis pdple.nosp@m.s@gm.nosp@m.ail.c.nosp@m.om
Gabriel Ostrolucký gabri.nosp@m.el.o.nosp@m.strol.nosp@m.ucky.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $stream,
 |  | array & | $sections,
 |  | int | $verbosity,
 |  | bool | $decorated,
 |  | OutputFormatterInterface | $formatter
 | ) |  |
Paramètres
resource | $stream
ConsoleSectionOutput[] | $sections

Références Output\$formatter, ConsoleSectionOutput\$sections, StreamOutput\$stream, $this, Output\$verbosity, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ addContent()

addContent ( string $input )

Références $input, content, et ConsoleSectionOutput\getDisplayLength().

Référencé par ConsoleSectionOutput\doWrite().

◆ clear()

clear ( int $lines = null )

Clears previous output for this section.

Paramètres
int $lines Number of lines to clear. If null, then the entire output of this section is cleared

Références ConsoleSectionOutput\$lines, content, Output\isDecorated(), et ConsoleSectionOutput\popStreamContentUntilCurrentSection().

Référencé par ConsoleSectionOutput\overwrite().

◆ doWrite()

doWrite | ( | string | $message,
 |  | bool | $newline
 | ) |  |
protected

{}

Références $message, ConsoleSectionOutput\addContent(), Output\isDecorated(), et ConsoleSectionOutput\popStreamContentUntilCurrentSection().

◆ getContent()

getContent ( )

Références content.

◆ getDisplayLength()

getDisplayLength ( string $text )
private

Références Output\getFormatter(), Helper\removeDecoration(), et Helper\width().

Référencé par ConsoleSectionOutput\addContent().

◆ overwrite()

overwrite ( $message )

Overwrites the previous output with a new message.

Paramètres
array | string $message

Références $message, ConsoleSectionOutput\clear(), et Output\writeln().

◆ popStreamContentUntilCurrentSection()

popStreamContentUntilCurrentSection ( int $numberOfLinesToClearFromCurrentSection = 0 )
private

At initial stage, cursor is at the end of stream output. This method makes cursor crawl upwards until it hits current section. Then it erases content it crawled through. Optionally, it erases part of current section too.

Références $section, et $this.

Référencé par ConsoleSectionOutput\clear(), et ConsoleSectionOutput\doWrite().

Documentation des champs

◆ $content

$content = []
private

◆ $lines

$lines = 0
private

Référencé par ConsoleSectionOutput\clear().

◆ $sections

$sections
private

Référencé par ConsoleSectionOutput\__construct().

◆ $terminal

$terminal
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConsoleSectionOutput.php


Joomla CMS: Référence de la classe NullOutput

  • Symfony
  • Component
  • Console
  • Output
  • NullOutput
Fonctions membres publiques | Attributs privés
Référence de la classe NullOutput
+ Graphe d'héritage de NullOutput:
OutputInterface

Fonctions membres publiques

setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Attributs privés

$formatter

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

NullOutput suppresses all output.

$output = new NullOutput();
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Tobias Schultze http://tobion.de

Documentation des fonctions membres

◆ getFormatter()

getFormatter ( )

{Returns current output formatter instance.

Renvoie
OutputFormatterInterface
}

Implémente OutputInterface.

Références NullOutput\$formatter.

◆ getVerbosity()

getVerbosity ( )

{Gets the current verbosity of the output.

Renvoie
int
}

Implémente OutputInterface.

◆ isDebug()

isDebug ( )

{Returns whether verbosity is debug (-vvv).

Renvoie
bool
}

Implémente OutputInterface.

◆ isDecorated()

isDecorated ( )

{Gets the decorated flag.

Renvoie
bool
}

Implémente OutputInterface.

◆ isQuiet()

isQuiet ( )

{Returns whether verbosity is quiet (-q).

Renvoie
bool
}

Implémente OutputInterface.

◆ isVerbose()

isVerbose ( )

{Returns whether verbosity is verbose (-v).

Renvoie
bool
}

Implémente OutputInterface.

◆ isVeryVerbose()

isVeryVerbose ( )

{Returns whether verbosity is very verbose (-vv).

Renvoie
bool
}

Implémente OutputInterface.

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputInterface.

◆ setFormatter()

setFormatter ( OutputFormatterInterface $formatter )

{}

Implémente OutputInterface.

◆ setVerbosity()

setVerbosity ( int $level )

{Sets the verbosity of the output.}

Implémente OutputInterface.

◆ write()

write | ( |  | $messages,
 |  | bool | $newline = false,
 |  | int | $options = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
bool | $newline | Whether to add a newline
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

◆ writeln()

writeln | ( |  | $messages,
 |  | int | $options = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output and adds a newline at the end.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Documentation des champs

◆ $formatter

$formatter
private

Référencé par NullOutput\getFormatter().

La documentation de cette classe a été générée à partir du fichier suivant :
  • NullOutput.php


Joomla CMS: Référence de la classe Output

  • Symfony
  • Component
  • Console
  • Output
  • Output
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe Output
+ Graphe d'héritage de Output:
OutputInterface BufferedOutput StreamOutput TrimmedBufferOutput ConsoleOutput ConsoleSectionOutput

Fonctions membres publiques

__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

doWrite (string $message, bool $newline)

Attributs privés

$verbosity
$formatter

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

Base class for output classes.

There are five levels of verbosity:

  • normal: no option passed (normal output)
  • verbose: -v (more output)
  • very verbose: -vv (highly extended output)
  • debug: -vvv (all debug output)
  • quiet: -q (no output)
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?int | $verbosity = self::VERBOSITY_NORMAL,
 |  | bool | $decorated = false,
 |  | OutputFormatterInterface | $formatter = null
 | ) |  |
Paramètres
int | null | $verbosity | The verbosity level (one of the VERBOSITY constants in OutputInterface)
bool | $decorated | Whether to decorate messages
OutputFormatterInterface | null | $formatter | Output formatter instance (null to use default OutputFormatter)

Références Output\$formatter, et Output\$verbosity.

Documentation des fonctions membres

◆ doWrite()

doWrite | ( | string | $message,
 |  | bool | $newline
 | ) |  |
abstractprotected

Writes a message to the output.

Référencé par Output\write().

◆ getFormatter()

getFormatter ( )

{Returns current output formatter instance.

Renvoie
OutputFormatterInterface
}

Implémente OutputInterface.

Références Output\$formatter.

Référencé par ConsoleOutput\__construct(), ConsoleSectionOutput\getDisplayLength(), et ConsoleOutput\section().

◆ getVerbosity()

getVerbosity ( )

{Gets the current verbosity of the output.

Renvoie
int
}

Implémente OutputInterface.

Références Output\$verbosity.

Référencé par ConsoleOutput\section(), et Output\write().

◆ isDebug()

isDebug ( )

{Returns whether verbosity is debug (-vvv).

Renvoie
bool
}

Implémente OutputInterface.

Références Output\$verbosity.

◆ isDecorated()

isDecorated ( )

{Gets the decorated flag.

Renvoie
bool
}

Implémente OutputInterface.

Référencé par ConsoleOutput\__construct(), ConsoleSectionOutput\clear(), ConsoleSectionOutput\doWrite(), et ConsoleOutput\section().

◆ isQuiet()

isQuiet ( )

{Returns whether verbosity is quiet (-q).

Renvoie
bool
}

Implémente OutputInterface.

Références Output\$verbosity.

◆ isVerbose()

isVerbose ( )

{Returns whether verbosity is verbose (-v).

Renvoie
bool
}

Implémente OutputInterface.

Références Output\$verbosity.

◆ isVeryVerbose()

isVeryVerbose ( )

{Returns whether verbosity is very verbose (-vv).

Renvoie
bool
}

Implémente OutputInterface.

Références Output\$verbosity.

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputInterface.

◆ setFormatter()

setFormatter ( OutputFormatterInterface $formatter )

{}

Implémente OutputInterface.

Références Output\$formatter.

◆ setVerbosity()

setVerbosity ( int $level )

{Sets the verbosity of the output.}

Implémente OutputInterface.

◆ write()

write | ( |  | $messages,
 |  | bool | $newline = false,
 |  | int | $options = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
bool | $newline | Whether to add a newline
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $message, $messages, $options, $type, Output\$verbosity, Output\doWrite(), Output\getVerbosity(), OutputInterface\OUTPUT_NORMAL, OutputInterface\OUTPUT_PLAIN, et OutputInterface\OUTPUT_RAW.

Référencé par Output\writeln().

◆ writeln()

writeln | ( |  | $messages,
 |  | int | $options = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output and adds a newline at the end.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $messages, $options, et Output\write().

Référencé par ConsoleSectionOutput\overwrite().

Documentation des champs

◆ $formatter

$formatter
private

Référencé par TrimmedBufferOutput\__construct(), ConsoleSectionOutput\__construct(), Output\__construct(), ConsoleOutput\__construct(), StreamOutput\__construct(), Output\getFormatter(), Output\setFormatter(), et ConsoleOutput\setFormatter().

◆ $verbosity

$verbosity
private

Référencé par TrimmedBufferOutput\__construct(), ConsoleSectionOutput\__construct(), ConsoleOutput\__construct(), Output\__construct(), StreamOutput\__construct(), Output\getVerbosity(), Output\isDebug(), Output\isQuiet(), Output\isVerbose(), Output\isVeryVerbose(), et Output\write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Output.php


Joomla CMS: Référence de l'interface OutputInterface

  • Symfony
  • Component
  • Console
  • Output
  • OutputInterface
Fonctions membres publiques | Champs de données
Référence de l'interface OutputInterface
+ Graphe d'héritage de OutputInterface:
ConsoleOutputInterface NullOutput Output OutputStyle ConsoleOutput BufferedOutput StreamOutput TrimmedBufferOutput SymfonyStyle ConsoleOutput ConsoleSectionOutput

Fonctions membres publiques

write ($messages, bool $newline=false, int $options=0)
writeln ($messages, int $options=0)
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
setDecorated (bool $decorated)
isDecorated ()
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()

Champs de données

const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

OutputInterface is the interface implemented by all Output classes.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ getFormatter()

getFormatter ( )

Returns current output formatter instance.

Renvoie
OutputFormatterInterface

Implémenté dans OutputStyle, Output, et NullOutput.

◆ getVerbosity()

getVerbosity ( )

Gets the current verbosity of the output.

Renvoie
int

Implémenté dans Output, NullOutput, et OutputStyle.

◆ isDebug()

isDebug ( )

Returns whether verbosity is debug (-vvv).

Renvoie
bool

Implémenté dans OutputStyle, Output, et NullOutput.

◆ isDecorated()

isDecorated ( )

Gets the decorated flag.

Renvoie
bool

Implémenté dans OutputStyle, Output, et NullOutput.

◆ isQuiet()

isQuiet ( )

Returns whether verbosity is quiet (-q).

Renvoie
bool

Implémenté dans OutputStyle, Output, et NullOutput.

◆ isVerbose()

isVerbose ( )

Returns whether verbosity is verbose (-v).

Renvoie
bool

Implémenté dans OutputStyle, Output, et NullOutput.

◆ isVeryVerbose()

isVeryVerbose ( )

Returns whether verbosity is very verbose (-vv).

Renvoie
bool

Implémenté dans OutputStyle, Output, et NullOutput.

◆ setDecorated()

setDecorated ( bool $decorated )

Sets the decorated flag.

Implémenté dans OutputStyle, ConsoleOutput, Output, et NullOutput.

◆ setFormatter()

setFormatter ( OutputFormatterInterface $formatter )

Implémenté dans OutputStyle, ConsoleOutput, Output, et NullOutput.

◆ setVerbosity()

setVerbosity ( int $level )

Sets the verbosity of the output.

Implémenté dans ConsoleOutput, Output, NullOutput, et OutputStyle.

◆ write()

write | ( |  | $messages,
 |  | bool | $newline = false,
 |  | int | $options = 0
 | ) |  |

Writes a message to the output.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
bool | $newline | Whether to add a newline
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL

Implémenté dans SymfonyStyle, Output, NullOutput, et OutputStyle.

◆ writeln()

writeln | ( |  | $messages,
 |  | int | $options = 0
 | ) |  |

Writes a message to the output and adds a newline at the end.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL

Implémenté dans SymfonyStyle, Output, NullOutput, et OutputStyle.

Référencé par Application\renderThrowable().

Documentation des champs

◆ OUTPUT_NORMAL

const OUTPUT_NORMAL = 1

Référencé par Descriptor\write(), et Output\write().

◆ OUTPUT_PLAIN

const OUTPUT_PLAIN = 4

Référencé par Output\write().

◆ OUTPUT_RAW

const OUTPUT_RAW = 2

Référencé par Descriptor\write(), et Output\write().

◆ VERBOSITY_DEBUG

const VERBOSITY_DEBUG = 256

Référencé par Application\configureIO(), ProgressIndicator\determineBestFormat(), ProgressBar\determineBestFormat(), et RemoveOldFilesCommand\doExecute().

◆ VERBOSITY_NORMAL

const VERBOSITY_NORMAL = 32

Référencé par Symfony\Component\Console\Tester\initOutput().

◆ VERBOSITY_QUIET

const VERBOSITY_QUIET = 16

Référencé par Application\configureIO(), ProgressIndicator\display(), ProgressBar\display(), Application\doRenderThrowable(), et Application\renderThrowable().

◆ VERBOSITY_VERBOSE

const VERBOSITY_VERBOSE = 64

Référencé par Application\configureIO(), ProgressIndicator\determineBestFormat(), ProgressBar\determineBestFormat(), et RemoveOldFilesCommand\doExecute().

◆ VERBOSITY_VERY_VERBOSE

const VERBOSITY_VERY_VERBOSE = 128

Référencé par Application\configureIO(), ProgressIndicator\determineBestFormat(), ProgressBar\determineBestFormat(), RemoveOldFilesCommand\doExecute(), et Command\run().

La documentation de cette interface a été générée à partir du fichier suivant :
  • OutputInterface.php


Joomla CMS: Référence de la classe StreamOutput

  • Symfony
  • Component
  • Console
  • Output
  • StreamOutput
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe StreamOutput
+ Graphe d'héritage de StreamOutput:
Output OutputInterface ConsoleOutput ConsoleSectionOutput

Fonctions membres publiques

__construct ($stream, int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=null, OutputFormatterInterface $formatter=null)
getStream ()
- Fonctions membres publiques hérités de Output
__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

doWrite (string $message, bool $newline)
hasColorSupport ()
- Fonctions membres protégées hérités de Output
doWrite (string $message, bool $newline)

Attributs privés

$stream

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

StreamOutput writes the output to a given stream.

Usage:

$output = new StreamOutput(fopen('php://stdout', 'w'));

As StreamOutput can use any stream, you can also use a file:

$output = new StreamOutput(fopen('/path/to/output.log', 'a', false));
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $stream,
 |  | int | $verbosity = self::VERBOSITY_NORMAL,
 |  | bool | $decorated = null,
 |  | OutputFormatterInterface | $formatter = null
 | ) |  |
Paramètres
resource | $stream | A stream resource
int | $verbosity | The verbosity level (one of the VERBOSITY constants in OutputInterface)
bool | null | $decorated | Whether to decorate messages (null for auto-guessing)
OutputFormatterInterface | null | $formatter | Output formatter instance (null to use default OutputFormatter)
Exceptions
InvalidArgumentException When first argument is not a real stream

Références Output\$formatter, StreamOutput\$stream, Output\$verbosity, Symfony\Contracts\Service\__construct(), StreamOutput\hasColorSupport(), et null.

Documentation des fonctions membres

◆ doWrite()

doWrite | ( | string | $message,
 |  | bool | $newline
 | ) |  |
protected

{}

Références $message.

◆ getStream()

getStream ( )

Gets the stream attached to this StreamOutput instance.

Renvoie
resource

Références StreamOutput\$stream.

Référencé par ConsoleOutput\section().

◆ hasColorSupport()

hasColorSupport ( )
protected

Returns true if the stream supports colorization.

Colorization is disabled if not supported by the stream:

This is tricky on Windows, because Cygwin, Msys2 etc emulate pseudo terminals via named pipes, so we can only check the environment.

Reference: Composer::supportsColor https://github.com/composer/xdebug-handler

Renvoie
bool true if the stream supports colorization, false otherwise

Référencé par StreamOutput\__construct().

Documentation des champs

◆ $stream

$stream
private

Référencé par ConsoleSectionOutput\__construct(), StreamOutput\__construct(), et StreamOutput\getStream().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StreamOutput.php


Joomla CMS: Référence de la classe TrimmedBufferOutput

  • Symfony
  • Component
  • Console
  • Output
  • TrimmedBufferOutput
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe TrimmedBufferOutput
+ Graphe d'héritage de TrimmedBufferOutput:
Output OutputInterface

Fonctions membres publiques

__construct (int $maxLength, ?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
fetch ()
- Fonctions membres publiques hérités de Output
__construct (?int $verbosity=self::VERBOSITY_NORMAL, bool $decorated=false, OutputFormatterInterface $formatter=null)
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
setDecorated (bool $decorated)
isDecorated ()
setVerbosity (int $level)
getVerbosity ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
writeln ($messages, int $options=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $options=self::OUTPUT_NORMAL)

Fonctions membres protégées

doWrite (string $message, bool $newline)
- Fonctions membres protégées hérités de Output
doWrite (string $message, bool $newline)

Attributs privés

$maxLength
$buffer = ''

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

A BufferedOutput that keeps only the last N chars.

Auteur
Jérémy Derussé jerem.nosp@m.y@de.nosp@m.russe.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $maxLength,
 |  | ?int | $verbosity = self::VERBOSITY_NORMAL,
 |  | bool | $decorated = false,
 |  | OutputFormatterInterface | $formatter = null
 | ) |  |

Références Output\$formatter, TrimmedBufferOutput\$maxLength, Output\$verbosity, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ doWrite()

doWrite | ( | string | $message,
 |  | bool | $newline
 | ) |  |
protected

{}

Références $message.

◆ fetch()

fetch ( )

Empties buffer and returns its content.

Renvoie
string

Références TrimmedBufferOutput\$buffer, et $content.

Documentation des champs

◆ $buffer

$buffer = ''
private

Référencé par TrimmedBufferOutput\fetch().

◆ $maxLength

$maxLength
private

Référencé par TrimmedBufferOutput\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TrimmedBufferOutput.php


Joomla CMS: Référence de la classe ChoiceQuestion

  • Symfony
  • Component
  • Console
  • Question
  • ChoiceQuestion
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ChoiceQuestion
+ Graphe d'héritage de ChoiceQuestion:
Question

Fonctions membres publiques

__construct (string $question, array $choices, $default=null)
getChoices ()
setMultiselect (bool $multiselect)
isMultiselect ()
getPrompt ()
setPrompt (string $prompt)
setErrorMessage (string $errorMessage)
- Fonctions membres publiques hérités de Question
__construct (string $question, $default=null)
getQuestion ()
getDefault ()
isMultiline ()
setMultiline (bool $multiline)
isHidden ()
setHidden (bool $hidden)
isHiddenFallback ()
setHiddenFallback (bool $fallback)
getAutocompleterValues ()
setAutocompleterValues (?iterable $values)
getAutocompleterCallback ()
setAutocompleterCallback (callable $callback=null)
setValidator (callable $validator=null)
getValidator ()
setMaxAttempts (?int $attempts)
getMaxAttempts ()
setNormalizer (callable $normalizer)
getNormalizer ()
isTrimmable ()
setTrimmable (bool $trimmable)

Fonctions membres privées

getDefaultValidator ()

Attributs privés

$choices
$multiselect = false
$prompt = ' > '
$errorMessage = 'Value "%s" is invalid'

Membres hérités additionnels

- Fonctions membres protégées hérités de Question
isAssoc (array $array)

Description détaillée

Represents a choice question.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $question,
 |  | array | $choices,
 |  |  | $default = null
 | ) |  |
Paramètres
string | $question | The question to ask to the user
array | $choices | The list of available choices
mixed | $default | The default answer to return

Références ChoiceQuestion\$choices, Question\$default, Question\$question, Symfony\Contracts\Service\__construct(), ChoiceQuestion\getDefaultValidator(), Question\setAutocompleterValues(), et Question\setValidator().

Documentation des fonctions membres

◆ getChoices()

getChoices ( )

Returns available choices.

Renvoie
array

Références ChoiceQuestion\$choices.

Référencé par QuestionHelper\formatChoiceQuestionChoices().

◆ getDefaultValidator()

getDefaultValidator ( )
private

Références ChoiceQuestion\$choices, ChoiceQuestion\$errorMessage, $key, ChoiceQuestion\$multiselect, $result, $results, $selected, $value, elseif, Question\isAssoc(), et Question\isTrimmable().

Référencé par ChoiceQuestion\__construct(), ChoiceQuestion\setErrorMessage(), et ChoiceQuestion\setMultiselect().

◆ getPrompt()

getPrompt ( )

Gets the prompt for choices.

Renvoie
string

Références ChoiceQuestion\$prompt.

◆ isMultiselect()

isMultiselect ( )

Returns whether the choices are multiselect.

Renvoie
bool

Références ChoiceQuestion\$multiselect.

◆ setErrorMessage()

setErrorMessage ( string $errorMessage )

Sets the error message for invalid values.

The error message has a string placeholder (s) for the invalid value.

Renvoie
$this

Références ChoiceQuestion\$errorMessage, $this, ChoiceQuestion\getDefaultValidator(), et Question\setValidator().

◆ setMultiselect()

setMultiselect ( bool $multiselect )

Sets multiselect option.

When multiselect is set to true, multiple choices can be answered.

Renvoie
$this

Références ChoiceQuestion\$multiselect, $this, ChoiceQuestion\getDefaultValidator(), et Question\setValidator().

◆ setPrompt()

setPrompt ( string $prompt )

Sets the prompt for choices.

Renvoie
$this

Références ChoiceQuestion\$prompt, et $this.

Documentation des champs

◆ $choices

$choices
private

Référencé par ChoiceQuestion\__construct(), ChoiceQuestion\getChoices(), et ChoiceQuestion\getDefaultValidator().

◆ $errorMessage

$errorMessage = 'Value "%s" is invalid'
private

Référencé par ChoiceQuestion\getDefaultValidator(), et ChoiceQuestion\setErrorMessage().

◆ $multiselect

$multiselect = false
private

Référencé par ChoiceQuestion\getDefaultValidator(), ChoiceQuestion\isMultiselect(), et ChoiceQuestion\setMultiselect().

◆ $prompt

$prompt = ' > '
private

Référencé par ChoiceQuestion\getPrompt(), et ChoiceQuestion\setPrompt().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ChoiceQuestion.php


Joomla CMS: Référence de la classe ConfirmationQuestion

  • Symfony
  • Component
  • Console
  • Question
  • ConfirmationQuestion
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ConfirmationQuestion
+ Graphe d'héritage de ConfirmationQuestion:
Question

Fonctions membres publiques

__construct (string $question, bool $default=true, string $trueAnswerRegex='/^y/i')
- Fonctions membres publiques hérités de Question
__construct (string $question, $default=null)
getQuestion ()
getDefault ()
isMultiline ()
setMultiline (bool $multiline)
isHidden ()
setHidden (bool $hidden)
isHiddenFallback ()
setHiddenFallback (bool $fallback)
getAutocompleterValues ()
setAutocompleterValues (?iterable $values)
getAutocompleterCallback ()
setAutocompleterCallback (callable $callback=null)
setValidator (callable $validator=null)
getValidator ()
setMaxAttempts (?int $attempts)
getMaxAttempts ()
setNormalizer (callable $normalizer)
getNormalizer ()
isTrimmable ()
setTrimmable (bool $trimmable)

Fonctions membres privées

getDefaultNormalizer ()

Attributs privés

$trueAnswerRegex

Membres hérités additionnels

- Fonctions membres protégées hérités de Question
isAssoc (array $array)

Description détaillée

Represents a yes/no question.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $question,
 |  | bool | $default = true,
 |  | string | $trueAnswerRegex = '/^y/i'
 | ) |  |
Paramètres
string | $question | The question to ask to the user
bool | $default | The default answer to return, true or false
string | $trueAnswerRegex | A regex to match the "yes" answer

Références Question\$default, Question\$question, ConfirmationQuestion\$trueAnswerRegex, Symfony\Contracts\Service\__construct(), ConfirmationQuestion\getDefaultNormalizer(), et Question\setNormalizer().

Documentation des fonctions membres

◆ getDefaultNormalizer()

getDefaultNormalizer ( )
private

Returns the default answer normalizer.

Références Question\$default, ConfirmationQuestion\$trueAnswerRegex, et Question\getDefault().

Référencé par ConfirmationQuestion\__construct().

Documentation des champs

◆ $trueAnswerRegex

$trueAnswerRegex
private

Référencé par ConfirmationQuestion\__construct(), et ConfirmationQuestion\getDefaultNormalizer().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConfirmationQuestion.php


Joomla CMS: Référence de la classe Question

  • Symfony
  • Component
  • Console
  • Question
  • Question
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe Question
+ Graphe d'héritage de Question:
ChoiceQuestion ConfirmationQuestion

Fonctions membres publiques

__construct (string $question, $default=null)
getQuestion ()
getDefault ()
isMultiline ()
setMultiline (bool $multiline)
isHidden ()
setHidden (bool $hidden)
isHiddenFallback ()
setHiddenFallback (bool $fallback)
getAutocompleterValues ()
setAutocompleterValues (?iterable $values)
getAutocompleterCallback ()
setAutocompleterCallback (callable $callback=null)
setValidator (callable $validator=null)
getValidator ()
setMaxAttempts (?int $attempts)
getMaxAttempts ()
setNormalizer (callable $normalizer)
getNormalizer ()
isTrimmable ()
setTrimmable (bool $trimmable)

Fonctions membres protégées

isAssoc (array $array)

Attributs privés

$question
$attempts
$hidden = false
$hiddenFallback = true
$autocompleterCallback
$validator
$default
$normalizer
$trimmable = true
$multiline = false

Description détaillée

Represents a Question.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $question,
 |  |  | $default = null
 | ) |  |
Paramètres
string | $question | The question to ask to the user
string | bool | int | float | null | $default | The default answer to return if the user enters nothing

Références Question\$default, et Question\$question.

Documentation des fonctions membres

◆ getAutocompleterCallback()

getAutocompleterCallback ( )

Gets the callback function used for the autocompleter.

Références Question\$autocompleterCallback.

Référencé par QuestionHelper\doAsk(), et Question\getAutocompleterValues().

◆ getAutocompleterValues()

getAutocompleterValues ( )

Gets values for the autocompleter.

Renvoie
iterable|null

Références Question\getAutocompleterCallback(), et null.

◆ getDefault()

getDefault ( )

Returns the default answer.

Renvoie
string|bool|int|float|null

Références Question\$default.

Référencé par QuestionHelper\autocomplete(), QuestionHelper\doAsk(), QuestionHelper\getDefaultAnswer(), ConfirmationQuestion\getDefaultNormalizer(), et SymfonyQuestionHelper\writePrompt().

◆ getMaxAttempts()

getMaxAttempts ( )

Gets the maximum number of attempts.

Null means an unlimited number of attempts.

Renvoie
int|null

Références Question\$attempts.

Référencé par QuestionHelper\validateAttempts().

◆ getNormalizer()

getNormalizer ( )

Gets the normalizer for the response.

The normalizer can ba a callable (a string), a closure or a class implementing __invoke.

Renvoie
callable|null

Références Question\$normalizer.

Référencé par QuestionHelper\doAsk().

◆ getQuestion()

getQuestion ( )

Returns the question.

Renvoie
string

Références Question\$question.

Référencé par SymfonyQuestionHelper\writePrompt(), et QuestionHelper\writePrompt().

◆ getValidator()

getValidator ( )

Gets the validator for the question.

Renvoie
callable|null

Références Question\$validator.

Référencé par QuestionHelper\ask(), QuestionHelper\getDefaultAnswer(), et QuestionHelper\validateAttempts().

◆ isAssoc()

isAssoc ( array $array )
protected

Référencé par ChoiceQuestion\getDefaultValidator(), et Question\setAutocompleterValues().

◆ isHidden()

isHidden ( )

Returns whether the user response must be hidden.

Renvoie
bool

Références Question\$hidden.

Référencé par QuestionHelper\doAsk().

◆ isHiddenFallback()

isHiddenFallback ( )

In case the response cannot be hidden, whether to fallback on non-hidden question or not.

Renvoie
bool

Références Question\$hiddenFallback.

Référencé par QuestionHelper\doAsk().

◆ isMultiline()

isMultiline ( )

Returns whether the user response accepts newline characters.

Références Question\$multiline.

Référencé par QuestionHelper\readInput(), et SymfonyQuestionHelper\writePrompt().

◆ isTrimmable()

isTrimmable ( )

Références Question\$trimmable.

Référencé par QuestionHelper\doAsk(), QuestionHelper\getDefaultAnswer(), et ChoiceQuestion\getDefaultValidator().

◆ setAutocompleterCallback()

setAutocompleterCallback ( callable $callback = null )

Sets the callback function used for the autocompleter.

The callback is passed the user input as argument and should return an iterable of corresponding suggestions.

Renvoie
$this

Références $this, et null.

Référencé par Question\setAutocompleterValues().

◆ setAutocompleterValues()

setAutocompleterValues ( ?iterable $values )

Sets values for the autocompleter.

Renvoie
$this
Exceptions
LogicException

Références elseif, Question\isAssoc(), null, et Question\setAutocompleterCallback().

Référencé par ChoiceQuestion\__construct().

◆ setHidden()

setHidden ( bool $hidden )

Sets whether the user response must be hidden or not.

Renvoie
$this
Exceptions
LogicException In case the autocompleter is also used

Références Question\$hidden, et $this.

◆ setHiddenFallback()

setHiddenFallback ( bool $fallback )

Sets whether to fallback on non-hidden question if the response cannot be hidden.

Renvoie
$this

Références $this.

◆ setMaxAttempts()

setMaxAttempts ( ?int $attempts )

Sets the maximum number of attempts.

Null means an unlimited number of attempts.

Renvoie
$this
Exceptions
InvalidArgumentException in case the number of attempts is invalid

Références Question\$attempts, $this, et null.

◆ setMultiline()

setMultiline ( bool $multiline )

Sets whether the user response should accept newline characters.

Renvoie
$this

Références Question\$multiline, et $this.

◆ setNormalizer()

setNormalizer ( callable $normalizer )

Sets a normalizer for the response.

The normalizer can be a callable (a string), a closure or a class implementing __invoke.

Renvoie
$this

Références Question\$normalizer, et $this.

Référencé par ConfirmationQuestion\__construct().

◆ setTrimmable()

setTrimmable ( bool $trimmable )
Renvoie
$this

Références $this, et Question\$trimmable.

◆ setValidator()

setValidator ( callable $validator = null )

Sets a validator for the question.

Renvoie
$this

Références $this, et Question\$validator.

Référencé par ChoiceQuestion\__construct(), ChoiceQuestion\setErrorMessage(), et ChoiceQuestion\setMultiselect().

Documentation des champs

◆ $attempts

$attempts
private

Référencé par Question\getMaxAttempts(), et Question\setMaxAttempts().

◆ $autocompleterCallback

$autocompleterCallback
private

Référencé par Question\getAutocompleterCallback().

◆ $default

$default
private

Référencé par ConfirmationQuestion\__construct(), ChoiceQuestion\__construct(), Question\__construct(), Question\getDefault(), et ConfirmationQuestion\getDefaultNormalizer().

◆ $hidden

$hidden = false
private

Référencé par Question\isHidden(), et Question\setHidden().

◆ $hiddenFallback

$hiddenFallback = true
private

Référencé par Question\isHiddenFallback().

◆ $multiline

$multiline = false
private

Référencé par Question\isMultiline(), et Question\setMultiline().

◆ $normalizer

$normalizer
private

Référencé par Question\getNormalizer(), et Question\setNormalizer().

◆ $question

$question
private

Référencé par ConfirmationQuestion\__construct(), ChoiceQuestion\__construct(), Question\__construct(), et Question\getQuestion().

◆ $trimmable

$trimmable = true
private

Référencé par Question\isTrimmable(), et Question\setTrimmable().

◆ $validator

$validator
private

Référencé par Question\getValidator(), et Question\setValidator().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Question.php


Joomla CMS: Référence de la classe SignalRegistry

  • Symfony
  • Component
  • Console
  • SignalRegistry
  • SignalRegistry
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe SignalRegistry

Fonctions membres publiques

__construct ()
register (int $signal, callable $signalHandler)
handle (int $signal)

Fonctions membres publiques statiques

static isSupported ()

Attributs privés

$signalHandlers = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ handle()

handle ( int $signal )

Références $count, et $i.

◆ isSupported()

static isSupported ( )
static

Référencé par Application\__construct().

◆ register()

register | ( | int | $signal,
 |  | callable | $signalHandler
 | ) |  |

Références $this.

Documentation des champs

◆ $signalHandlers

$signalHandlers = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • SignalRegistry.php


Joomla CMS: Référence de la classe OutputStyle

  • Symfony
  • Component
  • Console
  • Style
  • OutputStyle
Fonctions membres publiques | Fonctions membres protégées | Attributs privés
Référence de la classe OutputStyle
+ Graphe d'héritage de OutputStyle:
OutputInterface StyleInterface SymfonyStyle

Fonctions membres publiques

__construct (OutputInterface $output)
newLine (int $count=1)
createProgressBar (int $max=0)
write ($messages, bool $newline=false, int $type=self::OUTPUT_NORMAL)
writeln ($messages, int $type=self::OUTPUT_NORMAL)
setVerbosity (int $level)
getVerbosity ()
setDecorated (bool $decorated)
isDecorated ()
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()
- Fonctions membres publiques hérités de StyleInterface
title (string $message)
section (string $message)
listing (array $elements)
text ($message)
success ($message)
error ($message)
warning ($message)
note ($message)
caution ($message)
table (array $headers, array $rows)
ask (string $question, string $default=null, callable $validator=null)
askHidden (string $question, callable $validator=null)
confirm (string $question, bool $default=true)
choice (string $question, array $choices, $default=null)
progressStart (int $max=0)
progressAdvance (int $step=1)
progressFinish ()

Fonctions membres protégées

getErrorOutput ()

Attributs privés

$output

Membres hérités additionnels

- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Description détaillée

Decorates output to add console style guide helpers.

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( OutputInterface $output )

Références OutputStyle\$output.

Documentation des fonctions membres

◆ createProgressBar()

createProgressBar ( int $max = 0 )
Renvoie
ProgressBar

◆ getErrorOutput()

getErrorOutput ( )
protected

Références OutputStyle\$output.

Référencé par SymfonyStyle\getErrorStyle().

◆ getFormatter()

getFormatter ( )

{Returns current output formatter instance.

Renvoie
OutputFormatterInterface
}

Implémente OutputInterface.

Référencé par SymfonyStyle\createBlock(), SymfonyStyle\section(), et SymfonyStyle\title().

◆ getVerbosity()

getVerbosity ( )

{Gets the current verbosity of the output.

Renvoie
int
}

Implémente OutputInterface.

◆ isDebug()

isDebug ( )

{Returns whether verbosity is debug (-vvv).

Renvoie
bool
}

Implémente OutputInterface.

◆ isDecorated()

isDecorated ( )

{Gets the decorated flag.

Renvoie
bool
}

Implémente OutputInterface.

Référencé par SymfonyStyle\createBlock().

◆ isQuiet()

isQuiet ( )

{Returns whether verbosity is quiet (-q).

Renvoie
bool
}

Implémente OutputInterface.

◆ isVerbose()

isVerbose ( )

{Returns whether verbosity is verbose (-v).

Renvoie
bool
}

Implémente OutputInterface.

◆ isVeryVerbose()

isVeryVerbose ( )

{Returns whether verbosity is very verbose (-vv).

Renvoie
bool
}

Implémente OutputInterface.

◆ newLine()

newLine ( int $count = 1 )

{Add newline(s).}

Implémente StyleInterface.

Références $count.

◆ setDecorated()

setDecorated ( bool $decorated )

{Sets the decorated flag.}

Implémente OutputInterface.

◆ setFormatter()

setFormatter ( OutputFormatterInterface $formatter )

{}

Implémente OutputInterface.

◆ setVerbosity()

setVerbosity ( int $level )

{Sets the verbosity of the output.}

Implémente OutputInterface.

◆ write()

write | ( |  | $messages,
 |  | bool | $newline = false,
 |  | int | $type = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
bool | $newline | Whether to add a newline
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $messages, et $type.

◆ writeln()

writeln | ( |  | $messages,
 |  | int | $type = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output and adds a newline at the end.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $messages, et $type.

Documentation des champs

◆ $output

$output
private

Référencé par OutputStyle\__construct(), et OutputStyle\getErrorOutput().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OutputStyle.php


Joomla CMS: Référence de l'interface StyleInterface

  • Symfony
  • Component
  • Console
  • Style
  • StyleInterface
Fonctions membres publiques
Référence de l'interface StyleInterface
+ Graphe d'héritage de StyleInterface:
OutputStyle SymfonyStyle

Fonctions membres publiques

title (string $message)
section (string $message)
listing (array $elements)
text ($message)
success ($message)
error ($message)
warning ($message)
note ($message)
caution ($message)
table (array $headers, array $rows)
ask (string $question, string $default=null, callable $validator=null)
askHidden (string $question, callable $validator=null)
confirm (string $question, bool $default=true)
choice (string $question, array $choices, $default=null)
newLine (int $count=1)
progressStart (int $max=0)
progressAdvance (int $step=1)
progressFinish ()

Description détaillée

Output style helpers.

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des fonctions membres

◆ ask()

ask | ( | string | $question,
 |  | string | $default = null,
 |  | callable | $validator = null
 | ) |  |

Asks a question.

Renvoie
mixed

Implémenté dans SymfonyStyle.

◆ askHidden()

askHidden | ( | string | $question,
 |  | callable | $validator = null
 | ) |  |

Asks a question with the user input hidden.

Renvoie
mixed

Implémenté dans SymfonyStyle.

◆ caution()

caution ( $message )

Formats a caution admonition.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

◆ choice()

choice | ( | string | $question,
 |  | array | $choices,
 |  |  | $default = null
 | ) |  |

Asks a choice question.

Paramètres
string | int | null $default
Renvoie
mixed

Implémenté dans SymfonyStyle.

◆ confirm()

confirm | ( | string | $question,
 |  | bool | $default = true
 | ) |  |

Asks for confirmation.

Renvoie
bool

Implémenté dans SymfonyStyle.

◆ error()

error ( $message )

Formats an error result bar.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

◆ listing()

listing ( array $elements )

Formats a list.

Implémenté dans SymfonyStyle.

◆ newLine()

newLine ( int $count = 1 )

Add newline(s).

Implémenté dans SymfonyStyle, et OutputStyle.

◆ note()

note ( $message )

Formats a note admonition.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

◆ progressAdvance()

progressAdvance ( int $step = 1 )

Advances the progress output X steps.

Implémenté dans SymfonyStyle.

◆ progressFinish()

progressFinish ( )

Finishes the progress output.

Implémenté dans SymfonyStyle.

◆ progressStart()

progressStart ( int $max = 0 )

Starts the progress output.

Implémenté dans SymfonyStyle.

◆ section()

section ( string $message )

Formats a section title.

Implémenté dans SymfonyStyle.

◆ success()

success ( $message )

Formats a success result bar.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

◆ table()

table | ( | array | $headers,
 |  | array | $rows
 | ) |  |

Formats a table.

Implémenté dans SymfonyStyle.

◆ text()

text ( $message )

Formats informational text.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

◆ title()

title ( string $message )

Formats a command title.

Implémenté dans SymfonyStyle.

◆ warning()

warning ( $message )

Formats an warning result bar.

Paramètres
string | array $message

Implémenté dans SymfonyStyle.

La documentation de cette interface a été générée à partir du fichier suivant :
  • StyleInterface.php


Joomla CMS: Référence de la classe SymfonyStyle

  • Symfony
  • Component
  • Console
  • Style
  • SymfonyStyle
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe SymfonyStyle
+ Graphe d'héritage de SymfonyStyle:
OutputStyle OutputInterface StyleInterface

Fonctions membres publiques

__construct (InputInterface $input, OutputInterface $output)
block ($messages, string $type=null, string $style=null, string $prefix=' ', bool $padding=false, bool $escape=true)
title (string $message)
section (string $message)
listing (array $elements)
text ($message)
comment ($message)
success ($message)
error ($message)
warning ($message)
note ($message)
info ($message)
caution ($message)
table (array $headers, array $rows)
horizontalTable (array $headers, array $rows)
definitionList (... $list)
ask (string $question, string $default=null, callable $validator=null)
askHidden (string $question, callable $validator=null)
confirm (string $question, bool $default=true)
choice (string $question, array $choices, $default=null)
progressStart (int $max=0)
progressAdvance (int $step=1)
progressFinish ()
createProgressBar (int $max=0)
progressIterate (iterable $iterable, int $max=null)
askQuestion (Question $question)
writeln ($messages, int $type=self::OUTPUT_NORMAL)
write ($messages, bool $newline=false, int $type=self::OUTPUT_NORMAL)
newLine (int $count=1)
getErrorStyle ()
createTable ()
- Fonctions membres publiques hérités de OutputStyle
__construct (OutputInterface $output)
newLine (int $count=1)
createProgressBar (int $max=0)
write ($messages, bool $newline=false, int $type=self::OUTPUT_NORMAL)
writeln ($messages, int $type=self::OUTPUT_NORMAL)
setVerbosity (int $level)
getVerbosity ()
setDecorated (bool $decorated)
isDecorated ()
setFormatter (OutputFormatterInterface $formatter)
getFormatter ()
isQuiet ()
isVerbose ()
isVeryVerbose ()
isDebug ()

Champs de données

const | MAX_LINE_LENGTH = 120
- Champs de données hérités de OutputInterface
const | VERBOSITY_QUIET = 16
const | VERBOSITY_NORMAL = 32
const | VERBOSITY_VERBOSE = 64
const | VERBOSITY_VERY_VERBOSE = 128
const | VERBOSITY_DEBUG = 256
const | OUTPUT_NORMAL = 1
const | OUTPUT_RAW = 2
const | OUTPUT_PLAIN = 4

Fonctions membres privées

getProgressBar ()
autoPrependBlock ()
autoPrependText ()
writeBuffer (string $message, bool $newLine, int $type)
createBlock (iterable $messages, string $type=null, string $style=null, string $prefix=' ', bool $padding=false, bool $escape=false)

Attributs privés

$input
$output
$questionHelper
$progressBar
$lineLength
$bufferedOutput

Membres hérités additionnels

- Fonctions membres protégées hérités de OutputStyle
getErrorOutput ()

Description détaillée

Output decorator helpers for the Symfony Style Guide.

Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Références SymfonyStyle\$input, SymfonyStyle\$output, $width, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ ask()

ask | ( | string | $question,
 |  | string | $default = null,
 |  | callable | $validator = null
 | ) |  |

{Asks a question.

Renvoie
mixed
}

Implémente StyleInterface.

Références $default, et SymfonyStyle\askQuestion().

◆ askHidden()

askHidden | ( | string | $question,
 |  | callable | $validator = null
 | ) |  |

{Asks a question with the user input hidden.

Renvoie
mixed
}

Implémente StyleInterface.

Références SymfonyStyle\askQuestion().

◆ askQuestion()

askQuestion ( Question $question )
Renvoie
mixed

Références $this, SymfonyStyle\autoPrependBlock(), et SymfonyStyle\newLine().

Référencé par SymfonyStyle\ask(), SymfonyStyle\askHidden(), SymfonyStyle\choice(), et SymfonyStyle\confirm().

◆ autoPrependBlock()

autoPrependBlock ( )
private

Références SymfonyStyle\newLine().

Référencé par SymfonyStyle\askQuestion(), SymfonyStyle\block(), SymfonyStyle\section(), et SymfonyStyle\title().

◆ autoPrependText()

autoPrependText ( )
private

Références SymfonyStyle\newLine().

Référencé par SymfonyStyle\listing(), et SymfonyStyle\text().

◆ block()

block | ( |  | $messages,
 |  | string | $type = null,
 |  | string | $style = null,
 |  | string | $prefix = ' ',
 |  | bool | $padding = false,
 |  | bool | $escape = true
 | ) |  |

Formats a message as a block of text.

Paramètres
string | array $messages The message to write in the block

Références $messages, $prefix, $style, $type, SymfonyStyle\autoPrependBlock(), SymfonyStyle\createBlock(), SymfonyStyle\newLine(), et SymfonyStyle\writeln().

Référencé par SymfonyStyle\caution(), SymfonyStyle\comment(), SymfonyStyle\error(), SymfonyStyle\info(), SymfonyStyle\note(), SymfonyStyle\success(), et SymfonyStyle\warning().

◆ caution()

caution ( $message )

{Formats a caution admonition.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, et SymfonyStyle\block().

◆ choice()

choice | ( | string | $question,
 |  | array | $choices,
 |  |  | $default = null
 | ) |  |

{Asks a choice question.

Paramètres
string | int | null $default
Renvoie
mixed
}

Implémente StyleInterface.

Références $default, SymfonyStyle\askQuestion(), et null.

◆ comment()

comment ( $message )

Formats a command comment.

Paramètres
string | array $message

Références $message, SymfonyStyle\block(), et null.

Référencé par LintCommand\displayTxt().

◆ confirm()

confirm | ( | string | $question,
 |  | bool | $default = true
 | ) |  |

{Asks for confirmation.

Renvoie
bool
}

Implémente StyleInterface.

Références $default, et SymfonyStyle\askQuestion().

◆ createBlock()

createBlock | ( | iterable | $messages,
 |  | string | $type = null,
 |  | string | $style = null,
 |  | string | $prefix = ' ',
 |  | bool | $padding = false,
 |  | bool | $escape = false
 | ) |  |
private

Références $i, $key, $message, $messages, $prefix, $style, $type, OutputFormatter\escape(), OutputStyle\getFormatter(), OutputStyle\isDecorated(), null, Helper\removeDecoration(), et Helper\width().

Référencé par SymfonyStyle\block().

◆ createProgressBar()

createProgressBar ( int $max = 0 )

{}

Références SymfonyStyle\$progressBar.

Référencé par SymfonyStyle\progressIterate(), et SymfonyStyle\progressStart().

◆ createTable()

createTable ( )

Références SymfonyStyle\$output, $style, Table\getStyleDefinition(), et ConsoleOutputInterface\section().

Référencé par SymfonyStyle\horizontalTable(), et SymfonyStyle\table().

◆ definitionList()

definitionList ( $list )

Formats a list of key/value horizontally.

Each row can be one of:

  • 'A title'
  • ['key' => 'value']
  • new TableSeparator()
Paramètres
string|array|TableSeparator ...$list

Références $list, $value, SymfonyStyle\horizontalTable(), et null.

◆ error()

error ( $message )

{Formats an error result bar.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, et SymfonyStyle\block().

◆ getErrorStyle()

getErrorStyle ( )

Returns a new instance which makes use of stderr if available.

Renvoie
self

Références SymfonyStyle\$input, et OutputStyle\getErrorOutput().

◆ getProgressBar()

getProgressBar ( )
private

Références SymfonyStyle\$progressBar.

Référencé par SymfonyStyle\progressAdvance(), et SymfonyStyle\progressFinish().

◆ horizontalTable()

horizontalTable | ( | array | $headers,
 |  | array | $rows
 | ) |  |

Formats a horizontal table.

Références $rows, SymfonyStyle\createTable(), et SymfonyStyle\newLine().

Référencé par SymfonyStyle\definitionList().

◆ info()

info ( $message )

Formats an info message.

Paramètres
string | array $message

Références $message, et SymfonyStyle\block().

◆ listing()

listing ( array $elements )

{Formats a list.}

Implémente StyleInterface.

Références SymfonyStyle\autoPrependText(), SymfonyStyle\newLine(), et SymfonyStyle\writeln().

◆ newLine()

newLine ( int $count = 1 )

{Add newline(s).}

Implémente StyleInterface.

Références $count.

Référencé par SymfonyStyle\askQuestion(), SymfonyStyle\autoPrependBlock(), SymfonyStyle\autoPrependText(), SymfonyStyle\block(), SymfonyStyle\horizontalTable(), SymfonyStyle\listing(), SymfonyStyle\progressFinish(), SymfonyStyle\progressIterate(), SymfonyStyle\section(), SymfonyStyle\table(), et SymfonyStyle\title().

◆ note()

note ( $message )

{Formats a note admonition.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, et SymfonyStyle\block().

◆ progressAdvance()

progressAdvance ( int $step = 1 )

{Advances the progress output X steps.}

Implémente StyleInterface.

Références $step, et SymfonyStyle\getProgressBar().

◆ progressFinish()

progressFinish ( )

{Finishes the progress output.}

Implémente StyleInterface.

Références SymfonyStyle\getProgressBar(), SymfonyStyle\newLine(), et null.

◆ progressIterate()

progressIterate | ( | iterable | $iterable,
 |  | int | $max = null
 | ) |  |
Voir également
ProgressBar::iterate()

Références SymfonyStyle\createProgressBar(), et SymfonyStyle\newLine().

◆ progressStart()

progressStart ( int $max = 0 )

{Starts the progress output.}

Implémente StyleInterface.

Références SymfonyStyle\createProgressBar().

◆ section()

section ( string $message )

{Formats a section title.}

Implémente StyleInterface.

Références SymfonyStyle\autoPrependBlock(), OutputFormatter\escapeTrailingBackslash(), OutputStyle\getFormatter(), SymfonyStyle\newLine(), Helper\removeDecoration(), Helper\width(), et SymfonyStyle\writeln().

◆ success()

success ( $message )

{Formats a success result bar.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, et SymfonyStyle\block().

Référencé par LintCommand\displayTxt().

◆ table()

table | ( | array | $headers,
 |  | array | $rows
 | ) |  |

{Formats a table.}

Implémente StyleInterface.

Références $rows, SymfonyStyle\createTable(), et SymfonyStyle\newLine().

◆ text()

text ( $message )

{Formats informational text.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, $messages, SymfonyStyle\autoPrependText(), et SymfonyStyle\writeln().

Référencé par LintCommand\displayTxt().

◆ title()

title ( string $message )

{Formats a command title.}

Implémente StyleInterface.

Références SymfonyStyle\autoPrependBlock(), OutputFormatter\escapeTrailingBackslash(), OutputStyle\getFormatter(), SymfonyStyle\newLine(), Helper\removeDecoration(), Helper\width(), et SymfonyStyle\writeln().

◆ warning()

warning ( $message )

{Formats an warning result bar.

Paramètres
string | array $message
}

Implémente StyleInterface.

Références $message, et SymfonyStyle\block().

Référencé par LintCommand\displayTxt().

◆ write()

write | ( |  | $messages,
 |  | bool | $newline = false,
 |  | int | $type = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
bool | $newline | Whether to add a newline
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $message, $messages, $type, et SymfonyStyle\writeBuffer().

◆ writeBuffer()

writeBuffer | ( | string | $message,
 |  | bool | $newLine,
 |  | int | $type
 | ) |  |
private

Références $message, et $type.

Référencé par SymfonyStyle\write(), et SymfonyStyle\writeln().

◆ writeln()

writeln | ( |  | $messages,
 |  | int | $type = self::OUTPUT_NORMAL
 | ) |  |

{Writes a message to the output and adds a newline at the end.

Paramètres
string | iterable | $messages | The message as an iterable of strings or a single string
int | $options | A bitmask of options (one of the OUTPUT or VERBOSITY constants), 0 is considered the same as self::OUTPUT_NORMAL | self::VERBOSITY_NORMAL
}

Implémente OutputInterface.

Références $message, $messages, $type, et SymfonyStyle\writeBuffer().

Référencé par SymfonyStyle\block(), LintCommand\displayJson(), SymfonyStyle\listing(), SymfonyStyle\section(), SymfonyStyle\text(), et SymfonyStyle\title().

Documentation des champs

◆ $bufferedOutput

$bufferedOutput
private

◆ $input

$input
private

Référencé par SymfonyStyle\__construct(), et SymfonyStyle\getErrorStyle().

◆ $lineLength

$lineLength
private

◆ $output

$output
private

Référencé par SymfonyStyle\__construct(), et SymfonyStyle\createTable().

◆ $progressBar

$progressBar
private

Référencé par SymfonyStyle\createProgressBar(), et SymfonyStyle\getProgressBar().

◆ $questionHelper

$questionHelper
private

◆ MAX_LINE_LENGTH

const MAX_LINE_LENGTH = 120
La documentation de cette classe a été générée à partir du fichier suivant :
  • SymfonyStyle.php


Joomla CMS: Référence de la classe CommandIsSuccessful

  • Symfony
  • Component
  • Console
  • Tester
  • Constraint
  • CommandIsSuccessful
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe CommandIsSuccessful
+ Graphe d'héritage de CommandIsSuccessful:

Fonctions membres publiques

toString ()

Fonctions membres protégées

matches ($other)
failureDescription ($other)
additionalFailureDescription ($other)

Documentation des fonctions membres

◆ additionalFailureDescription()

additionalFailureDescription ( $other )
protected

{}

Références Command\FAILURE, et Command\INVALID.

◆ failureDescription()

failureDescription ( $other )
protected

{}

◆ matches()

matches ( $other )
protected

{}

Références Command\SUCCESS.

◆ toString()

toString ( )

{}

La documentation de cette classe a été générée à partir du fichier suivant :
  • CommandIsSuccessful.php


Joomla CMS: Référence de la classe ApplicationTester

  • Symfony
  • Component
  • Console
  • Tester
  • ApplicationTester
Fonctions membres publiques | Attributs privés
Référence de la classe ApplicationTester

Fonctions membres publiques

__construct (Application $application)
run (array $input, array $options=[])

Attributs privés

$application

Description détaillée

Eases the testing of console applications.

When testing an application, don't forget to disable the auto exit flag:

$application = new Application();
$application->setAutoExit(false);
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Application $application )

Références ApplicationTester\$application.

Documentation des fonctions membres

◆ run()

run | ( | array | $input,
 |  | array | $options = []
 | ) |  |

Executes the application.

Available options:

  • interactive: Sets the input interactive flag
  • decorated: Sets the output decorated flag
  • verbosity: Sets the output verbosity flag
  • capture_stderr_separately: Make output of stdOut and stdErr separately available
Renvoie
int The command exit code

Références Symfony\Component\Console\Tester\$input, $options, Symfony\Component\Console\Tester\createStream(), et Symfony\Component\Console\Tester\initOutput().

Documentation des champs

◆ $application

$application
private

Référencé par ApplicationTester\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ApplicationTester.php


Joomla CMS: Référence de la classe CommandCompletionTester

  • Symfony
  • Component
  • Console
  • Tester
  • CommandCompletionTester
Fonctions membres publiques | Attributs privés
Référence de la classe CommandCompletionTester

Fonctions membres publiques

__construct (Command $command)
complete (array $input)

Attributs privés

$command

Description détaillée

Eases the testing of command completion.

Auteur
Jérôme Tamarelle jerom.nosp@m.e@ta.nosp@m.marel.nosp@m.le.n.nosp@m.et

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Command $command )

Références CommandCompletionTester\$command.

Documentation des fonctions membres

◆ complete()

complete ( array $input )

Create completion suggestions from input tokens.

Références Symfony\Component\Console\Tester\$input, $option, $options, et CompletionInput\fromTokens().

Documentation des champs

◆ $command

$command
private

Référencé par CommandCompletionTester\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CommandCompletionTester.php


Joomla CMS: Référence de la classe CommandTester

  • Symfony
  • Component
  • Console
  • Tester
  • CommandTester
Fonctions membres publiques | Attributs privés
Référence de la classe CommandTester

Fonctions membres publiques

__construct (Command $command)
execute (array $input, array $options=[])

Attributs privés

$command

Description détaillée

Eases the testing of console commands.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Command $command )

Références CommandTester\$command.

Documentation des fonctions membres

◆ execute()

execute | ( | array | $input,
 |  | array | $options = []
 | ) |  |

Executes the command.

Available execution options:

  • interactive: Sets the input interactive flag
  • decorated: Sets the output decorated flag
  • verbosity: Sets the output verbosity flag
  • capture_stderr_separately: Make output of stdOut and stdErr separately available
Paramètres
array | $input | An array of command arguments and options
array | $options | An array of execution options
Renvoie
int The command exit code

Références Symfony\Component\Console\Tester\$input, $options, Symfony\Component\Console\Tester\createStream(), Symfony\Component\Console\Tester\initOutput(), et null.

Documentation des champs

◆ $command

$command
private

Référencé par CommandTester\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CommandTester.php


Joomla CMS: Référence de la classe Application

  • Symfony
  • Component
  • Console
  • Application
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Application
+ Graphe d'héritage de Application:
ResetInterface

Fonctions membres publiques

__construct (string $name='UNKNOWN', string $version='UNKNOWN')
setDispatcher (EventDispatcherInterface $dispatcher)
setCommandLoader (CommandLoaderInterface $commandLoader)
getSignalRegistry ()
setSignalsToDispatchEvent (int ... $signalsToDispatchEvent)
run (InputInterface $input=null, OutputInterface $output=null)
doRun (InputInterface $input, OutputInterface $output)
reset ()
setHelperSet (HelperSet $helperSet)
getHelperSet ()
setDefinition (InputDefinition $definition)
getDefinition ()
complete (CompletionInput $input, CompletionSuggestions $suggestions)
getHelp ()
areExceptionsCaught ()
setCatchExceptions (bool $boolean)
isAutoExitEnabled ()
setAutoExit (bool $boolean)
getName ()
setName (string $name)
getVersion ()
setVersion (string $version)
getLongVersion ()
register (string $name)
addCommands (array $commands)
add (Command $command)
get (string $name)
has (string $name)
getNamespaces ()
findNamespace (string $namespace)
find (string $name)
all (string $namespace=null)
renderThrowable (\Throwable $e, OutputInterface $output)
extractNamespace (string $name, int $limit=null)
setDefaultCommand (string $commandName, bool $isSingleCommand=false)
isSingleCommand ()

Fonctions membres publiques statiques

static getAbbreviations (array $names)

Fonctions membres protégées

doRenderThrowable (\Throwable $e, OutputInterface $output)
configureIO (InputInterface $input, OutputInterface $output)
doRunCommand (Command $command, InputInterface $input, OutputInterface $output)
getCommandName (InputInterface $input)
getDefaultInputDefinition ()
getDefaultCommands ()
getDefaultHelperSet ()

Fonctions membres privées

getAbbreviationSuggestions (array $abbrevs)
findAlternatives (string $name, iterable $collection)
splitStringByWidth (string $string, int $width)
extractAllNamespaces (string $name)
init ()

Attributs privés

$commands = []
$wantHelps = false
$runningCommand
$name
$version
$commandLoader
$catchExceptions = true
$autoExit = true
$definition
$helperSet
$dispatcher
$terminal
$defaultCommand
$singleCommand = false
$initialized
$signalRegistry
$signalsToDispatchEvent = []

Description détaillée

An Application is the container for a collection of commands.

It is the main entry point of a Console application.

This class is optimized for a standard CLI environment.

Usage:

$app = new Application('myapp', '1.0 (stable)');
$app->add(new SimpleCommand());
$app->run();
Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name = 'UNKNOWN',
 |  | string | $version = 'UNKNOWN'
 | ) |  |

Références Application\$name, Application\$version, SignalRegistry\isSupported(), et name.

Documentation des fonctions membres

◆ add()

add ( Command $command )

Adds a command object.

If a command with the same name already exists, it will be overridden. If the command is not enabled it will not be added.

Renvoie
Command|null

Références $this, Command\getAliases(), Command\getDefinition(), Command\getName(), Application\init(), Command\isEnabled(), null, et Command\setApplication().

Référencé par Application\addCommands(), Application\has(), Application\init(), et Application\register().

◆ addCommands()

addCommands ( array $commands )

Adds an array of command objects.

If a Command is not enabled it will not be added.

Paramètres
Command[] $commands An array of commands

Références Application\$commands, et Application\add().

◆ all()

all ( string $namespace = null )

Gets the commands (registered in the given namespace if provided).

The array keys are the full names and the values the command instances.

Renvoie
Command[]

Références Application\$commands, Application\$name, $namespace, Application\extractNamespace(), Application\has(), Application\init(), et null.

Référencé par Application\complete(), et Application\getNamespaces().

◆ areExceptionsCaught()

areExceptionsCaught ( )

Gets whether to catch exceptions or not during commands execution.

Renvoie
bool

Références Application\$catchExceptions.

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Adds suggestions to $suggestions for the current completion input (e.g. option or argument).

Références $input, Application\all(), CompletionInput\getCompletionType(), Application\getDefinition(), Command\getName(), Command\isHidden(), null, CompletionSuggestions\suggestOptions(), CompletionSuggestions\suggestValues(), CompletionInput\TYPE_ARGUMENT_VALUE, et CompletionInput\TYPE_OPTION_NAME.

◆ configureIO()

configureIO | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Configures the input and output instances based on the user arguments and options.

Références $input, $output, elseif, OutputInterface\VERBOSITY_DEBUG, OutputInterface\VERBOSITY_QUIET, OutputInterface\VERBOSITY_VERBOSE, et OutputInterface\VERBOSITY_VERY_VERBOSE.

Référencé par Application\run().

◆ doRenderThrowable()

doRenderThrowable | ( | \Throwable | $e,
 |  | OutputInterface | $output
 | ) |  |
protected

Références $class, $count, $function, $i, $message, $messages, $output, $title, $type, $width, OutputFormatter\escape(), Application\splitStringByWidth(), OutputInterface\VERBOSITY_QUIET, et Helper\width().

Référencé par Application\renderThrowable().

◆ doRun()

doRun | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |

Runs the current application.

Renvoie
int 0 if everything went fine, or an error code

Références Application\$defaultCommand, Application\$definition, $input, Application\$name, $output, $style, InputInterface\bind(), Application\doRunCommand(), ConsoleEvents\ERROR, Application\find(), Application\getCommandName(), Application\getDefinition(), Application\getLongVersion(), null, et InputArgument\OPTIONAL.

Référencé par Application\run().

◆ doRunCommand()

doRunCommand | ( | Command | $command,
 |  | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Runs the current command.

If an event dispatcher has been attached to the application, events are also dispatched during the life-cycle of the command.

Renvoie
int 0 if everything went fine, or an error code

Références $helper, $input, $output, ConsoleEvents\COMMAND, ConsoleEvents\ERROR, Command\getDefinition(), Command\getHelperSet(), Terminal\hasSttyAvailable(), Command\mergeApplicationDefinition(), null, ConsoleCommandEvent\RETURN_CODE_DISABLED, Command\run(), ConsoleEvents\SIGNAL, et ConsoleEvents\TERMINATE.

Référencé par Application\doRun().

◆ extractAllNamespaces()

extractAllNamespaces ( string $name )
private

Returns all namespaces of the command name.

Renvoie
string[]

Références Application\$name, et $parts.

Référencé par Application\getNamespaces().

◆ extractNamespace()

extractNamespace | ( | string | $name,
 |  | int | $limit = null
 | ) |  |

Returns the namespace part of the command name.

This method is not part of public API and should not be used directly.

Renvoie
string

Références $limit, Application\$name, $parts, et null.

Référencé par Application\all().

◆ find()

find ( string $name )

Finds a command by name or alias.

Contrary to get, this command tries to find the best match if you give it an abbreviation of a name or alias.

Renvoie
Command
Exceptions
CommandNotFoundException When command name is incorrect or ambiguous

Références Application\$commands, $message, Application\$name, Application\findAlternatives(), Application\findNamespace(), Application\getAbbreviationSuggestions(), Application\has(), Application\init(), Application\reset(), Helper\substr(), et Helper\width().

Référencé par Application\doRun(), et Application\setDefaultCommand().

◆ findAlternatives()

findAlternatives | ( | string | $name,
 |  | iterable | $collection
 | ) |  |
private

Finds alternative of $name among $collection, if nothing is found in $collection, try in $abbrevs.

Renvoie
string[]

Références $i, $item, Application\$name, $parts, et elseif.

Référencé par Application\find(), et Application\findNamespace().

◆ findNamespace()

findNamespace ( string $namespace )

Finds a registered namespace by a name or an abbreviation.

Renvoie
string
Exceptions
NamespaceNotFoundException When namespace is incorrect or ambiguous

Références $message, $namespace, Application\findAlternatives(), Application\getAbbreviationSuggestions(), Application\getNamespaces(), et Application\reset().

Référencé par Application\find().

◆ get()

get ( string $name )

Returns a registered command by name or alias.

Renvoie
Command
Exceptions
CommandNotFoundException When given command name does not exist

Références Application\$name, Application\has(), et Application\init().

◆ getAbbreviations()

static getAbbreviations ( array $names )
static

Returns an array of possible abbreviations given a set of names.

Renvoie
string[][]

Références Application\$name, et $names.

◆ getAbbreviationSuggestions()

getAbbreviationSuggestions ( array $abbrevs )
private

Returns abbreviated suggestions in string format.

Référencé par Application\find(), et Application\findNamespace().

◆ getCommandName()

getCommandName ( InputInterface $input )
protected

Gets the name of the command based on input.

Renvoie
string|null

Références $input.

Référencé par Application\doRun().

◆ getDefaultCommands()

getDefaultCommands ( )
protected

Gets the default commands that should always be available.

Renvoie
Command[]

Référencé par Application\init().

◆ getDefaultHelperSet()

getDefaultHelperSet ( )
protected

Gets the default helper set with the helpers that should always be available.

Renvoie
HelperSet

Référencé par Application\getHelperSet().

◆ getDefaultInputDefinition()

getDefaultInputDefinition ( )
protected

Gets the default input definition.

Renvoie
InputDefinition

Références null, InputArgument\REQUIRED, InputOption\VALUE_NEGATABLE, et InputOption\VALUE_NONE.

Référencé par Application\getDefinition().

◆ getDefinition()

getDefinition ( )

Gets the InputDefinition related to this Application.

Renvoie
InputDefinition

Références Application\$definition, et Application\getDefaultInputDefinition().

Référencé par Application\complete(), TextDescriptor\describeApplication(), et Application\doRun().

◆ getHelp()

getHelp ( )

Gets the help message.

Renvoie
string

Références Application\getLongVersion().

Référencé par TextDescriptor\describeApplication().

◆ getHelperSet()

getHelperSet ( )

Get the helper set associated with the command.

Renvoie
HelperSet

Références Application\$helperSet, et Application\getDefaultHelperSet().

◆ getLongVersion()

getLongVersion ( )

Returns the long version of the application.

Renvoie
string

Références Application\getName(), et Application\getVersion().

Référencé par Application\doRun(), et Application\getHelp().

◆ getName()

getName ( )

Gets the name of the application.

Renvoie
string

Références Application\$name.

Référencé par JsonDescriptor\describeApplication(), XmlDescriptor\getApplicationDocument(), MarkdownDescriptor\getApplicationTitle(), Application\getLongVersion(), et Application\renderThrowable().

◆ getNamespaces()

getNamespaces ( )

Returns an array of all unique namespaces used by currently registered commands.

It does not return the global namespace which always exists.

Renvoie
string[]

Références Application\all(), et Application\extractAllNamespaces().

Référencé par Application\findNamespace().

◆ getSignalRegistry()

getSignalRegistry ( )

Références Application\$signalRegistry.

◆ getVersion()

getVersion ( )

Gets the application version.

Renvoie
string

Références Application\$version.

Référencé par JsonDescriptor\describeApplication(), XmlDescriptor\getApplicationDocument(), MarkdownDescriptor\getApplicationTitle(), et Application\getLongVersion().

◆ has()

has ( string $name )

Returns true if the command exists, false otherwise.

Renvoie
bool

Références Application\$name, Application\add(), et Application\init().

Référencé par Application\all(), Application\find(), et Application\get().

◆ init()

init ( )
private

Références Application\add(), et Application\getDefaultCommands().

Référencé par Application\add(), Application\all(), Application\find(), Application\get(), et Application\has().

◆ isAutoExitEnabled()

isAutoExitEnabled ( )

Gets whether to automatically exit after a command execution or not.

Renvoie
bool

Références Application\$autoExit.

◆ isSingleCommand()

isSingleCommand ( )

Références Application\$singleCommand.

◆ register()

register ( string $name )

Registers a new command.

Renvoie
Command

Références Application\$name, et Application\add().

◆ renderThrowable()

renderThrowable | ( | \Throwable | $e,
 |  | OutputInterface | $output
 | ) |  |

Références $output, Application\doRenderThrowable(), OutputFormatter\escape(), Application\getName(), null, OutputInterface\VERBOSITY_QUIET, et OutputInterface\writeln().

Référencé par Application\run().

◆ reset()

reset ( )

{}

Implémente ResetInterface.

Référencé par Application\find(), et Application\findNamespace().

◆ run()

run | ( | InputInterface | $input = null,
 |  | OutputInterface | $output = null
 | ) |  |

Runs the current application.

Renvoie
int 0 if everything went fine, or an error code
Exceptions

Références $errorHandler, $input, $output, Application\configureIO(), Application\doRun(), elseif, null, et Application\renderThrowable().

◆ setAutoExit()

setAutoExit ( bool $boolean )

Sets whether to automatically exit after a command execution or not.

◆ setCatchExceptions()

setCatchExceptions ( bool $boolean )

Sets whether to catch exceptions or not during commands execution.

◆ setCommandLoader()

setCommandLoader ( CommandLoaderInterface $commandLoader )

Références Application\$commandLoader.

◆ setDefaultCommand()

setDefaultCommand | ( | string | $commandName,
 |  | bool | $isSingleCommand = false
 | ) |  |

Sets the default Command name.

Renvoie
$this

Références $this, et Application\find().

◆ setDefinition()

setDefinition ( InputDefinition $definition )

Références Application\$definition.

◆ setDispatcher()

setDispatcher ( EventDispatcherInterface $dispatcher )

Références Application\$dispatcher.

◆ setHelperSet()

setHelperSet ( HelperSet $helperSet )

Références Application\$helperSet.

◆ setName()

setName ( string $name )

Sets the application name.

Références Application\$name, et name.

◆ setSignalsToDispatchEvent()

setSignalsToDispatchEvent ( int ... $signalsToDispatchEvent )

Références Application\$signalsToDispatchEvent.

◆ setVersion()

setVersion ( string $version )

Sets the application version.

Références Application\$version.

◆ splitStringByWidth()

splitStringByWidth | ( | string | $string,
 |  | int | $width
 | ) |  |
private

Références Joomla\Database\Query\$offset, $width, et null.

Référencé par Application\doRenderThrowable().

Documentation des champs

◆ $autoExit

$autoExit = true
private

Référencé par Application\isAutoExitEnabled().

◆ $catchExceptions

$catchExceptions = true
private

Référencé par Application\areExceptionsCaught().

◆ $commandLoader

$commandLoader
private

Référencé par Application\setCommandLoader().

◆ $commands

$commands = []
private

Référencé par Application\addCommands(), Application\all(), et Application\find().

◆ $defaultCommand

$defaultCommand
private

Référencé par Application\doRun().

◆ $definition

$definition
private

Référencé par Application\doRun(), Application\getDefinition(), et Application\setDefinition().

◆ $dispatcher

$dispatcher
private

Référencé par Application\setDispatcher().

◆ $helperSet

$helperSet
private

Référencé par Application\getHelperSet(), et Application\setHelperSet().

◆ $initialized

$initialized
private

◆ $name

$name
private

Référencé par Application\__construct(), Application\all(), Application\doRun(), Application\extractAllNamespaces(), Application\extractNamespace(), Application\find(), Application\findAlternatives(), Application\get(), Application\getAbbreviations(), Application\getName(), Application\has(), Application\register(), et Application\setName().

◆ $runningCommand

$runningCommand
private

◆ $signalRegistry

$signalRegistry
private

Référencé par Application\getSignalRegistry().

◆ $signalsToDispatchEvent

$signalsToDispatchEvent = []
private

Référencé par Application\setSignalsToDispatchEvent().

◆ $singleCommand

$singleCommand = false
private

Référencé par Application\isSingleCommand().

◆ $terminal

$terminal
private

◆ $version

$version
private

Référencé par Application\__construct(), Application\getVersion(), et Application\setVersion().

◆ $wantHelps

$wantHelps = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/console/Application.php


Joomla CMS: Référence de la classe Color

  • Symfony
  • Component
  • Console
  • Color
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Color

Fonctions membres publiques

__construct (string $foreground='', string $background='', array $options=[])
apply (string $text)
set ()
unset ()

Fonctions membres privées

parseColor (string $color, bool $background=false)
convertHexColorToAnsi (int $color)
degradeHexColorToAnsi (int $r, int $g, int $b)
getSaturation (int $r, int $g, int $b)

Attributs privés

const | COLORS
const const | BRIGHT_COLORS
const const const | AVAILABLE_OPTIONS
const const const | $foreground
$background
$options = []

Description détaillée

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $foreground = '',
 |  | string | $background = '',
 |  | array | $options = []
 | ) |  |

Références Color\$background, Color\$foreground, $option, Color\$options, et Color\parseColor().

Documentation des fonctions membres

◆ apply()

apply ( string $text )

◆ convertHexColorToAnsi()

convertHexColorToAnsi ( int $color )
private

Références $b, $color, $g, $r, et Color\degradeHexColorToAnsi().

◆ degradeHexColorToAnsi()

degradeHexColorToAnsi | ( | int | $r,
 |  | int | $g,
 |  | int | $b
 | ) |  |
private

Références $b, $g, $r, et Color\getSaturation().

Référencé par Color\convertHexColorToAnsi().

◆ getSaturation()

getSaturation | ( | int | $r,
 |  | int | $g,
 |  | int | $b
 | ) |  |
private

Références $b, $g, et $r.

Référencé par Color\degradeHexColorToAnsi().

◆ parseColor()

parseColor | ( | string | $color,
 |  | bool | $background = false
 | ) |  |
private

Références Color\$background, et $color.

Référencé par Color\__construct().

◆ set()

set ( )

Références Color\$background, Color\$foreground, et $option.

◆ unset()

unset ( )

Références $option.

Documentation des champs

◆ $background

$background
private

Référencé par Color\__construct(), Color\parseColor(), et Color\set().

◆ $foreground

const const const $foreground
private
Valeur initiale :
=> 22],
'underscore' => ['set' => 4, 'unset' => 24],
'blink' => ['set' => 5, 'unset' => 25],
'reverse' => ['set' => 7, 'unset' => 27],
'conceal' => ['set' => 8, 'unset' => 28],
]

Référencé par Color\__construct(), et Color\set().

◆ $options

$options = []
private

Référencé par Color\__construct().

◆ AVAILABLE_OPTIONS

const const const AVAILABLE_OPTIONS
private
Valeur initiale :
= [
'bold' => ['set' => 1

◆ BRIGHT_COLORS

const const BRIGHT_COLORS
private
Valeur initiale :
= [
'gray' => 0

◆ COLORS

const COLORS
private
Valeur initiale :
= [
'black' => 0
La documentation de cette classe a été générée à partir du fichier suivant :
  • Color.php


Joomla CMS: Référence de la classe ConsoleEvents

  • Symfony
  • Component
  • Console
  • ConsoleEvents
Champs de données
Référence de la classe ConsoleEvents

Champs de données

const | COMMAND = 'console.command'
const | SIGNAL = 'console.signal'
const | TERMINATE = 'console.terminate'
const | ERROR = 'console.error'
const | ALIASES

Description détaillée

Contains all events dispatched by an Application.

Auteur
Francesco Levorato git@f.nosp@m.levo.nosp@m.ur.ne.nosp@m.t

Documentation des champs

◆ ALIASES

const ALIASES
Valeur initiale :
= [
ConsoleCommandEvent::class => self::COMMAND

Event aliases.

These aliases can be consumed by RegisterListenersPass.

◆ COMMAND

const COMMAND = 'console.command'

The COMMAND event allows you to attach listeners before any command is executed by the console. It also allows you to modify the command, input and output before they are handed to the command.

("Symfony\Component\Console\Event\ConsoleCommandEvent")

Référencé par Application\doRunCommand().

◆ ERROR

const ERROR = 'console.error'

The ERROR event occurs when an uncaught exception or error appears.

This event allows you to deal with the exception/error or to modify the thrown exception.

("Symfony\Component\Console\Event\ConsoleErrorEvent")

Référencé par Application\doRun(), Application\doRunCommand(), et ErrorListener\getSubscribedEvents().

◆ SIGNAL

const SIGNAL = 'console.signal'

The SIGNAL event allows you to perform some actions after the command execution was interrupted.

("Symfony\Component\Console\Event\ConsoleSignalEvent")

Référencé par Application\doRunCommand().

◆ TERMINATE

const TERMINATE = 'console.terminate'

The TERMINATE event allows you to attach listeners after a command is executed by the console.

("Symfony\Component\Console\Event\ConsoleTerminateEvent")

Référencé par Application\doRunCommand(), et ErrorListener\getSubscribedEvents().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/console/ConsoleEvents.php


Joomla CMS: Référence de la classe Cursor

  • Symfony
  • Component
  • Console
  • Cursor
Fonctions membres publiques | Attributs privés
Référence de la classe Cursor

Fonctions membres publiques

__construct (OutputInterface $output, $input=null)
moveUp (int $lines=1)
moveDown (int $lines=1)
moveRight (int $columns=1)
moveLeft (int $columns=1)
moveToColumn (int $column)
moveToPosition (int $column, int $row)
savePosition ()
restorePosition ()
hide ()
show ()
clearLine ()
clearLineAfter ()
clearOutput ()
clearScreen ()
getCurrentPosition ()

Attributs privés

$output
$input

Description détaillée

Auteur
Pierre du Plessis pdple.nosp@m.s@gm.nosp@m.ail.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | OutputInterface | $output,
 |  |  | $input = null
 | ) |  |
Paramètres
resource | null $input

Références Cursor\$input, et Cursor\$output.

Documentation des fonctions membres

◆ clearLine()

clearLine ( )

Clears all the output from the current line.

Renvoie
$this

Références $this.

◆ clearLineAfter()

clearLineAfter ( )

Clears all the output from the current line after the current position.

Références $this.

◆ clearOutput()

clearOutput ( )

Clears all the output from the cursors' current position to the end of the screen.

Renvoie
$this

Références $this.

◆ clearScreen()

clearScreen ( )

Clears the entire screen.

Renvoie
$this

Références $this.

◆ getCurrentPosition()

getCurrentPosition ( )

Returns the current cursor position as x,y coordinates.

Références null.

◆ hide()

hide ( )
Renvoie
$this

Références $this.

◆ moveDown()

moveDown ( int $lines = 1 )
Renvoie
$this

Références $this.

◆ moveLeft()

moveLeft ( int $columns = 1 )
Renvoie
$this

Références $columns, et $this.

◆ moveRight()

moveRight ( int $columns = 1 )
Renvoie
$this

Références $columns, et $this.

◆ moveToColumn()

moveToColumn ( int $column )
Renvoie
$this

Références $this.

◆ moveToPosition()

moveToPosition | ( | int | $column,
 |  | int | $row
 | ) |  |
Renvoie
$this

Références $this.

◆ moveUp()

moveUp ( int $lines = 1 )
Renvoie
$this

Références $this.

◆ restorePosition()

restorePosition ( )
Renvoie
$this

Références $this.

◆ savePosition()

savePosition ( )
Renvoie
$this

Références $this.

◆ show()

show ( )
Renvoie
$this

Références $this.

Documentation des champs

◆ $input

$input
private

Référencé par Cursor\__construct().

◆ $output

$output
private

Référencé par Cursor\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • console/Cursor.php


Joomla CMS: Référence de la classe SingleCommandApplication

  • Symfony
  • Component
  • Console
  • SingleCommandApplication
Fonctions membres publiques | Attributs privés
Référence de la classe SingleCommandApplication
+ Graphe d'héritage de SingleCommandApplication:
Command

Fonctions membres publiques

setVersion (string $version)
setAutoExit (bool $autoExit)
run (InputInterface $input=null, OutputInterface $output=null)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Attributs privés

$version = 'UNKNOWN'
$autoExit = true
$running = false

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Description détaillée

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ run()

run | ( | InputInterface | $input = null,
 |  | OutputInterface | $output = null
 | ) |  |

Références Command\$application, $input, $output, $this, Command\getName(), et Command\setName().

◆ setAutoExit()

setAutoExit ( bool $autoExit )
Renvoie
$this

Références SingleCommandApplication\$autoExit, et $this.

◆ setVersion()

setVersion ( string $version )
Renvoie
$this

Références $this, et SingleCommandApplication\$version.

Documentation des champs

◆ $autoExit

$autoExit = true
private

Référencé par SingleCommandApplication\setAutoExit().

◆ $running

$running = false
private

◆ $version

$version = 'UNKNOWN'
private

Référencé par SingleCommandApplication\setVersion().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SingleCommandApplication.php


Joomla CMS: Référence de la classe Terminal

  • Symfony
  • Component
  • Console
  • Terminal
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Terminal

Fonctions membres publiques

getWidth ()
getHeight ()

Fonctions membres publiques statiques

static hasSttyAvailable ()

Fonctions membres privées statiques

static | initDimensions ()
static | hasVt100Support ()
static | initDimensionsUsingStty ()
static | getConsoleMode ()
static | getSttyColumns ()
static | readFromProcess (string $command)

Attributs privés statiques

static | $width
static | $height
static | $stty

Documentation des fonctions membres

◆ getConsoleMode()

static getConsoleMode ( )
staticprivate

Runs and parses mode CON if it's available, suppressing any error output.

Renvoie
int[]|null An array composed of the width and the height or null if it could not be parsed

Références $info, et null.

◆ getHeight()

getHeight ( )

Gets the terminal height.

Renvoie
int

Références Terminal\$height, $height, et null.

◆ getSttyColumns()

static getSttyColumns ( )
staticprivate

Runs and parses stty -a if it's available, suppressing any error output.

◆ getWidth()

getWidth ( )

Gets the terminal width.

Renvoie
int

Références Terminal\$width, $width, et null.

◆ hasSttyAvailable()

static hasSttyAvailable ( )
static

Références $output, et null.

Référencé par QuestionHelper\doAsk(), Application\doRunCommand(), et QuestionHelper\getHiddenResponse().

◆ hasVt100Support()

static hasVt100Support ( )
staticprivate

Returns whether STDOUT has vt100 support (some Windows 10+ configurations).

◆ initDimensions()

static initDimensions ( )
staticprivate

Références $height, $width, elseif, et null.

◆ initDimensionsUsingStty()

static initDimensionsUsingStty ( )
staticprivate

Initializes dimensions using the output of an stty columns line.

Références $height, $width, et elseif.

◆ readFromProcess()

static readFromProcess ( string $command )
staticprivate

Références $info, et null.

Documentation des champs

◆ $height

$height
staticprivate

Référencé par Terminal\getHeight().

◆ $stty

$stty
staticprivate

◆ $width

$width
staticprivate

Référencé par Terminal\getWidth().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Terminal.php


Joomla CMS: Référence de la classe ClassNotFoundError

  • Symfony
  • Component
  • ErrorHandler
  • Error
  • ClassNotFoundError
Fonctions membres publiques
Référence de la classe ClassNotFoundError
+ Graphe d'héritage de ClassNotFoundError:

Fonctions membres publiques

__construct (string $message, \Throwable $previous)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | \Throwable | $previous
 | ) |  |

{}

Références $message, $this, $value, Symfony\Contracts\Service\__construct(), et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ClassNotFoundError.php


Joomla CMS: Référence de la classe FatalError

  • Symfony
  • Component
  • ErrorHandler
  • Error
  • FatalError
Fonctions membres publiques | Attributs privés
Référence de la classe FatalError
+ Graphe d'héritage de FatalError:
OutOfMemoryError

Fonctions membres publiques

__construct (string $message, int $code, array $error, int $traceOffset=null, bool $traceArgs=true, array $trace=null)
getError ()

Attributs privés

$error

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | int | $code,
 |  | array | $error,
 |  | int | $traceOffset = null,
 |  | bool | $traceArgs = true,
 |  | array | $trace = null
 | ) |  |

{}

Paramètres
array $error An array as returned by error_get_last()

Références FatalError\$error, $message, $this, $value, Symfony\Contracts\Service\__construct(), class, elseif, et null.

Documentation des fonctions membres

◆ getError()

getError ( )

{}

Références FatalError\$error.

Référencé par ClassNotFoundErrorEnhancer\enhance().

Documentation des champs

◆ $error

$error
private

Référencé par FatalError\__construct(), et FatalError\getError().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FatalError.php


Joomla CMS: Référence de la classe OutOfMemoryError

  • Symfony
  • Component
  • ErrorHandler
  • Error
  • OutOfMemoryError
Référence de la classe OutOfMemoryError
+ Graphe d'héritage de OutOfMemoryError:
FatalError

Membres hérités additionnels

- Fonctions membres publiques hérités de FatalError
__construct (string $message, int $code, array $error, int $traceOffset=null, bool $traceArgs=true, array $trace=null)
getError ()
La documentation de cette classe a été générée à partir du fichier suivant :
  • OutOfMemoryError.php


Joomla CMS: Référence de la classe UndefinedFunctionError

  • Symfony
  • Component
  • ErrorHandler
  • Error
  • UndefinedFunctionError
Fonctions membres publiques
Référence de la classe UndefinedFunctionError
+ Graphe d'héritage de UndefinedFunctionError:

Fonctions membres publiques

__construct (string $message, \Throwable $previous)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | \Throwable | $previous
 | ) |  |

{}

Références $message, $this, $value, Symfony\Contracts\Service\__construct(), et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedFunctionError.php


Joomla CMS: Référence de la classe UndefinedMethodError

  • Symfony
  • Component
  • ErrorHandler
  • Error
  • UndefinedMethodError
Fonctions membres publiques
Référence de la classe UndefinedMethodError
+ Graphe d'héritage de UndefinedMethodError:

Fonctions membres publiques

__construct (string $message, \Throwable $previous)

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | \Throwable | $previous
 | ) |  |

{}

Références $message, $this, $value, Symfony\Contracts\Service\__construct(), et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedMethodError.php


Joomla CMS: Référence de la classe ClassNotFoundErrorEnhancer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorEnhancer
  • ClassNotFoundErrorEnhancer
Fonctions membres publiques | Fonctions membres privées
Référence de la classe ClassNotFoundErrorEnhancer
+ Graphe d'héritage de ClassNotFoundErrorEnhancer:
ErrorEnhancerInterface

Fonctions membres publiques

enhance (\Throwable $error)

Fonctions membres privées

getClassCandidates (string $class)
findClassInPath (string $path, string $class, string $prefix)
convertFileToClass (string $path, string $file, string $prefix)
classExists (string $class)

Description détaillée

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ classExists()

classExists ( string $class )
private

Références $class.

Référencé par ClassNotFoundErrorEnhancer\convertFileToClass().

◆ convertFileToClass()

convertFileToClass | ( | string | $path,
 |  | string | $file,
 |  | string | $prefix
 | ) |  |
private

Références $path, $prefix, ClassNotFoundErrorEnhancer\classExists(), et null.

Référencé par ClassNotFoundErrorEnhancer\findClassInPath().

◆ enhance()

enhance ( \Throwable $error )

{Returns an instance if the class is able to improve the error, null otherwise.}

Implémente ErrorEnhancerInterface.

Références $className, $message, ClassNotFoundErrorEnhancer\getClassCandidates(), FatalError\getError(), et null.

◆ findClassInPath()

findClassInPath | ( | string | $path,
 |  | string | $class,
 |  | string | $prefix
 | ) |  |
private

Références $class, $classes, $path, $prefix, et ClassNotFoundErrorEnhancer\convertFileToClass().

Référencé par ClassNotFoundErrorEnhancer\getClassCandidates().

◆ getClassCandidates()

getClassCandidates ( string $class )
private

Tries to guess the full namespace for a given class name.

By default, it looks for PSR-0 and PSR-4 classes registered via a Symfony or a Composer autoloader (that should cover all common cases).

Paramètres
string $class A class name (without its namespace)

Returns an array of possible fully qualified class names

Références $class, $classes, $function, $path, $prefix, et ClassNotFoundErrorEnhancer\findClassInPath().

Référencé par ClassNotFoundErrorEnhancer\enhance().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ClassNotFoundErrorEnhancer.php


Joomla CMS: Référence de l'interface ErrorEnhancerInterface

  • Symfony
  • Component
  • ErrorHandler
  • ErrorEnhancer
  • ErrorEnhancerInterface
Fonctions membres publiques
Référence de l'interface ErrorEnhancerInterface
+ Graphe d'héritage de ErrorEnhancerInterface:
ClassNotFoundErrorEnhancer UndefinedFunctionErrorEnhancer UndefinedMethodErrorEnhancer

Fonctions membres publiques

enhance (\Throwable $error)

Documentation des fonctions membres

◆ enhance()

enhance ( \Throwable $error )

Returns an instance if the class is able to improve the error, null otherwise.

Implémenté dans ClassNotFoundErrorEnhancer, UndefinedFunctionErrorEnhancer, et UndefinedMethodErrorEnhancer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ErrorEnhancerInterface.php


Joomla CMS: Référence de la classe UndefinedFunctionErrorEnhancer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorEnhancer
  • UndefinedFunctionErrorEnhancer
Fonctions membres publiques
Référence de la classe UndefinedFunctionErrorEnhancer
+ Graphe d'héritage de UndefinedFunctionErrorEnhancer:
ErrorEnhancerInterface

Fonctions membres publiques

enhance (\Throwable $error)

Description détaillée

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ enhance()

enhance ( \Throwable $error )

{Returns an instance if the class is able to improve the error, null otherwise.}

Implémente ErrorEnhancerInterface.

Références $last, $message, $prefix, $type, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedFunctionErrorEnhancer.php


Joomla CMS: Référence de la classe UndefinedMethodErrorEnhancer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorEnhancer
  • UndefinedMethodErrorEnhancer
Fonctions membres publiques
Référence de la classe UndefinedMethodErrorEnhancer
+ Graphe d'héritage de UndefinedMethodErrorEnhancer:
ErrorEnhancerInterface

Fonctions membres publiques

enhance (\Throwable $error)

Description détaillée

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ enhance()

enhance ( \Throwable $error )

{Returns an instance if the class is able to improve the error, null otherwise.}

Implémente ErrorEnhancerInterface.

Références $className, $last, $message, $methodName, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedMethodErrorEnhancer.php


Joomla CMS: Référence de la classe CliErrorRenderer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorRenderer
  • CliErrorRenderer
Fonctions membres publiques
Référence de la classe CliErrorRenderer
+ Graphe d'héritage de CliErrorRenderer:
ErrorRendererInterface

Fonctions membres publiques

render (\Throwable $exception)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ render()

render ( \Throwable $exception )

{Renders a Throwable as a FlattenException.}

Implémente ErrorRendererInterface.

Références FlattenException\createFromThrowable().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CliErrorRenderer.php


Joomla CMS: Référence de l'interface ErrorRendererInterface

  • Symfony
  • Component
  • ErrorHandler
  • ErrorRenderer
  • ErrorRendererInterface
Fonctions membres publiques
Référence de l'interface ErrorRendererInterface
+ Graphe d'héritage de ErrorRendererInterface:
CliErrorRenderer HtmlErrorRenderer SerializerErrorRenderer

Fonctions membres publiques

render (\Throwable $exception)

Description détaillée

Formats an exception to be used as response content.

Auteur
Yonel Ceruto yonel.nosp@m.ceru.nosp@m.to@gm.nosp@m.ail..nosp@m.com

Documentation des fonctions membres

◆ render()

render ( \Throwable $exception )

Renders a Throwable as a FlattenException.

Implémenté dans HtmlErrorRenderer, SerializerErrorRenderer, et CliErrorRenderer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ErrorRendererInterface.php


Joomla CMS: Référence de la classe HtmlErrorRenderer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorRenderer
  • HtmlErrorRenderer
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe HtmlErrorRenderer
+ Graphe d'héritage de HtmlErrorRenderer:
ErrorRendererInterface

Fonctions membres publiques

__construct ($debug=false, string $charset=null, $fileLinkFormat=null, string $projectDir=null, $outputBuffer='', LoggerInterface $logger=null)
render (\Throwable $exception)
getBody (FlattenException $exception)
getStylesheet ()

Fonctions membres publiques statiques

static | isDebug (RequestStack $requestStack, bool $debug)
static | getAndCleanOutputBuffer (RequestStack $requestStack)

Fonctions membres privées

renderException (FlattenException $exception, string $debugTemplate='views/exception_full.html.php')
formatArgs (array $args)
formatArgsAsText (array $args)
escape (string $string)
abbrClass (string $class)
getFileRelative (string $file)
getFileLink (string $file, int $line)
formatFile (string $file, int $line, string $text=null)
fileExcerpt (string $file, int $line, int $srcContext=3)
fixCodeMarkup (string $line)
formatFileFromText (string $text)
formatLogMessage (string $message, array $context)
addElementToGhost ()

Attributs privés

const | GHOST_ADDONS
const const | GHOST_GIFT = 'M124.00534057617188,5.3606138080358505 C124.40059661865234,4.644828304648399 125.1237564086914,3.712414965033531 123.88127899169922,3.487462028861046 C123.53517150878906,3.3097832053899765 123.18894958496094,2.9953975528478622 122.8432846069336,3.345616325736046 C122.07421112060547,3.649444565176964 121.40750122070312,4.074306473135948 122.2164306640625,4.869479164481163 C122.57514953613281,5.3830065578222275 122.90142822265625,6.503447040915489 123.3077621459961,6.626829609274864 C123.55027770996094,6.210384353995323 123.7774658203125,5.785196766257286 124.00534057617188,5.3606138080358505 zM122.30630493164062,7.336987480521202 C121.60028076171875,6.076864704489708 121.03211975097656,4.72498320043087 120.16796875,3.562500938773155 C119.11695098876953,2.44033907353878 117.04605865478516,2.940566048026085 116.57544708251953,4.387995228171349 C115.95028686523438,5.819030746817589 117.2991714477539,7.527640804648399 118.826171875,7.348545059561729 C119.98493194580078,7.367936596274376 121.15027618408203,7.420116886496544 122.30630493164062,7.336987480521202 zM128.1732177734375,7.379541382193565 C129.67486572265625,7.17823551595211 130.53842163085938,5.287807449698448 129.68344116210938,4.032590612769127 C128.92578125,2.693056806921959 126.74605560302734,2.6463639587163925 125.98509216308594,4.007616028189659 C125.32617950439453,5.108129009604454 124.75428009033203,6.258124336600304 124.14962768554688,7.388818249106407 C125.48638916015625,7.465229496359825 126.8357162475586,7.447416767477989 128.1732177734375,7.379541382193565 zM130.6601104736328,8.991325363516808 C131.17202758789062,8.540884003043175 133.1543731689453,8.009847149252892 131.65304565429688,7.582054600119591 C131.2811279296875,7.476506695151329 130.84751892089844,6.99234913289547 130.5132598876953,7.124847874045372 C129.78744506835938,8.02728746831417 128.67140197753906,8.55669592320919 127.50616455078125,8.501235947012901 C127.27806091308594,8.576229080557823 126.11459350585938,8.38720129430294 126.428955078125,8.601900085806847 C127.25099182128906,9.070617660880089 128.0523223876953,9.579657539725304 128.902587890625,9.995706543326378 C129.49813842773438,9.678531631827354 130.0761260986328,9.329126343131065 130.6601104736328,8.991325363516808 zM118.96446990966797,9.246344551444054 C119.4022445678711,8.991325363516808 119.84001922607422,8.736305221915245 120.27779388427734,8.481284126639366 C118.93965911865234,8.414779648184776 117.40827941894531,8.607666000723839 116.39698791503906,7.531384453177452 C116.11186981201172,7.212117180228233 115.83845520019531,6.846597656607628 115.44329071044922,7.248530372977257 C114.96995544433594,7.574637398123741 113.5140609741211,7.908811077475548 114.63501739501953,8.306883797049522 C115.61112976074219,8.883499130606651 116.58037567138672,9.474181160330772 117.58061218261719,10.008124336600304 C118.05723571777344,9.784612640738487 118.50651550292969,9.5052699893713 118.96446990966797,9.246344551444054 zM125.38018035888672,12.091858848929405 C125.9474868774414,11.636047348380089 127.32159423828125,11.201767906546593 127.36749267578125,10.712632164359093 C126.08487701416016,9.974547371268272 124.83960723876953,9.152772888541222 123.49772644042969,8.528907760977745 C123.03594207763672,8.353693947196007 122.66152954101562,8.623294815421104 122.28982543945312,8.857431396842003 C121.19065856933594,9.51122473180294 120.06505584716797,10.12446115911007 119.00167083740234,10.835315689444542 C120.39238739013672,11.69529627263546 121.79983520507812,12.529837593436241 123.22095489501953,13.338589653372765 C123.94580841064453,12.932025894522667 124.66128540039062,12.508862480521202 125.38018035888672,12.091858848929405 zM131.07164001464844,13.514615997672081 C131.66018676757812,13.143282875418663 132.2487335205078,12.771927818655968 132.8372802734375,12.400571808218956 C132.8324737548828,11.156818374991417 132.8523406982422,9.912529930472374 132.81829833984375,8.669195160269737 C131.63046264648438,9.332009300589561 130.45948791503906,10.027913078665733 129.30828857421875,10.752535805106163 C129.182373046875,12.035354599356651 129.24623107910156,13.33940313756466 129.27359008789062,14.628684982657433 C129.88104248046875,14.27079389989376 130.4737548828125,13.888019546866417 131.07164001464844,13.514640793204308 zM117.26847839355469,12.731024727225304 C117.32825469970703,11.67083452641964 117.45709991455078,10.46224020421505 116.17853546142578,10.148179039359093 C115.37110900878906,9.77159021794796 114.25194549560547,8.806716904044151 113.62991333007812,8.81639002263546 C113.61052703857422,10.0110072940588 113.62078857421875,11.20585821568966 113.61869049072266,12.400571808218956 C114.81139373779297,13.144886955618858 115.98292541503906,13.925040230154991 117.20137023925781,14.626662239432335 C117.31951141357422,14.010867103934288 117.24227905273438,13.35805033147335 117.26847839355469,12.731024727225304 zM125.80937957763672,16.836034759879112 C126.51483917236328,16.390663132071495 127.22030639648438,15.945291504263878 127.92576599121094,15.49991987645626 C127.92250061035156,14.215868934988976 127.97560119628906,12.929980263113976 127.91757202148438,11.647302612662315 C127.14225769042969,11.869626984000206 126.25550079345703,12.556857094168663 125.43866729736328,12.983742699027061 C124.82704162597656,13.342005714774132 124.21542358398438,13.700271591544151 123.60379028320312,14.05853746831417 C123.61585235595703,15.429577812552452 123.57081604003906,16.803131088614464 123.64839172363281,18.172149643301964 C124.37957000732422,17.744937881827354 125.09130859375,17.284801468253136 125.80937957763672,16.836034759879112 zM122.8521499633789,16.115344032645226 C122.8521499633789,15.429741844534874 122.8521499633789,14.744139656424522 122.8521499633789,14.05853746831417 C121.43595123291016,13.230924591422081 120.02428436279297,12.395455345511436 118.60256958007812,11.577354416251183 C118.52394104003906,12.888403877615929 118.56887817382812,14.204405769705772 118.55702209472656,15.517732605338097 C119.97289276123047,16.4041957706213 121.37410736083984,17.314891800284386 122.80789947509766,18.172149643301964 C122.86368560791016,17.488990768790245 122.84332275390625,16.800363525748253 122.8521499633789,16.115344032645226 zM131.10684204101562,18.871450409293175 C131.68399047851562,18.48711584508419 132.2611541748047,18.10278509557247 132.8383026123047,17.718475326895714 C132.81423950195312,16.499977096915245 132.89776611328125,15.264989838004112 132.77627563476562,14.05993078649044 C131.5760040283203,14.744719490408897 130.41763305664062,15.524359688162804 129.23875427246094,16.255397781729698 C129.26707458496094,17.516149505972862 129.18060302734375,18.791316971182823 129.3108367919922,20.041303619742393 C129.91973876953125,19.667551025748253 130.51010131835938,19.264152511954308 131.10684204101562,18.871450409293175 zM117.2557373046875,18.188333496451378 C117.25104522705078,17.549470886588097 117.24633026123047,16.91058538854122 117.24163055419922,16.271720871329308 C116.04924774169922,15.525708183646202 114.87187957763672,14.75476549565792 113.66158294677734,14.038097366690636 C113.5858383178711,15.262084946036339 113.62901306152344,16.49083898961544 113.61761474609375,17.717010483145714 C114.82051086425781,18.513254150748253 116.00987243652344,19.330610260367393 117.22888946533203,20.101993545889854 C117.27559661865234,19.466014847159386 117.25241088867188,18.825733169913292 117.2557373046875,18.188333496451378 zM125.8398666381836,22.38675306737423 C126.54049682617188,21.921453461050987 127.24110412597656,21.456151947379112 127.94172668457031,20.99083136022091 C127.94009399414062,19.693386062979698 127.96646118164062,18.395381912589073 127.93160247802734,17.098379120230675 C126.50540924072266,17.97775076329708 125.08877563476562,18.873308166861534 123.68258666992188,19.78428266942501 C123.52366638183594,21.03710363805294 123.626708984375,22.32878302037716 123.62647247314453,23.595300659537315 C124.06291198730469,23.86113165318966 125.1788101196289,22.68297766149044 125.8398666381836,22.38675306737423 zM122.8521499633789,21.83134649693966 C122.76741790771484,20.936696991324425 123.21651458740234,19.67745779454708 122.0794677734375,19.330633148550987 C120.93280029296875,18.604360565543175 119.7907485961914,17.870157226920128 118.62899780273438,17.16818617284298 C118.45966339111328,18.396427139639854 118.63676452636719,19.675991043448448 118.50668334960938,20.919256195425987 C119.89984130859375,21.92635916173458 121.32942199707031,22.88914106786251 122.78502655029297,23.803510650992393 C122.90177917480469,23.1627406924963 122.82917022705078,22.48402212560177 122.8521499633789,21.83134649693966 zM117.9798355102539,21.59483526647091 C116.28416442871094,20.46288488805294 114.58848571777344,19.330957397818565 112.892822265625,18.199007019400597 C112.89473724365234,14.705654129385948 112.84647369384766,11.211485847830772 112.90847778320312,7.718807205557823 C113.7575912475586,7.194885239005089 114.66117858886719,6.765397056937218 115.5350341796875,6.284702762961388 C114.97061157226562,4.668964847922325 115.78496551513672,2.7054970115423203 117.42159271240234,2.1007001250982285 C118.79354095458984,1.537783369421959 120.44731903076172,2.0457767099142075 121.32200622558594,3.23083733022213 C121.95732116699219,2.9050118774175644 122.59264373779297,2.5791852325201035 123.22796630859375,2.253336176276207 C123.86669921875,2.5821153968572617 124.50543975830078,2.9108948558568954 125.1441650390625,3.23967407643795 C126.05941009521484,2.154020771384239 127.62747192382812,1.5344576686620712 128.986328125,2.1429056972265244 C130.61741638183594,2.716217741370201 131.50650024414062,4.675290569663048 130.9215545654297,6.2884936183691025 C131.8018341064453,6.78548763692379 132.7589111328125,7.1738648265600204 133.5660400390625,7.780336365103722 C133.60182189941406,11.252970680594444 133.56637573242188,14.726140961050987 133.5631103515625,18.199007019400597 C130.18914794921875,20.431867584586143 126.86984252929688,22.74994657933712 123.44108581542969,24.897907242178917 C122.44406127929688,24.897628769278526 121.5834732055664,23.815067276358604 120.65831756591797,23.37616156041622 C119.76387023925781,22.784828171133995 118.87168884277344,22.19007681310177 117.9798355102539,21.59483526647091 z'
const | GHOST_HEART = 'M125.91386369681868,8.305165958366445 C128.95033202169043,-0.40540639102854037 140.8469835342744,8.305165958366445 125.91386369681868,19.504526138305664 C110.98208663272044,8.305165958366445 122.87795231771452,-0.40540639102854037 125.91386369681868,8.305165958366445 z'
const | GHOST_PLUS = 'M111.36824226379395,8.969108581542969 L118.69175148010254,8.969108581542969 L118.69175148010254,1.6455793380737305 L126.20429420471191,1.6455793380737305 L126.20429420471191,8.969108581542969 L133.52781105041504,8.969108581542969 L133.52781105041504,16.481630325317383 L126.20429420471191,16.481630325317383 L126.20429420471191,23.805158615112305 L118.69175148010254,23.805158615112305 L118.69175148010254,16.481630325317383 L111.36824226379395,16.481630325317383 z'
$debug
$charset
$fileLinkFormat
$projectDir
$outputBuffer
$logger
function

Attributs privés statiques

static $template = 'views/error.html.php'

Description détaillée

Auteur
Yonel Ceruto yonel.nosp@m.ceru.nosp@m.to@gm.nosp@m.ail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $debug = false,
 |  | string | $charset = null,
 |  |  | $fileLinkFormat = null,
 |  | string | $projectDir = null,
 |  |  | $outputBuffer = '',
 |  | LoggerInterface | $logger = null
 | ) |  |
Paramètres
bool | callable | $debug | The debugging mode as a boolean or a callable that should return it
string | FileLinkFormatter | null | $fileLinkFormat
bool | callable | $outputBuffer | The output buffer as a string or a callable that should return it

Références HtmlErrorRenderer\$charset, HtmlErrorRenderer\$debug, HtmlErrorRenderer\$fileLinkFormat, HtmlErrorRenderer\$logger, HtmlErrorRenderer\$outputBuffer, et HtmlErrorRenderer\$projectDir.

Documentation des fonctions membres

◆ abbrClass()

abbrClass ( string $class )
private

Références $class, et $parts.

Référencé par HtmlErrorRenderer\formatArgs().

◆ addElementToGhost()

addElementToGhost ( )
private

◆ escape()

escape ( string $string )
private

Références ENT_COMPAT.

Référencé par HtmlErrorRenderer\formatArgs(), HtmlErrorRenderer\formatFile(), HtmlErrorRenderer\formatLogMessage(), et HtmlErrorRenderer\renderException().

◆ fileExcerpt()

fileExcerpt | ( | string | $file,
 |  | int | $line,
 |  | int | $srcContext = 3
 | ) |  |
private

Returns an excerpt of a code file around the given line number.

Paramètres
string | $file | A file path
int | $line | The selected line number
int | $srcContext | The number of displayed lines around or -1 for the whole file

Références $content, $i, et HtmlErrorRenderer\fixCodeMarkup().

◆ fixCodeMarkup()

fixCodeMarkup ( string $line )
private

Référencé par HtmlErrorRenderer\fileExcerpt().

◆ formatArgs()

formatArgs ( array $args )
private

Formats an array as a string.

Références $item, $key, $result, HtmlErrorRenderer\abbrClass(), elseif, et HtmlErrorRenderer\escape().

Référencé par HtmlErrorRenderer\formatArgsAsText().

◆ formatArgsAsText()

formatArgsAsText ( array $args )
private

Références HtmlErrorRenderer\formatArgs().

◆ formatFile()

formatFile | ( | string | $file,
 |  | int | $line,
 |  | string | $text = null
 | ) |  |
private

Formats a file path.

Paramètres
string | $file | An absolute file path
int | $line | The line number
string | $text | Use this text for the link rather than the file path

Références $link, $rel, $text, HtmlErrorRenderer\escape(), HtmlErrorRenderer\getFileLink(), HtmlErrorRenderer\getFileRelative(), et null.

◆ formatFileFromText()

formatFileFromText ( string $text )
private

Références $text.

◆ formatLogMessage()

formatLogMessage | ( | string | $message,
 |  | array | $context
 | ) |  |
private

Références $context, $key, $message, $val, et HtmlErrorRenderer\escape().

◆ getAndCleanOutputBuffer()

static getAndCleanOutputBuffer ( RequestStack $requestStack )
static

◆ getBody()

getBody ( FlattenException $exception )

Gets the HTML content associated with the given exception.

Références HtmlErrorRenderer\renderException().

◆ getFileLink()

getFileLink | ( | string | $file,
 |  | int | $line
 | ) |  |
private

Returns the link for a given file/line pair.

Renvoie
string|false

Référencé par HtmlErrorRenderer\formatFile().

◆ getFileRelative()

getFileRelative ( string $file )
private

Références null.

Référencé par HtmlErrorRenderer\formatFile().

◆ getStylesheet()

getStylesheet ( )

Gets the stylesheet associated with the given exception.

◆ isDebug()

static isDebug | ( | RequestStack | $requestStack,
 |  | bool | $debug
 | ) |  |
static

Références HtmlErrorRenderer\$debug.

◆ render()

render ( \Throwable $exception )

{Renders a Throwable as a FlattenException.}

Implémente ErrorRendererInterface.

Références FlattenException\createFromThrowable(), null, et HtmlErrorRenderer\renderException().

◆ renderException()

renderException | ( | FlattenException | $exception,
 |  | string | $debugTemplate = 'views/exception_full.html.php'
 | ) |  |
private

Références HtmlErrorRenderer\$debug, Symfony\Component\Console\Tester\$statusCode, $template, HtmlErrorRenderer\escape(), FlattenException\getMessage(), FlattenException\getStatusCode(), FlattenException\getStatusText(), et null.

Référencé par HtmlErrorRenderer\getBody(), et HtmlErrorRenderer\render().

Documentation des champs

◆ $charset

$charset
private

Référencé par HtmlErrorRenderer\__construct().

◆ $debug

$debug
private

Référencé par HtmlErrorRenderer\__construct(), HtmlErrorRenderer\isDebug(), et HtmlErrorRenderer\renderException().

◆ $fileLinkFormat

$fileLinkFormat
private

Référencé par HtmlErrorRenderer\__construct().

◆ $logger

$logger
private

Référencé par HtmlErrorRenderer\__construct().

◆ $outputBuffer

$outputBuffer
private

Référencé par HtmlErrorRenderer\__construct().

◆ $projectDir

$projectDir
private

Référencé par HtmlErrorRenderer\__construct().

◆ $template

$template = 'views/error.html.php'
staticprivate

◆ function

function
private

◆ GHOST_ADDONS

const GHOST_ADDONS
private
Valeur initiale :
= [
'02-14' => self::GHOST_HEART

◆ GHOST_GIFT

const const GHOST_GIFT = 'M124.00534057617188,5.3606138080358505 C124.40059661865234,4.644828304648399 125.1237564086914,3.712414965033531 123.88127899169922,3.487462028861046 C123.53517150878906,3.3097832053899765 123.18894958496094,2.9953975528478622 122.8432846069336,3.345616325736046 C122.07421112060547,3.649444565176964 121.40750122070312,4.074306473135948 122.2164306640625,4.869479164481163 C122.57514953613281,5.3830065578222275 122.90142822265625,6.503447040915489 123.3077621459961,6.626829609274864 C123.55027770996094,6.210384353995323 123.7774658203125,5.785196766257286 124.00534057617188,5.3606138080358505 zM122.30630493164062,7.336987480521202 C121.60028076171875,6.076864704489708 121.03211975097656,4.72498320043087 120.16796875,3.562500938773155 C119.11695098876953,2.44033907353878 117.04605865478516,2.940566048026085 116.57544708251953,4.387995228171349 C115.95028686523438,5.819030746817589 117.2991714477539,7.527640804648399 118.826171875,7.348545059561729 C119.98493194580078,7.367936596274376 121.15027618408203,7.420116886496544 122.30630493164062,7.336987480521202 zM128.1732177734375,7.379541382193565 C129.67486572265625,7.17823551595211 130.53842163085938,5.287807449698448 129.68344116210938,4.032590612769127 C128.92578125,2.693056806921959 126.74605560302734,2.6463639587163925 125.98509216308594,4.007616028189659 C125.32617950439453,5.108129009604454 124.75428009033203,6.258124336600304 124.14962768554688,7.388818249106407 C125.48638916015625,7.465229496359825 126.8357162475586,7.447416767477989 128.1732177734375,7.379541382193565 zM130.6601104736328,8.991325363516808 C131.17202758789062,8.540884003043175 133.1543731689453,8.009847149252892 131.65304565429688,7.582054600119591 C131.2811279296875,7.476506695151329 130.84751892089844,6.99234913289547 130.5132598876953,7.124847874045372 C129.78744506835938,8.02728746831417 128.67140197753906,8.55669592320919 127.50616455078125,8.501235947012901 C127.27806091308594,8.576229080557823 126.11459350585938,8.38720129430294 126.428955078125,8.601900085806847 C127.25099182128906,9.070617660880089 128.0523223876953,9.579657539725304 128.902587890625,9.995706543326378 C129.49813842773438,9.678531631827354 130.0761260986328,9.329126343131065 130.6601104736328,8.991325363516808 zM118.96446990966797,9.246344551444054 C119.4022445678711,8.991325363516808 119.84001922607422,8.736305221915245 120.27779388427734,8.481284126639366 C118.93965911865234,8.414779648184776 117.40827941894531,8.607666000723839 116.39698791503906,7.531384453177452 C116.11186981201172,7.212117180228233 115.83845520019531,6.846597656607628 115.44329071044922,7.248530372977257 C114.96995544433594,7.574637398123741 113.5140609741211,7.908811077475548 114.63501739501953,8.306883797049522 C115.61112976074219,8.883499130606651 116.58037567138672,9.474181160330772 117.58061218261719,10.008124336600304 C118.05723571777344,9.784612640738487 118.50651550292969,9.5052699893713 118.96446990966797,9.246344551444054 zM125.38018035888672,12.091858848929405 C125.9474868774414,11.636047348380089 127.32159423828125,11.201767906546593 127.36749267578125,10.712632164359093 C126.08487701416016,9.974547371268272 124.83960723876953,9.152772888541222 123.49772644042969,8.528907760977745 C123.03594207763672,8.353693947196007 122.66152954101562,8.623294815421104 122.28982543945312,8.857431396842003 C121.19065856933594,9.51122473180294 120.06505584716797,10.12446115911007 119.00167083740234,10.835315689444542 C120.39238739013672,11.69529627263546 121.79983520507812,12.529837593436241 123.22095489501953,13.338589653372765 C123.94580841064453,12.932025894522667 124.66128540039062,12.508862480521202 125.38018035888672,12.091858848929405 zM131.07164001464844,13.514615997672081 C131.66018676757812,13.143282875418663 132.2487335205078,12.771927818655968 132.8372802734375,12.400571808218956 C132.8324737548828,11.156818374991417 132.8523406982422,9.912529930472374 132.81829833984375,8.669195160269737 C131.63046264648438,9.332009300589561 130.45948791503906,10.027913078665733 129.30828857421875,10.752535805106163 C129.182373046875,12.035354599356651 129.24623107910156,13.33940313756466 129.27359008789062,14.628684982657433 C129.88104248046875,14.27079389989376 130.4737548828125,13.888019546866417 131.07164001464844,13.514640793204308 zM117.26847839355469,12.731024727225304 C117.32825469970703,11.67083452641964 117.45709991455078,10.46224020421505 116.17853546142578,10.148179039359093 C115.37110900878906,9.77159021794796 114.25194549560547,8.806716904044151 113.62991333007812,8.81639002263546 C113.61052703857422,10.0110072940588 113.62078857421875,11.20585821568966 113.61869049072266,12.400571808218956 C114.81139373779297,13.144886955618858 115.98292541503906,13.925040230154991 117.20137023925781,14.626662239432335 C117.31951141357422,14.010867103934288 117.24227905273438,13.35805033147335 117.26847839355469,12.731024727225304 zM125.80937957763672,16.836034759879112 C126.51483917236328,16.390663132071495 127.22030639648438,15.945291504263878 127.92576599121094,15.49991987645626 C127.92250061035156,14.215868934988976 127.97560119628906,12.929980263113976 127.91757202148438,11.647302612662315 C127.14225769042969,11.869626984000206 126.25550079345703,12.556857094168663 125.43866729736328,12.983742699027061 C124.82704162597656,13.342005714774132 124.21542358398438,13.700271591544151 123.60379028320312,14.05853746831417 C123.61585235595703,15.429577812552452 123.57081604003906,16.803131088614464 123.64839172363281,18.172149643301964 C124.37957000732422,17.744937881827354 125.09130859375,17.284801468253136 125.80937957763672,16.836034759879112 zM122.8521499633789,16.115344032645226 C122.8521499633789,15.429741844534874 122.8521499633789,14.744139656424522 122.8521499633789,14.05853746831417 C121.43595123291016,13.230924591422081 120.02428436279297,12.395455345511436 118.60256958007812,11.577354416251183 C118.52394104003906,12.888403877615929 118.56887817382812,14.204405769705772 118.55702209472656,15.517732605338097 C119.97289276123047,16.4041957706213 121.37410736083984,17.314891800284386 122.80789947509766,18.172149643301964 C122.86368560791016,17.488990768790245 122.84332275390625,16.800363525748253 122.8521499633789,16.115344032645226 zM131.10684204101562,18.871450409293175 C131.68399047851562,18.48711584508419 132.2611541748047,18.10278509557247 132.8383026123047,17.718475326895714 C132.81423950195312,16.499977096915245 132.89776611328125,15.264989838004112 132.77627563476562,14.05993078649044 C131.5760040283203,14.744719490408897 130.41763305664062,15.524359688162804 129.23875427246094,16.255397781729698 C129.26707458496094,17.516149505972862 129.18060302734375,18.791316971182823 129.3108367919922,20.041303619742393 C129.91973876953125,19.667551025748253 130.51010131835938,19.264152511954308 131.10684204101562,18.871450409293175 zM117.2557373046875,18.188333496451378 C117.25104522705078,17.549470886588097 117.24633026123047,16.91058538854122 117.24163055419922,16.271720871329308 C116.04924774169922,15.525708183646202 114.87187957763672,14.75476549565792 113.66158294677734,14.038097366690636 C113.5858383178711,15.262084946036339 113.62901306152344,16.49083898961544 113.61761474609375,17.717010483145714 C114.82051086425781,18.513254150748253 116.00987243652344,19.330610260367393 117.22888946533203,20.101993545889854 C117.27559661865234,19.466014847159386 117.25241088867188,18.825733169913292 117.2557373046875,18.188333496451378 zM125.8398666381836,22.38675306737423 C126.54049682617188,21.921453461050987 127.24110412597656,21.456151947379112 127.94172668457031,20.99083136022091 C127.94009399414062,19.693386062979698 127.96646118164062,18.395381912589073 127.93160247802734,17.098379120230675 C126.50540924072266,17.97775076329708 125.08877563476562,18.873308166861534 123.68258666992188,19.78428266942501 C123.52366638183594,21.03710363805294 123.626708984375,22.32878302037716 123.62647247314453,23.595300659537315 C124.06291198730469,23.86113165318966 125.1788101196289,22.68297766149044 125.8398666381836,22.38675306737423 zM122.8521499633789,21.83134649693966 C122.76741790771484,20.936696991324425 123.21651458740234,19.67745779454708 122.0794677734375,19.330633148550987 C120.93280029296875,18.604360565543175 119.7907485961914,17.870157226920128 118.62899780273438,17.16818617284298 C118.45966339111328,18.396427139639854 118.63676452636719,19.675991043448448 118.50668334960938,20.919256195425987 C119.89984130859375,21.92635916173458 121.32942199707031,22.88914106786251 122.78502655029297,23.803510650992393 C122.90177917480469,23.1627406924963 122.82917022705078,22.48402212560177 122.8521499633789,21.83134649693966 zM117.9798355102539,21.59483526647091 C116.28416442871094,20.46288488805294 114.58848571777344,19.330957397818565 112.892822265625,18.199007019400597 C112.89473724365234,14.705654129385948 112.84647369384766,11.211485847830772 112.90847778320312,7.718807205557823 C113.7575912475586,7.194885239005089 114.66117858886719,6.765397056937218 115.5350341796875,6.284702762961388 C114.97061157226562,4.668964847922325 115.78496551513672,2.7054970115423203 117.42159271240234,2.1007001250982285 C118.79354095458984,1.537783369421959 120.44731903076172,2.0457767099142075 121.32200622558594,3.23083733022213 C121.95732116699219,2.9050118774175644 122.59264373779297,2.5791852325201035 123.22796630859375,2.253336176276207 C123.86669921875,2.5821153968572617 124.50543975830078,2.9108948558568954 125.1441650390625,3.23967407643795 C126.05941009521484,2.154020771384239 127.62747192382812,1.5344576686620712 128.986328125,2.1429056972265244 C130.61741638183594,2.716217741370201 131.50650024414062,4.675290569663048 130.9215545654297,6.2884936183691025 C131.8018341064453,6.78548763692379 132.7589111328125,7.1738648265600204 133.5660400390625,7.780336365103722 C133.60182189941406,11.252970680594444 133.56637573242188,14.726140961050987 133.5631103515625,18.199007019400597 C130.18914794921875,20.431867584586143 126.86984252929688,22.74994657933712 123.44108581542969,24.897907242178917 C122.44406127929688,24.897628769278526 121.5834732055664,23.815067276358604 120.65831756591797,23.37616156041622 C119.76387023925781,22.784828171133995 118.87168884277344,22.19007681310177 117.9798355102539,21.59483526647091 z'
private

◆ GHOST_HEART

const GHOST_HEART = 'M125.91386369681868,8.305165958366445 C128.95033202169043,-0.40540639102854037 140.8469835342744,8.305165958366445 125.91386369681868,19.504526138305664 C110.98208663272044,8.305165958366445 122.87795231771452,-0.40540639102854037 125.91386369681868,8.305165958366445 z'
private

◆ GHOST_PLUS

const GHOST_PLUS = 'M111.36824226379395,8.969108581542969 L118.69175148010254,8.969108581542969 L118.69175148010254,1.6455793380737305 L126.20429420471191,1.6455793380737305 L126.20429420471191,8.969108581542969 L133.52781105041504,8.969108581542969 L133.52781105041504,16.481630325317383 L126.20429420471191,16.481630325317383 L126.20429420471191,23.805158615112305 L118.69175148010254,23.805158615112305 L118.69175148010254,16.481630325317383 L111.36824226379395,16.481630325317383 z'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlErrorRenderer.php


Joomla CMS: Référence de la classe SerializerErrorRenderer

  • Symfony
  • Component
  • ErrorHandler
  • ErrorRenderer
  • SerializerErrorRenderer
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe SerializerErrorRenderer
+ Graphe d'héritage de SerializerErrorRenderer:
ErrorRendererInterface

Fonctions membres publiques

__construct (SerializerInterface $serializer, $format, ErrorRendererInterface $fallbackErrorRenderer=null, $debug=false)
render (\Throwable $exception)

Fonctions membres publiques statiques

static getPreferredFormat (RequestStack $requestStack)

Attributs privés

$serializer
$format
$fallbackErrorRenderer
$debug

Description détaillée

Formats an exception using Serializer for rendering.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | SerializerInterface | $serializer,
 |  |  | $format,
 |  | ErrorRendererInterface | $fallbackErrorRenderer = null,
 |  |  | $debug = false
 | ) |  |
Paramètres
string|callable(FlattenException) | $format The format as a string or a callable that should return it formats not supported by Request::getMimeTypes() should be given as mime types
bool | callable | $debug | The debugging mode as a boolean or a callable that should return it

Références SerializerErrorRenderer\$debug, SerializerErrorRenderer\$fallbackErrorRenderer, SerializerErrorRenderer\$format, et SerializerErrorRenderer\$serializer.

Documentation des fonctions membres

◆ getPreferredFormat()

static getPreferredFormat ( RequestStack $requestStack )
static

◆ render()

render ( \Throwable $exception )

{Renders a Throwable as a FlattenException.}

Implémente ErrorRendererInterface.

Références SerializerErrorRenderer\$debug, SerializerErrorRenderer\$format, FlattenException\createFromThrowable(), null, et Laminas\Diactoros\setHeaders().

Documentation des champs

◆ $debug

$debug
private

Référencé par SerializerErrorRenderer\__construct(), et SerializerErrorRenderer\render().

◆ $fallbackErrorRenderer

$fallbackErrorRenderer
private

Référencé par SerializerErrorRenderer\__construct().

◆ $format

$format
private

Référencé par SerializerErrorRenderer\__construct(), et SerializerErrorRenderer\render().

◆ $serializer

$serializer
private

Référencé par SerializerErrorRenderer\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SerializerErrorRenderer.php


Joomla CMS: Référence de la classe FlattenException

  • Symfony
  • Component
  • ErrorHandler
  • Exception
  • FlattenException
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe FlattenException

Fonctions membres publiques

toArray ()
getStatusCode ()
setStatusCode (int $code)
getHeaders ()
setHeaders (array $headers)
getClass ()
setClass (string $class)
getFile ()
setFile (string $file)
getLine ()
setLine (int $line)
getStatusText ()
setStatusText (string $statusText)
getMessage ()
setMessage (string $message)
getCode ()
setCode ($code)
getPrevious ()
setPrevious (?self $previous)
getAllPrevious ()
getTrace ()
setTraceFromThrowable (\Throwable $throwable)
setTrace (array $trace, ?string $file, ?int $line)
getTraceAsString ()
setAsString (?string $asString)
getAsString ()

Fonctions membres publiques statiques

static | create (\Exception $exception, int $statusCode=null, array $headers=[])
static | createFromThrowable (\Throwable $exception, int $statusCode=null, array $headers=[])

Fonctions membres privées

flattenArgs (array $args, int $level=0, int &$count=0)
getClassNameFromIncomplete (\__PHP_Incomplete_Class $value)

Attributs privés

$message
$code
$previous
$trace
$traceAsString
$class
$statusCode
$statusText
$headers
$file
$line
$asString

Description détaillée

FlattenException wraps a PHP Error or Exception to be able to serialize it.

Basically, this class removes all objects from the trace.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ create()

static create | ( | \Exception | $exception,
 |  | int | $statusCode = null,
 |  | array | $headers = []
 | ) |  |
static
Renvoie
static

Références FlattenException\$headers, et FlattenException\$statusCode.

◆ createFromThrowable()

static createFromThrowable | ( | \Throwable | $exception,
 |  | int | $statusCode = null,
 |  | array | $headers = []
 | ) |  |
static
Renvoie
static

Références FlattenException\$headers, FlattenException\$previous, FlattenException\$statusCode, FlattenException\$statusText, class, elseif, et null.

Référencé par CliErrorRenderer\render(), SerializerErrorRenderer\render(), et HtmlErrorRenderer\render().

◆ flattenArgs()

flattenArgs | ( | array | $args,
 |  | int | $level = 0,
 |  | int & | $count = 0
 | ) |  |
private

Références $count, $key, $result, $value, elseif, FlattenException\getClassNameFromIncomplete(), et null.

Référencé par FlattenException\setTrace().

◆ getAllPrevious()

getAllPrevious ( )
Renvoie
self[]

Références $this.

Référencé par FlattenException\getAsString(), et FlattenException\toArray().

◆ getAsString()

getAsString ( )

Références FlattenException\$asString, FlattenException\$message, $this, FlattenException\getAllPrevious(), et null.

◆ getClass()

getClass ( )

Références FlattenException\$class.

◆ getClassNameFromIncomplete()

getClassNameFromIncomplete ( \__PHP_Incomplete_Class $value )
private

Références $value.

Référencé par FlattenException\flattenArgs().

◆ getCode()

getCode ( )
Renvoie
int|string int most of the time (might be a string with PDOException)

Références FlattenException\$code.

◆ getFile()

getFile ( )

Références FlattenException\$file.

◆ getHeaders()

getHeaders ( )

Références FlattenException\$headers.

◆ getLine()

getLine ( )

Références FlattenException\$line.

◆ getMessage()

getMessage ( )

Références FlattenException\$message.

Référencé par HtmlErrorRenderer\renderException().

◆ getPrevious()

getPrevious ( )

Références FlattenException\$previous.

◆ getStatusCode()

getStatusCode ( )

Références FlattenException\$statusCode.

Référencé par HtmlErrorRenderer\renderException().

◆ getStatusText()

getStatusText ( )

Références FlattenException\$statusText.

Référencé par HtmlErrorRenderer\renderException().

◆ getTrace()

getTrace ( )

Références FlattenException\$trace.

◆ getTraceAsString()

getTraceAsString ( )

Références FlattenException\$traceAsString.

◆ setAsString()

setAsString ( ?string $asString )
Renvoie
$this

Références FlattenException\$asString, et $this.

◆ setClass()

setClass ( string $class )
Renvoie
$this

Références FlattenException\$class, $this, et false.

◆ setCode()

setCode ( $code )
Paramètres
int | string $code
Renvoie
$this

Références FlattenException\$code, $this, et code.

◆ setFile()

setFile ( string $file )
Renvoie
$this

Références FlattenException\$file, et $this.

◆ setHeaders()

setHeaders ( array $headers )
Renvoie
$this

Références FlattenException\$headers, et $this.

◆ setLine()

setLine ( int $line )
Renvoie
$this

Références FlattenException\$line, et $this.

◆ setMessage()

setMessage ( string $message )
Renvoie
$this

Références FlattenException\$message, et $this.

◆ setPrevious()

setPrevious ( ?self $previous )
Renvoie
$this

Références FlattenException\$previous, et $this.

◆ setStatusCode()

setStatusCode ( int $code )
Renvoie
$this

Références FlattenException\$code, et $this.

◆ setStatusText()

setStatusText ( string $statusText )
Renvoie
$this

Références FlattenException\$statusText, et $this.

◆ setTrace()

setTrace | ( | array | $trace,
 |  | ?string | $file,
 |  | ?int | $line
 | ) |  |
Renvoie
$this

Références FlattenException\$class, FlattenException\$file, FlattenException\$line, $namespace, $parts, $this, FlattenException\$trace, FlattenException\flattenArgs(), et null.

Référencé par FlattenException\setTraceFromThrowable().

◆ setTraceFromThrowable()

setTraceFromThrowable ( \Throwable $throwable )
Renvoie
$this

Références FlattenException\setTrace().

◆ toArray()

toArray ( )

Références $this, et FlattenException\getAllPrevious().

Documentation des champs

◆ $asString

$asString
private

Référencé par FlattenException\getAsString(), et FlattenException\setAsString().

◆ $class

$class
private

Référencé par FlattenException\getClass(), FlattenException\setClass(), et FlattenException\setTrace().

◆ $code

$code
private

Référencé par FlattenException\getCode(), FlattenException\setCode(), et FlattenException\setStatusCode().

◆ $file

$file
private

Référencé par FlattenException\getFile(), FlattenException\setFile(), et FlattenException\setTrace().

◆ $headers

$headers
private

Référencé par FlattenException\create(), FlattenException\createFromThrowable(), FlattenException\getHeaders(), et FlattenException\setHeaders().

◆ $line

$line
private

Référencé par FlattenException\getLine(), FlattenException\setLine(), et FlattenException\setTrace().

◆ $message

$message
private

Référencé par FlattenException\getAsString(), FlattenException\getMessage(), et FlattenException\setMessage().

◆ $previous

$previous
private

Référencé par FlattenException\createFromThrowable(), FlattenException\getPrevious(), et FlattenException\setPrevious().

◆ $statusCode

$statusCode
private

Référencé par FlattenException\create(), FlattenException\createFromThrowable(), et FlattenException\getStatusCode().

◆ $statusText

$statusText
private

Référencé par FlattenException\createFromThrowable(), FlattenException\getStatusText(), et FlattenException\setStatusText().

◆ $trace

$trace
private

Référencé par FlattenException\getTrace(), et FlattenException\setTrace().

◆ $traceAsString

$traceAsString
private

Référencé par FlattenException\getTraceAsString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FlattenException.php


Joomla CMS: Référence de la classe SilencedErrorContext

  • Symfony
  • Component
  • ErrorHandler
  • Exception
  • SilencedErrorContext
Fonctions membres publiques | Champs de données | Attributs privés
Référence de la classe SilencedErrorContext
+ Graphe d'héritage de SilencedErrorContext:

Fonctions membres publiques

__construct (int $severity, string $file, int $line, array $trace=[], int $count=1)
getSeverity ()
getFile ()
getLine ()
getTrace ()
jsonSerialize ()

Champs de données

$count = 1

Attributs privés

$severity
$file
$line
$trace

Description détaillée

Data Object that represents a Silenced Error.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $severity,
 |  | string | $file,
 |  | int | $line,
 |  | array | $trace = [],
 |  | int | $count = 1
 | ) |  |

Références SilencedErrorContext\$count, SilencedErrorContext\$file, SilencedErrorContext\$line, SilencedErrorContext\$severity, et SilencedErrorContext\$trace.

Documentation des fonctions membres

◆ getFile()

getFile ( )

Références SilencedErrorContext\$file.

◆ getLine()

getLine ( )

Références SilencedErrorContext\$line.

◆ getSeverity()

getSeverity ( )

Références SilencedErrorContext\$severity.

◆ getTrace()

getTrace ( )

Références SilencedErrorContext\$trace.

◆ jsonSerialize()

jsonSerialize ( )

Références SilencedErrorContext\$count, SilencedErrorContext\$file, SilencedErrorContext\$line, SilencedErrorContext\$severity, et SilencedErrorContext\$trace.

Documentation des champs

◆ $count

$count = 1

Référencé par SilencedErrorContext\__construct(), et SilencedErrorContext\jsonSerialize().

◆ $file

$file
private

Référencé par SilencedErrorContext\__construct(), SilencedErrorContext\getFile(), et SilencedErrorContext\jsonSerialize().

◆ $line

$line
private

Référencé par SilencedErrorContext\__construct(), SilencedErrorContext\getLine(), et SilencedErrorContext\jsonSerialize().

◆ $severity

$severity
private

Référencé par SilencedErrorContext\__construct(), SilencedErrorContext\getSeverity(), et SilencedErrorContext\jsonSerialize().

◆ $trace

$trace
private

Référencé par SilencedErrorContext\__construct(), SilencedErrorContext\getTrace(), et SilencedErrorContext\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SilencedErrorContext.php


Joomla CMS: Référence de la classe TentativeTypes

  • Symfony
  • Component
  • ErrorHandler
  • Internal
  • TentativeTypes
Champs de données
Référence de la classe TentativeTypes

Champs de données

const RETURN_TYPES

Description détaillée

This class has been generated by extract-tentative-return-types.php.

Documentation des champs

◆ RETURN_TYPES

const RETURN_TYPES
Valeur initiale :
= [
'CURLFile' => [
'getFilename' => 'string'

Référencé par DebugClassLoader\checkAnnotations().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TentativeTypes.php


Joomla CMS: Référence de la classe BufferingLogger

  • Symfony
  • Component
  • ErrorHandler
  • BufferingLogger
Fonctions membres publiques | Attributs privés
Référence de la classe BufferingLogger
+ Graphe d'héritage de BufferingLogger:
AbstractLogger LoggerInterface

Fonctions membres publiques

log ($level, $message, array $context=[])
cleanLogs ()
__sleep ()
__wakeup ()
__destruct ()
- Fonctions membres publiques hérités de AbstractLogger
emergency ($message, array $context=array())
alert ($message, array $context=array())
critical ($message, array $context=array())
error ($message, array $context=array())
warning ($message, array $context=array())
notice ($message, array $context=array())
info ($message, array $context=array())
debug ($message, array $context=array())

Attributs privés

$logs = []

Description détaillée

A buffering logger that stacks logs for later.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __destruct()

__destruct ( )

Références $context, $key, $message, $val, elseif, et null.

Documentation des fonctions membres

◆ __sleep()

__sleep ( )
Renvoie
array

◆ __wakeup()

__wakeup ( )

◆ cleanLogs()

cleanLogs ( )

Références BufferingLogger\$logs.

◆ log()

log | ( |  | $level,
 |  |  | $message,
 |  | array | $context = []
 | ) |  |

Logs with an arbitrary level.

Paramètres
mixed | $level
string | $message
mixed[] | $context
Renvoie
void
Exceptions

Implémente LoggerInterface.

Références $context, et $message.

Documentation des champs

◆ $logs

$logs = []
private

Référencé par BufferingLogger\cleanLogs().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BufferingLogger.php


Joomla CMS: Référence de la classe Debug

  • Symfony
  • Component
  • ErrorHandler
  • Debug
Fonctions membres publiques statiques
Référence de la classe Debug

Fonctions membres publiques statiques

static enable ()

Description détaillée

Registers all the debug tools.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ enable()

static enable ( )
static

Références elseif, DebugClassLoader\enable(), et ErrorHandler\register().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/symfony/error-handler/Debug.php


Joomla CMS: Référence de la classe DebugClassLoader

  • Symfony
  • Component
  • ErrorHandler
  • DebugClassLoader
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe DebugClassLoader

Fonctions membres publiques

__construct (callable $classLoader)
getClassLoader ()
findFile (string $class)
loadClass (string $class)
checkAnnotations (\ReflectionClass $refl, string $class)
checkCase (\ReflectionClass $refl, string $file, string $class)

Fonctions membres publiques statiques

static | enable ()
static | disable ()
static | checkClasses ()

Fonctions membres privées

checkClass (string $class, string $file=null)
darwinRealpath (string $real)
getOwnInterfaces (string $class, ?string $parent)
setReturnType (string $types, string $class, string $method, string $filename, ?string $parent, \ReflectionType $returnType=null)
normalizeType (string $type, string $class, ?string $parent, ?\ReflectionType $returnType)
patchReturnTypeWillChange (\ReflectionMethod $method)
patchMethod (\ReflectionMethod $method, string $returnType, string $declaringFile, string $normalizedType)
fixReturnStatements (\ReflectionMethod $method, string $returnType)
parsePhpDoc (\Reflector $reflector)

Fonctions membres privées statiques

static getUseStatements (string $file)

Attributs privés

const | SPECIAL_RETURN_TYPES
const const | BUILTIN_RETURN_TYPES
const const const | MAGIC_METHODS
const const const | $classLoader
$isFinder
$loaded = []
$patchTypes

Attributs privés statiques

static | $caseCheck
static | $checkedClasses = []
static | $final = []
static | $finalMethods = []
static | $deprecated = []
static | $internal = []
static | $internalMethods = []
static | $annotatedParameters = []
static | $darwinCache = ['/' => ['/', []]]
static | $method = []
static | $returnTypes = []
static | $methodTraits = []
static | $fileOffsets = []

Description détaillée

Autoloader checking if the class is really defined in the file found.

The ClassLoader will wrap all registered autoloaders and will throw an exception if a file is found but does not declare the class.

It can also patch classes to turn docblocks into actual return types. This behavior is controlled by the SYMFONY_PATCH_TYPE_DECLARATIONS env var, which is a url-encoded array with the follow parameters:

  • "force": any value enables deprecation notices - can be any of:
    • "phpdoc" to patch only docblock annotations
    • "2" to add all possible return types
    • "1" to add return types but only to tests/final/internal/private methods
  • "php": the target version of PHP - e.g. "7.1" doesn't generate "object" types
  • "deprecations": "1" to trigger a deprecation notice when a child class misses a return type while the parent declares an "@return" annotation

Note that patching doesn't care about any coding style so you'd better to run php-cs-fixer after, with rules "phpdoc_trim_consecutive_blank_line_separation" and "no_superfluous_phpdoc_tags" enabled typically.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
Christophe Coevoet stof@.nosp@m.notk.nosp@m..org
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Guilhem Niot guilh.nosp@m.em.n.nosp@m.iot@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( callable $classLoader )

Références DebugClassLoader\$classLoader, $dir, $i, elseif, et null.

Documentation des fonctions membres

◆ checkAnnotations()

checkAnnotations | ( | \ReflectionClass | $refl,
 |  | string | $class
 | ) |  |

Références $class, $className, $description, $doc, $i, $message, $method, DebugClassLoader\$method, $name, $type, DebugClassLoader\checkClass(), class, elseif, DebugClassLoader\fixReturnStatements(), DebugClassLoader\getOwnInterfaces(), InstalledVersions\getRootPackage(), null, DebugClassLoader\parsePhpDoc(), DebugClassLoader\patchMethod(), DebugClassLoader\patchReturnTypeWillChange(), TentativeTypes\RETURN_TYPES, et DebugClassLoader\setReturnType().

Référencé par DebugClassLoader\checkClass().

◆ checkCase()

checkCase | ( | \ReflectionClass | $refl,
 |  | string | $file,
 |  | string | $class
 | ) |  |

Références $class, $i, DebugClassLoader\darwinRealpath(), et null.

Référencé par DebugClassLoader\checkClass().

◆ checkClass()

checkClass | ( | string | $class,
 |  | string | $file = null
 | ) |  |
private

Références $class, $message, $name, DebugClassLoader\checkAnnotations(), DebugClassLoader\checkCase(), et null.

Référencé par DebugClassLoader\checkAnnotations(), et DebugClassLoader\loadClass().

◆ checkClasses()

static checkClasses ( )
static

Références $function, $i, $loader, class, et null.

◆ darwinRealpath()

darwinRealpath ( string $real )
private

realpath on MacOSX doesn't normalize the case of characters.

Références $dir, $i, et elseif.

Référencé par DebugClassLoader\checkCase().

◆ disable()

static disable ( )
static

Disables the wrapping.

Références $function.

◆ enable()

static enable ( )
static

Wraps all autoloaders.

Références $function, et class.

Référencé par Debug\enable().

◆ findFile()

findFile ( string $class )

Références $class, et null.

Référencé par DebugClassLoader\loadClass().

◆ fixReturnStatements()

fixReturnStatements | ( | \ReflectionMethod | $method,
 |  | string | $returnType
 | ) |  |
private

Référencé par DebugClassLoader\checkAnnotations(), et DebugClassLoader\patchMethod().

◆ getClassLoader()

getClassLoader ( )

Références DebugClassLoader\$classLoader.

◆ getOwnInterfaces()

getOwnInterfaces | ( | string | $class,
 |  | ?string | $parent
 | ) |  |
private

class_implements includes interfaces from the parents so we have to manually exclude them.

Renvoie
string[]

Références $class.

Référencé par DebugClassLoader\checkAnnotations().

◆ getUseStatements()

static getUseStatements ( string $file )
staticprivate

◆ loadClass()

loadClass ( string $class )

Loads the given class or interface.

Exceptions

Références $class, DebugClassLoader\$classLoader, DebugClassLoader\checkClass(), elseif, et DebugClassLoader\findFile().

◆ normalizeType()

normalizeType | ( | string | $type,
 |  | string | $class,
 |  | ?string | $parent,
 |  | ?\ReflectionType | $returnType
 | ) |  |
private

Références $type, elseif, et null.

Référencé par DebugClassLoader\setReturnType().

◆ parsePhpDoc()

parsePhpDoc ( \Reflector $reflector )
private
Paramètres
\ReflectionClass | \ReflectionMethod | \ReflectionProperty $reflector

Référencé par DebugClassLoader\checkAnnotations().

◆ patchMethod()

patchMethod | ( | \ReflectionMethod | $method,
 |  | string | $returnType,
 |  | string | $declaringFile,
 |  | string | $normalizedType
 | ) |  |
private

Utility method to add

Renvoie
annotations to the Symfony code-base where it triggers self-deprecations.

Références $c, $format, $i, DebugClassLoader\$method, $namespace, $type, elseif, DebugClassLoader\fixReturnStatements(), et null.

Référencé par DebugClassLoader\checkAnnotations().

◆ patchReturnTypeWillChange()

patchReturnTypeWillChange ( \ReflectionMethod $method )
private

Utility method to add #[ReturnTypeWillChange] where php triggers deprecations.

Références DebugClassLoader\$method, et class.

Référencé par DebugClassLoader\checkAnnotations().

◆ setReturnType()

setReturnType | ( | string | $types,
 |  | string | $class,
 |  | string | $method,
 |  | string | $filename,
 |  | ?string | $parent,
 |  | \ReflectionType | $returnType = null
 | ) |  |
private

Références $class, DebugClassLoader\$method, $n, elseif, et DebugClassLoader\normalizeType().

Référencé par DebugClassLoader\checkAnnotations().

Documentation des champs

◆ $annotatedParameters

$annotatedParameters = []
staticprivate

◆ $caseCheck

$caseCheck
staticprivate

◆ $checkedClasses

$checkedClasses = []
staticprivate

◆ $classLoader

const const const $classLoader
private
Valeur initiale :
=> 'array',
'__toString' => 'string',
'__debugInfo' => 'array',
'__serialize' => 'array',
]

Référencé par DebugClassLoader\__construct(), DebugClassLoader\getClassLoader(), et DebugClassLoader\loadClass().

◆ $darwinCache

$darwinCache = ['/' => ['/', []]]
staticprivate

◆ $deprecated

$deprecated = []
staticprivate

◆ $fileOffsets

$fileOffsets = []
staticprivate

◆ $final

$final = []
staticprivate

◆ $finalMethods

$finalMethods = []
staticprivate

◆ $internal

$internal = []
staticprivate

◆ $internalMethods

$internalMethods = []
staticprivate

◆ $isFinder

$isFinder
private

◆ $loaded

$loaded = []
private

◆ $method

$method = []
staticprivate

Référencé par DebugClassLoader\checkAnnotations(), DebugClassLoader\patchMethod(), DebugClassLoader\patchReturnTypeWillChange(), et DebugClassLoader\setReturnType().

◆ $methodTraits

$methodTraits = []
staticprivate

◆ $patchTypes

$patchTypes
private

◆ $returnTypes

$returnTypes = []
staticprivate

◆ BUILTIN_RETURN_TYPES

const const BUILTIN_RETURN_TYPES
private
Valeur initiale :
= [
'void' => true

◆ MAGIC_METHODS

const const const MAGIC_METHODS
private
Valeur initiale :
= [
'__isset' => 'bool'

◆ SPECIAL_RETURN_TYPES

const SPECIAL_RETURN_TYPES
private
Valeur initiale :
= [
'void' => 'void'
La documentation de cette classe a été générée à partir du fichier suivant :
  • DebugClassLoader.php


Joomla CMS: Référence de la classe ErrorHandler

  • Symfony
  • Component
  • ErrorHandler
  • ErrorHandler
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe ErrorHandler

Fonctions membres publiques

__construct (BufferingLogger $bootstrappingLogger=null, bool $debug=false)
setDefaultLogger (LoggerInterface $logger, $levels=\E_ALL, bool $replace=false)
setLoggers (array $loggers)
setExceptionHandler (?callable $handler)
throwAt (int $levels, bool $replace=false)
scopeAt (int $levels, bool $replace=false)
traceAt (int $levels, bool $replace=false)
screamAt (int $levels, bool $replace=false)
handleError (int $type, string $message, string $file, int $line)
handleException (\Throwable $exception)

Fonctions membres publiques statiques

static | register (self $handler=null, bool $replace=true)
static | call (callable $function,... $arguments)
static | handleFatalError (array $error=null)

Champs de données

E_USER_DEPRECATED
E_NOTICE => [null
E_USER_NOTICE => [null
E_STRICT => [null
E_WARNING => [null
E_USER_WARNING => [null
E_COMPILE_WARNING => [null
E_CORE_WARNING => [null
E_USER_ERROR => [null
E_RECOVERABLE_ERROR => [null
E_COMPILE_ERROR => [null
E_PARSE => [null
E_ERROR => [null
E_CORE_ERROR => [null

Fonctions membres protégées

getErrorEnhancers ()

Fonctions membres privées

reRegister (int $prev)
renderException (\Throwable $exception)
cleanTrace (array $backtrace, int $type, string &$file, int &$line, bool $throw)
parseAnonymousClass (string $message)

Attributs privés

$levels
$loggers
$thrownErrors = 0x1FFF
$scopedErrors = 0x1FFF
$tracedErrors = 0x77FB
$screamedErrors = 0x55
$loggedErrors = 0
$configureException
$debug
$isRecursive = 0
$isRoot = false
$exceptionHandler
$bootstrappingLogger

Attributs privés statiques

static | $reservedMemory
static | $toStringException
static | $silencedErrorCache = []
static | $silencedErrorCount = 0
static | $exitCode = 0

Description détaillée

A generic ErrorHandler for the PHP engine.

Provides five bit fields that control how errors are handled:

  • thrownErrors: errors thrown as
  • loggedErrors: logged errors, when not -silenced
  • scopedErrors: errors thrown or logged with their local context
  • tracedErrors: errors logged with their stack trace
  • screamedErrors: never -silenced errors

Each error level can be logged by a dedicated PSR-3 logger object. Screaming only applies to logging. Throwing takes precedence over logging. Uncaught exceptions are logged as E_ERROR. E_DEPRECATED and E_USER_DEPRECATED levels never throw. E_RECOVERABLE_ERROR and E_USER_ERROR levels always throw. Non catchable errors that can be detected at shutdown time are logged when the scream bit field allows so. As errors have a performance cost, repeated errors are all logged, so that the developer can see them and weight them as more important to fix than others of the same level.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | BufferingLogger | $bootstrappingLogger = null,
 |  | bool | $debug = false
 | ) |  |

Références ErrorHandler\$bootstrappingLogger, ErrorHandler\$debug, class, null, et ErrorHandler\setDefaultLogger().

Documentation des fonctions membres

◆ call()

static call | ( | callable | $function,
 |  |  | $arguments
 | ) |  |
static

Calls a function and turns any PHP error into .

Renvoie
mixed What $function(...$arguments) returns
Exceptions

Références $function, $message, et $type.

◆ cleanTrace()

cleanTrace | ( | array | $backtrace,
 |  | int | $type,
 |  | string & | $file,
 |  | int & | $line,
 |  | bool | $throw
 | ) |  |
private

Cleans the trace by removing function arguments and the frames added by the error handler and DebugClassLoader.

Références $i, $type, class, et null.

Référencé par ErrorHandler\handleError().

◆ getErrorEnhancers()

getErrorEnhancers ( )
protected

Override this method if you want to define more error enhancers.

Renvoie
ErrorEnhancerInterface[]

Référencé par ErrorHandler\handleException().

◆ handleError()

handleError | ( | int | $type,
 |  | string | $message,
 |  | string | $file,
 |  | int | $line
 | ) |  |

Handles errors by filtering then logging them according to the configured bit fields.

Renvoie
bool Returns false when no handling happens so that the PHP engine can handle the error itself
Exceptions

Références ErrorHandler\$configureException, $context, $i, $id, $message, ErrorHandler\$screamedErrors, $type, ErrorHandler\cleanTrace(), LogLevel\DEBUG, ErrorHandler\E_RECOVERABLE_ERROR, ErrorHandler\E_USER_DEPRECATED, ErrorHandler\E_USER_ERROR, elseif, ErrorHandler\handleException(), null, et ErrorHandler\parseAnonymousClass().

◆ handleException()

handleException ( \Throwable $exception )

Handles an exception by logging then forwarding it to another handler.

Références ErrorHandler\$exceptionHandler, ErrorHandler\$loggedErrors, $message, $this, $type, elseif, ErrorHandler\getErrorEnhancers(), ThrowableUtils\getSeverity(), null, et ErrorHandler\parseAnonymousClass().

Référencé par ErrorHandler\handleError().

◆ handleFatalError()

static handleFatalError ( array $error = null )
static

Shutdown registered function for handling PHP fatal errors.

Paramètres
array | null $error An array as returned by error_get_last()

Références ErrorHandler\$exitCode, ErrorHandler\E_COMPILE_ERROR, ErrorHandler\E_CORE_ERROR, ErrorHandler\E_ERROR, ErrorHandler\E_PARSE, elseif, et null.

◆ parseAnonymousClass()

parseAnonymousClass ( string $message )
private

Parse the error message by removing the anonymous class notation and using the parent class instead if possible.

Références $message.

Référencé par ErrorHandler\handleError(), et ErrorHandler\handleException().

◆ register()

static register | ( | self | $handler = null,
 |  | bool | $replace = true
 | ) |  |
static

Registers the error handler.

Références elseif, et null.

Référencé par Debug\enable().

◆ renderException()

renderException ( \Throwable $exception )
private

Renders the given exception.

As this method is mainly called during boot where nothing is yet available, the output is always either HTML or CLI depending where PHP runs.

Références $name, $renderer, et $value.

◆ reRegister()

reRegister ( int $prev )
private

Re-registers as a PHP error handler if levels changed.

Références $this, et null.

Référencé par ErrorHandler\setLoggers(), et ErrorHandler\throwAt().

◆ scopeAt()

scopeAt | ( | int | $levels,
 |  | bool | $replace = false
 | ) |  |

Sets the PHP error levels for which local variables are preserved.

Paramètres
int | $levels | A bit field of E_* constants for scoped errors
bool | $replace | Replace or amend the previous value
Renvoie
int The previous value

Références ErrorHandler\$levels, et ErrorHandler\$scopedErrors.

◆ screamAt()

screamAt | ( | int | $levels,
 |  | bool | $replace = false
 | ) |  |

Sets the error levels where the -operator is ignored.

Paramètres
int | $levels | A bit field of E_* constants for screamed errors
bool | $replace | Replace or amend the previous value
Renvoie
int The previous value

Références ErrorHandler\$levels, et ErrorHandler\$screamedErrors.

◆ setDefaultLogger()

setDefaultLogger | ( | LoggerInterface | $logger,
 |  |  | $levels = \E_ALL,
 |  | bool | $replace = false
 | ) |  |

Sets a logger to non assigned errors levels.

Paramètres
LoggerInterface | $logger | A PSR-3 logger to put as default for the given levels
array | int | null | $levels | An array map of E_* to LogLevel::* or an integer bit field of E_* constants
bool | $replace | Whether to replace or not any existing logger

Références ErrorHandler\$levels, ErrorHandler\$loggers, $type, null, et ErrorHandler\setLoggers().

Référencé par ErrorHandler\__construct().

◆ setExceptionHandler()

setExceptionHandler ( ?callable $handler )

Sets a user exception handler.

Paramètres
\Throwable callable(,$e,)|null $handler
Renvoie
callable|null The previous exception handler

Références ErrorHandler\$exceptionHandler.

◆ setLoggers()

setLoggers ( array $loggers )

Sets a logger for each error level.

Paramètres
array $loggers Error levels to [LoggerInterface|null, LogLevel::*] map
Renvoie
array The previous map
Exceptions

Références ErrorHandler\$loggedErrors, ErrorHandler\$loggers, $type, elseif, ThrowableUtils\getSeverity(), null, et ErrorHandler\reRegister().

Référencé par ErrorHandler\setDefaultLogger().

◆ throwAt()

throwAt | ( | int | $levels,
 |  | bool | $replace = false
 | ) |  |

Sets the PHP error levels that throw an exception when a PHP error occurs.

Paramètres
int | $levels | A bit field of E_* constants for thrown errors
bool | $replace | Replace or amend the previous value
Renvoie
int The previous value

Références ErrorHandler\$levels, ErrorHandler\$thrownErrors, ErrorHandler\E_RECOVERABLE_ERROR, ErrorHandler\E_USER_ERROR, et ErrorHandler\reRegister().

◆ traceAt()

traceAt | ( | int | $levels,
 |  | bool | $replace = false
 | ) |  |

Sets the PHP error levels for which the stack trace is preserved.

Paramètres
int | $levels | A bit field of E_* constants for traced errors
bool | $replace | Replace or amend the previous value
Renvoie
int The previous value

Références ErrorHandler\$levels, et ErrorHandler\$tracedErrors.

Documentation des champs

◆ $bootstrappingLogger

$bootstrappingLogger
private

Référencé par ErrorHandler\__construct().

◆ $configureException

$configureException
private

Référencé par ErrorHandler\handleError().

◆ $debug

$debug
private

Référencé par ErrorHandler\__construct().

◆ $exceptionHandler

$exceptionHandler
private

Référencé par ErrorHandler\handleException(), et ErrorHandler\setExceptionHandler().

◆ $exitCode

$exitCode = 0
staticprivate

Référencé par ErrorHandler\handleFatalError().

◆ $isRecursive

$isRecursive = 0
private

◆ $isRoot

$isRoot = false
private

◆ $levels

$levels
private
Valeur initiale :
= [
\E_DEPRECATED => 'Deprecated'

Référencé par ErrorHandler\scopeAt(), ErrorHandler\screamAt(), ErrorHandler\setDefaultLogger(), ErrorHandler\throwAt(), et ErrorHandler\traceAt().

◆ $loggedErrors

$loggedErrors = 0
private

Référencé par ErrorHandler\handleException(), et ErrorHandler\setLoggers().

◆ $loggers

$loggers
private
Valeur initiale :
= [
\E_DEPRECATED => [null, LogLevel::INFO]

Référencé par ErrorHandler\setDefaultLogger(), et ErrorHandler\setLoggers().

◆ $reservedMemory

$reservedMemory
staticprivate

◆ $scopedErrors

$scopedErrors = 0x1FFF
private

Référencé par ErrorHandler\scopeAt().

◆ $screamedErrors

$screamedErrors = 0x55
private

Référencé par ErrorHandler\handleError(), et ErrorHandler\screamAt().

◆ $silencedErrorCache

$silencedErrorCache = []
staticprivate

◆ $silencedErrorCount

$silencedErrorCount = 0
staticprivate

◆ $thrownErrors

$thrownErrors = 0x1FFF
private

Référencé par ErrorHandler\throwAt().

◆ $toStringException

$toStringException
staticprivate

◆ $tracedErrors

$tracedErrors = 0x77FB
private

Référencé par ErrorHandler\traceAt().

◆ E_COMPILE_ERROR

E_COMPILE_ERROR => [null

Référencé par ErrorHandler\handleFatalError().

◆ E_COMPILE_WARNING

E_COMPILE_WARNING => [null

◆ E_CORE_ERROR

E_CORE_ERROR => [null

Référencé par ErrorHandler\handleFatalError().

◆ E_CORE_WARNING

E_CORE_WARNING => [null

◆ E_ERROR

E_ERROR => [null

Référencé par ErrorHandler\handleFatalError().

◆ E_NOTICE

E_NOTICE => [null

◆ E_PARSE

E_PARSE => [null

Référencé par ErrorHandler\handleFatalError().

◆ E_RECOVERABLE_ERROR

E_RECOVERABLE_ERROR => [null

Référencé par ErrorHandler\handleError(), et ErrorHandler\throwAt().

◆ E_STRICT

E_STRICT => [null

◆ E_USER_DEPRECATED

E_USER_DEPRECATED
Valeur initiale :
=> 'User Deprecated',
\E_NOTICE => 'Notice',
\E_USER_NOTICE => 'User Notice',
\E_STRICT => 'Runtime Notice',
\E_WARNING => 'Warning',
\E_USER_WARNING => 'User Warning',
\E_COMPILE_WARNING => 'Compile Warning',
\E_CORE_WARNING => 'Core Warning',
\E_USER_ERROR => 'User Error',
\E_RECOVERABLE_ERROR => 'Catchable Fatal Error',
\E_COMPILE_ERROR => 'Compile Error',
\E_PARSE => 'Parse Error',
\E_ERROR => 'Error',
\E_CORE_ERROR => 'Core Error',
]

Référencé par ErrorHandler\handleError().

◆ E_USER_ERROR

E_USER_ERROR => [null

Référencé par ErrorHandler\handleError(), et ErrorHandler\throwAt().

◆ E_USER_NOTICE

E_USER_NOTICE => [null

◆ E_USER_WARNING

E_USER_WARNING => [null

◆ E_WARNING

E_WARNING => [null
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/error-handler/ErrorHandler.php


Joomla CMS: Référence de la classe ThrowableUtils

  • Symfony
  • Component
  • ErrorHandler
  • ThrowableUtils
Fonctions membres publiques statiques
Référence de la classe ThrowableUtils

Fonctions membres publiques statiques

static getSeverity ($throwable)

Documentation des fonctions membres

◆ getSeverity()

static getSeverity ( $throwable )
static
Paramètres
SilencedErrorContext|

Référencé par ErrorHandler\handleException(), et ErrorHandler\setLoggers().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ThrowableUtils.php


Joomla CMS: Référence de la classe Adapter

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • Adapter
Fonctions membres publiques | Attributs privés
Référence de la classe Adapter
+ Graphe d'héritage de Adapter:
AdapterInterface

Fonctions membres publiques

__construct (array $config=[])
getConnection ()
getEntryManager ()
createQuery (string $dn, string $query, array $options=[])
escape (string $subject, string $ignore='', int $flags=0)

Attributs privés

$config
$connection
$entryManager

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $config = [] )

Références Adapter\$config.

Documentation des fonctions membres

◆ createQuery()

createQuery | ( | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

{Creates a new Query.

Renvoie
QueryInterface
}

Implémente AdapterInterface.

Références $options, $query, et Adapter\getConnection().

◆ escape()

escape | ( | string | $subject,
 |  | string | $ignore = '',
 |  | int | $flags = 0
 | ) |  |

{Escape a string for use in an LDAP filter or DN.

Renvoie
string
}

Implémente AdapterInterface.

Références $subject, et $value.

◆ getConnection()

getConnection ( )

{Returns the current connection.

Renvoie
ConnectionInterface
}

Implémente AdapterInterface.

Références Adapter\$connection, et null.

Référencé par Adapter\createQuery(), et Adapter\getEntryManager().

◆ getEntryManager()

getEntryManager ( )

{Fetches the entry manager instance.

Renvoie
EntryManagerInterface
}

Implémente AdapterInterface.

Références Adapter\$entryManager, Adapter\getConnection(), et null.

Documentation des champs

◆ $config

$config
private

Référencé par Adapter\__construct().

◆ $connection

$connection
private

Référencé par Adapter\getConnection().

◆ $entryManager

$entryManager
private

Référencé par Adapter\getEntryManager().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/ldap/Adapter/ExtLdap/Adapter.php


Joomla CMS: Référence de la classe Collection

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • Collection
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Collection
+ Graphe d'héritage de Collection:
CollectionInterface

Fonctions membres publiques

__construct (Connection $connection, Query $search)
toArray ()
count ()
getIterator ()
offsetExists ($offset)
offsetGet ($offset)
offsetSet ($offset, $value)
offsetUnset ($offset)

Fonctions membres privées

getSingleEntry ($con, $current)
cleanupAttributes (array $entry)

Attributs privés

$connection
$search
$entries

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Connection | $connection,
 |  | Query | $search
 | ) |  |

Références Collection\$connection, et Collection\$search.

Documentation des fonctions membres

◆ cleanupAttributes()

cleanupAttributes ( array $entry )
private

Références $attributes, $value, et null.

Référencé par Collection\getSingleEntry().

◆ count()

count ( )
Renvoie
int

Références $count, et Collection\$search.

Référencé par Collection\getIterator().

◆ getIterator()

getIterator ( )
Renvoie
<int, Entry>

Références Collection\$search, Collection\count(), et Collection\getSingleEntry().

Référencé par Collection\toArray().

◆ getSingleEntry()

getSingleEntry | ( | $con,
 |  | $current
 | ) |
private

Références $attributes, et Collection\cleanupAttributes().

Référencé par Collection\getIterator().

◆ offsetExists()

offsetExists ( $offset )
Renvoie
bool

Références Joomla\Database\Query\$offset, et Collection\toArray().

◆ offsetGet()

offsetGet ( $offset )
Renvoie
Entry|null

Références Joomla\Database\Query\$offset, null, et Collection\toArray().

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |
Renvoie
void

Références Joomla\Database\Query\$offset, $value, et Collection\toArray().

◆ offsetUnset()

offsetUnset ( $offset )
Renvoie
void

Références Joomla\Database\Query\$offset, et Collection\toArray().

◆ toArray()

toArray ( )

{

Renvoie
list<Entry>
}

Implémente CollectionInterface.

Références Collection\$entries, Collection\getIterator(), et null.

Référencé par Collection\offsetExists(), Collection\offsetGet(), Collection\offsetSet(), et Collection\offsetUnset().

Documentation des champs

◆ $connection

$connection
private

Référencé par Collection\__construct().

◆ $entries

$entries
private

Référencé par Collection\toArray().

◆ $search

$search
private

Référencé par Collection\__construct(), Collection\count(), et Collection\getIterator().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/ldap/Adapter/ExtLdap/Collection.php


Joomla CMS: Référence de la classe Connection

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • Connection
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe Connection
+ Graphe d'héritage de Connection:
AbstractConnection ConnectionInterface

Fonctions membres publiques

__sleep ()
__wakeup ()
__destruct ()
isBound ()
bind (string $dn=null, string $password=null)
getResource ()
setOption (string $name, $value)
getOption (string $name)
- Fonctions membres publiques hérités de AbstractConnection
__construct (array $config=[])

Fonctions membres protégées

configureOptions (OptionsResolver $resolver)
- Fonctions membres protégées hérités de AbstractConnection
configureOptions (OptionsResolver $resolver)

Fonctions membres privées

connect ()
disconnect ()

Attributs privés

const | LDAP_INVALID_CREDENTIALS = 0x31
const | LDAP_TIMEOUT = 0x55
const | LDAP_ALREADY_EXISTS = 0x44
$bound = false
$connection

Membres hérités additionnels

- Attributs protégés hérités de AbstractConnection
$config

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __destruct()

__destruct ( )

Références Connection\disconnect().

Documentation des fonctions membres

◆ __sleep()

__sleep ( )
Renvoie
array

◆ __wakeup()

__wakeup ( )

◆ bind()

bind | ( | string | $dn = null,
 |  | string | $password = null
 | ) |  |

{Binds the connection against a user's DN and password.

Exceptions
AlreadyExistsException | When the connection can't be created because of an LDAP_ALREADY_EXISTS error
ConnectionTimeoutException | When the connection can't be created because of an LDAP_TIMEOUT error
InvalidCredentialsException | When the connection can't be created because of an LDAP_INVALID_CREDENTIALS error
}

Paramètres
string $password WARNING: When the LDAP server allows unauthenticated binds, a blank $password will always be valid

Implémente ConnectionInterface.

Références $password, et Connection\connect().

◆ configureOptions()

configureOptions ( OptionsResolver $resolver )
protected

Références $options, class, OptionsResolver\setAllowedTypes(), et OptionsResolver\setDefault().

◆ connect()

connect ( )
private

Références $name, $value, et Connection\setOption().

Référencé par Connection\bind().

◆ disconnect()

disconnect ( )
private

Références null.

Référencé par Connection\__destruct().

◆ getOption()

getOption ( string $name )

Références $name, et ConnectionOptions\getOption().

◆ getResource()

getResource ( )
Renvoie
resource|LDAPConnection

Références Connection\$connection.

◆ isBound()

isBound ( )

{Checks whether the connection was already bound or not.

Renvoie
bool
}

Implémente ConnectionInterface.

Références Connection\$bound.

◆ setOption()

setOption | ( | string | $name,
 |  |  | $value
 | ) |  |

Références $name, $value, et ConnectionOptions\getOption().

Référencé par Connection\connect().

Documentation des champs

◆ $bound

$bound = false
private

Référencé par Connection\isBound().

◆ $connection

$connection
private

Référencé par Connection\getResource().

◆ LDAP_ALREADY_EXISTS

const LDAP_ALREADY_EXISTS = 0x44
private

◆ LDAP_INVALID_CREDENTIALS

const LDAP_INVALID_CREDENTIALS = 0x31
private

◆ LDAP_TIMEOUT

const LDAP_TIMEOUT = 0x55
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ldap/Adapter/ExtLdap/Connection.php


Joomla CMS: Référence de la classe ConnectionOptions

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • ConnectionOptions
Fonctions membres publiques statiques | Champs de données
Référence de la classe ConnectionOptions

Fonctions membres publiques statiques

static | getOptionName (string $name)
static | getOption (string $name)
static | isOption (string $name)

Champs de données

const | API_INFO = 0x00
const | DEREF = 0x02
const | SIZELIMIT = 0x03
const | TIMELIMIT = 0x04
const | REFERRALS = 0x08
const | RESTART = 0x09
const | PROTOCOL_VERSION = 0x11
const | SERVER_CONTROLS = 0x12
const | CLIENT_CONTROLS = 0x13
const | API_FEATURE_INFO = 0x15
const | HOST_NAME = 0x30
const | ERROR_NUMBER = 0x31
const | ERROR_STRING = 0x32
const | MATCHED_DN = 0x33
const | DEBUG_LEVEL = 0x5001
const | TIMEOUT = 0x5002
const | NETWORK_TIMEOUT = 0x5005
const | X_TLS_CACERTDIR = 0x6003
const | X_TLS_CERTFILE = 0x6004
const | X_TLS_CRL_ALL = 0x02
const | X_TLS_CRL_NONE = 0x00
const | X_TLS_CRL_PEER = 0x01
const | X_TLS_KEYFILE = 0x6005
const | X_TLS_REQUIRE_CERT = 0x6006
const | X_TLS_PROTOCOL_MIN = 0x6007
const | X_TLS_CIPHER_SUITE = 0x6008
const | X_TLS_RANDOM_FILE = 0x6009
const | X_TLS_CRLFILE = 0x6010
const | X_TLS_PACKAGE = 0x6011
const | X_TLS_CRLCHECK = 0x600B
const | X_TLS_DHFILE = 0x600E
const | X_SASL_MECH = 0x6100
const | X_SASL_REALM = 0x6101
const | X_SASL_AUTHCID = 0x6102
const | X_SASL_AUTHZID = 0x6103
const | X_KEEPALIVE_IDLE = 0x6300
const | X_KEEPALIVE_PROBES = 0x6301
const | X_KEEPALIVE_INTERVAL = 0x6302

Description détaillée

A class representing the Ldap extension's options, which can be used with ldap_set_option or ldap_get_option.

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des fonctions membres

◆ getOption()

static getOption ( string $name )
static

Fetches an option's corresponding constant value from an option name. The option name can either be in snake or camel case.

Exceptions
LdapException

Références $name.

Référencé par Connection\getOption(), et Connection\setOption().

◆ getOptionName()

static getOptionName ( string $name )
static

Références $name, et class.

◆ isOption()

static isOption ( string $name )
static

Références $name.

Documentation des champs

◆ API_FEATURE_INFO

const API_FEATURE_INFO = 0x15

◆ API_INFO

const API_INFO = 0x00

◆ CLIENT_CONTROLS

const CLIENT_CONTROLS = 0x13

◆ DEBUG_LEVEL

const DEBUG_LEVEL = 0x5001

◆ DEREF

const DEREF = 0x02

◆ ERROR_NUMBER

const ERROR_NUMBER = 0x31

◆ ERROR_STRING

const ERROR_STRING = 0x32

◆ HOST_NAME

const HOST_NAME = 0x30

◆ MATCHED_DN

const MATCHED_DN = 0x33

◆ NETWORK_TIMEOUT

const NETWORK_TIMEOUT = 0x5005

◆ PROTOCOL_VERSION

const PROTOCOL_VERSION = 0x11

◆ REFERRALS

const REFERRALS = 0x08

◆ RESTART

const RESTART = 0x09

◆ SERVER_CONTROLS

const SERVER_CONTROLS = 0x12

◆ SIZELIMIT

const SIZELIMIT = 0x03

◆ TIMELIMIT

const TIMELIMIT = 0x04

◆ TIMEOUT

const TIMEOUT = 0x5002

◆ X_KEEPALIVE_IDLE

const X_KEEPALIVE_IDLE = 0x6300

◆ X_KEEPALIVE_INTERVAL

const X_KEEPALIVE_INTERVAL = 0x6302

◆ X_KEEPALIVE_PROBES

const X_KEEPALIVE_PROBES = 0x6301

◆ X_SASL_AUTHCID

const X_SASL_AUTHCID = 0x6102

◆ X_SASL_AUTHZID

const X_SASL_AUTHZID = 0x6103

◆ X_SASL_MECH

const X_SASL_MECH = 0x6100

◆ X_SASL_REALM

const X_SASL_REALM = 0x6101

◆ X_TLS_CACERTDIR

const X_TLS_CACERTDIR = 0x6003

◆ X_TLS_CERTFILE

const X_TLS_CERTFILE = 0x6004

◆ X_TLS_CIPHER_SUITE

const X_TLS_CIPHER_SUITE = 0x6008

◆ X_TLS_CRL_ALL

const X_TLS_CRL_ALL = 0x02

◆ X_TLS_CRL_NONE

const X_TLS_CRL_NONE = 0x00

◆ X_TLS_CRL_PEER

const X_TLS_CRL_PEER = 0x01

◆ X_TLS_CRLCHECK

const X_TLS_CRLCHECK = 0x600B

◆ X_TLS_CRLFILE

const X_TLS_CRLFILE = 0x6010

◆ X_TLS_DHFILE

const X_TLS_DHFILE = 0x600E

◆ X_TLS_KEYFILE

const X_TLS_KEYFILE = 0x6005

◆ X_TLS_PACKAGE

const X_TLS_PACKAGE = 0x6011

◆ X_TLS_PROTOCOL_MIN

const X_TLS_PROTOCOL_MIN = 0x6007

◆ X_TLS_RANDOM_FILE

const X_TLS_RANDOM_FILE = 0x6009

◆ X_TLS_REQUIRE_CERT

const X_TLS_REQUIRE_CERT = 0x6006
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionOptions.php


Joomla CMS: Référence de la classe EntryManager

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • EntryManager
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe EntryManager
+ Graphe d'héritage de EntryManager:
EntryManagerInterface

Fonctions membres publiques

__construct (Connection $connection)
add (Entry $entry)
update (Entry $entry)
remove (Entry $entry)
addAttributeValues (Entry $entry, string $attribute, array $values)
removeAttributeValues (Entry $entry, string $attribute, array $values)
rename (Entry $entry, string $newRdn, bool $removeOldRdn=true)
move (Entry $entry, string $newParent)
applyOperations (string $dn, iterable $operations)

Fonctions membres privées

getConnectionResource ()
parseRdnFromEntry (Entry $entry)

Attributs privés

$connection

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Bob van de Vijver bobva.nosp@m.ndev.nosp@m.ijver.nosp@m.@hot.nosp@m.mail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( Connection $connection )

Références EntryManager\$connection.

Documentation des fonctions membres

◆ add()

add ( Entry $entry )

{Adds a new entry in the Ldap server.

Exceptions
NotBoundException
LdapException
}

Implémente EntryManagerInterface.

Références $this, Entry\getAttributes(), EntryManager\getConnectionResource(), et Entry\getDn().

◆ addAttributeValues()

addAttributeValues | ( | Entry | $entry,
 |  | string | $attribute,
 |  | array | $values
 | ) |  |

Adds values to an entry's multi-valued attribute from the LDAP server.

Exceptions
NotBoundException
LdapException

Références EntryManager\getConnectionResource(), et Entry\getDn().

◆ applyOperations()

applyOperations | ( | string | $dn,
 |  | iterable | $operations
 | ) |  |
Paramètres
iterable<int,UpdateOperation> $operations An array or iterable of UpdateOperation instances
Exceptions
UpdateOperationException in case of an error

Références EntryManager\getConnectionResource().

◆ getConnectionResource()

getConnectionResource ( )
private

Get the connection resource, but first check if the connection is bound.

Référencé par EntryManager\add(), EntryManager\addAttributeValues(), EntryManager\applyOperations(), EntryManager\move(), EntryManager\remove(), EntryManager\removeAttributeValues(), EntryManager\rename(), et EntryManager\update().

◆ move()

move | ( | Entry | $entry,
 |  | string | $newParent
 | ) |  |

Moves an entry on the Ldap server.

Exceptions
NotBoundException | if the connection has not been previously bound
LdapException | if an error is thrown during the rename operation

Implémente EntryManagerInterface.

Références EntryManager\getConnectionResource(), Entry\getDn(), et EntryManager\parseRdnFromEntry().

◆ parseRdnFromEntry()

parseRdnFromEntry ( Entry $entry )
private

Références Entry\getDn().

Référencé par EntryManager\move().

◆ remove()

remove ( Entry $entry )

{Removes an entry from the Ldap server.

Exceptions
NotBoundException
LdapException
}

Implémente EntryManagerInterface.

Références EntryManager\getConnectionResource().

◆ removeAttributeValues()

removeAttributeValues | ( | Entry | $entry,
 |  | string | $attribute,
 |  | array | $values
 | ) |  |

Removes values from an entry's multi-valued attribute from the LDAP server.

Exceptions
NotBoundException
LdapException

Références EntryManager\getConnectionResource(), et Entry\getDn().

◆ rename()

rename | ( | Entry | $entry,
 |  | string | $newRdn,
 |  | bool | $removeOldRdn = true
 | ) |  |

{Renames an entry on the Ldap server.

Exceptions
NotBoundException
LdapException
}

Implémente EntryManagerInterface.

Références EntryManager\getConnectionResource(), et Entry\getDn().

◆ update()

update ( Entry $entry )

{Updates an entry from the Ldap server.

Exceptions
NotBoundException
LdapException
}

Implémente EntryManagerInterface.

Références Entry\getAttributes(), EntryManager\getConnectionResource(), et Entry\getDn().

Documentation des champs

◆ $connection

$connection
private

Référencé par EntryManager\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EntryManager.php


Joomla CMS: Référence de la classe Query

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • Query
Fonctions membres publiques | Champs de données | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe Query
+ Graphe d'héritage de Query:
AbstractQuery QueryInterface

Fonctions membres publiques

__construct (Connection $connection, string $dn, string $query, array $options=[])
__sleep ()
__wakeup ()
__destruct ()
execute ()
getResource (int $idx=0)
getResources ()
- Fonctions membres publiques hérités de AbstractQuery
__construct (ConnectionInterface $connection, string $dn, string $query, array $options=[])

Champs de données

const | PAGINATION_OID = '1.2.840.113556.1.4.319'
- Champs de données hérités de QueryInterface
const | DEREF_NEVER = 0x00
const | DEREF_SEARCHING = 0x01
const | DEREF_FINDING = 0x02
const | DEREF_ALWAYS = 0x03
const | SCOPE_BASE = 'base'
const | SCOPE_ONE = 'one'
const | SCOPE_SUB = 'sub'

Attributs protégés

$connection
- Attributs protégés hérités de AbstractQuery
$connection
$dn
$query
$options

Fonctions membres privées

resetPagination ()
controlPagedResult ($con, int $pageSize, bool $critical, string $cookie)
controlPagedResultResponse ($con, $result, string $cookie='')
callSearchFunction ($con, callable $func, int $sizeLimit)

Attributs privés

$results
$serverctrls = []

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Bob van de Vijver bobva.nosp@m.ndev.nosp@m.ijver.nosp@m.@hot.nosp@m.mail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Connection | $connection,
 |  | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

Références Query\$connection, AbstractQuery\$dn, AbstractQuery\$options, AbstractQuery\$query, et Symfony\Contracts\Service\__construct().

◆ __destruct()

__destruct ( )

Références $result, et null.

Documentation des fonctions membres

◆ __sleep()

__sleep ( )
Renvoie
array

◆ __wakeup()

__wakeup ( )

◆ callSearchFunction()

callSearchFunction | ( |  | $con,
 |  | callable | $func,
 |  | int | $sizeLimit
 | ) |  |
private

Calls actual LDAP search function with the prepared options and parameters.

Paramètres
resource | LDAPConnection $con
Renvoie
resource|Result|false

Référencé par Query\execute().

◆ controlPagedResult()

controlPagedResult | ( |  | $con,
 |  | int | $pageSize,
 |  | bool | $critical,
 |  | string | $cookie
 | ) |  |
private

Sets LDAP pagination controls.

Paramètres
resource | LDAPConnection $con

Référencé par Query\execute(), et Query\resetPagination().

◆ controlPagedResultResponse()

controlPagedResultResponse | ( |  | $con,
 |  |  | $result,
 |  | string | $cookie = ''
 | ) |  |
private

Retrieve LDAP pagination cookie.

Paramètres
resource | LDAPConnection | $con
resource | Result | $result

Références $result.

Référencé par Query\execute().

◆ execute()

execute ( )

{Executes a query and returns the list of Ldap entries.

Renvoie
CollectionInterface
Exceptions
NotBoundException
LdapException
}

Implémente QueryInterface.

Références $this, Query\callSearchFunction(), Query\controlPagedResult(), Query\controlPagedResultResponse(), elseif, null, et Query\resetPagination().

◆ getResource()

getResource ( int $idx = 0 )

Returns an LDAP search resource. If this query resulted in multiple searches, only the first page will be returned.

Renvoie
resource|Result|null

Références null.

◆ getResources()

getResources ( )

Returns all LDAP search resources.

Renvoie
resource[]|Result[]

Références Query\$results.

◆ resetPagination()

resetPagination ( )
private

Resets pagination on the current connection.

Références $info, et Query\controlPagedResult().

Référencé par Query\execute().

Documentation des champs

◆ $connection

$connection
protected

Référencé par Query\__construct().

◆ $results

$results
private

Référencé par Query\getResources().

◆ $serverctrls

$serverctrls = []
private

◆ PAGINATION_OID

const PAGINATION_OID = '1.2.840.113556.1.4.319'
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/ldap/Adapter/ExtLdap/Query.php


Joomla CMS: Référence de la classe UpdateOperation

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ExtLdap
  • UpdateOperation
Fonctions membres publiques | Attributs privés
Référence de la classe UpdateOperation

Fonctions membres publiques

__construct (int $operationType, string $attribute, ?array $values)
toArray ()

Attributs privés

$operationType
$values
$attribute
const VALID_OPERATION_TYPES

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $operationType,
 |  | string | $attribute,
 |  | ?array | $values
 | ) |  |
Paramètres
int | $operationType | An LDAP_MODIFY_BATCH_* constant
string | $attribute | The attribute to batch modify on
Exceptions
UpdateOperationException on consistency errors during construction

Références UpdateOperation\$attribute, UpdateOperation\$operationType, UpdateOperation\$values, et null.

Documentation des fonctions membres

◆ toArray()

toArray ( )

Références UpdateOperation\$attribute, UpdateOperation\$operationType, et UpdateOperation\$values.

Documentation des champs

◆ $attribute

$attribute
private

Référencé par UpdateOperation\__construct(), et UpdateOperation\toArray().

◆ $operationType

$operationType
private

Référencé par UpdateOperation\__construct(), et UpdateOperation\toArray().

◆ $values

$values
private

Référencé par UpdateOperation\__construct(), et UpdateOperation\toArray().

◆ VALID_OPERATION_TYPES

const VALID_OPERATION_TYPES
private
Valeur initiale :
= [
\LDAP_MODIFY_BATCH_ADD,
\LDAP_MODIFY_BATCH_REMOVE,
\LDAP_MODIFY_BATCH_REMOVE_ALL,
\LDAP_MODIFY_BATCH_REPLACE,
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdateOperation.php


Joomla CMS: Référence de la classe AbstractConnection

  • Symfony
  • Component
  • Ldap
  • Adapter
  • AbstractConnection
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe AbstractConnection
+ Graphe d'héritage de AbstractConnection:
ConnectionInterface Connection

Fonctions membres publiques

__construct (array $config=[])
- Fonctions membres publiques hérités de ConnectionInterface
isBound ()
bind (string $dn=null, string $password=null)

Fonctions membres protégées

configureOptions (OptionsResolver $resolver)

Attributs protégés

$config

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $config = [] )

Références AbstractConnection\$config, et AbstractConnection\configureOptions().

Documentation des fonctions membres

◆ configureOptions()

configureOptions ( OptionsResolver $resolver )
protected

Références $options, null, OptionsResolver\setAllowedTypes(), OptionsResolver\setAllowedValues(), OptionsResolver\setDefault(), et OptionsResolver\setDefaults().

Référencé par AbstractConnection\__construct().

Documentation des champs

◆ $config

$config
protected

Référencé par AbstractConnection\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractConnection.php


Joomla CMS: Référence de la classe AbstractQuery

  • Symfony
  • Component
  • Ldap
  • Adapter
  • AbstractQuery
Fonctions membres publiques | Attributs protégés
Référence de la classe AbstractQuery
+ Graphe d'héritage de AbstractQuery:
QueryInterface Query

Fonctions membres publiques

__construct (ConnectionInterface $connection, string $dn, string $query, array $options=[])
- Fonctions membres publiques hérités de QueryInterface
execute ()

Attributs protégés

$connection
$dn
$query
$options

Membres hérités additionnels

- Champs de données hérités de QueryInterface
const | DEREF_NEVER = 0x00
const | DEREF_SEARCHING = 0x01
const | DEREF_FINDING = 0x02
const | DEREF_ALWAYS = 0x03
const | SCOPE_BASE = 'base'
const | SCOPE_ONE = 'one'
const | SCOPE_SUB = 'sub'

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ConnectionInterface | $connection,
 |  | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

Références AbstractQuery\$connection, AbstractQuery\$dn, AbstractQuery\$options, AbstractQuery\$query, et $value.

Documentation des champs

◆ $connection

$connection
protected

Référencé par AbstractQuery\__construct().

◆ $dn

$dn
protected

Référencé par AbstractQuery\__construct(), et Query\__construct().

◆ $options

$options
protected

Référencé par AbstractQuery\__construct(), et Query\__construct().

◆ $query

$query
protected

Référencé par AbstractQuery\__construct(), et Query\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractQuery.php


Joomla CMS: Référence de l'interface AdapterInterface

  • Symfony
  • Component
  • Ldap
  • Adapter
  • AdapterInterface
Fonctions membres publiques
Référence de l'interface AdapterInterface
+ Graphe d'héritage de AdapterInterface:
Adapter

Fonctions membres publiques

getConnection ()
createQuery (string $dn, string $query, array $options=[])
getEntryManager ()
escape (string $subject, string $ignore='', int $flags=0)

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des fonctions membres

◆ createQuery()

createQuery | ( | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

Creates a new Query.

Renvoie
QueryInterface

Implémenté dans Adapter.

◆ escape()

escape | ( | string | $subject,
 |  | string | $ignore = '',
 |  | int | $flags = 0
 | ) |  |

Escape a string for use in an LDAP filter or DN.

Renvoie
string

Implémenté dans Adapter.

◆ getConnection()

getConnection ( )

Returns the current connection.

Renvoie
ConnectionInterface

Implémenté dans Adapter.

◆ getEntryManager()

getEntryManager ( )

Fetches the entry manager instance.

Renvoie
EntryManagerInterface

Implémenté dans Adapter.

La documentation de cette interface a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/ldap/Adapter/AdapterInterface.php


Joomla CMS: Référence de l'interface CollectionInterface

  • Symfony
  • Component
  • Ldap
  • Adapter
  • CollectionInterface
Fonctions membres publiques
Référence de l'interface CollectionInterface
+ Graphe d'héritage de CollectionInterface:
Collection

Fonctions membres publiques

toArray ()

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

<int, Entry> <int, Entry>

Documentation des fonctions membres

◆ toArray()

toArray ( )
Renvoie
list<Entry>

Implémenté dans Collection.

La documentation de cette interface a été générée à partir du fichier suivant :
  • CollectionInterface.php


Joomla CMS: Référence de l'interface ConnectionInterface

  • Symfony
  • Component
  • Ldap
  • Adapter
  • ConnectionInterface
Fonctions membres publiques
Référence de l'interface ConnectionInterface
+ Graphe d'héritage de ConnectionInterface:
AbstractConnection Connection

Fonctions membres publiques

isBound ()
bind (string $dn=null, string $password=null)

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des fonctions membres

◆ bind()

bind | ( | string | $dn = null,
 |  | string | $password = null
 | ) |  |

Binds the connection against a user's DN and password.

Exceptions
AlreadyExistsException | When the connection can't be created because of an LDAP_ALREADY_EXISTS error
ConnectionTimeoutException | When the connection can't be created because of an LDAP_TIMEOUT error
InvalidCredentialsException | When the connection can't be created because of an LDAP_INVALID_CREDENTIALS error

Implémenté dans Connection.

◆ isBound()

isBound ( )

Checks whether the connection was already bound or not.

Renvoie
bool

Implémenté dans Connection.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ConnectionInterface.php


Joomla CMS: Référence de l'interface EntryManagerInterface

  • Symfony
  • Component
  • Ldap
  • Adapter
  • EntryManagerInterface
Fonctions membres publiques
Référence de l'interface EntryManagerInterface
+ Graphe d'héritage de EntryManagerInterface:
EntryManager

Fonctions membres publiques

add (Entry $entry)
update (Entry $entry)
move (Entry $entry, string $newParent)
rename (Entry $entry, string $newRdn, bool $removeOldRdn=true)
remove (Entry $entry)

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Bob van de Vijver bobva.nosp@m.ndev.nosp@m.ijver.nosp@m.@hot.nosp@m.mail..nosp@m.com
Kevin Schuurmans kevin.nosp@m..sch.nosp@m.uurma.nosp@m.ns@f.nosp@m.reshh.nosp@m.eads.nosp@m..com

Documentation des fonctions membres

◆ add()

add ( Entry $entry )

Adds a new entry in the Ldap server.

Exceptions
NotBoundException
LdapException

Implémenté dans EntryManager.

◆ move()

move | ( | Entry | $entry,
 |  | string | $newParent
 | ) |  |

Moves an entry on the Ldap server.

Exceptions
NotBoundException
LdapException

Implémenté dans EntryManager.

◆ remove()

remove ( Entry $entry )

Removes an entry from the Ldap server.

Exceptions
NotBoundException
LdapException

Implémenté dans EntryManager.

◆ rename()

rename | ( | Entry | $entry,
 |  | string | $newRdn,
 |  | bool | $removeOldRdn = true
 | ) |  |

Renames an entry on the Ldap server.

Exceptions
NotBoundException
LdapException

Implémenté dans EntryManager.

◆ update()

update ( Entry $entry )

Updates an entry from the Ldap server.

Exceptions
NotBoundException
LdapException

Implémenté dans EntryManager.

La documentation de cette interface a été générée à partir du fichier suivant :
  • EntryManagerInterface.php


Joomla CMS: Référence de l'interface QueryInterface

  • Symfony
  • Component
  • Ldap
  • Adapter
  • QueryInterface
Fonctions membres publiques | Champs de données
Référence de l'interface QueryInterface
+ Graphe d'héritage de QueryInterface:
AbstractQuery Query

Fonctions membres publiques

execute ()

Champs de données

const | DEREF_NEVER = 0x00
const | DEREF_SEARCHING = 0x01
const | DEREF_FINDING = 0x02
const | DEREF_ALWAYS = 0x03
const | SCOPE_BASE = 'base'
const | SCOPE_ONE = 'one'
const | SCOPE_SUB = 'sub'

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Bob van de Vijver bobva.nosp@m.ndev.nosp@m.ijver.nosp@m.@hot.nosp@m.mail..nosp@m.com

Documentation des fonctions membres

◆ execute()

execute ( )

Executes a query and returns the list of Ldap entries.

Renvoie
CollectionInterface
Exceptions
NotBoundException
LdapException

Implémenté dans Query.

Documentation des champs

◆ DEREF_ALWAYS

const DEREF_ALWAYS = 0x03

◆ DEREF_FINDING

const DEREF_FINDING = 0x02

◆ DEREF_NEVER

const DEREF_NEVER = 0x00

◆ DEREF_SEARCHING

const DEREF_SEARCHING = 0x01

◆ SCOPE_BASE

const SCOPE_BASE = 'base'

◆ SCOPE_ONE

const SCOPE_ONE = 'one'

◆ SCOPE_SUB

const SCOPE_SUB = 'sub'
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/ldap/Adapter/QueryInterface.php


Joomla CMS: Référence de la classe AlreadyExistsException

  • Symfony
  • Component
  • Ldap
  • Exception
  • AlreadyExistsException
Référence de la classe AlreadyExistsException
+ Graphe d'héritage de AlreadyExistsException:
ConnectionException ExceptionInterface

Description détaillée

AlreadyExistsException is thrown if the element already exists.

Auteur
Hamza Amrouche hamza.nosp@m..sim.nosp@m.perfi.nosp@m.t@gm.nosp@m.ail.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • AlreadyExistsException.php


Joomla CMS: Référence de la classe ConnectionException

  • Symfony
  • Component
  • Ldap
  • Exception
  • ConnectionException
Référence de la classe ConnectionException
+ Graphe d'héritage de ConnectionException:
ExceptionInterface AlreadyExistsException ConnectionTimeoutException InvalidCredentialsException

Description détaillée

ConnectionException is thrown if binding to ldap cannot be established.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionException.php


Joomla CMS: Référence de la classe ConnectionTimeoutException

  • Symfony
  • Component
  • Ldap
  • Exception
  • ConnectionTimeoutException
Référence de la classe ConnectionTimeoutException
+ Graphe d'héritage de ConnectionTimeoutException:
ConnectionException ExceptionInterface

Description détaillée

ConnectionTimeoutException is thrown if binding to ldap time out.

Auteur
Hamza Amrouche hamza.nosp@m..sim.nosp@m.perfi.nosp@m.t@gm.nosp@m.ail.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • ConnectionTimeoutException.php


Joomla CMS: Référence de la classe DriverNotFoundException

  • Symfony
  • Component
  • Ldap
  • Exception
  • DriverNotFoundException
Référence de la classe DriverNotFoundException
+ Graphe d'héritage de DriverNotFoundException:
ExceptionInterface

Description détaillée

LdapException is thrown if php ldap module is not loaded.

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
La documentation de cette classe a été générée à partir du fichier suivant :
  • DriverNotFoundException.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Symfony
  • Component
  • Ldap
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
ConnectionException DriverNotFoundException LdapException NotBoundException AlreadyExistsException ConnectionTimeoutException InvalidCredentialsException UpdateOperationException

Description détaillée

Base ExceptionInterface for the Ldap component.

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/ldap/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe InvalidCredentialsException

  • Symfony
  • Component
  • Ldap
  • Exception
  • InvalidCredentialsException
Référence de la classe InvalidCredentialsException
+ Graphe d'héritage de InvalidCredentialsException:
ConnectionException ExceptionInterface

Description détaillée

InvalidCredentialsException is thrown if binding to ldap has been done with invalid credentials.

Auteur
Hamza Amrouche hamza.nosp@m..sim.nosp@m.perfi.nosp@m.t@gm.nosp@m.ail.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidCredentialsException.php


Joomla CMS: Référence de la classe LdapException

  • Symfony
  • Component
  • Ldap
  • Exception
  • LdapException
Référence de la classe LdapException
+ Graphe d'héritage de LdapException:
ExceptionInterface UpdateOperationException

Description détaillée

LdapException is thrown if php ldap module is not loaded.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info
La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapException.php


Joomla CMS: Référence de la classe NotBoundException

  • Symfony
  • Component
  • Ldap
  • Exception
  • NotBoundException
Référence de la classe NotBoundException
+ Graphe d'héritage de NotBoundException:
ExceptionInterface

Description détaillée

NotBoundException is thrown if the connection with the LDAP server is not yet bound.

Auteur
Bob van de Vijver bobva.nosp@m.ndev.nosp@m.ijver.nosp@m.@hot.nosp@m.mail..nosp@m.com
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotBoundException.php


Joomla CMS: Référence de la classe UpdateOperationException

  • Symfony
  • Component
  • Ldap
  • Exception
  • UpdateOperationException
Référence de la classe UpdateOperationException
+ Graphe d'héritage de UpdateOperationException:
LdapException ExceptionInterface
La documentation de cette classe a été générée à partir du fichier suivant :
  • UpdateOperationException.php


Joomla CMS: Référence de la classe CheckLdapCredentialsListener

  • Symfony
  • Component
  • Ldap
  • Security
  • CheckLdapCredentialsListener
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe CheckLdapCredentialsListener
+ Graphe d'héritage de CheckLdapCredentialsListener:

Fonctions membres publiques

__construct (ContainerInterface $ldapLocator)

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs privés

$ldapLocator

Description détaillée

Verifies password credentials using an LDAP service whenever the LdapBadge is attached to the Security passport.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ContainerInterface $ldapLocator )

Références CheckLdapCredentialsListener\$ldapLocator.

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Références class.

Documentation des champs

◆ $ldapLocator

$ldapLocator
private

Référencé par CheckLdapCredentialsListener\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CheckLdapCredentialsListener.php


Joomla CMS: Référence de la classe LdapAuthenticator

  • Symfony
  • Component
  • Ldap
  • Security
  • LdapAuthenticator
Fonctions membres publiques | Attributs privés
Référence de la classe LdapAuthenticator
+ Graphe d'héritage de LdapAuthenticator:

Fonctions membres publiques

__construct (AuthenticatorInterface $authenticator, string $ldapServiceId, string $dnString='{username}', string $searchDn='', string $searchPassword='', string $queryString='')
supports (Request $request)
authenticate (Request $request)
createAuthenticatedToken (PassportInterface $passport, string $firewallName)
createToken (Passport $passport, string $firewallName)
onAuthenticationSuccess (Request $request, TokenInterface $token, string $firewallName)
onAuthenticationFailure (Request $request, AuthenticationException $exception)
start (Request $request, AuthenticationException $authException=null)
isInteractive ()

Attributs privés

$authenticator
$ldapServiceId
$dnString
$searchDn
$searchPassword
$queryString

Description détaillée

This class decorates internal authenticators to add the LDAP integration.

In your own authenticators, it is recommended to directly use the LdapBadge in the authenticate() method. This class should only be used for Symfony or third party authenticators.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AuthenticatorInterface | $authenticator,
 |  | string | $ldapServiceId,
 |  | string | $dnString = '{username}',
 |  | string | $searchDn = '',
 |  | string | $searchPassword = '',
 |  | string | $queryString = ''
 | ) |  |

Références LdapAuthenticator\$authenticator, LdapAuthenticator\$dnString, LdapAuthenticator\$ldapServiceId, LdapAuthenticator\$queryString, LdapAuthenticator\$searchDn, et LdapAuthenticator\$searchPassword.

Documentation des fonctions membres

◆ authenticate()

authenticate ( Request $request )

◆ createAuthenticatedToken()

createAuthenticatedToken | ( | PassportInterface | $passport,
 |  | string | $firewallName
 | ) |  |
Obsolète:
since Symfony 5.4, use createToken() instead

Références LdapAuthenticator\createToken().

◆ createToken()

createToken | ( | Passport | $passport,
 |  | string | $firewallName
 | ) |  |

Référencé par LdapAuthenticator\createAuthenticatedToken().

◆ isInteractive()

isInteractive ( )

◆ onAuthenticationFailure()

onAuthenticationFailure | ( | Request | $request,
 |  | AuthenticationException | $exception
 | ) |  |

◆ onAuthenticationSuccess()

onAuthenticationSuccess | ( | Request | $request,
 |  | TokenInterface | $token,
 |  | string | $firewallName
 | ) |  |

◆ start()

start | ( | Request | $request,
 |  | AuthenticationException | $authException = null
 | ) |  |

Références class.

◆ supports()

supports ( Request $request )

Documentation des champs

◆ $authenticator

$authenticator
private

Référencé par LdapAuthenticator\__construct().

◆ $dnString

$dnString
private

Référencé par LdapAuthenticator\__construct().

◆ $ldapServiceId

$ldapServiceId
private

Référencé par LdapAuthenticator\__construct().

◆ $queryString

$queryString
private

Référencé par LdapAuthenticator\__construct().

◆ $searchDn

$searchDn
private

Référencé par LdapAuthenticator\__construct().

◆ $searchPassword

$searchPassword
private

Référencé par LdapAuthenticator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapAuthenticator.php


Joomla CMS: Référence de la classe LdapBadge

  • Symfony
  • Component
  • Ldap
  • Security
  • LdapBadge
Fonctions membres publiques | Attributs privés
Référence de la classe LdapBadge
+ Graphe d'héritage de LdapBadge:

Fonctions membres publiques

__construct (string $ldapServiceId, string $dnString='{username}', string $searchDn='', string $searchPassword='', string $queryString=null)
getLdapServiceId ()
getDnString ()
getSearchDn ()
getSearchPassword ()
getQueryString ()
markResolved ()
isResolved ()

Attributs privés

$resolved = false
$ldapServiceId
$dnString
$searchDn
$searchPassword
$queryString

Description détaillée

A badge indicating that the credentials should be checked using LDAP.

This badge must be used together with PasswordCredentials.

Auteur
Wouter de Jong woute.nosp@m.r@wo.nosp@m.uterj.nosp@m..nl

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $ldapServiceId,
 |  | string | $dnString = '{username}',
 |  | string | $searchDn = '',
 |  | string | $searchPassword = '',
 |  | string | $queryString = null
 | ) |  |

Références LdapBadge\$dnString, LdapBadge\$ldapServiceId, LdapBadge\$queryString, LdapBadge\$searchDn, et LdapBadge\$searchPassword.

Documentation des fonctions membres

◆ getDnString()

getDnString ( )

Références LdapBadge\$dnString.

◆ getLdapServiceId()

getLdapServiceId ( )

Références LdapBadge\$ldapServiceId.

◆ getQueryString()

getQueryString ( )

Références LdapBadge\$queryString.

◆ getSearchDn()

getSearchDn ( )

Références LdapBadge\$searchDn.

◆ getSearchPassword()

getSearchPassword ( )

Références LdapBadge\$searchPassword.

◆ isResolved()

isResolved ( )

Références LdapBadge\$resolved.

◆ markResolved()

markResolved ( )

Documentation des champs

◆ $dnString

$dnString
private

Référencé par LdapBadge\__construct(), et LdapBadge\getDnString().

◆ $ldapServiceId

$ldapServiceId
private

Référencé par LdapBadge\__construct(), et LdapBadge\getLdapServiceId().

◆ $queryString

$queryString
private

Référencé par LdapBadge\__construct(), et LdapBadge\getQueryString().

◆ $resolved

$resolved = false
private

Référencé par LdapBadge\isResolved().

◆ $searchDn

$searchDn
private

Référencé par LdapBadge\__construct(), et LdapBadge\getSearchDn().

◆ $searchPassword

$searchPassword
private

Référencé par LdapBadge\__construct(), et LdapBadge\getSearchPassword().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapBadge.php


Joomla CMS: Référence de la classe LdapUser

  • Symfony
  • Component
  • Ldap
  • Security
  • LdapUser
Fonctions membres publiques | Attributs privés
Référence de la classe LdapUser
+ Graphe d'héritage de LdapUser:

Fonctions membres publiques

__construct (Entry $entry, string $username, ?string $password, array $roles=[], array $extraFields=[])
getEntry ()
getRoles ()
getPassword ()
getSalt ()
getUsername ()
getUserIdentifier ()
eraseCredentials ()
getExtraFields ()
setPassword (string $password)
isEqualTo (UserInterface $user)

Attributs privés

$entry
$username
$password
$roles
$extraFields

Description détaillée

Auteur
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Entry | $entry,
 |  | string | $username,
 |  | ?string | $password,
 |  | array | $roles = [],
 |  | array | $extraFields = []
 | ) |  |

Références LdapUser\$entry, LdapUser\$extraFields, LdapUser\$password, LdapUser\$roles, et LdapUser\$username.

Documentation des fonctions membres

◆ eraseCredentials()

eraseCredentials ( )

{}

Références null.

◆ getEntry()

getEntry ( )

Références LdapUser\$entry.

◆ getExtraFields()

getExtraFields ( )

Références LdapUser\$extraFields.

◆ getPassword()

getPassword ( )

{}

Références LdapUser\$password.

Référencé par LdapUser\isEqualTo().

◆ getRoles()

getRoles ( )

{}

Références LdapUser\$roles.

◆ getSalt()

getSalt ( )

{}

Références null.

Référencé par LdapUser\isEqualTo().

◆ getUserIdentifier()

getUserIdentifier ( )

Références LdapUser\$username.

Référencé par LdapUser\isEqualTo().

◆ getUsername()

getUsername ( )

{}

Références LdapUser\$username.

◆ isEqualTo()

isEqualTo ( UserInterface $user )

{}

Références $user, LdapUser\getPassword(), LdapUser\getSalt(), et LdapUser\getUserIdentifier().

◆ setPassword()

setPassword ( string $password )

Références LdapUser\$password.

Documentation des champs

◆ $entry

$entry
private

Référencé par LdapUser\__construct(), et LdapUser\getEntry().

◆ $extraFields

$extraFields
private

Référencé par LdapUser\__construct(), et LdapUser\getExtraFields().

◆ $password

$password
private

Référencé par LdapUser\__construct(), LdapUser\getPassword(), et LdapUser\setPassword().

◆ $roles

$roles
private

Référencé par LdapUser\__construct(), et LdapUser\getRoles().

◆ $username

$username
private

Référencé par LdapUser\__construct(), LdapUser\getUserIdentifier(), et LdapUser\getUsername().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapUser.php


Joomla CMS: Référence de la classe LdapUserProvider

  • Symfony
  • Component
  • Ldap
  • Security
  • LdapUserProvider
Fonctions membres publiques | Fonctions membres protégées | Fonctions membres privées | Attributs privés
Référence de la classe LdapUserProvider
+ Graphe d'héritage de LdapUserProvider:

Fonctions membres publiques

__construct (LdapInterface $ldap, string $baseDn, string $searchDn=null, string $searchPassword=null, array $defaultRoles=[], string $uidKey=null, string $filter=null, string $passwordAttribute=null, array $extraFields=[])
loadUserByUsername (string $username)
loadUserByIdentifier (string $identifier)
refreshUser (UserInterface $user)
upgradePassword ($user, string $newHashedPassword)
supportsClass (string $class)

Fonctions membres protégées

loadUser (string $identifier, Entry $entry)

Fonctions membres privées

getAttributeValue (Entry $entry, string $attribute)

Attributs privés

$ldap
$baseDn
$searchDn
$searchPassword
$defaultRoles
$uidKey
$defaultSearch
$passwordAttribute
$extraFields

Description détaillée

LdapUserProvider is a simple user provider on top of LDAP.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | LdapInterface | $ldap,
 |  | string | $baseDn,
 |  | string | $searchDn = null,
 |  | string | $searchPassword = null,
 |  | array | $defaultRoles = [],
 |  | string | $uidKey = null,
 |  | string | $filter = null,
 |  | string | $passwordAttribute = null,
 |  | array | $extraFields = []
 | ) |  |

Références LdapUserProvider\$baseDn, LdapUserProvider\$defaultRoles, LdapUserProvider\$extraFields, LdapUserProvider\$ldap, LdapUserProvider\$passwordAttribute, LdapUserProvider\$searchDn, LdapUserProvider\$searchPassword, LdapUserProvider\$uidKey, et null.

Documentation des fonctions membres

◆ getAttributeValue()

getAttributeValue | ( | Entry | $entry,
 |  | string | $attribute
 | ) |  |
private

Références Entry\getAttribute(), Entry\getDn(), et Entry\hasAttribute().

Référencé par LdapUserProvider\loadUser(), et LdapUserProvider\loadUserByIdentifier().

◆ loadUser()

loadUser | ( | string | $identifier,
 |  | Entry | $entry
 | ) |  |
protected

Loads a user from an LDAP entry.

Renvoie
UserInterface

Références LdapUserProvider\$extraFields, $field, $password, LdapUserProvider\getAttributeValue(), et null.

Référencé par LdapUserProvider\loadUserByIdentifier().

◆ loadUserByIdentifier()

loadUserByIdentifier ( string $identifier )

Références $count, $query, LdapInterface\ESCAPE_FILTER, LdapUserProvider\getAttributeValue(), LdapUserProvider\loadUser(), et null.

Référencé par LdapUserProvider\loadUserByUsername().

◆ loadUserByUsername()

loadUserByUsername ( string $username )

{}

Références LdapUserProvider\loadUserByIdentifier().

◆ refreshUser()

refreshUser ( UserInterface $user )

{}

Références $user.

◆ supportsClass()

supportsClass ( string $class )

{}

Références $class, et class.

◆ upgradePassword()

upgradePassword | ( |  | $user,
 |  | string | $newHashedPassword
 | ) |  |

{}

Références $user, et null.

Documentation des champs

◆ $baseDn

$baseDn
private

Référencé par LdapUserProvider\__construct().

◆ $defaultRoles

$defaultRoles
private

Référencé par LdapUserProvider\__construct().

◆ $defaultSearch

$defaultSearch
private

◆ $extraFields

$extraFields
private

Référencé par LdapUserProvider\__construct(), et LdapUserProvider\loadUser().

◆ $ldap

$ldap
private

Référencé par LdapUserProvider\__construct().

◆ $passwordAttribute

$passwordAttribute
private

Référencé par LdapUserProvider\__construct().

◆ $searchDn

$searchDn
private

Référencé par LdapUserProvider\__construct().

◆ $searchPassword

$searchPassword
private

Référencé par LdapUserProvider\__construct().

◆ $uidKey

$uidKey
private

Référencé par LdapUserProvider\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LdapUserProvider.php


Joomla CMS: Référence de la classe Entry

  • Symfony
  • Component
  • Ldap
  • Entry
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Entry

Fonctions membres publiques

__construct (string $dn, array $attributes=[])
getDn ()
hasAttribute (string $name)
getAttribute (string $name)
getAttributes ()
setAttribute (string $name, array $value)
removeAttribute (string $name)

Fonctions membres privées

getAttributeKey (string $name, bool $caseSensitive=true)

Attributs privés

$dn
$attributes = []
$lowerMap = []

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in
Karl Shea karl@.nosp@m.karl.nosp@m.shea..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $dn,
 |  | array | $attributes = []
 | ) |  |
Paramètres
array<string,array> $attributes

Références Entry\$attributes, Entry\$dn, $key, et Entry\setAttribute().

Documentation des fonctions membres

◆ getAttribute()

getAttribute ( string $name )

Returns a specific attribute's value.

As LDAP can return multiple values for a single attribute, this value is returned as an array.

Paramètres
string | $name | The name of the attribute
bool | $caseSensitive | Whether the attribute name is case-sensitive
Renvoie
array|null

Références Entry\getAttributeKey(), et null.

Référencé par LdapUserProvider\getAttributeValue().

◆ getAttributeKey()

getAttributeKey | ( | string | $name,
 |  | bool | $caseSensitive = true
 | ) |  |
private

Références $name, et null.

Référencé par Entry\getAttribute(), et Entry\hasAttribute().

◆ getAttributes()

getAttributes ( )

Returns the complete list of attributes.

Renvoie
array

Références Entry\$attributes.

Référencé par EntryManager\add(), et EntryManager\update().

◆ getDn()

getDn ( )

Returns the entry's DN.

Renvoie
string

Références Entry\$dn.

Référencé par EntryManager\add(), EntryManager\addAttributeValues(), LdapUserProvider\getAttributeValue(), EntryManager\move(), EntryManager\parseRdnFromEntry(), EntryManager\removeAttributeValues(), EntryManager\rename(), et EntryManager\update().

◆ hasAttribute()

hasAttribute ( string $name )

Returns whether an attribute exists.

Paramètres
string | $name | The name of the attribute
bool | $caseSensitive | Whether the check should be case-sensitive
Renvoie
bool

Références Entry\getAttributeKey(), et null.

Référencé par LdapUserProvider\getAttributeValue().

◆ removeAttribute()

removeAttribute ( string $name )

Removes a given attribute.

Références $name.

◆ setAttribute()

setAttribute | ( | string | $name,
 |  | array | $value
 | ) |  |

Sets a value for the given attribute.

Références $name, et $value.

Référencé par Entry\__construct().

Documentation des champs

◆ $attributes

$attributes = []
private

Référencé par Entry\__construct(), et Entry\getAttributes().

◆ $dn

$dn
private

Référencé par Entry\__construct(), et Entry\getDn().

◆ $lowerMap

$lowerMap = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Entry.php


Joomla CMS: Référence de la classe Ldap

  • Symfony
  • Component
  • Ldap
  • Ldap
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Ldap
+ Graphe d'héritage de Ldap:
LdapInterface

Fonctions membres publiques

__construct (AdapterInterface $adapter)
bind (string $dn=null, string $password=null)
query (string $dn, string $query, array $options=[])
getEntryManager ()
escape (string $subject, string $ignore='', int $flags=0)

Fonctions membres publiques statiques

static create (string $adapter, array $config=[])

Attributs privés

$adapter

Membres hérités additionnels

- Champs de données hérités de LdapInterface
const | ESCAPE_FILTER = 0x01
const | ESCAPE_DN = 0x02

Description détaillée

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( AdapterInterface $adapter )

Références Ldap\$adapter.

Documentation des fonctions membres

◆ bind()

bind | ( | string | $dn = null,
 |  | string | $password = null
 | ) |  |

{Return a connection bound to the ldap.

Exceptions
ConnectionException if dn / password could not be bound
}

Implémente LdapInterface.

Références $password.

◆ create()

static create | ( | string | $adapter,
 |  | array | $config = []
 | ) |  |
static

Creates a new Ldap instance.

Paramètres
string | $adapter | The adapter name
array | $config | The adapter's configuration
Renvoie
static

Références Ldap\$adapter, et $config.

◆ escape()

escape | ( | string | $subject,
 |  | string | $ignore = '',
 |  | int | $flags = 0
 | ) |  |

{Escape a string for use in an LDAP filter or DN.

Renvoie
string
}

Implémente LdapInterface.

Références $subject.

◆ getEntryManager()

getEntryManager ( )

{

Renvoie
EntryManagerInterface
}

Implémente LdapInterface.

◆ query()

query | ( | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

{Queries a ldap server for entries matching the given criteria.

Renvoie
QueryInterface
}

Implémente LdapInterface.

Références $options, et $query.

Référencé par PlgAuthenticationLdap\searchByString().

Documentation des champs

◆ $adapter

$adapter
private

Référencé par Ldap\__construct(), et Ldap\create().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ldap.php


Joomla CMS: Référence de l'interface LdapInterface

  • Symfony
  • Component
  • Ldap
  • LdapInterface
Fonctions membres publiques | Champs de données
Référence de l'interface LdapInterface
+ Graphe d'héritage de LdapInterface:
Ldap

Fonctions membres publiques

bind (string $dn=null, string $password=null)
query (string $dn, string $query, array $options=[])
getEntryManager ()
escape (string $subject, string $ignore='', int $flags=0)

Champs de données

const | ESCAPE_FILTER = 0x01
const | ESCAPE_DN = 0x02

Description détaillée

Ldap interface.

Auteur
Charles Sarrazin charl.nosp@m.es@s.nosp@m.arraz.nosp@m..in

Documentation des fonctions membres

◆ bind()

bind | ( | string | $dn = null,
 |  | string | $password = null
 | ) |  |

Return a connection bound to the ldap.

Exceptions
ConnectionException if dn / password could not be bound

Implémenté dans Ldap.

◆ escape()

escape | ( | string | $subject,
 |  | string | $ignore = '',
 |  | int | $flags = 0
 | ) |  |

Escape a string for use in an LDAP filter or DN.

Renvoie
string

Implémenté dans Ldap.

◆ getEntryManager()

getEntryManager ( )
Renvoie
EntryManagerInterface

Implémenté dans Ldap.

◆ query()

query | ( | string | $dn,
 |  | string | $query,
 |  | array | $options = []
 | ) |  |

Queries a ldap server for entries matching the given criteria.

Renvoie
QueryInterface

Implémenté dans Ldap.

Documentation des champs

◆ ESCAPE_DN

const ESCAPE_DN = 0x02

◆ ESCAPE_FILTER

const ESCAPE_FILTER = 0x01

Référencé par LdapUserProvider\loadUserByIdentifier().

La documentation de cette interface a été générée à partir du fichier suivant :
  • LdapInterface.php


Joomla CMS: Référence de la classe OptionsResolverIntrospector

  • Symfony
  • Component
  • OptionsResolver
  • Debug
  • OptionsResolverIntrospector
Fonctions membres publiques | Attributs privés
Référence de la classe OptionsResolverIntrospector

Fonctions membres publiques

getDefault (string $option)
getLazyClosures (string $option)
getAllowedTypes (string $option)
getAllowedValues (string $option)
getNormalizer (string $option)
getNormalizers (string $option)
getDeprecationMessage (string $option)
getDeprecation (string $option)

Attributs privés

$get

Description détaillée

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des fonctions membres

◆ getAllowedTypes()

getAllowedTypes ( string $option )
Renvoie
string[]
Exceptions
NoConfigurationException on no configured types

Références $option.

◆ getAllowedValues()

getAllowedValues ( string $option )
Renvoie
mixed[]
Exceptions
NoConfigurationException on no configured values

Références $option.

◆ getDefault()

getDefault ( string $option )
Renvoie
mixed
Exceptions
NoConfigurationException on no configured value

Références $option.

◆ getDeprecation()

getDeprecation ( string $option )
Exceptions
NoConfigurationException on no configured deprecation

Références $option.

Référencé par OptionsResolverIntrospector\getDeprecationMessage().

◆ getDeprecationMessage()

getDeprecationMessage ( string $option )
Renvoie
string|
Exceptions
NoConfigurationException on no configured deprecation
Obsolète:
since Symfony 5.1, use "getDeprecation()" instead.

Références OptionsResolverIntrospector\getDeprecation().

◆ getLazyClosures()

getLazyClosures ( string $option )
Renvoie
[]
Exceptions
NoConfigurationException on no configured closures

Références $option.

◆ getNormalizer()

getNormalizer ( string $option )
Exceptions
NoConfigurationException on no configured normalizer

Références OptionsResolverIntrospector\getNormalizers().

◆ getNormalizers()

getNormalizers ( string $option )
Exceptions
NoConfigurationException when no normalizer is configured

Références $option.

Référencé par OptionsResolverIntrospector\getNormalizer().

Documentation des champs

◆ $get

$get
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • OptionsResolverIntrospector.php


Joomla CMS: Référence de la classe AccessException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • AccessException
Référence de la classe AccessException
+ Graphe d'héritage de AccessException:
ExceptionInterface

Description détaillée

Thrown when trying to read an option outside of or write it inside of Symfony\Component\OptionsResolver\Options::resolve().@authorBernhardSchussek<bschussek@gmail.com>

La documentation de cette classe a été générée à partir du fichier suivant :
  • AccessException.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
AccessException InvalidArgumentException NoConfigurationException NoSuchOptionException OptionDefinitionException InvalidOptionsException MissingOptionsException UndefinedOptionsException

Description détaillée

Marker interface for all exceptions thrown by the OptionsResolver component.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/options-resolver/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
ExceptionInterface InvalidOptionsException MissingOptionsException UndefinedOptionsException

Description détaillée

Thrown when an argument is invalid.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/options-resolver/Exception/InvalidArgumentException.php


Joomla CMS: Référence de la classe InvalidOptionsException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • InvalidOptionsException
Référence de la classe InvalidOptionsException
+ Graphe d'héritage de InvalidOptionsException:
InvalidArgumentException ExceptionInterface

Description détaillée

Thrown when the value of an option does not match its validation rules.

You should make sure a valid value is passed to the option.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidOptionsException.php


Joomla CMS: Référence de la classe MissingOptionsException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • MissingOptionsException
Référence de la classe MissingOptionsException
+ Graphe d'héritage de MissingOptionsException:
InvalidArgumentException ExceptionInterface

Description détaillée

Exception thrown when a required option is missing.

Add the option to the passed options array.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • MissingOptionsException.php


Joomla CMS: Référence de la classe NoConfigurationException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • NoConfigurationException
Référence de la classe NoConfigurationException
+ Graphe d'héritage de NoConfigurationException:
ExceptionInterface

Description détaillée

Thrown when trying to introspect an option definition property for which no value was configured inside the OptionsResolver instance.

Voir également
OptionsResolverIntrospector
Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoConfigurationException.php


Joomla CMS: Référence de la classe NoSuchOptionException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • NoSuchOptionException
Référence de la classe NoSuchOptionException
+ Graphe d'héritage de NoSuchOptionException:
ExceptionInterface

Description détaillée

Thrown when trying to read an option that has no value set.

When accessing optional options from within a lazy option or normalizer you should first check whether the optional option is set. You can do this with ‘isset($options['optional’])`. In contrast to the UndefinedOptionsException, this is a runtime exception that can occur when evaluating lazy options.

Auteur
Tobias Schultze http://tobion.de
La documentation de cette classe a été générée à partir du fichier suivant :
  • NoSuchOptionException.php


Joomla CMS: Référence de la classe OptionDefinitionException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • OptionDefinitionException
Référence de la classe OptionDefinitionException
+ Graphe d'héritage de OptionDefinitionException:
ExceptionInterface

Description détaillée

Thrown when two lazy options have a cyclic dependency.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • OptionDefinitionException.php


Joomla CMS: Référence de la classe UndefinedOptionsException

  • Symfony
  • Component
  • OptionsResolver
  • Exception
  • UndefinedOptionsException
Référence de la classe UndefinedOptionsException
+ Graphe d'héritage de UndefinedOptionsException:
InvalidArgumentException ExceptionInterface

Description détaillée

Exception thrown when an undefined option is passed.

You should remove the options in question from your code or define them beforehand.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
La documentation de cette classe a été générée à partir du fichier suivant :
  • UndefinedOptionsException.php


Joomla CMS: Référence de la classe OptionConfigurator

  • Symfony
  • Component
  • OptionsResolver
  • OptionConfigurator
Fonctions membres publiques | Attributs privés
Référence de la classe OptionConfigurator

Fonctions membres publiques

__construct (string $name, OptionsResolver $resolver)
allowedTypes (string ... $types)
allowedValues (... $values)
default ($value)
define (string $option)
deprecated (string $package, string $version, $message='The option "%name%" is deprecated.')
normalize (\Closure $normalizer)
required ()
info (string $info)

Attributs privés

$name
$resolver

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | OptionsResolver | $resolver
 | ) |  |

Références OptionConfigurator\$name, OptionConfigurator\$resolver, et name.

Documentation des fonctions membres

◆ allowedTypes()

allowedTypes ( string ... $types )

Adds allowed types for this option.

Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et name.

◆ allowedValues()

allowedValues ( $values )

Sets allowed values for this option.

Paramètres
mixed ...$values One or more acceptable values/closures
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et name.

◆ default()

default ( $value )

Sets the default value for this option.

Paramètres
mixed $value The default value of the option
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, $value, et name.

◆ define()

define ( string $option )

Defines an option configurator with the given name.

Références $option.

◆ deprecated()

deprecated | ( | string | $package,
 |  | string | $version,
 |  |  | $message = 'The option "%name%" is deprecated.'
 | ) |  |

Marks this option as deprecated.

Paramètres
string | $package | The name of the composer package that is triggering the deprecation
string | $version | The version of the package that introduced the deprecation
string | \Closure | $message | The deprecation message to use
Renvoie
$this

Références $message, $this, $version, et name.

◆ info()

info ( string $info )

Sets an info message for an option.

Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et name.

◆ normalize()

normalize ( \Closure $normalizer )

Sets the normalizer for this option.

Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et name.

◆ required()

required ( )

Marks this option as required.

Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et name.

Documentation des champs

◆ $name

$name
private

Référencé par OptionConfigurator\__construct().

◆ $resolver

$resolver
private

Référencé par OptionConfigurator\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • OptionConfigurator.php


Joomla CMS: Référence de l'interface Options

  • Symfony
  • Component
  • OptionsResolver
  • Options
Référence de l'interface Options
+ Graphe d'héritage de Options:
OptionsResolver

Description détaillée

Contains resolved option values.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
Tobias Schultze http://tobion.de
La documentation de cette interface a été générée à partir du fichier suivant :
  • Options.php


Joomla CMS: Référence de la classe OptionsResolver

  • Symfony
  • Component
  • OptionsResolver
  • OptionsResolver
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe OptionsResolver
+ Graphe d'héritage de OptionsResolver:
Options

Fonctions membres publiques

setDefault (string $option, $value)
setDefaults (array $defaults)
hasDefault (string $option)
setRequired ($optionNames)
isRequired (string $option)
getRequiredOptions ()
isMissing (string $option)
getMissingOptions ()
setDefined ($optionNames)
isDefined (string $option)
getDefinedOptions ()
isNested (string $option)
setDeprecated (string $option)
isDeprecated (string $option)
setNormalizer (string $option, \Closure $normalizer)
addNormalizer (string $option, \Closure $normalizer, bool $forcePrepend=false)
setAllowedValues (string $option, $allowedValues)
addAllowedValues (string $option, $allowedValues)
setAllowedTypes (string $option, $allowedTypes)
addAllowedTypes (string $option, $allowedTypes)
define (string $option)
setInfo (string $option, string $info)
getInfo (string $option)
setPrototype (bool $prototype)
isPrototype ()
remove ($optionNames)
clear ()
resolve (array $options=[])
offsetGet ($option, bool $triggerDeprecation=true)
offsetExists ($option)
offsetSet ($option, $value)
offsetUnset ($option)
count ()

Fonctions membres privées

verifyTypes (string $type, $value, array &$invalidTypes, int $level=0)
formatValue ($value)
formatValues (array $values)
formatOptions (array $options)
getParameterClassName (\ReflectionParameter $parameter)

Attributs privés

const | VALIDATION_FUNCTIONS
const | $defined = []
$defaults = []
$nested = []
$required = []
$resolved = []
$normalizers = []
$allowedValues = []
$allowedTypes = []
$info = []
$lazy = []
$calling = []
$deprecated = []
$given = []
$locked = false
$parentsOptions = []
$prototype
$prototypeIndex

Description détaillée

Validates options and merges them with default values.

Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
Tobias Schultze http://tobion.de

Documentation des fonctions membres

◆ addAllowedTypes()

addAllowedTypes | ( | string | $option,
 |  |  | $allowedTypes
 | ) |  |

Adds allowed types for an option.

The types are merged with the allowed types defined previously.

Any type for which a corresponding is_<type>() function exists is acceptable. Additionally, fully-qualified class or interface names may be passed.

Paramètres
string|string[] $allowedTypes One or more accepted types
Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références OptionsResolver\$allowedTypes, $option, $this, et OptionsResolver\formatOptions().

◆ addAllowedValues()

addAllowedValues | ( | string | $option,
 |  |  | $allowedValues
 | ) |  |

Adds allowed values for an option.

The values are merged with the allowed values defined previously.

Instead of passing values, you may also pass a closures with the following signature:

function ($value) {
    // return true or false
}

The closure receives the value as argument and should return true to accept the value and false to reject the value.

Paramètres
string | $option | The option name
mixed | $allowedValues | One or more acceptable values/closures
Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références OptionsResolver\$allowedValues, $option, $this, et OptionsResolver\formatOptions().

◆ addNormalizer()

addNormalizer | ( | string | $option,
 |  | \Closure | $normalizer,
 |  | bool | $forcePrepend = false
 | ) |  |

Adds a normalizer for an option.

The normalizer should be a closure with the following signature:

function (Options $options, $value): mixed {
    // ...
}

The closure is invoked when resolve() is called. The closure has access to the resolved values of other options through the passed Options instance.

The second parameter passed to the closure is the value of the option.

The resolved option value is set to the return value of the closure.

Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références $option, $this, et OptionsResolver\formatOptions().

◆ clear()

clear ( )

Removes all options.

Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $this, et Assert\lazy().

◆ count()

count ( )

Returns the number of set options.

This may be only a subset of the defined options.

Renvoie
int
Exceptions
AccessException If accessing this method outside of resolve()
Voir également
::count()

Référencé par OptionsResolver\offsetGet(), et OptionsResolver\resolve().

◆ define()

define ( string $option )

Defines an option configurator with the given name.

Références $option, et $this.

◆ formatOptions()

formatOptions ( array $options )
private

Références $option, $options, $prefix, et null.

Référencé par OptionsResolver\addAllowedTypes(), OptionsResolver\addAllowedValues(), OptionsResolver\addNormalizer(), OptionsResolver\getInfo(), OptionsResolver\offsetGet(), OptionsResolver\resolve(), OptionsResolver\setAllowedTypes(), OptionsResolver\setAllowedValues(), OptionsResolver\setDeprecated(), OptionsResolver\setInfo(), et OptionsResolver\setNormalizer().

◆ formatValue()

formatValue ( $value )
private

Returns a string representation of the value.

This method returns the equivalent PHP tokens for most scalar types (i.e. "false" for false, "1" for 1 etc.). Strings are always wrapped in double quotes (").

Paramètres
mixed $value The value to format as string

Références $value, et null.

Référencé par OptionsResolver\formatValues(), et OptionsResolver\offsetGet().

◆ formatValues()

formatValues ( array $values )
private

Returns a string representation of a list of values.

Each of the values is converted to a string using formatValue(). The values are then concatenated with commas.

Voir également
formatValue()

Références $key, $value, et OptionsResolver\formatValue().

Référencé par OptionsResolver\offsetGet().

◆ getDefinedOptions()

getDefinedOptions ( )

Returns the names of all defined options.

Renvoie
string[]
Voir également
isDefined()

◆ getInfo()

getInfo ( string $option )

Gets the info message for an option.

Références $option, OptionsResolver\formatOptions(), et null.

◆ getMissingOptions()

getMissingOptions ( )

Returns the names of all options missing a default value.

Renvoie
string[]

◆ getParameterClassName()

getParameterClassName ( \ReflectionParameter $parameter )
private

Références $type, et null.

Référencé par OptionsResolver\setDefault().

◆ getRequiredOptions()

getRequiredOptions ( )

Returns the names of all required options.

Renvoie
string[]
Voir également
isRequired()

◆ hasDefault()

hasDefault ( string $option )

Returns whether a default value is set for an option.

Returns true if setDefault() was called for this option. An option is also considered set if it was set to null.

Renvoie
bool

Références $option.

◆ isDefined()

isDefined ( string $option )

Returns whether an option is defined.

Returns true for any option passed to setDefault(), setRequired() or setDefined().

Renvoie
bool

◆ isDeprecated()

isDeprecated ( string $option )

Références $option.

◆ isMissing()

isMissing ( string $option )

Returns whether an option is missing a default value.

An option is missing if it was passed to setRequired(), but not to setDefault(). This option must be passed explicitly to resolve(), otherwise an exception will be thrown.

Renvoie
bool

Références $option.

◆ isNested()

isNested ( string $option )

Références $option.

◆ isPrototype()

isPrototype ( )

◆ isRequired()

isRequired ( string $option )

Returns whether an option is required.

An option is required if it was passed to setRequired().

Renvoie
bool

Références $option.

◆ offsetExists()

offsetExists ( $option )

Returns whether a resolved option with the given name exists.

Paramètres
string $option The option name
Renvoie
bool
Exceptions
AccessException If accessing this method outside of resolve()
Voir également
::offsetExists()

Références $option.

◆ offsetGet()

offsetGet | ( |  | $option,
 |  | bool | $triggerDeprecation = true
 | ) |  |

Returns the resolved value of an option.

Paramètres
bool $triggerDeprecation Whether to trigger the deprecation or not (true by default)
Renvoie
mixed
Exceptions
AccessException | If accessing this method outside of resolve()
NoSuchOptionException | If the option is not set
InvalidOptionsException | If the option doesn't fulfill the specified validation rules
OptionDefinitionException | If there is a cyclic dependency between lazy options and/or normalizers

Références $item, $message, $option, OptionsResolver\$parentsOptions, $this, $type, $value, OptionsResolver\count(), OptionsResolver\formatOptions(), OptionsResolver\formatValue(), OptionsResolver\formatValues(), Assert\lazy(), null, et OptionsResolver\verifyTypes().

◆ offsetSet()

offsetSet | ( | $option,
 |  | $value
 | ) |

Not supported.

Renvoie
void
Exceptions
AccessException

◆ offsetUnset()

offsetUnset ( $option )

Not supported.

Renvoie
void
Exceptions
AccessException

◆ remove()

remove ( $optionNames )

Removes the option with the given name.

Undefined options are ignored.

Paramètres
string|string[] $optionNames One or more option names
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $option, $this, et Assert\lazy().

◆ resolve()

resolve ( array $options = [] )

Merges options with the default values stored in the container and validates them.

Exceptions are thrown if:

  • Undefined options are passed;
  • Required options are missing;
  • Options have invalid types;
  • Options have invalid values.
Renvoie
array
Exceptions
UndefinedOptionsException | If an option name is undefined
InvalidOptionsException | If an option doesn't fulfill the specified validation rules
MissingOptionsException | If a required option is missing
OptionDefinitionException | If there is a cyclic dependency between lazy options and/or normalizers
NoSuchOptionException | If a lazy option reads an unavailable option
AccessException | If called from a lazy option or normalizer

Références $option, $options, $this, $value, OptionsResolver\count(), et OptionsResolver\formatOptions().

◆ setAllowedTypes()

setAllowedTypes | ( | string | $option,
 |  |  | $allowedTypes
 | ) |  |

Sets allowed types for an option.

Any type for which a corresponding is_<type>() function exists is acceptable. Additionally, fully-qualified class or interface names may be passed.

Paramètres
string|string[] $allowedTypes One or more accepted types
Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références OptionsResolver\$allowedTypes, $option, $this, et OptionsResolver\formatOptions().

Référencé par AbstractConnection\configureOptions(), Connection\configureOptions(), et SessionFactory\configureSessionHandlerOptions().

◆ setAllowedValues()

setAllowedValues | ( | string | $option,
 |  |  | $allowedValues
 | ) |  |

Sets allowed values for an option.

Instead of passing values, you may also pass a closures with the following signature:

function ($value) {
    // return true or false
}

The closure receives the value as argument and should return true to accept the value and false to reject the value.

Paramètres
string | $option | The option name
mixed | $allowedValues | One or more acceptable values/closures
Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références OptionsResolver\$allowedValues, $option, $this, et OptionsResolver\formatOptions().

Référencé par AbstractConnection\configureOptions().

◆ setDefault()

setDefault | ( | string | $option,
 |  |  | $value
 | ) |  |

Sets the default value of a given option.

If the default value should be set based on other options, you can pass a closure with the following signature:

function (Options $options) {
    // ...
}

The closure will be evaluated when resolve() is called. The closure has access to the resolved values of other options through the passed Options instance:

function (Options $options) {
    if (isset($options['port'])) {
        // ...
    }
}

If you want to access the previously set default value, add a second argument to the closure's signature:

$options->setDefault('name', 'Default Name');

$options->setDefault('name', function (Options $options, $previousValue) {
    // 'Default Name' === $previousValue
});

This is mostly useful if the configuration of the Options object is spread across different locations of your code, such as base and sub-classes.

If you want to define nested options, you can pass a closure with the following signature:

$options->setDefault('database', function (OptionsResolver $resolver) {
    $resolver->setDefined(['dbname', 'host', 'port', 'user', 'pass']);
}

To get access to the parent options, add a second argument to the closure's signature:

function (OptionsResolver $resolver, Options $parent) {
    // 'default' === $parent['connection']
}
Paramètres
string | $option | The name of the option
mixed | $value | The default value of the option
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $option, $params, $this, $type, $value, class, OptionsResolver\getParameterClassName(), Assert\lazy(), et null.

Référencé par AbstractConnection\configureOptions(), Connection\configureOptions(), et OptionsResolver\setDefaults().

◆ setDefaults()

setDefaults ( array $defaults )
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références OptionsResolver\$defaults, $option, $this, $value, et OptionsResolver\setDefault().

Référencé par AbstractConnection\configureOptions(), SessionFactory\configureSessionHandlerOptions(), TaskModel\configureTaskGetterOptions(), et Scheduler\configureTaskRunnerOptions().

◆ setDefined()

setDefined ( $optionNames )

Defines a valid option name.

Defines an option name without setting a default value. The option will be accepted when passed to resolve(). When not passed, the option will not be included in the resolved options.

Paramètres
string|string[] $optionNames One or more option names
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $option, et $this.

◆ setDeprecated()

setDeprecated ( string $option )

Deprecates an option, allowed types or values.

Instead of passing the message, you may also pass a closure with the following signature:

function (Options $options, $value): string {
    // ...
}

The closure receives the value as argument and should return a string. Return an empty string to ignore the option deprecation.

The closure is invoked when resolve() is called. The parameter passed to the closure is the value of the option after validating it and before normalizing it.

Paramètres
string | $package | The name of the composer package that is triggering the deprecation
string | $version | The version of the package that introduced the deprecation
string | \Closure | $message | The deprecation message to use
Renvoie
$this

Références $message, $option, $this, $version, et OptionsResolver\formatOptions().

◆ setInfo()

setInfo | ( | string | $option,
 |  | string | $info
 | ) |  |

Sets an info message for an option.

Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références OptionsResolver\$info, $option, $this, et OptionsResolver\formatOptions().

◆ setNormalizer()

setNormalizer | ( | string | $option,
 |  | \Closure | $normalizer
 | ) |  |

Sets the normalizer for an option.

The normalizer should be a closure with the following signature:

function (Options $options, $value) {
    // ...
}

The closure is invoked when resolve() is called. The closure has access to the resolved values of other options through the passed Options instance.

The second parameter passed to the closure is the value of the option.

The resolved option value is set to the return value of the closure.

Renvoie
$this
Exceptions
UndefinedOptionsException | If the option is undefined
AccessException | If called from a lazy option or normalizer

Références $option, $this, et OptionsResolver\formatOptions().

◆ setPrototype()

setPrototype ( bool $prototype )

Marks the whole options definition as array prototype.

Renvoie
$this
Exceptions
AccessException If called from a lazy option, a normalizer or a root definition

Références OptionsResolver\$prototype, $this, et null.

◆ setRequired()

setRequired ( $optionNames )

Marks one or more options as required.

Paramètres
string|string[] $optionNames One or more option names
Renvoie
$this
Exceptions
AccessException If called from a lazy option or normalizer

Références $option, et $this.

Référencé par SessionFactory\configureSessionHandlerOptions().

◆ verifyTypes()

verifyTypes | ( | string | $type,
 |  |  | $value,
 |  | array & | $invalidTypes,
 |  | int | $level = 0
 | ) |  |
private

Références $type, $val, $value, et null.

Référencé par OptionsResolver\offsetGet().

Documentation des champs

◆ $allowedTypes

$allowedTypes = []
private

A list of accepted types for each option.

Référencé par OptionsResolver\addAllowedTypes(), et OptionsResolver\setAllowedTypes().

◆ $allowedValues

$allowedValues = []
private

A list of accepted values for each option.

Référencé par OptionsResolver\addAllowedValues(), et OptionsResolver\setAllowedValues().

◆ $calling

$calling = []
private

A list of lazy options whose closure is currently being called.

This list helps detecting circular dependencies between lazy options.

◆ $defaults

$defaults = []
private

The default option values.

Référencé par OptionsResolver\setDefaults().

◆ $defined

const $defined = []
private

The names of all defined options.

◆ $deprecated

$deprecated = []
private

A list of deprecated options.

◆ $given

$given = []
private

The list of options provided by the user.

◆ $info

$info = []
private

A list of info messages for each option.

Référencé par OptionsResolver\setInfo().

◆ $lazy

$lazy = []
private

A list of closures for evaluating lazy options.

◆ $locked

$locked = false
private

Whether the instance is locked for reading.

Once locked, the options cannot be changed anymore. This is necessary in order to avoid inconsistencies during the resolving process. If any option is changed after being read, all evaluated lazy options that depend on this option would become invalid.

◆ $nested

$nested = []
private

◆ $normalizers

$normalizers = []
private

◆ $parentsOptions

$parentsOptions = []
private

Référencé par OptionsResolver\offsetGet().

◆ $prototype

$prototype
private

Whether the whole options definition is marked as array prototype.

Référencé par OptionsResolver\setPrototype().

◆ $prototypeIndex

$prototypeIndex
private

The prototype array's index that is being read.

◆ $required

$required = []
private

The names of required options.

◆ $resolved

$resolved = []
private

The resolved option values.

◆ VALIDATION_FUNCTIONS

const VALIDATION_FUNCTIONS
private
Valeur initiale :
= [
'bool' => 'is_bool'
La documentation de cette classe a été générée à partir du fichier suivant :
  • OptionsResolver.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Symfony
  • Component
  • String
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
InvalidArgumentException RuntimeException
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/string/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Symfony
  • Component
  • String
  • Exception
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
ExceptionInterface
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/string/Exception/InvalidArgumentException.php


Joomla CMS: Référence de la classe RuntimeException

  • Symfony
  • Component
  • String
  • Exception
  • RuntimeException
Référence de la classe RuntimeException
+ Graphe d'héritage de RuntimeException:
ExceptionInterface
La documentation de cette classe a été générée à partir du fichier suivant :
  • string/Exception/RuntimeException.php


Joomla CMS: Référence de la classe EnglishInflector

  • Symfony
  • Component
  • String
  • Inflector
  • EnglishInflector
Fonctions membres publiques | Attributs privés
Référence de la classe EnglishInflector
+ Graphe d'héritage de EnglishInflector:
InflectorInterface

Fonctions membres publiques

singularize (string $plural)
pluralize (string $singular)

Attributs privés

const | PLURAL_MAP
const | SINGULAR_MAP
const | UNINFLECTED

Documentation des fonctions membres

◆ pluralize()

pluralize ( string $singular )

{Returns the plural forms of a string.If the method can't determine the form with certainty, several possible plurals are returned.

Renvoie
string[]
}

Implémente InflectorInterface.

Références $suffix.

◆ singularize()

singularize ( string $plural )

{Returns the singular forms of a string.If the method can't determine the form with certainty, several possible singulars are returned.

Renvoie
string[]
}

Implémente InflectorInterface.

Références $suffix.

Documentation des champs

◆ PLURAL_MAP

const PLURAL_MAP
private

Map English plural to singular suffixes.

Voir également
http://english-zone.com/spelling/plurals.html

◆ SINGULAR_MAP

const SINGULAR_MAP
private

Map English singular to plural suffixes.

Voir également
http://english-zone.com/spelling/plurals.html

◆ UNINFLECTED

const UNINFLECTED
private
Valeur initiale :
= [
'',
'atad',
'reed',
'kcabdeef',
'hsif',
'ofni',
'esoom',
'seires',
'peehs',
'seiceps',
]

A list of words which should not be inflected, reversed.

La documentation de cette classe a été générée à partir du fichier suivant :
  • EnglishInflector.php


Joomla CMS: Référence de la classe FrenchInflector

  • Symfony
  • Component
  • String
  • Inflector
  • FrenchInflector
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FrenchInflector
+ Graphe d'héritage de FrenchInflector:
InflectorInterface

Fonctions membres publiques

singularize (string $plural)
pluralize (string $singular)

Fonctions membres privées

isInflectedWord (string $word)

Attributs privés

const | PLURALIZE_REGEXP
const | SINGULARIZE_REGEXP
const | UNINFLECTED = '/^(abcès|accès|abus|albatros|anchois|anglais|autobus|bois|brebis|carquois|cas|chas|colis|concours|corps|cours|cyprès|décès|devis|discours|dos|embarras|engrais|entrelacs|excès|fils|fois|gâchis|gars|glas|héros|intrus|jars|jus|kermès|lacis|legs|lilas|marais|mars|matelas|mépris|mets|mois|mors|obus|os|palais|paradis|parcours|pardessus|pays|plusieurs|poids|pois|pouls|printemps|processus|progrès|puits|pus|rabais|radis|recors|recours|refus|relais|remords|remous|rictus|rhinocéros|repas|rubis|sas|secours|sens|souris|succès|talus|tapis|tas|taudis|temps|tiers|univers|velours|verglas|vernis|virus)$/i'

Description détaillée

French inflector.

This class does only inflect nouns; not adjectives nor composed words like "soixante-dix".

Documentation des fonctions membres

◆ isInflectedWord()

isInflectedWord ( string $word )
private

Référencé par FrenchInflector\pluralize(), et FrenchInflector\singularize().

◆ pluralize()

pluralize ( string $singular )

{Returns the plural forms of a string.If the method can't determine the form with certainty, several possible plurals are returned.

Renvoie
string[]
}

Implémente InflectorInterface.

Références FrenchInflector\isInflectedWord().

◆ singularize()

singularize ( string $plural )

{Returns the singular forms of a string.If the method can't determine the form with certainty, several possible singulars are returned.

Renvoie
string[]
}

Implémente InflectorInterface.

Références FrenchInflector\isInflectedWord().

Documentation des champs

◆ PLURALIZE_REGEXP

const PLURALIZE_REGEXP
private

A list of all rules for pluralise.

Voir également
https://la-conjugaison.nouvelobs.com/regles/grammaire/le-pluriel-des-noms-121.php

◆ SINGULARIZE_REGEXP

const SINGULARIZE_REGEXP
private

A list of all rules for singularize.

◆ UNINFLECTED

const UNINFLECTED = '/^(abcès|accès|abus|albatros|anchois|anglais|autobus|bois|brebis|carquois|cas|chas|colis|concours|corps|cours|cyprès|décès|devis|discours|dos|embarras|engrais|entrelacs|excès|fils|fois|gâchis|gars|glas|héros|intrus|jars|jus|kermès|lacis|legs|lilas|marais|mars|matelas|mépris|mets|mois|mors|obus|os|palais|paradis|parcours|pardessus|pays|plusieurs|poids|pois|pouls|printemps|processus|progrès|puits|pus|rabais|radis|recors|recours|refus|relais|remords|remous|rictus|rhinocéros|repas|rubis|sas|secours|sens|souris|succès|talus|tapis|tas|taudis|temps|tiers|univers|velours|verglas|vernis|virus)$/i'
private

A list of words which should not be inflected. This list is only used by singularize.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FrenchInflector.php


Joomla CMS: Référence de l'interface InflectorInterface

  • Symfony
  • Component
  • String
  • Inflector
  • InflectorInterface
Fonctions membres publiques
Référence de l'interface InflectorInterface
+ Graphe d'héritage de InflectorInterface:
EnglishInflector FrenchInflector

Fonctions membres publiques

singularize (string $plural)
pluralize (string $singular)

Documentation des fonctions membres

◆ pluralize()

pluralize ( string $singular )

Returns the plural forms of a string.

If the method can't determine the form with certainty, several possible plurals are returned.

Renvoie
string[]

Implémenté dans EnglishInflector, et FrenchInflector.

◆ singularize()

singularize ( string $plural )

Returns the singular forms of a string.

If the method can't determine the form with certainty, several possible singulars are returned.

Renvoie
string[]

Implémenté dans EnglishInflector, et FrenchInflector.

La documentation de cette interface a été générée à partir du fichier suivant :
  • InflectorInterface.php


Joomla CMS: Référence de la classe AsciiSlugger

  • Symfony
  • Component
  • String
  • Slugger
  • AsciiSlugger
Fonctions membres publiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe AsciiSlugger
+ Graphe d'héritage de AsciiSlugger:
SluggerInterface

Fonctions membres publiques

__construct (string $defaultLocale=null, $symbolsMap=null)
setLocale ($locale)
getLocale ()
slug (string $string, string $separator='-', string $locale=null)

Fonctions membres privées

createTransliterator (string $locale)

Fonctions membres privées statiques

static getParentLocale (?string $locale)

Attributs privés

const | LOCALE_TO_TRANSLITERATOR_ID
const | $defaultLocale
$symbolsMap
$transliterators = []

Description détaillée

Auteur
Titouan Galopin galop.nosp@m.inti.nosp@m.touan.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $defaultLocale = null,
 |  |  | $symbolsMap = null
 | ) |  |
Paramètres
array | \Closure | null $symbolsMap

Références AsciiSlugger\$defaultLocale, AsciiSlugger\$symbolsMap, et null.

Documentation des fonctions membres

◆ createTransliterator()

createTransliterator ( string $locale )
private

Références $id, et null.

Référencé par AsciiSlugger\slug().

◆ getLocale()

getLocale ( )

{}

Références AsciiSlugger\$defaultLocale.

◆ getParentLocale()

static getParentLocale ( ?string $locale )
staticprivate

Références null.

◆ setLocale()

setLocale ( $locale )

{}

◆ slug()

slug | ( | string | $string,
 |  | string | $separator = '-',
 |  | string | $locale = null
 | ) |  |

{Creates a slug for the given string and locale, using appropriate transliteration when needed.}

Implémente SluggerInterface.

Références AsciiSlugger\$defaultLocale, $separator, AsciiSlugger\$symbolsMap, AsciiSlugger\createTransliterator(), elseif, et null.

Documentation des champs

◆ $defaultLocale

const $defaultLocale
private
Valeur initiale :
=> 'Arabic-Latin',
'az' => 'Azerbaijani-Latin',
'be' => 'Belarusian-Latin',
'bg' => 'Bulgarian-Latin',
'bn' => 'Bengali-Latin',
'de' => 'de-ASCII',
'el' => 'Greek-Latin',
'fa' => 'Persian-Latin',
'he' => 'Hebrew-Latin',
'hy' => 'Armenian-Latin',
'ka' => 'Georgian-Latin',
'kk' => 'Kazakh-Latin',
'ky' => 'Kirghiz-Latin',
'ko' => 'Korean-Latin',
'mk' => 'Macedonian-Latin',
'mn' => 'Mongolian-Latin',
'or' => 'Oriya-Latin',
'ps' => 'Pashto-Latin',
'ru' => 'Russian-Latin',
'sr' => 'Serbian-Latin',
'sr_Cyrl' => 'Serbian-Latin',
'th' => 'Thai-Latin',
'tk' => 'Turkmen-Latin',
'uk' => 'Ukrainian-Latin',
'uz' => 'Uzbek-Latin',
'zh' => 'Han-Latin',
]

Référencé par AsciiSlugger\__construct(), AsciiSlugger\getLocale(), et AsciiSlugger\slug().

◆ $symbolsMap

$symbolsMap
private
Valeur initiale :
= [
'en' => ['@' => 'at'

Référencé par AsciiSlugger\__construct(), et AsciiSlugger\slug().

◆ $transliterators

$transliterators = []
private

◆ LOCALE_TO_TRANSLITERATOR_ID

const LOCALE_TO_TRANSLITERATOR_ID
private
Valeur initiale :
= [
'am' => 'Amharic-Latin'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AsciiSlugger.php


Joomla CMS: Référence de l'interface SluggerInterface

  • Symfony
  • Component
  • String
  • Slugger
  • SluggerInterface
Fonctions membres publiques
Référence de l'interface SluggerInterface
+ Graphe d'héritage de SluggerInterface:
AsciiSlugger

Fonctions membres publiques

slug (string $string, string $separator='-', string $locale=null)

Description détaillée

Creates a URL-friendly slug from a given string.

Auteur
Titouan Galopin galop.nosp@m.inti.nosp@m.touan.nosp@m.@gma.nosp@m.il.co.nosp@m.m

Documentation des fonctions membres

◆ slug()

slug | ( | string | $string,
 |  | string | $separator = '-',
 |  | string | $locale = null
 | ) |  |

Creates a slug for the given string and locale, using appropriate transliteration when needed.

Implémenté dans AsciiSlugger.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SluggerInterface.php


Joomla CMS: Référence de la classe AbstractString

  • Symfony
  • Component
  • String
  • AbstractString
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés
Référence de la classe AbstractString
+ Graphe d'héritage de AbstractString:
AbstractUnicodeString ByteString CodePointString UnicodeString

Fonctions membres publiques

__construct (string $string='')
after ($needle, bool $includeNeedle=false, int $offset=0)
afterLast ($needle, bool $includeNeedle=false, int $offset=0)
append (string ... $suffix)
before ($needle, bool $includeNeedle=false, int $offset=0)
beforeLast ($needle, bool $includeNeedle=false, int $offset=0)
bytesAt (int $offset)
camel ()
chunk (int $length=1)
collapseWhitespace ()
containsAny ($needle)
endsWith ($suffix)
ensureEnd (string $suffix)
ensureStart (string $prefix)
equalsTo ($string)
folded ()
ignoreCase ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isEmpty ()
join (array $strings, string $lastGlue=null)
jsonSerialize ()
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
repeat (int $multiplier)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toByteString (string $toEncoding=null)
toCodePointString ()
toString ()
toUnicodeString ()
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
truncate (int $length, string $ellipsis='', bool $cut=true)
upper ()
width (bool $ignoreAnsiDecoration=true)
wordwrap (int $width=75, string $break="\, bool $cut=false)
__sleep ()
__clone ()
__toString ()

Fonctions membres publiques statiques

static | unwrap (array $values)
static | wrap (array $values)

Champs de données

const | PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER
const | PREG_SET_ORDER = \PREG_SET_ORDER
const | PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE
const | PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL
const | PREG_SPLIT = 0
const | PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY
const | PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE
const | PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE

Attributs protégés

$string = ''
$ignoreCase = false

Description détaillée

Represents a string of abstract characters.

Unicode defines 3 types of "characters" (bytes, code points and grapheme clusters). This class is the abstract type to use as a type-hint when the logic you want to implement doesn't care about the exact variant it deals with.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Hugo Hamon hugoh.nosp@m.amon.nosp@m.@neuf.nosp@m..fr
Exceptions
ExceptionInterface

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $string = '' )
abstract

Documentation des fonctions membres

◆ __clone()

__clone ( )

Références AbstractString\ignoreCase().

◆ __sleep()

__sleep ( )

◆ __toString()

__toString ( )

Références AbstractString\$string.

◆ after()

after | ( |  | $needle,
 |  | bool | $includeNeedle = false,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle
Renvoie
static

Références $i, $n, Joomla\Database\Query\$offset, $this, AbstractString\indexOf(), null, et AbstractString\slice().

◆ afterLast()

afterLast | ( |  | $needle,
 |  | bool | $includeNeedle = false,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle
Renvoie
static

Références $i, $n, Joomla\Database\Query\$offset, $this, AbstractString\indexOfLast(), null, et AbstractString\slice().

◆ append()

append ( string ... $suffix )
abstract
Renvoie
static

Référencé par AbstractString\ensureEnd().

◆ before()

before | ( |  | $needle,
 |  | bool | $includeNeedle = false,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle
Renvoie
static

Références $i, $n, Joomla\Database\Query\$offset, $this, AbstractString\indexOf(), null, et AbstractString\slice().

◆ beforeLast()

beforeLast | ( |  | $needle,
 |  | bool | $includeNeedle = false,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle
Renvoie
static

Références $i, $n, Joomla\Database\Query\$offset, $this, AbstractString\indexOfLast(), null, et AbstractString\slice().

◆ bytesAt()

bytesAt ( int $offset )
Renvoie
int[]

Références AbstractString\slice().

◆ camel()

camel ( )
abstract
Renvoie
static

◆ chunk()

chunk ( int $length = 1 )
abstract
Renvoie
static[]

◆ collapseWhitespace()

collapseWhitespace ( )
Renvoie
static

Références $this, et AbstractString\trim().

◆ containsAny()

containsAny ( $needle )
Paramètres
string|string[] $needle

Références AbstractString\indexOf(), et null.

◆ endsWith()

endsWith ( $suffix )
Paramètres
string|string[] $suffix

Références $suffix, et class.

Référencé par AbstractString\ensureEnd().

◆ ensureEnd()

ensureEnd ( string $suffix )
Renvoie
static

Références $suffix, AbstractString\append(), AbstractString\endsWith(), et AbstractString\replaceMatches().

◆ ensureStart()

ensureStart ( string $prefix )
Renvoie
static

Références $i, $prefix, $this, AbstractString\indexOf(), AbstractString\prepend(), et AbstractString\startsWith().

◆ equalsTo()

equalsTo ( $string )
Paramètres
string|string[] $string

Références AbstractString\$string, et class.

◆ folded()

folded ( )
abstract
Renvoie
static

◆ ignoreCase()

ignoreCase ( )
Renvoie
static

Références $this.

Référencé par UnicodeString\__clone(), AbstractString\__clone(), CodePointString\endsWith(), UnicodeString\endsWith(), ByteString\endsWith(), CodePointString\equalsTo(), UnicodeString\equalsTo(), ByteString\equalsTo(), CodePointString\indexOf(), UnicodeString\indexOf(), ByteString\indexOf(), CodePointString\indexOfLast(), UnicodeString\indexOfLast(), ByteString\indexOfLast(), ByteString\match(), CodePointString\replace(), UnicodeString\replace(), ByteString\replace(), ByteString\replaceMatches(), CodePointString\split(), UnicodeString\split(), ByteString\split(), AbstractString\split(), CodePointString\startsWith(), UnicodeString\startsWith(), ByteString\startsWith(), AbstractString\trimPrefix(), et AbstractString\trimSuffix().

◆ indexOf()

indexOf | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle

Références $i, $n, Joomla\Database\Query\$offset, class, et null.

Référencé par AbstractString\after(), AbstractString\before(), AbstractString\containsAny(), AbstractString\ensureStart(), et AbstractString\truncate().

◆ indexOfLast()

indexOfLast | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |
Paramètres
string|string[] $needle

Références $i, $n, Joomla\Database\Query\$offset, class, et null.

Référencé par AbstractString\afterLast(), et AbstractString\beforeLast().

◆ isEmpty()

isEmpty ( )

Références AbstractString\$string.

◆ join()

join | ( | array | $strings,
 |  | string | $lastGlue = null
 | ) |  |
abstract
Renvoie
static

◆ jsonSerialize()

jsonSerialize ( )

Références AbstractString\$string.

◆ length()

length ( )
abstract

Référencé par AbstractString\truncate().

◆ lower()

lower ( )
abstract
Renvoie
static

◆ match()

match | ( | string | $regexp,
 |  | int | $flags = 0,
 |  | int | $offset = 0
 | ) |  |
abstract

Matches the string using a regular expression.

Pass PREG_PATTERN_ORDER or PREG_SET_ORDER as $flags to get all occurrences matching the regular expression.

Renvoie
array All matches in a multi-dimensional array ordered according to flags

◆ padBoth()

padBoth | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |
abstract
Renvoie
static

◆ padEnd()

padEnd | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |
abstract
Renvoie
static

◆ padStart()

padStart | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |
abstract
Renvoie
static

◆ prepend()

prepend ( string ... $prefix )
abstract
Renvoie
static

Référencé par AbstractString\ensureStart().

◆ repeat()

repeat ( int $multiplier )
Renvoie
static

Références $this.

◆ replace()

replace | ( | string | $from,
 |  | string | $to
 | ) |  |
abstract
Renvoie
static

◆ replaceMatches()

replaceMatches | ( | string | $fromRegexp,
 |  |  | $to
 | ) |  |
abstract
Paramètres
string | callable $to
Renvoie
static

Référencé par AbstractString\ensureEnd().

◆ reverse()

reverse ( )
abstract
Renvoie
static

◆ slice()

slice | ( | int | $start = 0,
 |  | int | $length = null
 | ) |  |
abstract
Renvoie
static

Référencé par AbstractString\after(), AbstractString\afterLast(), AbstractString\before(), AbstractString\beforeLast(), AbstractString\bytesAt(), et AbstractString\truncate().

◆ snake()

snake ( )
abstract
Renvoie
static

◆ splice()

splice | ( | string | $replacement,
 |  | int | $start = 0,
 |  | int | $length = null
 | ) |  |
abstract
Renvoie
static

◆ split()

split | ( | string | $delimiter,
 |  | int | $limit = null,
 |  | int | $flags = null
 | ) |  |
Renvoie
static[]

Références $limit, $this, AbstractString\ignoreCase(), et null.

Référencé par AbstractString\wordwrap().

◆ startsWith()

startsWith ( $prefix )
Paramètres
string|string[] $prefix

Références $prefix, et class.

Référencé par AbstractString\ensureStart().

◆ title()

title ( bool $allWords = false )
abstract
Renvoie
static

◆ toByteString()

toByteString ( string $toEncoding = null )

Références $b, AbstractString\$string, $this, et null.

◆ toCodePointString()

toCodePointString ( )

Référencé par ByteString\toUnicodeString().

◆ toString()

toString ( )

Références AbstractString\$string.

◆ toUnicodeString()

toUnicodeString ( )

◆ trim()

trim ( string $chars = " \\\B\C\A0}\FEFF}" )
abstract
Renvoie
static

Référencé par AbstractString\collapseWhitespace().

◆ trimEnd()

trimEnd ( string $chars = " \\\B\C\A0}\FEFF}" )
abstract
Renvoie
static

◆ trimPrefix()

trimPrefix ( $prefix )
Paramètres
string|string[] $prefix
Renvoie
static

Références $prefix, $this, et AbstractString\ignoreCase().

◆ trimStart()

trimStart ( string $chars = " \\\B\C\A0}\FEFF}" )
abstract
Renvoie
static

◆ trimSuffix()

trimSuffix ( $suffix )
Paramètres
string|string[] $suffix
Renvoie
static

Références $suffix, $this, AbstractString\ignoreCase(), et null.

◆ truncate()

truncate | ( | int | $length,
 |  | string | $ellipsis = '',
 |  | bool | $cut = true
 | ) |  |
Renvoie
static

Références $this, AbstractString\indexOf(), AbstractString\length(), null, et AbstractString\slice().

◆ unwrap()

static unwrap ( array $values )
static

Unwraps instances of AbstractString back to strings.

Renvoie
string[]|array

Références elseif.

◆ upper()

upper ( )
abstract
Renvoie
static

◆ width()

width ( bool $ignoreAnsiDecoration = true )
abstract

Returns the printable length on a terminal.

◆ wordwrap()

wordwrap | ( | int | $width = 75,
 |  | string | $break = "\n",
 |  | bool | $cut = false
 | ) |  |
Renvoie
static

Références $b, $i, AbstractString\$string, $this, $width, et AbstractString\split().

◆ wrap()

static wrap ( array $values )
static

Wraps (and normalizes) strings in instances of AbstractString.

Renvoie
static[]|array

Références $i, elseif, et null.

Documentation des champs

◆ $ignoreCase

$ignoreCase = false
protected

◆ $string

$string = ''
protected

Référencé par CodePointString\__construct(), ByteString\__construct(), UnicodeString\__construct(), AbstractString\__toString(), CodePointString\equalsTo(), UnicodeString\equalsTo(), ByteString\equalsTo(), AbstractString\equalsTo(), AbstractUnicodeString\fromCodePoints(), UnicodeString\indexOfLast(), AbstractString\isEmpty(), AbstractString\jsonSerialize(), ByteString\replaceMatches(), UnicodeString\split(), AbstractString\toByteString(), ByteString\toCodePointString(), AbstractString\toString(), ByteString\width(), et AbstractString\wordwrap().

◆ PREG_OFFSET_CAPTURE

const PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE

◆ PREG_PATTERN_ORDER

const PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER

Référencé par ByteString\match().

◆ PREG_SET_ORDER

const PREG_SET_ORDER = \PREG_SET_ORDER

Référencé par ByteString\match().

◆ PREG_SPLIT

const PREG_SPLIT = 0

◆ PREG_SPLIT_DELIM_CAPTURE

const PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE

Référencé par CodePointString\chunk(), et UnicodeString\chunk().

◆ PREG_SPLIT_NO_EMPTY

const PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY

Référencé par CodePointString\chunk(), et UnicodeString\chunk().

◆ PREG_SPLIT_OFFSET_CAPTURE

const PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE

◆ PREG_UNMATCHED_AS_NULL

const PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL

Référencé par ByteString\match().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/string/AbstractString.php


Joomla CMS: Référence de la classe AbstractUnicodeString

  • Symfony
  • Component
  • String
  • AbstractUnicodeString
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe AbstractUnicodeString
+ Graphe d'héritage de AbstractUnicodeString:
AbstractString CodePointString UnicodeString

Fonctions membres publiques

ascii (array $rules=[])
camel ()
codePointsAt (int $offset)
folded (bool $compat=true)
join (array $strings, string $lastGlue=null)
lower ()
match (string $regexp, int $flags=0, int $offset=0)
normalize (int $form=self::NFC)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
replaceMatches (string $fromRegexp, $to)
reverse ()
snake ()
title (bool $allWords=false)
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
upper ()
width (bool $ignoreAnsiDecoration=true)
- Fonctions membres publiques hérités de AbstractString
__construct (string $string='')
after ($needle, bool $includeNeedle=false, int $offset=0)
afterLast ($needle, bool $includeNeedle=false, int $offset=0)
append (string ... $suffix)
before ($needle, bool $includeNeedle=false, int $offset=0)
beforeLast ($needle, bool $includeNeedle=false, int $offset=0)
bytesAt (int $offset)
camel ()
chunk (int $length=1)
collapseWhitespace ()
containsAny ($needle)
endsWith ($suffix)
ensureEnd (string $suffix)
ensureStart (string $prefix)
equalsTo ($string)
folded ()
ignoreCase ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isEmpty ()
join (array $strings, string $lastGlue=null)
jsonSerialize ()
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
repeat (int $multiplier)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toByteString (string $toEncoding=null)
toCodePointString ()
toString ()
toUnicodeString ()
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
truncate (int $length, string $ellipsis='', bool $cut=true)
upper ()
width (bool $ignoreAnsiDecoration=true)
wordwrap (int $width=75, string $break="\, bool $cut=false)
__sleep ()
__clone ()
__toString ()

Fonctions membres publiques statiques

static | fromCodePoints (int ... $codes)
- Fonctions membres publiques statiques hérités de AbstractString
static | unwrap (array $values)
static | wrap (array $values)

Champs de données

const | NFC = \Normalizer::NFC
const | NFD = \Normalizer::NFD
const | NFKC = \Normalizer::NFKC
const | NFKD = \Normalizer::NFKD
- Champs de données hérités de AbstractString
const | PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER
const | PREG_SET_ORDER = \PREG_SET_ORDER
const | PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE
const | PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL
const | PREG_SPLIT = 0
const | PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY
const | PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE
const | PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE

Fonctions membres privées

pad (int $len, self $pad, int $type)
wcswidth (string $string)

Attributs privés

const | ASCII = "\x20\x65\x69\x61\x73\x6E\x74\x72\x6F\x6C\x75\x64\x5D\x5B\x63\x6D\x70\x27\x0A\x67\x7C\x68\x76\x2E\x66\x62\x2C\x3A\x3D\x2D\x71\x31\x30\x43\x32\x2A\x79\x78\x29\x28\x4C\x39\x41\x53\x2F\x50\x22\x45\x6A\x4D\x49\x6B\x33\x3E\x35\x54\x3C\x44\x34\x7D\x42\x7B\x38\x46\x77\x52\x36\x37\x55\x47\x4E\x3B\x4A\x7A\x56\x23\x48\x4F\x57\x5F\x26\x21\x4B\x3F\x58\x51\x25\x59\x5C\x09\x5A\x2B\x7E\x5E\x24\x40\x60\x7F\x00\x01\x02\x03\x04\x05\x06\x07\x08\x0B\x0C\x0D\x0E\x0F\x10\x11\x12\x13\x14\x15\x16\x17\x18\x19\x1A\x1B\x1C\x1D\x1E\x1F"
const | FOLD_FROM = ['İ', 'µ', 'ſ', "\xCD\x85", 'ς', 'ϐ', 'ϑ', 'ϕ', 'ϖ', 'ϰ', 'ϱ', 'ϵ', 'ẛ', "\xE1\xBE\xBE", 'ß', 'İ', 'ŉ', 'ǰ', 'ΐ', 'ΰ', 'և', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'ẚ', 'ẞ', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ᾀ', 'ᾁ', 'ᾂ', 'ᾃ', 'ᾄ', 'ᾅ', 'ᾆ', 'ᾇ', 'ᾈ', 'ᾉ', 'ᾊ', 'ᾋ', 'ᾌ', 'ᾍ', 'ᾎ', 'ᾏ', 'ᾐ', 'ᾑ', 'ᾒ', 'ᾓ', 'ᾔ', 'ᾕ', 'ᾖ', 'ᾗ', 'ᾘ', 'ᾙ', 'ᾚ', 'ᾛ', 'ᾜ', 'ᾝ', 'ᾞ', 'ᾟ', 'ᾠ', 'ᾡ', 'ᾢ', 'ᾣ', 'ᾤ', 'ᾥ', 'ᾦ', 'ᾧ', 'ᾨ', 'ᾩ', 'ᾪ', 'ᾫ', 'ᾬ', 'ᾭ', 'ᾮ', 'ᾯ', 'ᾲ', 'ᾳ', 'ᾴ', 'ᾶ', 'ᾷ', 'ᾼ', 'ῂ', 'ῃ', 'ῄ', 'ῆ', 'ῇ', 'ῌ', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ῲ', 'ῳ', 'ῴ', 'ῶ', 'ῷ', 'ῼ', 'ﬀ', 'ﬁ', 'ﬂ', 'ﬃ', 'ﬄ', 'ﬅ', 'ﬆ', 'ﬓ', 'ﬔ', 'ﬕ', 'ﬖ', 'ﬗ']
const | FOLD_TO = ['i̇', 'μ', 's', 'ι', 'σ', 'β', 'θ', 'φ', 'π', 'κ', 'ρ', 'ε', 'ṡ', 'ι', 'ss', 'i̇', 'ʼn', 'ǰ', 'ΐ', 'ΰ', 'եւ', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'aʾ', 'ss', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ἀι', 'ἁι', 'ἂι', 'ἃι', 'ἄι', 'ἅι', 'ἆι', 'ἇι', 'ἀι', 'ἁι', 'ἂι', 'ἃι', 'ἄι', 'ἅι', 'ἆι', 'ἇι', 'ἠι', 'ἡι', 'ἢι', 'ἣι', 'ἤι', 'ἥι', 'ἦι', 'ἧι', 'ἠι', 'ἡι', 'ἢι', 'ἣι', 'ἤι', 'ἥι', 'ἦι', 'ἧι', 'ὠι', 'ὡι', 'ὢι', 'ὣι', 'ὤι', 'ὥι', 'ὦι', 'ὧι', 'ὠι', 'ὡι', 'ὢι', 'ὣι', 'ὤι', 'ὥι', 'ὦι', 'ὧι', 'ὰι', 'αι', 'άι', 'ᾶ', 'ᾶι', 'αι', 'ὴι', 'ηι', 'ήι', 'ῆ', 'ῆι', 'ηι', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ὼι', 'ωι', 'ώι', 'ῶ', 'ῶι', 'ωι', 'ff', 'fi', 'fl', 'ffi', 'ffl', 'st', 'st', 'մն', 'մե', 'մի', 'վն', 'մխ']
const | UPPER_FROM = ['ß', 'ﬀ', 'ﬁ', 'ﬂ', 'ﬃ', 'ﬄ', 'ﬅ', 'ﬆ', 'և', 'ﬓ', 'ﬔ', 'ﬕ', 'ﬖ', 'ﬗ', 'ŉ', 'ΐ', 'ΰ', 'ǰ', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'ẚ', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ᾶ', 'ῆ', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ῶ']
const | UPPER_TO = ['SS', 'FF', 'FI', 'FL', 'FFI', 'FFL', 'ST', 'ST', 'ԵՒ', 'ՄՆ', 'ՄԵ', 'ՄԻ', 'ՎՆ', 'ՄԽ', 'ʼN', 'Ϊ́', 'Ϋ́', 'J̌', 'H̱', 'T̈', 'W̊', 'Y̊', 'Aʾ', 'Υ̓', 'Υ̓̀', 'Υ̓́', 'Υ̓͂', 'Α͂', 'Η͂', 'Ϊ̀', 'Ϊ́', 'Ι͂', 'Ϊ͂', 'Ϋ̀', 'Ϋ́', 'Ρ̓', 'Υ͂', 'Ϋ͂', 'Ω͂']
const | TRANSLIT_FROM = ['Æ', 'Ð', 'Ø', 'Þ', 'ß', 'æ', 'ð', 'ø', 'þ', 'Đ', 'đ', 'Ħ', 'ħ', 'ı', 'ĸ', 'Ŀ', 'ŀ', 'Ł', 'ł', 'ŉ', 'Ŋ', 'ŋ', 'Œ', 'œ', 'Ŧ', 'ŧ', 'ƀ', 'Ɓ', 'Ƃ', 'ƃ', 'Ƈ', 'ƈ', 'Ɖ', 'Ɗ', 'Ƌ', 'ƌ', 'Ɛ', 'Ƒ', 'ƒ', 'Ɠ', 'ƕ', 'Ɩ', 'Ɨ', 'Ƙ', 'ƙ', 'ƚ', 'Ɲ', 'ƞ', 'Ƣ', 'ƣ', 'Ƥ', 'ƥ', 'ƫ', 'Ƭ', 'ƭ', 'Ʈ', 'Ʋ', 'Ƴ', 'ƴ', 'Ƶ', 'ƶ', 'Ǆ', 'ǅ', 'ǆ', 'Ǥ', 'ǥ', 'ȡ', 'Ȥ', 'ȥ', 'ȴ', 'ȵ', 'ȶ', 'ȷ', 'ȸ', 'ȹ', 'Ⱥ', 'Ȼ', 'ȼ', 'Ƚ', 'Ⱦ', 'ȿ', 'ɀ', 'Ƀ', 'Ʉ', 'Ɇ', 'ɇ', 'Ɉ', 'ɉ', 'Ɍ', 'ɍ', 'Ɏ', 'ɏ', 'ɓ', 'ɕ', 'ɖ', 'ɗ', 'ɛ', 'ɟ', 'ɠ', 'ɡ', 'ɢ', 'ɦ', 'ɧ', 'ɨ', 'ɪ', 'ɫ', 'ɬ', 'ɭ', 'ɱ', 'ɲ', 'ɳ', 'ɴ', 'ɶ', 'ɼ', 'ɽ', 'ɾ', 'ʀ', 'ʂ', 'ʈ', 'ʉ', 'ʋ', 'ʏ', 'ʐ', 'ʑ', 'ʙ', 'ʛ', 'ʜ', 'ʝ', 'ʟ', 'ʠ', 'ʣ', 'ʥ', 'ʦ', 'ʪ', 'ʫ', 'ᴀ', 'ᴁ', 'ᴃ', 'ᴄ', 'ᴅ', 'ᴆ', 'ᴇ', 'ᴊ', 'ᴋ', 'ᴌ', 'ᴍ', 'ᴏ', 'ᴘ', 'ᴛ', 'ᴜ', 'ᴠ', 'ᴡ', 'ᴢ', 'ᵫ', 'ᵬ', 'ᵭ', 'ᵮ', 'ᵯ', 'ᵰ', 'ᵱ', 'ᵲ', 'ᵳ', 'ᵴ', 'ᵵ', 'ᵶ', 'ᵺ', 'ᵻ', 'ᵽ', 'ᵾ', 'ᶀ', 'ᶁ', 'ᶂ', 'ᶃ', 'ᶄ', 'ᶅ', 'ᶆ', 'ᶇ', 'ᶈ', 'ᶉ', 'ᶊ', 'ᶌ', 'ᶍ', 'ᶎ', 'ᶏ', 'ᶑ', 'ᶒ', 'ᶓ', 'ᶖ', 'ᶙ', 'ẚ', 'ẜ', 'ẝ', 'ẞ', 'Ỻ', 'ỻ', 'Ỽ', 'ỽ', 'Ỿ', 'ỿ', '©', '®', '₠', '₢', '₣', '₤', '₧', '₺', '₹', 'ℌ', '℞', '㎧', '㎮', '㏆', '㏗', '㏞', '㏟', '¼', '½', '¾', '⅓', '⅔', '⅕', '⅖', '⅗', '⅘', '⅙', '⅚', '⅛', '⅜', '⅝', '⅞', '⅟', '〇', '‘', '’', '‚', '‛', '“', '”', '„', '‟', '′', '″', '〝', '〞', '«', '»', '‹', '›', '‐', '‑', '‒', '–', '—', '―', '︱', '︲', '﹘', '‖', '⁄', '⁅', '⁆', '⁎', '、', '。', '〈', '〉', '《', '》', '〔', '〕', '〘', '〙', '〚', '〛', '︑', '︒', '︹', '︺', '︽', '︾', '︿', '﹀', '﹑', '﹝', '﹞', '｟', '｠', '｡', '､', '×', '÷', '−', '∕', '∖', '∣', '∥', '≪', '≫', '⦅', '⦆']
const | TRANSLIT_TO = ['AE', 'D', 'O', 'TH', 'ss', 'ae', 'd', 'o', 'th', 'D', 'd', 'H', 'h', 'i', 'q', 'L', 'l', 'L', 'l', '\'n', 'N', 'n', 'OE', 'oe', 'T', 't', 'b', 'B', 'B', 'b', 'C', 'c', 'D', 'D', 'D', 'd', 'E', 'F', 'f', 'G', 'hv', 'I', 'I', 'K', 'k', 'l', 'N', 'n', 'OI', 'oi', 'P', 'p', 't', 'T', 't', 'T', 'V', 'Y', 'y', 'Z', 'z', 'DZ', 'Dz', 'dz', 'G', 'g', 'd', 'Z', 'z', 'l', 'n', 't', 'j', 'db', 'qp', 'A', 'C', 'c', 'L', 'T', 's', 'z', 'B', 'U', 'E', 'e', 'J', 'j', 'R', 'r', 'Y', 'y', 'b', 'c', 'd', 'd', 'e', 'j', 'g', 'g', 'G', 'h', 'h', 'i', 'I', 'l', 'l', 'l', 'm', 'n', 'n', 'N', 'OE', 'r', 'r', 'r', 'R', 's', 't', 'u', 'v', 'Y', 'z', 'z', 'B', 'G', 'H', 'j', 'L', 'q', 'dz', 'dz', 'ts', 'ls', 'lz', 'A', 'AE', 'B', 'C', 'D', 'D', 'E', 'J', 'K', 'L', 'M', 'O', 'P', 'T', 'U', 'V', 'W', 'Z', 'ue', 'b', 'd', 'f', 'm', 'n', 'p', 'r', 'r', 's', 't', 'z', 'th', 'I', 'p', 'U', 'b', 'd', 'f', 'g', 'k', 'l', 'm', 'n', 'p', 'r', 's', 'v', 'x', 'z', 'a', 'd', 'e', 'e', 'i', 'u', 'a', 's', 's', 'SS', 'LL', 'll', 'V', 'v', 'Y', 'y', '(C)', '(R)', 'CE', 'Cr', 'Fr.', 'L.', 'Pts', 'TL', 'Rs', 'x', 'Rx', 'm/s', 'rad/s', 'C/kg', 'pH', 'V/m', 'A/m', ' 1/4', ' 1/2', ' 3/4', ' 1/3', ' 2/3', ' 1/5', ' 2/5', ' 3/5', ' 4/5', ' 1/6', ' 5/6', ' 1/8', ' 3/8', ' 5/8', ' 7/8', ' 1/', '0', '\'', '\'', ',', '\'', '"', '"', ',,', '"', '\'', '"', '"', '"', '<<', '>>', '<', '>', '-', '-', '-', '-', '-', '-', '-', '-', '-', '||', '/', '[', ']', '*', ',', '.', '<', '>', '<<', '>>', '[', ']', '[', ']', '[', ']', ',', '.', '[', ']', '<<', '>>', '<', '>', ',', '[', ']', '((', '))', '.', ',', '*', '/', '-', '/', '\\', '|', '||', '<<', '>>', '((', '))']

Attributs privés statiques

static | $transliterators = []
static | $tableZero
static | $tableWide

Membres hérités additionnels

- Attributs protégés hérités de AbstractString
$string = ''
$ignoreCase = false

Description détaillée

Represents a string of abstract Unicode characters.

Unicode defines 3 types of "characters" (bytes, code points and grapheme clusters). This class is the abstract type to use as a type-hint when the logic you want to implement is Unicode-aware but doesn't care about code points vs grapheme clusters.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Exceptions
ExceptionInterface

Documentation des fonctions membres

◆ ascii()

ascii ( array $rules = [] )

Generic UTF-8 to ASCII transliteration.

Install the intl extension for best results.

Paramètres
string[]|

Références $c, $i, $this, class, elseif, et null.

◆ camel()

camel ( )

◆ codePointsAt()

codePointsAt ( int $offset )
Renvoie
int[]

◆ folded()

folded ( bool $compat = true )

◆ fromCodePoints()

static fromCodePoints ( int ... $codes )
static
Renvoie
static

Références AbstractString\$string, et elseif.

◆ join()

join | ( | array | $strings,
 |  | string | $lastGlue = null
 | ) |  |

◆ lower()

lower ( )

◆ match()

match | ( | string | $regexp,
 |  | int | $flags = 0,
 |  | int | $offset = 0
 | ) |  |

◆ normalize()

normalize ( int $form = self::NFC )
Renvoie
static

◆ pad()

pad | ( | int | $len,
 |  | self | $pad,
 |  | int | $type
 | ) |  |
private
Renvoie
static

◆ padBoth()

padBoth | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

◆ padEnd()

padEnd | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

◆ padStart()

padStart | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

◆ replaceMatches()

replaceMatches | ( | string | $fromRegexp,
 |  |  | $to
 | ) |  |

◆ reverse()

reverse ( )

◆ snake()

snake ( )

◆ title()

title ( bool $allWords = false )

◆ trim()

trim ( string $chars = " \t\n\r\0\x0B\x0C\u{A0}\u{FEFF}" )

◆ trimEnd()

trimEnd ( string $chars = " \t\n\r\0\x0B\x0C\u{A0}\u{FEFF}" )

◆ trimPrefix()

trimPrefix ( $prefix )

Références $prefix.

◆ trimStart()

trimStart ( string $chars = " \t\n\r\0\x0B\x0C\u{A0}\u{FEFF}" )

◆ trimSuffix()

trimSuffix ( $suffix )

Références $suffix.

◆ upper()

upper ( )

◆ wcswidth()

wcswidth ( string $string )
private

Based on https://github.com/jquast/wcwidth, a Python implementation of https://www.cl.cam.ac.uk/~mgk25/ucs/wcwidth.c.

◆ width()

width ( bool $ignoreAnsiDecoration = true )

Documentation des champs

◆ $tableWide

$tableWide
staticprivate

◆ $tableZero

$tableZero
staticprivate

◆ $transliterators

$transliterators = []
staticprivate

◆ ASCII

const ASCII = "\x20\x65\x69\x61\x73\x6E\x74\x72\x6F\x6C\x75\x64\x5D\x5B\x63\x6D\x70\x27\x0A\x67\x7C\x68\x76\x2E\x66\x62\x2C\x3A\x3D\x2D\x71\x31\x30\x43\x32\x2A\x79\x78\x29\x28\x4C\x39\x41\x53\x2F\x50\x22\x45\x6A\x4D\x49\x6B\x33\x3E\x35\x54\x3C\x44\x34\x7D\x42\x7B\x38\x46\x77\x52\x36\x37\x55\x47\x4E\x3B\x4A\x7A\x56\x23\x48\x4F\x57\x5F\x26\x21\x4B\x3F\x58\x51\x25\x59\x5C\x09\x5A\x2B\x7E\x5E\x24\x40\x60\x7F\x00\x01\x02\x03\x04\x05\x06\x07\x08\x0B\x0C\x0D\x0E\x0F\x10\x11\x12\x13\x14\x15\x16\x17\x18\x19\x1A\x1B\x1C\x1D\x1E\x1F"
private

◆ FOLD_FROM

const FOLD_FROM = ['İ', 'µ', 'ſ', "\xCD\x85", 'ς', 'ϐ', 'ϑ', 'ϕ', 'ϖ', 'ϰ', 'ϱ', 'ϵ', 'ẛ', "\xE1\xBE\xBE", 'ß', 'İ', 'ŉ', 'ǰ', 'ΐ', 'ΰ', 'և', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'ẚ', 'ẞ', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ᾀ', 'ᾁ', 'ᾂ', 'ᾃ', 'ᾄ', 'ᾅ', 'ᾆ', 'ᾇ', 'ᾈ', 'ᾉ', 'ᾊ', 'ᾋ', 'ᾌ', 'ᾍ', 'ᾎ', 'ᾏ', 'ᾐ', 'ᾑ', 'ᾒ', 'ᾓ', 'ᾔ', 'ᾕ', 'ᾖ', 'ᾗ', 'ᾘ', 'ᾙ', 'ᾚ', 'ᾛ', 'ᾜ', 'ᾝ', 'ᾞ', 'ᾟ', 'ᾠ', 'ᾡ', 'ᾢ', 'ᾣ', 'ᾤ', 'ᾥ', 'ᾦ', 'ᾧ', 'ᾨ', 'ᾩ', 'ᾪ', 'ᾫ', 'ᾬ', 'ᾭ', 'ᾮ', 'ᾯ', 'ᾲ', 'ᾳ', 'ᾴ', 'ᾶ', 'ᾷ', 'ᾼ', 'ῂ', 'ῃ', 'ῄ', 'ῆ', 'ῇ', 'ῌ', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ῲ', 'ῳ', 'ῴ', 'ῶ', 'ῷ', 'ῼ', 'ﬀ', 'ﬁ', 'ﬂ', 'ﬃ', 'ﬄ', 'ﬅ', 'ﬆ', 'ﬓ', 'ﬔ', 'ﬕ', 'ﬖ', 'ﬗ']
private

◆ FOLD_TO

const FOLD_TO = ['i̇', 'μ', 's', 'ι', 'σ', 'β', 'θ', 'φ', 'π', 'κ', 'ρ', 'ε', 'ṡ', 'ι', 'ss', 'i̇', 'ʼn', 'ǰ', 'ΐ', 'ΰ', 'եւ', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'aʾ', 'ss', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ἀι', 'ἁι', 'ἂι', 'ἃι', 'ἄι', 'ἅι', 'ἆι', 'ἇι', 'ἀι', 'ἁι', 'ἂι', 'ἃι', 'ἄι', 'ἅι', 'ἆι', 'ἇι', 'ἠι', 'ἡι', 'ἢι', 'ἣι', 'ἤι', 'ἥι', 'ἦι', 'ἧι', 'ἠι', 'ἡι', 'ἢι', 'ἣι', 'ἤι', 'ἥι', 'ἦι', 'ἧι', 'ὠι', 'ὡι', 'ὢι', 'ὣι', 'ὤι', 'ὥι', 'ὦι', 'ὧι', 'ὠι', 'ὡι', 'ὢι', 'ὣι', 'ὤι', 'ὥι', 'ὦι', 'ὧι', 'ὰι', 'αι', 'άι', 'ᾶ', 'ᾶι', 'αι', 'ὴι', 'ηι', 'ήι', 'ῆ', 'ῆι', 'ηι', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ὼι', 'ωι', 'ώι', 'ῶ', 'ῶι', 'ωι', 'ff', 'fi', 'fl', 'ffi', 'ffl', 'st', 'st', 'մն', 'մե', 'մի', 'վն', 'մխ']
private

◆ NFC

const NFC = \Normalizer::NFC

◆ NFD

const NFD = \Normalizer::NFD

◆ NFKC

const NFKC = \Normalizer::NFKC

◆ NFKD

const NFKD = \Normalizer::NFKD

◆ TRANSLIT_FROM

const TRANSLIT_FROM = ['Æ', 'Ð', 'Ø', 'Þ', 'ß', 'æ', 'ð', 'ø', 'þ', 'Đ', 'đ', 'Ħ', 'ħ', 'ı', 'ĸ', 'Ŀ', 'ŀ', 'Ł', 'ł', 'ŉ', 'Ŋ', 'ŋ', 'Œ', 'œ', 'Ŧ', 'ŧ', 'ƀ', 'Ɓ', 'Ƃ', 'ƃ', 'Ƈ', 'ƈ', 'Ɖ', 'Ɗ', 'Ƌ', 'ƌ', 'Ɛ', 'Ƒ', 'ƒ', 'Ɠ', 'ƕ', 'Ɩ', 'Ɨ', 'Ƙ', 'ƙ', 'ƚ', 'Ɲ', 'ƞ', 'Ƣ', 'ƣ', 'Ƥ', 'ƥ', 'ƫ', 'Ƭ', 'ƭ', 'Ʈ', 'Ʋ', 'Ƴ', 'ƴ', 'Ƶ', 'ƶ', 'Ǆ', 'ǅ', 'ǆ', 'Ǥ', 'ǥ', 'ȡ', 'Ȥ', 'ȥ', 'ȴ', 'ȵ', 'ȶ', 'ȷ', 'ȸ', 'ȹ', 'Ⱥ', 'Ȼ', 'ȼ', 'Ƚ', 'Ⱦ', 'ȿ', 'ɀ', 'Ƀ', 'Ʉ', 'Ɇ', 'ɇ', 'Ɉ', 'ɉ', 'Ɍ', 'ɍ', 'Ɏ', 'ɏ', 'ɓ', 'ɕ', 'ɖ', 'ɗ', 'ɛ', 'ɟ', 'ɠ', 'ɡ', 'ɢ', 'ɦ', 'ɧ', 'ɨ', 'ɪ', 'ɫ', 'ɬ', 'ɭ', 'ɱ', 'ɲ', 'ɳ', 'ɴ', 'ɶ', 'ɼ', 'ɽ', 'ɾ', 'ʀ', 'ʂ', 'ʈ', 'ʉ', 'ʋ', 'ʏ', 'ʐ', 'ʑ', 'ʙ', 'ʛ', 'ʜ', 'ʝ', 'ʟ', 'ʠ', 'ʣ', 'ʥ', 'ʦ', 'ʪ', 'ʫ', 'ᴀ', 'ᴁ', 'ᴃ', 'ᴄ', 'ᴅ', 'ᴆ', 'ᴇ', 'ᴊ', 'ᴋ', 'ᴌ', 'ᴍ', 'ᴏ', 'ᴘ', 'ᴛ', 'ᴜ', 'ᴠ', 'ᴡ', 'ᴢ', 'ᵫ', 'ᵬ', 'ᵭ', 'ᵮ', 'ᵯ', 'ᵰ', 'ᵱ', 'ᵲ', 'ᵳ', 'ᵴ', 'ᵵ', 'ᵶ', 'ᵺ', 'ᵻ', 'ᵽ', 'ᵾ', 'ᶀ', 'ᶁ', 'ᶂ', 'ᶃ', 'ᶄ', 'ᶅ', 'ᶆ', 'ᶇ', 'ᶈ', 'ᶉ', 'ᶊ', 'ᶌ', 'ᶍ', 'ᶎ', 'ᶏ', 'ᶑ', 'ᶒ', 'ᶓ', 'ᶖ', 'ᶙ', 'ẚ', 'ẜ', 'ẝ', 'ẞ', 'Ỻ', 'ỻ', 'Ỽ', 'ỽ', 'Ỿ', 'ỿ', '©', '®', '₠', '₢', '₣', '₤', '₧', '₺', '₹', 'ℌ', '℞', '㎧', '㎮', '㏆', '㏗', '㏞', '㏟', '¼', '½', '¾', '⅓', '⅔', '⅕', '⅖', '⅗', '⅘', '⅙', '⅚', '⅛', '⅜', '⅝', '⅞', '⅟', '〇', '‘', '’', '‚', '‛', '“', '”', '„', '‟', '′', '″', '〝', '〞', '«', '»', '‹', '›', '‐', '‑', '‒', '–', '—', '―', '︱', '︲', '﹘', '‖', '⁄', '⁅', '⁆', '⁎', '、', '。', '〈', '〉', '《', '》', '〔', '〕', '〘', '〙', '〚', '〛', '︑', '︒', '︹', '︺', '︽', '︾', '︿', '﹀', '﹑', '﹝', '﹞', '｟', '｠', '｡', '､', '×', '÷', '−', '∕', '∖', '∣', '∥', '≪', '≫', '⦅', '⦆']
private

◆ TRANSLIT_TO

const TRANSLIT_TO = ['AE', 'D', 'O', 'TH', 'ss', 'ae', 'd', 'o', 'th', 'D', 'd', 'H', 'h', 'i', 'q', 'L', 'l', 'L', 'l', '\'n', 'N', 'n', 'OE', 'oe', 'T', 't', 'b', 'B', 'B', 'b', 'C', 'c', 'D', 'D', 'D', 'd', 'E', 'F', 'f', 'G', 'hv', 'I', 'I', 'K', 'k', 'l', 'N', 'n', 'OI', 'oi', 'P', 'p', 't', 'T', 't', 'T', 'V', 'Y', 'y', 'Z', 'z', 'DZ', 'Dz', 'dz', 'G', 'g', 'd', 'Z', 'z', 'l', 'n', 't', 'j', 'db', 'qp', 'A', 'C', 'c', 'L', 'T', 's', 'z', 'B', 'U', 'E', 'e', 'J', 'j', 'R', 'r', 'Y', 'y', 'b', 'c', 'd', 'd', 'e', 'j', 'g', 'g', 'G', 'h', 'h', 'i', 'I', 'l', 'l', 'l', 'm', 'n', 'n', 'N', 'OE', 'r', 'r', 'r', 'R', 's', 't', 'u', 'v', 'Y', 'z', 'z', 'B', 'G', 'H', 'j', 'L', 'q', 'dz', 'dz', 'ts', 'ls', 'lz', 'A', 'AE', 'B', 'C', 'D', 'D', 'E', 'J', 'K', 'L', 'M', 'O', 'P', 'T', 'U', 'V', 'W', 'Z', 'ue', 'b', 'd', 'f', 'm', 'n', 'p', 'r', 'r', 's', 't', 'z', 'th', 'I', 'p', 'U', 'b', 'd', 'f', 'g', 'k', 'l', 'm', 'n', 'p', 'r', 's', 'v', 'x', 'z', 'a', 'd', 'e', 'e', 'i', 'u', 'a', 's', 's', 'SS', 'LL', 'll', 'V', 'v', 'Y', 'y', '(C)', '(R)', 'CE', 'Cr', 'Fr.', 'L.', 'Pts', 'TL', 'Rs', 'x', 'Rx', 'm/s', 'rad/s', 'C/kg', 'pH', 'V/m', 'A/m', ' 1/4', ' 1/2', ' 3/4', ' 1/3', ' 2/3', ' 1/5', ' 2/5', ' 3/5', ' 4/5', ' 1/6', ' 5/6', ' 1/8', ' 3/8', ' 5/8', ' 7/8', ' 1/', '0', '\'', '\'', ',', '\'', '"', '"', ',,', '"', '\'', '"', '"', '"', '<<', '>>', '<', '>', '-', '-', '-', '-', '-', '-', '-', '-', '-', '||', '/', '[', ']', '*', ',', '.', '<', '>', '<<', '>>', '[', ']', '[', ']', '[', ']', ',', '.', '[', ']', '<<', '>>', '<', '>', ',', '[', ']', '((', '))', '.', ',', '*', '/', '-', '/', '\\', '|', '||', '<<', '>>', '((', '))']
private

◆ UPPER_FROM

const UPPER_FROM = ['ß', 'ﬀ', 'ﬁ', 'ﬂ', 'ﬃ', 'ﬄ', 'ﬅ', 'ﬆ', 'և', 'ﬓ', 'ﬔ', 'ﬕ', 'ﬖ', 'ﬗ', 'ŉ', 'ΐ', 'ΰ', 'ǰ', 'ẖ', 'ẗ', 'ẘ', 'ẙ', 'ẚ', 'ὐ', 'ὒ', 'ὔ', 'ὖ', 'ᾶ', 'ῆ', 'ῒ', 'ΐ', 'ῖ', 'ῗ', 'ῢ', 'ΰ', 'ῤ', 'ῦ', 'ῧ', 'ῶ']
private

◆ UPPER_TO

const UPPER_TO = ['SS', 'FF', 'FI', 'FL', 'FFI', 'FFL', 'ST', 'ST', 'ԵՒ', 'ՄՆ', 'ՄԵ', 'ՄԻ', 'ՎՆ', 'ՄԽ', 'ʼN', 'Ϊ́', 'Ϋ́', 'J̌', 'H̱', 'T̈', 'W̊', 'Y̊', 'Aʾ', 'Υ̓', 'Υ̓̀', 'Υ̓́', 'Υ̓͂', 'Α͂', 'Η͂', 'Ϊ̀', 'Ϊ́', 'Ι͂', 'Ϊ͂', 'Ϋ̀', 'Ϋ́', 'Ρ̓', 'Υ͂', 'Ϋ͂', 'Ω͂']
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractUnicodeString.php


Joomla CMS: Référence de la classe ByteString

  • Symfony
  • Component
  • String
  • ByteString
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe ByteString
+ Graphe d'héritage de ByteString:
AbstractString

Fonctions membres publiques

__construct (string $string='')
bytesAt (int $offset)
append (string ... $suffix)
camel ()
chunk (int $length=1)
endsWith ($suffix)
equalsTo ($string)
folded ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isUtf8 ()
join (array $strings, string $lastGlue=null)
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toUnicodeString (string $fromEncoding=null)
toCodePointString (string $fromEncoding=null)
trim (string $chars=" \\\B\C")
trimEnd (string $chars=" \\\B\C")
trimStart (string $chars=" \\\B\C")
upper ()
width (bool $ignoreAnsiDecoration=true)
- Fonctions membres publiques hérités de AbstractString
__construct (string $string='')
after ($needle, bool $includeNeedle=false, int $offset=0)
afterLast ($needle, bool $includeNeedle=false, int $offset=0)
append (string ... $suffix)
before ($needle, bool $includeNeedle=false, int $offset=0)
beforeLast ($needle, bool $includeNeedle=false, int $offset=0)
bytesAt (int $offset)
camel ()
chunk (int $length=1)
collapseWhitespace ()
containsAny ($needle)
endsWith ($suffix)
ensureEnd (string $suffix)
ensureStart (string $prefix)
equalsTo ($string)
folded ()
ignoreCase ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isEmpty ()
join (array $strings, string $lastGlue=null)
jsonSerialize ()
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
repeat (int $multiplier)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toByteString (string $toEncoding=null)
toCodePointString ()
toString ()
toUnicodeString ()
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
truncate (int $length, string $ellipsis='', bool $cut=true)
upper ()
width (bool $ignoreAnsiDecoration=true)
wordwrap (int $width=75, string $break="\, bool $cut=false)
__sleep ()
__clone ()
__toString ()

Fonctions membres publiques statiques

static | fromRandom (int $length=16, string $alphabet=null)
- Fonctions membres publiques statiques hérités de AbstractString
static | unwrap (array $values)
static | wrap (array $values)

Attributs privés

const ALPHABET_ALPHANUMERIC = '123456789ABCDEFGHJKLMNPQRSTUVWXYZabcdefghijkmnopqrstuvwxyz'

Membres hérités additionnels

- Champs de données hérités de AbstractString
const | PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER
const | PREG_SET_ORDER = \PREG_SET_ORDER
const | PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE
const | PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL
const | PREG_SPLIT = 0
const | PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY
const | PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE
const | PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE
- Attributs protégés hérités de AbstractString
$string = ''
$ignoreCase = false

Description détaillée

Represents a binary-safe string of bytes.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Hugo Hamon hugoh.nosp@m.amon.nosp@m.@neuf.nosp@m..fr
Exceptions
ExceptionInterface

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $string = '' )

Références AbstractString\$string.

Documentation des fonctions membres

◆ append()

append ( string ... $suffix )

Références $suffix, et $this.

◆ bytesAt()

bytesAt ( int $offset )

Références Joomla\Database\Query\$offset.

◆ camel()

camel ( )

Références $this.

Référencé par ByteString\snake().

◆ chunk()

chunk ( int $length = 1 )

Références $this.

◆ endsWith()

endsWith ( $suffix )

Références $suffix, elseif, AbstractString\ignoreCase(), null, et parent.

◆ equalsTo()

equalsTo ( $string )

Références AbstractString\$string, elseif, AbstractString\ignoreCase(), et parent.

◆ folded()

folded ( )

Références $this.

◆ fromRandom()

static fromRandom | ( | int | $length = 16,
 |  | string | $alphabet = null
 | ) |  |
static

Références $data, et $i.

◆ indexOf()

indexOf | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $i, Joomla\Database\Query\$offset, elseif, AbstractString\ignoreCase(), null, et parent.

◆ indexOfLast()

indexOfLast | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $i, Joomla\Database\Query\$offset, elseif, AbstractString\ignoreCase(), null, et parent.

◆ isUtf8()

isUtf8 ( )

◆ join()

join | ( | array | $strings,
 |  | string | $lastGlue = null
 | ) |  |

Références $strings, $this, et null.

◆ length()

length ( )

◆ lower()

lower ( )

Références $this.

◆ match()

match | ( | string | $regexp,
 |  | int | $flags = 0,
 |  | int | $offset = 0
 | ) |  |

Références Joomla\Database\Query\$offset, AbstractString\ignoreCase(), AbstractString\PREG_PATTERN_ORDER, AbstractString\PREG_SET_ORDER, et AbstractString\PREG_UNMATCHED_AS_NULL.

◆ padBoth()

padBoth | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

Références $this.

◆ padEnd()

padEnd | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

Références $this.

◆ padStart()

padStart | ( | int | $length,
 |  | string | $padStr = ' '
 | ) |  |

Références $this.

◆ prepend()

prepend ( string ... $prefix )

Références $prefix, et $this.

◆ replace()

replace | ( | string | $from,
 |  | string | $to
 | ) |  |

Références $this, et AbstractString\ignoreCase().

◆ replaceMatches()

replaceMatches | ( | string | $fromRegexp,
 |  |  | $to
 | ) |  |

Références AbstractString\$string, $this, class, AbstractString\ignoreCase(), et null.

◆ reverse()

reverse ( )

Références $this.

◆ slice()

slice | ( | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

◆ snake()

snake ( )

Références ByteString\camel().

◆ splice()

splice | ( | string | $replacement,
 |  | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

◆ split()

split | ( | string | $delimiter,
 |  | int | $limit = null,
 |  | int | $flags = null
 | ) |  |

Références $limit, $this, AbstractString\ignoreCase(), et null.

◆ startsWith()

startsWith ( $prefix )

Références $prefix, elseif, AbstractString\ignoreCase(), et parent.

◆ title()

title ( bool $allWords = false )

Références $this.

◆ toCodePointString()

toCodePointString ( string $fromEncoding = null )

Références AbstractString\$string, et null.

◆ toUnicodeString()

toUnicodeString ( string $fromEncoding = null )

Références AbstractString\toCodePointString().

◆ trim()

trim ( string $chars = " \t\n\r\0\x0B\x0C" )

Références $this.

◆ trimEnd()

trimEnd ( string $chars = " \t\n\r\0\x0B\x0C" )

Références $this.

◆ trimStart()

trimStart ( string $chars = " \t\n\r\0\x0B\x0C" )

Références $this.

◆ upper()

upper ( )

Références $this.

◆ width()

width ( bool $ignoreAnsiDecoration = true )

Références AbstractString\$string.

Documentation des champs

◆ ALPHABET_ALPHANUMERIC

const ALPHABET_ALPHANUMERIC = '123456789ABCDEFGHJKLMNPQRSTUVWXYZabcdefghijkmnopqrstuvwxyz'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ByteString.php


Joomla CMS: Référence de la classe CodePointString

  • Symfony
  • Component
  • String
  • CodePointString
Fonctions membres publiques
Référence de la classe CodePointString
+ Graphe d'héritage de CodePointString:
AbstractUnicodeString AbstractString

Fonctions membres publiques

__construct (string $string='')
append (string ... $suffix)
chunk (int $length=1)
codePointsAt (int $offset)
endsWith ($suffix)
equalsTo ($string)
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
length ()
prepend (string ... $prefix)
replace (string $from, string $to)
slice (int $start=0, int $length=null)
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
- Fonctions membres publiques hérités de AbstractUnicodeString
ascii (array $rules=[])
camel ()
codePointsAt (int $offset)
folded (bool $compat=true)
join (array $strings, string $lastGlue=null)
lower ()
match (string $regexp, int $flags=0, int $offset=0)
normalize (int $form=self::NFC)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
replaceMatches (string $fromRegexp, $to)
reverse ()
snake ()
title (bool $allWords=false)
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
upper ()
width (bool $ignoreAnsiDecoration=true)
- Fonctions membres publiques hérités de AbstractString
__construct (string $string='')
after ($needle, bool $includeNeedle=false, int $offset=0)
afterLast ($needle, bool $includeNeedle=false, int $offset=0)
append (string ... $suffix)
before ($needle, bool $includeNeedle=false, int $offset=0)
beforeLast ($needle, bool $includeNeedle=false, int $offset=0)
bytesAt (int $offset)
camel ()
chunk (int $length=1)
collapseWhitespace ()
containsAny ($needle)
endsWith ($suffix)
ensureEnd (string $suffix)
ensureStart (string $prefix)
equalsTo ($string)
folded ()
ignoreCase ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isEmpty ()
join (array $strings, string $lastGlue=null)
jsonSerialize ()
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
repeat (int $multiplier)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toByteString (string $toEncoding=null)
toCodePointString ()
toString ()
toUnicodeString ()
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
truncate (int $length, string $ellipsis='', bool $cut=true)
upper ()
width (bool $ignoreAnsiDecoration=true)
wordwrap (int $width=75, string $break="\, bool $cut=false)
__sleep ()
__clone ()
__toString ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractUnicodeString
static | fromCodePoints (int ... $codes)
- Fonctions membres publiques statiques hérités de AbstractString
static | unwrap (array $values)
static | wrap (array $values)
- Champs de données hérités de AbstractUnicodeString
const | NFC = \Normalizer::NFC
const | NFD = \Normalizer::NFD
const | NFKC = \Normalizer::NFKC
const | NFKD = \Normalizer::NFKD
- Champs de données hérités de AbstractString
const | PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER
const | PREG_SET_ORDER = \PREG_SET_ORDER
const | PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE
const | PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL
const | PREG_SPLIT = 0
const | PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY
const | PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE
const | PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE
- Attributs protégés hérités de AbstractString
$string = ''
$ignoreCase = false

Description détaillée

Represents a string of Unicode code points encoded as UTF-8.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Hugo Hamon hugoh.nosp@m.amon.nosp@m.@neuf.nosp@m..fr
Exceptions
ExceptionInterface

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $string = '' )

Références AbstractString\$string.

Documentation des fonctions membres

◆ append()

append ( string ... $suffix )

Références $suffix, et $this.

◆ chunk()

chunk ( int $length = 1 )

Références $this, AbstractString\PREG_SPLIT_DELIM_CAPTURE, et AbstractString\PREG_SPLIT_NO_EMPTY.

◆ codePointsAt()

codePointsAt ( int $offset )

Références Joomla\Database\Query\$offset, $this, et CodePointString\slice().

◆ endsWith()

endsWith ( $suffix )

Références $suffix, elseif, et AbstractString\ignoreCase().

◆ equalsTo()

equalsTo ( $string )

Références AbstractString\$string, elseif, et AbstractString\ignoreCase().

◆ indexOf()

indexOf | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $i, Joomla\Database\Query\$offset, elseif, AbstractString\ignoreCase(), et null.

◆ indexOfLast()

indexOfLast | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $i, Joomla\Database\Query\$offset, elseif, AbstractString\ignoreCase(), et null.

◆ length()

length ( )

◆ prepend()

prepend ( string ... $prefix )

Références $prefix, et $this.

◆ replace()

replace | ( | string | $from,
 |  | string | $to
 | ) |  |

Références $this, et AbstractString\ignoreCase().

◆ slice()

slice | ( | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

Référencé par CodePointString\codePointsAt().

◆ splice()

splice | ( | string | $replacement,
 |  | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

◆ split()

split | ( | string | $delimiter,
 |  | int | $limit = null,
 |  | int | $flags = null
 | ) |  |

Références $limit, $this, AbstractString\ignoreCase(), et null.

◆ startsWith()

startsWith ( $prefix )

Références $prefix, elseif, et AbstractString\ignoreCase().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CodePointString.php


Joomla CMS: Référence de la classe LazyString

  • Symfony
  • Component
  • String
  • LazyString
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe LazyString
+ Graphe d'héritage de LazyString:

Fonctions membres publiques

__toString ()
__sleep ()
jsonSerialize ()

Fonctions membres publiques statiques

static | fromCallable ($callback,... $arguments)
static | fromStringable ($value)
static | isStringable ($value)
static | resolve ($value)

Fonctions membres privées

__construct ()

Fonctions membres privées statiques

static getPrettyName (callable $callback)

Attributs privés

$value

Description détaillée

A string whose value is computed lazily by a callback.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Documentation des fonctions membres

◆ __sleep()

__sleep ( )

Références LazyString\__toString().

◆ __toString()

__toString ( )
Renvoie
string

Références $r, $type, LazyString\$value, class, et value.

Référencé par LazyString\__sleep(), et LazyString\jsonSerialize().

◆ fromCallable()

static fromCallable | ( | $callback,
 |  | $arguments
 | ) |
static
Paramètres
callable | array $callback A callable or a [Closure, method] lazy-callable
Renvoie
static

Références LazyString\$value, et null.

◆ fromStringable()

static fromStringable ( $value )
static
Paramètres
string | int | float | bool | \Stringable $value
Renvoie
static

Références LazyString\$value.

◆ getPrettyName()

static getPrettyName ( callable $callback )
staticprivate

Références $class, $method, $r, et elseif.

◆ isStringable()

static isStringable ( $value )
staticfinal

Tells whether the provided value can be cast to string.

Références LazyString\$value.

◆ jsonSerialize()

jsonSerialize ( )

Références LazyString\__toString().

◆ resolve()

static resolve ( $value )
staticfinal

Casts scalars and stringable objects to strings.

Paramètres
object | string | int | float | bool $value
Exceptions

Références LazyString\$value.

Documentation des champs

◆ $value

$value
private

Référencé par LazyString\__toString(), LazyString\fromCallable(), LazyString\fromStringable(), LazyString\isStringable(), et LazyString\resolve().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LazyString.php


Joomla CMS: Référence de la classe UnicodeString

  • Symfony
  • Component
  • String
  • UnicodeString
Fonctions membres publiques
Référence de la classe UnicodeString
+ Graphe d'héritage de UnicodeString:
AbstractUnicodeString AbstractString

Fonctions membres publiques

__construct (string $string='')
append (string ... $suffix)
chunk (int $length=1)
endsWith ($suffix)
equalsTo ($string)
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
join (array $strings, string $lastGlue=null)
length ()
normalize (int $form=self::NFC)
prepend (string ... $prefix)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
slice (int $start=0, int $length=null)
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
__wakeup ()
__clone ()
- Fonctions membres publiques hérités de AbstractUnicodeString
ascii (array $rules=[])
camel ()
codePointsAt (int $offset)
folded (bool $compat=true)
join (array $strings, string $lastGlue=null)
lower ()
match (string $regexp, int $flags=0, int $offset=0)
normalize (int $form=self::NFC)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
replaceMatches (string $fromRegexp, $to)
reverse ()
snake ()
title (bool $allWords=false)
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
upper ()
width (bool $ignoreAnsiDecoration=true)
- Fonctions membres publiques hérités de AbstractString
__construct (string $string='')
after ($needle, bool $includeNeedle=false, int $offset=0)
afterLast ($needle, bool $includeNeedle=false, int $offset=0)
append (string ... $suffix)
before ($needle, bool $includeNeedle=false, int $offset=0)
beforeLast ($needle, bool $includeNeedle=false, int $offset=0)
bytesAt (int $offset)
camel ()
chunk (int $length=1)
collapseWhitespace ()
containsAny ($needle)
endsWith ($suffix)
ensureEnd (string $suffix)
ensureStart (string $prefix)
equalsTo ($string)
folded ()
ignoreCase ()
indexOf ($needle, int $offset=0)
indexOfLast ($needle, int $offset=0)
isEmpty ()
join (array $strings, string $lastGlue=null)
jsonSerialize ()
length ()
lower ()
match (string $regexp, int $flags=0, int $offset=0)
padBoth (int $length, string $padStr=' ')
padEnd (int $length, string $padStr=' ')
padStart (int $length, string $padStr=' ')
prepend (string ... $prefix)
repeat (int $multiplier)
replace (string $from, string $to)
replaceMatches (string $fromRegexp, $to)
reverse ()
slice (int $start=0, int $length=null)
snake ()
splice (string $replacement, int $start=0, int $length=null)
split (string $delimiter, int $limit=null, int $flags=null)
startsWith ($prefix)
title (bool $allWords=false)
toByteString (string $toEncoding=null)
toCodePointString ()
toString ()
toUnicodeString ()
trim (string $chars=" \\\B\C\A0}\FEFF}")
trimEnd (string $chars=" \\\B\C\A0}\FEFF}")
trimPrefix ($prefix)
trimStart (string $chars=" \\\B\C\A0}\FEFF}")
trimSuffix ($suffix)
truncate (int $length, string $ellipsis='', bool $cut=true)
upper ()
width (bool $ignoreAnsiDecoration=true)
wordwrap (int $width=75, string $break="\, bool $cut=false)
__sleep ()
__clone ()
__toString ()

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de AbstractUnicodeString
static | fromCodePoints (int ... $codes)
- Fonctions membres publiques statiques hérités de AbstractString
static | unwrap (array $values)
static | wrap (array $values)
- Champs de données hérités de AbstractUnicodeString
const | NFC = \Normalizer::NFC
const | NFD = \Normalizer::NFD
const | NFKC = \Normalizer::NFKC
const | NFKD = \Normalizer::NFKD
- Champs de données hérités de AbstractString
const | PREG_PATTERN_ORDER = \PREG_PATTERN_ORDER
const | PREG_SET_ORDER = \PREG_SET_ORDER
const | PREG_OFFSET_CAPTURE = \PREG_OFFSET_CAPTURE
const | PREG_UNMATCHED_AS_NULL = \PREG_UNMATCHED_AS_NULL
const | PREG_SPLIT = 0
const | PREG_SPLIT_NO_EMPTY = \PREG_SPLIT_NO_EMPTY
const | PREG_SPLIT_DELIM_CAPTURE = \PREG_SPLIT_DELIM_CAPTURE
const | PREG_SPLIT_OFFSET_CAPTURE = \PREG_SPLIT_OFFSET_CAPTURE
- Attributs protégés hérités de AbstractString
$string = ''
$ignoreCase = false

Description détaillée

Represents a string of Unicode grapheme clusters encoded as UTF-8.

A letter followed by combining characters (accents typically) form what Unicode defines as a grapheme cluster: a character as humans mean it in written texts. This class knows about the concept and won't split a letter apart from its combining accents. It also ensures all string comparisons happen on their canonically-composed representation, ignoring e.g. the order in which accents are listed when a letter has many of them.

Voir également
https://unicode.org/reports/tr15/
Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Hugo Hamon hugoh.nosp@m.amon.nosp@m.@neuf.nosp@m..fr
Exceptions
ExceptionInterface

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $string = '' )

Références AbstractString\$string.

Documentation des fonctions membres

◆ __clone()

__clone ( )

Références AbstractString\ignoreCase(), et null.

◆ __wakeup()

__wakeup ( )

◆ append()

append ( string ... $suffix )

Références $suffix, et $this.

◆ chunk()

chunk ( int $length = 1 )

Références $this, AbstractString\PREG_SPLIT_DELIM_CAPTURE, et AbstractString\PREG_SPLIT_NO_EMPTY.

◆ endsWith()

endsWith ( $suffix )

Références $form, $suffix, elseif, AbstractString\ignoreCase(), Normalizer\NFC, Normalizer\NFD, et null.

◆ equalsTo()

equalsTo ( $string )

Références $form, AbstractString\$string, elseif, AbstractString\ignoreCase(), Normalizer\NFC, Normalizer\NFD, et null.

◆ indexOf()

indexOf | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $form, $i, Joomla\Database\Query\$offset, elseif, AbstractString\ignoreCase(), Normalizer\NFC, Normalizer\NFD, et null.

◆ indexOfLast()

indexOfLast | ( |  | $needle,
 |  | int | $offset = 0
 | ) |  |

Références $form, $i, Joomla\Database\Query\$offset, AbstractString\$string, elseif, AbstractString\ignoreCase(), Normalizer\NFC, Normalizer\NFD, et null.

◆ join()

join | ( | array | $strings,
 |  | string | $lastGlue = null
 | ) |  |

Références $strings.

◆ length()

length ( )

◆ normalize()

normalize ( int $form = self::NFC )
Renvoie
static

Références $form, $this, elseif, et null.

◆ prepend()

prepend ( string ... $prefix )

Références $prefix, et $this.

◆ replace()

replace | ( | string | $from,
 |  | string | $to
 | ) |  |

Références $i, $result, $this, et AbstractString\ignoreCase().

◆ replaceMatches()

replaceMatches | ( | string | $fromRegexp,
 |  |  | $to
 | ) |  |

◆ slice()

slice | ( | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

◆ splice()

splice | ( | string | $replacement,
 |  | int | $start = 0,
 |  | int | $length = null
 | ) |  |

Références $start, et $this.

◆ split()

split | ( | string | $delimiter,
 |  | int | $limit = null,
 |  | int | $flags = null
 | ) |  |

Références $i, $limit, AbstractString\$string, $this, AbstractString\ignoreCase(), et null.

◆ startsWith()

startsWith ( $prefix )

Références $form, $prefix, elseif, AbstractString\ignoreCase(), Normalizer\NFC, Normalizer\NFD, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UnicodeString.php


Joomla CMS: Référence de la classe AmqpCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • AmqpCaster
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés
Référence de la classe AmqpCaster

Fonctions membres publiques statiques

static | castConnection (\AMQPConnection $c, array $a, Stub $stub, bool $isNested)
static | castChannel (\AMQPChannel $c, array $a, Stub $stub, bool $isNested)
static | castQueue (\AMQPQueue $c, array $a, Stub $stub, bool $isNested)
static | castExchange (\AMQPExchange $c, array $a, Stub $stub, bool $isNested)
static | castEnvelope (\AMQPEnvelope $c, array $a, Stub $stub, bool $isNested, int $filter=0)

Champs de données

const | AMQP_PASSIVE
const | AMQP_EX_TYPE_FANOUT

Fonctions membres privées statiques

static extractFlags (int $flags)

Attributs privés

const | FLAGS
const | EXCHANGE_TYPES

Description détaillée

Casts Amqp related classes to array representation.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ castChannel()

static castChannel | ( | \AMQPChannel | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castConnection()

static castConnection | ( | \AMQPConnection | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castEnvelope()

static castEnvelope | ( | \AMQPEnvelope | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, $prefix, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castExchange()

static castExchange | ( | \AMQPExchange | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, $type, et Caster\PREFIX_VIRTUAL.

◆ castQueue()

static castQueue | ( | \AMQPQueue | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ extractFlags()

static extractFlags ( int $flags )
staticprivate

Références $name, et $value.

Documentation des champs

◆ AMQP_EX_TYPE_FANOUT

const AMQP_EX_TYPE_FANOUT
Valeur initiale :
=> 'AMQP_EX_TYPE_FANOUT',
\AMQP_EX_TYPE_TOPIC => 'AMQP_EX_TYPE_TOPIC',
\AMQP_EX_TYPE_HEADERS => 'AMQP_EX_TYPE_HEADERS',
]

◆ AMQP_PASSIVE

const AMQP_PASSIVE
Valeur initiale :
=> 'AMQP_PASSIVE',
\AMQP_EXCLUSIVE => 'AMQP_EXCLUSIVE',
\AMQP_AUTODELETE => 'AMQP_AUTODELETE',
\AMQP_INTERNAL => 'AMQP_INTERNAL',
\AMQP_NOLOCAL => 'AMQP_NOLOCAL',
\AMQP_AUTOACK => 'AMQP_AUTOACK',
\AMQP_IFEMPTY => 'AMQP_IFEMPTY',
\AMQP_IFUNUSED => 'AMQP_IFUNUSED',
\AMQP_MANDATORY => 'AMQP_MANDATORY',
\AMQP_IMMEDIATE => 'AMQP_IMMEDIATE',
\AMQP_MULTIPLE => 'AMQP_MULTIPLE',
\AMQP_NOWAIT => 'AMQP_NOWAIT',
\AMQP_REQUEUE => 'AMQP_REQUEUE',
]

◆ EXCHANGE_TYPES

const EXCHANGE_TYPES
private
Valeur initiale :
= [
\AMQP_EX_TYPE_DIRECT => 'AMQP_EX_TYPE_DIRECT'

◆ FLAGS

const FLAGS
private
Valeur initiale :
= [
\AMQP_DURABLE => 'AMQP_DURABLE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AmqpCaster.php


Joomla CMS: Référence de la classe ArgsStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ArgsStub
Fonctions membres publiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe ArgsStub
+ Graphe d'héritage de ArgsStub:
EnumStub Stub

Fonctions membres publiques

__construct (array $args, string $function, ?string $class)
- Fonctions membres publiques hérités de EnumStub
__construct (array $values, bool $dumpKeys=true)
- Fonctions membres publiques hérités de Stub
__sleep ()

Fonctions membres privées statiques

static getParameters (string $function, ?string $class)

Attributs privés statiques

static $parameters = []

Membres hérités additionnels

- Champs de données hérités de EnumStub
$dumpKeys = true
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a list of function arguments.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $args,
 |  | string | $function,
 |  | ?string | $class
 | ) |  |

Références Stub\$class, $function, $params, Symfony\Contracts\Service\__construct(), elseif, null, et value.

Documentation des fonctions membres

◆ getParameters()

static getParameters | ( | string | $function,
 |  | ?string | $class
 | ) |  |
staticprivate

Références Stub\$class, $function, $parameters, $params, $r, et null.

Documentation des champs

◆ $parameters

$parameters = []
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • ArgsStub.php


Joomla CMS: Référence de la classe Caster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • Caster
Fonctions membres publiques statiques | Champs de données
Référence de la classe Caster

Fonctions membres publiques statiques

static | castObject (object $obj, string $class, bool $hasDebugInfo=false, string $debugClass=null)
static | filter (array $a, int $filter, array $listedProperties=[], ?int &$count=0)
static | castPhpIncompleteClass (\__PHP_Incomplete_Class $c, array $a, Stub $stub, bool $isNested)

Champs de données

const | EXCLUDE_VERBOSE = 1
const | EXCLUDE_VIRTUAL = 2
const | EXCLUDE_DYNAMIC = 4
const | EXCLUDE_PUBLIC = 8
const | EXCLUDE_PROTECTED = 16
const | EXCLUDE_PRIVATE = 32
const | EXCLUDE_NULL = 64
const | EXCLUDE_EMPTY = 128
const | EXCLUDE_NOT_IMPORTANT = 256
const | EXCLUDE_STRICT = 512
const | PREFIX_VIRTUAL = "\0~\0"
const | PREFIX_DYNAMIC = "\0+\0"
const | PREFIX_PROTECTED = "\0*\0"

Description détaillée

Helper for filtering out properties in casters.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castObject()

static castObject | ( | object | $obj,
 |  | string | $class,
 |  | bool | $hasDebugInfo = false,
 |  | string | $debugClass = null
 | ) |  |
static

Casts objects to arrays and adds the dynamic property prefix.

Paramètres
bool $hasDebugInfo Whether the __debugInfo method exists on $obj or not

Références $class, $i, et elseif.

Référencé par AbstractCloner\castObject(), et SplCaster\castSplArray().

◆ castPhpIncompleteClass()

static castPhpIncompleteClass | ( | \__PHP_Incomplete_Class | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ filter()

static filter | ( | array | $a,
 |  | int | $filter,
 |  | array | $listedProperties = [],
 |  | ?int & | $count = 0
 | ) |  |
static

Filters out the specified properties.

By default, a single match in the $filter bit field filters properties out, following an "or" logic. When EXCLUDE_STRICT is set, an "and" logic is applied: all bits must match for a property to be removed.

Paramètres
array | $a | The array containing the properties to filter
int | $filter | A bit field of Caster::EXCLUDE_* constants specifying which properties to filter out
string[] | $listedProperties List of properties to exclude when Caster::EXCLUDE_VERBOSE is set, and to preserve when Caster::EXCLUDE_NOT_IMPORTANT is set
int | &$count | Set to the number of removed properties

Références $count, $type, elseif, et null.

Référencé par XmlReaderCaster\castXmlReader().

Documentation des champs

◆ EXCLUDE_DYNAMIC

const EXCLUDE_DYNAMIC = 4

◆ EXCLUDE_EMPTY

const EXCLUDE_EMPTY = 128

Référencé par XmlReaderCaster\castXmlReader().

◆ EXCLUDE_NOT_IMPORTANT

const EXCLUDE_NOT_IMPORTANT = 256

◆ EXCLUDE_NULL

const EXCLUDE_NULL = 64

◆ EXCLUDE_PRIVATE

const EXCLUDE_PRIVATE = 32

◆ EXCLUDE_PROTECTED

const EXCLUDE_PROTECTED = 16

◆ EXCLUDE_PUBLIC

const EXCLUDE_PUBLIC = 8

◆ EXCLUDE_STRICT

const EXCLUDE_STRICT = 512

◆ EXCLUDE_VERBOSE

const EXCLUDE_VERBOSE = 1

Référencé par CutStub\__construct(), ClassStub\__construct(), ReflectionCaster\castClass(), ReflectionCaster\castClosure(), DOMCaster\castDocument(), AmqpCaster\castEnvelope(), ReflectionCaster\castFunctionAbstract(), DateCaster\castInterval(), IntlCaster\castIntlCalendar(), IntlCaster\castIntlDateFormatter(), IntlCaster\castNumberFormatter(), DateCaster\castPeriod(), DateCaster\castTimeZone(), ExceptionCaster\extractSource(), et ExceptionCaster\filterExceptionArray().

◆ EXCLUDE_VIRTUAL

const EXCLUDE_VIRTUAL = 2

◆ PREFIX_DYNAMIC

const PREFIX_DYNAMIC = "\0+\0"

Référencé par DateCaster\castDateTime(), SplCaster\castObjectStorage(), ExceptionCaster\filterExceptionArray(), et Data\seek().

◆ PREFIX_PROTECTED

const PREFIX_PROTECTED = "\0*\0"

Référencé par ExceptionCaster\castErrorException(), DOMCaster\castException(), SymfonyCaster\castRequest(), ExceptionCaster\castThrowingCasterException(), ExceptionCaster\filterExceptionArray(), et Data\seek().

◆ PREFIX_VIRTUAL

const PREFIX_VIRTUAL = "\0~\0"

Référencé par DsPairStub\__construct(), ReflectionCaster\addExtra(), RdKafkaCaster\castBrokerMetadata(), AmqpCaster\castChannel(), ReflectionCaster\castClass(), ReflectionCaster\castClassConstant(), ReflectionCaster\castClosure(), DsCaster\castCollection(), RdKafkaCaster\castConf(), AmqpCaster\castConnection(), DateCaster\castDateTime(), DOMCaster\castDocument(), SplCaster\castDoublyLinkedList(), StubCaster\castEnum(), AmqpCaster\castEnvelope(), IntlCaster\castError(), AmqpCaster\castExchange(), FiberCaster\castFiber(), SplCaster\castFileInfo(), SplCaster\castFileObject(), ExceptionCaster\castFrameStub(), ReflectionCaster\castFunctionAbstract(), ReflectionCaster\castGenerator(), GmpCaster\castGmp(), SplCaster\castHeap(), ImagineCaster\castImage(), DOMCaster\castImplementation(), DateCaster\castInterval(), IntlCaster\castIntlCalendar(), IntlCaster\castIntlDateFormatter(), IntlCaster\castIntlTimeZone(), RdKafkaCaster\castKafkaConsumer(), MemcachedCaster\castMemcached(), RdKafkaCaster\castMessage(), IntlCaster\castMessageFormatter(), ReflectionCaster\castMethod(), IntlCaster\castNumberFormatter(), AbstractCloner\castObject(), SplCaster\castObjectStorage(), SplCaster\castOuterIterator(), DsCaster\castPair(), ReflectionCaster\castParameter(), RdKafkaCaster\castPartitionMetadata(), PdoCaster\castPdo(), PdoCaster\castPdoStatement(), DateCaster\castPeriod(), ReflectionCaster\castProperty(), AmqpCaster\castQueue(), UuidCaster\castRamseyUuid(), RdKafkaCaster\castRdKafka(), RedisCaster\castRedis(), RedisCaster\castRedisArray(), RedisCaster\castRedisCluster(), ReflectionCaster\castReference(), ReflectionCaster\castReflectionGenerator(), SymfonyCaster\castRequest(), AbstractCloner\castResource(), ExceptionCaster\castSilencedErrorContext(), SplCaster\castSplArray(), ExceptionCaster\castThrowingCasterException(), DateCaster\castTimeZone(), RdKafkaCaster\castTopic(), RdKafkaCaster\castTopicConf(), RdKafkaCaster\castTopicMetadata(), RdKafkaCaster\castTopicPartition(), ExceptionCaster\castTraceStub(), ReflectionCaster\castType(), SplCaster\castWeakReference(), XmlReaderCaster\castXmlReader(), RdKafkaCaster\extractMetadata(), ExceptionCaster\filterExceptionArray(), ReflectionCaster\getSignature(), Data\seek(), et ReflectionCaster\unsetClosureFileInfo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Caster.php


Joomla CMS: Référence de la classe ClassStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ClassStub
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe ClassStub
+ Graphe d'héritage de ClassStub:
ConstStub Stub

Fonctions membres publiques

__construct (string $identifier, $callable=null)
- Fonctions membres publiques hérités de ConstStub
__construct (string $name, $value=null)
__toString ()
- Fonctions membres publiques hérités de Stub
__sleep ()

Fonctions membres publiques statiques

static wrapCallable ($callable)

Membres hérités additionnels

- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a PHP class identifier.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $identifier,
 |  |  | $callable = null
 | ) |  |
Paramètres
string | $identifier | A PHP identifier, e.g. a class, method, interface, etc. name
callable | $callable | The callable targeted by the identifier when it is ambiguous or not a real PHP identifier

Références $i, $r, ReflectionCaster\castFunctionAbstract(), elseif, Caster\EXCLUDE_VERBOSE, ReflectionCaster\getSignature(), null, et value.

Documentation des fonctions membres

◆ wrapCallable()

static wrapCallable ( $callable )
static

Références elseif.

Référencé par RedisCaster\castRedisArray().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ClassStub.php


Joomla CMS: Référence de la classe ConstStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ConstStub
Fonctions membres publiques
Référence de la classe ConstStub
+ Graphe d'héritage de ConstStub:
Stub ClassStub ImgStub LinkStub

Fonctions membres publiques

__construct (string $name, $value=null)
__toString ()
- Fonctions membres publiques hérités de Stub
__sleep ()

Membres hérités additionnels

- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a PHP constant and its value.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  |  | $value = null
 | ) |  |

Références $name, Stub\$value, et value.

Documentation des fonctions membres

◆ __toString()

__toString ( )
Renvoie
string

Références Stub\$value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConstStub.php


Joomla CMS: Référence de la classe CutArrayStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • CutArrayStub
Fonctions membres publiques | Champs de données
Référence de la classe CutArrayStub
+ Graphe d'héritage de CutArrayStub:
CutStub Stub

Fonctions membres publiques

__construct (array $value, array $preservedKeys)
- Fonctions membres publiques hérités de CutStub
__construct ($value)
- Fonctions membres publiques hérités de Stub
__sleep ()

Champs de données

$preservedSubset
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a cut array.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $value,
 |  | array | $preservedKeys
 | ) |  |

Références Stub\$value, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ $preservedSubset

$preservedSubset
La documentation de cette classe a été générée à partir du fichier suivant :
  • CutArrayStub.php


Joomla CMS: Référence de la classe CutStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • CutStub
Fonctions membres publiques
Référence de la classe CutStub
+ Graphe d'héritage de CutStub:
Stub CutArrayStub

Fonctions membres publiques

__construct ($value)
- Fonctions membres publiques hérités de Stub
__sleep ()

Membres hérités additionnels

- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents the main properties of a PHP variable, pre-casted by a caster.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $value )

Références $this, Stub\$value, break, ReflectionCaster\castClosure(), Caster\EXCLUDE_VERBOSE, et value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CutStub.php


Joomla CMS: Référence de la classe DateCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • DateCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe DateCaster

Fonctions membres publiques statiques

static | castDateTime (\DateTimeInterface $d, array $a, Stub $stub, bool $isNested, int $filter)
static | castInterval (\DateInterval $interval, array $a, Stub $stub, bool $isNested, int $filter)
static | castTimeZone (\DateTimeZone $timeZone, array $a, Stub $stub, bool $isNested, int $filter)
static | castPeriod (\DatePeriod $p, array $a, Stub $stub, bool $isNested, int $filter)

Fonctions membres privées statiques

static | formatInterval (\DateInterval $i)
static | formatDateTime (\DateTimeInterface $d, string $extra='')
static | formatSeconds (string $s, string $us)

Attributs privés

const PERIOD_LIMIT = 3

Description détaillée

Casts DateTimeInterface related classes to array representation.

Auteur
Dany Maillard danym.nosp@m.aill.nosp@m.ard93.nosp@m.b@gm.nosp@m.ail.c.nosp@m.om

Documentation des fonctions membres

◆ castDateTime()

static castDateTime | ( | \DateTimeInterface | $d,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter
 | ) |  |
static

Références $location, $prefix, $title, Caster\PREFIX_DYNAMIC, et Caster\PREFIX_VIRTUAL.

◆ castInterval()

static castInterval | ( | \DateInterval | $interval,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter
 | ) |  |
static

Références $i, $now, $title, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castPeriod()

static castPeriod | ( | \DatePeriod | $p,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter
 | ) |  |
static

Références $i, $now, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castTimeZone()

static castTimeZone | ( | \DateTimeZone | $timeZone,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter
 | ) |  |
static

Références $location, $title, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ formatDateTime()

static formatDateTime | ( | \DateTimeInterface | $d,
 |  | string | $extra = ''
 | ) |  |
staticprivate

◆ formatInterval()

static formatInterval ( \DateInterval $i )
staticprivate

Références $format, et $i.

◆ formatSeconds()

static formatSeconds | ( | string | $s,
 |  | string | $us
 | ) |  |
staticprivate

Documentation des champs

◆ PERIOD_LIMIT

const PERIOD_LIMIT = 3
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • DateCaster.php


Joomla CMS: Référence de la classe DoctrineCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • DoctrineCaster
Fonctions membres publiques statiques
Référence de la classe DoctrineCaster

Fonctions membres publiques statiques

static | castCommonProxy (CommonProxy $proxy, array $a, Stub $stub, bool $isNested)
static | castOrmProxy (OrmProxy $proxy, array $a, Stub $stub, bool $isNested)
static | castPersistentCollection (PersistentCollection $coll, array $a, Stub $stub, bool $isNested)

Description détaillée

Casts Doctrine related classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castCommonProxy()

static castCommonProxy | ( | CommonProxy | $proxy,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castOrmProxy()

static castOrmProxy | ( | OrmProxy | $proxy,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castPersistentCollection()

static castPersistentCollection | ( | PersistentCollection | $coll,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • DoctrineCaster.php


Joomla CMS: Référence de la classe DOMCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • DOMCaster
Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe DOMCaster

Fonctions membres publiques statiques

static | castException (\DOMException $e, array $a, Stub $stub, bool $isNested)
static | castLength ($dom, array $a, Stub $stub, bool $isNested)
static | castImplementation (\DOMImplementation $dom, array $a, Stub $stub, bool $isNested)
static | castNode (\DOMNode $dom, array $a, Stub $stub, bool $isNested)
static | castNameSpaceNode (\DOMNameSpaceNode $dom, array $a, Stub $stub, bool $isNested)
static | castDocument (\DOMDocument $dom, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castCharacterData (\DOMCharacterData $dom, array $a, Stub $stub, bool $isNested)
static | castAttr (\DOMAttr $dom, array $a, Stub $stub, bool $isNested)
static | castElement (\DOMElement $dom, array $a, Stub $stub, bool $isNested)
static | castText (\DOMText $dom, array $a, Stub $stub, bool $isNested)
static | castTypeinfo (\DOMTypeinfo $dom, array $a, Stub $stub, bool $isNested)
static | castDomError (\DOMDomError $dom, array $a, Stub $stub, bool $isNested)
static | castLocator (\DOMLocator $dom, array $a, Stub $stub, bool $isNested)
static | castDocumentType (\DOMDocumentType $dom, array $a, Stub $stub, bool $isNested)
static | castNotation (\DOMNotation $dom, array $a, Stub $stub, bool $isNested)
static | castEntity (\DOMEntity $dom, array $a, Stub $stub, bool $isNested)
static | castProcessingInstruction (\DOMProcessingInstruction $dom, array $a, Stub $stub, bool $isNested)
static | castXPath (\DOMXPath $dom, array $a, Stub $stub, bool $isNested)

Champs de données

const | DOM_INDEX_SIZE_ERR
const | XML_ATTRIBUTE_NODE

Attributs privés

const | ERROR_CODES
const | NODE_TYPES

Description détaillée

Casts DOM related classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castAttr()

static castAttr | ( | \DOMAttr | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castCharacterData()

static castCharacterData | ( | \DOMCharacterData | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castDocument()

static castDocument | ( | \DOMDocument | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castDocumentType()

static castDocumentType | ( | \DOMDocumentType | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castDomError()

static castDomError | ( | \DOMDomError | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castElement()

static castElement | ( | \DOMElement | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castEntity()

static castEntity | ( | \DOMEntity | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castException()

static castException | ( | \DOMException | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Caster\PREFIX_PROTECTED.

◆ castImplementation()

static castImplementation | ( | \DOMImplementation | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Caster\PREFIX_VIRTUAL.

◆ castLength()

static castLength | ( |  | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castLocator()

static castLocator | ( | \DOMLocator | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castNameSpaceNode()

static castNameSpaceNode | ( | \DOMNameSpaceNode | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castNode()

static castNode | ( | \DOMNode | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castNotation()

static castNotation | ( | \DOMNotation | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castProcessingInstruction()

static castProcessingInstruction | ( | \DOMProcessingInstruction | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castText()

static castText | ( | \DOMText | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castTypeinfo()

static castTypeinfo | ( | \DOMTypeinfo | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castXPath()

static castXPath | ( | \DOMXPath | $dom,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Documentation des champs

◆ DOM_INDEX_SIZE_ERR

const DOM_INDEX_SIZE_ERR
Valeur initiale :
=> 'DOM_INDEX_SIZE_ERR',
\DOMSTRING_SIZE_ERR => 'DOMSTRING_SIZE_ERR',
\DOM_HIERARCHY_REQUEST_ERR => 'DOM_HIERARCHY_REQUEST_ERR',
\DOM_WRONG_DOCUMENT_ERR => 'DOM_WRONG_DOCUMENT_ERR',
\DOM_INVALID_CHARACTER_ERR => 'DOM_INVALID_CHARACTER_ERR',
\DOM_NO_DATA_ALLOWED_ERR => 'DOM_NO_DATA_ALLOWED_ERR',
\DOM_NO_MODIFICATION_ALLOWED_ERR => 'DOM_NO_MODIFICATION_ALLOWED_ERR',
\DOM_NOT_FOUND_ERR => 'DOM_NOT_FOUND_ERR',
\DOM_NOT_SUPPORTED_ERR => 'DOM_NOT_SUPPORTED_ERR',
\DOM_INUSE_ATTRIBUTE_ERR => 'DOM_INUSE_ATTRIBUTE_ERR',
\DOM_INVALID_STATE_ERR => 'DOM_INVALID_STATE_ERR',
\DOM_SYNTAX_ERR => 'DOM_SYNTAX_ERR',
\DOM_INVALID_MODIFICATION_ERR => 'DOM_INVALID_MODIFICATION_ERR',
\DOM_NAMESPACE_ERR => 'DOM_NAMESPACE_ERR',
\DOM_INVALID_ACCESS_ERR => 'DOM_INVALID_ACCESS_ERR',
\DOM_VALIDATION_ERR => 'DOM_VALIDATION_ERR',
]

◆ ERROR_CODES

const ERROR_CODES
private
Valeur initiale :
= [
\DOM_PHP_ERR => 'DOM_PHP_ERR'

◆ NODE_TYPES

const NODE_TYPES
private
Valeur initiale :
= [
\XML_ELEMENT_NODE => 'XML_ELEMENT_NODE'

◆ XML_ATTRIBUTE_NODE

const XML_ATTRIBUTE_NODE
Valeur initiale :
=> 'XML_ATTRIBUTE_NODE',
\XML_TEXT_NODE => 'XML_TEXT_NODE',
\XML_CDATA_SECTION_NODE => 'XML_CDATA_SECTION_NODE',
\XML_ENTITY_REF_NODE => 'XML_ENTITY_REF_NODE',
\XML_ENTITY_NODE => 'XML_ENTITY_NODE',
\XML_PI_NODE => 'XML_PI_NODE',
\XML_COMMENT_NODE => 'XML_COMMENT_NODE',
\XML_DOCUMENT_NODE => 'XML_DOCUMENT_NODE',
\XML_DOCUMENT_TYPE_NODE => 'XML_DOCUMENT_TYPE_NODE',
\XML_DOCUMENT_FRAG_NODE => 'XML_DOCUMENT_FRAG_NODE',
\XML_NOTATION_NODE => 'XML_NOTATION_NODE',
\XML_HTML_DOCUMENT_NODE => 'XML_HTML_DOCUMENT_NODE',
\XML_DTD_NODE => 'XML_DTD_NODE',
\XML_ELEMENT_DECL_NODE => 'XML_ELEMENT_DECL_NODE',
\XML_ATTRIBUTE_DECL_NODE => 'XML_ATTRIBUTE_DECL_NODE',
\XML_ENTITY_DECL_NODE => 'XML_ENTITY_DECL_NODE',
\XML_NAMESPACE_DECL_NODE => 'XML_NAMESPACE_DECL_NODE',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • DOMCaster.php


Joomla CMS: Référence de la classe DsCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • DsCaster
Fonctions membres publiques statiques
Référence de la classe DsCaster

Fonctions membres publiques statiques

static | castCollection (Collection $c, array $a, Stub $stub, bool $isNested)
static | castMap (Map $c, array $a, Stub $stub, bool $isNested)
static | castPair (Pair $c, array $a, Stub $stub, bool $isNested)
static | castPairStub (DsPairStub $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Casts Ds extension classes to array representation.

Auteur
Jáchym Toušek enuma.nosp@m.g@gm.nosp@m.ail.c.nosp@m.om

Documentation des fonctions membres

◆ castCollection()

static castCollection | ( | Collection | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castMap()

static castMap | ( | Map | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castPair()

static castPair | ( | Pair | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castPairStub()

static castPairStub | ( | DsPairStub | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, class, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DsCaster.php


Joomla CMS: Référence de la classe DsPairStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • DsPairStub
Fonctions membres publiques
Référence de la classe DsPairStub
+ Graphe d'héritage de DsPairStub:
Stub

Fonctions membres publiques

__construct ($key, $value)
- Fonctions membres publiques hérités de Stub
__sleep ()

Membres hérités additionnels

- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key,
 |  | $value
 | ) |

Références $key, Stub\$value, Caster\PREFIX_VIRTUAL, et value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • DsPairStub.php


Joomla CMS: Référence de la classe EnumStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • EnumStub
Fonctions membres publiques | Champs de données
Référence de la classe EnumStub
+ Graphe d'héritage de EnumStub:
Stub ArgsStub FrameStub

Fonctions membres publiques

__construct (array $values, bool $dumpKeys=true)
- Fonctions membres publiques hérités de Stub
__sleep ()

Champs de données

$dumpKeys = true
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents an enumeration of values.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $values,
 |  | bool | $dumpKeys = true
 | ) |  |

Références EnumStub\$dumpKeys, et value.

Documentation des champs

◆ $dumpKeys

$dumpKeys = true

Référencé par EnumStub\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EnumStub.php


Joomla CMS: Référence de la classe ExceptionCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ExceptionCaster
Fonctions membres publiques statiques | Attributs publics statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe ExceptionCaster

Fonctions membres publiques statiques

static | castError (\Error $e, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castException (\Exception $e, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castErrorException (\ErrorException $e, array $a, Stub $stub, bool $isNested)
static | castThrowingCasterException (ThrowingCasterException $e, array $a, Stub $stub, bool $isNested)
static | castSilencedErrorContext (SilencedErrorContext $e, array $a, Stub $stub, bool $isNested)
static | castTraceStub (TraceStub $trace, array $a, Stub $stub, bool $isNested)
static | castFrameStub (FrameStub $frame, array $a, Stub $stub, bool $isNested)

Attributs publics statiques

static | $srcContext = 1
static | $traceArgs = true
static | $errorTypes
static | E_USER_DEPRECATED

Fonctions membres privées statiques

static | filterExceptionArray (string $xClass, array $a, string $xPrefix, int $filter)
static | traceUnshift (array &$trace, ?string $class, string $file, int $line)
static | extractSource (string $srcLines, int $line, int $srcContext, string $lang, ?string $file, array $frame)

Attributs privés statiques

static $framesCache = []

Description détaillée

Casts common Exception classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castError()

static castError | ( | \Error | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

◆ castErrorException()

static castErrorException | ( | \ErrorException | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Caster\PREFIX_PROTECTED.

◆ castException()

static castException | ( | \Exception | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

◆ castFrameStub()

static castFrameStub | ( | FrameStub | $frame,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $prefix, $template, $templatePath, elseif, if, null, et Caster\PREFIX_VIRTUAL.

Référencé par ReflectionCaster\castReflectionGenerator().

◆ castSilencedErrorContext()

static castSilencedErrorContext | ( | SilencedErrorContext | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Caster\PREFIX_VIRTUAL.

◆ castThrowingCasterException()

static castThrowingCasterException | ( | ThrowingCasterException | $e,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $b, $class, $prefix, Caster\PREFIX_PROTECTED, Caster\PREFIX_VIRTUAL, et value.

◆ castTraceStub()

static castTraceStub | ( | TraceStub | $trace,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $i, $label, $prefix, elseif, null, et Caster\PREFIX_VIRTUAL.

◆ extractSource()

static extractSource | ( | string | $srcLines,
 |  | int | $line,
 |  | int | $srcContext,
 |  | string | $lang,
 |  | ?string | $file,
 |  | array | $frame
 | ) |  |
staticprivate

Références $c, $i, $lang, ExceptionCaster\$srcContext, ReflectionCaster\castFunctionAbstract(), Caster\EXCLUDE_VERBOSE, ReflectionCaster\getSignature(), null, et Stub\TYPE_OBJECT.

◆ filterExceptionArray()

static filterExceptionArray | ( | string | $xClass,
 |  | array | $a,
 |  | string | $xPrefix,
 |  | int | $filter
 | ) |  |
staticprivate

Références Caster\EXCLUDE_VERBOSE, Caster\PREFIX_DYNAMIC, Caster\PREFIX_PROTECTED, et Caster\PREFIX_VIRTUAL.

◆ traceUnshift()

static traceUnshift | ( | array & | $trace,
 |  | ?string | $class,
 |  | string | $file,
 |  | int | $line
 | ) |  |
staticprivate

Références $class, et null.

Documentation des champs

◆ $errorTypes

$errorTypes
static
Valeur initiale :
= [
\E_DEPRECATED => 'E_DEPRECATED'

◆ $framesCache

$framesCache = []
staticprivate

◆ $srcContext

$srcContext = 1
static

Référencé par ExceptionCaster\extractSource().

◆ $traceArgs

$traceArgs = true
static

◆ E_USER_DEPRECATED

E_USER_DEPRECATED
static
Valeur initiale :
=> 'E_USER_DEPRECATED',
\E_RECOVERABLE_ERROR => 'E_RECOVERABLE_ERROR',
\E_ERROR => 'E_ERROR',
\E_WARNING => 'E_WARNING',
\E_PARSE => 'E_PARSE',
\E_NOTICE => 'E_NOTICE',
\E_CORE_ERROR => 'E_CORE_ERROR',
\E_CORE_WARNING => 'E_CORE_WARNING',
\E_COMPILE_ERROR => 'E_COMPILE_ERROR',
\E_COMPILE_WARNING => 'E_COMPILE_WARNING',
\E_USER_ERROR => 'E_USER_ERROR',
\E_USER_WARNING => 'E_USER_WARNING',
\E_USER_NOTICE => 'E_USER_NOTICE',
\E_STRICT => 'E_STRICT',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExceptionCaster.php


Joomla CMS: Référence de la classe FiberCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • FiberCaster
Fonctions membres publiques statiques
Référence de la classe FiberCaster

Fonctions membres publiques statiques

static castFiber (\Fiber $fiber, array $a, Stub $stub, bool $isNested, int $filter=0)

Description détaillée

Casts Fiber related classes to array representation.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ castFiber()

static castFiber | ( | \Fiber | $fiber,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $prefix, elseif, et Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • FiberCaster.php


Joomla CMS: Référence de la classe FrameStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • FrameStub
Fonctions membres publiques | Champs de données
Référence de la classe FrameStub
+ Graphe d'héritage de FrameStub:
EnumStub Stub

Fonctions membres publiques

__construct (array $frame, bool $keepArgs=true, bool $inTraceStub=false)
- Fonctions membres publiques hérités de EnumStub
__construct (array $values, bool $dumpKeys=true)
- Fonctions membres publiques hérités de Stub
__sleep ()

Champs de données

$keepArgs
$inTraceStub
- Champs de données hérités de EnumStub
$dumpKeys = true
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a single backtrace frame as returned by debug_backtrace() or Exception->getTrace().

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $frame,
 |  | bool | $keepArgs = true,
 |  | bool | $inTraceStub = false
 | ) |  |

Références FrameStub\$inTraceStub, FrameStub\$keepArgs, et value.

Documentation des champs

◆ $inTraceStub

$inTraceStub

Référencé par FrameStub\__construct().

◆ $keepArgs

$keepArgs

Référencé par FrameStub\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FrameStub.php


Joomla CMS: Référence de la classe GmpCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • GmpCaster
Fonctions membres publiques statiques
Référence de la classe GmpCaster

Fonctions membres publiques statiques

static castGmp (\GMP $gmp, array $a, Stub $stub, bool $isNested, int $filter)

Description détaillée

Casts GMP objects to array representation.

Auteur
Hamza Amrouche hamza.nosp@m..sim.nosp@m.perfi.nosp@m.t@gm.nosp@m.ail.c.nosp@m.om
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castGmp()

static castGmp | ( | \GMP | $gmp,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter
 | ) |  |
static

Références Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • GmpCaster.php


Joomla CMS: Référence de la classe ImagineCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ImagineCaster
Fonctions membres publiques statiques
Référence de la classe ImagineCaster

Fonctions membres publiques statiques

static castImage (ImageInterface $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ castImage()

static castImage | ( | ImageInterface | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ImagineCaster.php


Joomla CMS: Référence de la classe ImgStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ImgStub
Fonctions membres publiques
Référence de la classe ImgStub
+ Graphe d'héritage de ImgStub:
ConstStub Stub

Fonctions membres publiques

__construct (string $data, string $contentType, string $size='')
- Fonctions membres publiques hérités de ConstStub
__construct (string $name, $value=null)
__toString ()
- Fonctions membres publiques hérités de Stub
__sleep ()

Membres hérités additionnels

- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $data,
 |  | string | $contentType,
 |  | string | $size = ''
 | ) |  |

Références $data, $size, et value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ImgStub.php


Joomla CMS: Référence de la classe IntlCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • IntlCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe IntlCaster

Fonctions membres publiques statiques

static | castMessageFormatter (\MessageFormatter $c, array $a, Stub $stub, bool $isNested)
static | castNumberFormatter (\NumberFormatter $c, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castIntlTimeZone (\IntlTimeZone $c, array $a, Stub $stub, bool $isNested)
static | castIntlCalendar (\IntlCalendar $c, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castIntlDateFormatter (\IntlDateFormatter $c, array $a, Stub $stub, bool $isNested, int $filter=0)

Fonctions membres privées statiques

static castError (object $c, array $a)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Jan Schädlich jan.s.nosp@m.chae.nosp@m.dlich.nosp@m.@sen.nosp@m.siola.nosp@m.bs.d.nosp@m.e

Documentation des fonctions membres

◆ castError()

static castError | ( | object | $c,
 |  | array | $a
 | ) |  |
staticprivate

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castIntlCalendar()

static castIntlCalendar | ( | \IntlCalendar | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castIntlDateFormatter()

static castIntlDateFormatter | ( | \IntlDateFormatter | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castIntlTimeZone()

static castIntlTimeZone | ( | \IntlTimeZone | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castMessageFormatter()

static castMessageFormatter | ( | \MessageFormatter | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castNumberFormatter()

static castNumberFormatter | ( | \NumberFormatter | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • IntlCaster.php


Joomla CMS: Référence de la classe LinkStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • LinkStub
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés statiques
Référence de la classe LinkStub
+ Graphe d'héritage de LinkStub:
ConstStub Stub

Fonctions membres publiques

__construct (string $label, int $line=0, string $href=null)
- Fonctions membres publiques hérités de ConstStub
__construct (string $name, $value=null)
__toString ()
- Fonctions membres publiques hérités de Stub
__sleep ()

Champs de données

$inVendor = false
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Fonctions membres privées

getComposerRoot (string $file, bool &$inVendor)

Attributs privés statiques

static | $vendorRoots
static | $composerRoots

Description détaillée

Represents a file or a URL.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $label,
 |  | int | $line = 0,
 |  | string | $href = null
 | ) |  |

Références $href, $label, elseif, LinkStub\getComposerRoot(), null, et value.

Documentation des fonctions membres

◆ getComposerRoot()

getComposerRoot | ( | string | $file,
 |  | bool & | $inVendor
 | ) |  |
private

Références Stub\$class, $dir, LinkStub\$inVendor, $r, $root, et null.

Référencé par LinkStub\__construct().

Documentation des champs

◆ $composerRoots

$composerRoots
staticprivate

◆ $inVendor

$inVendor = false

Référencé par LinkStub\getComposerRoot().

◆ $vendorRoots

$vendorRoots
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • LinkStub.php


Joomla CMS: Référence de la classe MemcachedCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • MemcachedCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe MemcachedCaster

Fonctions membres publiques statiques

static castMemcached (\Memcached $c, array $a, Stub $stub, bool $isNested)

Fonctions membres privées statiques

static | getNonDefaultOptions (\Memcached $c)
static | discoverDefaultOptions ()
static | getOptionConstants ()

Attributs privés statiques

static | $optionConstants
static | $defaultOptions

Description détaillée

Auteur
Jan Schädlich jan.s.nosp@m.chae.nosp@m.dlich.nosp@m.@sen.nosp@m.siola.nosp@m.bs.d.nosp@m.e

Documentation des fonctions membres

◆ castMemcached()

static castMemcached | ( | \Memcached | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ discoverDefaultOptions()

static discoverDefaultOptions ( )
staticprivate

Références MemcachedCaster\$defaultOptions, et $value.

◆ getNonDefaultOptions()

static getNonDefaultOptions ( \Memcached $c )
staticprivate

Références $c, $option, et $value.

◆ getOptionConstants()

static getOptionConstants ( )
staticprivate

Références MemcachedCaster\$optionConstants, $value, et class.

Documentation des champs

◆ $defaultOptions

$defaultOptions
staticprivate

Référencé par MemcachedCaster\discoverDefaultOptions().

◆ $optionConstants

$optionConstants
staticprivate

Référencé par MemcachedCaster\getOptionConstants().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MemcachedCaster.php


Joomla CMS: Référence de la classe MysqliCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • MysqliCaster
Fonctions membres publiques statiques
Référence de la classe MysqliCaster

Fonctions membres publiques statiques

static castMysqliDriver (\mysqli_driver $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castMysqliDriver()

static castMysqliDriver | ( | \mysqli_driver | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

La documentation de cette classe a été générée à partir du fichier suivant :
  • MysqliCaster.php


Joomla CMS: Référence de la classe PdoCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • PdoCaster
Fonctions membres publiques statiques | Attributs privés
Référence de la classe PdoCaster

Fonctions membres publiques statiques

static | castPdo (\PDO $c, array $a, Stub $stub, bool $isNested)
static | castPdoStatement (\PDOStatement $c, array $a, Stub $stub, bool $isNested)

Attributs privés

const PDO_ATTRIBUTES

Description détaillée

Casts PDO related classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castPdo()

static castPdo | ( | \PDO | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $attr, $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castPdoStatement()

static castPdoStatement | ( | \PDOStatement | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

Documentation des champs

◆ PDO_ATTRIBUTES

const PDO_ATTRIBUTES
private
Valeur initiale :
= [
'CASE' => [
\PDO::CASE_LOWER => 'LOWER'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PdoCaster.php


Joomla CMS: Référence de la classe PgSqlCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • PgSqlCaster
Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe PgSqlCaster

Fonctions membres publiques statiques

const static | castLargeObject ($lo, array $a, Stub $stub, bool $isNested)
static | castLink ($link, array $a, Stub $stub, bool $isNested)
static | castResult ($result, array $a, Stub $stub, bool $isNested)

Champs de données

const | PGSQL_TRANSACTION_ACTIVE
const | PGSQL_COMMAND_OK

Attributs privés

const | PARAM_CODES
const | TRANSACTION_STATUS
const | RESULT_STATUS
const | DIAG_CODES

Description détaillée

Casts pqsql resources to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castLargeObject()

const static castLargeObject | ( |  | $lo,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castLink()

static castLink | ( |  | $link,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $link.

◆ castResult()

static castResult | ( |  | $result,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $field, $fields, $i, $result, elseif, et null.

Documentation des champs

◆ DIAG_CODES

const DIAG_CODES
private
Valeur initiale :
= [
'severity' => \PGSQL_DIAG_SEVERITY

◆ PARAM_CODES

const PARAM_CODES
private
Valeur initiale :
= [
'server_encoding',
'client_encoding',
'is_superuser',
'session_authorization',
'DateStyle',
'TimeZone',
'IntervalStyle',
'integer_datetimes',
'application_name',
'standard_conforming_strings',
]

◆ PGSQL_COMMAND_OK

const PGSQL_COMMAND_OK
Valeur initiale :
=> 'PGSQL_COMMAND_OK',
\PGSQL_TUPLES_OK => 'PGSQL_TUPLES_OK',
\PGSQL_COPY_OUT => 'PGSQL_COPY_OUT',
\PGSQL_COPY_IN => 'PGSQL_COPY_IN',
\PGSQL_BAD_RESPONSE => 'PGSQL_BAD_RESPONSE',
\PGSQL_NONFATAL_ERROR => 'PGSQL_NONFATAL_ERROR',
\PGSQL_FATAL_ERROR => 'PGSQL_FATAL_ERROR',
]

◆ PGSQL_TRANSACTION_ACTIVE

const PGSQL_TRANSACTION_ACTIVE
Valeur initiale :
=> 'PGSQL_TRANSACTION_ACTIVE',
\PGSQL_TRANSACTION_INTRANS => 'PGSQL_TRANSACTION_INTRANS',
\PGSQL_TRANSACTION_INERROR => 'PGSQL_TRANSACTION_INERROR',
\PGSQL_TRANSACTION_UNKNOWN => 'PGSQL_TRANSACTION_UNKNOWN',
]

◆ RESULT_STATUS

const RESULT_STATUS
private
Valeur initiale :
= [
\PGSQL_EMPTY_QUERY => 'PGSQL_EMPTY_QUERY'

◆ TRANSACTION_STATUS

const TRANSACTION_STATUS
private
Valeur initiale :
= [
\PGSQL_TRANSACTION_IDLE => 'PGSQL_TRANSACTION_IDLE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PgSqlCaster.php


Joomla CMS: Référence de la classe ProxyManagerCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ProxyManagerCaster
Fonctions membres publiques statiques
Référence de la classe ProxyManagerCaster

Fonctions membres publiques statiques

static castProxy (ProxyInterface $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castProxy()

static castProxy | ( | ProxyInterface | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ProxyManagerCaster.php


Joomla CMS: Référence de la classe RdKafkaCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • RdKafkaCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe RdKafkaCaster

Fonctions membres publiques statiques

static | castKafkaConsumer (KafkaConsumer $c, array $a, Stub $stub, bool $isNested)
static | castTopic (Topic $c, array $a, Stub $stub, bool $isNested)
static | castTopicPartition (TopicPartition $c, array $a)
static | castMessage (Message $c, array $a, Stub $stub, bool $isNested)
static | castConf (Conf $c, array $a, Stub $stub, bool $isNested)
static | castTopicConf (TopicConf $c, array $a, Stub $stub, bool $isNested)
static | castRdKafka (\RdKafka $c, array $a, Stub $stub, bool $isNested)
static | castCollectionMetadata (CollectionMetadata $c, array $a, Stub $stub, bool $isNested)
static | castTopicMetadata (TopicMetadata $c, array $a, Stub $stub, bool $isNested)
static | castPartitionMetadata (PartitionMetadata $c, array $a, Stub $stub, bool $isNested)
static | castBrokerMetadata (BrokerMetadata $c, array $a, Stub $stub, bool $isNested)

Fonctions membres privées statiques

static extractMetadata ($c)

Description détaillée

Casts RdKafka related classes to array representation.

Auteur
Romain Neutron impre.nosp@m.c@gm.nosp@m.ail.c.nosp@m.om

Documentation des fonctions membres

◆ castBrokerMetadata()

static castBrokerMetadata | ( | BrokerMetadata | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castCollectionMetadata()

static castCollectionMetadata | ( | CollectionMetadata | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castConf()

static castConf | ( | Conf | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $key, $prefix, $value, et Caster\PREFIX_VIRTUAL.

◆ castKafkaConsumer()

static castKafkaConsumer | ( | KafkaConsumer | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castMessage()

static castMessage | ( | Message | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castPartitionMetadata()

static castPartitionMetadata | ( | PartitionMetadata | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castRdKafka()

static castRdKafka | ( | \RdKafka | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castTopic()

static castTopic | ( | Topic | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castTopicConf()

static castTopicConf | ( | TopicConf | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $key, $prefix, $value, et Caster\PREFIX_VIRTUAL.

◆ castTopicMetadata()

static castTopicMetadata | ( | TopicMetadata | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castTopicPartition()

static castTopicPartition | ( | TopicPartition | $c,
 |  | array | $a
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ extractMetadata()

static extractMetadata ( $c )
staticprivate

Références $c, $prefix, null, et Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • RdKafkaCaster.php


Joomla CMS: Référence de la classe RedisCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • RedisCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe RedisCaster

Fonctions membres publiques statiques

static | castRedis (\Redis $c, array $a, Stub $stub, bool $isNested)
static | castRedisArray (\RedisArray $c, array $a, Stub $stub, bool $isNested)
static | castRedisCluster (\RedisCluster $c, array $a, Stub $stub, bool $isNested)

Fonctions membres privées statiques

static getRedisOptions ($redis, array $options=[])

Attributs privés

const | SERIALIZERS
const | MODES
const | COMPRESSION_MODES
const const | FAILOVER_OPTIONS

Description détaillée

Casts Redis class from ext-redis to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castRedis()

static castRedis | ( | \Redis | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $mode, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castRedisArray()

static castRedisArray | ( | \RedisArray | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, Caster\PREFIX_VIRTUAL, et ClassStub\wrapCallable().

◆ castRedisCluster()

static castRedisCluster | ( | \RedisCluster | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, et Caster\PREFIX_VIRTUAL.

◆ getRedisOptions()

static getRedisOptions | ( |  | $redis,
 |  | array | $options = []
 | ) |  |
staticprivate
Paramètres
\Redis | \RedisArray | \RedisCluster $redis

Références $options, et elseif.

Documentation des champs

◆ COMPRESSION_MODES

const COMPRESSION_MODES
private
Valeur initiale :
= [
0 => 'NONE'

◆ FAILOVER_OPTIONS

const const FAILOVER_OPTIONS
private
Valeur initiale :
= [
\RedisCluster::FAILOVER_NONE => 'NONE'

◆ MODES

const MODES
private
Valeur initiale :
= [
\Redis::ATOMIC => 'ATOMIC'

◆ SERIALIZERS

const SERIALIZERS
private
Valeur initiale :
= [
\Redis::SERIALIZER_NONE => 'NONE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • RedisCaster.php


Joomla CMS: Référence de la classe ReflectionCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ReflectionCaster
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés
Référence de la classe ReflectionCaster

Fonctions membres publiques statiques

const static | castClosure (\Closure $c, array $a, Stub $stub, bool $isNested, int $filter=0)
static | unsetClosureFileInfo (\Closure $c, array $a)
static | castGenerator (\Generator $c, array $a, Stub $stub, bool $isNested)
static | castType (\ReflectionType $c, array $a, Stub $stub, bool $isNested)
static | castAttribute (\ReflectionAttribute $c, array $a, Stub $stub, bool $isNested)
static | castReflectionGenerator (\ReflectionGenerator $c, array $a, Stub $stub, bool $isNested)
static | castClass (\ReflectionClass $c, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castFunctionAbstract (\ReflectionFunctionAbstract $c, array $a, Stub $stub, bool $isNested, int $filter=0)
static | castClassConstant (\ReflectionClassConstant $c, array $a, Stub $stub, bool $isNested)
static | castMethod (\ReflectionMethod $c, array $a, Stub $stub, bool $isNested)
static | castParameter (\ReflectionParameter $c, array $a, Stub $stub, bool $isNested)
static | castProperty (\ReflectionProperty $c, array $a, Stub $stub, bool $isNested)
static | castReference (\ReflectionReference $c, array $a, Stub $stub, bool $isNested)
static | castExtension (\ReflectionExtension $c, array $a, Stub $stub, bool $isNested)
static | castZendExtension (\ReflectionZendExtension $c, array $a, Stub $stub, bool $isNested)
static | getSignature (array $a)

Champs de données

const UNSET_CLOSURE_FILE_INFO = ['Closure' => __CLASS__.'::unsetClosureFileInfo']

Fonctions membres privées statiques

static | addExtra (array &$a, \Reflector $c)
static | addMap (array &$a, object $c, array $map, string $prefix=Caster::PREFIX_VIRTUAL)
static | addAttributes (array &$a, \Reflector $c, string $prefix=Caster::PREFIX_VIRTUAL)

Attributs privés

const EXTRA_MAP

Description détaillée

Casts Reflector related classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ addAttributes()

static addAttributes | ( | array & | $a,
 |  | \Reflector | $c,
 |  | string | $prefix = Caster::PREFIX_VIRTUAL
 | ) |  |
staticprivate

Références $c, $n, et $prefix.

◆ addExtra()

static addExtra | ( | array & | $a,
 |  | \Reflector | $c
 | ) |  |
staticprivate

Références $c, et Caster\PREFIX_VIRTUAL.

◆ addMap()

static addMap | ( | array & | $a,
 |  | object | $c,
 |  | array | $map,
 |  | string | $prefix = Caster::PREFIX_VIRTUAL
 | ) |  |
staticprivate

Références $c, $prefix, et null.

◆ castAttribute()

static castAttribute | ( | \ReflectionAttribute | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castClass()

static castClass | ( | \ReflectionClass | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, $n, $prefix, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

◆ castClassConstant()

static castClassConstant | ( | \ReflectionClassConstant | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castClosure()

const static castClosure | ( | \Closure | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, $prefix, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

Référencé par CutStub\__construct().

◆ castExtension()

static castExtension | ( | \ReflectionExtension | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castFunctionAbstract()

static castFunctionAbstract | ( | \ReflectionFunctionAbstract | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested,
 |  | int | $filter = 0
 | ) |  |
static

Références $c, $prefix, Caster\EXCLUDE_VERBOSE, et Caster\PREFIX_VIRTUAL.

Référencé par ClassStub\__construct(), et ExceptionCaster\extractSource().

◆ castGenerator()

static castGenerator | ( | \Generator | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castMethod()

static castMethod | ( | \ReflectionMethod | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castParameter()

static castParameter | ( | \ReflectionParameter | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, null, et Caster\PREFIX_VIRTUAL.

◆ castProperty()

static castProperty | ( | \ReflectionProperty | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castReference()

static castReference | ( | \ReflectionReference | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castReflectionGenerator()

static castReflectionGenerator | ( | \ReflectionGenerator | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $function, $prefix, ExceptionCaster\castFrameStub(), null, et Caster\PREFIX_VIRTUAL.

◆ castType()

static castType | ( | \ReflectionType | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $prefix, elseif, et Caster\PREFIX_VIRTUAL.

◆ castZendExtension()

static castZendExtension | ( | \ReflectionZendExtension | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ getSignature()

static getSignature ( array $a )
static

Références $prefix, $type, elseif, null, et Caster\PREFIX_VIRTUAL.

Référencé par ClassStub\__construct(), et ExceptionCaster\extractSource().

◆ unsetClosureFileInfo()

static unsetClosureFileInfo | ( | \Closure | $c,
 |  | array | $a
 | ) |  |
static

Références Caster\PREFIX_VIRTUAL.

Documentation des champs

◆ EXTRA_MAP

const EXTRA_MAP
private
Valeur initiale :
= [
'docComment' => 'getDocComment'

◆ UNSET_CLOSURE_FILE_INFO

const UNSET_CLOSURE_FILE_INFO = ['Closure' => __CLASS__.'::unsetClosureFileInfo']

Référencé par RequestContextProvider\__construct(), et VarDumper\register().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ReflectionCaster.php


Joomla CMS: Référence de la classe ResourceCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • ResourceCaster
Fonctions membres publiques statiques
Référence de la classe ResourceCaster

Fonctions membres publiques statiques

static | castCurl ($h, array $a, Stub $stub, bool $isNested)
static | castDba ($dba, array $a, Stub $stub, bool $isNested)
static | castProcess ($process, array $a, Stub $stub, bool $isNested)
static | castStream ($stream, array $a, Stub $stub, bool $isNested)
static | castStreamContext ($stream, array $a, Stub $stub, bool $isNested)
static | castGd ($gd, array $a, Stub $stub, bool $isNested)
static | castMysqlLink ($h, array $a, Stub $stub, bool $isNested)
static | castOpensslX509 ($h, array $a, Stub $stub, bool $isNested)

Description détaillée

Casts common resource types to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castCurl()

static castCurl | ( |  | $h,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static
Paramètres
\CurlHandle | resource $h

◆ castDba()

static castDba | ( |  | $dba,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $list.

◆ castGd()

static castGd | ( |  | $gd,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castMysqlLink()

static castMysqlLink | ( |  | $h,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castOpensslX509()

static castOpensslX509 | ( |  | $h,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $info.

◆ castProcess()

static castProcess | ( |  | $process,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castStream()

static castStream | ( |  | $stream,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Laminas\Diactoros\$stream.

◆ castStreamContext()

static castStreamContext | ( |  | $stream,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références Laminas\Diactoros\$stream.

La documentation de cette classe a été générée à partir du fichier suivant :
  • ResourceCaster.php


Joomla CMS: Référence de la classe SplCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • SplCaster
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés
Référence de la classe SplCaster

Fonctions membres publiques statiques

static | castArrayObject (\ArrayObject $c, array $a, Stub $stub, bool $isNested)
static | castArrayIterator (\ArrayIterator $c, array $a, Stub $stub, bool $isNested)
static | castHeap (\Iterator $c, array $a, Stub $stub, bool $isNested)
static | castDoublyLinkedList (\SplDoublyLinkedList $c, array $a, Stub $stub, bool $isNested)
static | castFileInfo (\SplFileInfo $c, array $a, Stub $stub, bool $isNested)
static | castFileObject (\SplFileObject $c, array $a, Stub $stub, bool $isNested)
static | castObjectStorage (\SplObjectStorage $c, array $a, Stub $stub, bool $isNested)
static | castOuterIterator (\OuterIterator $c, array $a, Stub $stub, bool $isNested)
static | castWeakReference (\WeakReference $c, array $a, Stub $stub, bool $isNested)

Fonctions membres privées statiques

static castSplArray ($c, array $a, Stub $stub, bool $isNested)

Attributs privés

const SPL_FILE_OBJECT_FLAGS

Description détaillée

Casts SPL related classes to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castArrayIterator()

static castArrayIterator | ( | \ArrayIterator | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castArrayObject()

static castArrayObject | ( | \ArrayObject | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castDoublyLinkedList()

static castDoublyLinkedList | ( | \SplDoublyLinkedList | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $mode, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castFileInfo()

static castFileInfo | ( | \SplFileInfo | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $key, $prefix, et Caster\PREFIX_VIRTUAL.

◆ castFileObject()

static castFileObject | ( | \SplFileObject | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, $key, $name, $prefix, $value, et Caster\PREFIX_VIRTUAL.

◆ castHeap()

static castHeap | ( | \Iterator | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castObjectStorage()

static castObjectStorage | ( | \SplObjectStorage | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, Caster\PREFIX_DYNAMIC, et Caster\PREFIX_VIRTUAL.

◆ castOuterIterator()

static castOuterIterator | ( | \OuterIterator | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

◆ castSplArray()

static castSplArray | ( |  | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
staticprivate

Références $c, $prefix, Caster\castObject(), et Caster\PREFIX_VIRTUAL.

◆ castWeakReference()

static castWeakReference | ( | \WeakReference | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

Documentation des champs

◆ SPL_FILE_OBJECT_FLAGS

const SPL_FILE_OBJECT_FLAGS
private
Valeur initiale :
= [
\SplFileObject::DROP_NEW_LINE => 'DROP_NEW_LINE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SplCaster.php


Joomla CMS: Référence de la classe StubCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • StubCaster
Fonctions membres publiques statiques
Référence de la classe StubCaster

Fonctions membres publiques statiques

static | castStub (Stub $c, array $a, Stub $stub, bool $isNested)
static | castCutArray (CutArrayStub $c, array $a, Stub $stub, bool $isNested)
static | cutInternals ($obj, array $a, Stub $stub, bool $isNested)
static | castEnum (EnumStub $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Casts a caster's Stub.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castCutArray()

static castCutArray | ( | CutArrayStub | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c.

◆ castEnum()

static castEnum | ( | EnumStub | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, null, et Caster\PREFIX_VIRTUAL.

◆ castStub()

static castStub | ( | Stub | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, Stub\STRING_BINARY, Stub\TYPE_REF, et Stub\TYPE_STRING.

◆ cutInternals()

static cutInternals | ( |  | $obj,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • StubCaster.php


Joomla CMS: Référence de la classe SymfonyCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • SymfonyCaster
Fonctions membres publiques statiques | Attributs privés
Référence de la classe SymfonyCaster

Fonctions membres publiques statiques

const static | castRequest (Request $request, array $a, Stub $stub, bool $isNested)
static | castHttpClient ($client, array $a, Stub $stub, bool $isNested)
static | castHttpClientResponse ($response, array $a, Stub $stub, bool $isNested)
static | castUuid (Uuid $uuid, array $a, Stub $stub, bool $isNested)
static | castUlid (Ulid $ulid, array $a, Stub $stub, bool $isNested)

Attributs privés

const REQUEST_GETTERS

Description détaillée

Documentation des fonctions membres

◆ castHttpClient()

static castHttpClient | ( |  | $client,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $client.

◆ castHttpClientResponse()

static castHttpClientResponse | ( |  | $response,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castRequest()

const static castRequest | ( | Request | $request,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $key, null, Caster\PREFIX_PROTECTED, et Caster\PREFIX_VIRTUAL.

◆ castUlid()

static castUlid | ( | Ulid | $ulid,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

◆ castUuid()

static castUuid | ( | Uuid | $uuid,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Documentation des champs

◆ REQUEST_GETTERS

const REQUEST_GETTERS
private
Valeur initiale :
= [
'pathInfo' => 'getPathInfo'
La documentation de cette classe a été générée à partir du fichier suivant :
  • SymfonyCaster.php


Joomla CMS: Référence de la classe TraceStub

  • Symfony
  • Component
  • VarDumper
  • Caster
  • TraceStub
Fonctions membres publiques | Champs de données
Référence de la classe TraceStub
+ Graphe d'héritage de TraceStub:
Stub

Fonctions membres publiques

__construct (array $trace, bool $keepArgs=true, int $sliceOffset=0, int $sliceLength=null, int $numberingOffset=0)
- Fonctions membres publiques hérités de Stub
__sleep ()

Champs de données

$keepArgs
$sliceOffset
$sliceLength
$numberingOffset
- Champs de données hérités de Stub
const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Description détaillée

Represents a backtrace as returned by debug_backtrace() or Exception->getTrace().

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | array | $trace,
 |  | bool | $keepArgs = true,
 |  | int | $sliceOffset = 0,
 |  | int | $sliceLength = null,
 |  | int | $numberingOffset = 0
 | ) |  |

Références TraceStub\$keepArgs, TraceStub\$numberingOffset, TraceStub\$sliceLength, TraceStub\$sliceOffset, et value.

Documentation des champs

◆ $keepArgs

$keepArgs

Référencé par TraceStub\__construct().

◆ $numberingOffset

$numberingOffset

Référencé par TraceStub\__construct().

◆ $sliceLength

$sliceLength

Référencé par TraceStub\__construct().

◆ $sliceOffset

$sliceOffset

Référencé par TraceStub\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TraceStub.php


Joomla CMS: Référence de la classe UuidCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • UuidCaster
Fonctions membres publiques statiques
Référence de la classe UuidCaster

Fonctions membres publiques statiques

static castRamseyUuid (UuidInterface $c, array $a, Stub $stub, bool $isNested)

Description détaillée

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info

Documentation des fonctions membres

◆ castRamseyUuid()

static castRamseyUuid | ( | UuidInterface | $c,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $c, et Caster\PREFIX_VIRTUAL.

La documentation de cette classe a été générée à partir du fichier suivant :
  • UuidCaster.php


Joomla CMS: Référence de la classe XmlReaderCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • XmlReaderCaster
Fonctions membres publiques statiques | Attributs privés
Référence de la classe XmlReaderCaster

Fonctions membres publiques statiques

static castXmlReader (\XMLReader $reader, array $a, Stub $stub, bool $isNested)

Attributs privés

const NODE_TYPES

Description détaillée

Casts XmlReader class to array representation.

Auteur
Baptiste Clavié clavi.nosp@m.e.b@.nosp@m.gmail.nosp@m..com

Documentation des fonctions membres

◆ castXmlReader()

static castXmlReader | ( | \XMLReader | $reader,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Références $count, $info, Caster\EXCLUDE_EMPTY, Caster\filter(), null, et Caster\PREFIX_VIRTUAL.

Documentation des champs

◆ NODE_TYPES

const NODE_TYPES
private
Valeur initiale :
= [
\XMLReader::NONE => 'NONE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlReaderCaster.php


Joomla CMS: Référence de la classe XmlResourceCaster

  • Symfony
  • Component
  • VarDumper
  • Caster
  • XmlResourceCaster
Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe XmlResourceCaster

Fonctions membres publiques statiques

static castXml ($h, array $a, Stub $stub, bool $isNested)

Champs de données

const XML_ERROR_NO_MEMORY

Attributs privés

const XML_ERRORS

Description détaillée

Casts XML resources to array representation.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ castXml()

static castXml | ( |  | $h,
 |  | array | $a,
 |  | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
static

Documentation des champs

◆ XML_ERROR_NO_MEMORY

const XML_ERROR_NO_MEMORY
Valeur initiale :
=> 'XML_ERROR_NO_MEMORY',
\XML_ERROR_SYNTAX => 'XML_ERROR_SYNTAX',
\XML_ERROR_NO_ELEMENTS => 'XML_ERROR_NO_ELEMENTS',
\XML_ERROR_INVALID_TOKEN => 'XML_ERROR_INVALID_TOKEN',
\XML_ERROR_UNCLOSED_TOKEN => 'XML_ERROR_UNCLOSED_TOKEN',
\XML_ERROR_PARTIAL_CHAR => 'XML_ERROR_PARTIAL_CHAR',
\XML_ERROR_TAG_MISMATCH => 'XML_ERROR_TAG_MISMATCH',
\XML_ERROR_DUPLICATE_ATTRIBUTE => 'XML_ERROR_DUPLICATE_ATTRIBUTE',
\XML_ERROR_JUNK_AFTER_DOC_ELEMENT => 'XML_ERROR_JUNK_AFTER_DOC_ELEMENT',
\XML_ERROR_PARAM_ENTITY_REF => 'XML_ERROR_PARAM_ENTITY_REF',
\XML_ERROR_UNDEFINED_ENTITY => 'XML_ERROR_UNDEFINED_ENTITY',
\XML_ERROR_RECURSIVE_ENTITY_REF => 'XML_ERROR_RECURSIVE_ENTITY_REF',
\XML_ERROR_ASYNC_ENTITY => 'XML_ERROR_ASYNC_ENTITY',
\XML_ERROR_BAD_CHAR_REF => 'XML_ERROR_BAD_CHAR_REF',
\XML_ERROR_BINARY_ENTITY_REF => 'XML_ERROR_BINARY_ENTITY_REF',
\XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF => 'XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF',
\XML_ERROR_MISPLACED_XML_PI => 'XML_ERROR_MISPLACED_XML_PI',
\XML_ERROR_UNKNOWN_ENCODING => 'XML_ERROR_UNKNOWN_ENCODING',
\XML_ERROR_INCORRECT_ENCODING => 'XML_ERROR_INCORRECT_ENCODING',
\XML_ERROR_UNCLOSED_CDATA_SECTION => 'XML_ERROR_UNCLOSED_CDATA_SECTION',
\XML_ERROR_EXTERNAL_ENTITY_HANDLING => 'XML_ERROR_EXTERNAL_ENTITY_HANDLING',
]

◆ XML_ERRORS

const XML_ERRORS
private
Valeur initiale :
= [
\XML_ERROR_NONE => 'XML_ERROR_NONE'
La documentation de cette classe a été générée à partir du fichier suivant :
  • XmlResourceCaster.php


Joomla CMS: Référence de la classe AbstractCloner

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • AbstractCloner
Fonctions membres publiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe AbstractCloner
+ Graphe d'héritage de AbstractCloner:
ClonerInterface VarCloner

Fonctions membres publiques

__construct (array $casters=null)
addCasters (array $casters)
setMaxItems (int $maxItems)
setMaxString (int $maxString)
setMinDepth (int $minDepth)
cloneVar ($var, int $filter=0)
- Fonctions membres publiques hérités de ClonerInterface
cloneVar ($var)

Attributs publics statiques

static $defaultCasters

Fonctions membres protégées

doClone ($var)
castObject (Stub $stub, bool $isNested)
castResource (Stub $stub, bool $isNested)

Attributs protégés

static $maxItems = 2500
$maxString = -1
$minDepth = 1

Attributs privés

$casters = []
$prevErrorHandler
$classInfo = []
$filter = 0

Description détaillée

AbstractCloner implements a generic caster mechanism for objects and resources.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $casters = null )
Paramètres
callable[]|null $casters A map of casters
Voir également
addCasters

Références AbstractCloner\$casters, AbstractCloner\addCasters(), et null.

Documentation des fonctions membres

◆ addCasters()

addCasters ( array $casters )

Adds casters for resources and objects.

Maps resources or objects types to a callback. Types are in the key, with a callable caster for value. Resource types are to be prefixed with a :, see e.g. static::$defaultCasters.

Paramètres
callable[] $casters A map of casters

Références AbstractCloner\$casters, et $type.

Référencé par AbstractCloner\__construct().

◆ castObject()

castObject | ( | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
protected

Casts an object to an array representation.

Paramètres
bool $isNested True if the object is nested in the dumped structure
Renvoie
array

Références $class, $i, $r, Caster\castObject(), class, null, Caster\PREFIX_VIRTUAL, et Stub\TYPE_OBJECT.

Référencé par VarCloner\doClone().

◆ castResource()

castResource | ( | Stub | $stub,
 |  | bool | $isNested
 | ) |  |
protected

Casts a resource to an array representation.

Paramètres
bool $isNested True if the object is nested in the dumped structure
Renvoie
array

Références $type, Caster\PREFIX_VIRTUAL, et Stub\TYPE_OBJECT.

Référencé par VarCloner\doClone().

◆ cloneVar()

cloneVar | ( |  | $var,
 |  | int | $filter = 0
 | ) |  |

Clones a PHP variable.

Paramètres
mixed | $var | Any PHP variable
int | $filter | A bit field of Caster::EXCLUDE_* constants
Renvoie
Data

Références $context, AbstractCloner\$filter, $type, AbstractCloner\doClone(), et null.

◆ doClone()

doClone ( $var )
abstractprotected

Effectively clones the PHP variable.

Paramètres
mixed $var Any PHP variable
Renvoie
array

Référencé par AbstractCloner\cloneVar().

◆ setMaxItems()

setMaxItems ( int $maxItems )

Sets the maximum number of items to clone past the minimum depth in nested structures.

Références AbstractCloner\$maxItems.

◆ setMaxString()

setMaxString ( int $maxString )

Sets the maximum cloned length for strings.

Références AbstractCloner\$maxString.

◆ setMinDepth()

setMinDepth ( int $minDepth )

Sets the minimum tree depth where we are guaranteed to clone all the items. After this depth is reached, only setMaxItems items will be cloned.

Références AbstractCloner\$minDepth.

Documentation des champs

◆ $casters

$casters = []
private

Référencé par AbstractCloner\__construct(), et AbstractCloner\addCasters().

◆ $classInfo

$classInfo = []
private

◆ $defaultCasters

$defaultCasters
static
Valeur initiale :
= [
'__PHP_Incomplete_Class' => ['Symfony\Component\VarDumper\Caster\Caster', 'castPhpIncompleteClass']

◆ $filter

$filter = 0
private

Référencé par AbstractCloner\cloneVar().

◆ $maxItems

$maxItems = 2500
protected

Référencé par VarCloner\doClone(), et AbstractCloner\setMaxItems().

◆ $maxString

$maxString = -1
protected

Référencé par VarCloner\doClone(), et AbstractCloner\setMaxString().

◆ $minDepth

$minDepth = 1
protected

Référencé par VarCloner\doClone(), et AbstractCloner\setMinDepth().

◆ $prevErrorHandler

$prevErrorHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractCloner.php


Joomla CMS: Référence de l'interface ClonerInterface

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • ClonerInterface
Fonctions membres publiques
Référence de l'interface ClonerInterface
+ Graphe d'héritage de ClonerInterface:
AbstractCloner VarCloner

Fonctions membres publiques

cloneVar ($var)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ cloneVar()

cloneVar ( $var )

Clones a PHP variable.

Paramètres
mixed $var Any PHP variable
Renvoie
Data
La documentation de cette interface a été générée à partir du fichier suivant :
  • ClonerInterface.php


Joomla CMS: Référence de la classe Cursor

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • Cursor
Champs de données
Référence de la classe Cursor

Champs de données

const | HASH_INDEXED = Stub::ARRAY_INDEXED
const | HASH_ASSOC = Stub::ARRAY_ASSOC
const | HASH_OBJECT = Stub::TYPE_OBJECT
const | HASH_RESOURCE = Stub::TYPE_RESOURCE
$depth = 0
$refIndex = 0
$softRefTo = 0
$softRefCount = 0
$softRefHandle = 0
$hardRefTo = 0
$hardRefCount = 0
$hardRefHandle = 0
$hashType
$hashKey
$hashKeyIsBinary
$hashIndex = 0
$hashLength = 0
$hashCut = 0
$stop = false
$attr = []
$skipChildren = false

Description détaillée

Represents the current state of a dumper while dumping.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des champs

◆ $attr

$attr = []

◆ $depth

$depth = 0

◆ $hardRefCount

$hardRefCount = 0

◆ $hardRefHandle

$hardRefHandle = 0

◆ $hardRefTo

$hardRefTo = 0

◆ $hashCut

$hashCut = 0

◆ $hashIndex

$hashIndex = 0

◆ $hashKey

$hashKey

◆ $hashKeyIsBinary

$hashKeyIsBinary

◆ $hashLength

$hashLength = 0

◆ $hashType

$hashType

◆ $refIndex

$refIndex = 0

◆ $skipChildren

$skipChildren = false

◆ $softRefCount

$softRefCount = 0

◆ $softRefHandle

$softRefHandle = 0

◆ $softRefTo

$softRefTo = 0

◆ $stop

$stop = false

◆ HASH_ASSOC

const HASH_ASSOC = Stub::ARRAY_ASSOC

Référencé par CliDumper\dumpKey().

◆ HASH_INDEXED

const HASH_INDEXED = Stub::ARRAY_INDEXED

Référencé par Data\dumpItem(), et CliDumper\dumpKey().

◆ HASH_OBJECT

const HASH_OBJECT = Stub::TYPE_OBJECT

Référencé par CliDumper\dumpKey(), CliDumper\enterHash(), et CliDumper\leaveHash().

◆ HASH_RESOURCE

const HASH_RESOURCE = Stub::TYPE_RESOURCE

Référencé par CliDumper\dumpKey(), CliDumper\enterHash(), et CliDumper\leaveHash().

La documentation de cette classe a été générée à partir du fichier suivant :
  • var-dumper/Cloner/Cursor.php


Joomla CMS: Référence de la classe Data

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • Data
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe Data
+ Graphe d'héritage de Data:
SeekingData

Fonctions membres publiques

__construct (array $data)
getType ()
getValue ($recursive=false)
count ()
getIterator ()
__get (string $key)
__isset (string $key)
offsetExists ($key)
offsetGet ($key)
offsetSet ($key, $value)
offsetUnset ($key)
__toString ()
withMaxDepth (int $maxDepth)
withMaxItemsPerDepth (int $maxItemsPerDepth)
withRefHandles (bool $useRefHandles)
withContext (array $context)
seek ($key)
dump (DumperInterface $dumper)

Fonctions membres privées

dumpItem (DumperInterface $dumper, Cursor $cursor, array &$refs, $item)
dumpChildren (DumperInterface $dumper, Cursor $parentCursor, array &$refs, array $children, int $hashCut, int $hashType, bool $dumpKeys)
getStub ($item)

Attributs privés

$data
$position = 0
$key = 0
$maxDepth = 20
$maxItemsPerDepth = -1
$useRefHandles = -1
$context = []

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $data )
Paramètres
array $data An array as returned by ClonerInterface::cloneVar()

Références Data\$data.

Documentation des fonctions membres

◆ __get()

__get ( string $key )

Références Data\$data, $item, Data\getStub(), null, et Data\seek().

Référencé par Data\offsetGet().

◆ __isset()

__isset ( string $key )
Renvoie
bool

Références null, et Data\seek().

Référencé par Data\offsetExists().

◆ __toString()

__toString ( )
Renvoie
string

Références $value, Data\count(), Data\getType(), et Data\getValue().

◆ count()

count ( )
Renvoie
int

Références Data\getValue().

Référencé par Data\__toString(), Data\dumpChildren(), Data\dumpItem(), et Data\getStub().

◆ dump()

dump ( DumperInterface $dumper )

Dumps data with a DumperInterface dumper.

Références $this, class, Data\dumpItem(), et DumperInterface\dumpScalar().

Référencé par AbstractDumper\dump().

◆ dumpChildren()

dumpChildren | ( | DumperInterface | $dumper,
 |  | Cursor | $parentCursor,
 |  | array & | $refs,
 |  | array | $children,
 |  | int | $hashCut,
 |  | int | $hashType,
 |  | bool | $dumpKeys
 | ) |  |
private

Dumps children of hash structures.

Renvoie
int The final number of removed items

Références Data\$key, $this, Data\count(), Data\dumpItem(), et null.

Référencé par Data\dumpItem().

◆ dumpItem()

dumpItem | ( | DumperInterface | $dumper,
 |  | Cursor | $cursor,
 |  | array & | $refs,
 |  |  | $item
 | ) |  |
private

Depth-first dumping of items.

Paramètres
mixed $item A Stub object or the original value being dumped

Références $item, Data\$maxItemsPerDepth, $r, $type, Data\count(), Data\dumpChildren(), DumperInterface\dumpScalar(), DumperInterface\dumpString(), elseif, DumperInterface\enterHash(), Data\getStub(), Cursor\HASH_INDEXED, DumperInterface\leaveHash(), null, Stub\STRING_BINARY, Stub\TYPE_ARRAY, Stub\TYPE_OBJECT, Stub\TYPE_REF, Stub\TYPE_RESOURCE, et Stub\TYPE_STRING.

Référencé par Data\dump(), et Data\dumpChildren().

◆ getIterator()

getIterator ( )
Renvoie

Références $value, class, et Data\getValue().

◆ getStub()

getStub ( $item )
private

Références $item, Data\count(), et Stub\TYPE_ARRAY.

Référencé par Data\__get(), Data\dumpItem(), Data\getValue(), et Data\seek().

◆ getType()

getType ( )
Renvoie
string|null

Références $item, Data\$key, Data\$position, null, Stub\TYPE_ARRAY, Stub\TYPE_OBJECT, Stub\TYPE_REF, Stub\TYPE_RESOURCE, et Stub\TYPE_STRING.

Référencé par Data\__toString().

◆ getValue()

getValue ( $recursive = false )

Returns a native representation of the original value.

Paramètres
array | bool $recursive Whether values should be resolved recursively or not
Renvoie
string|int|float|bool|array|Data[]|null

Références $item, Data\$key, Data\$position, $this, Data\getStub(), Stub\TYPE_REF, et Stub\TYPE_STRING.

Référencé par Data\__toString(), Data\count(), et Data\getIterator().

◆ offsetExists()

offsetExists ( $key )
Renvoie
bool

Références Data\$key, et Data\__isset().

◆ offsetGet()

offsetGet ( $key )
Renvoie
mixed

Références Data\$key, et Data\__get().

◆ offsetSet()

offsetSet | ( | $key,
 |  | $value
 | ) |
Renvoie
void

Références class.

◆ offsetUnset()

offsetUnset ( $key )
Renvoie
void

Références class.

◆ seek()

seek ( $key )

Seeks to a specific key in nested data structures.

Paramètres
string | int $key The key to seek to
Renvoie
static|null

Références Data\$data, $item, Data\$key, Data\$position, $this, Data\getStub(), null, Caster\PREFIX_DYNAMIC, Caster\PREFIX_PROTECTED, Caster\PREFIX_VIRTUAL, Stub\TYPE_ARRAY, Stub\TYPE_OBJECT, Stub\TYPE_REF, et Stub\TYPE_RESOURCE.

Référencé par Data\__get(), et Data\__isset().

◆ withContext()

withContext ( array $context )
Renvoie
static

Références Data\$context, Data\$data, et $this.

◆ withMaxDepth()

withMaxDepth ( int $maxDepth )

Returns a depth limited clone of $this.

Renvoie
static

Références Data\$data, Data\$maxDepth, et $this.

◆ withMaxItemsPerDepth()

withMaxItemsPerDepth ( int $maxItemsPerDepth )

Limits the number of elements per depth level.

Renvoie
static

Références Data\$data, Data\$maxItemsPerDepth, et $this.

◆ withRefHandles()

withRefHandles ( bool $useRefHandles )

Enables/disables objects' identifiers tracking.

Paramètres
bool $useRefHandles False to hide global ref. handles
Renvoie
static

Références Data\$data, $this, et Data\$useRefHandles.

Documentation des champs

◆ $context

$context = []
private

Référencé par Data\withContext().

◆ $data

$data
private

Référencé par Data\__construct(), Data\__get(), SeekingData\dump(), SeekingData\seek(), Data\seek(), Data\withContext(), Data\withMaxDepth(), Data\withMaxItemsPerDepth(), et Data\withRefHandles().

◆ $key

$key = 0
private

Référencé par Data\dumpChildren(), Data\getType(), Data\getValue(), Data\offsetExists(), Data\offsetGet(), et Data\seek().

◆ $maxDepth

$maxDepth = 20
private

Référencé par Data\withMaxDepth().

◆ $maxItemsPerDepth

$maxItemsPerDepth = -1
private

Référencé par Data\dumpItem(), et Data\withMaxItemsPerDepth().

◆ $position

$position = 0
private

Référencé par Data\getType(), Data\getValue(), et Data\seek().

◆ $useRefHandles

$useRefHandles = -1
private

Référencé par Data\withRefHandles().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Data.php


Joomla CMS: Référence de l'interface DumperInterface

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • DumperInterface
Fonctions membres publiques
Référence de l'interface DumperInterface
+ Graphe d'héritage de DumperInterface:
AbstractDumper CliDumper HtmlDumper DebugBarHtmlDumper

Fonctions membres publiques

dumpScalar (Cursor $cursor, string $type, $value)
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)

Description détaillée

DumperInterface used by Data objects.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ dumpScalar()

dumpScalar | ( | Cursor | $cursor,
 |  | string | $type,
 |  |  | $value
 | ) |  |

Dumps a scalar value.

Paramètres
string | $type | The PHP type of the value being dumped
string | int | float | bool | $value | The scalar value being dumped

Implémenté dans CliDumper.

Référencé par Data\dump(), et Data\dumpItem().

◆ dumpString()

dumpString | ( | Cursor | $cursor,
 |  | string | $str,
 |  | bool | $bin,
 |  | int | $cut
 | ) |  |

Dumps a string.

Paramètres
string | $str | The string being dumped
bool | $bin | Whether $str is UTF-8 or binary encoded
int | $cut | The number of characters $str has been cut by

Implémenté dans HtmlDumper, et CliDumper.

Référencé par Data\dumpItem().

◆ enterHash()

enterHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild
 | ) |  |

Dumps while entering an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item

Implémenté dans HtmlDumper, et CliDumper.

Référencé par Data\dumpItem().

◆ leaveHash()

leaveHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild,
 |  | int | $cut
 | ) |  |

Dumps while leaving an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item
int | $cut | The number of items the hash has been cut by

Implémenté dans HtmlDumper, et CliDumper.

Référencé par Data\dumpItem().

La documentation de cette interface a été générée à partir du fichier suivant :
  • DumperInterface.php


Joomla CMS: Référence de la classe Stub

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • Stub
Fonctions membres publiques | Champs de données | Attributs privés statiques
Référence de la classe Stub
+ Graphe d'héritage de Stub:
ConstStub CutStub DsPairStub EnumStub TraceStub ClassStub ImgStub LinkStub CutArrayStub ArgsStub FrameStub

Fonctions membres publiques

__sleep ()

Champs de données

const | TYPE_REF = 1
const | TYPE_STRING = 2
const | TYPE_ARRAY = 3
const | TYPE_OBJECT = 4
const | TYPE_RESOURCE = 5
const | STRING_BINARY = 1
const | STRING_UTF8 = 2
const | ARRAY_ASSOC = 1
const | ARRAY_INDEXED = 2
$type = self::TYPE_REF
$class = ''
$value
$cut = 0
$handle = 0
$refCount = 0
$position = 0
$attr = []

Attributs privés statiques

static $defaultProperties = []

Description détaillée

Represents the main properties of a PHP variable.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ __sleep()

__sleep ( )

Références $c, et class.

Documentation des champs

◆ $attr

$attr = []

◆ $class

$class = ''

Référencé par ArgsStub\__construct(), LinkStub\getComposerRoot(), et ArgsStub\getParameters().

◆ $cut

$cut = 0

◆ $defaultProperties

$defaultProperties = []
staticprivate

◆ $handle

$handle = 0

◆ $position

$position = 0

◆ $refCount

$refCount = 0

◆ $type

$type = self::TYPE_REF

◆ $value

$value

Référencé par DsPairStub\__construct(), CutStub\__construct(), ConstStub\__construct(), CutArrayStub\__construct(), et ConstStub\__toString().

◆ ARRAY_ASSOC

const ARRAY_ASSOC = 1

Référencé par VarCloner\doClone(), et CliDumper\endValue().

◆ ARRAY_INDEXED

const ARRAY_INDEXED = 2

Référencé par VarCloner\doClone(), et CliDumper\endValue().

◆ STRING_BINARY

const STRING_BINARY = 1

Référencé par StubCaster\castStub(), VarCloner\doClone(), et Data\dumpItem().

◆ STRING_UTF8

const STRING_UTF8 = 2

Référencé par VarCloner\doClone().

◆ TYPE_ARRAY

const TYPE_ARRAY = 3

Référencé par VarCloner\doClone(), Data\dumpItem(), Data\getStub(), Data\getType(), SeekingData\seek(), et Data\seek().

◆ TYPE_OBJECT

const TYPE_OBJECT = 4

Référencé par AbstractCloner\castObject(), AbstractCloner\castResource(), VarCloner\doClone(), Data\dumpItem(), ExceptionCaster\extractSource(), Data\getType(), SeekingData\seek(), et Data\seek().

◆ TYPE_REF

const TYPE_REF = 1

Référencé par StubCaster\castStub(), Data\dumpItem(), Data\getType(), Data\getValue(), et Data\seek().

◆ TYPE_RESOURCE

const TYPE_RESOURCE = 5

Référencé par VarCloner\doClone(), Data\dumpItem(), Data\getType(), SeekingData\seek(), et Data\seek().

◆ TYPE_STRING

const TYPE_STRING = 2

Référencé par StubCaster\castStub(), VarCloner\doClone(), Data\dumpItem(), Data\getType(), et Data\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/var-dumper/Cloner/Stub.php


Joomla CMS: Référence de la classe VarCloner

  • Symfony
  • Component
  • VarDumper
  • Cloner
  • VarCloner
Fonctions membres protégées | Attributs privés statiques
Référence de la classe VarCloner
+ Graphe d'héritage de VarCloner:
AbstractCloner ClonerInterface

Fonctions membres protégées

doClone ($var)
- Fonctions membres protégées hérités de AbstractCloner
doClone ($var)
castObject (Stub $stub, bool $isNested)
castResource (Stub $stub, bool $isNested)

Attributs privés statiques

static | $gid
static | $arrayCache = []

Membres hérités additionnels

- Fonctions membres publiques hérités de AbstractCloner
__construct (array $casters=null)
addCasters (array $casters)
setMaxItems (int $maxItems)
setMaxString (int $maxString)
setMinDepth (int $minDepth)
cloneVar ($var, int $filter=0)
- Fonctions membres publiques hérités de ClonerInterface
cloneVar ($var)
- Attributs publics statiques hérités de AbstractCloner
static | $defaultCasters
- Attributs protégés hérités de AbstractCloner
static | $maxItems = 2500
$maxString = -1
$minDepth = 1

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ doClone()

doClone ( $var )
protected

{}

Références VarCloner\$gid, $i, AbstractCloner\$maxItems, AbstractCloner\$maxString, AbstractCloner\$minDepth, $r, Stub\ARRAY_ASSOC, Stub\ARRAY_INDEXED, AbstractCloner\castObject(), AbstractCloner\castResource(), elseif, null, Stub\STRING_BINARY, Stub\STRING_UTF8, Stub\TYPE_ARRAY, Stub\TYPE_OBJECT, Stub\TYPE_RESOURCE, et Stub\TYPE_STRING.

Documentation des champs

◆ $arrayCache

$arrayCache = []
staticprivate

◆ $gid

$gid
staticprivate

Référencé par VarCloner\doClone().

La documentation de cette classe a été générée à partir du fichier suivant :
  • VarCloner.php


Joomla CMS: Référence de la classe CliDescriptor

  • Symfony
  • Component
  • VarDumper
  • Command
  • Descriptor
  • CliDescriptor
Fonctions membres publiques | Attributs privés
Référence de la classe CliDescriptor
+ Graphe d'héritage de CliDescriptor:
DumpDescriptorInterface

Fonctions membres publiques

__construct (CliDumper $dumper)
describe (OutputInterface $output, Data $data, array $context, int $clientId)

Attributs privés

$dumper
$lastIdentifier

Description détaillée

Describe collected data clones for cli output.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CliDumper $dumper )

Références CliDescriptor\$dumper.

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | Data | $data,
 |  | array | $context,
 |  | int | $clientId
 | ) |  |

Implémente DumpDescriptorInterface.

Références $clientId, $context, $data, CliDescriptor\$lastIdentifier, $output, $rows, $section, elseif, et null.

Documentation des champs

◆ $dumper

$dumper
private

Référencé par CliDescriptor\__construct().

◆ $lastIdentifier

$lastIdentifier
private

Référencé par CliDescriptor\describe().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CliDescriptor.php


Joomla CMS: Référence de l'interface DumpDescriptorInterface

  • Symfony
  • Component
  • VarDumper
  • Command
  • Descriptor
  • DumpDescriptorInterface
Fonctions membres publiques
Référence de l'interface DumpDescriptorInterface
+ Graphe d'héritage de DumpDescriptorInterface:
CliDescriptor HtmlDescriptor

Fonctions membres publiques

describe (OutputInterface $output, Data $data, array $context, int $clientId)

Description détaillée

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | Data | $data,
 |  | array | $context,
 |  | int | $clientId
 | ) |  |

Implémenté dans CliDescriptor, et HtmlDescriptor.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DumpDescriptorInterface.php


Joomla CMS: Référence de la classe HtmlDescriptor

  • Symfony
  • Component
  • VarDumper
  • Command
  • Descriptor
  • HtmlDescriptor
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe HtmlDescriptor
+ Graphe d'héritage de HtmlDescriptor:
DumpDescriptorInterface

Fonctions membres publiques

__construct (HtmlDumper $dumper)
describe (OutputInterface $output, Data $data, array $context, int $clientId)

Fonctions membres privées

extractDate (array $context, string $format='r')
renderTags (array $tags)

Attributs privés

$dumper
$initialized = false

Description détaillée

Describe collected data clones for html output.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( HtmlDumper $dumper )

Références HtmlDescriptor\$dumper.

Documentation des fonctions membres

◆ describe()

describe | ( | OutputInterface | $output,
 |  | Data | $data,
 |  | array | $context,
 |  | int | $clientId
 | ) |  |

Implémente DumpDescriptorInterface.

Références $context, $data, $output, $title, $uri, __DIR__, elseif, HtmlDescriptor\extractDate(), null, et HtmlDescriptor\renderTags().

◆ extractDate()

extractDate | ( | array | $context,
 |  | string | $format = 'r'
 | ) |  |
private

Références $context, et $format.

Référencé par HtmlDescriptor\describe().

◆ renderTags()

renderTags ( array $tags )
private

Références $key, et $value.

Référencé par HtmlDescriptor\describe().

Documentation des champs

◆ $dumper

$dumper
private

Référencé par HtmlDescriptor\__construct().

◆ $initialized

$initialized = false
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlDescriptor.php


Joomla CMS: Référence de la classe ServerDumpCommand

  • Symfony
  • Component
  • VarDumper
  • Command
  • ServerDumpCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe ServerDumpCommand
+ Graphe d'héritage de ServerDumpCommand:
Command

Fonctions membres publiques

__construct (DumpServer $server, array $descriptors=[])
complete (CompletionInput $input, CompletionSuggestions $suggestions)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'server:dump'
static | $defaultDescription = 'Start a dump server that collects and displays dumps in a single place'
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Fonctions membres privées

getAvailableFormats ()

Attributs privés

$server
$descriptors

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2

Description détaillée

Starts a dump server to collect and output dumps on a single place with multiple formats support.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DumpServer | $server,
 |  | array | $descriptors = []
 | ) |  |

Références ServerDumpCommand\$descriptors, ServerDumpCommand\$server, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Références $input, ServerDumpCommand\getAvailableFormats(), et CompletionSuggestions\suggestValues().

◆ configure()

configure ( )
protected

Références $this, ServerDumpCommand\getAvailableFormats(), null, Assert\that(), et InputOption\VALUE_REQUIRED.

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Références $clientId, $context, $data, $format, $input, $output, et null.

◆ getAvailableFormats()

getAvailableFormats ( )
private

Référencé par ServerDumpCommand\complete(), et ServerDumpCommand\configure().

Documentation des champs

◆ $defaultDescription

$defaultDescription = 'Start a dump server that collects and displays dumps in a single place'
staticprotected

◆ $defaultName

$defaultName = 'server:dump'
staticprotected

◆ $descriptors

$descriptors
private

Référencé par ServerDumpCommand\__construct().

◆ $server

$server
private

Référencé par ServerDumpCommand\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ServerDumpCommand.php


Joomla CMS: Référence de la classe CliContextProvider

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextProvider
  • CliContextProvider
Fonctions membres publiques
Référence de la classe CliContextProvider
+ Graphe d'héritage de CliContextProvider:
ContextProviderInterface

Fonctions membres publiques

getContext ()

Description détaillée

Tries to provide context on CLI.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des fonctions membres

◆ getContext()

getContext ( )

Implémente ContextProviderInterface.

Références null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • CliContextProvider.php


Joomla CMS: Référence de l'interface ContextProviderInterface

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextProvider
  • ContextProviderInterface
Fonctions membres publiques
Référence de l'interface ContextProviderInterface
+ Graphe d'héritage de ContextProviderInterface:
CliContextProvider RequestContextProvider SourceContextProvider

Fonctions membres publiques

getContext ()

Description détaillée

Interface to provide contextual data about dump data clones sent to a server.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des fonctions membres

◆ getContext()

getContext ( )

Implémenté dans SourceContextProvider, RequestContextProvider, et CliContextProvider.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ContextProviderInterface.php


Joomla CMS: Référence de la classe RequestContextProvider

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextProvider
  • RequestContextProvider
Fonctions membres publiques | Attributs privés
Référence de la classe RequestContextProvider
+ Graphe d'héritage de RequestContextProvider:
ContextProviderInterface

Fonctions membres publiques

__construct (RequestStack $requestStack)
getContext ()

Attributs privés

$requestStack
$cloner

Description détaillée

Tries to provide context from a request.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( RequestStack $requestStack )

Références RequestContextProvider\$requestStack, et ReflectionCaster\UNSET_CLOSURE_FILE_INFO.

Documentation des fonctions membres

◆ getContext()

getContext ( )

Implémente ContextProviderInterface.

Références null.

Documentation des champs

◆ $cloner

$cloner
private

◆ $requestStack

$requestStack
private

Référencé par RequestContextProvider\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RequestContextProvider.php


Joomla CMS: Référence de la classe SourceContextProvider

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextProvider
  • SourceContextProvider
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe SourceContextProvider
+ Graphe d'héritage de SourceContextProvider:
ContextProviderInterface

Fonctions membres publiques

__construct (string $charset=null, string $projectDir=null, FileLinkFormatter $fileLinkFormatter=null, int $limit=9)
getContext ()

Fonctions membres privées

htmlEncode (string $s)

Attributs privés

$limit
$charset
$projectDir
$fileLinkFormatter

Description détaillée

Tries to provide context from sources (class name, file, line, code excerpt, ...).

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $charset = null,
 |  | string | $projectDir = null,
 |  | FileLinkFormatter | $fileLinkFormatter = null,
 |  | int | $limit = 9
 | ) |  |

Références SourceContextProvider\$charset, SourceContextProvider\$fileLinkFormatter, SourceContextProvider\$limit, SourceContextProvider\$projectDir, et Joomla\Database\Query\limit().

Documentation des fonctions membres

◆ getContext()

getContext ( )

Implémente ContextProviderInterface.

Références $context, $i, $info, SourceContextProvider\$limit, $name, SourceContextProvider\$projectDir, $template, class, elseif, SourceContextProvider\htmlEncode(), Joomla\Database\Query\limit(), et null.

◆ htmlEncode()

htmlEncode ( string $s )
private

Références SourceContextProvider\$charset, $html, et HtmlDumper\setDumpHeader().

Référencé par SourceContextProvider\getContext().

Documentation des champs

◆ $charset

$charset
private

Référencé par SourceContextProvider\__construct(), et SourceContextProvider\htmlEncode().

◆ $fileLinkFormatter

$fileLinkFormatter
private

Référencé par SourceContextProvider\__construct().

◆ $limit

$limit
private

Référencé par SourceContextProvider\__construct(), et SourceContextProvider\getContext().

◆ $projectDir

$projectDir
private

Référencé par SourceContextProvider\__construct(), et SourceContextProvider\getContext().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SourceContextProvider.php


Joomla CMS: Référence de la classe AbstractDumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • AbstractDumper
Fonctions membres publiques | Champs de données | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe AbstractDumper
+ Graphe d'héritage de AbstractDumper:
DataDumperInterface DumperInterface CliDumper HtmlDumper DebugBarHtmlDumper

Fonctions membres publiques

__construct ($output=null, string $charset=null, int $flags=0)
setOutput ($output)
setCharset (string $charset)
setIndentPad (string $pad)
dump (Data $data, $output=null)
- Fonctions membres publiques hérités de DataDumperInterface
dump (Data $data)
- Fonctions membres publiques hérités de DumperInterface
dumpScalar (Cursor $cursor, string $type, $value)
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)

Champs de données

const | DUMP_LIGHT_ARRAY = 1
const | DUMP_STRING_LENGTH = 2
const | DUMP_COMMA_SEPARATOR = 4
const | DUMP_TRAILING_COMMA = 8

Attributs publics statiques

static $defaultOutput = 'php://output'

Fonctions membres protégées

dumpLine (int $depth)
echoLine (string $line, int $depth, string $indentPad)
utf8Encode (?string $s)

Attributs protégés

$line = ''
$lineDumper
$outputStream
$decimalPoint
$indentPad = ' '
$flags

Attributs privés

$charset = ''

Description détaillée

Abstract mechanism for dumping a Data object.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $output = null,
 |  | string | $charset = null,
 |  | int | $flags = 0
 | ) |  |
Paramètres
callable | resource | string | null | $output | A line dumper callable, an opened stream or an output path, defaults to static::$defaultOutput
string | null | $charset | The default character encoding to use for non-UTF8 strings
int | $flags | A bit field of static::DUMP_* constants to fine tune dumps representation

Références AbstractDumper\$charset, AbstractDumper\$flags, $output, AbstractDumper\$outputStream, AbstractDumper\setCharset(), et AbstractDumper\setOutput().

Référencé par HtmlDumper\__construct().

Documentation des fonctions membres

◆ dump()

dump | ( | Data | $data,
 |  |  | $output = null
 | ) |  |

Dumps a Data object.

Paramètres
callable | resource | string | true | null $output A line dumper callable, an opened stream, an output path or true to return the dump
Renvoie
string|null The dump as string when $output is true

Références $output, $result, $this, Data\dump(), AbstractDumper\dumpLine(), null, et AbstractDumper\setOutput().

◆ dumpLine()

dumpLine ( int $depth )
protected

Dumps the current line.

Paramètres
int $depth The recursive depth in the dumped structure for the line being dumped, or -1 to signal the end-of-dump to the line dumper callable

Références AbstractDumper\$lineDumper.

Référencé par AbstractDumper\dump().

◆ echoLine()

echoLine | ( | string | $line,
 |  | int | $depth,
 |  | string | $indentPad
 | ) |  |
protected

Generic line dumper callback.

Références AbstractDumper\$indentPad, et AbstractDumper\$line.

◆ setCharset()

setCharset ( string $charset )

Sets the default character encoding to use for non-UTF8 strings.

Renvoie
string The previous charset

Références AbstractDumper\$charset, et null.

Référencé par AbstractDumper\__construct().

◆ setIndentPad()

setIndentPad ( string $pad )

Sets the indentation pad string.

Paramètres
string $pad A string that will be prepended to dumped lines, repeated by nesting level
Renvoie
string The previous indent pad

Références AbstractDumper\$indentPad.

◆ setOutput()

setOutput ( $output )

Sets the output destination of the dumps.

Paramètres
callable | resource | string $output A line dumper callable, an opened stream or an output path
Renvoie
callable|resource|string The previous output destination

Références AbstractDumper\$lineDumper, $output, $this, et null.

Référencé par AbstractDumper\__construct(), et AbstractDumper\dump().

◆ utf8Encode()

utf8Encode ( ?string $s )
protected

Converts a non-UTF-8 string to UTF-8.

Renvoie
string|null

Références $c, et null.

Référencé par CliDumper\dumpKey(), CliDumper\dumpScalar(), CliDumper\dumpString(), et CliDumper\enterHash().

Documentation des champs

◆ $charset

$charset = ''
private

Référencé par AbstractDumper\__construct(), CliDumper\__construct(), HtmlDumper\__construct(), et AbstractDumper\setCharset().

◆ $decimalPoint

$decimalPoint
protected

◆ $defaultOutput

$defaultOutput = 'php://output'
static

◆ $flags

$flags
protected

Référencé par AbstractDumper\__construct(), CliDumper\__construct(), HtmlDumper\__construct(), et CliDumper\enterHash().

◆ $indentPad

$indentPad = ' '
protected

Référencé par CliDumper\dumpString(), AbstractDumper\echoLine(), et AbstractDumper\setIndentPad().

◆ $line

$line = ''
protected

Référencé par AbstractDumper\echoLine(), HtmlDumper\getDumpHeader(), et CliDumper\getSourceLink().

◆ $lineDumper

$lineDumper
protected

Référencé par AbstractDumper\dumpLine(), HtmlDumper\getDumpHeader(), et AbstractDumper\setOutput().

◆ $outputStream

$outputStream
protected

Référencé par AbstractDumper\__construct(), et CliDumper\supportsColors().

◆ DUMP_COMMA_SEPARATOR

const DUMP_COMMA_SEPARATOR = 4

Référencé par Dumper\__construct(), et Symfony\Component\VarDumper\Test\getDump().

◆ DUMP_LIGHT_ARRAY

const DUMP_LIGHT_ARRAY = 1

Référencé par Dumper\__construct(), et Symfony\Component\VarDumper\Test\getDump().

◆ DUMP_STRING_LENGTH

const DUMP_STRING_LENGTH = 2

Référencé par Symfony\Component\VarDumper\Test\getDump().

◆ DUMP_TRAILING_COMMA

const DUMP_TRAILING_COMMA = 8
La documentation de cette classe a été générée à partir du fichier suivant :
  • AbstractDumper.php


Joomla CMS: Référence de la classe CliDumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • CliDumper
Fonctions membres publiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe CliDumper
+ Graphe d'héritage de CliDumper:
AbstractDumper DataDumperInterface DumperInterface HtmlDumper DebugBarHtmlDumper

Fonctions membres publiques

__construct ($output=null, string $charset=null, int $flags=0)
setColors (bool $colors)
setMaxStringWidth (int $maxStringWidth)
setStyles (array $styles)
setDisplayOptions (array $displayOptions)
dumpScalar (Cursor $cursor, string $type, $value)
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)
- Fonctions membres publiques hérités de AbstractDumper
__construct ($output=null, string $charset=null, int $flags=0)
setOutput ($output)
setCharset (string $charset)
setIndentPad (string $pad)
dump (Data $data, $output=null)
- Fonctions membres publiques hérités de DataDumperInterface
dump (Data $data)

Attributs publics statiques

static | $defaultColors
static | $defaultOutput = 'php://stdout'
static | n
- Attributs publics statiques hérités de AbstractDumper
static | $defaultOutput = 'php://output'

Fonctions membres protégées

dumpEllipsis (Cursor $cursor, bool $hasChild, int $cut)
dumpKey (Cursor $cursor)
style (string $style, string $value, array $attr=[])
supportsColors ()
dumpLine (int $depth, bool $endOfValue=false)
endValue (Cursor $cursor)
- Fonctions membres protégées hérités de AbstractDumper
dumpLine (int $depth)
echoLine (string $line, int $depth, string $indentPad)
utf8Encode (?string $s)

Attributs protégés

$colors
$maxStringWidth = 0
$styles
$collapseNextHash = false
$expandNextHash = false
- Attributs protégés hérités de AbstractDumper
$line = ''
$lineDumper
$outputStream
$decimalPoint
$indentPad = ' '
$flags

Attributs protégés statiques

static | $controlCharsRx = '/[\x00-\x1F\x7F]+/'
static | $controlCharsMap

Fonctions membres privées

hasColorSupport ($stream)
isWindowsTrueColor ()
getSourceLink (string $file, int $line)

Attributs privés

$displayOptions
$handlesHrefGracefully

Membres hérités additionnels

- Champs de données hérités de AbstractDumper
const | DUMP_LIGHT_ARRAY = 1
const | DUMP_STRING_LENGTH = 2
const | DUMP_COMMA_SEPARATOR = 4
const | DUMP_TRAILING_COMMA = 8

Description détaillée

CliDumper dumps variables for command line output.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $output = null,
 |  | string | $charset = null,
 |  | int | $flags = 0
 | ) |  |

{}

Références AbstractDumper\$charset, AbstractDumper\$flags, $output, Symfony\Contracts\Service\__construct(), CliDumper\isWindowsTrueColor(), et CliDumper\setStyles().

Documentation des fonctions membres

◆ dumpEllipsis()

dumpEllipsis | ( | Cursor | $cursor,
 |  | bool | $hasChild,
 |  | int | $cut
 | ) |  |
protected

Dumps an ellipsis for cut children.

Paramètres
bool | $hasChild | When the dump of the hash has child item
int | $cut | The number of items the hash has been cut by

Références CliDumper\dumpLine().

Référencé par CliDumper\leaveHash().

◆ dumpKey()

dumpKey ( Cursor $cursor )
protected

Dumps a key in a hash structure.

Références $attr, $key, $style, elseif, Cursor\HASH_ASSOC, Cursor\HASH_INDEXED, Cursor\HASH_OBJECT, Cursor\HASH_RESOURCE, null, CliDumper\style(), et AbstractDumper\utf8Encode().

Référencé par CliDumper\dumpScalar(), CliDumper\dumpString(), et CliDumper\enterHash().

◆ dumpLine()

dumpLine | ( | int | $depth,
 |  | bool | $endOfValue = false
 | ) |  |
protected

{}

Référencé par CliDumper\dumpEllipsis(), CliDumper\dumpString(), CliDumper\endValue(), et CliDumper\enterHash().

◆ dumpScalar()

dumpScalar | ( | Cursor | $cursor,
 |  | string | $type,
 |  |  | $value
 | ) |  |

{Dumps a scalar value.

Paramètres
string | $type | The PHP type of the value being dumped
string | int | float | bool | $value | The scalar value being dumped
}

Implémente DumperInterface.

Références $attr, $style, $type, $value, CliDumper\dumpKey(), CliDumper\endValue(), CliDumper\style(), et AbstractDumper\utf8Encode().

◆ dumpString()

dumpString | ( | Cursor | $cursor,
 |  | string | $str,
 |  | bool | $bin,
 |  | int | $cut
 | ) |  |

{Dumps a string.

Paramètres
string | $str | The string being dumped
bool | $bin | Whether $str is UTF-8 or binary encoded
int | $cut | The number of characters $str has been cut by
}

Implémente DumperInterface.

Références $attr, $i, AbstractDumper\$indentPad, CliDumper\$maxStringWidth, CliDumper\dumpKey(), CliDumper\dumpLine(), elseif, CliDumper\endValue(), CliDumper\style(), et AbstractDumper\utf8Encode().

◆ endValue()

endValue ( Cursor $cursor )
protected

Références Stub\ARRAY_ASSOC, Stub\ARRAY_INDEXED, CliDumper\dumpLine(), et elseif.

Référencé par CliDumper\dumpScalar(), CliDumper\dumpString(), et CliDumper\leaveHash().

◆ enterHash()

enterHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild
 | ) |  |

{Dumps while entering an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item
}

Implémente DumperInterface.

Références $attr, $class, AbstractDumper\$flags, $prefix, $type, CliDumper\dumpKey(), CliDumper\dumpLine(), elseif, Cursor\HASH_OBJECT, Cursor\HASH_RESOURCE, null, CliDumper\style(), CliDumper\supportsColors(), et AbstractDumper\utf8Encode().

◆ getSourceLink()

getSourceLink | ( | string | $file,
 |  | int | $line
 | ) |  |
private

Références AbstractDumper\$line.

Référencé par CliDumper\style().

◆ hasColorSupport()

hasColorSupport ( $stream )
private

Returns true if the stream supports colorization.

Reference: Composer::supportsColor https://github.com/composer/xdebug-handler

Paramètres
mixed $stream A CLI output stream

Références Laminas\Diactoros\$stream.

Référencé par CliDumper\supportsColors().

◆ isWindowsTrueColor()

isWindowsTrueColor ( )
private

Returns true if the Windows terminal supports true color.

Note that this does not check an output stream, but relies on environment variables from known implementations, or a PHP and Windows version that supports true color.

Références $result, et $version.

Référencé par CliDumper\__construct().

◆ leaveHash()

leaveHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild,
 |  | int | $cut
 | ) |  |

{Dumps while leaving an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item
int | $cut | The number of items the hash has been cut by
}

Implémente DumperInterface.

Références $type, CliDumper\dumpEllipsis(), CliDumper\endValue(), Cursor\HASH_OBJECT, et Cursor\HASH_RESOURCE.

◆ setColors()

setColors ( bool $colors )

Enables/disables colored output.

Références CliDumper\$colors.

◆ setDisplayOptions()

setDisplayOptions ( array $displayOptions )

Configures display options.

Paramètres
array $displayOptions A map of display options to customize the behavior

Références CliDumper\$displayOptions.

◆ setMaxStringWidth()

setMaxStringWidth ( int $maxStringWidth )

Sets the maximum number of characters per line for dumped strings.

Références CliDumper\$maxStringWidth.

◆ setStyles()

setStyles ( array $styles )

Configures styles.

Paramètres
array $styles A map of style names to style definitions

Références CliDumper\$styles.

Référencé par CliDumper\__construct().

◆ style()

style | ( | string | $style,
 |  | string | $value,
 |  | array | $attr = []
 | ) |  |
protected

Decorates a value with some style.

Paramètres
string | $style | The type of style being applied
string | $value | The value being styled
array | $attr | Optional context information
Renvoie
string

Références $attr, $c, $href, $i, $prefix, $value, elseif, CliDumper\getSourceLink(), null, et CliDumper\supportsColors().

Référencé par CliDumper\dumpKey(), CliDumper\dumpScalar(), CliDumper\dumpString(), et CliDumper\enterHash().

◆ supportsColors()

supportsColors ( )
protected
Renvoie
bool

Références CliDumper\$colors, $i, AbstractDumper\$outputStream, CliDumper\hasColorSupport(), et null.

Référencé par CliDumper\enterHash(), et CliDumper\style().

Documentation des champs

◆ $collapseNextHash

$collapseNextHash = false
protected

◆ $colors

$colors
protected

Référencé par CliDumper\setColors(), et CliDumper\supportsColors().

◆ $controlCharsMap

$controlCharsMap
staticprotected
Valeur initiale :
= [
"\t" => '\t'

◆ $controlCharsRx

$controlCharsRx = '/[\x00-\x1F\x7F]+/'
staticprotected

◆ $defaultColors

$defaultColors
static

◆ $defaultOutput

$defaultOutput = 'php://stdout'
static

◆ $displayOptions

$displayOptions
private
Valeur initiale :
= [
'fileLinkFormat' => null

Référencé par CliDumper\setDisplayOptions().

◆ $expandNextHash

$expandNextHash = false
protected

◆ $handlesHrefGracefully

$handlesHrefGracefully
private

◆ $maxStringWidth

$maxStringWidth = 0
protected

Référencé par CliDumper\dumpString(), et CliDumper\setMaxStringWidth().

◆ $styles

$styles
protected
Valeur initiale :
= [
'default' => '0;38;5;208'

Référencé par CliDumper\setStyles().

◆ n

n
static
Valeur initiale :
=> '\n',
"\v" => '\v',
"\f" => '\f',
"\r" => '\r',
"\033" => '\e',
]

Référencé par HtmlDumper\getDumpHeader().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CliDumper.php


Joomla CMS: Référence de la classe ContextualizedDumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ContextualizedDumper
Fonctions membres publiques | Attributs privés
Référence de la classe ContextualizedDumper
+ Graphe d'héritage de ContextualizedDumper:
DataDumperInterface

Fonctions membres publiques

__construct (DataDumperInterface $wrappedDumper, array $contextProviders)
dump (Data $data)

Attributs privés

$wrappedDumper
$contextProviders

Description détaillée

Auteur
Kévin Thérage thera.nosp@m.ge.k.nosp@m.evin@.nosp@m.gmai.nosp@m.l.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | DataDumperInterface | $wrappedDumper,
 |  | array | $contextProviders
 | ) |  |
Paramètres
ContextProviderInterface[] $contextProviders

Références ContextualizedDumper\$contextProviders, et ContextualizedDumper\$wrappedDumper.

Documentation des fonctions membres

◆ dump()

dump ( Data $data )

Implémente DataDumperInterface.

Références $context, et $data.

Documentation des champs

◆ $contextProviders

$contextProviders
private

Référencé par ContextualizedDumper\__construct().

◆ $wrappedDumper

$wrappedDumper
private

Référencé par ContextualizedDumper\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ContextualizedDumper.php


Joomla CMS: Référence de l'interface DataDumperInterface

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • DataDumperInterface
Fonctions membres publiques
Référence de l'interface DataDumperInterface
+ Graphe d'héritage de DataDumperInterface:
AbstractDumper ContextualizedDumper ServerDumper CliDumper HtmlDumper DebugBarHtmlDumper

Fonctions membres publiques

dump (Data $data)

Description détaillée

DataDumperInterface for dumping Data objects.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ dump()

dump ( Data $data )

Implémenté dans ServerDumper, et ContextualizedDumper.

La documentation de cette interface a été générée à partir du fichier suivant :
  • DataDumperInterface.php


Joomla CMS: Référence de la classe HtmlDumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • HtmlDumper
Fonctions membres publiques | Attributs publics statiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe HtmlDumper
+ Graphe d'héritage de HtmlDumper:
CliDumper AbstractDumper DataDumperInterface DumperInterface DebugBarHtmlDumper

Fonctions membres publiques

__construct ($output=null, string $charset=null, int $flags=0)
setStyles (array $styles)
setTheme (string $themeName)
setDisplayOptions (array $displayOptions)
setDumpHeader (?string $header)
setDumpBoundaries (string $prefix, string $suffix)
dump (Data $data, $output=null, array $extraDisplayOptions=[])
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)
- Fonctions membres publiques hérités de CliDumper
__construct ($output=null, string $charset=null, int $flags=0)
setColors (bool $colors)
setMaxStringWidth (int $maxStringWidth)
setStyles (array $styles)
setDisplayOptions (array $displayOptions)
dumpScalar (Cursor $cursor, string $type, $value)
dumpString (Cursor $cursor, string $str, bool $bin, int $cut)
enterHash (Cursor $cursor, int $type, $class, bool $hasChild)
leaveHash (Cursor $cursor, int $type, $class, bool $hasChild, int $cut)
- Fonctions membres publiques hérités de AbstractDumper
__construct ($output=null, string $charset=null, int $flags=0)
setOutput ($output)
setCharset (string $charset)
setIndentPad (string $pad)
dump (Data $data, $output=null)
- Fonctions membres publiques hérités de DataDumperInterface
dump (Data $data)

Attributs publics statiques

static | $defaultOutput = 'php://output'
- Attributs publics statiques hérités de CliDumper
static | $defaultColors
static | $defaultOutput = 'php://stdout'
static | n
- Attributs publics statiques hérités de AbstractDumper
static | $defaultOutput = 'php://output'

Fonctions membres protégées

getDumpHeader ()
style (string $style, string $value, array $attr=[])
dumpLine (int $depth, bool $endOfValue=false)
- Fonctions membres protégées hérités de CliDumper
dumpEllipsis (Cursor $cursor, bool $hasChild, int $cut)
dumpKey (Cursor $cursor)
style (string $style, string $value, array $attr=[])
supportsColors ()
dumpLine (int $depth, bool $endOfValue=false)
endValue (Cursor $cursor)
- Fonctions membres protégées hérités de AbstractDumper
dumpLine (int $depth)
echoLine (string $line, int $depth, string $indentPad)
utf8Encode (?string $s)

Attributs protégés

static $dumpHeader
$dumpPrefix = '<pre class=sf-dump id=%s data-indent-pad="%s">'
$dumpSuffix = '</pre><script>Sfdump(%s)</script>'
$dumpId = 'sf-dump'
$colors = true
$headerIsDumped = false
$lastDepth = -1
$styles
- Attributs protégés hérités de CliDumper
$colors
$maxStringWidth = 0
$styles
$collapseNextHash = false
$expandNextHash = false
- Attributs protégés hérités de AbstractDumper
$line = ''
$lineDumper
$outputStream
$decimalPoint
$indentPad = ' '
$flags

Attributs protégés statiques

static | $themes
- Attributs protégés statiques hérités de CliDumper
static | $controlCharsRx = '/[\x00-\x1F\x7F]+/'
static | $controlCharsMap

Fonctions membres privées

getSourceLink (string $file, int $line)

Attributs privés

$displayOptions
$extraDisplayOptions = []

Membres hérités additionnels

- Champs de données hérités de AbstractDumper
const | DUMP_LIGHT_ARRAY = 1
const | DUMP_STRING_LENGTH = 2
const | DUMP_COMMA_SEPARATOR = 4
const | DUMP_TRAILING_COMMA = 8

Description détaillée

HtmlDumper dumps variables as HTML.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $output = null,
 |  | string | $charset = null,
 |  | int | $flags = 0
 | ) |  |

{}

Références AbstractDumper\$charset, AbstractDumper\$flags, $output, et AbstractDumper\__construct().

Documentation des fonctions membres

◆ dump()

dump | ( | Data | $data,
 |  |  | $output = null,
 |  | array | $extraDisplayOptions = []
 | ) |  |

{}

Références $data, HtmlDumper\$extraDisplayOptions, $output, et $result.

Référencé par HtmlDumper\getDumpHeader().

◆ dumpLine()

dumpLine | ( | int | $depth,
 |  | bool | $endOfValue = false
 | ) |  |
protected

{}

◆ dumpString()

dumpString | ( | Cursor | $cursor,
 |  | string | $str,
 |  | bool | $bin,
 |  | int | $cut
 | ) |  |

{Dumps a string.

Paramètres
string | $str | The string being dumped
bool | $bin | Whether $str is UTF-8 or binary encoded
int | $cut | The number of characters $str has been cut by
}

Implémente DumperInterface.

◆ enterHash()

enterHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild
 | ) |  |

{Dumps while entering an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item
}

Implémente DumperInterface.

Références $class, $r, $this, et $type.

◆ getDumpHeader()

getDumpHeader ( )
protected

Dumps the HTML header.

Références HtmlDumper\$dumpHeader, AbstractDumper\$line, AbstractDumper\$lineDumper, $options, HtmlDumper\dump(), if, CliDumper\n, null, et parent.

Référencé par DebugBarHtmlDumper\getDumpHeaderByDebugBar().

◆ getSourceLink()

getSourceLink | ( | string | $file,
 |  | int | $line
 | ) |  |
private

◆ leaveHash()

leaveHash | ( | Cursor | $cursor,
 |  | int | $type,
 |  |  | $class,
 |  | bool | $hasChild,
 |  | int | $cut
 | ) |  |

{Dumps while leaving an hash.

Paramètres
int | $type | A Cursor::HASH_* const for the type of hash
string | int | $class | The object class, resource type or array count
bool | $hasChild | When the dump of the hash has child item
int | $cut | The number of items the hash has been cut by
}

Implémente DumperInterface.

Références $class, et $type.

◆ setDisplayOptions()

setDisplayOptions ( array $displayOptions )

Configures display options.

Paramètres
array $displayOptions A map of display options to customize the behavior

Références HtmlDumper\$displayOptions.

◆ setDumpBoundaries()

setDumpBoundaries | ( | string | $prefix,
 |  | string | $suffix
 | ) |  |

Sets an HTML prefix and suffix that will encapse every single dump.

Références $prefix, et $suffix.

◆ setDumpHeader()

setDumpHeader ( ?string $header )

Sets an HTML header that will be dumped once in the output stream.

Références $header.

Référencé par SourceContextProvider\htmlEncode().

◆ setStyles()

setStyles ( array $styles )

{}

Références HtmlDumper\$styles.

Référencé par HtmlDumper\setTheme().

◆ setTheme()

setTheme ( string $themeName )

Références class, et HtmlDumper\setStyles().

◆ style()

style | ( | string | $style,
 |  | string | $value,
 |  | array | $attr = []
 | ) |  |
protected

{}

Références $attr, $b, $c, $class, $href, $i, $label, $r, $style, $target, $value, elseif, et Symfony\Component\VarDumper\Dumper\esc().

Documentation des champs

◆ $colors

$colors = true
protected

◆ $defaultOutput

$defaultOutput = 'php://output'
static

◆ $displayOptions

$displayOptions
private
Valeur initiale :
= [
'maxDepth' => 1

Référencé par HtmlDumper\setDisplayOptions().

◆ $dumpHeader

$dumpHeader
protected

Référencé par HtmlDumper\getDumpHeader().

◆ $dumpId

$dumpId = 'sf-dump'
protected

◆ $dumpPrefix

$dumpPrefix = '<pre class=sf-dump id=%s data-indent-pad="%s">'
protected

◆ $dumpSuffix

$dumpSuffix = '</pre><script>Sfdump(%s)</script>'
protected

◆ $extraDisplayOptions

$extraDisplayOptions = []
private

Référencé par HtmlDumper\dump().

◆ $headerIsDumped

$headerIsDumped = false
protected

◆ $lastDepth

$lastDepth = -1
protected

◆ $styles

$styles
protected

Référencé par HtmlDumper\setStyles().

◆ $themes

$themes
staticprotected
Valeur initiale :
= [
'dark' => [
'default' => 'background-color:#18171B; color:#FF8400; line-height:1.2em; font:12px Menlo, Monaco, Consolas, monospace; word-wrap: break-word; white-space: pre-wrap; position:relative; z-index:99999; word-break: break-all'
La documentation de cette classe a été générée à partir du fichier suivant :
  • HtmlDumper.php


Joomla CMS: Référence de la classe ServerDumper

  • Symfony
  • Component
  • VarDumper
  • Dumper
  • ServerDumper
Fonctions membres publiques | Attributs privés
Référence de la classe ServerDumper
+ Graphe d'héritage de ServerDumper:
DataDumperInterface

Fonctions membres publiques

__construct (string $host, DataDumperInterface $wrappedDumper=null, array $contextProviders=[])
getContextProviders ()
dump (Data $data)

Attributs privés

$connection
$wrappedDumper

Description détaillée

ServerDumper forwards serialized Data clones to a server.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $host,
 |  | DataDumperInterface | $wrappedDumper = null,
 |  | array | $contextProviders = []
 | ) |  |
Paramètres
string | $host | The server host
DataDumperInterface | null | $wrappedDumper | A wrapped instance used whenever we failed contacting the server
ContextProviderInterface[] | $contextProviders Context providers indexed by context name

Références ServerDumper\$wrappedDumper.

Documentation des fonctions membres

◆ dump()

dump ( Data $data )

{}

Implémente DataDumperInterface.

Références $data, et ServerDumper\$wrappedDumper.

◆ getContextProviders()

getContextProviders ( )

Documentation des champs

◆ $connection

$connection
private

◆ $wrappedDumper

$wrappedDumper
private

Référencé par ServerDumper\__construct(), et ServerDumper\dump().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ServerDumper.php


Joomla CMS: Référence de la classe ThrowingCasterException

  • Symfony
  • Component
  • VarDumper
  • Exception
  • ThrowingCasterException
Fonctions membres publiques
Référence de la classe ThrowingCasterException
+ Graphe d'héritage de ThrowingCasterException:

Fonctions membres publiques

__construct (\Throwable $prev)

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( \Throwable $prev )
Paramètres
\Throwable $prev The exception thrown from the caster

Références Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ThrowingCasterException.php


Joomla CMS: Référence de la classe Connection

  • Symfony
  • Component
  • VarDumper
  • Server
  • Connection
Fonctions membres publiques | Fonctions membres privées | Fonctions membres privées statiques | Attributs privés
Référence de la classe Connection

Fonctions membres publiques

__construct (string $host, array $contextProviders=[])
getContextProviders ()
write (Data $data)

Fonctions membres privées

createSocket ()

Fonctions membres privées statiques

static nullErrorHandler (int $t, string $m)

Attributs privés

$host
$contextProviders
$socket

Description détaillée

Forwards serialized Data clones to a server.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $host,
 |  | array | $contextProviders = []
 | ) |  |
Paramètres
string | $host | The server host
ContextProviderInterface[] | $contextProviders Context providers indexed by context name

Références Connection\$contextProviders, et Connection\$host.

Documentation des fonctions membres

◆ createSocket()

createSocket ( )
private

Références class.

Référencé par Connection\write().

◆ getContextProviders()

getContextProviders ( )

Références Connection\$contextProviders.

◆ nullErrorHandler()

static nullErrorHandler | ( | int | $t,
 |  | string | $m
 | ) |  |
staticprivate

◆ write()

write ( Data $data )

Références $context, $data, $name, Connection\$socket, class, et Connection\createSocket().

Documentation des champs

◆ $contextProviders

$contextProviders
private

Référencé par Connection\__construct(), et Connection\getContextProviders().

◆ $host

$host
private

Référencé par Connection\__construct().

◆ $socket

$socket
private

Référencé par Connection\write().

La documentation de cette classe a été générée à partir du fichier suivant :
  • var-dumper/Server/Connection.php


Joomla CMS: Référence de la classe DumpServer

  • Symfony
  • Component
  • VarDumper
  • Server
  • DumpServer
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe DumpServer

Fonctions membres publiques

__construct (string $host, LoggerInterface $logger=null)
start ()
listen (callable $callback)
getHost ()

Fonctions membres privées

getMessages ()

Attributs privés

$host
$logger
$socket

Description détaillée

A server collecting Data clones sent by a ServerDumper.

Auteur
Maxime Steinhausser maxim.nosp@m.e.st.nosp@m.einha.nosp@m.usse.nosp@m.r@gma.nosp@m.il.c.nosp@m.om

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $host,
 |  | LoggerInterface | $logger = null
 | ) |  |

Références DumpServer\$host, et DumpServer\$logger.

Documentation des fonctions membres

◆ getHost()

getHost ( )

Références DumpServer\$host.

◆ getMessages()

getMessages ( )
private

Références Laminas\Diactoros\$stream, elseif, et null.

Référencé par DumpServer\listen().

◆ listen()

listen ( callable $callback )

Références $clientId, $context, $data, $message, class, DumpServer\getMessages(), null, et DumpServer\start().

◆ start()

start ( )

Référencé par DumpServer\listen().

Documentation des champs

◆ $host

$host
private

Référencé par DumpServer\__construct(), et DumpServer\getHost().

◆ $logger

$logger
private

Référencé par DumpServer\__construct().

◆ $socket

$socket
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • DumpServer.php


Joomla CMS: Référence de la classe VarDumper

  • Symfony
  • Component
  • VarDumper
  • VarDumper
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe VarDumper

Fonctions membres publiques statiques

static | dump ($var)
static | setHandler (callable $callable=null)

Fonctions membres privées statiques

static | register ()
static | getDefaultContextProviders ()

Attributs privés statiques

static $handler

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ dump()

static dump ( $var )
static

Références null.

◆ getDefaultContextProviders()

static getDefaultContextProviders ( )
staticprivate

Références class, et null.

◆ register()

static register ( )
staticprivate

Références $format, null, et ReflectionCaster\UNSET_CLOSURE_FILE_INFO.

◆ setHandler()

static setHandler ( callable $callable = null )
static
Renvoie
callable|null

Documentation des champs

◆ $handler

$handler
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • VarDumper.php


Joomla CMS: Référence de la classe AddLinkHeaderListener

  • Symfony
  • Component
  • WebLink
  • EventListener
  • AddLinkHeaderListener
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe AddLinkHeaderListener
+ Graphe d'héritage de AddLinkHeaderListener:

Fonctions membres publiques

__construct ()
onKernelResponse (ResponseEvent $event)

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs privés

$serializer

Description détaillée

Adds the Link HTTP header to the response.

Auteur
Kévin Dunglas dungl.nosp@m.as@g.nosp@m.mail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

{}

◆ onKernelResponse()

onKernelResponse ( ResponseEvent $event )

Références LinkProviderInterface\getLinks().

Documentation des champs

◆ $serializer

$serializer
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AddLinkHeaderListener.php


Joomla CMS: Référence de la classe GenericLinkProvider

  • Symfony
  • Component
  • WebLink
  • GenericLinkProvider
Fonctions membres publiques | Attributs privés
Référence de la classe GenericLinkProvider
+ Graphe d'héritage de GenericLinkProvider:
EvolvableLinkProviderInterface LinkProviderInterface

Fonctions membres publiques

__construct (array $links=[])
getLinks ()
getLinksByRel ($rel)
withLink (LinkInterface $link)
withoutLink (LinkInterface $link)

Attributs privés

$links = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $links = [] )
Paramètres
LinkInterface[] $links

Références $link, GenericLinkProvider\$links, et $this.

Documentation des fonctions membres

◆ getLinks()

getLinks ( )

{Returns an iterable of LinkInterface objects.The iterable may be an array or any PHP object. If no links are available, an empty array or MUST be returned.

Renvoie
LinkInterface[]|
}

Implémente LinkProviderInterface.

◆ getLinksByRel()

getLinksByRel ( $rel )

{Returns an iterable of LinkInterface objects that have a specific relationship.The iterable may be an array or any PHP object. If no links with that relationship are available, an empty array or MUST be returned.

Renvoie
LinkInterface[]|
}

Implémente LinkProviderInterface.

Références $link, GenericLinkProvider\$links, et $rel.

◆ withLink()

withLink ( LinkInterface $link )

{Returns an instance with the specified link included.If the specified link is already present, this method MUST return normally without errors. The link is present if $link is === identical to a link object already in the collection.

Paramètres
LinkInterface $link A link object that should be included in this collection.
Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkProviderInterface.

Références $link, et $this.

◆ withoutLink()

withoutLink ( LinkInterface $link )

{Returns an instance with the specifed link removed.If the specified link is not present, this method MUST return normally without errors. The link is present if $link is === identical to a link object already in the collection.

Paramètres
LinkInterface $link The link to remove.
Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkProviderInterface.

Références $link, et $this.

Documentation des champs

◆ $links

$links = []
private

Référencé par GenericLinkProvider\__construct(), et GenericLinkProvider\getLinksByRel().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/web-link/GenericLinkProvider.php


Joomla CMS: Référence de la classe HttpHeaderSerializer

  • Symfony
  • Component
  • WebLink
  • HttpHeaderSerializer
Fonctions membres publiques
Référence de la classe HttpHeaderSerializer

Fonctions membres publiques

serialize (iterable $links)

Description détaillée

Serializes a list of Link instances to an HTTP Link header.

Voir également
https://tools.ietf.org/html/rfc5988
Auteur
Kévin Dunglas dungl.nosp@m.as@g.nosp@m.mail..nosp@m.com

Documentation des fonctions membres

◆ serialize()

serialize ( iterable $links )

Builds the value of the "Link" HTTP header.

Paramètres
\Traversable LinkInterface[]|,$links

Références $key, $link, $value, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • HttpHeaderSerializer.php


Joomla CMS: Référence de la classe Link

  • Symfony
  • Component
  • WebLink
  • Link
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Link
+ Graphe d'héritage de Link:
EvolvableLinkInterface LinkInterface

Fonctions membres publiques

__construct (string $rel=null, string $href='')
getHref ()
isTemplated ()
getRels ()
getAttributes ()
withHref ($href)
withRel ($rel)
withoutRel ($rel)
withAttribute ($attribute, $value)
withoutAttribute ($attribute)

Champs de données

const | REL_ALTERNATE = 'alternate'
const | REL_AUTHOR = 'author'
const | REL_HELP = 'help'
const | REL_ICON = 'icon'
const | REL_LICENSE = 'license'
const | REL_SEARCH = 'search'
const | REL_STYLESHEET = 'stylesheet'
const | REL_NEXT = 'next'
const | REL_PREV = 'prev'
const | REL_PRELOAD = 'preload'
const | REL_DNS_PREFETCH = 'dns-prefetch'
const | REL_PRECONNECT = 'preconnect'
const | REL_PREFETCH = 'prefetch'
const | REL_PRERENDER = 'prerender'
const | REL_MERCURE = 'mercure'

Fonctions membres privées

hrefIsTemplated (string $href)

Attributs privés

$href = ''
$rel = []
$attributes = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $rel = null,
 |  | string | $href = ''
 | ) |  |

Références Link\$href, Link\$rel, et null.

Documentation des fonctions membres

◆ getAttributes()

getAttributes ( )

{Returns a list of attributes that describe the target URI.

Renvoie
array A key-value list of attributes, where the key is a string and the value is either a PHP primitive or an array of PHP strings. If no values are found an empty array MUST be returned.
}

Implémente LinkInterface.

Références Link\$attributes.

◆ getHref()

getHref ( )

{Returns the target of the link.The target link must be one of:

  • An absolute URI, as defined by RFC 5988.
  • A relative URI, as defined by RFC 5988. The base of the relative link is assumed to be known based on context by the client.
  • A URI template as defined by RFC 6570.
If a URI template is returned, isTemplated() MUST return True.
Renvoie
string
}

Implémente LinkInterface.

Références Link\$href.

◆ getRels()

getRels ( )

{Returns the relationship type(s) of the link.This method returns 0 or more relationship types for a link, expressed as an array of strings.

Renvoie
string[]
}

Implémente LinkInterface.

◆ hrefIsTemplated()

hrefIsTemplated ( string $href )
private

Références Link\$href.

Référencé par Link\isTemplated().

◆ isTemplated()

isTemplated ( )

{Returns whether or not this is a templated link.

Renvoie
bool True if this link object is templated, False otherwise.
}

Implémente LinkInterface.

Références Link\hrefIsTemplated().

◆ withAttribute()

withAttribute | ( | $attribute,
 |  | $value
 | ) |

{Returns an instance with the specified attribute added.If the specified attribute is already present, it will be overwritten with the new value.

Paramètres
string | $attribute | The attribute to include.
string | $value | The value of the attribute to set.
Renvoie
static
}

Paramètres
string|

Implémente EvolvableLinkInterface.

Références $this, et $value.

◆ withHref()

withHref ( $href )

{Returns an instance with the specified href.

Paramètres
string $href The href value to include. It must be one of:
  • An absolute URI, as defined by RFC 5988.
  • A relative URI, as defined by RFC 5988. The base of the relative link is assumed to be known based on context by the client.
  • A URI template as defined by RFC 6570.
  • An object implementing __toString() that produces one of the above values.

An implementing library SHOULD evaluate a passed object to a string immediately rather than waiting for it to be returned later.

Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkInterface.

Références Link\$href, et $this.

◆ withoutAttribute()

withoutAttribute ( $attribute )

{Returns an instance with the specified attribute excluded.If the specified attribute is not present, this method MUST return normally without errors.

Paramètres
string $attribute The attribute to remove.
Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkInterface.

Références $this.

◆ withoutRel()

withoutRel ( $rel )

{Returns an instance with the specified relationship excluded.If the specified rel is already not present, this method MUST return normally without errors.

Paramètres
string $rel The relationship value to exclude.
Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkInterface.

Références Link\$rel, et $this.

◆ withRel()

withRel ( $rel )

{Returns an instance with the specified relationship included.If the specified rel is already present, this method MUST return normally without errors, but without adding the rel a second time.

Paramètres
string $rel The relationship value to add.
Renvoie
static
}

Renvoie
static

Implémente EvolvableLinkInterface.

Références Link\$rel, et $this.

Documentation des champs

◆ $attributes

$attributes = []
private

Référencé par Link\getAttributes().

◆ $href

$href = ''
private

Référencé par Link\__construct(), Link\getHref(), Link\hrefIsTemplated(), et Link\withHref().

◆ $rel

$rel = []
private

Référencé par Link\__construct(), Link\withoutRel(), et Link\withRel().

◆ REL_ALTERNATE

const REL_ALTERNATE = 'alternate'

◆ REL_AUTHOR

const REL_AUTHOR = 'author'

◆ REL_DNS_PREFETCH

const REL_DNS_PREFETCH = 'dns-prefetch'

◆ REL_HELP

const REL_HELP = 'help'

◆ REL_ICON

const REL_ICON = 'icon'

◆ REL_LICENSE

const REL_LICENSE = 'license'

◆ REL_MERCURE

const REL_MERCURE = 'mercure'

◆ REL_NEXT

const REL_NEXT = 'next'

◆ REL_PRECONNECT

const REL_PRECONNECT = 'preconnect'

◆ REL_PREFETCH

const REL_PREFETCH = 'prefetch'

◆ REL_PRELOAD

const REL_PRELOAD = 'preload'

◆ REL_PRERENDER

const REL_PRERENDER = 'prerender'

◆ REL_PREV

const REL_PREV = 'prev'

◆ REL_SEARCH

const REL_SEARCH = 'search'

◆ REL_STYLESHEET

const REL_STYLESHEET = 'stylesheet'
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/web-link/Link.php


Joomla CMS: Référence de la classe LintCommand

  • Symfony
  • Component
  • Yaml
  • Command
  • LintCommand
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe LintCommand
+ Graphe d'héritage de LintCommand:
Command

Fonctions membres publiques

__construct (string $name=null, callable $directoryIteratorProvider=null, callable $isReadableProvider=null)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
- Fonctions membres publiques hérités de Command
__construct (string $name=null)
ignoreValidationErrors ()
setApplication (Application $application=null)
setHelperSet (HelperSet $helperSet)
getHelperSet ()
getApplication ()
isEnabled ()
run (InputInterface $input, OutputInterface $output)
complete (CompletionInput $input, CompletionSuggestions $suggestions)
setCode (callable $code)
mergeApplicationDefinition (bool $mergeArgs=true)
setDefinition ($definition)
getDefinition ()
getNativeDefinition ()
addArgument (string $name, int $mode=null, string $description='', $default=null)
addOption (string $name, $shortcut=null, int $mode=null, string $description='', $default=null)
setName (string $name)
setProcessTitle (string $title)
getName ()
setHidden (bool $hidden)
isHidden ()
setDescription (string $description)
getDescription ()
setHelp (string $help)
getHelp ()
getProcessedHelp ()
setAliases (iterable $aliases)
getAliases ()
getSynopsis (bool $short=false)
addUsage (string $usage)
getUsages ()
getHelper (string $name)

Fonctions membres protégées

configure ()
execute (InputInterface $input, OutputInterface $output)
- Fonctions membres protégées hérités de Command
configure ()
execute (InputInterface $input, OutputInterface $output)
interact (InputInterface $input, OutputInterface $output)
initialize (InputInterface $input, OutputInterface $output)

Attributs protégés statiques

static | $defaultName = 'lint:yaml'
static | $defaultDescription = 'Lint a YAML file and outputs encountered errors'
- Attributs protégés statiques hérités de Command
static | $defaultName
static | $defaultDescription

Fonctions membres privées

validate (string $content, int $flags, string $file=null)
display (SymfonyStyle $io, array $files)
displayTxt (SymfonyStyle $io, array $filesInfo, bool $errorAsGithubAnnotations=false)
displayJson (SymfonyStyle $io, array $filesInfo)
getFiles (string $fileOrDirectory)
getParser ()
getDirectoryIterator (string $directory)
isReadable (string $fileOrDirectory)

Attributs privés

$parser
$format
$displayCorrectFiles
$directoryIteratorProvider
$isReadableProvider

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Command
static | getDefaultName ()
static | getDefaultDescription ()
- Champs de données hérités de Command
const | SUCCESS = 0
const | FAILURE = 1
const | INVALID = 2

Description détaillée

Validates YAML files syntax and outputs encountered errors.

Auteur
Grégoire Pineau lyrix.nosp@m.x@ly.nosp@m.rixx..nosp@m.info
Robin Chalas robin.nosp@m..cha.nosp@m.las@g.nosp@m.mail.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name = null,
 |  | callable | $directoryIteratorProvider = null,
 |  | callable | $isReadableProvider = null
 | ) |  |

Références LintCommand\$directoryIteratorProvider, LintCommand\$isReadableProvider, Command\$name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ complete()

complete | ( | CompletionInput | $input,
 |  | CompletionSuggestions | $suggestions
 | ) |  |

Références $input, et CompletionSuggestions\suggestValues().

◆ configure()

configure ( )
protected

{}

Références $this, InputArgument\IS_ARRAY, null, LintCommand\validate(), InputOption\VALUE_IS_ARRAY, InputOption\VALUE_NEGATABLE, et InputOption\VALUE_REQUIRED.

◆ display()

display | ( | SymfonyStyle | $io,
 |  | array | $files
 | ) |  |
private

Références LintCommand\displayJson(), et LintCommand\displayTxt().

Référencé par LintCommand\execute().

◆ displayJson()

displayJson | ( | SymfonyStyle | $io,
 |  | array | $filesInfo
 | ) |  |
private

Références SymfonyStyle\writeln().

Référencé par LintCommand\display().

◆ displayTxt()

displayTxt | ( | SymfonyStyle | $io,
 |  | array | $filesInfo,
 |  | bool | $errorAsGithubAnnotations = false
 | ) |  |
private

Références $info, SymfonyStyle\comment(), elseif, SymfonyStyle\success(), SymfonyStyle\text(), et SymfonyStyle\warning().

Référencé par LintCommand\display().

◆ execute()

execute | ( | InputInterface | $input,
 |  | OutputInterface | $output
 | ) |  |
protected

Références $input, $output, class, LintCommand\display(), LintCommand\getFiles(), GithubActionReporter\isGithubActionEnvironment(), LintCommand\isReadable(), null, Yaml\PARSE_CUSTOM_TAGS, et LintCommand\validate().

◆ getDirectoryIterator()

getDirectoryIterator ( string $directory )
private

Références $default, et null.

Référencé par LintCommand\getFiles().

◆ getFiles()

getFiles ( string $fileOrDirectory )
private

Références LintCommand\getDirectoryIterator().

Référencé par LintCommand\execute().

◆ getParser()

getParser ( )
private

Références LintCommand\$parser.

Référencé par LintCommand\validate().

◆ isReadable()

isReadable ( string $fileOrDirectory )
private

Références $default, et null.

Référencé par LintCommand\execute().

◆ validate()

validate | ( | string | $content,
 |  | int | $flags,
 |  | string | $file = null
 | ) |  |
private

Références $message, ParseException\getParsedLine(), LintCommand\getParser(), et Yaml\PARSE_CONSTANT.

Référencé par LintCommand\configure(), et LintCommand\execute().

Documentation des champs

◆ $defaultDescription

$defaultDescription = 'Lint a YAML file and outputs encountered errors'
staticprotected

◆ $defaultName

$defaultName = 'lint:yaml'
staticprotected

◆ $directoryIteratorProvider

$directoryIteratorProvider
private

Référencé par LintCommand\__construct().

◆ $displayCorrectFiles

$displayCorrectFiles
private

◆ $format

$format
private

◆ $isReadableProvider

$isReadableProvider
private

Référencé par LintCommand\__construct().

◆ $parser

$parser
private

Référencé par LintCommand\getParser().

La documentation de cette classe a été générée à partir du fichier suivant :
  • LintCommand.php


Joomla CMS: Référence de la classe DumpException

  • Symfony
  • Component
  • Yaml
  • Exception
  • DumpException
Référence de la classe DumpException
+ Graphe d'héritage de DumpException:
RuntimeException ExceptionInterface

Description détaillée

Exception class thrown when an error occurs during dumping.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
La documentation de cette classe a été générée à partir du fichier suivant :
  • DumpException.php


Joomla CMS: Référence de l'interface ExceptionInterface

  • Symfony
  • Component
  • Yaml
  • Exception
  • ExceptionInterface
Référence de l'interface ExceptionInterface
+ Graphe d'héritage de ExceptionInterface:
RuntimeException DumpException ParseException

Description détaillée

Exception interface for all exceptions thrown by the component.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/yaml/Exception/ExceptionInterface.php


Joomla CMS: Référence de la classe ParseException

  • Symfony
  • Component
  • Yaml
  • Exception
  • ParseException
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ParseException
+ Graphe d'héritage de ParseException:
RuntimeException ExceptionInterface

Fonctions membres publiques

__construct (string $message, int $parsedLine=-1, string $snippet=null, string $parsedFile=null, \Throwable $previous=null)
getSnippet ()
setSnippet (string $snippet)
getParsedFile ()
setParsedFile (string $parsedFile)
getParsedLine ()
setParsedLine (int $parsedLine)

Fonctions membres privées

updateRepr ()

Attributs privés

$parsedFile
$parsedLine
$snippet
$rawMessage

Description détaillée

Exception class thrown when an error occurs during parsing.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $message,
 |  | int | $parsedLine = -1,
 |  | string | $snippet = null,
 |  | string | $parsedFile = null,
 |  | \Throwable | $previous = null
 | ) |  |
Paramètres
string | $message | The error message
int | $parsedLine | The line where the error occurred
string | null | $snippet | The snippet of code near the problem
string | null | $parsedFile | The file name where the error occurred

Références $message, ParseException\$parsedFile, ParseException\$parsedLine, ParseException\$snippet, Symfony\Contracts\Service\__construct(), et ParseException\updateRepr().

Documentation des fonctions membres

◆ getParsedFile()

getParsedFile ( )

Gets the filename where the error occurred.

This method returns null if a string is parsed.

Renvoie
string

Références ParseException\$parsedFile.

◆ getParsedLine()

getParsedLine ( )

Gets the line where the error occurred.

Renvoie
int

Références ParseException\$parsedLine.

Référencé par LintCommand\validate().

◆ getSnippet()

getSnippet ( )

Gets the snippet of code near the error.

Renvoie
string

Références ParseException\$snippet.

◆ setParsedFile()

setParsedFile ( string $parsedFile )

Sets the filename where the error occurred.

Références ParseException\$parsedFile, et ParseException\updateRepr().

◆ setParsedLine()

setParsedLine ( int $parsedLine )

Sets the line where the error occurred.

Références ParseException\$parsedLine, et ParseException\updateRepr().

Référencé par Parser\doParse(), et Parser\parseValue().

◆ setSnippet()

setSnippet ( string $snippet )

Sets the snippet of code near the error.

Références ParseException\$snippet, et ParseException\updateRepr().

Référencé par Parser\doParse(), et Parser\parseValue().

◆ updateRepr()

updateRepr ( )
private

Références ParseException\$rawMessage, et null.

Référencé par ParseException\__construct(), ParseException\setParsedFile(), ParseException\setParsedLine(), et ParseException\setSnippet().

Documentation des champs

◆ $parsedFile

$parsedFile
private

Référencé par ParseException\__construct(), ParseException\getParsedFile(), et ParseException\setParsedFile().

◆ $parsedLine

$parsedLine
private

Référencé par ParseException\__construct(), ParseException\getParsedLine(), et ParseException\setParsedLine().

◆ $rawMessage

$rawMessage
private

Référencé par ParseException\updateRepr().

◆ $snippet

$snippet
private

Référencé par ParseException\__construct(), ParseException\getSnippet(), et ParseException\setSnippet().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ParseException.php


Joomla CMS: Référence de la classe RuntimeException

  • Symfony
  • Component
  • Yaml
  • Exception
  • RuntimeException
Référence de la classe RuntimeException
+ Graphe d'héritage de RuntimeException:
ExceptionInterface DumpException ParseException

Description détaillée

Exception class thrown when an error occurs during parsing.

Auteur
Romain Neutron impre.nosp@m.c@gm.nosp@m.ail.c.nosp@m.om
La documentation de cette classe a été générée à partir du fichier suivant :
  • yaml/Exception/RuntimeException.php


Joomla CMS: Référence de la classe TaggedValue

  • Symfony
  • Component
  • Yaml
  • Tag
  • TaggedValue
Fonctions membres publiques | Attributs privés
Référence de la classe TaggedValue

Fonctions membres publiques

__construct (string $tag, $value)
getTag ()
getValue ()

Attributs privés

$tag
$value

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Guilhem N. egeti.nosp@m.ck@g.nosp@m.mail..nosp@m.com

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $tag,
 |  |  | $value
 | ) |  |

Références TaggedValue\$tag, TaggedValue\$value, et value.

Documentation des fonctions membres

◆ getTag()

getTag ( )

Références TaggedValue\$tag.

◆ getValue()

getValue ( )

Références TaggedValue\$value.

Documentation des champs

◆ $tag

$tag
private

Référencé par TaggedValue\__construct(), et TaggedValue\getTag().

◆ $value

$value
private

Référencé par TaggedValue\__construct(), et TaggedValue\getValue().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TaggedValue.php


Joomla CMS: Référence de la classe Dumper

  • Symfony
  • Component
  • Yaml
  • Dumper
Fonctions membres publiques | Attributs protégés
Référence de la classe Dumper

Fonctions membres publiques

__construct (int $indentation=4)
dump ($input, int $inline=0, int $indent=0, int $flags=0)

Attributs protégés

$indentation

Description détaillée

Dumper dumps PHP variables to YAML strings.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( int $indentation = 4 )

Références Dumper\$indentation.

Documentation des fonctions membres

◆ dump()

dump | ( |  | $input,
 |  | int | $inline = 0,
 |  | int | $indent = 0,
 |  | int | $flags = 0
 | ) |  |

Dumps a PHP value to YAML.

Paramètres
mixed | $input | The PHP value
int | $inline | The level where you switch to inline YAML
int | $indent | The level of indentation (used internally)
int | $flags | A bit field of Yaml::DUMP_* constants to customize the dumped YAML string

Références $input, $key, $output, $prefix, $value, Inline\dump(), Yaml\DUMP_MULTI_LINE_LITERAL_BLOCK, Yaml\DUMP_OBJECT_AS_MAP, elseif, Inline\isHash(), et null.

Documentation des champs

◆ $indentation

$indentation
protected

Référencé par Dumper\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • yaml/Dumper.php


Joomla CMS: Référence de la classe Escaper

  • Symfony
  • Component
  • Yaml
  • Escaper
Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe Escaper

Fonctions membres publiques statiques

static | requiresDoubleQuoting (string $value)
static | escapeWithDoubleQuotes (string $value)
static | requiresSingleQuoting (string $value)
static | escapeWithSingleQuotes (string $value)

Champs de données

const REGEX_CHARACTER_TO_ESCAPE = "[\\x00-\\x1f]|\x7f|\xc2\x85|\xc2\xa0|\xe2\x80\xa8|\xe2\x80\xa9"

Attributs privés

const | ESCAPEES
const | ESCAPED

Description détaillée

Escaper encapsulates escaping rules for single and double-quoted YAML strings.

Auteur
Matthew Lewinski matth.nosp@m.ew@l.nosp@m.ewins.nosp@m.ki.o.nosp@m.rg

Documentation des fonctions membres

◆ escapeWithDoubleQuotes()

static escapeWithDoubleQuotes ( string $value )
static

Escapes and surrounds a PHP value with double quotes.

Paramètres
string $value A PHP value

Références $value.

Référencé par Inline\dump().

◆ escapeWithSingleQuotes()

static escapeWithSingleQuotes ( string $value )
static

Escapes and surrounds a PHP value with single quotes.

Paramètres
string $value A PHP value

Références $value.

Référencé par Inline\dump().

◆ requiresDoubleQuoting()

static requiresDoubleQuoting ( string $value )
static

Determines if a PHP value would require double quoting in YAML.

Paramètres
string $value A PHP value

Références $value.

Référencé par Inline\dump().

◆ requiresSingleQuoting()

static requiresSingleQuoting ( string $value )
static

Determines if a PHP value would require single quoting in YAML.

Paramètres
string $value A PHP value

Références $value.

Référencé par Inline\dump().

Documentation des champs

◆ ESCAPED

const ESCAPED
private
Valeur initiale :
= ['\\\\', '\\"', '\\\\', '\\"',
'\\0', '\\x01', '\\x02', '\\x03', '\\x04', '\\x05', '\\x06', '\\a',
'\\b', '\\t', '\\n', '\\v', '\\f', '\\r', '\\x0e', '\\x0f',
'\\x10', '\\x11', '\\x12', '\\x13', '\\x14', '\\x15', '\\x16', '\\x17',
'\\x18', '\\x19', '\\x1a', '\\e', '\\x1c', '\\x1d', '\\x1e', '\\x1f',
'\\x7f',
'\\N', '\\_', '\\L', '\\P',
]

◆ ESCAPEES

const ESCAPEES
private
Valeur initiale :
= ['\\', '\\\\', '\\"', '"',
"\x00", "\x01", "\x02", "\x03", "\x04", "\x05", "\x06", "\x07",
"\x08", "\x09", "\x0a", "\x0b", "\x0c", "\x0d", "\x0e", "\x0f",
"\x10", "\x11", "\x12", "\x13", "\x14", "\x15", "\x16", "\x17",
"\x18", "\x19", "\x1a", "\x1b", "\x1c", "\x1d", "\x1e", "\x1f",
"\x7f",
"\xc2\x85", "\xc2\xa0", "\xe2\x80\xa8", "\xe2\x80\xa9",
]

◆ REGEX_CHARACTER_TO_ESCAPE

const REGEX_CHARACTER_TO_ESCAPE = "[\\x00-\\x1f]|\x7f|\xc2\x85|\xc2\xa0|\xe2\x80\xa8|\xe2\x80\xa9"
La documentation de cette classe a été générée à partir du fichier suivant :
  • Escaper.php


Joomla CMS: Référence de la classe Inline

  • Symfony
  • Component
  • Yaml
  • Inline
Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Inline

Fonctions membres publiques statiques

static | initialize (int $flags, int $parsedLineNumber=null, string $parsedFilename=null)
static | parse (string $value=null, int $flags=0, array &$references=[])
static | dump ($value, int $flags=0)
static | isHash ($value)
static | parseScalar (string $scalar, int $flags=0, array $delimiters=null, int &$i=0, bool $evaluate=true, array &$references=[], bool &$isQuoted=null)
static | evaluateBinaryScalar (string $scalar)

Champs de données

const REGEX_QUOTED_STRING = '(?:"([^"\\\\]*+(?:\\\\.[^"\\\\]*+)*+)"|\'([^\']*+(?:\'\'[^\']*+)*+)\')'

Attributs publics statiques

static | $parsedLineNumber = -1
static | $parsedFilename

Fonctions membres privées statiques

static | dumpArray (array $value, int $flags)
static | dumpNull (int $flags)
static | parseQuotedScalar (string $scalar, int &$i=0)
static | parseSequence (string $sequence, int $flags, int &$i=0, array &$references=[])
static | parseMapping (string $mapping, int $flags, int &$i=0, array &$references=[])
static | evaluateScalar (string $scalar, int $flags, array &$references=[], bool &$isQuotedString=null)
static | parseTag (string $value, int &$i, int $flags)
static | isBinaryString (string $value)
static | getTimestampRegex ()
static | getHexRegex ()

Attributs privés statiques

static | $exceptionOnInvalidType = false
static | $objectSupport = false
static | $objectForMap = false
static | $constantSupport = false

Description détaillée

Inline implements a YAML parser/dumper for the YAML inline syntax.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ dump()

static dump | ( |  | $value,
 |  | int | $flags = 0
 | ) |  |
static

Dumps a given PHP variable to a YAML string.

Paramètres
mixed | $value | The PHP variable to convert
int | $flags | A bit field of Yaml::DUMP_* constants to customize the dumped YAML string
Exceptions
DumpException When trying to dump PHP resource

Références $key, $output, $val, $value, Yaml\DUMP_EXCEPTION_ON_INVALID_TYPE, Yaml\DUMP_OBJECT, Yaml\DUMP_OBJECT_AS_MAP, elseif, Escaper\escapeWithDoubleQuotes(), Escaper\escapeWithSingleQuotes(), null, Parser\preg_match(), Escaper\requiresDoubleQuoting(), et Escaper\requiresSingleQuoting().

Référencé par Dumper\dump().

◆ dumpArray()

static dumpArray | ( | array | $value,
 |  | int | $flags
 | ) |  |
staticprivate

Dumps a PHP array to a YAML string.

Paramètres
array | $value | The PHP array to dump
int | $flags | A bit field of Yaml::DUMP_* constants to customize the dumped YAML string

Références $key, $output, $val, $value, et Yaml\DUMP_EMPTY_ARRAY_AS_SEQUENCE.

◆ dumpNull()

static dumpNull ( int $flags )
staticprivate

Références Yaml\DUMP_NULL_AS_TILDE.

◆ evaluateBinaryScalar()

static evaluateBinaryScalar ( string $scalar )
static

Références Parser\preg_match().

Référencé par Parser\parseValue().

◆ evaluateScalar()

static evaluateScalar | ( | string | $scalar,
 |  | int | $flags,
 |  | array & | $references = [],
 |  | bool & | $isQuotedString = null
 | ) |  |
staticprivate

Evaluates scalars and replaces magic values.

Renvoie
mixed
Exceptions
ParseException when object parsing support was disabled and the parser detected a PHP object or when a reference could not be resolved

Références $i, $value, null, Yaml\PARSE_DATETIME, et Parser\preg_match().

◆ getHexRegex()

static getHexRegex ( )
staticprivate

Gets a regex that matches a YAML number in hexadecimal notation.

◆ getTimestampRegex()

static getTimestampRegex ( )
staticprivate

Gets a regex that matches a YAML date.

Voir également
http://www.yaml.org/spec/1.2/spec.html#id2761573

◆ initialize()

static initialize | ( | int | $flags,
 |  | int | $parsedLineNumber = null,
 |  | string | $parsedFilename = null
 | ) |  |
static

Références Inline\$parsedFilename, Inline\$parsedLineNumber, null, Yaml\PARSE_CONSTANT, Yaml\PARSE_EXCEPTION_ON_INVALID_TYPE, Yaml\PARSE_OBJECT, et Yaml\PARSE_OBJECT_FOR_MAP.

Référencé par Parser\doParse().

◆ isBinaryString()

static isBinaryString ( string $value )
staticprivate

Références $value.

◆ isHash()

static isHash ( $value )
static

Check if given array is hash or just normal indexed array.

Paramètres
array | \ArrayObject | \stdClass $value The PHP array or array-like object to check

Références $key, $val, et $value.

Référencé par Dumper\dump().

◆ parse()

static parse | ( | string | $value = null,
 |  | int | $flags = 0,
 |  | array & | $references = []
 | ) |  |
static

Converts a YAML string to a PHP value.

Paramètres
string | $value | A YAML string
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
array | $references | Mapping of variable names to values
Renvoie
mixed
Exceptions
ParseException

Références $i, $result, $value, Laminas\Diactoros\initialize(), et null.

Référencé par Parser\doParse(), et Parser\parseValue().

◆ parseMapping()

static parseMapping | ( | string | $mapping,
 |  | int | $flags,
 |  | int & | $i = 0,
 |  | array & | $references = []
 | ) |  |
staticprivate

Parses a YAML mapping.

Renvoie
array|
Exceptions
ParseException When malformed inline YAML string is parsed

Références $i, $key, $output, $value, elseif, null, Parser\preg_match(), et Parser\REFERENCE_PATTERN.

◆ parseQuotedScalar()

static parseQuotedScalar | ( | string | $scalar,
 |  | int & | $i = 0
 | ) |  |
staticprivate

Parses a YAML quoted scalar.

Exceptions
ParseException When malformed inline YAML string is parsed

Références $i, $output, et Parser\preg_match().

◆ parseScalar()

static parseScalar | ( | string | $scalar,
 |  | int | $flags = 0,
 |  | array | $delimiters = null,
 |  | int & | $i = 0,
 |  | bool | $evaluate = true,
 |  | array & | $references = [],
 |  | bool & | $isQuoted = null
 | ) |  |
static

Parses a YAML scalar.

Renvoie
mixed
Exceptions
ParseException When malformed inline YAML string is parsed

Références $i, $output, $tmp, elseif, null, et Parser\preg_match().

Référencé par Parser\doParse().

◆ parseSequence()

static parseSequence | ( | string | $sequence,
 |  | int | $flags,
 |  | int & | $i = 0,
 |  | array & | $references = []
 | ) |  |
staticprivate

Parses a YAML sequence.

Exceptions
ParseException When malformed inline YAML string is parsed

Références $i, $output, $value, null, Parser\preg_match(), et Parser\REFERENCE_PATTERN.

◆ parseTag()

static parseTag | ( | string | $value,
 |  | int & | $i,
 |  | int | $flags
 | ) |  |
staticprivate

Références $i, $value, null, et Yaml\PARSE_CUSTOM_TAGS.

Documentation des champs

◆ $constantSupport

$constantSupport = false
staticprivate

◆ $exceptionOnInvalidType

$exceptionOnInvalidType = false
staticprivate

◆ $objectForMap

$objectForMap = false
staticprivate

◆ $objectSupport

$objectSupport = false
staticprivate

◆ $parsedFilename

$parsedFilename
static

Référencé par Inline\initialize().

◆ $parsedLineNumber

$parsedLineNumber = -1
static

Référencé par Inline\initialize(), et Parser\parseValue().

◆ REGEX_QUOTED_STRING

const REGEX_QUOTED_STRING = '(?:"([^"\\\\]*+(?:\\\\.[^"\\\\]*+)*+)"|\'([^\']*+(?:\'\'[^\']*+)*+)\')'

Référencé par Parser\doParse().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Inline.php


Joomla CMS: Référence de la classe Parser

  • Symfony
  • Component
  • Yaml
  • Parser
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Parser

Fonctions membres publiques

parseFile (string $filename, int $flags=0)
parse (string $value, int $flags=0)
getRealCurrentLineNb ()

Fonctions membres publiques statiques

static preg_match (string $pattern, string $subject, array &$matches=null, int $flags=0, int $offset=0)

Champs de données

const | TAG_PATTERN = '(?P<tag>![\w!.\/:-]+)'
const | BLOCK_SCALAR_HEADER_PATTERN = '(?P<separator>\||>)(?P<modifiers>\+|\-|\d+|\+\d+|\-\d+|\d+\+|\d+\-)?(?P<comments> +#.*)?'
const | REFERENCE_PATTERN = '#^&(?P<ref>[^ ]++) *+(?P<value>.*)#u'

Fonctions membres privées

doParse (string $value, int $flags)
parseBlock (int $offset, string $yaml, int $flags)
getCurrentLineIndentation ()
getNextEmbedBlock (int $indentation=null, bool $inSequence=false)
hasMoreLines ()
moveToNextLine ()
moveToPreviousLine ()
parseValue (string $value, int $flags, string $context)
parseBlockScalar (string $style, string $chomping='', int $indentation=0)
isNextLineIndented ()
isCurrentLineEmpty ()
isCurrentLineBlank ()
isCurrentLineComment ()
isCurrentLineLastLineInDocument ()
cleanup (string $value)
isNextLineUnIndentedCollection ()
isStringUnIndentedCollectionItem ()
trimTag (string $value)
getLineTag (string $value, int $flags, bool $nextLineCheck=true)
lexInlineQuotedString (int &$cursor=0)
lexUnquotedString (int &$cursor)
lexInlineMapping (int &$cursor=0)
lexInlineSequence (int &$cursor=0)
lexInlineStructure (int &$cursor, string $closingTag)
consumeWhitespaces (int &$cursor)

Attributs privés

$filename
$offset = 0
$numberOfParsedLines = 0
$totalNumberOfLines
$lines = []
$currentLineNb = -1
$currentLine = ''
$refs = []
$skippedLineNumbers = []
$locallySkippedLineNumbers = []
$refsBeingParsed = []

Description détaillée

Parser parses YAML strings to convert them to PHP arrays.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ cleanup()

cleanup ( string $value )
private

Cleanups a YAML string to be parsed.

Paramètres
string $value The input YAML string

Références $count, $value, et Joomla\Database\Query\offset().

Référencé par Parser\doParse().

◆ consumeWhitespaces()

consumeWhitespaces ( int & $cursor )
private

Références Parser\hasMoreLines(), et Parser\moveToNextLine().

Référencé par Parser\lexInlineStructure().

◆ doParse()

doParse | ( | string | $value,
 |  | int | $flags
 | ) |  |
private

Références $context, $data, $key, Parser\$numberOfParsedLines, $value, Parser\cleanup(), elseif, Parser\getCurrentLineIndentation(), Parser\getLineTag(), Parser\getNextEmbedBlock(), Parser\getRealCurrentLineNb(), Inline\initialize(), Parser\isCurrentLineEmpty(), Parser\isNextLineIndented(), Parser\isNextLineUnIndentedCollection(), Parser\lexInlineMapping(), Parser\lexInlineQuotedString(), Parser\lexInlineSequence(), Parser\moveToNextLine(), null, Joomla\Database\Query\offset(), Inline\parse(), Yaml\PARSE_OBJECT_FOR_MAP, Parser\parseBlock(), Inline\parseScalar(), Parser\parseValue(), Inline\REGEX_QUOTED_STRING, ParseException\setParsedLine(), ParseException\setSnippet(), et Parser\trimTag().

Référencé par Parser\parse().

◆ getCurrentLineIndentation()

getCurrentLineIndentation ( )
private

Returns the current line indentation.

Référencé par Parser\doParse(), Parser\getNextEmbedBlock(), Parser\isNextLineIndented(), Parser\isNextLineUnIndentedCollection(), et Parser\parseValue().

◆ getLineTag()

getLineTag | ( | string | $value,
 |  | int | $flags,
 |  | bool | $nextLineCheck = true
 | ) |  |
private

Références $value, Parser\getRealCurrentLineNb(), Parser\isNextLineIndented(), null, et Yaml\PARSE_CUSTOM_TAGS.

Référencé par Parser\doParse().

◆ getNextEmbedBlock()

getNextEmbedBlock | ( | int | $indentation = null,
 |  | bool | $inSequence = false
 | ) |  |
private

Returns the next embed block of YAML.

Paramètres
int | null | $indentation | The indent level at which the block is to be read, or null for default
bool | $inSequence | True if the enclosing data structure is a sequence
Exceptions
ParseException When indentation problem are detected

Références Parser\$currentLine, $data, $i, elseif, Parser\getCurrentLineIndentation(), Parser\getRealCurrentLineNb(), Parser\isCurrentLineBlank(), Parser\isCurrentLineComment(), Parser\isCurrentLineEmpty(), Parser\isStringUnIndentedCollectionItem(), Parser\moveToNextLine(), Parser\moveToPreviousLine(), et null.

Référencé par Parser\doParse().

◆ getRealCurrentLineNb()

getRealCurrentLineNb ( )

Returns the current line number (takes the offset into account).

Références Parser\$offset.

Référencé par Parser\doParse(), Parser\getLineTag(), Parser\getNextEmbedBlock(), et Parser\parseValue().

◆ hasMoreLines()

hasMoreLines ( )
private

Références Parser\$currentLineNb.

Référencé par Parser\consumeWhitespaces(), Parser\lexInlineQuotedString(), et Parser\lexInlineStructure().

◆ isCurrentLineBlank()

isCurrentLineBlank ( )
private

Returns true if the current line is blank.

Référencé par Parser\getNextEmbedBlock(), Parser\isCurrentLineEmpty(), Parser\lexInlineQuotedString(), et Parser\parseBlockScalar().

◆ isCurrentLineComment()

isCurrentLineComment ( )
private

Returns true if the current line is a comment line.

Références Parser\$currentLine.

Référencé par Parser\getNextEmbedBlock(), Parser\isCurrentLineEmpty(), Parser\isNextLineIndented(), et Parser\isNextLineUnIndentedCollection().

◆ isCurrentLineEmpty()

isCurrentLineEmpty ( )
private

Returns true if the current line is blank or if it is a comment line.

Références Parser\isCurrentLineBlank(), et Parser\isCurrentLineComment().

Référencé par Parser\doParse(), Parser\getNextEmbedBlock(), Parser\isNextLineIndented(), et Parser\isNextLineUnIndentedCollection().

◆ isCurrentLineLastLineInDocument()

isCurrentLineLastLineInDocument ( )
private

Références Joomla\Database\Query\offset().

Référencé par Parser\parseBlockScalar().

◆ isNextLineIndented()

isNextLineIndented ( )
private

Returns true if the next line is indented.

Références $i, Parser\getCurrentLineIndentation(), Parser\isCurrentLineComment(), Parser\isCurrentLineEmpty(), Parser\moveToNextLine(), et Parser\moveToPreviousLine().

Référencé par Parser\doParse(), et Parser\getLineTag().

◆ isNextLineUnIndentedCollection()

isNextLineUnIndentedCollection ( )
private

Returns true if the next line starts unindented collection.

Références $i, Parser\getCurrentLineIndentation(), Parser\isCurrentLineComment(), Parser\isCurrentLineEmpty(), Parser\isStringUnIndentedCollectionItem(), Parser\moveToNextLine(), et Parser\moveToPreviousLine().

Référencé par Parser\doParse().

◆ isStringUnIndentedCollectionItem()

isStringUnIndentedCollectionItem ( )
private

Returns true if the string is un-indented collection item.

Référencé par Parser\getNextEmbedBlock(), et Parser\isNextLineUnIndentedCollection().

◆ lexInlineMapping()

lexInlineMapping ( int & $cursor = 0 )
private

Références Parser\lexInlineStructure().

Référencé par Parser\doParse(), Parser\lexInlineStructure(), et Parser\parseValue().

◆ lexInlineQuotedString()

lexInlineQuotedString ( int & $cursor = 0 )
private

Références $value, elseif, Parser\hasMoreLines(), Parser\isCurrentLineBlank(), et Parser\moveToNextLine().

Référencé par Parser\doParse(), Parser\lexInlineStructure(), et Parser\parseValue().

◆ lexInlineSequence()

lexInlineSequence ( int & $cursor = 0 )
private

Références Parser\lexInlineStructure().

Référencé par Parser\doParse(), Parser\lexInlineStructure(), et Parser\parseValue().

◆ lexInlineStructure()

lexInlineStructure | ( | int & | $cursor,
 |  | string | $closingTag
 | ) |  |
private

Références $value, Parser\consumeWhitespaces(), Parser\hasMoreLines(), Parser\lexInlineMapping(), Parser\lexInlineQuotedString(), Parser\lexInlineSequence(), Parser\lexUnquotedString(), et Parser\moveToNextLine().

Référencé par Parser\lexInlineMapping(), et Parser\lexInlineSequence().

◆ lexUnquotedString()

lexUnquotedString ( int & $cursor )
private

Références Parser\$offset.

Référencé par Parser\lexInlineStructure().

◆ moveToNextLine()

moveToNextLine ( )
private

Moves the parser to the next line.

Références Parser\$currentLineNb.

Référencé par Parser\consumeWhitespaces(), Parser\doParse(), Parser\getNextEmbedBlock(), Parser\isNextLineIndented(), Parser\isNextLineUnIndentedCollection(), Parser\lexInlineQuotedString(), Parser\lexInlineStructure(), Parser\parseBlockScalar(), et Parser\parseValue().

◆ moveToPreviousLine()

moveToPreviousLine ( )
private

Moves the parser to the previous line.

Références Parser\$currentLineNb.

Référencé par Parser\getNextEmbedBlock(), Parser\isNextLineIndented(), Parser\isNextLineUnIndentedCollection(), Parser\parseBlockScalar(), et Parser\parseValue().

◆ parse()

parse | ( | string | $value,
 |  | int | $flags = 0
 | ) |  |

Parses a YAML string to a PHP value.

Paramètres
string | $value | A YAML string
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
Renvoie
mixed
Exceptions
ParseException If the YAML is not valid

Références $data, $value, Parser\doParse(), null, Joomla\Database\Query\offset(), et Parser\preg_match().

Référencé par Parser\parseFile().

◆ parseBlock()

parseBlock | ( | int | $offset,
 |  | string | $yaml,
 |  | int | $flags
 | ) |  |
private

Références Parser\$offset, Parser\$refs, Parser\$refsBeingParsed, Parser\$skippedLineNumbers, et Parser\$totalNumberOfLines.

Référencé par Parser\doParse().

◆ parseBlockScalar()

parseBlockScalar | ( | string | $style,
 |  | string | $chomping = '',
 |  | int | $indentation = 0
 | ) |  |
private

Parses a block scalar.

Paramètres
string | $style | The style indicator that was used to begin this block scalar (| or >)
string | $chomping | The chomping indicator that was used to begin this block scalar (+ or -)
int | $indentation | The indentation indicator that was used to begin this block scalar

Références $i, $style, $text, elseif, Parser\isCurrentLineBlank(), Parser\isCurrentLineLastLineInDocument(), Parser\moveToNextLine(), et Parser\moveToPreviousLine().

Référencé par Parser\parseValue().

◆ parseFile()

parseFile | ( | string | $filename,
 |  | int | $flags = 0
 | ) |  |

Parses a YAML file into a PHP value.

Paramètres
string | $filename | The path to the YAML file to be parsed
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
Renvoie
mixed
Exceptions
ParseException If the file could not be read or the YAML is not valid

Références Parser\$filename, null, et Parser\parse().

◆ parseValue()

parseValue | ( | string | $value,
 |  | int | $flags,
 |  | string | $context
 | ) |  |
private

Parses a YAML value.

Paramètres
string | $value | A YAML value
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
string | $context | The parser context (either sequence or mapping)
Renvoie
mixed
Exceptions
ParseException When reference does not exist

Références $context, $data, $i, Parser\$lines, Inline\$parsedLineNumber, $value, elseif, Inline\evaluateBinaryScalar(), Parser\getCurrentLineIndentation(), Parser\getRealCurrentLineNb(), Parser\lexInlineMapping(), Parser\lexInlineQuotedString(), Parser\lexInlineSequence(), Parser\moveToNextLine(), Parser\moveToPreviousLine(), Inline\parse(), Parser\parseBlockScalar(), ParseException\setParsedLine(), et ParseException\setSnippet().

Référencé par Parser\doParse().

◆ preg_match()

static preg_match | ( | string | $pattern,
 |  | string | $subject,
 |  | array & | $matches = null,
 |  | int | $flags = 0,
 |  | int | $offset = 0
 | ) |  |
static

A local wrapper for "preg_match" which will throw a ParseException if there is an internal error in the PCRE engine.

This avoids us needing to check for "false" every time PCRE is used in the YAML engine

Exceptions
ParseException on a PCRE internal error
Voir également
preg_last_error()

Références Parser\$offset, et $subject.

Référencé par Inline\dump(), Inline\evaluateBinaryScalar(), Inline\evaluateScalar(), Parser\parse(), Inline\parseMapping(), Inline\parseQuotedScalar(), Inline\parseScalar(), et Inline\parseSequence().

◆ trimTag()

trimTag ( string $value )
private

Trim the tag on top of the value.

Prevent values such as "!foo {quz: bar}" to be considered as a mapping block.

Références $value.

Référencé par Parser\doParse().

Documentation des champs

◆ $currentLine

$currentLine = ''
private

Référencé par Parser\getNextEmbedBlock(), et Parser\isCurrentLineComment().

◆ $currentLineNb

$currentLineNb = -1
private

Référencé par Parser\hasMoreLines(), Parser\moveToNextLine(), et Parser\moveToPreviousLine().

◆ $filename

$filename
private

Référencé par Parser\parseFile().

◆ $lines

$lines = []
private

Référencé par Parser\parseValue().

◆ $locallySkippedLineNumbers

$locallySkippedLineNumbers = []
private

◆ $numberOfParsedLines

$numberOfParsedLines = 0
private

Référencé par Parser\doParse().

◆ $offset

$offset = 0
private

Référencé par Parser\getRealCurrentLineNb(), Parser\lexUnquotedString(), Parser\parseBlock(), et Parser\preg_match().

◆ $refs

$refs = []
private

Référencé par Parser\parseBlock().

◆ $refsBeingParsed

$refsBeingParsed = []
private

Référencé par Parser\parseBlock().

◆ $skippedLineNumbers

$skippedLineNumbers = []
private

Référencé par Parser\parseBlock().

◆ $totalNumberOfLines

$totalNumberOfLines
private

Référencé par Parser\parseBlock().

◆ BLOCK_SCALAR_HEADER_PATTERN

const BLOCK_SCALAR_HEADER_PATTERN = '(?P<separator>\||>)(?P<modifiers>\+|\-|\d+|\+\d+|\-\d+|\d+\+|\d+\-)?(?P<comments> +#.*)?'

◆ REFERENCE_PATTERN

const REFERENCE_PATTERN = '#^&(?P<ref>[^ ]++) *+(?P<value>.*)#u'

Référencé par Inline\parseMapping(), et Inline\parseSequence().

◆ TAG_PATTERN

const TAG_PATTERN = '(?P<tag>![\w!.\/:-]+)'
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/symfony/yaml/Parser.php


Joomla CMS: Référence de la classe Unescaper

  • Symfony
  • Component
  • Yaml
  • Unescaper
Fonctions membres publiques | Champs de données | Fonctions membres privées | Fonctions membres privées statiques
Référence de la classe Unescaper

Fonctions membres publiques

unescapeSingleQuotedString (string $value)
unescapeDoubleQuotedString (string $value)

Champs de données

const REGEX_ESCAPED_CHARACTER = '\\\\(x[0-9a-fA-F]{2}|u[0-9a-fA-F]{4}|U[0-9a-fA-F]{8}|.)'

Fonctions membres privées

unescapeCharacter (string $value)

Fonctions membres privées statiques

static utf8chr (int $c)

Description détaillée

Unescaper encapsulates unescaping rules for single and double-quoted YAML strings.

Auteur
Matthew Lewinski matth.nosp@m.ew@l.nosp@m.ewins.nosp@m.ki.o.nosp@m.rg

Documentation des fonctions membres

◆ unescapeCharacter()

unescapeCharacter ( string $value )
private

Unescapes a character that was found in a double-quoted string.

Paramètres
string $value An escaped character

Références $value.

Référencé par Unescaper\unescapeDoubleQuotedString().

◆ unescapeDoubleQuotedString()

unescapeDoubleQuotedString ( string $value )

Unescapes a double quoted string.

Paramètres
string $value A double quoted string

Références $value, et Unescaper\unescapeCharacter().

◆ unescapeSingleQuotedString()

unescapeSingleQuotedString ( string $value )

Unescapes a single quoted string.

Paramètres
string $value A single quoted string

Références $value.

◆ utf8chr()

static utf8chr ( int $c )
staticprivate

Get the UTF-8 character for the given code point.

Références $c.

Documentation des champs

◆ REGEX_ESCAPED_CHARACTER

const REGEX_ESCAPED_CHARACTER = '\\\\(x[0-9a-fA-F]{2}|u[0-9a-fA-F]{4}|U[0-9a-fA-F]{8}|.)'

Regex fragment that matches an escaped character in a double quoted string.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Unescaper.php


Joomla CMS: Référence de la classe Yaml

  • Symfony
  • Component
  • Yaml
  • Yaml
Fonctions membres publiques statiques | Champs de données
Référence de la classe Yaml

Fonctions membres publiques statiques

static | parseFile (string $filename, int $flags=0)
static | parse (string $input, int $flags=0)
static | dump ($input, int $inline=2, int $indent=4, int $flags=0)

Champs de données

const | DUMP_OBJECT = 1
const | PARSE_EXCEPTION_ON_INVALID_TYPE = 2
const | PARSE_OBJECT = 4
const | PARSE_OBJECT_FOR_MAP = 8
const | DUMP_EXCEPTION_ON_INVALID_TYPE = 16
const | PARSE_DATETIME = 32
const | DUMP_OBJECT_AS_MAP = 64
const | DUMP_MULTI_LINE_LITERAL_BLOCK = 128
const | PARSE_CONSTANT = 256
const | PARSE_CUSTOM_TAGS = 512
const | DUMP_EMPTY_ARRAY_AS_SEQUENCE = 1024
const | DUMP_NULL_AS_TILDE = 2048

Description détaillée

Yaml offers convenience methods to load and dump YAML.

Auteur
Fabien Potencier fabie.nosp@m.n@sy.nosp@m.mfony.nosp@m..com

Documentation des fonctions membres

◆ dump()

static dump | ( |  | $input,
 |  | int | $inline = 2,
 |  | int | $indent = 4,
 |  | int | $flags = 0
 | ) |  |
static

Dumps a PHP value to a YAML string.

The dump method, when supplied with an array, will do its best to convert the array into friendly YAML.

Paramètres
mixed | $input | The PHP value
int | $inline | The level where you switch to inline YAML
int | $indent | The amount of spaces to use for indentation of nested nodes
int | $flags | A bit field of DUMP_* constants to customize the dumped YAML string

Références $input.

◆ parse()

static parse | ( | string | $input,
 |  | int | $flags = 0
 | ) |  |
static

Parses YAML into a PHP value.

Usage: $array = Yaml::parse(file_get_contents('config.yml')); print_r($array);

Paramètres
string | $input | A string containing YAML
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
Renvoie
mixed
Exceptions
ParseException If the YAML is not valid

Références $input.

◆ parseFile()

static parseFile | ( | string | $filename,
 |  | int | $flags = 0
 | ) |  |
static

Parses a YAML file into a PHP value.

Usage:

$array = Yaml::parseFile('config.yml');
print_r($array);
Paramètres
string | $filename | The path to the YAML file to be parsed
int | $flags | A bit field of PARSE_* constants to customize the YAML parser behavior
Renvoie
mixed
Exceptions
ParseException If the file could not be read or the YAML is not valid

Documentation des champs

◆ DUMP_EMPTY_ARRAY_AS_SEQUENCE

const DUMP_EMPTY_ARRAY_AS_SEQUENCE = 1024

Référencé par Inline\dumpArray().

◆ DUMP_EXCEPTION_ON_INVALID_TYPE

const DUMP_EXCEPTION_ON_INVALID_TYPE = 16

Référencé par Inline\dump().

◆ DUMP_MULTI_LINE_LITERAL_BLOCK

const DUMP_MULTI_LINE_LITERAL_BLOCK = 128

Référencé par Dumper\dump().

◆ DUMP_NULL_AS_TILDE

const DUMP_NULL_AS_TILDE = 2048

Référencé par Inline\dumpNull().

◆ DUMP_OBJECT

const DUMP_OBJECT = 1

Référencé par Inline\dump().

◆ DUMP_OBJECT_AS_MAP

const DUMP_OBJECT_AS_MAP = 64

Référencé par Dumper\dump(), et Inline\dump().

◆ PARSE_CONSTANT

const PARSE_CONSTANT = 256

Référencé par Inline\initialize(), et LintCommand\validate().

◆ PARSE_CUSTOM_TAGS

const PARSE_CUSTOM_TAGS = 512

Référencé par LintCommand\execute(), Parser\getLineTag(), et Inline\parseTag().

◆ PARSE_DATETIME

const PARSE_DATETIME = 32

Référencé par Inline\evaluateScalar().

◆ PARSE_EXCEPTION_ON_INVALID_TYPE

const PARSE_EXCEPTION_ON_INVALID_TYPE = 2

Référencé par Inline\initialize().

◆ PARSE_OBJECT

const PARSE_OBJECT = 4

Référencé par Inline\initialize().

◆ PARSE_OBJECT_FOR_MAP

const PARSE_OBJECT_FOR_MAP = 8

Référencé par Parser\doParse(), et Inline\initialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/yaml/Yaml.php


Joomla CMS: Référence de la classe Required

  • Symfony
  • Contracts
  • Service
  • Attribute
  • Required
Référence de la classe Required

Description détaillée

A required dependency.

This attribute indicates that a property holds a required dependency. The annotated property or method should be considered during the instantiation process of the containing class.

Auteur
Alexander M. Turek me@de.nosp@m.rrab.nosp@m.us.de
La documentation de cette classe a été générée à partir du fichier suivant :
  • Required.php


Joomla CMS: Référence de la classe SubscribedService

  • Symfony
  • Contracts
  • Service
  • Attribute
  • SubscribedService
Fonctions membres publiques
Référence de la classe SubscribedService

Fonctions membres publiques

__construct (public ?string $key=null)

Description détaillée

Use with {

Voir également
ServiceSubscriberTrait} to mark a method's return type as a subscribed service.
Auteur
Kevin Bond kevin.nosp@m.bond.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( public ?string $key = null )
Paramètres
string | null $key The key to use for the service If null, use "ClassName::methodName"
La documentation de cette classe a été générée à partir du fichier suivant :
  • SubscribedService.php


Joomla CMS: Référence de la classe ServiceLocatorTest

  • Symfony
  • Contracts
  • Service
  • Test
  • ServiceLocatorTest
Fonctions membres publiques | Fonctions membres protégées
Référence de la classe ServiceLocatorTest
+ Graphe d'héritage de ServiceLocatorTest:

Fonctions membres publiques

testHas ()
testGet ()
testGetDoesNotMemoize ()
testThrowsOnUndefinedInternalService ()
testThrowsOnCircularReference ()

Fonctions membres protégées

getServiceLocator (array $factories)

Documentation des fonctions membres

◆ getServiceLocator()

getServiceLocator ( array $factories )
protected
Renvoie
ContainerInterface

Références Symfony\Contracts\Service\ServiceLocatorTrait.

Référencé par ServiceLocatorTest\testGet(), ServiceLocatorTest\testGetDoesNotMemoize(), ServiceLocatorTest\testHas(), ServiceLocatorTest\testThrowsOnCircularReference(), et ServiceLocatorTest\testThrowsOnUndefinedInternalService().

◆ testGet()

testGet ( )

Références ServiceLocatorTest\getServiceLocator().

◆ testGetDoesNotMemoize()

testGetDoesNotMemoize ( )

Références $i, et ServiceLocatorTest\getServiceLocator().

◆ testHas()

testHas ( )

Références ServiceLocatorTest\getServiceLocator().

◆ testThrowsOnCircularReference()

testThrowsOnCircularReference ( )

Références class, et ServiceLocatorTest\getServiceLocator().

◆ testThrowsOnUndefinedInternalService()

testThrowsOnUndefinedInternalService ( )

Références class, et ServiceLocatorTest\getServiceLocator().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ServiceLocatorTest.php


Joomla CMS: Référence de l'interface ResetInterface

  • Symfony
  • Contracts
  • Service
  • ResetInterface
Fonctions membres publiques
Référence de l'interface ResetInterface
+ Graphe d'héritage de ResetInterface:
Application OutputFormatterStyleStack

Fonctions membres publiques

reset ()

Description détaillée

Provides a way to reset an object to its initial state.

When calling the "reset()" method on an object, it should be put back to its initial state. This usually means clearing any internal buffers and forwarding the call to internal dependencies. All properties of the object should be put back to the same state it had when it was first ready to use.

This method could be called, for example, to recycle objects that are used as services, so that they can be used to handle several requests in the same process loop (note that we advise making your services stateless instead of implementing this interface when possible.)

Documentation des fonctions membres

◆ reset()

reset ( )

Implémenté dans Application, et OutputFormatterStyleStack.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ResetInterface.php


Joomla CMS: Référence de l'interface ServiceProviderInterface

  • Symfony
  • Contracts
  • Service
  • ServiceProviderInterface
Fonctions membres publiques
Référence de l'interface ServiceProviderInterface
+ Graphe d'héritage de ServiceProviderInterface:
ContainerInterface

Fonctions membres publiques

getProvidedServices ()
- Fonctions membres publiques hérités de ContainerInterface
get (string $id)
has (string $id)

Description détaillée

A ServiceProviderInterface exposes the identifiers and the types of services provided by a container.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Mateusz Sip mateu.nosp@m.sz.s.nosp@m.ip@gm.nosp@m.ail..nosp@m.com

Documentation des fonctions membres

◆ getProvidedServices()

getProvidedServices ( )

Returns an associative array of service types keyed by the identifiers provided by the current container.

Examples:

  • ['logger' => 'Psr'] means the object provides a service named "logger" that implements Psr
  • ['foo' => '?'] means the container provides service name "foo" of unspecified type
  • ['bar' => '?Bar'] means the container provides a service "bar" of type Bar|null
Renvoie
string[] The provided service types, keyed by service names
La documentation de cette interface a été générée à partir du fichier suivant :
  • symfony/service-contracts/ServiceProviderInterface.php


Joomla CMS: Référence de l'interface ServiceSubscriberInterface

  • Symfony
  • Contracts
  • Service
  • ServiceSubscriberInterface
Fonctions membres publiques statiques
Référence de l'interface ServiceSubscriberInterface

Fonctions membres publiques statiques

static getSubscribedServices ()

Description détaillée

A ServiceSubscriber exposes its dependencies via the static getSubscribedServices method.

The getSubscribedServices method returns an array of service types required by such instances, optionally keyed by the service names used internally. Service types that start with an interrogation mark "?" are optional, while the other ones are mandatory service dependencies.

The injected service locators SHOULD NOT allow access to any other services not specified by the method.

It is expected that ServiceSubscriber instances consume PSR-11-based service locators internally. This interface does not dictate any injection method for these service locators, although constructor injection is recommended.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ getSubscribedServices()

static getSubscribedServices ( )
static

Returns an array of service types required by such instances, optionally keyed by the service names used internally.

For mandatory dependencies:

  • ['logger' => 'Psr'] means the objects use the "logger" name internally to fetch a service which must implement Psr.
  • ['loggers' => 'Psr[]'] means the objects use the "loggers" name internally to fetch an iterable of Psr instances.
  • ['Psr'] is a shortcut for
  • ['Psr' => 'Psr']

otherwise:

  • ['logger' => '?Psr'] denotes an optional dependency
  • ['loggers' => '?Psr[]'] denotes an optional iterable dependency
  • ['?Psr'] is a shortcut for
  • ['Psr' => '?Psr']
Renvoie
string[] The required service types, optionally keyed by service names
La documentation de cette interface a été générée à partir du fichier suivant :
  • ServiceSubscriberInterface.php


Joomla CMS: Référence de la classe Ctype

  • Symfony
  • Polyfill
  • Ctype
  • Ctype
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Ctype

Fonctions membres publiques statiques

static | ctype_alnum ($text)
static | ctype_alpha ($text)
static | ctype_cntrl ($text)
static | ctype_digit ($text)
static | ctype_graph ($text)
static | ctype_lower ($text)
static | ctype_print ($text)
static | ctype_punct ($text)
static | ctype_space ($text)
static | ctype_upper ($text)
static | ctype_xdigit ($text)

Fonctions membres privées statiques

static convert_int_to_char_for_ctype ($int, $function)

Description détaillée

Ctype implementation through regex.

Documentation des fonctions membres

◆ convert_int_to_char_for_ctype()

static convert_int_to_char_for_ctype | ( | $int,
 |  | $function
 | ) |
staticprivate

Converts integers to their char versions according to normal ctype behaviour, if needed.

If an integer between -128 and 255 inclusive is provided, it is interpreted as the ASCII value of a single character (negative values have 256 added in order to allow characters in the Extended ASCII range). Any other integer is interpreted as a string containing the decimal digits of the integer.

Paramètres
mixed | $int
string | $function
Renvoie
mixed

Références $function.

◆ ctype_alnum()

static ctype_alnum ( $text )
static

Returns TRUE if every character in text is either a letter or a digit, FALSE otherwise.

Voir également
https://php.net/ctype-alnum
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_alpha()

static ctype_alpha ( $text )
static

Returns TRUE if every character in text is a letter, FALSE otherwise.

Voir également
https://php.net/ctype-alpha
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_cntrl()

static ctype_cntrl ( $text )
static

Returns TRUE if every character in text is a control character from the current locale, FALSE otherwise.

Voir également
https://php.net/ctype-cntrl
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_digit()

static ctype_digit ( $text )
static

Returns TRUE if every character in the string text is a decimal digit, FALSE otherwise.

Voir également
https://php.net/ctype-digit
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_graph()

static ctype_graph ( $text )
static

Returns TRUE if every character in text is printable and actually creates visible output (no white space), FALSE otherwise.

Voir également
https://php.net/ctype-graph
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_lower()

static ctype_lower ( $text )
static

Returns TRUE if every character in text is a lowercase letter.

Voir également
https://php.net/ctype-lower
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_print()

static ctype_print ( $text )
static

Returns TRUE if every character in text will actually create output (including blanks). Returns FALSE if text contains control characters or characters that do not have any output or control function at all.

Voir également
https://php.net/ctype-print
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_punct()

static ctype_punct ( $text )
static

Returns TRUE if every character in text is printable, but neither letter, digit or blank, FALSE otherwise.

Voir également
https://php.net/ctype-punct
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_space()

static ctype_space ( $text )
static

Returns TRUE if every character in text creates some sort of white space, FALSE otherwise. Besides the blank character this also includes tab, vertical tab, line feed, carriage return and form feed characters.

Voir également
https://php.net/ctype-space
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_upper()

static ctype_upper ( $text )
static

Returns TRUE if every character in text is an uppercase letter.

Voir également
https://php.net/ctype-upper
Paramètres
mixed $text
Renvoie
bool

Références $text.

◆ ctype_xdigit()

static ctype_xdigit ( $text )
static

Returns TRUE if every character in text is a hexadecimal 'digit', that is a decimal digit or a character from [A-Fa-f] , FALSE otherwise.

Voir également
https://php.net/ctype-xdigit
Paramètres
mixed $text
Renvoie
bool

Références $text.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Ctype.php


Joomla CMS: Référence de la classe Iconv

  • Symfony
  • Polyfill
  • Iconv
  • Iconv
Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Iconv

Fonctions membres publiques statiques

static | iconv ($inCharset, $outCharset, $str)
static | iconv_mime_decode_headers ($str, $mode=0, $charset=null)
static | iconv_mime_decode ($str, $mode=0, $charset=null)
static | iconv_get_encoding ($type='all')
static | iconv_set_encoding ($type, $charset)
static | iconv_mime_encode ($fieldName, $fieldValue, $pref=null)
static | iconv_strlen ($s, $encoding=null)
static | strlen1 ($s, $encoding=null)
static | strlen2 ($s, $encoding=null)
static | iconv_strpos ($haystack, $needle, $offset=0, $encoding=null)
static | iconv_strrpos ($haystack, $needle, $encoding=null)
static | iconv_substr ($s, $start, $length=2147483647, $encoding=null)

Champs de données

const | ERROR_ILLEGAL_CHARACTER = 'iconv(): Detected an illegal character in input string'
const | ERROR_WRONG_CHARSET = 'iconv(): Wrong charset, conversion from `%s\' to `%s\' is not allowed'

Attributs publics statiques

static | $inputEncoding = 'utf-8'
static | $outputEncoding = 'utf-8'
static | $internalEncoding = 'utf-8'
static | xD0 => 2, "\xE0" => 3, "\xF0" => 4]

Fonctions membres privées statiques

static | loadMap ($type, $charset, &$map)
static | utf8ToUtf8 ($str, $ignore)
static | mapToUtf8 (&$result, array $map, $str, $ignore)
static | mapFromUtf8 (&$result, array $map, $str, $ignore, $translit)
static | qpByteCallback (array $m)
static | pregOffset ($offset)
static | getData ($file)

Attributs privés statiques

static | $alias
static static | $translitMap = []
static | $convertMap = []
static | $errorHandler
static | $lastError
static | $ulenMask = ["\xC0" => 2
static | $isValidUtf8

Description détaillée

iconv implementation in pure PHP, UTF-8 centric.

Implemented:

  • iconv - Convert string to requested character encoding
  • iconv_mime_decode - Decodes a MIME header field
  • iconv_mime_decode_headers - Decodes multiple MIME header fields at once
  • iconv_get_encoding - Retrieve internal configuration variables of iconv extension
  • iconv_set_encoding - Set current setting for character encoding conversion
  • iconv_mime_encode - Composes a MIME header field
  • iconv_strlen - Returns the character count of string
  • iconv_strpos - Finds position of first occurrence of a needle within a haystack
  • iconv_strrpos - Finds the last occurrence of a needle within a haystack
  • iconv_substr - Cut out part of a string

Charsets available for conversion are defined by files in the charset/ directory and by Iconv::$alias below. You're welcome to send back any addition you make.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ getData()

static getData ( $file )
staticprivate

Références __DIR__.

◆ iconv()

static iconv | ( | $inCharset,
 |  | $outCharset,
 |  | $str
 | ) |
static

Références $loop, et $result.

◆ iconv_get_encoding()

static iconv_get_encoding ( $type = 'all' )
static

Références $type.

◆ iconv_mime_decode()

static iconv_mime_decode | ( | $str,
 |  | $mode = 0,
 |  | $charset = null
 | ) |
static

Références $c, $i, $mode, $result, elseif, et null.

◆ iconv_mime_decode_headers()

static iconv_mime_decode_headers | ( | $str,
 |  | $mode = 0,
 |  | $charset = null
 | ) |
static

Références $mode, et null.

◆ iconv_mime_encode()

static iconv_mime_encode | ( | $fieldName,
 |  | $fieldValue,
 |  | $pref = null
 | ) |
static

Références $c, et $fieldValue.

◆ iconv_set_encoding()

static iconv_set_encoding | ( | $type,
 |  | $charset
 | ) |
static

Références $type.

◆ iconv_strlen()

static iconv_strlen | ( | $s,
 |  | $encoding = null
 | ) |
static

Références null.

◆ iconv_strpos()

static iconv_strpos | ( | $haystack,
 |  | $needle,
 |  | $offset = 0,
 |  | $encoding = null
 | ) |
static

Références Joomla\Database\Query\$offset, false, et null.

◆ iconv_strrpos()

static iconv_strrpos | ( | $haystack,
 |  | $needle,
 |  | $encoding = null
 | ) |
static

Références false, et null.

◆ iconv_substr()

static iconv_substr | ( | $s,
 |  | $start,
 |  | $length = 2147483647,
 |  | $encoding = null
 | ) |
static

Références $start, elseif, et null.

◆ loadMap()

static loadMap | ( |  | $type,
 |  |  | $charset,
 |  | & | $map
 | ) |  |
staticprivate

Références $type.

◆ mapFromUtf8()

static mapFromUtf8 | ( | & | $result,
 |  | array | $map,
 |  |  | $str,
 |  |  | $ignore,
 |  |  | $translit
 | ) |  |
staticprivate

Références $i, $result, Iconv\$ulenMask, elseif, Normalizer\NFD, et Normalizer\normalize().

◆ mapToUtf8()

static mapToUtf8 | ( | & | $result,
 |  | array | $map,
 |  |  | $str,
 |  |  | $ignore
 | ) |  |
staticprivate

Références $i, $result, et elseif.

◆ pregOffset()

static pregOffset ( $offset )
staticprivate

Références Joomla\Database\Query\$offset.

◆ qpByteCallback()

static qpByteCallback ( array $m )
staticprivate

◆ strlen1()

static strlen1 | ( | $s,
 |  | $encoding = null
 | ) |
static

Références null.

◆ strlen2()

static strlen2 | ( | $s,
 |  | $encoding = null
 | ) |
static

Références $i, Iconv\$ulenMask, et null.

◆ utf8ToUtf8()

static utf8ToUtf8 | ( | $str,
 |  | $ignore
 | ) |
staticprivate

Références $i, et Iconv\$ulenMask.

Documentation des champs

◆ $alias

$alias
staticprivate
Valeur initiale :
= [
'utf8' => 'utf-8'

◆ $convertMap

$convertMap = []
staticprivate

◆ $errorHandler

$errorHandler
staticprivate

◆ $inputEncoding

$inputEncoding = 'utf-8'
static

◆ $internalEncoding

$internalEncoding = 'utf-8'
static

◆ $isValidUtf8

$isValidUtf8
staticprivate

◆ $lastError

$lastError
staticprivate

◆ $outputEncoding

$outputEncoding = 'utf-8'
static

◆ $translitMap

static $translitMap = []
staticprivate

◆ $ulenMask

$ulenMask = ["\xC0" => 2
staticprivate

Référencé par Iconv\mapFromUtf8(), Iconv\strlen2(), et Iconv\utf8ToUtf8().

◆ ERROR_ILLEGAL_CHARACTER

const ERROR_ILLEGAL_CHARACTER = 'iconv(): Detected an illegal character in input string'

◆ ERROR_WRONG_CHARSET

const ERROR_WRONG_CHARSET = 'iconv(): Wrong charset, conversion from `%s\' to `%s\' is not allowed'

◆ xD0

xD0 => 2, "\xE0" => 3, "\xF0" => 4]
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Iconv.php


Joomla CMS: Référence de la classe Grapheme

  • Symfony
  • Polyfill
  • Intl
  • Grapheme
  • Grapheme
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés
Référence de la classe Grapheme

Fonctions membres publiques statiques

static | grapheme_extract ($s, $size, $type=\GRAPHEME_EXTR_COUNT, $start=0, &$next=0)
static | grapheme_strlen ($s)
static | grapheme_substr ($s, $start, $len=null)
static | grapheme_strpos ($s, $needle, $offset=0)
static | grapheme_stripos ($s, $needle, $offset=0)
static | grapheme_strrpos ($s, $needle, $offset=0)
static | grapheme_strripos ($s, $needle, $offset=0)
static | grapheme_stristr ($s, $needle, $beforeNeedle=false)
static | grapheme_strstr ($s, $needle, $beforeNeedle=false)

Champs de données

const GRAPHEME_CLUSTER_RX = '(?:\r\n|(?:[ -~\x{200C}\x{200D}]|[ᆨ-ᇹ]+|[ᄀ-ᅟ]*(?:[가개갸걔거게겨계고과괘괴교구궈궤귀규그긔기까깨꺄꺠꺼께껴꼐꼬꽈꽤꾀꾜꾸꿔꿰뀌뀨끄끠끼나내냐냬너네녀녜노놔놰뇌뇨누눠눼뉘뉴느늬니다대댜댸더데뎌뎨도돠돼되됴두둬뒈뒤듀드듸디따때땨떄떠떼뗘뗴또똬뙈뙤뚀뚜뚸뛔뛰뜌뜨띄띠라래랴럐러레려례로롸뢔뢰료루뤄뤠뤼류르릐리마매먀먜머메며몌모뫄뫠뫼묘무뭐뭬뮈뮤므믜미바배뱌뱨버베벼볘보봐봬뵈뵤부붜붸뷔뷰브븨비빠빼뺘뺴뻐뻬뼈뼤뽀뽜뽸뾔뾰뿌뿨쀄쀠쀼쁘쁴삐사새샤섀서세셔셰소솨쇄쇠쇼수숴쉐쉬슈스싀시싸쌔쌰썌써쎄쎠쎼쏘쏴쐐쐬쑈쑤쒀쒜쒸쓔쓰씌씨아애야얘어에여예오와왜외요우워웨위유으의이자재쟈쟤저제져졔조좌좨죄죠주줘줴쥐쥬즈즤지짜째쨔쨰쩌쩨쪄쪠쪼쫘쫴쬐쬬쭈쭤쮀쮜쮸쯔쯰찌차채챠챼처체쳐쳬초촤쵀최쵸추춰췌취츄츠츼치카캐캬컈커케켜켸코콰쾌쾨쿄쿠쿼퀘퀴큐크킈키타태탸턔터테텨톄토톼퇘퇴툐투퉈퉤튀튜트틔티파패퍄퍠퍼페펴폐포퐈퐤푀표푸풔풰퓌퓨프픠피하해햐햬허헤혀혜호화홰회효후훠훼휘휴흐희히]?[ᅠ-ᆢ]+|[가-힣])[ᆨ-ᇹ]*|[ᄀ-ᅟ]+|[^\p{Cc}\p{Cf}\p{Zl}\p{Zp}])[\p{Mn}\p{Me}\x{09BE}\x{09D7}\x{0B3E}\x{0B57}\x{0BBE}\x{0BD7}\x{0CC2}\x{0CD5}\x{0CD6}\x{0D3E}\x{0D57}\x{0DCF}\x{0DDF}\x{200C}\x{200D}\x{1D165}\x{1D16E}-\x{1D172}]*|[\p{Cc}\p{Cf}\p{Zl}\p{Zp}])'

Fonctions membres privées statiques

static grapheme_position ($s, $needle, $offset, $mode)

Attributs privés

const CASE_FOLD

Description détaillée

Partial intl implementation in pure PHP.

Implemented:

  • grapheme_extract - Extract a sequence of grapheme clusters from a text buffer, which must be encoded in UTF-8
  • grapheme_stripos - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_stristr - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strlen - Get string length in grapheme units
  • grapheme_strpos - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos - Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • grapheme_substr - Return part of a string
Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ grapheme_extract()

static grapheme_extract | ( |  | $s,
 |  |  | $size,
 |  |  | $type = \GRAPHEME_EXTR_COUNT,
 |  |  | $start = 0,
 |  | & | $next = 0
 | ) |  |
static

Références $i, $size, $start, $type, elseif, et Symfony\Polyfill\Intl\Grapheme\SYMFONY_GRAPHEME_CLUSTER_RX.

◆ grapheme_position()

static grapheme_position | ( | $s,
 |  | $needle,
 |  | $offset,
 |  | $mode
 | ) |
staticprivate

Références $mode, Joomla\Database\Query\$offset, et elseif.

◆ grapheme_stripos()

static grapheme_stripos | ( | $s,
 |  | $needle,
 |  | $offset = 0
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ grapheme_stristr()

static grapheme_stristr | ( | $s,
 |  | $needle,
 |  | $beforeNeedle = false
 | ) |
static

◆ grapheme_strlen()

static grapheme_strlen ( $s )
static

Références null, et Symfony\Polyfill\Intl\Grapheme\SYMFONY_GRAPHEME_CLUSTER_RX.

◆ grapheme_strpos()

static grapheme_strpos | ( | $s,
 |  | $needle,
 |  | $offset = 0
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ grapheme_strripos()

static grapheme_strripos | ( | $s,
 |  | $needle,
 |  | $offset = 0
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ grapheme_strrpos()

static grapheme_strrpos | ( | $s,
 |  | $needle,
 |  | $offset = 0
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ grapheme_strstr()

static grapheme_strstr | ( | $s,
 |  | $needle,
 |  | $beforeNeedle = false
 | ) |
static

◆ grapheme_substr()

static grapheme_substr | ( | $s,
 |  | $start,
 |  | $len = null
 | ) |
static

Références $start, null, et Symfony\Polyfill\Intl\Grapheme\SYMFONY_GRAPHEME_CLUSTER_RX.

Documentation des champs

◆ CASE_FOLD

const CASE_FOLD
private
Valeur initiale :
= [
['µ', 'ſ', "\xCD\x85", 'ς', "\xCF\x90", "\xCF\x91", "\xCF\x95", "\xCF\x96", "\xCF\xB0", "\xCF\xB1", "\xCF\xB5", "\xE1\xBA\x9B", "\xE1\xBE\xBE"],
['μ', 's', 'ι', 'σ', 'β', 'θ', 'φ', 'π', 'κ', 'ρ', 'ε', "\xE1\xB9\xA1", 'ι'],
]

◆ GRAPHEME_CLUSTER_RX

const GRAPHEME_CLUSTER_RX = '(?:\r\n|(?:[ -~\x{200C}\x{200D}]|[ᆨ-ᇹ]+|[ᄀ-ᅟ]*(?:[가개갸걔거게겨계고과괘괴교구궈궤귀규그긔기까깨꺄꺠꺼께껴꼐꼬꽈꽤꾀꾜꾸꿔꿰뀌뀨끄끠끼나내냐냬너네녀녜노놔놰뇌뇨누눠눼뉘뉴느늬니다대댜댸더데뎌뎨도돠돼되됴두둬뒈뒤듀드듸디따때땨떄떠떼뗘뗴또똬뙈뙤뚀뚜뚸뛔뛰뜌뜨띄띠라래랴럐러레려례로롸뢔뢰료루뤄뤠뤼류르릐리마매먀먜머메며몌모뫄뫠뫼묘무뭐뭬뮈뮤므믜미바배뱌뱨버베벼볘보봐봬뵈뵤부붜붸뷔뷰브븨비빠빼뺘뺴뻐뻬뼈뼤뽀뽜뽸뾔뾰뿌뿨쀄쀠쀼쁘쁴삐사새샤섀서세셔셰소솨쇄쇠쇼수숴쉐쉬슈스싀시싸쌔쌰썌써쎄쎠쎼쏘쏴쐐쐬쑈쑤쒀쒜쒸쓔쓰씌씨아애야얘어에여예오와왜외요우워웨위유으의이자재쟈쟤저제져졔조좌좨죄죠주줘줴쥐쥬즈즤지짜째쨔쨰쩌쩨쪄쪠쪼쫘쫴쬐쬬쭈쭤쮀쮜쮸쯔쯰찌차채챠챼처체쳐쳬초촤쵀최쵸추춰췌취츄츠츼치카캐캬컈커케켜켸코콰쾌쾨쿄쿠쿼퀘퀴큐크킈키타태탸턔터테텨톄토톼퇘퇴툐투퉈퉤튀튜트틔티파패퍄퍠퍼페펴폐포퐈퐤푀표푸풔풰퓌퓨프픠피하해햐햬허헤혀혜호화홰회효후훠훼휘휴흐희히]?[ᅠ-ᆢ]+|[가-힣])[ᆨ-ᇹ]*|[ᄀ-ᅟ]+|[^\p{Cc}\p{Cf}\p{Zl}\p{Zp}])[\p{Mn}\p{Me}\x{09BE}\x{09D7}\x{0B3E}\x{0B57}\x{0BBE}\x{0BD7}\x{0CC2}\x{0CD5}\x{0CD6}\x{0D3E}\x{0D57}\x{0DCF}\x{0DDF}\x{200C}\x{200D}\x{1D165}\x{1D16E}-\x{1D172}]*|[\p{Cc}\p{Cf}\p{Zl}\p{Zp}])'
La documentation de cette classe a été générée à partir du fichier suivant :
  • Grapheme.php


Joomla CMS: Référence de la classe Normalizer

  • Symfony
  • Polyfill
  • Intl
  • Normalizer
  • Normalizer
Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Normalizer
+ Graphe d'héritage de Normalizer:
Normalizer

Fonctions membres publiques statiques

static | isNormalized (string $s, int $form=self::FORM_C)
static | normalize (string $s, int $form=self::FORM_C)

Champs de données

const | FORM_D = \Normalizer::FORM_D
const | FORM_KD = \Normalizer::FORM_KD
const | FORM_C = \Normalizer::FORM_C
const | FORM_KC = \Normalizer::FORM_KC
const | NFD = \Normalizer::NFD
const | NFKD = \Normalizer::NFKD
const | NFC = \Normalizer::NFC
const | NFKC = \Normalizer::NFKC

Attributs publics statiques

static xD0 => 2, "\xE0" => 3, "\xF0" => 4]

Fonctions membres privées statiques

static | recompose ($s)
static | decompose ($s, $c)
static | getData ($file)

Attributs privés statiques

static | $C
static | $D
static | $KD
static | $cC
static | $ulenMask = ["\xC0" => 2
static | $ASCII = "\x20\x65\x69\x61\x73\x6E\x74\x72\x6F\x6C\x75\x64\x5D\x5B\x63\x6D\x70\x27\x0A\x67\x7C\x68\x76\x2E\x66\x62\x2C\x3A\x3D\x2D\x71\x31\x30\x43\x32\x2A\x79\x78\x29\x28\x4C\x39\x41\x53\x2F\x50\x22\x45\x6A\x4D\x49\x6B\x33\x3E\x35\x54\x3C\x44\x34\x7D\x42\x7B\x38\x46\x77\x52\x36\x37\x55\x47\x4E\x3B\x4A\x7A\x56\x23\x48\x4F\x57\x5F\x26\x21\x4B\x3F\x58\x51\x25\x59\x5C\x09\x5A\x2B\x7E\x5E\x24\x40\x60\x7F\x00\x01\x02\x03\x04\x05\x06\x07\x08\x0B\x0C\x0D\x0E\x0F\x10\x11\x12\x13\x14\x15\x16\x17\x18\x19\x1A\x1B\x1C\x1D\x1E\x1F"

Description détaillée

Normalizer is a PHP fallback implementation of the Normalizer class provided by the intl extension.

It has been validated with Unicode 6.3 Normalization Conformance Test. See http://www.unicode.org/reports/tr15/ for detailed info about Unicode normalizations.

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ decompose()

static decompose | ( | $s,
 |  | $c
 | ) |
staticprivate

Références Normalizer\$ASCII, $c, $i, $result, et Normalizer\$ulenMask.

◆ getData()

static getData ( $file )
staticprivate

Références __DIR__.

◆ isNormalized()

static isNormalized | ( | string | $s,
 |  | int | $form = self::FORM_C
 | ) |  |
static

Références $form.

◆ normalize()

static normalize | ( | string | $s,
 |  | int | $form = self::FORM_C
 | ) |  |
static

Références Normalizer\$C, $form, $r, Normalizer\NONE, et null.

Référencé par Iconv\mapFromUtf8().

◆ recompose()

static recompose ( $s )
staticprivate

Références Normalizer\$ASCII, $i, $result, Normalizer\$ulenMask, et elseif.

Documentation des champs

◆ $ASCII

$ASCII = "\x20\x65\x69\x61\x73\x6E\x74\x72\x6F\x6C\x75\x64\x5D\x5B\x63\x6D\x70\x27\x0A\x67\x7C\x68\x76\x2E\x66\x62\x2C\x3A\x3D\x2D\x71\x31\x30\x43\x32\x2A\x79\x78\x29\x28\x4C\x39\x41\x53\x2F\x50\x22\x45\x6A\x4D\x49\x6B\x33\x3E\x35\x54\x3C\x44\x34\x7D\x42\x7B\x38\x46\x77\x52\x36\x37\x55\x47\x4E\x3B\x4A\x7A\x56\x23\x48\x4F\x57\x5F\x26\x21\x4B\x3F\x58\x51\x25\x59\x5C\x09\x5A\x2B\x7E\x5E\x24\x40\x60\x7F\x00\x01\x02\x03\x04\x05\x06\x07\x08\x0B\x0C\x0D\x0E\x0F\x10\x11\x12\x13\x14\x15\x16\x17\x18\x19\x1A\x1B\x1C\x1D\x1E\x1F"
staticprivate

Référencé par Normalizer\decompose(), et Normalizer\recompose().

◆ $C

$C
staticprivate

Référencé par Normalizer\normalize().

◆ $cC

$cC
staticprivate

◆ $D

$D
staticprivate

◆ $KD

$KD
staticprivate

◆ $ulenMask

$ulenMask = ["\xC0" => 2
staticprivate

Référencé par Normalizer\decompose(), et Normalizer\recompose().

◆ FORM_C

const FORM_C = \Normalizer::FORM_C

◆ FORM_D

const FORM_D = \Normalizer::FORM_D

◆ FORM_KC

const FORM_KC = \Normalizer::FORM_KC

◆ FORM_KD

const FORM_KD = \Normalizer::FORM_KD

◆ NFC

const NFC = \Normalizer::NFC

◆ NFD

const NFD = \Normalizer::NFD

◆ NFKC

const NFKC = \Normalizer::NFKC

◆ NFKD

const NFKD = \Normalizer::NFKD

◆ xD0

xD0 => 2, "\xE0" => 3, "\xF0" => 4]
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Normalizer.php


Joomla CMS: Référence de la classe Mbstring

  • Symfony
  • Polyfill
  • Mbstring
  • Mbstring
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés | Attributs privés statiques
Référence de la classe Mbstring

Fonctions membres publiques statiques

static | mb_convert_encoding ($s, $toEncoding, $fromEncoding=null)
static | mb_convert_variables ($toEncoding, $fromEncoding, &... $vars)
static | mb_decode_mimeheader ($s)
static | mb_encode_mimeheader ($s, $charset=null, $transferEncoding=null, $linefeed=null, $indent=null)
static | mb_decode_numericentity ($s, $convmap, $encoding=null)
static | mb_encode_numericentity ($s, $convmap, $encoding=null, $is_hex=false)
static | mb_convert_case ($s, $mode, $encoding=null)
static | mb_internal_encoding ($encoding=null)
static | mb_language ($lang=null)
static | mb_list_encodings ()
static | mb_encoding_aliases ($encoding)
static | mb_check_encoding ($var=null, $encoding=null)
static | mb_detect_encoding ($str, $encodingList=null, $strict=false)
static | mb_detect_order ($encodingList=null)
static | mb_strlen ($s, $encoding=null)
static | mb_strpos ($haystack, $needle, $offset=0, $encoding=null)
static | mb_strrpos ($haystack, $needle, $offset=0, $encoding=null)
static | mb_str_split ($string, $split_length=1, $encoding=null)
static | mb_strtolower ($s, $encoding=null)
static | mb_strtoupper ($s, $encoding=null)
static | mb_substitute_character ($c=null)
static | mb_substr ($s, $start, $length=null, $encoding=null)
static | mb_stripos ($haystack, $needle, $offset=0, $encoding=null)
static | mb_stristr ($haystack, $needle, $part=false, $encoding=null)
static | mb_strrchr ($haystack, $needle, $part=false, $encoding=null)
static | mb_strrichr ($haystack, $needle, $part=false, $encoding=null)
static | mb_strripos ($haystack, $needle, $offset=0, $encoding=null)
static | mb_strstr ($haystack, $needle, $part=false, $encoding=null)
static | mb_get_info ($type='all')
static | mb_http_input ($type='')
static | mb_http_output ($encoding=null)
static | mb_strwidth ($s, $encoding=null)
static | mb_substr_count ($haystack, $needle, $encoding=null)
static | mb_output_handler ($contents, $status)
static | mb_chr ($code, $encoding=null)
static | mb_ord ($s, $encoding=null)

Champs de données

const MB_CASE_FOLD = \PHP_INT_MAX

Fonctions membres privées statiques

static | getSubpart ($pos, $part, $haystack, $encoding)
static | html_encoding_callback (array $m)
static | title_case (array $s)
static | getData ($file)
static | getEncoding ($encoding)

Attributs privés

const CASE_FOLD

Attributs privés statiques

static | $encodingList = ['ASCII', 'UTF-8']
static | $language = 'neutral'
static | $internalEncoding = 'UTF-8'

Description détaillée

Partial mbstring implementation in PHP, iconv based, UTF-8 centric.

Implemented:

  • mb_chr - Returns a specific character from its Unicode code point
  • mb_convert_encoding - Convert character encoding
  • mb_convert_variables - Convert character code in variable(s)
  • mb_decode_mimeheader - Decode string in MIME header field
  • mb_encode_mimeheader - Encode string for MIME header XXX NATIVE IMPLEMENTATION IS REALLY BUGGED
  • mb_decode_numericentity - Decode HTML numeric string reference to character
  • mb_encode_numericentity - Encode character to HTML numeric string reference
  • mb_convert_case - Perform case folding on a string
  • mb_detect_encoding - Detect character encoding
  • mb_get_info - Get internal settings of mbstring
  • mb_http_input - Detect HTTP input character encoding
  • mb_http_output - Set/Get HTTP output character encoding
  • mb_internal_encoding - Set/Get internal character encoding
  • mb_list_encodings - Returns an array of all supported encodings
  • mb_ord - Returns the Unicode code point of a character
  • mb_output_handler - Callback function converts character encoding in output buffer
  • mb_scrub - Replaces ill-formed byte sequences with substitute characters
  • mb_strlen - Get string length
  • mb_strpos - Find position of first occurrence of string in a string
  • mb_strrpos - Find position of last occurrence of a string in a string
  • mb_str_split - Convert a string to an array
  • mb_strtolower - Make a string lowercase
  • mb_strtoupper - Make a string uppercase
  • mb_substitute_character - Set/Get substitution character
  • mb_substr - Get part of string
  • mb_stripos - Finds position of first occurrence of a string within another, case insensitive
  • mb_stristr - Finds first occurrence of a string within another, case insensitive
  • mb_strrchr - Finds the last occurrence of a character in a string within another
  • mb_strrichr - Finds the last occurrence of a character in a string within another, case insensitive
  • mb_strripos - Finds position of last occurrence of a string within another, case insensitive
  • mb_strstr - Finds first occurrence of a string within another
  • mb_strwidth - Return width of string
  • mb_substr_count - Count the number of substring occurrences

Not implemented:

  • mb_convert_kana - Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
  • mb_ereg_* - Regular expression with multibyte support
  • mb_parse_str - Parse GET/POST/COOKIE data and set global variable
  • mb_preferred_mime_name - Get MIME charset string
  • mb_regex_encoding - Returns current encoding for multibyte regex as string
  • mb_regex_set_options - Set/Get the default options for mbregex functions
  • mb_send_mail - Send encoded mail
  • mb_split - Split multibyte string using regular expression
  • mb_strcut - Get part of string
  • mb_strimwidth - Get truncated string with specified width
Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ getData()

static getData ( $file )
staticprivate

Références __DIR__.

◆ getEncoding()

static getEncoding ( $encoding )
staticprivate

Références null.

◆ getSubpart()

static getSubpart | ( | $pos,
 |  | $part,
 |  | $haystack,
 |  | $encoding
 | ) |
staticprivate

Références null.

◆ html_encoding_callback()

static html_encoding_callback ( array $m )
staticprivate

Références $c, $i, elseif, et ENT_COMPAT.

◆ mb_check_encoding()

static mb_check_encoding | ( | $var = null,
 |  | $encoding = null
 | ) |
static

Références null.

◆ mb_chr()

static mb_chr | ( | $code,
 |  | $encoding = null
 | ) |
static

Références elseif, et Mbstring\mb_convert_encoding().

◆ mb_convert_case()

static mb_convert_case | ( | $s,
 |  | $mode,
 |  | $encoding = null
 | ) |
static

Références $i, $mode, et null.

◆ mb_convert_encoding()

static mb_convert_encoding | ( | $s,
 |  | $toEncoding,
 |  | $fromEncoding = null
 | ) |
static

Références ENT_COMPAT, et null.

Référencé par Mbstring\mb_chr(), et Mbstring\mb_ord().

◆ mb_convert_variables()

static mb_convert_variables | ( |  | $toEncoding,
 |  |  | $fromEncoding,
 |  | &... | $vars
 | ) |  |
static

◆ mb_decode_mimeheader()

static mb_decode_mimeheader ( $s )
static

◆ mb_decode_numericentity()

static mb_decode_numericentity | ( | $s,
 |  | $convmap,
 |  | $encoding = null
 | ) |
static

Références $c, $i, et null.

◆ mb_detect_encoding()

static mb_detect_encoding | ( | $str,
 |  | $encodingList = null,
 |  | $strict = false
 | ) |
static

Références Mbstring\$encodingList, et null.

◆ mb_detect_order()

static mb_detect_order ( $encodingList = null )
static

Références Mbstring\$encodingList, et null.

◆ mb_encode_mimeheader()

static mb_encode_mimeheader | ( | $s,
 |  | $charset = null,
 |  | $transferEncoding = null,
 |  | $linefeed = null,
 |  | $indent = null
 | ) |
static

◆ mb_encode_numericentity()

static mb_encode_numericentity | ( | $s,
 |  | $convmap,
 |  | $encoding = null,
 |  | $is_hex = false
 | ) |
static

Références $c, $i, $result, et null.

◆ mb_encoding_aliases()

static mb_encoding_aliases ( $encoding )
static

◆ mb_get_info()

static mb_get_info ( $type = 'all' )
static

Références $info, $language, et $type.

◆ mb_http_input()

static mb_http_input ( $type = '' )
static

◆ mb_http_output()

static mb_http_output ( $encoding = null )
static

Références null.

◆ mb_internal_encoding()

static mb_internal_encoding ( $encoding = null )
static

Références null.

Référencé par Mbstring\mb_str_split().

◆ mb_language()

static mb_language ( $lang = null )
static

Références $lang, $language, et null.

◆ mb_list_encodings()

static mb_list_encodings ( )
static

◆ mb_ord()

static mb_ord | ( | $s,
 |  | $encoding = null
 | ) |
static

Références Mbstring\mb_convert_encoding().

◆ mb_output_handler()

static mb_output_handler | ( | $contents,
 |  | $status
 | ) |
static

◆ mb_str_split()

static mb_str_split | ( | $string,
 |  | $split_length = 1,
 |  | $encoding = null
 | ) |
static

Références $i, $result, Mbstring\mb_internal_encoding(), Mbstring\mb_strlen(), Mbstring\mb_substr(), et null.

◆ mb_stripos()

static mb_stripos | ( | $haystack,
 |  | $needle,
 |  | $offset = 0,
 |  | $encoding = null
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ mb_stristr()

static mb_stristr | ( | $haystack,
 |  | $needle,
 |  | $part = false,
 |  | $encoding = null
 | ) |
static

◆ mb_strlen()

static mb_strlen | ( | $s,
 |  | $encoding = null
 | ) |
static

Référencé par Mbstring\mb_str_split().

◆ mb_strpos()

static mb_strpos | ( | $haystack,
 |  | $needle,
 |  | $offset = 0,
 |  | $encoding = null
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ mb_strrchr()

static mb_strrchr | ( | $haystack,
 |  | $needle,
 |  | $part = false,
 |  | $encoding = null
 | ) |
static

◆ mb_strrichr()

static mb_strrichr | ( | $haystack,
 |  | $needle,
 |  | $part = false,
 |  | $encoding = null
 | ) |
static

◆ mb_strripos()

static mb_strripos | ( | $haystack,
 |  | $needle,
 |  | $offset = 0,
 |  | $encoding = null
 | ) |
static

Références Joomla\Database\Query\$offset.

◆ mb_strrpos()

static mb_strrpos | ( | $haystack,
 |  | $needle,
 |  | $offset = 0,
 |  | $encoding = null
 | ) |
static

Références Joomla\Database\Query\$offset, et elseif.

◆ mb_strstr()

static mb_strstr | ( | $haystack,
 |  | $needle,
 |  | $part = false,
 |  | $encoding = null
 | ) |
static

◆ mb_strtolower()

static mb_strtolower | ( | $s,
 |  | $encoding = null
 | ) |
static

◆ mb_strtoupper()

static mb_strtoupper | ( | $s,
 |  | $encoding = null
 | ) |
static

◆ mb_strwidth()

static mb_strwidth | ( | $s,
 |  | $encoding = null
 | ) |
static

◆ mb_substitute_character()

static mb_substitute_character ( $c = null )
static

Références $c, et null.

◆ mb_substr()

static mb_substr | ( | $s,
 |  | $start,
 |  | $length = null,
 |  | $encoding = null
 | ) |
static

Références $start, elseif, et null.

Référencé par Mbstring\mb_str_split().

◆ mb_substr_count()

static mb_substr_count | ( | $haystack,
 |  | $needle,
 |  | $encoding = null
 | ) |
static

◆ title_case()

static title_case ( array $s )
staticprivate

Documentation des champs

◆ $encodingList

$encodingList = ['ASCII', 'UTF-8']
staticprivate

Référencé par Mbstring\mb_detect_encoding(), et Mbstring\mb_detect_order().

◆ $internalEncoding

$internalEncoding = 'UTF-8'
staticprivate

◆ $language

$language = 'neutral'
staticprivate

◆ CASE_FOLD

const CASE_FOLD
private
Valeur initiale :
= [
['µ', 'ſ', "\xCD\x85", 'ς', "\xCF\x90", "\xCF\x91", "\xCF\x95", "\xCF\x96", "\xCF\xB0", "\xCF\xB1", "\xCF\xB5", "\xE1\xBA\x9B", "\xE1\xBE\xBE"],
['μ', 's', 'ι', 'σ', 'β', 'θ', 'φ', 'π', 'κ', 'ρ', 'ε', "\xE1\xB9\xA1", 'ι'],
]

◆ MB_CASE_FOLD

const MB_CASE_FOLD = \PHP_INT_MAX
La documentation de cette classe a été générée à partir du fichier suivant :
  • Mbstring.php


Joomla CMS: Référence de la classe Php72

  • Symfony
  • Polyfill
  • Php72
  • Php72
Fonctions membres publiques statiques | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe Php72

Fonctions membres publiques statiques

static | utf8_encode ($s)
static | utf8_decode ($s)
static | php_os_family ()
static | spl_object_id ($object)
static | sapi_windows_vt100_support ($stream, $enable=null)
static | stream_isatty ($stream)
static | mb_chr ($code, $encoding=null)
static | mb_ord ($s, $encoding=null)

Fonctions membres privées statiques

static initHashMask ()

Attributs privés statiques

static $hashMask

Description détaillée

Auteur
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com
Dariusz Rumiński dariu.nosp@m.sz.r.nosp@m.umins.nosp@m.ki@g.nosp@m.mail..nosp@m.com

Documentation des fonctions membres

◆ initHashMask()

static initHashMask ( )
staticprivate

◆ mb_chr()

static mb_chr | ( | $code,
 |  | $encoding = null
 | ) |
static

Références elseif.

◆ mb_ord()

static mb_ord | ( | $s,
 |  | $encoding = null
 | ) |
static

Références elseif, et null.

◆ php_os_family()

static php_os_family ( )
static

◆ sapi_windows_vt100_support()

static sapi_windows_vt100_support | ( | $stream,
 |  | $enable = null
 | ) |
static

Références Laminas\Diactoros\$stream.

◆ spl_object_id()

static spl_object_id ( $object )
static

Références $hash, et null.

◆ stream_isatty()

static stream_isatty ( $stream )
static

Références Laminas\Diactoros\$stream.

◆ utf8_decode()

static utf8_decode ( $s )
static

Références $c, et $i.

◆ utf8_encode()

static utf8_encode ( $s )
static

Références $i.

Documentation des champs

◆ $hashMask

$hashMask
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • Php72.php


Joomla CMS: Référence de la classe Php73

  • Symfony
  • Polyfill
  • Php73
  • Php73
Fonctions membres publiques statiques | Attributs publics statiques
Référence de la classe Php73

Fonctions membres publiques statiques

static hrtime ($asNum=false)

Attributs publics statiques

static $startAt = 1533462603

Description détaillée

Auteur
Gabriel Caruso carus.nosp@m.ogab.nosp@m.riel3.nosp@m.4@gm.nosp@m.ail.c.nosp@m.om
Ion Bazan ion.b.nosp@m.azan.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des fonctions membres

◆ hrtime()

static hrtime ( $asNum = false )
static
Paramètres
bool $asNum
Renvoie
array|float|int

Documentation des champs

◆ $startAt

$startAt = 1533462603
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Php73.php


Joomla CMS: Référence de la classe Php80

  • Symfony
  • Polyfill
  • Php80
  • Php80
Fonctions membres publiques statiques
Référence de la classe Php80

Fonctions membres publiques statiques

static | fdiv (float $dividend, float $divisor)
static | get_debug_type ($value)
static | get_resource_id ($res)
static | preg_last_error_msg ()
static | str_contains (string $haystack, string $needle)
static | str_starts_with (string $haystack, string $needle)
static | str_ends_with (string $haystack, string $needle)

Description détaillée

Auteur
Ion Bazan ion.b.nosp@m.azan.nosp@m.@gmai.nosp@m.l.co.nosp@m.m
Nico Oelgart nicos.nosp@m.wd@g.nosp@m.mail..nosp@m.com
Nicolas Grekas p@tch.nosp@m.work.nosp@m..com

Documentation des fonctions membres

◆ fdiv()

static fdiv | ( | float | $dividend,
 |  | float | $divisor
 | ) |  |
static

◆ get_debug_type()

static get_debug_type ( $value )
static

Références $class, $type, $value, et null.

Référencé par Php80\get_resource_id().

◆ get_resource_id()

static get_resource_id ( $res )
static

Références Php80\get_debug_type(), et null.

◆ preg_last_error_msg()

static preg_last_error_msg ( )
static

◆ str_contains()

static str_contains | ( | string | $haystack,
 |  | string | $needle
 | ) |  |
static

◆ str_ends_with()

static str_ends_with | ( | string | $haystack,
 |  | string | $needle
 | ) |  |
static

◆ str_starts_with()

static str_starts_with | ( | string | $haystack,
 |  | string | $needle
 | ) |  |
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • Php80.php


Joomla CMS: Référence de la classe PhpToken

  • Symfony
  • Polyfill
  • Php80
  • PhpToken
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe PhpToken
+ Graphe d'héritage de PhpToken:

Fonctions membres publiques

__construct (int $id, string $text, int $line=-1, int $position=-1)
getTokenName ()
is ($kind)
isIgnorable ()
__toString ()

Fonctions membres publiques statiques

static tokenize (string $code, int $flags=0)

Champs de données

$id
$text
$line
$pos

Description détaillée

Auteur
Fedonyuk Anton info@.nosp@m.enso.nosp@m.studi.nosp@m.o.ru

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | int | $id,
 |  | string | $text,
 |  | int | $line = -1,
 |  | int | $position = -1
 | ) |  |

Références PhpToken\$id, PhpToken\$line, $position, PhpToken\$text, et text.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références PhpToken\$text.

◆ getTokenName()

getTokenName ( )

Références $name, PhpToken\$text, null, et text.

◆ is()

is ( $kind )
Paramètres
int | string | array $kind

Références $value, et text.

◆ isIgnorable()

isIgnorable ( )

◆ tokenize()

static tokenize | ( | string | $code,
 |  | int | $flags = 0
 | ) |  |
static
Renvoie
static[]

Références PhpToken\$id, PhpToken\$line, $position, et PhpToken\$text.

Documentation des champs

◆ $id

$id

Référencé par PhpToken\__construct(), et PhpToken\tokenize().

◆ $line

$line

Référencé par PhpToken\__construct(), et PhpToken\tokenize().

◆ $pos

$pos

◆ $text

$text

Référencé par PhpToken\__construct(), PhpToken\__toString(), PhpToken\getTokenName(), et PhpToken\tokenize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PhpToken.php


Joomla CMS: Référence de l'interface ExceptionHandlerInterface

  • Tobscure
  • JsonApi
  • Exception
  • Handler
  • ExceptionHandlerInterface
Fonctions membres publiques
Référence de l'interface ExceptionHandlerInterface
+ Graphe d'héritage de ExceptionHandlerInterface:
AuthenticationFailedExceptionHandler CheckinCheckoutExceptionHandler InvalidRouteExceptionHandler NotAcceptableExceptionHandler NotAllowedExceptionHandler ResourceNotFoundExceptionHandler SaveExceptionHandler SendEmailExceptionHandler FallbackExceptionHandler InvalidParameterExceptionHandler

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the provided exception.

Paramètres
\Exception $e
Renvoie

Implémenté dans AuthenticationFailedExceptionHandler, CheckinCheckoutExceptionHandler, InvalidRouteExceptionHandler, NotAcceptableExceptionHandler, NotAllowedExceptionHandler, ResourceNotFoundExceptionHandler, SaveExceptionHandler, SendEmailExceptionHandler, FallbackExceptionHandler, InvalidParameterExceptionHandler, et InvalidParameterExceptionHandler.

◆ manages()

manages ( Exception $e )

If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e
Renvoie
bool

Implémenté dans AuthenticationFailedExceptionHandler, CheckinCheckoutExceptionHandler, InvalidRouteExceptionHandler, NotAcceptableExceptionHandler, NotAllowedExceptionHandler, ResourceNotFoundExceptionHandler, SaveExceptionHandler, SendEmailExceptionHandler, FallbackExceptionHandler, et InvalidParameterExceptionHandler.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ExceptionHandlerInterface.php


Joomla CMS: Référence de la classe FallbackExceptionHandler

  • Tobscure
  • JsonApi
  • Exception
  • Handler
  • FallbackExceptionHandler
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FallbackExceptionHandler
+ Graphe d'héritage de FallbackExceptionHandler:
ExceptionHandlerInterface

Fonctions membres publiques

__construct ($debug)
manages (Exception $e)
handle (Exception $e)

Fonctions membres privées

constructError (Exception $e, $status)

Attributs privés

$debug

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $debug )
Paramètres
bool $debug

Références FallbackExceptionHandler\$debug.

Documentation des fonctions membres

◆ constructError()

constructError | ( | Exception | $e,
 |  |  | $status
 | ) |  |
private
Paramètres
\Exception $e
$status
Renvoie
array

Référencé par FallbackExceptionHandler\handle().

◆ handle()

handle ( Exception $e )

{Handle the provided exception.

Paramètres
\Exception $e
Renvoie
}

Implémente ExceptionHandlerInterface.

Références FallbackExceptionHandler\constructError().

◆ manages()

manages ( Exception $e )

{If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e
Renvoie
bool
}

Implémente ExceptionHandlerInterface.

Documentation des champs

◆ $debug

$debug
private

Référencé par FallbackExceptionHandler\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • FallbackExceptionHandler.php


Joomla CMS: Référence de la classe InvalidParameterExceptionHandler

  • Tobscure
  • JsonApi
  • Exception
  • Handler
  • InvalidParameterExceptionHandler
Fonctions membres publiques
Référence de la classe InvalidParameterExceptionHandler
+ Graphe d'héritage de InvalidParameterExceptionHandler:
ExceptionHandlerInterface InvalidParameterExceptionHandler

Fonctions membres publiques

manages (Exception $e)
handle (Exception $e)

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

{Handle the provided exception.

Paramètres
\Exception $e
Renvoie
}

Implémente ExceptionHandlerInterface.

◆ manages()

manages ( Exception $e )

{If the exception handler is able to format a response for the provided exception, then the implementation should return true.

Paramètres
\Exception $e
Renvoie
bool
}

Implémente ExceptionHandlerInterface.

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/tobscure/json-api/src/Exception/Handler/InvalidParameterExceptionHandler.php


Joomla CMS: Référence de la classe ResponseBag

  • Tobscure
  • JsonApi
  • Exception
  • Handler
  • ResponseBag
Fonctions membres publiques | Attributs privés
Référence de la classe ResponseBag

Fonctions membres publiques

__construct ($status, array $errors)
getErrors ()
getStatus ()

Attributs privés

$status
$errors

Description détaillée

DTO to manage JSON error response handling.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $status,
 |  | array | $errors
 | ) |  |
Paramètres
int | $status
array | $errors

Références ResponseBag\$errors, et ResponseBag\$status.

Documentation des fonctions membres

◆ getErrors()

getErrors ( )
Renvoie
array

Références ResponseBag\$errors.

◆ getStatus()

getStatus ( )
Renvoie
int

Références ResponseBag\$status.

Documentation des champs

◆ $errors

$errors
private

Référencé par ResponseBag\__construct(), et ResponseBag\getErrors().

◆ $status

$status
private

Référencé par ResponseBag\__construct(), et ResponseBag\getStatus().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ResponseBag.php


Joomla CMS: Référence de la classe InvalidParameterException

  • Tobscure
  • JsonApi
  • Exception
  • InvalidParameterException
Fonctions membres publiques | Attributs privés
Référence de la classe InvalidParameterException
+ Graphe d'héritage de InvalidParameterException:

Fonctions membres publiques

__construct ($message='', $code=0, $previous=null, $invalidParameter='')
getInvalidParameter ()

Attributs privés

$invalidParameter

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $message = '',
 |  | $code = 0,
 |  | $previous = null,
 |  | $invalidParameter = ''
 | ) |

{}

Paramètres
string $invalidParameter The parameter that caused this exception.

Références InvalidParameterException\$invalidParameter, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getInvalidParameter()

getInvalidParameter ( )
Renvoie
string The parameter that caused this exception.

Références InvalidParameterException\$invalidParameter.

Documentation des champs

◆ $invalidParameter

$invalidParameter
private

Référencé par InvalidParameterException\__construct(), et InvalidParameterException\getInvalidParameter().

La documentation de cette classe a été générée à partir du fichier suivant :
  • InvalidParameterException.php


Joomla CMS: Référence de la classe AbstractSerializer

  • Tobscure
  • JsonApi
  • AbstractSerializer
Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe AbstractSerializer
+ Graphe d'héritage de AbstractSerializer:
SerializerInterface JoomlaSerializer ContactSerializer ContentSerializer NewsfeedSerializer

Fonctions membres publiques

getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Attributs protégés

$type

Fonctions membres privées

getRelationshipMethodName ($name)

Documentation des fonctions membres

◆ getAttributes()

getAttributes | ( |  | $model,
 |  | array | $fields = null
 | ) |  |

{Get the attributes array.

Paramètres
mixed | $model
array | null | $fields
Renvoie
array
}

Implémente SerializerInterface.

◆ getId()

getId ( $model )

{Get the id.

Paramètres
mixed $model
Renvoie
string
}

Implémente SerializerInterface.

Références $model.

◆ getLinks()

getLinks ( $model )

{Get the links array.

Paramètres
mixed $model
Renvoie
array
}

Implémente SerializerInterface.

◆ getMeta()

getMeta ( $model )

{Get the meta.

Paramètres
mixed $model
Renvoie
array
}

Implémente SerializerInterface.

◆ getRelationship()

getRelationship | ( | $model,
 |  | $name
 | ) |

{Get a relationship.

Paramètres
mixed | $model
string | $name
Renvoie
|null
}

Exceptions

Implémente SerializerInterface.

Références $method, $model, $name, $this, AbstractSerializer\getRelationshipMethodName(), et null.

◆ getRelationshipMethodName()

getRelationshipMethodName ( $name )
private

Get the serializer method name for the given relationship.

snake_case and kebab-case are converted into camelCase.

Paramètres
string $name
Renvoie
string

Références $name.

Référencé par AbstractSerializer\getRelationship().

◆ getType()

getType ( $model )

{Get the type.

Paramètres
mixed $model
Renvoie
string
}

Implémente SerializerInterface.

Références AbstractSerializer\$type.

Documentation des champs

◆ $type

$type
protected

Référencé par AbstractSerializer\getType().

La documentation de cette classe a été générée à partir du fichier suivant :
  • tobscure/json-api/src/AbstractSerializer.php


Joomla CMS: Référence de la classe Collection

  • Tobscure
  • JsonApi
  • Collection
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Collection
+ Graphe d'héritage de Collection:
ElementInterface

Fonctions membres publiques

__construct ($data, SerializerInterface $serializer)
getResources ()
setResources ($resources)
with ($relationships)
fields ($fields)
toArray ()
toIdentifier ()

Fonctions membres protégées

buildResources ($data, SerializerInterface $serializer)

Attributs protégés

$resources = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $data,
 |  | SerializerInterface | $serializer
 | ) |  |

Create a new collection instance.

Paramètres
mixed | $data
\Tobscure\JsonApi\SerializerInterface | $serializer

Références $data, et Collection\buildResources().

Documentation des fonctions membres

◆ buildResources()

buildResources | ( |  | $data,
 |  | SerializerInterface | $serializer
 | ) |  |
protected

Convert an array of raw data to Resource objects.

Paramètres
mixed | $data
SerializerInterface | $serializer
Renvoie
[]

Références $data, et Collection\$resources.

Référencé par Collection\__construct().

◆ fields()

fields ( $fields )

Request a restricted set of fields.

Paramètres
array | null $fields
Renvoie
$this

Implémente ElementInterface.

Références $fields, et $this.

◆ getResources()

getResources ( )

{Get the resources array.

Renvoie
array
}

Implémente ElementInterface.

Références Collection\$resources.

◆ setResources()

setResources ( $resources )

Set the resources array.

Paramètres
array $resources
Renvoie
void

Références Collection\$resources.

◆ toArray()

toArray ( )

{Map to a "resource object" array.

Renvoie
array
}

Implémente ElementInterface.

Références Collection\$resources, et Resource\toArray().

◆ toIdentifier()

toIdentifier ( )

{Map to a "resource object identifier" array.

Renvoie
array
}

Implémente ElementInterface.

Références Collection\$resources, et Resource\toIdentifier().

◆ with()

with ( $relationships )

Request a relationship to be included for all resources.

Paramètres
string | array $relationships
Renvoie
$this

Implémente ElementInterface.

Références $this.

Documentation des champs

◆ $resources

$resources = []
protected

Référencé par Collection\buildResources(), Collection\getResources(), Collection\setResources(), Collection\toArray(), et Collection\toIdentifier().

La documentation de cette classe a été générée à partir du fichier suivant :
  • tobscure/json-api/src/Collection.php


Joomla CMS: Référence de la classe Document

  • Tobscure
  • JsonApi
  • Document
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés
Référence de la classe Document
+ Graphe d'héritage de Document:

Fonctions membres publiques

__construct (ElementInterface $data=null)
setData (ElementInterface $element)
setErrors ($errors)
setJsonapi ($jsonapi)
toArray ()
__toString ()
jsonSerialize ()

Champs de données

const MEDIA_TYPE = 'application/vnd.api+json'

Fonctions membres protégées

getIncluded (ElementInterface $element, $includeParent=false)
mergeResource (array $resources, Resource $newResource)

Attributs protégés

$included = []
$errors
$jsonapi
$data

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ElementInterface $data = null )
Paramètres
ElementInterface $data

Références Document\$data.

Documentation des fonctions membres

◆ __toString()

__toString ( )

Map to string.

Renvoie
string

Références Document\toArray().

◆ getIncluded()

getIncluded | ( | ElementInterface | $element,
 |  |  | $includeParent = false
 | ) |  |
protected

Get included resources.

Paramètres
\Tobscure\JsonApi\ElementInterface | $element
bool | $includeParent
Renvoie
[]

Références $id, Document\$included, $type, ElementInterface\getResources(), et Document\mergeResource().

Référencé par Document\toArray().

◆ jsonSerialize()

jsonSerialize ( )

Serialize for JSON usage.

Renvoie
array

Références Document\toArray().

◆ mergeResource()

mergeResource | ( | array | $resources,
 |  | Resource | $newResource
 | ) |  |
protected
Paramètres

Références $id, $type, Resource\getId(), et Resource\getType().

Référencé par Document\getIncluded().

◆ setData()

setData ( ElementInterface $element )

Set the data object.

Paramètres
\Tobscure\JsonApi\ElementInterface $element
Renvoie
$this

Références $this.

◆ setErrors()

setErrors ( $errors )

Set the errors array.

Paramètres
array $errors
Renvoie
$this

Références Document\$errors, et $this.

◆ setJsonapi()

setJsonapi ( $jsonapi )

Set the jsonapi array.

Paramètres
array $jsonapi
Renvoie
$this

Références Document\$jsonapi, et $this.

◆ toArray()

toArray ( )

Map everything to arrays.

Renvoie
array

Références $document, Document\$errors, Document\$jsonapi, Document\getIncluded(), et Resource\toArray().

Référencé par Document\__toString(), et Document\jsonSerialize().

Documentation des champs

◆ $data

$data
protected

Référencé par Document\__construct().

◆ $errors

$errors
protected

Référencé par Document\setErrors(), et Document\toArray().

◆ $included

$included = []
protected

Référencé par Document\getIncluded().

◆ $jsonapi

$jsonapi
protected

Référencé par Document\setJsonapi(), et Document\toArray().

◆ MEDIA_TYPE

const MEDIA_TYPE = 'application/vnd.api+json'
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/tobscure/json-api/src/Document.php


Joomla CMS: Référence de l'interface ElementInterface

  • Tobscure
  • JsonApi
  • ElementInterface
Fonctions membres publiques
Référence de l'interface ElementInterface
+ Graphe d'héritage de ElementInterface:
Collection Resource

Fonctions membres publiques

getResources ()
toArray ()
toIdentifier ()
with ($relationships)
fields ($fields)

Documentation des fonctions membres

◆ fields()

fields ( $fields )

Request a restricted set of fields.

Paramètres
array | null $fields
Renvoie
$this

Implémenté dans Resource, et Collection.

◆ getResources()

getResources ( )

Get the resources array.

Renvoie
array

Implémenté dans Resource, et Collection.

Référencé par Document\getIncluded().

◆ toArray()

toArray ( )

Map to a "resource object" array.

Renvoie
array

Implémenté dans Collection, et Resource.

◆ toIdentifier()

toIdentifier ( )

Map to a "resource object identifier" array.

Renvoie
array

Implémenté dans Resource, et Collection.

◆ with()

with ( $relationships )

Request a relationship to be included.

Paramètres
string | array $relationships
Renvoie
$this

Implémenté dans Resource, et Collection.

La documentation de cette interface a été générée à partir du fichier suivant :
  • ElementInterface.php


Joomla CMS: Référence de la classe ErrorHandler

  • Tobscure
  • JsonApi
  • ErrorHandler
Fonctions membres publiques | Attributs privés
Référence de la classe ErrorHandler

Fonctions membres publiques

handle (Exception $e)
registerHandler (ExceptionHandlerInterface $handler)

Attributs privés

$handlers = []

Documentation des fonctions membres

◆ handle()

handle ( Exception $e )

Handle the exception provided.

Paramètres
Exception $e
Exceptions
RuntimeException
Renvoie

◆ registerHandler()

registerHandler ( ExceptionHandlerInterface $handler )

Register a new exception handler.

Paramètres
\Tobscure\JsonApi\Exception\Handler\ExceptionHandlerInterface $handler
Renvoie
void

Documentation des champs

◆ $handlers

$handlers = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • tobscure/json-api/src/ErrorHandler.php


Joomla CMS: Référence de la classe Parameters

  • Tobscure
  • JsonApi
  • Parameters
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe Parameters

Fonctions membres publiques

__construct (array $input)
getInclude (array $available=[])
getOffset ($perPage=null)
getLimit ($max=null)
getSort (array $available=[])
getFields ()
getFilter ()

Fonctions membres protégées

getOffsetFromNumber ($perPage)
getInput ($key, $default=null)
getPage ($key)

Attributs protégés

$input

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $input )
Paramètres
array $input

Références Parameters\$input.

Documentation des fonctions membres

◆ getFields()

getFields ( )

Get the fields requested for inclusion.

Renvoie
array

Références $fields, et Parameters\getInput().

◆ getFilter()

getFilter ( )

Get a filter item.

Renvoie
mixed

Références Parameters\getInput().

◆ getInclude()

getInclude ( array $available = [] )

Get the includes.

Paramètres
array $available
Exceptions

Références Parameters\getInput(), et null.

◆ getInput()

getInput | ( | $key,
 |  | $default = null
 | ) |
protected

Get an input item.

Paramètres
string | $key
null | $default
Renvoie
mixed

Références $default, et $key.

Référencé par Parameters\getFields(), Parameters\getFilter(), Parameters\getInclude(), Parameters\getPage(), et Parameters\getSort().

◆ getLimit()

getLimit ( $max = null )

Get the limit.

Paramètres
int | null $max
Renvoie
int|null

Références $limit, Parameters\getPage(), et null.

◆ getOffset()

getOffset ( $perPage = null )

Get number of offset.

Paramètres
int | null $perPage
Exceptions

Références Joomla\Database\Query\$offset, Parameters\getOffsetFromNumber(), Parameters\getPage(), et null.

◆ getOffsetFromNumber()

getOffsetFromNumber ( $perPage )
protected

Calculate the offset based on the page[number] parameter.

Paramètres
int $perPage
Exceptions

Références Parameters\getPage().

Référencé par Parameters\getOffset().

◆ getPage()

getPage ( $key )
protected

Get the page.

Paramètres
string $key
Renvoie
string

Références $key, et Parameters\getInput().

Référencé par Parameters\getLimit(), Parameters\getOffset(), et Parameters\getOffsetFromNumber().

◆ getSort()

getSort ( array $available = [] )

Get the sort.

Paramètres
array $available
Exceptions

Références $field, $fields, Parameters\$input, $sort, Parameters\getInput(), et null.

Documentation des champs

◆ $input

$input
protected

Référencé par Parameters\__construct(), et Parameters\getSort().

La documentation de cette classe a été générée à partir du fichier suivant :
  • tobscure/json-api/src/Parameters.php


Joomla CMS: Référence de la classe Relationship

  • Tobscure
  • JsonApi
  • Relationship
Fonctions membres publiques | Attributs protégés
Référence de la classe Relationship

Fonctions membres publiques

__construct (ElementInterface $data=null)
getData ()
setData ($data)
toArray ()

Attributs protégés

$data

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ElementInterface $data = null )

Create a new relationship.

Paramètres
\Tobscure\JsonApi\ElementInterface | null $data

Références Relationship\$data.

Documentation des fonctions membres

◆ getData()

getData ( )

Get the data object.

Renvoie
|null

Références Relationship\$data.

◆ setData()

setData ( $data )

Set the data object.

Paramètres
\Tobscure\JsonApi\ElementInterface | null $data
Renvoie
$this

Références Relationship\$data, et $this.

◆ toArray()

toArray ( )

Map everything to an array.

Renvoie
array

Référencé par Resource\convertRelationshipsToArray().

Documentation des champs

◆ $data

$data
protected

Référencé par Relationship\__construct(), Relationship\getData(), et Relationship\setData().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Relationship.php


Joomla CMS: Référence de la classe Resource

  • Tobscure
  • JsonApi
  • Resource
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe Resource
+ Graphe d'héritage de Resource:
ElementInterface

Fonctions membres publiques

__construct ($data, SerializerInterface $serializer)
getResources ()
toArray ()
isIdentifier ()
toIdentifier ()
getType ()
getId ()
getAttributes ()
getRelationships ()
getUnfilteredRelationships ()
getRelationshipsAsArray ()
merge (Resource $resource)
with ($relationships)
fields ($fields)
getData ()
setData ($data)
getSerializer ()
setSerializer (SerializerInterface $serializer)

Fonctions membres protégées

getOwnFields ()
filterFields (array $fields)
mergeAttributes (array $attributes)
buildRelationships ()
mergeRelationships (array $relationships)
convertRelationshipsToArray (array $relationships)

Attributs protégés

$data
$serializer
$includes = []
$fields
$merged = []

Attributs privés

$relationships

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( |  | $data,
 |  | SerializerInterface | $serializer
 | ) |  |
Paramètres
mixed | $data
\Tobscure\JsonApi\SerializerInterface | $serializer

Références Resource\$data, et Resource\$serializer.

Documentation des fonctions membres

◆ buildRelationships()

buildRelationships ( )
protected

Get an array of built relationships.

Renvoie
[]

Références $name, Resource\$relationships, Resource\fields(), et Util\parseRelationshipPaths().

Référencé par Resource\getRelationships(), et Resource\getUnfilteredRelationships().

◆ convertRelationshipsToArray()

convertRelationshipsToArray ( array $relationships )
protected

Convert the given array of Relationship objects into an array.

Paramètres

Références Resource\$relationships, et Relationship\toArray().

Référencé par Resource\getRelationshipsAsArray().

◆ fields()

fields ( $fields )

{Request a restricted set of fields.

Paramètres
array | null $fields
Renvoie
$this
}

Implémente ElementInterface.

Références Resource\$fields, et $this.

Référencé par Resource\buildRelationships(), et Resource\getOwnFields().

◆ filterFields()

filterFields ( array $fields )
protected

Filter the given fields array (attributes or relationships) according to the requested fieldset.

Paramètres
array $fields
Renvoie
array

Références Resource\$fields, et Resource\getOwnFields().

Référencé par Resource\getAttributes(), et Resource\getRelationships().

◆ getAttributes()

getAttributes ( )

Get the resource attributes.

Renvoie
array

Références $attributes, $this, Resource\filterFields(), et Resource\mergeAttributes().

Référencé par Resource\toArray().

◆ getData()

getData ( )
Renvoie
mixed

Références Resource\$data.

◆ getId()

getId ( )

Get the resource ID.

Renvoie
string

Références Resource\$data.

Référencé par Document\mergeResource(), et Resource\toIdentifier().

◆ getOwnFields()

getOwnFields ( )
protected

Get the requested fields for this resource type.

Renvoie
array|null

Références $type, Resource\fields(), et Resource\getType().

Référencé par Resource\filterFields().

◆ getRelationships()

getRelationships ( )

Get the resource relationships.

Renvoie
[]

Références Resource\$relationships, Resource\buildRelationships(), et Resource\filterFields().

Référencé par Resource\getRelationshipsAsArray().

◆ getRelationshipsAsArray()

getRelationshipsAsArray ( )

Get the resource relationships as an array.

Renvoie
array

Références Resource\$relationships, Resource\convertRelationshipsToArray(), Resource\getRelationships(), et Resource\mergeRelationships().

Référencé par Resource\toArray().

◆ getResources()

getResources ( )

{Get the resources array.

Renvoie
array
}

Implémente ElementInterface.

Références $this.

◆ getSerializer()

getSerializer ( )
Renvoie

Références Resource\$serializer.

◆ getType()

getType ( )

Get the resource type.

Renvoie
string

Référencé par Resource\getOwnFields(), Document\mergeResource(), et Resource\toIdentifier().

◆ getUnfilteredRelationships()

getUnfilteredRelationships ( )

Get the resource relationships without considering requested ones.

Renvoie
[]

Références Resource\buildRelationships().

◆ isIdentifier()

isIdentifier ( )

Check whether or not this resource is an identifier (i.e. does it have any data attached?).

Renvoie
bool

Référencé par Resource\toArray().

◆ merge()

merge ( Resource $resource )

Merge a resource into this one.

Paramètres
\Tobscure\JsonApi\Resource $resource
Renvoie
void

◆ mergeAttributes()

mergeAttributes ( array $attributes )
protected

Merge the attributes of merged resources into an array of attributes.

Paramètres
array $attributes
Renvoie
array

Références $attributes.

Référencé par Resource\getAttributes().

◆ mergeRelationships()

mergeRelationships ( array $relationships )
protected

Merge the relationships of merged resources into an array of relationships.

Paramètres
array $relationships
Renvoie
array

Références Resource\$relationships.

Référencé par Resource\getRelationshipsAsArray().

◆ setData()

setData ( $data )
Paramètres
mixed $data
Renvoie
void

Références Resource\$data.

◆ setSerializer()

setSerializer ( SerializerInterface $serializer )
Paramètres
\Tobscure\JsonApi\SerializerInterface $serializer
Renvoie
void

Références Resource\$serializer.

◆ toArray()

toArray ( )

{Map to a "resource object" array.

Renvoie
array
}

Implémente ElementInterface.

Références $attributes, Resource\$relationships, Resource\getAttributes(), Resource\getRelationshipsAsArray(), Resource\isIdentifier(), et Resource\toIdentifier().

Référencé par Collection\toArray(), et Document\toArray().

◆ toIdentifier()

toIdentifier ( )

{Map to a "resource object identifier" array.

Renvoie
array
}

Implémente ElementInterface.

Références Resource\getId(), et Resource\getType().

Référencé par Resource\toArray(), et Collection\toIdentifier().

◆ with()

with ( $relationships )

{Request a relationship to be included.

Paramètres
string | array $relationships
Renvoie
$this
}

Implémente ElementInterface.

Références Resource\$relationships, $this, et null.

Documentation des champs

◆ $data

$data
protected

Référencé par Resource\__construct(), Resource\getData(), Resource\getId(), et Resource\setData().

◆ $fields

$fields
protected

Référencé par Resource\fields(), et Resource\filterFields().

◆ $includes

$includes = []
protected

◆ $merged

$merged = []
protected

◆ $relationships

$relationships
private

Référencé par Resource\buildRelationships(), Resource\convertRelationshipsToArray(), Resource\getRelationships(), Resource\getRelationshipsAsArray(), Resource\mergeRelationships(), Resource\toArray(), et Resource\with().

◆ $serializer

$serializer
protected

Référencé par Resource\__construct(), Resource\getSerializer(), et Resource\setSerializer().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Resource.php


Joomla CMS: Référence de l'interface SerializerInterface

  • Tobscure
  • JsonApi
  • SerializerInterface
Fonctions membres publiques
Référence de l'interface SerializerInterface
+ Graphe d'héritage de SerializerInterface:
AbstractSerializer JoomlaSerializer ContactSerializer ContentSerializer NewsfeedSerializer

Fonctions membres publiques

getType ($model)
getId ($model)
getAttributes ($model, array $fields=null)
getLinks ($model)
getMeta ($model)
getRelationship ($model, $name)

Documentation des fonctions membres

◆ getAttributes()

getAttributes | ( |  | $model,
 |  | array | $fields = null
 | ) |  |

Get the attributes array.

Paramètres
mixed | $model
array | null | $fields
Renvoie
array

Implémenté dans AbstractSerializer.

◆ getId()

getId ( $model )

Get the id.

Paramètres
mixed $model
Renvoie
string

Implémenté dans AbstractSerializer.

◆ getLinks()

getLinks ( $model )

Get the links array.

Paramètres
mixed $model
Renvoie
array

Implémenté dans AbstractSerializer.

◆ getMeta()

getMeta ( $model )

Get the meta.

Paramètres
mixed $model
Renvoie
array

Implémenté dans AbstractSerializer.

◆ getRelationship()

getRelationship | ( | $model,
 |  | $name
 | ) |

Get a relationship.

Paramètres
mixed | $model
string | $name
Renvoie
|null

Implémenté dans AbstractSerializer.

◆ getType()

getType ( $model )

Get the type.

Paramètres
mixed $model
Renvoie
string

Implémenté dans AbstractSerializer.

La documentation de cette interface a été générée à partir du fichier suivant :
  • SerializerInterface.php


Joomla CMS: Référence de la classe Util

  • Tobscure
  • JsonApi
  • Util
Fonctions membres publiques statiques
Référence de la classe Util

Fonctions membres publiques statiques

static parseRelationshipPaths (array $paths)

Documentation des fonctions membres

◆ parseRelationshipPaths()

static parseRelationshipPaths ( array $paths )
static

Parse relationship paths.

Given a flat array of relationship paths like:

['user', 'user.employer', 'user.employer.country', 'comments']

create a nested array of relationship paths one-level deep that can be passed on to other serializers:

['user' => ['employer', 'employer.country'], 'comments' => []]

Paramètres
array $paths
Renvoie
array

Références $path, et null.

Référencé par Resource\buildRelationships().

La documentation de cette classe a été générée à partir du fichier suivant :
  • tobscure/json-api/src/Util.php


Joomla CMS: Référence de la classe ConjunctionInterceptor

  • TYPO3
  • PharStreamWrapper
  • Interceptor
  • ConjunctionInterceptor
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe ConjunctionInterceptor
+ Graphe d'héritage de ConjunctionInterceptor:
Assertable

Fonctions membres publiques

__construct (array $assertions)
assert (string $path, string $command)

Fonctions membres privées

assertAssertions (array $assertions)
invokeAssertions (string $path, string $command)

Attributs privés

$assertions

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $assertions )

Références ConjunctionInterceptor\$assertions, et ConjunctionInterceptor\assertAssertions().

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |

Executes assertions based on all contained assertions.

Paramètres
string | $path
string | $command
Renvoie
bool
Exceptions
Exception

Implémente Assertable.

Références $path, et ConjunctionInterceptor\invokeAssertions().

◆ assertAssertions()

assertAssertions ( array $assertions )
private
Paramètres
Assertable[] $assertions

Références ConjunctionInterceptor\$assertions.

Référencé par ConjunctionInterceptor\__construct().

◆ invokeAssertions()

invokeAssertions | ( | string | $path,
 |  | string | $command
 | ) |  |
private
Paramètres
string | $path
string | $command
Renvoie
bool

Références $path.

Référencé par ConjunctionInterceptor\assert().

Documentation des champs

◆ $assertions

$assertions
private

Référencé par ConjunctionInterceptor\__construct(), et ConjunctionInterceptor\assertAssertions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ConjunctionInterceptor.php


Joomla CMS: Référence de la classe PharExtensionInterceptor

  • TYPO3
  • PharStreamWrapper
  • Interceptor
  • PharExtensionInterceptor
Fonctions membres publiques | Fonctions membres privées
Référence de la classe PharExtensionInterceptor
+ Graphe d'héritage de PharExtensionInterceptor:
Assertable

Fonctions membres publiques

assert (string $path, string $command)

Fonctions membres privées

baseFileContainsPharExtension (string $path)

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |

Determines whether the base file name has a ".phar" suffix.

Paramètres
string | $path
string | $command
Renvoie
bool
Exceptions
Exception

Implémente Assertable.

Références $path, et PharExtensionInterceptor\baseFileContainsPharExtension().

◆ baseFileContainsPharExtension()

baseFileContainsPharExtension ( string $path )
private
Paramètres
string $path
Renvoie
bool

Références $path, Manager\instance(), et null.

Référencé par PharExtensionInterceptor\assert().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PharExtensionInterceptor.php


Joomla CMS: Référence de la classe PharMetaDataInterceptor

  • TYPO3
  • PharStreamWrapper
  • Interceptor
  • PharMetaDataInterceptor
Fonctions membres publiques | Fonctions membres privées
Référence de la classe PharMetaDataInterceptor
+ Graphe d'héritage de PharMetaDataInterceptor:
Assertable

Fonctions membres publiques

assert (string $path, string $command)

Fonctions membres privées

baseFileDoesNotHaveMetaDataIssues (string $path)

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |

Determines whether the according Phar archive contains (potential insecure) serialized objects.

Paramètres
string | $path
string | $command
Renvoie
bool
Exceptions
Exception

Implémente Assertable.

Références $path, et PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues().

◆ baseFileDoesNotHaveMetaDataIssues()

baseFileDoesNotHaveMetaDataIssues ( string $path )
private
Paramètres
string $path
Renvoie
bool

Références $path, class, Manager\instance(), null, et Reader\resolveContainer().

Référencé par PharMetaDataInterceptor\assert().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PharMetaDataInterceptor.php


Joomla CMS: Référence de la classe Container

  • TYPO3
  • PharStreamWrapper
  • Phar
  • Container
Fonctions membres publiques | Attributs privés
Référence de la classe Container

Fonctions membres publiques

__construct (Stub $stub, Manifest $manifest)
getStub ()
getManifest ()
getAlias ()

Attributs privés

$stub
$manifest

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Stub | $stub,
 |  | Manifest | $manifest
 | ) |  |
Paramètres
Stub | $stub
Manifest | $manifest

Références Container\$manifest, et Container\$stub.

Documentation des fonctions membres

◆ getAlias()

getAlias ( )
Renvoie
string

◆ getManifest()

getManifest ( )
Renvoie
Manifest

Références Container\$manifest.

◆ getStub()

getStub ( )
Renvoie
Stub

Références Container\$stub.

Documentation des champs

◆ $manifest

$manifest
private

Référencé par Container\__construct(), et Container\getManifest().

◆ $stub

$stub
private

Référencé par Container\__construct(), et Container\getStub().

La documentation de cette classe a été générée à partir du fichier suivant :
  • typo3/phar-stream-wrapper/src/Phar/Container.php


Joomla CMS: Référence de la classe DeserializationException

  • TYPO3
  • PharStreamWrapper
  • Phar
  • DeserializationException
Référence de la classe DeserializationException
+ Graphe d'héritage de DeserializationException:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • typo3/phar-stream-wrapper/src/Phar/DeserializationException.php


Joomla CMS: Référence de la classe Manifest

  • TYPO3
  • PharStreamWrapper
  • Phar
  • Manifest
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Manifest

Fonctions membres publiques

getManifestLength ()
getAmountOfFiles ()
getApiVersion ()
getFlags ()
getAliasLength ()
getAlias ()
getMetaDataLength ()
getMetaData ()
deserializeMetaData ()

Fonctions membres publiques statiques

static fromContent (string $content)

Fonctions membres privées

__construct ()

Attributs privés

$manifestLength
$amountOfFiles
$apiVersion
$flags
$aliasLength
$alias
$metaDataLength
$metaData

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Avoid direct instantiation.

Documentation des fonctions membres

◆ deserializeMetaData()

deserializeMetaData ( )
Renvoie
mixed|null

Références $result, et null.

◆ fromContent()

static fromContent ( string $content )
static
Paramètres
string $content
Renvoie
self
Voir également
http://php.net/manual/en/phar.fileformat.phar.php

Références $content, $target, Reader\resolveFourByteLittleEndian(), et Reader\resolveTwoByteBigEndian().

Référencé par Reader\resolveContainer().

◆ getAlias()

getAlias ( )
Renvoie
string

Références Manifest\$alias.

◆ getAliasLength()

getAliasLength ( )
Renvoie
int

Références Manifest\$aliasLength.

◆ getAmountOfFiles()

getAmountOfFiles ( )
Renvoie
int

Références Manifest\$amountOfFiles.

◆ getApiVersion()

getApiVersion ( )
Renvoie
string

Références Manifest\$apiVersion.

◆ getFlags()

getFlags ( )
Renvoie
int

Références Manifest\$flags.

◆ getManifestLength()

getManifestLength ( )
Renvoie
int

Références Manifest\$manifestLength.

◆ getMetaData()

getMetaData ( )
Renvoie
string

Références Manifest\$metaData.

◆ getMetaDataLength()

getMetaDataLength ( )
Renvoie
int

Références Manifest\$metaDataLength.

Documentation des champs

◆ $alias

$alias
private

Référencé par Manifest\getAlias().

◆ $aliasLength

$aliasLength
private

Référencé par Manifest\getAliasLength().

◆ $amountOfFiles

$amountOfFiles
private

Référencé par Manifest\getAmountOfFiles().

◆ $apiVersion

$apiVersion
private

Référencé par Manifest\getApiVersion().

◆ $flags

$flags
private

Référencé par Manifest\getFlags().

◆ $manifestLength

$manifestLength
private

Référencé par Manifest\getManifestLength().

◆ $metaData

$metaData
private

Référencé par Manifest\getMetaData().

◆ $metaDataLength

$metaDataLength
private

Référencé par Manifest\getMetaDataLength().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/typo3/phar-stream-wrapper/src/Phar/Manifest.php


Joomla CMS: Référence de la classe Reader

  • TYPO3
  • PharStreamWrapper
  • Phar
  • Reader
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe Reader

Fonctions membres publiques

__construct (string $fileName)
resolveContainer ()

Fonctions membres publiques statiques

static | resolveFourByteLittleEndian (string $content, int $start)
static | resolveTwoByteBigEndian (string $content, int $start)

Fonctions membres privées

extractData (string $fileName)
resolveStream ()
determineFileType ()
determineFileTypeByHeader ()
resolveManifestLength (string $content)

Attributs privés

$fileName
$fileType

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $fileName )
Paramètres
string $fileName

Références Reader\$fileName, et Reader\determineFileType().

Documentation des fonctions membres

◆ determineFileType()

determineFileType ( )
private
Renvoie
string

Références Reader\determineFileTypeByHeader().

Référencé par Reader\__construct().

◆ determineFileTypeByHeader()

determineFileTypeByHeader ( )
private

In case ext-fileinfo is not present only the relevant types 'application/x-gzip' and 'application/x-bzip2' are resolved.

Renvoie
string

Références $header, et elseif.

Référencé par Reader\determineFileType().

◆ extractData()

extractData ( string $fileName )
private
Paramètres
string $fileName e.g. '/path/file.phar' or 'compress.zlib:///path/file.phar'
Renvoie
array

Références Reader\$fileName, elseif, null, et Reader\resolveManifestLength().

Référencé par Reader\resolveContainer().

◆ resolveContainer()

resolveContainer ( )
Renvoie
Container

Références $data, Reader\extractData(), Manifest\fromContent(), Stub\fromContent(), null, et Reader\resolveStream().

Référencé par PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues().

◆ resolveFourByteLittleEndian()

static resolveFourByteLittleEndian | ( | string | $content,
 |  | int | $start
 | ) |  |
static
Paramètres
string | $content
int | $start
Renvoie
int

Références $content, $start, et $value.

Référencé par Manifest\fromContent().

◆ resolveManifestLength()

resolveManifestLength ( string $content )
private
Paramètres
string $content
Renvoie
int|null

Références $content, et null.

Référencé par Reader\extractData().

◆ resolveStream()

resolveStream ( )
private

Resolves stream in order to handle compressed Phar archives.

Renvoie
string

Références elseif.

Référencé par Reader\resolveContainer().

◆ resolveTwoByteBigEndian()

static resolveTwoByteBigEndian | ( | string | $content,
 |  | int | $start
 | ) |  |
static
Paramètres
string | $content
int | $start
Renvoie
int

Références $content, $start, et $value.

Référencé par Manifest\fromContent().

Documentation des champs

◆ $fileName

$fileName
private

Référencé par Reader\__construct(), et Reader\extractData().

◆ $fileType

$fileType
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • Reader.php


Joomla CMS: Référence de la classe ReaderException

  • TYPO3
  • PharStreamWrapper
  • Phar
  • ReaderException
Référence de la classe ReaderException
+ Graphe d'héritage de ReaderException:
Exception
La documentation de cette classe a été générée à partir du fichier suivant :
  • ReaderException.php


Joomla CMS: Référence de la classe Stub

  • TYPO3
  • PharStreamWrapper
  • Phar
  • Stub
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Stub

Fonctions membres publiques

getContent ()
getMappedAlias ()

Fonctions membres publiques statiques

static fromContent (string $content)

Attributs privés

$content
$mappedAlias = ''

Documentation des fonctions membres

◆ fromContent()

static fromContent ( string $content )
static
Paramètres
string $content
Renvoie
self

Références Stub\$content, et $target.

Référencé par Reader\resolveContainer().

◆ getContent()

getContent ( )
Renvoie
string

Références Stub\$content.

◆ getMappedAlias()

getMappedAlias ( )
Renvoie
string

Références Stub\$mappedAlias.

Documentation des champs

◆ $content

$content
private

Référencé par Stub\fromContent(), et Stub\getContent().

◆ $mappedAlias

$mappedAlias = ''
private

Référencé par Stub\getMappedAlias().

La documentation de cette classe a été générée à partir du fichier suivant :
  • typo3/phar-stream-wrapper/src/Phar/Stub.php


Joomla CMS: Référence de la classe PharInvocation

  • TYPO3
  • PharStreamWrapper
  • Resolver
  • PharInvocation
Fonctions membres publiques | Attributs privés
Référence de la classe PharInvocation

Fonctions membres publiques

__construct (string $baseName, string $alias='')
__toString ()
getBaseName ()
getAlias ()
isConfirmed ()
confirm ()
getVariable (string $name)
setVariable (string $name, $value)
equals (PharInvocation $other)

Attributs privés

$baseName
$alias
$confirmed = false
$variables

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $baseName,
 |  | string | $alias = ''
 | ) |  |
Paramètres
string | $baseName
string | $alias

Références PharInvocation\$alias, et PharInvocation\$baseName.

Documentation des fonctions membres

◆ __toString()

__toString ( )
Renvoie
string

Références PharInvocation\$baseName.

◆ confirm()

confirm ( )

◆ equals()

equals ( PharInvocation $other )
Paramètres
PharInvocation $other
Renvoie
bool

Références PharInvocation\$alias.

Référencé par PharInvocationCollection\assertUniqueInvocation().

◆ getAlias()

getAlias ( )
Renvoie
null|string

Références PharInvocation\$alias.

Référencé par PharInvocationCollection\collect(), PharInvocationResolver\findByAlias(), et PharInvocationCollection\triggerDuplicateAliasWarning().

◆ getBaseName()

getBaseName ( )
Renvoie
string

Références PharInvocation\$baseName.

Référencé par PharInvocationCollection\assertUniqueBaseName(), PharInvocationCollection\collect(), PharInvocationResolver\findByBaseName(), et PharInvocationCollection\triggerDuplicateAliasWarning().

◆ getVariable()

getVariable ( string $name )
Paramètres
string $name
Renvoie
mixed|null

Références $name, et null.

◆ isConfirmed()

isConfirmed ( )
Renvoie
bool

Références PharInvocation\$confirmed.

Référencé par PharInvocationResolver\findByAlias(), et PharInvocationCollection\triggerDuplicateAliasWarning().

◆ setVariable()

setVariable | ( | string | $name,
 |  |  | $value
 | ) |  |
Paramètres
string | $name
mixed | $value

Références $name, et $value.

Documentation des champs

◆ $alias

$alias
private

Référencé par PharInvocation\__construct(), PharInvocation\equals(), et PharInvocation\getAlias().

◆ $baseName

$baseName
private

Référencé par PharInvocation\__construct(), PharInvocation\__toString(), et PharInvocation\getBaseName().

◆ $confirmed

$confirmed = false
private

Référencé par PharInvocation\isConfirmed().

◆ $variables

$variables
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • PharInvocation.php


Joomla CMS: Référence de la classe PharInvocationCollection

  • TYPO3
  • PharStreamWrapper
  • Resolver
  • PharInvocationCollection
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe PharInvocationCollection
+ Graphe d'héritage de PharInvocationCollection:
Collectable

Fonctions membres publiques

has (PharInvocation $invocation)
collect (PharInvocation $invocation, int $flags=null)
findByCallback (callable $callback, $reverse=false)

Champs de données

const | UNIQUE_INVOCATION = 1
const | UNIQUE_BASE_NAME = 2
const | DUPLICATE_ALIAS_WARNING = 32

Fonctions membres privées

assertUniqueBaseName (PharInvocation $invocation, int $flags)
assertUniqueInvocation (PharInvocation $invocation, int $flags)
triggerDuplicateAliasWarning (PharInvocation $invocation)
getInvocations (bool $reverse=false)

Attributs privés

$invocations = []

Documentation des fonctions membres

◆ assertUniqueBaseName()

assertUniqueBaseName | ( | PharInvocation | $invocation,
 |  | int | $flags
 | ) |  |
private

Asserts that base-name is unique. This disallows having multiple invocations for same base-name but having different alias names.

Paramètres
PharInvocation | $invocation
int | $flags
Renvoie
bool

Références PharInvocationCollection\findByCallback(), PharInvocation\getBaseName(), et null.

Référencé par PharInvocationCollection\collect().

◆ assertUniqueInvocation()

assertUniqueInvocation | ( | PharInvocation | $invocation,
 |  | int | $flags
 | ) |  |
private

Asserts that combination of base-name and alias is unique. This allows having multiple invocations for same base-name but having different alias names (for whatever reason).

Paramètres
PharInvocation | $invocation
int | $flags
Renvoie
bool

Références PharInvocation\equals(), PharInvocationCollection\findByCallback(), et null.

Référencé par PharInvocationCollection\collect().

◆ collect()

collect | ( | PharInvocation | $invocation,
 |  | int | $flags = null
 | ) |  |
Paramètres
PharInvocation | $invocation
null | int | $flags
Renvoie
bool

Implémente Collectable.

Références PharInvocationCollection\assertUniqueBaseName(), PharInvocationCollection\assertUniqueInvocation(), PharInvocation\getAlias(), PharInvocation\getBaseName(), null, et PharInvocationCollection\triggerDuplicateAliasWarning().

◆ findByCallback()

findByCallback | ( | callable | $callback,
 |  |  | $reverse = false
 | ) |  |
Paramètres
callable | $callback
bool | $reverse
Renvoie
null|PharInvocation

Implémente Collectable.

Références PharInvocationCollection\getInvocations(), et null.

Référencé par PharInvocationCollection\assertUniqueBaseName(), PharInvocationCollection\assertUniqueInvocation(), et PharInvocationCollection\triggerDuplicateAliasWarning().

◆ getInvocations()

getInvocations ( bool $reverse = false )
private
Paramètres
bool $reverse
Renvoie
PharInvocation[]

Références PharInvocationCollection\$invocations.

Référencé par PharInvocationCollection\findByCallback().

◆ has()

has ( PharInvocation $invocation )
Paramètres
PharInvocation $invocation
Renvoie
bool

Implémente Collectable.

◆ triggerDuplicateAliasWarning()

triggerDuplicateAliasWarning ( PharInvocation $invocation )
private

Triggers warning for invocations with same alias and same confirmation state.

Paramètres
PharInvocation $invocation
Voir également
::collectInvocation()

Références PharInvocationCollection\findByCallback(), PharInvocation\getAlias(), PharInvocation\getBaseName(), PharInvocation\isConfirmed(), null, et true.

Référencé par PharInvocationCollection\collect().

Documentation des champs

◆ $invocations

$invocations = []
private

Référencé par PharInvocationCollection\getInvocations().

◆ DUPLICATE_ALIAS_WARNING

const DUPLICATE_ALIAS_WARNING = 32

◆ UNIQUE_BASE_NAME

const UNIQUE_BASE_NAME = 2

◆ UNIQUE_INVOCATION

const UNIQUE_INVOCATION = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • PharInvocationCollection.php


Joomla CMS: Référence de la classe PharInvocationResolver

  • TYPO3
  • PharStreamWrapper
  • Resolver
  • PharInvocationResolver
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe PharInvocationResolver
+ Graphe d'héritage de PharInvocationResolver:
Resolvable

Fonctions membres publiques

resolve (string $path, int $flags=null)

Champs de données

const | RESOLVE_REALPATH = 1
const | RESOLVE_ALIAS = 2
const | ASSERT_INTERNAL_INVOCATION = 32

Fonctions membres privées

retrieveInvocation (string $baseName, int $flags)
resolveBaseName (string $path, int $flags)
resolvePossibleAlias (string $path)
findByBaseName (string $baseName)
findInBaseNames (string $path)
addBaseName (string $baseName)
findByAlias (string $path)

Attributs privés

$invocationFunctionNames
$baseNames = []

Documentation des fonctions membres

◆ addBaseName()

addBaseName ( string $baseName )
private
Paramètres
string $baseName

Références Helper\normalizeWindowsPath().

Référencé par PharInvocationResolver\resolveBaseName().

◆ findByAlias()

findByAlias ( string $path )
private

Finds confirmed(!) invocations by alias.

Paramètres
string $path
Renvoie
null|PharInvocation
Voir également
::collectInvocation()

Références PharInvocation\getAlias(), Manager\instance(), PharInvocation\isConfirmed(), null, PharInvocationResolver\resolvePossibleAlias(), et true.

Référencé par PharInvocationResolver\resolve().

◆ findByBaseName()

findByBaseName ( string $baseName )
private
Paramètres
string $baseName
Renvoie
null|PharInvocation

Références PharInvocation\getBaseName(), Manager\instance(), et true.

Référencé par PharInvocationResolver\retrieveInvocation().

◆ findInBaseNames()

findInBaseNames ( string $path )
private
Paramètres
string $path
Renvoie
null|string

Références $parts, $path, Helper\normalizePath(), et null.

Référencé par PharInvocationResolver\resolveBaseName().

◆ resolve()

resolve | ( | string | $path,
 |  | int | $flags = null
 | ) |  |

Resolves PharInvocation value object (baseName and optional alias).

Phar aliases are intended to be used only inside Phar archives, however PharStreamWrapper needs this information exposed outside of Phar as well It is possible that same alias is used for different $baseName values. That's why PharInvocationCollection behaves like a stack when resolving base-name for a given alias. On the other hand it is not possible that one $baseName is referring to multiple aliases.

Voir également
https://secure.php.net/manual/en/phar.setalias.php
https://secure.php.net/manual/en/phar.mapphar.php
Paramètres
string | $path
int | null | $flags
Renvoie
null|PharInvocation

Implémente Resolvable.

Références $path, PharInvocationResolver\findByAlias(), Helper\hasPharPrefix(), null, PharInvocationResolver\resolveBaseName(), et PharInvocationResolver\retrieveInvocation().

◆ resolveBaseName()

resolveBaseName | ( | string | $path,
 |  | int | $flags
 | ) |  |
private
Paramètres
string | $path
int | $flags
Renvoie
null|string

Références $item, $path, PharInvocationResolver\addBaseName(), Helper\determineBaseFile(), PharInvocationResolver\findInBaseNames(), Helper\hasPharPrefix(), null, et PharInvocationResolver\resolvePossibleAlias().

Référencé par PharInvocationResolver\resolve().

◆ resolvePossibleAlias()

resolvePossibleAlias ( string $path )
private
Paramètres
string $path
Renvoie
null|string

Références $path, Helper\normalizePath(), et null.

Référencé par PharInvocationResolver\findByAlias(), et PharInvocationResolver\resolveBaseName().

◆ retrieveInvocation()

retrieveInvocation | ( | string | $baseName,
 |  | int | $flags
 | ) |  |
private

Retrieves PharInvocation, either existing in collection or created on demand with resolving a potential alias name used in the according Phar archive.

Paramètres
string | $baseName
int | $flags
Renvoie
PharInvocation

Références PharInvocationResolver\findByBaseName(), Manager\instance(), et null.

Référencé par PharInvocationResolver\resolve().

Documentation des champs

◆ $baseNames

$baseNames = []
private

◆ $invocationFunctionNames

$invocationFunctionNames
private
Valeur initiale :
= [
'include',
'include_once',
'require',
'require_once'
]

◆ ASSERT_INTERNAL_INVOCATION

const ASSERT_INTERNAL_INVOCATION = 32

◆ RESOLVE_ALIAS

const RESOLVE_ALIAS = 2

◆ RESOLVE_REALPATH

const RESOLVE_REALPATH = 1
La documentation de cette classe a été générée à partir du fichier suivant :
  • PharInvocationResolver.php


Joomla CMS: Référence de l'interface Assertable

  • TYPO3
  • PharStreamWrapper
  • Assertable
Fonctions membres publiques
Référence de l'interface Assertable
+ Graphe d'héritage de Assertable:
Behavior ConjunctionInterceptor PharExtensionInterceptor PharMetaDataInterceptor

Fonctions membres publiques

assert (string $path, string $command)

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |
Paramètres
string | $path
string | $command
Renvoie
bool

Implémenté dans Behavior, ConjunctionInterceptor, PharMetaDataInterceptor, et PharExtensionInterceptor.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Assertable.php


Joomla CMS: Référence de la classe Behavior

  • TYPO3
  • PharStreamWrapper
  • Behavior
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Behavior
+ Graphe d'héritage de Behavior:
Assertable

Fonctions membres publiques

withAssertion (Assertable $assertable, string ... $commands)
assert (string $path, string $command)

Champs de données

const | COMMAND_DIR_OPENDIR = 'dir_opendir'
const | COMMAND_MKDIR = 'mkdir'
const | COMMAND_RENAME = 'rename'
const | COMMAND_RMDIR = 'rmdir'
const | COMMAND_STEAM_METADATA = 'stream_metadata'
const | COMMAND_STREAM_OPEN = 'stream_open'
const | COMMAND_UNLINK = 'unlink'
const | COMMAND_URL_STAT = 'url_stat'

Fonctions membres privées

assertCommands (array $commands)
assertCommand (string $command)
assertAssertionCompleteness ()

Attributs privés

$availableCommands
$assertions

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |
Paramètres
string | $path
string | $command
Renvoie
bool

Implémente Assertable.

Références $path, Behavior\assertAssertionCompleteness(), et Behavior\assertCommand().

◆ assertAssertionCompleteness()

assertAssertionCompleteness ( )
private

Référencé par Behavior\assert().

◆ assertCommand()

assertCommand ( string $command )
private

Référencé par Behavior\assert().

◆ assertCommands()

assertCommands ( array $commands )
private
Paramètres
array $commands

Référencé par Behavior\withAssertion().

◆ withAssertion()

withAssertion | ( | Assertable | $assertable,
 |  | string ... | $commands
 | ) |  |
Paramètres
Assertable | $assertable
string | ...$commands
Renvoie
static

Références Behavior\$availableCommands, $target, $this, et Behavior\assertCommands().

Documentation des champs

◆ $assertions

$assertions
private

◆ $availableCommands

$availableCommands
private
Valeur initiale :
= [
self::COMMAND_DIR_OPENDIR,
self::COMMAND_MKDIR,
self::COMMAND_RENAME,
self::COMMAND_RMDIR,
self::COMMAND_STEAM_METADATA,
self::COMMAND_STREAM_OPEN,
self::COMMAND_UNLINK,
self::COMMAND_URL_STAT,
]

Référencé par Behavior\withAssertion().

◆ COMMAND_DIR_OPENDIR

const COMMAND_DIR_OPENDIR = 'dir_opendir'

Référencé par PharStreamWrapper\dir_opendir().

◆ COMMAND_MKDIR

const COMMAND_MKDIR = 'mkdir'

Référencé par PharStreamWrapper\mkdir().

◆ COMMAND_RENAME

const COMMAND_RENAME = 'rename'

Référencé par PharStreamWrapper\rename().

◆ COMMAND_RMDIR

const COMMAND_RMDIR = 'rmdir'

Référencé par PharStreamWrapper\rmdir().

◆ COMMAND_STEAM_METADATA

const COMMAND_STEAM_METADATA = 'stream_metadata'

Référencé par PharStreamWrapper\stream_metadata().

◆ COMMAND_STREAM_OPEN

const COMMAND_STREAM_OPEN = 'stream_open'

Référencé par PharStreamWrapper\stream_open().

◆ COMMAND_UNLINK

const COMMAND_UNLINK = 'unlink'

Référencé par PharStreamWrapper\unlink().

◆ COMMAND_URL_STAT

const COMMAND_URL_STAT = 'url_stat'

Référencé par PharStreamWrapper\url_stat().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/typo3/phar-stream-wrapper/src/Behavior.php


Joomla CMS: Référence de l'interface Collectable

  • TYPO3
  • PharStreamWrapper
  • Collectable
Fonctions membres publiques
Référence de l'interface Collectable
+ Graphe d'héritage de Collectable:
PharInvocationCollection

Fonctions membres publiques

has (PharInvocation $invocation)
collect (PharInvocation $invocation, int $flags=null)
findByCallback (callable $callback, $reverse=false)

Documentation des fonctions membres

◆ collect()

collect | ( | PharInvocation | $invocation,
 |  | int | $flags = null
 | ) |  |
Paramètres
PharInvocation | $invocation
int | null | $flags
Renvoie
bool

Implémenté dans PharInvocationCollection.

◆ findByCallback()

findByCallback | ( | callable | $callback,
 |  |  | $reverse = false
 | ) |  |
Paramètres
callable | $callback
bool | $reverse
Renvoie
null|PharInvocation

Implémenté dans PharInvocationCollection.

◆ has()

has ( PharInvocation $invocation )
Paramètres
PharInvocation $invocation
Renvoie
bool

Implémenté dans PharInvocationCollection.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Collectable.php


Joomla CMS: Référence de la classe Exception

  • TYPO3
  • PharStreamWrapper
  • Exception
Référence de la classe Exception
+ Graphe d'héritage de Exception:
DeserializationException ReaderException
La documentation de cette classe a été générée à partir du fichier suivant :
  • typo3/phar-stream-wrapper/src/Exception.php


Joomla CMS: Référence de la classe Helper

  • TYPO3
  • PharStreamWrapper
  • Helper
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe Helper

Fonctions membres publiques statiques

static | resetOpCache ()
static | determineBaseFile (string $path)
static | hasPharPrefix (string $path)
static | removePharPrefix (string $path)
static | normalizePath (string $path)
static | normalizeWindowsPath (string $path)

Fonctions membres privées statiques

static | getCanonicalPath ($path)
static | isAbsolutePath ($path)
static | isWindows ()

Description détaillée

Helper provides low-level tools on file name resolving. However it does not (and should not) maintain any runtime state information. In order to resolve Phar archive paths according resolvers have to be used.

Voir également
::resolve()

Documentation des fonctions membres

◆ determineBaseFile()

static determineBaseFile ( string $path )
static

Determines base file that can be accessed using the regular file system. For e.g. "phar:///home/user/bundle.phar/content.txt" that would result into "/home/user/bundle.phar".

Paramètres
string $path
Renvoie
string|null

Références $parts, $path, et null.

Référencé par PharInvocationResolver\resolveBaseName().

◆ getCanonicalPath()

static getCanonicalPath ( $path )
staticprivate

Resolves all dots, slashes and removes spaces after or before a path...

Paramètres
string $path Input string
Renvoie
string Canonical path, always without trailing slash

Références $path, et elseif.

◆ hasPharPrefix()

static hasPharPrefix ( string $path )
static
Paramètres
string $path
Renvoie
bool

Références $path.

Référencé par PharInvocationResolver\resolve(), et PharInvocationResolver\resolveBaseName().

◆ isAbsolutePath()

static isAbsolutePath ( $path )
staticprivate

Checks if the $path is absolute or relative (detecting either '/' or 'x:/' as first part of string) and returns TRUE if so.

Paramètres
string $path File path to evaluate
Renvoie
bool

Références $path, et null.

◆ isWindows()

static isWindows ( )
staticprivate
Renvoie
bool

◆ normalizePath()

static normalizePath ( string $path )
static

Normalizes a path, removes phar:// prefix, fixes Windows directory separators. Result is without trailing slash.

Paramètres
string $path
Renvoie
string

Références $path.

Référencé par PharInvocationResolver\findInBaseNames(), et PharInvocationResolver\resolvePossibleAlias().

◆ normalizeWindowsPath()

static normalizeWindowsPath ( string $path )
static

Fixes a path for windows-backslashes and reduces double-slashes to single slashes

Paramètres
string $path File path to process
Renvoie
string

Références $path.

Référencé par PharInvocationResolver\addBaseName().

◆ removePharPrefix()

static removePharPrefix ( string $path )
static
Paramètres
string $path
Renvoie
string

Références $path.

◆ resetOpCache()

static resetOpCache ( )
static

Référencé par PharStreamWrapper\stream_open().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/typo3/phar-stream-wrapper/src/Helper.php


Joomla CMS: Référence de la classe Manager

  • TYPO3
  • PharStreamWrapper
  • Manager
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe Manager

Fonctions membres publiques

assert (string $path, string $command)
resolve (string $path, int $flags=null)
getCollection ()

Fonctions membres publiques statiques

static | initialize (Behavior $behaviour, Resolvable $resolver=null, Collectable $collection=null)
static | instance ()
static | destroy ()

Fonctions membres privées

__construct (Behavior $behaviour, Resolvable $resolver=null, Collectable $collection=null)

Attributs privés

$behavior
$resolver
$collection

Attributs privés statiques

static $instance

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | Behavior | $behaviour,
 |  | Resolvable | $resolver = null,
 |  | Collectable | $collection = null
 | ) |  |
private
Paramètres
Behavior | $behaviour
Resolvable | $resolver
Collectable | $collection

Références Manager\$collection, et Manager\$resolver.

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |
Paramètres
string | $path
string | $command
Renvoie
bool

Références $path.

◆ destroy()

static destroy ( )
static
Renvoie
bool

Références null.

◆ getCollection()

getCollection ( )
Renvoie
Collectable

Références Manager\$collection.

◆ initialize()

static initialize | ( | Behavior | $behaviour,
 |  | Resolvable | $resolver = null,
 |  | Collectable | $collection = null
 | ) |  |
static
Paramètres
Behavior | $behaviour
Resolvable | $resolver
Collectable | $collection
Renvoie
self

Références Manager\$collection, Manager\$resolver, et null.

◆ instance()

static instance ( )
static
Renvoie
self

Références null.

Référencé par PharStreamWrapper\assert(), PharExtensionInterceptor\baseFileContainsPharExtension(), PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues(), PharStreamWrapper\collectInvocation(), PharInvocationResolver\findByAlias(), PharInvocationResolver\findByBaseName(), PharStreamWrapper\resolveAssertable(), et PharInvocationResolver\retrieveInvocation().

◆ resolve()

resolve | ( | string | $path,
 |  | int | $flags = null
 | ) |  |
Paramètres
string | $path
null | int | $flags
Renvoie
PharInvocation|null

Références $path.

Documentation des champs

◆ $behavior

$behavior
private

◆ $collection

$collection
private

Référencé par Manager\__construct(), Manager\getCollection(), et Manager\initialize().

◆ $instance

$instance
staticprivate

◆ $resolver

$resolver
private

Référencé par Manager\__construct(), et Manager\initialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • typo3/phar-stream-wrapper/src/Manager.php


Joomla CMS: Référence de la classe PharStreamWrapper

  • TYPO3
  • PharStreamWrapper
  • PharStreamWrapper
Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe PharStreamWrapper

Fonctions membres publiques

dir_closedir ()
dir_opendir (string $path, int $options)
dir_readdir ()
dir_rewinddir ()
mkdir (string $path, int $mode, int $options)
rename (string $path_from, string $path_to)
rmdir (string $path, int $options)
stream_cast (int $cast_as)
stream_close ()
stream_eof ()
stream_flush ()
stream_lock (int $operation)
stream_metadata (string $path, int $option, $value)
stream_open (string $path, string $mode, int $options, string &$opened_path=null)
stream_read (int $count)
stream_seek (int $offset, int $whence=SEEK_SET)
stream_set_option (int $option, int $arg1, int $arg2)
stream_stat ()
stream_tell ()
stream_truncate (int $new_size)
stream_write (string $data)
unlink (string $path)
url_stat (string $path, int $flags)

Champs de données

const STREAM_OPEN_FOR_INCLUDE = 128
$context

Fonctions membres protégées

assert (string $path, string $command)
collectInvocation (string $path)
resolveAssertable ()

Attributs protégés

$internalResource
$invocation

Fonctions membres privées

invokeInternalStreamWrapper (string $functionName,... $arguments)
restoreInternalSteamWrapper ()
registerStreamWrapper ()

Documentation des fonctions membres

◆ assert()

assert | ( | string | $path,
 |  | string | $command
 | ) |  |
protected
Paramètres
string | $path
string | $command

Références $path, PharStreamWrapper\collectInvocation(), et Manager\instance().

Référencé par PharStreamWrapper\dir_opendir(), PharStreamWrapper\mkdir(), PharStreamWrapper\rename(), PharStreamWrapper\rmdir(), PharStreamWrapper\stream_metadata(), PharStreamWrapper\stream_open(), PharStreamWrapper\unlink(), et PharStreamWrapper\url_stat().

◆ collectInvocation()

collectInvocation ( string $path )
protected
Paramètres
string $path

Références $path, $this, Manager\instance(), et null.

Référencé par PharStreamWrapper\assert().

◆ dir_closedir()

dir_closedir ( )
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ dir_opendir()

dir_opendir | ( | string | $path,
 |  | int | $options
 | ) |  |
Paramètres
string | $path
int | $options
Renvoie
bool

Références PharStreamWrapper\assert(), Behavior\COMMAND_DIR_OPENDIR, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ dir_readdir()

dir_readdir ( )
Renvoie
string|false

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ dir_rewinddir()

dir_rewinddir ( )
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ invokeInternalStreamWrapper()

invokeInternalStreamWrapper | ( | string | $functionName,
 |  |  | $arguments
 | ) |  |
private

Invokes commands on the native PHP Phar stream wrapper.

Paramètres
string | $functionName
mixed | ...$arguments
Renvoie
mixed

Références $result, PharStreamWrapper\registerStreamWrapper(), et PharStreamWrapper\restoreInternalSteamWrapper().

Référencé par PharStreamWrapper\dir_closedir(), PharStreamWrapper\dir_opendir(), PharStreamWrapper\dir_readdir(), PharStreamWrapper\dir_rewinddir(), PharStreamWrapper\mkdir(), PharStreamWrapper\rename(), PharStreamWrapper\rmdir(), PharStreamWrapper\stream_close(), PharStreamWrapper\stream_eof(), PharStreamWrapper\stream_flush(), PharStreamWrapper\stream_lock(), PharStreamWrapper\stream_metadata(), PharStreamWrapper\stream_open(), PharStreamWrapper\stream_read(), PharStreamWrapper\stream_seek(), PharStreamWrapper\stream_set_option(), PharStreamWrapper\stream_stat(), PharStreamWrapper\stream_tell(), PharStreamWrapper\stream_truncate(), PharStreamWrapper\stream_write(), PharStreamWrapper\unlink(), et PharStreamWrapper\url_stat().

◆ mkdir()

mkdir | ( | string | $path,
 |  | int | $mode,
 |  | int | $options
 | ) |  |
Paramètres
string | $path
int | $mode
int | $options
Renvoie
bool

Références $mode, $options, PharStreamWrapper\assert(), Behavior\COMMAND_MKDIR, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ registerStreamWrapper()

registerStreamWrapper ( )
private

Références class.

Référencé par PharStreamWrapper\invokeInternalStreamWrapper().

◆ rename()

rename | ( | string | $path_from,
 |  | string | $path_to
 | ) |  |
Paramètres
string | $path_from
string | $path_to
Renvoie
bool

Références PharStreamWrapper\assert(), Behavior\COMMAND_RENAME, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ resolveAssertable()

resolveAssertable ( )
protected
Renvoie
Manager|Assertable
Obsolète:
Use Manager::instance() directly

Références Manager\instance().

◆ restoreInternalSteamWrapper()

restoreInternalSteamWrapper ( )
private

Référencé par PharStreamWrapper\invokeInternalStreamWrapper().

◆ rmdir()

rmdir | ( | string | $path,
 |  | int | $options
 | ) |  |
Paramètres
string | $path
int | $options
Renvoie
bool

Références PharStreamWrapper\assert(), Behavior\COMMAND_RMDIR, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_cast()

stream_cast ( int $cast_as )
Paramètres
int $cast_as

◆ stream_close()

stream_close ( )

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_eof()

stream_eof ( )
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_flush()

stream_flush ( )
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_lock()

stream_lock ( int $operation )
Paramètres
int $operation
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_metadata()

stream_metadata | ( | string | $path,
 |  | int | $option,
 |  |  | $value
 | ) |  |
Paramètres
string | $path
int | $option
string | int | $value
Renvoie
bool

Références $option, $value, PharStreamWrapper\assert(), Behavior\COMMAND_STEAM_METADATA, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_open()

stream_open | ( | string | $path,
 |  | string | $mode,
 |  | int | $options,
 |  | string & | $opened_path = null
 | ) |  |
Paramètres
string | $path
string | $mode
int | $options
string | null | $opened_path
Renvoie
bool

Références PharStreamWrapper\$context, $mode, $options, $path, PharStreamWrapper\assert(), Behavior\COMMAND_STREAM_OPEN, PharStreamWrapper\invokeInternalStreamWrapper(), null, et Helper\resetOpCache().

◆ stream_read()

stream_read ( int $count )
Paramètres
int $count
Renvoie
string

Références $count, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_seek()

stream_seek | ( | int | $offset,
 |  | int | $whence = SEEK_SET
 | ) |  |
Paramètres
int | $offset
int | $whence
Renvoie
bool

Références Joomla\Database\Query\$offset, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_set_option()

stream_set_option | ( | int | $option,
 |  | int | $arg1,
 |  | int | $arg2
 | ) |  |
Paramètres
int | $option
int | $arg1
int | $arg2
Renvoie
bool

Références $option, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_stat()

stream_stat ( )
Renvoie
array

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_tell()

stream_tell ( )
Renvoie
int

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_truncate()

stream_truncate ( int $new_size )
Paramètres
int $new_size
Renvoie
bool

Références PharStreamWrapper\invokeInternalStreamWrapper().

◆ stream_write()

stream_write ( string $data )
Paramètres
string $data
Renvoie
int

Références $data, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ unlink()

unlink ( string $path )
Paramètres
string $path
Renvoie
bool

Références PharStreamWrapper\assert(), Behavior\COMMAND_UNLINK, et PharStreamWrapper\invokeInternalStreamWrapper().

◆ url_stat()

url_stat | ( | string | $path,
 |  | int | $flags
 | ) |  |
Paramètres
string | $path
int | $flags
Renvoie
array|false

Références $path, PharStreamWrapper\assert(), Behavior\COMMAND_URL_STAT, et PharStreamWrapper\invokeInternalStreamWrapper().

Documentation des champs

◆ $context

$context

Référencé par PharStreamWrapper\stream_open().

◆ $internalResource

$internalResource
protected

◆ $invocation

$invocation
protected

◆ STREAM_OPEN_FOR_INCLUDE

const STREAM_OPEN_FOR_INCLUDE = 128

Internal stream constants that are not exposed to PHP, but used...

Voir également
https://github.com/php/php-src/blob/e17fc0d73c611ad0207cac8a4a01ded38251a7dc/main/php_streams.h
La documentation de cette classe a été générée à partir du fichier suivant :
  • PharStreamWrapper.php


Joomla CMS: Référence de l'interface Resolvable

  • TYPO3
  • PharStreamWrapper
  • Resolvable
Fonctions membres publiques
Référence de l'interface Resolvable
+ Graphe d'héritage de Resolvable:
PharInvocationResolver

Fonctions membres publiques

resolve (string $path, int $flags=null)

Documentation des fonctions membres

◆ resolve()

resolve | ( | string | $path,
 |  | int | $flags = null
 | ) |  |
Paramètres
string | $path
null | int | $flags
Renvoie
null|PharInvocation

Implémenté dans PharInvocationResolver.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Resolvable.php


Joomla CMS: Référence de la classe ASCII

  • voku
  • helper
  • ASCII
Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés statiques
Référence de la classe ASCII

Fonctions membres publiques statiques

static static | getAllLanguages ()
static | charsArray (bool $replace_extra_symbols=false)
static | clean (string $str, bool $normalize_whitespace=true, bool $keep_non_breaking_space=false, bool $normalize_msword=true, bool $remove_invisible_characters=true)
static | is_ascii (string $str)
static | remove_invisible_characters (string $str, bool $url_encoded=false, string $replacement='', bool $keep_basic_control_characters=true)
static | to_filename (string $str, bool $use_transliterate=true, string $fallback_char='-')
static | to_slugify (string $str, string $separator='-', string $language=self::ENGLISH_LANGUAGE_CODE, array $replacements=[], bool $replace_extra_symbols=false, bool $use_str_to_lower=true, bool $use_transliterate=false)

Champs de données

const | UZBEK_LANGUAGE_CODE = 'uz'
const | TURKMEN_LANGUAGE_CODE = 'tk'
const | THAI_LANGUAGE_CODE = 'th'
const | PASHTO_LANGUAGE_CODE = 'ps'
const | ORIYA_LANGUAGE_CODE = 'or'
const | MONGOLIAN_LANGUAGE_CODE = 'mn'
const | KOREAN_LANGUAGE_CODE = 'ko'
const | KIRGHIZ_LANGUAGE_CODE = 'ky'
const | ARMENIAN_LANGUAGE_CODE = 'hy'
const | BENGALI_LANGUAGE_CODE = 'bn'
const | BELARUSIAN_LANGUAGE_CODE = 'be'
const | AMHARIC_LANGUAGE_CODE = 'am'
const | JAPANESE_LANGUAGE_CODE = 'ja'
const | CHINESE_LANGUAGE_CODE = 'zh'
const | DUTCH_LANGUAGE_CODE = 'nl'
const | ITALIAN_LANGUAGE_CODE = 'it'
const | MACEDONIAN_LANGUAGE_CODE = 'mk'
const | PORTUGUESE_LANGUAGE_CODE = 'pt'
const | GREEKLISH_LANGUAGE_CODE = 'el__greeklish'
const | GREEK_LANGUAGE_CODE = 'el'
const | HINDI_LANGUAGE_CODE = 'hi'
const | SWEDISH_LANGUAGE_CODE = 'sv'
const | TURKISH_LANGUAGE_CODE = 'tr'
const | BULGARIAN_LANGUAGE_CODE = 'bg'
const | HUNGARIAN_LANGUAGE_CODE = 'hu'
const | MYANMAR_LANGUAGE_CODE = 'my'
const | CROATIAN_LANGUAGE_CODE = 'hr'
const | FINNISH_LANGUAGE_CODE = 'fi'
const | GEORGIAN_LANGUAGE_CODE = 'ka'
const | RUSSIAN_LANGUAGE_CODE = 'ru'
const | RUSSIAN_PASSPORT_2013_LANGUAGE_CODE = 'ru__passport_2013'
const | RUSSIAN_GOST_2000_B_LANGUAGE_CODE = 'ru__gost_2000_b'
const | UKRAINIAN_LANGUAGE_CODE = 'uk'
const | KAZAKH_LANGUAGE_CODE = 'kk'
const | CZECH_LANGUAGE_CODE = 'cs'
const | DANISH_LANGUAGE_CODE = 'da'
const | POLISH_LANGUAGE_CODE = 'pl'
const | ROMANIAN_LANGUAGE_CODE = 'ro'
const | ESPERANTO_LANGUAGE_CODE = 'eo'
const | ESTONIAN_LANGUAGE_CODE = 'et'
const | LATVIAN_LANGUAGE_CODE = 'lv'
const | LITHUANIAN_LANGUAGE_CODE = 'lt'
const | NORWEGIAN_LANGUAGE_CODE = 'no'
const | VIETNAMESE_LANGUAGE_CODE = 'vi'
const | ARABIC_LANGUAGE_CODE = 'ar'
const | PERSIAN_LANGUAGE_CODE = 'fa'
const | SERBIAN_LANGUAGE_CODE = 'sr'
const | SERBIAN_CYRILLIC_LANGUAGE_CODE = 'sr__cyr'
const | SERBIAN_LATIN_LANGUAGE_CODE = 'sr__lat'
const | AZERBAIJANI_LANGUAGE_CODE = 'az'
const | SLOVAK_LANGUAGE_CODE = 'sk'
const | FRENCH_LANGUAGE_CODE = 'fr'
const | FRENCH_AUSTRIAN_LANGUAGE_CODE = 'fr_at'
const | FRENCH_SWITZERLAND_LANGUAGE_CODE = 'fr_ch'
const | GERMAN_LANGUAGE_CODE = 'de'
const | GERMAN_AUSTRIAN_LANGUAGE_CODE = 'de_at'
const | GERMAN_SWITZERLAND_LANGUAGE_CODE = 'de_ch'
const | ENGLISH_LANGUAGE_CODE = 'en'
const | EXTRA_LATIN_CHARS_LANGUAGE_CODE = 'latin'
const | EXTRA_WHITESPACE_CHARS_LANGUAGE_CODE = ' '
const | EXTRA_MSWORD_CHARS_LANGUAGE_CODE = 'msword'

Fonctions membres privées statiques

static | get_language (string $language)
static | getData (string $file)
static | getDataIfExists (string $file)
static | prepareAsciiAndExtrasMaps ()
static | prepareAsciiMaps ()
static | prepareAsciiExtras ()

Attributs privés statiques

static | $ASCII_MAPS
static | $ASCII_MAPS_AND_EXTRAS
static | $ASCII_EXTRAS
static | $ORD
static | $LANGUAGE_MAX_KEY
static | $REGEX_ASCII = "[^\x09\x10\x13\x0A\x0D\x20-\x7E]"
static | $BIDI_UNI_CODE_CONTROLS_TABLE

Description détaillée

-immutable

Documentation des fonctions membres

◆ charsArray()

static charsArray ( bool $replace_extra_symbols = false )
static

Returns an replacement array for ASCII methods.

EXAMPLE: $array = ASCII::charsArray(); var_dump($array['ru']['б']); // 'b'

-suppress InvalidNullableReturnType - we use the prepare* methods here, so we don't get NULL here

Paramètres
bool $replace_extra_symbols [optional]

Add some more replacements e.g. "£" with " pound ".

-pure

Renvoie
array

-return array<string, array<string , string>>

◆ clean()

static clean | ( | string | $str,
 |  | bool | $normalize_whitespace = true,
 |  | bool | $keep_non_breaking_space = false,
 |  | bool | $normalize_msword = true,
 |  | bool | $remove_invisible_characters = true
 | ) |  |
static

Accepts a string and removes all non-UTF-8 characters from it + extras if needed.

Paramètres
string $str

The string to be sanitized.

Paramètres
bool $normalize_whitespace [optional]

Set to true, if you need to normalize the whitespace.

Paramètres
bool $normalize_msword [optional]

Set to true, if you need to normalize MS Word chars e.g.: "…" => "..."

Paramètres
bool $keep_non_breaking_space [optional]

Set to true, to keep non-breaking-spaces, in combination with $normalize_whitespace

Paramètres
bool $remove_invisible_characters [optional]

Set to false, if you not want to remove invisible characters e.g.: "\0"

-pure

Renvoie
string

A clean UTF-8 string.

◆ get_language()

static get_language ( string $language )
staticprivate

Get the language from a string.

e.g.: de_at -> de_at de_DE -> de DE_DE -> de de-de -> de

ReturnTypeCanBeDeclaredInspection

Paramètres
string $language -pure
Renvoie
string

Références $language.

◆ getAllLanguages()

static static getAllLanguages ( )
static

Get all languages from the constants "ASCII::.*LANGUAGE_CODE".

Renvoie
string[]

-return array<string, string>

Références $lang.

◆ getData()

static getData ( string $file )
staticprivate

Get data from "/data/*.php".

ReturnTypeCanBeDeclaredInspection

Paramètres
string $file -pure
Renvoie
array<mixed>

PhpIncludeInspection

UsingInclusionReturnValueInspection
-suppress UnresolvableInclude

Références __DIR__.

◆ getDataIfExists()

static getDataIfExists ( string $file )
staticprivate

Get data from "/data/*.php".

Paramètres
string $file -pure
Renvoie
array<mixed>

-suppress ImpureFunctionCall

PhpIncludeInspection

UsingInclusionReturnValueInspection
-suppress UnresolvableInclude

Références __DIR__.

◆ is_ascii()

static is_ascii ( string $str )
static

Checks if a string is 7 bit ASCII.

EXAMPLE: ASCII::is_ascii('白'); // false

Paramètres
string $str

The string to check.

-pure

Renvoie
bool

true if it is ASCII
false otherwise

◆ prepareAsciiAndExtrasMaps()

static prepareAsciiAndExtrasMaps ( )
staticprivate

-pure

Renvoie
void

-suppress PossiblyNullArgument - we use the prepare* methods here, so we don't get NULL here

Références null.

◆ prepareAsciiExtras()

static prepareAsciiExtras ( )
staticprivate

-pure

Renvoie
void

Références null.

◆ prepareAsciiMaps()

static prepareAsciiMaps ( )
staticprivate

-pure

Renvoie
void

Références null.

◆ remove_invisible_characters()

static remove_invisible_characters | ( | string | $str,
 |  | bool | $url_encoded = false,
 |  | string | $replacement = '',
 |  | bool | $keep_basic_control_characters = true
 | ) |  |
static

Remove invisible characters from a string.

e.g.: This prevents sandwiching null characters between ascii characters, like Java\0script.

copy&past from https://github.com/bcit-ci/CodeIgniter/blob/develop/system/core/Common.php

Paramètres
string | $str
bool | $url_encoded
string | $replacement
bool | $keep_basic_control_characters | -pure
Renvoie
string

Références $count.

◆ to_filename()

static to_filename | ( | string | $str,
 |  | bool | $use_transliterate = true,
 |  | string | $fallback_char = '-'
 | ) |  |
static

Convert given string to safe filename (and keep string case).

EXAMPLE: ASCII::to_filename('שדגשדג.png', true)); // 'shdgshdg.png'

Paramètres
string | $str
bool | $use_transliterate

ASCII::to_transliterate() is used by default - unsafe characters are simply replaced with hyphen otherwise.

Paramètres
string $fallback_char -pure
Renvoie
string

A string that contains only safe characters for a filename.

◆ to_slugify()

static to_slugify | ( | string | $str,
 |  | string | $separator = '-',
 |  | string | $language = self::ENGLISH_LANGUAGE_CODE,
 |  | array | $replacements = [],
 |  | bool | $replace_extra_symbols = false,
 |  | bool | $use_str_to_lower = true,
 |  | bool | $use_transliterate = false
 | ) |  |
static

Converts the string into an URL slug. This includes replacing non-ASCII characters with their closest ASCII equivalents, removing remaining non-ASCII and non-alphanumeric characters, and replacing whitespace with $separator. The separator defaults to a single dash, and the string is also converted to lowercase. The language of the source string can also be supplied for language-specific transliteration.

Paramètres
string | $str
string | $separator | [optional]

The string used to replace whitespace.

Paramètres
string $language [optional]

Language of the source string. (default is 'en') | ASCII::*_LANGUAGE_CODE

Paramètres
array<string,string> $replacements [optional]

A map of replaceable strings.

Paramètres
bool $replace_extra_symbols [optional]

Add some more replacements e.g. "£" with " pound ".

Paramètres
bool $use_str_to_lower [optional]

Use "string to lower" for the input.

Paramètres
bool $use_transliterate [optional]

Use ASCII::to_transliterate() for unknown chars.

-pure

Renvoie
string

A string that has been converted to an URL slug.

Références $language, et $separator.

Documentation des champs

◆ $ASCII_EXTRAS

$ASCII_EXTRAS
staticprivate

◆ $ASCII_MAPS

$ASCII_MAPS
staticprivate

◆ $ASCII_MAPS_AND_EXTRAS

$ASCII_MAPS_AND_EXTRAS
staticprivate

◆ $BIDI_UNI_CODE_CONTROLS_TABLE

$BIDI_UNI_CODE_CONTROLS_TABLE
staticprivate
Valeur initiale :
= [
8234 => "\xE2\x80\xAA"

◆ $LANGUAGE_MAX_KEY

$LANGUAGE_MAX_KEY
staticprivate

◆ $ORD

$ORD
staticprivate

◆ $REGEX_ASCII

$REGEX_ASCII = "[^\x09\x10\x13\x0A\x0D\x20-\x7E]"
staticprivate

◆ AMHARIC_LANGUAGE_CODE

const AMHARIC_LANGUAGE_CODE = 'am'

◆ ARABIC_LANGUAGE_CODE

const ARABIC_LANGUAGE_CODE = 'ar'

◆ ARMENIAN_LANGUAGE_CODE

const ARMENIAN_LANGUAGE_CODE = 'hy'

◆ AZERBAIJANI_LANGUAGE_CODE

const AZERBAIJANI_LANGUAGE_CODE = 'az'

◆ BELARUSIAN_LANGUAGE_CODE

const BELARUSIAN_LANGUAGE_CODE = 'be'

◆ BENGALI_LANGUAGE_CODE

const BENGALI_LANGUAGE_CODE = 'bn'

◆ BULGARIAN_LANGUAGE_CODE

const BULGARIAN_LANGUAGE_CODE = 'bg'

◆ CHINESE_LANGUAGE_CODE

const CHINESE_LANGUAGE_CODE = 'zh'

◆ CROATIAN_LANGUAGE_CODE

const CROATIAN_LANGUAGE_CODE = 'hr'

◆ CZECH_LANGUAGE_CODE

const CZECH_LANGUAGE_CODE = 'cs'

◆ DANISH_LANGUAGE_CODE

const DANISH_LANGUAGE_CODE = 'da'

◆ DUTCH_LANGUAGE_CODE

const DUTCH_LANGUAGE_CODE = 'nl'

◆ ENGLISH_LANGUAGE_CODE

const ENGLISH_LANGUAGE_CODE = 'en'

◆ ESPERANTO_LANGUAGE_CODE

const ESPERANTO_LANGUAGE_CODE = 'eo'

◆ ESTONIAN_LANGUAGE_CODE

const ESTONIAN_LANGUAGE_CODE = 'et'

◆ EXTRA_LATIN_CHARS_LANGUAGE_CODE

const EXTRA_LATIN_CHARS_LANGUAGE_CODE = 'latin'

◆ EXTRA_MSWORD_CHARS_LANGUAGE_CODE

const EXTRA_MSWORD_CHARS_LANGUAGE_CODE = 'msword'

◆ EXTRA_WHITESPACE_CHARS_LANGUAGE_CODE

const EXTRA_WHITESPACE_CHARS_LANGUAGE_CODE = ' '

◆ FINNISH_LANGUAGE_CODE

const FINNISH_LANGUAGE_CODE = 'fi'

◆ FRENCH_AUSTRIAN_LANGUAGE_CODE

const FRENCH_AUSTRIAN_LANGUAGE_CODE = 'fr_at'

◆ FRENCH_LANGUAGE_CODE

const FRENCH_LANGUAGE_CODE = 'fr'

◆ FRENCH_SWITZERLAND_LANGUAGE_CODE

const FRENCH_SWITZERLAND_LANGUAGE_CODE = 'fr_ch'

◆ GEORGIAN_LANGUAGE_CODE

const GEORGIAN_LANGUAGE_CODE = 'ka'

◆ GERMAN_AUSTRIAN_LANGUAGE_CODE

const GERMAN_AUSTRIAN_LANGUAGE_CODE = 'de_at'

◆ GERMAN_LANGUAGE_CODE

const GERMAN_LANGUAGE_CODE = 'de'

◆ GERMAN_SWITZERLAND_LANGUAGE_CODE

const GERMAN_SWITZERLAND_LANGUAGE_CODE = 'de_ch'

◆ GREEK_LANGUAGE_CODE

const GREEK_LANGUAGE_CODE = 'el'

◆ GREEKLISH_LANGUAGE_CODE

const GREEKLISH_LANGUAGE_CODE = 'el__greeklish'

◆ HINDI_LANGUAGE_CODE

const HINDI_LANGUAGE_CODE = 'hi'

◆ HUNGARIAN_LANGUAGE_CODE

const HUNGARIAN_LANGUAGE_CODE = 'hu'

◆ ITALIAN_LANGUAGE_CODE

const ITALIAN_LANGUAGE_CODE = 'it'

◆ JAPANESE_LANGUAGE_CODE

const JAPANESE_LANGUAGE_CODE = 'ja'

◆ KAZAKH_LANGUAGE_CODE

const KAZAKH_LANGUAGE_CODE = 'kk'

◆ KIRGHIZ_LANGUAGE_CODE

const KIRGHIZ_LANGUAGE_CODE = 'ky'

◆ KOREAN_LANGUAGE_CODE

const KOREAN_LANGUAGE_CODE = 'ko'

◆ LATVIAN_LANGUAGE_CODE

const LATVIAN_LANGUAGE_CODE = 'lv'

◆ LITHUANIAN_LANGUAGE_CODE

const LITHUANIAN_LANGUAGE_CODE = 'lt'

◆ MACEDONIAN_LANGUAGE_CODE

const MACEDONIAN_LANGUAGE_CODE = 'mk'

◆ MONGOLIAN_LANGUAGE_CODE

const MONGOLIAN_LANGUAGE_CODE = 'mn'

◆ MYANMAR_LANGUAGE_CODE

const MYANMAR_LANGUAGE_CODE = 'my'

◆ NORWEGIAN_LANGUAGE_CODE

const NORWEGIAN_LANGUAGE_CODE = 'no'

◆ ORIYA_LANGUAGE_CODE

const ORIYA_LANGUAGE_CODE = 'or'

◆ PASHTO_LANGUAGE_CODE

const PASHTO_LANGUAGE_CODE = 'ps'

◆ PERSIAN_LANGUAGE_CODE

const PERSIAN_LANGUAGE_CODE = 'fa'

◆ POLISH_LANGUAGE_CODE

const POLISH_LANGUAGE_CODE = 'pl'

◆ PORTUGUESE_LANGUAGE_CODE

const PORTUGUESE_LANGUAGE_CODE = 'pt'

◆ ROMANIAN_LANGUAGE_CODE

const ROMANIAN_LANGUAGE_CODE = 'ro'

◆ RUSSIAN_GOST_2000_B_LANGUAGE_CODE

const RUSSIAN_GOST_2000_B_LANGUAGE_CODE = 'ru__gost_2000_b'

◆ RUSSIAN_LANGUAGE_CODE

const RUSSIAN_LANGUAGE_CODE = 'ru'

◆ RUSSIAN_PASSPORT_2013_LANGUAGE_CODE

const RUSSIAN_PASSPORT_2013_LANGUAGE_CODE = 'ru__passport_2013'

◆ SERBIAN_CYRILLIC_LANGUAGE_CODE

const SERBIAN_CYRILLIC_LANGUAGE_CODE = 'sr__cyr'

◆ SERBIAN_LANGUAGE_CODE

const SERBIAN_LANGUAGE_CODE = 'sr'

◆ SERBIAN_LATIN_LANGUAGE_CODE

const SERBIAN_LATIN_LANGUAGE_CODE = 'sr__lat'

◆ SLOVAK_LANGUAGE_CODE

const SLOVAK_LANGUAGE_CODE = 'sk'

◆ SWEDISH_LANGUAGE_CODE

const SWEDISH_LANGUAGE_CODE = 'sv'

◆ THAI_LANGUAGE_CODE

const THAI_LANGUAGE_CODE = 'th'

◆ TURKISH_LANGUAGE_CODE

const TURKISH_LANGUAGE_CODE = 'tr'

◆ TURKMEN_LANGUAGE_CODE

const TURKMEN_LANGUAGE_CODE = 'tk'

◆ UKRAINIAN_LANGUAGE_CODE

const UKRAINIAN_LANGUAGE_CODE = 'uk'

◆ UZBEK_LANGUAGE_CODE

const UZBEK_LANGUAGE_CODE = 'uz'

◆ VIETNAMESE_LANGUAGE_CODE

const VIETNAMESE_LANGUAGE_CODE = 'vi'
La documentation de cette classe a été générée à partir du fichier suivant :
  • ASCII.php


Joomla CMS: Référence de la classe Bootup

  • voku
  • helper
  • Bootup
Fonctions membres publiques statiques
Référence de la classe Bootup

Fonctions membres publiques statiques

static | filterRequestInputs (int $normalization_form=\Normalizer::NFC, string $leading_combining='◌')
static | filterRequestUri ($uri=null, bool $exit=true)
static | filterString ( $input, int $normalization_form=\Normalizer::NFC, string $leading_combining='◌')
static | get_random_bytes ($length)
static | initAll ()

Description détaillée

-immutable

Documentation des fonctions membres

◆ filterRequestInputs()

static filterRequestInputs | ( | int | $normalization_form = \Normalizer::NFC,
 |  | string | $leading_combining = '◌'
 | ) |  |
static

filter request inputs

Ensures inputs are well formed UTF-8 When not, assumes Windows-1252 and converts to UTF-8 Tests only values, not keys

Paramètres
int | $normalization_form
string | $leading_combining
Renvoie
bool
Obsolète:

This method will be removed in future releases, so please don't use it anymore.

ReferenceMismatchInspection

ForeachSourceInspection

ReferenceMismatchInspection

ForeachSourceInspection
ReferenceMismatchInspection

Références $i, et $r.

◆ filterRequestUri()

static filterRequestUri | ( |  | $uri = null,
 |  | bool | $exit = true
 | ) |  |
static

Filter current REQUEST_URI .

Paramètres
string | null $uri

If null is set, then the server REQUEST_URI will be used.

Paramètres
bool $exit
Renvoie
mixed
Obsolète:

This method will be removed in future releases, so please don't use it anymore.

Paramètres
array $m
Renvoie
string
Paramètres
array $m
Renvoie
string

Références $uri, false, et null.

◆ filterString()

static filterString | ( |  | $input,
 |  | int | $normalization_form = \Normalizer::NFC,
 |  | string | $leading_combining = '◌'
 | ) |  |
static

Normalizes to UTF-8 NFC, converting from WINDOWS-1252 when needed.

Paramètres
mixed | $input
int | $normalization_form
string | $leading_combining
Renvoie
mixed

Références $input.

◆ get_random_bytes()

static get_random_bytes ( $length )
static

Get random bytes via "random_bytes()"

Paramètres
int $length

output length

Exceptions

◆ initAll()

static initAll ( )
static
Renvoie
bool

Références $result.

La documentation de cette classe a été générée à partir du fichier suivant :
  • Bootup.php


Joomla CMS: Référence de la classe Catalan

  • Wamania
  • Snowball
  • Stemmer
  • Catalan
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Catalan
+ Graphe d'héritage de Catalan:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = ['a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'à', 'è', 'ï', 'ò', 'ü']
static | $standard_suffix_1a
static | $attached_pronoun
static | $verb_suffixes
static | $residual_suffixes
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1a ()
step1b ()
step2 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

Orestes Sanchez Benavente orest.nosp@m.es@e.nosp@m.stoti.nosp@m.enea.nosp@m.rregl.nosp@m.o.es Some fine tuning was necessary in this implementation of the original catalan stemmer algorithm in Snowball: Some suffix sets have overlapping items, so here all items are sorted by decreasing size, to prevent that a shorter suffix will skip a larger one. Some alternatives (or operator in Snowball) in the original algorithm have been rearranged to make sure they are applied in the right order. Based on the reference Snowball implementation by Israel Olalla of iSOCO

Documentation des fonctions membres

◆ finish()

finish ( )
private

And finally: Remove accents and l aggeminades

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

◆ step0()

step0 ( )
private

Step 0: Attached pronoun

Search for the longest among the following suffixes and delete it in R1.

◆ step1a()

step1a ( )
private

Step 1a: Standard suffix

◆ step1b()

step1b ( )
private

Step 1b: Verb suffixes Search for the longest among the following suffixes in r1 and r2, and perform the action indicated.

◆ step2()

step2 ( )
private

Step 2: residual suffix Search for the longest among the following suffixes in R1, and perform the action indicated.

Documentation des champs

◆ $attached_pronoun

$attached_pronoun
staticprotected
Valeur initiale :
= [
'selas', 'selos', '\'hi', '\'ho', '\'ls', '-les', '-nos', '\'ns', 'sela', 'selo', '\'s', '\'l', '-ls', '-la',
'-li', 'vos', 'nos', '-us', '\' n ', '-ns', '\'m', '-me', '-te', '\'t', 'los', 'las', 'les', 'ens', 'se', 'us',
'-n ', '-m', 'li', 'lo', 'me', 'le', 'la', 'ho', 'hi'
]

◆ $residual_suffixes

$residual_suffixes
staticprotected
Valeur initiale :
= [
'itz', 'it', 'os', 'eu', 'iu', 'is', 'ir', 'ïn', 'ïs', 'a', 'o', 'á', 'à', 'í', 'ó', 'e', 'é', 'i', 's', 'ì',
'ï'
]

◆ $standard_suffix_1a

$standard_suffix_1a
staticprotected
Valeur initiale :
= [
'allengües', 'ativitats', 'bilitats', 'ionistes', 'ialistes', 'ialismes', 'ativitat', 'atòries', 'isament',
'bilitat', 'ivitats', 'ionisme', 'ionista', 'ialista', 'ialisme', 'íssimes', 'formes', 'ivisme', 'aments',
'nça', 'ificar', 'idores', 'ancies', 'atòria', 'ivitat', 'encies', 'ències', 'atives', 'íssima', 'íssims',
'ictes', 'eries', 'itats', 'itzar', 'ament', 'ments', 'sfera', 'ícies', 'àries', 'cions', 'ístic', 'issos',
'íssem', 'íssiu', 'issem', 'isseu', 'ísseu', 'dores', 'adura', 'ívola', 'ables', 'adors', 'idors', 'adora',
'doras', 'dures', 'ancia', 'toris', 'encia', 'ència', 'ïtats', 'atius', 'ativa', 'ibles', 'asses', 'assos',
'íssim', 'ìssem', 'ìsseu', 'ìssin', 'ismes', 'istes', 'inies', 'íinia', 'ínies', 'trius', 'atge', 'icte',
'ells', 'ella', 'essa', 'eres', 'ines', 'able', 'itat', 'ives', 'ment', 'amen', 'iste', 'aire', 'eria',
'eses', 'esos', 'ícia', 'icis', 'ícis', 'ària', 'alla', 'nces', 'enca', 'issa', 'dora', 'dors', 'bles',
'ívol', 'egar', 'ejar', 'itar', 'ació', 'ants', 'tori', 'ions', 'isam', 'ores', 'aris', 'ïtat', 'atiu',
'ible', 'assa', 'ents', 'imes', 'isme', 'ista', 'inia', 'ites', 'triu', 'oses', 'osos', 'ient', 'otes',
'ell', 'esc', 'ets', 'eta', 'ers', 'ina', 'iva', 'ius', 'fer', 'als', 'era', 'ana', 'esa', 'ici', 'íci',
'ció', 'dor', 'all', 'enc', 'osa', 'ble', 'dís', 'dur', 'ant', 'ats', 'ota', 'ors', 'ora', 'ari', 'uts',
'uds', 'ent', 'ims', 'ima', 'ita', 'ar', 'és', 'ès', 'et', 'ls', 'ió', 'ot', 'al', 'or', 'il', 'ís', 'ós',
'ud', 'ots', 'ó'
]

◆ $verb_suffixes

$verb_suffixes
staticprotected
Valeur initiale :
= [
'aríamos', 'eríamos', 'iríamos', 'eresseu', 'iéramos', 'iésemos', 'adores', 'aríais', 'aremos', 'eríais',
'eremos', 'iríais', 'iremos', 'ierais', 'ieseis', 'asteis', 'isteis', 'ábamos', 'áramos', 'ásemos', 'isquen',
'esquin', 'esquis', 'esques', 'esquen', 'ïsquen', 'ïsques', 'adora', 'adors', 'arían', 'arías', 'arian',
'arien', 'aries', 'aréis', 'erían', 'erías', 'eréis', 'erass', 'irían', 'irías', 'iréis', 'asseu', 'esseu',
'àsseu', 'àssem', 'àssim', 'àssiu', 'essen', 'esses', 'assen', 'asses', 'assim', 'assiu', 'éssen', 'ésseu',
'éssim', 'éssiu', 'éssem', 'aríem', 'aríeu', 'eixer', 'eixes', 'ieran', 'iesen', 'ieron', 'iendo', 'essin',
'essis', 'assin', 'assis', 'essim', 'èssim', 'èssiu', 'ieras', 'ieses', 'abais', 'arais', 'aseis', 'íamos',
'irien', 'iries', 'irìem', 'irìeu', 'iguem', 'igueu', 'esqui', 'eixin', 'eixis', 'eixen', 'iríem', 'iríeu',
'atges', 'issen', 'isses', 'issin', 'issis', 'issiu', 'issim', 'ïssin', 'íssiu', 'íssim', 'ïssis', 'ïguem',
'ïgueu', 'ïssen', 'ïsses', 'itzeu', 'itzis', 'ador', 'ents', 'udes', 'eren', 'arán', 'arás', 'aria', 'aràs',
'aría', 'arés', 'erán', 'erás', 'ería', 'erau', 'irán', 'irás', 'iría', 'írem', 'íreu', 'aves', 'avem', 'ávem',
'àvem', 'àveu', 'áveu', 'aven', 'ares', 'àrem', 'àreu', 'àren', 'areu', 'aren', 'tzar', 'ides', 'ïdes', 'ades',
'iera', 'iese', 'aste', 'iste', 'aban', 'aran', 'asen', 'aron', 'abas', 'adas', 'idas', 'aras', 'ases', 'íais',
'ados', 'idos', 'amos', 'imos', 'ques', 'iran', 'irem', 'iren', 'ires', 'ireu', 'iria', 'iràs', 'eixi', 'eixo',
'isin', 'isis', 'esca', 'isca', 'ïsca', 'ïren', 'ïres', 'ïxen', 'ïxes', 'ixen', 'ixes', 'inin', 'inis', 'ineu',
'itza', 'itzi', 'itzo', 'itzà', 'arem', 'ent', 'arà', 'ará', 'ara', 'aré', 'erá', 'eré', 'irá', 'iré', 'íeu',
'ies', 'íem', 'ìeu', 'ien', 'uda', 'ava', 'ats', 'ant', 'ïen', 'ams', 'ïes', 'dre', 'eix', 'ïda', 'aba', 'ada',
'ida', 'its', 'ids', 'ase', 'ían', 'ado', 'ido', 'ieu', 'ess', 'ass', 'ías', 'áis', 'ira', 'irà', 'irè', 'sis',
'sin', 'int', 'isc', 'ïsc', 'ïra', 'ïxo', 'ixo', 'ixa', 'ini', 'itz', 'iïn', 're', 'ie', 'er', 'ia', 'at', 'ut',
'au', 'ïm', 'ïu', 'és', 'en', 'es', 'em', 'am', 'ïa', 'it', 'ït', 'ía', 'ad', 'ed', 'id', 'an', 'ió', 'ar',
'ir', 'as', 'ii', 'io', 'ià', 'ís', 'ïx', 'ix', 'in', 'às', 'iï', 'iïs', 'í'
]

◆ $vowels

$vowels = ['a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'à', 'è', 'ï', 'ò', 'ü']
staticprotected

All catalan vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Catalan.php


Joomla CMS: Référence de la classe Danish

  • Wamania
  • Snowball
  • Stemmer
  • Danish
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Danish
+ Graphe d'héritage de Danish:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'æ', 'å', 'ø')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

hasValidSEnding ($word)
step1 ()
step2 ()
step3 ()
step4 ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ hasValidSEnding()

hasValidSEnding ( $word )
private

Define a valid s-ending as one of a b c d f g h j k l m n o p r t v y z å

Paramètres
string $ending
Renvoie
boolean

Références Stem\$word.

Référencé par Danish\step1().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Stem\r1(), Danish\step1(), Danish\step2(), Danish\step3(), et Danish\step4().

◆ step1()

step1 ( )
private

Step 1 Search for the longest among the following suffixes in R1, and perform the action indicated.

Références $position, Stem\$word, Danish\hasValidSEnding(), et Stem\searchIfInR1().

Référencé par Danish\stem().

◆ step2()

step2 ( )
private

Step 2 Search for one of the following suffixes in R1, and if found delete the last letter. gd dt gt kt

Références Stem\searchIfInR1().

Référencé par Danish\stem(), et Danish\step3().

◆ step3()

step3 ( )
private

Step 3:

Références $position, Stem\search(), Stem\searchIfInR1(), et Danish\step2().

Référencé par Danish\stem().

◆ step4()

step4 ( )
private

Step 4: undouble If the word ends with double consonant in R1, remove one of the consonants.

Références Stem\inR1().

Référencé par Danish\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'æ', 'å', 'ø')
staticprotected

All danish vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Danish.php


Joomla CMS: Référence de la classe Dutch

  • Wamania
  • Snowball
  • Stemmer
  • Dutch
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Dutch
+ Graphe d'héritage de Dutch:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'è')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

hasValidSEnding ($word)
hasValidEnEnding ($word)
unDoubling ()
step1 ()
step2 ()
step3a ()
step3b ($removedE)
step4 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

Finally Turn I and Y back into lower case.

Référencé par Dutch\stem().

◆ hasValidEnEnding()

hasValidEnEnding ( $word )
private

Define a valid en-ending as a non-vowel, and not gem.

Paramètres
string $ending
Renvoie
boolean

Références Stem\$word.

Référencé par Dutch\step1(), et Dutch\step3a().

◆ hasValidSEnding()

hasValidSEnding ( $word )
private

Define a valid s-ending as a non-vowel other than j.

Paramètres
string $ending
Renvoie
boolean

Références Stem\$word.

Référencé par Dutch\step1().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références $this, Stem\$word, Dutch\finish(), Stem\r1(), Stem\r2(), Dutch\step1(), Dutch\step2(), Dutch\step3a(), Dutch\step3b(), et Dutch\step4().

◆ step1()

step1 ( )
private

Step 1 Search for the longest among the following suffixes, and perform the action indicated

Références $position, Stem\$word, Dutch\hasValidEnEnding(), Dutch\hasValidSEnding(), Stem\inR1(), Stem\search(), et Dutch\unDoubling().

Référencé par Dutch\stem().

◆ step2()

step2 ( )
private

Step 2 Delete suffix e if in R1 and preceded by a non-vowel, and then undouble the ending

Références $position, Stem\inR1(), Stem\search(), et Dutch\unDoubling().

Référencé par Dutch\stem(), et Dutch\step3b().

◆ step3a()

step3a ( )
private

Step 3a: heid delete heid if in R2 and not preceded by c, and treat a preceding en as in step 1(b)

Références $position, Stem\$word, Dutch\hasValidEnEnding(), Stem\inR1(), Stem\inR2(), Stem\search(), et Dutch\unDoubling().

Référencé par Dutch\stem().

◆ step3b()

step3b ( $removedE )
private

Step 3b: d-suffixe Search for the longest among the following suffixes, and perform the action indicated.

Références $position, Stem\inR2(), Stem\search(), Stem\searchIfInR2(), Dutch\step2(), et Dutch\unDoubling().

Référencé par Dutch\stem().

◆ step4()

step4 ( )
private

Step 4: undouble vowel If the words ends CVD, where C is a non-vowel, D is a non-vowel other than I, and V is double a, e, o or u, remove one of the vowels from V (for example, maan -> man, brood -> brod).

Références $c.

Référencé par Dutch\stem().

◆ unDoubling()

unDoubling ( )
private

Define undoubling the ending as removing the last letter if the word ends kk, dd or tt.

Références Stem\search().

Référencé par Dutch\step1(), Dutch\step2(), Dutch\step3a(), et Dutch\step3b().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'è')
staticprotected

All dutch vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Dutch.php


Joomla CMS: Référence de la classe English

  • Wamania
  • Snowball
  • Stemmer
  • English
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe English
+ Graphe d'héritage de English:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')
static | $doubles = array('bb', 'dd', 'ff', 'gg', 'mm', 'nn', 'pp', 'rr', 'tt')
static | $liEnding = array('c', 'd', 'e', 'g', 'h', 'k', 'm', 'n', 'r', 't')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1a ()
step1b ()
step1c ()
step2 ()
step3 ()
step4 ()
step5 ()
finish ()
exceptionR1 ()
exception1 ()
exception2 ()
isShort ()
searchShortSyllabe ($from, $nbLetters)

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

English Porter 2

wamania

Documentation des fonctions membres

◆ exception1()

exception1 ( )
private

1/ Stem certain special words as follows, 2/ If one of the following is found, leave it invariant,

Références Stem\$word, et null.

Référencé par English\stem().

◆ exception2()

exception2 ( )
private

Following step 1a, leave the following invariant,

Références Stem\$word, et null.

Référencé par English\stem().

◆ exceptionR1()

exceptionR1 ( )
private

Références elseif, et Stem\r1().

Référencé par English\stem().

◆ finish()

finish ( )
private

Référencé par English\stem().

◆ isShort()

isShort ( )
private

A word is called short if it ends in a short syllable, and if R1 is null. Note : R1 not really null, but the word at this state must be smaller than r1 index

Renvoie
boolean

Références English\searchShortSyllabe().

Référencé par English\step1b().

◆ searchShortSyllabe()

searchShortSyllabe | ( | $from,
 |  | $nbLetters
 | ) |
private

Define a short syllable in a word as either (a) a vowel followed by a non-vowel other than w, x or Y and preceded by a non-vowel, or * (b) a vowel at the beginning of the word followed by a non-vowel.

So rap, trap, entrap end with a short syllable, and ow, on, at are classed as short syllables. But uproot, bestow, disturb do not end with a short syllable.

Référencé par English\isShort(), et English\step5().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références $this, Stem\$word, English\exception1(), English\exception2(), English\exceptionR1(), English\finish(), null, Stem\r1(), Stem\r2(), English\step0(), English\step1a(), English\step1b(), English\step1c(), English\step2(), English\step3(), English\step4(), et English\step5().

◆ step0()

step0 ( )
private

Step 0 Remove ', 's, 's'

Références $position, et Stem\search().

Référencé par English\stem().

◆ step1a()

step1a ( )
private

Références $i, $position, et Stem\search().

Référencé par English\stem().

◆ step1b()

step1b ( )
private

Step 1b

Références $i, $position, elseif, Stem\inR1(), English\isShort(), et Stem\search().

Référencé par English\stem().

◆ step1c()

step1c ( )
private

Step 1c: *

Références $position, et Stem\search().

Référencé par English\stem().

◆ step2()

step2 ( )
private

Step 2 Search for the longest among the following suffixes, and, if found and in R1, perform the action indicated.

Références $position, Stem\inR1(), et Stem\search().

Référencé par English\stem().

◆ step3()

step3 ( )
private

Step 3: Search for the longest among the following suffixes, and, if found and in R1, perform the action indicated.

Références $position, Stem\inR2(), et Stem\searchIfInR1().

Référencé par English\stem().

◆ step4()

step4 ( )
private

Step 4 Search for the longest among the following suffixes, and, if found and in R2, perform the action indicated.

Références $position, Stem\inR2(), Stem\search(), et Stem\searchIfInR2().

Référencé par English\stem().

◆ step5()

step5 ( )
private

Step 5: * Search for the the following suffixes, and, if found, perform the action indicated.

Références $position, elseif, Stem\inR1(), Stem\inR2(), Stem\search(), Stem\searchIfInR2(), et English\searchShortSyllabe().

Référencé par English\stem().

Documentation des champs

◆ $doubles

$doubles = array('bb', 'dd', 'ff', 'gg', 'mm', 'nn', 'pp', 'rr', 'tt')
staticprotected

◆ $liEnding

$liEnding = array('c', 'd', 'e', 'g', 'h', 'k', 'm', 'n', 'r', 't')
staticprotected

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y')
staticprotected

All english vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • English.php


Joomla CMS: Référence de la classe Finnish

  • Wamania
  • Snowball
  • Stemmer
  • Finnish
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées | Attributs privés
Référence de la classe Finnish
+ Graphe d'héritage de Finnish:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'ö')
static | $consonants
static | $restrictedVowels = array('a', 'e', 'i', 'o', 'u', 'ä', 'ö')
static | $longVowels = array('aa', 'ee', 'ii', 'oo', 'uu', 'ää', 'öö')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step1 ()
step2 ()
step3 ()
step4 ()
step5 ()
step6 ()

Attributs privés

$_removedInStep3 = false

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

Finnish Snowball Stemmer.

msaari

Documentation des fonctions membres

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Stem\r1(), Stem\r2(), Finnish\step1(), Finnish\step2(), Finnish\step3(), Finnish\step4(), Finnish\step5(), et Finnish\step6().

◆ step1()

step1 ( )
private

Step 1

Search for the longest among the following suffixes in R1, and perform the action indicated.

Renvoie
boolean True when something is done.

Références $position, Stem\inR2(), Stem\r1(), Stem\r2(), et Stem\searchIfInR1().

Référencé par Finnish\stem().

◆ step2()

step2 ( )
private

Step 2: possessives.

Search for the longest among the following suffixes in R1, and perform the action indicated.

Renvoie
boolean True when something is done.

Références $position, Stem\$word, Stem\r1(), Stem\r2(), Stem\search(), et Stem\searchIfInR1().

Référencé par Finnish\stem().

◆ step3()

step3 ( )
private

Step 3: cases

Search for the longest among the following suffixes in R1, and perform the action indicated.

Renvoie
boolean True when something is done.

Références $position, Stem\r1(), Stem\r2(), et Stem\searchIfInR1().

Référencé par Finnish\stem().

◆ step4()

step4 ( )
private

Step 4: other endings

Search for the longest among the following suffixes in R2, and perform the action indicated

Renvoie
boolean True when something is done.

Références $position, Stem\r1(), Stem\r2(), et Stem\searchIfInR2().

Référencé par Finnish\stem().

◆ step5()

step5 ( )
private

Step 5: plurals If an ending was removed in step 3, delete a final i or j if in R1; otherwise, if an ending was not removed in step 3, delete a final t in R1 if it follows a vowel, and, if a t is removed, delete a final mma or imma in R2, unless the mma is preceded by po.

Renvoie
boolean True when something is done.

Références $position, elseif, Stem\r1(), Stem\r2(), Stem\searchIfInR1(), et Stem\searchIfInR2().

Référencé par Finnish\stem().

◆ step6()

step6 ( )
private

Step 6: tidying up

Do in turn steps (a), (b), (c), (d), restricting all tests to the region R1.

Références $i, $position, Stem\r1(), Stem\r2(), et Stem\searchIfInR1().

Référencé par Finnish\stem().

Documentation des champs

◆ $_removedInStep3

$_removedInStep3 = false
private

◆ $consonants

$consonants
staticprotected
Valeur initiale :
= array('b', 'c', 'd', 'f', 'g', 'h', 'j',
'k', 'l', 'm', 'n', 'p', 'q', 'r', 's', 't', 'v', 'w', 'x', 'z')

◆ $longVowels

$longVowels = array('aa', 'ee', 'ii', 'oo', 'uu', 'ää', 'öö')
staticprotected

Long restricted vowels, ie. doubled vowels.

◆ $restrictedVowels

$restrictedVowels = array('a', 'e', 'i', 'o', 'u', 'ä', 'ö')
staticprotected

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'ö')
staticprotected

All swedish vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Finnish.php


Joomla CMS: Référence de la classe French

  • Wamania
  • Snowball
  • Stemmer
  • French
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées
Référence de la classe French
+ Graphe d'héritage de French:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Fonctions membres protégées

rv ()
- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'â', 'à', 'ë', 'é', 'ê', 'è', 'ï', 'î', 'ô', 'û', 'ù')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1 ()
step2a ()
step2b ()
step3 ()
step4 ()
step5 ()
step6 ()
finish ()

Membres hérités additionnels

- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

And finally: Turn any remaining I, U and Y letters in the word back into lower case.

Référencé par French\stem().

◆ rv()

rv ( )
protected

If the word begins with two vowels, RV is the region after the third letter, otherwise the region after the first vowel not at the beginning of the word, or the end of the word if these positions cannot be found. (Exceptionally, par, col or tap, at the begining of a word is also taken to define RV as the region to their right.)

Références $i.

Référencé par French\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, French\finish(), Stem\r1(), Stem\r2(), French\rv(), French\step0(), French\step1(), French\step2a(), French\step2b(), French\step3(), French\step4(), French\step5(), et French\step6().

◆ step0()

step0 ( )
private

Assume the word is in lower case. Then put into upper case u or i preceded and followed by a vowel, and y preceded or followed by a vowel. u after q is also put into upper case. For example, jouer -> joUer ennuie -> ennuIe yeux -> Yeux quand -> qUand

Références $this.

Référencé par French\stem().

◆ step1()

step1 ( )
private

Step 1 Search for the longest among the following suffixes, and perform the action indicated.

Renvoie
integer Next step number

Références $position, elseif, Stem\inR1(), Stem\inR2(), Stem\inRv(), Stem\search(), Stem\searchIfInR2(), et Stem\searchIfInRv().

Référencé par French\stem().

◆ step2a()

step2a ( )
private

Step 2a: Verb suffixes beginning i In steps 2a and 2b all tests are confined to the RV region. Search for the longest among the following suffixes and if found, delete if preceded by a non-vowel. îmes ît îtes i ie ies ir ira irai iraIent irais irait iras irent irez iriez irions irons iront is issaIent issais issait issant issante issantes issants isse issent isses issez issiez issions issons it (Note that the non-vowel itself must also be in RV.)

Références $position, Stem\inRv(), et Stem\searchIfInRv().

Référencé par French\stem().

◆ step2b()

step2b ( )
private

Do step 2b if step 2a was done, but failed to remove a suffix. Step 2b: Other verb suffixes

Références $position, Stem\inR2(), Stem\inRv(), et Stem\searchIfInRv().

Référencé par French\stem().

◆ step3()

step3 ( )
private

Step 3: Replace final Y with i or final ç with c

Référencé par French\stem().

◆ step4()

step4 ( )
private

Step 4: Residual suffix

Références $position, Stem\inR2(), Stem\inRv(), et Stem\searchIfInRv().

Référencé par French\stem().

◆ step5()

step5 ( )
private

Step 5: Undouble If the word ends enn, onn, ett, ell or eill, delete the last letter

Références Stem\search().

Référencé par French\stem().

◆ step6()

step6 ( )
private

Step 6: Un-accent If the words ends é or è followed by at least one non-vowel, remove the accent from the e.

Références $this.

Référencé par French\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'â', 'à', 'ë', 'é', 'ê', 'è', 'ï', 'î', 'ô', 'û', 'ù')
staticprotected

All french vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • French.php


Joomla CMS: Référence de la classe German

  • Wamania
  • Snowball
  • Stemmer
  • German
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe German
+ Graphe d'héritage de German:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'ö', 'ü')
static | $sEndings = array('b', 'd', 'f', 'g', 'h', 'k', 'l', 'm', 'n', 'r' ,'t')
static | $stEndings = array('b', 'd', 'f', 'g', 'h', 'k', 'l', 'm', 'n', 't')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step1 ()
step2 ()
step3 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

Finally

Référencé par German\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références $this, Stem\$word, German\finish(), Stem\r1(), Stem\r2(), German\step1(), German\step2(), et German\step3().

◆ step1()

step1 ( )
private

Step 1

Références $position, Stem\inR1(), et Stem\search().

Référencé par German\stem().

◆ step2()

step2 ( )
private

Step 2

Références $position, Stem\inR1(), et Stem\search().

Référencé par German\stem().

◆ step3()

step3 ( )
private

Step 3: d-suffixes

Références $position, Stem\inR1(), Stem\inR2(), et Stem\search().

Référencé par German\stem().

Documentation des champs

◆ $sEndings

$sEndings = array('b', 'd', 'f', 'g', 'h', 'k', 'l', 'm', 'n', 'r' ,'t')
staticprotected

◆ $stEndings

$stEndings = array('b', 'd', 'f', 'g', 'h', 'k', 'l', 'm', 'n', 't')
staticprotected

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'ö', 'ü')
staticprotected

All German vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • German.php


Joomla CMS: Référence de la classe Italian

  • Wamania
  • Snowball
  • Stemmer
  • Italian
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Italian
+ Graphe d'héritage de Italian:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'à', 'è', 'ì', 'ò', 'ù')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1 ()
step2 ()
step3a ()
step3b ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

Finally turn I and U back into lower case

Référencé par Italian\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références $this, Stem\$word, Italian\finish(), Stem\r1(), Stem\r2(), Stem\rv(), Italian\step0(), Italian\step1(), Italian\step2(), Italian\step3a(), et Italian\step3b().

◆ step0()

step0 ( )
private

Step 0: Attached pronoun

Références $b, $item, $position, $this, Stem\search(), et Stem\searchIfInRv().

Référencé par Italian\stem().

◆ step1()

step1 ( )
private

Step 1: Standard suffix removal

Références $position, elseif, Stem\inR1(), Stem\inR2(), Stem\inRv(), Stem\search(), et Stem\searchIfInR2().

Référencé par Italian\stem().

◆ step2()

step2 ( )
private

Step 2: Verb suffixes Search for the longest among the following suffixes in RV, and if found, delete.

Références $position, et Stem\searchIfInRv().

Référencé par Italian\stem().

◆ step3a()

step3a ( )
private

Step 3a Delete a final a, e, i, o, à, è, ì or ò if it is in RV, and a preceding i if it is in RV

Références Stem\searchIfInRv().

Référencé par Italian\stem().

◆ step3b()

step3b ( )
private

Step 3b Replace final ch (or gh) with c (or g) if in RV (crocch -> crocc)

Références elseif, et Stem\searchIfInRv().

Référencé par Italian\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'à', 'è', 'ì', 'ò', 'ù')
staticprotected

All Italian vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Italian.php


Joomla CMS: Référence de la classe Norwegian

  • Wamania
  • Snowball
  • Stemmer
  • Norwegian
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Norwegian
+ Graphe d'héritage de Norwegian:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'æ', 'å', 'ø')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

hasValidSEnding ($word)
step1 ()
step2 ()
step3 ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ hasValidSEnding()

hasValidSEnding ( $word )
private

Define a valid s-ending as one of b c d f g h j l m n o p r t v y z, or k not preceded by a vowel

Paramètres
string $ending
Renvoie
boolean

Références Stem\$word.

Référencé par Norwegian\step1().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Stem\r1(), Norwegian\step1(), Norwegian\step2(), et Norwegian\step3().

◆ step1()

step1 ( )
private

Step 1 Search for the longest among the following suffixes in R1, and perform the action indicated.

Références $position, Stem\$word, Norwegian\hasValidSEnding(), et Stem\searchIfInR1().

Référencé par Norwegian\stem().

◆ step2()

step2 ( )
private

Step 2 If the word ends dt or vt in R1, delete the t.

Références Stem\searchIfInR1().

Référencé par Norwegian\stem().

◆ step3()

step3 ( )
private

Step 3: Search for the longest among the following suffixes in R1, and if found, delete.

Références $position, et Stem\searchIfInR1().

Référencé par Norwegian\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'æ', 'å', 'ø')
staticprotected

All norwegian vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Norwegian.php


Joomla CMS: Référence de la classe Portuguese

  • Wamania
  • Snowball
  • Stemmer
  • Portuguese
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Portuguese
+ Graphe d'héritage de Portuguese:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'â', 'ê', 'ô')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step1 ()
step2 ()
step3 ()
step4 ()
step5 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

Finally

Référencé par Portuguese\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Portuguese\finish(), Stem\r1(), Stem\r2(), Stem\rv(), Portuguese\step1(), Portuguese\step2(), Portuguese\step3(), Portuguese\step4(), et Portuguese\step5().

◆ step1()

step1 ( )
private

Step 1: Standard suffix removal

Références $position, elseif, Stem\inR1(), Stem\inR2(), Stem\inRv(), Stem\search(), et Stem\searchIfInR2().

Référencé par Portuguese\stem().

◆ step2()

step2 ( )
private

Step 2: Verb suffixes Search for the longest among the following suffixes in RV, and if found, delete.

Références $position, et Stem\searchIfInRv().

Référencé par Portuguese\stem().

◆ step3()

step3 ( )
private

Step 3: d-suffixes

Références Stem\searchIfInRv().

Référencé par Portuguese\stem().

◆ step4()

step4 ( )
private

Step 4

Références $position, et Stem\searchIfInRv().

Référencé par Portuguese\stem().

◆ step5()

step5 ( )
private

Step 5

Références Stem\inRv(), Stem\search(), et Stem\searchIfInRv().

Référencé par Portuguese\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'â', 'ê', 'ô')
staticprotected

All Portuguese vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Portuguese.php


Joomla CMS: Référence de la classe Romanian

  • Wamania
  • Snowball
  • Stemmer
  • Romanian
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Romanian
+ Graphe d'héritage de Romanian:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'ă', 'â', 'e', 'i', 'î', 'o', 'u')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1 ()
step2 ()
step3 ()
step4 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

Finally Turn I, U back into i, u

Référencé par Romanian\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références $this, Stem\$word, Romanian\finish(), Stem\r1(), Stem\r2(), Stem\rv(), Romanian\step0(), Romanian\step1(), Romanian\step2(), Romanian\step3(), et Romanian\step4().

◆ step0()

step0 ( )
private

Step 0: Removal of plurals (and other simplifications) Search for the longest among the following suffixes, and, if it is in R1, perform the action indicated.

Renvoie
boolean

Références $position, Stem\inR1(), et Stem\search().

Référencé par Romanian\stem().

◆ step1()

step1 ( )
private

Step 1: Reduction of combining suffixes Search for the longest among the following suffixes, and, if it is in R1, preform the replacement action indicated. Then repeat this step until no replacement occurs.

Renvoie
boolean

Références $position, Stem\inR1(), et Stem\search().

Référencé par Romanian\stem().

◆ step2()

step2 ( )
private

Step 2: Removal of 'standard' suffixes Search for the longest among the following suffixes, and, if it is in R2, perform the action indicated.

Renvoie
boolean

Références $position, Stem\inR2(), et Stem\search().

Référencé par Romanian\stem().

◆ step3()

step3 ( )
private

Step 3: Removal of verb suffixes Do step 3 if no suffix was removed either by step 1 or step 2.

Renvoie
boolean

Références $position, Stem\inRv(), et Stem\searchIfInRv().

Référencé par Romanian\stem().

◆ step4()

step4 ( )
private

Step 4: Removal of final vowel

Références $position, Stem\inRv(), et Stem\search().

Référencé par Romanian\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'ă', 'â', 'e', 'i', 'î', 'o', 'u')
staticprotected

All Romanian vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Romanian.php


Joomla CMS: Référence de la classe Russian

  • Wamania
  • Snowball
  • Stemmer
  • Russian
Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Russian
+ Graphe d'héritage de Russian:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Fonctions membres protégées

rv ()
- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()

Attributs protégés statiques

static | $vowels = array('а', 'е', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я')
static | $perfectiveGerund
static | $adjective
static | $participle
static | $reflexive = array('ся', 'сь')
static | $verb
static | $noun
static | $superlative = array('ейше', 'ейш')
static | $derivational = array('ость', 'ост')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step1 ()
step2 ()
step3 ()
step4 ()
checkGroup1 ($position)

Membres hérités additionnels

- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ checkGroup1()

checkGroup1 ( $position )
private

group 1 endings must follow а (a) or я (ia)

Paramètres
integer $position
Renvoie
boolean

Références $position, et Stem\inRv().

Référencé par Russian\step1().

◆ rv()

rv ( )
protected

In any word, RV is the region after the first vowel, or the end of the word if it contains no vowel.

Références $i.

Référencé par Russian\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Stem\r1(), Stem\r2(), Russian\rv(), Russian\step1(), Russian\step2(), Russian\step3(), et Russian\step4().

◆ step1()

step1 ( )
private

Step 1: Search for a PERFECTIVE GERUND ending. If one is found remove it, and that is then the end of step 1. Otherwise try and remove a REFLEXIVE ending, and then search in turn for (1) an ADJECTIVAL, (2) a VERB or (3) a NOUN ending. As soon as one of the endings (1) to (3) is found remove it, and terminate step 1.

Références $position, Russian\checkGroup1(), Stem\inRv(), Stem\search(), et Stem\searchIfInRv().

Référencé par Russian\stem().

◆ step2()

step2 ( )
private

Step 2: If the word ends with и (i), remove it.

Références $position, Stem\inRv(), et Stem\searchIfInRv().

Référencé par Russian\stem().

◆ step3()

step3 ( )
private

Step 3: Search for a DERIVATIONAL ending in R2 (i.e. the entire ending must lie in R2), and if one is found, remove it.

Références $position, Stem\inR2(), et Stem\searchIfInRv().

Référencé par Russian\stem().

◆ step4()

step4 ( )
private

Step 4: (1) Undouble н (n), or, (2) if the word ends with a SUPERLATIVE ending, remove it and undouble н (n), or (3) if the word ends ь (') (soft sign) remove it.

Références $position, et Stem\searchIfInRv().

Référencé par Russian\stem().

Documentation des champs

◆ $adjective

$adjective
staticprotected
Valeur initiale :
= array(
'ыми', 'ими', 'ему', 'ому', 'его', 'ого', 'ее', 'ие', 'ые', 'ое', 'ей', 'ий',
'ый', 'ой', 'ем', 'им', 'ым','ом','их', 'ых', 'ую', 'юю', 'ая', 'яя', 'ою', 'ею'
)

◆ $derivational

$derivational = array('ость', 'ост')
staticprotected

◆ $noun

$noun
staticprotected
Valeur initiale :
= array(
'иями', 'ями', 'ами', 'ией', 'иям', 'ием', 'иях', 'ев', 'ов', 'ие', 'ье', 'еи', 'ии', 'ей', 'ой', 'ий', 'ям',
'ем', 'ам', 'ом', 'ах', 'ях', 'ию', 'ью', 'ия', 'ья', 'я', 'а', 'е', 'ы', 'ь', 'и', 'о', 'у', 'й', 'ю'
)

◆ $participle

$participle
staticprotected
Valeur initiale :
= array(
array('ем', 'нн', 'вш', 'ющ', 'щ'),
array('ивш', 'ывш', 'ующ')
)

◆ $perfectiveGerund

$perfectiveGerund
staticprotected
Valeur initiale :
= array(
array('вшись', 'вши', 'в'),
array('ывшись', 'ившись', 'ывши', 'ивши', 'ив', 'ыв')
)

◆ $reflexive

$reflexive = array('ся', 'сь')
staticprotected

◆ $superlative

$superlative = array('ейше', 'ейш')
staticprotected

◆ $verb

$verb
staticprotected
Valeur initiale :
= array(
array('ешь', 'нно', 'ете', 'йте', 'ла', 'на', 'ли', 'й', 'л', 'ем', 'н', 'ло', 'но', 'ет', 'ют', 'ны', 'ть'),
array(
'уйте', 'ило', 'ыло', 'ено','ила', 'ыла', 'ена', 'ейте', 'ены', 'ить', 'ыть', 'ишь', 'ите', 'или', 'ыли',
'ует', 'уют', 'ей', 'уй', 'ил', 'ыл', 'им', 'ым', 'ен', 'ят', 'ит', 'ыт', 'ую', 'ю'
)
)

◆ $vowels

$vowels = array('а', 'е', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я')
staticprotected

All russian vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Russian.php


Joomla CMS: Référence de la classe Spanish

  • Wamania
  • Snowball
  • Stemmer
  • Spanish
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Spanish
+ Graphe d'héritage de Spanish:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'ü')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

step0 ()
step1 ()
step2a ()
step2b ()
step3 ()
finish ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ finish()

finish ( )
private

And finally: Remove acute accents

Référencé par Spanish\stem().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Spanish\finish(), Stem\r1(), Stem\r2(), Stem\rv(), Spanish\step0(), Spanish\step1(), Spanish\step2a(), Spanish\step2b(), et Spanish\step3().

◆ step0()

step0 ( )
private

Step 0: Attached pronoun

Search for the longest among the following suffixes me se sela selo selas selos la le lo las les los nos

and delete it, if comes after one of (a) iéndo ándo ár ér ír (b) ando iendo ar er ir (c) yendo following u

in RV. In the case of (c), yendo must lie in RV, but the preceding u can be outside it. In the case of (a), deletion is followed by removing the acute accent (for example, haciéndola -> haciendo).

Références $b, $item, $position, et Stem\searchIfInRv().

Référencé par Spanish\stem().

◆ step1()

step1 ( )
private

Step 1

Références $position, elseif, Stem\inR1(), Stem\inR2(), Stem\search(), et Stem\searchIfInR2().

Référencé par Spanish\stem().

◆ step2a()

step2a ( )
private

Step 2a: Verb suffixes beginning y

Références $position, et Stem\searchIfInRv().

Référencé par Spanish\stem().

◆ step2b()

step2b ( )
private

Step 2b: Other verb suffixes Search for the longest among the following suffixes in RV, and perform the action indicated.

Références $position, Stem\search(), et Stem\searchIfInRv().

Référencé par Spanish\stem().

◆ step3()

step3 ( )
private

Step 3: residual suffix Search for the longest among the following suffixes in RV, and perform the action indicated.

Références $position, et Stem\searchIfInRv().

Référencé par Spanish\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'á', 'é', 'í', 'ó', 'ú', 'ü')
staticprotected

All spanish vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Spanish.php


Joomla CMS: Référence de la classe Stem

  • Wamania
  • Snowball
  • Stemmer
  • Stem
Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe Stem
+ Graphe d'héritage de Stem:
Stemmer Catalan Danish Dutch English Finnish French German Italian Norwegian Portuguese Romanian Russian Spanish Swedish

Fonctions membres protégées

inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()

Attributs protégés

$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Attributs protégés statiques

static $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Membres hérités additionnels

- Fonctions membres publiques hérités de Stemmer
stem ($word)

Documentation des fonctions membres

◆ inR1()

inR1 ( $position )
protected

Références $position.

Référencé par Romanian\step0(), Portuguese\step1(), German\step1(), French\step1(), Italian\step1(), Dutch\step1(), Spanish\step1(), Romanian\step1(), English\step1b(), German\step2(), Dutch\step2(), English\step2(), German\step3(), Dutch\step3a(), Danish\step4(), et English\step5().

◆ inR2()

inR2 ( $position )
protected

Références $position.

Référencé par Portuguese\step1(), Finnish\step1(), French\step1(), Italian\step1(), Spanish\step1(), Romanian\step2(), French\step2b(), German\step3(), Russian\step3(), English\step3(), Dutch\step3a(), Dutch\step3b(), English\step4(), French\step4(), et English\step5().

◆ inRv()

inRv ( $position )
protected

Références $position.

Référencé par Russian\checkGroup1(), Portuguese\step1(), Russian\step1(), French\step1(), Italian\step1(), Russian\step2(), French\step2a(), French\step2b(), Romanian\step3(), Romanian\step4(), French\step4(), et Portuguese\step5().

◆ r1()

r1 ( )
protected

R1 is the region after the first non-vowel following a vowel, or the end of the word if there is no such non-vowel.

Références Stem\rx().

Référencé par English\exceptionR1(), Stem\r2(), Dutch\stem(), Portuguese\stem(), Romanian\stem(), Spanish\stem(), Danish\stem(), Norwegian\stem(), Swedish\stem(), French\stem(), Italian\stem(), German\stem(), English\stem(), Finnish\stem(), Russian\stem(), Finnish\step1(), Finnish\step2(), Finnish\step3(), Finnish\step4(), Finnish\step5(), et Finnish\step6().

◆ r2()

r2 ( )
protected

R2 is the region after the first non-vowel following a vowel in R1, or the end of the word if there is no such non-vowel.

Références $value, Stem\r1(), et Stem\rx().

Référencé par Dutch\stem(), French\stem(), Spanish\stem(), Italian\stem(), Portuguese\stem(), Romanian\stem(), German\stem(), English\stem(), Finnish\stem(), Russian\stem(), Finnish\step1(), Finnish\step2(), Finnish\step3(), Finnish\step4(), Finnish\step5(), et Finnish\step6().

◆ rv()

rv ( )
protected

Used by spanish, italian, portuguese, etc (but not by french)

If the second letter is a consonant, RV is the region after the next following vowel, or if the first two letters are vowels, RV is the region after the next consonant, and otherwise (consonant-vowel case) RV is the region after the third letter. But RV is the end of the word if these positions cannot be found.

Références $i.

Référencé par Italian\stem(), Spanish\stem(), Romanian\stem(), et Portuguese\stem().

◆ rx()

rx ( $in )
protected

Common function for R1 and R2 Search the region after the first non-vowel following a vowel in $word, or the end of the word if there is no such non-vowel. R1 : $in = $this->word R2 : $in = R1

Références $i, $position, $value, et Stem\$vowels.

Référencé par Stem\r1(), et Stem\r2().

◆ search()

search | ( | $suffixes,
 |  | $offset = 0
 | ) |
protected

Références Joomla\Database\Query\$offset, et $position.

Référencé par Stem\searchIfInR1(), Stem\searchIfInR2(), Stem\searchIfInRv(), Italian\step0(), Romanian\step0(), English\step0(), Portuguese\step1(), German\step1(), Russian\step1(), French\step1(), Italian\step1(), Dutch\step1(), Spanish\step1(), Romanian\step1(), English\step1a(), English\step1b(), English\step1c(), German\step2(), Finnish\step2(), Dutch\step2(), Romanian\step2(), English\step2(), Spanish\step2b(), Danish\step3(), German\step3(), Dutch\step3a(), Dutch\step3b(), Romanian\step4(), English\step4(), Portuguese\step5(), English\step5(), French\step5(), et Dutch\unDoubling().

◆ searchIfInR1()

searchIfInR1 ( $suffixes )
protected

Références Stem\search().

Référencé par Swedish\step1(), Danish\step1(), Finnish\step1(), Norwegian\step1(), Swedish\step2(), Danish\step2(), Finnish\step2(), Norwegian\step2(), Danish\step3(), Swedish\step3(), Norwegian\step3(), Finnish\step3(), English\step3(), Finnish\step5(), et Finnish\step6().

◆ searchIfInR2()

searchIfInR2 ( $suffixes )
protected

Références Stem\search().

Référencé par Portuguese\step1(), French\step1(), Italian\step1(), Spanish\step1(), Dutch\step3b(), Finnish\step4(), English\step4(), Finnish\step5(), et English\step5().

◆ searchIfInRv()

searchIfInRv ( $suffixes )
protected

Références Stem\search().

Référencé par Italian\step0(), Spanish\step0(), Russian\step1(), French\step1(), Russian\step2(), Portuguese\step2(), Italian\step2(), Spanish\step2a(), French\step2a(), Spanish\step2b(), French\step2b(), Russian\step3(), Portuguese\step3(), Romanian\step3(), Spanish\step3(), Italian\step3a(), Italian\step3b(), Russian\step4(), Portuguese\step4(), French\step4(), et Portuguese\step5().

Documentation des champs

◆ $originalWord

$originalWord
protected

◆ $plainVowels

$plainVowels
protected

◆ $r1

$r1
protected

◆ $r1Index

$r1Index
protected

◆ $r2

$r2
protected

◆ $r2Index

$r2Index
protected

◆ $rv

$rv
protected

◆ $rvIndex

$rvIndex
protected

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y')
staticprotected

Référencé par Stem\rx().

◆ $word

$word
protected

Référencé par English\exception1(), English\exception2(), Dutch\hasValidEnEnding(), Swedish\hasValidSEnding(), Norwegian\hasValidSEnding(), Danish\hasValidSEnding(), Dutch\hasValidSEnding(), Romanian\stem(), Italian\stem(), Norwegian\stem(), Dutch\stem(), Danish\stem(), Portuguese\stem(), Spanish\stem(), Swedish\stem(), French\stem(), German\stem(), English\stem(), Finnish\stem(), Russian\stem(), Swedish\step1(), Danish\step1(), Norwegian\step1(), Dutch\step1(), Finnish\step2(), et Dutch\step3a().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Stem.php


Joomla CMS: Référence de l'interface Stemmer

  • Wamania
  • Snowball
  • Stemmer
  • Stemmer
Fonctions membres publiques
Référence de l'interface Stemmer
+ Graphe d'héritage de Stemmer:
Stem Catalan Danish Dutch English Finnish French German Italian Norwegian Portuguese Romanian Russian Spanish Swedish

Fonctions membres publiques

stem ($word)

Description détaillée

Auteur
Luís Cobucci lcobu.nosp@m.cci@.nosp@m.gmail.nosp@m..com

Documentation des fonctions membres

◆ stem()

stem ( $word )

Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions

Implémenté dans Catalan, Russian, Finnish, English, German, Danish, Dutch, French, Italian, Norwegian, Portuguese, Romanian, Spanish, et Swedish.

La documentation de cette interface a été générée à partir du fichier suivant :
  • Stemmer.php


Joomla CMS: Référence de la classe Swedish

  • Wamania
  • Snowball
  • Stemmer
  • Swedish
Fonctions membres publiques | Attributs protégés statiques | Fonctions membres privées
Référence de la classe Swedish
+ Graphe d'héritage de Swedish:
Stem Stemmer

Fonctions membres publiques

stem ($word)

Attributs protégés statiques

static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'å', 'ö')
- Attributs protégés statiques hérités de Stem
static | $vowels = array('a', 'e', 'i', 'o', 'u', 'y')

Fonctions membres privées

hasValidSEnding ($word)
step1 ()
step2 ()
step3 ()

Membres hérités additionnels

- Fonctions membres protégées hérités de Stem
inRv ($position)
inR1 ($position)
inR2 ($position)
searchIfInRv ($suffixes)
searchIfInR1 ($suffixes)
searchIfInR2 ($suffixes)
search ($suffixes, $offset=0)
r1 ()
r2 ()
rx ($in)
rv ()
- Attributs protégés hérités de Stem
$plainVowels
$word
$originalWord
$rv
$rvIndex
$r1
$r1Index
$r2
$r2Index

Description détaillée

wamania

Documentation des fonctions membres

◆ hasValidSEnding()

hasValidSEnding ( $word )
private

Define a valid s-ending as one of b c d f g h j k l m n o p r t v y

Paramètres
string $ending
Renvoie
boolean

Références Stem\$word.

Référencé par Swedish\step1().

◆ stem()

stem ( $word )

{Main function to get the STEM of a word

Paramètres
string $word A valid UTF-8 word
Renvoie
string
Exceptions
}

Implémente Stemmer.

Références Stem\$word, Stem\r1(), Swedish\step1(), Swedish\step2(), et Swedish\step3().

◆ step1()

step1 ( )
private

Step 1 Search for the longest among the following suffixes in R1, and perform the action indicated.

Références $position, Stem\$word, Swedish\hasValidSEnding(), et Stem\searchIfInR1().

Référencé par Swedish\stem().

◆ step2()

step2 ( )
private

Step 2 Search for one of the following suffixes in R1, and if found delete the last letter.

Références Stem\searchIfInR1().

Référencé par Swedish\stem().

◆ step3()

step3 ( )
private

Step 3: Search for the longest among the following suffixes in R1, and perform the action indicated.

Références $position, et Stem\searchIfInR1().

Référencé par Swedish\stem().

Documentation des champs

◆ $vowels

$vowels = array('a', 'e', 'i', 'o', 'u', 'y', 'ä', 'å', 'ö')
staticprotected

All swedish vowels

La documentation de cette classe a été générée à partir du fichier suivant :
  • Swedish.php


Joomla CMS: Référence de la classe NotFoundException

  • Wamania
  • Snowball
  • NotFoundException
Référence de la classe NotFoundException
+ Graphe d'héritage de NotFoundException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • NotFoundException.php


Joomla CMS: Référence de la classe StemmerFactory

  • Wamania
  • Snowball
  • StemmerFactory
Fonctions membres publiques statiques | Champs de données
Référence de la classe StemmerFactory

Fonctions membres publiques statiques

const static create (string $code)

Champs de données

const LANGS

Documentation des fonctions membres

◆ create()

const static create ( string $code )
static
Exceptions
NotFoundException

Référencé par Language\__construct(), et StemmerManager\stem().

Documentation des champs

◆ LANGS

const LANGS
Valeur initiale :
= [
Catalan::class => ['ca', 'cat', 'catalan']
La documentation de cette classe a été générée à partir du fichier suivant :
  • StemmerFactory.php


Joomla CMS: Référence de la classe StemmerManager

  • Wamania
  • Snowball
  • StemmerManager
Fonctions membres publiques | Attributs privés
Référence de la classe StemmerManager

Fonctions membres publiques

__construct ()
stem (string $word, string $isoCode)

Attributs privés

$stemmers

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Documentation des fonctions membres

◆ stem()

stem | ( | string | $word,
 |  | string | $isoCode
 | ) |  |
Exceptions
NotFoundException

Références StemmerFactory\create().

Documentation des champs

◆ $stemmers

$stemmers
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • StemmerManager.php


Joomla CMS: Référence de la classe AndroidKeyAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • AndroidKeyAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AndroidKeyAttestationStatementSupport
+ Graphe d'héritage de AndroidKeyAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

checkCertificateAndGetPublicKey (string $certificate, string $clientDataHash, AuthenticatorData $authenticatorData)
checkAbsenceOfAllApplicationsTag (Sequence $sequence)

Attributs privés

$decoder
$metadataStatementRepository

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |

Références AndroidKeyAttestationStatementSupport\$decoder, AndroidKeyAttestationStatementSupport\$metadataStatementRepository, et null.

Documentation des fonctions membres

◆ checkAbsenceOfAllApplicationsTag()

checkAbsenceOfAllApplicationsTag ( Sequence $sequence )
private
Paramètres
Sequence $sequence Obvious
Renvoie
void
Exceptions

Références class, Construct\getChildren(), Assertion\isInstanceOf(), et Assertion\notEq().

Référencé par AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey().

◆ checkCertificateAndGetPublicKey()

checkCertificateAndGetPublicKey | ( | string | $certificate,
 |  | string | $clientDataHash,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références $extension, AndroidKeyAttestationStatementSupport\checkAbsenceOfAllApplicationsTag(), class, Key\createFromData(), Assertion\eq(), ASNObject\fromBinary(), AuthenticatorData\getAttestedCredentialData(), Assertion\isArray(), Assertion\isInstanceOf(), Assertion\isResource(), Assertion\keyExists(), Assertion\notNull(), et Assertion\true().

Référencé par AndroidKeyAttestationStatementSupport\isValid().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémente AttestationStatementSupport.

Références AndroidKeyAttestationStatementSupport\$metadataStatementRepository, AttestationStatement\$trustPath, CertificateToolbox\checkAttestationMedata(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), class, AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Algorithms\getOpensslAlgorithmFor(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références $key, CertificateToolbox\convertAllDERToPEM(), AttestationStatement\createBasic(), Assertion\greaterThan(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

Référencé par AndroidKeyAttestationStatementSupport\__construct().

◆ $metadataStatementRepository

$metadataStatementRepository
private

Référencé par AndroidKeyAttestationStatementSupport\__construct(), et AndroidKeyAttestationStatementSupport\isValid().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/AndroidKeyAttestationStatementSupport.php


Joomla CMS: Référence de la classe AndroidSafetyNetAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • AndroidSafetyNetAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AndroidSafetyNetAttestationStatementSupport
+ Graphe d'héritage de AndroidSafetyNetAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?ClientInterface $client=null, ?string $apiKey=null, ?RequestFactoryInterface $requestFactory=null, int $leeway=0, int $maxAge=60000, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
- Fonctions membres publiques hérités de AttestationStatementSupport
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

validatePayload (?string $payload, string $clientDataJSONHash, AuthenticatorData $authenticatorData)
validateSignature (JWS $jws, CertificateTrustPath $trustPath)
validateUsingGoogleApi (AttestationStatement $attestationStatement)
getResponseBody (ResponseInterface $response)
checkGoogleApiResponse (ResponseInterface $response)
convertCertificatesToPem (array $certificates)
initJwsVerifier ()

Attributs privés

$apiKey
$client
$jwsSerializer
$jwsVerifier
$requestFactory
$leeway
$maxAge
$metadataStatementRepository

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?ClientInterface | $client = null,
 |  | ?string | $apiKey = null,
 |  | ?RequestFactoryInterface | $requestFactory = null,
 |  | int | $leeway = 0,
 |  | int | $maxAge = 60000,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |

Références AndroidSafetyNetAttestationStatementSupport\$apiKey, AndroidSafetyNetAttestationStatementSupport\$client, AndroidSafetyNetAttestationStatementSupport\$leeway, AndroidSafetyNetAttestationStatementSupport\$maxAge, AndroidSafetyNetAttestationStatementSupport\$metadataStatementRepository, AndroidSafetyNetAttestationStatementSupport\$requestFactory, class, et AndroidSafetyNetAttestationStatementSupport\initJwsVerifier().

Documentation des fonctions membres

◆ checkGoogleApiResponse()

checkGoogleApiResponse ( ResponseInterface $response )
private

Références $header, Assertion\eq(), MessageInterface\getHeader(), ResponseInterface\getStatusCode(), MessageInterface\hasHeader(), et Assertion\true().

Référencé par AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ convertCertificatesToPem()

convertCertificatesToPem ( array $certificates )
private

Références CertificateToolbox\fixPEMStructure().

Référencé par AndroidSafetyNetAttestationStatementSupport\load().

◆ getResponseBody()

getResponseBody ( ResponseInterface $response )
private

Références $tmp, et MessageInterface\getBody().

Référencé par AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ initJwsVerifier()

initJwsVerifier ( )
private

Références $key, et class.

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références $key, AndroidSafetyNetAttestationStatementSupport\convertCertificatesToPem(), AttestationStatement\createBasic(), Assertion\keyExists(), AndroidSafetyNetAttestationStatementSupport\name(), et Assertion\notEmpty().

◆ name()

name ( )

Implémente AttestationStatementSupport.

Référencé par AndroidSafetyNetAttestationStatementSupport\load().

◆ validatePayload()

validatePayload | ( | ?string | $payload,
 |  | string | $clientDataJSONHash,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références JsonConverter\decode(), Assertion\eq(), AuthenticatorData\getAuthData(), Assertion\integer(), Assertion\isArray(), Assertion\keyExists(), Assertion\lessOrEqualThan(), Assertion\notNull(), et Assertion\true().

◆ validateSignature()

validateSignature | ( | JWS | $jws,
 |  | CertificateTrustPath | $trustPath
 | ) |  |
private

Références AttestationStatement\$trustPath, et Assertion\true().

◆ validateUsingGoogleApi()

validateUsingGoogleApi ( AttestationStatement $attestationStatement )
private

Références $uri, Assertion\boolean(), AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), Assertion\eq(), AttestationStatement\get(), AndroidSafetyNetAttestationStatementSupport\getResponseBody(), Assertion\keyExists(), null, et Assertion\true().

Documentation des champs

◆ $apiKey

$apiKey
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ $client

$client
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ $jwsSerializer

$jwsSerializer
private

◆ $jwsVerifier

$jwsVerifier
private

◆ $leeway

$leeway
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ $maxAge

$maxAge
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ $metadataStatementRepository

$metadataStatementRepository
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

◆ $requestFactory

$requestFactory
private

Référencé par AndroidSafetyNetAttestationStatementSupport\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AndroidSafetyNetAttestationStatementSupport.php


Joomla CMS: Référence de la classe AttestationObject

  • Webauthn
  • AttestationStatement
  • AttestationObject
Fonctions membres publiques | Attributs privés
Référence de la classe AttestationObject

Fonctions membres publiques

__construct (string $rawAttestationObject, AttestationStatement $attStmt, AuthenticatorData $authData)
getRawAttestationObject ()
getAttStmt ()
getAuthData ()

Attributs privés

$rawAttestationObject
$attStmt
$authData

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $rawAttestationObject,
 |  | AttestationStatement | $attStmt,
 |  | AuthenticatorData | $authData
 | ) |  |

Références AttestationObject\$attStmt, AttestationObject\$authData, et AttestationObject\$rawAttestationObject.

Documentation des fonctions membres

◆ getAttStmt()

getAttStmt ( )

Références AttestationObject\$attStmt.

Référencé par AuthenticatorAttestationResponseValidator\createPublicKeyCredentialSource().

◆ getAuthData()

getAuthData ( )

Références AttestationObject\$authData.

Référencé par AuthenticatorAttestationResponseValidator\createPublicKeyCredentialSource().

◆ getRawAttestationObject()

getRawAttestationObject ( )

Références AttestationObject\$rawAttestationObject.

Documentation des champs

◆ $attStmt

$attStmt
private

Référencé par AttestationObject\__construct(), et AttestationObject\getAttStmt().

◆ $authData

$authData
private

Référencé par AttestationObject\__construct(), et AttestationObject\getAuthData().

◆ $rawAttestationObject

$rawAttestationObject
private

Référencé par AttestationObject\__construct(), et AttestationObject\getRawAttestationObject().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AttestationObject.php


Joomla CMS: Référence de la classe AttestationObjectLoader

  • Webauthn
  • AttestationStatement
  • AttestationObjectLoader
Fonctions membres publiques | Attributs privés
Référence de la classe AttestationObjectLoader

Fonctions membres publiques

__construct (AttestationStatementSupportManager $attestationStatementSupportManager, ?Decoder $decoder=null)
load (string $data)

Attributs privés

const | FLAG_AT = 0b01000000
const | FLAG_ED = 0b10000000
$decoder
$attestationStatementSupportManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AttestationStatementSupportManager | $attestationStatementSupportManager,
 |  | ?Decoder | $decoder = null
 | ) |  |

Références AttestationObjectLoader\$attestationStatementSupportManager, AttestationObjectLoader\$decoder, et null.

Documentation des fonctions membres

◆ load()

load ( string $data )

Références $data, $extension, Laminas\Diactoros\$stream, class, Base64Url\decode(), Uuid\fromBytes(), Assertion\isArray(), Assertion\isInstanceOf(), Assertion\keyExists(), AuthenticationExtensionsClientOutputsLoader\load(), null, et Assertion\true().

Documentation des champs

◆ $attestationStatementSupportManager

$attestationStatementSupportManager
private

Référencé par AttestationObjectLoader\__construct().

◆ $decoder

$decoder
private

Référencé par AttestationObjectLoader\__construct().

◆ FLAG_AT

const FLAG_AT = 0b01000000
private

◆ FLAG_ED

const FLAG_ED = 0b10000000
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttestationObjectLoader.php


Joomla CMS: Référence de la classe AttestationStatement

  • Webauthn
  • AttestationStatement
  • AttestationStatement
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe AttestationStatement
+ Graphe d'héritage de AttestationStatement:

Fonctions membres publiques

__construct (string $fmt, array $attStmt, string $type, TrustPath $trustPath)
getFmt ()
getAttStmt ()
has (string $key)
get (string $key)
getTrustPath ()
getType ()
jsonSerialize ()

Fonctions membres publiques statiques

static | createNone (string $fmt, array $attStmt, TrustPath $trustPath)
static | createBasic (string $fmt, array $attStmt, TrustPath $trustPath)
static | createSelf (string $fmt, array $attStmt, TrustPath $trustPath)
static | createAttCA (string $fmt, array $attStmt, TrustPath $trustPath)
static | createEcdaa (string $fmt, array $attStmt, TrustPath $trustPath)
static | createFromArray (array $data)

Champs de données

const | TYPE_NONE = 'none'
const | TYPE_BASIC = 'basic'
const | TYPE_SELF = 'self'
const | TYPE_ATTCA = 'attca'
const | TYPE_ECDAA = 'ecdaa'

Attributs privés

$fmt
$attStmt
$trustPath
$type

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $fmt,
 |  | array | $attStmt,
 |  | string | $type,
 |  | TrustPath | $trustPath
 | ) |  |

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, AttestationStatement\$trustPath, et AttestationStatement\$type.

Documentation des fonctions membres

◆ createAttCA()

static createAttCA | ( | string | $fmt,
 |  | array | $attStmt,
 |  | TrustPath | $trustPath
 | ) |  |
static

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, et AttestationStatement\$trustPath.

Référencé par TPMAttestationStatementSupport\load().

◆ createBasic()

static createBasic | ( | string | $fmt,
 |  | array | $attStmt,
 |  | TrustPath | $trustPath
 | ) |  |
static

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, et AttestationStatement\$trustPath.

Référencé par FidoU2FAttestationStatementSupport\load(), AndroidKeyAttestationStatementSupport\load(), AndroidSafetyNetAttestationStatementSupport\load(), et PackedAttestationStatementSupport\loadBasicType().

◆ createEcdaa()

static createEcdaa | ( | string | $fmt,
 |  | array | $attStmt,
 |  | TrustPath | $trustPath
 | ) |  |
static

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, et AttestationStatement\$trustPath.

Référencé par PackedAttestationStatementSupport\loadEcdaaType().

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, $key, Assertion\keyExists(), et TrustPathLoader\loadTrustPath().

◆ createNone()

static createNone | ( | string | $fmt,
 |  | array | $attStmt,
 |  | TrustPath | $trustPath
 | ) |  |
static

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, et AttestationStatement\$trustPath.

Référencé par NoneAttestationStatementSupport\load().

◆ createSelf()

static createSelf | ( | string | $fmt,
 |  | array | $attStmt,
 |  | TrustPath | $trustPath
 | ) |  |
static

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, et AttestationStatement\$trustPath.

Référencé par PackedAttestationStatementSupport\loadEmptyType().

◆ get()

get ( string $key )
Renvoie
mixed

Références $key, AttestationStatement\has(), et Assertion\true().

Référencé par FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\processWithCertificate(), TPMAttestationStatementSupport\processWithCertificate(), PackedAttestationStatementSupport\processWithSelfAttestation(), et AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi().

◆ getAttStmt()

getAttStmt ( )

Références AttestationStatement\$attStmt.

Référencé par NoneAttestationStatementSupport\isValid().

◆ getFmt()

getFmt ( )

Références AttestationStatement\$fmt.

◆ getTrustPath()

getTrustPath ( )

Références AttestationStatement\$trustPath.

Référencé par FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\isValid(), et TPMAttestationStatementSupport\processWithCertificate().

◆ getType()

getType ( )

Références AttestationStatement\$type.

Référencé par CertificateToolbox\getAttestationType().

◆ has()

has ( string $key )

Références $key.

Référencé par AttestationStatement\get().

◆ jsonSerialize()

jsonSerialize ( )

Références AttestationStatement\$attStmt, AttestationStatement\$fmt, AttestationStatement\$trustPath, et AttestationStatement\$type.

Documentation des champs

◆ $attStmt

$attStmt
private

Référencé par AttestationStatement\__construct(), AttestationStatement\createAttCA(), AttestationStatement\createBasic(), AttestationStatement\createEcdaa(), AttestationStatement\createNone(), AttestationStatement\createSelf(), AttestationStatement\getAttStmt(), et AttestationStatement\jsonSerialize().

◆ $fmt

$fmt
private

Référencé par AttestationStatement\__construct(), AttestationStatement\createAttCA(), AttestationStatement\createBasic(), AttestationStatement\createEcdaa(), AttestationStatement\createNone(), AttestationStatement\createSelf(), AttestationStatement\getFmt(), et AttestationStatement\jsonSerialize().

◆ $trustPath

$trustPath
private

Référencé par AttestationStatement\__construct(), AttestationStatement\createAttCA(), AttestationStatement\createBasic(), AttestationStatement\createEcdaa(), AttestationStatement\createNone(), AttestationStatement\createSelf(), AttestationStatement\getTrustPath(), FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\isValid(), AttestationStatement\jsonSerialize(), PackedAttestationStatementSupport\processWithCertificate(), TPMAttestationStatementSupport\processWithCertificate(), et AndroidSafetyNetAttestationStatementSupport\validateSignature().

◆ $type

$type
private

Référencé par AttestationStatement\__construct(), TPMAttestationStatementSupport\checkCertInfo(), TPMAttestationStatementSupport\checkPubArea(), TPMAttestationStatementSupport\getParameters(), AttestationStatement\getType(), et AttestationStatement\jsonSerialize().

◆ TYPE_ATTCA

const TYPE_ATTCA = 'attca'

◆ TYPE_BASIC

const TYPE_BASIC = 'basic'

◆ TYPE_ECDAA

const TYPE_ECDAA = 'ecdaa'

◆ TYPE_NONE

const TYPE_NONE = 'none'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ TYPE_SELF

const TYPE_SELF = 'self'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttestationStatement.php


Joomla CMS: Référence de l'interface AttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • AttestationStatementSupport
Fonctions membres publiques
Référence de l'interface AttestationStatementSupport
+ Graphe d'héritage de AttestationStatementSupport:
AndroidKeyAttestationStatementSupport FidoU2FAttestationStatementSupport AndroidKeyAttestationStatementSupport FidoU2FAttestationStatementSupport AndroidKeyAttestationStatementSupport AndroidSafetyNetAttestationStatementSupport FidoU2FAttestationStatementSupport NoneAttestationStatementSupport PackedAttestationStatementSupport TPMAttestationStatementSupport

Fonctions membres publiques

name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Documentation des fonctions membres

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémenté dans AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, PackedAttestationStatementSupport, TPMAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, et NoneAttestationStatementSupport.

◆ load()

load ( array $attestation )

Implémenté dans AndroidKeyAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, FidoU2FAttestationStatementSupport, AndroidSafetyNetAttestationStatementSupport, PackedAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, TPMAttestationStatementSupport, et NoneAttestationStatementSupport.

◆ name()

name ( )

Implémenté dans AndroidKeyAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, FidoU2FAttestationStatementSupport, AndroidSafetyNetAttestationStatementSupport, PackedAttestationStatementSupport, AndroidKeyAttestationStatementSupport, FidoU2FAttestationStatementSupport, TPMAttestationStatementSupport, et NoneAttestationStatementSupport.

Référencé par AttestationStatementSupportManager\add().

La documentation de cette interface a été générée à partir du fichier suivant :
  • AttestationStatementSupport.php


Joomla CMS: Référence de la classe AttestationStatementSupportManager

  • Webauthn
  • AttestationStatement
  • AttestationStatementSupportManager
Fonctions membres publiques | Attributs privés
Référence de la classe AttestationStatementSupportManager

Fonctions membres publiques

add (AttestationStatementSupport $attestationStatementSupport)
has (string $name)
get (string $name)

Attributs privés

$attestationStatementSupports = []

Documentation des fonctions membres

◆ add()

add ( AttestationStatementSupport $attestationStatementSupport )

Références AttestationStatementSupport\name().

◆ get()

get ( string $name )

Références $name, AttestationStatementSupportManager\has(), et Assertion\true().

◆ has()

has ( string $name )

Références $name.

Référencé par AttestationStatementSupportManager\get().

Documentation des champs

◆ $attestationStatementSupports

$attestationStatementSupports = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttestationStatementSupportManager.php


Joomla CMS: Référence de la classe FidoU2FAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • FidoU2FAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe FidoU2FAttestationStatementSupport
+ Graphe d'héritage de FidoU2FAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder=null, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

extractPublicKey (?string $publicKey)
checkCertificate (string $publicKey)

Attributs privés

$decoder
$metadataStatementRepository

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder = null,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |

Références FidoU2FAttestationStatementSupport\$decoder, FidoU2FAttestationStatementSupport\$metadataStatementRepository, et null.

Documentation des fonctions membres

◆ checkCertificate()

checkCertificate ( string $publicKey )
private

Références Assertion\eq(), Assertion\isResource(), et Assertion\keyExists().

Référencé par FidoU2FAttestationStatementSupport\load().

◆ extractPublicKey()

extractPublicKey ( ?string $publicKey )
private

Références class, Ec2Key\CURVE_P256, Ec2Key\DATA_CURVE, Assertion\isInstanceOf(), Assertion\notNull(), Assertion\true(), et Key\TYPE.

Référencé par FidoU2FAttestationStatementSupport\isValid().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémente AttestationStatementSupport.

Références FidoU2FAttestationStatementSupport\$metadataStatementRepository, AttestationStatement\$trustPath, CertificateToolbox\checkAttestationMedata(), class, Assertion\eq(), FidoU2FAttestationStatementSupport\extractPublicKey(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getRpIdHash(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références $key, FidoU2FAttestationStatementSupport\checkCertificate(), CertificateToolbox\convertAllDERToPEM(), Assertion\count(), AttestationStatement\createBasic(), Assertion\isArray(), et Assertion\keyExists().

◆ name()

name ( )

Implémente AttestationStatementSupport.

Documentation des champs

◆ $decoder

$decoder
private

Référencé par FidoU2FAttestationStatementSupport\__construct().

◆ $metadataStatementRepository

$metadataStatementRepository
private

Référencé par FidoU2FAttestationStatementSupport\__construct(), et FidoU2FAttestationStatementSupport\isValid().

La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/FidoU2FAttestationStatementSupport.php


Joomla CMS: Référence de la classe NoneAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • NoneAttestationStatementSupport
Fonctions membres publiques
Référence de la classe NoneAttestationStatementSupport
+ Graphe d'héritage de NoneAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Documentation des fonctions membres

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémente AttestationStatementSupport.

Références AttestationStatement\getAttStmt().

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références AttestationStatement\createNone(), et Assertion\noContent().

◆ name()

name ( )

Implémente AttestationStatementSupport.

La documentation de cette classe a été générée à partir du fichier suivant :
  • NoneAttestationStatementSupport.php


Joomla CMS: Référence de la classe PackedAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • PackedAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe PackedAttestationStatementSupport
+ Graphe d'héritage de PackedAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

__construct (?Decoder $decoder, Manager $algorithmManager, ?MetadataStatementRepository $metadataStatementRepository=null)
name ()
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

loadBasicType (array $attestation)
loadEcdaaType (array $attestation)
loadEmptyType (array $attestation)
checkCertificate (string $attestnCert, AuthenticatorData $authenticatorData)
processWithCertificate (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData, CertificateTrustPath $trustPath)
processWithECDAA ()
processWithSelfAttestation (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Attributs privés

$decoder
$algorithmManager
$metadataStatementRepository

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?Decoder | $decoder,
 |  | Manager | $algorithmManager,
 |  | ?MetadataStatementRepository | $metadataStatementRepository = null
 | ) |  |

Références PackedAttestationStatementSupport\$algorithmManager, PackedAttestationStatementSupport\$decoder, PackedAttestationStatementSupport\$metadataStatementRepository, et null.

Documentation des fonctions membres

◆ checkCertificate()

checkCertificate | ( | string | $attestnCert,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références Assertion\false(), AuthenticatorData\getAttestedCredentialData(), Assertion\isArray(), et Assertion\notNull().

Référencé par PackedAttestationStatementSupport\processWithCertificate().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémente AttestationStatementSupport.

Références AttestationStatement\$trustPath, AttestationStatement\getTrustPath(), PackedAttestationStatementSupport\processWithCertificate(), PackedAttestationStatementSupport\processWithECDAA(), et PackedAttestationStatementSupport\processWithSelfAttestation().

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références Assertion\keyExists(), PackedAttestationStatementSupport\loadBasicType(), PackedAttestationStatementSupport\loadEcdaaType(), PackedAttestationStatementSupport\loadEmptyType(), et Assertion\string().

◆ loadBasicType()

loadBasicType ( array $attestation )
private

Références CertificateToolbox\convertAllDERToPEM(), AttestationStatement\createBasic(), Assertion\isArray(), et Assertion\minCount().

Référencé par PackedAttestationStatementSupport\load().

◆ loadEcdaaType()

loadEcdaaType ( array $attestation )
private

Références AttestationStatement\createEcdaa(), et Assertion\string().

Référencé par PackedAttestationStatementSupport\load().

◆ loadEmptyType()

loadEmptyType ( array $attestation )
private

Références AttestationStatement\createSelf().

Référencé par PackedAttestationStatementSupport\load().

◆ name()

name ( )

Implémente AttestationStatementSupport.

◆ processWithCertificate()

processWithCertificate | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData,
 |  | CertificateTrustPath | $trustPath
 | ) |  |
private

Références PackedAttestationStatementSupport\$metadataStatementRepository, $result, AttestationStatement\$trustPath, CertificateToolbox\checkAttestationMedata(), PackedAttestationStatementSupport\checkCertificate(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Algorithms\getOpensslAlgorithmFor(), et null.

Référencé par PackedAttestationStatementSupport\isValid().

◆ processWithECDAA()

processWithECDAA ( )
private

Référencé par PackedAttestationStatementSupport\isValid().

◆ processWithSelfAttestation()

processWithSelfAttestation | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références class, Assertion\eq(), CoseSignatureFixer\fix(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Assertion\isInstanceOf(), Assertion\notNull(), et Assertion\true().

Référencé par PackedAttestationStatementSupport\isValid().

Documentation des champs

◆ $algorithmManager

$algorithmManager
private

Référencé par PackedAttestationStatementSupport\__construct().

◆ $decoder

$decoder
private

Référencé par PackedAttestationStatementSupport\__construct().

◆ $metadataStatementRepository

$metadataStatementRepository
private

Référencé par PackedAttestationStatementSupport\__construct(), et PackedAttestationStatementSupport\processWithCertificate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PackedAttestationStatementSupport.php


Joomla CMS: Référence de la classe TPMAttestationStatementSupport

  • Webauthn
  • AttestationStatement
  • TPMAttestationStatementSupport
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe TPMAttestationStatementSupport
+ Graphe d'héritage de TPMAttestationStatementSupport:
AttestationStatementSupport

Fonctions membres publiques

name ()
__construct (?MetadataStatementRepository $metadataStatementRepository=null)
load (array $attestation)
isValid (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)

Fonctions membres privées

checkUniquePublicKey (string $unique, string $cborPublicKey)
checkCertInfo (string $data)
checkPubArea (string $data)
getParameters (string $type, StringStream $stream)
getExponent (string $exponent)
convertCertificatesToPem (array $certificates)
getTPMHash (string $nameAlg)
processWithCertificate (string $clientDataJSONHash, AttestationStatement $attestationStatement, AuthenticatorData $authenticatorData)
checkCertificate (string $attestnCert, AuthenticatorData $authenticatorData)
processWithECDAA ()

Attributs privés

$metadataStatementRepository

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( ?MetadataStatementRepository $metadataStatementRepository = null )

Références TPMAttestationStatementSupport\$metadataStatementRepository.

Documentation des fonctions membres

◆ checkCertificate()

checkCertificate | ( | string | $attestnCert,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références $endDate, $startDate, Assertion\eq(), Assertion\false(), AuthenticatorData\getAttestedCredentialData(), Assertion\integer(), Assertion\isArray(), Assertion\keyExists(), et Assertion\true().

Référencé par TPMAttestationStatementSupport\processWithCertificate().

◆ checkCertInfo()

checkCertInfo ( string $data )
private

Références $data, AttestationStatement\$type, Assertion\eq(), et Assertion\true().

Référencé par TPMAttestationStatementSupport\load().

◆ checkPubArea()

checkPubArea ( string $data )
private

Références $data, $parameters, AttestationStatement\$type, TPMAttestationStatementSupport\getParameters(), et Assertion\true().

Référencé par TPMAttestationStatementSupport\load().

◆ checkUniquePublicKey()

checkUniquePublicKey | ( | string | $unique,
 |  | string | $cborPublicKey
 | ) |  |
private

Références $key, class, Assertion\eq(), Assertion\isInstanceOf(), Key\TYPE_EC2, Key\TYPE_OKP, Key\TYPE_RSA, et Ec2Key\x().

Référencé par TPMAttestationStatementSupport\isValid().

◆ convertCertificatesToPem()

convertCertificatesToPem ( array $certificates )
private

Références $tmp.

◆ getExponent()

getExponent ( string $exponent )
private

Références Base64Url\decode().

Référencé par TPMAttestationStatementSupport\getParameters().

◆ getParameters()

getParameters | ( | string | $type,
 |  | StringStream | $stream
 | ) |  |
private

Références Laminas\Diactoros\$stream, AttestationStatement\$type, TPMAttestationStatementSupport\getExponent(), et StringStream\read().

Référencé par TPMAttestationStatementSupport\checkPubArea().

◆ getTPMHash()

getTPMHash ( string $nameAlg )
private

Référencé par TPMAttestationStatementSupport\load().

◆ isValid()

isValid | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |

Implémente AttestationStatementSupport.

Références TPMAttestationStatementSupport\checkUniquePublicKey(), Assertion\eq(), AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), AuthenticatorData\getAuthData(), Algorithms\getHashAlgorithmFor(), AttestationStatement\getTrustPath(), TPMAttestationStatementSupport\processWithCertificate(), et TPMAttestationStatementSupport\processWithECDAA().

◆ load()

load ( array $attestation )

Implémente AttestationStatementSupport.

Références $key, TPMAttestationStatementSupport\checkCertInfo(), TPMAttestationStatementSupport\checkPubArea(), CertificateToolbox\convertAllDERToPEM(), AttestationStatement\createAttCA(), Assertion\eq(), TPMAttestationStatementSupport\getTPMHash(), Assertion\keyExists(), Assertion\keyNotExists(), Assertion\minCount(), et TPMAttestationStatementSupport\name().

◆ name()

name ( )

Implémente AttestationStatementSupport.

Référencé par TPMAttestationStatementSupport\load().

◆ processWithCertificate()

processWithCertificate | ( | string | $clientDataJSONHash,
 |  | AttestationStatement | $attestationStatement,
 |  | AuthenticatorData | $authenticatorData
 | ) |  |
private

Références TPMAttestationStatementSupport\$metadataStatementRepository, $result, AttestationStatement\$trustPath, CertificateToolbox\checkAttestationMedata(), TPMAttestationStatementSupport\checkCertificate(), class, AttestationStatement\get(), AuthenticatorData\getAttestedCredentialData(), Algorithms\getOpensslAlgorithmFor(), AttestationStatement\getTrustPath(), Assertion\isInstanceOf(), et null.

Référencé par TPMAttestationStatementSupport\isValid().

◆ processWithECDAA()

processWithECDAA ( )
private

Référencé par TPMAttestationStatementSupport\isValid().

Documentation des champs

◆ $metadataStatementRepository

$metadataStatementRepository
private

Référencé par TPMAttestationStatementSupport\__construct(), et TPMAttestationStatementSupport\processWithCertificate().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TPMAttestationStatementSupport.php


Joomla CMS: Référence de la classe AuthenticationExtension

  • Webauthn
  • AuthenticationExtensions
  • AuthenticationExtension
Fonctions membres publiques | Attributs privés
Référence de la classe AuthenticationExtension
+ Graphe d'héritage de AuthenticationExtension:

Fonctions membres publiques

__construct (string $name, $value)
name ()
value ()
jsonSerialize ()

Attributs privés

$name
$value

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  |  | $value
 | ) |  |
Paramètres
mixed $value

Références AuthenticationExtension\$name, AuthenticationExtension\$value, AuthenticationExtension\name(), et AuthenticationExtension\value().

Documentation des fonctions membres

◆ jsonSerialize()

jsonSerialize ( )
Renvoie
mixed

Références AuthenticationExtension\$value.

◆ name()

name ( )

Références AuthenticationExtension\$name.

Référencé par AuthenticationExtension\__construct().

◆ value()

value ( )
Renvoie
mixed

Références AuthenticationExtension\$value.

Référencé par AuthenticationExtension\__construct().

Documentation des champs

◆ $name

$name
private

Référencé par AuthenticationExtension\__construct(), et AuthenticationExtension\name().

◆ $value

$value
private

Référencé par AuthenticationExtension\__construct(), AuthenticationExtension\jsonSerialize(), et AuthenticationExtension\value().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationExtension.php


Joomla CMS: Référence de la classe AuthenticationExtensionsClientInputs

  • Webauthn
  • AuthenticationExtensions
  • AuthenticationExtensionsClientInputs
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe AuthenticationExtensionsClientInputs
+ Graphe d'héritage de AuthenticationExtensionsClientInputs:

Fonctions membres publiques

add (AuthenticationExtension $extension)
has (string $key)
get (string $key)
jsonSerialize ()
getIterator ()
count (int $mode=COUNT_NORMAL)

Fonctions membres publiques statiques

static createFromArray (array $json)

Attributs privés

$extensions = []

Documentation des fonctions membres

◆ add()

add ( AuthenticationExtension $extension )

Références $extension.

◆ count()

count ( int $mode = COUNT_NORMAL )

Références $mode.

◆ createFromArray()

static createFromArray ( array $json )
static

◆ get()

get ( string $key )
Renvoie
mixed

Références $key, AuthenticationExtensionsClientInputs\has(), et Assertion\true().

Référencé par AuthenticatorAssertionResponseValidator\getFacetId().

◆ getIterator()

getIterator ( )

◆ has()

has ( string $key )

Références $key.

Référencé par AuthenticationExtensionsClientInputs\get(), et AuthenticatorAssertionResponseValidator\getFacetId().

◆ jsonSerialize()

jsonSerialize ( )

Références AuthenticationExtensionsClientInputs\$extensions.

Documentation des champs

◆ $extensions

$extensions = []
private

Référencé par AuthenticationExtensionsClientInputs\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationExtensionsClientInputs.php


Joomla CMS: Référence de la classe AuthenticationExtensionsClientOutputs

  • Webauthn
  • AuthenticationExtensions
  • AuthenticationExtensionsClientOutputs
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe AuthenticationExtensionsClientOutputs
+ Graphe d'héritage de AuthenticationExtensionsClientOutputs:

Fonctions membres publiques

add (AuthenticationExtension $extension)
has (string $key)
get (string $key)
jsonSerialize ()
getIterator ()
count (int $mode=COUNT_NORMAL)

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Attributs privés

$extensions = []

Documentation des fonctions membres

◆ add()

add ( AuthenticationExtension $extension )

Références $extension.

◆ count()

count ( int $mode = COUNT_NORMAL )

Références $mode.

◆ createFromArray()

static createFromArray ( array $json )
static

◆ createFromString()

static createFromString ( string $data )
static

Références $data, Assertion\eq(), et Assertion\isArray().

◆ get()

get ( string $key )
Renvoie
mixed

Références $key, AuthenticationExtensionsClientOutputs\has(), et Assertion\true().

Référencé par AuthenticatorAssertionResponseValidator\getFacetId().

◆ getIterator()

getIterator ( )

◆ has()

has ( string $key )

Références $key.

Référencé par AuthenticationExtensionsClientOutputs\get(), et AuthenticatorAssertionResponseValidator\getFacetId().

◆ jsonSerialize()

jsonSerialize ( )

Références AuthenticationExtensionsClientOutputs\$extensions.

Documentation des champs

◆ $extensions

$extensions = []
private

Référencé par AuthenticationExtensionsClientOutputs\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationExtensionsClientOutputs.php


Joomla CMS: Référence de la classe AuthenticationExtensionsClientOutputsLoader

  • Webauthn
  • AuthenticationExtensions
  • AuthenticationExtensionsClientOutputsLoader
Fonctions membres publiques statiques
Référence de la classe AuthenticationExtensionsClientOutputsLoader

Fonctions membres publiques statiques

static load (CBORObject $object)

Documentation des fonctions membres

◆ load()

static load ( CBORObject $object )
static

Références $data, $key, $value, class, CBORObject\getNormalizedData(), Assertion\isInstanceOf(), et Assertion\string().

Référencé par AttestationObjectLoader\load().

La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticationExtensionsClientOutputsLoader.php


Joomla CMS: Référence de l'interface ExtensionOutputChecker

  • Webauthn
  • AuthenticationExtensions
  • ExtensionOutputChecker
Fonctions membres publiques
Référence de l'interface ExtensionOutputChecker

Fonctions membres publiques

check (AuthenticationExtensionsClientOutputs $extensions)

Documentation des fonctions membres

◆ check()

check ( AuthenticationExtensionsClientOutputs $extensions )
Exceptions
ExtensionOutputError
La documentation de cette interface a été générée à partir du fichier suivant :
  • ExtensionOutputChecker.php


Joomla CMS: Référence de la classe ExtensionOutputCheckerHandler

  • Webauthn
  • AuthenticationExtensions
  • ExtensionOutputCheckerHandler
Fonctions membres publiques | Attributs privés
Référence de la classe ExtensionOutputCheckerHandler

Fonctions membres publiques

add (ExtensionOutputChecker $checker)
check (AuthenticationExtensionsClientOutputs $extensions)

Attributs privés

$checkers = []

Documentation des fonctions membres

◆ add()

add ( ExtensionOutputChecker $checker )

◆ check()

check ( AuthenticationExtensionsClientOutputs $extensions )
Exceptions
ExtensionOutputError

Documentation des champs

◆ $checkers

$checkers = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionOutputCheckerHandler.php


Joomla CMS: Référence de la classe ExtensionOutputError

  • Webauthn
  • AuthenticationExtensions
  • ExtensionOutputError
Fonctions membres publiques | Attributs privés
Référence de la classe ExtensionOutputError
+ Graphe d'héritage de ExtensionOutputError:

Fonctions membres publiques

__construct (AuthenticationExtension $authenticationExtension, string $message='', int $code=0, Throwable $previous=null)
getAuthenticationExtension ()

Attributs privés

$authenticationExtension

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AuthenticationExtension | $authenticationExtension,
 |  | string | $message = '',
 |  | int | $code = 0,
 |  | Throwable | $previous = null
 | ) |  |

Références ExtensionOutputError\$authenticationExtension, $message, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAuthenticationExtension()

getAuthenticationExtension ( )

Références ExtensionOutputError\$authenticationExtension.

Documentation des champs

◆ $authenticationExtension

$authenticationExtension
private

Référencé par ExtensionOutputError\__construct(), et ExtensionOutputError\getAuthenticationExtension().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionOutputError.php


Joomla CMS: Référence de la classe AuthenticatorStatus

  • Webauthn
  • MetadataService
  • AuthenticatorStatus
Champs de données
Référence de la classe AuthenticatorStatus

Champs de données

const | NOT_FIDO_CERTIFIED = 'NOT_FIDO_CERTIFIED'
const | FIDO_CERTIFIED = 'FIDO_CERTIFIED'
const | USER_VERIFICATION_BYPASS = 'USER_VERIFICATION_BYPASS'
const | ATTESTATION_KEY_COMPROMISE = 'ATTESTATION_KEY_COMPROMISE'
const | USER_KEY_REMOTE_COMPROMISE = 'USER_KEY_REMOTE_COMPROMISE'
const | USER_KEY_PHYSICAL_COMPROMISE = 'USER_KEY_PHYSICAL_COMPROMISE'
const | UPDATE_AVAILABLE = 'UPDATE_AVAILABLE'
const | REVOKED = 'REVOKED'
const | SELF_ASSERTION_SUBMITTED = 'SELF_ASSERTION_SUBMITTED'
const | FIDO_CERTIFIED_L1 = 'FIDO_CERTIFIED_L1'
const | FIDO_CERTIFIED_L1plus = 'FIDO_CERTIFIED_L1plus'
const | FIDO_CERTIFIED_L2 = 'FIDO_CERTIFIED_L2'
const | FIDO_CERTIFIED_L2plus = 'FIDO_CERTIFIED_L2plus'
const | FIDO_CERTIFIED_L3 = 'FIDO_CERTIFIED_L3'
const | FIDO_CERTIFIED_L3plus = 'FIDO_CERTIFIED_L3plus'

Documentation des champs

◆ ATTESTATION_KEY_COMPROMISE

const ATTESTATION_KEY_COMPROMISE = 'ATTESTATION_KEY_COMPROMISE'

◆ FIDO_CERTIFIED

const FIDO_CERTIFIED = 'FIDO_CERTIFIED'

◆ FIDO_CERTIFIED_L1

const FIDO_CERTIFIED_L1 = 'FIDO_CERTIFIED_L1'

◆ FIDO_CERTIFIED_L1plus

const FIDO_CERTIFIED_L1plus = 'FIDO_CERTIFIED_L1plus'

◆ FIDO_CERTIFIED_L2

const FIDO_CERTIFIED_L2 = 'FIDO_CERTIFIED_L2'

◆ FIDO_CERTIFIED_L2plus

const FIDO_CERTIFIED_L2plus = 'FIDO_CERTIFIED_L2plus'

◆ FIDO_CERTIFIED_L3

const FIDO_CERTIFIED_L3 = 'FIDO_CERTIFIED_L3'

◆ FIDO_CERTIFIED_L3plus

const FIDO_CERTIFIED_L3plus = 'FIDO_CERTIFIED_L3plus'

◆ NOT_FIDO_CERTIFIED

const NOT_FIDO_CERTIFIED = 'NOT_FIDO_CERTIFIED'

◆ REVOKED

const REVOKED = 'REVOKED'

◆ SELF_ASSERTION_SUBMITTED

const SELF_ASSERTION_SUBMITTED = 'SELF_ASSERTION_SUBMITTED'

◆ UPDATE_AVAILABLE

const UPDATE_AVAILABLE = 'UPDATE_AVAILABLE'

◆ USER_KEY_PHYSICAL_COMPROMISE

const USER_KEY_PHYSICAL_COMPROMISE = 'USER_KEY_PHYSICAL_COMPROMISE'

◆ USER_KEY_REMOTE_COMPROMISE

const USER_KEY_REMOTE_COMPROMISE = 'USER_KEY_REMOTE_COMPROMISE'

◆ USER_VERIFICATION_BYPASS

const USER_VERIFICATION_BYPASS = 'USER_VERIFICATION_BYPASS'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorStatus.php


Joomla CMS: Référence de la classe BiometricAccuracyDescriptor

  • Webauthn
  • MetadataService
  • BiometricAccuracyDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe BiometricAccuracyDescriptor

Fonctions membres publiques

getSelfAttestedFRR ()
getSelfAttestedFAR ()
getMaxTemplates ()
getMaxRetries ()
getBlockSlowdown ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$selfAttestedFRR
$selfAttestedFAR
$maxTemplates
$maxRetries
$blockSlowdown

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par VerificationMethodDescriptor\createFromArray().

◆ getBlockSlowdown()

getBlockSlowdown ( )
Renvoie
int|null

Références BiometricAccuracyDescriptor\$blockSlowdown.

◆ getMaxRetries()

getMaxRetries ( )
Renvoie
int|null

Références BiometricAccuracyDescriptor\$maxRetries.

◆ getMaxTemplates()

getMaxTemplates ( )
Renvoie
int|null

Références BiometricAccuracyDescriptor\$maxTemplates.

◆ getSelfAttestedFAR()

getSelfAttestedFAR ( )
Renvoie
int

Références BiometricAccuracyDescriptor\$selfAttestedFAR.

◆ getSelfAttestedFRR()

getSelfAttestedFRR ( )
Renvoie
int

Références BiometricAccuracyDescriptor\$selfAttestedFRR.

Documentation des champs

◆ $blockSlowdown

$blockSlowdown
private

Référencé par BiometricAccuracyDescriptor\getBlockSlowdown().

◆ $maxRetries

$maxRetries
private

Référencé par BiometricAccuracyDescriptor\getMaxRetries().

◆ $maxTemplates

$maxTemplates
private

Référencé par BiometricAccuracyDescriptor\getMaxTemplates().

◆ $selfAttestedFAR

$selfAttestedFAR
private

Référencé par BiometricAccuracyDescriptor\getSelfAttestedFAR().

◆ $selfAttestedFRR

$selfAttestedFRR
private

Référencé par BiometricAccuracyDescriptor\getSelfAttestedFRR().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BiometricAccuracyDescriptor.php


Joomla CMS: Référence de la classe BiometricStatusReport

  • Webauthn
  • MetadataService
  • BiometricStatusReport
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe BiometricStatusReport

Fonctions membres publiques

getCertLevel ()
getModality ()
getEffectiveDate ()
getCertificationDescriptor ()
getCertificateNumber ()
getCertificationPolicyVersion ()
getCertificationRequirementsVersion ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$certLevel
$modality
$effectiveDate
$certificationDescriptor
$certificateNumber
$certificationPolicyVersion
$certificationRequirementsVersion

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par MetadataTOCPayloadEntry\createFromArray().

◆ getCertificateNumber()

getCertificateNumber ( )

Références BiometricStatusReport\$certificateNumber.

◆ getCertificationDescriptor()

getCertificationDescriptor ( )

Références BiometricStatusReport\$certificationDescriptor.

◆ getCertificationPolicyVersion()

getCertificationPolicyVersion ( )

Références BiometricStatusReport\$certificationPolicyVersion.

◆ getCertificationRequirementsVersion()

getCertificationRequirementsVersion ( )

Références BiometricStatusReport\$certificationRequirementsVersion.

◆ getCertLevel()

getCertLevel ( )

Références BiometricStatusReport\$certLevel.

◆ getEffectiveDate()

getEffectiveDate ( )

Références BiometricStatusReport\$effectiveDate.

◆ getModality()

getModality ( )

Références BiometricStatusReport\$modality.

Documentation des champs

◆ $certificateNumber

$certificateNumber
private

Référencé par BiometricStatusReport\getCertificateNumber().

◆ $certificationDescriptor

$certificationDescriptor
private

Référencé par BiometricStatusReport\getCertificationDescriptor().

◆ $certificationPolicyVersion

$certificationPolicyVersion
private

Référencé par BiometricStatusReport\getCertificationPolicyVersion().

◆ $certificationRequirementsVersion

$certificationRequirementsVersion
private

Référencé par BiometricStatusReport\getCertificationRequirementsVersion().

◆ $certLevel

$certLevel
private

Référencé par BiometricStatusReport\getCertLevel().

◆ $effectiveDate

$effectiveDate
private

Référencé par BiometricStatusReport\getEffectiveDate().

◆ $modality

$modality
private

Référencé par BiometricStatusReport\getModality().

La documentation de cette classe a été générée à partir du fichier suivant :
  • BiometricStatusReport.php


Joomla CMS: Référence de la classe CodeAccuracyDescriptor

  • Webauthn
  • MetadataService
  • CodeAccuracyDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe CodeAccuracyDescriptor

Fonctions membres publiques

getBase ()
getMinLength ()
getMaxRetries ()
getBlockSlowdown ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$base
$minLength
$maxRetries
$blockSlowdown

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par VerificationMethodDescriptor\createFromArray().

◆ getBase()

getBase ( )

Références CodeAccuracyDescriptor\$base.

◆ getBlockSlowdown()

getBlockSlowdown ( )

Références CodeAccuracyDescriptor\$blockSlowdown.

◆ getMaxRetries()

getMaxRetries ( )

Références CodeAccuracyDescriptor\$maxRetries.

◆ getMinLength()

getMinLength ( )

Références CodeAccuracyDescriptor\$minLength.

Documentation des champs

◆ $base

$base
private

Référencé par CodeAccuracyDescriptor\getBase().

◆ $blockSlowdown

$blockSlowdown
private

Référencé par CodeAccuracyDescriptor\getBlockSlowdown().

◆ $maxRetries

$maxRetries
private

Référencé par CodeAccuracyDescriptor\getMaxRetries().

◆ $minLength

$minLength
private

Référencé par CodeAccuracyDescriptor\getMinLength().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CodeAccuracyDescriptor.php


Joomla CMS: Référence de la classe DisplayPNGCharacteristicsDescriptor

  • Webauthn
  • MetadataService
  • DisplayPNGCharacteristicsDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe DisplayPNGCharacteristicsDescriptor

Fonctions membres publiques

getWidth ()
getHeight ()
getBitDepth ()
getColorType ()
getCompression ()
getFilter ()
getInterlace ()
getPlte ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$width
$height
$bitDepth
$colorType
$compression
$filter
$interlace
$plte = []

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, $item, DisplayPNGCharacteristicsDescriptor\$plte, RgbPaletteEntry\createFromArray(), Assertion\isArray(), et null.

Référencé par MetadataStatement\createFromArray().

◆ getBitDepth()

getBitDepth ( )

Références DisplayPNGCharacteristicsDescriptor\$bitDepth.

◆ getColorType()

getColorType ( )

Références DisplayPNGCharacteristicsDescriptor\$colorType.

◆ getCompression()

getCompression ( )

Références DisplayPNGCharacteristicsDescriptor\$compression.

◆ getFilter()

getFilter ( )

Références DisplayPNGCharacteristicsDescriptor\$filter.

◆ getHeight()

getHeight ( )

Références DisplayPNGCharacteristicsDescriptor\$height.

◆ getInterlace()

getInterlace ( )

Références DisplayPNGCharacteristicsDescriptor\$interlace.

◆ getPlte()

getPlte ( )
Renvoie
RgbPaletteEntry[]

Références DisplayPNGCharacteristicsDescriptor\$plte.

◆ getWidth()

getWidth ( )

Références DisplayPNGCharacteristicsDescriptor\$width.

Documentation des champs

◆ $bitDepth

$bitDepth
private

Référencé par DisplayPNGCharacteristicsDescriptor\getBitDepth().

◆ $colorType

$colorType
private

Référencé par DisplayPNGCharacteristicsDescriptor\getColorType().

◆ $compression

$compression
private

Référencé par DisplayPNGCharacteristicsDescriptor\getCompression().

◆ $filter

$filter
private

Référencé par DisplayPNGCharacteristicsDescriptor\getFilter().

◆ $height

$height
private

Référencé par DisplayPNGCharacteristicsDescriptor\getHeight().

◆ $interlace

$interlace
private

Référencé par DisplayPNGCharacteristicsDescriptor\getInterlace().

◆ $plte

$plte = []
private

Référencé par DisplayPNGCharacteristicsDescriptor\createFromArray(), et DisplayPNGCharacteristicsDescriptor\getPlte().

◆ $width

$width
private

Référencé par DisplayPNGCharacteristicsDescriptor\getWidth().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DisplayPNGCharacteristicsDescriptor.php


Joomla CMS: Référence de la classe DistantSingleMetadata

  • Webauthn
  • MetadataService
  • DistantSingleMetadata
Fonctions membres publiques | Attributs privés
Référence de la classe DistantSingleMetadata
+ Graphe d'héritage de DistantSingleMetadata:
SingleMetadata

Fonctions membres publiques

__construct (string $uri, bool $isBare64Encoded, ClientInterface $httpClient, RequestFactoryInterface $requestFactory, array $additionalHeaders=[])
getMetadataStatement ()
- Fonctions membres publiques hérités de SingleMetadata
__construct (string $data, bool $isBare64Encoded)
getMetadataStatement ()

Attributs privés

$httpClient
$requestFactory
$additionalHeaders
$uri
$isBare64Encoded

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $uri,
 |  | bool | $isBare64Encoded,
 |  | ClientInterface | $httpClient,
 |  | RequestFactoryInterface | $requestFactory,
 |  | array | $additionalHeaders = []
 | ) |  |

Références DistantSingleMetadata\$additionalHeaders, DistantSingleMetadata\$httpClient, DistantSingleMetadata\$isBare64Encoded, DistantSingleMetadata\$requestFactory, DistantSingleMetadata\$uri, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getMetadataStatement()

getMetadataStatement ( )

Références MetadataStatementFetcher\fetchMetadataStatement().

Documentation des champs

◆ $additionalHeaders

$additionalHeaders
private

Référencé par DistantSingleMetadata\__construct().

◆ $httpClient

$httpClient
private

Référencé par DistantSingleMetadata\__construct().

◆ $isBare64Encoded

$isBare64Encoded
private

Référencé par DistantSingleMetadata\__construct().

◆ $requestFactory

$requestFactory
private

Référencé par DistantSingleMetadata\__construct().

◆ $uri

$uri
private

Référencé par DistantSingleMetadata\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DistantSingleMetadata.php


Joomla CMS: Référence de la classe DistantSingleMetadataFactory

  • Webauthn
  • MetadataService
  • DistantSingleMetadataFactory
Fonctions membres publiques | Attributs privés
Référence de la classe DistantSingleMetadataFactory

Fonctions membres publiques

__construct (ClientInterface $httpClient, RequestFactoryInterface $requestFactory)
create (string $uri, bool $isBare64Encoded, array $additionalHeaders=[], ?ClientInterface $client=null)

Attributs privés

$httpClient
$requestFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ClientInterface | $httpClient,
 |  | RequestFactoryInterface | $requestFactory
 | ) |  |

Références DistantSingleMetadataFactory\$httpClient, et DistantSingleMetadataFactory\$requestFactory.

Documentation des fonctions membres

◆ create()

create | ( | string | $uri,
 |  | bool | $isBare64Encoded,
 |  | array | $additionalHeaders = [],
 |  | ?ClientInterface | $client = null
 | ) |  |

Références $client, DistantSingleMetadataFactory\$httpClient, et $uri.

Documentation des champs

◆ $httpClient

$httpClient
private

Référencé par DistantSingleMetadataFactory\__construct(), et DistantSingleMetadataFactory\create().

◆ $requestFactory

$requestFactory
private

Référencé par DistantSingleMetadataFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • DistantSingleMetadataFactory.php


Joomla CMS: Référence de la classe EcdaaTrustAnchor

  • Webauthn
  • MetadataService
  • EcdaaTrustAnchor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe EcdaaTrustAnchor

Fonctions membres publiques

getX ()
getY ()
getC ()
getSx ()
getSy ()
getG1Curve ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$X
$Y
$c
$sx
$sy
$G1Curve

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références EcdaaTrustAnchor\$c, $data, et null.

◆ getC()

getC ( )

Références EcdaaTrustAnchor\$c.

◆ getG1Curve()

getG1Curve ( )

Références EcdaaTrustAnchor\$G1Curve.

◆ getSx()

getSx ( )

Références EcdaaTrustAnchor\$sx.

◆ getSy()

getSy ( )

Références EcdaaTrustAnchor\$sy.

◆ getX()

getX ( )

Références EcdaaTrustAnchor\$X.

◆ getY()

getY ( )

Références EcdaaTrustAnchor\$Y.

Documentation des champs

◆ $c

$c
private

Référencé par EcdaaTrustAnchor\createFromArray(), et EcdaaTrustAnchor\getC().

◆ $G1Curve

$G1Curve
private

Référencé par EcdaaTrustAnchor\getG1Curve().

◆ $sx

$sx
private

Référencé par EcdaaTrustAnchor\getSx().

◆ $sy

$sy
private

Référencé par EcdaaTrustAnchor\getSy().

◆ $X

$X
private

Référencé par EcdaaTrustAnchor\getX().

◆ $Y

$Y
private

Référencé par EcdaaTrustAnchor\getY().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EcdaaTrustAnchor.php


Joomla CMS: Référence de la classe ExtensionDescriptor

  • Webauthn
  • MetadataService
  • ExtensionDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe ExtensionDescriptor

Fonctions membres publiques

getId ()
getTag ()
getData ()
isFailIfUnknown ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$id
$tag
$data
$fail_if_unknown

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références ExtensionDescriptor\$data, et null.

Référencé par MetadataStatement\createFromArray().

◆ getData()

getData ( )

Références ExtensionDescriptor\$data.

◆ getId()

getId ( )

Références ExtensionDescriptor\$id.

◆ getTag()

getTag ( )

Références ExtensionDescriptor\$tag.

◆ isFailIfUnknown()

isFailIfUnknown ( )

Références ExtensionDescriptor\$fail_if_unknown.

Documentation des champs

◆ $data

$data
private

Référencé par ExtensionDescriptor\createFromArray(), et ExtensionDescriptor\getData().

◆ $fail_if_unknown

$fail_if_unknown
private

Référencé par ExtensionDescriptor\isFailIfUnknown().

◆ $id

$id
private

Référencé par ExtensionDescriptor\getId().

◆ $tag

$tag
private

Référencé par ExtensionDescriptor\getTag().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ExtensionDescriptor.php


Joomla CMS: Référence de la classe MetadataService

  • Webauthn
  • MetadataService
  • MetadataService
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe MetadataService

Fonctions membres publiques

__construct (string $serviceUri, ClientInterface $httpClient, RequestFactoryInterface $requestFactory, array $additionalQueryStringValues=[], array $additionalHeaders=[])
getMetadataStatementFor (MetadataTOCPayloadEntry $entry)
getMetadataTOCPayload ()

Fonctions membres privées

buildUri (string $uri)

Attributs privés

$httpClient
$requestFactory
$additionalQueryStringValues
$additionalHeaders
$serviceUri

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $serviceUri,
 |  | ClientInterface | $httpClient,
 |  | RequestFactoryInterface | $requestFactory,
 |  | array | $additionalQueryStringValues = [],
 |  | array | $additionalHeaders = []
 | ) |  |

Références MetadataService\$additionalHeaders, MetadataService\$additionalQueryStringValues, MetadataService\$httpClient, MetadataService\$requestFactory, et MetadataService\$serviceUri.

Documentation des fonctions membres

◆ buildUri()

buildUri ( string $uri )
private

Références $query, et $uri.

Référencé par MetadataService\getMetadataStatementFor(), et MetadataService\getMetadataTOCPayload().

◆ getMetadataStatementFor()

getMetadataStatementFor ( MetadataTOCPayloadEntry $entry )

Références $uri, MetadataService\buildUri(), MetadataStatementFetcher\fetchMetadataStatement(), et MetadataTOCPayloadEntry\getUrl().

◆ getMetadataTOCPayload()

getMetadataTOCPayload ( )

Références $uri, MetadataService\buildUri(), et MetadataStatementFetcher\fetchTableOfContent().

Documentation des champs

◆ $additionalHeaders

$additionalHeaders
private

Référencé par MetadataService\__construct().

◆ $additionalQueryStringValues

$additionalQueryStringValues
private

Référencé par MetadataService\__construct().

◆ $httpClient

$httpClient
private

Référencé par MetadataService\__construct().

◆ $requestFactory

$requestFactory
private

Référencé par MetadataService\__construct().

◆ $serviceUri

$serviceUri
private

Référencé par MetadataService\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataService.php


Joomla CMS: Référence de la classe MetadataServiceFactory

  • Webauthn
  • MetadataService
  • MetadataServiceFactory
Fonctions membres publiques | Attributs privés
Référence de la classe MetadataServiceFactory

Fonctions membres publiques

__construct (ClientInterface $httpClient, RequestFactoryInterface $requestFactory)
create (string $serviceUri, array $additionalQueryStringValues=[], array $additionalHeaders=[], ?ClientInterface $client=null)

Attributs privés

$httpClient
$requestFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ClientInterface | $httpClient,
 |  | RequestFactoryInterface | $requestFactory
 | ) |  |

Références MetadataServiceFactory\$httpClient, et MetadataServiceFactory\$requestFactory.

Documentation des fonctions membres

◆ create()

create | ( | string | $serviceUri,
 |  | array | $additionalQueryStringValues = [],
 |  | array | $additionalHeaders = [],
 |  | ?ClientInterface | $client = null
 | ) |  |

Références $client, et MetadataServiceFactory\$httpClient.

Documentation des champs

◆ $httpClient

$httpClient
private

Référencé par MetadataServiceFactory\__construct(), et MetadataServiceFactory\create().

◆ $requestFactory

$requestFactory
private

Référencé par MetadataServiceFactory\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataServiceFactory.php


Joomla CMS: Référence de la classe MetadataStatement

  • Webauthn
  • MetadataService
  • MetadataStatement
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe MetadataStatement

Fonctions membres publiques

getLegalHeader ()
getAaid ()
getAaguid ()
getAttestationCertificateKeyIdentifiers ()
getDescription ()
getAlternativeDescriptions ()
getAuthenticatorVersion ()
getProtocolFamily ()
getUpv ()
getAssertionScheme ()
getAuthenticationAlgorithm ()
getAuthenticationAlgorithms ()
getPublicKeyAlgAndEncoding ()
getPublicKeyAlgAndEncodings ()
getAttestationTypes ()
getUserVerificationDetails ()
getKeyProtection ()
isKeyRestricted ()
isFreshUserVerificationRequired ()
getMatcherProtection ()
getCryptoStrength ()
getOperatingEnv ()
getAttachmentHint ()
isSecondFactorOnly ()
getTcDisplay ()
getTcDisplayContentType ()
getTcDisplayPNGCharacteristics ()
getAttestationRootCertificates ()
getEcdaaTrustAnchors ()
getIcon ()
getSupportedExtensions ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Champs de données

const | KEY_PROTECTION_SOFTWARE = 0x0001
const | KEY_PROTECTION_HARDWARE = 0x0002
const | KEY_PROTECTION_TEE = 0x0004
const | KEY_PROTECTION_SECURE_ELEMENT = 0x0008
const | KEY_PROTECTION_REMOTE_HANDLE = 0x0010
const | MATCHER_PROTECTION_SOFTWARE = 0x0001
const | MATCHER_PROTECTION_TEE = 0x0002
const | MATCHER_PROTECTION_ON_CHIP = 0x0004
const | ATTACHMENT_HINT_INTERNAL = 0x0001
const | ATTACHMENT_HINT_EXTERNAL = 0x0002
const | ATTACHMENT_HINT_WIRED = 0x0004
const | ATTACHMENT_HINT_WIRELESS = 0x0008
const | ATTACHMENT_HINT_NFC = 0x0010
const | ATTACHMENT_HINT_BLUETOOTH = 0x0020
const | ATTACHMENT_HINT_NETWORK = 0x0040
const | ATTACHMENT_HINT_READY = 0x0080
const | ATTACHMENT_HINT_WIFI_DIRECT = 0x0100
const | TRANSACTION_CONFIRMATION_DISPLAY_ANY = 0x0001
const | TRANSACTION_CONFIRMATION_DISPLAY_PRIVILEGED_SOFTWARE = 0x0002
const | TRANSACTION_CONFIRMATION_DISPLAY_TEE = 0x0004
const | TRANSACTION_CONFIRMATION_DISPLAY_HARDWARE = 0x0008
const | TRANSACTION_CONFIRMATION_DISPLAY_REMOTE = 0x0010
const | ALG_SIGN_SECP256R1_ECDSA_SHA256_RAW = 0x0001
const | ALG_SIGN_SECP256R1_ECDSA_SHA256_DER = 0x0002
const | ALG_SIGN_RSASSA_PSS_SHA256_RAW = 0x0003
const | ALG_SIGN_RSASSA_PSS_SHA256_DER = 0x0004
const | ALG_SIGN_SECP256K1_ECDSA_SHA256_RAW = 0x0005
const | ALG_SIGN_SECP256K1_ECDSA_SHA256_DER = 0x0006
const | ALG_SIGN_SM2_SM3_RAW = 0x0007
const | ALG_SIGN_RSA_EMSA_PKCS1_SHA256_RAW = 0x0008
const | ALG_SIGN_RSA_EMSA_PKCS1_SHA256_DER = 0x0009
const | ALG_SIGN_RSASSA_PSS_SHA384_RAW = 0x000A
const | ALG_SIGN_RSASSA_PSS_SHA512_RAW = 0x000B
const | ALG_SIGN_RSASSA_PKCSV15_SHA256_RAW = 0x000C
const | ALG_SIGN_RSASSA_PKCSV15_SHA384_RAW = 0x000D
const | ALG_SIGN_RSASSA_PKCSV15_SHA512_RAW = 0x000E
const | ALG_SIGN_RSASSA_PKCSV15_SHA1_RAW = 0x000F
const | ALG_SIGN_SECP384R1_ECDSA_SHA384_RAW = 0x0010
const | ALG_SIGN_SECP521R1_ECDSA_SHA512_RAW = 0x0011
const | ALG_SIGN_ED25519_EDDSA_SHA256_RAW = 0x0012
const | ALG_KEY_ECC_X962_RAW = 0x0100
const | ALG_KEY_ECC_X962_DER = 0x0101
const | ALG_KEY_RSA_2048_RAW = 0x0102
const | ALG_KEY_RSA_2048_DER = 0x0103
const | ALG_KEY_COSE = 0x0104
const | ATTESTATION_BASIC_FULL = 0x3E07
const | ATTESTATION_BASIC_SURROGATE = 0x3E08
const | ATTESTATION_ECDAA = 0x3E09
const | ATTESTATION_ATTCA = 0x3E0A

Attributs privés

$legalHeader
$aaid
$aaguid
$attestationCertificateKeyIdentifiers = []
$description
$alternativeDescriptions = []
$authenticatorVersion
$protocolFamily
$upv = []
$assertionScheme
$authenticationAlgorithm
$authenticationAlgorithms = []
$publicKeyAlgAndEncoding
$publicKeyAlgAndEncodings = []
$attestationTypes = []
$userVerificationDetails = []
$keyProtection
$isKeyRestricted
$isFreshUserVerificationRequired
$matcherProtection
$cryptoStrength
$operatingEnv
$attachmentHint = 0
$isSecondFactorOnly
$tcDisplay
$tcDisplayContentType
$tcDisplayPNGCharacteristics = []
$attestationRootCertificates = []
$ecdaaTrustAnchors = []
$icon
$supportedExtensions = []

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, $key, MetadataStatement\$supportedExtensions, MetadataStatement\$tcDisplayPNGCharacteristics, MetadataStatement\$upv, MetadataStatement\$userVerificationDetails, $value, VerificationMethodANDCombinations\createFromArray(), Version\createFromArray(), ExtensionDescriptor\createFromArray(), DisplayPNGCharacteristicsDescriptor\createFromArray(), Assertion\isArray(), et null.

Référencé par MetadataStatementFetcher\fetchMetadataStatement(), SingleMetadata\getMetadataStatement(), et MetadataRepository\load().

◆ getAaguid()

getAaguid ( )

Références MetadataStatement\$aaguid.

◆ getAaid()

getAaid ( )

Références MetadataStatement\$aaid.

◆ getAlternativeDescriptions()

getAlternativeDescriptions ( )
Renvoie
string[]

Références MetadataStatement\$alternativeDescriptions.

◆ getAssertionScheme()

getAssertionScheme ( )

Références MetadataStatement\$assertionScheme.

◆ getAttachmentHint()

getAttachmentHint ( )

Références MetadataStatement\$attachmentHint.

◆ getAttestationCertificateKeyIdentifiers()

getAttestationCertificateKeyIdentifiers ( )
Renvoie
string[]

Références MetadataStatement\$attestationCertificateKeyIdentifiers.

◆ getAttestationRootCertificates()

getAttestationRootCertificates ( )
Renvoie
string[]

Références MetadataStatement\$attestationRootCertificates.

◆ getAttestationTypes()

getAttestationTypes ( )
Renvoie
int[]

Références MetadataStatement\$attestationTypes.

◆ getAuthenticationAlgorithm()

getAuthenticationAlgorithm ( )

Références MetadataStatement\$authenticationAlgorithm.

◆ getAuthenticationAlgorithms()

getAuthenticationAlgorithms ( )
Renvoie
int[]

Références MetadataStatement\$authenticationAlgorithms.

◆ getAuthenticatorVersion()

getAuthenticatorVersion ( )

Références MetadataStatement\$authenticatorVersion.

◆ getCryptoStrength()

getCryptoStrength ( )

Références MetadataStatement\$cryptoStrength.

◆ getDescription()

getDescription ( )

Références MetadataStatement\$description.

◆ getEcdaaTrustAnchors()

getEcdaaTrustAnchors ( )
Renvoie
EcdaaTrustAnchor[]

Références MetadataStatement\$ecdaaTrustAnchors.

◆ getIcon()

getIcon ( )

Références MetadataStatement\$icon.

◆ getKeyProtection()

getKeyProtection ( )

Références MetadataStatement\$keyProtection.

◆ getLegalHeader()

getLegalHeader ( )

Références MetadataStatement\$legalHeader.

◆ getMatcherProtection()

getMatcherProtection ( )

Références MetadataStatement\$matcherProtection.

◆ getOperatingEnv()

getOperatingEnv ( )

Références MetadataStatement\$operatingEnv.

◆ getProtocolFamily()

getProtocolFamily ( )

Références MetadataStatement\$protocolFamily.

◆ getPublicKeyAlgAndEncoding()

getPublicKeyAlgAndEncoding ( )

Références MetadataStatement\$publicKeyAlgAndEncoding.

◆ getPublicKeyAlgAndEncodings()

getPublicKeyAlgAndEncodings ( )
Renvoie
int[]

Références MetadataStatement\$publicKeyAlgAndEncodings.

◆ getSupportedExtensions()

getSupportedExtensions ( )
Renvoie
ExtensionDescriptor[]

Références MetadataStatement\$supportedExtensions.

◆ getTcDisplay()

getTcDisplay ( )

Références MetadataStatement\$tcDisplay.

◆ getTcDisplayContentType()

getTcDisplayContentType ( )

Références MetadataStatement\$tcDisplayContentType.

◆ getTcDisplayPNGCharacteristics()

getTcDisplayPNGCharacteristics ( )
Renvoie
DisplayPNGCharacteristicsDescriptor[]

Références MetadataStatement\$tcDisplayPNGCharacteristics.

◆ getUpv()

getUpv ( )
Renvoie
Version[]

Références MetadataStatement\$upv.

◆ getUserVerificationDetails()

getUserVerificationDetails ( )
Renvoie
VerificationMethodANDCombinations[]

Références MetadataStatement\$userVerificationDetails.

◆ isFreshUserVerificationRequired()

isFreshUserVerificationRequired ( )

Références MetadataStatement\$isFreshUserVerificationRequired.

◆ isKeyRestricted()

isKeyRestricted ( )

Références MetadataStatement\$isKeyRestricted.

◆ isSecondFactorOnly()

isSecondFactorOnly ( )

Références MetadataStatement\$isSecondFactorOnly.

Documentation des champs

◆ $aaguid

$aaguid
private

Référencé par MetadataStatement\getAaguid().

◆ $aaid

$aaid
private

Référencé par MetadataStatement\getAaid().

◆ $alternativeDescriptions

$alternativeDescriptions = []
private

Référencé par MetadataStatement\getAlternativeDescriptions().

◆ $assertionScheme

$assertionScheme
private

Référencé par MetadataStatement\getAssertionScheme().

◆ $attachmentHint

$attachmentHint = 0
private

Référencé par MetadataStatement\getAttachmentHint().

◆ $attestationCertificateKeyIdentifiers

$attestationCertificateKeyIdentifiers = []
private

Référencé par MetadataStatement\getAttestationCertificateKeyIdentifiers().

◆ $attestationRootCertificates

$attestationRootCertificates = []
private

Référencé par MetadataStatement\getAttestationRootCertificates().

◆ $attestationTypes

$attestationTypes = []
private

Référencé par MetadataStatement\getAttestationTypes().

◆ $authenticationAlgorithm

$authenticationAlgorithm
private

Référencé par MetadataStatement\getAuthenticationAlgorithm().

◆ $authenticationAlgorithms

$authenticationAlgorithms = []
private

Référencé par MetadataStatement\getAuthenticationAlgorithms().

◆ $authenticatorVersion

$authenticatorVersion
private

Référencé par MetadataStatement\getAuthenticatorVersion().

◆ $cryptoStrength

$cryptoStrength
private

Référencé par MetadataStatement\getCryptoStrength().

◆ $description

$description
private

Référencé par MetadataStatement\getDescription().

◆ $ecdaaTrustAnchors

$ecdaaTrustAnchors = []
private

Référencé par MetadataStatement\getEcdaaTrustAnchors().

◆ $icon

$icon
private

Référencé par MetadataStatement\getIcon().

◆ $isFreshUserVerificationRequired

$isFreshUserVerificationRequired
private

Référencé par MetadataStatement\isFreshUserVerificationRequired().

◆ $isKeyRestricted

$isKeyRestricted
private

Référencé par MetadataStatement\isKeyRestricted().

◆ $isSecondFactorOnly

$isSecondFactorOnly
private

Référencé par MetadataStatement\isSecondFactorOnly().

◆ $keyProtection

$keyProtection
private

Référencé par MetadataStatement\getKeyProtection().

◆ $legalHeader

$legalHeader
private

Référencé par MetadataStatement\getLegalHeader().

◆ $matcherProtection

$matcherProtection
private

Référencé par MetadataStatement\getMatcherProtection().

◆ $operatingEnv

$operatingEnv
private

Référencé par MetadataStatement\getOperatingEnv().

◆ $protocolFamily

$protocolFamily
private

Référencé par MetadataStatement\getProtocolFamily().

◆ $publicKeyAlgAndEncoding

$publicKeyAlgAndEncoding
private

Référencé par MetadataStatement\getPublicKeyAlgAndEncoding().

◆ $publicKeyAlgAndEncodings

$publicKeyAlgAndEncodings = []
private

Référencé par MetadataStatement\getPublicKeyAlgAndEncodings().

◆ $supportedExtensions

$supportedExtensions = []
private

Référencé par MetadataStatement\createFromArray(), et MetadataStatement\getSupportedExtensions().

◆ $tcDisplay

$tcDisplay
private

Référencé par MetadataStatement\getTcDisplay().

◆ $tcDisplayContentType

$tcDisplayContentType
private

Référencé par MetadataStatement\getTcDisplayContentType().

◆ $tcDisplayPNGCharacteristics

$tcDisplayPNGCharacteristics = []
private

Référencé par MetadataStatement\createFromArray(), et MetadataStatement\getTcDisplayPNGCharacteristics().

◆ $upv

$upv = []
private

Référencé par MetadataStatement\createFromArray(), et MetadataStatement\getUpv().

◆ $userVerificationDetails

$userVerificationDetails = []
private

Référencé par MetadataStatement\createFromArray(), et MetadataStatement\getUserVerificationDetails().

◆ ALG_KEY_COSE

const ALG_KEY_COSE = 0x0104

◆ ALG_KEY_ECC_X962_DER

const ALG_KEY_ECC_X962_DER = 0x0101

◆ ALG_KEY_ECC_X962_RAW

const ALG_KEY_ECC_X962_RAW = 0x0100

◆ ALG_KEY_RSA_2048_DER

const ALG_KEY_RSA_2048_DER = 0x0103

◆ ALG_KEY_RSA_2048_RAW

const ALG_KEY_RSA_2048_RAW = 0x0102

◆ ALG_SIGN_ED25519_EDDSA_SHA256_RAW

const ALG_SIGN_ED25519_EDDSA_SHA256_RAW = 0x0012

◆ ALG_SIGN_RSA_EMSA_PKCS1_SHA256_DER

const ALG_SIGN_RSA_EMSA_PKCS1_SHA256_DER = 0x0009

◆ ALG_SIGN_RSA_EMSA_PKCS1_SHA256_RAW

const ALG_SIGN_RSA_EMSA_PKCS1_SHA256_RAW = 0x0008

◆ ALG_SIGN_RSASSA_PKCSV15_SHA1_RAW

const ALG_SIGN_RSASSA_PKCSV15_SHA1_RAW = 0x000F

◆ ALG_SIGN_RSASSA_PKCSV15_SHA256_RAW

const ALG_SIGN_RSASSA_PKCSV15_SHA256_RAW = 0x000C

◆ ALG_SIGN_RSASSA_PKCSV15_SHA384_RAW

const ALG_SIGN_RSASSA_PKCSV15_SHA384_RAW = 0x000D

◆ ALG_SIGN_RSASSA_PKCSV15_SHA512_RAW

const ALG_SIGN_RSASSA_PKCSV15_SHA512_RAW = 0x000E

◆ ALG_SIGN_RSASSA_PSS_SHA256_DER

const ALG_SIGN_RSASSA_PSS_SHA256_DER = 0x0004

◆ ALG_SIGN_RSASSA_PSS_SHA256_RAW

const ALG_SIGN_RSASSA_PSS_SHA256_RAW = 0x0003

◆ ALG_SIGN_RSASSA_PSS_SHA384_RAW

const ALG_SIGN_RSASSA_PSS_SHA384_RAW = 0x000A

◆ ALG_SIGN_RSASSA_PSS_SHA512_RAW

const ALG_SIGN_RSASSA_PSS_SHA512_RAW = 0x000B

◆ ALG_SIGN_SECP256K1_ECDSA_SHA256_DER

const ALG_SIGN_SECP256K1_ECDSA_SHA256_DER = 0x0006

◆ ALG_SIGN_SECP256K1_ECDSA_SHA256_RAW

const ALG_SIGN_SECP256K1_ECDSA_SHA256_RAW = 0x0005

◆ ALG_SIGN_SECP256R1_ECDSA_SHA256_DER

const ALG_SIGN_SECP256R1_ECDSA_SHA256_DER = 0x0002

◆ ALG_SIGN_SECP256R1_ECDSA_SHA256_RAW

const ALG_SIGN_SECP256R1_ECDSA_SHA256_RAW = 0x0001

◆ ALG_SIGN_SECP384R1_ECDSA_SHA384_RAW

const ALG_SIGN_SECP384R1_ECDSA_SHA384_RAW = 0x0010

◆ ALG_SIGN_SECP521R1_ECDSA_SHA512_RAW

const ALG_SIGN_SECP521R1_ECDSA_SHA512_RAW = 0x0011

◆ ALG_SIGN_SM2_SM3_RAW

const ALG_SIGN_SM2_SM3_RAW = 0x0007

◆ ATTACHMENT_HINT_BLUETOOTH

const ATTACHMENT_HINT_BLUETOOTH = 0x0020

◆ ATTACHMENT_HINT_EXTERNAL

const ATTACHMENT_HINT_EXTERNAL = 0x0002

◆ ATTACHMENT_HINT_INTERNAL

const ATTACHMENT_HINT_INTERNAL = 0x0001

◆ ATTACHMENT_HINT_NETWORK

const ATTACHMENT_HINT_NETWORK = 0x0040

◆ ATTACHMENT_HINT_NFC

const ATTACHMENT_HINT_NFC = 0x0010

◆ ATTACHMENT_HINT_READY

const ATTACHMENT_HINT_READY = 0x0080

◆ ATTACHMENT_HINT_WIFI_DIRECT

const ATTACHMENT_HINT_WIFI_DIRECT = 0x0100

◆ ATTACHMENT_HINT_WIRED

const ATTACHMENT_HINT_WIRED = 0x0004

◆ ATTACHMENT_HINT_WIRELESS

const ATTACHMENT_HINT_WIRELESS = 0x0008

◆ ATTESTATION_ATTCA

const ATTESTATION_ATTCA = 0x3E0A

◆ ATTESTATION_BASIC_FULL

const ATTESTATION_BASIC_FULL = 0x3E07

◆ ATTESTATION_BASIC_SURROGATE

const ATTESTATION_BASIC_SURROGATE = 0x3E08

◆ ATTESTATION_ECDAA

const ATTESTATION_ECDAA = 0x3E09

◆ KEY_PROTECTION_HARDWARE

const KEY_PROTECTION_HARDWARE = 0x0002

◆ KEY_PROTECTION_REMOTE_HANDLE

const KEY_PROTECTION_REMOTE_HANDLE = 0x0010

◆ KEY_PROTECTION_SECURE_ELEMENT

const KEY_PROTECTION_SECURE_ELEMENT = 0x0008

◆ KEY_PROTECTION_SOFTWARE

const KEY_PROTECTION_SOFTWARE = 0x0001

◆ KEY_PROTECTION_TEE

const KEY_PROTECTION_TEE = 0x0004

◆ MATCHER_PROTECTION_ON_CHIP

const MATCHER_PROTECTION_ON_CHIP = 0x0004

◆ MATCHER_PROTECTION_SOFTWARE

const MATCHER_PROTECTION_SOFTWARE = 0x0001

◆ MATCHER_PROTECTION_TEE

const MATCHER_PROTECTION_TEE = 0x0002

◆ TRANSACTION_CONFIRMATION_DISPLAY_ANY

const TRANSACTION_CONFIRMATION_DISPLAY_ANY = 0x0001

◆ TRANSACTION_CONFIRMATION_DISPLAY_HARDWARE

const TRANSACTION_CONFIRMATION_DISPLAY_HARDWARE = 0x0008

◆ TRANSACTION_CONFIRMATION_DISPLAY_PRIVILEGED_SOFTWARE

const TRANSACTION_CONFIRMATION_DISPLAY_PRIVILEGED_SOFTWARE = 0x0002

◆ TRANSACTION_CONFIRMATION_DISPLAY_REMOTE

const TRANSACTION_CONFIRMATION_DISPLAY_REMOTE = 0x0010

◆ TRANSACTION_CONFIRMATION_DISPLAY_TEE

const TRANSACTION_CONFIRMATION_DISPLAY_TEE = 0x0004
La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataStatement.php


Joomla CMS: Référence de la classe MetadataStatementFetcher

  • Webauthn
  • MetadataService
  • MetadataStatementFetcher
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe MetadataStatementFetcher

Fonctions membres publiques statiques

static | fetchTableOfContent (string $uri, ClientInterface $client, RequestFactoryInterface $requestFactory, array $additionalHeaders=[])
static | fetchMetadataStatement (string $uri, bool $isBase64UrlEncoded, ClientInterface $client, RequestFactoryInterface $requestFactory, array $additionalHeaders=[])

Fonctions membres privées statiques

static | fetch (string $uri, ClientInterface $client, RequestFactoryInterface $requestFactory, array $additionalHeaders=[])
static | getJwsPayload (string $token)

Documentation des fonctions membres

◆ fetch()

static fetch | ( | string | $uri,
 |  | ClientInterface | $client,
 |  | RequestFactoryInterface | $requestFactory,
 |  | array | $additionalHeaders = []
 | ) |  |
staticprivate

Références $client, $content, $uri, RequestFactoryInterface\createRequest(), Assertion\eq(), et Assertion\notEmpty().

◆ fetchMetadataStatement()

static fetchMetadataStatement | ( | string | $uri,
 |  | bool | $isBase64UrlEncoded,
 |  | ClientInterface | $client,
 |  | RequestFactoryInterface | $requestFactory,
 |  | array | $additionalHeaders = []
 | ) |  |
static

Références $client, $data, $uri, MetadataStatement\createFromArray(), Base64Url\decode(), et Assertion\eq().

Référencé par DistantSingleMetadata\getMetadataStatement(), et MetadataService\getMetadataStatementFor().

◆ fetchTableOfContent()

static fetchTableOfContent | ( | string | $uri,
 |  | ClientInterface | $client,
 |  | RequestFactoryInterface | $requestFactory,
 |  | array | $additionalHeaders = []
 | ) |  |
static

Références $client, $content, $data, $uri, MetadataTOCPayload\createFromArray(), et Assertion\eq().

Référencé par MetadataService\getMetadataTOCPayload().

◆ getJwsPayload()

static getJwsPayload ( string $token )
staticprivate

Références $header, $key, Assertion\eq(), Assertion\isArray(), Assertion\keyExists(), Assertion\notEmpty(), et Assertion\true().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataStatementFetcher.php


Joomla CMS: Référence de l'interface MetadataStatementRepository

  • Webauthn
  • MetadataService
  • MetadataStatementRepository
Fonctions membres publiques
Référence de l'interface MetadataStatementRepository
+ Graphe d'héritage de MetadataStatementRepository:
MetadataRepository SimpleMetadataStatementRepository

Fonctions membres publiques

findOneByAAGUID (string $aaguid)

Documentation des fonctions membres

◆ findOneByAAGUID()

findOneByAAGUID ( string $aaguid )

Implémenté dans MetadataRepository, et SimpleMetadataStatementRepository.

Référencé par CertificateToolbox\checkAttestationMedata().

La documentation de cette interface a été générée à partir du fichier suivant :
  • MetadataStatementRepository.php


Joomla CMS: Référence de la classe MetadataTOCPayload

  • Webauthn
  • MetadataService
  • MetadataTOCPayload
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe MetadataTOCPayload

Fonctions membres publiques

getLegalHeader ()
getNo ()
getNextUpdate ()
getEntries ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$legalHeader
$no
$nextUpdate
$entries = []

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, MetadataTOCPayloadEntry\createFromArray(), et null.

Référencé par MetadataStatementFetcher\fetchTableOfContent().

◆ getEntries()

getEntries ( )
Renvoie
MetadataTOCPayloadEntry[]

Références MetadataTOCPayload\$entries.

◆ getLegalHeader()

getLegalHeader ( )

Références MetadataTOCPayload\$legalHeader.

◆ getNextUpdate()

getNextUpdate ( )

Références MetadataTOCPayload\$nextUpdate.

◆ getNo()

getNo ( )

Références MetadataTOCPayload\$no.

Documentation des champs

◆ $entries

$entries = []
private

Référencé par MetadataTOCPayload\getEntries().

◆ $legalHeader

$legalHeader
private

Référencé par MetadataTOCPayload\getLegalHeader().

◆ $nextUpdate

$nextUpdate
private

Référencé par MetadataTOCPayload\getNextUpdate().

◆ $no

$no
private

Référencé par MetadataTOCPayload\getNo().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataTOCPayload.php


Joomla CMS: Référence de la classe MetadataTOCPayloadEntry

  • Webauthn
  • MetadataService
  • MetadataTOCPayloadEntry
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe MetadataTOCPayloadEntry

Fonctions membres publiques

getAaid ()
getAaguid ()
getAttestationCertificateKeyIdentifiers ()
getHash ()
getUrl ()
getBiometricStatusReports ()
getStatusReports ()
getTimeOfLastStatusChange ()
getRogueListURL ()
getRogueListHash ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$aaid
$aaguid
$attestationCertificateKeyIdentifiers = []
$hash
$url
$biometricStatusReports = []
$statusReports = []
$timeOfLastStatusChange
$rogueListURL
$rogueListHash

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, BiometricStatusReport\createFromArray(), StatusReport\createFromArray(), Assertion\isArray(), et null.

Référencé par MetadataTOCPayload\createFromArray().

◆ getAaguid()

getAaguid ( )

Références MetadataTOCPayloadEntry\$aaguid.

◆ getAaid()

getAaid ( )

Références MetadataTOCPayloadEntry\$aaid.

◆ getAttestationCertificateKeyIdentifiers()

getAttestationCertificateKeyIdentifiers ( )

Références MetadataTOCPayloadEntry\$attestationCertificateKeyIdentifiers.

◆ getBiometricStatusReports()

getBiometricStatusReports ( )

Références MetadataTOCPayloadEntry\$biometricStatusReports.

◆ getHash()

getHash ( )

Références MetadataTOCPayloadEntry\$hash.

◆ getRogueListHash()

getRogueListHash ( )

Références MetadataTOCPayloadEntry\$rogueListHash.

◆ getRogueListURL()

getRogueListURL ( )

Références MetadataTOCPayloadEntry\$rogueListURL.

◆ getStatusReports()

getStatusReports ( )
Renvoie
StatusReport[]

Références MetadataTOCPayloadEntry\$statusReports.

◆ getTimeOfLastStatusChange()

getTimeOfLastStatusChange ( )

Références MetadataTOCPayloadEntry\$timeOfLastStatusChange.

◆ getUrl()

getUrl ( )

Références MetadataTOCPayloadEntry\$url.

Référencé par MetadataService\getMetadataStatementFor().

Documentation des champs

◆ $aaguid

$aaguid
private

Référencé par MetadataTOCPayloadEntry\getAaguid().

◆ $aaid

$aaid
private

Référencé par MetadataTOCPayloadEntry\getAaid().

◆ $attestationCertificateKeyIdentifiers

$attestationCertificateKeyIdentifiers = []
private

Référencé par MetadataTOCPayloadEntry\getAttestationCertificateKeyIdentifiers().

◆ $biometricStatusReports

$biometricStatusReports = []
private

Référencé par MetadataTOCPayloadEntry\getBiometricStatusReports().

◆ $hash

$hash
private

Référencé par MetadataTOCPayloadEntry\getHash().

◆ $rogueListHash

$rogueListHash
private

Référencé par MetadataTOCPayloadEntry\getRogueListHash().

◆ $rogueListURL

$rogueListURL
private

Référencé par MetadataTOCPayloadEntry\getRogueListURL().

◆ $statusReports

$statusReports = []
private

Référencé par MetadataTOCPayloadEntry\getStatusReports().

◆ $timeOfLastStatusChange

$timeOfLastStatusChange
private

Référencé par MetadataTOCPayloadEntry\getTimeOfLastStatusChange().

◆ $url

$url
private

Référencé par MetadataTOCPayloadEntry\getUrl().

La documentation de cette classe a été générée à partir du fichier suivant :
  • MetadataTOCPayloadEntry.php


Joomla CMS: Référence de la classe PatternAccuracyDescriptor

  • Webauthn
  • MetadataService
  • PatternAccuracyDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe PatternAccuracyDescriptor

Fonctions membres publiques

getMinComplexity ()
getMaxRetries ()
getBlockSlowdown ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$minComplexity
$maxRetries
$blockSlowdown

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par VerificationMethodDescriptor\createFromArray().

◆ getBlockSlowdown()

getBlockSlowdown ( )

Références PatternAccuracyDescriptor\$blockSlowdown.

◆ getMaxRetries()

getMaxRetries ( )

Références PatternAccuracyDescriptor\$maxRetries.

◆ getMinComplexity()

getMinComplexity ( )

Références PatternAccuracyDescriptor\$minComplexity.

Documentation des champs

◆ $blockSlowdown

$blockSlowdown
private

Référencé par PatternAccuracyDescriptor\getBlockSlowdown().

◆ $maxRetries

$maxRetries
private

Référencé par PatternAccuracyDescriptor\getMaxRetries().

◆ $minComplexity

$minComplexity
private

Référencé par PatternAccuracyDescriptor\getMinComplexity().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PatternAccuracyDescriptor.php


Joomla CMS: Référence de la classe RgbPaletteEntry

  • Webauthn
  • MetadataService
  • RgbPaletteEntry
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe RgbPaletteEntry

Fonctions membres publiques

getR ()
getG ()
getB ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$r
$g
$b

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par DisplayPNGCharacteristicsDescriptor\createFromArray().

◆ getB()

getB ( )

Références RgbPaletteEntry\$b.

◆ getG()

getG ( )

Références RgbPaletteEntry\$g.

◆ getR()

getR ( )

Références RgbPaletteEntry\$r.

Documentation des champs

◆ $b

$b
private

Référencé par RgbPaletteEntry\getB().

◆ $g

$g
private

Référencé par RgbPaletteEntry\getG().

◆ $r

$r
private

Référencé par RgbPaletteEntry\getR().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RgbPaletteEntry.php


Joomla CMS: Référence de la classe RogueListEntry

  • Webauthn
  • MetadataService
  • RogueListEntry
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe RogueListEntry

Fonctions membres publiques

getSk ()
getDate ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$sk
$date

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

◆ getDate()

getDate ( )

Références RogueListEntry\$date.

◆ getSk()

getSk ( )

Références RogueListEntry\$sk.

Documentation des champs

◆ $date

$date
private

Référencé par RogueListEntry\getDate().

◆ $sk

$sk
private

Référencé par RogueListEntry\getSk().

La documentation de cette classe a été générée à partir du fichier suivant :
  • RogueListEntry.php


Joomla CMS: Référence de la classe SimpleMetadataStatementRepository

  • Webauthn
  • MetadataService
  • SimpleMetadataStatementRepository
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe SimpleMetadataStatementRepository
+ Graphe d'héritage de SimpleMetadataStatementRepository:
MetadataStatementRepository

Fonctions membres publiques

__construct (CacheItemPoolInterface $cacheItemPool)
addService (string $name, MetadataService $service)
addSingleStatement (string $name, SingleMetadata $singleStatements)
findOneByAAGUID (string $aaguid)

Fonctions membres privées

findOneByAAGUIDFromSingleStatements (string $aaguid)
findOneByAAGUIDFromServices (string $aaguid)

Attributs privés

$cacheItemPool
$services = []
$singleStatements = []

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CacheItemPoolInterface $cacheItemPool )

Références SimpleMetadataStatementRepository\$cacheItemPool.

Documentation des fonctions membres

◆ addService()

addService | ( | string | $name,
 |  | MetadataService | $service
 | ) |  |

Références $name.

◆ addSingleStatement()

addSingleStatement | ( | string | $name,
 |  | SingleMetadata | $singleStatements
 | ) |  |

Références $name, et SimpleMetadataStatementRepository\$singleStatements.

◆ findOneByAAGUID()

findOneByAAGUID ( string $aaguid )

Implémente MetadataStatementRepository.

Références SimpleMetadataStatementRepository\findOneByAAGUIDFromServices(), SimpleMetadataStatementRepository\findOneByAAGUIDFromSingleStatements(), et null.

◆ findOneByAAGUIDFromServices()

findOneByAAGUIDFromServices ( string $aaguid )
private

Références $name, $url, et null.

Référencé par SimpleMetadataStatementRepository\findOneByAAGUID().

◆ findOneByAAGUIDFromSingleStatements()

findOneByAAGUIDFromSingleStatements ( string $aaguid )
private

Références $name, et null.

Référencé par SimpleMetadataStatementRepository\findOneByAAGUID().

Documentation des champs

◆ $cacheItemPool

$cacheItemPool
private

Référencé par SimpleMetadataStatementRepository\__construct().

◆ $services

$services = []
private

◆ $singleStatements

$singleStatements = []
private

Référencé par SimpleMetadataStatementRepository\addSingleStatement().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SimpleMetadataStatementRepository.php


Joomla CMS: Référence de la classe SingleMetadata

  • Webauthn
  • MetadataService
  • SingleMetadata
Fonctions membres publiques | Attributs privés
Référence de la classe SingleMetadata
+ Graphe d'héritage de SingleMetadata:
DistantSingleMetadata

Fonctions membres publiques

__construct (string $data, bool $isBare64Encoded)
getMetadataStatement ()

Attributs privés

$statement
$data
$isBare64Encoded

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $data,
 |  | bool | $isBare64Encoded
 | ) |  |

Références SingleMetadata\$data, et SingleMetadata\$isBare64Encoded.

Documentation des fonctions membres

◆ getMetadataStatement()

getMetadataStatement ( )

Références SingleMetadata\$data, SingleMetadata\$statement, MetadataStatement\createFromArray(), Assertion\eq(), null, et Assertion\string().

Documentation des champs

◆ $data

$data
private

Référencé par SingleMetadata\__construct(), et SingleMetadata\getMetadataStatement().

◆ $isBare64Encoded

$isBare64Encoded
private

Référencé par SingleMetadata\__construct().

◆ $statement

$statement
private

Référencé par SingleMetadata\getMetadataStatement().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SingleMetadata.php


Joomla CMS: Référence de la classe StatusReport

  • Webauthn
  • MetadataService
  • StatusReport
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe StatusReport

Fonctions membres publiques

getStatus ()
getEffectiveDate ()
getCertificate ()
getUrl ()
getCertificationDescriptor ()
getCertificateNumber ()
getCertificationPolicyVersion ()
getCertificationRequirementsVersion ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$status
$effectiveDate
$certificate
$url
$certificationDescriptor
$certificateNumber
$certificationPolicyVersion
$certificationRequirementsVersion

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par MetadataTOCPayloadEntry\createFromArray().

◆ getCertificate()

getCertificate ( )

Références StatusReport\$certificate.

◆ getCertificateNumber()

getCertificateNumber ( )

Références StatusReport\$certificateNumber.

◆ getCertificationDescriptor()

getCertificationDescriptor ( )

Références StatusReport\$certificationDescriptor.

◆ getCertificationPolicyVersion()

getCertificationPolicyVersion ( )

Références StatusReport\$certificationPolicyVersion.

◆ getCertificationRequirementsVersion()

getCertificationRequirementsVersion ( )

Références StatusReport\$certificationRequirementsVersion.

◆ getEffectiveDate()

getEffectiveDate ( )

Références StatusReport\$effectiveDate.

◆ getStatus()

getStatus ( )

Références StatusReport\$status.

◆ getUrl()

getUrl ( )

Références StatusReport\$url.

Documentation des champs

◆ $certificate

$certificate
private

Référencé par StatusReport\getCertificate().

◆ $certificateNumber

$certificateNumber
private

Référencé par StatusReport\getCertificateNumber().

◆ $certificationDescriptor

$certificationDescriptor
private

Référencé par StatusReport\getCertificationDescriptor().

◆ $certificationPolicyVersion

$certificationPolicyVersion
private

Référencé par StatusReport\getCertificationPolicyVersion().

◆ $certificationRequirementsVersion

$certificationRequirementsVersion
private

Référencé par StatusReport\getCertificationRequirementsVersion().

◆ $effectiveDate

$effectiveDate
private

Référencé par StatusReport\getEffectiveDate().

◆ $status

$status
private

Référencé par StatusReport\getStatus().

◆ $url

$url
private

Référencé par StatusReport\getUrl().

La documentation de cette classe a été générée à partir du fichier suivant :
  • StatusReport.php


Joomla CMS: Référence de la classe VerificationMethodANDCombinations

  • Webauthn
  • MetadataService
  • VerificationMethodANDCombinations
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe VerificationMethodANDCombinations

Fonctions membres publiques

getVerificationMethods ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$verificationMethods = []

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, VerificationMethodDescriptor\createFromArray(), et Assertion\isArray().

Référencé par MetadataStatement\createFromArray().

◆ getVerificationMethods()

getVerificationMethods ( )
Renvoie
VerificationMethodDescriptor[]

Références VerificationMethodANDCombinations\$verificationMethods.

Documentation des champs

◆ $verificationMethods

$verificationMethods = []
private

Référencé par VerificationMethodANDCombinations\getVerificationMethods().

La documentation de cette classe a été générée à partir du fichier suivant :
  • VerificationMethodANDCombinations.php


Joomla CMS: Référence de la classe VerificationMethodDescriptor

  • Webauthn
  • MetadataService
  • VerificationMethodDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe VerificationMethodDescriptor

Fonctions membres publiques

getUserVerification ()
getCaDesc ()
getBaDesc ()
getPaDesc ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Champs de données

const | USER_VERIFY_PRESENCE = 0x00000001
const | USER_VERIFY_FINGERPRINT = 0x00000002
const | USER_VERIFY_PASSCODE = 0x00000004
const | USER_VERIFY_VOICEPRINT = 0x00000008
const | USER_VERIFY_FACEPRINT = 0x00000010
const | USER_VERIFY_LOCATION = 0x00000020
const | USER_VERIFY_EYEPRINT = 0x00000040
const | USER_VERIFY_PATTERN = 0x00000080
const | USER_VERIFY_HANDPRINT = 0x00000100
const | USER_VERIFY_NONE = 0x00000200
const | USER_VERIFY_ALL = 0x00000400

Attributs privés

$userVerification
$caDesc
$baDesc
$paDesc

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, PatternAccuracyDescriptor\createFromArray(), CodeAccuracyDescriptor\createFromArray(), BiometricAccuracyDescriptor\createFromArray(), et null.

Référencé par VerificationMethodANDCombinations\createFromArray().

◆ getBaDesc()

getBaDesc ( )

Références VerificationMethodDescriptor\$baDesc.

◆ getCaDesc()

getCaDesc ( )

Références VerificationMethodDescriptor\$caDesc.

◆ getPaDesc()

getPaDesc ( )

Références VerificationMethodDescriptor\$paDesc.

◆ getUserVerification()

getUserVerification ( )

Références VerificationMethodDescriptor\$userVerification.

Documentation des champs

◆ $baDesc

$baDesc
private

Référencé par VerificationMethodDescriptor\getBaDesc().

◆ $caDesc

$caDesc
private

Référencé par VerificationMethodDescriptor\getCaDesc().

◆ $paDesc

$paDesc
private

Référencé par VerificationMethodDescriptor\getPaDesc().

◆ $userVerification

$userVerification
private

Référencé par VerificationMethodDescriptor\getUserVerification().

◆ USER_VERIFY_ALL

const USER_VERIFY_ALL = 0x00000400

◆ USER_VERIFY_EYEPRINT

const USER_VERIFY_EYEPRINT = 0x00000040

◆ USER_VERIFY_FACEPRINT

const USER_VERIFY_FACEPRINT = 0x00000010

◆ USER_VERIFY_FINGERPRINT

const USER_VERIFY_FINGERPRINT = 0x00000002

◆ USER_VERIFY_HANDPRINT

const USER_VERIFY_HANDPRINT = 0x00000100

◆ USER_VERIFY_LOCATION

const USER_VERIFY_LOCATION = 0x00000020

◆ USER_VERIFY_NONE

const USER_VERIFY_NONE = 0x00000200

◆ USER_VERIFY_PASSCODE

const USER_VERIFY_PASSCODE = 0x00000004

◆ USER_VERIFY_PATTERN

const USER_VERIFY_PATTERN = 0x00000080

◆ USER_VERIFY_PRESENCE

const USER_VERIFY_PRESENCE = 0x00000001

◆ USER_VERIFY_VOICEPRINT

const USER_VERIFY_VOICEPRINT = 0x00000008
La documentation de cette classe a été générée à partir du fichier suivant :
  • VerificationMethodDescriptor.php


Joomla CMS: Référence de la classe Version

  • Webauthn
  • MetadataService
  • Version
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe Version

Fonctions membres publiques

getMajor ()
getMinor ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$major
$minor

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, et null.

Référencé par MetadataStatement\createFromArray().

◆ getMajor()

getMajor ( )

Références Version\$major.

◆ getMinor()

getMinor ( )

Références Version\$minor.

Documentation des champs

◆ $major

$major
private

Référencé par Version\getMajor().

◆ $minor

$minor
private

Référencé par Version\getMinor().

La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/web-auth/metadata-service/src/Version.php


Joomla CMS: Référence de la classe IgnoreTokenBindingHandler

  • Webauthn
  • TokenBinding
  • IgnoreTokenBindingHandler
Fonctions membres publiques
Référence de la classe IgnoreTokenBindingHandler
+ Graphe d'héritage de IgnoreTokenBindingHandler:
TokenBindingHandler

Fonctions membres publiques

check (TokenBinding $tokenBinding, ServerRequestInterface $request)

Documentation des fonctions membres

◆ check()

check | ( | TokenBinding | $tokenBinding,
 |  | ServerRequestInterface | $request
 | ) |  |

Implémente TokenBindingHandler.

La documentation de cette classe a été générée à partir du fichier suivant :
  • IgnoreTokenBindingHandler.php


Joomla CMS: Référence de la classe TokenBinding

  • Webauthn
  • TokenBinding
  • TokenBinding
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques | Attributs privés
Référence de la classe TokenBinding

Fonctions membres publiques

__construct (string $status, ?string $id)
getStatus ()
getId ()

Fonctions membres publiques statiques

static createFormArray (array $json)

Champs de données

const | TOKEN_BINDING_STATUS_PRESENT = 'present'
const | TOKEN_BINDING_STATUS_SUPPORTED = 'supported'
const | TOKEN_BINDING_STATUS_NOT_SUPPORTED = 'not-supported'

Fonctions membres privées statiques

static getSupportedStatus ()

Attributs privés

$status
$id

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $status,
 |  | ?string | $id
 | ) |  |

Références TokenBinding\$id, TokenBinding\$status, Assertion\false(), et null.

Documentation des fonctions membres

◆ createFormArray()

static createFormArray ( array $json )
static

Références TokenBinding\$id, TokenBinding\$status, Base64Url\decode(), Assertion\inArray(), Assertion\keyExists(), et null.

◆ getId()

getId ( )

Références TokenBinding\$id.

◆ getStatus()

getStatus ( )

Références TokenBinding\$status.

Référencé par TokenBindingNotSupportedHandler\check().

◆ getSupportedStatus()

static getSupportedStatus ( )
staticprivate
Renvoie
string[]

Documentation des champs

◆ $id

$id
private

Référencé par TokenBinding\__construct(), TokenBinding\createFormArray(), et TokenBinding\getId().

◆ $status

$status
private

Référencé par TokenBinding\__construct(), TokenBinding\createFormArray(), et TokenBinding\getStatus().

◆ TOKEN_BINDING_STATUS_NOT_SUPPORTED

const TOKEN_BINDING_STATUS_NOT_SUPPORTED = 'not-supported'

◆ TOKEN_BINDING_STATUS_PRESENT

const TOKEN_BINDING_STATUS_PRESENT = 'present'

Référencé par TokenBindingNotSupportedHandler\check().

◆ TOKEN_BINDING_STATUS_SUPPORTED

const TOKEN_BINDING_STATUS_SUPPORTED = 'supported'
La documentation de cette classe a été générée à partir du fichier suivant :
  • TokenBinding.php


Joomla CMS: Référence de l'interface TokenBindingHandler

  • Webauthn
  • TokenBinding
  • TokenBindingHandler
Fonctions membres publiques
Référence de l'interface TokenBindingHandler
+ Graphe d'héritage de TokenBindingHandler:
IgnoreTokenBindingHandler TokenBindingNotSupportedHandler

Fonctions membres publiques

check (TokenBinding $tokenBinding, ServerRequestInterface $request)

Documentation des fonctions membres

◆ check()

check | ( | TokenBinding | $tokenBinding,
 |  | ServerRequestInterface | $request
 | ) |  |

Implémenté dans TokenBindingNotSupportedHandler, et IgnoreTokenBindingHandler.

La documentation de cette interface a été générée à partir du fichier suivant :
  • TokenBindingHandler.php


Joomla CMS: Référence de la classe TokenBindingNotSupportedHandler

  • Webauthn
  • TokenBinding
  • TokenBindingNotSupportedHandler
Fonctions membres publiques
Référence de la classe TokenBindingNotSupportedHandler
+ Graphe d'héritage de TokenBindingNotSupportedHandler:
TokenBindingHandler

Fonctions membres publiques

check (TokenBinding $tokenBinding, ServerRequestInterface $request)

Documentation des fonctions membres

◆ check()

check | ( | TokenBinding | $tokenBinding,
 |  | ServerRequestInterface | $request
 | ) |  |

Implémente TokenBindingHandler.

Références TokenBinding\getStatus(), TokenBinding\TOKEN_BINDING_STATUS_PRESENT, et Assertion\true().

La documentation de cette classe a été générée à partir du fichier suivant :
  • TokenBindingNotSupportedHandler.php


Joomla CMS: Référence de la classe CertificateTrustPath

  • Webauthn
  • TrustPath
  • CertificateTrustPath
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe CertificateTrustPath
+ Graphe d'héritage de CertificateTrustPath:
TrustPath

Fonctions membres publiques

__construct (array $certificates)
getCertificates ()
jsonSerialize ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$certificates

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( array $certificates )
Paramètres
string[] $certificates

Références CertificateTrustPath\$certificates.

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Implémente TrustPath.

Références $data, et Assertion\keyExists().

◆ getCertificates()

getCertificates ( )
Renvoie
string[]

Références CertificateTrustPath\$certificates.

◆ jsonSerialize()

jsonSerialize ( )

Références CertificateTrustPath\$certificates, et class.

Documentation des champs

◆ $certificates

$certificates
private

Référencé par CertificateTrustPath\__construct(), CertificateTrustPath\getCertificates(), et CertificateTrustPath\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateTrustPath.php


Joomla CMS: Référence de la classe EcdaaKeyIdTrustPath

  • Webauthn
  • TrustPath
  • EcdaaKeyIdTrustPath
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe EcdaaKeyIdTrustPath
+ Graphe d'héritage de EcdaaKeyIdTrustPath:
TrustPath

Fonctions membres publiques

__construct (string $ecdaaKeyId)
getEcdaaKeyId ()
jsonSerialize ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Attributs privés

$ecdaaKeyId

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $ecdaaKeyId )

Références EcdaaKeyIdTrustPath\$ecdaaKeyId.

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Implémente TrustPath.

Références $data, et Assertion\keyExists().

◆ getEcdaaKeyId()

getEcdaaKeyId ( )

Références EcdaaKeyIdTrustPath\$ecdaaKeyId.

◆ jsonSerialize()

jsonSerialize ( )

Références EcdaaKeyIdTrustPath\$ecdaaKeyId, et class.

Documentation des champs

◆ $ecdaaKeyId

$ecdaaKeyId
private

Référencé par EcdaaKeyIdTrustPath\__construct(), EcdaaKeyIdTrustPath\getEcdaaKeyId(), et EcdaaKeyIdTrustPath\jsonSerialize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • EcdaaKeyIdTrustPath.php


Joomla CMS: Référence de la classe EmptyTrustPath

  • Webauthn
  • TrustPath
  • EmptyTrustPath
Fonctions membres publiques | Fonctions membres publiques statiques
Référence de la classe EmptyTrustPath
+ Graphe d'héritage de EmptyTrustPath:
TrustPath

Fonctions membres publiques

jsonSerialize ()

Fonctions membres publiques statiques

static createFromArray (array $data)

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Implémente TrustPath.

◆ jsonSerialize()

jsonSerialize ( )

Références class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • EmptyTrustPath.php


Joomla CMS: Référence de l'interface TrustPath

  • Webauthn
  • TrustPath
  • TrustPath
Fonctions membres publiques statiques
Référence de l'interface TrustPath
+ Graphe d'héritage de TrustPath:
CertificateTrustPath EcdaaKeyIdTrustPath EmptyTrustPath

Fonctions membres publiques statiques

static createFromArray (array $data)

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Implémenté dans EcdaaKeyIdTrustPath, CertificateTrustPath, et EmptyTrustPath.

Référencé par TrustPathLoader\loadTrustPath().

La documentation de cette interface a été générée à partir du fichier suivant :
  • TrustPath.php


Joomla CMS: Référence de la classe TrustPathLoader

  • Webauthn
  • TrustPath
  • TrustPathLoader
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe TrustPathLoader

Fonctions membres publiques statiques

static loadTrustPath (array $data)

Fonctions membres privées statiques

static oldTrustPathTypes ()

Documentation des fonctions membres

◆ loadTrustPath()

static loadTrustPath ( array $data )
static

Références $data, $type, class, TrustPath\createFromArray(), et Assertion\keyExists().

Référencé par AttestationStatement\createFromArray().

◆ oldTrustPathTypes()

static oldTrustPathTypes ( )
staticprivate

Références class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • TrustPathLoader.php


Joomla CMS: Référence de la classe CoseSignatureFixer

  • Webauthn
  • Util
  • CoseSignatureFixer
Fonctions membres publiques statiques
Référence de la classe CoseSignatureFixer

Fonctions membres publiques statiques

static fix (string $signature, Signature $algorithm)

Description détaillée

This class fixes the signature of the ECDSA based algorithms.

Documentation des fonctions membres

◆ fix()

static fix | ( | string | $signature,
 |  | Signature | $algorithm
 | ) |  |
static

Référencé par PackedAttestationStatementSupport\processWithSelfAttestation().

La documentation de cette classe a été générée à partir du fichier suivant :
  • CoseSignatureFixer.php


Joomla CMS: Référence de la classe AttestedCredentialData

  • Webauthn
  • AttestedCredentialData
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe AttestedCredentialData
+ Graphe d'héritage de AttestedCredentialData:

Fonctions membres publiques

__construct (UuidInterface $aaguid, string $credentialId, ?string $credentialPublicKey)
getAaguid ()
getCredentialId ()
getCredentialPublicKey ()
jsonSerialize ()

Fonctions membres publiques statiques

static createFromArray (array $json)

Attributs privés

$aaguid
$credentialId
$credentialPublicKey

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#sec-attested-credential-data

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | UuidInterface | $aaguid,
 |  | string | $credentialId,
 |  | ?string | $credentialPublicKey
 | ) |  |

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références null.

◆ getAaguid()

getAaguid ( )

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource(), et AuthenticatorAttestationResponseValidator\createPublicKeyCredentialSource().

◆ getCredentialId()

getCredentialId ( )

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ getCredentialPublicKey()

getCredentialPublicKey ( )

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource(), et AuthenticatorAttestationResponseValidator\createPublicKeyCredentialSource().

◆ jsonSerialize()

jsonSerialize ( )

Références $result, et null.

Documentation des champs

◆ $aaguid

$aaguid
private

◆ $credentialId

$credentialId
private

◆ $credentialPublicKey

$credentialPublicKey
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AttestedCredentialData.php


Joomla CMS: Référence de la classe AuthenticatorAssertionResponse

  • Webauthn
  • AuthenticatorAssertionResponse
Fonctions membres publiques | Attributs privés
Référence de la classe AuthenticatorAssertionResponse
+ Graphe d'héritage de AuthenticatorAssertionResponse:
AuthenticatorResponse

Fonctions membres publiques

__construct (CollectedClientData $clientDataJSON, AuthenticatorData $authenticatorData, string $signature, ?string $userHandle)
getAuthenticatorData ()
getSignature ()
getUserHandle ()
- Fonctions membres publiques hérités de AuthenticatorResponse
__construct (CollectedClientData $clientDataJSON)
getClientDataJSON ()

Attributs privés

$authenticatorData
$signature
$userHandle

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#authenticatorassertionresponse

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CollectedClientData | $clientDataJSON,
 |  | AuthenticatorData | $authenticatorData,
 |  | string | $signature,
 |  | ?string | $userHandle
 | ) |  |

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAuthenticatorData()

getAuthenticatorData ( )

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getSignature()

getSignature ( )

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getUserHandle()

getUserHandle ( )

Références null.

Référencé par AuthenticatorAssertionResponseValidator\check().

Documentation des champs

◆ $authenticatorData

$authenticatorData
private

◆ $signature

$signature
private

◆ $userHandle

$userHandle
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorAssertionResponse.php


Joomla CMS: Référence de la classe AuthenticatorAssertionResponseValidator

  • Webauthn
  • AuthenticatorAssertionResponseValidator
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AuthenticatorAssertionResponseValidator

Fonctions membres publiques

__construct (PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?Decoder $decoder, TokenBindingHandler $tokenBindingHandler, ExtensionOutputCheckerHandler $extensionOutputCheckerHandler, Manager $algorithmManager)
check (string $credentialId, AuthenticatorAssertionResponse $authenticatorAssertionResponse, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ServerRequestInterface $request, ?string $userHandle)

Fonctions membres privées

isCredentialIdAllowed (string $credentialId, array $allowedCredentials)
getFacetId (string $rpId, AuthenticationExtensionsClientInputs $authenticationExtensionsClientInputs, ?AuthenticationExtensionsClientOutputs $authenticationExtensionsClientOutputs)

Attributs privés

$publicKeyCredentialSourceRepository
$decoder
$tokenBindingHandler
$extensionOutputCheckerHandler
$algorithmManager

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository,
 |  | ?Decoder | $decoder,
 |  | TokenBindingHandler | $tokenBindingHandler,
 |  | ExtensionOutputCheckerHandler | $extensionOutputCheckerHandler,
 |  | Manager | $algorithmManager
 | ) |  |

Références null.

Documentation des fonctions membres

◆ check()

check | ( | string | $credentialId,
 |  | AuthenticatorAssertionResponse | $authenticatorAssertionResponse,
 |  | PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions,
 |  | ServerRequestInterface | $request,
 |  | ?string | $userHandle
 | ) |  |
Voir également
https://www.w3.org/TR/webauthn/#verifying-assertion
Voir également
7.2.4

7.2.5

7.2.6

7.2.9

7.2.11
7.2.15

Références Laminas\Diactoros\$stream, class, Key\get(), PublicKeyCredentialRequestOptions\getAllowCredentials(), AuthenticatorAssertionResponse\getAuthenticatorData(), PublicKeyCredentialOptions\getChallenge(), AuthenticatorResponse\getClientDataJSON(), PublicKeyCredentialOptions\getExtensions(), PublicKeyCredentialRequestOptions\getRpId(), AuthenticatorAssertionResponse\getSignature(), RequestInterface\getUri(), AuthenticatorAssertionResponse\getUserHandle(), PublicKeyCredentialRequestOptions\getUserVerification(), null, et true.

Référencé par Server\loadAndCheckAssertionResponse().

◆ getFacetId()

getFacetId | ( | string | $rpId,
 |  | AuthenticationExtensionsClientInputs | $authenticationExtensionsClientInputs,
 |  | ?AuthenticationExtensionsClientOutputs | $authenticationExtensionsClientOutputs
 | ) |  |
private

Références AuthenticationExtensionsClientInputs\get(), AuthenticationExtensionsClientOutputs\get(), AuthenticationExtensionsClientInputs\has(), AuthenticationExtensionsClientOutputs\has(), et null.

◆ isCredentialIdAllowed()

isCredentialIdAllowed | ( | string | $credentialId,
 |  | array | $allowedCredentials
 | ) |  |
private

Documentation des champs

◆ $algorithmManager

$algorithmManager
private

◆ $decoder

$decoder
private

◆ $extensionOutputCheckerHandler

$extensionOutputCheckerHandler
private

◆ $publicKeyCredentialSourceRepository

$publicKeyCredentialSourceRepository
private

◆ $tokenBindingHandler

$tokenBindingHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorAssertionResponseValidator.php


Joomla CMS: Référence de la classe AuthenticatorAttestationResponse

  • Webauthn
  • AuthenticatorAttestationResponse
Fonctions membres publiques | Attributs privés
Référence de la classe AuthenticatorAttestationResponse
+ Graphe d'héritage de AuthenticatorAttestationResponse:
AuthenticatorResponse

Fonctions membres publiques

__construct (CollectedClientData $clientDataJSON, AttestationObject $attestationObject)
getAttestationObject ()
- Fonctions membres publiques hérités de AuthenticatorResponse
__construct (CollectedClientData $clientDataJSON)
getClientDataJSON ()

Attributs privés

$attestationObject

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#authenticatorattestationresponse

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | CollectedClientData | $clientDataJSON,
 |  | AttestationObject | $attestationObject
 | ) |  |

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ getAttestationObject()

getAttestationObject ( )

Référencé par AuthenticatorAttestationResponseValidator\check().

Documentation des champs

◆ $attestationObject

$attestationObject
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorAttestationResponse.php


Joomla CMS: Référence de la classe AuthenticatorAttestationResponseValidator

  • Webauthn
  • AuthenticatorAttestationResponseValidator
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe AuthenticatorAttestationResponseValidator

Fonctions membres publiques

__construct (AttestationStatementSupportManager $attestationStatementSupportManager, PublicKeyCredentialSourceRepository $publicKeyCredentialSource, TokenBindingHandler $tokenBindingHandler, ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
check (AuthenticatorAttestationResponse $authenticatorAttestationResponse, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $request)

Fonctions membres privées

createPublicKeyCredentialSource (string $credentialId, AttestedCredentialData $attestedCredentialData, AttestationObject $attestationObject, string $userHandle)

Attributs privés

$attestationStatementSupportManager
$publicKeyCredentialSource
$tokenBindingHandler
$extensionOutputCheckerHandler

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AttestationStatementSupportManager | $attestationStatementSupportManager,
 |  | PublicKeyCredentialSourceRepository | $publicKeyCredentialSource,
 |  | TokenBindingHandler | $tokenBindingHandler,
 |  | ExtensionOutputCheckerHandler | $extensionOutputCheckerHandler
 | ) |  |

Documentation des fonctions membres

◆ check()

check | ( | AuthenticatorAttestationResponse | $authenticatorAttestationResponse,
 |  | PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions,
 |  | ServerRequestInterface | $request
 | ) |  |
Voir également
https://www.w3.org/TR/webauthn/#registering-a-new-credential
Voir également
7.1.1

7.1.2

7.1.5

7.1.7

7.1.8

7.1.9

7.1.13
7.1.14

Références AuthenticatorAttestationResponse\getAttestationObject(), PublicKeyCredentialCreationOptions\getAuthenticatorSelection(), PublicKeyCredentialOptions\getChallenge(), AuthenticatorResponse\getClientDataJSON(), PublicKeyCredentialCreationOptions\getRp(), RequestInterface\getUri(), PublicKeyCredentialCreationOptions\getUser(), null, et true.

◆ createPublicKeyCredentialSource()

createPublicKeyCredentialSource | ( | string | $credentialId,
 |  | AttestedCredentialData | $attestedCredentialData,
 |  | AttestationObject | $attestationObject,
 |  | string | $userHandle
 | ) |  |
private

Références AttestedCredentialData\getAaguid(), AttestationObject\getAttStmt(), AttestationObject\getAuthData(), et AttestedCredentialData\getCredentialPublicKey().

Documentation des champs

◆ $attestationStatementSupportManager

$attestationStatementSupportManager
private

◆ $extensionOutputCheckerHandler

$extensionOutputCheckerHandler
private

◆ $publicKeyCredentialSource

$publicKeyCredentialSource
private

◆ $tokenBindingHandler

$tokenBindingHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorAttestationResponseValidator.php


Joomla CMS: Référence de la classe AuthenticatorData

  • Webauthn
  • AuthenticatorData
Fonctions membres publiques | Attributs protégés | Attributs privés
Référence de la classe AuthenticatorData

Fonctions membres publiques

__construct (string $authData, string $rpIdHash, string $flags, int $signCount, ?AttestedCredentialData $attestedCredentialData, ?AuthenticationExtensionsClientOutputs $extensions)
getAuthData ()
getRpIdHash ()
isUserPresent ()
isUserVerified ()
hasAttestedCredentialData ()
hasExtensions ()
getReservedForFutureUse1 ()
getReservedForFutureUse2 ()
getSignCount ()
getAttestedCredentialData ()
getExtensions ()

Attributs protégés

$authData
$rpIdHash
$flags
$signCount
$attestedCredentialData
$extensions

Attributs privés

const | FLAG_UP = 0b00000001
const | FLAG_RFU1 = 0b00000010
const | FLAG_UV = 0b00000100
const | FLAG_RFU2 = 0b00111000
const | FLAG_AT = 0b01000000
const | FLAG_ED = 0b10000000

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#sec-authenticator-data

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $authData,
 |  | string | $rpIdHash,
 |  | string | $flags,
 |  | int | $signCount,
 |  | ?AttestedCredentialData | $attestedCredentialData,
 |  | ?AuthenticationExtensionsClientOutputs | $extensions
 | ) |  |

Documentation des fonctions membres

◆ getAttestedCredentialData()

getAttestedCredentialData ( )

Référencé par PackedAttestationStatementSupport\checkCertificate(), TPMAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\processWithCertificate(), TPMAttestationStatementSupport\processWithCertificate(), et PackedAttestationStatementSupport\processWithSelfAttestation().

◆ getAuthData()

getAuthData ( )

Référencé par AndroidKeyAttestationStatementSupport\isValid(), TPMAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\processWithCertificate(), PackedAttestationStatementSupport\processWithSelfAttestation(), et AndroidSafetyNetAttestationStatementSupport\validatePayload().

◆ getExtensions()

getExtensions ( )

Références null.

◆ getReservedForFutureUse1()

getReservedForFutureUse1 ( )

◆ getReservedForFutureUse2()

getReservedForFutureUse2 ( )

◆ getRpIdHash()

getRpIdHash ( )

Référencé par FidoU2FAttestationStatementSupport\isValid().

◆ getSignCount()

getSignCount ( )

◆ hasAttestedCredentialData()

hasAttestedCredentialData ( )

◆ hasExtensions()

hasExtensions ( )

◆ isUserPresent()

isUserPresent ( )

◆ isUserVerified()

isUserVerified ( )

Documentation des champs

◆ $attestedCredentialData

$attestedCredentialData
protected

◆ $authData

$authData
protected

◆ $extensions

$extensions
protected

◆ $flags

$flags
protected

◆ $rpIdHash

$rpIdHash
protected

◆ $signCount

$signCount
protected

◆ FLAG_AT

const FLAG_AT = 0b01000000
private

◆ FLAG_ED

const FLAG_ED = 0b10000000
private

◆ FLAG_RFU1

const FLAG_RFU1 = 0b00000010
private

◆ FLAG_RFU2

const FLAG_RFU2 = 0b00111000
private

◆ FLAG_UP

const FLAG_UP = 0b00000001
private

◆ FLAG_UV

const FLAG_UV = 0b00000100
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorData.php


Joomla CMS: Référence de la classe AuthenticatorResponse

  • Webauthn
  • AuthenticatorResponse
Fonctions membres publiques | Attributs privés
Référence de la classe AuthenticatorResponse
+ Graphe d'héritage de AuthenticatorResponse:
AuthenticatorAssertionResponse AuthenticatorAttestationResponse

Fonctions membres publiques

__construct (CollectedClientData $clientDataJSON)
getClientDataJSON ()

Attributs privés

$clientDataJSON

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#authenticatorresponse

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( CollectedClientData $clientDataJSON )

Documentation des fonctions membres

◆ getClientDataJSON()

getClientDataJSON ( )

Référencé par AuthenticatorAttestationResponseValidator\check(), et AuthenticatorAssertionResponseValidator\check().

Documentation des champs

◆ $clientDataJSON

$clientDataJSON
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorResponse.php


Joomla CMS: Référence de la classe AuthenticatorSelectionCriteria

  • Webauthn
  • AuthenticatorSelectionCriteria
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe AuthenticatorSelectionCriteria
+ Graphe d'héritage de AuthenticatorSelectionCriteria:

Fonctions membres publiques

__construct (?string $authenticatorAttachment=null, bool $requireResidentKey=false, string $userVerification=self::USER_VERIFICATION_REQUIREMENT_PREFERRED)
getAuthenticatorAttachment ()
isRequireResidentKey ()
getUserVerification ()
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Champs de données

const | AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE = null
const | AUTHENTICATOR_ATTACHMENT_PLATFORM = 'platform'
const | AUTHENTICATOR_ATTACHMENT_CROSS_PLATFORM = 'cross-platform'
const | USER_VERIFICATION_REQUIREMENT_REQUIRED = 'required'
const | USER_VERIFICATION_REQUIREMENT_PREFERRED = 'preferred'
const | USER_VERIFICATION_REQUIREMENT_DISCOURAGED = 'discouraged'

Attributs privés

$authenticatorAttachment
$requireResidentKey
$userVerification

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ?string | $authenticatorAttachment = null,
 |  | bool | $requireResidentKey = false,
 |  | string | $userVerification = self::USER_VERIFICATION_REQUIREMENT_PREFERRED
 | ) |  |

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références null.

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getAuthenticatorAttachment()

getAuthenticatorAttachment ( )

◆ getUserVerification()

getUserVerification ( )

◆ isRequireResidentKey()

isRequireResidentKey ( )

◆ jsonSerialize()

jsonSerialize ( )

Références null.

Documentation des champs

◆ $authenticatorAttachment

$authenticatorAttachment
private

◆ $requireResidentKey

$requireResidentKey
private

◆ $userVerification

$userVerification
private

◆ AUTHENTICATOR_ATTACHMENT_CROSS_PLATFORM

const AUTHENTICATOR_ATTACHMENT_CROSS_PLATFORM = 'cross-platform'

◆ AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE

const AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE = null

Référencé par Authentication\getPubKeyCreationOptions(), et Credentials\requestAttestation().

◆ AUTHENTICATOR_ATTACHMENT_PLATFORM

const AUTHENTICATOR_ATTACHMENT_PLATFORM = 'platform'

◆ USER_VERIFICATION_REQUIREMENT_DISCOURAGED

const USER_VERIFICATION_REQUIREMENT_DISCOURAGED = 'discouraged'

◆ USER_VERIFICATION_REQUIREMENT_PREFERRED

const USER_VERIFICATION_REQUIREMENT_PREFERRED = 'preferred'

Référencé par Authentication\getPubKeyCreationOptions(), et Credentials\requestAttestation().

◆ USER_VERIFICATION_REQUIREMENT_REQUIRED

const USER_VERIFICATION_REQUIREMENT_REQUIRED = 'required'
La documentation de cette classe a été générée à partir du fichier suivant :
  • AuthenticatorSelectionCriteria.php


Joomla CMS: Référence de la classe CertificateToolbox

  • Webauthn
  • CertificateToolbox
Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe CertificateToolbox

Fonctions membres publiques statiques

static | checkChain (array $certificates, array $trustedCertificates=[])
static | checkAttestationMedata (AttestationStatement $attestationStatement, string $aaguid, array $certificates, MetadataStatementRepository $metadataStatementRepository)
static | fixPEMStructure (string $certificate)
static | convertDERToPEM (string $certificate)
static | convertAllDERToPEM (array $certificates)

Fonctions membres privées statiques

static | getAttestationType (AttestationStatement $attestationStatement)
static | unusedBytesFix (string $certificate)
static | checkCertificatesValidity (array $certificates)
static | getCertificateHashes ()

Documentation des fonctions membres

◆ checkAttestationMedata()

static checkAttestationMedata | ( | AttestationStatement | $attestationStatement,
 |  | string | $aaguid,
 |  | array | $certificates,
 |  | MetadataStatementRepository | $metadataStatementRepository
 | ) |  |
static

Références $key, $type, MetadataStatementRepository\findOneByAAGUID(), et null.

Référencé par FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), PackedAttestationStatementSupport\processWithCertificate(), et TPMAttestationStatementSupport\processWithCertificate().

◆ checkCertificatesValidity()

static checkCertificatesValidity ( array $certificates )
staticprivate
Paramètres
string[] $certificates

◆ checkChain()

static checkChain | ( | array | $certificates,
 |  | array | $trustedCertificates = []
 | ) |  |
static

Références $result, et true.

◆ convertAllDERToPEM()

static convertAllDERToPEM ( array $certificates )
static

Référencé par TPMAttestationStatementSupport\load(), FidoU2FAttestationStatementSupport\load(), AndroidKeyAttestationStatementSupport\load(), et PackedAttestationStatementSupport\loadBasicType().

◆ convertDERToPEM()

static convertDERToPEM ( string $certificate )
static

◆ fixPEMStructure()

static fixPEMStructure ( string $certificate )
static

Référencé par AndroidSafetyNetAttestationStatementSupport\convertCertificatesToPem().

◆ getAttestationType()

static getAttestationType ( AttestationStatement $attestationStatement )
staticprivate

Références AttestationStatement\getType().

◆ getCertificateHashes()

static getCertificateHashes ( )
staticprivate
Renvoie
string[]

◆ unusedBytesFix()

static unusedBytesFix ( string $certificate )
staticprivate
La documentation de cette classe a été générée à partir du fichier suivant :
  • CertificateToolbox.php


Joomla CMS: Référence de la classe CollectedClientData

  • Webauthn
  • CollectedClientData
Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres privées | Attributs privés
Référence de la classe CollectedClientData

Fonctions membres publiques

__construct (string $rawData, array $data)
getType ()
getChallenge ()
getOrigin ()
getTokenBinding ()
getRawData ()
all ()
has (string $key)
get (string $key)

Fonctions membres publiques statiques

static createFormJson (string $data)

Fonctions membres privées

findData (array $json, string $key, bool $isRequired=true, bool $isB64=false)

Attributs privés

$rawData
$data
$type
$challenge
$origin
$tokenBinding

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $rawData,
 |  | array | $data
 | ) |  |

Références $data.

Documentation des fonctions membres

◆ all()

all ( )
Renvoie
string[]

◆ createFormJson()

static createFormJson ( string $data )
static

Références $data.

◆ findData()

findData | ( | array | $json,
 |  | string | $key,
 |  | bool | $isRequired = true,
 |  | bool | $isB64 = false
 | ) |  |
private
Renvoie
mixed|null

Références $key.

◆ get()

get ( string $key )
Renvoie
mixed

Références $key, et Symfony\Contracts\Service\has().

◆ getChallenge()

getChallenge ( )

◆ getOrigin()

getOrigin ( )

◆ getRawData()

getRawData ( )

◆ getTokenBinding()

getTokenBinding ( )

Références null.

◆ getType()

getType ( )

Références $type.

◆ has()

has ( string $key )

Références $key.

Documentation des champs

◆ $challenge

$challenge
private

◆ $data

$data
private

◆ $origin

$origin
private

◆ $rawData

$rawData
private

◆ $tokenBinding

$tokenBinding
private

◆ $type

$type
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • CollectedClientData.php


Joomla CMS: Référence de la classe Credential

  • Webauthn
  • Credential
Fonctions membres publiques | Attributs protégés
Référence de la classe Credential
+ Graphe d'héritage de Credential:
PublicKeyCredential

Fonctions membres publiques

__construct (string $id, string $type)
getId ()
getType ()

Attributs protégés

$id
$type

Description détaillée

Voir également
https://w3c.github.io/webappsec-credential-management/#credential

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $id,
 |  | string | $type
 | ) |  |

Références $id, et $type.

Documentation des fonctions membres

◆ getId()

getId ( )

Références $id.

◆ getType()

getType ( )

Références $type.

Documentation des champs

◆ $id

$id
protected

◆ $type

$type
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • Credential.php


Joomla CMS: Référence de la classe PublicKeyCredential

  • Webauthn
  • PublicKeyCredential
Fonctions membres publiques | Attributs protégés
Référence de la classe PublicKeyCredential
+ Graphe d'héritage de PublicKeyCredential:
Credential

Fonctions membres publiques

__construct (string $id, string $type, string $rawId, AuthenticatorResponse $response)
getRawId ()
getResponse ()
getPublicKeyCredentialDescriptor (array $transport=[])
__toString ()
- Fonctions membres publiques hérités de Credential
__construct (string $id, string $type)
getId ()
getType ()

Attributs protégés

$rawId
$response
- Attributs protégés hérités de Credential
$id
$type

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#iface-pkcredential

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $id,
 |  | string | $type,
 |  | string | $rawId,
 |  | AuthenticatorResponse | $response
 | ) |  |

Références $id, $type, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ __toString()

__toString ( )

Références $this.

◆ getPublicKeyCredentialDescriptor()

getPublicKeyCredentialDescriptor ( array $transport = [] )
Paramètres
string[] $transport

Référencé par PublicKeyCredentialSource\createFromPublicKeyCredential().

◆ getRawId()

getRawId ( )

◆ getResponse()

getResponse ( )

Référencé par PublicKeyCredentialSource\createFromPublicKeyCredential().

Documentation des champs

◆ $rawId

$rawId
protected

◆ $response

$response
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredential.php


Joomla CMS: Référence de la classe PublicKeyCredentialCreationOptions

  • Webauthn
  • PublicKeyCredentialCreationOptions
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe PublicKeyCredentialCreationOptions
+ Graphe d'héritage de PublicKeyCredentialCreationOptions:
PublicKeyCredentialOptions

Fonctions membres publiques

__construct (PublicKeyCredentialRpEntity $rp, PublicKeyCredentialUserEntity $user, string $challenge, array $pubKeyCredParams, ?int $timeout, array $excludeCredentials, AuthenticatorSelectionCriteria $authenticatorSelection, string $attestation, ?AuthenticationExtensionsClientInputs $extensions)
getRp ()
getUser ()
getPubKeyCredParams ()
getExcludeCredentials ()
getAuthenticatorSelection ()
getAttestation ()
jsonSerialize ()
- Fonctions membres publiques hérités de PublicKeyCredentialOptions
__construct (string $challenge, ?int $timeout=null, ?AuthenticationExtensionsClientInputs $extensions=null)
getChallenge ()
getTimeout ()
getExtensions ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)
- Fonctions membres publiques statiques hérités de PublicKeyCredentialOptions
static | createFromString (string $data)
static | createFromArray (array $json)

Champs de données

const | ATTESTATION_CONVEYANCE_PREFERENCE_NONE = 'none'
const | ATTESTATION_CONVEYANCE_PREFERENCE_INDIRECT = 'indirect'
const | ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT = 'direct'

Attributs privés

$rp
$user
$pubKeyCredParams
$excludeCredentials
$authenticatorSelection
$attestation

Membres hérités additionnels

- Attributs protégés hérités de PublicKeyCredentialOptions
$challenge
$timeout
$extensions

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PublicKeyCredentialRpEntity | $rp,
 |  | PublicKeyCredentialUserEntity | $user,
 |  | string | $challenge,
 |  | array | $pubKeyCredParams,
 |  | ?int | $timeout,
 |  | array | $excludeCredentials,
 |  | AuthenticatorSelectionCriteria | $authenticatorSelection,
 |  | string | $attestation,
 |  | ?AuthenticationExtensionsClientInputs | $extensions
 | ) |  |

PublicKeyCredentialCreationOptions constructor.

Paramètres
PublicKeyCredentialParameters[] | $pubKeyCredParams
PublicKeyCredentialDescriptor[] | $excludeCredentials

Références $user, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références null.

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getAttestation()

getAttestation ( )

◆ getAuthenticatorSelection()

getAuthenticatorSelection ( )

Référencé par AuthenticatorAttestationResponseValidator\check().

◆ getExcludeCredentials()

getExcludeCredentials ( )
Renvoie
PublicKeyCredentialDescriptor[]

◆ getPubKeyCredParams()

getPubKeyCredParams ( )
Renvoie
PublicKeyCredentialParameters[]

◆ getRp()

getRp ( )

Référencé par AuthenticatorAttestationResponseValidator\check().

◆ getUser()

getUser ( )

Références $user.

Référencé par AuthenticatorAttestationResponseValidator\check().

◆ jsonSerialize()

jsonSerialize ( )

Références $user, et null.

Documentation des champs

◆ $attestation

$attestation
private

◆ $authenticatorSelection

$authenticatorSelection
private

◆ $excludeCredentials

$excludeCredentials
private

◆ $pubKeyCredParams

$pubKeyCredParams
private

◆ $rp

$rp
private

◆ $user

$user
private

◆ ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT

const ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT = 'direct'

Référencé par Authentication\getPubKeyCreationOptions().

◆ ATTESTATION_CONVEYANCE_PREFERENCE_INDIRECT

const ATTESTATION_CONVEYANCE_PREFERENCE_INDIRECT = 'indirect'

◆ ATTESTATION_CONVEYANCE_PREFERENCE_NONE

const ATTESTATION_CONVEYANCE_PREFERENCE_NONE = 'none'

Référencé par Authentication\getPubKeyCreationOptions(), et Credentials\requestAttestation().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialCreationOptions.php


Joomla CMS: Référence de la classe PublicKeyCredentialDescriptor

  • Webauthn
  • PublicKeyCredentialDescriptor
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs protégés
Référence de la classe PublicKeyCredentialDescriptor
+ Graphe d'héritage de PublicKeyCredentialDescriptor:

Fonctions membres publiques

__construct (string $type, string $id, array $transports=[])
getType ()
getId ()
getTransports ()
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Champs de données

const | CREDENTIAL_TYPE_PUBLIC_KEY = 'public-key'
const | AUTHENTICATOR_TRANSPORT_USB = 'usb'
const | AUTHENTICATOR_TRANSPORT_NFC = 'nfc'
const | AUTHENTICATOR_TRANSPORT_BLE = 'ble'
const | AUTHENTICATOR_TRANSPORT_INTERNAL = 'internal'

Attributs protégés

$type
$id
$transports

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $type,
 |  | string | $id,
 |  | array | $transports = []
 | ) |  |
Paramètres
string[] $transports

Références $id, et $type.

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getId()

getId ( )

Références $id.

Référencé par PublicKeyCredentialDescriptorCollection\add().

◆ getTransports()

getTransports ( )
Renvoie
string[]

◆ getType()

getType ( )

Références $type.

◆ jsonSerialize()

jsonSerialize ( )

Références $type.

Documentation des champs

◆ $id

$id
protected

◆ $transports

$transports
protected

◆ $type

$type
protected

◆ AUTHENTICATOR_TRANSPORT_BLE

const AUTHENTICATOR_TRANSPORT_BLE = 'ble'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ AUTHENTICATOR_TRANSPORT_INTERNAL

const AUTHENTICATOR_TRANSPORT_INTERNAL = 'internal'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ AUTHENTICATOR_TRANSPORT_NFC

const AUTHENTICATOR_TRANSPORT_NFC = 'nfc'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ AUTHENTICATOR_TRANSPORT_USB

const AUTHENTICATOR_TRANSPORT_USB = 'usb'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource().

◆ CREDENTIAL_TYPE_PUBLIC_KEY

const CREDENTIAL_TYPE_PUBLIC_KEY = 'public-key'

Référencé par CredentialRepository\attestedCredentialToPublicKeyCredentialSource(), et Server\generatePublicKeyCredentialCreationOptions().

La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialDescriptor.php


Joomla CMS: Référence de la classe PublicKeyCredentialDescriptorCollection

  • Webauthn
  • PublicKeyCredentialDescriptorCollection
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe PublicKeyCredentialDescriptorCollection
+ Graphe d'héritage de PublicKeyCredentialDescriptorCollection:

Fonctions membres publiques

add (PublicKeyCredentialDescriptor $publicKeyCredentialDescriptor)
has (string $id)
remove (string $id)
getIterator ()
count (int $mode=COUNT_NORMAL)
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Attributs privés

$publicKeyCredentialDescriptors = []

Documentation des fonctions membres

◆ add()

add ( PublicKeyCredentialDescriptor $publicKeyCredentialDescriptor )

Références PublicKeyCredentialDescriptor\getId().

◆ count()

count ( int $mode = COUNT_NORMAL )

Références $mode.

◆ createFromArray()

static createFromArray ( array $json )
static

Références $item.

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getIterator()

getIterator ( )

◆ has()

has ( string $id )

Références $id.

◆ jsonSerialize()

jsonSerialize ( )

◆ remove()

remove ( string $id )

Références $id, et Symfony\Contracts\Service\has().

Documentation des champs

◆ $publicKeyCredentialDescriptors

$publicKeyCredentialDescriptors = []
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialDescriptorCollection.php


Joomla CMS: Référence de la classe PublicKeyCredentialEntity

  • Webauthn
  • PublicKeyCredentialEntity
Fonctions membres publiques | Attributs protégés
Référence de la classe PublicKeyCredentialEntity
+ Graphe d'héritage de PublicKeyCredentialEntity:
PublicKeyCredentialRpEntity PublicKeyCredentialUserEntity

Fonctions membres publiques

__construct (string $name, ?string $icon)
getName ()
getIcon ()
jsonSerialize ()

Attributs protégés

$name
$icon

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | ?string | $icon
 | ) |  |

Références $icon, $name, et name.

Documentation des fonctions membres

◆ getIcon()

getIcon ( )

Références $icon.

◆ getName()

getName ( )

Références $name.

◆ jsonSerialize()

jsonSerialize ( )

Références $icon, $name, et null.

Documentation des champs

◆ $icon

$icon
protected

◆ $name

$name
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialEntity.php


Joomla CMS: Référence de la classe PublicKeyCredentialLoader

  • Webauthn
  • PublicKeyCredentialLoader
Fonctions membres publiques | Fonctions membres privées | Attributs privés
Référence de la classe PublicKeyCredentialLoader

Fonctions membres publiques

__construct (AttestationObjectLoader $attestationObjectLoader, ?Decoder $decoder=null)
loadArray (array $json)
load (string $data)

Fonctions membres privées

createResponse (array $response)

Attributs privés

const | FLAG_AT = 0b01000000
const | FLAG_ED = 0b10000000
$attestationObjectLoader
$decoder

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | AttestationObjectLoader | $attestationObjectLoader,
 |  | ?Decoder | $decoder = null
 | ) |  |

Références null.

Documentation des fonctions membres

◆ createResponse()

createResponse ( array $response )
private

Références $extension, class, null, et true.

◆ load()

load ( string $data )

Références $data.

◆ loadArray()

loadArray ( array $json )

Références $id, $key, et true.

Documentation des champs

◆ $attestationObjectLoader

$attestationObjectLoader
private

◆ $decoder

$decoder
private

◆ FLAG_AT

const FLAG_AT = 0b01000000
private

◆ FLAG_ED

const FLAG_ED = 0b10000000
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialLoader.php


Joomla CMS: Référence de la classe PublicKeyCredentialOptions

  • Webauthn
  • PublicKeyCredentialOptions
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe PublicKeyCredentialOptions
+ Graphe d'héritage de PublicKeyCredentialOptions:
PublicKeyCredentialCreationOptions PublicKeyCredentialRequestOptions

Fonctions membres publiques

__construct (string $challenge, ?int $timeout=null, ?AuthenticationExtensionsClientInputs $extensions=null)
getChallenge ()
getTimeout ()
getExtensions ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Attributs protégés

$challenge
$timeout
$extensions

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $challenge,
 |  | ?int | $timeout = null,
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
staticabstract

◆ createFromString()

static createFromString ( string $data )
staticabstract

◆ getChallenge()

getChallenge ( )

Référencé par AuthenticatorAttestationResponseValidator\check(), et AuthenticatorAssertionResponseValidator\check().

◆ getExtensions()

getExtensions ( )

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getTimeout()

getTimeout ( )

Documentation des champs

◆ $challenge

$challenge
protected

◆ $extensions

$extensions
protected

◆ $timeout

$timeout
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialOptions.php


Joomla CMS: Référence de la classe PublicKeyCredentialParameters

  • Webauthn
  • PublicKeyCredentialParameters
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe PublicKeyCredentialParameters
+ Graphe d'héritage de PublicKeyCredentialParameters:

Fonctions membres publiques

__construct (string $type, int $alg)
getType ()
getAlg ()
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Attributs privés

$type
$alg

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $type,
 |  | int | $alg
 | ) |  |

Références $type.

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getAlg()

getAlg ( )

◆ getType()

getType ( )

Références $type.

◆ jsonSerialize()

jsonSerialize ( )

Références $type.

Documentation des champs

◆ $alg

$alg
private

◆ $type

$type
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialParameters.php


Joomla CMS: Référence de la classe PublicKeyCredentialRequestOptions

  • Webauthn
  • PublicKeyCredentialRequestOptions
Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Attributs privés
Référence de la classe PublicKeyCredentialRequestOptions
+ Graphe d'héritage de PublicKeyCredentialRequestOptions:
PublicKeyCredentialOptions

Fonctions membres publiques

__construct (string $challenge, ?int $timeout=null, ?string $rpId=null, array $allowCredentials=[], ?string $userVerification=null, ?AuthenticationExtensionsClientInputs $extensions=null)
getRpId ()
getAllowCredentials ()
getUserVerification ()
jsonSerialize ()
- Fonctions membres publiques hérités de PublicKeyCredentialOptions
__construct (string $challenge, ?int $timeout=null, ?AuthenticationExtensionsClientInputs $extensions=null)
getChallenge ()
getTimeout ()
getExtensions ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)
- Fonctions membres publiques statiques hérités de PublicKeyCredentialOptions
static | createFromString (string $data)
static | createFromArray (array $json)

Champs de données

const | USER_VERIFICATION_REQUIREMENT_REQUIRED = 'required'
const | USER_VERIFICATION_REQUIREMENT_PREFERRED = 'preferred'
const | USER_VERIFICATION_REQUIREMENT_DISCOURAGED = 'discouraged'

Attributs privés

$rpId
$allowCredentials
$userVerification

Membres hérités additionnels

- Attributs protégés hérités de PublicKeyCredentialOptions
$challenge
$timeout
$extensions

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $challenge,
 |  | ?int | $timeout = null,
 |  | ?string | $rpId = null,
 |  | array | $allowCredentials = [],
 |  | ?string | $userVerification = null,
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
PublicKeyCredentialDescriptor[] $allowCredentials

Références Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références null.

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getAllowCredentials()

getAllowCredentials ( )
Renvoie
PublicKeyCredentialDescriptor[]

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getRpId()

getRpId ( )

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ getUserVerification()

getUserVerification ( )

Référencé par AuthenticatorAssertionResponseValidator\check().

◆ jsonSerialize()

jsonSerialize ( )

Références null.

Documentation des champs

◆ $allowCredentials

$allowCredentials
private

◆ $rpId

$rpId
private

◆ $userVerification

$userVerification
private

◆ USER_VERIFICATION_REQUIREMENT_DISCOURAGED

const USER_VERIFICATION_REQUIREMENT_DISCOURAGED = 'discouraged'

◆ USER_VERIFICATION_REQUIREMENT_PREFERRED

const USER_VERIFICATION_REQUIREMENT_PREFERRED = 'preferred'

Référencé par Authentication\getPubkeyRequestOptions().

◆ USER_VERIFICATION_REQUIREMENT_REQUIRED

const USER_VERIFICATION_REQUIREMENT_REQUIRED = 'required'
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialRequestOptions.php


Joomla CMS: Référence de la classe PublicKeyCredentialRpEntity

  • Webauthn
  • PublicKeyCredentialRpEntity
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe PublicKeyCredentialRpEntity
+ Graphe d'héritage de PublicKeyCredentialRpEntity:
PublicKeyCredentialEntity

Fonctions membres publiques

__construct (string $name, ?string $id=null, ?string $icon=null)
getId ()
jsonSerialize ()
- Fonctions membres publiques hérités de PublicKeyCredentialEntity
__construct (string $name, ?string $icon)
getName ()
getIcon ()
jsonSerialize ()

Fonctions membres publiques statiques

static createFromArray (array $json)

Attributs protégés

$id
- Attributs protégés hérités de PublicKeyCredentialEntity
$name
$icon

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | ?string | $id = null,
 |  | ?string | $icon = null
 | ) |  |

Références $icon, $id, $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références null.

◆ getId()

getId ( )

Références $id.

◆ jsonSerialize()

jsonSerialize ( )

Références $id, et null.

Documentation des champs

◆ $id

$id
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialRpEntity.php


Joomla CMS: Référence de la classe PublicKeyCredentialSource

  • Webauthn
  • PublicKeyCredentialSource
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe PublicKeyCredentialSource
+ Graphe d'héritage de PublicKeyCredentialSource:

Fonctions membres publiques

__construct (string $publicKeyCredentialId, string $type, array $transports, string $attestationType, TrustPath $trustPath, UuidInterface $aaguid, string $credentialPublicKey, string $userHandle, int $counter)
getPublicKeyCredentialId ()
getPublicKeyCredentialDescriptor ()
getAttestationType ()
getTrustPath ()
getAttestedCredentialData ()
getType ()
getTransports ()
getAaguid ()
getCredentialPublicKey ()
getUserHandle ()
getCounter ()
setCounter (int $counter)
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromPublicKeyCredential (PublicKeyCredential $publicKeyCredential, string $userHandle)
static | createFromArray (array $data)

Attributs protégés

$publicKeyCredentialId
$type
$transports
$attestationType
$trustPath
$aaguid
$credentialPublicKey
$userHandle
$counter

Description détaillée

Voir également
https://www.w3.org/TR/webauthn/#iface-pkcredential

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $publicKeyCredentialId,
 |  | string | $type,
 |  | array | $transports,
 |  | string | $attestationType,
 |  | TrustPath | $trustPath,
 |  | UuidInterface | $aaguid,
 |  | string | $credentialPublicKey,
 |  | string | $userHandle,
 |  | int | $counter
 | ) |  |

Références $type, et counter.

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $data )
static

Références $data, $key, et class.

◆ createFromPublicKeyCredential()

static createFromPublicKeyCredential | ( | PublicKeyCredential | $publicKeyCredential,
 |  | string | $userHandle
 | ) |  |
static
Obsolète:
Deprecated since v2.1. Will be removed in v3.0. Please use response from the credential source returned by the AuthenticatorAttestationResponseValidator after "check" method

Références class, PublicKeyCredential\getPublicKeyCredentialDescriptor(), et PublicKeyCredential\getResponse().

◆ getAaguid()

getAaguid ( )

◆ getAttestationType()

getAttestationType ( )

◆ getAttestedCredentialData()

getAttestedCredentialData ( )

◆ getCounter()

getCounter ( )

◆ getCredentialPublicKey()

getCredentialPublicKey ( )

◆ getPublicKeyCredentialDescriptor()

getPublicKeyCredentialDescriptor ( )

◆ getPublicKeyCredentialId()

getPublicKeyCredentialId ( )

◆ getTransports()

getTransports ( )
Renvoie
string[]

◆ getTrustPath()

getTrustPath ( )

◆ getType()

getType ( )

Références $type.

◆ getUserHandle()

getUserHandle ( )

◆ jsonSerialize()

jsonSerialize ( )

Références $type.

◆ setCounter()

setCounter ( int $counter )

Références counter.

Documentation des champs

◆ $aaguid

$aaguid
protected

◆ $attestationType

$attestationType
protected

◆ $counter

$counter
protected

◆ $credentialPublicKey

$credentialPublicKey
protected

◆ $publicKeyCredentialId

$publicKeyCredentialId
protected

◆ $transports

$transports
protected

◆ $trustPath

$trustPath
protected

◆ $type

$type
protected

◆ $userHandle

$userHandle
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialSource.php


Joomla CMS: Référence de l'interface PublicKeyCredentialSourceRepository

  • Webauthn
  • PublicKeyCredentialSourceRepository
Fonctions membres publiques
Référence de l'interface PublicKeyCredentialSourceRepository
+ Graphe d'héritage de PublicKeyCredentialSourceRepository:
CredentialRepository CredentialRepository

Fonctions membres publiques

findOneByCredentialId (string $publicKeyCredentialId)
findAllForUserEntity (PublicKeyCredentialUserEntity $publicKeyCredentialUserEntity)
saveCredentialSource (PublicKeyCredentialSource $publicKeyCredentialSource)

Documentation des fonctions membres

◆ findAllForUserEntity()

findAllForUserEntity ( PublicKeyCredentialUserEntity $publicKeyCredentialUserEntity )
Renvoie
PublicKeyCredentialSource[]

◆ findOneByCredentialId()

findOneByCredentialId ( string $publicKeyCredentialId )

Implémenté dans CredentialRepository.

◆ saveCredentialSource()

saveCredentialSource ( PublicKeyCredentialSource $publicKeyCredentialSource )
La documentation de cette interface a été générée à partir du fichier suivant :
  • PublicKeyCredentialSourceRepository.php


Joomla CMS: Référence de la classe PublicKeyCredentialUserEntity

  • Webauthn
  • PublicKeyCredentialUserEntity
Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe PublicKeyCredentialUserEntity
+ Graphe d'héritage de PublicKeyCredentialUserEntity:
PublicKeyCredentialEntity

Fonctions membres publiques

__construct (string $name, string $id, string $displayName, ?string $icon=null)
getId ()
getDisplayName ()
jsonSerialize ()
- Fonctions membres publiques hérités de PublicKeyCredentialEntity
__construct (string $name, ?string $icon)
getName ()
getIcon ()
jsonSerialize ()

Fonctions membres publiques statiques

static | createFromString (string $data)
static | createFromArray (array $json)

Attributs protégés

$id
$displayName
- Attributs protégés hérités de PublicKeyCredentialEntity
$name
$icon

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | string | $name,
 |  | string | $id,
 |  | string | $displayName,
 |  | ?string | $icon = null
 | ) |  |

Références $icon, $id, $name, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ createFromArray()

static createFromArray ( array $json )
static

Références $id, et null.

◆ createFromString()

static createFromString ( string $data )
static

Références $data.

◆ getDisplayName()

getDisplayName ( )

◆ getId()

getId ( )

Références $id.

Référencé par Server\loadAndCheckAssertionResponse().

◆ jsonSerialize()

jsonSerialize ( )

Documentation des champs

◆ $displayName

$displayName
protected

◆ $id

$id
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • PublicKeyCredentialUserEntity.php


Joomla CMS: Référence de la classe Server

  • Webauthn
  • Server
Fonctions membres publiques | Champs de données | Fonctions membres privées | Attributs privés
Référence de la classe Server
+ Graphe d'héritage de Server:
Server Server

Fonctions membres publiques

__construct (PublicKeyCredentialRpEntity $relayingParty, PublicKeyCredentialSourceRepository $publicKeyCredentialSourceRepository, ?MetadataStatementRepository $metadataStatementRepository)
setSelectedAlgorithms (array $selectedAlgorithms)
setTokenBindingHandler (TokenBindingNotSupportedHandler $tokenBindingHandler)
addAlgorithm (string $alias, Algorithm $algorithm)
setExtensionOutputCheckerHandler (ExtensionOutputCheckerHandler $extensionOutputCheckerHandler)
generatePublicKeyCredentialCreationOptions (PublicKeyCredentialUserEntity $userEntity, ?string $attestationMode=PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE, array $excludedPublicKeyDescriptors=[], ?AuthenticatorSelectionCriteria $criteria=null, ?AuthenticationExtensionsClientInputs $extensions=null)
generatePublicKeyCredentialRequestOptions (?string $userVerification=PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED, array $allowedPublicKeyDescriptors=[], ?AuthenticationExtensionsClientInputs $extensions=null)
loadAndCheckAttestationResponse (string $data, PublicKeyCredentialCreationOptions $publicKeyCredentialCreationOptions, ServerRequestInterface $serverRequest)
loadAndCheckAssertionResponse (string $data, PublicKeyCredentialRequestOptions $publicKeyCredentialRequestOptions, ?PublicKeyCredentialUserEntity $userEntity, ServerRequestInterface $serverRequest)
enforceAndroidSafetyNetVerification (ClientInterface $client, string $apiKey, RequestFactoryInterface $requestFactory)

Champs de données

$timeout = 60000
$challengeSize = 32

Fonctions membres privées

getAttestationStatementSupportManager ()

Attributs privés

$rpEntity
$coseAlgorithmManagerFactory
$publicKeyCredentialSourceRepository
$tokenBindingHandler
$extensionOutputCheckerHandler
$selectedAlgorithms
$metadataStatementRepository
$httpClient
$googleApiKey
$requestFactory

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | PublicKeyCredentialRpEntity | $relayingParty,
 |  | PublicKeyCredentialSourceRepository | $publicKeyCredentialSourceRepository,
 |  | ?MetadataStatementRepository | $metadataStatementRepository
 | ) |  |

Documentation des fonctions membres

◆ addAlgorithm()

addAlgorithm | ( | string | $alias,
 |  | Algorithm | $algorithm
 | ) |  |

◆ enforceAndroidSafetyNetVerification()

enforceAndroidSafetyNetVerification | ( | ClientInterface | $client,
 |  | string | $apiKey,
 |  | RequestFactoryInterface | $requestFactory
 | ) |  |

Références $client.

◆ generatePublicKeyCredentialCreationOptions()

generatePublicKeyCredentialCreationOptions | ( | PublicKeyCredentialUserEntity | $userEntity,
 |  | ?string | $attestationMode = PublicKeyCredentialCreationOptions::ATTESTATION_CONVEYANCE_PREFERENCE_NONE,
 |  | array | $excludedPublicKeyDescriptors = [],
 |  | ?AuthenticatorSelectionCriteria | $criteria = null,
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
PublicKeyCredentialDescriptor[] $excludedPublicKeyDescriptors

◆ generatePublicKeyCredentialRequestOptions()

generatePublicKeyCredentialRequestOptions | ( | ?string | $userVerification = PublicKeyCredentialRequestOptions::USER_VERIFICATION_REQUIREMENT_PREFERRED,
 |  | array | $allowedPublicKeyDescriptors = [],
 |  | ?AuthenticationExtensionsClientInputs | $extensions = null
 | ) |  |
Paramètres
PublicKeyCredentialDescriptor[] $allowedPublicKeyDescriptors

◆ getAttestationStatementSupportManager()

getAttestationStatementSupportManager ( )
private

Références null.

◆ loadAndCheckAssertionResponse()

loadAndCheckAssertionResponse | ( | string | $data,
 |  | PublicKeyCredentialRequestOptions | $publicKeyCredentialRequestOptions,
 |  | ?PublicKeyCredentialUserEntity | $userEntity,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |

Références $data, $this, AuthenticatorAssertionResponseValidator\check(), class, PublicKeyCredentialUserEntity\getId(), et null.

◆ loadAndCheckAttestationResponse()

loadAndCheckAttestationResponse | ( | string | $data,
 |  | PublicKeyCredentialCreationOptions | $publicKeyCredentialCreationOptions,
 |  | ServerRequestInterface | $serverRequest
 | ) |  |

Références $data, et class.

◆ setExtensionOutputCheckerHandler()

setExtensionOutputCheckerHandler ( ExtensionOutputCheckerHandler $extensionOutputCheckerHandler )

◆ setSelectedAlgorithms()

setSelectedAlgorithms ( array $selectedAlgorithms )
Paramètres
string[] $selectedAlgorithms

◆ setTokenBindingHandler()

setTokenBindingHandler ( TokenBindingNotSupportedHandler $tokenBindingHandler )

Documentation des champs

◆ $challengeSize

$challengeSize = 32

◆ $coseAlgorithmManagerFactory

$coseAlgorithmManagerFactory
private

◆ $extensionOutputCheckerHandler

$extensionOutputCheckerHandler
private

◆ $googleApiKey

$googleApiKey
private

◆ $httpClient

$httpClient
private

◆ $metadataStatementRepository

$metadataStatementRepository
private

◆ $publicKeyCredentialSourceRepository

$publicKeyCredentialSourceRepository
private

◆ $requestFactory

$requestFactory
private

◆ $rpEntity

$rpEntity
private

◆ $selectedAlgorithms

$selectedAlgorithms
private

◆ $timeout

$timeout = 60000

◆ $tokenBindingHandler

$tokenBindingHandler
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/vendor/web-auth/webauthn-lib/src/Server.php


Joomla CMS: Référence de la classe StringStream

  • Webauthn
  • StringStream
Fonctions membres publiques | Attributs privés
Référence de la classe StringStream
+ Graphe d'héritage de StringStream:
Stream

Fonctions membres publiques

__construct (string $data)
read (int $length)
close ()
isEOF ()

Attributs privés

$data
$length
$totalRead = 0

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( string $data )

Références $data, $result, et true.

Documentation des fonctions membres

◆ close()

close ( )

Références $result, et true.

◆ isEOF()

isEOF ( )

◆ read()

read ( int $length )

Implémente Stream.

Références null.

Référencé par TPMAttestationStatementSupport\getParameters().

Documentation des champs

◆ $data

$data
private

◆ $length

$length
private

◆ $totalRead

$totalRead = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • web-auth/webauthn-lib/src/StringStream.php


Joomla CMS: Référence de la classe Assert

  • Webmozart
  • Assert
  • Assert
Fonctions membres publiques statiques | Fonctions membres protégées statiques | Fonctions membres privées
Référence de la classe Assert

Fonctions membres publiques statiques

static | string ($value, $message='')
static | stringNotEmpty ($value, $message='')
static | integer ($value, $message='')
static | integerish ($value, $message='')
static | positiveInteger ($value, $message='')
static | float ($value, $message='')
static | numeric ($value, $message='')
static | natural ($value, $message='')
static | boolean ($value, $message='')
static | scalar ($value, $message='')
static | object ($value, $message='')
static | resource ($value, $type=null, $message='')
static | isCallable ($value, $message='')
static | isArray ($value, $message='')
static | isTraversable ($value, $message='')
static | isArrayAccessible ($value, $message='')
static | isCountable ($value, $message='')
static | isIterable ($value, $message='')
static | isInstanceOf ($value, $class, $message='')
static | notInstanceOf ($value, $class, $message='')
static | isInstanceOfAny ($value, array $classes, $message='')
static | isAOf ($value, $class, $message='')
static | isNotA ($value, $class, $message='')
static | isAnyOf ($value, array $classes, $message='')
static | isEmpty ($value, $message='')
static | notEmpty ($value, $message='')
static | null ($value, $message='')
static | notNull ($value, $message='')
static | true ($value, $message='')
static | false ($value, $message='')
static | notFalse ($value, $message='')
static | ip ($value, $message='')
static | ipv4 ($value, $message='')
static | ipv6 ($value, $message='')
static | email ($value, $message='')
static | uniqueValues (array $values, $message='')
static | eq ($value, $expect, $message='')
static | notEq ($value, $expect, $message='')
static | same ($value, $expect, $message='')
static | notSame ($value, $expect, $message='')
static | greaterThan ($value, $limit, $message='')
static | greaterThanEq ($value, $limit, $message='')
static | lessThan ($value, $limit, $message='')
static | lessThanEq ($value, $limit, $message='')
static | range ($value, $min, $max, $message='')
static | oneOf ($value, array $values, $message='')
static | inArray ($value, array $values, $message='')
static | contains ($value, $subString, $message='')
static | notContains ($value, $subString, $message='')
static | notWhitespaceOnly ($value, $message='')
static | startsWith ($value, $prefix, $message='')
static | notStartsWith ($value, $prefix, $message='')
static | startsWithLetter ($value, $message='')
static | endsWith ($value, $suffix, $message='')
static | notEndsWith ($value, $suffix, $message='')
static | regex ($value, $pattern, $message='')
static | notRegex ($value, $pattern, $message='')
static | unicodeLetters ($value, $message='')
static | alpha ($value, $message='')
static | digits ($value, $message='')
static | alnum ($value, $message='')
static | lower ($value, $message='')
static | upper ($value, $message='')
static | length ($value, $length, $message='')
static | minLength ($value, $min, $message='')
static | maxLength ($value, $max, $message='')
static | lengthBetween ($value, $min, $max, $message='')
static | fileExists ($value, $message='')
static | file ($value, $message='')
static | directory ($value, $message='')
static | readable ($value, $message='')
static | writable ($value, $message='')
static | classExists ($value, $message='')
static | subclassOf ($value, $class, $message='')
static | interfaceExists ($value, $message='')
static | implementsInterface ($value, $interface, $message='')
static | propertyExists ($classOrObject, $property, $message='')
static | propertyNotExists ($classOrObject, $property, $message='')
static | methodExists ($classOrObject, $method, $message='')
static | methodNotExists ($classOrObject, $method, $message='')
static | keyExists ($array, $key, $message='')
static | keyNotExists ($array, $key, $message='')
static | validArrayKey ($value, $message='')
static | count ($array, $number, $message='')
static | minCount ($array, $min, $message='')
static | maxCount ($array, $max, $message='')
static | countBetween ($array, $min, $max, $message='')
static | isList ($array, $message='')
static | isNonEmptyList ($array, $message='')
static | isMap ($array, $message='')
static | isNonEmptyMap ($array, $message='')
static | uuid ($value, $message='')
static | throws (Closure $expression, $class='Exception', $message='')
static | __callStatic ($name, $arguments)

Fonctions membres protégées statiques

static | valueToString ($value)
static | typeToString ($value)
static | strlen ($value)
static | reportInvalidArgument ($message)

Fonctions membres privées

__construct ()

Description détaillée

Efficient assertions to validate the input/output of your methods.

Depuis
1.0
Auteur
Bernhard Schussek bschu.nosp@m.ssek.nosp@m.@gmai.nosp@m.l.co.nosp@m.m

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )
private

Documentation des fonctions membres

◆ __callStatic()

static __callStatic | ( | $name,
 |  | $arguments
 | ) |
static
Exceptions
BadMethodCallException

Références $method, $name, et Assert\null().

◆ alnum()

static alnum | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ alpha()

static alpha | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ boolean()

static boolean | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert bool $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ classExists()

static classExists | ( | $value,
 |  | $message = ''
 | ) |
static

-assert class-string $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ contains()

static contains | ( | $value,
 |  | $subString,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $subString
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ count()

static count | ( | $array,
 |  | $number,
 |  | $message = ''
 | ) |
static

Does not check if $array is countable, this can generate a warning on php versions after 7.2.

Paramètres
Countable | array | $array
int | $number
string | $message
Exceptions
InvalidArgumentException

Références $message.

Référencé par Assert\countBetween(), Assert\maxCount(), Assert\minCount(), et Assert\uniqueValues().

◆ countBetween()

static countBetween | ( | $array,
 |  | $min,
 |  | $max,
 |  | $message = ''
 | ) |
static

Does not check if $array is countable, this can generate a warning on php versions after 7.2.

Paramètres
Countable | array | $array
int | float | $min
int | float | $max
string | $message
Exceptions
InvalidArgumentException

Références $count, $message, et Assert\count().

◆ digits()

static digits | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ directory()

static directory | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ email()

static email | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ endsWith()

static endsWith | ( | $value,
 |  | $suffix,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $suffix
string | $message
Exceptions
InvalidArgumentException

Références $message, $suffix, $value, et Assert\strlen().

◆ eq()

static eq | ( | $value,
 |  | $expect,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
mixed | $expect
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ false()

static false | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert false $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ file()

static file | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ fileExists()

static fileExists | ( | $value,
 |  | $message = ''
 | ) |
static

Will also pass if $value is a directory, use Assert::file() instead if you need to be sure it is a file.

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ float()

static float | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert float $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ greaterThan()

static greaterThan | ( | $value,
 |  | $limit,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $limit
string | $message
Exceptions
InvalidArgumentException

Références $limit, $message, et $value.

◆ greaterThanEq()

static greaterThanEq | ( | $value,
 |  | $limit,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $limit
string | $message
Exceptions
InvalidArgumentException

Références $limit, $message, et $value.

◆ implementsInterface()

static implementsInterface | ( | $value,
 |  | $interface,
 |  | $message = ''
 | ) |
static

-pure -template ExpectedType of object -param class-string<ExpectedType> $interface -assert class-string<ExpectedType> $value

Paramètres
mixed | $value
mixed | $interface
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ inArray()

static inArray | ( |  | $value,
 |  | array | $values,
 |  |  | $message = ''
 | ) |  |
static

Does strict comparison, so Assert::inArray(3, ['3']) does not pass the assertion.

-pure

Paramètres
mixed | $value
array | $values
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ integer()

static integer | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert int $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ integerish()

static integerish | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert numeric $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ interfaceExists()

static interfaceExists | ( | $value,
 |  | $message = ''
 | ) |
static

-assert class-string $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ ip()

static ip | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ ipv4()

static ipv4 | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ ipv6()

static ipv6 | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isAnyOf()

static isAnyOf | ( |  | $value,
 |  | array | $classes,
 |  |  | $message = ''
 | ) |  |
static

-pure -param array<class-string> $classes

Paramètres
object | string | $value
string[] | $classes
string | $message
Exceptions
InvalidArgumentException

Références $class, $classes, $message, et $value.

◆ isAOf()

static isAOf | ( | $value,
 |  | $class,
 |  | $message = ''
 | ) |
static

-pure -template ExpectedType of object -param class-string<ExpectedType> $class -assert ExpectedType|class-string<ExpectedType> $value

Paramètres
object | string | $value
string | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, $message, et $value.

◆ isArray()

static isArray | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert array $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isArrayAccessible()

static isArrayAccessible | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert array|ArrayAccess $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isCallable()

static isCallable | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert callable $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isCountable()

static isCountable | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert countable $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isEmpty()

static isEmpty | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert empty $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isInstanceOf()

static isInstanceOf | ( | $value,
 |  | $class,
 |  | $message = ''
 | ) |
static

-pure -template ExpectedType of object -param class-string<ExpectedType> $class -assert ExpectedType $value

Paramètres
mixed | $value
string | object | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, $message, et $value.

◆ isInstanceOfAny()

static isInstanceOfAny | ( |  | $value,
 |  | array | $classes,
 |  |  | $message = ''
 | ) |  |
static

-pure -param array<class-string> $classes

Paramètres
mixed | $value
array<object|string> | $classes
string | $message
Exceptions
InvalidArgumentException

Références $class, $classes, $message, et $value.

◆ isIterable()

static isIterable | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert iterable $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ isList()

static isList | ( | $array,
 |  | $message = ''
 | ) |
static

-pure -assert list $array

Paramètres
mixed | $array
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ isMap()

static isMap | ( | $array,
 |  | $message = ''
 | ) |
static

-pure -template T -param mixed|array<T> $array -assert array<string, T> $array

Paramètres
mixed | $array
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ isNonEmptyList()

static isNonEmptyList | ( | $array,
 |  | $message = ''
 | ) |
static

-pure -assert non-empty-list $array

Paramètres
mixed | $array
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ isNonEmptyMap()

static isNonEmptyMap | ( | $array,
 |  | $message = ''
 | ) |
static

-pure -template T -param mixed|array<T> $array -assert array<string, T> $array -assert !empty $array

Paramètres
mixed | $array
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ isNotA()

static isNotA | ( | $value,
 |  | $class,
 |  | $message = ''
 | ) |
static

-pure -template UnexpectedType of object -param class-string<UnexpectedType> $class -assert !UnexpectedType $value -assert !class-string<UnexpectedType> $value

Paramètres
object | string | $value
string | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, $message, et $value.

◆ isTraversable()

static isTraversable | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert iterable $value

Obsolète:
use "isIterable" or "isInstanceOf" instead
Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ keyExists()

static keyExists | ( | $array,
 |  | $key,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
array | $array
string | int | $key
string | $message
Exceptions
InvalidArgumentException

Références $key, et $message.

◆ keyNotExists()

static keyNotExists | ( | $array,
 |  | $key,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
array | $array
string | int | $key
string | $message
Exceptions
InvalidArgumentException

Références $key, et $message.

◆ length()

static length | ( | $value,
 |  | $length,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
int | $length
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ lengthBetween()

static lengthBetween | ( | $value,
 |  | $min,
 |  | $max,
 |  | $message = ''
 | ) |
static

Inclusive , so Assert::lengthBetween('asd', 3, 5); passes the assertion.

-pure

Paramètres
string | $value
int | float | $min
int | float | $max
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ lessThan()

static lessThan | ( | $value,
 |  | $limit,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $limit
string | $message
Exceptions
InvalidArgumentException

Références $limit, $message, et $value.

◆ lessThanEq()

static lessThanEq | ( | $value,
 |  | $limit,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $limit
string | $message
Exceptions
InvalidArgumentException

Références $limit, $message, et $value.

◆ lower()

static lower | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert lowercase-string $value

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ maxCount()

static maxCount | ( | $array,
 |  | $max,
 |  | $message = ''
 | ) |
static

Does not check if $array is countable, this can generate a warning on php versions after 7.2.

Paramètres
Countable | array | $array
int | float | $max
string | $message
Exceptions
InvalidArgumentException

Références $message, et Assert\count().

◆ maxLength()

static maxLength | ( | $value,
 |  | $max,
 |  | $message = ''
 | ) |
static

Inclusive max.

-pure

Paramètres
string | $value
int | float | $max
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ methodExists()

static methodExists | ( | $classOrObject,
 |  | $method,
 |  | $message = ''
 | ) |
static

-pure -param class-string|object $classOrObject

Paramètres
string | object | $classOrObject
mixed | $method
string | $message
Exceptions
InvalidArgumentException

Références $message, et $method.

◆ methodNotExists()

static methodNotExists | ( | $classOrObject,
 |  | $method,
 |  | $message = ''
 | ) |
static

-pure -param class-string|object $classOrObject

Paramètres
string | object | $classOrObject
mixed | $method
string | $message
Exceptions
InvalidArgumentException

Références $message, et $method.

◆ minCount()

static minCount | ( | $array,
 |  | $min,
 |  | $message = ''
 | ) |
static

Does not check if $array is countable, this can generate a warning on php versions after 7.2.

Paramètres
Countable | array | $array
int | float | $min
string | $message
Exceptions
InvalidArgumentException

Références $message, et Assert\count().

◆ minLength()

static minLength | ( | $value,
 |  | $min,
 |  | $message = ''
 | ) |
static

Inclusive min.

-pure

Paramètres
string | $value
int | float | $min
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ natural()

static natural | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert positive-int|0 $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notContains()

static notContains | ( | $value,
 |  | $subString,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $subString
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notEmpty()

static notEmpty | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert !empty $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notEndsWith()

static notEndsWith | ( | $value,
 |  | $suffix,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $suffix
string | $message
Exceptions
InvalidArgumentException

Références $message, $suffix, $value, et Assert\strlen().

◆ notEq()

static notEq | ( | $value,
 |  | $expect,
 |  | $message = ''
 | ) |
static
Paramètres
mixed | $value
mixed | $expect
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notFalse()

static notFalse | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert !false $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notInstanceOf()

static notInstanceOf | ( | $value,
 |  | $class,
 |  | $message = ''
 | ) |
static

-pure -template ExpectedType of object -param class-string<ExpectedType> $class -assert !ExpectedType $value

Paramètres
mixed | $value
string | object | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, $message, et $value.

◆ notNull()

static notNull | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert !null $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, $value, et Assert\null().

◆ notRegex()

static notRegex | ( | $value,
 |  | $pattern,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $pattern
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notSame()

static notSame | ( | $value,
 |  | $expect,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $expect
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ notStartsWith()

static notStartsWith | ( | $value,
 |  | $prefix,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $prefix
string | $message
Exceptions
InvalidArgumentException

Références $message, $prefix, et $value.

◆ notWhitespaceOnly()

static notWhitespaceOnly | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ null()

static null | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert null $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

Référencé par Assert\__callStatic(), Assert\notNull(), et Assert\valueToString().

◆ numeric()

static numeric | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert numeric $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ object()

static object | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert object $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ oneOf()

static oneOf | ( |  | $value,
 |  | array | $values,
 |  |  | $message = ''
 | ) |  |
static

A more human-readable alias of Assert::inArray().

-pure

Paramètres
mixed | $value
array | $values
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ positiveInteger()

static positiveInteger | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert positive-int $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ propertyExists()

static propertyExists | ( | $classOrObject,
 |  | $property,
 |  | $message = ''
 | ) |
static

-pure -param class-string|object $classOrObject

Paramètres
string | object | $classOrObject
mixed | $property
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ propertyNotExists()

static propertyNotExists | ( | $classOrObject,
 |  | $property,
 |  | $message = ''
 | ) |
static

-pure -param class-string|object $classOrObject

Paramètres
string | object | $classOrObject
mixed | $property
string | $message
Exceptions
InvalidArgumentException

Références $message.

◆ range()

static range | ( | $value,
 |  | $min,
 |  | $max,
 |  | $message = ''
 | ) |
static

Inclusive range, so Assert::(3, 3, 5) passes.

-pure

Paramètres
mixed | $value
mixed | $min
mixed | $max
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ readable()

static readable | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ regex()

static regex | ( | $value,
 |  | $pattern,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $pattern
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ reportInvalidArgument()

static reportInvalidArgument ( $message )
staticprotected
Paramètres
string $message
Exceptions
InvalidArgumentException -pure this method is not supposed to perform side-effects

Références $message.

◆ resource()

static resource | ( | $value,
 |  | $type = null,
 |  | $message = ''
 | ) |
static

-pure -assert resource $value

Paramètres
mixed | $value
string | null | $type | type of resource this should be.
Voir également
https://www.php.net/manual/en/function.get-resource-type.php
Paramètres
string $message
Exceptions
InvalidArgumentException

Références $message, $type, et $value.

◆ same()

static same | ( | $value,
 |  | $expect,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
mixed | $expect
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ scalar()

static scalar | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert scalar $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ startsWith()

static startsWith | ( | $value,
 |  | $prefix,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $prefix
string | $message
Exceptions
InvalidArgumentException

Références $message, $prefix, et $value.

◆ startsWithLetter()

static startsWithLetter | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ string()

static string | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert string $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ stringNotEmpty()

static stringNotEmpty | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert non-empty-string $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ strlen()

static strlen ( $value )
staticprotected

Références $value.

Référencé par Assert\endsWith(), et Assert\notEndsWith().

◆ subclassOf()

static subclassOf | ( | $value,
 |  | $class,
 |  | $message = ''
 | ) |
static

-pure -template ExpectedType of object -param class-string<ExpectedType> $class -assert class-string<ExpectedType>|ExpectedType $value

Paramètres
mixed | $value
string | object | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, $message, et $value.

◆ throws()

static throws | ( | Closure | $expression,
 |  |  | $class = 'Exception',
 |  |  | $message = ''
 | ) |  |
static

-param class-string<Throwable> $class

Paramètres
Closure | $expression
string | $class
string | $message
Exceptions
InvalidArgumentException

Références $class, et $message.

◆ true()

static true | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert true $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ typeToString()

static typeToString ( $value )
staticprotected
Paramètres
mixed $value
Renvoie
string

Références $value.

◆ unicodeLetters()

static unicodeLetters | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ uniqueValues()

static uniqueValues | ( | array | $values,
 |  |  | $message = ''
 | ) |  |
static

Does non strict comparisons on the items, so ['3', 3] will not pass the assertion.

Paramètres
array | $values
string | $message
Exceptions
InvalidArgumentException

Références $message, et Assert\count().

◆ upper()

static upper | ( | $value,
 |  | $message = ''
 | ) |
static

-pure -assert !lowercase-string $value

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ uuid()

static uuid | ( | $value,
 |  | $message = ''
 | ) |
static

-pure

Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ validArrayKey()

static validArrayKey | ( | $value,
 |  | $message = ''
 | ) |
static

Checks if a value is a valid array key (int or string).

-pure -assert array-key $value

Paramètres
mixed | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

◆ valueToString()

static valueToString ( $value )
staticprotected
Paramètres
mixed $value
Renvoie
string

Références $value, et Assert\null().

◆ writable()

static writable | ( | $value,
 |  | $message = ''
 | ) |
static
Paramètres
string | $value
string | $message
Exceptions
InvalidArgumentException

Références $message, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • webmozart/assert/src/Assert.php


Joomla CMS: Référence de la classe InvalidArgumentException

  • Webmozart
  • Assert
  • InvalidArgumentException
Référence de la classe InvalidArgumentException
+ Graphe d'héritage de InvalidArgumentException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • webmozart/assert/src/InvalidArgumentException.php


Joomla CMS: Référence de la classe Attribute

Fonctions membres publiques | Champs de données
Référence de la classe Attribute

Fonctions membres publiques

__construct (int $flags=self::TARGET_ALL)

Champs de données

const | TARGET_CLASS = 1
const | TARGET_FUNCTION = 2
const | TARGET_METHOD = 4
const | TARGET_PROPERTY = 8
const | TARGET_CLASS_CONSTANT = 16
const | TARGET_PARAMETER = 32
const | TARGET_ALL = 63
const | IS_REPEATABLE = 64
$flags

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( int $flags = self::TARGET_ALL )

Références $flags.

Documentation des champs

◆ $flags

$flags

Référencé par __construct().

◆ IS_REPEATABLE

const IS_REPEATABLE = 64

◆ TARGET_ALL

const TARGET_ALL = 63

◆ TARGET_CLASS

const TARGET_CLASS = 1

◆ TARGET_CLASS_CONSTANT

const TARGET_CLASS_CONSTANT = 16

◆ TARGET_FUNCTION

const TARGET_FUNCTION = 2

◆ TARGET_METHOD

const TARGET_METHOD = 4

◆ TARGET_PARAMETER

const TARGET_PARAMETER = 32

◆ TARGET_PROPERTY

const TARGET_PROPERTY = 8
La documentation de cette classe a été générée à partir du fichier suivant :
  • symfony/polyfill-php80/Resources/stubs/Attribute.php


Joomla CMS: Référence de la classe BannersHelper

Référence de la classe BannersHelper
+ Graphe d'héritage de BannersHelper:
BannersHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de BannersHelper
static | getClientOptions ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Banners component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_banners/helpers/banners.php


Joomla CMS: Référence de la classe CannotPerformOperationException

Référence de la classe CannotPerformOperationException
+ Graphe d'héritage de CannotPerformOperationException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • php-encryption/Crypto.php


Joomla CMS: Référence de la classe CategoriesHelper

Référence de la classe CategoriesHelper
+ Graphe d'héritage de CategoriesHelper:
CategoriesHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de CategoriesHelper
static | getAssociations ($pk, $extension='com_content')
static | validateCategoryId ($catid, $extension)
static | createCategory ($data)

Description détaillée

Categories helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_categories/helpers/categories.php


Joomla CMS: Référence de la classe ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f

Fonctions membres publiques statiques | Attributs privés statiques
Référence de la classe ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f

Fonctions membres publiques statiques

static | loadClassLoader ($class)
static | getLoader ()

Attributs privés statiques

static $loader

Documentation des fonctions membres

◆ getLoader()

static getLoader ( )
static
Renvoie

Références ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\$files, $loader, $loader, __DIR__, composerRequire2399d40fc48ada3450e844df0430bf2f(), et null.

◆ loadClassLoader()

static loadClassLoader ( $class )
static

Références $class, et __DIR__.

Documentation des champs

◆ $loader

$loader
staticprivate

Référencé par getLoader().

La documentation de cette classe a été générée à partir du fichier suivant :
  • autoload_real.php


Joomla CMS: Référence de la classe ContactHelper

Référence de la classe ContactHelper
+ Graphe d'héritage de ContactHelper:
ContactHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Contact component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contact/helpers/contact.php


Joomla CMS: Référence de la classe ContactHelperRoute

Référence de la classe ContactHelperRoute
+ Graphe d'héritage de ContactHelperRoute:
RouteHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RouteHelper
static | getContactRoute ($id, $catid, $language=0)
static | getCategoryRoute ($catid, $language=0)
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_contact/helpers/route.php


Joomla CMS: Référence de la classe ContentHelper

Référence de la classe ContentHelper
+ Graphe d'héritage de ContentHelper:
ContentHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de ContentHelper
static | canDeleteState (int $id)
static | filterTransitions (array $transitions, int $pk, int $workflowId=0)
static | onPrepareForm (Form $form, $data)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)

Description détaillée

Content component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_content/helpers/content.php


Joomla CMS: Référence de la classe ContenthistoryHelper

Référence de la classe ContenthistoryHelper
+ Graphe d'héritage de ContenthistoryHelper:
ContenthistoryHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ContenthistoryHelper
static | createObjectArray ($object)
static | decodeFields ($jsonString)
static | getFormValues ($object, ContentType $typesTable)
static | getFormFile (ContentType $typesTable)
static | getLookupValue ($lookup, $value)
static | hideFields ($object, ContentType $typeTable)
static | loadLanguageFiles ($typeAlias)
static | mergeLabels ($object, $formValues)
static | prepareData (ContentHistory $table)
static | processLookupFields ($object, ContentType $typesTable)

Description détaillée

Categories helper.

Depuis
3.2
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_contenthistory/helpers/contenthistory.php


Joomla CMS: Référence de la classe Crypto

Fonctions membres publiques statiques | Champs de données | Fonctions membres privées statiques
Référence de la classe Crypto

Fonctions membres publiques statiques

static | CreateNewRandomKey ()
static | Encrypt ($plaintext, $key)
static | Decrypt ($ciphertext, $key)
static | RuntimeTest ()

Champs de données

const | CIPHER = MCRYPT_RIJNDAEL_128
const | KEY_BYTE_SIZE = 16
const | CIPHER_MODE = 'cbc'
const | HASH_FUNCTION = 'sha256'
const | MAC_BYTE_SIZE = 32
const | ENCRYPTION_INFO = 'DefusePHP|KeyForEncryption'
const | AUTHENTICATION_INFO = 'DefusePHP|KeyForAuthentication'

Fonctions membres privées statiques

static | PlainEncrypt ($plaintext, $key, $iv)
static | PlainDecrypt ($ciphertext, $key, $iv)
static | SecureRandom ($octets)
static | HKDF ($hash, $ikm, $length, $info='', $salt=NULL)
static | VerifyHMAC ($correct_hmac, $message, $key)
static | TestEncryptDecrypt ()
static | HKDFTestVector ()
static | HMACTestVector ()
static | AESTestVector ()
static | hexToBytes ($hex_string)
static | EnsureFunctionExists ($name)
static | our_strlen ($str)
static | our_substr ($str, $start, $length=NULL)

Documentation des fonctions membres

◆ AESTestVector()

static AESTestVector ( )
staticprivate

Références $key.

◆ CreateNewRandomKey()

static CreateNewRandomKey ( )
static

Références RuntimeTest().

Référencé par CryptoCipher\generateKey(), RuntimeTest(), et TestEncryptDecrypt().

◆ Decrypt()

static Decrypt | ( | $ciphertext,
 |  | $key
 | ) |
static

Références $key, et RuntimeTest().

Référencé par TestEncryptDecrypt().

◆ Encrypt()

static Encrypt | ( | $plaintext,
 |  | $key
 | ) |
static

Références $key, et RuntimeTest().

Référencé par TestEncryptDecrypt().

◆ EnsureFunctionExists()

static EnsureFunctionExists ( $name )
staticprivate

Références $name.

◆ hexToBytes()

static hexToBytes ( $hex_string )
staticprivate

◆ HKDF()

static HKDF | ( | $hash,
 |  | $ikm,
 |  | $length,
 |  | $info = '',
 |  | $salt = NULL
 | ) |
staticprivate

Références $hash, et $info.

◆ HKDFTestVector()

static HKDFTestVector ( )
staticprivate

Références $info.

◆ HMACTestVector()

static HMACTestVector ( )
staticprivate

Références $data, et $key.

◆ our_strlen()

static our_strlen ( $str )
staticprivate

◆ our_substr()

static our_substr | ( | $str,
 |  | $start,
 |  | $length = NULL
 | ) |
staticprivate

Références $start.

◆ PlainDecrypt()

static PlainDecrypt | ( | $ciphertext,
 |  | $key,
 |  | $iv
 | ) |
staticprivate

Références $key.

◆ PlainEncrypt()

static PlainEncrypt | ( | $plaintext,
 |  | $key,
 |  | $iv
 | ) |
staticprivate

Références $key.

◆ RuntimeTest()

static RuntimeTest ( )
static

Références CreateNewRandomKey().

Référencé par CreateNewRandomKey(), Decrypt(), Encrypt(), et CryptoCipher\isSupported().

◆ SecureRandom()

static SecureRandom ( $octets )
staticprivate

◆ TestEncryptDecrypt()

static TestEncryptDecrypt ( )
staticprivate

Références $data, $key, CreateNewRandomKey(), Decrypt(), et Encrypt().

◆ VerifyHMAC()

static VerifyHMAC | ( | $correct_hmac,
 |  | $message,
 |  | $key
 | ) |
staticprivate

Références $key, et $message.

Documentation des champs

◆ AUTHENTICATION_INFO

const AUTHENTICATION_INFO = 'DefusePHP|KeyForAuthentication'

◆ CIPHER

const CIPHER = MCRYPT_RIJNDAEL_128

◆ CIPHER_MODE

const CIPHER_MODE = 'cbc'

◆ ENCRYPTION_INFO

const ENCRYPTION_INFO = 'DefusePHP|KeyForEncryption'

◆ HASH_FUNCTION

const HASH_FUNCTION = 'sha256'

◆ KEY_BYTE_SIZE

const KEY_BYTE_SIZE = 16

◆ MAC_BYTE_SIZE

const MAC_BYTE_SIZE = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • php-encryption/Crypto.php


Joomla CMS: Référence de la classe CryptoExceptionHandler

Fonctions membres publiques | Attributs privés
Référence de la classe CryptoExceptionHandler

Fonctions membres publiques

__construct ()
handler ($ex)
__destruct ()

Attributs privés

$rethrow = NULL

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Références $this.

◆ __destruct()

__destruct ( )

Références $rethrow.

Documentation des fonctions membres

◆ handler()

handler ( $ex )

Documentation des champs

◆ $rethrow

$rethrow = NULL
private

Référencé par __destruct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • php-encryption/Crypto.php


Joomla CMS: Référence de la classe CryptoTestFailedException

Référence de la classe CryptoTestFailedException
+ Graphe d'héritage de CryptoTestFailedException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • php-encryption/Crypto.php


Joomla CMS: Référence de la classe En_GBLocalise

Fonctions membres publiques statiques
Référence de la classe En_GBLocalise

Fonctions membres publiques statiques

static | getPluralSuffixes ($count)
static | getIgnoredSearchWords ()
static | getLowerLimitSearchWord ()
static | getUpperLimitSearchWord ()
static | getSearchDisplayedCharactersNumber ()
static | getPluralSuffixes ($count)

Description détaillée

en-GB localise class.

Depuis
1.6

Documentation des fonctions membres

◆ getIgnoredSearchWords()

static getIgnoredSearchWords ( )
static

Returns the ignored search words

Renvoie
array An array of ignored search words.
Depuis
1.6

◆ getLowerLimitSearchWord()

static getLowerLimitSearchWord ( )
static

Returns the lower length limit of search words

Renvoie
integer The lower length limit of search words.
Depuis
1.6

◆ getPluralSuffixes() [1/2]

static getPluralSuffixes ( $count )
static

Returns the potential suffixes for a specific number of items

Paramètres
integer $count The number of items.
Renvoie
array An array of potential suffixes.
Depuis
1.6

Références $count, et elseif.

◆ getPluralSuffixes() [2/2]

static getPluralSuffixes ( $count )
static

Returns the potential suffixes for a specific number of items

Paramètres
integer $count The number of items.
Renvoie
array An array of potential suffixes.
Depuis
1.6

Références $count, et elseif.

◆ getSearchDisplayedCharactersNumber()

static getSearchDisplayedCharactersNumber ( )
static

Returns the number of chars to display when searching

Renvoie
integer The number of chars to display when searching.
Depuis
1.6

◆ getUpperLimitSearchWord()

static getUpperLimitSearchWord ( )
static

Returns the upper length limit of search words

Renvoie
integer The upper length limit of search words.
Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/language/en-GB/localise.php


Joomla CMS: Référence de la classe FieldsHelper

Référence de la classe FieldsHelper
+ Graphe d'héritage de FieldsHelper:
FieldsHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de FieldsHelper
static | extract ($contextString, $item=null)
static | getFields ( $context, $item=null, $prepareValue=false, array $valuesToOverride=null, bool $includeSubformFields=false)
static | render ($context, $layoutFile, $displayData)
static | canEditFieldValue ($field)
static | displayFieldOnForm ($field)
static | getAssignedCategoriesIds ($fieldId)
static | getAssignedCategoriesTitles ($fieldId)
static | getFieldsPluginId ()
static | getFieldTypes ()
static | clearFieldsCache ()

Description détaillée

FieldsHelper

Depuis
3.7.0
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_fields/helpers/fields.php


Joomla CMS: Référence de la classe FinderHelperLanguage

Référence de la classe FinderHelperLanguage
+ Graphe d'héritage de FinderHelperLanguage:
LanguageHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de LanguageHelper
static | branchPlural ($branchName)
static | branchSingular ($branchName)
static | branchLanguageTitle ($branchName)
static | loadComponentLanguage ()
static | loadPluginLanguage ()

Description détaillée

Finder language helper class.

Depuis
2.5
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_finder/helpers/language.php


Joomla CMS: Référence de la classe FinderHelperRoute

Référence de la classe FinderHelperRoute
+ Graphe d'héritage de FinderHelperRoute:
RouteHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RouteHelper
static | getSearchRoute ($f=null, $q=null)
static | getAdvancedRoute ($f=null, $q=null)
static | getItemid ($query)

Description détaillée

Finder route helper class.

Depuis
2.5
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_finder/helpers/route.php


Joomla CMS: Référence de la classe Fr_FRLocalise

Fonctions membres publiques statiques
Référence de la classe Fr_FRLocalise

Fonctions membres publiques statiques

static | getPluralSuffixes ($count)
static | getIgnoredSearchWords ()
static | getLowerLimitSearchWord ()
static | getUpperLimitSearchWord ()
static | getSearchDisplayedCharactersNumber ()
static | getPluralSuffixes ($count)

Description détaillée

fr-FR localise classe.

Depuis
1.6

Documentation des fonctions membres

◆ getIgnoredSearchWords()

static getIgnoredSearchWords ( )
static

Returns the ignored search words

Renvoie
array An array of ignored search words.
Depuis
1.6

◆ getLowerLimitSearchWord()

static getLowerLimitSearchWord ( )
static

Returns the lower length limit of search words

Renvoie
integer The lower length limit of search words.
Depuis
1.6

◆ getPluralSuffixes() [1/2]

static getPluralSuffixes ( $count )
static

Returns the potential suffixes for a specific number of items

Paramètres
integer $count The number of items.
Renvoie
array An array of potential suffixes.
Depuis
1.6

Références $count, et elseif.

◆ getPluralSuffixes() [2/2]

static getPluralSuffixes ( $count )
static

Returns the potential suffixes for a specific number of items

Paramètres
integer $count The number of items.
Renvoie
array An array of potential suffixes.
Depuis
1.6

Références $count, et elseif.

◆ getSearchDisplayedCharactersNumber()

static getSearchDisplayedCharactersNumber ( )
static

Returns the number of chars to display when searching

Renvoie
integer The number of chars to display when searching.
Depuis
1.6

◆ getUpperLimitSearchWord()

static getUpperLimitSearchWord ( )
static

Returns the upper length limit of search words

Renvoie
integer The upper length limit of search words.
Depuis
1.6
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/language/fr-FR/localise.php


Joomla CMS: Référence de la classe InstallerHelper

Référence de la classe InstallerHelper
+ Graphe d'héritage de InstallerHelper:
InstallerHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de InstallerHelper
static | getExtensionTypes ()
static | getExtensionGroups ()
static | getClientOptions ()
static | getStateOptions ()
static | getInstallationXML (string $element, string $type, int $clientId=1, ?string $folder=null)
static | getDownloadKey (CMSObject $extension)
static | getExtensionDownloadKey (string $element, string $type, int $clientId=1, ?string $folder=null)
static | getDownloadKeySupportedSites ($onlyEnabled=false)
static | getDownloadKeyExistsSites (bool $exists=true, $onlyEnabled=false)
- Fonctions membres protégées statiques hérités de InstallerHelper
static | getUpdateSitesInformation (bool $onlyEnabled)

Description détaillée

Installer helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_installer/helpers/installer.php


Joomla CMS: Référence de la classe InvalidCiphertextException

Référence de la classe InvalidCiphertextException
+ Graphe d'héritage de InvalidCiphertextException:
La documentation de cette classe a été générée à partir du fichier suivant :
  • php-encryption/Crypto.php


Joomla CMS: Référence de la classe JHtmlIcon

Fonctions membres publiques statiques | Fonctions membres privées statiques
Référence de la classe JHtmlIcon

Fonctions membres publiques statiques

static | create ($category, $params, $attribs=array(), $legacy=false)
static | edit ($article, $params, $attribs=array(), $legacy=false)
static | print_popup ($article, $params, $attribs=array(), $legacy=false)
static | print_screen ($article, $params, $attribs=array(), $legacy=false)

Fonctions membres privées statiques

static getIcon ()

Description détaillée

Content Component HTML Helper

Depuis
1.5
Obsolète:
5.0 Use the class instead

Documentation des fonctions membres

◆ create()

static create | ( | $category,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |
static

Method to generate a link to the create item page for the given category

Paramètres
object | $category | The category information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML markup for the create item link
Obsolète:
5.0 Use the class instead

Références $attribs, $category, et $params.

◆ edit()

static edit | ( | $article,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |
static

Display an edit icon for the article.

This icon will not display in a popup window, nor if the article is trashed. Edit access checks must be performed in the calling code.

Paramètres
object | $article | The article information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML for the article edit icon.
Depuis
1.6
Obsolète:
5.0 Use the class instead

Références $article, $attribs, et $params.

◆ getIcon()

static getIcon ( )
staticprivate

Creates an icon instance.

Renvoie

◆ print_popup()

static print_popup | ( | $article,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |
static

Method to generate a popup link to print an article

Paramètres
object | $article | The article information
Registry | $params | The item parameters
array | $attribs | Optional attributes for the link
boolean | $legacy | True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML markup for the popup link
Obsolète:
5.0 Use the class instead

◆ print_screen()

static print_screen | ( | $article,
 |  | $params,
 |  | $attribs = array(),
 |  | $legacy = false
 | ) |
static

Method to generate a link to print an article

Paramètres
object $article Not used,
Obsolète:
for 4.0
Paramètres
Registry | $params | The item parameters
array | $attribs | Not used,
Obsolète:
for 4.0
Paramètres
boolean $legacy True to use legacy images, false to use icomoon based graphic
Renvoie
string The HTML markup for the popup link
Obsolète:
5.0 Use the class instead

Références $params.

La documentation de cette classe a été générée à partir du fichier suivant :
  • components/com_content/helpers/icon.php


Joomla CMS: Référence de la classe JLoader

Fonctions membres publiques statiques | Attributs protégés statiques | Fonctions membres privées statiques
Référence de la classe JLoader

Fonctions membres publiques statiques

static | discover ($classPrefix, $parentPath, $force=true, $recurse=false)
static | getClassList ()
static | getDeprecatedAliases ()
static | getNamespaces ()
static | import ($key, $base=null)
static | load ($class)
static | register ($class, $path, $force=true)
static | registerPrefix ($prefix, $path, $reset=false, $prepend=false)
static | registerAlias ($alias, $original, $version=false)
static | registerNamespace ($namespace, $path, $reset=false, $prepend=false)
static | setup ($enablePsr=true, $enablePrefixes=true, $enableClasses=true)
static | loadByPsr4 ($class)
static | loadByPsr ($class)
static | loadByAlias ($class)
static | applyAliasFor ($class)
static | _autoload ($class)

Attributs protégés statiques

static | $classes = array()
static | $imported = array()
static | $prefixes = array()
static | $classAliases = array()
static | $classAliasesInverse = array()
static | $namespaces = array()
static | $deprecatedAliases = array()
static | $extensionRootFolders = array()

Fonctions membres privées statiques

static | _load ($class, $lookup)
static | loadAliasFor ($class)
static | stripFirstBackslash ($class)

Description détaillée

Static class to handle loading of libraries.

Depuis
1.7.0

Documentation des fonctions membres

◆ _autoload()

static _autoload ( $class )
static

Autoload a class based on name.

Paramètres
string $class The class to be loaded.
Renvoie
boolean True if the class was loaded, false otherwise.
Depuis
1.7.3

Références $class, et $prefix.

◆ _load()

static _load | ( | $class,
 |  | $lookup
 | ) |
staticprivate

Load a class based on name and lookup array.

Paramètres
string | $class | The class to be loaded (without prefix).
array | $lookup | The array of base paths to use for finding the class file.
Renvoie
boolean True if the class was loaded, false otherwise.
Depuis
3.0.0

Références $base, $class, $parts, et $path.

◆ applyAliasFor()

static applyAliasFor ( $class )
static

Applies a class alias for an already loaded class, if a class alias was created for it.

Paramètres
string $class We'll look for and register aliases for this (real) class name
Renvoie
void
Depuis
3.4

Références $class.

Référencé par ClassLoader\loadClass().

◆ discover()

static discover | ( | $classPrefix,
 |  | $parentPath,
 |  | $force = true,
 |  | $recurse = false
 | ) |
static

Method to discover classes of a given type in a given path.

Paramètres
string | $classPrefix | The class name prefix to use for discovery.
string | $parentPath | Full path to the parent folder for the classes to discover.
boolean | $force | True to overwrite the autoload path value for the class if it already exists.
boolean | $recurse | Recurse through all child directories as well as the parent path.
Renvoie
void
Depuis
1.7.0
Obsolète:
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.

$file DirectoryIterator

Références $class, et $classes.

◆ getClassList()

static getClassList ( )
static

Method to get the list of registered classes and their respective file paths for the autoloader.

Renvoie
array The array of class => path values for the autoloader.
Depuis
1.7.0

Références $classes.

◆ getDeprecatedAliases()

static getDeprecatedAliases ( )
static

Method to get the list of deprecated class aliases.

Renvoie
array An associative array with deprecated class alias data.
Depuis
3.6.3

◆ getNamespaces()

static getNamespaces ( )
static

Method to get the list of registered namespaces.

Renvoie
array The array of namespace => path values for the autoloader.
Depuis
3.1.4

◆ import()

static import | ( | $key,
 |  | $base = null
 | ) |
static

Loads a class from specified directories.

Paramètres
string | $key | The class name to look for (dot notation).
string | $base | Search this directory for the class.
Renvoie
boolean True on success.
Depuis
1.7.0
Obsolète:
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.

If we are not importing a library from the Joomla namespace directly include the file since we cannot assert the file/folder naming conventions.

Références $base, $class, $classes, $key, $parts, $path, et __DIR__.

Référencé par jimport().

◆ load()

static load ( $class )
static

Load the file for a class.

Paramètres
string $class The class to be loaded.
Renvoie
boolean True on success
Depuis
1.7.0

Références $class, $classes, et $key.

◆ loadAliasFor()

static loadAliasFor ( $class )
staticprivate

Loads the aliases for the given class.

Paramètres
string $class The class.
Renvoie
void
Depuis
3.8.0

Références $class.

◆ loadByAlias()

static loadByAlias ( $class )
static

Method to autoload classes that have been aliased using the registerAlias method.

Paramètres
string $class The fully qualified class name to autoload.
Renvoie
boolean True on success, false otherwise.
Depuis
3.2

Références $class.

◆ loadByPsr()

static loadByPsr ( $class )
static

Method to autoload classes that are namespaced to the PSR-4 standard.

Paramètres
string $class The fully qualified class name to autoload.
Renvoie
boolean True on success, false otherwise.
Depuis
4.0.0

Références $class, $className, $path, et null.

◆ loadByPsr4()

static loadByPsr4 ( $class )
static

Method to autoload classes that are namespaced to the PSR-4 standard.

Paramètres
string $class The fully qualified class name to autoload.
Renvoie
boolean True on success, false otherwise.
Depuis
3.7.0
Obsolète:
5.0 Use JLoader::loadByPsr instead

Références $class.

◆ register()

static register | ( | $class,
 |  | $path,
 |  | $force = true
 | ) |
static

Directly register a class to the autoload list.

Paramètres
string | $class | The class name to register.
string | $path | Full path to the file that holds the class to register.
boolean | $force | True to overwrite the autoload path value for the class if it already exists.
Renvoie
void
Depuis
1.7.0
Obsolète:
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Références $class, $classes, et $path.

Référencé par HTMLHelper\_(), LegacyFactory\createView(), RemoveOldFilesCommand\doExecute(), UpdateModel\finaliseUpgrade(), Installer\getAdapters(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), ActionlogsHelper\getContentTypeLink(), CacheController\getInstance(), RouteHelper\getItemRoute(), LanguagesHelper\getList(), PlgFinderCategories\index(), ListView\initializeView(), LegacyComponent\loadHelper(), PlgSystemLanguageFilter\onAfterDispatch(), CategoryModel\preprocessForm(), Config\register(), PlgSystemActionLogs\renderActionlogsExtensions(), Adapter\setAdapter(), et InstallerAdapter\setupScriptfile().

◆ registerAlias()

static registerAlias | ( | $alias,
 |  | $original,
 |  | $version = false
 | ) |
static

Offers the ability for "just in time" usage of class_alias(). You cannot overwrite an existing alias.

Paramètres
string | $alias | The alias name to register.
string | $original | The original class to alias.
string | boolean | $version | The version in which the alias will no longer be present.
Renvoie
boolean True if registration was successful. False if the alias already exists.
Depuis
3.2

Références $version.

◆ registerNamespace()

static registerNamespace | ( | $namespace,
 |  | $path,
 |  | $reset = false,
 |  | $prepend = false
 | ) |
static

Register a namespace to the autoloader. When loaded, namespace paths are searched in a "last in, first out" order.

Paramètres
string | $namespace | A case sensitive Namespace to register.
string | $path | A case sensitive absolute file path to the library root where classes of the given namespace can be found.
boolean | $reset | True to reset the namespace with only the given lookup path.
boolean | $prepend | If true, push the path to the beginning of the namespace lookup paths array.
Renvoie
void
Exceptions
RuntimeException
Depuis
3.1.4

Références $namespace, $path, et JPATH_ROOT.

◆ registerPrefix()

static registerPrefix | ( | $prefix,
 |  | $path,
 |  | $reset = false,
 |  | $prepend = false
 | ) |
static

Register a class prefix with lookup path. This will allow developers to register library packages with different class prefixes to the system autoloader. More than one lookup path may be registered for the same class prefix, but if this method is called with the reset flag set to true then any registered lookups for the given prefix will be overwritten with the current lookup path. When loaded, prefix paths are searched in a "last in, first out" order.

Paramètres
string | $prefix | The class prefix to register.
string | $path | Absolute file path to the library root where classes with the given prefix can be found.
boolean | $reset | True to reset the prefix with only the given lookup path.
boolean | $prepend | If true, push the path to the beginning of the prefix lookup paths array.
Renvoie
void
Exceptions
RuntimeException
Depuis
3.0.0

Références $path, $prefix, et JPATH_ROOT.

◆ setup()

static setup | ( | $enablePsr = true,
 |  | $enablePrefixes = true,
 |  | $enableClasses = true
 | ) |
static

Method to setup the autoloaders for the Joomla Platform. Since the SPL autoloaders are called in a queue we will add our explicit class-registration based loader first, then fall back on the autoloader based on conventions. This will allow people to register a class in a specific location and override platform libraries as was previously possible.

Paramètres
boolean | $enablePsr | True to enable autoloading based on PSR-0.
boolean | $enablePrefixes | True to enable prefix based class loading (needed to auto load the Joomla core).
boolean | $enableClasses | True to enable class map based class loading (needed to auto load the Joomla core).
Renvoie
void
Depuis
3.1.4

◆ stripFirstBackslash()

static stripFirstBackslash ( $class )
staticprivate

Strips the first backslash from the given class if present.

Paramètres
string $class The class to strip the first prefix from.
Renvoie
string The striped class name.
Depuis
3.8.0

Références $class.

Documentation des champs

◆ $classAliases

$classAliases = array()
staticprotected

◆ $classAliasesInverse

$classAliasesInverse = array()
staticprotected

◆ $classes

$classes = array()
staticprotected

◆ $deprecatedAliases

$deprecatedAliases = array()
staticprotected

◆ $extensionRootFolders

$extensionRootFolders = array()
staticprotected

◆ $imported

$imported = array()
staticprotected

◆ $namespaces

$namespaces = array()
staticprotected

◆ $prefixes

$prefixes = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • loader.php


Joomla CMS: Référence de la classe JNamespacePsr4Map

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe JNamespacePsr4Map

Fonctions membres publiques

exists ()
ensureMapFileExists ()
create ()
load ()

Fonctions membres protégées

writeNamespaceFile ($elements)

Attributs protégés

$file = JPATH_CACHE . '/autoload_psr4.php'

Fonctions membres privées

getNamespaces (string $type)

Attributs privés

$cachedMap = null

Description détaillée

Class JNamespacePsr4Map

Depuis
4.0.0

Documentation des fonctions membres

◆ create()

create ( )

Create the namespace file

Renvoie
boolean
Depuis
4.0.0

◆ ensureMapFileExists()

ensureMapFileExists ( )

Check if the namespace mapping file exists, if not create it

Renvoie
void
Depuis
4.0.0

◆ exists()

exists ( )

Check if the file exists

Renvoie
boolean
Depuis
4.0.0

◆ getNamespaces()

getNamespaces ( string $type )
private

Get an array of namespaces with their respective path for the given extension type.

Paramètres
string $type The extension type
Renvoie
array
Depuis
4.0.0

Références $baseDir, $count, $extension, $name, $namespace, $path, $type, $xml, elseif, JPATH_ADMINISTRATOR, JPATH_API, JPATH_LIBRARIES, JPATH_PLUGINS, et JPATH_SITE.

◆ load()

load ( )

Load the PSR4 file

Renvoie
boolean
Depuis
4.0.0

Références $loader, $namespace, $path, et JPATH_LIBRARIES.

◆ writeNamespaceFile()

writeNamespaceFile ( $elements )
protected

Write the Namespace mapping file

Paramètres
array $elements Array of elements
Renvoie
void
Depuis
4.0.0

Backup the current error_reporting level and set a new level

We do this because file_put_contents can raise a Warning if it cannot write the autoload_psr4.php file and this will output to the response BEFORE the session has started, causing the session start to fail and ultimately leading us to a 500 Internal Server Error page just because of the output warning, which we can safely ignore as we can use an in-memory autoload_psr4 map temporarily, and display real errors later.

Références $content, $namespace, et $path.

Documentation des champs

◆ $cachedMap

$cachedMap = null
private

◆ $file

$file = JPATH_CACHE . '/autoload_psr4.php'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • libraries/namespacemap.php


Joomla CMS: Référence de la classe JoomlaInstallerScript

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe JoomlaInstallerScript

Fonctions membres publiques

preflight ($action, $installer)
update ($installer)
deleteUnexistingFiles ($dryRun=false, $suppressOutput=false)
convertTablesToUtf8mb4 ($doDbFixMsg=false)
postflight ($action, $installer)

Fonctions membres protégées

clearStatsCache ()
updateDatabase ()
updateDatabaseMysql ()
uninstallEosPlugin ()
updateManifestCaches ()
fixFilenameCasing ()
moveRemainingTemplateFiles ()
fixTemplateMode ()
addUserAuthProviderColumn ()

Attributs protégés

$fromVersion = null

Fonctions membres privées

dropUtf8ConversionTable ()
contactItems (Table $tableItem)
finderItems (Table $tableItem)
updateContentTypes ()

Description détaillée

Script file of Joomla CMS

Depuis
1.6.4

Documentation des fonctions membres

◆ addUserAuthProviderColumn()

addUserAuthProviderColumn ( )
protected

Add the user Auth Provider Column as it could be present from 3.10 already

Renvoie
void
Depuis
4.1.1

Références $db, $fields, $query, et Joomla\DI\getContainer().

◆ clearStatsCache()

clearStatsCache ( )
protected

Method to clear our stats plugin cache to ensure we get fresh data on Joomla Update

Renvoie
void
Depuis
3.5

Références $db, $params, $query, et Joomla\CMS\MVC\Model\getDbo().

◆ contactItems()

contactItems ( Table $tableItem )
private

Prepare the contact menu items

Renvoie
array Menu items
Depuis
4.0.0

Références Table\load(), et null.

◆ convertTablesToUtf8mb4()

convertTablesToUtf8mb4 ( $doDbFixMsg = false )

Converts the site's database tables to support UTF-8 Multibyte.

Paramètres
boolean $doDbFixMsg Flag if message to be shown to check db fix
Renvoie
void
Depuis
3.5

Références $db, $rows, Factory\getApplication(), Joomla\CMS\MVC\Model\getDbo(), et JPATH_ROOT.

◆ deleteUnexistingFiles()

deleteUnexistingFiles | ( | $dryRun = false,
 |  | $suppressOutput = false
 | ) |

Delete files that should not exist

Paramètres
bool | $dryRun | If set to true, will not actually delete files, but just report their status for use in CLI
bool | $suppressOutput | Set to true to suppress echoing any errors, and just return the $status array
Renvoie
array

Références $folder, et JPATH_ROOT.

◆ dropUtf8ConversionTable()

dropUtf8ConversionTable ( )
private

This method drops the #__utf8_conversion table

Renvoie
boolean True on success
Depuis
4.0.0

Références $db, et Joomla\CMS\MVC\Model\getDbo().

◆ finderItems()

finderItems ( Table $tableItem )
private

Prepare the finder menu items

Renvoie
array Menu items
Depuis
4.0.0

Références Table\load(), et null.

◆ fixFilenameCasing()

fixFilenameCasing ( )
protected

Renames or removes incorrectly cased files.

Renvoie
void
Depuis
3.9.25

Références JPATH_ROOT.

◆ fixTemplateMode()

fixTemplateMode ( )
protected

Ensure the core templates are correctly moved to the new mode.

Renvoie
void
Depuis
4.1.0

Références $clientId, $db, $query, $template, et Joomla\DI\getContainer().

◆ moveRemainingTemplateFiles()

moveRemainingTemplateFiles ( )
protected

Move core template (s)css or js or image files which are left after deleting obsolete core files to the right place in media folder.

Renvoie
void
Depuis
4.1.0

Références JPATH_ROOT.

◆ postflight()

postflight | ( | $action,
 |  | $installer
 | ) |

Called after any type of action

Paramètres
string | $action | Which action is happening (install|uninstall|discover_install|update)
Installer | $installer | The class calling this method
Renvoie
boolean True on success
Depuis
4.0.0

Références $db, Joomla\CMS\MVC\Model\getDbo(), et JPATH_ADMINISTRATOR.

◆ preflight()

preflight | ( | $action,
 |  | $installer
 | ) |

Function to act prior to installation process begins

Paramètres
string | $action | Which action is happening (install|uninstall|discover_install|update)
Installer | $installer | The class calling this method
Renvoie
boolean True on success
Depuis
3.7.0

◆ uninstallEosPlugin()

uninstallEosPlugin ( )
protected

Uninstall the 3.10 EOS plugin

Renvoie
void
Depuis
4.0.0

Références $db, et Joomla\CMS\MVC\Model\getDbo().

◆ update()

update ( $installer )

Method to update Joomla!

Paramètres
Installer $installer The class calling this method
Renvoie
void

Références $options.

◆ updateContentTypes()

updateContentTypes ( )
private

Updates content type table classes.

Renvoie
void
Depuis
4.0.0

Références $component, $db, $query, et Joomla\CMS\MVC\Model\getDbo().

◆ updateDatabase()

updateDatabase ( )
protected

Method to update Database

Renvoie
void

Références Joomla\CMS\MVC\Model\getDbo().

◆ updateDatabaseMysql()

updateDatabaseMysql ( )
protected

Method to update MySQL Database

Renvoie
void

Références $db, $result, $results, et Joomla\CMS\MVC\Model\getDbo().

◆ updateManifestCaches()

updateManifestCaches ( )
protected

Update the manifest caches

Renvoie
void

Références $db, $extension, $query, Joomla\CMS\MVC\Model\getDbo(), et JPATH_ROOT.

Documentation des champs

◆ $fromVersion

$fromVersion = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • script.php


Joomla CMS: Référence de la classe MediaHelper

Fonctions membres publiques statiques
Référence de la classe MediaHelper

Fonctions membres publiques statiques

static getContentTypeLink ($contentType, $id, CMSObject $mediaObject)

Description détaillée

Media helper class.

Depuis
1.6

Documentation des fonctions membres

◆ getContentTypeLink()

static getContentTypeLink | ( |  | $contentType,
 |  |  | $id,
 |  | CMSObject | $mediaObject
 | ) |  |
static

Generates the URL to the object in the action logs component

Paramètres
string | $contentType | The content type
integer | $id | The integer id
CMSObject | $mediaObject | The media object being uploaded
Renvoie
string The link for the action log
Depuis
3.9.27

Références $link, et CMSObject\get().

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_media/helpers/media.php


Joomla CMS: Référence de la classe MenusHelper

Référence de la classe MenusHelper
+ Graphe d'héritage de MenusHelper:
MenusHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de MenusHelper
static | getLinkKey ($request)
static | getMenuTypes ($clientId=0)
static | getMenuLinks ($menuType=null, $parentId=0, $mode=0, $published=array(), $languages=array(), $clientId=0)
static | getAssociations ($pk)
static | getMenuItems ($menutype, $enabledOnly=false, $exclude=array())
static | installPreset ($preset, $menutype)
static | addPreset ($name, $title, $path, $replace=true)
static | getPresets ()
static | loadPreset ($name, $fallback=true, $parent=null)
static | resolveAlias (&$item)
static | preprocess ($item)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)
- Fonctions membres protégées statiques hérités de MenusHelper
static | loadXml ($elements, $parent, $replace=array())
static | parseXmlNode ($node, $replace=array())
- Attributs protégés statiques hérités de MenusHelper
static | $_filter = array('option', 'view', 'layout')
static | $presets = null

Description détaillée

Menus component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_menus/helpers/menus.php


Joomla CMS: Référence de la classe ModulesHelper

Référence de la classe ModulesHelper
+ Graphe d'héritage de ModulesHelper:
ModulesHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ModulesHelper
static | getStateOptions ()
static | getClientOptions ()
static | getPositions ($clientId, $editPositions=false)
static | getTemplates ($clientId=0, $state='', $template='')
static | getModules ($clientId)
static | getAssignmentOptions ($clientId)
static | getTranslatedModulePosition ($clientId, $template, $position)
static | isTranslatedText ($langKey, $text)
static | createOption ($value='', $text='')
static | createOptionGroup ($label='', $options=array())

Description détaillée

Modules component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_modules/helpers/modules.php


Joomla CMS: Référence de la classe NewsfeedsHelper

Référence de la classe NewsfeedsHelper
+ Graphe d'héritage de NewsfeedsHelper:
NewsfeedsHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de NewsfeedsHelper
static | countItems (&$items)
static | countTagItems (&$items, $extension)
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)
- Attributs publics statiques hérités de NewsfeedsHelper
static | $extension = 'com_newsfeeds'

Description détaillée

Newsfeeds component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_newsfeeds/helpers/newsfeeds.php


Joomla CMS: Référence de la classe NewsfeedsHelperRoute

Référence de la classe NewsfeedsHelperRoute
+ Graphe d'héritage de NewsfeedsHelperRoute:
RouteHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RouteHelper
static | getNewsfeedRoute ($id, $catid, $language=0)
static | getCategoryRoute ($catid, $language=0)

Description détaillée

Newsfeeds Component Route Helper

Depuis
1.5
Obsolète:
5.0 Use Joomla instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_newsfeeds/helpers/route.php


Joomla CMS: Référence de la classe Normalizer

Champs de données
Référence de la classe Normalizer
+ Graphe d'héritage de Normalizer:
Normalizer

Champs de données

const | NONE = 2
const | FORM_D = 4
const | FORM_KD = 8
const | FORM_C = 16
const | FORM_KC = 32
const | NFD = 4
const | NFKD = 8
const | NFC = 16
const | NFKC = 32
- Champs de données hérités de Normalizer
const | FORM_D = \Normalizer::FORM_D
const | FORM_KD = \Normalizer::FORM_KD
const | FORM_C = \Normalizer::FORM_C
const | FORM_KC = \Normalizer::FORM_KC
const | NFD = \Normalizer::NFD
const | NFKD = \Normalizer::NFKD
const | NFC = \Normalizer::NFC
const | NFKC = \Normalizer::NFKC

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de Normalizer
static | isNormalized (string $s, int $form=self::FORM_C)
static | normalize (string $s, int $form=self::FORM_C)
- Attributs publics statiques hérités de Normalizer
static | xD0 => 2, "\xE0" => 3, "\xF0" => 4]

Documentation des champs

◆ FORM_C

const FORM_C = 16

◆ FORM_D

const FORM_D = 4

◆ FORM_KC

const FORM_KC = 32

◆ FORM_KD

const FORM_KD = 8

◆ NFC

const NFC = 16

Référencé par UnicodeString\endsWith(), UnicodeString\equalsTo(), UnicodeString\indexOf(), UnicodeString\indexOfLast(), et UnicodeString\startsWith().

◆ NFD

const NFD = 4

Référencé par UnicodeString\endsWith(), UnicodeString\equalsTo(), UnicodeString\indexOf(), UnicodeString\indexOfLast(), Iconv\mapFromUtf8(), et UnicodeString\startsWith().

◆ NFKC

const NFKC = 32

◆ NFKD

const NFKD = 8

◆ NONE

const NONE = 2
Obsolète:
since ICU 56 and removed in PHP 8

Référencé par normalize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Resources/stubs/Normalizer.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Compat

Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Compat
+ Graphe d'héritage de ParagonIE_Sodium_Compat:
Compat

Fonctions membres publiques statiques

static | add (&$val, $addv)
static | bin2hex ($string)
static | compare ($left, $right)
static | crypto_aead_aes256gcm_is_available ()
static | crypto_aead_aes256gcm_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_aes256gcm_keygen ()
static | crypto_aead_chacha20poly1305_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_ietf_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_keygen ()
static | crypto_aead_chacha20poly1305_ietf_encrypt ( $plaintext='', $assocData='', $nonce='', $key='')
static | crypto_aead_chacha20poly1305_ietf_keygen ()
static | crypto_aead_xchacha20poly1305_ietf_decrypt ( $ciphertext='', $assocData='', $nonce='', $key='', $dontFallback=false)
static | crypto_aead_xchacha20poly1305_ietf_encrypt ( $plaintext='', $assocData='', $nonce='', $key='', $dontFallback=false)
static | crypto_aead_xchacha20poly1305_ietf_keygen ()
static | crypto_auth ($message, $key)
static | crypto_auth_keygen ()
static | crypto_auth_verify ($mac, $message, $key)
static | crypto_box ($plaintext, $nonce, $keypair)
static | crypto_box_seal ($plaintext, $publicKey)
static | crypto_box_seal_open ($ciphertext, $keypair)
static | crypto_box_keypair ()
static | crypto_box_keypair_from_secretkey_and_publickey ($secretKey, $publicKey)
static | crypto_box_open ($ciphertext, $nonce, $keypair)
static | crypto_box_publickey ($keypair)
static | crypto_box_publickey_from_secretkey ($secretKey)
static | crypto_box_secretkey ($keypair)
static | crypto_box_seed_keypair ($seed)
static | crypto_generichash ($message, $key='', $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_final (&$ctx, $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_init ($key='', $length=self::CRYPTO_GENERICHASH_BYTES)
static | crypto_generichash_init_salt_personal ( $key='', $length=self::CRYPTO_GENERICHASH_BYTES, $salt='', $personal='')
static | crypto_generichash_update (&$ctx, $message)
static | crypto_generichash_keygen ()
static | crypto_kdf_derive_from_key ( $subkey_len, $subkey_id, $context, $key)
static | crypto_kdf_keygen ()
static | crypto_kx ($my_secret, $their_public, $client_public, $server_public, $dontFallback=false)
static | crypto_kx_seed_keypair ($seed)
static | crypto_kx_keypair ()
static | crypto_kx_client_session_keys ($keypair, $serverPublicKey)
static | crypto_kx_server_session_keys ($keypair, $clientPublicKey)
static | crypto_kx_secretkey ($kp)
static | crypto_kx_publickey ($kp)
static | crypto_pwhash ($outlen, $passwd, $salt, $opslimit, $memlimit, $alg=null)
static | crypto_pwhash_is_available ()
static | crypto_pwhash_str ($passwd, $opslimit, $memlimit)
static | crypto_pwhash_str_verify ($passwd, $hash)
static | crypto_pwhash_scryptsalsa208sha256 ($outlen, $passwd, $salt, $opslimit, $memlimit)
static | crypto_pwhash_scryptsalsa208sha256_is_available ()
static | crypto_pwhash_scryptsalsa208sha256_str ($passwd, $opslimit, $memlimit)
static | crypto_pwhash_scryptsalsa208sha256_str_verify ($passwd, $hash)
static | crypto_scalarmult ($secretKey, $publicKey)
static | crypto_scalarmult_base ($secretKey)
static | crypto_secretbox ($plaintext, $nonce, $key)
static | crypto_secretbox_open ($ciphertext, $nonce, $key)
static | crypto_secretbox_keygen ()
static | crypto_secretbox_xchacha20poly1305 ($plaintext, $nonce, $key)
static | crypto_secretbox_xchacha20poly1305_open ($ciphertext, $nonce, $key)
static | crypto_secretstream_xchacha20poly1305_init_push ($key)
static | crypto_secretstream_xchacha20poly1305_init_pull ($header, $key)
static | crypto_secretstream_xchacha20poly1305_push (&$state, $msg, $aad='', $tag=0)
static | crypto_secretstream_xchacha20poly1305_pull (&$state, $msg, $aad='')
static | crypto_secretstream_xchacha20poly1305_keygen ()
static | crypto_secretstream_xchacha20poly1305_rekey (&$state)
static | crypto_shorthash ($message, $key)
static | crypto_shorthash_keygen ()
static | crypto_sign ($message, $secretKey)
static | crypto_sign_open ($signedMessage, $publicKey)
static | crypto_sign_keypair ()
static | crypto_sign_keypair_from_secretkey_and_publickey ($sk, $pk)
static | crypto_sign_seed_keypair ($seed)
static | crypto_sign_publickey ($keypair)
static | crypto_sign_publickey_from_secretkey ($secretKey)
static | crypto_sign_secretkey ($keypair)
static | crypto_sign_detached ($message, $secretKey)
static | crypto_sign_verify_detached ($signature, $message, $publicKey)
static | crypto_sign_ed25519_pk_to_curve25519 ($pk)
static | crypto_sign_ed25519_sk_to_curve25519 ($sk)
static | crypto_stream ($len, $nonce, $key)
static | crypto_stream_xor ($message, $nonce, $key)
static | crypto_stream_keygen ()
static | crypto_stream_xchacha20 ($len, $nonce, $key, $dontFallback=false)
static | crypto_stream_xchacha20_xor ($message, $nonce, $key, $dontFallback=false)
static | crypto_stream_xchacha20_keygen ()
static | hex2bin ($string)
static | increment (&$var)
static | is_zero ($str)
static | library_version_major ()
static | library_version_minor ()
static | memzero (&$var)
static | unpad ($padded, $blockSize, $dontFallback=false)
static | polyfill_is_fast ()
static | randombytes_uniform ($range)
static | randombytes_random16 ()
static | ristretto255_is_valid_point ($p, $dontFallback=false)
static | ristretto255_add ($p, $q, $dontFallback=false)
static | ristretto255_sub ($p, $q, $dontFallback=false)
static | ristretto255_from_hash ($r, $dontFallback=false)
static | ristretto255_random ($dontFallback=false)
static | ristretto255_scalar_random ($dontFallback=false)
static | ristretto255_scalar_invert ($s, $dontFallback=false)
static | ristretto255_scalar_negate ($s, $dontFallback=false)
static | ristretto255_scalar_complement ($s, $dontFallback=false)
static | ristretto255_scalar_add ($x, $y, $dontFallback=false)
static | ristretto255_scalar_sub ($x, $y, $dontFallback=false)
static | ristretto255_scalar_mul ($x, $y, $dontFallback=false)
static | scalarmult_ristretto255 ($n, $p, $dontFallback=false)
static | scalarmult_ristretto255_base ($n, $dontFallback=false)
static | ristretto255_scalar_reduce ($s, $dontFallback=false)
static | sub (&$val, $addv)
static | version_string ()

Champs de données

const | LIBRARY_MAJOR_VERSION = 9
const | LIBRARY_MINOR_VERSION = 1
const | LIBRARY_VERSION_MAJOR = 9
const | LIBRARY_VERSION_MINOR = 1
const | VERSION_STRING = 'polyfill-1.0.8'
const | BASE64_VARIANT_ORIGINAL = 1
const | BASE64_VARIANT_ORIGINAL_NO_PADDING = 3
const | BASE64_VARIANT_URLSAFE = 5
const | BASE64_VARIANT_URLSAFE_NO_PADDING = 7
const | CRYPTO_AEAD_AES256GCM_KEYBYTES = 32
const | CRYPTO_AEAD_AES256GCM_NSECBYTES = 0
const | CRYPTO_AEAD_AES256GCM_NPUBBYTES = 12
const | CRYPTO_AEAD_AES256GCM_ABYTES = 16
const | CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = 32
const | CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = 0
const | CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = 8
const | CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = 16
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = 32
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = 0
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = 12
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = 16
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES = 32
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES = 0
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES = 24
const | CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES = 16
const | CRYPTO_AUTH_BYTES = 32
const | CRYPTO_AUTH_KEYBYTES = 32
const | CRYPTO_BOX_SEALBYTES = 16
const | CRYPTO_BOX_SECRETKEYBYTES = 32
const | CRYPTO_BOX_PUBLICKEYBYTES = 32
const | CRYPTO_BOX_KEYPAIRBYTES = 64
const | CRYPTO_BOX_MACBYTES = 16
const | CRYPTO_BOX_NONCEBYTES = 24
const | CRYPTO_BOX_SEEDBYTES = 32
const | CRYPTO_CORE_RISTRETTO255_BYTES = 32
const | CRYPTO_CORE_RISTRETTO255_SCALARBYTES = 32
const | CRYPTO_CORE_RISTRETTO255_HASHBYTES = 64
const | CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES = 64
const | CRYPTO_KDF_BYTES_MIN = 16
const | CRYPTO_KDF_BYTES_MAX = 64
const | CRYPTO_KDF_CONTEXTBYTES = 8
const | CRYPTO_KDF_KEYBYTES = 32
const | CRYPTO_KX_BYTES = 32
const | CRYPTO_KX_PRIMITIVE = 'x25519blake2b'
const | CRYPTO_KX_SEEDBYTES = 32
const | CRYPTO_KX_KEYPAIRBYTES = 64
const | CRYPTO_KX_PUBLICKEYBYTES = 32
const | CRYPTO_KX_SECRETKEYBYTES = 32
const | CRYPTO_KX_SESSIONKEYBYTES = 32
const | CRYPTO_GENERICHASH_BYTES = 32
const | CRYPTO_GENERICHASH_BYTES_MIN = 16
const | CRYPTO_GENERICHASH_BYTES_MAX = 64
const | CRYPTO_GENERICHASH_KEYBYTES = 32
const | CRYPTO_GENERICHASH_KEYBYTES_MIN = 16
const | CRYPTO_GENERICHASH_KEYBYTES_MAX = 64
const | CRYPTO_PWHASH_SALTBYTES = 16
const | CRYPTO_PWHASH_STRPREFIX = '$argon2id$'
const | CRYPTO_PWHASH_ALG_ARGON2I13 = 1
const | CRYPTO_PWHASH_ALG_ARGON2ID13 = 2
const | CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE = 33554432
const | CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE = 4
const | CRYPTO_PWHASH_MEMLIMIT_MODERATE = 134217728
const | CRYPTO_PWHASH_OPSLIMIT_MODERATE = 6
const | CRYPTO_PWHASH_MEMLIMIT_SENSITIVE = 536870912
const | CRYPTO_PWHASH_OPSLIMIT_SENSITIVE = 8
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES = 32
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX = '$7$'
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE = 534288
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE = 16777216
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE = 33554432
const | CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE = 1073741824
const | CRYPTO_SCALARMULT_BYTES = 32
const | CRYPTO_SCALARMULT_SCALARBYTES = 32
const | CRYPTO_SCALARMULT_RISTRETTO255_BYTES = 32
const | CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES = 32
const | CRYPTO_SHORTHASH_BYTES = 8
const | CRYPTO_SHORTHASH_KEYBYTES = 16
const | CRYPTO_SECRETBOX_KEYBYTES = 32
const | CRYPTO_SECRETBOX_MACBYTES = 16
const | CRYPTO_SECRETBOX_NONCEBYTES = 24
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES = 17
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES = 24
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES = 32
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH = 0
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL = 1
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY = 2
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL = 3
const | CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX = 0x3fffffff80
const | CRYPTO_SIGN_BYTES = 64
const | CRYPTO_SIGN_SEEDBYTES = 32
const | CRYPTO_SIGN_PUBLICKEYBYTES = 32
const | CRYPTO_SIGN_SECRETKEYBYTES = 64
const | CRYPTO_SIGN_KEYPAIRBYTES = 96
const | CRYPTO_STREAM_KEYBYTES = 32
const | CRYPTO_STREAM_NONCEBYTES = 24
const | CRYPTO_STREAM_XCHACHA20_KEYBYTES = 32
const | CRYPTO_STREAM_XCHACHA20_NONCEBYTES = 24

Attributs publics statiques

static | $disableFallbackForUnitTests = false
static | $fastMult = false

Fonctions membres protégées statiques

static | use_fallback ($sodium_func_name='')
static | useNewSodiumAPI ()

Description détaillée

Libsodium compatibility layer

This is the only class you should be interfacing with, as a user of sodium_compat.

If the PHP extension for libsodium is installed, it will always use that instead of our implementations. You get better performance and stronger guarantees against side-channels that way.

However, if your users don't have the PHP extension installed, we offer a compatible interface here. It will give you the correct results as if the PHP extension was installed. It won't be as fast, of course.

CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION *

  • Until audited, this is probably not safe to use! DANGER WILL ROBINSON *
  • CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION * CAUTION *

Documentation des fonctions membres

◆ add()

static add | ( | & | $val,
 |  |  | $addv
 | ) |  |
static

Add two numbers (little-endian unsigned), storing the value in the first parameter.

This mutates $val.

Paramètres
string | $val
string | $addv
Renvoie
void
Exceptions
SodiumException

Références $c, $i, $val, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Core_Ed25519\scalar_add().

◆ bin2hex()

static bin2hex ( $string )
static

Cache-timing-safe implementation of bin2hex().

Paramètres
string $string A string (probably raw binary)
Renvoie
string A hexadecimal-encoded string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ compare()

static compare | ( | $left,
 |  | $right
 | ) |
static

Compare two strings, in constant-time. Compared to memcmp(), compare() is more useful for sorting.

Paramètres
string | $left | The left operand; must be a string
string | $right | The right operand; must be a string
Renvoie
int If < 0 if the left operand is less than the right If = 0 if both strings are equal If > 0 if the right operand is less than the left
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\compare(), et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_aead_aes256gcm_encrypt()

static crypto_aead_aes256gcm_encrypt | ( | $plaintext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Authenticated Encryption with Associated Data: Encryption

Algorithm: AES-256-GCM

Paramètres
string | $plaintext | Message to be encrypted
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
Renvoie
string Ciphertext with a 16-byte GCM message authentication code appended
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_AEAD_AES256GCM_KEYBYTES, Sodium\CRYPTO_AEAD_AES256GCM_NPUBBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_aes256gcm_is_available()

static crypto_aead_aes256gcm_is_available ( )
static

Is AES-256-GCM even available to use?

Renvoie
bool -suppress UndefinedFunction -suppress MixedInferredReturnType -suppress MixedReturnStatement

◆ crypto_aead_aes256gcm_keygen()

static crypto_aead_aes256gcm_keygen ( )
static

Return a secure random key for use with the AES-256-GCM symmetric AEAD interface.

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_AEAD_AES256GCM_KEYBYTES.

◆ crypto_aead_chacha20poly1305_decrypt()

static crypto_aead_chacha20poly1305_decrypt | ( | $ciphertext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Authenticated Encryption with Associated Data: Decryption

Algorithm: ChaCha20-Poly1305

This mode uses a 64-bit random nonce with a 64-bit counter. IETF mode uses a 96-bit random nonce with a 32-bit counter.

Paramètres
string | $ciphertext | Encrypted message (with Poly1305 MAC appended)
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
Renvoie
string The original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références $key, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_chacha20poly1305_encrypt()

static crypto_aead_chacha20poly1305_encrypt | ( | $plaintext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Authenticated Encryption with Associated Data

Algorithm: ChaCha20-Poly1305

This mode uses a 64-bit random nonce with a 64-bit counter. IETF mode uses a 96-bit random nonce with a 32-bit counter.

Paramètres
string | $plaintext | Message to be encrypted
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
Renvoie
string Ciphertext with a 16-byte Poly1305 message authentication code appended
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_chacha20poly1305_ietf_decrypt()

static crypto_aead_chacha20poly1305_ietf_decrypt | ( | $ciphertext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Authenticated Encryption with Associated Data: Decryption

Algorithm: ChaCha20-Poly1305

IETF mode uses a 96-bit random nonce with a 32-bit counter. Regular mode uses a 64-bit random nonce with a 64-bit counter.

Paramètres
string | $ciphertext | Encrypted message (with Poly1305 MAC appended)
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 12 bytes
string | $key | Encryption key
Renvoie
string The original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références $key, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_chacha20poly1305_ietf_encrypt()

static crypto_aead_chacha20poly1305_ietf_encrypt | ( | $plaintext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Authenticated Encryption with Associated Data

Algorithm: ChaCha20-Poly1305

IETF mode uses a 96-bit random nonce with a 32-bit counter. Regular mode uses a 64-bit random nonce with a 64-bit counter.

Paramètres
string | $plaintext | Message to be encrypted
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
Renvoie
string Ciphertext with a 16-byte Poly1305 message authentication code appended
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES, Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_chacha20poly1305_ietf_keygen()

static crypto_aead_chacha20poly1305_ietf_keygen ( )
static

Return a secure random key for use with the ChaCha20-Poly1305 symmetric AEAD interface. (IETF version)

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES.

◆ crypto_aead_chacha20poly1305_keygen()

static crypto_aead_chacha20poly1305_keygen ( )
static

Return a secure random key for use with the ChaCha20-Poly1305 symmetric AEAD interface.

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES.

◆ crypto_aead_xchacha20poly1305_ietf_decrypt()

static crypto_aead_xchacha20poly1305_ietf_decrypt | ( | $ciphertext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = '',
 |  | $dontFallback = false
 | ) |
static

Authenticated Encryption with Associated Data: Decryption

Algorithm: XChaCha20-Poly1305

This mode uses a 64-bit random nonce with a 64-bit counter. IETF mode uses a 96-bit random nonce with a 32-bit counter.

Paramètres
string | $ciphertext | Encrypted message (with Poly1305 MAC appended)
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
bool | $dontFallback | Don't fallback to ext/sodium
Renvoie
string|bool The original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_xchacha20poly1305_ietf_encrypt()

static crypto_aead_xchacha20poly1305_ietf_encrypt | ( | $plaintext = '',
 |  | $assocData = '',
 |  | $nonce = '',
 |  | $key = '',
 |  | $dontFallback = false
 | ) |
static

Authenticated Encryption with Associated Data

Algorithm: XChaCha20-Poly1305

This mode uses a 64-bit random nonce with a 64-bit counter. IETF mode uses a 96-bit random nonce with a 32-bit counter.

Paramètres
string | $plaintext | Message to be encrypted
string | $assocData | Authenticated Associated Data (unencrypted)
string | $nonce | Number to be used only Once; must be 8 bytes
string | $key | Encryption key
bool | $dontFallback | Don't fallback to ext/sodium
Renvoie
string Ciphertext with a 16-byte Poly1305 message authentication code appended
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_aead_xchacha20poly1305_ietf_keygen()

static crypto_aead_xchacha20poly1305_ietf_keygen ( )
static

Return a secure random key for use with the XChaCha20-Poly1305 symmetric AEAD interface.

Renvoie
string
Exceptions
Exception
Error

◆ crypto_auth()

static crypto_auth | ( | $message,
 |  | $key
 | ) |
static

Authenticate a message. Uses symmetric-key cryptography.

Algorithm: HMAC-SHA512-256. Which is HMAC-SHA-512 truncated to 256 bits. Not to be confused with HMAC-SHA-512/256 which would use the SHA-512/256 hash function (uses different initial parameters but still truncates to 256 bits to sidestep length-extension attacks).

Paramètres
string | $message | Message to be authenticated
string | $key | Symmetric authentication key
Renvoie
string Message authentication code
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, $message, ParagonIE_Sodium_Crypto32\auth(), ParagonIE_Sodium_Crypto\auth(), Sodium\CRYPTO_AUTH_KEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_auth_keygen()

static crypto_auth_keygen ( )
static
Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_AUTH_KEYBYTES.

◆ crypto_auth_verify()

static crypto_auth_verify | ( | $mac,
 |  | $message,
 |  | $key
 | ) |
static

Verify the MAC of a message previously authenticated with crypto_auth.

Paramètres
string | $mac | Message authentication code
string | $message | Message whose authenticity you are attempting to verify (with a given MAC and key)
string | $key | Symmetric authentication key
Renvoie
bool TRUE if authenticated, FALSE otherwise
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, $message, ParagonIE_Sodium_Crypto\auth_verify(), ParagonIE_Sodium_Crypto32\auth_verify(), Sodium\CRYPTO_AUTH_BYTES, Sodium\CRYPTO_AUTH_KEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_box()

static crypto_box | ( | $plaintext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

Authenticated asymmetric-key encryption. Both the sender and recipient may decrypt messages.

Algorithm: X25519-XSalsa20-Poly1305. X25519: Elliptic-Curve Diffie Hellman over Curve25519. XSalsa20: Extended-nonce variant of salsa20. Poyl1305: Polynomial MAC for one-time message authentication.

Paramètres
string | $plaintext | The message to be encrypted
string | $nonce | A Number to only be used Once; must be 24 bytes
string | $keypair | Your secret key and your recipient's public key
Renvoie
string Ciphertext with 16-byte Poly1305 MAC
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box(), ParagonIE_Sodium_Crypto\box(), Sodium\CRYPTO_BOX_KEYPAIRBYTES, Sodium\CRYPTO_BOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par SodiumCipher\encrypt().

◆ crypto_box_keypair()

static crypto_box_keypair ( )
static

Generate a new random X25519 keypair.

Renvoie
string A 64-byte string; the first 32 are your secret key, while the last 32 are your public key. crypto_box_secretkey() and crypto_box_publickey() exist to separate them so you don't accidentally get them mixed up!
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box_keypair(), et ParagonIE_Sodium_Crypto\box_keypair().

Référencé par SodiumCipher\generateKey().

◆ crypto_box_keypair_from_secretkey_and_publickey()

static crypto_box_keypair_from_secretkey_and_publickey | ( | $secretKey,
 |  | $publicKey
 | ) |
static

Combine two keys into a keypair for use in library methods that expect a keypair. This doesn't necessarily have to be the same person's keys.

Paramètres
string | $secretKey | Secret key
string | $publicKey | Public key
Renvoie
string Keypair
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Crypto\box_keypair_from_secretkey_and_publickey(), Sodium\CRYPTO_BOX_PUBLICKEYBYTES, Sodium\CRYPTO_BOX_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par SodiumCipher\decrypt(), et SodiumCipher\encrypt().

◆ crypto_box_open()

static crypto_box_open | ( | $ciphertext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

Decrypt a message previously encrypted with crypto_box().

Paramètres
string | $ciphertext | Encrypted message
string | $nonce | Number to only be used Once; must be 24 bytes
string | $keypair | Your secret key and the sender's public key
Renvoie
string The original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références ParagonIE_Sodium_Crypto32\box_open(), ParagonIE_Sodium_Crypto\box_open(), Sodium\CRYPTO_BOX_KEYPAIRBYTES, Sodium\CRYPTO_BOX_MACBYTES, Sodium\CRYPTO_BOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par SodiumCipher\decrypt().

◆ crypto_box_publickey()

static crypto_box_publickey ( $keypair )
static

Extract the public key from a crypto_box keypair.

Paramètres
string $keypair Keypair containing secret and public key
Renvoie
string Your crypto_box public key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box_publickey(), ParagonIE_Sodium_Crypto\box_publickey(), Sodium\CRYPTO_BOX_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par SodiumCipher\generateKey().

◆ crypto_box_publickey_from_secretkey()

static crypto_box_publickey_from_secretkey ( $secretKey )
static

Calculate the X25519 public key from a given X25519 secret key.

Paramètres
string $secretKey Any X25519 secret key
Renvoie
string The corresponding X25519 public key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box_publickey_from_secretkey(), ParagonIE_Sodium_Crypto\box_publickey_from_secretkey(), Sodium\CRYPTO_BOX_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_box_seal()

static crypto_box_seal | ( | $plaintext,
 |  | $publicKey
 | ) |
static

Anonymous public-key encryption. Only the recipient may decrypt messages.

Algorithm: X25519-XSalsa20-Poly1305, as with crypto_box. The sender's X25519 keypair is ephemeral. Nonce is generated from the BLAKE2b hash of both public keys.

This provides ciphertext integrity.

Paramètres
string | $plaintext | Message to be sealed
string | $publicKey | Your recipient's public key
Renvoie
string Sealed message that only your recipient can decrypt
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_BOX_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_box_seal_open()

static crypto_box_seal_open | ( | $ciphertext,
 |  | $keypair
 | ) |
static

Opens a message encrypted with crypto_box_seal(). Requires the recipient's keypair (sk || pk) to decrypt successfully.

This validates ciphertext integrity.

Paramètres
string | $ciphertext | Sealed message to be opened
string | $keypair | Your crypto_box keypair
Renvoie
string The original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références Sodium\CRYPTO_BOX_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_box_secretkey()

static crypto_box_secretkey ( $keypair )
static

Extract the secret key from a crypto_box keypair.

Paramètres
string $keypair
Renvoie
string Your crypto_box secret key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Crypto32\box_secretkey(), ParagonIE_Sodium_Crypto\box_secretkey(), Sodium\CRYPTO_BOX_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par SodiumCipher\generateKey().

◆ crypto_box_seed_keypair()

static crypto_box_seed_keypair ( $seed )
static

Generate an X25519 keypair from a seed.

Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress UndefinedFunction

Références ParagonIE_Sodium_Crypto32\box_seed_keypair(), ParagonIE_Sodium_Crypto\box_seed_keypair(), et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_generichash()

static crypto_generichash | ( | $message,
 |  | $key = '',
 |  | $length = self::CRYPTO_GENERICHASH_BYTES
 | ) |
static

Calculates a BLAKE2b hash, with an optional key.

Paramètres
string | $message | The message to be hashed
string | null | $key | If specified, must be a string between 16 and 64 bytes long
int | $length | Output length in bytes; must be between 16 and 64 (default = 32)
Renvoie
string Raw binary
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, $message, Sodium\CRYPTO_GENERICHASH_KEYBYTES_MAX, Sodium\CRYPTO_GENERICHASH_KEYBYTES_MIN, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Crypto\keyExchange().

◆ crypto_generichash_final()

static crypto_generichash_final | ( | & | $ctx,
 |  |  | $length = self::CRYPTO_GENERICHASH_BYTES
 | ) |  |
static

Get the final BLAKE2b hash output for a given context.

Paramètres
string | $ctx | BLAKE2 hashing context. Generated by crypto_generichash_init().
int | $length | Hash output size.
Renvoie
string Final BLAKE2b hash.
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress ReferenceConstraintViolation -suppress ConflictingReferenceConstraint

Références $result, et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_generichash_init()

static crypto_generichash_init | ( | $key = '',
 |  | $length = self::CRYPTO_GENERICHASH_BYTES
 | ) |
static

Initialize a BLAKE2b hashing context, for use in a streaming interface.

Paramètres
string | null | $key | If specified must be a string between 16 and 64 bytes
int | $length | The size of the desired hash output
Renvoie
string A BLAKE2 hashing context, encoded as a string (To be 100% compatible with ext/libsodium)
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_GENERICHASH_KEYBYTES_MAX, Sodium\CRYPTO_GENERICHASH_KEYBYTES_MIN, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_generichash_init_salt_personal()

static crypto_generichash_init_salt_personal | ( | $key = '',
 |  | $length = self::CRYPTO_GENERICHASH_BYTES,
 |  | $salt = '',
 |  | $personal = ''
 | ) |
static

Initialize a BLAKE2b hashing context, for use in a streaming interface.

Paramètres
string | null | $key | If specified must be a string between 16 and 64 bytes
int | $length | The size of the desired hash output
string | $salt | Salt (up to 16 bytes)
string | $personal | Personalization string (up to 16 bytes)
Renvoie
string A BLAKE2 hashing context, encoded as a string (To be 100% compatible with ext/libsodium)
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_GENERICHASH_KEYBYTES_MAX, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_generichash_keygen()

static crypto_generichash_keygen ( )
static
Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_GENERICHASH_KEYBYTES.

◆ crypto_generichash_update()

static crypto_generichash_update | ( | & | $ctx,
 |  |  | $message
 | ) |  |
static

Update a BLAKE2b hashing context with additional data.

Paramètres
string | $ctx | BLAKE2 hashing context. Generated by crypto_generichash_init(). $ctx is passed by reference and gets updated in-place.
-out | string $ctx
string | $message | The message to append to the existing hash state.
Renvoie
void
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress ReferenceConstraintViolation

Références $message, et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_kdf_derive_from_key()

static crypto_kdf_derive_from_key | ( | $subkey_len,
 |  | $subkey_id,
 |  | $context,
 |  | $key
 | ) |
static
Paramètres
int | $subkey_len
int | $subkey_id
string | $context
string | $key
Renvoie
string
Exceptions
SodiumException

Références $context, $key, $state, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_kdf_keygen()

static crypto_kdf_keygen ( )
static
Renvoie
string
Exceptions
Exception
Error

◆ crypto_kx()

static crypto_kx | ( | $my_secret,
 |  | $their_public,
 |  | $client_public,
 |  | $server_public,
 |  | $dontFallback = false
 | ) |
static

Perform a key exchange, between a designated client and a server.

Typically, you would designate one machine to be the client and the other to be the server. The first two keys are what you'd expect for scalarmult() below, but the latter two public keys don't swap places.

| ALICE | BOB |

Client | Server
shared = crypto_kx( | shared = crypto_kx(

| alice_sk, | bob_sk, | <- contextual | bob_pk, | alice_pk, | <- contextual | alice_pk, | alice_pk, | <--— static | bob_pk | bob_pk | <--— static | ) | ) |

They are used along with the scalarmult product to generate a 256-bit BLAKE2b hash unique to the client and server keys.

Paramètres
string | $my_secret
string | $their_public
string | $client_public
string | $server_public
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_BOX_PUBLICKEYBYTES, Sodium\CRYPTO_BOX_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\keyExchange(), ParagonIE_Sodium_Crypto\keyExchange(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_kx_client_session_keys()

static crypto_kx_client_session_keys | ( | $keypair,
 |  | $serverPublicKey
 | ) |
static
Paramètres
string | $keypair
string | $serverPublicKey
Renvoie
array{0: string, 1: string}
Exceptions
SodiumException

Références Sodium\CRYPTO_KX_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), null, ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

◆ crypto_kx_keypair()

static crypto_kx_keypair ( )
static
Renvoie
string
Exceptions
Exception

Références Sodium\CRYPTO_KX_SECRETKEYBYTES.

◆ crypto_kx_publickey()

static crypto_kx_publickey ( $kp )
static
Paramètres
string $kp
Renvoie
string
Exceptions
SodiumException

Références Sodium\CRYPTO_KX_PUBLICKEYBYTES, Sodium\CRYPTO_KX_SECRETKEYBYTES, et ParagonIE_Sodium_Core_Util\substr().

◆ crypto_kx_secretkey()

static crypto_kx_secretkey ( $kp )
static
Paramètres
string $kp
Renvoie
string
Exceptions
SodiumException

Références Sodium\CRYPTO_KX_SECRETKEYBYTES, et ParagonIE_Sodium_Core_Util\substr().

◆ crypto_kx_seed_keypair()

static crypto_kx_seed_keypair ( $seed )
static
Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException

Références Sodium\CRYPTO_KX_SECRETKEYBYTES, Sodium\CRYPTO_KX_SEEDBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_kx_server_session_keys()

static crypto_kx_server_session_keys | ( | $keypair,
 |  | $clientPublicKey
 | ) |
static
Paramètres
string | $keypair
string | $clientPublicKey
Renvoie
array{0: string, 1: string}
Exceptions
SodiumException

Références Sodium\CRYPTO_KX_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), null, ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

◆ crypto_pwhash()

static crypto_pwhash | ( | $outlen,
 |  | $passwd,
 |  | $salt,
 |  | $opslimit,
 |  | $memlimit,
 |  | $alg = null
 | ) |
static
Paramètres
int | $outlen
string | $passwd
string | $salt
int | $opslimit
int | $memlimit
int | null | $alg
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_pwhash_is_available()

static crypto_pwhash_is_available ( )
static

!Exclusive to sodium_compat!

This returns TRUE if the native crypto_pwhash API is available by libsodium. This returns FALSE if only sodium_compat is available.

Renvoie
bool

◆ crypto_pwhash_scryptsalsa208sha256()

static crypto_pwhash_scryptsalsa208sha256 | ( | $outlen,
 |  | $passwd,
 |  | $salt,
 |  | $opslimit,
 |  | $memlimit
 | ) |
static
Paramètres
int | $outlen
string | $passwd
string | $salt
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_pwhash_scryptsalsa208sha256_is_available()

static crypto_pwhash_scryptsalsa208sha256_is_available ( )
static

!Exclusive to sodium_compat!

This returns TRUE if the native crypto_pwhash API is available by libsodium. This returns FALSE if only sodium_compat is available.

Renvoie
bool

◆ crypto_pwhash_scryptsalsa208sha256_str()

static crypto_pwhash_scryptsalsa208sha256_str | ( | $passwd,
 |  | $opslimit,
 |  | $memlimit
 | ) |
static
Paramètres
string | $passwd
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_pwhash_scryptsalsa208sha256_str_verify()

static crypto_pwhash_scryptsalsa208sha256_str_verify | ( | $passwd,
 |  | $hash
 | ) |
static
Paramètres
string | $passwd
string | $hash
Renvoie
bool
Exceptions
SodiumException
TypeError

Références $hash, et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_pwhash_str()

static crypto_pwhash_str | ( | $passwd,
 |  | $opslimit,
 |  | $memlimit
 | ) |
static
Paramètres
string | $passwd
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_pwhash_str_verify()

static crypto_pwhash_str_verify | ( | $passwd,
 |  | $hash
 | ) |
static
Paramètres
string | $passwd
string | $hash
Renvoie
bool
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $hash, et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_scalarmult()

static crypto_scalarmult | ( | $secretKey,
 |  | $publicKey
 | ) |
static

Calculate the shared secret between your secret key and your recipient's public key.

Algorithm: X25519 (ECDH over Curve25519)

Paramètres
string | $secretKey
string | $publicKey
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_BOX_PUBLICKEYBYTES, Sodium\CRYPTO_BOX_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\scalarmult(), ParagonIE_Sodium_Crypto\scalarmult(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Crypto\keyExchange().

◆ crypto_scalarmult_base()

static crypto_scalarmult_base ( $secretKey )
static

Calculate an X25519 public key from an X25519 secret key.

Paramètres
string $secretKey
Renvoie
string
Exceptions
SodiumException
TypeError -suppress TooFewArguments -suppress MixedArgument

Références Sodium\CRYPTO_BOX_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\scalarmult_base(), ParagonIE_Sodium_Crypto\scalarmult_base(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretbox()

static crypto_secretbox | ( | $plaintext,
 |  | $nonce,
 |  | $key
 | ) |
static

Authenticated symmetric-key encryption.

Algorithm: XSalsa20-Poly1305

Paramètres
string | $plaintext | The message you're encrypting
string | $nonce | A Number to be used Once; must be 24 bytes
string | $key | Symmetric encryption key
Renvoie
string Ciphertext with Poly1305 MAC
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_SECRETBOX_KEYBYTES, Sodium\CRYPTO_SECRETBOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretbox_keygen()

static crypto_secretbox_keygen ( )
static

Return a secure random key for use with crypto_secretbox

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_SECRETBOX_KEYBYTES.

◆ crypto_secretbox_open()

static crypto_secretbox_open | ( | $ciphertext,
 |  | $nonce,
 |  | $key
 | ) |
static

Decrypts a message previously encrypted with crypto_secretbox().

Paramètres
string | $ciphertext | Ciphertext with Poly1305 MAC
string | $nonce | A Number to be used Once; must be 24 bytes
string | $key | Symmetric encryption key
Renvoie
string Original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références $key, Sodium\CRYPTO_SECRETBOX_KEYBYTES, Sodium\CRYPTO_SECRETBOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretbox_xchacha20poly1305()

static crypto_secretbox_xchacha20poly1305 | ( | $plaintext,
 |  | $nonce,
 |  | $key
 | ) |
static

Authenticated symmetric-key encryption.

Algorithm: XChaCha20-Poly1305

Paramètres
string | $plaintext | The message you're encrypting
string | $nonce | A Number to be used Once; must be 24 bytes
string | $key | Symmetric encryption key
Renvoie
string Ciphertext with Poly1305 MAC
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_SECRETBOX_KEYBYTES, Sodium\CRYPTO_SECRETBOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretbox_xchacha20poly1305_open()

static crypto_secretbox_xchacha20poly1305_open | ( | $ciphertext,
 |  | $nonce,
 |  | $key
 | ) |
static

Decrypts a message previously encrypted with crypto_secretbox_xchacha20poly1305().

Paramètres
string | $ciphertext | Ciphertext with Poly1305 MAC
string | $nonce | A Number to be used Once; must be 24 bytes
string | $key | Symmetric encryption key
Renvoie
string Original plaintext message
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_SECRETBOX_KEYBYTES, Sodium\CRYPTO_SECRETBOX_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretstream_xchacha20poly1305_init_pull()

static crypto_secretstream_xchacha20poly1305_init_pull | ( | $header,
 |  | $key
 | ) |
static
Paramètres
string | $header
string | $key
Renvoie
string Returns a state.
Exceptions
Exception

Références $header, $key, ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_secretstream_xchacha20poly1305_init_push()

static crypto_secretstream_xchacha20poly1305_init_push ( $key )
static
Paramètres
string $key
Renvoie
array<int, string> Returns a state and a header.
Exceptions
Exception
SodiumException

Références $key, ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_push(), et ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_push().

◆ crypto_secretstream_xchacha20poly1305_keygen()

static crypto_secretstream_xchacha20poly1305_keygen ( )
static
Renvoie
string
Exceptions
Exception

◆ crypto_secretstream_xchacha20poly1305_pull()

static crypto_secretstream_xchacha20poly1305_pull | ( | & | $state,
 |  |  | $msg,
 |  |  | $aad = ''
 | ) |  |
static
Paramètres
string | $state
string | $msg
string | $aad
Renvoie
bool|array{0: string, 1: int}
Exceptions
SodiumException

Références $state.

◆ crypto_secretstream_xchacha20poly1305_push()

static crypto_secretstream_xchacha20poly1305_push | ( | & | $state,
 |  |  | $msg,
 |  |  | $aad = '',
 |  |  | $tag = 0
 | ) |  |
static
Paramètres
string | $state
string | $msg
string | $aad
int | $tag
Renvoie
string
Exceptions
SodiumException

Références $state.

◆ crypto_secretstream_xchacha20poly1305_rekey()

static crypto_secretstream_xchacha20poly1305_rekey ( & $state )
static
Paramètres
string $state
Renvoie
void
Exceptions
SodiumException

Références $state, ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_rekey(), et ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_rekey().

◆ crypto_shorthash()

static crypto_shorthash | ( | $message,
 |  | $key
 | ) |
static

Calculates a SipHash-2-4 hash of a message for a given key.

Paramètres
string | $message | Input message
string | $key | SipHash-2-4 key
Renvoie
string Hash
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

Références $key, $message, Sodium\CRYPTO_SHORTHASH_KEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_SipHash\sipHash24(), ParagonIE_Sodium_Core_SipHash\sipHash24(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_shorthash_keygen()

static crypto_shorthash_keygen ( )
static

Return a secure random key for use with crypto_shorthash

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_SHORTHASH_KEYBYTES.

◆ crypto_sign()

static crypto_sign | ( | $message,
 |  | $secretKey
 | ) |
static

Returns a signed message. You probably want crypto_sign_detached() instead, which only returns the signature.

Algorithm: Ed25519 (EdDSA over Curve25519)

Paramètres
string | $message | Message to be signed.
string | $secretKey | Secret signing key.
Renvoie
string Signed message (signature is prefixed).
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

Références $message, Sodium\CRYPTO_SIGN_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\sign(), ParagonIE_Sodium_Crypto\sign(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_detached()

static crypto_sign_detached | ( | $message,
 |  | $secretKey
 | ) |
static

Calculate the Ed25519 signature of a message and return ONLY the signature.

Algorithm: Ed25519 (EdDSA over Curve25519)

Paramètres
string | $message | Message to be signed
string | $secretKey | Secret signing key
Renvoie
string Digital signature
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $message, Sodium\CRYPTO_SIGN_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\sign_detached(), ParagonIE_Sodium_Crypto\sign_detached(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_ed25519_pk_to_curve25519()

static crypto_sign_ed25519_pk_to_curve25519 ( $pk )
static

Convert an Ed25519 public key to a Curve25519 public key

Paramètres
string $pk
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_SIGN_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_Ed25519\pk_to_curve25519(), ParagonIE_Sodium_Core_Ed25519\pk_to_curve25519(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_ed25519_sk_to_curve25519()

static crypto_sign_ed25519_sk_to_curve25519 ( $sk )
static

Convert an Ed25519 secret key to a Curve25519 secret key

Paramètres
string $sk
Renvoie
string
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_SIGN_SEEDBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core_Util\intToChr(), ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

◆ crypto_sign_keypair()

static crypto_sign_keypair ( )
static

Generate a new random Ed25519 keypair.

Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core32_Ed25519\keypair(), et ParagonIE_Sodium_Core_Ed25519\keypair().

◆ crypto_sign_keypair_from_secretkey_and_publickey()

static crypto_sign_keypair_from_secretkey_and_publickey | ( | $sk,
 |  | $pk
 | ) |
static
Paramètres
string | $sk
string | $pk
Renvoie
string
Exceptions
SodiumException

Références Sodium\CRYPTO_SIGN_PUBLICKEYBYTES, Sodium\CRYPTO_SIGN_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_open()

static crypto_sign_open | ( | $signedMessage,
 |  | $publicKey
 | ) |
static

Validates a signed message then returns the message.

Paramètres
string | $signedMessage | A signed message
string | $publicKey | A public key
Renvoie
string The original message (if the signature is valid for this public key)
Exceptions
SodiumException
TypeError -suppress MixedArgument -suppress MixedInferredReturnType -suppress MixedReturnStatement

-suppress InvalidReturnStatement -suppress FalsableReturnStatement

Références Sodium\CRYPTO_SIGN_BYTES, Sodium\CRYPTO_SIGN_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\sign_open(), ParagonIE_Sodium_Crypto\sign_open(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_publickey()

static crypto_sign_publickey ( $keypair )
static

Extract an Ed25519 public key from an Ed25519 keypair.

Paramètres
string $keypair Keypair
Renvoie
string Public key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_SIGN_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_Ed25519\publickey(), ParagonIE_Sodium_Core_Ed25519\publickey(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_publickey_from_secretkey()

static crypto_sign_publickey_from_secretkey ( $secretKey )
static

Calculate an Ed25519 public key from an Ed25519 secret key.

Paramètres
string $secretKey Your Ed25519 secret key
Renvoie
string The corresponding Ed25519 public key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_SIGN_SECRETKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_secretkey()

static crypto_sign_secretkey ( $keypair )
static

Extract an Ed25519 secret key from an Ed25519 keypair.

Paramètres
string $keypair Keypair
Renvoie
string Secret key
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références Sodium\CRYPTO_SIGN_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_Ed25519\secretkey(), ParagonIE_Sodium_Core_Ed25519\secretkey(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_sign_seed_keypair()

static crypto_sign_seed_keypair ( $seed )
static

Generate an Ed25519 keypair from a seed.

Paramètres
string $seed Input seed
Renvoie
string Keypair
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ crypto_sign_verify_detached()

static crypto_sign_verify_detached | ( | $signature,
 |  | $message,
 |  | $publicKey
 | ) |
static

Verify the Ed25519 signature of a message.

Paramètres
string | $signature | Digital sginature
string | $message | Message to be verified
string | $publicKey | Public key
Renvoie
bool TRUE if this signature is good for this public key; FALSE otherwise
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $message, Sodium\CRYPTO_SIGN_BYTES, Sodium\CRYPTO_SIGN_PUBLICKEYBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Crypto32\sign_verify_detached(), ParagonIE_Sodium_Crypto\sign_verify_detached(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_stream()

static crypto_stream | ( | $len,
 |  | $nonce,
 |  | $key
 | ) |
static

Expand a key and nonce into a keystream of pseudorandom bytes.

Paramètres
int | $len | Number of bytes desired
string | $nonce | Number to be used Once; must be 24 bytes
string | $key | XSalsa20 key
Renvoie
string Pseudorandom stream that can be XORed with messages to provide encryption (but not authentication; see Poly1305 or crypto_auth() for that, which is not optional for security)
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, Sodium\CRYPTO_STREAM_KEYBYTES, Sodium\CRYPTO_STREAM_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core_Util\strlen(), ParagonIE_Sodium_Core32_XSalsa20\xsalsa20(), et ParagonIE_Sodium_Core_XSalsa20\xsalsa20().

◆ crypto_stream_keygen()

static crypto_stream_keygen ( )
static

Return a secure random key for use with crypto_stream

Renvoie
string
Exceptions
Exception
Error

Références Sodium\CRYPTO_STREAM_KEYBYTES.

◆ crypto_stream_xchacha20()

static crypto_stream_xchacha20 | ( | $len,
 |  | $nonce,
 |  | $key,
 |  | $dontFallback = false
 | ) |
static

Expand a key and nonce into a keystream of pseudorandom bytes.

Paramètres
int | $len | Number of bytes desired
string | $nonce | Number to be used Once; must be 24 bytes
string | $key | XChaCha20 key
bool | $dontFallback
Renvoie
string Pseudorandom stream that can be XORed with messages to provide encryption (but not authentication; see Poly1305 or crypto_auth() for that, which is not optional for security)
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_XChaCha20\stream(), ParagonIE_Sodium_Core_XChaCha20\stream(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_stream_xchacha20_keygen()

static crypto_stream_xchacha20_keygen ( )
static

Return a secure random key for use with crypto_stream_xchacha20

Renvoie
string
Exceptions
Exception
Error

◆ crypto_stream_xchacha20_xor()

static crypto_stream_xchacha20_xor | ( | $message,
 |  | $nonce,
 |  | $key,
 |  | $dontFallback = false
 | ) |
static

DANGER! UNAUTHENTICATED ENCRYPTION!

Unless you are following expert advice, do not use this feature.

Algorithm: XChaCha20

This DOES NOT provide ciphertext integrity.

Paramètres
string | $message | Plaintext message
string | $nonce | Number to be used Once; must be 24 bytes
string | $key | Encryption key
Renvoie
string Encrypted text which is vulnerable to chosen- ciphertext attacks unless you implement some other mitigation to the ciphertext (i.e. Encrypt then MAC)
Paramètres
bool $dontFallback
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, $message, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core32_XChaCha20\streamXorIc(), ParagonIE_Sodium_Core_XChaCha20\streamXorIc(), et ParagonIE_Sodium_Core_Util\strlen().

◆ crypto_stream_xor()

static crypto_stream_xor | ( | $message,
 |  | $nonce,
 |  | $key
 | ) |
static

DANGER! UNAUTHENTICATED ENCRYPTION!

Unless you are following expert advice, do not use this feature.

Algorithm: XSalsa20

This DOES NOT provide ciphertext integrity.

Paramètres
string | $message | Plaintext message
string | $nonce | Number to be used Once; must be 24 bytes
string | $key | Encryption key
Renvoie
string Encrypted text which is vulnerable to chosen- ciphertext attacks unless you implement some other mitigation to the ciphertext (i.e. Encrypt then MAC)
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $key, $message, Sodium\CRYPTO_STREAM_KEYBYTES, Sodium\CRYPTO_STREAM_NONCEBYTES, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core_Util\strlen(), ParagonIE_Sodium_Core32_XSalsa20\xsalsa20_xor(), et ParagonIE_Sodium_Core_XSalsa20\xsalsa20_xor().

◆ hex2bin()

static hex2bin ( $string )
static

Cache-timing-safe implementation of hex2bin().

Paramètres
string $string Hexadecimal string
Renvoie
string Raw binary string
Exceptions
SodiumException
TypeError -suppress TooFewArguments -suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ increment()

static increment ( & $var )
static

Increase a string (little endian)

Paramètres
string $var
Renvoie
void
Exceptions
SodiumException
TypeError -suppress MixedArgument

Références $c, $i, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core_Util\intToChr(), ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

◆ is_zero()

static is_zero ( $str )
static
Paramètres
string $str
Renvoie
bool
Exceptions
SodiumException

Références $i.

Référencé par ParagonIE_Sodium_Core_Ed25519\scalar_random(), ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255(), et ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255_base().

◆ library_version_major()

static library_version_major ( )
static

The equivalent to the libsodium minor version we aim to be compatible with (sans pwhash and memzero).

Renvoie
int

-suppress UndefinedFunction

Références SODIUM_LIBRARY_MAJOR_VERSION.

◆ library_version_minor()

static library_version_minor ( )
static

The equivalent to the libsodium minor version we aim to be compatible with (sans pwhash and memzero).

Renvoie
int

-suppress UndefinedFunction

Références SODIUM_LIBRARY_MINOR_VERSION.

◆ memzero()

static memzero ( & $var )
static

It's actually not possible to zero memory buffers in PHP. You need the native library for that.

Paramètres
string | null | $var
-out | string|null $var
Renvoie
void
Exceptions
SodiumException | (Unless libsodium is installed)
TypeError | -suppress TooFewArguments

-suppress MixedArgument

Références ParagonIE_Sodium_Core_Util\declareScalarType(), et null.

Référencé par ParagonIE_Sodium_Core_Salsa20\salsa20(), ParagonIE_Sodium_Core32_Salsa20\salsa20(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core_Ed25519\sign_detached(), et ParagonIE_Sodium_Core32_Ed25519\sign_detached().

◆ polyfill_is_fast()

static polyfill_is_fast ( )
static

Will sodium_compat run fast on the current hardware and PHP configuration?

Renvoie
bool

◆ randombytes_random16()

static randombytes_random16 ( )
static

Generate a random 16-bit integer.

Renvoie
int
Exceptions
Exception
Error
TypeError

◆ randombytes_uniform()

static randombytes_uniform ( $range )
static

Generate an integer between 0 and $range (non-inclusive).

Paramètres
int $range
Renvoie
int
Exceptions
Exception
Error
TypeError

Références $range.

◆ ristretto255_add()

static ristretto255_add | ( | $p,
 |  | $q,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $p
string | $q
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_add().

◆ ristretto255_from_hash()

static ristretto255_from_hash | ( | $r,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $r
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références $r, et ParagonIE_Sodium_Core_Ristretto255\ristretto255_from_hash().

◆ ristretto255_is_valid_point()

static ristretto255_is_valid_point | ( | $p,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $p
bool | $dontFallback
Renvoie
bool
Exceptions
SodiumException

Références $r, ParagonIE_Sodium_Core_Ristretto255\ristretto255_frombytes(), et ParagonIE_Sodium_Core_Ristretto255\ristretto255_point_is_canonical().

◆ ristretto255_random()

static ristretto255_random ( $dontFallback = false )
static
Paramètres
bool $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_random().

◆ ristretto255_scalar_add()

static ristretto255_scalar_add | ( | $x,
 |  | $y,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $x
string | $y
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_add().

◆ ristretto255_scalar_complement()

static ristretto255_scalar_complement | ( | $s,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $s
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_complement().

◆ ristretto255_scalar_invert()

static ristretto255_scalar_invert | ( | $s,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $s
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_invert().

◆ ristretto255_scalar_mul()

static ristretto255_scalar_mul | ( | $x,
 |  | $y,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $x
string | $y
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_mul().

◆ ristretto255_scalar_negate()

static ristretto255_scalar_negate | ( | $s,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $s
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_negate().

◆ ristretto255_scalar_random()

static ristretto255_scalar_random ( $dontFallback = false )
static
Paramètres
bool $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_random().

◆ ristretto255_scalar_reduce()

static ristretto255_scalar_reduce | ( | $s,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $s
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

◆ ristretto255_scalar_sub()

static ristretto255_scalar_sub | ( | $x,
 |  | $y,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $x
string | $y
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_sub().

◆ ristretto255_sub()

static ristretto255_sub | ( | $p,
 |  | $q,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $p
string | $q
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Ristretto255\ristretto255_sub().

◆ scalarmult_ristretto255()

static scalarmult_ristretto255 | ( | $n,
 |  | $p,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $n
string | $p
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références $n, et ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255().

◆ scalarmult_ristretto255_base()

static scalarmult_ristretto255_base | ( | $n,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $n
string | $p
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références $n, et ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255_base().

◆ sub()

static sub | ( | & | $val,
 |  |  | $addv
 | ) |  |
static

Add two numbers (little-endian unsigned), storing the value in the first parameter.

This mutates $val.

Paramètres
string | $val
string | $addv
Renvoie
void
Exceptions
SodiumException

Références $c, $i, $val, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Core_Ed25519\scalar_complement(), et ParagonIE_Sodium_Core_Ed25519\scalar_negate().

◆ unpad()

static unpad | ( | $padded,
 |  | $blockSize,
 |  | $dontFallback = false
 | ) |
static
Paramètres
string | $padded
int | $blockSize
bool | $dontFallback
Renvoie
string
Exceptions
SodiumException

Références $c, $i, ParagonIE_Sodium_Core_Util\declareScalarType(), ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

◆ use_fallback()

static use_fallback ( $sodium_func_name = '' )
staticprotected

Should we use the libsodium core function instead? This is always a good idea, if it's available. (Unless we're in the middle of running our unit test suite.)

If ext/libsodium is available, use it. Return TRUE. Otherwise, we have to use the code provided herein. Return FALSE.

Paramètres
string $sodium_func_name
Renvoie
bool

Références null.

◆ useNewSodiumAPI()

static useNewSodiumAPI ( )
staticprotected

Libsodium as implemented in PHP 7.2 and/or ext/sodium (via PECL)

https://wiki.php.net/rfc/libsodium

Renvoie
bool

Références null.

◆ version_string()

static version_string ( )
static

This emulates libsodium's version_string() function, except ours is prefixed with 'polyfill-'.

Renvoie
string -suppress MixedInferredReturnType -suppress UndefinedFunction

Documentation des champs

◆ $disableFallbackForUnitTests

$disableFallbackForUnitTests = false
static

◆ $fastMult

$fastMult = false
static

◆ BASE64_VARIANT_ORIGINAL

const BASE64_VARIANT_ORIGINAL = 1

◆ BASE64_VARIANT_ORIGINAL_NO_PADDING

const BASE64_VARIANT_ORIGINAL_NO_PADDING = 3

◆ BASE64_VARIANT_URLSAFE

const BASE64_VARIANT_URLSAFE = 5

◆ BASE64_VARIANT_URLSAFE_NO_PADDING

const BASE64_VARIANT_URLSAFE_NO_PADDING = 7

◆ CRYPTO_AEAD_AES256GCM_ABYTES

const CRYPTO_AEAD_AES256GCM_ABYTES = 16

◆ CRYPTO_AEAD_AES256GCM_KEYBYTES

const CRYPTO_AEAD_AES256GCM_KEYBYTES = 32

◆ CRYPTO_AEAD_AES256GCM_NPUBBYTES

const CRYPTO_AEAD_AES256GCM_NPUBBYTES = 12

◆ CRYPTO_AEAD_AES256GCM_NSECBYTES

const CRYPTO_AEAD_AES256GCM_NSECBYTES = 0

◆ CRYPTO_AEAD_CHACHA20POLY1305_ABYTES

const CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = 16

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = 16

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = 32

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = 12

◆ CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = 0

◆ CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = 32

◆ CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = 8

◆ CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES

const CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = 0

◆ CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES

const CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES = 16

◆ CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES

const CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES = 32

◆ CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES

const CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES = 24

◆ CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES

const CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES = 0

◆ CRYPTO_AUTH_BYTES

const CRYPTO_AUTH_BYTES = 32

◆ CRYPTO_AUTH_KEYBYTES

const CRYPTO_AUTH_KEYBYTES = 32

◆ CRYPTO_BOX_KEYPAIRBYTES

const CRYPTO_BOX_KEYPAIRBYTES = 64

Référencé par ParagonIE_Sodium_Crypto32\box_publickey(), et ParagonIE_Sodium_Crypto\box_publickey().

◆ CRYPTO_BOX_MACBYTES

const CRYPTO_BOX_MACBYTES = 16

◆ CRYPTO_BOX_NONCEBYTES

const CRYPTO_BOX_NONCEBYTES = 24

◆ CRYPTO_BOX_PUBLICKEYBYTES

const CRYPTO_BOX_PUBLICKEYBYTES = 32

◆ CRYPTO_BOX_SEALBYTES

const CRYPTO_BOX_SEALBYTES = 16

◆ CRYPTO_BOX_SECRETKEYBYTES

const CRYPTO_BOX_SECRETKEYBYTES = 32

Référencé par ParagonIE_Sodium_Crypto32\box_publickey_from_secretkey(), et ParagonIE_Sodium_Crypto\box_publickey_from_secretkey().

◆ CRYPTO_BOX_SEEDBYTES

const CRYPTO_BOX_SEEDBYTES = 32

◆ CRYPTO_CORE_RISTRETTO255_BYTES

const CRYPTO_CORE_RISTRETTO255_BYTES = 32

◆ CRYPTO_CORE_RISTRETTO255_HASHBYTES

const CRYPTO_CORE_RISTRETTO255_HASHBYTES = 64

◆ CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES

const CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES = 64

◆ CRYPTO_CORE_RISTRETTO255_SCALARBYTES

const CRYPTO_CORE_RISTRETTO255_SCALARBYTES = 32

◆ CRYPTO_GENERICHASH_BYTES

const CRYPTO_GENERICHASH_BYTES = 32

◆ CRYPTO_GENERICHASH_BYTES_MAX

const CRYPTO_GENERICHASH_BYTES_MAX = 64

◆ CRYPTO_GENERICHASH_BYTES_MIN

const CRYPTO_GENERICHASH_BYTES_MIN = 16

◆ CRYPTO_GENERICHASH_KEYBYTES

const CRYPTO_GENERICHASH_KEYBYTES = 32

◆ CRYPTO_GENERICHASH_KEYBYTES_MAX

const CRYPTO_GENERICHASH_KEYBYTES_MAX = 64

◆ CRYPTO_GENERICHASH_KEYBYTES_MIN

const CRYPTO_GENERICHASH_KEYBYTES_MIN = 16

◆ CRYPTO_KDF_BYTES_MAX

const CRYPTO_KDF_BYTES_MAX = 64

◆ CRYPTO_KDF_BYTES_MIN

const CRYPTO_KDF_BYTES_MIN = 16

◆ CRYPTO_KDF_CONTEXTBYTES

const CRYPTO_KDF_CONTEXTBYTES = 8

◆ CRYPTO_KDF_KEYBYTES

const CRYPTO_KDF_KEYBYTES = 32

◆ CRYPTO_KX_BYTES

const CRYPTO_KX_BYTES = 32

◆ CRYPTO_KX_KEYPAIRBYTES

const CRYPTO_KX_KEYPAIRBYTES = 64

◆ CRYPTO_KX_PRIMITIVE

const CRYPTO_KX_PRIMITIVE = 'x25519blake2b'

◆ CRYPTO_KX_PUBLICKEYBYTES

const CRYPTO_KX_PUBLICKEYBYTES = 32

◆ CRYPTO_KX_SECRETKEYBYTES

const CRYPTO_KX_SECRETKEYBYTES = 32

◆ CRYPTO_KX_SEEDBYTES

const CRYPTO_KX_SEEDBYTES = 32

◆ CRYPTO_KX_SESSIONKEYBYTES

const CRYPTO_KX_SESSIONKEYBYTES = 32

◆ CRYPTO_PWHASH_ALG_ARGON2I13

const CRYPTO_PWHASH_ALG_ARGON2I13 = 1

◆ CRYPTO_PWHASH_ALG_ARGON2ID13

const CRYPTO_PWHASH_ALG_ARGON2ID13 = 2

◆ CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE

const CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE = 33554432

◆ CRYPTO_PWHASH_MEMLIMIT_MODERATE

const CRYPTO_PWHASH_MEMLIMIT_MODERATE = 134217728

◆ CRYPTO_PWHASH_MEMLIMIT_SENSITIVE

const CRYPTO_PWHASH_MEMLIMIT_SENSITIVE = 536870912

◆ CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE

const CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE = 4

◆ CRYPTO_PWHASH_OPSLIMIT_MODERATE

const CRYPTO_PWHASH_OPSLIMIT_MODERATE = 6

◆ CRYPTO_PWHASH_OPSLIMIT_SENSITIVE

const CRYPTO_PWHASH_OPSLIMIT_SENSITIVE = 8

◆ CRYPTO_PWHASH_SALTBYTES

const CRYPTO_PWHASH_SALTBYTES = 16

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE = 16777216

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE = 1073741824

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE = 534288

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE = 33554432

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES = 32

◆ CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX

const CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX = '$7$'

◆ CRYPTO_PWHASH_STRPREFIX

const CRYPTO_PWHASH_STRPREFIX = '$argon2id$'

◆ CRYPTO_SCALARMULT_BYTES

const CRYPTO_SCALARMULT_BYTES = 32

◆ CRYPTO_SCALARMULT_RISTRETTO255_BYTES

const CRYPTO_SCALARMULT_RISTRETTO255_BYTES = 32

◆ CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES

const CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES = 32

◆ CRYPTO_SCALARMULT_SCALARBYTES

const CRYPTO_SCALARMULT_SCALARBYTES = 32

◆ CRYPTO_SECRETBOX_KEYBYTES

const CRYPTO_SECRETBOX_KEYBYTES = 32

◆ CRYPTO_SECRETBOX_MACBYTES

const CRYPTO_SECRETBOX_MACBYTES = 16

◆ CRYPTO_SECRETBOX_NONCEBYTES

const CRYPTO_SECRETBOX_NONCEBYTES = 24

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES = 17

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES = 24

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES = 32

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX = 0x3fffffff80

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL = 3

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL = 1

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH = 0

◆ CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY

const CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY = 2

◆ CRYPTO_SHORTHASH_BYTES

const CRYPTO_SHORTHASH_BYTES = 8

◆ CRYPTO_SHORTHASH_KEYBYTES

const CRYPTO_SHORTHASH_KEYBYTES = 16

◆ CRYPTO_SIGN_BYTES

const CRYPTO_SIGN_BYTES = 64

◆ CRYPTO_SIGN_KEYPAIRBYTES

const CRYPTO_SIGN_KEYPAIRBYTES = 96

◆ CRYPTO_SIGN_PUBLICKEYBYTES

const CRYPTO_SIGN_PUBLICKEYBYTES = 32

◆ CRYPTO_SIGN_SECRETKEYBYTES

const CRYPTO_SIGN_SECRETKEYBYTES = 64

◆ CRYPTO_SIGN_SEEDBYTES

const CRYPTO_SIGN_SEEDBYTES = 32

◆ CRYPTO_STREAM_KEYBYTES

const CRYPTO_STREAM_KEYBYTES = 32

◆ CRYPTO_STREAM_NONCEBYTES

const CRYPTO_STREAM_NONCEBYTES = 24

◆ CRYPTO_STREAM_XCHACHA20_KEYBYTES

const CRYPTO_STREAM_XCHACHA20_KEYBYTES = 32

◆ CRYPTO_STREAM_XCHACHA20_NONCEBYTES

const CRYPTO_STREAM_XCHACHA20_NONCEBYTES = 24

◆ LIBRARY_MAJOR_VERSION

const LIBRARY_MAJOR_VERSION = 9

◆ LIBRARY_MINOR_VERSION

const LIBRARY_MINOR_VERSION = 1

◆ LIBRARY_VERSION_MAJOR

const LIBRARY_VERSION_MAJOR = 9

◆ LIBRARY_VERSION_MINOR

const LIBRARY_VERSION_MINOR = 1

◆ VERSION_STRING

const VERSION_STRING = 'polyfill-1.0.8'
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Compat.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_BLAKE2b

Fonctions membres publiques statiques | Champs de données | Attributs publics statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core32_BLAKE2b
+ Graphe d'héritage de ParagonIE_Sodium_Core32_BLAKE2b:
ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | new64 ($high, $low)
static | add364 ($x, $y, $z)
static | xor64 (ParagonIE_Sodium_Core32_Int64 $x, ParagonIE_Sodium_Core32_Int64 $y)
static | rotr64 (ParagonIE_Sodium_Core32_Int64 $x, $c)
static | store64 (SplFixedArray $x, $i, ParagonIE_Sodium_Core32_Int64 $u)
static | pseudoConstructor ()
static | G ($r, $i, $a, $b, $c, $d, SplFixedArray $v, SplFixedArray $m)
static | update (SplFixedArray $ctx, SplFixedArray $p, $plen)
static | init ( $key=null, $outlen=64, $salt=null, $personal=null)
static | stringToSplFixedArray ($str='')
static | stringToContext ($string)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const | BLOCKBYTES = 128
const | OUTBYTES = 64
const | KEYBYTES = 64

Attributs publics statiques

static | $iv
static | $sigma

Fonctions membres protégées statiques

static | to64 ($num)
static | add64 ($x, $y)
static | context ()
static | compress (SplFixedArray $ctx, SplFixedArray $buf)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_BLAKE2b

Based on the work of Devi Mandiri in devi/salt.

Documentation des fonctions membres

◆ add364()

static add364 | ( | $x,
 |  | $y,
 |  | $z
 | ) |
static

◆ add64()

static add64 | ( | $x,
 |  | $y
 | ) |
staticprotected

Adds two 64-bit integers together, returning their sum as a SplFixedArray containing two 32-bit integers (representing a 64-bit integer).

◆ compress()

static compress | ( | SplFixedArray | $ctx,
 |  | SplFixedArray | $buf
 | ) |  |
staticprotected

Références $i, et $r.

◆ context()

static context ( )
staticprotected

Returns a fresh BLAKE2 context.

Références $i.

◆ G()

static G | ( |  | $r,
 |  |  | $i,
 |  |  | $a,
 |  |  | $b,
 |  |  | $c,
 |  |  | $d,
 |  | SplFixedArray | $v,
 |  | SplFixedArray | $m
 | ) |  |
static

Références $b, $c, $i, et $r.

◆ init()

static init | ( | $key = null,
 |  | $outlen = 64,
 |  | $salt = null,
 |  | $personal = null
 | ) |
static

Références $i, $key, et null.

◆ new64()

static new64 | ( | $high,
 |  | $low
 | ) |
static

Turn two 32-bit integers into a fixed array representing a 64-bit integer.

Références ParagonIE_Sodium_Core32_Int64\fromInts().

◆ pseudoConstructor()

static pseudoConstructor ( )
static

This just sets the $iv static variable.

◆ rotr64()

static rotr64 | ( | ParagonIE_Sodium_Core32_Int64 | $x,
 |  |  | $c
 | ) |  |
static

Références $c.

◆ store64()

static store64 | ( | SplFixedArray | $x,
 |  |  | $i,
 |  | ParagonIE_Sodium_Core32_Int64 | $u
 | ) |  |
static

Références $i, et SplFixedArray\getSize().

◆ stringToContext()

static stringToContext ( $string )
static

Creates an SplFixedArray containing other SplFixedArray elements, from a string (compatible with {init, update, final})

Références $i, et ParagonIE_Sodium_Core32_Int64\fromReverseString().

◆ stringToSplFixedArray()

static stringToSplFixedArray ( $str = '' )
static

Convert a string into an SplFixedArray of integers

Références SplFixedArray\fromArray().

◆ to64()

static to64 ( $num )
staticprotected

Convert an arbitrary number into an SplFixedArray of two 32-bit integers that represents a 64-bit integer.

◆ update()

static update | ( | SplFixedArray | $ctx,
 |  | SplFixedArray | $p,
 |  |  | $plen
 | ) |  |
static

Références $i, et Joomla\Database\Query\$offset.

◆ xor64()

static xor64 | ( | ParagonIE_Sodium_Core32_Int64 | $x,
 |  | ParagonIE_Sodium_Core32_Int64 | $y
 | ) |  |
static

Références ParagonIE_Sodium_Core32_Int64\xorInt64().

Documentation des champs

◆ $iv

$iv
static

◆ $sigma

$sigma
static
Valeur initiale :
= array(
array( 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15),
array( 14, 10, 4, 8, 9, 15, 13, 6, 1, 12, 0, 2, 11, 7, 5, 3),
array( 11, 8, 12, 0, 5, 2, 15, 13, 10, 14, 3, 6, 7, 1, 9, 4),
array( 7, 9, 3, 1, 13, 12, 11, 14, 2, 6, 5, 10, 4, 0, 15, 8),
array( 9, 0, 5, 7, 2, 4, 10, 15, 14, 1, 11, 12, 6, 8, 3, 13),
array( 2, 12, 6, 10, 0, 11, 8, 3, 4, 13, 7, 5, 15, 14, 1, 9),
array( 12, 5, 1, 15, 14, 13, 4, 10, 0, 7, 6, 3, 9, 2, 8, 11),
array( 13, 11, 7, 14, 12, 1, 3, 9, 5, 0, 15, 4, 8, 6, 2, 10),
array( 6, 15, 14, 9, 11, 3, 0, 8, 12, 2, 13, 7, 1, 4, 10, 5),
array( 10, 2, 8, 4, 7, 6, 1, 5, 15, 11, 9, 14, 3, 12, 13 , 0),
array( 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15),
array( 14, 10, 4, 8, 9, 15, 13, 6, 1, 12, 0, 2, 11, 7, 5, 3)
)

◆ BLOCKBYTES

const BLOCKBYTES = 128

◆ KEYBYTES

const KEYBYTES = 64

◆ OUTBYTES

const OUTBYTES = 64
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/BLAKE2b.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_ChaCha20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_ChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_ChaCha20:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_HChaCha20 ParagonIE_Sodium_Core32_XChaCha20

Fonctions membres publiques statiques

static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_ChaCha20

Documentation des fonctions membres

◆ ietfStream()

static ietfStream | ( | $len,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

◆ ietfStreamXorIc()

static ietfStreamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

Référencé par ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_rekey().

◆ stream()

static stream | ( | $len = 64,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

◆ streamXorIc()

static streamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core32/ChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_ChaCha20_Ctx

Fonctions membres publiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core32_ChaCha20_Ctx
+ Graphe d'héritage de ParagonIE_Sodium_Core32_ChaCha20_Ctx:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_ChaCha20_IetfCtx

Fonctions membres publiques

__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)

Attributs protégés

$container

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_ChaCha20_Ctx

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key = '',
 |  | $iv = '',
 |  | $counter = ''
 | ) |

ParagonIE_Sodium_Core_ChaCha20_Ctx constructor.

Références $key, et ParagonIE_Sodium_Core32_Int32\fromReverseString().

Documentation des fonctions membres

◆ offsetExists()

offsetExists ( $offset )

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Références Joomla\Database\Query\$offset, et null.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Références Joomla\Database\Query\$offset, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Références Joomla\Database\Query\$offset.

Documentation des champs

◆ $container

$container
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/ChaCha20/Ctx.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_ChaCha20_IetfCtx

Fonctions membres publiques
Référence de la classe ParagonIE_Sodium_Core32_ChaCha20_IetfCtx
+ Graphe d'héritage de ParagonIE_Sodium_Core32_ChaCha20_IetfCtx:
ParagonIE_Sodium_Core32_ChaCha20_Ctx ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques

__construct ($key='', $iv='', $counter='')
- Fonctions membres publiques hérités de ParagonIE_Sodium_Core32_ChaCha20_Ctx
__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés hérités de ParagonIE_Sodium_Core32_ChaCha20_Ctx
$container

Description détaillée

Class ParagonIE_Sodium_Core32_ChaCha20_IetfCtx

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key = '',
 |  | $iv = '',
 |  | $counter = ''
 | ) |

ParagonIE_Sodium_Core_ChaCha20_IetfCtx constructor.

Références $key, Symfony\Contracts\Service\__construct(), et ParagonIE_Sodium_Core32_Int32\fromReverseString().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/ChaCha20/IetfCtx.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_Curve25519
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Curve25519:
ParagonIE_Sodium_Core32_Curve25519_H ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_Ed25519 ParagonIE_Sodium_Core32_X25519

Fonctions membres publiques statiques

static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_isnegative (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_neg (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core32_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core32_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core32_Curve25519_Fe $f, ParagonIE_Sodium_Core32_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | cmov (ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $u, $b)
static | ge_select ($pos=0, $b=0)
static | ge_sub (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $h)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core32_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519

Implements Curve25519 core functions

Based on the ref10 curve25519 code provided by libsodium

https://github.com/jedisct1/libsodium/blob/master/src/libsodium/crypto_core/curve25519/ref10/curve25519_ref10.c

Documentation des fonctions membres

◆ cmov()

static cmov | ( | ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp | $t,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp | $u,
 |  |  | $b
 | ) |  |
static

Conditional move

Références $b.

◆ equal()

static equal | ( | $b,
 |  | $c
 | ) |
static

Références $b, et $c.

◆ fe_0()

static fe_0 ( )
static

Get a field element of size 10 with a value of 0

Références ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray().

Référencé par ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp\__construct(), et ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1\__construct().

◆ fe_1()

static fe_1 ( )
static

Get a field element of size 10 with a value of 1

Références ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray().

◆ fe_copy()

static fe_copy ( ParagonIE_Sodium_Core32_Curve25519_Fe $f )
static

Create a copy of a field element.

◆ fe_invert()

static fe_invert ( ParagonIE_Sodium_Core32_Curve25519_Fe $Z )
static

Références $i.

◆ fe_isnegative()

static fe_isnegative ( ParagonIE_Sodium_Core32_Curve25519_Fe $f )
static

Is a field element negative? (1 = yes, 0 = no. Used in calculations.)

◆ fe_neg()

static fe_neg ( ParagonIE_Sodium_Core32_Curve25519_Fe $f )
static

Get the negative values for each piece of the field element.

h = -f

Références $i.

◆ fe_pow22523()

static fe_pow22523 ( ParagonIE_Sodium_Core32_Curve25519_Fe $z )
static

Références $i.

◆ fe_sub()

static fe_sub | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $f,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $g
 | ) |  |
static

Subtract two field elements.

h = f - g

Preconditions: |f| bounded by 1.1*2^25,1.1*2^24,1.1*2^25,1.1*2^24,etc. |g| bounded by 1.1*2^25,1.1*2^24,1.1*2^25,1.1*2^24,etc.

Postconditions: |h| bounded by 1.1*2^26,1.1*2^25,1.1*2^26,1.1*2^25,etc.

Références $g, et ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray().

◆ ge_add()

static ge_add | ( | ParagonIE_Sodium_Core32_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_Cached | $q
 | ) |  |
static

Add two group elements.

r = p + q

Références $r.

◆ ge_madd()

static ge_madd | ( | ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 | $R,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp | $q
 | ) |  |
static

Références $r.

◆ ge_msub()

static ge_msub | ( | ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 | $R,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp | $q
 | ) |  |
static

Références $r.

◆ ge_p1p1_to_p2()

static ge_p1p1_to_p2 ( ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p )
static

Références $r.

◆ ge_p1p1_to_p3()

static ge_p1p1_to_p3 ( ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p )
static

Références $r.

◆ ge_p2_0()

static ge_p2_0 ( )
static

◆ ge_p2_dbl()

static ge_p2_dbl ( ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $p )
static

Références $r.

◆ ge_p3_0()

static ge_p3_0 ( )
static

◆ ge_p3_dbl()

static ge_p3_dbl ( ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p )
static

◆ ge_p3_to_p2()

static ge_p3_to_p2 ( ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p )
static

◆ ge_p3_tobytes()

static ge_p3_tobytes ( ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $h )
static

◆ ge_precomp_0()

static ge_precomp_0 ( )
static
Renvoie
ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
Exceptions
SodiumException
TypeError

◆ ge_select()

static ge_select | ( | $pos = 0,
 |  | $b = 0
 | ) |
static

Références $b, $base, ParagonIE_Sodium_Core32_Curve25519_H\$base, $i, ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray(), et null.

◆ ge_sub()

static ge_sub | ( | ParagonIE_Sodium_Core32_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core32_Curve25519_Ge_Cached | $q
 | ) |  |
static

Subtract two group elements.

r = p - q

Références $r.

◆ ge_tobytes()

static ge_tobytes ( ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $h )
static

Convert a group element to a byte string.

Paramètres
ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $h
Renvoie
string
Exceptions
SodiumException
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core32/Curve25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Fe

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Fe
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Curve25519_Fe:

Fonctions membres publiques

offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
__debugInfo ()

Fonctions membres publiques statiques

static fromArray ($array, $save_indexes=null)

Attributs protégés

$container = array()
$size = 10

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Fe

This represents a Field Element

Documentation des fonctions membres

◆ __debugInfo()

__debugInfo ( )

Références $c.

◆ fromArray()

static fromArray | ( | $array,
 |  | $save_indexes = null
 | ) |
static

Références $count, et $i.

Référencé par ParagonIE_Sodium_Core32_Curve25519\fe_0(), ParagonIE_Sodium_Core32_Curve25519\fe_1(), ParagonIE_Sodium_Core32_Curve25519\fe_sub(), et ParagonIE_Sodium_Core32_Curve25519\ge_select().

◆ offsetExists()

offsetExists ( $offset )

Références Joomla\Database\Query\$offset.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Références Joomla\Database\Query\$offset, $value, et ParagonIE_Sodium_Core_Util\declareScalarType().

◆ offsetUnset()

offsetUnset ( $offset )

Références Joomla\Database\Query\$offset.

Documentation des champs

◆ $container

$container = array()
protected

◆ $size

$size = 10
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Fe.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_Cached

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_Cached

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core32_Curve25519_Fe $YplusX=null, ParagonIE_Sodium_Core32_Curve25519_Fe $YminusX=null, ParagonIE_Sodium_Core32_Curve25519_Fe $Z=null, ParagonIE_Sodium_Core32_Curve25519_Fe $T2d=null)

Champs de données

$YplusX
$YminusX
$Z
$T2d

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Ge_Cached

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $YplusX = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $YminusX = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $Z = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $T2d = null
 | ) |  |

ParagonIE_Sodium_Core32_Curve25519_Ge_Cached constructor.

Références $T2d, $YminusX, $YplusX, $Z, et null.

Documentation des champs

◆ $T2d

$T2d

Référencé par __construct().

◆ $YminusX

$YminusX

Référencé par __construct().

◆ $YplusX

$YplusX

Référencé par __construct().

◆ $Z

$Z

Référencé par __construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Ge/Cached.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core32_Curve25519_Fe $x=null, ParagonIE_Sodium_Core32_Curve25519_Fe $y=null, ParagonIE_Sodium_Core32_Curve25519_Fe $z=null, ParagonIE_Sodium_Core32_Curve25519_Fe $t=null)

Champs de données

$X
$Y
$Z
$T

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $z = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $t = null
 | ) |  |

ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 constructor.

Références ParagonIE_Sodium_Core32_Curve25519\fe_0(), et null.

Documentation des champs

◆ $T

$T

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Ge/P1p1.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P2

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P2

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core32_Curve25519_Fe $x=null, ParagonIE_Sodium_Core32_Curve25519_Fe $y=null, ParagonIE_Sodium_Core32_Curve25519_Fe $z=null)

Champs de données

$X
$Y
$Z

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Ge_P2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $z = null
 | ) |  |

ParagonIE_Sodium_Core32_Curve25519_Ge_P2 constructor.

Références null.

Documentation des champs

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Ge/P2.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P3

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_P3

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core32_Curve25519_Fe $x=null, ParagonIE_Sodium_Core32_Curve25519_Fe $y=null, ParagonIE_Sodium_Core32_Curve25519_Fe $z=null, ParagonIE_Sodium_Core32_Curve25519_Fe $t=null)

Champs de données

$X
$Y
$Z
$T

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Ge_P3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $z = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $t = null
 | ) |  |

ParagonIE_Sodium_Core32_Curve25519_Ge_P3 constructor.

Références null.

Documentation des champs

◆ $T

$T

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Ge/P3.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core32_Curve25519_Fe $yplusx=null, ParagonIE_Sodium_Core32_Curve25519_Fe $yminusx=null, ParagonIE_Sodium_Core32_Curve25519_Fe $xy2d=null)

Champs de données

$yplusx
$yminusx
$xy2d

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $yplusx = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $yminusx = null,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $xy2d = null
 | ) |  |

ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp constructor.

Références $xy2d, $yminusx, $yplusx, ParagonIE_Sodium_Core32_Curve25519\fe_0(), et null.

Documentation des champs

◆ $xy2d

$xy2d

Référencé par __construct().

◆ $yminusx

$yminusx

Référencé par __construct().

◆ $yplusx

$yplusx

Référencé par __construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/Ge/Precomp.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Curve25519_H

Attributs protégés statiques
Référence de la classe ParagonIE_Sodium_Core32_Curve25519_H
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Curve25519_H:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_Curve25519 ParagonIE_Sodium_Core32_Ed25519 ParagonIE_Sodium_Core32_X25519

Attributs protégés statiques

static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_Curve25519_H

This just contains the constants in the ref10/base.h file

Documentation des champs

◆ $base

$base
staticprotected

Référencé par ParagonIE_Sodium_Core32_Curve25519\ge_select().

◆ $base2

$base2
staticprotected

◆ $d

$d
staticprotected
Valeur initiale :
= array(
-10913610,
13857413,
-15372611,
6949391,
114729,
-8787816,
-6275908,
-3247719,
-18696448,
-12055116
)

◆ $d2

$d2
staticprotected
Valeur initiale :
= array(
-21827239,
-5839606,
-30745221,
13898782,
229458,
15978800,
-12551817,
-6495438,
29715968,
9444199
)

◆ $sqrtm1

$sqrtm1
staticprotected
Valeur initiale :
= array(
-32595792,
-7943725,
9377950,
3500415,
12389472,
-272473,
-25146209,
-2005654,
326686,
11406482
)
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Curve25519/H.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Ed25519

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Ed25519
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Ed25519:
ParagonIE_Sodium_Core32_Curve25519 ParagonIE_Sodium_Core32_Curve25519_H ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | keypair ()
static | secretkey ($keypair)
static | publickey ($keypair)
static | pk_to_curve25519 ($pk)
static | sk_to_pk ($sk)
static | sign_detached ($message, $sk)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_isnegative (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_neg (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core32_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core32_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core32_Curve25519_Fe $f, ParagonIE_Sodium_Core32_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | cmov (ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $u, $b)
static | ge_select ($pos=0, $b=0)
static | ge_sub (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $h)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const | KEYPAIR_BYTES = 96
const | SEED_BYTES = 32

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core32_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1

Description détaillée

Class ParagonIE_Sodium_Core32_Ed25519

Documentation des fonctions membres

◆ keypair()

static keypair ( )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_keypair().

◆ pk_to_curve25519()

static pk_to_curve25519 ( $pk )
static
Paramètres
string $pk
Renvoie
string
Exceptions
SodiumException
TypeError

Référencé par ParagonIE_Sodium_Compat\crypto_sign_ed25519_pk_to_curve25519().

◆ publickey()

static publickey ( $keypair )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_publickey().

◆ secretkey()

static secretkey ( $keypair )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_secretkey().

◆ sign_detached()

static sign_detached | ( | $message,
 |  | $sk
 | ) |
static

Références $message, ParagonIE_Sodium_Compat\memzero(), et null.

Référencé par ParagonIE_Sodium_Crypto32\sign_detached().

◆ sk_to_pk()

static sk_to_pk ( $sk )
static

Documentation des champs

◆ KEYPAIR_BYTES

const KEYPAIR_BYTES = 96

◆ SEED_BYTES

const SEED_BYTES = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core32/Ed25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_HChaCha20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_HChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_HChaCha20:
ParagonIE_Sodium_Core32_ChaCha20 ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_XChaCha20

Fonctions membres publiques statiques

static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_ChaCha20
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_HChaCha20

Documentation des fonctions membres

◆ hChaCha20()

static hChaCha20 | ( | $in = '',
 |  | $key = '',
 |  | $c = null
 | ) |
static
Paramètres
string | $in
string | $key
string | null | $c
Renvoie
string
Exceptions
SodiumException
TypeError

Références $c, $key, ParagonIE_Sodium_Core32_Int32\fromReverseString(), et null.

Référencé par ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), et ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_push().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/HChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_HSalsa20

Référence de la classe ParagonIE_Sodium_Core32_HSalsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_HSalsa20:
ParagonIE_Sodium_Core32_Salsa20 ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_XSalsa20

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_Salsa20
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Champs de données hérités de ParagonIE_Sodium_Core32_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_HSalsa20

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/HSalsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Int32

Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Int32

Fonctions membres publiques

__construct ($array=array(0, 0), $unsignedInt=false)
addInt32 (ParagonIE_Sodium_Core32_Int32 $addend)
mulIntFast ($int)
mulInt32Fast (ParagonIE_Sodium_Core32_Int32 $right)
isGreaterThan ($b=0)
isLessThanInt ($b=0)
setUnsignedInt ($bool=false)
xorInt32 (ParagonIE_Sodium_Core32_Int32 $b)
toArray ()
toString ()
toInt ()
toInt32 ()
toInt64 ()
toReverseString ()
__toString ()

Fonctions membres publiques statiques

static | fromString ($string)
static | fromReverseString ($string)

Champs de données

$limbs = array(0, 0)
$overflow = 0
$unsignedInt = false

Description détaillée

Class ParagonIE_Sodium_Core32_Int32

Encapsulates a 32-bit integer.

These are immutable. It always returns a new instance.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $array = array(0, 0),
 |  | $unsignedInt = false
 | ) |

ParagonIE_Sodium_Core32_Int32 constructor.

Paramètres
array | $array
bool | $unsignedInt

Références $unsignedInt.

Documentation des fonctions membres

◆ __toString()

__toString ( )
Renvoie
string

Références toString().

◆ addInt32()

addInt32 ( ParagonIE_Sodium_Core32_Int32 $addend )

Adds two int32 objects

Paramètres
ParagonIE_Sodium_Core32_Int32 $addend
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $return, et $unsignedInt.

◆ fromReverseString()

static fromReverseString ( $string )
static
Paramètres
string $string
Renvoie
self
Exceptions
SodiumException
TypeError

Références $return, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Core32_ChaCha20_IetfCtx\__construct(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\__construct(), ParagonIE_Sodium_Core32_Poly1305_State\__construct(), et ParagonIE_Sodium_Core32_HChaCha20\hChaCha20().

◆ fromString()

static fromString ( $string )
static
Paramètres
string $string
Renvoie
self
Exceptions
SodiumException
TypeError

Références $return, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ isGreaterThan()

isGreaterThan ( $b = 0 )
Paramètres
int $b
Renvoie
bool

Références $b.

◆ isLessThanInt()

isLessThanInt ( $b = 0 )
Paramètres
int $b
Renvoie
bool

Références $b.

◆ mulInt32Fast()

mulInt32Fast ( ParagonIE_Sodium_Core32_Int32 $right )
Paramètres
ParagonIE_Sodium_Core32_Int32 $right
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $b, $c, $i, et $return.

◆ mulIntFast()

mulIntFast ( $int )
Paramètres
int $int
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $b, $c, $i, $return, et $unsignedInt.

◆ setUnsignedInt()

setUnsignedInt ( $bool = false )
Paramètres
bool $bool
Renvoie
self

Références $this.

◆ toArray()

toArray ( )
Renvoie
array<int, int>

◆ toInt()

toInt ( )
Renvoie
int

◆ toInt32()

toInt32 ( )
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $return, et $unsignedInt.

◆ toInt64()

toInt64 ( )
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $overflow, $return, et $unsignedInt.

◆ toReverseString()

toReverseString ( )
Renvoie
string
Exceptions
TypeError

Références ParagonIE_Sodium_Core_Util\intToChr().

◆ toString()

toString ( )
Renvoie
string
Exceptions
TypeError

Références ParagonIE_Sodium_Core_Util\intToChr().

Référencé par __toString().

◆ xorInt32()

xorInt32 ( ParagonIE_Sodium_Core32_Int32 $b )

XOR this 32-bit integer with another.

Paramètres
ParagonIE_Sodium_Core32_Int32 $b
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $b, $return, $this, et $unsignedInt.

Documentation des champs

◆ $limbs

$limbs = array(0, 0)

◆ $overflow

$overflow = 0

Référencé par toInt64().

◆ $unsignedInt

$unsignedInt = false

Référencé par __construct(), addInt32(), mulIntFast(), toInt32(), toInt64(), et xorInt32().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Int32.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Int64

Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Int64

Fonctions membres publiques

__construct ($array=array(0, 0, 0, 0), $unsignedInt=false)
addInt64 (ParagonIE_Sodium_Core32_Int64 $addend)
isGreaterThan ($b=0)
isLessThanInt ($b=0)
mulIntFast ($int)
mulInt64Fast (ParagonIE_Sodium_Core32_Int64 $right)
orInt64 (ParagonIE_Sodium_Core32_Int64 $b)
xorInt64 (ParagonIE_Sodium_Core32_Int64 $b)
toInt ()
toArray ()
toInt32 ()
toInt64 ()
setUnsignedInt ($bool=false)
toString ()
toReverseString ()
__toString ()

Fonctions membres publiques statiques

static | fromInts ($low, $high)
static | fromInt ($low)
static | fromString ($string)
static | fromReverseString ($string)

Champs de données

$limbs = array(0, 0, 0, 0)
$overflow = 0
$unsignedInt = false

Description détaillée

Class ParagonIE_Sodium_Core32_Int64

Encapsulates a 64-bit integer.

These are immutable. It always returns a new instance.

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $array = array(0, 0, 0, 0),
 |  | $unsignedInt = false
 | ) |

ParagonIE_Sodium_Core32_Int64 constructor.

Paramètres
array | $array
bool | $unsignedInt

Références $unsignedInt.

Documentation des fonctions membres

◆ __toString()

__toString ( )
Renvoie
string

Références toString().

◆ addInt64()

addInt64 ( ParagonIE_Sodium_Core32_Int64 $addend )

Adds two int64 objects

Paramètres
ParagonIE_Sodium_Core32_Int64 $addend
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $return, et $unsignedInt.

◆ fromInt()

static fromInt ( $low )
static
Paramètres
int $low
Renvoie
self
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\declareScalarType().

◆ fromInts()

static fromInts | ( | $low,
 |  | $high
 | ) |
static
Paramètres
int | $low
int | $high
Renvoie
self
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\declareScalarType().

Référencé par ParagonIE_Sodium_Core32_BLAKE2b\new64(), et ParagonIE_Sodium_Core32_SipHash\sipHash24().

◆ fromReverseString()

static fromReverseString ( $string )
static
Paramètres
string $string
Renvoie
self
Exceptions
SodiumException
TypeError

Références $return, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Core32_SipHash\sipHash24(), et ParagonIE_Sodium_Core32_BLAKE2b\stringToContext().

◆ fromString()

static fromString ( $string )
static
Paramètres
string $string
Renvoie
self
Exceptions
SodiumException
TypeError

Références $return, ParagonIE_Sodium_Core_Util\declareScalarType(), et ParagonIE_Sodium_Core_Util\strlen().

◆ isGreaterThan()

isGreaterThan ( $b = 0 )
Paramètres
int $b
Renvoie
bool

Références $b.

◆ isLessThanInt()

isLessThanInt ( $b = 0 )
Paramètres
int $b
Renvoie
bool

Références $b.

◆ mulInt64Fast()

mulInt64Fast ( ParagonIE_Sodium_Core32_Int64 $right )
Paramètres
ParagonIE_Sodium_Core32_Int64 $right
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $b, $c, $i, et $return.

◆ mulIntFast()

mulIntFast ( $int )
Paramètres
int $int
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $b, $c, $i, $return, et $unsignedInt.

◆ orInt64()

orInt64 ( ParagonIE_Sodium_Core32_Int64 $b )

OR this 64-bit integer with another.

Paramètres
ParagonIE_Sodium_Core32_Int64 $b
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $b, $return, $this, et $unsignedInt.

◆ setUnsignedInt()

setUnsignedInt ( $bool = false )
Paramètres
bool $bool
Renvoie
self

Références $this.

◆ toArray()

toArray ( )
Renvoie
array<int, int>

◆ toInt()

toInt ( )
Renvoie
int

◆ toInt32()

toInt32 ( )
Renvoie
ParagonIE_Sodium_Core32_Int32

Références $return, et $unsignedInt.

◆ toInt64()

toInt64 ( )
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $return, et $unsignedInt.

◆ toReverseString()

toReverseString ( )
Renvoie
string
Exceptions
TypeError

Références ParagonIE_Sodium_Core_Util\intToChr().

◆ toString()

toString ( )
Renvoie
string
Exceptions
TypeError

Références ParagonIE_Sodium_Core_Util\intToChr().

Référencé par __toString().

◆ xorInt64()

xorInt64 ( ParagonIE_Sodium_Core32_Int64 $b )

XOR this 64-bit integer with another.

Paramètres
ParagonIE_Sodium_Core32_Int64 $b
Renvoie
ParagonIE_Sodium_Core32_Int64

Références $b, $return, $this, et $unsignedInt.

Référencé par ParagonIE_Sodium_Core32_BLAKE2b\xor64().

Documentation des champs

◆ $limbs

$limbs = array(0, 0, 0, 0)

◆ $overflow

$overflow = 0

◆ $unsignedInt

$unsignedInt = false

Référencé par __construct(), addInt64(), mulIntFast(), orInt64(), toInt32(), toInt64(), et xorInt64().

La documentation de cette classe a été générée à partir du fichier suivant :
  • Int64.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Poly1305

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Poly1305
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Poly1305:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | onetimeauth ($m, $key)
static | onetimeauth_verify ($mac, $m, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const BLOCK_SIZE = 16

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_Poly1305

Documentation des fonctions membres

◆ onetimeauth()

static onetimeauth | ( | $m,
 |  | $key
 | ) |
static

Références $key, et $state.

◆ onetimeauth_verify()

static onetimeauth_verify | ( | $mac,
 |  | $m,
 |  | $key
 | ) |
static

Références $key, et $state.

Documentation des champs

◆ BLOCK_SIZE

const BLOCK_SIZE = 16
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Poly1305.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Poly1305_State

Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core32_Poly1305_State
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Poly1305_State:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques

__construct ($key='')

Champs de données

$h
$r
$pad

Attributs protégés

$buffer = array()
$final = false
$leftover = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_Poly1305_State

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $key = '' )

ParagonIE_Sodium_Core32_Poly1305_State constructor.

Références $key, et ParagonIE_Sodium_Core32_Int32\fromReverseString().

Documentation des champs

◆ $buffer

$buffer = array()
protected

◆ $final

$final = false
protected

◆ $h

$h

◆ $leftover

$leftover = 0
protected

◆ $pad

$pad

◆ $r

$r
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/Poly1305/State.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Salsa20

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core32_Salsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Salsa20:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_HSalsa20 ParagonIE_Sodium_Core32_XSalsa20

Fonctions membres publiques statiques

static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const ROUNDS = 20

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_Salsa20

Documentation des fonctions membres

◆ salsa20()

static salsa20 | ( | $len,
 |  | $nonce,
 |  | $key
 | ) |
static

Références $c, $i, $key, ParagonIE_Sodium_Compat\memzero(), et null.

◆ salsa20_xor()

static salsa20_xor | ( | $message,
 |  | $nonce,
 |  | $key
 | ) |
static

Références $key, et $message.

◆ salsa20_xor_ic()

static salsa20_xor_ic | ( | $m,
 |  | $n,
 |  | $ic,
 |  | $k
 | ) |
static

Références $c, $i, $n, ParagonIE_Sodium_Compat\memzero(), et null.

Documentation des champs

◆ ROUNDS

const ROUNDS = 20
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core32/Salsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_SecretStream_State

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core32_SecretStream_State

Fonctions membres publiques

__construct ($key, $nonce=null)
counterReset ()
getKey ()
getCounter ()
getNonce ()
getCombinedNonce ()
incrementCounter ()
needsRekey ()
rekey ($newKeyAndNonce)
xorNonce ($str)
toString ()

Fonctions membres publiques statiques

static fromString ($string)

Attributs protégés

$key
$counter
$nonce
$_pad

Description détaillée

Class ParagonIE_Sodium_Core32_SecretStream_State

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key,
 |  | $nonce = null
 | ) |

ParagonIE_Sodium_Core32_SecretStream_State constructor.

Paramètres
string | $key
string | null | $nonce

Références $key, $nonce, et counter.

Documentation des fonctions membres

◆ counterReset()

counterReset ( )
Renvoie
self

Références $this, et counter.

◆ fromString()

static fromString ( $string )
static
Paramètres
string $string
Renvoie
self

Références $state, et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_rekey().

◆ getCombinedNonce()

getCombinedNonce ( )
Renvoie
string

Références getCounter(), getNonce(), et ParagonIE_Sodium_Core_Util\substr().

◆ getCounter()

getCounter ( )
Renvoie
string

Références counter.

Référencé par getCombinedNonce(), et toString().

◆ getKey()

getKey ( )
Renvoie
string

Références $key.

◆ getNonce()

getNonce ( )
Renvoie
string

Références $nonce, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par getCombinedNonce(), et xorNonce().

◆ incrementCounter()

incrementCounter ( )
Renvoie
self

Références $counter, et $this.

◆ needsRekey()

needsRekey ( )
Renvoie
bool

Références counter.

◆ rekey()

rekey ( $newKeyAndNonce )
Paramètres
string $newKeyAndNonce
Renvoie
self

Références $this, et ParagonIE_Sodium_Core_Util\substr().

◆ toString()

toString ( )
Renvoie
string

Références $_pad, et getCounter().

◆ xorNonce()

xorNonce ( $str )
Paramètres
string $str
Renvoie
self

Références $this, getNonce(), ParagonIE_Sodium_Core_Util\substr(), et ParagonIE_Sodium_Core_Util\xorStrings().

Documentation des champs

◆ $_pad

$_pad
protected

Référencé par toString().

◆ $counter

$counter
protected

Référencé par incrementCounter().

◆ $key

$key
protected

Référencé par __construct(), et getKey().

◆ $nonce

$nonce
protected

Référencé par __construct(), et getNonce().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/SecretStream/State.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_SipHash

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_SipHash
+ Graphe d'héritage de ParagonIE_Sodium_Core32_SipHash:
ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | sipRound (array $v)
static | sipHash24 ($in, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_SodiumCompat_Core32_SipHash

Only uses 32-bit arithmetic, while the original SipHash used 64-bit integers

Documentation des fonctions membres

◆ sipHash24()

static sipHash24 | ( | $in,
 |  | $key
 | ) |
static

Références $b, $key, ParagonIE_Sodium_Core32_Int64\fromInts(), et ParagonIE_Sodium_Core32_Int64\fromReverseString().

Référencé par ParagonIE_Sodium_Compat\crypto_shorthash().

◆ sipRound()

static sipRound ( array $v )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/SipHash.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_Util

Référence de la classe ParagonIE_Sodium_Core32_Util
+ Graphe d'héritage de ParagonIE_Sodium_Core32_Util:
ParagonIE_Sodium_Core_Util ParagonIE_Sodium_Core32_ChaCha20 ParagonIE_Sodium_Core32_ChaCha20_Ctx ParagonIE_Sodium_Core32_Curve25519_H ParagonIE_Sodium_Core32_Poly1305 ParagonIE_Sodium_Core32_Poly1305_State ParagonIE_Sodium_Core32_Salsa20 ParagonIE_Sodium_Core32_SipHash ParagonIE_Sodium_Core32_HChaCha20 ParagonIE_Sodium_Core32_ChaCha20_IetfCtx ParagonIE_Sodium_Core32_Curve25519 ParagonIE_Sodium_Core32_HSalsa20 ParagonIE_Sodium_Core32_XChaCha20 ParagonIE_Sodium_Core32_Ed25519 ParagonIE_Sodium_Core32_X25519 ParagonIE_Sodium_Core32_XSalsa20

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Util

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core32/Util.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_X25519

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_X25519
+ Graphe d'héritage de ParagonIE_Sodium_Core32_X25519:
ParagonIE_Sodium_Core32_Curve25519 ParagonIE_Sodium_Core32_Curve25519_H ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | edwards_to_montgomery (ParagonIE_Sodium_Core32_Curve25519_Fe $edwardsY, ParagonIE_Sodium_Core32_Curve25519_Fe $edwardsZ)
static | crypto_scalarmult_curve25519_ref10_base ($n)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_isnegative (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_neg (ParagonIE_Sodium_Core32_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core32_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core32_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core32_Curve25519_Fe $f, ParagonIE_Sodium_Core32_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | cmov (ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp $u, $b)
static | ge_select ($pos=0, $b=0)
static | ge_sub (ParagonIE_Sodium_Core32_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core32_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core32_Curve25519_Ge_P2 $h)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core32_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1

Description détaillée

Class ParagonIE_Sodium_Core32_X25519

Documentation des fonctions membres

◆ crypto_scalarmult_curve25519_ref10_base()

static crypto_scalarmult_curve25519_ref10_base ( $n )
static

Références $n.

Référencé par ParagonIE_Sodium_Crypto32\scalarmult_base().

◆ edwards_to_montgomery()

static edwards_to_montgomery | ( | ParagonIE_Sodium_Core32_Curve25519_Fe | $edwardsY,
 |  | ParagonIE_Sodium_Core32_Curve25519_Fe | $edwardsZ
 | ) |  |
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/X25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_XChaCha20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_XChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_XChaCha20:
ParagonIE_Sodium_Core32_HChaCha20 ParagonIE_Sodium_Core32_ChaCha20 ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | stream ($len=64, $nonce='', $key='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_HChaCha20
static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_ChaCha20
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_XChaCha20

Documentation des fonctions membres

◆ ietfStreamXorIc()

static ietfStreamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

◆ stream()

static stream | ( | $len = 64,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xchacha20().

◆ streamXorIc()

static streamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core32/XChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core32_XSalsa20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core32_XSalsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core32_XSalsa20:
ParagonIE_Sodium_Core32_HSalsa20 ParagonIE_Sodium_Core32_Salsa20 ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | xsalsa20 ($len, $nonce, $key)
static | xsalsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core32_Salsa20
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Champs de données hérités de ParagonIE_Sodium_Core32_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core32_XSalsa20

Documentation des fonctions membres

◆ xsalsa20()

static xsalsa20 | ( | $len,
 |  | $nonce,
 |  | $key
 | ) |
static

Expand a key and nonce into an xsalsa20 keystream.

Références $key.

Référencé par ParagonIE_Sodium_Compat\crypto_stream().

◆ xsalsa20_xor()

static xsalsa20_xor | ( | $message,
 |  | $nonce,
 |  | $key
 | ) |
static

Encrypt a string with XSalsa20. Doesn't provide integrity.

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xor().

La documentation de cette classe a été générée à partir du fichier suivant :
  • 2/XSalsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Base64_Common

Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_Base64_Common

Fonctions membres publiques statiques

static | encode ($src)
static | encodeUnpadded ($src)

Fonctions membres protégées statiques

static | decode6Bits ($src)
static | encode6Bits ($src)

Description détaillée

Class ParagonIE_Sodium_Core_Base64

Copyright (c) 2016 - 2018 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

We have to copy/paste the contents into the variant files because PHP 5.2 doesn't support late static binding, and we have no better workaround available that won't break PHP 7+. Therefore, we're forced to duplicate code.

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( $src )
staticabstractprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [A-Z] [a-z] [0-9] + / 0x41-0x5a, 0x61-0x7a, 0x30-0x39, 0x2b, 0x2f

Paramètres
int $src
Renvoie
int

◆ encode()

static encode ( $src )
static

Encode into Base64

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError

◆ encode6Bits()

static encode6Bits ( $src )
staticabstractprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string

◆ encodeUnpadded()

static encodeUnpadded ( $src )
static

Encode into Base64, no = padding

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/Base64/Common.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Base64_Original

Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_Base64_Original

Fonctions membres publiques statiques

static | encode ($src)
static | encodeUnpadded ($src)

Fonctions membres protégées statiques

static | decode6Bits ($src)
static | encode6Bits ($src)

Description détaillée

Class ParagonIE_Sodium_Core_Base64

Copyright (c) 2016 - 2018 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [A-Z] [a-z] [0-9] + / 0x41-0x5a, 0x61-0x7a, 0x30-0x39, 0x2b, 0x2f

Paramètres
int $src
Renvoie
int

◆ encode()

static encode ( $src )
static

Encode into Base64

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError

◆ encode6Bits()

static encode6Bits ( $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string

◆ encodeUnpadded()

static encodeUnpadded ( $src )
static

Encode into Base64, no = padding

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • Original.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Base64_UrlSafe

Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_Base64_UrlSafe

Fonctions membres publiques statiques

static | encode ($src)
static | encodeUnpadded ($src)

Fonctions membres protégées statiques

static | decode6Bits ($src)
static | encode6Bits ($src)

Description détaillée

Class ParagonIE_Sodium_Core_Base64UrlSafe

Copyright (c) 2016 - 2018 Paragon Initiative Enterprises. Copyright (c) 2014 Steve "Sc00bz" Thomas (steve at tobtu dot com)

Documentation des fonctions membres

◆ decode6Bits()

static decode6Bits ( $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 6-bit integers into 8-bit integers.

Base64 character set: [A-Z] [a-z] [0-9] + / 0x41-0x5a, 0x61-0x7a, 0x30-0x39, 0x2b, 0x2f

Paramètres
int $src
Renvoie
int

◆ encode()

static encode ( $src )
static

Encode into Base64

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError

◆ encode6Bits()

static encode6Bits ( $src )
staticprotected

Uses bitwise operators instead of table-lookups to turn 8-bit integers into 6-bit integers.

Paramètres
int $src
Renvoie
string

◆ encodeUnpadded()

static encodeUnpadded ( $src )
static

Encode into Base64, no = padding

Base64 character set "[A-Z][a-z][0-9]+/"

Paramètres
string $src
Renvoie
string
Exceptions
TypeError
La documentation de cette classe a été générée à partir du fichier suivant :
  • UrlSafe.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_BLAKE2b

Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques | Attributs protégés statiques
Référence de la classe ParagonIE_Sodium_Core_BLAKE2b
+ Graphe d'héritage de ParagonIE_Sodium_Core_BLAKE2b:
ParagonIE_Sodium_Core_Util BLAKE2b

Fonctions membres publiques statiques

static | new64 ($high, $low)
static | pseudoConstructor ()
static | G ($r, $i, $a, $b, $c, $d, SplFixedArray $v, SplFixedArray $m)
static | increment_counter ($ctx, $inc)
static | update (SplFixedArray $ctx, SplFixedArray $p, $plen)
static | finish (SplFixedArray $ctx, SplFixedArray $out)
static | init ( $key=null, $outlen=64, $salt=null, $personal=null)
static | stringToSplFixedArray ($str='')
static | stringToContext ($string)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const | BLOCKBYTES = 128
const | OUTBYTES = 64
const | KEYBYTES = 64

Fonctions membres protégées statiques

static | to64 ($num)
static | add64 ($x, $y)
static | add364 ($x, $y, $z)
static | xor64 (SplFixedArray $x, SplFixedArray $y)
static | flatten64 ($x)
static | context ()
static | compress (SplFixedArray $ctx, SplFixedArray $buf)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Attributs protégés statiques

static | $iv
static | $sigma

Description détaillée

Class ParagonIE_Sodium_Core_BLAKE2b

Based on the work of Devi Mandiri in devi/salt.

Documentation des fonctions membres

◆ add364()

static add364 | ( | $x,
 |  | $y,
 |  | $z
 | ) |
staticprotected

◆ add64()

static add64 | ( | $x,
 |  | $y
 | ) |
staticprotected

Adds two 64-bit integers together, returning their sum as a SplFixedArray containing two 32-bit integers (representing a 64-bit integer).

◆ compress()

static compress | ( | SplFixedArray | $ctx,
 |  | SplFixedArray | $buf
 | ) |  |
staticprotected

Références $i, et $r.

◆ context()

static context ( )
staticprotected

Returns a fresh BLAKE2 context.

Références $i.

◆ finish()

static finish | ( | SplFixedArray | $ctx,
 |  | SplFixedArray | $out
 | ) |  |
static

Références $i, et SplFixedArray\getSize().

◆ flatten64()

static flatten64 ( $x )
staticprotected

◆ G()

static G | ( |  | $r,
 |  |  | $i,
 |  |  | $a,
 |  |  | $b,
 |  |  | $c,
 |  |  | $d,
 |  | SplFixedArray | $v,
 |  | SplFixedArray | $m
 | ) |  |
static

Références $b, $c, $i, et $r.

◆ increment_counter()

static increment_counter | ( | $ctx,
 |  | $inc
 | ) |
static

◆ init()

static init | ( | $key = null,
 |  | $outlen = 64,
 |  | $salt = null,
 |  | $personal = null
 | ) |
static

Références $i, $key, et null.

◆ new64()

static new64 | ( | $high,
 |  | $low
 | ) |
static

Turn two 32-bit integers into a fixed array representing a 64-bit integer.

◆ pseudoConstructor()

static pseudoConstructor ( )
static

This just sets the $iv static variable.

◆ stringToContext()

static stringToContext ( $string )
static

Creates an SplFixedArray containing other SplFixedArray elements, from a string (compatible with {init, update, final})

Références $i, et SplFixedArray\fromArray().

◆ stringToSplFixedArray()

static stringToSplFixedArray ( $str = '' )
static

Convert a string into an SplFixedArray of integers

Références SplFixedArray\fromArray().

◆ to64()

static to64 ( $num )
staticprotected

Convert an arbitrary number into an SplFixedArray of two 32-bit integers that represents a 64-bit integer.

◆ update()

static update | ( | SplFixedArray | $ctx,
 |  | SplFixedArray | $p,
 |  |  | $plen
 | ) |  |
static

Références $i, et Joomla\Database\Query\$offset.

◆ xor64()

static xor64 | ( | SplFixedArray | $x,
 |  | SplFixedArray | $y
 | ) |  |
staticprotected

Documentation des champs

◆ $iv

$iv
staticprotected

◆ $sigma

$sigma
staticprotected
Valeur initiale :
= array(
array( 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15),
array( 14, 10, 4, 8, 9, 15, 13, 6, 1, 12, 0, 2, 11, 7, 5, 3),
array( 11, 8, 12, 0, 5, 2, 15, 13, 10, 14, 3, 6, 7, 1, 9, 4),
array( 7, 9, 3, 1, 13, 12, 11, 14, 2, 6, 5, 10, 4, 0, 15, 8),
array( 9, 0, 5, 7, 2, 4, 10, 15, 14, 1, 11, 12, 6, 8, 3, 13),
array( 2, 12, 6, 10, 0, 11, 8, 3, 4, 13, 7, 5, 15, 14, 1, 9),
array( 12, 5, 1, 15, 14, 13, 4, 10, 0, 7, 6, 3, 9, 2, 8, 11),
array( 13, 11, 7, 14, 12, 1, 3, 9, 5, 0, 15, 4, 8, 6, 2, 10),
array( 6, 15, 14, 9, 11, 3, 0, 8, 12, 2, 13, 7, 1, 4, 10, 5),
array( 10, 2, 8, 4, 7, 6, 1, 5, 15, 11, 9, 14, 3, 12, 13 , 0),
array( 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15),
array( 14, 10, 4, 8, 9, 15, 13, 6, 1, 12, 0, 2, 11, 7, 5, 3)
)

◆ BLOCKBYTES

const BLOCKBYTES = 128

◆ KEYBYTES

const KEYBYTES = 64

◆ OUTBYTES

const OUTBYTES = 64
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/BLAKE2b.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_ChaCha20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_ChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core_ChaCha20:
ParagonIE_Sodium_Core_Util ChaCha20 ParagonIE_Sodium_Core_HChaCha20 HChaCha20 ParagonIE_Sodium_Core_XChaCha20 XChaCha20

Fonctions membres publiques statiques

static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_ChaCha20

Documentation des fonctions membres

◆ ietfStream()

static ietfStream | ( | $len,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

◆ ietfStreamXorIc()

static ietfStreamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

Référencé par ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_rekey().

◆ rotate()

static rotate | ( | $v,
 |  | $n
 | ) |
static

Bitwise left rotation

Références $n.

◆ stream()

static stream | ( | $len = 64,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

◆ streamXorIc()

static streamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/ChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_ChaCha20_Ctx

Fonctions membres publiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core_ChaCha20_Ctx
+ Graphe d'héritage de ParagonIE_Sodium_Core_ChaCha20_Ctx:
ParagonIE_Sodium_Core_Util Ctx ParagonIE_Sodium_Core_ChaCha20_IetfCtx IetfCtx

Fonctions membres publiques

__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)

Attributs protégés

$container

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_ChaCha20_Ctx

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key = '',
 |  | $iv = '',
 |  | $counter = ''
 | ) |

ParagonIE_Sodium_Core_ChaCha20_Ctx constructor.

Références $key.

Documentation des fonctions membres

◆ offsetExists()

offsetExists ( $offset )

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Références Joomla\Database\Query\$offset, et null.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Références Joomla\Database\Query\$offset, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Références Joomla\Database\Query\$offset.

Documentation des champs

◆ $container

$container
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/ChaCha20/Ctx.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_ChaCha20_IetfCtx

Fonctions membres publiques
Référence de la classe ParagonIE_Sodium_Core_ChaCha20_IetfCtx
+ Graphe d'héritage de ParagonIE_Sodium_Core_ChaCha20_IetfCtx:
ParagonIE_Sodium_Core_ChaCha20_Ctx ParagonIE_Sodium_Core_Util IetfCtx

Fonctions membres publiques

__construct ($key='', $iv='', $counter='')
- Fonctions membres publiques hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
__construct ($key='', $iv='', $counter='')
offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés hérités de ParagonIE_Sodium_Core_ChaCha20_Ctx
$container

Description détaillée

Class ParagonIE_Sodium_Core_ChaCha20_IetfCtx

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key = '',
 |  | $iv = '',
 |  | $counter = ''
 | ) |

ParagonIE_Sodium_Core_ChaCha20_IetfCtx constructor.

Références $key, et Symfony\Contracts\Service\__construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/ChaCha20/IetfCtx.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_Curve25519
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519:
ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util Curve25519 ParagonIE_Sodium_Core_Ed25519 ParagonIE_Sodium_Core_X25519 Ed25519 ParagonIE_Sodium_Core_Ristretto255 X25519

Fonctions membres publiques statiques

static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519

Implements Curve25519 core functions

Based on the ref10 curve25519 code provided by libsodium

https://github.com/jedisct1/libsodium/blob/master/src/libsodium/crypto_core/curve25519/ref10/curve25519_ref10.c

Documentation des fonctions membres

◆ clamp()

static clamp ( $s )
static
Paramètres
string $s
Renvoie
string

◆ cmov()

static cmov | ( | ParagonIE_Sodium_Core_Curve25519_Ge_Precomp | $t,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Precomp | $u,
 |  |  | $b
 | ) |  |
static

Conditional move

Références $b.

◆ equal()

static equal | ( | $b,
 |  | $c
 | ) |
static

Références $b, et $c.

◆ fe_0()

static fe_0 ( )
static

Get a field element of size 10 with a value of 0

◆ fe_1()

static fe_1 ( )
static

Get a field element of size 10 with a value of 1

◆ fe_copy()

static fe_copy ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Create a copy of a field element.

◆ fe_frombytes()

static fe_frombytes ( $s )
static

Give: 32-byte string. Receive: A field element object to use for internal calculations.

◆ fe_invert()

static fe_invert ( ParagonIE_Sodium_Core_Curve25519_Fe $Z )
static

Références $i.

◆ fe_isnegative()

static fe_isnegative ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Is a field element negative? (1 = yes, 0 = no. Used in calculations.)

◆ fe_mul()

static fe_mul | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $f,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $g
 | ) |  |
static

Multiply two field elements

h = f * g

Références $g.

◆ fe_neg()

static fe_neg ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Get the negative values for each piece of the field element.

h = -f

Références $i.

◆ fe_normalize()

static fe_normalize ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Ensure limbs are less than 28 bits long to prevent float promotion.

This uses a constant-time conditional swap under the hood.

Paramètres
ParagonIE_Sodium_Core_Curve25519_Fe $f
Renvoie
ParagonIE_Sodium_Core_Curve25519_Fe

Références $b, $g, et $i.

◆ fe_pow22523()

static fe_pow22523 ( ParagonIE_Sodium_Core_Curve25519_Fe $z )
static

Références $i.

◆ fe_sq()

static fe_sq ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Square a field element

h = f * f

◆ fe_sq2()

static fe_sq2 ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static

Square and double a field element

h = 2 * f * f

◆ fe_sub()

static fe_sub | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $f,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $g
 | ) |  |
static

Subtract two field elements.

h = f - g

Preconditions: |f| bounded by 1.1*2^25,1.1*2^24,1.1*2^25,1.1*2^24,etc. |g| bounded by 1.1*2^25,1.1*2^24,1.1*2^25,1.1*2^24,etc.

Postconditions: |h| bounded by 1.1*2^26,1.1*2^25,1.1*2^26,1.1*2^25,etc.

Références $g.

◆ ge_add()

static ge_add | ( | ParagonIE_Sodium_Core_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $q
 | ) |  |
static

Add two group elements.

r = p + q

Références $r.

◆ ge_cmov8_cached()

static ge_cmov8_cached | ( | array | $cached,
 |  |  | $b
 | ) |  |
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Ge_Cached[] | $cached
int | $b
Renvoie
ParagonIE_Sodium_Core_Curve25519_Ge_Cached
Exceptions
SodiumException

Références $b.

◆ ge_cmov_cached()

static ge_cmov_cached | ( | ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $t,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $u,
 |  |  | $b
 | ) |  |
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $t
ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $u
int | $b
Renvoie
ParagonIE_Sodium_Core_Curve25519_Ge_Cached

Références $b.

◆ ge_madd()

static ge_madd | ( | ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 | $R,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Precomp | $q
 | ) |  |
static

Références $r.

◆ ge_msub()

static ge_msub | ( | ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 | $R,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Precomp | $q
 | ) |  |
static

Références $r.

◆ ge_p1p1_to_p2()

static ge_p1p1_to_p2 ( ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p )
static

Références $r.

◆ ge_p1p1_to_p3()

static ge_p1p1_to_p3 ( ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p )
static

Références $r.

◆ ge_p2_0()

static ge_p2_0 ( )
static

◆ ge_p2_dbl()

static ge_p2_dbl ( ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p )
static

Références $r.

◆ ge_p3_0()

static ge_p3_0 ( )
static

◆ ge_p3_dbl()

static ge_p3_dbl ( ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p )
static

◆ ge_p3_to_p2()

static ge_p3_to_p2 ( ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p )
static

◆ ge_p3_tobytes()

static ge_p3_tobytes ( ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h )
static

◆ ge_precomp_0()

static ge_precomp_0 ( )
static
Renvoie
ParagonIE_Sodium_Core_Curve25519_Ge_Precomp

◆ ge_sub()

static ge_sub | ( | ParagonIE_Sodium_Core_Curve25519_Ge_P3 | $p,
 |  | ParagonIE_Sodium_Core_Curve25519_Ge_Cached | $q
 | ) |  |
static

Subtract two group elements.

r = p - q

Références $r.

◆ ge_tobytes()

static ge_tobytes ( ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h )
static

Convert a group element to a byte string.

Paramètres
ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h
Renvoie
string
Exceptions
SodiumException
TypeError

◆ negative()

static negative ( $char )
static

◆ sc25519_invert()

static sc25519_invert ( $s )
static
Paramètres
string $s
Renvoie
string

◆ sc25519_mul()

static sc25519_mul | ( | $a,
 |  | $b
 | ) |
static
Paramètres
string | $a
string | $b
Renvoie
string

Références $b.

◆ sc25519_sq()

static sc25519_sq ( $s )
static
Paramètres
string $s
Renvoie
string

◆ sc25519_sqmul()

static sc25519_sqmul | ( | $s,
 |  | $n,
 |  | $a
 | ) |
static
Paramètres
string | $s
int | $n
string | $a
Renvoie
string

Références $i, et $n.

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/Curve25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Fe

Fonctions membres publiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Fe
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Fe:
Fe

Fonctions membres publiques

offsetSet ($offset, $value)
offsetExists ($offset)
offsetUnset ($offset)
offsetGet ($offset)
__debugInfo ()

Attributs protégés

$container = array()
$size = 10

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Fe

This represents a Field Element

Documentation des fonctions membres

◆ __debugInfo()

__debugInfo ( )

◆ offsetExists()

offsetExists ( $offset )

Références Joomla\Database\Query\$offset.

◆ offsetGet()

offsetGet ( $offset )

Références Joomla\Database\Query\$offset.

◆ offsetSet()

offsetSet | ( | $offset,
 |  | $value
 | ) |

Références Joomla\Database\Query\$offset, et $value.

◆ offsetUnset()

offsetUnset ( $offset )

Références Joomla\Database\Query\$offset.

Documentation des champs

◆ $container

$container = array()
protected

◆ $size

$size = 10
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Fe.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_Cached

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_Cached
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Ge_Cached:
Cached

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core_Curve25519_Fe $YplusX=null, ParagonIE_Sodium_Core_Curve25519_Fe $YminusX=null, ParagonIE_Sodium_Core_Curve25519_Fe $Z=null, ParagonIE_Sodium_Core_Curve25519_Fe $T2d=null)

Champs de données

$YplusX
$YminusX
$Z
$T2d

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Ge_Cached

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $YplusX = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $YminusX = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $Z = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $T2d = null
 | ) |  |

ParagonIE_Sodium_Core_Curve25519_Ge_Cached constructor.

Références $T2d, $YminusX, $YplusX, $Z, et null.

Documentation des champs

◆ $T2d

$T2d

Référencé par __construct().

◆ $YminusX

$YminusX

Référencé par __construct().

◆ $YplusX

$YplusX

Référencé par __construct().

◆ $Z

$Z

Référencé par __construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Ge/Cached.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P1p1

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P1p1
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Ge_P1p1:
P1p1

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null, ParagonIE_Sodium_Core_Curve25519_Fe $t=null)

Champs de données

$X
$Y
$Z
$T

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Ge_P1p1

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $z = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $t = null
 | ) |  |

ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 constructor.

Références null.

Documentation des champs

◆ $T

$T

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Ge/P1p1.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P2

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P2
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Ge_P2:
P2

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null)

Champs de données

$X
$Y
$Z

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Ge_P2

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $z = null
 | ) |  |

ParagonIE_Sodium_Core_Curve25519_Ge_P2 constructor.

Références null.

Documentation des champs

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Ge/P2.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P3

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_P3
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Ge_P3:
P3

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core_Curve25519_Fe $x=null, ParagonIE_Sodium_Core_Curve25519_Fe $y=null, ParagonIE_Sodium_Core_Curve25519_Fe $z=null, ParagonIE_Sodium_Core_Curve25519_Fe $t=null)

Champs de données

$X
$Y
$Z
$T

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Ge_P3

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $x = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $y = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $z = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $t = null
 | ) |  |

ParagonIE_Sodium_Core_Curve25519_Ge_P3 constructor.

Références null.

Documentation des champs

◆ $T

$T

◆ $X

$X

◆ $Y

$Y

◆ $Z

$Z
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Ge/P3.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_Precomp

Fonctions membres publiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_Ge_Precomp:
Precomp

Fonctions membres publiques

__construct (ParagonIE_Sodium_Core_Curve25519_Fe $yplusx=null, ParagonIE_Sodium_Core_Curve25519_Fe $yminusx=null, ParagonIE_Sodium_Core_Curve25519_Fe $xy2d=null)

Champs de données

$yplusx
$yminusx
$xy2d

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_Ge_Precomp

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $yplusx = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $yminusx = null,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $xy2d = null
 | ) |  |

ParagonIE_Sodium_Core_Curve25519_Ge_Precomp constructor.

Références $xy2d, $yminusx, $yplusx, et null.

Documentation des champs

◆ $xy2d

$xy2d

Référencé par __construct().

◆ $yminusx

$yminusx

Référencé par __construct().

◆ $yplusx

$yplusx

Référencé par __construct().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/Ge/Precomp.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Curve25519_H

Champs de données | Attributs protégés statiques
Référence de la classe ParagonIE_Sodium_Core_Curve25519_H
+ Graphe d'héritage de ParagonIE_Sodium_Core_Curve25519_H:
ParagonIE_Sodium_Core_Util H ParagonIE_Sodium_Core_Curve25519 Curve25519 ParagonIE_Sodium_Core_Ed25519 ParagonIE_Sodium_Core_X25519 Ed25519 ParagonIE_Sodium_Core_Ristretto255 X25519

Champs de données

const L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"

Attributs protégés statiques

static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Curve25519_H

This just contains the constants in the ref10/base.h file

Documentation des champs

◆ $base

$base
staticprotected

◆ $base2

$base2
staticprotected

◆ $d

$d
staticprotected
Valeur initiale :
= array(
-10913610,
13857413,
-15372611,
6949391,
114729,
-8787816,
-6275908,
-3247719,
-18696448,
-12055116
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), et ParagonIE_Sodium_Core_Ristretto255\ristretto255_point_is_canonical().

◆ $d2

$d2
staticprotected
Valeur initiale :
= array(
-21827239,
-5839606,
-30745221,
13898782,
229458,
15978800,
-12551817,
-6495438,
29715968,
9444199
)

◆ $invsqrtamd

$invsqrtamd
staticprotected
Valeur initiale :
= array(
6111485,
4156064,
-27798727,
12243468,
-25904040,
120897,
20826367,
-7060776,
6093568,
-1986012
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_p3_tobytes().

◆ $onemsqd

$onemsqd
staticprotected
Valeur initiale :
= array(
6275446,
-16617371,
-22938544,
-3773710,
11667077,
7397348,
-27922721,
1766195,
-24433858,
672203
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator().

◆ $sqdmone

$sqdmone
staticprotected
Valeur initiale :
= array(
15551795,
-11097455,
-13425098,
-10125071,
-11896535,
10178284,
-26634327,
4729244,
-5282110,
-10116402
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator().

◆ $sqrtadm1

$sqrtadm1
staticprotected
Valeur initiale :
= array(
24849947,
-153582,
-23613485,
6347715,
-21072328,
-667138,
-25271143,
-15367704,
-870347,
14525639
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator().

◆ $sqrtm1

$sqrtm1
staticprotected
Valeur initiale :
= array(
-32595792,
-7943725,
9377950,
3500415,
12389472,
-272473,
-25146209,
-2005654,
326686,
11406482
)

Référencé par ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_p3_tobytes(), et ParagonIE_Sodium_Core_Ristretto255\ristretto255_sqrt_ratio_m1().

◆ L

const L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Curve25519/H.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Ed25519

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Ed25519
+ Graphe d'héritage de ParagonIE_Sodium_Core_Ed25519:
ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util Ed25519 ParagonIE_Sodium_Core_Ristretto255

Fonctions membres publiques statiques

static | keypair ()
static | secretkey ($keypair)
static | publickey ($keypair)
static | pk_to_curve25519 ($pk)
static | sk_to_pk ($sk)
static | sign_detached ($message, $sk)
static | scalar_complement ($s)
static | scalar_random ()
static | scalar_negate ($s)
static | scalar_add ($a, $b)
static | scalar_sub ($x, $y)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const | KEYPAIR_BYTES = 96
const | SEED_BYTES = 32
const | SCALAR_BYTES = 32
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone

Description détaillée

Class ParagonIE_Sodium_Core_Ed25519

Documentation des fonctions membres

◆ keypair()

static keypair ( )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_keypair().

◆ pk_to_curve25519()

static pk_to_curve25519 ( $pk )
static
Paramètres
string $pk
Renvoie
string
Exceptions
SodiumException
TypeError

Référencé par ParagonIE_Sodium_Compat\crypto_sign_ed25519_pk_to_curve25519().

◆ publickey()

static publickey ( $keypair )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_publickey().

◆ scalar_add()

static scalar_add | ( | $a,
 |  | $b
 | ) |
static
Paramètres
string | $a
string | $b
Renvoie
string
Exceptions
SodiumException

Références $b, et ParagonIE_Sodium_Compat\add().

◆ scalar_complement()

static scalar_complement ( $s )
static
Paramètres
string $s
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Compat\sub().

◆ scalar_negate()

static scalar_negate ( $s )
static
Paramètres
string $s
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Compat\sub().

◆ scalar_random()

static scalar_random ( )
static
Renvoie
string
Exceptions
SodiumException

Références $r, et ParagonIE_Sodium_Compat\is_zero().

◆ scalar_sub()

static scalar_sub | ( | $x,
 |  | $y
 | ) |
static
Paramètres
string | $x
string | $y
Renvoie
string
Exceptions
SodiumException

◆ secretkey()

static secretkey ( $keypair )
static

Référencé par ParagonIE_Sodium_Compat\crypto_sign_secretkey().

◆ sign_detached()

static sign_detached | ( | $message,
 |  | $sk
 | ) |
static

Références $message, ParagonIE_Sodium_Core_Util\hash_update(), ParagonIE_Sodium_Compat\memzero(), et null.

Référencé par ParagonIE_Sodium_Crypto\sign_detached().

◆ sk_to_pk()

static sk_to_pk ( $sk )
static

Documentation des champs

◆ KEYPAIR_BYTES

const KEYPAIR_BYTES = 96

◆ SCALAR_BYTES

const SCALAR_BYTES = 32

◆ SEED_BYTES

const SEED_BYTES = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/Ed25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_HChaCha20

Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_HChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core_HChaCha20:
ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_Util HChaCha20 ParagonIE_Sodium_Core_XChaCha20 XChaCha20

Fonctions membres publiques statiques

static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_ChaCha20
static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Fonctions membres protégées statiques

static | hChaCha20Bytes (array $ctx)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_HChaCha20

Documentation des fonctions membres

◆ hChaCha20()

static hChaCha20 | ( | $in = '',
 |  | $key = '',
 |  | $c = null
 | ) |
static
Paramètres
string | $in
string | $key
string | null | $c
Renvoie
string
Exceptions
TypeError

Références $c, $key, et null.

Référencé par ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), et ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_push().

◆ hChaCha20Bytes()

static hChaCha20Bytes ( array $ctx )
staticprotected
Paramètres
array $ctx
Renvoie
string
Exceptions
TypeError

Références $i.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/HChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_HSalsa20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_HSalsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core_HSalsa20:
ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_Util HSalsa20 ParagonIE_Sodium_Core_XSalsa20 Xsalsa20

Fonctions membres publiques statiques

static | hsalsa20 ($in, $k, $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Salsa20
static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Champs de données hérités de ParagonIE_Sodium_Core_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_HSalsa20

Documentation des fonctions membres

◆ hsalsa20()

static hsalsa20 | ( | $in,
 |  | $k,
 |  | $c = null
 | ) |
static

Calculate an hsalsa20 hash of a single block

HSalsa20 doesn't have a counter and will never be used for more than one block (used to derive a subkey for xsalsa20).

Références $c, $i, et null.

Référencé par ParagonIE_Sodium_Crypto\box_beforenm().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/HSalsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Poly1305

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Poly1305
+ Graphe d'héritage de ParagonIE_Sodium_Core_Poly1305:
ParagonIE_Sodium_Core_Util Poly1305

Fonctions membres publiques statiques

static | onetimeauth ($m, $key)
static | onetimeauth_verify ($mac, $m, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const BLOCK_SIZE = 16

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Poly1305

Documentation des fonctions membres

◆ onetimeauth()

static onetimeauth | ( | $m,
 |  | $key
 | ) |
static

Références $key, et $state.

◆ onetimeauth_verify()

static onetimeauth_verify | ( | $mac,
 |  | $m,
 |  | $key
 | ) |
static

Références $key, et $state.

Documentation des champs

◆ BLOCK_SIZE

const BLOCK_SIZE = 16
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Poly1305.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Poly1305_State

Fonctions membres publiques | Champs de données | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core_Poly1305_State
+ Graphe d'héritage de ParagonIE_Sodium_Core_Poly1305_State:
ParagonIE_Sodium_Core_Util State

Fonctions membres publiques

__construct ($key='')
__destruct ()

Champs de données

$h
$r
$pad

Attributs protégés

$buffer = array()
$final = false
$leftover = 0

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Poly1305_State

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $key = '' )

ParagonIE_Sodium_Core_Poly1305_State constructor.

Références $key.

◆ __destruct()

__destruct ( )

Zero internal buffer upon destruction

Documentation des champs

◆ $buffer

$buffer = array()
protected

◆ $final

$final = false
protected

◆ $h

$h

◆ $leftover

$leftover = 0
protected

◆ $pad

$pad

◆ $r

$r
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/Poly1305/State.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Ristretto255

Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_Ristretto255
+ Graphe d'héritage de ParagonIE_Sodium_Core_Ristretto255:
ParagonIE_Sodium_Core_Ed25519 ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques

static | fe_cneg (ParagonIE_Sodium_Core_Curve25519_Fe $f, $b)
static | fe_abs (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | ristretto255_sqrt_ratio_m1 (ParagonIE_Sodium_Core_Curve25519_Fe $u, ParagonIE_Sodium_Core_Curve25519_Fe $v)
static | ristretto255_point_is_canonical ($s)
static | ristretto255_frombytes ($s, $skipCanonicalCheck=false)
static | ristretto255_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ristretto255_elligator (ParagonIE_Sodium_Core_Curve25519_Fe $t)
static | ristretto255_from_hash ($h)
static | is_valid_point ($p)
static | ristretto255_add ($p, $q)
static | ristretto255_sub ($p, $q)
static | h2c_string_to_hash ($hLen, $ctx, $msg, $hash_alg)
static | ristretto255_random ()
static | ristretto255_scalar_random ()
static | ristretto255_scalar_complement ($s)
static | ristretto255_scalar_invert ($s)
static | ristretto255_scalar_negate ($s)
static | ristretto255_scalar_add ($x, $y)
static | ristretto255_scalar_sub ($x, $y)
static | ristretto255_scalar_mul ($x, $y)
static | ristretto255_scalar_from_string ($ctx, $msg, $hash_alg)
static | ristretto255_scalar_reduce ($s)
static | scalarmult_ristretto255 ($n, $p)
static | scalarmult_ristretto255_base ($n)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Ed25519
static | keypair ()
static | secretkey ($keypair)
static | publickey ($keypair)
static | pk_to_curve25519 ($pk)
static | sk_to_pk ($sk)
static | sign_detached ($message, $sk)
static | scalar_complement ($s)
static | scalar_random ()
static | scalar_negate ($s)
static | scalar_add ($a, $b)
static | scalar_sub ($x, $y)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const | crypto_core_ristretto255_HASHBYTES = 64
const | HASH_SC_L = 48
const | CORE_H2C_SHA256 = 1
const | CORE_H2C_SHA512 = 2
- Champs de données hérités de ParagonIE_Sodium_Core_Ed25519
const | KEYPAIR_BYTES = 96
const | SEED_BYTES = 32
const | SCALAR_BYTES = 32
- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"

Fonctions membres protégées statiques

static | h2c_string_to_hash_sha256 ($hLen, $ctx, $msg)
static | h2c_string_to_hash_sha512 ($hLen, $ctx, $msg)
static | _string_to_element ($ctx, $msg, $hash_alg)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Membres hérités additionnels

- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone

Description détaillée

Class ParagonIE_Sodium_Core_Ristretto255

Documentation des fonctions membres

◆ _string_to_element()

static _string_to_element | ( | $ctx,
 |  | $msg,
 |  | $hash_alg
 | ) |
staticprotected
Paramètres
?string | $ctx
string | $msg
int | $hash_alg
Renvoie
string
Exceptions
SodiumException

◆ fe_abs()

static fe_abs ( ParagonIE_Sodium_Core_Curve25519_Fe $f )
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Fe $f
Renvoie
ParagonIE_Sodium_Core_Curve25519_Fe
Exceptions
SodiumException

◆ fe_cneg()

static fe_cneg | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $f,
 |  |  | $b
 | ) |  |
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Fe | $f
int | $b
Renvoie
ParagonIE_Sodium_Core_Curve25519_Fe

Références $b.

◆ h2c_string_to_hash()

static h2c_string_to_hash | ( | $hLen,
 |  | $ctx,
 |  | $msg,
 |  | $hash_alg
 | ) |
static
Paramètres
int | $hLen
?string | $ctx
string | $msg
int | $hash_alg
Renvoie
string
Exceptions
SodiumException

◆ h2c_string_to_hash_sha256()

static h2c_string_to_hash_sha256 | ( | $hLen,
 |  | $ctx,
 |  | $msg
 | ) |
staticprotected
Paramètres
int | $hLen
?string | $ctx
string | $msg
Renvoie
string
Exceptions
SodiumException -suppress PossiblyInvalidArgument hash API

Références $i.

◆ h2c_string_to_hash_sha512()

static h2c_string_to_hash_sha512 | ( | $hLen,
 |  | $ctx,
 |  | $msg
 | ) |
staticprotected
Paramètres
int | $hLen
?string | $ctx
string | $msg
Renvoie
string
Exceptions
SodiumException -suppress PossiblyInvalidArgument hash API

Références $i.

◆ is_valid_point()

static is_valid_point ( $p )
static
Paramètres
string $p
Renvoie
int
Exceptions
SodiumException

Références $result.

◆ ristretto255_add()

static ristretto255_add | ( | $p,
 |  | $q
 | ) |
static
Paramètres
string | $p
string | $q
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_add().

◆ ristretto255_elligator()

static ristretto255_elligator ( ParagonIE_Sodium_Core_Curve25519_Fe $t )
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Fe $t
Renvoie
ParagonIE_Sodium_Core_Curve25519_Ge_P3
Exceptions
SodiumException

Références $c, ParagonIE_Sodium_Core_Curve25519_H\$d, $n, ParagonIE_Sodium_Core_Curve25519_H\$onemsqd, $r, $result, ParagonIE_Sodium_Core_Curve25519_H\$sqdmone, ParagonIE_Sodium_Core_Curve25519_H\$sqrtadm1, et ParagonIE_Sodium_Core_Curve25519_H\$sqrtm1.

◆ ristretto255_from_hash()

static ristretto255_from_hash ( $h )
static
Paramètres
string $h
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_from_hash().

◆ ristretto255_frombytes()

static ristretto255_frombytes | ( | $s,
 |  | $skipCanonicalCheck = false
 | ) |
static
Paramètres
string | $s
bool | $skipCanonicalCheck
Renvoie
array{h: ParagonIE_Sodium_Core_Curve25519_Ge_P3, res: int}
Exceptions
SodiumException

Références $result.

Référencé par ParagonIE_Sodium_Compat\ristretto255_is_valid_point().

◆ ristretto255_p3_tobytes()

static ristretto255_p3_tobytes ( ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h )
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h
Renvoie
string
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Curve25519_H\$invsqrtamd, $result, et ParagonIE_Sodium_Core_Curve25519_H\$sqrtm1.

◆ ristretto255_point_is_canonical()

static ristretto255_point_is_canonical ( $s )
static
Paramètres
string $s
Renvoie
int
Exceptions
SodiumException

Références $c, ParagonIE_Sodium_Core_Curve25519_H\$d, et $i.

Référencé par ParagonIE_Sodium_Compat\ristretto255_is_valid_point().

◆ ristretto255_random()

static ristretto255_random ( )
static
Renvoie
string
Exceptions
SodiumException
Exception

Référencé par ParagonIE_Sodium_Compat\ristretto255_random().

◆ ristretto255_scalar_add()

static ristretto255_scalar_add | ( | $x,
 |  | $y
 | ) |
static
Paramètres
string | $x
string | $y
Renvoie
string

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_add().

◆ ristretto255_scalar_complement()

static ristretto255_scalar_complement ( $s )
static
Paramètres
string $s
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_complement().

◆ ristretto255_scalar_from_string()

static ristretto255_scalar_from_string | ( | $ctx,
 |  | $msg,
 |  | $hash_alg
 | ) |
static
Paramètres
string | $ctx
string | $msg
int | $hash_alg
Renvoie
string
Exceptions
SodiumException

Références $i.

◆ ristretto255_scalar_invert()

static ristretto255_scalar_invert ( $s )
static
Paramètres
string $s
Renvoie
string

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_invert().

◆ ristretto255_scalar_mul()

static ristretto255_scalar_mul | ( | $x,
 |  | $y
 | ) |
static
Paramètres
string | $x
string | $y
Renvoie
string

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_mul().

◆ ristretto255_scalar_negate()

static ristretto255_scalar_negate ( $s )
static
Paramètres
string $s
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_negate().

◆ ristretto255_scalar_random()

static ristretto255_scalar_random ( )
static
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_random().

◆ ristretto255_scalar_reduce()

static ristretto255_scalar_reduce ( $s )
static
Paramètres
string $s
Renvoie
string

◆ ristretto255_scalar_sub()

static ristretto255_scalar_sub | ( | $x,
 |  | $y
 | ) |
static
Paramètres
string | $x
string | $y
Renvoie
string

Référencé par ParagonIE_Sodium_Compat\ristretto255_scalar_sub().

◆ ristretto255_sqrt_ratio_m1()

static ristretto255_sqrt_ratio_m1 | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $u,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $v
 | ) |  |
static
Paramètres
ParagonIE_Sodium_Core_Curve25519_Fe | $u
ParagonIE_Sodium_Core_Curve25519_Fe | $v
Renvoie
array{x: ParagonIE_Sodium_Core_Curve25519_Fe, nonsquare: int}
Exceptions
SodiumException

Références ParagonIE_Sodium_Core_Curve25519_H\$sqrtm1.

◆ ristretto255_sub()

static ristretto255_sub | ( | $p,
 |  | $q
 | ) |
static
Paramètres
string | $p
string | $q
Renvoie
string
Exceptions
SodiumException

Référencé par ParagonIE_Sodium_Compat\ristretto255_sub().

◆ scalarmult_ristretto255()

static scalarmult_ristretto255 | ( | $n,
 |  | $p
 | ) |
static
Paramètres
string | $n
string | $p
Renvoie
string
Exceptions
SodiumException

Références $n, $result, et ParagonIE_Sodium_Compat\is_zero().

Référencé par ParagonIE_Sodium_Compat\scalarmult_ristretto255().

◆ scalarmult_ristretto255_base()

static scalarmult_ristretto255_base ( $n )
static
Paramètres
string $n
Renvoie
string
Exceptions
SodiumException

Références $n, et ParagonIE_Sodium_Compat\is_zero().

Référencé par ParagonIE_Sodium_Compat\scalarmult_ristretto255_base().

Documentation des champs

◆ CORE_H2C_SHA256

const CORE_H2C_SHA256 = 1

◆ CORE_H2C_SHA512

const CORE_H2C_SHA512 = 2

◆ crypto_core_ristretto255_HASHBYTES

const crypto_core_ristretto255_HASHBYTES = 64

◆ HASH_SC_L

const HASH_SC_L = 48
La documentation de cette classe a été générée à partir du fichier suivant :
  • Ristretto255.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Salsa20

Fonctions membres publiques statiques | Champs de données
Référence de la classe ParagonIE_Sodium_Core_Salsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core_Salsa20:
ParagonIE_Sodium_Core_Util Salsa20 ParagonIE_Sodium_Core_HSalsa20 HSalsa20 ParagonIE_Sodium_Core_XSalsa20 Xsalsa20

Fonctions membres publiques statiques

static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Champs de données

const ROUNDS = 20

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Salsa20

Documentation des fonctions membres

◆ core_salsa20()

static core_salsa20 | ( | $in,
 |  | $k,
 |  | $c = null
 | ) |
static

Calculate an salsa20 hash of a single block

Références $c, $i, et null.

◆ rotate()

static rotate | ( | $u,
 |  | $c
 | ) |
static

Références $c.

◆ salsa20()

static salsa20 | ( | $len,
 |  | $nonce,
 |  | $key
 | ) |
static

Références $c, $i, $key, ParagonIE_Sodium_Compat\memzero(), et null.

◆ salsa20_xor()

static salsa20_xor | ( | $message,
 |  | $nonce,
 |  | $key
 | ) |
static

Références $key, et $message.

◆ salsa20_xor_ic()

static salsa20_xor_ic | ( | $m,
 |  | $n,
 |  | $ic,
 |  | $k
 | ) |
static

Références $c, $i, $n, ParagonIE_Sodium_Compat\memzero(), et null.

Documentation des champs

◆ ROUNDS

const ROUNDS = 20
La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/Salsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_SecretStream_State

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés
Référence de la classe ParagonIE_Sodium_Core_SecretStream_State

Fonctions membres publiques

__construct ($key, $nonce=null)
counterReset ()
getKey ()
getCounter ()
getNonce ()
getCombinedNonce ()
incrementCounter ()
needsRekey ()
rekey ($newKeyAndNonce)
xorNonce ($str)
toString ()

Fonctions membres publiques statiques

static fromString ($string)

Attributs protégés

$key
$counter
$nonce
$_pad

Description détaillée

Class ParagonIE_Sodium_Core_SecretStream_State

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $key,
 |  | $nonce = null
 | ) |

ParagonIE_Sodium_Core_SecretStream_State constructor.

Paramètres
string | $key
string | null | $nonce

Références $key, $nonce, et counter.

Documentation des fonctions membres

◆ counterReset()

counterReset ( )
Renvoie
self

Références $this, et counter.

◆ fromString()

static fromString ( $string )
static
Paramètres
string $string
Renvoie
self

Références $state, et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_rekey().

◆ getCombinedNonce()

getCombinedNonce ( )
Renvoie
string

Références getCounter(), getNonce(), et ParagonIE_Sodium_Core_Util\substr().

◆ getCounter()

getCounter ( )
Renvoie
string

Références counter.

Référencé par getCombinedNonce(), et toString().

◆ getKey()

getKey ( )
Renvoie
string

Références $key.

◆ getNonce()

getNonce ( )
Renvoie
string

Références $nonce, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par getCombinedNonce(), et xorNonce().

◆ incrementCounter()

incrementCounter ( )
Renvoie
self

Références $counter, et $this.

◆ needsRekey()

needsRekey ( )
Renvoie
bool

Références counter.

◆ rekey()

rekey ( $newKeyAndNonce )
Paramètres
string $newKeyAndNonce
Renvoie
self

Références $this, et ParagonIE_Sodium_Core_Util\substr().

◆ toString()

toString ( )
Renvoie
string

Références $_pad, et getCounter().

◆ xorNonce()

xorNonce ( $str )
Paramètres
string $str
Renvoie
self

Références $this, getNonce(), ParagonIE_Sodium_Core_Util\substr(), et ParagonIE_Sodium_Core_Util\xorStrings().

Documentation des champs

◆ $_pad

$_pad
protected

Référencé par toString().

◆ $counter

$counter
protected

Référencé par incrementCounter().

◆ $key

$key
protected

Référencé par __construct(), et getKey().

◆ $nonce

$nonce
protected

Référencé par __construct(), et getNonce().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/SecretStream/State.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_SipHash

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_SipHash
+ Graphe d'héritage de ParagonIE_Sodium_Core_SipHash:
ParagonIE_Sodium_Core_Util SipHash

Fonctions membres publiques statiques

static | sipRound (array $v)
static | rotl_64 ($int0, $int1, $c)
static | sipHash24 ($in, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_SodiumCompat_Core_SipHash

Only uses 32-bit arithmetic, while the original SipHash used 64-bit integers

Documentation des fonctions membres

◆ rotl_64()

static rotl_64 | ( | $int0,
 |  | $int1,
 |  | $c
 | ) |
static

Références $c, et $tmp.

◆ sipHash24()

static sipHash24 | ( | $in,
 |  | $key
 | ) |
static

Implements Siphash-2-4 using only 32-bit numbers.

When we split an int into two, the higher bits go to the lower index. e.g. 0xDEADBEEFAB10C92D becomes [ 0 => 0xDEADBEEF, 1 => 0xAB10C92D ].

Références $b, et $key.

Référencé par ParagonIE_Sodium_Compat\crypto_shorthash().

◆ sipRound()

static sipRound ( array $v )
static
La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/SipHash.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_Util

Fonctions membres publiques statiques | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Core_Util
+ Graphe d'héritage de ParagonIE_Sodium_Core_Util:
Util ParagonIE_Sodium_Core32_BLAKE2b ParagonIE_Sodium_Core32_Util ParagonIE_Sodium_Core_BLAKE2b ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_ChaCha20_Ctx ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Poly1305 ParagonIE_Sodium_Core_Poly1305_State ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_SipHash ParagonIE_Sodium_File

Fonctions membres publiques statiques

static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Fonctions membres protégées statiques

static hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_Util

Documentation des fonctions membres

◆ compare()

static compare | ( | $left,
 |  | $right,
 |  | $len = null
 | ) |
static

Compares two strings.

Références $i, et null.

Référencé par ParagonIE_Sodium_Compat\compare().

◆ declareScalarType()

static declareScalarType | ( | & | $mixedVar = null,
 |  |  | $type = 'void',
 |  |  | $argumentIndex = 0
 | ) |  |
static

If a variable does not match a given type, throw a TypeError.

Paramètres
mixed | $mixedVar
string | $type
int | $argumentIndex
Exceptions
TypeError
SodiumException
Renvoie
void

Références $type, et null.

Référencé par ParagonIE_Sodium_Compat\bin2hex(), ParagonIE_Sodium_Compat\compare(), ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_auth(), ParagonIE_Sodium_Compat\crypto_auth_verify(), ParagonIE_Sodium_Compat\crypto_box(), ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_box_open(), ParagonIE_Sodium_Compat\crypto_box_publickey(), ParagonIE_Sodium_Compat\crypto_box_publickey_from_secretkey(), ParagonIE_Sodium_Compat\crypto_box_seal(), ParagonIE_Sodium_Compat\crypto_box_seal_open(), ParagonIE_Sodium_Compat\crypto_box_secretkey(), ParagonIE_Sodium_Compat\crypto_box_seed_keypair(), ParagonIE_Sodium_Compat\crypto_generichash(), ParagonIE_Sodium_Compat\crypto_generichash_final(), ParagonIE_Sodium_Compat\crypto_generichash_init(), ParagonIE_Sodium_Compat\crypto_generichash_init_salt_personal(), ParagonIE_Sodium_Compat\crypto_generichash_update(), ParagonIE_Sodium_Compat\crypto_kdf_derive_from_key(), ParagonIE_Sodium_Compat\crypto_kx(), ParagonIE_Sodium_Compat\crypto_kx_client_session_keys(), ParagonIE_Sodium_Compat\crypto_kx_seed_keypair(), ParagonIE_Sodium_Compat\crypto_kx_server_session_keys(), ParagonIE_Sodium_Compat\crypto_pwhash(), ParagonIE_Sodium_Compat\crypto_pwhash_scryptsalsa208sha256(), ParagonIE_Sodium_Compat\crypto_pwhash_scryptsalsa208sha256_str(), ParagonIE_Sodium_Compat\crypto_pwhash_scryptsalsa208sha256_str_verify(), ParagonIE_Sodium_Compat\crypto_pwhash_str(), ParagonIE_Sodium_Compat\crypto_pwhash_str_verify(), ParagonIE_Sodium_Compat\crypto_scalarmult(), ParagonIE_Sodium_Compat\crypto_scalarmult_base(), ParagonIE_Sodium_Compat\crypto_secretbox(), ParagonIE_Sodium_Compat\crypto_secretbox_open(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305_open(), ParagonIE_Sodium_Compat\crypto_shorthash(), ParagonIE_Sodium_Compat\crypto_sign(), ParagonIE_Sodium_Compat\crypto_sign_detached(), ParagonIE_Sodium_Compat\crypto_sign_ed25519_pk_to_curve25519(), ParagonIE_Sodium_Compat\crypto_sign_ed25519_sk_to_curve25519(), ParagonIE_Sodium_Compat\crypto_sign_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_sign_open(), ParagonIE_Sodium_Compat\crypto_sign_publickey(), ParagonIE_Sodium_Compat\crypto_sign_publickey_from_secretkey(), ParagonIE_Sodium_Compat\crypto_sign_secretkey(), ParagonIE_Sodium_Compat\crypto_sign_seed_keypair(), ParagonIE_Sodium_Compat\crypto_sign_verify_detached(), ParagonIE_Sodium_Compat\crypto_stream(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor(), ParagonIE_Sodium_Compat\crypto_stream_xor(), ParagonIE_Sodium_Core32_Int64\fromInt(), ParagonIE_Sodium_Core32_Int64\fromInts(), ParagonIE_Sodium_Core32_Int32\fromReverseString(), ParagonIE_Sodium_Core32_Int64\fromReverseString(), ParagonIE_Sodium_Core32_Int32\fromString(), ParagonIE_Sodium_Core32_Int64\fromString(), ParagonIE_Sodium_Compat\hex2bin(), ParagonIE_Sodium_Compat\increment(), ParagonIE_Sodium_Compat\memzero(), ParagonIE_Sodium_Core32_Curve25519_Fe\offsetSet(), et ParagonIE_Sodium_Compat\unpad().

◆ hash_update()

static hash_update | ( | & | $hs,
 |  |  | $data
 | ) |  |
staticprotected

Catch hash_update() failures and throw instead of silently proceeding

Paramètres
HashContext | resource | &$hs
string | $data
Renvoie
void
Exceptions
SodiumException -suppress PossiblyInvalidArgument

Références $data.

Référencé par ParagonIE_Sodium_Core_Ed25519\sign_detached().

◆ intToChr()

static intToChr ( $int )
static

Cache-timing-safe variant of ord()

Référencé par ParagonIE_Sodium_Compat\crypto_sign_ed25519_sk_to_curve25519(), ParagonIE_Sodium_Compat\increment(), ParagonIE_Sodium_Core32_Int32\toReverseString(), ParagonIE_Sodium_Core32_Int64\toReverseString(), ParagonIE_Sodium_Core32_Int32\toString(), et ParagonIE_Sodium_Core32_Int64\toString().

◆ memcmp()

static memcmp | ( | $left,
 |  | $right
 | ) |
static

◆ strlen()

static strlen ( $str )
static

Safe string length

Référencé par ParagonIE_Sodium_Compat\add(), ParagonIE_Sodium_Crypto32\box_publickey(), ParagonIE_Sodium_Crypto\box_publickey(), ParagonIE_Sodium_Crypto32\box_publickey_from_secretkey(), ParagonIE_Sodium_Crypto\box_publickey_from_secretkey(), ParagonIE_Sodium_Crypto32\box_secretkey(), ParagonIE_Sodium_Crypto\box_secretkey(), ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_auth(), ParagonIE_Sodium_Compat\crypto_auth_verify(), ParagonIE_Sodium_Compat\crypto_box(), ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_box_open(), ParagonIE_Sodium_Compat\crypto_box_publickey(), ParagonIE_Sodium_Compat\crypto_box_publickey_from_secretkey(), ParagonIE_Sodium_Compat\crypto_box_seal(), ParagonIE_Sodium_Compat\crypto_box_seal_open(), ParagonIE_Sodium_Compat\crypto_box_secretkey(), ParagonIE_Sodium_Compat\crypto_generichash(), ParagonIE_Sodium_Compat\crypto_generichash_init(), ParagonIE_Sodium_Compat\crypto_generichash_init_salt_personal(), ParagonIE_Sodium_Compat\crypto_kdf_derive_from_key(), ParagonIE_Sodium_Compat\crypto_kx(), ParagonIE_Sodium_Compat\crypto_kx_client_session_keys(), ParagonIE_Sodium_Compat\crypto_kx_seed_keypair(), ParagonIE_Sodium_Compat\crypto_kx_server_session_keys(), ParagonIE_Sodium_Compat\crypto_scalarmult(), ParagonIE_Sodium_Compat\crypto_scalarmult_base(), ParagonIE_Sodium_Compat\crypto_secretbox(), ParagonIE_Sodium_Compat\crypto_secretbox_open(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305_open(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Compat\crypto_shorthash(), ParagonIE_Sodium_Compat\crypto_sign(), ParagonIE_Sodium_Compat\crypto_sign_detached(), ParagonIE_Sodium_Compat\crypto_sign_ed25519_pk_to_curve25519(), ParagonIE_Sodium_Compat\crypto_sign_ed25519_sk_to_curve25519(), ParagonIE_Sodium_Compat\crypto_sign_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Compat\crypto_sign_open(), ParagonIE_Sodium_Compat\crypto_sign_publickey(), ParagonIE_Sodium_Compat\crypto_sign_publickey_from_secretkey(), ParagonIE_Sodium_Compat\crypto_sign_secretkey(), ParagonIE_Sodium_Compat\crypto_sign_verify_detached(), ParagonIE_Sodium_Compat\crypto_stream(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor(), ParagonIE_Sodium_Compat\crypto_stream_xor(), ParagonIE_Sodium_Core32_Int32\fromReverseString(), ParagonIE_Sodium_Core32_Int64\fromReverseString(), ParagonIE_Sodium_Core32_Int32\fromString(), ParagonIE_Sodium_Core32_Int64\fromString(), ParagonIE_Sodium_Core_SecretStream_State\getNonce(), ParagonIE_Sodium_Core32_SecretStream_State\getNonce(), ParagonIE_Sodium_Compat\increment(), ParagonIE_Sodium_Compat\sub(), et ParagonIE_Sodium_Compat\unpad().

◆ substr()

static substr | ( | $str,
 |  | $start = 0,
 |  | $length = null
 | ) |
static

Safe substring

Références $start, elseif, et null.

Référencé par ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto32\auth(), ParagonIE_Sodium_Crypto\auth(), ParagonIE_Sodium_Crypto32\box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Crypto\box_keypair_from_secretkey_and_publickey(), ParagonIE_Sodium_Crypto32\box_publickey(), ParagonIE_Sodium_Crypto\box_publickey(), ParagonIE_Sodium_Crypto32\box_secretkey(), ParagonIE_Sodium_Crypto\box_secretkey(), ParagonIE_Sodium_Crypto32\box_seed_keypair(), ParagonIE_Sodium_Crypto\box_seed_keypair(), ParagonIE_Sodium_Compat\crypto_kx_client_session_keys(), ParagonIE_Sodium_Compat\crypto_kx_publickey(), ParagonIE_Sodium_Compat\crypto_kx_secretkey(), ParagonIE_Sodium_Compat\crypto_kx_server_session_keys(), ParagonIE_Sodium_Compat\crypto_sign_ed25519_sk_to_curve25519(), ParagonIE_Sodium_Core32_SecretStream_State\fromString(), ParagonIE_Sodium_Core_SecretStream_State\fromString(), ParagonIE_Sodium_Core_SecretStream_State\getCombinedNonce(), ParagonIE_Sodium_Core32_SecretStream_State\getCombinedNonce(), ParagonIE_Sodium_Compat\increment(), ParagonIE_Sodium_Core32_SecretStream_State\rekey(), ParagonIE_Sodium_Core_SecretStream_State\rekey(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Compat\unpad(), ParagonIE_Sodium_Core32_SecretStream_State\xorNonce(), et ParagonIE_Sodium_Core_SecretStream_State\xorNonce().

◆ verify_16()

static verify_16 | ( | $a,
 |  | $b
 | ) |
static

Compare a 16-character byte string in constant time.

Références $b.

◆ verify_32()

static verify_32 | ( | $a,
 |  | $b
 | ) |
static

Compare a 32-character byte string in constant time.

Références $b.

◆ xorStrings()

static xorStrings | ( | $a,
 |  | $b
 | ) |
static

Calculate $a ^ $b for two strings.

Références $b.

Référencé par ParagonIE_Sodium_Core_SecretStream_State\xorNonce(), et ParagonIE_Sodium_Core32_SecretStream_State\xorNonce().

La documentation de cette classe a été générée à partir du fichier suivant :
  • paragonie/sodium_compat/src/Core/Util.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_X25519

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_X25519
+ Graphe d'héritage de ParagonIE_Sodium_Core_X25519:
ParagonIE_Sodium_Core_Curve25519 ParagonIE_Sodium_Core_Curve25519_H ParagonIE_Sodium_Core_Util X25519

Fonctions membres publiques statiques

static | fe_cswap (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g, $b=0)
static | edwards_to_montgomery (ParagonIE_Sodium_Core_Curve25519_Fe $edwardsY, ParagonIE_Sodium_Core_Curve25519_Fe $edwardsZ)
static | crypto_scalarmult_curve25519_ref10_base ($n)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Curve25519
static | fe_0 ()
static | fe_1 ()
static | fe_copy (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_frombytes ($s)
static | fe_isnegative (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_mul (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | fe_neg (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_sq2 (ParagonIE_Sodium_Core_Curve25519_Fe $f)
static | fe_invert (ParagonIE_Sodium_Core_Curve25519_Fe $Z)
static | fe_pow22523 (ParagonIE_Sodium_Core_Curve25519_Fe $z)
static | fe_sub (ParagonIE_Sodium_Core_Curve25519_Fe $f, ParagonIE_Sodium_Core_Curve25519_Fe $g)
static | ge_add (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_madd (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_msub (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $R, ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $q)
static | ge_p1p1_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p1p1_to_p3 (ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 $p)
static | ge_p2_0 ()
static | ge_p2_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $p)
static | ge_p3_0 ()
static | ge_p3_to_p2 (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_p3_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $h)
static | ge_p3_dbl (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p)
static | ge_precomp_0 ()
static | equal ($b, $c)
static | negative ($char)
static | cmov (ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $t, ParagonIE_Sodium_Core_Curve25519_Ge_Precomp $u, $b)
static | ge_cmov_cached (ParagonIE_Sodium_Core_Curve25519_Ge_Cached $t, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $u, $b)
static | ge_cmov8_cached (array $cached, $b)
static | ge_sub (ParagonIE_Sodium_Core_Curve25519_Ge_P3 $p, ParagonIE_Sodium_Core_Curve25519_Ge_Cached $q)
static | ge_tobytes (ParagonIE_Sodium_Core_Curve25519_Ge_P2 $h)
static | sc25519_mul ($a, $b)
static | sc25519_sq ($s)
static | sc25519_sqmul ($s, $n, $a)
static | sc25519_invert ($s)
static | clamp ($s)
static | fe_normalize (ParagonIE_Sodium_Core_Curve25519_Fe $f)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Champs de données hérités de ParagonIE_Sodium_Core_Curve25519_H
const | L = "\xed\xd3\xf5\x5c\x1a\x63\x12\x58\xd6\x9c\xf7\xa2\xde\xf9\xde\x14\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x10"
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)
- Attributs protégés statiques hérités de ParagonIE_Sodium_Core_Curve25519_H
static | $base
static | $base2
static | $d
static | $d2
static | $sqrtm1
static | $invsqrtamd
static | $sqrtadm1
static | $onemsqd
static | $sqdmone

Description détaillée

Class ParagonIE_Sodium_Core_X25519

Documentation des fonctions membres

◆ crypto_scalarmult_curve25519_ref10_base()

static crypto_scalarmult_curve25519_ref10_base ( $n )
static

Références $n.

Référencé par ParagonIE_Sodium_Crypto\scalarmult_base().

◆ edwards_to_montgomery()

static edwards_to_montgomery | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $edwardsY,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $edwardsZ
 | ) |  |
static

◆ fe_cswap()

static fe_cswap | ( | ParagonIE_Sodium_Core_Curve25519_Fe | $f,
 |  | ParagonIE_Sodium_Core_Curve25519_Fe | $g,
 |  |  | $b = 0
 | ) |  |
static

Alters the objects passed to this method in place.

Références $b, et $g.

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/X25519.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_XChaCha20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_XChaCha20
+ Graphe d'héritage de ParagonIE_Sodium_Core_XChaCha20:
ParagonIE_Sodium_Core_HChaCha20 ParagonIE_Sodium_Core_ChaCha20 ParagonIE_Sodium_Core_Util XChaCha20

Fonctions membres publiques statiques

static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len=64, $nonce='', $key='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20 ($in='', $key='', $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_ChaCha20
static | rotate ($v, $n)
static | stream ($len=64, $nonce='', $key='')
static | ietfStream ($len, $nonce='', $key='')
static | ietfStreamXorIc ($message, $nonce='', $key='', $ic='')
static | streamXorIc ($message, $nonce='', $key='', $ic='')
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_HChaCha20
static | hChaCha20Bytes (array $ctx)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_XChaCha20

Documentation des fonctions membres

◆ ietfStream()

static ietfStream | ( | $len = 64,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

◆ ietfStreamXorIc()

static ietfStreamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

◆ stream()

static stream | ( | $len = 64,
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

Références $key.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xchacha20().

◆ streamXorIc()

static streamXorIc | ( | $message,
 |  | $nonce = '',
 |  | $key = '',
 |  | $ic = ''
 | ) |
static

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor().

La documentation de cette classe a été générée à partir du fichier suivant :
  • src/Core/XChaCha20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Core_XSalsa20

Fonctions membres publiques statiques
Référence de la classe ParagonIE_Sodium_Core_XSalsa20
+ Graphe d'héritage de ParagonIE_Sodium_Core_XSalsa20:
ParagonIE_Sodium_Core_HSalsa20 ParagonIE_Sodium_Core_Salsa20 ParagonIE_Sodium_Core_Util Xsalsa20

Fonctions membres publiques statiques

static | xsalsa20 ($len, $nonce, $key)
static | xsalsa20_xor ($message, $nonce, $key)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_HSalsa20
static | hsalsa20 ($in, $k, $c=null)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Salsa20
static | core_salsa20 ($in, $k, $c=null)
static | salsa20 ($len, $nonce, $key)
static | salsa20_xor_ic ($m, $n, $ic, $k)
static | salsa20_xor ($message, $nonce, $key)
static | rotate ($u, $c)
- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Membres hérités additionnels

- Champs de données hérités de ParagonIE_Sodium_Core_Salsa20
const | ROUNDS = 20
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Description détaillée

Class ParagonIE_Sodium_Core_XSalsa20

Documentation des fonctions membres

◆ xsalsa20()

static xsalsa20 | ( | $len,
 |  | $nonce,
 |  | $key
 | ) |
static

Expand a key and nonce into an xsalsa20 keystream.

Références $key.

Référencé par ParagonIE_Sodium_Compat\crypto_stream().

◆ xsalsa20_xor()

static xsalsa20_xor | ( | $message,
 |  | $nonce,
 |  | $key
 | ) |
static

Encrypt a string with XSalsa20. Doesn't provide integrity.

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_stream_xor().

La documentation de cette classe a été générée à partir du fichier suivant :
  • XSalsa20.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Crypto

Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Crypto
+ Graphe d'héritage de ParagonIE_Sodium_Crypto:
Crypto

Fonctions membres publiques statiques

static | aead_xchacha20poly1305_ietf_decrypt ( $message='', $ad='', $nonce='', $key='')
static | aead_xchacha20poly1305_ietf_encrypt ( $message='', $ad='', $nonce='', $key='')
static | auth ($message, $key)
static | auth_verify ($mac, $message, $key)
static | box ($plaintext, $nonce, $keypair)
static | box_beforenm ($sk, $pk)
static | box_keypair ()
static | box_seed_keypair ($seed)
static | box_keypair_from_secretkey_and_publickey ($sKey, $pKey)
static | box_secretkey ($keypair)
static | box_publickey ($keypair)
static | box_publickey_from_secretkey ($sKey)
static | box_open ($ciphertext, $nonce, $keypair)
static | keyExchange ($my_sk, $their_pk, $client_pk, $server_pk)
static | scalarmult ($sKey, $pKey)
static | scalarmult_base ($secret)
static | secretstream_xchacha20poly1305_init_push ($key)
static | secretstream_xchacha20poly1305_init_pull ($key, $header)
static | secretstream_xchacha20poly1305_rekey (&$state)
static | sign_detached ($message, $sk)
static | sign ($message, $sk)
static | sign_open ($signedMessage, $pk)
static | sign_verify_detached ($signature, $message, $pk)

Champs de données

const | aead_chacha20poly1305_KEYBYTES = 32
const | aead_chacha20poly1305_NSECBYTES = 0
const | aead_chacha20poly1305_NPUBBYTES = 8
const | aead_chacha20poly1305_ABYTES = 16
const | aead_chacha20poly1305_IETF_KEYBYTES = 32
const | aead_chacha20poly1305_IETF_NSECBYTES = 0
const | aead_chacha20poly1305_IETF_NPUBBYTES = 12
const | aead_chacha20poly1305_IETF_ABYTES = 16
const | aead_xchacha20poly1305_IETF_KEYBYTES = 32
const | aead_xchacha20poly1305_IETF_NSECBYTES = 0
const | aead_xchacha20poly1305_IETF_NPUBBYTES = 24
const | aead_xchacha20poly1305_IETF_ABYTES = 16
const | box_curve25519xsalsa20poly1305_SEEDBYTES = 32
const | box_curve25519xsalsa20poly1305_PUBLICKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_SECRETKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_BEFORENMBYTES = 32
const | box_curve25519xsalsa20poly1305_NONCEBYTES = 24
const | box_curve25519xsalsa20poly1305_MACBYTES = 16
const | box_curve25519xsalsa20poly1305_BOXZEROBYTES = 16
const | box_curve25519xsalsa20poly1305_ZEROBYTES = 32
const | onetimeauth_poly1305_BYTES = 16
const | onetimeauth_poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_NONCEBYTES = 24
const | secretbox_xsalsa20poly1305_MACBYTES = 16
const | secretbox_xsalsa20poly1305_BOXZEROBYTES = 16
const | secretbox_xsalsa20poly1305_ZEROBYTES = 32
const | secretbox_xchacha20poly1305_KEYBYTES = 32
const | secretbox_xchacha20poly1305_NONCEBYTES = 24
const | secretbox_xchacha20poly1305_MACBYTES = 16
const | secretbox_xchacha20poly1305_BOXZEROBYTES = 16
const | secretbox_xchacha20poly1305_ZEROBYTES = 32
const | stream_salsa20_KEYBYTES = 32

Fonctions membres protégées statiques

static scalarmult_throw_if_zero ($q)

Description détaillée

Class ParagonIE_Sodium_Crypto

ATTENTION!

If you are using this library, you should be using ParagonIE_Sodium_Compat in your code, not this class.

Documentation des fonctions membres

◆ aead_xchacha20poly1305_ietf_decrypt()

static aead_xchacha20poly1305_ietf_decrypt | ( | $message = '',
 |  | $ad = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

AEAD Decryption with ChaCha20-Poly1305, IETF mode (96-bit nonce)

Références $key, $message, ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_decrypt().

◆ aead_xchacha20poly1305_ietf_encrypt()

static aead_xchacha20poly1305_ietf_encrypt | ( | $message = '',
 |  | $ad = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

AEAD Encryption with ChaCha20-Poly1305, IETF mode (96-bit nonce)

Références $key, $message, ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_encrypt().

◆ auth()

static auth | ( | $message,
 |  | $key
 | ) |
static

HMAC-SHA-512-256 (a.k.a. the leftmost 256 bits of HMAC-SHA-512)

Références $key, $message, et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_auth().

◆ auth_verify()

static auth_verify | ( | $mac,
 |  | $message,
 |  | $key
 | ) |
static

HMAC-SHA-512-256 validation. Constant-time via hash_equals().

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_auth_verify().

◆ box()

static box | ( | $plaintext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

X25519 key exchange followed by XSalsa20Poly1305 symmetric encryption

Références $c.

Référencé par ParagonIE_Sodium_Compat\crypto_box().

◆ box_beforenm()

static box_beforenm | ( | $sk,
 |  | $pk
 | ) |
static

Used by crypto_box() to get the crypto_secretbox() key.

Références ParagonIE_Sodium_Core_HSalsa20\hsalsa20().

Référencé par ParagonIE_Sodium_File\box_decrypt(), et ParagonIE_Sodium_File\box_encrypt().

◆ box_keypair()

static box_keypair ( )
static

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair().

◆ box_keypair_from_secretkey_and_publickey()

static box_keypair_from_secretkey_and_publickey | ( | $sKey,
 |  | $pKey
 | ) |
static

Références ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey().

◆ box_open()

static box_open | ( | $ciphertext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

Decrypt a message encrypted with box().

Référencé par ParagonIE_Sodium_Compat\crypto_box_open().

◆ box_publickey()

static box_publickey ( $keypair )
static

Références ParagonIE_Sodium_Compat\CRYPTO_BOX_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_File\box_decrypt(), ParagonIE_Sodium_File\box_encrypt(), et ParagonIE_Sodium_Compat\crypto_box_publickey().

◆ box_publickey_from_secretkey()

static box_publickey_from_secretkey ( $sKey )
static

Références ParagonIE_Sodium_Compat\CRYPTO_BOX_SECRETKEYBYTES, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Compat\crypto_box_publickey_from_secretkey().

◆ box_secretkey()

static box_secretkey ( $keypair )
static

Références ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_File\box_decrypt(), ParagonIE_Sodium_File\box_encrypt(), et ParagonIE_Sodium_Compat\crypto_box_secretkey().

◆ box_seed_keypair()

static box_seed_keypair ( $seed )
static
Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_box_seed_keypair().

◆ keyExchange()

static keyExchange | ( | $my_sk,
 |  | $their_pk,
 |  | $client_pk,
 |  | $server_pk
 | ) |
static

Libsodium's crypto_kx().

Références ParagonIE_Sodium_Compat\crypto_generichash(), et ParagonIE_Sodium_Compat\crypto_scalarmult().

Référencé par ParagonIE_Sodium_Compat\crypto_kx().

◆ scalarmult()

static scalarmult | ( | $sKey,
 |  | $pKey
 | ) |
static

ECDH over Curve25519

Référencé par ParagonIE_Sodium_Compat\crypto_scalarmult().

◆ scalarmult_base()

static scalarmult_base ( $secret )
static

ECDH over Curve25519, using the basepoint. Used to get a secret key from a public key.

Paramètres
string $secret
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_X25519\crypto_scalarmult_curve25519_ref10_base().

Référencé par ParagonIE_Sodium_Compat\crypto_scalarmult_base().

◆ scalarmult_throw_if_zero()

static scalarmult_throw_if_zero ( $q )
staticprotected

This throws an Error if a zero public key was passed to the function.

Paramètres
string $q
Renvoie
void
Exceptions
SodiumException
TypeError

Références $i.

◆ secretstream_xchacha20poly1305_init_pull()

static secretstream_xchacha20poly1305_init_pull | ( | $key,
 |  | $header
 | ) |
static
Paramètres
string | $key
string | $header
Renvoie
string Returns a state.
Exceptions
Exception

Références $header, $key, $state, ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_pull().

◆ secretstream_xchacha20poly1305_init_push()

static secretstream_xchacha20poly1305_init_push ( $key )
static
Paramètres
string $key
Renvoie
array<int, string> Returns a state and a header.
Exceptions
Exception
SodiumException

Références $key, $state, ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_push().

◆ secretstream_xchacha20poly1305_rekey()

static secretstream_xchacha20poly1305_rekey ( & $state )
static
Paramètres
string $state
Renvoie
void
Exceptions
SodiumException

Références $state, ParagonIE_Sodium_Core_SecretStream_State\fromString(), et ParagonIE_Sodium_Core_ChaCha20\ietfStreamXorIc().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_rekey().

◆ sign()

static sign | ( | $message,
 |  | $sk
 | ) |
static

Attached Ed25519 signature. (Returns a signed message.)

Références $message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign().

◆ sign_detached()

static sign_detached | ( | $message,
 |  | $sk
 | ) |
static

Detached Ed25519 signature.

Références $message, et ParagonIE_Sodium_Core_Ed25519\sign_detached().

Référencé par ParagonIE_Sodium_Compat\crypto_sign_detached().

◆ sign_open()

static sign_open | ( | $signedMessage,
 |  | $pk
 | ) |
static

Opens a signed message. If valid, returns the message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign_open().

◆ sign_verify_detached()

static sign_verify_detached | ( | $signature,
 |  | $message,
 |  | $pk
 | ) |
static

Verify a detached signature of a given message and public key.

Références $message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign_verify_detached().

Documentation des champs

◆ aead_chacha20poly1305_ABYTES

const aead_chacha20poly1305_ABYTES = 16

◆ aead_chacha20poly1305_IETF_ABYTES

const aead_chacha20poly1305_IETF_ABYTES = 16

◆ aead_chacha20poly1305_IETF_KEYBYTES

const aead_chacha20poly1305_IETF_KEYBYTES = 32

◆ aead_chacha20poly1305_IETF_NPUBBYTES

const aead_chacha20poly1305_IETF_NPUBBYTES = 12

◆ aead_chacha20poly1305_IETF_NSECBYTES

const aead_chacha20poly1305_IETF_NSECBYTES = 0

◆ aead_chacha20poly1305_KEYBYTES

const aead_chacha20poly1305_KEYBYTES = 32

◆ aead_chacha20poly1305_NPUBBYTES

const aead_chacha20poly1305_NPUBBYTES = 8

◆ aead_chacha20poly1305_NSECBYTES

const aead_chacha20poly1305_NSECBYTES = 0

◆ aead_xchacha20poly1305_IETF_ABYTES

const aead_xchacha20poly1305_IETF_ABYTES = 16

◆ aead_xchacha20poly1305_IETF_KEYBYTES

const aead_xchacha20poly1305_IETF_KEYBYTES = 32

◆ aead_xchacha20poly1305_IETF_NPUBBYTES

const aead_xchacha20poly1305_IETF_NPUBBYTES = 24

◆ aead_xchacha20poly1305_IETF_NSECBYTES

const aead_xchacha20poly1305_IETF_NSECBYTES = 0

◆ box_curve25519xsalsa20poly1305_BEFORENMBYTES

const box_curve25519xsalsa20poly1305_BEFORENMBYTES = 32

◆ box_curve25519xsalsa20poly1305_BOXZEROBYTES

const box_curve25519xsalsa20poly1305_BOXZEROBYTES = 16

◆ box_curve25519xsalsa20poly1305_MACBYTES

const box_curve25519xsalsa20poly1305_MACBYTES = 16

◆ box_curve25519xsalsa20poly1305_NONCEBYTES

const box_curve25519xsalsa20poly1305_NONCEBYTES = 24

◆ box_curve25519xsalsa20poly1305_PUBLICKEYBYTES

const box_curve25519xsalsa20poly1305_PUBLICKEYBYTES = 32

◆ box_curve25519xsalsa20poly1305_SECRETKEYBYTES

const box_curve25519xsalsa20poly1305_SECRETKEYBYTES = 32

◆ box_curve25519xsalsa20poly1305_SEEDBYTES

const box_curve25519xsalsa20poly1305_SEEDBYTES = 32

◆ box_curve25519xsalsa20poly1305_ZEROBYTES

const box_curve25519xsalsa20poly1305_ZEROBYTES = 32

◆ onetimeauth_poly1305_BYTES

const onetimeauth_poly1305_BYTES = 16

◆ onetimeauth_poly1305_KEYBYTES

const onetimeauth_poly1305_KEYBYTES = 32

◆ secretbox_xchacha20poly1305_BOXZEROBYTES

const secretbox_xchacha20poly1305_BOXZEROBYTES = 16

◆ secretbox_xchacha20poly1305_KEYBYTES

const secretbox_xchacha20poly1305_KEYBYTES = 32

◆ secretbox_xchacha20poly1305_MACBYTES

const secretbox_xchacha20poly1305_MACBYTES = 16

◆ secretbox_xchacha20poly1305_NONCEBYTES

const secretbox_xchacha20poly1305_NONCEBYTES = 24

◆ secretbox_xchacha20poly1305_ZEROBYTES

const secretbox_xchacha20poly1305_ZEROBYTES = 32

◆ secretbox_xsalsa20poly1305_BOXZEROBYTES

const secretbox_xsalsa20poly1305_BOXZEROBYTES = 16

◆ secretbox_xsalsa20poly1305_KEYBYTES

const secretbox_xsalsa20poly1305_KEYBYTES = 32

◆ secretbox_xsalsa20poly1305_MACBYTES

const secretbox_xsalsa20poly1305_MACBYTES = 16

◆ secretbox_xsalsa20poly1305_NONCEBYTES

const secretbox_xsalsa20poly1305_NONCEBYTES = 24

◆ secretbox_xsalsa20poly1305_ZEROBYTES

const secretbox_xsalsa20poly1305_ZEROBYTES = 32

◆ stream_salsa20_KEYBYTES

const stream_salsa20_KEYBYTES = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/paragonie/sodium_compat/src/Crypto.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_Crypto32

Fonctions membres publiques statiques | Champs de données | Fonctions membres protégées statiques
Référence de la classe ParagonIE_Sodium_Crypto32

Fonctions membres publiques statiques

static | aead_xchacha20poly1305_ietf_decrypt ( $message='', $ad='', $nonce='', $key='')
static | aead_xchacha20poly1305_ietf_encrypt ( $message='', $ad='', $nonce='', $key='')
static | auth ($message, $key)
static | auth_verify ($mac, $message, $key)
static | box ($plaintext, $nonce, $keypair)
static | box_beforenm ($sk, $pk)
static | box_keypair ()
static | box_seed_keypair ($seed)
static | box_keypair_from_secretkey_and_publickey ($sKey, $pKey)
static | box_secretkey ($keypair)
static | box_publickey ($keypair)
static | box_publickey_from_secretkey ($sKey)
static | box_open ($ciphertext, $nonce, $keypair)
static | keyExchange ($my_sk, $their_pk, $client_pk, $server_pk)
static | scalarmult ($sKey, $pKey)
static | scalarmult_base ($secret)
static | secretstream_xchacha20poly1305_init_push ($key)
static | secretstream_xchacha20poly1305_init_pull ($key, $header)
static | secretstream_xchacha20poly1305_rekey (&$state)
static | sign_detached ($message, $sk)
static | sign ($message, $sk)
static | sign_open ($signedMessage, $pk)
static | sign_verify_detached ($signature, $message, $pk)

Champs de données

const | aead_chacha20poly1305_KEYBYTES = 32
const | aead_chacha20poly1305_NSECBYTES = 0
const | aead_chacha20poly1305_NPUBBYTES = 8
const | aead_chacha20poly1305_ABYTES = 16
const | aead_chacha20poly1305_IETF_KEYBYTES = 32
const | aead_chacha20poly1305_IETF_NSECBYTES = 0
const | aead_chacha20poly1305_IETF_NPUBBYTES = 12
const | aead_chacha20poly1305_IETF_ABYTES = 16
const | aead_xchacha20poly1305_IETF_KEYBYTES = 32
const | aead_xchacha20poly1305_IETF_NSECBYTES = 0
const | aead_xchacha20poly1305_IETF_NPUBBYTES = 24
const | aead_xchacha20poly1305_IETF_ABYTES = 16
const | box_curve25519xsalsa20poly1305_SEEDBYTES = 32
const | box_curve25519xsalsa20poly1305_PUBLICKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_SECRETKEYBYTES = 32
const | box_curve25519xsalsa20poly1305_BEFORENMBYTES = 32
const | box_curve25519xsalsa20poly1305_NONCEBYTES = 24
const | box_curve25519xsalsa20poly1305_MACBYTES = 16
const | box_curve25519xsalsa20poly1305_BOXZEROBYTES = 16
const | box_curve25519xsalsa20poly1305_ZEROBYTES = 32
const | onetimeauth_poly1305_BYTES = 16
const | onetimeauth_poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_KEYBYTES = 32
const | secretbox_xsalsa20poly1305_NONCEBYTES = 24
const | secretbox_xsalsa20poly1305_MACBYTES = 16
const | secretbox_xsalsa20poly1305_BOXZEROBYTES = 16
const | secretbox_xsalsa20poly1305_ZEROBYTES = 32
const | secretbox_xchacha20poly1305_KEYBYTES = 32
const | secretbox_xchacha20poly1305_NONCEBYTES = 24
const | secretbox_xchacha20poly1305_MACBYTES = 16
const | secretbox_xchacha20poly1305_BOXZEROBYTES = 16
const | secretbox_xchacha20poly1305_ZEROBYTES = 32
const | stream_salsa20_KEYBYTES = 32

Fonctions membres protégées statiques

static scalarmult_throw_if_zero ($q)

Description détaillée

Class ParagonIE_Sodium_Crypto

ATTENTION!

If you are using this library, you should be using ParagonIE_Sodium_Compat in your code, not this class.

Documentation des fonctions membres

◆ aead_xchacha20poly1305_ietf_decrypt()

static aead_xchacha20poly1305_ietf_decrypt | ( | $message = '',
 |  | $ad = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

AEAD Decryption with ChaCha20-Poly1305, IETF mode (96-bit nonce)

Références $key, $message, ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_decrypt().

◆ aead_xchacha20poly1305_ietf_encrypt()

static aead_xchacha20poly1305_ietf_encrypt | ( | $message = '',
 |  | $ad = '',
 |  | $nonce = '',
 |  | $key = ''
 | ) |
static

AEAD Encryption with ChaCha20-Poly1305, IETF mode (96-bit nonce)

Références $key, $message, ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_encrypt().

◆ auth()

static auth | ( | $message,
 |  | $key
 | ) |
static

HMAC-SHA-512-256 (a.k.a. the leftmost 256 bits of HMAC-SHA-512)

Références $key, $message, et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_auth().

◆ auth_verify()

static auth_verify | ( | $mac,
 |  | $message,
 |  | $key
 | ) |
static

HMAC-SHA-512-256 validation. Constant-time via hash_equals().

Références $key, et $message.

Référencé par ParagonIE_Sodium_Compat\crypto_auth_verify().

◆ box()

static box | ( | $plaintext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

X25519 key exchange followed by XSalsa20Poly1305 symmetric encryption

Référencé par ParagonIE_Sodium_Compat\crypto_box().

◆ box_beforenm()

static box_beforenm | ( | $sk,
 |  | $pk
 | ) |
static

Used by crypto_box() to get the crypto_secretbox() key.

Référencé par ParagonIE_Sodium_File\box_decrypt(), et ParagonIE_Sodium_File\box_encrypt().

◆ box_keypair()

static box_keypair ( )
static

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair().

◆ box_keypair_from_secretkey_and_publickey()

static box_keypair_from_secretkey_and_publickey | ( | $sKey,
 |  | $pKey
 | ) |
static

Références ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_box_keypair_from_secretkey_and_publickey().

◆ box_open()

static box_open | ( | $ciphertext,
 |  | $nonce,
 |  | $keypair
 | ) |
static

Decrypt a message encrypted with box().

Référencé par ParagonIE_Sodium_Compat\crypto_box_open().

◆ box_publickey()

static box_publickey ( $keypair )
static

Références ParagonIE_Sodium_Compat\CRYPTO_BOX_KEYPAIRBYTES, ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_File\box_decrypt(), ParagonIE_Sodium_File\box_encrypt(), et ParagonIE_Sodium_Compat\crypto_box_publickey().

◆ box_publickey_from_secretkey()

static box_publickey_from_secretkey ( $sKey )
static

Références ParagonIE_Sodium_Compat\CRYPTO_BOX_SECRETKEYBYTES, et ParagonIE_Sodium_Core_Util\strlen().

Référencé par ParagonIE_Sodium_Compat\crypto_box_publickey_from_secretkey().

◆ box_secretkey()

static box_secretkey ( $keypair )
static

Références ParagonIE_Sodium_Core_Util\strlen(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_File\box_decrypt(), ParagonIE_Sodium_File\box_encrypt(), et ParagonIE_Sodium_Compat\crypto_box_secretkey().

◆ box_seed_keypair()

static box_seed_keypair ( $seed )
static
Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_box_seed_keypair().

◆ keyExchange()

static keyExchange | ( | $my_sk,
 |  | $their_pk,
 |  | $client_pk,
 |  | $server_pk
 | ) |
static

Libsodium's crypto_kx().

Référencé par ParagonIE_Sodium_Compat\crypto_kx().

◆ scalarmult()

static scalarmult | ( | $sKey,
 |  | $pKey
 | ) |
static

ECDH over Curve25519

Référencé par ParagonIE_Sodium_Compat\crypto_scalarmult().

◆ scalarmult_base()

static scalarmult_base ( $secret )
static

ECDH over Curve25519, using the basepoint. Used to get a secret key from a public key.

Paramètres
string $secret
Renvoie
string
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Core32_X25519\crypto_scalarmult_curve25519_ref10_base().

Référencé par ParagonIE_Sodium_Compat\crypto_scalarmult_base().

◆ scalarmult_throw_if_zero()

static scalarmult_throw_if_zero ( $q )
staticprotected

This throws an Error if a zero public key was passed to the function.

Paramètres
string $q
Renvoie
void
Exceptions
SodiumException
TypeError

Références $i.

◆ secretstream_xchacha20poly1305_init_pull()

static secretstream_xchacha20poly1305_init_pull | ( | $key,
 |  | $header
 | ) |
static
Paramètres
string | $key
string | $header
Renvoie
string Returns a state.
Exceptions
Exception

Références $header, $key, $state, ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_pull().

◆ secretstream_xchacha20poly1305_init_push()

static secretstream_xchacha20poly1305_init_push ( $key )
static
Paramètres
string $key
Renvoie
array<int, string> Returns a state and a header.
Exceptions
Exception
SodiumException

Références $key, $state, ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), et ParagonIE_Sodium_Core_Util\substr().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_push().

◆ secretstream_xchacha20poly1305_rekey()

static secretstream_xchacha20poly1305_rekey ( & $state )
static
Paramètres
string $state
Renvoie
void
Exceptions
SodiumException

Références $state, ParagonIE_Sodium_Core32_SecretStream_State\fromString(), et ParagonIE_Sodium_Core32_ChaCha20\ietfStreamXorIc().

Référencé par ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_rekey().

◆ sign()

static sign | ( | $message,
 |  | $sk
 | ) |
static

Attached Ed25519 signature. (Returns a signed message.)

Références $message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign().

◆ sign_detached()

static sign_detached | ( | $message,
 |  | $sk
 | ) |
static

Detached Ed25519 signature.

Références $message, et ParagonIE_Sodium_Core32_Ed25519\sign_detached().

Référencé par ParagonIE_Sodium_Compat\crypto_sign_detached().

◆ sign_open()

static sign_open | ( | $signedMessage,
 |  | $pk
 | ) |
static

Opens a signed message. If valid, returns the message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign_open().

◆ sign_verify_detached()

static sign_verify_detached | ( | $signature,
 |  | $message,
 |  | $pk
 | ) |
static

Verify a detached signature of a given message and public key.

Références $message.

Référencé par ParagonIE_Sodium_Compat\crypto_sign_verify_detached().

Documentation des champs

◆ aead_chacha20poly1305_ABYTES

const aead_chacha20poly1305_ABYTES = 16

◆ aead_chacha20poly1305_IETF_ABYTES

const aead_chacha20poly1305_IETF_ABYTES = 16

◆ aead_chacha20poly1305_IETF_KEYBYTES

const aead_chacha20poly1305_IETF_KEYBYTES = 32

◆ aead_chacha20poly1305_IETF_NPUBBYTES

const aead_chacha20poly1305_IETF_NPUBBYTES = 12

◆ aead_chacha20poly1305_IETF_NSECBYTES

const aead_chacha20poly1305_IETF_NSECBYTES = 0

◆ aead_chacha20poly1305_KEYBYTES

const aead_chacha20poly1305_KEYBYTES = 32

◆ aead_chacha20poly1305_NPUBBYTES

const aead_chacha20poly1305_NPUBBYTES = 8

◆ aead_chacha20poly1305_NSECBYTES

const aead_chacha20poly1305_NSECBYTES = 0

◆ aead_xchacha20poly1305_IETF_ABYTES

const aead_xchacha20poly1305_IETF_ABYTES = 16

◆ aead_xchacha20poly1305_IETF_KEYBYTES

const aead_xchacha20poly1305_IETF_KEYBYTES = 32

◆ aead_xchacha20poly1305_IETF_NPUBBYTES

const aead_xchacha20poly1305_IETF_NPUBBYTES = 24

◆ aead_xchacha20poly1305_IETF_NSECBYTES

const aead_xchacha20poly1305_IETF_NSECBYTES = 0

◆ box_curve25519xsalsa20poly1305_BEFORENMBYTES

const box_curve25519xsalsa20poly1305_BEFORENMBYTES = 32

◆ box_curve25519xsalsa20poly1305_BOXZEROBYTES

const box_curve25519xsalsa20poly1305_BOXZEROBYTES = 16

◆ box_curve25519xsalsa20poly1305_MACBYTES

const box_curve25519xsalsa20poly1305_MACBYTES = 16

◆ box_curve25519xsalsa20poly1305_NONCEBYTES

const box_curve25519xsalsa20poly1305_NONCEBYTES = 24

◆ box_curve25519xsalsa20poly1305_PUBLICKEYBYTES

const box_curve25519xsalsa20poly1305_PUBLICKEYBYTES = 32

◆ box_curve25519xsalsa20poly1305_SECRETKEYBYTES

const box_curve25519xsalsa20poly1305_SECRETKEYBYTES = 32

◆ box_curve25519xsalsa20poly1305_SEEDBYTES

const box_curve25519xsalsa20poly1305_SEEDBYTES = 32

◆ box_curve25519xsalsa20poly1305_ZEROBYTES

const box_curve25519xsalsa20poly1305_ZEROBYTES = 32

◆ onetimeauth_poly1305_BYTES

const onetimeauth_poly1305_BYTES = 16

◆ onetimeauth_poly1305_KEYBYTES

const onetimeauth_poly1305_KEYBYTES = 32

◆ secretbox_xchacha20poly1305_BOXZEROBYTES

const secretbox_xchacha20poly1305_BOXZEROBYTES = 16

◆ secretbox_xchacha20poly1305_KEYBYTES

const secretbox_xchacha20poly1305_KEYBYTES = 32

◆ secretbox_xchacha20poly1305_MACBYTES

const secretbox_xchacha20poly1305_MACBYTES = 16

◆ secretbox_xchacha20poly1305_NONCEBYTES

const secretbox_xchacha20poly1305_NONCEBYTES = 24

◆ secretbox_xchacha20poly1305_ZEROBYTES

const secretbox_xchacha20poly1305_ZEROBYTES = 32

◆ secretbox_xsalsa20poly1305_BOXZEROBYTES

const secretbox_xsalsa20poly1305_BOXZEROBYTES = 16

◆ secretbox_xsalsa20poly1305_KEYBYTES

const secretbox_xsalsa20poly1305_KEYBYTES = 32

◆ secretbox_xsalsa20poly1305_MACBYTES

const secretbox_xsalsa20poly1305_MACBYTES = 16

◆ secretbox_xsalsa20poly1305_NONCEBYTES

const secretbox_xsalsa20poly1305_NONCEBYTES = 24

◆ secretbox_xsalsa20poly1305_ZEROBYTES

const secretbox_xsalsa20poly1305_ZEROBYTES = 32

◆ stream_salsa20_KEYBYTES

const stream_salsa20_KEYBYTES = 32
La documentation de cette classe a été générée à partir du fichier suivant :
  • Crypto32.php


Joomla CMS: Référence de la classe ParagonIE_Sodium_File

Champs de données | Fonctions membres protégées statiques | Fonctions membres privées statiques
Référence de la classe ParagonIE_Sodium_File
+ Graphe d'héritage de ParagonIE_Sodium_File:
ParagonIE_Sodium_Core_Util File

Champs de données

const BUFFER_SIZE = 8192

Fonctions membres protégées statiques

static | box_encrypt ($ifp, $ofp, $mlen, $nonce, $boxKeypair)
static | box_decrypt ($ifp, $ofp, $mlen, $nonce, $boxKeypair)
- Fonctions membres protégées statiques hérités de ParagonIE_Sodium_Core_Util
static | hash_update (&$hs, $data)

Fonctions membres privées statiques

static ftell ($resource)

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de ParagonIE_Sodium_Core_Util
static | compare ($left, $right, $len=null)
static | declareScalarType (&$mixedVar=null, $type='void', $argumentIndex=0)
static | intToChr ($int)
static | memcmp ($left, $right)
static | strlen ($str)
static | substr ($str, $start=0, $length=null)
static | verify_16 ($a, $b)
static | verify_32 ($a, $b)
static | xorStrings ($a, $b)

Description détaillée

Class ParagonIE_Sodium_File

Documentation des fonctions membres

◆ box_decrypt()

static box_decrypt | ( | $ifp,
 |  | $ofp,
 |  | $mlen,
 |  | $nonce,
 |  | $boxKeypair
 | ) |
staticprotected
Paramètres
resource | $ifp
resource | $ofp
int | $mlen
string | $nonce
string | $boxKeypair
Renvoie
bool
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Crypto32\box_beforenm(), ParagonIE_Sodium_Crypto\box_beforenm(), ParagonIE_Sodium_Crypto32\box_publickey(), ParagonIE_Sodium_Crypto\box_publickey(), ParagonIE_Sodium_Crypto32\box_secretkey(), et ParagonIE_Sodium_Crypto\box_secretkey().

◆ box_encrypt()

static box_encrypt | ( | $ifp,
 |  | $ofp,
 |  | $mlen,
 |  | $nonce,
 |  | $boxKeypair
 | ) |
staticprotected
Paramètres
resource | $ifp
resource | $ofp
int | $mlen
string | $nonce
string | $boxKeypair
Renvoie
bool
Exceptions
SodiumException
TypeError

Références ParagonIE_Sodium_Crypto32\box_beforenm(), ParagonIE_Sodium_Crypto\box_beforenm(), ParagonIE_Sodium_Crypto32\box_publickey(), ParagonIE_Sodium_Crypto\box_publickey(), ParagonIE_Sodium_Crypto32\box_secretkey(), et ParagonIE_Sodium_Crypto\box_secretkey().

◆ ftell()

static ftell ( $resource )
staticprivate
Paramètres
resource $resource
Renvoie
int
Exceptions
SodiumException

Références $return.

Documentation des champs

◆ BUFFER_SIZE

const BUFFER_SIZE = 8192
La documentation de cette classe a été générée à partir du fichier suivant :
  • vendor/paragonie/sodium_compat/src/File.php


Joomla CMS: Référence de la classe PasswordHash

Fonctions membres publiques | Champs de données
Référence de la classe PasswordHash

Fonctions membres publiques

__construct ($iteration_count_log2, $portable_hashes)
PasswordHash ($iteration_count_log2, $portable_hashes)
get_random_bytes ($count)
encode64 ($input, $count)
gensalt_private ($input)
crypt_private ($password, $setting)
gensalt_blowfish ($input)
HashPassword ($password)
CheckPassword ($password, $stored_hash)

Champs de données

$itoa64
$iteration_count_log2
$portable_hashes
$random_state

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | $iteration_count_log2,
 |  | $portable_hashes
 | ) |

Références $iteration_count_log2, et $portable_hashes.

Documentation des fonctions membres

◆ CheckPassword()

CheckPassword | ( | $password,
 |  | $stored_hash
 | ) |

Références $hash, $password, et crypt_private().

◆ crypt_private()

crypt_private | ( | $password,
 |  | $setting
 | ) |

Références $count, $hash, $id, $output, $password, et encode64().

Référencé par CheckPassword(), et HashPassword().

◆ encode64()

encode64 | ( | $input,
 |  | $count
 | ) |

Références $count, $i, $input, $output, et $value.

Référencé par crypt_private(), et gensalt_private().

◆ gensalt_blowfish()

gensalt_blowfish ( $input )

Références $i, $input, $itoa64, et $output.

Référencé par HashPassword().

◆ gensalt_private()

gensalt_private ( $input )

Références $input, $output, et encode64().

Référencé par HashPassword().

◆ get_random_bytes()

get_random_bytes ( $count )

Références $count, $i, et $output.

Référencé par HashPassword().

◆ HashPassword()

HashPassword ( $password )

Références $hash, $password, crypt_private(), gensalt_blowfish(), gensalt_private(), et get_random_bytes().

◆ PasswordHash()

PasswordHash | ( | $iteration_count_log2,
 |  | $portable_hashes
 | ) |

Références $iteration_count_log2, $portable_hashes, et Symfony\Contracts\Service\__construct().

Documentation des champs

◆ $iteration_count_log2

$iteration_count_log2

Référencé par __construct(), et PasswordHash().

◆ $itoa64

$itoa64

Référencé par gensalt_blowfish().

◆ $portable_hashes

$portable_hashes

Référencé par __construct(), et PasswordHash().

◆ $random_state

$random_state
La documentation de cette classe a été générée à partir du fichier suivant :
  • PasswordHash.php


Joomla CMS: Référence de la classe PlgAuthenticationCookie

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgAuthenticationCookie
+ Graphe d'héritage de PlgAuthenticationCookie:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyCollectAdminCapabilities ()
onUserAuthenticate ($credentials, $options, &$response)
onUserAfterLogin ($options)
onUserAfterLogout ($options)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla Authentication plugin

Depuis
3.2
Note
Code based on http://jaspan.com/improved_persistent_login_cookie_best_practice and http://fishbowl.pastiche.org/2004/01/19/persistent_login_cookie_best_practice/

Documentation des fonctions membres

◆ onPrivacyCollectAdminCapabilities()

onPrivacyCollectAdminCapabilities ( )

Reports the privacy related capabilities for this plugin to site administrators.

Renvoie
array
Depuis
3.9.0

◆ onUserAfterLogin()

onUserAfterLogin ( $options )

We set the authentication cookie only after login is successfully finished. We set a new cookie either for a user with no cookies or one where the user used a cookie to authenticate.

Paramètres
array $options Array holding options
Renvoie
boolean True on success
Depuis
3.2

Références $options, $query, $results, elseif, null, et true.

◆ onUserAfterLogout()

onUserAfterLogout ( $options )

This is where we delete any authentication cookie when a user logs out

Paramètres
array $options Array holding options (length, timeToExpiration)
Renvoie
boolean True on success
Depuis
3.2

Références $query.

◆ onUserAuthenticate()

onUserAuthenticate | ( |  | $credentials,
 |  |  | $options,
 |  | & | $response
 | ) |  |

This method should handle any authentication and report back to the subject

Paramètres
array | $credentials | Array holding the user credentials
array | $options | Array of extra options
object | &$response | Authentication response object
Renvoie
boolean
Depuis
3.2

Références $now, $query, $result, $results, et $user.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • cookie.php


Joomla CMS: Référence de la classe PlgAuthenticationJoomla

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgAuthenticationJoomla
+ Graphe d'héritage de PlgAuthenticationJoomla:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserAuthenticate ($credentials, $options, &$response)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla Authentication plugin

Depuis
1.5

Documentation des fonctions membres

◆ onUserAuthenticate()

onUserAuthenticate | ( |  | $credentials,
 |  |  | $options,
 |  | & | $response
 | ) |  |

This method should handle any authentication and report back to the subject

Paramètres
array | $credentials | Array holding the user credentials
array | $options | Array of extra options
object | &$response | Authentication response object
Renvoie
void
Depuis
1.5

Références $db, $query, $result, $user, et User\getInstance().

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/authentication/joomla/joomla.php


Joomla CMS: Référence de la classe PlgAuthenticationLdap

Fonctions membres publiques | Fonctions membres privées
Référence de la classe PlgAuthenticationLdap
+ Graphe d'héritage de PlgAuthenticationLdap:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserAuthenticate ($credentials, $options, &$response)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres privées

searchByString ($search, Ldap $ldap)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

LDAP Authentication Plugin

Depuis
1.5

Documentation des fonctions membres

◆ onUserAuthenticate()

onUserAuthenticate | ( |  | $credentials,
 |  |  | $options,
 |  | & | $response
 | ) |  |

This method should handle any authentication and report back to the subject

Paramètres
array | $credentials | Array holding the user credentials
array | $options | Array of extra options
object | &$response | Authentication response object
Renvoie
boolean
Depuis
1.5

◆ searchByString()

searchByString | ( |  | $search,
 |  | Ldap | $ldap
 | ) |  |
private

Shortcut method to perform a LDAP search based on a semicolon separated string

Note that this method requires that semicolons which should be part of the search term to be escaped to correctly split the search string into separate lookups

Paramètres
string | $search | search string of search values
Ldap | $ldap | The LDAP client
Renvoie
Entry|null The search result entry if a matching record was found
Depuis
3.8.2

Références $key, $result, $results, et Ldap\query().

La documentation de cette classe a été générée à partir du fichier suivant :
  • ldap.php


Joomla CMS: Référence de la classe PlgButtonArticle

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonArticle
+ Graphe d'héritage de PlgButtonArticle:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Article button

Depuis
1.5

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject|void The button options as CMSObject, void if ACL check fails.
Depuis
1.5

Références $button, $link, $name, $user, et Joomla\Application\getFormToken().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • article.php


Joomla CMS: Référence de la classe PlgButtonContact

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonContact
+ Graphe d'héritage de PlgButtonContact:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Contact button

Depuis
3.7.0

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject|void The button options as CMSObject
Depuis
3.7.0

Références $button, $link, $name, $user, et Joomla\Application\getFormToken().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors-xtd/contact/contact.php


Joomla CMS: Référence de la classe PlgButtonFields

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonFields
+ Graphe d'héritage de PlgButtonFields:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Fields button

Depuis
3.7.0

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject|void The button options as CMSObject
Depuis
3.7.0

Références $button, $context, $link, $name, Text\_(), Factory\getApplication(), Joomla\Application\getFormToken(), et ComponentHelper\isEnabled().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors-xtd/fields/fields.php


Joomla CMS: Référence de la classe PlgButtonImage

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonImage
+ Graphe d'héritage de PlgButtonImage:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name, $asset, $author)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Image button

Depuis
1.5

Documentation des fonctions membres

◆ onDisplay()

onDisplay | ( | $name,
 |  | $asset,
 |  | $author
 | ) |

Display the button.

Paramètres
string | $name | The name of the button to display.
string | $asset | The name of the asset being edited.
integer | $author | The id of the author owning the asset being edited.
Renvoie
CMSObject|false
Depuis
1.5

Références $app, $author, $button, $doc, $extension, $link, $name, $parts, $user, Factory\getApplication(), et Factory\getUser().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors-xtd/image/image.php


Joomla CMS: Référence de la classe PlgButtonMenu

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonMenu
+ Graphe d'héritage de PlgButtonMenu:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor menu button

Depuis
3.7.0

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Depuis
3.7.0
Renvoie
CMSObject

Références $button, $link, $name, $user, et Joomla\Application\getFormToken().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • menu.php


Joomla CMS: Référence de la classe PlgButtonModule

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonModule
+ Graphe d'héritage de PlgButtonModule:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Module button

Depuis
3.5

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject|void The button options as CMSObject
Depuis
3.5

Références $button, $link, $name, $user, Text\_(), Joomla\Application\getFormToken(), et Factory\getUser().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • module.php


Joomla CMS: Référence de la classe PlgButtonPagebreak

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonPagebreak
+ Graphe d'héritage de PlgButtonPagebreak:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Pagebreak button

Depuis
1.5

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Display the button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject|void The button options as CMSObject
Depuis
1.5

Références $button, $link, $name, et $user.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors-xtd/pagebreak/pagebreak.php


Joomla CMS: Référence de la classe PlgButtonReadmore

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgButtonReadmore
+ Graphe d'héritage de PlgButtonReadmore:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ($name)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Editor Readmore button

Depuis
1.5

Documentation des fonctions membres

◆ onDisplay()

onDisplay ( $name )

Readmore button

Paramètres
string $name The name of the button to add
Renvoie
CMSObject $button A two element array of (imageName, textToInsert)
Depuis
1.5

Références $button, $doc, $name, path, et width.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors-xtd/readmore/readmore.php


Joomla CMS: Référence de la classe PlgCaptchaRecaptcha

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgCaptchaRecaptcha
+ Graphe d'héritage de PlgCaptchaRecaptcha:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyCollectAdminCapabilities ()
onInit ($id='dynamic_recaptcha_1')
onDisplay ($name=null, $id='dynamic_recaptcha_1', $class='')
onCheckAnswer ($code=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getResponse (string $privatekey, string $remoteip, string $response)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Recaptcha Plugin Based on the official recaptcha library( https://packagist.org/packages/google/recaptcha )

Depuis
2.5

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | string | $privatekey,
 |  | string | $remoteip,
 |  | string | $response
 | ) |  |
private

Get the reCaptcha response.

Paramètres
string | $privatekey | The private key for authentication.
string | $remoteip | The remote IP of the visitor.
string | $response | The response received from Google.
Renvoie
bool True if response is good | False if response is bad.
Depuis
3.4
Exceptions

Références $version.

◆ onCheckAnswer()

onCheckAnswer ( $code = null )

Calls an HTTP POST function to verify if the user's guess was correct

Paramètres
string $code Answer provided by user. Not needed for the Recaptcha implementation
Renvoie
True if the answer is correct, false otherwise
Depuis
2.5
Exceptions

Références $input, $version, et null.

◆ onDisplay()

onDisplay | ( | $name = null,
 |  | $id = 'dynamic_recaptcha_1',
 |  | $class = ''
 | ) |

Gets the challenge HTML

Paramètres
string | $name | The name of the field. Not Used.
string | $id | The id of the field.
string | $class | The class of the field.
Renvoie
string The HTML to be embedded in the form.
Depuis
2.5

Références $class, et $id.

◆ onInit()

onInit ( $id = 'dynamic_recaptcha_1' )

Initialise the captcha

Paramètres
string $id The id of the field.
Renvoie
Boolean True on success, false otherwise
Depuis
2.5
Exceptions

◆ onPrivacyCollectAdminCapabilities()

onPrivacyCollectAdminCapabilities ( )

Reports the privacy related capabilities for this plugin to site administrators.

Renvoie
array
Depuis
3.9.0

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • recaptcha.php


Joomla CMS: Référence de la classe PlgCaptchaRecaptcha_Invisible

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgCaptchaRecaptcha_Invisible
+ Graphe d'héritage de PlgCaptchaRecaptcha_Invisible:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyCollectAdminCapabilities ()
onInit ($id='dynamic_recaptcha_invisible_1')
onDisplay ($name=null, $id='dynamic_recaptcha_invisible_1', $class='')
onCheckAnswer ($code=null)
onSetupField (\Joomla\CMS\Form\Field\CaptchaField $field, \SimpleXMLElement $element)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getResponse ($privatekey, $remoteip, $response)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Invisible reCAPTCHA Plugin.

Depuis
3.9.0

Documentation des fonctions membres

◆ getResponse()

getResponse | ( | $privatekey,
 |  | $remoteip,
 |  | $response
 | ) |
private

Get the reCaptcha response.

Paramètres
string | $privatekey | The private key for authentication.
string | $remoteip | The remote IP of the visitor.
string | $response | The response received from Google.
Renvoie
boolean True if response is good | False if response is bad.
Depuis
3.9.0
Exceptions

◆ onCheckAnswer()

onCheckAnswer ( $code = null )

Calls an HTTP POST function to verify if the user's guess was correct

Paramètres
string $code Answer provided by user. Not needed for the Recaptcha implementation
Renvoie
boolean True if the answer is correct, false otherwise
Depuis
3.9.0
Exceptions

Références $input.

◆ onDisplay()

onDisplay | ( | $name = null,
 |  | $id = 'dynamic_recaptcha_invisible_1',
 |  | $class = ''
 | ) |

Gets the challenge HTML

Paramètres
string | $name | The name of the field. Not Used.
string | $id | The id of the field.
string | $class | The class of the field.
Renvoie
string The HTML to be embedded in the form.
Depuis
3.9.0

Références $class, et $id.

◆ onInit()

onInit ( $id = 'dynamic_recaptcha_invisible_1' )

Initialise the captcha

Paramètres
string $id The id of the field.
Renvoie
boolean True on success, false otherwise
Depuis
3.9.0
Exceptions

◆ onPrivacyCollectAdminCapabilities()

onPrivacyCollectAdminCapabilities ( )

Reports the privacy related capabilities for this plugin to site administrators.

Renvoie
array
Depuis
3.9.0

◆ onSetupField()

onSetupField | ( | \Joomla\CMS\Form\Field\CaptchaField | $field,
 |  | \SimpleXMLElement | $element
 | ) |  |

Method to react on the setup of a captcha field. Gives the possibility to change the field and/or the XML element for the field.

Paramètres
\Joomla\CMS\Form\Field\CaptchaField | $field | Captcha field instance
\SimpleXMLElement | $element | XML form definition
Renvoie
void
Depuis
3.9.0

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • recaptcha_invisible.php


Joomla CMS: Référence de la classe PlgContentConfirmConsent

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgContentConfirmConsent
+ Graphe d'héritage de PlgContentConfirmConsent:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$autoloadLanguage = true
$supportedContext
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

The Joomla Core confirm consent plugin

Depuis
3.9.0

Documentation des fonctions membres

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Add additional fields to the supported forms

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
3.9.0

Références $form, Text\_(), et ENT_COMPAT.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $supportedContext

$supportedContext
protected
Valeur initiale :
= [
'com_contact.contact',
'com_privacy.request',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • confirmconsent.php


Joomla CMS: Référence de la classe PlgContentContact

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgContentContact
+ Graphe d'héritage de PlgContentContact:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepare ($context, &$row, $params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

getContactData ($userId)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Contact Plugin

Depuis
3.2

Documentation des fonctions membres

◆ getContactData()

getContactData ( $userId )
protected

Retrieve Contact

Paramètres
int $userId Id of the user who created the article
Renvoie
stdClass|null Object containing contact details or null if not found

Références $db, $query, et $userId.

◆ onContentPrepare()

onContentPrepare | ( |  | $context,
 |  | & | $row,
 |  |  | $params,
 |  |  | $page = 0
 | ) |  |

Plugin that retrieves contact information for contact

Paramètres
string | $context | The context of the content being passed to the plugin.
mixed | &$row | An object with a "text" property
mixed | $params | Additional parameters. See {
Voir également
PlgContentContent()}.
Paramètres
integer $page Optional page number. Unused. Defaults to zero.
Renvoie
void

Références $context, $params, $url, elseif, et null.

Documentation des champs

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/content/contact/contact.php


Joomla CMS: Référence de la classe PlgContentEmailcloak

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgContentEmailcloak
+ Graphe d'héritage de PlgContentEmailcloak:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepare ($context, &$row, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

_getPattern ($link, $text)
_cloak (&$text, &$params)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Email cloak plugin class.

Depuis
1.5

Documentation des fonctions membres

◆ _cloak()

_cloak | ( | & | $text,
 |  | & | $params
 | ) |  |
protected

Cloak all emails in text from spambots via Javascript.

Paramètres
string | &$text | The string to be cloaked.
mixed | &$params | Additional parameters. Parameter "mode" (integer, default 1) replaces addresses with "mailto:" links if nonzero.
Renvoie
void

Références $mode, et $text.

◆ _getPattern()

_getPattern | ( | $link,
 |  | $text
 | ) |
protected

Generate a search pattern based on link and text.

Paramètres
string | $link | The target of an email link.
string | $text | The text enclosed by the link.
Renvoie
string A regular expression that matches a link containing the parameters.

Références $link, et $text.

◆ onContentPrepare()

onContentPrepare | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Plugin that cloaks all emails in content from spambots via Javascript.

Paramètres
string | $context | The context of the content being passed to the plugin.
mixed | &$row | An object with a "text" property or the string to be cloaked.
mixed | &$params | Additional parameters.
integer | $page | Optional page number. Unused. Defaults to zero.
Renvoie
void

Références $context, et $params.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • emailcloak.php


Joomla CMS: Référence de la classe PlgContentFields

Fonctions membres publiques | Fonctions membres privées
Référence de la classe PlgContentFields
+ Graphe d'héritage de PlgContentFields:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepare ($context, &$item, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres privées

prepare ($string, $context, $item)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Plug-in to show a custom field in eg an article This uses the {fields ID} syntax

Depuis
3.7.0

Documentation des fonctions membres

◆ onContentPrepare()

onContentPrepare | ( |  | $context,
 |  | & | $item,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Plugin that shows a custom field

Paramètres
string | $context | The context of the content being passed to the plugin.
object | &$item | The item object. Note $article->text is also available
object | &$params | The article params
int | $page | The 'page' number
Renvoie
void
Depuis
3.7.0

Références $context, $item, et elseif.

◆ prepare()

prepare | ( | $string,
 |  | $context,
 |  | $item
 | ) |
private

Prepares the given string by parsing {field} and {fieldgroup} groups and replacing them.

Paramètres
string | $string | The text to prepare
string | $context | The context of the content
object | $item | The item object
Renvoie
string
Depuis
3.8.1

Références $context, $field, $fields, $groups, $i, $id, $item, $layout, $output, $parts, FieldsHelper\extract(), FieldsHelper\getFields(), et FieldsHelper\render().

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/content/fields/fields.php


Joomla CMS: Référence de la classe PlgContentFinder

Fonctions membres publiques
Référence de la classe PlgContentFinder
+ Graphe d'héritage de PlgContentFinder:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentAfterSave ($context, $article, $isNew)
onContentBeforeSave ($context, $article, $isNew)
onContentAfterDelete ($context, $article)
onContentChangeState ($context, $pks, $value)
onCategoryChangeState ($extension, $pks, $value)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Smart Search Content Plugin

Depuis
2.5

Documentation des fonctions membres

◆ onCategoryChangeState()

onCategoryChangeState | ( | $extension,
 |  | $pks,
 |  | $value
 | ) |

Smart Search change category state content method. Method is called when the state of the category to which the content item belongs is changed.

Paramètres
string | $extension | The extension whose category has been updated.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $extension, et $value.

◆ onContentAfterDelete()

onContentAfterDelete | ( | $context,
 |  | $article
 | ) |

Smart Search after delete content method. Content is passed by reference, but after the deletion.

Paramètres
string | $context | The context of the content passed to the plugin (added in 1.6).
object | $article | A JTableContent object.
Renvoie
void
Depuis
2.5

Références $article, et $context.

◆ onContentAfterSave()

onContentAfterSave | ( | $context,
 |  | $article,
 |  | $isNew
 | ) |

Smart Search after save content method. Content is passed by reference, but after the save, so no changes will be saved. Method is called right after the content is saved.

Paramètres
string | $context | The context of the content passed to the plugin (added in 1.6)
object | $article | A JTableContent object
bool | $isNew | If the content has just been created
Renvoie
void
Depuis
2.5

Références $article, et $context.

◆ onContentBeforeSave()

onContentBeforeSave | ( | $context,
 |  | $article,
 |  | $isNew
 | ) |

Smart Search before save content method. Content is passed by reference. Method is called before the content is saved.

Paramètres
string | $context | The context of the content passed to the plugin (added in 1.6).
object | $article | A JTableContent object.
bool | $isNew | If the content is just about to be created.
Renvoie
void
Depuis
2.5

Références $article, et $context.

◆ onContentChangeState()

onContentChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Smart Search content state change method. Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $context, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • content/finder/finder.php


Joomla CMS: Référence de la classe PlgContentJoomla

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgContentJoomla
+ Graphe d'héritage de PlgContentJoomla:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentBeforeSave ($context, $table, $isNew, $data)
onContentAfterSave ($context, $article, $isNew)
onContentBeforeDelete ($context, $data)
onContentBeforeChangeState ($context, $pks, $value)
onContentChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

_canDeleteCategories ($data)
_canDeleteStage ($pk)
_countItemsInCategory ($table, $catid)
_countItemsInStage (array $stageIds, string $extension)
_countItemsInChildren ($table, $catid, $data)
checkMenuItemBeforeSave ($context, $table, $isNew, $data)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Example Content Plugin

Depuis
1.6

Documentation des fonctions membres

◆ _canDeleteCategories()

_canDeleteCategories ( $data )
private

Checks if a given category can be deleted

Paramètres
object $data The category object
Renvoie
boolean

Références $count, $data, $extension, $result, et elseif.

◆ _canDeleteStage()

_canDeleteStage ( $pk )
private

Checks if a given stage can be deleted

Paramètres
int $pk The stage ID
Renvoie
boolean
Depuis
4.0.0

Références $component, $parts, $result, et Joomla\CMS\MVC\Model\$workflow.

◆ _countItemsInCategory()

_countItemsInCategory | ( | $table,
 |  | $catid
 | ) |
private

Get count of items in a category

Paramètres
string | $table | table name of component table (column is catid)
integer | $catid | id of the category to check
Renvoie
mixed count of items found or false if db error
Depuis
1.6

Références $count, $db, et $query.

◆ _countItemsInChildren()

_countItemsInChildren | ( | $table,
 |  | $catid,
 |  | $data
 | ) |
private

Get count of items in a category's child categories

Paramètres
string | $table | table name of component table (column is catid)
integer | $catid | id of the category to check
object | $data | The data relating to the content that was deleted.
Renvoie
mixed count of items found or false if db error
Depuis
1.6

Références $count, $data, $db, et $query.

◆ _countItemsInStage()

_countItemsInStage | ( | array | $stageIds,
 |  | string | $extension
 | ) |  |
private

Get count of items in assigned to a stage

Paramètres
array | $stageIds | The stage ids to test for
string | $extension | The extension of the workflow
Renvoie
bool
Depuis
4.0.0

Références $component, $db, $extension, $parts, $query, $section, et ArrayHelper\toInteger().

◆ checkMenuItemBeforeSave()

checkMenuItemBeforeSave | ( | $context,
 |  | $table,
 |  | $isNew,
 |  | $data
 | ) |
private

The save event.

Paramètres
string | $context | The context
object | $table | The item
boolean | $isNew | Is new item
array | $data | The validated data
Renvoie
boolean
Depuis
3.9.12

Références $context, et $params.

◆ onContentAfterSave()

onContentAfterSave | ( | $context,
 |  | $article,
 |  | $isNew
 | ) |

Example after save content method Article is passed by reference, but after the save, so no changes will be saved. Method is called right after the content is saved

Paramètres
string | $context | The context of the content passed to the plugin (added in 1.6)
object | $article | A JTableContent object
boolean | $isNew | If the content is just about to be created
Renvoie
void
Depuis
1.6

Références $article, $context, $db, $lang, $message, $query, $user, User\getInstance(), et ComponentHelper\getParams().

◆ onContentBeforeChangeState()

onContentBeforeChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Don't allow workflows/stages to be deleted if they contain items

Paramètres
string | $context | The context for the content passed to the plugin.
object | $pks | The IDs of the records which will be changed.
object | $value | The new state.
Renvoie
boolean
Depuis
4.0.0

Références $context, $id, $result, et $value.

◆ onContentBeforeDelete()

onContentBeforeDelete | ( | $context,
 |  | $data
 | ) |

Don't allow categories to be deleted if they contain items or subcategories with items

Paramètres
string | $context | The context for the content passed to the plugin.
object | $data | The data relating to the content that was deleted.
Renvoie
boolean
Depuis
1.6

Références $context, et $data.

◆ onContentBeforeSave()

onContentBeforeSave | ( | $context,
 |  | $table,
 |  | $isNew,
 |  | $data
 | ) |

The save event.

Paramètres
string | $context | The context
object | $table | The item
boolean | $isNew | Is new item
array | $data | The validated data
Renvoie
boolean
Depuis
4.0.0

Références $context, $data, et $item.

◆ onContentChangeState()

onContentChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Change the state in core_content if the stage in a table is changed

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | A list of primary key ids of the content that has changed stage.
integer | $value | The value of the condition that the content has been changed to
Renvoie
boolean
Depuis
3.1

Références $context, $db, $query, $value, et ArrayHelper\toInteger().

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/content/joomla/joomla.php


Joomla CMS: Référence de la classe PlgContentLoadmodule

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés statiques
Référence de la classe PlgContentLoadmodule
+ Graphe d'héritage de PlgContentLoadmodule:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepare ($context, &$article, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

_load ($position, $style='none')
_loadmod ($module, $title, $style='none')
_loadid ($id)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés statiques

static | $modules = array()
static | $mods = array()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Plugin to enable loading modules into content (e.g. articles) This uses the {loadmodule} syntax

Depuis
1.5

Documentation des fonctions membres

◆ _load()

_load | ( | $position,
 |  | $style = 'none'
 | ) |
protected

Loads and renders the module

Paramètres
string | $position | The position assigned to the module
string | $style | The style assigned to the module
Renvoie
mixed
Depuis
1.6

Références $document, $module, $modules, $params, $position, $renderer, et $style.

◆ _loadid()

_loadid ( $id )
protected

Loads and renders the module

Paramètres
string $id The id of the module
Renvoie
mixed
Depuis
3.9.0

Références $document, $id, $modules, $params, et $renderer.

◆ _loadmod()

_loadmod | ( | $module,
 |  | $title,
 |  | $style = 'none'
 | ) |
protected

This is always going to get the first instance of the module type unless there is a title.

Paramètres
string | $module | The module title
string | $title | The title of the module
string | $style | The style of the module
Renvoie
mixed
Depuis
1.6

Références $document, $mod, $module, $name, $params, $renderer, $style, et $title.

◆ onContentPrepare()

onContentPrepare | ( |  | $context,
 |  | & | $article,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Plugin that loads module positions within content

Paramètres
string | $context | The context of the content being passed to the plugin.
object | &$article | The article object. Note $article->text is also available
mixed | &$params | The article params
integer | $page | The 'page' number
Renvoie
void
Depuis
1.6

Références $article, $context, $id, $module, $name, $output, $position, $start, $style, et null.

Documentation des champs

◆ $mods

$mods = array()
staticprotected

◆ $modules

$modules = array()
staticprotected
La documentation de cette classe a été générée à partir du fichier suivant :
  • loadmodule.php


Joomla CMS: Référence de la classe PlgContentPagebreak

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgContentPagebreak
+ Graphe d'héritage de PlgContentPagebreak:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepare ($context, &$row, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

_createToc (&$row, &$matches, &$page)
_createNavigation (&$row, $page, $n)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$list = array()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Page break plugin

Usage:

or

or

or

Depuis
1.6

Documentation des fonctions membres

◆ _createNavigation()

_createNavigation | ( | & | $row,
 |  |  | $page,
 |  |  | $n
 | ) |  |
protected

Creates the navigation for the item

Paramètres
object | &$row | The article object. Note $article->text is also available
int | $page | The page number
int | $n | The total number of pages
Renvoie
void
Depuis
1.6

Références $n, et $path.

◆ _createToc()

_createToc | ( | & | $row,
 |  | & | $matches,
 |  | & | $page
 | ) |  |
protected

Creates a Table of Contents for the pagebreak

Paramètres
object | &$row | The article object. Note $article->text is also available
array | &$matches | Array of matches of a regex in onContentPrepare
integer | &$page | The 'page' number
Renvoie
void
Depuis
1.6

Références $heading, $i, $input, $list, $path, $title, elseif, et ENT_QUOTES.

◆ onContentPrepare()

onContentPrepare | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Plugin that adds a pagebreak into the text and truncates text at that point

Paramètres
string | $context | The context of the content being passed to the plugin.
object | &$row | The article object. Note $article->text is also available
mixed | &$params | The article params
integer | $page | The 'page' number
Renvoie
void
Depuis
1.6

Références $context, $input, $key, $n, $params, $style, $text, $title, $view, et elseif.

Documentation des champs

◆ $list

$list = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/content/pagebreak/pagebreak.php


Joomla CMS: Référence de la classe PlgContentPagenavigation

Fonctions membres publiques
Référence de la classe PlgContentPagenavigation
+ Graphe d'héritage de PlgContentPagenavigation:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentBeforeDisplay ($context, &$row, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Pagenavigation plugin class.

Depuis
1.5

Documentation des fonctions membres

◆ onContentBeforeDisplay()

onContentBeforeDisplay | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

If in the article view and the parameter is enabled shows the page navigation

Paramètres
string | $context | The context of the content being passed to the plugin
object | &$row | The article object
mixed | &$params | The article params
integer | $page | The 'page' number
Renvoie
mixed void or true
Depuis
1.6

The following is needed as different menu items types utilise a different param to control ordering. For Blogs the orderby_sec param is the order controlling param. For Table and List views it is the orderby param.

Références $app, $context, $db, $lang, $list, $location, $now, $option, $params, $path, $query, $rows, $user, $view, Factory\getApplication(), Factory\getDate(), Joomla\CMS\MVC\Model\getDbo(), Factory\getLanguage(), Factory\getUser(), et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • pagenavigation.php


Joomla CMS: Référence de la classe PlgContentVote

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgContentVote
+ Graphe d'héritage de PlgContentVote:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config)
onContentBeforeDisplay ($context, &$row, &$params, $page=0)
onContentAfterDisplay ($context, &$row, &$params, $page=0)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$votingPosition
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

displayVotingData ($context, &$row, &$params, $page)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Vote plugin.

Depuis
1.5

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |
Paramètres
object | &$subject | The object to observe
array | $config | An optional associative array of configuration settings.
Depuis
3.7.0

Références $config, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ displayVotingData()

displayVotingData | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page
 | ) |  |
private

Displays the voting area

Paramètres
string | $context | The context of the content being passed to the plugin
object | &$row | The article object
object | &$params | The article params
integer | $page | The 'page' number
Renvoie
string|boolean HTML string containing code for the votes if in com_content else boolean false
Depuis
3.7.0

Références $context, $html, $params, $parts, $path, et null.

◆ onContentAfterDisplay()

onContentAfterDisplay | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Displays the voting area when viewing an article and the voting section is displayed after the article

Paramètres
string | $context | The context of the content being passed to the plugin
object | &$row | The article object
object | &$params | The article params
integer | $page | The 'page' number
Renvoie
string|boolean HTML string containing code for the votes if in com_content else boolean false
Depuis
3.7.0

Références $context, et $params.

◆ onContentBeforeDisplay()

onContentBeforeDisplay | ( |  | $context,
 |  | & | $row,
 |  | & | $params,
 |  |  | $page = 0
 | ) |  |

Displays the voting area when viewing an article and the voting section is displayed before the article

Paramètres
string | $context | The context of the content being passed to the plugin
object | &$row | The article object
object | &$params | The article params
integer | $page | The 'page' number
Renvoie
string|boolean HTML string containing code for the votes if in com_content else boolean false
Depuis
1.6

Références $context, et $params.

Documentation des champs

◆ $app

$app
protected

◆ $votingPosition

$votingPosition
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • vote.php


Joomla CMS: Référence de la classe PlgEditorCodemirror

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgEditorCodemirror
+ Graphe d'héritage de PlgEditorCodemirror:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInit ()
onDisplay ( $name, $content, $width, $height, $col, $row, $buttons=true, $id=null, $asset=null, $author=null, $params=array())
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

displayButtons ($name, $buttons, $asset, $author)
getFontInfo ($font)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$modeAlias = array()
$basePath = 'media/vendor/codemirror/'
$modePath = 'media/vendor/codemirror/mode/%N/%N'
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

CodeMirror Editor Plugin.

Depuis
1.6

Documentation des fonctions membres

◆ displayButtons()

displayButtons | ( | $name,
 |  | $buttons,
 |  | $asset,
 |  | $author
 | ) |
protected

Displays the editor buttons.

Paramètres
string | $name | Button name.
mixed | $buttons | [array with button objects | boolean true to display buttons]
mixed | $asset | Unused.
mixed | $author | Unused.
Renvoie
string|void

Références $buttons, $name, et Joomla\CMS\Application\getDispatcher().

◆ getFontInfo()

getFontInfo ( $font )
protected

Gets font info from the json data file

Paramètres
string $font A key from the $fonts array.
Renvoie
object

Références __DIR__, et null.

◆ onDisplay()

onDisplay | ( | $name,
 |  | $content,
 |  | $width,
 |  | $height,
 |  | $col,
 |  | $row,
 |  | $buttons = true,
 |  | $id = null,
 |  | $asset = null,
 |  | $author = null,
 |  | $params = array()
 | ) |

Display the editor area.

Paramètres
string | $name | The control name.
string | $content | The contents of the text area.
string | $width | The width of the text area (px or %).
string | $height | The height of the text area (px or %).
int | $col | The number of columns for the textarea.
int | $row | The number of rows for the textarea.
boolean | $buttons | True and the editor buttons will be displayed.
string | $id | An optional ID for the textarea (note: since 1.6). If not supplied the name is used.
string | $asset | Not used.
object | $author | Not used.
array | $params | Associative array of editor parameters.
Renvoie
string HTML

Références $author, $buttons, $content, $displayData, $height, $id, $name, $options, $params, $result, $results, $this, $width, et __DIR__.

◆ onInit()

onInit ( )

Initialises the Editor.

Renvoie
void

Références $displayData, $doc, et __DIR__.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $basePath

$basePath = 'media/vendor/codemirror/'
protected

◆ $modeAlias

$modeAlias = array()
protected

◆ $modePath

$modePath = 'media/vendor/codemirror/mode/%N/%N'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • codemirror.php


Joomla CMS: Référence de la classe PlgEditorNone

Fonctions membres publiques
Référence de la classe PlgEditorNone
+ Graphe d'héritage de PlgEditorNone:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onDisplay ( $name, $content, $width, $height, $col, $row, $buttons=true, $id=null, $asset=null, $author=null, $params=array())
_displayButtons ($name, $buttons, $asset, $author)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Plain Textarea Editor Plugin

Depuis
1.5

Documentation des fonctions membres

◆ _displayButtons()

_displayButtons | ( | $name,
 |  | $buttons,
 |  | $asset,
 |  | $author
 | ) |

Displays the editor buttons.

Paramètres
string | $name | The control name.
mixed | $buttons | [array with button objects | boolean true to display buttons]
string | $asset | The object asset
object | $author | The author.
Renvoie
void|string HTML

Références $buttons, $name, et Joomla\CMS\Application\getDispatcher().

◆ onDisplay()

onDisplay | ( | $name,
 |  | $content,
 |  | $width,
 |  | $height,
 |  | $col,
 |  | $row,
 |  | $buttons = true,
 |  | $id = null,
 |  | $asset = null,
 |  | $author = null,
 |  | $params = array()
 | ) |

Display the editor area.

Paramètres
string | $name | The control name.
string | $content | The contents of the text area.
string | $width | The width of the text area (px or %).
string | $height | The height of the text area (px or %).
integer | $col | The number of columns for the textarea.
integer | $row | The number of rows for the textarea.
boolean | $buttons | True and the editor buttons will be displayed.
string | $id | An optional ID for the textarea (note: since 1.6). If not supplied the name is used.
string | $asset | The object asset
object | $author | The author.
array | $params | Associative array of editor parameters.
Renvoie
string

Références $author, $buttons, $content, $height, $id, $name, $params, $readonly, et $width.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/editors/none/none.php


Joomla CMS: Référence de la classe PlgEditorTinymce

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgEditorTinymce
+ Graphe d'héritage de PlgEditorTinymce:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInit ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$_basePath = 'media/vendor/tinymce'
$autoloadLanguage = true
$app = null
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

TinyMCE Editor Plugin

Depuis
1.5

Documentation des fonctions membres

◆ onInit()

onInit ( )

Initialises the Editor.

Renvoie
void
Depuis
1.5

Documentation des champs

◆ $_basePath

$_basePath = 'media/vendor/tinymce'
protected

Base path for editor files

Depuis
3.5
Obsolète:
5.0

◆ $app

$app = null
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • tinymce.php


Joomla CMS: Référence de la classe PlgExtensionFinder

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgExtensionFinder
+ Graphe d'héritage de PlgExtensionFinder:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onExtensionAfterInstall ($installer, $eid)
onExtensionAfterUpdate ($installer, $eid)
onExtensionAfterUninstall ($installer, $eid, $removed)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

getLanguage ($eid)
addCommonWords ($extension)
removeCommonWords ($extension)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Finder extension plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ addCommonWords()

addCommonWords ( $extension )
protected

Add common words from a txt file to com_finder

Paramètres
object $extension Extension object
Renvoie
void
Depuis
4.0.0

Références $bindNames, $db, $extension, $lang, $path, $query, JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getLanguage()

getLanguage ( $eid )
protected

Get an object of information if the handled extension is a language

Paramètres
integer $eid Extension id
Renvoie
object
Depuis
4.0.0

Références $db, $extension, et $query.

◆ onExtensionAfterInstall()

onExtensionAfterInstall | ( | $installer,
 |  | $eid
 | ) |

Add common words to finder after language got installed

Paramètres
Installer | $installer | Installer object
integer | $eid | Extension Identifier
Renvoie
void
Depuis
4.0.0

Références $extension.

◆ onExtensionAfterUninstall()

onExtensionAfterUninstall | ( | $installer,
 |  | $eid,
 |  | $removed
 | ) |

Remove common words to finder after language got uninstalled

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
boolean | $removed | Installation result
Renvoie
void
Depuis
4.0.0

◆ onExtensionAfterUpdate()

onExtensionAfterUpdate | ( | $installer,
 |  | $eid
 | ) |

Add common words to finder after language got updated

Paramètres
Installer | $installer | Installer object
integer | $eid | Extension identifier
Renvoie
void
Depuis
4.0.0

◆ removeCommonWords()

removeCommonWords ( $extension )
protected

Remove common words of a language from com_finder

Paramètres
object $extension Extension object
Renvoie
void
Depuis
4.0.0

Références $db, $extension, $lang, $query, et JPATH_ADMINISTRATOR.

Documentation des champs

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • extension/finder/finder.php


Joomla CMS: Référence de la classe PlgExtensionJoomla

Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgExtensionJoomla
+ Graphe d'héritage de PlgExtensionJoomla:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onExtensionAfterInstall ($installer, $eid)
onExtensionAfterUninstall ($installer, $eid, $removed)
onExtensionAfterUpdate ($installer, $eid)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

addUpdateSite ($name, $type, $location, $enabled, $extraQuery='')
processUpdateSites ()

Attributs privés

$eid = 0
$installer = null

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! master extension plugin.

Depuis
1.6

Documentation des fonctions membres

◆ addUpdateSite()

addUpdateSite | ( | $name,
 |  | $type,
 |  | $location,
 |  | $enabled,
 |  | $extraQuery = ''
 | ) |
private

Adds an update site to the table if it doesn't exist.

Paramètres
string | $name | The friendly name of the site
string | $type | The type of site (e.g. collection or extension)
string | $location | The URI for the site
boolean | $enabled | If this site is enabled
string | $extraQuery | Any additional request query to use when updating
Renvoie
void
Depuis
1.6

Références $db, $enabled, $location, $name, $query, et $type.

◆ onExtensionAfterInstall()

onExtensionAfterInstall | ( | $installer,
 |  | $eid
 | ) |

Handle post extension install update sites

Paramètres
Installer | $installer | Installer object
integer | $eid | Extension Identifier
Renvoie
void
Depuis
1.6

◆ onExtensionAfterUninstall()

onExtensionAfterUninstall | ( | $installer,
 |  | $eid,
 |  | $removed
 | ) |

Handle extension uninstall

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
boolean | $removed | Installation result
Renvoie
void
Depuis
1.6

Références $db, $query, et $results.

◆ onExtensionAfterUpdate()

onExtensionAfterUpdate | ( | $installer,
 |  | $eid
 | ) |

After update of an extension

Paramètres
Installer | $installer | Installer object
integer | $eid | Extension identifier
Renvoie
void
Depuis
1.6

◆ processUpdateSites()

processUpdateSites ( )
private

Processes the list of update sites for an extension.

Renvoie
void
Depuis
1.6

Références $data, et $manifest.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected

◆ $eid

$eid = 0
private

◆ $installer

$installer = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/extension/joomla/joomla.php


Joomla CMS: Référence de la classe PlgExtensionNamespacemap

Fonctions membres publiques | Attributs privés
Référence de la classe PlgExtensionNamespacemap
+ Graphe d'héritage de PlgExtensionNamespacemap:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config=array())
onExtensionAfterInstall ($installer, $eid)
onExtensionAfterUninstall ($installer, $eid, $removed)
onExtensionAfterUpdate ($installer, $eid)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs privés

$fileCreator = null

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Joomla! namespace map creator / updater.

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config = array()
 | ) |  |

Constructor

Paramètres
DispatcherInterface | &$subject | The object to observe
array | $config | An optional associative array of configuration settings. Recognized key values include 'name', 'group', 'params', 'language' (this list is not meant to be comprehensive).
Depuis
4.0.0

Références $config, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ onExtensionAfterInstall()

onExtensionAfterInstall | ( | $installer,
 |  | $eid
 | ) |

Update / Create map on extension install

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
Renvoie
void
Depuis
4.0.0

◆ onExtensionAfterUninstall()

onExtensionAfterUninstall | ( | $installer,
 |  | $eid,
 |  | $removed
 | ) |

Update / Create map on extension uninstall

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
boolean | $removed | Installation result
Renvoie
void
Depuis
4.0.0

◆ onExtensionAfterUpdate()

onExtensionAfterUpdate | ( | $installer,
 |  | $eid
 | ) |

Update map on extension update

Paramètres
Installer | $installer | Installer instance
integer | $eid | Extension id
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $fileCreator

$fileCreator = null
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/extension/namespacemap/namespacemap.php


Joomla CMS: Référence de la classe PlgFieldsCalendar

Fonctions membres publiques
Référence de la classe PlgFieldsCalendar
+ Graphe d'héritage de PlgFieldsCalendar:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Calendar Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/calendar/calendar.php


Joomla CMS: Référence de la classe PlgFieldsCheckboxes

Fonctions membres publiques
Référence de la classe PlgFieldsCheckboxes
+ Graphe d'héritage de PlgFieldsCheckboxes:
FieldsListPlugin FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsBeforePrepareField ($context, $item, $field)
- Fonctions membres publiques hérités de FieldsListPlugin
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
getOptionsFromField ($field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Checkboxes Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsBeforePrepareField()

onCustomFieldsBeforePrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Before prepares the field value.

Paramètres
string | $context | The context.
\stdclass | $item | The item.
\stdclass | $field | The field.
Renvoie
void
Depuis
3.7.0

Références $field, $key, $options, et $value.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/checkboxes/checkboxes.php


Joomla CMS: Référence de la classe PlgFieldsColor

Fonctions membres publiques
Référence de la classe PlgFieldsColor
+ Graphe d'héritage de PlgFieldsColor:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Color Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • color.php


Joomla CMS: Référence de la classe PlgFieldsEditor

Fonctions membres publiques
Référence de la classe PlgFieldsEditor
+ Graphe d'héritage de PlgFieldsEditor:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Editor Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, $form, et $this.

La documentation de cette classe a été générée à partir du fichier suivant :
  • editor.php


Joomla CMS: Référence de la classe PlgFieldsImagelist

Fonctions membres publiques
Référence de la classe PlgFieldsImagelist
+ Graphe d'héritage de PlgFieldsImagelist:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Imagelist Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • imagelist.php


Joomla CMS: Référence de la classe PlgFieldsInteger

Référence de la classe PlgFieldsInteger
+ Graphe d'héritage de PlgFieldsInteger:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Integer Plugin

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • integer.php


Joomla CMS: Référence de la classe PlgFieldsList

Fonctions membres publiques
Référence de la classe PlgFieldsList
+ Graphe d'héritage de PlgFieldsList:
FieldsListPlugin FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsBeforePrepareField ($context, $item, $field)
onCustomFieldsPrepareField ($context, $item, $field)
- Fonctions membres publiques hérités de FieldsListPlugin
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
getOptionsFromField ($field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields list Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsBeforePrepareField()

onCustomFieldsBeforePrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Before prepares the field value.

Paramètres
string | $context | The context.
\stdclass | $item | The item.
\stdclass | $field | The field.
Renvoie
void
Depuis
3.7.0

Références $field, et $options.

◆ onCustomFieldsPrepareField()

onCustomFieldsPrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Prepares the field

Paramètres
string | $context | The context.
stdclass | $item | The item.
stdclass | $field | The field.
Renvoie
object
Depuis
3.9.2

Références $context, $field, et $item.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/list/list.php


Joomla CMS: Référence de la classe PlgFieldsMedia

Fonctions membres publiques | Fonctions membres privées
Référence de la classe PlgFieldsMedia
+ Graphe d'héritage de PlgFieldsMedia:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
onCustomFieldsBeforePrepareField ($context, $item, $field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres privées

checkValue ($value)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Media Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ checkValue()

checkValue ( $value )
private

Before prepares the field value.

Paramètres
string $value The value to check.
Renvoie
array The checked value
Depuis
4.0.0

Références $value.

◆ onCustomFieldsBeforePrepareField()

onCustomFieldsBeforePrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Before prepares the field value.

Paramètres
string | $context | The context.
\stdclass | $item | The item.
\stdclass | $field | The field.
Renvoie
void
Depuis
4.0.0

Références $field.

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
4.0.0

Références $field, $form, Factory\getApplication(), et Joomla\CMS\Application\getIdentity().

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/media/media.php


Joomla CMS: Référence de la classe PlgFieldsRadio

Fonctions membres publiques
Référence de la classe PlgFieldsRadio
+ Graphe d'héritage de PlgFieldsRadio:
FieldsListPlugin FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsBeforePrepareField ($context, $item, $field)
- Fonctions membres publiques hérités de FieldsListPlugin
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
getOptionsFromField ($field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Radio Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsBeforePrepareField()

onCustomFieldsBeforePrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Before prepares the field value.

Paramètres
string | $context | The context.
\stdclass | $item | The item.
\stdclass | $field | The field.
Renvoie
void
Depuis
3.7.0

Références $field, et $options.

La documentation de cette classe a été générée à partir du fichier suivant :
  • radio.php


Joomla CMS: Référence de la classe PlgFieldsSql

Fonctions membres publiques
Référence de la classe PlgFieldsSql
+ Graphe d'héritage de PlgFieldsSql:
FieldsListPlugin FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
onContentBeforeSave ($context, $item, $isNew, $data=[])
- Fonctions membres publiques hérités de FieldsListPlugin
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
getOptionsFromField ($field)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Sql Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onContentBeforeSave()

onContentBeforeSave | ( | $context,
 |  | $item,
 |  | $isNew,
 |  | $data = []
 | ) |

The save event.

Paramètres
string | $context | The context
\Joomla\CMS\Table\Table | $item | The table
boolean | $isNew | Is new item
array | $data | The validated data
Renvoie
boolean
Depuis
3.7.0

Références $context, et $item.

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • sql.php


Joomla CMS: Référence de la classe PlgFieldsSubform

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Attributs protégés statiques
Référence de la classe PlgFieldsSubform
+ Graphe d'héritage de PlgFieldsSubform:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsBeforePrepareField ($context, $item, $field)
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

getOptionsFromField (\stdClass $field)
getParamsFromField (\stdClass $field)
getSubfieldsFromField (\stdClass $field)
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$renderCache = array()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs protégés statiques

static $customFieldsCache = null

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Fields subform Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ getOptionsFromField()

getOptionsFromField ( \stdClass $field )
protected

Returns an array of all options configured for this field.

Paramètres
\stdClass $field The field
Renvoie
[]
Depuis
4.0.0

Références $field, $option, $params, et $result.

◆ getParamsFromField()

getParamsFromField ( \stdClass $field )
protected

Returns the configured params for a given field.

Paramètres
\stdClass $field The field
Renvoie
Depuis
4.0.0

Références $field, et $params.

◆ getSubfieldsFromField()

getSubfieldsFromField ( \stdClass $field )
protected

Returns an array of all subfields for a given field. This will always return a bare clone of a sub field, so manipulating it is safe.

Paramètres
\stdClass $field The field
Renvoie
[]
Depuis
4.0.0

Set the name of the sub field to its id so that the values in the database are being saved based on the id of the sub fields, not on their name. Actually we do not need the name of the sub fields to render them, but just to make sure we have the name when we need it, we store it as fieldname.

Références $customFields, $field, $option, $result, FieldsHelper\getFields(), et null.

◆ onCustomFieldsBeforePrepareField()

onCustomFieldsBeforePrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Manipulates the $field->value before the field is being passed to onCustomFieldsPrepareField.

Paramètres
string | $context | The context
object | $item | The item
\stdClass | $field | The field
Renvoie
void
Depuis
4.0.0

Références $field.

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Returns a DOMElement which is the child of $parent and represents the form XML definition for this field.

Paramètres
\stdClass | $field | The field
DOMElement | $parent | The original parent element
Form | $form | The form
Renvoie
Depuis
4.0.0

Références $field, $form, et Factory\getApplication().

◆ onCustomFieldsPrepareField()

onCustomFieldsPrepareField | ( | $context,
 |  | $item,
 |  | $field
 | ) |

Renders this fields value by rendering all sub fields and joining all those rendered sub fields together.

Paramètres
string | $context | The context
object | $item | The item
\stdClass | $field | The field
Renvoie
string
Depuis
4.0.0

Placeholder to hold all rows (if this field is repeatable). Each array entry is another array representing a row, containing all of the sub fields that are valid for this row and their raw and rendered values.

Construct the cache-key for our renderCache. It is important that the cache key is as unique as possible to avoid false duplicates (e.g. type and rawvalue is not enough for the cache key, because type 'list' and value '1' can have different rendered values, depending on the list items), but it also must be as general as possible to not cause too many unneeded rendering processes (e.g. the type 'text' will always be rendered the same when it has the same rawvalue).

Références $context, $field, $item, $rows, et Factory\getApplication().

Documentation des champs

◆ $customFieldsCache

$customFieldsCache = null
staticprotected

◆ $renderCache

$renderCache = array()
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • subform.php


Joomla CMS: Référence de la classe PlgFieldsText

Référence de la classe PlgFieldsText
+ Graphe d'héritage de PlgFieldsText:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Text Plugin

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/text/text.php


Joomla CMS: Référence de la classe PlgFieldsTextarea

Référence de la classe PlgFieldsTextarea
+ Graphe d'héritage de PlgFieldsTextarea:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Textarea Plugin

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/textarea/textarea.php


Joomla CMS: Référence de la classe PlgFieldsUrl

Fonctions membres publiques
Référence de la classe PlgFieldsUrl
+ Graphe d'héritage de PlgFieldsUrl:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields URL Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/url/url.php


Joomla CMS: Référence de la classe PlgFieldsUser

Fonctions membres publiques
Référence de la classe PlgFieldsUser
+ Graphe d'héritage de PlgFieldsUser:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onCustomFieldsPrepareDom ($field, DOMElement $parent, Form $form)
- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields User Plugin

Depuis
3.7.0

Documentation des fonctions membres

◆ onCustomFieldsPrepareDom()

onCustomFieldsPrepareDom | ( |  | $field,
 |  | DOMElement | $parent,
 |  | Form | $form
 | ) |  |

Transforms the field into a DOM XML element and appends it as a child on the given parent.

Paramètres
stdClass | $field | The field.
DOMElement | $parent | The field node parent.
Form | $form | The form.
Renvoie
DOMElement
Depuis
3.7.0

Références $field, et $form.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/fields/user/user.php


Joomla CMS: Référence de la classe PlgFieldsUsergrouplist

Référence de la classe PlgFieldsUsergrouplist
+ Graphe d'héritage de PlgFieldsUsergrouplist:
FieldsPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de FieldsPlugin
onCustomFieldsGetTypes ()
onCustomFieldsPrepareField ($context, $item, $field)
onCustomFieldsPrepareDom ($field, \DOMElement $parent, Form $form)
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de FieldsPlugin
getFormPath (Form $form, $data)
isTypeSupported ($type)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de FieldsPlugin
$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Fields Usergrouplist Plugin

Depuis
3.7.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • usergrouplist.php


Joomla CMS: Référence de la classe PlgFileSystemLocal

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgFileSystemLocal
+ Graphe d'héritage de PlgFileSystemLocal:
CMSPlugin ProviderInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onSetupProviders (MediaProviderEvent $event)
getID ()
getDisplayName ()
getAdapters ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

FileSystem Local plugin.

The plugin to deal with the local filesystem in Media Manager.

Depuis
4.0.0

Documentation des fonctions membres

◆ getAdapters()

getAdapters ( )

Returns and array of adapters

Renvoie
[]
Depuis
4.0.0

Implémente ProviderInterface.

Références JPATH_ROOT.

◆ getDisplayName()

getDisplayName ( )

Returns the display name of the provider

Renvoie
string
Depuis
4.0.0

Implémente ProviderInterface.

◆ getID()

getID ( )

Returns the ID of the provider

Renvoie
string
Depuis
4.0.0

Implémente ProviderInterface.

◆ onSetupProviders()

onSetupProviders ( MediaProviderEvent $event )

Setup Providers for Local Adapter

Paramètres
MediaProviderEvent $event Event for ProviderManager
Renvoie
void
Depuis
4.0.0

Références $this, et MediaProviderEvent\getProviderManager().

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • local.php


Joomla CMS: Référence de la classe PlgFinderCategories

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgFinderCategories
+ Graphe d'héritage de PlgFinderCategories:
Adapter CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderDelete ($context, $table)
onFinderAfterSave ($context, $row, $isNew)
onFinderBeforeSave ($context, $row, $isNew)
onFinderChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de Adapter
__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

setup ()
index (Result $item)
getListQuery ($query=null)
getStateQuery ()
- Fonctions membres protégées hérités de Adapter
change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context = 'Categories'
$extension = 'com_categories'
$layout = 'category'
$type_title = 'Category'
$table = '#__categories'
$state_field = 'published'
$autoloadLanguage = true
- Attributs protégés hérités de Adapter
$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Smart Search adapter for Joomla Categories.

Depuis
2.5

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A DatabaseQuery object or null.
Renvoie
DatabaseQuery A database object.
Depuis
2.5

Références $db, et $query.

◆ getStateQuery()

getStateQuery ( )
protected

Method to get a SQL query to load the published and access states for a category and its parents.

Renvoie
DatabaseQuery A database object.
Depuis
2.5

Références $query, et $this.

◆ index()

index ( Result $item )
protected

Method to index an item. The item must be a Result object.

Paramètres
Result $item The item to index as a Result object.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $class, $extension, $item, $parts, $this, $title, extension, JPATH_SITE, et JLoader\register().

◆ onFinderAfterSave()

onFinderAfterSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search after save content method. Reindexes the link information for a category that has been saved. It also makes adjustments if the access level of the category has changed.

Paramètres
string | $context | The context of the category passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | True if the category has just been created.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderBeforeSave()

onFinderBeforeSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search before content save method. This event is fired before the data is actually saved.

Paramètres
string | $context | The context of the category passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | True if the category is just about to be created.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderChangeState()

onFinderChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the category passed to the plugin.
array | $pks | An array of primary key ids of the category that has changed state.
integer | $value | The value of the state that the category has been changed to.
Renvoie
void
Depuis
2.5

Références $context, $item, $query, $state, $temp, $value, ParameterType\INTEGER, et null.

◆ onFinderDelete()

onFinderDelete | ( | $context,
 |  | $table
 | ) |

Method to remove the link information for items that have been deleted.

Paramètres
string | $context | The context of the action being performed.
Table | $table | A Table object containing the record to be deleted
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $context, $id, et elseif.

◆ setup()

setup ( )
protected

Method to setup the indexer to be run.

Renvoie
boolean True on success.
Depuis
2.5

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $context

$context = 'Categories'
protected

◆ $extension

$extension = 'com_categories'
protected

◆ $layout

$layout = 'category'
protected

◆ $state_field

$state_field = 'published'
protected

◆ $table

$table = '#__categories'
protected

◆ $type_title

$type_title = 'Category'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/finder/categories/categories.php


Joomla CMS: Référence de la classe PlgFinderContacts

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgFinderContacts
+ Graphe d'héritage de PlgFinderContacts:
Adapter CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderCategoryChangeState ($extension, $pks, $value)
onFinderAfterDelete ($context, $table)
onFinderAfterSave ($context, $row, $isNew)
onFinderBeforeSave ($context, $row, $isNew)
onFinderChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de Adapter
__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

index (Result $item)
setup ()
getListQuery ($query=null)
- Fonctions membres protégées hérités de Adapter
change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context = 'Contacts'
$extension = 'com_contact'
$layout = 'contact'
$type_title = 'Contact'
$table = '#__contact_details'
$state_field = 'published'
$autoloadLanguage = true
- Attributs protégés hérités de Adapter
$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Finder adapter for Joomla Contacts.

Depuis
2.5

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A DatabaseQuery object or null.
Renvoie
DatabaseQuery A database object.
Depuis
2.5

Références $db, et $query.

◆ index()

index ( Result $item )
protected

Method to index an item. The item must be a Result object.

Paramètres
Result $item The item to index as a Result object.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $category, $item, $this, $title, extension, Categories\getInstance(), ComponentHelper\isEnabled(), et Result\setLanguage().

◆ onFinderAfterDelete()

onFinderAfterDelete | ( | $context,
 |  | $table
 | ) |

Method to remove the link information for items that have been deleted.

This event will fire when contacts are deleted and when an indexed item is deleted.

Paramètres
string | $context | The context of the action being performed.
Table | $table | A Table object containing the record to be deleted
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context, $id, et elseif.

◆ onFinderAfterSave()

onFinderAfterSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Method to determine if the access level of an item changed.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object
boolean | $isNew | If the content has just been created
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderBeforeSave()

onFinderBeforeSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Method to reindex the link information for an item that has been saved. This event is fired before the data is actually saved so we are going to queue the item to be indexed later.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object
boolean | $isNew | If the content is just about to be created
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderCategoryChangeState()

onFinderCategoryChangeState | ( | $extension,
 |  | $pks,
 |  | $value
 | ) |

Method to update the item link information when the item category is changed. This is fired when the item category is published or unpublished from the list view.

Paramètres
string | $extension | The extension whose category has been updated.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $extension, et $value.

◆ onFinderChangeState()

onFinderChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $context, et $value.

◆ setup()

setup ( )
protected

Method to setup the indexer to be run.

Renvoie
boolean True on success.
Depuis
2.5

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $context

$context = 'Contacts'
protected

◆ $extension

$extension = 'com_contact'
protected

◆ $layout

$layout = 'contact'
protected

◆ $state_field

$state_field = 'published'
protected

◆ $table

$table = '#__contact_details'
protected

◆ $type_title

$type_title = 'Contact'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • contacts.php


Joomla CMS: Référence de la classe PlgFinderContent

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgFinderContent
+ Graphe d'héritage de PlgFinderContent:
Adapter CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderCategoryChangeState ($extension, $pks, $value)
onFinderAfterDelete ($context, $table)
onFinderAfterSave ($context, $row, $isNew)
onFinderBeforeSave ($context, $row, $isNew)
onFinderChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de Adapter
__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

setup ()
index (Result $item)
getListQuery ($query=null)
- Fonctions membres protégées hérités de Adapter
change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context = 'Content'
$extension = 'com_content'
$layout = 'article'
$type_title = 'Article'
$table = '#__content'
$autoloadLanguage = true
- Attributs protégés hérités de Adapter
$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Smart Search adapter for com_content.

Depuis
2.5

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A DatabaseQuery object or null.
Renvoie
DatabaseQuery A database object.
Depuis
2.5

Références $db, et $query.

◆ index()

index ( Result $item )
protected

Method to index an item. The item must be a Result object.

Paramètres
Result $item The item to index as a Result object.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $category, $images, $item, $this, $title, et extension.

◆ onFinderAfterDelete()

onFinderAfterDelete | ( | $context,
 |  | $table
 | ) |

Method to remove the link information for items that have been deleted.

Paramètres
string | $context | The context of the action being performed.
Table | $table | A Table object containing the record to be deleted
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context, $id, et elseif.

◆ onFinderAfterSave()

onFinderAfterSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search after save content method. Reindexes the link information for an article that has been saved. It also makes adjustments if the access level of an item or the category to which it belongs has changed.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | True if the content has just been created.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderBeforeSave()

onFinderBeforeSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search before content save method. This event is fired before the data is actually saved.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | If the content is just about to be created.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderCategoryChangeState()

onFinderCategoryChangeState | ( | $extension,
 |  | $pks,
 |  | $value
 | ) |

Method to update the item link information when the item category is changed. This is fired when the item category is published or unpublished from the list view.

Paramètres
string | $extension | The extension whose category has been updated.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $extension, et $value.

◆ onFinderChangeState()

onFinderChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | An array of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $context, et $value.

◆ setup()

setup ( )
protected

Method to setup the indexer to be run.

Renvoie
boolean True on success.
Depuis
2.5

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $context

$context = 'Content'
protected

◆ $extension

$extension = 'com_content'
protected

◆ $layout

$layout = 'article'
protected

◆ $table

$table = '#__content'
protected

◆ $type_title

$type_title = 'Article'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/finder/content/content.php


Joomla CMS: Référence de la classe PlgFinderNewsfeeds

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgFinderNewsfeeds
+ Graphe d'héritage de PlgFinderNewsfeeds:
Adapter CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderCategoryChangeState ($extension, $pks, $value)
onFinderAfterDelete ($context, $table)
onFinderAfterSave ($context, $row, $isNew)
onFinderBeforeSave ($context, $row, $isNew)
onFinderChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de Adapter
__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

index (Result $item)
setup ()
getListQuery ($query=null)
- Fonctions membres protégées hérités de Adapter
change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context = 'Newsfeeds'
$extension = 'com_newsfeeds'
$layout = 'newsfeed'
$type_title = 'News Feed'
$table = '#__newsfeeds'
$state_field = 'published'
$autoloadLanguage = true
- Attributs protégés hérités de Adapter
$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Smart Search adapter for Joomla Newsfeeds.

Depuis
2.5

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A DatabaseQuery object or null.
Renvoie
DatabaseQuery A database object.
Depuis
2.5

Références $db, et $query.

◆ index()

index ( Result $item )
protected

Method to index an item. The item must be a Result object.

Paramètres
Result $item The item to index as a Result object.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $category, $item, $this, extension, Categories\getInstance(), ComponentHelper\isEnabled(), et Result\setLanguage().

◆ onFinderAfterDelete()

onFinderAfterDelete | ( | $context,
 |  | $table
 | ) |

Method to remove the link information for items that have been deleted.

Paramètres
string | $context | The context of the action being performed.
Table | $table | A Table object containing the record to be deleted.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context, $id, et elseif.

◆ onFinderAfterSave()

onFinderAfterSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search after save content method. Reindexes the link information for a newsfeed that has been saved. It also makes adjustments if the access level of a newsfeed item or the category to which it belongs has changed.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | True if the content has just been created.
Renvoie
void
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderBeforeSave()

onFinderBeforeSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Smart Search before content save method. This event is fired before the data is actually saved.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object.
boolean | $isNew | True if the content is just about to be created.
Renvoie
boolean True on success.
Depuis
2.5
Exceptions
Exception on database error.

Références $context.

◆ onFinderCategoryChangeState()

onFinderCategoryChangeState | ( | $extension,
 |  | $pks,
 |  | $value
 | ) |

Method to update the item link information when the item category is changed. This is fired when the item category is published or unpublished from the list view.

Paramètres
string | $extension | The extension whose category has been updated.
array | $pks | An array of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $extension, et $value.

◆ onFinderChangeState()

onFinderChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | An array of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
2.5

Références $context, et $value.

◆ setup()

setup ( )
protected

Method to setup the indexer to be run.

Renvoie
boolean True on success.
Depuis
2.5

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $context

$context = 'Newsfeeds'
protected

◆ $extension

$extension = 'com_newsfeeds'
protected

◆ $layout

$layout = 'newsfeed'
protected

◆ $state_field

$state_field = 'published'
protected

◆ $table

$table = '#__newsfeeds'
protected

◆ $type_title

$type_title = 'News Feed'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/finder/newsfeeds/newsfeeds.php


Joomla CMS: Référence de la classe PlgFinderTags

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgFinderTags
+ Graphe d'héritage de PlgFinderTags:
Adapter CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderAfterDelete ($context, $table)
onFinderAfterSave ($context, $row, $isNew)
onFinderBeforeSave ($context, $row, $isNew)
onFinderChangeState ($context, $pks, $value)
- Fonctions membres publiques hérités de Adapter
__construct (&$subject, $config)
onStartIndex ()
onBeforeIndex ()
onBuildIndex ()
onFinderGarbageCollection ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

index (Result $item)
setup ()
getListQuery ($query=null)
getStateQuery ()
getUpdateQueryByTime ($time)
- Fonctions membres protégées hérités de Adapter
change ($id, $property, $value)
index (Result $item)
reindex ($id)
remove ($id, $removeTaxonomies=true)
setup ()
categoryAccessChange ($row)
categoryStateChange ($pks, $value)
checkCategoryAccess ($row)
checkItemAccess ($row)
getContentCount ()
getItem ($id)
getItems ($offset, $limit, $query=null)
getListQuery ($query=null)
getPluginType ($id)
getStateQuery ()
getUpdateQueryByTime ($time)
getUpdateQueryByIds ($ids)
getTypeId ()
getUrl ($id, $extension, $view)
getItemMenuTitle ($url)
itemAccessChange ($row)
itemStateChange ($pks, $value)
pluginDisable ($pks)
translateState ($item, $category=null)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$context = 'Tags'
$extension = 'com_tags'
$layout = 'tag'
$type_title = 'Tag'
$table = '#__tags'
$autoloadLanguage = true
$state_field = 'published'
- Attributs protégés hérités de Adapter
$context
$extension
$layout
$mime
$old_access
$old_cataccess
$type_title
$type_id
$db
$table
$indexer
$state_field = 'state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Finder adapter for Joomla Tag.

Depuis
3.1

Documentation des fonctions membres

◆ getListQuery()

getListQuery ( $query = null )
protected

Method to get the SQL query used to retrieve the list of content items.

Paramètres
mixed $query A DatabaseQuery object or null.
Renvoie
DatabaseQuery A database object.
Depuis
3.1

Références $db, et $query.

◆ getStateQuery()

getStateQuery ( )
protected

Method to get a SQL query to load the published and access states for the given tag.

Renvoie
DatabaseQuery A database object.
Depuis
3.1

Références $query, et $this.

◆ getUpdateQueryByTime()

getUpdateQueryByTime ( $time )
protected

Method to get the query clause for getting items to update by time.

Paramètres
string $time The modified timestamp.
Renvoie
DatabaseQuery A database object.
Depuis
3.1

Références $query.

◆ index()

index ( Result $item )
protected

Method to index an item. The item must be a Result object.

Paramètres
Result $item The item to index as a Result object.
Renvoie
void
Depuis
3.1
Exceptions
Exception on database error.

Références $item, $this, $title, extension, et Result\setLanguage().

◆ onFinderAfterDelete()

onFinderAfterDelete | ( | $context,
 |  | $table
 | ) |

Method to remove the link information for items that have been deleted.

Paramètres
string | $context | The context of the action being performed.
Table | $table | A Table object containing the record to be deleted
Renvoie
void
Depuis
3.1
Exceptions
Exception on database error.

Références $context, $id, et elseif.

◆ onFinderAfterSave()

onFinderAfterSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Method to determine if the access level of an item changed.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object
boolean | $isNew | If the content has just been created
Renvoie
void
Depuis
3.1
Exceptions
Exception on database error.

Références $context.

◆ onFinderBeforeSave()

onFinderBeforeSave | ( | $context,
 |  | $row,
 |  | $isNew
 | ) |

Method to reindex the link information for an item that has been saved. This event is fired before the data is actually saved so we are going to queue the item to be indexed later.

Paramètres
string | $context | The context of the content passed to the plugin.
Table | $row | A Table object
boolean | $isNew | If the content is just about to be created
Renvoie
boolean True on success.
Depuis
3.1
Exceptions
Exception on database error.

Références $context.

◆ onFinderChangeState()

onFinderChangeState | ( | $context,
 |  | $pks,
 |  | $value
 | ) |

Method to update the link information for items that have been changed from outside the edit screen. This is fired when the item is published, unpublished, archived, or unarchived from the list view.

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | A list of primary key ids of the content that has changed state.
integer | $value | The value of the state that the content has been changed to.
Renvoie
void
Depuis
3.1

Références $context, et $value.

◆ setup()

setup ( )
protected

Method to setup the indexer to be run.

Renvoie
boolean True on success.
Depuis
3.1

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $context

$context = 'Tags'
protected

◆ $extension

$extension = 'com_tags'
protected

◆ $layout

$layout = 'tag'
protected

◆ $state_field

$state_field = 'published'
protected

◆ $table

$table = '#__tags'
protected

◆ $type_title

$type_title = 'Tag'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/finder/tags/tags.php


Joomla CMS: Référence de la classe PlgInstallerFolderInstaller

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgInstallerFolderInstaller
+ Graphe d'héritage de PlgInstallerFolderInstaller:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInstallerAddInstallationTab ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

FolderInstaller Plugin.

Depuis
3.6.0

Documentation des fonctions membres

◆ onInstallerAddInstallationTab()

onInstallerAddInstallationTab ( )

Textfield or Form of the Plugin.

Renvoie
array Returns an array with the tab information
Depuis
3.6.0

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • folderinstaller.php


Joomla CMS: Référence de la classe PlgInstallerOverride

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgInstallerOverride
+ Graphe d'héritage de PlgInstallerOverride:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

purge ()
storeBeforeEventFiles ()
storeAfterEventFiles ()
getUpdatedFiles ($action)
finalize ($result)
onExtensionBeforeUpdate ()
onExtensionAfterUpdate ()
onJoomlaBeforeUpdate ()
onJoomlaAfterUpdate ()
onInstallerBeforeInstaller ()
onInstallerAfterInstaller ()
load ($id, $exid)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$autoloadLanguage = true
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

saveOverrides ($pks)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Override Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ finalize()

finalize ( $result )

Last process of this plugin.

Paramètres
array $result Result array.
Renvoie
void
Depuis
4.0.0

Références $link, et $result.

◆ getUpdatedFiles()

getUpdatedFiles ( $action )

Method to prepare changed or updated core file.

Paramètres
string $action The name of the action.
Renvoie
array A list of changed files.
Depuis
4.0.0

Références $i, et $result.

◆ load()

load | ( | $id,
 |  | $exid
 | ) |

Check for existing id.

Paramètres
string | $id | Hash id of file.
integer | $exid | Extension id of file.
Renvoie
boolean True/False
Depuis
4.0.0

Références $db, $id, $query, et $results.

◆ onExtensionAfterUpdate()

onExtensionAfterUpdate ( )

Event after extension update.

Renvoie
void
Depuis
4.0.0

Références $result.

◆ onExtensionBeforeUpdate()

onExtensionBeforeUpdate ( )

Event before extension update.

Renvoie
void
Depuis
4.0.0

◆ onInstallerAfterInstaller()

onInstallerAfterInstaller ( )

Event after install.

Renvoie
void
Depuis
4.0.0

Références $result.

◆ onInstallerBeforeInstaller()

onInstallerBeforeInstaller ( )

Event before install.

Renvoie
void
Depuis
4.0.0

◆ onJoomlaAfterUpdate()

onJoomlaAfterUpdate ( )

Event after joomla update.

Renvoie
void
Depuis
4.0.0

Références $result.

◆ onJoomlaBeforeUpdate()

onJoomlaBeforeUpdate ( )

Event before joomla update.

Renvoie
void
Depuis
4.0.0

◆ purge()

purge ( )

Purges session array.

Renvoie
void
Depuis
4.0.0

◆ saveOverrides()

saveOverrides ( $pks )
private

Save the updated files.

Paramètres
array $pks Updated files.
Renvoie
void
Depuis
4.0.0
Exceptions

Références $columns, $date, et null.

◆ storeAfterEventFiles()

storeAfterEventFiles ( )

Method to store files after event.

Renvoie
void
Depuis
4.0.0

Références $list.

◆ storeBeforeEventFiles()

storeBeforeEventFiles ( )

Method to store files before event.

Renvoie
void
Depuis
4.0.0

Références $list.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • override.php


Joomla CMS: Référence de la classe PlgInstallerPackageInstaller

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgInstallerPackageInstaller
+ Graphe d'héritage de PlgInstallerPackageInstaller:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInstallerAddInstallationTab ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

PackageInstaller Plugin.

Depuis
3.6.0

Documentation des fonctions membres

◆ onInstallerAddInstallationTab()

onInstallerAddInstallationTab ( )

Textfield or Form of the Plugin.

Renvoie
array Returns an array with the tab information
Depuis
3.6.0

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • packageinstaller.php


Joomla CMS: Référence de la classe PlgInstallerUrlInstaller

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgInstallerUrlInstaller
+ Graphe d'héritage de PlgInstallerUrlInstaller:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInstallerAddInstallationTab ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

UrlFolderInstaller Plugin.

Depuis
3.6.0

Documentation des fonctions membres

◆ onInstallerAddInstallationTab()

onInstallerAddInstallationTab ( )

Textfield or Form of the Plugin.

Renvoie
array Returns an array with the tab information
Depuis
3.6.0

Références Text\_().

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • urlinstaller.php


Joomla CMS: Référence de la classe PlgInstallerWebinstaller

Fonctions membres publiques | Champs de données | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgInstallerWebinstaller
+ Graphe d'héritage de PlgInstallerWebinstaller:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onInstallerAddInstallationTab ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Champs de données

const REMOTE_URL = 'https://appscdn.joomla.org/webapps/'
- Champs de données hérités de CMSPlugin
$params = null

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

isRTL ()
getInstallFrom ()

Attributs privés

$installfrom = null
$rtl = null

Membres hérités additionnels

- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Support for the "Install from Web" tab

Depuis
3.2

Documentation des fonctions membres

◆ getInstallFrom()

getInstallFrom ( )
private

Get the install from URL

Renvoie
string
Depuis
3.2

Références $field, et null.

◆ isRTL()

isRTL ( )
private

Internal check to determine if the output is in a RTL direction

Renvoie
integer
Depuis
3.2

Références null.

◆ onInstallerAddInstallationTab()

onInstallerAddInstallationTab ( )

Event listener for the onInstallerAddInstallationTab event.

Renvoie
array Returns an array with the tab information
Depuis
4.0.0

Références $doc, $lang, Text\_(), et Text\script().

Documentation des champs

◆ $app

$app
protected

◆ $installfrom

$installfrom = null
private

◆ $rtl

$rtl = null
private

◆ REMOTE_URL

const REMOTE_URL = 'https://appscdn.joomla.org/webapps/'
La documentation de cette classe a été générée à partir du fichier suivant :
  • webinstaller.php


Joomla CMS: Référence de la classe PlgMediaActionCrop

Fonctions membres protégées
Référence de la classe PlgMediaActionCrop
+ Graphe d'héritage de PlgMediaActionCrop:
MediaActionPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres protégées

loadJs ()
loadCss ()
- Fonctions membres protégées hérités de MediaActionPlugin
loadJs ()
loadCss ()
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Membres hérités additionnels

- Fonctions membres publiques hérités de MediaActionPlugin
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Attributs protégés hérités de MediaActionPlugin
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Media Manager Crop Action

Depuis
4.0.0

Documentation des fonctions membres

◆ loadCss()

loadCss ( )
protected

Load the CSS files of the plugin.

Renvoie
void
Depuis
4.0.0

◆ loadJs()

loadJs ( )
protected

Load the javascript files of the plugin.

Renvoie
void
Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • crop.php


Joomla CMS: Référence de la classe PlgMediaActionResize

Fonctions membres publiques
Référence de la classe PlgMediaActionResize
+ Graphe d'héritage de PlgMediaActionResize:
MediaActionPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentBeforeSave ($context, $item, $isNew, $data=array())
- Fonctions membres publiques hérités de MediaActionPlugin
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de MediaActionPlugin
loadJs ()
loadCss ()
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de MediaActionPlugin
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Media Manager Resize Action

Depuis
4.0.0

Documentation des fonctions membres

◆ onContentBeforeSave()

onContentBeforeSave | ( | $context,
 |  | $item,
 |  | $isNew,
 |  | $data = array()
 | ) |

The save event.

Paramètres
string | $context | The context
object | $item | The item
boolean | $isNew | Is new item
array | $data | The validated data
Renvoie
void
Depuis
4.0.0

Références $context, $item, $type, et null.

La documentation de cette classe a été générée à partir du fichier suivant :
  • resize.php


Joomla CMS: Référence de la classe PlgMediaActionRotate

Référence de la classe PlgMediaActionRotate
+ Graphe d'héritage de PlgMediaActionRotate:
MediaActionPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Membres hérités additionnels

- Fonctions membres publiques hérités de MediaActionPlugin
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de MediaActionPlugin
loadJs ()
loadCss ()
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de MediaActionPlugin
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Media Manager Rotate Action

Depuis
4.0.0
La documentation de cette classe a été générée à partir du fichier suivant :
  • rotate.php


Joomla CMS: Référence de la classe PlgPrivacyActionlogs

Fonctions membres publiques
Référence de la classe PlgPrivacyActionlogs
+ Graphe d'héritage de PlgPrivacyActionlogs:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyExportRequest (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Privacy plugin managing Joomla actionlogs data

Depuis
3.9.0

Documentation des fonctions membres

◆ onPrivacyExportRequest()

onPrivacyExportRequest | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Processes an export request for Joomla core actionlog data

Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
[]
Depuis
3.9.0

Références $data, $db, $item, $query, $user, et $userId.

La documentation de cette classe a été générée à partir du fichier suivant :
  • privacy/actionlogs/actionlogs.php


Joomla CMS: Référence de la classe PlgPrivacyConsents

Fonctions membres publiques
Référence de la classe PlgPrivacyConsents
+ Graphe d'héritage de PlgPrivacyConsents:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyExportRequest (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Privacy plugin managing Joomla user consent data

Depuis
3.9.0

Documentation des fonctions membres

◆ onPrivacyExportRequest()

onPrivacyExportRequest | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Processes an export request for Joomla core user consent data

This event will collect data for the core #__privacy_consents table

Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
[]
Depuis
3.9.0

Références $db, $item, $items, $query, $user, et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • consents.php


Joomla CMS: Référence de la classe PlgPrivacyContact

Fonctions membres publiques
Référence de la classe PlgPrivacyContact
+ Graphe d'héritage de PlgPrivacyContact:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyExportRequest (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Privacy plugin managing Joomla user contact data

Depuis
3.9.0

Documentation des fonctions membres

◆ onPrivacyExportRequest()

onPrivacyExportRequest | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Processes an export request for Joomla core user contact data

This event will collect data for the contact core tables:

  • Contact custom fields
Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
[]
Depuis
3.9.0

Références $item, $items, $query, et $user.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/privacy/contact/contact.php


Joomla CMS: Référence de la classe PlgPrivacyContent

Fonctions membres publiques
Référence de la classe PlgPrivacyContent
+ Graphe d'héritage de PlgPrivacyContent:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyExportRequest (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Privacy plugin managing Joomla user content data

Depuis
3.9.0

Documentation des fonctions membres

◆ onPrivacyExportRequest()

onPrivacyExportRequest | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Processes an export request for Joomla core user content data

This event will collect data for the content core table

  • Content custom fields
Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
[]
Depuis
3.9.0

Références $item, $items, $query, et $user.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/privacy/content/content.php


Joomla CMS: Référence de la classe PlgPrivacyMessage

Fonctions membres publiques
Référence de la classe PlgPrivacyMessage
+ Graphe d'héritage de PlgPrivacyMessage:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyExportRequest (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Privacy plugin managing Joomla user messages

Depuis
3.9.0

Documentation des fonctions membres

◆ onPrivacyExportRequest()

onPrivacyExportRequest | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Processes an export request for Joomla core user message

This event will collect data for the message table

Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
[]
Depuis
3.9.0

Références $db, $item, $items, $query, $user, et ParameterType\INTEGER.

La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/privacy/message/message.php


Joomla CMS: Référence de la classe PlgPrivacyUser

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgPrivacyUser
+ Graphe d'héritage de PlgPrivacyUser:
PrivacyPlugin CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onPrivacyCanRemoveData (RequestTable $request, User $user=null)
onPrivacyRemoveData (RequestTable $request, User $user=null)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de PrivacyPlugin
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createNotesDomain (TableUser $user)
createProfileDomain (TableUser $user)
createUserDomain (TableUser $user)
createItemForUserTable (TableUser $user)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de PrivacyPlugin
createDomain ($name, $description='')
createItemFromArray (array $data, $itemId=null)
createItemForTable ($table)
createCustomFieldsDomain ($context, $items=array())
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Privacy plugin managing Joomla user data

Depuis
3.9.0

Documentation des fonctions membres

◆ createItemForUserTable()

createItemForUserTable ( TableUser $user )
private

Create an item object for a TableUser object

Paramètres
TableUser $user The TableUser object to convert
Renvoie
Depuis
3.9.0

Références $data, et $user.

◆ createNotesDomain()

createNotesDomain ( TableUser $user )
private

Create the domain for the user notes data

Paramètres
TableUser $user The TableUser object to process
Renvoie
Depuis
3.9.0

Références $db, $item, $items, $query, $user, User\bind(), ArrayHelper\dropColumn(), et ParameterType\INTEGER.

◆ createProfileDomain()

createProfileDomain ( TableUser $user )
private

Create the domain for the user profile data

Paramètres
TableUser $user The TableUser object to process
Renvoie
Depuis
3.9.0

Références $db, $item, $items, $query, $user, User\bind(), et ParameterType\INTEGER.

◆ createUserDomain()

createUserDomain ( TableUser $user )
private

Create the domain for the user record

Paramètres
TableUser $user The TableUser object to process
Renvoie
Depuis
3.9.0

Références $user.

◆ onPrivacyCanRemoveData()

onPrivacyCanRemoveData | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Performs validation to determine if the data associated with a remove information request can be processed

This event will not allow a super user account to be removed

Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
Status
Depuis
3.9.0

Références $user, et Text\_().

◆ onPrivacyRemoveData()

onPrivacyRemoveData | ( | RequestTable | $request,
 |  | User | $user = null
 | ) |  |

Removes the data associated with a remove information request

This event will pseudoanonymise the user account

Paramètres
RequestTable | $request | The request record being processed
User | $user | The user account associated with this request if available
Renvoie
void
Depuis
3.9.0

Références $user.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/privacy/user/user.php


Joomla CMS: Référence de la classe PlgQuickiconDownloadkey

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgQuickiconDownloadkey
+ Graphe d'héritage de PlgQuickiconDownloadkey:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onGetIcons ($context)
getMissingDownloadKeyInfo ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! update notification plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ getMissingDownloadKeyInfo()

getMissingDownloadKeyInfo ( )

Gets the information about update sites requiring but missing a download key.

The return array has two keys:

  • supported Number of update sites supporting Download Key
  • missing Number of update sites missing a Download Key

If 'supported' is zero you do not need to provide any download keys. All your extensions are free downloads.

If 'supported' is non-zero and 'missing' is zero you have entered a download key for all paid extensions.

If 'supported' is non-zero and 'missing' is also non-zero you need to enter one or more download keys.

Renvoie
array
Depuis
4.0.0

Références JPATH_ADMINISTRATOR.

◆ onGetIcons()

onGetIcons ( $context )

Returns an icon definition for an icon which looks for extensions updates via AJAX and displays a notification when such updates are found.

Paramètres
string $context The calling context
Renvoie
array A list of icon definition associative arrays, consisting of the keys link, image, text and access.
Depuis
4.0.0

Références $context, et $info.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • downloadkey.php


Joomla CMS: Référence de la classe PlgQuickiconExtensionupdate

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgQuickiconExtensionupdate
+ Graphe d'héritage de PlgQuickiconExtensionupdate:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onGetIcons ($context)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! update notification plugin

Depuis
2.5

Documentation des fonctions membres

◆ onGetIcons()

onGetIcons ( $context )

Returns an icon definition for an icon which looks for extensions updates via AJAX and displays a notification when such updates are found.

Paramètres
string $context The calling context
Renvoie
array A list of icon definition associative arrays, consisting of the keys link, image, text and access.
Depuis
2.5

Références $context, $options, et Joomla\Application\getFormToken().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • extensionupdate.php


Joomla CMS: Référence de la classe PlgQuickiconOverrideCheck

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgQuickiconOverrideCheck
+ Graphe d'héritage de PlgQuickiconOverrideCheck:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onGetIcons ($context)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getOverridePluginId ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! template override notification plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ getOverridePluginId()

getOverridePluginId ( )
private

Gets the installer override plugin extension id.

Renvoie
integer The installer override plugin extension id.
Depuis
4.0.0

Références $query, et $result.

◆ onGetIcons()

onGetIcons ( $context )

Returns an icon definition for an icon which looks for overrides update via AJAX and displays a notification when such overrides are updated.

Paramètres
string $context The calling context
Renvoie
array A list of icon definition associative arrays, consisting of the keys link, image, text and access.
Depuis
4.0.0

Références $context, $options, et Joomla\Application\getFormToken().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • overridecheck.php


Joomla CMS: Référence de la classe PlgQuickiconPhpVersionCheck

Fonctions membres publiques | Champs de données | Attributs protégés | Fonctions membres privées
Référence de la classe PlgQuickiconPhpVersionCheck
+ Graphe d'héritage de PlgQuickiconPhpVersionCheck:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onGetIcons ($context)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Champs de données

const | PHP_SUPPORTED = 0
const | PHP_SECURITY_ONLY = 1
const | PHP_UNSUPPORTED = 2
- Champs de données hérités de CMSPlugin
$params = null

Attributs protégés

$app
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getPhpSupport ()
shouldDisplayMessage ()

Membres hérités additionnels

- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Plugin to check the PHP version and display a warning about its support status

Depuis
3.7.0

Documentation des fonctions membres

◆ getPhpSupport()

getPhpSupport ( )
private

Gets PHP support status.

Renvoie
array Array of PHP support data
Depuis
3.7.0
Note
The dates used in this method should correspond to the dates given on PHP.net https://www.php.net/eol.php

Références $version, et null.

◆ onGetIcons()

onGetIcons ( $context )

Check the PHP version after the admin component has been dispatched.

Paramètres
string $context The calling context
Renvoie
array
Depuis
3.7.0

◆ shouldDisplayMessage()

shouldDisplayMessage ( )
private

Determines if the message should be displayed

Renvoie
boolean
Depuis
3.7.0

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ PHP_SECURITY_ONLY

const PHP_SECURITY_ONLY = 1

◆ PHP_SUPPORTED

const PHP_SUPPORTED = 0

◆ PHP_UNSUPPORTED

const PHP_UNSUPPORTED = 2
La documentation de cette classe a été générée à partir du fichier suivant :
  • phpversioncheck.php


Joomla CMS: Référence de la classe PlgQuickiconPrivacyCheck

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgQuickiconPrivacyCheck
+ Graphe d'héritage de PlgQuickiconPrivacyCheck:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onGetIcons ($context)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Plugin to check privacy requests older than 14 days

Depuis
3.9.0

Documentation des fonctions membres

◆ onGetIcons()

onGetIcons ( $context )

Check privacy requests older than 14 days.

Paramètres
string $context The calling context
Renvoie
array A list of icon definition associative arrays
Depuis
3.9.0

Références $context, $options, Text\_(), et Joomla\Application\getFormToken().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • privacycheck.php


Joomla CMS: Référence de la classe PlgSampledataBlog

Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgSampledataBlog
+ Graphe d'héritage de PlgSampledataBlog:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onSampledataGetOverview ()
onAjaxSampledataApplyStep2 ()
onAjaxSampledataApplyStep4 ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$db
$app
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

addMenuItems (array $menuItems, $level)

Attributs privés

$menuItemModel

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Sampledata - Blog Plugin

Depuis
3.8.0

Documentation des fonctions membres

◆ addMenuItems()

addMenuItems | ( | array | $menuItems,
 |  |  | $level
 | ) |  |
private

Adds menuitems.

Paramètres
array | $menuItems | Array holding the menuitems arrays.
integer | $level | Level in the category tree.
Renvoie
array IDs of the inserted menuitems.
Depuis
3.8.0
Exceptions
Exception

Références $itemIds, $language, et $user.

◆ onAjaxSampledataApplyStep2()

onAjaxSampledataApplyStep2 ( )

Second step to enter the sampledata. Menus.

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
3.8.0

Références $i, $language, $menu, $menuTypes, $type, et Joomla\Application\checkToken().

◆ onAjaxSampledataApplyStep4()

onAjaxSampledataApplyStep4 ( )

Final step to show completion of sampledata.

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

◆ onSampledataGetOverview()

onSampledataGetOverview ( )

Get an overview of the proposed sampledata.

Renvoie
stdClass|void Will be converted into the JSON response to the module.
Depuis
3.8.0

Références $data.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected

◆ $menuItemModel

$menuItemModel
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/sampledata/blog/blog.php


Joomla CMS: Référence de la classe PlgSampledataMultilang

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSampledataMultilang
+ Graphe d'héritage de PlgSampledataMultilang:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onSampledataGetOverview ()
onAjaxSampledataApplyStep1 ()
onAjaxSampledataApplyStep2 ()
onAjaxSampledataApplyStep3 ()
onAjaxSampledataApplyStep4 ()
onAjaxSampledataApplyStep5 ()
onAjaxSampledataApplyStep6 ()
onAjaxSampledataApplyStep7 ()
onAjaxSampledataApplyStep8 ()
addCategory ($itemLanguage)
getInstalledlangsAdministrator ()
getInstalledlangsFrontend ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

getInstalledlangs ($clientName='administrator')
getLanguageList ($clientId=1)
compareLanguages ($lang1, $lang2)
getPath ()
getClient ($client='administrator')
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$db
$app
$autoloadLanguage = true
$path = null
$adminId
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

enablePlugin ($pluginName)
disableModuleMainMenu ()
addModuleLanguageSwitcher ()
addModuleMenu ($itemLanguage)
addMenuGroup ($itemLanguage)
addAllCategoriesMenuItem ($itemLanguage)
addBlogMenuItem ($itemLanguage, $categoryId)
addAssociations ($groupedAssociations)
addModuleInModuleMenu ($moduleId)
addArticle ($itemLanguage, $categoryId)
publishContentLanguages ()
getAdminId ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Sampledata - Multilang Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ addAllCategoriesMenuItem()

addAllCategoriesMenuItem ( $itemLanguage )
private

Add List All Categories Menu Item for new router.

Paramètres
stdClass $itemLanguage Language Object.
Renvoie
Table|boolean Menu Item Object. False otherwise.
Depuis
4.0.0

Références $title, et JPATH_ADMINISTRATOR.

◆ addArticle()

addArticle | ( | $itemLanguage,
 |  | $categoryId
 | ) |
private

Create an article in a specific language.

Paramètres
stdClass | $itemLanguage | Language Object.
integer | $categoryId | The id of the category where we want to add the article.
Renvoie
Table|boolean Article Object. False otherwise.
Depuis
4.0.0

Références $article, $currentDate, $data, $db, $query, $title, Joomla\CMS\MVC\Model\$workflow, Factory\getDate(), JPATH_ADMINISTRATOR, null, et ApplicationHelper\stringURLSafe().

◆ addAssociations()

addAssociations ( $groupedAssociations )
private

Create the language associations.

Paramètres
array $groupedAssociations Array of language associations for all items.
Renvoie
boolean True on success.
Depuis
4.0.0

Références $context, $db, $id, $key, $language, $query, ParameterType\INTEGER, et ParameterType\STRING.

◆ addBlogMenuItem()

addBlogMenuItem | ( | $itemLanguage,
 |  | $categoryId
 | ) |
private

Add Blog Menu Item.

Paramètres
stdClass | $itemLanguage | Language Object.
integer | $categoryId | The id of the category displayed by the blog.
Renvoie
Table|boolean Menu Item Object. False otherwise.
Depuis
4.0.0

Références $title, et JPATH_ADMINISTRATOR.

◆ addCategory()

addCategory ( $itemLanguage )

Method to create a category for a specific language.

Paramètres
stdClass $itemLanguage Language Object.
Renvoie
Table|boolean Category Object. False otherwise.
Depuis
4.0.0

Références $app, $category, $data, $title, Factory\getApplication(), Factory\getDate(), JPATH_ADMINISTRATOR, et ApplicationHelper\stringURLSafe().

◆ addMenuGroup()

addMenuGroup ( $itemLanguage )
private

Add Menu Group.

Paramètres
stdClass $itemLanguage Language Object.
Renvoie
boolean
Depuis
4.0.0

◆ addModuleInModuleMenu()

addModuleInModuleMenu ( $moduleId )
private

Add a Module in Module menus.

Paramètres
integer $moduleId The Id of module.
Renvoie
boolean
Depuis
4.0.0

Références $db, $moduleId, $query, et ParameterType\INTEGER.

◆ addModuleLanguageSwitcher()

addModuleLanguageSwitcher ( )
private

Enable the Language Switcher Module.

Renvoie
boolean
Depuis
4.0.0

◆ addModuleMenu()

addModuleMenu ( $itemLanguage )
private

Add Module Menu.

Paramètres
stdClass $itemLanguage Language Object.
Renvoie
boolean
Depuis
4.0.0

Références $title.

◆ compareLanguages()

compareLanguages | ( | $lang1,
 |  | $lang2
 | ) |
protected

Compare two languages in order to sort them.

Paramètres
object | $lang1 | The first language.
object | $lang2 | The second language.
Renvoie
integer
Depuis
4.0.0

◆ disableModuleMainMenu()

disableModuleMainMenu ( )
private

Disable Default Main Menu Module.

Renvoie
boolean
Depuis
4.0.0

Références $db, et $query.

◆ enablePlugin()

enablePlugin ( $pluginName )
private

Enable a Joomla plugin.

Paramètres
string $pluginName The name of plugin.
Renvoie
boolean
Depuis
4.0.0

Références $db, $params, et $query.

◆ getAdminId()

getAdminId ( )
private

Retrieve the admin user id.

Renvoie
integer|boolean One Administrator ID.
Depuis
4.0.0

Références $db, $id, et $query.

◆ getClient()

getClient ( $client = 'administrator' )
protected

Get the client object of Administrator or Frontend.

Paramètres
string $client Name of the client object.
Renvoie
object
Depuis
4.0.0

Références $client, et ApplicationHelper\getClientInfo().

◆ getInstalledlangs()

getInstalledlangs ( $clientName = 'administrator' )
protected

Get Installed Languages.

Paramètres
string $clientName Name of the cms client.
Renvoie
array
Depuis
4.0.0

Références $client, $data, $info, $key, $lang, $params, $path, $this, $value, ComponentHelper\getParams(), null, et Installer\parseXMLInstallFile().

◆ getInstalledlangsAdministrator()

getInstalledlangsAdministrator ( )

Get Languages item data for the Administrator.

Renvoie
array
Depuis
4.0.0

◆ getInstalledlangsFrontend()

getInstalledlangsFrontend ( )

Get Languages item data for the Frontend.

Renvoie
array List of installed languages in the frontend application.
Depuis
4.0.0

◆ getLanguageList()

getLanguageList ( $clientId = 1 )
protected

Get installed languages data.

Paramètres
integer $clientId The client ID to retrieve data for.
Renvoie
object The language data.
Depuis
4.0.0

Références $clientId, $db, $query, et ParameterType\INTEGER.

◆ getPath()

getPath ( )
protected

Get the languages folder path.

Renvoie
string The path to the languages folders.
Depuis
4.0.0

Références $client, $path, LanguageHelper\getLanguagePath(), null, et path.

◆ onAjaxSampledataApplyStep1()

onAjaxSampledataApplyStep1 ( )

First step to enable the Language filter plugin.

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références $lang, $languages, $message, Text\_(), Joomla\Application\checkToken(), JPATH_ADMINISTRATOR, et Text\sprintf().

◆ onAjaxSampledataApplyStep2()

onAjaxSampledataApplyStep2 ( )

Second step to add a language switcher module

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références $lang, $message, Text\_(), Joomla\Application\checkToken(), ComponentHelper\isEnabled(), JPATH_SITE, et Text\sprintf().

◆ onAjaxSampledataApplyStep3()

onAjaxSampledataApplyStep3 ( )

Third step to make sure all content languages are published

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_(), Joomla\Application\checkToken(), ComponentHelper\isEnabled(), et Text\sprintf().

◆ onAjaxSampledataApplyStep4()

onAjaxSampledataApplyStep4 ( )

Fourth step to create Menus and list all categories menu items

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_(), Joomla\Application\checkToken(), ComponentHelper\isEnabled(), et Text\sprintf().

◆ onAjaxSampledataApplyStep5()

onAjaxSampledataApplyStep5 ( )

Fifth step to add menu modules

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_(), Joomla\Application\checkToken(), ComponentHelper\isEnabled(), et Text\sprintf().

◆ onAjaxSampledataApplyStep6()

onAjaxSampledataApplyStep6 ( )

Sixth step to add workflow, categories, articles and blog menu items

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_(), Joomla\Application\checkToken(), ComponentHelper\getParams(), ComponentHelper\isEnabled(), et Text\sprintf().

◆ onAjaxSampledataApplyStep7()

onAjaxSampledataApplyStep7 ( )

Seventh step to disable the mainmenu module whose home page is set to All languages.

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_(), Joomla\Application\checkToken(), ComponentHelper\isEnabled(), et Text\sprintf().

◆ onAjaxSampledataApplyStep8()

onAjaxSampledataApplyStep8 ( )

Final step to show completion of sampledata.

Renvoie
array|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références Text\_().

◆ onSampledataGetOverview()

onSampledataGetOverview ( )

Get an overview of the proposed sampledata.

Renvoie
stdClass|void Will be converted into the JSON response to the module.
Depuis
4.0.0

Références $data, et Text\_().

◆ publishContentLanguages()

publishContentLanguages ( )
private

Publish the Installed Content Languages.

Renvoie
boolean
Depuis
4.0.0

Références Text\sprintf().

Documentation des champs

◆ $adminId

$adminId
protected

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected

◆ $path

$path = null
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • multilang.php


Joomla CMS: Référence de la classe PlgSystemAccessibility

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgSystemAccessibility
+ Graphe d'héritage de PlgSystemAccessibility:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeCompileHead ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

System plugin to add additional accessibility features to the administrator interface.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeCompileHead()

onBeforeCompileHead ( )

Add the javascript for the accessibility menu

Renvoie
void
Depuis
4.0.0

Add strings for translations in Javascript. Reference https://ranbuch.github.io/accessibility/

Références $direction, $document, $lang, $section, et true.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • accessibility.php


Joomla CMS: Référence de la classe PlgSystemActionLogs

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemActionLogs
+ Graphe d'héritage de PlgSystemActionLogs:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config)
onAfterInitialise ()
onContentPrepareForm (Form $form, $data)
onContentPrepareData ($context, $data)
onAfterRespond ()
onUserAfterSave ($user, $isNew, $success, $msg)
onUserAfterDelete ($user, $success, $msg)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static | renderActionlogsNotify ($value)
static | renderActionlogsExtensions ($extensions)

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

clearCacheGroups (array $clearGroups, array $cacheClients=[0, 1])

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Users Actions Logging Plugin.

Depuis
3.9.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |

Constructor.

Paramètres
object | $subject | The object to observe.
array | $config | An optional associative array of configuration settings.
Depuis
3.9.0

Références $config, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ clearCacheGroups()

clearCacheGroups | ( | array | $clearGroups,
 |  | array | $cacheClients = [0,
 |  | 1] |
 | ) |  |
private

Clears cache groups. We use it to clear the plugins cache after we update the last run timestamp.

Paramètres
array | $clearGroups | The cache groups to clean
array | $cacheClients | The cache clients (site, admin) to clean
Renvoie
void
Depuis
3.9.0

Références $clientId, $options, Factory\getApplication(), JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ onAfterInitialise()

onAfterInitialise ( )

Listener for the onAfterInitialise event

Renvoie
void
Depuis
4.0.0

◆ onAfterRespond()

onAfterRespond ( )

Runs after the HTTP response has been sent to the client and delete log records older than certain days

Renvoie
void
Depuis
3.9.0

Références $db, $last, $now, $params, $query, $result, et Factory\getDate().

◆ onContentPrepareData()

onContentPrepareData | ( | $context,
 |  | $data
 | ) |

Runs on content preparation

Paramètres
string | $context | The context for the data
object | $data | An object containing the data for the form.
Renvoie
boolean
Depuis
3.9.0

Références $context, $data, $db, $id, et $query.

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Adds additional fields to the user editing form for logs e-mail notifications

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
3.9.0
Exceptions
Exception

We only allow users who have Super User permission to change this setting for themselves or for other users who have the same Super User permission

Références $data, $form, $user, __DIR__, Factory\getApplication(), et Factory\getUser().

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

Removes user preferences

Method is called after user data is deleted from the database

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Depuis
3.9.0

Références $db, $query, et $user.

◆ onUserAfterSave()

onUserAfterSave | ( | $user,
 |  | $isNew,
 |  | $success,
 |  | $msg
 | ) |

Utility method to act on a user after it has been saved.

Paramètres
array | $user | Holds the new user data.
boolean | $isNew | True if a new user is stored.
boolean | $success | True if user was successfully stored in the database.
string | $msg | Message.
Renvoie
void
Depuis
3.9.0

Références $authorised, $columns, $db, $extension, $query, $user, et elseif.

◆ renderActionlogsExtensions()

static renderActionlogsExtensions ( $extensions )
static

Method to render a list of extensions.

Paramètres
array | string $extensions Array of extensions or an empty string if none selected.
Renvoie
string The rendered value.
Depuis
3.9.16

Références $extension, JPATH_ADMINISTRATOR, et JLoader\register().

◆ renderActionlogsNotify()

static renderActionlogsNotify ( $value )
static

Method to render a value.

Paramètres
integer | string $value The value (0 or 1).
Renvoie
string The rendered value.
Depuis
3.9.16

Références $value.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • system/actionlogs/actionlogs.php


Joomla CMS: Référence de la classe PlgSystemDebug

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgSystemDebug
+ Graphe d'héritage de PlgSystemDebug:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeCompileHead ()
onAfterRespond ()
onAjaxDebug ($event)
onAfterDisconnect (ConnectionEvent $event)
logger (LogEntry $entry)
onBeforeRespond ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$app
$db
$isAjax = false
$showLogs = false
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

isAuthorisedDisplayDebug ()
collectLogs ()

Attributs privés

$debugLang = false
$logEntries = []
$sqlShowProfiles = []
$sqlShowProfileEach = []
$explains = []
$totalQueries = 0
$debugBar
$queryMonitor

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Debug plugin.

Depuis
1.5

Documentation des fonctions membres

◆ collectLogs()

collectLogs ( )
private

Collect log messages.

Renvoie
$this
Depuis
4.0.0

Références $category, $message, $this, elseif, et JPATH_ROOT.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.1.3

Implémente SubscriberInterface.

◆ isAuthorisedDisplayDebug()

isAuthorisedDisplayDebug ( )
private

Method to check if the current user is allowed to see the debug information or not.

Renvoie
boolean True if access is allowed.
Depuis
3.0

Références $result, et null.

◆ logger()

logger ( LogEntry $entry )

Store log messages so they can be displayed later. This function is passed log entries by JLogLoggerCallback.

Paramètres
LogEntry $entry A log entry.
Renvoie
void
Depuis
3.1
Obsolète:
5.0 Use Log::add(LogEntry $entry);

◆ onAfterDisconnect()

onAfterDisconnect ( ConnectionEvent $event )

Disconnect handler for database to collect profiling and explain information.

Paramètres
ConnectionEvent $event Event object
Renvoie
void
Depuis
4.0.0

Références $db, $key, $query, ConnectionEvent\getDriver(), JDEBUG, et null.

◆ onAfterRespond()

onAfterRespond ( )

Show the debug info.

Renvoie
void
Depuis
1.6

Références Joomla\Application\getFormToken(), et JDEBUG.

◆ onAjaxDebug()

onAjaxDebug ( $event )

AJAX handler

Paramètres
Joomla\Event\Event $event
Renvoie
void
Depuis
4.0.0

Références $result, Joomla\Application\checkToken(), et JDEBUG.

◆ onBeforeCompileHead()

onBeforeCompileHead ( )

Add an assets for debugger.

Renvoie
void
Depuis
4.0.0

Références JDEBUG, et null.

◆ onBeforeRespond()

onBeforeRespond ( )

Add server timing headers when profile is activated.

Renvoie
void
Depuis
4.1.0

Références $desc, $name, et JDEBUG.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected

◆ $debugBar

$debugBar
private

◆ $debugLang

$debugLang = false
private

◆ $explains

$explains = []
private

◆ $isAjax

$isAjax = false
protected

◆ $logEntries

$logEntries = []
private

◆ $queryMonitor

$queryMonitor
private

◆ $showLogs

$showLogs = false
protected

◆ $sqlShowProfileEach

$sqlShowProfileEach = []
private

◆ $sqlShowProfiles

$sqlShowProfiles = []
private

◆ $totalQueries

$totalQueries = 0
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/debug/debug.php


Joomla CMS: Référence de la classe PlgSystemFields

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemFields
+ Graphe d'héritage de PlgSystemFields:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentNormaliseRequestData ($context, $data, Form $form)
onUserAfterSave ($userData, $isNew, $success, $msg)
onUserAfterDelete ($user, $success, $msg)
onContentPrepareForm (Form $form, $data)
onContentAfterTitle ($context, $item, $params, $limitstart=0)
onContentBeforeDisplay ($context, $item, $params, $limitstart=0)
onContentAfterDisplay ($context, $item, $params, $limitstart=0)
onContentPrepare ($context, $item)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

display ($context, $item, $params, $displayType)
prepareTagItem ($item)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Fields Plugin

Depuis
3.7

Documentation des fonctions membres

◆ display()

display | ( | $context,
 |  | $item,
 |  | $params,
 |  | $displayType
 | ) |
private

Performs the display event.

Paramètres
string | $context | The context
stdClass | $item | The item
Registry | $params | The params
integer | $displayType | The type
Renvoie
string
Depuis
3.7.0

Références $app, $context, $field, $fields, $item, $key, $lang, $params, $parts, FieldsHelper\extract(), Factory\getApplication(), FieldsHelper\getFields(), et FieldsHelper\render().

◆ onContentAfterDisplay()

onContentAfterDisplay | ( | $context,
 |  | $item,
 |  | $params,
 |  | $limitstart = 0
 | ) |

The display event.

Paramètres
string | $context | The context
stdClass | $item | The item
Registry | $params | The params
integer | $limitstart | The start
Renvoie
string
Depuis
3.7.0

Références $context, $item, et $params.

◆ onContentAfterTitle()

onContentAfterTitle | ( | $context,
 |  | $item,
 |  | $params,
 |  | $limitstart = 0
 | ) |

The display event.

Paramètres
string | $context | The context
stdClass | $item | The item
Registry | $params | The params
integer | $limitstart | The start
Renvoie
string
Depuis
3.7.0

Références $context, $item, et $params.

◆ onContentBeforeDisplay()

onContentBeforeDisplay | ( | $context,
 |  | $item,
 |  | $params,
 |  | $limitstart = 0
 | ) |

The display event.

Paramètres
string | $context | The context
stdClass | $item | The item
Registry | $params | The params
integer | $limitstart | The start
Renvoie
string
Depuis
3.7.0

Références $context, $item, et $params.

◆ onContentNormaliseRequestData()

onContentNormaliseRequestData | ( |  | $context,
 |  |  | $data,
 |  | Form | $form
 | ) |  |

Normalizes the request data.

Paramètres
string | $context | The context
object | $data | The object
Form | $form | The form
Renvoie
void
Depuis
3.8.7

Disabled fields should NEVER be added to the request as they should NEVER be added by the browser anyway so nothing to check against as "disabled" means no interaction at all.

Références $context, $data, $field, $form, et FieldsHelper\extract().

◆ onContentPrepare()

onContentPrepare | ( | $context,
 |  | $item
 | ) |

Performs the display event.

Paramètres
string | $context | The context
stdClass | $item | The item
Renvoie
void
Depuis
3.7.0

Références $context, $field, $fields, $item, $key, $parts, FieldsHelper\extract(), et FieldsHelper\getFields().

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

The form event.

Paramètres
Form | $form | The form
stdClass | $data | The data
Renvoie
boolean
Depuis
3.7.0

Références $context, $data, $form, $input, $parts, FieldsHelper\extract(), Factory\getApplication(), et Joomla\CMS\Categories\prepareForm().

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

The user delete event.

Paramètres
stdClass | $user | The context
boolean | $success | Is success
string | $msg | The message
Renvoie
void
Depuis
3.7.0

Références $item, et $user.

◆ onUserAfterSave()

onUserAfterSave | ( | $userData,
 |  | $isNew,
 |  | $success,
 |  | $msg
 | ) |

The save event.

Paramètres
array | $userData | The date
boolean | $isNew | Is new
boolean | $success | Is success
string | $msg | The message
Renvoie
void
Depuis
3.7.0

Références $task, $user, Factory\getApplication(), et Factory\getUser().

◆ prepareTagItem()

prepareTagItem ( $item )
private

Prepares a tag item to be ready for com_fields.

Paramètres
stdClass $item The item
Renvoie
object
Depuis
3.8.4

Références $item.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/fields/fields.php


Joomla CMS: Référence de la classe PlgSystemHighlight

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgSystemHighlight
+ Graphe d'héritage de PlgSystemHighlight:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onFinderResult ($item, $query)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

System plugin to highlight terms.

Depuis
2.5

Documentation des fonctions membres

◆ onFinderResult()

onFinderResult | ( | $item,
 |  | $query
 | ) |

Method to catch the onFinderResult event.

Paramètres
Result | $item | The search result
array | $query | The search query of this result
Renvoie
void
Depuis
4.0.0

Références $item, $params, $query, et ComponentHelper\getParams().

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • highlight.php


Joomla CMS: Référence de la classe PlgSystemHttpHeaders

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgSystemHttpHeaders
+ Graphe d'héritage de PlgSystemHttpHeaders:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config)
applyHashesToCspRule (Event $event)
setHttpHeaders (Event $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

setCspHeader ()
getStaticHeaderConfiguration ()
setStaticHeaders ()

Attributs privés

$cspNonce
$supportedHttpHeaders
$validDirectives
$noValueDirectives
$nonceDirectives

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Plugin class for HTTP Headers

Depuis
4.0.0

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |

Constructor.

Paramètres
DispatcherInterface | $subject | The object to observe.
array | $config | An optional associative array of configuration settings.
Depuis
4.0.0

Références $config, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ applyHashesToCspRule()

applyHashesToCspRule ( Event $event )

The applyHashesToCspRule method makes sure the csp hashes are added to the csp header when enabled

Renvoie
void
Depuis
4.0.0

Références $hash, $id, et $type.

◆ getStaticHeaderConfiguration()

getStaticHeaderConfiguration ( )
private

Get the configured static headers.

Renvoie
array We return the array of static headers with its values.
Depuis
4.0.0

Références $this.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

◆ setCspHeader()

setCspHeader ( )
private

Set the CSP header when enabled

Renvoie
void
Depuis
4.0.0

That line is for B/C we do no longer require to add the nonce tag but add it once the setting is enabled so this line here is needed to remove the outdated tag that was required until 4.2.0

Références $this.

◆ setHttpHeaders()

setHttpHeaders ( Event $event )

The setHttpHeaders method handle the setting of the configured HTTP Headers

Renvoie
void
Depuis
4.0.0

◆ setStaticHeaders()

setStaticHeaders ( )
private

Set the static headers when enabled

Renvoie
void
Depuis
4.0.0

Références $client, $header, et $value.

Documentation des champs

◆ $app

$app
protected

◆ $cspNonce

$cspNonce
private

◆ $db

$db
protected

◆ $nonceDirectives

$nonceDirectives
private
Valeur initiale :
= [
'script-src',
'style-src',
]

◆ $noValueDirectives

$noValueDirectives
private
Valeur initiale :
= [
'block-all-mixed-content',
'upgrade-insecure-requests',
]

◆ $supportedHttpHeaders

$supportedHttpHeaders
private
Valeur initiale :
= [
'strict-transport-security',
'content-security-policy',
'content-security-policy-report-only',
'x-frame-options',
'referrer-policy',
'expect-ct',
'feature-policy',
'cross-origin-opener-policy',
'report-to',
'permissions-policy',
]

◆ $validDirectives

$validDirectives
private
Valeur initiale :
= [
'child-src',
'connect-src',
'default-src',
'font-src',
'frame-src',
'img-src',
'manifest-src',
'media-src',
'prefetch-src',
'object-src',
'script-src',
'script-src-elem',
'script-src-attr',
'style-src',
'style-src-elem',
'style-src-attr',
'worker-src',
'base-uri',
'plugin-types',
'sandbox',
'form-action',
'frame-ancestors',
'navigate-to',
'report-uri',
'report-to',
'block-all-mixed-content',
'upgrade-insecure-requests',
'require-sri-for',
]
La documentation de cette classe a été générée à partir du fichier suivant :
  • httpheaders.php


Joomla CMS: Référence de la classe PlgSystemJooa11y

Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemJooa11y
+ Graphe d'héritage de PlgSystemJooa11y:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$app
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

isAuthorisedDisplayChecker ()

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Jooa11y plugin to add an accessibility checker

Depuis
4.1.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Subscribe to certain events

Renvoie
string[] An array of event mappings
Depuis
4.1.0
Exceptions
Exception

Implémente SubscriberInterface.

Références Factory\getApplication().

◆ isAuthorisedDisplayChecker()

isAuthorisedDisplayChecker ( )
private

Method to check if the current user is allowed to see the debug information or not.

Renvoie
boolean True if access is allowed.
Depuis
4.1.0

Références $result.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • jooa11y.php


Joomla CMS: Référence de la classe PlgSystemLanguagecode

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgSystemLanguagecode
+ Graphe d'héritage de PlgSystemLanguagecode:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onAfterRender ()
onContentPrepareForm (Form $form, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Language Code plugin class.

Depuis
2.5

Documentation des fonctions membres

◆ onAfterRender()

onAfterRender ( )

Plugin that changes the language code used in the <html> tag.

Renvoie
void
Depuis
2.5

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Prepare form.

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
2.5

Références $form, $language, $languages, ENT_COMPAT, LanguageHelper\getKnownLanguages(), JPATH_SITE, et Text\sprintf().

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • languagecode.php


Joomla CMS: Référence de la classe PlgSystemLanguageFilter

Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgSystemLanguageFilter
+ Graphe d'héritage de PlgSystemLanguageFilter:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config)
onAfterInitialise ()
onAfterRoute ()
preprocessBuildRule (&$router, &$uri)
buildRule (&$router, &$uri)
postprocessSEFBuildRule (&$router, &$uri)
postprocessNonSEFBuildRule (&$router, &$uri)
parseRule (&$router, &$uri)
onPrivacyCollectAdminCapabilities ()
onUserBeforeSave ($user, $isnew, $new)
onUserAfterSave ($user, $isnew, $success, $msg)
onUserLogin ($user, $options=array())
onAfterDispatch ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$mode_sef
$sefs
$lang_codes
$current_lang
$default_lang
$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

setLanguageCookie ($languageCode)
getLanguageCookie ()

Attributs privés

$user_lang_code

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Language Filter Plugin.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |

Constructor.

Paramètres
object | &$subject | The object to observe
array | $config | An optional associative array of configuration settings.
Depuis
1.6

Références $config, $language, $subject, $this, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ buildRule()

buildRule | ( | & | $router,
 |  | & | $uri
 | ) |  |

Add build rule to router.

Paramètres
Router | &$router | Router object.
Uri | &$uri | Uri object.
Renvoie
void
Depuis
1.6

Références $lang, et $uri.

◆ getLanguageCookie()

getLanguageCookie ( )
private

Get the language cookie

Renvoie
string
Depuis
3.4.2

Références null.

◆ onAfterDispatch()

onAfterDispatch ( )

Method to add alternative meta tags for associated menu items.

Renvoie
void
Depuis
1.7

Références $active, $component, $doc, $i, $item, $language, $languages, $menu, $option, class, MenusHelper\getAssociations(), Joomla\DI\getContainer(), Uri\getInstance(), JPATH_SITE, et JLoader\register().

◆ onAfterInitialise()

onAfterInitialise ( )

After initialise.

Renvoie
void
Depuis
1.6

Références $this, class, et Joomla\DI\getContainer().

◆ onAfterRoute()

onAfterRoute ( )

After route.

Renvoie
void
Depuis
3.4

◆ onPrivacyCollectAdminCapabilities()

onPrivacyCollectAdminCapabilities ( )

Reports the privacy related capabilities for this plugin to site administrators.

Renvoie
array
Depuis
3.9.0

◆ onUserAfterSave()

onUserAfterSave | ( | $user,
 |  | $isnew,
 |  | $success,
 |  | $msg
 | ) |

After store user method.

Method is called after user data is stored in the database.

Paramètres
array | $user | Holds the new user data.
boolean | $isnew | True if a new user is stored.
boolean | $success | True if user was successfully stored in the database.
string | $msg | Message.
Renvoie
void
Depuis
1.6

Références $user, et null.

◆ onUserBeforeSave()

onUserBeforeSave | ( | $user,
 |  | $isnew,
 |  | $new
 | ) |

Before store user method.

Method is called before user data is stored in the database.

Paramètres
array | $user | Holds the old user data.
boolean | $isnew | True if a new user is stored.
array | $new | Holds the new user data.
Renvoie
void
Depuis
1.6

Références $user.

◆ onUserLogin()

onUserLogin | ( | $user,
 |  | $options = array()
 | ) |

Method to handle any login logic and report back to the subject.

Paramètres
array | $user | Holds the user data.
array | $options | Array holding options (remember, autoregister, group).
Renvoie
boolean True on success.
Depuis
1.5

Looking for associations. If the login menu item form contains an internal URL redirection, This will override the automatic change to the user preferred site language. In that case we use the redirect as defined in the menu item. Otherwise we redirect, when available, to the user preferred site language.

The login form does not contain a menu item redirection. The active menu item has associations. We redirect to the user preferred site language associated page.

Références $active, $assoc, $item, $menu, $uri, $user, class, elseif, MenusHelper\getAssociations(), Joomla\DI\getContainer(), et JPATH_SITE.

◆ parseRule()

parseRule | ( | & | $router,
 |  | & | $uri
 | ) |  |

Add parse rule to router.

Paramètres
Router | &$router | Router object.
Uri | &$uri | Uri object.
Renvoie
void
Depuis
1.6

Références $extension, $lang, $language, $parts, $path, $redirectUri, $uri, Language\getInstance(), JPATH_ADMINISTRATOR, et JPATH_PLUGINS.

◆ postprocessNonSEFBuildRule()

postprocessNonSEFBuildRule | ( | & | $router,
 |  | & | $uri
 | ) |  |

postprocess build rule for non-SEF URLs

Paramètres
Router | &$router | Router object.
Uri | &$uri | Uri object.
Renvoie
void
Depuis
3.4

Références $lang, et $uri.

◆ postprocessSEFBuildRule()

postprocessSEFBuildRule | ( | & | $router,
 |  | & | $uri
 | ) |  |

postprocess build rule for SEF URLs

Paramètres
Router | &$router | Router object.
Uri | &$uri | Uri object.
Renvoie
void
Depuis
3.4

Références $uri.

◆ preprocessBuildRule()

preprocessBuildRule | ( | & | $router,
 |  | & | $uri
 | ) |  |

Add build preprocess rule to router.

Paramètres
Router | &$router | Router object.
Uri | &$uri | Uri object.
Renvoie
void
Depuis
3.4

Références $lang, et $uri.

◆ setLanguageCookie()

setLanguageCookie ( $languageCode )
private

Set the language cookie

Paramètres
string $languageCode The language code for which we want to set the cookie
Renvoie
void
Depuis
3.4.2

Références true.

Documentation des champs

◆ $app

$app
protected

◆ $current_lang

$current_lang
protected

◆ $default_lang

$default_lang
protected

◆ $lang_codes

$lang_codes
protected

◆ $mode_sef

$mode_sef
protected

◆ $sefs

$sefs
protected

◆ $user_lang_code

$user_lang_code
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • languagefilter.php


Joomla CMS: Référence de la classe PlgSystemLog

Fonctions membres publiques
Référence de la classe PlgSystemLog
+ Graphe d'héritage de PlgSystemLog:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserLoginFailure ($response)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Description détaillée

Joomla! System Logging Plugin.

Depuis
1.5

Documentation des fonctions membres

◆ onUserLoginFailure()

onUserLoginFailure ( $response )

Called if user fails to be logged in.

Paramètres
array $response Array of response data.
Renvoie
void
Depuis
1.5
La documentation de cette classe a été générée à partir du fichier suivant :
  • log.php


Joomla CMS: Référence de la classe PlgSystemLogout

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgSystemLogout
+ Graphe d'héritage de PlgSystemLogout:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

__construct (&$subject, $config)
onUserLogout ($user, $options=[])
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Plugin class for logout redirect handling.

Depuis
1.6

Documentation des constructeurs et destructeur

◆ __construct()

__construct | ( | & | $subject,
 |  |  | $config
 | ) |  |
Paramètres
object | &$subject | The object to observe – event dispatcher.
object | $config | An optional associative array of configuration settings.
Depuis
1.6

Références $config, $hash, $subject, et Symfony\Contracts\Service\__construct().

Documentation des fonctions membres

◆ onUserLogout()

onUserLogout | ( | $user,
 |  | $options = []
 | ) |

Method to handle any logout logic and report back to the subject.

Paramètres
array | $user | Holds the user data.
array | $options | Array holding options (client, ...).
Renvoie
boolean Always returns true.
Depuis
1.6

Références true.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • logout.php


Joomla CMS: Référence de la classe PlgSystemLogrotation

Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemLogrotation
+ Graphe d'héritage de PlgSystemLogrotation:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getLogFiles ($path)
rotate ($path, $filename, $currentVersion)
clearCacheGroups (array $clearGroups, array $cacheClients=array(0, 1))

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Log Rotation plugin

Rotate the log files created by Joomla core

Depuis
3.9.0

Documentation des fonctions membres

◆ clearCacheGroups()

clearCacheGroups | ( | array | $clearGroups,
 |  | array | $cacheClients = array(0, 1)
 | ) |  |
private

Clears cache groups. We use it to clear the plugins cache after we update the last run timestamp.

Paramètres
array | $clearGroups | The cache groups to clean
array | $cacheClients | The cache clients (site, admin) to clean
Renvoie
void
Depuis
3.9.0

Références $options, JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getLogFiles()

getLogFiles ( $path )
private

Get log files from log folder

Paramètres
string $path The folder to get log files
Renvoie
array The log files in the given path grouped by version number (not rotated files has number 0)
Depuis
3.9.0

Références $parts, $path, et $version.

◆ rotate()

rotate | ( | $path,
 |  | $filename,
 |  | $currentVersion
 | ) |
private

Method to rotate (increase version) of a log file

Paramètres
string | $path | Path to file to rotate
string | $filename | Name of file to rotate
int | $currentVersion | The current version number
Renvoie
void
Depuis
3.9.0

Références $parts, et $path.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • logrotation.php


Joomla CMS: Référence de la classe PlgSystemPrivacyconsent

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemPrivacyconsent
+ Graphe d'héritage de PlgSystemPrivacyconsent:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (Form $form, $data)
onUserBeforeSave ($user, $isNew, $data)
onUserAfterDelete ($user, $success, $msg)
onAfterRoute ()
onPrivacyCheckPrivacyPolicyPublished (&$policy)
onAfterRender ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getRedirectMessage ()
isUserConsented ($userId)
getPrivacyArticleId ()
getPrivacyItemId ()
remindExpiringConsents ()
clearCacheGroups (array $clearGroups, array $cacheClients=[0, 1])

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

An example custom privacyconsent plugin.

Depuis
3.9.0

Documentation des fonctions membres

◆ clearCacheGroups()

clearCacheGroups | ( | array | $clearGroups,
 |  | array | $cacheClients = [0,
 |  | 1] |
 | ) |  |
private

Clears cache groups. We use it to clear the plugins cache after we update the last run timestamp.

Paramètres
array | $clearGroups | The cache groups to clean
array | $cacheClients | The cache clients (site, admin) to clean
Renvoie
void
Depuis
3.9.0

Références $options, JPATH_ADMINISTRATOR, et JPATH_SITE.

◆ getPrivacyArticleId()

getPrivacyArticleId ( )
private

Get privacy article ID. If the site is a multilingual website and there is associated article for the current language, ID of the associated article will be returned

Renvoie
integer
Depuis
3.9.0

◆ getPrivacyItemId()

getPrivacyItemId ( )
private

Get privacy menu item ID. If the site is a multilingual website and there is associated menu item for the current language, ID of the associated menu item will be returned.

Renvoie
integer
Depuis
4.0.0

Références $itemId.

◆ getRedirectMessage()

getRedirectMessage ( )
private

Returns the configured redirect message and falls back to the default version.

Renvoie
string redirect message
Depuis
3.9.0

◆ isUserConsented()

isUserConsented ( $userId )
private

Method to check if the given user has consented yet

Paramètres
integer $userId ID of uer to check
Renvoie
boolean
Depuis
3.9.0

Références $db, $query, et $userId.

◆ onAfterRender()

onAfterRender ( )

The privacy consent expiration check code is triggered after the page has fully rendered.

Renvoie
void
Depuis
3.9.0

Références $db, $last, $now, $query, et $result.

◆ onAfterRoute()

onAfterRoute ( )

If logged in users haven't agreed to privacy consent, redirect them to profile edit page, ask them to agree to privacy consent before allowing access to any other pages

Renvoie
void
Depuis
3.9.0

Références $id, $layout, $link, $option, $task, $userId, et $view.

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Adds additional fields to the user editing form

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
3.9.0

Références $data, $form, $name, $userId, et __DIR__.

◆ onPrivacyCheckPrivacyPolicyPublished()

onPrivacyCheckPrivacyPolicyPublished ( & $policy )

Event to specify whether a privacy policy has been published.

Paramètres
array &$policy The privacy policy status data, passed by reference, with keys "published", "editLink" and "articlePublished".
Renvoie
void
Depuis
3.9.0

Références $article, $articleId, et $query.

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

Remove all user privacy consent information for the given user ID

Method is called after user data is deleted from the database

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Depuis
3.9.0

Références $query, $user, et $userId.

◆ onUserBeforeSave()

onUserBeforeSave | ( | $user,
 |  | $isNew,
 |  | $data
 | ) |

Method is called before user data is stored in the database

Paramètres
array | $user | Holds the old user data.
boolean | $isNew | True if a new user is stored.
array | $data | Holds the new user data.
Renvoie
boolean
Depuis
3.9.0
Exceptions
InvalidArgumentException on missing required data.

Références $form, $option, $task, $user, et $userId.

◆ remindExpiringConsents()

remindExpiringConsents ( )
private

Method to send the remind for privacy consents renew

Renvoie
integer
Depuis
3.9.0

Références $app, $db, $now, $query, $user, $userId, et MailTemplate\addTemplateData().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • privacyconsent.php


Joomla CMS: Référence de la classe PlgSystemRedirect

Fonctions membres publiques statiques | Attributs protégés
Référence de la classe PlgSystemRedirect
+ Graphe d'héritage de PlgSystemRedirect:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$autoloadLanguage = false
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Plugin class for redirect handling.

Depuis
1.6

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = false
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/system/redirect/redirect.php


Joomla CMS: Référence de la classe PlgSystemRemember

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgSystemRemember
+ Graphe d'héritage de PlgSystemRemember:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onAfterInitialise ()
onUserLogout ($user, $options)
onUserBeforeSave ($user, $isnew, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! System Remember Me Plugin

Depuis
1.5

Documentation des fonctions membres

◆ onAfterInitialise()

onAfterInitialise ( )

Remember me method to run onAfterInitialise Only purpose is to initialise the login authentication process if a cookie is present

Renvoie
void
Depuis
1.5
Exceptions
InvalidArgumentException

◆ onUserBeforeSave()

onUserBeforeSave | ( | $user,
 |  | $isnew,
 |  | $data
 | ) |

Method is called before user data is stored in the database Invalidate all existing remember-me cookies after a password change

Paramètres
array | $user | Holds the old user data.
boolean | $isnew | True if a new user is stored.
array | $data | Holds the new user data.
Renvoie
boolean
Depuis
3.8.6

Références $data, $db, $query, et $user.

◆ onUserLogout()

onUserLogout | ( | $user,
 |  | $options
 | ) |

Imports the authentication plugin on user logout to make sure that the cookie is destroyed.

Paramètres
array | $user | Holds the user data.
array | $options | Array holding options (remember, autoregister, group).
Renvoie
boolean

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • remember.php


Joomla CMS: Référence de la classe PlgSystemSchedulerunner

Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Attributs privés
Référence de la classe PlgSystemSchedulerunner
+ Graphe d'héritage de PlgSystemSchedulerunner:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

injectLazyJS (EventInterface $event)
runLazyCron (EventInterface $e)
runWebCron (Event $event)
runTestCron (Event $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres protégées

runScheduler (int $id=0)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

const WEBCRON_KEY_LENGTH = 20

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

This plugin implements listeners to support a visitor-triggered lazy-scheduling pattern. If com_scheduler is installed/enabled and its configuration allows unprotected lazy scheduling, this plugin injects into each response with an HTML context a JS file {

Voir également
PlgSystemSchedulerunner::injectScheduleRunner()} that sets up an AJAX callback to trigger the scheduler {
PlgSystemSchedulerunner::runScheduler()}. This is achieved through a call to the com_ajax component. Also supports the scheduler component configuration form through auto-generation of the webcron key and injection of JS of usability enhancement.
Depuis
4.1.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static
Renvoie
string[]
Depuis
4.1.0
Exceptions
Exception

Implémente SubscriberInterface.

Références $app, $config, elseif, et Factory\getApplication().

◆ injectLazyJS()

injectLazyJS ( EventInterface $event )

Inject JavaScript to trigger the scheduler in HTML contexts.

Paramètres
EventInterface $event The onBeforeCompileHead event.
Renvoie
void
Depuis
4.1.0

Références $config, $items, $model, et $wa.

◆ runLazyCron()

runLazyCron ( EventInterface $e )

Acts on the LazyCron trigger from the frontend when Lazy Cron is enabled in the Scheduler component configuration. The lazy cron trigger is implemented in client-side JavaScript which is injected on every page load with an HTML context when the component configuration allows it. This method then triggers the Scheduler, which effectively runs the next Task in the Scheduler's task queue.

Paramètres
EventInterface $e The onAjaxRunSchedulerLazy event.
Renvoie
void
Depuis
4.1.0
Exceptions
Exception

Références $config.

◆ runScheduler()

runScheduler ( int $id = 0 )
protected

Run the scheduler, allowing execution of a single due task. Does not bypass task scheduling, meaning that even if an ID is passed the task is only triggered if it is due.

Paramètres
integer $id The optional ID of the task to run
Renvoie
?Task
Depuis
4.1.0
Exceptions
RuntimeException

Références $id.

◆ runTestCron()

runTestCron ( Event $event )

This method is responsible for the "test run" functionality in the Scheduler administrator backend interface. Acting on a com_ajax call, this method requires the URL to have a id query parameter (corresponding to an existing Task ID).

Paramètres
Event $event The onAjaxRunScheduler event.
Renvoie
void
Depuis
4.1.0
Exceptions
Exception

?: About allow simultaneous, how do we detect if it failed because of pre-existing lock?

We will allow CLI exclusive tasks to be fetched and executed, it's left to routines to do a runtime check if they want to refuse normal operation.

Placeholder result, but the idea is if we failed to fetch the task, it's likely because another task was already running. This is a fair assumption if this test run was triggered through the administrator backend, so we know the task probably exists and is either enabled/disabled (not trashed).

Références $id, $task, $user, Event\addArgument(), Joomla\Application\checkToken(), et Factory\getApplication().

◆ runWebCron()

runWebCron ( Event $event )

This method is responsible for the WebCron functionality of the Scheduler component.
Acting on a com_ajax call, this method can work in two ways:

  1. If no Task ID is specified, it triggers the Scheduler to run the next task in the task queue.
  2. If a Task ID is specified, it fetches the task (if it exists) from the Scheduler API and executes it.

URL query parameters:

  • hash string (required) Webcron hash (from the Scheduler component configuration).
  • id int (optional) ID of the task to trigger.
Paramètres
Event $event The onAjaxRunSchedulerWebcron event.
Renvoie
void
Depuis
4.1.0
Exceptions
Exception

Références $config, $hash, $id, et $task.

Documentation des champs

◆ $app

$app
protected

◆ WEBCRON_KEY_LENGTH

const WEBCRON_KEY_LENGTH = 20
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • schedulerunner.php


Joomla CMS: Référence de la classe PlgSystemSef

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemSef
+ Graphe d'héritage de PlgSystemSef:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onAfterDispatch ()
onAfterRender ()
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

checkBuffer ($buffer)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! SEF Plugin.

Depuis
1.5

Documentation des fonctions membres

◆ checkBuffer()

checkBuffer ( $buffer )
private

Check the buffer.

Paramètres
string $buffer Buffer to be checked.
Renvoie
void

Références $buffer, $message, et null.

◆ onAfterDispatch()

onAfterDispatch ( )

Add the canonical uri to the head.

Renvoie
void
Depuis
3.5

Références $doc, $link, et $linkUrl.

◆ onAfterRender()

onAfterRender ( )

Convert the site URL to fit to the HTTP request.

Renvoie
void

Références $attributes, $base, $buffer, et $prefix.

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • sef.php


Joomla CMS: Référence de la classe PlgSystemSessionGc

Attributs protégés
Référence de la classe PlgSystemSessionGc
+ Graphe d'héritage de PlgSystemSessionGc:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Garbage collection handler for session related data

Depuis
3.8.6

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • sessiongc.php


Joomla CMS: Référence de la classe PlgSystemSkipto

Attributs protégés
Référence de la classe PlgSystemSkipto
+ Graphe d'héritage de PlgSystemSkipto:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Attributs protégés

$app
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Skipto plugin to add accessible keyboard navigation to the site and administrator templates.

Depuis
4.0.0

Documentation des champs

◆ $app

$app
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • skipto.php


Joomla CMS: Référence de la classe PlgSystemStats

Fonctions membres publiques | Champs de données | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemStats
+ Graphe d'héritage de PlgSystemStats:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onAfterInitialise ()
onAfterDispatch ()
onAjaxSendAlways ()
onAjaxSendNever ()
onAjaxSendStats ()
onGetStatsData ($context)
debug ($layoutId, $data=[])
render ($layoutId, $data=[])
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Champs de données

const | MODE_ALLOW_ALWAYS = 1
const | MODE_ALLOW_NEVER = 3
- Champs de données hérités de CMSPlugin
$params = null

Fonctions membres protégées

getLayoutData ()
getLayoutPaths ()
getRenderer ($layoutId='default')
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$app
$db
$serverUrl = 'https://developer.joomla.org/stats/submit'
$uniqueId
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getStatsData ()
getUniqueId ()
isAllowedUser ()
isDebugEnabled ()
isUpdateRequired ()
isAjaxRequest ()
saveParams ()
sendStats ()
clearCacheGroups (array $clearGroups)
disablePlugin ()
isCaptiveMFA ()

Description détaillée

Statistics system plugin. This sends anonymous data back to the Joomla! Project about the PHP, SQL, Joomla and OS versions

Depuis
3.5

Documentation des fonctions membres

◆ clearCacheGroups()

clearCacheGroups ( array $clearGroups )
private

Clears cache groups. We use it to clear the plugins cache after we update the last run timestamp.

Paramètres
array $clearGroups The cache groups to clean
Renvoie
void
Depuis
3.5

Références $options, et JPATH_CACHE.

◆ debug()

debug | ( | $layoutId,
 |  | $data = []
 | ) |

Debug a layout of this plugin

Paramètres
string | $layoutId | Layout identifier
array | $data | Optional data for the layout
Renvoie
string
Depuis
3.5

Références $data.

◆ disablePlugin()

disablePlugin ( )
private

Disable this plugin, if user selects once or never, to stop Joomla loading the plugin on every page load and therefore regaining a tiny bit of performance

Depuis
4.0.0
Renvoie
boolean

Références $db, $query, et $result.

◆ getLayoutData()

getLayoutData ( )
protected

Get the data for the layout

Renvoie
array
Depuis
3.5

Références $params, et $this.

◆ getLayoutPaths()

getLayoutPaths ( )
protected

Get the layout paths

Renvoie
array
Depuis
3.5

Références $template, __DIR__, Factory\getApplication(), et JPATH_ADMINISTRATOR.

◆ getRenderer()

getRenderer ( $layoutId = 'default' )
protected

Get the plugin renderer

Paramètres
string $layoutId Layout identifier
Renvoie
Depuis
3.5

Références $renderer.

◆ getStatsData()

getStatsData ( )
private

Get the data that will be sent to the stats server.

Renvoie
array
Depuis
3.5

Références $data.

◆ getUniqueId()

getUniqueId ( )
private

Get the unique id. Generates one if none is set.

Renvoie
integer
Depuis
3.5

Références null.

◆ isAjaxRequest()

isAjaxRequest ( )
private

Check valid AJAX request

Renvoie
boolean
Depuis
3.5

◆ isAllowedUser()

isAllowedUser ( )
private

Check if current user is allowed to send the data

Renvoie
boolean
Depuis
3.5

Références Factory\getUser().

◆ isCaptiveMFA()

isCaptiveMFA ( )
private

Are we in a Multi-factor Authentication page?

Renvoie
bool
Depuis
4.2.1

◆ isDebugEnabled()

isDebugEnabled ( )
private

Check if the debug is enabled

Renvoie
boolean
Depuis
3.5

◆ isUpdateRequired()

isUpdateRequired ( )
private

Check if last_run + interval > now

Renvoie
boolean
Depuis
3.5

Références $last, et $mode.

◆ onAfterDispatch()

onAfterDispatch ( )

Listener for the onAfterDispatch event

Renvoie
void
Depuis
4.0.0

◆ onAfterInitialise()

onAfterInitialise ( )

Listener for the onAfterInitialise event

Renvoie
void
Depuis
3.5

◆ onAjaxSendAlways()

onAjaxSendAlways ( )

User selected to always send data

Renvoie
void
Depuis
3.5
Exceptions
Exception | If user is not allowed.
RuntimeException | If there is an error saving the params or sending the data.

Références Text\_().

◆ onAjaxSendNever()

onAjaxSendNever ( )

User selected to never send data.

Renvoie
void
Depuis
3.5
Exceptions
Exception | If user is not allowed.
RuntimeException | If there is an error saving the params.

Références Text\_().

◆ onAjaxSendStats()

onAjaxSendStats ( )

Send the stats to the server. On first load | on demand mode it will show a message asking users to select mode.

Renvoie
void
Depuis
3.5
Exceptions
Exception | If user is not allowed.
RuntimeException | If there is an error saving the params, disabling the plugin or sending the data.

Références $data, et Text\_().

◆ onGetStatsData()

onGetStatsData ( $context )

Get the data through events

Paramètres
string $context Context where this will be called from
Renvoie
array
Depuis
3.5

◆ render()

render | ( | $layoutId,
 |  | $data = []
 | ) |

Render a layout of this plugin

Paramètres
string | $layoutId | Layout identifier
array | $data | Optional data for the layout
Renvoie
string
Depuis
3.5

Références $data.

◆ saveParams()

saveParams ( )
private

Save the plugin parameters

Renvoie
boolean
Depuis
3.5

Références $db, $query, et $result.

◆ sendStats()

sendStats ( )
private

Send the stats to the stats server

Renvoie
boolean
Depuis
3.5
Exceptions
RuntimeException If there is an error sending the data and debug mode enabled.

Références $data, et elseif.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected

◆ $serverUrl

$serverUrl = 'https://developer.joomla.org/stats/submit'
protected

◆ $uniqueId

$uniqueId
protected

◆ MODE_ALLOW_ALWAYS

const MODE_ALLOW_ALWAYS = 1

◆ MODE_ALLOW_NEVER

const MODE_ALLOW_NEVER = 3
La documentation de cette classe a été générée à partir du fichier suivant :
  • stats.php


Joomla CMS: Référence de la classe PlgSystemTasknotification

Fonctions membres publiques statiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgSystemTasknotification
+ Graphe d'héritage de PlgSystemTasknotification:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques statiques

static getSubscribedEvents ()

Attributs protégés

$app
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getDataFromTask (Task $task)

Attributs privés

const TASK_NOTIFICATION_FORM = 'task_notification'

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

This plugin implements email notification functionality for Tasks configured through the Scheduler component. Notification configuration is supported on a per-task basis, which can be set-up through the Task item form, made possible by injecting the notification fields into the item form with a onContentPrepareForm listener.

Notifications can be set-up on: task success, failure, fatal failure (task running too long or crashing the request), or on orphaned task routines (missing parent plugin - either uninstalled, disabled or no longer offering a routine with the same ID).

Depuis
4.1.0

Documentation des fonctions membres

◆ getDataFromTask()

getDataFromTask ( Task $task )
private
Paramètres
Task $task A task object
Renvoie
array An array of data to bind to a mail template.
Depuis
4.1.0

Références $task, Text\_(), et Factory\getDate().

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static
Renvoie
array
Depuis
4.1.0

Implémente SubscriberInterface.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected

◆ TASK_NOTIFICATION_FORM

const TASK_NOTIFICATION_FORM = 'task_notification'
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • tasknotification.php


Joomla CMS: Référence de la classe PlgSystemUpdatenotification

Attributs protégés | Fonctions membres privées
Référence de la classe PlgSystemUpdatenotification
+ Graphe d'héritage de PlgSystemUpdatenotification:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Attributs protégés

$app
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getSuperUsers ($email=null)
clearCacheGroups (array $clearGroups)

Membres hérités additionnels

- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()
- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Joomla! Update Notification plugin

Sends out an email to all Super Users or a predefined list of email addresses of Super Users when a new Joomla! version is available.

This plugin is a direct adaptation of the corresponding plugin in Akeeba Ltd's Admin Tools. The author has consented to relicensing their plugin's code under GPLv2 or later (the original version was licensed under GPLv3 or later) to allow its inclusion in the Joomla! CMS.

Depuis
3.5

Documentation des fonctions membres

◆ clearCacheGroups()

clearCacheGroups ( array $clearGroups )
private

Clears cache groups. We use it to clear the plugins cache after we update the last run timestamp.

Paramètres
array $clearGroups The cache groups to clean
Renvoie
void
Depuis
3.5

Références $options, et JPATH_CACHE.

◆ getSuperUsers()

getSuperUsers ( $email = null )
private

Returns the Super Users email information. If you provide a comma separated $email list we will check that these emails do belong to Super Users and that they have not blocked system emails.

Paramètres
null | string $email A list of Super Users to email
Renvoie
array The list of Super User emails
Depuis
3.5

Références $db, $enabled, $g, $groups, $query, $temp, et ParameterType\STRING.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • updatenotification.php


Joomla CMS: Référence de la classe PlgUserContactCreator

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgUserContactCreator
+ Graphe d'héritage de PlgUserContactCreator:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onUserAfterSave ($user, $isnew, $success, $msg)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

generateAliasAndName ($alias, $name, $categoryId)
getContactTable ()
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Class for Contact Creator

A tool to automatically create and synchronise contacts with a user

Depuis
1.6

Documentation des fonctions membres

◆ generateAliasAndName()

generateAliasAndName | ( | $alias,
 |  | $name,
 |  | $categoryId
 | ) |
protected

Method to change the name & alias if alias is already in use

Paramètres
string | $alias | The alias.
string | $name | The name.
integer | $categoryId | Category identifier
Renvoie
array Contains the modified title and alias.
Depuis
3.2.3

Références $name.

◆ getContactTable()

getContactTable ( )
protected

Get an instance of the contact table

Renvoie
ContactTable|null
Depuis
3.2.3

◆ onUserAfterSave()

onUserAfterSave | ( | $user,
 |  | $isnew,
 |  | $success,
 |  | $msg
 | ) |

Utility method to act on a user after it has been saved.

This method creates a contact for the saved user

Paramètres
array | $user | Holds the new user data.
boolean | $isnew | True if a new user is stored.
boolean | $success | True if user was successfully stored in the database.
string | $msg | Message.
Renvoie
void
Depuis
1.6

Try to pre-load a contact for this user. Apparently only possible if other plugin creates it Note: $user_id is cleaned above

Références $name, $user, et Text\_().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • contactcreator.php


Joomla CMS: Référence de la classe PlgUserJoomla

Fonctions membres publiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgUserJoomla
+ Graphe d'héritage de PlgUserJoomla:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm ($form, $data)
onUserAfterDelete ($user, $success, $msg)
onUserAfterSave ($user, $isnew, $success, $msg)
onUserLogin ($user, $options=[])
onUserLogout ($user, $options=[])
onUserAfterLogin (array $options)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres protégées

_getUser ($user, $options=[])
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Joomla User plugin

Depuis
1.5

Documentation des fonctions membres

◆ _getUser()

_getUser | ( | $user,
 |  | $options = []
 | ) |
protected

This method will return a user object

If options['autoregister'] is true, if the user doesn't exist yet they will be created

Paramètres
array | $user | Holds the user data.
array | $options | Array holding options (remember, autoregister, group).
Renvoie
User
Depuis
1.5

Références $id, $options, $params, $user, User\getInstance(), et ComponentHelper\getParams().

◆ onContentPrepareForm()

onContentPrepareForm | ( | $form,
 |  | $data
 | ) |

Set as required the passwords fields when mail to user is set to No

Paramètres
\Joomla\CMS\Form\Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
4.0.0

Références $data, $form, $name, et Factory\getApplication().

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

Remove all sessions for the user name

Method is called after user data is deleted from the database

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Depuis
1.6

Références $query, $user, et $userId.

◆ onUserAfterLogin()

onUserAfterLogin ( array $options )

Hooks on the Joomla! login event. Detects silent logins and disables the Multi-Factor Authentication page in this case.

Moreover, it will save the redirection URL and the Captive URL which is necessary in Joomla 4. You see, in Joomla 4 having unified sessions turned on makes the backend login redirect you to the frontend of the site AFTER logging in, something which would cause the Captive page to appear in the frontend and redirect you to the public frontend homepage after successfully passing the Two Step verification process.

Paramètres
array $options Passed by Joomla. user: a User object; responseType: string, authentication response type.
Renvoie
void
Depuis
4.2.0

Références $options.

◆ onUserAfterSave()

onUserAfterSave | ( | $user,
 |  | $isnew,
 |  | $success,
 |  | $msg
 | ) |

Utility method to act on a user after it has been saved.

This method sends a registration email to new users created in the backend.

Paramètres
array | $user | Holds the new user data.
boolean | $isnew | True if a new user is stored.
boolean | $success | True if user was successfully stored in the database.
string | $msg | Message.
Renvoie
void
Depuis
1.6

Look for user language. Priority:

  1. User frontend language
  2. User backend language

Références $data, $language, $user, class, Joomla\DI\getContainer(), et Factory\getLanguage().

◆ onUserLogin()

onUserLogin | ( | $user,
 |  | $options = []
 | ) |

This method should handle any login logic and report back to the subject

Paramètres
array | $user | Holds the user data
array | $options | Array holding options (remember, autoregister, group)
Renvoie
boolean True on success
Depuis
1.5

Références $options, $query, $result, $user, et true.

◆ onUserLogout()

onUserLogout | ( | $user,
 |  | $options = []
 | ) |

This method should handle any logout logic and report back to the subject

Paramètres
array | $user | Holds the user data.
array | $options | Array holding options (client, ...).
Renvoie
boolean True on success
Depuis
1.5

Références $clientId, $options, $this, $user, Joomla\Application\getSession(), Factory\getUser(), et null.

Documentation des champs

◆ $app

$app
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/user/joomla/joomla.php


Joomla CMS: Référence de la classe PlgUserProfile

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs protégés | Attributs privés
Référence de la classe PlgUserProfile
+ Graphe d'héritage de PlgUserProfile:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareData ($context, $data)
onContentPrepareForm (Form $form, $data)
onUserBeforeSave ($user, $isnew, $data)
onUserAfterSave ($data, $isNew, $result, $error)
onUserAfterDelete ($user, $success, $msg)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static | url ($value)
static | calendar ($value)
static | dob ($value)
static | tos ($value)

Attributs protégés

$app
$db
$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Attributs privés

$date = ''

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

An example custom profile plugin.

Depuis
1.6

Documentation des fonctions membres

◆ calendar()

static calendar ( $value )
static

Returns html markup showing a date picker

Paramètres
string $value valid date string
Renvoie
mixed

Références $value, et null.

◆ dob()

static dob ( $value )
static

Returns the date of birth formatted and calculated using server timezone.

Paramètres
string $value valid date string
Renvoie
mixed

Références $value, et Text\_().

◆ onContentPrepareData()

onContentPrepareData | ( | $context,
 |  | $data
 | ) |

Runs on content preparation

Paramètres
string | $context | The context for the data
object | $data | An object containing the data for the form.
Renvoie
boolean
Depuis
1.6

Références $context, $data, $db, $query, $results, $userId, ParameterType\INTEGER, et null.

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Adds additional fields to the user editing form

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
1.6

Références $field, $fields, $form, $name, __DIR__, et elseif.

◆ onUserAfterDelete()

onUserAfterDelete | ( | $user,
 |  | $success,
 |  | $msg
 | ) |

Remove all user profile information for the given user ID

Method is called after user data is deleted from the database

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void

Références $db, $query, $user, $userId, ArrayHelper\getValue(), et ParameterType\INTEGER.

◆ onUserAfterSave()

onUserAfterSave | ( | $data,
 |  | $isNew,
 |  | $result,
 |  | $error
 | ) |

Saves user profile data

Paramètres
array | $data | entered user data
boolean | $isNew | true if this is a new user
boolean | $result | true if saving the user worked
string | $error | error message
Renvoie
void

Références $data, $date, $db, $key, $query, $result, $userId, ArrayHelper\getValue(), ParameterType\INTEGER, et ParameterType\STRING.

◆ onUserBeforeSave()

onUserBeforeSave | ( | $user,
 |  | $isnew,
 |  | $data
 | ) |

Method is called before user data is stored in the database

Paramètres
array | $user | Holds the old user data.
boolean | $isnew | True if a new user is stored.
array | $data | Holds the new user data.
Renvoie
boolean
Depuis
3.1
Exceptions
InvalidArgumentException on invalid date.

Références $data, $date, $option, $task, Text\_(), et Date\getInstance().

◆ tos()

static tos ( $value )
static

Return the translated strings yes or no depending on the value

Paramètres
boolean $value input value
Renvoie
string

Références $value, et Text\_().

◆ url()

static url ( $value )
static

Returns an anchor tag generated from a given value

Paramètres
string $value URL to use
Renvoie
mixed|string

Références $value.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $date

$date = ''
private

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • profile.php


Joomla CMS: Référence de la classe PlgUserTerms

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgUserTerms
+ Graphe d'héritage de PlgUserTerms:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (Form $form, $data)
onUserBeforeSave ($user, $isNew, $data)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

An example custom terms and conditions plugin.

Depuis
3.9.0

Documentation des fonctions membres

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Adds additional fields to the user registration form

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Depuis
3.9.0

Références $form, $name, et __DIR__.

◆ onUserBeforeSave()

onUserBeforeSave | ( | $user,
 |  | $isNew,
 |  | $data
 | ) |

Method is called before user data is stored in the database

Paramètres
array | $user | Holds the old user data.
boolean | $isNew | True if a new user is stored.
array | $data | Holds the new user data.
Renvoie
boolean
Depuis
3.9.0
Exceptions
InvalidArgumentException on missing required data.

Références $form, $option, $task, $user, et $userId.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • terms.php


Joomla CMS: Référence de la classe PlgUserToken

Fonctions membres publiques | Attributs protégés | Fonctions membres privées | Attributs privés
Référence de la classe PlgUserToken
+ Graphe d'héritage de PlgUserToken:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareData (string $context, &$data)
onContentPrepareForm (Form $form, $data)
onUserAfterSave ($data, bool $isNew, bool $result, ?string $error)
onUserAfterDelete (array $user, bool $success, string $msg)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getDefaultProfileFieldValues ()
getTokenSeedForUser (int $userId)
getAllowedUserGroups ()
isInAllowedUserGroup ($userId)
getTokenForDisplay (int $userId, string $tokenSeed, string $algorithm='sha256')
getAlgorithmFromFormFile ()
hasTokenProfileFields (?int $userId)

Attributs privés

$allowedContexts
$profileKeyPrefix = 'joomlatoken'
$tokenLength = 32

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

An example custom terms and conditions plugin.

Depuis
3.9.0

Documentation des fonctions membres

◆ getAlgorithmFromFormFile()

getAlgorithmFromFormFile ( )
private

Get the token algorithm as defined in the form file

We use a simple RegEx match instead of loading the form for better performance.

Renvoie
string The configured algorithm, 'sha256' as a fallback if none is found.

Références __DIR__.

◆ getAllowedUserGroups()

getAllowedUserGroups ( )
private

Get the configured user groups which are allowed to have access to tokens.

Renvoie
int[]
Depuis
4.0.0

◆ getDefaultProfileFieldValues()

getDefaultProfileFieldValues ( )
private

Returns an array with the default profile field values.

This is used when saving the form data of a user (new or existing) without a token already set.

Renvoie
array
Depuis
4.0.0

Références Crypt\genRandomBytes().

◆ getTokenForDisplay()

getTokenForDisplay | ( | int | $userId,
 |  | string | $tokenSeed,
 |  | string | $algorithm = 'sha256'
 | ) |  |
private

Returns the token formatted suitably for the user to copy.

Paramètres
integer | $userId | The user id for token
string | $tokenSeed | The token seed data stored in the database
string | $algorithm | The hashing algorithm to use for the token (default: sha256)
Renvoie
string
Depuis
4.0.0

Références $message, et $userId.

◆ getTokenSeedForUser()

getTokenSeedForUser ( int $userId )
private

Retrieve the token seed string for the given user ID.

Paramètres
int $userId The numeric user ID to return the token seed string for.
Renvoie
string|null Null if there is no token configured or the user doesn't exist.
Depuis
4.0.0

Références $db, $query, $userId, ParameterType\INTEGER, null, et ParameterType\STRING.

◆ hasTokenProfileFields()

hasTokenProfileFields ( ?int $userId )
private

Does the user have the Joomla Token profile fields?

Paramètres
int | null $userId The user we're interested in
Renvoie
bool True if the user has Joomla Token profile fields

Références $db, et $userId.

◆ isInAllowedUserGroup()

isInAllowedUserGroup ( $userId )
private

Is the user with the given ID in the allowed User Groups with access to tokens?

Paramètres
int $userId The user ID to check
Renvoie
boolean False when doesn't belong to allowed user groups, user not found, or guest
Depuis
4.0.0

Références $groups, $user, et $userId.

◆ onContentPrepareData()

onContentPrepareData | ( | string | $context,
 |  | & | $data
 | ) |  |

Inject the Joomla token management panel's data into the User Profile.

This method is called whenever Joomla is preparing the data for an XML form for display.

Paramètres
string | $context | Form context, passed by Joomla
mixed | $data | Form data
Renvoie
boolean
Depuis
4.0.0

Modify the data for display in the user profile view page in the frontend.

It's important to note that we deliberately not register HTMLHelper methods to do the same (unlike e.g. the actionlogs system plugin) because the names of our fields are too generic and we run the risk of creating naming clashes. Instead, we manipulate the data directly.

Références $context, $data, et $userId.

◆ onContentPrepareForm()

onContentPrepareForm | ( | Form | $form,
 |  |  | $data
 | ) |  |

Runs whenever Joomla is preparing a form object.

Paramètres
Form | $form | The form to be altered.
mixed | $data | The associated data for the form.
Renvoie
boolean
Exceptions
Exception When $form is not a valid form object
Depuis
4.0.0

Références $data, $form, $userId, __DIR__, et if.

◆ onUserAfterDelete()

onUserAfterDelete | ( | array | $user,
 |  | bool | $success,
 |  | string | $msg
 | ) |  |

Remove the Joomla token when the user account is deleted from the database.

This event is called after the user data is deleted from the database.

Paramètres
array | $user | Holds the user data
boolean | $success | True if user was successfully stored in the database
string | $msg | Message
Renvoie
void
Exceptions
Exception
Depuis
4.0.0

Références $db, $query, $user, $userId, ParameterType\INTEGER, et ParameterType\STRING.

◆ onUserAfterSave()

onUserAfterSave | ( |  | $data,
 |  | bool | $isNew,
 |  | bool | $result,
 |  | ?string | $error
 | ) |  |

Save the Joomla token in the user profile field

Paramètres
mixed | $data | The incoming form data
bool | $isNew | Is this a new user?
bool | $result | Has Joomla successfully saved the user?
string | $error | Error string
Renvoie
void
Depuis
4.0.0

Is the user being saved programmatically, without passing the user profile information? In this case I do not want to accidentally try to generate a new token!

We determine that by examining whether the Joomla token field exists. If it does but it wasn't passed when saving the user I know it's a programmatic user save and I have to ignore it.

Références $data, $db, $default, $query, $result, $this, $userId, ParameterType\INTEGER, et ParameterType\STRING.

Documentation des champs

◆ $allowedContexts

$allowedContexts
private
Valeur initiale :
= [
'com_users.profile',
'com_users.user',
]

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected

◆ $profileKeyPrefix

$profileKeyPrefix = 'joomlatoken'
private

◆ $tokenLength

$tokenLength = 32
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/user/token/token.php


Joomla CMS: Référence de la classe PlgWebservicesBanners

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesBanners
+ Graphe d'héritage de PlgWebservicesBanners:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createContentHistoryRoutes (&$router)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_banners.

Depuis
4.0.0

Documentation des fonctions membres

◆ createContentHistoryRoutes()

createContentHistoryRoutes ( & $router )
private

Create contenthistory routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_banners's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/banners/banners.php


Joomla CMS: Référence de la classe PlgWebservicesConfig

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesConfig
+ Graphe d'héritage de PlgWebservicesConfig:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_config.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_config's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • config.php


Joomla CMS: Référence de la classe PlgWebservicesContact

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesContact
+ Graphe d'héritage de PlgWebservicesContact:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createFieldsRoutes (&$router)
createContentHistoryRoutes (&$router)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_contact.

Depuis
4.0.0

Documentation des fonctions membres

◆ createContentHistoryRoutes()

createContentHistoryRoutes ( & $router )
private

Create contenthistory routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ createFieldsRoutes()

createFieldsRoutes ( & $router )
private

Create fields routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_contact's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Références $route.

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/contact/contact.php


Joomla CMS: Référence de la classe PlgWebservicesContent

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesContent
+ Graphe d'héritage de PlgWebservicesContent:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createFieldsRoutes (&$router)
createContentHistoryRoutes (&$router)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_content.

Depuis
4.0.0

Documentation des fonctions membres

◆ createContentHistoryRoutes()

createContentHistoryRoutes ( & $router )
private

Create contenthistory routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ createFieldsRoutes()

createFieldsRoutes ( & $router )
private

Create fields routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_content's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/content/content.php


Joomla CMS: Référence de la classe PlgWebservicesInstaller

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesInstaller
+ Graphe d'héritage de PlgWebservicesInstaller:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_installer.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_installer's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/installer/installer.php


Joomla CMS: Référence de la classe PlgWebservicesLanguages

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesLanguages
+ Graphe d'héritage de PlgWebservicesLanguages:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createLanguageInstallerRoutes (&$router)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_languages.

Depuis
4.0.0

Documentation des fonctions membres

◆ createLanguageInstallerRoutes()

createLanguageInstallerRoutes ( & $router )
private

Create language installer routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_languages's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • languages.php


Joomla CMS: Référence de la classe PlgWebservicesMedia

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesMedia
+ Graphe d'héritage de PlgWebservicesMedia:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createAdapterReadRoutes (&$router, $baseName, $controller, $defaults=[], $publicGets=false)
createMediaCRUDRoutes (&$router, $baseName, $controller, $defaults=[], $publicGets=false)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_media.

Depuis
4.1.0

Documentation des fonctions membres

◆ createAdapterReadRoutes()

createAdapterReadRoutes | ( | & | $router,
 |  |  | $baseName,
 |  |  | $controller,
 |  |  | $defaults = [],
 |  |  | $publicGets = false
 | ) |  |
private

Creates adapter read routes.

Paramètres
ApiRouter | &$router | The API Routing object
string | $baseName | The base name of the component.
string | $controller | The name of the controller that contains CRUD functions.
array | $defaults | An array of default values that are used when the URL is matched.
bool | $publicGets | Allow the public to make GET requests.
Renvoie
void
Depuis
4.1.0

◆ createMediaCRUDRoutes()

createMediaCRUDRoutes | ( | & | $router,
 |  |  | $baseName,
 |  |  | $controller,
 |  |  | $defaults = [],
 |  |  | $publicGets = false
 | ) |  |
private

Creates media CRUD routes.

Paramètres
ApiRouter | &$router | The API Routing object
string | $baseName | The base name of the component.
string | $controller | The name of the controller that contains CRUD functions.
array | $defaults | An array of default values that are used when the URL is matched.
bool | $publicGets | Allow the public to make GET requests.
Renvoie
void
Depuis
4.1.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_media's API's routes in the application.

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.1.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/media/media.php


Joomla CMS: Référence de la classe PlgWebservicesMenus

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesMenus
+ Graphe d'héritage de PlgWebservicesMenus:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_menus.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_menus's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/menus/menus.php


Joomla CMS: Référence de la classe PlgWebservicesMessages

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesMessages
+ Graphe d'héritage de PlgWebservicesMessages:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_messages.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_messages's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • messages.php


Joomla CMS: Référence de la classe PlgWebservicesModules

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesModules
+ Graphe d'héritage de PlgWebservicesModules:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_modules.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_modules's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/modules/modules.php


Joomla CMS: Référence de la classe PlgWebservicesNewsfeeds

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesNewsfeeds
+ Graphe d'héritage de PlgWebservicesNewsfeeds:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_newsfeeds.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_newsfeeds's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/newsfeeds/newsfeeds.php


Joomla CMS: Référence de la classe PlgWebservicesPlugins

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesPlugins
+ Graphe d'héritage de PlgWebservicesPlugins:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_plugins.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_plugins's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/plugins/plugins.php


Joomla CMS: Référence de la classe PlgWebservicesPrivacy

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesPrivacy
+ Graphe d'héritage de PlgWebservicesPrivacy:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_privacy.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_privacy's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • privacy.php


Joomla CMS: Référence de la classe PlgWebservicesRedirect

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesRedirect
+ Graphe d'héritage de PlgWebservicesRedirect:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_redirect.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_redirect's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/redirect/redirect.php


Joomla CMS: Référence de la classe PlgWebservicesTags

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesTags
+ Graphe d'héritage de PlgWebservicesTags:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_tags.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_tags's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/tags/tags.php


Joomla CMS: Référence de la classe PlgWebservicesTemplates

Fonctions membres publiques | Attributs protégés
Référence de la classe PlgWebservicesTemplates
+ Graphe d'héritage de PlgWebservicesTemplates:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_templates.

Depuis
4.0.0

Documentation des fonctions membres

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_templates's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/templates/templates.php


Joomla CMS: Référence de la classe PlgWebservicesUsers

Fonctions membres publiques | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWebservicesUsers
+ Graphe d'héritage de PlgWebservicesUsers:
CMSPlugin DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onBeforeApiRoute (&$router)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Attributs protégés

$autoloadLanguage = true
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

createFieldsRoutes (&$router)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Description détaillée

Web Services adapter for com_users.

Depuis
4.0.0

Documentation des fonctions membres

◆ createFieldsRoutes()

createFieldsRoutes ( & $router )
private

Create fields routes

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

◆ onBeforeApiRoute()

onBeforeApiRoute ( & $router )

Registers com_users's API's routes in the application

Paramètres
ApiRouter &$router The API Routing object
Renvoie
void
Depuis
4.0.0

Documentation des champs

◆ $autoloadLanguage

$autoloadLanguage = true
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • plugins/webservices/users/users.php


Joomla CMS: Référence de la classe PlgWorkflowFeaturing

Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgWorkflowFeaturing
+ Graphe d'héritage de PlgWorkflowFeaturing:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (EventInterface $event)
onAfterDisplay (DisplayEvent $event)
onWorkflowBeforeTransition (WorkflowTransitionEvent $event)
onWorkflowAfterTransition (WorkflowTransitionEvent $event)
onContentBeforeChangeFeatured (FeatureEvent $event)
onContentVersioningPrepareTable (EventInterface $event)
onTableBeforeStore (BeforeStoreEvent $event)
onWorkflowFunctionalityUsed (WorkflowFunctionalityUsedEvent $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres protégées

enhanceItemForm (Form $form, $data)
isSupported ($context)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$app
$supportFunctionality = 'core.featured'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Workflow Featuring Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ enhanceItemForm()

enhanceItemForm | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Disable certain fields in the item form view, when we want to take over this function in the transition Check also for the workflow implementation and if the field exists

Paramètres
Form | $form | The form
stdClass | $data | The data
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $data, $form, $label, $option, $options, $parts, $text, $value, ENT_COMPAT, et null.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

◆ isSupported()

isSupported ( $context )
protected

Check if the current plugin should execute workflow related activities

Paramètres
string $context
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $model, $parts, TableInterface\hasField(), et Joomla\CMS\Workflow\supportFunctionality().

◆ onAfterDisplay()

onAfterDisplay ( DisplayEvent $event )

Manipulate the generic list view

Paramètres
DisplayEvent $event
Depuis
4.0.0

Références $app, $component, $section, et AbstractEvent\getArgument().

◆ onContentBeforeChangeFeatured()

onContentBeforeChangeFeatured ( FeatureEvent $event )

Change Feature State of an item. Used to disable Feature state change

Paramètres
FeatureEvent $event
Renvoie
boolean
Exceptions
Exception
Depuis
4.0.0

Références $extension, AbstractEvent\getArgument(), et FeatureEvent\setAbort().

◆ onContentPrepareForm()

onContentPrepareForm ( EventInterface $event )

The form event.

Paramètres
EventInterface $event The event
Depuis
4.0.0

Références $context, $data, $form, et EventInterface\getArgument().

◆ onContentVersioningPrepareTable()

onContentVersioningPrepareTable ( EventInterface $event )

We remove the featured field from the versioning

Paramètres
EventInterface $event
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $model, $parts, $subject, et EventInterface\getArgument().

◆ onTableBeforeStore()

onTableBeforeStore ( BeforeStoreEvent $event )

Pre-processor for $table->store($updateNulls)

Paramètres
BeforeStoreEvent $event The event to handle
Renvoie
void
Depuis
4.0.0

Références $component, $field, $model, $parts, $subject, et AbstractEvent\getArgument().

◆ onWorkflowAfterTransition()

onWorkflowAfterTransition ( WorkflowTransitionEvent $event )

Change Feature State of an item. Used to disable feature state change

Paramètres
WorkflowTransitionEvent $event
Renvoie
void
Depuis
4.0.0

Références $component, $context, $model, $options, $value, et AbstractEvent\getArgument().

◆ onWorkflowBeforeTransition()

onWorkflowBeforeTransition ( WorkflowTransitionEvent $event )

Check if we can execute the transition

Paramètres
WorkflowTransitionEvent $event
Renvoie
boolean
Depuis
4.0.0

Here it becomes tricky. We would like to use the component models featured method, so we will Execute the normal "onContentBeforeChangeFeatured" plugins. But they could cancel the execution, So we have to precheck and cancel the whole transition stuff if not allowed.

Références $context, $this, $value, AbstractEvent\getArgument(), et WorkflowTransitionEvent\setStopTransition().

◆ onWorkflowFunctionalityUsed()

onWorkflowFunctionalityUsed ( WorkflowFunctionalityUsedEvent $event )

If plugin supports the functionality we set the used variable

Paramètres
WorkflowFunctionalityUsedEvent $event
Depuis
4.0.0

Références AbstractEvent\getArgument(), et WorkflowFunctionalityUsedEvent\setUsed().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $supportFunctionality

$supportFunctionality = 'core.featured'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • featuring.php


Joomla CMS: Référence de la classe PlgWorkflowNotification

Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés | Fonctions membres privées
Référence de la classe PlgWorkflowNotification
+ Graphe d'héritage de PlgWorkflowNotification:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (EventInterface $event)
onWorkflowAfterTransition (WorkflowTransitionEvent $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres protégées

isSupported ($context)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$app
$db
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Fonctions membres privées

getUsersFromGroup ($data)
removeLocked (array $userIds)

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Workflow Notification Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

◆ getUsersFromGroup()

getUsersFromGroup ( $data )
private

Get user_ids of receivers

Paramètres
object $data Object containing data about the transition
Renvoie
array $userIds The receivers
Depuis
4.0.0

Références $data, $groups, et $model.

◆ isSupported()

isSupported ( $context )
protected

Check if the current plugin should execute workflow related activities

Paramètres
string $context
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, et $parts.

◆ onContentPrepareForm()

onContentPrepareForm ( EventInterface $event )

The form event.

Paramètres
Form | $form | The form
stdClass | $data | The data
Renvoie
boolean
Depuis
4.0.0

Références $context, $data, $form, et EventInterface\getArgument().

◆ onWorkflowAfterTransition()

onWorkflowAfterTransition ( WorkflowTransitionEvent $event )

Send a Notification to defined users a transition is performed

Paramètres
string | $context | The context for the content passed to the plugin.
array | $pks | A list of primary key ids of the content that has changed stage.
object | $data | Object containing data about the transition
Renvoie
boolean
Depuis
4.0.0

Références $component, $container, $context, $item, $key, $lang, $message, $model, $title, $user, class, AbstractEvent\getArgument(), et Joomla\DI\getContainer().

◆ removeLocked()

removeLocked ( array $userIds )
private

Remove receivers who have locked their message inputbox

Paramètres
array $userIds The userIds which must be checked
Renvoie
array users with active message input box
Depuis
4.0.0

Références $query.

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $db

$db
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • notification.php


Joomla CMS: Référence de la classe PlgWorkflowPublishing

Fonctions membres publiques | Fonctions membres publiques statiques | Fonctions membres protégées | Attributs protégés
Référence de la classe PlgWorkflowPublishing
+ Graphe d'héritage de PlgWorkflowPublishing:
CMSPlugin SubscriberInterface DispatcherAwareInterface PluginInterface DispatcherAwareInterface

Fonctions membres publiques

onContentPrepareForm (EventInterface $event)
onAfterDisplay (DisplayEvent $event)
onWorkflowBeforeTransition (WorkflowTransitionEvent $event)
onWorkflowAfterTransition (WorkflowTransitionEvent $event)
onContentBeforeChangeState (EventInterface $event)
onContentVersioningPrepareTable (EventInterface $event)
onTableBeforeStore (BeforeStoreEvent $event)
onWorkflowFunctionalityUsed (WorkflowFunctionalityUsedEvent $event)
- Fonctions membres publiques hérités de CMSPlugin
__construct (&$subject, $config=array())
loadLanguage ($extension='', $basePath=JPATH_ADMINISTRATOR)
setApplication (CMSApplicationInterface $application)
- Fonctions membres publiques hérités de DispatcherAwareInterface
setDispatcher (DispatcherInterface $dispatcher)
- Fonctions membres publiques hérités de PluginInterface
registerListeners ()

Fonctions membres publiques statiques

static getSubscribedEvents ()

Fonctions membres protégées

enhanceTransitionForm (Form $form, $data)
enhanceItemForm (Form $form, $data)
isSupported ($context)
- Fonctions membres protégées hérités de CMSPlugin
registerLegacyListener (string $methodName)
registerListener (string $methodName)
getApplication ()

Attributs protégés

$autoloadLanguage = true
$app
$supportFunctionality = 'core.state'
- Attributs protégés hérités de CMSPlugin
$_name = null
$_type = null
$autoloadLanguage = false
$allowLegacyListeners = true

Membres hérités additionnels

- Champs de données hérités de CMSPlugin
$params = null

Description détaillée

Workflow Publishing Plugin

Depuis
4.0.0

Documentation des fonctions membres

◆ enhanceItemForm()

enhanceItemForm | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Disable certain fields in the item form view, when we want to take over this function in the transition Check also for the workflow implementation and if the field exists

Paramètres
Form | $form | The form
stdClass | $data | The data
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $data, $form, $label, $option, $options, $parts, $text, $value, ENT_COMPAT, null, et Text\sprintf().

◆ enhanceTransitionForm()

enhanceTransitionForm | ( | Form | $form,
 |  |  | $data
 | ) |  |
protected

Add different parameter options to the transition view, we need when executing the transition

Paramètres
Form | $form | The form
stdClass | $data | The data
Renvoie
boolean
Depuis
4.0.0

Références $data, $form, et Joomla\CMS\MVC\Model\$workflow.

◆ getSubscribedEvents()

static getSubscribedEvents ( )
static

Returns an array of events this subscriber will listen to.

Renvoie
array
Depuis
4.0.0

Implémente SubscriberInterface.

◆ isSupported()

isSupported ( $context )
protected

Check if the current plugin should execute workflow related activities

Paramètres
string $context
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $model, $parts, TableInterface\hasField(), et Joomla\CMS\Workflow\supportFunctionality().

◆ onAfterDisplay()

onAfterDisplay ( DisplayEvent $event )

Manipulate the generic list view

Paramètres
DisplayEvent $event
Depuis
4.0.0

Références $app, $component, $section, Factory\getApplication(), et AbstractEvent\getArgument().

◆ onContentBeforeChangeState()

onContentBeforeChangeState ( EventInterface $event )

Change State of an item. Used to disable state change

Paramètres
EventInterface $event
Renvoie
boolean
Exceptions
Exception
Depuis
4.0.0

Références $context, Text\_(), et EventInterface\getArgument().

◆ onContentPrepareForm()

onContentPrepareForm ( EventInterface $event )

The form event.

Paramètres
EventInterface $event The event
Depuis
4.0.0

Références $context, $data, $form, et EventInterface\getArgument().

◆ onContentVersioningPrepareTable()

onContentVersioningPrepareTable ( EventInterface $event )

We remove the publishing field from the versioning

Paramètres
EventInterface $event
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $model, $parts, $subject, et EventInterface\getArgument().

◆ onTableBeforeStore()

onTableBeforeStore ( BeforeStoreEvent $event )

Pre-processor for $table->store($updateNulls)

Paramètres
BeforeStoreEvent $event The event to handle
Renvoie
void
Depuis
4.0.0

Références $component, $field, $model, $parts, $subject, et AbstractEvent\getArgument().

◆ onWorkflowAfterTransition()

onWorkflowAfterTransition ( WorkflowTransitionEvent $event )

Change State of an item. Used to disable state change

Paramètres
WorkflowTransitionEvent $event
Renvoie
boolean
Depuis
4.0.0

Références $component, $context, $model, $options, $value, et AbstractEvent\getArgument().

◆ onWorkflowBeforeTransition()

onWorkflowBeforeTransition ( WorkflowTransitionEvent $event )

Check if we can execute the transition

Paramètres
WorkflowTransitionEvent $event
Renvoie
boolean
Depuis
4.0.0

Here it becomes tricky. We would like to use the component models publish method, so we will Execute the normal "onContentBeforeChangeState" plugins. But they could cancel the execution, So we have to precheck and cancel the whole transition stuff if not allowed.

Références $context, $result, $value, AbstractEvent\getArgument(), et WorkflowTransitionEvent\setStopTransition().

◆ onWorkflowFunctionalityUsed()

onWorkflowFunctionalityUsed ( WorkflowFunctionalityUsedEvent $event )

If plugin supports the functionality we set the used variable

Paramètres
WorkflowFunctionalityUsedEvent $event
Depuis
4.0.0

Références AbstractEvent\getArgument(), et WorkflowFunctionalityUsedEvent\setUsed().

Documentation des champs

◆ $app

$app
protected

◆ $autoloadLanguage

$autoloadLanguage = true
protected

◆ $supportFunctionality

$supportFunctionality = 'core.state'
protected
La documentation de cette classe a été générée à partir du fichier suivant :
  • publishing.php


Joomla CMS: Référence de la classe PluginsHelper

Référence de la classe PluginsHelper
+ Graphe d'héritage de PluginsHelper:
PluginsHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de PluginsHelper
parseXMLTemplateFile ($templateBaseDir, $templateDir)
- Fonctions membres publiques statiques hérités de PluginsHelper
static | publishedOptions ()
static | folderOptions ()
static | elementOptions ()
- Attributs publics statiques hérités de PluginsHelper
static | $extension = 'com_plugins'

Description détaillée

Plugins component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_plugins/helpers/plugins.php


Joomla CMS: Référence de la classe RedirectHelper

Référence de la classe RedirectHelper
+ Graphe d'héritage de RedirectHelper:
RedirectHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de RedirectHelper
static | publishedOptions ()
static | getRedirectPluginId ()
static | collectUrlsEnabled ()
- Attributs publics statiques hérités de RedirectHelper
static | $extension = 'com_redirect'

Description détaillée

Redirect component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_redirect/helpers/redirect.php


Joomla CMS: Référence de la classe ServiceProviderInterface

Fonctions membres publiques | Fonctions membres privées
Référence de la classe ServiceProviderInterface

Fonctions membres publiques

register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)
register (Container $container)

Fonctions membres privées

getSession (ApplicationInterface $app)

Description détaillée

The actionlogs service provider.

Depuis
4.0.0

The admin service provider.

Depuis
4.0.0

The associations service provider.

Depuis
4.0.0

The banners service provider.

Depuis
4.0.0

The cache service provider.

Depuis
4.0.0

The categories service provider.

Depuis
4.0.0

The checkin service provider.

Depuis
4.0.0

The config service provider.

Depuis
4.0.0

The contact service provider.

Depuis
4.0.0

The content service provider.

Depuis
4.0.0

The content history service provider.

Depuis
4.0.0

The cpanel service provider.

Depuis
4.0.0

The fields service provider.

Depuis
4.0.0

The finder service provider.

Depuis
4.0.0

The installer service provider.

Depuis
4.0.0

The language service provider.

Depuis
4.0.0

The login service provider.

Depuis
4.0.0

The media service provider.

Depuis
4.0.0

The menus service provider.

Depuis
4.0.0

The messages service provider.

Depuis
4.0.0

The module service provider.

Depuis
4.0.0

The newsfeed service provider.

Depuis
4.0.0

The plugin service provider.

Depuis
4.0.0

The postinstall service provider.

Depuis
4.0.0

The privacy component service provider.

Depuis
4.0.0

The redirect service provider.

Depuis
4.0.0

The com_scheduler service provider. Returns an instance of the Component's Service Provider Interface used to register the components initializers into a DI container created by the application.

Depuis
4.1.0

The tags service provider.

Depuis
4.0.0

The templates service provider.

Depuis
4.0.0

The users service provider.

Depuis
4.0.0

The workflow service provider.

Depuis
4.0.0

The wrapper service provider.

Depuis
4.0.0

The quickicon module service provider.

Depuis
4.0.0

The article latest module service provider.

Depuis
4.2.0

The article news module service provider.

Depuis
4.2.0

Documentation des fonctions membres

◆ getSession()

getSession ( ApplicationInterface $app )
private

Get the current application session object

Paramètres
ApplicationInterface $app The application we are running in
Renvoie
|null
Depuis
4.2.0

Références $app, et null.

◆ register() [1/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $config, $container, $subject, et class.

◆ register() [2/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, et class.

◆ register() [3/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $container, class, et PluginHelper\getPlugin().

◆ register() [4/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $config, $container, $subject, et class.

◆ register() [5/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $config, $container, $subject, et class.

◆ register() [6/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $config, $container, $subject, et class.

◆ register() [7/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $config, $container, $subject, et class.

◆ register() [8/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, et class.

◆ register() [9/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, JPATH_ROOT, et CMSPlugin\setApplication().

◆ register() [10/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, et class.

◆ register() [11/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, et class.

◆ register() [12/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, JDEBUG, et null.

◆ register() [13/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, JPATH_ROOT, et CMSPlugin\setApplication().

◆ register() [14/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, JPATH_CONFIGURATION, et CMSPlugin\setApplication().

◆ register() [15/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, et CMSPlugin\setApplication().

◆ register() [16/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, et class.

◆ register() [17/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $container.

◆ register() [18/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container.

◆ register() [19/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container.

◆ register() [20/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $container, class, et CMSPlugin\setApplication().

◆ register() [21/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [22/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [23/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [24/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [25/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [26/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [27/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [28/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [29/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [30/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [31/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [32/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [33/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [34/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.2.0

Références $app, $config, $container, $db, $params, $subject, class, Container\get(), Joomla\Application\getSession(), et null.

◆ register() [35/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [36/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [37/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [38/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [39/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [40/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [41/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [42/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [43/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [44/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [45/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [46/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [47/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [48/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [49/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [50/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [51/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.1.0

Register the MVCFactory and ComponentDispatcherFactory providers to map 'MVCFactoryInterface' and 'ComponentDispatcherFactoryInterface' to their initializers and register them with the component's DI container.

Références $component, $container, et class.

◆ register() [52/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [53/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [54/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

◆ register() [55/55]

register ( Container $container )

Registers the service provider with a DI container.

Paramètres
Container $container The DI container.
Renvoie
void
Depuis
4.0.0

Références $component, $container, et class.

La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_actionlogs/services/provider.php


Joomla CMS: Référence de la classe SplFixedArray

Fonctions membres publiques | Fonctions membres publiques statiques | Attributs privés
Référence de la classe SplFixedArray
+ Graphe d'héritage de SplFixedArray:

Fonctions membres publiques

__construct ($size=0)
count ()
toArray ()
getSize ()
setSize ($size)
offsetExists ($index)
offsetGet ($index)
offsetSet ($index, $newval)
offsetUnset ($index)
rewind ()
current ()
key ()
next ()
valid ()
__wakeup ()

Fonctions membres publiques statiques

static fromArray (array $array, $save_indexes=true)

Attributs privés

$internalArray = array()
$size = 0

Description détaillée

The SplFixedArray class provides the main functionalities of array. The main differences between a SplFixedArray and a normal PHP array is that the SplFixedArray is of fixed length and allows only integers within the range as indexes. The advantage is that it allows a faster array implementation.

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( $size = 0 )

SplFixedArray constructor.

Paramètres
int $size

Références $size.

Documentation des fonctions membres

◆ __wakeup()

__wakeup ( )

Do nothing.

◆ count()

count ( )
Renvoie
int

Référencé par fromArray().

◆ current()

current ( )

Return current array entry mixed The current element value. 5.3.0

-suppress MixedReturnStatement

◆ fromArray()

static fromArray | ( | array | $array,
 |  |  | $save_indexes = true
 | ) |  |
static
Paramètres
array | $array
bool | $save_indexes
Renvoie
SplFixedArray -suppress MixedAssignment

Références $i, $key, $self, $value, et count().

Référencé par ParagonIE_Sodium_Core_BLAKE2b\stringToContext(), ParagonIE_Sodium_Core32_BLAKE2b\stringToSplFixedArray(), et ParagonIE_Sodium_Core_BLAKE2b\stringToSplFixedArray().

◆ getSize()

getSize ( )
Renvoie
int

Références $size.

Référencé par ParagonIE_Sodium_Core_BLAKE2b\finish(), et ParagonIE_Sodium_Core32_BLAKE2b\store64().

◆ key()

key ( )

Return current array index

Renvoie
int The current array index.

◆ next()

next ( )
Renvoie
void

Référencé par valid().

◆ offsetExists()

offsetExists ( $index )
Paramètres
string | int $index
Renvoie
bool

◆ offsetGet()

offsetGet ( $index )
Paramètres
string | int $index
Renvoie
mixed

-suppress MixedReturnStatement

◆ offsetSet()

offsetSet | ( | $index,
 |  | $newval
 | ) |
Paramètres
string | int | $index
mixed | $newval | -suppress MixedAssignment

◆ offsetUnset()

offsetUnset ( $index )
Paramètres
string | int $index

◆ rewind()

rewind ( )

Rewind iterator back to the start void 5.3.0

◆ setSize()

setSize ( $size )
Paramètres
int $size
Renvoie
bool

Références $size.

◆ toArray()

toArray ( )
Renvoie
array

Références $internalArray.

◆ valid()

valid ( )

Check whether the array contains more elements bool true if the array contains any more elements, false otherwise.

Références $result, et next().

Documentation des champs

◆ $internalArray

$internalArray = array()
private

Référencé par toArray().

◆ $size

$size = 0
private

Référencé par __construct(), getSize(), et setSize().

La documentation de cette classe a été générée à partir du fichier suivant :
  • SplFixedArray.php


Joomla CMS: Référence de la classe TagsHelperRoute

Référence de la classe TagsHelperRoute
+ Graphe d'héritage de TagsHelperRoute:
RouteHelper RouteHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de RouteHelper
getRoute ($id, $typealias, $link='', $language=null, $catid=null)
- Fonctions membres publiques statiques hérités de RouteHelper
static | getItemRoute ($contentItemId, $contentItemAlias, $contentCatId, $language, $typeAlias, $routerName)
static | getTagRoute ($id)
static | getComponentTagRoute (string $id, string $language=' *')
static | getTagsRoute ()
static | getComponentTagsRoute (string $language=' *')
- Fonctions membres publiques statiques hérités de RouteHelper
static | getCategoryRoute ($catid, $language=0, $extension='')
- Fonctions membres protégées hérités de RouteHelper
findItem ($needles=array())
- Fonctions membres protégées statiques hérités de RouteHelper
static | _findItem ($needles=null)
- Fonctions membres protégées statiques hérités de RouteHelper
static | lookupItem ($needles=array())
- Attributs protégés hérités de RouteHelper
$extension
$id
$view
- Attributs protégés statiques hérités de RouteHelper
static | $lookup
- Attributs protégés statiques hérités de RouteHelper
static | $lookup

Description détaillée

Tags Component Route Helper.

Depuis
3.1
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • com_tags/helpers/route.php


Joomla CMS: Référence de la classe TemplateHelper

Référence de la classe TemplateHelper
+ Graphe d'héritage de TemplateHelper:
TemplateHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de TemplateHelper
static | getTypeIcon ($fileName)
static | canUpload ($file, $err='')

Description détaillée

Template Helper class.

Depuis
3.2
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • template.php


Joomla CMS: Référence de la classe TemplatesHelper

Référence de la classe TemplatesHelper
+ Graphe d'héritage de TemplatesHelper:
TemplatesHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de TemplatesHelper
static | getClientOptions ()
static | getTemplateOptions ($clientId=' *')
static | parseXMLTemplateFile ($templateBaseDir, $templateDir)
static | getPositions ($clientId, $templateDir)

Description détaillée

Templates component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_templates/helpers/templates.php


Joomla CMS: Référence de la classe UsersHelper

Référence de la classe UsersHelper
+ Graphe d'héritage de UsersHelper:
UsersHelper ContentHelper

Membres hérités additionnels

- Fonctions membres publiques hérités de ContentHelper
getRowData (Table $table)
- Fonctions membres publiques statiques hérités de UsersHelper
static | getStateOptions ()
static | getActiveOptions ()
static | getGroups ()
static | getRangeOptions ()
static | getTwoFactorMethods ()
static | getVisibleByGroups ($rules)
static | validateSection ($section)
static | getContexts ()
- Fonctions membres publiques statiques hérités de ContentHelper
static | addSubmenu ($vName)
static | countRelations (&$items, $config)
static | getActions ($component='', $section='', $id=0)
static | getCurrentLanguage ($detectBrowser=true)
static | getLanguageId ($langCode)
- Attributs protégés statiques hérités de UsersHelper
static | $actions

Description détaillée

Users component helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/helpers/users.php


Joomla CMS: Référence de la classe UsersHelperDebug

Référence de la classe UsersHelperDebug
+ Graphe d'héritage de UsersHelperDebug:
DebugHelper

Membres hérités additionnels

- Fonctions membres publiques statiques hérités de DebugHelper
static | getComponents ()
static | getDebugActions ($component=null)
static | getLevelsOptions ()

Description détaillée

Users component debugging helper.

Depuis
1.6
Obsolète:
5.0 Use instead
La documentation de cette classe a été générée à partir du fichier suivant :
  • administrator/components/com_users/helpers/debug.php


Joomla CMS: Référence de la classe ZIPExtraction

Fonctions membres publiques | Fonctions membres publiques statiques | Champs de données | Fonctions membres privées | Attributs privés | Attributs privés statiques
Référence de la classe ZIPExtraction

Fonctions membres publiques

__construct ()
__wakeup ()
enforceMinimumExecutionTime ()
setFilename (string $value)
setAddPath (string $addPath)
setSkipFiles (array $skipFiles)
setIgnoreDirectories (array $ignoreDirectories)
initialize ()
step ()
getError ()

Fonctions membres publiques statiques

static | getInstance ()
static | getSerialised ()
static | unserialiseInstance (string $serialised)

Champs de données

$totalSize = 0
$skipFiles = []
$compressedTotal = 0
$uncompressedTotal = 0
$filesProcessed = 0

Fonctions membres privées

getTimeLeft ()
getRunningTime ()
processLastExtractedFile ()
setLastExtractedFilename (?string $lastExtractedFilename)
setLastExtractedFileTimestamp (int $lastExtractedFileTimestamp)
shutdown ()
binStringLength (?string $string)
setError (string $error)
fread ($fp, ?int $length=null)
readArchiveHeader ()
readFileHeader ()
createDirectory ()
processFileData ()
openArchiveFile ()
isEOF ()
setCorrectPermissions (string $path)
isIgnoredDirectory (string $shortFilename)
processTypeDir ()
processTypeLink ()
processTypeFileUncompressed ()
processTypeFileCompressed ()
setupMaxExecTime ()
getPhpMaxExecTime ()
debugMsg (string $message, int $priority=self::LOG_INFO)
initializeLog (string $logPath)

Attributs privés

const | CHUNK_SIZE = 524288
const | MAX_EXEC_TIME = 4
const | RUNTIME_BIAS = 90
const | MIN_EXEC_TIME = 3
const | AK_STATE_INITIALIZE = -1
const | AK_STATE_NOFILE = 0
const | AK_STATE_HEADER = 1
const | AK_STATE_DATA = 2
const | AK_STATE_DATAREAD = 3
const | AK_STATE_POSTPROC = 4
const | AK_STATE_DONE = 5
const | AK_STATE_FINISHED = 999
const | LOG_DEBUG = 1
const | LOG_INFO = 10
const | LOG_WARNING = 50
const | LOG_ERROR = 90
$maxExecTime = null
$startTime
$lastErrorMessage = null
$filename = null
$archiveFileIsBeingRead = false
$currentOffset = 0
$addPath = ''
$fp = null
$runState = self::AK_STATE_INITIALIZE
$fileHeader = null
$dataReadLength = 0
$ignoreDirectories = []
$expectDataDescriptor = false
$lastExtractedFileTimestamp = 0
$lastExtractedFilename = null

Attributs privés statiques

static | $instance = null
static | $logFP = null
static | $logFilePath = null

Description détaillée

ZIP archive extraction class

This is a derivative work of Akeeba Restore which is Copyright (c)2008-2021 Nicholas K. Dionysopoulos and Akeeba Ltd, distributed under the terms of GNU General Public License version 3 or later.

The author of the original work has decided to relicense the derivative work under the terms of the GNU General Public License version 2 or later and share the copyright of the derivative work with Open Source Matters, Inc (OSM), granting OSM non-exclusive rights to this work per the terms of the Joomla Contributor Agreement (JCA) the author signed back in 2011 and which is still in effect. This is affirmed by the cryptographically signed commits in the Git repository containing this file, the copyright messages and this notice here.

Depuis
4.0.4

Documentation des constructeurs et destructeur

◆ __construct()

__construct ( )

Public constructor.

Sets up the internal timer.

Depuis
4.0.4

Références setupMaxExecTime().

Documentation des fonctions membres

◆ __wakeup()

__wakeup ( )

Wakeup function, called whenever the class is deserialized.

This method does the following:

  • Restart the timer.
  • Reopen the archive file, if one is defined.
  • Seek to the correct offset of the file.
Renvoie
void
Depuis
4.0.4

◆ binStringLength()

binStringLength ( ?string $string )
private

Unicode-safe binary data length

Paramètres
string | null $string The binary data to get the length for
Renvoie
integer
Depuis
4.0.4

Référencé par processTypeFileCompressed(), processTypeFileUncompressed(), et processTypeLink().

◆ createDirectory()

createDirectory ( )
private

Creates the directory this file points to

Renvoie
void
Depuis
4.0.4

Références isIgnoredDirectory(), et setError().

Référencé par readFileHeader().

◆ debugMsg()

debugMsg | ( | string | $message,
 |  | int | $priority = self::LOG_INFO
 | ) |  |
private

Write a message to the debug error log

Paramètres
string | $message | The message to log
int | $priority | The message's log priority
Renvoie
void
Depuis
4.0.4

Références $message.

Référencé par fread(), initialize(), openArchiveFile(), processFileData(), processLastExtractedFile(), processTypeFileCompressed(), processTypeFileUncompressed(), processTypeLink(), readArchiveHeader(), readFileHeader(), et step().

◆ enforceMinimumExecutionTime()

enforceMinimumExecutionTime ( )

Enforce the minimum execution time.

Renvoie
void
Depuis
4.0.4

If we need to sleep for more than 1 second we should be using sleep() or time_sleep_until() to prevent high CPU usage, also because some OS might not support sleeping for over 1 second using these functions. In all other cases we will try to use usleep or time_nanosleep instead.

Références getPhpMaxExecTime(), et getRunningTime().

◆ fread()

fread | ( |  | $fp,
 |  | ?int | $length = null
 | ) |  |
private

Reads data from the archive.

Paramètres
resource | $fp | The file pointer to read data from
int | null | $length | The volume of data to read, in bytes
Renvoie
string The data read from the file
Depuis
4.0.4

Références $data, $fp, et debugMsg().

Référencé par processTypeFileCompressed(), processTypeFileUncompressed(), processTypeLink(), readArchiveHeader(), et readFileHeader().

◆ getError()

getError ( )

Get the most recent error message

Renvoie
string|null The message string, null if there's no error
Depuis
4.0.4

Références $lastErrorMessage.

Référencé par initialize(), et step().

◆ getInstance()

static getInstance ( )
static

Singleton implementation.

Renvoie
static
Depuis
4.0.4

◆ getPhpMaxExecTime()

getPhpMaxExecTime ( )
private

Get the PHP maximum execution time.

If it's not defined or it's zero (infinite) we use a fake value of 10 seconds.

Renvoie
integer
Depuis
4.0.4

Référencé par enforceMinimumExecutionTime(), et setupMaxExecTime().

◆ getRunningTime()

getRunningTime ( )
private

Gets the time elapsed since object creation/unserialization, effectively how long Akeeba Engine has been processing data

Renvoie
float
Depuis
4.0.4

Références $startTime.

Référencé par enforceMinimumExecutionTime(), et getTimeLeft().

◆ getSerialised()

static getSerialised ( )
static

Returns a serialised copy of the object.

This is different to calling serialise() directly. This operates on a copy of the object which undergoes a call to shutdown() first so any open files are closed first.

Renvoie
string The serialised data, potentially base64 encoded.
Depuis
4.0.4

◆ getTimeLeft()

getTimeLeft ( )
private

Gets the number of seconds left, before we hit the "must break" threshold

Renvoie
float
Depuis
4.0.4

Références getRunningTime().

Référencé par processTypeFileUncompressed(), et step().

◆ initialize()

initialize ( )

Prepares for the archive extraction

Renvoie
void
Depuis
4.0.4

Références debugMsg(), getError(), et readArchiveHeader().

Référencé par step().

◆ initializeLog()

initializeLog ( string $logPath )
private

Initialise the debug log file

Paramètres
string $logPath The path where the log file will be written to
Renvoie
void
Depuis
4.0.4

Référencé par setFilename().

◆ isEOF()

isEOF ( )
private

Returns true if we have reached the end of file

Renvoie
boolean True if we have reached End Of File
Depuis
4.0.4

feof() will return false if the file pointer is exactly at the last byte of the file. However, this is a condition we want to treat as a proper EOF for the purpose of extracting a ZIP file. Hence the second part after the logical OR.

Référencé par processTypeFileCompressed(), processTypeFileUncompressed(), processTypeLink(), et readFileHeader().

◆ isIgnoredDirectory()

isIgnoredDirectory ( string $shortFilename )
private

Is this file or directory contained in a directory we've decided to ignore write errors for? This is useful to let the extraction work despite write errors in the log, logs and tmp directories which MIGHT be used by the system on some low quality hosts and Plesk-powered hosts.

Paramètres
string $shortFilename The relative path of the file/directory in the package
Renvoie
boolean True if it belongs in an ignored directory
Depuis
4.0.4

Références $check.

Référencé par createDirectory(), processTypeFileCompressed(), et processTypeFileUncompressed().

◆ openArchiveFile()

openArchiveFile ( )
private

Opens the next part file for reading

Renvoie
void
Depuis
4.0.4

Références $message, debugMsg(), et setError().

Référencé par readArchiveHeader().

◆ processFileData()

processFileData ( )
private

Concrete classes must use this method to process file data. It must set $runState to self::AK_STATE_DATAREAD when it's finished processing the file data.

Renvoie
boolean True if processing the file data was successful, false if an error occurred
Depuis
4.0.4

Références debugMsg(), processTypeDir(), processTypeFileCompressed(), processTypeFileUncompressed(), processTypeLink(), et setError().

Référencé par step().

◆ processLastExtractedFile()

processLastExtractedFile ( )
private

Process the last extracted file or directory

This invalidates OPcache for .php files. Also applies the correct permissions and timestamp.

Renvoie
void
Depuis
4.0.4

Références clearFileInOPCache(), et debugMsg().

Référencé par step().

◆ processTypeDir()

processTypeDir ( )
private

Process the file data of a directory entry

Renvoie
boolean
Depuis
4.0.4

Référencé par processFileData().

◆ processTypeFileCompressed()

processTypeFileCompressed ( )
private

Processes a compressed file

Renvoie
boolean
Depuis
4.0.4

PhpComposerExtensionStubsInspection
PhpComposerExtensionStubsInspection

Références binStringLength(), debugMsg(), fread(), isEOF(), isIgnoredDirectory(), setCorrectPermissions(), et setError().

Référencé par processFileData().

◆ processTypeFileUncompressed()

processTypeFileUncompressed ( )
private

Processes an uncompressed (stored) file

Renvoie
boolean
Depuis
4.0.4

Références $data, $dataReadLength, binStringLength(), debugMsg(), fread(), getTimeLeft(), isEOF(), isIgnoredDirectory(), setCorrectPermissions(), et setError().

Référencé par processFileData().

◆ processTypeLink()

processTypeLink ( )
private

Process the file data of a link entry

Renvoie
boolean
Depuis
4.0.4

Références $data, $filename, binStringLength(), clearFileInOPCache(), debugMsg(), fread(), isEOF(), et setError().

Référencé par processFileData().

◆ readArchiveHeader()

readArchiveHeader ( )
private

Read the header of the archive, making sure it's a valid ZIP file.

Renvoie
void
Depuis
4.0.4

Références debugMsg(), fread(), openArchiveFile(), et setError().

Référencé par initialize().

◆ readFileHeader()

readFileHeader ( )
private

Concrete classes must use this method to read the file header

Renvoie
boolean True if reading the file was successful, false if an error occurred or we reached end of archive.
Depuis
4.0.4

The last file had bit 3 of the general purpose bit flag set. This means that we have a 12 byte data descriptor we need to skip. To make things worse, there might also be a 4 byte optional data descriptor header (0x08074b50).

Références $dir, $format, $this, createDirectory(), debugMsg(), elseif, fread(), isEOF(), null, setError(), et setLastExtractedFilename().

Référencé par step().

◆ setAddPath()

setAddPath ( string $addPath )

Sets the path to prefix all extracted files with. Essentially, where the archive will be extracted to.

Paramètres
string $addPath The path where the archive will be extracted.
Renvoie
void
Depuis
4.0.4

Références $addPath.

◆ setCorrectPermissions()

setCorrectPermissions ( string $path )
private

Handles the permissions of the parent directory to a file and the file itself to make it writeable.

Paramètres
string $path A path to a file
Renvoie
void
Depuis
4.0.4

Références $path, et null.

Référencé par processTypeFileCompressed(), et processTypeFileUncompressed().

◆ setError()

setError ( string $error )
private

Add an error message

Paramètres
string $error Error message
Renvoie
void
Depuis
4.0.4

Référencé par createDirectory(), openArchiveFile(), processFileData(), processTypeFileCompressed(), processTypeFileUncompressed(), processTypeLink(), readArchiveHeader(), readFileHeader(), et setFilename().

◆ setFilename()

setFilename ( string $value )

Set the filepath to the ZIP archive which will be extracted.

Paramètres
string $value The filepath to the archive. Only LOCAL files are allowed!
Renvoie
void
Depuis
4.0.4

Références $value, initializeLog(), et setError().

◆ setIgnoreDirectories()

setIgnoreDirectories ( array $ignoreDirectories )

Set the directories to skip over when extracting the ZIP archive

Paramètres
array $ignoreDirectories The list of directories to ignore.
Renvoie
void
Depuis
4.0.4

Références $ignoreDirectories.

◆ setLastExtractedFilename()

setLastExtractedFilename ( ?string $lastExtractedFilename )
private

Set the last extracted filename

Paramètres
string | null $lastExtractedFilename The last extracted filename
Renvoie
void
Depuis
4.0.4

Références $lastExtractedFilename.

Référencé par readFileHeader().

◆ setLastExtractedFileTimestamp()

setLastExtractedFileTimestamp ( int $lastExtractedFileTimestamp )
private

Set the last modification UNIX timestamp for the last extracted file

Paramètres
int $lastExtractedFileTimestamp The timestamp
Renvoie
void
Depuis
4.0.4

Références $lastExtractedFileTimestamp.

Référencé par step().

◆ setSkipFiles()

setSkipFiles ( array $skipFiles )

Set the list of files to skip when extracting the ZIP file.

Paramètres
array $skipFiles A list of files to skip when extracting the ZIP archive
Renvoie
void
Depuis
4.0.4

Références $skipFiles.

◆ setupMaxExecTime()

setupMaxExecTime ( )
private

Set up the maximum execution time

Renvoie
void
Depuis
4.0.4

Références getPhpMaxExecTime().

Référencé par __construct().

◆ shutdown()

shutdown ( )
private

Sleep function, called whenever the class is serialized

Renvoie
void
Depuis
4.0.4

◆ step()

step ( )

Executes a step of the archive extraction

Renvoie
boolean True if we are done extracting or an error occurred
Depuis
4.0.4

Références debugMsg(), elseif, getError(), getTimeLeft(), initialize(), null, processFileData(), processLastExtractedFile(), readFileHeader(), et setLastExtractedFileTimestamp().

◆ unserialiseInstance()

static unserialiseInstance ( string $serialised )
static

Restores a serialised instance into the singleton implementation and returns it.

If the serialised data is corrupt it will return null.

Paramètres
string $serialised The serialised data, potentially base64 encoded, to deserialize.
Renvoie
static|null The instance of the object, NULL if it cannot be deserialised.
Depuis
4.0.4

Références $instance, class, et null.

Documentation des champs

◆ $addPath

$addPath = ''
private

Référencé par setAddPath().

◆ $archiveFileIsBeingRead

$archiveFileIsBeingRead = false
private

◆ $compressedTotal

$compressedTotal = 0

◆ $currentOffset

$currentOffset = 0
private

◆ $dataReadLength

$dataReadLength = 0
private

Référencé par processTypeFileUncompressed().

◆ $expectDataDescriptor

$expectDataDescriptor = false
private

◆ $fileHeader

$fileHeader = null
private

◆ $filename

$filename = null
private

Référencé par processTypeLink().

◆ $filesProcessed

$filesProcessed = 0

◆ $fp

$fp = null
private

Référencé par fread().

◆ $ignoreDirectories

$ignoreDirectories = []
private

Référencé par setIgnoreDirectories().

◆ $instance

$instance = null
staticprivate

Référencé par unserialiseInstance().

◆ $lastErrorMessage

$lastErrorMessage = null
private

Référencé par getError().

◆ $lastExtractedFilename

$lastExtractedFilename = null
private

Référencé par setLastExtractedFilename().

◆ $lastExtractedFileTimestamp

$lastExtractedFileTimestamp = 0
private

Référencé par setLastExtractedFileTimestamp().

◆ $logFilePath

$logFilePath = null
staticprivate

◆ $logFP

$logFP = null
staticprivate

◆ $maxExecTime

$maxExecTime = null
private

◆ $runState

$runState = self::AK_STATE_INITIALIZE
private

◆ $skipFiles

$skipFiles = []

Référencé par setSkipFiles().

◆ $startTime

$startTime
private

Référencé par getRunningTime().

◆ $totalSize

$totalSize = 0

◆ $uncompressedTotal

$uncompressedTotal = 0

◆ AK_STATE_DATA

const AK_STATE_DATA = 2
private

◆ AK_STATE_DATAREAD

const AK_STATE_DATAREAD = 3
private

◆ AK_STATE_DONE

const AK_STATE_DONE = 5
private

◆ AK_STATE_FINISHED

const AK_STATE_FINISHED = 999
private

◆ AK_STATE_HEADER

const AK_STATE_HEADER = 1
private

◆ AK_STATE_INITIALIZE

const AK_STATE_INITIALIZE = -1
private

◆ AK_STATE_NOFILE

const AK_STATE_NOFILE = 0
private

◆ AK_STATE_POSTPROC

const AK_STATE_POSTPROC = 4
private

◆ CHUNK_SIZE

const CHUNK_SIZE = 524288
private

◆ LOG_DEBUG

const LOG_DEBUG = 1
private

◆ LOG_ERROR

const LOG_ERROR = 90
private

◆ LOG_INFO

const LOG_INFO = 10
private

◆ LOG_WARNING

const LOG_WARNING = 50
private

◆ MAX_EXEC_TIME

const MAX_EXEC_TIME = 4
private

◆ MIN_EXEC_TIME

const MIN_EXEC_TIME = 3
private

◆ RUNTIME_BIAS

const RUNTIME_BIAS = 90
private
La documentation de cette classe a été générée à partir du fichier suivant :
  • extract.php


Joomla CMS: Index des structures de données

Index des structures de données
a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z
a
Dispatcher (Joomla\Event) Language (Joomla\CMS\Language) RandomBytesGenerator (Ramsey\Uuid\Generator)
DispatcherAwareInterface (Joomla\Event) Language (Joomla\CMS\Service\Provider) RandomGeneratorFactory (Ramsey\Uuid\Generator)
AbstractAES (Joomla\CMS\Encrypt\AES) DispatcherInterface (Joomla\CMS\Dispatcher) Language (Doctrine\Inflector) RandomGeneratorInterface (Ramsey\Uuid\Generator)
AbstractApplication (Joomla\Application) DispatcherInterface (Joomla\Event) Language (Joomla\Component\Finder\Administrator\Indexer) RandomImageHelper (Joomla\Module\RandomImage\Site\Helper)
AbstractCBORObject (CBOR) DisplayController (Joomla\Component\Templates\Administrator\Controller) LanguageAdapter (Joomla\CMS\Installer\Adapter) RandomLibAdapter (Ramsey\Uuid\Generator)
AbstractCloner (Symfony\Component\VarDumper\Cloner) DisplayController (Joomla\Component\Admin\Administrator\Controller) LanguageclientField (Joomla\Component\Languages\Administrator\Field) RandomNodeProvider (Ramsey\Uuid\Provider\Node)
AbstractCommand (Joomla\Console\Command) DisplayController (Joomla\Component\Users\Administrator\Controller) LanguageController (Joomla\Component\Languages\Administrator\Controller) Randval (Joomla\CMS\Encrypt)
AbstractConnection (Symfony\Component\Ldap\Adapter) DisplayController (Joomla\Component\Joomlaupdate\Administrator\Controller) LanguageController (Joomla\CMS\Installation\Controller) RandValInterface (Joomla\CMS\Encrypt)
AbstractDataCollector (Joomla\Plugin\System\Debug) DisplayController (Joomla\Component\Cache\Administrator\Controller) LanguageErrorsCollector (Joomla\Plugin\System\Debug\DataCollector) RangeField (Joomla\CMS\Form\Field)
AbstractDumper (Symfony\Component\VarDumper\Dumper) DisplayController (Joomla\Component\Languages\Administrator\Controller) LanguageFactory (Joomla\CMS\Language) Raw (phpseclib3\Crypt\DSA\Formats\Keys)
AbstractEvent (Joomla\CMS\Event\Table) DisplayController (Joomla\Component\Contenthistory\Administrator\Controller) LanguageFactoryInterface (Joomla\CMS\Language) Raw (phpseclib3\Crypt\DSA\Formats\Signature)
AbstractEvent (Joomla\CMS\Event\WebAsset) DisplayController (Joomla\Component\Workflow\Administrator\Controller) LanguageField (Joomla\CMS\Form\Field) Raw (phpseclib3\Crypt\Common\Formats\Signature)
AbstractEvent (Joomla\CMS\Event\Workflow) DisplayController (Joomla\Component\Categories\Administrator\Controller) LanguageField (Joomla\CMS\Installation\Form\Field\Installation) Raw (phpseclib3\Crypt\EC\Formats\Signature)
AbstractEvent (Joomla\CMS\Event) DisplayController (Joomla\Component\Login\Administrator\Controller) LanguageFilesCollector (Joomla\Plugin\System\Debug\DataCollector) Raw (phpseclib3\Crypt\RSA\Formats\Keys)
AbstractEvent (Joomla\Event) DisplayController (Joomla\Component\Mails\Administrator\Controller) LanguageHelper (Joomla\Component\Finder\Administrator\Helper) RawDocument (Joomla\CMS\Document)
AbstractField (Cron) DisplayController (Joomla\Component\Cpanel\Administrator\Controller) LanguageHelper (Joomla\CMS\Language) RawFilter (Joomla\CMS\Form\Filter)
AbstractGroupButton (Joomla\CMS\Toolbar\Button) DisplayController (Joomla\Component\Fields\Administrator\Controller) LanguageInflectorFactory (Doctrine\Inflector) RawView (Joomla\Component\Banners\Administrator\View\Tracks)
AbstractIdnaConvert (Algo26\IdnaConvert) DisplayController (Joomla\Component\Media\Administrator\Controller) LanguageModel (Joomla\Component\Languages\Administrator\Model) RC2 (phpseclib3\Crypt)
AbstractImmutableEvent (Joomla\CMS\Event) DisplayController (Joomla\Component\Menus\Administrator\Controller) LanguageNegotiator (Negotiation) RC2CBCParameter (phpseclib3\File\ASN1\Maps)
AbstractLogger (Psr\Log) DisplayController (Joomla\Component\Banners\Site\Controller) Languages (Joomla\Component\Languages\Administrator\Service\HTML) RC4 (phpseclib3\Crypt)
AbstractMediaItemValidationEvent (Joomla\Component\Media\Administrator\Event) DisplayController (Joomla\Component\Config\Site\Controller) LanguagesComponent (Joomla\Component\Languages\Administrator\Extension) RdKafkaCaster (Symfony\Component\VarDumper\Caster)
AbstractMenu (Joomla\CMS\Menu) DisplayController (Joomla\Component\Checkin\Administrator\Controller) LanguagesController (Joomla\Component\Languages\Administrator\Controller) RDNSequence (phpseclib3\File\ASN1\Maps)
AbstractModuleDispatcher (Joomla\CMS\Dispatcher) DisplayController (Joomla\Component\Banners\Administrator\Controller) LanguagesController (Joomla\Component\Languages\Api\Controller) RDNString (FG\ASN1\Composite)
AbstractNegotiator (Negotiation) DisplayController (Joomla\Component\Contact\Site\Controller) LanguagesHelper (Joomla\Component\Languages\Administrator\Helper) Reader (TYPO3\PharStreamWrapper\Phar)
AbstractPunycode (Algo26\IdnaConvert\Punycode) DisplayController (Joomla\Component\Messages\Administrator\Controller) LanguagesHelper (Joomla\Module\Languages\Site\Helper) ReaderException (TYPO3\PharStreamWrapper\Phar)
AbstractQuery (Symfony\Component\Ldap\Adapter) DisplayController (Joomla\Component\Content\Site\Controller) LanguagesModel (Joomla\Component\Installer\Administrator\Model) ReasonFlags (phpseclib3\File\ASN1\Maps)
AbstractRenderer (Joomla\CMS\Error) DisplayController (Joomla\Component\Config\Administrator\Controller) LanguagesModel (Joomla\Component\Languages\Administrator\Model) ReCaptcha (ReCaptcha)
AbstractSerializer (Tobscure\JsonApi) DisplayController (Joomla\Component\Finder\Administrator\Controller) LanguagesModel (Joomla\CMS\Installation\Model) Redirect (Joomla\Component\Redirect\Administrator\Service\HTML)
AbstractSerializer (Laminas\Diactoros) DisplayController (Joomla\Component\Contenthistory\Site\Controller) LanguageStringsCollector (Joomla\Plugin\System\Debug\DataCollector) RedirectComponent (Joomla\Component\Redirect\Administrator\Extension)
AbstractStatsField (Joomla\Plugin\System\Stats\Field) DisplayController (Joomla\Component\Modules\Administrator\Controller) LastvisitdaterangeField (Joomla\CMS\Form\Field) RedirectController (Joomla\Component\Redirect\Api\Controller)
AbstractString (Symfony\Component\String) DisplayController (Joomla\Component\Finder\Site\Controller) LatestActionsHelper (Joomla\Module\LatestActions\Administrator\Helper) RedirectField (Joomla\Component\Redirect\Administrator\Field)
AbstractString (FG\ASN1) DisplayController (Joomla\Component\Modules\Site\Controller) LatestHelper (Joomla\Module\Latest\Administrator\Helper) RedirectHelper
AbstractTime (FG\ASN1) DisplayController (Joomla\Component\Newsfeeds\Site\Controller) LayoutHelper (Joomla\CMS\Layout) RedirectHelper (Joomla\Component\Redirect\Administrator\Helper)
AbstractTransport (Joomla\Http) DisplayController (Joomla\Component\Privacy\Site\Controller) LayoutInterface (Joomla\CMS\Layout) Response\RedirectResponse (Laminas\Diactoros)
AbstractUnicodeString (Symfony\Component\String) DisplayController (Joomla\Component\Tags\Site\Controller) LazyAssertion (Assert) RedirectStatusField (Joomla\CMS\Form\Field)
AbstractUri (Joomla\Uri) DisplayController (Joomla\Component\Newsfeeds\Administrator\Controller) LazyAssertionException (Assert) RedisCaster (Symfony\Component\VarDumper\Caster)
AbstractUsernamePasswordAuthenticationStrategy (Joomla\Authentication) DisplayController (Joomla\Component\Users\Site\Controller) LazyCommand (Symfony\Component\Console\Command) RedisHandler (Joomla\Session\Handler)
AbstractView (Joomla\CMS\MVC\View) DisplayController (Joomla\Component\Plugins\Administrator\Controller) LazyServiceEventListener (Joomla\Event) RedisStorage (DebugBar\Storage)
AbstractWebApplication (Joomla\Application) DisplayController (Joomla\Component\Actionlogs\Administrator\Controller) LazyString (Symfony\Component\String) RedisStorage (Joomla\CMS\Cache\Storage)
Accept (Negotiation) DisplayController (Joomla\Component\Wrapper\Site\Controller) Ldap (Symfony\Component\Ldap) ReflectionCaster (Symfony\Component\VarDumper\Caster)
AcceptCharset (Negotiation) DisplayController (Joomla\CMS\Installation\Controller) LdapAuthenticator (Symfony\Component\Ldap\Security) Token\RegisteredClaimGiven (Lcobucci\JWT)
AcceptEncoding (Negotiation) DisplayController (Joomla\Component\Postinstall\Administrator\Controller) LdapBadge (Symfony\Component\Ldap\Security) Token\RegisteredClaims (Lcobucci\JWT)
AcceptHeader (Negotiation) DisplayController (Joomla\Component\Contact\Administrator\Controller) LdapClient (Joomla\Ldap) RegistrationController (Joomla\Component\Users\Site\Controller)
AcceptLanguage (Negotiation) DisplayController (Joomla\Component\Privacy\Administrator\Controller) LdapException (Symfony\Component\Ldap\Exception) RegistrationdaterangeField (Joomla\CMS\Form\Field)
AcceptMatch (Negotiation) DisplayController (Joomla\Component\Redirect\Administrator\Controller) LdapInterface (Symfony\Component\Ldap) RegistrationModel (Joomla\Component\Users\Site\Model)
Access (Joomla\CMS\HTML\Helpers) DisplayController (Joomla\Component\Fields\Site\Controller) LdapUser (Symfony\Component\Ldap\Security) Registry (Joomla\CMS\HTML)
Access (Joomla\CMS\Access) DisplayController (Joomla\Component\Scheduler\Administrator\Controller) LdapUserProvider (Symfony\Component\Ldap\Security) Registry (Joomla\Registry)
AccessDescription (phpseclib3\File\ASN1\Maps) DisplayController (Joomla\Component\Installer\Administrator\Controller) Constraint\LeewayCannotBeNegative (Lcobucci\JWT\Validation) RelatedItemsHelper (Joomla\Module\RelatedItems\Site\Helper)
AccessException (Symfony\Component\OptionsResolver\Exception) DisplayController (Joomla\Component\Associations\Administrator\Controller) LegacyComponent (Joomla\CMS\Extension) Constraint\RelatedTo (Lcobucci\JWT\Validation)
AccessiblemediaField (Joomla\CMS\Form\Field) DisplayController (Joomla\Component\Content\Administrator\Controller) LegacyComponentDispatcher (Joomla\CMS\Dispatcher) Relations (Fig\Link)
AccesslevelField (Joomla\CMS\Form\Field) DisplayController (Joomla\Component\Tags\Administrator\Controller) LegacyFactory (Joomla\CMS\MVC\Factory) Relationship (Tobscure\JsonApi)
ActionButton (Joomla\CMS\Button) DisplayEvent (Joomla\CMS\Event\View) LegacyInstallerScript (Joomla\CMS\Installer) RelativeDistinguishedName (FG\ASN1\Composite)
ActionlogConfigModel (Joomla\Component\Actionlogs\Administrator\Model) DisplayPNGCharacteristicsDescriptor (Webauthn\MetadataService) LengthCalculator (CBOR) RelativeDistinguishedName (phpseclib3\File\ASN1\Maps)
ActionlogModel (Joomla\Component\Actionlogs\Administrator\Model) DisplayText (phpseclib3\File\ASN1\Maps) Claim\LesserOrEqualsTo (Lcobucci\JWT) RelativeObjectIdentifier (FG\ASN1\Universal)
ActionLogPlugin (Joomla\Component\Actionlogs\Administrator\Plugin) DistantSingleMetadata (Webauthn\MetadataService) LevelController (Joomla\Component\Users\Administrator\Controller) RelativeStream (Laminas\Diactoros)
ActionlogsController (Joomla\Component\Actionlogs\Administrator\Controller) DistantSingleMetadataFactory (Webauthn\MetadataService) LevelModel (Joomla\Component\Users\Administrator\Model) RemindController (Joomla\Component\Users\Site\Controller)
ActionlogsHelper (Joomla\Component\Actionlogs\Administrator\Helper) DistributionPoint (phpseclib3\File\ASN1\Maps) LevelsController (Joomla\Component\Users\Administrator\Controller) RemindModel (Joomla\Component\Privacy\Site\Model)
ActionlogsModel (Joomla\Component\Actionlogs\Administrator\Model) DistributionPointName (phpseclib3\File\ASN1\Maps) LevelsController (Joomla\Component\Users\Api\Controller) RemindModel (Joomla\Component\Users\Site\Model)
ActionsDropdown (Joomla\CMS\HTML\Helpers) DivisionByZeroException (Brick\Math\Exception) LevelsField (Joomla\Component\Users\Administrator\Field) RemoveModel (Joomla\Component\Privacy\Administrator\Model)
Adapter (Symfony\Component\Ldap\Adapter\ExtLdap) DNSName (FG\X509\SAN) LevelsModel (Joomla\Component\Users\Administrator\Model) RemoveOldFilesCommand (Joomla\CMS\Console)
Adapter (Joomla\Component\Finder\Administrator\Indexer) DoctrineCaster (Symfony\Component\VarDumper\Caster) LibraryAdapter (Joomla\CMS\Installer\Adapter) RemoveUserFromGroupCommand (Joomla\CMS\Console)
Adapter (Joomla\CMS\Adapter) DoctrineCollector (DebugBar\Bridge) LibraryHelper (Joomla\CMS\Helper) Renderable (DebugBar\DataCollector)
AdapterInstance (Joomla\CMS\Adapter) Document (Joomla\CMS\Document) Manifest\LibraryManifest (Joomla\CMS\Installer) RendererInterface (Joomla\CMS\Error)
AdapterInterface (Joomla\Component\Media\Administrator\Adapter) Document (Joomla\CMS\Service\Provider) libsodium (phpseclib3\Crypt\EC\Formats\Keys) RendererInterface (Joomla\CMS\Document)
AdapterInterface (Symfony\Component\Ldap\Adapter) Document (Tobscure\JsonApi) LimitableInterface (Joomla\Database\Query) Replacements (Laminas\ZendFrameworkBridge)
AdapterModel (Joomla\Component\Media\Api\Model) DocumentRenderer (Joomla\CMS\Document) LimitboxField (Joomla\CMS\Form\Field) Request (Nyholm\Psr7)
AdaptersController (Joomla\Component\Media\Api\Controller) Domain (Joomla\Component\Privacy\Administrator\Export) Link (Symfony\Component\WebLink) Request (Laminas\Diactoros)
AdaptersModel (Joomla\Component\Media\Api\Model) DOMCaster (Symfony\Component\VarDumper\Caster) Link (Fig\Link) RequestContextProvider (Symfony\Component\VarDumper\Dumper\ContextProvider)
AddConsoleCommandPass (Symfony\Component\Console\DependencyInjection) OtherObject\DoublePrecisionFloatObject (CBOR) LinkButton (Joomla\CMS\Toolbar\Button) RequestController (Joomla\Component\Privacy\Site\Controller)
AddLinkHeaderListener (Symfony\Component\WebLink\EventListener) DownloadModel (Joomla\Component\Banners\Administrator\Model) LinkController (Joomla\Component\Redirect\Administrator\Controller) RequestController (Joomla\Component\Config\Administrator\Controller)
AddressValidator (Joomla\Session\Validator) DownloadSource (Joomla\CMS\Updater) LinkInterface (Psr\Link) RequestController (Joomla\Component\Privacy\Administrator\Controller)
AddUserCommand (Joomla\CMS\Console) DraggableList (Joomla\CMS\HTML\Helpers) LinkModel (Joomla\Component\Redirect\Administrator\Model) RequestDataCollector (DebugBar\DataCollector)
AddUserToGroupCommand (Joomla\CMS\Console) DriverNotFoundException (Symfony\Component\Ldap\Exception) LinkProviderInterface (Psr\Link) RequestExceptionInterface (Psr\Http\Client)
AdminComponent (Joomla\Component\Admin\Administrator\Extension) Dropdown (Joomla\CMS\HTML\Helpers) Links (Joomla\CMS\HTML\Helpers) RequestFactory (Laminas\Diactoros)
AdminController (Joomla\CMS\MVC\Controller) DropdownButton (Joomla\CMS\Toolbar\Button) LinksController (Joomla\Component\Redirect\Administrator\Controller) RequestFactory (Http\Message)
AdministrationDomainName (phpseclib3\File\ASN1\Maps) DSA (phpseclib3\Crypt) LinksModel (Joomla\Component\Redirect\Administrator\Model) RequestFactoryInterface (Psr\Http\Message)
AdministratorApplication (Joomla\CMS\Application) DSAParams (phpseclib3\File\ASN1\Maps) LinkStub (Symfony\Component\VarDumper\Caster) RequestIdGenerator (DebugBar)
AdministratorMenu (Joomla\CMS\Menu) DSAPrivateKey (phpseclib3\File\ASN1\Maps) LinkTable (Joomla\Component\Finder\Administrator\Table) RequestIdGeneratorInterface (DebugBar)
AdministratorMenuItem (Joomla\CMS\Menu) DSAPublicKey (phpseclib3\File\ASN1\Maps) LinkTable (Joomla\Component\Redirect\Administrator\Table) RequestInterface (Psr\Http\Message)
AdministratorRouter (Joomla\CMS\Router) DsCaster (Symfony\Component\VarDumper\Caster) LintCommand (Symfony\Component\Yaml\Command) RequestMethod (ReCaptcha)
AdministratorService (Joomla\Component\Content\Administrator\Service\HTML) DsPairStub (Symfony\Component\VarDumper\Caster) ListCommand (Symfony\Component\Console\Command) RequestModel (Joomla\Component\Privacy\Administrator\Model)
AdministratorService (Joomla\Component\Categories\Administrator\Service\HTML) DssSigValue (phpseclib3\File\ASN1\Maps) ListCommand (Joomla\Console\Command) RequestModel (Joomla\Component\Privacy\Site\Model)
AdministratorService (Joomla\Component\Newsfeeds\Administrator\Service\HTML) DummyPlugin (Joomla\CMS\Extension) ListenersPriorityQueue (Joomla\Event) RequestParameters (ReCaptcha)
AdministratorService (Joomla\Component\Contact\Administrator\Service\HTML) DumpableInterface (Joomla\Data) ListField (Joomla\CMS\Form\Field) Requests (Joomla\Plugin\Task\Requests\Extension)
AdminLanguage (Joomla\CMS\HTML\Helpers) DumpCompletionCommand (Symfony\Component\Console\Command) ListHelper (Joomla\CMS\HTML\Helpers) RequestsController (Joomla\Component\Privacy\Administrator\Controller)
AdminModel (Joomla\CMS\MVC\Model) DumpDescriptorInterface (Symfony\Component\VarDumper\Command\Descriptor) ListModel (Joomla\CMS\MVC\Model) RequestsController (Joomla\Component\Privacy\Api\Controller)
Aes (Joomla\CMS\Encrypt) Dumper (Symfony\Component\Console\Helper) ListModelInterface (Joomla\CMS\MVC\Model) RequestsModel (Joomla\Component\Privacy\Administrator\Model)
AES (phpseclib3\Crypt) Dumper (Symfony\Component\Yaml) ListObject (CBOR) RequeststatusField (Joomla\Component\Privacy\Administrator\Field)
AesInterface (Joomla\CMS\Encrypt\AES) DumperInterface (Symfony\Component\VarDumper\Cloner) ListUserCommand (Joomla\CMS\Console) RequestTable (Joomla\Component\Privacy\Administrator\Table)
AfterBindEvent (Joomla\CMS\Event\Table) DumpException (Symfony\Component\Yaml\Exception) ListView (Joomla\CMS\MVC\View) RequesttypeField (Joomla\Component\Privacy\Administrator\Field)
AfterCheckinEvent (Joomla\CMS\Event\Table) DumpServer (Symfony\Component\VarDumper\Server) LoaderInterface (Joomla\Console\Loader) Required (Symfony\Contracts\Service\Attribute)
AfterCheckoutEvent (Joomla\CMS\Event\Table) Dutch (Wamania\Snowball\Stemmer) LocalAdapter (Joomla\Plugin\Filesystem\Local\Adapter) RequiredConstraintsViolated (Lcobucci\JWT\Validation)
AfterDeleteEvent (Joomla\CMS\Event\Table)
e
Signer\Key\LocalFileReference (Lcobucci\JWT) ResetController (Joomla\Component\Users\Site\Controller)
AfterExtensionBootEvent (Joomla\CMS\Event) LocalizationCollector (DebugBar\DataCollector) ResetInterface (Symfony\Contracts\Service)
AfterHitEvent (Joomla\CMS\Event\Table) EC (phpseclib3\Crypt) LocalStrategy (Joomla\Authentication\Strategies) ResetModel (Joomla\Component\Users\Site\Model)
AfterLoadEvent (Joomla\CMS\Event\Table) Ec2Key (Cose\Key) LocationField (Joomla\Component\Installer\Administrator\Field) Resolvable (TYPO3\PharStreamWrapper)
AfterMoveEvent (Joomla\CMS\Event\Table) EcdaaKeyIdTrustPath (Webauthn\TrustPath) Log (Joomla\CMS\Log) ResolvedRoute (Joomla\Router)
AfterPublishEvent (Joomla\CMS\Event\Table) EcdaaTrustAnchor (Webauthn\MetadataService) LogcreatorField (Joomla\Component\Actionlogs\Administrator\Field) Resolver (enshrined\svgSanitize\ElementReference)
AfterReorderEvent (Joomla\CMS\Event\Table) Signer\Ecdsa (Lcobucci\JWT) LogEntry (Joomla\CMS\Log) Resource (Tobscure\JsonApi)
AfterResetEvent (Joomla\CMS\Event\Table) ECDSA (Cose\Algorithm\Signature\ECDSA) LoggedHelper (Joomla\Module\Logged\Administrator\Helper) ResourceCaster (Symfony\Component\VarDumper\Caster)
AfterStoreEvent (Joomla\CMS\Event\Table) ECDSA (Jose\Component\Signature\Algorithm) Logger (Joomla\CMS\Log) ResourceNotFound (Joomla\CMS\MVC\Controller\Exception)
Agent (phpseclib3\System\SSH) EcdsaSigValue (phpseclib3\File\ASN1\Maps) Logger (Joomla\CMS\Service\Provider) ResourceNotFoundExceptionHandler (Joomla\CMS\Error\JsonApi)
AggregatedCollector (DebugBar\DataCollector) Logger\EchoLogger (Joomla\CMS\Log) LoggerAwareInterface (Psr\Log) Response (Nyholm\Psr7)
Ajax (Joomla\CMS\Event\Plugin\System\Webauthn) ECKey (Jose\Component\Core\Util) LoggerInterface (Psr\Log) Response (Joomla\CMS\Http)
AjaxChallenge (Joomla\CMS\Event\Plugin\System\Webauthn) ECParameters (phpseclib3\File\ASN1\Maps) LoggerRegistry (Joomla\CMS\Log) Response (ReCaptcha)
AjaxController (Joomla\Component\Categories\Administrator\Controller) ECPoint (phpseclib3\File\ASN1\Maps) LoggingMonitor (Joomla\Database\Monitor) Response (Joomla\Component\Finder\Administrator\Response)
AjaxController (Joomla\Component\Menus\Administrator\Controller) ECPrivateKey (phpseclib3\File\ASN1\Maps) LogicException (Symfony\Component\Console\Exception) Response (Joomla\Http)
AjaxController (Joomla\Component\Newsfeeds\Administrator\Controller) ECSignature (Cose\Algorithm\Signature\ECDSA) LoginHelper (Joomla\Module\Login\Administrator\Helper) Response (Laminas\Diactoros)
AjaxController (Joomla\Component\Contact\Administrator\Controller) ECSignature (Jose\Component\Core\Util) LoginHelper (Joomla\Module\Login\Site\Helper) ResponseBag (Tobscure\JsonApi\Exception\Handler)
AjaxController (Joomla\Component\Content\Administrator\Controller) Ed25519 (ParagonIE\Sodium\Core) LoginModel (Joomla\Component\Users\Site\Model) ResponseFactory (Http\Message)
AjaxCreate (Joomla\CMS\Event\Plugin\System\Webauthn) Ed25519 (phpseclib3\Crypt\EC\Curves) LoginModel (Joomla\Component\Login\Administrator\Model) ResponseFactory (Laminas\Diactoros)
AjaxDelete (Joomla\CMS\Event\Plugin\System\Webauthn) Ed25519 (Cose\Algorithm\Signature\EdDSA) LoginUniqueFieldRule (Joomla\Component\Users\Site\Rule) ResponseFactoryInterface (Psr\Http\Message)
AjaxInitCreate (Joomla\CMS\Event\Plugin\System\Webauthn) ED256 (Cose\Algorithm\Signature\EdDSA) LogLevel (Psr\Log) ResponseInterface (Psr\Http\Message)
AjaxLogin (Joomla\CMS\Event\Plugin\System\Webauthn) Ed448 (phpseclib3\Crypt\EC\Curves) LogoutUniqueFieldRule (Joomla\Component\Users\Site\Rule) Result (Joomla\Component\Finder\Administrator\Indexer)
AjaxSaveLabel (Joomla\CMS\Event\Plugin\System\Webauthn) ED512 (Cose\Algorithm\Signature\EdDSA) LogsdaterangeField (Joomla\Component\Actionlogs\Administrator\Field) ResultAwareInterface (Joomla\CMS\Event\Result)
Algorithm (Cose\Algorithm) EdDSA (Cose\Algorithm\Signature\EdDSA) LogtypeField (Joomla\Component\Actionlogs\Administrator\Field) RevokedCertificate (phpseclib3\File\ASN1\Maps)
Algorithm (Jose\Component\Core) EdDSA (Jose\Component\Signature\Algorithm)
m
RewriteRules (Laminas\ZendFrameworkBridge)
AlgorithmIdentifier (phpseclib3\File\ASN1\Maps) Edgedetect (Joomla\CMS\Image\Filter) RFC4648 (ParagonIE\ConstantTime)
AlgorithmIdentifier (FG\X509) EDIPartyName (phpseclib3\File\ASN1\Maps) Mac (Cose\Algorithm\Mac) RgbPaletteEntry (Webauthn\MetadataService)
AlgorithmManager (Jose\Component\Core) Editor (Joomla\CMS\Editor) MacAlgorithm (Jose\Component\Signature\Algorithm) Rijndael (phpseclib3\Crypt)
AlgorithmManagerFactory (Jose\Component\Core) EditorField (Joomla\CMS\Form\Field) Mail (Joomla\CMS\Mail) RogueListEntry (Webauthn\MetadataService)
Algorithms (Cose) Language\El (Joomla\Component\Finder\Administrator\Indexer) MailController (Joomla\Component\Users\Administrator\Controller) Romanian (Wamania\Snowball\Stemmer)
AliastagField (Joomla\CMS\Form\Field) ASN1\Element (phpseclib3\File) MailDisabledException (Joomla\CMS\Mail\Exception) RoundingMode (Brick\Math)
AllowedAttributes (enshrined\svgSanitize\data) ElementInterface (Tobscure\JsonApi) MailHelper (Joomla\CMS\Mail) RoundingNecessaryException (Brick\Math\Exception)
AllowedTags (enshrined\svgSanitize\data) Email (Joomla\CMS\HTML\Helpers) MailModel (Joomla\Component\Users\Administrator\Model) Route (Joomla\CMS\Router)
AlreadyExistsException (Symfony\Component\Ldap\Exception) Email (Joomla\Plugin\Multifactorauth\Email\Extension) MailsHelper (Joomla\Component\Mails\Administrator\Helper) Route (Joomla\Router)
AlreadyPunycodeException (Algo26\IdnaConvert\Exception) EmailField (Joomla\CMS\Form\Field) MailTemplate (Joomla\CMS\Mail) RouteHelper (Joomla\Component\Finder\Site\Helper)
AmqpCaster (Symfony\Component\VarDumper\Caster) EmailRule (Joomla\CMS\Form\Rule) Manage (Joomla\Component\Installer\Administrator\Service\HTML) RouteHelper (Joomla\Component\Contact\Site\Helper)
AndroidKeyAttestationStatementSupport (Webauthn\AttestationStatement) Emboss (Joomla\CMS\Image\Filter) ManageController (Joomla\Component\Installer\Api\Controller) RouteHelper (Joomla\CMS\Helper)
AndroidKeyAttestationStatementSupport (Joomla\Plugin\Multifactorauth\Webauthn\Hotfix) Response\EmptyResponse (Laminas\Diactoros) ManageController (Joomla\Component\Installer\Administrator\Controller) RouteHelper (Joomla\Component\Content\Site\Helper)
AndroidKeyAttestationStatementSupport (Joomla\Plugin\System\Webauthn\Hotfix) EmptyTrustPath (Webauthn\TrustPath) ManageModel (Joomla\Component\Installer\Administrator\Model) RouteHelper (Joomla\Component\Newsfeeds\Site\Helper)
AndroidSafetyNetAttestationStatementSupport (Webauthn\AttestationStatement) En_GBLocalise Manager (TYPO3\PharStreamWrapper) RouteHelper (Joomla\Component\Tags\Site\Helper)
AnotherName (phpseclib3\File\ASN1\Maps) Encoder (Lcobucci\JWT\Parsing) Manager (Cose\Algorithm) RouteNotFoundException (Joomla\CMS\Router\Exception)
ANSI (phpseclib3\File) EncoderInterface (ParagonIE\ConstantTime) ManagerFactory (Cose\Algorithm) RouteNotFoundException (Joomla\Router\Exception)
ApcuHandler (Joomla\Session\Handler) Encoding (ParagonIE\ConstantTime) Manifest (Joomla\CMS\Installer) Router (Joomla\CMS\Service\Provider)
ApcuStorage (Joomla\CMS\Cache\Storage) Encoding (Defuse\Crypto) Manifest (TYPO3\PharStreamWrapper\Phar) Router (Joomla\Component\Newsfeeds\Site\Service)
ApiApplication (Joomla\CMS\Application) EncodingHelperInterface (Algo26\IdnaConvert\EncodingHelper) MapItem (CBOR) Router (Joomla\Component\Wrapper\Site\Service)
ApiController (Joomla\Component\Media\Administrator\Controller) EncodingNegotiator (Negotiation) MapObject (CBOR) Router (Joomla\Component\Users\Site\Service)
ApiController (Joomla\CMS\MVC\Controller) Encrypt (Joomla\Component\Users\Administrator\Service) MapsController (Joomla\Component\Finder\Administrator\Controller) Router (Joomla\Component\Contact\Site\Service)
ApiDispatcher (Joomla\CMS\Dispatcher) EncryptedData (phpseclib3\File\ASN1\Maps) MapsModel (Joomla\Component\Finder\Administrator\Model) Router (Joomla\Component\Config\Site\Service)
ApiModel (Joomla\Component\Media\Administrator\Model) EncryptedPrivateKeyInfo (phpseclib3\File\ASN1\Maps) MapTable (Joomla\Component\Finder\Administrator\Table) Router (Joomla\Component\Finder\Site\Service)
ApiMVCFactory (Joomla\CMS\MVC\Factory) EncryptionException (Joomla\Crypt\Exception) MarkdownDescriptor (Symfony\Component\Console\Descriptor) Router (Joomla\CMS\Router)
ApiRouter (Joomla\CMS\Router) Engine (phpseclib3\Math\BigInteger\Engines) MaskGenAlgorithm (phpseclib3\File\ASN1\Maps) Router (Joomla\Component\Privacy\Site\Service)
Application (Symfony\Component\Console) English (Wamania\Snowball\Stemmer) MathException (Brick\Math\Exception) Router (Joomla\Component\Banners\Site\Service)
Application (Joomla\CMS\Service\Provider) EnglishInflector (Symfony\Component\String\Inflector) Mbstring (Symfony\Polyfill\Mbstring) Router (Joomla\Component\Tags\Site\Service)
Application (Joomla\CMS\Installation\Service\Provider) Entry (Symfony\Component\Ldap) Mcrypt (Joomla\CMS\Encrypt\AES) Router (Joomla\Component\Content\Site\Service)
Application (Joomla\Console) EntryManager (Symfony\Component\Ldap\Adapter\ExtLdap) MD5Handler (Joomla\CMS\Authentication\Password) Router (Joomla\Router)
ApplicationController (Joomla\Component\Config\Api\Controller) EntryManagerInterface (Symfony\Component\Ldap\Adapter) MediaActionPlugin (Joomla\Component\Media\Administrator\Plugin) RouterBase (Joomla\CMS\Component\Router)
ApplicationController (Joomla\Component\Config\Administrator\Controller) Enumerated (FG\ASN1\Universal) MediaController (Joomla\Component\Media\Api\Controller) RouterFactory (Joomla\CMS\Component\Router)
ApplicationDescription (Symfony\Component\Console\Descriptor) EnumStub (Symfony\Component\VarDumper\Caster) MediaField (Joomla\CMS\Form\Field) RouterFactory (Joomla\CMS\Extension\Service\Provider)
ApplicationDescription (Joomla\Console\Descriptor) EnvironmentIsBrokenException (Defuse\Crypto\Exception) MediaHelper RouterFactoryInterface (Joomla\CMS\Component\Router)
ApplicationErrorEvent (Joomla\Application\Event) EpochTag (CBOR\Tag) MediaHelper (Joomla\CMS\Helper) RouterInterface (Joomla\CMS\Component\Router)
ApplicationErrorEvent (Joomla\Console\Event) EqualsRule (Joomla\CMS\Form\Rule) MediaModel (Joomla\Component\Media\Administrator\Model) RouterInterface (Joomla\Router)
ApplicationEvent (Joomla\Application\Event) Claim\EqualsTo (Lcobucci\JWT) MediaModel (Joomla\Component\Media\Api\Model) RouterLegacy (Joomla\CMS\Component\Router)
ApplicationEvents (Joomla\Application) ErrorDocument (Joomla\CMS\Document) MediaProviderEvent (Joomla\Component\Media\Administrator\Event) RouterServiceInterface (Joomla\CMS\Component\Router)
ApplicationHelper (Joomla\CMS\Application) ErrorEnhancerInterface (Symfony\Component\ErrorHandler\ErrorEnhancer) MediaRssParser (Joomla\CMS\Feed\Parser\Rss) RouterView (Joomla\CMS\Component\Router)
ApplicationInterface (Joomla\Application) ErrorEvent (Joomla\CMS\Event) MediumModel (Joomla\Component\Media\Api\Model) RouterViewConfiguration (Joomla\CMS\Component\Router)
ApplicationModel (Joomla\Component\Config\Administrator\Model) ErrorHandler (Symfony\Component\ErrorHandler) MemcachedCaster (Symfony\Component\VarDumper\Caster) RS1 (Jose\Component\Signature\Algorithm)
ApplicationTester (Symfony\Component\Console\Tester) ErrorHandler (Tobscure\JsonApi) MemcachedHandler (Joomla\Session\Handler) RS1 (Cose\Algorithm\Signature\RSA)
Archive (Joomla\Archive) ErrorListener (Symfony\Component\Console\EventListener) MemcachedStorage (DebugBar\Storage) RS256 (Jose\Component\Signature\Algorithm)
ArchiveModel (Joomla\Component\Content\Site\Model) ErrorRendererInterface (Symfony\Component\ErrorHandler\ErrorRenderer) MemcachedStorage (Joomla\CMS\Cache\Storage) RS256 (Cose\Algorithm\Signature\RSA)
Argon2idHandler (Joomla\Authentication\Password) ES256 (Jose\Component\Signature\Algorithm) MemoryCollector (DebugBar\DataCollector) RS384 (Jose\Component\Signature\Algorithm)
Argon2idHandler (Joomla\CMS\Authentication\Password) ES256 (Cose\Algorithm\Signature\ECDSA) Menu (Joomla\CMS\Table) RS384 (Cose\Algorithm\Signature\RSA)
Argon2iHandler (Joomla\Authentication\Password) ES256K (Cose\Algorithm\Signature\ECDSA) Menu (Joomla\CMS\HTML\Helpers) RS512 (Cose\Algorithm\Signature\RSA)
Argon2iHandler (Joomla\CMS\Authentication\Password) ES256K (Jose\Component\Signature\Algorithm) Menu (Joomla\CMS\Service\Provider) RS512 (Jose\Component\Signature\Algorithm)
ArgsStub (Symfony\Component\VarDumper\Caster) ES384 (Cose\Algorithm\Signature\ECDSA) Menu (Joomla\Module\Submenu\Administrator\Menu) Signer\Rsa (Lcobucci\JWT)
ArgvInput (Symfony\Component\Console\Input) ES384 (Jose\Component\Signature\Algorithm) MenuController (Joomla\Component\Menus\Administrator\Controller) RSA (Jose\Component\Signature\Algorithm\Util)
ArrayHelper (Joomla\Utilities) ES512 (Cose\Algorithm\Signature\ECDSA) MenuFactory (Joomla\CMS\Menu) RSA (phpseclib3\Crypt)
ArrayInput (Symfony\Component\Console\Input) ES512 (Jose\Component\Signature\Algorithm) MenuFactoryInterface (Joomla\CMS\Menu) RSA (Jose\Component\Signature\Algorithm)
Request\ArraySerializer (Laminas\Diactoros) Escaper (Symfony\Component\Yaml) MenuField (Joomla\Component\Menus\Administrator\Field\Modal) RSA (Cose\Algorithm\Signature\RSA)
Response\ArraySerializer (Laminas\Diactoros) EvalBarrett (phpseclib3\Math\BigInteger\Engines\BCMath\Reductions) MenuField (Joomla\CMS\Form\Field) RsaKey (Cose\Key)
ArticleController (Joomla\Component\Content\Site\Controller) EvalBarrett (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) MenuHelper (Joomla\Module\Menu\Site\Helper) RSAKey (Jose\Component\Core\Util)
ArticleController (Joomla\Component\Content\Administrator\Controller) Event (Joomla\Event) MenuItem (Joomla\CMS\Menu) RSAPKCS1 (Jose\Component\Signature\Algorithm)
ArticleField (Joomla\Component\Content\Administrator\Field\Modal) EventAwareInterface (Joomla\CMS\Application) MenuItemByTypeField (Joomla\Component\Menus\Administrator\Field) RSAPrivateKey (phpseclib3\File\ASN1\Maps)
ArticleModel (Joomla\Component\Content\Administrator\Model) EventImmutable (Joomla\Event) MenuitemField (Joomla\CMS\Form\Field) RSAPSS (Jose\Component\Signature\Algorithm)
ArticleModel (Joomla\Component\Content\Site\Model) EventInterface (Joomla\Event) MenuModel (Joomla\Component\Menus\Administrator\Model) RSAPublicKey (phpseclib3\File\ASN1\Maps)
ArticlesArchiveHelper (Joomla\Module\ArticlesArchive\Site\Helper) EvolvableLinkInterface (Psr\Link) MenuOrderingField (Joomla\Component\Menus\Administrator\Field) RSASSA_PSS_params (phpseclib3\File\ASN1\Maps)
ArticlesCategoriesHelper (Joomla\Module\ArticlesCategories\Site\Helper) EvolvableLinkProviderInterface (Psr\Link) MenuParentField (Joomla\Component\Menus\Administrator\Field) RssParser (Joomla\CMS\Feed\Parser)
ArticlesCategoryHelper (Joomla\Module\ArticlesCategory\Site\Helper) Exception (PHPMailer\PHPMailer) MenuPresetField (Joomla\Component\Menus\Administrator\Field) RssRenderer (Joomla\CMS\Document\Renderer\Feed)
ArticlesController (Joomla\Component\Content\Api\Controller) Exception (TYPO3\PharStreamWrapper) MenuRules (Joomla\CMS\Component\Router\Rules) Parser\Rtf (Joomla\Component\Finder\Administrator\Indexer)
ArticlesController (Joomla\Component\Content\Administrator\Controller) Exception (Negotiation\Exception) Menus (Joomla\Component\Menus\Administrator\Service\HTML) Rule (Joomla\CMS\Access)
ArticlesLatestHelper (Joomla\Module\ArticlesLatest\Site\Helper) ExceptionCaster (Symfony\Component\VarDumper\Caster) MenusComponent (Joomla\Component\Menus\Administrator\Extension) Rules (Doctrine\Inflector\Rules\NorwegianBokmal)
ArticlesModel (Joomla\Component\Content\Administrator\Model) ExceptionHandler (Joomla\CMS\Exception) MenusController (Joomla\Component\Menus\Api\Controller) Rules (Doctrine\Inflector\Rules\French)
ArticlesModel (Joomla\Component\Content\Site\Model) ExceptionHandlerInterface (Tobscure\JsonApi\Exception\Handler) MenusController (Joomla\Component\Menus\Administrator\Controller) Rules (Doctrine\Inflector\Rules\English)
ArticlesNewsHelper (Joomla\Module\ArticlesNews\Site\Helper) ExceptionInterface (Symfony\Component\Console\Exception) MenusHelper Rules (Doctrine\Inflector\Rules\Spanish)
ArticlesPopularHelper (Joomla\Module\ArticlesPopular\Site\Helper) ExceptionInterface (Symfony\Component\Ldap\Exception) MenusHelper (Joomla\Component\Menus\Administrator\Helper) Rules (Doctrine\Inflector\Rules\Portuguese)
ArticleTable (Joomla\Component\Content\Administrator\Table) ExceptionInterface (Symfony\Component\OptionsResolver\Exception) MenusModel (Joomla\Component\Menus\Administrator\Model) Rules (Doctrine\Inflector\Rules\Turkish)
ASCII (voku\helper) ExceptionInterface (Symfony\Component\String\Exception) MenuTable (Joomla\Component\Menus\Administrator\Table) Rules (Joomla\CMS\Access)
AsciiSlugger (Symfony\Component\String\Slugger) ExceptionInterface (Symfony\Component\Yaml\Exception) MenuType (Joomla\CMS\Table) Ruleset (Doctrine\Inflector\Rules)
AsCommand (Symfony\Component\Console\Attribute) ExceptionInterface (Laminas\Diactoros\Exception) MenutypeField (Joomla\Component\Menus\Administrator\Field) RulesetInflector (Doctrine\Inflector)
ASN1 (phpseclib3\Crypt\DSA\Formats\Signature) ExceptionsCollector (DebugBar\DataCollector) MenutypesModel (Joomla\Component\Menus\Administrator\Model) RulesField (Joomla\CMS\Form\Field)
ASN1 (phpseclib3\Crypt\EC\Formats\Signature) ExecRuleHelper (Joomla\Component\Scheduler\Administrator\Helper) MenuTypeTable (Joomla\Component\Menus\Administrator\Table) RulesFilter (Joomla\CMS\Form\Filter)
ASN1 (phpseclib3\File) ExecuteTaskEvent (Joomla\Component\Scheduler\Administrator\Event) MessageController (Joomla\Component\Messages\Administrator\Controller) RulesInterface (Joomla\CMS\Component\Router\Rules)
ASNObject (FG\ASN1) ExecutionFailureException (Joomla\Database\Exception) MessageController (Joomla\Component\Postinstall\Administrator\Controller) RulesRule (Joomla\CMS\Form\Rule)
Assert (Webmozart\Assert) ExecutionRuleField (Joomla\Component\Scheduler\Administrator\Field) MessageFactory (Http\Message) RuntimeException (Symfony\Component\String\Exception)
Assert (Assert) ExecutionRulesRule (Joomla\Component\Scheduler\Administrator\Rule) MessageInterface (Psr\Http\Message) RuntimeException (Symfony\Component\Console\Exception)
Assertable (TYPO3\PharStreamWrapper) ExistsRule (Joomla\CMS\Form\Rule) MessageModel (Joomla\Component\Messages\Administrator\Model) RuntimeException (Symfony\Component\Yaml\Exception)
Assertion (Assert) ExplicitlyTaggedObject (FG\ASN1) Logger\MessagequeueLogger (Joomla\CMS\Log) RuntimeStorage (Joomla\Session\Storage)
AssertionChain (Assert) ExportCommand (Joomla\Database\Command) MessageRenderer (Joomla\CMS\Document\Renderer\Html) RuntimeTests (Defuse\Crypto)
AssertionFailedException (Assert) ExportModel (Joomla\Component\Privacy\Administrator\Model) Messages (Joomla\Component\Messages\Administrator\Service\HTML) Russian (Wamania\Snowball\Stemmer)
Asset (Joomla\CMS\Table) Extension (phpseclib3\File\ASN1\Maps) MessagesAggregateInterface (DebugBar\DataCollector)
s
AssetProvider (DebugBar\DataCollector) Extension (Joomla\CMS\Table) MessagesCollector (DebugBar\DataCollector)
AssocField (Joomla\Component\Content\Administrator\Field) ExtensionAdapter (Joomla\CMS\Updater\Adapter) MessagesComponent (Joomla\Component\Messages\Administrator\Extension) SafehtmlFilter (Joomla\CMS\Form\Filter)
AssociationController (Joomla\Component\Associations\Administrator\Controller) ExtensionAttribute (phpseclib3\File\ASN1\Maps) MessagesController (Joomla\Component\Messages\Api\Controller) Salsa20 (ParagonIE\Sodium\Core)
AssociationExtensionHelper (Joomla\CMS\Association) ExtensionAttributes (phpseclib3\File\ASN1\Maps) MessagesController (Joomla\Component\Messages\Administrator\Controller) Salsa20 (phpseclib3\Crypt)
AssociationExtensionInterface (Joomla\CMS\Association) ExtensionDescriptor (Webauthn\MetadataService) MessagesHelper (Joomla\Component\Messages\Administrator\Helper) SampledataHelper (Joomla\Module\Sampledata\Administrator\Helper)
AssociationField (Joomla\Component\Associations\Administrator\Field\Modal) ExtensionDiscoverCommand (Joomla\CMS\Console) MessagesModel (Joomla\Component\Messages\Administrator\Model) Sanitizer (enshrined\svgSanitize)
AssociationHelper (Joomla\Component\Contact\Site\Helper) ExtensionDiscoverInstallCommand (Joomla\CMS\Console) MessagesModel (Joomla\Component\Postinstall\Administrator\Model) Save (Joomla\CMS\MVC\Controller\Exception)
AssociationHelper (Joomla\Component\Content\Site\Helper) ExtensionDiscoverListCommand (Joomla\CMS\Console) MessageStatesField (Joomla\Component\Messages\Administrator\Field) SaveExceptionHandler (Joomla\CMS\Error\JsonApi)
AssociationHelper (Joomla\Component\Newsfeeds\Site\Helper) ExtensionField (Joomla\Component\Actionlogs\Administrator\Field) MessageTable (Joomla\Component\Messages\Administrator\Table) SaveSetup (Joomla\CMS\Event\MultiFactor)
AssociationModel (Joomla\Component\Associations\Administrator\Model) ExtensionHelper (Joomla\CMS\Extension) MetadataManager (Joomla\CMS\Session) Scheduler (Joomla\Component\Scheduler\Administrator\Scheduler)
Associations (Joomla\CMS\Language) ExtensionInstallCommand (Joomla\CMS\Console) MetadataManagerListener (Joomla\CMS\Session\EventListener) SchedulerComponent (Joomla\Component\Scheduler\Administrator\Extension)
AssociationsController (Joomla\Component\Associations\Administrator\Controller) ExtensionManagerInterface (Joomla\CMS\Extension) MetadataRepository (Joomla\Plugin\System\Webauthn) SchedulerHelper (Joomla\Component\Scheduler\Administrator\Helper)
AssociationServiceInterface (Joomla\CMS\Association) ExtensionOutputChecker (Webauthn\AuthenticationExtensions) MetadataService (Webauthn\MetadataService) ScriptsRenderer (Joomla\CMS\Document\Renderer\Html)
AssociationsHelper (Joomla\Component\Content\Administrator\Helper) ExtensionOutputCheckerHandler (Webauthn\AuthenticationExtensions) MetadataServiceFactory (Webauthn\MetadataService) SearchesController (Joomla\Component\Finder\Administrator\Controller)
AssociationsHelper (Joomla\Component\Associations\Administrator\Helper) ExtensionOutputError (Webauthn\AuthenticationExtensions) MetadataStatement (Webauthn\MetadataService) SearchesModel (Joomla\Component\Finder\Administrator\Model)
AssociationsHelper (Joomla\Component\Menus\Administrator\Helper) ExtensionRemoveCommand (Joomla\CMS\Console) MetadataStatementFetcher (Webauthn\MetadataService) SearchfilterField (Joomla\Component\Finder\Administrator\Field)
AssociationsHelper (Joomla\Component\Newsfeeds\Administrator\Helper) Extensions (phpseclib3\File\ASN1\Maps) MetadataStatementRepository (Webauthn\MetadataService) SearchModel (Joomla\Component\Finder\Site\Model)
AssociationsHelper (Joomla\Component\Contact\Administrator\Helper) ExtensionsListCommand (Joomla\CMS\Console) MetadataTOCPayload (Webauthn\MetadataService) SearchTools (Joomla\CMS\HTML\Helpers)
AssociationsModel (Joomla\Component\Associations\Administrator\Model) ExtensionstatusField (Joomla\Component\Installer\Administrator\Field) MetadataTOCPayloadEntry (Webauthn\MetadataService) secp112r1 (phpseclib3\Crypt\EC\Curves)
AsymmetricKey (phpseclib3\Crypt\Common) ExtKeyUsageSyntax (phpseclib3\File\ASN1\Maps) MetasRenderer (Joomla\CMS\Document\Renderer\Html) secp112r2 (phpseclib3\Crypt\EC\Curves)
AtomParser (Joomla\CMS\Feed\Parser) ExtractableInterface (Joomla\Archive) MeterField (Joomla\CMS\Form\Field) secp128r1 (phpseclib3\Crypt\EC\Curves)
AtomRenderer (Joomla\CMS\Document\Renderer\Feed)
f
MethodController (Joomla\Component\Users\Site\Controller) secp128r2 (phpseclib3\Crypt\EC\Curves)
AttestationObject (Webauthn\AttestationStatement) MethodController (Joomla\Component\Users\Administrator\Controller) secp160k1 (phpseclib3\Crypt\EC\Curves)
AttestationObjectLoader (Webauthn\AttestationStatement) Claim\Factory (Lcobucci\JWT) MethodDescriptor (Joomla\Component\Users\Administrator\DataShape) secp160r1 (phpseclib3\Crypt\EC\Curves)
AttestationStatement (Webauthn\AttestationStatement) Factory (Joomla\CMS\Document) MethodModel (Joomla\Component\Users\Administrator\Model) secp160r2 (phpseclib3\Crypt\EC\Curves)
AttestationStatementSupport (Webauthn\AttestationStatement) Factory (Joomla\CMS) MethodModel (Joomla\Component\Users\Site\Model) secp192k1 (phpseclib3\Crypt\EC\Curves)
AttestationStatementSupportManager (Webauthn\AttestationStatement) Factory (Joomla\Registry) MethodNotAllowedException (Joomla\Router\Exception) secp192r1 (phpseclib3\Crypt\EC\Curves)
AttestedCredentialData (Webauthn) FactoryCommandLoader (Symfony\Component\Console\CommandLoader) MethodsController (Joomla\Component\Users\Administrator\Controller) secp224k1 (phpseclib3\Crypt\EC\Curves)
Attribute (phpseclib3\File\ASN1\Maps) FactoryInterface (Joomla\CMS\Document) MethodsController (Joomla\Component\Users\Site\Controller) secp224r1 (phpseclib3\Crypt\EC\Curves)
Attribute FallbackExceptionHandler (Tobscure\JsonApi\Exception\Handler) MethodsModel (Joomla\Component\Users\Administrator\Model) secp256k1 (phpseclib3\Crypt\EC\Curves)
AttributeInterface (enshrined\svgSanitize\data) FallbackNodeProvider (Ramsey\Uuid\Provider\Node) MethodsModel (Joomla\Component\Users\Site\Model) secp256r1 (phpseclib3\Crypt\EC\Curves)
Attributes (phpseclib3\File\ASN1\Maps) OtherObject\FalseObject (CBOR) Mfa (Joomla\Component\Users\Administrator\Helper) secp384r1 (phpseclib3\Crypt\EC\Curves)
Attributes (FG\X509\CSR) FatalError (Symfony\Component\ErrorHandler\Error) MfaTable (Joomla\Component\Users\Administrator\Table) secp521r1 (phpseclib3\Crypt\EC\Curves)
AttributeType (phpseclib3\File\ASN1\Maps) Curve25519\Fe (ParagonIE\Sodium\Core) Microdata (Joomla\CMS\Microdata) sect113r1 (phpseclib3\Crypt\EC\Curves)
AttributeTypeAndValue (phpseclib3\File\ASN1\Maps) FeaturedButton (Joomla\CMS\Button) MinutesField (Cron) sect113r2 (phpseclib3\Crypt\EC\Curves)
AttributeTypeAndValue (FG\ASN1\Composite) FeaturedController (Joomla\Component\Content\Administrator\Controller) MissingComponentException (Joomla\CMS\Component\Exception) sect131r1 (phpseclib3\Crypt\EC\Curves)
AttributeValue (phpseclib3\File\ASN1\Maps) FeaturedModel (Joomla\Component\Content\Administrator\Model) MissingInputException (Symfony\Component\Console\Exception) sect131r2 (phpseclib3\Crypt\EC\Curves)
Authentication (Joomla\CMS\Service\Provider) FeaturedModel (Joomla\Component\Contact\Site\Model) MissingOptionsException (Symfony\Component\OptionsResolver\Exception) sect163k1 (phpseclib3\Crypt\EC\Curves)
Authentication (Joomla\Plugin\System\Webauthn) FeaturedModel (Joomla\Component\Content\Site\Model) ModelInterface (Joomla\CMS\MVC\Model) sect163r1 (phpseclib3\Crypt\EC\Curves)
Authentication (Joomla\Authentication) FeaturedTable (Joomla\Component\Content\Administrator\Table) Module (Laminas\ZendFrameworkBridge) sect163r2 (phpseclib3\Crypt\EC\Curves)
Authentication (Joomla\CMS\Authentication) FeatureEvent (Joomla\Component\Content\Administrator\Event\Model) Module (Joomla\CMS\Extension) sect193r1 (phpseclib3\Crypt\EC\Curves)
AuthenticationExtension (Webauthn\AuthenticationExtensions) FeatureModel (Joomla\Component\Content\Administrator\Model) Module (Joomla\CMS\Extension\Service\Provider) sect193r2 (phpseclib3\Crypt\EC\Curves)
AuthenticationExtensionsClientInputs (Webauthn\AuthenticationExtensions) FeatureSet (Ramsey\Uuid) Module (Joomla\CMS\Table) sect233k1 (phpseclib3\Crypt\EC\Curves)
AuthenticationExtensionsClientOutputs (Webauthn\AuthenticationExtensions) Feed (Joomla\CMS\Feed) Module (Laminas\Diactoros) sect233r1 (phpseclib3\Crypt\EC\Curves)
AuthenticationExtensionsClientOutputsLoader (Webauthn\AuthenticationExtensions) FeedDocument (Joomla\CMS\Document) ModuleAdapter (Joomla\CMS\Installer\Adapter) sect239k1 (phpseclib3\Crypt\EC\Curves)
AuthenticationFailed (Joomla\CMS\Access\Exception) FeedEnclosure (Joomla\CMS\Document\Feed) ModuleController (Joomla\Component\Modules\Administrator\Controller) sect283k1 (phpseclib3\Crypt\EC\Curves)
AuthenticationFailedExceptionHandler (Joomla\CMS\Error\JsonApi) FeedEntry (Joomla\CMS\Feed) ModuleDispatcher (Joomla\CMS\Dispatcher) sect283r1 (phpseclib3\Crypt\EC\Curves)
AuthenticationHelper (Joomla\CMS\Helper) FeedFactory (Joomla\CMS\Feed) ModuleDispatcherFactory (Joomla\CMS\Dispatcher) sect409k1 (phpseclib3\Crypt\EC\Curves)
AuthenticationResponse (Joomla\CMS\Authentication) FeedHelper (Joomla\Module\Feed\Administrator\Helper) ModuleDispatcherFactory (Joomla\CMS\Extension\Service\Provider) sect409r1 (phpseclib3\Crypt\EC\Curves)
AuthenticationStrategyInterface (Joomla\Authentication) FeedHelper (Joomla\Module\Feed\Site\Helper) ModuleDispatcherFactoryInterface (Joomla\CMS\Dispatcher) sect571k1 (phpseclib3\Crypt\EC\Curves)
AuthenticatorAssertionResponse (Webauthn) FeedImage (Joomla\CMS\Document\Feed) ModuleHelper (Joomla\CMS\Helper) sect571r1 (phpseclib3\Crypt\EC\Curves)
AuthenticatorAssertionResponseValidator (Webauthn) FeedItem (Joomla\CMS\Document\Feed) ModuleInterface (Joomla\CMS\Extension) SectionField (Joomla\Component\Fields\Administrator\Field)
AuthenticatorAttestationResponse (Webauthn) FeedLink (Joomla\CMS\Feed) ModulelayoutField (Joomla\CMS\Form\Field) SectionNotFoundException (Joomla\CMS\Categories)
AuthenticatorAttestationResponseValidator (Webauthn) FeedParser (Joomla\CMS\Feed) ModuleLayoutRule (Joomla\CMS\Form\Rule) SeekingData (DebugBar\DataFormatter\VarDumper)
AuthenticatorData (Webauthn) FeedPerson (Joomla\CMS\Feed) ModuleModel (Joomla\Component\Modules\Administrator\Model) Select (Joomla\CMS\HTML\Helpers)
AuthenticatorResponse (Webauthn) FeedRenderer (Joomla\CMS\Error\Renderer) ModuleorderField (Joomla\CMS\Form\Field) SelectModel (Joomla\Component\Modules\Administrator\Model)
AuthenticatorSelectionCriteria (Webauthn) FeedsController (Joomla\Component\Newsfeeds\Api\Controller) ModulepositionField (Joomla\CMS\Form\Field) SelectModel (Joomla\Component\Scheduler\Administrator\Model)
AuthenticatorStatus (Webauthn\MetadataService) FeedView (Joomla\Component\Contact\Site\View\Category) ModuleRenderer (Joomla\CMS\Document\Renderer\Html) SendEmail (Joomla\CMS\MVC\Controller\Exception)
AuthorField (Joomla\CMS\Form\Field) FeedView (Joomla\Component\Content\Site\View\Featured) Modules (Joomla\Component\Modules\Administrator\Service\HTML) SendEmailExceptionHandler (Joomla\CMS\Error\JsonApi)
AuthorityInfoAccessSyntax (phpseclib3\File\ASN1\Maps) FeedView (Joomla\Component\Content\Site\View\Category) ModulesComponent (Joomla\Component\Modules\Administrator\Extension) SeparatorButton (Joomla\CMS\Toolbar\Button)
AuthorityKeyIdentifier (phpseclib3\File\ASN1\Maps) FeedView (Joomla\Component\Finder\Site\View\Search) ModulesController (Joomla\Component\Modules\Api\Controller) Sequence (FG\ASN1\Universal)
Autoloader (Laminas\ZendFrameworkBridge) FeedView (Joomla\Component\Tags\Site\View\Tag) ModulesController (Joomla\Component\Config\Site\Controller) SerializationException (Laminas\Diactoros\Exception)
b
FeedView (Joomla\Component\Tags\Site\View\Tags) ModulesController (Joomla\Component\Modules\Administrator\Controller) Request\Serializer (Laminas\Diactoros)
FetchMediaItemEvent (Joomla\Component\Media\Administrator\Event) ModulesHelper Response\Serializer (Laminas\Diactoros)
Backgroundfill (Joomla\CMS\Image\Filter) FetchMediaItemsEvent (Joomla\Component\Media\Administrator\Event) ModulesHelper (Joomla\Component\Modules\Administrator\Helper) Serializer (Jose\Component\Signature\Serializer)
BackupcodesModel (Joomla\Component\Users\Administrator\Model) FetchMediaItemUrlEvent (Joomla\Component\Media\Administrator\Event) ModulesModel (Joomla\Component\Config\Site\Model) SerializerErrorRenderer (Symfony\Component\ErrorHandler\ErrorRenderer)
BackupcodesModel (Joomla\Component\Users\Site\Model) FetchMode (Joomla\Database) ModulesModel (Joomla\Component\Modules\Administrator\Model) SerializerInterface (Tobscure\JsonApi)
BadConfigurationException (phpseclib3\Exception) FetchOrientation (Joomla\Database) ModulesModuleField (Joomla\Component\Modules\Administrator\Field) Server (Joomla\Plugin\System\Webauthn\Hotfix)
BadDecryptionException (phpseclib3\Exception) FiberCaster (Symfony\Component\VarDumper\Caster) ModulesPositioneditField (Joomla\Component\Modules\Administrator\Field) Server (Webauthn)
BadFormatException (Defuse\Crypto\Exception) FidoU2FAttestationStatementSupport (Webauthn\AttestationStatement) ModulesPositionField (Joomla\Component\Users\Administrator\Field) Server (Joomla\Plugin\Multifactorauth\Webauthn\Hotfix)
BadModeException (phpseclib3\Exception) FidoU2FAttestationStatementSupport (Joomla\Plugin\Multifactorauth\Webauthn\Hotfix) ModulesPositionField (Joomla\Component\Modules\Administrator\Field) ServerDumpCommand (Symfony\Component\VarDumper\Command)
Banner (Joomla\Component\Banners\Administrator\Service\Html) FidoU2FAttestationStatementSupport (Joomla\Plugin\System\Webauthn\Hotfix) ModulesRenderer (Joomla\CMS\Document\Renderer\Html) ServerDumper (Symfony\Component\VarDumper\Dumper)
BannerclientField (Joomla\Component\Banners\Administrator\Field) Field (Joomla\Component\Privacy\Administrator\Export) ModuletagField (Joomla\CMS\Form\Field) ServerRequest (Laminas\Diactoros)
BannerController (Joomla\Component\Banners\Administrator\Controller) FieldcontextsField (Joomla\Component\Fields\Administrator\Field) MonologCollector (DebugBar\Bridge) ServerRequest (Nyholm\Psr7)
BannerHelper (Joomla\Component\Banners\Site\Helper) FieldController (Joomla\Component\Fields\Administrator\Controller) Montgomery (phpseclib3\Crypt\EC\BaseCurves) ServerRequestFactory (Laminas\Diactoros)
BannerModel (Joomla\Component\Banners\Site\Model) FieldElement (phpseclib3\File\ASN1\Maps) Montgomery (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) ServerRequestFactoryInterface (Psr\Http\Message)
BannerModel (Joomla\Component\Banners\Administrator\Model) FieldFactory (Cron) PHP\Montgomery (phpseclib3\Math\BigInteger\Engines) ServerRequestInterface (Psr\Http\Message)
BannersComponent (Joomla\Component\Banners\Administrator\Extension) FieldFactoryInterface (Cron) MontgomeryMult (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) ServiceLocatorTest (Symfony\Contracts\Service\Test)
BannersController (Joomla\Component\Banners\Api\Controller) FieldgroupsField (Joomla\Component\Fields\Administrator\Field) MontgomeryPrivate (phpseclib3\Crypt\EC\Formats\Keys) ServiceProviderInterface
BannersController (Joomla\Component\Banners\Administrator\Controller) FieldID (phpseclib3\File\ASN1\Maps) MontgomeryPublic (phpseclib3\Crypt\EC\Formats\Keys) ServiceProviderInterface (Symfony\Contracts\Service)
BannersHelper FieldInterface (Cron) MonthField (Cron) ServiceProviderInterface (Joomla\DI)
BannersHelper (Joomla\Module\Banners\Site\Helper) FieldLayoutField (Joomla\Component\Fields\Administrator\Field) MSBLOB (phpseclib3\Crypt\RSA\Formats\Keys) ServiceSubscriberInterface (Symfony\Contracts\Service)
BannersHelper (Joomla\Component\Banners\Administrator\Helper) FieldModel (Joomla\Component\Fields\Administrator\Model) MtRandGenerator (Ramsey\Uuid\Generator) Session (Joomla\CMS\Session)
BannersModel (Joomla\Component\Banners\Site\Model) FieldsComponent (Joomla\Component\Fields\Administrator\Extension) Signer\Ecdsa\MultibyteStringConverter (Lcobucci\JWT) Session (Joomla\CMS\Service\Provider)
BannersModel (Joomla\Component\Banners\Administrator\Model) FieldsController (Joomla\Component\Fields\Administrator\Controller) MultilangstatusHelper (Joomla\Component\Languages\Administrator\Helper) Session (Joomla\Session)
BannerTable (Joomla\Component\Banners\Administrator\Table) FieldsController (Joomla\Component\Fields\Api\Controller) Multilanguage (Joomla\CMS\Language) SessionAwareWebApplicationInterface (Joomla\Application)
Barrett (phpseclib3\Math\BigInteger\Engines\BCMath\Reductions) FieldsHelper MVCComponent (Joomla\CMS\Extension) SessionCollector (Joomla\Plugin\System\Debug\DataCollector)
Barrett (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) FieldsHelper (Joomla\Component\Fields\Administrator\Helper) MVCFactory (Joomla\CMS\Extension\Service\Provider) SessionEvent (Joomla\Session)
Base (phpseclib3\Crypt\EC\BaseCurves) FieldsListPlugin (Joomla\Component\Fields\Administrator\Plugin) MVCFactory (Joomla\CMS\MVC\Factory) SessionEvents (Joomla\Session)
BCMath\Base (phpseclib3\Math\BigInteger\Engines) FieldsModel (Joomla\Component\Fields\Administrator\Model) MVCFactoryInterface (Joomla\CMS\MVC\Factory) SessionFactory (Joomla\CMS\Session)
PHP\Base (phpseclib3\Math\BigInteger\Engines) FieldsPlugin (Joomla\Component\Fields\Administrator\Plugin) MVCFactoryServiceInterface (Joomla\CMS\MVC\Factory) SessionGcCommand (Joomla\CMS\Console)
Base128 (FG\ASN1) FieldsServiceInterface (Joomla\CMS\Fields) ChangeItem\MysqlChangeItem (Joomla\CMS\Schema) SessionhandlerField (Joomla\CMS\Form\Field)
Base16EncodingTag (CBOR\Tag) FieldTable (Joomla\Component\Fields\Administrator\Table) MysqlDriver (Joomla\Database\Mysql) SessionInterface (Joomla\Session)
Base32 (Joomla\CMS\Encrypt) File (ParagonIE\Sodium) MysqlExporter (Joomla\Database\Mysql) SessionManager (Joomla\CMS\Session)
Base32 (ParagonIE\ConstantTime) File (Joomla\CMS\Filesystem) MysqliCaster (Symfony\Component\VarDumper\Caster) SessionMetadataGcCommand (Joomla\CMS\Console)
Base32Hex (ParagonIE\ConstantTime) File (Defuse\Crypto) MysqliDriver (Joomla\Database\Mysqli) SessionState (Joomla\Session)
Base64 (ParagonIE\ConstantTime) File (Joomla\Filesystem) MysqliExporter (Joomla\Database\Mysqli) Set (FG\ASN1\Universal)
Base64DotSlash (ParagonIE\ConstantTime) FileAdapter (Joomla\CMS\Installer\Adapter) MysqliImporter (Joomla\Database\Mysqli) SetConfigurationCommand (Joomla\CMS\Console)
Base64DotSlashOrdered (ParagonIE\ConstantTime) FileExistsException (Joomla\Component\Media\Administrator\Exception) MysqlImporter (Joomla\Database\Mysql) SetNewTagsEvent (Joomla\CMS\Event\Table)
Base64EncodingTag (CBOR\Tag) FileField (Joomla\CMS\Form\Field) MysqliQuery (Joomla\Database\Mysqli) SetupModel (Joomla\CMS\Installation\Model)
Base64Url (Base64Url) FileLayout (Joomla\CMS\Layout) MysqliStatement (Joomla\Database\Mysqli) SetupRenderOptions (Joomla\Component\Users\Administrator\DataShape)
Base64UrlEncodingTag (CBOR\Tag) FilelistField (Joomla\CMS\Form\Field) MysqlQuery (Joomla\Database\Mysql) SFTP (phpseclib3\Net)
Base64UrlSafe (ParagonIE\ConstantTime) FileModel (Joomla\Component\Media\Administrator\Model)
n
Signer\Ecdsa\Sha256 (Lcobucci\JWT)
BaseAccept (Negotiation) FileNotFoundException (phpseclib3\Exception) Signer\Hmac\Sha256 (Lcobucci\JWT)
BaseApplication (Joomla\CMS\Application) FileNotFoundException (Joomla\Component\Media\Administrator\Exception) Name (phpseclib3\File\ASN1\Maps) Signer\Rsa\Sha256 (Lcobucci\JWT)
BaseController (Joomla\CMS\MVC\Controller) FilePathRule (Joomla\CMS\Form\Rule) NameConstraints (phpseclib3\File\ASN1\Maps) Signer\Rsa\Sha384 (Lcobucci\JWT)
BaseDatabaseModel (Joomla\CMS\MVC\Model) Files (Joomla\CMS\Input) NamePrep (Algo26\IdnaConvert\NamePrep) Signer\Hmac\Sha384 (Lcobucci\JWT)
BaseDistance (phpseclib3\File\ASN1\Maps) Files (Joomla\Input) NamePrepData2003 (Algo26\IdnaConvert\NamePrep) Signer\Ecdsa\Sha384 (Lcobucci\JWT)
BaseInstallationModel (Joomla\CMS\Installation\Model) FileStorage (DebugBar\Storage) NamePrepData2008 (Algo26\IdnaConvert\NamePrep) Signer\Rsa\Sha512 (Lcobucci\JWT)
BaseLayout (Joomla\CMS\Layout) FileStorage (Joomla\Plugin\System\Debug\Storage) NamePrepDataInterface (Algo26\IdnaConvert\NamePrep) Signer\Ecdsa\Sha512 (Lcobucci\JWT)
BaseModel (Joomla\CMS\MVC\Model) FileStorage (Joomla\CMS\Cache\Storage) NamePrepInterface (Algo26\IdnaConvert\NamePrep) Signer\Hmac\Sha512 (Lcobucci\JWT)
Signer\BaseSigner (Lcobucci\JWT) FilesystemException (Joomla\Filesystem\Exception) NamespacedTwigProfileCollector (DebugBar\Bridge) Shortcut (Joomla\Plugin\System\Shortcut\Extension)
BashCompletionOutput (Symfony\Component\Console\Completion\Output) FilesystemHandler (Joomla\Session\Handler) NamespaceNotFoundException (Symfony\Component\Console\Exception) Sidebar (Joomla\CMS\HTML\Helpers)
Claim\Basic (Lcobucci\JWT) FilesystemHelper (Joomla\CMS\Filesystem) NamespaceNotFoundException (Joomla\Console\Exception) SignalableCommandInterface (Symfony\Component\Console\Command)
Basic (Joomla\Plugin\ApiAuthentication\Basic\Extension) Filter (Joomla\Component\Finder\Administrator\Service\HTML) NamespaceParserInterface (Joomla\CMS\Feed\Parser) SignalRegistry (Symfony\Component\Console\SignalRegistry)
BasicButton (Joomla\CMS\Toolbar\Button) FilterController (Joomla\Component\Finder\Administrator\Controller) Calculator\NativeCalculator (Brick\Math\Internal) Signature (Lcobucci\JWT)
BasicConstraints (phpseclib3\File\ASN1\Maps) FilterModel (Joomla\Component\Finder\Administrator\Model) NativeStorage (Joomla\Session\Storage) Signature (Cose\Algorithm\Signature)
BCMath (bcmath_compat) FiltersController (Joomla\Component\Finder\Administrator\Controller) Negate (Joomla\CMS\Image\Filter) Signature (Jose\Component\Signature)
BCMath (phpseclib3\Math\BigInteger\Engines) FiltersField (Joomla\Component\Config\Administrator\Field) NegativeBigIntegerTag (CBOR\Tag) SignatureAlgorithm (Jose\Component\Signature\Algorithm)
Calculator\BcMathCalculator (Brick\Math\Internal) FiltersModel (Joomla\Component\Finder\Administrator\Model) NegativeNumberException (Brick\Math\Exception) Signer\Ecdsa\SignatureConverter (Lcobucci\JWT)
BCryptHandler (Joomla\Authentication\Password) FilterTable (Joomla\Component\Finder\Administrator\Table) Negotiator (Negotiation) SignedIntegerObject (CBOR)
BCryptHandler (Joomla\CMS\Authentication\Password) Finder (Joomla\Component\Finder\Administrator\Service\HTML) Nested (Joomla\CMS\Table) SignedPublicKeyAndChallenge (phpseclib3\File\ASN1\Maps)
BeforeBatchEvent (Joomla\CMS\Event\Model) FinderComponent (Joomla\Component\Finder\Administrator\Extension) NestingException (enshrined\svgSanitize\Exceptions) Constraint\SignedWith (Lcobucci\JWT\Validation)
BeforeBindEvent (Joomla\CMS\Event\Table) FinderHelper (Joomla\Component\Finder\Site\Helper) netscape_ca_policy_url (phpseclib3\File\ASN1\Maps) Signer (Lcobucci\JWT)
BeforeCheckinEvent (Joomla\CMS\Event\Table) FinderHelper (Joomla\Module\Finder\Site\Helper) netscape_cert_type (phpseclib3\File\ASN1\Maps) SilencedErrorContext (Symfony\Component\ErrorHandler\Exception)
BeforeCheckoutEvent (Joomla\CMS\Event\Table) FinderHelper (Joomla\Component\Finder\Administrator\Helper) netscape_comment (phpseclib3\File\ASN1\Maps) SimpleMetadataStatementRepository (Webauthn\MetadataService)
BeforeCommandExecuteEvent (Joomla\Console\Event) FinderHelperLanguage NetworkAddress (phpseclib3\File\ASN1\Maps) OtherObject\SimpleObject (CBOR)
BeforeDeleteEvent (Joomla\CMS\Event\Table) FinderHelperRoute NetworkExceptionInterface (Psr\Http\Client) SingleCommandApplication (Symfony\Component\Console)
BeforeDisplayMethods (Joomla\CMS\Event\MultiFactor) FinderIndexCommand (Joomla\CMS\Console) NewsfeedController (Joomla\Component\Newsfeeds\Administrator\Controller) SingleMetadata (Webauthn\MetadataService)
BeforeExtensionBootEvent (Joomla\CMS\Event) FiniteField (phpseclib3\Math\Common) NewsfeedField (Joomla\Component\Newsfeeds\Administrator\Field\Modal) OtherObject\SinglePrecisionFloatObject (CBOR)
BeforeHitEvent (Joomla\CMS\Event\Table) Finnish (Wamania\Snowball\Stemmer) NewsfeedModel (Joomla\Component\Newsfeeds\Site\Model) SipHash (ParagonIE\Sodium\Core)
BeforeLoadEvent (Joomla\CMS\Event\Table) Fixed (Joomla\Plugin\Multifactorauth\Fixed\Extension) NewsfeedModel (Joomla\Component\Newsfeeds\Administrator\Model) SiteApplication (Joomla\CMS\Application)
BeforeMoveEvent (Joomla\CMS\Event\Table) FixedTimeProvider (Ramsey\Uuid\Provider\Time) NewsfeedsComponent (Joomla\Component\Newsfeeds\Administrator\Extension) SiteDownCommand (Joomla\CMS\Console)
BeforePublishEvent (Joomla\CMS\Event\Table) FlattenException (Symfony\Component\ErrorHandler\Exception) NewsfeedsController (Joomla\Component\Newsfeeds\Administrator\Controller) SiteMenu (Joomla\CMS\Menu)
BeforeReorderEvent (Joomla\CMS\Event\Table) Folder (Joomla\CMS\Filesystem) NewsfeedSerializer (Joomla\Component\Newsfeeds\Api\Serializer) SitePathway (Joomla\CMS\Pathway)
BeforeResetEvent (Joomla\CMS\Event\Table) Folder (Joomla\Filesystem) NewsfeedsField (Joomla\Component\Newsfeeds\Administrator\Field) SiteRouter (Joomla\CMS\Router)
BeforeStoreEvent (Joomla\CMS\Event\Table) FolderField (Joomla\Component\Installer\Administrator\Field) NewsfeedsHelper SiteRouterAwareInterface (Joomla\CMS\Router)
Behavior (Joomla\CMS\HTML\Helpers) FolderlistField (Joomla\CMS\Form\Field) NewsfeedsHelper (Joomla\Component\Newsfeeds\Administrator\Helper) SiteStatus (Joomla\Plugin\Task\SiteStatus\Extension)
Behavior (TYPO3\PharStreamWrapper) FolderPathExistsRule (Joomla\CMS\Form\Rule) NewsfeedsHelperRoute SiteUpCommand (Joomla\CMS\Console)
BigDecimal (Brick\Math) FontsField (Joomla\Plugin\Editors\CodeMirror\Field) NewsfeedsModel (Joomla\Component\Newsfeeds\Administrator\Model) Sketchy (Joomla\CMS\Image\Filter)
BigFloatTag (CBOR\Tag) Form (Joomla\CMS\Form) NewsfeedTable (Joomla\Component\Newsfeeds\Administrator\Table) SlimCollector (DebugBar\Bridge)
BigInteger (phpseclib3\Math) Form (Joomla\CMS\HTML\Helpers) nistb233 (phpseclib3\Crypt\EC\Curves) SluggerInterface (Symfony\Component\String\Slugger)
BigInteger (Jose\Component\Core\Util) Form (Joomla\CMS\Service\Provider) nistb409 (phpseclib3\Crypt\EC\Curves) Smooth (Joomla\CMS\Image\Filter)
BigInteger (Brick\Math) FormatInterface (Joomla\Registry) nistk163 (phpseclib3\Crypt\EC\Curves) SMTP (PHPMailer\PHPMailer)
BigInteger (FG\Utility) Logger\FormattedtextLogger (Joomla\CMS\Log) nistk233 (phpseclib3\Crypt\EC\Curves) RequestMethod\Socket (ReCaptcha)
BigIntegerBcmath (FG\Utility) FormatterHelper (Symfony\Component\Console\Helper) nistk283 (phpseclib3\Crypt\EC\Curves) Socket (Joomla\Http\Transport)
BigIntegerGmp (FG\Utility) FormBehavior (Joomla\CMS\HTML\Helpers) nistk409 (phpseclib3\Crypt\EC\Curves) RequestMethod\SocketPost (ReCaptcha)
BigNumber (Brick\Math) FormController (Joomla\CMS\MVC\Controller) nistp192 (phpseclib3\Crypt\EC\Curves) SocketTransport (Joomla\CMS\Http\Transport)
BigNumberConverter (Ramsey\Uuid\Converter\Number) FormFactory (Joomla\CMS\Form) nistp224 (phpseclib3\Crypt\EC\Curves) Sodium (Joomla\Crypt\Cipher)
BigNumberTimeConverter (Ramsey\Uuid\Converter\Time) FormFactoryAwareInterface (Joomla\CMS\Form) nistp256 (phpseclib3\Crypt\EC\Curves) SodiumCipher (Joomla\CMS\Crypt\Cipher)
BigRational (Brick\Math) FormFactoryInterface (Joomla\CMS\Form) nistp384 (phpseclib3\Crypt\EC\Curves) SodiumRandomGenerator (Ramsey\Uuid\Generator)
Binary (ParagonIE\ConstantTime) FormField (Joomla\CMS\Form) nistp521 (phpseclib3\Crypt\EC\Curves) SortableList (Joomla\CMS\HTML\Helpers)
Binary (phpseclib3\Crypt\EC\BaseCurves) FormFilterInterface (Joomla\CMS\Form) nistt571 (phpseclib3\Crypt\EC\Curves) SourceContextProvider (Symfony\Component\VarDumper\Dumper\ContextProvider)
BinaryField (phpseclib3\Math) FormHelper (Joomla\CMS\Form) NoConfigurationException (Symfony\Component\OptionsResolver\Exception) SpacerField (Joomla\CMS\Form\Field)
BinaryUtils (Ramsey\Uuid) FormModel (Joomla\CMS\MVC\Model) NoConstraintsGiven (Lcobucci\JWT\Validation) Spanish (Wamania\Snowball\Stemmer)
BiometricAccuracyDescriptor (Webauthn\MetadataService) FormModel (Joomla\Component\Config\Site\Model) NodeInterface (Joomla\CMS\Tree) SpecifiedECDomain (phpseclib3\File\ASN1\Maps)
BiometricStatusReport (Webauthn\MetadataService) FormModel (Joomla\Component\Contact\Site\Model) NodeProviderInterface (Ramsey\Uuid\Provider) SplCaster (Symfony\Component\VarDumper\Caster)
BitString (FG\ASN1\Universal) FormModel (Joomla\Component\Content\Site\Model) NoKeyLoadedException (phpseclib3\Exception) SplFixedArray
BLAKE2b (ParagonIE\Sodium\Core) FormModelInterface (Joomla\CMS\MVC\Model) NomenuRules (Joomla\CMS\Component\Router\Rules) SqlazureDriver (Joomla\Database\Sqlazure)
BlockCipher (phpseclib3\Crypt\Common) FormRule (Joomla\CMS\Form) None (Jose\Component\Signature\Algorithm) SqlazureQuery (Joomla\Database\Sqlazure)
Blowfish (phpseclib3\Crypt) FormValidateAssetItem (Joomla\CMS\WebAsset\AssetItem) Signer\None (Lcobucci\JWT) SqlField (Joomla\CMS\Form\Field)
BMPString (FG\ASN1\Universal) FormView (Joomla\CMS\MVC\View) NoneAttestationStatementSupport (Webauthn\AttestationStatement) SqliteDriver (Joomla\Database\Sqlite)
Boolean (FG\ASN1\Universal) ForwardedValidator (Joomla\Session\Validator) NoopWordInflector (Doctrine\Inflector) SqliteQuery (Joomla\Database\Sqlite)
BooleanRule (Joomla\CMS\Form\Rule) Fr_FRLocalise Normalise (Joomla\String) ChangeItem\SqlsrvChangeItem (Joomla\CMS\Schema)
BootableExtensionInterface (Joomla\CMS\Extension) FrameStub (Symfony\Component\VarDumper\Caster) Normalizer (Symfony\Polyfill\Intl\Normalizer) SqlsrvQuery (Joomla\Database\Sqlsrv)
Bootstrap (Joomla\CMS\HTML\Helpers) French (Wamania\Snowball\Stemmer) Normalizer SqlsrvStatement (Joomla\Database\Sqlsrv)
Bootup (voku\helper) FrenchInflector (Symfony\Component\String\Inflector) Norwegian (Wamania\Snowball\Stemmer) SSH2 (phpseclib3\Crypt\EC\Formats\Signature)
brainpoolP160r1 (phpseclib3\Crypt\EC\Curves) FromPunycode (Algo26\IdnaConvert\Punycode) NoSuchOptionException (Symfony\Component\OptionsResolver\Exception) SSH2 (phpseclib3\Crypt\DSA\Formats\Signature)
brainpoolP160t1 (phpseclib3\Crypt\EC\Curves) FromUtf8 (Algo26\IdnaConvert\EncodingHelper) NoSupportedAlgorithmsException (phpseclib3\Exception) SSH2 (phpseclib3\Net)
brainpoolP192r1 (phpseclib3\Crypt\EC\Curves) FrontendlanguageField (Joomla\CMS\Form\Field) NotAcceptable (Joomla\CMS\Application\Exception) StageController (Joomla\Component\Workflow\Administrator\Controller)
brainpoolP192t1 (phpseclib3\Crypt\EC\Curves) FtpClient (Joomla\Filesystem\Clients) NotAcceptableExceptionHandler (Joomla\CMS\Error\JsonApi) StageHelper (Joomla\Component\Workflow\Administrator\Helper)
brainpoolP224r1 (phpseclib3\Crypt\EC\Curves) FtpClient (Joomla\CMS\Client) NotAllowed (Joomla\CMS\Access\Exception) StageModel (Joomla\Component\Workflow\Administrator\Model)
brainpoolP224t1 (phpseclib3\Crypt\EC\Curves)
g
NotAllowedExceptionHandler (Joomla\CMS\Error\JsonApi) StagesController (Joomla\Component\Workflow\Administrator\Controller)
brainpoolP256r1 (phpseclib3\Crypt\EC\Curves) NotBoundException (Symfony\Component\Ldap\Exception) StagesModel (Joomla\Component\Workflow\Administrator\Model)
brainpoolP256t1 (phpseclib3\Crypt\EC\Curves) GeneralizedTime (FG\ASN1\Universal) NoteController (Joomla\Component\Users\Administrator\Controller) StageTable (Joomla\Component\Workflow\Administrator\Table)
brainpoolP320r1 (phpseclib3\Crypt\EC\Curves) GeneralName (phpseclib3\File\ASN1\Maps) NoteField (Joomla\CMS\Form\Field) StandardButton (Joomla\CMS\Toolbar\Button)
brainpoolP320t1 (phpseclib3\Crypt\EC\Curves) GeneralNames (phpseclib3\File\ASN1\Maps) NoteModel (Joomla\Component\Users\Administrator\Model) StandardDebugBar (DebugBar)
brainpoolP384r1 (phpseclib3\Crypt\EC\Curves) GeneralString (FG\ASN1\Universal) NotequalsRule (Joomla\CMS\Form\Rule) StandardRules (Joomla\CMS\Component\Router\Rules)
brainpoolP384t1 (phpseclib3\Crypt\EC\Curves) GeneralSubtree (phpseclib3\File\ASN1\Maps) NotesController (Joomla\Component\Users\Administrator\Controller) Poly1305\State (ParagonIE\Sodium\Core)
brainpoolP512r1 (phpseclib3\Crypt\EC\Curves) GeneralSubtrees (phpseclib3\File\ASN1\Maps) NotesModel (Joomla\Component\Users\Administrator\Model) StatefulModelInterface (Joomla\CMS\MVC\Model)
brainpoolP512t1 (phpseclib3\Crypt\EC\Curves) GenericDataException (Joomla\CMS\MVC\View) NoteTable (Joomla\Component\Users\Administrator\Table) StatementInterface (Joomla\Database)
BranchesField (Joomla\Component\Finder\Administrator\Field) GenericEvent (Joomla\CMS\Event) NotFoundException (Wamania\Snowball) StatisticsModel (Joomla\Component\Finder\Administrator\Model)
BreadcrumbsHelper (Joomla\Module\Breadcrumbs\Site\Helper) GenericLanguageInflectorFactory (Doctrine\Inflector) NotFoundExceptionInterface (Psr\Container) StatsAdminHelper (Joomla\Module\StatsAdmin\Administrator\Helper)
OtherObject\BreakObject (CBOR) GenericLinkProvider (Symfony\Component\WebLink) NoticeReference (phpseclib3\File\ASN1\Maps) StatsHelper (Joomla\Module\Stats\Site\Helper)
Brightness (Joomla\CMS\Image\Filter) GenericLinkProvider (Fig\Link) NotifyActionLog (Joomla\CMS\Event\MultiFactor) Status (Joomla\Component\Privacy\Administrator\Removal)
Browser (Joomla\CMS\Environment) OtherObject\GenericObject (CBOR) NotImplementedException (FG\ASN1\Exception) Status (Joomla\Component\Scheduler\Administrator\Task)
Buffer (Joomla\Filesystem) GenericTag (CBOR\Tag) NullLogger (Psr\Log) StatusField (Joomla\CMS\Form\Field)
BufferedOutput (Symfony\Component\Console\Output) German (Wamania\Snowball\Stemmer) NullObject (FG\ASN1\Universal) StatusReport (Webauthn\MetadataService)
BufferingLogger (Symfony\Component\ErrorHandler) GetConfigurationCommand (Joomla\CMS\Console) OtherObject\NullObject (CBOR) Stdout (Joomla\CMS\Application\CLI\Output)
BufferStreamHandler (Joomla\CMS\Utility) GetIconEvent (Joomla\CMS\Event\QuickIcon) NullOutput (Symfony\Component\Console\Output) Stem (Wamania\Snowball\Stemmer)
Builder (Lcobucci\JWT) GetMethod (Joomla\CMS\Event\MultiFactor) NullOutputFormatter (Symfony\Component\Console\Formatter) Stemmer (Wamania\Snowball\Stemmer)
BCMath\BuiltIn (phpseclib3\Math\BigInteger\Engines) GetSetup (Joomla\CMS\Event\MultiFactor) NullOutputFormatterStyle (Symfony\Component\Console\Formatter) StemmerFactory (Wamania\Snowball)
BuiltInDomainDefinedAttribute (phpseclib3\File\ASN1\Maps) GithubActionReporter (Symfony\Component\Console\CI) Number (Joomla\CMS\HTML\Helpers) StemmerManager (Wamania\Snowball)
BuiltInDomainDefinedAttributes (phpseclib3\File\ASN1\Maps) GMP (phpseclib3\Math\BigInteger\Engines) NumberConverterInterface (Ramsey\Uuid\Converter) StorageInterface (DebugBar\Storage)
BuiltInStandardAttributes (phpseclib3\File\ASN1\Maps) Calculator\GmpCalculator (Brick\Math\Internal) NumberField (Joomla\CMS\Form\Field) StorageInterface (Joomla\Session)
ByteString (Symfony\Component\String) GmpCaster (Symfony\Component\VarDumper\Caster) NumberFormatException (Brick\Math\Exception) Stream (Joomla\Http\Transport)
ByteStringObject (CBOR) Grapheme (Symfony\Polyfill\Intl\Grapheme) NumberRule (Joomla\CMS\Form\Rule) Stream (Joomla\CMS\Filesystem)
ByteStringWithChunkObject (CBOR) GraphicString (FG\ASN1\Universal) NumericString (FG\ASN1\Universal) SFTP\Stream (phpseclib3\Net)
Bzip2 (Joomla\Archive) Grayscale (Joomla\CMS\Image\Filter) NumericUserIdentifier (phpseclib3\File\ASN1\Maps) Stream (Laminas\Diactoros)
c
Claim\GreaterOrEqualsTo (Lcobucci\JWT)
o
Stream (Nyholm\Psr7)
Grid (Joomla\CMS\HTML\Helpers) Stream (CBOR)
CaBundle (Composer\CaBundle) GroupController (Joomla\Component\Users\Administrator\Controller) OAuth (PHPMailer\PHPMailer) Stream (Joomla\Filesystem)
Cache (Joomla\Plugin\System\Cache\Extension) GroupController (Joomla\Component\Fields\Administrator\Controller) OAuthCallbackEvent (Joomla\Component\Media\Administrator\Event) StreamableInputInterface (Symfony\Component\Console\Input)
Cache (Joomla\CMS\Cache) GroupedlistField (Joomla\CMS\Form\Field) OAuthTokenProvider (PHPMailer\PHPMailer) StreamCipher (phpseclib3\Crypt\Common)
CacheCacheCollector (DebugBar\Bridge) GroupModel (Joomla\Component\Users\Administrator\Model) ObjectCreateEvent (Joomla\CMS\Event\Table) StreamFactory (Laminas\Diactoros)
CacheConnectingException (Joomla\CMS\Cache\Exception) GroupModel (Joomla\Component\Fields\Administrator\Model) ObjectDescriptor (FG\ASN1\Universal) StreamFactory (Http\Message)
CacheController (Joomla\CMS\Service\Provider) GroupparentField (Joomla\Component\Users\Administrator\Field) ObjectIdentifier (FG\ASN1\Universal) StreamFactoryInterface (Psr\Http\Message)
CacheController (Joomla\CMS\Cache) GroupsController (Joomla\Component\Users\Administrator\Controller) OctetString (FG\ASN1\Universal) StreamInterface (Psr\Http\Message)
CacheControllerFactory (Joomla\CMS\Cache) GroupsController (Joomla\Component\Fields\Api\Controller) OID (FG\ASN1) StreamOutput (Symfony\Component\Console\Output)
CacheControllerFactoryAwareInterface (Joomla\CMS\Cache) GroupsController (Joomla\Component\Fields\Administrator\Controller) OkpKey (Cose\Key) StreamString (Joomla\CMS\Filesystem\Streams)
CacheControllerFactoryInterface (Joomla\CMS\Cache) GroupsController (Joomla\Component\Users\Api\Controller) OneAsymmetricKey (phpseclib3\File\ASN1\Maps) StreamTransport (Joomla\CMS\Http\Transport)
Cached (ParagonIE\Sodium\Core\Curve25519\Ge) GroupsModel (Joomla\Component\Users\Administrator\Model) OnGetApiAttributes (Joomla\CMS\Serializer\Events) StringCodec (Ramsey\Uuid\Codec)
CachedWordInflector (Doctrine\Inflector) GroupsModel (Joomla\Component\Fields\Administrator\Model) OnGetApiFields (Joomla\CMS\MVC\View\Event) StringController (Joomla\CMS\Filesystem\Support)
CacheExceptionInterface (Joomla\CMS\Cache\Exception) GroupTable (Joomla\Component\Fields\Administrator\Table) OnGetApiRelation (Joomla\CMS\Serializer\Events) StringController (Joomla\Filesystem\Support)
CachehandlerField (Joomla\CMS\Form\Field) GuidStringCodec (Ramsey\Uuid\Codec) OpenHandler (DebugBar) StringHelper (Joomla\String)
CacheModel (Joomla\Component\Cache\Administrator\Model) Gzip (Joomla\Archive) OpensearchDocument (Joomla\CMS\Document) StringHelper (Joomla\CMS\HTML\Helpers)
CacheStorage (Joomla\CMS\Cache)
h
OpensearchImage (Joomla\CMS\Document\Opensearch) StringInput (Symfony\Component\Console\Input)
CacheStorageHelper (Joomla\CMS\Cache\Storage) OpensearchUrl (Joomla\CMS\Document\Opensearch) Strings (phpseclib3\Common\Functions)
CachingLanguageFactory (Joomla\CMS\Language) Curve25519\H (ParagonIE\Sodium\Core) OpensearchView (Joomla\Component\Finder\Site\View\Search) StringsController (Joomla\Component\Languages\Administrator\Controller)
Calculator (Brick\Math\Internal) OtherObject\HalfPrecisionFloatObject (CBOR) OpenSSH (phpseclib3\Crypt\Common\Formats\Keys) StringsController (Joomla\Component\Languages\Api\Controller)
CalendarField (Joomla\CMS\Form\Field) HandlerInterface (Joomla\Authentication\Password) OpenSSH (phpseclib3\Crypt\EC\Formats\Keys) StringsModel (Joomla\Component\Languages\Administrator\Model)
CalendarRule (Joomla\CMS\Form\Rule) HandlerInterface (Joomla\Session) OpenSSH (phpseclib3\Crypt\RSA\Formats\Keys) StringStream (Webauthn)
Callback (Joomla\CMS\Event\MultiFactor) Hash (phpseclib3\Crypt) OpenSSH (phpseclib3\Crypt\DSA\Formats\Keys) StringStream (CBOR)
CallbackController (Joomla\Component\Users\Administrator\Controller) Hash (Jose\Component\Core\Util) Signer\OpenSSL (Lcobucci\JWT) Stream\StringWrapper (Joomla\Filesystem)
CallbackController (Joomla\Component\Users\Site\Controller) HashAlgorithm (phpseclib3\File\ASN1\Maps) OpenSSL (Joomla\CMS\Encrypt\AES) Stub (TYPO3\PharStreamWrapper\Phar)
CallbackController (Joomla\CMS\Cache\Controller) HChaCha20 (ParagonIE\Sodium\Core) OpenSSL (phpseclib3\Math\BigInteger\Engines) Stub (Symfony\Component\VarDumper\Cloner)
Logger\CallbackLogger (Joomla\CMS\Log) HeaderSecurity (Laminas\Diactoros) BCMath\OpenSSL (phpseclib3\Math\BigInteger\Engines) StubCaster (Symfony\Component\VarDumper\Caster)
CallbackStream (Laminas\Diactoros) HeadertagField (Joomla\CMS\Form\Field) OpenSSL (Joomla\Crypt\Cipher) StyleController (Joomla\Component\Templates\Administrator\Controller)
CannotDecodeContent (Lcobucci\JWT\Encoding) HeadRenderer (Joomla\CMS\Document\Renderer\Html) PHP\OpenSSL (phpseclib3\Math\BigInteger\Engines) StyleInterface (Symfony\Component\Console\Style)
CannotEncodeContent (Lcobucci\JWT\Encoding) Help (Joomla\CMS\Help) OpenSslGenerator (Ramsey\Uuid\Generator) StyleModel (Joomla\Component\Templates\Administrator\Model)
CannotPerformOperationException HelpButton (Joomla\CMS\Toolbar\Button) OptionConfigurator (Symfony\Component\OptionsResolver) StylesController (Joomla\Component\Templates\Api\Controller)
Signer\CannotSignPayload (Lcobucci\JWT) HelpCommand (Symfony\Component\Console\Command) OptionDefinitionException (Symfony\Component\OptionsResolver\Exception) StylesController (Joomla\Component\Templates\Administrator\Controller)
CapabilitiesModel (Joomla\Component\Privacy\Administrator\Model) HelpCommand (Joomla\Console\Command) Options (Symfony\Component\OptionsResolver) StylesModel (Joomla\Component\Templates\Administrator\Model)
Captcha (Joomla\CMS\Captcha) Helper (Symfony\Component\Console\Helper) OptionsResolver (Symfony\Component\OptionsResolver) StylesRenderer (Joomla\CMS\Document\Renderer\Html)
CaptchaField (Joomla\CMS\Form\Field) Helper (TYPO3\PharStreamWrapper) OptionsResolverIntrospector (Symfony\Component\OptionsResolver\Debug) StyleTable (Joomla\Component\Templates\Administrator\Table)
CaptchaRule (Joomla\CMS\Form\Rule) Helper (Joomla\Component\Finder\Administrator\Indexer) OptionsRule (Joomla\CMS\Form\Rule) SubfieldsField (Joomla\Component\Fields\Administrator\Field)
Captive (Joomla\CMS\Event\MultiFactor) Helper (enshrined\svgSanitize) ORAddress (phpseclib3\File\ASN1\Maps) SubformField (Joomla\CMS\Form\Field)
CaptiveController (Joomla\Component\Users\Administrator\Controller) Helper (Joomla\Filesystem) OrderedTimeCodec (Ramsey\Uuid\Codec) SubformRule (Joomla\CMS\Form\Rule)
CaptiveController (Joomla\Component\Users\Site\Controller) HelperFactory (Joomla\CMS\Extension\Service\Provider) OrderingField (Joomla\CMS\Form\Field) Subject (enshrined\svgSanitize\ElementReference)
CaptiveModel (Joomla\Component\Users\Administrator\Model) HelperFactory (Joomla\CMS\Helper) OrganizationalUnitNames (phpseclib3\File\ASN1\Maps) SubjectAlternativeNames (FG\X509\SAN)
CaptiveModel (Joomla\Component\Users\Site\Model) HelperFactoryAwareInterface (Joomla\CMS\Helper) OrganizationName (phpseclib3\File\ASN1\Maps) SubjectAltName (phpseclib3\File\ASN1\Maps)
CaptiveRenderOptions (Joomla\Component\Users\Administrator\DataShape) HelperFactoryInterface (Joomla\CMS\Helper) OtherObject (CBOR) SubjectDirectoryAttributes (phpseclib3\File\ASN1\Maps)
Caster (Symfony\Component\VarDumper\Caster) HelperInterface (Symfony\Component\Console\Helper) OtherObject\OtherObjectManager (CBOR) SubjectInfoAccessSyntax (phpseclib3\File\ASN1\Maps)
Catalan (Wamania\Snowball\Stemmer) HelperSet (Symfony\Component\Console\Helper) OtherPrimeInfo (phpseclib3\File\ASN1\Maps) SubjectPublicKeyInfo (phpseclib3\File\ASN1\Maps)
Categories (Joomla\CMS\Categories) HelpModel (Joomla\Component\Admin\Administrator\Model) OtherPrimeInfos (phpseclib3\File\ASN1\Maps) SubscribedService (Symfony\Contracts\Service\Attribute)
CategoriesComponent (Joomla\Component\Categories\Administrator\Extension) Hex (ParagonIE\ConstantTime) OutOfMemoryError (Symfony\Component\ErrorHandler\Error) SubscriberInterface (Joomla\Event)
CategoriesController (Joomla\Component\Categories\Administrator\Controller) HiddenField (Joomla\CMS\Form\Field) Output (Symfony\Component\Console\Output) Substitution (Doctrine\Inflector\Rules)
CategoriesController (Joomla\Component\Categories\Api\Controller) HistoryController (Joomla\Component\Contenthistory\Administrator\Controller) OutputController (Joomla\CMS\Cache\Controller) Substitutions (Doctrine\Inflector\Rules)
CategoriesHelper HistoryController (Joomla\Component\Contenthistory\Api\Controller) OutputFilter (Joomla\CMS\Filter) Suggestion (Symfony\Component\Console\Completion)
CategoriesHelper (Joomla\Component\Categories\Administrator\Helper) HistoryModel (Joomla\Component\Contenthistory\Administrator\Model) OutputFilter (Joomla\Filter) SuggestionsController (Joomla\Component\Finder\Site\Controller)
CategoriesModel (Joomla\Component\Categories\Administrator\Model) Signer\Hmac (Lcobucci\JWT) OutputFormatter (Symfony\Component\Console\Formatter) SuggestionsModel (Joomla\Component\Finder\Site\Model)
CategoriesModel (Joomla\Component\Contact\Site\Model) Hmac (Cose\Algorithm\Mac) OutputFormatterInterface (Symfony\Component\Console\Formatter) Swedish (Wamania\Snowball\Stemmer)
CategoriesModel (Joomla\Component\Content\Site\Model) HMAC (Jose\Component\Signature\Algorithm) OutputFormatterStyle (Symfony\Component\Console\Formatter) SwiftLogCollector (DebugBar\Bridge\SwiftMailer)
CategoriesModel (Joomla\Component\Newsfeeds\Site\Model) HoldInstructionCode (phpseclib3\File\ASN1\Maps) OutputFormatterStyleInterface (Symfony\Component\Console\Formatter) SwiftMailCollector (DebugBar\Bridge\SwiftMailer)
CategoriesView (Joomla\CMS\MVC\View) HoursField (Cron) OutputFormatterStyleStack (Symfony\Component\Console\Formatter) SymfonyCaster (Symfony\Component\VarDumper\Caster)
Category (Joomla\CMS\HTML\Helpers) HS1 (Jose\Component\Signature\Algorithm) OutputInterface (Symfony\Component\Console\Output) SymfonyQuestionHelper (Symfony\Component\Console\Helper)
Category (Joomla\Component\Banners\Site\Service) HS256 (Cose\Algorithm\Mac) OutputStyle (Symfony\Component\Console\Style) SymfonyStyle (Symfony\Component\Console\Style)
Category (Joomla\Component\Contact\Site\Service) HS256 (Jose\Component\Signature\Algorithm) OverrideController (Joomla\Component\Languages\Administrator\Controller) SymmetricKey (Cose\Key)
Category (Joomla\CMS\Table) HS256_64 (Jose\Component\Signature\Algorithm) OverrideModel (Joomla\Component\Languages\Administrator\Model) SymmetricKey (phpseclib3\Crypt\Common)
Category (Joomla\Component\Content\Site\Service) HS256Truncated64 (Cose\Algorithm\Mac) OverridesController (Joomla\Component\Languages\Administrator\Controller) SyndicateHelper (Joomla\Module\Syndicate\Site\Helper)
Category (Joomla\Component\Newsfeeds\Site\Service) HS384 (Jose\Component\Signature\Algorithm) OverridesController (Joomla\Component\Languages\Api\Controller) SysinfoModel (Joomla\Component\Admin\Administrator\Model)
CategoryAssociationHelper (Joomla\Component\Categories\Administrator\Helper) HS384 (Cose\Algorithm\Mac) OverridesModel (Joomla\Component\Languages\Administrator\Model) Logger\SyslogLogger (Joomla\CMS\Log)
CategoryController (Joomla\Component\Categories\Administrator\Controller) HS512 (Cose\Algorithm\Mac)
p
System (Joomla\Component\Admin\Administrator\Service\HTML)
CategoryeditField (Joomla\Component\Categories\Administrator\Field) HS512 (Jose\Component\Signature\Algorithm) SystemNodeProvider (Ramsey\Uuid\Provider\Node)
CategoryFactory (Joomla\CMS\Extension\Service\Provider) HSalsa20 (ParagonIE\Sodium\Core) P1p1 (ParagonIE\Sodium\Core\Curve25519\Ge) SystemTimeProvider (Ramsey\Uuid\Provider\Time)
CategoryFactory (Joomla\CMS\Categories) Parser\Html (Joomla\Component\Finder\Administrator\Indexer) P2 (ParagonIE\Sodium\Core\Curve25519\Ge)
t
CategoryFactoryInterface (Joomla\CMS\Categories) HtmlDescriptor (Symfony\Component\VarDumper\Command\Descriptor) P3 (ParagonIE\Sodium\Core\Curve25519\Ge)
CategoryFeedView (Joomla\CMS\MVC\View) HtmlDocument (Joomla\CMS\Document) PackageAdapter (Joomla\CMS\Installer\Adapter) T61String (FG\ASN1\Universal)
CategoryField (Joomla\CMS\Form\Field) HtmlDumper (Symfony\Component\VarDumper\Dumper) PackageField (Joomla\Component\Installer\Administrator\Field) Table (Symfony\Component\Console\Helper)
CategoryField (Joomla\Component\Categories\Administrator\Field\Modal) HtmlErrorRenderer (Symfony\Component\ErrorHandler\ErrorRenderer) Manifest\PackageManifest (Joomla\CMS\Installer) Table (Joomla\CMS\Table)
CategoryInterface (Joomla\CMS\Categories) HTMLHelper (Joomla\CMS\HTML) PackedAttestationStatementSupport (Webauthn\AttestationStatement) TableCell (Symfony\Component\Console\Helper)
CategoryModel (Joomla\Component\Categories\Administrator\Model) HTMLRegistry (Joomla\CMS\Service\Provider) PageController (Joomla\CMS\Cache\Controller) TableCellStyle (Symfony\Component\Console\Helper)
CategoryModel (Joomla\Component\Contact\Site\Model) HtmlRenderer (Joomla\CMS\Error\Renderer) Pagination (Joomla\CMS\Pagination) TableColumnsAssetItem (Joomla\CMS\WebAsset\AssetItem)
CategoryModel (Joomla\Component\Content\Site\Model) Response\HtmlResponse (Laminas\Diactoros) PaginationObject (Joomla\CMS\Pagination) TableInterface (Joomla\CMS\Table)
CategoryModel (Joomla\Component\Newsfeeds\Site\Model) HtmlView (Joomla\Component\Banners\Administrator\View\Banners) ParagonIE_Sodium_Compat TableRows (Symfony\Component\Console\Helper)
CategoryNode (Joomla\CMS\Categories) HtmlView (Joomla\Component\Tags\Administrator\View\Tag) ParagonIE_Sodium_Core32_BLAKE2b TableSeparator (Symfony\Component\Console\Helper)
CategoryServiceInterface (Joomla\CMS\Categories) HtmlView (Joomla\Component\Tags\Administrator\View\Tags) ParagonIE_Sodium_Core32_ChaCha20 TableStyle (Symfony\Component\Console\Helper)
CategoryTable (Joomla\Component\Categories\Administrator\Table) HtmlView (Joomla\Component\Banners\Administrator\View\Client) ParagonIE_Sodium_Core32_ChaCha20_Ctx Tag (Joomla\CMS\HTML\Helpers)
CategoryView (Joomla\CMS\MVC\View) HtmlView (Joomla\Component\Banners\Administrator\View\Download) ParagonIE_Sodium_Core32_ChaCha20_IetfCtx TagController (Joomla\Component\Tags\Administrator\Controller)
CBORObject (CBOR) HtmlView (Joomla\Component\Templates\Administrator\View\Style) ParagonIE_Sodium_Core32_Curve25519 TagField (Joomla\CMS\Form\Field)
Certificate (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Templates\Administrator\View\Styles) ParagonIE_Sodium_Core32_Curve25519_Fe Taggable (Joomla\Plugin\Behaviour\Taggable\Extension)
CertificateExtensions (FG\X509) HtmlView (Joomla\Component\Templates\Administrator\View\Template) ParagonIE_Sodium_Core32_Curve25519_Ge_Cached TaggableTableInterface (Joomla\CMS\Tag)
CertificateIssuer (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Installer\Administrator\View\Database) ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 TaggedValue (Symfony\Component\Yaml\Tag)
CertificateList (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Templates\Administrator\View\Templates) ParagonIE_Sodium_Core32_Curve25519_Ge_P2 TagInterface (enshrined\svgSanitize\data)
CertificatePolicies (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Banners\Administrator\View\Clients) ParagonIE_Sodium_Core32_Curve25519_Ge_P3 TagModel (Joomla\Component\Tags\Site\Model)
CertificateSerialNumber (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Installer\Administrator\View\Discover) ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp TagModel (Joomla\Component\Tags\Administrator\Model)
CertificateSubject (FG\X509) HtmlView (Joomla\Component\Installer\Administrator\View\Install) ParagonIE_Sodium_Core32_Curve25519_H TagObject (CBOR)
CertificateToolbox (Webauthn) HtmlView (Joomla\Component\Installer\Administrator\View\Installer) ParagonIE_Sodium_Core32_Ed25519 TagObjectManager (CBOR\Tag)
CertificateTrustPath (Webauthn\TrustPath) HtmlView (Joomla\Component\Contact\Site\View\Featured) ParagonIE_Sodium_Core32_HChaCha20 TagsComponent (Joomla\Component\Tags\Administrator\Extension)
CertificationRequest (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Banners\Administrator\View\Tracks) ParagonIE_Sodium_Core32_HSalsa20 TagsController (Joomla\Component\Tags\Administrator\Controller)
CertificationRequestInfo (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Installer\Administrator\View\Languages) ParagonIE_Sodium_Core32_Int32 TagsController (Joomla\Component\Tags\Api\Controller)
CertPolicyId (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Installer\Administrator\View\Manage) ParagonIE_Sodium_Core32_Int64 TagsController (Joomla\Component\Tags\Site\Controller)
ChaCha20 (ParagonIE\Sodium\Core) HtmlView (Joomla\Component\Installer\Administrator\View\Update) ParagonIE_Sodium_Core32_Poly1305 TagServiceInterface (Joomla\CMS\Tag)
ChaCha20 (phpseclib3\Crypt) HtmlView (Joomla\Component\Installer\Administrator\View\Updatesite) ParagonIE_Sodium_Core32_Poly1305_State TagsHelper (Joomla\CMS\Helper)
ChainedHandler (Joomla\CMS\Authentication\Password) HtmlView (Joomla\Component\Installer\Administrator\View\Updatesites) ParagonIE_Sodium_Core32_Salsa20 TagsHelperRoute
ChainedMonitor (Joomla\Database\Monitor) HtmlView (Joomla\Component\Installer\Administrator\View\Warnings) ParagonIE_Sodium_Core32_SecretStream_State TagsModel (Joomla\Component\Tags\Site\Model)
ChangeItem (Joomla\CMS\Schema) HtmlView (Joomla\Component\Messages\Administrator\View\Messages) ParagonIE_Sodium_Core32_SipHash TagsModel (Joomla\Component\Tags\Administrator\Model)
Changelog (Joomla\CMS\Changelog) HtmlView (Joomla\Component\Joomlaupdate\Administrator\View\Joomlaupdate) ParagonIE_Sodium_Core32_Util TagsPopularHelper (Joomla\Module\TagsPopular\Site\Helper)
ChangeSet (Joomla\CMS\Schema) HtmlView (Joomla\Component\Privacy\Site\View\Remind) ParagonIE_Sodium_Core32_X25519 TagsSimilarHelper (Joomla\Module\TagsSimilar\Site\Helper)
ChangeUserPasswordCommand (Joomla\CMS\Console) HtmlView (Joomla\Component\Joomlaupdate\Administrator\View\Update) ParagonIE_Sodium_Core32_XChaCha20 TagTable (Joomla\Component\Tags\Administrator\Table)
Characteristic_two (phpseclib3\File\ASN1\Maps) HtmlView (Joomla\Component\Joomlaupdate\Administrator\View\Upload) ParagonIE_Sodium_Core32_XSalsa20 Tar (Joomla\Archive)
CharacterString (FG\ASN1\Universal) HtmlView (Joomla\Component\Content\Administrator\View\Article) ParagonIE_Sodium_Core_Base64_Common Task (Joomla\Component\Scheduler\Administrator\Task)
CharsetNegotiator (Negotiation) HtmlView (Joomla\Component\Content\Administrator\View\Articles) ParagonIE_Sodium_Core_Base64_Original TaskController (Joomla\Component\Scheduler\Administrator\Controller)
CheckboxesField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Content\Administrator\View\Featured) ParagonIE_Sodium_Core_Base64_UrlSafe TaskModel (Joomla\Component\Scheduler\Administrator\Model)
CheckboxField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Cache\Administrator\View\Cache) ParagonIE_Sodium_Core_BLAKE2b TaskOption (Joomla\Component\Scheduler\Administrator\Task)
CheckEvent (Joomla\CMS\Event\Table) HtmlView (Joomla\Component\Users\Administrator\View\Captive) ParagonIE_Sodium_Core_ChaCha20 TaskOptions (Joomla\Component\Scheduler\Administrator\Task)
Checkfiles (Joomla\Plugin\Task\Checkfiles\Extension) HtmlView (Joomla\Component\Users\Administrator\View\Debuggroup) ParagonIE_Sodium_Core_ChaCha20_Ctx TasksController (Joomla\Component\Scheduler\Administrator\Controller)
CheckIfRehashNeededHandlerInterface (Joomla\CMS\Authentication\Password) HtmlView (Joomla\Component\Users\Administrator\View\Group) ParagonIE_Sodium_Core_ChaCha20_IetfCtx TasksListCommand (Joomla\CMS\Console)
CheckinCheckout (Joomla\CMS\MVC\Controller\Exception) HtmlView (Joomla\Component\Users\Administrator\View\Debuguser) ParagonIE_Sodium_Core_Curve25519 TasksModel (Joomla\Component\Scheduler\Administrator\Model)
CheckinCheckoutExceptionHandler (Joomla\CMS\Error\JsonApi) HtmlView (Joomla\Component\Users\Administrator\View\Groups) ParagonIE_Sodium_Core_Curve25519_Fe TasksRunCommand (Joomla\CMS\Console)
CheckinModel (Joomla\Component\Checkin\Administrator\Model) HtmlView (Joomla\Component\Users\Administrator\View\Level) ParagonIE_Sodium_Core_Curve25519_Ge_Cached TasksStateCommand (Joomla\CMS\Console)
CheckJoomlaUpdatesCommand (Joomla\CMS\Console) HtmlView (Joomla\Component\Users\Administrator\View\Levels) ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 TaskStateField (Joomla\Component\Scheduler\Administrator\Field)
CheckLdapCredentialsListener (Symfony\Component\Ldap\Security) HtmlView (Joomla\Component\Users\Administrator\View\Mail) ParagonIE_Sodium_Core_Curve25519_Ge_P2 TaskTable (Joomla\Component\Scheduler\Administrator\Table)
ChecksModel (Joomla\CMS\Installation\Model) HtmlView (Joomla\Component\Users\Administrator\View\Method) ParagonIE_Sodium_Core_Curve25519_Ge_P3 TaskTypeField (Joomla\Component\Scheduler\Administrator\Field)
CheckUpdatesCommand (Joomla\CMS\Console) HtmlView (Joomla\Component\Users\Administrator\View\Methods) ParagonIE_Sodium_Core_Curve25519_Ge_Precomp Taxonomy (Joomla\Component\Finder\Administrator\Indexer)
ChoiceQuestion (Symfony\Component\Console\Question) HtmlView (Joomla\Component\Users\Administrator\View\Note) ParagonIE_Sodium_Core_Curve25519_H TBSCertificate (phpseclib3\File\ASN1\Maps)
ChromestyleField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Users\Administrator\View\Notes) ParagonIE_Sodium_Core_Ed25519 TBSCertList (phpseclib3\File\ASN1\Maps)
CipherInterface (Joomla\Crypt) HtmlView (Joomla\Component\Users\Administrator\View\Users) ParagonIE_Sodium_Core_HChaCha20 Telephone (Joomla\CMS\HTML\Helpers)
Claim (Lcobucci\JWT) HtmlView (Joomla\Component\Users\Administrator\View\User) ParagonIE_Sodium_Core_HSalsa20 TelephoneField (Joomla\CMS\Form\Field)
Classic (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) HtmlView (Joomla\Component\Menus\Administrator\View\Item) ParagonIE_Sodium_Core_Poly1305 TelFilter (Joomla\CMS\Form\Filter)
ClassLoader (Composer\Autoload) HtmlView (Joomla\Component\Languages\Administrator\View\Installed) ParagonIE_Sodium_Core_Poly1305_State TelRule (Joomla\CMS\Form\Rule)
ClassLoader (Joomla\CMS\Autoload) HtmlView (Joomla\Component\Languages\Administrator\View\Language) ParagonIE_Sodium_Core_Ristretto255 TemplateAdapter (Joomla\CMS\Installer\Adapter)
ClassNotFoundError (Symfony\Component\ErrorHandler\Error) HtmlView (Joomla\Component\Languages\Administrator\View\Languages) ParagonIE_Sodium_Core_Salsa20 TemplateController (Joomla\Component\Mails\Administrator\Controller)
ClassNotFoundErrorEnhancer (Symfony\Component\ErrorHandler\ErrorEnhancer) HtmlView (Joomla\Component\Contact\Site\View\Form) ParagonIE_Sodium_Core_SecretStream_State TemplateController (Joomla\Component\Templates\Administrator\Controller)
ClassStub (Symfony\Component\VarDumper\Caster) HtmlView (Joomla\Component\Languages\Administrator\View\Multilangstatus) ParagonIE_Sodium_Core_SipHash TemplateHelper
CleanCacheCommand (Joomla\CMS\Console) HtmlView (Joomla\Component\Languages\Administrator\View\Override) ParagonIE_Sodium_Core_Util TemplateHelper (Joomla\Component\Templates\Administrator\Helper)
CleanupModel (Joomla\CMS\Installation\Model) HtmlView (Joomla\Component\Languages\Administrator\View\Overrides) ParagonIE_Sodium_Core_X25519 TemplatelocationField (Joomla\Component\Templates\Administrator\Field)
Cli (Joomla\CMS\Input) HtmlView (Joomla\Component\Workflow\Administrator\View\Stage) ParagonIE_Sodium_Core_XChaCha20 TemplateModel (Joomla\Component\Templates\Administrator\Model)
CliApplication (Joomla\CMS\Application) HtmlView (Joomla\Component\Contenthistory\Administrator\View\Compare) ParagonIE_Sodium_Core_XSalsa20 TemplateModel (Joomla\Component\Mails\Administrator\Model)
ClicksField (Joomla\Component\Banners\Administrator\Field) HtmlView (Joomla\Component\Associations\Administrator\View\Association) ParagonIE_Sodium_Crypto TemplatenameField (Joomla\Component\Templates\Administrator\Field)
CliContextProvider (Symfony\Component\VarDumper\Dumper\ContextProvider) HtmlView (Joomla\Component\Workflow\Administrator\View\Workflow) ParagonIE_Sodium_Crypto32 TemplateParser (FG\ASN1)
CliDescriptor (Symfony\Component\VarDumper\Command\Descriptor) HtmlView (Joomla\Component\Workflow\Administrator\View\Workflows) ParagonIE_Sodium_File Templates (Joomla\Component\Templates\Administrator\Service\HTML)
CliDumper (Symfony\Component\VarDumper\Dumper) HtmlView (Joomla\Component\Login\Administrator\View\Login) DH\Parameters (phpseclib3\Crypt) TemplatesComponent (Joomla\Component\Templates\Administrator\Extension)
Client (Joomla\OAuth1) HtmlView (Joomla\Component\Contenthistory\Administrator\View\History) EC\Parameters (phpseclib3\Crypt) TemplatesController (Joomla\Component\Config\Site\Controller)
Client (Joomla\OAuth2) HtmlView (Joomla\Component\Contenthistory\Administrator\View\Preview) Parameters (Tobscure\JsonApi) TemplatesHelper (Joomla\Component\Templates\Administrator\Helper)
ClientController (Joomla\Component\Banners\Administrator\Controller) HtmlView (Joomla\Component\Content\Site\View\Categories) DSA\Parameters (phpseclib3\Crypt) TemplatesHelper
ClientExceptionInterface (Psr\Http\Client) HtmlView (Joomla\Component\Cpanel\Administrator\View\Cpanel) ParameterType (Joomla\Database) TemplatesListField (Joomla\Plugin\Editors\TinyMCE\Field)
ClientHelper (Joomla\CMS\Client) HtmlView (Joomla\Component\Mails\Administrator\View\Template) Parsable (FG\ASN1) TemplatesModel (Joomla\Component\Mails\Administrator\Model)
ClientInterface (Psr\Http\Client) HtmlView (Joomla\Component\Mails\Administrator\View\Templates) ParseException (Symfony\Component\Yaml\Exception) TemplatesModel (Joomla\Component\Templates\Administrator\Model)
ClientModel (Joomla\Component\Banners\Administrator\Model) HtmlView (Joomla\Component\Checkin\Administrator\View\Checkin) Parser (Lcobucci\JWT) TemplatesModel (Joomla\Component\Config\Site\Model)
ClientsController (Joomla\Component\Banners\Api\Controller) HtmlView (Joomla\Component\Associations\Administrator\View\Associations) Parser (Symfony\Component\Yaml) TemplatestyleField (Joomla\CMS\Form\Field)
ClientsController (Joomla\Component\Banners\Administrator\Controller) HtmlView (Joomla\Component\Contact\Site\View\Category) Parser (Joomla\Component\Finder\Administrator\Indexer) TemplateTable (Joomla\Component\Mails\Administrator\Table)
ClientsModel (Joomla\Component\Banners\Administrator\Model) HtmlView (Joomla\Component\Fields\Administrator\View\Field) ParserException (FG\ASN1\Exception) TentativeTypes (Symfony\Component\ErrorHandler\Internal)
ClientTable (Joomla\Component\Banners\Administrator\Table) HtmlView (Joomla\Component\Media\Administrator\View\File) PasswordField (Joomla\CMS\Form\Field) Terminal (Symfony\Component\Console)
CliErrorRenderer (Symfony\Component\ErrorHandler\ErrorRenderer) HtmlView (Joomla\Component\Media\Administrator\View\Media) PasswordHash TerminalIdentifier (phpseclib3\File\ASN1\Maps)
CliInput (Joomla\CMS\Application\CLI) HtmlView (Joomla\Component\Config\Site\View\Templates) PasswordRule (Joomla\CMS\Form\Rule) TerminateEvent (Joomla\Console\Event)
CliOutput (Joomla\CMS\Application\CLI) HtmlView (Joomla\Component\Categories\Administrator\View\Categories) Patcher (Joomla\CMS\Filesystem) TermsField (Joomla\Plugin\User\Terms\Field)
CliRenderer (Joomla\CMS\Error\Renderer) HtmlView (Joomla\Component\Categories\Administrator\View\Category) Patcher (Joomla\Filesystem) Text (Joomla\CMS\Language)
ClonerInterface (Symfony\Component\VarDumper\Cloner) HtmlView (Joomla\Component\Fields\Administrator\View\Fields) Path (Joomla\CMS\Filesystem) TextareaField (Joomla\CMS\Form\Field)
CMSApplication (Joomla\CMS\Application) HtmlView (Joomla\Component\Workflow\Administrator\View\Stages) Path (Joomla\Filesystem) TextDescriptor (Joomla\Console\Descriptor)
CMSApplicationInterface (Joomla\CMS\Application) HtmlView (Joomla\Component\Config\Site\View\Config) Pathway (Joomla\CMS\Pathway) TextDescriptor (Symfony\Component\Console\Descriptor)
CMSHelper (Joomla\CMS\Helper) HtmlView (Joomla\Component\Menus\Administrator\View\Items) Pathway (Joomla\CMS\Service\Provider) TextField (Joomla\CMS\Form\Field)
CMSObject (Joomla\CMS\Object) HtmlView (Joomla\Component\Menus\Administrator\View\Menu) Pattern (Doctrine\Inflector\Rules) Response\TextResponse (Laminas\Diactoros)
CMSPlugin (Joomla\CMS\Plugin) HtmlView (Joomla\Component\Workflow\Administrator\View\Transition) PatternAccuracyDescriptor (Webauthn\MetadataService) TextStringObject (CBOR)
CMSWebApplicationInterface (Joomla\CMS\Application) HtmlView (Joomla\Component\Workflow\Administrator\View\Transitions) Patterns (Doctrine\Inflector\Rules) TextStringWithChunkObject (CBOR)
CodeAccuracyDescriptor (Webauthn\MetadataService) HtmlView (Joomla\Component\Menus\Administrator\View\Menus) PBEParameter (phpseclib3\File\ASN1\Maps) TextView (Joomla\Component\Admin\Administrator\View\Sysinfo)
CodecInterface (Ramsey\Uuid\Codec) HtmlView (Joomla\Component\Contact\Site\View\Categories) PBES2params (phpseclib3\File\ASN1\Maps) ThrowableUtils (Symfony\Component\ErrorHandler)
CodePointString (Symfony\Component\String) HtmlView (Joomla\CMS\MVC\View) PBKDF2params (phpseclib3\File\ASN1\Maps) ThrowingCasterException (Symfony\Component\VarDumper\Exception)
Collectable (TYPO3\PharStreamWrapper) HtmlView (Joomla\Component\Contact\Site\View\Contact) PBMAC1params (phpseclib3\File\ASN1\Maps) Time (phpseclib3\File\ASN1\Maps)
CollectedClientData (Webauthn) HtmlView (Joomla\Component\Menus\Administrator\View\Menutypes) PdoCaster (Symfony\Component\VarDumper\Caster) TimeableTwigExtensionProfiler (DebugBar\Bridge\Twig)
Collection (Symfony\Component\Ldap\Adapter\ExtLdap) HtmlView (Joomla\Component\Fields\Administrator\View\Group) PDOCollector (DebugBar\DataCollector\PDO) TimeConverterInterface (Ramsey\Uuid\Converter)
Collection (Tobscure\JsonApi) HtmlView (Joomla\Component\Fields\Administrator\View\Groups) PdoDriver (Joomla\Database\Pdo) TimeDataCollector (DebugBar\DataCollector)
CollectionAdapter (Joomla\CMS\Updater\Adapter) HtmlView (Joomla\Component\Content\Site\View\Archive) PdoQuery (Joomla\Database\Pdo) TimeField (Joomla\CMS\Form\Field)
CollectionInterface (Symfony\Component\Ldap\Adapter) HtmlView (Joomla\Component\Content\Site\View\Article) PdoStatement (Joomla\Database\Pdo) TimeGeneratorFactory (Ramsey\Uuid\Generator)
Color (Symfony\Component\Console) HtmlView (Joomla\Component\Content\Site\View\Category) PdoStorage (DebugBar\Storage) TimeGeneratorInterface (Ramsey\Uuid\Generator)
ColorField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Content\Site\View\Featured) PeclUuidRandomGenerator (Ramsey\Uuid\Generator) TimeProviderInterface (Ramsey\Uuid\Provider)
ColorProcessor (Joomla\CMS\Application\CLI\Output\Processor) HtmlView (Joomla\Component\Content\Site\View\Form) PeclUuidTimeGenerator (Ramsey\Uuid\Generator) TimeRule (Joomla\CMS\Form\Rule)
ColorRule (Joomla\CMS\Form\Rule) HtmlView (Joomla\Component\Messages\Administrator\View\Message) Pentanomial (phpseclib3\File\ASN1\Maps) TimestampFirstCombCodec (Ramsey\Uuid\Codec)
ColorStyle (Joomla\CMS\Application\CLI) HtmlView (Joomla\Component\Messages\Administrator\View\Config) Constraint\PermittedFor (Lcobucci\JWT\Validation) TimestampLastCombCodec (Ramsey\Uuid\Codec)
CombGenerator (Ramsey\Uuid\Generator) HtmlView (Joomla\Component\Admin\Administrator\View\Help) PersonalName (phpseclib3\File\ASN1\Maps) TimestampTag (CBOR\Tag)
ComboField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Finder\Site\View\Search) PgSqlCaster (Symfony\Component\VarDumper\Caster) TimezoneField (Joomla\CMS\Form\Field)
Command (Symfony\Component\Console\Command) HtmlView (Joomla\Component\Users\Site\View\Captive) PgsqlDriver (Joomla\Database\Pgsql) TinymcebuilderField (Joomla\Plugin\Editors\TinyMCE\Field)
CommandCompletionTester (Symfony\Component\Console\Tester) HtmlView (Joomla\Component\Newsfeeds\Site\View\Categories) PgsqlExporter (Joomla\Database\Pgsql) ToIdn (Algo26\IdnaConvert)
CommandErrorEvent (Joomla\Console\Event) HtmlView (Joomla\Component\Newsfeeds\Site\View\Category) PgsqlImporter (Joomla\Database\Pgsql) Token (Joomla\Plugin\ApiAuthentication\Token\Extension)
CommandIsSuccessful (Symfony\Component\Console\Tester\Constraint) HtmlView (Joomla\Component\Modules\Administrator\View\Module) PgsqlQuery (Joomla\Database\Pgsql) Token (Joomla\Component\Finder\Administrator\Indexer)
CommandLoaderInterface (Symfony\Component\Console\CommandLoader) HtmlView (Joomla\Component\Newsfeeds\Site\View\Newsfeed) PharExtensionInterceptor (TYPO3\PharStreamWrapper\Interceptor) Token (Lcobucci\JWT)
CommandNotFoundException (Symfony\Component\Console\Exception) HtmlView (Joomla\Component\Modules\Administrator\View\Modules) PharInvocation (TYPO3\PharStreamWrapper\Resolver) TokenBinding (Webauthn\TokenBinding)
CommandTester (Symfony\Component\Console\Tester) HtmlView (Joomla\Component\Modules\Administrator\View\Select) PharInvocationCollection (TYPO3\PharStreamWrapper\Resolver) TokenBindingHandler (Webauthn\TokenBinding)
CompactSerializer (Jose\Component\Signature\Serializer) HtmlView (Joomla\Component\Privacy\Site\View\Confirm) PharInvocationResolver (TYPO3\PharStreamWrapper\Resolver) TokenBindingNotSupportedHandler (Webauthn\TokenBinding)
CompareModel (Joomla\Component\Contenthistory\Administrator\Model) HtmlView (Joomla\Component\Privacy\Site\View\Request) PharMetaDataInterceptor (TYPO3\PharStreamWrapper\Interceptor) Toolbar (Joomla\CMS\Service\Provider)
Compat (ParagonIE\Sodium) HtmlView (Joomla\Component\Tags\Site\View\Tag) PharStreamWrapper (TYPO3\PharStreamWrapper) Toolbar (Joomla\CMS\Toolbar)
CompleteCommand (Symfony\Component\Console\Command) HtmlView (Joomla\Component\Tags\Site\View\Tags) PHP (phpseclib3\Math\BigInteger\Engines) ToolbarButton (Joomla\CMS\Toolbar)
CompletionInput (Symfony\Component\Console\Completion) HtmlView (Joomla\Component\Config\Administrator\View\Application) Php (Joomla\Registry\Format) ToolbarFactoryInterface (Joomla\CMS\Toolbar)
CompletionOutputInterface (Symfony\Component\Console\Completion\Output) HtmlView (Joomla\Component\Config\Administrator\View\Component) PHP32 (phpseclib3\Math\BigInteger\Engines) ToolbarHelper (Joomla\CMS\Toolbar)
CompletionSuggestions (Symfony\Component\Console\Completion) HtmlView (Joomla\Component\Newsfeeds\Administrator\View\Newsfeed) PHP64 (phpseclib3\Math\BigInteger\Engines) ToPunycode (Algo26\IdnaConvert\Punycode)
Component (Joomla\CMS\Extension) HtmlView (Joomla\Component\Newsfeeds\Administrator\View\Newsfeeds) Php72 (Symfony\Polyfill\Php72) TosField (Joomla\Plugin\User\Profile\Field)
ComponentAdapter (Joomla\CMS\Installer\Adapter) HtmlView (Joomla\Component\Admin\Administrator\View\Sysinfo) Php73 (Symfony\Polyfill\Php73) Totp (Joomla\CMS\Encrypt)
ComponentController (Joomla\Component\Config\Api\Controller) HtmlView (Joomla\Component\Users\Site\View\Login) Php80 (Symfony\Polyfill\Php80) Totp (Joomla\Plugin\Multifactorauth\Totp\Extension)
ComponentController (Joomla\Component\Config\Administrator\Controller) HtmlView (Joomla\Component\Users\Site\View\Method) PHPassHandler (Joomla\CMS\Authentication\Password) ToUnicode (Algo26\IdnaConvert)
ComponentDispatcher (Joomla\CMS\Dispatcher) HtmlView (Joomla\Component\Users\Site\View\Profile) PhpHttpDriver (DebugBar) ToUtf8 (Algo26\IdnaConvert\EncodingHelper)
ComponentDispatcherFactory (Joomla\CMS\Dispatcher) HtmlView (Joomla\Component\Users\Site\View\Methods) PhpInfoCollector (DebugBar\DataCollector) TPMAttestationStatementSupport (Webauthn\AttestationStatement)
ComponentDispatcherFactory (Joomla\CMS\Extension\Service\Provider) HtmlView (Joomla\Component\Users\Site\View\Remind) PhpInputStream (Laminas\Diactoros) TraceablePDO (DebugBar\DataCollector\PDO)
ComponentDispatcherFactoryInterface (Joomla\CMS\Dispatcher) HtmlView (Joomla\Component\Users\Site\View\Registration) PHPMailer (PHPMailer\PHPMailer) TraceablePDOStatement (DebugBar\DataCollector\PDO)
ComponentHelper (Joomla\CMS\Component) HtmlView (Joomla\Component\Users\Site\View\Reset) PhpSetting (Joomla\Component\Admin\Administrator\Service\HTML) TraceableTwigEnvironment (DebugBar\Bridge\Twig)
ComponentInterface (Joomla\CMS\Extension) HtmlView (Joomla\Component\Wrapper\Site\View\Wrapper) PhpTimeConverter (Ramsey\Uuid\Converter\Time) TraceableTwigTemplate (DebugBar\Bridge\Twig)
ComponentlayoutField (Joomla\CMS\Form\Field) HtmlView (Joomla\Component\Plugins\Administrator\View\Plugin) PhpToken (Symfony\Polyfill\Php80) TracedStatement (DebugBar\DataCollector\PDO)
ComponentModel (Joomla\Component\Config\Administrator\Model) HtmlView (Joomla\Component\Plugins\Administrator\View\Plugins) PKCS (phpseclib3\Crypt\Common\Formats\Keys) TraceStub (Symfony\Component\VarDumper\Caster)
ComponentRecord (Joomla\CMS\Component) HtmlView (Joomla\Component\Postinstall\Administrator\View\Messages) PKCS1 (phpseclib3\Crypt\Common\Formats\Keys) TracksController (Joomla\Component\Banners\Administrator\Controller)
ComponentRenderer (Joomla\CMS\Document\Renderer\Html) HtmlView (Joomla\CMS\Installation\View\Error) PKCS1 (phpseclib3\Crypt\DH\Formats\Keys) TracksModel (Joomla\Component\Banners\Administrator\Model)
ComponentsCategoryField (Joomla\Component\Categories\Administrator\Field) HtmlView (Joomla\CMS\Installation\View\Preinstall) PKCS1 (phpseclib3\Crypt\RSA\Formats\Keys) TranscodeUnicode (Algo26\IdnaConvert\TranscodeUnicode)
ComponentsField (Joomla\CMS\Form\Field) HtmlView (Joomla\CMS\Installation\View\Remove) PKCS1 (phpseclib3\Crypt\EC\Formats\Keys) TranscodeUnicodeInterface (Algo26\IdnaConvert\TranscodeUnicode)
ComponentsFieldgroupField (Joomla\Component\Fields\Administrator\Field) HtmlView (Joomla\CMS\Installation\View\Setup) PKCS1 (phpseclib3\Crypt\DSA\Formats\Keys) Transformation (Doctrine\Inflector\Rules)
ComponentsFieldsField (Joomla\Component\Fields\Administrator\Field) HtmlView (Joomla\Component\Actionlogs\Administrator\View\Actionlogs) PKCS8 (phpseclib3\Crypt\Common\Formats\Keys) Transformations (Doctrine\Inflector\Rules)
ComponentsWorkflowField (Joomla\Component\Workflow\Administrator\Field) HtmlView (Joomla\Component\Privacy\Administrator\View\Capabilities) PKCS8 (phpseclib3\Crypt\RSA\Formats\Keys) TransitionButton (Joomla\CMS\Button)
ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f HtmlView (Joomla\Component\Privacy\Administrator\View\Consents) PKCS8 (phpseclib3\Crypt\DH\Formats\Keys) TransitionController (Joomla\Component\Workflow\Administrator\Controller)
ComposerStaticInit2399d40fc48ada3450e844df0430bf2f (Composer\Autoload) HtmlView (Joomla\Component\Finder\Administrator\View\Filter) PKCS8 (phpseclib3\Crypt\DSA\Formats\Keys) TransitionField (Joomla\CMS\Form\Field)
Config (Joomla\CMS\Service\Provider) HtmlView (Joomla\Component\Privacy\Administrator\View\Request) PKCS8 (phpseclib3\Crypt\EC\Formats\Keys) TransitionModel (Joomla\Component\Workflow\Administrator\Model)
ConfigCollector (DebugBar\DataCollector) HtmlView (Joomla\Component\Finder\Administrator\View\Filters) PKCS9String (phpseclib3\File\ASN1\Maps) TransitionsController (Joomla\Component\Workflow\Administrator\Controller)
ConfigComponent (Joomla\Component\Config\Administrator\Extension) HtmlView (Joomla\Component\Privacy\Administrator\View\Requests) PlgAuthenticationCookie TransitionsModel (Joomla\Component\Workflow\Administrator\Model)
ConfigComponentsField (Joomla\Component\Config\Administrator\Field) HtmlView (Joomla\Component\Finder\Administrator\View\Index) PlgAuthenticationJoomla TransitionTable (Joomla\Component\Workflow\Administrator\Table)
ConfigController (Joomla\Component\Config\Site\Controller) HtmlView (Joomla\Component\Finder\Administrator\View\Indexer) PlgAuthenticationLdap Transliterate (Joomla\CMS\Language)
ConfigController (Joomla\Component\Messages\Administrator\Controller) HtmlView (Joomla\Component\Finder\Administrator\View\Maps) PlgButtonArticle TransportInterface (Joomla\Http)
ConfigHelper (Joomla\Component\Config\Administrator\Helper) HtmlView (Joomla\Component\Finder\Administrator\View\Searches) PlgButtonContact TransportInterface (Joomla\CMS\Http)
ConfigModel (Joomla\Component\Config\Site\Model) HtmlView (Joomla\Component\Finder\Administrator\View\Statistics) PlgButtonFields TrimmedBufferOutput (Symfony\Component\Console\Output)
ConfigModel (Joomla\Component\Messages\Administrator\Model) HtmlView (Joomla\Component\Config\Site\View\Modules) PlgButtonImage Trinomial (phpseclib3\File\ASN1\Maps)
ConfigPostProcessor (Laminas\ZendFrameworkBridge) HtmlView (Joomla\Component\Redirect\Administrator\View\Link) PlgButtonMenu TripleDES (phpseclib3\Crypt)
ConfigProvider (Laminas\Diactoros) HtmlView (Joomla\Component\Redirect\Administrator\View\Links) PlgButtonModule OtherObject\TrueObject (CBOR)
Configuration (Lcobucci\JWT) HtmlView (Joomla\Component\Contact\Administrator\View\Contacts) PlgButtonPagebreak TrustPath (Webauthn\TrustPath)
Configuration (Joomla\Component\Admin\Administrator\Service\HTML) HtmlView (Joomla\Component\Contact\Administrator\View\Contact) PlgButtonReadmore TrustPathLoader (Webauthn\TrustPath)
ConfigurationAwareApplicationInterface (Joomla\Application) HtmlView (Joomla\Component\Banners\Administrator\View\Banner) PlgCaptchaRecaptcha TwigCollector (DebugBar\Bridge\Twig)
ConfigurationModel (Joomla\CMS\Installation\Model) HtmlView (Joomla\Component\Scheduler\Administrator\View\Select) PlgCaptchaRecaptcha_Invisible TwigProfileCollector (DebugBar\Bridge)
ConfirmationQuestion (Symfony\Component\Console\Question) HtmlView (Joomla\Component\Scheduler\Administrator\View\Task) PlgContentConfirmConsent TwistedEdwards (phpseclib3\Crypt\EC\BaseCurves)
ConfirmButton (Joomla\CMS\Toolbar\Button) HtmlView (Joomla\Component\Scheduler\Administrator\View\Tasks) PlgContentContact Twofish (phpseclib3\Crypt)
ConfirmModel (Joomla\Component\Privacy\Site\Model) Http (Joomla\CMS\Http) PlgContentEmailcloak Parser\Txt (Joomla\Component\Finder\Administrator\Indexer)
ConjunctionInterceptor (TYPO3\PharStreamWrapper\Interceptor) Http (Joomla\Http) PlgContentFields TypeField (Joomla\Component\Installer\Administrator\Field)
Connection (Symfony\Component\Ldap\Adapter\ExtLdap) HttpBridgePostRequestMethod (Joomla\CMS\Captcha\Google) PlgContentFinder TypeField (Joomla\Component\Fields\Administrator\Field)
Connection (Symfony\Component\VarDumper\Server) HttpDriverInterface (DebugBar) PlgContentJoomla
u
ConnectionClosedException (phpseclib3\Exception) HttpFactory (Joomla\CMS\Http) PlgContentLoadmodule
ConnectionEvent (Joomla\Database\Event) HttpFactory (Joomla\Http) PlgContentPagebreak UCM (Joomla\CMS\UCM)
ConnectionException (Symfony\Component\Ldap\Exception) HttpHeaderSerializer (Symfony\Component\WebLink) PlgContentPagenavigation Ucm (Joomla\CMS\Table)
ConnectionFailureException (Joomla\Database\Exception) HttplugFactory (Nyholm\Psr7\Factory) PlgContentVote UCMBase (Joomla\CMS\UCM)
ConnectionInterface (Symfony\Component\Ldap\Adapter)
i
PlgEditorCodemirror UCMContent (Joomla\CMS\UCM)
ConnectionOptions (Symfony\Component\Ldap\Adapter\ExtLdap) PlgEditorNone UCMType (Joomla\CMS\UCM)
ConnectionTimeoutException (Symfony\Component\Ldap\Exception) IA5String (FG\ASN1\Universal) PlgEditorTinymce UiTab (Joomla\CMS\HTML\Helpers)
ConsentBoxField (Joomla\Plugin\Content\ConfirmConsent\Field) Icon (Joomla\Component\Content\Administrator\Service\HTML) PlgExtensionFinder UnableToConnectException (phpseclib3\Exception)
ConsentsController (Joomla\Component\Privacy\Api\Controller) Icon (Joomla\Component\Contact\Administrator\Service\HTML) PlgExtensionJoomla UnableToWriteBody (Joomla\Application\Exception)
ConsentsController (Joomla\Component\Privacy\Administrator\Controller) Icons (Joomla\CMS\HTML\Helpers) PlgExtensionNamespacemap UndefinedFunctionError (Symfony\Component\ErrorHandler\Error)
ConsentsModel (Joomla\Component\Privacy\Administrator\Model) Iconv (Symfony\Polyfill\Iconv) PlgFieldsCalendar UndefinedFunctionErrorEnhancer (Symfony\Component\ErrorHandler\ErrorEnhancer)
ConsentTable (Joomla\Component\Privacy\Administrator\Table) Constraint\IdentifiedBy (Lcobucci\JWT\Validation) PlgFieldsCheckboxes UndefinedMethodError (Symfony\Component\ErrorHandler\Error)
Console (Joomla\CMS\Service\Provider) Identifier (FG\ASN1) PlgFieldsColor UndefinedMethodErrorEnhancer (Symfony\Component\ErrorHandler\ErrorEnhancer)
ConsoleApplication (Joomla\CMS\Application) Agent\Identity (phpseclib3\System\SSH) PlgFieldsEditor OtherObject\UndefinedObject (CBOR)
ConsoleCommandEvent (Symfony\Component\Console\Event) IdnaConvertInterface (Algo26\IdnaConvert) PlgFieldsImagelist UndefinedOptionsException (Symfony\Component\OptionsResolver\Exception)
ConsoleErrorEvent (Symfony\Component\Console\Event) ChaCha20\IetfCtx (ParagonIE\Sodium\Core) PlgFieldsInteger Unescaper (Symfony\Component\Yaml)
ConsoleEvent (Symfony\Component\Console\Event) IgnoreTokenBindingHandler (Webauthn\TokenBinding) PlgFieldsList UnexpectedResponseException (Joomla\Http\Exception)
ConsoleEvent (Joomla\Console\Event) Image (Joomla\CMS\Image) PlgFieldsMedia UnicodeString (Symfony\Component\String)
ConsoleEvents (Symfony\Component\Console) ImageDocument (Joomla\CMS\Document) PlgFieldsRadio Uninflected (Doctrine\Inflector\Rules\NorwegianBokmal)
ConsoleEvents (Joomla\Console) ImageFilter (Joomla\CMS\Image) PlgFieldsSql Uninflected (Doctrine\Inflector\Rules\French)
ConsoleLogger (Symfony\Component\Console\Logger) ImagelistField (Joomla\CMS\Form\Field) PlgFieldsSubform Uninflected (Doctrine\Inflector\Rules\Portuguese)
ConsoleOutput (Symfony\Component\Console\Output) ImagineCaster (Symfony\Component\VarDumper\Caster) PlgFieldsText Uninflected (Doctrine\Inflector\Rules\Turkish)
ConsoleOutputInterface (Symfony\Component\Console\Output) ImgStub (Symfony\Component\VarDumper\Caster) PlgFieldsTextarea Uninflected (Doctrine\Inflector\Rules\English)
ConsoleSectionOutput (Symfony\Component\Console\Output) ImmutableNodeInterface (Joomla\CMS\Tree) PlgFieldsUrl Uninflected (Doctrine\Inflector\Rules\Spanish)
ConsoleSignalEvent (Symfony\Component\Console\Event) ImpmadeField (Joomla\Component\Banners\Administrator\Field) PlgFieldsUser UniqueIdentifier (phpseclib3\File\ASN1\Maps)
ConsoleTerminateEvent (Symfony\Component\Console\Event) ImportCommand (Joomla\Database\Command) PlgFieldsUsergrouplist UniqueidField (Joomla\Plugin\System\Stats\Field)
Constraint (Lcobucci\JWT\Validation) ImptotalField (Joomla\Component\Banners\Administrator\Field) PlgFileSystemLocal UniversalString (FG\ASN1\Universal)
ConstraintViolation (Lcobucci\JWT\Validation) InconsistentSetupException (phpseclib3\Exception) PlgFinderCategories UnknownArchiveException (Joomla\Archive\Exception)
Construct (FG\ASN1) IndexController (Joomla\Component\Finder\Administrator\Controller) PlgFinderContacts UnknownAssetException (Joomla\CMS\WebAsset\Exception)
ConstStub (Symfony\Component\VarDumper\Caster) Indexer (Joomla\Component\Finder\Administrator\Indexer) PlgFinderContent UnknownConstructedObject (FG\ASN1)
ContactComponent (Joomla\Component\Contact\Administrator\Extension) IndexerController (Joomla\Component\Finder\Administrator\Controller) PlgFinderNewsfeeds UnknownObject (FG\ASN1)
ContactController (Joomla\Component\Contact\Api\Controller) IndexerModel (Joomla\Component\Finder\Administrator\Model) PlgFinderTags UnknownTypeException (Joomla\Database\Exception)
ContactController (Joomla\Component\Contact\Site\Controller) IndexModel (Joomla\Component\Finder\Administrator\Model) PlgInstallerFolderInstaller UnparsableImageException (Joomla\CMS\Image\Exception)
ContactController (Joomla\Component\Contact\Administrator\Controller) InfiniteListObject (CBOR) PlgInstallerOverride UnreadableStreamException (Laminas\Diactoros\Exception)
ContactEmailMessageRule (Joomla\Component\Contact\Site\Rule) InfiniteMapObject (CBOR) PlgInstallerPackageInstaller UnrecognizedProtocolVersionException (Laminas\Diactoros\Exception)
ContactEmailRule (Joomla\Component\Contact\Site\Rule) Inflectible (Doctrine\Inflector\Rules\English) PlgInstallerUrlInstaller UnrewindableStreamException (Laminas\Diactoros\Exception)
ContactEmailSubjectRule (Joomla\Component\Contact\Site\Rule) Inflectible (Doctrine\Inflector\Rules\French) PlgInstallerWebinstaller UnsatisfiedDependencyException (Ramsey\Uuid\Exception)
ContactField (Joomla\Component\Contact\Administrator\Field\Modal) Inflectible (Doctrine\Inflector\Rules\NorwegianBokmal) PlgMediaActionCrop UnsatisfiedDependencyException (Joomla\CMS\WebAsset\Exception)
ContactHelper Inflectible (Doctrine\Inflector\Rules\Portuguese) PlgMediaActionResize UnseekableStreamException (Laminas\Diactoros\Exception)
ContactHelper (Joomla\Component\Contact\Administrator\Helper) Inflectible (Doctrine\Inflector\Rules\Spanish) PlgMediaActionRotate UnsetFilter (Joomla\CMS\Form\Filter)
ContactHelperRoute Inflectible (Doctrine\Inflector\Rules\Turkish) PlgPrivacyActionlogs UnsignedIntegerObject (CBOR)
ContactModel (Joomla\Component\Contact\Site\Model) Inflector (Doctrine\Common\Inflector) PlgPrivacyConsents UnsupportedAdapterException (Joomla\Database\Exception)
ContactModel (Joomla\Component\Contact\Administrator\Model) Inflector (Doctrine\Inflector) PlgPrivacyContact UnsupportedAlgorithmException (phpseclib3\Exception)
ContactsController (Joomla\Component\Contact\Administrator\Controller) Inflector (Joomla\String) PlgPrivacyContent UnsupportedArchiveException (Joomla\Archive\Exception)
ContactSerializer (Joomla\Component\Contact\Api\Serializer) InflectorFactory (Doctrine\Inflector\Rules\English) PlgPrivacyMessage UnsupportedCacheException (Joomla\CMS\Cache\Exception)
ContactsModel (Joomla\Component\Contact\Administrator\Model) InflectorFactory (Doctrine\Inflector) PlgPrivacyUser UnsupportedCipherException (Joomla\Crypt\Exception)
ContactTable (Joomla\Component\Contact\Administrator\Table) InflectorFactory (Doctrine\Inflector\Rules\French) PlgQuickiconDownloadkey UnsupportedCurveException (phpseclib3\Exception)
Container (TYPO3\PharStreamWrapper\Phar) InflectorFactory (Doctrine\Inflector\Rules\NorwegianBokmal) PlgQuickiconExtensionupdate UnsupportedDatabaseDriverException (Joomla\Session\Exception)
Container (Joomla\DI) InflectorFactory (Doctrine\Inflector\Rules\Portuguese) PlgQuickiconOverrideCheck UnsupportedFormatException (phpseclib3\Exception)
ContainerAwareInterface (Joomla\DI) InflectorFactory (Doctrine\Inflector\Rules\Spanish) PlgQuickiconPhpVersionCheck Token\UnsupportedHeaderFound (Lcobucci\JWT)
ContainerAwareToolbarFactory (Joomla\CMS\Toolbar) InflectorFactory (Doctrine\Inflector\Rules\Turkish) PlgQuickiconPrivacyCheck UnsupportedOperationException (Ramsey\Uuid\Exception)
ContainerCommandLoader (Symfony\Component\Console\CommandLoader) InflectorInterface (Symfony\Component\String\Inflector) PlgSampledataBlog UnsupportedOperationException (phpseclib3\Exception)
ContainerControllerResolver (Joomla\Application\Controller) InfoCollector (Joomla\Plugin\System\Debug\DataCollector) PlgSampledataMultilang UnsupportedPasswordHandlerException (Joomla\Authentication\Exception)
ContainerExceptionInterface (Psr\Container) Ini (Joomla\Registry\Format) PlgSystemAccessibility UnsupportedStorageException (Joomla\CMS\Session\Exception)
ContainerInterface (Psr\Container) Inline (Symfony\Component\Yaml) PlgSystemActionLogs UntellableStreamException (Laminas\Diactoros\Exception)
ContainerLoader (Joomla\Console\Loader) InlinehelpButton (Joomla\CMS\Toolbar\Button) PlgSystemDebug UnwritableStreamException (Laminas\Diactoros\Exception)
ContainerNotFoundException (Joomla\DI\Exception) Signer\Key\InMemory (Lcobucci\JWT) PlgSystemFields Update (Joomla\CMS\Table)
ContainerResource (Joomla\DI) Logger\InMemoryLogger (Joomla\CMS\Log) PlgSystemHighlight Update (Joomla\CMS\Updater)
Content (Joomla\CMS\HTML\Helpers) Input (Joomla\CMS\Input) PlgSystemHttpHeaders UpdateAdapter (Joomla\CMS\Updater)
Content (Joomla\CMS\Table) Input (Symfony\Component\Console\Input) PlgSystemJooa11y UpdateController (Joomla\Component\Joomlaupdate\Administrator\Controller)
ContentComponent (Joomla\Component\Content\Administrator\Extension) Input (Joomla\Input) PlgSystemLanguagecode UpdateController (Joomla\Component\Installer\Administrator\Controller)
ContentHelper (Joomla\Component\Content\Administrator\Helper) InputArgument (Symfony\Component\Console\Input) PlgSystemLanguageFilter UpdateCoreCommand (Joomla\CMS\Console)
ContentHelper (Joomla\CMS\Helper) InputAwareHelper (Symfony\Component\Console\Helper) PlgSystemLog UpdateModel (Joomla\Component\Installer\Administrator\Model)
ContentHelper (Joomla\Component\Content\Api\Helper) InputAwareInterface (Symfony\Component\Console\Input) PlgSystemLogout UpdateModel (Joomla\Component\Joomlaupdate\Administrator\Model)
ContentHelper InputDefinition (Symfony\Component\Console\Input) PlgSystemLogrotation UpdateOperation (Symfony\Component\Ldap\Adapter\ExtLdap)
ContentHistory (Joomla\CMS\Table) InputFilter (Joomla\CMS\Filter) PlgSystemPrivacyconsent UpdateOperationException (Symfony\Component\Ldap\Exception)
ContenthistoryField (Joomla\CMS\Form\Field) InputFilter (Joomla\Filter) PlgSystemRedirect Updater (Joomla\CMS\Updater)
ContenthistoryHelper InputInterface (Symfony\Component\Console\Input) PlgSystemRemember UpdateSite (Joomla\CMS\Table)
ContenthistoryHelper (Joomla\Component\Contenthistory\Administrator\Helper) InputOption (Symfony\Component\Console\Input) PlgSystemSchedulerunner UpdatesiteController (Joomla\Component\Installer\Administrator\Controller)
ContentLanguage (Joomla\CMS\HTML\Helpers) InstallationApplication (Joomla\CMS\Installation\Application) PlgSystemSef UpdatesiteModel (Joomla\Component\Installer\Administrator\Model)
ContentlanguageField (Joomla\CMS\Form\Field) InstallationController (Joomla\CMS\Installation\Controller) PlgSystemSessionGc Updatesites (Joomla\Component\Installer\Administrator\Service\HTML)
ContentmapField (Joomla\Component\Finder\Administrator\Field) InstallationRouter (Joomla\CMS\Installation\Router) PlgSystemSkipto UpdatesitesController (Joomla\Component\Installer\Administrator\Controller)
ContentSerializer (Joomla\Component\Content\Api\Serializer) InstallController (Joomla\Component\Installer\Administrator\Controller) PlgSystemStats UpdatesitesModel (Joomla\Component\Installer\Administrator\Model)
ContentType (Joomla\CMS\Table) InstalledController (Joomla\Component\Languages\Administrator\Controller) PlgSystemTasknotification UpdatesiteTable (Joomla\Component\Installer\Administrator\Table)
ContenttypeField (Joomla\CMS\Form\Field) InstalledModel (Joomla\Component\Languages\Administrator\Model) PlgSystemUpdatenotification UploaddirsField (Joomla\Plugin\Editors\TinyMCE\Field)
ContenttypesField (Joomla\Component\Finder\Administrator\Field) InstalledVersions (Composer) PlgUserContactCreator UploadedFile (Nyholm\Psr7)
ContextProviderInterface (Symfony\Component\VarDumper\Dumper\ContextProvider) Installer (Joomla\CMS\Installer) PlgUserJoomla UploadedFile (Laminas\Diactoros)
ContextualizedDumper (Symfony\Component\VarDumper\Dumper) InstallerAdapter (Joomla\CMS\Installer) PlgUserProfile UploadedFileAlreadyMovedException (Laminas\Diactoros\Exception)
Contrast (Joomla\CMS\Image\Filter) InstallerComponent (Joomla\Component\Installer\Administrator\Extension) PlgUserTerms UploadedFileErrorException (Laminas\Diactoros\Exception)
ControllerInterface (Joomla\CMS\MVC\Controller) InstallerExtension (Joomla\CMS\Installer) PlgUserToken UploadedFileFactory (Laminas\Diactoros)
ControllerResolver (Joomla\Application\Controller) InstallerHelper (Joomla\Component\Installer\Administrator\Helper) PlgWebservicesBanners UploadedFileFactoryInterface (Psr\Http\Message)
ControllerResolverInterface (Joomla\Application\Controller) InstallerHelper (Joomla\CMS\Installer) PlgWebservicesConfig UploadedFileInterface (Psr\Http\Message)
Signer\Ecdsa\ConversionFailed (Lcobucci\JWT) InstallerHelper PlgWebservicesContact Uri (Nyholm\Psr7)
Cookie (Joomla\CMS\Input) InstallerModel (Joomla\Component\Installer\Administrator\Model) PlgWebservicesContent Uri (Laminas\Diactoros)
Cookie (Joomla\Input) InstallerScript (Joomla\CMS\Installer) PlgWebservicesInstaller Uri (Joomla\Uri)
Core (Defuse\Crypto) InstallerScriptInterface (Joomla\CMS\Installer) PlgWebservicesLanguages Uri (Joomla\CMS\Uri)
CoreAssetItem (Joomla\CMS\WebAsset\AssetItem) InstallModel (Joomla\Component\Installer\Administrator\Model) PlgWebservicesMedia UriFactory (Laminas\Diactoros)
CoreContent (Joomla\CMS\Table) InsufficientSetupException (phpseclib3\Exception) PlgWebservicesMenus UriFactory (Http\Message)
CoseSignatureFixer (Webauthn\Util) IntarrayFilter (Joomla\CMS\Form\Filter) PlgWebservicesMessages UriFactoryInterface (Psr\Http\Message)
CountryName (phpseclib3\File\ASN1\Maps) BinaryField\Integer (phpseclib3\Math) PlgWebservicesModules UriHelper (Joomla\Uri)
CPSuri (phpseclib3\File\ASN1\Maps) FiniteField\Integer (phpseclib3\Math\Common) PlgWebservicesNewsfeeds UriImmutable (Joomla\Uri)
CreateSessionTableCommand (Joomla\Session\Command) PrimeField\Integer (phpseclib3\Math) PlgWebservicesPlugins UriInterface (Joomla\Uri)
CreateSessionTableException (Joomla\Session\Exception) Integer (FG\ASN1\Universal) PlgWebservicesPrivacy UriInterface (Psr\Http\Message)
Credential (Webauthn) IntegerField (Joomla\CMS\Form\Field) PlgWebservicesRedirect UrlField (Joomla\CMS\Form\Field)
CredentialRepository (Joomla\Plugin\Multifactorauth\Webauthn) IntegerOverflowException (Brick\Math\Exception) PlgWebservicesTags UrlFilter (Joomla\CMS\Form\Filter)
CredentialRepository (Joomla\Plugin\System\Webauthn) IntervalField (Joomla\Component\Scheduler\Administrator\Field) PlgWebservicesTemplates UrlRule (Joomla\CMS\Form\Rule)
Credentials (Joomla\Plugin\Multifactorauth\Webauthn\Helper) IntlCaster (Symfony\Component\VarDumper\Caster) PlgWebservicesUsers Usage (enshrined\svgSanitize\ElementReference)
CRLDistributionPoints (phpseclib3\File\ASN1\Maps) InvalidActionException (Joomla\CMS\WebAsset\Exception) PlgWorkflowFeaturing User (Joomla\CMS\User)
CRLNumber (phpseclib3\File\ASN1\Maps) InvalidArgument (Negotiation\Exception) PlgWorkflowNotification User (Joomla\CMS\Service\Provider)
CRLReason (phpseclib3\File\ASN1\Maps) InvalidArgumentException (Psr\Log) PlgWorkflowPublishing User (Joomla\CMS\Table)
CronExpression (Cron) InvalidArgumentException (Symfony\Component\Console\Exception) PluginAdapter (Joomla\CMS\Installer\Adapter) User (Joomla\CMS\HTML\Helpers)
CronField (Joomla\Component\Scheduler\Administrator\Field) InvalidArgumentException (Symfony\Component\OptionsResolver\Exception) PluginController (Joomla\Component\Media\Administrator\Controller) UseractiveField (Joomla\CMS\Form\Field)
Crypt (Joomla\Crypt) InvalidArgumentException (Symfony\Component\String\Exception) PluginController (Joomla\Component\Plugins\Administrator\Controller) UserController (Joomla\Component\Users\Administrator\Controller)
Crypt (Joomla\CMS\Crypt) InvalidArgumentException (Webmozart\Assert) PluginElementField (Joomla\Component\Plugins\Administrator\Field) UserController (Joomla\Component\Users\Site\Controller)
CryptExceptionInterface (Joomla\Crypt\Exception) InvalidArgumentException (Assert) PluginHelper (Joomla\CMS\Plugin) UserFactory (Joomla\CMS\User)
Crypto (ParagonIE\Sodium) InvalidArgumentException (Laminas\Diactoros\Exception) PlugininfoField (Joomla\Component\Actionlogs\Administrator\Field) UserFactoryInterface (Joomla\CMS\User)
Crypto (Defuse\Crypto) InvalidCharacterException (Algo26\IdnaConvert\Exception) PluginInterface (Joomla\CMS\Extension) UserField (Joomla\CMS\Form\Field)
Crypto InvalidCiphertextException PluginModel (Joomla\Component\Plugins\Administrator\Model) Usergroup (Joomla\CMS\Table)
Crypto (Joomla\Crypt\Cipher) InvalidCredentialsException (Symfony\Component\Ldap\Exception) PluginorderingField (Joomla\Component\Plugins\Administrator\Field) UsergrouplistField (Joomla\CMS\Form\Field)
CryptoCipher (Joomla\CMS\Crypt\Cipher) InvalidHeader (Negotiation\Exception) PluginsController (Joomla\Component\Plugins\Api\Controller) UserGroupsHelper (Joomla\CMS\Helper)
CryptoException (Defuse\Crypto\Exception) InvalidIdnVersionException (Algo26\IdnaConvert\Exception) PluginsController (Joomla\Component\Plugins\Administrator\Controller) UserHelper (Joomla\CMS\User)
CryptoExceptionHandler InvalidityDate (phpseclib3\File\ASN1\Maps) PluginsField (Joomla\CMS\Form\Field) UserIdRule (Joomla\CMS\Form\Rule)
CryptoTestFailedException InvalidKeyException (Joomla\Crypt\Exception) PluginsHelper (Joomla\Component\Plugins\Administrator\Helper) UserMessagesField (Joomla\Component\Messages\Administrator\Field)
CSR (FG\X509\CSR) Signer\InvalidKeyProvided (Lcobucci\JWT) PluginsHelper UserModel (Joomla\Component\Users\Administrator\Model)
CssIdentifierRule (Joomla\CMS\Form\Rule) InvalidKeyTypeException (Joomla\Crypt\Exception) PluginsModel (Joomla\Component\Plugins\Administrator\Model) UsernameRule (Joomla\CMS\Installation\Form\Rule)
CssIdentifierSubstringRule (Joomla\CMS\Form\Rule) InvalidLanguage (Negotiation\Exception) PluginstatusField (Joomla\CMS\Form\Field) UsernameRule (Joomla\CMS\Form\Rule)
CssMenu (Joomla\Module\Menu\Administrator\Menu) InvalidMediaType (Negotiation\Exception) PluginTypeField (Joomla\Component\Plugins\Administrator\Field) UserNotice (phpseclib3\File\ASN1\Maps)
ChaCha20\Ctx (ParagonIE\Sodium\Core) InvalidOptionException (Symfony\Component\Console\Exception) PolicyInformation (phpseclib3\File\ASN1\Maps) Users (Joomla\Component\Users\Administrator\Service\HTML)
Ctype (Symfony\Polyfill\Ctype) InvalidOptionsException (Symfony\Component\OptionsResolver\Exception) PolicyMappings (phpseclib3\File\ASN1\Maps) UsersComponent (Joomla\Component\Users\Administrator\Extension)
RequestMethod\Curl (ReCaptcha) InvalidParameterException (Tobscure\JsonApi\Exception) PolicyQualifierId (phpseclib3\File\ASN1\Maps) UsersController (Joomla\Component\Users\Api\Controller)
Curl (Joomla\Http\Transport) InvalidParameterExceptionHandler (Joomla\CMS\Error\JsonApi) PolicyQualifierInfo (phpseclib3\File\ASN1\Maps) UsersController (Joomla\Component\Users\Administrator\Controller)
RequestMethod\CurlPost (ReCaptcha) InvalidParameterExceptionHandler (Tobscure\JsonApi\Exception\Handler) Poly1305 (ParagonIE\Sodium\Core) UsersHelper
CurlTransport (Joomla\CMS\Http\Transport) InvalidPathException (Joomla\Component\Media\Administrator\Exception) POP3 (PHPMailer\PHPMailer) UsersHelper (Joomla\Component\Users\Administrator\Helper)
CurrentUserInterface (Joomla\CMS\User) InvalidResponseCodeException (Joomla\Http\Exception) PopularHelper (Joomla\Module\Popular\Administrator\Helper) UsersHelperDebug
Cursor (Symfony\Component\Console) InvalidRouteExceptionHandler (Joomla\CMS\Error\JsonApi) PopupButton (Joomla\CMS\Toolbar\Button) UsersLatestHelper (Joomla\Module\UsersLatest\Site\Helper)
Cursor (Symfony\Component\VarDumper\Cloner) InvalidSessionException (Joomla\Session\Exception) Portuguese (Wamania\Snowball\Stemmer) UsersModel (Joomla\Component\Users\Administrator\Model)
Curve (phpseclib3\File\ASN1\Maps) InvalidStreamPointerPositionException (Laminas\Diactoros\Exception) PositionsModel (Joomla\Component\Modules\Administrator\Model) UserstateField (Joomla\CMS\Form\Field)
Curve25519 (ParagonIE\Sodium\Core) Token\InvalidTokenStructure (Lcobucci\JWT) PositiveBigIntegerTag (CBOR\Tag) UTCTime (FG\ASN1\Universal)
Curve25519 (phpseclib3\Crypt\EC\Curves) InvalidUuidStringException (Ramsey\Uuid\Exception) RequestMethod\Post (ReCaptcha) UTF8MB4SupportInterface (Joomla\Database)
Curve448 (phpseclib3\Crypt\EC\Curves) IOException (Defuse\Crypto\Exception) PostalAddress (phpseclib3\File\ASN1\Maps) UTF8String (FG\ASN1\Universal)
CustomButton (Joomla\CMS\Toolbar\Button) IPAddress (FG\X509\SAN) ChangeItem\PostgresqlChangeItem (Joomla\CMS\Schema) Util (ParagonIE\Sodium\Core)
CutArrayStub (Symfony\Component\VarDumper\Caster) IpHelper (Joomla\Utilities) PostinstallHelper (Joomla\Component\Postinstall\Administrator\Helper) Util (Tobscure\JsonApi)
CutStub (Symfony\Component\VarDumper\Caster) Constraint\IssuedBy (Lcobucci\JWT\Validation) PowerOfTwo (phpseclib3\Math\BigInteger\Engines\PHP\Reductions) Utility (Joomla\CMS\Utility)
d
IssuerAltName (phpseclib3\File\ASN1\Maps) Precomp (ParagonIE\Sodium\Core\Curve25519\Ge) Utils (CBOR)
IssuingDistributionPoint (phpseclib3\File\ASN1\Maps) PredefinedlistField (Joomla\CMS\Form\Field) Uuid (Ramsey\Uuid)
DaemonApplication (Joomla\CMS\Application) Italian (Wamania\Snowball\Stemmer) PrefixField (Joomla\CMS\Installation\Form\Field\Installation) UuidBuilderInterface (Ramsey\Uuid\Builder)
Danish (Wamania\Snowball\Stemmer) Item (Joomla\Component\Privacy\Administrator\Export) PrefixRule (Joomla\CMS\Installation\Form\Rule) UuidCaster (Symfony\Component\VarDumper\Caster)
Data (Symfony\Component\VarDumper\Cloner) ItemController (Joomla\Component\Menus\Administrator\Controller) PreloadManager (Joomla\CMS\Document) UuidFactory (Ramsey\Uuid)
Database (Joomla\CMS\Service\Provider) ItemlanguageField (Joomla\Component\Associations\Administrator\Field) PreloadManagerInterface (Joomla\CMS\Document) UuidFactoryInterface (Ramsey\Uuid)
DatabaseAwareInterface (Joomla\Database) ItemModel (Joomla\Component\Menus\Administrator\Model) PreparableInterface (Joomla\Database\Query) UuidInterface (Ramsey\Uuid)
DatabaseconnectionField (Joomla\CMS\Form\Field) ItemModel (Joomla\CMS\MVC\Model) PrepareStatementFailureException (Joomla\Database\Exception)
v
DatabaseController (Joomla\Component\Installer\Administrator\Controller) ItemModelInterface (Joomla\CMS\MVC\Model) PreviewController (Joomla\Component\Contenthistory\Administrator\Controller)
DatabaseDriver (Joomla\Database) ItemsController (Joomla\Component\Menus\Api\Controller) PreviewModel (Joomla\Component\Contenthistory\Administrator\Model) Constraint\ValidAt (Lcobucci\JWT\Validation)
DatabaseEvents (Joomla\Database) ItemsController (Joomla\Component\Menus\Administrator\Controller) Prime (phpseclib3\Crypt\EC\BaseCurves) Claim\Validatable (Lcobucci\JWT)
DatabaseExporter (Joomla\Database) ItemsModel (Joomla\Component\Menus\Administrator\Model) prime192v1 (phpseclib3\Crypt\EC\Curves) Validate (Joomla\CMS\Event\MultiFactor)
DatabaseFactory (Joomla\Database) ItemtypeField (Joomla\Component\Associations\Administrator\Field) prime192v2 (phpseclib3\Crypt\EC\Curves) ValidationData (Lcobucci\JWT)
DatabaseHandler (Joomla\Session\Handler) ItunesRssParser (Joomla\CMS\Feed\Parser\Rss) prime192v3 (phpseclib3\Crypt\EC\Curves) Validator (Lcobucci\JWT)
DatabaseHelper (Joomla\CMS\Installation\Helper)
j
prime239v1 (phpseclib3\Crypt\EC\Curves) Validator (Lcobucci\JWT\Validation)
DatabaseImporter (Joomla\Database) prime239v2 (phpseclib3\Crypt\EC\Curves) ValidatorInterface (Joomla\Session)
DatabaseInterface (Joomla\Database) JavascriptRenderer (DebugBar) prime239v3 (phpseclib3\Crypt\EC\Curves) Validity (phpseclib3\File\ASN1\Maps)
DatabaseIterator (Joomla\Database) JavascriptRenderer (Joomla\Plugin\System\Debug) prime256v1 (phpseclib3\Crypt\EC\Curves) VarCloner (Symfony\Component\VarDumper\Cloner)
Logger\DatabaseLogger (Joomla\CMS\Log) JGrid (Joomla\CMS\HTML\Helpers) Prime_p (phpseclib3\File\ASN1\Maps) VarDumper (Symfony\Component\VarDumper)
DatabaseModel (Joomla\Component\Installer\Administrator\Model) JHtmlIcon PrimeField (phpseclib3\Math) VcfView (Joomla\Component\Contact\Site\View\Contact)
DatabaseModel (Joomla\CMS\Installation\Model) JLoader PrintableString (FG\ASN1\Universal) VerificationMethodANDCombinations (Webauthn\MetadataService)
DatabaseModelInterface (Joomla\CMS\MVC\Model) JNamespacePsr4Map Priority (Joomla\Event) VerificationMethodDescriptor (Webauthn\MetadataService)
DatabaseNotFoundException (Joomla\Database\Exception) Joomla (Joomla\Plugin\Actionlog\Joomla\Extension) Privacy (Joomla\Component\Privacy\Administrator\Service\HTML) Verifier (Cose)
DatabaseProvider (Joomla\Database\Service) JoomlaHttpDriver (Joomla\Plugin\System\Debug) PrivacyComponent (Joomla\Component\Privacy\Administrator\Extension) Version (Webauthn\MetadataService)
DatabaseQuery (Joomla\Database) JoomlaInstallerScript PrivacyDashboardHelper (Joomla\Module\PrivacyDashboard\Administrator\Helper) Version (Joomla\CMS)
DatabaseStrategy (Joomla\Authentication\Strategies) JoomlaSerializer (Joomla\CMS\Serializer) PrivacyField (Joomla\Plugin\System\PrivacyConsent\Field) Versionable (Joomla\Plugin\Behaviour\Versionable\Extension)
DataCollector (DebugBar\DataCollector) JoomlaStorage (Joomla\CMS\Session\Storage) PrivacyHelper (Joomla\Component\Privacy\Administrator\Helper) VersionableTableInterface (Joomla\CMS\Versioning)
DataCollectorInterface (DebugBar\DataCollector) JoomlatokenField (Joomla\Plugin\User\Token\Field) PrivacyPlugin (Joomla\Component\Privacy\Administrator\Plugin) VersionHelper (Joomla\Module\Version\Administrator\Helper)
DataDumperInterface (Symfony\Component\VarDumper\Dumper) Joomlaupdate (Joomla\Plugin\Quickicon\Joomlaupdate\Extension) PrivacyStatusHelper (Joomla\Module\PrivacyStatus\Administrator\Helper) Versioning (Joomla\CMS\Versioning)
DataField (Joomla\Plugin\System\Stats\Field) Jquery (Joomla\CMS\HTML\Helpers) PrivateDomainName (phpseclib3\File\ASN1\Maps) ViewController (Joomla\CMS\Cache\Controller)
DataFormatter (DebugBar\DataFormatter) Json (Joomla\CMS\Input) PrivateKey (phpseclib3\Crypt\Common) ViewInterface (Joomla\CMS\MVC\View)
DataFormatter (Joomla\Plugin\System\Debug) Json (Joomla\Input) RSA\PrivateKey (phpseclib3\Crypt) ViewLevel (Joomla\CMS\Table)
DataFormatterInterface (DebugBar\DataFormatter) Json (Joomla\Registry\Format) PrivateKey (phpseclib3\File\ASN1\Maps) VisibleString (FG\ASN1\Universal)
DataObject (Joomla\Data) JsonapiDocument (Joomla\CMS\Document) DH\PrivateKey (phpseclib3\Crypt) VotelistField (Joomla\Component\Content\Administrator\Field)
Token\DataSet (Lcobucci\JWT) JsonapiRenderer (Joomla\CMS\Error\Renderer) EC\PrivateKey (phpseclib3\Crypt) VoteradioField (Joomla\Component\Content\Administrator\Field)
DataSet (Joomla\Data) JsonapiView (Joomla\Component\Menus\Api\View\Menus) PrivateKey (FG\X509)
w
DataShapeObject (Joomla\Component\Users\Administrator\DataShape) JsonapiView (Joomla\Component\Banners\Api\View\Banners) DSA\PrivateKey (phpseclib3\Crypt)
Date (Joomla\CMS\Date) JsonapiView (Joomla\Component\Banners\Api\View\Clients) PrivateKeyInfo (phpseclib3\File\ASN1\Maps) Logger\W3cLogger (Joomla\CMS\Log)
Date (Joomla\CMS\HTML\Helpers) JsonapiView (Joomla\Component\Categories\Api\View\Categories) PrivateKeyUsagePeriod (phpseclib3\File\ASN1\Maps) WarningsModel (Joomla\Component\Installer\Administrator\Model)
DateCaster (Symfony\Component\VarDumper\Caster) JsonapiView (Joomla\Component\Config\Api\View\Application) ProcessHelper (Symfony\Component\Console\Helper) WebApplication (Joomla\CMS\Application)
DayOfMonthField (Cron) JsonapiView (Joomla\Component\Config\Api\View\Component) ProcessorInterface (Joomla\CMS\Application\CLI\Output\Processor) WebApplication (Joomla\Application)
DayOfWeekField (Cron) JsonapiView (Joomla\Component\Contact\Api\View\Contacts) ProfileCollector (Joomla\Plugin\System\Debug\DataCollector) WebApplicationInterface (Joomla\Application)
Debug (Joomla\CMS\HTML\Helpers) JsonapiView (Joomla\Component\Modules\Api\View\Modules) ProfileController (Joomla\Component\Users\Site\Controller) WebAssetAttachBehaviorInterface (Joomla\CMS\WebAsset)
Debug (Symfony\Component\ErrorHandler) JsonapiView (Joomla\Component\Content\Api\View\Articles) ProfileModel (Joomla\Component\Users\Site\Model) WebAssetExceptionInterface (Joomla\CMS\WebAsset\Exception)
DebugBar (DebugBar) JsonapiView (Joomla\Component\Contenthistory\Api\View\History) Profiler (Joomla\CMS\Profiler) WebAssetItem (Joomla\CMS\WebAsset)
DebugBarException (DebugBar) JsonapiView (Joomla\Component\Fields\Api\View\Fields) ProgressBar (Symfony\Component\Console\Helper) WebAssetItemInterface (Joomla\CMS\WebAsset)
DebugBarHtmlDumper (DebugBar\DataFormatter\VarDumper) JsonapiView (Joomla\Component\Fields\Api\View\Groups) ProgressIndicator (Symfony\Component\Console\Helper) WebAssetManager (Joomla\CMS\WebAsset)
DebugBarVarDumper (DebugBar\DataFormatter) JsonapiView (Joomla\Component\Installer\Api\View\Manage) Propel2Collector (DebugBar\Bridge) WebAssetManagerInterface (Joomla\CMS\WebAsset)
DebugClassLoader (Symfony\Component\ErrorHandler) JsonapiView (Joomla\Component\Languages\Api\View\Languages) PropelCollector (DebugBar\Bridge) WebAssetRegistry (Joomla\CMS\Service\Provider)
DebugEventDispatcherCommand (Joomla\Event\Command) JsonapiView (Joomla\Component\Languages\Api\View\Overrides) ProtectedKeyException (Joomla\DI\Exception) WebAssetRegistry (Joomla\CMS\WebAsset)
DebugFormatterHelper (Symfony\Component\Console\Helper) JsonapiView (Joomla\Component\Languages\Api\View\Strings) ProviderAwareAuthenticationPluginInterface (Joomla\CMS\Authentication) WebAssetRegistryAssetChanged (Joomla\CMS\Event\WebAsset)
DebuggroupModel (Joomla\Component\Users\Administrator\Model) JsonapiView (Joomla\Component\Media\Api\View\Adapters) ProviderInterface (Joomla\Component\Media\Administrator\Provider) WebAssetRegistryInterface (Joomla\CMS\WebAsset)
DebugHelper (Joomla\Component\Users\Administrator\Helper) JsonapiView (Joomla\Component\Media\Api\View\Media) ProviderManager (Joomla\Component\Media\Administrator\Provider) Webauthn (Joomla\Plugin\System\Webauthn\Extension)
DebugMonitor (Joomla\Database\Monitor) JsonapiView (Joomla\Component\Menus\Api\View\Items) ProxyManagerCaster (Symfony\Component\VarDumper\Caster) Webauthn (Joomla\Plugin\Multifactorauth\Webauthn\Extension)
DebugRouterCommand (Joomla\Router\Command) JsonapiView (Joomla\Component\Messages\Api\View\Messages) PS256 (Jose\Component\Signature\Algorithm) WebauthnField (Joomla\Plugin\System\Webauthn\Field)
DebuguserModel (Joomla\Component\Users\Administrator\Model) JsonapiView (Joomla\Component\Newsfeeds\Api\View\Feeds) PS256 (Cose\Algorithm\Signature\RSA) WebClient (Joomla\Application\Web)
DecimalFractionTag (CBOR\Tag) JsonapiView (Joomla\Component\Plugins\Api\View\Plugins) PS384 (Jose\Component\Signature\Algorithm) WebcronLinkField (Joomla\Component\Scheduler\Administrator\Field)
Decoder (Lcobucci\JWT\Parsing) JsonapiView (Joomla\Component\Privacy\Api\View\Consents) PS384 (Cose\Algorithm\Signature\RSA) WhosonlineHelper (Joomla\Module\Whosonline\Site\Helper)
Decoder (CBOR) JsonapiView (Joomla\Component\Privacy\Api\View\Requests) PS512 (Cose\Algorithm\Signature\RSA) WincacheHandler (Joomla\Session\Handler)
DecryptionException (Joomla\Crypt\Exception) JsonapiView (Joomla\Component\Redirect\Api\View\Redirect) PS512 (Jose\Component\Signature\Algorithm) WincacheStorage (Joomla\CMS\Cache\Storage)
BCMath\DefaultEngine (phpseclib3\Math\BigInteger\Engines) JsonapiView (Joomla\Component\Tags\Api\View\Tags) Psr17Factory (Nyholm\Psr7\Factory) Word (Doctrine\Inflector\Rules)
GMP\DefaultEngine (phpseclib3\Math\BigInteger\Engines) JsonapiView (Joomla\Component\Templates\Api\View\Styles) PSS (phpseclib3\Crypt\RSA\Formats\Keys) WordInflector (Doctrine\Inflector)
PHP\DefaultEngine (phpseclib3\Math\BigInteger\Engines) JsonapiView (Joomla\Component\Users\Api\View\Groups) PSSRSA (Cose\Algorithm\Signature\RSA) Workflow (Joomla\CMS\Workflow)
DefaultTimeGenerator (Ramsey\Uuid\Generator) JsonapiView (Joomla\Component\Users\Api\View\Levels) RSA\PublicKey (phpseclib3\Crypt) WorkflowComponentSectionsField (Joomla\CMS\Form\Field)
DefaultUuidBuilder (Ramsey\Uuid\Builder) JsonapiView (Joomla\Component\Users\Api\View\Users) DH\PublicKey (phpseclib3\Crypt) WorkflowconditionField (Joomla\CMS\Form\Field)
DefaultView (Joomla\CMS\Installation\View) JsonApiView (Joomla\CMS\MVC\View) PublicKey (phpseclib3\Crypt\Common) WorkflowcontextsField (Joomla\Component\Workflow\Administrator\Field)
DegradedNumberConverter (Ramsey\Uuid\Converter\Number) JSONController (Joomla\CMS\Installation\Controller) EC\PublicKey (phpseclib3\Crypt) WorkflowController (Joomla\Component\Workflow\Administrator\Controller)
DegradedTimeConverter (Ramsey\Uuid\Converter\Time) JsonConverter (Jose\Component\Core\Util) PublicKey (FG\X509) WorkflowFunctionalityUsedEvent (Joomla\CMS\Event\Workflow)
DegradedUuid (Ramsey\Uuid) JsonDescriptor (Symfony\Component\Console\Descriptor) DSA\PublicKey (phpseclib3\Crypt) WorkflowHelper (Joomla\Component\Workflow\Administrator\Helper)
DegradedUuidBuilder (Ramsey\Uuid\Builder) JsonDocument (Joomla\CMS\Document) PublicKey (phpseclib3\File\ASN1\Maps) WorkflowModel (Joomla\Component\Workflow\Administrator\Model)
DelegatingPsrLogger (Joomla\CMS\Log) JSONFlattenedSerializer (Jose\Component\Signature\Serializer) PublicKeyAndChallenge (phpseclib3\File\ASN1\Maps) WorkflowModelInterface (Joomla\CMS\MVC\Model)
DeleteUserCommand (Joomla\CMS\Console) JSONGeneralSerializer (Jose\Component\Signature\Serializer) PublicKeyCredential (Webauthn) WorkflowsController (Joomla\Component\Workflow\Administrator\Controller)
DemoTasks (Joomla\Plugin\Task\DemoTasks\Extension) JsonRenderer (Joomla\CMS\Error\Renderer) PublicKeyCredentialCreationOptions (Webauthn) WorkflowServiceInterface (Joomla\CMS\Workflow)
DependencyResolutionException (Joomla\DI\Exception) JsonRenderer (Joomla\CMS\Installation\Error\Renderer) PublicKeyCredentialDescriptor (Webauthn) WorkflowsModel (Joomla\Component\Workflow\Administrator\Model)
DerivedKeys (Defuse\Crypto) JsonResponse (Joomla\CMS\Response) PublicKeyCredentialDescriptorCollection (Webauthn) WorkflowStage (Joomla\CMS\HTML\Helpers)
DES (phpseclib3\Crypt) JsonResponse (Joomla\CMS\Installation\Response) PublicKeyCredentialEntity (Webauthn) WorkflowstageField (Joomla\CMS\Form\Field)
Descriptor (Symfony\Component\Console\Descriptor) Response\JsonResponse (Laminas\Diactoros) PublicKeyCredentialLoader (Webauthn) WorkflowTable (Joomla\Component\Workflow\Administrator\Table)
DescriptorHelper (Symfony\Component\Console\Helper) JsonView (Joomla\Component\Templates\Administrator\View\Style) PublicKeyCredentialOptions (Webauthn) WorkflowTransitionEvent (Joomla\CMS\Event\Workflow)
DescriptorHelper (Joomla\Console\Helper) JsonView (Joomla\CMS\MVC\View) PublicKeyCredentialParameters (Webauthn) WrappableOutputFormatterInterface (Symfony\Component\Console\Formatter)
DescriptorInterface (Symfony\Component\Console\Descriptor) JsonView (Joomla\Component\Admin\Administrator\View\Sysinfo) PublicKeyCredentialRequestOptions (Webauthn) WrapperComponent (Joomla\Component\Wrapper\Administrator\Extension)
DeserializationException (TYPO3\PharStreamWrapper\Phar) JWK (Jose\Component\Core) PublicKeyCredentialRpEntity (Webauthn) WrapperHelper (Joomla\Module\Wrapper\Site\Helper)
DeserializationException (Laminas\Diactoros\Exception) JWKSet (Jose\Component\Core) PublicKeyCredentialSource (Webauthn) WritableContainerLoader (Joomla\CMS\Console\Loader)
DH (phpseclib3\Crypt) JWS (Jose\Component\Signature) PublicKeyCredentialSourceRepository (Webauthn) WritableLoaderInterface (Joomla\CMS\Console\Loader)
DHParameter (phpseclib3\File\ASN1\Maps) JWSBuilder (Jose\Component\Signature) PublicKeyCredentialUserEntity (Webauthn) WrongKeyOrModifiedCiphertextException (Defuse\Crypto\Exception)
DigestInfo (phpseclib3\File\ASN1\Maps) JWSBuilderFactory (Jose\Component\Signature) PublicKeyInfo (phpseclib3\File\ASN1\Maps)
x
Directory (Joomla\Component\Admin\Administrator\Service\HTML) JWSLoader (Jose\Component\Signature) PublicKeyLoader (phpseclib3\Crypt)
DirectoryString (phpseclib3\File\ASN1\Maps) JWSLoaderFactory (Jose\Component\Signature) PublishedButton (Joomla\CMS\Button) X25519 (ParagonIE\Sodium\Core)
DiscoverController (Joomla\Component\Installer\Administrator\Controller) JWSSerializer (Jose\Component\Signature\Serializer) PunycodeHelper (Joomla\CMS\String) X509 (phpseclib3\File)
DiscoverModel (Joomla\Component\Installer\Administrator\Model) JWSSerializerManager (Jose\Component\Signature\Serializer) PunycodeInterface (Algo26\IdnaConvert\Punycode) XChaCha20 (ParagonIE\Sodium\Core)
Dispatcher (Joomla\CMS\Dispatcher) JWSSerializerManagerFactory (Jose\Component\Signature\Serializer) PuTTY (phpseclib3\Crypt\DSA\Formats\Keys) Xml (Joomla\CMS\Application\CLI\Output)
Dispatcher (Joomla\Component\Users\Administrator\Dispatcher) JWSTokenSupport (Jose\Component\Signature) PuTTY (phpseclib3\Crypt\RSA\Formats\Keys) XML (phpseclib3\Crypt\RSA\Formats\Keys)
Dispatcher (Joomla\Component\Associations\Administrator\Dispatcher) JWSVerifier (Jose\Component\Signature) PuTTY (phpseclib3\Crypt\Common\Formats\Keys) XML (phpseclib3\Crypt\DSA\Formats\Keys)
Dispatcher (Joomla\Component\Joomlaupdate\Administrator\Dispatcher) JWSVerifierFactory (Jose\Component\Signature) PuTTY (phpseclib3\Crypt\EC\Formats\Keys) Xml (Joomla\Registry\Format)
Dispatcher (Joomla\Component\Admin\Administrator\Dispatcher) JWT (Jose\Component\Core)
q
XML (phpseclib3\Crypt\EC\Formats\Keys)
Dispatcher (Joomla\Component\Contenthistory\Administrator\Dispatcher)
k
XmlDescriptor (Symfony\Component\Console\Descriptor)
Dispatcher (Joomla\Component\Workflow\Administrator\Dispatcher) Query (Joomla\Component\Finder\Administrator\Service\HTML) XmlDocument (Joomla\CMS\Document)
Dispatcher (Joomla\Component\Login\Administrator\Dispatcher) KeepaliveAssetItem (Joomla\CMS\WebAsset\AssetItem) Query (Joomla\Component\Finder\Administrator\Indexer) XmlReaderCaster (Symfony\Component\VarDumper\Caster)
Dispatcher (Joomla\Component\Categories\Administrator\Dispatcher) Signer\Key (Lcobucci\JWT) Query (Symfony\Component\Ldap\Adapter\ExtLdap) XmlRenderer (Joomla\CMS\Error\Renderer)
Dispatcher (Joomla\Module\Quickicon\Administrator\Dispatcher) Key (Cose\Key) QueryCollector (Joomla\Plugin\System\Debug\DataCollector) XmlResourceCaster (Symfony\Component\VarDumper\Caster)
Dispatcher (Joomla\Component\Cpanel\Administrator\Dispatcher) Key (Defuse\Crypto) QueryElement (Joomla\Database\Query) Response\XmlResponse (Laminas\Diactoros)
Dispatcher (Joomla\Component\Media\Administrator\Dispatcher) Key (Joomla\Crypt) QueryHelper (Joomla\Component\Content\Site\Helper) XmlView (Joomla\Component\Menus\Administrator\View\Menu)
Dispatcher (Joomla\Component\Fields\Administrator\Dispatcher) Signer\Keychain (Lcobucci\JWT) QueryInterface (Joomla\Database) XmlView (Joomla\Component\Privacy\Administrator\View\Export)
Dispatcher (Joomla\Component\Config\Site\Dispatcher) KeyChecker (Jose\Component\Core\Util) QueryInterface (Symfony\Component\Ldap\Adapter) XPath (enshrined\svgSanitize\data)
Dispatcher (Joomla\Component\Contact\Site\Dispatcher) KeyIdentifier (phpseclib3\File\ASN1\Maps) QueryMonitorInterface (Joomla\Database) Xsalsa20 (ParagonIE\Sodium\Core)
Dispatcher (Joomla\CMS\Service\Provider) KeyNotFoundException (Joomla\DI\Exception) QueryTypeAlreadyDefinedException (Joomla\Database\Exception)
y
Dispatcher (Joomla\Component\Content\Site\Dispatcher) KeyOrPassword (Defuse\Crypto) Question (Symfony\Component\Console\Question)
Dispatcher (Joomla\Component\Contenthistory\Site\Dispatcher) KeyProtectedByPassword (Defuse\Crypto) QuestionHelper (Symfony\Component\Console\Helper) Yaml (Joomla\Registry\Format)
Dispatcher (Joomla\Component\Fields\Site\Dispatcher) KeyPurposeId (phpseclib3\File\ASN1\Maps) QuickIconHelper (Joomla\Module\Quickicon\Administrator\Helper) Yaml (Symfony\Component\Yaml)
Dispatcher (Joomla\Component\Media\Site\Dispatcher) KeyUsage (phpseclib3\File\ASN1\Maps) QuickIconsEvent (Joomla\Module\Quickicon\Administrator\Event) Yubikey (Joomla\Plugin\Multifactorauth\Yubikey\Extension)
Dispatcher (Joomla\Component\Menus\Site\Dispatcher) KoblitzPrime (phpseclib3\Crypt\EC\BaseCurves)
r
z
Dispatcher (Joomla\Component\Modules\Site\Dispatcher)
l
Dispatcher (Joomla\Module\ArticlesLatest\Site\Dispatcher) RadiobasicField (Joomla\CMS\Form\Field) Language\Zh (Joomla\Component\Finder\Administrator\Indexer)
Dispatcher (Joomla\Module\ArticlesNews\Site\Dispatcher) LangActiveAssetItem (Joomla\CMS\WebAsset\AssetItem) RadioField (Joomla\CMS\Form\Field) Zip (Joomla\Archive)
Dispatcher (Joomla\Component\Privacy\Administrator\Dispatcher) Language (Joomla\CMS\Table) Random (phpseclib3\Crypt) ZIPExtraction
a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z


Joomla CMS: Hiérarchie des classes

Hiérarchie des classes
Cette liste d'héritage est classée approximativement par ordre alphabétique :
[Niveau de détails 12345678]
▶C AbstractAES
C Mcrypt
C OpenSSL
▶C AbstractCommand
C AddUserCommand
C AddUserToGroupCommand
C ChangeUserPasswordCommand
C CheckJoomlaUpdatesCommand
C CheckUpdatesCommand
C CleanCacheCommand
C DeleteUserCommand
C ExtensionDiscoverCommand
C ExtensionDiscoverInstallCommand
C ExtensionInstallCommand
C ExtensionRemoveCommand
▶C ExtensionsListCommand
C ExtensionDiscoverListCommand
C FinderIndexCommand
C GetConfigurationCommand
C ListUserCommand
C RemoveOldFilesCommand
C RemoveUserFromGroupCommand
C SessionGcCommand
C SessionMetadataGcCommand
C SetConfigurationCommand
C SiteDownCommand
C SiteUpCommand
C TasksListCommand
C TasksRunCommand
C TasksStateCommand
C UpdateCoreCommand
C HelpCommand
C ListCommand
C ExportCommand
C ImportCommand
C DebugEventDispatcherCommand
C DebugRouterCommand
C CreateSessionTableCommand
▶C AbstractIdnaConvert
C ToIdn
C ToUnicode
▶C AbstractMenu
C AdministratorMenu
C SiteMenu
▶C AbstractNegotiator
C CharsetNegotiator
C EncodingNegotiator
C LanguageNegotiator
C Negotiator
▶C AbstractPunycode
C FromPunycode
C ToPunycode
▶C AbstractSerializer
C Serializer
C Serializer
▶C AcceptHeader
C Accept
C AcceptCharset
C AcceptEncoding
C AcceptLanguage
C AcceptMatch
C Access
C Access
C AccessDescription
▶C ActionButton
C FeaturedButton
C PublishedButton
C TransitionButton
C ActionlogsHelper
C ActionsDropdown
▶C AdapterInterface
C LocalAdapter
▶C AdapterInterface
C Adapter
C AdministrationDomainName
C AdministratorService
C AdministratorService
C AdministratorService
C AdministratorService
C AdminLanguage
C Aes
▶C AesInterface
C Mcrypt
C OpenSSL
C Agent
▶C Algorithm
▶C Mac
▶C Hmac
C HS256
C HS256Truncated64
C HS384
C HS512
▶C Signature
▶C ECDSA
C ES256
C ES256K
C ES384
C ES512
▶C EdDSA
C Ed25519
C ED256
C ED512
▶C PSSRSA
C PS256
C PS384
C PS512
▶C RSA
C RS1
C RS256
C RS384
C RS512
▶C Algorithm
▶C MacAlgorithm
▶C HMAC
C HS1
C HS256
C HS256_64
C HS384
C HS512
▶C SignatureAlgorithm
▶C ECDSA
C ES256
C ES256K
C ES384
C ES512
C EdDSA
C None
C RSA
▶C RSAPKCS1
C RS1
C RS256
C RS384
C RS512
▶C RSAPSS
C PS256
C PS384
C PS512
C AlgorithmIdentifier
C AlgorithmManager
C AlgorithmManagerFactory
C Algorithms
C AmqpCaster
C AnotherName
C ANSI
C ApplicationDescription
C ApplicationDescription
C ApplicationEvents
C ApplicationHelper
▶C ApplicationInterface
▶C ConfigurationAwareApplicationInterface
▶C AbstractApplication
▶C AbstractWebApplication
C WebApplication
▶C WebApplication
▶C CMSApplication
C AdministratorApplication
C ApiApplication
C SiteApplication
C InstallationApplication
C BaseApplication
▶C CliApplication
C DaemonApplication
▶C Application
C ConsoleApplication
▶C CMSApplicationInterface
C CliApplication
▶C CMSWebApplicationInterface
C CMSApplication
C ConsoleApplication
▶C WebApplicationInterface
C AbstractWebApplication
▶C SessionAwareWebApplicationInterface
C WebApplication
C CMSWebApplicationInterface
C ApplicationTester
C Archive
C ArrayHelper
C ArraySerializer
C ArraySerializer
C ArticlesArchiveHelper
C ArticlesCategoriesHelper
C ArticlesCategoryHelper
C ArticlesPopularHelper
C ASCII
C AsCommand
C ASN1
C ASN1
C ASN1
C Assert
C Assert
▶C Assertable
C Behavior
C ConjunctionInterceptor
C PharExtensionInterceptor
C PharMetaDataInterceptor
C Assertion
C AssertionChain
▶C AssetProvider
C DoctrineCollector
C NamespacedTwigProfileCollector
C Propel2Collector
C PropelCollector
C SwiftMailCollector
C TwigCollector
C TwigProfileCollector
C ConfigCollector
▶C MessagesCollector
C SlimCollector
C SwiftLogCollector
C PDOCollector
C RequestDataCollector
C DebugBarVarDumper
C InfoCollector
C LanguageErrorsCollector
C LanguageFilesCollector
C LanguageStringsCollector
C QueryCollector
▶C AssociationExtensionInterface
▶C AssociationExtensionHelper
C AssociationsHelper
C AssociationsHelper
C AssociationsHelper
C AssociationsHelper
C Associations
▶C AssociationServiceInterface
C ContactComponent
C ContentComponent
C MenusComponent
C NewsfeedsComponent
▶C AsymmetricKey
▶C DH
C Parameters
C PrivateKey
C PublicKey
▶C DSA
C Parameters
C PrivateKey
C PublicKey
▶C EC
C Parameters
C PrivateKey
C PublicKey
▶C RSA
C PrivateKey
C PublicKey
C AttestationObject
C AttestationObjectLoader
▶C AttestationStatementSupport
C AndroidKeyAttestationStatementSupport
C FidoU2FAttestationStatementSupport
C AndroidKeyAttestationStatementSupport
C FidoU2FAttestationStatementSupport
C AndroidKeyAttestationStatementSupport
C AndroidSafetyNetAttestationStatementSupport
C FidoU2FAttestationStatementSupport
C NoneAttestationStatementSupport
C PackedAttestationStatementSupport
C TPMAttestationStatementSupport
C AttestationStatementSupportManager
C Attribute
C Attribute
▶C AttributeInterface
C AllowedAttributes
C Attributes
C AttributeType
C AttributeTypeAndValue
C AttributeValue
C Authentication
C Authentication
C Authentication
C AuthenticationExtensionsClientOutputsLoader
C AuthenticationHelper
C AuthenticationResponse
▶C AuthenticationStrategyInterface
▶C AbstractUsernamePasswordAuthenticationStrategy
C DatabaseStrategy
C LocalStrategy
C AuthenticatorAssertionResponseValidator
C AuthenticatorAttestationResponseValidator
C AuthenticatorData
▶C AuthenticatorResponse
C AuthenticatorAssertionResponse
C AuthenticatorAttestationResponse
C AuthenticatorStatus
C AuthorityInfoAccessSyntax
C AuthorityKeyIdentifier
C Autoloader
C Banner
C BannerHelper
C BannersHelper
▶C Base
▶C Binary
C sect113r1
C sect113r2
C sect131r1
C sect131r2
▶C sect163k1
C nistk163
C sect163r1
C sect163r2
C sect193r1
C sect193r2
▶C sect233k1
C nistk233
▶C sect233r1
C nistb233
C sect239k1
▶C sect283k1
C nistk283
C sect283r1
▶C sect409k1
C nistk409
▶C sect409r1
C nistb409
▶C sect571k1
C nistt571
C sect571r1
▶C Montgomery
C Curve25519
C Curve448
▶C Prime
▶C KoblitzPrime
C secp160k1
C secp192k1
C secp224k1
C secp256k1
C brainpoolP160r1
C brainpoolP160t1
C brainpoolP192r1
C brainpoolP192t1
C brainpoolP224r1
C brainpoolP224t1
C brainpoolP256r1
C brainpoolP256t1
C brainpoolP320r1
C brainpoolP320t1
C brainpoolP384r1
C brainpoolP384t1
C brainpoolP512r1
C brainpoolP512t1
C prime192v2
C prime192v3
C prime239v1
C prime239v2
C prime239v3
C secp112r1
C secp112r2
C secp128r1
C secp128r2
C secp160r1
C secp160r2
▶C secp192r1
C nistp192
C prime192v1
▶C secp224r1
C nistp224
▶C secp256r1
C nistp256
C prime256v1
▶C secp384r1
C nistp384
▶C secp521r1
C nistp521
▶C TwistedEdwards
C Ed25519
C Ed448
C Base128
C Base32
C Base64Url
▶C BaseAccept
C Accept
C AcceptCharset
C AcceptEncoding
C AcceptLanguage
C BaseDistance
C BasicConstraints
C BCMath
C Behavior
C BigInteger
▶C BigInteger
C BigIntegerBcmath
C BigIntegerGmp
C Binary
C BinaryUtils
C BiometricAccuracyDescriptor
C BiometricStatusReport
▶C BootableExtensionInterface
C AdminComponent
C BannersComponent
C CategoriesComponent
C ContactComponent
C ContentComponent
C FinderComponent
C InstallerComponent
C LanguagesComponent
C MenusComponent
C MessagesComponent
C ModulesComponent
C NewsfeedsComponent
C PrivacyComponent
C RedirectComponent
C SchedulerComponent
C TemplatesComponent
C UsersComponent
C Bootstrap
C Bootup
C BreadcrumbsHelper
C Browser
C Buffer
C BufferStreamHandler
C Builder
C BuiltInDomainDefinedAttribute
C BuiltInDomainDefinedAttributes
C BuiltInStandardAttributes
C CaBundle
C Cache
▶C CacheController
C CallbackController
C OutputController
C PageController
C ViewController
▶C CacheControllerFactoryAwareInterface
▶C HtmlDocument
C ErrorDocument
C SiteMenu
▶C BaseDatabaseModel
▶C BaseInstallationModel
C ChecksModel
C CleanupModel
C ConfigurationModel
C DatabaseModel
C LanguagesModel
C SetupModel
▶C FormModel
▶C AdminModel
C BannerModel
C ClientModel
C CategoryModel
▶C ContactModel
▶C FormModel
C ContactModel
▶C ArticleModel
C FeatureModel
C FormModel
C FieldModel
C GroupModel
C FilterModel
C UpdatesiteModel
C LanguageModel
C OverrideModel
C TemplateModel
C ItemModel
C MessageModel
C ModuleModel
C NewsfeedModel
C PluginModel
C RequestModel
C ConfirmModel
C RemindModel
C RequestModel
C LinkModel
C TaskModel
C TagModel
C StyleModel
C GroupModel
C LevelModel
C MailModel
C NoteModel
C UserModel
C StageModel
C TransitionModel
C WorkflowModel
C DownloadModel
C ApplicationModel
C ComponentModel
▶C FormModel
C ConfigModel
C ModulesModel
C TemplatesModel
C FileModel
C MenuModel
C ConfigModel
C TemplateModel
C LoginModel
C ProfileModel
C RegistrationModel
C RemindModel
C ResetModel
▶C ItemModel
C ArticleModel
C PreviewModel
C NewsfeedModel
▶C ListModel
C ActionlogsModel
C AssociationModel
C AssociationsModel
C BannersModel
C ClientsModel
C TracksModel
C BannersModel
C CacheModel
C CategoriesModel
C CheckinModel
C ContactsModel
C CategoriesModel
C CategoryModel
C FeaturedModel
▶C ArticlesModel
C FeaturedModel
▶C ArticlesModel
C ArchiveModel
C FeaturedModel
C CategoriesModel
C CategoryModel
C CompareModel
C HistoryModel
C FieldsModel
C GroupsModel
C FiltersModel
C IndexModel
C MapsModel
C SearchesModel
C SearchModel
C SuggestionsModel
▶C InstallerModel
C DatabaseModel
C DiscoverModel
C ManageModel
C UpdatesitesModel
C LanguagesModel
C UpdateModel
C WarningsModel
C InstalledModel
C LanguagesModel
C OverridesModel
C TemplatesModel
C ItemsModel
C MenusModel
C MessagesModel
C ModulesModel
C PositionsModel
C SelectModel
C NewsfeedsModel
C CategoriesModel
C CategoryModel
C PluginsModel
C ConsentsModel
C RequestsModel
C LinksModel
C SelectModel
C TasksModel
C TagsModel
C TagModel
C TagsModel
C StylesModel
C TemplatesModel
C DebuggroupModel
C DebuguserModel
C GroupsModel
C LevelsModel
C NotesModel
C UsersModel
C StagesModel
C TransitionsModel
C WorkflowsModel
C ActionlogConfigModel
C ActionlogModel
C HelpModel
C SysinfoModel
C BannerModel
C IndexerModel
C StatisticsModel
C InstallModel
C UpdateModel
C StringsModel
C LoginModel
C ApiModel
C MediaModel
C MenutypesModel
C MessagesModel
C ExportModel
C RemoveModel
▶C BackupcodesModel
C BackupcodesModel
▶C CaptiveModel
C CaptiveModel
▶C MethodModel
C MethodModel
▶C MethodsModel
C MethodsModel
▶C CacheControllerFactoryInterface
C CacheControllerFactory
▶C CacheExceptionInterface
C CacheConnectingException
C UnsupportedCacheException
▶C CacheStorage
C ApcuStorage
C FileStorage
C MemcachedStorage
C RedisStorage
C WincacheStorage
C CacheStorageHelper
▶C Calculator
C BcMathCalculator
C GmpCalculator
C NativeCalculator
C Caster
▶C CategoriesHelper
C CategoriesHelper
C Category
▶C CategoryAssociationHelper
C AssociationHelper
C AssociationHelper
C AssociationHelper
▶C CategoryFactoryInterface
C CategoryFactory
▶C CategoryInterface
▶C Categories
C Category
C Category
C Category
C Category
▶C CategoryServiceInterface
C LegacyComponent
C BannersComponent
C ContactComponent
C ContentComponent
C FieldsComponent
C NewsfeedsComponent
▶C CBORObject
▶C AbstractCBORObject
C ByteStringObject
C ByteStringWithChunkObject
C InfiniteListObject
C InfiniteMapObject
C ListObject
C MapObject
C OtherObject
C SignedIntegerObject
▶C TagObject
C BreakObject
C DoublePrecisionFloatObject
C FalseObject
C GenericObject
C HalfPrecisionFloatObject
C NullObject
C SimpleObject
C SinglePrecisionFloatObject
C TrueObject
C UndefinedObject
C Base16EncodingTag
C Base64EncodingTag
C Base64UrlEncodingTag
C BigFloatTag
C DecimalFractionTag
C EpochTag
C GenericTag
C NegativeBigIntegerTag
C PositiveBigIntegerTag
C TimestampTag
C Integer
C Integer
C TextStringObject
C TextStringWithChunkObject
C UnsignedIntegerObject
C Certificate
C CertificateIssuer
C CertificateList
C CertificatePolicies
C CertificateSerialNumber
C CertificateToolbox
C CertificationRequest
C CertificationRequestInfo
C CertPolicyId
▶C ChangeItem
C MysqlChangeItem
C PostgresqlChangeItem
C SqlsrvChangeItem
C ChangeSet
C Characteristic_two
▶C CheckIfRehashNeededHandlerInterface
C Argon2idHandler
C Argon2iHandler
C BCryptHandler
C ChainedHandler
C MD5Handler
C PHPassHandler
▶C CipherInterface
C CryptoCipher
C SodiumCipher
C Crypto
C OpenSSL
C Sodium
C ClassLoader
C ClassLoader
C Client
C Client
C ClientHelper
▶C ClientInterface
▶C Http
C Http
C CliInput
▶C CliOutput
C Stdout
C Xml
▶C ClonerInterface
▶C AbstractCloner
C VarCloner
▶C CMSHelper
C TagsHelper
▶C CMSObject
▶C Adapter
C Installer
C Updater
▶C AdapterInstance
▶C UpdateAdapter
C CollectionAdapter
C ExtensionAdapter
C CategoryNode
C Changelog
C Stream
C InstallerExtension
▶C BaseModel
C BaseDatabaseModel
C AdapterModel
C AdaptersModel
C MediaModel
C MediumModel
C CapabilitiesModel
▶C AbstractView
▶C HtmlView
▶C DefaultView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
▶C CategoriesView
C HtmlView
C HtmlView
C HtmlView
▶C CategoryFeedView
C FeedView
C FeedView
▶C CategoryView
C HtmlView
C HtmlView
C HtmlView
C FormView
C ListView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C RawView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C FeedView
C HtmlView
▶C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C XmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C FeedView
C HtmlView
C FeedView
C HtmlView
C HtmlView
C JsonView
C HtmlView
C HtmlView
C HtmlView
▶C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
▶C HtmlView
C HtmlView
▶C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
C HtmlView
▶C JsonView
▶C JsonApiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonapiView
C JsonView
C TextView
C VcfView
C FeedView
C OpensearchView
C XmlView
▶C Table
▶C Content
C ArticleTable
C ContentHistory
C ContentType
C CoreContent
C Extension
C Language
▶C MenuType
C MenuTypeTable
C Module
▶C Nested
C Asset
▶C Category
C CategoryTable
▶C Menu
C MenuTable
C MapTable
C TagTable
C Ucm
C Update
C UpdateSite
C User
C Usergroup
C ViewLevel
C BannerTable
C ClientTable
C ContactTable
C FeaturedTable
C FieldTable
C GroupTable
C FilterTable
C LinkTable
C UpdatesiteTable
C TemplateTable
C MessageTable
C NewsfeedTable
C ConsentTable
C RequestTable
C LinkTable
C TaskTable
C StyleTable
C MfaTable
C NoteTable
C StageTable
C TransitionTable
C WorkflowTable
C Update
C User
C CodeAccuracyDescriptor
▶C CodecInterface
▶C StringCodec
C GuidStringCodec
C OrderedTimeCodec
C TimestampFirstCombCodec
C TimestampLastCombCodec
▶C Collectable
C PharInvocationCollection
C CollectedClientData
C Color
C ColorStyle
▶C Command
C CompleteCommand
C DumpCompletionCommand
C HelpCommand
C LazyCommand
C ListCommand
C SingleCommandApplication
C ServerDumpCommand
C LintCommand
C CommandCompletionTester
▶C CommandLoaderInterface
C ContainerCommandLoader
C FactoryCommandLoader
C CommandTester
▶C CompletionOutputInterface
C BashCompletionOutput
C CompletionSuggestions
▶C ComponentDispatcherFactoryInterface
C ComponentDispatcherFactory
C ComponentHelper
▶C ComponentInterface
▶C Component
▶C MVCComponent
C AdminComponent
C BannersComponent
C CategoriesComponent
C ConfigComponent
C ContactComponent
C ContentComponent
C FieldsComponent
C FinderComponent
C InstallerComponent
C LanguagesComponent
C MenusComponent
C MessagesComponent
C ModulesComponent
C NewsfeedsComponent
C PrivacyComponent
C RedirectComponent
C SchedulerComponent
C TagsComponent
C TemplatesComponent
C UsersComponent
C WrapperComponent
C LegacyComponent
C ComponentRecord
C ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f
C ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
C ConfigPostProcessor
C ConfigProvider
C Configuration
C Configuration
C Connection
▶C ConnectionInterface
▶C AbstractConnection
C Connection
C ConnectionOptions
C ConsoleEvents
C ConsoleEvents
▶C Constraint
C IdentifiedBy
C IssuedBy
C PermittedFor
C RelatedTo
C SignedWith
C ValidAt
C Container
▶C ContainerAwareInterface
C CMSApplication
C SessionGcCommand
▶C InstallerAdapter
C ComponentAdapter
C FileAdapter
C LanguageAdapter
C LibraryAdapter
C ModuleAdapter
C PackageAdapter
C PluginAdapter
C TemplateAdapter
C SessionFactory
C ContainerAwareToolbarFactory
▶C ContainerExceptionInterface
C ContainerNotFoundException
C DependencyResolutionException
C ProtectedKeyException
▶C NotFoundExceptionInterface
C KeyNotFoundException
▶C ContainerInterface
C Container
C ServiceProviderInterface
C ContainerResource
C Content
▶C ContentHelper
C AssociationsHelper
▶C BannersHelper
C BannersHelper
C ConfigHelper
▶C ContactHelper
C ContactHelper
▶C ContentHelper
C ContentHelper
▶C MenusHelper
C MenusHelper
▶C NewsfeedsHelper
C NewsfeedsHelper
C PrivacyHelper
▶C UsersHelper
C UsersHelper
C StageHelper
C WorkflowHelper
C ContentHelper
▶C ContenthistoryHelper
C ContenthistoryHelper
C ContentLanguage
▶C ContextProviderInterface
C CliContextProvider
C RequestContextProvider
C SourceContextProvider
▶C ControllerInterface
▶C BaseController
C DisplayController
▶C JSONController
C InstallationController
C LanguageController
▶C AdminController
C ActionlogsController
C AssociationsController
C BannersController
C ClientsController
C CategoriesController
C ContactsController
▶C ArticlesController
C FeaturedController
C HistoryController
C FieldsController
C GroupsController
C FiltersController
C IndexController
C MapsController
C UpdatesitesController
C LanguagesController
C OverridesController
C StringsController
C ItemsController
C MessagesController
C ModulesController
C NewsfeedsController
C PluginsController
C RequestsController
C LinksController
C TasksController
C TagsController
C StylesController
C GroupsController
C LevelsController
C NotesController
C UsersController
C StagesController
C TransitionsController
C WorkflowsController
▶C ApiController
C BannersController
C ClientsController
C CategoriesController
C ApplicationController
C ComponentController
C ContactController
C ArticlesController
C HistoryController
C FieldsController
C GroupsController
C ManageController
C LanguagesController
C OverridesController
C StringsController
C AdaptersController
C MediaController
C ItemsController
C MenusController
C MessagesController
C ModulesController
C FeedsController
C PluginsController
C ConsentsController
C RequestsController
C RedirectController
C TagsController
C StylesController
C GroupsController
C LevelsController
C UsersController
▶C FormController
C AssociationController
C BannerController
C ClientController
C CategoryController
C ComponentController
C ContactController
C ContactController
C ArticleController
C ArticleController
C FieldController
C GroupController
C FilterController
C UpdatesiteController
C LanguageController
C OverrideController
C TemplateController
C ItemController
C MenuController
C MessageController
C ModuleController
C NewsfeedController
C PluginController
C ConsentsController
C RequestController
C LinkController
C TaskController
C TagController
C StyleController
C GroupController
C LevelController
C NoteController
C UserController
C StageController
C TransitionController
C WorkflowController
C DisplayController
C DisplayController
C DisplayController
C DisplayController
C TracksController
C DisplayController
C DisplayController
C AjaxController
C DisplayController
C DisplayController
C ApplicationController
C DisplayController
C RequestController
C ConfigController
C DisplayController
C ModulesController
C TemplatesController
C AjaxController
C DisplayController
C DisplayController
C AjaxController
C DisplayController
C DisplayController
C DisplayController
C PreviewController
C DisplayController
C DisplayController
C DisplayController
C DisplayController
C DisplayController
C IndexerController
C SearchesController
C DisplayController
C SuggestionsController
C DatabaseController
C DiscoverController
C DisplayController
C InstallController
C ManageController
C UpdateController
C DisplayController
C UpdateController
C DisplayController
C InstalledController
C DisplayController
C DisplayController
C ApiController
C DisplayController
C PluginController
C AjaxController
C DisplayController
C MenusController
C ConfigController
C DisplayController
C DisplayController
C DisplayController
C AjaxController
C DisplayController
C DisplayController
C DisplayController
C DisplayController
C MessageController
C DisplayController
C DisplayController
C RequestController
C DisplayController
C DisplayController
C DisplayController
C DisplayController
C TagsController
C DisplayController
C TemplateController
▶C CallbackController
C CallbackController
▶C CaptiveController
C CaptiveController
C DisplayController
C MailController
▶C MethodController
C MethodController
▶C MethodsController
C MethodsController
C DisplayController
C ProfileController
C RegistrationController
C RemindController
C ResetController
C UserController
C DisplayController
C DisplayController
▶C ControllerResolverInterface
▶C ControllerResolver
C ContainerControllerResolver
C Core
C CoseSignatureFixer
C CountryName
C CPSuri
▶C Credential
C PublicKeyCredential
C Credentials
C CRLDistributionPoints
C CRLNumber
C CRLReason
C CronExpression
▶C Crypt
C Crypt
▶C Crypto
C RuntimeTests
C Crypto
C CryptoExceptionHandler
C CssMenu
C Ctype
C Curl
▶C CurrentUserInterface
C BaseDatabaseModel
C HtmlView
C Cursor
C Cursor
C Curve
▶C DatabaseAwareInterface
C Categories
▶C FormField
C CalendarField
C CaptchaField
C CheckboxField
C ColorField
C ComponentlayoutField
C ContenthistoryField
C FileField
▶C GroupedlistField
C ChromestyleField
C MenuField
C MenuitemField
C TemplatestyleField
C TimezoneField
C WorkflowstageField
C ItemtypeField
C ContentmapField
C MenuItemByTypeField
C HiddenField
▶C ListField
C AccesslevelField
C AliastagField
C AuthorField
C CachehandlerField
C CategoryField
▶C CheckboxesField
C ConsentBoxField
C ComboField
▶C ComponentsField
C WorkflowComponentSectionsField
C ContentlanguageField
C ContenttypeField
C DatabaseconnectionField
▶C FilelistField
C ImagelistField
▶C FolderlistField
C TemplatesListField
C UploaddirsField
C FrontendlanguageField
C HeadertagField
C IntegerField
C LanguageField
C LimitboxField
C ModuletagField
C PluginsField
▶C PredefinedlistField
C LastvisitdaterangeField
C PluginstatusField
C RedirectStatusField
C RegistrationdaterangeField
C StatusField
C UseractiveField
C UserstateField
C LogsdaterangeField
C RequeststatusField
C RequesttypeField
C ExecutionRuleField
C TaskStateField
C RadiobasicField
▶C RadioField
C VoteradioField
C PrivacyField
C TosField
C TermsField
C SessionhandlerField
C SqlField
C TagField
C TransitionField
C UsergrouplistField
C WorkflowconditionField
C LanguageField
C ExtensionField
C LogcreatorField
C LogtypeField
C ItemlanguageField
C BannerclientField
C CategoryeditField
C ComponentsCategoryField
C ConfigComponentsField
C AssocField
C VotelistField
C ComponentsFieldgroupField
C ComponentsFieldsField
C FieldcontextsField
C FieldgroupsField
C SectionField
C SubfieldsField
C TypeField
C BranchesField
C ContenttypesField
C SearchfilterField
C ExtensionstatusField
C FolderField
C LocationField
C PackageField
C TypeField
C LanguageclientField
C MenuOrderingField
C MenuParentField
C MenuPresetField
C MenutypeField
C MessageStatesField
C ModulesModuleField
▶C ModulesPositionField
C ModulesPositionField
C NewsfeedsField
C PluginElementField
C PluginTypeField
C RedirectField
C CronField
C TaskTypeField
C TemplatelocationField
C TemplatenameField
C GroupparentField
C LevelsField
C ComponentsWorkflowField
C WorkflowcontextsField
C FontsField
C MediaField
C MeterField
C ModulelayoutField
C ModuleorderField
C NoteField
▶C NumberField
C RangeField
C IntervalField
▶C OrderingField
C PluginorderingField
C PasswordField
C RulesField
C SpacerField
▶C SubformField
C AccessiblemediaField
▶C TextareaField
C EditorField
▶C TextField
C EmailField
C ModulepositionField
C TelephoneField
C UrlField
C WebcronLinkField
C JoomlatokenField
C TimeField
▶C UserField
C UserMessagesField
C PrefixField
C PlugininfoField
C AssociationField
C ClicksField
C ImpmadeField
C ImptotalField
C CategoryField
C FiltersField
C ContactField
C ArticleField
C FieldLayoutField
C MenuField
C ModulesPositioneditField
C NewsfeedField
C TinymcebuilderField
▶C AbstractStatsField
C DataField
C UniqueidField
C WebauthnField
▶C EmailRule
C ContactEmailRule
C ExistsRule
C UserIdRule
C UsernameRule
C LanguagesModel
C Installer
C InstallerAdapter
C BaseDatabaseModel
C ArticlesLatestHelper
C ArticlesNewsHelper
C CredentialRepository
C DatabaseEvents
▶C DatabaseExporter
C MysqlExporter
C MysqliExporter
C PgsqlExporter
C DatabaseFactory
C DatabaseHelper
▶C DatabaseImporter
C MysqlImporter
C MysqliImporter
C PgsqlImporter
▶C DatabaseInterface
▶C DatabaseDriver
C MysqliDriver
▶C PdoDriver
C MysqlDriver
C PgsqlDriver
C SqliteDriver
▶C DatabaseModelInterface
C BaseDatabaseModel
▶C DataCollectorInterface
▶C MonologCollector
C CacheCacheCollector
C AggregatedCollector
▶C DataCollector
C DoctrineCollector
C NamespacedTwigProfileCollector
C Propel2Collector
C PropelCollector
C SwiftMailCollector
C TwigCollector
C TwigProfileCollector
C ConfigCollector
C ExceptionsCollector
C LocalizationCollector
C MemoryCollector
C PDOCollector
C PhpInfoCollector
C RequestDataCollector
C TimeDataCollector
▶C AbstractDataCollector
C InfoCollector
C LanguageErrorsCollector
C LanguageFilesCollector
C LanguageStringsCollector
C ProfileCollector
C QueryCollector
C SessionCollector
C MessagesCollector
▶C DataDumperInterface
▶C AbstractDumper
▶C CliDumper
▶C HtmlDumper
C DebugBarHtmlDumper
C ContextualizedDumper
C ServerDumper
▶C DataFormatterInterface
▶C DataFormatter
C DataFormatter
C DataSet
C Date
C DateCaster
C Debug
C Debug
C DebugClassLoader
▶C DebugHelper
C UsersHelperDebug
C Decoder
C Decoder
C DerivedKeys
▶C DescriptorInterface
▶C Descriptor
C JsonDescriptor
C MarkdownDescriptor
▶C TextDescriptor
C TextDescriptor
C XmlDescriptor
C DHParameter
C DigestInfo
C Directory
C DirectoryString
▶C DispatcherAwareInterface
C AbstractApplication
C BaseApplication
C CliApplication
C ConsoleApplication
▶C EventAwareInterface
C CMSApplicationInterface
C Captcha
C Editor
▶C PluginInterface
▶C CMSPlugin
C DummyPlugin
▶C ActionLogPlugin
C Joomla
▶C FieldsPlugin
▶C FieldsListPlugin
C PlgFieldsCheckboxes
C PlgFieldsList
C PlgFieldsRadio
C PlgFieldsSql
C PlgFieldsCalendar
C PlgFieldsColor
C PlgFieldsEditor
C PlgFieldsImagelist
C PlgFieldsInteger
C PlgFieldsMedia
C PlgFieldsSubform
C PlgFieldsText
C PlgFieldsTextarea
C PlgFieldsUrl
C PlgFieldsUser
C PlgFieldsUsergrouplist
▶C Adapter
C PlgFinderCategories
C PlgFinderContacts
C PlgFinderContent
C PlgFinderNewsfeeds
C PlgFinderTags
▶C MediaActionPlugin
C PlgMediaActionCrop
C PlgMediaActionResize
C PlgMediaActionRotate
▶C PrivacyPlugin
C PlgPrivacyActionlogs
C PlgPrivacyConsents
C PlgPrivacyContact
C PlgPrivacyContent
C PlgPrivacyMessage
C PlgPrivacyUser
C Basic
C Token
C Taggable
C Versionable
C Email
C Fixed
C Totp
C Webauthn
C Yubikey
C Joomlaupdate
C Cache
C Shortcut
C Webauthn
C Checkfiles
C DemoTasks
C Requests
C SiteStatus
C PlgAuthenticationCookie
C PlgAuthenticationJoomla
C PlgAuthenticationLdap
C PlgButtonArticle
C PlgButtonContact
C PlgButtonFields
C PlgButtonImage
C PlgButtonMenu
C PlgButtonModule
C PlgButtonPagebreak
C PlgButtonReadmore
C PlgCaptchaRecaptcha
C PlgCaptchaRecaptcha_Invisible
C PlgContentConfirmConsent
C PlgContentContact
C PlgContentEmailcloak
C PlgContentFields
C PlgContentFinder
C PlgContentJoomla
C PlgContentLoadmodule
C PlgContentPagebreak
C PlgContentPagenavigation
C PlgContentVote
C PlgEditorCodemirror
C PlgEditorNone
C PlgEditorTinymce
C PlgExtensionFinder
C PlgExtensionJoomla
C PlgExtensionNamespacemap
C PlgFileSystemLocal
C PlgInstallerFolderInstaller
C PlgInstallerOverride
C PlgInstallerPackageInstaller
C PlgInstallerUrlInstaller
C PlgInstallerWebinstaller
C PlgQuickiconDownloadkey
C PlgQuickiconExtensionupdate
C PlgQuickiconOverrideCheck
C PlgQuickiconPhpVersionCheck
C PlgQuickiconPrivacyCheck
C PlgSampledataBlog
C PlgSampledataMultilang
C PlgSystemAccessibility
C PlgSystemActionLogs
C PlgSystemDebug
C PlgSystemFields
C PlgSystemHighlight
C PlgSystemHttpHeaders
C PlgSystemJooa11y
C PlgSystemLanguagecode
C PlgSystemLanguageFilter
C PlgSystemLog
C PlgSystemLogout
C PlgSystemLogrotation
C PlgSystemPrivacyconsent
C PlgSystemRedirect
C PlgSystemRemember
C PlgSystemSchedulerunner
C PlgSystemSef
C PlgSystemSessionGc
C PlgSystemSkipto
C PlgSystemStats
C PlgSystemTasknotification
C PlgSystemUpdatenotification
C PlgUserContactCreator
C PlgUserJoomla
C PlgUserProfile
C PlgUserTerms
C PlgUserToken
C PlgWebservicesBanners
C PlgWebservicesConfig
C PlgWebservicesContact
C PlgWebservicesContent
C PlgWebservicesInstaller
C PlgWebservicesLanguages
C PlgWebservicesMedia
C PlgWebservicesMenus
C PlgWebservicesMessages
C PlgWebservicesModules
C PlgWebservicesNewsfeeds
C PlgWebservicesPlugins
C PlgWebservicesPrivacy
C PlgWebservicesRedirect
C PlgWebservicesTags
C PlgWebservicesTemplates
C PlgWebservicesUsers
C PlgWorkflowFeaturing
C PlgWorkflowNotification
C PlgWorkflowPublishing
C BaseController
C BaseDatabaseModel
C AbstractView
C CMSPlugin
C Table
C WebAssetRegistry
C DatabaseDriver
C DebugEventDispatcherCommand
▶C Session
C Session
▶C DispatcherInterface
▶C Dispatcher
▶C AbstractModuleDispatcher
C ModuleDispatcher
C Dispatcher
C Dispatcher
C Dispatcher
▶C ComponentDispatcher
C ApiDispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C Dispatcher
C LegacyComponentDispatcher
▶C DispatcherInterface
C Dispatcher
C DisplayPNGCharacteristicsDescriptor
C DisplayText
C DistantSingleMetadataFactory
C DistributionPoint
C DistributionPointName
C DoctrineCaster
▶C Document
C FeedDocument
C HtmlDocument
C ImageDocument
▶C JsonDocument
C JsonapiDocument
C OpensearchDocument
C RawDocument
C XmlDocument
C Domain
C DOMCaster
▶C DOMXPath
C XPath
C DownloadSource
C DraggableList
C Dropdown
C DSAParams
C DSAPrivateKey
C DSAPublicKey
C DsCaster
C DssSigValue
▶C DumpableInterface
C DataObject
C DataSet
▶C DumpDescriptorInterface
C CliDescriptor
C HtmlDescriptor
C Dumper
C Dumper
▶C DumperInterface
C AbstractDumper
C DumpServer
C EcdaaTrustAnchor
C EcdsaSigValue
C ECKey
C ECParameters
C ECPoint
C ECPrivateKey
C ECSignature
C ECSignature
C EDIPartyName
C Element
▶C ElementInterface
C Collection
C Resource
C Email
C En_GBLocalise
C Encoder
▶C EncoderInterface
▶C Base32
C Base32Hex
▶C Base64
C Base64DotSlash
C Base64DotSlashOrdered
C Base64UrlSafe
C Hex
C Encoding
C Encoding
▶C EncodingHelperInterface
C FromUtf8
C ToUtf8
C Encrypt
C EncryptedData
C EncryptedPrivateKeyInfo
C Entry
▶C EntryManagerInterface
C EntryManager
▶C Error
C ClassNotFoundError
▶C FatalError
C OutOfMemoryError
C UndefinedFunctionError
C UndefinedMethodError
▶C ErrorEnhancerInterface
C ClassNotFoundErrorEnhancer
C UndefinedFunctionErrorEnhancer
C UndefinedMethodErrorEnhancer
C ErrorHandler
C ErrorHandler
▶C ErrorRendererInterface
C CliErrorRenderer
C HtmlErrorRenderer
C SerializerErrorRenderer
C Escaper
▶C EventInterface
▶C AbstractEvent
▶C Event
▶C ApplicationEvent
C ApplicationErrorEvent
▶C AbstractEvent
▶C AbstractImmutableEvent
C AfterExtensionBootEvent
C BeforeExtensionBootEvent
C BeforeBatchEvent
C BeforeDisplayMethods
C Callback
C Captive
C GetMethod
C GetSetup
C NotifyActionLog
C SaveSetup
C Validate
C Ajax
C AjaxChallenge
C AjaxCreate
C AjaxDelete
C AjaxInitCreate
C AjaxLogin
C AjaxSaveLabel
C GetIconEvent
▶C AbstractEvent
C AfterDeleteEvent
C AfterLoadEvent
C AfterMoveEvent
C AfterReorderEvent
C AfterResetEvent
C AfterStoreEvent
▶C BeforeBindEvent
C AfterBindEvent
▶C BeforeCheckinEvent
C AfterCheckinEvent
C AfterHitEvent
C BeforeHitEvent
▶C BeforeCheckoutEvent
C AfterCheckoutEvent
C BeforeDeleteEvent
C BeforeLoadEvent
C BeforeMoveEvent
▶C BeforePublishEvent
C AfterPublishEvent
C BeforeReorderEvent
C BeforeResetEvent
C BeforeStoreEvent
C CheckEvent
C ObjectCreateEvent
C SetNewTagsEvent
C DisplayEvent
▶C AbstractEvent
C WebAssetRegistryAssetChanged
▶C AbstractEvent
C WorkflowFunctionalityUsedEvent
C WorkflowTransitionEvent
C OnGetApiFields
C OnGetApiAttributes
C OnGetApiRelation
C FeatureEvent
▶C AbstractMediaItemValidationEvent
C FetchMediaItemEvent
C FetchMediaItemsEvent
C FetchMediaItemUrlEvent
C ErrorEvent
C GenericEvent
C MediaProviderEvent
C OAuthCallbackEvent
C ExecuteTaskEvent
C QuickIconsEvent
▶C ConsoleEvent
C ApplicationErrorEvent
C BeforeCommandExecuteEvent
C CommandErrorEvent
C TerminateEvent
C ConnectionEvent
C SessionEvent
C EventImmutable
▶C Exception
C InvalidArgument
C InvalidHeader
C InvalidLanguage
C InvalidMediaType
C ExceptionCaster
C ExceptionHandler
▶C ExceptionHandlerInterface
C AuthenticationFailedExceptionHandler
C CheckinCheckoutExceptionHandler
C InvalidRouteExceptionHandler
C NotAcceptableExceptionHandler
C NotAllowedExceptionHandler
C ResourceNotFoundExceptionHandler
C SaveExceptionHandler
C SendEmailExceptionHandler
C FallbackExceptionHandler
▶C InvalidParameterExceptionHandler
C InvalidParameterExceptionHandler
C ExecRuleHelper
C Extension
C ExtensionAttribute
C ExtensionAttributes
C ExtensionDescriptor
C ExtensionHelper
▶C ExtensionManagerInterface
C CMSApplicationInterface
C ExtensionOutputChecker
C ExtensionOutputCheckerHandler
C Extensions
C ExtKeyUsageSyntax
▶C ExtractableInterface
C Bzip2
C Gzip
C Tar
C Zip
C Factory
C Factory
C Factory
▶C FactoryInterface
C Factory
C FeatureSet
C FeedEnclosure
C FeedEntry
C FeedFactory
C FeedHelper
C FeedHelper
C FeedImage
C FeedItem
C FeedLink
▶C FeedParser
C AtomParser
C RssParser
C FeedPerson
C FetchMode
C FetchOrientation
C FiberCaster
C Field
C FieldElement
▶C FieldFactoryInterface
C FieldFactory
C FieldID
▶C FieldInterface
▶C AbstractField
C DayOfMonthField
C DayOfWeekField
C HoursField
C MinutesField
C MonthField
▶C FieldsHelper
C FieldsHelper
▶C FieldsServiceInterface
C LegacyComponent
C ContactComponent
C ContentComponent
C UsersComponent
C File
C File
C File
C FilesystemHelper
C Filter
C Finder
C FinderHelper
C FinderHelper
C FinderHelper
▶C FiniteField
C BinaryField
C PrimeField
C FlattenException
C Folder
C Folder
C Form
C Form
▶C FormatInterface
C Ini
C Json
C Php
C Xml
C Yaml
C FormBehavior
▶C FormFactoryAwareInterface
C FormController
▶C MVCFactory
C ApiMVCFactory
C FormModel
C ListModel
▶C FormFactoryInterface
C FormFactory
▶C FormFilterInterface
C IntarrayFilter
C RawFilter
C RulesFilter
C SafehtmlFilter
C TelFilter
C UnsetFilter
C UrlFilter
C FormHelper
▶C FormModelInterface
C FormModel
▶C FormRule
C BooleanRule
C CalendarRule
C CaptchaRule
C ColorRule
C CssIdentifierRule
C CssIdentifierSubstringRule
C EmailRule
C EqualsRule
C ExistsRule
▶C FilePathRule
C FolderPathExistsRule
C ModuleLayoutRule
C NotequalsRule
C NumberRule
C OptionsRule
C PasswordRule
C RulesRule
C SubformRule
C TelRule
C TimeRule
C UrlRule
C UserIdRule
C UsernameRule
C PrefixRule
C UsernameRule
C ContactEmailMessageRule
C ContactEmailSubjectRule
C ExecutionRulesRule
C LoginUniqueFieldRule
C LogoutUniqueFieldRule
C Fr_FRLocalise
C FtpClient
C FtpClient
C GeneralName
C GeneralNames
C GeneralSubtree
C GeneralSubtrees
C GithubActionReporter
C GmpCaster
C Grapheme
C Grid
▶C HandlerInterface
▶C Argon2idHandler
C Argon2idHandler
▶C Argon2iHandler
C Argon2iHandler
▶C BCryptHandler
C BCryptHandler
C ChainedHandler
C MD5Handler
C PHPassHandler
C Hash
C Hash
C HashAlgorithm
C HeaderSecurity
C Help
C Helper
C Helper
C Helper
C Helper
▶C HelperFactoryAwareInterface
C Dispatcher
C Dispatcher
▶C HelperFactoryInterface
C Module
C HelperFactory
▶C HelperInterface
▶C Helper
C DescriptorHelper
C DebugFormatterHelper
C DescriptorHelper
C FormatterHelper
C InputAwareHelper
C ProcessHelper
▶C QuestionHelper
C SymfonyQuestionHelper
C HoldInstructionCode
C HTMLHelper
▶C HttpDriverInterface
C PhpHttpDriver
C JoomlaHttpDriver
C HttpFactory
C HttpFactory
C HttpHeaderSerializer
C Icon
C Icon
C Icons
C Iconv
C Identifier
▶C IdnaConvertInterface
C ToIdn
C ToUnicode
C Image
▶C ImageFilter
C Backgroundfill
C Brightness
C Contrast
C Edgedetect
C Emboss
C Grayscale
C Negate
C Sketchy
C Smooth
C ImagineCaster
▶C ImmutableNodeInterface
▶C NodeInterface
C CategoryNode
▶C MenuItem
C AdministratorMenuItem
C Indexer
C Inflectible
C Inflectible
C Inflectible
C Inflectible
C Inflectible
C Inflectible
▶C Inflector
C Inflector
C Inflector
C InflectorFactory
▶C InflectorInterface
C EnglishInflector
C FrenchInflector
C Inline
C InputArgument
▶C InputAwareInterface
C InputAwareHelper
C InputDefinition
▶C InputFilter
C InputFilter
▶C InputInterface
▶C Input
▶C ArgvInput
C CompletionInput
C StringInput
C ArrayInput
▶C StreamableInputInterface
C Input
C InputOption
C InstalledVersions
▶C InstallerHelper
C InstallerHelper
C InstallerHelper
C InstallerScript
▶C InstallerScriptInterface
C LegacyInstallerScript
C IntlCaster
C InvalidityDate
C IpHelper
C IssuerAltName
C IssuingDistributionPoint
C Item
▶C ItemModelInterface
C ItemModel
▶C JavascriptRenderer
C JavascriptRenderer
C JGrid
C JHtmlIcon
C JLoader
C JNamespacePsr4Map
C JoomlaInstallerScript
C Jquery
C JsonConverter
C JsonResponse
C JsonResponse
C JWSBuilder
C JWSBuilderFactory
C JWSLoader
C JWSLoaderFactory
▶C JWSSerializer
▶C Serializer
C CompactSerializer
C JSONFlattenedSerializer
C JSONGeneralSerializer
C JWSSerializerManager
C JWSSerializerManagerFactory
C JWSVerifier
C JWSVerifierFactory
▶C JWT
C JWS
▶C Key
C InMemory
C LocalFileReference
▶C Key
C Ec2Key
C OkpKey
C RsaKey
C SymmetricKey
C Key
C Key
C Keychain
C KeyChecker
C KeyIdentifier
C KeyOrPassword
C KeyProtectedByPassword
C KeyPurposeId
C KeyUsage
C Language
C Language
▶C Language
C El
C Zh
▶C LanguageFactoryInterface
▶C LanguageFactory
C CachingLanguageFactory
▶C LanguageHelper
C FinderHelperLanguage
C LanguageHelper
▶C LanguageInflectorFactory
▶C GenericLanguageInflectorFactory
C InflectorFactory
C InflectorFactory
C InflectorFactory
C InflectorFactory
C InflectorFactory
C InflectorFactory
C Languages
C LanguagesHelper
C LanguagesHelper
C LatestActionsHelper
C LatestHelper
C LayoutHelper
▶C LayoutInterface
▶C BaseLayout
C FileLayout
C LazyAssertion
C LazyServiceEventListener
C LdapClient
▶C LdapInterface
C Ldap
C LengthCalculator
C LibraryHelper
C libsodium
▶C LimitableInterface
▶C QueryInterface
▶C DatabaseQuery
C MysqliQuery
▶C PdoQuery
C MysqlQuery
C PgsqlQuery
C SqliteQuery
▶C SqlsrvQuery
C SqlazureQuery
▶C LinkInterface
▶C EvolvableLinkInterface
C Link
C Link
▶C LinkProviderInterface
▶C EvolvableLinkProviderInterface
C GenericLinkProvider
C GenericLinkProvider
C Links
C ListHelper
▶C ListModelInterface
C ListModel
C AdaptersModel
C MediaModel
▶C LoaderInterface
▶C WritableLoaderInterface
C WritableContainerLoader
C ContainerLoader
C Log
C LogEntry
C LoggedHelper
▶C Logger
C CallbackLogger
C DatabaseLogger
C EchoLogger
▶C FormattedtextLogger
C W3cLogger
C InMemoryLogger
C MessagequeueLogger
C SyslogLogger
▶C LoggerAwareInterface
C AbstractApplication
C Task
C LoggingMonitor
▶C LoggerInterface
▶C AbstractLogger
C MessagesCollector
C DelegatingPsrLogger
C NullLogger
C ConsoleLogger
C BufferingLogger
C LoggerRegistry
C LoginHelper
C LoginHelper
C LogLevel
C MailHelper
C MailsHelper
C MailTemplate
C Manage
C Manager
C Manager
C ManagerFactory
▶C Manifest
C LibraryManifest
C PackageManifest
C Manifest
C MapItem
C MaskGenAlgorithm
C Mbstring
C MediaHelper
C MediaHelper
C MemcachedCaster
C Menu
C Menu
▶C MenuFactoryInterface
C MenuFactory
C MenuHelper
C Menus
▶C MessageInterface
▶C RequestInterface
C Request
C Request
▶C ServerRequestInterface
C ServerRequest
C ServerRequest
▶C ResponseInterface
▶C Response
▶C Response
C Response
C EmptyResponse
C HtmlResponse
C JsonResponse
C RedirectResponse
C TextResponse
C XmlResponse
C Response
C Messages
▶C MessagesAggregateInterface
C MonologCollector
C MessagesCollector
C MessagesHelper
C MetadataManager
C MetadataManagerListener
C MetadataService
C MetadataServiceFactory
C MetadataStatement
C MetadataStatementFetcher
▶C MetadataStatementRepository
C MetadataRepository
C SimpleMetadataStatementRepository
C MetadataTOCPayload
C MetadataTOCPayloadEntry
C Mfa
C Microdata
▶C ModelInterface
C BaseModel
C Module
C Module
▶C ModuleDispatcherFactoryInterface
C ModuleDispatcherFactory
C ModuleHelper
▶C ModuleInterface
C Module
C Modules
▶C ModulesHelper
C ModulesHelper
C MontgomeryPrivate
C MontgomeryPublic
C MSBLOB
C MultilangstatusHelper
C Multilanguage
▶C MVCFactoryInterface
C LegacyFactory
C MVCFactory
▶C MVCFactoryServiceInterface
C LegacyComponent
C MVCComponent
C MysqliCaster
C Name
C NameConstraints
▶C NamePrepDataInterface
C NamePrepData2003
▶C NamePrepData2008
C NamePrepData2003
▶C NamePrepInterface
C NamePrep
▶C NamespaceParserInterface
C ItunesRssParser
C MediaRssParser
C netscape_ca_policy_url
C netscape_cert_type
C netscape_comment
C NetworkAddress
▶C NodeProviderInterface
C FallbackNodeProvider
C RandomNodeProvider
C SystemNodeProvider
C Normalise
▶C Normalizer
C Normalizer
C NoticeReference
C Number
▶C NumberConverterInterface
C BigNumberConverter
C DegradedNumberConverter
C NumericUserIdentifier
▶C OAuthTokenProvider
C OAuth
C OID
C OneAsymmetricKey
C OpenHandler
C OpensearchImage
C OpensearchUrl
C OpenSSH
C OpenSSL
C OptionConfigurator
C OptionsResolverIntrospector
C ORAddress
C OrganizationalUnitNames
C OrganizationName
C OtherObjectManager
C OtherPrimeInfo
C OtherPrimeInfos
▶C OutputFilter
C OutputFilter
▶C OutputFormatterInterface
C NullOutputFormatter
▶C WrappableOutputFormatterInterface
C OutputFormatter
▶C OutputFormatterStyleInterface
C NullOutputFormatterStyle
C OutputFormatterStyle
▶C OutputInterface
▶C ConsoleOutputInterface
C ConsoleOutput
C NullOutput
▶C Output
C BufferedOutput
▶C StreamOutput
C ConsoleOutput
C ConsoleSectionOutput
C TrimmedBufferOutput
▶C OutputStyle
C SymfonyStyle
C Pagination
C PaginationObject
▶C ParagonIE_Sodium_Compat
C Compat
C ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
C ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1
C ParagonIE_Sodium_Core32_Curve25519_Ge_P2
C ParagonIE_Sodium_Core32_Curve25519_Ge_P3
C ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
C ParagonIE_Sodium_Core32_Int32
C ParagonIE_Sodium_Core32_Int64
C ParagonIE_Sodium_Core32_SecretStream_State
C ParagonIE_Sodium_Core_Base64_Common
C ParagonIE_Sodium_Core_Base64_Original
C ParagonIE_Sodium_Core_Base64_UrlSafe
▶C ParagonIE_Sodium_Core_Curve25519_Ge_Cached
C Cached
▶C ParagonIE_Sodium_Core_Curve25519_Ge_P1p1
C P1p1
▶C ParagonIE_Sodium_Core_Curve25519_Ge_P2
C P2
▶C ParagonIE_Sodium_Core_Curve25519_Ge_P3
C P3
▶C ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
C Precomp
C ParagonIE_Sodium_Core_SecretStream_State
▶C ParagonIE_Sodium_Core_Util
C Util
C ParagonIE_Sodium_Core32_BLAKE2b
▶C ParagonIE_Sodium_Core32_Util
▶C ParagonIE_Sodium_Core32_ChaCha20
▶C ParagonIE_Sodium_Core32_HChaCha20
C ParagonIE_Sodium_Core32_XChaCha20
▶C ParagonIE_Sodium_Core32_ChaCha20_Ctx
C ParagonIE_Sodium_Core32_ChaCha20_IetfCtx
▶C ParagonIE_Sodium_Core32_Curve25519_H
▶C ParagonIE_Sodium_Core32_Curve25519
C ParagonIE_Sodium_Core32_Ed25519
C ParagonIE_Sodium_Core32_X25519
C ParagonIE_Sodium_Core32_Poly1305
C ParagonIE_Sodium_Core32_Poly1305_State
▶C ParagonIE_Sodium_Core32_Salsa20
▶C ParagonIE_Sodium_Core32_HSalsa20
C ParagonIE_Sodium_Core32_XSalsa20
C ParagonIE_Sodium_Core32_SipHash
▶C ParagonIE_Sodium_Core_BLAKE2b
C BLAKE2b
▶C ParagonIE_Sodium_Core_ChaCha20
C ChaCha20
▶C ParagonIE_Sodium_Core_HChaCha20
C HChaCha20
▶C ParagonIE_Sodium_Core_XChaCha20
C XChaCha20
▶C ParagonIE_Sodium_Core_ChaCha20_Ctx
C Ctx
▶C ParagonIE_Sodium_Core_ChaCha20_IetfCtx
C IetfCtx
▶C ParagonIE_Sodium_Core_Curve25519_H
C H
▶C ParagonIE_Sodium_Core_Curve25519
C Curve25519
▶C ParagonIE_Sodium_Core_Ed25519
C Ed25519
C ParagonIE_Sodium_Core_Ristretto255
▶C ParagonIE_Sodium_Core_X25519
C X25519
▶C ParagonIE_Sodium_Core_Poly1305
C Poly1305
▶C ParagonIE_Sodium_Core_Poly1305_State
C State
▶C ParagonIE_Sodium_Core_Salsa20
C Salsa20
▶C ParagonIE_Sodium_Core_HSalsa20
C HSalsa20
▶C ParagonIE_Sodium_Core_XSalsa20
C Xsalsa20
▶C ParagonIE_Sodium_Core_SipHash
C SipHash
▶C ParagonIE_Sodium_File
C File
▶C ParagonIE_Sodium_Crypto
C Crypto
C ParagonIE_Sodium_Crypto32
C Parameters
C ParameterType
▶C Parsable
▶C AbstractString
C BMPString
C CharacterString
▶C GeneralString
C DNSName
▶C GraphicString
C ObjectDescriptor
C IA5String
C NumericString
C PrintableString
C T61String
C UniversalString
C UTF8String
C VisibleString
▶C ASNObject
C AbstractString
▶C AbstractTime
C GeneralizedTime
C UTCTime
▶C Construct
▶C Sequence
▶C AttributeTypeAndValue
C AlgorithmIdentifier
▶C Set
▶C RelativeDistinguishedName
C RDNString
C CertificateExtensions
C CertificateSubject
C CSR
C PrivateKey
C PublicKey
C UnknownConstructedObject
C Attributes
C ExplicitlyTaggedObject
C Boolean
▶C Integer
C Enumerated
C NullObject
▶C ObjectIdentifier
C RelativeObjectIdentifier
▶C OctetString
C BitString
C UnknownObject
C IPAddress
C SubjectAlternativeNames
C Construct
C BitString
C Boolean
C GeneralizedTime
C Integer
C NullObject
C ObjectIdentifier
C OctetString
C RelativeObjectIdentifier
C Sequence
C UTCTime
C CertificateExtensions
C CertificateSubject
C Attributes
C IPAddress
C SubjectAlternativeNames
C Parser
C Parser
▶C Parser
C Html
C Rtf
C Txt
C PasswordHash
C Patcher
C Patcher
C Path
C Path
▶C Pathway
C SitePathway
C Pattern
C PatternAccuracyDescriptor
C Patterns
C PBEParameter
C PBES2params
C PBKDF2params
C PBMAC1params
C PdoCaster
C Pentanomial
C PersonalName
C PgSqlCaster
C PharInvocation
C PharStreamWrapper
C Php72
C Php73
C Php80
▶C PHPMailer
C Mail
C PhpSetting
▶C PKCS
C PKCS1
C PKCS8
C PKCS9String
C PluginHelper
▶C PluginsHelper
C PluginsHelper
C PolicyInformation
C PolicyMappings
C PolicyQualifierId
C PolicyQualifierInfo
C POP3
C PopularHelper
C PostalAddress
C PostinstallHelper
▶C PreloadManagerInterface
C PreloadManager
▶C PreparableInterface
C QueryInterface
C Prime_p
C Priority
C Privacy
C PrivacyDashboardHelper
C PrivacyStatusHelper
C PrivateDomainName
▶C PrivateKey
C PrivateKey
C PrivateKey
C PrivateKey
C Identity
C PrivateKey
C PrivateKeyInfo
C PrivateKeyUsagePeriod
▶C ProcessorInterface
C ColorProcessor
C Profiler
C ProgressBar
C ProgressIndicator
C ProviderAwareAuthenticationPluginInterface
▶C ProviderInterface
C PlgFileSystemLocal
C ProviderManager
C ProxyManagerCaster
▶C PublicKey
C PublicKey
C PublicKey
C PublicKey
C PublicKey
C PublicKeyAndChallenge
C PublicKeyCredentialLoader
▶C PublicKeyCredentialSourceRepository
C CredentialRepository
C CredentialRepository
C PublicKeyInfo
C PublicKeyLoader
C PunycodeHelper
▶C PunycodeInterface
C FromPunycode
C ToPunycode
C PuTTY
C Query
C Query
C QueryElement
C QueryHelper
▶C QueryInterface
▶C AbstractQuery
C Query
▶C QueryMonitorInterface
C ChainedMonitor
C DebugMonitor
C LoggingMonitor
▶C Question
C ChoiceQuestion
C ConfirmationQuestion
C QuickIconHelper
C Random
C RandomGeneratorFactory
▶C RandomGeneratorInterface
C CombGenerator
C MtRandGenerator
C OpenSslGenerator
C PeclUuidRandomGenerator
C RandomBytesGenerator
C RandomLibAdapter
C SodiumRandomGenerator
C RandomImageHelper
▶C RandValInterface
C Randval
C Raw
C Raw
C Raw
C RC2CBCParameter
C RdKafkaCaster
C RDNSequence
C Reader
C ReasonFlags
C ReCaptcha
C Redirect
▶C RedirectHelper
C RedirectHelper
C RedisCaster
C ReflectionCaster
C RegisteredClaims
C Registry
C RelatedItemsHelper
C Relations
C Relationship
C RelativeDistinguishedName
▶C Renderable
C DoctrineCollector
C MonologCollector
C NamespacedTwigProfileCollector
C Propel2Collector
C PropelCollector
C SwiftMailCollector
C TwigCollector
C TwigProfileCollector
C ConfigCollector
C ExceptionsCollector
C LocalizationCollector
C MemoryCollector
C MessagesCollector
C PDOCollector
C PhpInfoCollector
C RequestDataCollector
C TimeDataCollector
C AbstractDataCollector
▶C RendererInterface
▶C AbstractRenderer
C CliRenderer
C HtmlRenderer
▶C JsonRenderer
C JsonapiRenderer
▶C XmlRenderer
C FeedRenderer
C JsonRenderer
▶C RendererInterface
▶C DocumentRenderer
C AtomRenderer
C RssRenderer
C ComponentRenderer
C HeadRenderer
C MessageRenderer
C MetasRenderer
C ModuleRenderer
C ModulesRenderer
C ScriptsRenderer
C StylesRenderer
C Replacements
▶C RequestFactory
▶C MessageFactory
C HttplugFactory
▶C RequestFactoryInterface
C RequestFactory
C Psr17Factory
▶C RequestIdGeneratorInterface
C RequestIdGenerator
▶C RequestMethod
C HttpBridgePostRequestMethod
C CurlPost
C Post
C SocketPost
C RequestParameters
C Required
▶C ResetInterface
C Application
C OutputFormatterStyleStack
▶C Resolvable
C PharInvocationResolver
C ResolvedRoute
C Resolver
C ResourceCaster
C Response
C Response
C ResponseBag
▶C ResponseFactory
C MessageFactory
▶C ResponseFactoryInterface
C ResponseFactory
C Psr17Factory
▶C ResultAwareInterface
C Captive
C GetMethod
C GetSetup
C SaveSetup
C Validate
C AjaxChallenge
C AjaxCreate
C AjaxDelete
C AjaxInitCreate
C AjaxSaveLabel
C GetIconEvent
C RevokedCertificate
C RewriteRules
C RFC4648
C RgbPaletteEntry
C RogueListEntry
C RoundingMode
C Route
▶C RouteHelper
C FinderHelperRoute
▶C RouteHelper
C ContactHelperRoute
▶C RouteHelper
▶C RouteHelper
C TagsHelperRoute
C RouteHelper
▶C RouteHelper
C NewsfeedsHelperRoute
▶C Router
C InstallationRouter
C AdministratorRouter
C ApiRouter
C SiteRouter
▶C RouterFactoryInterface
C RouterFactory
▶C RouterInterface
▶C RouterBase
▶C RouterView
C Router
C Router
C Router
C Router
C Router
C Router
C Router
C Router
C Router
C Router
C RouterLegacy
▶C RouterInterface
C Router
▶C RouterServiceInterface
C LegacyComponent
C BannersComponent
C ConfigComponent
C ContactComponent
C ContentComponent
C FinderComponent
C NewsfeedsComponent
C PrivacyComponent
C TagsComponent
C UsersComponent
C WrapperComponent
C RouterViewConfiguration
C RSA
C RSAKey
C RSAPrivateKey
C RSAPublicKey
C RSASSA_PSS_params
C Rule
C Rules
C Rules
C Rules
C Rules
C Rules
C Rules
C Rules
C Ruleset
▶C RulesInterface
C MenuRules
C NomenuRules
C StandardRules
C SampledataHelper
C Sanitizer
C Scheduler
C SchedulerHelper
C SearchTools
C Select
▶C SerializerInterface
▶C AbstractSerializer
▶C JoomlaSerializer
C ContactSerializer
C ContentSerializer
C NewsfeedSerializer
▶C Server
C Server
C Server
▶C ServerRequestFactoryInterface
C ServerRequestFactory
C Psr17Factory
C ServiceProviderInterface
▶C ServiceProviderInterface
C CategoryFactory
C ComponentDispatcherFactory
C HelperFactory
C Module
C ModuleDispatcherFactory
C MVCFactory
C RouterFactory
C Application
C Application
C Authentication
C CacheController
C Config
C Console
C Database
C Dispatcher
C Document
C Form
C HTMLRegistry
C Language
C Logger
C Menu
C Pathway
C Router
C Session
C Toolbar
C User
C WebAssetRegistry
C DatabaseProvider
C ServiceSubscriberInterface
C SessionEvents
▶C SessionHandler
C FilesystemHandler
C WincacheHandler
▶C SessionHandlerInterface
▶C HandlerInterface
C ApcuHandler
C DatabaseHandler
C FilesystemHandler
C MemcachedHandler
C RedisHandler
C WincacheHandler
C SessionManager
C SessionState
C Sidebar
C SignalableCommandInterface
C SignalRegistry
C Signature
C Signature
▶C SignatureConverter
C MultibyteStringConverter
C SignedPublicKeyAndChallenge
▶C Signer
▶C BaseSigner
▶C Hmac
C Sha256
C Sha384
C Sha512
C None
▶C OpenSSL
▶C Ecdsa
C Sha256
C Sha384
C Sha512
▶C Rsa
C Sha256
C Sha384
C Sha512
▶C SingleMetadata
C DistantSingleMetadata
▶C SiteRouterAwareInterface
C MVCFactory
C HtmlView
▶C SluggerInterface
C AsciiSlugger
C SMTP
C Socket
C SortableList
C SpecifiedECDomain
C SplCaster
C SSH2
C SSH2
▶C SSH2
C SFTP
▶C StatefulModelInterface
C BaseModel
▶C StatementInterface
C MysqliStatement
C PdoStatement
C SqlsrvStatement
C StatsAdminHelper
C StatsHelper
C Status
C Status
C StatusReport
▶C Stemmer
▶C Stem
C Catalan
C Danish
C Dutch
C English
C Finnish
C French
C German
C Italian
C Norwegian
C Portuguese
C Romanian
C Russian
C Spanish
C Swedish
C StemmerFactory
C StemmerManager
▶C StorageInterface
▶C FileStorage
C FileStorage
C MemcachedStorage
C PdoStorage
C RedisStorage
▶C StorageInterface
▶C NativeStorage
C JoomlaStorage
C RuntimeStorage
C Stream
▶C Stream
C StringStream
C StringStream
C Stream
▶C StreamFactory
C HttplugFactory
▶C StreamFactoryInterface
C StreamFactory
C Psr17Factory
▶C StreamInterface
C CallbackStream
C RelativeStream
▶C Stream
C PhpInputStream
C Stream
C StreamString
▶C Stringable
▶C AbstractString
▶C AbstractUnicodeString
C CodePointString
C UnicodeString
C ByteString
C LazyString
C PhpToken
C StringController
C StringController
C StringHelper
C StringHelper
C Strings
C StringWrapper
C Stub
▶C Stub
▶C ConstStub
C ClassStub
C ImgStub
C LinkStub
▶C CutStub
C CutArrayStub
C DsPairStub
▶C EnumStub
C ArgsStub
C FrameStub
C TraceStub
C StubCaster
▶C StyleInterface
C OutputStyle
C Subject
C SubjectAltName
C SubjectDirectoryAttributes
C SubjectInfoAccessSyntax
C SubjectPublicKeyInfo
C SubscribedService
▶C SubscriberInterface
C Taggable
C Versionable
C Email
C Fixed
C Totp
C Webauthn
C Yubikey
C Joomlaupdate
C Cache
C Shortcut
C Webauthn
C Checkfiles
C DemoTasks
C Requests
C SiteStatus
C PlgSystemDebug
C PlgSystemHttpHeaders
C PlgSystemJooa11y
C PlgSystemRedirect
C PlgSystemSchedulerunner
C PlgSystemTasknotification
C PlgWorkflowFeaturing
C PlgWorkflowNotification
C PlgWorkflowPublishing
C Substitution
C Suggestion
C SymfonyCaster
▶C SymmetricKey
▶C BlockCipher
C Blowfish
▶C DES
C TripleDES
C RC2
▶C Rijndael
C AES
C Twofish
▶C StreamCipher
C RC4
▶C Salsa20
C ChaCha20
C SyndicateHelper
C System
C Table
▶C TableCell
C TableSeparator
C TableCellStyle
▶C TableInterface
C Table
▶C TaggableTableInterface
C Category
C Content
C ContactTable
C NewsfeedTable
▶C VersionableTableInterface
C Category
C Content
C BannerTable
C ClientTable
C ContactTable
C NewsfeedTable
C TagTable
C NoteTable
C TableStyle
C Tag
C TaggedValue
▶C TagInterface
C AllowedTags
C TagObjectManager
▶C TagServiceInterface
C LegacyComponent
C BannersComponent
C ContactComponent
C ContentComponent
C NewsfeedsComponent
C TagsPopularHelper
C TagsSimilarHelper
C TaskOption
C TaskOptions
C Taxonomy
C TBSCertificate
C TBSCertList
C Telephone
▶C TemplateHelper
C TemplateHelper
C TemplateParser
C Templates
▶C TemplatesHelper
C TemplatesHelper
C TentativeTypes
C Terminal
C TerminalIdentifier
C Text
C ThrowableUtils
C Time
▶C TimeConverterInterface
C BigNumberTimeConverter
C DegradedTimeConverter
C PhpTimeConverter
C TimeGeneratorFactory
▶C TimeGeneratorInterface
C DefaultTimeGenerator
C PeclUuidTimeGenerator
▶C TimeProviderInterface
C FixedTimeProvider
C SystemTimeProvider
C Token
C Token
C TokenBinding
▶C TokenBindingHandler
C IgnoreTokenBindingHandler
C TokenBindingNotSupportedHandler
C Toolbar
▶C ToolbarButton
▶C BasicButton
▶C AbstractGroupButton
C DropdownButton
C HelpButton
C InlinehelpButton
▶C StandardButton
C ConfirmButton
C CustomButton
C LinkButton
C PopupButton
C SeparatorButton
▶C ToolbarFactoryInterface
C ContainerAwareToolbarFactory
C ToolbarHelper
C Totp
C TracedStatement
▶C TranscodeUnicodeInterface
C TranscodeUnicode
C Transliterate
▶C TransportInterface
▶C TransportInterface
C CurlTransport
C SocketTransport
C StreamTransport
▶C AbstractTransport
C CurlTransport
C SocketTransport
C StreamTransport
C Curl
C Socket
C Stream
C Trinomial
C TrustPathLoader
▶C Twig_Extension_Profiler
C TimeableTwigExtensionProfiler
▶C UCM
▶C UCMBase
C UCMContent
C UCMType
C UiTab
C Unescaper
C Uninflected
C Uninflected
C Uninflected
C Uninflected
C Uninflected
C Uninflected
C UniqueIdentifier
C UpdateOperation
C Updatesites
▶C UploadedFileFactoryInterface
C UploadedFileFactory
C Psr17Factory
▶C UploadedFileInterface
C UploadedFile
C UploadedFile
▶C UriFactory
C HttplugFactory
▶C UriFactoryInterface
C UriFactory
C Psr17Factory
C UriHelper
▶C UriInterface
▶C AbstractUri
▶C Uri
C Uri
C UriImmutable
▶C UriInterface
C Uri
C Uri
C Usage
C User
▶C UserFactoryInterface
C UserFactory
C UserGroupsHelper
C UserHelper
C UserNotice
C Users
C UsersLatestHelper
▶C UTF8MB4SupportInterface
C MysqlDriver
C MysqliDriver
C Util
C Utility
C Utils
▶C UuidBuilderInterface
C DefaultUuidBuilder
C DegradedUuidBuilder
C UuidCaster
▶C UuidFactoryInterface
C UuidFactory
▶C Validatable
C EqualsTo
C GreaterOrEqualsTo
C LesserOrEqualsTo
C ValidationData
▶C Validator
C Validator
▶C ValidatorInterface
C AddressValidator
C ForwardedValidator
C Validity
C VarDumper
C VerificationMethodANDCombinations
C VerificationMethodDescriptor
C Verifier
C Version
C Version
C VersionHelper
C Versioning
▶C ViewInterface
C AbstractView
▶C WebAssetAttachBehaviorInterface
C CoreAssetItem
C FormValidateAssetItem
C KeepaliveAssetItem
C TableColumnsAssetItem
▶C WebAssetExceptionInterface
C InvalidActionException
C UnknownAssetException
C UnsatisfiedDependencyException
▶C WebAssetItemInterface
▶C WebAssetItem
C CoreAssetItem
C FormValidateAssetItem
C KeepaliveAssetItem
C LangActiveAssetItem
C TableColumnsAssetItem
▶C WebAssetManagerInterface
C WebAssetManager
▶C WebAssetRegistryInterface
C WebAssetRegistry
C WebClient
C WhosonlineHelper
C Word
▶C WordInflector
C CachedWordInflector
C NoopWordInflector
C Substitutions
C Transformation
C Transformations
C RulesetInflector
C Workflow
▶C WorkflowModelInterface
C ArticleModel
▶C WorkflowServiceInterface
C ContentComponent
C WorkflowStage
C WrapperHelper
C X509
C XML
C XML
C XML
C XmlReaderCaster
C XmlResourceCaster
C Yaml
C ZIPExtraction
▶C AbstractProcessingHandler
C MonologCollector
▶C ArrayAccess
C AggregatedCollector
▶C DebugBar
C StandardDebugBar
C Construct
C Feed
▶C DataShapeObject
C CaptiveRenderOptions
C MethodDescriptor
C SetupRenderOptions
C DataSet
C AbstractEvent
C Registry
C ParagonIE_Sodium_Core32_ChaCha20_Ctx
C ParagonIE_Sodium_Core32_Curve25519_Fe
C ParagonIE_Sodium_Core_ChaCha20_Ctx
▶C ParagonIE_Sodium_Core_Curve25519_Fe
C Fe
C SplFixedArray
▶C CollectionInterface
C Collection
C CollectionInterface
▶C Options
C OptionsResolver
▶C Data
C SeekingData
▶C AuthenticationEntryPointInterface
C LdapAuthenticator
▶C BadgeInterface
C LdapBadge
▶C BasicLogger
C PropelCollector
▶C CompilerPassInterface
C AddConsoleCommandPass
▶C Constraint
C CommandIsSuccessful
▶C Countable
C InfiniteListObject
C InfiniteMapObject
C ListObject
C MapObject
C Construct
C Feed
C DataObject
C DataSet
C DatabaseIterator
C AbstractEvent
C ListenersPriorityQueue
▶C Input
▶C Input
C Cli
C Cookie
C Files
C Json
C Cookie
C Files
C Json
C Registry
C JWKSet
C SplFixedArray
C CollectionInterface
C Options
C Data
C AuthenticationExtensionsClientInputs
C AuthenticationExtensionsClientOutputs
C PublicKeyCredentialDescriptorCollection
▶C DateTime
C Date
▶C DomainException
C UnableToWriteBody
C UnexpectedResponseException
▶C EquatableInterface
C LdapUser
▶C Event
▶C ConsoleEvent
C ConsoleCommandEvent
C ConsoleErrorEvent
C ConsoleSignalEvent
C ConsoleTerminateEvent
▶C EventSubscriberInterface
C ErrorListener
C CheckLdapCredentialsListener
C AddLinkHeaderListener
▶C Exception
C AlreadyPunycodeException
C InvalidCharacterException
C InvalidIdnVersionException
C CannotPerformOperationException
C CryptoTestFailedException
C DebugBarException
▶C CryptoException
C BadFormatException
C EnvironmentIsBrokenException
C IOException
C WrongKeyOrModifiedCiphertextException
C NestingException
C NotImplementedException
C ParserException
C InvalidCiphertextException
C FileExistsException
C FileNotFoundException
C InvalidPathException
C Exception
C ThrowingCasterException
C InvalidParameterException
C NotFoundException
C ExtensionOutputError
▶C Exception
C CannotDecodeContent
C CannotEncodeContent
C CannotSignPayload
C ConversionFailed
C InvalidKeyProvided
C InvalidTokenStructure
C RegisteredClaimGiven
C UnsupportedHeaderFound
C LeewayCannotBeNegative
C ConstraintViolation
C NoConstraintsGiven
C RequiredConstraintsViolated
▶C InteractiveAuthenticatorInterface
C LdapAuthenticator
▶C InvalidArgumentException
C KeyNotFoundException
▶C InvalidArgumentException
▶C InvalidArgumentException
C LazyAssertionException
C UnknownArchiveException
C UnsupportedArchiveException
▶C RouteNotFoundException
C MissingComponentException
C InvalidKeyTypeException
C UnknownTypeException
C RouteNotFoundException
C InvalidArgumentException
C CannotSignPayload
C ConversionFailed
C InvalidKeyProvided
C InvalidTokenStructure
C RegisteredClaimGiven
C UnsupportedHeaderFound
C LeewayCannotBeNegative
C InvalidArgument
C InvalidArgumentException
C InvalidUuidStringException
▶C InvalidArgumentException
▶C CommandNotFoundException
C NamespaceNotFoundException
C NamespaceNotFoundException
C InvalidOptionException
▶C InvalidArgumentException
C InvalidOptionsException
C MissingOptionsException
C UndefinedOptionsException
C InvalidArgumentException
C InvalidArgumentException
▶C Iterator
C Construct
C DataSet
C DatabaseIterator
C SplFixedArray
▶C IteratorAggregate
C InfiniteListObject
C InfiniteMapObject
C ListObject
C MapObject
C DataObject
C ListenersPriorityQueue
C Registry
▶C SessionInterface
C Session
C JWKSet
C HelperSet
C HelperSet
C TableRows
C CollectionInterface
C CollectionInterface
C Data
C AuthenticationExtensionsClientInputs
C AuthenticationExtensionsClientOutputs
C PublicKeyCredentialDescriptorCollection
▶C JsonSerializable
▶C BigNumber
C BigDecimal
C BigInteger
C BigRational
C JsonapiDocument
C DataObject
C Registry
C JWK
C JWKSet
▶C Claim
▶C Basic
C EqualsTo
C GreaterOrEqualsTo
C LesserOrEqualsTo
C EqualsTo
C GreaterOrEqualsTo
C LesserOrEqualsTo
C BigInteger
▶C Engine
▶C BCMath
▶C Base
▶C Barrett
C DefaultEngine
C EvalBarrett
C BuiltIn
▶C GMP
C DefaultEngine
▶C PHP
C PHP32
C PHP64
▶C Base
▶C Montgomery
C PKCS1
C PKCS8
C OpenSSH
C PKCS1
C PKCS8
C PuTTY
C Raw
C OpenSSH
C PKCS1
C PKCS8
C PuTTY
C Raw
C OpenSSH
C PKCS1
C PKCS8
C PSS
C PuTTY
C OpenSSL
C OpenSSL
▶C Montgomery
C MontgomeryMult
C Barrett
C Classic
▶C EvalBarrett
C DefaultEngine
C PowerOfTwo
C Integer
▶C UuidInterface
▶C Uuid
C DegradedUuid
C SilencedErrorContext
C AbstractString
C LazyString
C Document
C AttestationStatement
C AttestedCredentialData
C AuthenticationExtension
C AuthenticationExtensionsClientInputs
C AuthenticationExtensionsClientOutputs
C AuthenticatorSelectionCriteria
C PublicKeyCredentialDescriptor
C PublicKeyCredentialDescriptorCollection
▶C PublicKeyCredentialEntity
C PublicKeyCredentialRpEntity
C PublicKeyCredentialUserEntity
▶C PublicKeyCredentialOptions
C PublicKeyCredentialCreationOptions
C PublicKeyCredentialRequestOptions
C PublicKeyCredentialParameters
C PublicKeyCredentialSource
▶C TrustPath
C CertificateTrustPath
C EcdaaKeyIdTrustPath
C EmptyTrustPath
▶C LocaleAwareInterface
C AsciiSlugger
▶C LogicException
C UnsupportedPasswordHandlerException
C UnsupportedCipherException
C LogicException
C AccessException
C OptionDefinitionException
▶C OutOfBoundsException
C ProtectedKeyException
C NoSuchOptionException
▶C PasswordAuthenticatedUserInterface
C LdapUser
▶C PasswordUpgraderInterface
C LdapUserProvider
▶C PDO
C TraceablePDO
▶C PDOStatement
C TraceablePDOStatement
▶C RuntimeException
▶C MathException
C DivisionByZeroException
C IntegerOverflowException
C NegativeNumberException
C NumberFormatException
C RoundingNecessaryException
C AuthenticationFailed
C NotAllowed
C NotAcceptable
C CacheConnectingException
C UnsupportedCacheException
C SectionNotFoundException
C UnparsableImageException
C MailDisabledException
C CheckinCheckout
C ResourceNotFound
C Save
C SendEmail
C GenericDataException
C UnsupportedStorageException
C InvalidActionException
C UnknownAssetException
C UnsatisfiedDependencyException
C DecryptionException
C EncryptionException
C InvalidKeyException
C ConnectionFailureException
C DatabaseNotFoundException
C ExecutionFailureException
C PrepareStatementFailureException
C QueryTypeAlreadyDefinedException
C UnsupportedAdapterException
C ContainerNotFoundException
C DependencyResolutionException
C FilesystemException
C MethodNotAllowedException
C CreateSessionTableException
C InvalidSessionException
C InvalidStreamPointerPositionException
C UnreadableStreamException
C UnrewindableStreamException
C UnseekableStreamException
C UntellableStreamException
C UnwritableStreamException
C UploadedFileAlreadyMovedException
C UploadedFileErrorException
C CannotDecodeContent
C CannotEncodeContent
C ConstraintViolation
C NoConstraintsGiven
C RequiredConstraintsViolated
C InvalidHeader
C InvalidLanguage
C InvalidMediaType
C BadConfigurationException
C BadDecryptionException
C BadModeException
C ConnectionClosedException
C FileNotFoundException
C InconsistentSetupException
C InsufficientSetupException
C NoKeyLoadedException
C NoSupportedAlgorithmsException
C UnableToConnectException
C UnsupportedAlgorithmException
C UnsupportedCurveException
C UnsupportedFormatException
C UnsupportedOperationException
C UnsatisfiedDependencyException
C UnsupportedOperationException
▶C RuntimeException
C MissingInputException
▶C ConnectionException
C AlreadyExistsException
C ConnectionTimeoutException
C InvalidCredentialsException
C DriverNotFoundException
▶C LdapException
C UpdateOperationException
C NotBoundException
C NoConfigurationException
C RuntimeException
▶C RuntimeException
C DumpException
C ParseException
▶C Exception
C DeserializationException
C ReaderException
▶C Serializable
C BigNumber
C Result
C AbstractEvent
C Route
C Router
C UuidInterface
▶C SqlsrvDriver
C SqlazureDriver
▶C Swift_Plugins_Logger
C SwiftLogCollector
▶C TestCase
C ServiceLocatorTest
▶C Throwable
▶C AssertionFailedException
C InvalidArgumentException
▶C CryptExceptionInterface
C DecryptionException
C EncryptionException
C InvalidKeyException
C InvalidKeyTypeException
C UnsupportedCipherException
▶C ExceptionInterface
C DeserializationException
C InvalidArgumentException
C InvalidStreamPointerPositionException
C SerializationException
C UnreadableStreamException
C UnrecognizedProtocolVersionException
C UnrewindableStreamException
C UnseekableStreamException
C UntellableStreamException
C UnwritableStreamException
C UploadedFileAlreadyMovedException
C UploadedFileErrorException
▶C ClientExceptionInterface
C InvalidResponseCodeException
C UnexpectedResponseException
C NetworkExceptionInterface
C RequestExceptionInterface
▶C ExceptionInterface
C CommandNotFoundException
C InvalidArgumentException
C InvalidOptionException
C LogicException
C MissingInputException
C RuntimeException
▶C ExceptionInterface
C ConnectionException
C DriverNotFoundException
C LdapException
C NotBoundException
▶C ExceptionInterface
C AccessException
C InvalidArgumentException
C NoConfigurationException
C NoSuchOptionException
C OptionDefinitionException
▶C ExceptionInterface
C InvalidArgumentException
C RuntimeException
▶C ExceptionInterface
C RuntimeException
▶C TokenTypeSupport
C JWSTokenSupport
▶C Twig_Environment
C TraceableTwigEnvironment
▶C Twig_Template
C TraceableTwigTemplate
▶C Twig_TemplateInterface
C TraceableTwigTemplate
▶C UnexpectedValueException
C InvalidResponseCodeException
C UnsupportedDatabaseDriverException
C DeserializationException
C SerializationException
C UnrecognizedProtocolVersionException
▶C UserInterface
C LdapUser
▶C UserProviderInterface
C LdapUserProvider


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- $ -

  • $_adapterfolder : Adapter
  • $_adapters : Adapter
  • $_allChildrenloaded : CategoryNode
  • $_application : CacheStorage
  • $_articles : CategoryModel
  • $_authActions : User
  • $_authGroups : User
  • $_authLevels : User
  • $_autoAscii : FtpClient
  • $_autoincrement : Table
  • $_bar : Toolbar
  • $_base32 : Totp
  • $_basepath : Adapter
  • $_basePath : HtmlView , JsonView , PlgEditorTinymce
  • $_buffer : Document
  • $_buttonPath : Toolbar
  • $_cache : Nested , PluginModel , StyleModel
  • $_caching : HtmlDocument
  • $_captcha : CaptchaField
  • $_categories : CategoryModel
  • $_category : CategoryModel
  • $_charset : Document , HtmlView , JsonView
  • $_checkedCategories : Categories
  • $_children : CategoryModel
  • $_classprefix : Adapter
  • $_clients : ApplicationHelper
  • $_columnAlias : Table
  • $_compress : MemcachedStorage
  • $_conn : FtpClient
  • $_constructor : CategoryNode
  • $_context : ItemModel , DownloadModel , CategoriesModel , ContactModel , ArchiveModel , ArticleModel , CategoriesModel , CategoryModel , FeaturedModel , DatabaseModel , InstallModel , MenuModel , CategoriesModel , NewsfeedModel , TagsModel
  • $_custom : HtmlDocument
  • $_data : CacheModel
  • $_dataconn : FtpClient
  • $_db : Adapter , MemcachedStorage , Table
  • $_debug : Nested
  • $_defaultModel : HtmlView , AbstractView
  • $_doc : DocumentRenderer
  • $_editor : Editor
  • $_engine : Document
  • $_error : ErrorDocument
  • $_errorMsg : User
  • $_errors : CMSObject
  • $_extension : Categories , CategoriesModel
  • $_field : Categories
  • $_file : HtmlDocument
  • $_filter : MenusHelper
  • $_generator : Document
  • $_group : OutputController , PageController
  • $_handler : Cache
  • $_hash : CacheStorage
  • $_id : OutputController , PageController
  • $_images : OpensearchDocument
  • $_includePaths : Table
  • $_item : ItemModel , BannerModel , CategoryModel , ContactModel , CategoryModel , UserModel
  • $_items : CategoriesModel
  • $_jsonEncode : CoreContent , Extension , Table , Update , ContactTable , FilterTable , TemplateTable , NewsfeedTable , TaskTable , TagTable , TransitionTable
  • $_key : Categories
  • $_language : CacheStorage
  • $_layout : HtmlView
  • $_layoutExt : HtmlView
  • $_layoutTemplate : HtmlView
  • $_lifetime : CacheStorage
  • $_lineEnd : Document
  • $_lineEndings : FtpClient
  • $_links : HtmlDocument
  • $_location : Nested
  • $_location_id : Nested
  • $_locked : Table
  • $_locked_files : FileStorage
  • $_locking : CacheStorage
  • $_locktest : PageController
  • $_mdate : Document
  • $_metaTags : Document
  • $_mime : Document , DocumentRenderer , AtomRenderer , RssRenderer
  • $_models : AbstractView
  • $_name : JsonDocument , Editor , AbstractView , CMSPlugin , Toolbar
  • $_namespace : Document
  • $_nodes : Categories
  • $_now : CacheStorage
  • $_options : Cache , Categories
  • $_output : HtmlView , JsonView
  • $_pad : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • $_pagination : CacheModel
  • $_params : User
  • $_parent : CategoriesModel , CategoryModel , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel
  • $_passCodeLength : Totp
  • $_pasv : FtpClient
  • $_path : CategoryNode , HtmlView
  • $_persistent : RedisStorage
  • $_pinModulo : Totp
  • $_prefer : BigInteger
  • $_profile : Document
  • $_raw : Json
  • $_redis : RedisStorage
  • $_removedInStep3 : Finnish
  • $_response : FtpClient
  • $_rh : BigIntegerGmp
  • $_root : FileStorage
  • $_router : Route
  • $_rules : Table
  • $_script : Document
  • $_scripts : Document
  • $_secretLength : Totp
  • $_shortName : OpensearchDocument
  • $_siblings : CategoryModel
  • $_statefield : Categories
  • $_str : BigIntegerBcmath
  • $_style : Document
  • $_styleSheets : Document
  • $_supportNullValue : Category , Content , CoreContent , Extension , Menu , Module , Table , User , BannerTable , ClientTable , ContactTable , FieldTable , GroupTable , FilterTable , LinkTable , UpdatesiteTable , NewsfeedTable , RequestTable , TaskTable , TagTable , MfaTable , NoteTable , StageTable , TransitionTable , WorkflowTable
  • $_tab : Document
  • $_table : Categories , InstallModel
  • $_tbl : Table
  • $_tbl_key : Table
  • $_tbl_keys : Table
  • $_template : HtmlDocument , HtmlView
  • $_template_tags : HtmlDocument
  • $_timeout : FtpClient
  • $_timeStep : Totp
  • $_total : CacheModel
  • $_trackAssets : Table
  • $_type : FtpClient , Document , CMSPlugin
  • $_url : UpdateAdapter , InstallModel
  • $_urls : OpensearchDocument
  • $_validLocations : Nested
  • $a : Binary , Montgomery , Prime , TwistedEdwards
  • $a24 : Montgomery
  • $aad : SymmetricKey
  • $aaguid : AttestedCredentialData , MetadataStatement , MetadataTOCPayloadEntry , PublicKeyCredentialSource
  • $aaid : MetadataStatement , MetadataTOCPayloadEntry
  • $accept : Browser , FileField
  • $acceptEncoding : WebClient
  • $acceptLanguage : WebClient
  • $acceptParsed : Browser
  • $access : CategoryNode , MenuItem , Result
  • $accumulatedDuration : QueryCollector
  • $accumulatedMemory : QueryCollector
  • $accumulatedTime : PropelCollector
  • $action : Sidebar , Response
  • $action_function : PHPMailer
  • $actionlogs : HtmlView
  • $actions : UsersHelper , HtmlView
  • $activation : User
  • $active : MeterField , AbstractMenu , PaginationObject , MethodDescriptor , NativeStorage , RuntimeStorage
  • $activeAssets : WebAssetManager
  • $activeFilters : ListView , HtmlView
  • $activeMFAMethodNames : CaptiveModel
  • $activeonly : WorkflowstageField
  • $adapter : Aes , Ldap
  • $adapters : Archive
  • $adapterType : UnsupportedArchiveException
  • $addition : Changelog
  • $additionalAssets : JavascriptRenderer
  • $additionalHeaders : DistantSingleMetadata , MetadataService
  • $additionalInformation : AbstractCBORObject
  • $additionalQueryStringValues : MetadataService
  • $additionalUrlParams : Pagination
  • $addonAfter : TextField
  • $addonBefore : TextField
  • $addPath : ZIPExtraction
  • $addTokensToDbQueryTemplate : Indexer
  • $adjective : Russian
  • $adminId : LanguagesModel , PlgSampledataMultilang
  • $aes : Encrypt
  • $agent : Browser , SSH2
  • $aggregates : MessagesCollector
  • $ajaxHandlerAutoShow : JavascriptRenderer
  • $ajaxHandlerBindToFetch : JavascriptRenderer
  • $ajaxHandlerBindToJquery : JavascriptRenderer
  • $ajaxHandlerBindToXHR : JavascriptRenderer
  • $ajaxHandlerClass : JavascriptRenderer
  • $akey : DerivedKeys
  • $alg : PublicKeyCredentialParameters
  • $algo : Hash
  • $algorithmManager : PackedAttestationStatementSupport , AuthenticatorAssertionResponseValidator
  • $algorithmManagerFactory : JWSVerifierFactory
  • $algorithms : Manager , ManagerFactory , AlgorithmManager , AlgorithmManagerFactory
  • $alias : CategoryNode , MenuItem , Nested , UCMBase , UCMType , DatabaseQuery , Iconv , Manifest , PharInvocation
  • $aliases : AbstractCommand , ApplicationDescription , Container , Command , ApplicationDescription
  • $aliasLength : Manifest
  • $all : AssertionChain
  • $all_recipients : PHPMailer
  • $allMFAs : Mfa
  • $allow_arbitrary_length_packets : SFTP
  • $allowAdd : CategoryeditField
  • $allowClear : MenuField
  • $allowCredentials : PublicKeyCredentialRequestOptions
  • $allowDowngrades : InstallerScript
  • $allowedAlgos : Token
  • $allowedAttrs : Sanitizer
  • $allowedCharacters : AbstractString
  • $allowedContexts : PlgUserToken
  • $allowedExtensions : ApiModel
  • $allowedGlobals : Input
  • $allowEdit : MenuField
  • $allowedMethods : MethodNotAllowedException
  • $allowedSchemes : Uri
  • $allowedTags : Sanitizer
  • $allowedTypes : OptionsResolver
  • $allowedUnprivilegedOptions : AdministratorApplication
  • $allowedValues : OptionsResolver
  • $AllowEmpty : PHPMailer
  • $allowEntryBatching : CaptiveRenderOptions , MethodDescriptor , HtmlView
  • $allowIpOverrides : IpHelper
  • $allowLegacyListeners : CMSPlugin , Email , Fixed , Totp , Yubikey , Webauthn
  • $allowMultiple : MethodDescriptor
  • $allowNew : MenuField
  • $allowPropagate : MenuField
  • $allowSelect : MenuField
  • $AltBody : PHPMailer
  • $alternativeDescriptions : MetadataStatement
  • $alternativeNamesSequence : SubjectAlternativeNames
  • $alternatives : CommandNotFoundException
  • $alwaysTryAll : LazyAssertion
  • $alwaysValid : AssertionChain
  • $amountOfFiles : Manifest
  • $animated : MeterField
  • $annotatedParameters : DebugClassLoader
  • $ansi : ANSI
  • $apacheRequestHeaders : ServerRequestFactory
  • $apcuPrefix : ClassLoader
  • $apiKey : AndroidSafetyNetAttestationStatementSupport
  • $apiVersion : Manifest
  • $apkPackageName : Response
  • $app : RouterBase , Dispatcher , LegacyComponentDispatcher , SiteMenu , BaseController , Pagination , ApiRouter , SiteRouter , MetadataManager , Workflow , ActionLogPlugin , HtmlView , FieldsPlugin , SelectModel , TaskModel , Task , HtmlView , JoomlaHttpDriver , Authentication , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgContentConfirmConsent , PlgContentEmailcloak , PlgContentJoomla , PlgContentVote , PlgEditorCodemirror , PlgEditorTinymce , PlgInstallerFolderInstaller , PlgInstallerOverride , PlgInstallerPackageInstaller , PlgInstallerUrlInstaller , PlgInstallerWebinstaller , PlgPrivacyUser , PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemAccessibility , PlgSystemActionLogs , PlgSystemDebug , PlgSystemHighlight , PlgSystemHttpHeaders , PlgSystemJooa11y , PlgSystemLanguagecode , PlgSystemLanguageFilter , PlgSystemLogout , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRemember , PlgSystemSchedulerunner , PlgSystemSef , PlgSystemSessionGc , PlgSystemSkipto , PlgSystemStats , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • $appendExtension : UpdateAdapter
  • $application : ApplicationEvent , TasksListCommand , TasksStateCommand , Factory , CMSPlugin , AbstractCommand , ApplicationDescription , ConsoleEvent , CssMenu , Client , Command , ApplicationDescription , ApplicationTester
  • $applicationDefinitionMerged : AbstractCommand
  • $applicationDefinitionMergedWithArgs : AbstractCommand
  • $archive : HtmlView
  • $archiveFileIsBeingRead : ZIPExtraction
  • $args : Cli
  • $arguments : AbstractEvent , Input , InputDefinition
  • $arrayCache : VarCloner
  • $articleid : ConsentBoxField
  • $ASCII : Normalizer
  • $ASCII_EXTRAS : ASCII
  • $ASCII_MAPS : ASCII
  • $ASCII_MAPS_AND_EXTRAS : ASCII
  • $asFormat : DatabaseExporter , DatabaseImporter
  • $assertClass : LazyAssertion
  • $assertionClass : Assert
  • $assertionClassName : AssertionChain
  • $assertions : Behavior , ConjunctionInterceptor
  • $assertionScheme : MetadataStatement
  • $asset : Editor , EditorField , MediaField
  • $asset_groups : Access
  • $asset_id : CategoryNode
  • $assetField : EditorField , RulesField
  • $assetPermissionsParentIdMapping : Access
  • $assetRules : Access
  • $assetRulesIdentities : Access
  • $assets : CategoryNode , WebAssetRegistry
  • $assoc : HtmlView
  • $associationsContext : AdminModel , CategoryModel , ContactModel , ArticleModel , ItemModel , NewsfeedModel
  • $associationsSupport : AssociationExtensionHelper , AssociationsHelper
  • $asString : FlattenException
  • $attached_pronoun : Catalan
  • $attachment : PHPMailer
  • $attachmentHint : MetadataStatement
  • $attachments : MailTemplate
  • $attempts : Question
  • $attestation : PublicKeyCredentialCreationOptions
  • $attestationCertificateKeyIdentifiers : MetadataStatement , MetadataTOCPayloadEntry
  • $attestationObject : AuthenticatorAttestationResponse
  • $attestationObjectLoader : PublicKeyCredentialLoader
  • $attestationRootCertificates : MetadataStatement
  • $attestationStatementSupportManager : AttestationObjectLoader , AuthenticatorAttestationResponseValidator
  • $attestationStatementSupports : AttestationStatementSupportManager
  • $attestationSupport : Authentication
  • $attestationType : PublicKeyCredentialSource
  • $attestationTypes : MetadataStatement
  • $attestedCredentialData : AuthenticatorData
  • $attr : Cursor , Stub
  • $attr_cell : ANSI
  • $attr_row : ANSI
  • $attrArray : InputFilter
  • $attribute : UpdateOperation
  • $attributes : OnGetApiAttributes , WebAssetItem , ServerRequest , SFTP , Entry , Link
  • $attrMethod : InputFilter
  • $attrs : ANSI
  • $attStmt : AttestationObject , AttestationStatement
  • $audience : PermittedFor
  • $auth : SSH2
  • $auth_method : LdapClient
  • $auth_methods_to_continue : SSH2
  • $authData : AttestationObject , AuthenticatorData
  • $authenticationAlgorithm : MetadataStatement
  • $authenticationAlgorithms : MetadataStatement
  • $authenticationExtension : ExtensionOutputError
  • $authenticationHelper : Webauthn
  • $authenticationPluginType : ApiApplication , CMSApplication
  • $authenticator : LdapAuthenticator
  • $authenticatorAttachment : AuthenticatorSelectionCriteria
  • $authenticatorData : AuthenticatorAssertionResponse
  • $authenticatorSelection : PublicKeyCredentialCreationOptions
  • $authenticatorVersion : MetadataStatement
  • $author : FeedItem , Editor , LibraryManifest
  • $authorEmail : FeedItem
  • $authoremail : LibraryManifest
  • $authorField : EditorField , MediaField
  • $authorurl : LibraryManifest
  • $AuthType : PHPMailer
  • $autoAscii : FtpClient
  • $autocomplete : FormField
  • $autocompleterCallback : Question
  • $autoExit : Application , SingleCommandApplication
  • $autofocus : FormField
  • $autoIncrementField : DatabaseQuery
  • $autoloadLanguage : CMSPlugin , ActionLogPlugin , FieldsPlugin , MediaActionPlugin , PrivacyPlugin , Email , Fixed , Totp , Webauthn , Yubikey , Joomlaupdate , Shortcut , Webauthn , Checkfiles , DemoTasks , Requests , SiteStatus , PlgButtonArticle , PlgButtonContact , PlgButtonFields , PlgButtonImage , PlgButtonMenu , PlgButtonModule , PlgButtonPagebreak , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgContentConfirmConsent , PlgEditorCodemirror , PlgEditorTinymce , PlgExtensionJoomla , PlgFileSystemLocal , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags , PlgInstallerOverride , PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemFields , PlgSystemJooa11y , PlgSystemLogout , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRedirect , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWebservicesBanners , PlgWebservicesConfig , PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesInstaller , PlgWebservicesLanguages , PlgWebservicesMedia , PlgWebservicesMenus , PlgWebservicesMessages , PlgWebservicesModules , PlgWebservicesNewsfeeds , PlgWebservicesPlugins , PlgWebservicesPrivacy , PlgWebservicesRedirect , PlgWebservicesTags , PlgWebservicesTemplates , PlgWebservicesUsers , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • $availableCommands : Behavior
  • $b : Binary , Prime , RgbPaletteEntry
  • $background : Color , OutputFormatterStyle
  • $backupCodes : HtmlView
  • $bad_key_size_fix : SSH2
  • $baDesc : VerificationMethodDescriptor
  • $banner_message : SSH2
  • $barChar : ProgressBar
  • $barWidth : ProgressBar
  • $base : Document , PaginationObject , CollectionAdapter , Uri , ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H , DH , CodeAccuracyDescriptor
  • $base2 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $base_attr_cell : ANSI
  • $base_dn : LdapClient
  • $baseDn : LdapUserProvider
  • $basename : TracksModel
  • $baseName : PharInvocation
  • $baseNames : PharInvocationResolver
  • $basePart : Accept
  • $basePath : JavascriptRenderer , FileLayout , BaseController , PlgEditorCodemirror
  • $baseUrl : JavascriptRenderer
  • $baseurl : HtmlDocument
  • $batch_commands : AdminModel , BannerModel , ContactModel , FieldModel , GroupModel , ItemModel , ModuleModel , TagModel
  • $batch_copymove : AdminModel , BannerModel , ContactModel , FieldModel , ItemModel , ModuleModel
  • $batchSet : AdminModel
  • $bcc : PHPMailer
  • $bctx : Blowfish
  • $behavior : Manager
  • $bgBase : ColorStyle
  • $bgColor : ColorStyle
  • $BIDI_UNI_CODE_CONTROLS_TABLE : ASCII
  • $binary : OpenSSH
  • $binary_packet_buffer : SSH2
  • $bindedValues : MysqliStatement , SqlsrvStatement
  • $biometricStatusReports : MetadataTOCPayloadEntry
  • $birthdate : AuthenticationResponse
  • $bitDepth : DisplayPNGCharacteristicsDescriptor
  • $bitmap : SSH2
  • $bitmask : Engine
  • $block : User
  • $block_size : Blowfish , StreamCipher , SymmetricKey , DES , RC2
  • $blockChildUninstall : PackageManifest
  • $blockCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $blockedAttributes : InputFilter
  • $blockedChars : InputFilter
  • $blockedTags : InputFilter
  • $blockSlowdown : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • $Body : PHPMailer
  • $bootstrappingLogger : ErrorHandler
  • $borderFormat : TableStyle
  • $bound : Connection
  • $boundary : PHPMailer
  • $bounded : DatabaseQuery
  • $boundParameters : TraceablePDOStatement
  • $boundParams : DebugMonitor
  • $branches : Taxonomy
  • $browser : WebClient , Browser
  • $browserNav : MenuItem
  • $browserVersion : WebClient
  • $buffer : Profiler , ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , BufferedOutput , TrimmedBufferOutput
  • $bufferedOutput : SymfonyStyle
  • $buffers : BufferStreamHandler , Buffer
  • $builder : StringCodec , FeatureSet
  • $builderFactory : Configuration
  • $buttons : EditorField , SubformField , QuickIconHelper
  • $c : Hash , Rijndael
  • $C : Normalizer
  • $c : EcdaaTrustAnchor
  • $cache : CachedWordInflector , CacheController , Factory , FileLayout , ListModel , Router , LanguageclientField , BackupcodesModel , DatabaseExporter , DatabaseImporter , Cache , Ini , PhpInputStream
  • $cacheable : AbstractWebApplication
  • $cacheControllerFactory : Cache
  • $cachedMap : JNamespacePsr4Map
  • $cacheItemPool : SimpleMetadataStatementRepository
  • $caDesc : VerificationMethodDescriptor
  • $caFileValidity : CaBundle
  • $caFlag : X509
  • $call : DatabaseQuery
  • $callback : CallbackLogger , CallbackStream
  • $callbacks : Factory
  • $calling : OptionsResolver
  • $callStack : LogEntry
  • $callStacks : DebugMonitor
  • $canDisable : MethodDescriptor
  • $canDo : FormView , ListView , HtmlView
  • $canFlushFileCache : File
  • $canGetVendors : InstalledVersions
  • $canonicalize_paths : SFTP
  • $canRemove : Status
  • $capabilities : HtmlView
  • $caPath : CaBundle
  • $captcha : Captcha
  • $captchaEnabled : HtmlView
  • $CAs : X509
  • $caseCheck : DebugClassLoader
  • $casters : AbstractCloner
  • $catchExceptions : Application
  • $catchThrowables : Application
  • $categories : CategoryView , HtmlView
  • $category : FeedItem , FeedDocument , LogEntry , CategoryView , Update
  • $category_association : CategoryAssociationHelper
  • $categoryCache : Router
  • $categoryFactory : RouterFactory , Router
  • $cc : PHPMailer
  • $cC : Normalizer
  • $cellHeaderFormat : TableStyle
  • $cellRowContentFormat : TableStyle
  • $cellRowFormat : TableStyle
  • $certificate : StatusReport
  • $certificateNumber : BiometricStatusReport , StatusReport
  • $certificates : CertificateTrustPath
  • $certificationDescriptor : BiometricStatusReport , StatusReport
  • $certificationPolicyVersion : BiometricStatusReport , StatusReport
  • $certificationRequirementsVersion : BiometricStatusReport , StatusReport
  • $certLevel : BiometricStatusReport
  • $cfb_init_len : Blowfish , SymmetricKey , DES , RC2 , TripleDES , Twofish
  • $chainExceptions : ExceptionsCollector
  • $challenge : X509 , CollectedClientData , PublicKeyCredentialOptions
  • $challengeSize : Server
  • $challengeTs : Response
  • $change : Changelog
  • $changed : SymmetricKey
  • $changeItems : ChangeSet
  • $changelogurl : InstallerAdapter
  • $changeSet : HtmlView
  • $changeSetList : DatabaseModel
  • $channel_buffers : SSH2
  • $channel_close : SFTP
  • $channel_extended_data_type_codes : SSH2
  • $channel_open_failure_reasons : SSH2
  • $channel_status : SSH2
  • $characters : ActionlogsHelper
  • $charcounter : TextareaField
  • $charSet : AbstractWebApplication
  • $CharSet : Mail , PHPMailer
  • $charset : HtmlErrorRenderer , AbstractDumper , SourceContextProvider
  • $checked : CheckboxField
  • $checked_out : CategoryNode
  • $checked_out_time : CategoryNode
  • $checkedClasses : DebugClassLoader
  • $checkedOptions : CheckboxesField
  • $checkers : ExtensionOutputCheckerHandler
  • $checkQuery : ChangeItem
  • $checkQueryExpected : ChangeItem
  • $checkStatus : ChangeItem
  • $checkStringForIllegalChars : AbstractString
  • $checkTags : HtmlView
  • $child : AbstractGroupButton
  • $child_keys : RouterViewConfiguration
  • $childOIDsLoaded : PKCS8 , PSS
  • $children : Construct , RouterViewConfiguration , CategoryView , HtmlView
  • $childrennumitems : CategoryNode
  • $choices : ChoiceQuestion
  • $chunks : ByteStringWithChunkObject
  • $chunksize : Stream
  • $cipher : Crypt
  • $cipher_name_mcrypt : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , TripleDES , Twofish
  • $cipher_name_openssl : ChaCha20 , SymmetricKey
  • $cipher_name_openssl_ecb : SymmetricKey
  • $cipherMode : Mcrypt
  • $cipherType : Mcrypt
  • $claimFactory : Builder , Token
  • $claims : Builder , Token
  • $class : FormField , DatabaseIterator , FlattenException , Stub
  • $classAliases : JLoader
  • $classAliasesInverse : JLoader
  • $classes : OtherObjectManager , TagObjectManager , JLoader
  • $classInfo : AbstractCloner
  • $classLoader : DebugClassLoader
  • $classMap : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $classMapAuthoritative : ClassLoader
  • $client : AbstractWebApplication , LanguagesModel , InstallerExtension , Update , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , Client , AndroidSafetyNetAttestationStatementSupport
  • $clientDataJSON : AuthenticatorResponse
  • $clientFilename : UploadedFile
  • $clientId : CMSApplication , ChromestyleField , MenuitemField , ModulepositionField , ModuleAdapter , TemplateAdapter , MenuItemByTypeField
  • $clientMediaType : UploadedFile
  • $clientName : TemplatestyleField
  • $cliInput : CliApplication , AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , UpdateCoreCommand
  • $cliScriptFiles : InstallerScript
  • $clock : ValidAt
  • $cloner : DebugBarVarDumper , Dumper , RequestContextProvider
  • $clonerOptions : DebugBarVarDumper
  • $closed : NativeStorage , RuntimeStorage
  • $code : Command , FlattenException
  • $codec : FeatureSet , Uuid , UuidFactory
  • $coefficient : RSAKey
  • $coefficients : PrivateKey
  • $collapseNextHash : CliDumper
  • $collect_urls_enabled : HtmlView
  • $collection : Manager
  • $collectors : AggregatedCollector , DebugBar
  • $color : OutputFormatterStyle
  • $colors : ColorField , CliDumper , HtmlDumper
  • $colorType : DisplayPNGCharacteristicsDescriptor
  • $column : DatabaseIterator
  • $columnMaxWidths : Table
  • $columnNames : MysqliStatement
  • $columns : TextareaField , DatabaseQuery
  • $columnStyles : Table
  • $columnWidths : Table
  • $command : HelpCommand , ConsoleEvent , HelpCommand , LazyCommand , ConsoleEvent , HelperSet , CommandCompletionTester , CommandTester
  • $commandEnabled : BeforeCommandExecuteEvent
  • $commandLoader : Application
  • $commandLoaderServiceId : AddConsoleCommandPass
  • $commandMap : WritableContainerLoader , ContainerLoader , ContainerCommandLoader
  • $commands : Application , ApplicationDescription , Application , ApplicationDescription
  • $commandShouldRun : ConsoleCommandEvent
  • $commandTag : AddConsoleCommandPass
  • $comment : AsymmetricKey , OpenSSH , PuTTY
  • $comments : FeedItem
  • $common : Token
  • $commonName : CertificateSubject
  • $comParams : TagField
  • $compatibleVersions : Update
  • $completionName : CompletionInput
  • $completionOutputs : CompleteCommand
  • $completionType : CompletionInput
  • $completionValue : CompletionInput
  • $component : RouterLegacy , LegacyComponent , RulesField , MenuItem , Workflow , HtmlView , FieldController , GroupController
  • $component_id : MenuItem
  • $componentRouters : SiteRouter
  • $components : ComponentHelper
  • $composerRoots : LinkStub
  • $compress : SSH2
  • $compress_context : SSH2
  • $compressedTotal : ZIPExtraction
  • $compression : DisplayPNGCharacteristicsDescriptor
  • $compression_algorithms_client_to_server : SSH2
  • $compression_algorithms_server_to_client : SSH2
  • $computedKey : Hash
  • $concat_operator : PgsqlDriver
  • $config : Propel2Collector , AbstractApplication , Factory , MetadataManagerListener , SysinfoModel , HtmlView , AbstractConnection , Adapter
  • $configFile : SiteStatus , RSA
  • $configurations : Log
  • $configureException : ErrorHandler
  • $confirmed : PharInvocation
  • $ConfirmReadingTo : PHPMailer
  • $conn : FtpClient
  • $connected : POP3
  • $connection : DatabaseDriver , MysqliDriver , MysqliStatement , PdoDriver , SqlsrvStatement , AbstractQuery , Adapter , Collection , Connection , EntryManager , Query , ServerDumper
  • $connections : PDOCollector , SocketTransport , Socket , SSH2
  • $connectors : DatabaseDriver
  • $consoleInput : Application
  • $consoleOutput : Application
  • $consoleSectionOutputs : ConsoleOutput
  • $consonants : Finnish
  • $constantSupport : Inline
  • $constraints : InvalidArgumentException
  • $constructed : AbstractImmutableEvent , EventImmutable , UriImmutable
  • $contacts : HtmlView
  • $container : ContainerControllerResolver , WritableContainerLoader , Factory , ContainerLoader , ContainerResource , LazyServiceEventListener , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , ContainerCommandLoader
  • $content : Microdata , Key , ConsoleSectionOutput , Stub
  • $contentLength : ASNObject , UnknownConstructedObject
  • $contentType : OrderingField , ApiController , AdminModel , BannersController , ClientsController , CategoriesController , ApplicationController , ComponentController , ContactController , ArticlesController , HistoryController , FieldsController , GroupsController , ManageController , LanguagesController , OverridesController , StringsController , AdaptersController , MediaController , ItemsController , MenusController , MessagesController , ModulesController , FeedsController , PluginsController , ConsentsController , RequestsController , RedirectController , TagsController , StylesController , GroupsController , LevelsController , UsersController
  • $ContentType : PHPMailer
  • $context : Stream , LogEntry , ApiController , FormController , ListModel , TracksController , SubfieldsField , GroupsModel , Adapter , FilterModel , SearchModel , SuggestionsModel , OAuthCallbackEvent , Stream , QuickIconsEvent , EC , Stream , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags , Data , PharStreamWrapper
  • $contextAliases : Joomla
  • $contextOptions : Stream
  • $contextProviders : ContextualizedDumper , Connection
  • $continuousBuffer : SymmetricKey
  • $control : ColorField
  • $controlCharsMap : CliDumper
  • $controlCharsRx : CliDumper
  • $controller : ResolvedRoute , Route
  • $controllerResolver : WebApplication
  • $controls : JavascriptRenderer
  • $converter : Ecdsa , DefaultUuidBuilder , DegradedUuidBuilder , CombGenerator , Uuid
  • $convertMap : Iconv
  • $convertToInt : ContentHistory
  • $cookieParams : ServerRequest
  • $copyright : FeedDocument , LibraryManifest
  • $core : LanguageAdapter
  • $coreExtensionIds : ExtensionHelper
  • $coreExtensions : ExtensionHelper
  • $coseAlgorithmManagerFactory : Server
  • $count : Usage , CacheStorageHelper , FormField , Pathway , DatabaseDriver , LanguageErrorsCollector , LanguageFilesCollector , DebugFormatterHelper , SilencedErrorContext
  • $countable : Inflector
  • $counter : Language , CssMenu , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , Salsa20 , PublicKeyCredentialSource
  • $country : CertificateSubject , AuthenticationResponse
  • $created : TaskTable
  • $created_time : CategoryNode
  • $created_user_id : CategoryNode
  • $creationDate : LibraryManifest
  • $credentialId : AttestedCredentialData
  • $credentialPublicKey : AttestedCredentialData , PublicKeyCredentialSource
  • $credentialsRepository : Authentication
  • $credentialStore : LocalStrategy
  • $cronParts : CronExpression
  • $crossingBottomLeftChar : TableStyle
  • $crossingBottomMidChar : TableStyle
  • $crossingBottomRightChar : TableStyle
  • $crossingChar : TableStyle
  • $crossingMidLeftChar : TableStyle
  • $crossingMidRightChar : TableStyle
  • $crossingTopLeftBottomChar : TableStyle
  • $crossingTopLeftChar : TableStyle
  • $crossingTopMidBottomChar : TableStyle
  • $crossingTopMidChar : TableStyle
  • $crossingTopRightBottomChar : TableStyle
  • $crossingTopRightChar : TableStyle
  • $crypto_engine : SSH2
  • $cryptoStrength : MetadataStatement
  • $cspNonce : JavascriptRenderer , HtmlDocument , PlgSystemHttpHeaders
  • $cssFiles : JavascriptRenderer
  • $cssVendors : JavascriptRenderer
  • $curl : CurlPost
  • $current : Uri , DataSet , DatabaseIterator
  • $current_key_length : RC2
  • $current_lang : PlgSystemLanguageFilter
  • $currentCert : X509
  • $currentChain : LazyAssertion
  • $currentChainFailed : LazyAssertion
  • $currentChangelog : Changelog
  • $currentExtensionId : InstallerAdapter
  • $currentIndex : CompletionInput
  • $currentKeyIdentifier : X509
  • $currentLine : Parser
  • $currentLineNb : Parser
  • $currentOffset : ZIPExtraction
  • $currentPath : HtmlView
  • $currentString : StreamString , StringWrapper
  • $currentUpdate : Update
  • $cursor : DatabaseDriver , ProgressBar
  • $curTimeout : SSH2
  • $curve : EC
  • $curveAliases : Identity
  • $curveName : EC
  • $custom_data : Extension
  • $custom_reduction : EvalBarrett
  • $customFieldsCache : SubfieldsField , PlgFieldsSubform
  • $CustomHeader : PHPMailer
  • $customPrefix : CategoryeditField
  • $cut : Stub
  • $d : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H , TwistedEdwards
  • $D : Normalizer
  • $d2 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $dA : PrivateKey
  • $darwinCache : DebugClassLoader
  • $data : InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , Key , ConfigCollector , DebugBar , Bzip2 , Gzip , Tar , Zip , Rule , Rules , OpensearchImage , Form , LanguagesModel , BaseLayout , MailTemplate , Pagination , JsonResponse , JoomlaStorage , HtmlView , InstalledModel , ProfileModel , RegistrationModel , HtmlView , Input , Registry , RuntimeStorage , DataSet , Data , Document , Relationship , Resource , CollectedClientData , ExtensionDescriptor , SingleMetadata , StringStream
  • $dataAttributes : FormField
  • $database : Factory , DatabaseLogger , DatabaseDriver
  • $dataconn : FtpClient
  • $dataFilesNew : WebAssetRegistry
  • $dataFilesParsed : WebAssetRegistry
  • $dataFormater : DataCollector , MessagesCollector
  • $dataReadLength : ZIPExtraction
  • $date : FeedItem , LogEntry , PlgUserProfile , RogueListEntry
  • $date1 : Query
  • $date2 : Query
  • $dateRelative : HtmlView
  • $dates : Factory
  • $db : DatabaseStrategy , AdapterInstance , RouterFactory , FinderIndexCommand , UpdateCoreCommand , DatabaseLogger , SiteMenu , ChangeItem , ChangeSet , MetadataManager , UCMType , UserFactory , Workflow , ActionLogPlugin , Router , HtmlView , Adapter , Indexer , Router , PrivacyPlugin , Task , Router , HtmlView , ExportCommand , ImportCommand , DatabaseExporter , DatabaseImporter , DatabaseQuery , CreateSessionTableCommand , DatabaseHandler , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgContentContact , PlgContentJoomla , PlgExtensionFinder , PlgExtensionJoomla , PlgInstallerOverride , PlgQuickiconOverrideCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemActionLogs , PlgSystemDebug , PlgSystemHttpHeaders , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRedirect , PlgSystemRemember , PlgSystemSessionGc , PlgSystemStats , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowNotification
  • $dbMinimum : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver
  • $dbMinimumMariaDb : DatabaseHelper
  • $dbMinimumMySql : DatabaseHelper
  • $dbMinimumPostgreSql : DatabaseHelper
  • $dbMinMariadb : MysqlDriver , MysqliDriver
  • $dbOptions : DatabaseStrategy
  • $debuffer : SymmetricKey , Salsa20
  • $debug : ErrorDocument , Language , ErrorHandler , HtmlErrorRenderer , SerializerErrorRenderer , FallbackExceptionHandler
  • $debugBar : JavascriptRenderer , OpenHandler , PlgSystemDebug
  • $debugLang : PlgSystemDebug
  • $debugMessages : BaseLayout
  • $Debugoutput : PHPMailer , SMTP
  • $debugStack : DoctrineCollector
  • $dechanged : SymmetricKey
  • $decimalPoint : AbstractDumper
  • $decodedData : Files
  • $decoder : AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Parser , AndroidKeyAttestationStatementSupport , AttestationObjectLoader , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , AuthenticatorAssertionResponseValidator , PublicKeyCredentialLoader
  • $decompress : SSH2
  • $decompress_context : SSH2
  • $decorated : OutputFormatter
  • $decoratedObjects : ExplicitlyTaggedObject
  • $decoratedStream : RelativeStream
  • $decrypt : SSH2
  • $decrypt_block_size : SSH2
  • $decryptFixedPart : SSH2
  • $decryptInvocationCounter : SSH2
  • $decryptIV : SymmetricKey
  • $decryptName : SSH2
  • $default : ColorField , FormField , Language , AbstractMenu , InputArgument , InputOption , Question
  • $default_key_length : RC2
  • $default_lang : PlgSystemLanguageFilter
  • $default_title : SetupRenderOptions
  • $default_view : BaseController , DisplayController , BannersController , ClientsController , DisplayController , CategoriesController , DisplayController , ApplicationController , ComponentController , DisplayController , ContactController , DisplayController , ArticlesController , HistoryController , DisplayController , FieldsController , GroupsController , DisplayController , ManageController , DisplayController , LanguagesController , OverridesController , StringsController , DisplayController , AdaptersController , MediaController , DisplayController , ItemsController , MenusController , DisplayController , MessagesController , DisplayController , ModulesController , DisplayController , FeedsController , DisplayController , PluginsController , DisplayController , ConsentsController , RequestsController , DisplayController , RedirectController , DisplayController , TagsController , DisplayController , StylesController , DisplayController , GroupsController , LevelsController , UsersController , DisplayController
  • $defaultBackendTemplate : HtmlView
  • $defaultBasePath : LayoutHelper
  • $defaultCasters : AbstractCloner
  • $defaultCipherSuite : MysqlDriver
  • $defaultClonerOptions : DebugBarVarDumper
  • $defaultColors : CliDumper
  • $defaultCommand : Application
  • $defaultDataFormatter : DataCollector , AbstractDataCollector
  • $defaultDescription : Command , CompleteCommand , DumpCompletionCommand , ServerDumpCommand , LintCommand
  • $defaultDumperOptions : DebugBarVarDumper
  • $defaultEncryptionAlgorithm : PKCS1 , PKCS8
  • $defaultEncryptionScheme : PKCS8
  • $defaultExponent : RSA
  • $defaultFetchStyle : MysqliStatement , SqlsrvStatement
  • $defaultIterationCount : PKCS8
  • $defaultLanguage : Result , HtmlView
  • $defaultLimits : LimitboxField
  • $defaultLocale : AsciiSlugger
  • $defaultMessage : AssertionChain
  • $defaultMethod : HtmlView
  • $defaultName : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , CleanCacheCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , AbstractCommand , HelpCommand , ListCommand , ExportCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand , Command , CompleteCommand , DumpCompletionCommand , ServerDumpCommand , LintCommand
  • $defaultNamespaceURI : XPath
  • $defaultObjectClass : SqlsrvStatement
  • $defaultOptions : MemcachedCaster
  • $defaultOutput : AbstractDumper , CliDumper , HtmlDumper
  • $defaultPageTitle : CategoryView , HtmlView
  • $defaultPRF : PKCS8
  • $defaultProperties : Stub
  • $defaultPropertyPath : AssertionChain
  • $defaultRoles : LdapUserProvider
  • $defaults : Route , OptionsResolver
  • $defaultSearch : LdapUserProvider
  • $defaultTargetSrc : HtmlView
  • $defaultVarDumper : DataCollector
  • $defaultVersion : SFTP
  • $defer : FormattedtextLogger
  • $deferredEntries : FormattedtextLogger
  • $defined : OptionsResolver
  • $definition : Application , AbstractCommand , Application , Command , Input
  • $delete : DatabaseQuery
  • $deleteFiles : InstallerScript
  • $deleteFlags : MfaTable
  • $deleteFolders : InstallerScript
  • $demcrypt : SymmetricKey
  • $denominator : BigRational
  • $dependencies : WebAssetItem
  • $dependenciesIsActual : WebAssetManager
  • $deprecated : DebugClassLoader , OptionsResolver
  • $deprecatedAliases : JLoader
  • $depth : Cursor
  • $derivational : Russian
  • $derived : Token
  • $des : TripleDES
  • $des_rounds : DES
  • $desc : TaskOption
  • $description : CategoryNode , Document , FeedImage , FeedItem , FormField , Manifest , Update , Result , Domain , AbstractCommand , Command , InputArgument , InputOption , MetadataStatement
  • $descriptors : DescriptorHelper , ServerDumpCommand
  • $destinations : Patcher
  • $detect_browser : SiteApplication
  • $detection : WebClient
  • $development : HtmlView
  • $direction : Document
  • $directories : SysinfoModel
  • $directory : AccessiblemediaField , FilelistField , FolderlistField , MediaField , HtmlView
  • $directoryIteratorProvider : LintCommand
  • $dirmode : Stream
  • $dirname : FileStorage , TextField
  • $disable : MenuitemField , MenuItemByTypeField
  • $disable64Bit : FeatureSet
  • $disable_url_fetch : X509
  • $disableBigNumber : FeatureSet
  • $disabled : FormField
  • $disableFallbackForUnitTests : ParagonIE_Sodium_Compat
  • $disconnect_reasons : SSH2
  • $dispatcher : Application
  • $dispatcherFactory : Component , Module
  • $display : ColorField , MethodDescriptor
  • $displayCorrectFiles : LintCommand
  • $displayName : PublicKeyCredentialUserEntity
  • $displayOptions : CliDumper , HtmlDumper
  • $divisor : FinderIndexCommand
  • $DKIM_copyHeaderFields : PHPMailer
  • $DKIM_domain : PHPMailer
  • $DKIM_extraHeaders : PHPMailer
  • $DKIM_identity : PHPMailer
  • $DKIM_passphrase : PHPMailer
  • $DKIM_private : PHPMailer
  • $DKIM_private_string : PHPMailer
  • $DKIM_selector : PHPMailer
  • $dn : LdapClient , X509 , AbstractQuery , Entry
  • $dnString : LdapAuthenticator , LdapBadge
  • $do_debug : POP3 , SMTP
  • $do_verp : PHPMailer , SMTP
  • $docOptions : CMSApplication
  • $docs : FeedDocument
  • $document : WebApplication , JsonapiDocument , AbstractRenderer , Factory , AbstractView , JsonApiView , HtmlView , Joomlaupdate
  • $documentFactory : Cache
  • $domains : X509
  • $doTask : BaseController
  • $doubles : Base , English
  • $downloads : Update
  • $downloadSources : Update
  • $driver : DatabaseLogger , ConnectionEvent
  • $dropDownList : ActionsDropdown , Dropdown
  • $dsn : PHPMailer
  • $dummySession : JoomlaHttpDriver
  • $dumper : DebugBarVarDumper , Yaml , Dumper , CliDescriptor , HtmlDescriptor
  • $dumperOptions : DebugBarVarDumper
  • $dumpHeader : HtmlDumper
  • $dumpId : HtmlDumper
  • $dumpKeys : EnumStub
  • $dumpPrefix : HtmlDumper
  • $dumpSuffix : HtmlDumper
  • $duration : TracedStatement
  • $dw : Rijndael
  • $ecb : SymmetricKey
  • $ecdaaKeyId : EcdaaKeyIdTrustPath
  • $ecdaaTrustAnchors : MetadataStatement
  • $editor : FeedDocument , EditorField , SysinfoModel
  • $editorEmail : FeedDocument
  • $editorType : EditorField
  • $editUri : HtmlView
  • $effectiveColumnWidths : Table
  • $effectiveDate : BiometricStatusReport , StatusReport
  • $eid : PlgExtensionJoomla
  • $eight : Prime
  • $ekey : DerivedKeys
  • $element : Subject , NestingException , Changelog , FormField , InstallerAdapter , Update , TemplateModel , DatabaseQuery , Element
  • $elementReferenceResolver : Sanitizer
  • $elements : Result , QueryElement
  • $elementsToRemove : Resolver
  • $email : CertificateSubject , AuthenticationResponse , AddUserCommand , FeedPerson , User
  • $empty : Query
  • $emptyBarChar : ProgressBar
  • $emptyStyle : OutputFormatterStyleStack
  • $enableBlinding : RSA
  • $enabled : ComponentRecord , Multilanguage , Microdata , HtmlView , CssMenu
  • $enableJqueryNoConflict : JavascriptRenderer
  • $enablePecl : FeatureSet
  • $eName : HtmlView
  • $enbuffer : SymmetricKey , Salsa20
  • $enchanged : SymmetricKey
  • $enclosure : FeedItem
  • $encoded : Signature , DataSet , ASN1
  • $encodedPayload : JWS
  • $encodedProtectedHeader : Signature
  • $encoder : Builder
  • $encoding : FromUtf8 , ToUtf8
  • $Encoding : PHPMailer
  • $encodingList : Mbstring
  • $encodingOptions : JsonResponse
  • $encodings : WebClient
  • $encrypt : SSH2
  • $encrypt_block_size : SSH2
  • $encrypted_key : KeyProtectedByPassword
  • $encryptFixedPart : SSH2
  • $encryptInvocationCounter : SSH2
  • $encryption_algorithms_client_to_server : SSH2
  • $encryption_algorithms_server_to_client : SSH2
  • $encryptionPadding : RSA
  • $encryptIV : SymmetricKey
  • $encryptName : SSH2
  • $encryptService : MfaTable
  • $end_date : Result
  • $endDate : X509
  • $endMemory : TracedStatement
  • $endTime : TracedStatement
  • $engine : WebClient , SymmetricKey
  • $engines : AsymmetricKey , BigInteger
  • $enmcrypt : SymmetricKey
  • $entities : FormHelper
  • $entries : Feed , Sidebar , Stream , Collection , MetadataTOCPayload
  • $entry : LdapUser
  • $entryElementName : FeedParser , RssParser
  • $entryManager : Adapter
  • $eof : Stream
  • $error : ApplicationErrorEvent , ErrorDocument , ApplicationErrorEvent , CommandErrorEvent , UploadedFile , SMTP , ConsoleErrorEvent , FatalError
  • $error_count : PHPMailer
  • $error_message : AuthenticationResponse
  • $errorCodes : Response
  • $errorCount : DatabaseModel , HtmlView
  • $errored : ConsoleLogger
  • $errorfiles : Language
  • $errorHandler : Iconv
  • $ErrorInfo : PHPMailer
  • $errorMessage : ParserException , ChoiceQuestion
  • $errorMsg : DatabaseDriver
  • $errorNum : DatabaseDriver
  • $errors : LazyAssertion , LazyAssertionException , Propel2Collector , Form , POP3 , SSH2 , Document , ResponseBag
  • $errorTypes : ExceptionCaster
  • $event_after_change_featured : ArticleModel
  • $event_after_delete : AdminModel , IndexModel
  • $event_after_purge : IndexModel
  • $event_after_save : AdminModel
  • $event_before_batch : AdminModel
  • $event_before_change_featured : ArticleModel
  • $event_before_change_state : AdminModel
  • $event_before_delete : AdminModel , IndexModel
  • $event_before_save : AdminModel
  • $event_before_unlock : TaskModel
  • $event_change_state : AdminModel
  • $event_clean_cache : BaseDatabaseModel
  • $event_unlock : TaskModel
  • $events : Dispatcher
  • $events_map : FormModel
  • $exactReplacements : ConfigPostProcessor
  • $exception : TracedStatement
  • $exceptionClass : Assertion , LazyAssertion
  • $exceptionHandler : ErrorHandler
  • $exceptionOnInvalidType : Inline
  • $exceptions : ExceptionsCollector , PHPMailer
  • $exchange_hash : SSH2
  • $exclude : FilelistField , FolderlistField
  • $excludeCredentials : PublicKeyCredentialCreationOptions
  • $excluded : UserField , Query
  • $excludedTerms : SearchModel
  • $exec : DatabaseQuery
  • $executable : Cli
  • $executed : DatabaseDriver
  • $executedStatements : TraceablePDO
  • $exit_status : SSH2
  • $exitCode : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent , ErrorHandler
  • $exiting : DaemonApplication
  • $expandNextHash : CliDumper
  • $expectDataDescriptor : ZIPExtraction
  • $expected_bytes : Agent
  • $expiration : MemcachedStorage
  • $expire : Session
  • $explained : HtmlView
  • $explains : QueryCollector , PlgSystemDebug
  • $explicit_key_length : SymmetricKey
  • $exponent : RSA
  • $exponents : RSAKey , PrivateKey
  • $extension : AssociationExtensionHelper , CategoryNode , TransitionField , WorkflowconditionField , WorkflowstageField , RouteHelper , Installer , InstallerAdapter , InstallerScript , CategoryView , Workflow , CategoryController , DisplayController , AssociationsHelper , HtmlView , AssociationsHelper , HtmlView , FinderHelper , Adapter , AssociationsHelper , NewsfeedsHelper , HtmlView , PluginsHelper , RedirectHelper , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , HtmlView , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $extension_message : Installer
  • $extensionMessage : InstallerAdapter
  • $extensionName : HtmlView
  • $extensionOutputCheckerHandler : Server , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , Server
  • $extensionRootFolders : JLoader
  • $extensions : CertificateExtensions , ExtensionsListCommand , ExtensionHelper , X509 , SFTP , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorData , PublicKeyCredentialOptions
  • $extensionsSupport : AssociationsHelper
  • $extensionValues : X509
  • $extra_query : Update
  • $extraAttributes : OnGetApiFields
  • $extraButtons : HtmlView
  • $extraDisplayOptions : HtmlDumper
  • $extraFields : LdapUser , LdapUserProvider
  • $extraQuery : Installer
  • $extraRelations : OnGetApiFields
  • $f_levels : HtmlView
  • $factories : FactoryCommandLoader
  • $factory : Inflector , Document , BaseController , Toolbar , DatabaseDriver , ContainerResource , Base , Binary , Montgomery , Prime , Uuid
  • $factory128 : Hash
  • $factory36 : Hash
  • $factory64 : Hash
  • $fail_if_unknown : ExtensionDescriptor
  • $fallbackDirsPsr0 : ClassLoader
  • $fallbackDirsPsr4 : ClassLoader
  • $fallbackErrorRenderer : SerializerErrorRenderer
  • $fallbackProperty : Microdata
  • $fallbackType : Microdata
  • $fastMult : ParagonIE_Sodium_Compat
  • $fetched : DatabaseIterator
  • $fetchMap : SqlsrvStatement
  • $fgBase : ColorStyle
  • $fgColor : ColorStyle
  • $fh : Stream
  • $field_type : CaptiveRenderOptions , SetupRenderOptions
  • $fieldCache : FieldsHelper
  • $fieldFactory : CronExpression
  • $fieldname : FormField
  • $fields : FieldFactory , FormattedtextLogger , Item , Uuid , Resource
  • $fieldsCache : FieldsHelper
  • $fieldsToRenderItem : JsonApiView , JsonapiView
  • $fieldsToRenderList : JsonApiView , JsonapiView
  • $file : JNamespacePsr4Map , ChangeItem , HtmlView , UploadedFile , FlattenException , SilencedErrorContext
  • $file_types : SFTP
  • $fileCreator : PlgExtensionNamespacemap
  • $fileFilter : FilelistField
  • $fileHeader : ZIPExtraction
  • $fileLinkFormat : HtmlErrorRenderer
  • $fileLinkFormatter : SourceContextProvider
  • $filelist : Manifest
  • $filemode : Stream
  • $filename : Stream , InstallerExtension
  • $fileName : HtmlView
  • $filename : Stream , Parser
  • $fileName : Reader
  • $filename : ZIPExtraction
  • $fileOffsets : DebugClassLoader
  • $filePath : LocalAdapter
  • $files : ComposerStaticInit2399d40fc48ada3450e844df0430bf2f , HtmlView
  • $filesize : Stream
  • $filesProcessed : ZIPExtraction
  • $fileType : Reader
  • $filter : CalendarField , HtmlView , Query , HtmlView , Input , Token , Versionable , AbstractCloner , DisplayPNGCharacteristicsDescriptor
  • $filter_fields : ListModel
  • $filterBlacklist : ListModel
  • $filterForbiddenList : ListModel , UsersModel
  • $filterForm : ListView , HtmlView
  • $filterFormat : CalendarField
  • $filterFormName : ListModel
  • $filters : FinderIndexCommand , Stream , Sidebar , Query , Stream , ASN1
  • $final : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , DebugClassLoader
  • $finalMethods : DebugClassLoader
  • $finderPluginId : HtmlView
  • $fix : Changelog
  • $fixedTime : FixedTimeProvider
  • $flags : Attribute , Identity , AbstractDumper , Manifest , AuthenticatorData
  • $fmt : AttestationStatement
  • $folder : PluginsField , ChangeSet
  • $folderFilter : FolderlistField
  • $font : HtmlView
  • $footerTitle : Table
  • $footerTitleFormat : TableStyle
  • $force : PasswordField
  • $forceMultiple : CheckboxesField , ConsentBoxField
  • $forceSSL : JoomlaStorage
  • $foreground : Color , OutputFormatterStyle
  • $form : FormField , DefaultView , FormView , HtmlView , JsonView , HtmlView
  • $format : Date , CalendarField , ColorField , FormattedtextLogger , W3cLogger , DownloadSource , AsymmetricKey , PKCS , EC , ASN1 , ProgressBar , ProgressIndicator , SerializerErrorRenderer , LintCommand
  • $formatLevelMap : ConsoleLogger
  • $formatLineCount : ProgressBar
  • $formatMapper : ApiApplication
  • $formatOptions : HTMLHelper
  • $formats : Image , ProgressBar
  • $formatter : NullOutput , Output
  • $formatters : ProgressBar , ProgressIndicator
  • $formControl : FormField
  • $formName : ContactModel , FormModel
  • $forms : Form , FormModel
  • $formsource : SubformField
  • $forward_status : Agent
  • $four : Prime
  • $fp : ZIPExtraction
  • $fragment : AbstractUri , Uri
  • $framesCache : ExceptionCaster
  • $from : Substitution , DatabaseExporter , DatabaseImporter , DatabaseQuery
  • $From : PHPMailer
  • $FromName : PHPMailer
  • $fromVersion : JoomlaInstallerScript
  • $fsock : SSH2 , Agent , Identity
  • $fullDefinition : Command
  • $fullname : AuthenticationResponse
  • $fullPath : FileLayout
  • $fullRange : AbstractField
  • $g : DSA , RgbPaletteEntry
  • $G1Curve : EcdaaTrustAnchor
  • $gcCalled : DatabaseHandler
  • $gcLifetime : DatabaseHandler
  • $gcmField : SymmetricKey
  • $gender : AuthenticationResponse
  • $generalProhibited : NamePrepData2008
  • $generateBestQuality : Image
  • $generated_fieldname : FormField
  • $generator : RandomLibAdapter , TableRows
  • $get : OptionsResolverIntrospector
  • $get_seq_no : SSH2
  • $gid : VarCloner
  • $given : OptionsResolver
  • $glue : QueryElement
  • $gmt : Date
  • $googleApiKey : Server
  • $group : CacheStorageHelper , FormField , InstallerExtension , InMemoryLogger , Update , HtmlView , DatabaseQuery
  • $groupByFieldset : SubformField
  • $grouplist : HtmlView
  • $groups : UserField , UserGroupsHelper , User , HtmlView
  • $groupsByUser : Access
  • $guest : User
  • $guid : FeedItem
  • $h : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , SymmetricKey
  • $handle : Image , ImageFilter , Socket , Stub
  • $handler : Propel2Collector , NativeStorage , Dumper , VarDumper
  • $handlers : ChainedHandler , ErrorHandler
  • $handlesHrefGracefully : OutputFormatterStyle , CliDumper
  • $handlingSignal : ConsoleSignalEvent
  • $hardRefCount : Cursor
  • $hardRefHandle : Cursor
  • $hardRefTo : Cursor
  • $hasAssociation : CategoriesModel , CategoryModel
  • $hash : RedisStorage , Hash , Signature , AsymmetricKey , MetadataTOCPayloadEntry
  • $hashCut : Cursor
  • $hashIndex : Cursor
  • $hashKey : Cursor
  • $hashKeyIsBinary : Cursor
  • $hashLength : Cursor
  • $hashMask : Php72
  • $hashParam : Hash
  • $hashType : Cursor
  • $having : DatabaseQuery
  • $header : Signature
  • $headerCheckerManager : JWSLoader
  • $headerCheckerManagerFactory : JWSLoaderFactory
  • $headerIsDumped : HtmlDumper
  • $headers : WebClient , Builder , Token , Table , FlattenException
  • $headerTitle : Table
  • $headerTitleFormat : TableStyle
  • $height : FeedImage , OpensearchImage , EditorField , MediaField , Terminal , DisplayPNGCharacteristicsDescriptor
  • $Helo : PHPMailer
  • $helo_rply : SMTP
  • $help : AbstractCommand , Command
  • $help_search : HelpModel
  • $help_url : CaptiveRenderOptions , MethodDescriptor , SetupRenderOptions
  • $helper : Versionable
  • $helperFactory : Module
  • $helpers : HelperSet
  • $helperSet : Application , AbstractCommand , Application , Command , Helper
  • $helpKey : ItemModel , ModuleModel , PluginModel , StyleModel
  • $helpLink : FormView , ListView
  • $helpLocal : ItemModel
  • $helpSearch : HtmlView
  • $helpURL : ItemModel , ModuleModel , PluginModel , StyleModel
  • $hex : BigInteger , Engine
  • $hidden : FormField , AbstractCommand , Command , Question
  • $hidden_data : SetupRenderOptions
  • $hiddenDescription : NoteField , FormField
  • $hiddenFallback : Question
  • $hiddenLabel : NoteField , FormField
  • $hide : EditorField
  • $hide_submit : CaptiveRenderOptions
  • $hideAll : WorkflowconditionField
  • $hideDefault : FilelistField , FolderlistField
  • $hideEmptyLimitstart : Pagination
  • $hideNone : FilelistField , FolderlistField
  • $highlight : Query
  • $hint : FormField
  • $history : ANSI
  • $history_attrs : ANSI
  • $hits : CategoryNode
  • $hLen : RSA
  • $hmac : AsymmetricKey
  • $hmac_check : SSH2
  • $hmac_check_etm : SSH2
  • $hmac_check_name : SSH2
  • $hmac_create : SSH2
  • $hmac_create_etm : SSH2
  • $hmac_create_name : SSH2
  • $hmac_size : SSH2
  • $home : MenuItem
  • $horizontal : Table
  • $horizontalInsideBorderChar : TableStyle
  • $horizontalOutsideBorderChar : TableStyle
  • $host : DatabaseLogger , LdapClient , AbstractUri , Uri
  • $Host : PHPMailer
  • $host : POP3 , SSH2 , Connection , DumpServer
  • $Hostname : PHPMailer
  • $hostname : Response
  • $href : OutputFormatterStyle , Link
  • $html : CaptiveRenderOptions , SetupRenderOptions
  • $html5 : HtmlDocument
  • $htmlFormName : ListModel
  • $http : HttpBridgePostRequestMethod , Client
  • $httpClient : Server , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , Server
  • $httpDriver : DebugBar
  • $httpFactory : Requests
  • $httpVersion : AbstractWebApplication
  • $Ical : PHPMailer
  • $IcalMethods : PHPMailer
  • $icon : AdministratorMenuItem , MetadataStatement , PublicKeyCredentialEntity
  • $iconImage : AdministratorMenuItem
  • $id : CategoryNode , ComponentRecord , FormField , RouteHelper , InstallerExtension , MenuItem , Asset , User , Item , TaskOption , HtmlView , RuntimeStorage , IdentifiedBy , PhpToken , Credential , ExtensionDescriptor , PublicKeyCredentialDescriptor , PublicKeyCredentialRpEntity , PublicKeyCredentialUserEntity , TokenBinding
  • $idCounter : ToolbarButton
  • $identifier : UnknownConstructedObject , UnknownObject , SSH2
  • $identities : Access
  • $ignoreCase : AbstractString
  • $ignoreChanges : ContentHistory
  • $ignored : Query
  • $ignoredCollectors : JavascriptRenderer
  • $ignoreDirectories : ZIPExtraction
  • $ignoredSearchWordsCallback : Language
  • $ignoreSystemNode : FeatureSet
  • $ignoreUninstallQueries : LanguageAdapter
  • $ignoreValidationErrors : Command
  • $image : FeedDocument , HtmlView , MethodDescriptor
  • $images : Browser
  • $img : MenuItem
  • $imported : JLoader
  • $in_request_pty_exec : SSH2
  • $in_subsystem : SSH2
  • $included : Query , Document
  • $includedTerms : SearchModel
  • $includePaths : HTMLHelper , FileLayout
  • $includes : Resource
  • $includeVendors : JavascriptRenderer
  • $incrementStyles : StringHelper
  • $indentation : Dumper
  • $indentPad : AbstractDumper
  • $index : RequestIdGenerator , AcceptMatch
  • $indexer : Adapter
  • $indicatorChangeInterval : ProgressIndicator
  • $indicatorCurrent : ProgressIndicator
  • $indicatorUpdateTime : ProgressIndicator
  • $indicatorValues : ProgressIndicator
  • $info : SysinfoModel , HtmlView , OptionsResolver
  • $infourl : Update
  • $initialised : Application
  • $initialization : JavascriptRenderer
  • $initialized : Registry , Application , HtmlDescriptor
  • $inline_crypt : SymmetricKey
  • $innerSequence : CertificateExtensions
  • $input : AbstractWebApplication , DatabaseStrategy , LocalStrategy , CliApplication , ConsoleApplication , Dispatcher , FormField , BaseController , JoomlaStorage , Query , OAuthCallbackEvent , HtmlView , Client , AddressValidator , ForwardedValidator , Cursor , ConsoleEvent , InputAwareHelper , SymfonyStyle , Parameters
  • $input_attributes : CaptiveRenderOptions , SetupRenderOptions
  • $input_type : CaptiveRenderOptions , SetupRenderOptions
  • $input_value : SetupRenderOptions
  • $inputEncoding : Iconv
  • $inputFilter : FeedParser
  • $inputmode : TextField
  • $inputs : Input
  • $inputStream : QuestionHelper
  • $insert : DatabaseQuery
  • $install_script : ComponentAdapter
  • $installed : InstalledVersions
  • $installed_languages : HtmlView
  • $installedByVendor : InstalledVersions
  • $installedIds : PackageAdapter
  • $installer : PlgExtensionJoomla
  • $installerScript : LegacyInstallerScript
  • $installfrom : PlgInstallerWebinstaller
  • $instance : Calculator , Inflector , CliApplication , WebApplication , Authentication , Patcher , UserGroupsHelper , Log , BaseController , ChangeSet , Updater , ContainerResource , Patcher , Inflector , Manager , ZIPExtraction
  • $instanceCounter : BinaryField , PrimeField
  • $instanceID : BinaryField , Integer , PrimeField , Integer
  • $instances : CMSApplication , Captcha , Categories , FtpClient , Document , Editor , Browser , InputFilter , Installer , Mail , AbstractMenu , Pathway , Profiler , Router , Toolbar , Uri , User , Language , Parser , DatabaseDriver , FtpClient , Stream
  • $instructions : Result
  • $interactive : Input
  • $interactiveBuffer : SSH2
  • $interlace : DisplayPNGCharacteristicsDescriptor
  • $internal : DebugClassLoader
  • $internalArray : SplFixedArray
  • $internalContext : FieldController
  • $internalEncoding : Iconv , Mbstring
  • $internalFormat : ProgressBar
  • $internalMethods : DebugClassLoader
  • $internalResource : PharStreamWrapper
  • $inTraceStub : FrameStub
  • $intro_items : HtmlView
  • $invalidParameter : InvalidParameterException
  • $inVendor : LinkStub
  • $invipmap : DES
  • $invisiblePlugins : AsymmetricKey
  • $invocation : PharStreamWrapper
  • $invocationFunctionNames : PharInvocationResolver
  • $invocations : PharInvocationCollection
  • $invpitable : RC2
  • $invsqrtamd : ParagonIE_Sodium_Core_Curve25519_H
  • $ioStyle : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand
  • $ip : IpHelper
  • $ipad : Hash
  • $ipAddresses : X509
  • $ipmap : DES
  • $irregular : Ruleset
  • $is_negative : Engine
  • $is_timeout : SSH2
  • $isAdmin : Mfa , HtmlView
  • $isAjax : PlgSystemDebug
  • $isBare64Encoded : DistantSingleMetadata , SingleMetadata
  • $isBound : LdapClient
  • $isDebug : CompleteCommand
  • $isDefaultBackendTemplate : HtmlView
  • $isDownload : XmlDocument
  • $isEditExisting : HtmlView
  • $isEmptyState : HtmlView
  • $isEnabled : LazyCommand
  • $isFinder : DebugClassLoader
  • $isFreshUserVerificationRequired : MetadataStatement
  • $isKeyRestricted : MetadataStatement
  • $isMandatoryMFASetup : HtmlView
  • $isMbStringOverload : AbstractPunycode
  • $isNested : TagField
  • $isPayloadDetached : JWS , JWSBuilder
  • $isPayloadEncoded : JWSBuilder
  • $isReadableProvider : LintCommand
  • $isRecursive : ErrorHandler
  • $isRoot : User , ErrorHandler
  • $isSecondFactorOnly : MetadataStatement
  • $issuers : IssuedBy
  • $isValidEngine : Engine
  • $isValidUtf8 : Iconv
  • $item : FormView , HtmlView , VcfView , HtmlView , MessageModel , HtmlView , JsonView , HtmlView
  • $itemQueryModelStateMap : MediaController
  • $items : Changelog , FeedDocument , AdminLanguage , Category , ContentLanguage , Menu , Tag , HtmlView , AbstractMenu , CategoriesView , CategoryView , ListView , HtmlView , XmlView , HtmlView , Domain , HtmlView , TagModel , HtmlView , ValidationData
  • $itemsLoaded : AbstractMenu
  • $itemsPerPage : ApiController
  • $itemTags : TagsHelper
  • $itemType : HtmlView
  • $itemTypes : AssociationExtensionHelper , AssociationsHelper
  • $iteration_count_log2 : PasswordHash
  • $iteratorPosition : Construct
  • $itoa64 : PasswordHash
  • $iv : OpenSSL , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , SymmetricKey
  • $javascriptClass : JavascriptRenderer
  • $join : DatabaseQuery
  • $jsFiles : JavascriptRenderer
  • $jsonapi : Document
  • $jsRenderer : DebugBar
  • $jsVendors : JavascriptRenderer
  • $jwsSerializer : AndroidSafetyNetAttestationStatementSupport
  • $jwsSerializerManagerFactory : JWSLoaderFactory
  • $jwsVerifier : JWSLoader , AndroidSafetyNetAttestationStatementSupport
  • $jwsVerifierFactory : JWSLoaderFactory
  • $k : RSA
  • $K : Twofish
  • $KD : Normalizer
  • $keepAlive : SSH2
  • $keepArgs : FrameStub , TraceStub
  • $kex_algorithm : SSH2
  • $kex_algorithms : SSH2
  • $kex_dh_group_size_max : SSH2
  • $kex_dh_group_size_min : SSH2
  • $kex_dh_group_size_preferred : SSH2
  • $key : MapItem , SeekingData , RouterViewConfiguration , Aes , Crypt , DatabaseIterator , Builder , SignedWith , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , SymmetricKey , Hash , RC2 , RC4 , Identity , Data
  • $key_blob : Identity
  • $key_bytes : Key
  • $key_length : Blowfish , DES , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • $key_length_max : DES , TripleDES
  • $keyboard_requests_responses : SSH2
  • $keyField : SqlField , TimezoneField
  • $keyNamespace : MemcachedStorage
  • $keyProtection : MetadataStatement
  • $keys : JWKSet , DES , RC2
  • $keywords : ColorField
  • $kl : Blowfish , Rijndael , Twofish
  • $knownColors : ColorStyle
  • $knownOptions : ColorStyle
  • $label : FormField , CaptiveRenderOptions , SetupRenderOptions , RSA
  • $labelclass : FormField
  • $lang : Language
  • $lang_codes : PlgSystemLanguageFilter
  • $lang_tag : HelpModel
  • $langConstPrefix : TaskOption
  • $langlist : LanguagesModel
  • $language : CliApplication , ConsoleApplication , WebApplication , AuthenticationResponse , CategoryNode , Changelog , Document , Factory , FeedLink , MenuitemField , MailTemplate , MenuItem , SiteMenu , Language , El , Zh , Query , Result , Token , MenuItemByTypeField , OutputFilter , AcceptLanguage , PHPMailer , Mbstring
  • $language_filter : SiteApplication
  • $LANGUAGE_MAX_KEY : ASCII
  • $languageCount : LanguagesModel
  • $languages : WebClient , CachingLanguageFactory , Language , HtmlView
  • $languages_client_to_server : SSH2
  • $languages_server_to_client : SSH2
  • $languageTag : HtmlView
  • $last_interactive_response : SSH2
  • $last_packet : SSH2
  • $last_reply : SMTP
  • $last_smtp_transaction_id : SMTP
  • $lastArrayArgument : InputDefinition
  • $lastBuildDate : FeedDocument
  • $lastDepth : HtmlDumper
  • $lastError : Iconv
  • $lastErrorMessage : ZIPExtraction
  • $lastExtractedFilename : ZIPExtraction
  • $lastExtractedFileTimestamp : ZIPExtraction
  • $lastIdentifier : CliDescriptor
  • $lastMessageID : PHPMailer
  • $lastOptionalArgument : InputDefinition
  • $lastQueryStoreId : ListModel
  • $lastResetTime : User
  • $lastvisitDate : User
  • $lastWriteTime : ProgressBar
  • $latest : Changelog , Update
  • $latest_version_check : HelpModel
  • $layout : ActionButton , TransitionButton , AccessiblemediaField , CalendarField , CheckboxesField , CheckboxField , ColorField , ComboField , ContenthistoryField , EmailField , FileField , GroupedlistField , HiddenField , ListField , MediaField , MeterField , ModuleorderField , NumberField , PasswordField , RadiobasicField , RadioField , RangeField , RulesField , SubformField , TagField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , FormField , BasicButton , DropdownButton , InlinehelpButton , LinkButton , PopupButton , SeparatorButton , StandardButton , ToolbarButton , CategoryeditField , Adapter , ModulesPositioneditField , WebcronLinkField , TinymcebuilderField , DataField , UniqueidField , JoomlatokenField , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $layoutData : TinymcebuilderField
  • $layoutId : FileLayout
  • $layouts : RouterViewConfiguration
  • $lazy : OptionsResolver
  • $lazyAssertionExceptionClass : Assert
  • $ldap : LdapUserProvider
  • $ldapLocator : CheckLdapCredentialsListener
  • $ldapServiceId : LdapAuthenticator , LdapBadge
  • $LE : PHPMailer
  • $lead_items : HtmlView
  • $leeway : ValidAt , ValidationData , AndroidSafetyNetAttestationStatementSupport
  • $leftover : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State
  • $legalHeader : MetadataStatement , MetadataTOCPayload
  • $len : StreamString , StringWrapper
  • $length : ByteStringObject , ListObject , MapObject , TextStringObject , FeedEnclosure , FeedLink , Token , Hash , StringStream
  • $lengthDecrypt : SSH2
  • $lengthEncrypt : SSH2
  • $level : CategoryNode , MenuItem , Nested
  • $levels : HtmlView , ErrorHandler
  • $levelsInUse : LevelModel
  • $lft : CategoryNode , Nested
  • $libraries : LibraryHelper
  • $libraryname : LibraryManifest
  • $license : LibraryManifest
  • $liEnding : English
  • $limbs : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $limit : Pagination , DatabaseDriver , DatabaseQuery , SourceContextProvider
  • $limitstart : Pagination
  • $line : FlattenException , SilencedErrorContext , AbstractDumper , PhpToken
  • $line_separator : EchoLogger
  • $lineDumper : AbstractDumper
  • $lineEndings : FtpClient
  • $lineLength : SymfonyStyle
  • $lines : ConsoleSectionOutput , Parser
  • $link : Document , FeedImage , FeedItem , MediaField , MenuItem , PaginationObject
  • $link_items : HtmlView
  • $linkProvider : PreloadManager
  • $links : GenericLinkProvider
  • $list : PlgContentPagebreak
  • $list_price : Result
  • $listBlacklist : ListModel
  • $listeners : Dispatcher , ListenersPriorityQueue
  • $listForbiddenList : ListModel
  • $listQueryModelStateMap : MediaController
  • $literals : AbstractField , DayOfWeekField , MonthField
  • $loaded : Behavior , Bootstrap , DraggableList , Dropdown , Form , FormBehavior , Jquery , SearchTools , UiTab , MetadataRepository , DebugClassLoader
  • $loadedExtensions : ExtensionHelper
  • $loader : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f , NamespacedTwigProfileCollector , TwigProfileCollector , ClassLoader
  • $locale : Language
  • $locality : CertificateSubject
  • $locallySkippedLineNumbers : Parser
  • $location : ASN1
  • $lock : PasswordField
  • $locked : WebAssetManager , OptionsResolver
  • $log_boundary : SSH2
  • $log_long_width : SSH2
  • $log_short_width : SSH2
  • $log_size : SSH2
  • $logCategory : Task
  • $logEntries : InMemoryLogger , PlgSystemDebug
  • $logFilePath : ZIPExtraction
  • $logFP : ZIPExtraction
  • $loggableApi : Joomla
  • $loggableExtensions : Joomla
  • $loggableVerbs : Joomla
  • $loggedErrors : ErrorHandler
  • $logger : CacheCacheCollector , Propel2Collector , PropelCollector , DelegatingPsrLogger , ErrorListener , HtmlErrorRenderer , DumpServer
  • $loggerMap : LoggerRegistry
  • $loggerRegistry : Log
  • $loggers : Log , ErrorHandler
  • $logs : DebugMonitor , BufferingLogger
  • $longVowels : Finnish
  • $lookup : MenuRules , RouteHelper , Log , RouteHelper
  • $lowerAgent : Browser
  • $lowerLimitSearchWordCallback : Language
  • $lowerMap : Entry
  • $m0 : Twofish
  • $m1 : Twofish
  • $m2 : Twofish
  • $m3 : Twofish
  • $mac_algorithms_client_to_server : SSH2
  • $mac_algorithms_server_to_client : SSH2
  • $machineContent : Microdata
  • $macroCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $mailer : Factory , MailTemplate
  • $Mailer : PHPMailer
  • $mailHeader : PHPMailer
  • $mainEngine : BigInteger
  • $maintainer : Update
  • $maintainerurl : Update
  • $major : Version
  • $majorType : AbstractCBORObject
  • $majorVersion : Browser
  • $manifest : Installer , InstallerAdapter , Container
  • $manifest_cache : InstallerExtension
  • $manifest_file : Manifest
  • $manifest_script : ComponentAdapter , InstallerAdapter
  • $manifestClass : Installer
  • $manifestLength : Manifest
  • $mappedAlias : Stub
  • $mapToNothing : NamePrepData2008
  • $mariadb : MysqlDriver , MysqliDriver
  • $marker128 : Hash
  • $marker64 : Hash
  • $marks : Profiler
  • $master : HtmlView
  • $matcherProtection : MetadataStatement
  • $matches : Token
  • $matchVersion : Changelog
  • $max : MeterField , NumberField , SubformField , TimeField , IntervalField , ProgressBar
  • $max_history : ANSI
  • $max_sftp_packet : SFTP
  • $max_x : ANSI
  • $max_y : ANSI
  • $maxAge : AndroidSafetyNetAttestationStatementSupport
  • $maxDepth : Data
  • $maxDigits : NativeCalculator
  • $maxExecTime : ZIPExtraction
  • $maxItems : AbstractCloner
  • $maxItemsPerDepth : Data
  • $maxIterationCount : CronExpression
  • $maxlength : CalendarField
  • $maxLength : PasswordField
  • $maxlength : TextareaField
  • $maxLength : TextField , TrimmedBufferOutput
  • $maxRetries : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • $maxSecondsBetweenRedraws : ProgressBar
  • $maxString : AbstractCloner
  • $maxStringWidth : CliDumper
  • $maxTemplates : BiometricAccuracyDescriptor
  • $maxwordrange128 : Hash
  • $maxwordrange64 : Hash
  • $maxyear : CalendarField
  • $mdsCache : MetadataRepository
  • $mdsMap : MetadataRepository
  • $measures : TimeDataCollector , ProfileCollector
  • $mediaApiModel : MediaModel , MediumModel
  • $mediaElement : TemplateModel
  • $mediaFiles : HtmlView
  • $mediaVersion : Document , Version
  • $memcached : MemcachedStorage , MemcachedHandler
  • $memoryDelta : TracedStatement
  • $memoryLogs : DebugMonitor
  • $menu : RouterBase , SiteRouter
  • $menuFactory : CMSApplication
  • $menuItemId : ConsentBoxField
  • $menuItemMatchArticle : HtmlView
  • $menuItemMatchCategory : CategoryView
  • $menuItemMatchContact : HtmlView
  • $menuItemModel : PlgSampledataBlog
  • $menus : CMSApplication , Menu
  • $menuType : MenuitemField
  • $menutype : MenuItem
  • $menuType : MenuItemByTypeField
  • $merge : DatabaseQuery
  • $merged : Resource
  • $mergeProperty : AggregatedCollector
  • $message : Installer , LogEntry , BaseController , JsonResponse , ProgressIndicator , FlattenException
  • $message_log : SSH2
  • $message_number_log : SSH2
  • $message_numbers : SSH2
  • $message_type : PHPMailer
  • $MessageDate : PHPMailer
  • $MessageID : PHPMailer
  • $messagePrefix : HtmlView
  • $messageQueue : CMSApplication
  • $messages : MessagesCollector , CliApplication , ConsoleApplication , JsonResponse , ProgressBar
  • $messagesLogger : SwiftMailCollector
  • $messageType : BaseController
  • $metadata : Tar , Zip , CategoryNode , Language
  • $metaData : Manifest
  • $metaDataLength : Manifest
  • $metadataManager : SessionMetadataGcCommand , MetadataManagerListener
  • $metadataRepository : Authentication
  • $metadataStatementRepository : AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , Server
  • $metadesc : CategoryNode
  • $metakey : CategoryNode
  • $meter : PasswordField
  • $method : OpenSSL , LazyServiceEventListener , DebugClassLoader
  • $methods : BaseController , HtmlView , Route
  • $methodTraits : DebugClassLoader
  • $mfaActive : HtmlView
  • $mfaConfigurationUI : HtmlView
  • $mfaMethodName : Email , Fixed , Totp , Webauthn , Yubikey
  • $mfaMethods : MethodModel , HtmlView
  • $mgfHash : RSA
  • $mgfHLen : RSA
  • $microseconds : GeneralizedTime
  • $mime : Adapter
  • $MIMEBody : PHPMailer
  • $MIMEHeader : PHPMailer
  • $mimeType : AbstractWebApplication
  • $min : NumberField , SubformField , TimeField , IntervalField
  • $minComplexity : PatternAccuracyDescriptor
  • $minDepth : AbstractCloner
  • $minifyXML : Sanitizer
  • $minimum_stability : Update , UpdateAdapter
  • $minimumBatchProcessingTime : FinderIndexCommand
  • $minimumJoomla : InstallerScript
  • $minimumPhp : InstallerScript
  • $minLength : CodeAccuracyDescriptor
  • $minor : Version
  • $minorVersion : Browser
  • $minSecondsBetweenRedraws : ProgressBar
  • $minyear : CalendarField
  • $missingClasses : ClassLoader
  • $missingDownloadKeys : HtmlView
  • $mobile : WebClient , Browser
  • $modality : BiometricStatusReport
  • $modalLink : HtmlView
  • $mode : StreamString , UserGroupsHelper , Query , StringWrapper , SymmetricKey , Stream , InputArgument , InputOption
  • $mode_3cbc : TripleDES
  • $mode_sef : PlgSystemLanguageFilter
  • $modeAlias : PlgEditorCodemirror
  • $model_prefix : BaseController
  • $modelState : ApiController
  • $modePath : PlgEditorCodemirror
  • $modexpEngine : Engine
  • $modified_time : CategoryNode
  • $modified_user_id : CategoryNode
  • $modifiedDate : AbstractWebApplication
  • $modifiers : FormRule , BooleanRule , PrefixRule
  • $mods : PlgContentLoadmodule
  • $module : AbstractModuleDispatcher
  • $modules : HtmlView , PlgContentLoadmodule
  • $modulo : Binary , Montgomery , Prime , TwistedEdwards , Integer
  • $modulus : RSAKey , RSA
  • $modulus_length : RSAKey
  • $monitor : DatabaseDriver
  • $monitors : ChainedMonitor
  • $moved : UploadedFile
  • $msgElements : ChangeItem
  • $multiline : Question
  • $multiple : FormField
  • $multiselect : ChoiceQuestion
  • $mvcFactory : ComponentDispatcher , ComponentDispatcherFactory
  • $naf : Base
  • $name : MonologCollector , AggregatedCollector , ConfigCollector , MessagesCollector , CMSApplication , ConsoleApplication , Captcha , RouterView , RouterViewConfiguration , AddUserCommand , XmlDocument , FeedPerson , Form , FormField , InstallerAdapter , Manifest , BaseController , BaseModel , Asset , ToolbarButton , Update , User , BufferStreamHandler , WebAssetItem , Domain , Field , MethodDescriptor , Application , AbstractCommand , DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , QueryElement , SqlazureDriver , SqliteDriver , AbstractEvent , Buffer , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , QueryCollector , SessionCollector , RuntimeStorage , Basic , Application , Command , InputArgument , InputOption , OptionConfigurator , AuthenticationExtension , PublicKeyCredentialEntity
  • $namePrep : ToPunycode
  • $namePrepData : NamePrep
  • $nameQuote : DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • $namespace : CategoryFactory , ComponentRecord , RouterFactory , ComponentDispatcherFactory , ModuleDispatcherFactory , CategoryFactory , ComponentDispatcherFactory , HelperFactory , ModuleDispatcherFactory , MVCFactory , RouterFactory , HelperFactory , InstallerExtension , MVCFactory , ApplicationDescription , XML , ApplicationDescription
  • $namespaces : JLoader , FeedParser , ApplicationDescription
  • $Nb : Rijndael
  • $negations : InputDefinition
  • $negotiate_tls : LdapClient
  • $nestable : RouterViewConfiguration
  • $nested : OptionsResolver
  • $newGetMultiSignature : MemcachedStorage
  • $newtag : SymmetricKey
  • $nextUpdate : MetadataTOCPayload
  • $Nk : Rijndael
  • $no : MetadataTOCPayload
  • $no_referrals : LdapClient
  • $noBackupCheck : HtmlView
  • $noColors : ColorProcessor
  • $nodeProvider : FeatureSet , DefaultTimeGenerator , TimeGeneratorFactory , UuidFactory
  • $nodeProviders : FallbackNodeProvider
  • $nodes : Taxonomy , CssMenu
  • $noIDs : Router
  • $nonce : SodiumCipher , Sodium , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , SymmetricKey , Hash
  • $nonceDirectives : PlgSystemHttpHeaders
  • $nonCoreCriticalPlugins : HtmlView
  • $nonCoreExtensions : HtmlView
  • $nonIVChanged : SymmetricKey
  • $noPreloadTag : AddConsoleCommandPass
  • $normalizeCombiningClasses : NamePrepData2008
  • $normalized : BaseAccept
  • $normalizer : Question
  • $normalizers : OptionsResolver
  • $note : Changelog , MenuItem
  • $notification : Stream
  • $noun : Russian
  • $noValueDirectives : PlgSystemHttpHeaders
  • $noVersionCheck : HtmlView
  • $Nr : Rijndael
  • $nrOfLengthOctets : ASNObject
  • $nrOfUnusedBits : BitString
  • $nthRange : DayOfWeekField
  • $nullDate : DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver
  • $nullDatetimeList : DatabaseQuery , MysqlQuery , MysqliQuery , PdoQuery , PgsqlQuery , SqlsrvQuery
  • $numberConverter : FeatureSet , UuidFactory
  • $numberingOffset : TraceStub
  • $numberOfColumns : Table
  • $numberOfParsedLines : Parser
  • $numerator : BigRational
  • $numeric : Token
  • $numitems : CategoryNode
  • $oauth : PHPMailer
  • $oauthClientId : OAuth
  • $oauthClientSecret : OAuth
  • $oauthRefreshToken : OAuth
  • $oauthToken : OAuth
  • $oauthUserEmail : OAuth
  • $object : TagObject
  • $objectForMap : Inline
  • $objects : DataSet
  • $objectSupport : Inline
  • $offset : ParserException , DatabaseDriver , DatabaseQuery , RelativeStream , Parser
  • $offset128 : Hash
  • $offset64 : Hash
  • $oids : ASN1 , X509
  • $oidsLoaded : PKCS8 , PSS , X509
  • $old_access : Adapter
  • $old_cataccess : Adapter
  • $old_x : ANSI
  • $old_y : ANSI
  • $oldAdminFiles : ComponentAdapter
  • $oldApiFiles : ComponentAdapter
  • $oldConfig : SiteStatus
  • $oldFiles : ComponentAdapter , PluginAdapter
  • $oldtag : SymmetricKey
  • $onchange : FormField
  • $onclick : FormField
  • $one : AsymmetricKey , Binary , Montgomery , Prime , TwistedEdwards , Engine
  • $onemsqd : ParagonIE_Sodium_Core_Curve25519_H
  • $onlyNumericLabels : CronField
  • $opad : Hash
  • $open_flags : SFTP
  • $open_flags5 : SFTP
  • $openedPath : StreamString , StringWrapper
  • $openHandlerClass : JavascriptRenderer
  • $openHandlerUrl : JavascriptRenderer
  • $openmode : Stream
  • $openssl_emulate_ctr : SymmetricKey
  • $openssl_mode_names : DES
  • $openSSLOptions : OpenSSL
  • $operatingEnv : MetadataStatement
  • $operationType : UpdateOperation
  • $operators : Query
  • $option : ComponentRecord , ComponentDispatcher , AdminController , ApiController , FormController , BaseDatabaseModel , AbstractView , InstalledModel , HtmlView
  • $optionConstants : MemcachedCaster
  • $optionDefaults : Select
  • $options : Archive , Bzip2 , Gzip , Tar , Zip , ColorStyle , ActionButton , CacheController , SetConfigurationCommand , StreamString , AuthorField , LimitboxField , PredefinedlistField , UsergrouplistField , Form , HtmlView , BaseLayout , Logger , ToolbarButton , WebAssetItem , LogcreatorField , TaskOptions , DatabaseDriver , DatabaseExporter , DatabaseImporter , StringWrapper , AbstractTransport , Http , Input , Client , Ini , Color , OutputFormatterStyle , TableCell , TableCellStyle , Input , InputDefinition , AbstractQuery
  • $optionsFilter : PredefinedlistField
  • $optionSuggestions : CompletionSuggestions
  • $ORD : ASCII
  • $order : CronExpression , DatabaseQuery , Base , Binary , Montgomery , Prime
  • $ordering : HtmlView
  • $organization : CertificateSubject
  • $organizationalUnit : CertificateSubject
  • $orig_key : RC2
  • $origin : CollectedClientData
  • $originalLogWriter : SlimCollector
  • $originalWord : Stem
  • $origIV : SymmetricKey
  • $orphans : Language
  • $otherTypeManager : Decoder
  • $output : CliApplication , GithubActionReporter , Cursor , Descriptor , ConsoleEvent , Dumper , ProgressBar , ProgressIndicator , Table , ConsoleLogger , OutputStyle , SymfonyStyle
  • $outputBuffer : HtmlErrorRenderer
  • $outputEncoding : Iconv
  • $outputStream : AbstractDumper
  • $overflow : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $override : Language
  • $overridesList : HtmlView
  • $overwrite : Installer , ProgressBar
  • $p : DSA , Binary , Montgomery , Prime , TwistedEdwards
  • $p1 : Salsa20
  • $p2 : Salsa20
  • $packagename : PackageManifest
  • $packager : Manifest
  • $packagerurl : Manifest
  • $packageUninstall : Installer
  • $packet_buffer : SFTP
  • $packet_log : SFTP
  • $packet_size_client_to_server : SSH2
  • $packet_type : SFTP
  • $packet_type_log : SFTP
  • $packet_types : SFTP
  • $pad : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , Hash
  • $paddable : SymmetricKey
  • $padding : SymmetricKey
  • $paddingChar : TableStyle
  • $paddingType : Hash
  • $paDesc : VerificationMethodDescriptor
  • $padType : TableStyle
  • $page : HelpModel , HtmlView
  • $pageclass_sfx : HtmlView
  • $pageHeading : CategoriesView , HtmlView
  • $pagesCurrent : Pagination
  • $pagesStart : Pagination
  • $pagesStop : Pagination
  • $pagesTotal : Pagination
  • $pagination : CategoryView , ListView , HtmlView
  • $parameterKeyMapping : MysqliStatement , SqlsrvStatement
  • $parameterMapping : DatabaseQuery
  • $parameters : TracedStatement , BaseAccept , Hash , ArrayInput , ArgsStub
  • $parameterTypeMapping : MysqliStatement , SqlsrvStatement
  • $params : CategoryNode , ComponentRecord , HtmlDocument , InstallerExtension , MenuItem , CMSPlugin , User , HtmlView , CssMenu , AbstractDataCollector
  • $paramTable : InstallerScript
  • $parent : AdapterInstance , RouterViewConfiguration , InstallerAdapter , ToolbarButton , CollectionAdapter , HtmlView , Container
  • $parent_id : CategoryNode , MenuItem , Nested
  • $parent_key : RouterViewConfiguration
  • $parentclass : CalendarField , EditorField , MediaField , NumberField , RulesField , FormField
  • $parentId : DaemonApplication
  • $parentsOptions : OptionsResolver
  • $parray : Blowfish
  • $parsed : ArgvInput
  • $parsedBody : ServerRequest
  • $parsedFile : ParseException
  • $parsedFilename : Inline
  • $parsedLine : ParseException
  • $parsedLineNumber : Inline
  • $parser : Yaml , Configuration , LintCommand
  • $parsers : FeedFactory
  • $partial_init : SFTP
  • $participle : Russian
  • $pass : AbstractUri
  • $passphrase : Key
  • $password : AuthenticationResponse , AddUserCommand , ChangeUserPasswordCommand , DatabaseLogger , User , LdapClient
  • $Password : PHPMailer
  • $password : POP3 , LdapUser
  • $password_clear : User
  • $password_default_salt : SymmetricKey
  • $passwordAttribute : LdapUserProvider
  • $passwordHandler : AbstractUsernamePasswordAuthenticationStrategy
  • $pasv : FtpClient
  • $patches : Patcher
  • $patchTypes : DebugClassLoader
  • $path : RouterViewConfiguration , StreamString , Image , LanguagesModel , FormattedtextLogger , InstalledModel , StringWrapper , AbstractUri , Uri , Stream , PlgSampledataMultilang
  • $paths : FormHelper , Installer , Language , BaseController , BaseModel
  • $pathway : CMSApplication , Pathway
  • $pattern : Pattern , Transformation , FormField , Route
  • $patterns : Patterns
  • $pause : FinderIndexCommand
  • $payload : JWS , JWSBuilder , JsonResponse
  • $pdo : TraceablePDO , TraceablePDOStatement , PdoStorage
  • $pdoStatement : PdoStatement
  • $peakMemory : PropelCollector
  • $peakUsage : MemoryCollector
  • $percent : ProgressBar
  • $perfectiveGerund : Russian
  • $php_info : SysinfoModel
  • $php_settings : SysinfoModel
  • $phpInfo : HtmlView
  • $phpInfoArray : SysinfoModel
  • $phpoptions : HtmlView
  • $phpOptions : HtmlView
  • $phpsettings : HtmlView
  • $phpSettings : HtmlView
  • $phrase : Token
  • $phrases : Response
  • $pitable : RC2
  • $placeholder : CaptiveRenderOptions , SetupRenderOptions
  • $plainVowels : Stem
  • $platform : WebClient , Browser
  • $plte : DisplayPNGCharacteristicsDescriptor
  • $plugins : PluginHelper , AsymmetricKey
  • $pluginState : HtmlView
  • $pluginType : Authentication
  • $pluralizer : Inflector
  • $pluralRulesets : GenericLanguageInflectorFactory
  • $pluralSuffixesCallback : Language
  • $poly1305Field : SymmetricKey
  • $poly1305Key : SymmetricKey
  • $pop_conn : POP3
  • $pop_parent : CollectionAdapter
  • $port : LdapClient , AbstractUri , Uri
  • $Port : PHPMailer
  • $port : POP3 , SSH2
  • $portable_hashes : PasswordHash
  • $pos : StreamString , StringWrapper , Stream , PhpToken
  • $position : SeekingData , ColorField , BufferStreamHandler , HtmlView , Buffer , Data , Stub
  • $post_message : CaptiveRenderOptions , SetupRenderOptions
  • $postcode : AuthenticationResponse
  • $pre_message : CaptiveRenderOptions , SetupRenderOptions
  • $precision : BigInteger , Engine
  • $predefinedOptions : PluginstatusField , PredefinedlistField , RedirectStatusField , RegistrationdaterangeField , StatusField , UseractiveField , UserstateField , LogsdaterangeField , RequeststatusField , RequesttypeField , ExecutionRuleField , TaskStateField
  • $preferred : SSH2
  • $preferred_signature_format : SSH2
  • $preferredEngine : SymmetricKey
  • $preferredVersion : SFTP
  • $prefix : Pagination , PaginationObject , Profiler , ApcuHandler , MemcachedHandler , RedisHandler
  • $prefixAsArray : AbstractPunycode
  • $prefixDirsPsr4 : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $prefixes : JLoader , FormHelper
  • $prefixesPsr0 : ClassLoader
  • $prefixLength : AbstractPunycode
  • $prefixLengthsPsr4 : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $preloadedAssets : Access
  • $preloadedAssetTypes : Access
  • $preloadManager : Document
  • $preloadTypes : Document
  • $preparedIndex : DatabaseQuery
  • $preservedSubset : CutArrayStub
  • $preserveTime : SFTP
  • $presets : MenusHelper
  • $prevErrorHandler : AbstractCloner
  • $preview : AccessiblemediaField , ColorField , MediaField , HtmlView
  • $previewHeight : AccessiblemediaField , MediaField
  • $previewLink : FormView
  • $previewWidth : AccessiblemediaField , MediaField
  • $previous : FlattenException
  • $previousMem : Profiler
  • $previousMessage : ProgressBar
  • $previousTime : Profiler
  • $prime : DH
  • $primes : RSAKey , PrivateKey
  • $print : HtmlView
  • $priorities : LogEntry , Logger , SyslogLogger
  • $priority : LogEntry
  • $Priority : PHPMailer
  • $priorityMap : DelegatingPsrLogger
  • $privacyType : ConsentBoxField
  • $private : Key , RSAKey
  • $private_exponent : RSAKey
  • $privateKey : PrivateKey , X509
  • $privateSettings : SysinfoModel
  • $privateTagName : AddConsoleCommandPass
  • $processId : DaemonApplication
  • $processingmethod : Stream
  • $processor : CliOutput
  • $processTitle : Command
  • $profile : NamespacedTwigProfileCollector , TwigProfileCollector
  • $profileKeyPrefix : Token , PlgUserToken
  • $profiler : CMSApplication , Indexer , Cache
  • $profiles : QueryCollector
  • $progressBar : UpdateCoreCommand , SymfonyStyle
  • $progressChar : ProgressBar
  • $prohibit : NamePrepData2008
  • $prohibitRanges : NamePrepData2008
  • $projectDir : HtmlErrorRenderer , SourceContextProvider
  • $prompt : ChoiceQuestion
  • $properties : Feed , FeedEntry , DataObject
  • $property : Microdata
  • $propertyPath : InvalidArgumentException
  • $protected : ContainerResource
  • $protectedConfigurationFields : ApplicationModel
  • $protectedHeader : Signature
  • $protocolFamily : MetadataStatement
  • $prototype : OptionsResolver
  • $prototypeIndex : OptionsResolver
  • $provider : OAuth
  • $providerManager : MediaProviderEvent
  • $providers : ProviderManager , HtmlView
  • $pubDate : FeedDocument
  • $pubKeyCredParams : PublicKeyCredentialCreationOptions
  • $public : Key
  • $public_exponent : RSAKey
  • $publicExponent : PrivateKey
  • $publicKey : CSR , PrivateKey , X509
  • $publicKeyAlgAndEncoding : MetadataStatement
  • $publicKeyAlgAndEncodings : MetadataStatement
  • $publicKeyCredentialDescriptors : PublicKeyCredentialDescriptorCollection
  • $publicKeyCredentialId : PublicKeyCredentialSource
  • $publicKeyCredentialSource : AuthenticatorAttestationResponseValidator
  • $publicKeyCredentialSourceRepository : Server , AuthenticatorAssertionResponseValidator , Server
  • $publish_end_date : Result
  • $publish_start_date : Result
  • $published : CategoryNode , MenuitemField , InstallerExtension , Result , MenuItemByTypeField
  • $punycodeEncoder : ToIdn , ToUnicode
  • $pwd : SFTP
  • $q : DSA , EC
  • $q0 : Twofish
  • $q1 : Twofish
  • $QA : EC
  • $qtime : FinderIndexCommand
  • $quality : AcceptMatch , BaseAccept
  • $query : SqlField , MenuItem , ListModel , HtmlView , ExecutionFailureException , MysqliStatement , SqlsrvStatement , AbstractUri , Uri , AbstractQuery
  • $queryCount : Propel2Collector
  • $queryMonitor : QueryCollector , PlgSystemDebug
  • $queryParams : ServerRequest
  • $querySet : DatabaseQuery
  • $queryString : LdapAuthenticator , LdapBadge
  • $queryType : ChangeItem
  • $question : Question
  • $questionHelper : SymfonyStyle
  • $quickicons : HtmlView
  • $quiet_mode : SSH2
  • $r : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , RgbPaletteEntry
  • $r1 : Stem
  • $r1Index : Stem
  • $r2 : Stem
  • $r2Index : Stem
  • $random_state : PasswordHash
  • $randomGenerator : FeatureSet , CombGenerator , UuidFactory
  • $randomMax : BinaryField
  • $rangeEnd : AbstractField , DayOfMonthField , DayOfWeekField , HoursField , MinutesField , MonthField
  • $rangeStart : AbstractField , DayOfMonthField , DayOfWeekField , HoursField , MinutesField , MonthField
  • $rating : FeedDocument
  • $raw : Json
  • $rawAttestationObject : AttestationObject
  • $rawData : CollectedClientData
  • $rawId : PublicKeyCredential
  • $rawMessage : ParseException
  • $rawname : CacheStorage
  • $reachedEof : PhpInputStream
  • $readable : Stream
  • $readonly : FormField
  • $readprefix : Stream
  • $realtime_log_file : SSH2
  • $realtime_log_size : SSH2
  • $realtime_log_wrap : SSH2
  • $realUsage : MemoryCollector
  • $reason : MailDisabledException , Status
  • $reasonPhrase : Response
  • $recipients : MailTemplate
  • $RecipientsQueue : PHPMailer
  • $recomputeAESKey : Hash
  • $record : HtmlView
  • $recordId : HtmlView
  • $records : MonologCollector , HtmlView
  • $recur_limit : X509
  • $recursive : FolderlistField
  • $redirect : BaseController
  • $redirect_url : Installer
  • $redirectPluginId : HtmlView
  • $redis : RedisStorage , RedisHandler
  • $redrawFreq : ProgressBar
  • $reduce : Engine , Integer
  • $refCount : Stub
  • $referenceId : HtmlView
  • $referenceLanguage : HtmlView
  • $referenceTitle : HtmlView
  • $referenceTitleValue : HtmlView
  • $refIndex : Cursor
  • $reflexive : Russian
  • $refs : Parser
  • $refsBeingParsed : Parser
  • $regenerate_compression_context : SSH2
  • $regenerate_decompression_context : SSH2
  • $regex : Pattern , Patterns , FormRule , BooleanRule , EmailRule , ModuleLayoutRule , PrefixRule , Route
  • $REGEX_ASCII : ASCII
  • $region : AcceptLanguage
  • $registerDate : User
  • $registered : BufferStreamHandler
  • $registeredAliases : CronExpression
  • $registeredLoaders : ClassLoader
  • $registry : HTMLHelper , WebAssetManager
  • $regular : Ruleset
  • $rel : OpensearchUrl , Link
  • $relation : FeedLink
  • $relationship : JsonApiView , OnGetApiRelation , JsonapiView
  • $relationships : Update , Resource
  • $release : InstallerScript
  • $remoteIp : RequestParameters
  • $removals : Patcher
  • $remove : Changelog
  • $removeRemoteReferences : Sanitizer
  • $removeXMLTag : Sanitizer
  • $renderCache : PlgFieldsSubform
  • $rendered : Table
  • $renderedSrc : ScriptsRenderer , StylesRenderer
  • $renderedTemplates : TraceableTwigEnvironment
  • $renderLabelLayout : FormField
  • $renderLayout : FormField
  • $renderOptions : HtmlView
  • $renderSqlWithParams : PDOCollector
  • $repeat : Form , FormField
  • $replaceMaps : NamePrepData2003 , NamePrepData2008
  • $replacement : Transformation
  • $replacements : ConfigPostProcessor , Replacements
  • $replaceTags : TagsHelper
  • $replyto : MailTemplate
  • $ReplyTo : PHPMailer
  • $ReplyToQueue : PHPMailer
  • $request_channel : Agent
  • $request_pty : SSH2
  • $requestBuffer : SFTP
  • $requestEndTime : TimeDataCollector , ProfileCollector
  • $requestFactory : Server , AndroidSafetyNetAttestationStatementSupport , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , Server
  • $requestId : DebugBar , InfoCollector
  • $requestIdGenerator : DebugBar
  • $requestMethod : ReCaptcha
  • $requestStack : RequestContextProvider
  • $requestStartTime : TimeDataCollector , ProfileCollector
  • $required : FormField , OptionsResolver
  • $requiredCount : InputDefinition
  • $requiredTerms : SearchModel
  • $requireReset : User
  • $requireResidentKey : AuthenticatorSelectionCriteria
  • $rerunStatus : ChangeItem
  • $reservedMemory : ErrorHandler
  • $resetCount : User
  • $residual_suffixes : Catalan
  • $resolved : LdapBadge , OptionsResolver
  • $resolver : OptionConfigurator , Manager
  • $resource : StringStream , LdapClient , Stream
  • $resources : Container , Collection
  • $response : AbstractWebApplication , FtpClient , UnexpectedResponseException , RequestParameters , PublicKeyCredential
  • $responseCode : FtpClient
  • $responseMap : AbstractWebApplication , RedirectField
  • $responseMsg : FtpClient
  • $restrictedVowels : Finnish
  • $result : MysqliStatement , SqlsrvStatement
  • $results : Authentication , PackageAdapter , HtmlView , Query
  • $rethrow : CryptoExceptionHandler
  • $retry_connect : SSH2
  • $return_page : HtmlView
  • $returnTypes : DebugClassLoader
  • $returnURL : HtmlView
  • $reverseOIDs : ASN1
  • $rfc4050 : XML
  • $rgt : CategoryNode , Nested
  • $rlu : MenutypesModel
  • $robot : WebClient
  • $robots : Browser
  • $rogueListHash : MetadataTOCPayloadEntry
  • $rogueListURL : MetadataTOCPayloadEntry
  • $roles : LdapUser
  • $root : Uri , CssMenu
  • $root_id : Nested
  • $rootAssetId : Access
  • $rootDirectory : Checkfiles , Requests
  • $rootPath : LocalAdapter
  • $route : InstallerAdapter , MenuItem , Result
  • $router : WebApplication , MenuRules , NomenuRules , StandardRules , Cache , DebugRouterCommand
  • $routes : Router
  • $routeVariables : ResolvedRoute , Route
  • $rowBindedValues : MysqliStatement
  • $rowCount : TracedStatement
  • $rows : TextareaField , HtmlView , Table
  • $rp : PublicKeyCredentialCreationOptions
  • $rpEntity : Server
  • $rpId : PublicKeyCredentialRequestOptions
  • $rpIdHash : AuthenticatorData
  • $rtl : PlgInstallerWebinstaller
  • $rule : ExecRuleHelper
  • $rules : RouterView , Router , Asset , Route
  • $rulesets : RulesetInflector , ConfigPostProcessor
  • $running : DaemonApplication , SingleCommandApplication
  • $runningCommand : Application
  • $runPlugins : CategoryView , HtmlView
  • $runState : ZIPExtraction
  • $rv : Stem
  • $rvIndex : Stem
  • $S0 : Twofish
  • $S1 : Twofish
  • $S2 : Twofish
  • $S3 : Twofish
  • $safeCodepoint : TranscodeUnicode
  • $safeData : SysinfoModel
  • $safeMode : TranscodeUnicode
  • $sale_price : Result
  • $save2copy : HtmlView
  • $saveFormat : ColorField
  • $sbox0 : Blowfish
  • $sbox1 : Blowfish , DES
  • $sbox2 : Blowfish , DES
  • $sbox3 : Blowfish , DES
  • $sbox4 : DES
  • $sbox5 : DES
  • $sbox6 : DES
  • $sbox7 : DES
  • $sbox8 : DES
  • $scale : BCMath , BigDecimal
  • $scheme : AbstractUri , Uri
  • $scope : CMSApplication
  • $scopedErrors : ErrorHandler
  • $score : AcceptMatch , Response
  • $screamedErrors : ErrorHandler
  • $screen : ANSI
  • $script : AcceptLanguage
  • $scriptElement : FileAdapter , ModuleAdapter , PluginAdapter
  • $scriptfile : PackageManifest
  • $scriptOptions : Document
  • $search : Query , Collection
  • $search_string : LdapClient
  • $searchDisplayedCharactersNumberCallback : Language
  • $searchDn : LdapAuthenticator , LdapBadge , LdapUserProvider
  • $searchPassword : LdapAuthenticator , LdapBadge , LdapUserProvider
  • $searchquery : SearchModel
  • $secret : KeyOrPassword , ReCaptcha , RequestParameters
  • $secret_type : KeyOrPassword
  • $section : RulesField , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , HtmlView
  • $sections : ConsoleSectionOutput
  • $security : Changelog
  • $seekable : Stream
  • $sefs : PlgSystemLanguageFilter
  • $select : DatabaseQuery
  • $selectedAlgorithms : Server
  • $selectRowNumber : DatabaseQuery
  • $selfAttestedFAR : BiometricAccuracyDescriptor
  • $selfAttestedFRR : BiometricAccuracyDescriptor
  • $selfUpdateAvailable : HtmlView
  • $send_id_string_first : SSH2
  • $send_kex_first : SSH2
  • $send_seq_no : SSH2
  • $sendEmail : User
  • $Sender : PHPMailer
  • $sEndings : German
  • $Sendmail : PHPMailer
  • $sendMailEnabled : HtmlView
  • $separator : Registry
  • $sequence : RSAKey
  • $serializer : JsonApiView , SerializerErrorRenderer , AddLinkHeaderListener , Resource
  • $serializerManager : JWSLoader
  • $serializers : JWSSerializerManager , JWSSerializerManagerFactory
  • $serialNumber : X509
  • $server : ServerDumpCommand
  • $server_caps : SMTP
  • $server_channels : SSH2
  • $server_host_key_algorithms : SSH2
  • $server_identifier : SSH2
  • $server_public_host_key : SSH2
  • $serverctrls : Query
  • $serverParams : ServerRequest
  • $serverType : DatabaseDriver
  • $serverUrl : PlgSystemStats
  • $serviceId : LazyServiceEventListener
  • $serviceMap : Registry
  • $serviceRegistry : HTMLHelper
  • $services : SimpleMetadataStatementRepository
  • $serviceUri : MetadataService
  • $session : ConsoleApplication , SessionMetadataGcCommand , Factory , JoomlaHttpDriver , Authentication , SessionEvent , AddressValidator , ForwardedValidator
  • $session_id : SSH2
  • $sessionHandler : SessionManager
  • $sessionRecordDoesNotExist : MetadataManager
  • $sessionRecordExists : MetadataManager
  • $sessionRecordUnknown : MetadataManager
  • $sessionValidators : Session
  • $set : DatabaseQuery
  • $severity : SilencedErrorContext
  • $sftp : Stream
  • $sftp_errors : SFTP
  • $shared : ContainerResource
  • $shortcut : InputOption
  • $shortcuts : InputDefinition
  • $shortFormat : DSA , EC
  • $shortinfo : MethodDescriptor
  • $show_submit : SetupRenderOptions
  • $showHidden : ApplicationDescription
  • $showIpColumn : HtmlView
  • $showLogs : PlgSystemDebug
  • $showMessage : HtmlView
  • $showon : FormField
  • $showSaveAsCopy : HtmlView
  • $shuffle : DES
  • $sidebar : ListView , HtmlView
  • $sigFormat : DSA
  • $sigma : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • $sign_cert_file : PHPMailer
  • $sign_extracerts_file : PHPMailer
  • $sign_key_file : PHPMailer
  • $sign_key_pass : PHPMailer
  • $signalHandlers : SignalRegistry
  • $signalRegistry : Application
  • $signals : DaemonApplication
  • $signalsToDispatchEvent : Application
  • $signature : CSR , Signature , Token , SSH2 , AuthenticatorAssertionResponse
  • $signature_format : SSH2
  • $signature_validated : SSH2
  • $signatureAlgorithm : CSR
  • $signatureAlgorithmManager : JWSBuilder , JWSVerifier
  • $signatureAlgorithmManagerFactory : JWSBuilderFactory
  • $signatureFileFormats : AsymmetricKey
  • $signatureFormats : AsymmetricKey
  • $signaturePadding : RSA
  • $signatures : JWS , JWSBuilder
  • $signatureSubject : X509
  • $signCount : AuthenticatorData
  • $signer : Builder , Configuration , SignedWith
  • $signingKey : Configuration
  • $silencedErrorCache : ErrorHandler
  • $silencedErrorCount : ErrorHandler
  • $singleCommand : Application
  • $singleStatements : SimpleMetadataStatementRepository
  • $SingleTo : PHPMailer
  • $SingleToArray : PHPMailer
  • $singularizer : Inflector
  • $singularRulesets : GenericLanguageInflectorFactory
  • $siteVerifyUrl : CurlPost , Post
  • $size : CacheStorageHelper , FormField , UploadedFile , Stream , UploadedFile , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_Curve25519_Fe , Stream , SplFixedArray
  • $sk : RogueListEntry
  • $skip_key_adjustment : SymmetricKey , RC2
  • $skipChildren : Cursor
  • $skipDays : FeedDocument
  • $skipFiles : ZIPExtraction
  • $skipHours : FeedDocument
  • $skippedLineNumbers : Parser
  • $sLen : RSA
  • $sliceLength : TraceStub
  • $sliceOffset : TraceStub
  • $slim : SlimCollector
  • $slug : CategoryNode
  • $smallestPrime : RSA
  • $smartMFA : SSH2
  • $smtp : PHPMailer
  • $smtp_conn : SMTP
  • $smtp_transaction_id_patterns : SMTP
  • $SMTPAuth : PHPMailer
  • $SMTPAutoTLS : PHPMailer
  • $SMTPDebug : PHPMailer
  • $SMTPKeepAlive : PHPMailer
  • $SMTPOptions : PHPMailer
  • $SMTPSecure : PHPMailer
  • $snapshot : Task
  • $snippet : ParseException
  • $socket : SocketPost , Connection , DumpServer
  • $socket_buffer : Agent
  • $softRefCount : Cursor
  • $softRefHandle : Cursor
  • $softRefTo : Cursor
  • $sort : AggregatedCollector
  • $sortOptions : SFTP
  • $source : FeedItem , HtmlView
  • $sources : Patcher
  • $spacer : Language , Zh
  • $spellcheck : FormField
  • $split : ColorField
  • $sqdmone : ParagonIE_Sodium_Core_Curve25519_H
  • $sql : TracedStatement , DatabaseDriver , DatabaseQuery
  • $sqlQueries : PdoStorage
  • $sqlQuotationChar : PDOCollector
  • $sqlShowProfileEach : PlgSystemDebug
  • $sqlShowProfiles : PlgSystemDebug
  • $sqrtadm1 : ParagonIE_Sodium_Core_Curve25519_H
  • $sqrtm1 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $srcContext : ExceptionCaster
  • $stack : Changelog , Update , UpdateAdapter
  • $stackAlwaysUseSessionStorage : DebugBar
  • $stackSessionNamespace : DebugBar
  • $stage : HtmlView
  • $stages : HtmlView
  • $standard_suffix_1a : Catalan
  • $start : Profiler
  • $start_date : Result
  • $startAt : Php73
  • $startDate : X509
  • $started : NativeStorage , RuntimeStorage , DebugFormatterHelper , ProgressIndicator
  • $startedMeasures : TimeDataCollector , ProfileCollector
  • $startMemory : TracedStatement
  • $startSequence : CSR
  • $startTime : TracedStatement , ProgressBar , ProgressIndicator , ZIPExtraction
  • $stat : StreamString , StringWrapper
  • $stat_cache : SFTP
  • $state : CertificateSubject , CategoriesView , CategoryView , FormView , ListView , HtmlView , Indexer , Result , HtmlView , XmlView , HtmlView , JsonView , HtmlView , Session
  • $state_field : Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderNewsfeeds , PlgFinderTags
  • $statement : DatabaseDriver , DatabaseIterator , MysqliStatement , SqlsrvStatement , SingleMetadata
  • $statements : PropelCollector
  • $states : ActionButton
  • $stateStore : Update
  • $status : AbstractUsernamePasswordAuthenticationStrategy , AuthenticationResponse , ResponseBag , StatusReport , TokenBinding
  • $status_codes : SFTP
  • $statusCode : Response , FlattenException
  • $statusReports : MetadataTOCPayloadEntry
  • $statusText : FlattenException
  • $stderr : ConsoleOutput
  • $stdErrorLog : SSH2
  • $stdinIsInteractive : QuestionHelper
  • $stem : Token
  • $stemmer : Language
  • $stemmers : StemmerManager
  • $stEndings : German
  • $step : NumberField , TimeField , IntervalField , ProgressBar
  • $stepStack : Installer
  • $stepWidth : ProgressBar
  • $stop : Cursor
  • $stopped : AbstractEvent
  • $storage : DebugBar
  • $store : Session
  • $storedUser : AbstractMenu
  • $strategies : Authentication
  • $stream : FeedParser , Stream , UploadedFile , Stream , UploadedFile , RC4 , Input , StreamOutput
  • $string : AbstractString
  • $strings : Language , Text , StringController
  • $striped : MeterField
  • $stripExt : FilelistField
  • $stripFilter : ColorProcessor
  • $stripUSC : InputFilter
  • $stty : QuestionHelper , Terminal
  • $stub : Container
  • $style : NullOutputFormatter , Table
  • $styles : ColorProcessor , OutputFormatter , OutputFormatterStyleStack , Table , CliDumper , HtmlDumper
  • $styleStack : OutputFormatter
  • $stz : Date
  • $subIdentifiers : ObjectIdentifier
  • $subject : Usage , CSR , RelatedTo
  • $Subject : PHPMailer
  • $subjects : Resolver
  • $submit_class : CaptiveRenderOptions , SetupRenderOptions
  • $submit_icon : CaptiveRenderOptions , SetupRenderOptions
  • $submit_text : CaptiveRenderOptions , SetupRenderOptions
  • $subPart : Accept
  • $substitutions : Substitutions
  • $subtype : CronField
  • $success : JsonResponse , Response
  • $suggested : HtmlView
  • $suggestion : Token
  • $superlative : Russian
  • $supportedContext : PlgContentConfirmConsent
  • $supportedExtensions : MetadataStatement
  • $supportedExtensionsList : AssociationsHelper
  • $supportedFunctionality : ContentComponent
  • $supportedHttpHeaders : PlgSystemHttpHeaders
  • $supportFunctionality : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • $supportsBatch : ListView
  • $supportsDiscoverInstall : FileAdapter , PackageAdapter , InstallerAdapter
  • $sx : EcdaaTrustAnchor
  • $sy : EcdaaTrustAnchor
  • $symbolsMap : AsciiSlugger
  • $syndicationURL : FeedDocument
  • $synopsis : AbstractCommand , Command
  • $t : Hash
  • $T : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $T2d : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $table : DatabaseLogger , AdminModel , UCMContent , Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $table_heading : SetupRenderOptions
  • $tableClassName : AdminModel
  • $tableFields : Table
  • $tableName : PdoStorage
  • $tablePrefix : DatabaseDriver
  • $tableWide : AbstractUnicodeString
  • $tableZero : AbstractUnicodeString
  • $tabular_data : SetupRenderOptions
  • $tag : ExplicitlyTaggedObject , LanguageAdapter , TagModel , TaggedValue , ExtensionDescriptor
  • $tagFilter : ColorProcessor
  • $tagObjectManager : Decoder
  • $tags : Update , Container
  • $tags_title : HtmlView
  • $tagsArray : InputFilter
  • $tagsChanged : TagsHelper
  • $tagsMethod : InputFilter
  • $target : AdministratorMenuItem
  • $targetAction : HtmlView
  • $targetId : HtmlView
  • $targetLanguage : HtmlView
  • $targetplatform : Update
  • $targetTitle : HtmlView
  • $task : BaseController , ExecRuleHelper
  • $taskMap : BaseController
  • $taskOptionsCache : SchedulerHelper
  • $taskRegistry : Task
  • $taxonomies : Taxonomy
  • $taxonomy : Result
  • $tcDisplay : MetadataStatement
  • $tcDisplayContentType : MetadataStatement
  • $tcDisplayPNGCharacteristics : MetadataStatement
  • $template : TraceableTwigTemplate , CMSApplication , HtmlDocument , OpensearchUrl , TemplatestyleField , TemplateModel , HtmlView , HtmlErrorRenderer
  • $template_id : MailTemplate
  • $template_style_id : MenuItem
  • $templateCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $templateData : HtmlView
  • $templates : NamespacedTwigProfileCollector , TwigProfileCollector
  • $term : Token , SSH2
  • $terminal : Application , ProgressBar , ConsoleSectionOutput
  • $terminal_modes : SSH2
  • $terms : Query
  • $text : PaginationObject , PhpToken
  • $text_prefix : AdminController , ApiController , FormController , AdminModel , BannerController , BannersController , ClientController , ClientsController , BannerModel , CategoryModel , ArticleModel , FieldController , FieldsController , GroupController , GroupsController , FieldModel , FiltersController , MapsController , FilterModel , UpdatesitesController , OverridesController , TemplateModel , ItemModel , MenuModel , ModuleModel , NewsfeedModel , LinkModel , TaskModel , TagModel , StyleController , GroupController , GroupsController , LevelController , LevelsController , NoteController , NotesController , UserController , UsersController , StagesController , TransitionsController
  • $tfa : HtmlView
  • $themes : HtmlDumper
  • $thisChainTryAll : LazyAssertion
  • $three : Prime
  • $threshold : PasswordField
  • $thrownErrors : ErrorHandler
  • $time : FinderIndexCommand
  • $timeCollector : PDOCollector
  • $timeConverter : DefaultTimeGenerator , TimeGeneratorFactory
  • $timeDataCollector : TimeableTwigExtensionProfiler , TraceableTwigEnvironment
  • $timeGenerator : FeatureSet , UuidFactory
  • $Timelimit : SMTP
  • $timeOfLastStatusChange : MetadataTOCPayloadEntry
  • $timeout : FtpClient , Server
  • $Timeout : PHPMailer , SMTP
  • $timeout : SSH2 , PublicKeyCredentialOptions , Server
  • $timeProvider : DefaultTimeGenerator , TimeGeneratorFactory
  • $timezone : AuthenticationResponse
  • $timings : DebugMonitor
  • $title : CategoryNode , Document , FeedImage , FeedItem , FeedLink , MenuItem , Asset , Result , TaskTable , TaskOption , HtmlView
  • $to : Substitution , PHPMailer
  • $toc : HelpModel , HtmlView
  • $token : Client
  • $tokenBinding : CollectedClientData
  • $tokenBindingHandler : Server , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , Server
  • $tokenization : ANSI
  • $tokenLength : PlgUserToken
  • $tokens : CompletionInput , ArgvInput
  • $toolbarIcon : FormView , ListView
  • $toolbarTitle : FormView , ListView
  • $toStringException : ErrorHandler
  • $total : UserGroupsHelper , Pagination , HtmlView , CheckinModel , HtmlView , InstalledModel , AdaptersModel , MediaModel
  • $totalNumberOfLines : Parser
  • $totalQueries : PlgSystemDebug
  • $totalRead : StringStream
  • $totalSize : ZIPExtraction
  • $trace : FlattenException , SilencedErrorContext
  • $traceArgs : ExceptionCaster
  • $traceAsString : FlattenException
  • $tracedErrors : ErrorHandler
  • $transactionDepth : DatabaseDriver
  • $transformations : Transformations
  • $transitions : HoursField , HtmlView
  • $transitionsEnd : HoursField
  • $transitionsStart : HoursField
  • $translate : PredefinedlistField , SqlField
  • $translateDescription : FormField
  • $translateHint : FormField
  • $translateLabel : FormField
  • $transliterator : Language
  • $transliterators : AbstractUnicodeString , AsciiSlugger
  • $translitMap : Iconv
  • $transport : Http
  • $transports : PublicKeyCredentialDescriptor , PublicKeyCredentialSource
  • $tree : MenuItem
  • $trimmable : Question
  • $trueAnswerRegex : ConfirmationQuestion
  • $trustPath : AttestationStatement , PublicKeyCredentialSource
  • $ttl : FeedDocument , MemcachedHandler , RedisHandler
  • $tval : POP3
  • $twig : TraceableTwigEnvironment
  • $two : Prime , TwistedEdwards , Engine
  • $type : AuthenticationResponse , Changelog , FeedEnclosure , OpensearchImage , OpensearchUrl , AbstractRenderer , CliRenderer , HtmlRenderer , JsonapiRenderer , JsonRenderer , XmlRenderer , FeedLink , FeedPerson , AccessiblemediaField , AccesslevelField , AliastagField , AuthorField , CachehandlerField , CalendarField , CaptchaField , CategoryField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , ComboField , ComponentlayoutField , ComponentsField , ContenthistoryField , ContentlanguageField , ContenttypeField , DatabaseconnectionField , EditorField , EmailField , FileField , FilelistField , FolderlistField , FrontendlanguageField , GroupedlistField , HeadertagField , HiddenField , ImagelistField , IntegerField , LanguageField , LimitboxField , ListField , MediaField , MenuField , MenuitemField , MeterField , ModulelayoutField , ModuleorderField , ModulepositionField , ModuletagField , NoteField , NumberField , OrderingField , PasswordField , PluginsField , PluginstatusField , PredefinedlistField , RadiobasicField , RadioField , RangeField , RedirectStatusField , RegistrationdaterangeField , RulesField , SessionhandlerField , SpacerField , SqlField , StatusField , SubformField , TagField , TelephoneField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , TransitionField , UrlField , UseractiveField , UserField , UsergrouplistField , UserstateField , WorkflowComponentSectionsField , WorkflowconditionField , WorkflowstageField , FormField , JsonRenderer , LanguageField , PrefixField , InstallerAdapter , InstallerExtension , MenuItem , Microdata , AdminModel , JsonApiView , UCMBase , UCMType , DownloadSource , Update , ExtensionField , LogcreatorField , LogsdaterangeField , LogtypeField , PlugininfoField , ItemlanguageField , ItemtypeField , AssociationField , HtmlView , BannerclientField , ClicksField , ImpmadeField , ImptotalField , CategoryeditField , ComponentsCategoryField , CategoryField , ConfigComponentsField , FiltersField , ContactField , AssocField , ArticleField , VotelistField , VoteradioField , ComponentsFieldgroupField , ComponentsFieldsField , FieldcontextsField , FieldgroupsField , FieldLayoutField , SectionField , SubfieldsField , TypeField , BranchesField , ContentmapField , ContenttypesField , SearchfilterField , ExtensionstatusField , FolderField , LocationField , TypeField , WarningsModel , LanguageclientField , MenuItemByTypeField , MenuOrderingField , MenuParentField , MenuPresetField , MenutypeField , MenuField , MessageStatesField , UserMessagesField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , NewsfeedField , NewsfeedsField , PluginElementField , PluginorderingField , PluginTypeField , RequeststatusField , RequesttypeField , RedirectField , CronField , ExecutionRuleField , IntervalField , TaskStateField , TaskTypeField , ExecRuleHelper , TemplatelocationField , TemplatenameField , HtmlView , GroupparentField , LevelsField , ComponentsWorkflowField , WorkflowcontextsField , Key , DatabaseQuery , FtpClient , ConsentBoxField , FontsField , TemplatesListField , TinymcebuilderField , UploaddirsField , PrivacyField , DataField , UniqueidField , WebauthnField , TosField , TermsField , BaseAccept , Stub , AbstractSerializer , AttestationStatement , CollectedClientData , Credential , PublicKeyCredentialDescriptor , PublicKeyCredentialParameters , PublicKeyCredentialSource
  • $type_id : Adapter , Result
  • $type_title : Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $typeAlias : TagsHelper , AdminModel , Table , BannerModel , ClientModel , CategoryModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , UpdatesiteModel , TemplateModel , ItemModel , ModuleModel , NewsfeedModel , TaskModel , TaskTable , TagModel , NoteModel
  • $typeName : HtmlView
  • $types : MediaField , Microdata , HtmlView , OpenSSH , PuTTY , OpenSSH , PuTTY , OpenSSH , PuTTY
  • $typesKeyMapping : MysqliStatement , SqlsrvStatement
  • $typeSupports : HtmlView
  • $tz : Date
  • $ucmData : UCMContent
  • $uidKey : LdapUserProvider
  • $ulenMask : Iconv , Normalizer
  • $uncompressedTotal : ZIPExtraction
  • $unicodeTransCoder : AbstractPunycode , ToIdn , ToUnicode
  • $uninflected : Ruleset
  • $uniqueid : PHPMailer
  • $uniqueId : PlgSystemStats
  • $unknownState : ActionButton
  • $unsignedInt : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $update : Manifest , DatabaseQuery
  • $update_sites : CollectionAdapter
  • $updatecols : UpdateAdapter
  • $updateInfo : CheckJoomlaUpdatesCommand , UpdateCoreCommand , HtmlView
  • $updateInformation : UpdateModel
  • $updateModel : UpdateCoreCommand
  • $updateQuery : ChangeItem
  • $updates : CollectionAdapter
  • $updateSiteId : UpdateAdapter
  • $updateSiteName : UpdateAdapter
  • $upgrade : Installer
  • $uploadedFiles : ServerRequest
  • $upperLimitSearchWordCallback : Language
  • $upv : MetadataStatement
  • $urgentRequestAge : HtmlView
  • $uri : FeedLink , FeedPerson , WebAssetItem , ResolvedRoute , AbstractUri , Stream , DistantSingleMetadata
  • $uriString : Uri
  • $url : FeedEnclosure , FeedImage , PackageManifest , DownloadSource , Result , MetadataTOCPayloadEntry , StatusReport
  • $urlVar : ArticleController
  • $usages : Command
  • $use_ldapV3 : LdapClient
  • $use_request_id : SFTP
  • $use_stat_cache : SFTP
  • $useCollection : Subject
  • $used : Language
  • $usedInCollection : Subject
  • $useHtmlVarDumper : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • $useIncludePath : ClassLoader
  • $useNestingLimit : Resolver , Subject , Sanitizer
  • $useOpenHandlerWhenSendingDataHeaders : DebugBar
  • $useOpensslParse : CaBundle
  • $usePoly1305 : SymmetricKey
  • $user : AddUserCommand , DatabaseLogger , AdminModel , HtmlView , InstalledModel , HtmlView , AbstractUri , PublicKeyCredentialCreationOptions
  • $user_lang_code : PlgSystemLanguageFilter
  • $userAgent : WebClient
  • $useRefHandles : Data
  • $useRequireJs : JavascriptRenderer
  • $userFactory : Icon , Basic , Token
  • $userGroupPaths : Access
  • $userGroups : Access , AddUserCommand , AddUserToGroupCommand , RemoveUserFromGroupCommand
  • $userHandle : AuthenticatorAssertionResponse , PublicKeyCredentialSource
  • $userId : ConfigurationModel , CredentialRepository
  • $userInfo : Uri
  • $userIsSuperAdmin : HtmlView
  • $username : AuthenticationResponse , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , RemoveUserFromGroupCommand , User , LdapClient
  • $Username : PHPMailer
  • $username : POP3 , LdapUser
  • $users_dn : LdapClient
  • $userVerification : AuthenticatorSelectionCriteria , VerificationMethodDescriptor , PublicKeyCredentialRequestOptions
  • $userVerificationDetails : MetadataStatement
  • $UseSendmailOptions : PHPMailer
  • $useThreshold : Sanitizer
  • $usingGeneratedPoly1305Key : Salsa20
  • $utf : DatabaseDriver
  • $utf8mb4 : MysqlDriver , MysqliDriver
  • $uuidBuilder : UuidFactory
  • $validate : FormField
  • $validationConstraints : Configuration
  • $validationtext : FormField
  • $validator : Configuration , PHPMailer , Question
  • $validDirectives : PlgSystemHttpHeaders
  • $value : AssertionChain , InvalidArgumentException , BigDecimal , BigInteger , ByteStringObject , MapItem , AbstractString , AbstractTime , Boolean , Integer , ObjectIdentifier , OctetString , UnknownObject , IPAddress , FormField , Field , BigInteger , Basic , BaseAccept , BigInteger , Engine , Integer , Suggestion , TableCell , LazyString , Stub , TaggedValue , AuthenticationExtension
  • $valueCache : FieldModel
  • $valueField : SqlField
  • $values : DatabaseQuery , JWK , RSAKey , UpdateOperation
  • $valueSuggestions : CompletionSuggestions
  • $varDumper : DataCollector , MessagesCollector
  • $variableName : JavascriptRenderer
  • $variables : PharInvocation
  • $vars : Router , AbstractUri
  • $vendorDir : ClassLoader
  • $vendorRoots : LinkStub
  • $verb : Russian
  • $verb_suffixes : Catalan
  • $verbosity : Output
  • $verbosityLevelMap : ConsoleLogger
  • $verificationKey : Configuration
  • $verificationMethods : VerificationMethodANDCombinations
  • $version : Changelog , AtomParser , RssParser , Manifest , Update , WebAssetItem , Application , Client , PuTTY , SFTP , RequestParameters , Application , SingleCommandApplication
  • $verticalInsideBorderChar : TableStyle
  • $verticalOutsideBorderChar : TableStyle
  • $view : RouteHelper
  • $view_item : FormController , ContactController , ContactModel , ArticleController
  • $view_list : AdminController , FormController , AssociationsController , ContactController , ArticleController
  • $viewall : Pagination
  • $viewLevels : Access
  • $viewName : CategoryView , FeedView , HtmlView , FeedView , HtmlView
  • $views : RouterView , BaseController
  • $violations : RequiredConstraintsViolated
  • $votingPosition : PlgContentVote
  • $vowels : Catalan , Danish , Dutch , English , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Stem , Swedish
  • $w : Rijndael
  • $wantHelps : Application
  • $wantsHelp : Application
  • $warnings : HtmlView
  • $webAssetManager : Document
  • $webmaster : FeedDocument
  • $weight : Token
  • $when1 : Query
  • $when2 : Query
  • $where : DatabaseQuery
  • $width : FeedImage , OpensearchImage , EditorField , MediaField , Terminal , DisplayPNGCharacteristicsDescriptor
  • $wildcard : CronField
  • $window_resize : SSH2
  • $window_size : SSH2
  • $window_size_client_to_server : SSH2
  • $window_size_server_to_client : SSH2
  • $windowColumns : SSH2
  • $windowRows : SSH2
  • $word : Word , Stem
  • $wordInflector : CachedWordInflector
  • $wordmode : Query
  • $WordWrap : PHPMailer
  • $workflow : HtmlView
  • $workflowId : StageController , StagesController , TransitionController , TransitionsController
  • $workflowID : HtmlView
  • $workflows : HtmlView
  • $workflowStage : TransitionField
  • $wrappedDumper : ContextualizedDumper , ServerDumper
  • $wrapper : HtmlView
  • $writable : Stream
  • $writeCount : ProgressBar
  • $writeprefix : Stream
  • $X : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $x : PrivateKey , EC , ANSI
  • $X : EcdaaTrustAnchor
  • $xdebugLinkFormat : Debug
  • $xdebugLinkTemplate : DataCollector
  • $xdebugReplacements : DataCollector
  • $xdebugShouldUseAjax : DataCollector
  • $XMailer : PHPMailer
  • $xml : Form
  • $xmlDocument : Sanitizer
  • $xmlIssues : Sanitizer
  • $xmlLoaderValue : Sanitizer
  • $xmlOptions : Sanitizer
  • $xmlParser : Changelog , Update , UpdateAdapter
  • $xPath : Resolver
  • $xssAuto : InputFilter
  • $xy2d : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $Y : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $y : DSA , ANSI
  • $Y : EcdaaTrustAnchor
  • $years : HtmlView
  • $YminusX : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
  • $yminusx : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
  • $YminusX : ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $yminusx : ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $YplusX : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
  • $yplusx : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
  • $YplusX : ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $yplusx : ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $Z : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $zero : AsymmetricKey , Montgomery , TwistedEdwards , Engine , Integer
  • $zones : TimezoneField


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- _ -

  • _() : HTMLHelper , Language , Text , Route
  • __call() : AssertionChain , LazyAssertion , TraceableTwigEnvironment , TraceableTwigTemplate , TraceablePDO , CacheController , LegacyInstallerScript , Toolbar , ToolbarButton , WebAssetManager , DataSet , Input , Stream
  • __callStatic() : Assertion , BCMath , Assert
  • __clone() : BigInteger , BigIntegerBcmath , BigIntegerGmp , DatabaseQuery , QueryElement , Registry , Uri , BigInteger , OutputFormatter , AbstractString , UnicodeString
  • __construct() : NamePrep , AbstractPunycode , FromPunycode , PunycodeInterface , ToPunycode , ToIdn , ToUnicode , AssertionChain , InvalidArgumentException , LazyAssertionException , Attribute , BigDecimal , BigInteger , BigRational , NativeCalculator , RoundingMode , AbstractCBORObject , ByteStringObject , ByteStringWithChunkObject , Decoder , InfiniteListObject , InfiniteMapObject , ListObject , MapItem , MapObject , OtherObject , BreakObject , FalseObject , NullObject , TrueObject , UndefinedObject , SignedIntegerObject , StringStream , BigFloatTag , DecimalFractionTag , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , ClassLoader , ECDSA , Ec2Key , Key , OkpKey , RsaKey , SymmetricKey , AbstractField , CronExpression , DayOfWeekField , CryptoExceptionHandler , CacheCacheCollector , DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SlimCollector , SwiftLogCollector , SwiftMailCollector , TimeableTwigExtensionProfiler , TraceableTwigEnvironment , TraceableTwigTemplate , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , MessagesCollector , PDOCollector , TraceablePDO , TraceablePDOStatement , TracedStatement , TimeDataCollector , DataFormatter , JavascriptRenderer , OpenHandler , StandardDebugBar , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , DerivedKeys , Key , KeyOrPassword , KeyProtectedByPassword , CachedWordInflector , GenericLanguageInflectorFactory , Inflector , Language , Pattern , Patterns , Ruleset , Substitution , Substitutions , Transformation , Transformations , Word , RulesetInflector , XPath , Resolver , Subject , Usage , NestingException , Sanitizer , AbstractString , AbstractTime , AttributeTypeAndValue , RDNString , RelativeDistinguishedName , Construct , ParserException , ExplicitlyTaggedObject , BitString , BMPString , Boolean , CharacterString , GeneralizedTime , GeneralString , GraphicString , IA5String , Integer , NumericString , ObjectDescriptor , ObjectIdentifier , OctetString , PrintableString , RelativeObjectIdentifier , T61String , UniversalString , UTF8String , VisibleString , UnknownConstructedObject , UnknownObject , BigInteger , AlgorithmIdentifier , CertificateExtensions , CertificateSubject , CSR , PrivateKey , PublicKey , DNSName , IPAddress , SubjectAlternativeNames , GenericLinkProvider , Link , AbstractApplication , AbstractWebApplication , ContainerControllerResolver , ApplicationErrorEvent , ApplicationEvent , WebClient , WebApplication , Archive , Bzip2 , UnsupportedArchiveException , Gzip , Tar , Zip , AbstractUsernamePasswordAuthenticationStrategy , DatabaseStrategy , LocalStrategy , Rule , Rules , Adapter , AdapterInstance , AdministratorApplication , ApiApplication , BaseApplication , CliOutput , ColorStyle , ColorProcessor , CliApplication , CMSApplication , ConsoleApplication , DaemonApplication , SiteApplication , WebApplication , Authentication , ClassLoader , ActionButton , TransitionButton , Cache , CacheController , CacheStorage , CacheStorageHelper , FileStorage , MemcachedStorage , RedisStorage , Captcha , HttpBridgePostRequestMethod , Categories , CategoryFactory , CategoryNode , FtpClient , ComponentRecord , MissingComponentException , RouterBase , RouterFactory , RouterLegacy , RouterViewConfiguration , MenuRules , NomenuRules , StandardRules , AddUserCommand , AddUserToGroupCommand , DeleteUserCommand , ExtensionDiscoverInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , ListUserCommand , WritableContainerLoader , RemoveUserFromGroupCommand , SessionMetadataGcCommand , UpdateCoreCommand , Date , AbstractModuleDispatcher , ComponentDispatcher , ComponentDispatcherFactory , Dispatcher , LegacyComponentDispatcher , ModuleDispatcherFactory , Document , DocumentRenderer , ErrorDocument , FeedDocument , HtmlDocument , ImageDocument , JsonapiDocument , JsonDocument , OpensearchDocument , PreloadManager , RawDocument , XmlDocument , Editor , Aes , OpenSSL , Totp , Browser , AbstractEvent , AbstractImmutableEvent , BeforeBatchEvent , BeforeDisplayMethods , Callback , Captive , GetMethod , GetSetup , NotifyActionLog , SaveSetup , Validate , AjaxInitCreate , GetIconEvent , AbstractEvent , AfterDeleteEvent , AfterLoadEvent , AfterMoveEvent , AfterReorderEvent , AfterStoreEvent , BeforeBindEvent , BeforeCheckinEvent , BeforeCheckoutEvent , BeforeDeleteEvent , BeforeLoadEvent , BeforeMoveEvent , BeforePublishEvent , BeforeReorderEvent , BeforeStoreEvent , SetNewTagsEvent , DisplayEvent , AbstractEvent , WebAssetRegistryAssetChanged , AbstractEvent , WorkflowFunctionalityUsedEvent , WorkflowTransitionEvent , Component , LegacyComponent , Module , CategoryFactory , ComponentDispatcherFactory , HelperFactory , ModuleDispatcherFactory , MVCFactory , RouterFactory , FeedLink , FeedParser , FeedPerson , Patcher , Stream , InputFilter , LastvisitdaterangeField , RegistrationdaterangeField , TagField , UseractiveField , Form , FormField , HelperFactory , UserGroupsHelper , Http , Image , ImageFilter , Cli , Cookie , Files , Input , Json , InstallationApplication , InstallationController , BaseInstallationModel , LanguagesModel , JsonResponse , Installer , InstallerAdapter , InstallerExtension , LegacyInstallerScript , Manifest , Language , FileLayout , DelegatingPsrLogger , Log , LogEntry , Logger , CallbackLogger , DatabaseLogger , EchoLogger , FormattedtextLogger , InMemoryLogger , SyslogLogger , W3cLogger , MailDisabledException , MailTemplate , AbstractMenu , MenuItem , SiteMenu , Microdata , AdminController , ApiController , BaseController , FormController , MVCFactory , AdminModel , BaseDatabaseModel , BaseModel , FormModel , ListModel , AbstractView , OnGetApiFields , FormView , HtmlView , JsonApiView , JsonView , ListView , CMSObject , Pagination , PaginationObject , SitePathway , CMSPlugin , Profiler , JsonResponse , ApiRouter , RouteNotFoundException , SiteRouter , ChangeItem , ChangeSet , OnGetApiAttributes , OnGetApiRelation , JoomlaSerializer , MetadataManagerListener , MetadataManager , Session , SessionManager , JoomlaStorage , Asset , Category , Content , ContentHistory , ContentType , CoreContent , Extension , Language , Menu , MenuType , Module , Table , Ucm , Update , UpdateSite , User , Usergroup , ViewLevel , Toolbar , ToolbarButton , UCMBase , UCMContent , UCMType , Updater , User , UserFactory , LangActiveAssetItem , WebAssetItem , WebAssetManager , WebAssetRegistry , Workflow , ActionlogsController , LogsdaterangeField , ActionlogsModel , AssociationsModel , BannersController , BannersModel , ClientsModel , TracksModel , BannerTable , ClientTable , Category , CacheModel , CategoryController , DisplayController , CategoriesModel , CategoryModel , CheckinModel , ApplicationController , ComponentController , ConfigController , ModulesController , TemplatesController , Router , ContactsController , ContactsModel , Icon , ContactTable , JsonapiView , DisplayController , CategoryModel , FeaturedModel , Category , Router , ArticleController , ArticlesController , FeatureEvent , ArticleModel , ArticlesModel , FeaturedModel , FeaturedTable , JsonapiView , DisplayController , ArticlesModel , CategoryModel , Category , Router , HistoryModel , DisplayController , FieldController , GroupController , FieldModel , FieldsModel , GroupsModel , FieldTable , GroupTable , DisplayController , Adapter , Indexer , Language , El , Zh , Query , Result , Token , FiltersModel , IndexModel , MapsModel , SearchesModel , Response , FilterTable , LinkTable , MapTable , Router , ManageController , UpdatesitesController , DatabaseModel , DiscoverModel , InstallerModel , LanguagesModel , ManageModel , UpdateModel , UpdatesitesModel , UpdatesiteTable , HtmlView , InstalledModel , LanguageModel , LanguagesModel , OverridesModel , TemplateController , TemplatesModel , TemplateTable , FetchMediaItemEvent , FetchMediaItemsEvent , FetchMediaItemUrlEvent , MediaModel , MediumModel , ItemsController , ItemsModel , MenusModel , MessagesModel , MessageTable , ModuleModel , ModulesModel , PositionsModel , DisplayController , NewsfeedsModel , NewsfeedTable , JsonapiView , CategoryModel , Category , Router , PluginModel , PluginsModel , ConsentsModel , RequestsModel , ConsentTable , RequestTable , Router , LinksModel , LinkTable , ExecuteTaskEvent , ExecRuleHelper , SelectModel , TaskModel , TasksModel , TaskTable , Task , TaskOption , HtmlView , TagsModel , TagTable , TagModel , Router , TemplateController , StyleModel , StylesModel , TemplatesModel , StyleTable , CallbackController , CaptiveController , MethodController , MethodsController , UsersController , DataShapeObject , DebuggroupModel , DebuguserModel , GroupModel , GroupsModel , LevelsModel , NotesModel , UserModel , UsersModel , Encrypt , MfaTable , NoteTable , ProfileModel , RegistrationModel , Router , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , StagesModel , TransitionsModel , WorkflowsModel , StageTable , TransitionTable , WorkflowTable , Application , AbstractCommand , ApplicationDescription , ApplicationErrorEvent , BeforeCommandExecuteEvent , CommandErrorEvent , ConsoleEvent , TerminateEvent , ContainerLoader , OpenSSL , Crypt , InvalidKeyTypeException , UnsupportedCipherException , Key , DataObject , DataSet , ExportCommand , ImportCommand , DatabaseDriver , DatabaseEvents , DatabaseExporter , DatabaseImporter , DatabaseIterator , DatabaseQuery , ConnectionEvent , ConnectionFailureException , ExecutionFailureException , PrepareStatementFailureException , FetchMode , FetchOrientation , MysqlDriver , MysqliDriver , MysqliStatement , ParameterType , PdoDriver , PdoStatement , PgsqlDriver , QueryElement , SqlsrvStatement , Container , ContainerResource , AbstractEvent , DebugEventDispatcherCommand , EventImmutable , LazyServiceEventListener , Priority , FtpClient , FilesystemException , Patcher , Stream , InputFilter , AbstractTransport , UnexpectedResponseException , Http , Cookie , Files , Input , Json , LdapClient , CssMenu , Client , Joomla , Basic , Token , Versionable , LocalAdapter , CredentialRepository , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , Joomlaupdate , Cache , AbstractDataCollector , InfoCollector , ProfileCollector , QueryCollector , JavascriptRenderer , JoomlaHttpDriver , Authentication , CredentialRepository , Webauthn , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , Checkfiles , Requests , SiteStatus , Yaml , Registry , DebugRouterCommand , MethodNotAllowedException , ResolvedRoute , Route , Router , CreateSessionTableCommand , ApcuHandler , DatabaseHandler , FilesystemHandler , MemcachedHandler , RedisHandler , WincacheHandler , Session , SessionEvent , SessionEvents , SessionState , NativeStorage , AddressValidator , ForwardedValidator , AbstractUri , UriImmutable , ArrayHelper , IpHelper , AlgorithmManager , JWK , JWKSet , BigInteger , Hash , RSAKey , ECDSA , EdDSA , JWS , JWSBuilder , JWSBuilderFactory , JWSLoader , JWSLoaderFactory , JWSVerifier , JWSVerifierFactory , JWSSerializerManager , Signature , CallbackStream , InvalidStreamPointerPositionException , UploadedFileAlreadyMovedException , HeaderSecurity , PhpInputStream , RelativeStream , Request , Response , EmptyResponse , HtmlResponse , JsonResponse , RedirectResponse , TextResponse , XmlResponse , ServerRequest , Stream , UploadedFile , Uri , ConfigPostProcessor , Replacements , Builder , Basic , Factory , Configuration , Parser , Signature , Ecdsa , Key , Token , DataSet , IdentifiedBy , IssuedBy , PermittedFor , RelatedTo , SignedWith , ValidAt , ValidationData , Accept , AcceptLanguage , AcceptMatch , BaseAccept , Request , Response , ServerRequest , Stream , UploadedFile , Uri , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_ChaCha20_IetfCtx , ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_ChaCha20_IetfCtx , ParagonIE_Sodium_Core_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core_Poly1305_State , ParagonIE_Sodium_Core_SecretStream_State , PasswordHash , OAuth , PHPMailer , Blowfish , AsymmetricKey , StreamCipher , SymmetricKey , DES , DSA , EC , brainpoolP160r1 , brainpoolP160t1 , brainpoolP192r1 , brainpoolP192t1 , brainpoolP224r1 , brainpoolP224t1 , brainpoolP256r1 , brainpoolP256t1 , brainpoolP320r1 , brainpoolP320t1 , brainpoolP384r1 , brainpoolP384t1 , brainpoolP512r1 , brainpoolP512t1 , Curve25519 , Curve448 , Ed25519 , Ed448 , prime192v2 , prime192v3 , prime239v1 , prime239v2 , prime239v3 , secp112r1 , secp112r2 , secp128r1 , secp128r2 , secp160k1 , secp160r1 , secp160r2 , secp192k1 , secp192r1 , secp224k1 , secp224r1 , secp256k1 , secp256r1 , secp384r1 , secp521r1 , sect113r1 , sect113r2 , sect131r1 , sect131r2 , sect163k1 , sect163r1 , sect163r2 , sect193r1 , sect193r2 , sect233k1 , sect233r1 , sect239k1 , sect283k1 , sect283r1 , sect409k1 , sect409r1 , sect571k1 , sect571r1 , Hash , RC2 , Rijndael , RSA , TripleDES , Twofish , ANSI , Element , X509 , BigInteger , BCMath , Engine , GMP , PHP , BinaryField , Integer , PrimeField , Integer , SFTP , Stream , Agent , Identity , PlgContentVote , PlgExtensionNamespacemap , PlgSystemActionLogs , PlgSystemHttpHeaders , PlgSystemLanguageFilter , PlgSystemLogout , DefaultUuidBuilder , DegradedUuidBuilder , StringCodec , FeatureSet , CombGenerator , DefaultTimeGenerator , RandomLibAdapter , TimeGeneratorFactory , FallbackNodeProvider , FixedTimeProvider , Uuid , UuidFactory , ReCaptcha , CurlPost , Post , SocketPost , RequestParameters , Response , SplFixedArray , Application , AsCommand , GithubActionReporter , Color , Command , CompleteCommand , LazyCommand , ContainerCommandLoader , FactoryCommandLoader , Suggestion , Cursor , AddConsoleCommandPass , ApplicationDescription , ConsoleErrorEvent , ConsoleEvent , ConsoleSignalEvent , ConsoleTerminateEvent , ErrorListener , CommandNotFoundException , OutputFormatter , OutputFormatterStyle , OutputFormatterStyleStack , DescriptorHelper , Dumper , HelperSet , ProgressBar , ProgressIndicator , Table , TableCell , TableCellStyle , TableRows , TableSeparator , ArgvInput , ArrayInput , Input , InputArgument , InputDefinition , InputOption , StringInput , ConsoleLogger , ConsoleOutput , ConsoleSectionOutput , Output , StreamOutput , TrimmedBufferOutput , ChoiceQuestion , ConfirmationQuestion , Question , SignalRegistry , OutputStyle , SymfonyStyle , ApplicationTester , CommandCompletionTester , CommandTester , DebugClassLoader , ClassNotFoundError , FatalError , UndefinedFunctionError , UndefinedMethodError , ErrorHandler , HtmlErrorRenderer , SerializerErrorRenderer , SilencedErrorContext , AbstractConnection , AbstractQuery , Adapter , Collection , EntryManager , Query , UpdateOperation , Entry , Ldap , CheckLdapCredentialsListener , LdapAuthenticator , LdapBadge , LdapUser , LdapUserProvider , OptionConfigurator , AbstractString , ByteString , CodePointString , LazyString , AsciiSlugger , UnicodeString , ArgsStub , ClassStub , ConstStub , CutArrayStub , CutStub , DsPairStub , EnumStub , FrameStub , ImgStub , LinkStub , TraceStub , AbstractCloner , Data , CliDescriptor , HtmlDescriptor , ServerDumpCommand , AbstractDumper , CliDumper , RequestContextProvider , SourceContextProvider , ContextualizedDumper , HtmlDumper , ServerDumper , ThrowingCasterException , Connection , DumpServer , AddLinkHeaderListener , GenericLinkProvider , Link , LintCommand , Dumper , ParseException , TaggedValue , SubscribedService , PhpToken , Collection , Document , FallbackExceptionHandler , ResponseBag , InvalidParameterException , Parameters , Relationship , Resource , ConjunctionInterceptor , Manager , Container , Manifest , Reader , PharInvocation , StemmerManager , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationObject , AttestationObjectLoader , AttestationStatement , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AttestedCredentialData , AuthenticationExtension , ExtensionOutputError , AuthenticatorAssertionResponse , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponse , AuthenticatorAttestationResponseValidator , AuthenticatorData , AuthenticatorResponse , AuthenticatorSelectionCriteria , CollectedClientData , Credential , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , SimpleMetadataStatementRepository , SingleMetadata , PublicKeyCredential , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialEntity , PublicKeyCredentialLoader , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , Server , StringStream , TokenBinding , CertificateTrustPath , EcdaaKeyIdTrustPath , Assert , ZIPExtraction
  • __debugInfo() : ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_Curve25519_Fe , BigInteger , Engine , Integer
  • __destruct() : CryptoExceptionHandler , FtpClient , Stream , Image , FormattedtextLogger , SyslogLogger , DatabaseDriver , DatabaseIterator , PdoDriver , SqliteDriver , FtpClient , Stream , LdapClient , Stream , ParagonIE_Sodium_Core_Poly1305_State , PHPMailer , PrimeField , SSH2 , BufferingLogger , Connection , Query
  • __get() : TraceablePDO , AbstractWebApplication , WebClient , CliApplication , ConsoleApplication , ComponentRecord , Date , Feed , FeedEntry , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , ListField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , FormField , Input , InstallerAdapter , LegacyInstallerScript , AbstractMenu , BaseDatabaseModel , UCMType , CategoryeditField , Result , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , TaskOption , DataShapeObject , DataObject , DataSet , DatabaseDriver , DatabaseQuery , Response , Input , ConsentBoxField , Data
  • __invoke() : LazyServiceEventListener , ConfigProvider , ConfigPostProcessor , Dumper
  • __isset() : Result , DataShapeObject , DataObject , DataSet , Data
  • __serialize() : Result , AbstractEvent , Route , Router , Uuid
  • __set() : TraceablePDO , ComponentRecord , Feed , FeedEntry , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , FormField , LegacyInstallerScript , CategoryeditField , Result , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , DataShapeObject , DataObject , DataSet , ConsentBoxField , UriImmutable
  • __sleep() : User , PdoDriver , BigInteger , Engine , BufferingLogger , Connection , Query , AbstractString , LazyString , Stub
  • __toString() : BigDecimal , BigInteger , BigNumber , BigRational , AbstractCBORObject , ByteStringObject , ByteStringWithChunkObject , CBORObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , CronExpression , AbstractTime , ASNObject , AttributeTypeAndValue , Construct , ExplicitlyTaggedObject , GeneralizedTime , ObjectIdentifier , BigInteger , BigIntegerBcmath , BigIntegerGmp , CSR , Rule , Rules , ColorStyle , ActionButton , Date , JsonapiDocument , CMSObject , JsonResponse , DatabaseExporter , DatabaseQuery , QueryElement , QueryInterface , SqliteQuery , SqlsrvQuery , Registry , AbstractUri , UriInterface , CallbackStream , PhpInputStream , RelativeStream , Stream , Uri , Claim , Basic , Signature , Token , Stream , Uri , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , AsymmetricKey , EC , Hash , BigInteger , Engine , Integer , SSH2 , StreamInterface , UriInterface , Uuid , CompletionInput , Suggestion , TableCell , ArgvInput , ArrayInput , AbstractString , LazyString , ConstStub , Data , PhpToken , Document , PharInvocation , PublicKeyCredential
  • __unserialize() : Result , AbstractEvent , Route , Router , Uuid
  • __unset() : Result , DataObject , DataSet
  • __wakeup() : User , PdoDriver , BigInteger , Engine , SplFixedArray , BufferingLogger , Connection , Query , UnicodeString , ZIPExtraction
  • _addPath() : HtmlView
  • _autoload() : JLoader
  • _buildAdminMenus() : ComponentAdapter
  • _buildContentOrderBy() : CategoryModel
  • _buildContext() : Stream
  • _buildDataObject() : Pagination
  • _canDeleteCategories() : PlgContentJoomla
  • _canDeleteStage() : PlgContentJoomla
  • _characterData() : ExtensionAdapter , Update
  • _checkedOut() : Grid
  • _checkExpire() : FileStorage
  • _cleanIntrotext() : ArticlesCategoryHelper
  • _cleanPath() : FileStorage
  • _cloak() : PlgContentEmailcloak
  • _countItemsInCategory() : PlgContentJoomla
  • _countItemsInChildren() : PlgContentJoomla
  • _countItemsInStage() : PlgContentJoomla
  • _createFileName() : HtmlView
  • _createNavigation() : PlgContentPagebreak
  • _createTable() : BaseDatabaseModel
  • _createToc() : PlgContentPagebreak
  • _deleteFolder() : FileStorage
  • _dir_closedir() : Stream
  • _dir_opendir() : Stream
  • _dir_readdir() : Stream
  • _dir_rewinddir() : Stream
  • _displayButtons() : PlgEditorNone
  • _endElement() : CollectionAdapter , ExtensionAdapter , Update
  • _fetchFeedParser() : FeedFactory
  • _fetchTemplate() : HtmlDocument
  • _filesInFolder() : FileStorage
  • _findItem() : RouteHelper
  • _findMode() : FtpClient
  • _folders() : FileStorage
  • _fromInteger() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • _fromString() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • _getArray() : StringController
  • _getAssetName() : Category , Content , Language , MenuType , Module , Table , FieldTable , GroupTable , TaskTable , StageTable , TransitionTable , WorkflowTable
  • _getAssetParentId() : Category , Content , Language , MenuType , Module , FieldTable , GroupTable , StageTable , TransitionTable , WorkflowTable
  • _getAssetTitle() : Category , Content , Language , MenuType , Module , Table , FieldTable , GroupTable , StageTable , TransitionTable , WorkflowTable
  • _getCacheId() : CacheStorage , MemcachedStorage
  • _getCommand() : ConfirmButton , HelpButton , PopupButton , StandardButton
  • _getExtensionId() : PackageAdapter
  • _getFilename() : Stream
  • _getFilePath() : FileStorage
  • _getLastTag() : Update , UpdateAdapter
  • _getLineEnd() : Document
  • _getList() : BaseDatabaseModel , FieldsModel , GroupsModel , InstallerModel , UpdateModel , ModulesModel , PluginsModel , TasksModel
  • _getListCount() : BaseDatabaseModel , MapsModel , LanguagesModel
  • _getListQuery() : ListModel
  • _getNode() : Nested
  • _getPackageFromFolder() : InstallModel
  • _getPackageFromUpload() : InstallModel
  • _getPackageFromUrl() : InstallModel
  • _getParent() : CollectionAdapter
  • _getPattern() : PlgContentEmailcloak
  • _getStackLocation() : CollectionAdapter , Update , UpdateAdapter
  • _getStorage() : Cache
  • _getTab() : Document
  • _getTreeRepositionData() : Nested
  • _getUser() : PlgUserJoomla
  • _item_active() : Pagination
  • _item_inactive() : Pagination
  • _items() : Folder
  • _list_footer() : Pagination
  • _list_render() : Pagination
  • _load() : JLoader , Captcha , Categories , PlgContentLoadmodule
  • _loadEditor() : Editor
  • _loadid() : PlgContentLoadmodule
  • _loadmod() : PlgContentLoadmodule
  • _loadTemplate() : HtmlDocument
  • _lock() : Table
  • _logtable() : Nested
  • _makeId() : CallbackController , PageController , ViewController
  • _mapbin() : Base32
  • _mapcharset() : Base32
  • _mime_types() : PHPMailer
  • _mkdir() : Stream
  • _mode() : FtpClient
  • _noChange() : PageController
  • _parseTemplate() : HtmlDocument
  • _passive() : FtpClient
  • _prepareDocument() : HtmlView
  • _putCmd() : FtpClient
  • _relToAbs() : DocumentRenderer
  • _rename() : Stream
  • _renderTemplate() : HtmlDocument
  • _rmdir() : Stream
  • _rollback_menu() : ComponentAdapter , ModuleAdapter
  • _rollback_module() : ModuleAdapter
  • _runQuery() : Nested
  • _sendEmail() : ContactController
  • _setEtag() : PageController
  • _setPath() : HtmlView
  • _setPlatform() : Browser
  • _sortLanguages() : LanguageField
  • _startElement() : CollectionAdapter , ExtensionAdapter , Update
  • _stream_cast() : Stream
  • _stream_close() : Stream
  • _stream_eof() : Stream
  • _stream_flush() : Stream
  • _stream_lock() : Stream
  • _stream_metadata() : Stream
  • _stream_open() : Stream
  • _stream_read() : Stream
  • _stream_seek() : Stream
  • _stream_set_option() : Stream
  • _stream_stat() : Stream
  • _stream_tell() : Stream
  • _stream_truncate() : Stream
  • _stream_write() : Stream
  • _string_to_element() : ParagonIE_Sodium_Core_Ristretto255
  • _unlink() : Stream
  • _unlock() : Table
  • _unwrap() : BigIntegerBcmath , BigIntegerGmp
  • _updateMenus() : ComponentAdapter
  • _updateSiteMenus() : ComponentAdapter
  • _url_stat() : Stream
  • _verifyResponse() : FtpClient


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- a -

  • abbrClass() : HtmlErrorRenderer
  • abort() : Installer , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • ABOVE_NORMAL : Priority
  • abridge() : StringHelper
  • abs() : BigDecimal , BigInteger , BigRational , Calculator
  • ABS : FetchOrientation
  • abs() : BigInteger , BCMath , GMP , PHP
  • absoluteValue() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • ACCENTED_CHARACTERS : Inflector
  • ACCEPTABLE_EVENTS : NotifyActionLog
  • acceptFactory() : AbstractNegotiator , CharsetNegotiator , EncodingNegotiator , LanguageNegotiator , Negotiator
  • acceptValue() : InputOption
  • acquireLock() : Task
  • action() : JGrid , MessageController
  • actions() : Access
  • activate() : LinksController , LinkModel , UsersController , UserModel , RegistrationModel
  • activateStates() : Users
  • activateUser() : UserHelper
  • ACTIVE : SessionState
  • adapt() : AbstractPunycode
  • add() : BCMath , Calculator , BcMathCalculator , GmpCalculator , NativeCalculator , ByteStringWithChunkObject , InfiniteListObject , ListObject , MapObject , OtherObjectManager , TagObjectManager , TextStringWithChunkObject , ClassLoader , Manager , ManagerFactory , SwiftLogCollector , BigInteger , BigIntegerBcmath , BigIntegerGmp , WritableContainerLoader , WritableLoaderInterface , Patcher , Log , Mail , ApiController , FormController , WebAssetRegistry , WebAssetRegistryInterface , ArticleController , MediaController , ItemController , ItemsController , ModuleController , ListenersPriorityQueue , Patcher , LdapClient , AlgorithmManager , AlgorithmManagerFactory , BigInteger , JWSSerializerManager , JWSSerializerManagerFactory , ParagonIE_Sodium_Compat , BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer , Application , EntryManagerInterface , EntryManager , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , ExtensionOutputCheckerHandler , PublicKeyCredentialDescriptorCollection
  • add364() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • add64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • addActiveMethod() : MethodDescriptor
  • addAddress() : PHPMailer
  • addAlgorithm() : Server
  • addAllCategoriesMenuItem() : PlgSampledataMultilang
  • addAllowedTypes() : OptionsResolver
  • addAllowedValues() : OptionsResolver
  • addAnAddress() : PHPMailer
  • addArgument() : AbstractCommand , Event , Command , LazyCommand , ArrayInput , InputDefinition
  • addArguments() : InputDefinition
  • addArticle() : PlgSampledataMultilang
  • addAssets() : JavascriptRenderer
  • addAssociations() : PlgSampledataMultilang
  • addAttachment() : Mail , MailTemplate , PHPMailer
  • addAttribute() : Attributes , OnGetApiAttributes
  • addAttributes() : OnGetApiAttributes , ReflectionCaster
  • addAttributeValues() : EntryManager
  • addBaseName() : PharInvocationResolver
  • addBcc() : Mail
  • addBCC() : PHPMailer
  • addBlogMenuItem() : PlgSampledataMultilang
  • addBranch() : Taxonomy
  • addButtonPath() : Toolbar
  • addCache() : CacheCacheCollector
  • addCasters() : AbstractCloner
  • addCategory() : Feed , FeedEntry , PlgSampledataMultilang
  • addCc() : Mail
  • addCC() : PHPMailer
  • addChild() : Construct , NodeInterface
  • addChildren() : Construct
  • addClassMap() : ClassLoader
  • addClientInfo() : ApplicationHelper
  • addCollector() : AggregatedCollector , DebugBar
  • addColumn() : ArrayHelper
  • addCommand() : Application
  • addCommands() : Application
  • addCommonWords() : PlgExtensionFinder
  • addConnection() : PDOCollector
  • addContent() : ConsoleSectionOutput
  • addContentType() : Helper
  • addContextEntry() : Stream
  • addContributor() : Feed , FeedEntry
  • addControl() : JavascriptRenderer
  • addCountableRule() : Inflector
  • addCustomHeader() : PHPMailer
  • addCustomItem() : ActionsDropdown , Dropdown
  • addCustomTag() : HtmlDocument
  • addCustomTypes() : HtmlView
  • addDashboardMenu() : InstallerScript
  • addDebugMessage() : BaseLayout
  • addDirectory() : SysinfoModel
  • addDomainName() : SubjectAlternativeNames
  • addElementToGhost() : HtmlErrorRenderer
  • addEmbeddedImage() : PHPMailer
  • addEntry() : Feed , Sidebar , Logger , CallbackLogger , DatabaseLogger , EchoLogger , FormattedtextLogger , InMemoryLogger , MessagequeueLogger , SyslogLogger
  • addEvent() : Dispatcher
  • addException() : ExceptionsCollector
  • addExecutedStatement() : TraceablePDO
  • addExtension() : TraceableTwigEnvironment , CertificateExtensions
  • addExtensionRegistryFile() : WebAssetRegistry
  • addExtra() : ReflectionCaster
  • addFavicon() : HtmlDocument
  • addFeed() : CategoryView
  • addField() : Item
  • addFieldPath() : Form , FormHelper
  • addFieldPrefix() : FormHelper
  • addFields() : OnGetApiFields
  • addFile() : Patcher
  • addFileFormat() : AsymmetricKey
  • addFileToBuffer() : HTMLHelper
  • addFilter() : TraceableTwigEnvironment , Sidebar
  • addFilterPath() : Form , FormHelper
  • addFilterPrefix() : FormHelper
  • addFormatMap() : ApiApplication
  • addFormPath() : Form , FormHelper
  • addFormPrefix() : FormHelper
  • addFunction() : TraceableTwigEnvironment
  • addGlobal() : TraceableTwigEnvironment
  • addHandler() : ChainedHandler
  • addHeadLink() : HtmlDocument
  • addHelper() : PHP
  • addHelperPath() : HtmlView
  • addImage() : OpensearchDocument
  • addIncludePath() : Cache , CacheController , CacheStorage , HTMLHelper , FileLayout , BaseModel , Table
  • addIncludePaths() : FileLayout
  • addInline() : WebAssetManager
  • addInlineAssets() : JavascriptRenderer
  • addInstruction() : Result
  • addInt32() : ParagonIE_Sodium_Core32_Int32
  • addInt64() : ParagonIE_Sodium_Core32_Int64
  • addIP() : SubjectAlternativeNames
  • addItem() : FeedDocument , Pathway , Domain
  • ADDITIONAL_INFORMATION : ByteStringWithChunkObject , InfiniteListObject , InfiniteMapObject , TextStringWithChunkObject
  • additionalFailureDescription() : CommandIsSuccessful
  • addLayout() : RouterViewConfiguration
  • addLink() : JsonapiDocument , FeedEntry
  • addListener() : Dispatcher , DispatcherInterface
  • addLog() : ActionlogModel
  • addLogEntry() : Log
  • addLogger() : MonologCollector , Log
  • addLoggerInternal() : Log
  • addLongOption() : ArgvInput , ArrayInput
  • addMap() : Taxonomy , ReflectionCaster
  • addMeasure() : TimeDataCollector , ProfileCollector
  • addMenuGroup() : PlgSampledataMultilang
  • addMenuItems() : PlgSampledataBlog
  • addMessage() : MessagesCollector
  • addMeta() : JsonapiDocument
  • addModelPath() : BaseController
  • addModule() : DisplayController
  • addModuleInModuleMenu() : PlgSampledataMultilang
  • addModuleLanguageSwitcher() : PlgSampledataMultilang
  • addModuleMenu() : PlgSampledataMultilang
  • addMonitor() : ChainedMonitor
  • addNestedNode() : Taxonomy
  • addNestedTaxonomy() : Result
  • addNew() : ToolbarHelper
  • addNode() : Form , Taxonomy
  • addNodeVisitor() : TraceableTwigEnvironment
  • addNormalizer() : OptionsResolver
  • addNote() : Users
  • addOption() : ListField , AbstractCommand , Command , LazyCommand , InputDefinition
  • addOptions() : TaskOptions , InputDefinition
  • addOrEnqueueAnAddress() : PHPMailer
  • addPath() : FormHelper , BaseController
  • addPluraliseRule() : Inflector
  • addPoint() : Binary , Prime , Ed25519 , Ed448
  • addPostInstallationMessage() : MessagesModel
  • addPredefinedStyles() : ColorProcessor
  • addPrefix() : FormHelper
  • addPreset() : MenusHelper
  • addPsr4() : ClassLoader
  • addrAppend() : PHPMailer
  • addRecipient() : Mail , MailTemplate
  • addRegistryFile() : WebAssetRegistry
  • addRelations() : OnGetApiFields
  • addRenderedTemplate() : TraceableTwigEnvironment
  • addReplyTo() : Mail , PHPMailer
  • addResult() : ResultAwareInterface
  • addReverseLookupUrl() : MenutypesModel
  • addrFormat() : PHPMailer
  • addRoute() : Router , RouterInterface
  • addRoutes() : Router , RouterInterface
  • addRow() : Table
  • addRows() : Table
  • addRule() : Inflector
  • addRulePath() : Form , FormHelper
  • addRulePrefix() : FormHelper
  • addScript() : Document
  • addScriptDeclaration() : Document
  • addScriptOptions() : Document
  • addService() : SimpleMetadataStatementRepository
  • addShortcuts() : Shortcut
  • addShortOption() : ArgvInput , ArrayInput
  • addSignature() : JWS , JWSBuilder
  • addSingleStatement() : SimpleMetadataStatementRepository
  • addSingulariseRule() : Inflector
  • addSlide() : Bootstrap
  • addState() : ActionButton
  • addStrategy() : Authentication
  • addStringAttachment() : PHPMailer
  • addStringEmbeddedImage() : PHPMailer
  • addStyle() : ColorProcessor
  • addStyleDeclaration() : Document
  • addStyleSheet() : Document
  • addSubjectAlternativeNames() : CertificateExtensions
  • addSubmenu() : ContentHelper
  • addSubscriber() : Dispatcher , DispatcherInterface
  • addTab() : Bootstrap , UiTab
  • addTagMapping() : TagsHelper
  • addTaxonomy() : Result
  • addTemplateData() : MailTemplate
  • addTemplatePath() : HtmlView
  • addTemplateRegistryFile() : WebAssetRegistry
  • addTest() : TraceableTwigEnvironment
  • addThrowable() : ExceptionsCollector
  • addTokenParser() : TraceableTwigEnvironment
  • addToolbar() : FormView , ListView , HtmlView
  • addToZipFile() : Zip
  • addUpdateSite() : PlgExtensionJoomla
  • addUrl() : OpensearchDocument
  • addUsage() : Command , LazyCommand
  • addUse() : Subject
  • addUsedIn() : Subject
  • addUserAuthProviderColumn() : JoomlaInstallerScript
  • addUserToGroup() : UserHelper
  • addValidator() : Session
  • addViewPath() : BaseController
  • addWord() : Inflector
  • addXmlChild() : XmlView
  • admin_language() : Users
  • advance() : ProgressBar , ProgressIndicator
  • aead_chacha20poly1305_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • AESTestVector() : Crypto , RuntimeTests
  • after() : AbstractString
  • AFTER_EXECUTE : ApplicationEvents
  • AFTER_RESPOND : ApplicationEvents
  • afterDelete() : MfaTable
  • afterLast() : AbstractString
  • afterSessionStart() : WebApplication , InstallationApplication
  • aggregate() : MessagesCollector
  • ajax_upload() : InstallController
  • ajaxchosen() : FormBehavior
  • ajaxfield() : Tag
  • AK_STATE_DATA : ZIPExtraction
  • AK_STATE_DATAREAD : ZIPExtraction
  • AK_STATE_DONE : ZIPExtraction
  • AK_STATE_FINISHED : ZIPExtraction
  • AK_STATE_HEADER : ZIPExtraction
  • AK_STATE_INITIALIZE : ZIPExtraction
  • AK_STATE_NOFILE : ZIPExtraction
  • AK_STATE_POSTPROC : ZIPExtraction
  • alert() : PropelCollector , Bootstrap
  • ALERT : Log
  • alert() : AbstractLogger , LoggerInterface
  • ALERT : LogLevel
  • alg() : Key
  • ALG : Key
  • ALG_KEY_COSE : MetadataStatement
  • ALG_KEY_ECC_X962_DER : MetadataStatement
  • ALG_KEY_ECC_X962_RAW : MetadataStatement
  • ALG_KEY_RSA_2048_DER : MetadataStatement
  • ALG_KEY_RSA_2048_RAW : MetadataStatement
  • ALG_SIGN_ED25519_EDDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSA_EMSA_PKCS1_SHA256_DER : MetadataStatement
  • ALG_SIGN_RSA_EMSA_PKCS1_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA1_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA384_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA512_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA256_DER : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA384_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA512_RAW : MetadataStatement
  • ALG_SIGN_SECP256K1_ECDSA_SHA256_DER : MetadataStatement
  • ALG_SIGN_SECP256K1_ECDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_SECP256R1_ECDSA_SHA256_DER : MetadataStatement
  • ALG_SIGN_SECP256R1_ECDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_SECP384R1_ECDSA_SHA384_RAW : MetadataStatement
  • ALG_SIGN_SECP521R1_ECDSA_SHA512_RAW : MetadataStatement
  • ALG_SIGN_SM2_SM3_RAW : MetadataStatement
  • ALGORITHM : DH , DSA , EC , RSA
  • alias() : DatabaseQuery , QueryInterface , Container
  • aliases() : AlgorithmManagerFactory
  • ALIASES : ConsoleEvents
  • ALIGN_MAP : TableCellStyle
  • all() : AssertionChain , Manager , ManagerFactory
  • ALL : Log
  • all() : JoomlaStorage , Router , RouterInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • ALL : UriInterface
  • all() : AlgorithmManagerFactory , JWK , JWKSet , JWSSerializerManagerFactory , DataSet
  • ALL : RegisteredClaims
  • all() : Application , CollectedClientData
  • allow() : Rule , Rules
  • allowAdd() : ApiController , FormController , AssociationsHelper , BannerController , CategoryController , ContactController , ArticleController , FieldController , GroupController , TemplateController , MediaController , ItemController , NewsfeedController , TagController , StageController , TransitionController , WorkflowController
  • allowAll() : AbstractString
  • allowAllLetters() : AbstractString
  • allowCache() : AbstractWebApplication , WebApplicationInterface
  • allowCapitalLetters() : AbstractString
  • allowCharacter() : AbstractString
  • allowCharacters() : AbstractString
  • allowCustom() : TagField
  • allowDelete() : MediaController
  • ALLOWED_GLOBALS : Input
  • ALLOWED_STREAM_RESOURCE_TYPES : Stream
  • allowEdit() : ApiController , FormController , AssociationsHelper , BannerController , CategoryController , ContactController , ArticleController , FieldController , GroupController , MediaController , ItemController , ModuleController , NewsfeedController , TaskController , TagController , TemplateController , GroupController , LevelController , UserController , StageController , TransitionController , WorkflowController
  • allowedKeyTypes() : Algorithm , ECDSA , EdDSA , HMAC , None , RSA , RSAPKCS1 , RSAPSS
  • allowedTypes() : OptionConfigurator
  • allowedValues() : OptionConfigurator
  • allowNumbers() : AbstractString
  • allowSave() : FormController , MessageController , ModuleController , GroupController , LevelController
  • allowSmallLetters() : AbstractString
  • allowSpaces() : AbstractString
  • alnum() : Assertion , Assert
  • alpha() : Assert
  • ALPHABET : Calculator
  • ALPHABET_ALPHANUMERIC : ByteString
  • alt() : Text
  • alterDbCharacterSet() : DatabaseDriver , SqliteDriver
  • alternativeExists() : PHPMailer
  • alterSiteStatus() : SiteStatus
  • AMAYA : WebClient
  • AMHARIC_LANGUAGE_CODE : ASCII
  • ampReplace() : OutputFilter
  • ampReplaceCallback() : OutputFilter
  • AMQP_EX_TYPE_FANOUT : AmqpCaster
  • AMQP_PASSIVE : AmqpCaster
  • and() : BigInteger , Calculator , GmpCalculator
  • ANDROID : WebClient
  • ANDROIDTABLET : WebClient
  • andWhere() : DatabaseQuery
  • anonymous_bind() : LdapClient
  • ANY_MAP : ASN1
  • API_FEATURE_INFO : ConnectionOptions
  • API_INFO : ConnectionOptions
  • append() : ByteStringWithChunkObject , InfiniteMapObject , TextStringWithChunkObject , FtpClient , File , QueryElement , Registry , AbstractString , ByteString , CodePointString , UnicodeString
  • append_log() : SSH2
  • appendBody() : AbstractWebApplication , WebApplicationInterface
  • appendButton() : Toolbar
  • appendDocument() : XmlDescriptor
  • appendFilter() : Stream
  • appendPrimaryKeys() : Table
  • appendRow() : Table
  • appendString() : ANSI
  • APPLICATION_ERROR : ConsoleEvents
  • apply() : Patcher , ToolbarHelper , Patcher , Color , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • applyAliasFor() : JLoader
  • applyCanonicalOrdering() : NamePrep
  • applyCharacterMaps() : NamePrep
  • applyContextToStream() : Stream
  • applyCurrentStyle() : OutputFormatter
  • applyHashesToCspRule() : PlgSystemHttpHeaders
  • applyHunk() : Patcher
  • applyOperations() : EntryManager
  • applyUpdateSite() : UpdateModel
  • applyVariant() : BinaryUtils
  • applyVersion() : BinaryUtils
  • appStateSupportsCaching() : Cache
  • ARABIC_LANGUAGE_CODE : ASCII
  • archive() : ActionsDropdown , Dropdown , MessageController
  • archiveList() : ToolbarHelper
  • archiveMessage() : MessagesModel
  • areExceptionsCaught() : Application
  • areVendorsIncluded() : JavascriptRenderer
  • ARMENIAN_LANGUAGE_CODE : ASCII
  • ARRAY_ASSOC : Stub
  • ARRAY_INDEXED : Stub
  • array_intersect_first() : SSH2
  • array_repeat() : PHP
  • arrayExpected() : InvalidTokenStructure
  • arrayFromObject() : ArrayHelper
  • arraySearch() : ArrayHelper
  • arrayUnique() : ArrayHelper
  • asArray() : DataShapeObject , Registry
  • ascii() : AbstractUnicodeString
  • ASCII : AbstractUnicodeString
  • ask() : QuestionHelper , StyleInterface , SymfonyStyle
  • askHidden() : StyleInterface , SymfonyStyle
  • askQuestion() : SymfonyStyle
  • ASN1_BIG_INTEGER_LIMIT : ECSignature , MultibyteStringConverter
  • ASN1_INTEGER : ECSignature , MultibyteStringConverter
  • ASN1_LENGTH_2BYTES : ECSignature , MultibyteStringConverter
  • ASN1_MAX_SINGLE_BYTE : ECSignature , MultibyteStringConverter
  • ASN1_NEGATIVE_INTEGER : ECSignature , MultibyteStringConverter
  • ASN1_SEQUENCE : ECSignature , MultibyteStringConverter
  • asn1map() : ASN1
  • asPEM() : Ec2Key
  • asPem() : RsaKey
  • asPrivateKey() : PublicKey
  • assert() : Constraint , IdentifiedBy , IssuedBy , PermittedFor , RelatedTo , SignedWith , ValidAt , Validator , Assertable , Behavior , ConjunctionInterceptor , PharExtensionInterceptor , PharMetaDataInterceptor , Manager , PharStreamWrapper
  • ASSERT_INTERNAL_INVOCATION : PharInvocationResolver
  • assertAssertionCompleteness() : Behavior
  • assertAssertions() : ConjunctionInterceptor
  • assertCanDelete() : MethodController
  • assertCanEdit() : MethodController
  • assertCommand() : Behavior
  • assertCommands() : Behavior
  • assertExpiration() : ValidAt
  • assertIssueTime() : ValidAt
  • assertLoggedInUser() : MethodController , MethodsController
  • assertMinimumTime() : ValidAt
  • assertTypeId() : TemplateParser
  • assertUniqueBaseName() : PharInvocationCollection
  • assertUniqueInvocation() : PharInvocationCollection
  • assertValid() : HeaderSecurity
  • assertValidName() : HeaderSecurity
  • ASSET_STATE_ACTIVE : WebAssetManager
  • ASSET_STATE_DEPENDENCY : WebAssetManager
  • ASSET_STATE_INACTIVE : WebAssetManager
  • assetExists() : WebAssetManager
  • assetgrouplist() : Access
  • assetgroups() : Access
  • assign() : ToolbarHelper
  • association() : AdministratorService , Menus , AdministratorService
  • ASSOCIATIVE : FetchMode
  • asXml() : DatabaseExporter , DatabaseImporter
  • attach() : CallbackStream , Stream
  • attachAll() : PHPMailer
  • attachBuildRule() : Router
  • ATTACHMENT_HINT_BLUETOOTH : MetadataStatement
  • ATTACHMENT_HINT_EXTERNAL : MetadataStatement
  • ATTACHMENT_HINT_INTERNAL : MetadataStatement
  • ATTACHMENT_HINT_NETWORK : MetadataStatement
  • ATTACHMENT_HINT_NFC : MetadataStatement
  • ATTACHMENT_HINT_READY : MetadataStatement
  • ATTACHMENT_HINT_WIFI_DIRECT : MetadataStatement
  • ATTACHMENT_HINT_WIRED : MetadataStatement
  • ATTACHMENT_HINT_WIRELESS : MetadataStatement
  • attachmentExists() : PHPMailer
  • attachParseRule() : Router
  • attachRule() : RouterView
  • attachRules() : RouterView
  • attachTaskOptions() : TasksModel
  • ATTESTATION_ATTCA : MetadataStatement
  • ATTESTATION_BASIC_FULL : MetadataStatement
  • ATTESTATION_BASIC_SURROGATE : MetadataStatement
  • ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT : PublicKeyCredentialCreationOptions
  • ATTESTATION_CONVEYANCE_PREFERENCE_INDIRECT : PublicKeyCredentialCreationOptions
  • ATTESTATION_CONVEYANCE_PREFERENCE_NONE : PublicKeyCredentialCreationOptions
  • ATTESTATION_ECDAA : MetadataStatement
  • ATTESTATION_KEY_COMPROMISE : AuthenticatorStatus
  • attestedCredentialToPublicKeyCredentialSource() : CredentialRepository
  • ATTR_ALL : X509
  • ATTR_APPEND : X509
  • ATTR_REPLACE : X509
  • AUDIENCE : RegisteredClaims
  • auth() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • auth_verify() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • authenticate() : AuthenticationStrategyInterface , DatabaseStrategy , LocalStrategy , Authentication , Client , SMTP , LdapAuthenticator
  • AUTHENTICATION_INFO : Crypto
  • AUTHENTICATION_INFO_STRING : Core
  • AUTHENTICATOR_ATTACHMENT_CROSS_PLATFORM : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_ATTACHMENT_PLATFORM : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_TRANSPORT_BLE : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_INTERNAL : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_NFC : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_USB : PublicKeyCredentialDescriptor
  • authorise() : SiteApplication , Authentication , AbstractMenu , User , Client , POP3
  • AUTHORITY_INFORMATION_ACCESS : OID
  • AUTHORITY_REVOCATION_LIST : OID
  • autocomplete() : QuestionHelper
  • autoPrependBlock() : SymfonyStyle
  • autoPrependText() : SymfonyStyle
  • AVAILABLE_OPTIONS : Color
  • AZERBAIJANI_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- b -

  • back() : ToolbarHelper
  • backupDatabase() : DatabaseModel
  • bad_algorithm_candidate() : SSH2
  • base : AbstractPunycode , Uri
  • BASE : PHP32 , PHP64
  • base16Decode() : RFC4648
  • base16Encode() : RFC4648
  • base256_lshift() : Engine
  • base256ToBase2() : BinaryField
  • base2ToBase256() : BinaryField
  • base32Decode() : Encoding , RFC4648
  • base32DecodeUpper() : Encoding
  • base32Encode() : Encoding , RFC4648
  • base32EncodeUpper() : Encoding
  • base32HexDecode() : Encoding , RFC4648
  • base32HexDecodeUpper() : Encoding
  • base32HexEncode() : Encoding , RFC4648
  • base32HexEncodeUpper() : Encoding
  • base64() : Assertion
  • BASE64_VARIANT_ORIGINAL : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_ORIGINAL_NO_PADDING : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_URLSAFE : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_URLSAFE_NO_PADDING : ParagonIE_Sodium_Compat
  • base64Decode() : Encoding , RFC4648
  • base64DecodeDotSlash() : Encoding
  • base64DecodeDotSlashOrdered() : Encoding
  • base64Encode() : Encoding , RFC4648
  • base64Encoded() : InMemory
  • base64EncodeDotSlash() : Encoding
  • base64EncodeDotSlashOrdered() : Encoding
  • base64EncodeWrapMB() : PHPMailer
  • base64UrlDecode() : Decoder
  • base64UrlEncode() : Encoder
  • base64UrlSafeDecode() : RFC4648
  • base64UrlSafeEncode() : RFC4648
  • BASE_FULL : PHP32 , PHP64
  • BASE_IV : Key
  • baseFileContainsPharExtension() : PharExtensionInterceptor
  • baseFileDoesNotHaveMetaDataIssues() : PharMetaDataInterceptor
  • baseSquare() : PHP
  • baseString() : Client
  • batch() : FormController , AdminModel , BannerController , FieldController , GroupController , IndexerController , ModuleController , NewsfeedController , LinksController , TagController , UserController , UserModel
  • batchAccess() : AdminModel
  • batchCopy() : AdminModel , CategoryModel , FieldModel , ItemModel , ModuleModel
  • batchFlipordering() : CategoryModel
  • batchLanguage() : AdminModel
  • batchMove() : AdminModel , CategoryModel , ArticleModel , FieldModel , ItemModel , ModuleModel
  • batchOptions() : Modules
  • batchProcess() : LinksModel
  • batchReset() : UserModel
  • batchTag() : AdminModel
  • batchUser() : ContactModel , UserModel
  • before() : AbstractString
  • BEFORE_COMMAND_EXECUTE : ConsoleEvents
  • BEFORE_EXECUTE : ApplicationEvents
  • BEFORE_RESPOND : ApplicationEvents
  • beforeLast() : AbstractString
  • beginTransaction() : TraceablePDO
  • BELARUSIAN_LANGUAGE_CODE : ASCII
  • BELOW_NORMAL : Priority
  • BENGALI_LANGUAGE_CODE : ASCII
  • bestLinkForUri() : AtomParser
  • between() : Assertion , BigInteger , BCMath , GMP , PHP32 , PHP64
  • betweenExclusive() : Assertion
  • betweenLength() : Assertion
  • bin2bits() : Strings
  • bin2hex() : ParagonIE_Sodium_Compat
  • bin2str() : Base32
  • bind() : Form , Category , Content , Menu , Module , Table , TableInterface , User , ViewLevel , User , BannerTable , FieldTable , GroupTable , TaskTable , StyleTable , StageTable , TransitionTable , WorkflowTable , DataObject , DatabaseQuery , PreparableInterface , LdapClient , CompletionInput , Input , InputInterface , ConnectionInterface , Connection , Ldap , LdapInterface
  • bindArray() : DatabaseQuery , QueryInterface
  • bindColumn() : TraceablePDOStatement
  • bindData() : Registry
  • bindLevel() : Form
  • bindParam() : TraceablePDOStatement , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • bindValue() : TraceablePDOStatement , SqlsrvStatement
  • bindValues() : MysqliStatement
  • binStringLength() : ZIPExtraction
  • binToBigInteger() : Utils
  • binToHex() : Encoding
  • binToInt() : Utils
  • bits2bin() : Strings
  • bits2int() : AsymmetricKey
  • bits2octets() : AsymmetricKey
  • BITSTRING : Identifier
  • bitwise() : Calculator
  • bitwise_and() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwise_leftRotate() : BigInteger , Engine
  • bitwise_leftShift() : BigInteger , BCMath , GMP , PHP
  • bitwise_not() : BigInteger , Engine
  • bitwise_or() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwise_rightRotate() : BigInteger , Engine
  • bitwise_rightShift() : BigInteger , BCMath , GMP , PHP
  • bitwise_small_split() : PHP
  • bitwise_split() : BigInteger , Engine , PHP
  • bitwise_xor() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwiseAndHelper() : Engine
  • bitwiseOrHelper() : Engine
  • bitwiseXorHelper() : Engine
  • BLACKBERRY : WebClient
  • blind() : PrivateKey
  • BLINK : WebClient
  • block() : UserModel , SymfonyStyle
  • BLOCK_BYTE_SIZE : Core
  • BLOCK_SCALAR_HEADER_PATTERN : Parser
  • BLOCK_SIZE : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • BLOCKBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • blockStates() : Users
  • BMP_STRING : Identifier
  • boolean() : Assertion
  • BOOLEAN : Identifier
  • boolean() : PhpSetting
  • BOOLEAN : ParameterType
  • boolean() : Assert
  • booleanlist() : Select
  • boot() : BootableExtensionInterface , AdminComponent , BannersComponent , CategoriesComponent , ContactComponent , ContentComponent , FinderComponent , InstallerComponent , LanguagesComponent , MenusComponent , MessagesComponent , ModulesComponent , NewsfeedsComponent , PrivacyComponent , RedirectComponent , SchedulerComponent , TemplatesComponent , UsersComponent
  • bootComponent() : ExtensionManagerInterface , BaseDatabaseModel
  • bootModule() : ExtensionManagerInterface
  • bootPlugin() : ExtensionManagerInterface
  • BORDER_INSIDE : Table
  • BORDER_OUTSIDE : Table
  • box() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_beforenm() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_BEFORENMBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_PUBLICKEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_SECRETKEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_SEEDBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_decrypt() : ParagonIE_Sodium_File
  • box_encrypt() : ParagonIE_Sodium_File
  • box_keypair() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_open() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_publickey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_publickey_from_secretkey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_secretkey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_seed_keypair() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • branchLanguageTitle() : LanguageHelper
  • branchPlural() : LanguageHelper
  • branchSingular() : LanguageHelper
  • BRIGHT_COLORS : Color
  • BUFFER_BYTE_SIZE : Core
  • BUFFER_SIZE : ParagonIE_Sodium_File
  • build() : GenericLanguageInflectorFactory , LanguageInflectorFactory , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , InstallationRouter , AdministratorRouter , Router , DefaultUuidBuilder , DegradedUuidBuilder , UuidBuilderInterface
  • buildBase() : SiteRouter
  • buildCheckQuery() : ChangeItem , MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • buildCodec() : FeatureSet
  • buildComponentPreprocess() : SiteRouter
  • buildContactExtendedData() : ContactModel
  • buildDateRange() : ActionlogsModel , UsersModel
  • builder() : Configuration
  • buildExecutionRules() : TaskModel
  • buildFormat() : SiteRouter
  • buildInit() : SiteRouter
  • buildLine() : ProgressBar
  • buildLookup() : MenuRules
  • buildMessage() : RequiredConstraintsViolated
  • buildNodeProvider() : FeatureSet
  • buildNumberConverter() : FeatureSet
  • buildObject() : Container
  • buildPaginationData() : SiteRouter
  • buildParametersString() : BaseAccept
  • buildQuery() : Uri , AbstractUri
  • buildRandomGenerator() : FeatureSet
  • buildRegexAndVarList() : Route
  • buildRelationships() : Resource
  • buildResources() : Collection
  • buildRewrite() : SiteRouter
  • buildRule() : PlgSystemLanguageFilter
  • buildRuleset() : Inflector
  • buildSefRoute() : SiteRouter
  • buildSession() : Session
  • buildSharedObject() : Container
  • buildTimeConverter() : FeatureSet
  • buildTimeGenerator() : FeatureSet
  • buildUri() : MetadataService
  • buildUuidBuilder() : FeatureSet
  • buildVotingQuery() : QueryHelper
  • buildXml() : DatabaseExporter , MysqlExporter , MysqliExporter , PgsqlExporter
  • buildXmlData() : DatabaseExporter , PgsqlExporter
  • buildXmlStructure() : DatabaseExporter , MysqlExporter , MysqliExporter , PgsqlExporter
  • BUILTIN_RETURN_TYPES : DebugClassLoader
  • BULGARIAN_LANGUAGE_CODE : ASCII
  • button() : Bootstrap , Icons
  • buttons() : Icons
  • BYTE_SIZE : ECSignature , MultibyteStringConverter
  • byteLength() : AbstractPunycode , TranscodeUnicode
  • bytes() : Number
  • bytesAt() : AbstractString , ByteString


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- c -

  • caDirUsable() : CaBundle
  • caFileUsable() : CaBundle
  • calculateColumnsWidth() : Table
  • calculateContentLength() : AbstractString , ASNObject , Construct , ExplicitlyTaggedObject , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , UTCTime , UnknownConstructedObject , UnknownObject , IPAddress , SubjectAlternativeNames
  • calculateNumberOfColumns() : Table
  • calculateOrderOfActiveAssets() : WebAssetManager
  • calculateRowCount() : Table
  • calculateTime() : BigNumberTimeConverter , DegradedTimeConverter , PhpTimeConverter , TimeConverterInterface
  • calculateTotalWidthForOptions() : TextDescriptor
  • calendar() : Date , HTMLHelper , PlgUserProfile
  • calendartranslation() : Behavior
  • CALG_RSA_KEYX : MSBLOB
  • CALG_RSA_SIGN : MSBLOB
  • call() : HTMLHelper , DatabaseQuery , QueryInterface , ErrorHandler
  • callback() : CallbackController
  • callOnScript() : LegacyInstallerScript
  • callSearchFunction() : Query
  • camel() : AbstractString , AbstractUnicodeString , ByteString
  • camelize() : Inflector
  • CAN_FAIL_MARKER : Installer
  • CAN_FAIL_MARKER_LENGTH : Installer
  • canAddEditMethod() : Mfa
  • cancel() : FormController , ToolbarHelper , AssociationController , CategoryController , ApplicationController , ComponentController , ConfigController , DisplayController , ModulesController , TemplatesController , ContactController , OverrideController , ItemController , ConfigController , ModuleController , TaskController , TemplateController , MailController , UserController , ProfileController
  • canCheckinItem() : AssociationsHelper
  • canChmod() : Path
  • canCreateCategory() : BannerModel , ContactModel , ArticleModel , NewsfeedModel
  • canDelete() : AdminModel , BannerModel , ClientModel , CategoryModel , ContactModel , ArticleModel , HistoryModel , FieldModel , GroupModel , IndexModel , MapsModel , TemplateModel , ItemModel , MenuModel , NewsfeedModel , LinkModel , TaskModel , TagModel , LevelModel , StageModel , TransitionModel , WorkflowModel
  • canDeleteMethod() : Mfa
  • canDeleteState() : ContentHelper
  • canEditFieldValue() : FieldsHelper
  • canEditState() : AdminModel , BannerModel , ClientModel , CategoryModel , ContactModel , ArticleModel , FieldModel , GroupModel , IndexModel , MapsModel , ItemModel , MenuModel , ModuleModel , NewsfeedModel , StageModel , TransitionModel , WorkflowModel
  • canFlushFileCache() : File
  • canKeyBeUsedFor() : JWKSet
  • canKeyBeUsedWithAlgorithm() : JWKSet
  • cannotBeParsed() : InvalidKeyProvided
  • canOnlyBeUsedAfter() : Builder
  • canOnlyBeUsedBy() : Builder
  • canSave() : ItemModel
  • canTransition() : RequestController
  • canUninstallPackageChild() : InstallerAdapter
  • canUpload() : MediaHelper , TemplateHelper
  • canView() : DisplayController
  • capitalize() : Inflector
  • captive() : UpdateController
  • captiveFileExists() : UpdateModel
  • captiveLogin() : UpdateModel
  • captureVar() : DebugBarVarDumper
  • carousel() : Bootstrap
  • CASE_FOLD : Grapheme , Mbstring
  • castArrayIterator() : SplCaster
  • castArrayObject() : SplCaster
  • castAs() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • castAsChar() : DatabaseQuery , PdoQuery , PgsqlQuery
  • castAttr() : DOMCaster
  • castAttribute() : ReflectionCaster
  • castBrokerMetadata() : RdKafkaCaster
  • castChannel() : AmqpCaster
  • castCharacterData() : DOMCaster
  • castClass() : ReflectionCaster
  • castClassConstant() : ReflectionCaster
  • castClosure() : ReflectionCaster
  • castCollection() : DsCaster
  • castCollectionMetadata() : RdKafkaCaster
  • castCommonProxy() : DoctrineCaster
  • castConf() : RdKafkaCaster
  • castConnection() : AmqpCaster
  • castCurl() : ResourceCaster
  • castCutArray() : StubCaster
  • castDateTime() : DateCaster
  • castDba() : ResourceCaster
  • castDocument() : DOMCaster
  • castDocumentType() : DOMCaster
  • castDomError() : DOMCaster
  • castDoublyLinkedList() : SplCaster
  • castElement() : DOMCaster
  • castEntity() : DOMCaster
  • castEnum() : StubCaster
  • castEnvelope() : AmqpCaster
  • castError() : ExceptionCaster , IntlCaster
  • castErrorException() : ExceptionCaster
  • castException() : DOMCaster , ExceptionCaster
  • castExchange() : AmqpCaster
  • castExtension() : ReflectionCaster
  • castFiber() : FiberCaster
  • castFileInfo() : SplCaster
  • castFileObject() : SplCaster
  • castFrameStub() : ExceptionCaster
  • castFunctionAbstract() : ReflectionCaster
  • castGd() : ResourceCaster
  • castGenerator() : ReflectionCaster
  • castGmp() : GmpCaster
  • castHeap() : SplCaster
  • castHttpClient() : SymfonyCaster
  • castHttpClientResponse() : SymfonyCaster
  • castImage() : ImagineCaster
  • castImplementation() : DOMCaster
  • castInterval() : DateCaster
  • castIntlCalendar() : IntlCaster
  • castIntlDateFormatter() : IntlCaster
  • castIntlTimeZone() : IntlCaster
  • castKafkaConsumer() : RdKafkaCaster
  • castLargeObject() : PgSqlCaster
  • castLength() : DOMCaster
  • castLink() : PgSqlCaster
  • castLocator() : DOMCaster
  • castMap() : DsCaster
  • castMemcached() : MemcachedCaster
  • castMessage() : RdKafkaCaster
  • castMessageFormatter() : IntlCaster
  • castMethod() : ReflectionCaster
  • castMysqliDriver() : MysqliCaster
  • castMysqlLink() : ResourceCaster
  • castNameSpaceNode() : DOMCaster
  • castNode() : DOMCaster
  • castNotation() : DOMCaster
  • castNumberFormatter() : IntlCaster
  • castObject() : Caster , AbstractCloner
  • castObjectStorage() : SplCaster
  • castOpensslX509() : ResourceCaster
  • castOrmProxy() : DoctrineCaster
  • castOuterIterator() : SplCaster
  • castPair() : DsCaster
  • castPairStub() : DsCaster
  • castParameter() : ReflectionCaster
  • castPartitionMetadata() : RdKafkaCaster
  • castPdo() : PdoCaster
  • castPdoStatement() : PdoCaster
  • castPeriod() : DateCaster
  • castPersistentCollection() : DoctrineCaster
  • castPhpIncompleteClass() : Caster
  • castProcess() : ResourceCaster
  • castProcessingInstruction() : DOMCaster
  • castProperty() : ReflectionCaster
  • castProxy() : ProxyManagerCaster
  • castQueue() : AmqpCaster
  • castRamseyUuid() : UuidCaster
  • castRdKafka() : RdKafkaCaster
  • castRedis() : RedisCaster
  • castRedisArray() : RedisCaster
  • castRedisCluster() : RedisCaster
  • castReference() : ReflectionCaster
  • castReflectionGenerator() : ReflectionCaster
  • castRequest() : SymfonyCaster
  • castResource() : AbstractCloner
  • castResult() : PgSqlCaster
  • castSilencedErrorContext() : ExceptionCaster
  • castSplArray() : SplCaster
  • castStream() : ResourceCaster
  • castStreamContext() : ResourceCaster
  • castStub() : StubCaster
  • castText() : DOMCaster
  • castThrowingCasterException() : ExceptionCaster
  • castTimeZone() : DateCaster
  • castTopic() : RdKafkaCaster
  • castTopicConf() : RdKafkaCaster
  • castTopicMetadata() : RdKafkaCaster
  • castTopicPartition() : RdKafkaCaster
  • castTraceStub() : ExceptionCaster
  • castType() : ReflectionCaster
  • castTypeinfo() : DOMCaster
  • castUlid() : SymfonyCaster
  • castUuid() : SymfonyCaster
  • castWeakReference() : SplCaster
  • castXml() : XmlResourceCaster
  • castXmlReader() : XmlReaderCaster
  • castXPath() : DOMCaster
  • castZendExtension() : ReflectionCaster
  • catchWarning() : POP3
  • categories() : Category
  • category() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • categoryAccessChange() : Adapter
  • categoryStateChange() : Adapter
  • caution() : StyleInterface , SymfonyStyle
  • CEILING : RoundingMode
  • CERT_EXT_AUTHORITY_KEY_IDENTIFIER : OID
  • CERT_EXT_BASIC_CONSTRAINTS : OID
  • CERT_EXT_CERT_ISSUER : OID
  • CERT_EXT_CERT_POLICIES : OID
  • CERT_EXT_CRL_DISTRIBUTION_POINTS : OID
  • CERT_EXT_CRL_NUMBER : OID
  • CERT_EXT_DELTA_CRL_INDICATOR : OID
  • CERT_EXT_EXTENDED_KEY_USAGE : OID
  • CERT_EXT_INVALIDITY_DATE : OID
  • CERT_EXT_ISSUER_ALT_NAME : OID
  • CERT_EXT_ISSUING_DIST_POINT : OID
  • CERT_EXT_KEY_USAGE : OID
  • CERT_EXT_NAME_CONSTRAINTS : OID
  • CERT_EXT_PRIVATE_KEY_USAGE_PERIOD : OID
  • CERT_EXT_REASON_CODE : OID
  • CERT_EXT_SUBJECT_ALT_NAME : OID
  • CERT_EXT_SUBJECT_DIRECTORY_ATTR : OID
  • CERT_EXT_SUBJECT_KEY_IDENTIFIER : OID
  • change() : Adapter
  • changeBlock() : UsersController
  • changeIdentity() : DaemonApplication
  • changePassword() : KeyProtectedByPassword
  • CHANNEL : SFTP
  • CHANNEL_AGENT_FORWARD : SSH2
  • CHANNEL_EXEC : SSH2
  • CHANNEL_KEEP_ALIVE : SSH2
  • CHANNEL_SHELL : SSH2
  • CHANNEL_SUBSYSTEM : SSH2
  • CHAR_SUB_DELIMS : Uri
  • CHAR_UNRESERVED : Uri
  • CHARACTER_STRING : Identifier
  • characterData() : Changelog
  • charLength() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • charNotInAlphabet() : NumberFormatException
  • charsArray() : ASCII
  • CHARSET_ASCII : PHPMailer
  • CHARSET_ISO88591 : PHPMailer
  • CHARSET_UTF8 : PHPMailer
  • chdir() : FtpClient , SFTP
  • check() : Access , Path , ChangeItem , ChangeSet , Asset , Category , Content , ContentType , CoreContent , Extension , Language , Menu , MenuType , Module , Nested , Table , TableInterface , Update , UpdateSite , User , Usergroup , ViewLevel , BannerTable , ClientTable , ContactTable , FieldTable , GroupTable , FilterTable , MapTable , MenuTable , MessageTable , NewsfeedTable , LinkTable , TaskTable , TagTable , StyleTable , NoteTable , StageTable , WorkflowTable , DatabaseExporter , DatabaseImporter , MysqlExporter , MysqlImporter , MysqliExporter , MysqliImporter , PgsqlExporter , PgsqlImporter , Path , CssMenu , ExtensionOutputChecker , ExtensionOutputCheckerHandler , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , IgnoreTokenBindingHandler , TokenBindingHandler , TokenBindingNotSupportedHandler
  • checkAbsenceOfAllApplicationsTag() : AndroidKeyAttestationStatementSupport
  • checkAccess() : ComponentDispatcher , Dispatcher
  • checkall() : Grid
  • checkAnnotations() : DebugClassLoader
  • checkAnswer() : Captcha
  • checkAttestationMedata() : CertificateToolbox
  • checkAttribute() : InputFilter
  • checkB64AndCriticalHeader() : JWSBuilder
  • checkBuffer() : PlgSystemSef
  • checkCase() : DebugClassLoader
  • checkCategoryAccess() : Adapter
  • checkCategoryId() : AdminModel
  • checkCertificate() : FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • checkCertificateAndGetPublicKey() : AndroidKeyAttestationStatementSupport
  • checkCertificatesValidity() : CertificateToolbox
  • checkCertInfo() : TPMAttestationStatementSupport
  • checkChain() : CertificateToolbox
  • checkClass() : DebugClassLoader
  • checkClasses() : DebugClassLoader
  • checkCode() : Totp
  • checkCompatibility() : UpdateModel
  • checkConnectionAlive() : AbstractWebApplication
  • checkConstraint() : Validator
  • checkContent() : MailHelper , ApiController , MediaController , LocalAdapter
  • checkDb() : SetConfigurationCommand
  • checkDbServerParameters() : DatabaseHelper
  • checkDefault() : MysqlChangeItem
  • checkDefaultValue() : FieldModel
  • checkDuplicatedHeaderParameters() : JWSBuilder
  • checkEditId() : BaseController
  • checkedOut() : Grid
  • checkedout() : JGrid
  • checkExistingExtension() : ModuleAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • checkExtensionInFilesystem() : ComponentAdapter , LibraryAdapter , PackageAdapter , InstallerAdapter
  • checkExtensions() : DiscoverModel
  • checKey() : Hmac
  • checkFileExtension() : MediaHelper
  • checkFileOrder() : HTMLHelper
  • checkForm() : SetupModel
  • checkFormat() : TemplateModel
  • checkGoogleApiResponse() : AndroidSafetyNetAttestationStatementSupport
  • checkGroup() : Access
  • checkGroup1() : Russian
  • checkHeadersSent() : AbstractWebApplication
  • checkIfCoreExtension() : ExtensionHelper
  • checkIfPayloadIsEncoded() : JWSBuilder
  • checkIfRehashNeeded() : Argon2idHandler , Argon2iHandler , BCryptHandler , ChainedHandler , CheckIfRehashNeededHandlerInterface , MD5Handler , PHPassHandler
  • checkImages() : Checkfiles
  • checkin() : Dropdown , AdminController , AdminModel , FormModel
  • checkIn() : Table
  • checkin() : ToolbarHelper , AssociationsController , CheckinModel , FormModel , GroupsController
  • checkInstance() : Integer
  • checkIPv6CIDR() : IpHelper
  • checkItemAccess() : Adapter
  • checkKey() : ECDSA , EdDSA , None , RSA , RSAPKCS1 , RSAPSS
  • checkKeyAlgorithm() : KeyChecker
  • checkKeyUsage() : KeyChecker
  • checkLoggable() : Joomla
  • checkMenuItemBeforeSave() : PlgContentJoomla
  • checkMimeType() : MediaHelper
  • checkNewName() : TemplateModel
  • checkNull() : MysqlChangeItem
  • checkOperation() : KeyChecker
  • checkout() : AdminModel , FormModel
  • checkOut() : Table
  • checkout() : FormModel
  • checkParameters() : TracedStatement
  • CheckPassword() : PasswordHash
  • checkPayload() : JWSVerifier
  • checkPayloadEncoding() : JSONGeneralSerializer
  • checkPubArea() : TPMAttestationStatementSupport
  • checkRemoteDbHost() : DatabaseHelper
  • checkResetLimit() : ResetModel
  • checkResponse() : POP3
  • checkSession() : CMSApplication
  • checkSessionRecordExists() : MetadataManager
  • checkString() : AbstractString
  • CHECKSUM_BYTE_SIZE : Encoding
  • CHECKSUM_HASH_ALGO : Encoding
  • checkSuperUserInUsers() : UserHelper
  • checkTestingSampledata() : ConfigurationModel
  • checkToken() : SessionAwareWebApplicationInterface , BaseController , Session
  • checkType() : OpenSSH
  • checkUniquePublicKey() : TPMAttestationStatementSupport
  • checkUsage() : KeyChecker
  • checkUserRequireReset() : CMSApplication
  • checkValidToken() : JSONController
  • checkValue() : PlgFieldsMedia
  • checkZipData() : Zip
  • checkZipFile() : ImportCommand
  • chgrp() : SFTP
  • child() : TemplateModel
  • CHINESE_LANGUAGE_CODE : ASCII
  • chmod() : FtpClient , Stream , FtpClient , Stream , SFTP
  • choice() : Assertion , StyleInterface , SymfonyStyle
  • choicesNotEmpty() : Assertion
  • chown() : SFTP
  • CHROME : WebClient
  • chunk() : AbstractString , ByteString , CodePointString , UnicodeString
  • CHUNK_SIZE : ZIPExtraction
  • cidExists() : PHPMailer
  • CIPHER : Crypto
  • CIPHER_METHOD : Core
  • CIPHER_MODE : Crypto
  • claims() : Token
  • clamp() : ParagonIE_Sodium_Core_Curve25519
  • CLASS_APPLICATION : Identifier , ASN1
  • CLASS_CONTEXT_SPECIFIC : Identifier , ASN1
  • CLASS_PRIVATE : Identifier , ASN1
  • CLASS_UNIVERSAL : Identifier , ASN1
  • classExists() : Assertion , ClassNotFoundErrorEnhancer , Assert
  • classify() : Inflector
  • clean() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Path , InputFilter , AssociationsController , AssociationsModel , CacheModel , Path , InputFilter , ASCII
  • cleanAddress() : MailHelper
  • cleanAlnum() : InputFilter
  • cleanAssetKey() : Access
  • cleanAttributes() : InputFilter
  • cleanAttributesOnWhitelist() : Sanitizer
  • cleanBase64() : InputFilter
  • cleanBody() : MailHelper
  • cleanBool() : InputFilter
  • cleanBoolean() : InputFilter
  • cleanCache() : CategoryModel , ArticleModel , FieldModel , GroupModel , FilterModel , LanguageModel , LanguagesModel , ItemModel , MenuModel , ModuleModel , PluginModel , RequestModel , StyleModel
  • cleanCmd() : InputFilter
  • cleanDiscoveredExtension() : Installer
  • cleanDouble() : InputFilter
  • cleanFloat() : InputFilter
  • cleanHrefs() : Sanitizer
  • cleanHtml() : InputFilter
  • cleanImageURL() : HTMLHelper
  • cleanInt() : InputFilter
  • cleanInteger() : InputFilter
  • cleanLine() : MailHelper
  • cleanlist() : CacheModel
  • cleanLogs() : BufferingLogger
  • cleanModuleList() : ModuleHelper
  • cleanOptionsChildrenByFather() : GroupparentField
  • cleanPath() : InputFilter , AbstractUri
  • cleanPrivateData() : SysinfoModel
  • cleanSectionPrivateData() : SysinfoModel
  • cleanString() : InputFilter
  • cleanSubject() : MailHelper
  • cleanTags() : InputFilter
  • cleanText() : MailHelper , OutputFilter
  • cleanTrace() : ErrorHandler
  • cleanTrim() : InputFilter
  • cleanUint() : InputFilter
  • cleanUp() : BigNumber , UpdateModel
  • cleanup() : TemplateModel , Table , Parser
  • cleanupAttributes() : Collection
  • cleanupCache() : Integer
  • cleanupInstall() : InstallerHelper
  • cleanupPostBatchCopy() : AdminModel , ArticleModel
  • cleanupValues() : FieldModel
  • cleanUsername() : InputFilter
  • cleanWord() : InputFilter
  • cleanXlinkHrefs() : Sanitizer
  • clear() : MessagesCollector , OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , Session , JoomlaStorage , DataSet , DatabaseQuery , QueryInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , ProgressBar , ConsoleSectionOutput , OptionsResolver
  • clearAccessRights() : User
  • clearAddresses() : PHPMailer
  • clearAllRecipients() : PHPMailer
  • clearArguments() : Event
  • clearAttachments() : Mail , PHPMailer
  • clearBCCs() : PHPMailer
  • clearCache() : TraceableTwigTemplate
  • clearCacheFiles() : TraceableTwigEnvironment
  • clearCacheGroups() : PlgSystemActionLogs , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemStats , PlgSystemUpdatenotification
  • clearCCs() : PHPMailer
  • clearCustomHeaders() : PHPMailer
  • clearDebugMessages() : BaseLayout
  • clearEvents() : Dispatcher
  • clearFieldsCache() : FieldsHelper
  • clearHeaders() : AbstractWebApplication , WebApplicationInterface
  • clearIncludePaths() : FileLayout
  • clearInternalAndGetAffectedElements() : Subject
  • clearLine() : Cursor
  • clearLineAfter() : Cursor
  • clearListeners() : Dispatcher , DispatcherInterface
  • clearOutput() : Cursor
  • clearQueuedAddresses() : PHPMailer
  • clearReplyTos() : PHPMailer
  • clearScreen() : Cursor
  • clearStatCache() : SFTP
  • clearStatics() : Access
  • clearStatsCache() : JoomlaInstallerScript
  • clearTagsHelper() : TaggableTableInterface
  • clearTemplateCache() : TraceableTwigEnvironment
  • click() : BannerModel
  • clicks() : BannerTable
  • CLIENT_CONTROLS : ConnectionOptions
  • client_send() : SMTP
  • clientlist() : Banner
  • clients() : Banner , Languages
  • cloak() : Email
  • cloneInputStream() : QuestionHelper
  • cloneVar() : AbstractCloner , ClonerInterface
  • close() : AbstractApplication , ApplicationInterface , Stream , JoomlaStorage , TemplateController , Stream , LdapClient , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , CallbackStream , RelativeStream , Stream , SMTP , StreamInterface , Curl , StringStream
  • close_channel() : SSH2
  • close_handle() : SFTP
  • closeCursor() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • CLOSED : SessionState
  • cmov() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • cmp() : Calculator
  • CODE_LENGTH : Email
  • CODENAME : Version
  • codePointsAt() : AbstractUnicodeString , CodePointString
  • collapse() : Bootstrap
  • collapseWhitespace() : AbstractString
  • collect() : DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , DataCollectorInterface , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , RequestDataCollector , TimeDataCollector , DebugBar , Resolver , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector , Collectable , PharInvocationCollection
  • collectInvocation() : PharStreamWrapper
  • collectLogs() : PlgSystemDebug
  • collectPDO() : PDOCollector
  • collectUrlsEnabled() : RedirectHelper
  • COLORS : Color , DebugFormatterHelper
  • COLUMN : FetchMode
  • columns() : DatabaseQuery , QueryInterface
  • combine() : NamePrep
  • combineCodePoints() : NamePrep
  • combobox() : Behavior
  • COMMAND : ConsoleEvents
  • COMMAND_DIR_OPENDIR : Behavior
  • COMMAND_ERROR : ConsoleEvents
  • COMMAND_MKDIR : Behavior
  • COMMAND_RENAME : Behavior
  • COMMAND_RMDIR : Behavior
  • COMMAND_STEAM_METADATA : Behavior
  • COMMAND_STREAM_OPEN : Behavior
  • COMMAND_UNLINK : Behavior
  • COMMAND_URL_STAT : Behavior
  • commandShouldRun() : ConsoleCommandEvent
  • comment() : SymfonyStyle
  • commit() : TraceablePDO
  • COMMON_NAME : OID
  • commonCategoryDisplay() : CategoryView
  • comp() : BCMath
  • comparator() : SFTP
  • compare() : BigInteger , BigIntegerBcmath , BigIntegerGmp , LdapClient , BigInteger , AcceptMatch , ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Util , BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer
  • compareHelper() : PHP
  • compareLanguages() : LanguagesModel , PlgSampledataMultilang
  • compareTo() : BigDecimal , BigInteger , BigNumber , BigRational , Uuid , UuidInterface
  • compareUpdateVersion() : DatabaseModel
  • compile() : TraceableTwigEnvironment
  • compileSource() : TraceableTwigEnvironment
  • complete() : Application , Command , DumpCompletionCommand , HelpCommand , LazyCommand , ListCommand , CommandCompletionTester , ServerDumpCommand , LintCommand
  • compliant() : StringHelper
  • compress() : AbstractWebApplication , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • COMPRESSION_MODES : RedisCaster
  • computeAlternatives() : TraceableTwigEnvironment
  • computeData() : NamespacedTwigProfileCollector , TwigProfileCollector
  • computek() : AsymmetricKey
  • computeKey() : Hash
  • computeKeyIdentifier() : X509
  • computeLength() : LengthCalculator
  • computeSecret() : DH
  • concatenate() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • CONDITION_ARCHIVED : Workflow , ContentComponent
  • CONDITION_NAMES : Workflow , ContentComponent
  • CONDITION_PUBLISHED : Workflow , ContentComponent
  • CONDITION_TRASHED : Workflow , ContentComponent
  • CONDITION_UNPUBLISHED : Workflow , ContentComponent
  • CONFIG_GET_GROUP_NOT_FOUND : GetConfigurationCommand
  • CONFIG_GET_OPTION_FAILED : GetConfigurationCommand
  • CONFIG_GET_OPTION_NOT_FOUND : GetConfigurationCommand
  • CONFIG_GET_SUCCESSFUL : GetConfigurationCommand
  • CONFIG_OPTIONS_WRONG : SetConfigurationCommand
  • CONFIG_SET_FAILED : SetConfigurationCommand
  • CONFIG_SET_SUCCESSFUL : SetConfigurationCommand
  • CONFIG_VALIDATION_FAILED : SetConfigurationCommand
  • configure() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , CleanCacheCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , AbstractGroupButton , AbstractCommand , HelpCommand , ListCommand , ExportCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand , Command , CompleteCommand , DumpCompletionCommand , HelpCommand , ListCommand , ServerDumpCommand , LintCommand
  • configureClaim() : Builder
  • configureIO() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , Application
  • configureOptions() : AbstractConnection , Connection
  • configureSessionHandlerOptions() : SessionFactory
  • configureTaskGetterOptions() : TaskModel
  • configureTaskRunnerOptions() : Scheduler
  • confirm() : StyleInterface , SymfonyStyle , PharInvocation
  • connect() : FtpClient , SocketTransport , DatabaseLogger , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver , FtpClient , Socket , LdapClient , POP3 , SMTP , SSH2 , Connection
  • connected() : DatabaseInterface , MysqliDriver , PdoDriver , SMTP
  • constructError() : FallbackExceptionHandler
  • consumeWhitespaces() : Parser
  • contactItems() : JoomlaInstallerScript
  • contains() : Assertion , Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Assert
  • containsAny() : AbstractString
  • containsFractionalSecondsElement() : GeneralizedTime
  • containsPlugin() : PluginController
  • content() : Microdata
  • CONTENT_TYPE_MULTIPART_ALTERNATIVE : PHPMailer
  • CONTENT_TYPE_MULTIPART_MIXED : PHPMailer
  • CONTENT_TYPE_MULTIPART_RELATED : PHPMailer
  • CONTENT_TYPE_PLAINTEXT : PHPMailer
  • CONTENT_TYPE_TEXT_CALENDAR : PHPMailer
  • CONTENT_TYPE_TEXT_HTML : PHPMailer
  • contents() : Key
  • context() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • controlPagedResult() : Query
  • controlPagedResultResponse() : Query
  • convert() : AbstractIdnaConvert , EncodingHelperInterface , FromUtf8 , ToUtf8 , IdnaConvertInterface , FromPunycode , ToPunycode , ToIdn , ToUnicode , TranscodeUnicode , TranscodeUnicodeInterface , ASN1
  • convert_int_to_char_for_ctype() : Ctype
  • convertAllDERToPEM() : CertificateToolbox
  • convertBase64StringToBigInteger() : RSAKey
  • convertCertificatesToPem() : AndroidSafetyNetAttestationStatementSupport , TPMAttestationStatementSupport
  • convertDERToPEM() : CertificateToolbox
  • convertEmailAddress() : AbstractIdnaConvert , IdnaConvertInterface
  • convertFetchMode() : PdoStatement
  • convertFileToClass() : ClassNotFoundErrorEnhancer
  • convertHexColorToAnsi() : Color
  • convertInteger() : Base
  • convertIntegerToOctetString() : PSSRSA , RSA
  • convertItems() : Builder , Parser
  • convertKeyOpsToKeyUse() : JWKSet
  • convertLiterals() : AbstractField
  • convertLogLevel() : PropelCollector
  • convertParameterType() : PdoStatement
  • convertPathsToNames() : TagsHelper
  • convertPrivateKeyToPEM() : ECKey
  • convertPublicKeyToPEM() : ECKey
  • convertRelationshipsToArray() : Resource
  • convertRelativeToAbsoluteUrls() : MailHelper
  • convertTablesToUtf8mb4() : JoomlaInstallerScript
  • convertToAffine() : Base , Binary , Montgomery , Prime , TwistedEdwards
  • convertToDataSet() : Token
  • convertToDate() : Builder
  • convertToInternal() : Base , Binary , Montgomery , Prime , Ed25519 , Ed448
  • convertToObj() : PHP
  • convertToPEM() : ECKey
  • convertToRelativePath() : HTMLHelper
  • convertUrl() : AbstractIdnaConvert , IdnaConvertInterface
  • convertUtf8mb4QueryToUtf8() : MysqlDriver , MysqliDriver , UTF8MB4SupportInterface
  • convertWithLibraries() : FromUtf8 , ToUtf8
  • copy() : File , Folder , Stream , AdapterInterface , ApiModel , TemplateModel , File , Folder , Stream , LocalAdapter
  • copyBaseFiles() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • copyFile() : TemplateModel , LocalAdapter
  • copyFiles() : Installer
  • copyFileTo() : UpdateCoreCommand
  • copyFolder() : LocalAdapter
  • copyManifest() : Installer
  • COPYRIGHT : Version
  • copyRow() : Table
  • copyStyles() : TemplateModel
  • core() : Behavior
  • CORE_H2C_SHA256 : ParagonIE_Sodium_Core_Ristretto255
  • CORE_H2C_SHA512 : ParagonIE_Sodium_Core_Ristretto255
  • core_salsa20() : ParagonIE_Sodium_Core_Salsa20
  • COSE_ALGORITHM_A128GCM : Algorithms
  • COSE_ALGORITHM_A128KW : Algorithms
  • COSE_ALGORITHM_A192GCM : Algorithms
  • COSE_ALGORITHM_A192KW : Algorithms
  • COSE_ALGORITHM_A256GCM : Algorithms
  • COSE_ALGORITHM_A256KW : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_128_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_128_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_64_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_64_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_128_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_128_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_64_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_64_256 : Algorithms
  • COSE_ALGORITHM_AES_MAC_128_128 : Algorithms
  • COSE_ALGORITHM_AES_MAC_128_64 : Algorithms
  • COSE_ALGORITHM_AES_MAC_256_128 : Algorithms
  • COSE_ALGORITHM_AES_MAC_256_64 : Algorithms
  • COSE_ALGORITHM_CHACHA20_POLY1305 : Algorithms
  • COSE_ALGORITHM_DIRECT : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_AES_128 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_AES_256 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_SHA_256 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_SHA_512 : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A128KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A192KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A256KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_HKDF_256 : Algorithms
  • COSE_ALGORITHM_ECDH_ES_HKDF_512 : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A128KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A192KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A256KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_HKDF_256 : Algorithms
  • COSE_ALGORITHM_ECDH_SS_HKDF_512 : Algorithms
  • COSE_ALGORITHM_ED256 : Algorithms
  • COSE_ALGORITHM_ED512 : Algorithms
  • COSE_ALGORITHM_EdDSA : Algorithms
  • COSE_ALGORITHM_ES256 : Algorithms
  • COSE_ALGORITHM_ES256K : Algorithms
  • COSE_ALGORITHM_ES384 : Algorithms
  • COSE_ALGORITHM_ES512 : Algorithms
  • COSE_ALGORITHM_HS256 : Algorithms
  • COSE_ALGORITHM_HS256_64 : Algorithms
  • COSE_ALGORITHM_HS384 : Algorithms
  • COSE_ALGORITHM_HS512 : Algorithms
  • COSE_ALGORITHM_MAP : Algorithms
  • COSE_ALGORITHM_PS256 : Algorithms
  • COSE_ALGORITHM_PS384 : Algorithms
  • COSE_ALGORITHM_PS512 : Algorithms
  • COSE_ALGORITHM_RS1 : Algorithms
  • COSE_ALGORITHM_RS256 : Algorithms
  • COSE_ALGORITHM_RS384 : Algorithms
  • COSE_ALGORITHM_RS512 : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP_256 : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP_512 : Algorithms
  • COSE_HASH_MAP : Algorithms
  • count() : Assertion , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , Construct , Feed , UserGroupsHelper , DataObject , DataSet , DatabaseIterator , AbstractEvent , ListenersPriorityQueue , Input , Registry , JWKSet , SplFixedArray , Collection , OptionsResolver , Data , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , PublicKeyCredentialDescriptorCollection , Assert
  • countBetween() : Assert
  • counterReset() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • countEvents() : Dispatcher
  • countFiles() : MediaHelper
  • countItems() : CategoryServiceInterface , LegacyComponent , CategoriesModel , ContentComponent , NewsfeedsHelper , TagsModel , WorkflowsModel
  • countItemsByMonth() : ArticlesModel
  • countListeners() : Dispatcher , DispatcherInterface
  • countMenuChildren() : HtmlDocument
  • countModules() : HtmlDocument
  • countRelations() : ContentHelper
  • COUNTRY_NAME : OID
  • countSignatures() : JWS
  • countTagItems() : LegacyComponent , TagServiceInterface , ContentComponent , NewsfeedsHelper
  • countUse() : Subject
  • countUsedIn() : Subject
  • CR : AbstractSerializer
  • create() : BigNumber , DoublePrecisionFloatObject , HalfPrecisionFloatObject , SimpleObject , SinglePrecisionFloatObject , SignedIntegerObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , EpochTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , UnsignedIntegerObject , ManagerFactory , InflectorFactory , Identifier , BigInteger , JHtmlIcon , JNamespacePsr4Map , Zip , FtpClient , AbstractEvent , Folder , Icon , FtpClient , Folder , LdapClient , AlgorithmManagerFactory , JWSBuilder , JWSBuilderFactory , JWSLoaderFactory , JWSVerifierFactory , JWSSerializerManagerFactory , Factory , LeewayCannotBeNegative , Stream , FlattenException , Ldap , StemmerFactory , DistantSingleMetadataFactory , MetadataServiceFactory
  • createAdapterReadRoutes() : PlgWebservicesMedia
  • createAppendAutoloader() : Autoloader
  • createAsset() : WebAssetRegistry
  • createAsseticCollection() : JavascriptRenderer
  • createAssociation() : Workflow
  • createAttCA() : AttestationStatement
  • createAuthenticatedToken() : LdapAuthenticator
  • createBasic() : Factory , AttestationStatement
  • createBigInteger() : SignedIntegerObject , UnsignedIntegerObject
  • createBlock() : SymfonyStyle
  • createBody() : HtmlResponse , TextResponse , XmlResponse , PHPMailer
  • createBodyFromJson() : JsonResponse
  • createButton() : ToolbarFactoryInterface
  • createCacheController() : CacheControllerFactory , CacheControllerFactoryInterface
  • createCategory() : CategoryFactory , CategoryFactoryInterface , CategoriesHelper
  • createChild() : Toolbar , Container
  • createCompletionInput() : CompleteCommand
  • createConfig() : Factory
  • createConfiguration() : ConfigurationModel
  • createContainer() : Factory
  • createContentHistoryRoutes() : PlgWebservicesBanners , PlgWebservicesContact , PlgWebservicesContent
  • createContentLanguage() : LanguageAdapter
  • createController() : LegacyFactory , MVCFactory , MVCFactoryInterface
  • createCRUDRoutes() : ApiRouter
  • createCSRSequence() : CSR
  • createCustomFieldsDomain() : PrivacyPlugin
  • createDatabase() : DatabaseModel , DatabaseDriver , DatabaseInterface , SqliteDriver
  • createDatabaseTable() : DatabaseHandler
  • createDb() : DatabaseModel
  • createDbo() : Factory
  • createdBy() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • createDelegatedLogger() : Log
  • createDirectory() : ZIPExtraction
  • createDispatcher() : ComponentDispatcherFactory , ComponentDispatcherFactoryInterface , ModuleDispatcherFactory , ModuleDispatcherFactoryInterface
  • createDocument() : FactoryInterface , Factory
  • createDomain() : PrivacyPlugin
  • createDummyModule() : ModuleHelper
  • createEcdaa() : AttestationStatement
  • createECKey() : ECKey
  • createECKeyUsingOpenSSL() : ECKey
  • createEqualsTo() : Factory
  • createException() : Assertion
  • createExtensionRoot() : ComponentAdapter , PackageAdapter , PluginAdapter , InstallerAdapter
  • createFactory() : Inflector
  • createFieldsRoutes() : PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesUsers
  • createFile() : AdapterInterface , ApiModel , TemplateController , TemplateModel , LocalAdapter
  • createFileName() : BaseController
  • createFolder() : AdapterInterface , ApiModel , TemplateModel , LocalAdapter
  • createForLanguage() : InflectorFactory
  • createForm() : FormFactory , FormFactoryInterface
  • createFormArray() : TokenBinding
  • createFormJson() : CollectedClientData
  • createFromArray() : AttestationStatement , AttestedCredentialData , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , BiometricAccuracyDescriptor , BiometricStatusReport , CodeAccuracyDescriptor , DisplayPNGCharacteristicsDescriptor , EcdaaTrustAnchor , ExtensionDescriptor , MetadataStatement , MetadataTOCPayload , MetadataTOCPayloadEntry , PatternAccuracyDescriptor , RgbPaletteEntry , RogueListEntry , StatusReport , VerificationMethodANDCombinations , VerificationMethodDescriptor , Version , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , CertificateTrustPath , EcdaaKeyIdTrustPath , EmptyTrustPath , TrustPath
  • createFromBigInteger() : BigInteger
  • createFromBinaryString() : BigInteger
  • createFromData() : Key
  • createFromDecimal() : BigInteger
  • createFromExponentAndMantissa() : BigFloatTag , DecimalFractionTag
  • createFromGmpValue() : SignedIntegerObject , UnsignedIntegerObject
  • createFromHex() : UnsignedIntegerObject
  • createFromJson() : JWK , JWKSet
  • createFromJWK() : RSAKey
  • createFromKey() : KeyOrPassword
  • createFromKeyData() : JWKSet
  • createFromLoadedData() : BreakObject , OtherObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , TrueObject , UndefinedObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TagObject
  • createFromPassword() : KeyOrPassword
  • createFromPublicKeyCredential() : PublicKeyCredentialSource
  • createFromString() : SignedIntegerObject , UnsignedIntegerObject , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialUserEntity
  • createFromThrowable() : FlattenException
  • createGreaterOrEqualsTo() : Factory
  • createHash() : BaseSigner , Ecdsa , Hmac , None , OpenSSL
  • createHeader() : Client , PHPMailer
  • createInlineCryptFunction() : SymmetricKey
  • createItemForTable() : PrivacyPlugin
  • createItemForUserTable() : PlgPrivacyUser
  • createItemFromArray() : PrivacyPlugin
  • createKey() : MemcachedStorage , DH , DSA , EC
  • createLanguage() : Factory , CachingLanguageFactory , LanguageFactory , LanguageFactoryInterface
  • createLanguageInstallerRoutes() : PlgWebservicesLanguages
  • createLanguageList() : LanguageHelper
  • createLengthPart() : ASNObject
  • createLesserOrEqualsTo() : Factory
  • createMailer() : Factory
  • createMediaCRUDRoutes() : PlgWebservicesMedia
  • createMenu() : MenuFactory , MenuFactoryInterface
  • createModel() : BaseController , ApiMVCFactory , LegacyFactory , MVCFactory , MVCFactoryInterface
  • CreateNewRandomKey() : Crypto
  • createNewRandomKey() : Key
  • createNodeName() : XPath
  • createNone() : AttestationStatement
  • createNotesDomain() : PlgPrivacyUser
  • createObjectArray() : ContenthistoryHelper
  • createObjectForValue() : SignedIntegerObject , UnsignedIntegerObject
  • createOption() : ModulesModel , ModulesHelper
  • createOptionGroup() : ModulesModel , ModulesHelper
  • createOrUpdateRecord() : MetadataManager
  • createOverride() : TemplateModel
  • createParameters() : DH , DSA
  • createPoly1305Key() : Salsa20
  • createPrependAutoloader() : Autoloader
  • createProfileDomain() : PlgPrivacyUser
  • createProgressBar() : OutputStyle , SymfonyStyle
  • createPublicKeyCredentialSource() : AuthenticatorAttestationResponseValidator
  • createQuery() : AdapterInterface , Adapter
  • createRandomMultiplier() : Base , Curve25519 , Curve448 , Ed25519 , Ed448
  • createRandomPasswordProtectedKey() : KeyProtectedByPassword
  • createRecordIfNonExisting() : MetadataManager
  • createRecurringModuloFunction() : BigInteger , Engine , GMP
  • createRef() : StringController
  • createRenderer() : Factory , FactoryInterface
  • createRequest() : RequestFactory , HttplugFactory , Psr17Factory , RequestFactoryInterface
  • createResponse() : ResponseFactory , HttplugFactory , Psr17Factory , ResponseFactoryInterface , PublicKeyCredentialLoader
  • createRestorationFile() : UpdateModel
  • createRootUser() : ConfigurationModel
  • createRouter() : RouterFactory , RouterFactoryInterface , RouterServiceInterface , LegacyComponent
  • createSelf() : AttestationStatement
  • createServerRequest() : ServerRequestFactory , Psr17Factory , ServerRequestFactoryInterface
  • createSessionRecord() : MetadataManager
  • createSignature() : Builder
  • createSiteList() : Help
  • createSocket() : Connection
  • createStream() : StreamFactory , HttplugFactory , Psr17Factory , StreamFactoryInterface
  • createStreamFromFile() : StreamFactory , Psr17Factory , StreamFactoryInterface
  • createStreamFromResource() : StreamFactory , Psr17Factory , StreamFactoryInterface
  • createStyleFromString() : OutputFormatter
  • createTable() : ApiMVCFactory , LegacyFactory , MVCFactory , MVCFactoryInterface , SymfonyStyle
  • createTables() : DatabaseModel
  • createTagsFromField() : TagsHelper
  • createTemplate() : MailTemplate
  • createTemplateOverride() : TemplateModel
  • createThumbs() : Image
  • createToken() : Session , LdapAuthenticator
  • createToolbar() : ContainerAwareToolbarFactory , ToolbarFactoryInterface
  • createTransliterator() : AsciiSlugger
  • createUpdateFile() : UpdateModel
  • createUploadedFile() : UploadedFileFactory , Psr17Factory , UploadedFileFactoryInterface
  • createUri() : UriFactory , Router , UriFactory , HttplugFactory , Psr17Factory , UriFactoryInterface
  • createUriFromRequestTarget() : Serializer
  • createUriString() : Uri
  • createUrl() : Help , Client
  • createUserDomain() : PlgPrivacyUser
  • createView() : BaseController , LegacyFactory , MVCFactory , MVCFactoryInterface
  • createZipFile() : Zip
  • CREDENTIAL_TYPE_PUBLIC_KEY : PublicKeyCredentialDescriptor
  • crit() : PropelCollector
  • CRITICAL : Log
  • critical() : AbstractLogger , LoggerInterface
  • CRITICAL : LogLevel
  • CRLF : PHPMailer
  • CROATIAN_LANGUAGE_CODE : ASCII
  • CROP : Image
  • crop() : Image
  • CROP_RESIZE : Image
  • cropImage() : TemplateModel
  • cropResize() : Image
  • crypt() : RC4 , Salsa20
  • crypt_private() : PasswordHash
  • CRYPTO_AEAD_AES256GCM_ABYTES : ParagonIE_Sodium_Compat
  • crypto_aead_aes256gcm_encrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_aes256gcm_is_available() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_aead_aes256gcm_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_encrypt() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES : ParagonIE_Sodium_Compat
  • crypto_auth() : ParagonIE_Sodium_Compat
  • CRYPTO_AUTH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AUTH_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_auth_keygen() : ParagonIE_Sodium_Compat
  • crypto_auth_verify() : ParagonIE_Sodium_Compat
  • crypto_box() : ParagonIE_Sodium_Compat
  • crypto_box_keypair() : ParagonIE_Sodium_Compat
  • crypto_box_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_MACBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_NONCEBYTES : ParagonIE_Sodium_Compat
  • crypto_box_open() : ParagonIE_Sodium_Compat
  • crypto_box_publickey() : ParagonIE_Sodium_Compat
  • crypto_box_publickey_from_secretkey() : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_box_seal() : ParagonIE_Sodium_Compat
  • crypto_box_seal_open() : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SEALBYTES : ParagonIE_Sodium_Compat
  • crypto_box_secretkey() : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_box_seed_keypair() : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SEEDBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_HASHBYTES : ParagonIE_Sodium_Compat
  • crypto_core_ristretto255_HASHBYTES : ParagonIE_Sodium_Core_Ristretto255
  • CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_SCALARBYTES : ParagonIE_Sodium_Compat
  • crypto_generichash() : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES_MIN : ParagonIE_Sodium_Compat
  • crypto_generichash_final() : ParagonIE_Sodium_Compat
  • crypto_generichash_init() : ParagonIE_Sodium_Compat
  • crypto_generichash_init_salt_personal() : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES_MIN : ParagonIE_Sodium_Compat
  • crypto_generichash_keygen() : ParagonIE_Sodium_Compat
  • crypto_generichash_update() : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_BYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_BYTES_MIN : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_CONTEXTBYTES : ParagonIE_Sodium_Compat
  • crypto_kdf_derive_from_key() : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_kdf_keygen() : ParagonIE_Sodium_Compat
  • crypto_kx() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_BYTES : ParagonIE_Sodium_Compat
  • crypto_kx_client_session_keys() : ParagonIE_Sodium_Compat
  • crypto_kx_keypair() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_PRIMITIVE : ParagonIE_Sodium_Compat
  • crypto_kx_publickey() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_kx_secretkey() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_kx_seed_keypair() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SEEDBYTES : ParagonIE_Sodium_Compat
  • crypto_kx_server_session_keys() : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SESSIONKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_pwhash() : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_ALG_ARGON2I13 : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_ALG_ARGON2ID13 : ParagonIE_Sodium_Compat
  • crypto_pwhash_is_available() : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_MODERATE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_MODERATE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SALTBYTES : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_is_available() : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_str() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_str_verify() : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX : ParagonIE_Sodium_Compat
  • crypto_pwhash_str() : ParagonIE_Sodium_Compat
  • crypto_pwhash_str_verify() : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_STRPREFIX : ParagonIE_Sodium_Compat
  • crypto_scalarmult() : ParagonIE_Sodium_Compat
  • crypto_scalarmult_base() : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_BYTES : ParagonIE_Sodium_Compat
  • crypto_scalarmult_curve25519_ref10_base() : ParagonIE_Sodium_Core32_X25519 , ParagonIE_Sodium_Core_X25519
  • CRYPTO_SCALARMULT_RISTRETTO255_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_SCALARBYTES : ParagonIE_Sodium_Compat
  • crypto_secretbox() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_secretbox_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_MACBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_NONCEBYTES : ParagonIE_Sodium_Compat
  • crypto_secretbox_open() : ParagonIE_Sodium_Compat
  • crypto_secretbox_xchacha20poly1305() : ParagonIE_Sodium_Compat
  • crypto_secretbox_xchacha20poly1305_open() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_init_pull() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_init_push() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_pull() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_push() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_rekey() : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY : ParagonIE_Sodium_Compat
  • crypto_shorthash() : ParagonIE_Sodium_Compat
  • CRYPTO_SHORTHASH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SHORTHASH_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_shorthash_keygen() : ParagonIE_Sodium_Compat
  • crypto_sign() : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_BYTES : ParagonIE_Sodium_Compat
  • crypto_sign_detached() : ParagonIE_Sodium_Compat
  • crypto_sign_ed25519_pk_to_curve25519() : ParagonIE_Sodium_Compat
  • crypto_sign_ed25519_sk_to_curve25519() : ParagonIE_Sodium_Compat
  • crypto_sign_keypair() : ParagonIE_Sodium_Compat
  • crypto_sign_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • crypto_sign_open() : ParagonIE_Sodium_Compat
  • crypto_sign_publickey() : ParagonIE_Sodium_Compat
  • crypto_sign_publickey_from_secretkey() : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_sign_secretkey() : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • crypto_sign_seed_keypair() : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_SEEDBYTES : ParagonIE_Sodium_Compat
  • crypto_sign_verify_detached() : ParagonIE_Sodium_Compat
  • crypto_stream() : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_stream_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_NONCEBYTES : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20() : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_XCHACHA20_KEYBYTES : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20_keygen() : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_XCHACHA20_NONCEBYTES : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20_xor() : ParagonIE_Sodium_Compat
  • crypto_stream_xor() : ParagonIE_Sodium_Compat
  • CSR_VERSION_NR : CSR
  • CSRFC3548 : Base32
  • CTRL_DIR_END : Zip
  • CTRL_DIR_HEADER : Zip
  • ctype_alnum() : Ctype
  • ctype_alpha() : Ctype
  • ctype_cntrl() : Ctype
  • ctype_digit() : Ctype
  • ctype_graph() : Ctype
  • ctype_lower() : Ctype
  • ctype_print() : Ctype
  • ctype_punct() : Ctype
  • ctype_space() : Ctype
  • ctype_upper() : Ctype
  • ctype_xdigit() : Ctype
  • current() : Construct , Uri , DataSet , DatabaseIterator , SplFixedArray
  • CURRENT_VERSION : Core
  • currentTime() : FixedTimeProvider , SystemTimeProvider , TimeProviderInterface
  • currentTimestamp() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • curve() : Ec2Key , OkpKey
  • CURVE_ED25519 : OkpKey
  • CURVE_ED448 : OkpKey
  • CURVE_KEY_LENGTH : Ec2Key
  • CURVE_P256 : Ec2Key
  • CURVE_P256K : Ec2Key
  • CURVE_P384 : Ec2Key
  • CURVE_P521 : Ec2Key
  • CURVE_X25519 : OkpKey
  • CURVE_X448 : OkpKey
  • custom() : ToolbarHelper
  • CUSTOM_OBJECT : FetchMode
  • CUSTOM_RULE_GROUP : ExecutionRulesRule
  • cutInternals() : StubCaster
  • CZECH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- d -

  • d() : Ec2Key , OkpKey , RsaKey
  • daemonize() : DaemonApplication
  • damp : AbstractPunycode
  • DANISH_LANGUAGE_CODE : ASCII
  • darwinRealpath() : DebugClassLoader
  • data() : SMTP
  • DATA : Base , Barrett , Base
  • DATA_CURVE : Ec2Key , OkpKey
  • DATA_D : Ec2Key , OkpKey , RsaKey
  • DATA_DI : RsaKey
  • DATA_DP : RsaKey
  • DATA_DQ : RsaKey
  • DATA_E : RsaKey
  • DATA_K : SymmetricKey
  • DATA_N : RsaKey
  • DATA_OTHER : RsaKey
  • DATA_P : RsaKey
  • DATA_Q : RsaKey
  • DATA_QI : RsaKey
  • DATA_RI : RsaKey
  • DATA_TI : RsaKey
  • DATA_X : Ec2Key , OkpKey
  • DATA_Y : Ec2Key
  • date() : Assertion , HTMLHelper
  • DATE_CLAIMS : RegisteredClaims
  • dateAdd() : DatabaseQuery
  • dateFormat() : DatabaseQuery
  • dateIsNotParseable() : InvalidTokenStructure
  • dateTimeToSql() : ExecRuleHelper
  • DAY : CronExpression
  • day() : DatabaseQuery , QueryInterface
  • DAY_ABBR : Date
  • DAY_NAME : Date
  • dayToString() : Date
  • DB_GROUP : GetConfigurationCommand
  • DB_VALIDATION_FAILED : SetConfigurationCommand
  • debug() : PropelCollector , BaseLayout , LayoutHelper
  • DEBUG : Log
  • debug() : Nested , PlgSystemStats , AbstractLogger , LoggerInterface
  • DEBUG : LogLevel
  • debug() : GithubActionReporter
  • DEBUG_CLIENT : POP3 , SMTP
  • DEBUG_CONNECTION : SMTP
  • DEBUG_LEVEL : ConnectionOptions
  • DEBUG_LOWLEVEL : SMTP
  • DEBUG_OFF : POP3 , SMTP
  • DEBUG_SERVER : POP3 , SMTP
  • debugFile() : Language
  • debugLanguage() : InstallationApplication
  • debugMsg() : ZIPExtraction
  • declareScalarType() : ParagonIE_Sodium_Core_Util
  • decode() : Base64Url , Decoder , Base128 , Base32 , InputFilter , JsonConverter , Base32 , EncoderInterface , CodecInterface , GuidStringCodec , StringCodec , TimestampFirstCombCodec
  • decode5Bits() : Base32 , Base32Hex
  • decode5BitsUpper() : Base32 , Base32Hex
  • decode6Bits() : Base64 , Base64DotSlash , Base64DotSlashOrdered , Base64UrlSafe , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • decodeBER() : ASN1
  • decodeBinary() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • decodeBytes() : CodecInterface , GuidStringCodec , OrderedTimeCodec , StringCodec , TimestampFirstCombCodec
  • decodeData() : Files
  • decodeDigit() : FromPunycode
  • decodeFields() : ContenthistoryHelper
  • decodeFileData() : InputFilter
  • decodeIP() : X509
  • decodeLength() : ASN1
  • decodeNameConstraintIP() : X509
  • decodeNoPadding() : Base32 , Base64
  • decodeOID() : ASN1
  • decodeRecordOptions() : Email , Fixed , Totp , Yubikey
  • decodeTime() : ASN1
  • decodeUpper() : Base32
  • decodeValue() : XML
  • decompose() : Normalizer
  • Decrypt() : Crypto
  • decrypt() : Crypto , CryptoCipher , SodiumCipher , AesInterface , Mcrypt , OpenSSL , Encrypt , Crypto , OpenSSL , Sodium , CipherInterface , Crypt , ChaCha20 , SymmetricKey
  • DECRYPT : DES
  • decrypt() : RC2 , RC4
  • DECRYPT : RC4
  • decrypt() : Rijndael , PrivateKey , Salsa20
  • DECRYPT : Salsa20
  • decrypt() : TripleDES
  • decrypt_with_libsodium() : ChaCha20
  • decryptBlock() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , Twofish
  • decryptCredential() : CredentialRepository
  • decryptFile() : File
  • decryptFileInternal() : File
  • decryptFileWithPassword() : File
  • decryptOptions() : MfaTable
  • decryptResource() : File
  • decryptResourceWithPassword() : File
  • decryptString() : Aes
  • decryptWithPassword() : Crypto
  • def() : CMSObject , Input , Registry
  • default() : OptionConfigurator
  • DEFAULT_ALIGN : TableCellStyle
  • DEFAULT_ENCODING : FromUtf8 , ToUtf8
  • DEFAULT_JSON_FLAGS : JsonResponse
  • DEFAULT_MESSAGE : RegisteredClaimGiven
  • DEFAULT_NAMESPACE_PREFIX : XPath
  • DEFAULT_PORT : POP3 , SMTP
  • DEFAULT_TIMEOUT : POP3
  • define() : OptionConfigurator , OptionsResolver
  • define_array() : SSH2
  • defined() : Assertion
  • definitionList() : SymfonyStyle
  • defParam() : User
  • deg() : Integer
  • degradeHexColorToAnsi() : Color
  • delete() : FtpClient , File , Folder , Stream , AdminController , AdminModel , CoreContent , MenuType , TableInterface , User , Usergroup , UCMContent , User , Versioning , ActionlogsModel , TracksModel , DisplayController , CategoryTable , ArticleModel , HistoryModel , FieldModel , IndexModel , MapsModel , UpdatesitesController , UpdatesitesModel , OverridesController , LanguagesModel , OverridesModel , OverridesController , AdapterInterface , ApiModel , MediaController , MediumModel , MenuModel , MenuTable , MessageModel , ModuleModel , TagTable , TemplateController , StyleModel , StyleTable , GroupsController , LevelController , MethodController , GroupModel , UserModel , MfaTable , StageTable , WorkflowTable , DatabaseQuery , QueryInterface , FtpClient , File , Folder , Stream , Http , LdapClient , LocalAdapter , Router , RouterInterface , SFTP
  • delete_recursive() : SFTP
  • deleteAll() : MethodsModel
  • deleteAssociation() : Workflow
  • deleteByContentId() : CoreContent
  • deleteConfiguration() : ConfigurationModel
  • deleteContextEntry() : Stream
  • deleteFile() : TemplateModel
  • deleteFiles() : ApiController
  • deleteFolder() : TemplateModel
  • deleteInstallationFolder() : CleanupModel
  • deleteList() : ToolbarHelper
  • deleteOldVersions() : ContentHistory
  • deletePriorTo() : MetadataManager
  • deleteSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • deleteTemplate() : MailTemplate
  • deleteUnexistingFiles() : JoomlaInstallerScript
  • delVar() : Uri
  • denominatorMustNotBeZero() : DivisionByZeroException
  • deprecated() : OptionConfigurator
  • DEREF : ConnectionOptions
  • DEREF_ALWAYS : QueryInterface
  • DEREF_FINDING : QueryInterface
  • DEREF_NEVER : QueryInterface
  • DEREF_SEARCHING : QueryInterface
  • deriveKeys() : KeyOrPassword
  • derivePoint() : Binary , Prime
  • describe() : TextDescriptor , DescriptorHelper , Descriptor , DescriptorInterface , MarkdownDescriptor , DescriptorHelper , CliDescriptor , DumpDescriptorInterface , HtmlDescriptor
  • describeApplication() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeCommand() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeConsoleCommand() : TextDescriptor
  • describeInputArgument() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeInputDefinition() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeInputOption() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeJoomlaApplication() : TextDescriptor
  • DESCRIPTION : OID
  • deserializeMetaData() : Manifest
  • destroy() : Image , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , Manager
  • DESTROYED : SessionState
  • destroySession() : SessionManager
  • destroySessions() : SessionManager
  • detach() : DaemonApplication , CallbackStream , RelativeStream , Stream , StreamInterface
  • detachRule() : RouterView , Router
  • detect() : Calculator
  • detectAndCleanIP() : IpHelper
  • detectBrowser() : WebClient
  • detectEncoding() : WebClient
  • detectEngine() : WebClient
  • detectHeaders() : WebClient
  • detectIP() : IpHelper
  • detectLanguage() : WebClient , LanguageHelper
  • detectPlatform() : WebClient
  • detectRequestUri() : AbstractWebApplication
  • detectRobot() : WebClient
  • detectType() : InstallerHelper
  • determineBaseFile() : Helper
  • determineBestFormat() : ProgressBar , ProgressIndicator
  • determineFileType() : Reader
  • determineFileTypeByHeader() : Reader
  • determineInvalidSubjects() : Resolver
  • determineTimeZone() : CronExpression
  • DEV_STATUS : Version
  • dI() : RsaKey
  • DIAG_CODES : PgSqlCaster
  • digit() : Assertion
  • digits() : Assert
  • dir_closedir() : PharStreamWrapper
  • dir_opendir() : PharStreamWrapper
  • dir_readdir() : PharStreamWrapper
  • dir_rewinddir() : PharStreamWrapper
  • directory() : Assertion , Assert
  • directoryTree() : HtmlView
  • disable() : DebugClassLoader
  • disableArbitraryLengthPackets() : SFTP
  • disableAsset() : WebAssetManager , WebAssetManagerInterface
  • disableAutoReload() : TraceableTwigEnvironment
  • disableBlinding() : RSA
  • disableCommand() : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • disableContinuousBuffer() : SymmetricKey , TripleDES
  • disableControl() : JavascriptRenderer
  • disableDatePreservation() : SFTP
  • disableDebug() : TraceableTwigEnvironment
  • disableModuleMainMenu() : PlgSampledataMultilang
  • disablePadding() : SymmetricKey
  • disablePathCanonicalization() : SFTP
  • disablePlugin() : PlgSystemStats
  • disablePresetItems() : WebAssetManager
  • disablePTY() : SSH2
  • disableQuietMode() : SSH2
  • disableRFC4050Syntax() : XML
  • disableSmartMFA() : SSH2
  • disableStatCache() : SFTP
  • disableStrictVariables() : TraceableTwigEnvironment
  • disableStty() : QuestionHelper
  • disableURLFetch() : X509
  • disableVendor() : JavascriptRenderer
  • disconnect() : DatabaseDriver , DatabaseInterface , MysqliDriver , POP3 , SSH2 , Connection
  • disconnect_helper() : SFTP , SSH2
  • discover() : JLoader , ComponentAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PluginAdapter , TemplateAdapter , Installer , DiscoverModel
  • discover_install() : LanguageAdapter , Installer , InstallerAdapter , DiscoverModel
  • discoverDefaultOptions() : MemcachedCaster
  • dispatch() : AdministratorApplication , ApiApplication , SiteApplication , ApiDispatcher , ComponentDispatcher , DispatcherInterface , LegacyComponentDispatcher , ModuleDispatcher , InstallationApplication , Dispatcher , DispatcherInterface
  • dispatchAssetChanged() : WebAssetRegistry
  • dispatchEvent() : AbstractApplication , BaseDatabaseModel , AbstractView , DatabaseDriver
  • dispatchExitEvent() : Task
  • display() : TraceableTwigEnvironment , TraceableTwigTemplate , Captcha , Editor , DefaultView , HtmlView , Microdata , AbstractView , CategoriesView , CategoryFeedView , CategoryView , FormView , HtmlView , JsonView , ListView , ViewInterface , DisplayController , JsonView , TextView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , VcfView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , FeedView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , FeedView , HtmlView , OpensearchView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , MenuController , MenusController , HtmlView , XmlView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , FeedView , HtmlView , FeedView , HtmlView , DisplayController , HtmlView , JsonView , HtmlView , DisplayController , MethodsController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , PlgSystemFields , ProgressBar , ProgressIndicator , LintCommand
  • displayAssociations() : AssociationHelper
  • displayBlock() : TraceableTwigTemplate
  • displayButtons() : PlgEditorCodemirror
  • displayFieldOnForm() : FieldsHelper
  • displayItem() : CategoriesController , JsonapiView , FieldsController , GroupsController , OverridesController , AdaptersController , MediaController , ItemsController , MenusController , ModulesController , JsonapiView , ConsentsController , StylesController , JsonapiView
  • displayJson() : LintCommand
  • displayList() : CategoriesController , JsonapiView , ArticlesController , JsonapiView , HistoryController , FieldsController , GroupsController , ManageController , OverridesController , MediaController , ItemsController , MenusController , ModulesController , PluginsController , StylesController , UsersController , JsonapiView
  • displayName() : CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer
  • displayParentBlock() : TraceableTwigTemplate
  • displayScope() : Microdata
  • displayTxt() : LintCommand
  • displayVotingData() : PlgContentVote
  • div() : BCMath
  • divide() : BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer
  • divide_digit() : PHP
  • dividedBy() : BigDecimal , BigInteger , BigRational
  • divideHelper() : PHP
  • divider() : ActionsDropdown , Dropdown , ToolbarHelper
  • divisionByZero() : DivisionByZeroException
  • divQ() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divQR() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divR() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divRound() : Calculator
  • DKIM_Add() : PHPMailer
  • DKIM_BodyC() : PHPMailer
  • DKIM_HeaderC() : PHPMailer
  • DKIM_QP() : PHPMailer
  • DKIM_Sign() : PHPMailer
  • DN_ARRAY : X509
  • DN_ASN1 : X509
  • DN_CANON : X509
  • DN_HASH : X509
  • DN_OPENSSL : X509
  • DN_STRING : X509
  • dnsName() : X509
  • dnsPrefetch() : PreloadManager , PreloadManagerInterface
  • do() : NamePrep , NamePrepInterface
  • doAdd() : NativeCalculator
  • doAsk() : QuestionHelper
  • doAuthenticate() : AbstractUsernamePasswordAuthenticationStrategy
  • dob() : PlgUserProfile
  • doCallback() : PHPMailer
  • doClone() : AbstractCloner , VarCloner
  • doCmp() : NativeCalculator
  • doDatabaseTransactions() : InstallerAdapter
  • doDisplay() : TraceableTwigTemplate
  • doDiv() : NativeCalculator
  • doesKeySatisfyRestrictions() : JWKSet
  • doExecute() : AbstractApplication , WebApplication , AdministratorApplication , ApiApplication , ConsoleApplication , SiteApplication , AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , UpdateCoreCommand , InstallationApplication , Application , AbstractCommand , HelpCommand , ListCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand
  • doLoadLanguage() : InstallerAdapter
  • DOM_INDEX_SIZE_ERR : DOMCaster
  • doMul() : NativeCalculator
  • doParse() : Parser
  • doRenderThrowable() : Application
  • doRun() : Application
  • doRunCommand() : Application
  • doSub() : NativeCalculator
  • doubleAndAddPoint() : Montgomery
  • doublePoint() : Binary , Prime , Ed25519 , Ed448
  • doublePointHelper() : KoblitzPrime , Prime
  • doubleRound() : ChaCha20 , Salsa20
  • doVerify() : BaseSigner , Ecdsa , Hmac , None , OpenSSL
  • DOWN : RoundingMode
  • download() : UpdateModel
  • downloadFile() : UpdateCoreCommand
  • downloadPackage() : LanguagesModel , InstallerHelper , UpdateModel
  • doWrite() : BufferedOutput , ConsoleSectionOutput , Output , StreamOutput , TrimmedBufferOutput
  • dP() : RsaKey
  • dQ() : RsaKey
  • draggable() : DraggableList
  • dropColumn() : ArrayHelper
  • dropdown() : Bootstrap
  • dropTable() : DatabaseDriver , DatabaseInterface
  • dropUtf8ConversionTable() : JoomlaInstallerScript
  • DST_FILE : Patcher
  • dueToConfiguration() : UnreadableStreamException , UnseekableStreamException , UnwritableStreamException
  • dueToMissingResource() : UnreadableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • dueToPhpError() : UnreadableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • dueToStreamUploadError() : UploadedFileErrorException
  • dueToUnwritablePath() : UploadedFileErrorException
  • dueToUnwritableTarget() : UploadedFileErrorException
  • dump() : SwiftLogCollector , DebugBarVarDumper , SeekingData , DataObject , DataSet , DumpableInterface , DatabaseQuery , Data , AbstractDumper , ContextualizedDumper , DataDumperInterface , HtmlDumper , ServerDumper , VarDumper , Dumper , Inline , Yaml
  • DUMP_COMMA_SEPARATOR : AbstractDumper
  • DUMP_EMPTY_ARRAY_AS_SEQUENCE : Yaml
  • DUMP_EXCEPTION_ON_INVALID_TYPE : Yaml
  • DUMP_LIGHT_ARRAY : AbstractDumper
  • DUMP_MULTI_LINE_LITERAL_BLOCK : Yaml
  • DUMP_NULL_AS_TILDE : Yaml
  • DUMP_OBJECT : Yaml
  • DUMP_OBJECT_AS_MAP : Yaml
  • DUMP_STRING_LENGTH : AbstractDumper
  • DUMP_TRAILING_COMMA : AbstractDumper
  • dumpArray() : Inline
  • dumpAssets() : JavascriptRenderer
  • dumpChildren() : Data
  • dumpCssAssets() : JavascriptRenderer
  • dumpEllipsis() : CliDumper
  • dumpHeadAssets() : JavascriptRenderer
  • dumpItem() : Data
  • dumpJsAssets() : JavascriptRenderer
  • dumpKey() : CliDumper
  • dumpLine() : AbstractDumper , CliDumper , HtmlDumper
  • dumpNull() : Inline
  • dumpProperty() : DataObject
  • dumpScalar() : DumperInterface , CliDumper
  • dumpString() : DumperInterface , CliDumper , HtmlDumper
  • duplicate() : ActionsDropdown , ModulesController , ModuleModel , StylesController , StyleModel
  • DUPLICATE_ALIAS_WARNING : PharInvocationCollection
  • duplicateUrls() : LinksController , LinkModel
  • DUTCH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- e -

  • e() : RsaKey , DatabaseQuery
  • e164() : Assertion
  • E_ACTION_MISMATCH : ReCaptcha
  • E_APK_PACKAGE_NAME_MISMATCH : ReCaptcha
  • E_BAD_RESPONSE : ReCaptcha
  • E_CHALLENGE_TIMEOUT : ReCaptcha
  • E_COMPILE_ERROR : ErrorHandler
  • E_COMPILE_WARNING : ErrorHandler
  • E_CONNECTION_FAILED : ReCaptcha
  • E_CORE_ERROR : ErrorHandler
  • E_CORE_WARNING : ErrorHandler
  • E_ERROR : ErrorHandler
  • E_HOSTNAME_MISMATCH : ReCaptcha
  • E_INVALID_JSON : ReCaptcha
  • E_MISSING_INPUT_RESPONSE : ReCaptcha
  • E_NOTICE : ErrorHandler
  • E_PARSE : ErrorHandler
  • E_RECOVERABLE_ERROR : ErrorHandler
  • E_SCORE_THRESHOLD_NOT_MET : ReCaptcha
  • E_STRICT : ErrorHandler
  • E_UNKNOWN_ERROR : ReCaptcha
  • E_USER_DEPRECATED : ErrorHandler , ExceptionCaster
  • E_USER_ERROR : ErrorHandler
  • E_USER_NOTICE : ErrorHandler
  • E_USER_WARNING : ErrorHandler
  • E_WARNING : ErrorHandler
  • echoLine() : AbstractDumper
  • edebug() : PHPMailer , SMTP
  • EDG : WebClient
  • EDGE : WebClient
  • edit() : JHtmlIcon , Dropdown , FormController , AssociationController , Icon , ArticleController , OverrideController , TemplateController , MediaController , ItemController , ItemsController , ProfileController
  • editAssociations() : FormController , AdminModel
  • editCss() : ToolbarHelper
  • editHtml() : ToolbarHelper
  • editList() : ToolbarHelper
  • editor() : Users
  • edwards_to_montgomery() : ParagonIE_Sodium_Core32_X25519 , ParagonIE_Sodium_Core_X25519
  • elementOptions() : PluginsHelper
  • email() : Assertion , Assert
  • emailToPunycode() : InputFilter , PunycodeHelper
  • emailToUTF8() : PunycodeHelper
  • EMBEDDED_PDV : Identifier
  • emergency() : PropelCollector
  • EMERGENCY : Log
  • emergency() : AbstractLogger , LoggerInterface
  • EMERGENCY : LogLevel
  • emsa_pkcs1_v1_5_encode() : RSA
  • emsa_pkcs1_v1_5_encode_without_null() : RSA
  • emsa_pss_encode() : PrivateKey
  • emsa_pss_verify() : PublicKey
  • enable() : Microdata , Debug , DebugClassLoader
  • enableArbitraryLengthPackets() : SFTP
  • enableAutoReload() : TraceableTwigEnvironment
  • enableBlinding() : RSA
  • enableCommand() : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • enableContinuousBuffer() : SymmetricKey , TripleDES
  • enableDatePreservation() : SFTP
  • enableDebug() : TraceableTwigEnvironment
  • enableDependencies() : WebAssetManager
  • enablePadding() : SymmetricKey
  • enablePathCanonicalization() : SFTP
  • enablePlugin() : PlgSampledataMultilang
  • enablePoly1305() : SymmetricKey
  • enablePropelProfiling() : PropelCollector
  • enablePTY() : SSH2
  • enableQuietMode() : SSH2
  • enableRFC4050Syntax() : XML
  • enableSmartMFA() : SSH2
  • enableStatCache() : SFTP
  • enableStrictVariables() : TraceableTwigEnvironment
  • enableURLFetch() : X509
  • encode() : Base64Url , Base128 , Base32 , JsonConverter , Base32 , Base64 , EncoderInterface , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe , CodecInterface , GuidStringCodec , StringCodec , TimestampFirstCombCodec
  • encode5Bits() : Base32 , Base32Hex
  • encode5BitsUpper() : Base32 , Base32Hex
  • encode64() : PasswordHash
  • encode6Bits() : Base64 , Base64DotSlash , Base64DotSlashOrdered , Base64UrlSafe , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • encode_der() : ASN1
  • encodeBinary() : CodecInterface , GuidStringCodec , OrderedTimeCodec , StringCodec , TimestampFirstCombCodec
  • encodeDER() : ASN1
  • encodeDigit() : ToPunycode
  • encodeEMSA15() : RSA
  • encodeEMSAPSS() : PSSRSA , RSA
  • encodeFile() : PHPMailer
  • encodeHeader() : PHPMailer
  • encodeIP() : X509
  • encodeLength() : ASN1
  • encodeOID() : ASN1
  • encodePoint() : Ed25519 , Ed448
  • encodeQ() : PHPMailer
  • encodeQP() : PHPMailer
  • encodeString() : PHPMailer
  • encodeUnpadded() : Base32 , Base64 , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • encodeUpper() : Base32
  • encodeUpperUnpadded() : Base32
  • encodeXMLParameters() : XML
  • ENCODING_7BIT : PHPMailer
  • ENCODING_8BIT : PHPMailer
  • ENCODING_BASE64 : PHPMailer
  • ENCODING_BINARY : PHPMailer
  • ENCODING_QUOTED_PRINTABLE : PHPMailer
  • encodings : TranscodeUnicode
  • Encrypt() : Crypto
  • encrypt() : Crypto , CryptoCipher , SodiumCipher , AesInterface , Mcrypt , OpenSSL , Encrypt , Crypto , OpenSSL , Sodium , CipherInterface , Crypt , ChaCha20 , SymmetricKey
  • ENCRYPT : DES
  • encrypt() : RC2 , RC4
  • ENCRYPT : RC4
  • encrypt() : Rijndael , PublicKey , Salsa20
  • ENCRYPT : Salsa20
  • encrypt() : TripleDES
  • encrypt_with_libsodium() : ChaCha20
  • encryptBlock() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , Twofish
  • encryptCredential() : CredentialRepository
  • encryptFile() : File
  • encryptFileInternal() : File
  • encryptFileWithPassword() : File
  • encryptInternal() : Crypto
  • encryption() : UnsupportedHeaderFound
  • encryption_algorithm_to_crypt_instance() : SSH2
  • encryption_algorithm_to_key_size() : SSH2
  • ENCRYPTION_INFO : Crypto
  • ENCRYPTION_INFO_STRING : Core
  • ENCRYPTION_NONE : RSA
  • ENCRYPTION_OAEP : RSA
  • ENCRYPTION_PKCS1 : RSA
  • ENCRYPTION_SMTPS : PHPMailer
  • ENCRYPTION_STARTTLS : PHPMailer
  • encryptResource() : File
  • encryptResourceWithPassword() : File
  • encryptString() : Aes
  • encryptWithPassword() : Crypto
  • end() : TracedStatement
  • endAccordion() : Bootstrap
  • endBoundary() : PHPMailer
  • endElement() : Changelog
  • endSlide() : Bootstrap
  • endsWith() : Assertion , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • endTab() : Bootstrap , UiTab
  • endTabSet() : Bootstrap , UiTab
  • endValue() : CliDumper
  • enforceAndroidSafetyNetVerification() : Server
  • enforceMinimumExecutionTime() : ZIPExtraction
  • ENGINE_DIR : BCMath , GMP , PHP
  • ENGINE_EVAL : SymmetricKey
  • ENGINE_INTERNAL : SymmetricKey
  • ENGINE_LIBSODIUM : SymmetricKey
  • ENGINE_MAP : SymmetricKey
  • ENGINE_MCRYPT : SymmetricKey
  • ENGINE_OPENSSL : SymmetricKey
  • ENGINE_OPENSSL_GCM : SymmetricKey
  • ENGLISH : Language
  • ENGLISH_LANGUAGE_CODE : ASCII
  • enhance() : ClassNotFoundErrorEnhancer , ErrorEnhancerInterface , UndefinedFunctionErrorEnhancer , UndefinedMethodErrorEnhancer
  • enhanceItemForm() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • enhanceTransitionForm() : PlgWorkflowPublishing
  • enqueueMessage() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • ensureConstantExists() : Core
  • ensureEnd() : AbstractString
  • EnsureFunctionExists() : Crypto
  • ensureFunctionExists() : Core
  • ensureMapFileExists() : JNamespacePsr4Map
  • ensureMinimalEncoding() : Integer
  • ensureStart() : AbstractString
  • ensureTrue() : Core
  • ensureUniqueId() : ToolbarButton
  • enter() : TimeableTwigExtensionProfiler
  • enterHash() : DumperInterface , CliDumper , HtmlDumper
  • ENUMERATED : Identifier
  • EOC : Identifier
  • eof() : Stream , CallbackStream , RelativeStream , Stream , StreamInterface
  • EOL : AbstractSerializer
  • eq() : Assertion , Assert
  • eqArraySubset() : Assertion
  • equal() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • equals() : BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer , Uuid , UuidInterface , InputOption , PharInvocation
  • equalsTo() : AbstractString , ByteString , CodePointString , UnicodeString
  • eraseCredentials() : LdapUser
  • err() : PropelCollector
  • ERR_CHECKS_FAILED : UpdateCoreCommand
  • ERR_UPDATE_FAILED : UpdateCoreCommand
  • ERROR : ApplicationEvents , Log , SessionState
  • error() : AbstractLogger , LoggerInterface
  • ERROR : LogLevel
  • error() : GithubActionReporter
  • ERROR : ConsoleEvents , ConsoleLogger
  • error() : StyleInterface , SymfonyStyle
  • ERROR_CODES : DOMCaster
  • ERROR_ILLEGAL_CHARACTER : Iconv
  • ERROR_MESSAGES : UploadedFile
  • ERROR_NUMBER : ConnectionOptions
  • ERROR_STRING : ConnectionOptions
  • ERROR_WRONG_CHARSET : Iconv
  • errorCode() : TraceablePDO , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • errorHandler() : SMTP
  • errorHappened() : CannotSignPayload
  • errorInfo() : TraceablePDO , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • errorMessage() : Exception
  • ERRORS : UploadedFile
  • escape() : BaseLayout , LayoutInterface , HtmlView , DatabaseInterface , DatabaseQuery , MysqlDriver , MysqliDriver , PdoDriver , SqliteDriver , LdapClient , OutputFormatter , HtmlErrorRenderer , AdapterInterface , Adapter , Ldap , LdapInterface
  • ESCAPE_DN : LdapInterface
  • ESCAPE_FILTER : LdapInterface
  • escapeAttributeValues() : InputFilter
  • escapeCsvFormula() : ActionlogsHelper
  • ESCAPED : Escaper
  • ESCAPED_DATA : GithubActionReporter
  • ESCAPED_PROPERTIES : GithubActionReporter
  • ESCAPEES : Escaper
  • escapeString() : ProcessHelper
  • escapeToken() : Input
  • escapeTrailingBackslash() : OutputFormatter
  • escapeWithDoubleQuotes() : Escaper
  • escapeWithSingleQuotes() : Escaper
  • ESPERANTO_LANGUAGE_CODE : ASCII
  • ESTONIAN_LANGUAGE_CODE : ASCII
  • evaluateBinaryScalar() : Inline
  • evaluateScalar() : Inline
  • EVENTS_MAP : Task
  • exactlyDividedBy() : BigDecimal
  • exception1() : English
  • exception2() : English
  • exceptionR1() : English
  • EXCHANGE_TYPES : AmqpCaster
  • EXCLUDE_DYNAMIC : Caster
  • EXCLUDE_EMPTY : Caster
  • EXCLUDE_NOT_IMPORTANT : Caster
  • EXCLUDE_NULL : Caster
  • EXCLUDE_PRIVATE : Caster
  • EXCLUDE_PROTECTED : Caster
  • EXCLUDE_PUBLIC : Caster
  • EXCLUDE_STRICT : Caster
  • EXCLUDE_VERBOSE : Caster
  • EXCLUDE_VIRTUAL : Caster
  • exec() : TraceablePDO , DatabaseQuery , QueryInterface , SSH2 , Curl
  • EXECUTABLES : MediaHelper
  • execute() : TraceablePDOStatement , AbstractApplication , AbstractWebApplication , ApplicationInterface , CliApplication , ConsoleApplication , DaemonApplication , WebApplication , Backgroundfill , Brightness , Contrast , Edgedetect , Emboss , Grayscale , Negate , Sketchy , Smooth , ImageFilter , InstallationApplication , BaseController , ControllerInterface , ApiController , MethodController , CaptiveController , MethodController , MethodsController , Application , AbstractCommand , DatabaseDriver , DatabaseInterface , MysqliStatement , PdoDriver , PdoStatement , SqlsrvStatement , StatementInterface , Command , DumpCompletionCommand , HelpCommand , ListCommand , CommandTester , Query , QueryInterface , ServerDumpCommand , LintCommand
  • executeController() : InstallationApplication
  • executeTransition() : WorkflowModelInterface , Workflow
  • executeUnpreparedQuery() : MysqliDriver
  • existing() : AdminLanguage , ContentLanguage , WorkflowStage
  • exists() : JNamespacePsr4Map , File , Folder , LanguageHelper , WebAssetRegistry , WebAssetRegistryInterface , Container , Input , Registry
  • EXPIRATION_TIME : RegisteredClaims
  • EXPIRED : SessionState
  • expiresAt() : Builder
  • explained() : Query
  • exponentiate() : PSSRSA , RSAKey , PrivateKey , PublicKey
  • exponents() : RsaKey
  • export() : RequestController
  • exportXml() : MenuController
  • extend() : Container
  • extendedGCD() : KoblitzPrime , BCMath , GMP , PHP32 , PHP64
  • extendedGCDHelper() : Engine
  • extendWhere() : DatabaseQuery , QueryInterface
  • extensionExistsInSystem() : FileAdapter
  • extensionLoaded() : Assertion
  • extensions() : X509
  • extensionVersion() : Assertion
  • EXTERNAL : Identifier
  • EXTRA_LATIN_CHARS_LANGUAGE_CODE : ASCII
  • EXTRA_MAP : ReflectionCaster
  • EXTRA_MSWORD_CHARS_LANGUAGE_CODE : ASCII
  • EXTRA_VERSION : Version
  • EXTRA_WHITESPACE_CHARS_LANGUAGE_CODE : ASCII
  • extract() : Archive , Bzip2 , ExtractableInterface , Gzip , Tar , Zip , HTMLHelper , FieldsHelper , Registry
  • extractAllNamespaces() : Application
  • extractArchive() : TemplateModel
  • extractBER() : ASN1
  • extractComponents() : StringCodec
  • extractCustom() : Zip
  • extractData() : Reader
  • extractDate() : HtmlDescriptor
  • extractEncryptionAlgorithm() : PKCS8
  • extractFile() : UpdateCoreCommand
  • extractFlags() : AmqpCaster
  • extractIdReferenceFromHref() : Helper
  • extractMetadata() : RdKafkaCaster
  • extractNamespace() : Application , ApplicationDescription , Application
  • extractNative() : Zip
  • extractPointRFC4050() : XML
  • extractPublicKey() : FidoU2FAttestationStatementSupport
  • extractSecret() : Ed25519 , Ed448
  • extractSource() : ExceptionCaster
  • extractTimeZoneData() : AbstractTime


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- f -

  • factory() : CronExpression
  • FAILOVER_OPTIONS : RedisCaster
  • FAILURE : Command
  • failureDescription() : CommandIsSuccessful
  • fallback() : Microdata
  • fallbackReplacement() : ConfigPostProcessor
  • false() : Assertion , Assert
  • FAST_BITWISE : BCMath , GMP , PHP
  • fclose() : Socket
  • fdiv() : Php80
  • fe_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_1() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_abs() : ParagonIE_Sodium_Core_Ristretto255
  • fe_cneg() : ParagonIE_Sodium_Core_Ristretto255
  • fe_copy() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_cswap() : ParagonIE_Sodium_Core_X25519
  • fe_frombytes() : ParagonIE_Sodium_Core_Curve25519
  • fe_invert() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_isnegative() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_mul() : ParagonIE_Sodium_Core_Curve25519
  • fe_neg() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_normalize() : ParagonIE_Sodium_Core_Curve25519
  • fe_pow22523() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_sq() : ParagonIE_Sodium_Core_Curve25519
  • fe_sq2() : ParagonIE_Sodium_Core_Curve25519
  • fe_sub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • feature() : ActionsDropdown
  • featured() : Dropdown , ContactModel , AdministratorService , ArticleModel
  • feof() : Socket
  • fetch() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface , BufferedOutput , TrimmedBufferOutput , MetadataStatementFetcher
  • FETCH_MODE_MAP : PdoStatement
  • fetchArray() : DatabaseDriver
  • fetchAssoc() : DatabaseDriver
  • fetchAssociations() : AjaxController
  • fetchButton() : BasicButton , ConfirmButton , CustomButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , SeparatorButton , StandardButton , ToolbarButton
  • fetchButtonClass() : StandardButton
  • fetchColumn() : MysqliStatement , SqlsrvStatement
  • fetchCompatibility() : UpdateModel
  • fetchConfigurationData() : InstallationApplication
  • fetchData() : MysqliStatement
  • fetchIconClass() : ActionButton , ToolbarButton
  • fetchId() : AbstractGroupButton , DropdownButton , ToolbarButton
  • fetchMetadataStatement() : MetadataStatementFetcher
  • fetchNamespace() : FeedParser
  • fetchObject() : DatabaseDriver , DatabaseIterator
  • fetchSchemaCache() : DatabaseModel
  • fetchTableOfContent() : MetadataStatementFetcher
  • fetchTaskRecord() : Scheduler
  • fetchURL() : X509
  • fgets() : Socket
  • FIDO_CERTIFIED : AuthenticatorStatus
  • FIDO_CERTIFIED_L1 : AuthenticatorStatus
  • FIDO_CERTIFIED_L1plus : AuthenticatorStatus
  • FIDO_CERTIFIED_L2 : AuthenticatorStatus
  • FIDO_CERTIFIED_L2plus : AuthenticatorStatus
  • FIDO_CERTIFIED_L3 : AuthenticatorStatus
  • FIDO_CERTIFIED_L3plus : AuthenticatorStatus
  • FIELD_CUSTOM : CaptiveRenderOptions , SetupRenderOptions
  • FIELD_INPUT : CaptiveRenderOptions , SetupRenderOptions
  • fieldmapExpand() : ContentType , UCMType
  • fields() : Collection , ElementInterface , Resource
  • file() : Assertion , InMemory , LocalFileReference , Assert
  • file_exists() : SFTP
  • FILE_HEADER : Zip
  • fileatime() : SFTP
  • fileExcerpt() : HtmlErrorRenderer
  • fileExists() : Assert
  • filegroup() : SFTP
  • fileIsAccessible() : PHPMailer
  • filemtime() : SFTP
  • filenameToType() : PHPMailer
  • fileowner() : SFTP
  • fileperms() : SFTP
  • files() : Folder
  • filesize() : Stream , SFTP
  • filetype() : SFTP
  • fileUploadMaxSize() : FilesystemHelper
  • fillCells() : Table
  • fillNextRows() : Table
  • filter() : FileStorage , MemcachedStorage , RedisStorage , CalendarField , SubformField , IntarrayFilter , RawFilter , RulesFilter , SafehtmlFilter , TelFilter , UnsetFilter , UrlFilter , Form , FormField , FormFilterInterface , Image , HeaderSecurity , SSH2 , Caster
  • filterAssetArray() : JavascriptRenderer
  • filterExceptionArray() : ExceptionCaster
  • filterExtensionsBasedOn() : ExtensionsListCommand
  • filterExtensionsBasedOnState() : ExtensionDiscoverListCommand
  • filterFields() : Resource
  • filterFragment() : Uri
  • filterHeader() : AbstractSerializer
  • filterInvalidUtf8() : Uri
  • filterKey() : LanguagesHelper
  • filterModules() : CaptiveModel
  • filterNotes() : Users
  • filterOutInlineAssets() : WebAssetManager
  • filterPath() : Uri
  • filterPort() : Uri
  • filterQuery() : Uri
  • filterQueryAndFragment() : Uri
  • filterQueryOrFragment() : Uri
  • filterRequestInputs() : Bootup
  • filterRequestUri() : Bootup
  • filterScheme() : Uri
  • filterString() : Bootup
  • filterText() : ComponentHelper , LanguagesHelper
  • filterTransitions() : WorkflowServiceInterface , ContentComponent , ContentHelper
  • filterUserInfoPart() : Uri
  • finaliseInstall() : FileAdapter , LanguageAdapter , ModuleAdapter , InstallerAdapter
  • finaliseUninstall() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • finaliseUpgrade() : UpdateModel
  • finalize() : PlgInstallerOverride
  • find() : OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , Path , Extension , Update , Path , FileStorage , Application
  • findAllForUserEntity() : PublicKeyCredentialSourceRepository
  • findAlternatives() : Application
  • findByAlias() : PharInvocationResolver
  • findByBaseName() : PharInvocationResolver
  • findByCallback() : Collectable , PharInvocationCollection
  • findByElement() : Resolver
  • findByElementId() : Resolver
  • findClassInPath() : ClassNotFoundErrorEnhancer
  • findCommand() : CompleteCommand
  • findData() : CollectedClientData
  • findDeletedFiles() : Installer
  • finderItems() : JoomlaInstallerScript
  • findField() : Form
  • findFieldsByFieldset() : Form
  • findFieldsByGroup() : Form
  • findFile() : ClassLoader , DebugClassLoader
  • findFileWithExtension() : ClassLoader
  • findGroup() : Form
  • findHeader() : Patcher
  • findHunk() : Patcher
  • findInBaseNames() : PharInvocationResolver
  • findInSet() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • findItem() : RouteHelper
  • findLoggers() : Log
  • findManifest() : Installer
  • findMatches() : AbstractNegotiator
  • findNamespace() : Application
  • findOneByAAGUID() : MetadataRepository , MetadataStatementRepository , SimpleMetadataStatementRepository
  • findOneByAAGUIDFromServices() : SimpleMetadataStatementRepository
  • findOneByAAGUIDFromSingleStatements() : SimpleMetadataStatementRepository
  • findOneByCredentialId() : CredentialRepository , PublicKeyCredentialSourceRepository
  • findOption() : TaskOptions
  • findOptionName() : ToolbarButton
  • findSignatureAlgorithm() : JWSBuilder
  • findUpdate() : CollectionAdapter , ExtensionAdapter , UpdateAdapter
  • findUpdates() : UpdateModel
  • finish() : ParagonIE_Sodium_Core_BLAKE2b , ProgressBar , ProgressIndicator , Catalan , Dutch , English , French , German , Italian , Portuguese , Romanian , Spanish
  • FINNISH_LANGUAGE_CODE : ASCII
  • FIREFOX : WebClient
  • FIRST : FetchOrientation
  • fix() : ChangeItem , ChangeSet , DatabaseModel , CoseSignatureFixer
  • fixCodeMarkup() : HtmlErrorRenderer
  • fixDefaultTextFilters() : DatabaseModel
  • fixFilenameCasing() : JoomlaInstallerScript
  • fixGroupColumns() : SqlsrvQuery
  • fixHexLength() : LengthCalculator
  • fixInteger() : MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • fixPEMStructure() : CertificateToolbox
  • fixQuote() : MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • fixReturnStatements() : DebugClassLoader
  • fixSchemaVersion() : DatabaseModel
  • fixSegment() : Router
  • fixSelectAliases() : SqlsrvQuery
  • fixTemplateMode() : JoomlaInstallerScript
  • fixTemplateName() : TemplateModel
  • fixUpdateVersion() : DatabaseModel
  • fixUtf8mb4TypeChecks() : MysqlChangeItem
  • FLAG_AT : AttestationObjectLoader , AuthenticatorData , PublicKeyCredentialLoader
  • FLAG_ED : AttestationObjectLoader , AuthenticatorData , PublicKeyCredentialLoader
  • FLAG_RFU1 : AuthenticatorData
  • FLAG_RFU2 : AuthenticatorData
  • FLAG_UP : AuthenticatorData
  • FLAG_UV : AuthenticatorData
  • FLAGS : Gzip , AmqpCaster
  • flatten() : Registry , ArrayHelper
  • flatten64() : ParagonIE_Sodium_Core_BLAKE2b
  • flattenArgs() : FlattenException
  • flip() : Image
  • float() : Assertion , Assert
  • float2string() : EvalBarrett
  • floatToString() : BigNumber
  • FLOOR : RoundingMode
  • flush() : CacheStorage , MemcachedStorage
  • flushAssets() : ConsoleApplication , WebApplication
  • FOLD_FROM : AbstractUnicodeString
  • FOLD_TO : AbstractUnicodeString
  • folded() : AbstractString , AbstractUnicodeString , ByteString
  • folderOptions() : PluginsHelper
  • folders() : Folder
  • folderTree() : HtmlView
  • forAsymmetricSigner() : Configuration
  • FORBIDDEN_FILE_EXTENSIONS : InputFilter
  • forCallbackStream() : UnreadableStreamException , UnrewindableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • forClaim() : RegisteredClaimGiven
  • forInvalidHeader() : DeserializationException
  • forInvalidHeaderContinuation() : DeserializationException
  • forInvalidRequestLine() : SerializationException
  • forInvalidStatusLine() : SerializationException
  • fork() : DaemonApplication , Session , SessionInterface
  • form() : SearchTools
  • FORM_C : Normalizer
  • FORM_D : Normalizer
  • FORM_KC : Normalizer
  • FORM_KD : Normalizer
  • format() : BCMath , Date , DatabaseQuery , NullOutputFormatter , OutputFormatter , OutputFormatterInterface
  • FORMAT_AUTO_DETECT : X509
  • FORMAT_DEBUG : ProgressBar
  • FORMAT_DEBUG_NOMAX : ProgressBar
  • FORMAT_DER : X509
  • format_log() : SSH2
  • FORMAT_NORMAL : ProgressBar
  • FORMAT_NORMAL_NOMAX : ProgressBar
  • FORMAT_PEM : X509
  • FORMAT_SPKAC : X509
  • FORMAT_TAR_BZIP : DownloadSource
  • FORMAT_TAR_GZ : DownloadSource
  • FORMAT_UCS4 : TranscodeUnicode
  • FORMAT_UCS4_ARRAY : TranscodeUnicode
  • FORMAT_UTF7 : TranscodeUnicode
  • FORMAT_UTF7_IMAP : TranscodeUnicode
  • FORMAT_UTF8 : TranscodeUnicode
  • FORMAT_VERBOSE : ProgressBar
  • FORMAT_VERBOSE_NOMAX : ProgressBar
  • FORMAT_VERY_VERBOSE : ProgressBar
  • FORMAT_VERY_VERBOSE_NOMAX : ProgressBar
  • FORMAT_ZIP : DownloadSource
  • formatAndWrap() : OutputFormatter , WrappableOutputFormatterInterface
  • formatArgs() : HtmlErrorRenderer
  • formatArgsAsText() : HtmlErrorRenderer
  • formatBlock() : FormatterHelper
  • formatBytes() : DataCollector , DataFormatter , DataFormatterInterface
  • formatCallable() : DebugEventDispatcherCommand , DebugRouterCommand
  • formatCallerInfo() : AbstractDataCollector , DataFormatter
  • formatChoiceQuestionChoices() : QuestionHelper
  • formatConfig() : GetConfigurationCommand
  • formatConfigValue() : GetConfigurationCommand
  • formatDate() : CredentialRepository
  • formatDateTime() : DateCaster
  • formatDefaultValue() : TextDescriptor
  • formatDuration() : DataCollector , DataFormatter , DataFormatterInterface
  • formatExceptionData() : ExceptionsCollector
  • formatFile() : HtmlErrorRenderer
  • formatFileFromText() : HtmlErrorRenderer
  • formatInterval() : DateCaster
  • formatLine() : FormattedtextLogger
  • formatLogMessage() : HtmlErrorRenderer
  • formatMemory() : Helper
  • formatOptions() : OptionsResolver
  • formatPack() : Strings
  • formatPath() : AbstractDataCollector , DataFormatter
  • formatRelative() : MethodsModel
  • FORMATS : ProgressIndicator
  • formatSeconds() : DateCaster
  • formatSection() : FormatterHelper
  • formatSubjectPublicKey() : X509
  • formatThrowableData() : ExceptionsCollector
  • formatTime() : Helper
  • formatTo() : SwiftMailCollector
  • formatValue() : Php , DebugRouterCommand , OptionsResolver
  • formatValues() : OptionsResolver
  • formatVar() : DataCollector , DataFormatter , DataFormatterInterface
  • formvalidator() : Behavior
  • forRequestFromArray() : DeserializationException
  • forResponseFromArray() : DeserializationException
  • forSymmetricSigner() : Configuration
  • forUnexpectedCarriageReturn() : DeserializationException
  • forUnexpectedEndOfHeaders() : DeserializationException
  • forUnexpectedLineFeed() : DeserializationException
  • forUnmovableFile() : UploadedFileErrorException
  • forUnsecuredSigner() : Configuration
  • forVersion() : UnrecognizedProtocolVersionException
  • FORWARD_ACTIVE : Agent
  • FORWARD_NONE : Agent
  • FORWARD_REQUEST : Agent
  • forwardCallToCorrectClaimMethod() : Builder
  • forwardData() : Agent
  • FRAGMENT : UriInterface
  • framework() : Bootstrap , Jquery
  • fread() : ZIPExtraction
  • freeResult() : DatabaseDriver , DatabaseIterator
  • FRENCH : Language
  • FRENCH_AUSTRIAN_LANGUAGE_CODE : ASCII
  • FRENCH_LANGUAGE_CODE : ASCII
  • FRENCH_SWITZERLAND_LANGUAGE_CODE : ASCII
  • from() : DatabaseExporter , DatabaseImporter , DatabaseQuery , QueryInterface
  • fromArbitraryBase() : BigInteger , Calculator
  • fromArray() : ArraySerializer , ParagonIE_Sodium_Core32_Curve25519_Fe , SplFixedArray
  • fromAsn1() : ECSignature , MultibyteStringConverter , SignatureConverter
  • fromBase() : BigInteger , Calculator , GmpCalculator
  • fromBase64ToInteger() : RsaKey , RSAKey
  • fromBin() : Base32
  • fromBinary() : AbstractString , ASNObject , RelativeDistinguishedName , Construct , ExplicitlyTaggedObject , Parsable , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , RelativeObjectIdentifier , UTCTime , CertificateSubject , Attributes , IPAddress
  • fromBytes() : BigInteger , Uuid , UuidFactory , UuidFactoryInterface
  • fromCallable() : LazyString
  • fromCamelCase() : Normalise
  • fromCodePoints() : AbstractUnicodeString
  • fromContent() : Manifest , Stub
  • fromEmptyData() : Signature
  • fromErrors() : LazyAssertionException
  • fromGlobals() : ServerRequestFactory
  • fromHex() : BigNumberConverter , DegradedNumberConverter , NumberConverterInterface
  • fromInt() : ParagonIE_Sodium_Core32_Int64
  • fromInteger() : Uuid , UuidFactory , UuidFactoryInterface
  • fromInts() : ParagonIE_Sodium_Core32_Int64
  • fromJson() : Response
  • fromObject() : ArrayHelper
  • fromPunycode() : PunycodeHelper
  • fromRandom() : ByteString
  • fromReverseString() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • fromStream() : Serializer
  • fromString() : ColorStyle , Serializer , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , Uuid , UuidFactory , UuidFactoryInterface , CompletionInput
  • fromStringable() : LazyString
  • fromTokens() : CompletionInput
  • fromViolations() : RequiredConstraintsViolated
  • fsockopen() : Socket
  • ftell() : ParagonIE_Sodium_File
  • ftpChmod() : FilesystemHelper , Helper
  • function : HtmlErrorRenderer
  • fwrite() : Socket
  • FWS : PHPMailer


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- g -

  • G() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • gc() : DaemonApplication , Cache , CacheStorage , ApcuStorage , FileStorage , WincacheStorage , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • gcd() : BigInteger , Calculator , GmpCalculator , BigInteger , GMP , PHP32 , PHP64 , BigInteger
  • gcdExtended() : Calculator
  • ge_add() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_cmov8_cached() : ParagonIE_Sodium_Core_Curve25519
  • ge_cmov_cached() : ParagonIE_Sodium_Core_Curve25519
  • ge_madd() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_msub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p1p1_to_p2() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p1p1_to_p3() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p2_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p2_dbl() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_dbl() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_to_p2() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_tobytes() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_precomp_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_select() : ParagonIE_Sodium_Core32_Curve25519
  • ge_sub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_tobytes() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • GECKO : WebClient
  • GENERAL_STRING : Identifier
  • GENERALIZED_TIME : Identifier
  • generate() : RequestIdGenerator , RequestIdGeneratorInterface , Randval , RandValInterface , CombGenerator , DefaultTimeGenerator , MtRandGenerator , OpenSslGenerator , PeclUuidRandomGenerator , PeclUuidTimeGenerator , RandomBytesGenerator , RandomGeneratorInterface , RandomLibAdapter , SodiumRandomGenerator , TimeGeneratorInterface
  • generate_identifier() : SSH2
  • generateAccessToken() : Client
  • generateAlias() : ContactTable
  • generateAliasAndName() : PlgUserContactCreator
  • generateCustomReduction() : EvalBarrett
  • generateFileHeader() : FormattedtextLogger
  • generateGroupTitle() : GroupModel
  • generateId() : RuntimeStorage , PHPMailer
  • generateInlineAdd() : EvalBarrett
  • generateInlineCompare() : EvalBarrett
  • generateInlineMultiply() : EvalBarrett
  • generateInlineSubtract1() : EvalBarrett
  • generateInlineSubtract2() : EvalBarrett
  • generateInlineTrim() : EvalBarrett
  • generateKey() : CryptoCipher , SodiumCipher , Crypto , OpenSSL , Sodium , CipherInterface , Crypt
  • generateManifestCache() : Installer
  • generateMediaVersion() : Version
  • generateMessage() : Assertion
  • generateNewTitle() : AdminModel , CategoryModel , FieldModel , ItemModel , ModuleModel , StyleModel , StageModel , TransitionModel , WorkflowModel
  • generateNonce() : Client
  • generateOteps() : UserModel
  • generatePassword() : LdapClient
  • generatePublicKeyCredentialCreationOptions() : Server
  • generatePublicKeyCredentialRequestOptions() : Server
  • generateRandUserId() : ConfigurationModel
  • generateRequestToken() : Client
  • generateSecret() : Totp
  • generateSymmetricKey() : PKCS1
  • generateThumbs() : Image
  • generateTitle() : AdminModel , BannerModel
  • generateV2Key() : PuTTY
  • generateV3Key() : PuTTY
  • genericlist() : Select
  • genericordering() : ListHelper
  • genRandomBytes() : Crypt
  • genRandomPassword() : UserHelper
  • gensalt_blowfish() : PasswordHash
  • gensalt_private() : PasswordHash
  • GEORGIAN_LANGUAGE_CODE : ASCII
  • GERMAN_AUSTRIAN_LANGUAGE_CODE : ASCII
  • GERMAN_LANGUAGE_CODE : ASCII
  • GERMAN_SWITZERLAND_LANGUAGE_CODE : ASCII
  • get() : Calculator , ListObject , Manager , Key , OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , AbstractApplication , ConfigurationAwareApplicationInterface , Cache , CacheStorage , OutputController , PageController , ViewController , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Categories , CategoryInterface , FtpClient , WritableContainerLoader , UserGroupsHelper , Files , Language , BaseLayout , AbstractView , CMSObject , Session , JoomlaStorage , Versioning , WebAssetRegistry , WebAssetRegistryInterface , Task , ContainerLoader , LoaderInterface , Container , FtpClient , Stream , Http , Files , Input , FileStorage , Registry , Router , RouterInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , AlgorithmManager , JWK , JWKSet , BigInteger , DataSet , ValidationData , SFTP , ContainerInterface , Application , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader , HelperSet , AttestationStatement , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , CollectedClientData
  • get_channel_packet() : SSH2
  • get_debug_type() : Php80
  • get_interactive_channel() : SSH2
  • get_language() : ASCII
  • get_lines() : SMTP
  • get_lstat_cache_prop() : SFTP
  • get_meta_data() : Stream
  • get_open_channel() : SSH2
  • get_random_bytes() : PasswordHash , Bootup
  • get_resource_id() : Php80
  • get_stat_cache_prop() : SFTP
  • get_xstat_cache_prop() : SFTP
  • getA() : Binary , Prime , TwistedEdwards
  • getAaguid() : AttestedCredentialData , MetadataStatement , MetadataTOCPayloadEntry , PublicKeyCredentialSource
  • getAaid() : MetadataStatement , MetadataTOCPayloadEntry
  • getAbbreviations() : Application
  • getAbbreviationSuggestions() : Application
  • getAccessors() : ConfirmButton , CustomButton , DropdownButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , ToolbarButton
  • getAccumulatedStatementsDuration() : TraceablePDO
  • getAction() : Sidebar , Response
  • getActionlogModel() : ExportModel , RemoveModel , RequestModel , ConfirmModel , RequestModel
  • getActionLogParams() : Joomla
  • getActions() : ContentHelper
  • getActionsFromData() : Access
  • getActionsFromFile() : Access
  • getActive() : AbstractMenu , MenuHelper
  • getActiveFilters() : ListModel
  • getActiveMethodNames() : CaptiveModel
  • getActiveOptions() : UsersHelper
  • getActivePositions() : ModulesModel
  • getAdapter() : Archive , Adapter , ApiController , ProviderManager
  • getAdapterName() : AdapterInterface , LocalAdapter
  • getAdapters() : Installer , ProviderInterface , PlgFileSystemLocal
  • getAddColumnSql() : DatabaseImporter
  • getAddDatasetCode() : JavascriptRenderer
  • getAddIndexSql() : PgsqlImporter
  • getAdditionalInformation() : AbstractCBORObject , CBORObject , UnsignedIntegerObject
  • getAdditionalUrlParam() : Pagination
  • getAddKeySql() : MysqlImporter , MysqliImporter
  • getAddSequenceSql() : PgsqlImporter
  • getAddUniqueSql() : PgsqlImporter
  • getAdminId() : PlgSampledataMultilang
  • getAdminTemplate() : StyleModel
  • getAdvancedModeLayoutData() : ColorField
  • getAdvancedRoute() : RouteHelper
  • getAffectedRows() : DatabaseDriver , DatabaseInterface
  • getAgentString() : Browser
  • getAjaxHandlerClass() : JavascriptRenderer
  • getAlg() : PublicKeyCredentialParameters
  • getAlgorithm() : Algorithms , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512 , RSA , RSAPKCS1 , RSAPSS , JWSVerifier , Sha256 , Sha384 , Sha512 , Hmac , Sha256 , Sha384 , Sha512 , OpenSSL , Sha256 , Sha384 , Sha512
  • getAlgorithmFromFormFile() : PlgUserToken
  • getAlgorithmId() : Sha256 , Sha384 , Sha512 , Signer , Sha256 , Sha384 , Sha512 , None , Sha256 , Sha384 , Sha512
  • getAlgorithms() : Manager , Algorithms
  • getAlgorithmsNegotiated() : SSH2
  • getAlias() : OpenSSH , Container , Manifest , PharInvocation
  • getAliases() : CronExpression , AbstractCommand , Command
  • getAliasLength() : Manifest
  • getAll() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , UserGroupsHelper , ListenersPriorityQueue
  • getAllCommands() : Application
  • getAllComponents() : ConfigHelper
  • getAllExtensionsFromDB() : ExtensionsListCommand
  • getAllLanguages() : ASCII
  • getAllowCredentials() : PublicKeyCredentialRequestOptions
  • getAllowed() : Rules
  • getAllowedAttrs() : Sanitizer
  • getAllowedMethods() : MethodNotAllowedException
  • getAllowedModulePositions() : CaptiveModel
  • getAllowedTags() : Sanitizer
  • getAllowedTypes() : OptionsResolverIntrospector
  • getAllowedUserGroups() : Token , PlgUserToken
  • getAllowedValues() : OptionsResolverIntrospector
  • getAllPrevious() : FlattenException
  • getAllPropertiesToRender() : OnGetApiFields
  • getAllRawData() : InstalledVersions
  • getAllRecipientAddresses() : PHPMailer
  • getAllRelationsToRender() : OnGetApiFields
  • getAllTemplateStyles() : TemplateModel
  • getAlterColumnSql() : PgsqlImporter
  • getAlterDbCharacterSet() : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver
  • getAlternativeDescriptions() : MetadataStatement
  • getAlternatives() : CommandNotFoundException
  • getAlterTableSql() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getAmountOfFiles() : Manifest
  • getAndCleanOutputBuffer() : HtmlErrorRenderer
  • getApcuPrefix() : ClassLoader
  • getApiRouter() : ApiApplication
  • getApiVersion() : Manifest
  • getApkPackageName() : Response
  • getApplication() : ApplicationEvent , Dispatcher , ErrorEvent , Factory , CMSPlugin , AbstractCommand , ConsoleEvent , Command
  • getApplicationDocument() : XmlDescriptor
  • getApplicationTitle() : MarkdownDescriptor
  • getArchive() : TemplateModel
  • getArgument() : AbstractEvent , EventInterface , Input , InputDefinition , InputInterface
  • getArgumentCount() : InputDefinition
  • getArgumentDefaults() : InputDefinition
  • getArgumentRequiredCount() : InputDefinition
  • getArguments() : AbstractEvent , Input , InputDefinition , InputInterface
  • getArray() : Input , StringController , Input
  • getArrayRecursive() : Input
  • getArrayString() : Php
  • getArticleId() : Router
  • getArticleRoute() : RouteHelper
  • getArticleSegment() : Router
  • getAssertionScheme() : MetadataStatement
  • getAsset() : WebAssetRegistryAssetChanged , WebAssetManager
  • getAssetAncestors() : Access
  • getAsseticCollection() : JavascriptRenderer
  • getAssetId() : Access , FieldTable
  • getAssetName() : Access
  • getAssetRules() : Access
  • getAssets() : DoctrineCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AssetProvider , ConfigCollector , MessagesCollector , PDOCollector , RequestDataCollector , DebugBarVarDumper , JavascriptRenderer , WebAssetManager , WebAssetManagerInterface , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , QueryCollector
  • getAssetState() : WebAssetManager
  • getAssetType() : Access , WebAssetRegistryAssetChanged
  • getAssignedArticleUrl() : ConsentBoxField
  • getAssignedCategoriesIds() : FieldsHelper
  • getAssignedCategoriesTitles() : FieldsHelper
  • getAssignedGroups() : UserModel
  • getAssignedMenuItemUrl() : ConsentBoxField
  • getAssignmentOptions() : ModulesHelper
  • getAssoc() : CategoriesModel , CategoryModel
  • getAssociation() : Workflow
  • getAssociationHtmlList() : AssociationsHelper
  • getAssociationList() : AssociationExtensionHelper , AssociationsHelper
  • getAssociations() : Associations , CategoriesHelper , AssociationsHelper , AssociationHelper , AssociationsHelper , AssociationHelper , AssociationsHelper , MenusHelper , AssociationsHelper , AssociationHelper
  • getAssociationsExtension() : AssociationServiceInterface
  • getAssociationsForItem() : AssociationExtensionInterface , AssociationsHelper
  • getAsString() : FlattenException
  • getAttachmentHint() : MetadataStatement
  • getAttachmentName() : MailTemplate
  • getAttachments() : PHPMailer
  • getAttestation() : PublicKeyCredentialCreationOptions
  • getAttestationCertificateKeyIdentifiers() : MetadataStatement , MetadataTOCPayloadEntry
  • getAttestationObject() : AuthenticatorAttestationResponse
  • getAttestationRootCertificates() : MetadataStatement
  • getAttestationStatementSupportManager() : Server
  • getAttestationType() : CertificateToolbox , PublicKeyCredentialSource
  • getAttestationTypes() : MetadataStatement
  • getAttestedCredentialData() : AuthenticatorData , PublicKeyCredentialSource
  • getAttribute() : TraceablePDO , Form , FormField , WebAssetItem , WebAssetItemInterface , ServerRequest , X509 , ServerRequestInterface , Entry
  • getAttributeKey() : Entry
  • getAttributes() : AllowedAttributes , AttributeInterface , OnGetApiAttributes , WebAssetItem , WebAssetItemInterface , ServerRequest , X509 , ServerRequestInterface , LinkInterface , Entry , Link , AbstractSerializer , Resource , SerializerInterface
  • getAttributeValue() : LdapUserProvider
  • getAttStmt() : AttestationObject , AttestationStatement
  • getAuthData() : AttestationObject , AuthenticatorData
  • getAuthenticationAlgorithm() : MetadataStatement
  • getAuthenticationAlgorithms() : MetadataStatement
  • getAuthenticationExtension() : ExtensionOutputError
  • getAuthenticationHelper() : Webauthn
  • getAuthenticationKey() : DerivedKeys
  • getAuthenticatorAttachment() : AuthenticatorSelectionCriteria
  • getAuthenticatorData() : AuthenticatorAssertionResponse
  • getAuthenticatorSelection() : PublicKeyCredentialCreationOptions
  • getAuthenticatorVersion() : MetadataStatement
  • getAuthMethodsToContinue() : SSH2
  • getAuthor() : CategoryNode
  • getAuthorisedCategories() : User
  • getAuthorisedGroups() : User
  • getAuthorisedViewLevels() : Access , User
  • getAuthority() : Uri , UriInterface
  • getAutocompleterCallback() : Question
  • getAutocompleterValues() : Question
  • getAvailableDriver() : HttpFactory
  • getAvailableFormats() : ServerDumpCommand
  • getAvailableTypes() : Microdata
  • getAvatar() : Credentials , Authentication
  • getB() : Binary , Prime , RgbPaletteEntry
  • getBaDesc() : VerificationMethodDescriptor
  • getBannerMessage() : SSH2
  • getBarCharacter() : ProgressBar
  • getBarOffset() : ProgressBar
  • getBarWidth() : ProgressBar
  • getBase() : Document , MenuHelper , CodeAccuracyDescriptor
  • getBaseName() : TracksModel , PharInvocation
  • getBasePart() : Accept , AcceptLanguage
  • getBasePath() : JavascriptRenderer , TemplateModel
  • getBasePoint() : Binary , Montgomery , Prime , TwistedEdwards
  • getBaseTemplateClass() : TraceableTwigEnvironment
  • getBaseUrl() : JavascriptRenderer
  • getBccAddresses() : PHPMailer
  • getBest() : AbstractNegotiator
  • getBinary() : ASNObject
  • getBinaryContent() : OctetString
  • getBinaryOperators() : TraceableTwigEnvironment
  • getBiometricStatusReports() : MetadataTOCPayloadEntry
  • getBitDepth() : DisplayPNGCharacteristicsDescriptor
  • getBitLength() : BigInteger
  • getBlockLength() : SymmetricKey , Hash
  • getBlockLengthInBytes() : SymmetricKey , Hash
  • getBlockNames() : TraceableTwigTemplate
  • getBlocks() : TraceableTwigTemplate
  • getBlockSize() : AesInterface , Mcrypt , OpenSSL
  • getBlockSlowdown() : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • getBody() : AbstractWebApplication , WebApplicationInterface , MessageInterface , HtmlErrorRenderer
  • getBorder() : DebugFormatterHelper
  • getBorderChars() : TableStyle
  • getBorderFormat() : TableStyle
  • getBoundary() : PHPMailer
  • getBounded() : DatabaseQuery , PreparableInterface
  • getBoundParams() : DebugMonitor
  • getBranch() : Taxonomy
  • getBranchTitles() : Taxonomy
  • getBrowser() : Browser
  • getBuffer() : Document , Profiler
  • getBuilder() : StringCodec , FeatureSet
  • getBundledCaBundlePath() : CaBundle
  • getButtonPath() : Toolbar
  • getButtons() : Editor , QuickIconHelper
  • getBytes() : Uuid , UuidInterface
  • getC() : EcdaaTrustAnchor
  • getCache() : TraceableTwigEnvironment , Factory , CacheModel
  • getCacheController() : Cache
  • getCacheFilename() : TraceableTwigEnvironment
  • getCacheKey() : Cache
  • getCaching() : Cache
  • getCaDesc() : VerificationMethodDescriptor
  • getCalendar() : Language
  • getCallerInfo() : Language
  • getCallStacks() : DebugMonitor
  • getCanonicalPath() : Helper
  • getCapabilities() : CapabilitiesModel
  • getCategories() : Router
  • getCategoriesId() : Router
  • getCategoriesSegment() : Router
  • getCategory() : CategoryServiceInterface , LegacyComponent , CategoryModel
  • getCategoryAssociations() : CategoryAssociationHelper
  • getCategoryId() : Router
  • getCategoryName() : TracksModel
  • getCategoryOrders() : BannersModel
  • getCategoryRoute() : RouteHelper
  • getCategorySegment() : Router
  • getCategoryWorkflowContext() : WorkflowServiceInterface , ContentComponent
  • getCcAddresses() : PHPMailer
  • getCellFormat() : TableCellStyle
  • getCellHeaderFormat() : TableStyle
  • getCellRowContentFormat() : TableStyle
  • getCellRowFormat() : TableStyle
  • getCellWidth() : Table
  • getCertificate() : StatusReport
  • getCertificateHashes() : CertificateToolbox
  • getCertificateNumber() : BiometricStatusReport , StatusReport
  • getCertificates() : CertificateTrustPath
  • getCertificationDescriptor() : BiometricStatusReport , StatusReport
  • getCertificationPolicyVersion() : BiometricStatusReport , StatusReport
  • getCertificationRequirementsVersion() : BiometricStatusReport , StatusReport
  • getCertLevel() : BiometricStatusReport
  • getCfg() : CMSApplication
  • getChain() : X509
  • getChallenge() : CollectedClientData , PublicKeyCredentialOptions
  • getChallengeTs() : Response
  • getChange() : WebAssetRegistryAssetChanged
  • getChangeColumnSql() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getChangeSequenceSql() : PgsqlImporter
  • getCharset() : TraceableTwigEnvironment , Document
  • getCheckForSelfUpdate() : UpdateModel
  • getChildren() : Construct , CategoryNode , ImmutableNodeInterface , CategoryModel
  • getChildToolbar() : AbstractGroupButton
  • getChoices() : ChoiceQuestion
  • getClaim() : Token
  • getClaims() : Token
  • getClass() : FlattenException
  • getClassCandidates() : ClassNotFoundErrorEnhancer
  • getClassDescription() : Identifier
  • getClassForValue() : OtherObjectManager , TagObjectManager
  • getClassList() : JLoader
  • getClassLoader() : Autoloader , DebugClassLoader
  • getClassMap() : ClassLoader
  • getClassName() : MVCFactory
  • getClassNameFromIncomplete() : FlattenException
  • getCleanMediaFieldValue() : MediaHelper
  • getClient() : LanguagesModel , InstalledModel , ModuleModel , PlgSampledataMultilang
  • getClientDataJSON() : AuthenticatorResponse
  • getClientFilename() : UploadedFile , UploadedFileInterface
  • getClientFromInput() : OverridesController
  • getClientId() : CMSApplication
  • getClientIdFromInput() : ItemsController , MenusController , ModulesController , StylesController
  • getClientInfo() : ApplicationHelper
  • getClientMediaType() : UploadedFile , UploadedFileInterface
  • getClientName() : TracksModel
  • getClientOptions() : BannersHelper , InstallerHelper , ModulesHelper , TemplatesHelper
  • getCliInput() : CliApplication
  • getClockSeqHiAndReserved() : Uuid
  • getClockSeqHiAndReservedHex() : Uuid , UuidInterface
  • getClockSeqLow() : Uuid
  • getClockSeqLowHex() : Uuid , UuidInterface
  • getClockSequence() : Uuid
  • getClockSequenceHex() : Uuid , UuidInterface
  • getCloner() : DebugBarVarDumper
  • getClonerOptions() : DebugBarVarDumper
  • getCode() : Totp , FlattenException
  • getCodec() : FeatureSet , UuidFactory
  • getCoefficient() : RSAKey
  • getCollation() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getCollectedEntries() : InMemoryLogger
  • getCollection() : Manager
  • getCollectionDetailsUrls() : UpdateModel
  • getCollector() : DebugBar
  • getCollectors() : AggregatedCollector , DebugBar
  • getColorType() : DisplayPNGCharacteristicsDescriptor
  • getColspan() : TableCell
  • getColumn() : ArrayHelper
  • getColumnAlias() : Table
  • getColumnSeparatorWidth() : Table
  • getColumnSql() : MysqlImporter , MysqliImporter , PgsqlImporter
  • getColumnStyle() : Table
  • getColumnWidth() : TextDescriptor
  • getCombinedNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getCombiningClass() : NamePrep
  • getCommand() : ApplicationDescription , ConsoleEvent , LazyCommand , ApplicationDescription , ConsoleEvent , HelperSet
  • getCommandAliasesText() : TextDescriptor
  • getCommandData() : JsonDescriptor
  • getCommandDocument() : XmlDescriptor
  • getCommandName() : Application
  • getCommands() : Application , ApplicationDescription
  • getComment() : AsymmetricKey
  • getCommonName() : CertificateSubject
  • getCommonWords() : Helper
  • getCompiler() : TraceableTwigEnvironment
  • getCompletionName() : CompletionInput
  • getCompletionType() : CompletionInput
  • getCompletionValue() : CompletionInput
  • getComponent() : ComponentHelper , Workflow , ComponentModel
  • getComponentName() : ApplicationHelper , ComponentHelper
  • getComponentOptions() : MessagesModel
  • getComponentRouter() : SiteRouter
  • getComponents() : ComponentHelper , DebugHelper
  • getComponentsWithConfig() : ConfigHelper
  • getComponentTagRoute() : RouteHelper
  • getComponentTagsRoute() : RouteHelper
  • getComposerRoot() : LinkStub
  • getCompression() : DisplayPNGCharacteristicsDescriptor
  • getConditionName() : Workflow
  • getConditions() : WorkflowServiceInterface
  • getConfig() : Propel2Collector , CliApplication , ConsoleApplication , WebApplication , Factory , SysinfoModel , Module
  • getConfiguredDatabaseType() : UpdateModel
  • getConnectedQuery() : PdoDriver
  • getConnection() : MemcachedStorage , RedisStorage , DatabaseDriver , DatabaseInterface , AdapterInterface , Adapter
  • getConnectionByResourceId() : SSH2
  • getConnectionCollation() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getConnectionEncryption() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getConnectionResource() : EntryManager
  • getConnections() : PDOCollector
  • getConnectionsGraph() : WebAssetManager
  • getConsoleInput() : Application
  • getConsoleMode() : Terminal
  • getConsoleOutput() : Application
  • getConstraints() : AssertionFailedException , InvalidArgumentException
  • getContactData() : PlgContentContact
  • getContactId() : Router
  • getContactRoute() : RouteHelper
  • getContacts() : MultilangstatusHelper
  • getContactSegment() : Router
  • getContactTable() : PlgUserContactCreator
  • getContainer() : AfterExtensionBootEvent , BeforeExtensionBootEvent , Factory
  • getContent() : AbstractString , AbstractTime , ASNObject , Construct , ExplicitlyTaggedObject , Boolean , Integer , NullObject , ObjectIdentifier , OctetString , UnknownObject , CertificateExtensions , IPAddress , SubjectAlternativeNames , Microdata , TracksModel , Task , Key , ConsoleSectionOutput , Stub
  • getContentCount() : Adapter
  • getContentExtras() : Helper
  • getContentlangs() : MultilangstatusHelper
  • getContentLanguages() : AssociationsHelper
  • getContentLength() : ASNObject
  • getContents() : CallbackStream , PhpInputStream , RelativeStream , Stream , StreamInterface
  • getContentTable() : ContentType
  • getContentType() : DocumentRenderer
  • getContentTypeLink() : ActionlogsHelper , MediaHelper
  • getContext() : OAuthCallbackEvent , QuickIconsEvent , EC , CliContextProvider , ContextProviderInterface , RequestContextProvider , SourceContextProvider
  • getContextFromInput() : FieldsController , GroupsController
  • getContextProviders() : ServerDumper , Connection
  • getContexts() : LegacyComponent , FieldsServiceInterface , ContactComponent , ContentComponent , UsersComponent , UsersHelper
  • getController() : ComponentDispatcher , Dispatcher , ResolvedRoute , Route
  • getControls() : JavascriptRenderer
  • getCookieParams() : ServerRequest , ServerRequestInterface
  • getCoreExtensionIds() : ExtensionHelper
  • getCoreExtensions() : ExtensionHelper
  • getCoreFile() : TemplateModel
  • getCoreList() : TemplateModel
  • getCoreUpdateNotification() : Joomlaupdate
  • getCount() : Usage , DatabaseDriver , DatabaseInterface , LanguageErrorsCollector , LanguageStringsCollector
  • getCounter() : CssMenu , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , PublicKeyCredentialSource
  • getCountry() : CertificateSubject , CSR
  • getCreateDatabaseQuery() : DatabaseDriver , MysqlDriver , MysqliDriver
  • getCreateDbQuery() : PgsqlDriver
  • getCredentialId() : AttestedCredentialData
  • getCredentialPublicKey() : AttestedCredentialData , PublicKeyCredentialSource
  • getCredentials() : ClientHelper
  • getCredentialsRepository() : Authentication
  • getCrossingChar() : TableStyle
  • getCrossingChars() : TableStyle
  • getCryptoStrength() : MetadataStatement
  • getCspNonce() : JavascriptRenderer
  • getCsvData() : ActionlogsHelper
  • getCurrent() : OutputFormatterStyleStack
  • getCurrentCert() : X509
  • getCurrentLanguage() : CMSHelper , ContentHelper
  • getCurrentLineIndentation() : Parser
  • getCurrentPosition() : Cursor
  • getCurrentRequestId() : DebugBar
  • getCurrentTimeInMilliseconds() : ProgressIndicator
  • getCurve() : ECDSA , ES256 , ES256K , ES384 , ES512 , EC , Identity
  • getCurveOid() : Ec2Key
  • getCustomHeaders() : PHPMailer
  • getD() : TwistedEdwards
  • getData() : Key , DebugBar , Rule , Rules , MessageRenderer , Form , BaseLayout , Pagination , CacheModel , ApplicationModel , ArchiveModel , StatisticsModel , InstalledModel , ProfileModel , RegistrationModel , PrivacyDashboardHelper , LanguageErrorsCollector , LanguageStringsCollector , Iconv , Normalizer , Mbstring , Relationship , Resource , ASCII , ExtensionDescriptor
  • getDataAsHeaders() : DebugBar
  • getDataAttributes() : FormField
  • getDatabase() : DatabaseDriver
  • getDatabaseInfo() : InfoCollector
  • getDataFormatter() : DataCollector , MessagesCollector , AbstractDataCollector
  • getDataFromTask() : PlgSystemTasknotification
  • getDataIfExists() : ASCII
  • getDataObject() : CMSHelper
  • getDate() : Factory , LocalAdapter , RogueListEntry
  • getDateFormat() : DatabaseDriver , DatabaseInterface
  • getDateTime() : DegradedUuid , Uuid , UuidInterface
  • getDbo() : Adapter , Factory , DatabaseHelper , BaseDatabaseModel , DatabaseModelInterface , Table , TableInterface
  • getDebug() : Language
  • getDebugActions() : DebugHelper , DebuggroupModel , DebuguserModel
  • getDebugLevel() : SMTP
  • getDebugMessages() : BaseLayout
  • getDebugOutput() : SMTP
  • getDefault() : Uninflected , Language , AbstractMenu , SiteMenu , MenuHelper , InputArgument , InputOption , Question , OptionsResolverIntrospector
  • getDefaultAnswer() : QuestionHelper
  • getDefaultCommands() : ConsoleApplication , Application
  • getDefaultContextProviders() : VarDumper
  • getDefaultDataFormatter() : DataCollector , AbstractDataCollector
  • getDefaultDescription() : Command
  • getDefaultEvent() : Dispatcher
  • getDefaultHelperSet() : Application
  • getDefaultHomeModule() : MultilangstatusHelper
  • getDefaultIncludePaths() : FileLayout
  • getDefaultInputDefinition() : ConsoleApplication , Application
  • getDefaultLanguage() : Helper
  • getDefaultLogger() : Propel2Collector
  • getDefaultName() : AbstractCommand , Command
  • getDefaultNormalizer() : ConfirmationQuestion
  • getDefaultProfileFieldValues() : PlgUserToken
  • getDefaults() : Route
  • getDefaultSchema() : PgsqlDriver
  • getDefaultStageByCategory() : Workflow
  • getDefaultTextFilters() : DatabaseModel
  • getDefaultValidator() : ChoiceQuestion
  • getDefaultVarDumper() : DataCollector
  • getDefinedOptions() : OptionsResolver
  • getDefinition() : Application , AbstractCommand , Application , Command , LazyCommand
  • getDenominator() : BigRational
  • getDependencies() : WebAssetItem , WebAssetItemInterface , ConfigProvider
  • getDependenciesForAsset() : WebAssetManager
  • getDeprecatedAliases() : JLoader
  • getDeprecation() : OptionsResolverIntrospector
  • getDeprecationMessage() : OptionsResolverIntrospector
  • getDescription() : Document , AbstractCommand , Command , InputArgument , InputOption , MetadataStatement
  • getDestination() : Patcher
  • getDetectBrowser() : SiteApplication
  • getDirection() : Document
  • getDirectory() : SysinfoModel
  • getDirectoryIterator() : LintCommand
  • getDirectoryTree() : TemplateModel
  • getDisabledUpdateSites() : UpdateModel
  • getDiscoverInstallSupported() : InstallerAdapter
  • getDispatcher() : EventAwareInterface , Component , ComponentInterface , LegacyComponent , Module , ModuleInterface
  • getDisplayLength() : ConsoleSectionOutput
  • getDisplayName() : ProviderInterface , PlgFileSystemLocal , PublicKeyCredentialUserEntity
  • getDisplayOptions() : DebugBarVarDumper
  • getDn() : LdapClient
  • getDN() : X509
  • getDn() : Entry
  • getDNProp() : X509
  • getDnString() : LdapBadge
  • getDocument() : CMSWebApplicationInterface , WebApplication , AbstractRenderer , RendererInterface , Factory
  • getDomain() : LocalizationCollector
  • getDownloadKey() : InstallerHelper
  • getDownloadKeyExistsSites() : InstallerHelper
  • getDownloadKeySupportedSites() : InstallerHelper
  • getDriver() : DatabaseFactory , ConnectionEvent
  • getDropColumnSql() : DatabaseImporter
  • getDropIndexSql() : PgsqlImporter
  • getDropKeySql() : MysqlImporter , MysqliImporter
  • getDropPrimaryKeySql() : MysqlImporter , MysqliImporter , PgsqlImporter
  • getDropSequenceSql() : PgsqlImporter
  • getDumper() : DebugBarVarDumper
  • getDumperOptions() : DebugBarVarDumper
  • getDumpHeader() : HtmlDumper
  • getDumpHeaderByDebugBar() : DebugBarHtmlDumper
  • getDuration() : TracedStatement
  • getEcdaaKeyId() : EcdaaKeyIdTrustPath
  • getEcdaaTrustAnchors() : MetadataStatement
  • getEditor() : EditorField , SysinfoModel
  • getEffectiveDate() : BiometricStatusReport , StatusReport
  • getElement() : Subject , NestingException , ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , InstallerAdapter , Result
  • getElementHref() : Helper
  • getElementId() : Subject
  • getElements() : Result , QueryElement
  • getElementsToRemove() : Resolver
  • getEmail() : CertificateSubject
  • getEmptyBarCharacter() : ProgressBar
  • getEmptyStateQuery() : ListModel , CategoriesModel , MapsModel , DiscoverModel , UpdateModel , ModulesModel , TagsModel
  • getEmptyStyle() : OutputFormatterStyleStack
  • getEnabledExtensions() : AssociationsHelper
  • getEncodedCoordinates() : EC
  • getEncodedPath() : LocalAdapter
  • getEncodedPayload() : JWS
  • getEncodedProtectedHeader() : Signature
  • getEncodedValue() : AbstractString , ASNObject , Construct , ExplicitlyTaggedObject , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , UTCTime , UnknownConstructedObject , UnknownObject , IPAddress , SubjectAlternativeNames
  • getEncoding() : Mbstring
  • getEncodingOptions() : JsonResponse
  • getEncryptionKey() : DerivedKeys
  • getEncryptionMode() : PKCS1
  • getEncryptionObject() : PKCS1
  • getEncryptionSettings() : DatabaseHelper
  • getEndMemory() : TracedStatement
  • getEndTime() : TracedStatement
  • getEngine() : SymmetricKey , DSA , EC , RSA , BigInteger
  • getEntries() : Sidebar , MetadataTOCPayload
  • getEntry() : LdapUser
  • getEntryManager() : AdapterInterface , Adapter , Ldap , LdapInterface
  • getEnvironment() : TraceableTwigTemplate
  • getEnvVariable() : CaBundle
  • getEofShortcut() : SymfonyQuestionHelper
  • getError() : ApplicationErrorEvent , ErrorEvent , CMSObject , ApplicationErrorEvent , CommandErrorEvent , UploadedFile , SMTP , UploadedFileInterface , ConsoleErrorEvent , FatalError , ZIPExtraction
  • getErrorCode() : TracedStatement
  • getErrorCodes() : Response
  • getErrorCount() : DatabaseModel
  • getErrorEnhancers() : ErrorHandler
  • getErrorExceptions() : LazyAssertionException
  • getErrorFiles() : Language
  • getErrorMessage() : TracedStatement
  • getErrorMsg() : LdapClient
  • getErrorOutput() : ConsoleOutput , ConsoleOutputInterface , OutputStyle
  • getErrors() : Form , CMSObject , POP3 , SSH2 , ResponseBag
  • getErrorsMessage() : DatabaseModel
  • getErrorStyle() : SymfonyStyle
  • getEstimated() : ProgressBar
  • getEvent() : Dispatcher
  • getEvents() : Dispatcher
  • getException() : TracedStatement
  • getExceptions() : ExceptionsCollector
  • getExcludeCredentials() : PublicKeyCredentialCreationOptions
  • getExcluded() : UserField , UserMessagesField
  • getExcludedTermIds() : Query
  • getExecutedStatements() : TraceablePDO
  • getExitCode() : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent
  • getExitStatus() : SSH2
  • getExpandedKey() : Aes
  • getExpectedDisplayType() : Microdata
  • getExpectedTypes() : Microdata
  • getExpire() : Session , SessionInterface
  • getExponent() : DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject , RSAKey , TPMAttestationStatementSupport
  • getExponents() : RSAKey
  • getExporter() : DatabaseDriver
  • getExpression() : CronExpression
  • getExt() : File
  • getExtension() : TraceableTwigEnvironment , Categories , X509
  • getExtensionDownloadKey() : InstallerHelper
  • getExtensionElementsForMenuItems() : MenuModel
  • getExtensionFromInput() : CategoriesController
  • getExtensionGroups() : InstallerHelper
  • getExtensionHelper() : AssociationsHelper , X509
  • getExtensionHelperClassName() : AssociationsHelper
  • getExtensionName() : AfterExtensionBootEvent , BeforeExtensionBootEvent , MessagesModel
  • getExtensionNameFromAsset() : Access
  • getExtensionRealName() : AssociationsHelper
  • getExtensionRecord() : ExtensionHelper
  • getExtensions() : TraceableTwigEnvironment , ExtensionsListCommand , SysinfoModel , TemplatesModel , X509 , AuthenticatorData , PublicKeyCredentialOptions
  • getExtensionsHelper() : X509
  • getExtensionsNameAndId() : ExtensionsListCommand
  • getExtensionType() : AfterExtensionBootEvent , BeforeExtensionBootEvent
  • getExtensionTypes() : InstallerHelper
  • getExtraFields() : LdapUser
  • getFacetId() : AuthenticatorAssertionResponseValidator
  • getFactory() : ContainerResource , Uuid
  • getFailedExecutedStatements() : TraceablePDO
  • getFallbackDirs() : ClassLoader
  • getFallbackDirsPsr4() : ClassLoader
  • getFallbackProperty() : Microdata
  • getFallbackType() : Microdata
  • getFeed() : FeedFactory , FeedHelper
  • getField() : FieldFactory , FieldFactoryInterface , Form
  • getFieldActions() : RulesRule
  • getFieldAttribute() : Form
  • getFieldName() : FormField
  • getFields() : Table , FieldsHelper , HtmlView , Item , StringCodec , DegradedUuid , Uuid , Parameters
  • getFieldset() : Form
  • getFieldsets() : Form
  • getFieldsHex() : Uuid , UuidInterface
  • getFieldsPluginId() : FieldsHelper
  • getFieldsTemplate() : AssociationExtensionHelper
  • getFieldTypes() : FieldsHelper
  • getFieldValue() : FieldModel
  • getFieldValues() : FieldModel
  • getFieldXml() : Form
  • getFile() : AdapterInterface , ApiModel , TemplateModel , LocalAdapter , FlattenException , SilencedErrorContext
  • getFileData() : Zip
  • getFileHandle() : Stream
  • getFileInformation() : FileModel
  • getFileLink() : HtmlErrorRenderer
  • getFileName() : LocalAdapter
  • getFilenameFromUrl() : InstallerHelper
  • getFilePosition() : Gzip
  • getFileRelative() : HtmlErrorRenderer
  • getFiles() : AdapterInterface , ApiController , ApiModel , TemplateModel , LocalAdapter , LintCommand
  • getFileType() : TracksModel
  • getFilter() : TraceableTwigEnvironment , FilterModel , Parameters , DisplayPNGCharacteristicsDescriptor
  • getFilterForm() : ListModel , ActionlogsModel , ArticlesModel , FieldsModel , UsersModel , TransitionsModel , WorkflowsModel
  • getFilterInstance() : Image
  • getFilters() : TraceableTwigEnvironment , FinderIndexCommand , FilesystemHelper , Sidebar , Helper
  • getFinderPluginId() : FinderHelper
  • getFingerprint() : PublicKey
  • getFirstArgument() : ArgvInput , ArrayInput , InputInterface
  • getFirstChild() : Construct
  • getFirstDay() : Language
  • getFlags() : Manifest
  • getFlippedSubstitutions() : Substitutions
  • getFmt() : AttestationStatement
  • getFolder() : RandomImageHelper
  • getFolders() : InstalledModel , MenutypesModel
  • getFont() : TemplateModel
  • getFontInfo() : PlgEditorCodemirror
  • getFooterTitleFormat() : TableStyle
  • getForm() : ChecksModel , LanguagesModel , SetupModel , FormModelInterface , HtmlView , AssociationModel , BannerModel , ClientModel , DownloadModel , CategoryModel , ApplicationModel , ComponentModel , ConfigModel , ModulesModel , TemplatesModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , FilterModel , UpdateModel , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , FileModel , ItemModel , MenuModel , ConfigModel , MessageModel , ModuleModel , NewsfeedModel , PluginModel , RequestModel , ConfirmModel , RemindModel , RequestModel , LinkModel , TaskModel , TagModel , StyleModel , TemplateModel , GroupModel , LevelModel , MailModel , NoteModel , UserModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , TransitionModel , WorkflowModel
  • getFormat() : Factory
  • getFormatDefinition() : ProgressBar , ProgressIndicator
  • getFormats() : DescriptorHelper
  • getFormatter() : NullOutput , Output , OutputInterface , OutputStyle
  • getFormControl() : Form
  • getFormFile() : ContenthistoryHelper
  • getFormPath() : FieldsPlugin
  • getFormRoute() : RouteHelper
  • getFormSegment() : Router
  • getFormToken() : SessionAwareWebApplicationInterface , Session
  • getFormValues() : ContenthistoryHelper
  • getFractionalPart() : BigDecimal
  • getFragment() : AbstractUri , UriInterface , Uri , UriInterface
  • getFrom() : Substitution
  • getFromName() : TemplateModel
  • getFromTask() : ExecRuleHelper
  • getFunction() : TraceableTwigEnvironment
  • getFunctions() : TraceableTwigEnvironment
  • getG() : RgbPaletteEntry
  • getG1Curve() : EcdaaTrustAnchor
  • getGenerator() : Document , RandomGeneratorFactory , TimeGeneratorFactory
  • getGenericTableName() : DatabaseExporter
  • getGetFields() : FinderHelper
  • getGlobals() : TraceableTwigEnvironment
  • getGlue() : QueryElement
  • getGrant() : OAuth
  • getGroup() : Form , DebuggroupModel
  • getGroupId() : AddUserCommand , AddUserToGroupCommand , RemoveUserFromGroupCommand
  • getGroupPath() : Access
  • getGroups() : AddUserToGroupCommand , GetConfigurationCommand , RemoveUserFromGroupCommand , ChromestyleField , GroupedlistField , MenuField , MenuitemField , TemplatestyleField , TimezoneField , UserField , WorkflowstageField , ItemtypeField , FieldsModel , ContentmapField , MenuItemByTypeField , UserMessagesField , UsersHelper , UserModel
  • getGroupsByUser() : Access
  • getGroupTitle() : Access
  • getHandle() : Image
  • getHandleFromUserId() : CredentialRepository
  • getHandler() : Propel2Collector , NativeStorage
  • getHandlers() : Session
  • getHandlingSignal() : ConsoleSignalEvent
  • getHash() : ApplicationHelper , AsymmetricKey , DH , Hash , MetadataTOCPayloadEntry
  • getHashAlgorithm() : Hmac , HS256 , HS256Truncated64 , HS384 , HS512 , ECDSA , ES256 , ES256K , ES384 , ES512 , PS256 , PS384 , PS512 , PSSRSA , RS1 , RS256 , RS384 , RS512 , RSA , ECDSA , ES256 , ES256K , ES384 , ES512 , HMAC , HS1 , HS256 , HS256_64 , HS384 , HS512
  • getHashAlgorithmFor() : Algorithms
  • getHashedPassword() : AbstractUsernamePasswordAuthenticationStrategy , DatabaseStrategy , LocalStrategy
  • getHashMatch() : ContentHistory
  • getHeadData() : HtmlDocument
  • getHeader() : Signature , Request , Token , MessageInterface
  • getHeaderCheckerManager() : JWSLoader
  • getHeaderLine() : MessageInterface
  • getHeaderParameter() : Signature
  • getHeaders() : AbstractWebApplication , WebApplicationInterface , Request , Token , MessageInterface , FlattenException
  • getHeaderTitleFormat() : TableStyle
  • getHeight() : Image , Terminal , DisplayPNGCharacteristicsDescriptor
  • getHelp() : ItemModel , ModuleModel , PluginModel , StyleModel , AbstractCommand , Application , Command , LazyCommand
  • getHelper() : Module , HelperFactory , HelperFactoryInterface , Command , LazyCommand
  • getHelperSet() : Application , AbstractCommand , Application , Command , Helper , HelperInterface
  • getHelpSearch() : HelpModel
  • getHelpVersion() : Version
  • getHex() : Uuid , UuidInterface
  • getHexRegex() : Inline
  • getHiddenResponse() : QuestionHelper
  • getHistory() : ANSI
  • getHome() : BreadcrumbsHelper
  • getHomes() : MultilangstatusHelper
  • getHost() : AbstractUri , UriInterface , Uri , UriInterface , DumpServer
  • getHostname() : Response
  • getHref() : LinkInterface , Link
  • getHtmlCallGraph() : NamespacedTwigProfileCollector , TwigProfileCollector
  • getHttp() : HttpFactory
  • getHttpDriver() : DebugBar
  • getHTTPProtocol() : Browser
  • getHttpStatusValue() : AbstractWebApplication
  • getHttpTransports() : HttpFactory
  • getHumanReadableLogMessage() : ActionlogsHelper
  • getIcon() : JHtmlIcon , MetadataStatement , PublicKeyCredentialEntity
  • getIconClass() : CssMenu
  • getId() : FormField , Table , TableInterface
  • getID() : ProviderInterface
  • getId() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • getID() : PlgFileSystemLocal
  • getId() : AbstractSerializer , Resource , SerializerInterface , Credential , ExtensionDescriptor , PublicKeyCredentialDescriptor , PublicKeyCredentialRpEntity , PublicKeyCredentialUserEntity , TokenBinding
  • getIdentifier() : ASNObject , ExplicitlyTaggedObject , UnknownConstructedObject , UnknownObject
  • getIdentity() : CMSApplicationInterface
  • getIdentityInfo() : InfoCollector
  • getIfconfig() : SystemNodeProvider
  • getIgnoredCollectors() : JavascriptRenderer
  • getIgnoredSearchWords() : En_GBLocalise , Fr_FRLocalise , Language
  • getIgnoredSearchWordsCallback() : Language
  • getImage() : TemplateModel
  • getImageFileProperties() : Image
  • getImages() : RandomImageHelper
  • getImporter() : DatabaseDriver
  • getInclude() : Parameters
  • getIncluded() : Document
  • getIncludedTermIds() : Query
  • getIncludePaths() : FileLayout
  • getInfo() : SysinfoModel , OptionsResolver
  • getIniParserAvailability() : ChecksModel , UpdateModel
  • getInitialConfigurationOptions() : SetConfigurationCommand
  • getInitialization() : JavascriptRenderer
  • getInitializer() : ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • getInlineRelation() : WebAssetManager
  • getInput() : AbstractWebApplication , WebApplicationInterface , CliApplication , CMSApplicationInterface , ConsoleApplication , CalendarField , CaptchaField , CheckboxesField , ColorField , ComboField , ComponentlayoutField , ContenthistoryField , ContenttypeField , EditorField , EmailField , FileField , GroupedlistField , HiddenField , ListField , MediaField , MeterField , ModulelayoutField , ModuleorderField , ModulepositionField , NoteField , NumberField , OrderingField , PasswordField , RadiobasicField , RangeField , RulesField , SpacerField , SubformField , TagField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , Form , FormField , PrefixField , PlugininfoField , AssociationField , ClicksField , ImpmadeField , ImptotalField , CategoryeditField , FiltersField , FieldcontextsField , FieldLayoutField , SectionField , OAuthCallbackEvent , MenuOrderingField , MenutypeField , ModulesPositioneditField , WorkflowcontextsField , ConsentBoxField , TemplatesListField , UploaddirsField , PrivacyField , TermsField , JoomlatokenField , ConsoleEvent , Parameters
  • getInputArgumentData() : JsonDescriptor
  • getInputArgumentDocument() : XmlDescriptor
  • getInputDefinitionData() : JsonDescriptor
  • getInputDefinitionDocument() : XmlDescriptor
  • getInputForRequestMethod() : Input
  • getInputOptionData() : JsonDescriptor
  • getInputOptionDocument() : XmlDescriptor
  • getInputString() : ErrorListener
  • getInputToVerify() : JWSVerifier
  • getInstallationXML() : InstallerHelper
  • getInstalled() : InstalledVersions
  • getInstalledlangs() : LanguagesModel , PlgSampledataMultilang
  • getInstalledlangsAdministrator() : LanguagesModel , PlgSampledataMultilang
  • getInstalledlangsFrontend() : LanguagesModel , PlgSampledataMultilang
  • getInstalledPackages() : InstalledVersions
  • getInstalledPackagesByType() : InstalledVersions
  • getInstallFrom() : PlgInstallerWebinstaller
  • getInstallPath() : InstalledVersions
  • getInstance() : Inflector , CliApplication , CMSApplication , WebApplication , Authentication , Cache , CacheController , Captcha , Categories , FtpClient , Date , Document , Editor , Browser , Patcher , InputFilter , Form , UserGroupsHelper , Installer , Language , Mail , AbstractMenu , BaseController , Pathway , Profiler , Router , ChangeItem , ChangeSet , Session , Table , Toolbar , Updater , Uri , User , Language , Parser , DatabaseDriver , ContainerResource , FtpClient , Patcher , Inflector , ZIPExtraction
  • getInstances() : InstallerScript
  • getInstructions() : Result
  • getInteger() : Uuid , UuidInterface
  • getIntegralPart() : BigDecimal
  • getInterlace() : DisplayPNGCharacteristicsDescriptor
  • getInvalidParameter() : InvalidParameterException
  • getInvocations() : PharInvocationCollection
  • getInvTables() : Rijndael
  • getIp() : IpHelper
  • getIrregular() : Inflectible , Ruleset , Inflectible
  • getIsEmptyState() : ListModel
  • getIssuerDN() : X509
  • getIssuerDNProp() : X509
  • getItem() : AbstractMenu , AdminModel , ItemModelInterface , AssociationsHelper , CategoryModel , AssociationsHelper , ContactModel , FormModel , AssociationsHelper , ArticleModel , FormModel , FieldModel , GroupModel , Adapter , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , AdapterModel , MediumModel , AssociationsHelper , ItemModel , MenuModel , ConfigModel , MessageModel , ModuleModel , AssociationsHelper , NewsfeedModel , PluginModel , MessagesModel , TaskModel , TagModel , StyleModel , LevelModel , NoteModel , UserModel , TransitionModel
  • getItemArray() : InstallerScript
  • getItemId() : OrderingField
  • getItemid() : RouteHelper
  • getItemId() : PluginorderingField
  • getItemIdFromInput() : HistoryController
  • getItemMenuTitle() : Adapter
  • getItemRoute() : RouteHelper
  • getItems() : LanguagesModel , AbstractMenu , SiteMenu , ListModel , ListModelInterface , Toolbar , ClientsModel , BannersModel , CategoriesModel , CheckinModel , CategoriesModel , CategoryModel , FeaturedModel , ArticlesModel , CategoriesModel , CategoryModel , FeaturedModel , HistoryModel , Adapter , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , LanguagesModel , UpdatesitesModel , WarningsModel , TemplatesModel , FetchMediaItemsEvent , AdaptersModel , MediaModel , ItemsModel , MenusModel , PositionsModel , SelectModel , CategoriesModel , CategoryModel , Domain , SelectModel , TagsModel , TagModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , UsersModel , WorkflowsModel
  • getItemTags() : TagsHelper
  • getItemTypes() : AssociationExtensionHelper
  • getIterator() : InfiniteListObject , InfiniteMapObject , ListObject , MapObject , Construct , DataObject , DatabaseDriver , DatabaseFactory , ListenersPriorityQueue , Registry , Session , JWKSet , HelperSet , TableRows , Collection , Data , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , PublicKeyCredentialDescriptorCollection
  • getIV() : SymmetricKey
  • getJavascriptClass() : JavascriptRenderer
  • getJavascriptRenderer() : DebugBar
  • getJoomlaFilesExtensionId() : MessagesModel
  • getJoomlaUpdateSitesIds() : UpdatesitesModel
  • getJsControlsDefinitionCode() : JavascriptRenderer
  • getJSFPoints() : Prime
  • getJsInitializationCode() : JavascriptRenderer
  • getJson() : RequestController
  • getJwsPayload() : MetadataStatementFetcher
  • getJwsVerifier() : JWSLoader
  • getKey() : MapItem , ECKey , HMAC , HS256 , HS384 , HS512 , BaseSigner , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getKeyLength() : Ecdsa , Sha256 , Sha384 , Sha512 , SymmetricKey , RC2
  • getKeyLookup() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getKeyName() : Table , TableInterface
  • getKeyProtection() : MetadataStatement
  • getKeys() : Container
  • getKeySql() : MysqlImporter , MysqliImporter
  • getKeyType() : Ecdsa , OpenSSL , Rsa
  • getKnownAuthenticators() : Authentication , MetadataRepository
  • getKnownColors() : ColorStyle
  • getKnownLanguages() : LanguageHelper
  • getKnownOptions() : ColorStyle
  • getLabel() : NoteField , SpacerField , Form , FormField , CategoryField , ContactField , ArticleField , MenuField , NewsfeedField , ConsentBoxField , PrivacyField , TosField , TermsField , RSA
  • getLangswitchers() : MultilangstatusHelper
  • getLangTag() : HelpModel
  • getLanguage() : CliApplication , CMSApplicationInterface , ConsoleApplication , WebApplication , Document , Factory , PlgExtensionFinder
  • getLanguageCookie() : PlgSystemLanguageFilter
  • getLanguageFilter() : SiteApplication
  • getLanguagefilterPluginId() : AssociationsHelper
  • getLanguageFromInput() : OverridesController
  • getLanguageId() : CMSHelper , ContentHelper
  • getLanguageList() : LanguagesModel , LoginHelper , PlgSampledataMultilang
  • getLanguageManifest() : LanguagesModel
  • getLanguagePath() : LanguageHelper
  • getLanguages() : SetupModel , LanguagesModel , TemplatesModel
  • getLastDateTimeErrors() : AbstractTime
  • getLastError() : SSH2
  • getLastErrorMessage() : File
  • getLastMessageID() : PHPMailer
  • getLastReply() : SMTP
  • getLastSFTPError() : SFTP
  • getLastTag() : Changelog
  • getLastTransactionID() : SMTP
  • getLayout() : ActionButton , HtmlView , ToolbarButton
  • getLayoutData() : AbstractModuleDispatcher , CalendarField , CheckboxesField , CheckboxField , ColorField , ComboField , ContenthistoryField , EmailField , FileField , HiddenField , MediaField , MeterField , ModuleorderField , NumberField , PasswordField , RadiobasicField , RadioField , RangeField , RulesField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , FormField , Dispatcher , ConsentBoxField , TinymcebuilderField , PrivacyField , DataField , TermsField , JoomlatokenField , PlgSystemStats
  • getLayoutFile() : HtmlView
  • getLayoutId() : FileLayout
  • getLayoutPath() : ModuleHelper , PluginHelper
  • getLayoutPaths() : FormField , WebcronLinkField , AbstractStatsField , JoomlatokenField , PlgSystemStats
  • getLayoutTemplate() : HtmlView
  • getLazyClosures() : OptionsResolverIntrospector
  • getLdapServiceId() : LdapBadge
  • getLE() : PHPMailer
  • getLeastSignificantBits() : Uuid
  • getLeastSignificantBitsHex() : Uuid , UuidInterface
  • getLeftSibling() : CategoryModel
  • getLegalHeader() : MetadataStatement , MetadataTOCPayload
  • getLength() : ByteStringObject , ByteStringWithChunkObject , TextStringObject , TextStringWithChunkObject , Hash , DSA , Base , EC , Hash , RSA , Engine , BigInteger , BinaryField , PrimeField
  • getLengthInBytes() : Base , Hash , Engine , BigInteger , BinaryField , PrimeField
  • getLengthOfArray() : LengthCalculator
  • getLengthOfString() : LengthCalculator
  • getLevelName() : SlimCollector
  • getLevelsOptions() : DebugHelper
  • getLexer() : TraceableTwigEnvironment
  • getLibrary() : LibraryHelper
  • getLimit() : Parameters
  • getLimitBox() : Pagination
  • getLine() : AbstractSerializer , FlattenException , SilencedErrorContext
  • getLineTag() : Parser
  • getLink() : Document , SyndicateHelper
  • getLinkKey() : MenusHelper
  • getLinkProvider() : PreloadManager , PreloadManagerInterface
  • getLinks() : LinkProviderInterface , GenericLinkProvider , AbstractSerializer , SerializerInterface
  • getLinksByRel() : LinkProviderInterface , GenericLinkProvider
  • getList() : ArticlesArchiveHelper , ArticlesCategoriesHelper , ArticlesCategoryHelper , ArticlesLatestHelper , ArticlesNewsHelper , ArticlesPopularHelper , BannersHelper , BreadcrumbsHelper , LanguagesHelper , LatestHelper , LoggedHelper , PopularHelper , SampledataHelper , StatsHelper , TagsPopularHelper , TagsSimilarHelper
  • getListenerPriority() : Dispatcher
  • getListeners() : Dispatcher , DispatcherInterface
  • getListFooter() : Pagination
  • getListQuery() : ListModel , ActionlogsModel , AssociationsModel , BannersModel , ClientsModel , TracksModel , BannersModel , CategoriesModel , ContactsModel , FeaturedModel , ArticlesModel , FeaturedModel , ArchiveModel , FeaturedModel , HistoryModel , FieldsModel , GroupsModel , Adapter , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , DiscoverModel , ManageModel , UpdateModel , UpdatesitesModel , LanguagesModel , TemplatesModel , ItemsModel , MenusModel , MessagesModel , ModulesModel , SelectModel , NewsfeedsModel , PluginsModel , ConsentsModel , RequestsModel , LinksModel , TasksModel , TagsModel , TagModel , TagsModel , StylesModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NotesModel , UsersModel , StagesModel , TransitionsModel , WorkflowsModel , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • getLoadedFormat() : AsymmetricKey
  • getLoader() : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f , TraceableTwigEnvironment
  • getLocale() : LocalizationCollector , Language , AsciiSlugger
  • getLocalise() : InstallationApplication
  • getLocaliseAdmin() : InstallationApplication
  • getLocality() : CertificateSubject
  • getLocalName() : CSR
  • getLocalPath() : LocalAdapter
  • getLog() : SSH2
  • getLogContentTypeParams() : ActionlogsHelper , ActionlogConfigModel
  • getLogDataAsIterator() : ActionlogsModel
  • getLogDataQuery() : ActionlogsModel
  • getLogFiles() : PlgSystemLogrotation
  • getLogger() : Propel2Collector , AbstractApplication
  • getLoggerClass() : LoggerRegistry
  • getLoginModule() : LoginModel
  • getLogs() : DebugMonitor
  • getLogsData() : ActionlogsModel
  • getLogsForItem() : ActionlogsModel
  • getLongVersion() : ConsoleApplication , Version , Application
  • getLookupValue() : ContenthistoryHelper
  • getLowerLimitSearchWord() : En_GBLocalise , Fr_FRLocalise , Language
  • getLowerLimitSearchWordCallback() : Language
  • getLowestSetBit() : BigInteger
  • getMachineContent() : Microdata
  • getMailer() : Factory
  • getMailMIME() : PHPMailer
  • getMajor() : Browser , Version
  • getMajorType() : AbstractCBORObject , CBORObject , UnsignedIntegerObject
  • getManagerState() : WebAssetManager
  • getManifest() : Installer , InstallerAdapter , Container
  • getManifestLength() : Manifest
  • getMantissa() : DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject
  • getMappedAlias() : Stub
  • getMapping() : X509
  • getMarks() : Profiler
  • getMaster() : TemplateModel
  • getMatcherProtection() : MetadataStatement
  • getMatchingRoutes() : ApiRouter
  • getMaxAttempts() : Question
  • getMaxRetries() : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • getMaxSteps() : ProgressBar
  • getMaxTemplates() : BiometricAccuracyDescriptor
  • getMaxUploadSize() : Utility
  • getMeasures() : TimeDataCollector , ProfileCollector
  • getMediaFiles() : TemplateModel
  • getMediaVersion() : Document , Version
  • getMemoryLimit() : DemoTasks
  • getMemoryLogs() : DebugMonitor
  • getMemoryUsage() : TraceablePDO , TracedStatement
  • getMenu() : CMSApplication , CMSWebApplicationInterface , InstallationApplication , AbstractMenu , ItemsModel
  • getMenuBadgeData() : DisplayController , DatabaseController , DiscoverController , DisplayController , UpdateController , DisplayController
  • getMenuItems() : MenusHelper
  • getMenuLanguage() : LoginModel
  • getMenuLinks() : MenusHelper
  • getMenuType() : ItemModel
  • getMenuTypeId() : ItemController , ItemModel
  • getMenuTypes() : MenusHelper
  • getMergeProperty() : AggregatedCollector
  • getMessage() : ProgressBar , FlattenException
  • getMessageQueue() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • getMessages() : MonologCollector , MessagesAggregateInterface , MessagesCollector , DumpServer
  • getMeta() : AbstractSerializer , SerializerInterface
  • getMetadata() : CategoryNode
  • getMetaData() : Document
  • getMetadata() : LanguageHelper , CallbackStream , RelativeStream , Stream , StreamInterface
  • getMetaData() : Manifest
  • getMetaDataLength() : Manifest
  • getMetadataRepository() : Authentication
  • getMetadataStatement() : DistantSingleMetadata , SingleMetadata
  • getMetadataStatementFor() : MetadataService
  • getMetadataTOCPayload() : MetadataService
  • getMethod() : MethodModel , Input , RequestInterface
  • getMethodArgs() : Container
  • getMethodId() : Router
  • getMethodImage() : CaptiveModel
  • getMethods() : MethodsModel , Route
  • getMethodSegment() : Router
  • getMfaMethods() : Mfa
  • getMGF1() : PSSRSA , RSA
  • getMGFHash() : RSA
  • getMimeEncoding() : Document
  • getMimeType() : MediaHelper , TracksModel
  • getMinComplexity() : PatternAccuracyDescriptor
  • getMinimum() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver
  • getMinimumServerVersion() : DatabaseHelper
  • getMinLength() : CodeAccuracyDescriptor
  • getMinor() : Browser , Version
  • getMissingDownloadKeyInfo() : PlgQuickiconDownloadkey
  • getMissingModuleLanguages() : MenusModel
  • getMissingOptions() : OptionsResolver
  • getModality() : BiometricStatusReport
  • getMode() : SymmetricKey
  • getModel() : BaseController , FormController , AbstractView , ViewInterface , ActionlogsController , AssociationsController , BannersController , ClientsController , TracksController , CategoriesController , ContactsController , ContactController , ArticlesController , FeaturedController , ArticleController , HistoryController , PreviewController , FieldsController , GroupsController , FiltersController , IndexController , MapsController , UpdatesitesController , LanguagesController , ApiController , DisplayController , ItemsController , MenusController , MessagesController , ModulesController , NewsfeedsController , PluginsController , RequestsController , LinksController , TasksController , TagsController , StylesController , TemplateController , GroupsController , LevelsController , NotesController , UsersController , StagesController , TransitionsController , WorkflowsController
  • getModelName() : WorkflowServiceInterface , ContentComponent
  • getModifiedDate() : Document
  • getModMenuId() : MenusModel
  • getModule() : ModuleHelper , MultilangstatusHelper
  • getModuleById() : ModuleHelper
  • getModules() : ModuleHelper , ItemModel , MenuModel , MenusModel , ModulesHelper
  • getModulo() : Binary , Prime , TwistedEdwards , Integer
  • getModulus() : RSAKey
  • getModulusLength() : RSAKey
  • getMonitor() : DatabaseDriver
  • getMostSignificantBits() : Uuid
  • getMostSignificantBitsHex() : Uuid , UuidInterface
  • getMultipleRunDates() : CronExpression
  • getMVCFactory() : LegacyComponent , MVCFactoryServiceInterface
  • getNAF() : Integer
  • getNAFPoints() : Prime
  • getName() : CacheCacheCollector , DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SlimCollector , SwiftLogCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , DataCollectorInterface , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , RequestDataCollector , TimeDataCollector , Identifier , OID , CMSApplication , CMSApplicationInterface , ConsoleApplication , RouterView , JsonDocument , XmlDocument , SubformField , Form , FormField , InstallerAdapter , Language , BaseController , BaseModel , ModelInterface , WorkflowModelInterface , AbstractView , Toolbar , ToolbarButton , WebAssetItem , WebAssetItemInterface , Application , AbstractCommand , DescriptorHelper , DatabaseDriver , DatabaseInterface , QueryElement , AbstractEvent , EventInterface , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Basic , Claim , Application , Command , DebugFormatterHelper , DescriptorHelper , FormatterHelper , HelperInterface , ProcessHelper , QuestionHelper , InputArgument , InputOption , PublicKeyCredentialEntity
  • getNames() : WritableContainerLoader , ContainerLoader , LoaderInterface , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader
  • getNamesKey() : PgsqlDriver
  • getNamespaces() : JLoader , JNamespacePsr4Map , Application , ApplicationDescription , Application , ApplicationDescription
  • getNativeDefinition() : Command , LazyCommand
  • getNativeLanguage() : LanguageField
  • getNearestWeekday() : DayOfMonthField
  • getNegotiatedVersion() : SFTP
  • getNewInstance() : Container
  • getNewsfeedId() : Router
  • getNewsfeedRoute() : RouteHelper
  • getNewsfeedSegment() : Router
  • getNextEmbedBlock() : Parser
  • getNextOrder() : Table
  • getNextRunDate() : CronExpression
  • getNextUpdate() : MetadataTOCPayload
  • getNistCurveSize() : ECKey
  • getNo() : MetadataTOCPayload
  • getNode() : DegradedUuid , FallbackNodeProvider , RandomNodeProvider , SystemNodeProvider , NodeProviderInterface , Uuid
  • getNodeByTitle() : Taxonomy
  • getNodeHex() : Uuid , UuidInterface
  • getNodeProvider() : FeatureSet , UuidFactory
  • getNodeVisitors() : TraceableTwigEnvironment
  • getNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getNonceAttribute() : JavascriptRenderer
  • getNonCoreExtensions() : UpdateModel
  • getNonCorePlugins() : UpdateModel
  • getNonDefaultOptions() : MemcachedCaster
  • getNormalizedData() : ByteStringObject , ByteStringWithChunkObject , CBORObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , BreakObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , TrueObject , UndefinedObject , SignedIntegerObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject
  • getNormalizedValue() : BaseAccept
  • getNormalizer() : Question , OptionsResolverIntrospector
  • getNormalizers() : OptionsResolverIntrospector
  • getNote() : ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand
  • getNullDate() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver
  • getNumberConverter() : FeatureSet , Uuid , UuidFactory , UuidInterface
  • getNumberOfChildren() : Construct
  • getNumberOfColumns() : Table
  • getNumberOfLengthOctets() : ASNObject
  • getNumberOfUnusedBits() : BitString
  • getNumberUrgentRequests() : RequestsModel , PrivacyStatusHelper
  • getNumerator() : BigRational
  • getNumItems() : CategoryNode
  • getNumRecords() : MfaTable
  • getNumRows() : DatabaseDriver , DatabaseInterface
  • getOAuth() : PHPMailer
  • getOauth64() : OAuth , OAuthTokenProvider
  • getObjectLength() : ASNObject
  • getObjectsKeys() : DataSet
  • getOffset() : ParserException , Parameters
  • getOffsetFromGmt() : Date
  • getOffsetFromNumber() : Parameters
  • getOID() : ASN1
  • getOnlineCount() : WhosonlineHelper
  • getOnlineUserNames() : WhosonlineHelper
  • getOpenHandlerClass() : JavascriptRenderer
  • getOpenHandlerUrl() : JavascriptRenderer
  • getOpensslAlgorithmFor() : Algorithms
  • getOpensslCurveName() : ECKey
  • getOperatingEnv() : MetadataStatement
  • getOption() : ActionButton , ToolbarButton , WebAssetItem , WebAssetItemInterface , InstalledModel , PdoDriver , AbstractTransport , Http , Client , Input , InputDefinition , InputInterface , Connection , ConnectionOptions
  • getOptionConstants() : MemcachedCaster
  • getOptionDefaults() : InputDefinition
  • getOptionForShortcut() : InputDefinition
  • getOptionFromToken() : CompletionInput
  • getOptionName() : ConnectionOptions
  • getOptions() : ActionButton , SetConfigurationCommand , AccesslevelField , AliastagField , AuthorField , CachehandlerField , CategoryField , ComponentsField , ContentlanguageField , ContenttypeField , DatabaseconnectionField , FilelistField , FolderlistField , FrontendlanguageField , HeadertagField , ImagelistField , IntegerField , LanguageField , LimitboxField , ListField , ModuletagField , PluginsField , PredefinedlistField , SessionhandlerField , SqlField , TagField , TextField , TransitionField , UsergrouplistField , WorkflowComponentSectionsField , WorkflowconditionField , LanguageField , ChecksModel , DatabaseModel , LanguagesModel , SetupModel , BaseLayout , ToolbarButton , WebAssetItem , WebAssetItemInterface , ExtensionField , LogcreatorField , LogtypeField , ItemlanguageField , BannerclientField , CategoryeditField , ComponentsCategoryField , ConfigComponentsField , ComponentsFieldgroupField , ComponentsFieldsField , FieldcontextsField , FieldgroupsField , SubfieldsField , TypeField , BranchesField , ContenttypesField , SearchfilterField , ExtensionstatusField , FolderField , LocationField , PackageField , TypeField , LanguageclientField , MenuOrderingField , MenuParentField , MenuPresetField , MessageStatesField , ModulesModuleField , ModulesPositionField , NewsfeedsField , PluginElementField , PluginTypeField , RedirectField , CronField , TaskTypeField , TemplatelocationField , TemplatenameField , GroupparentField , LevelsField , ComponentsWorkflowField , WorkflowcontextsField , FontsField , TemplatesListField , UploaddirsField , TableCellStyle , Input , InputDefinition , InputInterface
  • getOptionsFromField() : FieldsListPlugin , PlgFieldsSubform
  • getOptionSuggestions() : CompletionSuggestions
  • getOrder() : Base
  • getOrderedElements() : AbstractNegotiator
  • getOrganization() : CertificateSubject
  • getOrganizationalUnit() : CertificateSubject , CSR
  • getOrganizationName() : CSR
  • getOrientation() : Image
  • getOrientationString() : Image
  • getOrigin() : CollectedClientData
  • getOrphans() : Language
  • getOtherInformationMessage() : DatabaseModel
  • getOtpConfig() : UserModel
  • getOtpConfigEncryptionKey() : UserModel
  • getOutput() : CliApplication , ConsoleEvent
  • getOverridePluginId() : PlgQuickiconOverrideCheck
  • getOverrides() : OverridesModel
  • getOverridesFolder() : TemplateModel
  • getOverridesList() : TemplateModel
  • getOwnFields() : Resource
  • getOwnInterfaces() : DebugClassLoader
  • getPackageUrl() : LanguagesModel
  • getPadByAlign() : TableCellStyle
  • getPadding() : RSA
  • getPaddingChar() : TableStyle
  • getPaDesc() : VerificationMethodDescriptor
  • getPadType() : TableStyle
  • getPage() : HelpModel , Parameters
  • getPagesCounter() : Pagination
  • getPagesLinks() : Pagination
  • getPageTitle() : CaptiveModel , MethodModel
  • getPagination() : ListModel , CacheModel , CategoryModel , AdaptersModel , MediaModel
  • getPaginationLinks() : Pagination
  • getPaginationPages() : Pagination
  • getParam() : InstallerScript , User
  • getParameter() : BaseAccept
  • getParameterClassName() : OptionsResolver
  • getParameterOption() : ArgvInput , ArrayInput , InputInterface
  • getParameters() : TracedStatement , BaseAccept , DH , DSA , EC , ArgsStub , TPMAttestationStatementSupport
  • getParams() : SiteApplication , CategoryNode , ComponentHelper , ComponentRecord , LibraryHelper , Installer , AbstractMenu , MenuItem , FieldModel , WrapperHelper
  • getParamsFromField() : PlgFieldsSubform
  • getParent() : TraceableTwigTemplate , AdapterInstance , InstallerAdapter , ToolbarButton , ImmutableNodeInterface , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel
  • getParentLocale() : AsciiSlugger
  • getParsedBody() : ServerRequest , ServerRequestInterface
  • getParsedFile() : ParseException
  • getParsedLine() : ParseException
  • getParser() : TraceableTwigEnvironment , LintCommand
  • getParsers() : FeedFactory
  • getParts() : CronExpression
  • getPass() : AbstractUri , UriInterface
  • getPassphrase() : Key
  • getPassword() : Encrypt , LdapUser
  • getPasswordHash() : PHPassHandler
  • getPastTransition() : HoursField
  • getPath() : CategoryNode , RouterView , Image , LanguagesModel , Installer , FileLayout , Nested , InstalledModel , ApiController , AbstractUri , UriInterface , Uri , PlgSampledataMultilang , UriInterface
  • getPathInformation() : LocalAdapter
  • getPaths() : Language
  • getPathway() : CMSApplication , SiteApplication , Pathway
  • getPathwayNames() : Pathway
  • getPattern() : Pattern , Transformation , Route
  • getPayload() : JWT , JWS , JsonResponse , Token
  • getPBES1EncryptionObject() : PKCS8
  • getPBES1Hash() : PKCS8
  • getPBES1KDF() : PKCS8
  • getPBES2EncryptionObject() : PKCS8
  • getPeakMemoryUsage() : TraceablePDO
  • getPeakUsage() : MemoryCollector
  • getPeriod() : Totp
  • getPermissions() : Path
  • getPHPInfo() : SysinfoModel
  • getPhpInfoArray() : SysinfoModel
  • getPhpMaxExecTime() : ZIPExtraction
  • getPhpOptions() : ChecksModel , UpdateModel
  • getPhpOptionsSufficient() : ChecksModel
  • getPhpSettings() : ChecksModel , SysinfoModel , UpdateModel
  • getPhpSupport() : PlgQuickiconPhpVersionCheck
  • getPKCredentialRequestOptions() : Authentication
  • getPlaceholderFormatterDefinition() : ProgressBar , ProgressIndicator
  • getPlatform() : Browser
  • getPlatformPrefix() : Cache
  • getPlte() : DisplayPNGCharacteristicsDescriptor
  • getPlugin() : PluginHelper
  • getPluginState() : IndexModel
  • getPluginType() : Adapter
  • getPlural() : Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected
  • getPluralRuleset() : GenericLanguageInflectorFactory , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules
  • getPluralSuffixes() : En_GBLocalise , Fr_FRLocalise , Language
  • getPluralSuffixesCallback() : Language
  • getPort() : AbstractUri , UriInterface , Uri , UriInterface
  • getPositions() : ModulesModel , ModulesHelper , TemplatesHelper
  • getPrecision() : Engine , BigInteger
  • getPreferredFormat() : SerializerErrorRenderer
  • getPrefix() : DatabaseDriver
  • getPrefixes() : ClassLoader
  • getPrefixesPsr4() : ClassLoader
  • getPreloadManager() : Document
  • getPreparedId() : TracedStatement
  • getPresets() : MenusHelper
  • getPrettyName() : LazyString
  • getPrettyVersion() : InstalledVersions
  • getPreview() : TemplateModel
  • getPrevious() : FlattenException
  • getPreviousRunDate() : CronExpression
  • getPrimaryKey() : Table , UCMContent
  • getPrimaryLanguage() : Helper
  • getPrimes() : RSAKey
  • getPriority() : ListenersPriorityQueue
  • getPrivacyArticleId() : PlgSystemPrivacyconsent
  • getPrivacyConsentPluginId() : PrivacyHelper
  • getPrivacyItemId() : PlgSystemPrivacyconsent
  • getPrivacyPolicyInfo() : PrivacyStatusHelper
  • getPrivate() : Key
  • getPrivateExponent() : RSAKey
  • getPrivateKey() : Keychain , OpenSSL
  • getProcessedHelp() : AbstractCommand , Command , LazyCommand
  • getProcessor() : CliOutput
  • getProfile() : UserHelper
  • getProgress() : ProgressBar
  • getProgressBar() : SymfonyStyle
  • getProgressCharacter() : ProgressBar
  • getProgressPercent() : ProgressBar
  • getPrompt() : ChoiceQuestion
  • getProperties() : CMSObject
  • getProperty() : Microdata , DataObject
  • getPropertyPath() : AssertionFailedException , InvalidArgumentException
  • getProtectedHeader() : Signature
  • getProtectedHeaderParameter() : Signature
  • getProtocolFamily() : MetadataStatement
  • getProtocolVersion() : MessageInterface
  • getProvidedServices() : ServiceProviderInterface
  • getProvider() : ProviderManager
  • getProviderManager() : MediaProviderEvent
  • getProviderName() : ProviderAwareAuthenticationPluginInterface
  • getProviders() : MediaModel , ProviderManager
  • getPubKeyCreationOptions() : Authentication
  • getPubKeyCredParams() : PublicKeyCredentialCreationOptions
  • getPubKeyDescriptorsForUser() : Credentials , Authentication
  • getPubkeyRequestOptions() : Authentication
  • getPublic() : Key
  • getPublicExponent() : RSAKey
  • getPublicKey() : CSR , Keychain , OpenSSL , PrivateKey , X509 , Identity
  • getPublicKeyAlgAndEncoding() : MetadataStatement
  • getPublicKeyAlgAndEncodings() : MetadataStatement
  • getPublicKeyCredentialDescriptor() : PublicKeyCredential , PublicKeyCredentialSource
  • getPublicKeyCredentialId() : PublicKeyCredentialSource
  • getPunycodePrefix() : AbstractPunycode , PunycodeInterface
  • getQuality() : BaseAccept
  • getQuery() : OrderingField , SearchModel , PluginorderingField , DatabaseDriver , DatabaseFactory , DatabaseInterface , ExecutionFailureException , FinderHelper , AbstractUri , UriInterface , Uri , UriInterface
  • getQueryCount() : Propel2Collector
  • getQueryDate() : QueryHelper
  • getQueryParams() : ServerRequest , ServerRequestInterface
  • getQueryString() : LdapBadge
  • getQuestion() : Question
  • getQuickiconContent() : DisplayController , CategoriesController , DisplayController , ArticlesController , ItemsController , ModulesController , PluginsController , TagsController , UsersController
  • getR() : RgbPaletteEntry
  • getRandom() : PgsqlDriver
  • getRandomGenerator() : FeatureSet , UuidFactory
  • getRandomImage() : RandomImageHelper
  • getRangeForExpression() : AbstractField
  • getRangeOptions() : UsersHelper
  • getRaw() : Json
  • getRawAttestationObject() : AttestationObject
  • getRawBytes() : Key
  • getRawData() : InstalledVersions , CollectedClientData
  • getRawId() : PublicKeyCredential
  • getRealCurrentLineNb() : Parser
  • getRealTableName() : DatabaseImporter
  • getRealUsage() : MemoryCollector
  • getReason() : MailDisabledException
  • getReasonPhrase() : Response , ResponseInterface
  • getRecord() : Task
  • getRecords() : CaptiveModel
  • getRedirectMessage() : PlgSystemPrivacyconsent
  • getRedirectPluginId() : RedirectHelper
  • getRedirectToItemAppend() : FormController , CategoryController , ContactController , ArticleController , FieldController , GroupController , LanguageController , TemplateController , ModuleController , NoteController , StageController , TransitionController , WorkflowController
  • getRedirectToListAppend() : AdminController , FormController , CategoriesController , CategoryController , HistoryController , FieldController , GroupController , ItemsController , ModuleController , ModulesController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController
  • getRedirectUrl() : Installer
  • getRedisOptions() : RedisCaster
  • getRef() : StringController
  • getReference() : InstalledVersions
  • getRegex() : Pattern , Route
  • getRegisteredExtension() : X509
  • getRegisteredLoaders() : ClassLoader
  • getRegistrationUrl() : LoginHelper
  • getRegistry() : WebAssetManager
  • getRegistryFiles() : WebAssetRegistry
  • getRegular() : Ruleset
  • getRelationship() : OnGetApiRelation , AbstractSerializer , SerializerInterface
  • getRelationshipMethodName() : AbstractSerializer
  • getRelationships() : Resource
  • getRelationshipsAsArray() : Resource
  • getRelativeRoot() : JavascriptRenderer
  • getRelevantToken() : CompletionInput
  • getRels() : LinkInterface , Link
  • getRemaining() : ProgressBar
  • getRenderedTemplates() : TraceableTwigEnvironment
  • getRenderer() : AbstractRenderer , FormField , PlgSystemStats
  • getRenderOptions() : MethodModel
  • getReorderConditions() : AdminModel , BannerModel , CategoryModel , ContactModel , ArticleModel , FeatureModel , FieldModel , GroupModel , ItemModel , ModuleModel , NewsfeedModel , PluginModel , StagesModel , TransitionsModel , WorkflowModel
  • getReplacement() : Transformation
  • getReplyToAddresses() : PHPMailer
  • getRequest() : NetworkExceptionInterface , RequestExceptionInterface
  • getRequestDuration() : TimeDataCollector , ProfileCollector
  • getRequestEndTime() : TimeDataCollector , ProfileCollector
  • getRequestFormPublished() : PrivacyStatusHelper
  • getRequestIdGenerator() : DebugBar
  • getRequestLine() : Serializer
  • getRequestStartTime() : TimeDataCollector , ProfileCollector
  • getRequestTarget() : RequestInterface
  • getRequiredOptions() : OptionsResolver
  • getRequiredTermIds() : Query
  • getReservedForFutureUse1() : AuthenticatorData
  • getReservedForFutureUse2() : AuthenticatorData
  • getResetCompleteForm() : ResetModel
  • getResetConfirmForm() : ResetModel
  • getResource() : AdapterInterface , Container , LocalAdapter , Connection , Query
  • getResourceId() : SSH2
  • getResources() : Query , Collection , ElementInterface , Resource
  • getResponse() : AbstractWebApplication , WebApplicationInterface , CurlTransport , SocketTransport , StreamTransport , UnexpectedResponseException , Curl , Socket , Stream , POP3 , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PublicKeyCredential
  • getResponseBody() : AndroidSafetyNetAttestationStatementSupport
  • getResponseInfo() : InfoCollector
  • getResult() : AbstractUsernamePasswordAuthenticationStrategy , AuthenticationStrategyInterface
  • getResults() : Authentication
  • getResultsCounter() : Pagination
  • getResultSnapshot() : ExecuteTaskEvent
  • getReturnPage() : ContactController , FormModel , ArticleController , FormModel
  • getReturnUri() : LoginHelper
  • getReturnUrl() : LoginHelper
  • getReverseLookup() : MenutypesModel
  • getRevoked() : X509
  • getRevokedCertificateExtension() : X509
  • getRevokedCertificateExtensions() : X509
  • getRightSibling() : CategoryModel
  • getRogueListHash() : MetadataTOCPayloadEntry
  • getRogueListURL() : MetadataTOCPayloadEntry
  • getRoles() : LdapUser
  • getRoot() : ImmutableNodeInterface
  • getRootId() : Nested
  • getRootPackage() : InstalledVersions
  • getRoute() : RouteHelper , InstallerAdapter
  • getRoutePath() : ApiRouter
  • getRouter() : AdministratorApplication , CMSApplication , CMSWebApplicationInterface , ConsoleApplication , SiteApplication
  • getRoutes() : Router , RouterInterface
  • getRouteVariables() : ResolvedRoute , Route
  • getRoutineId() : ExecuteTaskEvent
  • getRowColumns() : Table
  • getRowCount() : TracedStatement
  • getRowData() : CMSHelper , ContentHelper
  • getRowOffset() : Pagination
  • getRowspan() : TableCell
  • getRp() : PublicKeyCredentialCreationOptions
  • getRpId() : PublicKeyCredentialRequestOptions
  • getRpIdHash() : AuthenticatorData
  • getRules() : RouterView , Router , Table , Route
  • getRunDate() : CronExpression
  • getRunningTime() : ZIPExtraction
  • gets() : Stream
  • getSafeData() : SysinfoModel
  • getSafeName() : TemplateModel , LocalAdapter
  • getSalt() : LdapUser
  • getSaltLength() : RSA
  • getSaturation() : Color
  • getScale() : BigDecimal
  • getSchema() : ChangeSet
  • getSchemaVersion() : DatabaseModel
  • getScheme() : AbstractUri , UriInterface , Uri , UriInterface
  • getScore() : Response
  • getScreen() : ANSI
  • getScreenHelper() : ANSI
  • getScriptClassName() : PluginAdapter , InstallerAdapter
  • getScriptOptions() : Document
  • getScriptStrings() : Text
  • getSearchDisplayedCharactersNumber() : En_GBLocalise , Fr_FRLocalise , Language
  • getSearchDisplayedCharactersNumberCallback() : Language
  • getSearchDn() : LdapBadge
  • getSearchPassword() : LdapBadge
  • getSearchRoute() : RouteHelper
  • getSefString() : LanguageAdapter
  • getSelfAttestedFAR() : BiometricAccuracyDescriptor
  • getSelfAttestedFRR() : BiometricAccuracyDescriptor
  • getSentMIMEMessage() : PHPMailer
  • getSeqLookup() : PgsqlImporter
  • getSequenceIsCalled() : PgsqlDriver
  • getSequenceLastValue() : PgsqlDriver
  • getSerialised() : ZIPExtraction
  • getSerializer() : Resource
  • getSerializerManager() : JWSLoader
  • getServerAlgorithms() : SSH2
  • getServerExt() : SMTP
  • getServerExtList() : SMTP
  • getServerIdentification() : SSH2
  • getServerParams() : ServerRequest , ServerRequestInterface
  • getServerPublicHostKey() : SSH2
  • getServerType() : DatabaseDriver , DatabaseInterface
  • getService() : Registry
  • getServiceLocator() : ServiceLocatorTest
  • getServiceRegistry() : HTMLHelper
  • getSession() : SessionAwareWebApplicationInterface , CliApplication , ConsoleApplication , Factory , SessionEvent , ServiceProviderInterface
  • getSessionService() : SessionGcCommand
  • getSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • getSetvalSequenceSql() : PgsqlImporter
  • getSeverity() : SilencedErrorContext , ThrowableUtils
  • getSFTPErrors() : SFTP
  • getSFTPLog() : SFTP
  • getSha1() : ContentHistory
  • getSha1Hash() : HistoryModel
  • getShortcut() : InputOption
  • getShortHashedUserAgent() : UserHelper
  • getShortName() : Identifier
  • getShortVersion() : Version
  • getSibling() : CategoryNode , ImmutableNodeInterface
  • getSign() : BigDecimal , BigInteger , BigNumber , BigRational , DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject
  • getSignalRegistry() : Application
  • getSignature() : CSR , Indexer , JWS , Signature , ReflectionCaster , AuthenticatorAssertionResponse
  • getSignatureAlgorithm() : CSR
  • getSignatureAlgorithmManager() : JWSBuilder , JWSVerifier
  • getSignatureFormat() : DSA , EC
  • getSignatureLength() : Hmac , HS256 , HS256Truncated64 , HS384 , HS512
  • getSignatureMethod() : RSA
  • getSignaturePartLength() : ES256 , ES256K , ES384 , ES512 , ECDSA , ES256 , ES256K , ES384 , ES512
  • getSignatures() : JWS
  • getSignatureSubject() : CSR
  • getSignCount() : AuthenticatorData
  • getSimpleModeLayoutData() : ColorField
  • getSingleEntry() : Collection
  • getSingular() : Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected
  • getSingularRuleset() : GenericLanguageInflectorFactory , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules
  • getSiteHomePages() : Multilanguage
  • getSiteIcon() : Authentication
  • getSitesWithUpdates() : Updater
  • getSiteTemplates() : StyleModel
  • getSize() : CallbackStream , RelativeStream , Stream , UploadedFile , Stream , UploadedFile , StreamInterface , UploadedFileInterface , SplFixedArray
  • getSk() : RogueListEntry
  • getSliderModeLayoutData() : ColorField
  • getSlugColumn() : CategoryModel , ContactModel , ArchiveModel
  • getSMTPConnection() : SMTP
  • getSmtpErrorMessage() : PHPMailer
  • getSMTPInstance() : PHPMailer
  • getSnippet() : ParseException
  • getSort() : AggregatedCollector , Parameters
  • getSource() : Patcher , TemplateModel , Patcher
  • getSourceLink() : CliDumper , HtmlDumper
  • getSql() : TracedStatement
  • getSqlQuery() : PdoStorage
  • getSqlQuotationChar() : PDOCollector
  • getSqlWithParams() : TracedStatement
  • getStackDataSessionNamespace() : DebugBar
  • getStackedData() : DebugBar
  • getStackLocation() : Changelog
  • getStart() : ListModel , ArticlesModel , AdaptersModel , MediaModel
  • getStartMemory() : TracedStatement
  • getStartTime() : TracedStatement , ProgressBar
  • getState() : CertificateSubject , CSR , ActionButton , StatefulModelInterface , WorkflowModelInterface , Indexer , Session
  • getStateColumnForSection() : ContactComponent , NewsfeedsComponent
  • getStatements() : Propel2Collector , QueryCollector
  • getStateOptions() : InstallerHelper , MessagesHelper , ModulesHelper , UsersHelper
  • getStateQuery() : Adapter , PlgFinderCategories , PlgFinderTags
  • getStaticHeaderConfiguration() : PlgSystemHttpHeaders
  • getStats() : StatsAdminHelper
  • getStatsData() : PlgSystemStats
  • getStatus() : ChangeSet , MultilangstatusHelper , ResponseBag , StatusReport , TokenBinding
  • getStatusCode() : Response , ResponseInterface , FlattenException
  • getStatusLine() : Serializer
  • getStatusReports() : MetadataTOCPayloadEntry
  • getStatusText() : FlattenException
  • getStdError() : SSH2
  • getStepWidth() : ProgressBar
  • getStorage() : DebugBar
  • getStoreId() : ItemModel , ListModel , AssociationsModel , BannersModel , ClientsModel , BannersModel , CacheModel , CategoriesModel , ContactsModel , CategoriesModel , ArticlesModel , CategoriesModel , FeaturedModel , FieldsModel , GroupsModel , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , LanguagesModel , UpdatesitesModel , InstalledModel , LanguagesModel , ItemsModel , MessagesModel , ModulesModel , SelectModel , NewsfeedsModel , CategoriesModel , PluginsModel , ConsentsModel , RequestsModel , LinksModel , TasksModel , TagsModel , StylesModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NotesModel , UsersModel
  • getStores() : Cache
  • getStream() : Factory , Stream , UploadedFile , UploadedFileInterface , Input , StreamableInputInterface , StreamOutput
  • getStringFromOption() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , RemoveUserFromGroupCommand
  • getStringPositionSql() : PgsqlDriver
  • getSttyColumns() : Terminal
  • getStub() : Data , Container
  • getStyle() : ColorStyle , NullOutputFormatter , OutputFormatter , OutputFormatterInterface , Table , TableCell
  • getStyleDefinition() : Table
  • getStylesheet() : HtmlErrorRenderer
  • getStyleStack() : OutputFormatter
  • getSubfieldsFromField() : PlgFieldsSubform
  • getSubject() : Usage
  • getSubjectDN() : X509
  • getSubjectDNProp() : X509
  • getSubPart() : Accept , AcceptLanguage
  • getSubpart() : Mbstring
  • getSubscribedEvents() : SubscriberInterface , Taggable , Versionable , Email , Fixed , Totp , Webauthn , Yubikey , Joomlaupdate , Cache , Shortcut , Webauthn , Checkfiles , DemoTasks , Requests , SiteStatus , PlgSystemDebug , PlgSystemHttpHeaders , PlgSystemJooa11y , PlgSystemRedirect , PlgSystemSchedulerunner , PlgSystemTasknotification , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing , ErrorListener , CheckLdapCredentialsListener , AddLinkHeaderListener
  • getSubscribedServices() : ServiceSubscriberInterface
  • getSubscribedSignals() : SignalableCommandInterface
  • getSuffixes() : FileLayout
  • getSuggestions() : SuggestionsController
  • getSuperUsers() : PlgSystemUpdatenotification
  • getSupported() : FilesystemHelper , Helper
  • getSupportedCompressionAlgorithms() : SSH2
  • getSupportedEncryptionAlgorithms() : SSH2
  • getSupportedExtension() : AssociationsHelper
  • getSupportedExtensions() : AssociationsHelper , MetadataStatement
  • getSupportedHostKeyAlgorithms() : SSH2
  • getSupportedKEXAlgorithms() : SSH2
  • getSupportedKeyFormats() : AsymmetricKey
  • getSupportedMACAlgorithms() : SSH2
  • getSupportedShells() : DumpCompletionCommand
  • getSupportedStatus() : TokenBinding
  • getSupportedVersions() : SFTP
  • getSupportTemplate() : AssociationExtensionHelper
  • getSx() : EcdaaTrustAnchor
  • getSy() : EcdaaTrustAnchor
  • getSynopsis() : AbstractCommand , Command , LazyCommand , InputDefinition
  • getSysfs() : SystemNodeProvider
  • getSystemCaRootBundlePath() : CaBundle
  • getTable() : BaseDatabaseModel , WorkflowModelInterface , User , BannersModel , CategoryModel , FormModel , FeatureModel , FormModel , CompareModel , HistoryModel , PreviewModel , FieldModel , GroupModel , IndexModel , MapsModel , LanguageModel , TemplateModel , ItemModel , MenuModel , ModuleModel , PluginModel , ExportModel , RemoveModel , RequestModel , ConfirmModel , RemindModel , RequestModel , TaskModel , GroupModel , LevelModel , UserModel , StagesModel , TransitionsModel , WorkflowsModel
  • getTableColumns() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableCreate() : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableKeys() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableList() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableName() : Table
  • getTableNameForSection() : BannersComponent , ContactComponent , ContentComponent , FieldsComponent , NewsfeedsComponent
  • getTables() : Rijndael
  • getTableSequences() : PgsqlDriver
  • getTag() : ExplicitlyTaggedObject , Language , SymmetricKey , TaggedValue , ExtensionDescriptor
  • getTagged() : Container
  • getTagId() : Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TagObject
  • getTagIds() : TagsHelper
  • getTagItemsQuery() : TagsHelper
  • getTagNames() : TagsHelper
  • getTagNumber() : Identifier
  • getTagOptions() : TableCellStyle
  • getTagRoute() : RouteHelper
  • getTags() : TraceableTwigEnvironment , AllowedTags , TagInterface
  • getTagsHelper() : TaggableTableInterface
  • getTagsRoute() : RouteHelper
  • getTagsTitle() : HtmlView
  • getTagTreeArray() : TagsHelper
  • getTargetMinimumPHPVersion() : UpdateModel
  • getTarInfo() : Tar
  • getTask() : BaseController , TaskModel
  • getTaskId() : ExecuteTaskEvent
  • getTasks() : TasksListCommand , BaseController
  • getTaxonomy() : Result , Taxonomy
  • getTcDisplay() : MetadataStatement
  • getTcDisplayContentType() : MetadataStatement
  • getTcDisplayPNGCharacteristics() : MetadataStatement
  • getTemplate() : AdministratorApplication , ApiApplication , CMSApplication , InstallationApplication , MailTemplate , TemplateModel
  • getTemplateClass() : TraceableTwigEnvironment
  • getTemplateClassPrefix() : TraceableTwigEnvironment
  • getTemplateInfo() : InfoCollector
  • getTemplateList() : TemplateModel
  • getTemplateModuleStyles() : ChromestyleField
  • getTemplateName() : TraceableTwigTemplate
  • getTemplateOptions() : TemplatesHelper
  • getTemplates() : ChromestyleField , ModulesHelper
  • getTest() : TraceableTwigEnvironment
  • getTests() : TraceableTwigEnvironment
  • getTimeDataCollector() : TraceableTwigEnvironment
  • getTimeGenerator() : FeatureSet , UuidFactory
  • getTimeHiAndVersion() : Uuid
  • getTimeHiAndVersionHex() : Uuid , UuidInterface
  • getTimeLeft() : ZIPExtraction
  • getTimeLow() : DegradedUuid , Uuid
  • getTimeLowHex() : Uuid , UuidInterface
  • getTimeMid() : Uuid
  • getTimeMidHex() : Uuid , UuidInterface
  • getTimeOfLastStatusChange() : MetadataTOCPayloadEntry
  • getTimeout() : SMTP , PublicKeyCredentialOptions
  • getTimestamp() : DegradedUuid , Uuid
  • getTimestampHex() : Uuid , UuidInterface
  • getTimestampRegex() : Inline
  • getTimezone() : User
  • getTimings() : DebugMonitor
  • getTitle() : Document , SpacerField , FormField , LatestHelper , LatestActionsHelper , LoggedHelper , PopularHelper
  • getTo() : Substitution
  • getToAddresses() : PHPMailer
  • getToc() : HelpModel
  • getToken() : Client , Session , SessionInterface , Builder , OAuth
  • getTokenBinding() : CollectedClientData
  • getTokenData() : Query
  • getTokenForDisplay() : JoomlatokenField , PlgUserToken
  • getTokenName() : PhpToken
  • getTokenParsers() : TraceableTwigEnvironment
  • getTokenSeedForUser() : Token , PlgUserToken
  • getTotal() : ListModel , CacheModel , CheckinModel , FilterModel , InstalledModel , OverridesModel , AdaptersModel , MediaModel , PositionsModel
  • getTotalIndexed() : IndexModel
  • getTPMHash() : TPMAttestationStatementSupport
  • getTrace() : CliRenderer , Language , FlattenException , SilencedErrorContext
  • getTraceAsString() : FlattenException
  • getTransitions() : ArticlesModel
  • getTranslatedModulePosition() : ModulesHelper
  • getTranslations() : PHPMailer
  • getTransliterator() : Language
  • getTransports() : FilesystemHelper , Helper , PublicKeyCredentialDescriptor , PublicKeyCredentialSource
  • getTree() : Nested
  • getTrustPath() : AttestationStatement , PublicKeyCredentialSource
  • getTwofactorform() : UserModel , ProfileModel
  • getTwoFactorMethods() : AuthenticationHelper , UsersHelper
  • getType() : ASNObject , ExplicitlyTaggedObject , BitString , BMPString , Boolean , CharacterString , Enumerated , GeneralizedTime , GeneralString , GraphicString , IA5String , Integer , NullObject , NumericString , ObjectDescriptor , ObjectIdentifier , OctetString , PrintableString , RelativeObjectIdentifier , Sequence , Set , T61String , UniversalString , UTCTime , UTF8String , VisibleString , UnknownConstructedObject , UnknownObject , Attributes , DNSName , IPAddress , SubjectAlternativeNames , AssociationExtensionHelper , Document , Microdata , UCMBase , UCMType , AssociationsHelper , Key , LoginHelper , BaseAccept , Data , AbstractSerializer , Resource , SerializerInterface , AttestationStatement , CollectedClientData , Credential , PublicKeyCredentialDescriptor , PublicKeyCredentialParameters , PublicKeyCredentialSource
  • getTypeAlias() : Category , Content , TaggableTableInterface , VersionableTableInterface , BannerTable , ClientTable , ContactTable , NewsfeedTable , TagTable , NoteTable
  • getTypeAliasFromInput() : HistoryController
  • getTypeByAlias() : UCMType
  • getTypeByTable() : UCMType
  • getTypeFieldName() : AssociationExtensionHelper , AssociationsHelper
  • getTypeFields() : AssociationExtensionHelper
  • getTypeIcon() : MediaHelper , TemplateHelper
  • getTypeId() : ContentType , UCMType , Adapter
  • getTypeIdFromInput() : HistoryController
  • getTypeInformation() : AssociationExtensionHelper
  • getTypeJoins() : AssociationExtensionHelper
  • getTypeName() : ASNObject
  • getTypeOptions() : MenutypesModel
  • getTypeOptionsByComponent() : MenutypesModel
  • getTypeOptionsFromLayouts() : MenutypesModel
  • getTypeOptionsFromManifest() : MenutypesModel
  • getTypeOptionsFromMvc() : MenutypesModel
  • getTypeOptionsFromXml() : MenutypesModel
  • getTypes() : TagsHelper , Microdata
  • getTypeSupport() : AssociationExtensionHelper
  • getTypeTables() : AssociationExtensionHelper
  • getTypeTitle() : AssociationExtensionHelper
  • getUnaryOperators() : TraceableTwigEnvironment
  • getUncompressedCoordinates() : Ec2Key
  • getUnfilteredRelationships() : Resource
  • getUninflected() : Ruleset
  • getUniqueId() : PlgSystemStats
  • getUnscaledValue() : BigDecimal
  • getUnscaledValueWithLeadingZeros() : BigDecimal
  • getUnsupportedAdapterType() : UnsupportedArchiveException
  • getUpdatedFiles() : PlgInstallerOverride
  • getUpdatedList() : TemplateModel
  • getUpdateFiles() : ChangeSet
  • getUpdateInfo() : CheckJoomlaUpdatesCommand
  • getUpdateInformation() : UpdateModel
  • getUpdateInformationFromModel() : CheckJoomlaUpdatesCommand
  • getUpdateModel() : UpdateCoreCommand
  • getUpdateQueries() : ChangeSet
  • getUpdateQueryByIds() : Adapter
  • getUpdateQueryByTime() : Adapter , PlgFinderTags
  • getUpdateSite() : LanguagesModel
  • getUpdateSiteName() : UpdateAdapter
  • getUpdateSiteResponse() : UpdateAdapter
  • getUpdateSites() : Updater
  • getUpdateSitesInfo() : UpdateModel
  • getUpdateSitesInformation() : InstallerHelper
  • getUploadedFiles() : ServerRequest , ServerRequestInterface
  • getUpperLimitSearchWord() : En_GBLocalise , Fr_FRLocalise , Language
  • getUpperLimitSearchWordCallback() : Language
  • getUpv() : MetadataStatement
  • getUri() : WebAssetItem , WebAssetItemInterface , ResolvedRoute , Stream , RequestInterface
  • getUrl() : Totp , BannerModel , Adapter , AdapterInterface , ApiModel , LocalAdapter , MetadataTOCPayloadEntry , StatusReport
  • getUrn() : Uuid , UuidInterface
  • getUsages() : Command , LazyCommand
  • getUsed() : Language
  • getUseIncludePath() : ClassLoader
  • getUser() : Factory , AbstractMenu , DebuguserModel , NotesModel , AbstractUri , UriInterface , PublicKeyCredentialCreationOptions
  • getUserAgent() : Version
  • getUserDisplayedGroups() : UsersModel
  • getUserEntity() : Credentials , Authentication
  • getUserGroups() : AddUserCommand , RulesField , UserHelper , FiltersField
  • getUserHandle() : AuthenticatorAssertionResponse , PublicKeyCredentialSource
  • getUserHandleFor() : CredentialRepository
  • getUserId() : AddUserToGroupCommand , ConfigurationModel , UserHelper
  • getUserIdentifier() : LdapUser
  • getUserIdFromToken() : RegistrationModel
  • getUserInfo() : Uri , UriInterface
  • getUsername() : LdapUser
  • getUsers() : UsersLatestHelper
  • getUsersByGroup() : Access
  • getUsersFromGroup() : PlgWorkflowNotification
  • getUserState() : CMSApplication , CMSWebApplicationInterface
  • getUserStateFromRequest() : CMSApplication , CMSWebApplicationInterface , ListModel
  • getUserVerification() : AuthenticatorSelectionCriteria , VerificationMethodDescriptor , PublicKeyCredentialRequestOptions
  • getUserVerificationDetails() : MetadataStatement
  • getUseStatements() : DebugClassLoader
  • getUuidBuilder() : UuidFactory
  • getValidatableClaims() : Token
  • getValidator() : Question
  • getValidNode() : DefaultTimeGenerator
  • getValidTransition() : Workflow
  • getValue() : AssertionFailedException , InvalidArgumentException , ByteStringObject , ByteStringWithChunkObject , MapItem , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , Form , ArrayHelper , Basic , Claim , BaseAccept , Suggestion , Data , TaggedValue
  • getValueActions() : RulesRule
  • getValueAsIni() : Ini
  • getValueFromKey() : ArraySerializer
  • getValueFromNode() : Xml
  • getValueSuggestions() : CompletionSuggestions
  • getVar() : Router , AbstractUri , UriInterface
  • getVarDumper() : DataCollector , MessagesCollector
  • getVariable() : PharInvocation
  • getVariableName() : JavascriptRenderer
  • getVariant() : Uuid , UuidInterface
  • getVars() : Router
  • getVerbosity() : NullOutput , Output , OutputInterface , OutputStyle
  • getVerificationMethods() : VerificationMethodANDCombinations
  • getVerp() : SMTP
  • getVersion() : InstalledVersions , CSR , Browser , WebAssetItem , WebAssetItemInterface , Application , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , SqliteDriver , VersionHelper , Uuid , UuidInterface , Application
  • getVersionRanges() : InstalledVersions
  • getView() : DisplayController , BaseController , DisplayController
  • getViewLevels() : ItemModel
  • getViews() : RouterView
  • getVisibleByGroups() : UsersHelper
  • getWebAssetManager() : Document
  • getWebauthnServer() : Authentication
  • getWeekEnd() : Language
  • getWidgets() : DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , ConfigCollector , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , Renderable , RequestDataCollector , TimeDataCollector , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector
  • getWidth() : Image , Terminal , DisplayPNGCharacteristicsDescriptor
  • getWindowColumns() : SSH2
  • getWindowRows() : SSH2
  • getWord() : Word
  • getWorkarounds() : Cache
  • getWorkflow() : StagesModel , TransitionModel , TransitionsModel
  • getWorkflowContexts() : WorkflowServiceInterface , ContentComponent
  • getWorkflowTableBySection() : WorkflowServiceInterface , ContentComponent
  • getWriteModes() : FilesystemHelper , Helper
  • getX() : EcdaaTrustAnchor
  • getXdebugLink() : NamespacedTwigProfileCollector , TwigProfileCollector , DataCollector
  • getXdebugLinkTemplate() : DataCollector
  • getXdebugReplacements() : DataCollector
  • getXdebugShouldUseAjax() : DataCollector
  • getXml() : Form
  • getXmlChildren() : Xml
  • getXmlIssues() : Sanitizer
  • getXMLOptions() : Sanitizer
  • getY() : EcdaaTrustAnchor
  • getYears() : ArchiveModel
  • getZeroPadding() : AbstractAES
  • ghash() : SymmetricKey
  • GHOST_ADDONS : HtmlErrorRenderer
  • GHOST_GIFT : HtmlErrorRenderer
  • GHOST_HEART : HtmlErrorRenderer
  • GHOST_PLUS : HtmlErrorRenderer
  • glob() : CaBundle
  • GLOBAL_NAMESPACE : ApplicationDescription
  • GRAPHEME_CLUSTER_RX : Grapheme
  • grapheme_extract() : Grapheme
  • grapheme_position() : Grapheme
  • grapheme_stripos() : Grapheme
  • grapheme_stristr() : Grapheme
  • grapheme_strlen() : Grapheme
  • grapheme_strpos() : Grapheme
  • grapheme_strripos() : Grapheme
  • grapheme_strrpos() : Grapheme
  • grapheme_strstr() : Grapheme
  • grapheme_substr() : Grapheme
  • GRAPHIC_STRING : Identifier
  • greaterOrEqualThan() : Assertion
  • greaterThan() : Assertion , Assert
  • greaterThanEq() : Assert
  • GREEK_LANGUAGE_CODE : ASCII
  • GREEKLISH_LANGUAGE_CODE : ASCII
  • group() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • groupBy() : ArticlesCategoryHelper
  • groupByDate() : ArticlesCategoryHelper
  • groupByTags() : ArticlesCategoryHelper
  • groupConcat() : QueryInterface , SqliteQuery , SqlsrvQuery
  • groupedlist() : Select
  • groups() : User
  • guardLeeway() : ValidAt
  • guessShell() : DumpCompletionCommand


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- h -

  • h2c_string_to_hash() : ParagonIE_Sodium_Core_Ristretto255
  • h2c_string_to_hash_sha256() : ParagonIE_Sodium_Core_Ristretto255
  • h2c_string_to_hash_sha512() : ParagonIE_Sodium_Core_Ristretto255
  • HALF_CEILING : RoundingMode
  • HALF_DOWN : RoundingMode
  • HALF_EVEN : RoundingMode
  • HALF_FLOOR : RoundingMode
  • HALF_UP : RoundingMode
  • handle() : OpenHandler , AuthenticationFailedExceptionHandler , CheckinCheckoutExceptionHandler , InvalidParameterExceptionHandler , InvalidRouteExceptionHandler , NotAcceptableExceptionHandler , NotAllowedExceptionHandler , ResourceNotFoundExceptionHandler , SaveExceptionHandler , SendEmailExceptionHandler , SignalRegistry , ErrorHandler , ExceptionHandlerInterface , FallbackExceptionHandler , InvalidParameterExceptionHandler
  • handleAuthor() : AtomParser
  • handleCategory() : RssParser
  • handleCloud() : RssParser
  • handleContributor() : AtomParser
  • handleCopyright() : RssParser
  • handleDefaultNamespace() : XPath
  • handleDescription() : RssParser
  • handleError() : ErrorHandler
  • handleException() : ExceptionHandler , ErrorHandler
  • handleFatalError() : ErrorHandler
  • handleGenerator() : AtomParser , RssParser
  • handleId() : AtomParser
  • handleImage() : RssParser
  • handleKey() : ECDSA , EdDSA , PSSRSA , RSA
  • handleLanguage() : RssParser
  • handleLastBuildDate() : RssParser
  • handleLink() : AtomParser , RssParser
  • handleManagingEditor() : RssParser
  • handleOldDatabase() : DatabaseModel
  • handlePreflight() : ApiApplication
  • handlePubDate() : RssParser
  • handler() : CryptoExceptionHandler
  • handleRights() : AtomParser
  • handleSignal() : SignalableCommandInterface
  • handleSkipDays() : RssParser
  • handleSkipHours() : RssParser
  • handleSubtitle() : AtomParser
  • handleTitle() : AtomParser , RssParser
  • handleTtl() : RssParser
  • handleUpdated() : AtomParser
  • handleUserDeprecatedErrors() : ExceptionHandler
  • handleWebmaster() : RssParser
  • hangulCompose() : NamePrep
  • hangulDecompose() : NamePrep
  • has() : Manager , Key , WritableContainerLoader , UserGroupsHelper , Session , JoomlaStorage , ContainerLoader , LoaderInterface , Container , ListenersPriorityQueue , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , AlgorithmManager , JWK , JWKSet , DataSet , ValidationData , ContainerInterface , Application , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader , HelperSet , Collectable , PharInvocationCollection , AttestationStatement , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , CollectedClientData , PublicKeyCredentialDescriptorCollection
  • has8bitChars() : PHPMailer
  • hasArgument() : AbstractEvent , Input , InputDefinition , InputInterface
  • hasAssociationsSupport() : AssociationExtensionHelper , AssociationExtensionInterface
  • hasAttestationSupport() : Authentication
  • hasAttestedCredentialData() : AuthenticatorData
  • hasAttribute() : Entry
  • hasBeenIssuedBefore() : Token
  • hasBeenIssuedBy() : Token
  • hasBigNumber() : FeatureSet
  • hasBlock() : TraceableTwigTemplate
  • hasChildren() : ImmutableNodeInterface
  • hasClaim() : Token
  • hasCoefficient() : RsaKey
  • hasCollector() : DebugBar
  • hasColorSupport() : StreamOutput , CliDumper
  • hasCommand() : Application
  • hasComponentConfig() : ConfigHelper
  • hasCredentials() : ClientHelper
  • hasDefault() : OptionsResolver
  • hasErrored() : ConsoleLogger
  • hasEvent() : Dispatcher
  • hasExponents() : RsaKey
  • hasExtension() : TraceableTwigEnvironment
  • hasExtensions() : AuthenticatorData
  • hasField() : Table , TableInterface
  • hasFlag() : Container
  • hash() : Hmac , Mac , Hash , HMAC , HS256_64 , MacAlgorithm , Signature
  • HASH : Ed25519 , Ed448
  • hash() : Hash
  • HASH_ALGORITHMS : UserHelper
  • HASH_ARGON2I : UserHelper
  • HASH_ARGON2I_BC : UserHelper
  • HASH_ARGON2ID : UserHelper
  • HASH_ARGON2ID_BC : UserHelper
  • HASH_ASSOC : Cursor
  • HASH_BCRYPT : UserHelper
  • HASH_BCRYPT_BC : UserHelper
  • HASH_FUNCTION : Crypto
  • HASH_FUNCTION_NAME : Core
  • HASH_INDEXED : Cursor
  • HASH_MD5 : UserHelper
  • HASH_NOT_PROVIDED : InstallerHelper
  • HASH_NOT_VALIDATED : InstallerHelper
  • HASH_OBJECT : Cursor
  • HASH_PHPASS : UserHelper
  • HASH_RESOURCE : Cursor
  • HASH_SC_L : ParagonIE_Sodium_Core_Ristretto255
  • hash_update() : ParagonIE_Sodium_Core_Util
  • HASH_VALIDATED : InstallerHelper
  • hasHeader() : Token , MessageInterface
  • hasHeaderParameter() : Signature
  • hashEquals() : Core
  • hashPassword() : Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler , UserHelper
  • HashPassword() : PasswordHash
  • hashToInt() : Totp
  • hasInfiniteLoop() : Subject
  • hasKey() : Language
  • hasLineLongerThanMax() : PHPMailer
  • hasListener() : Dispatcher , DispatcherInterface
  • hasLogger() : LoggerRegistry
  • hasMoreLines() : Parser
  • hasMultiBytes() : PHPMailer
  • hasNativeSupport() : Zip
  • hasNegation() : InputDefinition
  • hasNonZeroFractionalPart() : BigDecimal
  • hasOption() : Input , InputDefinition , InputInterface
  • hasParameter() : BaseAccept
  • hasParameterOption() : ArgvInput , ArrayInput , InputInterface
  • hasParent() : ImmutableNodeInterface
  • hasPharPrefix() : Helper
  • hasPrimaryKey() : Table
  • hasPrimes() : RsaKey
  • hasProtectedHeaderParameter() : Signature
  • hasRemoteReference() : Sanitizer
  • hasService() : Registry
  • hasSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • hasShortcut() : InputDefinition
  • hasStackedData() : DebugBar
  • hasStartedMeasure() : TimeDataCollector , ProfileCollector
  • hasStderrSupport() : ConsoleOutput
  • hasStdoutSupport() : ConsoleOutput
  • hasSttyAvailable() : Terminal
  • hasStyle() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface
  • hasSupport() : AssociationsHelper
  • hasToken() : Session , SessionInterface
  • hasTokenProfileFields() : PlgUserToken
  • hasUserConfiguredTwoFactorAuthentication() : CMSApplication
  • hasUTF8mb4Support() : MysqlDriver , MysqliDriver
  • hasUtf8mb4Support() : UTF8MB4SupportInterface
  • hasUtfSupport() : DatabaseDriver , DatabaseInterface
  • hasValidEnEnding() : Dutch
  • hasValidSEnding() : Danish , Dutch , Norwegian , Swedish
  • hasVar() : AbstractUri , UriInterface
  • hasVt100Support() : Terminal
  • having() : DatabaseQuery , QueryInterface
  • hChaCha20() : ParagonIE_Sodium_Core32_HChaCha20 , ParagonIE_Sodium_Core_HChaCha20
  • hChaCha20Bytes() : ParagonIE_Sodium_Core_HChaCha20
  • head() : Http , Router , RouterInterface
  • header() : AbstractWebApplication
  • HEADER_VERSION_SIZE : Core
  • headerLine() : PHPMailer
  • headers() : Token
  • hello() : SMTP
  • help() : ToolbarHelper
  • hex2bin() : LengthCalculator , SignedIntegerObject , UnsignedIntegerObject , ECSignature , ParagonIE_Sodium_Compat
  • hexDecode() : Encoding
  • hexDecodeUpper() : Encoding
  • hexEncode() : Encoding
  • hexEncodeUpper() : Encoding
  • hexToBigInteger() : Utils
  • hexToBin() : Encoding
  • hexToBytes() : Crypto
  • hexToInt() : Utils
  • hexToString() : Utils
  • hide() : Cursor
  • hideFields() : ContenthistoryHelper
  • hideMessages() : MessagesModel
  • HIGH : Priority
  • highlighter() : Behavior
  • HINDI_LANGUAGE_CODE : ASCII
  • hit() : Table , CategoryModel , ContactModel , ArticleModel , CategoryModel , NewsfeedModel
  • HKDF() : Crypto
  • HKDFTestVector() : Crypto , RuntimeTests
  • hmac() : SMTP
  • HMACTestVector() : Crypto , RuntimeTests
  • holdEditId() : BaseController
  • horizontalTable() : SymfonyStyle
  • HOST : UriInterface
  • HOST_NAME : ConnectionOptions
  • HOUR : CronExpression
  • hour() : DatabaseQuery , QueryInterface
  • hrefIsTemplated() : Link
  • hrtime() : Php73
  • hsalsa20() : ParagonIE_Sodium_Core_HSalsa20
  • html2text() : PHPMailer
  • html_encoding_callback() : Mbstring
  • htmlDiv() : Microdata
  • htmlEncode() : SourceContextProvider
  • htmlMeta() : Microdata
  • htmlProperty() : Microdata
  • htmlScope() : Microdata
  • htmlSpan() : Microdata
  • htmlTag() : Microdata
  • HUNGARIAN_LANGUAGE_CODE : ASCII
  • HUNK : Patcher


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- i -

  • i2osp() : RSA
  • IA5_STRING : Identifier
  • ICAL_METHOD_ADD : PHPMailer
  • ICAL_METHOD_CANCEL : PHPMailer
  • ICAL_METHOD_COUNTER : PHPMailer
  • ICAL_METHOD_DECLINECOUNTER : PHPMailer
  • ICAL_METHOD_PUBLISH : PHPMailer
  • ICAL_METHOD_REFRESH : PHPMailer
  • ICAL_METHOD_REPLY : PHPMailer
  • ICAL_METHOD_REQUEST : PHPMailer
  • iconv() : Iconv
  • iconv_get_encoding() : Iconv
  • iconv_mime_decode() : Iconv
  • iconv_mime_decode_headers() : Iconv
  • iconv_mime_encode() : Iconv
  • iconv_set_encoding() : Iconv
  • iconv_strlen() : Iconv
  • iconv_strpos() : Iconv
  • iconv_strrpos() : Iconv
  • iconv_substr() : Iconv
  • ID : HS256 , HS256Truncated64 , HS384 , HS512 , ES256 , ES256K , ES384 , ES512 , Ed25519 , ED256 , ED512 , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512
  • id() : Grid , Languages
  • ID : RegisteredClaims
  • identifiedBy() : Builder
  • identifier() : Algorithm , HS256 , HS256Truncated64 , HS384 , HS512 , ES256 , ES256K , ES384 , ES512 , Ed25519 , ED256 , ED512 , EdDSA , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512
  • IDENTIFIER : DNSName , IPAddress
  • identifyBrowserVersion() : Browser
  • identifySignatureAlgorithm() : X509
  • idnSupported() : PHPMailer
  • IE : WebClient
  • ietfStream() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • ietfStreamXorIc() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • iframe() : HTMLHelper
  • ignoreCase() : AbstractString
  • ignoreCollector() : JavascriptRenderer
  • ignoreValidationErrors() : Command , LazyCommand
  • image() : HTMLHelper , Users
  • imageResize() : MediaHelper
  • images() : ListHelper
  • implementsInterface() : Assertion , Assert
  • import() : JLoader , PluginHelper
  • importData() : DatabaseImporter
  • importPlugin() : PluginHelper
  • impress() : BannersModel
  • in() : CliInput , CliApplication
  • INACTIVE : SessionState
  • inArray() : Assertion , Assert
  • includeRelativeFiles() : HTMLHelper
  • incompatibleKey() : InvalidKeyProvided
  • INCOMPLETE_CREDENTIALS : Authentication
  • incorrectStartSequence() : ConversionFailed
  • increment() : DayOfMonthField , DayOfWeekField , FieldInterface , HoursField , MinutesField , MonthField , Usage , StringHelper , ParagonIE_Sodium_Compat
  • increment_counter() : ParagonIE_Sodium_Core_BLAKE2b
  • increment_str() : Strings
  • incrementCounter() : Core , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • index() : FinderIndexCommand , Adapter , Indexer , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • indexOf() : AbstractString , ByteString , CodePointString , UnicodeString
  • indexOfLast() : AbstractString , ByteString , CodePointString , UnicodeString
  • inetToBits() : IpHelper
  • inflect() : CachedWordInflector , NoopWordInflector , Substitutions , Transformation , Transformations , RulesetInflector , WordInflector
  • info() : PropelCollector
  • INFO : Log
  • info() : AbstractLogger , LoggerInterface
  • INFO : LogLevel , ConsoleLogger
  • info() : SymfonyStyle , OptionConfigurator
  • init() : Calculator , Dropdown , Module , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , Curl , Application
  • init_sftp_connection() : SFTP
  • initAll() : Bootup
  • initBatch() : AdminModel
  • initCommands() : Application
  • initDimensions() : Terminal
  • initDimensionsUsingStty() : Terminal
  • initFile() : FormattedtextLogger
  • initFormats() : ProgressBar
  • initHashMask() : Php72
  • initialBias : AbstractPunycode
  • initialise() : AbstractApplication , Captcha , Editor , FeedParser , AtomParser , RssParser , DatabaseModel , Application , AbstractCommand , DataSet
  • initialiseApp() : AdministratorApplication , CMSApplication , SiteApplication , InstallationApplication
  • initialize() : Encrypt , Shortcut , BCMath , GMP , PHP32 , PHP64 , PHP , Command , CompleteCommand , Inline , Manager , ZIPExtraction
  • INITIALIZE_CONSTRUCTOR : JavascriptRenderer
  • INITIALIZE_CONTROLS : JavascriptRenderer
  • initialize_static_variables() : AsymmetricKey , PKCS8 , PSS , RSA , BigInteger
  • initializeLog() : ZIPExtraction
  • initializeView() : FormView , ListView
  • initialN : AbstractPunycode
  • initJwsVerifier() : AndroidSafetyNetAttestationStatementSupport
  • initPlaceholderFormatters() : ProgressBar , ProgressIndicator
  • initPrivateKey() : RSAKey
  • initPublicKey() : RSAKey
  • initRuntime() : TraceableTwigEnvironment
  • initShell() : SSH2
  • initStackSession() : DebugBar
  • initStyles() : Table
  • injectLazyJS() : PlgSystemSchedulerunner
  • inlinehelp() : ToolbarHelper
  • inlineImageExists() : PHPMailer
  • innerJoin() : DatabaseQuery
  • inR1() : Stem
  • inR2() : Stem
  • inRv() : Stem
  • insert() : DatabaseQuery , QueryInterface
  • insertid() : DatabaseInterface , MysqliDriver , PdoDriver
  • insertObject() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver
  • inspectApplication() : ApplicationDescription
  • install() : LanguagesModel , LanguageAdapter , Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript , InstallModel , UpdateModel
  • INSTALLATION_FAILED : ExtensionInstallCommand
  • INSTALLATION_SUCCESSFUL : ExtensionInstallCommand
  • installPreset() : MenusHelper
  • instance() : Manager
  • instantiateController() : ContainerControllerResolver , ControllerResolver
  • instantiateField() : FieldFactory
  • int2bytes() : PHP
  • int2octets() : AsymmetricKey
  • integer() : Assertion
  • INTEGER : Identifier , ParameterType
  • integer() : Assert
  • integerExpected() : ConversionFailed
  • integerish() : Assertion , Assert
  • integerlist() : Select
  • interact() : Command
  • INTERFACE_NOT_IMPLEMENTED : Assertion
  • interfaceExists() : Assertion , Assert
  • interpolate() : MessagesCollector , ConsoleLogger
  • inTransaction() : TraceablePDO
  • intToChr() : ParagonIE_Sodium_Core_Util
  • intToHex() : Utils
  • INVALID : Command
  • INVALID_ALNUM : Assertion
  • INVALID_ARRAY : Assertion
  • INVALID_ARRAY_ACCESSIBLE : Assertion
  • INVALID_BASE64 : Assertion
  • INVALID_BETWEEN : Assertion
  • INVALID_BETWEEN_EXCLUSIVE : Assertion
  • INVALID_BOOLEAN : Assertion
  • INVALID_CALLABLE : Assertion
  • INVALID_CHOICE : Assertion
  • INVALID_CLASS : Assertion
  • INVALID_CONSTANT : Assertion
  • INVALID_COUNT : Assertion
  • INVALID_COUNTABLE : Assertion
  • INVALID_CREDENTIALS : Authentication
  • INVALID_DATE : Assertion
  • INVALID_DIGIT : Assertion
  • INVALID_DIRECTORY : Assertion
  • INVALID_E164 : Assertion
  • INVALID_EMAIL : Assertion
  • INVALID_EQ : Assertion
  • INVALID_EXIT : Status
  • INVALID_EXTENSION : Assertion
  • INVALID_FALSE : Assertion
  • INVALID_FILE : Assertion
  • INVALID_FILE_NOT_EXISTS : Assertion
  • INVALID_FLOAT : Assertion
  • INVALID_GREATER : Assertion
  • INVALID_GREATER_OR_EQUAL : Assertion
  • INVALID_INSTANCE_OF : Assertion
  • INVALID_INTEGER : Assertion
  • INVALID_INTEGERISH : Assertion
  • INVALID_INTERFACE : Assertion
  • INVALID_IP : Assertion
  • INVALID_JSON_STRING : Assertion
  • INVALID_KEY_EXISTS : Assertion
  • INVALID_KEY_ISSET : Assertion
  • INVALID_KEY_NOT_EXISTS : Assertion
  • INVALID_LENGTH : Assertion
  • INVALID_LESS : Assertion
  • INVALID_LESS_OR_EQUAL : Assertion
  • INVALID_MAX : Assertion
  • INVALID_MAX_COUNT : Assertion
  • INVALID_MAX_LENGTH : Assertion
  • INVALID_METHOD : Assertion
  • INVALID_MIN : Assertion
  • INVALID_MIN_COUNT : Assertion
  • INVALID_MIN_LENGTH : Assertion
  • INVALID_NOT_BLANK : Assertion
  • INVALID_NOT_EQ : Assertion
  • INVALID_NOT_INSTANCE_OF : Assertion
  • INVALID_NOT_REGEX : Assertion
  • INVALID_NOT_SAME : Assertion
  • INVALID_NUMERIC : Assertion
  • INVALID_OBJECT : Assertion
  • INVALID_PROPERTY : Assertion
  • INVALID_RANGE : Assertion
  • INVALID_READABLE : Assertion
  • INVALID_REGEX : Assertion
  • INVALID_RESOURCE : Assertion
  • INVALID_SAME : Assertion
  • INVALID_SATISFY : Assertion
  • INVALID_SCALAR : Assertion
  • INVALID_STRING : Assertion
  • INVALID_STRING_CONTAINS : Assertion
  • INVALID_STRING_END : Assertion
  • INVALID_STRING_NOT_CONTAINS : Assertion
  • INVALID_STRING_START : Assertion
  • INVALID_SUBCLASS_OF : Assertion
  • INVALID_TRAVERSABLE : Assertion
  • INVALID_TRUE : Assertion
  • INVALID_UNIQUE_VALUES : Assertion
  • INVALID_URL : Assertion
  • INVALID_UUID : Assertion
  • INVALID_VALUE_IN_ARRAY : Assertion
  • INVALID_VERSION : Assertion
  • INVALID_WRITEABLE : Assertion
  • invalidate() : ConsentsModel
  • invalidateAll() : ConsentsModel
  • invalidateFileCache() : File
  • invalidBase64String() : CannotDecodeContent
  • invalidLength() : ConversionFailed
  • invalidUcs : AbstractPunycode
  • invert() : ArrayHelper
  • invokeAssertions() : ConjunctionInterceptor
  • invokeInternalStreamWrapper() : PharStreamWrapper
  • ip() : Assertion , Assert
  • IPAD : WebClient
  • iPAddress() : X509
  • IPHONE : WebClient
  • IPinList() : IpHelper
  • IPOD : WebClient
  • ipToNetAddress() : LdapClient
  • ipv4() : Assertion , Assert
  • ipv6() : Assertion , Assert
  • is() : PhpToken
  • is64BitSystem() : FeatureSet
  • IS_ARRAY : InputArgument
  • is_ascii() : StringHelper , ASCII
  • IS_CONSTRUCTED : Identifier
  • is_dir() : SFTP
  • is_file() : SFTP
  • IS_INVISIBLE : libsodium , MontgomeryPrivate , MontgomeryPublic
  • is_link() : SFTP
  • is_readable() : SFTP
  • IS_REPEATABLE : Attribute
  • is_stringable() : Strings
  • is_valid_point() : ParagonIE_Sodium_Core_Ristretto255
  • is_writable() : SFTP
  • is_writeable() : SFTP
  • is_zero() : ParagonIE_Sodium_Compat
  • isAbsolutePath() : Helper
  • isActive() : DaemonApplication , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • isAdminMultilang() : ModuleHelper
  • isAjaxHandlerAutoShow() : JavascriptRenderer
  • isAjaxHandlerBoundToFetch() : JavascriptRenderer
  • isAjaxHandlerBoundToJquery() : JavascriptRenderer
  • isAjaxHandlerBoundToXHR() : JavascriptRenderer
  • isAjaxRequest() : PlgSystemStats
  • isAllowedUser() : PlgSystemStats
  • isAnyOf() : Assert
  • isAOf() : Assert
  • isApplicationClass() : Identifier
  • isAriaAttribute() : Sanitizer
  • isArray() : Assertion , InputArgument , InputOption , Assert
  • isArrayAccessible() : Assertion , Assert
  • isAscii() : AbstractWebApplication
  • isAssetActive() : WebAssetManager , WebAssetManagerInterface
  • isAssoc() : Question
  • isAssociative() : ArrayHelper
  • isAuthenticated() : Client , SSH2
  • isAuthorisedDisplayChecker() : PlgSystemJooa11y
  • isAuthorisedDisplayDebug() : PlgSystemDebug
  • isAutoExitEnabled() : Application
  • isAutoReload() : TraceableTwigEnvironment
  • isBackupCode() : BackupcodesModel
  • isBelow() : Tar , Zip
  • isBinaryString() : Inline
  • isBound() : ConnectionInterface , Connection
  • isBrowser() : Browser
  • isCallable() : Assertion , Assert
  • isCaptiveMFA() : PlgSystemStats
  • isCheckedOut() : BaseDatabaseModel , Table
  • isCheckoutItem() : AssociationsHelper
  • isChecksumValid() : InstallerHelper , UpdateModel
  • isClassMapAuthoritative() : ClassLoader
  • isCli() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • isClient() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • isCommandEnabled() : BeforeCommandExecuteEvent
  • isCommon() : Helper
  • isCompatible() : Version
  • isConfirmed() : PharInvocation
  • isConnected() : RedisStorage , FtpClient , LdapClient , SSH2
  • isConnectionEncryptionSupported() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • isConstructed() : Identifier
  • isContextSpecificClass() : Identifier
  • isCountable() : Assertion , Inflector , Assert
  • isCredentialIdAllowed() : AuthenticatorAssertionResponseValidator
  • isCurrentLineBlank() : Parser
  • isCurrentLineComment() : Parser
  • isCurrentLineEmpty() : Parser
  • isCurrentLineLastLineInDocument() : Parser
  • isCursorFree() : CompletionInput
  • isDataAttribute() : Sanitizer
  • isDatabaseTypeSupported() : UpdateModel
  • isDataPersisted() : DebugBar
  • isDebug() : TraceableTwigEnvironment , NullOutput , Output , OutputInterface , OutputStyle , HtmlErrorRenderer
  • isDebugEnabled() : FormField , BaseLayout , PlgSystemStats
  • isDecorated() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , NullOutput , Output , OutputInterface , OutputStyle
  • isdefault() : JGrid
  • isDefined() : OptionsResolver
  • isDeprecated() : OptionsResolver
  • isDir() : CaBundle
  • isDownload() : XmlDocument
  • isDue() : CronExpression
  • isElementContainedIn() : Helper
  • isEmailAddress() : MailHelper
  • isEmpty() : AbstractString , Assert
  • isEnabled() : ComponentHelper , LibraryHelper , ModuleHelper , Associations , Multilanguage , Microdata , PluginHelper , AbstractCommand , Command , LazyCommand
  • isEOF() : StringStream , ZIPExtraction
  • isEqualTo() : BigNumber , LdapUser
  • isError() : PHPMailer
  • isEven() : BigInteger
  • isException() : ExceptionHandler
  • isExcluded() : Cache
  • isExpired() : Token
  • isFailIfUnknown() : ExtensionDescriptor
  • isFile() : CaBundle
  • isFreshUserVerificationRequired() : MetadataStatement
  • isGithubActionEnvironment() : GithubActionReporter
  • isGreaterThan() : BigNumber , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • isGreaterThanOrEqualTo() : BigNumber
  • isHash() : Inline
  • isHidden() : AbstractCommand , Command , Question
  • isHiddenFallback() : Question
  • isHrefSafeValue() : Sanitizer
  • isHtml() : Mail
  • isHTML() : PHPMailer
  • isHtml5() : HtmlDocument
  • isHtmlVarDumperUsed() : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • isHttpsForced() : CMSApplication
  • isIdentifiedBy() : Token
  • isIdentifier() : Resource
  • isIgnorable() : PhpToken
  • isIgnoredDirectory() : ZIPExtraction
  • isImage() : MediaHelper , BannerHelper
  • isInAllowedUserGroup() : Token , PlgUserToken
  • isIncrementsOfRanges() : AbstractField
  • isInDevelopmentState() : Version
  • isInflectedWord() : FrenchInflector
  • isInIncrementsOfRanges() : AbstractField
  • isInRange() : AbstractField
  • isInstalled() : InstalledVersions , ComponentHelper
  • isInstanceOf() : Assertion , Assert
  • isInstanceOfAny() : Assert
  • isInteractive() : Input , InputInterface , LdapAuthenticator
  • isInteractiveInput() : QuestionHelper
  • isInternal() : Uri
  • isIPv6() : IpHelper
  • isIterable() : Assert
  • isJoomlaStream() : FilesystemHelper , Helper
  • isJqueryNoConflictEnabled() : JavascriptRenderer
  • isJsonString() : Assertion
  • isKeyRestricted() : MetadataStatement
  • isLeaf() : Nested
  • isLessThan() : BigNumber
  • isLessThanInt() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • isLessThanOrEqualTo() : BigNumber
  • isList() : Assert
  • isLoaded() : Image
  • isLogQueriesToLogger() : PropelCollector
  • isLongForm() : Identifier
  • isMail() : PHPMailer
  • isManifest() : Installer
  • isMap() : Assert
  • isMariaDb() : MysqlDriver , MysqliDriver
  • isMediaFile() : ApiModel
  • isMinimumTimeBefore() : Token
  • isMinimumVersion() : DatabaseDriver , DatabaseInterface
  • isMissing() : OptionsResolver
  • isMobile() : Browser
  • isMultiline() : Question
  • isMultiselect() : ChoiceQuestion
  • isNegatable() : InputOption
  • isNegative() : BCMath , BigNumber , BigInteger , BigIntegerBcmath , BigIntegerGmp , BCMath , GMP , PHP , BigInteger
  • isNegativeOrZero() : BigNumber
  • isNested() : TagField , OptionsResolver
  • isNew() : Session , SessionInterface
  • isNextLineIndented() : Parser
  • isNextLineUnIndentedCollection() : Parser
  • isNonEmptyList() : Assert
  • isNonEmptyMap() : Assert
  • isNonStandardPort() : Uri
  • isNormalized() : Normalizer
  • isNotA() : Assert
  • isNullDatetime() : DatabaseQuery , QueryInterface
  • isObject() : Assertion
  • isOdd() : BigInteger , BCMath , GMP , PHP , BigInteger , Integer
  • isolateNamespace() : XML
  • isOpensslParseSafe() : CaBundle
  • isOption() : ConnectionOptions
  • isOverwrite() : Installer
  • isOwner() : Path
  • isPackageUninstall() : Installer
  • isPathAbsolute() : WebAssetItem
  • isPathExternal() : WebAssetItem
  • isPayloadDetached() : JWS
  • isPayloadEmpty() : JWSVerifier
  • isPayloadEncoded() : Serializer
  • isPermittedFor() : Token
  • isPermittedPath() : PHPMailer
  • isPhpVersionSupported() : UpdateModel
  • isPlural() : Inflector
  • isPositive() : BigNumber
  • isPositiveOrZero() : BigNumber
  • isPrepared() : TracedStatement
  • isPrimaryProvider() : ProviderAwareAuthenticationPluginInterface
  • isPrime() : Engine , BigInteger
  • isPrivate() : Ec2Key , OkpKey , RsaKey
  • isPrivateClass() : Identifier
  • isPropertyInType() : Microdata
  • isProtected() : Container , ContainerResource
  • isPrototype() : OptionsResolver
  • isPTYEnabled() : SSH2
  • isPublic() : RsaKey , RSAKey
  • isQmail() : PHPMailer
  • isQuiet() : NullOutput , Output , OutputInterface , OutputStyle
  • isQuietModeEnabled() : SSH2
  • isRange() : AbstractField
  • isReadable() : CaBundle , CallbackStream , RelativeStream , Stream , StreamInterface , LintCommand
  • isRedirectState() : AbstractWebApplication
  • isRegistered() : HTMLHelper
  • isRelatedTo() : Token
  • isRemoteSearch() : TagField
  • isRequired() : InputArgument , OptionsResolver
  • isRequireJsUsed() : JavascriptRenderer
  • isRequireResidentKey() : AuthenticatorSelectionCriteria
  • isResolved() : LdapBadge
  • isResource() : Assertion
  • isRobot() : Browser
  • isRtl() : Language
  • isRTL() : PlgInstallerWebinstaller
  • isRunningOS400() : ConsoleOutput
  • isSafeFile() : InputFilter
  • isSatisfied() : AbstractField
  • isSatisfiedBy() : DayOfMonthField , DayOfWeekField , FieldInterface , HoursField , MinutesField , MonthField
  • isSecondFactorOnly() : MetadataStatement
  • isSeekable() : CallbackStream , RelativeStream , Stream , StreamInterface
  • isSendmail() : Mail , PHPMailer
  • isSessionStarted() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • isShared() : Container , ContainerResource
  • isShellSafe() : PHPMailer
  • isShort() : English
  • isSingleCommand() : Application
  • isSingleton() : UserGroupsHelper
  • isSingular() : Inflector
  • isSMTP() : PHPMailer
  • isSqlRenderedWithParams() : PDOCollector
  • isSsl() : AbstractUri , UriInterface
  • isSslConnection() : AbstractWebApplication , WebApplicationInterface
  • isStackAlwaysUseSessionStorage() : DebugBar
  • isStarted() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • isStopped() : AbstractEvent , EventInterface
  • isStrictVariables() : TraceableTwigEnvironment
  • isStringable() : LazyString
  • isStringUnIndentedCollectionItem() : Parser
  • isSubArrayValid() : X509
  • isSuccess() : TracedStatement , Task , Response
  • ISSUED_AT : RegisteredClaims
  • issuedAt() : Builder
  • issuedBy() : Builder
  • ISSUER : RegisteredClaims
  • isSupported() : Bzip2 , ExtractableInterface , Gzip , Tar , Zip , Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler , CacheStorage , ApcuStorage , MemcachedStorage , RedisStorage , WincacheStorage , CryptoCipher , SodiumCipher , AesInterface , Aes , Mcrypt , OpenSSL , CurlTransport , SocketTransport , StreamTransport , Crypto , OpenSSL , Sodium , CipherInterface , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver , Curl , Socket , Stream , TransportInterface , ApcuHandler , DatabaseHandler , FilesystemHandler , MemcachedHandler , RedisHandler , WincacheHandler , HandlerInterface , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing , SignalRegistry
  • isTemplateActive() : UpdateModel
  • isTemplated() : LinkInterface , Link
  • isTemplateFresh() : TraceableTwigEnvironment
  • isTimeout() : SSH2
  • isTokenEnabledForUser() : Token
  • isTraitable() : TraceableTwigTemplate
  • isTranslatedText() : ModulesHelper
  • isTransparent() : Image
  • isTraversable() : Assertion , Assert
  • isTrimmable() : Question
  • isTwoFactorAuthenticationRequired() : CMSApplication
  • isTypeAvailable() : Microdata
  • isTypeSupported() : FieldsPlugin
  • isUniversalClass() : Identifier
  • isUpdateRequired() : PlgSystemStats
  • isUpgrade() : Installer
  • isUserConsented() : PlgSystemPrivacyconsent
  • isUserPresent() : AuthenticatorData
  • isUserVerified() : AuthenticatorData
  • isUseTagDirty() : Sanitizer
  • isUseTagExceedingThreshold() : Sanitizer
  • isUtf8() : ByteString
  • isValid() : AbstractString , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , HeaderSecurity , Uuid , AndroidKeyAttestationStatementSupport , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • isValidEngine() : SymmetricKey , Base , BCMath , GMP , OpenSSL , PHP32 , PHP64 , Base , Montgomery
  • isValidEngineHelper() : Blowfish , ChaCha20 , SymmetricKey , DES , RC2 , RC4 , Rijndael , TripleDES
  • isValidExpression() : CronExpression
  • isValidHost() : PHPMailer
  • isValidHttpStatus() : AbstractWebApplication , WebApplicationInterface
  • isValidId() : Task
  • isValidLocalDirectory() : MediaHelper
  • isValidOtep() : UserModel
  • isValidSecretKey() : UserModel
  • isValidState() : Task
  • isValidStreamResourceType() : Stream
  • isValueOptional() : InputOption
  • isValueRequired() : InputOption
  • isVerbose() : NullOutput , Output , OutputInterface , OutputStyle
  • isVeryVerbose() : NullOutput , Output , OutputInterface , OutputStyle
  • isViewable() : Browser
  • isWindows() : Helper
  • isWindowsTrueColor() : CliDumper
  • isWorkflowActive() : WorkflowServiceInterface
  • isWritable() : CallbackStream , PhpInputStream , RelativeStream , Stream , StreamInterface
  • isZero() : BigNumber
  • ITALIAN_LANGUAGE_CODE : ASCII
  • ITEM : OnGetApiFields
  • itemAccessChange() : Adapter
  • itemStateChange() : Adapter
  • iterate() : ProgressBar


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- j -

  • jacobianAddPoint() : Prime
  • jacobianAddPointMixedX() : Prime
  • jacobianAddPointMixedXY() : Prime
  • jacobianDoublePoint() : KoblitzPrime , Prime
  • jacobianDoublePointMixed() : KoblitzPrime , Prime
  • JAPANESE_LANGUAGE_CODE : ASCII
  • join() : DatabaseQuery , QueryInterface , AbstractString , AbstractUnicodeString , ByteString , UnicodeString
  • jooa11y() : ToolbarHelper
  • jsonDecode() : Decoder
  • jsonEncode() : JsonResponse , Encoder
  • jsonIssues() : CannotDecodeContent , CannotEncodeContent
  • jsonSerialize() : BigNumber , JsonapiDocument , DataObject , DataSet , Registry , JWK , JWKSet , Basic , Engine , BigInteger , Integer , Uuid , SilencedErrorContext , AbstractString , LazyString , Document , AttestationStatement , AttestedCredentialData , AuthenticationExtension , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialEntity , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , CertificateTrustPath , EcdaaKeyIdTrustPath , EmptyTrustPath


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- k -

  • k() : SymmetricKey
  • karatsuba() : PHP
  • KARATSUBA_CUTOFF : PHP
  • karatsubaSquare() : PHP
  • KAZAKH_LANGUAGE_CODE : ASCII
  • kdf() : Hash
  • keep() : HistoryController , HistoryModel
  • keepalive() : Behavior
  • key() : Construct , DataSet , DatabaseIterator , SplFixedArray
  • KEY_BYTE_SIZE : Crypto , Core , Key
  • KEY_CURRENT_VERSION : Key
  • key_exchange() : SSH2
  • KEY_OPS : Key
  • KEY_PROTECTION_HARDWARE : MetadataStatement
  • KEY_PROTECTION_REMOTE_HANDLE : MetadataStatement
  • KEY_PROTECTION_SECURE_ELEMENT : MetadataStatement
  • KEY_PROTECTION_SOFTWARE : MetadataStatement
  • KEY_PROTECTION_TEE : MetadataStatement
  • keyboard_interactive_login() : SSH2
  • keyboard_interactive_process() : SSH2
  • KEYBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • keyExchange() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • keyExists() : Assertion , Assert
  • keyIsset() : Assertion
  • keyNotExists() : Assertion , Assert
  • keypair() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • KEYPAIR_BYTES : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • keys() : DataSet
  • KHTML : WebClient
  • KID : Key
  • KIRGHIZ_LANGUAGE_CODE : ASCII
  • KNOCKOUT : Status
  • KOREAN_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- l -

  • L : ParagonIE_Sodium_Core_Curve25519_H
  • L1Hash() : Hash
  • L2Hash() : Hash
  • L3Hash() : Hash
  • lang() : PHPMailer
  • LANGS : StemmerFactory
  • language() : Users
  • languageAssociations() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • LARGE_OBJECT : ParameterType
  • LAST : FetchOrientation
  • lastInsertId() : TraceablePDO
  • LATVIAN_LANGUAGE_CODE : ASCII
  • layout() : ToolbarButton
  • lazy() : Assert
  • lBase : NamePrep
  • lCount : NamePrep
  • LDAP_ALREADY_EXISTS : Connection
  • LDAP_INVALID_CREDENTIALS : Connection
  • LDAP_TIMEOUT : Connection
  • ldapNetAddr() : LdapClient
  • LE : POP3 , SMTP
  • leave() : TimeableTwigExtensionProfiler
  • leaveHash() : DumperInterface , CliDumper , HtmlDumper
  • leftJoin() : DatabaseQuery
  • leftRotate() : Salsa20
  • LEGACY_AUTHENTICATION_INFO_STRING : Core
  • LEGACY_BLOCK_BYTE_SIZE : Core
  • LEGACY_CIPHER_METHOD : Core
  • LEGACY_ENCRYPTION_INFO_STRING : Core
  • LEGACY_HASH_FUNCTION_NAME : Core
  • LEGACY_KEY_BYTE_SIZE : Core
  • LEGACY_MAC_BYTE_SIZE : Core
  • len64() : SymmetricKey
  • length() : Assertion , DatabaseQuery , QueryInterface , SqlsrvQuery , Helper , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • lengthBetween() : Assert
  • lessOrEqualThan() : Assertion
  • lessThan() : Assertion , Assert
  • lessThanEq() : Assert
  • level() : Access
  • lexInlineMapping() : Parser
  • lexInlineQuotedString() : Parser
  • lexInlineSequence() : Parser
  • lexInlineStructure() : Parser
  • lexUnquotedString() : Parser
  • LF : AbstractSerializer
  • LIBRARY_MAJOR_VERSION : ParagonIE_Sodium_Compat
  • LIBRARY_MINOR_VERSION : ParagonIE_Sodium_Compat
  • LIBRARY_VERSION_MAJOR : ParagonIE_Sodium_Compat
  • library_version_major() : ParagonIE_Sodium_Compat
  • library_version_minor() : ParagonIE_Sodium_Compat
  • LIBRARY_VERSION_MINOR : ParagonIE_Sodium_Compat
  • link() : PreloadManager , Links , HTMLHelper , Route , ToolbarHelper
  • linkOptions() : Menu
  • links() : Links
  • linksgroups() : Links
  • linkXHTMLSafe() : OutputFilter
  • linkXhtmlSafe() : OutputFilter
  • LINUX : WebClient
  • list() : Manager , ManagerFactory
  • LIST : OnGetApiFields
  • list() : AlgorithmManager , JWSSerializerManager
  • listDetails() : FtpClient
  • listen() : DumpServer
  • listFolderTree() : Folder
  • listing() : StyleInterface , SymfonyStyle
  • listNames() : FtpClient
  • listRevoked() : X509
  • LITHUANIAN_LANGUAGE_CODE : ASCII
  • load() : JLoader , JNamespacePsr4Map , Form , ModuleHelper , UserGroupsHelper , Language , AbstractMenu , AdministratorMenu , Table , TableInterface , User , MfaTable , CssMenu , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , MetadataRepository , Autoloader , AsymmetricKey , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , PKCS1 , PKCS8 , DH , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , XML , ASN1 , SSH2 , libsodium , MontgomeryPrivate , MontgomeryPublic , OpenSSH , PKCS1 , PKCS8 , PuTTY , XML , ASN1 , SSH2 , PublicKeyLoader , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML , PlgInstallerOverride , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationObjectLoader , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AuthenticationExtensionsClientOutputsLoader , PublicKeyCredentialLoader
  • loadActionLogPluginsLanguage() : ActionlogsHelper
  • loadAdapter() : Installer
  • loadAliasFor() : JLoader
  • loadAll() : UserGroupsHelper
  • loadAllAdapters() : Adapter
  • loadAndCheckAssertionResponse() : Server
  • loadAndCheckAttestationResponse() : Server
  • loadAndVerifyWithKey() : JWSLoader
  • loadAndVerifyWithKeySet() : JWSLoader
  • loadArray() : Registry , PublicKeyCredentialLoader
  • loadAssoc() : DatabaseDriver , DatabaseInterface
  • loadAssocList() : DatabaseDriver , DatabaseInterface
  • loadBasicType() : PackedAttestationStatementSupport
  • loadButtonClass() : ContainerAwareToolbarFactory
  • loadButtonType() : Toolbar
  • loadByAlias() : JLoader
  • loadByName() : Asset
  • loadByPsr() : JLoader
  • loadByPsr4() : JLoader
  • loadBytesFromChecksummedAsciiSafeString() : Encoding
  • loadCA() : X509
  • loadCaptiveRenderOptions() : CaptiveModel
  • loadChangelog() : ManageModel
  • loadClass() : ClassLoader , FormHelper , DebugClassLoader
  • loadClassLoader() : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f
  • loadColumn() : DatabaseDriver , DatabaseInterface
  • loadComponentLanguage() : LanguageHelper
  • loadConfiguration() : DaemonApplication
  • loadCRL() : X509
  • loadCSR() : X509
  • loadCss() : Bootstrap , MediaActionPlugin , PlgMediaActionCrop
  • loadCurveByParam() : XML
  • loadCurveByParamRFC4050() : XML
  • loadDocument() : WebApplication , AbstractRenderer , InstallationApplication
  • loadEcdaaType() : PackedAttestationStatementSupport
  • loadEdDSA() : PKCS8
  • loadEmptyType() : PackedAttestationStatementSupport
  • loadField() : Form
  • loadFieldClass() : FormHelper
  • loadFieldType() : FormHelper
  • loadFile() : Form , Image , Registry
  • loadFilterClass() : FormHelper
  • loadFilterType() : FormHelper
  • loadForm() : FormModel
  • loadFormat() : AsymmetricKey
  • loadFormData() : ListModel , BannerModel , ClientModel , DownloadModel , CategoryModel , ComponentModel , FormModel , ContactModel , ArticleModel , FieldModel , GroupModel , FilterModel , UpdateModel , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , ItemModel , MenuModel , MessageModel , ModuleModel , NewsfeedModel , PluginModel , PluginsModel , RequestModel , LinkModel , TagModel , StyleModel , TemplateModel , GroupModel , LevelModel , MailModel , NoteModel , UserModel , LoginModel , ProfileModel , RegistrationModel , StageModel , TransitionModel , WorkflowModel
  • loadFromAsciiSafeString() : Key , KeyProtectedByPassword
  • loadFromWeb() : OID
  • loadFromXml() : Changelog , Update
  • loadHelper() : LegacyComponent , HtmlView , AssociationsHelper
  • loadIdentity() : CMSApplicationInterface
  • loadJs() : MediaActionPlugin , PlgMediaActionCrop
  • loadLanguage() : WebApplication , AbstractModuleDispatcher , ApiDispatcher , ComponentDispatcher , ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , Language , CMSPlugin , Dispatcher
  • loadLanguageFiles() : ContenthistoryHelper
  • loadLanguageForComponent() : ConfigHelper
  • loadLanguageForComponents() : ConfigHelper
  • loadLanguageSuffixes() : FileLayout
  • loadLibraryLanguage() : CMSApplication , SiteApplication
  • loadManifestFromData() : LibraryManifest , Manifest , PackageManifest
  • loadManifestFromXml() : Manifest
  • loadMap() : Iconv
  • loadMD5Sum() : Installer
  • loadObject() : DatabaseDriver , DatabaseInterface , Registry
  • loadObjectList() : DatabaseDriver , DatabaseInterface
  • loadOIDs() : ASN1
  • loadParameters() : AsymmetricKey , PublicKeyLoader
  • loadParametersFormat() : AsymmetricKey
  • loadPluginLanguage() : LanguageHelper
  • loadPlugins() : AsymmetricKey
  • loadPreset() : MenusHelper
  • loadPrivateKey() : AsymmetricKey , PublicKeyLoader
  • loadPrivateKeyFormat() : AsymmetricKey
  • loadPublicKey() : AsymmetricKey , PublicKeyLoader
  • loadPublicKeyFormat() : AsymmetricKey
  • loadRenderer() : Document , ErrorDocument
  • loadResult() : DatabaseDriver , DatabaseInterface
  • loadRow() : DatabaseDriver , DatabaseInterface
  • loadRowList() : DatabaseDriver , DatabaseInterface
  • loadRuleClass() : FormHelper
  • loadRuleType() : FormHelper
  • loadSession() : WebApplication
  • loadSPKAC() : X509
  • loadString() : Registry , ANSI
  • loadSubForm() : SubformField
  • loadSubFormData() : SubformField
  • loadSystemUris() : AbstractWebApplication , WebApplication
  • loadTemplate() : TraceableTwigEnvironment , HtmlView
  • loadTranslationFiles() : ActionlogsHelper , MailsHelper
  • loadTrustPath() : TrustPathLoader
  • loadType() : FormHelper
  • loadTypes() : Microdata
  • loadUser() : LdapUserProvider
  • loadUserById() : UserFactory , UserFactoryInterface
  • loadUserByIdentifier() : LdapUserProvider
  • loadUserByUsername() : UserFactory , UserFactoryInterface , LdapUserProvider
  • loadVersionSuffixes() : FileLayout
  • loadX509() : X509
  • loadXml() : MenusHelper
  • LOCALE_TO_TRANSLITERATOR_ID : AsciiSlugger
  • LOCALITY_NAME : OID
  • lock() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , WebAssetManager
  • lockindex() : MemcachedStorage
  • lockTable() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • log() : PropelCollector , MessagesCollector , DelegatingPsrLogger , Task , LoggerInterface , NullLogger , GithubActionReporter , CompleteCommand , ConsoleLogger , BufferingLogger
  • LOG_COMPLEX : SSH2
  • LOG_DEBUG : ZIPExtraction
  • LOG_ERROR : ZIPExtraction
  • LOG_INFO : ZIPExtraction
  • LOG_MAX_SIZE : SSH2
  • LOG_REALTIME : SSH2
  • LOG_REALTIME_FILE : SSH2
  • LOG_SIMPLE : SSH2
  • LOG_TEXT : Scheduler
  • LOG_WARNING : ZIPExtraction
  • logError() : SFTP
  • logException() : ExceptionHandler
  • logExport() : ExportModel
  • logExportEmailed() : ExportModel
  • logger() : PlgSystemDebug
  • login() : AdministratorApplication , CMSApplication , SiteApplication , FtpClient , DisplayController , UserController , FtpClient , POP3 , SSH2
  • login_helper() : SSH2
  • logout() : CMSApplication , DisplayController , UserController
  • logRemove() : RemoveModel
  • logRemoveBlocked() : RemoveModel
  • logSearch() : FinderHelper
  • LONG_FORM : Identifier
  • lookupItem() : RouteHelper
  • LOW : Priority
  • lower() : AbstractString , AbstractUnicodeString , ByteString , Assert
  • lowerThan() : BigInteger
  • lshift() : PHP
  • lstat() : SFTP
  • ltrim() : StringHelper


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- m -

  • MAC : WebClient
  • mac_algorithm_to_hash_instance() : SSH2
  • MAC_BYTE_SIZE : Crypto , Core
  • MACEDONIAN_LANGUAGE_CODE : ASCII
  • MAGIC_METHODS : DebugClassLoader
  • mail() : SMTP
  • MAIL_GROUP : GetConfigurationCommand
  • MAIL_MAX_LINE_LENGTH : PHPMailer
  • mailPassthru() : PHPMailer
  • mailSend() : PHPMailer
  • mailtags() : MailsHelper
  • MAJOR_TYPE : ByteStringObject , ByteStringWithChunkObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject
  • MAJOR_VERSION : Version
  • make_odd() : BCMath , GMP , PHP
  • makeCA() : X509
  • makeDefault() : ToolbarHelper
  • makeFilename() : FileStorage
  • makeGetRequest() : Requests
  • makeId() : Cache
  • makeItem() : Pathway
  • makeNumeric() : Identifier
  • makeSafe() : File , Folder , File , Folder
  • makeTransportRequest() : Http
  • makeUriRelativeTo() : JavascriptRenderer
  • manages() : AuthenticationFailedExceptionHandler , CheckinCheckoutExceptionHandler , InvalidRouteExceptionHandler , NotAcceptableExceptionHandler , NotAllowedExceptionHandler , ResourceNotFoundExceptionHandler , SaveExceptionHandler , SendEmailExceptionHandler , ExceptionHandlerInterface , FallbackExceptionHandler , InvalidParameterExceptionHandler
  • MAP : AccessDescription , AdministrationDomainName , AlgorithmIdentifier , AnotherName , Attribute , Attributes , AttributeType , AttributeTypeAndValue , AttributeValue , AuthorityInfoAccessSyntax , AuthorityKeyIdentifier , BaseDistance , BasicConstraints , BuiltInDomainDefinedAttribute , BuiltInDomainDefinedAttributes , BuiltInStandardAttributes , Certificate , CertificateIssuer , CertificateList , CertificatePolicies , CertificateSerialNumber , CertificationRequest , CertificationRequestInfo , CertPolicyId , Characteristic_two , CountryName , CPSuri , CRLDistributionPoints , CRLNumber , CRLReason , Curve , DHParameter , DigestInfo , DirectoryString , DisplayText , DistributionPoint , DistributionPointName , DSAParams , DSAPrivateKey , DSAPublicKey , DssSigValue , EcdsaSigValue , ECParameters , ECPoint , ECPrivateKey , EDIPartyName , EncryptedData , EncryptedPrivateKeyInfo , Extension , ExtensionAttribute , ExtensionAttributes , Extensions , ExtKeyUsageSyntax , FieldElement , FieldID , GeneralName , GeneralNames , GeneralSubtree , GeneralSubtrees , HashAlgorithm , HoldInstructionCode , InvalidityDate , IssuerAltName , IssuingDistributionPoint , KeyIdentifier , KeyPurposeId , KeyUsage , MaskGenAlgorithm , Name , NameConstraints , netscape_ca_policy_url , netscape_cert_type , netscape_comment , NetworkAddress , NoticeReference , NumericUserIdentifier , OneAsymmetricKey , ORAddress , OrganizationalUnitNames , OrganizationName , OtherPrimeInfo , OtherPrimeInfos , PBEParameter , PBES2params , PBKDF2params , PBMAC1params , Pentanomial , PersonalName , PKCS9String , PolicyInformation , PolicyMappings , PolicyQualifierId , PolicyQualifierInfo , PostalAddress , Prime_p , PrivateDomainName , PrivateKey , PrivateKeyInfo , PrivateKeyUsagePeriod , PublicKey , PublicKeyAndChallenge , PublicKeyInfo , RC2CBCParameter , RDNSequence , ReasonFlags , RelativeDistinguishedName , RevokedCertificate , RSAPrivateKey , RSAPublicKey , RSASSA_PSS_params , SignedPublicKeyAndChallenge , SpecifiedECDomain , SubjectAltName , SubjectDirectoryAttributes , SubjectInfoAccessSyntax , SubjectPublicKeyInfo , TBSCertificate , TBSCertList , TerminalIdentifier , Time , Trinomial , UniqueIdentifier , UserNotice , Validity
  • mapBase() : UCMBase
  • mapData() : UCMContent
  • mapFromUtf8() : Iconv
  • mapInAttributes() : X509
  • mapInDNs() : X509
  • mapInExtensions() : X509
  • mapIso8859_1ToWindows1252() : FromUtf8
  • mapOutAttributes() : X509
  • mapOutDNs() : X509
  • mapOutExtensions() : X509
  • MAPPINGS : CronExpression
  • mapProtocolVersion() : Curl
  • mapslist() : Finder
  • mapToUtf8() : Iconv
  • mapWindows1252ToIso8859_1() : ToUtf8
  • mark() : Profiler
  • markResolved() : LdapBadge
  • markSubjectAsInvalid() : Resolver
  • MASK_CONNECTED : SSH2
  • MASK_CONSTRUCTOR : SSH2
  • MASK_LOGIN : SSH2
  • MASK_LOGIN_REQ : SSH2
  • MASK_SHELL : SSH2
  • MASK_WINDOW_ADJUST : SSH2
  • match() : Browser , AbstractNegotiator , LanguageNegotiator , Negotiator , AbstractString , AbstractUnicodeString , ByteString
  • MATCHED_DN : ConnectionOptions
  • MATCHER_PROTECTION_ON_CHIP : MetadataStatement
  • MATCHER_PROTECTION_SOFTWARE : MetadataStatement
  • MATCHER_PROTECTION_TEE : MetadataStatement
  • matches() : Pattern , Patterns , CommandIsSuccessful
  • max() : Assertion , BigNumber
  • MAX : Priority
  • max() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • MAX10 : PHP32 , PHP64
  • MAX10LEN : PHP32 , PHP64
  • MAX_DIGIT : PHP32 , PHP64
  • MAX_DIGIT2 : PHP32 , PHP64
  • MAX_EXEC_TIME : ZIPExtraction
  • MAX_LINE_LENGTH : PHPMailer , SMTP , SymfonyStyle
  • MAX_POWER : Calculator
  • MAX_REPLY_LENGTH : SMTP
  • MAX_STATUS_CODE_VALUE : Response
  • maxCount() : Assertion , Assert
  • maxHelper() : Engine
  • maxLength() : Assertion , Assert
  • maxSecondsBetweenRedraws() : ProgressBar
  • maxUcs : AbstractPunycode
  • MB_CASE_FOLD : Mbstring
  • mb_check_encoding() : Mbstring
  • mb_chr() : Mbstring , Php72
  • mb_convert_case() : Mbstring
  • mb_convert_encoding() : Mbstring
  • mb_convert_variables() : Mbstring
  • mb_decode_mimeheader() : Mbstring
  • mb_decode_numericentity() : Mbstring
  • mb_detect_encoding() : Mbstring
  • mb_detect_order() : Mbstring
  • mb_encode_mimeheader() : Mbstring
  • mb_encode_numericentity() : Mbstring
  • mb_encoding_aliases() : Mbstring
  • mb_get_info() : Mbstring
  • mb_http_input() : Mbstring
  • mb_http_output() : Mbstring
  • mb_internal_encoding() : Mbstring
  • mb_language() : Mbstring
  • mb_list_encodings() : Mbstring
  • mb_ord() : Mbstring , Php72
  • mb_output_handler() : Mbstring
  • mb_pathinfo() : PHPMailer
  • mb_str_split() : Mbstring
  • mb_stripos() : Mbstring
  • mb_stristr() : Mbstring
  • mb_strlen() : Mbstring
  • mb_strpos() : Mbstring
  • mb_strrchr() : Mbstring
  • mb_strrichr() : Mbstring
  • mb_strripos() : Mbstring
  • mb_strrpos() : Mbstring
  • mb_strstr() : Mbstring
  • mb_strtolower() : Mbstring
  • mb_strtoupper() : Mbstring
  • mb_strwidth() : Mbstring
  • mb_substitute_character() : Mbstring
  • mb_substr() : Mbstring
  • mb_substr_count() : Mbstring
  • MD5_WITH_RSA_ENCRYPTION : OID
  • mdsrem() : Twofish
  • measure() : TimeDataCollector , ProfileCollector
  • media_manager() : ToolbarHelper
  • MEDIA_TYPE : Document
  • mediaFolderTree() : HtmlView
  • mediaTree() : HtmlView
  • memcachedGetMulti() : MemcachedStorage
  • memcmp() : ParagonIE_Sodium_Core_Util
  • memzero() : ParagonIE_Sodium_Compat
  • menuItemList() : Menu
  • menuItems() : Menu
  • menulogout() : UserController
  • menus() : Menu
  • merge() : Rules , DataShapeObject , DatabaseQuery , Registry , ConfigPostProcessor , Resource
  • mergeAction() : Rules
  • mergeApplicationDefinition() : AbstractCommand , Command , LazyCommand
  • mergeAttributes() : Resource
  • mergeClonerOptions() : DebugBarVarDumper
  • mergeCollection() : Rules
  • mergeDumperOptions() : DebugBarVarDumper
  • mergeGlobals() : TraceableTwigEnvironment
  • mergeHeadData() : HtmlDocument
  • mergeIdentities() : Rule
  • mergeIdentity() : Rule
  • mergeLabels() : ContenthistoryHelper
  • mergeNode() : Form
  • mergeNodes() : Form
  • mergeRecursive() : ArrayHelper
  • mergeRelationships() : Resource
  • mergeResource() : Document
  • mergeSchemaCache() : DatabaseModel
  • mergeStructure() : DatabaseImporter
  • message() : Directory
  • META_CONTEXT : Indexer
  • methodExists() : Assertion , MethodModel , Assert
  • methodNotExists() : Assert
  • METHODS : Zip
  • mgf1() : RSA
  • min() : Assertion , BigNumber
  • MIN : Priority
  • min() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • MIN_EXEC_TIME : ZIPExtraction
  • MIN_STATUS_CODE_VALUE : Response
  • minCount() : Assertion , Assert
  • minHelper() : Engine
  • minify() : Sanitizer
  • MINIMUM_CIPHERTEXT_SIZE : Core
  • minLength() : Assertion , Assert
  • minMaxBits() : Engine
  • MINOR_VERSION : Version
  • minSecondsBetweenRedraws() : ProgressBar
  • minus() : BigDecimal , BigInteger , BigRational
  • MINUTE : CronExpression
  • minute() : DatabaseQuery , QueryInterface
  • MISC_CONTEXT : Indexer
  • missingOrNotEnoughSeparators() : InvalidTokenStructure
  • MIXED : FetchMode
  • mkdir() : FtpClient , SFTP , PharStreamWrapper
  • mkdir_helper() : SFTP
  • mod() : BCMath , BigInteger , Calculator , BigInteger
  • modal() : Bootstrap , ToolbarHelper
  • MODE_3CBC : TripleDES
  • MODE_ALLOW_ALWAYS : PlgSystemStats
  • MODE_ALLOW_NEVER : PlgSystemStats
  • MODE_ANY : PKCS
  • MODE_CBC : SymmetricKey
  • MODE_CBC3 : TripleDES
  • MODE_CFB : SymmetricKey
  • MODE_CFB8 : SymmetricKey
  • MODE_CTR : SymmetricKey
  • MODE_DER : PKCS
  • MODE_ECB : SymmetricKey
  • MODE_GCM : SymmetricKey
  • MODE_INSTANCE : UserGroupsHelper
  • MODE_MAP : SymmetricKey
  • MODE_OFB : SymmetricKey
  • MODE_OFB8 : SymmetricKey
  • MODE_PEM : PKCS
  • MODE_SINGLETON : UserGroupsHelper
  • MODE_STREAM : SymmetricKey
  • MODES : RedisCaster
  • modifiedBy() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • modify() : LdapClient
  • modifyHeader() : BaseSigner , Signer
  • modInverse() : BigInteger , GmpCalculator , Calculator , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • modInverse67108864() : Montgomery
  • modPow() : BigInteger , BcMathCalculator , GmpCalculator , Calculator , NativeCalculator , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • modulus() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • modulusMustNotBeZero() : DivisionByZeroException
  • MONGOLIAN_LANGUAGE_CODE : ASCII
  • MONTH : CronExpression
  • month() : DatabaseQuery , QueryInterface
  • MONTH_ABBR : Date
  • MONTH_NAME : Date
  • monthToString() : Date
  • mostRecentlyEnteredValue() : QuestionHelper
  • move() : File , Folder , Stream , Nested , Table , AdapterInterface , ApiModel , File , Folder , Stream , LocalAdapter , EntryManagerInterface , EntryManager
  • moveByReference() : Nested
  • moveCliFiles() : InstallerScript
  • moveDown() : Cursor
  • moveFile() : LocalAdapter
  • moveFolder() : LocalAdapter
  • moveLeft() : Cursor
  • moveRemainingTemplateFiles() : JoomlaInstallerScript
  • moveRight() : Cursor
  • moveTo() : UploadedFile , UploadedFileInterface
  • moveToClosingElement() : FeedParser
  • moveToColumn() : Cursor
  • moveToNextElement() : FeedParser
  • moveToNextLine() : Parser
  • moveToPosition() : Cursor
  • moveToPreviousLine() : Parser
  • moveUp() : Cursor
  • MSB : PHP32 , PHP64
  • MSG_ALERT : CMSApplicationInterface
  • MSG_CRITICAL : CMSApplicationInterface
  • MSG_DEBUG : CMSApplicationInterface
  • MSG_EMERGENCY : CMSApplicationInterface
  • MSG_ERROR : CMSApplicationInterface
  • MSG_INFO : CMSApplicationInterface
  • MSG_NOTICE : CMSApplicationInterface
  • MSG_WARNING : CMSApplicationInterface
  • msgHTML() : PHPMailer
  • mul() : BCMath , BcMathCalculator , GmpCalculator , Calculator , NativeCalculator
  • mulInt32Fast() : ParagonIE_Sodium_Core32_Int32
  • mulInt64Fast() : ParagonIE_Sodium_Core32_Int64
  • mulIntFast() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • multipliedBy() : BigDecimal , BigInteger , BigRational
  • multiply() : BigInteger , BigIntegerBcmath , BigIntegerGmp , BigInteger , PrivateKey , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • multiplyAddPoints() : Base , KoblitzPrime , Prime
  • multiplyHelper() : PHP
  • multiplyLower() : Barrett
  • multiplyPoint() : Base , Montgomery , Curve25519 , Curve448
  • multiplyReduce() : Base , MontgomeryMult
  • multiselect() : Behavior
  • mustRun() : ProcessHelper
  • mustSuggestArgumentValuesFor() : CompletionInput
  • mustSuggestOptionValuesFor() : CompletionInput
  • MYANMAR_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- n -

  • n() : RsaKey , CliDumper
  • name() : ToolbarButton , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Algorithm , Hash , EdDSA , ES256 , ES256K , ES384 , ES512 , HS1 , HS256 , HS256_64 , HS384 , HS512 , None , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512
  • NAME : CompactSerializer
  • name() : CompactSerializer
  • NAME : JSONFlattenedSerializer
  • name() : JSONFlattenedSerializer , JSONGeneralSerializer
  • NAME : JSONGeneralSerializer
  • name() : JWSSerializer , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AuthenticationExtension
  • NAMED_CURVE_OID : Ec2Key
  • names() : JWSSerializerManagerFactory
  • NAMESPACE_DNS : Uuid
  • NAMESPACE_OID : Uuid
  • NAMESPACE_URL : Uuid
  • NAMESPACE_X500 : Uuid
  • namespaceReverse() : RewriteRules
  • namespaceRewrite() : RewriteRules
  • natural() : Assert
  • nCount : NamePrep
  • nd() : BigRational
  • needsRekey() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • neg() : Calculator
  • negate() : BCMath , GMP , PHP , BigInteger , Integer
  • negated() : BigDecimal , BigInteger , BigRational
  • negatePoint() : Base
  • negationToName() : InputDefinition
  • negative() : ParagonIE_Sodium_Core_Curve25519
  • NET_SSH2_COMPRESSION_NONE : SSH2
  • NET_SSH2_COMPRESSION_ZLIB : SSH2
  • NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH : SSH2
  • NETWORK_TIMEOUT : ConnectionOptions
  • new64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • newInteger() : BinaryField , PrimeField
  • newLine() : ANSI , OutputStyle , StyleInterface , SymfonyStyle
  • next() : Construct , DataSet , DatabaseIterator
  • NEXT : FetchOrientation
  • next() : SplFixedArray
  • nextExec() : ExecRuleHelper
  • NFC : Normalizer , AbstractUnicodeString , Normalizer
  • NFD : Normalizer , AbstractUnicodeString , Normalizer
  • NFKC : Normalizer , AbstractUnicodeString , Normalizer
  • NFKD : Normalizer , AbstractUnicodeString , Normalizer
  • nh() : Hash
  • NIL : Uuid
  • nlist() : SFTP
  • nlist_helper() : SFTP
  • NO_CREDENTIALS : Authentication
  • NO_EXIT : Status
  • NO_LOCK : Status
  • NO_PROTECT : ContainerResource
  • NO_RELEASE : Status
  • NO_ROUTINE : Status
  • NO_RUN : Status
  • NO_SHARE : ContainerResource
  • NO_SUCH_USER : Authentication
  • NO_TASK : Status
  • noContent() : Assertion
  • NODE_TYPES : DOMCaster , XmlReaderCaster
  • NONE : Normalizer
  • noop() : SMTP
  • noopReplacement() : ConfigPostProcessor
  • NORMAL : Priority
  • normalize() : BCMath , GMP , PHP , OptionConfigurator , AbstractUnicodeString , UnicodeString , Normalizer
  • normalizeBreaks() : PHPMailer
  • normalizePath() : Helper
  • normalizeType() : DebugClassLoader
  • normalizeWindowsPath() : Helper
  • NORWEGIAN_BOKMAL : Language
  • NORWEGIAN_LANGUAGE_CODE : ASCII
  • NOT_BEFORE : RegisteredClaims
  • NOT_FIDO_CERTIFIED : AuthenticatorStatus
  • notBlank() : Assertion
  • notContains() : Assertion , Assert
  • note() : StyleInterface , SymfonyStyle
  • notEmpty() : Assertion , Assert
  • notEmptyKey() : Assertion
  • notEndsWith() : Assert
  • notEq() : Assertion , Assert
  • notes() : Users
  • notesModal() : Users
  • notFalse() : Assert
  • notice() : PropelCollector
  • NOTICE : Log
  • notice() : AbstractLogger , LoggerInterface
  • NOTICE : LogLevel
  • notInArray() : Assertion
  • notInstanceOf() : Assert
  • notIsInstanceOf() : Assertion
  • notNull() : Assertion , Assert
  • notRegex() : Assertion , Assert
  • notSame() : Assertion , Assert
  • notStartsWith() : Assert
  • notWhitespaceOnly() : Assert
  • null() : Assertion
  • NULL : Identifier , ParameterType
  • null() : Assert
  • nullDate() : DatabaseQuery , QueryInterface
  • nullErrorHandler() : Connection
  • nullOr() : AssertionChain
  • nullPad128() : SymmetricKey
  • numeric() : Assertion
  • NUMERIC : FetchMode
  • numeric() : Assert
  • NUMERIC_STRING : Identifier


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- o -

  • oauthcallback() : PluginController
  • oauthRequest() : Client
  • object() : Assert
  • OBJECT_DESCRIPTOR : Identifier
  • OBJECT_IDENTIFIER : Identifier
  • objectHtmlSafe() : OutputFilter
  • objectOrClass() : Assertion
  • objectToString() : Ini , Json , Php , Xml , Yaml , FormatInterface
  • octetLength() : ECSignature , MultibyteStringConverter
  • OCTETSTRING : Identifier
  • of() : BigDecimal , BigInteger , BigNumber , BigRational
  • offcanvas() : Bootstrap
  • offsetExists() : AggregatedCollector , DebugBar , Construct , Feed , DataShapeObject , DataSet , AbstractEvent , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetGet() : AggregatedCollector , DebugBar , Construct , Feed , DataShapeObject , DataSet , AbstractEvent , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetSet() : AggregatedCollector , DebugBar , Construct , AbstractImmutableEvent , Feed , DataShapeObject , DataSet , Event , EventImmutable , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetUnset() : AggregatedCollector , DebugBar , Construct , AbstractImmutableEvent , Feed , DataShapeObject , DataSet , Event , EventImmutable , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • ofUnscaledValue() : BigDecimal
  • OID_NAME : PKCS8 , PSS
  • OID_VALUE : PKCS8 , PSS
  • OK : Status
  • oldTrustPathTypes() : TrustPathLoader
  • on_channel_open() : SSH2
  • onAfterCheckin() : Joomla
  • onAfterDisconnect() : PlgSystemDebug
  • onAfterDispatch() : Joomla , PlgSystemLanguageFilter , PlgSystemSef , PlgSystemStats
  • onAfterDisplay() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onAfterInitialise() : PlgSystemActionLogs , PlgSystemLanguageFilter , PlgSystemRemember , PlgSystemStats
  • onAfterLogExport() : Joomla
  • onAfterLogPurge() : Joomla
  • onAfterModuleList() : CaptiveModel
  • onAfterPurge() : Joomla
  • onAfterRender() : Cache , PlgSystemLanguagecode , PlgSystemPrivacyconsent , PlgSystemSef
  • onAfterRespond() : Cache , PlgSystemActionLogs , PlgSystemDebug
  • onAfterRoute() : Cache , PlgSystemLanguageFilter , PlgSystemPrivacyconsent
  • onAfterSessionStart() : MetadataManagerListener
  • onAjaxDebug() : PlgSystemDebug
  • onAjaxSampledataApplyStep1() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep2() : PlgSampledataBlog , PlgSampledataMultilang
  • onAjaxSampledataApplyStep3() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep4() : PlgSampledataBlog , PlgSampledataMultilang
  • onAjaxSampledataApplyStep5() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep6() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep7() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep8() : PlgSampledataMultilang
  • onAjaxSendAlways() : PlgSystemStats
  • onAjaxSendNever() : PlgSystemStats
  • onAjaxSendStats() : PlgSystemStats
  • onApplicationAfterSave() : Joomla
  • onAttachCallback() : CoreAssetItem , FormValidateAssetItem , KeepaliveAssetItem , TableColumnsAssetItem , WebAssetAttachBehaviorInterface
  • onAuthenticationFailure() : LdapAuthenticator
  • onAuthenticationSuccess() : LdapAuthenticator
  • onBeforeApiRoute() : PlgWebservicesBanners , PlgWebservicesConfig , PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesInstaller , PlgWebservicesLanguages , PlgWebservicesMedia , PlgWebservicesMenus , PlgWebservicesMessages , PlgWebservicesModules , PlgWebservicesNewsfeeds , PlgWebservicesPlugins , PlgWebservicesPrivacy , PlgWebservicesRedirect , PlgWebservicesTags , PlgWebservicesTemplates , PlgWebservicesUsers
  • onBeforeCompileHead() : PlgSystemAccessibility , PlgSystemDebug
  • onBeforeIndex() : Adapter
  • onBeforeRespond() : PlgSystemDebug
  • onBuildIndex() : Adapter
  • onCategoryChangeState() : PlgContentFinder
  • onCheckAnswer() : PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible
  • onConsoleError() : ErrorListener
  • onConsoleTerminate() : ErrorListener
  • onContentAfterDelete() : Joomla , PlgContentFinder
  • onContentAfterDisplay() : PlgContentVote , PlgSystemFields
  • onContentAfterSave() : Joomla , PlgContentFinder , PlgContentJoomla
  • onContentAfterTitle() : PlgSystemFields
  • onContentBeforeChangeFeatured() : PlgWorkflowFeaturing
  • onContentBeforeChangeState() : PlgContentJoomla , PlgWorkflowPublishing
  • onContentBeforeDelete() : PlgContentJoomla
  • onContentBeforeDisplay() : PlgContentPagenavigation , PlgContentVote , PlgSystemFields
  • onContentBeforeSave() : PlgContentFinder , PlgContentJoomla , PlgFieldsSql , PlgMediaActionResize
  • onContentChangeState() : Joomla , PlgContentFinder , PlgContentJoomla
  • onContentNormaliseRequestData() : PlgSystemFields
  • onContentPrepare() : PlgContentContact , PlgContentEmailcloak , PlgContentFields , PlgContentLoadmodule , PlgContentPagebreak , PlgSystemFields
  • onContentPrepareData() : PlgSystemActionLogs , PlgUserProfile , PlgUserToken
  • onContentPrepareForm() : FieldsPlugin , MediaActionPlugin , PlgContentConfirmConsent , PlgSystemActionLogs , PlgSystemFields , PlgSystemLanguagecode , PlgSystemPrivacyconsent , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • onContentVersioningPrepareTable() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onCustomFieldsBeforePrepareField() : PlgFieldsCheckboxes , PlgFieldsList , PlgFieldsMedia , PlgFieldsRadio , PlgFieldsSubform
  • onCustomFieldsGetTypes() : FieldsPlugin
  • onCustomFieldsPrepareDom() : FieldsListPlugin , FieldsPlugin , PlgFieldsCalendar , PlgFieldsColor , PlgFieldsEditor , PlgFieldsImagelist , PlgFieldsMedia , PlgFieldsSql , PlgFieldsSubform , PlgFieldsUrl , PlgFieldsUser
  • onCustomFieldsPrepareField() : FieldsPlugin , PlgFieldsList , PlgFieldsSubform
  • onDisplay() : PlgButtonArticle , PlgButtonContact , PlgButtonFields , PlgButtonImage , PlgButtonMenu , PlgButtonModule , PlgButtonPagebreak , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgEditorCodemirror , PlgEditorNone
  • one() : BigDecimal , BigInteger , BigRational
  • oneOf() : Assert
  • onetimeauth() : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • onetimeauth_poly1305_BYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • onetimeauth_poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • onetimeauth_verify() : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • onExtensionAfterDelete() : Joomla
  • onExtensionAfterInstall() : PackageAdapter , Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap
  • onExtensionAfterSave() : Joomla
  • onExtensionAfterUninstall() : Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap
  • onExtensionAfterUpdate() : Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap , PlgInstallerOverride
  • onExtensionBeforeUpdate() : PlgInstallerOverride
  • onFinderAfterDelete() : PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderAfterSave() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderBeforeSave() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderCategoryChangeState() : PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds
  • onFinderChangeState() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderDelete() : PlgFinderCategories
  • onFinderGarbageCollection() : Adapter
  • onFinderResult() : PlgSystemHighlight
  • onGetIcons() : PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck
  • onGetStatsData() : PlgSystemStats
  • onInit() : PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgEditorCodemirror , PlgEditorTinymce
  • onInstallerAddInstallationTab() : PlgInstallerFolderInstaller , PlgInstallerPackageInstaller , PlgInstallerUrlInstaller , PlgInstallerWebinstaller
  • onInstallerAfterInstaller() : PlgInstallerOverride
  • onInstallerBeforeInstaller() : PlgInstallerOverride
  • onJoomlaAfterUpdate() : Joomla , PlgInstallerOverride
  • onJoomlaBeforeUpdate() : PlgInstallerOverride
  • onKernelResponse() : AddLinkHeaderListener
  • onLoad() : DH , DSA , EC , RSA
  • ONLY_ALLOW_DEFINED_ATTRIBUTES : InputFilter
  • ONLY_ALLOW_DEFINED_TAGS : InputFilter
  • ONLY_BLOCK_DEFINED_ATTRIBUTES : InputFilter
  • ONLY_BLOCK_DEFINED_TAGS : InputFilter
  • onPrepareForm() : ContentHelper
  • onPrivacyCanRemoveData() : PlgPrivacyUser
  • onPrivacyCheckPrivacyPolicyPublished() : PlgSystemPrivacyconsent
  • onPrivacyCollectAdminCapabilities() : PlgAuthenticationCookie , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgSystemLanguageFilter
  • onPrivacyExportRequest() : PlgPrivacyActionlogs , PlgPrivacyConsents , PlgPrivacyContact , PlgPrivacyContent , PlgPrivacyMessage
  • onPrivacyRemoveData() : PlgPrivacyUser
  • onProcessList() : MessagesModel
  • onSampledataGetOverview() : PlgSampledataBlog , PlgSampledataMultilang
  • onSetupField() : PlgCaptchaRecaptcha_Invisible
  • onSetupProviders() : PlgFileSystemLocal
  • onStartIndex() : Adapter
  • onTableBeforeStore() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onUserAfterDelete() : Joomla , PlgSystemActionLogs , PlgSystemFields , PlgSystemPrivacyconsent , PlgUserJoomla , PlgUserProfile , PlgUserToken
  • onUserAfterDeleteGroup() : Joomla
  • onUserAfterLogin() : Joomla , PlgAuthenticationCookie , PlgUserJoomla
  • onUserAfterLogout() : PlgAuthenticationCookie
  • onUserAfterRemind() : Joomla
  • onUserAfterSave() : Joomla , PlgSystemActionLogs , PlgSystemFields , PlgSystemLanguageFilter , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserToken
  • onUserAfterSaveGroup() : Joomla
  • onUserAuthenticate() : Basic , Token , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgAuthenticationLdap
  • onUserBeforeSave() : PlgSystemLanguageFilter , PlgSystemPrivacyconsent , PlgSystemRemember , PlgUserProfile , PlgUserTerms
  • onUserLogin() : PlgSystemLanguageFilter , PlgUserJoomla
  • onUserLoginFailure() : Joomla , PlgSystemLog
  • onUserLogout() : Joomla , PlgSystemLogout , PlgSystemRemember , PlgUserJoomla
  • onUserMultifactorGetMethod() : Email , Fixed , Totp , Webauthn , Yubikey
  • onWorkflowAfterTransition() : PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • onWorkflowBeforeTransition() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onWorkflowFunctionalityUsed() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • open() : Stream , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler
  • openArchiveFile() : ZIPExtraction
  • openErrorStream() : ConsoleOutput
  • openOutputStream() : ConsoleOutput
  • opensearchsuggest() : SuggestionsController
  • openssl_ctr_process() : SymmetricKey
  • openssl_ofb_process() : SymmetricKey
  • openssl_translate_mode() : SymmetricKey
  • OPERA : WebClient
  • optimise() : IndexController
  • optimize() : IndexerController , Indexer
  • option() : Select
  • OPTIONAL : InputArgument
  • options() : Category , Select , Tag , Http , Router , RouterInterface
  • OPTIONS_RANGE : CronField
  • optionsToRegistry() : SearchTools
  • or() : BigInteger , GmpCalculator , Calculator
  • ord() : StringHelper
  • order() : Grid , DatabaseQuery , QueryInterface
  • orderbyPrimary() : QueryHelper
  • orderbySecondary() : QueryHelper
  • orderDown() : JGrid , Nested
  • orderDownIcon() : Pagination
  • ordering() : ListHelper , Menu
  • orderPosition() : ModuleController
  • orderUp() : JGrid , Nested
  • orderUpIcon() : Pagination
  • ORGANIZATION_NAME : OID
  • ORIENTATION_LANDSCAPE : Image
  • ORIENTATION_PORTRAIT : Image
  • ORIENTATION_SQUARE : Image
  • orInt64() : ParagonIE_Sodium_Core32_Int64
  • ORIYA_LANGUAGE_CODE : ASCII
  • orWhere() : DatabaseQuery
  • os2ip() : RSA
  • other() : RsaKey
  • OU_NAME : OID
  • our_strlen() : Crypto
  • our_substr() : Crypto
  • ourStrlen() : Core
  • ourSubstr() : Core
  • out() : CliOutput , Stdout , Xml , CliApplication
  • OUTBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • outerJoin() : DatabaseQuery
  • OUTPUT_NORMAL : OutputInterface
  • OUTPUT_PLAIN : OutputInterface
  • OUTPUT_RAW : OutputInterface
  • overrides() : TemplateController
  • overwrite() : ProgressBar , ProgressIndicator , ConsoleSectionOutput


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- p -

  • p() : RsaKey
  • p256KPrivateKey() : ECKey
  • p256KPublicKey() : ECKey
  • p256PrivateKey() : ECKey
  • p256PublicKey() : ECKey
  • p384PrivateKey() : ECKey
  • p384PublicKey() : ECKey
  • p521PrivateKey() : ECKey
  • p521PublicKey() : ECKey
  • packSSH2() : Strings
  • pad() : NativeCalculator , SymmetricKey , PHP , AbstractUnicodeString
  • padBoth() : AbstractString , AbstractUnicodeString , ByteString
  • PADDING_KECCAK : Hash
  • PADDING_SHA3 : Hash
  • PADDING_SHAKE : Hash
  • padEnd() : AbstractString , AbstractUnicodeString , ByteString
  • padStart() : AbstractString , AbstractUnicodeString , ByteString
  • PAGINATION_OID : Query
  • PARAM_CODES : PgSqlCaster
  • PARAMETER_TYPE_MAP : PdoStatement
  • parameterImplementsEventInterface() : CMSPlugin
  • parse() : BigInteger , TraceableTwigEnvironment , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , Document , HtmlDocument , FeedParser , InstallationRouter , Language , AdministratorRouter , Router , Uri , Router , Helper , Html , Parser , Router , AbstractUri , Parser , ArgvInput , ArrayInput , Input , Inline , Parser , Yaml
  • PARSE_CONSTANT : Yaml
  • PARSE_CUSTOM_TAGS : Yaml
  • PARSE_DATETIME : Yaml
  • PARSE_EXCEPTION_ON_INVALID_TYPE : Yaml
  • PARSE_OBJECT : Yaml
  • PARSE_OBJECT_FOR_MAP : Yaml
  • parse_path() : Stream
  • PARSE_REGEXP : BigNumber
  • parse_url() : UriHelper
  • parseAddresses() : PHPMailer
  • parseAndLogSqlQuery() : PropelCollector
  • parseAnonymousClass() : ErrorHandler
  • parseApiRoute() : ApiRouter
  • parseArgument() : ArgvInput
  • parseArguments() : Cli
  • parseAttributes() : Utility , SFTP
  • parseBase64() : TemplateParser
  • parseBinary() : TemplateParser
  • parseBinaryIdentifier() : ASNObject
  • parseBlock() : Parser
  • parseBlockScalar() : Parser
  • parseCheckSSL() : SiteRouter
  • parseClaims() : Parser
  • parseColor() : Color
  • parseContentLength() : ASNObject
  • parseFields() : FormattedtextLogger
  • parseFile() : Parser , Yaml
  • parseFiles() : Installer
  • parseFormat() : SiteRouter
  • parseHeader() : Parser , AbstractNegotiator
  • parseHelloFields() : SMTP
  • parseIdentifier() : ASNObject
  • parseIniFile() : LanguageHelper
  • parseInit() : SiteRouter
  • parseLanguageFiles() : LanguageHelper
  • parseLanguages() : Installer
  • parseLongname() : SFTP
  • parseLongOption() : ArgvInput
  • parseMapping() : Inline
  • parseMedia() : Installer
  • parseMode() : SFTP
  • parseOid() : ObjectIdentifier
  • parseOptionalTags() : ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • parsePaginationData() : SiteRouter
  • parseParameters() : BaseAccept
  • parsePath() : PostinstallHelper
  • parsePhpDoc() : DebugClassLoader
  • parsePhpInfo() : SysinfoModel
  • parseQueries() : ComponentAdapter , TemplateAdapter , Installer , InstallerAdapter
  • parseQuotedScalar() : Inline
  • parser() : Configuration
  • parseRawRoute() : SiteRouter
  • parseRdnFromEntry() : EntryManager
  • parseRegistryFile() : WebAssetRegistry
  • parseRegistryFiles() : WebAssetRegistry
  • parseRelationshipPaths() : Util
  • parseRoute() : Router , RouterInterface
  • parseRule() : PlgSystemLanguageFilter
  • parseScalar() : Inline
  • parseSchemaUpdates() : Installer
  • parseSefRoute() : SiteRouter
  • parseSequence() : Inline
  • parseShortOption() : ArgvInput
  • parseShortOptionSet() : ArgvInput
  • parseShowOnConditions() : FormHelper
  • parseSignature() : Parser
  • parseSize() : FilesystemHelper
  • parseSizeUnit() : FilesystemHelper
  • parseSQLFiles() : Installer
  • parseTag() : Inline
  • parseTime() : SFTP
  • parseToken() : CompletionInput , ArgvInput
  • parseUri() : Uri
  • parseValue() : Parser
  • parseXMLInstallFile() : Installer
  • parseXMLLanguageFile() : LanguageHelper
  • parseXmlNode() : MenusHelper
  • parseXMLTemplateFile() : PluginsHelper , TemplatesHelper
  • partial_init_sftp_connection() : SFTP
  • PASHTO_LANGUAGE_CODE : ASCII
  • PASS : UriInterface
  • passphrase() : Key
  • passSprintf() : Text
  • PASSWORD_KEY_CURRENT_VERSION : KeyProtectedByPassword
  • PasswordHash() : PasswordHash
  • patch() : Http , Router , RouterInterface
  • PATCH_VERSION : Version
  • patchMethod() : DebugClassLoader
  • patchReturnTypeWillChange() : DebugClassLoader
  • PATH : UriInterface
  • PATH_CONTEXT : Indexer
  • PATH_PREFIX : LocalFileReference
  • payload() : Token
  • pbkdf2() : Core
  • PBKDF2_ITERATIONS : KeyOrPassword
  • pcntlChildExitStatus() : DaemonApplication
  • pcntlFork() : DaemonApplication
  • pcntlSignal() : DaemonApplication
  • pcntlWait() : DaemonApplication
  • pdf() : Hash
  • PDO_ATTRIBUTES : PdoCaster
  • pem() : Ec2Key , RsaKey
  • PERIOD_LIMIT : DateCaster
  • permittedFor() : Builder
  • PERSIAN_LANGUAGE_CODE : ASCII
  • PGSQL_COMMAND_OK : PgSqlCaster
  • PGSQL_TRANSACTION_ACTIVE : PgSqlCaster
  • php_os_family() : Php72
  • PHP_SECURITY_ONLY : PlgQuickiconPhpVersionCheck
  • PHP_SUPPORTED : PlgQuickiconPhpVersionCheck
  • PHP_UNSUPPORTED : PlgQuickiconPhpVersionCheck
  • phpinfoEnabled() : SysinfoModel
  • phpVersion() : Assertion
  • PHRASES : Response
  • ping() : SSH2
  • pinned() : Banner
  • pivot() : ArrayHelper
  • pk_to_curve25519() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • pkcs12helper() : SymmetricKey
  • PKCS9_CONTENT_TYPE : OID
  • PKCS9_EMAIL : OID
  • PKCS9_EXTENSION_REQUEST : OID
  • PKCS9_MESSAGE_DIGEST : OID
  • PKCS9_SIGNING_TIME : OID
  • PKCS9_UNSTRUCTURED_NAME : OID
  • PlainDecrypt() : Crypto
  • PlainEncrypt() : Crypto
  • plainText() : InMemory
  • pluginDisable() : Adapter
  • plural() : Text
  • PLURAL_MAP : EnglishInflector
  • pluralize() : Inflector , EnglishInflector , FrenchInflector , InflectorInterface
  • PLURALIZE_REGEXP : FrenchInflector
  • plus() : BigDecimal , BigInteger , BigRational
  • POLISH_LANGUAGE_CODE : ASCII
  • poly() : Hash
  • poly1305() : SymmetricKey , Salsa20
  • polyfill_is_fast() : ParagonIE_Sodium_Compat
  • polynomialDivide() : Integer
  • polynomialMultiply() : Integer
  • pop() : Strings , OutputFormatterStyleStack
  • popBeforeSmtp() : POP3
  • popover() : Bootstrap
  • popStreamContentUntilCurrentSection() : ConsoleSectionOutput
  • populateBigIntegers() : RSAKey
  • populateDatabase() : DatabaseModel
  • populateExtraData() : GroupsModel
  • populateFilesAndFolderList() : FileAdapter
  • populateGroupData() : UserGroupsHelper
  • populateGroupsData() : UserGroupsHelper
  • populateHttpHost() : ConsoleApplication
  • populateMfaMethods() : MethodModel
  • populateState() : AdminModel , ListModel , ActionlogsModel , AssociationsModel , BannersModel , ClientsModel , DownloadModel , TracksModel , CacheModel , CategoriesModel , CategoryModel , CheckinModel , ComponentModel , ModulesModel , TemplatesModel , ContactsModel , CategoriesModel , CategoryModel , FeaturedModel , FormModel , ArticlesModel , FeaturedModel , ArchiveModel , ArticleModel , ArticlesModel , CategoriesModel , CategoryModel , FeaturedModel , FormModel , HistoryModel , FieldModel , FieldsModel , GroupModel , GroupsModel , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , DiscoverModel , InstallModel , LanguagesModel , ManageModel , UpdateModel , UpdatesitesModel , InstalledModel , LanguageModel , LanguagesModel , OverrideModel , OverridesModel , LoginModel , TemplateModel , TemplatesModel , ItemModel , ItemsModel , MenuModel , MenusModel , MenutypesModel , ConfigModel , MessageModel , MessagesModel , ModuleModel , ModulesModel , PositionsModel , SelectModel , NewsfeedsModel , CategoriesModel , CategoryModel , NewsfeedModel , PluginModel , PluginsModel , MessagesModel , CapabilitiesModel , ConsentsModel , ExportModel , RemoveModel , RequestsModel , ConfirmModel , RemindModel , RequestModel , LinksModel , TaskModel , TasksModel , TagModel , TagsModel , TagModel , TagsModel , StyleModel , StylesModel , TemplateModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NoteModel , NotesModel , UsersModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , StagesModel , TransitionModel , TransitionsModel , WorkflowModel , WorkflowsModel
  • PORT : UriInterface
  • PORTUGUESE : Language
  • PORTUGUESE_LANGUAGE_CODE : ASCII
  • positionList() : Modules
  • positions() : ListHelper , Modules
  • positiveInteger() : Assert
  • post() : Http , Router , RouterInterface
  • POST_CONNECT : DatabaseEvents
  • POST_DISCONNECT : DatabaseEvents
  • POSTAL_ADDRESS : OID
  • POSTAL_CODE : OID
  • postDeleteHook() : AdminController
  • postFiles() : ApiController
  • postflight() : InstallerScriptInterface , LegacyInstallerScript , JoomlaInstallerScript
  • postFork() : DaemonApplication
  • postProcess() : Form , FormField
  • postprocessNonSEFBuildRule() : PlgSystemLanguageFilter
  • postprocessSEFBuildRule() : PlgSystemLanguageFilter
  • postSaveHook() : FormController , CategoryController , ContactController , ArticleController , FieldController , GroupController , ModuleController , RequestController , UserController , WorkflowController
  • postSend() : PHPMailer
  • postStoreProcess() : TagsHelper
  • pow() : BCMath , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • power() : BigDecimal , BigInteger , BigRational
  • powerMod() : BigInteger
  • powHelper() : PHP
  • powmod() : BCMath
  • powMod() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • powModHelper() : Base , BuiltIn , DefaultEngine , OpenSSL , Base
  • powModInner() : BCMath , GMP , PHP
  • powModOuter() : Engine
  • precheck() : SFTP
  • preconnect() : PreloadManager , PreloadManagerInterface
  • preferences() : ToolbarHelper
  • prefetch() : PreloadManager , PreloadManagerInterface
  • PREFIX_DYNAMIC : Caster
  • PREFIX_PROTECTED : Caster
  • PREFIX_VIRTUAL : Caster
  • preflight() : InstallerScript , InstallerScriptInterface , LegacyInstallerScript , JoomlaInstallerScript
  • preg_last_error_msg() : Php80
  • preg_match() : Parser
  • PREG_OFFSET_CAPTURE : AbstractString
  • PREG_PATTERN_ORDER : AbstractString
  • PREG_SET_ORDER : AbstractString
  • PREG_SPLIT : AbstractString
  • PREG_SPLIT_DELIM_CAPTURE : AbstractString
  • PREG_SPLIT_NO_EMPTY : AbstractString
  • PREG_SPLIT_OFFSET_CAPTURE : AbstractString
  • PREG_UNMATCHED_AS_NULL : AbstractString
  • pregOffset() : Iconv
  • preload() : Access , PreloadManager , PreloadManagerInterface
  • preloadAssets() : Document
  • preloadComponents() : Access
  • preloadPermissions() : Access
  • prepare() : TraceablePDO , Content , SqlsrvStatement , PlgContentFields
  • prepareAsciiAndExtrasMaps() : ASCII
  • prepareAsciiExtras() : ASCII
  • prepareAsciiMaps() : ASCII
  • prepareContent() : Helper
  • prepareCoreFiles() : TemplateModel
  • PREPARED_RESPONSE_LABELS : CronField
  • prepareData() : ContenthistoryHelper
  • prepareDimensions() : Image
  • prepareDiscoverInstall() : LibraryAdapter , ModuleAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • prepareDocument() : CategoriesView , CategoryView , HtmlView
  • prepareForm() : CategoryServiceInterface , ContentComponent
  • prepareItem() : JsonApiView , JsonapiView
  • prepareLevel() : ContentmapField
  • prepareOptions() : ConfirmButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , StandardButton , ToolbarButton
  • prepareOptionsNested() : TagField
  • prepareParameterKeyMapping() : MysqliStatement , SqlsrvStatement
  • preparePositiveInteger() : ECSignature , MultibyteStringConverter
  • preparePreUpdate() : UpdateModel
  • prepareReduce() : Base , Montgomery , PowerOfTwo
  • prepareSigningKey() : Client
  • prepareStatement() : DatabaseDriver , MysqliDriver , PdoDriver
  • prepareTable() : AdminModel , BannerModel , ClientModel , ContactModel , ArticleModel , TemplateModel , ModuleModel , NewsfeedModel , TagModel
  • prepareTagItem() : PlgSystemFields
  • prepareToolbar() : HtmlView
  • preParse() : PKCS8
  • prepend() : AbstractString , ByteString , CodePointString , UnicodeString
  • prependBody() : AbstractWebApplication , WebApplicationInterface
  • prependButton() : Toolbar
  • prependFilter() : Stream
  • preprocess() : ActionButton , FeaturedButton , PublishedButton , RouterBase , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , MenusHelper , CssMenu , Menu
  • preprocessBuildRule() : PlgSystemLanguageFilter
  • preprocessData() : FormModel
  • preprocessForm() : BannerModel , CategoryModel , FormModel , ModulesModel , TemplatesModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , ItemModel , ItemsModel , ModuleModel , NewsfeedModel , PluginModel , TaskModel , StyleModel , GroupModel , LevelModel , MailModel , UserModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , TransitionModel , WorkflowModel
  • preprocessSaveData() : ApiController , CategoriesController , ContactController , ArticlesController , StylesController , UsersController
  • prerender() : PreloadManager , PreloadManagerInterface
  • preSend() : PHPMailer
  • PRESTO : WebClient
  • preStoreProcess() : TagsHelper
  • preview() : ToolbarHelper
  • primes() : RsaKey
  • PRIMES : Engine
  • print_popup() : JHtmlIcon
  • print_screen() : JHtmlIcon , Icon
  • PRINTABLE_STRING : Identifier
  • printf() : Text
  • PRIOR : FetchOrientation
  • privatekey_login() : SSH2
  • PRIVATEKEYBLOB : MSBLOB
  • process() : Decoder , ColorProcessor , ProcessorInterface , Form , Html , Parser , Rtf , Txt , AddConsoleCommandPass
  • PROCESS_AFTER : Router
  • PROCESS_BEFORE : Router
  • PROCESS_DURING : Router
  • processBlock() : DES
  • processBuildRules() : Router
  • processCoordinate() : ANSI
  • processDates() : Query
  • processDiscover() : ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand
  • processDynamicTaxonomy() : Query
  • processElement() : FeedParser
  • processElementForFeed() : NamespaceParserInterface , ItunesRssParser , MediaRssParser
  • processElementForFeedEntry() : NamespaceParserInterface , ItunesRssParser , MediaRssParser
  • processExecutionRules() : TaskModel
  • processFeedEntry() : AtomParser , RssParser
  • processFileData() : ZIPExtraction
  • processFinite() : Decoder
  • processGroupOptions() : GetConfigurationCommand
  • processHeaders() : AbstractTransport , JSONGeneralSerializer
  • processInfinite() : Decoder
  • processIsPayloadEncoded() : JSONGeneralSerializer
  • processLastExtractedFile() : ZIPExtraction
  • processLimit() : LimitableInterface , SqliteQuery , SqlsrvQuery
  • processLookupFields() : ContenthistoryHelper
  • processParseRules() : Router
  • processPathInstallation() : ExtensionInstallCommand
  • processPayload() : JSONGeneralSerializer
  • processPerson() : RssParser
  • processQuery() : SqlField
  • processRemindRequest() : RemindModel
  • processResetComplete() : ResetModel
  • processResetConfirm() : ResetModel
  • processResetRequest() : ResetModel
  • processSHA3Block32() : Hash
  • processSHA3Block64() : Hash
  • processSignature() : JWSLoader
  • processSingleOption() : GetConfigurationCommand
  • processStaticTaxonomy() : Query
  • processString() : Query
  • processTypeDir() : ZIPExtraction
  • processTypeFileCompressed() : ZIPExtraction
  • processTypeFileUncompressed() : ZIPExtraction
  • processTypeLink() : ZIPExtraction
  • processUpdatePackage() : UpdateCoreCommand
  • processUpdateSites() : PlgExtensionJoomla
  • processUrlInstallation() : ExtensionInstallCommand
  • processWithCertificate() : PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • processWithECDAA() : PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • processWithSelfAttestation() : PackedAttestationStatementSupport
  • PRODUCT : Version
  • profileCall() : TraceablePDO
  • progress() : DebugFormatterHelper
  • progressAdvance() : StyleInterface , SymfonyStyle
  • progressFinish() : StyleInterface , SymfonyStyle
  • progressIterate() : SymfonyStyle
  • progressStart() : StyleInterface , SymfonyStyle
  • propertiesExist() : Assertion
  • property() : Microdata
  • propertyExists() : Assertion , Assert
  • propertyNotExists() : Assert
  • protect() : Container
  • PROTECT : ContainerResource
  • PROTOCOL_VERSION : ConnectionOptions
  • pseudoConstructor() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • PUBLIC_HANDLER : PuTTY
  • publickey() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • PUBLICKEYBLOB : MSBLOB
  • PUBLICKEYBLOBEX : MSBLOB
  • publish() : ActionsDropdown , Dropdown , AdminController , AdminModel , Nested , Table , ToolbarHelper , CategoryModel , FeaturedController , ArticleModel , IndexModel , MapsModel , ManageModel , UpdatesitesModel , InstalledModel , ItemsController , ItemModel , MessageModel , NewsfeedModel , TemplateController , TemplateModel , GroupsController , StageModel , WorkflowModel
  • publishContentLanguages() : PlgSampledataMultilang
  • published() : Grid , JGrid , Languages , Redirect
  • publishedOptions() : JGrid , Languages , PluginsHelper , RedirectHelper
  • publishList() : ToolbarHelper
  • punycodePrefix : AbstractPunycode
  • punyencodeAddress() : PHPMailer
  • purge() : FinderIndexCommand , ActionlogsController , ActionlogsModel , AssociationsController , AssociationsModel , DisplayController , CacheModel , IndexModel , MapsModel , DiscoverModel , UpdateModel , OverridesModel , MessagesModel , LinksController , LinksModel , PlgInstallerOverride
  • purgeMessages() : AdministratorApplication
  • push() : OutputFormatterStyleStack
  • pushStep() : Installer
  • put() : Http , Router , RouterInterface , SFTP
  • putFiles() : ApiController
  • putFilters() : FinderIndexCommand
  • pwd() : FtpClient , SFTP


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- q -

  • q() : RsaKey , DatabaseDriver , DatabaseQuery
  • QInv() : RsaKey
  • qn() : DatabaseDriver , DatabaseQuery
  • qpByteCallback() : Iconv
  • quarterRound() : ChaCha20 , Salsa20
  • query() : TraceablePDO , Client
  • QUERY : UriInterface
  • query() : XML , Ldap , LdapInterface
  • query_stat_cache() : SFTP
  • queryEncode() : JsonApiView
  • querySet() : DatabaseQuery , QueryInterface
  • quit() : FtpClient , SMTP
  • quote() : TraceablePDO , DatabaseDriver , DatabaseInterface , DatabaseQuery
  • quoteBinary() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • quotedString() : PHPMailer
  • quoteName() : DatabaseDriver , DatabaseInterface , DatabaseQuery
  • quoteNameStr() : DatabaseDriver
  • quoteNameString() : DatabaseDriver
  • quotient() : BigDecimal , BigInteger , BigRational
  • quotientAndRemainder() : BigDecimal , BigInteger , BigRational


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- r -

  • r : GithubActionReporter
  • r1() : Stem
  • r2() : Stem
  • radiolist() : Select
  • rand() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • random() : BigInteger
  • randomBits() : BigInteger
  • randombytes_random16() : ParagonIE_Sodium_Compat
  • randombytes_uniform() : ParagonIE_Sodium_Compat
  • randomInteger() : Base , BinaryField , PrimeField
  • randomPrime() : BigInteger
  • randomRange() : BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • randomRangeHelper() : Engine
  • randomRangePrime() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • randomRangePrimeInner() : Engine , GMP
  • randomRangePrimeOuter() : Engine
  • range() : Assertion , Assert
  • rangeCheck() : Base , Curve25519 , Curve448
  • raw_encrypt() : PrivateKey , PublicKey
  • rawlist() : SFTP
  • rawurlencodeMatchZero() : Uri
  • read() : Stream , StringStream , FtpClient , Stream , FtpClient , Stream , LdapClient , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , CallbackStream , PhpInputStream , RelativeStream , Stream , SSH2 , StreamInterface , StringStream
  • READ_NEXT : SSH2
  • read_put_responses() : SFTP
  • READ_REGEX : SSH2
  • read_remaining_bytes() : SSH2
  • READ_SIMPLE : SSH2
  • READ_WRITE_HASH : Stream
  • readable() : Assertion , Assert
  • readArchiveHeader() : ZIPExtraction
  • readAsn1Content() : ECSignature , MultibyteStringConverter
  • readAsn1Integer() : ECSignature , MultibyteStringConverter
  • readFile() : Key
  • readFileHeader() : ZIPExtraction
  • readFromProcess() : Terminal
  • readInput() : QuestionHelper
  • readlink() : SFTP
  • readlist() : SFTP
  • readZipInfo() : Zip
  • REAL : Identifier
  • realpath() : SFTP
  • REASON_MAIL_FUNCTION_NOT_AVAILABLE : MailDisabledException
  • REASON_USER_DISABLED : MailDisabledException
  • rebuild() : Asset , Nested , Usergroup , CategoryModel , UpdatesitesController , UpdatesitesModel , ItemModel
  • rebuildPath() : Nested
  • recipient() : SMTP
  • reciprocal() : BigRational
  • recompose() : Normalizer
  • reconcileNames() : CategoryFeedView , FeedView
  • reconnect() : SSH2
  • recordLastTransactionID() : SMTP
  • recoverX() : Ed25519 , Ed448
  • recursiveUpdatePublishedColumn() : Nested
  • redirect() : AbstractWebApplication , WebApplicationInterface , CMSApplication , BaseController
  • redirectsAllowed() : CurlTransport , Curl
  • redirectToAssociations() : AdminModel
  • reduce() : AcceptMatch , Barrett , EvalBarrett , Barrett , Classic , EvalBarrett , Montgomery , PowerOfTwo
  • REFERENCE_PATTERN : Parser
  • REFERRALS : ConnectionOptions
  • refineSearchStringToRegex() : ListModel
  • refresh() : ManageModel , StringsController , StringsModel
  • refreshManifestCache() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , Installer
  • refreshMediaVersion() : Version
  • refreshToken() : Client
  • refreshUpdates() : UpdateModel
  • refreshUser() : LdapUserProvider
  • regenerate() : NativeStorage , RuntimeStorage , StorageInterface
  • regenerateBackupCodes() : BackupcodesModel
  • regex() : Assertion , Assert
  • REGEX_CHARACTER_TO_ESCAPE : Escaper
  • REGEX_ESCAPED_CHARACTER : Unescaper
  • REGEX_QUOTED_STRING : StringInput , Inline
  • REGEX_STRING : StringInput
  • REGEX_UNQUOTED_STRING : StringInput
  • regexp() : DatabaseQuery , QueryInterface
  • register() : ClassLoader , JLoader , CategoryFactory , ComponentDispatcherFactory , HelperFactory , Module , ModuleDispatcherFactory , MVCFactory , RouterFactory , HTMLHelper , Registry , Application , LoggerRegistry , Application , Authentication , CacheController , Config , Console , Database , Dispatcher , Document , Form , HTMLRegistry , Language , Logger , Menu , Pathway , Router , Toolbar , User , WebAssetRegistry , RegistrationModel , ServiceProviderInterface , Stream , ServiceProviderInterface , Application , DescriptorHelper , SignalRegistry , ErrorHandler , VarDumper
  • registerAlias() : CronExpression , JLoader
  • registerAsset() : WebAssetManager
  • registerChannelOpen() : Agent
  • registerDefaultTask() : BaseController
  • registerExtension() : X509
  • registerHandler() : ErrorHandler
  • registerLegacyListener() : CMSPlugin
  • registerListener() : CMSPlugin
  • registerListeners() : PluginInterface
  • registerLogger() : Log
  • registerNamespace() : JLoader , FeedParser
  • registerParser() : FeedFactory
  • registerPrefix() : JLoader
  • registerProvider() : ProviderManager
  • registerServiceProvider() : Container
  • registerSessionHandlerAsService() : Session
  • registerStreamWrapper() : PharStreamWrapper
  • registerTask() : BaseController
  • registerUndefinedFilterCallback() : TraceableTwigEnvironment
  • registerUndefinedFunctionCallback() : TraceableTwigEnvironment
  • registerView() : RouterView
  • regularBarrett() : Barrett
  • regularMultiply() : PHP
  • regularPolynomialMultiply() : Integer
  • reindex() : Adapter
  • reinit() : FtpClient
  • rekey() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • REL : FetchOrientation
  • REL_ABOUT : Relations
  • REL_ALTERNATE : Relations , Link
  • REL_AMPHTML : Relations
  • REL_APPENDIX : Relations
  • REL_APPLE_TOUCH_ICON : Relations
  • REL_APPLE_TOUCH_STARTUP_IMAGE : Relations
  • REL_ARCHIVES : Relations
  • REL_AUTHOR : Relations , Link
  • REL_BLOCKED_BY : Relations
  • REL_BOOKMARK : Relations
  • REL_CANONICAL : Relations
  • REL_CHAPTER : Relations
  • REL_CITE_AS : Relations
  • REL_COLLECTION : Relations
  • REL_CONTENTS : Relations
  • REL_CONVERTEDFROM : Relations
  • REL_COPYRIGHT : Relations
  • REL_CREATE_FORM : Relations
  • REL_CURRENT : Relations
  • REL_DESCRIBEDBY : Relations
  • REL_DESCRIBES : Relations
  • REL_DISCLOSURE : Relations
  • REL_DNS_PREFETCH : Relations , Link
  • REL_DUPLICATE : Relations
  • REL_EDIT : Relations
  • REL_EDIT_FORM : Relations
  • REL_EDIT_MEDIA : Relations
  • REL_ENCLOSURE : Relations
  • REL_EXTERNAL : Relations
  • REL_FIRST : Relations
  • REL_GLOSSARY : Relations
  • REL_HELP : Relations , Link
  • REL_HOSTS : Relations
  • REL_HUB : Relations
  • REL_ICON : Relations , Link
  • REL_INDEX : Relations
  • REL_INTERVALAFTER : Relations
  • REL_INTERVALBEFORE : Relations
  • REL_INTERVALCONTAINS : Relations
  • REL_INTERVALDISJOINT : Relations
  • REL_INTERVALDURING : Relations
  • REL_INTERVALEQUALS : Relations
  • REL_INTERVALFINISHEDBY : Relations
  • REL_INTERVALFINISHES : Relations
  • REL_INTERVALIN : Relations
  • REL_INTERVALMEETS : Relations
  • REL_INTERVALMETBY : Relations
  • REL_INTERVALOVERLAPPEDBY : Relations
  • REL_INTERVALOVERLAPS : Relations
  • REL_INTERVALSTARTEDBY : Relations
  • REL_INTERVALSTARTS : Relations
  • REL_ITEM : Relations
  • REL_LAST : Relations
  • REL_LATEST_VERSION : Relations
  • REL_LICENSE : Relations , Link
  • REL_LRDD : Relations
  • REL_MANIFEST : Relations
  • REL_MASK_ICON : Relations
  • REL_MEDIA_FEED : Relations
  • REL_MEMENTO : Relations
  • REL_MERCURE : Link
  • REL_MICROPUB : Relations
  • REL_MODULEPRELOAD : Relations
  • REL_MONITOR : Relations
  • REL_MONITOR_GROUP : Relations
  • REL_NEXT : Relations , Link
  • REL_NEXT_ARCHIVE : Relations
  • REL_NOFOLLOW : Relations
  • REL_NOOPENER : Relations
  • REL_NOREFERRER : Relations
  • REL_OPENER : Relations
  • REL_OPENID2_LOCAL_ID : Relations
  • REL_OPENID2_PROVIDER : Relations
  • REL_ORIGINAL : Relations
  • REL_P3PV1 : Relations
  • REL_PAYMENT : Relations
  • REL_PINGBACK : Relations
  • REL_PRECONNECT : Relations , Link
  • REL_PREDECESSOR_VERSION : Relations
  • REL_PREFETCH : Relations , Link
  • REL_PRELOAD : Relations , Link
  • REL_PRERENDER : Relations , Link
  • REL_PREV : Relations , Link
  • REL_PREV_ARCHIVE : Relations
  • REL_PREVIEW : Relations
  • REL_PREVIOUS : Relations
  • REL_PRIVACY_POLICY : Relations
  • REL_PROFILE : Relations
  • REL_PUBLICATION : Relations
  • REL_RELATED : Relations
  • REL_REPLIES : Relations
  • REL_RESTCONF : Relations
  • REL_RULEINPUT : Relations
  • REL_SEARCH : Relations , Link
  • REL_SECTION : Relations
  • REL_SELF : Relations
  • REL_SERVICE : Relations
  • REL_SERVICE_DESC : Relations
  • REL_SERVICE_DOC : Relations
  • REL_SERVICE_META : Relations
  • REL_SPONSORED : Relations
  • REL_START : Relations
  • REL_STATUS : Relations
  • REL_STYLESHEET : Relations , Link
  • REL_SUBSECTION : Relations
  • REL_SUCCESSOR_VERSION : Relations
  • REL_SUNSET : Relations
  • REL_TAG : Relations
  • REL_TERMS_OF_SERVICE : Relations
  • REL_TIMEGATE : Relations
  • REL_TIMEMAP : Relations
  • REL_TYPE : Relations
  • REL_UGC : Relations
  • REL_UP : Relations
  • REL_VERSION_HISTORY : Relations
  • REL_VIA : Relations
  • REL_WEBMENTION : Relations
  • REL_WORKING_COPY : Relations
  • REL_WORKING_COPY_OF : Relations
  • relatedTo() : Builder
  • relative() : Date
  • RELATIVE_OID : Identifier
  • RELATIVE_PATH : JavascriptRenderer
  • RELATIVE_URL : JavascriptRenderer
  • RELDATE : Version
  • releaseEditId() : BaseController
  • releaseLock() : Task
  • reload() : InstalledVersions , ArticleController
  • RELTIME : Version
  • RELTZ : Version
  • remainder() : BigDecimal , BigInteger , BigRational
  • remindExpiringConsents() : PlgSystemPrivacyconsent
  • REMOTE_URL : PlgInstallerWebinstaller
  • remotefsize() : FilesystemHelper , Helper
  • remove() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , JoomlaStorage , WebAssetRegistry , WebAssetRegistryInterface , Adapter , Indexer , ManageModel , ListenersPriorityQueue , InputFilter , LdapClient , Registry , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , EntryManagerInterface , EntryManager , OptionsResolver , PublicKeyCredentialDescriptorCollection
  • REMOVE_ABORT : ExtensionRemoveCommand
  • REMOVE_FAILED : ExtensionRemoveCommand
  • remove_from_stat_cache() : SFTP
  • REMOVE_INVALID_RESPONSE : ExtensionRemoveCommand
  • REMOVE_INVALID_TYPE : ExtensionRemoveCommand
  • remove_invisible_characters() : ASCII
  • REMOVE_LOCKED : ExtensionRemoveCommand
  • REMOVE_NOT_FOUND : ExtensionRemoveCommand
  • REMOVE_SUCCESSFUL : ExtensionRemoveCommand
  • removeArgument() : Event
  • removeAttachment() : Mail
  • removeAttribute() : X509 , Entry
  • removeAttributeValues() : EntryManager
  • removeBlocks() : Html
  • removeCategory() : Feed , FeedEntry
  • removeChild() : NodeInterface
  • removeCommonWords() : PlgExtensionFinder
  • removeContributor() : Feed , FeedEntry
  • removeDecoration() : Helper
  • removeDNProp() : X509
  • removeEntry() : Feed
  • removeEvent() : Dispatcher
  • removeExtension() : TraceableTwigEnvironment , X509
  • removeExtensionFiles() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • removeExtensionHelper() : X509
  • removeField() : Form
  • removeFiles() : Installer , InstallerScript
  • removeFilter() : Stream
  • removeGroup() : Form
  • removeIncludePath() : FileLayout
  • removeIncludePaths() : FileLayout
  • removeIndexPhpFromPath() : ApiRouter
  • removeInstruction() : Result
  • removeLayout() : RouterViewConfiguration
  • removeLink() : FeedEntry
  • removeListener() : Dispatcher , DispatcherInterface
  • removeLocked() : PlgWorkflowNotification
  • removeMaps() : Taxonomy
  • removeNonPrintableCharacters() : Sanitizer
  • removeOrphanMaps() : Taxonomy
  • removeOrphanNodes() : Taxonomy
  • removePackageFiles() : UpdateModel
  • removePharPrefix() : Helper
  • removeRemoteReferences() : Sanitizer
  • removeRevokedCertificateExtension() : X509
  • removeRoot() : Path
  • removeroot() : ApplicationModel
  • removeRoot() : Path
  • removeState() : ActionButton
  • removeSubscriber() : Dispatcher , DispatcherInterface
  • removeUserFromGroup() : UserHelper
  • removeXMLTag() : Sanitizer
  • rename() : FtpClient , LdapClient , SFTP , EntryManagerInterface , EntryManager , PharStreamWrapper
  • renameFile() : TemplateModel
  • renameTable() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • render() : TraceableTwigEnvironment , TraceableTwigTemplate , JavascriptRenderer , AdministratorApplication , ApiApplication , CMSApplication , SiteApplication , WebApplication , ActionButton , FeaturedButton , PublishedButton , TransitionButton , Document , ErrorDocument , FeedDocument , HtmlDocument , ImageDocument , JsonapiDocument , OpensearchDocument , RawDocument , AtomRenderer , RssRenderer , ComponentRenderer , HeadRenderer , MessageRenderer , ModuleRenderer , ModulesRenderer , ScriptsRenderer , StylesRenderer , RendererInterface , XmlDocument , CliRenderer , HtmlRenderer , JsonapiRenderer , JsonRenderer , XmlRenderer , RendererInterface , FormField , ActionsDropdown , Dropdown , Sidebar , InstallationApplication , JsonRenderer , BaseLayout , FileLayout , LayoutHelper , LayoutInterface , Toolbar , ToolbarButton , FieldsHelper , JavascriptRenderer , AbstractUri , PlgSystemStats , Table , CliErrorRenderer , ErrorRendererInterface , HtmlErrorRenderer , SerializerErrorRenderer
  • renderActionlogsExtensions() : PlgSystemActionLogs
  • renderActionlogsNotify() : PlgSystemActionLogs
  • renderAttributes() : ScriptsRenderer , StylesRenderer
  • renderBacktrace() : ErrorDocument
  • renderBlock() : TraceableTwigTemplate
  • renderButton() : CustomButton , DropdownButton , PopupButton , Toolbar , ToolbarButton
  • renderCapturedVar() : DebugBarVarDumper
  • renderCell() : Table
  • renderColumnSeparator() : Table
  • renderDataAsXml() : PrivacyHelper
  • renderDataAttributes() : FormField
  • renderDebugMessages() : BaseLayout
  • renderDirectories() : TextView
  • renderElement() : ScriptsRenderer , StylesRenderer
  • renderEventListenerTable() : DebugEventDispatcherCommand
  • renderException() : ErrorHandler , HtmlErrorRenderer
  • renderField() : SpacerField , Form , FormField
  • renderFieldset() : Form
  • renderHead() : JavascriptRenderer
  • renderInlineElement() : ScriptsRenderer , StylesRenderer
  • renderModal() : Bootstrap
  • renderModule() : ModuleHelper
  • renderOnShutdown() : JavascriptRenderer
  • renderOnShutdownWithHead() : JavascriptRenderer
  • renderParentBlock() : TraceableTwigTemplate
  • renderRawModule() : ModuleHelper
  • renderRow() : Table
  • renderRowSeparator() : Table
  • renderSection() : TextView
  • renderSubmenu() : CssMenu
  • renderTags() : HtmlDescriptor
  • renderThrowable() : Application
  • renderVar() : DebugBarVarDumper
  • reorder() : AdminController , AdminModel , Table , GroupsController , LevelsModel
  • repeat() : AbstractString
  • replace() : LdapClient , ConfigPostProcessor , Replacements , AbstractString , ByteString , CodePointString , UnicodeString
  • REPLACEABLE_TAG : JavascriptRenderer
  • replaceColors() : ColorProcessor
  • replaceDependencyAliases() : ConfigPostProcessor
  • replaceDependencyConfiguration() : ConfigPostProcessor
  • replaceDependencyFactories() : ConfigPostProcessor
  • replaceDependencyInvokables() : ConfigPostProcessor
  • replaceDependencyServices() : ConfigPostProcessor
  • replaceExactValue() : ConfigPostProcessor
  • replaceMatches() : AbstractString , AbstractUnicodeString , ByteString , UnicodeString
  • replacementRuleMatch() : ConfigPostProcessor
  • replacePrefix() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • replaceTagInBuffer() : JavascriptRenderer
  • replaceTags() : MailTemplate
  • reply() : MessageController
  • reportInvalidArgument() : Assert
  • republish() : MessageController
  • republishMessage() : MessagesModel
  • request() : CurlTransport , SocketTransport , StreamTransport , Curl , Socket , Stream , TransportInterface
  • request_forwarding() : Agent
  • REQUEST_GETTERS : SymfonyCaster
  • requestAgentForwarding() : SSH2
  • requestAttestation() : Credentials
  • requestIdentities() : Agent
  • requireAny() : PKCS
  • REQUIRED : InputArgument
  • required() : OptionConfigurator
  • requireDER() : PKCS
  • requirePEM() : PKCS
  • requiresDoubleQuoting() : Escaper
  • requiresSingleQuoting() : Escaper
  • reRegister() : ErrorHandler
  • resend() : UserController
  • RESERVED_FUTURE : Uuid
  • RESERVED_MICROSOFT : Uuid
  • RESERVED_NCS : Uuid
  • reset() : CaBundle , Inflector , Patcher , Form , Nested , Table , TableInterface , Uri , WebAssetManager , SearchesController , SearchesModel , ContainerResource , Patcher , SMTP , SSH2 , Application , OutputFormatterStyleStack , ResetInterface
  • reset_connection() : SFTP , SSH2
  • resetAfter() : Sanitizer
  • resetClonerOptions() : DebugBarVarDumper
  • resetDumperOptions() : DebugBarVarDumper
  • resetDumpHeader() : DebugBarHtmlDumper
  • resetHeadData() : HtmlDocument
  • resetHeadDatum() : HtmlDocument
  • resetInternal() : Sanitizer
  • resetIOCodepage() : QuestionHelper
  • resetMessages() : MessagesModel
  • resetOpCache() : Helper
  • resetOptions() : BaseLayout
  • resetPagination() : Query
  • resetParams() : Microdata
  • resetRandUserId() : ConfigurationModel
  • resetState() : Indexer
  • resetUserLanguage() : LanguageAdapter
  • resize() : Image
  • resizeImage() : TemplateModel
  • resizeKey() : AbstractAES
  • resolve() : ControllerResolver , ControllerResolverInterface , Path , ContentHelper , Path , OptionsResolver , LazyString , Manager , Resolvable , PharInvocationResolver
  • RESOLVE_ALIAS : PharInvocationResolver
  • RESOLVE_REALPATH : PharInvocationResolver
  • resolveAlias() : MenusHelper , Container
  • resolveAssertable() : PharStreamWrapper
  • resolveBaseName() : PharInvocationResolver
  • resolveContainer() : Reader
  • resolveFourByteLittleEndian() : Reader
  • resolveManifestLength() : Reader
  • resolvePath() : WebAssetItem
  • resolvePossibleAlias() : PharInvocationResolver
  • resolveStream() : Reader
  • resolveStyle() : Table
  • resolveTemplate() : TraceableTwigEnvironment
  • resolveTwoByteBigEndian() : Reader
  • resource() : Assert
  • respond() : AbstractWebApplication , ApiApplication
  • restart() : DaemonApplication , FtpClient , Session
  • RESTART : SessionEvents
  • restart() : SessionInterface
  • RESTART : ConnectionOptions
  • restoreInternalSteamWrapper() : PharStreamWrapper
  • restorePosition() : Cursor
  • RESULT_STATUS : PgSqlCaster
  • RESUME : SFTP
  • RESUME_START : SFTP
  • resync() : MenusController
  • retrieveInvocation() : PharInvocationResolver
  • retrieveOptionsFromInput() : SetConfigurationCommand
  • retrievePositiveInteger() : ECSignature , MultibyteStringConverter
  • retrieveTokenHeaders() : JWSTokenSupport
  • return_bytes() : WarningsModel
  • RETURN_CODE_DISABLED : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • RETURN_TYPES : TentativeTypes
  • reverse() : AbstractString , AbstractUnicodeString , ByteString
  • reverseItems() : Feed
  • revoke() : X509
  • REVOKED : AuthenticatorStatus
  • revokedCertificate() : X509
  • rewind() : Construct , DataSet , DatabaseIterator , CallbackStream , RelativeStream , Stream , StreamInterface , SplFixedArray
  • RFC_4122 : Uuid
  • rfcDate() : PHPMailer
  • rglob() : LocalAdapter
  • rI() : RsaKey
  • rightJoin() : DatabaseQuery
  • ristretto255_add() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_elligator() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_from_hash() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_frombytes() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_is_valid_point() : ParagonIE_Sodium_Compat
  • ristretto255_p3_tobytes() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_point_is_canonical() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_random() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_add() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_complement() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_from_string() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_invert() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_mul() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_negate() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_random() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_reduce() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_sub() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_sqrt_ratio_m1() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_sub() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • rmdir() : SFTP , PharStreamWrapper
  • rollBack() : TraceablePDO
  • ROMANIAN_LANGUAGE_CODE : ASCII
  • root() : Uri , Engine , BigInteger
  • rootHelper() : Engine
  • rootInner() : Engine , GMP
  • rotate() : Image , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_Salsa20 , PlgSystemLogrotation
  • rotateLeft32() : Hash
  • rotateLeft64() : Hash
  • rotl_64() : ParagonIE_Sodium_Core_SipHash
  • rotr64() : ParagonIE_Sodium_Core32_BLAKE2b
  • roundingNecessary() : RoundingNecessaryException
  • ROUNDS : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • route() : AdministratorApplication , CMSApplication , SiteApplication
  • rowCount() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • RSA1 : MSBLOB
  • RSA2 : MSBLOB
  • RSA_ENCRYPTION : OID
  • rsadp() : PrivateKey
  • rsaep() : PublicKey
  • rsaes_oaep_decrypt() : PrivateKey
  • rsaes_oaep_encrypt() : PublicKey
  • rsaes_pkcs1_v1_5_decrypt() : PrivateKey
  • rsaes_pkcs1_v1_5_encrypt() : PublicKey
  • rsasp1() : PrivateKey
  • rsassa_pkcs1_v1_5_relaxed_verify() : PublicKey
  • rsassa_pkcs1_v1_5_sign() : PrivateKey
  • rsassa_pkcs1_v1_5_verify() : PublicKey
  • rsassa_pss_sign() : PrivateKey
  • rsassa_pss_verify() : PublicKey
  • rsavp1() : PublicKey
  • rshift() : PHP
  • rtrim() : StringHelper
  • RULE_TYPE_FIELD : ExecutionRulesRule
  • rules() : Inflector
  • run() : Application , Command , LazyCommand , ProcessHelper , SingleCommandApplication , ApplicationTester
  • runCommand() : Application
  • runLazyCron() : PlgSystemSchedulerunner
  • RUNNING : Status
  • runScheduler() : PlgSystemSchedulerunner
  • runTestCron() : PlgSystemSchedulerunner
  • RUNTIME_BIAS : ZIPExtraction
  • RuntimeTest() : Crypto
  • runtimeTest() : RuntimeTests
  • runTransition() : AdminController
  • runWebCron() : PlgSystemSchedulerunner
  • RUSSIAN_GOST_2000_B_LANGUAGE_CODE : ASCII
  • RUSSIAN_LANGUAGE_CODE : ASCII
  • RUSSIAN_PASSPORT_2013_LANGUAGE_CODE : ASCII
  • rv() : French , Russian , Stem
  • rx() : Stem


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- s -

  • SAFARI : WebClient
  • safe_intval() : SymmetricKey
  • safe_intval_inline() : SymmetricKey
  • safe_serialize() : Random
  • safeEncode() : Client
  • safeStrlen() : Crypt , Binary
  • safeSubstr() : Crypt , Binary
  • salsa20() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20 , ChaCha20 , Salsa20
  • salsa20_xor() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • salsa20_xor_ic() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • SALT_BYTE_SIZE : Core
  • same() : Assertion , Assert
  • sanitize() : Sanitizer
  • sanitizeColor() : Backgroundfill
  • sanitizeHeight() : Image
  • sanitizeOffset() : Image
  • sanitizeOptions() : SetConfigurationCommand
  • sanitizeProperty() : Microdata
  • sanitizeType() : Microdata
  • sanitizeWidth() : Image
  • sanityCheckSystemVariables() : CMSApplication
  • sapi_windows_vt100_support() : Php72
  • satisfies() : InstalledVersions
  • satisfy() : Assertion
  • save() : FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , FormController , AdminModel , Table , ToolbarHelper , UCMContent , User , CategoryController , CategoryModel , ApplicationModel , ComponentModel , ConfigController , TemplatesController , FormModel , ArticleController , FormModel , FieldModel , GroupModel , UpdatesiteModel , OverrideController , LanguageModel , OverrideModel , TemplateModel , MediumModel , ItemModel , MenuModel , ConfigController , ConfigModel , MessageModel , ModuleController , ModuleModel , PluginModel , RequestModel , TaskModel , StyleController , StyleModel , TemplateModel , UserController , GroupModel , LevelModel , UserModel , ProfileModel , StageModel , TransitionModel , WorkflowModel , FileStorage , Raw , ASN1 , SSH2 , ASN1 , SSH2
  • save2copy() : ToolbarHelper
  • save2new() : ToolbarHelper
  • saveBytesToChecksummedAsciiSafeString() : Encoding
  • saveConfiguration() : SetConfigurationCommand
  • saveCredentialSource() : PublicKeyCredentialSourceRepository
  • saveCRL() : X509
  • saveCSR() : X509
  • saveGroup() : ToolbarHelper
  • saveorder() : AdminController , AdminModel , Nested , CategoryModel , ItemModel , GroupsController , LevelsModel
  • saveOrderAjax() : AdminController
  • saveOverrides() : PlgInstallerOverride
  • saveParameters() : PKCS1
  • saveParams() : LibraryHelper , PlgSystemStats
  • savePosition() : Cursor
  • savePrivateKey() : PKCS8 , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , libsodium , MontgomeryPrivate , OpenSSH , PKCS1 , PKCS8 , PuTTY , MSBLOB , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML
  • savePSSParams() : PSS
  • savePublicKey() : PKCS8 , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , XML , libsodium , MontgomeryPrivate , MontgomeryPublic , OpenSSH , PKCS8 , PuTTY , XML , MSBLOB , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML
  • saveSPKAC() : X509
  • saveToAsciiSafeString() : Key , KeyProtectedByPassword
  • saveToIniFile() : LanguageHelper
  • saveX509() : X509
  • sBase : NamePrep
  • sc25519_invert() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_mul() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_sq() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_sqmul() : ParagonIE_Sodium_Core_Curve25519
  • scalar() : Assertion , Assert
  • scalar_add() : ParagonIE_Sodium_Core_Ed25519
  • SCALAR_BYTES : ParagonIE_Sodium_Core_Ed25519
  • scalar_complement() : ParagonIE_Sodium_Core_Ed25519
  • scalar_negate() : ParagonIE_Sodium_Core_Ed25519
  • scalar_random() : ParagonIE_Sodium_Core_Ed25519
  • scalar_sub() : ParagonIE_Sodium_Core_Ed25519
  • scalarmult() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scalarmult_base() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scalarmult_ristretto255() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • scalarmult_ristretto255_base() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • scalarmult_throw_if_zero() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scale() : BCMath
  • SCALE_FILL : Image
  • SCALE_FIT : Image
  • SCALE_INSIDE : Image
  • SCALE_OUTSIDE : Image
  • scaleValues() : BigDecimal
  • scan1divide() : BCMath , GMP , PHP , BigInteger
  • SCHEME : UriInterface
  • SCHEMES : Uri
  • SCOPE_BASE : QueryInterface
  • SCOPE_ONE : QueryInterface
  • SCOPE_SUB : QueryInterface
  • scopeAt() : ErrorHandler
  • sCount : NamePrep
  • screamAt() : ErrorHandler
  • script() : HTMLHelper , Text
  • scrollspy() : Bootstrap
  • search() : StringsController , StringsModel , AdapterInterface , ApiModel , LdapClient , LocalAdapter , Stem
  • searchAjax() : TagsController
  • searchByString() : PlgAuthenticationLdap
  • searchIfInR1() : Stem
  • searchIfInR2() : Stem
  • searchIfInRv() : Stem
  • searchShortSyllabe() : English
  • searchTags() : TagsHelper
  • second() : DatabaseQuery , QueryInterface
  • SECRET_KEY_LENGTH : Email
  • SECRET_TYPE_KEY : KeyOrPassword
  • SECRET_TYPE_PASSWORD : KeyOrPassword
  • secretbox_xchacha20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretkey() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • secretstream_xchacha20poly1305_init_pull() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretstream_xchacha20poly1305_init_push() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretstream_xchacha20poly1305_rekey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • section() : ConsoleOutput , ConsoleOutputInterface , StyleInterface , SymfonyStyle
  • secureHeader() : PHPMailer
  • SecureRandom() : Crypto
  • secureRandom() : Core
  • SEED_BYTES : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • seek() : SeekingData , Stream , CallbackStream , RelativeStream , Stream , StreamInterface , Data
  • seek_cur() : BufferStreamHandler
  • seek_end() : BufferStreamHandler
  • seek_set() : BufferStreamHandler
  • seemsUtf8() : Inflector
  • select() : Filter , DatabaseInterface , DatabaseQuery , MysqlDriver , MysqliDriver , PdoDriver , QueryInterface , SqliteDriver
  • selectKey() : JWKSet
  • selectRowNumber() : DatabaseQuery , QueryInterface , SqliteQuery
  • SELF_ASSERTION_SUBMITTED : AuthenticatorStatus
  • Send() : Mail
  • send() : MailController , MailModel , PHPMailer
  • send_binary_packet() : SSH2
  • send_channel_packet() : SSH2
  • send_sftp_packet() : SFTP
  • sendAndMail() : SMTP
  • sendCode() : Email
  • sendCommand() : SMTP
  • sendDataInHeaders() : DebugBar
  • sendHeaders() : AbstractWebApplication , WebApplicationInterface
  • sendHello() : SMTP
  • sendIdentificationStringFirst() : SSH2
  • sendIdentificationStringLast() : SSH2
  • sendJsonResponse() : JSONController
  • sendKEXINITFirst() : SSH2
  • sendKEXINITLast() : SSH2
  • sendMail() : Mail
  • sendmailSend() : PHPMailer
  • sendNotificationEmails() : ActionlogModel
  • sendRequest() : Http , ClientInterface
  • sendResponse() : IndexerController , ApiController
  • sendStats() : PlgSystemStats
  • sendString() : POP3
  • sendTestMail() : ApplicationModel
  • SEPARATOR_BOTTOM : Table
  • SEPARATOR_MID : Table
  • SEPARATOR_TOP : Table
  • SEPARATOR_TOP_BOTTOM : Table
  • SEQUENCE : Identifier
  • SERBIAN_CYRILLIC_LANGUAGE_CODE : ASCII
  • SERBIAN_LANGUAGE_CODE : ASCII
  • SERBIAN_LATIN_LANGUAGE_CODE : ASCII
  • SERIAL_NUMBER : OID
  • serialize() : BigDecimal , BigInteger , BigRational , Cli , Result , AbstractEvent , Route , Router , CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer , JWSSerializerManager , Uuid , HttpHeaderSerializer
  • SERIALIZE_HEADER_BYTES : Encoding
  • serializeHeaders() : AbstractSerializer
  • SERIALIZERS : RedisCaster
  • server() : System
  • SERVER_CONTROLS : ConnectionOptions
  • serverClaimsUtf8mb4Support() : MysqliDriver
  • serverHostname() : PHPMailer
  • SERVICE_MANAGER_KEYS_OF_INTEREST : ConfigPostProcessor
  • SESSION_GROUP : GetConfigurationCommand
  • set() : Calculator , ClassLoader
  • SET : Identifier
  • set() : AbstractApplication , ConfigurationAwareApplicationInterface , Cookie , Files , BaseLayout , CMSObject , Session , JoomlaStorage , PhpSetting , Task , DatabaseQuery , QueryInterface , Container , Stream , Cookie , Files , Input , Registry , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Builder , PHPMailer , Color , HelperSet
  • setAAD() : SymmetricKey
  • setAbort() : FeatureEvent
  • setAction() : Sidebar
  • setActive() : AbstractMenu
  • setAdapter() : Archive , Adapter , FetchMediaItemUrlEvent
  • setAdditionalUrlParam() : Pagination
  • setAddPath() : ZIPExtraction
  • setAjaxHandlerAutoShow() : JavascriptRenderer
  • setAjaxHandlerClass() : JavascriptRenderer
  • setAliases() : AbstractCommand , Command
  • setAllLoaded() : CategoryNode
  • setAllowedAttrs() : Sanitizer
  • setAllowedTags() : Sanitizer
  • setAllowedTypes() : OptionsResolver
  • setAllowedValues() : OptionsResolver
  • setAllowIpOverrides() : IpHelper
  • setApcuPrefix() : ClassLoader
  • setApplication() : CMSPlugin , AbstractCommand , Command , LazyCommand
  • setArgument() : AbstractEvent , Event , Input , InputInterface
  • setArguments() : InputDefinition
  • setAssertClass() : LazyAssertion
  • setAssertionClassName() : AssertionChain
  • setAsString() : FlattenException
  • setAttestationSupport() : Authentication
  • setAttribute() : TraceablePDO , WebAssetItem , WebAssetItemInterface , X509 , Entry
  • setAudience() : Builder , ValidationData
  • setAuthor() : Feed , FeedEntry
  • setAutocompleterCallback() : Question
  • setAutocompleterValues() : Question
  • setAutoExit() : Application , SingleCommandApplication
  • setBackground() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • setBarCharacter() : ProgressBar
  • setBarWidth() : ProgressBar
  • setBase() : Document
  • setBasePath() : JavascriptRenderer
  • setBasePoint() : Binary , Montgomery , Prime , TwistedEdwards
  • setBaseTemplateClass() : TraceableTwigEnvironment
  • setBaseUrl() : JavascriptRenderer
  • setBinaryOutput() : OpenSSH
  • setBindAjaxHandlerToFetch() : JavascriptRenderer
  • setBindAjaxHandlerToJquery() : JavascriptRenderer
  • setBindAjaxHandlerToXHR() : JavascriptRenderer
  • setBitmask() : BCMath , Engine
  • setBlockLength() : AES , Rijndael
  • setBody() : AbstractWebApplication , WebApplicationInterface , Mail
  • setBorderFormat() : TableStyle
  • setBrowser() : Browser
  • setBuffer() : Document , HtmlDocument
  • setBuilderFactory() : Configuration
  • setCache() : TraceableTwigEnvironment
  • setCacheControllerFactory() : CacheControllerFactoryAwareInterface
  • setCacheControllerOnObject() : MVCFactory
  • setCaching() : Cache
  • setCAOptionAndValue() : Curl
  • setCatchExceptions() : Application
  • setCatchThrowables() : Application
  • setCellHeaderFormat() : TableStyle
  • setCellRowContentFormat() : TableStyle
  • setCellRowFormat() : TableStyle
  • setCfg() : InstallationApplication
  • setChainExceptions() : ExceptionsCollector
  • setChallenge() : X509
  • setChallengeTimeout() : ReCaptcha
  • setCharset() : TraceableTwigEnvironment , Document , AbstractDumper
  • setClass() : FlattenException
  • setClassMapAuthoritative() : ClassLoader
  • setClient() : FileLayout
  • setCode() : Validate , Command , LazyCommand , FlattenException
  • setCodec() : UuidFactory
  • setCoefficients() : Binary , Montgomery , Prime , TwistedEdwards
  • setColors() : CliDumper
  • setColumnAlias() : Table
  • setColumnMaxWidth() : Table
  • setColumnStyle() : Table
  • setColumnWidth() : Table
  • setColumnWidths() : Table
  • setCommand() : HelpCommand , HelperSet
  • setCommandLoader() : Application
  • setComment() : OpenSSH , PuTTY
  • setCompiler() : TraceableTwigEnvironment
  • setComponent() : FileLayout
  • setComponentRouter() : SiteRouter
  • setConfiguration() : AbstractApplication , ConfigurationAwareApplicationInterface
  • setContainer() : ContainerAwareInterface
  • setContent() : Key
  • setContentLength() : ASNObject
  • setContext() : GetIconEvent , OAuthCallbackEvent , QuickIconsEvent
  • setContextOptions() : Stream
  • setController() : Route
  • setCookieParams() : JoomlaStorage
  • setCorrectPermissions() : ZIPExtraction
  • setCounter() : Session , Salsa20 , PublicKeyCredentialSource
  • setCredentials() : ClientHelper
  • setCredentialsFromRequest() : ClientHelper
  • setCrossingChars() : TableStyle
  • setCryptoEngine() : SSH2
  • setCspHeader() : PlgSystemHttpHeaders
  • setCspNonce() : JavascriptRenderer
  • setCurrentTime() : ValidationData
  • setCurrentUser() : CurrentUserInterface
  • setData() : ConfigCollector , JsonapiDocument , BaseLayout , Document , Relationship , Resource
  • setDatabase() : DatabaseAwareInterface
  • setDataFormatter() : DataCollector , MessagesCollector
  • setDbo() : BaseDatabaseModel , Table , DatabaseExporter , DatabaseImporter
  • setDebug() : Language , BaseLayout
  • setDebugLevel() : SMTP
  • setDebugOutput() : SMTP
  • setDecorated() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setDefault() : LanguagesModel , Language , AbstractMenu , InstalledController , ItemsController , StagesController , WorkflowsController , StageModel , WorkflowModel , InputArgument , InputOption , OptionsResolver
  • setDefaultCommand() : Application
  • setDefaultCrossingChar() : TableStyle
  • setDefaultDataFormatter() : DataCollector
  • setDefaultLogger() : ErrorHandler
  • setDefaults() : Route , OptionsResolver
  • setDefaultVarDumper() : DataCollector
  • setDefined() : OptionsResolver
  • setDefinition() : AbstractCommand , Application , Command , LazyCommand , InputDefinition
  • setDelta() : AfterMoveEvent , BeforeMoveEvent
  • setDeprecated() : OptionsResolver
  • setDescription() : Document , AbstractCommand , Command
  • setDetectBrowser() : SiteApplication
  • setDimensions() : ANSI
  • setDirection() : Document
  • setDispatcher() : DispatcherAwareInterface , Application
  • setDispatcherOnObject() : MVCFactory
  • setDisplayOptions() : CliDumper , HtmlDumper
  • setDn() : LdapClient
  • setDN() : X509
  • setDNProp() : X509
  • setDocumentTitle() : HtmlView
  • setDomain() : X509
  • setDownload() : XmlDocument
  • setDumpBoundaries() : HtmlDumper
  • setDumpHeader() : HtmlDumper
  • setElement() : Result
  • setEmptyBarCharacter() : ProgressBar
  • setEmptyStyle() : OutputFormatterStyleStack
  • setEnableJqueryNoConflict() : JavascriptRenderer
  • setEnclosure() : FeedItem
  • setEncryptionAlgorithm() : PKCS1 , PKCS8
  • setEncryptionMode() : AesInterface , Mcrypt , OpenSSL
  • setEncryptionScheme() : PKCS8
  • setEndDate() : X509
  • setEngine() : SymmetricKey
  • setError() : ApplicationErrorEvent , ErrorDocument , ErrorEvent , CMSObject , ApplicationErrorEvent , CommandErrorEvent , PHPMailer , POP3 , SMTP , ConsoleErrorEvent , ZIPExtraction
  • setErrorMessage() : ChoiceQuestion
  • setErrorOutput() : ConsoleOutput , ConsoleOutputInterface
  • setErrors() : JsonapiDocument , Document
  • setEvent() : Dispatcher
  • setExceptionClass() : LazyAssertion
  • setExceptionHandler() : ErrorHandler
  • setExitCode() : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent
  • setExpectedAction() : ReCaptcha
  • setExpectedApkPackageName() : ReCaptcha
  • setExpectedHostname() : ReCaptcha
  • setExpiration() : Builder
  • setExpire() : Session
  • setExponent() : RSA
  • setExpression() : CronExpression
  • setExtension() : X509
  • setExtensionHelper() : X509
  • setExtensionOutputCheckerHandler() : Server
  • setExtensions() : TraceableTwigEnvironment , ExtensionsListCommand
  • setExtensionValue() : X509
  • setFactory() : Document , Toolbar , Uuid
  • setFetchMode() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • setField() : Form
  • setField_type() : CaptiveRenderOptions , SetupRenderOptions
  • setFieldAttribute() : Form
  • setFields() : Form , OnGetApiFields
  • setFieldValue() : FieldModel
  • setFile() : FlattenException
  • setFilename() : ZIPExtraction
  • setFilters() : ASN1
  • setFlag() : MethodsModel
  • setFooterTitle() : Table
  • setFooterTitleFormat() : TableStyle
  • setForeground() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • setForm() : FormField
  • setFormat() : ProgressBar
  • setFormatDefinition() : ProgressBar
  • setFormatOptions() : HTMLHelper
  • setFormatter() : ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setFormFactory() : FormFactoryAwareInterface
  • setFormFactoryOnObject() : MVCFactory
  • setFragment() : Uri
  • setFrom() : PHPMailer
  • setGenerator() : Document
  • setGroups() : UserGroupsHelper
  • setHandler() : NativeStorage , VarDumper
  • setHash() : Hash
  • setHeadData() : HtmlDocument
  • setHeader() : AbstractWebApplication , WebApplicationInterface , Builder
  • setHeaders() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver , Table , FlattenException
  • setHeaderTitle() : Table
  • setHeaderTitleFormat() : TableStyle
  • setHelp() : AbstractCommand , Command , LazyCommand
  • setHelperFactory() : HelperFactoryAwareInterface
  • setHelperSet() : Application , AbstractCommand , Application , Command , LazyCommand , Helper , HelperInterface
  • setHidden() : AbstractCommand , Command , Question
  • setHiddenFallback() : Question
  • setHistory() : ANSI
  • setHome() : ItemModel , StyleModel
  • setHorizontal() : Table
  • setHorizontalBorderChars() : TableStyle
  • setHost() : Uri
  • setHref() : OutputFormatterStyle
  • setHtml5() : HtmlDocument
  • setHttpDriver() : DebugBar
  • setHttpHeaders() : PlgSystemHttpHeaders
  • setId() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Builder , ValidationData
  • setIgnore() : BeforeBindEvent
  • setIgnoreDirectories() : ZIPExtraction
  • setIgnoredSearchWordsCallback() : Language
  • setIncludePaths() : FileLayout
  • setIncludeVendors() : JavascriptRenderer
  • setIndentPad() : AbstractDumper
  • setInfo() : OptionsResolver
  • setInitialization() : JavascriptRenderer
  • setInput() : SaveSetup , OAuthCallbackEvent , InputAwareHelper , InputAwareInterface
  • setInput_attributes() : CaptiveRenderOptions , SetupRenderOptions
  • setInstance() : Log
  • setInteractive() : Input , InputInterface
  • setIOCodepage() : QuestionHelper
  • setIp() : IpHelper
  • setIPAddress() : X509
  • setIssuedAt() : Builder
  • setIssuer() : Builder , ValidationData
  • setItem() : FetchMediaItemEvent
  • setItemName() : Pathway
  • setItems() : Toolbar , FetchMediaItemsEvent
  • setIterationCount() : PKCS8
  • setIV() : SymmetricKey , TripleDES
  • setJavascriptClass() : JavascriptRenderer
  • setJsonapi() : JsonapiDocument , Document
  • setKeepAlive() : SSH2
  • setKey() : RouterViewConfiguration , Crypt , AES , SymmetricKey , DES , Hash , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • setKeyIdentifier() : X509
  • setKeyLength() : AES , Blowfish , SymmetricKey , RC2 , RC4 , Rijndael , TripleDES , Twofish
  • setLanguage() : Document , Result , OutputFilter , PHPMailer
  • setLanguageCookie() : PlgSystemLanguageFilter
  • setLanguageFilter() : SiteApplication
  • setLastExtractedFilename() : ZIPExtraction
  • setLastExtractedFileTimestamp() : ZIPExtraction
  • setLastVisit() : User
  • setLayout() : ActionButton , HtmlView
  • setLayoutExt() : HtmlView
  • setLayoutId() : FileLayout
  • setLE() : PHPMailer
  • setLexer() : TraceableTwigEnvironment
  • setLifeTime() : Cache
  • setLimit() : DatabaseQuery , LimitableInterface
  • setLine() : FlattenException
  • setLineEnd() : Document
  • setLink() : Document
  • setLinkProvider() : PreloadManager , PreloadManagerInterface
  • setListOrder() : SFTP
  • setLoader() : TraceableTwigEnvironment
  • setLocale() : AsciiSlugger
  • setLocation() : Nested
  • setLogger() : LoggerAwareInterface
  • setLoggers() : ErrorHandler
  • setLogQueriesToLogger() : PropelCollector
  • setLowerLimitSearchWordCallback() : Language
  • setManifest() : InstallerAdapter
  • setMaxAttempts() : Question
  • setMaxItems() : AbstractCloner
  • setMaxIterationCount() : CronExpression
  • setMaxSteps() : ProgressBar
  • setMaxString() : AbstractCloner
  • setMaxStringWidth() : CliDumper
  • setMediaVersion() : Document , Version
  • setMenuFactory() : CMSApplication
  • setMergeProperty() : AggregatedCollector
  • setMessage() : BaseController , ProgressBar , ProgressIndicator , FlattenException
  • setMessageType() : PHPMailer
  • setMetaData() : Document
  • setMethod() : Callback
  • setMethods() : Route
  • setMimeEncoding() : Document
  • setMinDepth() : AbstractCloner
  • setModel() : AbstractView
  • setModelState() : MediaController
  • setModExpEngine() : Engine
  • setModifiedDate() : Document
  • setModulo() : Binary , Montgomery , Prime , TwistedEdwards , Integer
  • setMonitor() : DatabaseDriver
  • setMultiline() : Question
  • setMultiselect() : ChoiceQuestion
  • setName() : ConsoleApplication , RouterViewConfiguration , JsonDocument , XmlDocument , Application , AbstractCommand , QueryElement , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Application , Command
  • setNamespace() : XML
  • setNestable() : RouterViewConfiguration
  • setNonce() : SodiumCipher , Sodium , ChaCha20 , SymmetricKey , Hash , Salsa20
  • setNormalizer() : Question , OptionsResolver
  • setNotBefore() : Builder
  • setNumberConverter() : UuidFactory
  • setOAuth() : PHPMailer
  • setOpenHandlerClass() : JavascriptRenderer
  • setOpenHandlerUrl() : JavascriptRenderer
  • setOpenSSLConfigPath() : RSA
  • setoptArray() : Curl
  • setOption() : ActionButton , ToolbarButton , WebAssetItem , WebAssetItemInterface , PdoDriver , Http , Client , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface , Input , InputInterface , Connection
  • setOptions() : JavascriptRenderer , ActionButton , FtpClient , SetConfigurationCommand , BaseLayout , JoomlaStorage , ToolbarButton , FtpClient , Session , NativeStorage , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface , InputDefinition
  • setOrder() : Base
  • setOtpConfig() : UserModel
  • setOutput() : CliApplication , AbstractDumper
  • setOverwrite() : Installer , ProgressBar
  • setPackageUninstall() : Installer
  • setPaddingChar() : TableStyle
  • setPadType() : TableStyle
  • setParam() : User
  • setParameters() : User
  • setParams() : ComponentRecord , InstallerScript , MenuItem
  • setParent() : CategoryNode , RouterViewConfiguration , ToolbarButton , NodeInterface
  • setParsedFile() : ParseException
  • setParsedLine() : ParseException
  • setParser() : TraceableTwigEnvironment , Configuration
  • setPart() : CronExpression
  • setPass() : Uri
  • setPassword() : Aes , SymmetricKey , LdapUser
  • setPath() : Installer , BaseController , FetchMediaItemUrlEvent , Uri
  • setPathway() : Pathway
  • setPattern() : Route
  • setPayload() : JsonResponse
  • setPermissions() : Path
  • setPlaceholderFormatterDefinition() : ProgressBar , ProgressIndicator
  • setPluralSuffixesCallback() : Language
  • setPoly1305Key() : SymmetricKey
  • setPort() : Uri
  • setPrecision() : Engine , BigInteger
  • setPrefer() : BigInteger
  • setPreferredAlgorithms() : SSH2
  • setPreferredEngine() : SymmetricKey , TripleDES
  • setPreferredVersion() : SFTP
  • setPreloadManager() : Document
  • setPrevious() : FlattenException
  • setPRF() : PKCS8
  • setPrivateKey() : X509
  • setProcessor() : CliOutput
  • setProcessTitle() : Command , LazyCommand
  • setProgress() : ProgressBar
  • setProgressCharacter() : ProgressBar
  • setPrompt() : ChoiceQuestion
  • setProperties() : CMSObject
  • setProperty() : DataObject
  • setPrototype() : OptionsResolver
  • setProviderManager() : MediaProviderEvent
  • setPsr4() : ClassLoader
  • setPublicKey() : X509
  • setPublished() : LanguagesModel
  • setQuery() : BeforeMoveEvent , BeforePublishEvent , BeforeReorderEvent , DatabaseDriver , DatabaseInterface , DatabaseQuery , Uri
  • setRandomGenerator() : UuidFactory
  • setRealFormat() : ProgressBar
  • setRealUsage() : MemoryCollector
  • setRecord() : Captive , GetSetup , SaveSetup , Validate
  • setRecurLimit() : X509
  • setRecurringModuloFunction() : Integer
  • setRedirect() : BaseController
  • setRedirectUrl() : Installer
  • setRedrawFrequency() : ProgressBar
  • setReduction() : Base , PrimeField
  • setRegex() : Route
  • setRegisteredClaim() : Builder
  • setRelations() : OnGetApiFields
  • setRelationship() : OnGetApiRelation
  • setRenderSqlWithParams() : PDOCollector
  • setReplaceTags() : SetNewTagsEvent
  • setReplyTo() : MailTemplate
  • setRequestIdGenerator() : DebugBar
  • setRequired() : OptionsResolver
  • setReset() : BeforeLoadEvent
  • setResources() : Collection
  • setResponse() : AbstractWebApplication , WebApplicationInterface
  • setResult() : AfterLoadEvent , AfterStoreEvent , ExecuteTaskEvent
  • setReturnType() : DebugClassLoader
  • setRevokedCertificateExtension() : X509
  • setRoute() : InstallerAdapter
  • setRouterOnObject() : MVCFactory
  • setRouteVariables() : Route
  • setRow() : AfterLoadEvent , AfterMoveEvent , Table
  • setRows() : Table
  • setRules() : Table , Route
  • setSchemaVersion() : Installer
  • setScheme() : Uri
  • setScoreThreshold() : ReCaptcha
  • setSearchDisplayedCharactersNumberCallback() : Language
  • setSec() : FixedTimeProvider
  • setSelectedAlgorithms() : Server
  • setSender() : Mail
  • setSeparator() : BreadcrumbsHelper
  • setSerializer() : Resource
  • setSerialNumber() : X509
  • setSession() : SessionAwareWebApplicationInterface , ConsoleApplication
  • setSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • setShortName() : OpensearchDocument
  • setSibling() : NodeInterface
  • setSignalsToDispatchEvent() : Application
  • setSignature() : CSR
  • setSiteRouter() : SiteRouterAwareInterface
  • setSize() : SplFixedArray
  • setSkipFiles() : ZIPExtraction
  • setSmallestPrime() : RSA
  • setSMTPInstance() : PHPMailer
  • setSnippet() : ParseException
  • setSort() : AggregatedCollector
  • setSqlQueries() : PdoStorage
  • setSrc() : BeforeBindEvent
  • setStackAlwaysUseSessionStorage() : DebugBar
  • setStackDataSessionNamespace() : DebugBar
  • setStart() : Profiler
  • setStartDate() : X509
  • setstat() : SFTP
  • setstat_recursive() : SFTP
  • setState() : BeforePublishEvent , StatefulModelInterface , Indexer , Session
  • setStaticHeaders() : PlgSystemHttpHeaders
  • setStatusCode() : Response , FlattenException
  • setStatusText() : FlattenException
  • setStopTransition() : WorkflowTransitionEvent
  • setStorage() : DebugBar
  • setStream() : Stream , Input , StreamableInputInterface
  • setStyle() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , Table
  • setStyleDefinition() : Table
  • setStyles() : CliDumper , HtmlDumper
  • setSubject() : AbstractEvent , WebAssetRegistryAssetChanged , Mail , Builder , ValidationData
  • setSuffixes() : FileLayout
  • setTab() : Document
  • setTag() : SymmetricKey
  • setTagsHelper() : TaggableTableInterface
  • setTemplate() : SiteApplication
  • setTerminal() : SSH2
  • setTheme() : HtmlDumper
  • setThumbnailGenerate() : Image
  • setTimeDataCollector() : TimeableTwigExtensionProfiler
  • setTimeFormat() : ASN1
  • setTimeGenerator() : UuidFactory
  • setTimeHour() : AbstractField
  • setTimeout() : SMTP , SSH2
  • setTimeProvider() : FeatureSet
  • setTimers() : Session
  • setTimezone() : Date
  • setTitle() : Document
  • setToken() : Client
  • setTokenBindingHandler() : Server
  • setTokens() : ArgvInput
  • setTrace() : FlattenException
  • setTraceFromThrowable() : FlattenException
  • setTransliterator() : Language
  • setTrimmable() : Question
  • setType() : Document , Microdata , OnGetApiFields , ItemController
  • setUnsignedInt() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • setup() : JLoader , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , PredefinedlistField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , TransitionField , UserField , UsergrouplistField , WorkflowconditionField , WorkflowstageField , FormField , LanguageField , ConfigurationModel , CategoryeditField , AssocField , VotelistField , VoteradioField , SectionField , SubfieldsField , TypeField , Adapter , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , CronField , IntervalField , ConsentBoxField , TemplatesListField , UploaddirsField , JoomlatokenField , ChaCha20 , SymmetricKey , Rijndael , Salsa20 , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • setUpBefore() : Sanitizer
  • setUpdateInfo() : CheckJoomlaUpdatesCommand , UpdateCoreCommand
  • setUpdateModel() : UpdateCoreCommand
  • setUpdateNulls() : BeforeStoreEvent
  • setupField() : Captcha
  • setupGCM() : SymmetricKey
  • setUpgrade() : Installer
  • setupInlineCrypt() : Blowfish , DES , RC2 , Rijndael , Twofish
  • setupInstall() : Installer
  • setupInstallPaths() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • setupIsPrime() : Engine
  • setupKey() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • setupLogging() : CMSApplication
  • setupMaxExecTime() : ZIPExtraction
  • setUpperLimitSearchWordCallback() : Language
  • setupScriptfile() : InstallerAdapter
  • setupSignalHandlers() : DaemonApplication
  • setupUninstall() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • setupUpdates() : ComponentAdapter , InstallerAdapter
  • setUpWorkflow() : WorkflowModelInterface
  • setUrl() : FetchMediaItemUrlEvent
  • setUsec() : FixedTimeProvider
  • setUsed() : WorkflowFunctionalityUsedEvent
  • setUseIncludePath() : ClassLoader
  • setUseNestingLimit() : Sanitizer
  • setUser() : BeforeDisplayMethods , Validate , AbstractMenu , Uri
  • setUseRequireJs() : JavascriptRenderer
  • setUserGroups() : UserHelper
  • setUserId() : BeforeCheckoutEvent , BeforePublishEvent
  • setUserState() : CMSApplication , CMSWebApplicationInterface
  • setUtf() : DatabaseDriver , MysqliDriver , PdoDriver , SqliteDriver
  • setUuidBuilder() : UuidFactory
  • setValidationConstraints() : Configuration
  • setValidator() : Configuration , Question
  • setValue() : Form , FormField
  • setVar() : Router , Uri
  • setVarDumper() : DataCollector , MessagesCollector
  • setVariable() : PharInvocation
  • setVariableName() : JavascriptRenderer
  • setVars() : Router
  • setVerbosity() : ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setVerp() : SMTP
  • setVersion() : Changelog , Application , PuTTY , Application , SingleCommandApplication
  • setVerticalBorderChars() : TableStyle
  • setWebAssetManager() : Document
  • setWhere() : AfterMoveEvent , AfterReorderEvent , BeforeMoveEvent , BeforeReorderEvent
  • setWindowColumns() : SSH2
  • setWindowRows() : SSH2
  • setWindowSize() : SSH2
  • setWordWrap() : PHPMailer
  • setWorkarounds() : Cache
  • setXdebugLinkTemplate() : DataCollector
  • setXdebugReplacement() : DataCollector
  • setXdebugReplacements() : DataCollector
  • setXMLOptions() : Sanitizer
  • sha1() : Hash
  • SHA1_WITH_RSA_SIGNATURE : OID
  • sha256() : Hash
  • SHA256_WITH_RSA_SIGNATURE : OID
  • sha384() : Hash
  • sha3_32() : Hash
  • sha3_64() : Hash
  • sha3_pad() : Hash
  • sha512() : Hash
  • share() : Container
  • SHARE : ContainerResource
  • shift() : Strings
  • shiftedLeft() : BigInteger
  • shiftedRight() : BigInteger
  • shiftLeft() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • shiftRight() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • shortcutToName() : InputDefinition
  • shouldAutoExit() : Application
  • shouldCatchThrowables() : Application
  • shouldDisplayMessage() : PlgQuickiconPhpVersionCheck
  • shouldDisplayPreUpdateCheck() : HtmlView
  • show() : Cursor
  • showTables() : PgsqlDriver
  • shutdown() : DaemonApplication , ZIPExtraction
  • sign() : ECDSA , ES256 , ES256K , ES384 , ES512 , ED256 , ED512 , EdDSA , PSSRSA , RSA , Signature , ECDSA , EdDSA , None , RSA , RSAPKCS1 , RSAPSS , SignatureAlgorithm , RSA , Builder , BaseSigner , Signer , ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto , PHPMailer , PrivateKey , X509
  • SIGN : PHP
  • sign() : Identity
  • sign_detached() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519 , ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • sign_open() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • sign_verify_detached() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • signal() : DaemonApplication
  • SIGNAL : ConsoleEvents
  • signature() : Token
  • SIGNATURE_PKCS1 : RSA
  • SIGNATURE_PSS : RSA
  • SIGNATURE_RELAXED_PKCS1 : RSA
  • signCRL() : X509
  • signCSR() : X509
  • signer() : Configuration
  • signingKey() : Configuration
  • signRequest() : Client
  • signSPKAC() : X509
  • signWithPKCS15() : RSA
  • signWithPSS() : RSA
  • simple_search() : LdapClient
  • simplified() : BigRational
  • SINGULAR_MAP : EnglishInflector
  • singularize() : Inflector , EnglishInflector , FrenchInflector , InflectorInterface
  • SINGULARIZE_REGEXP : FrenchInflector
  • sipHash24() : ParagonIE_Sodium_Core32_SipHash , ParagonIE_Sodium_Core_SipHash
  • sipRound() : ParagonIE_Sodium_Core32_SipHash , ParagonIE_Sodium_Core_SipHash
  • SITE_DOWN_FAILED : SiteDownCommand
  • SITE_DOWN_SUCCESSFUL : SiteDownCommand
  • SITE_UP_FAILED : SiteUpCommand
  • SITE_UP_SUCCESSFUL : SiteUpCommand
  • SITE_VERIFY_URL : HttpBridgePostRequestMethod , ReCaptcha
  • size() : FtpClient
  • SIZE : Ed25519 , Ed448
  • SIZELIMIT : ConnectionOptions
  • sk_to_pk() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • skew : AbstractPunycode
  • skipExecution() : Task
  • sLast : NamePrep
  • sleep() : DemoTasks
  • slice() : AbstractString , ByteString , CodePointString , UnicodeString
  • slider() : Filter
  • slidingWindow() : Engine , Montgomery
  • SLOVAK_LANGUAGE_CODE : ASCII
  • slug() : AsciiSlugger , SluggerInterface
  • smtpClose() : PHPMailer
  • smtpConnect() : PHPMailer
  • smtpSend() : PHPMailer
  • snake() : AbstractString , AbstractUnicodeString , ByteString
  • sort() : AggregatedCollector , Grid , SearchTools
  • sortable() : SortableList
  • sortCommands() : ApplicationDescription
  • sortKeys() : JWKSet
  • sortObjects() : ArrayHelper
  • SOURCE_CALLBACK : SFTP
  • SOURCE_LOCAL_FILE : SFTP
  • SOURCE_STRING : SFTP
  • spacer() : ToolbarHelper , Users
  • SPANISH : Language
  • SPECIAL_RETURN_TYPES : DebugClassLoader
  • SPL_FILE_OBJECT_FLAGS : SplCaster
  • spl_object_id() : Php72
  • splice() : AbstractString , ByteString , CodePointString , UnicodeString
  • SPLIT : Patcher
  • split() : JWS , AbstractString , ByteString , CodePointString , UnicodeString
  • splitJwt() : Parser
  • splitLines() : Patcher
  • splitQueries() : DatabaseModel
  • splitQueryValue() : Uri
  • splitSql() : Installer , DatabaseDriver
  • splitSqlExpression() : SqlsrvQuery
  • splitStream() : AbstractSerializer
  • splitStringByWidth() : Application
  • splitSubPart() : Negotiator
  • sprintf() : Text
  • sqlValue() : PgsqlDriver
  • sqrt() : BCMath , BigDecimal , BigInteger , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator
  • square() : PHP
  • squareReduce() : Base
  • squareRoot() : Integer
  • SRC_FILE : Patcher
  • SSH_AGENT_FAILURE : Agent
  • SSH_AGENT_IDENTITIES_ANSWER : Agent
  • ssh_agent_login() : SSH2
  • SSH_AGENT_RSA2_256 : Identity
  • SSH_AGENT_RSA2_512 : Identity
  • SSH_AGENT_SIGN_RESPONSE : Agent
  • SSH_AGENTC_REQUEST_IDENTITIES : Agent
  • SSH_AGENTC_SIGN_REQUEST : Agent
  • STABILITY_ALPHA : Updater
  • STABILITY_BETA : Updater
  • STABILITY_DEV : Updater
  • STABILITY_RC : Updater
  • STABILITY_STABLE : Updater
  • stabilityTagToInteger() : ExtensionAdapter , Update
  • stackData() : DebugBar
  • STANDARD_OBJECT : FetchMode
  • start() : TracedStatement , Dropdown , JoomlaStorage , IndexerController , Session
  • START : SessionEvents
  • start() : SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , DebugFormatterHelper , ProgressBar , ProgressIndicator , LdapAuthenticator , DumpServer
  • startAccordion() : Bootstrap
  • startElement() : Changelog
  • startMeasure() : TimeDataCollector , ProfileCollector
  • startQuery() : ChainedMonitor , DebugMonitor , LoggingMonitor , QueryMonitorInterface
  • startSSHForwarding() : Agent
  • startSubsystem() : SSH2
  • startsWith() : Assertion , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • startsWithLetter() : Assert
  • startTabSet() : Bootstrap , UiTab
  • startTLS() : SMTP
  • stat() : SFTP
  • stat_helper() : SFTP
  • state() : Grid , JGrid , Manage , Updatesites , Modules
  • STATE_DISABLED : Task
  • STATE_ENABLED : Task
  • STATE_MAP : Task
  • STATE_OR_PROVINCE_NAME : OID
  • STATE_TRASHED : Task
  • statelist() : Finder
  • status() : Messages
  • STATUS_CANCEL : Authentication
  • STATUS_DENIED : Authentication
  • STATUS_EXPIRED : Authentication
  • STATUS_FAILURE : Authentication
  • STATUS_SUCCESS : Authentication
  • STATUS_UNKNOWN : Authentication
  • statusLabel() : Privacy
  • STD_LINE_LENGTH : PHPMailer
  • stem() : Helper , El , Language , Catalan , Danish , Dutch , English , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Stemmer , Swedish , StemmerManager
  • step() : ZIPExtraction
  • step0() : Catalan , English , French , Italian , Romanian , Spanish
  • step1() : Danish , Dutch , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Swedish
  • step1a() : Catalan , English
  • step1b() : Catalan , English
  • step1c() : English
  • step2() : Catalan , Danish , Dutch , English , Finnish , German , Italian , Norwegian , Portuguese , Romanian , Russian , Swedish
  • step2a() : French , Spanish
  • step2b() : French , Spanish
  • step3() : Danish , English , Finnish , French , German , Norwegian , Portuguese , Romanian , Russian , Spanish , Swedish
  • step3a() : Dutch , Italian
  • step3b() : Dutch , Italian
  • step4() : Danish , Dutch , English , Finnish , French , Portuguese , Romanian , Russian
  • step5() : English , Finnish , French , Portuguese
  • step6() : Finnish , French
  • stop() : DaemonApplication , Event , DebugFormatterHelper
  • STOP_CONTINUE : PHPMailer
  • STOP_CRITICAL : PHPMailer
  • STOP_MESSAGE : PHPMailer
  • stopMeasure() : TimeDataCollector , ProfileCollector
  • stopPropagation() : AbstractEvent , EventInterface
  • stopQuery() : ChainedMonitor , DebugMonitor , LoggingMonitor , QueryMonitorInterface
  • stopSubsystem() : SSH2
  • store() : Cache , CacheStorage , CallbackController , OutputController , PageController , ViewController , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , FtpClient , Category , Content , ContentHistory , ContentType , CoreContent , Language , Menu , MenuType , Module , Nested , TableInterface , User , Usergroup , UCMBase , UCMContent , Versioning , ContactTable , FieldTable , GroupTable , FilterTable , LinkTable , NewsfeedTable , ConsentTable , RequestTable , LinkTable , TaskTable , TagTable , StyleTable , MfaTable , NoteTable , StageTable , WorkflowTable , FtpClient
  • store64() : ParagonIE_Sodium_Core32_BLAKE2b
  • storeAfterEventFiles() : PlgInstallerOverride
  • storeBeforeEventFiles() : PlgInstallerOverride
  • storeExtension() : FileAdapter , LanguageAdapter , LibraryAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • storeFileInfo() : TemplateModel
  • storeNode() : Taxonomy
  • storeOptions() : SetupModel
  • storeUcmBase() : CoreContent
  • storeVote() : ArticleModel
  • str2bin() : Base32
  • str_contains() : Php80
  • str_ends_with() : Php80
  • str_ireplace() : StringHelper
  • str_pad() : StringHelper
  • str_split() : StringHelper
  • str_starts_with() : Php80
  • strcasecmp() : StringHelper
  • strcmp() : StringHelper
  • strcspn() : StringHelper
  • stream() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • stream_cast() : PharStreamWrapper
  • stream_close() : PharStreamWrapper
  • stream_eof() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_flush() : StreamString , StringWrapper , PharStreamWrapper
  • stream_isatty() : Php72
  • stream_lock() : PharStreamWrapper
  • stream_metadata() : PharStreamWrapper
  • stream_open() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • STREAM_OPEN_FOR_INCLUDE : PharStreamWrapper
  • stream_read() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_register() : BufferStreamHandler
  • stream_salsa20_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • stream_seek() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_set_option() : PharStreamWrapper
  • stream_stat() : StreamString , StringWrapper , PharStreamWrapper
  • stream_tell() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_truncate() : PharStreamWrapper
  • stream_write() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • streamXorIc() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • STREET_ADDRESS : OID
  • stressMemory() : DemoTasks
  • stressMemoryRemoveLimit() : DemoTasks
  • string() : Assertion , PhpSetting
  • STRING : ParameterType
  • string() : Random , Assert
  • STRING_BINARY : Stub
  • STRING_TYPE_SIZE : ASN1
  • STRING_UTF8 : Stub
  • stringify() : Assertion
  • stringJSSafe() : OutputFilter
  • stringNotEmpty() : Assert
  • stringToContext() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • stringToObject() : Ini , Json , Php , Xml , Yaml , FormatInterface
  • stringToSplFixedArray() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • stringURLSafe() : ApplicationHelper , OutputFilter
  • stringUrlSafe() : OutputFilter
  • stringUrlUnicodeSlug() : OutputFilter
  • stripColors() : ColorProcessor
  • stripCssExpressions() : InputFilter
  • stripExt() : File
  • stripFirstBackslash() : JLoader
  • stripIframes() : OutputFilter
  • stripImages() : OutputFilter
  • stripTrailingWSP() : PHPMailer
  • stripTrailingZeros() : BigDecimal
  • stripUSC() : InputFilter
  • stristr() : StringHelper
  • strlen() : StringHelper , ParagonIE_Sodium_Core_Util , Helper , Assert
  • strlen1() : Iconv
  • strlen2() : Iconv
  • strlenWithoutDecoration() : Helper
  • strpos() : StringHelper
  • strrev() : StringHelper
  • strrpos() : StringHelper
  • strspn() : StringHelper
  • strtolower() : StringHelper
  • strtoupper() : StringHelper
  • style() : CliDumper , HtmlDumper
  • stylesheet() : HTMLHelper
  • sub() : BCMath , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator , ParagonIE_Sodium_Compat
  • subAdd2() : Integer
  • subAdd3() : Integer
  • subArray() : X509
  • subArrayUnchecked() : X509
  • subclassOf() : Assertion , Assert
  • SUBJECT : RegisteredClaims
  • sublayout() : FileLayout
  • sublogin() : SSH2
  • submit() : HttpBridgePostRequestMethod , ContactController , CurlPost , Post , SocketPost , RequestMethod
  • subMultiply() : Integer
  • substr() : StringHelper , ParagonIE_Sodium_Core_Util , Helper
  • substr_replace() : StringHelper
  • subtract() : BigInteger , BigIntegerBcmath , BigIntegerGmp , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • subtractHelper() : PHP
  • SUBTYPES : CronField , IntervalField
  • subWord() : Rijndael
  • SUCCESS : Authentication , Command
  • success() : StyleInterface , SymfonyStyle
  • suggest() : SuggestionsController
  • suggested() : Query
  • suggestOption() : CompletionSuggestions
  • suggestOptions() : CompletionSuggestions
  • suggestValue() : CompletionSuggestions
  • suggestValues() : CompletionSuggestions
  • SUPPORTED_CURVES : Ec2Key , OkpKey
  • supportedAdditionalInformation() : BreakObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , OtherObject , TrueObject , UndefinedObject
  • supportFunctionality() : WorkflowServiceInterface
  • supports() : JWSTokenSupport , LdapAuthenticator
  • supportsAlias() : CronExpression
  • supportsClass() : LdapUserProvider
  • supportsColors() : CliDumper
  • suppressAllModules() : CaptiveModel
  • SURNAME : OID
  • swapFields() : GuidStringCodec
  • swapTimestampAndRandomBits() : TimestampFirstCombCodec
  • SWEDISH_LANGUAGE_CODE : ASCII
  • switchAdminLanguage() : InstalledController , InstalledModel
  • switchDefaultRecord() : MfaTable
  • switchEndianness() : Strings
  • symlink() : SFTP
  • syncPaths() : Form
  • syst() : FtpClient


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- t -

  • t() : Hash
  • T61_STRING : Identifier
  • tab() : Bootstrap
  • table() : StyleInterface , SymfonyStyle
  • tableize() : Inflector
  • tag() : Container
  • TAG_OPTIONS : TableCellStyle
  • TAG_PATTERN : Parser
  • tagDeleteInstances() : TagsHelper
  • tagItem() : TagsHelper
  • tags() : Tag
  • TagServiceTrait : LegacyComponent , BannersComponent , ContactComponent , ContentComponent , NewsfeedsComponent
  • tailDebugLog() : DumpCompletionCommand
  • TARGET_ALL : Attribute
  • TARGET_CLASS : Attribute
  • TARGET_CLASS_CONSTANT : Attribute
  • TARGET_FUNCTION : Attribute
  • TARGET_METHOD : Attribute
  • TARGET_PARAMETER : Attribute
  • TARGET_PROPERTY : Attribute
  • TASK_NOTIFICATION_FORM : PlgSystemTasknotification
  • TASK_QUEUE_FILTERS : Scheduler
  • TASK_QUEUE_LIST_CONFIG : Scheduler
  • TASK_STATES : TaskModel
  • TASK_TABLE : TaskModel
  • TASKS_MAP : Checkfiles , DemoTasks , Requests , SiteStatus
  • tBase : NamePrep
  • tCount : NamePrep
  • tel() : Telephone
  • tell() : Stream , CallbackStream , RelativeStream , Stream , StreamInterface
  • templates() : Modules
  • templateStates() : Modules
  • templatestyle() : Users
  • ten() : BigDecimal , BigInteger , BigRational
  • TERMINATE : ConsoleEvents
  • test() : FormRule , CalendarRule , CaptchaRule , ColorRule , CssIdentifierRule , CssIdentifierSubstringRule , EmailRule , EqualsRule , ExistsRule , FilePathRule , FolderPathExistsRule , NotequalsRule , NumberRule , OptionsRule , PasswordRule , RulesRule , SubformRule , TelRule , TimeRule , UrlRule , UserIdRule , UsernameRule , ContactEmailMessageRule , ContactEmailRule , ContactEmailSubjectRule , ExecutionRulesRule , LoginUniqueFieldRule , LogoutUniqueFieldRule
  • testBit() : BigInteger , BCMath , GMP , PHP , BigInteger
  • TestEncryptDecrypt() : Crypto
  • testEncryptDecrypt() : RuntimeTests
  • testForIntermediate() : X509
  • testGet() : ServiceLocatorTest
  • testGetDoesNotMemoize() : ServiceLocatorTest
  • testHas() : ServiceLocatorTest
  • testPrimality() : Engine , GMP
  • testSmallPrimes() : BCMath , PHP
  • testThrowsOnCircularReference() : ServiceLocatorTest
  • testThrowsOnUndefinedInternalService() : ServiceLocatorTest
  • text() : StyleInterface , SymfonyStyle
  • TEXT_CONTEXT : Indexer
  • textLine() : PHPMailer
  • THAI_LANGUAGE_CODE : ASCII
  • that() : Assert , LazyAssertion
  • thatAll() : Assert
  • thatNullOr() : Assert
  • throwAt() : ErrorHandler
  • throws() : Assert
  • thumb() : Templates
  • thumbModal() : Templates
  • thumbprint() : JWK
  • tI() : RsaKey
  • timeField() : X509
  • TIMELIMIT : ConnectionOptions
  • TIMEOUT : Status , ConnectionOptions
  • timestamp() : CombGenerator
  • TIMESTAMP_BYTES : CombGenerator
  • timezoneSafeModify() : AbstractField
  • timingSafeCompare() : Crypt
  • TITLE : OID
  • title() : ToolbarHelper , StyleInterface , SymfonyStyle , AbstractString , AbstractUnicodeString , ByteString
  • title_case() : Mbstring
  • TITLE_CONTEXT : Indexer
  • TLS_DISABLE : Route
  • TLS_FORCE : Route
  • TLS_IGNORE : Route
  • tMax : AbstractPunycode
  • tMin : AbstractPunycode
  • to64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • to_filename() : ASCII
  • to_slugify() : ASCII
  • toArbitraryBase() : BigInteger , Calculator
  • toArray() : JsonapiDocument , DataSet , Registry , RSAKey , ArraySerializer , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , RequestParameters , Response , SplFixedArray , FlattenException , CollectionInterface , Collection , UpdateOperation , Collection , Document , ElementInterface , Relationship , Resource
  • toAsn1() : ECSignature , MultibyteStringConverter , SignatureConverter
  • toast() : Bootstrap
  • toBase() : BigInteger , GmpCalculator , Calculator
  • toBigDecimal() : BigDecimal , BigInteger , BigNumber , BigRational
  • toBigInteger() : BigDecimal , BigInteger , BigNumber , BigRational , PublicKey , Integer
  • toBigRational() : BigDecimal , BigInteger , BigNumber , BigRational
  • toBin() : Base32
  • toBinary() : Calculator
  • toBits() : Engine , GMP , BigInteger , Integer
  • toBytes() : BigInteger , MediaHelper , BigInteger , BCMath , GMP , PHP , BigInteger , Integer
  • toBytesHelper() : Engine
  • toByteString() : AbstractString
  • toCamelCase() : Normalise
  • toCodePointString() : AbstractString , ByteString
  • toDashSeparated() : Normalise
  • toDecimal() : Calculator
  • toFile() : Image
  • toFlatten() : Registry
  • toFloat() : BigDecimal , BigInteger , BigNumber , BigRational
  • toggleTables() : Indexer
  • toggleUpdateSite() : UpdateAdapter
  • toHex() : Engine , BigInteger , Integer , BigNumberConverter , DegradedNumberConverter , NumberConverterInterface
  • toIdentifier() : Collection , ElementInterface , Resource
  • toInt() : BigDecimal , BigInteger , BigNumber , BigRational , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInt32() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInt64() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInteger() : BigInteger , BigIntegerBcmath , BigIntegerGmp , ArrayHelper
  • toIntOverflow() : IntegerOverflowException
  • toISO8601() : Date
  • token() : Form , Jquery
  • TOKEN_BINDING_STATUS_NOT_SUPPORTED : TokenBinding
  • TOKEN_BINDING_STATUS_PRESENT : TokenBinding
  • TOKEN_BINDING_STATUS_SUPPORTED : TokenBinding
  • tokenise() : El , Language , Zh
  • tokenize() : TraceableTwigEnvironment , Helper , StringInput , PhpToken
  • tokenizeToDb() : Indexer
  • tokenizeToDbShort() : Indexer
  • toKey() : Normalise
  • toLowerCase() : El
  • toObject() : Registry , ArrayHelper
  • toolbar() : HtmlView
  • tooltip() : Bootstrap , HTMLHelper
  • tooltipText() : HTMLHelper
  • toPEM() : RSAKey
  • toPlural() : Inflector
  • toPower() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • toPublic() : Ec2Key , JWK , RSAKey
  • toPunycode() : PunycodeHelper
  • toQuerySet() : DatabaseQuery , QueryInterface
  • toQueryString() : RequestParameters
  • toReverseString() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toRFC822() : Date
  • tos() : PlgUserProfile
  • toScale() : BigDecimal , BigInteger , BigNumber , BigRational
  • toSingular() : Inflector
  • toSpaceSeparated() : Normalise
  • toSql() : Date
  • toString() : CMSApplication , Registry , AbstractUri , UriInterface , ArrayHelper , Serializer , Signature , DataSet , Token , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , AsymmetricKey , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , PrivateKey , PublicKey , BCMath , GMP , PHP , BigInteger , Identity , Uuid , UuidInterface , CommandIsSuccessful , AbstractString
  • total() : UserGroupsHelper
  • touch() : SFTP
  • toUnderscoreSeparated() : Normalise
  • toUnicodeString() : AbstractString , ByteString
  • toUnix() : Date
  • toUpperCase() : El
  • toUri() : Query
  • toUrl() : Client
  • toVariable() : Normalise
  • trace() : Http , Router , RouterInterface
  • traceAt() : ErrorHandler
  • traceUnshift() : ExceptionCaster
  • TRANSACTION_CONFIRMATION_DISPLAY_ANY : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_HARDWARE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_PRIVILEGED_SOFTWARE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_REMOTE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_TEE : MetadataStatement
  • TRANSACTION_STATUS : PgSqlCaster
  • transactionCommit() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transactionRollback() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transactionStart() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transcode() : StringHelper
  • translate() : InstallerModel , UpdateModel , ModulesModel , PluginsModel
  • translateDNProp() : X509
  • translateExtensionName() : UpdateModel
  • translateMethodName() : CaptiveModel
  • translateState() : Adapter
  • TRANSLIT_FROM : AbstractUnicodeString
  • TRANSLIT_TO : AbstractUnicodeString
  • transliterate() : Language
  • trash() : ActionsDropdown , Dropdown , ToolbarHelper
  • treerecurse() : Menu
  • TRIDENT : WebClient
  • triggerDuplicateAliasWarning() : PharInvocationCollection
  • triggerEvent() : EventAwareInterface , Dispatcher
  • triggerManifestScript() : PackageAdapter , InstallerAdapter
  • trim() : StringHelper , PHP , AbstractString , AbstractUnicodeString , ByteString
  • trimEnd() : AbstractString , AbstractUnicodeString , ByteString
  • trimPrefix() : AbstractString , AbstractUnicodeString
  • trimStart() : AbstractString , AbstractUnicodeString , ByteString
  • trimSuffix() : AbstractString , AbstractUnicodeString
  • trimTag() : Parser
  • trimTrailingWhitespace() : Encoding
  • true() : Assertion , Assert
  • truncate() : StringHelper , ArticlesCategoryHelper , SFTP , FormatterHelper , AbstractString
  • truncateComplex() : StringHelper
  • truncateTable() : DatabaseDriver , DatabaseInterface , SqliteDriver
  • tryAll() : LazyAssertion
  • TURKISH : Language
  • TURKISH_LANGUAGE_CODE : ASCII
  • TURKMEN_LANGUAGE_CODE : ASCII
  • turn() : SMTP
  • twosComplement() : Calculator
  • type() : Key
  • TYPE : Key
  • TYPE_ANY : ASN1
  • TYPE_ARGUMENT_VALUE : CompletionInput
  • TYPE_ARRAY : Stub
  • TYPE_ATTCA : AttestationStatement
  • TYPE_BASIC : AttestationStatement
  • TYPE_BIT_STRING : ASN1
  • TYPE_BMP_STRING : ASN1
  • TYPE_BOOLEAN : ASN1
  • TYPE_CHOICE : ASN1
  • TYPE_EC2 : Key
  • TYPE_ECDAA : AttestationStatement
  • TYPE_ENUMERATED : ASN1
  • TYPE_FULL : DownloadSource
  • TYPE_GENERAL_STRING : ASN1
  • TYPE_GENERALIZED_TIME : ASN1
  • TYPE_GRAPHIC_STRING : ASN1
  • TYPE_IA5_STRING : ASN1
  • TYPE_INTEGER : ASN1
  • TYPE_NONE : CompletionInput , AttestationStatement
  • TYPE_NULL : ASN1
  • TYPE_NUMERIC_STRING : ASN1
  • TYPE_OBJECT : Stub
  • TYPE_OBJECT_IDENTIFIER : ASN1
  • TYPE_OCT : Key
  • TYPE_OCTET_STRING : ASN1
  • TYPE_OKP : Key
  • TYPE_OPTION_NAME : CompletionInput
  • TYPE_OPTION_VALUE : CompletionInput
  • TYPE_PATCH : DownloadSource
  • TYPE_PRINTABLE_STRING : ASN1
  • TYPE_REAL : ASN1
  • TYPE_REF : Stub
  • TYPE_RESOURCE : Stub
  • TYPE_RSA : Key
  • TYPE_SELF : AttestationStatement
  • TYPE_SEQUENCE : ASN1
  • TYPE_SET : ASN1
  • TYPE_STRING : Stub
  • TYPE_TELETEX_STRING : ASN1
  • TYPE_UNIVERSAL_STRING : ASN1
  • TYPE_UPGRADE : DownloadSource
  • TYPE_UTC_TIME : ASN1
  • TYPE_UTF8_STRING : ASN1
  • TYPE_VIDEOTEX_STRING : ASN1
  • TYPE_VISIBLE_STRING : ASN1
  • typeCheckResult() : AjaxChallenge , ResultAwareInterface
  • TYPES : Tar
  • types() : Modules
  • typeslist() : Finder
  • typeSupportsCheckout() : AssociationsHelper
  • typeToString() : Assert


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- u -

  • ucfirst() : StringHelper
  • ucs4_ucs4array() : TranscodeUnicode
  • ucs4array_ucs4() : TranscodeUnicode
  • ucs4array_utf7() : TranscodeUnicode
  • ucs4array_utf7imap() : TranscodeUnicode
  • ucs4array_utf8() : TranscodeUnicode
  • ucwords() : Inflector , StringHelper
  • uhash() : Hash
  • UKRAINIAN_LANGUAGE_CODE : ASCII
  • unaccent() : Inflector
  • unarchive() : ActionsDropdown , Dropdown
  • unarchiveList() : ToolbarHelper
  • unbind() : DatabaseQuery , PreparableInterface , LdapClient
  • unDoubling() : Dutch
  • unescapeCharacter() : Unescaper
  • unescapeDoubleQuotedString() : Unescaper
  • unescapeSingleQuotedString() : Unescaper
  • unfeature() : ActionsDropdown
  • unfeatured() : Dropdown
  • unicode_to_utf16() : StringHelper
  • unicode_to_utf8() : StringHelper
  • unicodeLetters() : Assert
  • UNINFLECTED : EnglishInflector , FrenchInflector
  • uninstall() : Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript
  • uninstallEosPlugin() : JoomlaInstallerScript
  • union() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • unionAll() : DatabaseQuery , QueryInterface
  • UNIQUE_BASE_NAME : PharInvocationCollection
  • UNIQUE_INVOCATION : PharInvocationCollection
  • uniqueValues() : Assertion , Assert
  • UNIVERSAL_STRING : Identifier
  • unix2DosTime() : Zip
  • unlink() : PharStreamWrapper
  • unlock() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , TaskTable
  • unlockindex() : MemcachedStorage
  • unlockKey() : KeyProtectedByPassword
  • unlockTables() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • UNNECESSARY : RoundingMode
  • unpack() : InstallerHelper
  • unpackSSH2() : Strings
  • unpad() : ParagonIE_Sodium_Compat , SymmetricKey
  • unpublish() : ActionsDropdown , Dropdown , ToolbarHelper , MessageController
  • unpublishList() : ToolbarHelper
  • unpublishMessage() : MessagesModel
  • unregister() : ClassLoader , HTMLHelper
  • unregisterAlias() : CronExpression
  • unregisterProvider() : ProviderManager
  • unregisterTask() : BaseController
  • unrevoke() : X509
  • unserialiseInstance() : ZIPExtraction
  • unserialize() : BigDecimal , BigInteger , BigRational , Cli , Input , Result , AbstractEvent , Route , Router , CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer , JWSSerializerManager , Uuid
  • unset() : Color
  • UNSET_CLOSURE_FILE_INFO : ReflectionCaster
  • unsetClosureFileInfo() : ReflectionCaster
  • unsetHome() : StyleModel
  • unsetOption() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • unsign() : Builder
  • unTagItem() : TagsHelper
  • untrash() : ActionsDropdown , Dropdown
  • unusedBytesFix() : CertificateToolbox
  • unwrap() : AbstractString
  • UP : RoundingMode
  • update() : Captcha , LanguageAdapter , Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript , UpdateModel , DatabaseQuery , QueryInterface , JoomlaInstallerScript , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , EntryManagerInterface , EntryManager
  • UPDATE_AVAILABLE : AuthenticatorStatus
  • update_stat_cache() : SFTP
  • UPDATE_SUCCESSFUL : UpdateCoreCommand
  • updateAssociations() : Workflow
  • updateBodyFor() : JsonResponse
  • updateContentTypes() : JoomlaInstallerScript
  • updated() : TemplatesModel
  • updateDatabase() : JoomlaInstallerScript
  • updateDatabaseMysql() : JoomlaInstallerScript
  • updateFile() : AdapterInterface , ApiModel , LocalAdapter
  • updateJoomlaCore() : UpdateCoreCommand
  • updateLastCheckTimestamp() : Updater
  • updateLogHistory() : SSH2
  • updateManifestCaches() : JoomlaInstallerScript
  • updateObject() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • updatePeakUsage() : MemoryCollector
  • updateRepr() : ParseException
  • updateSessionRecord() : MetadataManager
  • updateSize() : CacheStorageHelper
  • updateTemplate() : MailTemplate
  • updateUserIds() : ConfigurationModel
  • upgradePassword() : LdapUserProvider
  • upload() : File , Stream , UpdateModel , File , Stream
  • UPLOAD_ERR_INI_SIZE : UploadedFile
  • uploadFile() : TemplateController , TemplateModel
  • upper() : AbstractString , AbstractUnicodeString , ByteString , Assert
  • UPPER_FROM : AbstractUnicodeString
  • UPPER_TO : AbstractUnicodeString
  • url() : Assertion
  • URL : Version
  • url() : PlgUserProfile
  • url_stat() : StreamString , StringWrapper , PharStreamWrapper
  • urlEncodeChar() : Uri
  • urlize() : Inflector
  • urlToPunycode() : PunycodeHelper
  • urlToUTF8() : PunycodeHelper
  • use_fallback() : ParagonIE_Sodium_Compat
  • useAsset() : WebAssetManager , WebAssetManagerInterface
  • useBestEngine() : AsymmetricKey
  • useHtmlVarDumper() : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • useInternalEngine() : AsymmetricKey
  • useNewSodiumAPI() : ParagonIE_Sodium_Compat
  • usePresetItems() : WebAssetManager
  • USER : UriInterface
  • USER_KEY_PHYSICAL_COMPROMISE : AuthenticatorStatus
  • USER_KEY_REMOTE_COMPROMISE : AuthenticatorStatus
  • USER_VERIFICATION_BYPASS : AuthenticatorStatus
  • USER_VERIFICATION_REQUIREMENT_DISCOURAGED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFICATION_REQUIREMENT_PREFERRED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFICATION_REQUIREMENT_REQUIRED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFY_ALL : VerificationMethodDescriptor
  • USER_VERIFY_EYEPRINT : VerificationMethodDescriptor
  • USER_VERIFY_FACEPRINT : VerificationMethodDescriptor
  • USER_VERIFY_FINGERPRINT : VerificationMethodDescriptor
  • USER_VERIFY_HANDPRINT : VerificationMethodDescriptor
  • USER_VERIFY_LOCATION : VerificationMethodDescriptor
  • USER_VERIFY_NONE : VerificationMethodDescriptor
  • USER_VERIFY_PASSCODE : VerificationMethodDescriptor
  • USER_VERIFY_PATTERN : VerificationMethodDescriptor
  • USER_VERIFY_PRESENCE : VerificationMethodDescriptor
  • USER_VERIFY_VOICEPRINT : VerificationMethodDescriptor
  • usergroup() : Access
  • usergroups() : Access
  • userId() : ContactSerializer
  • userlist() : User
  • users() : ListHelper
  • useSendmail() : Mail
  • usesIV() : StreamCipher , SymmetricKey
  • useSmtp() : Mail
  • usesNonce() : SymmetricKey , Salsa20
  • useThreshold() : Sanitizer
  • UTC_TIME : Identifier
  • utf7_ucs4array() : TranscodeUnicode
  • utf7imap_ucs4array() : TranscodeUnicode
  • utf8_decode() : Php72
  • utf8_encode() : Php72
  • utf8_latin_to_ascii() : Transliterate
  • UTF8_STRING : Identifier
  • utf8_ucs4array() : TranscodeUnicode
  • utf8CharBoundary() : PHPMailer
  • utf8chr() : Unescaper
  • utf8Encode() : AbstractDumper
  • utf8ToUtf8() : Iconv
  • uuid() : Assertion , UuidFactory , Assert
  • uuid1() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid3() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid4() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid5() : Uuid , UuidFactory , UuidFactoryInterface
  • UUID_TYPE_HASH_MD5 : Uuid
  • UUID_TYPE_HASH_SHA1 : Uuid
  • UUID_TYPE_IDENTIFIER : Uuid
  • UUID_TYPE_RANDOM : Uuid
  • UUID_TYPE_TIME : Uuid
  • uuidFromHashedName() : UuidFactory
  • uuidFromNsAndName() : UuidFactory
  • UZBEK_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- v -

  • valid() : Construct , DataSet , DatabaseIterator , StringHelper , SplFixedArray
  • VALID_OPERATION_TYPES : UpdateOperation
  • VALID_PATTERN : Uuid
  • validArrayKey() : Assert
  • validate() : FromPunycode , AbstractField , DayOfMonthField , DayOfWeekField , FieldInterface , TemplateParser , Form , FormField , SetupModel , FormModel , CategoryModel , FormModel , ArticleModel , FieldModel , GroupModel , TemplateModel , AbstractMediaItemValidationEvent , MenuModel , ModuleModel , RequestModel , LevelModel , Session , AddressValidator , ForwardedValidator , ValidatorInterface , EqualsTo , GreaterOrEqualsTo , LesserOrEqualsTo , Validatable , Token , Validator , Input , InputInterface , LintCommand
  • VALIDATE_SIGNATURE_BY_CA : X509
  • validateActive() : UploadedFile
  • validateAddress() : PHPMailer
  • validateAgainstRecord() : Yubikey
  • validateAssertionResponse() : Authentication
  • validateAttempts() : QuestionHelper
  • validateCaFile() : CaBundle
  • validateCategoryId() : CategoriesHelper
  • validateConnectionParameters() : DatabaseHelper
  • validateDate() : TemplateModel , X509
  • validateDbConnection() : SetupModel , ApplicationModel
  • validateEncoding() : PHPMailer
  • validateEntry() : DisplayController
  • validateField() : ExecutionRulesRule
  • validateKey() : OpenSSL
  • validateName() : Command
  • validateOptions() : SetConfigurationCommand
  • validatePassword() : Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler
  • validatePayload() : AndroidSafetyNetAttestationStatementSupport
  • validatePlugin() : AsymmetricKey
  • validateResponse() : Client
  • validateRowNumber() : DatabaseQuery
  • validateSection() : LegacyComponent , FieldsServiceInterface , ContactComponent , ContentComponent , UsersComponent , UsersHelper
  • validateSignature() : X509 , AndroidSafetyNetAttestationStatementSupport
  • validateSignatureCountable() : X509
  • validateSignatureHelper() : X509
  • validateUploadedFiles() : ServerRequest
  • validateURL() : X509
  • validateUsingGoogleApi() : AndroidSafetyNetAttestationStatementSupport
  • validateYubikeyOtp() : Yubikey
  • VALIDATION_FUNCTIONS : OptionsResolver
  • validationConstraints() : Configuration
  • validator() : Configuration
  • validComponent() : FileLayout
  • value() : Configuration , Users
  • VALUE : PHP
  • value() : AuthenticationExtension
  • VALUE_EMPTY : Assertion
  • VALUE_IS_ARRAY : InputOption
  • VALUE_NEGATABLE : InputOption
  • VALUE_NONE : InputOption
  • VALUE_NOT_EMPTY : Assertion
  • VALUE_NOT_NULL : Assertion
  • VALUE_NULL : Assertion
  • VALUE_OPTIONAL : InputOption
  • VALUE_REQUIRED : InputOption
  • values() : DatabaseQuery , QueryInterface
  • valueToString() : Assert
  • valueWithMinScale() : BigDecimal
  • VARIABLE : Base , Barrett , Base
  • vBase : NamePrep
  • vCount : NamePrep
  • VERBOSITY_DEBUG : OutputInterface
  • VERBOSITY_NORMAL : OutputInterface
  • VERBOSITY_QUIET : OutputInterface
  • VERBOSITY_VERBOSE : OutputInterface
  • VERBOSITY_VERY_VERBOSE : OutputInterface
  • verificationKey() : Configuration
  • verify() : Hmac , Mac , ECDSA , ES256 , ES256K , ES384 , ES512 , ED256 , ED512 , EdDSA , PSSRSA , RSA , Signature , ECDSA , EdDSA , HMAC , MacAlgorithm , None , RSA , RSAPKCS1 , RSAPSS , SignatureAlgorithm , RSA , Signature , BaseSigner , Signer , Token , SMTP , PublicKey , ReCaptcha
  • verify_16() : ParagonIE_Sodium_Core_Util
  • verify_32() : ParagonIE_Sodium_Core_Util
  • verifyAttestation() : Credentials
  • verifyCredentials() : Client
  • verifyEMSAPSS() : PSSRSA , RSA
  • VerifyHMAC() : Crypto
  • verifyHMAC() : Crypto
  • verifyNow() : LazyAssertion
  • verifyPassword() : AbstractUsernamePasswordAuthenticationStrategy
  • verifyPoint() : Binary , KoblitzPrime , Prime , TwistedEdwards
  • verifySignature() : JWSVerifier
  • verifyTypes() : OptionsResolver
  • verifyWithKey() : JWSVerifier
  • verifyWithKeySet() : JWSVerifier
  • verifyWithPKCS15() : RSA
  • verifyWithPSS() : RSA
  • version() : Assertion
  • VERSION : PHPMailer , POP3 , SMTP , ReCaptcha
  • VERSION_STRING : ParagonIE_Sodium_Compat
  • version_string() : ParagonIE_Sodium_Compat
  • VIDEOTEXT_STRING : Identifier
  • VIETNAMESE_LANGUAGE_CODE : ASCII
  • violations() : RequiredConstraintsViolated
  • visibility() : Menus
  • VISIBLE_STRING : Identifier
  • vote() : ArticleController


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- w -

  • walk() : DataSet
  • warning() : PropelCollector
  • WARNING : Log
  • warning() : AbstractLogger , LoggerInterface
  • WARNING : LogLevel
  • warning() : GithubActionReporter , StyleInterface , SymfonyStyle
  • watermark() : Image
  • wcswidth() : AbstractUnicodeString
  • WEBCRON_KEY_LENGTH : PlgSystemSchedulerunner
  • WEBKIT : WebClient
  • WEEKDAY : CronExpression
  • where() : DatabaseQuery , QueryInterface
  • whereIn() : DatabaseQuery , QueryInterface
  • whereNotIn() : DatabaseQuery , QueryInterface
  • width() : Helper , AbstractString , AbstractUnicodeString , ByteString
  • wildcardIfMatch() : TaskModel
  • WILL_RESUME : Status
  • WINDOWS : WebClient
  • WINDOWS_CE : WebClient
  • WINDOWS_PHONE : WebClient
  • with() : JWKSet , Builder , Collection , ElementInterface , Resource
  • withAddedHeader() : MessageInterface
  • withAssertion() : Behavior
  • withAttribute() : ServerRequest , ServerRequestInterface , EvolvableLinkInterface , Link
  • withBody() : MessageInterface
  • withClaim() : Builder
  • withContext() : EC , Data
  • withCookieParams() : ServerRequest , ServerRequestInterface
  • withData() : DatabaseExporter
  • withEncodingOptions() : JsonResponse
  • withFragment() : Uri , UriInterface
  • withHash() : AsymmetricKey , DH , EC , RSA , Identity
  • withHeader() : Builder , MessageInterface
  • withHeaders() : EmptyResponse
  • withHost() : Uri , UriInterface
  • withHref() : EvolvableLinkInterface , Link
  • withLabel() : RSA
  • withLink() : EvolvableLinkProviderInterface , GenericLinkProvider
  • withMaxDepth() : Data
  • withMaxItemsPerDepth() : Data
  • withMethod() : RequestInterface
  • withMGFHash() : RSA
  • without() : JWKSet
  • withoutAttribute() : ServerRequest , ServerRequestInterface , EvolvableLinkInterface , Link
  • withoutHeader() : MessageInterface
  • withoutLink() : EvolvableLinkProviderInterface , GenericLinkProvider
  • withoutRel() : EvolvableLinkInterface , Link
  • withPadding() : RSA , Identity
  • withParsedBody() : ServerRequest , ServerRequestInterface
  • withPassword() : PrivateKey , Identity
  • withPath() : Uri , UriInterface
  • withPayload() : JWSBuilder , JsonResponse
  • withPluralRules() : GenericLanguageInflectorFactory , LanguageInflectorFactory
  • withPointMovedLeft() : BigDecimal
  • withPointMovedRight() : BigDecimal
  • withPort() : Uri , UriInterface
  • withProtocolVersion() : MessageInterface
  • withPublicKey() : Identity
  • withPublicKeyBlob() : Identity
  • withQuery() : Uri , UriInterface
  • withQueryParams() : ServerRequest , ServerRequestInterface
  • withRefHandles() : Data
  • withRel() : EvolvableLinkInterface , Link
  • withRequestTarget() : RequestInterface
  • withSaltLength() : RSA
  • withScheme() : Uri , UriInterface
  • withSignatureFormat() : DSA , EC , Identity
  • withSingularRules() : GenericLanguageInflectorFactory , LanguageInflectorFactory
  • withStatus() : Response , ResponseInterface
  • withStructure() : DatabaseExporter , DatabaseImporter
  • withUploadedFiles() : ServerRequest , ServerRequestInterface
  • withUri() : RequestInterface
  • withUserInfo() : Uri , UriInterface
  • wordwrap() : AbstractString
  • workaroundIPIssues() : IpHelper
  • workflowAfterSave() : WorkflowModelInterface
  • workflowBeforeSave() : WorkflowModelInterface
  • workflowBeforeStageChange() : WorkflowModelInterface
  • workflowCleanupBatchMove() : WorkflowModelInterface
  • workflowPreprocessForm() : WorkflowModelInterface
  • wrap() : AbstractString
  • wrapCallable() : ClassStub
  • wrapCallback() : ProcessHelper
  • wrapPrivateKey() : OpenSSH , PKCS1 , PKCS8 , PuTTY
  • wrapPublicKey() : PKCS1 , PKCS8 , PuTTY
  • wrapText() : PHPMailer
  • writable() : Directory , Assert
  • write() : MonologCollector , SlimCollector , FtpClient , File , Stream , FtpClient , File , Stream , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , CallbackStream , RelativeStream , Stream , SSH2 , StreamInterface , BashCompletionOutput , CompletionOutputInterface , Descriptor , MarkdownDescriptor , NullOutput , Output , OutputInterface , OutputStyle , SymfonyStyle , Connection
  • writeable() : Assertion
  • writeBuffer() : SymfonyStyle
  • writeConfigFile() : ApplicationModel , SiteStatus
  • writeData() : JsonDescriptor
  • writeDocument() : XmlDescriptor
  • writeError() : QuestionHelper , SymfonyQuestionHelper
  • writeFile() : Stream , UploadedFile
  • writeln() : NullOutput , Output , OutputInterface , OutputStyle , SymfonyStyle
  • writeNamespaceFile() : JNamespacePsr4Map
  • writeProcessIdFile() : DaemonApplication
  • writePrompt() : QuestionHelper , SymfonyQuestionHelper
  • writeText() : TextDescriptor


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- x -

  • x() : Ec2Key , OkpKey
  • X_KEEPALIVE_IDLE : ConnectionOptions
  • X_KEEPALIVE_INTERVAL : ConnectionOptions
  • X_KEEPALIVE_PROBES : ConnectionOptions
  • X_SASL_AUTHCID : ConnectionOptions
  • X_SASL_AUTHZID : ConnectionOptions
  • X_SASL_MECH : ConnectionOptions
  • X_SASL_REALM : ConnectionOptions
  • X_TLS_CACERTDIR : ConnectionOptions
  • X_TLS_CERTFILE : ConnectionOptions
  • X_TLS_CIPHER_SUITE : ConnectionOptions
  • X_TLS_CRL_ALL : ConnectionOptions
  • X_TLS_CRL_NONE : ConnectionOptions
  • X_TLS_CRL_PEER : ConnectionOptions
  • X_TLS_CRLCHECK : ConnectionOptions
  • X_TLS_CRLFILE : ConnectionOptions
  • X_TLS_DHFILE : ConnectionOptions
  • X_TLS_KEYFILE : ConnectionOptions
  • X_TLS_PACKAGE : ConnectionOptions
  • X_TLS_PROTOCOL_MIN : ConnectionOptions
  • X_TLS_RANDOM_FILE : ConnectionOptions
  • X_TLS_REQUIRE_CERT : ConnectionOptions
  • xD0 : Iconv , Normalizer
  • xdebuglink() : Debug
  • XML_ATTRIBUTE_NODE : DOMCaster
  • XML_ERROR_NO_MEMORY : XmlResourceCaster
  • XML_ERRORS : XmlResourceCaster
  • xmlToCreate() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • xor() : BigInteger , GmpCalculator , Calculator
  • xor64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • xorInt32() : ParagonIE_Sodium_Core32_Int32
  • xorInt64() : ParagonIE_Sodium_Core32_Int64
  • xorNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • xorStrings() : ParagonIE_Sodium_Core_Util
  • xsalsa20() : ParagonIE_Sodium_Core32_XSalsa20 , ParagonIE_Sodium_Core_XSalsa20
  • xsalsa20_xor() : ParagonIE_Sodium_Core32_XSalsa20 , ParagonIE_Sodium_Core_XSalsa20


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- y -

  • y() : Ec2Key
  • YEAR : CronExpression
  • year() : DatabaseQuery , QueryInterface


Joomla CMS: Champs de donnée

Liste de tous les champs de structure et d'union avec des liens vers les structures/unions auxquelles ils appartiennent :

- z -

  • zero() : BigDecimal , BigInteger , BigRational


Joomla CMS: Champs de donnée - Fonctions

- _ -

  • _() : HTMLHelper , Language , Text , Route
  • __call() : AssertionChain , LazyAssertion , TraceableTwigEnvironment , TraceableTwigTemplate , TraceablePDO , CacheController , LegacyInstallerScript , Toolbar , ToolbarButton , WebAssetManager , DataSet , Input , Stream
  • __callStatic() : Assertion , BCMath , Assert
  • __clone() : BigInteger , BigIntegerBcmath , BigIntegerGmp , DatabaseQuery , QueryElement , Registry , Uri , BigInteger , OutputFormatter , AbstractString , UnicodeString
  • __construct() : NamePrep , AbstractPunycode , FromPunycode , PunycodeInterface , ToPunycode , ToIdn , ToUnicode , AssertionChain , InvalidArgumentException , LazyAssertionException , Attribute , BigDecimal , BigInteger , BigRational , NativeCalculator , RoundingMode , AbstractCBORObject , ByteStringObject , ByteStringWithChunkObject , Decoder , InfiniteListObject , InfiniteMapObject , ListObject , MapItem , MapObject , OtherObject , BreakObject , FalseObject , NullObject , TrueObject , UndefinedObject , SignedIntegerObject , StringStream , BigFloatTag , DecimalFractionTag , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , ClassLoader , ECDSA , Ec2Key , Key , OkpKey , RsaKey , SymmetricKey , AbstractField , CronExpression , DayOfWeekField , CryptoExceptionHandler , CacheCacheCollector , DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SlimCollector , SwiftLogCollector , SwiftMailCollector , TimeableTwigExtensionProfiler , TraceableTwigEnvironment , TraceableTwigTemplate , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , MessagesCollector , PDOCollector , TraceablePDO , TraceablePDOStatement , TracedStatement , TimeDataCollector , DataFormatter , JavascriptRenderer , OpenHandler , StandardDebugBar , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , DerivedKeys , Key , KeyOrPassword , KeyProtectedByPassword , CachedWordInflector , GenericLanguageInflectorFactory , Inflector , Language , Pattern , Patterns , Ruleset , Substitution , Substitutions , Transformation , Transformations , Word , RulesetInflector , XPath , Resolver , Subject , Usage , NestingException , Sanitizer , AbstractString , AbstractTime , AttributeTypeAndValue , RDNString , RelativeDistinguishedName , Construct , ParserException , ExplicitlyTaggedObject , BitString , BMPString , Boolean , CharacterString , GeneralizedTime , GeneralString , GraphicString , IA5String , Integer , NumericString , ObjectDescriptor , ObjectIdentifier , OctetString , PrintableString , RelativeObjectIdentifier , T61String , UniversalString , UTF8String , VisibleString , UnknownConstructedObject , UnknownObject , BigInteger , AlgorithmIdentifier , CertificateExtensions , CertificateSubject , CSR , PrivateKey , PublicKey , DNSName , IPAddress , SubjectAlternativeNames , GenericLinkProvider , Link , AbstractApplication , AbstractWebApplication , ContainerControllerResolver , ApplicationErrorEvent , ApplicationEvent , WebClient , WebApplication , Archive , Bzip2 , UnsupportedArchiveException , Gzip , Tar , Zip , AbstractUsernamePasswordAuthenticationStrategy , DatabaseStrategy , LocalStrategy , Rule , Rules , Adapter , AdapterInstance , AdministratorApplication , ApiApplication , BaseApplication , CliOutput , ColorStyle , ColorProcessor , CliApplication , CMSApplication , ConsoleApplication , DaemonApplication , SiteApplication , WebApplication , Authentication , ClassLoader , ActionButton , TransitionButton , Cache , CacheController , CacheStorage , CacheStorageHelper , FileStorage , MemcachedStorage , RedisStorage , Captcha , HttpBridgePostRequestMethod , Categories , CategoryFactory , CategoryNode , FtpClient , ComponentRecord , MissingComponentException , RouterBase , RouterFactory , RouterLegacy , RouterViewConfiguration , MenuRules , NomenuRules , StandardRules , AddUserCommand , AddUserToGroupCommand , DeleteUserCommand , ExtensionDiscoverInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , ListUserCommand , WritableContainerLoader , RemoveUserFromGroupCommand , SessionMetadataGcCommand , UpdateCoreCommand , Date , AbstractModuleDispatcher , ComponentDispatcher , ComponentDispatcherFactory , Dispatcher , LegacyComponentDispatcher , ModuleDispatcherFactory , Document , DocumentRenderer , ErrorDocument , FeedDocument , HtmlDocument , ImageDocument , JsonapiDocument , JsonDocument , OpensearchDocument , PreloadManager , RawDocument , XmlDocument , Editor , Aes , OpenSSL , Totp , Browser , AbstractEvent , AbstractImmutableEvent , BeforeBatchEvent , BeforeDisplayMethods , Callback , Captive , GetMethod , GetSetup , NotifyActionLog , SaveSetup , Validate , AjaxInitCreate , GetIconEvent , AbstractEvent , AfterDeleteEvent , AfterLoadEvent , AfterMoveEvent , AfterReorderEvent , AfterStoreEvent , BeforeBindEvent , BeforeCheckinEvent , BeforeCheckoutEvent , BeforeDeleteEvent , BeforeLoadEvent , BeforeMoveEvent , BeforePublishEvent , BeforeReorderEvent , BeforeStoreEvent , SetNewTagsEvent , DisplayEvent , AbstractEvent , WebAssetRegistryAssetChanged , AbstractEvent , WorkflowFunctionalityUsedEvent , WorkflowTransitionEvent , Component , LegacyComponent , Module , CategoryFactory , ComponentDispatcherFactory , HelperFactory , ModuleDispatcherFactory , MVCFactory , RouterFactory , FeedLink , FeedParser , FeedPerson , Patcher , Stream , InputFilter , LastvisitdaterangeField , RegistrationdaterangeField , TagField , UseractiveField , Form , FormField , HelperFactory , UserGroupsHelper , Http , Image , ImageFilter , Cli , Cookie , Files , Input , Json , InstallationApplication , InstallationController , BaseInstallationModel , LanguagesModel , JsonResponse , Installer , InstallerAdapter , InstallerExtension , LegacyInstallerScript , Manifest , Language , FileLayout , DelegatingPsrLogger , Log , LogEntry , Logger , CallbackLogger , DatabaseLogger , EchoLogger , FormattedtextLogger , InMemoryLogger , SyslogLogger , W3cLogger , MailDisabledException , MailTemplate , AbstractMenu , MenuItem , SiteMenu , Microdata , AdminController , ApiController , BaseController , FormController , MVCFactory , AdminModel , BaseDatabaseModel , BaseModel , FormModel , ListModel , AbstractView , OnGetApiFields , FormView , HtmlView , JsonApiView , JsonView , ListView , CMSObject , Pagination , PaginationObject , SitePathway , CMSPlugin , Profiler , JsonResponse , ApiRouter , RouteNotFoundException , SiteRouter , ChangeItem , ChangeSet , OnGetApiAttributes , OnGetApiRelation , JoomlaSerializer , MetadataManagerListener , MetadataManager , Session , SessionManager , JoomlaStorage , Asset , Category , Content , ContentHistory , ContentType , CoreContent , Extension , Language , Menu , MenuType , Module , Table , Ucm , Update , UpdateSite , User , Usergroup , ViewLevel , Toolbar , ToolbarButton , UCMBase , UCMContent , UCMType , Updater , User , UserFactory , LangActiveAssetItem , WebAssetItem , WebAssetManager , WebAssetRegistry , Workflow , ActionlogsController , LogsdaterangeField , ActionlogsModel , AssociationsModel , BannersController , BannersModel , ClientsModel , TracksModel , BannerTable , ClientTable , Category , CacheModel , CategoryController , DisplayController , CategoriesModel , CategoryModel , CheckinModel , ApplicationController , ComponentController , ConfigController , ModulesController , TemplatesController , Router , ContactsController , ContactsModel , Icon , ContactTable , JsonapiView , DisplayController , CategoryModel , FeaturedModel , Category , Router , ArticleController , ArticlesController , FeatureEvent , ArticleModel , ArticlesModel , FeaturedModel , FeaturedTable , JsonapiView , DisplayController , ArticlesModel , CategoryModel , Category , Router , HistoryModel , DisplayController , FieldController , GroupController , FieldModel , FieldsModel , GroupsModel , FieldTable , GroupTable , DisplayController , Adapter , Indexer , Language , El , Zh , Query , Result , Token , FiltersModel , IndexModel , MapsModel , SearchesModel , Response , FilterTable , LinkTable , MapTable , Router , ManageController , UpdatesitesController , DatabaseModel , DiscoverModel , InstallerModel , LanguagesModel , ManageModel , UpdateModel , UpdatesitesModel , UpdatesiteTable , HtmlView , InstalledModel , LanguageModel , LanguagesModel , OverridesModel , TemplateController , TemplatesModel , TemplateTable , FetchMediaItemEvent , FetchMediaItemsEvent , FetchMediaItemUrlEvent , MediaModel , MediumModel , ItemsController , ItemsModel , MenusModel , MessagesModel , MessageTable , ModuleModel , ModulesModel , PositionsModel , DisplayController , NewsfeedsModel , NewsfeedTable , JsonapiView , CategoryModel , Category , Router , PluginModel , PluginsModel , ConsentsModel , RequestsModel , ConsentTable , RequestTable , Router , LinksModel , LinkTable , ExecuteTaskEvent , ExecRuleHelper , SelectModel , TaskModel , TasksModel , TaskTable , Task , TaskOption , HtmlView , TagsModel , TagTable , TagModel , Router , TemplateController , StyleModel , StylesModel , TemplatesModel , StyleTable , CallbackController , CaptiveController , MethodController , MethodsController , UsersController , DataShapeObject , DebuggroupModel , DebuguserModel , GroupModel , GroupsModel , LevelsModel , NotesModel , UserModel , UsersModel , Encrypt , MfaTable , NoteTable , ProfileModel , RegistrationModel , Router , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , StagesModel , TransitionsModel , WorkflowsModel , StageTable , TransitionTable , WorkflowTable , Application , AbstractCommand , ApplicationDescription , ApplicationErrorEvent , BeforeCommandExecuteEvent , CommandErrorEvent , ConsoleEvent , TerminateEvent , ContainerLoader , OpenSSL , Crypt , InvalidKeyTypeException , UnsupportedCipherException , Key , DataObject , DataSet , ExportCommand , ImportCommand , DatabaseDriver , DatabaseEvents , DatabaseExporter , DatabaseImporter , DatabaseIterator , DatabaseQuery , ConnectionEvent , ConnectionFailureException , ExecutionFailureException , PrepareStatementFailureException , FetchMode , FetchOrientation , MysqlDriver , MysqliDriver , MysqliStatement , ParameterType , PdoDriver , PdoStatement , PgsqlDriver , QueryElement , SqlsrvStatement , Container , ContainerResource , AbstractEvent , DebugEventDispatcherCommand , EventImmutable , LazyServiceEventListener , Priority , FtpClient , FilesystemException , Patcher , Stream , InputFilter , AbstractTransport , UnexpectedResponseException , Http , Cookie , Files , Input , Json , LdapClient , CssMenu , Client , Joomla , Basic , Token , Versionable , LocalAdapter , CredentialRepository , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , Joomlaupdate , Cache , AbstractDataCollector , InfoCollector , ProfileCollector , QueryCollector , JavascriptRenderer , JoomlaHttpDriver , Authentication , CredentialRepository , Webauthn , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , Checkfiles , Requests , SiteStatus , Yaml , Registry , DebugRouterCommand , MethodNotAllowedException , ResolvedRoute , Route , Router , CreateSessionTableCommand , ApcuHandler , DatabaseHandler , FilesystemHandler , MemcachedHandler , RedisHandler , WincacheHandler , Session , SessionEvent , SessionEvents , SessionState , NativeStorage , AddressValidator , ForwardedValidator , AbstractUri , UriImmutable , ArrayHelper , IpHelper , AlgorithmManager , JWK , JWKSet , BigInteger , Hash , RSAKey , ECDSA , EdDSA , JWS , JWSBuilder , JWSBuilderFactory , JWSLoader , JWSLoaderFactory , JWSVerifier , JWSVerifierFactory , JWSSerializerManager , Signature , CallbackStream , InvalidStreamPointerPositionException , UploadedFileAlreadyMovedException , HeaderSecurity , PhpInputStream , RelativeStream , Request , Response , EmptyResponse , HtmlResponse , JsonResponse , RedirectResponse , TextResponse , XmlResponse , ServerRequest , Stream , UploadedFile , Uri , ConfigPostProcessor , Replacements , Builder , Basic , Factory , Configuration , Parser , Signature , Ecdsa , Key , Token , DataSet , IdentifiedBy , IssuedBy , PermittedFor , RelatedTo , SignedWith , ValidAt , ValidationData , Accept , AcceptLanguage , AcceptMatch , BaseAccept , Request , Response , ServerRequest , Stream , UploadedFile , Uri , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_ChaCha20_IetfCtx , ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_ChaCha20_IetfCtx , ParagonIE_Sodium_Core_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core_Poly1305_State , ParagonIE_Sodium_Core_SecretStream_State , PasswordHash , OAuth , PHPMailer , Blowfish , AsymmetricKey , StreamCipher , SymmetricKey , DES , DSA , EC , brainpoolP160r1 , brainpoolP160t1 , brainpoolP192r1 , brainpoolP192t1 , brainpoolP224r1 , brainpoolP224t1 , brainpoolP256r1 , brainpoolP256t1 , brainpoolP320r1 , brainpoolP320t1 , brainpoolP384r1 , brainpoolP384t1 , brainpoolP512r1 , brainpoolP512t1 , Curve25519 , Curve448 , Ed25519 , Ed448 , prime192v2 , prime192v3 , prime239v1 , prime239v2 , prime239v3 , secp112r1 , secp112r2 , secp128r1 , secp128r2 , secp160k1 , secp160r1 , secp160r2 , secp192k1 , secp192r1 , secp224k1 , secp224r1 , secp256k1 , secp256r1 , secp384r1 , secp521r1 , sect113r1 , sect113r2 , sect131r1 , sect131r2 , sect163k1 , sect163r1 , sect163r2 , sect193r1 , sect193r2 , sect233k1 , sect233r1 , sect239k1 , sect283k1 , sect283r1 , sect409k1 , sect409r1 , sect571k1 , sect571r1 , Hash , RC2 , Rijndael , RSA , TripleDES , Twofish , ANSI , Element , X509 , BigInteger , BCMath , Engine , GMP , PHP , BinaryField , Integer , PrimeField , Integer , SFTP , Stream , Agent , Identity , PlgContentVote , PlgExtensionNamespacemap , PlgSystemActionLogs , PlgSystemHttpHeaders , PlgSystemLanguageFilter , PlgSystemLogout , DefaultUuidBuilder , DegradedUuidBuilder , StringCodec , FeatureSet , CombGenerator , DefaultTimeGenerator , RandomLibAdapter , TimeGeneratorFactory , FallbackNodeProvider , FixedTimeProvider , Uuid , UuidFactory , ReCaptcha , CurlPost , Post , SocketPost , RequestParameters , Response , SplFixedArray , Application , AsCommand , GithubActionReporter , Color , Command , CompleteCommand , LazyCommand , ContainerCommandLoader , FactoryCommandLoader , Suggestion , Cursor , AddConsoleCommandPass , ApplicationDescription , ConsoleErrorEvent , ConsoleEvent , ConsoleSignalEvent , ConsoleTerminateEvent , ErrorListener , CommandNotFoundException , OutputFormatter , OutputFormatterStyle , OutputFormatterStyleStack , DescriptorHelper , Dumper , HelperSet , ProgressBar , ProgressIndicator , Table , TableCell , TableCellStyle , TableRows , TableSeparator , ArgvInput , ArrayInput , Input , InputArgument , InputDefinition , InputOption , StringInput , ConsoleLogger , ConsoleOutput , ConsoleSectionOutput , Output , StreamOutput , TrimmedBufferOutput , ChoiceQuestion , ConfirmationQuestion , Question , SignalRegistry , OutputStyle , SymfonyStyle , ApplicationTester , CommandCompletionTester , CommandTester , DebugClassLoader , ClassNotFoundError , FatalError , UndefinedFunctionError , UndefinedMethodError , ErrorHandler , HtmlErrorRenderer , SerializerErrorRenderer , SilencedErrorContext , AbstractConnection , AbstractQuery , Adapter , Collection , EntryManager , Query , UpdateOperation , Entry , Ldap , CheckLdapCredentialsListener , LdapAuthenticator , LdapBadge , LdapUser , LdapUserProvider , OptionConfigurator , AbstractString , ByteString , CodePointString , LazyString , AsciiSlugger , UnicodeString , ArgsStub , ClassStub , ConstStub , CutArrayStub , CutStub , DsPairStub , EnumStub , FrameStub , ImgStub , LinkStub , TraceStub , AbstractCloner , Data , CliDescriptor , HtmlDescriptor , ServerDumpCommand , AbstractDumper , CliDumper , RequestContextProvider , SourceContextProvider , ContextualizedDumper , HtmlDumper , ServerDumper , ThrowingCasterException , Connection , DumpServer , AddLinkHeaderListener , GenericLinkProvider , Link , LintCommand , Dumper , ParseException , TaggedValue , SubscribedService , PhpToken , Collection , Document , FallbackExceptionHandler , ResponseBag , InvalidParameterException , Parameters , Relationship , Resource , ConjunctionInterceptor , Manager , Container , Manifest , Reader , PharInvocation , StemmerManager , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationObject , AttestationObjectLoader , AttestationStatement , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AttestedCredentialData , AuthenticationExtension , ExtensionOutputError , AuthenticatorAssertionResponse , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponse , AuthenticatorAttestationResponseValidator , AuthenticatorData , AuthenticatorResponse , AuthenticatorSelectionCriteria , CollectedClientData , Credential , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , SimpleMetadataStatementRepository , SingleMetadata , PublicKeyCredential , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialEntity , PublicKeyCredentialLoader , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , Server , StringStream , TokenBinding , CertificateTrustPath , EcdaaKeyIdTrustPath , Assert , ZIPExtraction
  • __debugInfo() : ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_Curve25519_Fe , BigInteger , Engine , Integer
  • __destruct() : CryptoExceptionHandler , FtpClient , Stream , Image , FormattedtextLogger , SyslogLogger , DatabaseDriver , DatabaseIterator , PdoDriver , SqliteDriver , FtpClient , Stream , LdapClient , Stream , ParagonIE_Sodium_Core_Poly1305_State , PHPMailer , PrimeField , SSH2 , BufferingLogger , Connection , Query
  • __get() : TraceablePDO , AbstractWebApplication , WebClient , CliApplication , ConsoleApplication , ComponentRecord , Date , Feed , FeedEntry , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , ListField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , FormField , Input , InstallerAdapter , LegacyInstallerScript , AbstractMenu , BaseDatabaseModel , UCMType , CategoryeditField , Result , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , TaskOption , DataShapeObject , DataObject , DataSet , DatabaseDriver , DatabaseQuery , Response , Input , ConsentBoxField , Data
  • __invoke() : LazyServiceEventListener , ConfigProvider , ConfigPostProcessor , Dumper
  • __isset() : Result , DataShapeObject , DataObject , DataSet , Data
  • __serialize() : Result , AbstractEvent , Route , Router , Uuid
  • __set() : TraceablePDO , ComponentRecord , Feed , FeedEntry , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , FormField , LegacyInstallerScript , CategoryeditField , Result , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , DataShapeObject , DataObject , DataSet , ConsentBoxField , UriImmutable
  • __sleep() : User , PdoDriver , BigInteger , Engine , BufferingLogger , Connection , Query , AbstractString , LazyString , Stub
  • __toString() : BigDecimal , BigInteger , BigNumber , BigRational , AbstractCBORObject , ByteStringObject , ByteStringWithChunkObject , CBORObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , CronExpression , AbstractTime , ASNObject , AttributeTypeAndValue , Construct , ExplicitlyTaggedObject , GeneralizedTime , ObjectIdentifier , BigInteger , BigIntegerBcmath , BigIntegerGmp , CSR , Rule , Rules , ColorStyle , ActionButton , Date , JsonapiDocument , CMSObject , JsonResponse , DatabaseExporter , DatabaseQuery , QueryElement , QueryInterface , SqliteQuery , SqlsrvQuery , Registry , AbstractUri , UriInterface , CallbackStream , PhpInputStream , RelativeStream , Stream , Uri , Claim , Basic , Signature , Token , Stream , Uri , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , AsymmetricKey , EC , Hash , BigInteger , Engine , Integer , SSH2 , StreamInterface , UriInterface , Uuid , CompletionInput , Suggestion , TableCell , ArgvInput , ArrayInput , AbstractString , LazyString , ConstStub , Data , PhpToken , Document , PharInvocation , PublicKeyCredential
  • __unserialize() : Result , AbstractEvent , Route , Router , Uuid
  • __unset() : Result , DataObject , DataSet
  • __wakeup() : User , PdoDriver , BigInteger , Engine , SplFixedArray , BufferingLogger , Connection , Query , UnicodeString , ZIPExtraction
  • _addPath() : HtmlView
  • _autoload() : JLoader
  • _buildAdminMenus() : ComponentAdapter
  • _buildContentOrderBy() : CategoryModel
  • _buildContext() : Stream
  • _buildDataObject() : Pagination
  • _canDeleteCategories() : PlgContentJoomla
  • _canDeleteStage() : PlgContentJoomla
  • _characterData() : ExtensionAdapter , Update
  • _checkedOut() : Grid
  • _checkExpire() : FileStorage
  • _cleanIntrotext() : ArticlesCategoryHelper
  • _cleanPath() : FileStorage
  • _cloak() : PlgContentEmailcloak
  • _countItemsInCategory() : PlgContentJoomla
  • _countItemsInChildren() : PlgContentJoomla
  • _countItemsInStage() : PlgContentJoomla
  • _createFileName() : HtmlView
  • _createNavigation() : PlgContentPagebreak
  • _createTable() : BaseDatabaseModel
  • _createToc() : PlgContentPagebreak
  • _deleteFolder() : FileStorage
  • _dir_closedir() : Stream
  • _dir_opendir() : Stream
  • _dir_readdir() : Stream
  • _dir_rewinddir() : Stream
  • _displayButtons() : PlgEditorNone
  • _endElement() : CollectionAdapter , ExtensionAdapter , Update
  • _fetchFeedParser() : FeedFactory
  • _fetchTemplate() : HtmlDocument
  • _filesInFolder() : FileStorage
  • _findItem() : RouteHelper
  • _findMode() : FtpClient
  • _folders() : FileStorage
  • _fromInteger() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • _fromString() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • _getArray() : StringController
  • _getAssetName() : Category , Content , Language , MenuType , Module , Table , FieldTable , GroupTable , TaskTable , StageTable , TransitionTable , WorkflowTable
  • _getAssetParentId() : Category , Content , Language , MenuType , Module , FieldTable , GroupTable , StageTable , TransitionTable , WorkflowTable
  • _getAssetTitle() : Category , Content , Language , MenuType , Module , Table , FieldTable , GroupTable , StageTable , TransitionTable , WorkflowTable
  • _getCacheId() : CacheStorage , MemcachedStorage
  • _getCommand() : ConfirmButton , HelpButton , PopupButton , StandardButton
  • _getExtensionId() : PackageAdapter
  • _getFilename() : Stream
  • _getFilePath() : FileStorage
  • _getLastTag() : Update , UpdateAdapter
  • _getLineEnd() : Document
  • _getList() : BaseDatabaseModel , FieldsModel , GroupsModel , InstallerModel , UpdateModel , ModulesModel , PluginsModel , TasksModel
  • _getListCount() : BaseDatabaseModel , MapsModel , LanguagesModel
  • _getListQuery() : ListModel
  • _getNode() : Nested
  • _getPackageFromFolder() : InstallModel
  • _getPackageFromUpload() : InstallModel
  • _getPackageFromUrl() : InstallModel
  • _getParent() : CollectionAdapter
  • _getPattern() : PlgContentEmailcloak
  • _getStackLocation() : CollectionAdapter , Update , UpdateAdapter
  • _getStorage() : Cache
  • _getTab() : Document
  • _getTreeRepositionData() : Nested
  • _getUser() : PlgUserJoomla
  • _item_active() : Pagination
  • _item_inactive() : Pagination
  • _items() : Folder
  • _list_footer() : Pagination
  • _list_render() : Pagination
  • _load() : JLoader , Captcha , Categories , PlgContentLoadmodule
  • _loadEditor() : Editor
  • _loadid() : PlgContentLoadmodule
  • _loadmod() : PlgContentLoadmodule
  • _loadTemplate() : HtmlDocument
  • _lock() : Table
  • _logtable() : Nested
  • _makeId() : CallbackController , PageController , ViewController
  • _mapbin() : Base32
  • _mapcharset() : Base32
  • _mime_types() : PHPMailer
  • _mkdir() : Stream
  • _mode() : FtpClient
  • _noChange() : PageController
  • _parseTemplate() : HtmlDocument
  • _passive() : FtpClient
  • _prepareDocument() : HtmlView
  • _putCmd() : FtpClient
  • _relToAbs() : DocumentRenderer
  • _rename() : Stream
  • _renderTemplate() : HtmlDocument
  • _rmdir() : Stream
  • _rollback_menu() : ComponentAdapter , ModuleAdapter
  • _rollback_module() : ModuleAdapter
  • _runQuery() : Nested
  • _sendEmail() : ContactController
  • _setEtag() : PageController
  • _setPath() : HtmlView
  • _setPlatform() : Browser
  • _sortLanguages() : LanguageField
  • _startElement() : CollectionAdapter , ExtensionAdapter , Update
  • _stream_cast() : Stream
  • _stream_close() : Stream
  • _stream_eof() : Stream
  • _stream_flush() : Stream
  • _stream_lock() : Stream
  • _stream_metadata() : Stream
  • _stream_open() : Stream
  • _stream_read() : Stream
  • _stream_seek() : Stream
  • _stream_set_option() : Stream
  • _stream_stat() : Stream
  • _stream_tell() : Stream
  • _stream_truncate() : Stream
  • _stream_write() : Stream
  • _string_to_element() : ParagonIE_Sodium_Core_Ristretto255
  • _unlink() : Stream
  • _unlock() : Table
  • _unwrap() : BigIntegerBcmath , BigIntegerGmp
  • _updateMenus() : ComponentAdapter
  • _updateSiteMenus() : ComponentAdapter
  • _url_stat() : Stream
  • _verifyResponse() : FtpClient


Joomla CMS: Champs de donnée - Fonctions

- a -

  • abbrClass() : HtmlErrorRenderer
  • abort() : Installer , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • abridge() : StringHelper
  • abs() : BigDecimal , BigInteger , BigRational , Calculator , BigInteger , BCMath , GMP , PHP
  • absoluteValue() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • acceptFactory() : AbstractNegotiator , CharsetNegotiator , EncodingNegotiator , LanguageNegotiator , Negotiator
  • acceptValue() : InputOption
  • acquireLock() : Task
  • action() : JGrid , MessageController
  • actions() : Access
  • activate() : LinksController , LinkModel , UsersController , UserModel , RegistrationModel
  • activateStates() : Users
  • activateUser() : UserHelper
  • adapt() : AbstractPunycode
  • add() : BCMath , Calculator , BcMathCalculator , GmpCalculator , NativeCalculator , ByteStringWithChunkObject , InfiniteListObject , ListObject , MapObject , OtherObjectManager , TagObjectManager , TextStringWithChunkObject , ClassLoader , Manager , ManagerFactory , SwiftLogCollector , BigInteger , BigIntegerBcmath , BigIntegerGmp , WritableContainerLoader , WritableLoaderInterface , Patcher , Log , Mail , ApiController , FormController , WebAssetRegistry , WebAssetRegistryInterface , ArticleController , MediaController , ItemController , ItemsController , ModuleController , ListenersPriorityQueue , Patcher , LdapClient , AlgorithmManager , AlgorithmManagerFactory , BigInteger , JWSSerializerManager , JWSSerializerManagerFactory , ParagonIE_Sodium_Compat , BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer , Application , EntryManagerInterface , EntryManager , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , ExtensionOutputCheckerHandler , PublicKeyCredentialDescriptorCollection
  • add364() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • add64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • addActiveMethod() : MethodDescriptor
  • addAddress() : PHPMailer
  • addAlgorithm() : Server
  • addAllCategoriesMenuItem() : PlgSampledataMultilang
  • addAllowedTypes() : OptionsResolver
  • addAllowedValues() : OptionsResolver
  • addAnAddress() : PHPMailer
  • addArgument() : AbstractCommand , Event , Command , LazyCommand , ArrayInput , InputDefinition
  • addArguments() : InputDefinition
  • addArticle() : PlgSampledataMultilang
  • addAssets() : JavascriptRenderer
  • addAssociations() : PlgSampledataMultilang
  • addAttachment() : Mail , MailTemplate , PHPMailer
  • addAttribute() : Attributes , OnGetApiAttributes
  • addAttributes() : OnGetApiAttributes , ReflectionCaster
  • addAttributeValues() : EntryManager
  • addBaseName() : PharInvocationResolver
  • addBcc() : Mail
  • addBCC() : PHPMailer
  • addBlogMenuItem() : PlgSampledataMultilang
  • addBranch() : Taxonomy
  • addButtonPath() : Toolbar
  • addCache() : CacheCacheCollector
  • addCasters() : AbstractCloner
  • addCategory() : Feed , FeedEntry , PlgSampledataMultilang
  • addCc() : Mail
  • addCC() : PHPMailer
  • addChild() : Construct , NodeInterface
  • addChildren() : Construct
  • addClassMap() : ClassLoader
  • addClientInfo() : ApplicationHelper
  • addCollector() : AggregatedCollector , DebugBar
  • addColumn() : ArrayHelper
  • addCommand() : Application
  • addCommands() : Application
  • addCommonWords() : PlgExtensionFinder
  • addConnection() : PDOCollector
  • addContent() : ConsoleSectionOutput
  • addContentType() : Helper
  • addContextEntry() : Stream
  • addContributor() : Feed , FeedEntry
  • addControl() : JavascriptRenderer
  • addCountableRule() : Inflector
  • addCustomHeader() : PHPMailer
  • addCustomItem() : ActionsDropdown , Dropdown
  • addCustomTag() : HtmlDocument
  • addCustomTypes() : HtmlView
  • addDashboardMenu() : InstallerScript
  • addDebugMessage() : BaseLayout
  • addDirectory() : SysinfoModel
  • addDomainName() : SubjectAlternativeNames
  • addElementToGhost() : HtmlErrorRenderer
  • addEmbeddedImage() : PHPMailer
  • addEntry() : Feed , Sidebar , Logger , CallbackLogger , DatabaseLogger , EchoLogger , FormattedtextLogger , InMemoryLogger , MessagequeueLogger , SyslogLogger
  • addEvent() : Dispatcher
  • addException() : ExceptionsCollector
  • addExecutedStatement() : TraceablePDO
  • addExtension() : TraceableTwigEnvironment , CertificateExtensions
  • addExtensionRegistryFile() : WebAssetRegistry
  • addExtra() : ReflectionCaster
  • addFavicon() : HtmlDocument
  • addFeed() : CategoryView
  • addField() : Item
  • addFieldPath() : Form , FormHelper
  • addFieldPrefix() : FormHelper
  • addFields() : OnGetApiFields
  • addFile() : Patcher
  • addFileFormat() : AsymmetricKey
  • addFileToBuffer() : HTMLHelper
  • addFilter() : TraceableTwigEnvironment , Sidebar
  • addFilterPath() : Form , FormHelper
  • addFilterPrefix() : FormHelper
  • addFormatMap() : ApiApplication
  • addFormPath() : Form , FormHelper
  • addFormPrefix() : FormHelper
  • addFunction() : TraceableTwigEnvironment
  • addGlobal() : TraceableTwigEnvironment
  • addHandler() : ChainedHandler
  • addHeadLink() : HtmlDocument
  • addHelper() : PHP
  • addHelperPath() : HtmlView
  • addImage() : OpensearchDocument
  • addIncludePath() : Cache , CacheController , CacheStorage , HTMLHelper , FileLayout , BaseModel , Table
  • addIncludePaths() : FileLayout
  • addInline() : WebAssetManager
  • addInlineAssets() : JavascriptRenderer
  • addInstruction() : Result
  • addInt32() : ParagonIE_Sodium_Core32_Int32
  • addInt64() : ParagonIE_Sodium_Core32_Int64
  • addIP() : SubjectAlternativeNames
  • addItem() : FeedDocument , Pathway , Domain
  • additionalFailureDescription() : CommandIsSuccessful
  • addLayout() : RouterViewConfiguration
  • addLink() : JsonapiDocument , FeedEntry
  • addListener() : Dispatcher , DispatcherInterface
  • addLog() : ActionlogModel
  • addLogEntry() : Log
  • addLogger() : MonologCollector , Log
  • addLoggerInternal() : Log
  • addLongOption() : ArgvInput , ArrayInput
  • addMap() : Taxonomy , ReflectionCaster
  • addMeasure() : TimeDataCollector , ProfileCollector
  • addMenuGroup() : PlgSampledataMultilang
  • addMenuItems() : PlgSampledataBlog
  • addMessage() : MessagesCollector
  • addMeta() : JsonapiDocument
  • addModelPath() : BaseController
  • addModule() : DisplayController
  • addModuleInModuleMenu() : PlgSampledataMultilang
  • addModuleLanguageSwitcher() : PlgSampledataMultilang
  • addModuleMenu() : PlgSampledataMultilang
  • addMonitor() : ChainedMonitor
  • addNestedNode() : Taxonomy
  • addNestedTaxonomy() : Result
  • addNew() : ToolbarHelper
  • addNode() : Form , Taxonomy
  • addNodeVisitor() : TraceableTwigEnvironment
  • addNormalizer() : OptionsResolver
  • addNote() : Users
  • addOption() : ListField , AbstractCommand , Command , LazyCommand , InputDefinition
  • addOptions() : TaskOptions , InputDefinition
  • addOrEnqueueAnAddress() : PHPMailer
  • addPath() : FormHelper , BaseController
  • addPluraliseRule() : Inflector
  • addPoint() : Binary , Prime , Ed25519 , Ed448
  • addPostInstallationMessage() : MessagesModel
  • addPredefinedStyles() : ColorProcessor
  • addPrefix() : FormHelper
  • addPreset() : MenusHelper
  • addPsr4() : ClassLoader
  • addrAppend() : PHPMailer
  • addRecipient() : Mail , MailTemplate
  • addRegistryFile() : WebAssetRegistry
  • addRelations() : OnGetApiFields
  • addRenderedTemplate() : TraceableTwigEnvironment
  • addReplyTo() : Mail , PHPMailer
  • addResult() : ResultAwareInterface
  • addReverseLookupUrl() : MenutypesModel
  • addrFormat() : PHPMailer
  • addRoute() : Router , RouterInterface
  • addRoutes() : Router , RouterInterface
  • addRow() : Table
  • addRows() : Table
  • addRule() : Inflector
  • addRulePath() : Form , FormHelper
  • addRulePrefix() : FormHelper
  • addScript() : Document
  • addScriptDeclaration() : Document
  • addScriptOptions() : Document
  • addService() : SimpleMetadataStatementRepository
  • addShortcuts() : Shortcut
  • addShortOption() : ArgvInput , ArrayInput
  • addSignature() : JWS , JWSBuilder
  • addSingleStatement() : SimpleMetadataStatementRepository
  • addSingulariseRule() : Inflector
  • addSlide() : Bootstrap
  • addState() : ActionButton
  • addStrategy() : Authentication
  • addStringAttachment() : PHPMailer
  • addStringEmbeddedImage() : PHPMailer
  • addStyle() : ColorProcessor
  • addStyleDeclaration() : Document
  • addStyleSheet() : Document
  • addSubjectAlternativeNames() : CertificateExtensions
  • addSubmenu() : ContentHelper
  • addSubscriber() : Dispatcher , DispatcherInterface
  • addTab() : Bootstrap , UiTab
  • addTagMapping() : TagsHelper
  • addTaxonomy() : Result
  • addTemplateData() : MailTemplate
  • addTemplatePath() : HtmlView
  • addTemplateRegistryFile() : WebAssetRegistry
  • addTest() : TraceableTwigEnvironment
  • addThrowable() : ExceptionsCollector
  • addTokenParser() : TraceableTwigEnvironment
  • addToolbar() : FormView , ListView , HtmlView
  • addToZipFile() : Zip
  • addUpdateSite() : PlgExtensionJoomla
  • addUrl() : OpensearchDocument
  • addUsage() : Command , LazyCommand
  • addUse() : Subject
  • addUsedIn() : Subject
  • addUserAuthProviderColumn() : JoomlaInstallerScript
  • addUserToGroup() : UserHelper
  • addValidator() : Session
  • addViewPath() : BaseController
  • addWord() : Inflector
  • addXmlChild() : XmlView
  • admin_language() : Users
  • advance() : ProgressBar , ProgressIndicator
  • aead_xchacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • AESTestVector() : Crypto , RuntimeTests
  • after() : AbstractString
  • afterDelete() : MfaTable
  • afterLast() : AbstractString
  • afterSessionStart() : WebApplication , InstallationApplication
  • aggregate() : MessagesCollector
  • ajax_upload() : InstallController
  • ajaxchosen() : FormBehavior
  • ajaxfield() : Tag
  • alert() : PropelCollector , Bootstrap , AbstractLogger , LoggerInterface
  • alg() : Key
  • alias() : DatabaseQuery , QueryInterface , Container
  • aliases() : AlgorithmManagerFactory
  • all() : AssertionChain , Manager , ManagerFactory , JoomlaStorage , Router , RouterInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , AlgorithmManagerFactory , JWK , JWKSet , JWSSerializerManagerFactory , DataSet , Application , CollectedClientData
  • allow() : Rule , Rules
  • allowAdd() : ApiController , FormController , AssociationsHelper , BannerController , CategoryController , ContactController , ArticleController , FieldController , GroupController , TemplateController , MediaController , ItemController , NewsfeedController , TagController , StageController , TransitionController , WorkflowController
  • allowAll() : AbstractString
  • allowAllLetters() : AbstractString
  • allowCache() : AbstractWebApplication , WebApplicationInterface
  • allowCapitalLetters() : AbstractString
  • allowCharacter() : AbstractString
  • allowCharacters() : AbstractString
  • allowCustom() : TagField
  • allowDelete() : MediaController
  • allowEdit() : ApiController , FormController , AssociationsHelper , BannerController , CategoryController , ContactController , ArticleController , FieldController , GroupController , MediaController , ItemController , ModuleController , NewsfeedController , TaskController , TagController , TemplateController , GroupController , LevelController , UserController , StageController , TransitionController , WorkflowController
  • allowedKeyTypes() : Algorithm , ECDSA , EdDSA , HMAC , None , RSA , RSAPKCS1 , RSAPSS
  • allowedTypes() : OptionConfigurator
  • allowedValues() : OptionConfigurator
  • allowNumbers() : AbstractString
  • allowSave() : FormController , MessageController , ModuleController , GroupController , LevelController
  • allowSmallLetters() : AbstractString
  • allowSpaces() : AbstractString
  • alnum() : Assertion , Assert
  • alpha() : Assert
  • alt() : Text
  • alterDbCharacterSet() : DatabaseDriver , SqliteDriver
  • alternativeExists() : PHPMailer
  • alterSiteStatus() : SiteStatus
  • ampReplace() : OutputFilter
  • ampReplaceCallback() : OutputFilter
  • and() : BigInteger , Calculator , GmpCalculator
  • andWhere() : DatabaseQuery
  • anonymous_bind() : LdapClient
  • append() : ByteStringWithChunkObject , InfiniteMapObject , TextStringWithChunkObject , FtpClient , File , QueryElement , Registry , AbstractString , ByteString , CodePointString , UnicodeString
  • append_log() : SSH2
  • appendBody() : AbstractWebApplication , WebApplicationInterface
  • appendButton() : Toolbar
  • appendDocument() : XmlDescriptor
  • appendFilter() : Stream
  • appendPrimaryKeys() : Table
  • appendRow() : Table
  • appendString() : ANSI
  • apply() : Patcher , ToolbarHelper , Patcher , Color , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • applyAliasFor() : JLoader
  • applyCanonicalOrdering() : NamePrep
  • applyCharacterMaps() : NamePrep
  • applyContextToStream() : Stream
  • applyCurrentStyle() : OutputFormatter
  • applyHashesToCspRule() : PlgSystemHttpHeaders
  • applyHunk() : Patcher
  • applyOperations() : EntryManager
  • applyUpdateSite() : UpdateModel
  • applyVariant() : BinaryUtils
  • applyVersion() : BinaryUtils
  • appStateSupportsCaching() : Cache
  • archive() : ActionsDropdown , Dropdown , MessageController
  • archiveList() : ToolbarHelper
  • archiveMessage() : MessagesModel
  • areExceptionsCaught() : Application
  • areVendorsIncluded() : JavascriptRenderer
  • array_intersect_first() : SSH2
  • array_repeat() : PHP
  • arrayExpected() : InvalidTokenStructure
  • arrayFromObject() : ArrayHelper
  • arraySearch() : ArrayHelper
  • arrayUnique() : ArrayHelper
  • asArray() : DataShapeObject , Registry
  • ascii() : AbstractUnicodeString
  • ask() : QuestionHelper , StyleInterface , SymfonyStyle
  • askHidden() : StyleInterface , SymfonyStyle
  • askQuestion() : SymfonyStyle
  • asn1map() : ASN1
  • asPEM() : Ec2Key
  • asPem() : RsaKey
  • asPrivateKey() : PublicKey
  • assert() : Constraint , IdentifiedBy , IssuedBy , PermittedFor , RelatedTo , SignedWith , ValidAt , Validator , Assertable , Behavior , ConjunctionInterceptor , PharExtensionInterceptor , PharMetaDataInterceptor , Manager , PharStreamWrapper
  • assertAssertionCompleteness() : Behavior
  • assertAssertions() : ConjunctionInterceptor
  • assertCanDelete() : MethodController
  • assertCanEdit() : MethodController
  • assertCommand() : Behavior
  • assertCommands() : Behavior
  • assertExpiration() : ValidAt
  • assertIssueTime() : ValidAt
  • assertLoggedInUser() : MethodController , MethodsController
  • assertMinimumTime() : ValidAt
  • assertTypeId() : TemplateParser
  • assertUniqueBaseName() : PharInvocationCollection
  • assertUniqueInvocation() : PharInvocationCollection
  • assertValid() : HeaderSecurity
  • assertValidName() : HeaderSecurity
  • assetExists() : WebAssetManager
  • assetgrouplist() : Access
  • assetgroups() : Access
  • assign() : ToolbarHelper
  • association() : AdministratorService , Menus , AdministratorService
  • asXml() : DatabaseExporter , DatabaseImporter
  • attach() : CallbackStream , Stream
  • attachAll() : PHPMailer
  • attachBuildRule() : Router
  • attachmentExists() : PHPMailer
  • attachParseRule() : Router
  • attachRule() : RouterView
  • attachRules() : RouterView
  • attachTaskOptions() : TasksModel
  • attestedCredentialToPublicKeyCredentialSource() : CredentialRepository
  • auth() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • auth_verify() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • authenticate() : AuthenticationStrategyInterface , DatabaseStrategy , LocalStrategy , Authentication , Client , SMTP , LdapAuthenticator
  • authorise() : SiteApplication , Authentication , AbstractMenu , User , Client , POP3
  • autocomplete() : QuestionHelper
  • autoPrependBlock() : SymfonyStyle
  • autoPrependText() : SymfonyStyle


Joomla CMS: Champs de donnée - Fonctions

- b -

  • back() : ToolbarHelper
  • backupDatabase() : DatabaseModel
  • bad_algorithm_candidate() : SSH2
  • base() : Uri
  • base16Decode() : RFC4648
  • base16Encode() : RFC4648
  • base256_lshift() : Engine
  • base256ToBase2() : BinaryField
  • base2ToBase256() : BinaryField
  • base32Decode() : Encoding , RFC4648
  • base32DecodeUpper() : Encoding
  • base32Encode() : Encoding , RFC4648
  • base32EncodeUpper() : Encoding
  • base32HexDecode() : Encoding , RFC4648
  • base32HexDecodeUpper() : Encoding
  • base32HexEncode() : Encoding , RFC4648
  • base32HexEncodeUpper() : Encoding
  • base64() : Assertion
  • base64Decode() : Encoding , RFC4648
  • base64DecodeDotSlash() : Encoding
  • base64DecodeDotSlashOrdered() : Encoding
  • base64Encode() : Encoding , RFC4648
  • base64Encoded() : InMemory
  • base64EncodeDotSlash() : Encoding
  • base64EncodeDotSlashOrdered() : Encoding
  • base64EncodeWrapMB() : PHPMailer
  • base64UrlDecode() : Decoder
  • base64UrlEncode() : Encoder
  • base64UrlSafeDecode() : RFC4648
  • base64UrlSafeEncode() : RFC4648
  • baseFileContainsPharExtension() : PharExtensionInterceptor
  • baseFileDoesNotHaveMetaDataIssues() : PharMetaDataInterceptor
  • baseSquare() : PHP
  • baseString() : Client
  • batch() : FormController , AdminModel , BannerController , FieldController , GroupController , IndexerController , ModuleController , NewsfeedController , LinksController , TagController , UserController , UserModel
  • batchAccess() : AdminModel
  • batchCopy() : AdminModel , CategoryModel , FieldModel , ItemModel , ModuleModel
  • batchFlipordering() : CategoryModel
  • batchLanguage() : AdminModel
  • batchMove() : AdminModel , CategoryModel , ArticleModel , FieldModel , ItemModel , ModuleModel
  • batchOptions() : Modules
  • batchProcess() : LinksModel
  • batchReset() : UserModel
  • batchTag() : AdminModel
  • batchUser() : ContactModel , UserModel
  • before() : AbstractString
  • beforeLast() : AbstractString
  • beginTransaction() : TraceablePDO
  • bestLinkForUri() : AtomParser
  • between() : Assertion , BigInteger , BCMath , GMP , PHP32 , PHP64
  • betweenExclusive() : Assertion
  • betweenLength() : Assertion
  • bin2bits() : Strings
  • bin2hex() : ParagonIE_Sodium_Compat
  • bin2str() : Base32
  • bind() : Form , Category , Content , Menu , Module , Table , TableInterface , User , ViewLevel , User , BannerTable , FieldTable , GroupTable , TaskTable , StyleTable , StageTable , TransitionTable , WorkflowTable , DataObject , DatabaseQuery , PreparableInterface , LdapClient , CompletionInput , Input , InputInterface , ConnectionInterface , Connection , Ldap , LdapInterface
  • bindArray() : DatabaseQuery , QueryInterface
  • bindColumn() : TraceablePDOStatement
  • bindData() : Registry
  • bindLevel() : Form
  • bindParam() : TraceablePDOStatement , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • bindValue() : TraceablePDOStatement , SqlsrvStatement
  • bindValues() : MysqliStatement
  • binStringLength() : ZIPExtraction
  • binToBigInteger() : Utils
  • binToHex() : Encoding
  • binToInt() : Utils
  • bits2bin() : Strings
  • bits2int() : AsymmetricKey
  • bits2octets() : AsymmetricKey
  • bitwise() : Calculator
  • bitwise_and() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwise_leftRotate() : BigInteger , Engine
  • bitwise_leftShift() : BigInteger , BCMath , GMP , PHP
  • bitwise_not() : BigInteger , Engine
  • bitwise_or() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwise_rightRotate() : BigInteger , Engine
  • bitwise_rightShift() : BigInteger , BCMath , GMP , PHP
  • bitwise_small_split() : PHP
  • bitwise_split() : BigInteger , Engine , PHP
  • bitwise_xor() : BigInteger , BCMath , GMP , PHP32 , PHP64
  • bitwiseAndHelper() : Engine
  • bitwiseOrHelper() : Engine
  • bitwiseXorHelper() : Engine
  • blind() : PrivateKey
  • block() : UserModel , SymfonyStyle
  • blockStates() : Users
  • boolean() : Assertion , PhpSetting , Assert
  • booleanlist() : Select
  • boot() : BootableExtensionInterface , AdminComponent , BannersComponent , CategoriesComponent , ContactComponent , ContentComponent , FinderComponent , InstallerComponent , LanguagesComponent , MenusComponent , MessagesComponent , ModulesComponent , NewsfeedsComponent , PrivacyComponent , RedirectComponent , SchedulerComponent , TemplatesComponent , UsersComponent
  • bootComponent() : ExtensionManagerInterface , BaseDatabaseModel
  • bootModule() : ExtensionManagerInterface
  • bootPlugin() : ExtensionManagerInterface
  • box() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_beforenm() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_decrypt() : ParagonIE_Sodium_File
  • box_encrypt() : ParagonIE_Sodium_File
  • box_keypair() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_open() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_publickey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_publickey_from_secretkey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_secretkey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_seed_keypair() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • branchLanguageTitle() : LanguageHelper
  • branchPlural() : LanguageHelper
  • branchSingular() : LanguageHelper
  • build() : GenericLanguageInflectorFactory , LanguageInflectorFactory , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , InstallationRouter , AdministratorRouter , Router , DefaultUuidBuilder , DegradedUuidBuilder , UuidBuilderInterface
  • buildBase() : SiteRouter
  • buildCheckQuery() : ChangeItem , MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • buildCodec() : FeatureSet
  • buildComponentPreprocess() : SiteRouter
  • buildContactExtendedData() : ContactModel
  • buildDateRange() : ActionlogsModel , UsersModel
  • builder() : Configuration
  • buildExecutionRules() : TaskModel
  • buildFormat() : SiteRouter
  • buildInit() : SiteRouter
  • buildLine() : ProgressBar
  • buildLookup() : MenuRules
  • buildMessage() : RequiredConstraintsViolated
  • buildNodeProvider() : FeatureSet
  • buildNumberConverter() : FeatureSet
  • buildObject() : Container
  • buildPaginationData() : SiteRouter
  • buildParametersString() : BaseAccept
  • buildQuery() : Uri , AbstractUri
  • buildRandomGenerator() : FeatureSet
  • buildRegexAndVarList() : Route
  • buildRelationships() : Resource
  • buildResources() : Collection
  • buildRewrite() : SiteRouter
  • buildRule() : PlgSystemLanguageFilter
  • buildRuleset() : Inflector
  • buildSefRoute() : SiteRouter
  • buildSession() : Session
  • buildSharedObject() : Container
  • buildTimeConverter() : FeatureSet
  • buildTimeGenerator() : FeatureSet
  • buildUri() : MetadataService
  • buildUuidBuilder() : FeatureSet
  • buildVotingQuery() : QueryHelper
  • buildXml() : DatabaseExporter , MysqlExporter , MysqliExporter , PgsqlExporter
  • buildXmlData() : DatabaseExporter , PgsqlExporter
  • buildXmlStructure() : DatabaseExporter , MysqlExporter , MysqliExporter , PgsqlExporter
  • button() : Bootstrap , Icons
  • buttons() : Icons
  • byteLength() : AbstractPunycode , TranscodeUnicode
  • bytes() : Number
  • bytesAt() : AbstractString , ByteString


Joomla CMS: Champs de donnée - Fonctions

- c -

  • caDirUsable() : CaBundle
  • caFileUsable() : CaBundle
  • calculateColumnsWidth() : Table
  • calculateContentLength() : AbstractString , ASNObject , Construct , ExplicitlyTaggedObject , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , UTCTime , UnknownConstructedObject , UnknownObject , IPAddress , SubjectAlternativeNames
  • calculateNumberOfColumns() : Table
  • calculateOrderOfActiveAssets() : WebAssetManager
  • calculateRowCount() : Table
  • calculateTime() : BigNumberTimeConverter , DegradedTimeConverter , PhpTimeConverter , TimeConverterInterface
  • calculateTotalWidthForOptions() : TextDescriptor
  • calendar() : Date , HTMLHelper , PlgUserProfile
  • calendartranslation() : Behavior
  • call() : HTMLHelper , DatabaseQuery , QueryInterface , ErrorHandler
  • callback() : CallbackController
  • callOnScript() : LegacyInstallerScript
  • callSearchFunction() : Query
  • camel() : AbstractString , AbstractUnicodeString , ByteString
  • camelize() : Inflector
  • canAddEditMethod() : Mfa
  • cancel() : FormController , ToolbarHelper , AssociationController , CategoryController , ApplicationController , ComponentController , ConfigController , DisplayController , ModulesController , TemplatesController , ContactController , OverrideController , ItemController , ConfigController , ModuleController , TaskController , TemplateController , MailController , UserController , ProfileController
  • canCheckinItem() : AssociationsHelper
  • canChmod() : Path
  • canCreateCategory() : BannerModel , ContactModel , ArticleModel , NewsfeedModel
  • canDelete() : AdminModel , BannerModel , ClientModel , CategoryModel , ContactModel , ArticleModel , HistoryModel , FieldModel , GroupModel , IndexModel , MapsModel , TemplateModel , ItemModel , MenuModel , NewsfeedModel , LinkModel , TaskModel , TagModel , LevelModel , StageModel , TransitionModel , WorkflowModel
  • canDeleteMethod() : Mfa
  • canDeleteState() : ContentHelper
  • canEditFieldValue() : FieldsHelper
  • canEditState() : AdminModel , BannerModel , ClientModel , CategoryModel , ContactModel , ArticleModel , FieldModel , GroupModel , IndexModel , MapsModel , ItemModel , MenuModel , ModuleModel , NewsfeedModel , StageModel , TransitionModel , WorkflowModel
  • canFlushFileCache() : File
  • canKeyBeUsedFor() : JWKSet
  • canKeyBeUsedWithAlgorithm() : JWKSet
  • cannotBeParsed() : InvalidKeyProvided
  • canOnlyBeUsedAfter() : Builder
  • canOnlyBeUsedBy() : Builder
  • canSave() : ItemModel
  • canTransition() : RequestController
  • canUninstallPackageChild() : InstallerAdapter
  • canUpload() : MediaHelper , TemplateHelper
  • canView() : DisplayController
  • capitalize() : Inflector
  • captive() : UpdateController
  • captiveFileExists() : UpdateModel
  • captiveLogin() : UpdateModel
  • captureVar() : DebugBarVarDumper
  • carousel() : Bootstrap
  • castArrayIterator() : SplCaster
  • castArrayObject() : SplCaster
  • castAs() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • castAsChar() : DatabaseQuery , PdoQuery , PgsqlQuery
  • castAttr() : DOMCaster
  • castAttribute() : ReflectionCaster
  • castBrokerMetadata() : RdKafkaCaster
  • castChannel() : AmqpCaster
  • castCharacterData() : DOMCaster
  • castClass() : ReflectionCaster
  • castClassConstant() : ReflectionCaster
  • castClosure() : ReflectionCaster
  • castCollection() : DsCaster
  • castCollectionMetadata() : RdKafkaCaster
  • castCommonProxy() : DoctrineCaster
  • castConf() : RdKafkaCaster
  • castConnection() : AmqpCaster
  • castCurl() : ResourceCaster
  • castCutArray() : StubCaster
  • castDateTime() : DateCaster
  • castDba() : ResourceCaster
  • castDocument() : DOMCaster
  • castDocumentType() : DOMCaster
  • castDomError() : DOMCaster
  • castDoublyLinkedList() : SplCaster
  • castElement() : DOMCaster
  • castEntity() : DOMCaster
  • castEnum() : StubCaster
  • castEnvelope() : AmqpCaster
  • castError() : ExceptionCaster , IntlCaster
  • castErrorException() : ExceptionCaster
  • castException() : DOMCaster , ExceptionCaster
  • castExchange() : AmqpCaster
  • castExtension() : ReflectionCaster
  • castFiber() : FiberCaster
  • castFileInfo() : SplCaster
  • castFileObject() : SplCaster
  • castFrameStub() : ExceptionCaster
  • castFunctionAbstract() : ReflectionCaster
  • castGd() : ResourceCaster
  • castGenerator() : ReflectionCaster
  • castGmp() : GmpCaster
  • castHeap() : SplCaster
  • castHttpClient() : SymfonyCaster
  • castHttpClientResponse() : SymfonyCaster
  • castImage() : ImagineCaster
  • castImplementation() : DOMCaster
  • castInterval() : DateCaster
  • castIntlCalendar() : IntlCaster
  • castIntlDateFormatter() : IntlCaster
  • castIntlTimeZone() : IntlCaster
  • castKafkaConsumer() : RdKafkaCaster
  • castLargeObject() : PgSqlCaster
  • castLength() : DOMCaster
  • castLink() : PgSqlCaster
  • castLocator() : DOMCaster
  • castMap() : DsCaster
  • castMemcached() : MemcachedCaster
  • castMessage() : RdKafkaCaster
  • castMessageFormatter() : IntlCaster
  • castMethod() : ReflectionCaster
  • castMysqliDriver() : MysqliCaster
  • castMysqlLink() : ResourceCaster
  • castNameSpaceNode() : DOMCaster
  • castNode() : DOMCaster
  • castNotation() : DOMCaster
  • castNumberFormatter() : IntlCaster
  • castObject() : Caster , AbstractCloner
  • castObjectStorage() : SplCaster
  • castOpensslX509() : ResourceCaster
  • castOrmProxy() : DoctrineCaster
  • castOuterIterator() : SplCaster
  • castPair() : DsCaster
  • castPairStub() : DsCaster
  • castParameter() : ReflectionCaster
  • castPartitionMetadata() : RdKafkaCaster
  • castPdo() : PdoCaster
  • castPdoStatement() : PdoCaster
  • castPeriod() : DateCaster
  • castPersistentCollection() : DoctrineCaster
  • castPhpIncompleteClass() : Caster
  • castProcess() : ResourceCaster
  • castProcessingInstruction() : DOMCaster
  • castProperty() : ReflectionCaster
  • castProxy() : ProxyManagerCaster
  • castQueue() : AmqpCaster
  • castRamseyUuid() : UuidCaster
  • castRdKafka() : RdKafkaCaster
  • castRedis() : RedisCaster
  • castRedisArray() : RedisCaster
  • castRedisCluster() : RedisCaster
  • castReference() : ReflectionCaster
  • castReflectionGenerator() : ReflectionCaster
  • castRequest() : SymfonyCaster
  • castResource() : AbstractCloner
  • castResult() : PgSqlCaster
  • castSilencedErrorContext() : ExceptionCaster
  • castSplArray() : SplCaster
  • castStream() : ResourceCaster
  • castStreamContext() : ResourceCaster
  • castStub() : StubCaster
  • castText() : DOMCaster
  • castThrowingCasterException() : ExceptionCaster
  • castTimeZone() : DateCaster
  • castTopic() : RdKafkaCaster
  • castTopicConf() : RdKafkaCaster
  • castTopicMetadata() : RdKafkaCaster
  • castTopicPartition() : RdKafkaCaster
  • castTraceStub() : ExceptionCaster
  • castType() : ReflectionCaster
  • castTypeinfo() : DOMCaster
  • castUlid() : SymfonyCaster
  • castUuid() : SymfonyCaster
  • castWeakReference() : SplCaster
  • castXml() : XmlResourceCaster
  • castXmlReader() : XmlReaderCaster
  • castXPath() : DOMCaster
  • castZendExtension() : ReflectionCaster
  • catchWarning() : POP3
  • categories() : Category
  • category() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • categoryAccessChange() : Adapter
  • categoryStateChange() : Adapter
  • caution() : StyleInterface , SymfonyStyle
  • change() : Adapter
  • changeBlock() : UsersController
  • changeIdentity() : DaemonApplication
  • changePassword() : KeyProtectedByPassword
  • characterData() : Changelog
  • charLength() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • charNotInAlphabet() : NumberFormatException
  • charsArray() : ASCII
  • chdir() : FtpClient , SFTP
  • check() : Access , Path , ChangeItem , ChangeSet , Asset , Category , Content , ContentType , CoreContent , Extension , Language , Menu , MenuType , Module , Nested , Table , TableInterface , Update , UpdateSite , User , Usergroup , ViewLevel , BannerTable , ClientTable , ContactTable , FieldTable , GroupTable , FilterTable , MapTable , MenuTable , MessageTable , NewsfeedTable , LinkTable , TaskTable , TagTable , StyleTable , NoteTable , StageTable , WorkflowTable , DatabaseExporter , DatabaseImporter , MysqlExporter , MysqlImporter , MysqliExporter , MysqliImporter , PgsqlExporter , PgsqlImporter , Path , CssMenu , ExtensionOutputChecker , ExtensionOutputCheckerHandler , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , IgnoreTokenBindingHandler , TokenBindingHandler , TokenBindingNotSupportedHandler
  • checkAbsenceOfAllApplicationsTag() : AndroidKeyAttestationStatementSupport
  • checkAccess() : ComponentDispatcher , Dispatcher
  • checkall() : Grid
  • checkAnnotations() : DebugClassLoader
  • checkAnswer() : Captcha
  • checkAttestationMedata() : CertificateToolbox
  • checkAttribute() : InputFilter
  • checkB64AndCriticalHeader() : JWSBuilder
  • checkBuffer() : PlgSystemSef
  • checkCase() : DebugClassLoader
  • checkCategoryAccess() : Adapter
  • checkCategoryId() : AdminModel
  • checkCertificate() : FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • checkCertificateAndGetPublicKey() : AndroidKeyAttestationStatementSupport
  • checkCertificatesValidity() : CertificateToolbox
  • checkCertInfo() : TPMAttestationStatementSupport
  • checkChain() : CertificateToolbox
  • checkClass() : DebugClassLoader
  • checkClasses() : DebugClassLoader
  • checkCode() : Totp
  • checkCompatibility() : UpdateModel
  • checkConnectionAlive() : AbstractWebApplication
  • checkConstraint() : Validator
  • checkContent() : MailHelper , ApiController , MediaController , LocalAdapter
  • checkDb() : SetConfigurationCommand
  • checkDbServerParameters() : DatabaseHelper
  • checkDefault() : MysqlChangeItem
  • checkDefaultValue() : FieldModel
  • checkDuplicatedHeaderParameters() : JWSBuilder
  • checkEditId() : BaseController
  • checkedOut() : Grid
  • checkedout() : JGrid
  • checkExistingExtension() : ModuleAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • checkExtensionInFilesystem() : ComponentAdapter , LibraryAdapter , PackageAdapter , InstallerAdapter
  • checkExtensions() : DiscoverModel
  • checKey() : Hmac
  • checkFileExtension() : MediaHelper
  • checkFileOrder() : HTMLHelper
  • checkForm() : SetupModel
  • checkFormat() : TemplateModel
  • checkGoogleApiResponse() : AndroidSafetyNetAttestationStatementSupport
  • checkGroup() : Access
  • checkGroup1() : Russian
  • checkHeadersSent() : AbstractWebApplication
  • checkIfCoreExtension() : ExtensionHelper
  • checkIfPayloadIsEncoded() : JWSBuilder
  • checkIfRehashNeeded() : Argon2idHandler , Argon2iHandler , BCryptHandler , ChainedHandler , CheckIfRehashNeededHandlerInterface , MD5Handler , PHPassHandler
  • checkImages() : Checkfiles
  • checkin() : Dropdown , AdminController , AdminModel , FormModel
  • checkIn() : Table
  • checkin() : ToolbarHelper , AssociationsController , CheckinModel , FormModel , GroupsController
  • checkInstance() : Integer
  • checkIPv6CIDR() : IpHelper
  • checkItemAccess() : Adapter
  • checkKey() : ECDSA , EdDSA , None , RSA , RSAPKCS1 , RSAPSS
  • checkKeyAlgorithm() : KeyChecker
  • checkKeyUsage() : KeyChecker
  • checkLoggable() : Joomla
  • checkMenuItemBeforeSave() : PlgContentJoomla
  • checkMimeType() : MediaHelper
  • checkNewName() : TemplateModel
  • checkNull() : MysqlChangeItem
  • checkOperation() : KeyChecker
  • checkout() : AdminModel , FormModel
  • checkOut() : Table
  • checkout() : FormModel
  • checkParameters() : TracedStatement
  • CheckPassword() : PasswordHash
  • checkPayload() : JWSVerifier
  • checkPayloadEncoding() : JSONGeneralSerializer
  • checkPubArea() : TPMAttestationStatementSupport
  • checkRemoteDbHost() : DatabaseHelper
  • checkResetLimit() : ResetModel
  • checkResponse() : POP3
  • checkSession() : CMSApplication
  • checkSessionRecordExists() : MetadataManager
  • checkString() : AbstractString
  • checkSuperUserInUsers() : UserHelper
  • checkTestingSampledata() : ConfigurationModel
  • checkToken() : SessionAwareWebApplicationInterface , BaseController , Session
  • checkType() : OpenSSH
  • checkUniquePublicKey() : TPMAttestationStatementSupport
  • checkUsage() : KeyChecker
  • checkUserRequireReset() : CMSApplication
  • checkValidToken() : JSONController
  • checkValue() : PlgFieldsMedia
  • checkZipData() : Zip
  • checkZipFile() : ImportCommand
  • chgrp() : SFTP
  • child() : TemplateModel
  • chmod() : FtpClient , Stream , FtpClient , Stream , SFTP
  • choice() : Assertion , StyleInterface , SymfonyStyle
  • choicesNotEmpty() : Assertion
  • chown() : SFTP
  • chunk() : AbstractString , ByteString , CodePointString , UnicodeString
  • cidExists() : PHPMailer
  • claims() : Token
  • clamp() : ParagonIE_Sodium_Core_Curve25519
  • classExists() : Assertion , ClassNotFoundErrorEnhancer , Assert
  • classify() : Inflector
  • clean() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Path , InputFilter , AssociationsController , AssociationsModel , CacheModel , Path , InputFilter , ASCII
  • cleanAddress() : MailHelper
  • cleanAlnum() : InputFilter
  • cleanAssetKey() : Access
  • cleanAttributes() : InputFilter
  • cleanAttributesOnWhitelist() : Sanitizer
  • cleanBase64() : InputFilter
  • cleanBody() : MailHelper
  • cleanBool() : InputFilter
  • cleanBoolean() : InputFilter
  • cleanCache() : CategoryModel , ArticleModel , FieldModel , GroupModel , FilterModel , LanguageModel , LanguagesModel , ItemModel , MenuModel , ModuleModel , PluginModel , RequestModel , StyleModel
  • cleanCmd() : InputFilter
  • cleanDiscoveredExtension() : Installer
  • cleanDouble() : InputFilter
  • cleanFloat() : InputFilter
  • cleanHrefs() : Sanitizer
  • cleanHtml() : InputFilter
  • cleanImageURL() : HTMLHelper
  • cleanInt() : InputFilter
  • cleanInteger() : InputFilter
  • cleanLine() : MailHelper
  • cleanlist() : CacheModel
  • cleanLogs() : BufferingLogger
  • cleanModuleList() : ModuleHelper
  • cleanOptionsChildrenByFather() : GroupparentField
  • cleanPath() : InputFilter , AbstractUri
  • cleanPrivateData() : SysinfoModel
  • cleanSectionPrivateData() : SysinfoModel
  • cleanString() : InputFilter
  • cleanSubject() : MailHelper
  • cleanTags() : InputFilter
  • cleanText() : MailHelper , OutputFilter
  • cleanTrace() : ErrorHandler
  • cleanTrim() : InputFilter
  • cleanUint() : InputFilter
  • cleanUp() : BigNumber , UpdateModel
  • cleanup() : TemplateModel , Table , Parser
  • cleanupAttributes() : Collection
  • cleanupCache() : Integer
  • cleanupInstall() : InstallerHelper
  • cleanupPostBatchCopy() : AdminModel , ArticleModel
  • cleanupValues() : FieldModel
  • cleanUsername() : InputFilter
  • cleanWord() : InputFilter
  • cleanXlinkHrefs() : Sanitizer
  • clear() : MessagesCollector , OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , Session , JoomlaStorage , DataSet , DatabaseQuery , QueryInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , ProgressBar , ConsoleSectionOutput , OptionsResolver
  • clearAccessRights() : User
  • clearAddresses() : PHPMailer
  • clearAllRecipients() : PHPMailer
  • clearArguments() : Event
  • clearAttachments() : Mail , PHPMailer
  • clearBCCs() : PHPMailer
  • clearCache() : TraceableTwigTemplate
  • clearCacheFiles() : TraceableTwigEnvironment
  • clearCacheGroups() : PlgSystemActionLogs , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemStats , PlgSystemUpdatenotification
  • clearCCs() : PHPMailer
  • clearCustomHeaders() : PHPMailer
  • clearDebugMessages() : BaseLayout
  • clearEvents() : Dispatcher
  • clearFieldsCache() : FieldsHelper
  • clearHeaders() : AbstractWebApplication , WebApplicationInterface
  • clearIncludePaths() : FileLayout
  • clearInternalAndGetAffectedElements() : Subject
  • clearLine() : Cursor
  • clearLineAfter() : Cursor
  • clearListeners() : Dispatcher , DispatcherInterface
  • clearOutput() : Cursor
  • clearQueuedAddresses() : PHPMailer
  • clearReplyTos() : PHPMailer
  • clearScreen() : Cursor
  • clearStatCache() : SFTP
  • clearStatics() : Access
  • clearStatsCache() : JoomlaInstallerScript
  • clearTagsHelper() : TaggableTableInterface
  • clearTemplateCache() : TraceableTwigEnvironment
  • click() : BannerModel
  • clicks() : BannerTable
  • client_send() : SMTP
  • clientlist() : Banner
  • clients() : Banner , Languages
  • cloak() : Email
  • cloneInputStream() : QuestionHelper
  • cloneVar() : AbstractCloner , ClonerInterface
  • close() : AbstractApplication , ApplicationInterface , Stream , JoomlaStorage , TemplateController , Stream , LdapClient , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , CallbackStream , RelativeStream , Stream , SMTP , StreamInterface , Curl , StringStream
  • close_channel() : SSH2
  • close_handle() : SFTP
  • closeCursor() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • cmov() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • cmp() : Calculator
  • codePointsAt() : AbstractUnicodeString , CodePointString
  • collapse() : Bootstrap
  • collapseWhitespace() : AbstractString
  • collect() : DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , DataCollectorInterface , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , RequestDataCollector , TimeDataCollector , DebugBar , Resolver , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector , Collectable , PharInvocationCollection
  • collectInvocation() : PharStreamWrapper
  • collectLogs() : PlgSystemDebug
  • collectPDO() : PDOCollector
  • collectUrlsEnabled() : RedirectHelper
  • columns() : DatabaseQuery , QueryInterface
  • combine() : NamePrep
  • combineCodePoints() : NamePrep
  • combobox() : Behavior
  • commandShouldRun() : ConsoleCommandEvent
  • comment() : SymfonyStyle
  • commit() : TraceablePDO
  • commonCategoryDisplay() : CategoryView
  • comp() : BCMath
  • comparator() : SFTP
  • compare() : BigInteger , BigIntegerBcmath , BigIntegerGmp , LdapClient , BigInteger , AcceptMatch , ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Util , BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer
  • compareHelper() : PHP
  • compareLanguages() : LanguagesModel , PlgSampledataMultilang
  • compareTo() : BigDecimal , BigInteger , BigNumber , BigRational , Uuid , UuidInterface
  • compareUpdateVersion() : DatabaseModel
  • compile() : TraceableTwigEnvironment
  • compileSource() : TraceableTwigEnvironment
  • complete() : Application , Command , DumpCompletionCommand , HelpCommand , LazyCommand , ListCommand , CommandCompletionTester , ServerDumpCommand , LintCommand
  • compliant() : StringHelper
  • compress() : AbstractWebApplication , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • computeAlternatives() : TraceableTwigEnvironment
  • computeData() : NamespacedTwigProfileCollector , TwigProfileCollector
  • computek() : AsymmetricKey
  • computeKey() : Hash
  • computeKeyIdentifier() : X509
  • computeLength() : LengthCalculator
  • computeSecret() : DH
  • concatenate() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • configure() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , CleanCacheCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , AbstractGroupButton , AbstractCommand , HelpCommand , ListCommand , ExportCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand , Command , CompleteCommand , DumpCompletionCommand , HelpCommand , ListCommand , ServerDumpCommand , LintCommand
  • configureClaim() : Builder
  • configureIO() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , Application
  • configureOptions() : AbstractConnection , Connection
  • configureSessionHandlerOptions() : SessionFactory
  • configureTaskGetterOptions() : TaskModel
  • configureTaskRunnerOptions() : Scheduler
  • confirm() : StyleInterface , SymfonyStyle , PharInvocation
  • connect() : FtpClient , SocketTransport , DatabaseLogger , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver , FtpClient , Socket , LdapClient , POP3 , SMTP , SSH2 , Connection
  • connected() : DatabaseInterface , MysqliDriver , PdoDriver , SMTP
  • constructError() : FallbackExceptionHandler
  • consumeWhitespaces() : Parser
  • contactItems() : JoomlaInstallerScript
  • contains() : Assertion , Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Assert
  • containsAny() : AbstractString
  • containsFractionalSecondsElement() : GeneralizedTime
  • containsPlugin() : PluginController
  • content() : Microdata
  • contents() : Key
  • context() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • controlPagedResult() : Query
  • controlPagedResultResponse() : Query
  • convert() : AbstractIdnaConvert , EncodingHelperInterface , FromUtf8 , ToUtf8 , IdnaConvertInterface , FromPunycode , ToPunycode , ToIdn , ToUnicode , TranscodeUnicode , TranscodeUnicodeInterface , ASN1
  • convert_int_to_char_for_ctype() : Ctype
  • convertAllDERToPEM() : CertificateToolbox
  • convertBase64StringToBigInteger() : RSAKey
  • convertCertificatesToPem() : AndroidSafetyNetAttestationStatementSupport , TPMAttestationStatementSupport
  • convertDERToPEM() : CertificateToolbox
  • convertEmailAddress() : AbstractIdnaConvert , IdnaConvertInterface
  • convertFetchMode() : PdoStatement
  • convertFileToClass() : ClassNotFoundErrorEnhancer
  • convertHexColorToAnsi() : Color
  • convertInteger() : Base
  • convertIntegerToOctetString() : PSSRSA , RSA
  • convertItems() : Builder , Parser
  • convertKeyOpsToKeyUse() : JWKSet
  • convertLiterals() : AbstractField
  • convertLogLevel() : PropelCollector
  • convertParameterType() : PdoStatement
  • convertPathsToNames() : TagsHelper
  • convertPrivateKeyToPEM() : ECKey
  • convertPublicKeyToPEM() : ECKey
  • convertRelationshipsToArray() : Resource
  • convertRelativeToAbsoluteUrls() : MailHelper
  • convertTablesToUtf8mb4() : JoomlaInstallerScript
  • convertToAffine() : Base , Binary , Montgomery , Prime , TwistedEdwards
  • convertToDataSet() : Token
  • convertToDate() : Builder
  • convertToInternal() : Base , Binary , Montgomery , Prime , Ed25519 , Ed448
  • convertToObj() : PHP
  • convertToPEM() : ECKey
  • convertToRelativePath() : HTMLHelper
  • convertUrl() : AbstractIdnaConvert , IdnaConvertInterface
  • convertUtf8mb4QueryToUtf8() : MysqlDriver , MysqliDriver , UTF8MB4SupportInterface
  • convertWithLibraries() : FromUtf8 , ToUtf8
  • copy() : File , Folder , Stream , AdapterInterface , ApiModel , TemplateModel , File , Folder , Stream , LocalAdapter
  • copyBaseFiles() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • copyFile() : TemplateModel , LocalAdapter
  • copyFiles() : Installer
  • copyFileTo() : UpdateCoreCommand
  • copyFolder() : LocalAdapter
  • copyManifest() : Installer
  • copyRow() : Table
  • copyStyles() : TemplateModel
  • core() : Behavior
  • core_salsa20() : ParagonIE_Sodium_Core_Salsa20
  • count() : Assertion , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , Construct , Feed , UserGroupsHelper , DataObject , DataSet , DatabaseIterator , AbstractEvent , ListenersPriorityQueue , Input , Registry , JWKSet , SplFixedArray , Collection , OptionsResolver , Data , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , PublicKeyCredentialDescriptorCollection , Assert
  • countBetween() : Assert
  • counterReset() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • countEvents() : Dispatcher
  • countFiles() : MediaHelper
  • countItems() : CategoryServiceInterface , LegacyComponent , CategoriesModel , ContentComponent , NewsfeedsHelper , TagsModel , WorkflowsModel
  • countItemsByMonth() : ArticlesModel
  • countListeners() : Dispatcher , DispatcherInterface
  • countMenuChildren() : HtmlDocument
  • countModules() : HtmlDocument
  • countRelations() : ContentHelper
  • countSignatures() : JWS
  • countTagItems() : LegacyComponent , TagServiceInterface , ContentComponent , NewsfeedsHelper
  • countUse() : Subject
  • countUsedIn() : Subject
  • create() : BigNumber , DoublePrecisionFloatObject , HalfPrecisionFloatObject , SimpleObject , SinglePrecisionFloatObject , SignedIntegerObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , EpochTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , UnsignedIntegerObject , ManagerFactory , InflectorFactory , Identifier , BigInteger , JHtmlIcon , JNamespacePsr4Map , Zip , FtpClient , AbstractEvent , Folder , Icon , FtpClient , Folder , LdapClient , AlgorithmManagerFactory , JWSBuilder , JWSBuilderFactory , JWSLoaderFactory , JWSVerifierFactory , JWSSerializerManagerFactory , Factory , LeewayCannotBeNegative , Stream , FlattenException , Ldap , StemmerFactory , DistantSingleMetadataFactory , MetadataServiceFactory
  • createAdapterReadRoutes() : PlgWebservicesMedia
  • createAppendAutoloader() : Autoloader
  • createAsset() : WebAssetRegistry
  • createAsseticCollection() : JavascriptRenderer
  • createAssociation() : Workflow
  • createAttCA() : AttestationStatement
  • createAuthenticatedToken() : LdapAuthenticator
  • createBasic() : Factory , AttestationStatement
  • createBigInteger() : SignedIntegerObject , UnsignedIntegerObject
  • createBlock() : SymfonyStyle
  • createBody() : HtmlResponse , TextResponse , XmlResponse , PHPMailer
  • createBodyFromJson() : JsonResponse
  • createButton() : ToolbarFactoryInterface
  • createCacheController() : CacheControllerFactory , CacheControllerFactoryInterface
  • createCategory() : CategoryFactory , CategoryFactoryInterface , CategoriesHelper
  • createChild() : Toolbar , Container
  • createCompletionInput() : CompleteCommand
  • createConfig() : Factory
  • createConfiguration() : ConfigurationModel
  • createContainer() : Factory
  • createContentHistoryRoutes() : PlgWebservicesBanners , PlgWebservicesContact , PlgWebservicesContent
  • createContentLanguage() : LanguageAdapter
  • createController() : LegacyFactory , MVCFactory , MVCFactoryInterface
  • createCRUDRoutes() : ApiRouter
  • createCSRSequence() : CSR
  • createCustomFieldsDomain() : PrivacyPlugin
  • createDatabase() : DatabaseModel , DatabaseDriver , DatabaseInterface , SqliteDriver
  • createDatabaseTable() : DatabaseHandler
  • createDb() : DatabaseModel
  • createDbo() : Factory
  • createdBy() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • createDelegatedLogger() : Log
  • createDirectory() : ZIPExtraction
  • createDispatcher() : ComponentDispatcherFactory , ComponentDispatcherFactoryInterface , ModuleDispatcherFactory , ModuleDispatcherFactoryInterface
  • createDocument() : FactoryInterface , Factory
  • createDomain() : PrivacyPlugin
  • createDummyModule() : ModuleHelper
  • createEcdaa() : AttestationStatement
  • createECKey() : ECKey
  • createECKeyUsingOpenSSL() : ECKey
  • createEqualsTo() : Factory
  • createException() : Assertion
  • createExtensionRoot() : ComponentAdapter , PackageAdapter , PluginAdapter , InstallerAdapter
  • createFactory() : Inflector
  • createFieldsRoutes() : PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesUsers
  • createFile() : AdapterInterface , ApiModel , TemplateController , TemplateModel , LocalAdapter
  • createFileName() : BaseController
  • createFolder() : AdapterInterface , ApiModel , TemplateModel , LocalAdapter
  • createForLanguage() : InflectorFactory
  • createForm() : FormFactory , FormFactoryInterface
  • createFormArray() : TokenBinding
  • createFormJson() : CollectedClientData
  • createFromArray() : AttestationStatement , AttestedCredentialData , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , BiometricAccuracyDescriptor , BiometricStatusReport , CodeAccuracyDescriptor , DisplayPNGCharacteristicsDescriptor , EcdaaTrustAnchor , ExtensionDescriptor , MetadataStatement , MetadataTOCPayload , MetadataTOCPayloadEntry , PatternAccuracyDescriptor , RgbPaletteEntry , RogueListEntry , StatusReport , VerificationMethodANDCombinations , VerificationMethodDescriptor , Version , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , CertificateTrustPath , EcdaaKeyIdTrustPath , EmptyTrustPath , TrustPath
  • createFromBigInteger() : BigInteger
  • createFromBinaryString() : BigInteger
  • createFromData() : Key
  • createFromDecimal() : BigInteger
  • createFromExponentAndMantissa() : BigFloatTag , DecimalFractionTag
  • createFromGmpValue() : SignedIntegerObject , UnsignedIntegerObject
  • createFromHex() : UnsignedIntegerObject
  • createFromJson() : JWK , JWKSet
  • createFromJWK() : RSAKey
  • createFromKey() : KeyOrPassword
  • createFromKeyData() : JWKSet
  • createFromLoadedData() : BreakObject , OtherObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , TrueObject , UndefinedObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TagObject
  • createFromPassword() : KeyOrPassword
  • createFromPublicKeyCredential() : PublicKeyCredentialSource
  • createFromString() : SignedIntegerObject , UnsignedIntegerObject , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialOptions , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialUserEntity
  • createFromThrowable() : FlattenException
  • createGreaterOrEqualsTo() : Factory
  • createHash() : BaseSigner , Ecdsa , Hmac , None , OpenSSL
  • createHeader() : Client , PHPMailer
  • createInlineCryptFunction() : SymmetricKey
  • createItemForTable() : PrivacyPlugin
  • createItemForUserTable() : PlgPrivacyUser
  • createItemFromArray() : PrivacyPlugin
  • createKey() : MemcachedStorage , DH , DSA , EC
  • createLanguage() : Factory , CachingLanguageFactory , LanguageFactory , LanguageFactoryInterface
  • createLanguageInstallerRoutes() : PlgWebservicesLanguages
  • createLanguageList() : LanguageHelper
  • createLengthPart() : ASNObject
  • createLesserOrEqualsTo() : Factory
  • createMailer() : Factory
  • createMediaCRUDRoutes() : PlgWebservicesMedia
  • createMenu() : MenuFactory , MenuFactoryInterface
  • createModel() : BaseController , ApiMVCFactory , LegacyFactory , MVCFactory , MVCFactoryInterface
  • CreateNewRandomKey() : Crypto
  • createNewRandomKey() : Key
  • createNodeName() : XPath
  • createNone() : AttestationStatement
  • createNotesDomain() : PlgPrivacyUser
  • createObjectArray() : ContenthistoryHelper
  • createObjectForValue() : SignedIntegerObject , UnsignedIntegerObject
  • createOption() : ModulesModel , ModulesHelper
  • createOptionGroup() : ModulesModel , ModulesHelper
  • createOrUpdateRecord() : MetadataManager
  • createOverride() : TemplateModel
  • createParameters() : DH , DSA
  • createPoly1305Key() : Salsa20
  • createPrependAutoloader() : Autoloader
  • createProfileDomain() : PlgPrivacyUser
  • createProgressBar() : OutputStyle , SymfonyStyle
  • createPublicKeyCredentialSource() : AuthenticatorAttestationResponseValidator
  • createQuery() : AdapterInterface , Adapter
  • createRandomMultiplier() : Base , Curve25519 , Curve448 , Ed25519 , Ed448
  • createRandomPasswordProtectedKey() : KeyProtectedByPassword
  • createRecordIfNonExisting() : MetadataManager
  • createRecurringModuloFunction() : BigInteger , Engine , GMP
  • createRef() : StringController
  • createRenderer() : Factory , FactoryInterface
  • createRequest() : RequestFactory , HttplugFactory , Psr17Factory , RequestFactoryInterface
  • createResponse() : ResponseFactory , HttplugFactory , Psr17Factory , ResponseFactoryInterface , PublicKeyCredentialLoader
  • createRestorationFile() : UpdateModel
  • createRootUser() : ConfigurationModel
  • createRouter() : RouterFactory , RouterFactoryInterface , RouterServiceInterface , LegacyComponent
  • createSelf() : AttestationStatement
  • createServerRequest() : ServerRequestFactory , Psr17Factory , ServerRequestFactoryInterface
  • createSessionRecord() : MetadataManager
  • createSignature() : Builder
  • createSiteList() : Help
  • createSocket() : Connection
  • createStream() : StreamFactory , HttplugFactory , Psr17Factory , StreamFactoryInterface
  • createStreamFromFile() : StreamFactory , Psr17Factory , StreamFactoryInterface
  • createStreamFromResource() : StreamFactory , Psr17Factory , StreamFactoryInterface
  • createStyleFromString() : OutputFormatter
  • createTable() : ApiMVCFactory , LegacyFactory , MVCFactory , MVCFactoryInterface , SymfonyStyle
  • createTables() : DatabaseModel
  • createTagsFromField() : TagsHelper
  • createTemplate() : MailTemplate
  • createTemplateOverride() : TemplateModel
  • createThumbs() : Image
  • createToken() : Session , LdapAuthenticator
  • createToolbar() : ContainerAwareToolbarFactory , ToolbarFactoryInterface
  • createTransliterator() : AsciiSlugger
  • createUpdateFile() : UpdateModel
  • createUploadedFile() : UploadedFileFactory , Psr17Factory , UploadedFileFactoryInterface
  • createUri() : UriFactory , Router , UriFactory , HttplugFactory , Psr17Factory , UriFactoryInterface
  • createUriFromRequestTarget() : Serializer
  • createUriString() : Uri
  • createUrl() : Help , Client
  • createUserDomain() : PlgPrivacyUser
  • createView() : BaseController , LegacyFactory , MVCFactory , MVCFactoryInterface
  • createZipFile() : Zip
  • crit() : PropelCollector
  • critical() : AbstractLogger , LoggerInterface
  • crop() : Image
  • cropImage() : TemplateModel
  • cropResize() : Image
  • crypt() : RC4 , Salsa20
  • crypt_private() : PasswordHash
  • crypto_aead_aes256gcm_encrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_aes256gcm_is_available() : ParagonIE_Sodium_Compat
  • crypto_aead_aes256gcm_keygen() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_encrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_ietf_keygen() : ParagonIE_Sodium_Compat
  • crypto_aead_chacha20poly1305_keygen() : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_decrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_encrypt() : ParagonIE_Sodium_Compat
  • crypto_aead_xchacha20poly1305_ietf_keygen() : ParagonIE_Sodium_Compat
  • crypto_auth() : ParagonIE_Sodium_Compat
  • crypto_auth_keygen() : ParagonIE_Sodium_Compat
  • crypto_auth_verify() : ParagonIE_Sodium_Compat
  • crypto_box() : ParagonIE_Sodium_Compat
  • crypto_box_keypair() : ParagonIE_Sodium_Compat
  • crypto_box_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Compat
  • crypto_box_open() : ParagonIE_Sodium_Compat
  • crypto_box_publickey() : ParagonIE_Sodium_Compat
  • crypto_box_publickey_from_secretkey() : ParagonIE_Sodium_Compat
  • crypto_box_seal() : ParagonIE_Sodium_Compat
  • crypto_box_seal_open() : ParagonIE_Sodium_Compat
  • crypto_box_secretkey() : ParagonIE_Sodium_Compat
  • crypto_box_seed_keypair() : ParagonIE_Sodium_Compat
  • crypto_generichash() : ParagonIE_Sodium_Compat
  • crypto_generichash_final() : ParagonIE_Sodium_Compat
  • crypto_generichash_init() : ParagonIE_Sodium_Compat
  • crypto_generichash_init_salt_personal() : ParagonIE_Sodium_Compat
  • crypto_generichash_keygen() : ParagonIE_Sodium_Compat
  • crypto_generichash_update() : ParagonIE_Sodium_Compat
  • crypto_kdf_derive_from_key() : ParagonIE_Sodium_Compat
  • crypto_kdf_keygen() : ParagonIE_Sodium_Compat
  • crypto_kx() : ParagonIE_Sodium_Compat
  • crypto_kx_client_session_keys() : ParagonIE_Sodium_Compat
  • crypto_kx_keypair() : ParagonIE_Sodium_Compat
  • crypto_kx_publickey() : ParagonIE_Sodium_Compat
  • crypto_kx_secretkey() : ParagonIE_Sodium_Compat
  • crypto_kx_seed_keypair() : ParagonIE_Sodium_Compat
  • crypto_kx_server_session_keys() : ParagonIE_Sodium_Compat
  • crypto_pwhash() : ParagonIE_Sodium_Compat
  • crypto_pwhash_is_available() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_is_available() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_str() : ParagonIE_Sodium_Compat
  • crypto_pwhash_scryptsalsa208sha256_str_verify() : ParagonIE_Sodium_Compat
  • crypto_pwhash_str() : ParagonIE_Sodium_Compat
  • crypto_pwhash_str_verify() : ParagonIE_Sodium_Compat
  • crypto_scalarmult() : ParagonIE_Sodium_Compat
  • crypto_scalarmult_base() : ParagonIE_Sodium_Compat
  • crypto_scalarmult_curve25519_ref10_base() : ParagonIE_Sodium_Core32_X25519 , ParagonIE_Sodium_Core_X25519
  • crypto_secretbox() : ParagonIE_Sodium_Compat
  • crypto_secretbox_keygen() : ParagonIE_Sodium_Compat
  • crypto_secretbox_open() : ParagonIE_Sodium_Compat
  • crypto_secretbox_xchacha20poly1305() : ParagonIE_Sodium_Compat
  • crypto_secretbox_xchacha20poly1305_open() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_init_pull() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_init_push() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_keygen() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_pull() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_push() : ParagonIE_Sodium_Compat
  • crypto_secretstream_xchacha20poly1305_rekey() : ParagonIE_Sodium_Compat
  • crypto_shorthash() : ParagonIE_Sodium_Compat
  • crypto_shorthash_keygen() : ParagonIE_Sodium_Compat
  • crypto_sign() : ParagonIE_Sodium_Compat
  • crypto_sign_detached() : ParagonIE_Sodium_Compat
  • crypto_sign_ed25519_pk_to_curve25519() : ParagonIE_Sodium_Compat
  • crypto_sign_ed25519_sk_to_curve25519() : ParagonIE_Sodium_Compat
  • crypto_sign_keypair() : ParagonIE_Sodium_Compat
  • crypto_sign_keypair_from_secretkey_and_publickey() : ParagonIE_Sodium_Compat
  • crypto_sign_open() : ParagonIE_Sodium_Compat
  • crypto_sign_publickey() : ParagonIE_Sodium_Compat
  • crypto_sign_publickey_from_secretkey() : ParagonIE_Sodium_Compat
  • crypto_sign_secretkey() : ParagonIE_Sodium_Compat
  • crypto_sign_seed_keypair() : ParagonIE_Sodium_Compat
  • crypto_sign_verify_detached() : ParagonIE_Sodium_Compat
  • crypto_stream() : ParagonIE_Sodium_Compat
  • crypto_stream_keygen() : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20() : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20_keygen() : ParagonIE_Sodium_Compat
  • crypto_stream_xchacha20_xor() : ParagonIE_Sodium_Compat
  • crypto_stream_xor() : ParagonIE_Sodium_Compat
  • ctype_alnum() : Ctype
  • ctype_alpha() : Ctype
  • ctype_cntrl() : Ctype
  • ctype_digit() : Ctype
  • ctype_graph() : Ctype
  • ctype_lower() : Ctype
  • ctype_print() : Ctype
  • ctype_punct() : Ctype
  • ctype_space() : Ctype
  • ctype_upper() : Ctype
  • ctype_xdigit() : Ctype
  • current() : Construct , Uri , DataSet , DatabaseIterator , SplFixedArray
  • currentTime() : FixedTimeProvider , SystemTimeProvider , TimeProviderInterface
  • currentTimestamp() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • curve() : Ec2Key , OkpKey
  • custom() : ToolbarHelper
  • cutInternals() : StubCaster


Joomla CMS: Champs de donnée - Fonctions

- d -

  • d() : Ec2Key , OkpKey , RsaKey
  • daemonize() : DaemonApplication
  • darwinRealpath() : DebugClassLoader
  • data() : SMTP
  • date() : Assertion , HTMLHelper
  • dateAdd() : DatabaseQuery
  • dateFormat() : DatabaseQuery
  • dateIsNotParseable() : InvalidTokenStructure
  • dateTimeToSql() : ExecRuleHelper
  • day() : DatabaseQuery , QueryInterface
  • dayToString() : Date
  • debug() : PropelCollector , BaseLayout , LayoutHelper , Nested , PlgSystemStats , AbstractLogger , LoggerInterface , GithubActionReporter
  • debugFile() : Language
  • debugLanguage() : InstallationApplication
  • debugMsg() : ZIPExtraction
  • declareScalarType() : ParagonIE_Sodium_Core_Util
  • decode() : Base64Url , Decoder , Base128 , Base32 , InputFilter , JsonConverter , Base32 , EncoderInterface , CodecInterface , GuidStringCodec , StringCodec , TimestampFirstCombCodec
  • decode5Bits() : Base32 , Base32Hex
  • decode5BitsUpper() : Base32 , Base32Hex
  • decode6Bits() : Base64 , Base64DotSlash , Base64DotSlashOrdered , Base64UrlSafe , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • decodeBER() : ASN1
  • decodeBinary() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • decodeBytes() : CodecInterface , GuidStringCodec , OrderedTimeCodec , StringCodec , TimestampFirstCombCodec
  • decodeData() : Files
  • decodeDigit() : FromPunycode
  • decodeFields() : ContenthistoryHelper
  • decodeFileData() : InputFilter
  • decodeIP() : X509
  • decodeLength() : ASN1
  • decodeNameConstraintIP() : X509
  • decodeNoPadding() : Base32 , Base64
  • decodeOID() : ASN1
  • decodeRecordOptions() : Email , Fixed , Totp , Yubikey
  • decodeTime() : ASN1
  • decodeUpper() : Base32
  • decodeValue() : XML
  • decompose() : Normalizer
  • Decrypt() : Crypto
  • decrypt() : Crypto , CryptoCipher , SodiumCipher , AesInterface , Mcrypt , OpenSSL , Encrypt , Crypto , OpenSSL , Sodium , CipherInterface , Crypt , ChaCha20 , SymmetricKey , RC2 , RC4 , Rijndael , PrivateKey , Salsa20 , TripleDES
  • decrypt_with_libsodium() : ChaCha20
  • decryptBlock() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , Twofish
  • decryptCredential() : CredentialRepository
  • decryptFile() : File
  • decryptFileInternal() : File
  • decryptFileWithPassword() : File
  • decryptOptions() : MfaTable
  • decryptResource() : File
  • decryptResourceWithPassword() : File
  • decryptString() : Aes
  • decryptWithPassword() : Crypto
  • def() : CMSObject , Input , Registry
  • default() : OptionConfigurator
  • define() : OptionConfigurator , OptionsResolver
  • define_array() : SSH2
  • defined() : Assertion
  • definitionList() : SymfonyStyle
  • defParam() : User
  • deg() : Integer
  • degradeHexColorToAnsi() : Color
  • delete() : FtpClient , File , Folder , Stream , AdminController , AdminModel , CoreContent , MenuType , TableInterface , User , Usergroup , UCMContent , User , Versioning , ActionlogsModel , TracksModel , DisplayController , CategoryTable , ArticleModel , HistoryModel , FieldModel , IndexModel , MapsModel , UpdatesitesController , UpdatesitesModel , OverridesController , LanguagesModel , OverridesModel , OverridesController , AdapterInterface , ApiModel , MediaController , MediumModel , MenuModel , MenuTable , MessageModel , ModuleModel , TagTable , TemplateController , StyleModel , StyleTable , GroupsController , LevelController , MethodController , GroupModel , UserModel , MfaTable , StageTable , WorkflowTable , DatabaseQuery , QueryInterface , FtpClient , File , Folder , Stream , Http , LdapClient , LocalAdapter , Router , RouterInterface , SFTP
  • delete_recursive() : SFTP
  • deleteAll() : MethodsModel
  • deleteAssociation() : Workflow
  • deleteByContentId() : CoreContent
  • deleteConfiguration() : ConfigurationModel
  • deleteContextEntry() : Stream
  • deleteFile() : TemplateModel
  • deleteFiles() : ApiController
  • deleteFolder() : TemplateModel
  • deleteInstallationFolder() : CleanupModel
  • deleteList() : ToolbarHelper
  • deleteOldVersions() : ContentHistory
  • deletePriorTo() : MetadataManager
  • deleteSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • deleteTemplate() : MailTemplate
  • deleteUnexistingFiles() : JoomlaInstallerScript
  • delVar() : Uri
  • denominatorMustNotBeZero() : DivisionByZeroException
  • deprecated() : OptionConfigurator
  • deriveKeys() : KeyOrPassword
  • derivePoint() : Binary , Prime
  • describe() : TextDescriptor , DescriptorHelper , Descriptor , DescriptorInterface , MarkdownDescriptor , DescriptorHelper , CliDescriptor , DumpDescriptorInterface , HtmlDescriptor
  • describeApplication() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeCommand() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeConsoleCommand() : TextDescriptor
  • describeInputArgument() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeInputDefinition() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeInputOption() : Descriptor , JsonDescriptor , MarkdownDescriptor , TextDescriptor , XmlDescriptor
  • describeJoomlaApplication() : TextDescriptor
  • deserializeMetaData() : Manifest
  • destroy() : Image , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , Manager
  • destroySession() : SessionManager
  • destroySessions() : SessionManager
  • detach() : DaemonApplication , CallbackStream , RelativeStream , Stream , StreamInterface
  • detachRule() : RouterView , Router
  • detect() : Calculator
  • detectAndCleanIP() : IpHelper
  • detectBrowser() : WebClient
  • detectEncoding() : WebClient
  • detectEngine() : WebClient
  • detectHeaders() : WebClient
  • detectIP() : IpHelper
  • detectLanguage() : WebClient , LanguageHelper
  • detectPlatform() : WebClient
  • detectRequestUri() : AbstractWebApplication
  • detectRobot() : WebClient
  • detectType() : InstallerHelper
  • determineBaseFile() : Helper
  • determineBestFormat() : ProgressBar , ProgressIndicator
  • determineFileType() : Reader
  • determineFileTypeByHeader() : Reader
  • determineInvalidSubjects() : Resolver
  • determineTimeZone() : CronExpression
  • dI() : RsaKey
  • digit() : Assertion
  • digits() : Assert
  • dir_closedir() : PharStreamWrapper
  • dir_opendir() : PharStreamWrapper
  • dir_readdir() : PharStreamWrapper
  • dir_rewinddir() : PharStreamWrapper
  • directory() : Assertion , Assert
  • directoryTree() : HtmlView
  • disable() : DebugClassLoader
  • disableArbitraryLengthPackets() : SFTP
  • disableAsset() : WebAssetManager , WebAssetManagerInterface
  • disableAutoReload() : TraceableTwigEnvironment
  • disableBlinding() : RSA
  • disableCommand() : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • disableContinuousBuffer() : SymmetricKey , TripleDES
  • disableControl() : JavascriptRenderer
  • disableDatePreservation() : SFTP
  • disableDebug() : TraceableTwigEnvironment
  • disableModuleMainMenu() : PlgSampledataMultilang
  • disablePadding() : SymmetricKey
  • disablePathCanonicalization() : SFTP
  • disablePlugin() : PlgSystemStats
  • disablePresetItems() : WebAssetManager
  • disablePTY() : SSH2
  • disableQuietMode() : SSH2
  • disableRFC4050Syntax() : XML
  • disableSmartMFA() : SSH2
  • disableStatCache() : SFTP
  • disableStrictVariables() : TraceableTwigEnvironment
  • disableStty() : QuestionHelper
  • disableURLFetch() : X509
  • disableVendor() : JavascriptRenderer
  • disconnect() : DatabaseDriver , DatabaseInterface , MysqliDriver , POP3 , SSH2 , Connection
  • disconnect_helper() : SFTP , SSH2
  • discover() : JLoader , ComponentAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PluginAdapter , TemplateAdapter , Installer , DiscoverModel
  • discover_install() : LanguageAdapter , Installer , InstallerAdapter , DiscoverModel
  • discoverDefaultOptions() : MemcachedCaster
  • dispatch() : AdministratorApplication , ApiApplication , SiteApplication , ApiDispatcher , ComponentDispatcher , DispatcherInterface , LegacyComponentDispatcher , ModuleDispatcher , InstallationApplication , Dispatcher , DispatcherInterface
  • dispatchAssetChanged() : WebAssetRegistry
  • dispatchEvent() : AbstractApplication , BaseDatabaseModel , AbstractView , DatabaseDriver
  • dispatchExitEvent() : Task
  • display() : TraceableTwigEnvironment , TraceableTwigTemplate , Captcha , Editor , DefaultView , HtmlView , Microdata , AbstractView , CategoriesView , CategoryFeedView , CategoryView , FormView , HtmlView , JsonView , ListView , ViewInterface , DisplayController , JsonView , TextView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , VcfView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , FeedView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , FeedView , HtmlView , OpensearchView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , MenuController , MenusController , HtmlView , XmlView , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , FeedView , HtmlView , FeedView , HtmlView , DisplayController , HtmlView , JsonView , HtmlView , DisplayController , MethodsController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , DisplayController , HtmlView , PlgSystemFields , ProgressBar , ProgressIndicator , LintCommand
  • displayAssociations() : AssociationHelper
  • displayBlock() : TraceableTwigTemplate
  • displayButtons() : PlgEditorCodemirror
  • displayFieldOnForm() : FieldsHelper
  • displayItem() : CategoriesController , JsonapiView , FieldsController , GroupsController , OverridesController , AdaptersController , MediaController , ItemsController , MenusController , ModulesController , JsonapiView , ConsentsController , StylesController , JsonapiView
  • displayJson() : LintCommand
  • displayList() : CategoriesController , JsonapiView , ArticlesController , JsonapiView , HistoryController , FieldsController , GroupsController , ManageController , OverridesController , MediaController , ItemsController , MenusController , ModulesController , PluginsController , StylesController , UsersController , JsonapiView
  • displayName() : CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer
  • displayParentBlock() : TraceableTwigTemplate
  • displayScope() : Microdata
  • displayTxt() : LintCommand
  • displayVotingData() : PlgContentVote
  • div() : BCMath
  • divide() : BigInteger , BCMath , GMP , PHP32 , PHP64 , Integer
  • divide_digit() : PHP
  • dividedBy() : BigDecimal , BigInteger , BigRational
  • divideHelper() : PHP
  • divider() : ActionsDropdown , Dropdown , ToolbarHelper
  • divisionByZero() : DivisionByZeroException
  • divQ() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divQR() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divR() : BcMathCalculator , Calculator , GmpCalculator , NativeCalculator
  • divRound() : Calculator
  • DKIM_Add() : PHPMailer
  • DKIM_BodyC() : PHPMailer
  • DKIM_HeaderC() : PHPMailer
  • DKIM_QP() : PHPMailer
  • DKIM_Sign() : PHPMailer
  • dnsName() : X509
  • dnsPrefetch() : PreloadManager , PreloadManagerInterface
  • do() : NamePrep , NamePrepInterface
  • doAdd() : NativeCalculator
  • doAsk() : QuestionHelper
  • doAuthenticate() : AbstractUsernamePasswordAuthenticationStrategy
  • dob() : PlgUserProfile
  • doCallback() : PHPMailer
  • doClone() : AbstractCloner , VarCloner
  • doCmp() : NativeCalculator
  • doDatabaseTransactions() : InstallerAdapter
  • doDisplay() : TraceableTwigTemplate
  • doDiv() : NativeCalculator
  • doesKeySatisfyRestrictions() : JWKSet
  • doExecute() : AbstractApplication , WebApplication , AdministratorApplication , ApiApplication , ConsoleApplication , SiteApplication , AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , UpdateCoreCommand , InstallationApplication , Application , AbstractCommand , HelpCommand , ListCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand
  • doLoadLanguage() : InstallerAdapter
  • doMul() : NativeCalculator
  • doParse() : Parser
  • doRenderThrowable() : Application
  • doRun() : Application
  • doRunCommand() : Application
  • doSub() : NativeCalculator
  • doubleAndAddPoint() : Montgomery
  • doublePoint() : Binary , Prime , Ed25519 , Ed448
  • doublePointHelper() : KoblitzPrime , Prime
  • doubleRound() : ChaCha20 , Salsa20
  • doVerify() : BaseSigner , Ecdsa , Hmac , None , OpenSSL
  • download() : UpdateModel
  • downloadFile() : UpdateCoreCommand
  • downloadPackage() : LanguagesModel , InstallerHelper , UpdateModel
  • doWrite() : BufferedOutput , ConsoleSectionOutput , Output , StreamOutput , TrimmedBufferOutput
  • dP() : RsaKey
  • dQ() : RsaKey
  • draggable() : DraggableList
  • dropColumn() : ArrayHelper
  • dropdown() : Bootstrap
  • dropTable() : DatabaseDriver , DatabaseInterface
  • dropUtf8ConversionTable() : JoomlaInstallerScript
  • dueToConfiguration() : UnreadableStreamException , UnseekableStreamException , UnwritableStreamException
  • dueToMissingResource() : UnreadableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • dueToPhpError() : UnreadableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • dueToStreamUploadError() : UploadedFileErrorException
  • dueToUnwritablePath() : UploadedFileErrorException
  • dueToUnwritableTarget() : UploadedFileErrorException
  • dump() : SwiftLogCollector , DebugBarVarDumper , SeekingData , DataObject , DataSet , DumpableInterface , DatabaseQuery , Data , AbstractDumper , ContextualizedDumper , DataDumperInterface , HtmlDumper , ServerDumper , VarDumper , Dumper , Inline , Yaml
  • dumpArray() : Inline
  • dumpAssets() : JavascriptRenderer
  • dumpChildren() : Data
  • dumpCssAssets() : JavascriptRenderer
  • dumpEllipsis() : CliDumper
  • dumpHeadAssets() : JavascriptRenderer
  • dumpItem() : Data
  • dumpJsAssets() : JavascriptRenderer
  • dumpKey() : CliDumper
  • dumpLine() : AbstractDumper , CliDumper , HtmlDumper
  • dumpNull() : Inline
  • dumpProperty() : DataObject
  • dumpScalar() : DumperInterface , CliDumper
  • dumpString() : DumperInterface , CliDumper , HtmlDumper
  • duplicate() : ActionsDropdown , ModulesController , ModuleModel , StylesController , StyleModel
  • duplicateUrls() : LinksController , LinkModel


Joomla CMS: Champs de donnée - Fonctions

- e -

  • e() : RsaKey , DatabaseQuery
  • e164() : Assertion
  • echoLine() : AbstractDumper
  • edebug() : PHPMailer , SMTP
  • edit() : JHtmlIcon , Dropdown , FormController , AssociationController , Icon , ArticleController , OverrideController , TemplateController , MediaController , ItemController , ItemsController , ProfileController
  • editAssociations() : FormController , AdminModel
  • editCss() : ToolbarHelper
  • editHtml() : ToolbarHelper
  • editList() : ToolbarHelper
  • editor() : Users
  • edwards_to_montgomery() : ParagonIE_Sodium_Core32_X25519 , ParagonIE_Sodium_Core_X25519
  • elementOptions() : PluginsHelper
  • email() : Assertion , Assert
  • emailToPunycode() : InputFilter , PunycodeHelper
  • emailToUTF8() : PunycodeHelper
  • emergency() : PropelCollector , AbstractLogger , LoggerInterface
  • emsa_pkcs1_v1_5_encode() : RSA
  • emsa_pkcs1_v1_5_encode_without_null() : RSA
  • emsa_pss_encode() : PrivateKey
  • emsa_pss_verify() : PublicKey
  • enable() : Microdata , Debug , DebugClassLoader
  • enableArbitraryLengthPackets() : SFTP
  • enableAutoReload() : TraceableTwigEnvironment
  • enableBlinding() : RSA
  • enableCommand() : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • enableContinuousBuffer() : SymmetricKey , TripleDES
  • enableDatePreservation() : SFTP
  • enableDebug() : TraceableTwigEnvironment
  • enableDependencies() : WebAssetManager
  • enablePadding() : SymmetricKey
  • enablePathCanonicalization() : SFTP
  • enablePlugin() : PlgSampledataMultilang
  • enablePoly1305() : SymmetricKey
  • enablePropelProfiling() : PropelCollector
  • enablePTY() : SSH2
  • enableQuietMode() : SSH2
  • enableRFC4050Syntax() : XML
  • enableSmartMFA() : SSH2
  • enableStatCache() : SFTP
  • enableStrictVariables() : TraceableTwigEnvironment
  • enableURLFetch() : X509
  • encode() : Base64Url , Base128 , Base32 , JsonConverter , Base32 , Base64 , EncoderInterface , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe , CodecInterface , GuidStringCodec , StringCodec , TimestampFirstCombCodec
  • encode5Bits() : Base32 , Base32Hex
  • encode5BitsUpper() : Base32 , Base32Hex
  • encode64() : PasswordHash
  • encode6Bits() : Base64 , Base64DotSlash , Base64DotSlashOrdered , Base64UrlSafe , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • encode_der() : ASN1
  • encodeBinary() : CodecInterface , GuidStringCodec , OrderedTimeCodec , StringCodec , TimestampFirstCombCodec
  • encodeDER() : ASN1
  • encodeDigit() : ToPunycode
  • encodeEMSA15() : RSA
  • encodeEMSAPSS() : PSSRSA , RSA
  • encodeFile() : PHPMailer
  • encodeHeader() : PHPMailer
  • encodeIP() : X509
  • encodeLength() : ASN1
  • encodeOID() : ASN1
  • encodePoint() : Ed25519 , Ed448
  • encodeQ() : PHPMailer
  • encodeQP() : PHPMailer
  • encodeString() : PHPMailer
  • encodeUnpadded() : Base32 , Base64 , ParagonIE_Sodium_Core_Base64_Common , ParagonIE_Sodium_Core_Base64_Original , ParagonIE_Sodium_Core_Base64_UrlSafe
  • encodeUpper() : Base32
  • encodeUpperUnpadded() : Base32
  • encodeXMLParameters() : XML
  • Encrypt() : Crypto
  • encrypt() : Crypto , CryptoCipher , SodiumCipher , AesInterface , Mcrypt , OpenSSL , Encrypt , Crypto , OpenSSL , Sodium , CipherInterface , Crypt , ChaCha20 , SymmetricKey , RC2 , RC4 , Rijndael , PublicKey , Salsa20 , TripleDES
  • encrypt_with_libsodium() : ChaCha20
  • encryptBlock() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , Twofish
  • encryptCredential() : CredentialRepository
  • encryptFile() : File
  • encryptFileInternal() : File
  • encryptFileWithPassword() : File
  • encryptInternal() : Crypto
  • encryption() : UnsupportedHeaderFound
  • encryption_algorithm_to_crypt_instance() : SSH2
  • encryption_algorithm_to_key_size() : SSH2
  • encryptResource() : File
  • encryptResourceWithPassword() : File
  • encryptString() : Aes
  • encryptWithPassword() : Crypto
  • end() : TracedStatement
  • endAccordion() : Bootstrap
  • endBoundary() : PHPMailer
  • endElement() : Changelog
  • endSlide() : Bootstrap
  • endsWith() : Assertion , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • endTab() : Bootstrap , UiTab
  • endTabSet() : Bootstrap , UiTab
  • endValue() : CliDumper
  • enforceAndroidSafetyNetVerification() : Server
  • enforceMinimumExecutionTime() : ZIPExtraction
  • enhance() : ClassNotFoundErrorEnhancer , ErrorEnhancerInterface , UndefinedFunctionErrorEnhancer , UndefinedMethodErrorEnhancer
  • enhanceItemForm() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • enhanceTransitionForm() : PlgWorkflowPublishing
  • enqueueMessage() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • ensureConstantExists() : Core
  • ensureEnd() : AbstractString
  • EnsureFunctionExists() : Crypto
  • ensureFunctionExists() : Core
  • ensureMapFileExists() : JNamespacePsr4Map
  • ensureMinimalEncoding() : Integer
  • ensureStart() : AbstractString
  • ensureTrue() : Core
  • ensureUniqueId() : ToolbarButton
  • enter() : TimeableTwigExtensionProfiler
  • enterHash() : DumperInterface , CliDumper , HtmlDumper
  • eof() : Stream , CallbackStream , RelativeStream , Stream , StreamInterface
  • eq() : Assertion , Assert
  • eqArraySubset() : Assertion
  • equal() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • equals() : BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer , Uuid , UuidInterface , InputOption , PharInvocation
  • equalsTo() : AbstractString , ByteString , CodePointString , UnicodeString
  • eraseCredentials() : LdapUser
  • err() : PropelCollector
  • error() : AbstractLogger , LoggerInterface , GithubActionReporter , StyleInterface , SymfonyStyle
  • errorCode() : TraceablePDO , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • errorHandler() : SMTP
  • errorHappened() : CannotSignPayload
  • errorInfo() : TraceablePDO , MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • errorMessage() : Exception
  • escape() : BaseLayout , LayoutInterface , HtmlView , DatabaseInterface , DatabaseQuery , MysqlDriver , MysqliDriver , PdoDriver , SqliteDriver , LdapClient , OutputFormatter , HtmlErrorRenderer , AdapterInterface , Adapter , Ldap , LdapInterface
  • escapeAttributeValues() : InputFilter
  • escapeCsvFormula() : ActionlogsHelper
  • escapeString() : ProcessHelper
  • escapeToken() : Input
  • escapeTrailingBackslash() : OutputFormatter
  • escapeWithDoubleQuotes() : Escaper
  • escapeWithSingleQuotes() : Escaper
  • evaluateBinaryScalar() : Inline
  • evaluateScalar() : Inline
  • exactlyDividedBy() : BigDecimal
  • exception1() : English
  • exception2() : English
  • exceptionR1() : English
  • exec() : TraceablePDO , DatabaseQuery , QueryInterface , SSH2 , Curl
  • execute() : TraceablePDOStatement , AbstractApplication , AbstractWebApplication , ApplicationInterface , CliApplication , ConsoleApplication , DaemonApplication , WebApplication , Backgroundfill , Brightness , Contrast , Edgedetect , Emboss , Grayscale , Negate , Sketchy , Smooth , ImageFilter , InstallationApplication , BaseController , ControllerInterface , ApiController , MethodController , CaptiveController , MethodController , MethodsController , Application , AbstractCommand , DatabaseDriver , DatabaseInterface , MysqliStatement , PdoDriver , PdoStatement , SqlsrvStatement , StatementInterface , Command , DumpCompletionCommand , HelpCommand , ListCommand , CommandTester , Query , QueryInterface , ServerDumpCommand , LintCommand
  • executeController() : InstallationApplication
  • executeTransition() : WorkflowModelInterface , Workflow
  • executeUnpreparedQuery() : MysqliDriver
  • existing() : AdminLanguage , ContentLanguage , WorkflowStage
  • exists() : JNamespacePsr4Map , File , Folder , LanguageHelper , WebAssetRegistry , WebAssetRegistryInterface , Container , Input , Registry
  • expiresAt() : Builder
  • explained() : Query
  • exponentiate() : PSSRSA , RSAKey , PrivateKey , PublicKey
  • exponents() : RsaKey
  • export() : RequestController
  • exportXml() : MenuController
  • extend() : Container
  • extendedGCD() : KoblitzPrime , BCMath , GMP , PHP32 , PHP64
  • extendedGCDHelper() : Engine
  • extendWhere() : DatabaseQuery , QueryInterface
  • extensionExistsInSystem() : FileAdapter
  • extensionLoaded() : Assertion
  • extensions() : X509
  • extensionVersion() : Assertion
  • extract() : Archive , Bzip2 , ExtractableInterface , Gzip , Tar , Zip , HTMLHelper , FieldsHelper , Registry
  • extractAllNamespaces() : Application
  • extractArchive() : TemplateModel
  • extractBER() : ASN1
  • extractComponents() : StringCodec
  • extractCustom() : Zip
  • extractData() : Reader
  • extractDate() : HtmlDescriptor
  • extractEncryptionAlgorithm() : PKCS8
  • extractFile() : UpdateCoreCommand
  • extractFlags() : AmqpCaster
  • extractIdReferenceFromHref() : Helper
  • extractMetadata() : RdKafkaCaster
  • extractNamespace() : Application , ApplicationDescription , Application
  • extractNative() : Zip
  • extractPointRFC4050() : XML
  • extractPublicKey() : FidoU2FAttestationStatementSupport
  • extractSecret() : Ed25519 , Ed448
  • extractSource() : ExceptionCaster
  • extractTimeZoneData() : AbstractTime


Joomla CMS: Champs de donnée - Fonctions

- f -

  • factory() : CronExpression
  • failureDescription() : CommandIsSuccessful
  • fallback() : Microdata
  • fallbackReplacement() : ConfigPostProcessor
  • false() : Assertion , Assert
  • fclose() : Socket
  • fdiv() : Php80
  • fe_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_1() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_abs() : ParagonIE_Sodium_Core_Ristretto255
  • fe_cneg() : ParagonIE_Sodium_Core_Ristretto255
  • fe_copy() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_cswap() : ParagonIE_Sodium_Core_X25519
  • fe_frombytes() : ParagonIE_Sodium_Core_Curve25519
  • fe_invert() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_isnegative() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_mul() : ParagonIE_Sodium_Core_Curve25519
  • fe_neg() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_normalize() : ParagonIE_Sodium_Core_Curve25519
  • fe_pow22523() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • fe_sq() : ParagonIE_Sodium_Core_Curve25519
  • fe_sq2() : ParagonIE_Sodium_Core_Curve25519
  • fe_sub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • feature() : ActionsDropdown
  • featured() : Dropdown , ContactModel , AdministratorService , ArticleModel
  • feof() : Socket
  • fetch() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface , BufferedOutput , TrimmedBufferOutput , MetadataStatementFetcher
  • fetchArray() : DatabaseDriver
  • fetchAssoc() : DatabaseDriver
  • fetchAssociations() : AjaxController
  • fetchButton() : BasicButton , ConfirmButton , CustomButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , SeparatorButton , StandardButton , ToolbarButton
  • fetchButtonClass() : StandardButton
  • fetchColumn() : MysqliStatement , SqlsrvStatement
  • fetchCompatibility() : UpdateModel
  • fetchConfigurationData() : InstallationApplication
  • fetchData() : MysqliStatement
  • fetchIconClass() : ActionButton , ToolbarButton
  • fetchId() : AbstractGroupButton , DropdownButton , ToolbarButton
  • fetchMetadataStatement() : MetadataStatementFetcher
  • fetchNamespace() : FeedParser
  • fetchObject() : DatabaseDriver , DatabaseIterator
  • fetchSchemaCache() : DatabaseModel
  • fetchTableOfContent() : MetadataStatementFetcher
  • fetchTaskRecord() : Scheduler
  • fetchURL() : X509
  • fgets() : Socket
  • fieldmapExpand() : ContentType , UCMType
  • fields() : Collection , ElementInterface , Resource
  • file() : Assertion , InMemory , LocalFileReference , Assert
  • file_exists() : SFTP
  • fileatime() : SFTP
  • fileExcerpt() : HtmlErrorRenderer
  • fileExists() : Assert
  • filegroup() : SFTP
  • fileIsAccessible() : PHPMailer
  • filemtime() : SFTP
  • filenameToType() : PHPMailer
  • fileowner() : SFTP
  • fileperms() : SFTP
  • files() : Folder
  • filesize() : Stream , SFTP
  • filetype() : SFTP
  • fileUploadMaxSize() : FilesystemHelper
  • fillCells() : Table
  • fillNextRows() : Table
  • filter() : FileStorage , MemcachedStorage , RedisStorage , CalendarField , SubformField , IntarrayFilter , RawFilter , RulesFilter , SafehtmlFilter , TelFilter , UnsetFilter , UrlFilter , Form , FormField , FormFilterInterface , Image , HeaderSecurity , SSH2 , Caster
  • filterAssetArray() : JavascriptRenderer
  • filterExceptionArray() : ExceptionCaster
  • filterExtensionsBasedOn() : ExtensionsListCommand
  • filterExtensionsBasedOnState() : ExtensionDiscoverListCommand
  • filterFields() : Resource
  • filterFragment() : Uri
  • filterHeader() : AbstractSerializer
  • filterInvalidUtf8() : Uri
  • filterKey() : LanguagesHelper
  • filterModules() : CaptiveModel
  • filterNotes() : Users
  • filterOutInlineAssets() : WebAssetManager
  • filterPath() : Uri
  • filterPort() : Uri
  • filterQuery() : Uri
  • filterQueryAndFragment() : Uri
  • filterQueryOrFragment() : Uri
  • filterRequestInputs() : Bootup
  • filterRequestUri() : Bootup
  • filterScheme() : Uri
  • filterString() : Bootup
  • filterText() : ComponentHelper , LanguagesHelper
  • filterTransitions() : WorkflowServiceInterface , ContentComponent , ContentHelper
  • filterUserInfoPart() : Uri
  • finaliseInstall() : FileAdapter , LanguageAdapter , ModuleAdapter , InstallerAdapter
  • finaliseUninstall() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • finaliseUpgrade() : UpdateModel
  • finalize() : PlgInstallerOverride
  • find() : OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , Path , Extension , Update , Path , FileStorage , Application
  • findAllForUserEntity() : PublicKeyCredentialSourceRepository
  • findAlternatives() : Application
  • findByAlias() : PharInvocationResolver
  • findByBaseName() : PharInvocationResolver
  • findByCallback() : Collectable , PharInvocationCollection
  • findByElement() : Resolver
  • findByElementId() : Resolver
  • findClassInPath() : ClassNotFoundErrorEnhancer
  • findCommand() : CompleteCommand
  • findData() : CollectedClientData
  • findDeletedFiles() : Installer
  • finderItems() : JoomlaInstallerScript
  • findField() : Form
  • findFieldsByFieldset() : Form
  • findFieldsByGroup() : Form
  • findFile() : ClassLoader , DebugClassLoader
  • findFileWithExtension() : ClassLoader
  • findGroup() : Form
  • findHeader() : Patcher
  • findHunk() : Patcher
  • findInBaseNames() : PharInvocationResolver
  • findInSet() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • findItem() : RouteHelper
  • findLoggers() : Log
  • findManifest() : Installer
  • findMatches() : AbstractNegotiator
  • findNamespace() : Application
  • findOneByAAGUID() : MetadataRepository , MetadataStatementRepository , SimpleMetadataStatementRepository
  • findOneByAAGUIDFromServices() : SimpleMetadataStatementRepository
  • findOneByAAGUIDFromSingleStatements() : SimpleMetadataStatementRepository
  • findOneByCredentialId() : CredentialRepository , PublicKeyCredentialSourceRepository
  • findOption() : TaskOptions
  • findOptionName() : ToolbarButton
  • findSignatureAlgorithm() : JWSBuilder
  • findUpdate() : CollectionAdapter , ExtensionAdapter , UpdateAdapter
  • findUpdates() : UpdateModel
  • finish() : ParagonIE_Sodium_Core_BLAKE2b , ProgressBar , ProgressIndicator , Catalan , Dutch , English , French , German , Italian , Portuguese , Romanian , Spanish
  • fix() : ChangeItem , ChangeSet , DatabaseModel , CoseSignatureFixer
  • fixCodeMarkup() : HtmlErrorRenderer
  • fixDefaultTextFilters() : DatabaseModel
  • fixFilenameCasing() : JoomlaInstallerScript
  • fixGroupColumns() : SqlsrvQuery
  • fixHexLength() : LengthCalculator
  • fixInteger() : MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • fixPEMStructure() : CertificateToolbox
  • fixQuote() : MysqlChangeItem , PostgresqlChangeItem , SqlsrvChangeItem
  • fixReturnStatements() : DebugClassLoader
  • fixSchemaVersion() : DatabaseModel
  • fixSegment() : Router
  • fixSelectAliases() : SqlsrvQuery
  • fixTemplateMode() : JoomlaInstallerScript
  • fixTemplateName() : TemplateModel
  • fixUpdateVersion() : DatabaseModel
  • fixUtf8mb4TypeChecks() : MysqlChangeItem
  • flatten() : Registry , ArrayHelper
  • flatten64() : ParagonIE_Sodium_Core_BLAKE2b
  • flattenArgs() : FlattenException
  • flip() : Image
  • float() : Assertion , Assert
  • float2string() : EvalBarrett
  • floatToString() : BigNumber
  • flush() : CacheStorage , MemcachedStorage
  • flushAssets() : ConsoleApplication , WebApplication
  • folded() : AbstractString , AbstractUnicodeString , ByteString
  • folderOptions() : PluginsHelper
  • folders() : Folder
  • folderTree() : HtmlView
  • forAsymmetricSigner() : Configuration
  • forCallbackStream() : UnreadableStreamException , UnrewindableStreamException , UnseekableStreamException , UntellableStreamException , UnwritableStreamException
  • forClaim() : RegisteredClaimGiven
  • forInvalidHeader() : DeserializationException
  • forInvalidHeaderContinuation() : DeserializationException
  • forInvalidRequestLine() : SerializationException
  • forInvalidStatusLine() : SerializationException
  • fork() : DaemonApplication , Session , SessionInterface
  • form() : SearchTools
  • format() : BCMath , Date , DatabaseQuery , NullOutputFormatter , OutputFormatter , OutputFormatterInterface
  • format_log() : SSH2
  • formatAndWrap() : OutputFormatter , WrappableOutputFormatterInterface
  • formatArgs() : HtmlErrorRenderer
  • formatArgsAsText() : HtmlErrorRenderer
  • formatBlock() : FormatterHelper
  • formatBytes() : DataCollector , DataFormatter , DataFormatterInterface
  • formatCallable() : DebugEventDispatcherCommand , DebugRouterCommand
  • formatCallerInfo() : AbstractDataCollector , DataFormatter
  • formatChoiceQuestionChoices() : QuestionHelper
  • formatConfig() : GetConfigurationCommand
  • formatConfigValue() : GetConfigurationCommand
  • formatDate() : CredentialRepository
  • formatDateTime() : DateCaster
  • formatDefaultValue() : TextDescriptor
  • formatDuration() : DataCollector , DataFormatter , DataFormatterInterface
  • formatExceptionData() : ExceptionsCollector
  • formatFile() : HtmlErrorRenderer
  • formatFileFromText() : HtmlErrorRenderer
  • formatInterval() : DateCaster
  • formatLine() : FormattedtextLogger
  • formatLogMessage() : HtmlErrorRenderer
  • formatMemory() : Helper
  • formatOptions() : OptionsResolver
  • formatPack() : Strings
  • formatPath() : AbstractDataCollector , DataFormatter
  • formatRelative() : MethodsModel
  • formatSeconds() : DateCaster
  • formatSection() : FormatterHelper
  • formatSubjectPublicKey() : X509
  • formatThrowableData() : ExceptionsCollector
  • formatTime() : Helper
  • formatTo() : SwiftMailCollector
  • formatValue() : Php , DebugRouterCommand , OptionsResolver
  • formatValues() : OptionsResolver
  • formatVar() : DataCollector , DataFormatter , DataFormatterInterface
  • formvalidator() : Behavior
  • forRequestFromArray() : DeserializationException
  • forResponseFromArray() : DeserializationException
  • forSymmetricSigner() : Configuration
  • forUnexpectedCarriageReturn() : DeserializationException
  • forUnexpectedEndOfHeaders() : DeserializationException
  • forUnexpectedLineFeed() : DeserializationException
  • forUnmovableFile() : UploadedFileErrorException
  • forUnsecuredSigner() : Configuration
  • forVersion() : UnrecognizedProtocolVersionException
  • forwardCallToCorrectClaimMethod() : Builder
  • forwardData() : Agent
  • framework() : Bootstrap , Jquery
  • fread() : ZIPExtraction
  • freeResult() : DatabaseDriver , DatabaseIterator
  • from() : DatabaseExporter , DatabaseImporter , DatabaseQuery , QueryInterface
  • fromArbitraryBase() : BigInteger , Calculator
  • fromArray() : ArraySerializer , ParagonIE_Sodium_Core32_Curve25519_Fe , SplFixedArray
  • fromAsn1() : ECSignature , MultibyteStringConverter , SignatureConverter
  • fromBase() : BigInteger , Calculator , GmpCalculator
  • fromBase64ToInteger() : RsaKey , RSAKey
  • fromBin() : Base32
  • fromBinary() : AbstractString , ASNObject , RelativeDistinguishedName , Construct , ExplicitlyTaggedObject , Parsable , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , RelativeObjectIdentifier , UTCTime , CertificateSubject , Attributes , IPAddress
  • fromBytes() : BigInteger , Uuid , UuidFactory , UuidFactoryInterface
  • fromCallable() : LazyString
  • fromCamelCase() : Normalise
  • fromCodePoints() : AbstractUnicodeString
  • fromContent() : Manifest , Stub
  • fromEmptyData() : Signature
  • fromErrors() : LazyAssertionException
  • fromGlobals() : ServerRequestFactory
  • fromHex() : BigNumberConverter , DegradedNumberConverter , NumberConverterInterface
  • fromInt() : ParagonIE_Sodium_Core32_Int64
  • fromInteger() : Uuid , UuidFactory , UuidFactoryInterface
  • fromInts() : ParagonIE_Sodium_Core32_Int64
  • fromJson() : Response
  • fromObject() : ArrayHelper
  • fromPunycode() : PunycodeHelper
  • fromRandom() : ByteString
  • fromReverseString() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • fromStream() : Serializer
  • fromString() : ColorStyle , Serializer , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , Uuid , UuidFactory , UuidFactoryInterface , CompletionInput
  • fromStringable() : LazyString
  • fromTokens() : CompletionInput
  • fromViolations() : RequiredConstraintsViolated
  • fsockopen() : Socket
  • ftell() : ParagonIE_Sodium_File
  • ftpChmod() : FilesystemHelper , Helper
  • fwrite() : Socket


Joomla CMS: Champs de donnée - Fonctions

- g -

  • G() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • gc() : DaemonApplication , Cache , CacheStorage , ApcuStorage , FileStorage , WincacheStorage , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • gcd() : BigInteger , Calculator , GmpCalculator , BigInteger , GMP , PHP32 , PHP64 , BigInteger
  • gcdExtended() : Calculator
  • ge_add() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_cmov8_cached() : ParagonIE_Sodium_Core_Curve25519
  • ge_cmov_cached() : ParagonIE_Sodium_Core_Curve25519
  • ge_madd() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_msub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p1p1_to_p2() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p1p1_to_p3() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p2_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p2_dbl() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_dbl() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_to_p2() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_p3_tobytes() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_precomp_0() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_select() : ParagonIE_Sodium_Core32_Curve25519
  • ge_sub() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • ge_tobytes() : ParagonIE_Sodium_Core32_Curve25519 , ParagonIE_Sodium_Core_Curve25519
  • generate() : RequestIdGenerator , RequestIdGeneratorInterface , Randval , RandValInterface , CombGenerator , DefaultTimeGenerator , MtRandGenerator , OpenSslGenerator , PeclUuidRandomGenerator , PeclUuidTimeGenerator , RandomBytesGenerator , RandomGeneratorInterface , RandomLibAdapter , SodiumRandomGenerator , TimeGeneratorInterface
  • generate_identifier() : SSH2
  • generateAccessToken() : Client
  • generateAlias() : ContactTable
  • generateAliasAndName() : PlgUserContactCreator
  • generateCustomReduction() : EvalBarrett
  • generateFileHeader() : FormattedtextLogger
  • generateGroupTitle() : GroupModel
  • generateId() : RuntimeStorage , PHPMailer
  • generateInlineAdd() : EvalBarrett
  • generateInlineCompare() : EvalBarrett
  • generateInlineMultiply() : EvalBarrett
  • generateInlineSubtract1() : EvalBarrett
  • generateInlineSubtract2() : EvalBarrett
  • generateInlineTrim() : EvalBarrett
  • generateKey() : CryptoCipher , SodiumCipher , Crypto , OpenSSL , Sodium , CipherInterface , Crypt
  • generateManifestCache() : Installer
  • generateMediaVersion() : Version
  • generateMessage() : Assertion
  • generateNewTitle() : AdminModel , CategoryModel , FieldModel , ItemModel , ModuleModel , StyleModel , StageModel , TransitionModel , WorkflowModel
  • generateNonce() : Client
  • generateOteps() : UserModel
  • generatePassword() : LdapClient
  • generatePublicKeyCredentialCreationOptions() : Server
  • generatePublicKeyCredentialRequestOptions() : Server
  • generateRandUserId() : ConfigurationModel
  • generateRequestToken() : Client
  • generateSecret() : Totp
  • generateSymmetricKey() : PKCS1
  • generateThumbs() : Image
  • generateTitle() : AdminModel , BannerModel
  • generateV2Key() : PuTTY
  • generateV3Key() : PuTTY
  • genericlist() : Select
  • genericordering() : ListHelper
  • genRandomBytes() : Crypt
  • genRandomPassword() : UserHelper
  • gensalt_blowfish() : PasswordHash
  • gensalt_private() : PasswordHash
  • get() : Calculator , ListObject , Manager , Key , OpenHandler , FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , AbstractApplication , ConfigurationAwareApplicationInterface , Cache , CacheStorage , OutputController , PageController , ViewController , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , Categories , CategoryInterface , FtpClient , WritableContainerLoader , UserGroupsHelper , Files , Language , BaseLayout , AbstractView , CMSObject , Session , JoomlaStorage , Versioning , WebAssetRegistry , WebAssetRegistryInterface , Task , ContainerLoader , LoaderInterface , Container , FtpClient , Stream , Http , Files , Input , FileStorage , Registry , Router , RouterInterface , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , AlgorithmManager , JWK , JWKSet , BigInteger , DataSet , ValidationData , SFTP , ContainerInterface , Application , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader , HelperSet , AttestationStatement , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , CollectedClientData
  • get_channel_packet() : SSH2
  • get_debug_type() : Php80
  • get_interactive_channel() : SSH2
  • get_language() : ASCII
  • get_lines() : SMTP
  • get_lstat_cache_prop() : SFTP
  • get_meta_data() : Stream
  • get_open_channel() : SSH2
  • get_random_bytes() : PasswordHash , Bootup
  • get_resource_id() : Php80
  • get_stat_cache_prop() : SFTP
  • get_xstat_cache_prop() : SFTP
  • getA() : Binary , Prime , TwistedEdwards
  • getAaguid() : AttestedCredentialData , MetadataStatement , MetadataTOCPayloadEntry , PublicKeyCredentialSource
  • getAaid() : MetadataStatement , MetadataTOCPayloadEntry
  • getAbbreviations() : Application
  • getAbbreviationSuggestions() : Application
  • getAccessors() : ConfirmButton , CustomButton , DropdownButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , ToolbarButton
  • getAccumulatedStatementsDuration() : TraceablePDO
  • getAction() : Sidebar , Response
  • getActionlogModel() : ExportModel , RemoveModel , RequestModel , ConfirmModel , RequestModel
  • getActionLogParams() : Joomla
  • getActions() : ContentHelper
  • getActionsFromData() : Access
  • getActionsFromFile() : Access
  • getActive() : AbstractMenu , MenuHelper
  • getActiveFilters() : ListModel
  • getActiveMethodNames() : CaptiveModel
  • getActiveOptions() : UsersHelper
  • getActivePositions() : ModulesModel
  • getAdapter() : Archive , Adapter , ApiController , ProviderManager
  • getAdapterName() : AdapterInterface , LocalAdapter
  • getAdapters() : Installer , ProviderInterface , PlgFileSystemLocal
  • getAddColumnSql() : DatabaseImporter
  • getAddDatasetCode() : JavascriptRenderer
  • getAddIndexSql() : PgsqlImporter
  • getAdditionalInformation() : AbstractCBORObject , CBORObject , UnsignedIntegerObject
  • getAdditionalUrlParam() : Pagination
  • getAddKeySql() : MysqlImporter , MysqliImporter
  • getAddSequenceSql() : PgsqlImporter
  • getAddUniqueSql() : PgsqlImporter
  • getAdminId() : PlgSampledataMultilang
  • getAdminTemplate() : StyleModel
  • getAdvancedModeLayoutData() : ColorField
  • getAdvancedRoute() : RouteHelper
  • getAffectedRows() : DatabaseDriver , DatabaseInterface
  • getAgentString() : Browser
  • getAjaxHandlerClass() : JavascriptRenderer
  • getAlg() : PublicKeyCredentialParameters
  • getAlgorithm() : Algorithms , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512 , RSA , RSAPKCS1 , RSAPSS , JWSVerifier , Sha256 , Sha384 , Sha512 , Hmac , Sha256 , Sha384 , Sha512 , OpenSSL , Sha256 , Sha384 , Sha512
  • getAlgorithmFromFormFile() : PlgUserToken
  • getAlgorithmId() : Sha256 , Sha384 , Sha512 , Signer , Sha256 , Sha384 , Sha512 , None , Sha256 , Sha384 , Sha512
  • getAlgorithms() : Manager , Algorithms
  • getAlgorithmsNegotiated() : SSH2
  • getAlias() : OpenSSH , Container , Manifest , PharInvocation
  • getAliases() : CronExpression , AbstractCommand , Command
  • getAliasLength() : Manifest
  • getAll() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , UserGroupsHelper , ListenersPriorityQueue
  • getAllCommands() : Application
  • getAllComponents() : ConfigHelper
  • getAllExtensionsFromDB() : ExtensionsListCommand
  • getAllLanguages() : ASCII
  • getAllowCredentials() : PublicKeyCredentialRequestOptions
  • getAllowed() : Rules
  • getAllowedAttrs() : Sanitizer
  • getAllowedMethods() : MethodNotAllowedException
  • getAllowedModulePositions() : CaptiveModel
  • getAllowedTags() : Sanitizer
  • getAllowedTypes() : OptionsResolverIntrospector
  • getAllowedUserGroups() : Token , PlgUserToken
  • getAllowedValues() : OptionsResolverIntrospector
  • getAllPrevious() : FlattenException
  • getAllPropertiesToRender() : OnGetApiFields
  • getAllRawData() : InstalledVersions
  • getAllRecipientAddresses() : PHPMailer
  • getAllRelationsToRender() : OnGetApiFields
  • getAllTemplateStyles() : TemplateModel
  • getAlterColumnSql() : PgsqlImporter
  • getAlterDbCharacterSet() : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver
  • getAlternativeDescriptions() : MetadataStatement
  • getAlternatives() : CommandNotFoundException
  • getAlterTableSql() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getAmountOfFiles() : Manifest
  • getAndCleanOutputBuffer() : HtmlErrorRenderer
  • getApcuPrefix() : ClassLoader
  • getApiRouter() : ApiApplication
  • getApiVersion() : Manifest
  • getApkPackageName() : Response
  • getApplication() : ApplicationEvent , Dispatcher , ErrorEvent , Factory , CMSPlugin , AbstractCommand , ConsoleEvent , Command
  • getApplicationDocument() : XmlDescriptor
  • getApplicationTitle() : MarkdownDescriptor
  • getArchive() : TemplateModel
  • getArgument() : AbstractEvent , EventInterface , Input , InputDefinition , InputInterface
  • getArgumentCount() : InputDefinition
  • getArgumentDefaults() : InputDefinition
  • getArgumentRequiredCount() : InputDefinition
  • getArguments() : AbstractEvent , Input , InputDefinition , InputInterface
  • getArray() : Input , StringController , Input
  • getArrayRecursive() : Input
  • getArrayString() : Php
  • getArticleId() : Router
  • getArticleRoute() : RouteHelper
  • getArticleSegment() : Router
  • getAssertionScheme() : MetadataStatement
  • getAsset() : WebAssetRegistryAssetChanged , WebAssetManager
  • getAssetAncestors() : Access
  • getAsseticCollection() : JavascriptRenderer
  • getAssetId() : Access , FieldTable
  • getAssetName() : Access
  • getAssetRules() : Access
  • getAssets() : DoctrineCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AssetProvider , ConfigCollector , MessagesCollector , PDOCollector , RequestDataCollector , DebugBarVarDumper , JavascriptRenderer , WebAssetManager , WebAssetManagerInterface , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , QueryCollector
  • getAssetState() : WebAssetManager
  • getAssetType() : Access , WebAssetRegistryAssetChanged
  • getAssignedArticleUrl() : ConsentBoxField
  • getAssignedCategoriesIds() : FieldsHelper
  • getAssignedCategoriesTitles() : FieldsHelper
  • getAssignedGroups() : UserModel
  • getAssignedMenuItemUrl() : ConsentBoxField
  • getAssignmentOptions() : ModulesHelper
  • getAssoc() : CategoriesModel , CategoryModel
  • getAssociation() : Workflow
  • getAssociationHtmlList() : AssociationsHelper
  • getAssociationList() : AssociationExtensionHelper , AssociationsHelper
  • getAssociations() : Associations , CategoriesHelper , AssociationsHelper , AssociationHelper , AssociationsHelper , AssociationHelper , AssociationsHelper , MenusHelper , AssociationsHelper , AssociationHelper
  • getAssociationsExtension() : AssociationServiceInterface
  • getAssociationsForItem() : AssociationExtensionInterface , AssociationsHelper
  • getAsString() : FlattenException
  • getAttachmentHint() : MetadataStatement
  • getAttachmentName() : MailTemplate
  • getAttachments() : PHPMailer
  • getAttestation() : PublicKeyCredentialCreationOptions
  • getAttestationCertificateKeyIdentifiers() : MetadataStatement , MetadataTOCPayloadEntry
  • getAttestationObject() : AuthenticatorAttestationResponse
  • getAttestationRootCertificates() : MetadataStatement
  • getAttestationStatementSupportManager() : Server
  • getAttestationType() : CertificateToolbox , PublicKeyCredentialSource
  • getAttestationTypes() : MetadataStatement
  • getAttestedCredentialData() : AuthenticatorData , PublicKeyCredentialSource
  • getAttribute() : TraceablePDO , Form , FormField , WebAssetItem , WebAssetItemInterface , ServerRequest , X509 , ServerRequestInterface , Entry
  • getAttributeKey() : Entry
  • getAttributes() : AllowedAttributes , AttributeInterface , OnGetApiAttributes , WebAssetItem , WebAssetItemInterface , ServerRequest , X509 , ServerRequestInterface , LinkInterface , Entry , Link , AbstractSerializer , Resource , SerializerInterface
  • getAttributeValue() : LdapUserProvider
  • getAttStmt() : AttestationObject , AttestationStatement
  • getAuthData() : AttestationObject , AuthenticatorData
  • getAuthenticationAlgorithm() : MetadataStatement
  • getAuthenticationAlgorithms() : MetadataStatement
  • getAuthenticationExtension() : ExtensionOutputError
  • getAuthenticationHelper() : Webauthn
  • getAuthenticationKey() : DerivedKeys
  • getAuthenticatorAttachment() : AuthenticatorSelectionCriteria
  • getAuthenticatorData() : AuthenticatorAssertionResponse
  • getAuthenticatorSelection() : PublicKeyCredentialCreationOptions
  • getAuthenticatorVersion() : MetadataStatement
  • getAuthMethodsToContinue() : SSH2
  • getAuthor() : CategoryNode
  • getAuthorisedCategories() : User
  • getAuthorisedGroups() : User
  • getAuthorisedViewLevels() : Access , User
  • getAuthority() : Uri , UriInterface
  • getAutocompleterCallback() : Question
  • getAutocompleterValues() : Question
  • getAvailableDriver() : HttpFactory
  • getAvailableFormats() : ServerDumpCommand
  • getAvailableTypes() : Microdata
  • getAvatar() : Credentials , Authentication
  • getB() : Binary , Prime , RgbPaletteEntry
  • getBaDesc() : VerificationMethodDescriptor
  • getBannerMessage() : SSH2
  • getBarCharacter() : ProgressBar
  • getBarOffset() : ProgressBar
  • getBarWidth() : ProgressBar
  • getBase() : Document , MenuHelper , CodeAccuracyDescriptor
  • getBaseName() : TracksModel , PharInvocation
  • getBasePart() : Accept , AcceptLanguage
  • getBasePath() : JavascriptRenderer , TemplateModel
  • getBasePoint() : Binary , Montgomery , Prime , TwistedEdwards
  • getBaseTemplateClass() : TraceableTwigEnvironment
  • getBaseUrl() : JavascriptRenderer
  • getBccAddresses() : PHPMailer
  • getBest() : AbstractNegotiator
  • getBinary() : ASNObject
  • getBinaryContent() : OctetString
  • getBinaryOperators() : TraceableTwigEnvironment
  • getBiometricStatusReports() : MetadataTOCPayloadEntry
  • getBitDepth() : DisplayPNGCharacteristicsDescriptor
  • getBitLength() : BigInteger
  • getBlockLength() : SymmetricKey , Hash
  • getBlockLengthInBytes() : SymmetricKey , Hash
  • getBlockNames() : TraceableTwigTemplate
  • getBlocks() : TraceableTwigTemplate
  • getBlockSize() : AesInterface , Mcrypt , OpenSSL
  • getBlockSlowdown() : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • getBody() : AbstractWebApplication , WebApplicationInterface , MessageInterface , HtmlErrorRenderer
  • getBorder() : DebugFormatterHelper
  • getBorderChars() : TableStyle
  • getBorderFormat() : TableStyle
  • getBoundary() : PHPMailer
  • getBounded() : DatabaseQuery , PreparableInterface
  • getBoundParams() : DebugMonitor
  • getBranch() : Taxonomy
  • getBranchTitles() : Taxonomy
  • getBrowser() : Browser
  • getBuffer() : Document , Profiler
  • getBuilder() : StringCodec , FeatureSet
  • getBundledCaBundlePath() : CaBundle
  • getButtonPath() : Toolbar
  • getButtons() : Editor , QuickIconHelper
  • getBytes() : Uuid , UuidInterface
  • getC() : EcdaaTrustAnchor
  • getCache() : TraceableTwigEnvironment , Factory , CacheModel
  • getCacheController() : Cache
  • getCacheFilename() : TraceableTwigEnvironment
  • getCacheKey() : Cache
  • getCaching() : Cache
  • getCaDesc() : VerificationMethodDescriptor
  • getCalendar() : Language
  • getCallerInfo() : Language
  • getCallStacks() : DebugMonitor
  • getCanonicalPath() : Helper
  • getCapabilities() : CapabilitiesModel
  • getCategories() : Router
  • getCategoriesId() : Router
  • getCategoriesSegment() : Router
  • getCategory() : CategoryServiceInterface , LegacyComponent , CategoryModel
  • getCategoryAssociations() : CategoryAssociationHelper
  • getCategoryId() : Router
  • getCategoryName() : TracksModel
  • getCategoryOrders() : BannersModel
  • getCategoryRoute() : RouteHelper
  • getCategorySegment() : Router
  • getCategoryWorkflowContext() : WorkflowServiceInterface , ContentComponent
  • getCcAddresses() : PHPMailer
  • getCellFormat() : TableCellStyle
  • getCellHeaderFormat() : TableStyle
  • getCellRowContentFormat() : TableStyle
  • getCellRowFormat() : TableStyle
  • getCellWidth() : Table
  • getCertificate() : StatusReport
  • getCertificateHashes() : CertificateToolbox
  • getCertificateNumber() : BiometricStatusReport , StatusReport
  • getCertificates() : CertificateTrustPath
  • getCertificationDescriptor() : BiometricStatusReport , StatusReport
  • getCertificationPolicyVersion() : BiometricStatusReport , StatusReport
  • getCertificationRequirementsVersion() : BiometricStatusReport , StatusReport
  • getCertLevel() : BiometricStatusReport
  • getCfg() : CMSApplication
  • getChain() : X509
  • getChallenge() : CollectedClientData , PublicKeyCredentialOptions
  • getChallengeTs() : Response
  • getChange() : WebAssetRegistryAssetChanged
  • getChangeColumnSql() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getChangeSequenceSql() : PgsqlImporter
  • getCharset() : TraceableTwigEnvironment , Document
  • getCheckForSelfUpdate() : UpdateModel
  • getChildren() : Construct , CategoryNode , ImmutableNodeInterface , CategoryModel
  • getChildToolbar() : AbstractGroupButton
  • getChoices() : ChoiceQuestion
  • getClaim() : Token
  • getClaims() : Token
  • getClass() : FlattenException
  • getClassCandidates() : ClassNotFoundErrorEnhancer
  • getClassDescription() : Identifier
  • getClassForValue() : OtherObjectManager , TagObjectManager
  • getClassList() : JLoader
  • getClassLoader() : Autoloader , DebugClassLoader
  • getClassMap() : ClassLoader
  • getClassName() : MVCFactory
  • getClassNameFromIncomplete() : FlattenException
  • getCleanMediaFieldValue() : MediaHelper
  • getClient() : LanguagesModel , InstalledModel , ModuleModel , PlgSampledataMultilang
  • getClientDataJSON() : AuthenticatorResponse
  • getClientFilename() : UploadedFile , UploadedFileInterface
  • getClientFromInput() : OverridesController
  • getClientId() : CMSApplication
  • getClientIdFromInput() : ItemsController , MenusController , ModulesController , StylesController
  • getClientInfo() : ApplicationHelper
  • getClientMediaType() : UploadedFile , UploadedFileInterface
  • getClientName() : TracksModel
  • getClientOptions() : BannersHelper , InstallerHelper , ModulesHelper , TemplatesHelper
  • getCliInput() : CliApplication
  • getClockSeqHiAndReserved() : Uuid
  • getClockSeqHiAndReservedHex() : Uuid , UuidInterface
  • getClockSeqLow() : Uuid
  • getClockSeqLowHex() : Uuid , UuidInterface
  • getClockSequence() : Uuid
  • getClockSequenceHex() : Uuid , UuidInterface
  • getCloner() : DebugBarVarDumper
  • getClonerOptions() : DebugBarVarDumper
  • getCode() : Totp , FlattenException
  • getCodec() : FeatureSet , UuidFactory
  • getCoefficient() : RSAKey
  • getCollation() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getCollectedEntries() : InMemoryLogger
  • getCollection() : Manager
  • getCollectionDetailsUrls() : UpdateModel
  • getCollector() : DebugBar
  • getCollectors() : AggregatedCollector , DebugBar
  • getColorType() : DisplayPNGCharacteristicsDescriptor
  • getColspan() : TableCell
  • getColumn() : ArrayHelper
  • getColumnAlias() : Table
  • getColumnSeparatorWidth() : Table
  • getColumnSql() : MysqlImporter , MysqliImporter , PgsqlImporter
  • getColumnStyle() : Table
  • getColumnWidth() : TextDescriptor
  • getCombinedNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getCombiningClass() : NamePrep
  • getCommand() : ApplicationDescription , ConsoleEvent , LazyCommand , ApplicationDescription , ConsoleEvent , HelperSet
  • getCommandAliasesText() : TextDescriptor
  • getCommandData() : JsonDescriptor
  • getCommandDocument() : XmlDescriptor
  • getCommandName() : Application
  • getCommands() : Application , ApplicationDescription
  • getComment() : AsymmetricKey
  • getCommonName() : CertificateSubject
  • getCommonWords() : Helper
  • getCompiler() : TraceableTwigEnvironment
  • getCompletionName() : CompletionInput
  • getCompletionType() : CompletionInput
  • getCompletionValue() : CompletionInput
  • getComponent() : ComponentHelper , Workflow , ComponentModel
  • getComponentName() : ApplicationHelper , ComponentHelper
  • getComponentOptions() : MessagesModel
  • getComponentRouter() : SiteRouter
  • getComponents() : ComponentHelper , DebugHelper
  • getComponentsWithConfig() : ConfigHelper
  • getComponentTagRoute() : RouteHelper
  • getComponentTagsRoute() : RouteHelper
  • getComposerRoot() : LinkStub
  • getCompression() : DisplayPNGCharacteristicsDescriptor
  • getConditionName() : Workflow
  • getConditions() : WorkflowServiceInterface
  • getConfig() : Propel2Collector , CliApplication , ConsoleApplication , WebApplication , Factory , SysinfoModel , Module
  • getConfiguredDatabaseType() : UpdateModel
  • getConnectedQuery() : PdoDriver
  • getConnection() : MemcachedStorage , RedisStorage , DatabaseDriver , DatabaseInterface , AdapterInterface , Adapter
  • getConnectionByResourceId() : SSH2
  • getConnectionCollation() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getConnectionEncryption() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getConnectionResource() : EntryManager
  • getConnections() : PDOCollector
  • getConnectionsGraph() : WebAssetManager
  • getConsoleInput() : Application
  • getConsoleMode() : Terminal
  • getConsoleOutput() : Application
  • getConstraints() : AssertionFailedException , InvalidArgumentException
  • getContactData() : PlgContentContact
  • getContactId() : Router
  • getContactRoute() : RouteHelper
  • getContacts() : MultilangstatusHelper
  • getContactSegment() : Router
  • getContactTable() : PlgUserContactCreator
  • getContainer() : AfterExtensionBootEvent , BeforeExtensionBootEvent , Factory
  • getContent() : AbstractString , AbstractTime , ASNObject , Construct , ExplicitlyTaggedObject , Boolean , Integer , NullObject , ObjectIdentifier , OctetString , UnknownObject , CertificateExtensions , IPAddress , SubjectAlternativeNames , Microdata , TracksModel , Task , Key , ConsoleSectionOutput , Stub
  • getContentCount() : Adapter
  • getContentExtras() : Helper
  • getContentlangs() : MultilangstatusHelper
  • getContentLanguages() : AssociationsHelper
  • getContentLength() : ASNObject
  • getContents() : CallbackStream , PhpInputStream , RelativeStream , Stream , StreamInterface
  • getContentTable() : ContentType
  • getContentType() : DocumentRenderer
  • getContentTypeLink() : ActionlogsHelper , MediaHelper
  • getContext() : OAuthCallbackEvent , QuickIconsEvent , EC , CliContextProvider , ContextProviderInterface , RequestContextProvider , SourceContextProvider
  • getContextFromInput() : FieldsController , GroupsController
  • getContextProviders() : ServerDumper , Connection
  • getContexts() : LegacyComponent , FieldsServiceInterface , ContactComponent , ContentComponent , UsersComponent , UsersHelper
  • getController() : ComponentDispatcher , Dispatcher , ResolvedRoute , Route
  • getControls() : JavascriptRenderer
  • getCookieParams() : ServerRequest , ServerRequestInterface
  • getCoreExtensionIds() : ExtensionHelper
  • getCoreExtensions() : ExtensionHelper
  • getCoreFile() : TemplateModel
  • getCoreList() : TemplateModel
  • getCoreUpdateNotification() : Joomlaupdate
  • getCount() : Usage , DatabaseDriver , DatabaseInterface , LanguageErrorsCollector , LanguageStringsCollector
  • getCounter() : CssMenu , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , PublicKeyCredentialSource
  • getCountry() : CertificateSubject , CSR
  • getCreateDatabaseQuery() : DatabaseDriver , MysqlDriver , MysqliDriver
  • getCreateDbQuery() : PgsqlDriver
  • getCredentialId() : AttestedCredentialData
  • getCredentialPublicKey() : AttestedCredentialData , PublicKeyCredentialSource
  • getCredentials() : ClientHelper
  • getCredentialsRepository() : Authentication
  • getCrossingChar() : TableStyle
  • getCrossingChars() : TableStyle
  • getCryptoStrength() : MetadataStatement
  • getCspNonce() : JavascriptRenderer
  • getCsvData() : ActionlogsHelper
  • getCurrent() : OutputFormatterStyleStack
  • getCurrentCert() : X509
  • getCurrentLanguage() : CMSHelper , ContentHelper
  • getCurrentLineIndentation() : Parser
  • getCurrentPosition() : Cursor
  • getCurrentRequestId() : DebugBar
  • getCurrentTimeInMilliseconds() : ProgressIndicator
  • getCurve() : ECDSA , ES256 , ES256K , ES384 , ES512 , EC , Identity
  • getCurveOid() : Ec2Key
  • getCustomHeaders() : PHPMailer
  • getD() : TwistedEdwards
  • getData() : Key , DebugBar , Rule , Rules , MessageRenderer , Form , BaseLayout , Pagination , CacheModel , ApplicationModel , ArchiveModel , StatisticsModel , InstalledModel , ProfileModel , RegistrationModel , PrivacyDashboardHelper , LanguageErrorsCollector , LanguageStringsCollector , Iconv , Normalizer , Mbstring , Relationship , Resource , ASCII , ExtensionDescriptor
  • getDataAsHeaders() : DebugBar
  • getDataAttributes() : FormField
  • getDatabase() : DatabaseDriver
  • getDatabaseInfo() : InfoCollector
  • getDataFormatter() : DataCollector , MessagesCollector , AbstractDataCollector
  • getDataFromTask() : PlgSystemTasknotification
  • getDataIfExists() : ASCII
  • getDataObject() : CMSHelper
  • getDate() : Factory , LocalAdapter , RogueListEntry
  • getDateFormat() : DatabaseDriver , DatabaseInterface
  • getDateTime() : DegradedUuid , Uuid , UuidInterface
  • getDbo() : Adapter , Factory , DatabaseHelper , BaseDatabaseModel , DatabaseModelInterface , Table , TableInterface
  • getDebug() : Language
  • getDebugActions() : DebugHelper , DebuggroupModel , DebuguserModel
  • getDebugLevel() : SMTP
  • getDebugMessages() : BaseLayout
  • getDebugOutput() : SMTP
  • getDefault() : Uninflected , Language , AbstractMenu , SiteMenu , MenuHelper , InputArgument , InputOption , Question , OptionsResolverIntrospector
  • getDefaultAnswer() : QuestionHelper
  • getDefaultCommands() : ConsoleApplication , Application
  • getDefaultContextProviders() : VarDumper
  • getDefaultDataFormatter() : DataCollector , AbstractDataCollector
  • getDefaultDescription() : Command
  • getDefaultEvent() : Dispatcher
  • getDefaultHelperSet() : Application
  • getDefaultHomeModule() : MultilangstatusHelper
  • getDefaultIncludePaths() : FileLayout
  • getDefaultInputDefinition() : ConsoleApplication , Application
  • getDefaultLanguage() : Helper
  • getDefaultLogger() : Propel2Collector
  • getDefaultName() : AbstractCommand , Command
  • getDefaultNormalizer() : ConfirmationQuestion
  • getDefaultProfileFieldValues() : PlgUserToken
  • getDefaults() : Route
  • getDefaultSchema() : PgsqlDriver
  • getDefaultStageByCategory() : Workflow
  • getDefaultTextFilters() : DatabaseModel
  • getDefaultValidator() : ChoiceQuestion
  • getDefaultVarDumper() : DataCollector
  • getDefinedOptions() : OptionsResolver
  • getDefinition() : Application , AbstractCommand , Application , Command , LazyCommand
  • getDenominator() : BigRational
  • getDependencies() : WebAssetItem , WebAssetItemInterface , ConfigProvider
  • getDependenciesForAsset() : WebAssetManager
  • getDeprecatedAliases() : JLoader
  • getDeprecation() : OptionsResolverIntrospector
  • getDeprecationMessage() : OptionsResolverIntrospector
  • getDescription() : Document , AbstractCommand , Command , InputArgument , InputOption , MetadataStatement
  • getDestination() : Patcher
  • getDetectBrowser() : SiteApplication
  • getDirection() : Document
  • getDirectory() : SysinfoModel
  • getDirectoryIterator() : LintCommand
  • getDirectoryTree() : TemplateModel
  • getDisabledUpdateSites() : UpdateModel
  • getDiscoverInstallSupported() : InstallerAdapter
  • getDispatcher() : EventAwareInterface , Component , ComponentInterface , LegacyComponent , Module , ModuleInterface
  • getDisplayLength() : ConsoleSectionOutput
  • getDisplayName() : ProviderInterface , PlgFileSystemLocal , PublicKeyCredentialUserEntity
  • getDisplayOptions() : DebugBarVarDumper
  • getDn() : LdapClient
  • getDN() : X509
  • getDn() : Entry
  • getDNProp() : X509
  • getDnString() : LdapBadge
  • getDocument() : CMSWebApplicationInterface , WebApplication , AbstractRenderer , RendererInterface , Factory
  • getDomain() : LocalizationCollector
  • getDownloadKey() : InstallerHelper
  • getDownloadKeyExistsSites() : InstallerHelper
  • getDownloadKeySupportedSites() : InstallerHelper
  • getDriver() : DatabaseFactory , ConnectionEvent
  • getDropColumnSql() : DatabaseImporter
  • getDropIndexSql() : PgsqlImporter
  • getDropKeySql() : MysqlImporter , MysqliImporter
  • getDropPrimaryKeySql() : MysqlImporter , MysqliImporter , PgsqlImporter
  • getDropSequenceSql() : PgsqlImporter
  • getDumper() : DebugBarVarDumper
  • getDumperOptions() : DebugBarVarDumper
  • getDumpHeader() : HtmlDumper
  • getDumpHeaderByDebugBar() : DebugBarHtmlDumper
  • getDuration() : TracedStatement
  • getEcdaaKeyId() : EcdaaKeyIdTrustPath
  • getEcdaaTrustAnchors() : MetadataStatement
  • getEditor() : EditorField , SysinfoModel
  • getEffectiveDate() : BiometricStatusReport , StatusReport
  • getElement() : Subject , NestingException , ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , InstallerAdapter , Result
  • getElementHref() : Helper
  • getElementId() : Subject
  • getElements() : Result , QueryElement
  • getElementsToRemove() : Resolver
  • getEmail() : CertificateSubject
  • getEmptyBarCharacter() : ProgressBar
  • getEmptyStateQuery() : ListModel , CategoriesModel , MapsModel , DiscoverModel , UpdateModel , ModulesModel , TagsModel
  • getEmptyStyle() : OutputFormatterStyleStack
  • getEnabledExtensions() : AssociationsHelper
  • getEncodedCoordinates() : EC
  • getEncodedPath() : LocalAdapter
  • getEncodedPayload() : JWS
  • getEncodedProtectedHeader() : Signature
  • getEncodedValue() : AbstractString , ASNObject , Construct , ExplicitlyTaggedObject , BitString , Boolean , GeneralizedTime , Integer , NullObject , ObjectIdentifier , OctetString , UTCTime , UnknownConstructedObject , UnknownObject , IPAddress , SubjectAlternativeNames
  • getEncoding() : Mbstring
  • getEncodingOptions() : JsonResponse
  • getEncryptionKey() : DerivedKeys
  • getEncryptionMode() : PKCS1
  • getEncryptionObject() : PKCS1
  • getEncryptionSettings() : DatabaseHelper
  • getEndMemory() : TracedStatement
  • getEndTime() : TracedStatement
  • getEngine() : SymmetricKey , DSA , EC , RSA , BigInteger
  • getEntries() : Sidebar , MetadataTOCPayload
  • getEntry() : LdapUser
  • getEntryManager() : AdapterInterface , Adapter , Ldap , LdapInterface
  • getEnvironment() : TraceableTwigTemplate
  • getEnvVariable() : CaBundle
  • getEofShortcut() : SymfonyQuestionHelper
  • getError() : ApplicationErrorEvent , ErrorEvent , CMSObject , ApplicationErrorEvent , CommandErrorEvent , UploadedFile , SMTP , UploadedFileInterface , ConsoleErrorEvent , FatalError , ZIPExtraction
  • getErrorCode() : TracedStatement
  • getErrorCodes() : Response
  • getErrorCount() : DatabaseModel
  • getErrorEnhancers() : ErrorHandler
  • getErrorExceptions() : LazyAssertionException
  • getErrorFiles() : Language
  • getErrorMessage() : TracedStatement
  • getErrorMsg() : LdapClient
  • getErrorOutput() : ConsoleOutput , ConsoleOutputInterface , OutputStyle
  • getErrors() : Form , CMSObject , POP3 , SSH2 , ResponseBag
  • getErrorsMessage() : DatabaseModel
  • getErrorStyle() : SymfonyStyle
  • getEstimated() : ProgressBar
  • getEvent() : Dispatcher
  • getEvents() : Dispatcher
  • getException() : TracedStatement
  • getExceptions() : ExceptionsCollector
  • getExcludeCredentials() : PublicKeyCredentialCreationOptions
  • getExcluded() : UserField , UserMessagesField
  • getExcludedTermIds() : Query
  • getExecutedStatements() : TraceablePDO
  • getExitCode() : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent
  • getExitStatus() : SSH2
  • getExpandedKey() : Aes
  • getExpectedDisplayType() : Microdata
  • getExpectedTypes() : Microdata
  • getExpire() : Session , SessionInterface
  • getExponent() : DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject , RSAKey , TPMAttestationStatementSupport
  • getExponents() : RSAKey
  • getExporter() : DatabaseDriver
  • getExpression() : CronExpression
  • getExt() : File
  • getExtension() : TraceableTwigEnvironment , Categories , X509
  • getExtensionDownloadKey() : InstallerHelper
  • getExtensionElementsForMenuItems() : MenuModel
  • getExtensionFromInput() : CategoriesController
  • getExtensionGroups() : InstallerHelper
  • getExtensionHelper() : AssociationsHelper , X509
  • getExtensionHelperClassName() : AssociationsHelper
  • getExtensionName() : AfterExtensionBootEvent , BeforeExtensionBootEvent , MessagesModel
  • getExtensionNameFromAsset() : Access
  • getExtensionRealName() : AssociationsHelper
  • getExtensionRecord() : ExtensionHelper
  • getExtensions() : TraceableTwigEnvironment , ExtensionsListCommand , SysinfoModel , TemplatesModel , X509 , AuthenticatorData , PublicKeyCredentialOptions
  • getExtensionsHelper() : X509
  • getExtensionsNameAndId() : ExtensionsListCommand
  • getExtensionType() : AfterExtensionBootEvent , BeforeExtensionBootEvent
  • getExtensionTypes() : InstallerHelper
  • getExtraFields() : LdapUser
  • getFacetId() : AuthenticatorAssertionResponseValidator
  • getFactory() : ContainerResource , Uuid
  • getFailedExecutedStatements() : TraceablePDO
  • getFallbackDirs() : ClassLoader
  • getFallbackDirsPsr4() : ClassLoader
  • getFallbackProperty() : Microdata
  • getFallbackType() : Microdata
  • getFeed() : FeedFactory , FeedHelper
  • getField() : FieldFactory , FieldFactoryInterface , Form
  • getFieldActions() : RulesRule
  • getFieldAttribute() : Form
  • getFieldName() : FormField
  • getFields() : Table , FieldsHelper , HtmlView , Item , StringCodec , DegradedUuid , Uuid , Parameters
  • getFieldset() : Form
  • getFieldsets() : Form
  • getFieldsHex() : Uuid , UuidInterface
  • getFieldsPluginId() : FieldsHelper
  • getFieldsTemplate() : AssociationExtensionHelper
  • getFieldTypes() : FieldsHelper
  • getFieldValue() : FieldModel
  • getFieldValues() : FieldModel
  • getFieldXml() : Form
  • getFile() : AdapterInterface , ApiModel , TemplateModel , LocalAdapter , FlattenException , SilencedErrorContext
  • getFileData() : Zip
  • getFileHandle() : Stream
  • getFileInformation() : FileModel
  • getFileLink() : HtmlErrorRenderer
  • getFileName() : LocalAdapter
  • getFilenameFromUrl() : InstallerHelper
  • getFilePosition() : Gzip
  • getFileRelative() : HtmlErrorRenderer
  • getFiles() : AdapterInterface , ApiController , ApiModel , TemplateModel , LocalAdapter , LintCommand
  • getFileType() : TracksModel
  • getFilter() : TraceableTwigEnvironment , FilterModel , Parameters , DisplayPNGCharacteristicsDescriptor
  • getFilterForm() : ListModel , ActionlogsModel , ArticlesModel , FieldsModel , UsersModel , TransitionsModel , WorkflowsModel
  • getFilterInstance() : Image
  • getFilters() : TraceableTwigEnvironment , FinderIndexCommand , FilesystemHelper , Sidebar , Helper
  • getFinderPluginId() : FinderHelper
  • getFingerprint() : PublicKey
  • getFirstArgument() : ArgvInput , ArrayInput , InputInterface
  • getFirstChild() : Construct
  • getFirstDay() : Language
  • getFlags() : Manifest
  • getFlippedSubstitutions() : Substitutions
  • getFmt() : AttestationStatement
  • getFolder() : RandomImageHelper
  • getFolders() : InstalledModel , MenutypesModel
  • getFont() : TemplateModel
  • getFontInfo() : PlgEditorCodemirror
  • getFooterTitleFormat() : TableStyle
  • getForm() : ChecksModel , LanguagesModel , SetupModel , FormModelInterface , HtmlView , AssociationModel , BannerModel , ClientModel , DownloadModel , CategoryModel , ApplicationModel , ComponentModel , ConfigModel , ModulesModel , TemplatesModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , FilterModel , UpdateModel , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , FileModel , ItemModel , MenuModel , ConfigModel , MessageModel , ModuleModel , NewsfeedModel , PluginModel , RequestModel , ConfirmModel , RemindModel , RequestModel , LinkModel , TaskModel , TagModel , StyleModel , TemplateModel , GroupModel , LevelModel , MailModel , NoteModel , UserModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , TransitionModel , WorkflowModel
  • getFormat() : Factory
  • getFormatDefinition() : ProgressBar , ProgressIndicator
  • getFormats() : DescriptorHelper
  • getFormatter() : NullOutput , Output , OutputInterface , OutputStyle
  • getFormControl() : Form
  • getFormFile() : ContenthistoryHelper
  • getFormPath() : FieldsPlugin
  • getFormRoute() : RouteHelper
  • getFormSegment() : Router
  • getFormToken() : SessionAwareWebApplicationInterface , Session
  • getFormValues() : ContenthistoryHelper
  • getFractionalPart() : BigDecimal
  • getFragment() : AbstractUri , UriInterface , Uri , UriInterface
  • getFrom() : Substitution
  • getFromName() : TemplateModel
  • getFromTask() : ExecRuleHelper
  • getFunction() : TraceableTwigEnvironment
  • getFunctions() : TraceableTwigEnvironment
  • getG() : RgbPaletteEntry
  • getG1Curve() : EcdaaTrustAnchor
  • getGenerator() : Document , RandomGeneratorFactory , TimeGeneratorFactory
  • getGenericTableName() : DatabaseExporter
  • getGetFields() : FinderHelper
  • getGlobals() : TraceableTwigEnvironment
  • getGlue() : QueryElement
  • getGrant() : OAuth
  • getGroup() : Form , DebuggroupModel
  • getGroupId() : AddUserCommand , AddUserToGroupCommand , RemoveUserFromGroupCommand
  • getGroupPath() : Access
  • getGroups() : AddUserToGroupCommand , GetConfigurationCommand , RemoveUserFromGroupCommand , ChromestyleField , GroupedlistField , MenuField , MenuitemField , TemplatestyleField , TimezoneField , UserField , WorkflowstageField , ItemtypeField , FieldsModel , ContentmapField , MenuItemByTypeField , UserMessagesField , UsersHelper , UserModel
  • getGroupsByUser() : Access
  • getGroupTitle() : Access
  • getHandle() : Image
  • getHandleFromUserId() : CredentialRepository
  • getHandler() : Propel2Collector , NativeStorage
  • getHandlers() : Session
  • getHandlingSignal() : ConsoleSignalEvent
  • getHash() : ApplicationHelper , AsymmetricKey , DH , Hash , MetadataTOCPayloadEntry
  • getHashAlgorithm() : Hmac , HS256 , HS256Truncated64 , HS384 , HS512 , ECDSA , ES256 , ES256K , ES384 , ES512 , PS256 , PS384 , PS512 , PSSRSA , RS1 , RS256 , RS384 , RS512 , RSA , ECDSA , ES256 , ES256K , ES384 , ES512 , HMAC , HS1 , HS256 , HS256_64 , HS384 , HS512
  • getHashAlgorithmFor() : Algorithms
  • getHashedPassword() : AbstractUsernamePasswordAuthenticationStrategy , DatabaseStrategy , LocalStrategy
  • getHashMatch() : ContentHistory
  • getHeadData() : HtmlDocument
  • getHeader() : Signature , Request , Token , MessageInterface
  • getHeaderCheckerManager() : JWSLoader
  • getHeaderLine() : MessageInterface
  • getHeaderParameter() : Signature
  • getHeaders() : AbstractWebApplication , WebApplicationInterface , Request , Token , MessageInterface , FlattenException
  • getHeaderTitleFormat() : TableStyle
  • getHeight() : Image , Terminal , DisplayPNGCharacteristicsDescriptor
  • getHelp() : ItemModel , ModuleModel , PluginModel , StyleModel , AbstractCommand , Application , Command , LazyCommand
  • getHelper() : Module , HelperFactory , HelperFactoryInterface , Command , LazyCommand
  • getHelperSet() : Application , AbstractCommand , Application , Command , Helper , HelperInterface
  • getHelpSearch() : HelpModel
  • getHelpVersion() : Version
  • getHex() : Uuid , UuidInterface
  • getHexRegex() : Inline
  • getHiddenResponse() : QuestionHelper
  • getHistory() : ANSI
  • getHome() : BreadcrumbsHelper
  • getHomes() : MultilangstatusHelper
  • getHost() : AbstractUri , UriInterface , Uri , UriInterface , DumpServer
  • getHostname() : Response
  • getHref() : LinkInterface , Link
  • getHtmlCallGraph() : NamespacedTwigProfileCollector , TwigProfileCollector
  • getHttp() : HttpFactory
  • getHttpDriver() : DebugBar
  • getHTTPProtocol() : Browser
  • getHttpStatusValue() : AbstractWebApplication
  • getHttpTransports() : HttpFactory
  • getHumanReadableLogMessage() : ActionlogsHelper
  • getIcon() : JHtmlIcon , MetadataStatement , PublicKeyCredentialEntity
  • getIconClass() : CssMenu
  • getId() : FormField , Table , TableInterface
  • getID() : ProviderInterface
  • getId() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • getID() : PlgFileSystemLocal
  • getId() : AbstractSerializer , Resource , SerializerInterface , Credential , ExtensionDescriptor , PublicKeyCredentialDescriptor , PublicKeyCredentialRpEntity , PublicKeyCredentialUserEntity , TokenBinding
  • getIdentifier() : ASNObject , ExplicitlyTaggedObject , UnknownConstructedObject , UnknownObject
  • getIdentity() : CMSApplicationInterface
  • getIdentityInfo() : InfoCollector
  • getIfconfig() : SystemNodeProvider
  • getIgnoredCollectors() : JavascriptRenderer
  • getIgnoredSearchWords() : En_GBLocalise , Fr_FRLocalise , Language
  • getIgnoredSearchWordsCallback() : Language
  • getImage() : TemplateModel
  • getImageFileProperties() : Image
  • getImages() : RandomImageHelper
  • getImporter() : DatabaseDriver
  • getInclude() : Parameters
  • getIncluded() : Document
  • getIncludedTermIds() : Query
  • getIncludePaths() : FileLayout
  • getInfo() : SysinfoModel , OptionsResolver
  • getIniParserAvailability() : ChecksModel , UpdateModel
  • getInitialConfigurationOptions() : SetConfigurationCommand
  • getInitialization() : JavascriptRenderer
  • getInitializer() : ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • getInlineRelation() : WebAssetManager
  • getInput() : AbstractWebApplication , WebApplicationInterface , CliApplication , CMSApplicationInterface , ConsoleApplication , CalendarField , CaptchaField , CheckboxesField , ColorField , ComboField , ComponentlayoutField , ContenthistoryField , ContenttypeField , EditorField , EmailField , FileField , GroupedlistField , HiddenField , ListField , MediaField , MeterField , ModulelayoutField , ModuleorderField , ModulepositionField , NoteField , NumberField , OrderingField , PasswordField , RadiobasicField , RangeField , RulesField , SpacerField , SubformField , TagField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , Form , FormField , PrefixField , PlugininfoField , AssociationField , ClicksField , ImpmadeField , ImptotalField , CategoryeditField , FiltersField , FieldcontextsField , FieldLayoutField , SectionField , OAuthCallbackEvent , MenuOrderingField , MenutypeField , ModulesPositioneditField , WorkflowcontextsField , ConsentBoxField , TemplatesListField , UploaddirsField , PrivacyField , TermsField , JoomlatokenField , ConsoleEvent , Parameters
  • getInputArgumentData() : JsonDescriptor
  • getInputArgumentDocument() : XmlDescriptor
  • getInputDefinitionData() : JsonDescriptor
  • getInputDefinitionDocument() : XmlDescriptor
  • getInputForRequestMethod() : Input
  • getInputOptionData() : JsonDescriptor
  • getInputOptionDocument() : XmlDescriptor
  • getInputString() : ErrorListener
  • getInputToVerify() : JWSVerifier
  • getInstallationXML() : InstallerHelper
  • getInstalled() : InstalledVersions
  • getInstalledlangs() : LanguagesModel , PlgSampledataMultilang
  • getInstalledlangsAdministrator() : LanguagesModel , PlgSampledataMultilang
  • getInstalledlangsFrontend() : LanguagesModel , PlgSampledataMultilang
  • getInstalledPackages() : InstalledVersions
  • getInstalledPackagesByType() : InstalledVersions
  • getInstallFrom() : PlgInstallerWebinstaller
  • getInstallPath() : InstalledVersions
  • getInstance() : Inflector , CliApplication , CMSApplication , WebApplication , Authentication , Cache , CacheController , Captcha , Categories , FtpClient , Date , Document , Editor , Browser , Patcher , InputFilter , Form , UserGroupsHelper , Installer , Language , Mail , AbstractMenu , BaseController , Pathway , Profiler , Router , ChangeItem , ChangeSet , Session , Table , Toolbar , Updater , Uri , User , Language , Parser , DatabaseDriver , ContainerResource , FtpClient , Patcher , Inflector , ZIPExtraction
  • getInstances() : InstallerScript
  • getInstructions() : Result
  • getInteger() : Uuid , UuidInterface
  • getIntegralPart() : BigDecimal
  • getInterlace() : DisplayPNGCharacteristicsDescriptor
  • getInvalidParameter() : InvalidParameterException
  • getInvocations() : PharInvocationCollection
  • getInvTables() : Rijndael
  • getIp() : IpHelper
  • getIrregular() : Inflectible , Ruleset , Inflectible
  • getIsEmptyState() : ListModel
  • getIssuerDN() : X509
  • getIssuerDNProp() : X509
  • getItem() : AbstractMenu , AdminModel , ItemModelInterface , AssociationsHelper , CategoryModel , AssociationsHelper , ContactModel , FormModel , AssociationsHelper , ArticleModel , FormModel , FieldModel , GroupModel , Adapter , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , AdapterModel , MediumModel , AssociationsHelper , ItemModel , MenuModel , ConfigModel , MessageModel , ModuleModel , AssociationsHelper , NewsfeedModel , PluginModel , MessagesModel , TaskModel , TagModel , StyleModel , LevelModel , NoteModel , UserModel , TransitionModel
  • getItemArray() : InstallerScript
  • getItemId() : OrderingField
  • getItemid() : RouteHelper
  • getItemId() : PluginorderingField
  • getItemIdFromInput() : HistoryController
  • getItemMenuTitle() : Adapter
  • getItemRoute() : RouteHelper
  • getItems() : LanguagesModel , AbstractMenu , SiteMenu , ListModel , ListModelInterface , Toolbar , ClientsModel , BannersModel , CategoriesModel , CheckinModel , CategoriesModel , CategoryModel , FeaturedModel , ArticlesModel , CategoriesModel , CategoryModel , FeaturedModel , HistoryModel , Adapter , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , LanguagesModel , UpdatesitesModel , WarningsModel , TemplatesModel , FetchMediaItemsEvent , AdaptersModel , MediaModel , ItemsModel , MenusModel , PositionsModel , SelectModel , CategoriesModel , CategoryModel , Domain , SelectModel , TagsModel , TagModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , UsersModel , WorkflowsModel
  • getItemTags() : TagsHelper
  • getItemTypes() : AssociationExtensionHelper
  • getIterator() : InfiniteListObject , InfiniteMapObject , ListObject , MapObject , Construct , DataObject , DatabaseDriver , DatabaseFactory , ListenersPriorityQueue , Registry , Session , JWKSet , HelperSet , TableRows , Collection , Data , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , PublicKeyCredentialDescriptorCollection
  • getIV() : SymmetricKey
  • getJavascriptClass() : JavascriptRenderer
  • getJavascriptRenderer() : DebugBar
  • getJoomlaFilesExtensionId() : MessagesModel
  • getJoomlaUpdateSitesIds() : UpdatesitesModel
  • getJsControlsDefinitionCode() : JavascriptRenderer
  • getJSFPoints() : Prime
  • getJsInitializationCode() : JavascriptRenderer
  • getJson() : RequestController
  • getJwsPayload() : MetadataStatementFetcher
  • getJwsVerifier() : JWSLoader
  • getKey() : MapItem , ECKey , HMAC , HS256 , HS384 , HS512 , BaseSigner , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getKeyLength() : Ecdsa , Sha256 , Sha384 , Sha512 , SymmetricKey , RC2
  • getKeyLookup() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • getKeyName() : Table , TableInterface
  • getKeyProtection() : MetadataStatement
  • getKeys() : Container
  • getKeySql() : MysqlImporter , MysqliImporter
  • getKeyType() : Ecdsa , OpenSSL , Rsa
  • getKnownAuthenticators() : Authentication , MetadataRepository
  • getKnownColors() : ColorStyle
  • getKnownLanguages() : LanguageHelper
  • getKnownOptions() : ColorStyle
  • getLabel() : NoteField , SpacerField , Form , FormField , CategoryField , ContactField , ArticleField , MenuField , NewsfeedField , ConsentBoxField , PrivacyField , TosField , TermsField , RSA
  • getLangswitchers() : MultilangstatusHelper
  • getLangTag() : HelpModel
  • getLanguage() : CliApplication , CMSApplicationInterface , ConsoleApplication , WebApplication , Document , Factory , PlgExtensionFinder
  • getLanguageCookie() : PlgSystemLanguageFilter
  • getLanguageFilter() : SiteApplication
  • getLanguagefilterPluginId() : AssociationsHelper
  • getLanguageFromInput() : OverridesController
  • getLanguageId() : CMSHelper , ContentHelper
  • getLanguageList() : LanguagesModel , LoginHelper , PlgSampledataMultilang
  • getLanguageManifest() : LanguagesModel
  • getLanguagePath() : LanguageHelper
  • getLanguages() : SetupModel , LanguagesModel , TemplatesModel
  • getLastDateTimeErrors() : AbstractTime
  • getLastError() : SSH2
  • getLastErrorMessage() : File
  • getLastMessageID() : PHPMailer
  • getLastReply() : SMTP
  • getLastSFTPError() : SFTP
  • getLastTag() : Changelog
  • getLastTransactionID() : SMTP
  • getLayout() : ActionButton , HtmlView , ToolbarButton
  • getLayoutData() : AbstractModuleDispatcher , CalendarField , CheckboxesField , CheckboxField , ColorField , ComboField , ContenthistoryField , EmailField , FileField , HiddenField , MediaField , MeterField , ModuleorderField , NumberField , PasswordField , RadiobasicField , RadioField , RangeField , RulesField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , FormField , Dispatcher , ConsentBoxField , TinymcebuilderField , PrivacyField , DataField , TermsField , JoomlatokenField , PlgSystemStats
  • getLayoutFile() : HtmlView
  • getLayoutId() : FileLayout
  • getLayoutPath() : ModuleHelper , PluginHelper
  • getLayoutPaths() : FormField , WebcronLinkField , AbstractStatsField , JoomlatokenField , PlgSystemStats
  • getLayoutTemplate() : HtmlView
  • getLazyClosures() : OptionsResolverIntrospector
  • getLdapServiceId() : LdapBadge
  • getLE() : PHPMailer
  • getLeastSignificantBits() : Uuid
  • getLeastSignificantBitsHex() : Uuid , UuidInterface
  • getLeftSibling() : CategoryModel
  • getLegalHeader() : MetadataStatement , MetadataTOCPayload
  • getLength() : ByteStringObject , ByteStringWithChunkObject , TextStringObject , TextStringWithChunkObject , Hash , DSA , Base , EC , Hash , RSA , Engine , BigInteger , BinaryField , PrimeField
  • getLengthInBytes() : Base , Hash , Engine , BigInteger , BinaryField , PrimeField
  • getLengthOfArray() : LengthCalculator
  • getLengthOfString() : LengthCalculator
  • getLevelName() : SlimCollector
  • getLevelsOptions() : DebugHelper
  • getLexer() : TraceableTwigEnvironment
  • getLibrary() : LibraryHelper
  • getLimit() : Parameters
  • getLimitBox() : Pagination
  • getLine() : AbstractSerializer , FlattenException , SilencedErrorContext
  • getLineTag() : Parser
  • getLink() : Document , SyndicateHelper
  • getLinkKey() : MenusHelper
  • getLinkProvider() : PreloadManager , PreloadManagerInterface
  • getLinks() : LinkProviderInterface , GenericLinkProvider , AbstractSerializer , SerializerInterface
  • getLinksByRel() : LinkProviderInterface , GenericLinkProvider
  • getList() : ArticlesArchiveHelper , ArticlesCategoriesHelper , ArticlesCategoryHelper , ArticlesLatestHelper , ArticlesNewsHelper , ArticlesPopularHelper , BannersHelper , BreadcrumbsHelper , LanguagesHelper , LatestHelper , LoggedHelper , PopularHelper , SampledataHelper , StatsHelper , TagsPopularHelper , TagsSimilarHelper
  • getListenerPriority() : Dispatcher
  • getListeners() : Dispatcher , DispatcherInterface
  • getListFooter() : Pagination
  • getListQuery() : ListModel , ActionlogsModel , AssociationsModel , BannersModel , ClientsModel , TracksModel , BannersModel , CategoriesModel , ContactsModel , FeaturedModel , ArticlesModel , FeaturedModel , ArchiveModel , FeaturedModel , HistoryModel , FieldsModel , GroupsModel , Adapter , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , DiscoverModel , ManageModel , UpdateModel , UpdatesitesModel , LanguagesModel , TemplatesModel , ItemsModel , MenusModel , MessagesModel , ModulesModel , SelectModel , NewsfeedsModel , PluginsModel , ConsentsModel , RequestsModel , LinksModel , TasksModel , TagsModel , TagModel , TagsModel , StylesModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NotesModel , UsersModel , StagesModel , TransitionsModel , WorkflowsModel , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • getLoadedFormat() : AsymmetricKey
  • getLoader() : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f , TraceableTwigEnvironment
  • getLocale() : LocalizationCollector , Language , AsciiSlugger
  • getLocalise() : InstallationApplication
  • getLocaliseAdmin() : InstallationApplication
  • getLocality() : CertificateSubject
  • getLocalName() : CSR
  • getLocalPath() : LocalAdapter
  • getLog() : SSH2
  • getLogContentTypeParams() : ActionlogsHelper , ActionlogConfigModel
  • getLogDataAsIterator() : ActionlogsModel
  • getLogDataQuery() : ActionlogsModel
  • getLogFiles() : PlgSystemLogrotation
  • getLogger() : Propel2Collector , AbstractApplication
  • getLoggerClass() : LoggerRegistry
  • getLoginModule() : LoginModel
  • getLogs() : DebugMonitor
  • getLogsData() : ActionlogsModel
  • getLogsForItem() : ActionlogsModel
  • getLongVersion() : ConsoleApplication , Version , Application
  • getLookupValue() : ContenthistoryHelper
  • getLowerLimitSearchWord() : En_GBLocalise , Fr_FRLocalise , Language
  • getLowerLimitSearchWordCallback() : Language
  • getLowestSetBit() : BigInteger
  • getMachineContent() : Microdata
  • getMailer() : Factory
  • getMailMIME() : PHPMailer
  • getMajor() : Browser , Version
  • getMajorType() : AbstractCBORObject , CBORObject , UnsignedIntegerObject
  • getManagerState() : WebAssetManager
  • getManifest() : Installer , InstallerAdapter , Container
  • getManifestLength() : Manifest
  • getMantissa() : DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject
  • getMappedAlias() : Stub
  • getMapping() : X509
  • getMarks() : Profiler
  • getMaster() : TemplateModel
  • getMatcherProtection() : MetadataStatement
  • getMatchingRoutes() : ApiRouter
  • getMaxAttempts() : Question
  • getMaxRetries() : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • getMaxSteps() : ProgressBar
  • getMaxTemplates() : BiometricAccuracyDescriptor
  • getMaxUploadSize() : Utility
  • getMeasures() : TimeDataCollector , ProfileCollector
  • getMediaFiles() : TemplateModel
  • getMediaVersion() : Document , Version
  • getMemoryLimit() : DemoTasks
  • getMemoryLogs() : DebugMonitor
  • getMemoryUsage() : TraceablePDO , TracedStatement
  • getMenu() : CMSApplication , CMSWebApplicationInterface , InstallationApplication , AbstractMenu , ItemsModel
  • getMenuBadgeData() : DisplayController , DatabaseController , DiscoverController , DisplayController , UpdateController , DisplayController
  • getMenuItems() : MenusHelper
  • getMenuLanguage() : LoginModel
  • getMenuLinks() : MenusHelper
  • getMenuType() : ItemModel
  • getMenuTypeId() : ItemController , ItemModel
  • getMenuTypes() : MenusHelper
  • getMergeProperty() : AggregatedCollector
  • getMessage() : ProgressBar , FlattenException
  • getMessageQueue() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • getMessages() : MonologCollector , MessagesAggregateInterface , MessagesCollector , DumpServer
  • getMeta() : AbstractSerializer , SerializerInterface
  • getMetadata() : CategoryNode
  • getMetaData() : Document
  • getMetadata() : LanguageHelper , CallbackStream , RelativeStream , Stream , StreamInterface
  • getMetaData() : Manifest
  • getMetaDataLength() : Manifest
  • getMetadataRepository() : Authentication
  • getMetadataStatement() : DistantSingleMetadata , SingleMetadata
  • getMetadataStatementFor() : MetadataService
  • getMetadataTOCPayload() : MetadataService
  • getMethod() : MethodModel , Input , RequestInterface
  • getMethodArgs() : Container
  • getMethodId() : Router
  • getMethodImage() : CaptiveModel
  • getMethods() : MethodsModel , Route
  • getMethodSegment() : Router
  • getMfaMethods() : Mfa
  • getMGF1() : PSSRSA , RSA
  • getMGFHash() : RSA
  • getMimeEncoding() : Document
  • getMimeType() : MediaHelper , TracksModel
  • getMinComplexity() : PatternAccuracyDescriptor
  • getMinimum() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver
  • getMinimumServerVersion() : DatabaseHelper
  • getMinLength() : CodeAccuracyDescriptor
  • getMinor() : Browser , Version
  • getMissingDownloadKeyInfo() : PlgQuickiconDownloadkey
  • getMissingModuleLanguages() : MenusModel
  • getMissingOptions() : OptionsResolver
  • getModality() : BiometricStatusReport
  • getMode() : SymmetricKey
  • getModel() : BaseController , FormController , AbstractView , ViewInterface , ActionlogsController , AssociationsController , BannersController , ClientsController , TracksController , CategoriesController , ContactsController , ContactController , ArticlesController , FeaturedController , ArticleController , HistoryController , PreviewController , FieldsController , GroupsController , FiltersController , IndexController , MapsController , UpdatesitesController , LanguagesController , ApiController , DisplayController , ItemsController , MenusController , MessagesController , ModulesController , NewsfeedsController , PluginsController , RequestsController , LinksController , TasksController , TagsController , StylesController , TemplateController , GroupsController , LevelsController , NotesController , UsersController , StagesController , TransitionsController , WorkflowsController
  • getModelName() : WorkflowServiceInterface , ContentComponent
  • getModifiedDate() : Document
  • getModMenuId() : MenusModel
  • getModule() : ModuleHelper , MultilangstatusHelper
  • getModuleById() : ModuleHelper
  • getModules() : ModuleHelper , ItemModel , MenuModel , MenusModel , ModulesHelper
  • getModulo() : Binary , Prime , TwistedEdwards , Integer
  • getModulus() : RSAKey
  • getModulusLength() : RSAKey
  • getMonitor() : DatabaseDriver
  • getMostSignificantBits() : Uuid
  • getMostSignificantBitsHex() : Uuid , UuidInterface
  • getMultipleRunDates() : CronExpression
  • getMVCFactory() : LegacyComponent , MVCFactoryServiceInterface
  • getNAF() : Integer
  • getNAFPoints() : Prime
  • getName() : CacheCacheCollector , DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SlimCollector , SwiftLogCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , AggregatedCollector , ConfigCollector , DataCollectorInterface , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , RequestDataCollector , TimeDataCollector , Identifier , OID , CMSApplication , CMSApplicationInterface , ConsoleApplication , RouterView , JsonDocument , XmlDocument , SubformField , Form , FormField , InstallerAdapter , Language , BaseController , BaseModel , ModelInterface , WorkflowModelInterface , AbstractView , Toolbar , ToolbarButton , WebAssetItem , WebAssetItemInterface , Application , AbstractCommand , DescriptorHelper , DatabaseDriver , DatabaseInterface , QueryElement , AbstractEvent , EventInterface , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Basic , Claim , Application , Command , DebugFormatterHelper , DescriptorHelper , FormatterHelper , HelperInterface , ProcessHelper , QuestionHelper , InputArgument , InputOption , PublicKeyCredentialEntity
  • getNames() : WritableContainerLoader , ContainerLoader , LoaderInterface , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader
  • getNamesKey() : PgsqlDriver
  • getNamespaces() : JLoader , JNamespacePsr4Map , Application , ApplicationDescription , Application , ApplicationDescription
  • getNativeDefinition() : Command , LazyCommand
  • getNativeLanguage() : LanguageField
  • getNearestWeekday() : DayOfMonthField
  • getNegotiatedVersion() : SFTP
  • getNewInstance() : Container
  • getNewsfeedId() : Router
  • getNewsfeedRoute() : RouteHelper
  • getNewsfeedSegment() : Router
  • getNextEmbedBlock() : Parser
  • getNextOrder() : Table
  • getNextRunDate() : CronExpression
  • getNextUpdate() : MetadataTOCPayload
  • getNistCurveSize() : ECKey
  • getNo() : MetadataTOCPayload
  • getNode() : DegradedUuid , FallbackNodeProvider , RandomNodeProvider , SystemNodeProvider , NodeProviderInterface , Uuid
  • getNodeByTitle() : Taxonomy
  • getNodeHex() : Uuid , UuidInterface
  • getNodeProvider() : FeatureSet , UuidFactory
  • getNodeVisitors() : TraceableTwigEnvironment
  • getNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • getNonceAttribute() : JavascriptRenderer
  • getNonCoreExtensions() : UpdateModel
  • getNonCorePlugins() : UpdateModel
  • getNonDefaultOptions() : MemcachedCaster
  • getNormalizedData() : ByteStringObject , ByteStringWithChunkObject , CBORObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , BreakObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , TrueObject , UndefinedObject , SignedIntegerObject , Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject
  • getNormalizedValue() : BaseAccept
  • getNormalizer() : Question , OptionsResolverIntrospector
  • getNormalizers() : OptionsResolverIntrospector
  • getNote() : ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand
  • getNullDate() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver
  • getNumberConverter() : FeatureSet , Uuid , UuidFactory , UuidInterface
  • getNumberOfChildren() : Construct
  • getNumberOfColumns() : Table
  • getNumberOfLengthOctets() : ASNObject
  • getNumberOfUnusedBits() : BitString
  • getNumberUrgentRequests() : RequestsModel , PrivacyStatusHelper
  • getNumerator() : BigRational
  • getNumItems() : CategoryNode
  • getNumRecords() : MfaTable
  • getNumRows() : DatabaseDriver , DatabaseInterface
  • getOAuth() : PHPMailer
  • getOauth64() : OAuth , OAuthTokenProvider
  • getObjectLength() : ASNObject
  • getObjectsKeys() : DataSet
  • getOffset() : ParserException , Parameters
  • getOffsetFromGmt() : Date
  • getOffsetFromNumber() : Parameters
  • getOID() : ASN1
  • getOnlineCount() : WhosonlineHelper
  • getOnlineUserNames() : WhosonlineHelper
  • getOpenHandlerClass() : JavascriptRenderer
  • getOpenHandlerUrl() : JavascriptRenderer
  • getOpensslAlgorithmFor() : Algorithms
  • getOpensslCurveName() : ECKey
  • getOperatingEnv() : MetadataStatement
  • getOption() : ActionButton , ToolbarButton , WebAssetItem , WebAssetItemInterface , InstalledModel , PdoDriver , AbstractTransport , Http , Client , Input , InputDefinition , InputInterface , Connection , ConnectionOptions
  • getOptionConstants() : MemcachedCaster
  • getOptionDefaults() : InputDefinition
  • getOptionForShortcut() : InputDefinition
  • getOptionFromToken() : CompletionInput
  • getOptionName() : ConnectionOptions
  • getOptions() : ActionButton , SetConfigurationCommand , AccesslevelField , AliastagField , AuthorField , CachehandlerField , CategoryField , ComponentsField , ContentlanguageField , ContenttypeField , DatabaseconnectionField , FilelistField , FolderlistField , FrontendlanguageField , HeadertagField , ImagelistField , IntegerField , LanguageField , LimitboxField , ListField , ModuletagField , PluginsField , PredefinedlistField , SessionhandlerField , SqlField , TagField , TextField , TransitionField , UsergrouplistField , WorkflowComponentSectionsField , WorkflowconditionField , LanguageField , ChecksModel , DatabaseModel , LanguagesModel , SetupModel , BaseLayout , ToolbarButton , WebAssetItem , WebAssetItemInterface , ExtensionField , LogcreatorField , LogtypeField , ItemlanguageField , BannerclientField , CategoryeditField , ComponentsCategoryField , ConfigComponentsField , ComponentsFieldgroupField , ComponentsFieldsField , FieldcontextsField , FieldgroupsField , SubfieldsField , TypeField , BranchesField , ContenttypesField , SearchfilterField , ExtensionstatusField , FolderField , LocationField , PackageField , TypeField , LanguageclientField , MenuOrderingField , MenuParentField , MenuPresetField , MessageStatesField , ModulesModuleField , ModulesPositionField , NewsfeedsField , PluginElementField , PluginTypeField , RedirectField , CronField , TaskTypeField , TemplatelocationField , TemplatenameField , GroupparentField , LevelsField , ComponentsWorkflowField , WorkflowcontextsField , FontsField , TemplatesListField , UploaddirsField , TableCellStyle , Input , InputDefinition , InputInterface
  • getOptionsFromField() : FieldsListPlugin , PlgFieldsSubform
  • getOptionSuggestions() : CompletionSuggestions
  • getOrder() : Base
  • getOrderedElements() : AbstractNegotiator
  • getOrganization() : CertificateSubject
  • getOrganizationalUnit() : CertificateSubject , CSR
  • getOrganizationName() : CSR
  • getOrientation() : Image
  • getOrientationString() : Image
  • getOrigin() : CollectedClientData
  • getOrphans() : Language
  • getOtherInformationMessage() : DatabaseModel
  • getOtpConfig() : UserModel
  • getOtpConfigEncryptionKey() : UserModel
  • getOutput() : CliApplication , ConsoleEvent
  • getOverridePluginId() : PlgQuickiconOverrideCheck
  • getOverrides() : OverridesModel
  • getOverridesFolder() : TemplateModel
  • getOverridesList() : TemplateModel
  • getOwnFields() : Resource
  • getOwnInterfaces() : DebugClassLoader
  • getPackageUrl() : LanguagesModel
  • getPadByAlign() : TableCellStyle
  • getPadding() : RSA
  • getPaddingChar() : TableStyle
  • getPaDesc() : VerificationMethodDescriptor
  • getPadType() : TableStyle
  • getPage() : HelpModel , Parameters
  • getPagesCounter() : Pagination
  • getPagesLinks() : Pagination
  • getPageTitle() : CaptiveModel , MethodModel
  • getPagination() : ListModel , CacheModel , CategoryModel , AdaptersModel , MediaModel
  • getPaginationLinks() : Pagination
  • getPaginationPages() : Pagination
  • getParam() : InstallerScript , User
  • getParameter() : BaseAccept
  • getParameterClassName() : OptionsResolver
  • getParameterOption() : ArgvInput , ArrayInput , InputInterface
  • getParameters() : TracedStatement , BaseAccept , DH , DSA , EC , ArgsStub , TPMAttestationStatementSupport
  • getParams() : SiteApplication , CategoryNode , ComponentHelper , ComponentRecord , LibraryHelper , Installer , AbstractMenu , MenuItem , FieldModel , WrapperHelper
  • getParamsFromField() : PlgFieldsSubform
  • getParent() : TraceableTwigTemplate , AdapterInstance , InstallerAdapter , ToolbarButton , ImmutableNodeInterface , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel
  • getParentLocale() : AsciiSlugger
  • getParsedBody() : ServerRequest , ServerRequestInterface
  • getParsedFile() : ParseException
  • getParsedLine() : ParseException
  • getParser() : TraceableTwigEnvironment , LintCommand
  • getParsers() : FeedFactory
  • getParts() : CronExpression
  • getPass() : AbstractUri , UriInterface
  • getPassphrase() : Key
  • getPassword() : Encrypt , LdapUser
  • getPasswordHash() : PHPassHandler
  • getPastTransition() : HoursField
  • getPath() : CategoryNode , RouterView , Image , LanguagesModel , Installer , FileLayout , Nested , InstalledModel , ApiController , AbstractUri , UriInterface , Uri , PlgSampledataMultilang , UriInterface
  • getPathInformation() : LocalAdapter
  • getPaths() : Language
  • getPathway() : CMSApplication , SiteApplication , Pathway
  • getPathwayNames() : Pathway
  • getPattern() : Pattern , Transformation , Route
  • getPayload() : JWT , JWS , JsonResponse , Token
  • getPBES1EncryptionObject() : PKCS8
  • getPBES1Hash() : PKCS8
  • getPBES1KDF() : PKCS8
  • getPBES2EncryptionObject() : PKCS8
  • getPeakMemoryUsage() : TraceablePDO
  • getPeakUsage() : MemoryCollector
  • getPeriod() : Totp
  • getPermissions() : Path
  • getPHPInfo() : SysinfoModel
  • getPhpInfoArray() : SysinfoModel
  • getPhpMaxExecTime() : ZIPExtraction
  • getPhpOptions() : ChecksModel , UpdateModel
  • getPhpOptionsSufficient() : ChecksModel
  • getPhpSettings() : ChecksModel , SysinfoModel , UpdateModel
  • getPhpSupport() : PlgQuickiconPhpVersionCheck
  • getPKCredentialRequestOptions() : Authentication
  • getPlaceholderFormatterDefinition() : ProgressBar , ProgressIndicator
  • getPlatform() : Browser
  • getPlatformPrefix() : Cache
  • getPlte() : DisplayPNGCharacteristicsDescriptor
  • getPlugin() : PluginHelper
  • getPluginState() : IndexModel
  • getPluginType() : Adapter
  • getPlural() : Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected
  • getPluralRuleset() : GenericLanguageInflectorFactory , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules
  • getPluralSuffixes() : En_GBLocalise , Fr_FRLocalise , Language
  • getPluralSuffixesCallback() : Language
  • getPort() : AbstractUri , UriInterface , Uri , UriInterface
  • getPositions() : ModulesModel , ModulesHelper , TemplatesHelper
  • getPrecision() : Engine , BigInteger
  • getPreferredFormat() : SerializerErrorRenderer
  • getPrefix() : DatabaseDriver
  • getPrefixes() : ClassLoader
  • getPrefixesPsr4() : ClassLoader
  • getPreloadManager() : Document
  • getPreparedId() : TracedStatement
  • getPresets() : MenusHelper
  • getPrettyName() : LazyString
  • getPrettyVersion() : InstalledVersions
  • getPreview() : TemplateModel
  • getPrevious() : FlattenException
  • getPreviousRunDate() : CronExpression
  • getPrimaryKey() : Table , UCMContent
  • getPrimaryLanguage() : Helper
  • getPrimes() : RSAKey
  • getPriority() : ListenersPriorityQueue
  • getPrivacyArticleId() : PlgSystemPrivacyconsent
  • getPrivacyConsentPluginId() : PrivacyHelper
  • getPrivacyItemId() : PlgSystemPrivacyconsent
  • getPrivacyPolicyInfo() : PrivacyStatusHelper
  • getPrivate() : Key
  • getPrivateExponent() : RSAKey
  • getPrivateKey() : Keychain , OpenSSL
  • getProcessedHelp() : AbstractCommand , Command , LazyCommand
  • getProcessor() : CliOutput
  • getProfile() : UserHelper
  • getProgress() : ProgressBar
  • getProgressBar() : SymfonyStyle
  • getProgressCharacter() : ProgressBar
  • getProgressPercent() : ProgressBar
  • getPrompt() : ChoiceQuestion
  • getProperties() : CMSObject
  • getProperty() : Microdata , DataObject
  • getPropertyPath() : AssertionFailedException , InvalidArgumentException
  • getProtectedHeader() : Signature
  • getProtectedHeaderParameter() : Signature
  • getProtocolFamily() : MetadataStatement
  • getProtocolVersion() : MessageInterface
  • getProvidedServices() : ServiceProviderInterface
  • getProvider() : ProviderManager
  • getProviderManager() : MediaProviderEvent
  • getProviderName() : ProviderAwareAuthenticationPluginInterface
  • getProviders() : MediaModel , ProviderManager
  • getPubKeyCreationOptions() : Authentication
  • getPubKeyCredParams() : PublicKeyCredentialCreationOptions
  • getPubKeyDescriptorsForUser() : Credentials , Authentication
  • getPubkeyRequestOptions() : Authentication
  • getPublic() : Key
  • getPublicExponent() : RSAKey
  • getPublicKey() : CSR , Keychain , OpenSSL , PrivateKey , X509 , Identity
  • getPublicKeyAlgAndEncoding() : MetadataStatement
  • getPublicKeyAlgAndEncodings() : MetadataStatement
  • getPublicKeyCredentialDescriptor() : PublicKeyCredential , PublicKeyCredentialSource
  • getPublicKeyCredentialId() : PublicKeyCredentialSource
  • getPunycodePrefix() : AbstractPunycode , PunycodeInterface
  • getQuality() : BaseAccept
  • getQuery() : OrderingField , SearchModel , PluginorderingField , DatabaseDriver , DatabaseFactory , DatabaseInterface , ExecutionFailureException , FinderHelper , AbstractUri , UriInterface , Uri , UriInterface
  • getQueryCount() : Propel2Collector
  • getQueryDate() : QueryHelper
  • getQueryParams() : ServerRequest , ServerRequestInterface
  • getQueryString() : LdapBadge
  • getQuestion() : Question
  • getQuickiconContent() : DisplayController , CategoriesController , DisplayController , ArticlesController , ItemsController , ModulesController , PluginsController , TagsController , UsersController
  • getR() : RgbPaletteEntry
  • getRandom() : PgsqlDriver
  • getRandomGenerator() : FeatureSet , UuidFactory
  • getRandomImage() : RandomImageHelper
  • getRangeForExpression() : AbstractField
  • getRangeOptions() : UsersHelper
  • getRaw() : Json
  • getRawAttestationObject() : AttestationObject
  • getRawBytes() : Key
  • getRawData() : InstalledVersions , CollectedClientData
  • getRawId() : PublicKeyCredential
  • getRealCurrentLineNb() : Parser
  • getRealTableName() : DatabaseImporter
  • getRealUsage() : MemoryCollector
  • getReason() : MailDisabledException
  • getReasonPhrase() : Response , ResponseInterface
  • getRecord() : Task
  • getRecords() : CaptiveModel
  • getRedirectMessage() : PlgSystemPrivacyconsent
  • getRedirectPluginId() : RedirectHelper
  • getRedirectToItemAppend() : FormController , CategoryController , ContactController , ArticleController , FieldController , GroupController , LanguageController , TemplateController , ModuleController , NoteController , StageController , TransitionController , WorkflowController
  • getRedirectToListAppend() : AdminController , FormController , CategoriesController , CategoryController , HistoryController , FieldController , GroupController , ItemsController , ModuleController , ModulesController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController
  • getRedirectUrl() : Installer
  • getRedisOptions() : RedisCaster
  • getRef() : StringController
  • getReference() : InstalledVersions
  • getRegex() : Pattern , Route
  • getRegisteredExtension() : X509
  • getRegisteredLoaders() : ClassLoader
  • getRegistrationUrl() : LoginHelper
  • getRegistry() : WebAssetManager
  • getRegistryFiles() : WebAssetRegistry
  • getRegular() : Ruleset
  • getRelationship() : OnGetApiRelation , AbstractSerializer , SerializerInterface
  • getRelationshipMethodName() : AbstractSerializer
  • getRelationships() : Resource
  • getRelationshipsAsArray() : Resource
  • getRelativeRoot() : JavascriptRenderer
  • getRelevantToken() : CompletionInput
  • getRels() : LinkInterface , Link
  • getRemaining() : ProgressBar
  • getRenderedTemplates() : TraceableTwigEnvironment
  • getRenderer() : AbstractRenderer , FormField , PlgSystemStats
  • getRenderOptions() : MethodModel
  • getReorderConditions() : AdminModel , BannerModel , CategoryModel , ContactModel , ArticleModel , FeatureModel , FieldModel , GroupModel , ItemModel , ModuleModel , NewsfeedModel , PluginModel , StagesModel , TransitionsModel , WorkflowModel
  • getReplacement() : Transformation
  • getReplyToAddresses() : PHPMailer
  • getRequest() : NetworkExceptionInterface , RequestExceptionInterface
  • getRequestDuration() : TimeDataCollector , ProfileCollector
  • getRequestEndTime() : TimeDataCollector , ProfileCollector
  • getRequestFormPublished() : PrivacyStatusHelper
  • getRequestIdGenerator() : DebugBar
  • getRequestLine() : Serializer
  • getRequestStartTime() : TimeDataCollector , ProfileCollector
  • getRequestTarget() : RequestInterface
  • getRequiredOptions() : OptionsResolver
  • getRequiredTermIds() : Query
  • getReservedForFutureUse1() : AuthenticatorData
  • getReservedForFutureUse2() : AuthenticatorData
  • getResetCompleteForm() : ResetModel
  • getResetConfirmForm() : ResetModel
  • getResource() : AdapterInterface , Container , LocalAdapter , Connection , Query
  • getResourceId() : SSH2
  • getResources() : Query , Collection , ElementInterface , Resource
  • getResponse() : AbstractWebApplication , WebApplicationInterface , CurlTransport , SocketTransport , StreamTransport , UnexpectedResponseException , Curl , Socket , Stream , POP3 , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PublicKeyCredential
  • getResponseBody() : AndroidSafetyNetAttestationStatementSupport
  • getResponseInfo() : InfoCollector
  • getResult() : AbstractUsernamePasswordAuthenticationStrategy , AuthenticationStrategyInterface
  • getResults() : Authentication
  • getResultsCounter() : Pagination
  • getResultSnapshot() : ExecuteTaskEvent
  • getReturnPage() : ContactController , FormModel , ArticleController , FormModel
  • getReturnUri() : LoginHelper
  • getReturnUrl() : LoginHelper
  • getReverseLookup() : MenutypesModel
  • getRevoked() : X509
  • getRevokedCertificateExtension() : X509
  • getRevokedCertificateExtensions() : X509
  • getRightSibling() : CategoryModel
  • getRogueListHash() : MetadataTOCPayloadEntry
  • getRogueListURL() : MetadataTOCPayloadEntry
  • getRoles() : LdapUser
  • getRoot() : ImmutableNodeInterface
  • getRootId() : Nested
  • getRootPackage() : InstalledVersions
  • getRoute() : RouteHelper , InstallerAdapter
  • getRoutePath() : ApiRouter
  • getRouter() : AdministratorApplication , CMSApplication , CMSWebApplicationInterface , ConsoleApplication , SiteApplication
  • getRoutes() : Router , RouterInterface
  • getRouteVariables() : ResolvedRoute , Route
  • getRoutineId() : ExecuteTaskEvent
  • getRowColumns() : Table
  • getRowCount() : TracedStatement
  • getRowData() : CMSHelper , ContentHelper
  • getRowOffset() : Pagination
  • getRowspan() : TableCell
  • getRp() : PublicKeyCredentialCreationOptions
  • getRpId() : PublicKeyCredentialRequestOptions
  • getRpIdHash() : AuthenticatorData
  • getRules() : RouterView , Router , Table , Route
  • getRunDate() : CronExpression
  • getRunningTime() : ZIPExtraction
  • gets() : Stream
  • getSafeData() : SysinfoModel
  • getSafeName() : TemplateModel , LocalAdapter
  • getSalt() : LdapUser
  • getSaltLength() : RSA
  • getSaturation() : Color
  • getScale() : BigDecimal
  • getSchema() : ChangeSet
  • getSchemaVersion() : DatabaseModel
  • getScheme() : AbstractUri , UriInterface , Uri , UriInterface
  • getScore() : Response
  • getScreen() : ANSI
  • getScreenHelper() : ANSI
  • getScriptClassName() : PluginAdapter , InstallerAdapter
  • getScriptOptions() : Document
  • getScriptStrings() : Text
  • getSearchDisplayedCharactersNumber() : En_GBLocalise , Fr_FRLocalise , Language
  • getSearchDisplayedCharactersNumberCallback() : Language
  • getSearchDn() : LdapBadge
  • getSearchPassword() : LdapBadge
  • getSearchRoute() : RouteHelper
  • getSefString() : LanguageAdapter
  • getSelfAttestedFAR() : BiometricAccuracyDescriptor
  • getSelfAttestedFRR() : BiometricAccuracyDescriptor
  • getSentMIMEMessage() : PHPMailer
  • getSeqLookup() : PgsqlImporter
  • getSequenceIsCalled() : PgsqlDriver
  • getSequenceLastValue() : PgsqlDriver
  • getSerialised() : ZIPExtraction
  • getSerializer() : Resource
  • getSerializerManager() : JWSLoader
  • getServerAlgorithms() : SSH2
  • getServerExt() : SMTP
  • getServerExtList() : SMTP
  • getServerIdentification() : SSH2
  • getServerParams() : ServerRequest , ServerRequestInterface
  • getServerPublicHostKey() : SSH2
  • getServerType() : DatabaseDriver , DatabaseInterface
  • getService() : Registry
  • getServiceLocator() : ServiceLocatorTest
  • getServiceRegistry() : HTMLHelper
  • getSession() : SessionAwareWebApplicationInterface , CliApplication , ConsoleApplication , Factory , SessionEvent , ServiceProviderInterface
  • getSessionService() : SessionGcCommand
  • getSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • getSetvalSequenceSql() : PgsqlImporter
  • getSeverity() : SilencedErrorContext , ThrowableUtils
  • getSFTPErrors() : SFTP
  • getSFTPLog() : SFTP
  • getSha1() : ContentHistory
  • getSha1Hash() : HistoryModel
  • getShortcut() : InputOption
  • getShortHashedUserAgent() : UserHelper
  • getShortName() : Identifier
  • getShortVersion() : Version
  • getSibling() : CategoryNode , ImmutableNodeInterface
  • getSign() : BigDecimal , BigInteger , BigNumber , BigRational , DoublePrecisionFloatObject , HalfPrecisionFloatObject , SinglePrecisionFloatObject
  • getSignalRegistry() : Application
  • getSignature() : CSR , Indexer , JWS , Signature , ReflectionCaster , AuthenticatorAssertionResponse
  • getSignatureAlgorithm() : CSR
  • getSignatureAlgorithmManager() : JWSBuilder , JWSVerifier
  • getSignatureFormat() : DSA , EC
  • getSignatureLength() : Hmac , HS256 , HS256Truncated64 , HS384 , HS512
  • getSignatureMethod() : RSA
  • getSignaturePartLength() : ES256 , ES256K , ES384 , ES512 , ECDSA , ES256 , ES256K , ES384 , ES512
  • getSignatures() : JWS
  • getSignatureSubject() : CSR
  • getSignCount() : AuthenticatorData
  • getSimpleModeLayoutData() : ColorField
  • getSingleEntry() : Collection
  • getSingular() : Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected , Inflectible , Uninflected
  • getSingularRuleset() : GenericLanguageInflectorFactory , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules , InflectorFactory , Rules
  • getSiteHomePages() : Multilanguage
  • getSiteIcon() : Authentication
  • getSitesWithUpdates() : Updater
  • getSiteTemplates() : StyleModel
  • getSize() : CallbackStream , RelativeStream , Stream , UploadedFile , Stream , UploadedFile , StreamInterface , UploadedFileInterface , SplFixedArray
  • getSk() : RogueListEntry
  • getSliderModeLayoutData() : ColorField
  • getSlugColumn() : CategoryModel , ContactModel , ArchiveModel
  • getSMTPConnection() : SMTP
  • getSmtpErrorMessage() : PHPMailer
  • getSMTPInstance() : PHPMailer
  • getSnippet() : ParseException
  • getSort() : AggregatedCollector , Parameters
  • getSource() : Patcher , TemplateModel , Patcher
  • getSourceLink() : CliDumper , HtmlDumper
  • getSql() : TracedStatement
  • getSqlQuery() : PdoStorage
  • getSqlQuotationChar() : PDOCollector
  • getSqlWithParams() : TracedStatement
  • getStackDataSessionNamespace() : DebugBar
  • getStackedData() : DebugBar
  • getStackLocation() : Changelog
  • getStart() : ListModel , ArticlesModel , AdaptersModel , MediaModel
  • getStartMemory() : TracedStatement
  • getStartTime() : TracedStatement , ProgressBar
  • getState() : CertificateSubject , CSR , ActionButton , StatefulModelInterface , WorkflowModelInterface , Indexer , Session
  • getStateColumnForSection() : ContactComponent , NewsfeedsComponent
  • getStatements() : Propel2Collector , QueryCollector
  • getStateOptions() : InstallerHelper , MessagesHelper , ModulesHelper , UsersHelper
  • getStateQuery() : Adapter , PlgFinderCategories , PlgFinderTags
  • getStaticHeaderConfiguration() : PlgSystemHttpHeaders
  • getStats() : StatsAdminHelper
  • getStatsData() : PlgSystemStats
  • getStatus() : ChangeSet , MultilangstatusHelper , ResponseBag , StatusReport , TokenBinding
  • getStatusCode() : Response , ResponseInterface , FlattenException
  • getStatusLine() : Serializer
  • getStatusReports() : MetadataTOCPayloadEntry
  • getStatusText() : FlattenException
  • getStdError() : SSH2
  • getStepWidth() : ProgressBar
  • getStorage() : DebugBar
  • getStoreId() : ItemModel , ListModel , AssociationsModel , BannersModel , ClientsModel , BannersModel , CacheModel , CategoriesModel , ContactsModel , CategoriesModel , ArticlesModel , CategoriesModel , FeaturedModel , FieldsModel , GroupsModel , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , LanguagesModel , UpdatesitesModel , InstalledModel , LanguagesModel , ItemsModel , MessagesModel , ModulesModel , SelectModel , NewsfeedsModel , CategoriesModel , PluginsModel , ConsentsModel , RequestsModel , LinksModel , TasksModel , TagsModel , StylesModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NotesModel , UsersModel
  • getStores() : Cache
  • getStream() : Factory , Stream , UploadedFile , UploadedFileInterface , Input , StreamableInputInterface , StreamOutput
  • getStringFromOption() : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , RemoveUserFromGroupCommand
  • getStringPositionSql() : PgsqlDriver
  • getSttyColumns() : Terminal
  • getStub() : Data , Container
  • getStyle() : ColorStyle , NullOutputFormatter , OutputFormatter , OutputFormatterInterface , Table , TableCell
  • getStyleDefinition() : Table
  • getStylesheet() : HtmlErrorRenderer
  • getStyleStack() : OutputFormatter
  • getSubfieldsFromField() : PlgFieldsSubform
  • getSubject() : Usage
  • getSubjectDN() : X509
  • getSubjectDNProp() : X509
  • getSubPart() : Accept , AcceptLanguage
  • getSubpart() : Mbstring
  • getSubscribedEvents() : SubscriberInterface , Taggable , Versionable , Email , Fixed , Totp , Webauthn , Yubikey , Joomlaupdate , Cache , Shortcut , Webauthn , Checkfiles , DemoTasks , Requests , SiteStatus , PlgSystemDebug , PlgSystemHttpHeaders , PlgSystemJooa11y , PlgSystemRedirect , PlgSystemSchedulerunner , PlgSystemTasknotification , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing , ErrorListener , CheckLdapCredentialsListener , AddLinkHeaderListener
  • getSubscribedServices() : ServiceSubscriberInterface
  • getSubscribedSignals() : SignalableCommandInterface
  • getSuffixes() : FileLayout
  • getSuggestions() : SuggestionsController
  • getSuperUsers() : PlgSystemUpdatenotification
  • getSupported() : FilesystemHelper , Helper
  • getSupportedCompressionAlgorithms() : SSH2
  • getSupportedEncryptionAlgorithms() : SSH2
  • getSupportedExtension() : AssociationsHelper
  • getSupportedExtensions() : AssociationsHelper , MetadataStatement
  • getSupportedHostKeyAlgorithms() : SSH2
  • getSupportedKEXAlgorithms() : SSH2
  • getSupportedKeyFormats() : AsymmetricKey
  • getSupportedMACAlgorithms() : SSH2
  • getSupportedShells() : DumpCompletionCommand
  • getSupportedStatus() : TokenBinding
  • getSupportedVersions() : SFTP
  • getSupportTemplate() : AssociationExtensionHelper
  • getSx() : EcdaaTrustAnchor
  • getSy() : EcdaaTrustAnchor
  • getSynopsis() : AbstractCommand , Command , LazyCommand , InputDefinition
  • getSysfs() : SystemNodeProvider
  • getSystemCaRootBundlePath() : CaBundle
  • getTable() : BaseDatabaseModel , WorkflowModelInterface , User , BannersModel , CategoryModel , FormModel , FeatureModel , FormModel , CompareModel , HistoryModel , PreviewModel , FieldModel , GroupModel , IndexModel , MapsModel , LanguageModel , TemplateModel , ItemModel , MenuModel , ModuleModel , PluginModel , ExportModel , RemoveModel , RequestModel , ConfirmModel , RemindModel , RequestModel , TaskModel , GroupModel , LevelModel , UserModel , StagesModel , TransitionsModel , WorkflowsModel
  • getTableColumns() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableCreate() : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableKeys() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableList() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • getTableName() : Table
  • getTableNameForSection() : BannersComponent , ContactComponent , ContentComponent , FieldsComponent , NewsfeedsComponent
  • getTables() : Rijndael
  • getTableSequences() : PgsqlDriver
  • getTag() : ExplicitlyTaggedObject , Language , SymmetricKey , TaggedValue , ExtensionDescriptor
  • getTagged() : Container
  • getTagId() : Base16EncodingTag , Base64EncodingTag , Base64UrlEncodingTag , BigFloatTag , DecimalFractionTag , EpochTag , GenericTag , NegativeBigIntegerTag , PositiveBigIntegerTag , TimestampTag , TagObject
  • getTagIds() : TagsHelper
  • getTagItemsQuery() : TagsHelper
  • getTagNames() : TagsHelper
  • getTagNumber() : Identifier
  • getTagOptions() : TableCellStyle
  • getTagRoute() : RouteHelper
  • getTags() : TraceableTwigEnvironment , AllowedTags , TagInterface
  • getTagsHelper() : TaggableTableInterface
  • getTagsRoute() : RouteHelper
  • getTagsTitle() : HtmlView
  • getTagTreeArray() : TagsHelper
  • getTargetMinimumPHPVersion() : UpdateModel
  • getTarInfo() : Tar
  • getTask() : BaseController , TaskModel
  • getTaskId() : ExecuteTaskEvent
  • getTasks() : TasksListCommand , BaseController
  • getTaxonomy() : Result , Taxonomy
  • getTcDisplay() : MetadataStatement
  • getTcDisplayContentType() : MetadataStatement
  • getTcDisplayPNGCharacteristics() : MetadataStatement
  • getTemplate() : AdministratorApplication , ApiApplication , CMSApplication , InstallationApplication , MailTemplate , TemplateModel
  • getTemplateClass() : TraceableTwigEnvironment
  • getTemplateClassPrefix() : TraceableTwigEnvironment
  • getTemplateInfo() : InfoCollector
  • getTemplateList() : TemplateModel
  • getTemplateModuleStyles() : ChromestyleField
  • getTemplateName() : TraceableTwigTemplate
  • getTemplateOptions() : TemplatesHelper
  • getTemplates() : ChromestyleField , ModulesHelper
  • getTest() : TraceableTwigEnvironment
  • getTests() : TraceableTwigEnvironment
  • getTimeDataCollector() : TraceableTwigEnvironment
  • getTimeGenerator() : FeatureSet , UuidFactory
  • getTimeHiAndVersion() : Uuid
  • getTimeHiAndVersionHex() : Uuid , UuidInterface
  • getTimeLeft() : ZIPExtraction
  • getTimeLow() : DegradedUuid , Uuid
  • getTimeLowHex() : Uuid , UuidInterface
  • getTimeMid() : Uuid
  • getTimeMidHex() : Uuid , UuidInterface
  • getTimeOfLastStatusChange() : MetadataTOCPayloadEntry
  • getTimeout() : SMTP , PublicKeyCredentialOptions
  • getTimestamp() : DegradedUuid , Uuid
  • getTimestampHex() : Uuid , UuidInterface
  • getTimestampRegex() : Inline
  • getTimezone() : User
  • getTimings() : DebugMonitor
  • getTitle() : Document , SpacerField , FormField , LatestHelper , LatestActionsHelper , LoggedHelper , PopularHelper
  • getTo() : Substitution
  • getToAddresses() : PHPMailer
  • getToc() : HelpModel
  • getToken() : Client , Session , SessionInterface , Builder , OAuth
  • getTokenBinding() : CollectedClientData
  • getTokenData() : Query
  • getTokenForDisplay() : JoomlatokenField , PlgUserToken
  • getTokenName() : PhpToken
  • getTokenParsers() : TraceableTwigEnvironment
  • getTokenSeedForUser() : Token , PlgUserToken
  • getTotal() : ListModel , CacheModel , CheckinModel , FilterModel , InstalledModel , OverridesModel , AdaptersModel , MediaModel , PositionsModel
  • getTotalIndexed() : IndexModel
  • getTPMHash() : TPMAttestationStatementSupport
  • getTrace() : CliRenderer , Language , FlattenException , SilencedErrorContext
  • getTraceAsString() : FlattenException
  • getTransitions() : ArticlesModel
  • getTranslatedModulePosition() : ModulesHelper
  • getTranslations() : PHPMailer
  • getTransliterator() : Language
  • getTransports() : FilesystemHelper , Helper , PublicKeyCredentialDescriptor , PublicKeyCredentialSource
  • getTree() : Nested
  • getTrustPath() : AttestationStatement , PublicKeyCredentialSource
  • getTwofactorform() : UserModel , ProfileModel
  • getTwoFactorMethods() : AuthenticationHelper , UsersHelper
  • getType() : ASNObject , ExplicitlyTaggedObject , BitString , BMPString , Boolean , CharacterString , Enumerated , GeneralizedTime , GeneralString , GraphicString , IA5String , Integer , NullObject , NumericString , ObjectDescriptor , ObjectIdentifier , OctetString , PrintableString , RelativeObjectIdentifier , Sequence , Set , T61String , UniversalString , UTCTime , UTF8String , VisibleString , UnknownConstructedObject , UnknownObject , Attributes , DNSName , IPAddress , SubjectAlternativeNames , AssociationExtensionHelper , Document , Microdata , UCMBase , UCMType , AssociationsHelper , Key , LoginHelper , BaseAccept , Data , AbstractSerializer , Resource , SerializerInterface , AttestationStatement , CollectedClientData , Credential , PublicKeyCredentialDescriptor , PublicKeyCredentialParameters , PublicKeyCredentialSource
  • getTypeAlias() : Category , Content , TaggableTableInterface , VersionableTableInterface , BannerTable , ClientTable , ContactTable , NewsfeedTable , TagTable , NoteTable
  • getTypeAliasFromInput() : HistoryController
  • getTypeByAlias() : UCMType
  • getTypeByTable() : UCMType
  • getTypeFieldName() : AssociationExtensionHelper , AssociationsHelper
  • getTypeFields() : AssociationExtensionHelper
  • getTypeIcon() : MediaHelper , TemplateHelper
  • getTypeId() : ContentType , UCMType , Adapter
  • getTypeIdFromInput() : HistoryController
  • getTypeInformation() : AssociationExtensionHelper
  • getTypeJoins() : AssociationExtensionHelper
  • getTypeName() : ASNObject
  • getTypeOptions() : MenutypesModel
  • getTypeOptionsByComponent() : MenutypesModel
  • getTypeOptionsFromLayouts() : MenutypesModel
  • getTypeOptionsFromManifest() : MenutypesModel
  • getTypeOptionsFromMvc() : MenutypesModel
  • getTypeOptionsFromXml() : MenutypesModel
  • getTypes() : TagsHelper , Microdata
  • getTypeSupport() : AssociationExtensionHelper
  • getTypeTables() : AssociationExtensionHelper
  • getTypeTitle() : AssociationExtensionHelper
  • getUnaryOperators() : TraceableTwigEnvironment
  • getUncompressedCoordinates() : Ec2Key
  • getUnfilteredRelationships() : Resource
  • getUninflected() : Ruleset
  • getUniqueId() : PlgSystemStats
  • getUnscaledValue() : BigDecimal
  • getUnscaledValueWithLeadingZeros() : BigDecimal
  • getUnsupportedAdapterType() : UnsupportedArchiveException
  • getUpdatedFiles() : PlgInstallerOverride
  • getUpdatedList() : TemplateModel
  • getUpdateFiles() : ChangeSet
  • getUpdateInfo() : CheckJoomlaUpdatesCommand
  • getUpdateInformation() : UpdateModel
  • getUpdateInformationFromModel() : CheckJoomlaUpdatesCommand
  • getUpdateModel() : UpdateCoreCommand
  • getUpdateQueries() : ChangeSet
  • getUpdateQueryByIds() : Adapter
  • getUpdateQueryByTime() : Adapter , PlgFinderTags
  • getUpdateSite() : LanguagesModel
  • getUpdateSiteName() : UpdateAdapter
  • getUpdateSiteResponse() : UpdateAdapter
  • getUpdateSites() : Updater
  • getUpdateSitesInfo() : UpdateModel
  • getUpdateSitesInformation() : InstallerHelper
  • getUploadedFiles() : ServerRequest , ServerRequestInterface
  • getUpperLimitSearchWord() : En_GBLocalise , Fr_FRLocalise , Language
  • getUpperLimitSearchWordCallback() : Language
  • getUpv() : MetadataStatement
  • getUri() : WebAssetItem , WebAssetItemInterface , ResolvedRoute , Stream , RequestInterface
  • getUrl() : Totp , BannerModel , Adapter , AdapterInterface , ApiModel , LocalAdapter , MetadataTOCPayloadEntry , StatusReport
  • getUrn() : Uuid , UuidInterface
  • getUsages() : Command , LazyCommand
  • getUsed() : Language
  • getUseIncludePath() : ClassLoader
  • getUser() : Factory , AbstractMenu , DebuguserModel , NotesModel , AbstractUri , UriInterface , PublicKeyCredentialCreationOptions
  • getUserAgent() : Version
  • getUserDisplayedGroups() : UsersModel
  • getUserEntity() : Credentials , Authentication
  • getUserGroups() : AddUserCommand , RulesField , UserHelper , FiltersField
  • getUserHandle() : AuthenticatorAssertionResponse , PublicKeyCredentialSource
  • getUserHandleFor() : CredentialRepository
  • getUserId() : AddUserToGroupCommand , ConfigurationModel , UserHelper
  • getUserIdentifier() : LdapUser
  • getUserIdFromToken() : RegistrationModel
  • getUserInfo() : Uri , UriInterface
  • getUsername() : LdapUser
  • getUsers() : UsersLatestHelper
  • getUsersByGroup() : Access
  • getUsersFromGroup() : PlgWorkflowNotification
  • getUserState() : CMSApplication , CMSWebApplicationInterface
  • getUserStateFromRequest() : CMSApplication , CMSWebApplicationInterface , ListModel
  • getUserVerification() : AuthenticatorSelectionCriteria , VerificationMethodDescriptor , PublicKeyCredentialRequestOptions
  • getUserVerificationDetails() : MetadataStatement
  • getUseStatements() : DebugClassLoader
  • getUuidBuilder() : UuidFactory
  • getValidatableClaims() : Token
  • getValidator() : Question
  • getValidNode() : DefaultTimeGenerator
  • getValidTransition() : Workflow
  • getValue() : AssertionFailedException , InvalidArgumentException , ByteStringObject , ByteStringWithChunkObject , MapItem , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , Form , ArrayHelper , Basic , Claim , BaseAccept , Suggestion , Data , TaggedValue
  • getValueActions() : RulesRule
  • getValueAsIni() : Ini
  • getValueFromKey() : ArraySerializer
  • getValueFromNode() : Xml
  • getValueSuggestions() : CompletionSuggestions
  • getVar() : Router , AbstractUri , UriInterface
  • getVarDumper() : DataCollector , MessagesCollector
  • getVariable() : PharInvocation
  • getVariableName() : JavascriptRenderer
  • getVariant() : Uuid , UuidInterface
  • getVars() : Router
  • getVerbosity() : NullOutput , Output , OutputInterface , OutputStyle
  • getVerificationMethods() : VerificationMethodANDCombinations
  • getVerp() : SMTP
  • getVersion() : InstalledVersions , CSR , Browser , WebAssetItem , WebAssetItemInterface , Application , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , SqliteDriver , VersionHelper , Uuid , UuidInterface , Application
  • getVersionRanges() : InstalledVersions
  • getView() : DisplayController , BaseController , DisplayController
  • getViewLevels() : ItemModel
  • getViews() : RouterView
  • getVisibleByGroups() : UsersHelper
  • getWebAssetManager() : Document
  • getWebauthnServer() : Authentication
  • getWeekEnd() : Language
  • getWidgets() : DoctrineCollector , MonologCollector , NamespacedTwigProfileCollector , Propel2Collector , PropelCollector , SwiftMailCollector , TwigCollector , TwigProfileCollector , ConfigCollector , ExceptionsCollector , LocalizationCollector , MemoryCollector , MessagesCollector , PDOCollector , PhpInfoCollector , Renderable , RequestDataCollector , TimeDataCollector , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , ProfileCollector , QueryCollector , SessionCollector
  • getWidth() : Image , Terminal , DisplayPNGCharacteristicsDescriptor
  • getWindowColumns() : SSH2
  • getWindowRows() : SSH2
  • getWord() : Word
  • getWorkarounds() : Cache
  • getWorkflow() : StagesModel , TransitionModel , TransitionsModel
  • getWorkflowContexts() : WorkflowServiceInterface , ContentComponent
  • getWorkflowTableBySection() : WorkflowServiceInterface , ContentComponent
  • getWriteModes() : FilesystemHelper , Helper
  • getX() : EcdaaTrustAnchor
  • getXdebugLink() : NamespacedTwigProfileCollector , TwigProfileCollector , DataCollector
  • getXdebugLinkTemplate() : DataCollector
  • getXdebugReplacements() : DataCollector
  • getXdebugShouldUseAjax() : DataCollector
  • getXml() : Form
  • getXmlChildren() : Xml
  • getXmlIssues() : Sanitizer
  • getXMLOptions() : Sanitizer
  • getY() : EcdaaTrustAnchor
  • getYears() : ArchiveModel
  • getZeroPadding() : AbstractAES
  • ghash() : SymmetricKey
  • glob() : CaBundle
  • grapheme_extract() : Grapheme
  • grapheme_position() : Grapheme
  • grapheme_stripos() : Grapheme
  • grapheme_stristr() : Grapheme
  • grapheme_strlen() : Grapheme
  • grapheme_strpos() : Grapheme
  • grapheme_strripos() : Grapheme
  • grapheme_strrpos() : Grapheme
  • grapheme_strstr() : Grapheme
  • grapheme_substr() : Grapheme
  • greaterOrEqualThan() : Assertion
  • greaterThan() : Assertion , Assert
  • greaterThanEq() : Assert
  • group() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • groupBy() : ArticlesCategoryHelper
  • groupByDate() : ArticlesCategoryHelper
  • groupByTags() : ArticlesCategoryHelper
  • groupConcat() : QueryInterface , SqliteQuery , SqlsrvQuery
  • groupedlist() : Select
  • groups() : User
  • guardLeeway() : ValidAt
  • guessShell() : DumpCompletionCommand


Joomla CMS: Champs de donnée - Fonctions

- h -

  • h2c_string_to_hash() : ParagonIE_Sodium_Core_Ristretto255
  • h2c_string_to_hash_sha256() : ParagonIE_Sodium_Core_Ristretto255
  • h2c_string_to_hash_sha512() : ParagonIE_Sodium_Core_Ristretto255
  • handle() : OpenHandler , AuthenticationFailedExceptionHandler , CheckinCheckoutExceptionHandler , InvalidParameterExceptionHandler , InvalidRouteExceptionHandler , NotAcceptableExceptionHandler , NotAllowedExceptionHandler , ResourceNotFoundExceptionHandler , SaveExceptionHandler , SendEmailExceptionHandler , SignalRegistry , ErrorHandler , ExceptionHandlerInterface , FallbackExceptionHandler , InvalidParameterExceptionHandler
  • handleAuthor() : AtomParser
  • handleCategory() : RssParser
  • handleCloud() : RssParser
  • handleContributor() : AtomParser
  • handleCopyright() : RssParser
  • handleDefaultNamespace() : XPath
  • handleDescription() : RssParser
  • handleError() : ErrorHandler
  • handleException() : ExceptionHandler , ErrorHandler
  • handleFatalError() : ErrorHandler
  • handleGenerator() : AtomParser , RssParser
  • handleId() : AtomParser
  • handleImage() : RssParser
  • handleKey() : ECDSA , EdDSA , PSSRSA , RSA
  • handleLanguage() : RssParser
  • handleLastBuildDate() : RssParser
  • handleLink() : AtomParser , RssParser
  • handleManagingEditor() : RssParser
  • handleOldDatabase() : DatabaseModel
  • handlePreflight() : ApiApplication
  • handlePubDate() : RssParser
  • handler() : CryptoExceptionHandler
  • handleRights() : AtomParser
  • handleSignal() : SignalableCommandInterface
  • handleSkipDays() : RssParser
  • handleSkipHours() : RssParser
  • handleSubtitle() : AtomParser
  • handleTitle() : AtomParser , RssParser
  • handleTtl() : RssParser
  • handleUpdated() : AtomParser
  • handleUserDeprecatedErrors() : ExceptionHandler
  • handleWebmaster() : RssParser
  • hangulCompose() : NamePrep
  • hangulDecompose() : NamePrep
  • has() : Manager , Key , WritableContainerLoader , UserGroupsHelper , Session , JoomlaStorage , ContainerLoader , LoaderInterface , Container , ListenersPriorityQueue , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , AlgorithmManager , JWK , JWKSet , DataSet , ValidationData , ContainerInterface , Application , CommandLoaderInterface , ContainerCommandLoader , FactoryCommandLoader , HelperSet , Collectable , PharInvocationCollection , AttestationStatement , AttestationStatementSupportManager , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , CollectedClientData , PublicKeyCredentialDescriptorCollection
  • has8bitChars() : PHPMailer
  • hasArgument() : AbstractEvent , Input , InputDefinition , InputInterface
  • hasAssociationsSupport() : AssociationExtensionHelper , AssociationExtensionInterface
  • hasAttestationSupport() : Authentication
  • hasAttestedCredentialData() : AuthenticatorData
  • hasAttribute() : Entry
  • hasBeenIssuedBefore() : Token
  • hasBeenIssuedBy() : Token
  • hasBigNumber() : FeatureSet
  • hasBlock() : TraceableTwigTemplate
  • hasChildren() : ImmutableNodeInterface
  • hasClaim() : Token
  • hasCoefficient() : RsaKey
  • hasCollector() : DebugBar
  • hasColorSupport() : StreamOutput , CliDumper
  • hasCommand() : Application
  • hasComponentConfig() : ConfigHelper
  • hasCredentials() : ClientHelper
  • hasDefault() : OptionsResolver
  • hasErrored() : ConsoleLogger
  • hasEvent() : Dispatcher
  • hasExponents() : RsaKey
  • hasExtension() : TraceableTwigEnvironment
  • hasExtensions() : AuthenticatorData
  • hasField() : Table , TableInterface
  • hasFlag() : Container
  • hash() : Hmac , Mac , Hash , HMAC , HS256_64 , MacAlgorithm , Signature , Hash
  • hash_update() : ParagonIE_Sodium_Core_Util
  • hasHeader() : Token , MessageInterface
  • hasHeaderParameter() : Signature
  • hashEquals() : Core
  • hashPassword() : Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler , UserHelper
  • HashPassword() : PasswordHash
  • hashToInt() : Totp
  • hasInfiniteLoop() : Subject
  • hasKey() : Language
  • hasLineLongerThanMax() : PHPMailer
  • hasListener() : Dispatcher , DispatcherInterface
  • hasLogger() : LoggerRegistry
  • hasMoreLines() : Parser
  • hasMultiBytes() : PHPMailer
  • hasNativeSupport() : Zip
  • hasNegation() : InputDefinition
  • hasNonZeroFractionalPart() : BigDecimal
  • hasOption() : Input , InputDefinition , InputInterface
  • hasParameter() : BaseAccept
  • hasParameterOption() : ArgvInput , ArrayInput , InputInterface
  • hasParent() : ImmutableNodeInterface
  • hasPharPrefix() : Helper
  • hasPrimaryKey() : Table
  • hasPrimes() : RsaKey
  • hasProtectedHeaderParameter() : Signature
  • hasRemoteReference() : Sanitizer
  • hasService() : Registry
  • hasSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • hasShortcut() : InputDefinition
  • hasStackedData() : DebugBar
  • hasStartedMeasure() : TimeDataCollector , ProfileCollector
  • hasStderrSupport() : ConsoleOutput
  • hasStdoutSupport() : ConsoleOutput
  • hasSttyAvailable() : Terminal
  • hasStyle() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface
  • hasSupport() : AssociationsHelper
  • hasToken() : Session , SessionInterface
  • hasTokenProfileFields() : PlgUserToken
  • hasUserConfiguredTwoFactorAuthentication() : CMSApplication
  • hasUTF8mb4Support() : MysqlDriver , MysqliDriver
  • hasUtf8mb4Support() : UTF8MB4SupportInterface
  • hasUtfSupport() : DatabaseDriver , DatabaseInterface
  • hasValidEnEnding() : Dutch
  • hasValidSEnding() : Danish , Dutch , Norwegian , Swedish
  • hasVar() : AbstractUri , UriInterface
  • hasVt100Support() : Terminal
  • having() : DatabaseQuery , QueryInterface
  • hChaCha20() : ParagonIE_Sodium_Core32_HChaCha20 , ParagonIE_Sodium_Core_HChaCha20
  • hChaCha20Bytes() : ParagonIE_Sodium_Core_HChaCha20
  • head() : Http , Router , RouterInterface
  • header() : AbstractWebApplication
  • headerLine() : PHPMailer
  • headers() : Token
  • hello() : SMTP
  • help() : ToolbarHelper
  • hex2bin() : LengthCalculator , SignedIntegerObject , UnsignedIntegerObject , ECSignature , ParagonIE_Sodium_Compat
  • hexDecode() : Encoding
  • hexDecodeUpper() : Encoding
  • hexEncode() : Encoding
  • hexEncodeUpper() : Encoding
  • hexToBigInteger() : Utils
  • hexToBin() : Encoding
  • hexToBytes() : Crypto
  • hexToInt() : Utils
  • hexToString() : Utils
  • hide() : Cursor
  • hideFields() : ContenthistoryHelper
  • hideMessages() : MessagesModel
  • highlighter() : Behavior
  • hit() : Table , CategoryModel , ContactModel , ArticleModel , CategoryModel , NewsfeedModel
  • HKDF() : Crypto
  • HKDFTestVector() : Crypto , RuntimeTests
  • hmac() : SMTP
  • HMACTestVector() : Crypto , RuntimeTests
  • holdEditId() : BaseController
  • horizontalTable() : SymfonyStyle
  • hour() : DatabaseQuery , QueryInterface
  • hrefIsTemplated() : Link
  • hrtime() : Php73
  • hsalsa20() : ParagonIE_Sodium_Core_HSalsa20
  • html2text() : PHPMailer
  • html_encoding_callback() : Mbstring
  • htmlDiv() : Microdata
  • htmlEncode() : SourceContextProvider
  • htmlMeta() : Microdata
  • htmlProperty() : Microdata
  • htmlScope() : Microdata
  • htmlSpan() : Microdata
  • htmlTag() : Microdata


Joomla CMS: Champs de donnée - Fonctions

- i -

  • i2osp() : RSA
  • iconv() : Iconv
  • iconv_get_encoding() : Iconv
  • iconv_mime_decode() : Iconv
  • iconv_mime_decode_headers() : Iconv
  • iconv_mime_encode() : Iconv
  • iconv_set_encoding() : Iconv
  • iconv_strlen() : Iconv
  • iconv_strpos() : Iconv
  • iconv_strrpos() : Iconv
  • iconv_substr() : Iconv
  • id() : Grid , Languages
  • identifiedBy() : Builder
  • identifier() : Algorithm , HS256 , HS256Truncated64 , HS384 , HS512 , ES256 , ES256K , ES384 , ES512 , Ed25519 , ED256 , ED512 , EdDSA , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512
  • identifyBrowserVersion() : Browser
  • identifySignatureAlgorithm() : X509
  • idnSupported() : PHPMailer
  • ietfStream() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • ietfStreamXorIc() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • iframe() : HTMLHelper
  • ignoreCase() : AbstractString
  • ignoreCollector() : JavascriptRenderer
  • ignoreValidationErrors() : Command , LazyCommand
  • image() : HTMLHelper , Users
  • imageResize() : MediaHelper
  • images() : ListHelper
  • implementsInterface() : Assertion , Assert
  • import() : JLoader , PluginHelper
  • importData() : DatabaseImporter
  • importPlugin() : PluginHelper
  • impress() : BannersModel
  • in() : CliInput , CliApplication
  • inArray() : Assertion , Assert
  • includeRelativeFiles() : HTMLHelper
  • incompatibleKey() : InvalidKeyProvided
  • incorrectStartSequence() : ConversionFailed
  • increment() : DayOfMonthField , DayOfWeekField , FieldInterface , HoursField , MinutesField , MonthField , Usage , StringHelper , ParagonIE_Sodium_Compat
  • increment_counter() : ParagonIE_Sodium_Core_BLAKE2b
  • increment_str() : Strings
  • incrementCounter() : Core , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • index() : FinderIndexCommand , Adapter , Indexer , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • indexOf() : AbstractString , ByteString , CodePointString , UnicodeString
  • indexOfLast() : AbstractString , ByteString , CodePointString , UnicodeString
  • inetToBits() : IpHelper
  • inflect() : CachedWordInflector , NoopWordInflector , Substitutions , Transformation , Transformations , RulesetInflector , WordInflector
  • info() : PropelCollector , AbstractLogger , LoggerInterface , SymfonyStyle , OptionConfigurator
  • init() : Calculator , Dropdown , Module , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , Curl , Application
  • init_sftp_connection() : SFTP
  • initAll() : Bootup
  • initBatch() : AdminModel
  • initCommands() : Application
  • initDimensions() : Terminal
  • initDimensionsUsingStty() : Terminal
  • initFile() : FormattedtextLogger
  • initFormats() : ProgressBar
  • initHashMask() : Php72
  • initialise() : AbstractApplication , Captcha , Editor , FeedParser , AtomParser , RssParser , DatabaseModel , Application , AbstractCommand , DataSet
  • initialiseApp() : AdministratorApplication , CMSApplication , SiteApplication , InstallationApplication
  • initialize() : Encrypt , Shortcut , BCMath , GMP , PHP32 , PHP64 , PHP , Command , CompleteCommand , Inline , Manager , ZIPExtraction
  • initialize_static_variables() : AsymmetricKey , PKCS8 , PSS , RSA , BigInteger
  • initializeLog() : ZIPExtraction
  • initializeView() : FormView , ListView
  • initJwsVerifier() : AndroidSafetyNetAttestationStatementSupport
  • initPlaceholderFormatters() : ProgressBar , ProgressIndicator
  • initPrivateKey() : RSAKey
  • initPublicKey() : RSAKey
  • initRuntime() : TraceableTwigEnvironment
  • initShell() : SSH2
  • initStackSession() : DebugBar
  • initStyles() : Table
  • injectLazyJS() : PlgSystemSchedulerunner
  • inlinehelp() : ToolbarHelper
  • inlineImageExists() : PHPMailer
  • innerJoin() : DatabaseQuery
  • inR1() : Stem
  • inR2() : Stem
  • inRv() : Stem
  • insert() : DatabaseQuery , QueryInterface
  • insertid() : DatabaseInterface , MysqliDriver , PdoDriver
  • insertObject() : DatabaseDriver , DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver
  • inspectApplication() : ApplicationDescription
  • install() : LanguagesModel , LanguageAdapter , Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript , InstallModel , UpdateModel
  • installPreset() : MenusHelper
  • instance() : Manager
  • instantiateController() : ContainerControllerResolver , ControllerResolver
  • instantiateField() : FieldFactory
  • int2bytes() : PHP
  • int2octets() : AsymmetricKey
  • integer() : Assertion , Assert
  • integerExpected() : ConversionFailed
  • integerish() : Assertion , Assert
  • integerlist() : Select
  • interact() : Command
  • interfaceExists() : Assertion , Assert
  • interpolate() : MessagesCollector , ConsoleLogger
  • inTransaction() : TraceablePDO
  • intToChr() : ParagonIE_Sodium_Core_Util
  • intToHex() : Utils
  • invalidate() : ConsentsModel
  • invalidateAll() : ConsentsModel
  • invalidateFileCache() : File
  • invalidBase64String() : CannotDecodeContent
  • invalidLength() : ConversionFailed
  • invert() : ArrayHelper
  • invokeAssertions() : ConjunctionInterceptor
  • invokeInternalStreamWrapper() : PharStreamWrapper
  • ip() : Assertion , Assert
  • iPAddress() : X509
  • IPinList() : IpHelper
  • ipToNetAddress() : LdapClient
  • ipv4() : Assertion , Assert
  • ipv6() : Assertion , Assert
  • is() : PhpToken
  • is64BitSystem() : FeatureSet
  • is_ascii() : StringHelper , ASCII
  • is_dir() : SFTP
  • is_file() : SFTP
  • is_link() : SFTP
  • is_readable() : SFTP
  • is_stringable() : Strings
  • is_valid_point() : ParagonIE_Sodium_Core_Ristretto255
  • is_writable() : SFTP
  • is_writeable() : SFTP
  • is_zero() : ParagonIE_Sodium_Compat
  • isAbsolutePath() : Helper
  • isActive() : DaemonApplication , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • isAdminMultilang() : ModuleHelper
  • isAjaxHandlerAutoShow() : JavascriptRenderer
  • isAjaxHandlerBoundToFetch() : JavascriptRenderer
  • isAjaxHandlerBoundToJquery() : JavascriptRenderer
  • isAjaxHandlerBoundToXHR() : JavascriptRenderer
  • isAjaxRequest() : PlgSystemStats
  • isAllowedUser() : PlgSystemStats
  • isAnyOf() : Assert
  • isAOf() : Assert
  • isApplicationClass() : Identifier
  • isAriaAttribute() : Sanitizer
  • isArray() : Assertion , InputArgument , InputOption , Assert
  • isArrayAccessible() : Assertion , Assert
  • isAscii() : AbstractWebApplication
  • isAssetActive() : WebAssetManager , WebAssetManagerInterface
  • isAssoc() : Question
  • isAssociative() : ArrayHelper
  • isAuthenticated() : Client , SSH2
  • isAuthorisedDisplayChecker() : PlgSystemJooa11y
  • isAuthorisedDisplayDebug() : PlgSystemDebug
  • isAutoExitEnabled() : Application
  • isAutoReload() : TraceableTwigEnvironment
  • isBackupCode() : BackupcodesModel
  • isBelow() : Tar , Zip
  • isBinaryString() : Inline
  • isBound() : ConnectionInterface , Connection
  • isBrowser() : Browser
  • isCallable() : Assertion , Assert
  • isCaptiveMFA() : PlgSystemStats
  • isCheckedOut() : BaseDatabaseModel , Table
  • isCheckoutItem() : AssociationsHelper
  • isChecksumValid() : InstallerHelper , UpdateModel
  • isClassMapAuthoritative() : ClassLoader
  • isCli() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • isClient() : CliApplication , CMSApplication , CMSApplicationInterface , ConsoleApplication
  • isCommandEnabled() : BeforeCommandExecuteEvent
  • isCommon() : Helper
  • isCompatible() : Version
  • isConfirmed() : PharInvocation
  • isConnected() : RedisStorage , FtpClient , LdapClient , SSH2
  • isConnectionEncryptionSupported() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • isConstructed() : Identifier
  • isContextSpecificClass() : Identifier
  • isCountable() : Assertion , Inflector , Assert
  • isCredentialIdAllowed() : AuthenticatorAssertionResponseValidator
  • isCurrentLineBlank() : Parser
  • isCurrentLineComment() : Parser
  • isCurrentLineEmpty() : Parser
  • isCurrentLineLastLineInDocument() : Parser
  • isCursorFree() : CompletionInput
  • isDataAttribute() : Sanitizer
  • isDatabaseTypeSupported() : UpdateModel
  • isDataPersisted() : DebugBar
  • isDebug() : TraceableTwigEnvironment , NullOutput , Output , OutputInterface , OutputStyle , HtmlErrorRenderer
  • isDebugEnabled() : FormField , BaseLayout , PlgSystemStats
  • isDecorated() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , NullOutput , Output , OutputInterface , OutputStyle
  • isdefault() : JGrid
  • isDefined() : OptionsResolver
  • isDeprecated() : OptionsResolver
  • isDir() : CaBundle
  • isDownload() : XmlDocument
  • isDue() : CronExpression
  • isElementContainedIn() : Helper
  • isEmailAddress() : MailHelper
  • isEmpty() : AbstractString , Assert
  • isEnabled() : ComponentHelper , LibraryHelper , ModuleHelper , Associations , Multilanguage , Microdata , PluginHelper , AbstractCommand , Command , LazyCommand
  • isEOF() : StringStream , ZIPExtraction
  • isEqualTo() : BigNumber , LdapUser
  • isError() : PHPMailer
  • isEven() : BigInteger
  • isException() : ExceptionHandler
  • isExcluded() : Cache
  • isExpired() : Token
  • isFailIfUnknown() : ExtensionDescriptor
  • isFile() : CaBundle
  • isFreshUserVerificationRequired() : MetadataStatement
  • isGithubActionEnvironment() : GithubActionReporter
  • isGreaterThan() : BigNumber , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • isGreaterThanOrEqualTo() : BigNumber
  • isHash() : Inline
  • isHidden() : AbstractCommand , Command , Question
  • isHiddenFallback() : Question
  • isHrefSafeValue() : Sanitizer
  • isHtml() : Mail
  • isHTML() : PHPMailer
  • isHtml5() : HtmlDocument
  • isHtmlVarDumperUsed() : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • isHttpsForced() : CMSApplication
  • isIdentifiedBy() : Token
  • isIdentifier() : Resource
  • isIgnorable() : PhpToken
  • isIgnoredDirectory() : ZIPExtraction
  • isImage() : MediaHelper , BannerHelper
  • isInAllowedUserGroup() : Token , PlgUserToken
  • isIncrementsOfRanges() : AbstractField
  • isInDevelopmentState() : Version
  • isInflectedWord() : FrenchInflector
  • isInIncrementsOfRanges() : AbstractField
  • isInRange() : AbstractField
  • isInstalled() : InstalledVersions , ComponentHelper
  • isInstanceOf() : Assertion , Assert
  • isInstanceOfAny() : Assert
  • isInteractive() : Input , InputInterface , LdapAuthenticator
  • isInteractiveInput() : QuestionHelper
  • isInternal() : Uri
  • isIPv6() : IpHelper
  • isIterable() : Assert
  • isJoomlaStream() : FilesystemHelper , Helper
  • isJqueryNoConflictEnabled() : JavascriptRenderer
  • isJsonString() : Assertion
  • isKeyRestricted() : MetadataStatement
  • isLeaf() : Nested
  • isLessThan() : BigNumber
  • isLessThanInt() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • isLessThanOrEqualTo() : BigNumber
  • isList() : Assert
  • isLoaded() : Image
  • isLogQueriesToLogger() : PropelCollector
  • isLongForm() : Identifier
  • isMail() : PHPMailer
  • isManifest() : Installer
  • isMap() : Assert
  • isMariaDb() : MysqlDriver , MysqliDriver
  • isMediaFile() : ApiModel
  • isMinimumTimeBefore() : Token
  • isMinimumVersion() : DatabaseDriver , DatabaseInterface
  • isMissing() : OptionsResolver
  • isMobile() : Browser
  • isMultiline() : Question
  • isMultiselect() : ChoiceQuestion
  • isNegatable() : InputOption
  • isNegative() : BCMath , BigNumber , BigInteger , BigIntegerBcmath , BigIntegerGmp , BCMath , GMP , PHP , BigInteger
  • isNegativeOrZero() : BigNumber
  • isNested() : TagField , OptionsResolver
  • isNew() : Session , SessionInterface
  • isNextLineIndented() : Parser
  • isNextLineUnIndentedCollection() : Parser
  • isNonEmptyList() : Assert
  • isNonEmptyMap() : Assert
  • isNonStandardPort() : Uri
  • isNormalized() : Normalizer
  • isNotA() : Assert
  • isNullDatetime() : DatabaseQuery , QueryInterface
  • isObject() : Assertion
  • isOdd() : BigInteger , BCMath , GMP , PHP , BigInteger , Integer
  • isolateNamespace() : XML
  • isOpensslParseSafe() : CaBundle
  • isOption() : ConnectionOptions
  • isOverwrite() : Installer
  • isOwner() : Path
  • isPackageUninstall() : Installer
  • isPathAbsolute() : WebAssetItem
  • isPathExternal() : WebAssetItem
  • isPayloadDetached() : JWS
  • isPayloadEmpty() : JWSVerifier
  • isPayloadEncoded() : Serializer
  • isPermittedFor() : Token
  • isPermittedPath() : PHPMailer
  • isPhpVersionSupported() : UpdateModel
  • isPlural() : Inflector
  • isPositive() : BigNumber
  • isPositiveOrZero() : BigNumber
  • isPrepared() : TracedStatement
  • isPrimaryProvider() : ProviderAwareAuthenticationPluginInterface
  • isPrime() : Engine , BigInteger
  • isPrivate() : Ec2Key , OkpKey , RsaKey
  • isPrivateClass() : Identifier
  • isPropertyInType() : Microdata
  • isProtected() : Container , ContainerResource
  • isPrototype() : OptionsResolver
  • isPTYEnabled() : SSH2
  • isPublic() : RsaKey , RSAKey
  • isQmail() : PHPMailer
  • isQuiet() : NullOutput , Output , OutputInterface , OutputStyle
  • isQuietModeEnabled() : SSH2
  • isRange() : AbstractField
  • isReadable() : CaBundle , CallbackStream , RelativeStream , Stream , StreamInterface , LintCommand
  • isRedirectState() : AbstractWebApplication
  • isRegistered() : HTMLHelper
  • isRelatedTo() : Token
  • isRemoteSearch() : TagField
  • isRequired() : InputArgument , OptionsResolver
  • isRequireJsUsed() : JavascriptRenderer
  • isRequireResidentKey() : AuthenticatorSelectionCriteria
  • isResolved() : LdapBadge
  • isResource() : Assertion
  • isRobot() : Browser
  • isRtl() : Language
  • isRTL() : PlgInstallerWebinstaller
  • isRunningOS400() : ConsoleOutput
  • isSafeFile() : InputFilter
  • isSatisfied() : AbstractField
  • isSatisfiedBy() : DayOfMonthField , DayOfWeekField , FieldInterface , HoursField , MinutesField , MonthField
  • isSecondFactorOnly() : MetadataStatement
  • isSeekable() : CallbackStream , RelativeStream , Stream , StreamInterface
  • isSendmail() : Mail , PHPMailer
  • isSessionStarted() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • isShared() : Container , ContainerResource
  • isShellSafe() : PHPMailer
  • isShort() : English
  • isSingleCommand() : Application
  • isSingleton() : UserGroupsHelper
  • isSingular() : Inflector
  • isSMTP() : PHPMailer
  • isSqlRenderedWithParams() : PDOCollector
  • isSsl() : AbstractUri , UriInterface
  • isSslConnection() : AbstractWebApplication , WebApplicationInterface
  • isStackAlwaysUseSessionStorage() : DebugBar
  • isStarted() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface
  • isStopped() : AbstractEvent , EventInterface
  • isStrictVariables() : TraceableTwigEnvironment
  • isStringable() : LazyString
  • isStringUnIndentedCollectionItem() : Parser
  • isSubArrayValid() : X509
  • isSuccess() : TracedStatement , Task , Response
  • issuedAt() : Builder
  • issuedBy() : Builder
  • isSupported() : Bzip2 , ExtractableInterface , Gzip , Tar , Zip , Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler , CacheStorage , ApcuStorage , MemcachedStorage , RedisStorage , WincacheStorage , CryptoCipher , SodiumCipher , AesInterface , Aes , Mcrypt , OpenSSL , CurlTransport , SocketTransport , StreamTransport , Crypto , OpenSSL , Sodium , CipherInterface , DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver , Curl , Socket , Stream , TransportInterface , ApcuHandler , DatabaseHandler , FilesystemHandler , MemcachedHandler , RedisHandler , WincacheHandler , HandlerInterface , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing , SignalRegistry
  • isTemplateActive() : UpdateModel
  • isTemplated() : LinkInterface , Link
  • isTemplateFresh() : TraceableTwigEnvironment
  • isTimeout() : SSH2
  • isTokenEnabledForUser() : Token
  • isTraitable() : TraceableTwigTemplate
  • isTranslatedText() : ModulesHelper
  • isTransparent() : Image
  • isTraversable() : Assertion , Assert
  • isTrimmable() : Question
  • isTwoFactorAuthenticationRequired() : CMSApplication
  • isTypeAvailable() : Microdata
  • isTypeSupported() : FieldsPlugin
  • isUniversalClass() : Identifier
  • isUpdateRequired() : PlgSystemStats
  • isUpgrade() : Installer
  • isUserConsented() : PlgSystemPrivacyconsent
  • isUserPresent() : AuthenticatorData
  • isUserVerified() : AuthenticatorData
  • isUseTagDirty() : Sanitizer
  • isUseTagExceedingThreshold() : Sanitizer
  • isUtf8() : ByteString
  • isValid() : AbstractString , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , HeaderSecurity , Uuid , AndroidKeyAttestationStatementSupport , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • isValidEngine() : SymmetricKey , Base , BCMath , GMP , OpenSSL , PHP32 , PHP64 , Base , Montgomery
  • isValidEngineHelper() : Blowfish , ChaCha20 , SymmetricKey , DES , RC2 , RC4 , Rijndael , TripleDES
  • isValidExpression() : CronExpression
  • isValidHost() : PHPMailer
  • isValidHttpStatus() : AbstractWebApplication , WebApplicationInterface
  • isValidId() : Task
  • isValidLocalDirectory() : MediaHelper
  • isValidOtep() : UserModel
  • isValidSecretKey() : UserModel
  • isValidState() : Task
  • isValidStreamResourceType() : Stream
  • isValueOptional() : InputOption
  • isValueRequired() : InputOption
  • isVerbose() : NullOutput , Output , OutputInterface , OutputStyle
  • isVeryVerbose() : NullOutput , Output , OutputInterface , OutputStyle
  • isViewable() : Browser
  • isWindows() : Helper
  • isWindowsTrueColor() : CliDumper
  • isWorkflowActive() : WorkflowServiceInterface
  • isWritable() : CallbackStream , PhpInputStream , RelativeStream , Stream , StreamInterface
  • isZero() : BigNumber
  • itemAccessChange() : Adapter
  • itemStateChange() : Adapter
  • iterate() : ProgressBar


Joomla CMS: Champs de donnée - Fonctions

- j -

  • jacobianAddPoint() : Prime
  • jacobianAddPointMixedX() : Prime
  • jacobianAddPointMixedXY() : Prime
  • jacobianDoublePoint() : KoblitzPrime , Prime
  • jacobianDoublePointMixed() : KoblitzPrime , Prime
  • join() : DatabaseQuery , QueryInterface , AbstractString , AbstractUnicodeString , ByteString , UnicodeString
  • jooa11y() : ToolbarHelper
  • jsonDecode() : Decoder
  • jsonEncode() : JsonResponse , Encoder
  • jsonIssues() : CannotDecodeContent , CannotEncodeContent
  • jsonSerialize() : BigNumber , JsonapiDocument , DataObject , DataSet , Registry , JWK , JWKSet , Basic , Engine , BigInteger , Integer , Uuid , SilencedErrorContext , AbstractString , LazyString , Document , AttestationStatement , AttestedCredentialData , AuthenticationExtension , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorSelectionCriteria , PublicKeyCredentialCreationOptions , PublicKeyCredentialDescriptor , PublicKeyCredentialDescriptorCollection , PublicKeyCredentialEntity , PublicKeyCredentialParameters , PublicKeyCredentialRequestOptions , PublicKeyCredentialRpEntity , PublicKeyCredentialSource , PublicKeyCredentialUserEntity , CertificateTrustPath , EcdaaKeyIdTrustPath , EmptyTrustPath


Joomla CMS: Champs de donnée - Fonctions

- k -

  • k() : SymmetricKey
  • karatsuba() : PHP
  • karatsubaSquare() : PHP
  • kdf() : Hash
  • keep() : HistoryController , HistoryModel
  • keepalive() : Behavior
  • key() : Construct , DataSet , DatabaseIterator , SplFixedArray
  • key_exchange() : SSH2
  • keyboard_interactive_login() : SSH2
  • keyboard_interactive_process() : SSH2
  • keyExchange() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • keyExists() : Assertion , Assert
  • keyIsset() : Assertion
  • keyNotExists() : Assertion , Assert
  • keypair() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • keys() : DataSet


Joomla CMS: Champs de donnée - Fonctions

- l -

  • L1Hash() : Hash
  • L2Hash() : Hash
  • L3Hash() : Hash
  • lang() : PHPMailer
  • language() : Users
  • languageAssociations() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • lastInsertId() : TraceablePDO
  • layout() : ToolbarButton
  • lazy() : Assert
  • ldapNetAddr() : LdapClient
  • leave() : TimeableTwigExtensionProfiler
  • leaveHash() : DumperInterface , CliDumper , HtmlDumper
  • leftJoin() : DatabaseQuery
  • leftRotate() : Salsa20
  • len64() : SymmetricKey
  • length() : Assertion , DatabaseQuery , QueryInterface , SqlsrvQuery , Helper , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • lengthBetween() : Assert
  • lessOrEqualThan() : Assertion
  • lessThan() : Assertion , Assert
  • lessThanEq() : Assert
  • level() : Access
  • lexInlineMapping() : Parser
  • lexInlineQuotedString() : Parser
  • lexInlineSequence() : Parser
  • lexInlineStructure() : Parser
  • lexUnquotedString() : Parser
  • library_version_major() : ParagonIE_Sodium_Compat
  • library_version_minor() : ParagonIE_Sodium_Compat
  • link() : PreloadManager , Links , HTMLHelper , Route , ToolbarHelper
  • linkOptions() : Menu
  • links() : Links
  • linksgroups() : Links
  • linkXHTMLSafe() : OutputFilter
  • linkXhtmlSafe() : OutputFilter
  • list() : Manager , ManagerFactory , AlgorithmManager , JWSSerializerManager
  • listDetails() : FtpClient
  • listen() : DumpServer
  • listFolderTree() : Folder
  • listing() : StyleInterface , SymfonyStyle
  • listNames() : FtpClient
  • listRevoked() : X509
  • load() : JLoader , JNamespacePsr4Map , Form , ModuleHelper , UserGroupsHelper , Language , AbstractMenu , AdministratorMenu , Table , TableInterface , User , MfaTable , CssMenu , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , MetadataRepository , Autoloader , AsymmetricKey , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , PKCS1 , PKCS8 , DH , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , XML , ASN1 , SSH2 , libsodium , MontgomeryPrivate , MontgomeryPublic , OpenSSH , PKCS1 , PKCS8 , PuTTY , XML , ASN1 , SSH2 , PublicKeyLoader , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML , PlgInstallerOverride , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationObjectLoader , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AuthenticationExtensionsClientOutputsLoader , PublicKeyCredentialLoader
  • loadActionLogPluginsLanguage() : ActionlogsHelper
  • loadAdapter() : Installer
  • loadAliasFor() : JLoader
  • loadAll() : UserGroupsHelper
  • loadAllAdapters() : Adapter
  • loadAndCheckAssertionResponse() : Server
  • loadAndCheckAttestationResponse() : Server
  • loadAndVerifyWithKey() : JWSLoader
  • loadAndVerifyWithKeySet() : JWSLoader
  • loadArray() : Registry , PublicKeyCredentialLoader
  • loadAssoc() : DatabaseDriver , DatabaseInterface
  • loadAssocList() : DatabaseDriver , DatabaseInterface
  • loadBasicType() : PackedAttestationStatementSupport
  • loadButtonClass() : ContainerAwareToolbarFactory
  • loadButtonType() : Toolbar
  • loadByAlias() : JLoader
  • loadByName() : Asset
  • loadByPsr() : JLoader
  • loadByPsr4() : JLoader
  • loadBytesFromChecksummedAsciiSafeString() : Encoding
  • loadCA() : X509
  • loadCaptiveRenderOptions() : CaptiveModel
  • loadChangelog() : ManageModel
  • loadClass() : ClassLoader , FormHelper , DebugClassLoader
  • loadClassLoader() : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f
  • loadColumn() : DatabaseDriver , DatabaseInterface
  • loadComponentLanguage() : LanguageHelper
  • loadConfiguration() : DaemonApplication
  • loadCRL() : X509
  • loadCSR() : X509
  • loadCss() : Bootstrap , MediaActionPlugin , PlgMediaActionCrop
  • loadCurveByParam() : XML
  • loadCurveByParamRFC4050() : XML
  • loadDocument() : WebApplication , AbstractRenderer , InstallationApplication
  • loadEcdaaType() : PackedAttestationStatementSupport
  • loadEdDSA() : PKCS8
  • loadEmptyType() : PackedAttestationStatementSupport
  • loadField() : Form
  • loadFieldClass() : FormHelper
  • loadFieldType() : FormHelper
  • loadFile() : Form , Image , Registry
  • loadFilterClass() : FormHelper
  • loadFilterType() : FormHelper
  • loadForm() : FormModel
  • loadFormat() : AsymmetricKey
  • loadFormData() : ListModel , BannerModel , ClientModel , DownloadModel , CategoryModel , ComponentModel , FormModel , ContactModel , ArticleModel , FieldModel , GroupModel , FilterModel , UpdateModel , UpdatesiteModel , LanguageModel , OverrideModel , TemplateModel , ItemModel , MenuModel , MessageModel , ModuleModel , NewsfeedModel , PluginModel , PluginsModel , RequestModel , LinkModel , TagModel , StyleModel , TemplateModel , GroupModel , LevelModel , MailModel , NoteModel , UserModel , LoginModel , ProfileModel , RegistrationModel , StageModel , TransitionModel , WorkflowModel
  • loadFromAsciiSafeString() : Key , KeyProtectedByPassword
  • loadFromWeb() : OID
  • loadFromXml() : Changelog , Update
  • loadHelper() : LegacyComponent , HtmlView , AssociationsHelper
  • loadIdentity() : CMSApplicationInterface
  • loadJs() : MediaActionPlugin , PlgMediaActionCrop
  • loadLanguage() : WebApplication , AbstractModuleDispatcher , ApiDispatcher , ComponentDispatcher , ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , Language , CMSPlugin , Dispatcher
  • loadLanguageFiles() : ContenthistoryHelper
  • loadLanguageForComponent() : ConfigHelper
  • loadLanguageForComponents() : ConfigHelper
  • loadLanguageSuffixes() : FileLayout
  • loadLibraryLanguage() : CMSApplication , SiteApplication
  • loadManifestFromData() : LibraryManifest , Manifest , PackageManifest
  • loadManifestFromXml() : Manifest
  • loadMap() : Iconv
  • loadMD5Sum() : Installer
  • loadObject() : DatabaseDriver , DatabaseInterface , Registry
  • loadObjectList() : DatabaseDriver , DatabaseInterface
  • loadOIDs() : ASN1
  • loadParameters() : AsymmetricKey , PublicKeyLoader
  • loadParametersFormat() : AsymmetricKey
  • loadPluginLanguage() : LanguageHelper
  • loadPlugins() : AsymmetricKey
  • loadPreset() : MenusHelper
  • loadPrivateKey() : AsymmetricKey , PublicKeyLoader
  • loadPrivateKeyFormat() : AsymmetricKey
  • loadPublicKey() : AsymmetricKey , PublicKeyLoader
  • loadPublicKeyFormat() : AsymmetricKey
  • loadRenderer() : Document , ErrorDocument
  • loadResult() : DatabaseDriver , DatabaseInterface
  • loadRow() : DatabaseDriver , DatabaseInterface
  • loadRowList() : DatabaseDriver , DatabaseInterface
  • loadRuleClass() : FormHelper
  • loadRuleType() : FormHelper
  • loadSession() : WebApplication
  • loadSPKAC() : X509
  • loadString() : Registry , ANSI
  • loadSubForm() : SubformField
  • loadSubFormData() : SubformField
  • loadSystemUris() : AbstractWebApplication , WebApplication
  • loadTemplate() : TraceableTwigEnvironment , HtmlView
  • loadTranslationFiles() : ActionlogsHelper , MailsHelper
  • loadTrustPath() : TrustPathLoader
  • loadType() : FormHelper
  • loadTypes() : Microdata
  • loadUser() : LdapUserProvider
  • loadUserById() : UserFactory , UserFactoryInterface
  • loadUserByIdentifier() : LdapUserProvider
  • loadUserByUsername() : UserFactory , UserFactoryInterface , LdapUserProvider
  • loadVersionSuffixes() : FileLayout
  • loadX509() : X509
  • loadXml() : MenusHelper
  • lock() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , WebAssetManager
  • lockindex() : MemcachedStorage
  • lockTable() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • log() : PropelCollector , MessagesCollector , DelegatingPsrLogger , Task , LoggerInterface , NullLogger , GithubActionReporter , CompleteCommand , ConsoleLogger , BufferingLogger
  • logError() : SFTP
  • logException() : ExceptionHandler
  • logExport() : ExportModel
  • logExportEmailed() : ExportModel
  • logger() : PlgSystemDebug
  • login() : AdministratorApplication , CMSApplication , SiteApplication , FtpClient , DisplayController , UserController , FtpClient , POP3 , SSH2
  • login_helper() : SSH2
  • logout() : CMSApplication , DisplayController , UserController
  • logRemove() : RemoveModel
  • logRemoveBlocked() : RemoveModel
  • logSearch() : FinderHelper
  • lookupItem() : RouteHelper
  • lower() : AbstractString , AbstractUnicodeString , ByteString , Assert
  • lowerThan() : BigInteger
  • lshift() : PHP
  • lstat() : SFTP
  • ltrim() : StringHelper


Joomla CMS: Champs de donnée - Fonctions

- m -

  • mac_algorithm_to_hash_instance() : SSH2
  • mail() : SMTP
  • mailPassthru() : PHPMailer
  • mailSend() : PHPMailer
  • mailtags() : MailsHelper
  • make_odd() : BCMath , GMP , PHP
  • makeCA() : X509
  • makeDefault() : ToolbarHelper
  • makeFilename() : FileStorage
  • makeGetRequest() : Requests
  • makeId() : Cache
  • makeItem() : Pathway
  • makeNumeric() : Identifier
  • makeSafe() : File , Folder , File , Folder
  • makeTransportRequest() : Http
  • makeUriRelativeTo() : JavascriptRenderer
  • manages() : AuthenticationFailedExceptionHandler , CheckinCheckoutExceptionHandler , InvalidRouteExceptionHandler , NotAcceptableExceptionHandler , NotAllowedExceptionHandler , ResourceNotFoundExceptionHandler , SaveExceptionHandler , SendEmailExceptionHandler , ExceptionHandlerInterface , FallbackExceptionHandler , InvalidParameterExceptionHandler
  • mapBase() : UCMBase
  • mapData() : UCMContent
  • mapFromUtf8() : Iconv
  • mapInAttributes() : X509
  • mapInDNs() : X509
  • mapInExtensions() : X509
  • mapIso8859_1ToWindows1252() : FromUtf8
  • mapOutAttributes() : X509
  • mapOutDNs() : X509
  • mapOutExtensions() : X509
  • mapProtocolVersion() : Curl
  • mapslist() : Finder
  • mapToUtf8() : Iconv
  • mapWindows1252ToIso8859_1() : ToUtf8
  • mark() : Profiler
  • markResolved() : LdapBadge
  • markSubjectAsInvalid() : Resolver
  • match() : Browser , AbstractNegotiator , LanguageNegotiator , Negotiator , AbstractString , AbstractUnicodeString , ByteString
  • matches() : Pattern , Patterns , CommandIsSuccessful
  • max() : Assertion , BigNumber , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • maxCount() : Assertion , Assert
  • maxHelper() : Engine
  • maxLength() : Assertion , Assert
  • maxSecondsBetweenRedraws() : ProgressBar
  • mb_check_encoding() : Mbstring
  • mb_chr() : Mbstring , Php72
  • mb_convert_case() : Mbstring
  • mb_convert_encoding() : Mbstring
  • mb_convert_variables() : Mbstring
  • mb_decode_mimeheader() : Mbstring
  • mb_decode_numericentity() : Mbstring
  • mb_detect_encoding() : Mbstring
  • mb_detect_order() : Mbstring
  • mb_encode_mimeheader() : Mbstring
  • mb_encode_numericentity() : Mbstring
  • mb_encoding_aliases() : Mbstring
  • mb_get_info() : Mbstring
  • mb_http_input() : Mbstring
  • mb_http_output() : Mbstring
  • mb_internal_encoding() : Mbstring
  • mb_language() : Mbstring
  • mb_list_encodings() : Mbstring
  • mb_ord() : Mbstring , Php72
  • mb_output_handler() : Mbstring
  • mb_pathinfo() : PHPMailer
  • mb_str_split() : Mbstring
  • mb_stripos() : Mbstring
  • mb_stristr() : Mbstring
  • mb_strlen() : Mbstring
  • mb_strpos() : Mbstring
  • mb_strrchr() : Mbstring
  • mb_strrichr() : Mbstring
  • mb_strripos() : Mbstring
  • mb_strrpos() : Mbstring
  • mb_strstr() : Mbstring
  • mb_strtolower() : Mbstring
  • mb_strtoupper() : Mbstring
  • mb_strwidth() : Mbstring
  • mb_substitute_character() : Mbstring
  • mb_substr() : Mbstring
  • mb_substr_count() : Mbstring
  • mdsrem() : Twofish
  • measure() : TimeDataCollector , ProfileCollector
  • media_manager() : ToolbarHelper
  • mediaFolderTree() : HtmlView
  • mediaTree() : HtmlView
  • memcachedGetMulti() : MemcachedStorage
  • memcmp() : ParagonIE_Sodium_Core_Util
  • memzero() : ParagonIE_Sodium_Compat
  • menuItemList() : Menu
  • menuItems() : Menu
  • menulogout() : UserController
  • menus() : Menu
  • merge() : Rules , DataShapeObject , DatabaseQuery , Registry , ConfigPostProcessor , Resource
  • mergeAction() : Rules
  • mergeApplicationDefinition() : AbstractCommand , Command , LazyCommand
  • mergeAttributes() : Resource
  • mergeClonerOptions() : DebugBarVarDumper
  • mergeCollection() : Rules
  • mergeDumperOptions() : DebugBarVarDumper
  • mergeGlobals() : TraceableTwigEnvironment
  • mergeHeadData() : HtmlDocument
  • mergeIdentities() : Rule
  • mergeIdentity() : Rule
  • mergeLabels() : ContenthistoryHelper
  • mergeNode() : Form
  • mergeNodes() : Form
  • mergeRecursive() : ArrayHelper
  • mergeRelationships() : Resource
  • mergeResource() : Document
  • mergeSchemaCache() : DatabaseModel
  • mergeStructure() : DatabaseImporter
  • message() : Directory
  • methodExists() : Assertion , MethodModel , Assert
  • methodNotExists() : Assert
  • mgf1() : RSA
  • min() : Assertion , BigNumber , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • minCount() : Assertion , Assert
  • minHelper() : Engine
  • minify() : Sanitizer
  • minLength() : Assertion , Assert
  • minMaxBits() : Engine
  • minSecondsBetweenRedraws() : ProgressBar
  • minus() : BigDecimal , BigInteger , BigRational
  • minute() : DatabaseQuery , QueryInterface
  • missingOrNotEnoughSeparators() : InvalidTokenStructure
  • mkdir() : FtpClient , SFTP , PharStreamWrapper
  • mkdir_helper() : SFTP
  • mod() : BCMath , BigInteger , Calculator , BigInteger
  • modal() : Bootstrap , ToolbarHelper
  • modifiedBy() : ContactSerializer , ContentSerializer , NewsfeedSerializer
  • modify() : LdapClient
  • modifyHeader() : BaseSigner , Signer
  • modInverse() : BigInteger , GmpCalculator , Calculator , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • modInverse67108864() : Montgomery
  • modPow() : BigInteger , BcMathCalculator , GmpCalculator , Calculator , NativeCalculator , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • modulus() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • modulusMustNotBeZero() : DivisionByZeroException
  • month() : DatabaseQuery , QueryInterface
  • monthToString() : Date
  • mostRecentlyEnteredValue() : QuestionHelper
  • move() : File , Folder , Stream , Nested , Table , AdapterInterface , ApiModel , File , Folder , Stream , LocalAdapter , EntryManagerInterface , EntryManager
  • moveByReference() : Nested
  • moveCliFiles() : InstallerScript
  • moveDown() : Cursor
  • moveFile() : LocalAdapter
  • moveFolder() : LocalAdapter
  • moveLeft() : Cursor
  • moveRemainingTemplateFiles() : JoomlaInstallerScript
  • moveRight() : Cursor
  • moveTo() : UploadedFile , UploadedFileInterface
  • moveToClosingElement() : FeedParser
  • moveToColumn() : Cursor
  • moveToNextElement() : FeedParser
  • moveToNextLine() : Parser
  • moveToPosition() : Cursor
  • moveToPreviousLine() : Parser
  • moveUp() : Cursor
  • msgHTML() : PHPMailer
  • mul() : BCMath , BcMathCalculator , GmpCalculator , Calculator , NativeCalculator
  • mulInt32Fast() : ParagonIE_Sodium_Core32_Int32
  • mulInt64Fast() : ParagonIE_Sodium_Core32_Int64
  • mulIntFast() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • multipliedBy() : BigDecimal , BigInteger , BigRational
  • multiply() : BigInteger , BigIntegerBcmath , BigIntegerGmp , BigInteger , PrivateKey , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • multiplyAddPoints() : Base , KoblitzPrime , Prime
  • multiplyHelper() : PHP
  • multiplyLower() : Barrett
  • multiplyPoint() : Base , Montgomery , Curve25519 , Curve448
  • multiplyReduce() : Base , MontgomeryMult
  • multiselect() : Behavior
  • mustRun() : ProcessHelper
  • mustSuggestArgumentValuesFor() : CompletionInput
  • mustSuggestOptionValuesFor() : CompletionInput


Joomla CMS: Champs de donnée - Fonctions

- n -

  • n() : RsaKey
  • name() : ToolbarButton , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Algorithm , Hash , EdDSA , ES256 , ES256K , ES384 , ES512 , HS1 , HS256 , HS256_64 , HS384 , HS512 , None , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512 , CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , AttestationStatementSupport , FidoU2FAttestationStatementSupport , NoneAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , AuthenticationExtension
  • names() : JWSSerializerManagerFactory
  • namespaceReverse() : RewriteRules
  • namespaceRewrite() : RewriteRules
  • natural() : Assert
  • nd() : BigRational
  • needsRekey() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • neg() : Calculator
  • negate() : BCMath , GMP , PHP , BigInteger , Integer
  • negated() : BigDecimal , BigInteger , BigRational
  • negatePoint() : Base
  • negationToName() : InputDefinition
  • negative() : ParagonIE_Sodium_Core_Curve25519
  • new64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • newInteger() : BinaryField , PrimeField
  • newLine() : ANSI , OutputStyle , StyleInterface , SymfonyStyle
  • next() : Construct , DataSet , DatabaseIterator , SplFixedArray
  • nextExec() : ExecRuleHelper
  • nh() : Hash
  • nlist() : SFTP
  • nlist_helper() : SFTP
  • noContent() : Assertion
  • noop() : SMTP
  • noopReplacement() : ConfigPostProcessor
  • normalize() : BCMath , GMP , PHP , OptionConfigurator , AbstractUnicodeString , UnicodeString , Normalizer
  • normalizeBreaks() : PHPMailer
  • normalizePath() : Helper
  • normalizeType() : DebugClassLoader
  • normalizeWindowsPath() : Helper
  • notBlank() : Assertion
  • notContains() : Assertion , Assert
  • note() : StyleInterface , SymfonyStyle
  • notEmpty() : Assertion , Assert
  • notEmptyKey() : Assertion
  • notEndsWith() : Assert
  • notEq() : Assertion , Assert
  • notes() : Users
  • notesModal() : Users
  • notFalse() : Assert
  • notice() : PropelCollector , AbstractLogger , LoggerInterface
  • notInArray() : Assertion
  • notInstanceOf() : Assert
  • notIsInstanceOf() : Assertion
  • notNull() : Assertion , Assert
  • notRegex() : Assertion , Assert
  • notSame() : Assertion , Assert
  • notStartsWith() : Assert
  • notWhitespaceOnly() : Assert
  • null() : Assertion , Assert
  • nullDate() : DatabaseQuery , QueryInterface
  • nullErrorHandler() : Connection
  • nullOr() : AssertionChain
  • nullPad128() : SymmetricKey
  • numeric() : Assertion , Assert


Joomla CMS: Champs de donnée - Fonctions

- o -

  • oauthcallback() : PluginController
  • oauthRequest() : Client
  • object() : Assert
  • objectHtmlSafe() : OutputFilter
  • objectOrClass() : Assertion
  • objectToString() : Ini , Json , Php , Xml , Yaml , FormatInterface
  • octetLength() : ECSignature , MultibyteStringConverter
  • of() : BigDecimal , BigInteger , BigNumber , BigRational
  • offcanvas() : Bootstrap
  • offsetExists() : AggregatedCollector , DebugBar , Construct , Feed , DataShapeObject , DataSet , AbstractEvent , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetGet() : AggregatedCollector , DebugBar , Construct , Feed , DataShapeObject , DataSet , AbstractEvent , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetSet() : AggregatedCollector , DebugBar , Construct , AbstractImmutableEvent , Feed , DataShapeObject , DataSet , Event , EventImmutable , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • offsetUnset() : AggregatedCollector , DebugBar , Construct , AbstractImmutableEvent , Feed , DataShapeObject , DataSet , Event , EventImmutable , Registry , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , SplFixedArray , Collection , OptionsResolver , Data
  • ofUnscaledValue() : BigDecimal
  • oldTrustPathTypes() : TrustPathLoader
  • on_channel_open() : SSH2
  • onAfterCheckin() : Joomla
  • onAfterDisconnect() : PlgSystemDebug
  • onAfterDispatch() : Joomla , PlgSystemLanguageFilter , PlgSystemSef , PlgSystemStats
  • onAfterDisplay() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onAfterInitialise() : PlgSystemActionLogs , PlgSystemLanguageFilter , PlgSystemRemember , PlgSystemStats
  • onAfterLogExport() : Joomla
  • onAfterLogPurge() : Joomla
  • onAfterModuleList() : CaptiveModel
  • onAfterPurge() : Joomla
  • onAfterRender() : Cache , PlgSystemLanguagecode , PlgSystemPrivacyconsent , PlgSystemSef
  • onAfterRespond() : Cache , PlgSystemActionLogs , PlgSystemDebug
  • onAfterRoute() : Cache , PlgSystemLanguageFilter , PlgSystemPrivacyconsent
  • onAfterSessionStart() : MetadataManagerListener
  • onAjaxDebug() : PlgSystemDebug
  • onAjaxSampledataApplyStep1() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep2() : PlgSampledataBlog , PlgSampledataMultilang
  • onAjaxSampledataApplyStep3() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep4() : PlgSampledataBlog , PlgSampledataMultilang
  • onAjaxSampledataApplyStep5() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep6() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep7() : PlgSampledataMultilang
  • onAjaxSampledataApplyStep8() : PlgSampledataMultilang
  • onAjaxSendAlways() : PlgSystemStats
  • onAjaxSendNever() : PlgSystemStats
  • onAjaxSendStats() : PlgSystemStats
  • onApplicationAfterSave() : Joomla
  • onAttachCallback() : CoreAssetItem , FormValidateAssetItem , KeepaliveAssetItem , TableColumnsAssetItem , WebAssetAttachBehaviorInterface
  • onAuthenticationFailure() : LdapAuthenticator
  • onAuthenticationSuccess() : LdapAuthenticator
  • onBeforeApiRoute() : PlgWebservicesBanners , PlgWebservicesConfig , PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesInstaller , PlgWebservicesLanguages , PlgWebservicesMedia , PlgWebservicesMenus , PlgWebservicesMessages , PlgWebservicesModules , PlgWebservicesNewsfeeds , PlgWebservicesPlugins , PlgWebservicesPrivacy , PlgWebservicesRedirect , PlgWebservicesTags , PlgWebservicesTemplates , PlgWebservicesUsers
  • onBeforeCompileHead() : PlgSystemAccessibility , PlgSystemDebug
  • onBeforeIndex() : Adapter
  • onBeforeRespond() : PlgSystemDebug
  • onBuildIndex() : Adapter
  • onCategoryChangeState() : PlgContentFinder
  • onCheckAnswer() : PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible
  • onConsoleError() : ErrorListener
  • onConsoleTerminate() : ErrorListener
  • onContentAfterDelete() : Joomla , PlgContentFinder
  • onContentAfterDisplay() : PlgContentVote , PlgSystemFields
  • onContentAfterSave() : Joomla , PlgContentFinder , PlgContentJoomla
  • onContentAfterTitle() : PlgSystemFields
  • onContentBeforeChangeFeatured() : PlgWorkflowFeaturing
  • onContentBeforeChangeState() : PlgContentJoomla , PlgWorkflowPublishing
  • onContentBeforeDelete() : PlgContentJoomla
  • onContentBeforeDisplay() : PlgContentPagenavigation , PlgContentVote , PlgSystemFields
  • onContentBeforeSave() : PlgContentFinder , PlgContentJoomla , PlgFieldsSql , PlgMediaActionResize
  • onContentChangeState() : Joomla , PlgContentFinder , PlgContentJoomla
  • onContentNormaliseRequestData() : PlgSystemFields
  • onContentPrepare() : PlgContentContact , PlgContentEmailcloak , PlgContentFields , PlgContentLoadmodule , PlgContentPagebreak , PlgSystemFields
  • onContentPrepareData() : PlgSystemActionLogs , PlgUserProfile , PlgUserToken
  • onContentPrepareForm() : FieldsPlugin , MediaActionPlugin , PlgContentConfirmConsent , PlgSystemActionLogs , PlgSystemFields , PlgSystemLanguagecode , PlgSystemPrivacyconsent , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • onContentVersioningPrepareTable() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onCustomFieldsBeforePrepareField() : PlgFieldsCheckboxes , PlgFieldsList , PlgFieldsMedia , PlgFieldsRadio , PlgFieldsSubform
  • onCustomFieldsGetTypes() : FieldsPlugin
  • onCustomFieldsPrepareDom() : FieldsListPlugin , FieldsPlugin , PlgFieldsCalendar , PlgFieldsColor , PlgFieldsEditor , PlgFieldsImagelist , PlgFieldsMedia , PlgFieldsSql , PlgFieldsSubform , PlgFieldsUrl , PlgFieldsUser
  • onCustomFieldsPrepareField() : FieldsPlugin , PlgFieldsList , PlgFieldsSubform
  • onDisplay() : PlgButtonArticle , PlgButtonContact , PlgButtonFields , PlgButtonImage , PlgButtonMenu , PlgButtonModule , PlgButtonPagebreak , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgEditorCodemirror , PlgEditorNone
  • one() : BigDecimal , BigInteger , BigRational
  • oneOf() : Assert
  • onetimeauth() : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • onetimeauth_verify() : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • onExtensionAfterDelete() : Joomla
  • onExtensionAfterInstall() : PackageAdapter , Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap
  • onExtensionAfterSave() : Joomla
  • onExtensionAfterUninstall() : Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap
  • onExtensionAfterUpdate() : Joomla , PlgExtensionFinder , PlgExtensionJoomla , PlgExtensionNamespacemap , PlgInstallerOverride
  • onExtensionBeforeUpdate() : PlgInstallerOverride
  • onFinderAfterDelete() : PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderAfterSave() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderBeforeSave() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderCategoryChangeState() : PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds
  • onFinderChangeState() : PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • onFinderDelete() : PlgFinderCategories
  • onFinderGarbageCollection() : Adapter
  • onFinderResult() : PlgSystemHighlight
  • onGetIcons() : PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck
  • onGetStatsData() : PlgSystemStats
  • onInit() : PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgEditorCodemirror , PlgEditorTinymce
  • onInstallerAddInstallationTab() : PlgInstallerFolderInstaller , PlgInstallerPackageInstaller , PlgInstallerUrlInstaller , PlgInstallerWebinstaller
  • onInstallerAfterInstaller() : PlgInstallerOverride
  • onInstallerBeforeInstaller() : PlgInstallerOverride
  • onJoomlaAfterUpdate() : Joomla , PlgInstallerOverride
  • onJoomlaBeforeUpdate() : PlgInstallerOverride
  • onKernelResponse() : AddLinkHeaderListener
  • onLoad() : DH , DSA , EC , RSA
  • onPrepareForm() : ContentHelper
  • onPrivacyCanRemoveData() : PlgPrivacyUser
  • onPrivacyCheckPrivacyPolicyPublished() : PlgSystemPrivacyconsent
  • onPrivacyCollectAdminCapabilities() : PlgAuthenticationCookie , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgSystemLanguageFilter
  • onPrivacyExportRequest() : PlgPrivacyActionlogs , PlgPrivacyConsents , PlgPrivacyContact , PlgPrivacyContent , PlgPrivacyMessage
  • onPrivacyRemoveData() : PlgPrivacyUser
  • onProcessList() : MessagesModel
  • onSampledataGetOverview() : PlgSampledataBlog , PlgSampledataMultilang
  • onSetupField() : PlgCaptchaRecaptcha_Invisible
  • onSetupProviders() : PlgFileSystemLocal
  • onStartIndex() : Adapter
  • onTableBeforeStore() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onUserAfterDelete() : Joomla , PlgSystemActionLogs , PlgSystemFields , PlgSystemPrivacyconsent , PlgUserJoomla , PlgUserProfile , PlgUserToken
  • onUserAfterDeleteGroup() : Joomla
  • onUserAfterLogin() : Joomla , PlgAuthenticationCookie , PlgUserJoomla
  • onUserAfterLogout() : PlgAuthenticationCookie
  • onUserAfterRemind() : Joomla
  • onUserAfterSave() : Joomla , PlgSystemActionLogs , PlgSystemFields , PlgSystemLanguageFilter , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserToken
  • onUserAfterSaveGroup() : Joomla
  • onUserAuthenticate() : Basic , Token , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgAuthenticationLdap
  • onUserBeforeSave() : PlgSystemLanguageFilter , PlgSystemPrivacyconsent , PlgSystemRemember , PlgUserProfile , PlgUserTerms
  • onUserLogin() : PlgSystemLanguageFilter , PlgUserJoomla
  • onUserLoginFailure() : Joomla , PlgSystemLog
  • onUserLogout() : Joomla , PlgSystemLogout , PlgSystemRemember , PlgUserJoomla
  • onUserMultifactorGetMethod() : Email , Fixed , Totp , Webauthn , Yubikey
  • onWorkflowAfterTransition() : PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • onWorkflowBeforeTransition() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • onWorkflowFunctionalityUsed() : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • open() : Stream , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler
  • openArchiveFile() : ZIPExtraction
  • openErrorStream() : ConsoleOutput
  • openOutputStream() : ConsoleOutput
  • opensearchsuggest() : SuggestionsController
  • openssl_ctr_process() : SymmetricKey
  • openssl_ofb_process() : SymmetricKey
  • openssl_translate_mode() : SymmetricKey
  • optimise() : IndexController
  • optimize() : IndexerController , Indexer
  • option() : Select
  • options() : Category , Select , Tag , Http , Router , RouterInterface
  • optionsToRegistry() : SearchTools
  • or() : BigInteger , GmpCalculator , Calculator
  • ord() : StringHelper
  • order() : Grid , DatabaseQuery , QueryInterface
  • orderbyPrimary() : QueryHelper
  • orderbySecondary() : QueryHelper
  • orderDown() : JGrid , Nested
  • orderDownIcon() : Pagination
  • ordering() : ListHelper , Menu
  • orderPosition() : ModuleController
  • orderUp() : JGrid , Nested
  • orderUpIcon() : Pagination
  • orInt64() : ParagonIE_Sodium_Core32_Int64
  • orWhere() : DatabaseQuery
  • os2ip() : RSA
  • other() : RsaKey
  • our_strlen() : Crypto
  • our_substr() : Crypto
  • ourStrlen() : Core
  • ourSubstr() : Core
  • out() : CliOutput , Stdout , Xml , CliApplication
  • outerJoin() : DatabaseQuery
  • overrides() : TemplateController
  • overwrite() : ProgressBar , ProgressIndicator , ConsoleSectionOutput


Joomla CMS: Champs de donnée - Fonctions

- p -

  • p() : RsaKey
  • p256KPrivateKey() : ECKey
  • p256KPublicKey() : ECKey
  • p256PrivateKey() : ECKey
  • p256PublicKey() : ECKey
  • p384PrivateKey() : ECKey
  • p384PublicKey() : ECKey
  • p521PrivateKey() : ECKey
  • p521PublicKey() : ECKey
  • packSSH2() : Strings
  • pad() : NativeCalculator , SymmetricKey , PHP , AbstractUnicodeString
  • padBoth() : AbstractString , AbstractUnicodeString , ByteString
  • padEnd() : AbstractString , AbstractUnicodeString , ByteString
  • padStart() : AbstractString , AbstractUnicodeString , ByteString
  • parameterImplementsEventInterface() : CMSPlugin
  • parse() : BigInteger , TraceableTwigEnvironment , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , Document , HtmlDocument , FeedParser , InstallationRouter , Language , AdministratorRouter , Router , Uri , Router , Helper , Html , Parser , Router , AbstractUri , Parser , ArgvInput , ArrayInput , Input , Inline , Parser , Yaml
  • parse_path() : Stream
  • parse_url() : UriHelper
  • parseAddresses() : PHPMailer
  • parseAndLogSqlQuery() : PropelCollector
  • parseAnonymousClass() : ErrorHandler
  • parseApiRoute() : ApiRouter
  • parseArgument() : ArgvInput
  • parseArguments() : Cli
  • parseAttributes() : Utility , SFTP
  • parseBase64() : TemplateParser
  • parseBinary() : TemplateParser
  • parseBinaryIdentifier() : ASNObject
  • parseBlock() : Parser
  • parseBlockScalar() : Parser
  • parseCheckSSL() : SiteRouter
  • parseClaims() : Parser
  • parseColor() : Color
  • parseContentLength() : ASNObject
  • parseFields() : FormattedtextLogger
  • parseFile() : Parser , Yaml
  • parseFiles() : Installer
  • parseFormat() : SiteRouter
  • parseHeader() : Parser , AbstractNegotiator
  • parseHelloFields() : SMTP
  • parseIdentifier() : ASNObject
  • parseIniFile() : LanguageHelper
  • parseInit() : SiteRouter
  • parseLanguageFiles() : LanguageHelper
  • parseLanguages() : Installer
  • parseLongname() : SFTP
  • parseLongOption() : ArgvInput
  • parseMapping() : Inline
  • parseMedia() : Installer
  • parseMode() : SFTP
  • parseOid() : ObjectIdentifier
  • parseOptionalTags() : ComponentAdapter , FileAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • parsePaginationData() : SiteRouter
  • parseParameters() : BaseAccept
  • parsePath() : PostinstallHelper
  • parsePhpDoc() : DebugClassLoader
  • parsePhpInfo() : SysinfoModel
  • parseQueries() : ComponentAdapter , TemplateAdapter , Installer , InstallerAdapter
  • parseQuotedScalar() : Inline
  • parser() : Configuration
  • parseRawRoute() : SiteRouter
  • parseRdnFromEntry() : EntryManager
  • parseRegistryFile() : WebAssetRegistry
  • parseRegistryFiles() : WebAssetRegistry
  • parseRelationshipPaths() : Util
  • parseRoute() : Router , RouterInterface
  • parseRule() : PlgSystemLanguageFilter
  • parseScalar() : Inline
  • parseSchemaUpdates() : Installer
  • parseSefRoute() : SiteRouter
  • parseSequence() : Inline
  • parseShortOption() : ArgvInput
  • parseShortOptionSet() : ArgvInput
  • parseShowOnConditions() : FormHelper
  • parseSignature() : Parser
  • parseSize() : FilesystemHelper
  • parseSizeUnit() : FilesystemHelper
  • parseSQLFiles() : Installer
  • parseTag() : Inline
  • parseTime() : SFTP
  • parseToken() : CompletionInput , ArgvInput
  • parseUri() : Uri
  • parseValue() : Parser
  • parseXMLInstallFile() : Installer
  • parseXMLLanguageFile() : LanguageHelper
  • parseXmlNode() : MenusHelper
  • parseXMLTemplateFile() : PluginsHelper , TemplatesHelper
  • partial_init_sftp_connection() : SFTP
  • passphrase() : Key
  • passSprintf() : Text
  • PasswordHash() : PasswordHash
  • patch() : Http , Router , RouterInterface
  • patchMethod() : DebugClassLoader
  • patchReturnTypeWillChange() : DebugClassLoader
  • payload() : Token
  • pbkdf2() : Core
  • pcntlChildExitStatus() : DaemonApplication
  • pcntlFork() : DaemonApplication
  • pcntlSignal() : DaemonApplication
  • pcntlWait() : DaemonApplication
  • pdf() : Hash
  • pem() : Ec2Key , RsaKey
  • permittedFor() : Builder
  • php_os_family() : Php72
  • phpinfoEnabled() : SysinfoModel
  • phpVersion() : Assertion
  • ping() : SSH2
  • pinned() : Banner
  • pivot() : ArrayHelper
  • pk_to_curve25519() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • pkcs12helper() : SymmetricKey
  • PlainDecrypt() : Crypto
  • PlainEncrypt() : Crypto
  • plainText() : InMemory
  • pluginDisable() : Adapter
  • plural() : Text
  • pluralize() : Inflector , EnglishInflector , FrenchInflector , InflectorInterface
  • plus() : BigDecimal , BigInteger , BigRational
  • poly() : Hash
  • poly1305() : SymmetricKey , Salsa20
  • polyfill_is_fast() : ParagonIE_Sodium_Compat
  • polynomialDivide() : Integer
  • polynomialMultiply() : Integer
  • pop() : Strings , OutputFormatterStyleStack
  • popBeforeSmtp() : POP3
  • popover() : Bootstrap
  • popStreamContentUntilCurrentSection() : ConsoleSectionOutput
  • populateBigIntegers() : RSAKey
  • populateDatabase() : DatabaseModel
  • populateExtraData() : GroupsModel
  • populateFilesAndFolderList() : FileAdapter
  • populateGroupData() : UserGroupsHelper
  • populateGroupsData() : UserGroupsHelper
  • populateHttpHost() : ConsoleApplication
  • populateMfaMethods() : MethodModel
  • populateState() : AdminModel , ListModel , ActionlogsModel , AssociationsModel , BannersModel , ClientsModel , DownloadModel , TracksModel , CacheModel , CategoriesModel , CategoryModel , CheckinModel , ComponentModel , ModulesModel , TemplatesModel , ContactsModel , CategoriesModel , CategoryModel , FeaturedModel , FormModel , ArticlesModel , FeaturedModel , ArchiveModel , ArticleModel , ArticlesModel , CategoriesModel , CategoryModel , FeaturedModel , FormModel , HistoryModel , FieldModel , FieldsModel , GroupModel , GroupsModel , FiltersModel , IndexModel , MapsModel , SearchesModel , SearchModel , SuggestionsModel , DatabaseModel , DiscoverModel , InstallModel , LanguagesModel , ManageModel , UpdateModel , UpdatesitesModel , InstalledModel , LanguageModel , LanguagesModel , OverrideModel , OverridesModel , LoginModel , TemplateModel , TemplatesModel , ItemModel , ItemsModel , MenuModel , MenusModel , MenutypesModel , ConfigModel , MessageModel , MessagesModel , ModuleModel , ModulesModel , PositionsModel , SelectModel , NewsfeedsModel , CategoriesModel , CategoryModel , NewsfeedModel , PluginModel , PluginsModel , MessagesModel , CapabilitiesModel , ConsentsModel , ExportModel , RemoveModel , RequestsModel , ConfirmModel , RemindModel , RequestModel , LinksModel , TaskModel , TasksModel , TagModel , TagsModel , TagModel , TagsModel , StyleModel , StylesModel , TemplateModel , TemplatesModel , DebuggroupModel , DebuguserModel , GroupsModel , LevelsModel , NoteModel , NotesModel , UsersModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , StagesModel , TransitionModel , TransitionsModel , WorkflowModel , WorkflowsModel
  • positionList() : Modules
  • positions() : ListHelper , Modules
  • positiveInteger() : Assert
  • post() : Http , Router , RouterInterface
  • postDeleteHook() : AdminController
  • postFiles() : ApiController
  • postflight() : InstallerScriptInterface , LegacyInstallerScript , JoomlaInstallerScript
  • postFork() : DaemonApplication
  • postProcess() : Form , FormField
  • postprocessNonSEFBuildRule() : PlgSystemLanguageFilter
  • postprocessSEFBuildRule() : PlgSystemLanguageFilter
  • postSaveHook() : FormController , CategoryController , ContactController , ArticleController , FieldController , GroupController , ModuleController , RequestController , UserController , WorkflowController
  • postSend() : PHPMailer
  • postStoreProcess() : TagsHelper
  • pow() : BCMath , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • power() : BigDecimal , BigInteger , BigRational
  • powerMod() : BigInteger
  • powHelper() : PHP
  • powmod() : BCMath
  • powMod() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • powModHelper() : Base , BuiltIn , DefaultEngine , OpenSSL , Base
  • powModInner() : BCMath , GMP , PHP
  • powModOuter() : Engine
  • precheck() : SFTP
  • preconnect() : PreloadManager , PreloadManagerInterface
  • preferences() : ToolbarHelper
  • prefetch() : PreloadManager , PreloadManagerInterface
  • preflight() : InstallerScript , InstallerScriptInterface , LegacyInstallerScript , JoomlaInstallerScript
  • preg_last_error_msg() : Php80
  • preg_match() : Parser
  • pregOffset() : Iconv
  • preload() : Access , PreloadManager , PreloadManagerInterface
  • preloadAssets() : Document
  • preloadComponents() : Access
  • preloadPermissions() : Access
  • prepare() : TraceablePDO , Content , SqlsrvStatement , PlgContentFields
  • prepareAsciiAndExtrasMaps() : ASCII
  • prepareAsciiExtras() : ASCII
  • prepareAsciiMaps() : ASCII
  • prepareContent() : Helper
  • prepareCoreFiles() : TemplateModel
  • prepareData() : ContenthistoryHelper
  • prepareDimensions() : Image
  • prepareDiscoverInstall() : LibraryAdapter , ModuleAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • prepareDocument() : CategoriesView , CategoryView , HtmlView
  • prepareForm() : CategoryServiceInterface , ContentComponent
  • prepareItem() : JsonApiView , JsonapiView
  • prepareLevel() : ContentmapField
  • prepareOptions() : ConfirmButton , HelpButton , InlinehelpButton , LinkButton , PopupButton , StandardButton , ToolbarButton
  • prepareOptionsNested() : TagField
  • prepareParameterKeyMapping() : MysqliStatement , SqlsrvStatement
  • preparePositiveInteger() : ECSignature , MultibyteStringConverter
  • preparePreUpdate() : UpdateModel
  • prepareReduce() : Base , Montgomery , PowerOfTwo
  • prepareSigningKey() : Client
  • prepareStatement() : DatabaseDriver , MysqliDriver , PdoDriver
  • prepareTable() : AdminModel , BannerModel , ClientModel , ContactModel , ArticleModel , TemplateModel , ModuleModel , NewsfeedModel , TagModel
  • prepareTagItem() : PlgSystemFields
  • prepareToolbar() : HtmlView
  • preParse() : PKCS8
  • prepend() : AbstractString , ByteString , CodePointString , UnicodeString
  • prependBody() : AbstractWebApplication , WebApplicationInterface
  • prependButton() : Toolbar
  • prependFilter() : Stream
  • preprocess() : ActionButton , FeaturedButton , PublishedButton , RouterBase , RouterInterface , RouterLegacy , RouterView , MenuRules , NomenuRules , RulesInterface , StandardRules , MenusHelper , CssMenu , Menu
  • preprocessBuildRule() : PlgSystemLanguageFilter
  • preprocessData() : FormModel
  • preprocessForm() : BannerModel , CategoryModel , FormModel , ModulesModel , TemplatesModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , ItemModel , ItemsModel , ModuleModel , NewsfeedModel , PluginModel , TaskModel , StyleModel , GroupModel , LevelModel , MailModel , UserModel , LoginModel , ProfileModel , RegistrationModel , RemindModel , ResetModel , StageModel , TransitionModel , WorkflowModel
  • preprocessSaveData() : ApiController , CategoriesController , ContactController , ArticlesController , StylesController , UsersController
  • prerender() : PreloadManager , PreloadManagerInterface
  • preSend() : PHPMailer
  • preStoreProcess() : TagsHelper
  • preview() : ToolbarHelper
  • primes() : RsaKey
  • print_popup() : JHtmlIcon
  • print_screen() : JHtmlIcon , Icon
  • printf() : Text
  • privatekey_login() : SSH2
  • process() : Decoder , ColorProcessor , ProcessorInterface , Form , Html , Parser , Rtf , Txt , AddConsoleCommandPass
  • processBlock() : DES
  • processBuildRules() : Router
  • processCoordinate() : ANSI
  • processDates() : Query
  • processDiscover() : ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand
  • processDynamicTaxonomy() : Query
  • processElement() : FeedParser
  • processElementForFeed() : NamespaceParserInterface , ItunesRssParser , MediaRssParser
  • processElementForFeedEntry() : NamespaceParserInterface , ItunesRssParser , MediaRssParser
  • processExecutionRules() : TaskModel
  • processFeedEntry() : AtomParser , RssParser
  • processFileData() : ZIPExtraction
  • processFinite() : Decoder
  • processGroupOptions() : GetConfigurationCommand
  • processHeaders() : AbstractTransport , JSONGeneralSerializer
  • processInfinite() : Decoder
  • processIsPayloadEncoded() : JSONGeneralSerializer
  • processLastExtractedFile() : ZIPExtraction
  • processLimit() : LimitableInterface , SqliteQuery , SqlsrvQuery
  • processLookupFields() : ContenthistoryHelper
  • processParseRules() : Router
  • processPathInstallation() : ExtensionInstallCommand
  • processPayload() : JSONGeneralSerializer
  • processPerson() : RssParser
  • processQuery() : SqlField
  • processRemindRequest() : RemindModel
  • processResetComplete() : ResetModel
  • processResetConfirm() : ResetModel
  • processResetRequest() : ResetModel
  • processSHA3Block32() : Hash
  • processSHA3Block64() : Hash
  • processSignature() : JWSLoader
  • processSingleOption() : GetConfigurationCommand
  • processStaticTaxonomy() : Query
  • processString() : Query
  • processTypeDir() : ZIPExtraction
  • processTypeFileCompressed() : ZIPExtraction
  • processTypeFileUncompressed() : ZIPExtraction
  • processTypeLink() : ZIPExtraction
  • processUpdatePackage() : UpdateCoreCommand
  • processUpdateSites() : PlgExtensionJoomla
  • processUrlInstallation() : ExtensionInstallCommand
  • processWithCertificate() : PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • processWithECDAA() : PackedAttestationStatementSupport , TPMAttestationStatementSupport
  • processWithSelfAttestation() : PackedAttestationStatementSupport
  • profileCall() : TraceablePDO
  • progress() : DebugFormatterHelper
  • progressAdvance() : StyleInterface , SymfonyStyle
  • progressFinish() : StyleInterface , SymfonyStyle
  • progressIterate() : SymfonyStyle
  • progressStart() : StyleInterface , SymfonyStyle
  • propertiesExist() : Assertion
  • property() : Microdata
  • propertyExists() : Assertion , Assert
  • propertyNotExists() : Assert
  • protect() : Container
  • pseudoConstructor() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • publickey() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • publish() : ActionsDropdown , Dropdown , AdminController , AdminModel , Nested , Table , ToolbarHelper , CategoryModel , FeaturedController , ArticleModel , IndexModel , MapsModel , ManageModel , UpdatesitesModel , InstalledModel , ItemsController , ItemModel , MessageModel , NewsfeedModel , TemplateController , TemplateModel , GroupsController , StageModel , WorkflowModel
  • publishContentLanguages() : PlgSampledataMultilang
  • published() : Grid , JGrid , Languages , Redirect
  • publishedOptions() : JGrid , Languages , PluginsHelper , RedirectHelper
  • publishList() : ToolbarHelper
  • punyencodeAddress() : PHPMailer
  • purge() : FinderIndexCommand , ActionlogsController , ActionlogsModel , AssociationsController , AssociationsModel , DisplayController , CacheModel , IndexModel , MapsModel , DiscoverModel , UpdateModel , OverridesModel , MessagesModel , LinksController , LinksModel , PlgInstallerOverride
  • purgeMessages() : AdministratorApplication
  • push() : OutputFormatterStyleStack
  • pushStep() : Installer
  • put() : Http , Router , RouterInterface , SFTP
  • putFiles() : ApiController
  • putFilters() : FinderIndexCommand
  • pwd() : FtpClient , SFTP


Joomla CMS: Champs de donnée - Fonctions

- q -

  • q() : RsaKey , DatabaseDriver , DatabaseQuery
  • QInv() : RsaKey
  • qn() : DatabaseDriver , DatabaseQuery
  • qpByteCallback() : Iconv
  • quarterRound() : ChaCha20 , Salsa20
  • query() : TraceablePDO , Client , XML , Ldap , LdapInterface
  • query_stat_cache() : SFTP
  • queryEncode() : JsonApiView
  • querySet() : DatabaseQuery , QueryInterface
  • quit() : FtpClient , SMTP
  • quote() : TraceablePDO , DatabaseDriver , DatabaseInterface , DatabaseQuery
  • quoteBinary() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • quotedString() : PHPMailer
  • quoteName() : DatabaseDriver , DatabaseInterface , DatabaseQuery
  • quoteNameStr() : DatabaseDriver
  • quoteNameString() : DatabaseDriver
  • quotient() : BigDecimal , BigInteger , BigRational
  • quotientAndRemainder() : BigDecimal , BigInteger , BigRational


Joomla CMS: Champs de donnée - Fonctions

- r -

  • r1() : Stem
  • r2() : Stem
  • radiolist() : Select
  • rand() : DatabaseQuery , QueryInterface , SqlsrvQuery
  • random() : BigInteger
  • randomBits() : BigInteger
  • randombytes_random16() : ParagonIE_Sodium_Compat
  • randombytes_uniform() : ParagonIE_Sodium_Compat
  • randomInteger() : Base , BinaryField , PrimeField
  • randomPrime() : BigInteger
  • randomRange() : BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger
  • randomRangeHelper() : Engine
  • randomRangePrime() : BCMath , GMP , PHP32 , PHP64 , BigInteger
  • randomRangePrimeInner() : Engine , GMP
  • randomRangePrimeOuter() : Engine
  • range() : Assertion , Assert
  • rangeCheck() : Base , Curve25519 , Curve448
  • raw_encrypt() : PrivateKey , PublicKey
  • rawlist() : SFTP
  • rawurlencodeMatchZero() : Uri
  • read() : Stream , StringStream , FtpClient , Stream , FtpClient , Stream , LdapClient , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , CallbackStream , PhpInputStream , RelativeStream , Stream , SSH2 , StreamInterface , StringStream
  • read_put_responses() : SFTP
  • read_remaining_bytes() : SSH2
  • readable() : Assertion , Assert
  • readArchiveHeader() : ZIPExtraction
  • readAsn1Content() : ECSignature , MultibyteStringConverter
  • readAsn1Integer() : ECSignature , MultibyteStringConverter
  • readFile() : Key
  • readFileHeader() : ZIPExtraction
  • readFromProcess() : Terminal
  • readInput() : QuestionHelper
  • readlink() : SFTP
  • readlist() : SFTP
  • readZipInfo() : Zip
  • realpath() : SFTP
  • rebuild() : Asset , Nested , Usergroup , CategoryModel , UpdatesitesController , UpdatesitesModel , ItemModel
  • rebuildPath() : Nested
  • recipient() : SMTP
  • reciprocal() : BigRational
  • recompose() : Normalizer
  • reconcileNames() : CategoryFeedView , FeedView
  • reconnect() : SSH2
  • recordLastTransactionID() : SMTP
  • recoverX() : Ed25519 , Ed448
  • recursiveUpdatePublishedColumn() : Nested
  • redirect() : AbstractWebApplication , WebApplicationInterface , CMSApplication , BaseController
  • redirectsAllowed() : CurlTransport , Curl
  • redirectToAssociations() : AdminModel
  • reduce() : AcceptMatch , Barrett , EvalBarrett , Barrett , Classic , EvalBarrett , Montgomery , PowerOfTwo
  • refineSearchStringToRegex() : ListModel
  • refresh() : ManageModel , StringsController , StringsModel
  • refreshManifestCache() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , Installer
  • refreshMediaVersion() : Version
  • refreshToken() : Client
  • refreshUpdates() : UpdateModel
  • refreshUser() : LdapUserProvider
  • regenerate() : NativeStorage , RuntimeStorage , StorageInterface
  • regenerateBackupCodes() : BackupcodesModel
  • regex() : Assertion , Assert
  • regexp() : DatabaseQuery , QueryInterface
  • register() : ClassLoader , JLoader , CategoryFactory , ComponentDispatcherFactory , HelperFactory , Module , ModuleDispatcherFactory , MVCFactory , RouterFactory , HTMLHelper , Registry , Application , LoggerRegistry , Application , Authentication , CacheController , Config , Console , Database , Dispatcher , Document , Form , HTMLRegistry , Language , Logger , Menu , Pathway , Router , Toolbar , User , WebAssetRegistry , RegistrationModel , ServiceProviderInterface , Stream , ServiceProviderInterface , Application , DescriptorHelper , SignalRegistry , ErrorHandler , VarDumper
  • registerAlias() : CronExpression , JLoader
  • registerAsset() : WebAssetManager
  • registerChannelOpen() : Agent
  • registerDefaultTask() : BaseController
  • registerExtension() : X509
  • registerHandler() : ErrorHandler
  • registerLegacyListener() : CMSPlugin
  • registerListener() : CMSPlugin
  • registerListeners() : PluginInterface
  • registerLogger() : Log
  • registerNamespace() : JLoader , FeedParser
  • registerParser() : FeedFactory
  • registerPrefix() : JLoader
  • registerProvider() : ProviderManager
  • registerServiceProvider() : Container
  • registerSessionHandlerAsService() : Session
  • registerStreamWrapper() : PharStreamWrapper
  • registerTask() : BaseController
  • registerUndefinedFilterCallback() : TraceableTwigEnvironment
  • registerUndefinedFunctionCallback() : TraceableTwigEnvironment
  • registerView() : RouterView
  • regularBarrett() : Barrett
  • regularMultiply() : PHP
  • regularPolynomialMultiply() : Integer
  • reindex() : Adapter
  • reinit() : FtpClient
  • rekey() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • relatedTo() : Builder
  • relative() : Date
  • releaseEditId() : BaseController
  • releaseLock() : Task
  • reload() : InstalledVersions , ArticleController
  • remainder() : BigDecimal , BigInteger , BigRational
  • remindExpiringConsents() : PlgSystemPrivacyconsent
  • remotefsize() : FilesystemHelper , Helper
  • remove() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , JoomlaStorage , WebAssetRegistry , WebAssetRegistryInterface , Adapter , Indexer , ManageModel , ListenersPriorityQueue , InputFilter , LdapClient , Registry , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , EntryManagerInterface , EntryManager , OptionsResolver , PublicKeyCredentialDescriptorCollection
  • remove_from_stat_cache() : SFTP
  • remove_invisible_characters() : ASCII
  • removeArgument() : Event
  • removeAttachment() : Mail
  • removeAttribute() : X509 , Entry
  • removeAttributeValues() : EntryManager
  • removeBlocks() : Html
  • removeCategory() : Feed , FeedEntry
  • removeChild() : NodeInterface
  • removeCommonWords() : PlgExtensionFinder
  • removeContributor() : Feed , FeedEntry
  • removeDecoration() : Helper
  • removeDNProp() : X509
  • removeEntry() : Feed
  • removeEvent() : Dispatcher
  • removeExtension() : TraceableTwigEnvironment , X509
  • removeExtensionFiles() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • removeExtensionHelper() : X509
  • removeField() : Form
  • removeFiles() : Installer , InstallerScript
  • removeFilter() : Stream
  • removeGroup() : Form
  • removeIncludePath() : FileLayout
  • removeIncludePaths() : FileLayout
  • removeIndexPhpFromPath() : ApiRouter
  • removeInstruction() : Result
  • removeLayout() : RouterViewConfiguration
  • removeLink() : FeedEntry
  • removeListener() : Dispatcher , DispatcherInterface
  • removeLocked() : PlgWorkflowNotification
  • removeMaps() : Taxonomy
  • removeNonPrintableCharacters() : Sanitizer
  • removeOrphanMaps() : Taxonomy
  • removeOrphanNodes() : Taxonomy
  • removePackageFiles() : UpdateModel
  • removePharPrefix() : Helper
  • removeRemoteReferences() : Sanitizer
  • removeRevokedCertificateExtension() : X509
  • removeRoot() : Path
  • removeroot() : ApplicationModel
  • removeRoot() : Path
  • removeState() : ActionButton
  • removeSubscriber() : Dispatcher , DispatcherInterface
  • removeUserFromGroup() : UserHelper
  • removeXMLTag() : Sanitizer
  • rename() : FtpClient , LdapClient , SFTP , EntryManagerInterface , EntryManager , PharStreamWrapper
  • renameFile() : TemplateModel
  • renameTable() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • render() : TraceableTwigEnvironment , TraceableTwigTemplate , JavascriptRenderer , AdministratorApplication , ApiApplication , CMSApplication , SiteApplication , WebApplication , ActionButton , FeaturedButton , PublishedButton , TransitionButton , Document , ErrorDocument , FeedDocument , HtmlDocument , ImageDocument , JsonapiDocument , OpensearchDocument , RawDocument , AtomRenderer , RssRenderer , ComponentRenderer , HeadRenderer , MessageRenderer , ModuleRenderer , ModulesRenderer , ScriptsRenderer , StylesRenderer , RendererInterface , XmlDocument , CliRenderer , HtmlRenderer , JsonapiRenderer , JsonRenderer , XmlRenderer , RendererInterface , FormField , ActionsDropdown , Dropdown , Sidebar , InstallationApplication , JsonRenderer , BaseLayout , FileLayout , LayoutHelper , LayoutInterface , Toolbar , ToolbarButton , FieldsHelper , JavascriptRenderer , AbstractUri , PlgSystemStats , Table , CliErrorRenderer , ErrorRendererInterface , HtmlErrorRenderer , SerializerErrorRenderer
  • renderActionlogsExtensions() : PlgSystemActionLogs
  • renderActionlogsNotify() : PlgSystemActionLogs
  • renderAttributes() : ScriptsRenderer , StylesRenderer
  • renderBacktrace() : ErrorDocument
  • renderBlock() : TraceableTwigTemplate
  • renderButton() : CustomButton , DropdownButton , PopupButton , Toolbar , ToolbarButton
  • renderCapturedVar() : DebugBarVarDumper
  • renderCell() : Table
  • renderColumnSeparator() : Table
  • renderDataAsXml() : PrivacyHelper
  • renderDataAttributes() : FormField
  • renderDebugMessages() : BaseLayout
  • renderDirectories() : TextView
  • renderElement() : ScriptsRenderer , StylesRenderer
  • renderEventListenerTable() : DebugEventDispatcherCommand
  • renderException() : ErrorHandler , HtmlErrorRenderer
  • renderField() : SpacerField , Form , FormField
  • renderFieldset() : Form
  • renderHead() : JavascriptRenderer
  • renderInlineElement() : ScriptsRenderer , StylesRenderer
  • renderModal() : Bootstrap
  • renderModule() : ModuleHelper
  • renderOnShutdown() : JavascriptRenderer
  • renderOnShutdownWithHead() : JavascriptRenderer
  • renderParentBlock() : TraceableTwigTemplate
  • renderRawModule() : ModuleHelper
  • renderRow() : Table
  • renderRowSeparator() : Table
  • renderSection() : TextView
  • renderSubmenu() : CssMenu
  • renderTags() : HtmlDescriptor
  • renderThrowable() : Application
  • renderVar() : DebugBarVarDumper
  • reorder() : AdminController , AdminModel , Table , GroupsController , LevelsModel
  • repeat() : AbstractString
  • replace() : LdapClient , ConfigPostProcessor , Replacements , AbstractString , ByteString , CodePointString , UnicodeString
  • replaceColors() : ColorProcessor
  • replaceDependencyAliases() : ConfigPostProcessor
  • replaceDependencyConfiguration() : ConfigPostProcessor
  • replaceDependencyFactories() : ConfigPostProcessor
  • replaceDependencyInvokables() : ConfigPostProcessor
  • replaceDependencyServices() : ConfigPostProcessor
  • replaceExactValue() : ConfigPostProcessor
  • replaceMatches() : AbstractString , AbstractUnicodeString , ByteString , UnicodeString
  • replacementRuleMatch() : ConfigPostProcessor
  • replacePrefix() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • replaceTagInBuffer() : JavascriptRenderer
  • replaceTags() : MailTemplate
  • reply() : MessageController
  • reportInvalidArgument() : Assert
  • republish() : MessageController
  • republishMessage() : MessagesModel
  • request() : CurlTransport , SocketTransport , StreamTransport , Curl , Socket , Stream , TransportInterface
  • request_forwarding() : Agent
  • requestAgentForwarding() : SSH2
  • requestAttestation() : Credentials
  • requestIdentities() : Agent
  • requireAny() : PKCS
  • required() : OptionConfigurator
  • requireDER() : PKCS
  • requirePEM() : PKCS
  • requiresDoubleQuoting() : Escaper
  • requiresSingleQuoting() : Escaper
  • reRegister() : ErrorHandler
  • resend() : UserController
  • reset() : CaBundle , Inflector , Patcher , Form , Nested , Table , TableInterface , Uri , WebAssetManager , SearchesController , SearchesModel , ContainerResource , Patcher , SMTP , SSH2 , Application , OutputFormatterStyleStack , ResetInterface
  • reset_connection() : SFTP , SSH2
  • resetAfter() : Sanitizer
  • resetClonerOptions() : DebugBarVarDumper
  • resetDumperOptions() : DebugBarVarDumper
  • resetDumpHeader() : DebugBarHtmlDumper
  • resetHeadData() : HtmlDocument
  • resetHeadDatum() : HtmlDocument
  • resetInternal() : Sanitizer
  • resetIOCodepage() : QuestionHelper
  • resetMessages() : MessagesModel
  • resetOpCache() : Helper
  • resetOptions() : BaseLayout
  • resetPagination() : Query
  • resetParams() : Microdata
  • resetRandUserId() : ConfigurationModel
  • resetState() : Indexer
  • resetUserLanguage() : LanguageAdapter
  • resize() : Image
  • resizeImage() : TemplateModel
  • resizeKey() : AbstractAES
  • resolve() : ControllerResolver , ControllerResolverInterface , Path , ContentHelper , Path , OptionsResolver , LazyString , Manager , Resolvable , PharInvocationResolver
  • resolveAlias() : MenusHelper , Container
  • resolveAssertable() : PharStreamWrapper
  • resolveBaseName() : PharInvocationResolver
  • resolveContainer() : Reader
  • resolveFourByteLittleEndian() : Reader
  • resolveManifestLength() : Reader
  • resolvePath() : WebAssetItem
  • resolvePossibleAlias() : PharInvocationResolver
  • resolveStream() : Reader
  • resolveStyle() : Table
  • resolveTemplate() : TraceableTwigEnvironment
  • resolveTwoByteBigEndian() : Reader
  • resource() : Assert
  • respond() : AbstractWebApplication , ApiApplication
  • restart() : DaemonApplication , FtpClient , Session , SessionInterface
  • restoreInternalSteamWrapper() : PharStreamWrapper
  • restorePosition() : Cursor
  • resync() : MenusController
  • retrieveInvocation() : PharInvocationResolver
  • retrieveOptionsFromInput() : SetConfigurationCommand
  • retrievePositiveInteger() : ECSignature , MultibyteStringConverter
  • retrieveTokenHeaders() : JWSTokenSupport
  • return_bytes() : WarningsModel
  • reverse() : AbstractString , AbstractUnicodeString , ByteString
  • reverseItems() : Feed
  • revoke() : X509
  • revokedCertificate() : X509
  • rewind() : Construct , DataSet , DatabaseIterator , CallbackStream , RelativeStream , Stream , StreamInterface , SplFixedArray
  • rfcDate() : PHPMailer
  • rglob() : LocalAdapter
  • rI() : RsaKey
  • rightJoin() : DatabaseQuery
  • ristretto255_add() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_elligator() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_from_hash() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_frombytes() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_is_valid_point() : ParagonIE_Sodium_Compat
  • ristretto255_p3_tobytes() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_point_is_canonical() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_random() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_add() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_complement() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_from_string() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_invert() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_mul() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_negate() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_random() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_reduce() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_scalar_sub() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_sqrt_ratio_m1() : ParagonIE_Sodium_Core_Ristretto255
  • ristretto255_sub() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • rmdir() : SFTP , PharStreamWrapper
  • rollBack() : TraceablePDO
  • root() : Uri , Engine , BigInteger
  • rootHelper() : Engine
  • rootInner() : Engine , GMP
  • rotate() : Image , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_Salsa20 , PlgSystemLogrotation
  • rotateLeft32() : Hash
  • rotateLeft64() : Hash
  • rotl_64() : ParagonIE_Sodium_Core_SipHash
  • rotr64() : ParagonIE_Sodium_Core32_BLAKE2b
  • roundingNecessary() : RoundingNecessaryException
  • route() : AdministratorApplication , CMSApplication , SiteApplication
  • rowCount() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • rsadp() : PrivateKey
  • rsaep() : PublicKey
  • rsaes_oaep_decrypt() : PrivateKey
  • rsaes_oaep_encrypt() : PublicKey
  • rsaes_pkcs1_v1_5_decrypt() : PrivateKey
  • rsaes_pkcs1_v1_5_encrypt() : PublicKey
  • rsasp1() : PrivateKey
  • rsassa_pkcs1_v1_5_relaxed_verify() : PublicKey
  • rsassa_pkcs1_v1_5_sign() : PrivateKey
  • rsassa_pkcs1_v1_5_verify() : PublicKey
  • rsassa_pss_sign() : PrivateKey
  • rsassa_pss_verify() : PublicKey
  • rsavp1() : PublicKey
  • rshift() : PHP
  • rtrim() : StringHelper
  • rules() : Inflector
  • run() : Application , Command , LazyCommand , ProcessHelper , SingleCommandApplication , ApplicationTester
  • runCommand() : Application
  • runLazyCron() : PlgSystemSchedulerunner
  • runScheduler() : PlgSystemSchedulerunner
  • runTestCron() : PlgSystemSchedulerunner
  • RuntimeTest() : Crypto
  • runtimeTest() : RuntimeTests
  • runTransition() : AdminController
  • runWebCron() : PlgSystemSchedulerunner
  • rv() : French , Russian , Stem
  • rx() : Stem


Joomla CMS: Champs de donnée - Fonctions

- s -

  • safe_intval() : SymmetricKey
  • safe_intval_inline() : SymmetricKey
  • safe_serialize() : Random
  • safeEncode() : Client
  • safeStrlen() : Crypt , Binary
  • safeSubstr() : Crypt , Binary
  • salsa20() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20 , ChaCha20 , Salsa20
  • salsa20_xor() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • salsa20_xor_ic() : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • same() : Assertion , Assert
  • sanitize() : Sanitizer
  • sanitizeColor() : Backgroundfill
  • sanitizeHeight() : Image
  • sanitizeOffset() : Image
  • sanitizeOptions() : SetConfigurationCommand
  • sanitizeProperty() : Microdata
  • sanitizeType() : Microdata
  • sanitizeWidth() : Image
  • sanityCheckSystemVariables() : CMSApplication
  • sapi_windows_vt100_support() : Php72
  • satisfies() : InstalledVersions
  • satisfy() : Assertion
  • save() : FileStorage , MemcachedStorage , PdoStorage , RedisStorage , StorageInterface , FormController , AdminModel , Table , ToolbarHelper , UCMContent , User , CategoryController , CategoryModel , ApplicationModel , ComponentModel , ConfigController , TemplatesController , FormModel , ArticleController , FormModel , FieldModel , GroupModel , UpdatesiteModel , OverrideController , LanguageModel , OverrideModel , TemplateModel , MediumModel , ItemModel , MenuModel , ConfigController , ConfigModel , MessageModel , ModuleController , ModuleModel , PluginModel , RequestModel , TaskModel , StyleController , StyleModel , TemplateModel , UserController , GroupModel , LevelModel , UserModel , ProfileModel , StageModel , TransitionModel , WorkflowModel , FileStorage , Raw , ASN1 , SSH2 , ASN1 , SSH2
  • save2copy() : ToolbarHelper
  • save2new() : ToolbarHelper
  • saveBytesToChecksummedAsciiSafeString() : Encoding
  • saveConfiguration() : SetConfigurationCommand
  • saveCredentialSource() : PublicKeyCredentialSourceRepository
  • saveCRL() : X509
  • saveCSR() : X509
  • saveGroup() : ToolbarHelper
  • saveorder() : AdminController , AdminModel , Nested , CategoryModel , ItemModel , GroupsController , LevelsModel
  • saveOrderAjax() : AdminController
  • saveOverrides() : PlgInstallerOverride
  • saveParameters() : PKCS1
  • saveParams() : LibraryHelper , PlgSystemStats
  • savePosition() : Cursor
  • savePrivateKey() : PKCS8 , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , libsodium , MontgomeryPrivate , OpenSSH , PKCS1 , PKCS8 , PuTTY , MSBLOB , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML
  • savePSSParams() : PSS
  • savePublicKey() : PKCS8 , OpenSSH , PKCS1 , PKCS8 , PuTTY , Raw , XML , libsodium , MontgomeryPrivate , MontgomeryPublic , OpenSSH , PKCS8 , PuTTY , XML , MSBLOB , OpenSSH , PKCS1 , PKCS8 , PSS , PuTTY , Raw , XML
  • saveSPKAC() : X509
  • saveToAsciiSafeString() : Key , KeyProtectedByPassword
  • saveToIniFile() : LanguageHelper
  • saveX509() : X509
  • sc25519_invert() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_mul() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_sq() : ParagonIE_Sodium_Core_Curve25519
  • sc25519_sqmul() : ParagonIE_Sodium_Core_Curve25519
  • scalar() : Assertion , Assert
  • scalar_add() : ParagonIE_Sodium_Core_Ed25519
  • scalar_complement() : ParagonIE_Sodium_Core_Ed25519
  • scalar_negate() : ParagonIE_Sodium_Core_Ed25519
  • scalar_random() : ParagonIE_Sodium_Core_Ed25519
  • scalar_sub() : ParagonIE_Sodium_Core_Ed25519
  • scalarmult() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scalarmult_base() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scalarmult_ristretto255() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • scalarmult_ristretto255_base() : ParagonIE_Sodium_Compat , ParagonIE_Sodium_Core_Ristretto255
  • scalarmult_throw_if_zero() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • scale() : BCMath
  • scaleValues() : BigDecimal
  • scan1divide() : BCMath , GMP , PHP , BigInteger
  • scopeAt() : ErrorHandler
  • screamAt() : ErrorHandler
  • script() : HTMLHelper , Text
  • scrollspy() : Bootstrap
  • search() : StringsController , StringsModel , AdapterInterface , ApiModel , LdapClient , LocalAdapter , Stem
  • searchAjax() : TagsController
  • searchByString() : PlgAuthenticationLdap
  • searchIfInR1() : Stem
  • searchIfInR2() : Stem
  • searchIfInRv() : Stem
  • searchShortSyllabe() : English
  • searchTags() : TagsHelper
  • second() : DatabaseQuery , QueryInterface
  • secretkey() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • secretstream_xchacha20poly1305_init_pull() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretstream_xchacha20poly1305_init_push() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretstream_xchacha20poly1305_rekey() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • section() : ConsoleOutput , ConsoleOutputInterface , StyleInterface , SymfonyStyle
  • secureHeader() : PHPMailer
  • SecureRandom() : Crypto
  • secureRandom() : Core
  • seek() : SeekingData , Stream , CallbackStream , RelativeStream , Stream , StreamInterface , Data
  • seek_cur() : BufferStreamHandler
  • seek_end() : BufferStreamHandler
  • seek_set() : BufferStreamHandler
  • seemsUtf8() : Inflector
  • select() : Filter , DatabaseInterface , DatabaseQuery , MysqlDriver , MysqliDriver , PdoDriver , QueryInterface , SqliteDriver
  • selectKey() : JWKSet
  • selectRowNumber() : DatabaseQuery , QueryInterface , SqliteQuery
  • Send() : Mail
  • send() : MailController , MailModel , PHPMailer
  • send_binary_packet() : SSH2
  • send_channel_packet() : SSH2
  • send_sftp_packet() : SFTP
  • sendAndMail() : SMTP
  • sendCode() : Email
  • sendCommand() : SMTP
  • sendDataInHeaders() : DebugBar
  • sendHeaders() : AbstractWebApplication , WebApplicationInterface
  • sendHello() : SMTP
  • sendIdentificationStringFirst() : SSH2
  • sendIdentificationStringLast() : SSH2
  • sendJsonResponse() : JSONController
  • sendKEXINITFirst() : SSH2
  • sendKEXINITLast() : SSH2
  • sendMail() : Mail
  • sendmailSend() : PHPMailer
  • sendNotificationEmails() : ActionlogModel
  • sendRequest() : Http , ClientInterface
  • sendResponse() : IndexerController , ApiController
  • sendStats() : PlgSystemStats
  • sendString() : POP3
  • sendTestMail() : ApplicationModel
  • serialize() : BigDecimal , BigInteger , BigRational , Cli , Result , AbstractEvent , Route , Router , CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer , JWSSerializerManager , Uuid , HttpHeaderSerializer
  • serializeHeaders() : AbstractSerializer
  • server() : System
  • serverClaimsUtf8mb4Support() : MysqliDriver
  • serverHostname() : PHPMailer
  • set() : Calculator , ClassLoader , AbstractApplication , ConfigurationAwareApplicationInterface , Cookie , Files , BaseLayout , CMSObject , Session , JoomlaStorage , PhpSetting , Task , DatabaseQuery , QueryInterface , Container , Stream , Cookie , Files , Input , Registry , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Builder , PHPMailer , Color , HelperSet
  • setAAD() : SymmetricKey
  • setAbort() : FeatureEvent
  • setAction() : Sidebar
  • setActive() : AbstractMenu
  • setAdapter() : Archive , Adapter , FetchMediaItemUrlEvent
  • setAdditionalUrlParam() : Pagination
  • setAddPath() : ZIPExtraction
  • setAjaxHandlerAutoShow() : JavascriptRenderer
  • setAjaxHandlerClass() : JavascriptRenderer
  • setAliases() : AbstractCommand , Command
  • setAllLoaded() : CategoryNode
  • setAllowedAttrs() : Sanitizer
  • setAllowedTags() : Sanitizer
  • setAllowedTypes() : OptionsResolver
  • setAllowedValues() : OptionsResolver
  • setAllowIpOverrides() : IpHelper
  • setApcuPrefix() : ClassLoader
  • setApplication() : CMSPlugin , AbstractCommand , Command , LazyCommand
  • setArgument() : AbstractEvent , Event , Input , InputInterface
  • setArguments() : InputDefinition
  • setAssertClass() : LazyAssertion
  • setAssertionClassName() : AssertionChain
  • setAsString() : FlattenException
  • setAttestationSupport() : Authentication
  • setAttribute() : TraceablePDO , WebAssetItem , WebAssetItemInterface , X509 , Entry
  • setAudience() : Builder , ValidationData
  • setAuthor() : Feed , FeedEntry
  • setAutocompleterCallback() : Question
  • setAutocompleterValues() : Question
  • setAutoExit() : Application , SingleCommandApplication
  • setBackground() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • setBarCharacter() : ProgressBar
  • setBarWidth() : ProgressBar
  • setBase() : Document
  • setBasePath() : JavascriptRenderer
  • setBasePoint() : Binary , Montgomery , Prime , TwistedEdwards
  • setBaseTemplateClass() : TraceableTwigEnvironment
  • setBaseUrl() : JavascriptRenderer
  • setBinaryOutput() : OpenSSH
  • setBindAjaxHandlerToFetch() : JavascriptRenderer
  • setBindAjaxHandlerToJquery() : JavascriptRenderer
  • setBindAjaxHandlerToXHR() : JavascriptRenderer
  • setBitmask() : BCMath , Engine
  • setBlockLength() : AES , Rijndael
  • setBody() : AbstractWebApplication , WebApplicationInterface , Mail
  • setBorderFormat() : TableStyle
  • setBrowser() : Browser
  • setBuffer() : Document , HtmlDocument
  • setBuilderFactory() : Configuration
  • setCache() : TraceableTwigEnvironment
  • setCacheControllerFactory() : CacheControllerFactoryAwareInterface
  • setCacheControllerOnObject() : MVCFactory
  • setCaching() : Cache
  • setCAOptionAndValue() : Curl
  • setCatchExceptions() : Application
  • setCatchThrowables() : Application
  • setCellHeaderFormat() : TableStyle
  • setCellRowContentFormat() : TableStyle
  • setCellRowFormat() : TableStyle
  • setCfg() : InstallationApplication
  • setChainExceptions() : ExceptionsCollector
  • setChallenge() : X509
  • setChallengeTimeout() : ReCaptcha
  • setCharset() : TraceableTwigEnvironment , Document , AbstractDumper
  • setClass() : FlattenException
  • setClassMapAuthoritative() : ClassLoader
  • setClient() : FileLayout
  • setCode() : Validate , Command , LazyCommand , FlattenException
  • setCodec() : UuidFactory
  • setCoefficients() : Binary , Montgomery , Prime , TwistedEdwards
  • setColors() : CliDumper
  • setColumnAlias() : Table
  • setColumnMaxWidth() : Table
  • setColumnStyle() : Table
  • setColumnWidth() : Table
  • setColumnWidths() : Table
  • setCommand() : HelpCommand , HelperSet
  • setCommandLoader() : Application
  • setComment() : OpenSSH , PuTTY
  • setCompiler() : TraceableTwigEnvironment
  • setComponent() : FileLayout
  • setComponentRouter() : SiteRouter
  • setConfiguration() : AbstractApplication , ConfigurationAwareApplicationInterface
  • setContainer() : ContainerAwareInterface
  • setContent() : Key
  • setContentLength() : ASNObject
  • setContext() : GetIconEvent , OAuthCallbackEvent , QuickIconsEvent
  • setContextOptions() : Stream
  • setController() : Route
  • setCookieParams() : JoomlaStorage
  • setCorrectPermissions() : ZIPExtraction
  • setCounter() : Session , Salsa20 , PublicKeyCredentialSource
  • setCredentials() : ClientHelper
  • setCredentialsFromRequest() : ClientHelper
  • setCrossingChars() : TableStyle
  • setCryptoEngine() : SSH2
  • setCspHeader() : PlgSystemHttpHeaders
  • setCspNonce() : JavascriptRenderer
  • setCurrentTime() : ValidationData
  • setCurrentUser() : CurrentUserInterface
  • setData() : ConfigCollector , JsonapiDocument , BaseLayout , Document , Relationship , Resource
  • setDatabase() : DatabaseAwareInterface
  • setDataFormatter() : DataCollector , MessagesCollector
  • setDbo() : BaseDatabaseModel , Table , DatabaseExporter , DatabaseImporter
  • setDebug() : Language , BaseLayout
  • setDebugLevel() : SMTP
  • setDebugOutput() : SMTP
  • setDecorated() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setDefault() : LanguagesModel , Language , AbstractMenu , InstalledController , ItemsController , StagesController , WorkflowsController , StageModel , WorkflowModel , InputArgument , InputOption , OptionsResolver
  • setDefaultCommand() : Application
  • setDefaultCrossingChar() : TableStyle
  • setDefaultDataFormatter() : DataCollector
  • setDefaultLogger() : ErrorHandler
  • setDefaults() : Route , OptionsResolver
  • setDefaultVarDumper() : DataCollector
  • setDefined() : OptionsResolver
  • setDefinition() : AbstractCommand , Application , Command , LazyCommand , InputDefinition
  • setDelta() : AfterMoveEvent , BeforeMoveEvent
  • setDeprecated() : OptionsResolver
  • setDescription() : Document , AbstractCommand , Command
  • setDetectBrowser() : SiteApplication
  • setDimensions() : ANSI
  • setDirection() : Document
  • setDispatcher() : DispatcherAwareInterface , Application
  • setDispatcherOnObject() : MVCFactory
  • setDisplayOptions() : CliDumper , HtmlDumper
  • setDn() : LdapClient
  • setDN() : X509
  • setDNProp() : X509
  • setDocumentTitle() : HtmlView
  • setDomain() : X509
  • setDownload() : XmlDocument
  • setDumpBoundaries() : HtmlDumper
  • setDumpHeader() : HtmlDumper
  • setElement() : Result
  • setEmptyBarCharacter() : ProgressBar
  • setEmptyStyle() : OutputFormatterStyleStack
  • setEnableJqueryNoConflict() : JavascriptRenderer
  • setEnclosure() : FeedItem
  • setEncryptionAlgorithm() : PKCS1 , PKCS8
  • setEncryptionMode() : AesInterface , Mcrypt , OpenSSL
  • setEncryptionScheme() : PKCS8
  • setEndDate() : X509
  • setEngine() : SymmetricKey
  • setError() : ApplicationErrorEvent , ErrorDocument , ErrorEvent , CMSObject , ApplicationErrorEvent , CommandErrorEvent , PHPMailer , POP3 , SMTP , ConsoleErrorEvent , ZIPExtraction
  • setErrorMessage() : ChoiceQuestion
  • setErrorOutput() : ConsoleOutput , ConsoleOutputInterface
  • setErrors() : JsonapiDocument , Document
  • setEvent() : Dispatcher
  • setExceptionClass() : LazyAssertion
  • setExceptionHandler() : ErrorHandler
  • setExitCode() : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent
  • setExpectedAction() : ReCaptcha
  • setExpectedApkPackageName() : ReCaptcha
  • setExpectedHostname() : ReCaptcha
  • setExpiration() : Builder
  • setExpire() : Session
  • setExponent() : RSA
  • setExpression() : CronExpression
  • setExtension() : X509
  • setExtensionHelper() : X509
  • setExtensionOutputCheckerHandler() : Server
  • setExtensions() : TraceableTwigEnvironment , ExtensionsListCommand
  • setExtensionValue() : X509
  • setFactory() : Document , Toolbar , Uuid
  • setFetchMode() : MysqliStatement , PdoStatement , SqlsrvStatement , StatementInterface
  • setField() : Form
  • setField_type() : CaptiveRenderOptions , SetupRenderOptions
  • setFieldAttribute() : Form
  • setFields() : Form , OnGetApiFields
  • setFieldValue() : FieldModel
  • setFile() : FlattenException
  • setFilename() : ZIPExtraction
  • setFilters() : ASN1
  • setFlag() : MethodsModel
  • setFooterTitle() : Table
  • setFooterTitleFormat() : TableStyle
  • setForeground() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • setForm() : FormField
  • setFormat() : ProgressBar
  • setFormatDefinition() : ProgressBar
  • setFormatOptions() : HTMLHelper
  • setFormatter() : ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setFormFactory() : FormFactoryAwareInterface
  • setFormFactoryOnObject() : MVCFactory
  • setFragment() : Uri
  • setFrom() : PHPMailer
  • setGenerator() : Document
  • setGroups() : UserGroupsHelper
  • setHandler() : NativeStorage , VarDumper
  • setHash() : Hash
  • setHeadData() : HtmlDocument
  • setHeader() : AbstractWebApplication , WebApplicationInterface , Builder
  • setHeaders() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver , Table , FlattenException
  • setHeaderTitle() : Table
  • setHeaderTitleFormat() : TableStyle
  • setHelp() : AbstractCommand , Command , LazyCommand
  • setHelperFactory() : HelperFactoryAwareInterface
  • setHelperSet() : Application , AbstractCommand , Application , Command , LazyCommand , Helper , HelperInterface
  • setHidden() : AbstractCommand , Command , Question
  • setHiddenFallback() : Question
  • setHistory() : ANSI
  • setHome() : ItemModel , StyleModel
  • setHorizontal() : Table
  • setHorizontalBorderChars() : TableStyle
  • setHost() : Uri
  • setHref() : OutputFormatterStyle
  • setHtml5() : HtmlDocument
  • setHttpDriver() : DebugBar
  • setHttpHeaders() : PlgSystemHttpHeaders
  • setId() : Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Builder , ValidationData
  • setIgnore() : BeforeBindEvent
  • setIgnoreDirectories() : ZIPExtraction
  • setIgnoredSearchWordsCallback() : Language
  • setIncludePaths() : FileLayout
  • setIncludeVendors() : JavascriptRenderer
  • setIndentPad() : AbstractDumper
  • setInfo() : OptionsResolver
  • setInitialization() : JavascriptRenderer
  • setInput() : SaveSetup , OAuthCallbackEvent , InputAwareHelper , InputAwareInterface
  • setInput_attributes() : CaptiveRenderOptions , SetupRenderOptions
  • setInstance() : Log
  • setInteractive() : Input , InputInterface
  • setIOCodepage() : QuestionHelper
  • setIp() : IpHelper
  • setIPAddress() : X509
  • setIssuedAt() : Builder
  • setIssuer() : Builder , ValidationData
  • setItem() : FetchMediaItemEvent
  • setItemName() : Pathway
  • setItems() : Toolbar , FetchMediaItemsEvent
  • setIterationCount() : PKCS8
  • setIV() : SymmetricKey , TripleDES
  • setJavascriptClass() : JavascriptRenderer
  • setJsonapi() : JsonapiDocument , Document
  • setKeepAlive() : SSH2
  • setKey() : RouterViewConfiguration , Crypt , AES , SymmetricKey , DES , Hash , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • setKeyIdentifier() : X509
  • setKeyLength() : AES , Blowfish , SymmetricKey , RC2 , RC4 , Rijndael , TripleDES , Twofish
  • setLanguage() : Document , Result , OutputFilter , PHPMailer
  • setLanguageCookie() : PlgSystemLanguageFilter
  • setLanguageFilter() : SiteApplication
  • setLastExtractedFilename() : ZIPExtraction
  • setLastExtractedFileTimestamp() : ZIPExtraction
  • setLastVisit() : User
  • setLayout() : ActionButton , HtmlView
  • setLayoutExt() : HtmlView
  • setLayoutId() : FileLayout
  • setLE() : PHPMailer
  • setLexer() : TraceableTwigEnvironment
  • setLifeTime() : Cache
  • setLimit() : DatabaseQuery , LimitableInterface
  • setLine() : FlattenException
  • setLineEnd() : Document
  • setLink() : Document
  • setLinkProvider() : PreloadManager , PreloadManagerInterface
  • setListOrder() : SFTP
  • setLoader() : TraceableTwigEnvironment
  • setLocale() : AsciiSlugger
  • setLocation() : Nested
  • setLogger() : LoggerAwareInterface
  • setLoggers() : ErrorHandler
  • setLogQueriesToLogger() : PropelCollector
  • setLowerLimitSearchWordCallback() : Language
  • setManifest() : InstallerAdapter
  • setMaxAttempts() : Question
  • setMaxItems() : AbstractCloner
  • setMaxIterationCount() : CronExpression
  • setMaxSteps() : ProgressBar
  • setMaxString() : AbstractCloner
  • setMaxStringWidth() : CliDumper
  • setMediaVersion() : Document , Version
  • setMenuFactory() : CMSApplication
  • setMergeProperty() : AggregatedCollector
  • setMessage() : BaseController , ProgressBar , ProgressIndicator , FlattenException
  • setMessageType() : PHPMailer
  • setMetaData() : Document
  • setMethod() : Callback
  • setMethods() : Route
  • setMimeEncoding() : Document
  • setMinDepth() : AbstractCloner
  • setModel() : AbstractView
  • setModelState() : MediaController
  • setModExpEngine() : Engine
  • setModifiedDate() : Document
  • setModulo() : Binary , Montgomery , Prime , TwistedEdwards , Integer
  • setMonitor() : DatabaseDriver
  • setMultiline() : Question
  • setMultiselect() : ChoiceQuestion
  • setName() : ConsoleApplication , RouterViewConfiguration , JsonDocument , XmlDocument , Application , AbstractCommand , QueryElement , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , Application , Command
  • setNamespace() : XML
  • setNestable() : RouterViewConfiguration
  • setNonce() : SodiumCipher , Sodium , ChaCha20 , SymmetricKey , Hash , Salsa20
  • setNormalizer() : Question , OptionsResolver
  • setNotBefore() : Builder
  • setNumberConverter() : UuidFactory
  • setOAuth() : PHPMailer
  • setOpenHandlerClass() : JavascriptRenderer
  • setOpenHandlerUrl() : JavascriptRenderer
  • setOpenSSLConfigPath() : RSA
  • setoptArray() : Curl
  • setOption() : ActionButton , ToolbarButton , WebAssetItem , WebAssetItemInterface , PdoDriver , Http , Client , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface , Input , InputInterface , Connection
  • setOptions() : JavascriptRenderer , ActionButton , FtpClient , SetConfigurationCommand , BaseLayout , JoomlaStorage , ToolbarButton , FtpClient , Session , NativeStorage , NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface , InputDefinition
  • setOrder() : Base
  • setOtpConfig() : UserModel
  • setOutput() : CliApplication , AbstractDumper
  • setOverwrite() : Installer , ProgressBar
  • setPackageUninstall() : Installer
  • setPaddingChar() : TableStyle
  • setPadType() : TableStyle
  • setParam() : User
  • setParameters() : User
  • setParams() : ComponentRecord , InstallerScript , MenuItem
  • setParent() : CategoryNode , RouterViewConfiguration , ToolbarButton , NodeInterface
  • setParsedFile() : ParseException
  • setParsedLine() : ParseException
  • setParser() : TraceableTwigEnvironment , Configuration
  • setPart() : CronExpression
  • setPass() : Uri
  • setPassword() : Aes , SymmetricKey , LdapUser
  • setPath() : Installer , BaseController , FetchMediaItemUrlEvent , Uri
  • setPathway() : Pathway
  • setPattern() : Route
  • setPayload() : JsonResponse
  • setPermissions() : Path
  • setPlaceholderFormatterDefinition() : ProgressBar , ProgressIndicator
  • setPluralSuffixesCallback() : Language
  • setPoly1305Key() : SymmetricKey
  • setPort() : Uri
  • setPrecision() : Engine , BigInteger
  • setPrefer() : BigInteger
  • setPreferredAlgorithms() : SSH2
  • setPreferredEngine() : SymmetricKey , TripleDES
  • setPreferredVersion() : SFTP
  • setPreloadManager() : Document
  • setPrevious() : FlattenException
  • setPRF() : PKCS8
  • setPrivateKey() : X509
  • setProcessor() : CliOutput
  • setProcessTitle() : Command , LazyCommand
  • setProgress() : ProgressBar
  • setProgressCharacter() : ProgressBar
  • setPrompt() : ChoiceQuestion
  • setProperties() : CMSObject
  • setProperty() : DataObject
  • setPrototype() : OptionsResolver
  • setProviderManager() : MediaProviderEvent
  • setPsr4() : ClassLoader
  • setPublicKey() : X509
  • setPublished() : LanguagesModel
  • setQuery() : BeforeMoveEvent , BeforePublishEvent , BeforeReorderEvent , DatabaseDriver , DatabaseInterface , DatabaseQuery , Uri
  • setRandomGenerator() : UuidFactory
  • setRealFormat() : ProgressBar
  • setRealUsage() : MemoryCollector
  • setRecord() : Captive , GetSetup , SaveSetup , Validate
  • setRecurLimit() : X509
  • setRecurringModuloFunction() : Integer
  • setRedirect() : BaseController
  • setRedirectUrl() : Installer
  • setRedrawFrequency() : ProgressBar
  • setReduction() : Base , PrimeField
  • setRegex() : Route
  • setRegisteredClaim() : Builder
  • setRelations() : OnGetApiFields
  • setRelationship() : OnGetApiRelation
  • setRenderSqlWithParams() : PDOCollector
  • setReplaceTags() : SetNewTagsEvent
  • setReplyTo() : MailTemplate
  • setRequestIdGenerator() : DebugBar
  • setRequired() : OptionsResolver
  • setReset() : BeforeLoadEvent
  • setResources() : Collection
  • setResponse() : AbstractWebApplication , WebApplicationInterface
  • setResult() : AfterLoadEvent , AfterStoreEvent , ExecuteTaskEvent
  • setReturnType() : DebugClassLoader
  • setRevokedCertificateExtension() : X509
  • setRoute() : InstallerAdapter
  • setRouterOnObject() : MVCFactory
  • setRouteVariables() : Route
  • setRow() : AfterLoadEvent , AfterMoveEvent , Table
  • setRows() : Table
  • setRules() : Table , Route
  • setSchemaVersion() : Installer
  • setScheme() : Uri
  • setScoreThreshold() : ReCaptcha
  • setSearchDisplayedCharactersNumberCallback() : Language
  • setSec() : FixedTimeProvider
  • setSelectedAlgorithms() : Server
  • setSender() : Mail
  • setSeparator() : BreadcrumbsHelper
  • setSerializer() : Resource
  • setSerialNumber() : X509
  • setSession() : SessionAwareWebApplicationInterface , ConsoleApplication
  • setSessionValue() : HttpDriverInterface , PhpHttpDriver , JoomlaHttpDriver
  • setShortName() : OpensearchDocument
  • setSibling() : NodeInterface
  • setSignalsToDispatchEvent() : Application
  • setSignature() : CSR
  • setSiteRouter() : SiteRouterAwareInterface
  • setSize() : SplFixedArray
  • setSkipFiles() : ZIPExtraction
  • setSmallestPrime() : RSA
  • setSMTPInstance() : PHPMailer
  • setSnippet() : ParseException
  • setSort() : AggregatedCollector
  • setSqlQueries() : PdoStorage
  • setSrc() : BeforeBindEvent
  • setStackAlwaysUseSessionStorage() : DebugBar
  • setStackDataSessionNamespace() : DebugBar
  • setStart() : Profiler
  • setStartDate() : X509
  • setstat() : SFTP
  • setstat_recursive() : SFTP
  • setState() : BeforePublishEvent , StatefulModelInterface , Indexer , Session
  • setStaticHeaders() : PlgSystemHttpHeaders
  • setStatusCode() : Response , FlattenException
  • setStatusText() : FlattenException
  • setStopTransition() : WorkflowTransitionEvent
  • setStorage() : DebugBar
  • setStream() : Stream , Input , StreamableInputInterface
  • setStyle() : NullOutputFormatter , OutputFormatter , OutputFormatterInterface , Table
  • setStyleDefinition() : Table
  • setStyles() : CliDumper , HtmlDumper
  • setSubject() : AbstractEvent , WebAssetRegistryAssetChanged , Mail , Builder , ValidationData
  • setSuffixes() : FileLayout
  • setTab() : Document
  • setTag() : SymmetricKey
  • setTagsHelper() : TaggableTableInterface
  • setTemplate() : SiteApplication
  • setTerminal() : SSH2
  • setTheme() : HtmlDumper
  • setThumbnailGenerate() : Image
  • setTimeDataCollector() : TimeableTwigExtensionProfiler
  • setTimeFormat() : ASN1
  • setTimeGenerator() : UuidFactory
  • setTimeHour() : AbstractField
  • setTimeout() : SMTP , SSH2
  • setTimeProvider() : FeatureSet
  • setTimers() : Session
  • setTimezone() : Date
  • setTitle() : Document
  • setToken() : Client
  • setTokenBindingHandler() : Server
  • setTokens() : ArgvInput
  • setTrace() : FlattenException
  • setTraceFromThrowable() : FlattenException
  • setTransliterator() : Language
  • setTrimmable() : Question
  • setType() : Document , Microdata , OnGetApiFields , ItemController
  • setUnsignedInt() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • setup() : JLoader , AccessiblemediaField , CalendarField , CaptchaField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , EditorField , FileField , FilelistField , FolderlistField , MediaField , MenuitemField , MeterField , ModuleorderField , ModulepositionField , NumberField , OrderingField , PasswordField , PluginsField , PredefinedlistField , RulesField , SqlField , SubformField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , TransitionField , UserField , UsergrouplistField , WorkflowconditionField , WorkflowstageField , FormField , LanguageField , ConfigurationModel , CategoryeditField , AssocField , VotelistField , VoteradioField , SectionField , SubfieldsField , TypeField , Adapter , MenuItemByTypeField , MenuField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , CronField , IntervalField , ConsentBoxField , TemplatesListField , UploaddirsField , JoomlatokenField , ChaCha20 , SymmetricKey , Rijndael , Salsa20 , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • setUpBefore() : Sanitizer
  • setUpdateInfo() : CheckJoomlaUpdatesCommand , UpdateCoreCommand
  • setUpdateModel() : UpdateCoreCommand
  • setUpdateNulls() : BeforeStoreEvent
  • setupField() : Captcha
  • setupGCM() : SymmetricKey
  • setUpgrade() : Installer
  • setupInlineCrypt() : Blowfish , DES , RC2 , Rijndael , Twofish
  • setupInstall() : Installer
  • setupInstallPaths() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • setupIsPrime() : Engine
  • setupKey() : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • setupLogging() : CMSApplication
  • setupMaxExecTime() : ZIPExtraction
  • setUpperLimitSearchWordCallback() : Language
  • setupScriptfile() : InstallerAdapter
  • setupSignalHandlers() : DaemonApplication
  • setupUninstall() : ComponentAdapter , FileAdapter , LanguageAdapter , LibraryAdapter , ModuleAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • setupUpdates() : ComponentAdapter , InstallerAdapter
  • setUpWorkflow() : WorkflowModelInterface
  • setUrl() : FetchMediaItemUrlEvent
  • setUsec() : FixedTimeProvider
  • setUsed() : WorkflowFunctionalityUsedEvent
  • setUseIncludePath() : ClassLoader
  • setUseNestingLimit() : Sanitizer
  • setUser() : BeforeDisplayMethods , Validate , AbstractMenu , Uri
  • setUseRequireJs() : JavascriptRenderer
  • setUserGroups() : UserHelper
  • setUserId() : BeforeCheckoutEvent , BeforePublishEvent
  • setUserState() : CMSApplication , CMSWebApplicationInterface
  • setUtf() : DatabaseDriver , MysqliDriver , PdoDriver , SqliteDriver
  • setUuidBuilder() : UuidFactory
  • setValidationConstraints() : Configuration
  • setValidator() : Configuration , Question
  • setValue() : Form , FormField
  • setVar() : Router , Uri
  • setVarDumper() : DataCollector , MessagesCollector
  • setVariable() : PharInvocation
  • setVariableName() : JavascriptRenderer
  • setVars() : Router
  • setVerbosity() : ConsoleOutput , NullOutput , Output , OutputInterface , OutputStyle
  • setVerp() : SMTP
  • setVersion() : Changelog , Application , PuTTY , Application , SingleCommandApplication
  • setVerticalBorderChars() : TableStyle
  • setWebAssetManager() : Document
  • setWhere() : AfterMoveEvent , AfterReorderEvent , BeforeMoveEvent , BeforeReorderEvent
  • setWindowColumns() : SSH2
  • setWindowRows() : SSH2
  • setWindowSize() : SSH2
  • setWordWrap() : PHPMailer
  • setWorkarounds() : Cache
  • setXdebugLinkTemplate() : DataCollector
  • setXdebugReplacement() : DataCollector
  • setXdebugReplacements() : DataCollector
  • setXMLOptions() : Sanitizer
  • sha1() : Hash
  • sha256() : Hash
  • sha384() : Hash
  • sha3_32() : Hash
  • sha3_64() : Hash
  • sha3_pad() : Hash
  • sha512() : Hash
  • share() : Container
  • shift() : Strings
  • shiftedLeft() : BigInteger
  • shiftedRight() : BigInteger
  • shiftLeft() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • shiftRight() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • shortcutToName() : InputDefinition
  • shouldAutoExit() : Application
  • shouldCatchThrowables() : Application
  • shouldDisplayMessage() : PlgQuickiconPhpVersionCheck
  • shouldDisplayPreUpdateCheck() : HtmlView
  • show() : Cursor
  • showTables() : PgsqlDriver
  • shutdown() : DaemonApplication , ZIPExtraction
  • sign() : ECDSA , ES256 , ES256K , ES384 , ES512 , ED256 , ED512 , EdDSA , PSSRSA , RSA , Signature , ECDSA , EdDSA , None , RSA , RSAPKCS1 , RSAPSS , SignatureAlgorithm , RSA , Builder , BaseSigner , Signer , ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto , PHPMailer , PrivateKey , X509 , Identity
  • sign_detached() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519 , ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • sign_open() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • sign_verify_detached() : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • signal() : DaemonApplication
  • signature() : Token
  • signCRL() : X509
  • signCSR() : X509
  • signer() : Configuration
  • signingKey() : Configuration
  • signRequest() : Client
  • signSPKAC() : X509
  • signWithPKCS15() : RSA
  • signWithPSS() : RSA
  • simple_search() : LdapClient
  • simplified() : BigRational
  • singularize() : Inflector , EnglishInflector , FrenchInflector , InflectorInterface
  • sipHash24() : ParagonIE_Sodium_Core32_SipHash , ParagonIE_Sodium_Core_SipHash
  • sipRound() : ParagonIE_Sodium_Core32_SipHash , ParagonIE_Sodium_Core_SipHash
  • size() : FtpClient
  • sk_to_pk() : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • skipExecution() : Task
  • sleep() : DemoTasks
  • slice() : AbstractString , ByteString , CodePointString , UnicodeString
  • slider() : Filter
  • slidingWindow() : Engine , Montgomery
  • slug() : AsciiSlugger , SluggerInterface
  • smtpClose() : PHPMailer
  • smtpConnect() : PHPMailer
  • smtpSend() : PHPMailer
  • snake() : AbstractString , AbstractUnicodeString , ByteString
  • sort() : AggregatedCollector , Grid , SearchTools
  • sortable() : SortableList
  • sortCommands() : ApplicationDescription
  • sortKeys() : JWKSet
  • sortObjects() : ArrayHelper
  • spacer() : ToolbarHelper , Users
  • spl_object_id() : Php72
  • splice() : AbstractString , ByteString , CodePointString , UnicodeString
  • split() : JWS , AbstractString , ByteString , CodePointString , UnicodeString
  • splitJwt() : Parser
  • splitLines() : Patcher
  • splitQueries() : DatabaseModel
  • splitQueryValue() : Uri
  • splitSql() : Installer , DatabaseDriver
  • splitSqlExpression() : SqlsrvQuery
  • splitStream() : AbstractSerializer
  • splitStringByWidth() : Application
  • splitSubPart() : Negotiator
  • sprintf() : Text
  • sqlValue() : PgsqlDriver
  • sqrt() : BCMath , BigDecimal , BigInteger , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator
  • square() : PHP
  • squareReduce() : Base
  • squareRoot() : Integer
  • ssh_agent_login() : SSH2
  • stabilityTagToInteger() : ExtensionAdapter , Update
  • stackData() : DebugBar
  • start() : TracedStatement , Dropdown , JoomlaStorage , IndexerController , Session , SessionInterface , NativeStorage , RuntimeStorage , StorageInterface , DebugFormatterHelper , ProgressBar , ProgressIndicator , LdapAuthenticator , DumpServer
  • startAccordion() : Bootstrap
  • startElement() : Changelog
  • startMeasure() : TimeDataCollector , ProfileCollector
  • startQuery() : ChainedMonitor , DebugMonitor , LoggingMonitor , QueryMonitorInterface
  • startSSHForwarding() : Agent
  • startSubsystem() : SSH2
  • startsWith() : Assertion , AbstractString , ByteString , CodePointString , UnicodeString , Assert
  • startsWithLetter() : Assert
  • startTabSet() : Bootstrap , UiTab
  • startTLS() : SMTP
  • stat() : SFTP
  • stat_helper() : SFTP
  • state() : Grid , JGrid , Manage , Updatesites , Modules
  • statelist() : Finder
  • status() : Messages
  • statusLabel() : Privacy
  • stem() : Helper , El , Language , Catalan , Danish , Dutch , English , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Stemmer , Swedish , StemmerManager
  • step() : ZIPExtraction
  • step0() : Catalan , English , French , Italian , Romanian , Spanish
  • step1() : Danish , Dutch , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Swedish
  • step1a() : Catalan , English
  • step1b() : Catalan , English
  • step1c() : English
  • step2() : Catalan , Danish , Dutch , English , Finnish , German , Italian , Norwegian , Portuguese , Romanian , Russian , Swedish
  • step2a() : French , Spanish
  • step2b() : French , Spanish
  • step3() : Danish , English , Finnish , French , German , Norwegian , Portuguese , Romanian , Russian , Spanish , Swedish
  • step3a() : Dutch , Italian
  • step3b() : Dutch , Italian
  • step4() : Danish , Dutch , English , Finnish , French , Portuguese , Romanian , Russian
  • step5() : English , Finnish , French , Portuguese
  • step6() : Finnish , French
  • stop() : DaemonApplication , Event , DebugFormatterHelper
  • stopMeasure() : TimeDataCollector , ProfileCollector
  • stopPropagation() : AbstractEvent , EventInterface
  • stopQuery() : ChainedMonitor , DebugMonitor , LoggingMonitor , QueryMonitorInterface
  • stopSubsystem() : SSH2
  • store() : Cache , CacheStorage , CallbackController , OutputController , PageController , ViewController , ApcuStorage , FileStorage , MemcachedStorage , RedisStorage , WincacheStorage , FtpClient , Category , Content , ContentHistory , ContentType , CoreContent , Language , Menu , MenuType , Module , Nested , TableInterface , User , Usergroup , UCMBase , UCMContent , Versioning , ContactTable , FieldTable , GroupTable , FilterTable , LinkTable , NewsfeedTable , ConsentTable , RequestTable , LinkTable , TaskTable , TagTable , StyleTable , MfaTable , NoteTable , StageTable , WorkflowTable , FtpClient
  • store64() : ParagonIE_Sodium_Core32_BLAKE2b
  • storeAfterEventFiles() : PlgInstallerOverride
  • storeBeforeEventFiles() : PlgInstallerOverride
  • storeExtension() : FileAdapter , LanguageAdapter , LibraryAdapter , PackageAdapter , PluginAdapter , TemplateAdapter , InstallerAdapter
  • storeFileInfo() : TemplateModel
  • storeNode() : Taxonomy
  • storeOptions() : SetupModel
  • storeUcmBase() : CoreContent
  • storeVote() : ArticleModel
  • str2bin() : Base32
  • str_contains() : Php80
  • str_ends_with() : Php80
  • str_ireplace() : StringHelper
  • str_pad() : StringHelper
  • str_split() : StringHelper
  • str_starts_with() : Php80
  • strcasecmp() : StringHelper
  • strcmp() : StringHelper
  • strcspn() : StringHelper
  • stream() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • stream_cast() : PharStreamWrapper
  • stream_close() : PharStreamWrapper
  • stream_eof() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_flush() : StreamString , StringWrapper , PharStreamWrapper
  • stream_isatty() : Php72
  • stream_lock() : PharStreamWrapper
  • stream_metadata() : PharStreamWrapper
  • stream_open() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_read() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_register() : BufferStreamHandler
  • stream_seek() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_set_option() : PharStreamWrapper
  • stream_stat() : StreamString , StringWrapper , PharStreamWrapper
  • stream_tell() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • stream_truncate() : PharStreamWrapper
  • stream_write() : StreamString , BufferStreamHandler , Buffer , StringWrapper , PharStreamWrapper
  • streamXorIc() : ParagonIE_Sodium_Core32_ChaCha20 , ParagonIE_Sodium_Core32_XChaCha20 , ParagonIE_Sodium_Core_ChaCha20 , ParagonIE_Sodium_Core_XChaCha20
  • stressMemory() : DemoTasks
  • stressMemoryRemoveLimit() : DemoTasks
  • string() : Assertion , PhpSetting , Random , Assert
  • stringify() : Assertion
  • stringJSSafe() : OutputFilter
  • stringNotEmpty() : Assert
  • stringToContext() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • stringToObject() : Ini , Json , Php , Xml , Yaml , FormatInterface
  • stringToSplFixedArray() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • stringURLSafe() : ApplicationHelper , OutputFilter
  • stringUrlSafe() : OutputFilter
  • stringUrlUnicodeSlug() : OutputFilter
  • stripColors() : ColorProcessor
  • stripCssExpressions() : InputFilter
  • stripExt() : File
  • stripFirstBackslash() : JLoader
  • stripIframes() : OutputFilter
  • stripImages() : OutputFilter
  • stripTrailingWSP() : PHPMailer
  • stripTrailingZeros() : BigDecimal
  • stripUSC() : InputFilter
  • stristr() : StringHelper
  • strlen() : StringHelper , ParagonIE_Sodium_Core_Util , Helper , Assert
  • strlen1() : Iconv
  • strlen2() : Iconv
  • strlenWithoutDecoration() : Helper
  • strpos() : StringHelper
  • strrev() : StringHelper
  • strrpos() : StringHelper
  • strspn() : StringHelper
  • strtolower() : StringHelper
  • strtoupper() : StringHelper
  • style() : CliDumper , HtmlDumper
  • stylesheet() : HTMLHelper
  • sub() : BCMath , BcMathCalculator , GmpCalculator , NativeCalculator , Calculator , ParagonIE_Sodium_Compat
  • subAdd2() : Integer
  • subAdd3() : Integer
  • subArray() : X509
  • subArrayUnchecked() : X509
  • subclassOf() : Assertion , Assert
  • sublayout() : FileLayout
  • sublogin() : SSH2
  • submit() : HttpBridgePostRequestMethod , ContactController , CurlPost , Post , SocketPost , RequestMethod
  • subMultiply() : Integer
  • substr() : StringHelper , ParagonIE_Sodium_Core_Util , Helper
  • substr_replace() : StringHelper
  • subtract() : BigInteger , BigIntegerBcmath , BigIntegerGmp , BigInteger , BCMath , GMP , PHP32 , PHP64 , BigInteger , Integer
  • subtractHelper() : PHP
  • subWord() : Rijndael
  • success() : StyleInterface , SymfonyStyle
  • suggest() : SuggestionsController
  • suggested() : Query
  • suggestOption() : CompletionSuggestions
  • suggestOptions() : CompletionSuggestions
  • suggestValue() : CompletionSuggestions
  • suggestValues() : CompletionSuggestions
  • supportedAdditionalInformation() : BreakObject , DoublePrecisionFloatObject , FalseObject , GenericObject , HalfPrecisionFloatObject , NullObject , SimpleObject , SinglePrecisionFloatObject , OtherObject , TrueObject , UndefinedObject
  • supportFunctionality() : WorkflowServiceInterface
  • supports() : JWSTokenSupport , LdapAuthenticator
  • supportsAlias() : CronExpression
  • supportsClass() : LdapUserProvider
  • supportsColors() : CliDumper
  • suppressAllModules() : CaptiveModel
  • swapFields() : GuidStringCodec
  • swapTimestampAndRandomBits() : TimestampFirstCombCodec
  • switchAdminLanguage() : InstalledController , InstalledModel
  • switchDefaultRecord() : MfaTable
  • switchEndianness() : Strings
  • symlink() : SFTP
  • syncPaths() : Form
  • syst() : FtpClient


Joomla CMS: Champs de donnée - Fonctions

- t -

  • t() : Hash
  • tab() : Bootstrap
  • table() : StyleInterface , SymfonyStyle
  • tableize() : Inflector
  • tag() : Container
  • tagDeleteInstances() : TagsHelper
  • tagItem() : TagsHelper
  • tags() : Tag
  • tailDebugLog() : DumpCompletionCommand
  • tel() : Telephone
  • tell() : Stream , CallbackStream , RelativeStream , Stream , StreamInterface
  • templates() : Modules
  • templateStates() : Modules
  • templatestyle() : Users
  • ten() : BigDecimal , BigInteger , BigRational
  • test() : FormRule , CalendarRule , CaptchaRule , ColorRule , CssIdentifierRule , CssIdentifierSubstringRule , EmailRule , EqualsRule , ExistsRule , FilePathRule , FolderPathExistsRule , NotequalsRule , NumberRule , OptionsRule , PasswordRule , RulesRule , SubformRule , TelRule , TimeRule , UrlRule , UserIdRule , UsernameRule , ContactEmailMessageRule , ContactEmailRule , ContactEmailSubjectRule , ExecutionRulesRule , LoginUniqueFieldRule , LogoutUniqueFieldRule
  • testBit() : BigInteger , BCMath , GMP , PHP , BigInteger
  • TestEncryptDecrypt() : Crypto
  • testEncryptDecrypt() : RuntimeTests
  • testForIntermediate() : X509
  • testGet() : ServiceLocatorTest
  • testGetDoesNotMemoize() : ServiceLocatorTest
  • testHas() : ServiceLocatorTest
  • testPrimality() : Engine , GMP
  • testSmallPrimes() : BCMath , PHP
  • testThrowsOnCircularReference() : ServiceLocatorTest
  • testThrowsOnUndefinedInternalService() : ServiceLocatorTest
  • text() : StyleInterface , SymfonyStyle
  • textLine() : PHPMailer
  • that() : Assert , LazyAssertion
  • thatAll() : Assert
  • thatNullOr() : Assert
  • throwAt() : ErrorHandler
  • throws() : Assert
  • thumb() : Templates
  • thumbModal() : Templates
  • thumbprint() : JWK
  • tI() : RsaKey
  • timeField() : X509
  • timestamp() : CombGenerator
  • timezoneSafeModify() : AbstractField
  • timingSafeCompare() : Crypt
  • title() : ToolbarHelper , StyleInterface , SymfonyStyle , AbstractString , AbstractUnicodeString , ByteString
  • title_case() : Mbstring
  • to64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • to_filename() : ASCII
  • to_slugify() : ASCII
  • toArbitraryBase() : BigInteger , Calculator
  • toArray() : JsonapiDocument , DataSet , Registry , RSAKey , ArraySerializer , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , RequestParameters , Response , SplFixedArray , FlattenException , CollectionInterface , Collection , UpdateOperation , Collection , Document , ElementInterface , Relationship , Resource
  • toAsn1() : ECSignature , MultibyteStringConverter , SignatureConverter
  • toast() : Bootstrap
  • toBase() : BigInteger , GmpCalculator , Calculator
  • toBigDecimal() : BigDecimal , BigInteger , BigNumber , BigRational
  • toBigInteger() : BigDecimal , BigInteger , BigNumber , BigRational , PublicKey , Integer
  • toBigRational() : BigDecimal , BigInteger , BigNumber , BigRational
  • toBin() : Base32
  • toBinary() : Calculator
  • toBits() : Engine , GMP , BigInteger , Integer
  • toBytes() : BigInteger , MediaHelper , BigInteger , BCMath , GMP , PHP , BigInteger , Integer
  • toBytesHelper() : Engine
  • toByteString() : AbstractString
  • toCamelCase() : Normalise
  • toCodePointString() : AbstractString , ByteString
  • toDashSeparated() : Normalise
  • toDecimal() : Calculator
  • toFile() : Image
  • toFlatten() : Registry
  • toFloat() : BigDecimal , BigInteger , BigNumber , BigRational
  • toggleTables() : Indexer
  • toggleUpdateSite() : UpdateAdapter
  • toHex() : Engine , BigInteger , Integer , BigNumberConverter , DegradedNumberConverter , NumberConverterInterface
  • toIdentifier() : Collection , ElementInterface , Resource
  • toInt() : BigDecimal , BigInteger , BigNumber , BigRational , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInt32() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInt64() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toInteger() : BigInteger , BigIntegerBcmath , BigIntegerGmp , ArrayHelper
  • toIntOverflow() : IntegerOverflowException
  • toISO8601() : Date
  • token() : Form , Jquery
  • tokenise() : El , Language , Zh
  • tokenize() : TraceableTwigEnvironment , Helper , StringInput , PhpToken
  • tokenizeToDb() : Indexer
  • tokenizeToDbShort() : Indexer
  • toKey() : Normalise
  • toLowerCase() : El
  • toObject() : Registry , ArrayHelper
  • toolbar() : HtmlView
  • tooltip() : Bootstrap , HTMLHelper
  • tooltipText() : HTMLHelper
  • toPEM() : RSAKey
  • toPlural() : Inflector
  • toPower() : BigInteger , BigIntegerBcmath , BigIntegerGmp
  • toPublic() : Ec2Key , JWK , RSAKey
  • toPunycode() : PunycodeHelper
  • toQuerySet() : DatabaseQuery , QueryInterface
  • toQueryString() : RequestParameters
  • toReverseString() : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • toRFC822() : Date
  • tos() : PlgUserProfile
  • toScale() : BigDecimal , BigInteger , BigNumber , BigRational
  • toSingular() : Inflector
  • toSpaceSeparated() : Normalise
  • toSql() : Date
  • toString() : CMSApplication , Registry , AbstractUri , UriInterface , ArrayHelper , Serializer , Signature , DataSet , Token , ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64 , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , AsymmetricKey , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , Parameters , PrivateKey , PublicKey , PrivateKey , PublicKey , BCMath , GMP , PHP , BigInteger , Identity , Uuid , UuidInterface , CommandIsSuccessful , AbstractString
  • total() : UserGroupsHelper
  • touch() : SFTP
  • toUnderscoreSeparated() : Normalise
  • toUnicodeString() : AbstractString , ByteString
  • toUnix() : Date
  • toUpperCase() : El
  • toUri() : Query
  • toUrl() : Client
  • toVariable() : Normalise
  • trace() : Http , Router , RouterInterface
  • traceAt() : ErrorHandler
  • traceUnshift() : ExceptionCaster
  • transactionCommit() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transactionRollback() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transactionStart() : DatabaseInterface , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • transcode() : StringHelper
  • translate() : InstallerModel , UpdateModel , ModulesModel , PluginsModel
  • translateDNProp() : X509
  • translateExtensionName() : UpdateModel
  • translateMethodName() : CaptiveModel
  • translateState() : Adapter
  • transliterate() : Language
  • trash() : ActionsDropdown , Dropdown , ToolbarHelper
  • treerecurse() : Menu
  • triggerDuplicateAliasWarning() : PharInvocationCollection
  • triggerEvent() : EventAwareInterface , Dispatcher
  • triggerManifestScript() : PackageAdapter , InstallerAdapter
  • trim() : StringHelper , PHP , AbstractString , AbstractUnicodeString , ByteString
  • trimEnd() : AbstractString , AbstractUnicodeString , ByteString
  • trimPrefix() : AbstractString , AbstractUnicodeString
  • trimStart() : AbstractString , AbstractUnicodeString , ByteString
  • trimSuffix() : AbstractString , AbstractUnicodeString
  • trimTag() : Parser
  • trimTrailingWhitespace() : Encoding
  • true() : Assertion , Assert
  • truncate() : StringHelper , ArticlesCategoryHelper , SFTP , FormatterHelper , AbstractString
  • truncateComplex() : StringHelper
  • truncateTable() : DatabaseDriver , DatabaseInterface , SqliteDriver
  • tryAll() : LazyAssertion
  • turn() : SMTP
  • twosComplement() : Calculator
  • type() : Key
  • typeCheckResult() : AjaxChallenge , ResultAwareInterface
  • types() : Modules
  • typeslist() : Finder
  • typeSupportsCheckout() : AssociationsHelper
  • typeToString() : Assert


Joomla CMS: Champs de donnée - Fonctions

- u -

  • ucfirst() : StringHelper
  • ucs4_ucs4array() : TranscodeUnicode
  • ucs4array_ucs4() : TranscodeUnicode
  • ucs4array_utf7() : TranscodeUnicode
  • ucs4array_utf7imap() : TranscodeUnicode
  • ucs4array_utf8() : TranscodeUnicode
  • ucwords() : Inflector , StringHelper
  • uhash() : Hash
  • unaccent() : Inflector
  • unarchive() : ActionsDropdown , Dropdown
  • unarchiveList() : ToolbarHelper
  • unbind() : DatabaseQuery , PreparableInterface , LdapClient
  • unDoubling() : Dutch
  • unescapeCharacter() : Unescaper
  • unescapeDoubleQuotedString() : Unescaper
  • unescapeSingleQuotedString() : Unescaper
  • unfeature() : ActionsDropdown
  • unfeatured() : Dropdown
  • unicode_to_utf16() : StringHelper
  • unicode_to_utf8() : StringHelper
  • unicodeLetters() : Assert
  • uninstall() : Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript
  • uninstallEosPlugin() : JoomlaInstallerScript
  • union() : DatabaseQuery , QueryInterface , SqliteQuery , SqlsrvQuery
  • unionAll() : DatabaseQuery , QueryInterface
  • uniqueValues() : Assertion , Assert
  • unix2DosTime() : Zip
  • unlink() : PharStreamWrapper
  • unlock() : Cache , CacheStorage , ApcuStorage , FileStorage , MemcachedStorage , TaskTable
  • unlockindex() : MemcachedStorage
  • unlockKey() : KeyProtectedByPassword
  • unlockTables() : DatabaseInterface , MysqlDriver , MysqliDriver , PgsqlDriver , SqliteDriver
  • unpack() : InstallerHelper
  • unpackSSH2() : Strings
  • unpad() : ParagonIE_Sodium_Compat , SymmetricKey
  • unpublish() : ActionsDropdown , Dropdown , ToolbarHelper , MessageController
  • unpublishList() : ToolbarHelper
  • unpublishMessage() : MessagesModel
  • unregister() : ClassLoader , HTMLHelper
  • unregisterAlias() : CronExpression
  • unregisterProvider() : ProviderManager
  • unregisterTask() : BaseController
  • unrevoke() : X509
  • unserialiseInstance() : ZIPExtraction
  • unserialize() : BigDecimal , BigInteger , BigRational , Cli , Input , Result , AbstractEvent , Route , Router , CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer , JWSSerializer , JWSSerializerManager , Uuid
  • unset() : Color
  • unsetClosureFileInfo() : ReflectionCaster
  • unsetHome() : StyleModel
  • unsetOption() : NullOutputFormatterStyle , OutputFormatterStyle , OutputFormatterStyleInterface
  • unsign() : Builder
  • unTagItem() : TagsHelper
  • untrash() : ActionsDropdown , Dropdown
  • unusedBytesFix() : CertificateToolbox
  • unwrap() : AbstractString
  • update() : Captcha , LanguageAdapter , Installer , InstallerAdapter , InstallerScriptInterface , LegacyInstallerScript , UpdateModel , DatabaseQuery , QueryInterface , JoomlaInstallerScript , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , EntryManagerInterface , EntryManager
  • update_stat_cache() : SFTP
  • updateAssociations() : Workflow
  • updateBodyFor() : JsonResponse
  • updateContentTypes() : JoomlaInstallerScript
  • updated() : TemplatesModel
  • updateDatabase() : JoomlaInstallerScript
  • updateDatabaseMysql() : JoomlaInstallerScript
  • updateFile() : AdapterInterface , ApiModel , LocalAdapter
  • updateJoomlaCore() : UpdateCoreCommand
  • updateLastCheckTimestamp() : Updater
  • updateLogHistory() : SSH2
  • updateManifestCaches() : JoomlaInstallerScript
  • updateObject() : DatabaseDriver , DatabaseInterface , PgsqlDriver
  • updatePeakUsage() : MemoryCollector
  • updateRepr() : ParseException
  • updateSessionRecord() : MetadataManager
  • updateSize() : CacheStorageHelper
  • updateTemplate() : MailTemplate
  • updateUserIds() : ConfigurationModel
  • upgradePassword() : LdapUserProvider
  • upload() : File , Stream , UpdateModel , File , Stream
  • uploadFile() : TemplateController , TemplateModel
  • upper() : AbstractString , AbstractUnicodeString , ByteString , Assert
  • url() : Assertion , PlgUserProfile
  • url_stat() : StreamString , StringWrapper , PharStreamWrapper
  • urlEncodeChar() : Uri
  • urlize() : Inflector
  • urlToPunycode() : PunycodeHelper
  • urlToUTF8() : PunycodeHelper
  • use_fallback() : ParagonIE_Sodium_Compat
  • useAsset() : WebAssetManager , WebAssetManagerInterface
  • useBestEngine() : AsymmetricKey
  • useHtmlVarDumper() : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • useInternalEngine() : AsymmetricKey
  • useNewSodiumAPI() : ParagonIE_Sodium_Compat
  • usePresetItems() : WebAssetManager
  • usergroup() : Access
  • usergroups() : Access
  • userId() : ContactSerializer
  • userlist() : User
  • users() : ListHelper
  • useSendmail() : Mail
  • usesIV() : StreamCipher , SymmetricKey
  • useSmtp() : Mail
  • usesNonce() : SymmetricKey , Salsa20
  • useThreshold() : Sanitizer
  • utf7_ucs4array() : TranscodeUnicode
  • utf7imap_ucs4array() : TranscodeUnicode
  • utf8_decode() : Php72
  • utf8_encode() : Php72
  • utf8_latin_to_ascii() : Transliterate
  • utf8_ucs4array() : TranscodeUnicode
  • utf8CharBoundary() : PHPMailer
  • utf8chr() : Unescaper
  • utf8Encode() : AbstractDumper
  • utf8ToUtf8() : Iconv
  • uuid() : Assertion , UuidFactory , Assert
  • uuid1() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid3() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid4() : Uuid , UuidFactory , UuidFactoryInterface
  • uuid5() : Uuid , UuidFactory , UuidFactoryInterface
  • uuidFromHashedName() : UuidFactory
  • uuidFromNsAndName() : UuidFactory


Joomla CMS: Champs de donnée - Fonctions

- v -

  • valid() : Construct , DataSet , DatabaseIterator , StringHelper , SplFixedArray
  • validArrayKey() : Assert
  • validate() : FromPunycode , AbstractField , DayOfMonthField , DayOfWeekField , FieldInterface , TemplateParser , Form , FormField , SetupModel , FormModel , CategoryModel , FormModel , ArticleModel , FieldModel , GroupModel , TemplateModel , AbstractMediaItemValidationEvent , MenuModel , ModuleModel , RequestModel , LevelModel , Session , AddressValidator , ForwardedValidator , ValidatorInterface , EqualsTo , GreaterOrEqualsTo , LesserOrEqualsTo , Validatable , Token , Validator , Input , InputInterface , LintCommand
  • validateActive() : UploadedFile
  • validateAddress() : PHPMailer
  • validateAgainstRecord() : Yubikey
  • validateAssertionResponse() : Authentication
  • validateAttempts() : QuestionHelper
  • validateCaFile() : CaBundle
  • validateCategoryId() : CategoriesHelper
  • validateConnectionParameters() : DatabaseHelper
  • validateDate() : TemplateModel , X509
  • validateDbConnection() : SetupModel , ApplicationModel
  • validateEncoding() : PHPMailer
  • validateEntry() : DisplayController
  • validateField() : ExecutionRulesRule
  • validateKey() : OpenSSL
  • validateName() : Command
  • validateOptions() : SetConfigurationCommand
  • validatePassword() : Argon2idHandler , Argon2iHandler , BCryptHandler , HandlerInterface , ChainedHandler , MD5Handler , PHPassHandler
  • validatePayload() : AndroidSafetyNetAttestationStatementSupport
  • validatePlugin() : AsymmetricKey
  • validateResponse() : Client
  • validateRowNumber() : DatabaseQuery
  • validateSection() : LegacyComponent , FieldsServiceInterface , ContactComponent , ContentComponent , UsersComponent , UsersHelper
  • validateSignature() : X509 , AndroidSafetyNetAttestationStatementSupport
  • validateSignatureCountable() : X509
  • validateSignatureHelper() : X509
  • validateUploadedFiles() : ServerRequest
  • validateURL() : X509
  • validateUsingGoogleApi() : AndroidSafetyNetAttestationStatementSupport
  • validateYubikeyOtp() : Yubikey
  • validationConstraints() : Configuration
  • validator() : Configuration
  • validComponent() : FileLayout
  • value() : Configuration , Users , AuthenticationExtension
  • values() : DatabaseQuery , QueryInterface
  • valueToString() : Assert
  • valueWithMinScale() : BigDecimal
  • verificationKey() : Configuration
  • verify() : Hmac , Mac , ECDSA , ES256 , ES256K , ES384 , ES512 , ED256 , ED512 , EdDSA , PSSRSA , RSA , Signature , ECDSA , EdDSA , HMAC , MacAlgorithm , None , RSA , RSAPKCS1 , RSAPSS , SignatureAlgorithm , RSA , Signature , BaseSigner , Signer , Token , SMTP , PublicKey , ReCaptcha
  • verify_16() : ParagonIE_Sodium_Core_Util
  • verify_32() : ParagonIE_Sodium_Core_Util
  • verifyAttestation() : Credentials
  • verifyCredentials() : Client
  • verifyEMSAPSS() : PSSRSA , RSA
  • VerifyHMAC() : Crypto
  • verifyHMAC() : Crypto
  • verifyNow() : LazyAssertion
  • verifyPassword() : AbstractUsernamePasswordAuthenticationStrategy
  • verifyPoint() : Binary , KoblitzPrime , Prime , TwistedEdwards
  • verifySignature() : JWSVerifier
  • verifyTypes() : OptionsResolver
  • verifyWithKey() : JWSVerifier
  • verifyWithKeySet() : JWSVerifier
  • verifyWithPKCS15() : RSA
  • verifyWithPSS() : RSA
  • version() : Assertion
  • version_string() : ParagonIE_Sodium_Compat
  • violations() : RequiredConstraintsViolated
  • visibility() : Menus
  • vote() : ArticleController


Joomla CMS: Champs de donnée - Fonctions

- w -

  • walk() : DataSet
  • warning() : PropelCollector , AbstractLogger , LoggerInterface , GithubActionReporter , StyleInterface , SymfonyStyle
  • watermark() : Image
  • wcswidth() : AbstractUnicodeString
  • where() : DatabaseQuery , QueryInterface
  • whereIn() : DatabaseQuery , QueryInterface
  • whereNotIn() : DatabaseQuery , QueryInterface
  • width() : Helper , AbstractString , AbstractUnicodeString , ByteString
  • wildcardIfMatch() : TaskModel
  • with() : JWKSet , Builder , Collection , ElementInterface , Resource
  • withAddedHeader() : MessageInterface
  • withAssertion() : Behavior
  • withAttribute() : ServerRequest , ServerRequestInterface , EvolvableLinkInterface , Link
  • withBody() : MessageInterface
  • withClaim() : Builder
  • withContext() : EC , Data
  • withCookieParams() : ServerRequest , ServerRequestInterface
  • withData() : DatabaseExporter
  • withEncodingOptions() : JsonResponse
  • withFragment() : Uri , UriInterface
  • withHash() : AsymmetricKey , DH , EC , RSA , Identity
  • withHeader() : Builder , MessageInterface
  • withHeaders() : EmptyResponse
  • withHost() : Uri , UriInterface
  • withHref() : EvolvableLinkInterface , Link
  • withLabel() : RSA
  • withLink() : EvolvableLinkProviderInterface , GenericLinkProvider
  • withMaxDepth() : Data
  • withMaxItemsPerDepth() : Data
  • withMethod() : RequestInterface
  • withMGFHash() : RSA
  • without() : JWKSet
  • withoutAttribute() : ServerRequest , ServerRequestInterface , EvolvableLinkInterface , Link
  • withoutHeader() : MessageInterface
  • withoutLink() : EvolvableLinkProviderInterface , GenericLinkProvider
  • withoutRel() : EvolvableLinkInterface , Link
  • withPadding() : RSA , Identity
  • withParsedBody() : ServerRequest , ServerRequestInterface
  • withPassword() : PrivateKey , Identity
  • withPath() : Uri , UriInterface
  • withPayload() : JWSBuilder , JsonResponse
  • withPluralRules() : GenericLanguageInflectorFactory , LanguageInflectorFactory
  • withPointMovedLeft() : BigDecimal
  • withPointMovedRight() : BigDecimal
  • withPort() : Uri , UriInterface
  • withProtocolVersion() : MessageInterface
  • withPublicKey() : Identity
  • withPublicKeyBlob() : Identity
  • withQuery() : Uri , UriInterface
  • withQueryParams() : ServerRequest , ServerRequestInterface
  • withRefHandles() : Data
  • withRel() : EvolvableLinkInterface , Link
  • withRequestTarget() : RequestInterface
  • withSaltLength() : RSA
  • withScheme() : Uri , UriInterface
  • withSignatureFormat() : DSA , EC , Identity
  • withSingularRules() : GenericLanguageInflectorFactory , LanguageInflectorFactory
  • withStatus() : Response , ResponseInterface
  • withStructure() : DatabaseExporter , DatabaseImporter
  • withUploadedFiles() : ServerRequest , ServerRequestInterface
  • withUri() : RequestInterface
  • withUserInfo() : Uri , UriInterface
  • wordwrap() : AbstractString
  • workaroundIPIssues() : IpHelper
  • workflowAfterSave() : WorkflowModelInterface
  • workflowBeforeSave() : WorkflowModelInterface
  • workflowBeforeStageChange() : WorkflowModelInterface
  • workflowCleanupBatchMove() : WorkflowModelInterface
  • workflowPreprocessForm() : WorkflowModelInterface
  • wrap() : AbstractString
  • wrapCallable() : ClassStub
  • wrapCallback() : ProcessHelper
  • wrapPrivateKey() : OpenSSH , PKCS1 , PKCS8 , PuTTY
  • wrapPublicKey() : PKCS1 , PKCS8 , PuTTY
  • wrapText() : PHPMailer
  • writable() : Directory , Assert
  • write() : MonologCollector , SlimCollector , FtpClient , File , Stream , FtpClient , File , Stream , ApcuHandler , DatabaseHandler , MemcachedHandler , RedisHandler , CallbackStream , RelativeStream , Stream , SSH2 , StreamInterface , BashCompletionOutput , CompletionOutputInterface , Descriptor , MarkdownDescriptor , NullOutput , Output , OutputInterface , OutputStyle , SymfonyStyle , Connection
  • writeable() : Assertion
  • writeBuffer() : SymfonyStyle
  • writeConfigFile() : ApplicationModel , SiteStatus
  • writeData() : JsonDescriptor
  • writeDocument() : XmlDescriptor
  • writeError() : QuestionHelper , SymfonyQuestionHelper
  • writeFile() : Stream , UploadedFile
  • writeln() : NullOutput , Output , OutputInterface , OutputStyle , SymfonyStyle
  • writeNamespaceFile() : JNamespacePsr4Map
  • writeProcessIdFile() : DaemonApplication
  • writePrompt() : QuestionHelper , SymfonyQuestionHelper
  • writeText() : TextDescriptor


Joomla CMS: Champs de donnée - Fonctions

- x -

  • x() : Ec2Key , OkpKey
  • xdebuglink() : Debug
  • xmlToCreate() : DatabaseImporter , MysqlImporter , MysqliImporter , PgsqlImporter
  • xor() : BigInteger , GmpCalculator , Calculator
  • xor64() : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • xorInt32() : ParagonIE_Sodium_Core32_Int32
  • xorInt64() : ParagonIE_Sodium_Core32_Int64
  • xorNonce() : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • xorStrings() : ParagonIE_Sodium_Core_Util
  • xsalsa20() : ParagonIE_Sodium_Core32_XSalsa20 , ParagonIE_Sodium_Core_XSalsa20
  • xsalsa20_xor() : ParagonIE_Sodium_Core32_XSalsa20 , ParagonIE_Sodium_Core_XSalsa20


Joomla CMS: Champs de donnée - Fonctions

- y -

  • y() : Ec2Key
  • year() : DatabaseQuery , QueryInterface


Joomla CMS: Champs de donnée - Fonctions

- z -

  • zero() : BigDecimal , BigInteger , BigRational


Joomla CMS: Champs de donnée - Variables

- $ -

  • $_adapterfolder : Adapter
  • $_adapters : Adapter
  • $_allChildrenloaded : CategoryNode
  • $_application : CacheStorage
  • $_articles : CategoryModel
  • $_authActions : User
  • $_authGroups : User
  • $_authLevels : User
  • $_autoAscii : FtpClient
  • $_autoincrement : Table
  • $_bar : Toolbar
  • $_base32 : Totp
  • $_basepath : Adapter
  • $_basePath : HtmlView , JsonView , PlgEditorTinymce
  • $_buffer : Document
  • $_buttonPath : Toolbar
  • $_cache : Nested , PluginModel , StyleModel
  • $_caching : HtmlDocument
  • $_captcha : CaptchaField
  • $_categories : CategoryModel
  • $_category : CategoryModel
  • $_charset : Document , HtmlView , JsonView
  • $_checkedCategories : Categories
  • $_children : CategoryModel
  • $_classprefix : Adapter
  • $_clients : ApplicationHelper
  • $_columnAlias : Table
  • $_compress : MemcachedStorage
  • $_conn : FtpClient
  • $_constructor : CategoryNode
  • $_context : ItemModel , DownloadModel , CategoriesModel , ContactModel , ArchiveModel , ArticleModel , CategoriesModel , CategoryModel , FeaturedModel , DatabaseModel , InstallModel , MenuModel , CategoriesModel , NewsfeedModel , TagsModel
  • $_custom : HtmlDocument
  • $_data : CacheModel
  • $_dataconn : FtpClient
  • $_db : Adapter , MemcachedStorage , Table
  • $_debug : Nested
  • $_defaultModel : HtmlView , AbstractView
  • $_doc : DocumentRenderer
  • $_editor : Editor
  • $_engine : Document
  • $_error : ErrorDocument
  • $_errorMsg : User
  • $_errors : CMSObject
  • $_extension : Categories , CategoriesModel
  • $_field : Categories
  • $_file : HtmlDocument
  • $_filter : MenusHelper
  • $_generator : Document
  • $_group : OutputController , PageController
  • $_handler : Cache
  • $_hash : CacheStorage
  • $_id : OutputController , PageController
  • $_images : OpensearchDocument
  • $_includePaths : Table
  • $_item : ItemModel , BannerModel , CategoryModel , ContactModel , CategoryModel , UserModel
  • $_items : CategoriesModel
  • $_jsonEncode : CoreContent , Extension , Table , Update , ContactTable , FilterTable , TemplateTable , NewsfeedTable , TaskTable , TagTable , TransitionTable
  • $_key : Categories
  • $_language : CacheStorage
  • $_layout : HtmlView
  • $_layoutExt : HtmlView
  • $_layoutTemplate : HtmlView
  • $_lifetime : CacheStorage
  • $_lineEnd : Document
  • $_lineEndings : FtpClient
  • $_links : HtmlDocument
  • $_location : Nested
  • $_location_id : Nested
  • $_locked : Table
  • $_locked_files : FileStorage
  • $_locking : CacheStorage
  • $_locktest : PageController
  • $_mdate : Document
  • $_metaTags : Document
  • $_mime : Document , DocumentRenderer , AtomRenderer , RssRenderer
  • $_models : AbstractView
  • $_name : JsonDocument , Editor , AbstractView , CMSPlugin , Toolbar
  • $_namespace : Document
  • $_nodes : Categories
  • $_now : CacheStorage
  • $_options : Cache , Categories
  • $_output : HtmlView , JsonView
  • $_pad : ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State
  • $_pagination : CacheModel
  • $_params : User
  • $_parent : CategoriesModel , CategoryModel , CategoriesModel , CategoryModel , CategoriesModel , CategoryModel
  • $_passCodeLength : Totp
  • $_pasv : FtpClient
  • $_path : CategoryNode , HtmlView
  • $_persistent : RedisStorage
  • $_pinModulo : Totp
  • $_prefer : BigInteger
  • $_profile : Document
  • $_raw : Json
  • $_redis : RedisStorage
  • $_removedInStep3 : Finnish
  • $_response : FtpClient
  • $_rh : BigIntegerGmp
  • $_root : FileStorage
  • $_router : Route
  • $_rules : Table
  • $_script : Document
  • $_scripts : Document
  • $_secretLength : Totp
  • $_shortName : OpensearchDocument
  • $_siblings : CategoryModel
  • $_statefield : Categories
  • $_str : BigIntegerBcmath
  • $_style : Document
  • $_styleSheets : Document
  • $_supportNullValue : Category , Content , CoreContent , Extension , Menu , Module , Table , User , BannerTable , ClientTable , ContactTable , FieldTable , GroupTable , FilterTable , LinkTable , UpdatesiteTable , NewsfeedTable , RequestTable , TaskTable , TagTable , MfaTable , NoteTable , StageTable , TransitionTable , WorkflowTable
  • $_tab : Document
  • $_table : Categories , InstallModel
  • $_tbl : Table
  • $_tbl_key : Table
  • $_tbl_keys : Table
  • $_template : HtmlDocument , HtmlView
  • $_template_tags : HtmlDocument
  • $_timeout : FtpClient
  • $_timeStep : Totp
  • $_total : CacheModel
  • $_trackAssets : Table
  • $_type : FtpClient , Document , CMSPlugin
  • $_url : UpdateAdapter , InstallModel
  • $_urls : OpensearchDocument
  • $_validLocations : Nested
  • $a : Binary , Montgomery , Prime , TwistedEdwards
  • $a24 : Montgomery
  • $aad : SymmetricKey
  • $aaguid : AttestedCredentialData , MetadataStatement , MetadataTOCPayloadEntry , PublicKeyCredentialSource
  • $aaid : MetadataStatement , MetadataTOCPayloadEntry
  • $accept : Browser , FileField
  • $acceptEncoding : WebClient
  • $acceptLanguage : WebClient
  • $acceptParsed : Browser
  • $access : CategoryNode , MenuItem , Result
  • $accumulatedDuration : QueryCollector
  • $accumulatedMemory : QueryCollector
  • $accumulatedTime : PropelCollector
  • $action : Sidebar , Response
  • $action_function : PHPMailer
  • $actionlogs : HtmlView
  • $actions : UsersHelper , HtmlView
  • $activation : User
  • $active : MeterField , AbstractMenu , PaginationObject , MethodDescriptor , NativeStorage , RuntimeStorage
  • $activeAssets : WebAssetManager
  • $activeFilters : ListView , HtmlView
  • $activeMFAMethodNames : CaptiveModel
  • $activeonly : WorkflowstageField
  • $adapter : Aes , Ldap
  • $adapters : Archive
  • $adapterType : UnsupportedArchiveException
  • $addition : Changelog
  • $additionalAssets : JavascriptRenderer
  • $additionalHeaders : DistantSingleMetadata , MetadataService
  • $additionalInformation : AbstractCBORObject
  • $additionalQueryStringValues : MetadataService
  • $additionalUrlParams : Pagination
  • $addonAfter : TextField
  • $addonBefore : TextField
  • $addPath : ZIPExtraction
  • $addTokensToDbQueryTemplate : Indexer
  • $adjective : Russian
  • $adminId : LanguagesModel , PlgSampledataMultilang
  • $aes : Encrypt
  • $agent : Browser , SSH2
  • $aggregates : MessagesCollector
  • $ajaxHandlerAutoShow : JavascriptRenderer
  • $ajaxHandlerBindToFetch : JavascriptRenderer
  • $ajaxHandlerBindToJquery : JavascriptRenderer
  • $ajaxHandlerBindToXHR : JavascriptRenderer
  • $ajaxHandlerClass : JavascriptRenderer
  • $akey : DerivedKeys
  • $alg : PublicKeyCredentialParameters
  • $algo : Hash
  • $algorithmManager : PackedAttestationStatementSupport , AuthenticatorAssertionResponseValidator
  • $algorithmManagerFactory : JWSVerifierFactory
  • $algorithms : Manager , ManagerFactory , AlgorithmManager , AlgorithmManagerFactory
  • $alias : CategoryNode , MenuItem , Nested , UCMBase , UCMType , DatabaseQuery , Iconv , Manifest , PharInvocation
  • $aliases : AbstractCommand , ApplicationDescription , Container , Command , ApplicationDescription
  • $aliasLength : Manifest
  • $all : AssertionChain
  • $all_recipients : PHPMailer
  • $allMFAs : Mfa
  • $allow_arbitrary_length_packets : SFTP
  • $allowAdd : CategoryeditField
  • $allowClear : MenuField
  • $allowCredentials : PublicKeyCredentialRequestOptions
  • $allowDowngrades : InstallerScript
  • $allowedAlgos : Token
  • $allowedAttrs : Sanitizer
  • $allowedCharacters : AbstractString
  • $allowedContexts : PlgUserToken
  • $allowedExtensions : ApiModel
  • $allowedGlobals : Input
  • $allowEdit : MenuField
  • $allowedMethods : MethodNotAllowedException
  • $allowedSchemes : Uri
  • $allowedTags : Sanitizer
  • $allowedTypes : OptionsResolver
  • $allowedUnprivilegedOptions : AdministratorApplication
  • $allowedValues : OptionsResolver
  • $AllowEmpty : PHPMailer
  • $allowEntryBatching : CaptiveRenderOptions , MethodDescriptor , HtmlView
  • $allowIpOverrides : IpHelper
  • $allowLegacyListeners : CMSPlugin , Email , Fixed , Totp , Yubikey , Webauthn
  • $allowMultiple : MethodDescriptor
  • $allowNew : MenuField
  • $allowPropagate : MenuField
  • $allowSelect : MenuField
  • $AltBody : PHPMailer
  • $alternativeDescriptions : MetadataStatement
  • $alternativeNamesSequence : SubjectAlternativeNames
  • $alternatives : CommandNotFoundException
  • $alwaysTryAll : LazyAssertion
  • $alwaysValid : AssertionChain
  • $amountOfFiles : Manifest
  • $animated : MeterField
  • $annotatedParameters : DebugClassLoader
  • $ansi : ANSI
  • $apacheRequestHeaders : ServerRequestFactory
  • $apcuPrefix : ClassLoader
  • $apiKey : AndroidSafetyNetAttestationStatementSupport
  • $apiVersion : Manifest
  • $apkPackageName : Response
  • $app : RouterBase , Dispatcher , LegacyComponentDispatcher , SiteMenu , BaseController , Pagination , ApiRouter , SiteRouter , MetadataManager , Workflow , ActionLogPlugin , HtmlView , FieldsPlugin , SelectModel , TaskModel , Task , HtmlView , JoomlaHttpDriver , Authentication , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgContentConfirmConsent , PlgContentEmailcloak , PlgContentJoomla , PlgContentVote , PlgEditorCodemirror , PlgEditorTinymce , PlgInstallerFolderInstaller , PlgInstallerOverride , PlgInstallerPackageInstaller , PlgInstallerUrlInstaller , PlgInstallerWebinstaller , PlgPrivacyUser , PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemAccessibility , PlgSystemActionLogs , PlgSystemDebug , PlgSystemHighlight , PlgSystemHttpHeaders , PlgSystemJooa11y , PlgSystemLanguagecode , PlgSystemLanguageFilter , PlgSystemLogout , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRemember , PlgSystemSchedulerunner , PlgSystemSef , PlgSystemSessionGc , PlgSystemSkipto , PlgSystemStats , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • $appendExtension : UpdateAdapter
  • $application : ApplicationEvent , TasksListCommand , TasksStateCommand , Factory , CMSPlugin , AbstractCommand , ApplicationDescription , ConsoleEvent , CssMenu , Client , Command , ApplicationDescription , ApplicationTester
  • $applicationDefinitionMerged : AbstractCommand
  • $applicationDefinitionMergedWithArgs : AbstractCommand
  • $archive : HtmlView
  • $archiveFileIsBeingRead : ZIPExtraction
  • $args : Cli
  • $arguments : AbstractEvent , Input , InputDefinition
  • $arrayCache : VarCloner
  • $articleid : ConsentBoxField
  • $ASCII : Normalizer
  • $ASCII_EXTRAS : ASCII
  • $ASCII_MAPS : ASCII
  • $ASCII_MAPS_AND_EXTRAS : ASCII
  • $asFormat : DatabaseExporter , DatabaseImporter
  • $assertClass : LazyAssertion
  • $assertionClass : Assert
  • $assertionClassName : AssertionChain
  • $assertions : Behavior , ConjunctionInterceptor
  • $assertionScheme : MetadataStatement
  • $asset : Editor , EditorField , MediaField
  • $asset_groups : Access
  • $asset_id : CategoryNode
  • $assetField : EditorField , RulesField
  • $assetPermissionsParentIdMapping : Access
  • $assetRules : Access
  • $assetRulesIdentities : Access
  • $assets : CategoryNode , WebAssetRegistry
  • $assoc : HtmlView
  • $associationsContext : AdminModel , CategoryModel , ContactModel , ArticleModel , ItemModel , NewsfeedModel
  • $associationsSupport : AssociationExtensionHelper , AssociationsHelper
  • $asString : FlattenException
  • $attached_pronoun : Catalan
  • $attachment : PHPMailer
  • $attachmentHint : MetadataStatement
  • $attachments : MailTemplate
  • $attempts : Question
  • $attestation : PublicKeyCredentialCreationOptions
  • $attestationCertificateKeyIdentifiers : MetadataStatement , MetadataTOCPayloadEntry
  • $attestationObject : AuthenticatorAttestationResponse
  • $attestationObjectLoader : PublicKeyCredentialLoader
  • $attestationRootCertificates : MetadataStatement
  • $attestationStatementSupportManager : AttestationObjectLoader , AuthenticatorAttestationResponseValidator
  • $attestationStatementSupports : AttestationStatementSupportManager
  • $attestationSupport : Authentication
  • $attestationType : PublicKeyCredentialSource
  • $attestationTypes : MetadataStatement
  • $attestedCredentialData : AuthenticatorData
  • $attr : Cursor , Stub
  • $attr_cell : ANSI
  • $attr_row : ANSI
  • $attrArray : InputFilter
  • $attribute : UpdateOperation
  • $attributes : OnGetApiAttributes , WebAssetItem , ServerRequest , SFTP , Entry , Link
  • $attrMethod : InputFilter
  • $attrs : ANSI
  • $attStmt : AttestationObject , AttestationStatement
  • $audience : PermittedFor
  • $auth : SSH2
  • $auth_method : LdapClient
  • $auth_methods_to_continue : SSH2
  • $authData : AttestationObject , AuthenticatorData
  • $authenticationAlgorithm : MetadataStatement
  • $authenticationAlgorithms : MetadataStatement
  • $authenticationExtension : ExtensionOutputError
  • $authenticationHelper : Webauthn
  • $authenticationPluginType : ApiApplication , CMSApplication
  • $authenticator : LdapAuthenticator
  • $authenticatorAttachment : AuthenticatorSelectionCriteria
  • $authenticatorData : AuthenticatorAssertionResponse
  • $authenticatorSelection : PublicKeyCredentialCreationOptions
  • $authenticatorVersion : MetadataStatement
  • $author : FeedItem , Editor , LibraryManifest
  • $authorEmail : FeedItem
  • $authoremail : LibraryManifest
  • $authorField : EditorField , MediaField
  • $authorurl : LibraryManifest
  • $AuthType : PHPMailer
  • $autoAscii : FtpClient
  • $autocomplete : FormField
  • $autocompleterCallback : Question
  • $autoExit : Application , SingleCommandApplication
  • $autofocus : FormField
  • $autoIncrementField : DatabaseQuery
  • $autoloadLanguage : CMSPlugin , ActionLogPlugin , FieldsPlugin , MediaActionPlugin , PrivacyPlugin , Email , Fixed , Totp , Webauthn , Yubikey , Joomlaupdate , Shortcut , Webauthn , Checkfiles , DemoTasks , Requests , SiteStatus , PlgButtonArticle , PlgButtonContact , PlgButtonFields , PlgButtonImage , PlgButtonMenu , PlgButtonModule , PlgButtonPagebreak , PlgButtonReadmore , PlgCaptchaRecaptcha , PlgCaptchaRecaptcha_Invisible , PlgContentConfirmConsent , PlgEditorCodemirror , PlgEditorTinymce , PlgExtensionJoomla , PlgFileSystemLocal , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags , PlgInstallerOverride , PlgQuickiconDownloadkey , PlgQuickiconExtensionupdate , PlgQuickiconOverrideCheck , PlgQuickiconPhpVersionCheck , PlgQuickiconPrivacyCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemFields , PlgSystemJooa11y , PlgSystemLogout , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRedirect , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWebservicesBanners , PlgWebservicesConfig , PlgWebservicesContact , PlgWebservicesContent , PlgWebservicesInstaller , PlgWebservicesLanguages , PlgWebservicesMedia , PlgWebservicesMenus , PlgWebservicesMessages , PlgWebservicesModules , PlgWebservicesNewsfeeds , PlgWebservicesPlugins , PlgWebservicesPrivacy , PlgWebservicesRedirect , PlgWebservicesTags , PlgWebservicesTemplates , PlgWebservicesUsers , PlgWorkflowFeaturing , PlgWorkflowNotification , PlgWorkflowPublishing
  • $availableCommands : Behavior
  • $b : Binary , Prime , RgbPaletteEntry
  • $background : Color , OutputFormatterStyle
  • $backupCodes : HtmlView
  • $bad_key_size_fix : SSH2
  • $baDesc : VerificationMethodDescriptor
  • $banner_message : SSH2
  • $barChar : ProgressBar
  • $barWidth : ProgressBar
  • $base : Document , PaginationObject , CollectionAdapter , Uri , ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H , DH , CodeAccuracyDescriptor
  • $base2 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $base_attr_cell : ANSI
  • $base_dn : LdapClient
  • $baseDn : LdapUserProvider
  • $basename : TracksModel
  • $baseName : PharInvocation
  • $baseNames : PharInvocationResolver
  • $basePart : Accept
  • $basePath : JavascriptRenderer , FileLayout , BaseController , PlgEditorCodemirror
  • $baseUrl : JavascriptRenderer
  • $baseurl : HtmlDocument
  • $batch_commands : AdminModel , BannerModel , ContactModel , FieldModel , GroupModel , ItemModel , ModuleModel , TagModel
  • $batch_copymove : AdminModel , BannerModel , ContactModel , FieldModel , ItemModel , ModuleModel
  • $batchSet : AdminModel
  • $bcc : PHPMailer
  • $bctx : Blowfish
  • $behavior : Manager
  • $bgBase : ColorStyle
  • $bgColor : ColorStyle
  • $BIDI_UNI_CODE_CONTROLS_TABLE : ASCII
  • $binary : OpenSSH
  • $binary_packet_buffer : SSH2
  • $bindedValues : MysqliStatement , SqlsrvStatement
  • $biometricStatusReports : MetadataTOCPayloadEntry
  • $birthdate : AuthenticationResponse
  • $bitDepth : DisplayPNGCharacteristicsDescriptor
  • $bitmap : SSH2
  • $bitmask : Engine
  • $block : User
  • $block_size : Blowfish , StreamCipher , SymmetricKey , DES , RC2
  • $blockChildUninstall : PackageManifest
  • $blockCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $blockedAttributes : InputFilter
  • $blockedChars : InputFilter
  • $blockedTags : InputFilter
  • $blockSlowdown : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • $Body : PHPMailer
  • $bootstrappingLogger : ErrorHandler
  • $borderFormat : TableStyle
  • $bound : Connection
  • $boundary : PHPMailer
  • $bounded : DatabaseQuery
  • $boundParameters : TraceablePDOStatement
  • $boundParams : DebugMonitor
  • $branches : Taxonomy
  • $browser : WebClient , Browser
  • $browserNav : MenuItem
  • $browserVersion : WebClient
  • $buffer : Profiler , ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , BufferedOutput , TrimmedBufferOutput
  • $bufferedOutput : SymfonyStyle
  • $buffers : BufferStreamHandler , Buffer
  • $builder : StringCodec , FeatureSet
  • $builderFactory : Configuration
  • $buttons : EditorField , SubformField , QuickIconHelper
  • $c : Hash , Rijndael
  • $C : Normalizer
  • $c : EcdaaTrustAnchor
  • $cache : CachedWordInflector , CacheController , Factory , FileLayout , ListModel , Router , LanguageclientField , BackupcodesModel , DatabaseExporter , DatabaseImporter , Cache , Ini , PhpInputStream
  • $cacheable : AbstractWebApplication
  • $cacheControllerFactory : Cache
  • $cachedMap : JNamespacePsr4Map
  • $cacheItemPool : SimpleMetadataStatementRepository
  • $caDesc : VerificationMethodDescriptor
  • $caFileValidity : CaBundle
  • $caFlag : X509
  • $call : DatabaseQuery
  • $callback : CallbackLogger , CallbackStream
  • $callbacks : Factory
  • $calling : OptionsResolver
  • $callStack : LogEntry
  • $callStacks : DebugMonitor
  • $canDisable : MethodDescriptor
  • $canDo : FormView , ListView , HtmlView
  • $canFlushFileCache : File
  • $canGetVendors : InstalledVersions
  • $canonicalize_paths : SFTP
  • $canRemove : Status
  • $capabilities : HtmlView
  • $caPath : CaBundle
  • $captcha : Captcha
  • $captchaEnabled : HtmlView
  • $CAs : X509
  • $caseCheck : DebugClassLoader
  • $casters : AbstractCloner
  • $catchExceptions : Application
  • $catchThrowables : Application
  • $categories : CategoryView , HtmlView
  • $category : FeedItem , FeedDocument , LogEntry , CategoryView , Update
  • $category_association : CategoryAssociationHelper
  • $categoryCache : Router
  • $categoryFactory : RouterFactory , Router
  • $cc : PHPMailer
  • $cC : Normalizer
  • $cellHeaderFormat : TableStyle
  • $cellRowContentFormat : TableStyle
  • $cellRowFormat : TableStyle
  • $certificate : StatusReport
  • $certificateNumber : BiometricStatusReport , StatusReport
  • $certificates : CertificateTrustPath
  • $certificationDescriptor : BiometricStatusReport , StatusReport
  • $certificationPolicyVersion : BiometricStatusReport , StatusReport
  • $certificationRequirementsVersion : BiometricStatusReport , StatusReport
  • $certLevel : BiometricStatusReport
  • $cfb_init_len : Blowfish , SymmetricKey , DES , RC2 , TripleDES , Twofish
  • $chainExceptions : ExceptionsCollector
  • $challenge : X509 , CollectedClientData , PublicKeyCredentialOptions
  • $challengeSize : Server
  • $challengeTs : Response
  • $change : Changelog
  • $changed : SymmetricKey
  • $changeItems : ChangeSet
  • $changelogurl : InstallerAdapter
  • $changeSet : HtmlView
  • $changeSetList : DatabaseModel
  • $channel_buffers : SSH2
  • $channel_close : SFTP
  • $channel_extended_data_type_codes : SSH2
  • $channel_open_failure_reasons : SSH2
  • $channel_status : SSH2
  • $characters : ActionlogsHelper
  • $charcounter : TextareaField
  • $charSet : AbstractWebApplication
  • $CharSet : Mail , PHPMailer
  • $charset : HtmlErrorRenderer , AbstractDumper , SourceContextProvider
  • $checked : CheckboxField
  • $checked_out : CategoryNode
  • $checked_out_time : CategoryNode
  • $checkedClasses : DebugClassLoader
  • $checkedOptions : CheckboxesField
  • $checkers : ExtensionOutputCheckerHandler
  • $checkQuery : ChangeItem
  • $checkQueryExpected : ChangeItem
  • $checkStatus : ChangeItem
  • $checkStringForIllegalChars : AbstractString
  • $checkTags : HtmlView
  • $child : AbstractGroupButton
  • $child_keys : RouterViewConfiguration
  • $childOIDsLoaded : PKCS8 , PSS
  • $children : Construct , RouterViewConfiguration , CategoryView , HtmlView
  • $childrennumitems : CategoryNode
  • $choices : ChoiceQuestion
  • $chunks : ByteStringWithChunkObject
  • $chunksize : Stream
  • $cipher : Crypt
  • $cipher_name_mcrypt : Blowfish , SymmetricKey , DES , RC2 , RC4 , Rijndael , TripleDES , Twofish
  • $cipher_name_openssl : ChaCha20 , SymmetricKey
  • $cipher_name_openssl_ecb : SymmetricKey
  • $cipherMode : Mcrypt
  • $cipherType : Mcrypt
  • $claimFactory : Builder , Token
  • $claims : Builder , Token
  • $class : FormField , DatabaseIterator , FlattenException , Stub
  • $classAliases : JLoader
  • $classAliasesInverse : JLoader
  • $classes : OtherObjectManager , TagObjectManager , JLoader
  • $classInfo : AbstractCloner
  • $classLoader : DebugClassLoader
  • $classMap : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $classMapAuthoritative : ClassLoader
  • $client : AbstractWebApplication , LanguagesModel , InstallerExtension , Update , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , Client , AndroidSafetyNetAttestationStatementSupport
  • $clientDataJSON : AuthenticatorResponse
  • $clientFilename : UploadedFile
  • $clientId : CMSApplication , ChromestyleField , MenuitemField , ModulepositionField , ModuleAdapter , TemplateAdapter , MenuItemByTypeField
  • $clientMediaType : UploadedFile
  • $clientName : TemplatestyleField
  • $cliInput : CliApplication , AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , UpdateCoreCommand
  • $cliScriptFiles : InstallerScript
  • $clock : ValidAt
  • $cloner : DebugBarVarDumper , Dumper , RequestContextProvider
  • $clonerOptions : DebugBarVarDumper
  • $closed : NativeStorage , RuntimeStorage
  • $code : Command , FlattenException
  • $codec : FeatureSet , Uuid , UuidFactory
  • $coefficient : RSAKey
  • $coefficients : PrivateKey
  • $collapseNextHash : CliDumper
  • $collect_urls_enabled : HtmlView
  • $collection : Manager
  • $collectors : AggregatedCollector , DebugBar
  • $color : OutputFormatterStyle
  • $colors : ColorField , CliDumper , HtmlDumper
  • $colorType : DisplayPNGCharacteristicsDescriptor
  • $column : DatabaseIterator
  • $columnMaxWidths : Table
  • $columnNames : MysqliStatement
  • $columns : TextareaField , DatabaseQuery
  • $columnStyles : Table
  • $columnWidths : Table
  • $command : HelpCommand , ConsoleEvent , HelpCommand , LazyCommand , ConsoleEvent , HelperSet , CommandCompletionTester , CommandTester
  • $commandEnabled : BeforeCommandExecuteEvent
  • $commandLoader : Application
  • $commandLoaderServiceId : AddConsoleCommandPass
  • $commandMap : WritableContainerLoader , ContainerLoader , ContainerCommandLoader
  • $commands : Application , ApplicationDescription , Application , ApplicationDescription
  • $commandShouldRun : ConsoleCommandEvent
  • $commandTag : AddConsoleCommandPass
  • $comment : AsymmetricKey , OpenSSH , PuTTY
  • $comments : FeedItem
  • $common : Token
  • $commonName : CertificateSubject
  • $comParams : TagField
  • $compatibleVersions : Update
  • $completionName : CompletionInput
  • $completionOutputs : CompleteCommand
  • $completionType : CompletionInput
  • $completionValue : CompletionInput
  • $component : RouterLegacy , LegacyComponent , RulesField , MenuItem , Workflow , HtmlView , FieldController , GroupController
  • $component_id : MenuItem
  • $componentRouters : SiteRouter
  • $components : ComponentHelper
  • $composerRoots : LinkStub
  • $compress : SSH2
  • $compress_context : SSH2
  • $compressedTotal : ZIPExtraction
  • $compression : DisplayPNGCharacteristicsDescriptor
  • $compression_algorithms_client_to_server : SSH2
  • $compression_algorithms_server_to_client : SSH2
  • $computedKey : Hash
  • $concat_operator : PgsqlDriver
  • $config : Propel2Collector , AbstractApplication , Factory , MetadataManagerListener , SysinfoModel , HtmlView , AbstractConnection , Adapter
  • $configFile : SiteStatus , RSA
  • $configurations : Log
  • $configureException : ErrorHandler
  • $confirmed : PharInvocation
  • $ConfirmReadingTo : PHPMailer
  • $conn : FtpClient
  • $connected : POP3
  • $connection : DatabaseDriver , MysqliDriver , MysqliStatement , PdoDriver , SqlsrvStatement , AbstractQuery , Adapter , Collection , Connection , EntryManager , Query , ServerDumper
  • $connections : PDOCollector , SocketTransport , Socket , SSH2
  • $connectors : DatabaseDriver
  • $consoleInput : Application
  • $consoleOutput : Application
  • $consoleSectionOutputs : ConsoleOutput
  • $consonants : Finnish
  • $constantSupport : Inline
  • $constraints : InvalidArgumentException
  • $constructed : AbstractImmutableEvent , EventImmutable , UriImmutable
  • $contacts : HtmlView
  • $container : ContainerControllerResolver , WritableContainerLoader , Factory , ContainerLoader , ContainerResource , LazyServiceEventListener , ParagonIE_Sodium_Core32_ChaCha20_Ctx , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_ChaCha20_Ctx , ParagonIE_Sodium_Core_Curve25519_Fe , ContainerCommandLoader
  • $content : Microdata , Key , ConsoleSectionOutput , Stub
  • $contentLength : ASNObject , UnknownConstructedObject
  • $contentType : OrderingField , ApiController , AdminModel , BannersController , ClientsController , CategoriesController , ApplicationController , ComponentController , ContactController , ArticlesController , HistoryController , FieldsController , GroupsController , ManageController , LanguagesController , OverridesController , StringsController , AdaptersController , MediaController , ItemsController , MenusController , MessagesController , ModulesController , FeedsController , PluginsController , ConsentsController , RequestsController , RedirectController , TagsController , StylesController , GroupsController , LevelsController , UsersController
  • $ContentType : PHPMailer
  • $context : Stream , LogEntry , ApiController , FormController , ListModel , TracksController , SubfieldsField , GroupsModel , Adapter , FilterModel , SearchModel , SuggestionsModel , OAuthCallbackEvent , Stream , QuickIconsEvent , EC , Stream , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags , Data , PharStreamWrapper
  • $contextAliases : Joomla
  • $contextOptions : Stream
  • $contextProviders : ContextualizedDumper , Connection
  • $continuousBuffer : SymmetricKey
  • $control : ColorField
  • $controlCharsMap : CliDumper
  • $controlCharsRx : CliDumper
  • $controller : ResolvedRoute , Route
  • $controllerResolver : WebApplication
  • $controls : JavascriptRenderer
  • $converter : Ecdsa , DefaultUuidBuilder , DegradedUuidBuilder , CombGenerator , Uuid
  • $convertMap : Iconv
  • $convertToInt : ContentHistory
  • $cookieParams : ServerRequest
  • $copyright : FeedDocument , LibraryManifest
  • $core : LanguageAdapter
  • $coreExtensionIds : ExtensionHelper
  • $coreExtensions : ExtensionHelper
  • $coseAlgorithmManagerFactory : Server
  • $count : Usage , CacheStorageHelper , FormField , Pathway , DatabaseDriver , LanguageErrorsCollector , LanguageFilesCollector , DebugFormatterHelper , SilencedErrorContext
  • $countable : Inflector
  • $counter : Language , CssMenu , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , Salsa20 , PublicKeyCredentialSource
  • $country : CertificateSubject , AuthenticationResponse
  • $created : TaskTable
  • $created_time : CategoryNode
  • $created_user_id : CategoryNode
  • $creationDate : LibraryManifest
  • $credentialId : AttestedCredentialData
  • $credentialPublicKey : AttestedCredentialData , PublicKeyCredentialSource
  • $credentialsRepository : Authentication
  • $credentialStore : LocalStrategy
  • $cronParts : CronExpression
  • $crossingBottomLeftChar : TableStyle
  • $crossingBottomMidChar : TableStyle
  • $crossingBottomRightChar : TableStyle
  • $crossingChar : TableStyle
  • $crossingMidLeftChar : TableStyle
  • $crossingMidRightChar : TableStyle
  • $crossingTopLeftBottomChar : TableStyle
  • $crossingTopLeftChar : TableStyle
  • $crossingTopMidBottomChar : TableStyle
  • $crossingTopMidChar : TableStyle
  • $crossingTopRightBottomChar : TableStyle
  • $crossingTopRightChar : TableStyle
  • $crypto_engine : SSH2
  • $cryptoStrength : MetadataStatement
  • $cspNonce : JavascriptRenderer , HtmlDocument , PlgSystemHttpHeaders
  • $cssFiles : JavascriptRenderer
  • $cssVendors : JavascriptRenderer
  • $curl : CurlPost
  • $current : Uri , DataSet , DatabaseIterator
  • $current_key_length : RC2
  • $current_lang : PlgSystemLanguageFilter
  • $currentCert : X509
  • $currentChain : LazyAssertion
  • $currentChainFailed : LazyAssertion
  • $currentChangelog : Changelog
  • $currentExtensionId : InstallerAdapter
  • $currentIndex : CompletionInput
  • $currentKeyIdentifier : X509
  • $currentLine : Parser
  • $currentLineNb : Parser
  • $currentOffset : ZIPExtraction
  • $currentPath : HtmlView
  • $currentString : StreamString , StringWrapper
  • $currentUpdate : Update
  • $cursor : DatabaseDriver , ProgressBar
  • $curTimeout : SSH2
  • $curve : EC
  • $curveAliases : Identity
  • $curveName : EC
  • $custom_data : Extension
  • $custom_reduction : EvalBarrett
  • $customFieldsCache : SubfieldsField , PlgFieldsSubform
  • $CustomHeader : PHPMailer
  • $customPrefix : CategoryeditField
  • $cut : Stub
  • $d : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H , TwistedEdwards
  • $D : Normalizer
  • $d2 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $dA : PrivateKey
  • $darwinCache : DebugClassLoader
  • $data : InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject , Key , ConfigCollector , DebugBar , Bzip2 , Gzip , Tar , Zip , Rule , Rules , OpensearchImage , Form , LanguagesModel , BaseLayout , MailTemplate , Pagination , JsonResponse , JoomlaStorage , HtmlView , InstalledModel , ProfileModel , RegistrationModel , HtmlView , Input , Registry , RuntimeStorage , DataSet , Data , Document , Relationship , Resource , CollectedClientData , ExtensionDescriptor , SingleMetadata , StringStream
  • $dataAttributes : FormField
  • $database : Factory , DatabaseLogger , DatabaseDriver
  • $dataconn : FtpClient
  • $dataFilesNew : WebAssetRegistry
  • $dataFilesParsed : WebAssetRegistry
  • $dataFormater : DataCollector , MessagesCollector
  • $dataReadLength : ZIPExtraction
  • $date : FeedItem , LogEntry , PlgUserProfile , RogueListEntry
  • $date1 : Query
  • $date2 : Query
  • $dateRelative : HtmlView
  • $dates : Factory
  • $db : DatabaseStrategy , AdapterInstance , RouterFactory , FinderIndexCommand , UpdateCoreCommand , DatabaseLogger , SiteMenu , ChangeItem , ChangeSet , MetadataManager , UCMType , UserFactory , Workflow , ActionLogPlugin , Router , HtmlView , Adapter , Indexer , Router , PrivacyPlugin , Task , Router , HtmlView , ExportCommand , ImportCommand , DatabaseExporter , DatabaseImporter , DatabaseQuery , CreateSessionTableCommand , DatabaseHandler , PlgAuthenticationCookie , PlgAuthenticationJoomla , PlgContentContact , PlgContentJoomla , PlgExtensionFinder , PlgExtensionJoomla , PlgInstallerOverride , PlgQuickiconOverrideCheck , PlgSampledataBlog , PlgSampledataMultilang , PlgSystemActionLogs , PlgSystemDebug , PlgSystemHttpHeaders , PlgSystemLogrotation , PlgSystemPrivacyconsent , PlgSystemRedirect , PlgSystemRemember , PlgSystemSessionGc , PlgSystemStats , PlgSystemTasknotification , PlgSystemUpdatenotification , PlgUserContactCreator , PlgUserJoomla , PlgUserProfile , PlgUserTerms , PlgUserToken , PlgWorkflowNotification
  • $dbMinimum : DatabaseDriver , MysqlDriver , MysqliDriver , PgsqlDriver
  • $dbMinimumMariaDb : DatabaseHelper
  • $dbMinimumMySql : DatabaseHelper
  • $dbMinimumPostgreSql : DatabaseHelper
  • $dbMinMariadb : MysqlDriver , MysqliDriver
  • $dbOptions : DatabaseStrategy
  • $debuffer : SymmetricKey , Salsa20
  • $debug : ErrorDocument , Language , ErrorHandler , HtmlErrorRenderer , SerializerErrorRenderer , FallbackExceptionHandler
  • $debugBar : JavascriptRenderer , OpenHandler , PlgSystemDebug
  • $debugLang : PlgSystemDebug
  • $debugMessages : BaseLayout
  • $Debugoutput : PHPMailer , SMTP
  • $debugStack : DoctrineCollector
  • $dechanged : SymmetricKey
  • $decimalPoint : AbstractDumper
  • $decodedData : Files
  • $decoder : AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Parser , AndroidKeyAttestationStatementSupport , AttestationObjectLoader , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , AuthenticatorAssertionResponseValidator , PublicKeyCredentialLoader
  • $decompress : SSH2
  • $decompress_context : SSH2
  • $decorated : OutputFormatter
  • $decoratedObjects : ExplicitlyTaggedObject
  • $decoratedStream : RelativeStream
  • $decrypt : SSH2
  • $decrypt_block_size : SSH2
  • $decryptFixedPart : SSH2
  • $decryptInvocationCounter : SSH2
  • $decryptIV : SymmetricKey
  • $decryptName : SSH2
  • $default : ColorField , FormField , Language , AbstractMenu , InputArgument , InputOption , Question
  • $default_key_length : RC2
  • $default_lang : PlgSystemLanguageFilter
  • $default_title : SetupRenderOptions
  • $default_view : BaseController , DisplayController , BannersController , ClientsController , DisplayController , CategoriesController , DisplayController , ApplicationController , ComponentController , DisplayController , ContactController , DisplayController , ArticlesController , HistoryController , DisplayController , FieldsController , GroupsController , DisplayController , ManageController , DisplayController , LanguagesController , OverridesController , StringsController , DisplayController , AdaptersController , MediaController , DisplayController , ItemsController , MenusController , DisplayController , MessagesController , DisplayController , ModulesController , DisplayController , FeedsController , DisplayController , PluginsController , DisplayController , ConsentsController , RequestsController , DisplayController , RedirectController , DisplayController , TagsController , DisplayController , StylesController , DisplayController , GroupsController , LevelsController , UsersController , DisplayController
  • $defaultBackendTemplate : HtmlView
  • $defaultBasePath : LayoutHelper
  • $defaultCasters : AbstractCloner
  • $defaultCipherSuite : MysqlDriver
  • $defaultClonerOptions : DebugBarVarDumper
  • $defaultColors : CliDumper
  • $defaultCommand : Application
  • $defaultDataFormatter : DataCollector , AbstractDataCollector
  • $defaultDescription : Command , CompleteCommand , DumpCompletionCommand , ServerDumpCommand , LintCommand
  • $defaultDumperOptions : DebugBarVarDumper
  • $defaultEncryptionAlgorithm : PKCS1 , PKCS8
  • $defaultEncryptionScheme : PKCS8
  • $defaultExponent : RSA
  • $defaultFetchStyle : MysqliStatement , SqlsrvStatement
  • $defaultIterationCount : PKCS8
  • $defaultLanguage : Result , HtmlView
  • $defaultLimits : LimitboxField
  • $defaultLocale : AsciiSlugger
  • $defaultMessage : AssertionChain
  • $defaultMethod : HtmlView
  • $defaultName : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , CheckJoomlaUpdatesCommand , CheckUpdatesCommand , CleanCacheCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionDiscoverListCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveOldFilesCommand , RemoveUserFromGroupCommand , SessionGcCommand , SessionMetadataGcCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand , AbstractCommand , HelpCommand , ListCommand , ExportCommand , ImportCommand , DebugEventDispatcherCommand , DebugRouterCommand , CreateSessionTableCommand , Command , CompleteCommand , DumpCompletionCommand , ServerDumpCommand , LintCommand
  • $defaultNamespaceURI : XPath
  • $defaultObjectClass : SqlsrvStatement
  • $defaultOptions : MemcachedCaster
  • $defaultOutput : AbstractDumper , CliDumper , HtmlDumper
  • $defaultPageTitle : CategoryView , HtmlView
  • $defaultPRF : PKCS8
  • $defaultProperties : Stub
  • $defaultPropertyPath : AssertionChain
  • $defaultRoles : LdapUserProvider
  • $defaults : Route , OptionsResolver
  • $defaultSearch : LdapUserProvider
  • $defaultTargetSrc : HtmlView
  • $defaultVarDumper : DataCollector
  • $defaultVersion : SFTP
  • $defer : FormattedtextLogger
  • $deferredEntries : FormattedtextLogger
  • $defined : OptionsResolver
  • $definition : Application , AbstractCommand , Application , Command , Input
  • $delete : DatabaseQuery
  • $deleteFiles : InstallerScript
  • $deleteFlags : MfaTable
  • $deleteFolders : InstallerScript
  • $demcrypt : SymmetricKey
  • $denominator : BigRational
  • $dependencies : WebAssetItem
  • $dependenciesIsActual : WebAssetManager
  • $deprecated : DebugClassLoader , OptionsResolver
  • $deprecatedAliases : JLoader
  • $depth : Cursor
  • $derivational : Russian
  • $derived : Token
  • $des : TripleDES
  • $des_rounds : DES
  • $desc : TaskOption
  • $description : CategoryNode , Document , FeedImage , FeedItem , FormField , Manifest , Update , Result , Domain , AbstractCommand , Command , InputArgument , InputOption , MetadataStatement
  • $descriptors : DescriptorHelper , ServerDumpCommand
  • $destinations : Patcher
  • $detect_browser : SiteApplication
  • $detection : WebClient
  • $development : HtmlView
  • $direction : Document
  • $directories : SysinfoModel
  • $directory : AccessiblemediaField , FilelistField , FolderlistField , MediaField , HtmlView
  • $directoryIteratorProvider : LintCommand
  • $dirmode : Stream
  • $dirname : FileStorage , TextField
  • $disable : MenuitemField , MenuItemByTypeField
  • $disable64Bit : FeatureSet
  • $disable_url_fetch : X509
  • $disableBigNumber : FeatureSet
  • $disabled : FormField
  • $disableFallbackForUnitTests : ParagonIE_Sodium_Compat
  • $disconnect_reasons : SSH2
  • $dispatcher : Application
  • $dispatcherFactory : Component , Module
  • $display : ColorField , MethodDescriptor
  • $displayCorrectFiles : LintCommand
  • $displayName : PublicKeyCredentialUserEntity
  • $displayOptions : CliDumper , HtmlDumper
  • $divisor : FinderIndexCommand
  • $DKIM_copyHeaderFields : PHPMailer
  • $DKIM_domain : PHPMailer
  • $DKIM_extraHeaders : PHPMailer
  • $DKIM_identity : PHPMailer
  • $DKIM_passphrase : PHPMailer
  • $DKIM_private : PHPMailer
  • $DKIM_private_string : PHPMailer
  • $DKIM_selector : PHPMailer
  • $dn : LdapClient , X509 , AbstractQuery , Entry
  • $dnString : LdapAuthenticator , LdapBadge
  • $do_debug : POP3 , SMTP
  • $do_verp : PHPMailer , SMTP
  • $docOptions : CMSApplication
  • $docs : FeedDocument
  • $document : WebApplication , JsonapiDocument , AbstractRenderer , Factory , AbstractView , JsonApiView , HtmlView , Joomlaupdate
  • $documentFactory : Cache
  • $domains : X509
  • $doTask : BaseController
  • $doubles : Base , English
  • $downloads : Update
  • $downloadSources : Update
  • $driver : DatabaseLogger , ConnectionEvent
  • $dropDownList : ActionsDropdown , Dropdown
  • $dsn : PHPMailer
  • $dummySession : JoomlaHttpDriver
  • $dumper : DebugBarVarDumper , Yaml , Dumper , CliDescriptor , HtmlDescriptor
  • $dumperOptions : DebugBarVarDumper
  • $dumpHeader : HtmlDumper
  • $dumpId : HtmlDumper
  • $dumpKeys : EnumStub
  • $dumpPrefix : HtmlDumper
  • $dumpSuffix : HtmlDumper
  • $duration : TracedStatement
  • $dw : Rijndael
  • $ecb : SymmetricKey
  • $ecdaaKeyId : EcdaaKeyIdTrustPath
  • $ecdaaTrustAnchors : MetadataStatement
  • $editor : FeedDocument , EditorField , SysinfoModel
  • $editorEmail : FeedDocument
  • $editorType : EditorField
  • $editUri : HtmlView
  • $effectiveColumnWidths : Table
  • $effectiveDate : BiometricStatusReport , StatusReport
  • $eid : PlgExtensionJoomla
  • $eight : Prime
  • $ekey : DerivedKeys
  • $element : Subject , NestingException , Changelog , FormField , InstallerAdapter , Update , TemplateModel , DatabaseQuery , Element
  • $elementReferenceResolver : Sanitizer
  • $elements : Result , QueryElement
  • $elementsToRemove : Resolver
  • $email : CertificateSubject , AuthenticationResponse , AddUserCommand , FeedPerson , User
  • $empty : Query
  • $emptyBarChar : ProgressBar
  • $emptyStyle : OutputFormatterStyleStack
  • $enableBlinding : RSA
  • $enabled : ComponentRecord , Multilanguage , Microdata , HtmlView , CssMenu
  • $enableJqueryNoConflict : JavascriptRenderer
  • $enablePecl : FeatureSet
  • $eName : HtmlView
  • $enbuffer : SymmetricKey , Salsa20
  • $enchanged : SymmetricKey
  • $enclosure : FeedItem
  • $encoded : Signature , DataSet , ASN1
  • $encodedPayload : JWS
  • $encodedProtectedHeader : Signature
  • $encoder : Builder
  • $encoding : FromUtf8 , ToUtf8
  • $Encoding : PHPMailer
  • $encodingList : Mbstring
  • $encodingOptions : JsonResponse
  • $encodings : WebClient
  • $encrypt : SSH2
  • $encrypt_block_size : SSH2
  • $encrypted_key : KeyProtectedByPassword
  • $encryptFixedPart : SSH2
  • $encryptInvocationCounter : SSH2
  • $encryption_algorithms_client_to_server : SSH2
  • $encryption_algorithms_server_to_client : SSH2
  • $encryptionPadding : RSA
  • $encryptIV : SymmetricKey
  • $encryptName : SSH2
  • $encryptService : MfaTable
  • $end_date : Result
  • $endDate : X509
  • $endMemory : TracedStatement
  • $endTime : TracedStatement
  • $engine : WebClient , SymmetricKey
  • $engines : AsymmetricKey , BigInteger
  • $enmcrypt : SymmetricKey
  • $entities : FormHelper
  • $entries : Feed , Sidebar , Stream , Collection , MetadataTOCPayload
  • $entry : LdapUser
  • $entryElementName : FeedParser , RssParser
  • $entryManager : Adapter
  • $eof : Stream
  • $error : ApplicationErrorEvent , ErrorDocument , ApplicationErrorEvent , CommandErrorEvent , UploadedFile , SMTP , ConsoleErrorEvent , FatalError
  • $error_count : PHPMailer
  • $error_message : AuthenticationResponse
  • $errorCodes : Response
  • $errorCount : DatabaseModel , HtmlView
  • $errored : ConsoleLogger
  • $errorfiles : Language
  • $errorHandler : Iconv
  • $ErrorInfo : PHPMailer
  • $errorMessage : ParserException , ChoiceQuestion
  • $errorMsg : DatabaseDriver
  • $errorNum : DatabaseDriver
  • $errors : LazyAssertion , LazyAssertionException , Propel2Collector , Form , POP3 , SSH2 , Document , ResponseBag
  • $errorTypes : ExceptionCaster
  • $event_after_change_featured : ArticleModel
  • $event_after_delete : AdminModel , IndexModel
  • $event_after_purge : IndexModel
  • $event_after_save : AdminModel
  • $event_before_batch : AdminModel
  • $event_before_change_featured : ArticleModel
  • $event_before_change_state : AdminModel
  • $event_before_delete : AdminModel , IndexModel
  • $event_before_save : AdminModel
  • $event_before_unlock : TaskModel
  • $event_change_state : AdminModel
  • $event_clean_cache : BaseDatabaseModel
  • $event_unlock : TaskModel
  • $events : Dispatcher
  • $events_map : FormModel
  • $exactReplacements : ConfigPostProcessor
  • $exception : TracedStatement
  • $exceptionClass : Assertion , LazyAssertion
  • $exceptionHandler : ErrorHandler
  • $exceptionOnInvalidType : Inline
  • $exceptions : ExceptionsCollector , PHPMailer
  • $exchange_hash : SSH2
  • $exclude : FilelistField , FolderlistField
  • $excludeCredentials : PublicKeyCredentialCreationOptions
  • $excluded : UserField , Query
  • $excludedTerms : SearchModel
  • $exec : DatabaseQuery
  • $executable : Cli
  • $executed : DatabaseDriver
  • $executedStatements : TraceablePDO
  • $exit_status : SSH2
  • $exitCode : ApplicationErrorEvent , CommandErrorEvent , TerminateEvent , ConsoleErrorEvent , ConsoleTerminateEvent , ErrorHandler
  • $exiting : DaemonApplication
  • $expandNextHash : CliDumper
  • $expectDataDescriptor : ZIPExtraction
  • $expected_bytes : Agent
  • $expiration : MemcachedStorage
  • $expire : Session
  • $explained : HtmlView
  • $explains : QueryCollector , PlgSystemDebug
  • $explicit_key_length : SymmetricKey
  • $exponent : RSA
  • $exponents : RSAKey , PrivateKey
  • $extension : AssociationExtensionHelper , CategoryNode , TransitionField , WorkflowconditionField , WorkflowstageField , RouteHelper , Installer , InstallerAdapter , InstallerScript , CategoryView , Workflow , CategoryController , DisplayController , AssociationsHelper , HtmlView , AssociationsHelper , HtmlView , FinderHelper , Adapter , AssociationsHelper , NewsfeedsHelper , HtmlView , PluginsHelper , RedirectHelper , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , HtmlView , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $extension_message : Installer
  • $extensionMessage : InstallerAdapter
  • $extensionName : HtmlView
  • $extensionOutputCheckerHandler : Server , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , Server
  • $extensionRootFolders : JLoader
  • $extensions : CertificateExtensions , ExtensionsListCommand , ExtensionHelper , X509 , SFTP , AuthenticationExtensionsClientInputs , AuthenticationExtensionsClientOutputs , AuthenticatorData , PublicKeyCredentialOptions
  • $extensionsSupport : AssociationsHelper
  • $extensionValues : X509
  • $extra_query : Update
  • $extraAttributes : OnGetApiFields
  • $extraButtons : HtmlView
  • $extraDisplayOptions : HtmlDumper
  • $extraFields : LdapUser , LdapUserProvider
  • $extraQuery : Installer
  • $extraRelations : OnGetApiFields
  • $f_levels : HtmlView
  • $factories : FactoryCommandLoader
  • $factory : Inflector , Document , BaseController , Toolbar , DatabaseDriver , ContainerResource , Base , Binary , Montgomery , Prime , Uuid
  • $factory128 : Hash
  • $factory36 : Hash
  • $factory64 : Hash
  • $fail_if_unknown : ExtensionDescriptor
  • $fallbackDirsPsr0 : ClassLoader
  • $fallbackDirsPsr4 : ClassLoader
  • $fallbackErrorRenderer : SerializerErrorRenderer
  • $fallbackProperty : Microdata
  • $fallbackType : Microdata
  • $fastMult : ParagonIE_Sodium_Compat
  • $fetched : DatabaseIterator
  • $fetchMap : SqlsrvStatement
  • $fgBase : ColorStyle
  • $fgColor : ColorStyle
  • $fh : Stream
  • $field_type : CaptiveRenderOptions , SetupRenderOptions
  • $fieldCache : FieldsHelper
  • $fieldFactory : CronExpression
  • $fieldname : FormField
  • $fields : FieldFactory , FormattedtextLogger , Item , Uuid , Resource
  • $fieldsCache : FieldsHelper
  • $fieldsToRenderItem : JsonApiView , JsonapiView
  • $fieldsToRenderList : JsonApiView , JsonapiView
  • $file : JNamespacePsr4Map , ChangeItem , HtmlView , UploadedFile , FlattenException , SilencedErrorContext
  • $file_types : SFTP
  • $fileCreator : PlgExtensionNamespacemap
  • $fileFilter : FilelistField
  • $fileHeader : ZIPExtraction
  • $fileLinkFormat : HtmlErrorRenderer
  • $fileLinkFormatter : SourceContextProvider
  • $filelist : Manifest
  • $filemode : Stream
  • $filename : Stream , InstallerExtension
  • $fileName : HtmlView
  • $filename : Stream , Parser
  • $fileName : Reader
  • $filename : ZIPExtraction
  • $fileOffsets : DebugClassLoader
  • $filePath : LocalAdapter
  • $files : ComposerStaticInit2399d40fc48ada3450e844df0430bf2f , HtmlView
  • $filesize : Stream
  • $filesProcessed : ZIPExtraction
  • $fileType : Reader
  • $filter : CalendarField , HtmlView , Query , HtmlView , Input , Token , Versionable , AbstractCloner , DisplayPNGCharacteristicsDescriptor
  • $filter_fields : ListModel
  • $filterBlacklist : ListModel
  • $filterForbiddenList : ListModel , UsersModel
  • $filterForm : ListView , HtmlView
  • $filterFormat : CalendarField
  • $filterFormName : ListModel
  • $filters : FinderIndexCommand , Stream , Sidebar , Query , Stream , ASN1
  • $final : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , DebugClassLoader
  • $finalMethods : DebugClassLoader
  • $finderPluginId : HtmlView
  • $fix : Changelog
  • $fixedTime : FixedTimeProvider
  • $flags : Attribute , Identity , AbstractDumper , Manifest , AuthenticatorData
  • $fmt : AttestationStatement
  • $folder : PluginsField , ChangeSet
  • $folderFilter : FolderlistField
  • $font : HtmlView
  • $footerTitle : Table
  • $footerTitleFormat : TableStyle
  • $force : PasswordField
  • $forceMultiple : CheckboxesField , ConsentBoxField
  • $forceSSL : JoomlaStorage
  • $foreground : Color , OutputFormatterStyle
  • $form : FormField , DefaultView , FormView , HtmlView , JsonView , HtmlView
  • $format : Date , CalendarField , ColorField , FormattedtextLogger , W3cLogger , DownloadSource , AsymmetricKey , PKCS , EC , ASN1 , ProgressBar , ProgressIndicator , SerializerErrorRenderer , LintCommand
  • $formatLevelMap : ConsoleLogger
  • $formatLineCount : ProgressBar
  • $formatMapper : ApiApplication
  • $formatOptions : HTMLHelper
  • $formats : Image , ProgressBar
  • $formatter : NullOutput , Output
  • $formatters : ProgressBar , ProgressIndicator
  • $formControl : FormField
  • $formName : ContactModel , FormModel
  • $forms : Form , FormModel
  • $formsource : SubformField
  • $forward_status : Agent
  • $four : Prime
  • $fp : ZIPExtraction
  • $fragment : AbstractUri , Uri
  • $framesCache : ExceptionCaster
  • $from : Substitution , DatabaseExporter , DatabaseImporter , DatabaseQuery
  • $From : PHPMailer
  • $FromName : PHPMailer
  • $fromVersion : JoomlaInstallerScript
  • $fsock : SSH2 , Agent , Identity
  • $fullDefinition : Command
  • $fullname : AuthenticationResponse
  • $fullPath : FileLayout
  • $fullRange : AbstractField
  • $g : DSA , RgbPaletteEntry
  • $G1Curve : EcdaaTrustAnchor
  • $gcCalled : DatabaseHandler
  • $gcLifetime : DatabaseHandler
  • $gcmField : SymmetricKey
  • $gender : AuthenticationResponse
  • $generalProhibited : NamePrepData2008
  • $generateBestQuality : Image
  • $generated_fieldname : FormField
  • $generator : RandomLibAdapter , TableRows
  • $get : OptionsResolverIntrospector
  • $get_seq_no : SSH2
  • $gid : VarCloner
  • $given : OptionsResolver
  • $glue : QueryElement
  • $gmt : Date
  • $googleApiKey : Server
  • $group : CacheStorageHelper , FormField , InstallerExtension , InMemoryLogger , Update , HtmlView , DatabaseQuery
  • $groupByFieldset : SubformField
  • $grouplist : HtmlView
  • $groups : UserField , UserGroupsHelper , User , HtmlView
  • $groupsByUser : Access
  • $guest : User
  • $guid : FeedItem
  • $h : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , SymmetricKey
  • $handle : Image , ImageFilter , Socket , Stub
  • $handler : Propel2Collector , NativeStorage , Dumper , VarDumper
  • $handlers : ChainedHandler , ErrorHandler
  • $handlesHrefGracefully : OutputFormatterStyle , CliDumper
  • $handlingSignal : ConsoleSignalEvent
  • $hardRefCount : Cursor
  • $hardRefHandle : Cursor
  • $hardRefTo : Cursor
  • $hasAssociation : CategoriesModel , CategoryModel
  • $hash : RedisStorage , Hash , Signature , AsymmetricKey , MetadataTOCPayloadEntry
  • $hashCut : Cursor
  • $hashIndex : Cursor
  • $hashKey : Cursor
  • $hashKeyIsBinary : Cursor
  • $hashLength : Cursor
  • $hashMask : Php72
  • $hashParam : Hash
  • $hashType : Cursor
  • $having : DatabaseQuery
  • $header : Signature
  • $headerCheckerManager : JWSLoader
  • $headerCheckerManagerFactory : JWSLoaderFactory
  • $headerIsDumped : HtmlDumper
  • $headers : WebClient , Builder , Token , Table , FlattenException
  • $headerTitle : Table
  • $headerTitleFormat : TableStyle
  • $height : FeedImage , OpensearchImage , EditorField , MediaField , Terminal , DisplayPNGCharacteristicsDescriptor
  • $Helo : PHPMailer
  • $helo_rply : SMTP
  • $help : AbstractCommand , Command
  • $help_search : HelpModel
  • $help_url : CaptiveRenderOptions , MethodDescriptor , SetupRenderOptions
  • $helper : Versionable
  • $helperFactory : Module
  • $helpers : HelperSet
  • $helperSet : Application , AbstractCommand , Application , Command , Helper
  • $helpKey : ItemModel , ModuleModel , PluginModel , StyleModel
  • $helpLink : FormView , ListView
  • $helpLocal : ItemModel
  • $helpSearch : HtmlView
  • $helpURL : ItemModel , ModuleModel , PluginModel , StyleModel
  • $hex : BigInteger , Engine
  • $hidden : FormField , AbstractCommand , Command , Question
  • $hidden_data : SetupRenderOptions
  • $hiddenDescription : NoteField , FormField
  • $hiddenFallback : Question
  • $hiddenLabel : NoteField , FormField
  • $hide : EditorField
  • $hide_submit : CaptiveRenderOptions
  • $hideAll : WorkflowconditionField
  • $hideDefault : FilelistField , FolderlistField
  • $hideEmptyLimitstart : Pagination
  • $hideNone : FilelistField , FolderlistField
  • $highlight : Query
  • $hint : FormField
  • $history : ANSI
  • $history_attrs : ANSI
  • $hits : CategoryNode
  • $hLen : RSA
  • $hmac : AsymmetricKey
  • $hmac_check : SSH2
  • $hmac_check_etm : SSH2
  • $hmac_check_name : SSH2
  • $hmac_create : SSH2
  • $hmac_create_etm : SSH2
  • $hmac_create_name : SSH2
  • $hmac_size : SSH2
  • $home : MenuItem
  • $horizontal : Table
  • $horizontalInsideBorderChar : TableStyle
  • $horizontalOutsideBorderChar : TableStyle
  • $host : DatabaseLogger , LdapClient , AbstractUri , Uri
  • $Host : PHPMailer
  • $host : POP3 , SSH2 , Connection , DumpServer
  • $Hostname : PHPMailer
  • $hostname : Response
  • $href : OutputFormatterStyle , Link
  • $html : CaptiveRenderOptions , SetupRenderOptions
  • $html5 : HtmlDocument
  • $htmlFormName : ListModel
  • $http : HttpBridgePostRequestMethod , Client
  • $httpClient : Server , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , Server
  • $httpDriver : DebugBar
  • $httpFactory : Requests
  • $httpVersion : AbstractWebApplication
  • $Ical : PHPMailer
  • $IcalMethods : PHPMailer
  • $icon : AdministratorMenuItem , MetadataStatement , PublicKeyCredentialEntity
  • $iconImage : AdministratorMenuItem
  • $id : CategoryNode , ComponentRecord , FormField , RouteHelper , InstallerExtension , MenuItem , Asset , User , Item , TaskOption , HtmlView , RuntimeStorage , IdentifiedBy , PhpToken , Credential , ExtensionDescriptor , PublicKeyCredentialDescriptor , PublicKeyCredentialRpEntity , PublicKeyCredentialUserEntity , TokenBinding
  • $idCounter : ToolbarButton
  • $identifier : UnknownConstructedObject , UnknownObject , SSH2
  • $identities : Access
  • $ignoreCase : AbstractString
  • $ignoreChanges : ContentHistory
  • $ignored : Query
  • $ignoredCollectors : JavascriptRenderer
  • $ignoreDirectories : ZIPExtraction
  • $ignoredSearchWordsCallback : Language
  • $ignoreSystemNode : FeatureSet
  • $ignoreUninstallQueries : LanguageAdapter
  • $ignoreValidationErrors : Command
  • $image : FeedDocument , HtmlView , MethodDescriptor
  • $images : Browser
  • $img : MenuItem
  • $imported : JLoader
  • $in_request_pty_exec : SSH2
  • $in_subsystem : SSH2
  • $included : Query , Document
  • $includedTerms : SearchModel
  • $includePaths : HTMLHelper , FileLayout
  • $includes : Resource
  • $includeVendors : JavascriptRenderer
  • $incrementStyles : StringHelper
  • $indentation : Dumper
  • $indentPad : AbstractDumper
  • $index : RequestIdGenerator , AcceptMatch
  • $indexer : Adapter
  • $indicatorChangeInterval : ProgressIndicator
  • $indicatorCurrent : ProgressIndicator
  • $indicatorUpdateTime : ProgressIndicator
  • $indicatorValues : ProgressIndicator
  • $info : SysinfoModel , HtmlView , OptionsResolver
  • $infourl : Update
  • $initialised : Application
  • $initialization : JavascriptRenderer
  • $initialized : Registry , Application , HtmlDescriptor
  • $inline_crypt : SymmetricKey
  • $innerSequence : CertificateExtensions
  • $input : AbstractWebApplication , DatabaseStrategy , LocalStrategy , CliApplication , ConsoleApplication , Dispatcher , FormField , BaseController , JoomlaStorage , Query , OAuthCallbackEvent , HtmlView , Client , AddressValidator , ForwardedValidator , Cursor , ConsoleEvent , InputAwareHelper , SymfonyStyle , Parameters
  • $input_attributes : CaptiveRenderOptions , SetupRenderOptions
  • $input_type : CaptiveRenderOptions , SetupRenderOptions
  • $input_value : SetupRenderOptions
  • $inputEncoding : Iconv
  • $inputFilter : FeedParser
  • $inputmode : TextField
  • $inputs : Input
  • $inputStream : QuestionHelper
  • $insert : DatabaseQuery
  • $install_script : ComponentAdapter
  • $installed : InstalledVersions
  • $installed_languages : HtmlView
  • $installedByVendor : InstalledVersions
  • $installedIds : PackageAdapter
  • $installer : PlgExtensionJoomla
  • $installerScript : LegacyInstallerScript
  • $installfrom : PlgInstallerWebinstaller
  • $instance : Calculator , Inflector , CliApplication , WebApplication , Authentication , Patcher , UserGroupsHelper , Log , BaseController , ChangeSet , Updater , ContainerResource , Patcher , Inflector , Manager , ZIPExtraction
  • $instanceCounter : BinaryField , PrimeField
  • $instanceID : BinaryField , Integer , PrimeField , Integer
  • $instances : CMSApplication , Captcha , Categories , FtpClient , Document , Editor , Browser , InputFilter , Installer , Mail , AbstractMenu , Pathway , Profiler , Router , Toolbar , Uri , User , Language , Parser , DatabaseDriver , FtpClient , Stream
  • $instructions : Result
  • $interactive : Input
  • $interactiveBuffer : SSH2
  • $interlace : DisplayPNGCharacteristicsDescriptor
  • $internal : DebugClassLoader
  • $internalArray : SplFixedArray
  • $internalContext : FieldController
  • $internalEncoding : Iconv , Mbstring
  • $internalFormat : ProgressBar
  • $internalMethods : DebugClassLoader
  • $internalResource : PharStreamWrapper
  • $inTraceStub : FrameStub
  • $intro_items : HtmlView
  • $invalidParameter : InvalidParameterException
  • $inVendor : LinkStub
  • $invipmap : DES
  • $invisiblePlugins : AsymmetricKey
  • $invocation : PharStreamWrapper
  • $invocationFunctionNames : PharInvocationResolver
  • $invocations : PharInvocationCollection
  • $invpitable : RC2
  • $invsqrtamd : ParagonIE_Sodium_Core_Curve25519_H
  • $ioStyle : AddUserCommand , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , ExtensionDiscoverCommand , ExtensionDiscoverInstallCommand , ExtensionInstallCommand , ExtensionRemoveCommand , ExtensionsListCommand , FinderIndexCommand , GetConfigurationCommand , ListUserCommand , RemoveUserFromGroupCommand , SetConfigurationCommand , SiteDownCommand , SiteUpCommand , TasksListCommand , TasksRunCommand , TasksStateCommand , UpdateCoreCommand
  • $ip : IpHelper
  • $ipad : Hash
  • $ipAddresses : X509
  • $ipmap : DES
  • $irregular : Ruleset
  • $is_negative : Engine
  • $is_timeout : SSH2
  • $isAdmin : Mfa , HtmlView
  • $isAjax : PlgSystemDebug
  • $isBare64Encoded : DistantSingleMetadata , SingleMetadata
  • $isBound : LdapClient
  • $isDebug : CompleteCommand
  • $isDefaultBackendTemplate : HtmlView
  • $isDownload : XmlDocument
  • $isEditExisting : HtmlView
  • $isEmptyState : HtmlView
  • $isEnabled : LazyCommand
  • $isFinder : DebugClassLoader
  • $isFreshUserVerificationRequired : MetadataStatement
  • $isKeyRestricted : MetadataStatement
  • $isMandatoryMFASetup : HtmlView
  • $isMbStringOverload : AbstractPunycode
  • $isNested : TagField
  • $isPayloadDetached : JWS , JWSBuilder
  • $isPayloadEncoded : JWSBuilder
  • $isReadableProvider : LintCommand
  • $isRecursive : ErrorHandler
  • $isRoot : User , ErrorHandler
  • $isSecondFactorOnly : MetadataStatement
  • $issuers : IssuedBy
  • $isValidEngine : Engine
  • $isValidUtf8 : Iconv
  • $item : FormView , HtmlView , VcfView , HtmlView , MessageModel , HtmlView , JsonView , HtmlView
  • $itemQueryModelStateMap : MediaController
  • $items : Changelog , FeedDocument , AdminLanguage , Category , ContentLanguage , Menu , Tag , HtmlView , AbstractMenu , CategoriesView , CategoryView , ListView , HtmlView , XmlView , HtmlView , Domain , HtmlView , TagModel , HtmlView , ValidationData
  • $itemsLoaded : AbstractMenu
  • $itemsPerPage : ApiController
  • $itemTags : TagsHelper
  • $itemType : HtmlView
  • $itemTypes : AssociationExtensionHelper , AssociationsHelper
  • $iteration_count_log2 : PasswordHash
  • $iteratorPosition : Construct
  • $itoa64 : PasswordHash
  • $iv : OpenSSL , ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b , SymmetricKey
  • $javascriptClass : JavascriptRenderer
  • $join : DatabaseQuery
  • $jsFiles : JavascriptRenderer
  • $jsonapi : Document
  • $jsRenderer : DebugBar
  • $jsVendors : JavascriptRenderer
  • $jwsSerializer : AndroidSafetyNetAttestationStatementSupport
  • $jwsSerializerManagerFactory : JWSLoaderFactory
  • $jwsVerifier : JWSLoader , AndroidSafetyNetAttestationStatementSupport
  • $jwsVerifierFactory : JWSLoaderFactory
  • $k : RSA
  • $K : Twofish
  • $KD : Normalizer
  • $keepAlive : SSH2
  • $keepArgs : FrameStub , TraceStub
  • $kex_algorithm : SSH2
  • $kex_algorithms : SSH2
  • $kex_dh_group_size_max : SSH2
  • $kex_dh_group_size_min : SSH2
  • $kex_dh_group_size_preferred : SSH2
  • $key : MapItem , SeekingData , RouterViewConfiguration , Aes , Crypt , DatabaseIterator , Builder , SignedWith , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , SymmetricKey , Hash , RC2 , RC4 , Identity , Data
  • $key_blob : Identity
  • $key_bytes : Key
  • $key_length : Blowfish , DES , RC2 , RC4 , Rijndael , Salsa20 , TripleDES , Twofish
  • $key_length_max : DES , TripleDES
  • $keyboard_requests_responses : SSH2
  • $keyField : SqlField , TimezoneField
  • $keyNamespace : MemcachedStorage
  • $keyProtection : MetadataStatement
  • $keys : JWKSet , DES , RC2
  • $keywords : ColorField
  • $kl : Blowfish , Rijndael , Twofish
  • $knownColors : ColorStyle
  • $knownOptions : ColorStyle
  • $label : FormField , CaptiveRenderOptions , SetupRenderOptions , RSA
  • $labelclass : FormField
  • $lang : Language
  • $lang_codes : PlgSystemLanguageFilter
  • $lang_tag : HelpModel
  • $langConstPrefix : TaskOption
  • $langlist : LanguagesModel
  • $language : CliApplication , ConsoleApplication , WebApplication , AuthenticationResponse , CategoryNode , Changelog , Document , Factory , FeedLink , MenuitemField , MailTemplate , MenuItem , SiteMenu , Language , El , Zh , Query , Result , Token , MenuItemByTypeField , OutputFilter , AcceptLanguage , PHPMailer , Mbstring
  • $language_filter : SiteApplication
  • $LANGUAGE_MAX_KEY : ASCII
  • $languageCount : LanguagesModel
  • $languages : WebClient , CachingLanguageFactory , Language , HtmlView
  • $languages_client_to_server : SSH2
  • $languages_server_to_client : SSH2
  • $languageTag : HtmlView
  • $last_interactive_response : SSH2
  • $last_packet : SSH2
  • $last_reply : SMTP
  • $last_smtp_transaction_id : SMTP
  • $lastArrayArgument : InputDefinition
  • $lastBuildDate : FeedDocument
  • $lastDepth : HtmlDumper
  • $lastError : Iconv
  • $lastErrorMessage : ZIPExtraction
  • $lastExtractedFilename : ZIPExtraction
  • $lastExtractedFileTimestamp : ZIPExtraction
  • $lastIdentifier : CliDescriptor
  • $lastMessageID : PHPMailer
  • $lastOptionalArgument : InputDefinition
  • $lastQueryStoreId : ListModel
  • $lastResetTime : User
  • $lastvisitDate : User
  • $lastWriteTime : ProgressBar
  • $latest : Changelog , Update
  • $latest_version_check : HelpModel
  • $layout : ActionButton , TransitionButton , AccessiblemediaField , CalendarField , CheckboxesField , CheckboxField , ColorField , ComboField , ContenthistoryField , EmailField , FileField , GroupedlistField , HiddenField , ListField , MediaField , MeterField , ModuleorderField , NumberField , PasswordField , RadiobasicField , RadioField , RangeField , RulesField , SubformField , TagField , TelephoneField , TextareaField , TextField , TimeField , UrlField , UserField , FormField , BasicButton , DropdownButton , InlinehelpButton , LinkButton , PopupButton , SeparatorButton , StandardButton , ToolbarButton , CategoryeditField , Adapter , ModulesPositioneditField , WebcronLinkField , TinymcebuilderField , DataField , UniqueidField , JoomlatokenField , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $layoutData : TinymcebuilderField
  • $layoutId : FileLayout
  • $layouts : RouterViewConfiguration
  • $lazy : OptionsResolver
  • $lazyAssertionExceptionClass : Assert
  • $ldap : LdapUserProvider
  • $ldapLocator : CheckLdapCredentialsListener
  • $ldapServiceId : LdapAuthenticator , LdapBadge
  • $LE : PHPMailer
  • $lead_items : HtmlView
  • $leeway : ValidAt , ValidationData , AndroidSafetyNetAttestationStatementSupport
  • $leftover : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State
  • $legalHeader : MetadataStatement , MetadataTOCPayload
  • $len : StreamString , StringWrapper
  • $length : ByteStringObject , ListObject , MapObject , TextStringObject , FeedEnclosure , FeedLink , Token , Hash , StringStream
  • $lengthDecrypt : SSH2
  • $lengthEncrypt : SSH2
  • $level : CategoryNode , MenuItem , Nested
  • $levels : HtmlView , ErrorHandler
  • $levelsInUse : LevelModel
  • $lft : CategoryNode , Nested
  • $libraries : LibraryHelper
  • $libraryname : LibraryManifest
  • $license : LibraryManifest
  • $liEnding : English
  • $limbs : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $limit : Pagination , DatabaseDriver , DatabaseQuery , SourceContextProvider
  • $limitstart : Pagination
  • $line : FlattenException , SilencedErrorContext , AbstractDumper , PhpToken
  • $line_separator : EchoLogger
  • $lineDumper : AbstractDumper
  • $lineEndings : FtpClient
  • $lineLength : SymfonyStyle
  • $lines : ConsoleSectionOutput , Parser
  • $link : Document , FeedImage , FeedItem , MediaField , MenuItem , PaginationObject
  • $link_items : HtmlView
  • $linkProvider : PreloadManager
  • $links : GenericLinkProvider
  • $list : PlgContentPagebreak
  • $list_price : Result
  • $listBlacklist : ListModel
  • $listeners : Dispatcher , ListenersPriorityQueue
  • $listForbiddenList : ListModel
  • $listQueryModelStateMap : MediaController
  • $literals : AbstractField , DayOfWeekField , MonthField
  • $loaded : Behavior , Bootstrap , DraggableList , Dropdown , Form , FormBehavior , Jquery , SearchTools , UiTab , MetadataRepository , DebugClassLoader
  • $loadedExtensions : ExtensionHelper
  • $loader : ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f , NamespacedTwigProfileCollector , TwigProfileCollector , ClassLoader
  • $locale : Language
  • $locality : CertificateSubject
  • $locallySkippedLineNumbers : Parser
  • $location : ASN1
  • $lock : PasswordField
  • $locked : WebAssetManager , OptionsResolver
  • $log_boundary : SSH2
  • $log_long_width : SSH2
  • $log_short_width : SSH2
  • $log_size : SSH2
  • $logCategory : Task
  • $logEntries : InMemoryLogger , PlgSystemDebug
  • $logFilePath : ZIPExtraction
  • $logFP : ZIPExtraction
  • $loggableApi : Joomla
  • $loggableExtensions : Joomla
  • $loggableVerbs : Joomla
  • $loggedErrors : ErrorHandler
  • $logger : CacheCacheCollector , Propel2Collector , PropelCollector , DelegatingPsrLogger , ErrorListener , HtmlErrorRenderer , DumpServer
  • $loggerMap : LoggerRegistry
  • $loggerRegistry : Log
  • $loggers : Log , ErrorHandler
  • $logs : DebugMonitor , BufferingLogger
  • $longVowels : Finnish
  • $lookup : MenuRules , RouteHelper , Log , RouteHelper
  • $lowerAgent : Browser
  • $lowerLimitSearchWordCallback : Language
  • $lowerMap : Entry
  • $m0 : Twofish
  • $m1 : Twofish
  • $m2 : Twofish
  • $m3 : Twofish
  • $mac_algorithms_client_to_server : SSH2
  • $mac_algorithms_server_to_client : SSH2
  • $machineContent : Microdata
  • $macroCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $mailer : Factory , MailTemplate
  • $Mailer : PHPMailer
  • $mailHeader : PHPMailer
  • $mainEngine : BigInteger
  • $maintainer : Update
  • $maintainerurl : Update
  • $major : Version
  • $majorType : AbstractCBORObject
  • $majorVersion : Browser
  • $manifest : Installer , InstallerAdapter , Container
  • $manifest_cache : InstallerExtension
  • $manifest_file : Manifest
  • $manifest_script : ComponentAdapter , InstallerAdapter
  • $manifestClass : Installer
  • $manifestLength : Manifest
  • $mappedAlias : Stub
  • $mapToNothing : NamePrepData2008
  • $mariadb : MysqlDriver , MysqliDriver
  • $marker128 : Hash
  • $marker64 : Hash
  • $marks : Profiler
  • $master : HtmlView
  • $matcherProtection : MetadataStatement
  • $matches : Token
  • $matchVersion : Changelog
  • $max : MeterField , NumberField , SubformField , TimeField , IntervalField , ProgressBar
  • $max_history : ANSI
  • $max_sftp_packet : SFTP
  • $max_x : ANSI
  • $max_y : ANSI
  • $maxAge : AndroidSafetyNetAttestationStatementSupport
  • $maxDepth : Data
  • $maxDigits : NativeCalculator
  • $maxExecTime : ZIPExtraction
  • $maxItems : AbstractCloner
  • $maxItemsPerDepth : Data
  • $maxIterationCount : CronExpression
  • $maxlength : CalendarField
  • $maxLength : PasswordField
  • $maxlength : TextareaField
  • $maxLength : TextField , TrimmedBufferOutput
  • $maxRetries : BiometricAccuracyDescriptor , CodeAccuracyDescriptor , PatternAccuracyDescriptor
  • $maxSecondsBetweenRedraws : ProgressBar
  • $maxString : AbstractCloner
  • $maxStringWidth : CliDumper
  • $maxTemplates : BiometricAccuracyDescriptor
  • $maxwordrange128 : Hash
  • $maxwordrange64 : Hash
  • $maxyear : CalendarField
  • $mdsCache : MetadataRepository
  • $mdsMap : MetadataRepository
  • $measures : TimeDataCollector , ProfileCollector
  • $mediaApiModel : MediaModel , MediumModel
  • $mediaElement : TemplateModel
  • $mediaFiles : HtmlView
  • $mediaVersion : Document , Version
  • $memcached : MemcachedStorage , MemcachedHandler
  • $memoryDelta : TracedStatement
  • $memoryLogs : DebugMonitor
  • $menu : RouterBase , SiteRouter
  • $menuFactory : CMSApplication
  • $menuItemId : ConsentBoxField
  • $menuItemMatchArticle : HtmlView
  • $menuItemMatchCategory : CategoryView
  • $menuItemMatchContact : HtmlView
  • $menuItemModel : PlgSampledataBlog
  • $menus : CMSApplication , Menu
  • $menuType : MenuitemField
  • $menutype : MenuItem
  • $menuType : MenuItemByTypeField
  • $merge : DatabaseQuery
  • $merged : Resource
  • $mergeProperty : AggregatedCollector
  • $message : Installer , LogEntry , BaseController , JsonResponse , ProgressIndicator , FlattenException
  • $message_log : SSH2
  • $message_number_log : SSH2
  • $message_numbers : SSH2
  • $message_type : PHPMailer
  • $MessageDate : PHPMailer
  • $MessageID : PHPMailer
  • $messagePrefix : HtmlView
  • $messageQueue : CMSApplication
  • $messages : MessagesCollector , CliApplication , ConsoleApplication , JsonResponse , ProgressBar
  • $messagesLogger : SwiftMailCollector
  • $messageType : BaseController
  • $metadata : Tar , Zip , CategoryNode , Language
  • $metaData : Manifest
  • $metaDataLength : Manifest
  • $metadataManager : SessionMetadataGcCommand , MetadataManagerListener
  • $metadataRepository : Authentication
  • $metadataStatementRepository : AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , AndroidKeyAttestationStatementSupport , FidoU2FAttestationStatementSupport , Server , AndroidKeyAttestationStatementSupport , AndroidSafetyNetAttestationStatementSupport , FidoU2FAttestationStatementSupport , PackedAttestationStatementSupport , TPMAttestationStatementSupport , Server
  • $metadesc : CategoryNode
  • $metakey : CategoryNode
  • $meter : PasswordField
  • $method : OpenSSL , LazyServiceEventListener , DebugClassLoader
  • $methods : BaseController , HtmlView , Route
  • $methodTraits : DebugClassLoader
  • $mfaActive : HtmlView
  • $mfaConfigurationUI : HtmlView
  • $mfaMethodName : Email , Fixed , Totp , Webauthn , Yubikey
  • $mfaMethods : MethodModel , HtmlView
  • $mgfHash : RSA
  • $mgfHLen : RSA
  • $microseconds : GeneralizedTime
  • $mime : Adapter
  • $MIMEBody : PHPMailer
  • $MIMEHeader : PHPMailer
  • $mimeType : AbstractWebApplication
  • $min : NumberField , SubformField , TimeField , IntervalField
  • $minComplexity : PatternAccuracyDescriptor
  • $minDepth : AbstractCloner
  • $minifyXML : Sanitizer
  • $minimum_stability : Update , UpdateAdapter
  • $minimumBatchProcessingTime : FinderIndexCommand
  • $minimumJoomla : InstallerScript
  • $minimumPhp : InstallerScript
  • $minLength : CodeAccuracyDescriptor
  • $minor : Version
  • $minorVersion : Browser
  • $minSecondsBetweenRedraws : ProgressBar
  • $minyear : CalendarField
  • $missingClasses : ClassLoader
  • $missingDownloadKeys : HtmlView
  • $mobile : WebClient , Browser
  • $modality : BiometricStatusReport
  • $modalLink : HtmlView
  • $mode : StreamString , UserGroupsHelper , Query , StringWrapper , SymmetricKey , Stream , InputArgument , InputOption
  • $mode_3cbc : TripleDES
  • $mode_sef : PlgSystemLanguageFilter
  • $modeAlias : PlgEditorCodemirror
  • $model_prefix : BaseController
  • $modelState : ApiController
  • $modePath : PlgEditorCodemirror
  • $modexpEngine : Engine
  • $modified_time : CategoryNode
  • $modified_user_id : CategoryNode
  • $modifiedDate : AbstractWebApplication
  • $modifiers : FormRule , BooleanRule , PrefixRule
  • $mods : PlgContentLoadmodule
  • $module : AbstractModuleDispatcher
  • $modules : HtmlView , PlgContentLoadmodule
  • $modulo : Binary , Montgomery , Prime , TwistedEdwards , Integer
  • $modulus : RSAKey , RSA
  • $modulus_length : RSAKey
  • $monitor : DatabaseDriver
  • $monitors : ChainedMonitor
  • $moved : UploadedFile
  • $msgElements : ChangeItem
  • $multiline : Question
  • $multiple : FormField
  • $multiselect : ChoiceQuestion
  • $mvcFactory : ComponentDispatcher , ComponentDispatcherFactory
  • $naf : Base
  • $name : MonologCollector , AggregatedCollector , ConfigCollector , MessagesCollector , CMSApplication , ConsoleApplication , Captcha , RouterView , RouterViewConfiguration , AddUserCommand , XmlDocument , FeedPerson , Form , FormField , InstallerAdapter , Manifest , BaseController , BaseModel , Asset , ToolbarButton , Update , User , BufferStreamHandler , WebAssetItem , Domain , Field , MethodDescriptor , Application , AbstractCommand , DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , QueryElement , SqlazureDriver , SqliteDriver , AbstractEvent , Buffer , InfoCollector , LanguageErrorsCollector , LanguageFilesCollector , LanguageStringsCollector , QueryCollector , SessionCollector , RuntimeStorage , Basic , Application , Command , InputArgument , InputOption , OptionConfigurator , AuthenticationExtension , PublicKeyCredentialEntity
  • $namePrep : ToPunycode
  • $namePrepData : NamePrep
  • $nameQuote : DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver , SqliteDriver
  • $namespace : CategoryFactory , ComponentRecord , RouterFactory , ComponentDispatcherFactory , ModuleDispatcherFactory , CategoryFactory , ComponentDispatcherFactory , HelperFactory , ModuleDispatcherFactory , MVCFactory , RouterFactory , HelperFactory , InstallerExtension , MVCFactory , ApplicationDescription , XML , ApplicationDescription
  • $namespaces : JLoader , FeedParser , ApplicationDescription
  • $Nb : Rijndael
  • $negations : InputDefinition
  • $negotiate_tls : LdapClient
  • $nestable : RouterViewConfiguration
  • $nested : OptionsResolver
  • $newGetMultiSignature : MemcachedStorage
  • $newtag : SymmetricKey
  • $nextUpdate : MetadataTOCPayload
  • $Nk : Rijndael
  • $no : MetadataTOCPayload
  • $no_referrals : LdapClient
  • $noBackupCheck : HtmlView
  • $noColors : ColorProcessor
  • $nodeProvider : FeatureSet , DefaultTimeGenerator , TimeGeneratorFactory , UuidFactory
  • $nodeProviders : FallbackNodeProvider
  • $nodes : Taxonomy , CssMenu
  • $noIDs : Router
  • $nonce : SodiumCipher , Sodium , ParagonIE_Sodium_Core32_SecretStream_State , ParagonIE_Sodium_Core_SecretStream_State , SymmetricKey , Hash
  • $nonceDirectives : PlgSystemHttpHeaders
  • $nonCoreCriticalPlugins : HtmlView
  • $nonCoreExtensions : HtmlView
  • $nonIVChanged : SymmetricKey
  • $noPreloadTag : AddConsoleCommandPass
  • $normalizeCombiningClasses : NamePrepData2008
  • $normalized : BaseAccept
  • $normalizer : Question
  • $normalizers : OptionsResolver
  • $note : Changelog , MenuItem
  • $notification : Stream
  • $noun : Russian
  • $noValueDirectives : PlgSystemHttpHeaders
  • $noVersionCheck : HtmlView
  • $Nr : Rijndael
  • $nrOfLengthOctets : ASNObject
  • $nrOfUnusedBits : BitString
  • $nthRange : DayOfWeekField
  • $nullDate : DatabaseDriver , MysqlDriver , MysqliDriver , PdoDriver , PgsqlDriver
  • $nullDatetimeList : DatabaseQuery , MysqlQuery , MysqliQuery , PdoQuery , PgsqlQuery , SqlsrvQuery
  • $numberConverter : FeatureSet , UuidFactory
  • $numberingOffset : TraceStub
  • $numberOfColumns : Table
  • $numberOfParsedLines : Parser
  • $numerator : BigRational
  • $numeric : Token
  • $numitems : CategoryNode
  • $oauth : PHPMailer
  • $oauthClientId : OAuth
  • $oauthClientSecret : OAuth
  • $oauthRefreshToken : OAuth
  • $oauthToken : OAuth
  • $oauthUserEmail : OAuth
  • $object : TagObject
  • $objectForMap : Inline
  • $objects : DataSet
  • $objectSupport : Inline
  • $offset : ParserException , DatabaseDriver , DatabaseQuery , RelativeStream , Parser
  • $offset128 : Hash
  • $offset64 : Hash
  • $oids : ASN1 , X509
  • $oidsLoaded : PKCS8 , PSS , X509
  • $old_access : Adapter
  • $old_cataccess : Adapter
  • $old_x : ANSI
  • $old_y : ANSI
  • $oldAdminFiles : ComponentAdapter
  • $oldApiFiles : ComponentAdapter
  • $oldConfig : SiteStatus
  • $oldFiles : ComponentAdapter , PluginAdapter
  • $oldtag : SymmetricKey
  • $onchange : FormField
  • $onclick : FormField
  • $one : AsymmetricKey , Binary , Montgomery , Prime , TwistedEdwards , Engine
  • $onemsqd : ParagonIE_Sodium_Core_Curve25519_H
  • $onlyNumericLabels : CronField
  • $opad : Hash
  • $open_flags : SFTP
  • $open_flags5 : SFTP
  • $openedPath : StreamString , StringWrapper
  • $openHandlerClass : JavascriptRenderer
  • $openHandlerUrl : JavascriptRenderer
  • $openmode : Stream
  • $openssl_emulate_ctr : SymmetricKey
  • $openssl_mode_names : DES
  • $openSSLOptions : OpenSSL
  • $operatingEnv : MetadataStatement
  • $operationType : UpdateOperation
  • $operators : Query
  • $option : ComponentRecord , ComponentDispatcher , AdminController , ApiController , FormController , BaseDatabaseModel , AbstractView , InstalledModel , HtmlView
  • $optionConstants : MemcachedCaster
  • $optionDefaults : Select
  • $options : Archive , Bzip2 , Gzip , Tar , Zip , ColorStyle , ActionButton , CacheController , SetConfigurationCommand , StreamString , AuthorField , LimitboxField , PredefinedlistField , UsergrouplistField , Form , HtmlView , BaseLayout , Logger , ToolbarButton , WebAssetItem , LogcreatorField , TaskOptions , DatabaseDriver , DatabaseExporter , DatabaseImporter , StringWrapper , AbstractTransport , Http , Input , Client , Ini , Color , OutputFormatterStyle , TableCell , TableCellStyle , Input , InputDefinition , AbstractQuery
  • $optionsFilter : PredefinedlistField
  • $optionSuggestions : CompletionSuggestions
  • $ORD : ASCII
  • $order : CronExpression , DatabaseQuery , Base , Binary , Montgomery , Prime
  • $ordering : HtmlView
  • $organization : CertificateSubject
  • $organizationalUnit : CertificateSubject
  • $orig_key : RC2
  • $origin : CollectedClientData
  • $originalLogWriter : SlimCollector
  • $originalWord : Stem
  • $origIV : SymmetricKey
  • $orphans : Language
  • $otherTypeManager : Decoder
  • $output : CliApplication , GithubActionReporter , Cursor , Descriptor , ConsoleEvent , Dumper , ProgressBar , ProgressIndicator , Table , ConsoleLogger , OutputStyle , SymfonyStyle
  • $outputBuffer : HtmlErrorRenderer
  • $outputEncoding : Iconv
  • $outputStream : AbstractDumper
  • $overflow : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $override : Language
  • $overridesList : HtmlView
  • $overwrite : Installer , ProgressBar
  • $p : DSA , Binary , Montgomery , Prime , TwistedEdwards
  • $p1 : Salsa20
  • $p2 : Salsa20
  • $packagename : PackageManifest
  • $packager : Manifest
  • $packagerurl : Manifest
  • $packageUninstall : Installer
  • $packet_buffer : SFTP
  • $packet_log : SFTP
  • $packet_size_client_to_server : SSH2
  • $packet_type : SFTP
  • $packet_type_log : SFTP
  • $packet_types : SFTP
  • $pad : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , Hash
  • $paddable : SymmetricKey
  • $padding : SymmetricKey
  • $paddingChar : TableStyle
  • $paddingType : Hash
  • $paDesc : VerificationMethodDescriptor
  • $padType : TableStyle
  • $page : HelpModel , HtmlView
  • $pageclass_sfx : HtmlView
  • $pageHeading : CategoriesView , HtmlView
  • $pagesCurrent : Pagination
  • $pagesStart : Pagination
  • $pagesStop : Pagination
  • $pagesTotal : Pagination
  • $pagination : CategoryView , ListView , HtmlView
  • $parameterKeyMapping : MysqliStatement , SqlsrvStatement
  • $parameterMapping : DatabaseQuery
  • $parameters : TracedStatement , BaseAccept , Hash , ArrayInput , ArgsStub
  • $parameterTypeMapping : MysqliStatement , SqlsrvStatement
  • $params : CategoryNode , ComponentRecord , HtmlDocument , InstallerExtension , MenuItem , CMSPlugin , User , HtmlView , CssMenu , AbstractDataCollector
  • $paramTable : InstallerScript
  • $parent : AdapterInstance , RouterViewConfiguration , InstallerAdapter , ToolbarButton , CollectionAdapter , HtmlView , Container
  • $parent_id : CategoryNode , MenuItem , Nested
  • $parent_key : RouterViewConfiguration
  • $parentclass : CalendarField , EditorField , MediaField , NumberField , RulesField , FormField
  • $parentId : DaemonApplication
  • $parentsOptions : OptionsResolver
  • $parray : Blowfish
  • $parsed : ArgvInput
  • $parsedBody : ServerRequest
  • $parsedFile : ParseException
  • $parsedFilename : Inline
  • $parsedLine : ParseException
  • $parsedLineNumber : Inline
  • $parser : Yaml , Configuration , LintCommand
  • $parsers : FeedFactory
  • $partial_init : SFTP
  • $participle : Russian
  • $pass : AbstractUri
  • $passphrase : Key
  • $password : AuthenticationResponse , AddUserCommand , ChangeUserPasswordCommand , DatabaseLogger , User , LdapClient
  • $Password : PHPMailer
  • $password : POP3 , LdapUser
  • $password_clear : User
  • $password_default_salt : SymmetricKey
  • $passwordAttribute : LdapUserProvider
  • $passwordHandler : AbstractUsernamePasswordAuthenticationStrategy
  • $pasv : FtpClient
  • $patches : Patcher
  • $patchTypes : DebugClassLoader
  • $path : RouterViewConfiguration , StreamString , Image , LanguagesModel , FormattedtextLogger , InstalledModel , StringWrapper , AbstractUri , Uri , Stream , PlgSampledataMultilang
  • $paths : FormHelper , Installer , Language , BaseController , BaseModel
  • $pathway : CMSApplication , Pathway
  • $pattern : Pattern , Transformation , FormField , Route
  • $patterns : Patterns
  • $pause : FinderIndexCommand
  • $payload : JWS , JWSBuilder , JsonResponse
  • $pdo : TraceablePDO , TraceablePDOStatement , PdoStorage
  • $pdoStatement : PdoStatement
  • $peakMemory : PropelCollector
  • $peakUsage : MemoryCollector
  • $percent : ProgressBar
  • $perfectiveGerund : Russian
  • $php_info : SysinfoModel
  • $php_settings : SysinfoModel
  • $phpInfo : HtmlView
  • $phpInfoArray : SysinfoModel
  • $phpoptions : HtmlView
  • $phpOptions : HtmlView
  • $phpsettings : HtmlView
  • $phpSettings : HtmlView
  • $phrase : Token
  • $phrases : Response
  • $pitable : RC2
  • $placeholder : CaptiveRenderOptions , SetupRenderOptions
  • $plainVowels : Stem
  • $platform : WebClient , Browser
  • $plte : DisplayPNGCharacteristicsDescriptor
  • $plugins : PluginHelper , AsymmetricKey
  • $pluginState : HtmlView
  • $pluginType : Authentication
  • $pluralizer : Inflector
  • $pluralRulesets : GenericLanguageInflectorFactory
  • $pluralSuffixesCallback : Language
  • $poly1305Field : SymmetricKey
  • $poly1305Key : SymmetricKey
  • $pop_conn : POP3
  • $pop_parent : CollectionAdapter
  • $port : LdapClient , AbstractUri , Uri
  • $Port : PHPMailer
  • $port : POP3 , SSH2
  • $portable_hashes : PasswordHash
  • $pos : StreamString , StringWrapper , Stream , PhpToken
  • $position : SeekingData , ColorField , BufferStreamHandler , HtmlView , Buffer , Data , Stub
  • $post_message : CaptiveRenderOptions , SetupRenderOptions
  • $postcode : AuthenticationResponse
  • $pre_message : CaptiveRenderOptions , SetupRenderOptions
  • $precision : BigInteger , Engine
  • $predefinedOptions : PluginstatusField , PredefinedlistField , RedirectStatusField , RegistrationdaterangeField , StatusField , UseractiveField , UserstateField , LogsdaterangeField , RequeststatusField , RequesttypeField , ExecutionRuleField , TaskStateField
  • $preferred : SSH2
  • $preferred_signature_format : SSH2
  • $preferredEngine : SymmetricKey
  • $preferredVersion : SFTP
  • $prefix : Pagination , PaginationObject , Profiler , ApcuHandler , MemcachedHandler , RedisHandler
  • $prefixAsArray : AbstractPunycode
  • $prefixDirsPsr4 : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $prefixes : JLoader , FormHelper
  • $prefixesPsr0 : ClassLoader
  • $prefixLength : AbstractPunycode
  • $prefixLengthsPsr4 : ClassLoader , ComposerStaticInit2399d40fc48ada3450e844df0430bf2f
  • $preloadedAssets : Access
  • $preloadedAssetTypes : Access
  • $preloadManager : Document
  • $preloadTypes : Document
  • $preparedIndex : DatabaseQuery
  • $preservedSubset : CutArrayStub
  • $preserveTime : SFTP
  • $presets : MenusHelper
  • $prevErrorHandler : AbstractCloner
  • $preview : AccessiblemediaField , ColorField , MediaField , HtmlView
  • $previewHeight : AccessiblemediaField , MediaField
  • $previewLink : FormView
  • $previewWidth : AccessiblemediaField , MediaField
  • $previous : FlattenException
  • $previousMem : Profiler
  • $previousMessage : ProgressBar
  • $previousTime : Profiler
  • $prime : DH
  • $primes : RSAKey , PrivateKey
  • $print : HtmlView
  • $priorities : LogEntry , Logger , SyslogLogger
  • $priority : LogEntry
  • $Priority : PHPMailer
  • $priorityMap : DelegatingPsrLogger
  • $privacyType : ConsentBoxField
  • $private : Key , RSAKey
  • $private_exponent : RSAKey
  • $privateKey : PrivateKey , X509
  • $privateSettings : SysinfoModel
  • $privateTagName : AddConsoleCommandPass
  • $processId : DaemonApplication
  • $processingmethod : Stream
  • $processor : CliOutput
  • $processTitle : Command
  • $profile : NamespacedTwigProfileCollector , TwigProfileCollector
  • $profileKeyPrefix : Token , PlgUserToken
  • $profiler : CMSApplication , Indexer , Cache
  • $profiles : QueryCollector
  • $progressBar : UpdateCoreCommand , SymfonyStyle
  • $progressChar : ProgressBar
  • $prohibit : NamePrepData2008
  • $prohibitRanges : NamePrepData2008
  • $projectDir : HtmlErrorRenderer , SourceContextProvider
  • $prompt : ChoiceQuestion
  • $properties : Feed , FeedEntry , DataObject
  • $property : Microdata
  • $propertyPath : InvalidArgumentException
  • $protected : ContainerResource
  • $protectedConfigurationFields : ApplicationModel
  • $protectedHeader : Signature
  • $protocolFamily : MetadataStatement
  • $prototype : OptionsResolver
  • $prototypeIndex : OptionsResolver
  • $provider : OAuth
  • $providerManager : MediaProviderEvent
  • $providers : ProviderManager , HtmlView
  • $pubDate : FeedDocument
  • $pubKeyCredParams : PublicKeyCredentialCreationOptions
  • $public : Key
  • $public_exponent : RSAKey
  • $publicExponent : PrivateKey
  • $publicKey : CSR , PrivateKey , X509
  • $publicKeyAlgAndEncoding : MetadataStatement
  • $publicKeyAlgAndEncodings : MetadataStatement
  • $publicKeyCredentialDescriptors : PublicKeyCredentialDescriptorCollection
  • $publicKeyCredentialId : PublicKeyCredentialSource
  • $publicKeyCredentialSource : AuthenticatorAttestationResponseValidator
  • $publicKeyCredentialSourceRepository : Server , AuthenticatorAssertionResponseValidator , Server
  • $publish_end_date : Result
  • $publish_start_date : Result
  • $published : CategoryNode , MenuitemField , InstallerExtension , Result , MenuItemByTypeField
  • $punycodeEncoder : ToIdn , ToUnicode
  • $pwd : SFTP
  • $q : DSA , EC
  • $q0 : Twofish
  • $q1 : Twofish
  • $QA : EC
  • $qtime : FinderIndexCommand
  • $quality : AcceptMatch , BaseAccept
  • $query : SqlField , MenuItem , ListModel , HtmlView , ExecutionFailureException , MysqliStatement , SqlsrvStatement , AbstractUri , Uri , AbstractQuery
  • $queryCount : Propel2Collector
  • $queryMonitor : QueryCollector , PlgSystemDebug
  • $queryParams : ServerRequest
  • $querySet : DatabaseQuery
  • $queryString : LdapAuthenticator , LdapBadge
  • $queryType : ChangeItem
  • $question : Question
  • $questionHelper : SymfonyStyle
  • $quickicons : HtmlView
  • $quiet_mode : SSH2
  • $r : ParagonIE_Sodium_Core32_Poly1305_State , ParagonIE_Sodium_Core_Poly1305_State , RgbPaletteEntry
  • $r1 : Stem
  • $r1Index : Stem
  • $r2 : Stem
  • $r2Index : Stem
  • $random_state : PasswordHash
  • $randomGenerator : FeatureSet , CombGenerator , UuidFactory
  • $randomMax : BinaryField
  • $rangeEnd : AbstractField , DayOfMonthField , DayOfWeekField , HoursField , MinutesField , MonthField
  • $rangeStart : AbstractField , DayOfMonthField , DayOfWeekField , HoursField , MinutesField , MonthField
  • $rating : FeedDocument
  • $raw : Json
  • $rawAttestationObject : AttestationObject
  • $rawData : CollectedClientData
  • $rawId : PublicKeyCredential
  • $rawMessage : ParseException
  • $rawname : CacheStorage
  • $reachedEof : PhpInputStream
  • $readable : Stream
  • $readonly : FormField
  • $readprefix : Stream
  • $realtime_log_file : SSH2
  • $realtime_log_size : SSH2
  • $realtime_log_wrap : SSH2
  • $realUsage : MemoryCollector
  • $reason : MailDisabledException , Status
  • $reasonPhrase : Response
  • $recipients : MailTemplate
  • $RecipientsQueue : PHPMailer
  • $recomputeAESKey : Hash
  • $record : HtmlView
  • $recordId : HtmlView
  • $records : MonologCollector , HtmlView
  • $recur_limit : X509
  • $recursive : FolderlistField
  • $redirect : BaseController
  • $redirect_url : Installer
  • $redirectPluginId : HtmlView
  • $redis : RedisStorage , RedisHandler
  • $redrawFreq : ProgressBar
  • $reduce : Engine , Integer
  • $refCount : Stub
  • $referenceId : HtmlView
  • $referenceLanguage : HtmlView
  • $referenceTitle : HtmlView
  • $referenceTitleValue : HtmlView
  • $refIndex : Cursor
  • $reflexive : Russian
  • $refs : Parser
  • $refsBeingParsed : Parser
  • $regenerate_compression_context : SSH2
  • $regenerate_decompression_context : SSH2
  • $regex : Pattern , Patterns , FormRule , BooleanRule , EmailRule , ModuleLayoutRule , PrefixRule , Route
  • $REGEX_ASCII : ASCII
  • $region : AcceptLanguage
  • $registerDate : User
  • $registered : BufferStreamHandler
  • $registeredAliases : CronExpression
  • $registeredLoaders : ClassLoader
  • $registry : HTMLHelper , WebAssetManager
  • $regular : Ruleset
  • $rel : OpensearchUrl , Link
  • $relation : FeedLink
  • $relationship : JsonApiView , OnGetApiRelation , JsonapiView
  • $relationships : Update , Resource
  • $release : InstallerScript
  • $remoteIp : RequestParameters
  • $removals : Patcher
  • $remove : Changelog
  • $removeRemoteReferences : Sanitizer
  • $removeXMLTag : Sanitizer
  • $renderCache : PlgFieldsSubform
  • $rendered : Table
  • $renderedSrc : ScriptsRenderer , StylesRenderer
  • $renderedTemplates : TraceableTwigEnvironment
  • $renderLabelLayout : FormField
  • $renderLayout : FormField
  • $renderOptions : HtmlView
  • $renderSqlWithParams : PDOCollector
  • $repeat : Form , FormField
  • $replaceMaps : NamePrepData2003 , NamePrepData2008
  • $replacement : Transformation
  • $replacements : ConfigPostProcessor , Replacements
  • $replaceTags : TagsHelper
  • $replyto : MailTemplate
  • $ReplyTo : PHPMailer
  • $ReplyToQueue : PHPMailer
  • $request_channel : Agent
  • $request_pty : SSH2
  • $requestBuffer : SFTP
  • $requestEndTime : TimeDataCollector , ProfileCollector
  • $requestFactory : Server , AndroidSafetyNetAttestationStatementSupport , DistantSingleMetadata , DistantSingleMetadataFactory , MetadataService , MetadataServiceFactory , Server
  • $requestId : DebugBar , InfoCollector
  • $requestIdGenerator : DebugBar
  • $requestMethod : ReCaptcha
  • $requestStack : RequestContextProvider
  • $requestStartTime : TimeDataCollector , ProfileCollector
  • $required : FormField , OptionsResolver
  • $requiredCount : InputDefinition
  • $requiredTerms : SearchModel
  • $requireReset : User
  • $requireResidentKey : AuthenticatorSelectionCriteria
  • $rerunStatus : ChangeItem
  • $reservedMemory : ErrorHandler
  • $resetCount : User
  • $residual_suffixes : Catalan
  • $resolved : LdapBadge , OptionsResolver
  • $resolver : OptionConfigurator , Manager
  • $resource : StringStream , LdapClient , Stream
  • $resources : Container , Collection
  • $response : AbstractWebApplication , FtpClient , UnexpectedResponseException , RequestParameters , PublicKeyCredential
  • $responseCode : FtpClient
  • $responseMap : AbstractWebApplication , RedirectField
  • $responseMsg : FtpClient
  • $restrictedVowels : Finnish
  • $result : MysqliStatement , SqlsrvStatement
  • $results : Authentication , PackageAdapter , HtmlView , Query
  • $rethrow : CryptoExceptionHandler
  • $retry_connect : SSH2
  • $return_page : HtmlView
  • $returnTypes : DebugClassLoader
  • $returnURL : HtmlView
  • $reverseOIDs : ASN1
  • $rfc4050 : XML
  • $rgt : CategoryNode , Nested
  • $rlu : MenutypesModel
  • $robot : WebClient
  • $robots : Browser
  • $rogueListHash : MetadataTOCPayloadEntry
  • $rogueListURL : MetadataTOCPayloadEntry
  • $roles : LdapUser
  • $root : Uri , CssMenu
  • $root_id : Nested
  • $rootAssetId : Access
  • $rootDirectory : Checkfiles , Requests
  • $rootPath : LocalAdapter
  • $route : InstallerAdapter , MenuItem , Result
  • $router : WebApplication , MenuRules , NomenuRules , StandardRules , Cache , DebugRouterCommand
  • $routes : Router
  • $routeVariables : ResolvedRoute , Route
  • $rowBindedValues : MysqliStatement
  • $rowCount : TracedStatement
  • $rows : TextareaField , HtmlView , Table
  • $rp : PublicKeyCredentialCreationOptions
  • $rpEntity : Server
  • $rpId : PublicKeyCredentialRequestOptions
  • $rpIdHash : AuthenticatorData
  • $rtl : PlgInstallerWebinstaller
  • $rule : ExecRuleHelper
  • $rules : RouterView , Router , Asset , Route
  • $rulesets : RulesetInflector , ConfigPostProcessor
  • $running : DaemonApplication , SingleCommandApplication
  • $runningCommand : Application
  • $runPlugins : CategoryView , HtmlView
  • $runState : ZIPExtraction
  • $rv : Stem
  • $rvIndex : Stem
  • $S0 : Twofish
  • $S1 : Twofish
  • $S2 : Twofish
  • $S3 : Twofish
  • $safeCodepoint : TranscodeUnicode
  • $safeData : SysinfoModel
  • $safeMode : TranscodeUnicode
  • $sale_price : Result
  • $save2copy : HtmlView
  • $saveFormat : ColorField
  • $sbox0 : Blowfish
  • $sbox1 : Blowfish , DES
  • $sbox2 : Blowfish , DES
  • $sbox3 : Blowfish , DES
  • $sbox4 : DES
  • $sbox5 : DES
  • $sbox6 : DES
  • $sbox7 : DES
  • $sbox8 : DES
  • $scale : BCMath , BigDecimal
  • $scheme : AbstractUri , Uri
  • $scope : CMSApplication
  • $scopedErrors : ErrorHandler
  • $score : AcceptMatch , Response
  • $screamedErrors : ErrorHandler
  • $screen : ANSI
  • $script : AcceptLanguage
  • $scriptElement : FileAdapter , ModuleAdapter , PluginAdapter
  • $scriptfile : PackageManifest
  • $scriptOptions : Document
  • $search : Query , Collection
  • $search_string : LdapClient
  • $searchDisplayedCharactersNumberCallback : Language
  • $searchDn : LdapAuthenticator , LdapBadge , LdapUserProvider
  • $searchPassword : LdapAuthenticator , LdapBadge , LdapUserProvider
  • $searchquery : SearchModel
  • $secret : KeyOrPassword , ReCaptcha , RequestParameters
  • $secret_type : KeyOrPassword
  • $section : RulesField , DisplayController , StageController , StagesController , TransitionController , TransitionsController , WorkflowController , WorkflowsController , HtmlView
  • $sections : ConsoleSectionOutput
  • $security : Changelog
  • $seekable : Stream
  • $sefs : PlgSystemLanguageFilter
  • $select : DatabaseQuery
  • $selectedAlgorithms : Server
  • $selectRowNumber : DatabaseQuery
  • $selfAttestedFAR : BiometricAccuracyDescriptor
  • $selfAttestedFRR : BiometricAccuracyDescriptor
  • $selfUpdateAvailable : HtmlView
  • $send_id_string_first : SSH2
  • $send_kex_first : SSH2
  • $send_seq_no : SSH2
  • $sendEmail : User
  • $Sender : PHPMailer
  • $sEndings : German
  • $Sendmail : PHPMailer
  • $sendMailEnabled : HtmlView
  • $separator : Registry
  • $sequence : RSAKey
  • $serializer : JsonApiView , SerializerErrorRenderer , AddLinkHeaderListener , Resource
  • $serializerManager : JWSLoader
  • $serializers : JWSSerializerManager , JWSSerializerManagerFactory
  • $serialNumber : X509
  • $server : ServerDumpCommand
  • $server_caps : SMTP
  • $server_channels : SSH2
  • $server_host_key_algorithms : SSH2
  • $server_identifier : SSH2
  • $server_public_host_key : SSH2
  • $serverctrls : Query
  • $serverParams : ServerRequest
  • $serverType : DatabaseDriver
  • $serverUrl : PlgSystemStats
  • $serviceId : LazyServiceEventListener
  • $serviceMap : Registry
  • $serviceRegistry : HTMLHelper
  • $services : SimpleMetadataStatementRepository
  • $serviceUri : MetadataService
  • $session : ConsoleApplication , SessionMetadataGcCommand , Factory , JoomlaHttpDriver , Authentication , SessionEvent , AddressValidator , ForwardedValidator
  • $session_id : SSH2
  • $sessionHandler : SessionManager
  • $sessionRecordDoesNotExist : MetadataManager
  • $sessionRecordExists : MetadataManager
  • $sessionRecordUnknown : MetadataManager
  • $sessionValidators : Session
  • $set : DatabaseQuery
  • $severity : SilencedErrorContext
  • $sftp : Stream
  • $sftp_errors : SFTP
  • $shared : ContainerResource
  • $shortcut : InputOption
  • $shortcuts : InputDefinition
  • $shortFormat : DSA , EC
  • $shortinfo : MethodDescriptor
  • $show_submit : SetupRenderOptions
  • $showHidden : ApplicationDescription
  • $showIpColumn : HtmlView
  • $showLogs : PlgSystemDebug
  • $showMessage : HtmlView
  • $showon : FormField
  • $showSaveAsCopy : HtmlView
  • $shuffle : DES
  • $sidebar : ListView , HtmlView
  • $sigFormat : DSA
  • $sigma : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • $sign_cert_file : PHPMailer
  • $sign_extracerts_file : PHPMailer
  • $sign_key_file : PHPMailer
  • $sign_key_pass : PHPMailer
  • $signalHandlers : SignalRegistry
  • $signalRegistry : Application
  • $signals : DaemonApplication
  • $signalsToDispatchEvent : Application
  • $signature : CSR , Signature , Token , SSH2 , AuthenticatorAssertionResponse
  • $signature_format : SSH2
  • $signature_validated : SSH2
  • $signatureAlgorithm : CSR
  • $signatureAlgorithmManager : JWSBuilder , JWSVerifier
  • $signatureAlgorithmManagerFactory : JWSBuilderFactory
  • $signatureFileFormats : AsymmetricKey
  • $signatureFormats : AsymmetricKey
  • $signaturePadding : RSA
  • $signatures : JWS , JWSBuilder
  • $signatureSubject : X509
  • $signCount : AuthenticatorData
  • $signer : Builder , Configuration , SignedWith
  • $signingKey : Configuration
  • $silencedErrorCache : ErrorHandler
  • $silencedErrorCount : ErrorHandler
  • $singleCommand : Application
  • $singleStatements : SimpleMetadataStatementRepository
  • $SingleTo : PHPMailer
  • $SingleToArray : PHPMailer
  • $singularizer : Inflector
  • $singularRulesets : GenericLanguageInflectorFactory
  • $siteVerifyUrl : CurlPost , Post
  • $size : CacheStorageHelper , FormField , UploadedFile , Stream , UploadedFile , ParagonIE_Sodium_Core32_Curve25519_Fe , ParagonIE_Sodium_Core_Curve25519_Fe , Stream , SplFixedArray
  • $sk : RogueListEntry
  • $skip_key_adjustment : SymmetricKey , RC2
  • $skipChildren : Cursor
  • $skipDays : FeedDocument
  • $skipFiles : ZIPExtraction
  • $skipHours : FeedDocument
  • $skippedLineNumbers : Parser
  • $sLen : RSA
  • $sliceLength : TraceStub
  • $sliceOffset : TraceStub
  • $slim : SlimCollector
  • $slug : CategoryNode
  • $smallestPrime : RSA
  • $smartMFA : SSH2
  • $smtp : PHPMailer
  • $smtp_conn : SMTP
  • $smtp_transaction_id_patterns : SMTP
  • $SMTPAuth : PHPMailer
  • $SMTPAutoTLS : PHPMailer
  • $SMTPDebug : PHPMailer
  • $SMTPKeepAlive : PHPMailer
  • $SMTPOptions : PHPMailer
  • $SMTPSecure : PHPMailer
  • $snapshot : Task
  • $snippet : ParseException
  • $socket : SocketPost , Connection , DumpServer
  • $socket_buffer : Agent
  • $softRefCount : Cursor
  • $softRefHandle : Cursor
  • $softRefTo : Cursor
  • $sort : AggregatedCollector
  • $sortOptions : SFTP
  • $source : FeedItem , HtmlView
  • $sources : Patcher
  • $spacer : Language , Zh
  • $spellcheck : FormField
  • $split : ColorField
  • $sqdmone : ParagonIE_Sodium_Core_Curve25519_H
  • $sql : TracedStatement , DatabaseDriver , DatabaseQuery
  • $sqlQueries : PdoStorage
  • $sqlQuotationChar : PDOCollector
  • $sqlShowProfileEach : PlgSystemDebug
  • $sqlShowProfiles : PlgSystemDebug
  • $sqrtadm1 : ParagonIE_Sodium_Core_Curve25519_H
  • $sqrtm1 : ParagonIE_Sodium_Core32_Curve25519_H , ParagonIE_Sodium_Core_Curve25519_H
  • $srcContext : ExceptionCaster
  • $stack : Changelog , Update , UpdateAdapter
  • $stackAlwaysUseSessionStorage : DebugBar
  • $stackSessionNamespace : DebugBar
  • $stage : HtmlView
  • $stages : HtmlView
  • $standard_suffix_1a : Catalan
  • $start : Profiler
  • $start_date : Result
  • $startAt : Php73
  • $startDate : X509
  • $started : NativeStorage , RuntimeStorage , DebugFormatterHelper , ProgressIndicator
  • $startedMeasures : TimeDataCollector , ProfileCollector
  • $startMemory : TracedStatement
  • $startSequence : CSR
  • $startTime : TracedStatement , ProgressBar , ProgressIndicator , ZIPExtraction
  • $stat : StreamString , StringWrapper
  • $stat_cache : SFTP
  • $state : CertificateSubject , CategoriesView , CategoryView , FormView , ListView , HtmlView , Indexer , Result , HtmlView , XmlView , HtmlView , JsonView , HtmlView , Session
  • $state_field : Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderNewsfeeds , PlgFinderTags
  • $statement : DatabaseDriver , DatabaseIterator , MysqliStatement , SqlsrvStatement , SingleMetadata
  • $statements : PropelCollector
  • $states : ActionButton
  • $stateStore : Update
  • $status : AbstractUsernamePasswordAuthenticationStrategy , AuthenticationResponse , ResponseBag , StatusReport , TokenBinding
  • $status_codes : SFTP
  • $statusCode : Response , FlattenException
  • $statusReports : MetadataTOCPayloadEntry
  • $statusText : FlattenException
  • $stderr : ConsoleOutput
  • $stdErrorLog : SSH2
  • $stdinIsInteractive : QuestionHelper
  • $stem : Token
  • $stemmer : Language
  • $stemmers : StemmerManager
  • $stEndings : German
  • $step : NumberField , TimeField , IntervalField , ProgressBar
  • $stepStack : Installer
  • $stepWidth : ProgressBar
  • $stop : Cursor
  • $stopped : AbstractEvent
  • $storage : DebugBar
  • $store : Session
  • $storedUser : AbstractMenu
  • $strategies : Authentication
  • $stream : FeedParser , Stream , UploadedFile , Stream , UploadedFile , RC4 , Input , StreamOutput
  • $string : AbstractString
  • $strings : Language , Text , StringController
  • $striped : MeterField
  • $stripExt : FilelistField
  • $stripFilter : ColorProcessor
  • $stripUSC : InputFilter
  • $stty : QuestionHelper , Terminal
  • $stub : Container
  • $style : NullOutputFormatter , Table
  • $styles : ColorProcessor , OutputFormatter , OutputFormatterStyleStack , Table , CliDumper , HtmlDumper
  • $styleStack : OutputFormatter
  • $stz : Date
  • $subIdentifiers : ObjectIdentifier
  • $subject : Usage , CSR , RelatedTo
  • $Subject : PHPMailer
  • $subjects : Resolver
  • $submit_class : CaptiveRenderOptions , SetupRenderOptions
  • $submit_icon : CaptiveRenderOptions , SetupRenderOptions
  • $submit_text : CaptiveRenderOptions , SetupRenderOptions
  • $subPart : Accept
  • $substitutions : Substitutions
  • $subtype : CronField
  • $success : JsonResponse , Response
  • $suggested : HtmlView
  • $suggestion : Token
  • $superlative : Russian
  • $supportedContext : PlgContentConfirmConsent
  • $supportedExtensions : MetadataStatement
  • $supportedExtensionsList : AssociationsHelper
  • $supportedFunctionality : ContentComponent
  • $supportedHttpHeaders : PlgSystemHttpHeaders
  • $supportFunctionality : PlgWorkflowFeaturing , PlgWorkflowPublishing
  • $supportsBatch : ListView
  • $supportsDiscoverInstall : FileAdapter , PackageAdapter , InstallerAdapter
  • $sx : EcdaaTrustAnchor
  • $sy : EcdaaTrustAnchor
  • $symbolsMap : AsciiSlugger
  • $syndicationURL : FeedDocument
  • $synopsis : AbstractCommand , Command
  • $t : Hash
  • $T : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $T2d : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $table : DatabaseLogger , AdminModel , UCMContent , Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $table_heading : SetupRenderOptions
  • $tableClassName : AdminModel
  • $tableFields : Table
  • $tableName : PdoStorage
  • $tablePrefix : DatabaseDriver
  • $tableWide : AbstractUnicodeString
  • $tableZero : AbstractUnicodeString
  • $tabular_data : SetupRenderOptions
  • $tag : ExplicitlyTaggedObject , LanguageAdapter , TagModel , TaggedValue , ExtensionDescriptor
  • $tagFilter : ColorProcessor
  • $tagObjectManager : Decoder
  • $tags : Update , Container
  • $tags_title : HtmlView
  • $tagsArray : InputFilter
  • $tagsChanged : TagsHelper
  • $tagsMethod : InputFilter
  • $target : AdministratorMenuItem
  • $targetAction : HtmlView
  • $targetId : HtmlView
  • $targetLanguage : HtmlView
  • $targetplatform : Update
  • $targetTitle : HtmlView
  • $task : BaseController , ExecRuleHelper
  • $taskMap : BaseController
  • $taskOptionsCache : SchedulerHelper
  • $taskRegistry : Task
  • $taxonomies : Taxonomy
  • $taxonomy : Result
  • $tcDisplay : MetadataStatement
  • $tcDisplayContentType : MetadataStatement
  • $tcDisplayPNGCharacteristics : MetadataStatement
  • $template : TraceableTwigTemplate , CMSApplication , HtmlDocument , OpensearchUrl , TemplatestyleField , TemplateModel , HtmlView , HtmlErrorRenderer
  • $template_id : MailTemplate
  • $template_style_id : MenuItem
  • $templateCount : NamespacedTwigProfileCollector , TwigProfileCollector
  • $templateData : HtmlView
  • $templates : NamespacedTwigProfileCollector , TwigProfileCollector
  • $term : Token , SSH2
  • $terminal : Application , ProgressBar , ConsoleSectionOutput
  • $terminal_modes : SSH2
  • $terms : Query
  • $text : PaginationObject , PhpToken
  • $text_prefix : AdminController , ApiController , FormController , AdminModel , BannerController , BannersController , ClientController , ClientsController , BannerModel , CategoryModel , ArticleModel , FieldController , FieldsController , GroupController , GroupsController , FieldModel , FiltersController , MapsController , FilterModel , UpdatesitesController , OverridesController , TemplateModel , ItemModel , MenuModel , ModuleModel , NewsfeedModel , LinkModel , TaskModel , TagModel , StyleController , GroupController , GroupsController , LevelController , LevelsController , NoteController , NotesController , UserController , UsersController , StagesController , TransitionsController
  • $tfa : HtmlView
  • $themes : HtmlDumper
  • $thisChainTryAll : LazyAssertion
  • $three : Prime
  • $threshold : PasswordField
  • $thrownErrors : ErrorHandler
  • $time : FinderIndexCommand
  • $timeCollector : PDOCollector
  • $timeConverter : DefaultTimeGenerator , TimeGeneratorFactory
  • $timeDataCollector : TimeableTwigExtensionProfiler , TraceableTwigEnvironment
  • $timeGenerator : FeatureSet , UuidFactory
  • $Timelimit : SMTP
  • $timeOfLastStatusChange : MetadataTOCPayloadEntry
  • $timeout : FtpClient , Server
  • $Timeout : PHPMailer , SMTP
  • $timeout : SSH2 , PublicKeyCredentialOptions , Server
  • $timeProvider : DefaultTimeGenerator , TimeGeneratorFactory
  • $timezone : AuthenticationResponse
  • $timings : DebugMonitor
  • $title : CategoryNode , Document , FeedImage , FeedItem , FeedLink , MenuItem , Asset , Result , TaskTable , TaskOption , HtmlView
  • $to : Substitution , PHPMailer
  • $toc : HelpModel , HtmlView
  • $token : Client
  • $tokenBinding : CollectedClientData
  • $tokenBindingHandler : Server , AuthenticatorAssertionResponseValidator , AuthenticatorAttestationResponseValidator , Server
  • $tokenization : ANSI
  • $tokenLength : PlgUserToken
  • $tokens : CompletionInput , ArgvInput
  • $toolbarIcon : FormView , ListView
  • $toolbarTitle : FormView , ListView
  • $toStringException : ErrorHandler
  • $total : UserGroupsHelper , Pagination , HtmlView , CheckinModel , HtmlView , InstalledModel , AdaptersModel , MediaModel
  • $totalNumberOfLines : Parser
  • $totalQueries : PlgSystemDebug
  • $totalRead : StringStream
  • $totalSize : ZIPExtraction
  • $trace : FlattenException , SilencedErrorContext
  • $traceArgs : ExceptionCaster
  • $traceAsString : FlattenException
  • $tracedErrors : ErrorHandler
  • $transactionDepth : DatabaseDriver
  • $transformations : Transformations
  • $transitions : HoursField , HtmlView
  • $transitionsEnd : HoursField
  • $transitionsStart : HoursField
  • $translate : PredefinedlistField , SqlField
  • $translateDescription : FormField
  • $translateHint : FormField
  • $translateLabel : FormField
  • $transliterator : Language
  • $transliterators : AbstractUnicodeString , AsciiSlugger
  • $translitMap : Iconv
  • $transport : Http
  • $transports : PublicKeyCredentialDescriptor , PublicKeyCredentialSource
  • $tree : MenuItem
  • $trimmable : Question
  • $trueAnswerRegex : ConfirmationQuestion
  • $trustPath : AttestationStatement , PublicKeyCredentialSource
  • $ttl : FeedDocument , MemcachedHandler , RedisHandler
  • $tval : POP3
  • $twig : TraceableTwigEnvironment
  • $two : Prime , TwistedEdwards , Engine
  • $type : AuthenticationResponse , Changelog , FeedEnclosure , OpensearchImage , OpensearchUrl , AbstractRenderer , CliRenderer , HtmlRenderer , JsonapiRenderer , JsonRenderer , XmlRenderer , FeedLink , FeedPerson , AccessiblemediaField , AccesslevelField , AliastagField , AuthorField , CachehandlerField , CalendarField , CaptchaField , CategoryField , CheckboxesField , CheckboxField , ChromestyleField , ColorField , ComboField , ComponentlayoutField , ComponentsField , ContenthistoryField , ContentlanguageField , ContenttypeField , DatabaseconnectionField , EditorField , EmailField , FileField , FilelistField , FolderlistField , FrontendlanguageField , GroupedlistField , HeadertagField , HiddenField , ImagelistField , IntegerField , LanguageField , LimitboxField , ListField , MediaField , MenuField , MenuitemField , MeterField , ModulelayoutField , ModuleorderField , ModulepositionField , ModuletagField , NoteField , NumberField , OrderingField , PasswordField , PluginsField , PluginstatusField , PredefinedlistField , RadiobasicField , RadioField , RangeField , RedirectStatusField , RegistrationdaterangeField , RulesField , SessionhandlerField , SpacerField , SqlField , StatusField , SubformField , TagField , TelephoneField , TemplatestyleField , TextareaField , TextField , TimeField , TimezoneField , TransitionField , UrlField , UseractiveField , UserField , UsergrouplistField , UserstateField , WorkflowComponentSectionsField , WorkflowconditionField , WorkflowstageField , FormField , JsonRenderer , LanguageField , PrefixField , InstallerAdapter , InstallerExtension , MenuItem , Microdata , AdminModel , JsonApiView , UCMBase , UCMType , DownloadSource , Update , ExtensionField , LogcreatorField , LogsdaterangeField , LogtypeField , PlugininfoField , ItemlanguageField , ItemtypeField , AssociationField , HtmlView , BannerclientField , ClicksField , ImpmadeField , ImptotalField , CategoryeditField , ComponentsCategoryField , CategoryField , ConfigComponentsField , FiltersField , ContactField , AssocField , ArticleField , VotelistField , VoteradioField , ComponentsFieldgroupField , ComponentsFieldsField , FieldcontextsField , FieldgroupsField , FieldLayoutField , SectionField , SubfieldsField , TypeField , BranchesField , ContentmapField , ContenttypesField , SearchfilterField , ExtensionstatusField , FolderField , LocationField , TypeField , WarningsModel , LanguageclientField , MenuItemByTypeField , MenuOrderingField , MenuParentField , MenuPresetField , MenutypeField , MenuField , MessageStatesField , UserMessagesField , ModulesModuleField , ModulesPositioneditField , ModulesPositionField , NewsfeedField , NewsfeedsField , PluginElementField , PluginorderingField , PluginTypeField , RequeststatusField , RequesttypeField , RedirectField , CronField , ExecutionRuleField , IntervalField , TaskStateField , TaskTypeField , ExecRuleHelper , TemplatelocationField , TemplatenameField , HtmlView , GroupparentField , LevelsField , ComponentsWorkflowField , WorkflowcontextsField , Key , DatabaseQuery , FtpClient , ConsentBoxField , FontsField , TemplatesListField , TinymcebuilderField , UploaddirsField , PrivacyField , DataField , UniqueidField , WebauthnField , TosField , TermsField , BaseAccept , Stub , AbstractSerializer , AttestationStatement , CollectedClientData , Credential , PublicKeyCredentialDescriptor , PublicKeyCredentialParameters , PublicKeyCredentialSource
  • $type_id : Adapter , Result
  • $type_title : Adapter , PlgFinderCategories , PlgFinderContacts , PlgFinderContent , PlgFinderNewsfeeds , PlgFinderTags
  • $typeAlias : TagsHelper , AdminModel , Table , BannerModel , ClientModel , CategoryModel , ContactModel , FormModel , ArticleModel , FormModel , FieldModel , GroupModel , UpdatesiteModel , TemplateModel , ItemModel , ModuleModel , NewsfeedModel , TaskModel , TaskTable , TagModel , NoteModel
  • $typeName : HtmlView
  • $types : MediaField , Microdata , HtmlView , OpenSSH , PuTTY , OpenSSH , PuTTY , OpenSSH , PuTTY
  • $typesKeyMapping : MysqliStatement , SqlsrvStatement
  • $typeSupports : HtmlView
  • $tz : Date
  • $ucmData : UCMContent
  • $uidKey : LdapUserProvider
  • $ulenMask : Iconv , Normalizer
  • $uncompressedTotal : ZIPExtraction
  • $unicodeTransCoder : AbstractPunycode , ToIdn , ToUnicode
  • $uninflected : Ruleset
  • $uniqueid : PHPMailer
  • $uniqueId : PlgSystemStats
  • $unknownState : ActionButton
  • $unsignedInt : ParagonIE_Sodium_Core32_Int32 , ParagonIE_Sodium_Core32_Int64
  • $update : Manifest , DatabaseQuery
  • $update_sites : CollectionAdapter
  • $updatecols : UpdateAdapter
  • $updateInfo : CheckJoomlaUpdatesCommand , UpdateCoreCommand , HtmlView
  • $updateInformation : UpdateModel
  • $updateModel : UpdateCoreCommand
  • $updateQuery : ChangeItem
  • $updates : CollectionAdapter
  • $updateSiteId : UpdateAdapter
  • $updateSiteName : UpdateAdapter
  • $upgrade : Installer
  • $uploadedFiles : ServerRequest
  • $upperLimitSearchWordCallback : Language
  • $upv : MetadataStatement
  • $urgentRequestAge : HtmlView
  • $uri : FeedLink , FeedPerson , WebAssetItem , ResolvedRoute , AbstractUri , Stream , DistantSingleMetadata
  • $uriString : Uri
  • $url : FeedEnclosure , FeedImage , PackageManifest , DownloadSource , Result , MetadataTOCPayloadEntry , StatusReport
  • $urlVar : ArticleController
  • $usages : Command
  • $use_ldapV3 : LdapClient
  • $use_request_id : SFTP
  • $use_stat_cache : SFTP
  • $useCollection : Subject
  • $used : Language
  • $usedInCollection : Subject
  • $useHtmlVarDumper : ConfigCollector , ExceptionsCollector , MessagesCollector , RequestDataCollector
  • $useIncludePath : ClassLoader
  • $useNestingLimit : Resolver , Subject , Sanitizer
  • $useOpenHandlerWhenSendingDataHeaders : DebugBar
  • $useOpensslParse : CaBundle
  • $usePoly1305 : SymmetricKey
  • $user : AddUserCommand , DatabaseLogger , AdminModel , HtmlView , InstalledModel , HtmlView , AbstractUri , PublicKeyCredentialCreationOptions
  • $user_lang_code : PlgSystemLanguageFilter
  • $userAgent : WebClient
  • $useRefHandles : Data
  • $useRequireJs : JavascriptRenderer
  • $userFactory : Icon , Basic , Token
  • $userGroupPaths : Access
  • $userGroups : Access , AddUserCommand , AddUserToGroupCommand , RemoveUserFromGroupCommand
  • $userHandle : AuthenticatorAssertionResponse , PublicKeyCredentialSource
  • $userId : ConfigurationModel , CredentialRepository
  • $userInfo : Uri
  • $userIsSuperAdmin : HtmlView
  • $username : AuthenticationResponse , AddUserToGroupCommand , ChangeUserPasswordCommand , DeleteUserCommand , RemoveUserFromGroupCommand , User , LdapClient
  • $Username : PHPMailer
  • $username : POP3 , LdapUser
  • $users_dn : LdapClient
  • $userVerification : AuthenticatorSelectionCriteria , VerificationMethodDescriptor , PublicKeyCredentialRequestOptions
  • $userVerificationDetails : MetadataStatement
  • $UseSendmailOptions : PHPMailer
  • $useThreshold : Sanitizer
  • $usingGeneratedPoly1305Key : Salsa20
  • $utf : DatabaseDriver
  • $utf8mb4 : MysqlDriver , MysqliDriver
  • $uuidBuilder : UuidFactory
  • $validate : FormField
  • $validationConstraints : Configuration
  • $validationtext : FormField
  • $validator : Configuration , PHPMailer , Question
  • $validDirectives : PlgSystemHttpHeaders
  • $value : AssertionChain , InvalidArgumentException , BigDecimal , BigInteger , ByteStringObject , MapItem , AbstractString , AbstractTime , Boolean , Integer , ObjectIdentifier , OctetString , UnknownObject , IPAddress , FormField , Field , BigInteger , Basic , BaseAccept , BigInteger , Engine , Integer , Suggestion , TableCell , LazyString , Stub , TaggedValue , AuthenticationExtension
  • $valueCache : FieldModel
  • $valueField : SqlField
  • $values : DatabaseQuery , JWK , RSAKey , UpdateOperation
  • $valueSuggestions : CompletionSuggestions
  • $varDumper : DataCollector , MessagesCollector
  • $variableName : JavascriptRenderer
  • $variables : PharInvocation
  • $vars : Router , AbstractUri
  • $vendorDir : ClassLoader
  • $vendorRoots : LinkStub
  • $verb : Russian
  • $verb_suffixes : Catalan
  • $verbosity : Output
  • $verbosityLevelMap : ConsoleLogger
  • $verificationKey : Configuration
  • $verificationMethods : VerificationMethodANDCombinations
  • $version : Changelog , AtomParser , RssParser , Manifest , Update , WebAssetItem , Application , Client , PuTTY , SFTP , RequestParameters , Application , SingleCommandApplication
  • $verticalInsideBorderChar : TableStyle
  • $verticalOutsideBorderChar : TableStyle
  • $view : RouteHelper
  • $view_item : FormController , ContactController , ContactModel , ArticleController
  • $view_list : AdminController , FormController , AssociationsController , ContactController , ArticleController
  • $viewall : Pagination
  • $viewLevels : Access
  • $viewName : CategoryView , FeedView , HtmlView , FeedView , HtmlView
  • $views : RouterView , BaseController
  • $violations : RequiredConstraintsViolated
  • $votingPosition : PlgContentVote
  • $vowels : Catalan , Danish , Dutch , English , Finnish , French , German , Italian , Norwegian , Portuguese , Romanian , Russian , Spanish , Stem , Swedish
  • $w : Rijndael
  • $wantHelps : Application
  • $wantsHelp : Application
  • $warnings : HtmlView
  • $webAssetManager : Document
  • $webmaster : FeedDocument
  • $weight : Token
  • $when1 : Query
  • $when2 : Query
  • $where : DatabaseQuery
  • $width : FeedImage , OpensearchImage , EditorField , MediaField , Terminal , DisplayPNGCharacteristicsDescriptor
  • $wildcard : CronField
  • $window_resize : SSH2
  • $window_size : SSH2
  • $window_size_client_to_server : SSH2
  • $window_size_server_to_client : SSH2
  • $windowColumns : SSH2
  • $windowRows : SSH2
  • $word : Word , Stem
  • $wordInflector : CachedWordInflector
  • $wordmode : Query
  • $WordWrap : PHPMailer
  • $workflow : HtmlView
  • $workflowId : StageController , StagesController , TransitionController , TransitionsController
  • $workflowID : HtmlView
  • $workflows : HtmlView
  • $workflowStage : TransitionField
  • $wrappedDumper : ContextualizedDumper , ServerDumper
  • $wrapper : HtmlView
  • $writable : Stream
  • $writeCount : ProgressBar
  • $writeprefix : Stream
  • $X : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $x : PrivateKey , EC , ANSI
  • $X : EcdaaTrustAnchor
  • $xdebugLinkFormat : Debug
  • $xdebugLinkTemplate : DataCollector
  • $xdebugReplacements : DataCollector
  • $xdebugShouldUseAjax : DataCollector
  • $XMailer : PHPMailer
  • $xml : Form
  • $xmlDocument : Sanitizer
  • $xmlIssues : Sanitizer
  • $xmlLoaderValue : Sanitizer
  • $xmlOptions : Sanitizer
  • $xmlParser : Changelog , Update , UpdateAdapter
  • $xPath : Resolver
  • $xssAuto : InputFilter
  • $xy2d : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp , ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $Y : ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $y : DSA , ANSI
  • $Y : EcdaaTrustAnchor
  • $years : HtmlView
  • $YminusX : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
  • $yminusx : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
  • $YminusX : ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $yminusx : ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $YplusX : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached
  • $yplusx : ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp
  • $YplusX : ParagonIE_Sodium_Core_Curve25519_Ge_Cached
  • $yplusx : ParagonIE_Sodium_Core_Curve25519_Ge_Precomp
  • $Z : ParagonIE_Sodium_Core32_Curve25519_Ge_Cached , ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core32_Curve25519_Ge_P2 , ParagonIE_Sodium_Core32_Curve25519_Ge_P3 , ParagonIE_Sodium_Core_Curve25519_Ge_Cached , ParagonIE_Sodium_Core_Curve25519_Ge_P1p1 , ParagonIE_Sodium_Core_Curve25519_Ge_P2 , ParagonIE_Sodium_Core_Curve25519_Ge_P3
  • $zero : AsymmetricKey , Montgomery , TwistedEdwards , Engine , Integer
  • $zones : TimezoneField


Joomla CMS: Champs de donnée - Variables

- a -

  • ABOVE_NORMAL : Priority
  • ABS : FetchOrientation
  • ACCENTED_CHARACTERS : Inflector
  • ACCEPTABLE_EVENTS : NotifyActionLog
  • ACTIVE : SessionState
  • ADDITIONAL_INFORMATION : ByteStringWithChunkObject , InfiniteListObject , InfiniteMapObject , TextStringWithChunkObject
  • aead_chacha20poly1305_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_IETF_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_chacha20poly1305_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_ABYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_NPUBBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • aead_xchacha20poly1305_IETF_NSECBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • AFTER_EXECUTE : ApplicationEvents
  • AFTER_RESPOND : ApplicationEvents
  • AK_STATE_DATA : ZIPExtraction
  • AK_STATE_DATAREAD : ZIPExtraction
  • AK_STATE_DONE : ZIPExtraction
  • AK_STATE_FINISHED : ZIPExtraction
  • AK_STATE_HEADER : ZIPExtraction
  • AK_STATE_INITIALIZE : ZIPExtraction
  • AK_STATE_NOFILE : ZIPExtraction
  • AK_STATE_POSTPROC : ZIPExtraction
  • ALERT : Log , LogLevel
  • ALG : Key
  • ALG_KEY_COSE : MetadataStatement
  • ALG_KEY_ECC_X962_DER : MetadataStatement
  • ALG_KEY_ECC_X962_RAW : MetadataStatement
  • ALG_KEY_RSA_2048_DER : MetadataStatement
  • ALG_KEY_RSA_2048_RAW : MetadataStatement
  • ALG_SIGN_ED25519_EDDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSA_EMSA_PKCS1_SHA256_DER : MetadataStatement
  • ALG_SIGN_RSA_EMSA_PKCS1_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA1_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA384_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PKCSV15_SHA512_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA256_DER : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA256_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA384_RAW : MetadataStatement
  • ALG_SIGN_RSASSA_PSS_SHA512_RAW : MetadataStatement
  • ALG_SIGN_SECP256K1_ECDSA_SHA256_DER : MetadataStatement
  • ALG_SIGN_SECP256K1_ECDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_SECP256R1_ECDSA_SHA256_DER : MetadataStatement
  • ALG_SIGN_SECP256R1_ECDSA_SHA256_RAW : MetadataStatement
  • ALG_SIGN_SECP384R1_ECDSA_SHA384_RAW : MetadataStatement
  • ALG_SIGN_SECP521R1_ECDSA_SHA512_RAW : MetadataStatement
  • ALG_SIGN_SM2_SM3_RAW : MetadataStatement
  • ALGORITHM : DH , DSA , EC , RSA
  • ALIASES : ConsoleEvents
  • ALIGN_MAP : TableCellStyle
  • ALL : Log , UriInterface , RegisteredClaims
  • ALLOWED_GLOBALS : Input
  • ALLOWED_STREAM_RESOURCE_TYPES : Stream
  • ALPHABET : Calculator
  • ALPHABET_ALPHANUMERIC : ByteString
  • AMAYA : WebClient
  • AMHARIC_LANGUAGE_CODE : ASCII
  • AMQP_EX_TYPE_FANOUT : AmqpCaster
  • AMQP_PASSIVE : AmqpCaster
  • ANDROID : WebClient
  • ANDROIDTABLET : WebClient
  • ANY_MAP : ASN1
  • API_FEATURE_INFO : ConnectionOptions
  • API_INFO : ConnectionOptions
  • APPLICATION_ERROR : ConsoleEvents
  • ARABIC_LANGUAGE_CODE : ASCII
  • ARMENIAN_LANGUAGE_CODE : ASCII
  • ARRAY_ASSOC : Stub
  • ARRAY_INDEXED : Stub
  • ASCII : AbstractUnicodeString
  • ASN1_BIG_INTEGER_LIMIT : ECSignature , MultibyteStringConverter
  • ASN1_INTEGER : ECSignature , MultibyteStringConverter
  • ASN1_LENGTH_2BYTES : ECSignature , MultibyteStringConverter
  • ASN1_MAX_SINGLE_BYTE : ECSignature , MultibyteStringConverter
  • ASN1_NEGATIVE_INTEGER : ECSignature , MultibyteStringConverter
  • ASN1_SEQUENCE : ECSignature , MultibyteStringConverter
  • ASSERT_INTERNAL_INVOCATION : PharInvocationResolver
  • ASSET_STATE_ACTIVE : WebAssetManager
  • ASSET_STATE_DEPENDENCY : WebAssetManager
  • ASSET_STATE_INACTIVE : WebAssetManager
  • ASSOCIATIVE : FetchMode
  • ATTACHMENT_HINT_BLUETOOTH : MetadataStatement
  • ATTACHMENT_HINT_EXTERNAL : MetadataStatement
  • ATTACHMENT_HINT_INTERNAL : MetadataStatement
  • ATTACHMENT_HINT_NETWORK : MetadataStatement
  • ATTACHMENT_HINT_NFC : MetadataStatement
  • ATTACHMENT_HINT_READY : MetadataStatement
  • ATTACHMENT_HINT_WIFI_DIRECT : MetadataStatement
  • ATTACHMENT_HINT_WIRED : MetadataStatement
  • ATTACHMENT_HINT_WIRELESS : MetadataStatement
  • ATTESTATION_ATTCA : MetadataStatement
  • ATTESTATION_BASIC_FULL : MetadataStatement
  • ATTESTATION_BASIC_SURROGATE : MetadataStatement
  • ATTESTATION_CONVEYANCE_PREFERENCE_DIRECT : PublicKeyCredentialCreationOptions
  • ATTESTATION_CONVEYANCE_PREFERENCE_INDIRECT : PublicKeyCredentialCreationOptions
  • ATTESTATION_CONVEYANCE_PREFERENCE_NONE : PublicKeyCredentialCreationOptions
  • ATTESTATION_ECDAA : MetadataStatement
  • ATTESTATION_KEY_COMPROMISE : AuthenticatorStatus
  • ATTR_ALL : X509
  • ATTR_APPEND : X509
  • ATTR_REPLACE : X509
  • AUDIENCE : RegisteredClaims
  • AUTHENTICATION_INFO : Crypto
  • AUTHENTICATION_INFO_STRING : Core
  • AUTHENTICATOR_ATTACHMENT_CROSS_PLATFORM : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_ATTACHMENT_NO_PREFERENCE : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_ATTACHMENT_PLATFORM : AuthenticatorSelectionCriteria
  • AUTHENTICATOR_TRANSPORT_BLE : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_INTERNAL : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_NFC : PublicKeyCredentialDescriptor
  • AUTHENTICATOR_TRANSPORT_USB : PublicKeyCredentialDescriptor
  • AUTHORITY_INFORMATION_ACCESS : OID
  • AUTHORITY_REVOCATION_LIST : OID
  • AVAILABLE_OPTIONS : Color
  • AZERBAIJANI_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- b -

  • base : AbstractPunycode
  • BASE : PHP32 , PHP64
  • BASE64_VARIANT_ORIGINAL : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_ORIGINAL_NO_PADDING : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_URLSAFE : ParagonIE_Sodium_Compat
  • BASE64_VARIANT_URLSAFE_NO_PADDING : ParagonIE_Sodium_Compat
  • BASE_FULL : PHP32 , PHP64
  • BASE_IV : Key
  • BEFORE_COMMAND_EXECUTE : ConsoleEvents
  • BEFORE_EXECUTE : ApplicationEvents
  • BEFORE_RESPOND : ApplicationEvents
  • BELARUSIAN_LANGUAGE_CODE : ASCII
  • BELOW_NORMAL : Priority
  • BENGALI_LANGUAGE_CODE : ASCII
  • BITSTRING : Identifier
  • BLACKBERRY : WebClient
  • BLINK : WebClient
  • BLOCK_BYTE_SIZE : Core
  • BLOCK_SCALAR_HEADER_PATTERN : Parser
  • BLOCK_SIZE : ParagonIE_Sodium_Core32_Poly1305 , ParagonIE_Sodium_Core_Poly1305
  • BLOCKBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • BMP_STRING : Identifier
  • BOOLEAN : Identifier , ParameterType
  • BORDER_INSIDE : Table
  • BORDER_OUTSIDE : Table
  • box_curve25519xsalsa20poly1305_BEFORENMBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_PUBLICKEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_SECRETKEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_SEEDBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • box_curve25519xsalsa20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • BRIGHT_COLORS : Color
  • BUFFER_BYTE_SIZE : Core
  • BUFFER_SIZE : ParagonIE_Sodium_File
  • BUILTIN_RETURN_TYPES : DebugClassLoader
  • BULGARIAN_LANGUAGE_CODE : ASCII
  • BYTE_SIZE : ECSignature , MultibyteStringConverter


Joomla CMS: Champs de donnée - Variables

- c -

  • CALG_RSA_KEYX : MSBLOB
  • CALG_RSA_SIGN : MSBLOB
  • CAN_FAIL_MARKER : Installer
  • CAN_FAIL_MARKER_LENGTH : Installer
  • CASE_FOLD : Grapheme , Mbstring
  • CEILING : RoundingMode
  • CERT_EXT_AUTHORITY_KEY_IDENTIFIER : OID
  • CERT_EXT_BASIC_CONSTRAINTS : OID
  • CERT_EXT_CERT_ISSUER : OID
  • CERT_EXT_CERT_POLICIES : OID
  • CERT_EXT_CRL_DISTRIBUTION_POINTS : OID
  • CERT_EXT_CRL_NUMBER : OID
  • CERT_EXT_DELTA_CRL_INDICATOR : OID
  • CERT_EXT_EXTENDED_KEY_USAGE : OID
  • CERT_EXT_INVALIDITY_DATE : OID
  • CERT_EXT_ISSUER_ALT_NAME : OID
  • CERT_EXT_ISSUING_DIST_POINT : OID
  • CERT_EXT_KEY_USAGE : OID
  • CERT_EXT_NAME_CONSTRAINTS : OID
  • CERT_EXT_PRIVATE_KEY_USAGE_PERIOD : OID
  • CERT_EXT_REASON_CODE : OID
  • CERT_EXT_SUBJECT_ALT_NAME : OID
  • CERT_EXT_SUBJECT_DIRECTORY_ATTR : OID
  • CERT_EXT_SUBJECT_KEY_IDENTIFIER : OID
  • CHANNEL : SFTP
  • CHANNEL_AGENT_FORWARD : SSH2
  • CHANNEL_EXEC : SSH2
  • CHANNEL_KEEP_ALIVE : SSH2
  • CHANNEL_SHELL : SSH2
  • CHANNEL_SUBSYSTEM : SSH2
  • CHAR_SUB_DELIMS : Uri
  • CHAR_UNRESERVED : Uri
  • CHARACTER_STRING : Identifier
  • CHARSET_ASCII : PHPMailer
  • CHARSET_ISO88591 : PHPMailer
  • CHARSET_UTF8 : PHPMailer
  • CHECKSUM_BYTE_SIZE : Encoding
  • CHECKSUM_HASH_ALGO : Encoding
  • CHINESE_LANGUAGE_CODE : ASCII
  • CHROME : WebClient
  • CHUNK_SIZE : ZIPExtraction
  • CIPHER : Crypto
  • CIPHER_METHOD : Core
  • CIPHER_MODE : Crypto
  • CLASS_APPLICATION : Identifier , ASN1
  • CLASS_CONTEXT_SPECIFIC : Identifier , ASN1
  • CLASS_PRIVATE : Identifier , ASN1
  • CLASS_UNIVERSAL : Identifier , ASN1
  • CLIENT_CONTROLS : ConnectionOptions
  • CLOSED : SessionState
  • CODE_LENGTH : Email
  • CODENAME : Version
  • COLORS : Color , DebugFormatterHelper
  • COLUMN : FetchMode
  • COMMAND : ConsoleEvents
  • COMMAND_DIR_OPENDIR : Behavior
  • COMMAND_ERROR : ConsoleEvents
  • COMMAND_MKDIR : Behavior
  • COMMAND_RENAME : Behavior
  • COMMAND_RMDIR : Behavior
  • COMMAND_STEAM_METADATA : Behavior
  • COMMAND_STREAM_OPEN : Behavior
  • COMMAND_UNLINK : Behavior
  • COMMAND_URL_STAT : Behavior
  • COMMON_NAME : OID
  • COMPRESSION_MODES : RedisCaster
  • CONDITION_ARCHIVED : Workflow , ContentComponent
  • CONDITION_NAMES : Workflow , ContentComponent
  • CONDITION_PUBLISHED : Workflow , ContentComponent
  • CONDITION_TRASHED : Workflow , ContentComponent
  • CONDITION_UNPUBLISHED : Workflow , ContentComponent
  • CONFIG_GET_GROUP_NOT_FOUND : GetConfigurationCommand
  • CONFIG_GET_OPTION_FAILED : GetConfigurationCommand
  • CONFIG_GET_OPTION_NOT_FOUND : GetConfigurationCommand
  • CONFIG_GET_SUCCESSFUL : GetConfigurationCommand
  • CONFIG_OPTIONS_WRONG : SetConfigurationCommand
  • CONFIG_SET_FAILED : SetConfigurationCommand
  • CONFIG_SET_SUCCESSFUL : SetConfigurationCommand
  • CONFIG_VALIDATION_FAILED : SetConfigurationCommand
  • CONTENT_TYPE_MULTIPART_ALTERNATIVE : PHPMailer
  • CONTENT_TYPE_MULTIPART_MIXED : PHPMailer
  • CONTENT_TYPE_MULTIPART_RELATED : PHPMailer
  • CONTENT_TYPE_PLAINTEXT : PHPMailer
  • CONTENT_TYPE_TEXT_CALENDAR : PHPMailer
  • CONTENT_TYPE_TEXT_HTML : PHPMailer
  • COPYRIGHT : Version
  • CORE_H2C_SHA256 : ParagonIE_Sodium_Core_Ristretto255
  • CORE_H2C_SHA512 : ParagonIE_Sodium_Core_Ristretto255
  • COSE_ALGORITHM_A128GCM : Algorithms
  • COSE_ALGORITHM_A128KW : Algorithms
  • COSE_ALGORITHM_A192GCM : Algorithms
  • COSE_ALGORITHM_A192KW : Algorithms
  • COSE_ALGORITHM_A256GCM : Algorithms
  • COSE_ALGORITHM_A256KW : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_128_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_128_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_64_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_16_64_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_128_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_128_256 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_64_128 : Algorithms
  • COSE_ALGORITHM_AES_CCM_64_64_256 : Algorithms
  • COSE_ALGORITHM_AES_MAC_128_128 : Algorithms
  • COSE_ALGORITHM_AES_MAC_128_64 : Algorithms
  • COSE_ALGORITHM_AES_MAC_256_128 : Algorithms
  • COSE_ALGORITHM_AES_MAC_256_64 : Algorithms
  • COSE_ALGORITHM_CHACHA20_POLY1305 : Algorithms
  • COSE_ALGORITHM_DIRECT : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_AES_128 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_AES_256 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_SHA_256 : Algorithms
  • COSE_ALGORITHM_DIRECT_HKDF_SHA_512 : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A128KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A192KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_A256KW : Algorithms
  • COSE_ALGORITHM_ECDH_ES_HKDF_256 : Algorithms
  • COSE_ALGORITHM_ECDH_ES_HKDF_512 : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A128KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A192KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_A256KW : Algorithms
  • COSE_ALGORITHM_ECDH_SS_HKDF_256 : Algorithms
  • COSE_ALGORITHM_ECDH_SS_HKDF_512 : Algorithms
  • COSE_ALGORITHM_ED256 : Algorithms
  • COSE_ALGORITHM_ED512 : Algorithms
  • COSE_ALGORITHM_EdDSA : Algorithms
  • COSE_ALGORITHM_ES256 : Algorithms
  • COSE_ALGORITHM_ES256K : Algorithms
  • COSE_ALGORITHM_ES384 : Algorithms
  • COSE_ALGORITHM_ES512 : Algorithms
  • COSE_ALGORITHM_HS256 : Algorithms
  • COSE_ALGORITHM_HS256_64 : Algorithms
  • COSE_ALGORITHM_HS384 : Algorithms
  • COSE_ALGORITHM_HS512 : Algorithms
  • COSE_ALGORITHM_MAP : Algorithms
  • COSE_ALGORITHM_PS256 : Algorithms
  • COSE_ALGORITHM_PS384 : Algorithms
  • COSE_ALGORITHM_PS512 : Algorithms
  • COSE_ALGORITHM_RS1 : Algorithms
  • COSE_ALGORITHM_RS256 : Algorithms
  • COSE_ALGORITHM_RS384 : Algorithms
  • COSE_ALGORITHM_RS512 : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP_256 : Algorithms
  • COSE_ALGORITHM_RSAES_OAEP_512 : Algorithms
  • COSE_HASH_MAP : Algorithms
  • COUNTRY_NAME : OID
  • CR : AbstractSerializer
  • CREDENTIAL_TYPE_PUBLIC_KEY : PublicKeyCredentialDescriptor
  • CRITICAL : Log , LogLevel
  • CRLF : PHPMailer
  • CROATIAN_LANGUAGE_CODE : ASCII
  • CROP : Image
  • CROP_RESIZE : Image
  • CRYPTO_AEAD_AES256GCM_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_AES256GCM_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AUTH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_AUTH_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_MACBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_NONCEBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SEALBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_BOX_SEEDBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_HASHBYTES : ParagonIE_Sodium_Compat
  • crypto_core_ristretto255_HASHBYTES : ParagonIE_Sodium_Core_Ristretto255
  • CRYPTO_CORE_RISTRETTO255_NONREDUCEDSCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_CORE_RISTRETTO255_SCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_BYTES_MIN : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_GENERICHASH_KEYBYTES_MIN : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_BYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_BYTES_MIN : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_CONTEXTBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KDF_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_PRIMITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_KX_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SEEDBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_KX_SESSIONKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_ALG_ARGON2I13 : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_ALG_ARGON2ID13 : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_MODERATE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_MEMLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_MODERATE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_OPSLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SALTBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX : ParagonIE_Sodium_Compat
  • CRYPTO_PWHASH_STRPREFIX : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_RISTRETTO255_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_RISTRETTO255_SCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SCALARMULT_SCALARBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_MACBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETBOX_NONCEBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH : ParagonIE_Sodium_Compat
  • CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY : ParagonIE_Sodium_Compat
  • CRYPTO_SHORTHASH_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SHORTHASH_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_BYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_KEYPAIRBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_PUBLICKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_SECRETKEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_SIGN_SEEDBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_NONCEBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_XCHACHA20_KEYBYTES : ParagonIE_Sodium_Compat
  • CRYPTO_STREAM_XCHACHA20_NONCEBYTES : ParagonIE_Sodium_Compat
  • CSR_VERSION_NR : CSR
  • CSRFC3548 : Base32
  • CTRL_DIR_END : Zip
  • CTRL_DIR_HEADER : Zip
  • CURRENT_VERSION : Core
  • CURVE_ED25519 : OkpKey
  • CURVE_ED448 : OkpKey
  • CURVE_KEY_LENGTH : Ec2Key
  • CURVE_P256 : Ec2Key
  • CURVE_P256K : Ec2Key
  • CURVE_P384 : Ec2Key
  • CURVE_P521 : Ec2Key
  • CURVE_X25519 : OkpKey
  • CURVE_X448 : OkpKey
  • CUSTOM_OBJECT : FetchMode
  • CUSTOM_RULE_GROUP : ExecutionRulesRule
  • CZECH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- d -

  • damp : AbstractPunycode
  • DANISH_LANGUAGE_CODE : ASCII
  • DATA : Base , Barrett , Base
  • DATA_CURVE : Ec2Key , OkpKey
  • DATA_D : Ec2Key , OkpKey , RsaKey
  • DATA_DI : RsaKey
  • DATA_DP : RsaKey
  • DATA_DQ : RsaKey
  • DATA_E : RsaKey
  • DATA_K : SymmetricKey
  • DATA_N : RsaKey
  • DATA_OTHER : RsaKey
  • DATA_P : RsaKey
  • DATA_Q : RsaKey
  • DATA_QI : RsaKey
  • DATA_RI : RsaKey
  • DATA_TI : RsaKey
  • DATA_X : Ec2Key , OkpKey
  • DATA_Y : Ec2Key
  • DATE_CLAIMS : RegisteredClaims
  • DAY : CronExpression
  • DAY_ABBR : Date
  • DAY_NAME : Date
  • DB_GROUP : GetConfigurationCommand
  • DB_VALIDATION_FAILED : SetConfigurationCommand
  • DEBUG : Log , LogLevel
  • DEBUG_CLIENT : POP3 , SMTP
  • DEBUG_CONNECTION : SMTP
  • DEBUG_LEVEL : ConnectionOptions
  • DEBUG_LOWLEVEL : SMTP
  • DEBUG_OFF : POP3 , SMTP
  • DEBUG_SERVER : POP3 , SMTP
  • DECRYPT : DES , RC4 , Salsa20
  • DEFAULT_ALIGN : TableCellStyle
  • DEFAULT_ENCODING : FromUtf8 , ToUtf8
  • DEFAULT_JSON_FLAGS : JsonResponse
  • DEFAULT_MESSAGE : RegisteredClaimGiven
  • DEFAULT_NAMESPACE_PREFIX : XPath
  • DEFAULT_PORT : POP3 , SMTP
  • DEFAULT_TIMEOUT : POP3
  • DEREF : ConnectionOptions
  • DEREF_ALWAYS : QueryInterface
  • DEREF_FINDING : QueryInterface
  • DEREF_NEVER : QueryInterface
  • DEREF_SEARCHING : QueryInterface
  • DESCRIPTION : OID
  • DESTROYED : SessionState
  • DEV_STATUS : Version
  • DIAG_CODES : PgSqlCaster
  • DN_ARRAY : X509
  • DN_ASN1 : X509
  • DN_CANON : X509
  • DN_HASH : X509
  • DN_OPENSSL : X509
  • DN_STRING : X509
  • DOM_INDEX_SIZE_ERR : DOMCaster
  • DOWN : RoundingMode
  • DST_FILE : Patcher
  • DUMP_COMMA_SEPARATOR : AbstractDumper
  • DUMP_EMPTY_ARRAY_AS_SEQUENCE : Yaml
  • DUMP_EXCEPTION_ON_INVALID_TYPE : Yaml
  • DUMP_LIGHT_ARRAY : AbstractDumper
  • DUMP_MULTI_LINE_LITERAL_BLOCK : Yaml
  • DUMP_NULL_AS_TILDE : Yaml
  • DUMP_OBJECT : Yaml
  • DUMP_OBJECT_AS_MAP : Yaml
  • DUMP_STRING_LENGTH : AbstractDumper
  • DUMP_TRAILING_COMMA : AbstractDumper
  • DUPLICATE_ALIAS_WARNING : PharInvocationCollection
  • DUTCH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- e -

  • E_ACTION_MISMATCH : ReCaptcha
  • E_APK_PACKAGE_NAME_MISMATCH : ReCaptcha
  • E_BAD_RESPONSE : ReCaptcha
  • E_CHALLENGE_TIMEOUT : ReCaptcha
  • E_COMPILE_ERROR : ErrorHandler
  • E_COMPILE_WARNING : ErrorHandler
  • E_CONNECTION_FAILED : ReCaptcha
  • E_CORE_ERROR : ErrorHandler
  • E_CORE_WARNING : ErrorHandler
  • E_ERROR : ErrorHandler
  • E_HOSTNAME_MISMATCH : ReCaptcha
  • E_INVALID_JSON : ReCaptcha
  • E_MISSING_INPUT_RESPONSE : ReCaptcha
  • E_NOTICE : ErrorHandler
  • E_PARSE : ErrorHandler
  • E_RECOVERABLE_ERROR : ErrorHandler
  • E_SCORE_THRESHOLD_NOT_MET : ReCaptcha
  • E_STRICT : ErrorHandler
  • E_UNKNOWN_ERROR : ReCaptcha
  • E_USER_DEPRECATED : ErrorHandler , ExceptionCaster
  • E_USER_ERROR : ErrorHandler
  • E_USER_NOTICE : ErrorHandler
  • E_USER_WARNING : ErrorHandler
  • E_WARNING : ErrorHandler
  • EDG : WebClient
  • EDGE : WebClient
  • EMBEDDED_PDV : Identifier
  • EMERGENCY : Log , LogLevel
  • ENCODING_7BIT : PHPMailer
  • ENCODING_8BIT : PHPMailer
  • ENCODING_BASE64 : PHPMailer
  • ENCODING_BINARY : PHPMailer
  • ENCODING_QUOTED_PRINTABLE : PHPMailer
  • encodings : TranscodeUnicode
  • ENCRYPT : DES , RC4 , Salsa20
  • ENCRYPTION_INFO : Crypto
  • ENCRYPTION_INFO_STRING : Core
  • ENCRYPTION_NONE : RSA
  • ENCRYPTION_OAEP : RSA
  • ENCRYPTION_PKCS1 : RSA
  • ENCRYPTION_SMTPS : PHPMailer
  • ENCRYPTION_STARTTLS : PHPMailer
  • ENGINE_DIR : BCMath , GMP , PHP
  • ENGINE_EVAL : SymmetricKey
  • ENGINE_INTERNAL : SymmetricKey
  • ENGINE_LIBSODIUM : SymmetricKey
  • ENGINE_MAP : SymmetricKey
  • ENGINE_MCRYPT : SymmetricKey
  • ENGINE_OPENSSL : SymmetricKey
  • ENGINE_OPENSSL_GCM : SymmetricKey
  • ENGLISH : Language
  • ENGLISH_LANGUAGE_CODE : ASCII
  • ENUMERATED : Identifier
  • EOC : Identifier
  • EOL : AbstractSerializer
  • ERR_CHECKS_FAILED : UpdateCoreCommand
  • ERR_UPDATE_FAILED : UpdateCoreCommand
  • ERROR : ApplicationEvents , Log , SessionState , LogLevel , ConsoleEvents , ConsoleLogger
  • ERROR_CODES : DOMCaster
  • ERROR_ILLEGAL_CHARACTER : Iconv
  • ERROR_MESSAGES : UploadedFile
  • ERROR_NUMBER : ConnectionOptions
  • ERROR_STRING : ConnectionOptions
  • ERROR_WRONG_CHARSET : Iconv
  • ERRORS : UploadedFile
  • ESCAPE_DN : LdapInterface
  • ESCAPE_FILTER : LdapInterface
  • ESCAPED : Escaper
  • ESCAPED_DATA : GithubActionReporter
  • ESCAPED_PROPERTIES : GithubActionReporter
  • ESCAPEES : Escaper
  • ESPERANTO_LANGUAGE_CODE : ASCII
  • ESTONIAN_LANGUAGE_CODE : ASCII
  • EVENTS_MAP : Task
  • EXCHANGE_TYPES : AmqpCaster
  • EXCLUDE_DYNAMIC : Caster
  • EXCLUDE_EMPTY : Caster
  • EXCLUDE_NOT_IMPORTANT : Caster
  • EXCLUDE_NULL : Caster
  • EXCLUDE_PRIVATE : Caster
  • EXCLUDE_PROTECTED : Caster
  • EXCLUDE_PUBLIC : Caster
  • EXCLUDE_STRICT : Caster
  • EXCLUDE_VERBOSE : Caster
  • EXCLUDE_VIRTUAL : Caster
  • EXECUTABLES : MediaHelper
  • EXPIRATION_TIME : RegisteredClaims
  • EXPIRED : SessionState
  • EXTERNAL : Identifier
  • EXTRA_LATIN_CHARS_LANGUAGE_CODE : ASCII
  • EXTRA_MAP : ReflectionCaster
  • EXTRA_MSWORD_CHARS_LANGUAGE_CODE : ASCII
  • EXTRA_VERSION : Version
  • EXTRA_WHITESPACE_CHARS_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- f -

  • FAILOVER_OPTIONS : RedisCaster
  • FAILURE : Command
  • FAST_BITWISE : BCMath , GMP , PHP
  • FETCH_MODE_MAP : PdoStatement
  • FIDO_CERTIFIED : AuthenticatorStatus
  • FIDO_CERTIFIED_L1 : AuthenticatorStatus
  • FIDO_CERTIFIED_L1plus : AuthenticatorStatus
  • FIDO_CERTIFIED_L2 : AuthenticatorStatus
  • FIDO_CERTIFIED_L2plus : AuthenticatorStatus
  • FIDO_CERTIFIED_L3 : AuthenticatorStatus
  • FIDO_CERTIFIED_L3plus : AuthenticatorStatus
  • FIELD_CUSTOM : CaptiveRenderOptions , SetupRenderOptions
  • FIELD_INPUT : CaptiveRenderOptions , SetupRenderOptions
  • FILE_HEADER : Zip
  • FINNISH_LANGUAGE_CODE : ASCII
  • FIREFOX : WebClient
  • FIRST : FetchOrientation
  • FLAG_AT : AttestationObjectLoader , AuthenticatorData , PublicKeyCredentialLoader
  • FLAG_ED : AttestationObjectLoader , AuthenticatorData , PublicKeyCredentialLoader
  • FLAG_RFU1 : AuthenticatorData
  • FLAG_RFU2 : AuthenticatorData
  • FLAG_UP : AuthenticatorData
  • FLAG_UV : AuthenticatorData
  • FLAGS : Gzip , AmqpCaster
  • FLOOR : RoundingMode
  • FOLD_FROM : AbstractUnicodeString
  • FOLD_TO : AbstractUnicodeString
  • FORBIDDEN_FILE_EXTENSIONS : InputFilter
  • FORM_C : Normalizer
  • FORM_D : Normalizer
  • FORM_KC : Normalizer
  • FORM_KD : Normalizer
  • FORMAT_AUTO_DETECT : X509
  • FORMAT_DEBUG : ProgressBar
  • FORMAT_DEBUG_NOMAX : ProgressBar
  • FORMAT_DER : X509
  • FORMAT_NORMAL : ProgressBar
  • FORMAT_NORMAL_NOMAX : ProgressBar
  • FORMAT_PEM : X509
  • FORMAT_SPKAC : X509
  • FORMAT_TAR_BZIP : DownloadSource
  • FORMAT_TAR_GZ : DownloadSource
  • FORMAT_UCS4 : TranscodeUnicode
  • FORMAT_UCS4_ARRAY : TranscodeUnicode
  • FORMAT_UTF7 : TranscodeUnicode
  • FORMAT_UTF7_IMAP : TranscodeUnicode
  • FORMAT_UTF8 : TranscodeUnicode
  • FORMAT_VERBOSE : ProgressBar
  • FORMAT_VERBOSE_NOMAX : ProgressBar
  • FORMAT_VERY_VERBOSE : ProgressBar
  • FORMAT_VERY_VERBOSE_NOMAX : ProgressBar
  • FORMAT_ZIP : DownloadSource
  • FORMATS : ProgressIndicator
  • FORWARD_ACTIVE : Agent
  • FORWARD_NONE : Agent
  • FORWARD_REQUEST : Agent
  • FRAGMENT : UriInterface
  • FRENCH : Language
  • FRENCH_AUSTRIAN_LANGUAGE_CODE : ASCII
  • FRENCH_LANGUAGE_CODE : ASCII
  • FRENCH_SWITZERLAND_LANGUAGE_CODE : ASCII
  • function : HtmlErrorRenderer
  • FWS : PHPMailer


Joomla CMS: Champs de donnée - Variables

- g -

  • GECKO : WebClient
  • GENERAL_STRING : Identifier
  • GENERALIZED_TIME : Identifier
  • GEORGIAN_LANGUAGE_CODE : ASCII
  • GERMAN_AUSTRIAN_LANGUAGE_CODE : ASCII
  • GERMAN_LANGUAGE_CODE : ASCII
  • GERMAN_SWITZERLAND_LANGUAGE_CODE : ASCII
  • GHOST_ADDONS : HtmlErrorRenderer
  • GHOST_GIFT : HtmlErrorRenderer
  • GHOST_HEART : HtmlErrorRenderer
  • GHOST_PLUS : HtmlErrorRenderer
  • GLOBAL_NAMESPACE : ApplicationDescription
  • GRAPHEME_CLUSTER_RX : Grapheme
  • GRAPHIC_STRING : Identifier
  • GREEK_LANGUAGE_CODE : ASCII
  • GREEKLISH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- h -

  • HALF_CEILING : RoundingMode
  • HALF_DOWN : RoundingMode
  • HALF_EVEN : RoundingMode
  • HALF_FLOOR : RoundingMode
  • HALF_UP : RoundingMode
  • HASH : Ed25519 , Ed448
  • HASH_ALGORITHMS : UserHelper
  • HASH_ARGON2I : UserHelper
  • HASH_ARGON2I_BC : UserHelper
  • HASH_ARGON2ID : UserHelper
  • HASH_ARGON2ID_BC : UserHelper
  • HASH_ASSOC : Cursor
  • HASH_BCRYPT : UserHelper
  • HASH_BCRYPT_BC : UserHelper
  • HASH_FUNCTION : Crypto
  • HASH_FUNCTION_NAME : Core
  • HASH_INDEXED : Cursor
  • HASH_MD5 : UserHelper
  • HASH_NOT_PROVIDED : InstallerHelper
  • HASH_NOT_VALIDATED : InstallerHelper
  • HASH_OBJECT : Cursor
  • HASH_PHPASS : UserHelper
  • HASH_RESOURCE : Cursor
  • HASH_SC_L : ParagonIE_Sodium_Core_Ristretto255
  • HASH_VALIDATED : InstallerHelper
  • HEADER_VERSION_SIZE : Core
  • HIGH : Priority
  • HINDI_LANGUAGE_CODE : ASCII
  • HOST : UriInterface
  • HOST_NAME : ConnectionOptions
  • HOUR : CronExpression
  • HUNGARIAN_LANGUAGE_CODE : ASCII
  • HUNK : Patcher


Joomla CMS: Champs de donnée - Variables

- i -

  • IA5_STRING : Identifier
  • ICAL_METHOD_ADD : PHPMailer
  • ICAL_METHOD_CANCEL : PHPMailer
  • ICAL_METHOD_COUNTER : PHPMailer
  • ICAL_METHOD_DECLINECOUNTER : PHPMailer
  • ICAL_METHOD_PUBLISH : PHPMailer
  • ICAL_METHOD_REFRESH : PHPMailer
  • ICAL_METHOD_REPLY : PHPMailer
  • ICAL_METHOD_REQUEST : PHPMailer
  • ID : HS256 , HS256Truncated64 , HS384 , HS512 , ES256 , ES256K , ES384 , ES512 , Ed25519 , ED256 , ED512 , PS256 , PS384 , PS512 , RS1 , RS256 , RS384 , RS512 , RegisteredClaims
  • IDENTIFIER : DNSName , IPAddress
  • IE : WebClient
  • INACTIVE : SessionState
  • INCOMPLETE_CREDENTIALS : Authentication
  • INFO : Log , LogLevel , ConsoleLogger
  • initialBias : AbstractPunycode
  • INITIALIZE_CONSTRUCTOR : JavascriptRenderer
  • INITIALIZE_CONTROLS : JavascriptRenderer
  • initialN : AbstractPunycode
  • INSTALLATION_FAILED : ExtensionInstallCommand
  • INSTALLATION_SUCCESSFUL : ExtensionInstallCommand
  • INTEGER : Identifier , ParameterType
  • INTERFACE_NOT_IMPLEMENTED : Assertion
  • INVALID : Command
  • INVALID_ALNUM : Assertion
  • INVALID_ARRAY : Assertion
  • INVALID_ARRAY_ACCESSIBLE : Assertion
  • INVALID_BASE64 : Assertion
  • INVALID_BETWEEN : Assertion
  • INVALID_BETWEEN_EXCLUSIVE : Assertion
  • INVALID_BOOLEAN : Assertion
  • INVALID_CALLABLE : Assertion
  • INVALID_CHOICE : Assertion
  • INVALID_CLASS : Assertion
  • INVALID_CONSTANT : Assertion
  • INVALID_COUNT : Assertion
  • INVALID_COUNTABLE : Assertion
  • INVALID_CREDENTIALS : Authentication
  • INVALID_DATE : Assertion
  • INVALID_DIGIT : Assertion
  • INVALID_DIRECTORY : Assertion
  • INVALID_E164 : Assertion
  • INVALID_EMAIL : Assertion
  • INVALID_EQ : Assertion
  • INVALID_EXIT : Status
  • INVALID_EXTENSION : Assertion
  • INVALID_FALSE : Assertion
  • INVALID_FILE : Assertion
  • INVALID_FILE_NOT_EXISTS : Assertion
  • INVALID_FLOAT : Assertion
  • INVALID_GREATER : Assertion
  • INVALID_GREATER_OR_EQUAL : Assertion
  • INVALID_INSTANCE_OF : Assertion
  • INVALID_INTEGER : Assertion
  • INVALID_INTEGERISH : Assertion
  • INVALID_INTERFACE : Assertion
  • INVALID_IP : Assertion
  • INVALID_JSON_STRING : Assertion
  • INVALID_KEY_EXISTS : Assertion
  • INVALID_KEY_ISSET : Assertion
  • INVALID_KEY_NOT_EXISTS : Assertion
  • INVALID_LENGTH : Assertion
  • INVALID_LESS : Assertion
  • INVALID_LESS_OR_EQUAL : Assertion
  • INVALID_MAX : Assertion
  • INVALID_MAX_COUNT : Assertion
  • INVALID_MAX_LENGTH : Assertion
  • INVALID_METHOD : Assertion
  • INVALID_MIN : Assertion
  • INVALID_MIN_COUNT : Assertion
  • INVALID_MIN_LENGTH : Assertion
  • INVALID_NOT_BLANK : Assertion
  • INVALID_NOT_EQ : Assertion
  • INVALID_NOT_INSTANCE_OF : Assertion
  • INVALID_NOT_REGEX : Assertion
  • INVALID_NOT_SAME : Assertion
  • INVALID_NUMERIC : Assertion
  • INVALID_OBJECT : Assertion
  • INVALID_PROPERTY : Assertion
  • INVALID_RANGE : Assertion
  • INVALID_READABLE : Assertion
  • INVALID_REGEX : Assertion
  • INVALID_RESOURCE : Assertion
  • INVALID_SAME : Assertion
  • INVALID_SATISFY : Assertion
  • INVALID_SCALAR : Assertion
  • INVALID_STRING : Assertion
  • INVALID_STRING_CONTAINS : Assertion
  • INVALID_STRING_END : Assertion
  • INVALID_STRING_NOT_CONTAINS : Assertion
  • INVALID_STRING_START : Assertion
  • INVALID_SUBCLASS_OF : Assertion
  • INVALID_TRAVERSABLE : Assertion
  • INVALID_TRUE : Assertion
  • INVALID_UNIQUE_VALUES : Assertion
  • INVALID_URL : Assertion
  • INVALID_UUID : Assertion
  • INVALID_VALUE_IN_ARRAY : Assertion
  • INVALID_VERSION : Assertion
  • INVALID_WRITEABLE : Assertion
  • invalidUcs : AbstractPunycode
  • IPAD : WebClient
  • IPHONE : WebClient
  • IPOD : WebClient
  • IS_ARRAY : InputArgument
  • IS_CONSTRUCTED : Identifier
  • IS_INVISIBLE : libsodium , MontgomeryPrivate , MontgomeryPublic
  • IS_REPEATABLE : Attribute
  • ISSUED_AT : RegisteredClaims
  • ISSUER : RegisteredClaims
  • ITALIAN_LANGUAGE_CODE : ASCII
  • ITEM : OnGetApiFields


Joomla CMS: Champs de donnée - Variables

- j -

  • JAPANESE_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- k -

  • KARATSUBA_CUTOFF : PHP
  • KAZAKH_LANGUAGE_CODE : ASCII
  • KEY_BYTE_SIZE : Crypto , Core , Key
  • KEY_CURRENT_VERSION : Key
  • KEY_OPS : Key
  • KEY_PROTECTION_HARDWARE : MetadataStatement
  • KEY_PROTECTION_REMOTE_HANDLE : MetadataStatement
  • KEY_PROTECTION_SECURE_ELEMENT : MetadataStatement
  • KEY_PROTECTION_SOFTWARE : MetadataStatement
  • KEY_PROTECTION_TEE : MetadataStatement
  • KEYBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • KEYPAIR_BYTES : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • KHTML : WebClient
  • KID : Key
  • KIRGHIZ_LANGUAGE_CODE : ASCII
  • KNOCKOUT : Status
  • KOREAN_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- l -

  • L : ParagonIE_Sodium_Core_Curve25519_H
  • LANGS : StemmerFactory
  • LARGE_OBJECT : ParameterType
  • LAST : FetchOrientation
  • LATVIAN_LANGUAGE_CODE : ASCII
  • lBase : NamePrep
  • lCount : NamePrep
  • LDAP_ALREADY_EXISTS : Connection
  • LDAP_INVALID_CREDENTIALS : Connection
  • LDAP_TIMEOUT : Connection
  • LE : POP3 , SMTP
  • LEGACY_AUTHENTICATION_INFO_STRING : Core
  • LEGACY_BLOCK_BYTE_SIZE : Core
  • LEGACY_CIPHER_METHOD : Core
  • LEGACY_ENCRYPTION_INFO_STRING : Core
  • LEGACY_HASH_FUNCTION_NAME : Core
  • LEGACY_KEY_BYTE_SIZE : Core
  • LEGACY_MAC_BYTE_SIZE : Core
  • LF : AbstractSerializer
  • LIBRARY_MAJOR_VERSION : ParagonIE_Sodium_Compat
  • LIBRARY_MINOR_VERSION : ParagonIE_Sodium_Compat
  • LIBRARY_VERSION_MAJOR : ParagonIE_Sodium_Compat
  • LIBRARY_VERSION_MINOR : ParagonIE_Sodium_Compat
  • LINUX : WebClient
  • LIST : OnGetApiFields
  • LITHUANIAN_LANGUAGE_CODE : ASCII
  • LOCALE_TO_TRANSLITERATOR_ID : AsciiSlugger
  • LOCALITY_NAME : OID
  • LOG_COMPLEX : SSH2
  • LOG_DEBUG : ZIPExtraction
  • LOG_ERROR : ZIPExtraction
  • LOG_INFO : ZIPExtraction
  • LOG_MAX_SIZE : SSH2
  • LOG_REALTIME : SSH2
  • LOG_REALTIME_FILE : SSH2
  • LOG_SIMPLE : SSH2
  • LOG_TEXT : Scheduler
  • LOG_WARNING : ZIPExtraction
  • LONG_FORM : Identifier
  • LOW : Priority


Joomla CMS: Champs de donnée - Variables

- m -

  • MAC : WebClient
  • MAC_BYTE_SIZE : Crypto , Core
  • MACEDONIAN_LANGUAGE_CODE : ASCII
  • MAGIC_METHODS : DebugClassLoader
  • MAIL_GROUP : GetConfigurationCommand
  • MAIL_MAX_LINE_LENGTH : PHPMailer
  • MAJOR_TYPE : ByteStringObject , ByteStringWithChunkObject , InfiniteListObject , InfiniteMapObject , ListObject , MapObject , OtherObject , SignedIntegerObject , TagObject , TextStringObject , TextStringWithChunkObject , UnsignedIntegerObject
  • MAJOR_VERSION : Version
  • MAP : AccessDescription , AdministrationDomainName , AlgorithmIdentifier , AnotherName , Attribute , Attributes , AttributeType , AttributeTypeAndValue , AttributeValue , AuthorityInfoAccessSyntax , AuthorityKeyIdentifier , BaseDistance , BasicConstraints , BuiltInDomainDefinedAttribute , BuiltInDomainDefinedAttributes , BuiltInStandardAttributes , Certificate , CertificateIssuer , CertificateList , CertificatePolicies , CertificateSerialNumber , CertificationRequest , CertificationRequestInfo , CertPolicyId , Characteristic_two , CountryName , CPSuri , CRLDistributionPoints , CRLNumber , CRLReason , Curve , DHParameter , DigestInfo , DirectoryString , DisplayText , DistributionPoint , DistributionPointName , DSAParams , DSAPrivateKey , DSAPublicKey , DssSigValue , EcdsaSigValue , ECParameters , ECPoint , ECPrivateKey , EDIPartyName , EncryptedData , EncryptedPrivateKeyInfo , Extension , ExtensionAttribute , ExtensionAttributes , Extensions , ExtKeyUsageSyntax , FieldElement , FieldID , GeneralName , GeneralNames , GeneralSubtree , GeneralSubtrees , HashAlgorithm , HoldInstructionCode , InvalidityDate , IssuerAltName , IssuingDistributionPoint , KeyIdentifier , KeyPurposeId , KeyUsage , MaskGenAlgorithm , Name , NameConstraints , netscape_ca_policy_url , netscape_cert_type , netscape_comment , NetworkAddress , NoticeReference , NumericUserIdentifier , OneAsymmetricKey , ORAddress , OrganizationalUnitNames , OrganizationName , OtherPrimeInfo , OtherPrimeInfos , PBEParameter , PBES2params , PBKDF2params , PBMAC1params , Pentanomial , PersonalName , PKCS9String , PolicyInformation , PolicyMappings , PolicyQualifierId , PolicyQualifierInfo , PostalAddress , Prime_p , PrivateDomainName , PrivateKey , PrivateKeyInfo , PrivateKeyUsagePeriod , PublicKey , PublicKeyAndChallenge , PublicKeyInfo , RC2CBCParameter , RDNSequence , ReasonFlags , RelativeDistinguishedName , RevokedCertificate , RSAPrivateKey , RSAPublicKey , RSASSA_PSS_params , SignedPublicKeyAndChallenge , SpecifiedECDomain , SubjectAltName , SubjectDirectoryAttributes , SubjectInfoAccessSyntax , SubjectPublicKeyInfo , TBSCertificate , TBSCertList , TerminalIdentifier , Time , Trinomial , UniqueIdentifier , UserNotice , Validity
  • MAPPINGS : CronExpression
  • MASK_CONNECTED : SSH2
  • MASK_CONSTRUCTOR : SSH2
  • MASK_LOGIN : SSH2
  • MASK_LOGIN_REQ : SSH2
  • MASK_SHELL : SSH2
  • MASK_WINDOW_ADJUST : SSH2
  • MATCHED_DN : ConnectionOptions
  • MATCHER_PROTECTION_ON_CHIP : MetadataStatement
  • MATCHER_PROTECTION_SOFTWARE : MetadataStatement
  • MATCHER_PROTECTION_TEE : MetadataStatement
  • MAX : Priority
  • MAX10 : PHP32 , PHP64
  • MAX10LEN : PHP32 , PHP64
  • MAX_DIGIT : PHP32 , PHP64
  • MAX_DIGIT2 : PHP32 , PHP64
  • MAX_EXEC_TIME : ZIPExtraction
  • MAX_LINE_LENGTH : PHPMailer , SMTP , SymfonyStyle
  • MAX_POWER : Calculator
  • MAX_REPLY_LENGTH : SMTP
  • MAX_STATUS_CODE_VALUE : Response
  • maxUcs : AbstractPunycode
  • MB_CASE_FOLD : Mbstring
  • MD5_WITH_RSA_ENCRYPTION : OID
  • MEDIA_TYPE : Document
  • META_CONTEXT : Indexer
  • METHODS : Zip
  • MIN : Priority
  • MIN_EXEC_TIME : ZIPExtraction
  • MIN_STATUS_CODE_VALUE : Response
  • MINIMUM_CIPHERTEXT_SIZE : Core
  • MINOR_VERSION : Version
  • MINUTE : CronExpression
  • MISC_CONTEXT : Indexer
  • MIXED : FetchMode
  • MODE_3CBC : TripleDES
  • MODE_ALLOW_ALWAYS : PlgSystemStats
  • MODE_ALLOW_NEVER : PlgSystemStats
  • MODE_ANY : PKCS
  • MODE_CBC : SymmetricKey
  • MODE_CBC3 : TripleDES
  • MODE_CFB : SymmetricKey
  • MODE_CFB8 : SymmetricKey
  • MODE_CTR : SymmetricKey
  • MODE_DER : PKCS
  • MODE_ECB : SymmetricKey
  • MODE_GCM : SymmetricKey
  • MODE_INSTANCE : UserGroupsHelper
  • MODE_MAP : SymmetricKey
  • MODE_OFB : SymmetricKey
  • MODE_OFB8 : SymmetricKey
  • MODE_PEM : PKCS
  • MODE_SINGLETON : UserGroupsHelper
  • MODE_STREAM : SymmetricKey
  • MODES : RedisCaster
  • MONGOLIAN_LANGUAGE_CODE : ASCII
  • MONTH : CronExpression
  • MONTH_ABBR : Date
  • MONTH_NAME : Date
  • MSB : PHP32 , PHP64
  • MSG_ALERT : CMSApplicationInterface
  • MSG_CRITICAL : CMSApplicationInterface
  • MSG_DEBUG : CMSApplicationInterface
  • MSG_EMERGENCY : CMSApplicationInterface
  • MSG_ERROR : CMSApplicationInterface
  • MSG_INFO : CMSApplicationInterface
  • MSG_NOTICE : CMSApplicationInterface
  • MSG_WARNING : CMSApplicationInterface
  • MYANMAR_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- n -

  • n : CliDumper
  • NAME : CompactSerializer , JSONFlattenedSerializer , JSONGeneralSerializer
  • NAMED_CURVE_OID : Ec2Key
  • NAMESPACE_DNS : Uuid
  • NAMESPACE_OID : Uuid
  • NAMESPACE_URL : Uuid
  • NAMESPACE_X500 : Uuid
  • nCount : NamePrep
  • NET_SSH2_COMPRESSION_NONE : SSH2
  • NET_SSH2_COMPRESSION_ZLIB : SSH2
  • NET_SSH2_COMPRESSION_ZLIB_AT_OPENSSH : SSH2
  • NETWORK_TIMEOUT : ConnectionOptions
  • NEXT : FetchOrientation
  • NFC : Normalizer , AbstractUnicodeString , Normalizer
  • NFD : Normalizer , AbstractUnicodeString , Normalizer
  • NFKC : Normalizer , AbstractUnicodeString , Normalizer
  • NFKD : Normalizer , AbstractUnicodeString , Normalizer
  • NIL : Uuid
  • NO_CREDENTIALS : Authentication
  • NO_EXIT : Status
  • NO_LOCK : Status
  • NO_PROTECT : ContainerResource
  • NO_RELEASE : Status
  • NO_ROUTINE : Status
  • NO_RUN : Status
  • NO_SHARE : ContainerResource
  • NO_SUCH_USER : Authentication
  • NO_TASK : Status
  • NODE_TYPES : DOMCaster , XmlReaderCaster
  • NONE : Normalizer
  • NORMAL : Priority
  • NORWEGIAN_BOKMAL : Language
  • NORWEGIAN_LANGUAGE_CODE : ASCII
  • NOT_BEFORE : RegisteredClaims
  • NOT_FIDO_CERTIFIED : AuthenticatorStatus
  • NOTICE : Log , LogLevel
  • NULL : Identifier , ParameterType
  • NUMERIC : FetchMode
  • NUMERIC_STRING : Identifier


Joomla CMS: Champs de donnée - Variables

- o -

  • OBJECT_DESCRIPTOR : Identifier
  • OBJECT_IDENTIFIER : Identifier
  • OCTETSTRING : Identifier
  • OID_NAME : PKCS8 , PSS
  • OID_VALUE : PKCS8 , PSS
  • OK : Status
  • onetimeauth_poly1305_BYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • onetimeauth_poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • ONLY_ALLOW_DEFINED_ATTRIBUTES : InputFilter
  • ONLY_ALLOW_DEFINED_TAGS : InputFilter
  • ONLY_BLOCK_DEFINED_ATTRIBUTES : InputFilter
  • ONLY_BLOCK_DEFINED_TAGS : InputFilter
  • OPERA : WebClient
  • OPTIONAL : InputArgument
  • OPTIONS_RANGE : CronField
  • ORGANIZATION_NAME : OID
  • ORIENTATION_LANDSCAPE : Image
  • ORIENTATION_PORTRAIT : Image
  • ORIENTATION_SQUARE : Image
  • ORIYA_LANGUAGE_CODE : ASCII
  • OU_NAME : OID
  • OUTBYTES : ParagonIE_Sodium_Core32_BLAKE2b , ParagonIE_Sodium_Core_BLAKE2b
  • OUTPUT_NORMAL : OutputInterface
  • OUTPUT_PLAIN : OutputInterface
  • OUTPUT_RAW : OutputInterface


Joomla CMS: Champs de donnée - Variables

- p -

  • PADDING_KECCAK : Hash
  • PADDING_SHA3 : Hash
  • PADDING_SHAKE : Hash
  • PAGINATION_OID : Query
  • PARAM_CODES : PgSqlCaster
  • PARAMETER_TYPE_MAP : PdoStatement
  • PARSE_CONSTANT : Yaml
  • PARSE_CUSTOM_TAGS : Yaml
  • PARSE_DATETIME : Yaml
  • PARSE_EXCEPTION_ON_INVALID_TYPE : Yaml
  • PARSE_OBJECT : Yaml
  • PARSE_OBJECT_FOR_MAP : Yaml
  • PARSE_REGEXP : BigNumber
  • PASHTO_LANGUAGE_CODE : ASCII
  • PASS : UriInterface
  • PASSWORD_KEY_CURRENT_VERSION : KeyProtectedByPassword
  • PATCH_VERSION : Version
  • PATH : UriInterface
  • PATH_CONTEXT : Indexer
  • PATH_PREFIX : LocalFileReference
  • PBKDF2_ITERATIONS : KeyOrPassword
  • PDO_ATTRIBUTES : PdoCaster
  • PERIOD_LIMIT : DateCaster
  • PERSIAN_LANGUAGE_CODE : ASCII
  • PGSQL_COMMAND_OK : PgSqlCaster
  • PGSQL_TRANSACTION_ACTIVE : PgSqlCaster
  • PHP_SECURITY_ONLY : PlgQuickiconPhpVersionCheck
  • PHP_SUPPORTED : PlgQuickiconPhpVersionCheck
  • PHP_UNSUPPORTED : PlgQuickiconPhpVersionCheck
  • PHRASES : Response
  • PKCS9_CONTENT_TYPE : OID
  • PKCS9_EMAIL : OID
  • PKCS9_EXTENSION_REQUEST : OID
  • PKCS9_MESSAGE_DIGEST : OID
  • PKCS9_SIGNING_TIME : OID
  • PKCS9_UNSTRUCTURED_NAME : OID
  • PLURAL_MAP : EnglishInflector
  • PLURALIZE_REGEXP : FrenchInflector
  • POLISH_LANGUAGE_CODE : ASCII
  • PORT : UriInterface
  • PORTUGUESE : Language
  • PORTUGUESE_LANGUAGE_CODE : ASCII
  • POST_CONNECT : DatabaseEvents
  • POST_DISCONNECT : DatabaseEvents
  • POSTAL_ADDRESS : OID
  • POSTAL_CODE : OID
  • PREFIX_DYNAMIC : Caster
  • PREFIX_PROTECTED : Caster
  • PREFIX_VIRTUAL : Caster
  • PREG_OFFSET_CAPTURE : AbstractString
  • PREG_PATTERN_ORDER : AbstractString
  • PREG_SET_ORDER : AbstractString
  • PREG_SPLIT : AbstractString
  • PREG_SPLIT_DELIM_CAPTURE : AbstractString
  • PREG_SPLIT_NO_EMPTY : AbstractString
  • PREG_SPLIT_OFFSET_CAPTURE : AbstractString
  • PREG_UNMATCHED_AS_NULL : AbstractString
  • PREPARED_RESPONSE_LABELS : CronField
  • PRESTO : WebClient
  • PRIMES : Engine
  • PRINTABLE_STRING : Identifier
  • PRIOR : FetchOrientation
  • PRIVATEKEYBLOB : MSBLOB
  • PROCESS_AFTER : Router
  • PROCESS_BEFORE : Router
  • PROCESS_DURING : Router
  • PRODUCT : Version
  • PROTECT : ContainerResource
  • PROTOCOL_VERSION : ConnectionOptions
  • PUBLIC_HANDLER : PuTTY
  • PUBLICKEYBLOB : MSBLOB
  • PUBLICKEYBLOBEX : MSBLOB
  • punycodePrefix : AbstractPunycode


Joomla CMS: Champs de donnée - Variables

- q -

  • QUERY : UriInterface


Joomla CMS: Champs de donnée - Variables

- r -

  • r : GithubActionReporter
  • READ_NEXT : SSH2
  • READ_REGEX : SSH2
  • READ_SIMPLE : SSH2
  • READ_WRITE_HASH : Stream
  • REAL : Identifier
  • REASON_MAIL_FUNCTION_NOT_AVAILABLE : MailDisabledException
  • REASON_USER_DISABLED : MailDisabledException
  • REFERENCE_PATTERN : Parser
  • REFERRALS : ConnectionOptions
  • REGEX_CHARACTER_TO_ESCAPE : Escaper
  • REGEX_ESCAPED_CHARACTER : Unescaper
  • REGEX_QUOTED_STRING : StringInput , Inline
  • REGEX_STRING : StringInput
  • REGEX_UNQUOTED_STRING : StringInput
  • REL : FetchOrientation
  • REL_ABOUT : Relations
  • REL_ALTERNATE : Relations , Link
  • REL_AMPHTML : Relations
  • REL_APPENDIX : Relations
  • REL_APPLE_TOUCH_ICON : Relations
  • REL_APPLE_TOUCH_STARTUP_IMAGE : Relations
  • REL_ARCHIVES : Relations
  • REL_AUTHOR : Relations , Link
  • REL_BLOCKED_BY : Relations
  • REL_BOOKMARK : Relations
  • REL_CANONICAL : Relations
  • REL_CHAPTER : Relations
  • REL_CITE_AS : Relations
  • REL_COLLECTION : Relations
  • REL_CONTENTS : Relations
  • REL_CONVERTEDFROM : Relations
  • REL_COPYRIGHT : Relations
  • REL_CREATE_FORM : Relations
  • REL_CURRENT : Relations
  • REL_DESCRIBEDBY : Relations
  • REL_DESCRIBES : Relations
  • REL_DISCLOSURE : Relations
  • REL_DNS_PREFETCH : Relations , Link
  • REL_DUPLICATE : Relations
  • REL_EDIT : Relations
  • REL_EDIT_FORM : Relations
  • REL_EDIT_MEDIA : Relations
  • REL_ENCLOSURE : Relations
  • REL_EXTERNAL : Relations
  • REL_FIRST : Relations
  • REL_GLOSSARY : Relations
  • REL_HELP : Relations , Link
  • REL_HOSTS : Relations
  • REL_HUB : Relations
  • REL_ICON : Relations , Link
  • REL_INDEX : Relations
  • REL_INTERVALAFTER : Relations
  • REL_INTERVALBEFORE : Relations
  • REL_INTERVALCONTAINS : Relations
  • REL_INTERVALDISJOINT : Relations
  • REL_INTERVALDURING : Relations
  • REL_INTERVALEQUALS : Relations
  • REL_INTERVALFINISHEDBY : Relations
  • REL_INTERVALFINISHES : Relations
  • REL_INTERVALIN : Relations
  • REL_INTERVALMEETS : Relations
  • REL_INTERVALMETBY : Relations
  • REL_INTERVALOVERLAPPEDBY : Relations
  • REL_INTERVALOVERLAPS : Relations
  • REL_INTERVALSTARTEDBY : Relations
  • REL_INTERVALSTARTS : Relations
  • REL_ITEM : Relations
  • REL_LAST : Relations
  • REL_LATEST_VERSION : Relations
  • REL_LICENSE : Relations , Link
  • REL_LRDD : Relations
  • REL_MANIFEST : Relations
  • REL_MASK_ICON : Relations
  • REL_MEDIA_FEED : Relations
  • REL_MEMENTO : Relations
  • REL_MERCURE : Link
  • REL_MICROPUB : Relations
  • REL_MODULEPRELOAD : Relations
  • REL_MONITOR : Relations
  • REL_MONITOR_GROUP : Relations
  • REL_NEXT : Relations , Link
  • REL_NEXT_ARCHIVE : Relations
  • REL_NOFOLLOW : Relations
  • REL_NOOPENER : Relations
  • REL_NOREFERRER : Relations
  • REL_OPENER : Relations
  • REL_OPENID2_LOCAL_ID : Relations
  • REL_OPENID2_PROVIDER : Relations
  • REL_ORIGINAL : Relations
  • REL_P3PV1 : Relations
  • REL_PAYMENT : Relations
  • REL_PINGBACK : Relations
  • REL_PRECONNECT : Relations , Link
  • REL_PREDECESSOR_VERSION : Relations
  • REL_PREFETCH : Relations , Link
  • REL_PRELOAD : Relations , Link
  • REL_PRERENDER : Relations , Link
  • REL_PREV : Relations , Link
  • REL_PREV_ARCHIVE : Relations
  • REL_PREVIEW : Relations
  • REL_PREVIOUS : Relations
  • REL_PRIVACY_POLICY : Relations
  • REL_PROFILE : Relations
  • REL_PUBLICATION : Relations
  • REL_RELATED : Relations
  • REL_REPLIES : Relations
  • REL_RESTCONF : Relations
  • REL_RULEINPUT : Relations
  • REL_SEARCH : Relations , Link
  • REL_SECTION : Relations
  • REL_SELF : Relations
  • REL_SERVICE : Relations
  • REL_SERVICE_DESC : Relations
  • REL_SERVICE_DOC : Relations
  • REL_SERVICE_META : Relations
  • REL_SPONSORED : Relations
  • REL_START : Relations
  • REL_STATUS : Relations
  • REL_STYLESHEET : Relations , Link
  • REL_SUBSECTION : Relations
  • REL_SUCCESSOR_VERSION : Relations
  • REL_SUNSET : Relations
  • REL_TAG : Relations
  • REL_TERMS_OF_SERVICE : Relations
  • REL_TIMEGATE : Relations
  • REL_TIMEMAP : Relations
  • REL_TYPE : Relations
  • REL_UGC : Relations
  • REL_UP : Relations
  • REL_VERSION_HISTORY : Relations
  • REL_VIA : Relations
  • REL_WEBMENTION : Relations
  • REL_WORKING_COPY : Relations
  • REL_WORKING_COPY_OF : Relations
  • RELATIVE_OID : Identifier
  • RELATIVE_PATH : JavascriptRenderer
  • RELATIVE_URL : JavascriptRenderer
  • RELDATE : Version
  • RELTIME : Version
  • RELTZ : Version
  • REMOTE_URL : PlgInstallerWebinstaller
  • REMOVE_ABORT : ExtensionRemoveCommand
  • REMOVE_FAILED : ExtensionRemoveCommand
  • REMOVE_INVALID_RESPONSE : ExtensionRemoveCommand
  • REMOVE_INVALID_TYPE : ExtensionRemoveCommand
  • REMOVE_LOCKED : ExtensionRemoveCommand
  • REMOVE_NOT_FOUND : ExtensionRemoveCommand
  • REMOVE_SUCCESSFUL : ExtensionRemoveCommand
  • REPLACEABLE_TAG : JavascriptRenderer
  • REQUEST_GETTERS : SymfonyCaster
  • REQUIRED : InputArgument
  • RESERVED_FUTURE : Uuid
  • RESERVED_MICROSOFT : Uuid
  • RESERVED_NCS : Uuid
  • RESOLVE_ALIAS : PharInvocationResolver
  • RESOLVE_REALPATH : PharInvocationResolver
  • RESTART : SessionEvents , ConnectionOptions
  • RESULT_STATUS : PgSqlCaster
  • RESUME : SFTP
  • RESUME_START : SFTP
  • RETURN_CODE_DISABLED : BeforeCommandExecuteEvent , ConsoleCommandEvent
  • RETURN_TYPES : TentativeTypes
  • REVOKED : AuthenticatorStatus
  • RFC_4122 : Uuid
  • ROMANIAN_LANGUAGE_CODE : ASCII
  • ROUNDS : ParagonIE_Sodium_Core32_Salsa20 , ParagonIE_Sodium_Core_Salsa20
  • RSA1 : MSBLOB
  • RSA2 : MSBLOB
  • RSA_ENCRYPTION : OID
  • RULE_TYPE_FIELD : ExecutionRulesRule
  • RUNNING : Status
  • RUNTIME_BIAS : ZIPExtraction
  • RUSSIAN_GOST_2000_B_LANGUAGE_CODE : ASCII
  • RUSSIAN_LANGUAGE_CODE : ASCII
  • RUSSIAN_PASSPORT_2013_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- s -

  • SAFARI : WebClient
  • SALT_BYTE_SIZE : Core
  • sBase : NamePrep
  • SCALAR_BYTES : ParagonIE_Sodium_Core_Ed25519
  • SCALE_FILL : Image
  • SCALE_FIT : Image
  • SCALE_INSIDE : Image
  • SCALE_OUTSIDE : Image
  • SCHEME : UriInterface
  • SCHEMES : Uri
  • SCOPE_BASE : QueryInterface
  • SCOPE_ONE : QueryInterface
  • SCOPE_SUB : QueryInterface
  • sCount : NamePrep
  • SECRET_KEY_LENGTH : Email
  • SECRET_TYPE_KEY : KeyOrPassword
  • SECRET_TYPE_PASSWORD : KeyOrPassword
  • secretbox_xchacha20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xchacha20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_BOXZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_MACBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_NONCEBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • secretbox_xsalsa20poly1305_ZEROBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • SEED_BYTES : ParagonIE_Sodium_Core32_Ed25519 , ParagonIE_Sodium_Core_Ed25519
  • SELF_ASSERTION_SUBMITTED : AuthenticatorStatus
  • SEPARATOR_BOTTOM : Table
  • SEPARATOR_MID : Table
  • SEPARATOR_TOP : Table
  • SEPARATOR_TOP_BOTTOM : Table
  • SEQUENCE : Identifier
  • SERBIAN_CYRILLIC_LANGUAGE_CODE : ASCII
  • SERBIAN_LANGUAGE_CODE : ASCII
  • SERBIAN_LATIN_LANGUAGE_CODE : ASCII
  • SERIAL_NUMBER : OID
  • SERIALIZE_HEADER_BYTES : Encoding
  • SERIALIZERS : RedisCaster
  • SERVER_CONTROLS : ConnectionOptions
  • SERVICE_MANAGER_KEYS_OF_INTEREST : ConfigPostProcessor
  • SESSION_GROUP : GetConfigurationCommand
  • SET : Identifier
  • SHA1_WITH_RSA_SIGNATURE : OID
  • SHA256_WITH_RSA_SIGNATURE : OID
  • SHARE : ContainerResource
  • SIGN : PHP
  • SIGNAL : ConsoleEvents
  • SIGNATURE_PKCS1 : RSA
  • SIGNATURE_PSS : RSA
  • SIGNATURE_RELAXED_PKCS1 : RSA
  • SINGULAR_MAP : EnglishInflector
  • SINGULARIZE_REGEXP : FrenchInflector
  • SITE_DOWN_FAILED : SiteDownCommand
  • SITE_DOWN_SUCCESSFUL : SiteDownCommand
  • SITE_UP_FAILED : SiteUpCommand
  • SITE_UP_SUCCESSFUL : SiteUpCommand
  • SITE_VERIFY_URL : HttpBridgePostRequestMethod , ReCaptcha
  • SIZE : Ed25519 , Ed448
  • SIZELIMIT : ConnectionOptions
  • skew : AbstractPunycode
  • sLast : NamePrep
  • SLOVAK_LANGUAGE_CODE : ASCII
  • SOURCE_CALLBACK : SFTP
  • SOURCE_LOCAL_FILE : SFTP
  • SOURCE_STRING : SFTP
  • SPANISH : Language
  • SPECIAL_RETURN_TYPES : DebugClassLoader
  • SPL_FILE_OBJECT_FLAGS : SplCaster
  • SPLIT : Patcher
  • SRC_FILE : Patcher
  • SSH_AGENT_FAILURE : Agent
  • SSH_AGENT_IDENTITIES_ANSWER : Agent
  • SSH_AGENT_RSA2_256 : Identity
  • SSH_AGENT_RSA2_512 : Identity
  • SSH_AGENT_SIGN_RESPONSE : Agent
  • SSH_AGENTC_REQUEST_IDENTITIES : Agent
  • SSH_AGENTC_SIGN_REQUEST : Agent
  • STABILITY_ALPHA : Updater
  • STABILITY_BETA : Updater
  • STABILITY_DEV : Updater
  • STABILITY_RC : Updater
  • STABILITY_STABLE : Updater
  • STANDARD_OBJECT : FetchMode
  • START : SessionEvents
  • STATE_DISABLED : Task
  • STATE_ENABLED : Task
  • STATE_MAP : Task
  • STATE_OR_PROVINCE_NAME : OID
  • STATE_TRASHED : Task
  • STATUS_CANCEL : Authentication
  • STATUS_DENIED : Authentication
  • STATUS_EXPIRED : Authentication
  • STATUS_FAILURE : Authentication
  • STATUS_SUCCESS : Authentication
  • STATUS_UNKNOWN : Authentication
  • STD_LINE_LENGTH : PHPMailer
  • STOP_CONTINUE : PHPMailer
  • STOP_CRITICAL : PHPMailer
  • STOP_MESSAGE : PHPMailer
  • STREAM_OPEN_FOR_INCLUDE : PharStreamWrapper
  • stream_salsa20_KEYBYTES : ParagonIE_Sodium_Crypto32 , ParagonIE_Sodium_Crypto
  • STREET_ADDRESS : OID
  • STRING : ParameterType
  • STRING_BINARY : Stub
  • STRING_TYPE_SIZE : ASN1
  • STRING_UTF8 : Stub
  • SUBJECT : RegisteredClaims
  • SUBTYPES : CronField , IntervalField
  • SUCCESS : Authentication , Command
  • SUPPORTED_CURVES : Ec2Key , OkpKey
  • SURNAME : OID
  • SWEDISH_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- t -

  • T61_STRING : Identifier
  • TAG_OPTIONS : TableCellStyle
  • TAG_PATTERN : Parser
  • TagServiceTrait : LegacyComponent , BannersComponent , ContactComponent , ContentComponent , NewsfeedsComponent
  • TARGET_ALL : Attribute
  • TARGET_CLASS : Attribute
  • TARGET_CLASS_CONSTANT : Attribute
  • TARGET_FUNCTION : Attribute
  • TARGET_METHOD : Attribute
  • TARGET_PARAMETER : Attribute
  • TARGET_PROPERTY : Attribute
  • TASK_NOTIFICATION_FORM : PlgSystemTasknotification
  • TASK_QUEUE_FILTERS : Scheduler
  • TASK_QUEUE_LIST_CONFIG : Scheduler
  • TASK_STATES : TaskModel
  • TASK_TABLE : TaskModel
  • TASKS_MAP : Checkfiles , DemoTasks , Requests , SiteStatus
  • tBase : NamePrep
  • tCount : NamePrep
  • TERMINATE : ConsoleEvents
  • TEXT_CONTEXT : Indexer
  • THAI_LANGUAGE_CODE : ASCII
  • TIMELIMIT : ConnectionOptions
  • TIMEOUT : Status , ConnectionOptions
  • TIMESTAMP_BYTES : CombGenerator
  • TITLE : OID
  • TITLE_CONTEXT : Indexer
  • TLS_DISABLE : Route
  • TLS_FORCE : Route
  • TLS_IGNORE : Route
  • tMax : AbstractPunycode
  • tMin : AbstractPunycode
  • TOKEN_BINDING_STATUS_NOT_SUPPORTED : TokenBinding
  • TOKEN_BINDING_STATUS_PRESENT : TokenBinding
  • TOKEN_BINDING_STATUS_SUPPORTED : TokenBinding
  • TRANSACTION_CONFIRMATION_DISPLAY_ANY : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_HARDWARE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_PRIVILEGED_SOFTWARE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_REMOTE : MetadataStatement
  • TRANSACTION_CONFIRMATION_DISPLAY_TEE : MetadataStatement
  • TRANSACTION_STATUS : PgSqlCaster
  • TRANSLIT_FROM : AbstractUnicodeString
  • TRANSLIT_TO : AbstractUnicodeString
  • TRIDENT : WebClient
  • TURKISH : Language
  • TURKISH_LANGUAGE_CODE : ASCII
  • TURKMEN_LANGUAGE_CODE : ASCII
  • TYPE : Key
  • TYPE_ANY : ASN1
  • TYPE_ARGUMENT_VALUE : CompletionInput
  • TYPE_ARRAY : Stub
  • TYPE_ATTCA : AttestationStatement
  • TYPE_BASIC : AttestationStatement
  • TYPE_BIT_STRING : ASN1
  • TYPE_BMP_STRING : ASN1
  • TYPE_BOOLEAN : ASN1
  • TYPE_CHOICE : ASN1
  • TYPE_EC2 : Key
  • TYPE_ECDAA : AttestationStatement
  • TYPE_ENUMERATED : ASN1
  • TYPE_FULL : DownloadSource
  • TYPE_GENERAL_STRING : ASN1
  • TYPE_GENERALIZED_TIME : ASN1
  • TYPE_GRAPHIC_STRING : ASN1
  • TYPE_IA5_STRING : ASN1
  • TYPE_INTEGER : ASN1
  • TYPE_NONE : CompletionInput , AttestationStatement
  • TYPE_NULL : ASN1
  • TYPE_NUMERIC_STRING : ASN1
  • TYPE_OBJECT : Stub
  • TYPE_OBJECT_IDENTIFIER : ASN1
  • TYPE_OCT : Key
  • TYPE_OCTET_STRING : ASN1
  • TYPE_OKP : Key
  • TYPE_OPTION_NAME : CompletionInput
  • TYPE_OPTION_VALUE : CompletionInput
  • TYPE_PATCH : DownloadSource
  • TYPE_PRINTABLE_STRING : ASN1
  • TYPE_REAL : ASN1
  • TYPE_REF : Stub
  • TYPE_RESOURCE : Stub
  • TYPE_RSA : Key
  • TYPE_SELF : AttestationStatement
  • TYPE_SEQUENCE : ASN1
  • TYPE_SET : ASN1
  • TYPE_STRING : Stub
  • TYPE_TELETEX_STRING : ASN1
  • TYPE_UNIVERSAL_STRING : ASN1
  • TYPE_UPGRADE : DownloadSource
  • TYPE_UTC_TIME : ASN1
  • TYPE_UTF8_STRING : ASN1
  • TYPE_VIDEOTEX_STRING : ASN1
  • TYPE_VISIBLE_STRING : ASN1
  • TYPES : Tar


Joomla CMS: Champs de donnée - Variables

- u -

  • UKRAINIAN_LANGUAGE_CODE : ASCII
  • UNINFLECTED : EnglishInflector , FrenchInflector
  • UNIQUE_BASE_NAME : PharInvocationCollection
  • UNIQUE_INVOCATION : PharInvocationCollection
  • UNIVERSAL_STRING : Identifier
  • UNNECESSARY : RoundingMode
  • UNSET_CLOSURE_FILE_INFO : ReflectionCaster
  • UP : RoundingMode
  • UPDATE_AVAILABLE : AuthenticatorStatus
  • UPDATE_SUCCESSFUL : UpdateCoreCommand
  • UPLOAD_ERR_INI_SIZE : UploadedFile
  • UPPER_FROM : AbstractUnicodeString
  • UPPER_TO : AbstractUnicodeString
  • URL : Version
  • USER : UriInterface
  • USER_KEY_PHYSICAL_COMPROMISE : AuthenticatorStatus
  • USER_KEY_REMOTE_COMPROMISE : AuthenticatorStatus
  • USER_VERIFICATION_BYPASS : AuthenticatorStatus
  • USER_VERIFICATION_REQUIREMENT_DISCOURAGED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFICATION_REQUIREMENT_PREFERRED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFICATION_REQUIREMENT_REQUIRED : AuthenticatorSelectionCriteria , PublicKeyCredentialRequestOptions
  • USER_VERIFY_ALL : VerificationMethodDescriptor
  • USER_VERIFY_EYEPRINT : VerificationMethodDescriptor
  • USER_VERIFY_FACEPRINT : VerificationMethodDescriptor
  • USER_VERIFY_FINGERPRINT : VerificationMethodDescriptor
  • USER_VERIFY_HANDPRINT : VerificationMethodDescriptor
  • USER_VERIFY_LOCATION : VerificationMethodDescriptor
  • USER_VERIFY_NONE : VerificationMethodDescriptor
  • USER_VERIFY_PASSCODE : VerificationMethodDescriptor
  • USER_VERIFY_PATTERN : VerificationMethodDescriptor
  • USER_VERIFY_PRESENCE : VerificationMethodDescriptor
  • USER_VERIFY_VOICEPRINT : VerificationMethodDescriptor
  • UTC_TIME : Identifier
  • UTF8_STRING : Identifier
  • UUID_TYPE_HASH_MD5 : Uuid
  • UUID_TYPE_HASH_SHA1 : Uuid
  • UUID_TYPE_IDENTIFIER : Uuid
  • UUID_TYPE_RANDOM : Uuid
  • UUID_TYPE_TIME : Uuid
  • UZBEK_LANGUAGE_CODE : ASCII


Joomla CMS: Champs de donnée - Variables

- v -

  • VALID_OPERATION_TYPES : UpdateOperation
  • VALID_PATTERN : Uuid
  • VALIDATE_SIGNATURE_BY_CA : X509
  • VALIDATION_FUNCTIONS : OptionsResolver
  • VALUE : PHP
  • VALUE_EMPTY : Assertion
  • VALUE_IS_ARRAY : InputOption
  • VALUE_NEGATABLE : InputOption
  • VALUE_NONE : InputOption
  • VALUE_NOT_EMPTY : Assertion
  • VALUE_NOT_NULL : Assertion
  • VALUE_NULL : Assertion
  • VALUE_OPTIONAL : InputOption
  • VALUE_REQUIRED : InputOption
  • VARIABLE : Base , Barrett , Base
  • vBase : NamePrep
  • vCount : NamePrep
  • VERBOSITY_DEBUG : OutputInterface
  • VERBOSITY_NORMAL : OutputInterface
  • VERBOSITY_QUIET : OutputInterface
  • VERBOSITY_VERBOSE : OutputInterface
  • VERBOSITY_VERY_VERBOSE : OutputInterface
  • VERSION : PHPMailer , POP3 , SMTP , ReCaptcha
  • VERSION_STRING : ParagonIE_Sodium_Compat
  • VIDEOTEXT_STRING : Identifier
  • VIETNAMESE_LANGUAGE_CODE : ASCII
  • VISIBLE_STRING : Identifier


Joomla CMS: Champs de donnée - Variables

- w -

  • WARNING : Log , LogLevel
  • WEBCRON_KEY_LENGTH : PlgSystemSchedulerunner
  • WEBKIT : WebClient
  • WEEKDAY : CronExpression
  • WILL_RESUME : Status
  • WINDOWS : WebClient
  • WINDOWS_CE : WebClient
  • WINDOWS_PHONE : WebClient


Joomla CMS: Champs de donnée - Variables

- x -

  • X_KEEPALIVE_IDLE : ConnectionOptions
  • X_KEEPALIVE_INTERVAL : ConnectionOptions
  • X_KEEPALIVE_PROBES : ConnectionOptions
  • X_SASL_AUTHCID : ConnectionOptions
  • X_SASL_AUTHZID : ConnectionOptions
  • X_SASL_MECH : ConnectionOptions
  • X_SASL_REALM : ConnectionOptions
  • X_TLS_CACERTDIR : ConnectionOptions
  • X_TLS_CERTFILE : ConnectionOptions
  • X_TLS_CIPHER_SUITE : ConnectionOptions
  • X_TLS_CRL_ALL : ConnectionOptions
  • X_TLS_CRL_NONE : ConnectionOptions
  • X_TLS_CRL_PEER : ConnectionOptions
  • X_TLS_CRLCHECK : ConnectionOptions
  • X_TLS_CRLFILE : ConnectionOptions
  • X_TLS_DHFILE : ConnectionOptions
  • X_TLS_KEYFILE : ConnectionOptions
  • X_TLS_PACKAGE : ConnectionOptions
  • X_TLS_PROTOCOL_MIN : ConnectionOptions
  • X_TLS_RANDOM_FILE : ConnectionOptions
  • X_TLS_REQUIRE_CERT : ConnectionOptions
  • xD0 : Iconv , Normalizer
  • XML_ATTRIBUTE_NODE : DOMCaster
  • XML_ERROR_NO_MEMORY : XmlResourceCaster
  • XML_ERRORS : XmlResourceCaster


Joomla CMS: Champs de donnée - Variables

- y -

  • YEAR : CronExpression


Joomla CMS: Liste des fichiers

Liste des fichiers
Liste de tous les fichiers avec une brève description :
_item.php
AbstractAES.php
AbstractApplication.php
AbstractCBORObject.php
AbstractCloner.php
AbstractCommand.php
AbstractConnection.php
AbstractDataCollector.php
AbstractDumper.php
src/Event/AbstractEvent.php
src/Event/Table/AbstractEvent.php
src/Event/WebAsset/AbstractEvent.php
src/Event/Workflow/AbstractEvent.php
vendor/joomla/event/src/AbstractEvent.php
AbstractField.php
AbstractGroupButton.php
AbstractIdnaConvert.php
AbstractImmutableEvent.php
AbstractLogger.php
AbstractMediaItemValidationEvent.php
AbstractMenu.php
AbstractModuleDispatcher.php
AbstractNegotiator.php
AbstractPunycode.php
AbstractQuery.php
AbstractRenderer.php
laminas/laminas-diactoros/src/AbstractSerializer.php
tobscure/json-api/src/AbstractSerializer.php
AbstractStatsField.php
fgrosse/phpasn1/lib/ASN1/AbstractString.php
symfony/string/AbstractString.php
AbstractTime.php
AbstractTransport.php
AbstractUnicodeString.php
AbstractUri.php
AbstractUsernamePasswordAuthenticationStrategy.php
AbstractView.php
AbstractWebApplication.php
Accept.php
AcceptCharset.php
AcceptEncoding.php
AcceptHeader.php
AcceptLanguage.php
AcceptMatch.php
Access/Access.php
HTML/Helpers/Access.php
access.php
AccessDescription.php
AccessException.php
accessibility.php
accessiblemedia.php
AccessiblemediaField.php
AccesslevelField.php
action-button.php
ActionButton.php
ActionlogConfigModel.php
ActionlogModel.php
ActionLogPlugin.php
privacy/actionlogs/actionlogs.php
system/actionlogs/actionlogs.php
ActionlogsController.php
ActionlogsHelper.php
ActionlogsModel.php
ActionsDropdown.php
ActiveSiteTemplate.php
administrator/components/com_finder/src/Indexer/Adapter.php
libraries/src/Adapter/Adapter.php
libraries/vendor/symfony/ldap/Adapter/ExtLdap/Adapter.php
adapter.php
AdapterInstance.php
administrator/components/com_media/src/Adapter/AdapterInterface.php
libraries/vendor/symfony/ldap/Adapter/AdapterInterface.php
AdapterModel.php
AdaptersController.php
AdaptersModel.php
AddConsoleCommandPass.php
AdditionalLoginButtons.php
AddLinkHeaderListener.php
addnosniff.php
AddressValidator.php
addtab.php
AddUserCommand.php
AddUserToGroupCommand.php
admin_modules.php
AdminComponent.php
AdminController.php
AdministrationDomainName.php
AdministratorApplication.php
AdministratorMenu.php
AdministratorMenuItem.php
AdministratorRouter.php
com_categories/src/Service/HTML/AdministratorService.php
com_contact/src/Service/HTML/AdministratorService.php
com_content/src/Service/HTML/AdministratorService.php
com_newsfeeds/src/Service/HTML/AdministratorService.php
AdminLanguage.php
adminlanguage.php
AdminModel.php
advanced.php
AES.php
Aes.php
AesInterface.php
AfterBindEvent.php
AfterCheckinEvent.php
AfterCheckoutEvent.php
AfterDeleteEvent.php
AfterExtensionBootEvent.php
AfterHitEvent.php
AfterLoadEvent.php
AfterMoveEvent.php
AfterPublishEvent.php
AfterReorderEvent.php
AfterResetEvent.php
AfterStoreEvent.php
Agent.php
AggregatedCollector.php
Ajax.php
administrator/components/com_ajax/ajax.php
components/com_ajax/ajax.php
AjaxChallenge.php
com_categories/src/Controller/AjaxController.php
com_contact/src/Controller/AjaxController.php
com_content/src/Controller/AjaxController.php
com_menus/src/Controller/AjaxController.php
com_newsfeeds/src/Controller/AjaxController.php
AjaxCreate.php
AjaxDelete.php
AjaxHandler.php
AjaxHandlerChallenge.php
AjaxHandlerCreate.php
AjaxHandlerDelete.php
AjaxHandlerInitCreate.php
AjaxHandlerLogin.php
AjaxHandlerSaveLabel.php
AjaxInitCreate.php
AjaxLogin.php
AjaxSaveLabel.php
web-auth/cose-lib/src/Algorithm/Algorithm.php
web-token/jwt-core/Algorithm.php
fgrosse/phpasn1/lib/X509/AlgorithmIdentifier.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AlgorithmIdentifier.php
AlgorithmManager.php
AlgorithmManagerFactory.php
Algorithms.php
AliastagField.php
AllowedAttributes.php
AllowedTags.php
AlreadyExistsException.php
AlreadyPunycodeException.php
AmqpCaster.php
libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/AndroidKeyAttestationStatementSupport.php
plugins/multifactorauth/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php
plugins/system/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php
AndroidSafetyNetAttestationStatementSupport.php
AnotherName.php
ANSI.php
ApcuHandler.php
ApcuStorage.php
ApiApplication.php
administrator/components/com_media/src/Controller/ApiController.php
libraries/src/MVC/Controller/ApiController.php
ApiDispatcher.php
ApiModel.php
ApiMVCFactory.php
ApiRouter.php
administrator/includes/app.php
api/includes/app.php
includes/app.php
installation/includes/app.php
installation/src/Service/Provider/Application.php
libraries/src/Service/Provider/Application.php
libraries/vendor/joomla/console/src/Application.php
libraries/vendor/symfony/console/Application.php
administrator/components/com_config/src/Controller/ApplicationController.php
api/components/com_config/src/Controller/ApplicationController.php
joomla/console/src/Descriptor/ApplicationDescription.php
symfony/console/Descriptor/ApplicationDescription.php
application/src/Event/ApplicationErrorEvent.php
console/src/Event/ApplicationErrorEvent.php
ApplicationEvent.php
ApplicationEvents.php
ApplicationHelper.php
ApplicationInterface.php
ApplicationModel.php
ApplicationTester.php
Archive.php
ArchiveModel.php
src/Authentication/Password/Argon2idHandler.php
vendor/joomla/authentication/src/Password/Argon2idHandler.php
src/Authentication/Password/Argon2iHandler.php
vendor/joomla/authentication/src/Password/Argon2iHandler.php
ArgsStub.php
ArgvInput.php
ArrayHelper.php
ArrayInput.php
Request/ArraySerializer.php
Response/ArraySerializer.php
article.php
administrator/components/com_content/src/Controller/ArticleController.php
components/com_content/src/Controller/ArticleController.php
ArticleField.php
administrator/components/com_content/src/Model/ArticleModel.php
components/com_content/src/Model/ArticleModel.php
ArticlesArchiveHelper.php
ArticlesCategoriesHelper.php
ArticlesCategoryHelper.php
administrator/components/com_content/src/Controller/ArticlesController.php
api/components/com_content/src/Controller/ArticlesController.php
ArticlesLatestHelper.php
administrator/components/com_content/src/Model/ArticlesModel.php
components/com_content/src/Model/ArticlesModel.php
ArticlesNewsHelper.php
ArticlesPopularHelper.php
ArticleTable.php
ASCII.php
ascii.php
ascii_by_languages.php
ascii_extras_by_languages.php
ascii_language_max_key.php
ascii_ord.php
AsciiSlugger.php
AsCommand.php
Crypt/DSA/Formats/Signature/ASN1.php
Crypt/EC/Formats/Signature/ASN1.php
File/ASN1.php
ASNObject.php
beberlei/assert/lib/Assert/Assert.php
webmozart/assert/src/Assert.php
Assertable.php
Assertion.php
AssertionChain.php
AssertionFailedException.php
Asset.php
AssetProvider.php
AssocField.php
AssociationController.php
AssociationExtensionHelper.php
AssociationExtensionInterface.php
AssociationField.php
com_contact/src/Helper/AssociationHelper.php
com_content/src/Helper/AssociationHelper.php
com_newsfeeds/src/Helper/AssociationHelper.php
AssociationModel.php
Associations.php
content/associations.php
content/info_block/associations.php
edit/associations.php
AssociationsController.php
AssociationServiceInterface.php
AssociationServiceTrait.php
com_associations/src/Helper/AssociationsHelper.php
com_contact/src/Helper/AssociationsHelper.php
com_content/src/Helper/AssociationsHelper.php
com_menus/src/Helper/AssociationsHelper.php
com_newsfeeds/src/Helper/AssociationsHelper.php
AssociationsModel.php
AsymmetricKey.php
AtomParser.php
AtomRenderer.php
AttestationObject.php
AttestationObjectLoader.php
AttestationStatement.php
AttestationStatementSupport.php
AttestationStatementSupportManager.php
AttestedCredentialData.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attribute.php
symfony/polyfill-php80/Resources/stubs/Attribute.php
AttributeInterface.php
fgrosse/phpasn1/lib/X509/CSR/Attributes.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attributes.php
AttributeType.php
fgrosse/phpasn1/lib/ASN1/Composite/AttributeTypeAndValue.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AttributeTypeAndValue.php
AttributeValue.php
libraries/src/Authentication/Authentication.php
libraries/src/Service/Provider/Authentication.php
libraries/vendor/joomla/authentication/src/Authentication.php
plugins/system/webauthn/src/Authentication.php
AuthenticationExtension.php
AuthenticationExtensionsClientInputs.php
AuthenticationExtensionsClientOutputs.php
AuthenticationExtensionsClientOutputsLoader.php
AuthenticationFailed.php
AuthenticationFailedExceptionHandler.php
AuthenticationHelper.php
AuthenticationResponse.php
AuthenticationStrategyInterface.php
AuthenticatorAssertionResponse.php
AuthenticatorAssertionResponseValidator.php
AuthenticatorAttestationResponse.php
AuthenticatorAttestationResponseValidator.php
AuthenticatorData.php
AuthenticatorResponse.php
AuthenticatorSelectionCriteria.php
AuthenticatorStatus.php
author.php
AuthorField.php
AuthorityInfoAccessSyntax.php
AuthorityKeyIdentifier.php
autoload-fast.php
autoload-pedantic.php
autoload-php7.php
autoload-phpunit.php
autoload.php
google/recaptcha/src/autoload.php
laminas/laminas-zendframework-bridge/src/autoload.php
paragonie/sodium_compat/autoload.php
autoload_classmap.php
autoload_files.php
autoload_namespaces.php
administrator/cache/autoload_psr4.php
libraries/vendor/composer/autoload_psr4.php
autoload_real.php
autoload_static.php
Autoloader.php
Backgroundfill.php
backtrace.php
administrator/components/com_users/tmpl/method/backupcodes.php
components/com_users/tmpl/method/backupcodes.php
administrator/components/com_users/src/Model/BackupcodesModel.php
components/com_users/src/Model/BackupcodesModel.php
bad.php
BadConfigurationException.php
BadDecryptionException.php
BadFormatException.php
BadModeException.php
banner.php
Banner.php
BannerclientField.php
BannerController.php
BannerHelper.php
administrator/components/com_banners/src/Model/BannerModel.php
components/com_banners/src/Model/BannerModel.php
administrator/components/com_banners/helpers/banners.php
plugins/webservices/banners/banners.php
BannersComponent.php
administrator/components/com_banners/src/Controller/BannersController.php
api/components/com_banners/src/Controller/BannersController.php
administrator/components/com_banners/src/Helper/BannersHelper.php
modules/mod_banners/src/Helper/BannersHelper.php
administrator/components/com_banners/src/Model/BannersModel.php
components/com_banners/src/Model/BannersModel.php
BannerTable.php
bar.php
BCMath/Reductions/Barrett.php
PHP/Reductions/Barrett.php
Crypt/EC/BaseCurves/Base.php
Math/BigInteger/Engines/BCMath/Base.php
Math/BigInteger/Engines/PHP/Base.php
base.php
Base128.php
Base16EncodingTag.php
src/Encrypt/Base32.php
vendor/paragonie/constant_time_encoding/src/Base32.php
Base32Hex.php
Base64.php
Base64DotSlash.php
Base64DotSlashOrdered.php
Base64EncodingTag.php
Base64Url.php
Base64UrlEncodingTag.php
Base64UrlSafe.php
BaseAccept.php
BaseApplication.php
BaseController.php
BaseDatabaseModel.php
BaseDistance.php
BaseInstallationModel.php
BaseLayout.php
BaseModel.php
BaseSigner.php
BashCompletionOutput.php
libraries/vendor/lcobucci/jwt/src/Claim/Basic.php
plugins/api-authentication/basic/src/Extension/Basic.php
basic.php
BasicButton.php
BasicConstraints.php
administrator/components/com_redirect/layouts/toolbar/batch.php
layouts/joomla/toolbar/batch.php
bcmath_compat/src/BCMath.php
phpseclib/phpseclib/Math/BigInteger/Engines/BCMath.php
bcmath.php
BcMathCalculator.php
src/Authentication/Password/BCryptHandler.php
vendor/joomla/authentication/src/Password/BCryptHandler.php
BeforeBatchEvent.php
BeforeBindEvent.php
BeforeCheckinEvent.php
BeforeCheckoutEvent.php
BeforeCommandExecuteEvent.php
BeforeDeleteEvent.php
BeforeDisplayMethods.php
BeforeExtensionBootEvent.php
BeforeHitEvent.php
BeforeLoadEvent.php
BeforeMoveEvent.php
BeforePublishEvent.php
BeforeReorderEvent.php
BeforeResetEvent.php
BeforeStoreEvent.php
src/HTML/Helpers/Behavior.php
vendor/typo3/phar-stream-wrapper/src/Behavior.php
behindproxy.php
BigDecimal.php
BigFloatTag.php
brick/math/src/BigInteger.php
fgrosse/phpasn1/lib/Utility/BigInteger.php
phpseclib/phpseclib/phpseclib/Math/BigInteger.php
web-token/jwt-core/Util/BigInteger.php
BigIntegerBcmath.php
BigIntegerGmp.php
BigNumber.php
BigNumberConverter.php
BigNumberTimeConverter.php
BigRational.php
paragonie/constant_time_encoding/src/Binary.php
phpseclib/phpseclib/phpseclib/Crypt/EC/BaseCurves/Binary.php
BinaryField.php
BinaryUtils.php
BiometricAccuracyDescriptor.php
BiometricStatusReport.php
BitString.php
namespaced/Core/BLAKE2b.php
src/Core/BLAKE2b.php
src/Core32/BLAKE2b.php
BlockCipher.php
components/com_content/tmpl/category/blog.php
plugins/sampledata/blog/blog.php
blog_children.php
blog_item.php
blog_links.php
blog_style_default_item_title.php
Blowfish.php
BMPString.php
administrator/templates/atum/html/layouts/chromes/body.php
installation/template/body.php
layouts/libraries/html/bootstrap/modal/body.php
Boolean.php
BooleanRule.php
BootableExtensionInterface.php
Bootstrap.php
bootstrap.php
vendor/phpseclib/phpseclib/phpseclib/bootstrap.php
vendor/symfony/polyfill-ctype/bootstrap.php
vendor/symfony/polyfill-iconv/bootstrap.php
vendor/symfony/polyfill-intl-grapheme/bootstrap.php
vendor/symfony/polyfill-intl-normalizer/bootstrap.php
vendor/symfony/polyfill-mbstring/bootstrap.php
vendor/symfony/polyfill-php72/bootstrap.php
vendor/symfony/polyfill-php73/bootstrap.php
vendor/symfony/polyfill-php80/bootstrap.php
vendor/voku/portable-utf8/bootstrap.php
polyfill-ctype/bootstrap80.php
polyfill-iconv/bootstrap80.php
polyfill-intl-grapheme/bootstrap80.php
polyfill-intl-normalizer/bootstrap80.php
polyfill-mbstring/bootstrap80.php
Bootup.php
brainpoolP160r1.php
brainpoolP160t1.php
brainpoolP192r1.php
brainpoolP192t1.php
brainpoolP224r1.php
brainpoolP224t1.php
brainpoolP256r1.php
brainpoolP256t1.php
brainpoolP320r1.php
brainpoolP320t1.php
brainpoolP384r1.php
brainpoolP384t1.php
brainpoolP512r1.php
brainpoolP512t1.php
BranchesField.php
BreadcrumbsHelper.php
BreakObject.php
Brightness.php
Browser.php
Buffer.php
BufferedOutput.php
BufferingLogger.php
BufferStreamHandler.php
Builder.php
BuiltIn.php
BuiltInDomainDefinedAttribute.php
BuiltInDomainDefinedAttributes.php
BuiltInStandardAttributes.php
button.php
editors/buttons.php
form/field/radio/buttons.php
ByteString.php
ByteStringObject.php
ByteStringWithChunkObject.php
Bzip2.php
CaBundle.php
libraries/src/Cache/Cache.php
plugins/system/cache/src/Extension/Cache.php
CacheCacheCollector.php
CacheConnectingException.php
Cache/CacheController.php
Service/Provider/CacheController.php
CacheControllerFactory.php
CacheControllerFactoryAwareInterface.php
CacheControllerFactoryAwareTrait.php
CacheControllerFactoryInterface.php
namespaced/Core/Curve25519/Ge/Cached.php
src/Core/Curve25519/Ge/Cached.php
src/Core32/Curve25519/Ge/Cached.php
CachedWordInflector.php
CacheExceptionInterface.php
CachehandlerField.php
CacheModel.php
CacheStorage.php
CacheStorageHelper.php
CachingLanguageFactory.php
Calculator.php
layouts/joomla/form/field/calendar.php
plugins/fields/calendar/calendar.php
plugins/fields/calendar/tmpl/calendar.php
CalendarField.php
CalendarRule.php
Callback.php
administrator/components/com_users/src/Controller/CallbackController.php
components/com_users/src/Controller/CallbackController.php
libraries/src/Cache/Controller/CallbackController.php
CallbackLogger.php
CallbackStream.php
cancelselect.php
CannotDecodeContent.php
CannotEncodeContent.php
CannotSignPayload.php
canonicalComposition.php
canonicalDecomposition.php
CapabilitiesModel.php
Captcha.php
CaptchaField.php
CaptchaRule.php
Captive.php
captive.php
administrator/components/com_users/src/Controller/CaptiveController.php
components/com_users/src/Controller/CaptiveController.php
administrator/components/com_users/src/Model/CaptiveModel.php
components/com_users/src/Model/CaptiveModel.php
CaptiveRenderOptions.php
card.php
caseFolding_full.php
Caster.php
Catalan.php
Categories.php
administrator/components/com_categories/helpers/categories.php
plugins/finder/categories/categories.php
categories_default.php
categories_default_items.php
CategoriesComponent.php
administrator/components/com_categories/src/Controller/CategoriesController.php
api/components/com_categories/src/Controller/CategoriesController.php
CategoriesHelper.php
administrator/components/com_categories/src/Model/CategoriesModel.php
components/com_contact/src/Model/CategoriesModel.php
components/com_content/src/Model/CategoriesModel.php
components/com_newsfeeds/src/Model/CategoriesModel.php
CategoriesView.php
category.php
components/com_banners/src/Service/Category.php
components/com_contact/src/Service/Category.php
components/com_content/src/Service/Category.php
components/com_newsfeeds/src/Service/Category.php
libraries/src/HTML/Helpers/Category.php
libraries/src/Table/Category.php
category_default.php
CategoryAssociationHelper.php
CategoryController.php
categoryedit.php
CategoryeditField.php
Categories/CategoryFactory.php
Extension/Service/Provider/CategoryFactory.php
CategoryFactoryInterface.php
CategoryFeedView.php
administrator/components/com_categories/src/Field/Modal/CategoryField.php
libraries/src/Form/Field/CategoryField.php
CategoryInterface.php
administrator/components/com_categories/src/Model/CategoryModel.php
components/com_contact/src/Model/CategoryModel.php
components/com_content/src/Model/CategoryModel.php
components/com_newsfeeds/src/Model/CategoryModel.php
CategoryNode.php
CategoryServiceInterface.php
CategoryServiceTrait.php
CategoryTable.php
CategoryView.php
CBORObject.php
Certificate.php
CertificateExtensions.php
CertificateIssuer.php
CertificateList.php
CertificatePolicies.php
CertificateSerialNumber.php
CertificateSubject.php
CertificateToolbox.php
CertificateTrustPath.php
CertificationRequest.php
CertificationRequestInfo.php
CertPolicyId.php
paragonie/sodium_compat/namespaced/Core/ChaCha20.php
paragonie/sodium_compat/src/Core/ChaCha20.php
paragonie/sodium_compat/src/Core32/ChaCha20.php
phpseclib/phpseclib/phpseclib/Crypt/ChaCha20.php
ChainedHandler.php
ChainedMonitor.php
ChangeItem.php
Changelog.php
changelog.php
ChangeSet.php
ChangeUserPasswordCommand.php
Characteristic_two.php
CharacterString.php
CharsetNegotiator.php
checkbox.php
layouts/joomla/form/field/checkboxes.php
plugins/fields/checkboxes/checkboxes.php
plugins/fields/checkboxes/tmpl/checkboxes.php
CheckboxesField.php
CheckboxField.php
CheckEvent.php
Checkfiles.php
CheckIfRehashNeededHandlerInterface.php
CheckinCheckout.php
CheckinCheckoutExceptionHandler.php
CheckinModel.php
CheckJoomlaUpdatesCommand.php
CheckLdapCredentialsListener.php
ChecksModel.php
CheckUpdatesCommand.php
ChoiceQuestion.php
chr.php
ChromestyleField.php
CipherInterface.php
Claim.php
class-aliases.php
Classic.php
src/Autoload/ClassLoader.php
vendor/composer/ClassLoader.php
classmap.php
ClassNotFoundError.php
ClassNotFoundErrorEnhancer.php
ClassStub.php
CleanCacheCommand.php
CleanupModel.php
Cli.php
CliApplication.php
ClicksField.php
CliContextProvider.php
CliDescriptor.php
CliDumper.php
oauth1/src/Client.php
oauth2/src/Client.php
ClientController.php
ClientExceptionInterface.php
ClientHelper.php
ClientInterface.php
ClientModel.php
administrator/components/com_banners/src/Controller/ClientsController.php
api/components/com_banners/src/Controller/ClientsController.php
ClientsModel.php
ClientTable.php
CliErrorRenderer.php
CliInput.php
CliOutput.php
CliRenderer.php
ClonerInterface.php
cloud.php
cms.php
CMSApplication.php
CMSApplicationInterface.php
CMSHelper.php
CMSObject.php
CMSPlugin.php
CMSWebApplicationInterface.php
CodeAccuracyDescriptor.php
CodecInterface.php
codemirror.php
CodePointString.php
collapse-default.php
collapse-metismenu.php
Collectable.php
CollectedClientData.php
symfony/ldap/Adapter/ExtLdap/Collection.php
tobscure/json-api/src/Collection.php
CollectionAdapter.php
CollectionInterface.php
color.php
tmpl/color.php
Color.php
ColorField.php
ColorProcessor.php
ColorRule.php
ColorStyle.php
CombGenerator.php
combiningClass.php
combo.php
ComboField.php
Command.php
CommandCompletionTester.php
CommandErrorEvent.php
CommandIsSuccessful.php
CommandLoaderInterface.php
CommandNotFoundException.php
CommandTester.php
paragonie/sodium_compat/src/Core/Base64/Common.php
phpseclib/phpseclib/phpseclib/Crypt/EC/Formats/Keys/Common.php
CompactSerializer.php
compare.php
CompareModel.php
namespaced/Compat.php
src/Compat.php
compatibilityDecomposition.php
administrator/components/com_joomlaupdate/tmpl/joomlaupdate/complete.php
components/com_users/tmpl/registration/complete.php
components/com_users/tmpl/reset/complete.php
CompleteCommand.php
CompletionInput.php
CompletionOutputInterface.php
CompletionSuggestions.php
Component.php
administrator/templates/atum/component.php
administrator/templates/system/component.php
templates/cassiopeia/component.php
templates/system/component.php
ComponentAdapter.php
administrator/components/com_config/src/Controller/ComponentController.php
api/components/com_config/src/Controller/ComponentController.php
ComponentDispatcher.php
Dispatcher/ComponentDispatcherFactory.php
Extension/Service/Provider/ComponentDispatcherFactory.php
ComponentDispatcherFactoryInterface.php
ComponentHelper.php
ComponentInterface.php
ComponentlayoutField.php
ComponentModel.php
ComponentRecord.php
ComponentRenderer.php
ComponentsCategoryField.php
ComponentsField.php
ComponentsFieldgroupField.php
ComponentsFieldsField.php
ComponentsWorkflowField.php
config.php
Config.php
ConfigCollector.php
ConfigComponent.php
ConfigComponentsField.php
administrator/components/com_messages/src/Controller/ConfigController.php
components/com_config/src/Controller/ConfigController.php
ConfigHelper.php
administrator/components/com_messages/src/Model/ConfigModel.php
components/com_config/src/Model/ConfigModel.php
ConfigPostProcessor.php
ConfigProvider.php
administrator/components/com_admin/src/Service/HTML/Configuration.php
libraries/vendor/lcobucci/jwt/src/Configuration.php
ConfigurationAwareApplicationInterface.php
ConfigurationModel.php
confirm.php
ConfirmationQuestion.php
ConfirmButton.php
confirmconsent.php
ConfirmModel.php
ConjunctionInterceptor.php
ldap/Adapter/ExtLdap/Connection.php
var-dumper/Server/Connection.php
ConnectionClosedException.php
ConnectionEvent.php
ConnectionException.php
ConnectionFailureException.php
ConnectionInterface.php
ConnectionOptions.php
ConnectionTimeoutException.php
ConsentBoxField.php
consents.php
administrator/components/com_privacy/src/Controller/ConsentsController.php
api/components/com_privacy/src/Controller/ConsentsController.php
ConsentsModel.php
ConsentTable.php
Console.php
ConsoleApplication.php
ConsoleCommandEvent.php
ConsoleErrorEvent.php
joomla/console/src/Event/ConsoleEvent.php
symfony/console/Event/ConsoleEvent.php
joomla/console/src/ConsoleEvents.php
symfony/console/ConsoleEvents.php
ConsoleLogger.php
ConsoleOutput.php
ConsoleOutputInterface.php
ConsoleSectionOutput.php
ConsoleSignalEvent.php
ConsoleTerminateEvent.php
constants.php
Constraint.php
ConstraintViolation.php
Construct.php
ConstStub.php
administrator/components/com_contact/helpers/contact.php
plugins/content/contact/contact.php
plugins/editors-xtd/contact/contact.php
plugins/privacy/contact/contact.php
plugins/webservices/contact/contact.php
ContactComponent.php
administrator/components/com_contact/src/Controller/ContactController.php
api/components/com_contact/src/Controller/ContactController.php
components/com_contact/src/Controller/ContactController.php
contactcreator.php
ContactEmailMessageRule.php
ContactEmailRule.php
ContactEmailSubjectRule.php
ContactField.php
ContactHelper.php
administrator/components/com_contact/src/Model/ContactModel.php
components/com_contact/src/Model/ContactModel.php
contacts.php
ContactsController.php
ContactSerializer.php
ContactsModel.php
ContactTable.php
joomla/di/src/Container.php
typo3/phar-stream-wrapper/src/Phar/Container.php
ContainerAwareInterface.php
ContainerAwareToolbarFactory.php
ContainerAwareTrait.php
containerclose.php
ContainerCommandLoader.php
ContainerControllerResolver.php
ContainerExceptionInterface.php
ContainerInterface.php
ContainerLoader.php
ContainerNotFoundException.php
containeropen.php
ContainerResource.php
HTML/Helpers/Content.php
Table/Content.php
administrator/components/com_content/helpers/content.php
plugins/finder/content/content.php
plugins/privacy/content/content.php
plugins/webservices/content/content.php
ContentComponent.php
administrator/components/com_content/src/Helper/ContentHelper.php
api/components/com_content/src/Helper/ContentHelper.php
libraries/src/Helper/ContentHelper.php
ContentHistory.php
administrator/components/com_contenthistory/helpers/contenthistory.php
layouts/joomla/form/field/contenthistory.php
ContenthistoryField.php
ContenthistoryHelper.php
ContentLanguage.php
ContentlanguageField.php
ContentmapField.php
ContentSerializer.php
ContentType.php
ContenttypeField.php
ContenttypesField.php
ContextProviderInterface.php
ContextualizedDumper.php
Contrast.php
ControllerInterface.php
ControllerResolver.php
ControllerResolverInterface.php
ConversionFailed.php
cookie.php
src/Input/Cookie.php
vendor/joomla/input/src/Cookie.php
mbstring/core.php
native/core.php
Core.php
CoreAssetItem.php
CoreButtonsTrait.php
CoreContent.php
CoreEventAware.php
CoseSignatureFixer.php
CountryName.php
cpanel.php
CPSuri.php
create-folder.php
create.php
create_date.php
create_uploaded_file.legacy.php
create_uploaded_file.php
CreateSessionTableCommand.php
CreateSessionTableException.php
Credential.php
multifactorauth/webauthn/src/CredentialRepository.php
system/webauthn/src/CredentialRepository.php
Credentials.php
CRLDistributionPoints.php
CRLNumber.php
CRLReason.php
CronExpression.php
CronField.php
crop.php
src/Crypt/Crypt.php
vendor/joomla/crypt/src/Crypt.php
CryptExceptionInterface.php
php-encryption/Crypto.php
vendor/defuse/php-encryption/src/Crypto.php
vendor/joomla/crypt/src/Cipher/Crypto.php
vendor/paragonie/sodium_compat/namespaced/Crypto.php
vendor/paragonie/sodium_compat/src/Crypto.php
Crypto32.php
CryptoCipher.php
CryptoException.php
CSR.php
CssIdentifierRule.php
CssIdentifierSubstringRule.php
CssMenu.php
namespaced/Core/ChaCha20/Ctx.php
src/Core/ChaCha20/Ctx.php
src/Core32/ChaCha20/Ctx.php
Ctype.php
google/recaptcha/src/ReCaptcha/RequestMethod/Curl.php
joomla/http/src/Transport/Curl.php
CurlPost.php
CurlTransport.php
CurrentUserInterface.php
CurrentUserTrait.php
console/Cursor.php
var-dumper/Cloner/Cursor.php
Curve.php
paragonie/sodium_compat/namespaced/Core/Curve25519.php
paragonie/sodium_compat/src/Core/Curve25519.php
paragonie/sodium_compat/src/Core32/Curve25519.php
phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Curve25519.php
Curve448.php
CustomButton.php
CutArrayStub.php
CutStub.php
DaemonApplication.php
Danish.php
data.php
Data.php
Database.php
DatabaseAwareInterface.php
src/MVC/Model/DatabaseAwareTrait.php
vendor/joomla/database/src/DatabaseAwareTrait.php
DatabaseconnectionField.php
DatabaseController.php
DatabaseDriver.php
DatabaseEvents.php
DatabaseExporter.php
DatabaseFactory.php
DatabaseHandler.php
DatabaseHelper.php
DatabaseImporter.php
DatabaseInterface.php
DatabaseIterator.php
DatabaseLogger.php
administrator/components/com_installer/src/Model/DatabaseModel.php
installation/src/Model/DatabaseModel.php
DatabaseModelInterface.php
DatabaseNotFoundException.php
DatabaseProvider.php
DatabaseQuery.php
DatabaseStrategy.php
DataCollector.php
DataCollectorInterface.php
DataDumperInterface.php
DataField.php
libraries/vendor/maximebf/debugbar/src/DebugBar/DataFormatter/DataFormatter.php
plugins/system/debug/src/DataFormatter.php
DataFormatterInterface.php
DataObject.php
joomla/data/src/DataSet.php
lcobucci/jwt/src/Token/DataSet.php
DataShapeObject.php
Date/Date.php
HTML/Helpers/Date.php
DateCaster.php
DayOfMonthField.php
DayOfWeekField.php
src/HTML/Helpers/Debug.php
vendor/symfony/error-handler/Debug.php
administrator/components/com_users/helpers/debug.php
plugins/system/debug/debug.php
DebugBar.php
DebugBarException.php
DebugBarHtmlDumper.php
DebugBarVarDumper.php
DebugClassLoader.php
DebugEventDispatcherCommand.php
DebugFormatterHelper.php
DebuggroupModel.php
DebugHelper.php
DebugMonitor.php
DebugRouterCommand.php
DebuguserModel.php
DecimalFractionTag.php
lcobucci/jwt/src/Parsing/Decoder.php
spomky-labs/cbor-php/src/Decoder.php
DecryptionException.php
administrator/components/com_actionlogs/tmpl/actionlogs/default.php
administrator/components/com_admin/tmpl/help/default.php
administrator/components/com_admin/tmpl/sysinfo/default.php
administrator/components/com_associations/layouts/joomla/searchtools/default.php
administrator/components/com_associations/tmpl/associations/default.php
administrator/components/com_banners/tmpl/banners/default.php
administrator/components/com_banners/tmpl/clients/default.php
administrator/components/com_banners/tmpl/download/default.php
administrator/components/com_banners/tmpl/tracks/default.php
administrator/components/com_cache/tmpl/cache/default.php
administrator/components/com_categories/tmpl/categories/default.php
administrator/components/com_checkin/tmpl/checkin/default.php
administrator/components/com_config/tmpl/application/default.php
administrator/components/com_config/tmpl/component/default.php
administrator/components/com_contact/tmpl/contacts/default.php
administrator/components/com_content/tmpl/articles/default.php
administrator/components/com_content/tmpl/featured/default.php
administrator/components/com_cpanel/tmpl/cpanel/default.php
administrator/components/com_fields/tmpl/fields/default.php
administrator/components/com_fields/tmpl/groups/default.php
administrator/components/com_finder/tmpl/filters/default.php
administrator/components/com_finder/tmpl/index/default.php
administrator/components/com_finder/tmpl/indexer/default.php
administrator/components/com_finder/tmpl/maps/default.php
administrator/components/com_finder/tmpl/searches/default.php
administrator/components/com_finder/tmpl/statistics/default.php
administrator/components/com_installer/tmpl/database/default.php
administrator/components/com_installer/tmpl/discover/default.php
administrator/components/com_installer/tmpl/install/default.php
administrator/components/com_installer/tmpl/languages/default.php
administrator/components/com_installer/tmpl/manage/default.php
administrator/components/com_installer/tmpl/update/default.php
administrator/components/com_installer/tmpl/updatesites/default.php
administrator/components/com_installer/tmpl/warnings/default.php
administrator/components/com_joomlaupdate/tmpl/update/default.php
administrator/components/com_joomlaupdate/tmpl/upload/default.php
administrator/components/com_languages/tmpl/installed/default.php
administrator/components/com_languages/tmpl/languages/default.php
administrator/components/com_languages/tmpl/multilangstatus/default.php
administrator/components/com_languages/tmpl/overrides/default.php
administrator/components/com_login/tmpl/login/default.php
administrator/components/com_mails/tmpl/templates/default.php
administrator/components/com_media/tmpl/file/default.php
administrator/components/com_media/tmpl/media/default.php
administrator/components/com_menus/layouts/joomla/searchtools/default.php
administrator/components/com_menus/tmpl/items/default.php
administrator/components/com_menus/tmpl/menus/default.php
administrator/components/com_menus/tmpl/menutypes/default.php
administrator/components/com_messages/tmpl/config/default.php
administrator/components/com_messages/tmpl/message/default.php
administrator/components/com_messages/tmpl/messages/default.php
administrator/components/com_modules/tmpl/modules/default.php
administrator/components/com_modules/tmpl/select/default.php
administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php
administrator/components/com_plugins/tmpl/plugins/default.php
administrator/components/com_postinstall/tmpl/messages/default.php
administrator/components/com_privacy/tmpl/capabilities/default.php
administrator/components/com_privacy/tmpl/consents/default.php
administrator/components/com_privacy/tmpl/request/default.php
administrator/components/com_privacy/tmpl/requests/default.php
administrator/components/com_redirect/tmpl/links/default.php
administrator/components/com_scheduler/tmpl/select/default.php
administrator/components/com_scheduler/tmpl/tasks/default.php
administrator/components/com_tags/tmpl/tags/default.php
administrator/components/com_templates/tmpl/styles/default.php
administrator/components/com_templates/tmpl/template/default.php
administrator/components/com_templates/tmpl/templates/default.php
administrator/components/com_users/tmpl/captive/default.php
administrator/components/com_users/tmpl/debuggroup/default.php
administrator/components/com_users/tmpl/debuguser/default.php
administrator/components/com_users/tmpl/groups/default.php
administrator/components/com_users/tmpl/levels/default.php
administrator/components/com_users/tmpl/mail/default.php
administrator/components/com_users/tmpl/methods/default.php
administrator/components/com_users/tmpl/notes/default.php
administrator/components/com_users/tmpl/users/default.php
administrator/components/com_workflow/tmpl/stages/default.php
administrator/components/com_workflow/tmpl/transitions/default.php
administrator/components/com_workflow/tmpl/workflows/default.php
administrator/modules/mod_custom/tmpl/default.php
administrator/modules/mod_feed/tmpl/default.php
administrator/modules/mod_frontend/tmpl/default.php
administrator/modules/mod_latest/tmpl/default.php
administrator/modules/mod_latestactions/tmpl/default.php
administrator/modules/mod_logged/tmpl/default.php
administrator/modules/mod_login/tmpl/default.php
administrator/modules/mod_loginsupport/tmpl/default.php
administrator/modules/mod_menu/tmpl/default.php
administrator/modules/mod_messages/tmpl/default.php
administrator/modules/mod_multilangstatus/tmpl/default.php
administrator/modules/mod_popular/tmpl/default.php
administrator/modules/mod_post_installation_messages/tmpl/default.php
administrator/modules/mod_privacy_dashboard/tmpl/default.php
administrator/modules/mod_privacy_status/tmpl/default.php
administrator/modules/mod_quickicon/tmpl/default.php
administrator/modules/mod_sampledata/tmpl/default.php
administrator/modules/mod_stats_admin/tmpl/default.php
administrator/modules/mod_submenu/tmpl/default.php
administrator/modules/mod_title/tmpl/default.php
administrator/modules/mod_toolbar/tmpl/default.php
administrator/modules/mod_user/tmpl/default.php
administrator/modules/mod_version/tmpl/default.php
components/com_config/tmpl/config/default.php
components/com_config/tmpl/modules/default.php
components/com_config/tmpl/templates/default.php
components/com_contact/tmpl/categories/default.php
components/com_contact/tmpl/category/default.php
components/com_contact/tmpl/contact/default.php
components/com_contact/tmpl/featured/default.php
components/com_content/tmpl/archive/default.php
components/com_content/tmpl/article/default.php
components/com_content/tmpl/categories/default.php
components/com_content/tmpl/category/default.php
components/com_content/tmpl/featured/default.php
components/com_finder/tmpl/search/default.php
components/com_menus/layouts/joomla/searchtools/default.php
components/com_newsfeeds/tmpl/categories/default.php
components/com_newsfeeds/tmpl/category/default.php
components/com_newsfeeds/tmpl/newsfeed/default.php
components/com_privacy/tmpl/confirm/default.php
components/com_privacy/tmpl/remind/default.php
components/com_privacy/tmpl/request/default.php
components/com_tags/tmpl/tag/default.php
components/com_tags/tmpl/tags/default.php
components/com_users/tmpl/captive/default.php
components/com_users/tmpl/login/default.php
components/com_users/tmpl/methods/default.php
components/com_users/tmpl/profile/default.php
components/com_users/tmpl/registration/default.php
components/com_users/tmpl/remind/default.php
components/com_users/tmpl/reset/default.php
components/com_wrapper/tmpl/wrapper/default.php
installation/tmpl/error/default.php
installation/tmpl/preinstall/default.php
installation/tmpl/remove/default.php
installation/tmpl/setup/default.php
layouts/joomla/form/field/subform/default.php
layouts/joomla/searchtools/default.php
modules/mod_articles_archive/tmpl/default.php
modules/mod_articles_categories/tmpl/default.php
modules/mod_articles_category/tmpl/default.php
modules/mod_articles_latest/tmpl/default.php
modules/mod_articles_news/tmpl/default.php
modules/mod_articles_popular/tmpl/default.php
modules/mod_banners/tmpl/default.php
modules/mod_breadcrumbs/tmpl/default.php
modules/mod_custom/tmpl/default.php
modules/mod_feed/tmpl/default.php
modules/mod_finder/tmpl/default.php
modules/mod_footer/tmpl/default.php
modules/mod_languages/tmpl/default.php
modules/mod_login/tmpl/default.php
modules/mod_menu/tmpl/default.php
modules/mod_random_image/tmpl/default.php
modules/mod_related_items/tmpl/default.php
modules/mod_stats/tmpl/default.php
modules/mod_syndicate/tmpl/default.php
modules/mod_tags_popular/tmpl/default.php
modules/mod_tags_similar/tmpl/default.php
modules/mod_users_latest/tmpl/default.php
modules/mod_whosonline/tmpl/default.php
modules/mod_wrapper/tmpl/default.php
plugins/content/pagenavigation/tmpl/default.php
plugins/installer/folderinstaller/tmpl/default.php
plugins/installer/packageinstaller/tmpl/default.php
plugins/installer/urlinstaller/tmpl/default.php
plugins/installer/webinstaller/tmpl/default.php
plugins/multifactorauth/webauthn/tmpl/default.php
default_addform.php
default_address.php
com_contact/tmpl/contact/default_articles.php
com_content/tmpl/category/default_articles.php
com_banners/tmpl/banners/default_batch_body.php
com_categories/tmpl/categories/default_batch_body.php
com_contact/tmpl/contacts/default_batch_body.php
com_content/tmpl/articles/default_batch_body.php
com_fields/tmpl/fields/default_batch_body.php
com_fields/tmpl/groups/default_batch_body.php
com_menus/tmpl/items/default_batch_body.php
com_modules/tmpl/modules/default_batch_body.php
com_newsfeeds/tmpl/newsfeeds/default_batch_body.php
com_redirect/tmpl/links/default_batch_body.php
com_tags/tmpl/tags/default_batch_body.php
com_users/tmpl/users/default_batch_body.php
com_banners/tmpl/banners/default_batch_footer.php
com_categories/tmpl/categories/default_batch_footer.php
com_contact/tmpl/contacts/default_batch_footer.php
com_content/tmpl/articles/default_batch_footer.php
com_fields/tmpl/fields/default_batch_footer.php
com_fields/tmpl/groups/default_batch_footer.php
com_menus/tmpl/items/default_batch_footer.php
com_modules/tmpl/modules/default_batch_footer.php
com_newsfeeds/tmpl/newsfeeds/default_batch_footer.php
com_redirect/tmpl/links/default_batch_footer.php
com_tags/tmpl/tags/default_batch_footer.php
com_users/tmpl/users/default_batch_footer.php
default_cache.php
com_contact/tmpl/category/default_children.php
com_content/tmpl/category/default_children.php
com_newsfeeds/tmpl/category/default_children.php
default_component.php
default_config.php
default_cookie.php
default_core.php
default_custom.php
default_database.php
default_debug.php
default_description.php
default_directory.php
default_filters.php
default_folders.php
com_contact/tmpl/contact/default_form.php
com_finder/tmpl/search/default_form.php
default_heading.php
default_item.php
components/com_contact/tmpl/categories/default_items.php
components/com_contact/tmpl/category/default_items.php
components/com_contact/tmpl/featured/default_items.php
components/com_content/tmpl/archive/default_items.php
components/com_content/tmpl/categories/default_items.php
components/com_newsfeeds/tmpl/categories/default_items.php
components/com_newsfeeds/tmpl/category/default_items.php
components/com_tags/tmpl/tag/default_items.php
components/com_tags/tmpl/tags/default_items.php
modules/mod_articles_categories/tmpl/default_items.php
modules/mod_articles_category/tmpl/default_items.php
com_contact/tmpl/contact/default_links.php
com_content/tmpl/article/default_links.php
com_content/tmpl/featured/default_links.php
default_locale.php
default_logging.php
default_logging_custom.php
default_login.php
components/com_users/tmpl/login/default_logout.php
modules/mod_login/tmpl/default_logout.php
default_mail.php
default_media_folders.php
default_message.php
administrator/components/com_config/tmpl/application/default_metadata.php
components/com_config/tmpl/config/default_metadata.php
default_modal_child_body.php
default_modal_child_footer.php
default_modal_copy_body.php
default_modal_copy_footer.php
default_modal_delete_body.php
default_modal_delete_footer.php
default_modal_file_body.php
default_modal_file_footer.php
default_modal_folder_body.php
default_modal_folder_footer.php
default_modal_rename_body.php
default_modal_rename_footer.php
default_modal_resize_body.php
default_modal_resize_footer.php
application/default_navigation.php
component/default_navigation.php
modules/default_options.php
templates/default_options.php
default_params.php
default_permissions.php
default_phpinfo.php
default_phpsettings.php
default_profile.php
default_proxy.php
default_result.php
default_results.php
administrator/components/com_config/tmpl/application/default_seo.php
components/com_config/tmpl/config/default_seo.php
default_separator.php
default_server.php
default_session.php
administrator/components/com_config/tmpl/application/default_site.php
components/com_config/tmpl/config/default_site.php
default_stage_body.php
default_stage_footer.php
default_submenu.php
default_system.php
default_texts.php
default_tree.php
default_tree_media.php
default_updated_files.php
default_url.php
default_user_custom_fields.php
default_webservices.php
BCMath/DefaultEngine.php
GMP/DefaultEngine.php
PHP/DefaultEngine.php
DefaultTimeGenerator.php
DefaultUuidBuilder.php
DefaultView.php
administrator/includes/defines.php
api/includes/defines.php
includes/defines.php
installation/includes/defines.php
DegradedNumberConverter.php
DegradedTimeConverter.php
DegradedUuid.php
DegradedUuidBuilder.php
DelegatingPsrLogger.php
delete.php
DeleteUserCommand.php
DemoTasks.php
DependencyResolutionException.php
DerivedKeys.php
DES.php
Descriptor.php
joomla/console/src/Helper/DescriptorHelper.php
symfony/console/Helper/DescriptorHelper.php
DescriptorInterface.php
laminas/laminas-diactoros/src/Exception/DeserializationException.php
typo3/phar-stream-wrapper/src/Phar/DeserializationException.php
DH.php
DHParameter.php
DigestInfo.php
Directory.php
DirectoryString.php
administrator/modules/mod_logged/tmpl/disabled.php
modules/mod_whosonline/tmpl/disabled.php
DiscoverController.php
DiscoverModel.php
administrator/components/com_admin/src/Dispatcher/Dispatcher.php
administrator/components/com_associations/src/Dispatcher/Dispatcher.php
administrator/components/com_categories/src/Dispatcher/Dispatcher.php
administrator/components/com_contenthistory/src/Dispatcher/Dispatcher.php
administrator/components/com_cpanel/src/Dispatcher/Dispatcher.php
administrator/components/com_fields/src/Dispatcher/Dispatcher.php
administrator/components/com_joomlaupdate/src/Dispatcher/Dispatcher.php
administrator/components/com_login/src/Dispatcher/Dispatcher.php
administrator/components/com_media/src/Dispatcher/Dispatcher.php
administrator/components/com_privacy/src/Dispatcher/Dispatcher.php
administrator/components/com_users/src/Dispatcher/Dispatcher.php
administrator/components/com_workflow/src/Dispatcher/Dispatcher.php
administrator/modules/mod_quickicon/src/Dispatcher/Dispatcher.php
components/com_config/src/Dispatcher/Dispatcher.php
components/com_contact/src/Dispatcher/Dispatcher.php
components/com_content/src/Dispatcher/Dispatcher.php
components/com_contenthistory/src/Dispatcher/Dispatcher.php
components/com_fields/src/Dispatcher/Dispatcher.php
components/com_media/src/Dispatcher/Dispatcher.php
components/com_menus/src/Dispatcher/Dispatcher.php
components/com_modules/src/Dispatcher/Dispatcher.php
libraries/src/Dispatcher/Dispatcher.php
libraries/src/Service/Provider/Dispatcher.php
libraries/vendor/joomla/event/src/Dispatcher.php
modules/mod_articles_latest/src/Dispatcher/Dispatcher.php
modules/mod_articles_news/src/Dispatcher/Dispatcher.php
DispatcherAwareInterface.php
DispatcherAwareTrait.php
src/Dispatcher/DispatcherInterface.php
vendor/joomla/event/src/DispatcherInterface.php
administrator/components/com_actionlogs/src/Controller/DisplayController.php
administrator/components/com_admin/src/Controller/DisplayController.php
administrator/components/com_associations/src/Controller/DisplayController.php
administrator/components/com_banners/src/Controller/DisplayController.php
administrator/components/com_cache/src/Controller/DisplayController.php
administrator/components/com_categories/src/Controller/DisplayController.php
administrator/components/com_checkin/src/Controller/DisplayController.php
administrator/components/com_config/src/Controller/DisplayController.php
administrator/components/com_contact/src/Controller/DisplayController.php
administrator/components/com_content/src/Controller/DisplayController.php
administrator/components/com_contenthistory/src/Controller/DisplayController.php
administrator/components/com_cpanel/src/Controller/DisplayController.php
administrator/components/com_fields/src/Controller/DisplayController.php
administrator/components/com_finder/src/Controller/DisplayController.php
administrator/components/com_installer/src/Controller/DisplayController.php
administrator/components/com_joomlaupdate/src/Controller/DisplayController.php
administrator/components/com_languages/src/Controller/DisplayController.php
administrator/components/com_login/src/Controller/DisplayController.php
administrator/components/com_mails/src/Controller/DisplayController.php
administrator/components/com_media/src/Controller/DisplayController.php
administrator/components/com_menus/src/Controller/DisplayController.php
administrator/components/com_messages/src/Controller/DisplayController.php
administrator/components/com_modules/src/Controller/DisplayController.php
administrator/components/com_newsfeeds/src/Controller/DisplayController.php
administrator/components/com_plugins/src/Controller/DisplayController.php
administrator/components/com_postinstall/src/Controller/DisplayController.php
administrator/components/com_privacy/src/Controller/DisplayController.php
administrator/components/com_redirect/src/Controller/DisplayController.php
administrator/components/com_scheduler/src/Controller/DisplayController.php
administrator/components/com_tags/src/Controller/DisplayController.php
administrator/components/com_templates/src/Controller/DisplayController.php
administrator/components/com_users/src/Controller/DisplayController.php
administrator/components/com_workflow/src/Controller/DisplayController.php
components/com_banners/src/Controller/DisplayController.php
components/com_config/src/Controller/DisplayController.php
components/com_contact/src/Controller/DisplayController.php
components/com_content/src/Controller/DisplayController.php
components/com_contenthistory/src/Controller/DisplayController.php
components/com_fields/src/Controller/DisplayController.php
components/com_finder/src/Controller/DisplayController.php
components/com_modules/src/Controller/DisplayController.php
components/com_newsfeeds/src/Controller/DisplayController.php
components/com_privacy/src/Controller/DisplayController.php
components/com_tags/src/Controller/DisplayController.php
components/com_users/src/Controller/DisplayController.php
components/com_wrapper/src/Controller/DisplayController.php
installation/src/Controller/DisplayController.php
DisplayEvent.php
DisplayPNGCharacteristicsDescriptor.php
DisplayText.php
DisplayTrait.php
DistantSingleMetadata.php
DistantSingleMetadataFactory.php
DistributionPoint.php
DistributionPointName.php
DivisionByZeroException.php
DNSName.php
DoctrineCaster.php
DoctrineCollector.php
src/Document/Document.php
src/Service/Provider/Document.php
vendor/tobscure/json-api/src/Document.php
DocumentRenderer.php
Domain.php
DOMCaster.php
DoublePrecisionFloatObject.php
downloadkey.php
DownloadModel.php
DownloadSource.php
DraggableList.php
DriverNotFoundException.php
dropdown-metismenu.php
dropdown-metismenu_component.php
dropdown-metismenu_heading.php
dropdown-metismenu_separator.php
dropdown-metismenu_url.php
Dropdown.php
dropdown.php
DropdownButton.php
DSA.php
DSAParams.php
DSAPrivateKey.php
DSAPublicKey.php
DsCaster.php
DsPairStub.php
DssSigValue.php
DummyPlugin.php
dump.php
DumpableInterface.php
DumpCompletionCommand.php
DumpDescriptorInterface.php
console/Helper/Dumper.php
yaml/Dumper.php
DumperInterface.php
DumpException.php
DumpServer.php
Dutch.php
EC.php
Ec2Key.php
EcdaaKeyIdTrustPath.php
EcdaaTrustAnchor.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECDSA.php
web-token/jwt-signature-algorithm-ecdsa/ECDSA.php
Ecdsa.php
EcdsaSigValue.php
EchoLogger.php
ECKey.php
ECParameters.php
ECPoint.php
ECPrivateKey.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECSignature.php
web-token/jwt-core/Util/ECSignature.php
paragonie/sodium_compat/namespaced/Core/Ed25519.php
paragonie/sodium_compat/src/Core/Ed25519.php
paragonie/sodium_compat/src/Core32/Ed25519.php
phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Ed25519.php
web-auth/cose-lib/src/Algorithm/Signature/EdDSA/Ed25519.php
ED256.php
Ed448.php
ED512.php
web-auth/cose-lib/src/Algorithm/Signature/EdDSA/EdDSA.php
web-token/jwt-signature-algorithm-eddsa/EdDSA.php
Edgedetect.php
EDIPartyName.php
administrator/components/com_associations/tmpl/association/edit.php
administrator/components/com_banners/tmpl/banner/edit.php
administrator/components/com_banners/tmpl/client/edit.php
administrator/components/com_categories/tmpl/category/edit.php
administrator/components/com_contact/tmpl/contact/edit.php
administrator/components/com_content/tmpl/article/edit.php
administrator/components/com_fields/tmpl/field/edit.php
administrator/components/com_fields/tmpl/group/edit.php
administrator/components/com_finder/tmpl/filter/edit.php
administrator/components/com_installer/tmpl/updatesite/edit.php
administrator/components/com_languages/tmpl/language/edit.php
administrator/components/com_languages/tmpl/override/edit.php
administrator/components/com_mails/tmpl/template/edit.php
administrator/components/com_menus/tmpl/item/edit.php
administrator/components/com_menus/tmpl/menu/edit.php
administrator/components/com_messages/tmpl/message/edit.php
administrator/components/com_modules/tmpl/module/edit.php
administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php
administrator/components/com_plugins/tmpl/plugin/edit.php
administrator/components/com_privacy/tmpl/request/edit.php
administrator/components/com_redirect/tmpl/link/edit.php
administrator/components/com_scheduler/tmpl/task/edit.php
administrator/components/com_tags/tmpl/tag/edit.php
administrator/components/com_templates/tmpl/style/edit.php
administrator/components/com_users/tmpl/group/edit.php
administrator/components/com_users/tmpl/level/edit.php
administrator/components/com_users/tmpl/method/edit.php
administrator/components/com_users/tmpl/note/edit.php
administrator/components/com_users/tmpl/user/edit.php
administrator/components/com_workflow/tmpl/stage/edit.php
administrator/components/com_workflow/tmpl/transition/edit.php
administrator/components/com_workflow/tmpl/workflow/edit.php
components/com_contact/tmpl/form/edit.php
components/com_content/tmpl/form/edit.php
components/com_users/tmpl/method/edit.php
components/com_users/tmpl/profile/edit.php
layouts/joomla/content/icons/edit.php
com_modules/tmpl/module/edit_assignment.php
com_templates/tmpl/style/edit_assignment.php
edit_container.php
edit_display.php
edit_groups.php
edit_lock.php
layouts/joomla/menu/edit_modules.php
tmpl/item/edit_modules.php
editor.php
tmpl/editor.php
Editor.php
EditorField.php
El.php
element.php
Element.php
ElementInterface.php
libraries/src/HTML/Helpers/Email.php
plugins/multifactorauth/email/src/Extension/Email.php
email.php
emailcloak.php
EmailField.php
EmailRule.php
Emboss.php
emoji.php
empty_state.php
EmptyResponse.php
administrator/components/com_banners/tmpl/banners/emptystate.php
administrator/components/com_banners/tmpl/clients/emptystate.php
administrator/components/com_banners/tmpl/tracks/emptystate.php
administrator/components/com_cache/tmpl/cache/emptystate.php
administrator/components/com_categories/tmpl/categories/emptystate.php
administrator/components/com_checkin/tmpl/checkin/emptystate.php
administrator/components/com_contact/tmpl/contacts/emptystate.php
administrator/components/com_content/tmpl/articles/emptystate.php
administrator/components/com_content/tmpl/featured/emptystate.php
administrator/components/com_finder/tmpl/filters/emptystate.php
administrator/components/com_finder/tmpl/index/emptystate.php
administrator/components/com_finder/tmpl/maps/emptystate.php
administrator/components/com_finder/tmpl/searches/emptystate.php
administrator/components/com_installer/tmpl/discover/emptystate.php
administrator/components/com_installer/tmpl/update/emptystate.php
administrator/components/com_installer/tmpl/warnings/emptystate.php
administrator/components/com_messages/tmpl/messages/emptystate.php
administrator/components/com_modules/tmpl/modules/emptystate.php
administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php
administrator/components/com_postinstall/tmpl/messages/emptystate.php
administrator/components/com_privacy/tmpl/consents/emptystate.php
administrator/components/com_privacy/tmpl/requests/emptystate.php
administrator/components/com_redirect/tmpl/links/emptystate.php
administrator/components/com_tags/tmpl/tags/emptystate.php
administrator/components/com_users/tmpl/notes/emptystate.php
layouts/joomla/content/emptystate.php
emptystate_module.php
EmptyTrustPath.php
Encoder.php
EncoderInterface.php
defuse/php-encryption/src/Encoding.php
paragonie/constant_time_encoding/src/Encoding.php
EncodingHelperInterface.php
EncodingNegotiator.php
encodings.php
Encrypt.php
EncryptedData.php
EncryptedPrivateKeyInfo.php
EncryptionException.php
endtab.php
endtabset.php
Engine.php
English.php
EnglishInflector.php
Entry.php
EntryManager.php
EntryManagerInterface.php
Enumerated.php
EnumStub.php
EnvironmentIsBrokenException.php
EpochTag.php
EqualsRule.php
EqualsTo.php
error.html.php
administrator/templates/atum/error.php
administrator/templates/system/error.php
installation/template/error.php
templates/cassiopeia/error.php
templates/system/error.php
error_full.php
error_login.php
ErrorDocument.php
ErrorEnhancerInterface.php
ErrorEvent.php
symfony/error-handler/ErrorHandler.php
tobscure/json-api/src/ErrorHandler.php
ErrorListener.php
ErrorRendererInterface.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256.php
web-token/jwt-signature-algorithm-ecdsa/ES256.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256K.php
web-token/jwt-signature-algorithm-experimental/ES256K.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES384.php
web-token/jwt-signature-algorithm-ecdsa/ES384.php
web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES512.php
web-token/jwt-signature-algorithm-ecdsa/ES512.php
Escaper.php
BCMath/Reductions/EvalBarrett.php
PHP/Reductions/EvalBarrett.php
Event.php
EventAware.php
EventAwareInterface.php
EventImmutable.php
EventInterface.php
EventReturnAware.php
EvolvableLinkInterface.php
EvolvableLinkProviderInterface.php
EvolvableLinkProviderTrait.php
EvolvableLinkTrait.php
exception.html.php
lcobucci/jwt/src/Exception.php
phpmailer/phpmailer/src/Exception.php
typo3/phar-stream-wrapper/src/Exception.php
willdurand/negotiation/src/Negotiation/Exception/Exception.php
exception_full.html.php
ExceptionCaster.php
ExceptionHandler.php
ExceptionHandlerInterface.php
laminas/laminas-diactoros/src/Exception/ExceptionInterface.php
symfony/console/Exception/ExceptionInterface.php
symfony/ldap/Exception/ExceptionInterface.php
symfony/options-resolver/Exception/ExceptionInterface.php
symfony/string/Exception/ExceptionInterface.php
symfony/yaml/Exception/ExceptionInterface.php
ExceptionsCollector.php
ExecRuleHelper.php
ExecuteTaskEvent.php
ExecutionFailureException.php
ExecutionRuleField.php
ExecutionRulesRule.php
ExistsRule.php
ExplicitlyTaggedObject.php
ExportCommand.php
ExportModel.php
src/Table/Extension.php
vendor/phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Extension.php
ExtensionAdapter.php
ExtensionAttribute.php
ExtensionAttributes.php
ExtensionDescriptor.php
ExtensionDiscoverCommand.php
ExtensionDiscoverInstallCommand.php
ExtensionDiscoverListCommand.php
ExtensionField.php
ExtensionHelper.php
ExtensionInstallCommand.php
ExtensionManagerInterface.php
ExtensionManagerTrait.php
ExtensionNamespaceMapper.php
ExtensionOutputChecker.php
ExtensionOutputCheckerHandler.php
ExtensionOutputError.php
ExtensionRemoveCommand.php
extensions.classmap.php
Extensions.php
ExtensionsListCommand.php
ExtensionstatusField.php
extensionupdate.php
ExtKeyUsageSyntax.php
extract-tentative-return-types.php
extract.php
ExtractableInterface.php
src/Document/Factory.php
src/Factory.php
vendor/joomla/registry/src/Factory.php
vendor/lcobucci/jwt/src/Claim/Factory.php
FactoryCommandLoader.php
FactoryInterface.php
FallbackExceptionHandler.php
FallbackNodeProvider.php
FalseObject.php
fatal.php
FatalError.php
namespaced/Core/Curve25519/Fe.php
src/Core/Curve25519/Fe.php
src/Core32/Curve25519/Fe.php
FeaturedButton.php
FeaturedController.php
administrator/components/com_content/src/Model/FeaturedModel.php
components/com_contact/src/Model/FeaturedModel.php
components/com_content/src/Model/FeaturedModel.php
FeaturedTable.php
FeatureEvent.php
FeatureModel.php
FeatureSet.php
featuring.php
Feed.php
FeedDocument.php
FeedEnclosure.php
FeedEntry.php
FeedFactory.php
administrator/modules/mod_feed/src/Helper/FeedHelper.php
modules/mod_feed/src/Helper/FeedHelper.php
FeedImage.php
FeedItem.php
FeedLink.php
FeedParser.php
FeedPerson.php
FeedRenderer.php
FeedsController.php
com_contact/src/View/Category/FeedView.php
com_content/src/View/Category/FeedView.php
com_content/src/View/Featured/FeedView.php
com_finder/src/View/Search/FeedView.php
com_tags/src/View/Tag/FeedView.php
com_tags/src/View/Tags/FeedView.php
FetchMediaItemEvent.php
FetchMediaItemsEvent.php
FetchMediaItemUrlEvent.php
FetchMode.php
FetchOrientation.php
FiberCaster.php
libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/FidoU2FAttestationStatementSupport.php
plugins/multifactorauth/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php
plugins/system/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php
Field.php
FieldcontextsField.php
FieldController.php
FieldElement.php
FieldFactory.php
FieldFactoryInterface.php
FieldgroupsField.php
FieldID.php
FieldInterface.php
FieldLayoutField.php
FieldModel.php
administrator/components/com_fields/helpers/fields.php
plugins/content/fields/fields.php
plugins/editors-xtd/fields/fields.php
plugins/system/fields/fields.php
FieldsComponent.php
administrator/components/com_fields/src/Controller/FieldsController.php
api/components/com_fields/src/Controller/FieldsController.php
fieldset.php
FieldsHelper.php
FieldsListPlugin.php
FieldsModel.php
FieldsPlugin.php
FieldsServiceInterface.php
FieldTable.php
src/Filesystem/File.php
vendor/defuse/php-encryption/src/File.php
vendor/joomla/filesystem/src/File.php
vendor/paragonie/sodium_compat/namespaced/File.php
vendor/paragonie/sodium_compat/src/File.php
file.php
FileAdapter.php
FileCouldNotBeRead.php
FileExistsException.php
FileField.php
FileLayout.php
FilelistField.php
FileModel.php
administrator/components/com_media/src/Exception/FileNotFoundException.php
libraries/vendor/phpseclib/phpseclib/phpseclib/Exception/FileNotFoundException.php
FilePathRule.php
src/Input/Files.php
vendor/joomla/input/src/Files.php
libraries/src/Cache/Storage/FileStorage.php
libraries/vendor/maximebf/debugbar/src/DebugBar/Storage/FileStorage.php
plugins/system/debug/src/Storage/FileStorage.php
FilesystemException.php
FilesystemHandler.php
FilesystemHelper.php
Filter.php
FilterController.php
FilterModel.php
filters.php
FiltersController.php
FiltersField.php
FiltersModel.php
FilterTable.php
finalisation.php
finaliseconfirm.php
content/finder/finder.php
extension/finder/finder.php
Finder.php
FinderComponent.php
administrator/components/com_finder/src/Helper/FinderHelper.php
components/com_finder/src/Helper/FinderHelper.php
modules/mod_finder/src/Helper/FinderHelper.php
FinderIndexCommand.php
Fingerprint.php
FiniteField.php
Finnish.php
administrator/components/com_users/tmpl/methods/firsttime.php
components/com_users/tmpl/methods/firsttime.php
Fixed.php
FixedTimeProvider.php
FlattenException.php
src/Filesystem/Folder.php
vendor/joomla/filesystem/src/Folder.php
FolderField.php
folderinstaller.php
FolderlistField.php
FolderPathExistsRule.php
FontsField.php
footer.php
Form/Form.php
HTML/Helpers/Form.php
Service/Provider/Form.php
FormatInterface.php
FormattedtextLogger.php
FormatterHelper.php
FormBehavior.php
FormBehaviorTrait.php
FormController.php
FormFactory.php
FormFactoryAwareInterface.php
FormFactoryAwareTrait.php
FormFactoryInterface.php
FormField.php
FormFilterInterface.php
FormHelper.php
components/com_config/src/Model/FormModel.php
components/com_contact/src/Model/FormModel.php
components/com_content/src/Model/FormModel.php
libraries/src/MVC/Model/FormModel.php
FormModelInterface.php
FormRule.php
FormValidateAssetItem.php
FormView.php
ForwardedValidator.php
FrameStub.php
administrator/includes/framework.php
api/includes/framework.php
includes/framework.php
installation/includes/framework.php
French.php
FrenchInflector.php
from.big5.php
from.cp037.php
from.cp1006.php
from.cp1026.php
from.cp424.php
from.cp437.php
from.cp500.php
from.cp737.php
from.cp775.php
from.cp850.php
from.cp852.php
from.cp855.php
from.cp856.php
from.cp857.php
from.cp860.php
from.cp861.php
from.cp862.php
from.cp863.php
from.cp864.php
from.cp865.php
from.cp866.php
from.cp869.php
from.cp874.php
from.cp875.php
from.cp932.php
from.cp936.php
from.cp949.php
from.cp950.php
from.iso-8859-1.php
from.iso-8859-10.php
from.iso-8859-11.php
from.iso-8859-13.php
from.iso-8859-14.php
from.iso-8859-15.php
from.iso-8859-16.php
from.iso-8859-2.php
from.iso-8859-3.php
from.iso-8859-4.php
from.iso-8859-5.php
from.iso-8859-6.php
from.iso-8859-7.php
from.iso-8859-8.php
from.iso-8859-9.php
from.koi8-r.php
from.koi8-u.php
from.us-ascii.php
from.windows-1250.php
from.windows-1251.php
from.windows-1252.php
from.windows-1253.php
from.windows-1254.php
from.windows-1255.php
from.windows-1256.php
from.windows-1257.php
from.windows-1258.php
FromPunycode.php
FromUtf8.php
frontediting_modules.php
FrontendlanguageField.php
src/Client/FtpClient.php
vendor/joomla/filesystem/src/Clients/FtpClient.php
full_image.php
function.php
beberlei/assert/lib/Assert/functions.php
ramsey/uuid/src/functions.php
symfony/string/Resources/functions.php
GeneralizedTime.php
GeneralName.php
GeneralNames.php
GeneralString.php
GeneralSubtree.php
GeneralSubtrees.php
generate_docs.php
generate_max_key_length.php
GenericDataException.php
GenericEvent.php
GenericLanguageInflectorFactory.php
fig/link-util/src/GenericLinkProvider.php
symfony/web-link/GenericLinkProvider.php
GenericObject.php
GenericTag.php
German.php
GetConfigurationCommand.php
GetIconEvent.php
GetMethod.php
GetSetup.php
GithubActionReporter.php
global.php
GlobalFilters.php
GMP.php
GmpCalculator.php
GmpCaster.php
Grapheme.php
GraphicString.php
Grayscale.php
GreaterOrEqualsTo.php
Grid.php
groupclose.php
com_fields/src/Controller/GroupController.php
com_users/src/Controller/GroupController.php
groupedlist-fancy-select.php
groupedlist.php
GroupedlistField.php
com_fields/src/Model/GroupModel.php
com_users/src/Model/GroupModel.php
groupopen.php
GroupparentField.php
groupsclose.php
administrator/components/com_fields/src/Controller/GroupsController.php
administrator/components/com_users/src/Controller/GroupsController.php
api/components/com_fields/src/Controller/GroupsController.php
api/components/com_users/src/Controller/GroupsController.php
groupseparator.php
com_fields/src/Model/GroupsModel.php
com_users/src/Model/GroupsModel.php
groupsopen.php
GroupTable.php
GuidStringCodec.php
Gzip.php
namespaced/Core/Curve25519/H.php
src/Core/Curve25519/H.php
src/Core32/Curve25519/H.php
HalfPrecisionFloatObject.php
authentication/src/Password/HandlerInterface.php
session/src/HandlerInterface.php
phpseclib/phpseclib/phpseclib/Crypt/Hash.php
web-token/jwt-core/Util/Hash.php
HashAlgorithm.php
namespaced/Core/HChaCha20.php
src/Core/HChaCha20.php
src/Core32/HChaCha20.php
header-item.php
header.php
HeaderSecurity.php
HeadertagField.php
HeadRenderer.php
Help.php
HelpButton.php
joomla/console/src/Command/HelpCommand.php
symfony/console/Command/HelpCommand.php
administrator/components/com_finder/src/Indexer/Helper.php
libraries/vendor/enshrined/svg-sanitize/src/Helper.php
libraries/vendor/joomla/filesystem/src/Helper.php
libraries/vendor/symfony/console/Helper/Helper.php
libraries/vendor/typo3/phar-stream-wrapper/src/Helper.php
helper.php
Extension/Service/Provider/HelperFactory.php
Helper/HelperFactory.php
HelperFactoryAwareInterface.php
HelperFactoryAwareTrait.php
HelperFactoryInterface.php
HelperInterface.php
HelperSet.php
HelpModel.php
Hex.php
hidden.php
HiddenField.php
highlight.php
administrator/components/com_contenthistory/src/Controller/HistoryController.php
api/components/com_contenthistory/src/Controller/HistoryController.php
HistoryModel.php
hits.php
HMAC.php
lcobucci/jwt/src/Signer/Hmac.php
web-auth/cose-lib/src/Algorithm/Mac/Hmac.php
HoldInstructionCode.php
horizontal.php
HoursField.php
HS1.php
web-auth/cose-lib/src/Algorithm/Mac/HS256.php
web-token/jwt-signature-algorithm-hmac/HS256.php
HS256_64.php
HS256Truncated64.php
web-auth/cose-lib/src/Algorithm/Mac/HS384.php
web-token/jwt-signature-algorithm-hmac/HS384.php
web-auth/cose-lib/src/Algorithm/Mac/HS512.php
web-token/jwt-signature-algorithm-hmac/HS512.php
namespaced/Core/HSalsa20.php
src/Core/HSalsa20.php
src/Core32/HSalsa20.php
htaccesssvg.php
Html.php
html5.php
HtmlDescriptor.php
HtmlDocument.php
HtmlDumper.php
HtmlErrorRenderer.php
HTMLHelper.php
HTMLRegistry.php
HTMLRegistryAwareTrait.php
HtmlRenderer.php
HtmlResponse.php
administrator/components/com_actionlogs/src/View/Actionlogs/HtmlView.php
administrator/components/com_admin/src/View/Help/HtmlView.php
administrator/components/com_admin/src/View/Sysinfo/HtmlView.php
administrator/components/com_associations/src/View/Association/HtmlView.php
administrator/components/com_associations/src/View/Associations/HtmlView.php
administrator/components/com_banners/src/View/Banner/HtmlView.php
administrator/components/com_banners/src/View/Banners/HtmlView.php
administrator/components/com_banners/src/View/Client/HtmlView.php
administrator/components/com_banners/src/View/Clients/HtmlView.php
administrator/components/com_banners/src/View/Download/HtmlView.php
administrator/components/com_banners/src/View/Tracks/HtmlView.php
administrator/components/com_cache/src/View/Cache/HtmlView.php
administrator/components/com_categories/src/View/Categories/HtmlView.php
administrator/components/com_categories/src/View/Category/HtmlView.php
administrator/components/com_checkin/src/View/Checkin/HtmlView.php
administrator/components/com_config/src/View/Application/HtmlView.php
administrator/components/com_config/src/View/Component/HtmlView.php
administrator/components/com_contact/src/View/Contact/HtmlView.php
administrator/components/com_contact/src/View/Contacts/HtmlView.php
administrator/components/com_content/src/View/Article/HtmlView.php
administrator/components/com_content/src/View/Articles/HtmlView.php
administrator/components/com_content/src/View/Featured/HtmlView.php
administrator/components/com_contenthistory/src/View/Compare/HtmlView.php
administrator/components/com_contenthistory/src/View/History/HtmlView.php
administrator/components/com_contenthistory/src/View/Preview/HtmlView.php
administrator/components/com_cpanel/src/View/Cpanel/HtmlView.php
administrator/components/com_fields/src/View/Field/HtmlView.php
administrator/components/com_fields/src/View/Fields/HtmlView.php
administrator/components/com_fields/src/View/Group/HtmlView.php
administrator/components/com_fields/src/View/Groups/HtmlView.php
administrator/components/com_finder/src/View/Filter/HtmlView.php
administrator/components/com_finder/src/View/Filters/HtmlView.php
administrator/components/com_finder/src/View/Index/HtmlView.php
administrator/components/com_finder/src/View/Indexer/HtmlView.php
administrator/components/com_finder/src/View/Maps/HtmlView.php
administrator/components/com_finder/src/View/Searches/HtmlView.php
administrator/components/com_finder/src/View/Statistics/HtmlView.php
administrator/components/com_installer/src/View/Database/HtmlView.php
administrator/components/com_installer/src/View/Discover/HtmlView.php
administrator/components/com_installer/src/View/Install/HtmlView.php
administrator/components/com_installer/src/View/Installer/HtmlView.php
administrator/components/com_installer/src/View/Languages/HtmlView.php
administrator/components/com_installer/src/View/Manage/HtmlView.php
administrator/components/com_installer/src/View/Update/HtmlView.php
administrator/components/com_installer/src/View/Updatesite/HtmlView.php
administrator/components/com_installer/src/View/Updatesites/HtmlView.php
administrator/components/com_installer/src/View/Warnings/HtmlView.php
administrator/components/com_joomlaupdate/src/View/Joomlaupdate/HtmlView.php
administrator/components/com_joomlaupdate/src/View/Update/HtmlView.php
administrator/components/com_joomlaupdate/src/View/Upload/HtmlView.php
administrator/components/com_languages/src/View/Installed/HtmlView.php
administrator/components/com_languages/src/View/Language/HtmlView.php
administrator/components/com_languages/src/View/Languages/HtmlView.php
administrator/components/com_languages/src/View/Multilangstatus/HtmlView.php
administrator/components/com_languages/src/View/Override/HtmlView.php
administrator/components/com_languages/src/View/Overrides/HtmlView.php
administrator/components/com_login/src/View/Login/HtmlView.php
administrator/components/com_mails/src/View/Template/HtmlView.php
administrator/components/com_mails/src/View/Templates/HtmlView.php
administrator/components/com_media/src/View/File/HtmlView.php
administrator/components/com_media/src/View/Media/HtmlView.php
administrator/components/com_menus/src/View/Item/HtmlView.php
administrator/components/com_menus/src/View/Items/HtmlView.php
administrator/components/com_menus/src/View/Menu/HtmlView.php
administrator/components/com_menus/src/View/Menus/HtmlView.php
administrator/components/com_menus/src/View/Menutypes/HtmlView.php
administrator/components/com_messages/src/View/Config/HtmlView.php
administrator/components/com_messages/src/View/Message/HtmlView.php
administrator/components/com_messages/src/View/Messages/HtmlView.php
administrator/components/com_modules/src/View/Module/HtmlView.php
administrator/components/com_modules/src/View/Modules/HtmlView.php
administrator/components/com_modules/src/View/Select/HtmlView.php
administrator/components/com_newsfeeds/src/View/Newsfeed/HtmlView.php
administrator/components/com_newsfeeds/src/View/Newsfeeds/HtmlView.php
administrator/components/com_plugins/src/View/Plugin/HtmlView.php
administrator/components/com_plugins/src/View/Plugins/HtmlView.php
administrator/components/com_postinstall/src/View/Messages/HtmlView.php
administrator/components/com_privacy/src/View/Capabilities/HtmlView.php
administrator/components/com_privacy/src/View/Consents/HtmlView.php
administrator/components/com_privacy/src/View/Request/HtmlView.php
administrator/components/com_privacy/src/View/Requests/HtmlView.php
administrator/components/com_redirect/src/View/Link/HtmlView.php
administrator/components/com_redirect/src/View/Links/HtmlView.php
administrator/components/com_scheduler/src/View/Select/HtmlView.php
administrator/components/com_scheduler/src/View/Task/HtmlView.php
administrator/components/com_scheduler/src/View/Tasks/HtmlView.php
administrator/components/com_tags/src/View/Tag/HtmlView.php
administrator/components/com_tags/src/View/Tags/HtmlView.php
administrator/components/com_templates/src/View/Style/HtmlView.php
administrator/components/com_templates/src/View/Styles/HtmlView.php
administrator/components/com_templates/src/View/Template/HtmlView.php
administrator/components/com_templates/src/View/Templates/HtmlView.php
administrator/components/com_users/src/View/Captive/HtmlView.php
administrator/components/com_users/src/View/Debuggroup/HtmlView.php
administrator/components/com_users/src/View/Debuguser/HtmlView.php
administrator/components/com_users/src/View/Group/HtmlView.php
administrator/components/com_users/src/View/Groups/HtmlView.php
administrator/components/com_users/src/View/Level/HtmlView.php
administrator/components/com_users/src/View/Levels/HtmlView.php
administrator/components/com_users/src/View/Mail/HtmlView.php
administrator/components/com_users/src/View/Method/HtmlView.php
administrator/components/com_users/src/View/Methods/HtmlView.php
administrator/components/com_users/src/View/Note/HtmlView.php
administrator/components/com_users/src/View/Notes/HtmlView.php
administrator/components/com_users/src/View/User/HtmlView.php
administrator/components/com_users/src/View/Users/HtmlView.php
administrator/components/com_workflow/src/View/Stage/HtmlView.php
administrator/components/com_workflow/src/View/Stages/HtmlView.php
administrator/components/com_workflow/src/View/Transition/HtmlView.php
administrator/components/com_workflow/src/View/Transitions/HtmlView.php
administrator/components/com_workflow/src/View/Workflow/HtmlView.php
administrator/components/com_workflow/src/View/Workflows/HtmlView.php
components/com_config/src/View/Config/HtmlView.php
components/com_config/src/View/Modules/HtmlView.php
components/com_config/src/View/Templates/HtmlView.php
components/com_contact/src/View/Categories/HtmlView.php
components/com_contact/src/View/Category/HtmlView.php
components/com_contact/src/View/Contact/HtmlView.php
components/com_contact/src/View/Featured/HtmlView.php
components/com_contact/src/View/Form/HtmlView.php
components/com_content/src/View/Archive/HtmlView.php
components/com_content/src/View/Article/HtmlView.php
components/com_content/src/View/Categories/HtmlView.php
components/com_content/src/View/Category/HtmlView.php
components/com_content/src/View/Featured/HtmlView.php
components/com_content/src/View/Form/HtmlView.php
components/com_finder/src/View/Search/HtmlView.php
components/com_newsfeeds/src/View/Categories/HtmlView.php
components/com_newsfeeds/src/View/Category/HtmlView.php
components/com_newsfeeds/src/View/Newsfeed/HtmlView.php
components/com_privacy/src/View/Confirm/HtmlView.php
components/com_privacy/src/View/Remind/HtmlView.php
components/com_privacy/src/View/Request/HtmlView.php
components/com_tags/src/View/Tag/HtmlView.php
components/com_tags/src/View/Tags/HtmlView.php
components/com_users/src/View/Captive/HtmlView.php
components/com_users/src/View/Login/HtmlView.php
components/com_users/src/View/Method/HtmlView.php
components/com_users/src/View/Methods/HtmlView.php
components/com_users/src/View/Profile/HtmlView.php
components/com_users/src/View/Registration/HtmlView.php
components/com_users/src/View/Remind/HtmlView.php
components/com_users/src/View/Reset/HtmlView.php
components/com_wrapper/src/View/Wrapper/HtmlView.php
installation/src/View/Error/HtmlView.php
installation/src/View/Preinstall/HtmlView.php
installation/src/View/Remove/HtmlView.php
installation/src/View/Setup/HtmlView.php
libraries/src/MVC/View/HtmlView.php
src/Http/Http.php
vendor/joomla/http/src/Http.php
http_build_url.php
HttpBridgePostRequestMethod.php
HttpDriverInterface.php
src/Http/HttpFactory.php
vendor/joomla/http/src/HttpFactory.php
httpheaders.php
HttpHeaderSerializer.php
HttplugFactory.php
IA5String.php
components/com_content/helpers/icon.php
layouts/joomla/quickicons/icon.php
com_contact/src/Service/HTML/Icon.php
com_content/src/Service/HTML/Icon.php
button/iconclass.php
icon/iconclass.php
toolbar/iconclass.php
Icons.php
icons.php
Iconv.php
IdentifiedBy.php
Identifier.php
Identity.php
IdentityAware.php
IdnaConvertInterface.php
namespaced/Core/ChaCha20/IetfCtx.php
src/Core/ChaCha20/IetfCtx.php
src/Core32/ChaCha20/IetfCtx.php
iframe.php
IgnoreTokenBindingHandler.php
Image.php
layouts/joomla/html/image.php
plugins/editors-xtd/image/image.php
ImageDocument.php
ImageFilter.php
imagelist.php
tmpl/imagelist.php
ImagelistField.php
ImagineCaster.php
ImgStub.php
ImmutableNodeInterface.php
ImmutableNodeTrait.php
ImpmadeField.php
import.legacy.php
import.php
ImportCommand.php
ImptotalField.php
InconsistentSetupException.php
administrator/index.php
administrator/templates/atum/index.php
administrator/templates/system/index.php
api/index.php
index.php
installation/index.php
installation/template/index.php
templates/cassiopeia/index.php
templates/system/index.php
IndexController.php
Indexer.php
IndexerController.php
IndexerModel.php
IndexModel.php
InfiniteListObject.php
InfiniteMapObject.php
English/Inflectible.php
French/Inflectible.php
NorwegianBokmal/Inflectible.php
Portuguese/Inflectible.php
Spanish/Inflectible.php
Turkish/Inflectible.php
doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php
doctrine/inflector/lib/Doctrine/Inflector/Inflector.php
joomla/string/src/Inflector.php
InflectorFactory.php
Rules/English/InflectorFactory.php
Rules/French/InflectorFactory.php
Rules/NorwegianBokmal/InflectorFactory.php
Rules/Portuguese/InflectorFactory.php
Rules/Spanish/InflectorFactory.php
Rules/Turkish/InflectorFactory.php
InflectorInterface.php
info_block.php
InfoCollector.php
Ini.php
InjectContentTypeTrait.php
Inline.php
inlinehelp.php
InlinehelpButton.php
InMemory.php
InMemoryLogger.php
src/Input/Input.php
vendor/joomla/input/src/Input.php
vendor/symfony/console/Input/Input.php
InputArgument.php
InputAwareHelper.php
InputAwareInterface.php
InputDefinition.php
src/Filter/InputFilter.php
vendor/joomla/filter/src/InputFilter.php
InputInterface.php
InputOption.php
InstallationApplication.php
InstallationController.php
InstallationRouter.php
InstallController.php
installed.php
InstalledController.php
InstalledModel.php
InstalledVersions.php
Installer.php
administrator/components/com_installer/helpers/installer.php
plugins/webservices/installer/installer.php
InstallerAdapter.php
InstallerComponent.php
InstallerExtension.php
administrator/components/com_installer/src/Helper/InstallerHelper.php
libraries/src/Installer/InstallerHelper.php
InstallerModel.php
InstallerScript.php
InstallerScriptInterface.php
InstallModel.php
InsufficientSetupException.php
Int32.php
Int64.php
IntarrayFilter.php
integer.php
tmpl/integer.php
fgrosse/phpasn1/lib/ASN1/Universal/Integer.php
phpseclib/phpseclib/phpseclib/Math/BinaryField/Integer.php
phpseclib/phpseclib/phpseclib/Math/Common/FiniteField/Integer.php
phpseclib/phpseclib/phpseclib/Math/PrimeField/Integer.php
IntegerField.php
IntegerOverflowException.php
IntervalField.php
IntlCaster.php
intro_image.php
introduction.php
InvalidActionException.php
InvalidArgument.php
beberlei/assert/lib/Assert/InvalidArgumentException.php
laminas/laminas-diactoros/src/Exception/InvalidArgumentException.php
psr/log/Psr/Log/InvalidArgumentException.php
symfony/console/Exception/InvalidArgumentException.php
symfony/options-resolver/Exception/InvalidArgumentException.php
symfony/string/Exception/InvalidArgumentException.php
webmozart/assert/src/InvalidArgumentException.php
InvalidCharacterException.php
InvalidCredentialsException.php
InvalidHeader.php
InvalidIdnVersionException.php
InvalidityDate.php
InvalidKeyException.php
InvalidKeyProvided.php
InvalidKeyTypeException.php
InvalidLanguage.php
InvalidMediaType.php
InvalidOptionException.php
InvalidOptionsException.php
InvalidParameterException.php
src/Error/JsonApi/InvalidParameterExceptionHandler.php
vendor/tobscure/json-api/src/Exception/Handler/InvalidParameterExceptionHandler.php
InvalidPathException.php
InvalidResponseCodeException.php
InvalidRouteExceptionHandler.php
InvalidSessionException.php
InvalidStreamPointerPositionException.php
InvalidTokenStructure.php
InvalidUuidStringException.php
IOException.php
IPAddress.php
IpHelper.php
IssuedBy.php
IssuerAltName.php
IssuingDistributionPoint.php
Italian.php
item.php
Item.php
ItemController.php
ItemlanguageField.php
administrator/components/com_menus/src/Model/ItemModel.php
libraries/src/MVC/Model/ItemModel.php
ItemModelInterface.php
administrator/components/com_menus/src/Controller/ItemsController.php
api/components/com_menus/src/Controller/ItemsController.php
ItemsModel.php
ItemtypeField.php
ItunesRssParser.php
libraries/vendor/maximebf/debugbar/src/DebugBar/JavascriptRenderer.php
plugins/system/debug/src/JavascriptRenderer.php
JGrid.php
jooa11y.php
Joomla.php
cli/joomla.php
plugins/authentication/joomla/joomla.php
plugins/content/joomla/joomla.php
plugins/extension/joomla/joomla.php
plugins/user/joomla/joomla.php
JoomlaHttpDriver.php
JoomlaSerializer.php
JoomlaStorage.php
JoomlatokenField.php
Joomlaupdate.php
Jquery.php
json-exception-polyfill.php
src/Input/Json.php
vendor/joomla/input/src/Json.php
vendor/joomla/registry/src/Format/Json.php
JsonapiDocument.php
JsonapiRenderer.php
JsonApiView.php
com_banners/src/View/Banners/JsonapiView.php
com_banners/src/View/Clients/JsonapiView.php
com_categories/src/View/Categories/JsonapiView.php
com_config/src/View/Application/JsonapiView.php
com_config/src/View/Component/JsonapiView.php
com_contact/src/View/Contacts/JsonapiView.php
com_content/src/View/Articles/JsonapiView.php
com_contenthistory/src/View/History/JsonapiView.php
com_fields/src/View/Fields/JsonapiView.php
com_fields/src/View/Groups/JsonapiView.php
com_installer/src/View/Manage/JsonapiView.php
com_languages/src/View/Languages/JsonapiView.php
com_languages/src/View/Overrides/JsonapiView.php
com_languages/src/View/Strings/JsonapiView.php
com_media/src/View/Adapters/JsonapiView.php
com_media/src/View/Media/JsonapiView.php
com_menus/src/View/Items/JsonapiView.php
com_menus/src/View/Menus/JsonapiView.php
com_messages/src/View/Messages/JsonapiView.php
com_modules/src/View/Modules/JsonapiView.php
com_newsfeeds/src/View/Feeds/JsonapiView.php
com_plugins/src/View/Plugins/JsonapiView.php
com_privacy/src/View/Consents/JsonapiView.php
com_privacy/src/View/Requests/JsonapiView.php
com_redirect/src/View/Redirect/JsonapiView.php
com_tags/src/View/Tags/JsonapiView.php
com_templates/src/View/Styles/JsonapiView.php
com_users/src/View/Groups/JsonapiView.php
com_users/src/View/Levels/JsonapiView.php
com_users/src/View/Users/JsonapiView.php
JSONController.php
JsonConverter.php
JsonDescriptor.php
JsonDocument.php
JsonException.php
JSONFlattenedSerializer.php
JSONGeneralSerializer.php
installation/src/Error/Renderer/JsonRenderer.php
libraries/src/Error/Renderer/JsonRenderer.php
installation/src/Response/JsonResponse.php
libraries/src/Response/JsonResponse.php
libraries/vendor/laminas/laminas-diactoros/src/Response/JsonResponse.php
administrator/components/com_admin/src/View/Sysinfo/JsonView.php
administrator/components/com_templates/src/View/Style/JsonView.php
libraries/src/MVC/View/JsonView.php
JWK.php
JWKSet.php
JWS.php
JWSBuilder.php
JWSBuilderFactory.php
JWSLoader.php
JWSLoaderFactory.php
JWSSerializer.php
JWSSerializerManager.php
JWSSerializerManagerFactory.php
JWSTokenSupport.php
JWSVerifier.php
JWSVerifierFactory.php
JWT.php
KeepaliveAssetItem.php
defuse/php-encryption/src/Key.php
joomla/crypt/src/Key.php
lcobucci/jwt/src/Signer/Key.php
web-auth/cose-lib/src/Key/Key.php
Keychain.php
KeyChecker.php
KeyIdentifier.php
KeyNotFoundException.php
KeyOrPassword.php
KeyProtectedByPassword.php
KeyPurposeId.php
KeyUsage.php
KnownButtons.php
KoblitzPrime.php
system/privacyconsent/label.php
user/terms/label.php
LangActiveAssetItem.php
langforum.php
administrator/components/com_finder/src/Indexer/Language.php
libraries/src/Language/Language.php
libraries/src/Service/Provider/Language.php
libraries/src/Table/Language.php
libraries/vendor/doctrine/inflector/lib/Doctrine/Inflector/Language.php
administrator/components/com_finder/helpers/language.php
layouts/joomla/content/language.php
layouts/joomla/html/batch/language.php
languageaccess340.php
LanguageAdapter.php
LanguageclientField.php
languagecode.php
administrator/components/com_languages/src/Controller/LanguageController.php
installation/src/Controller/LanguageController.php
LanguageErrorsCollector.php
LanguageFactory.php
LanguageFactoryInterface.php
installation/src/Form/Field/Installation/LanguageField.php
libraries/src/Form/Field/LanguageField.php
LanguageFilesCollector.php
languagefilter.php
administrator/components/com_finder/src/Helper/LanguageHelper.php
libraries/src/Language/LanguageHelper.php
LanguageInflectorFactory.php
LanguageModel.php
LanguageNegotiator.php
languages.php
Languages.php
LanguagesComponent.php
administrator/components/com_languages/src/Controller/LanguagesController.php
api/components/com_languages/src/Controller/LanguagesController.php
administrator/components/com_languages/src/Helper/LanguagesHelper.php
modules/mod_languages/src/Helper/LanguagesHelper.php
administrator/components/com_installer/src/Model/LanguagesModel.php
administrator/components/com_languages/src/Model/LanguagesModel.php
installation/src/Model/LanguagesModel.php
LanguageStringsCollector.php
LastvisitdaterangeField.php
LatestActionsHelper.php
LatestHelper.php
LayoutHelper.php
LayoutInterface.php
LazyAssertion.php
LazyAssertionException.php
LazyCommand.php
LazyServiceEventListener.php
LazyString.php
lcobucci-clock-polyfill.php
ldap.php
Ldap.php
LdapAuthenticator.php
LdapBadge.php
LdapClient.php
LdapException.php
LdapInterface.php
LdapUser.php
LdapUserProvider.php
LeewayCannotBeNegative.php
LegacyComponent.php
LegacyComponentDispatcher.php
LegacyFactory.php
LegacyInstallerScript.php
LegacyModelLoaderTrait.php
LengthCalculator.php
LesserOrEqualsTo.php
LevelController.php
LevelModel.php
administrator/components/com_users/src/Controller/LevelsController.php
api/components/com_users/src/Controller/LevelsController.php
LevelsField.php
LevelsModel.php
LibraryAdapter.php
LibraryHelper.php
LibraryManifest.php
libsodium.php
LimitableInterface.php
LimitboxField.php
fig/link-util/src/Link.php
symfony/web-link/Link.php
links/link.php
pagination/link.php
toolbar/link.php
LinkButton.php
LinkController.php
LinkInterface.php
LinkModel.php
LinkProviderInterface.php
LinkProviderTrait.php
Links.php
links.php
LinksController.php
LinksModel.php
LinksTrait.php
LinkStub.php
com_finder/src/Table/LinkTable.php
com_redirect/src/Table/LinkTable.php
LinkTrait.php
LintCommand.php
list-fancy-select.php
administrator/components/com_users/tmpl/methods/list.php
components/com_tags/tmpl/tag/list.php
components/com_users/tmpl/methods/list.php
layouts/joomla/form/field/list.php
layouts/joomla/pagination/list.php
layouts/joomla/searchtools/default/list.php
plugins/fields/list/list.php
plugins/fields/list/tmpl/list.php
list_items.php
joomla/console/src/Command/ListCommand.php
symfony/console/Command/ListCommand.php
ListenersPriorityQueue.php
ListField.php
ListHelper.php
ListModel.php
ListModelInterface.php
ListObject.php
ListUserCommand.php
ListView.php
loader.php
LoaderInterface.php
loadmodule.php
local.php
LocalAdapter.php
LocalFileReference.php
administrator/language/en-GB/localise.php
administrator/language/fr-FR/localise.php
language/en-GB/localise.php
language/fr-FR/localise.php
LocalizationCollector.php
LocalStrategy.php
LocationField.php
LockableTrait.php
log.php
Log.php
LogcreatorField.php
LogEntry.php
LoggedHelper.php
Log/Logger.php
Service/Provider/Logger.php
LoggerAwareInterface.php
LoggerAwareTrait.php
LoggerInterface.php
LoggerRegistry.php
LoggerTrait.php
LoggingMonitor.php
LogicException.php
login.php
administrator/modules/mod_login/src/Helper/LoginHelper.php
modules/mod_login/src/Helper/LoginHelper.php
administrator/components/com_login/src/Model/LoginModel.php
components/com_users/src/Model/LoginModel.php
LoginUniqueFieldRule.php
LogLevel.php
logout.php
LogoutUniqueFieldRule.php
logrotation.php
logs.html.php
LogsdaterangeField.php
LogtypeField.php
lowerCase.php
Mac.php
MacAlgorithm.php
Mail.php
MailController.php
MailDisabledException.php
MailHelper.php
MailModel.php
MailsHelper.php
MailTemplate.php
main.php
manage.php
Manage.php
administrator/components/com_installer/src/Controller/ManageController.php
api/components/com_installer/src/Controller/ManageController.php
ManageModel.php
typo3/phar-stream-wrapper/src/Manager.php
web-auth/cose-lib/src/Algorithm/Manager.php
ManagerFactory.php
src/Installer/Manifest.php
vendor/typo3/phar-stream-wrapper/src/Phar/Manifest.php
MapItem.php
MapObject.php
MapsController.php
MapsModel.php
MapTable.php
MarkdownDescriptor.php
marshal_headers_from_sapi.legacy.php
marshal_headers_from_sapi.php
marshal_method_from_sapi.legacy.php
marshal_method_from_sapi.php
marshal_protocol_version_from_sapi.legacy.php
marshal_protocol_version_from_sapi.php
marshal_uri_from_sapi.legacy.php
marshal_uri_from_sapi.php
MaskGenAlgorithm.php
MathException.php
Mbstring.php
Mcrypt.php
MD5Handler.php
administrator/components/com_media/helpers/media.php
layouts/joomla/form/field/media.php
plugins/fields/media/media.php
plugins/fields/media/tmpl/media.php
plugins/webservices/media/media.php
MediaActionPlugin.php
MediaController.php
MediaField.php
MediaHelper.php
administrator/components/com_media/src/Model/MediaModel.php
api/components/com_media/src/Model/MediaModel.php
MediaProviderEvent.php
MediaRssParser.php
MediumModel.php
MemcachedCaster.php
MemcachedHandler.php
src/Cache/Storage/MemcachedStorage.php
vendor/maximebf/debugbar/src/DebugBar/Storage/MemcachedStorage.php
MemoryCollector.php
menu.php
administrator/modules/mod_submenu/src/Menu/Menu.php
libraries/src/HTML/Helpers/Menu.php
libraries/src/Service/Provider/Menu.php
libraries/src/Table/Menu.php
MenuController.php
MenuFactory.php
MenuFactoryInterface.php
administrator/components/com_menus/src/Field/Modal/MenuField.php
libraries/src/Form/Field/MenuField.php
MenuHelper.php
MenuItem.php
MenuItemByTypeField.php
MenuitemField.php
MenuModel.php
MenuOrderingField.php
MenuParentField.php
MenuPresetField.php
MenuRules.php
Menus.php
administrator/components/com_menus/helpers/menus.php
plugins/webservices/menus/menus.php
MenusComponent.php
administrator/components/com_menus/src/Controller/MenusController.php
api/components/com_menus/src/Controller/MenusController.php
MenusHelper.php
MenusModel.php
MenuTable.php
MenuType.php
MenutypeField.php
MenutypesModel.php
MenuTypeTable.php
layouts/joomla/system/message.php
layouts/plugins/system/privacyconsent/message.php
layouts/plugins/user/terms/message.php
plugins/privacy/message/message.php
plugins/system/stats/layouts/message.php
com_messages/src/Controller/MessageController.php
com_postinstall/src/Controller/MessageController.php
MessageFactory.php
MessageInterface.php
MessageModel.php
MessagequeueLogger.php
MessageRenderer.php
messages.php
Messages.php
MessagesAggregateInterface.php
MessagesCollector.php
MessagesComponent.php
administrator/components/com_messages/src/Controller/MessagesController.php
api/components/com_messages/src/Controller/MessagesController.php
MessagesHelper.php
com_messages/src/Model/MessagesModel.php
com_postinstall/src/Model/MessagesModel.php
MessageStatesField.php
MessageTable.php
laminas/laminas-diactoros/src/MessageTrait.php
nyholm/psr7/src/MessageTrait.php
metadata.php
MetadataManager.php
MetadataManagerListener.php
MetadataRepository.php
MetadataService.php
MetadataServiceFactory.php
MetadataStatement.php
MetadataStatementFetcher.php
MetadataStatementRepository.php
MetadataTOCPayload.php
MetadataTOCPayloadEntry.php
MetasRenderer.php
MetaTrait.php
meter.php
MeterField.php
administrator/components/com_users/src/Controller/MethodController.php
components/com_users/src/Controller/MethodController.php
MethodDescriptor.php
administrator/components/com_users/src/Model/MethodModel.php
components/com_users/src/Model/MethodModel.php
MethodNotAllowedException.php
administrator/components/com_users/src/Controller/MethodsController.php
components/com_users/src/Controller/MethodsController.php
administrator/components/com_users/src/Model/MethodsModel.php
components/com_users/src/Model/MethodsModel.php
Mfa.php
MfaTable.php
Microdata.php
MinutesField.php
MissingComponentException.php
MissingInputException.php
MissingOptionsException.php
Mixin.php
mod_articles_archive.php
mod_articles_categories.php
mod_articles_category.php
mod_articles_popular.php
mod_banners.php
mod_breadcrumbs.php
administrator/modules/mod_custom/mod_custom.php
modules/mod_custom/mod_custom.php
administrator/modules/mod_feed/mod_feed.php
modules/mod_feed/mod_feed.php
mod_finder.php
mod_footer.php
mod_frontend.php
mod_languages.php
mod_latest.php
mod_latestactions.php
mod_logged.php
administrator/modules/mod_login/mod_login.php
modules/mod_login/mod_login.php
mod_loginsupport.php
administrator/modules/mod_menu/mod_menu.php
modules/mod_menu/mod_menu.php
mod_messages.php
mod_multilangstatus.php
mod_popular.php
mod_post_installation_messages.php
mod_privacy_dashboard.php
mod_privacy_status.php
mod_random_image.php
mod_related_items.php
mod_sampledata.php
mod_stats.php
mod_stats_admin.php
mod_submenu.php
mod_syndicate.php
mod_tags_popular.php
mod_tags_similar.php
mod_title.php
mod_toolbar.php
mod_user.php
mod_users_latest.php
mod_version.php
mod_whosonline.php
mod_wrapper.php
administrator/components/com_associations/tmpl/associations/modal.php
administrator/components/com_categories/tmpl/categories/modal.php
administrator/components/com_categories/tmpl/category/modal.php
administrator/components/com_contact/tmpl/contact/modal.php
administrator/components/com_contact/tmpl/contacts/modal.php
administrator/components/com_content/tmpl/article/modal.php
administrator/components/com_content/tmpl/articles/modal.php
administrator/components/com_contenthistory/tmpl/history/modal.php
administrator/components/com_fields/tmpl/fields/modal.php
administrator/components/com_menus/tmpl/item/modal.php
administrator/components/com_menus/tmpl/items/modal.php
administrator/components/com_modules/tmpl/module/modal.php
administrator/components/com_modules/tmpl/modules/modal.php
administrator/components/com_modules/tmpl/select/modal.php
administrator/components/com_newsfeeds/tmpl/newsfeed/modal.php
administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php
administrator/components/com_plugins/tmpl/plugin/modal.php
administrator/components/com_scheduler/tmpl/select/modal.php
administrator/components/com_users/tmpl/notes/modal.php
administrator/components/com_users/tmpl/users/modal.php
layouts/joomla/editors/buttons/modal.php
ModelInterface.php
modify_date.php
module.php
src/Extension/Module.php
src/Extension/Service/Provider/Module.php
src/Table/Module.php
vendor/laminas/laminas-diactoros/src/Module.php
vendor/laminas/laminas-zendframework-bridge/src/Module.php
ModuleAdapter.php
ModuleController.php
ModuleDispatcher.php
Dispatcher/ModuleDispatcherFactory.php
Extension/Service/Provider/ModuleDispatcherFactory.php
ModuleDispatcherFactoryInterface.php
ModuleHelper.php
ModuleInterface.php
ModulelayoutField.php
ModuleLayoutRule.php
ModuleModel.php
moduleorder.php
ModuleorderField.php
ModulepositionField.php
ModuleRenderer.php
Modules.php
administrator/components/com_modules/helpers/modules.php
plugins/webservices/modules/modules.php
ModulesComponent.php
administrator/components/com_modules/src/Controller/ModulesController.php
api/components/com_modules/src/Controller/ModulesController.php
components/com_config/src/Controller/ModulesController.php
ModulesHelper.php
administrator/components/com_modules/src/Model/ModulesModel.php
components/com_config/src/Model/ModulesModel.php
ModulesModuleField.php
modulespositionedit.php
ModulesPositioneditField.php
com_modules/src/Field/ModulesPositionField.php
com_users/src/Field/ModulesPositionField.php
ModulesRenderer.php
ModuletagField.php
MonologCollector.php
Crypt/EC/BaseCurves/Montgomery.php
Math/BigInteger/Engines/PHP/Montgomery.php
Math/BigInteger/Engines/PHP/Reductions/Montgomery.php
MontgomeryMult.php
MontgomeryPrivate.php
MontgomeryPublic.php
MonthField.php
MSBLOB.php
MtRandGenerator.php
MultibyteStringConverter.php
multifactorauth.php
MultiFactorAuthenticationHandler.php
multilang.php
MultilangstatusHelper.php
Multilanguage.php
MVCComponent.php
Extension/Service/Provider/MVCFactory.php
MVC/Factory/MVCFactory.php
MVCFactoryAwareTrait.php
MVCFactoryInterface.php
MVCFactoryServiceInterface.php
MVCFactoryServiceTrait.php
MysqlChangeItem.php
MysqlDriver.php
MysqlExporter.php
MysqliCaster.php
MysqliDriver.php
MysqliExporter.php
MysqliImporter.php
MysqlImporter.php
MysqliQuery.php
MysqliStatement.php
MysqlQuery.php
MysqlQueryBuilder.php
Name.php
NameConstraints.php
NamePrep.php
NamePrepData2003.php
NamePrepData2008.php
NamePrepDataInterface.php
NamePrepInterface.php
namespaced.php
NamespacedTwigProfileCollector.php
libraries/namespacemap.php
plugins/extension/namespacemap/namespacemap.php
joomla/console/src/Exception/NamespaceNotFoundException.php
symfony/console/Exception/NamespaceNotFoundException.php
NamespaceParserInterface.php
NativeCalculator.php
NativeStorage.php
navigation.php
Negate.php
NegativeBigIntegerTag.php
NegativeNumberException.php
Negotiator.php
Nested.php
NestingException.php
netscape_ca_policy_url.php
netscape_cert_type.php
netscape_comment.php
NetworkAddress.php
NetworkExceptionInterface.php
NewsfeedController.php
NewsfeedField.php
administrator/components/com_newsfeeds/src/Model/NewsfeedModel.php
components/com_newsfeeds/src/Model/NewsfeedModel.php
administrator/components/com_newsfeeds/helpers/newsfeeds.php
plugins/finder/newsfeeds/newsfeeds.php
plugins/webservices/newsfeeds/newsfeeds.php
NewsfeedsComponent.php
NewsfeedsController.php
NewsfeedSerializer.php
NewsfeedsField.php
NewsfeedsHelper.php
NewsfeedsModel.php
NewsfeedTable.php
nistb233.php
nistb409.php
nistk163.php
nistk233.php
nistk283.php
nistk409.php
nistp192.php
nistp224.php
nistp256.php
nistp384.php
nistp521.php
nistt571.php
noCard.php
NoConfigurationException.php
NoConstraintsGiven.php
NodeInterface.php
NodeProviderInterface.php
NodeTrait.php
noitems.php
NoKeyLoadedException.php
NomenuRules.php
lcobucci/jwt/src/Signer/None.php
web-token/jwt-signature-algorithm-none/None.php
layouts/chromes/none.php
plugins/editors/none/none.php
NoneAttestationStatementSupport.php
NoopWordInflector.php
Normalise.php
normalize_server.legacy.php
normalize_server.php
normalize_uploaded_files.legacy.php
normalize_uploaded_files.php
Normalizer.php
Resources/stubs/Normalizer.php
Norwegian.php
NoSuchOptionException.php
NoSupportedAlgorithmsException.php
NotAcceptable.php
NotAcceptableExceptionHandler.php
NotAllowed.php
NotAllowedExceptionHandler.php
NotBoundException.php
NoteController.php
NoteField.php
NoteModel.php
NotequalsRule.php
NotesController.php
NotesModel.php
NoteTable.php
NotFoundException.php
NotFoundExceptionInterface.php
NoticeReference.php
notification.php
NotifyActionLog.php
NotImplementedException.php
noupdate.php
NullLogger.php
fgrosse/phpasn1/lib/ASN1/Universal/NullObject.php
spomky-labs/cbor-php/src/OtherObject/NullObject.php
NullOutput.php
NullOutputFormatter.php
NullOutputFormatterStyle.php
Number.php
number.php
NumberConverterInterface.php
NumberField.php
NumberFormatException.php
NumberRule.php
NumericString.php
NumericUserIdentifier.php
OAuth.php
OAuthCallbackEvent.php
OAuthTokenProvider.php
ObjectCreateEvent.php
ObjectDescriptor.php
ObjectIdentifier.php
OctetString.php
cassiopeia/offline.php
system/offline.php
OID.php
OkpKey.php
OneAsymmetricKey.php
OnGetApiAttributes.php
OnGetApiFields.php
OnGetApiRelation.php
OpenHandler.php
OpensearchDocument.php
OpensearchImage.php
OpensearchUrl.php
OpensearchView.php
Common/Formats/Keys/OpenSSH.php
DSA/Formats/Keys/OpenSSH.php
EC/Formats/Keys/OpenSSH.php
RSA/Formats/Keys/OpenSSH.php
src/Encrypt/AES/OpenSSL.php
vendor/joomla/crypt/src/Cipher/OpenSSL.php
vendor/lcobucci/jwt/src/Signer/OpenSSL.php
vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/BCMath/OpenSSL.php
vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/OpenSSL.php
vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/PHP/OpenSSL.php
OpenSslGenerator.php
OptionConfigurator.php
OptionDefinitionException.php
Options.php
options_default.php
OptionsResolver.php
OptionsResolverIntrospector.php
OptionsRule.php
ORAddress.php
joomla/string/src/phputf8/ord.php
voku/portable-utf8/src/voku/helper/data/ord.php
OrderedTimeCodec.php
OrderingField.php
OrganizationalUnitNames.php
OrganizationName.php
Original.php
OtherObject.php
OtherObjectManager.php
OtherPrimeInfo.php
OtherPrimeInfos.php
outline.php
OutOfMemoryError.php
Output.php
OutputController.php
src/Filter/OutputFilter.php
vendor/joomla/filter/src/OutputFilter.php
OutputFormatter.php
OutputFormatterInterface.php
OutputFormatterStyle.php
OutputFormatterStyleInterface.php
OutputFormatterStyleStack.php
OutputInterface.php
OutputStyle.php
override.php
overridecheck.php
OverrideController.php
OverrideModel.php
administrator/components/com_languages/src/Controller/OverridesController.php
api/components/com_languages/src/Controller/OverridesController.php
OverridesModel.php
namespaced/Core/Curve25519/Ge/P1p1.php
src/Core/Curve25519/Ge/P1p1.php
src/Core32/Curve25519/Ge/P1p1.php
namespaced/Core/Curve25519/Ge/P2.php
src/Core/Curve25519/Ge/P2.php
src/Core32/Curve25519/Ge/P2.php
namespaced/Core/Curve25519/Ge/P3.php
src/Core/Curve25519/Ge/P3.php
src/Core32/Curve25519/Ge/P3.php
PackageAdapter.php
PackageField.php
packageinstaller.php
PackageManifest.php
PackedAttestationStatementSupport.php
administrator/components/com_content/tmpl/article/pagebreak.php
plugins/content/pagebreak/pagebreak.php
plugins/editors-xtd/pagebreak/pagebreak.php
PageController.php
pagenavigation.php
Pagination.php
PaginationObject.php
phpseclib/phpseclib/phpseclib/Crypt/DH/Parameters.php
phpseclib/phpseclib/phpseclib/Crypt/DSA/Parameters.php
phpseclib/phpseclib/phpseclib/Crypt/EC/Parameters.php
tobscure/json-api/src/Parameters.php
ParameterType.php
params.php
parent_category.php
Parsable.php
parse_cookie_header.legacy.php
parse_cookie_header.php
ParseException.php
administrator/components/com_finder/src/Indexer/Parser.php
libraries/vendor/lcobucci/jwt/src/Parser.php
libraries/vendor/symfony/yaml/Parser.php
parser.php
ParserException.php
password.php
PasswordField.php
PasswordHash.php
PasswordProtected.php
PasswordRule.php
src/Filesystem/Patcher.php
vendor/joomla/filesystem/src/Patcher.php
src/Filesystem/Path.php
vendor/joomla/filesystem/src/Path.php
Pathway/Pathway.php
Service/Provider/Pathway.php
Pattern.php
PatternAccuracyDescriptor.php
patterns.php
Patterns.php
PBEParameter.php
PBES2params.php
PBKDF2params.php
PBMAC1params.php
PdoCaster.php
PDOCollector.php
PdoDriver.php
PdoQuery.php
PdoStatement.php
PdoStorage.php
PeclUuidRandomGenerator.php
PeclUuidTimeGenerator.php
Pentanomial.php
PermittedFor.php
PersonalName.php
PgSqlCaster.php
PgsqlDriver.php
PgsqlExporter.php
PgsqlImporter.php
PgsqlQuery.php
PharExtensionInterceptor.php
PharInvocation.php
PharInvocationCollection.php
PharInvocationResolver.php
PharMetaDataInterceptor.php
PharStreamWrapper.php
PHP.php
Php.php
PHP32.php
PHP64.php
Php72.php
php72compat.php
php72compat_const.php
Php73.php
Php80.php
PHPassHandler.php
PhpHttpDriver.php
PhpInfoCollector.php
PhpInputStream.php
phpmailer.lang-en_gb.php
PHPMailer.php
PhpSetting.php
PhpTimeConverter.php
PhpToken.php
Resources/stubs/PhpToken.php
phpversioncheck.php
PKCS.php
Common/Formats/Keys/PKCS1.php
DH/Formats/Keys/PKCS1.php
DSA/Formats/Keys/PKCS1.php
EC/Formats/Keys/PKCS1.php
RSA/Formats/Keys/PKCS1.php
Common/Formats/Keys/PKCS8.php
DH/Formats/Keys/PKCS8.php
DSA/Formats/Keys/PKCS8.php
EC/Formats/Keys/PKCS8.php
RSA/Formats/Keys/PKCS8.php
PKCS9String.php
Plain.php
platform_check.php
PluginAdapter.php
com_media/src/Controller/PluginController.php
com_plugins/src/Controller/PluginController.php
PluginElementField.php
PluginHelper.php
PlugininfoField.php
PluginInterface.php
PluginModel.php
PluginorderingField.php
administrator/components/com_plugins/helpers/plugins.php
plugins/webservices/plugins/plugins.php
administrator/components/com_plugins/src/Controller/PluginsController.php
api/components/com_plugins/src/Controller/PluginsController.php
PluginsField.php
PluginsHelper.php
PluginsModel.php
PluginstatusField.php
PluginTypeField.php
PolicyInformation.php
PolicyMappings.php
PolicyQualifierId.php
PolicyQualifierInfo.php
namespaced/Core/Poly1305.php
src/Core/Poly1305.php
src/Core32/Poly1305.php
POP3.php
PopularHelper.php
popup.php
PopupButton.php
Portuguese.php
position.php
PositionsModel.php
PositiveBigIntegerTag.php
Post.php
PostalAddress.php
PostgresqlChangeItem.php
PostgresqlQueryBuilder.php
PostinstallHelper.php
PowerOfTwo.php
namespaced/Core/Curve25519/Ge/Precomp.php
src/Core/Curve25519/Ge/Precomp.php
src/Core32/Curve25519/Ge/Precomp.php
PredefinedlistField.php
PrefixField.php
PrefixRule.php
PreloadManager.php
PreloadManagerInterface.php
PreparableInterface.php
PrepareStatementFailureException.php
preupdatecheck.php
preview.php
PreviewController.php
PreviewModel.php
Prime.php
prime192v1.php
prime192v2.php
prime192v3.php
prime239v1.php
prime239v2.php
prime239v3.php
prime256v1.php
Prime_p.php
PrimeField.php
PrintableString.php
Priority.php
privacy.php
Privacy.php
privacycheck.php
PrivacyComponent.php
privacyconsent.php
PrivacyDashboardHelper.php
PrivacyField.php
PrivacyHelper.php
PrivacyPlugin.php
PrivacyStatusHelper.php
PrivateDomainName.php
fgrosse/phpasn1/lib/X509/PrivateKey.php
phpseclib/phpseclib/phpseclib/Crypt/Common/PrivateKey.php
phpseclib/phpseclib/phpseclib/Crypt/DH/PrivateKey.php
phpseclib/phpseclib/phpseclib/Crypt/DSA/PrivateKey.php
phpseclib/phpseclib/phpseclib/Crypt/EC/PrivateKey.php
phpseclib/phpseclib/phpseclib/Crypt/RSA/PrivateKey.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PrivateKey.php
PrivateKeyInfo.php
PrivateKeyUsagePeriod.php
ProcessHelper.php
ProcessorInterface.php
profile.php
ProfileCollector.php
ProfileController.php
ProfileModel.php
Profiler.php
ProgressBar.php
ProgressIndicator.php
Propel2Collector.php
PropelCollector.php
ProtectedKeyException.php
administrator/components/com_actionlogs/services/provider.php
administrator/components/com_admin/services/provider.php
administrator/components/com_associations/services/provider.php
administrator/components/com_banners/services/provider.php
administrator/components/com_cache/services/provider.php
administrator/components/com_categories/services/provider.php
administrator/components/com_checkin/services/provider.php
administrator/components/com_config/services/provider.php
administrator/components/com_contact/services/provider.php
administrator/components/com_content/services/provider.php
administrator/components/com_contenthistory/services/provider.php
administrator/components/com_cpanel/services/provider.php
administrator/components/com_fields/services/provider.php
administrator/components/com_finder/services/provider.php
administrator/components/com_installer/services/provider.php
administrator/components/com_joomlaupdate/services/provider.php
administrator/components/com_languages/services/provider.php
administrator/components/com_login/services/provider.php
administrator/components/com_mails/services/provider.php
administrator/components/com_media/services/provider.php
administrator/components/com_menus/services/provider.php
administrator/components/com_messages/services/provider.php
administrator/components/com_modules/services/provider.php
administrator/components/com_newsfeeds/services/provider.php
administrator/components/com_plugins/services/provider.php
administrator/components/com_postinstall/services/provider.php
administrator/components/com_privacy/services/provider.php
administrator/components/com_redirect/services/provider.php
administrator/components/com_scheduler/services/provider.php
administrator/components/com_tags/services/provider.php
administrator/components/com_templates/services/provider.php
administrator/components/com_users/services/provider.php
administrator/components/com_workflow/services/provider.php
administrator/components/com_wrapper/services/provider.php
administrator/modules/mod_quickicon/services/provider.php
modules/mod_articles_latest/services/provider.php
modules/mod_articles_news/services/provider.php
plugins/actionlog/joomla/services/provider.php
plugins/api-authentication/basic/services/provider.php
plugins/api-authentication/token/services/provider.php
plugins/behaviour/taggable/services/provider.php
plugins/behaviour/versionable/services/provider.php
plugins/multifactorauth/email/services/provider.php
plugins/multifactorauth/fixed/services/provider.php
plugins/multifactorauth/totp/services/provider.php
plugins/multifactorauth/webauthn/services/provider.php
plugins/multifactorauth/yubikey/services/provider.php
plugins/quickicon/joomlaupdate/services/provider.php
plugins/system/cache/services/provider.php
plugins/system/shortcut/services/provider.php
plugins/system/webauthn/services/provider.php
plugins/task/checkfiles/services/provider.php
plugins/task/demotasks/services/provider.php
plugins/task/requests/services/provider.php
plugins/task/sitestatus/services/provider.php
ProviderAwareAuthenticationPluginInterface.php
ProviderInterface.php
ProviderManager.php
ProviderManagerHelperTrait.php
ProxyManagerCaster.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/PS256.php
web-token/jwt-signature-algorithm-rsa/PS256.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/PS384.php
web-token/jwt-signature-algorithm-rsa/PS384.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/PS512.php
web-token/jwt-signature-algorithm-rsa/PS512.php
Psr17Factory.php
PSS.php
PSSRSA.php
fgrosse/phpasn1/lib/X509/PublicKey.php
phpseclib/phpseclib/phpseclib/Crypt/Common/PublicKey.php
phpseclib/phpseclib/phpseclib/Crypt/DH/PublicKey.php
phpseclib/phpseclib/phpseclib/Crypt/DSA/PublicKey.php
phpseclib/phpseclib/phpseclib/Crypt/EC/PublicKey.php
phpseclib/phpseclib/phpseclib/Crypt/RSA/PublicKey.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PublicKey.php
PublicKeyAndChallenge.php
PublicKeyCredential.php
PublicKeyCredentialCreationOptions.php
PublicKeyCredentialDescriptor.php
PublicKeyCredentialDescriptorCollection.php
PublicKeyCredentialEntity.php
PublicKeyCredentialLoader.php
PublicKeyCredentialOptions.php
PublicKeyCredentialParameters.php
PublicKeyCredentialRequestOptions.php
PublicKeyCredentialRpEntity.php
PublicKeyCredentialSource.php
PublicKeyCredentialSourceRepository.php
PublicKeyCredentialUserEntity.php
PublicKeyInfo.php
PublicKeyLoader.php
publish_date.php
PublishedButton.php
publishing.php
publishingdata.php
PunycodeHelper.php
PunycodeInterface.php
Common/Formats/Keys/PuTTY.php
DSA/Formats/Keys/PuTTY.php
EC/Formats/Keys/PuTTY.php
RSA/Formats/Keys/PuTTY.php
administrator/components/com_finder/src/Indexer/Query.php
administrator/components/com_finder/src/Service/HTML/Query.php
libraries/vendor/symfony/ldap/Adapter/ExtLdap/Query.php
query.php
QueryCollector.php
QueryElement.php
QueryHelper.php
joomla/database/src/QueryInterface.php
symfony/ldap/Adapter/QueryInterface.php
QueryMonitorInterface.php
QueryTypeAlreadyDefinedException.php
Question.php
QuestionHelper.php
QuickIconHelper.php
QuickIconsEvent.php
radio.php
tmpl/radio.php
radiobasic.php
RadiobasicField.php
RadioField.php
Random.php
RandomBytesGenerator.php
RandomGeneratorFactory.php
RandomGeneratorInterface.php
RandomImageHelper.php
RandomLibAdapter.php
RandomNodeProvider.php
Randval.php
RandValInterface.php
range.php
RangeField.php
rating.php
Common/Formats/Signature/Raw.php
DSA/Formats/Keys/Raw.php
DSA/Formats/Signature/Raw.php
EC/Formats/Signature/Raw.php
RSA/Formats/Keys/Raw.php
RawDocument.php
RawFilter.php
RawView.php
RC2.php
RC2CBCParameter.php
RC4.php
RdKafkaCaster.php
RDNSequence.php
RDNString.php
ReadBytes.php
Reader.php
ReaderException.php
layouts/joomla/content/readmore.php
plugins/editors-xtd/readmore/readmore.php
readonly.php
ReasonFlags.php
recaptcha.php
ReCaptcha.php
recaptcha_invisible.php
Redirect.php
administrator/components/com_redirect/helpers/redirect.php
plugins/system/redirect/redirect.php
plugins/webservices/redirect/redirect.php
RedirectComponent.php
RedirectController.php
RedirectField.php
RedirectHelper.php
RedirectResponse.php
RedirectStatusField.php
RedisCaster.php
RedisHandler.php
src/Cache/Storage/RedisStorage.php
vendor/maximebf/debugbar/src/DebugBar/Storage/RedisStorage.php
ReflectionCaster.php
RegisteredClaimGiven.php
RegisteredClaims.php
RegistrationController.php
RegistrationdaterangeField.php
RegistrationModel.php
src/HTML/Registry.php
vendor/joomla/registry/src/Registry.php
reinstall.php
RelatedItemsHelper.php
RelatedTo.php
Relations.php
Relationship.php
fgrosse/phpasn1/lib/ASN1/Composite/RelativeDistinguishedName.php
phpseclib/phpseclib/phpseclib/File/ASN1/Maps/RelativeDistinguishedName.php
RelativeObjectIdentifier.php
RelativeStream.php
remember.php
RemindController.php
com_privacy/src/Model/RemindModel.php
com_users/src/Model/RemindModel.php
RemoveModel.php
RemoveOldFilesCommand.php
RemoveUserFromGroupCommand.php
com_contact/layouts/field/render.php
com_contact/layouts/fields/render.php
com_fields/layouts/field/render.php
com_fields/layouts/fields/render.php
Renderable.php
Document/RendererInterface.php
Error/RendererInterface.php
renderfield.php
renderlabel.php
repeatable-table.php
repeatable.php
Replacements.php
replacements.php
laminas/laminas-diactoros/src/Request.php
nyholm/psr7/src/Request.php
RequestContextProvider.php
administrator/components/com_config/src/Controller/RequestController.php
administrator/components/com_privacy/src/Controller/RequestController.php
components/com_privacy/src/Controller/RequestController.php
RequestDataCollector.php
RequestExceptionInterface.php
laminas/laminas-diactoros/src/RequestFactory.php
php-http/message-factory/src/RequestFactory.php
RequestFactoryInterface.php
RequestIdGenerator.php
RequestIdGeneratorInterface.php
RequestInterface.php
RequestMethod.php
administrator/components/com_privacy/src/Model/RequestModel.php
components/com_privacy/src/Model/RequestModel.php
RequestParameters.php
Requests.php
administrator/components/com_privacy/src/Controller/RequestsController.php
api/components/com_privacy/src/Controller/RequestsController.php
RequestsModel.php
RequeststatusField.php
RequestTable.php
laminas/laminas-diactoros/src/RequestTrait.php
nyholm/psr7/src/RequestTrait.php
RequesttypeField.php
Required.php
RequiredConstraintsViolated.php
ResetController.php
ResetInterface.php
ResetModel.php
ReshapeArgumentsAware.php
resize.php
Resolvable.php
ResolvedRoute.php
ResolveFiles.php
Resolver.php
Resource.php
ResourceCaster.php
ResourceNotFound.php
ResourceNotFoundExceptionHandler.php
administrator/components/com_finder/src/Response/Response.php
libraries/src/Http/Response.php
libraries/vendor/google/recaptcha/src/ReCaptcha/Response.php
libraries/vendor/joomla/http/src/Response.php
libraries/vendor/laminas/laminas-diactoros/src/Response.php
libraries/vendor/nyholm/psr7/src/Response.php
ResponseBag.php
laminas/laminas-diactoros/src/ResponseFactory.php
php-http/message-factory/src/ResponseFactory.php
ResponseFactoryInterface.php
ResponseInterface.php
Result.php
result.php
ResultAware.php
ResultAwareInterface.php
ResultTypeArrayAware.php
ResultTypeBooleanAware.php
ResultTypeFloatAware.php
ResultTypeIntegerAware.php
ResultTypeMixedAware.php
ResultTypeNumericAware.php
ResultTypeObjectAware.php
ResultTypeStringAware.php
RevokedCertificate.php
RewriteRules.php
RFC4648.php
RgbPaletteEntry.php
Rijndael.php
Ristretto255.php
ristretto255.php
RogueListEntry.php
Romanian.php
rotate.php
RoundingMode.php
RoundingNecessaryException.php
src/Router/Route.php
vendor/joomla/router/src/Route.php
com_contact/helpers/route.php
com_finder/helpers/route.php
com_newsfeeds/helpers/route.php
com_tags/helpers/route.php
components/com_contact/src/Helper/RouteHelper.php
components/com_content/src/Helper/RouteHelper.php
components/com_finder/src/Helper/RouteHelper.php
components/com_newsfeeds/src/Helper/RouteHelper.php
components/com_tags/src/Helper/RouteHelper.php
libraries/src/Helper/RouteHelper.php
src/Router/Exception/RouteNotFoundException.php
vendor/joomla/router/src/Exception/RouteNotFoundException.php
components/com_banners/src/Service/Router.php
components/com_config/src/Service/Router.php
components/com_contact/src/Service/Router.php
components/com_content/src/Service/Router.php
components/com_finder/src/Service/Router.php
components/com_newsfeeds/src/Service/Router.php
components/com_privacy/src/Service/Router.php
components/com_tags/src/Service/Router.php
components/com_users/src/Service/Router.php
components/com_wrapper/src/Service/Router.php
libraries/src/Router/Router.php
libraries/src/Service/Provider/Router.php
libraries/vendor/joomla/router/src/Router.php
RouterBase.php
Component/Router/RouterFactory.php
Extension/Service/Provider/RouterFactory.php
RouterFactoryInterface.php
src/Component/Router/RouterInterface.php
vendor/joomla/router/src/RouterInterface.php
RouterLegacy.php
RouterServiceInterface.php
RouterServiceTrait.php
RouterView.php
RouterViewConfiguration.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/RS1.php
web-token/jwt-signature-algorithm-experimental/RS1.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/RS256.php
web-token/jwt-signature-algorithm-rsa/RS256.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/RS384.php
web-token/jwt-signature-algorithm-rsa/RS384.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/RS512.php
web-token/jwt-signature-algorithm-rsa/RS512.php
phpseclib/phpseclib/phpseclib/Crypt/RSA.php
web-auth/cose-lib/src/Algorithm/Signature/RSA/RSA.php
web-token/jwt-signature-algorithm-rsa/RSA.php
web-token/jwt-signature-algorithm-rsa/Util/RSA.php
Rsa.php
RSAKey.php
RsaKey.php
RSAPKCS1.php
RSAPrivateKey.php
RSAPSS.php
RSAPublicKey.php
RSASSA_PSS_params.php
RssParser.php
RssRenderer.php
Rtf.php
Rule.php
src/Access/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/English/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/French/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/NorwegianBokmal/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Portuguese/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Spanish/Rules.php
vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Turkish/Rules.php
rules.php
Ruleset.php
RulesetInflector.php
RulesField.php
RulesFilter.php
RulesInterface.php
RulesRule.php
console/Exception/RuntimeException.php
string/Exception/RuntimeException.php
yaml/Exception/RuntimeException.php
RuntimeStorage.php
RuntimeTests.php
Russian.php
SafehtmlFilter.php
paragonie/sodium_compat/namespaced/Core/Salsa20.php
paragonie/sodium_compat/src/Core/Salsa20.php
paragonie/sodium_compat/src/Core32/Salsa20.php
phpseclib/phpseclib/phpseclib/Crypt/Salsa20.php
SampledataHelper.php
Sanitizer.php
Save.php
SaveExceptionHandler.php
SaveSetup.php
Scheduler.php
SchedulerComponent.php
SchedulerHelper.php
schedulerunner.php
script.php
ScriptsRenderer.php
SearchesController.php
SearchesModel.php
SearchfilterField.php
SearchModel.php
SearchTools.php
secp112r1.php
secp112r2.php
secp128r1.php
secp128r2.php
secp160k1.php
secp160r1.php
secp160r2.php
secp192k1.php
secp192r1.php
secp224k1.php
secp224r1.php
secp256k1.php
secp256r1.php
secp384r1.php
secp521r1.php
sect113r1.php
sect113r2.php
sect131r1.php
sect131r2.php
sect163k1.php
sect163r1.php
sect163r2.php
sect193r1.php
sect193r2.php
sect233k1.php
sect233r1.php
sect239k1.php
sect283k1.php
sect283r1.php
sect409k1.php
sect409r1.php
sect571k1.php
sect571r1.php
section-byfieldsets.php
table/section-byfieldsets.php
section.php
table/section.php
SectionField.php
SectionNotFoundException.php
SeekingData.php
sef.php
Select.php
administrator/components/com_users/tmpl/captive/select.php
components/com_users/tmpl/captive/select.php
com_modules/src/Model/SelectModel.php
com_scheduler/src/Model/SelectModel.php
selector.php
selfupdate.php
SendEmail.php
SendEmailExceptionHandler.php
separator.php
SeparatorButton.php
Sequence.php
SerializationException.php
laminas/laminas-diactoros/src/Request/Serializer.php
laminas/laminas-diactoros/src/Response/Serializer.php
web-token/jwt-signature/Serializer/Serializer.php
SerializerErrorRenderer.php
SerializerInterface.php
libraries/vendor/web-auth/webauthn-lib/src/Server.php
plugins/multifactorauth/webauthn/src/Hotfix/Server.php
plugins/system/webauthn/src/Hotfix/Server.php
ServerDumpCommand.php
ServerDumper.php
laminas/laminas-diactoros/src/ServerRequest.php
nyholm/psr7/src/ServerRequest.php
ServerRequestFactory.php
ServerRequestFactoryInterface.php
ServerRequestInterface.php
ServiceLocatorTest.php
ServiceLocatorTrait.php
joomla/di/src/ServiceProviderInterface.php
symfony/service-contracts/ServiceProviderInterface.php
ServiceSubscriberInterface.php
ServiceSubscriberTrait.php
src/Service/Provider/Session.php
src/Session/Session.php
vendor/joomla/session/src/Session.php
SessionAwareWebApplicationInterface.php
SessionAwareWebApplicationTrait.php
SessionCollector.php
SessionEvent.php
SessionEvents.php
SessionFactory.php
sessiongc.php
SessionGcCommand.php
SessionhandlerField.php
SessionInterface.php
SessionManager.php
SessionMetadataGcCommand.php
SessionState.php
Set.php
setaccess.php
SetConfigurationCommand.php
SetNewTagsEvent.php
setoptions.php
SetupModel.php
SetupRenderOptions.php
SFTP.php
Ecdsa/Sha256.php
Hmac/Sha256.php
Rsa/Sha256.php
Ecdsa/Sha384.php
Hmac/Sha384.php
Rsa/Sha384.php
Ecdsa/Sha512.php
Hmac/Sha512.php
Rsa/Sha512.php
Shortcut.php
Sidebar.php
SignalableCommandInterface.php
SignalRegistry.php
lcobucci/jwt/src/Signature.php
lcobucci/jwt/src/Token/Signature.php
web-auth/cose-lib/src/Algorithm/Signature/Signature.php
web-token/jwt-signature/Signature.php
SignatureAlgorithm.php
SignatureConverter.php
SignedIntegerObject.php
SignedPublicKeyAndChallenge.php
SignedWith.php
Signer.php
SilencedErrorContext.php
simple.php
SimpleMetadataStatementRepository.php
SimpleObject.php
SingleCommandApplication.php
SingleMetadata.php
SinglePrecisionFloatObject.php
namespaced/Core/SipHash.php
src/Core/SipHash.php
src/Core32/SipHash.php
SiteApplication.php
SiteDownCommand.php
SiteMenu.php
SitePathway.php
SiteRouter.php
SiteRouterAwareInterface.php
SiteRouterAwareTrait.php
SiteStatus.php
SiteTemplateTrait.php
SiteUpCommand.php
Sketchy.php
skipto.php
slider.php
SlimCollector.php
SluggerInterface.php
Smooth.php
SMTP.php
google/recaptcha/src/ReCaptcha/RequestMethod/Socket.php
joomla/http/src/Transport/Socket.php
SocketPost.php
SocketTransport.php
Sodium.php
sodium_compat.php
SodiumCipher.php
SodiumException.php
SodiumRandomGenerator.php
sort.php
SortableList.php
SourceContextProvider.php
SpacerField.php
Spanish.php
specials.php
SpecifiedECDomain.php
SplCaster.php
SplFixedArray.php
sql.php
tmpl/sql.php
SqlazureDriver.php
SqlazureQuery.php
SqlField.php
SqliteDriver.php
SqliteQuery.php
SqlsrvChangeItem.php
SqlsrvDriver.php
SqlsrvQuery.php
SqlsrvStatement.php
Crypt/DSA/Formats/Signature/SSH2.php
Crypt/EC/Formats/Signature/SSH2.php
Net/SSH2.php
StageController.php
StageHelper.php
StageModel.php
StagesController.php
StagesModel.php
StageTable.php
standard.php
StandardButton.php
StandardDebugBar.php
StandardRules.php
starttabset.php
namespaced/Core/Poly1305/State.php
src/Core/Poly1305/State.php
src/Core/SecretStream/State.php
src/Core32/Poly1305/State.php
src/Core32/SecretStream/State.php
StateBehaviorTrait.php
StatefulModelInterface.php
StatementInterface.php
StatisticsModel.php
layouts/stats.php
stats.php
StatsAdminHelper.php
statscollection.php
StatsHelper.php
status.php
com_privacy/src/Removal/Status.php
com_scheduler/src/Task/Status.php
StatusField.php
StatusReport.php
Stdout.php
Stem.php
Stemmer.php
StemmerFactory.php
StemmerManager.php
joomla/session/src/StorageInterface.php
maximebf/debugbar/src/DebugBar/Storage/StorageInterface.php
str_ireplace.php
str_pad.php
str_split.php
strcasecmp.php
strcspn.php
stream-xchacha20.php
src/Filesystem/Stream.php
vendor/joomla/filesystem/src/Stream.php
vendor/joomla/http/src/Transport/Stream.php
vendor/laminas/laminas-diactoros/src/Stream.php
vendor/nyholm/psr7/src/Stream.php
vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php
vendor/spomky-labs/cbor-php/src/Stream.php
StreamableInputInterface.php
StreamCipher.php
laminas/laminas-diactoros/src/StreamFactory.php
php-http/message-factory/src/StreamFactory.php
StreamFactoryInterface.php
StreamInterface.php
StreamOutput.php
StreamString.php
StreamTransport.php
Stringable.php
StringCodec.php
src/Filesystem/Support/StringController.php
vendor/joomla/filesystem/src/Support/StringController.php
src/HTML/Helpers/StringHelper.php
vendor/joomla/string/src/StringHelper.php
StringInput.php
Strings.php
administrator/components/com_languages/src/Controller/StringsController.php
api/components/com_languages/src/Controller/StringsController.php
StringsModel.php
spomky-labs/cbor-php/src/StringStream.php
web-auth/webauthn-lib/src/StringStream.php
StringWrapper.php
stristr.php
strrev.php
strspn.php
symfony/var-dumper/Cloner/Stub.php
typo3/phar-stream-wrapper/src/Phar/Stub.php
StubCaster.php
StyleController.php
StyleInterface.php
StyleModel.php
styles.php
administrator/components/com_templates/src/Controller/StylesController.php
api/components/com_templates/src/Controller/StylesController.php
StylesModel.php
StylesRenderer.php
StyleTable.php
SubfieldsField.php
subform.php
tmpl/subform.php
SubformField.php
SubformRule.php
Subject.php
SubjectAlternativeNames.php
SubjectAltName.php
SubjectDirectoryAttributes.php
SubjectInfoAccessSyntax.php
SubjectPublicKeyInfo.php
submenu.php
SubscribedService.php
SubscriberInterface.php
Substitution.php
Substitutions.php
substr_replace.php
Suggestion.php
SuggestionsController.php
SuggestionsModel.php
svg-scanner.php
Swedish.php
SwiftLogCollector.php
SwiftMailCollector.php
switcher.php
symfony-ghost.svg.php
SymfonyCaster.php
SymfonyQuestionHelper.php
SymfonyStyle.php
phpseclib/phpseclib/phpseclib/Crypt/Common/SymmetricKey.php
web-auth/cose-lib/src/Key/SymmetricKey.php
SyndicateHelper.php
SysinfoModel.php
SyslogLogger.php
System.php
SystemNodeProvider.php
SystemTimeProvider.php
T61String.php
src/Table/Table.php
vendor/symfony/console/Helper/Table.php
table.php
TableCell.php
TableCellStyle.php
TableColumnsAssetItem.php
TableInterface.php
TableRows.php
TableSeparator.php
TableStyle.php
Tag.php
form/field/tag.php
html/batch/tag.php
TagApiSerializerTrait.php
TagController.php
TagField.php
Taggable.php
TaggableTableInterface.php
TaggableTableTrait.php
TaggedValue.php
TagInterface.php
administrator/components/com_tags/src/Model/TagModel.php
components/com_tags/src/Model/TagModel.php
TagObject.php
TagObjectManager.php
layouts/joomla/content/tags.php
plugins/finder/tags/tags.php
plugins/webservices/tags/tags.php
TagsComponent.php
administrator/components/com_tags/src/Controller/TagsController.php
api/components/com_tags/src/Controller/TagsController.php
components/com_tags/src/Controller/TagsController.php
TagServiceInterface.php
TagServiceTrait.php
TagsHelper.php
administrator/components/com_tags/src/Model/TagsModel.php
components/com_tags/src/Model/TagsModel.php
TagsPopularHelper.php
TagsSimilarHelper.php
TagTable.php
Tar.php
Task.php
TaskController.php
TaskModel.php
tasknotification.php
TaskOption.php
TaskOptions.php
TaskPluginTrait.php
TasksController.php
TasksListCommand.php
TasksModel.php
TasksRunCommand.php
TasksStateCommand.php
TaskStateField.php
TaskTable.php
TaskTypeField.php
Taxonomy.php
taxonomy.php
TBSCertificate.php
TBSCertList.php
tel.php
Telephone.php
TelephoneField.php
TelFilter.php
TelRule.php
template.php
TemplateAdapter.php
com_mails/src/Controller/TemplateController.php
com_templates/src/Controller/TemplateController.php
TemplatedHrefTrait.php
TemplateHelper.php
TemplatelocationField.php
com_mails/src/Model/TemplateModel.php
com_templates/src/Model/TemplateModel.php
TemplatenameField.php
TemplateParser.php
Templates.php
administrator/components/com_templates/helpers/templates.php
plugins/webservices/templates/templates.php
TemplatesComponent.php
TemplatesController.php
TemplatesHelper.php
TemplateslistField.php
administrator/components/com_mails/src/Model/TemplatesModel.php
administrator/components/com_templates/src/Model/TemplatesModel.php
components/com_config/src/Model/TemplatesModel.php
TemplatestyleField.php
TemplateTable.php
TentativeTypes.php
Terminal.php
TerminalIdentifier.php
TerminateEvent.php
terms.php
TermsField.php
TesterTrait.php
Text.php
layouts/joomla/form/field/text.php
plugins/fields/text/text.php
plugins/fields/text/tmpl/text.php
text_filters.php
layouts/joomla/form/field/textarea.php
layouts/joomla/tinymce/textarea.php
plugins/fields/textarea/textarea.php
plugins/fields/textarea/tmpl/textarea.php
TextareaField.php
joomla/console/src/Descriptor/TextDescriptor.php
symfony/console/Descriptor/TextDescriptor.php
TextField.php
textfilter3919.php
TextResponse.php
TextStringObject.php
TextStringWithChunkObject.php
TextView.php
ThrowableUtils.php
ThrowingCasterException.php
Time.php
time.php
TimeableTwigExtensionProfiler.php
TimeConverterInterface.php
TimeDataCollector.php
TimeField.php
TimeGeneratorFactory.php
TimeGeneratorInterface.php
TimeProviderInterface.php
TimeRule.php
TimestampFirstCombCodec.php
TimestampLastCombCodec.php
TimestampTag.php
TimezoneField.php
tinymce.php
tinymcebuilder.php
TinymcebuilderField.php
administrator/templates/atum/html/layouts/chromes/title.php
layouts/joomla/toolbar/title.php
title_alias.php
titleCaseRegexp.php
toc.php
togglebutton.php
ToIdn.php
administrator/components/com_finder/src/Indexer/Token.php
libraries/vendor/lcobucci/jwt/src/Token.php
plugins/api-authentication/token/src/Extension/Token.php
administrator/components/com_finder/helpers/indexer/token.php
layouts/plugins/user/token/token.php
plugins/user/token/token.php
TokenBinding.php
TokenBindingHandler.php
TokenBindingNotSupportedHandler.php
Service/Provider/Toolbar.php
Toolbar/Toolbar.php
ToolbarButton.php
ToolbarFactoryInterface.php
ToolbarHelper.php
ToolbarPresets.php
ToPunycode.php
TosField.php
libraries/src/Encrypt/Totp.php
plugins/multifactorauth/totp/src/Extension/Totp.php
ToUnicode.php
ToUtf8.php
TPMAttestationStatementSupport.php
trace.html.php
TraceablePDO.php
TraceablePDOStatement.php
TraceableTwigEnvironment.php
TraceableTwigTemplate.php
TracedStatement.php
traces.html.php
traces_text.html.php
TraceStub.php
TracksController.php
TracksModel.php
TranscodeUnicode.php
TranscodeUnicodeInterface.php
Transformation.php
Transformations.php
transition-button.php
TransitionButton.php
TransitionController.php
TransitionField.php
TransitionModel.php
TransitionsController.php
TransitionsModel.php
TransitionTable.php
translit.php
Transliterate.php
transliterator_list.php
src/Http/TransportInterface.php
vendor/joomla/http/src/TransportInterface.php
treeprefix.php
trim.php
TrimmedBufferOutput.php
Trinomial.php
TripleDES.php
TrueObject.php
TrustPath.php
TrustPathLoader.php
TwigCollector.php
TwigProfileCollector.php
TwistedEdwards.php
Twofish.php
Txt.php
com_fields/src/Field/TypeField.php
com_installer/src/Field/TypeField.php
ucfirst.php
UCM.php
Ucm.php
UCMBase.php
UCMContent.php
UCMType.php
ucwords.php
UiTab.php
UnableToConnectException.php
UnableToWriteBody.php
UndefinedFunctionError.php
UndefinedFunctionErrorEnhancer.php
UndefinedMethodError.php
UndefinedMethodErrorEnhancer.php
UndefinedObject.php
UndefinedOptionsException.php
Unescaper.php
UnexpectedResponseException.php
UnhandledMatchError.php
unicode.php
UnicodeString.php
English/Uninflected.php
French/Uninflected.php
NorwegianBokmal/Uninflected.php
Portuguese/Uninflected.php
Spanish/Uninflected.php
Turkish/Uninflected.php
uniqueid.php
UniqueIdentifier.php
UniqueidField.php
UniversalString.php
UnknownArchiveException.php
UnknownAssetException.php
UnknownConstructedObject.php
UnknownObject.php
UnknownTypeException.php
UnparsableImageException.php
UnreadableStreamException.php
UnrecognizedProtocolVersionException.php
UnrewindableStreamException.php
src/WebAsset/Exception/UnsatisfiedDependencyException.php
vendor/ramsey/uuid/src/Exception/UnsatisfiedDependencyException.php
UnseekableStreamException.php
UnsetFilter.php
UnsignedIntegerObject.php
UnsupportedAdapterException.php
UnsupportedAlgorithmException.php
UnsupportedArchiveException.php
UnsupportedCacheException.php
UnsupportedCipherException.php
UnsupportedCurveException.php
UnsupportedDatabaseDriverException.php
UnsupportedFormatException.php
UnsupportedHeaderFound.php
phpseclib/phpseclib/phpseclib/Exception/UnsupportedOperationException.php
ramsey/uuid/src/Exception/UnsupportedOperationException.php
UnsupportedPasswordHandlerException.php
UnsupportedStorageException.php
UntellableStreamException.php
UnwritableStreamException.php
Table/Update.php
Updater/Update.php
update.php
UpdateAdapter.php
updatecachetime.php
com_installer/src/Controller/UpdateController.php
com_joomlaupdate/src/Controller/UpdateController.php
UpdateCoreCommand.php
com_installer/src/Model/UpdateModel.php
com_joomlaupdate/src/Model/UpdateModel.php
updatenotification.php
UpdateOperation.php
UpdateOperationException.php
Updater.php
UpdateSite.php
UpdatesiteController.php
UpdatesiteModel.php
Updatesites.php
UpdatesitesController.php
UpdatesitesModel.php
UpdatesiteTable.php
upload.php
UploaddirsField.php
laminas/laminas-diactoros/src/UploadedFile.php
nyholm/psr7/src/UploadedFile.php
UploadedFileAlreadyMovedException.php
UploadedFileErrorException.php
UploadedFileFactory.php
UploadedFileFactoryInterface.php
UploadedFileInterface.php
upperCase.php
src/Uri/Uri.php
vendor/joomla/uri/src/Uri.php
vendor/laminas/laminas-diactoros/src/Uri.php
vendor/nyholm/psr7/src/Uri.php
laminas/laminas-diactoros/src/UriFactory.php
php-http/message-factory/src/UriFactory.php
UriFactoryInterface.php
UriHelper.php
UriImmutable.php
joomla/uri/src/UriInterface.php
psr/http-message/src/UriInterface.php
layouts/joomla/form/field/url.php
plugins/fields/url/tmpl/url.php
plugins/fields/url/url.php
UrlField.php
UrlFilter.php
urlinstaller.php
UrlRule.php
UrlSafe.php
Usage.php
HTML/Helpers/User.php
Service/Provider/User.php
Table/User.php
User/User.php
layouts/joomla/form/field/user.php
layouts/joomla/html/batch/user.php
plugins/fields/user/tmpl/user.php
plugins/fields/user/user.php
plugins/privacy/user/user.php
UseractiveField.php
administrator/components/com_users/src/Controller/UserController.php
components/com_users/src/Controller/UserController.php
UserDeletion.php
UserFactory.php
UserFactoryInterface.php
UserField.php
Usergroup.php
tmpl/usergrouplist.php
usergrouplist.php
UsergrouplistField.php
UserGroupsHelper.php
UserHelper.php
UserIdRule.php
UserMessagesField.php
UserModel.php
installation/src/Form/Rule/UsernameRule.php
libraries/src/Form/Rule/UsernameRule.php
UserNotice.php
UserProfileFields.php
Users.php
administrator/components/com_users/helpers/users.php
plugins/webservices/users/users.php
UsersComponent.php
administrator/components/com_users/src/Controller/UsersController.php
api/components/com_users/src/Controller/UsersController.php
UsersHelper.php
UsersLatestHelper.php
UsersModel.php
UserstateField.php
UTCTime.php
UTF8.php
utf8.php
utf8_fix.php
UTF8MB4SupportInterface.php
UTF8String.php
paragonie/sodium_compat/namespaced/Core/Util.php
paragonie/sodium_compat/src/Core/Util.php
paragonie/sodium_compat/src/Core32/Util.php
tobscure/json-api/src/Util.php
Utility.php
Utils.php
Uuid.php
UuidBuilderInterface.php
UuidCaster.php
UuidFactory.php
UuidFactoryInterface.php
UuidInterface.php
ValidAt.php
Validatable.php
Validate.php
validation.php
ValidationData.php
Validation/Validator.php
Validator.php
ValidatorInterface.php
Validity.php
ValueError.php
VarCloner.php
VarDumper.php
VarDumperTestTrait.php
VcfView.php
VerificationMethodANDCombinations.php
VerificationMethodDescriptor.php
Verifier.php
src/Version.php
vendor/web-auth/metadata-service/src/Version.php
Versionable.php
VersionableControllerTrait.php
VersionableModelTrait.php
VersionableTableInterface.php
VersionHelper.php
Versioning.php
versions.php
vertical.php
ViewController.php
ViewInterface.php
ViewLevel.php
VisibleString.php
tmpl/vote.php
vote.php
VotelistField.php
VoteradioField.php
W3cLogger.php
WarningsModel.php
wcswidth_table_wide.php
wcswidth_table_zero.php
src/Application/WebApplication.php
vendor/joomla/application/src/WebApplication.php
WebApplicationInterface.php
WebAssetAttachBehaviorInterface.php
WebAssetExceptionInterface.php
WebAssetItem.php
WebAssetItemInterface.php
WebAssetManager.php
WebAssetManagerInterface.php
Service/Provider/WebAssetRegistry.php
WebAsset/WebAssetRegistry.php
WebAssetRegistryAssetChanged.php
WebAssetRegistryInterface.php
multifactorauth/webauthn/src/Extension/Webauthn.php
system/webauthn/src/Extension/Webauthn.php
WebauthnField.php
WebClient.php
webcron_link.php
WebcronLinkField.php
webinstaller.php
well.php
WhosonlineHelper.php
win1252_to_utf8.php
WincacheHandler.php
WincacheStorage.php
Word.php
WordInflector.php
Workflow.php
WorkflowBehaviorTrait.php
WorkflowComponentSectionsField.php
WorkflowconditionField.php
WorkflowcontextsField.php
WorkflowController.php
WorkflowFunctionalityUsedEvent.php
WorkflowHelper.php
WorkflowModel.php
WorkflowModelInterface.php
WorkflowPluginTrait.php
WorkflowsController.php
WorkflowServiceInterface.php
WorkflowServiceTrait.php
WorkflowsModel.php
WorkflowStage.php
workflowstage.php
WorkflowstageField.php
WorkflowTable.php
WorkflowTransitionEvent.php
WrappableOutputFormatterInterface.php
WrapperComponent.php
WrapperHelper.php
WritableContainerLoader.php
WritableLoaderInterface.php
WrongKeyOrModifiedCiphertextException.php
x000.php
x001.php
x002.php
x003.php
x004.php
x005.php
x006.php
x007.php
x009.php
x00a.php
x00b.php
x00c.php
x00d.php
x00e.php
x00f.php
x010.php
x011.php
x012.php
x013.php
x014.php
x015.php
x016.php
x017.php
x018.php
x01d.php
x01e.php
x01f.php
x020.php
x021.php
x022.php
x023.php
x024.php
x025.php
x026.php
x027.php
x028.php
x029.php
x02a.php
x02c.php
x02e.php
x02f.php
x030.php
x031.php
x032.php
x033.php
x04d.php
x04e.php
x04f.php
x050.php
x051.php
x052.php
x053.php
x054.php
x055.php
x056.php
x057.php
x058.php
x059.php
x05a.php
x05b.php
x05c.php
x05d.php
x05e.php
x05f.php
x060.php
x061.php
x062.php
x063.php
x064.php
x065.php
x066.php
x067.php
x068.php
x069.php
x06a.php
x06b.php
x06c.php
x06d.php
x06e.php
x06f.php
x070.php
x071.php
x072.php
x073.php
x074.php
x075.php
x076.php
x077.php
x078.php
x079.php
x07a.php
x07b.php
x07c.php
x07d.php
x07e.php
x07f.php
x080.php
x081.php
x082.php
x083.php
x084.php
x085.php
x086.php
x087.php
x088.php
x089.php
x08a.php
x08b.php
x08c.php
x08d.php
x08e.php
x08f.php
x090.php
x091.php
x092.php
x093.php
x094.php
x095.php
x096.php
x097.php
x098.php
x099.php
x09a.php
x09b.php
x09c.php
x09d.php
x09e.php
x09f.php
x0a0.php
x0a1.php
x0a2.php
x0a3.php
x0a4.php
x0ac.php
x0ad.php
x0ae.php
x0af.php
x0b0.php
x0b1.php
x0b2.php
x0b3.php
x0b4.php
x0b5.php
x0b6.php
x0b7.php
x0b8.php
x0b9.php
x0ba.php
x0bb.php
x0bc.php
x0bd.php
x0be.php
x0bf.php
x0c0.php
x0c1.php
x0c2.php
x0c3.php
x0c4.php
x0c5.php
x0c6.php
x0c7.php
x0c8.php
x0c9.php
x0ca.php
x0cb.php
x0cc.php
x0cd.php
x0ce.php
x0cf.php
x0d0.php
x0d1.php
x0d2.php
x0d3.php
x0d4.php
x0d5.php
x0d6.php
x0d7.php
x0f9.php
x0fa.php
x0fb.php
x0fc.php
x0fd.php
x0fe.php
x0ff.php
x1d4.php
x1d5.php
x1d6.php
x1d7.php
x1f1.php
namespaced/Core/X25519.php
src/Core/X25519.php
src/Core32/X25519.php
X509.php
namespaced/Core/XChaCha20.php
src/Core/XChaCha20.php
src/Core32/XChaCha20.php
DSA/Formats/Keys/XML.php
EC/Formats/Keys/XML.php
RSA/Formats/Keys/XML.php
src/Application/CLI/Output/Xml.php
vendor/joomla/registry/src/Format/Xml.php
XmlDescriptor.php
XmlDocument.php
XmlReaderCaster.php
XmlRenderer.php
XmlResourceCaster.php
XmlResponse.php
com_menus/src/View/Menu/XmlView.php
com_privacy/src/View/Export/XmlView.php
XPath.php
XSalsa20.php
2/XSalsa20.php
Xsalsa20.php
XTDButtons.php
joomla/registry/src/Format/Yaml.php
symfony/yaml/Yaml.php
Yubikey.php
Zh.php
Zip.php


Joomla CMS: Référence du fichier _item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • tmpl
Espaces de nommage | Variables
Référence du fichier _item.php

Espaces de nommage

Joomla\Site

Variables

if ( $item->link !=='' &&$params->get( 'link_titles'))
else __pad0__
endif

Documentation des variables

◆ __pad0__

else __pad0__

◆ endif

endif

◆ if

if($item->link !=='' && $params->get('link_titles'))


Joomla CMS: Référence du fichier AbstractAES.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
  • AES
Structures de données | Espaces de nommage
Référence du fichier AbstractAES.php

Structures de données

class AbstractAES

Espaces de nommage

Joomla\CMS\Encrypt\AES


Joomla CMS: Référence du fichier AbstractApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractApplication.php

Structures de données

class AbstractApplication

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier AbstractCBORObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractCBORObject.php

Structures de données

class AbstractCBORObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier AbstractCloner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier AbstractCloner.php

Structures de données

class AbstractCloner

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier AbstractCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier AbstractCommand.php

Structures de données

class AbstractCommand

Espaces de nommage

Joomla\Console\Command


Joomla CMS: Référence du fichier AbstractConnection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier AbstractConnection.php

Structures de données

class AbstractConnection

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier AbstractDataCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractDataCollector.php

Structures de données

class AbstractDataCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug


Joomla CMS: Référence du fichier AbstractDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage
Référence du fichier AbstractDumper.php

Structures de données

class AbstractDumper

Espaces de nommage

Symfony\Component\VarDumper\Dumper


Joomla CMS: Référence du fichier AbstractEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier src/Event/AbstractEvent.php

Structures de données

class AbstractEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier AbstractEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier src/Event/Table/AbstractEvent.php

Structures de données

class AbstractEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AbstractEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier src/Event/WebAsset/AbstractEvent.php

Structures de données

class AbstractEvent

Espaces de nommage

Joomla\CMS\Event\WebAsset


Joomla CMS: Référence du fichier AbstractEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier src/Event/Workflow/AbstractEvent.php

Structures de données

class AbstractEvent

Espaces de nommage

Joomla\CMS\Event\Workflow


Joomla CMS: Référence du fichier AbstractEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/event/src/AbstractEvent.php

Structures de données

class AbstractEvent

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier AbstractField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier AbstractField.php

Structures de données

class AbstractField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier AbstractGroupButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier AbstractGroupButton.php

Structures de données

class AbstractGroupButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier AbstractIdnaConvert.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractIdnaConvert.php

Structures de données

class AbstractIdnaConvert

Espaces de nommage

Algo26\IdnaConvert


Joomla CMS: Référence du fichier AbstractImmutableEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier AbstractImmutableEvent.php

Structures de données

class AbstractImmutableEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier AbstractLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier AbstractLogger.php

Structures de données

class AbstractLogger

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier AbstractMediaItemValidationEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier AbstractMediaItemValidationEvent.php

Structures de données

class AbstractMediaItemValidationEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier AbstractMenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier AbstractMenu.php

Structures de données

class AbstractMenu

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier AbstractModuleDispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier AbstractModuleDispatcher.php

Structures de données

class AbstractModuleDispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier AbstractNegotiator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AbstractNegotiator.php

Structures de données

class AbstractNegotiator

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AbstractPunycode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Punycode
Structures de données | Espaces de nommage
Référence du fichier AbstractPunycode.php

Structures de données

class AbstractPunycode

Espaces de nommage

Algo26\IdnaConvert\Punycode


Joomla CMS: Référence du fichier AbstractQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier AbstractQuery.php

Structures de données

class AbstractQuery

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier AbstractRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
Structures de données | Espaces de nommage
Référence du fichier AbstractRenderer.php

Structures de données

class AbstractRenderer

Espaces de nommage

Joomla\CMS\Error


Joomla CMS: Référence du fichier AbstractSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/AbstractSerializer.php

Structures de données

class AbstractSerializer

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier AbstractSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier tobscure/json-api/src/AbstractSerializer.php

Structures de données

class AbstractSerializer

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier AbstractStatsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier AbstractStatsField.php

Structures de données

class AbstractStatsField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Stats\Field


Joomla CMS: Référence du fichier AbstractString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/ASN1/AbstractString.php

Structures de données

class AbstractString

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier AbstractString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier symfony/string/AbstractString.php

Structures de données

class AbstractString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier AbstractTime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier AbstractTime.php

Structures de données

class AbstractTime

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier AbstractTransport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractTransport.php

Structures de données

class AbstractTransport

Espaces de nommage

Joomla\Http


Joomla CMS: Référence du fichier AbstractUnicodeString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier AbstractUnicodeString.php

Structures de données

class AbstractUnicodeString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier AbstractUri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractUri.php

Structures de données

class AbstractUri

Espaces de nommage

Joomla\Uri


Joomla CMS: Référence du fichier AbstractUsernamePasswordAuthenticationStrategy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractUsernamePasswordAuthenticationStrategy.php

Structures de données

class AbstractUsernamePasswordAuthenticationStrategy

Espaces de nommage

Joomla\Authentication


Joomla CMS: Référence du fichier AbstractView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier AbstractView.php

Structures de données

class AbstractView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier AbstractWebApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier AbstractWebApplication.php

Structures de données

class AbstractWebApplication

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier Accept.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier Accept.php

Structures de données

class Accept

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AcceptCharset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AcceptCharset.php

Structures de données

class AcceptCharset

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AcceptEncoding.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AcceptEncoding.php

Structures de données

class AcceptEncoding

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AcceptHeader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AcceptHeader.php

Structures de données

interface AcceptHeader

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AcceptLanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AcceptLanguage.php

Structures de données

class AcceptLanguage

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier AcceptMatch.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier AcceptMatch.php

Structures de données

class AcceptMatch

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier Access.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
Structures de données | Espaces de nommage
Référence du fichier Access/Access.php

Structures de données

class Access

Espaces de nommage

Joomla\CMS\Access


Joomla CMS: Référence du fichier Access.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier HTML/Helpers/Access.php

Structures de données

class Access

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier access.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage
Référence du fichier access.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier AccessDescription.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AccessDescription.php

Structures de données

class AccessDescription

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AccessException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier AccessException.php

Structures de données

class AccessException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier accessibility.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • accessibility
Structures de données | Espaces de nommage
Référence du fichier accessibility.php

Structures de données

class PlgSystemAccessibility

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier accessiblemedia.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • media
Espaces de nommage | Variables
Référence du fichier accessiblemedia.php

Espaces de nommage

Joomla\Site

Variables

$form = $forms[0]
$formfields = $form->getGroup('')
endforeach

Documentation des variables

◆ $form

$form = $forms[0]

◆ $formfields

$formfields = $form->getGroup('')

◆ endforeach

endforeach


Joomla CMS: Référence du fichier AccessiblemediaField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier AccessiblemediaField.php

Structures de données

class AccessiblemediaField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier AccesslevelField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier AccesslevelField.php

Structures de données

class AccesslevelField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier action-button.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • button
Espaces de nommage | Variables
Référence du fichier action-button.php

Espaces de nommage

Joomla\Site

Variables

$disabled = !empty($options['disabled'])
$taskPrefix = $options['task_prefix']
$checkboxName = $options['checkbox_name']
$id = $options['id']
$tipTitle = $options['tip_title']

Documentation des variables

◆ $checkboxName

$checkboxName = $options['checkbox_name']

◆ $disabled

$disabled = !empty($options['disabled'])
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), GroupedlistField\getGroups(), PrefixField\getInput(), FormField\getLayoutData(), ListField\getOptions(), MailModel\send(), et Form\validate().

◆ $id

$id = $options['id']

◆ $taskPrefix

$taskPrefix = $options['task_prefix']

Référencé par Dispatcher\checkAccess().

◆ $tipTitle

$tipTitle = $options['tip_title']


Joomla CMS: Référence du fichier ActionButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Button
Structures de données | Espaces de nommage
Référence du fichier ActionButton.php

Structures de données

class ActionButton

Espaces de nommage

Joomla\CMS\Button


Joomla CMS: Référence du fichier ActionlogConfigModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ActionlogConfigModel.php

Structures de données

class ActionlogConfigModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Model


Joomla CMS: Référence du fichier ActionlogModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ActionlogModel.php

Structures de données

class ActionlogModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Model


Joomla CMS: Référence du fichier ActionLogPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier ActionLogPlugin.php

Structures de données

class ActionLogPlugin

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Plugin


Joomla CMS: Référence du fichier actionlogs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • actionlogs
Structures de données | Espaces de nommage
Référence du fichier privacy/actionlogs/actionlogs.php

Structures de données

class PlgPrivacyActionlogs

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier actionlogs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • actionlogs
Structures de données | Espaces de nommage
Référence du fichier system/actionlogs/actionlogs.php

Structures de données

class PlgSystemActionLogs

Espaces de nommage

Joomla\Plugins


Joomla CMS: Référence du fichier ActionlogsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ActionlogsController.php

Structures de données

class ActionlogsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Controller


Joomla CMS: Référence du fichier ActionlogsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ActionlogsHelper.php

Structures de données

class ActionlogsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Helper


Joomla CMS: Référence du fichier ActionlogsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ActionlogsModel.php

Structures de données

class ActionlogsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Model


Joomla CMS: Référence du fichier ActionsDropdown.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier ActionsDropdown.php

Structures de données

class ActionsDropdown

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier ActiveSiteTemplate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier ActiveSiteTemplate.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Référence du fichier Adapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Adapter.php

Structures de données

class Adapter

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier Adapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Adapter/Adapter.php

Structures de données

class Adapter

Espaces de nommage

Joomla\CMS\Adapter


Joomla CMS: Référence du fichier Adapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/ldap/Adapter/ExtLdap/Adapter.php

Structures de données

class Adapter

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier adapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier adapter.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier AdapterInstance.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier AdapterInstance.php

Structures de données

class AdapterInstance

Espaces de nommage

Joomla\CMS\Adapter


Joomla CMS: Référence du fichier AdapterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Adapter/AdapterInterface.php

Structures de données

interface AdapterInterface

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Adapter


Joomla CMS: Référence du fichier AdapterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/ldap/Adapter/AdapterInterface.php

Structures de données

interface AdapterInterface

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier AdapterModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier AdapterModel.php

Structures de données

class AdapterModel

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Model


Joomla CMS: Référence du fichier AdaptersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier AdaptersController.php

Structures de données

class AdaptersController

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Controller


Joomla CMS: Référence du fichier AdaptersModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier AdaptersModel.php

Structures de données

class AdaptersModel

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Model


Joomla CMS: Référence du fichier AddConsoleCommandPass.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • DependencyInjection
Structures de données | Espaces de nommage
Référence du fichier AddConsoleCommandPass.php

Structures de données

class AddConsoleCommandPass

Espaces de nommage

Symfony\Component\Console\DependencyInjection


Joomla CMS: Référence du fichier AdditionalLoginButtons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage | Fonctions | Variables
Référence du fichier AdditionalLoginButtons.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits

Fonctions

mustDisplayButton ()

Variables

trait AdditionalLoginButtons
$injectedCSSandJS = false


Joomla CMS: Référence du fichier AddLinkHeaderListener.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
  • EventListener
Structures de données | Espaces de nommage
Référence du fichier AddLinkHeaderListener.php

Structures de données

class AddLinkHeaderListener

Espaces de nommage

Symfony\Component\WebLink\EventListener


Joomla CMS: Référence du fichier addnosniff.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier addnosniff.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_addnosniff_condition ()

Documentation des fonctions

◆ admin_postinstall_addnosniff_condition()

admin_postinstall_addnosniff_condition ( )

Notifies users of the add the nosniff headers by applying the changes from the default .htaccess or web.config file

This check returns true regardless of condition.

Renvoie
boolean
Depuis
3.4


Joomla CMS: Référence du fichier AddressValidator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Validator
Structures de données | Espaces de nommage
Référence du fichier AddressValidator.php

Structures de données

class AddressValidator

Espaces de nommage

Joomla\Session\Validator


Joomla CMS: Référence du fichier addtab.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • tab
Espaces de nommage | Variables
Référence du fichier addtab.php

Espaces de nommage

Joomla\Site

Variables

$id = empty($displayData['id']) ? '' : $displayData['id']
$active = empty($displayData['active']) ? '' : $displayData['active']
$title = empty($displayData['title']) ? '' : $displayData['title']

Documentation des variables

◆ $active

$active = empty($displayData['active']) ? '' : $displayData['active']

◆ $id

$id = empty($displayData['id']) ? '' : $displayData['id']

◆ $title

$title = empty($displayData['title']) ? '' : $displayData['title']


Joomla CMS: Référence du fichier AddUserCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier AddUserCommand.php

Structures de données

class AddUserCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier AddUserToGroupCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier AddUserToGroupCommand.php

Structures de données

class AddUserToGroupCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier admin_modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier admin_modules.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$form = $displayData->getForm()
$input = $app->input
$fields
$hiddenFields = $displayData->get('hidden_fields') ?: array()
if(!ModuleHelper::isAdminMultilang()) $html = array()
$html [] = '<fieldset class="form-vertical">'

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $fields

$fields
Valeur initiale :
= $displayData->get('fields') ?: array(
array('parent', 'parent_id'),
array('published', 'state', 'enabled'),
array('category', 'catid'),
'featured',
'sticky',
'access',
'language',
'tags',
'note',
'version_note',
)
$displayData
$displayData
Definition: administrator/components/com_banners/tmpl/banners/emptystate.php:16

◆ $form

$form = $displayData->getForm()

◆ $hiddenFields

$hiddenFields = $displayData->get('hidden_fields') ?: array()

◆ $html [1/2]

if (!ModuleHelper::isAdminMultilang()) $html = array()

◆ $html [2/2]

foreach ( $fields as $field) $html[] = '<fieldset class="form-vertical">'

◆ $input

$input = $app->input


Joomla CMS: Référence du fichier AdminComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier AdminComponent.php

Structures de données

class AdminComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Extension


Joomla CMS: Référence du fichier AdminController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Structures de données | Espaces de nommage
Référence du fichier AdminController.php

Structures de données

class AdminController

Espaces de nommage

Joomla\CMS\MVC\Controller


Joomla CMS: Référence du fichier AdministrationDomainName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AdministrationDomainName.php

Structures de données

class AdministrationDomainName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AdministratorApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier AdministratorApplication.php

Structures de données

class AdministratorApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier AdministratorMenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier AdministratorMenu.php

Structures de données

class AdministratorMenu

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier AdministratorMenuItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier AdministratorMenuItem.php

Structures de données

class AdministratorMenuItem

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier AdministratorRouter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier AdministratorRouter.php

Structures de données

class AdministratorRouter

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier AdministratorService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_categories/src/Service/HTML/AdministratorService.php

Structures de données

class AdministratorService

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Service\HTML


Joomla CMS: Référence du fichier AdministratorService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/Service/HTML/AdministratorService.php

Structures de données

class AdministratorService

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Service\HTML


Joomla CMS: Référence du fichier AdministratorService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_content/src/Service/HTML/AdministratorService.php

Structures de données

class AdministratorService

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Service\HTML


Joomla CMS: Référence du fichier AdministratorService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/src/Service/HTML/AdministratorService.php

Structures de données

class AdministratorService

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Service\HTML


Joomla CMS: Référence du fichier AdminLanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier AdminLanguage.php

Structures de données

class AdminLanguage

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier adminlanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage
Référence du fichier adminlanguage.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier AdminModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier AdminModel.php

Structures de données

class AdminModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier advanced.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • color
Espaces de nommage | Variables
Référence du fichier advanced.php

Espaces de nommage

Joomla\Site

Variables

if($validate !=='color' &&in_array($format, array('rgb', 'rgba'), true)) else
$inputclass = ($keywords && ! in_array($format, array('rgb', 'rgba'), true)) ? ' keywords' : ' ' . $format
$class = ' class="form-control ' . trim('minicolors ' . $class) . ($validate === 'color' ? '' : $inputclass) . '"'
$control = $control ? ' data-control="' . $control . '"' : ''
$format = $format ? ' data-format="' . $format . '"' : ''
$keywords = $keywords ? ' data-keywords="' . $keywords . '"' : ''
$colors = $colors ? ' data-colors="' . $colors . '"' : ''
$validate = $validate ? ' data-validate="' . $validate . '"' : ''
$disabled = $disabled ? ' disabled' : ''
$readonly = $readonly ? ' readonly' : ''
$hint = strlen($hint) ? ' placeholder="' . $this->escape($hint) . '"' : ' placeholder="' . $placeholder . '"'
$required = $required ? ' required' : ''
$autocomplete = !empty($autocomplete) ? ' autocomplete="' . $autocomplete . '"' : ''
$direction = $lang->isRtl() ? ' dir="ltr" style="text-align:right"' : ''
$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
$position
$onchange
$autofocus
$dataAttribute

Documentation des variables

◆ $autocomplete

$autocomplete = !empty($autocomplete) ? ' autocomplete="' . $autocomplete . '"' : ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par QuestionHelper\autocomplete(), HTMLHelper\calendar(), QuestionHelper\doAsk(), et FormField\getLayoutData().

◆ $autofocus

$autofocus

◆ $class

$class = ' class="form-control ' . trim('minicolors ' . $class) . ($validate === 'color' ? '' : $inputclass) . '"'

◆ $colors

$colors = $colors ? ' data-colors="' . $colors . '"' : ''

Référencé par ColorField\getSimpleModeLayoutData(), et Backgroundfill\sanitizeColor().

◆ $control

$control = $control ? ' data-control="' . $control . '"' : ''

Référencé par ColorField\getInput(), SubformField\getInput(), TinymcebuilderField\getLayoutData(), SubformField\loadSubForm(), SubformField\loadSubFormData(), et JavascriptRenderer\setOptions().

◆ $dataAttribute

$dataAttribute

Référencé par FormField\renderDataAttributes().

◆ $direction

$direction = $lang->isRtl() ? ' dir="ltr" style="text-align:right"' : ''

◆ $disabled

$disabled = $disabled ? ' disabled' : ''

◆ $format

$format = $format ? ' data-format="' . $format . '"' : ''

◆ $hint

$hint = strlen($hint) ? ' placeholder="' . $this->escape($hint) . '"' : ' placeholder="' . $placeholder . '"'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), et FormField\getLayoutData().

◆ $inputclass

$inputclass = ($keywords && ! in_array($format, array('rgb', 'rgba'), true)) ? ' keywords' : ' ' . $format

◆ $keywords

$keywords = $keywords ? ' data-keywords="' . $keywords . '"' : ''

Référencé par BannersModel\getItems(), BannersHelper\getList(), et BannersModel\getListQuery().

◆ $onchange

$onchange

◆ $position

$position

◆ $readonly

$readonly = $readonly ? ' readonly' : ''

◆ $required

$required = $required ? ' required' : ''

◆ $validate

$validate = $validate ? ' data-validate="' . $validate . '"' : ''

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

◆ else

if ( $validate !=='color' &&in_array( $format, array( 'rgb', 'rgba'), true)) else
Valeur initiale :
{
$placeholder = '#rrggbb'
$placeholder
$placeholder
Definition: categoryedit.php:71


Joomla CMS: Référence du fichier AES.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier AES.php

Structures de données

class AES

Espaces de nommage

AES
phpseclib3\Crypt


Joomla CMS: Référence du fichier Aes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Structures de données | Espaces de nommage
Référence du fichier Aes.php

Structures de données

class Aes

Espaces de nommage

Joomla\CMS\Encrypt


Joomla CMS: Référence du fichier AesInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
  • AES
Structures de données | Espaces de nommage
Référence du fichier AesInterface.php

Structures de données

interface AesInterface

Espaces de nommage

Joomla\CMS\Encrypt\AES


Joomla CMS: Référence du fichier AfterBindEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterBindEvent.php

Structures de données

class AfterBindEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterCheckinEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterCheckinEvent.php

Structures de données

class AfterCheckinEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterCheckoutEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterCheckoutEvent.php

Structures de données

class AfterCheckoutEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterDeleteEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterDeleteEvent.php

Structures de données

class AfterDeleteEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterExtensionBootEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier AfterExtensionBootEvent.php

Structures de données

class AfterExtensionBootEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier AfterHitEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterHitEvent.php

Structures de données

class AfterHitEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterLoadEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterLoadEvent.php

Structures de données

class AfterLoadEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterMoveEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterMoveEvent.php

Structures de données

class AfterMoveEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterPublishEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterPublishEvent.php

Structures de données

class AfterPublishEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterReorderEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterReorderEvent.php

Structures de données

class AfterReorderEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterResetEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterResetEvent.php

Structures de données

class AfterResetEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier AfterStoreEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier AfterStoreEvent.php

Structures de données

class AfterStoreEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier Agent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
Structures de données | Espaces de nommage
Référence du fichier Agent.php

Structures de données

class Agent

Espaces de nommage

phpseclib3\System\SSH
SSH


Joomla CMS: Référence du fichier AggregatedCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier AggregatedCollector.php

Structures de données

class AggregatedCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier Ajax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier Ajax.php

Structures de données

class Ajax

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier ajax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_ajax
Espaces de nommage
Référence du fichier administrator/components/com_ajax/ajax.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier ajax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_ajax
Espaces de nommage | Variables
Référence du fichier components/com_ajax/ajax.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$input = $app->input
$format = strtolower($input->getWord('format', ''))
$results = null
$parts = null

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $format

$format = strtolower($input->getWord('format', ''))
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Date\__toString(), ApiApplication\addFormatMap(), ASN1\asn1map(), SiteRouter\buildFormat(), HTMLHelper\calendar(), TemplateHelper\canUpload(), PdoDriver\connect(), HTMLHelper\date(), Assertion\date(), DisplayController\display(), ServerDumpCommand\execute(), HtmlDescriptor\extractDate(), DatabaseQuery\format(), CredentialRepository\formatDate(), DateCaster\formatInterval(), FormattedtextLogger\formatLine(), Strings\formatPack(), X509\formatSubjectPublicKey(), Helper\formatTime(), UTCTime\fromBinary(), GeneralizedTime\fromBinary(), X509\getDN(), Parser\getInstance(), BaseController\getInstance(), X509\getIssuerDN(), TagsModel\getListQuery(), X509\getSubjectDN(), Indexer\index(), Select\integerlist(), DayOfWeekField\isSatisfiedBy(), PKCS1\load(), Registry\loadFile(), Registry\loadString(), Strings\packSSH2(), Helper\parse(), DebugClassLoader\patchMethod(), TagModel\populateState(), CategoryModel\populateState(), PKCS8\preParse(), ZIPExtraction\readFileHeader(), VarDumper\register(), DescriptorHelper\register(), Date\relative(), PKCS\requireAny(), PKCS\requireDER(), PKCS\requirePEM(), X509\saveCRL(), X509\saveCSR(), X509\saveSPKAC(), X509\saveX509(), TableStyle\setFooterTitleFormat(), TableStyle\setHeaderTitleFormat(), ASN1\setTimeFormat(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), Serializer\toString(), Registry\toString(), Strings\unpackSSH2(), TemplateModel\validateDate(), et Identity\withSignatureFormat().

◆ $input

$input = $app->input

◆ $parts

$parts = null

◆ $results

$results = null

Référencé par Categories\_load(), Stream\_stream_stat(), Stream\_url_stat(), Authentication\authorise(), CheckinModel\checkin(), CategoryView\commonCategoryDisplay(), StyleTable\delete(), ModuleAdapter\discover(), DiscoverModel\discover(), LibraryAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), Installer\discover(), ComponentAdapter\discover(), FeedView\display(), HtmlView\display(), DatabaseModel\fetchSchemaCache(), FileStorage\find(), RedisStorage\find(), MemcachedStorage\find(), PdoStorage\find(), Files\get(), Input\getArray(), Input\getArrayRecursive(), ChoiceQuestion\getDefaultValidator(), Query\getExcludedTermIds(), Query\getIncludedTermIds(), SearchModel\getItems(), CheckinModel\getItems(), DatabaseModel\getItems(), TagsPopularHelper\getList(), TagsSimilarHelper\getList(), LoggedHelper\getList(), MediaModel\getProviders(), MethodModel\getRenderOptions(), Query\getRequiredTermIds(), TemplateModel\getTemplateList(), Query\getTokenData(), TemplateModel\getUpdatedList(), PluginHelper\importPlugin(), InstallModel\install(), Cache\isExcluded(), PlgInstallerOverride\load(), CaptiveModel\loadCaptiveRenderOptions(), Installer\loadMD5Sum(), MenusHelper\loadXml(), CMSApplication\login(), CMSApplication\logout(), DatabaseModel\mergeSchemaCache(), Cache\onAfterRoute(), PlgUserProfile\onContentPrepareData(), PlgEditorCodemirror\onDisplay(), PlgExtensionJoomla\onExtensionAfterUninstall(), PlgAuthenticationCookie\onUserAfterLogin(), PlgAuthenticationCookie\onUserAuthenticate(), Query\processDynamicTaxonomy(), Query\processStaticTaxonomy(), StringsModel\search(), LocalAdapter\search(), TagsController\searchAjax(), PlgAuthenticationLdap\searchByString(), TagsHelper\searchTags(), X509\setDN(), UserHelper\setUserGroups(), LdapClient\simple_search(), ContactController\submit(), et JoomlaInstallerScript\updateDatabaseMysql().


Joomla CMS: Référence du fichier AjaxChallenge.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxChallenge.php

Structures de données

class AjaxChallenge

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AjaxController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_categories/src/Controller/AjaxController.php

Structures de données

class AjaxController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Controller


Joomla CMS: Référence du fichier AjaxController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/Controller/AjaxController.php

Structures de données

class AjaxController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Controller


Joomla CMS: Référence du fichier AjaxController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_content/src/Controller/AjaxController.php

Structures de données

class AjaxController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Controller


Joomla CMS: Référence du fichier AjaxController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_menus/src/Controller/AjaxController.php

Structures de données

class AjaxController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier AjaxController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/src/Controller/AjaxController.php

Structures de données

class AjaxController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Controller


Joomla CMS: Référence du fichier AjaxCreate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxCreate.php

Structures de données

class AjaxCreate

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AjaxDelete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxDelete.php

Structures de données

class AjaxDelete

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AjaxHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandler.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerChallenge.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerChallenge.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerCreate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerCreate.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerDelete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerDelete.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerInitCreate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerInitCreate.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerLogin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerLogin.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxHandlerSaveLabel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier AjaxHandlerSaveLabel.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier AjaxInitCreate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxInitCreate.php

Structures de données

class AjaxInitCreate

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AjaxLogin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxLogin.php

Structures de données

class AjaxLogin

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AjaxSaveLabel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Structures de données | Espaces de nommage
Référence du fichier AjaxSaveLabel.php

Structures de données

class AjaxSaveLabel

Espaces de nommage

Joomla\CMS\Event\Plugin\System\Webauthn


Joomla CMS: Référence du fichier Algorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Algorithm.php

Structures de données

interface Algorithm

Espaces de nommage

Cose\Algorithm


Joomla CMS: Référence du fichier Algorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-core/Algorithm.php

Structures de données

interface Algorithm

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier AlgorithmIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/X509/AlgorithmIdentifier.php

Structures de données

class AlgorithmIdentifier

Espaces de nommage

FG\X509


Joomla CMS: Référence du fichier AlgorithmIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AlgorithmIdentifier.php

Structures de données

class AlgorithmIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AlgorithmManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier AlgorithmManager.php

Structures de données

class AlgorithmManager

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier AlgorithmManagerFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier AlgorithmManagerFactory.php

Structures de données

class AlgorithmManagerFactory

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier Algorithms.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier Algorithms.php

Structures de données

class Algorithms

Espaces de nommage

Cose


Joomla CMS: Référence du fichier AliastagField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier AliastagField.php

Structures de données

class AliastagField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier AllowedAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Structures de données | Espaces de nommage
Référence du fichier AllowedAttributes.php

Structures de données

class AllowedAttributes

Espaces de nommage

enshrined\svgSanitize\data
enshrined


Joomla CMS: Référence du fichier AllowedTags.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Structures de données | Espaces de nommage
Référence du fichier AllowedTags.php

Structures de données

class AllowedTags

Espaces de nommage

enshrined\svgSanitize\data
enshrined


Joomla CMS: Référence du fichier AlreadyExistsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier AlreadyExistsException.php

Structures de données

class AlreadyExistsException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier AlreadyPunycodeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier AlreadyPunycodeException.php

Structures de données

class AlreadyPunycodeException

Espaces de nommage

Algo26\IdnaConvert\Exception


Joomla CMS: Référence du fichier AmqpCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier AmqpCaster.php

Structures de données

class AmqpCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier AndroidKeyAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/AndroidKeyAttestationStatementSupport.php

Structures de données

class AndroidKeyAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AndroidKeyAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php

Structures de données

class AndroidKeyAttestationStatementSupport

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn\Hotfix


Joomla CMS: Référence du fichier AndroidKeyAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/system/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php

Structures de données

class AndroidKeyAttestationStatementSupport

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\Hotfix


Joomla CMS: Référence du fichier AndroidSafetyNetAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AndroidSafetyNetAttestationStatementSupport.php

Structures de données

class AndroidSafetyNetAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AnotherName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AnotherName.php

Structures de données

class AnotherName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ANSI.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
Structures de données | Espaces de nommage
Référence du fichier ANSI.php

Structures de données

class ANSI

Espaces de nommage

ANSI
phpseclib3\File


Joomla CMS: Référence du fichier ApcuHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier ApcuHandler.php

Structures de données

class ApcuHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier ApcuStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier ApcuStorage.php

Structures de données

class ApcuStorage

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier ApiApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier ApiApplication.php

Structures de données

class ApiApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier ApiController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Controller/ApiController.php

Structures de données

class ApiController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Controller


Joomla CMS: Référence du fichier ApiController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Structures de données | Espaces de nommage
Référence du fichier libraries/src/MVC/Controller/ApiController.php

Structures de données

class ApiController

Espaces de nommage

Joomla\CMS\MVC\Controller


Joomla CMS: Référence du fichier ApiDispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier ApiDispatcher.php

Structures de données

class ApiDispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ApiModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ApiModel.php

Structures de données

class ApiModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Model


Joomla CMS: Référence du fichier ApiMVCFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Structures de données | Espaces de nommage
Référence du fichier ApiMVCFactory.php

Structures de données

class ApiMVCFactory

Espaces de nommage

Joomla\CMS\MVC\Factory


Joomla CMS: Référence du fichier ApiRouter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier ApiRouter.php

Structures de données

class ApiRouter

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier app.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • includes
Espaces de nommage | Variables
Référence du fichier administrator/includes/app.php

Espaces de nommage

Joomla\Administrator

Variables

$startTime = microtime(1)
$startMem = memory_get_usage()
if(file_exists(dirname(__DIR__) . '/defines.php')) if(!defined('_JDEFINES')) if (!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))
$container = \Joomla\CMS\Factory::getContainer()
$app = $container->get(\Joomla\CMS\Application\AdministratorApplication::class)

Documentation des variables

◆ $app

$app = $container->get(\Joomla\CMS\Application\AdministratorApplication::class)

◆ $container

$container = \Joomla\CMS\Factory::getContainer()

Référencé par WritableContainerLoader\__construct(), InstallationApplication\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), SiteApplication\__construct(), CliApplication\__construct(), CMSApplication\__construct(), FinderComponent\boot(), BannersComponent\boot(), ContactComponent\boot(), Factory\createContainer(), Installer\findDeletedFiles(), Joomla\DI\getContainer(), Factory\getContainer(), CMSApplication\getInstance(), UserHelper\hashPassword(), PlgWorkflowNotification\onWorkflowAfterTransition(), AddConsoleCommandPass\process(), WebAssetRegistry\register(), HTMLRegistry\register(), Config\register(), Dispatcher\register(), Pathway\register(), Toolbar\register(), Logger\register(), CacheController\register(), Language\register(), Module\register(), ServiceProviderInterface\register(), User\register(), Document\register(), Form\register(), Menu\register(), Database\register(), Application\register(), Router\register(), Authentication\register(), ModuleDispatcherFactory\register(), Console\register(), CategoryFactory\register(), HelperFactory\register(), ComponentDispatcherFactory\register(), RouterFactory\register(), MVCFactory\register(), Session\registerSessionHandlerAsService(), Joomla\DI\setContainer(), Symfony\Contracts\Service\setContainer(), et InstallerAdapter\setupScriptfile().

◆ $startMem

$startMem = memory_get_usage()

Référencé par Profiler\setStart().

◆ $startTime

$startTime = microtime(1)

Référencé par UpdateAdapter\getUpdateSiteResponse(), et Profiler\setStart().

◆ if

if (file_exists(dirname(__DIR__) . '/defines.php')) if (!defined( '_JDEFINES')) if(!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))


Joomla CMS: Référence du fichier app.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • includes
Espaces de nommage | Variables
Référence du fichier api/includes/app.php

Espaces de nommage

Joomla\API

Variables

$startTime = microtime(1)
$startMem = memory_get_usage()
if(file_exists(dirname(__DIR__) . '/defines.php')) if (!defined( '_JDEFINES'))
$container = \Joomla\CMS\Factory::getContainer()
$app = $container->get(\Joomla\CMS\Application\ApiApplication::class)

Documentation des variables

◆ $app

$app = $container->get(\Joomla\CMS\Application\ApiApplication::class)

◆ $container

$container = \Joomla\CMS\Factory::getContainer()

◆ $startMem

$startMem = memory_get_usage()

◆ $startTime

$startTime = microtime(1)

◆ if

if (file_exists(dirname(__DIR__) . '/defines.php')) if(!defined('_JDEFINES'))


Joomla CMS: Référence du fichier app.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • includes
Espaces de nommage | Variables
Référence du fichier includes/app.php

Espaces de nommage

Joomla\Site

Variables

$startTime = microtime(1)
$startMem = memory_get_usage()
if(file_exists(dirname(__DIR__) . '/defines.php')) if(!defined('_JDEFINES')) if (!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))
$container = \Joomla\CMS\Factory::getContainer()
$app = $container->get(\Joomla\CMS\Application\SiteApplication::class)

Documentation des variables

◆ $app

$app = $container->get(\Joomla\CMS\Application\SiteApplication::class)

◆ $container

$container = \Joomla\CMS\Factory::getContainer()

◆ $startMem

$startMem = memory_get_usage()

◆ $startTime

$startTime = microtime(1)

◆ if

if (file_exists(dirname(__DIR__) . '/defines.php')) if (!defined( '_JDEFINES')) if(!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))


Joomla CMS: Référence du fichier app.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • includes
Espaces de nommage | Variables
Référence du fichier installation/includes/app.php

Espaces de nommage

Joomla\Installation

Variables

const JPATH_BASE dirname(__DIR__)
if (!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))
$container = \Joomla\CMS\Factory::getContainer()

Documentation des variables

◆ $container

$container = \Joomla\CMS\Factory::getContainer()

◆ if

if(!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor'))

◆ JPATH_BASE

const JPATH_BASE dirname(__DIR__)

Référencé par OpensearchDocument\__construct(), LanguagesModel\__construct(), Language\__construct(), HtmlDocument\_fetchTemplate(), Uri\base(), Help\createUrl(), ModuleDispatcher\dispatch(), LegacyComponentDispatcher\dispatch(), InstallationApplication\dispatch(), HtmlView\display(), ComponentModel\getComponent(), RandomImageHelper\getFolder(), ComponentModel\getForm(), RandomImageHelper\getImages(), RouteHelper\getItemRoute(), RequestController\getJson(), Authentication\getKnownAuthenticators(), HelpModel\getLangTag(), ModuleHelper\getLayoutPath(), LanguageHelper\getMetadata(), ComponentsCategoryField\getOptions(), ModulesModel\getPositions(), RandomImageHelper\getRandomImage(), Authentication\getSiteIcon(), HelpModel\getToc(), ApiDispatcher\loadLanguage(), ComponentDispatcher\loadLanguage(), AbstractModuleDispatcher\loadLanguage(), ConfigHelper\loadLanguageForComponent(), HtmlView\loadTemplate(), ActionlogsHelper\loadTranslationFiles(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), GroupModel\preprocessForm(), CategoryModel\preprocessForm(), FieldModel\preprocessForm(), UpdateCoreCommand\processUpdatePackage(), WebApplication\render(), CMSApplication\render(), UpdateCoreCommand\updateJoomlaCore(), et Joomla\CMS\MVC\Model\workflowAfterSave().


Joomla CMS: Référence du fichier Application.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier installation/src/Service/Provider/Application.php

Structures de données

class Application

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Service\Provider


Joomla CMS: Référence du fichier Application.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Application.php

Structures de données

class Application

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Application.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/console/src/Application.php

Structures de données

class Application

Espaces de nommage

Joomla\Console


Joomla CMS: Référence du fichier Application.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/console/Application.php

Structures de données

class Application

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier ApplicationController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/Controller/ApplicationController.php

Structures de données

class ApplicationController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Controller


Joomla CMS: Référence du fichier ApplicationController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_config/src/Controller/ApplicationController.php

Structures de données

class ApplicationController

Espaces de nommage

Joomla\API
Joomla\Component\Config\Api\Controller


Joomla CMS: Référence du fichier ApplicationDescription.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Descriptor/ApplicationDescription.php

Structures de données

class ApplicationDescription

Espaces de nommage

Joomla\Console\Descriptor


Joomla CMS: Référence du fichier ApplicationDescription.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Descriptor/ApplicationDescription.php

Structures de données

class ApplicationDescription

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier ApplicationErrorEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier application/src/Event/ApplicationErrorEvent.php

Structures de données

class ApplicationErrorEvent

Espaces de nommage

Joomla\Application\Event


Joomla CMS: Référence du fichier ApplicationErrorEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier console/src/Event/ApplicationErrorEvent.php

Structures de données

class ApplicationErrorEvent

Espaces de nommage

Joomla\Console\Event


Joomla CMS: Référence du fichier ApplicationEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier ApplicationEvent.php

Structures de données

class ApplicationEvent

Espaces de nommage

Joomla\Application\Event


Joomla CMS: Référence du fichier ApplicationEvents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier ApplicationEvents.php

Structures de données

class ApplicationEvents

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier ApplicationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier ApplicationHelper.php

Structures de données

class ApplicationHelper

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier ApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier ApplicationInterface.php

Structures de données

interface ApplicationInterface

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier ApplicationModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ApplicationModel.php

Structures de données

class ApplicationModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Model


Joomla CMS: Référence du fichier ApplicationTester.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
Structures de données | Espaces de nommage
Référence du fichier ApplicationTester.php

Structures de données

class ApplicationTester

Espaces de nommage

Symfony\Component\Console\Tester


Joomla CMS: Référence du fichier Archive.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier Archive.php

Structures de données

class Archive

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier ArchiveModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ArchiveModel.php

Structures de données

class ArchiveModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier Argon2idHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier src/Authentication/Password/Argon2idHandler.php

Structures de données

class Argon2idHandler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier Argon2idHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Password
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/authentication/src/Password/Argon2idHandler.php

Structures de données

class Argon2idHandler

Espaces de nommage

Joomla\Authentication\Password


Joomla CMS: Référence du fichier Argon2iHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier src/Authentication/Password/Argon2iHandler.php

Structures de données

class Argon2iHandler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier Argon2iHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Password
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/authentication/src/Password/Argon2iHandler.php

Structures de données

class Argon2iHandler

Espaces de nommage

Joomla\Authentication\Password


Joomla CMS: Référence du fichier ArgsStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ArgsStub.php

Structures de données

class ArgsStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier ArgvInput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier ArgvInput.php

Structures de données

class ArgvInput

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier ArrayHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • utilities
  • src
Structures de données | Espaces de nommage
Référence du fichier ArrayHelper.php

Structures de données

class ArrayHelper

Espaces de nommage

Joomla\Utilities


Joomla CMS: Référence du fichier ArrayInput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier ArrayInput.php

Structures de données

class ArrayInput

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier ArraySerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Request
Structures de données | Espaces de nommage
Référence du fichier Request/ArraySerializer.php

Structures de données

class ArraySerializer

Espaces de nommage

Laminas\Diactoros\Request


Joomla CMS: Référence du fichier ArraySerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier Response/ArraySerializer.php

Structures de données

class ArraySerializer

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier article.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • article
Structures de données | Espaces de nommage
Référence du fichier article.php

Structures de données

class PlgButtonArticle

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ArticleController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Controller/ArticleController.php

Structures de données

class ArticleController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Controller


Joomla CMS: Référence du fichier ArticleController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Controller/ArticleController.php

Structures de données

class ArticleController

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Controller


Joomla CMS: Référence du fichier ArticleField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier ArticleField.php

Structures de données

class ArticleField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Field\Modal


Joomla CMS: Référence du fichier ArticleModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Model/ArticleModel.php

Structures de données

class ArticleModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Model


Joomla CMS: Référence du fichier ArticleModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/ArticleModel.php

Structures de données

class ArticleModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier ArticlesArchiveHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesArchiveHelper.php

Structures de données

class ArticlesArchiveHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesArchive\Site\Helper


Joomla CMS: Référence du fichier ArticlesCategoriesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesCategoriesHelper.php

Structures de données

class ArticlesCategoriesHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesCategories\Site\Helper


Joomla CMS: Référence du fichier ArticlesCategoryHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesCategoryHelper.php

Structures de données

class ArticlesCategoryHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesCategory\Site\Helper


Joomla CMS: Référence du fichier ArticlesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Controller/ArticlesController.php

Structures de données

class ArticlesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Controller


Joomla CMS: Référence du fichier ArticlesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_content/src/Controller/ArticlesController.php

Structures de données

class ArticlesController

Espaces de nommage

Joomla\API
Joomla\Component\Content\Api\Controller


Joomla CMS: Référence du fichier ArticlesLatestHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesLatestHelper.php

Structures de données

class ArticlesLatestHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesLatest\Site\Helper


Joomla CMS: Référence du fichier ArticlesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Model/ArticlesModel.php

Structures de données

class ArticlesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Model


Joomla CMS: Référence du fichier ArticlesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/ArticlesModel.php

Structures de données

class ArticlesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier ArticlesNewsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesNewsHelper.php

Structures de données

class ArticlesNewsHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesNews\Site\Helper


Joomla CMS: Référence du fichier ArticlesPopularHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ArticlesPopularHelper.php

Structures de données

class ArticlesPopularHelper

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesPopular\Site\Helper


Joomla CMS: Référence du fichier ArticleTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ArticleTable.php

Structures de données

class ArticleTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Table


Joomla CMS: Référence du fichier ASCII.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
Structures de données | Espaces de nommage
Référence du fichier ASCII.php

Structures de données

class ASCII

Espaces de nommage

voku\helper


Joomla CMS: Référence du fichier ascii.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions
Référence du fichier ascii.php

Espaces de nommage

utf8

Fonctions

utf8_is_ascii ($str)
utf8_is_ascii_ctrl ($str)
utf8_strip_non_ascii ($str)
utf8_strip_ascii_ctrl ($str)
utf8_strip_non_ascii_ctrl ($str)
utf8_accents_to_ascii ( $str, $case=0)

Documentation des fonctions

◆ utf8_accents_to_ascii()

utf8_accents_to_ascii | ( | $str,
 |  | $case = 0
 | ) |

◆ utf8_is_ascii()

utf8_is_ascii ( $str )

Référencé par StringHelper\is_ascii().

◆ utf8_is_ascii_ctrl()

utf8_is_ascii_ctrl ( $str )

◆ utf8_strip_ascii_ctrl()

utf8_strip_ascii_ctrl ( $str )

Strip out device control codes in the ASCII range which are not permitted in XML. Note that this leaves multi-byte characters untouched - it only removes device control codes

Voir également
http://hsivonen.iki.fi/producing-xml/#controlchar
Paramètres
string
Renvoie
string control codes removed

Références $result.

◆ utf8_strip_non_ascii()

utf8_strip_non_ascii ( $str )

Références $result.

◆ utf8_strip_non_ascii_ctrl()

utf8_strip_non_ascii_ctrl ( $str )

Références $result.


Joomla CMS: Référence du fichier ascii_by_languages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier ascii_by_languages.php

Variables

return ['nl'=> ['Á'=> 'A', 'á'=> 'a', 'Ä'=> 'A', 'ä'=> 'a', 'À'=> 'A', 'à'=> 'a', 'Â'=> 'A', 'â'=> 'a', 'É'=> 'E', 'é'=> 'e', 'Ë'=> 'E', 'ë'=> 'e', 'È'=> 'E', 'è'=> 'e', 'Ê'=> 'E', 'ê'=> 'e', 'Í'=> 'I', 'í'=> 'i', 'Ï'=> 'I', 'ï'=> 'i', 'Ì'=> 'I', 'ì'=> 'i', 'Î'=> 'I', 'î'=> 'i', 'Ó'=> 'O', 'ó'=> 'o', 'Ö'=> 'O', 'ö'=> 'o', 'Ò'=> 'O', 'ò'=> 'o', 'Ô'=> 'O', 'ô'=> 'o', 'Ú'=> 'U', 'ú'=> 'u', 'Ü'=> 'U', 'ü'=> 'u', 'Ù'=> 'U', 'ù'=> 'u', 'Û'=> 'U', 'û'=> 'u', 'Ý'=> 'Y', 'ý'=> 'y', 'Ÿ'=> 'Y',], 'it'=> ['à'=> 'a', 'À'=> 'A', 'é'=> 'e', 'É'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ì'=> 'i', 'Ì'=> 'I', 'Ò'=> 'O', 'ò'=> 'o', 'ù'=> 'u', 'Ù'=> 'U',], 'mk'=> ['А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ѓ'=> 'Gj', 'Е'=> 'E', 'Ж'=> 'Zh', 'З'=> 'Z', 'Ѕ'=> 'Dz', 'И'=> 'I', 'Ј'=> 'J', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ќ'=> 'Kj', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'Ch', 'Џ'=> 'Dj', 'Ш'=> 'Sh', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ѓ'=> 'gj', 'е'=> 'e', 'ж'=> 'zh', 'з'=> 'z', 'ѕ'=> 'dz', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ќ'=> 'kj', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'ch', 'џ'=> 'dj', 'ш'=> 'sh',], 'pt'=> ['æ'=> 'ae', 'ǽ'=> 'ae', 'À'=> 'A', 'Á'=> 'A', 'Â'=> 'A', 'Ã'=> 'A', 'Å'=> 'AA', 'Ǻ'=> 'A', 'Ă'=> 'A', 'Ǎ'=> 'A', 'Æ'=> 'AE', 'Ǽ'=> 'AE', 'à'=> 'a', 'á'=> 'a', 'â'=> 'a', 'ã'=> 'a', 'å'=> 'aa', 'ǻ'=> 'a', 'ă'=> 'a', 'ǎ'=> 'a', 'ª'=> 'a', 'Ĉ'=> 'C', 'Ċ'=> 'C', 'Ç'=> 'C', 'ç'=> 'c', 'ĉ'=> 'c', 'ċ'=> 'c', 'Ð'=> 'Dj', 'Đ'=> 'D', 'ð'=> 'dj', 'đ'=> 'd', 'È'=> 'E', 'É'=> 'E', 'Ê'=> 'E', 'Ë'=> 'E', 'Ĕ'=> 'E', 'Ė'=> 'E', 'è'=> 'e', 'é'=> 'e', 'ê'=> 'e', 'ë'=> 'e', 'ĕ'=> 'e', 'ė'=> 'e', 'ƒ'=> 'f', 'Ĝ'=> 'G', 'Ġ'=> 'G', 'ĝ'=> 'g', 'ġ'=> 'g', 'Ĥ'=> 'H', 'Ħ'=> 'H', 'ĥ'=> 'h', 'ħ'=> 'h', 'Ì'=> 'I', 'Í'=> 'I', 'Î'=> 'I', 'Ï'=> 'I', 'Ĩ'=> 'I', 'Ĭ'=> 'I', 'Ǐ'=> 'I', 'Į'=> 'I', 'Ĳ'=> 'IJ', 'ì'=> 'i', 'í'=> 'i', 'î'=> 'i', 'ï'=> 'i', 'ĩ'=> 'i', 'ĭ'=> 'i', 'ǐ'=> 'i', 'į'=> 'i', 'ĳ'=> 'ij', 'Ĵ'=> 'J', 'ĵ'=> 'j', 'Ĺ'=> 'L', 'Ľ'=> 'L', 'Ŀ'=> 'L', 'ĺ'=> 'l', 'ľ'=> 'l', 'ŀ'=> 'l', 'Ñ'=> 'N', 'ñ'=> 'n', 'ŉ'=> 'n', 'Ò'=> 'O', 'Ó'=> 'O', 'Ô'=> 'O', 'Õ'=> 'O', 'Ō'=> 'O', 'Ŏ'=> 'O', 'Ǒ'=> 'O', 'Ő'=> 'O', 'Ơ'=> 'O', 'Ø'=> 'OE', 'Ǿ'=> 'O', 'Œ'=> 'OE', 'ò'=> 'o', 'ó'=> 'o', 'ô'=> 'o', 'õ'=> 'o', 'ō'=> 'o', 'ŏ'=> 'o', 'ǒ'=> 'o', 'ő'=> 'o', 'ơ'=> 'o', 'ø'=> 'oe', 'ǿ'=> 'o', 'º'=> 'o', 'œ'=> 'oe', 'Ŕ'=> 'R', 'Ŗ'=> 'R', 'ŕ'=> 'r', 'ŗ'=> 'r', 'Ŝ'=> 'S', 'Ș'=> 'S', 'ŝ'=> 's', 'ș'=> 's', 'ſ'=> 's', 'Ţ'=> 'T', 'Ț'=> 'T', 'Ŧ'=> 'T', 'Þ'=> 'TH', 'ţ'=> 't', 'ț'=> 't', 'ŧ'=> 't', 'þ'=> 'th', 'Ù'=> 'U', 'Ú'=> 'U', 'Û'=> 'U', 'Ü'=> 'U', 'Ũ'=> 'U', 'Ŭ'=> 'U', 'Ű'=> 'U', 'Ų'=> 'U', 'Ư'=> 'U', 'Ǔ'=> 'U', 'Ǖ'=> 'U', 'Ǘ'=> 'U', 'Ǚ'=> 'U', 'Ǜ'=> 'U', 'ù'=> 'u', 'ú'=> 'u', 'û'=> 'u', 'ü'=> 'u', 'ũ'=> 'u', 'ŭ'=> 'u', 'ű'=> 'u', 'ų'=> 'u', 'ư'=> 'u', 'ǔ'=> 'u', 'ǖ'=> 'u', 'ǘ'=> 'u', 'ǚ'=> 'u', 'ǜ'=> 'u', 'Ŵ'=> 'W', 'ŵ'=> 'w', 'Ý'=> 'Y', 'Ÿ'=> 'Y', 'Ŷ'=> 'Y', 'ý'=> 'y', 'ÿ'=> 'y', 'ŷ'=> 'y',], 'el__greeklish'=> ['ΑΥ'=> 'AU', 'ΑΎ'=> 'AU', 'Αυ'=> 'Au', 'Αύ'=> 'Au', 'ΕΊ'=> 'EI', 'ΕΙ'=> 'EI', 'Ει'=> 'EI', 'ΕΥ'=> 'EU', 'ΕΎ'=> 'EU', 'Εί'=> 'Ei', 'Ευ'=> 'Eu', 'Εύ'=> 'Eu', 'ΟΙ'=> 'OI', 'ΟΊ'=> 'OI', 'ΟΥ'=> 'OU', 'ΟΎ'=> 'OU', 'Οι'=> 'Oi', 'Οί'=> 'Oi', 'Ου'=> 'Ou', 'Ού'=> 'Ou', 'ΥΙ'=> 'YI', 'ΎΙ'=> 'YI', 'Υι'=> 'Yi', 'Ύι'=> 'Yi', 'ΥΊ'=> 'Yi', 'Υί'=> 'Yi', 'αυ'=> 'au', 'αύ'=> 'au', 'εί'=> 'ei', 'ει'=> 'ei', 'ευ'=> 'eu', 'εύ'=> 'eu', 'οι'=> 'oi', 'οί'=> 'oi', 'ου'=> 'ou', 'ού'=> 'ou', 'υι'=> 'yi', 'ύι'=> 'yi', 'υί'=> 'yi', 'Α'=> 'A', 'Ά'=> 'A', 'Β'=> 'B', 'Δ'=> 'D', 'Ε'=> 'E', 'Έ'=> 'E', 'Φ'=> 'F', 'Γ'=> 'G', 'Η'=> 'H', 'Ή'=> 'H', 'Ι'=> 'I', 'Ί'=> 'I', 'Ϊ'=> 'I', 'Κ'=> 'K', 'Ξ'=> 'Ks', 'Λ'=> 'L', 'Μ'=> 'M', 'Ν'=> 'N', 'Π'=> 'N', 'Ο'=> 'O', 'Ό'=> 'O', 'Ψ'=> 'Ps', 'Ρ'=> 'R', 'Σ'=> 'S', 'Τ'=> 'T', 'Θ'=> 'Th', 'Ω'=> 'W', 'Ώ'=> 'W', 'Χ'=> 'X', 'ϒ'=> 'Y', 'Υ'=> 'Y', 'Ύ'=> 'Y', 'Ϋ'=> 'Y', 'Ζ'=> 'Z', 'α'=> 'a', 'ά'=> 'a', 'β'=> 'b', 'δ'=> 'd', 'ε'=> 'e', 'έ'=> 'e', 'φ'=> 'f', 'γ'=> 'g', 'η'=> 'h', 'ή'=> 'h', 'ι'=> 'i', 'ί'=> 'i', 'ϊ'=> 'i', 'ΐ'=> 'i', 'κ'=> 'k', 'ξ'=> 'ks', 'λ'=> 'l', 'μ'=> 'm', 'ν'=> 'n', 'ο'=> 'o', 'ό'=> 'o', 'π'=> 'p', 'ψ'=> 'ps', 'ρ'=> 'r', 'σ'=> 's', 'ς'=> 's', 'τ'=> 't', 'ϑ'=> 'th', 'θ'=> 'th', 'ϐ'=> 'v', 'ω'=> 'w', 'ώ'=> 'w', 'χ'=> 'x', 'υ'=> 'y', 'ύ'=> 'y', 'ΰ'=> 'y', 'ϋ'=> 'y', 'ζ'=> 'z',], 'el'=> ['ΑΥ'=> 'AU', 'Αυ'=> 'Au', 'ΟΥ'=> 'U', 'Ου'=> 'u', 'ΕΥ'=> 'EF', 'Ευ'=> 'Ef', 'ΕΙ'=> 'I', 'Ει'=> 'I', 'ΟΙ'=> 'I', 'Οι'=> 'I', 'ΥΙ'=> 'I', 'Υι'=> 'I', 'ΑΎ'=> 'AU', 'Αύ'=> 'Au', 'ΟΎ'=> 'OU', 'Ού'=> 'Ou', 'ΕΎ'=> 'EU', 'Εύ'=> 'Eu', 'ΕΊ'=> 'I', 'Εί'=> 'I', 'ΟΊ'=> 'I', 'Οί'=> 'I', 'ΎΙ'=> 'I', 'Ύι'=> 'I', 'ΥΊ'=> 'I', 'Υί'=> 'I', 'αυ'=> 'au', 'ου'=> 'u', 'ευ'=> 'ef', 'ει'=> 'i', 'οι'=> 'i', 'υι'=> 'i', 'αύ'=> 'au', 'ού'=> 'ou', 'εύ'=> 'eu', 'εί'=> 'i', 'οί'=> 'i', 'ύι'=> 'i', 'υί'=> 'i', 'α'=> 'a', 'β'=> 'v', 'γ'=> 'gh', 'δ'=> 'd', 'ε'=> 'e', 'ζ'=> 'z', 'η'=> 'i', 'θ'=> 'th', 'ι'=> 'i', 'κ'=> 'k', 'λ'=> 'l', 'μ'=> 'm', 'ν'=> 'n', 'ξ'=> 'ks', 'ο'=> 'o', 'π'=> 'p', 'ρ'=> 'r', 'σ'=> 's', 'τ'=> 't', 'υ'=> 'i', 'φ'=> 'f', 'χ'=> 'kh', 'ψ'=> 'ps', 'ω'=> 'o', 'ά'=> 'a', 'έ'=> 'e', 'ί'=> 'i', 'ό'=> 'o', 'ϒ'=> 'Y', 'ύ'=> 'y', 'ή'=> 'i', 'ώ'=> 'w', 'ς'=> 's', 'ϊ'=> 'i', 'ΰ'=> 'y', 'ϋ'=> 'y', 'ΐ'=> 'i', 'Α'=> 'A', 'Β'=> 'B', 'Γ'=> 'G', 'Δ'=> 'D', 'Ε'=> 'E', 'Ζ'=> 'Z', 'Η'=> 'H', 'Θ'=> 'Th', 'Ι'=> 'I', 'Κ'=> 'K', 'Λ'=> 'L', 'Μ'=> 'M', 'Ν'=> 'N', 'Ξ'=> 'Ks', 'Ο'=> 'O', 'Π'=> 'P', 'Ρ'=> 'R', 'Σ'=> 'S', 'Τ'=> 'T', 'Υ'=> 'Y', 'Φ'=> 'F', 'Χ'=> 'X', 'Ψ'=> 'Ps', 'Ω'=> 'O', 'Ά'=> 'A', 'Έ'=> 'E', 'Ί'=> 'I', 'Ό'=> 'O', 'Ύ'=> 'Y', 'Ή'=> 'I', 'Ώ'=> 'W', 'Ϊ'=> 'I', 'Ϋ'=> 'Y', 'ϐ'=> 'v', 'ϑ'=> 'th',], 'hi'=> ['अ'=> 'a', 'आ'=> 'aa', 'ए'=> 'e', 'ई'=> 'ii', 'ऍ'=> 'ei', 'ऎ'=> 'ae', 'ऐ'=> 'ai', 'इ'=> 'i', 'ओ'=> 'o', 'ऑ'=> 'oi', 'ऒ'=> 'oii', 'ऊ'=> 'uu', 'औ'=> 'ou', 'उ'=> 'u', 'ब'=> 'B', 'भ'=> 'Bha', 'च'=> 'Ca', 'छ'=> 'Chha', 'ड'=> 'Da', 'ढ'=> 'Dha', 'फ'=> 'Fa', 'फ़'=> 'Fi', 'ग'=> 'Ga', 'घ'=> 'Gha', 'ग़'=> 'Ghi', 'ह'=> 'Ha', 'ज'=> 'Ja', 'झ'=> 'Jha', 'क'=> 'Ka', 'ख'=> 'Kha', 'ख़'=> 'Khi', 'ल'=> 'L', 'ळ'=> 'Li', 'ऌ'=> 'Li', 'ऴ'=> 'Lii', 'ॡ'=> 'Lii', 'म'=> 'Ma', 'न'=> 'Na', 'ङ'=> 'Na', 'ञ'=> 'Nia', 'ण'=> 'Nae', 'ऩ'=> 'Ni', 'ॐ'=> 'oms', 'प'=> 'Pa', 'क़'=> 'Qi', 'र'=> 'Ra', 'ऋ'=> 'Ri', 'ॠ'=> 'Ri', 'ऱ'=> 'Ri', 'स'=> 'Sa', 'श'=> 'Sha', 'ष'=> 'Shha', 'ट'=> 'Ta', 'त'=> 'Ta', 'ठ'=> 'Tha', 'द'=> 'Tha', 'थ'=> 'Tha', 'ध'=> 'Thha', 'ड़'=> 'ugDha', 'ढ़'=> 'ugDhha', 'व'=> 'Va', 'य'=> 'Ya', 'य़'=> 'Yi', 'ज़'=> 'Za',], 'hy'=> ['Ա'=> 'A', 'Բ'=> 'B', 'Գ'=> 'G', 'Դ'=> 'D', 'Ե'=> 'E', 'Զ'=> 'Z', 'Է'=> 'E', 'Ը'=> 'Y', 'Թ'=> 'Th', 'Ժ'=> 'Zh', 'Ի'=> 'I', 'Լ'=> 'L', 'Խ'=> 'Kh', 'Ծ'=> 'Ts', 'Կ'=> 'K', 'Հ'=> 'H', 'Ձ'=> 'Dz', 'Ղ'=> 'Gh', 'Ճ'=> 'Tch', 'Մ'=> 'M', 'Յ'=> 'Y', 'Ն'=> 'N', 'Շ'=> 'Sh', 'Ո'=> 'Vo', 'Չ'=> 'Ch', 'Պ'=> 'P', 'Ջ'=> 'J', 'Ռ'=> 'R', 'Ս'=> 'S', 'Վ'=> 'V', 'Տ'=> 'T', 'Ր'=> 'R', 'Ց'=> 'C', 'Ւ'=> 'u', 'Փ'=> 'Ph', 'Ք'=> 'Q', 'և'=> 'ev', 'Օ'=> 'O', 'Ֆ'=> 'F', 'ա'=> 'a', 'բ'=> 'b', 'գ'=> 'g', 'դ'=> 'd', 'ե'=> 'e', 'զ'=> 'z', 'է'=> 'e', 'ը'=> 'y', 'թ'=> 'th', 'ժ'=> 'zh', 'ի'=> 'i', 'լ'=> 'l', 'խ'=> 'kh', 'ծ'=> 'ts', 'կ'=> 'k', 'հ'=> 'h', 'ձ'=> 'dz', 'ղ'=> 'gh', 'ճ'=> 'tch', 'մ'=> 'm', 'յ'=> 'y', 'ն'=> 'n', 'շ'=> 'sh', 'ո'=> 'vo', 'չ'=> 'ch', 'պ'=> 'p', 'ջ'=> 'j', 'ռ'=> 'r', 'ս'=> 's', 'վ'=> 'v', 'տ'=> 't', 'ր'=> 'r', 'ց'=> 'c', 'ւ'=> 'u', 'փ'=> 'ph', 'ք'=> 'q', 'օ'=> 'o', 'ֆ'=> 'f',], 'sv'=> ['Ä'=> 'A', 'ä'=> 'a', 'Å'=> 'A', 'å'=> 'a', 'Ö'=> 'O', 'ö'=> 'o',], 'tk'=> ['Ç'=> 'C', 'Ä'=> 'A', 'Ž'=> 'Z', 'Ň'=> 'N', 'Ö'=> 'O', 'Ş'=> 'S', 'Ü'=> 'U', 'Ý'=> 'Y', 'ç'=> 'c', 'ä'=> 'a', 'ž'=> 'z', 'ň'=> 'n', 'ö'=> 'o', 'ş'=> 's', 'ü'=> 'u', 'ý'=> 'y',], 'tr'=> ['ň'=> 'n', 'Ň'=> 'N', 'ş'=> 's', 'Ş'=> 'S', 'ı'=> 'i', 'İ'=> 'I', 'ç'=> 'c', 'Ç'=> 'C', 'ä'=> 'a', 'Ä'=> 'A', 'ü'=> 'u', 'Ü'=> 'U', 'ö'=> 'o', 'Ö'=> 'O', 'ğ'=> 'g', 'Ğ'=> 'G', 'ý'=> 'y', 'Ý'=> 'Y', 'ž'=> 'z', 'Ž'=> 'Z',], 'bg'=> ['ьо'=> 'yo', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Е'=> 'E', 'Ж'=> 'Zh', 'З'=> 'Z', 'И'=> 'I', 'Й'=> 'Y', 'К'=> 'K', 'Л'=> 'L', 'М'=> 'M', 'Н'=> 'N', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'Ch', 'Ш'=> 'Sh', 'Щ'=> 'Sht', 'Ъ'=> 'A', 'Ь'=> '', 'Ю'=> 'Yu', 'Я'=> 'Ya', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'е'=> 'e', 'ж'=> 'zh', 'з'=> 'z', 'и'=> 'i', 'й'=> 'y', 'к'=> 'k', 'л'=> 'l', 'м'=> 'm', 'н'=> 'n', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'ch', 'ш'=> 'sh', 'щ'=> 'sht', 'ъ'=> 'a', 'ь'=> '', 'ю'=> 'yu', 'я'=> 'ya',], 'hu'=> ['Á'=> 'A', 'Ē'=> 'E', 'É'=> 'E', 'Í'=> 'I', 'Ó'=> 'O', 'Ö'=> 'O', 'Ő'=> 'O', 'Ú'=> 'U', 'Ü'=> 'U', 'Ű'=> 'U', 'á'=> 'a', 'ē'=> 'e', 'é'=> 'e', 'í'=> 'i', 'ó'=> 'o', 'ö'=> 'o', 'ő'=> 'o', 'ú'=> 'u', 'ü'=> 'u', 'ű'=> 'u',], 'my'=> ['န်ုပ်'=> 'nub', 'ောင်'=> 'aung', 'ိုက်'=> 'aik', 'ိုဒ်'=> 'ok', 'ိုင်'=> 'aing', 'ိုလ်'=> 'ol', 'ေါင်'=> 'aung', 'သြော'=> 'aw', 'ောက်'=> 'auk', 'ိတ်'=> 'eik', 'ုတ်'=> 'ok', 'ုန်'=> 'on', 'ေတ်'=> 'it', 'ုဒ်'=> 'ait', 'ာန်'=> 'an', 'ိန်'=> 'ein', 'ွတ်'=> 'ut', 'ေါ်'=> 'aw', 'ွန်'=> 'un', 'ိပ်'=> 'eik', 'ုပ်'=> 'ok', 'ွပ်'=> 'ut', 'ိမ်'=> 'ein', 'ုမ်'=> 'on', 'ော်'=> 'aw', 'ွမ်'=> 'un', 'က်'=> 'et', 'ေါ'=> 'aw', 'ော'=> 'aw', 'ျွ'=> 'ywa', 'ြွ'=> 'yw', 'ို'=> 'o', 'ုံ'=> 'on', 'တ်'=> 'at', 'င်'=> 'in', 'ည်'=> 'i', 'ဒ်'=> 'd', 'န်'=> 'an', 'ပ်'=> 'at', 'မ်'=> 'an', 'စျ'=> 'za', 'ယ်'=> 'e', 'ဉ်'=> 'in', 'စ်'=> 'it', 'ိံ'=> 'ein', 'ဲ'=> 'e', 'း'=> '', 'ာ'=> 'a', 'ါ'=> 'a', 'ေ'=> 'e', 'ံ'=> 'an', 'ိ'=> 'i', 'ီ'=> 'i', 'ု'=> 'u', 'ူ'=> 'u', '်'=> 'at', '္'=> '', '့'=> '', 'က'=> 'k', '၉'=> '9', 'တ'=> 't', 'ရ'=> 'ya', 'ယ'=> 'y', 'မ'=> 'm', 'ဘ'=> 'ba', 'ဗ'=> 'b', 'ဖ'=> 'pa', 'ပ'=> 'p', 'န'=> 'n', 'ဓ'=> 'da', 'ဒ'=> 'd', 'ထ'=> 'ta', 'ဏ'=> 'na', 'ဝ'=> 'w', 'ဎ'=> 'da', 'ဍ'=> 'd', 'ဌ'=> 'ta', 'ဋ'=> 't', 'ည'=> 'ny', 'ဇ'=> 'z', 'ဆ'=> 'sa', 'စ'=> 's', 'င'=> 'ng', 'ဃ'=> 'ga', 'ဂ'=> 'g', 'လ'=> 'l', 'သ'=> 'th', '၈'=> '8', 'ဩ'=> 'aw', 'ခ'=> 'kh', '၆'=> '6', '၅'=> '5', '၄'=> '4', '၃'=> '3', '၂'=> '2', '၁'=> '1', '၀'=> '0', '၌'=> 'hnaik', '၍'=> 'ywae', 'ဪ'=> 'aw', 'ဦ'=> '-u', 'ဟ'=> 'h', 'ဉ'=> 'u', 'ဤ'=> '-i', 'ဣ'=> 'i', '၏'=> '-e', 'ဧ'=> 'e', 'ှ'=> 'h', 'ွ'=> 'w', 'ျ'=> 'ya', 'ြ'=> 'y', 'အ'=> 'a', 'ဠ'=> 'la', '၇'=> '7',], 'hr'=> ['DŽ'=> 'DZ', 'Dž'=> 'Dz', 'dž'=> 'dz', 'Ǳ'=> 'DZ', 'ǲ'=> 'Dz', 'ǳ'=> 'dz', 'Ĳ'=> 'IJ', 'ĳ'=> 'ij', 'Ǉ'=> 'LJ', 'ǈ'=> 'Lj', 'ǉ'=> 'lj', 'Ǌ'=> 'NJ', 'ǋ'=> 'Nj', 'ǌ'=> 'nj', 'ž'=> 'z', 'Ž'=> 'Z', 'đ'=> 'dj', 'Đ'=> 'Dj', 'č'=> 'c', 'Č'=> 'C', 'ć'=> 'c', 'Ć'=> 'C', 'š'=> 's', 'Š'=> 'S',], 'fi'=> ['Ä'=> 'A', 'Ö'=> 'O', 'ä'=> 'a', 'ö'=> 'o',], 'ka'=> ['ა'=> 'a', 'ბ'=> 'b', 'გ'=> 'g', 'დ'=> 'd', 'ე'=> 'e', 'ვ'=> 'v', 'ზ'=> 'z', 'თ'=> 't', 'ი'=> 'i', 'კ'=> 'k', 'ლ'=> 'l', 'მ'=> 'm', 'ნ'=> 'n', 'ო'=> 'o', 'პ'=> 'p', 'ჟ'=> 'zh', 'რ'=> 'r', 'ს'=> 's', 'ტ'=> 't', 'უ'=> 'u', 'ფ'=> 'f', 'ქ'=> 'q', 'ღ'=> 'gh', 'ყ'=> 'y', 'შ'=> 'sh', 'ჩ'=> 'ch', 'ც'=> 'ts', 'ძ'=> 'dz', 'წ'=> 'ts', 'ჭ'=> 'ch', 'ხ'=> 'kh', 'ჯ'=> 'j', 'ჰ'=> 'h',], 'ru'=> ['А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'Yo', 'ё'=> 'yo', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'I', 'и'=> 'i', 'Й'=> 'Y', 'й'=> 'y', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'H', 'х'=> 'h', 'Ц'=> 'Ts', 'ц'=> 'ts', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Sch', 'щ'=> 'sch', 'Ъ'=> '', 'ъ'=> '', 'Ы'=> 'Y', 'ы'=> 'y', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E', 'э'=> 'e', 'Ю'=> 'Yu', 'ю'=> 'yu', 'Я'=> 'Ya', 'я'=> 'ya',], 'ru__passport_2013'=> ['А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'E', 'ё'=> 'e', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'i', 'и'=> 'i', 'Й'=> 'i', 'й'=> 'i', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'Kh', 'х'=> 'kh', 'Ц'=> 'Ts', 'ц'=> 'ts', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Shch', 'щ'=> 'shch', 'Ъ'=> 'Ie', 'ъ'=> 'ie', 'Ы'=> 'Y', 'ы'=> 'y', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E', 'э'=> 'e', 'Ю'=> 'Iu', 'ю'=> 'iu', 'Я'=> 'Ia', 'я'=> 'ia', 'І'=> '', 'і'=> '', 'Ѳ'=> '', 'ѳ'=> '', 'Ѣ'=> '', 'ѣ'=> '', 'Ѵ'=> '', 'ѵ'=> '', 'Є'=> '', 'є'=> '', 'Ѥ'=> '', 'ѥ'=> '', 'Ѕ'=> '', 'ѕ'=> '', 'Ꙋ'=> '', 'ꙋ'=> '', 'Ѡ'=> '', 'ѡ'=> '', 'Ѿ'=> '', 'ѿ'=> '', 'Ѫ'=> '', 'ѫ'=> '', 'Ѧ'=> '', 'ѧ'=> '', 'Ѭ'=> '', 'ѭ'=> '', 'Ѩ'=> '', 'ѩ'=> '', 'Ѯ'=> '', 'ѯ'=> '', 'Ѱ'=> '', 'ѱ'=> '',], 'ru__gost_2000_b'=> ['А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'Yo', 'ё'=> 'yo', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'i', 'и'=> 'i', 'Й'=> 'i', 'й'=> 'i', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'X', 'х'=> 'x', 'Ц'=> 'Cz', 'ц'=> 'cz', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Shh', 'щ'=> 'shh', 'Ъ'=> '', 'ъ'=> '', 'Ы'=> 'Y\'', 'ы'=> 'y\'', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E\'', 'э'=> 'e\'', 'Ю'=> 'Yu', 'ю'=> 'yu', 'Я'=> 'Ya', 'я'=> 'ya', 'І'=> 'I', 'і'=> 'i', 'Ѳ'=> 'Fh', 'ѳ'=> 'fh', 'Ѣ'=> 'Ye', 'ѣ'=> 'ye', 'Ѵ'=> 'Yh', 'ѵ'=> 'yh', 'Є'=> '', 'є'=> '', 'Ѥ'=> '', 'ѥ'=> '', 'Ѕ'=> 'Js', 'ѕ'=> 'js', 'Ꙋ'=> '', 'ꙋ'=> '', 'Ѡ'=> '', 'ѡ'=> '', 'Ѿ'=> '', 'ѿ'=> '', 'Ѫ'=> '', 'ѫ'=> '', 'Ѧ'=> '', 'ѧ'=> '', 'Ѭ'=> '', 'ѭ'=> '', 'Ѩ'=> '', 'ѩ'=> '', 'Ѯ'=> '', 'ѯ'=> '', 'Ѱ'=> '', 'ѱ'=> '',], 'uk'=> ['Є'=> 'Ye', 'є'=> 'ye', 'І'=> 'I', 'і'=> 'i', 'Ї'=> 'Yi', 'ї'=> 'yi', 'Ґ'=> 'G', 'ґ'=> 'g',], 'kk'=> ['Ә'=> 'A', 'Ғ'=> 'G', 'Қ'=> 'Q', 'Ң'=> 'N', 'Ө'=> 'O', 'Ұ'=> 'U', 'Ү'=> 'U', 'Һ'=> 'H', 'ә'=> 'a', 'ғ'=> 'g', 'қ'=> 'q', 'ң'=> 'n', 'ө'=> 'o', 'ұ'=> 'u', 'ү'=> 'u', 'һ'=> 'h',], 'cs'=> ['á'=> 'a', 'Á'=> 'A', 'č'=> 'c', 'Č'=> 'C', 'ď'=> 'd', 'Ď'=> 'D', 'é'=> 'e', 'É'=> 'E', 'ě'=> 'e', 'Ě'=> 'E', 'í'=> 'i', 'Í'=> 'I', 'ň'=> 'n', 'Ň'=> 'N', 'ó'=> 'o', 'Ó'=> 'O', 'ř'=> 'r', 'Ř'=> 'R', 'š'=> 's', 'Š'=> 'S', 'ť'=> 't', 'Ť'=> 'T', 'ú'=> 'u', 'Ú'=> 'U', 'ů'=> 'u', 'Ů'=> 'U', 'ý'=> 'y', 'Ý'=> 'Y', 'ž'=> 'z', 'Ž'=> 'Z',], 'da'=> ['Æ'=> 'Ae', 'æ'=> 'ae', 'Ø'=> 'Oe', 'ø'=> 'oe', 'Å'=> 'Aa', 'å'=> 'aa', 'É'=> 'E', 'é'=> 'e',], 'pl'=> ['ą'=> 'a', 'ć'=> 'c', 'ę'=> 'e', 'ł'=> 'l', 'ń'=> 'n', 'ó'=> 'o', 'ś'=> 's', 'ź'=> 'z', 'ż'=> 'z', 'Ą'=> 'A', 'Ć'=> 'C', 'Ę'=> 'E', 'Ł'=> 'L', 'Ń'=> 'N', 'Ó'=> 'O', 'Ś'=> 'S', 'Ź'=> 'Z', 'Ż'=> 'Z',], 'ro'=> ['ă'=> 'a', 'â'=> 'a', 'Ă'=> 'A', 'Â'=> 'A', 'î'=> 'i', 'Î'=> 'I', 'ș'=> 's', 'ş'=> 's', 'Ş'=> 'S', 'Ș'=> 'S', 'ț'=> 't', 'ţ'=> 't', 'Ţ'=> 'T', 'Ț'=> 'T',], 'eo'=> ['ĉ'=> 'cx', 'ĝ'=> 'gx', 'ĥ'=> 'hx', 'ĵ'=> 'jx', 'ŝ'=> 'sx', 'ŭ'=> 'ux', 'Ĉ'=> 'CX', 'Ĝ'=> 'GX', 'Ĥ'=> 'HX', 'Ĵ'=> 'JX', 'Ŝ'=> 'SX', 'Ŭ'=> 'UX',], 'et'=> ['Š'=> 'S', 'Ž'=> 'Z', 'Õ'=> 'O', 'Ä'=> 'A', 'Ö'=> 'O', 'Ü'=> 'U', 'š'=> 's', 'ž'=> 'z', 'õ'=> 'o', 'ä'=> 'a', 'ö'=> 'o', 'ü'=> 'u',], 'lv'=> ['ā'=> 'a', 'č'=> 'c', 'ē'=> 'e', 'ģ'=> 'g', 'ī'=> 'i', 'ķ'=> 'k', 'ļ'=> 'l', 'ņ'=> 'n', 'š'=> 's', 'ū'=> 'u', 'ž'=> 'z', 'Ā'=> 'A', 'Č'=> 'C', 'Ē'=> 'E', 'Ģ'=> 'G', 'Ī'=> 'i', 'Ķ'=> 'k', 'Ļ'=> 'L', 'Ņ'=> 'N', 'Š'=> 'S', 'Ū'=> 'u', 'Ž'=> 'Z',], 'lt'=> ['ą'=> 'a', 'č'=> 'c', 'ę'=> 'e', 'ė'=> 'e', 'į'=> 'i', 'š'=> 's', 'ų'=> 'u', 'ū'=> 'u', 'ž'=> 'z', 'Ą'=> 'A', 'Č'=> 'C', 'Ę'=> 'E', 'Ė'=> 'E', 'Į'=> 'I', 'Š'=> 'S', 'Ų'=> 'U', 'Ū'=> 'U', 'Ž'=> 'Z',], 'no'=> ['Æ'=> 'AE', 'æ'=> 'ae', 'Ø'=> 'OE', 'ø'=> 'oe', 'Å'=> 'AA', 'å'=> 'aa',], 'vi'=> ['Á'=> 'A', 'À'=> 'A', 'Ả'=> 'A', 'Ã'=> 'A', 'Ạ'=> 'A', 'Ă'=> 'A', 'Ắ'=> 'A', 'Ằ'=> 'A', 'Ẳ'=> 'A', 'Ẵ'=> 'A', 'Ặ'=> 'A', 'Â'=> 'A', 'Ấ'=> 'A', 'Ầ'=> 'A', 'Ẩ'=> 'A', 'Ẫ'=> 'A', 'Ậ'=> 'A', 'á'=> 'a', 'à'=> 'a', 'ả'=> 'a', 'ã'=> 'a', 'ạ'=> 'a', 'ă'=> 'a', 'ắ'=> 'a', 'ằ'=> 'a', 'ẳ'=> 'a', 'ẵ'=> 'a', 'ặ'=> 'a', 'â'=> 'a', 'ấ'=> 'a', 'ầ'=> 'a', 'ẩ'=> 'a', 'ẫ'=> 'a', 'ậ'=> 'a', 'É'=> 'E', 'È'=> 'E', 'Ẻ'=> 'E', 'Ẽ'=> 'E', 'Ẹ'=> 'E', 'Ê'=> 'E', 'Ế'=> 'E', 'Ề'=> 'E', 'Ể'=> 'E', 'Ễ'=> 'E', 'Ệ'=> 'E', 'é'=> 'e', 'è'=> 'e', 'ẻ'=> 'e', 'ẽ'=> 'e', 'ẹ'=> 'e', 'ê'=> 'e', 'ế'=> 'e', 'ề'=> 'e', 'ể'=> 'e', 'ễ'=> 'e', 'ệ'=> 'e', 'Í'=> 'I', 'Ì'=> 'I', 'Ỉ'=> 'I', 'Ĩ'=> 'I', 'Ị'=> 'I', 'í'=> 'i', 'ì'=> 'i', 'ỉ'=> 'i', 'ĩ'=> 'i', 'ị'=> 'i', 'Ó'=> 'O', 'Ò'=> 'O', 'Ỏ'=> 'O', 'Õ'=> 'O', 'Ọ'=> 'O', 'Ô'=> 'O', 'Ố'=> 'O', 'Ồ'=> 'O', 'Ổ'=> 'O', 'Ỗ'=> 'O', 'Ộ'=> 'O', 'Ơ'=> 'O', 'Ớ'=> 'O', 'Ờ'=> 'O', 'Ở'=> 'O', 'Ỡ'=> 'O', 'Ợ'=> 'O', 'ó'=> 'o', 'ò'=> 'o', 'ỏ'=> 'o', 'õ'=> 'o', 'ọ'=> 'o', 'ô'=> 'o', 'ố'=> 'o', 'ồ'=> 'o', 'ổ'=> 'o', 'ỗ'=> 'o', 'ộ'=> 'o', 'ơ'=> 'o', 'ớ'=> 'o', 'ờ'=> 'o', 'ở'=> 'o', 'ỡ'=> 'o', 'ợ'=> 'o', 'Ú'=> 'U', 'Ù'=> 'U', 'Ủ'=> 'U', 'Ũ'=> 'U', 'Ụ'=> 'U', 'Ư'=> 'U', 'Ứ'=> 'U', 'Ừ'=> 'U', 'Ử'=> 'U', 'Ữ'=> 'U', 'Ự'=> 'U', 'ú'=> 'u', 'ù'=> 'u', 'ủ'=> 'u', 'ũ'=> 'u', 'ụ'=> 'u', 'ư'=> 'u', 'ứ'=> 'u', 'ừ'=> 'u', 'ử'=> 'u', 'ữ'=> 'u', 'ự'=> 'u', 'Ý'=> 'Y', 'Ỳ'=> 'Y', 'Ỷ'=> 'Y', 'Ỹ'=> 'Y', 'Ỵ'=> 'Y', 'ý'=> 'y', 'ỳ'=> 'y', 'ỷ'=> 'y', 'ỹ'=> 'y', 'ỵ'=> 'y', 'Đ'=> 'D', 'đ'=> 'd',], 'fa'=> ['ا'=> 'a', 'ب'=> 'b', 'پ'=> 'b', 'ت'=> 't', 'ث'=> 's', 'ج'=> 'g', 'چ'=> 'ch', 'ح'=> 'h', 'خ'=> 'kh', 'د'=> 'd', 'ذ'=> 'z', 'ر'=> 'r', 'ز'=> 'z', 'س'=> 's', 'ش'=> 'sh', 'ص'=> 's', 'ض'=> 'z', 'ط'=> 't', 'ظ'=> 'z', 'ع'=> 'a', 'غ'=> 'gh', 'ف'=> 'f', 'ق'=> 'gh', 'ک'=> 'k', 'گ'=> 'g', 'ل'=> 'l', 'ژ'=> 'zh', 'ك'=> 'k', 'م'=> 'm', 'ن'=> 'n', 'ه'=> 'h', 'و'=> 'o', 'ی'=> 'y', 'آ'=> 'a', '٠'=> '0', '١'=> '1', '٢'=> '2', '٣'=> '3', '٤'=> '4', '٥'=> '5', '٦'=> '6', '٧'=> '7', '٨'=> '8', '٩'=> '9',], 'ar'=> ['أ'=> 'a', 'ب'=> 'b', 'ت'=> 't', 'ث'=> 'th', 'ج'=> 'g', 'ح'=> 'h', 'خ'=> 'kh', 'د'=> 'd', 'ذ'=> 'th', 'ر'=> 'r', 'ز'=> 'z', 'س'=> 's', 'ش'=> 'sh', 'ص'=> 's', 'ض'=> 'd', 'ط'=> 't', 'ظ'=> 'th', 'ع'=> 'aa', 'غ'=> 'gh', 'ف'=> 'f', 'ق'=> 'k', 'ك'=> 'k', 'ل'=> 'l', 'م'=> 'm', 'ن'=> 'n', 'ه'=> 'h', 'و'=> 'o', 'ي'=> 'y', 'ا'=> 'a', 'إ'=> 'a', 'آ'=> 'a', 'ؤ'=> 'o', 'ئ'=> 'y', 'ء'=> 'aa', '٠'=> '0', '١'=> '1', '٢'=> '2', '٣'=> '3', '٤'=> '4', '٥'=> '5', '٦'=> '6', '٧'=> '7', '٨'=> '8', '٩'=> '9',], 'sr'=> ['đ'=> 'dj', 'ž'=> 'z', 'ć'=> 'c', 'č'=> 'c', 'š'=> 's', 'Đ'=> 'Dj', 'Ž'=> 'Z', 'Ć'=> 'C', 'Č'=> 'C', 'Š'=> 'S', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ђ'=> 'dj', 'е'=> 'e', 'ж'=> 'z', 'з'=> 'z', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ћ'=> 'c', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'c', 'џ'=> 'dz', 'ш'=> 's', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ђ'=> 'Dj', 'Е'=> 'E', 'Ж'=> 'Z', 'З'=> 'Z', 'И'=> 'I', 'Ј'=> 'j', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ћ'=> 'C', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'C', 'Џ'=> 'Dz', 'Ш'=> 'S',], 'sr__cyr'=> ['а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ђ'=> 'dj', 'е'=> 'e', 'ж'=> 'z', 'з'=> 'z', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ћ'=> 'c', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'c', 'џ'=> 'dz', 'ш'=> 's', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ђ'=> 'Dj', 'Е'=> 'E', 'Ж'=> 'Z', 'З'=> 'Z', 'И'=> 'I', 'Ј'=> 'j', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ћ'=> 'C', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'C', 'Џ'=> 'Dz', 'Ш'=> 'S',], 'sr__lat'=> ['đ'=> 'dj', 'ž'=> 'z', 'ć'=> 'c', 'č'=> 'c', 'š'=> 's', 'Đ'=> 'Dj', 'Ž'=> 'Z', 'Ć'=> 'C', 'Č'=> 'C', 'Š'=> 'S',], 'az'=> ['ç'=> 'c', 'ə'=> 'e', 'ğ'=> 'g', 'ı'=> 'i', 'ö'=> 'o', 'ş'=> 's', 'ü'=> 'u', 'Ç'=> 'C', 'Ə'=> 'E', 'Ğ'=> 'G', 'İ'=> 'I', 'Ö'=> 'O', 'Ş'=> 'S', 'Ü'=> 'U',], 'sk'=> ['á'=> 'a', 'ä'=> 'a', 'č'=> 'c', 'ď'=> 'd', 'é'=> 'e', 'í'=> 'i', 'ľ'=> 'l', 'ĺ'=> 'l', 'ň'=> 'n', 'ó'=> 'o', 'ô'=> 'o', 'ŕ'=> 'r', 'š'=> 's', 'ť'=> 't', 'ú'=> 'u', 'ý'=> 'y', 'ž'=> 'z', 'Á'=> 'A', 'Ä'=> 'A', 'Č'=> 'C', 'Ď'=> 'D', 'É'=> 'E', 'Í'=> 'I', 'Ľ'=> 'L', 'Ĺ'=> 'L', 'Ň'=> 'N', 'Ó'=> 'O', 'Ô'=> 'O', 'Ŕ'=> 'R', 'Š'=> 'S', 'Ť'=> 'T', 'Ú'=> 'U', 'Ý'=> 'Y', 'Ž'=> 'Z',], 'fr'=> ['Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'fr_at'=> ['ß'=> 'sz', 'ẞ'=> 'SZ', 'Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'fr_ch'=> ['ß'=> 'ss', 'ẞ'=> 'SS', 'Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'de'=> ['Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'ss', 'ẞ'=> 'SS',], 'de_at'=> ['Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'sz', 'ẞ'=> 'SZ',], 'de_ch'=> ['Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'ss', 'ẞ'=> 'SS',], 'bn'=> ['ভ্ল'=> 'vl', 'পশ'=> 'psh', 'ব্ধ'=> 'bdh', 'ব্জ'=> 'bj', 'ব্দ'=> 'bd', 'ব্ব'=> 'bb', 'ব্ল'=> 'bl', 'ভ'=> 'v', 'ব'=> 'b', 'চ্ঞ'=> 'cNG', 'চ্ছ'=> 'cch', 'চ্চ'=> 'cc', 'ছ'=> 'ch', 'চ'=> 'c', 'ধ্ন'=> 'dhn', 'ধ্ম'=> 'dhm', 'দ্ঘ'=> 'dgh', 'দ্ধ'=> 'ddh', 'দ্ভ'=> 'dv', 'দ্ম'=> 'dm', 'ড্ড'=> 'DD', 'ঢ'=> 'Dh', 'ধ'=> 'dh', 'দ্গ'=> 'dg', 'দ্দ'=> 'dd', 'ড'=> 'D', 'দ'=> 'd', '।'=> '.', 'ঘ্ন'=> 'Ghn', 'গ্ধ'=> 'Gdh', 'গ্ণ'=> 'GN', 'গ্ন'=> 'Gn', 'গ্ম'=> 'Gm', 'গ্ল'=> 'Gl', 'জ্ঞ'=> 'jNG', 'ঘ'=> 'Gh', 'গ'=> 'g', 'হ্ণ'=> 'hN', 'হ্ন'=> 'hn', 'হ্ম'=> 'hm', 'হ্ল'=> 'hl', 'হ'=> 'h', 'জ্ঝ'=> 'jjh', 'ঝ'=> 'jh', 'জ্জ'=> 'jj', 'জ'=> 'j', 'ক্ষ্ণ'=> 'kxN', 'ক্ষ্ম'=> 'kxm', 'ক্ষ'=> 'ksh', 'কশ'=> 'ksh', 'ক্ক'=> 'kk', 'ক্ট'=> 'kT', 'ক্ত'=> 'kt', 'ক্ল'=> 'kl', 'ক্স'=> 'ks', 'খ'=> 'kh', 'ক'=> 'k', 'ল্ভ'=> 'lv', 'ল্ধ'=> 'ldh', 'লখ'=> 'lkh', 'লঘ'=> 'lgh', 'লফ'=> 'lph', 'ল্ক'=> 'lk', 'ল্গ'=> 'lg', 'ল্ট'=> 'lT', 'ল্ড'=> 'lD', 'ল্প'=> 'lp', 'ল্ম'=> 'lm', 'ল্ল'=> 'll', 'ল্ব'=> 'lb', 'ল'=> 'l', 'ম্থ'=> 'mth', 'ম্ফ'=> 'mf', 'ম্ভ'=> 'mv', 'মপ্ল'=> 'mpl', 'ম্ন'=> 'mn', 'ম্প'=> 'mp', 'ম্ম'=> 'mm', 'ম্ল'=> 'ml', 'ম্ব'=> 'mb', 'ম'=> 'm', '০'=> '0', '১'=> '1', '২'=> '2', '৩'=> '3', '৪'=> '4', '৫'=> '5', '৬'=> '6', '৭'=> '7', '৮'=> '8', '৯'=> '9', 'ঙ্ক্ষ'=> 'Ngkx', 'ঞ্ছ'=> 'nch', 'ঙ্ঘ'=> 'ngh', 'ঙ্খ'=> 'nkh', 'ঞ্ঝ'=> 'njh', 'ঙ্গৌ'=> 'ngOU', 'ঙ্গৈ'=> 'ngOI', 'ঞ্চ'=> 'nc', 'ঙ্ক'=> 'nk', 'ঙ্ষ'=> 'Ngx', 'ঙ্গ'=> 'ngo', 'ঙ্ম'=> 'Ngm', 'ঞ্জ'=> 'nj', 'ন্ধ'=> 'ndh', 'ন্ঠ'=> 'nTh', 'ণ্ঠ'=> 'NTh', 'ন্থ'=> 'nth', 'ঙ্গা'=> 'nga', 'ঙ্গি'=> 'ngi', 'ঙ্গী'=> 'ngI', 'ঙ্গু'=> 'ngu', 'ঙ্গূ'=> 'ngU', 'ঙ্গে'=> 'nge', 'ঙ্গো'=> 'ngO', 'ণ্ঢ'=> 'NDh', 'নশ'=> 'nsh', 'ঙর'=> 'Ngr', 'ঞর'=> 'NGr', 'ংর'=> 'ngr', 'ঙ'=> 'Ng', 'ঞ'=> 'NG', 'ং'=> 'ng', 'ন্ন'=> 'nn', 'ণ্ণ'=> 'NN', 'ণ্ন'=> 'Nn', 'ন্ম'=> 'nm', 'ণ্ম'=> 'Nm', 'ন্দ'=> 'nd', 'ন্ট'=> 'nT', 'ণ্ট'=> 'NT', 'ন্ড'=> 'nD', 'ণ্ড'=> 'ND', 'ন্ত'=> 'nt', 'ন্স'=> 'ns', 'ন'=> 'n', 'ণ'=> 'N', 'ৈ'=> 'OI', 'ৌ'=> 'OU', 'ো'=> 'O', 'ঐ'=> 'OI', 'ঔ'=> 'OU', 'অ'=> 'o', 'ও'=> 'oo', 'ফ্ল'=> 'fl', 'প্ট'=> 'pT', 'প্ত'=> 'pt', 'প্ন'=> 'pn', 'প্প'=> 'pp', 'প্ল'=> 'pl', 'প্স'=> 'ps', 'ফ'=> 'f', 'প'=> 'p', 'ৃ'=> 'rri', 'ঋ'=> 'rri', 'রর‍্য'=> 'rry', '্র্য'=> 'ry', '্রর'=> 'rr', 'ড়্গ'=> 'Rg', 'ঢ়'=> 'Rh', 'ড়'=> 'R', 'র'=> 'r', '্র'=> 'r', 'শ্ছ'=> 'Sch', 'ষ্ঠ'=> 'ShTh', 'ষ্ফ'=> 'Shf', 'স্ক্ল'=> 'skl', 'স্খ'=> 'skh', 'স্থ'=> 'sth', 'স্ফ'=> 'sf', 'শ্চ'=> 'Sc', 'শ্ত'=> 'St', 'শ্ন'=> 'Sn', 'শ্ম'=> 'Sm', 'শ্ল'=> 'Sl', 'ষ্ক'=> 'Shk', 'ষ্ট'=> 'ShT', 'ষ্ণ'=> 'ShN', 'ষ্প'=> 'Shp', 'ষ্ম'=> 'Shm', 'স্প্ল'=> 'spl', 'স্ক'=> 'sk', 'স্ট'=> 'sT', 'স্ত'=> 'st', 'স্ন'=> 'sn', 'স্প'=> 'sp', 'স্ম'=> 'sm', 'স্ল'=> 'sl', 'শ'=> 'S', 'ষ'=> 'Sh', 'স'=> 's', 'ু'=> 'u', 'উ'=> 'u', 'অ্য'=> 'oZ', 'ত্থ'=> 'tth', 'ৎ'=> 'tt', 'ট্ট'=> 'TT', 'ট্ম'=> 'Tm', 'ঠ'=> 'Th', 'ত্ন'=> 'tn', 'ত্ম'=> 'tm', 'থ'=> 'th', 'ত্ত'=> 'tt', 'ট'=> 'T', 'ত'=> 't', 'অ্যা'=> 'AZ', 'া'=> 'a', 'আ'=> 'a', 'য়া'=> 'ya', 'য়'=> 'y', 'ি'=> 'i', 'ই'=> 'i', 'ী'=> 'ee', 'ঈ'=> 'ee', 'ূ'=> 'uu', 'ঊ'=> 'uu', 'ে'=> 'e', 'এ'=> 'e', 'য'=> 'z', '্য'=> 'Z', 'ইয়'=> 'y', 'ওয়'=> 'w', '্ব'=> 'w', 'এক্স'=> 'x', 'ঃ'=> ':', 'ঁ'=> 'nn', '্‌'=> '',], 'en'=> [], 'latin'=> ['˚'=> '0', '¹'=> '1', '²'=> '2', '³'=> '3', '⁴'=> '4', '⁵'=> '5', '⁶'=> '6', '⁷'=> '7', '⁸'=> '8', '⁹'=> '9', '₀'=> '0', '₁'=> '1', '₂'=> '2', '₃'=> '3', '₄'=> '4', '₅'=> '5', '₆'=> '6', '₇'=> '7', '₈'=> '8', '₉'=> '9', '௦'=> '0', '௧'=> '1', '௨'=> '2', '௩'=> '3', '௪'=> '4', '௫'=> '5', '௬'=> '6', '௭'=> '7', '௮'=> '8', '௯'=> '9', '௰'=> '10', '௱'=> '100', '௲'=> '1000', 'Ꜳ'=> 'AA', 'ꜳ'=> 'aa', 'Æ'=> 'AE', 'æ'=> 'ae', 'Ǽ'=> 'AE', 'ǽ'=> 'ae', 'Ꜵ'=> 'AO', 'ꜵ'=> 'ao', 'Ꜷ'=> 'AU', 'ꜷ'=> 'au', 'Ꜹ'=> 'AV', 'ꜹ'=> 'av', 'Ꜻ'=> 'av', 'ꜻ'=> 'av', 'Ꜽ'=> 'AY', 'ꜽ'=> 'ay', 'ȸ'=> 'db', 'ʣ'=> 'dz', 'ʥ'=> 'dz', 'ʤ'=> 'dezh', '🙰'=> 'et', 'ﬀ'=> 'ff', 'ﬃ'=> 'ffi', 'ﬄ'=> 'ffl', 'ﬁ'=> 'fi', 'ﬂ'=> 'fl', 'ʩ'=> 'feng', 'Ĳ'=> 'IJ', 'ĳ'=> 'ij', 'ʪ'=> 'ls', 'ʫ'=> 'lz', 'ɮ'=> 'lezh', 'ȹ'=> 'qp', 'ʨ'=> 'tc', 'ʦ'=> 'ts', 'ʧ'=> 'tesh', 'Œ'=> 'OE', 'œ'=> 'oe', 'Ꝏ'=> 'OO', 'ꝏ'=> 'oo', 'ẞ'=> 'SS', 'ß'=> 'ss', 'ﬆ'=> 'st', 'ﬅ'=> 'st', 'Ꜩ'=> 'TZ', 'ꜩ'=> 'tz', 'ᵫ'=> 'ue', 'Aι'=> 'Ai', 'αι'=> 'ai', 'Ει'=> 'Ei', 'ει'=> 'ei', 'Οι'=> 'Oi', 'οι'=> 'oi', 'Ου'=> 'Oy', 'ου'=> 'oy', 'Υι'=> 'Yi', 'υι'=> 'yi', 'ἀ'=> 'a', 'ἁ'=> 'a', 'ἂ'=> 'a', 'ἃ'=> 'a', 'ἄ'=> 'a', 'ἅ'=> 'a', 'ἆ'=> 'a', 'ἇ'=> 'a', 'Ἀ'=> 'A', 'Ἁ'=> 'A', 'Ἂ'=> 'A', 'Ἃ'=> 'A', 'Ἄ'=> 'A', 'Ἅ'=> 'A', 'Ἆ'=> 'A', 'Ἇ'=> 'A', 'ᾰ'=> 'a', 'ᾱ'=> 'a', 'ᾲ'=> 'a', 'ᾳ'=> 'a', 'ᾴ'=> 'a', 'ᾶ'=> 'a', 'ᾷ'=> 'a', 'Ᾰ'=> 'A', 'Ᾱ'=> 'A', 'Ὰ'=> 'A', 'Ά'=> 'A', 'ᾼ'=> 'A', 'Ä'=> 'A', 'ä'=> 'a', 'À'=> 'A', 'à'=> 'a', 'Á'=> 'A', 'á'=> 'a', 'Â'=> 'A', 'â'=> 'a', 'Ã'=> 'A', 'ã'=> 'a', 'A̧'=> 'A', 'a̧'=> 'a', 'Ą'=> 'A', 'ą'=> 'a', 'Ⱥ'=> 'A', 'ⱥ'=> 'a', 'Å'=> 'A', 'å'=> 'a', 'Ǻ'=> 'A', 'ǻ'=> 'a', 'Ă'=> 'A', 'ă'=> 'a', 'Ǎ'=> 'A', 'ǎ'=> 'a', 'Ȧ'=> 'A', 'ȧ'=> 'a', 'Ạ'=> 'A', 'ạ'=> 'a', 'Ā'=> 'A', 'ā'=> 'a', 'ª'=> 'a', 'Ɓ'=> 'B', 'Ѣ'=> 'E', 'ѣ'=> 'e', 'Ç'=> 'C', 'ç'=> 'c', 'Ĉ'=> 'C', 'ĉ'=> 'c', 'C̈'=> 'C', 'c̈'=> 'c', 'C̨'=> 'C', 'c̨'=> 'c', 'Ȼ'=> 'C', 'ȼ'=> 'c', 'Č'=> 'C', 'č'=> 'c', 'Ć'=> 'C', 'ć'=> 'c', 'C̀'=> 'C', 'c̀'=> 'c', 'Ċ'=> 'C', 'ċ'=> 'c', 'C̣'=> 'C', 'c̣'=> 'c', 'C̄'=> 'C', 'c̄'=> 'c', 'C̃'=> 'C', 'c̃'=> 'c', 'Ð'=> 'D', 'Đ'=> 'D', 'ð'=> 'd', 'đ'=> 'd', 'È'=> 'E', 'É'=> 'E', 'Ê'=> 'E', 'Ë'=> 'E', 'Ĕ'=> 'E', 'Ė'=> 'E', 'Ȩ'=> 'E', 'ȩ'=> 'e', 'Ę'=> 'E', 'ę'=> 'e', 'Ɇ'=> 'E', 'ɇ'=> 'e', 'Ě'=> 'E', 'ě'=> 'e', 'Ẹ'=> 'E', 'ẹ'=> 'e', 'Ē'=> 'E', 'ē'=> 'e', 'Ẽ'=> 'E', 'ẽ'=> 'e', 'è'=> 'e', 'é'=> 'e', 'ê'=> 'e', 'ë'=> 'e', 'ĕ'=> 'e', 'ė'=> 'e', 'ƒ'=> 'f', 'Ѳ'=> 'F', 'ѳ'=> 'f', 'Ĝ'=> 'G', 'Ġ'=> 'G', 'ĝ'=> 'g', 'ġ'=> 'g', 'Ĥ'=> 'H', 'Ħ'=> 'H', 'ĥ'=> 'h', 'ħ'=> 'h', 'Ì'=> 'I', 'Í'=> 'I', 'Î'=> 'I', 'Ï'=> 'I', 'Ĩ'=> 'I', 'Ĭ'=> 'I', 'Ǐ'=> 'I', 'Į'=> 'I', 'ì'=> 'i', 'í'=> 'i', 'î'=> 'i', 'ï'=> 'i', 'ĩ'=> 'i', 'ĭ'=> 'i', 'ǐ'=> 'i', 'į'=> 'i', 'І'=> 'I', 'і'=> 'i', 'I̧'=> 'I', 'i̧'=> 'i', 'Ɨ'=> 'I', 'ɨ'=> 'i', 'İ'=> 'I', 'i'=> 'i', 'Ị'=> 'I', 'ị'=> 'i', 'Ī'=> 'I', 'ī'=> 'i', 'Ĵ'=> 'J', 'ĵ'=> 'j', 'J́́'=> 'J', 'j́'=> 'j', 'J̀̀'=> 'J', 'j̀'=> 'j', 'J̈'=> 'J', 'j̈'=> 'j', 'J̧'=> 'J', 'j̧'=> 'j', 'J̨'=> 'J', 'j̨'=> 'j', 'Ɉ'=> 'J', 'ɉ'=> 'j', 'J̌'=> 'J', 'ǰ'=> 'j', 'J̇'=> 'J', 'j'=> 'j', 'J̣'=> 'J', 'j̣'=> 'j', 'J̄'=> 'J', 'j̄'=> 'j', 'J̃'=> 'J', 'j̃'=> 'j', 'ĸ'=> 'k', 'Ĺ'=> 'L', 'Ľ'=> 'L', 'Ŀ'=> 'L', 'ĺ'=> 'l', 'ľ'=> 'l', 'ŀ'=> 'l', 'L̀'=> 'L', 'l̀'=> 'l', 'L̂'=> 'L', 'l̂'=> 'l', 'L̈'=> 'L', 'l̈'=> 'l', 'Ļ'=> 'L', 'ļ'=> 'l', 'L̨'=> 'L', 'l̨'=> 'l', 'Ł'=> 'L', 'ł'=> 'l', 'Ƚ'=> 'L', 'ƚ'=> 'l', 'L̇'=> 'L', 'l̇'=> 'l', 'Ḷ'=> 'L', 'ḷ'=> 'l', 'L̄'=> 'L', 'l̄'=> 'l', 'L̃'=> 'L', 'l̃'=> 'l', 'Ñ'=> 'N', 'ñ'=> 'n', 'Ŋ'=> 'N', 'ŋ'=> 'n', 'ŉ'=> 'n', 'Ń'=> 'N', 'ń'=> 'n', 'Ǹ'=> 'N', 'ǹ'=> 'n', 'N̂'=> 'N', 'n̂'=> 'n', 'N̈'=> 'N', 'n̈'=> 'n', 'Ņ'=> 'N', 'ņ'=> 'n', 'N̨'=> 'N', 'n̨'=> 'n', 'Ꞥ'=> 'N', 'ꞥ'=> 'n', 'Ň'=> 'N', 'ň'=> 'n', 'Ṅ'=> 'N', 'ṅ'=> 'n', 'Ṇ'=> 'N', 'ṇ'=> 'n', 'N̄'=> 'N', 'n̄'=> 'n', 'Ö'=> 'O', 'Ò'=> 'O', 'Ó'=> 'O', 'Ô'=> 'O', 'Õ'=> 'O', 'Ō'=> 'O', 'Ŏ'=> 'O', 'Ǒ'=> 'O', 'Ő'=> 'O', 'Ơ'=> 'O', 'Ø'=> 'O', 'Ǿ'=> 'O', 'ö'=> 'o', 'ò'=> 'o', 'ó'=> 'o', 'ô'=> 'o', 'õ'=> 'o', 'ō'=> 'o', 'ŏ'=> 'o', 'ǒ'=> 'o', 'ő'=> 'o', 'ơ'=> 'o', 'ø'=> 'o', 'ǿ'=> 'o', 'º'=> 'o', 'O̧'=> 'O', 'o̧'=> 'o', 'Ǫ'=> 'O', 'ǫ'=> 'o', 'Ɵ'=> 'O', 'ɵ'=> 'o', 'Ȯ'=> 'O', 'ȯ'=> 'o', 'Ọ'=> 'O', 'ọ'=> 'o', 'Ŕ'=> 'R', 'Ŗ'=> 'R', 'ŕ'=> 'r', 'ŗ'=> 'r', 'Ŝ'=> 'S', 'Ș'=> 'S', 'ș'=> 's', 'Ś'=> 'S', 'ś'=> 's', 'S̀'=> 'S', 's̀'=> 's', 'Ŝ̀'=> 'S', 'ŝ'=> 's', 'S̈'=> 'S', 's̈'=> 's', 'Ş'=> 'S', 'ş'=> 's', 'S̨'=> 'S', 's̨'=> 's', 'Ꞩ'=> 'S', 'ꞩ'=> 's', 'Š'=> 'S', 'š'=> 's', 'Ṡ'=> 'S', 'ṡ'=> 's', 'Ṣ'=> 'S', 'ṣ'=> 's', 'S̄'=> 'S', 's̄'=> 's', 'S̃'=> 'S', 's̃'=> 's', 'ſ'=> 's', 'Ţ'=> 'T', 'Ț'=> 'T', 'Ŧ'=> 'T', 'Þ'=> 'TH', 'ţ'=> 't', 'ț'=> 't', 'ŧ'=> 't', 'þ'=> 'th', 'T́'=> 'T', 't́'=> 't', 'T̀'=> 'T', 't̀'=> 't', 'T̂'=> 'T', 't̂'=> 't', 'T̈'=> 'T', 'ẗ'=> 't', 'T̨'=> 'T', 't̨'=> 't', 'Ⱦ'=> 'T', 'ⱦ'=> 't', 'Ť'=> 'T', 'ť'=> 't', 'Ṫ'=> 'T', 'ṫ'=> 't', 'Ṭ'=> 'T', 'ṭ'=> 't', 'T̄'=> 'T', 't̄'=> 't', 'T̃'=> 'T', 't̃'=> 't', 'Ü'=> 'U', 'Ù'=> 'U', 'Ú'=> 'U', 'Û'=> 'U', 'Ũ'=> 'U', 'Ŭ'=> 'U', 'Ű'=> 'U', 'Ų'=> 'U', 'Ư'=> 'U', 'Ǔ'=> 'U', 'Ǖ'=> 'U', 'Ǘ'=> 'U', 'Ǚ'=> 'U', 'Ǜ'=> 'U', 'ü'=> 'u', 'ù'=> 'u', 'ú'=> 'u', 'û'=> 'u', 'ũ'=> 'u', 'ŭ'=> 'u', 'ű'=> 'u', 'ų'=> 'u', 'ư'=> 'u', 'ǔ'=> 'u', 'ǖ'=> 'u', 'ǘ'=> 'u', 'ǚ'=> 'u', 'ǜ'=> 'u', 'U̧'=> 'U', 'u̧'=> 'u', 'Ʉ'=> 'U', 'ʉ'=> 'u', 'U̇'=> 'U', 'u̇'=> 'u', 'Ụ'=> 'U', 'ụ'=> 'u', 'Ū'=> 'U', 'ū'=> 'u', 'Ʊ'=> 'U', 'ʊ'=> 'u', 'Ŵ'=> 'W', 'ŵ'=> 'w', 'Ẁ'=> 'W', 'ẁ'=> 'w', 'Ẃ'=> 'W', 'ẃ'=> 'w', 'Ẅ'=> 'W', 'ẅ'=> 'w', 'Ѵ'=> 'I', 'ѵ'=> 'i', 'Ꙗ'=> 'Ja', 'ꙗ'=> 'ja', 'Є'=> 'Je', 'є'=> 'je', 'Ѥ'=> 'Je', 'ѥ'=> 'je', 'Ѕ'=> 'Dz', 'ѕ'=> 'dz', 'Ꙋ'=> 'U', 'ꙋ'=> 'u', 'Ѡ'=> 'O', 'ѡ'=> 'o', 'Ѿ'=> 'Ot', 'ѿ'=> 'ot', 'Ѫ'=> 'U', 'ѫ'=> 'u', 'Ѧ'=> 'Ja', 'ѧ'=> 'ja', 'Ѭ'=> 'Ju', 'ѭ'=> 'ju', 'Ѩ'=> 'Ja', 'ѩ'=> 'Ja', 'Ѯ'=> 'Ks', 'ѯ'=> 'ks', 'Ѱ'=> 'Ps', 'ѱ'=> 'ps', 'Х'=> 'X', 'х'=> 'x', 'Ý'=> 'Y', 'Ÿ'=> 'Y', 'Ŷ'=> 'Y', 'ý'=> 'y', 'ÿ'=> 'y', 'ŷ'=> 'y', 'Ỳ'=> 'Y', 'ỳ'=> 'y', 'Y̧'=> 'Y', 'y̧'=> 'y', 'Y̨'=> 'Y', 'y̨'=> 'y', 'Ɏ'=> 'Y', 'ɏ'=> 'y', 'Y̌'=> 'Y', 'y̌'=> 'y', 'Ẏ'=> 'Y', 'ẏ'=> 'y', 'Ỵ'=> 'Y', 'ỵ'=> 'y', 'Ȳ'=> 'Y', 'ȳ'=> 'y', 'Ỹ'=> 'Y', 'ỹ'=> 'y', 'Ź'=> 'Z', 'ź'=> 'z', 'Z̀'=> 'Z', 'z̀'=> 'z', 'Ẑ'=> 'Z', 'ẑ'=> 'z', 'Z̈'=> 'Z', 'z̈'=> 'z', 'Z̧'=> 'Z', 'z̧'=> 'z', 'Z̨'=> 'Z', 'z̨'=> 'z', 'Ƶ'=> 'Z', 'ƶ'=> 'z', 'Ž'=> 'Z', 'ž'=> 'z', 'Ż'=> 'Z', 'ż'=> 'z', 'Ẓ'=> 'Z', 'ẓ'=> 'z', 'Z̄'=> 'Z', 'z̄'=> 'z', 'Z̃'=> 'Z', 'z̃'=> 'z',], ' '=> ["\2\0"=> ' ', "\1\a\0"=> ' ', "\2\0\0"=> ' ', "\2\0\1"=> ' ', "\2\0\2"=> ' ', "\2\0\3"=> ' ', "\2\0\4"=> ' ', "\2\0\5"=> ' ', "\2\0\6"=> ' ', "\2\0\7"=> ' ', "\2\0\8"=> ' ', "\2\0\9"=> ' ', "\2\0\a"=> ' ', "\2\0\8"=> ' ', "\2\0\9"=> ' ', "\2\0\b"=> ' ', "\2\0\f"=> ' ', "\2\1\f"=> ' ', "\3\0\0"=> ' ', "\f\e\0"=> ' ',], 'msword'=> ["\2\b"=> '<<', "\2\b"=> '>>', "\2\0\8"=> "'", "\2\0\9"=> "'", "\2\0\a"=> "'", "\2\0\b"=> "'", "\2\0\c"=> '"', "\xe2\x80\x9d" => '"', "\2\0\e"=> '"', "\xe2\x80\x9f" => '"', "\2\0\9"=> "'", "\2\0\a"=> "'", "\2\0\3"=> '-', "\2\0\4"=> '-', "\2\0\6"=> '...',], 'currency_short'=> ['€'=> 'EUR', '$'=> '$', '₢'=> 'Cr', '₣'=> 'Fr.', '£'=> 'PS', '₤'=> 'L.', 'ℳ'=> 'M', '₥'=> 'mil', '₦'=> 'N', '₧'=> 'Pts', '₨'=> 'Rs', 'රු'=> 'LKR', 'ரூ'=> 'LKR', '௹'=> 'Rs', 'रू'=> 'NPR', '₹'=> 'Rs', '૱'=> 'Rs', '₩'=> 'W', '₪'=> 'NS', '₸'=> 'KZT', '₫'=> 'D', '֏'=> 'AMD', '₭'=> 'K', '₺'=> 'TL', '₼'=> 'AZN', '₮'=> 'T', '₯'=> 'Dr', '₲'=> 'PYG', '₾'=> 'GEL', '₳'=> 'ARA', '₴'=> 'UAH', '₽'=> 'RUB', '₵'=> 'GHS', '₡'=> 'CL', '¢'=> 'c', '¥'=> 'YEN', '円'=> 'JPY', '৳'=> 'BDT', '元'=> 'CNY', '﷼'=> 'SAR', '៛'=> 'KR', '₠'=> 'ECU', '¤'=> '$?', '฿'=> 'THB', '؋'=> 'AFN',],]

Documentation des variables

◆ return

return[ 'nl'=> [ 'Á'=> 'A', 'á'=> 'a', 'Ä'=> 'A', 'ä'=> 'a', 'À'=> 'A', 'à'=> 'a', 'Â'=> 'A', 'â'=> 'a', 'É'=> 'E', 'é'=> 'e', 'Ë'=> 'E', 'ë'=> 'e', 'È'=> 'E', 'è'=> 'e', 'Ê'=> 'E', 'ê'=> 'e', 'Í'=> 'I', 'í'=> 'i', 'Ï'=> 'I', 'ï'=> 'i', 'Ì'=> 'I', 'ì'=> 'i', 'Î'=> 'I', 'î'=> 'i', 'Ó'=> 'O', 'ó'=> 'o', 'Ö'=> 'O', 'ö'=> 'o', 'Ò'=> 'O', 'ò'=> 'o', 'Ô'=> 'O', 'ô'=> 'o', 'Ú'=> 'U', 'ú'=> 'u', 'Ü'=> 'U', 'ü'=> 'u', 'Ù'=> 'U', 'ù'=> 'u', 'Û'=> 'U', 'û'=> 'u', 'Ý'=> 'Y', 'ý'=> 'y', 'Ÿ'=> 'Y',], 'it'=> [ 'à'=> 'a', 'À'=> 'A', 'é'=> 'e', 'É'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ì'=> 'i', 'Ì'=> 'I', 'Ò'=> 'O', 'ò'=> 'o', 'ù'=> 'u', 'Ù'=> 'U',], 'mk'=> [ 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ѓ'=> 'Gj', 'Е'=> 'E', 'Ж'=> 'Zh', 'З'=> 'Z', 'Ѕ'=> 'Dz', 'И'=> 'I', 'Ј'=> 'J', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ќ'=> 'Kj', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'Ch', 'Џ'=> 'Dj', 'Ш'=> 'Sh', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ѓ'=> 'gj', 'е'=> 'e', 'ж'=> 'zh', 'з'=> 'z', 'ѕ'=> 'dz', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ќ'=> 'kj', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'ch', 'џ'=> 'dj', 'ш'=> 'sh',], 'pt'=> [ 'æ'=> 'ae', 'ǽ'=> 'ae', 'À'=> 'A', 'Á'=> 'A', 'Â'=> 'A', 'Ã'=> 'A', 'Å'=> 'AA', 'Ǻ'=> 'A', 'Ă'=> 'A', 'Ǎ'=> 'A', 'Æ'=> 'AE', 'Ǽ'=> 'AE', 'à'=> 'a', 'á'=> 'a', 'â'=> 'a', 'ã'=> 'a', 'å'=> 'aa', 'ǻ'=> 'a', 'ă'=> 'a', 'ǎ'=> 'a', 'ª'=> 'a', 'Ĉ'=> 'C', 'Ċ'=> 'C', 'Ç'=> 'C', 'ç'=> 'c', 'ĉ'=> 'c', 'ċ'=> 'c', 'Ð'=> 'Dj', 'Đ'=> 'D', 'ð'=> 'dj', 'đ'=> 'd', 'È'=> 'E', 'É'=> 'E', 'Ê'=> 'E', 'Ë'=> 'E', 'Ĕ'=> 'E', 'Ė'=> 'E', 'è'=> 'e', 'é'=> 'e', 'ê'=> 'e', 'ë'=> 'e', 'ĕ'=> 'e', 'ė'=> 'e', 'ƒ'=> 'f', 'Ĝ'=> 'G', 'Ġ'=> 'G', 'ĝ'=> 'g', 'ġ'=> 'g', 'Ĥ'=> 'H', 'Ħ'=> 'H', 'ĥ'=> 'h', 'ħ'=> 'h', 'Ì'=> 'I', 'Í'=> 'I', 'Î'=> 'I', 'Ï'=> 'I', 'Ĩ'=> 'I', 'Ĭ'=> 'I', 'Ǐ'=> 'I', 'Į'=> 'I', 'Ĳ'=> 'IJ', 'ì'=> 'i', 'í'=> 'i', 'î'=> 'i', 'ï'=> 'i', 'ĩ'=> 'i', 'ĭ'=> 'i', 'ǐ'=> 'i', 'į'=> 'i', 'ĳ'=> 'ij', 'Ĵ'=> 'J', 'ĵ'=> 'j', 'Ĺ'=> 'L', 'Ľ'=> 'L', 'Ŀ'=> 'L', 'ĺ'=> 'l', 'ľ'=> 'l', 'ŀ'=> 'l', 'Ñ'=> 'N', 'ñ'=> 'n', 'ŉ'=> 'n', 'Ò'=> 'O', 'Ó'=> 'O', 'Ô'=> 'O', 'Õ'=> 'O', 'Ō'=> 'O', 'Ŏ'=> 'O', 'Ǒ'=> 'O', 'Ő'=> 'O', 'Ơ'=> 'O', 'Ø'=> 'OE', 'Ǿ'=> 'O', 'Œ'=> 'OE', 'ò'=> 'o', 'ó'=> 'o', 'ô'=> 'o', 'õ'=> 'o', 'ō'=> 'o', 'ŏ'=> 'o', 'ǒ'=> 'o', 'ő'=> 'o', 'ơ'=> 'o', 'ø'=> 'oe', 'ǿ'=> 'o', 'º'=> 'o', 'œ'=> 'oe', 'Ŕ'=> 'R', 'Ŗ'=> 'R', 'ŕ'=> 'r', 'ŗ'=> 'r', 'Ŝ'=> 'S', 'Ș'=> 'S', 'ŝ'=> 's', 'ș'=> 's', 'ſ'=> 's', 'Ţ'=> 'T', 'Ț'=> 'T', 'Ŧ'=> 'T', 'Þ'=> 'TH', 'ţ'=> 't', 'ț'=> 't', 'ŧ'=> 't', 'þ'=> 'th', 'Ù'=> 'U', 'Ú'=> 'U', 'Û'=> 'U', 'Ü'=> 'U', 'Ũ'=> 'U', 'Ŭ'=> 'U', 'Ű'=> 'U', 'Ų'=> 'U', 'Ư'=> 'U', 'Ǔ'=> 'U', 'Ǖ'=> 'U', 'Ǘ'=> 'U', 'Ǚ'=> 'U', 'Ǜ'=> 'U', 'ù'=> 'u', 'ú'=> 'u', 'û'=> 'u', 'ü'=> 'u', 'ũ'=> 'u', 'ŭ'=> 'u', 'ű'=> 'u', 'ų'=> 'u', 'ư'=> 'u', 'ǔ'=> 'u', 'ǖ'=> 'u', 'ǘ'=> 'u', 'ǚ'=> 'u', 'ǜ'=> 'u', 'Ŵ'=> 'W', 'ŵ'=> 'w', 'Ý'=> 'Y', 'Ÿ'=> 'Y', 'Ŷ'=> 'Y', 'ý'=> 'y', 'ÿ'=> 'y', 'ŷ'=> 'y',], 'el__greeklish'=> [ 'ΑΥ'=> 'AU', 'ΑΎ'=> 'AU', 'Αυ'=> 'Au', 'Αύ'=> 'Au', 'ΕΊ'=> 'EI', 'ΕΙ'=> 'EI', 'Ει'=> 'EI', 'ΕΥ'=> 'EU', 'ΕΎ'=> 'EU', 'Εί'=> 'Ei', 'Ευ'=> 'Eu', 'Εύ'=> 'Eu', 'ΟΙ'=> 'OI', 'ΟΊ'=> 'OI', 'ΟΥ'=> 'OU', 'ΟΎ'=> 'OU', 'Οι'=> 'Oi', 'Οί'=> 'Oi', 'Ου'=> 'Ou', 'Ού'=> 'Ou', 'ΥΙ'=> 'YI', 'ΎΙ'=> 'YI', 'Υι'=> 'Yi', 'Ύι'=> 'Yi', 'ΥΊ'=> 'Yi', 'Υί'=> 'Yi', 'αυ'=> 'au', 'αύ'=> 'au', 'εί'=> 'ei', 'ει'=> 'ei', 'ευ'=> 'eu', 'εύ'=> 'eu', 'οι'=> 'oi', 'οί'=> 'oi', 'ου'=> 'ou', 'ού'=> 'ou', 'υι'=> 'yi', 'ύι'=> 'yi', 'υί'=> 'yi', 'Α'=> 'A', 'Ά'=> 'A', 'Β'=> 'B', 'Δ'=> 'D', 'Ε'=> 'E', 'Έ'=> 'E', 'Φ'=> 'F', 'Γ'=> 'G', 'Η'=> 'H', 'Ή'=> 'H', 'Ι'=> 'I', 'Ί'=> 'I', 'Ϊ'=> 'I', 'Κ'=> 'K', 'Ξ'=> 'Ks', 'Λ'=> 'L', 'Μ'=> 'M', 'Ν'=> 'N', 'Π'=> 'N', 'Ο'=> 'O', 'Ό'=> 'O', 'Ψ'=> 'Ps', 'Ρ'=> 'R', 'Σ'=> 'S', 'Τ'=> 'T', 'Θ'=> 'Th', 'Ω'=> 'W', 'Ώ'=> 'W', 'Χ'=> 'X', 'ϒ'=> 'Y', 'Υ'=> 'Y', 'Ύ'=> 'Y', 'Ϋ'=> 'Y', 'Ζ'=> 'Z', 'α'=> 'a', 'ά'=> 'a', 'β'=> 'b', 'δ'=> 'd', 'ε'=> 'e', 'έ'=> 'e', 'φ'=> 'f', 'γ'=> 'g', 'η'=> 'h', 'ή'=> 'h', 'ι'=> 'i', 'ί'=> 'i', 'ϊ'=> 'i', 'ΐ'=> 'i', 'κ'=> 'k', 'ξ'=> 'ks', 'λ'=> 'l', 'μ'=> 'm', 'ν'=> 'n', 'ο'=> 'o', 'ό'=> 'o', 'π'=> 'p', 'ψ'=> 'ps', 'ρ'=> 'r', 'σ'=> 's', 'ς'=> 's', 'τ'=> 't', 'ϑ'=> 'th', 'θ'=> 'th', 'ϐ'=> 'v', 'ω'=> 'w', 'ώ'=> 'w', 'χ'=> 'x', 'υ'=> 'y', 'ύ'=> 'y', 'ΰ'=> 'y', 'ϋ'=> 'y', 'ζ'=> 'z',], 'el'=> [ 'ΑΥ'=> 'AU', 'Αυ'=> 'Au', 'ΟΥ'=> 'U', 'Ου'=> 'u', 'ΕΥ'=> 'EF', 'Ευ'=> 'Ef', 'ΕΙ'=> 'I', 'Ει'=> 'I', 'ΟΙ'=> 'I', 'Οι'=> 'I', 'ΥΙ'=> 'I', 'Υι'=> 'I', 'ΑΎ'=> 'AU', 'Αύ'=> 'Au', 'ΟΎ'=> 'OU', 'Ού'=> 'Ou', 'ΕΎ'=> 'EU', 'Εύ'=> 'Eu', 'ΕΊ'=> 'I', 'Εί'=> 'I', 'ΟΊ'=> 'I', 'Οί'=> 'I', 'ΎΙ'=> 'I', 'Ύι'=> 'I', 'ΥΊ'=> 'I', 'Υί'=> 'I', 'αυ'=> 'au', 'ου'=> 'u', 'ευ'=> 'ef', 'ει'=> 'i', 'οι'=> 'i', 'υι'=> 'i', 'αύ'=> 'au', 'ού'=> 'ou', 'εύ'=> 'eu', 'εί'=> 'i', 'οί'=> 'i', 'ύι'=> 'i', 'υί'=> 'i', 'α'=> 'a', 'β'=> 'v', 'γ'=> 'gh', 'δ'=> 'd', 'ε'=> 'e', 'ζ'=> 'z', 'η'=> 'i', 'θ'=> 'th', 'ι'=> 'i', 'κ'=> 'k', 'λ'=> 'l', 'μ'=> 'm', 'ν'=> 'n', 'ξ'=> 'ks', 'ο'=> 'o', 'π'=> 'p', 'ρ'=> 'r', 'σ'=> 's', 'τ'=> 't', 'υ'=> 'i', 'φ'=> 'f', 'χ'=> 'kh', 'ψ'=> 'ps', 'ω'=> 'o', 'ά'=> 'a', 'έ'=> 'e', 'ί'=> 'i', 'ό'=> 'o', 'ϒ'=> 'Y', 'ύ'=> 'y', 'ή'=> 'i', 'ώ'=> 'w', 'ς'=> 's', 'ϊ'=> 'i', 'ΰ'=> 'y', 'ϋ'=> 'y', 'ΐ'=> 'i', 'Α'=> 'A', 'Β'=> 'B', 'Γ'=> 'G', 'Δ'=> 'D', 'Ε'=> 'E', 'Ζ'=> 'Z', 'Η'=> 'H', 'Θ'=> 'Th', 'Ι'=> 'I', 'Κ'=> 'K', 'Λ'=> 'L', 'Μ'=> 'M', 'Ν'=> 'N', 'Ξ'=> 'Ks', 'Ο'=> 'O', 'Π'=> 'P', 'Ρ'=> 'R', 'Σ'=> 'S', 'Τ'=> 'T', 'Υ'=> 'Y', 'Φ'=> 'F', 'Χ'=> 'X', 'Ψ'=> 'Ps', 'Ω'=> 'O', 'Ά'=> 'A', 'Έ'=> 'E', 'Ί'=> 'I', 'Ό'=> 'O', 'Ύ'=> 'Y', 'Ή'=> 'I', 'Ώ'=> 'W', 'Ϊ'=> 'I', 'Ϋ'=> 'Y', 'ϐ'=> 'v', 'ϑ'=> 'th',], 'hi'=> [ 'अ'=> 'a', 'आ'=> 'aa', 'ए'=> 'e', 'ई'=> 'ii', 'ऍ'=> 'ei', 'ऎ'=> 'ae', 'ऐ'=> 'ai', 'इ'=> 'i', 'ओ'=> 'o', 'ऑ'=> 'oi', 'ऒ'=> 'oii', 'ऊ'=> 'uu', 'औ'=> 'ou', 'उ'=> 'u', 'ब'=> 'B', 'भ'=> 'Bha', 'च'=> 'Ca', 'छ'=> 'Chha', 'ड'=> 'Da', 'ढ'=> 'Dha', 'फ'=> 'Fa', 'फ़'=> 'Fi', 'ग'=> 'Ga', 'घ'=> 'Gha', 'ग़'=> 'Ghi', 'ह'=> 'Ha', 'ज'=> 'Ja', 'झ'=> 'Jha', 'क'=> 'Ka', 'ख'=> 'Kha', 'ख़'=> 'Khi', 'ल'=> 'L', 'ळ'=> 'Li', 'ऌ'=> 'Li', 'ऴ'=> 'Lii', 'ॡ'=> 'Lii', 'म'=> 'Ma', 'न'=> 'Na', 'ङ'=> 'Na', 'ञ'=> 'Nia', 'ण'=> 'Nae', 'ऩ'=> 'Ni', 'ॐ'=> 'oms', 'प'=> 'Pa', 'क़'=> 'Qi', 'र'=> 'Ra', 'ऋ'=> 'Ri', 'ॠ'=> 'Ri', 'ऱ'=> 'Ri', 'स'=> 'Sa', 'श'=> 'Sha', 'ष'=> 'Shha', 'ट'=> 'Ta', 'त'=> 'Ta', 'ठ'=> 'Tha', 'द'=> 'Tha', 'थ'=> 'Tha', 'ध'=> 'Thha', 'ड़'=> 'ugDha', 'ढ़'=> 'ugDhha', 'व'=> 'Va', 'य'=> 'Ya', 'य़'=> 'Yi', 'ज़'=> 'Za',], 'hy'=> [ 'Ա'=> 'A', 'Բ'=> 'B', 'Գ'=> 'G', 'Դ'=> 'D', 'Ե'=> 'E', 'Զ'=> 'Z', 'Է'=> 'E', 'Ը'=> 'Y', 'Թ'=> 'Th', 'Ժ'=> 'Zh', 'Ի'=> 'I', 'Լ'=> 'L', 'Խ'=> 'Kh', 'Ծ'=> 'Ts', 'Կ'=> 'K', 'Հ'=> 'H', 'Ձ'=> 'Dz', 'Ղ'=> 'Gh', 'Ճ'=> 'Tch', 'Մ'=> 'M', 'Յ'=> 'Y', 'Ն'=> 'N', 'Շ'=> 'Sh', 'Ո'=> 'Vo', 'Չ'=> 'Ch', 'Պ'=> 'P', 'Ջ'=> 'J', 'Ռ'=> 'R', 'Ս'=> 'S', 'Վ'=> 'V', 'Տ'=> 'T', 'Ր'=> 'R', 'Ց'=> 'C', 'Ւ'=> 'u', 'Փ'=> 'Ph', 'Ք'=> 'Q', 'և'=> 'ev', 'Օ'=> 'O', 'Ֆ'=> 'F', 'ա'=> 'a', 'բ'=> 'b', 'գ'=> 'g', 'դ'=> 'd', 'ե'=> 'e', 'զ'=> 'z', 'է'=> 'e', 'ը'=> 'y', 'թ'=> 'th', 'ժ'=> 'zh', 'ի'=> 'i', 'լ'=> 'l', 'խ'=> 'kh', 'ծ'=> 'ts', 'կ'=> 'k', 'հ'=> 'h', 'ձ'=> 'dz', 'ղ'=> 'gh', 'ճ'=> 'tch', 'մ'=> 'm', 'յ'=> 'y', 'ն'=> 'n', 'շ'=> 'sh', 'ո'=> 'vo', 'չ'=> 'ch', 'պ'=> 'p', 'ջ'=> 'j', 'ռ'=> 'r', 'ս'=> 's', 'վ'=> 'v', 'տ'=> 't', 'ր'=> 'r', 'ց'=> 'c', 'ւ'=> 'u', 'փ'=> 'ph', 'ք'=> 'q', 'օ'=> 'o', 'ֆ'=> 'f',], 'sv'=> [ 'Ä'=> 'A', 'ä'=> 'a', 'Å'=> 'A', 'å'=> 'a', 'Ö'=> 'O', 'ö'=> 'o',], 'tk'=> [ 'Ç'=> 'C', 'Ä'=> 'A', 'Ž'=> 'Z', 'Ň'=> 'N', 'Ö'=> 'O', 'Ş'=> 'S', 'Ü'=> 'U', 'Ý'=> 'Y', 'ç'=> 'c', 'ä'=> 'a', 'ž'=> 'z', 'ň'=> 'n', 'ö'=> 'o', 'ş'=> 's', 'ü'=> 'u', 'ý'=> 'y',], 'tr'=> [ 'ň'=> 'n', 'Ň'=> 'N', 'ş'=> 's', 'Ş'=> 'S', 'ı'=> 'i', 'İ'=> 'I', 'ç'=> 'c', 'Ç'=> 'C', 'ä'=> 'a', 'Ä'=> 'A', 'ü'=> 'u', 'Ü'=> 'U', 'ö'=> 'o', 'Ö'=> 'O', 'ğ'=> 'g', 'Ğ'=> 'G', 'ý'=> 'y', 'Ý'=> 'Y', 'ž'=> 'z', 'Ž'=> 'Z',], 'bg'=> [ 'ьо'=> 'yo', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Е'=> 'E', 'Ж'=> 'Zh', 'З'=> 'Z', 'И'=> 'I', 'Й'=> 'Y', 'К'=> 'K', 'Л'=> 'L', 'М'=> 'M', 'Н'=> 'N', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'Ch', 'Ш'=> 'Sh', 'Щ'=> 'Sht', 'Ъ'=> 'A', 'Ь'=> '', 'Ю'=> 'Yu', 'Я'=> 'Ya', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'е'=> 'e', 'ж'=> 'zh', 'з'=> 'z', 'и'=> 'i', 'й'=> 'y', 'к'=> 'k', 'л'=> 'l', 'м'=> 'm', 'н'=> 'n', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'ch', 'ш'=> 'sh', 'щ'=> 'sht', 'ъ'=> 'a', 'ь'=> '', 'ю'=> 'yu', 'я'=> 'ya',], 'hu'=> [ 'Á'=> 'A', 'Ē'=> 'E', 'É'=> 'E', 'Í'=> 'I', 'Ó'=> 'O', 'Ö'=> 'O', 'Ő'=> 'O', 'Ú'=> 'U', 'Ü'=> 'U', 'Ű'=> 'U', 'á'=> 'a', 'ē'=> 'e', 'é'=> 'e', 'í'=> 'i', 'ó'=> 'o', 'ö'=> 'o', 'ő'=> 'o', 'ú'=> 'u', 'ü'=> 'u', 'ű'=> 'u',], 'my'=> [ 'န်ုပ်'=> 'nub', 'ောင်'=> 'aung', 'ိုက်'=> 'aik', 'ိုဒ်'=> 'ok', 'ိုင်'=> 'aing', 'ိုလ်'=> 'ol', 'ေါင်'=> 'aung', 'သြော'=> 'aw', 'ောက်'=> 'auk', 'ိတ်'=> 'eik', 'ုတ်'=> 'ok', 'ုန်'=> 'on', 'ေတ်'=> 'it', 'ုဒ်'=> 'ait', 'ာန်'=> 'an', 'ိန်'=> 'ein', 'ွတ်'=> 'ut', 'ေါ်'=> 'aw', 'ွန်'=> 'un', 'ိပ်'=> 'eik', 'ုပ်'=> 'ok', 'ွပ်'=> 'ut', 'ိမ်'=> 'ein', 'ုမ်'=> 'on', 'ော်'=> 'aw', 'ွမ်'=> 'un', 'က်'=> 'et', 'ေါ'=> 'aw', 'ော'=> 'aw', 'ျွ'=> 'ywa', 'ြွ'=> 'yw', 'ို'=> 'o', 'ုံ'=> 'on', 'တ်'=> 'at', 'င်'=> 'in', 'ည်'=> 'i', 'ဒ်'=> 'd', 'န်'=> 'an', 'ပ်'=> 'at', 'မ်'=> 'an', 'စျ'=> 'za', 'ယ်'=> 'e', 'ဉ်'=> 'in', 'စ်'=> 'it', 'ိံ'=> 'ein', 'ဲ'=> 'e', 'း'=> '', 'ာ'=> 'a', 'ါ'=> 'a', 'ေ'=> 'e', 'ံ'=> 'an', 'ိ'=> 'i', 'ီ'=> 'i', 'ု'=> 'u', 'ူ'=> 'u', '်'=> 'at', '္'=> '', '့'=> '', 'က'=> 'k', '၉'=> '9', 'တ'=> 't', 'ရ'=> 'ya', 'ယ'=> 'y', 'မ'=> 'm', 'ဘ'=> 'ba', 'ဗ'=> 'b', 'ဖ'=> 'pa', 'ပ'=> 'p', 'န'=> 'n', 'ဓ'=> 'da', 'ဒ'=> 'd', 'ထ'=> 'ta', 'ဏ'=> 'na', 'ဝ'=> 'w', 'ဎ'=> 'da', 'ဍ'=> 'd', 'ဌ'=> 'ta', 'ဋ'=> 't', 'ည'=> 'ny', 'ဇ'=> 'z', 'ဆ'=> 'sa', 'စ'=> 's', 'င'=> 'ng', 'ဃ'=> 'ga', 'ဂ'=> 'g', 'လ'=> 'l', 'သ'=> 'th', '၈'=> '8', 'ဩ'=> 'aw', 'ခ'=> 'kh', '၆'=> '6', '၅'=> '5', '၄'=> '4', '၃'=> '3', '၂'=> '2', '၁'=> '1', '၀'=> '0', '၌'=> 'hnaik', '၍'=> 'ywae', 'ဪ'=> 'aw', 'ဦ'=> '-u', 'ဟ'=> 'h', 'ဉ'=> 'u', 'ဤ'=> '-i', 'ဣ'=> 'i', '၏'=> '-e', 'ဧ'=> 'e', 'ှ'=> 'h', 'ွ'=> 'w', 'ျ'=> 'ya', 'ြ'=> 'y', 'အ'=> 'a', 'ဠ'=> 'la', '၇'=> '7',], 'hr'=> [ 'DŽ'=> 'DZ', 'Dž'=> 'Dz', 'dž'=> 'dz', 'Ǳ'=> 'DZ', 'ǲ'=> 'Dz', 'ǳ'=> 'dz', 'Ĳ'=> 'IJ', 'ĳ'=> 'ij', 'Ǉ'=> 'LJ', 'ǈ'=> 'Lj', 'ǉ'=> 'lj', 'Ǌ'=> 'NJ', 'ǋ'=> 'Nj', 'ǌ'=> 'nj', 'ž'=> 'z', 'Ž'=> 'Z', 'đ'=> 'dj', 'Đ'=> 'Dj', 'č'=> 'c', 'Č'=> 'C', 'ć'=> 'c', 'Ć'=> 'C', 'š'=> 's', 'Š'=> 'S',], 'fi'=> [ 'Ä'=> 'A', 'Ö'=> 'O', 'ä'=> 'a', 'ö'=> 'o',], 'ka'=> [ 'ა'=> 'a', 'ბ'=> 'b', 'გ'=> 'g', 'დ'=> 'd', 'ე'=> 'e', 'ვ'=> 'v', 'ზ'=> 'z', 'თ'=> 't', 'ი'=> 'i', 'კ'=> 'k', 'ლ'=> 'l', 'მ'=> 'm', 'ნ'=> 'n', 'ო'=> 'o', 'პ'=> 'p', 'ჟ'=> 'zh', 'რ'=> 'r', 'ს'=> 's', 'ტ'=> 't', 'უ'=> 'u', 'ფ'=> 'f', 'ქ'=> 'q', 'ღ'=> 'gh', 'ყ'=> 'y', 'შ'=> 'sh', 'ჩ'=> 'ch', 'ც'=> 'ts', 'ძ'=> 'dz', 'წ'=> 'ts', 'ჭ'=> 'ch', 'ხ'=> 'kh', 'ჯ'=> 'j', 'ჰ'=> 'h',], 'ru'=> [ 'А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'Yo', 'ё'=> 'yo', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'I', 'и'=> 'i', 'Й'=> 'Y', 'й'=> 'y', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'H', 'х'=> 'h', 'Ц'=> 'Ts', 'ц'=> 'ts', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Sch', 'щ'=> 'sch', 'Ъ'=> '', 'ъ'=> '', 'Ы'=> 'Y', 'ы'=> 'y', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E', 'э'=> 'e', 'Ю'=> 'Yu', 'ю'=> 'yu', 'Я'=> 'Ya', 'я'=> 'ya',], 'ru__passport_2013'=> [ 'А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'E', 'ё'=> 'e', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'i', 'и'=> 'i', 'Й'=> 'i', 'й'=> 'i', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'Kh', 'х'=> 'kh', 'Ц'=> 'Ts', 'ц'=> 'ts', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Shch', 'щ'=> 'shch', 'Ъ'=> 'Ie', 'ъ'=> 'ie', 'Ы'=> 'Y', 'ы'=> 'y', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E', 'э'=> 'e', 'Ю'=> 'Iu', 'ю'=> 'iu', 'Я'=> 'Ia', 'я'=> 'ia', 'І'=> '', 'і'=> '', 'Ѳ'=> '', 'ѳ'=> '', 'Ѣ'=> '', 'ѣ'=> '', 'Ѵ'=> '', 'ѵ'=> '', 'Є'=> '', 'є'=> '', 'Ѥ'=> '', 'ѥ'=> '', 'Ѕ'=> '', 'ѕ'=> '', 'Ꙋ'=> '', 'ꙋ'=> '', 'Ѡ'=> '', 'ѡ'=> '', 'Ѿ'=> '', 'ѿ'=> '', 'Ѫ'=> '', 'ѫ'=> '', 'Ѧ'=> '', 'ѧ'=> '', 'Ѭ'=> '', 'ѭ'=> '', 'Ѩ'=> '', 'ѩ'=> '', 'Ѯ'=> '', 'ѯ'=> '', 'Ѱ'=> '', 'ѱ'=> '',], 'ru__gost_2000_b'=> [ 'А'=> 'A', 'а'=> 'a', 'Б'=> 'B', 'б'=> 'b', 'В'=> 'V', 'в'=> 'v', 'Г'=> 'G', 'г'=> 'g', 'Д'=> 'D', 'д'=> 'd', 'Е'=> 'E', 'е'=> 'e', 'Ё'=> 'Yo', 'ё'=> 'yo', 'Ж'=> 'Zh', 'ж'=> 'zh', 'З'=> 'Z', 'з'=> 'z', 'И'=> 'i', 'и'=> 'i', 'Й'=> 'i', 'й'=> 'i', 'К'=> 'K', 'к'=> 'k', 'Л'=> 'L', 'л'=> 'l', 'М'=> 'M', 'м'=> 'm', 'Н'=> 'N', 'н'=> 'n', 'О'=> 'O', 'о'=> 'o', 'П'=> 'P', 'п'=> 'p', 'Р'=> 'R', 'р'=> 'r', 'С'=> 'S', 'с'=> 's', 'Т'=> 'T', 'т'=> 't', 'У'=> 'U', 'у'=> 'u', 'Ф'=> 'F', 'ф'=> 'f', 'Х'=> 'X', 'х'=> 'x', 'Ц'=> 'Cz', 'ц'=> 'cz', 'Ч'=> 'Ch', 'ч'=> 'ch', 'ш'=> 'sh', 'Ш'=> 'Sh', 'Щ'=> 'Shh', 'щ'=> 'shh', 'Ъ'=> '', 'ъ'=> '', 'Ы'=> 'Y\'', 'ы'=> 'y\'', 'Ь'=> '', 'ь'=> '', 'Э'=> 'E\'', 'э'=> 'e\'', 'Ю'=> 'Yu', 'ю'=> 'yu', 'Я'=> 'Ya', 'я'=> 'ya', 'І'=> 'I', 'і'=> 'i', 'Ѳ'=> 'Fh', 'ѳ'=> 'fh', 'Ѣ'=> 'Ye', 'ѣ'=> 'ye', 'Ѵ'=> 'Yh', 'ѵ'=> 'yh', 'Є'=> '', 'є'=> '', 'Ѥ'=> '', 'ѥ'=> '', 'Ѕ'=> 'Js', 'ѕ'=> 'js', 'Ꙋ'=> '', 'ꙋ'=> '', 'Ѡ'=> '', 'ѡ'=> '', 'Ѿ'=> '', 'ѿ'=> '', 'Ѫ'=> '', 'ѫ'=> '', 'Ѧ'=> '', 'ѧ'=> '', 'Ѭ'=> '', 'ѭ'=> '', 'Ѩ'=> '', 'ѩ'=> '', 'Ѯ'=> '', 'ѯ'=> '', 'Ѱ'=> '', 'ѱ'=> '',], 'uk'=> [ 'Є'=> 'Ye', 'є'=> 'ye', 'І'=> 'I', 'і'=> 'i', 'Ї'=> 'Yi', 'ї'=> 'yi', 'Ґ'=> 'G', 'ґ'=> 'g',], 'kk'=> [ 'Ә'=> 'A', 'Ғ'=> 'G', 'Қ'=> 'Q', 'Ң'=> 'N', 'Ө'=> 'O', 'Ұ'=> 'U', 'Ү'=> 'U', 'Һ'=> 'H', 'ә'=> 'a', 'ғ'=> 'g', 'қ'=> 'q', 'ң'=> 'n', 'ө'=> 'o', 'ұ'=> 'u', 'ү'=> 'u', 'һ'=> 'h',], 'cs'=> [ 'á'=> 'a', 'Á'=> 'A', 'č'=> 'c', 'Č'=> 'C', 'ď'=> 'd', 'Ď'=> 'D', 'é'=> 'e', 'É'=> 'E', 'ě'=> 'e', 'Ě'=> 'E', 'í'=> 'i', 'Í'=> 'I', 'ň'=> 'n', 'Ň'=> 'N', 'ó'=> 'o', 'Ó'=> 'O', 'ř'=> 'r', 'Ř'=> 'R', 'š'=> 's', 'Š'=> 'S', 'ť'=> 't', 'Ť'=> 'T', 'ú'=> 'u', 'Ú'=> 'U', 'ů'=> 'u', 'Ů'=> 'U', 'ý'=> 'y', 'Ý'=> 'Y', 'ž'=> 'z', 'Ž'=> 'Z',], 'da'=> [ 'Æ'=> 'Ae', 'æ'=> 'ae', 'Ø'=> 'Oe', 'ø'=> 'oe', 'Å'=> 'Aa', 'å'=> 'aa', 'É'=> 'E', 'é'=> 'e',], 'pl'=> [ 'ą'=> 'a', 'ć'=> 'c', 'ę'=> 'e', 'ł'=> 'l', 'ń'=> 'n', 'ó'=> 'o', 'ś'=> 's', 'ź'=> 'z', 'ż'=> 'z', 'Ą'=> 'A', 'Ć'=> 'C', 'Ę'=> 'E', 'Ł'=> 'L', 'Ń'=> 'N', 'Ó'=> 'O', 'Ś'=> 'S', 'Ź'=> 'Z', 'Ż'=> 'Z',], 'ro'=> [ 'ă'=> 'a', 'â'=> 'a', 'Ă'=> 'A', 'Â'=> 'A', 'î'=> 'i', 'Î'=> 'I', 'ș'=> 's', 'ş'=> 's', 'Ş'=> 'S', 'Ș'=> 'S', 'ț'=> 't', 'ţ'=> 't', 'Ţ'=> 'T', 'Ț'=> 'T',], 'eo'=> [ 'ĉ'=> 'cx', 'ĝ'=> 'gx', 'ĥ'=> 'hx', 'ĵ'=> 'jx', 'ŝ'=> 'sx', 'ŭ'=> 'ux', 'Ĉ'=> 'CX', 'Ĝ'=> 'GX', 'Ĥ'=> 'HX', 'Ĵ'=> 'JX', 'Ŝ'=> 'SX', 'Ŭ'=> 'UX',], 'et'=> [ 'Š'=> 'S', 'Ž'=> 'Z', 'Õ'=> 'O', 'Ä'=> 'A', 'Ö'=> 'O', 'Ü'=> 'U', 'š'=> 's', 'ž'=> 'z', 'õ'=> 'o', 'ä'=> 'a', 'ö'=> 'o', 'ü'=> 'u',], 'lv'=> [ 'ā'=> 'a', 'č'=> 'c', 'ē'=> 'e', 'ģ'=> 'g', 'ī'=> 'i', 'ķ'=> 'k', 'ļ'=> 'l', 'ņ'=> 'n', 'š'=> 's', 'ū'=> 'u', 'ž'=> 'z', 'Ā'=> 'A', 'Č'=> 'C', 'Ē'=> 'E', 'Ģ'=> 'G', 'Ī'=> 'i', 'Ķ'=> 'k', 'Ļ'=> 'L', 'Ņ'=> 'N', 'Š'=> 'S', 'Ū'=> 'u', 'Ž'=> 'Z',], 'lt'=> [ 'ą'=> 'a', 'č'=> 'c', 'ę'=> 'e', 'ė'=> 'e', 'į'=> 'i', 'š'=> 's', 'ų'=> 'u', 'ū'=> 'u', 'ž'=> 'z', 'Ą'=> 'A', 'Č'=> 'C', 'Ę'=> 'E', 'Ė'=> 'E', 'Į'=> 'I', 'Š'=> 'S', 'Ų'=> 'U', 'Ū'=> 'U', 'Ž'=> 'Z',], 'no'=> [ 'Æ'=> 'AE', 'æ'=> 'ae', 'Ø'=> 'OE', 'ø'=> 'oe', 'Å'=> 'AA', 'å'=> 'aa',], 'vi'=> [ 'Á'=> 'A', 'À'=> 'A', 'Ả'=> 'A', 'Ã'=> 'A', 'Ạ'=> 'A', 'Ă'=> 'A', 'Ắ'=> 'A', 'Ằ'=> 'A', 'Ẳ'=> 'A', 'Ẵ'=> 'A', 'Ặ'=> 'A', 'Â'=> 'A', 'Ấ'=> 'A', 'Ầ'=> 'A', 'Ẩ'=> 'A', 'Ẫ'=> 'A', 'Ậ'=> 'A', 'á'=> 'a', 'à'=> 'a', 'ả'=> 'a', 'ã'=> 'a', 'ạ'=> 'a', 'ă'=> 'a', 'ắ'=> 'a', 'ằ'=> 'a', 'ẳ'=> 'a', 'ẵ'=> 'a', 'ặ'=> 'a', 'â'=> 'a', 'ấ'=> 'a', 'ầ'=> 'a', 'ẩ'=> 'a', 'ẫ'=> 'a', 'ậ'=> 'a', 'É'=> 'E', 'È'=> 'E', 'Ẻ'=> 'E', 'Ẽ'=> 'E', 'Ẹ'=> 'E', 'Ê'=> 'E', 'Ế'=> 'E', 'Ề'=> 'E', 'Ể'=> 'E', 'Ễ'=> 'E', 'Ệ'=> 'E', 'é'=> 'e', 'è'=> 'e', 'ẻ'=> 'e', 'ẽ'=> 'e', 'ẹ'=> 'e', 'ê'=> 'e', 'ế'=> 'e', 'ề'=> 'e', 'ể'=> 'e', 'ễ'=> 'e', 'ệ'=> 'e', 'Í'=> 'I', 'Ì'=> 'I', 'Ỉ'=> 'I', 'Ĩ'=> 'I', 'Ị'=> 'I', 'í'=> 'i', 'ì'=> 'i', 'ỉ'=> 'i', 'ĩ'=> 'i', 'ị'=> 'i', 'Ó'=> 'O', 'Ò'=> 'O', 'Ỏ'=> 'O', 'Õ'=> 'O', 'Ọ'=> 'O', 'Ô'=> 'O', 'Ố'=> 'O', 'Ồ'=> 'O', 'Ổ'=> 'O', 'Ỗ'=> 'O', 'Ộ'=> 'O', 'Ơ'=> 'O', 'Ớ'=> 'O', 'Ờ'=> 'O', 'Ở'=> 'O', 'Ỡ'=> 'O', 'Ợ'=> 'O', 'ó'=> 'o', 'ò'=> 'o', 'ỏ'=> 'o', 'õ'=> 'o', 'ọ'=> 'o', 'ô'=> 'o', 'ố'=> 'o', 'ồ'=> 'o', 'ổ'=> 'o', 'ỗ'=> 'o', 'ộ'=> 'o', 'ơ'=> 'o', 'ớ'=> 'o', 'ờ'=> 'o', 'ở'=> 'o', 'ỡ'=> 'o', 'ợ'=> 'o', 'Ú'=> 'U', 'Ù'=> 'U', 'Ủ'=> 'U', 'Ũ'=> 'U', 'Ụ'=> 'U', 'Ư'=> 'U', 'Ứ'=> 'U', 'Ừ'=> 'U', 'Ử'=> 'U', 'Ữ'=> 'U', 'Ự'=> 'U', 'ú'=> 'u', 'ù'=> 'u', 'ủ'=> 'u', 'ũ'=> 'u', 'ụ'=> 'u', 'ư'=> 'u', 'ứ'=> 'u', 'ừ'=> 'u', 'ử'=> 'u', 'ữ'=> 'u', 'ự'=> 'u', 'Ý'=> 'Y', 'Ỳ'=> 'Y', 'Ỷ'=> 'Y', 'Ỹ'=> 'Y', 'Ỵ'=> 'Y', 'ý'=> 'y', 'ỳ'=> 'y', 'ỷ'=> 'y', 'ỹ'=> 'y', 'ỵ'=> 'y', 'Đ'=> 'D', 'đ'=> 'd',], 'fa'=> [ 'ا'=> 'a', 'ب'=> 'b', 'پ'=> 'b', 'ت'=> 't', 'ث'=> 's', 'ج'=> 'g', 'چ'=> 'ch', 'ح'=> 'h', 'خ'=> 'kh', 'د'=> 'd', 'ذ'=> 'z', 'ر'=> 'r', 'ز'=> 'z', 'س'=> 's', 'ش'=> 'sh', 'ص'=> 's', 'ض'=> 'z', 'ط'=> 't', 'ظ'=> 'z', 'ع'=> 'a', 'غ'=> 'gh', 'ف'=> 'f', 'ق'=> 'gh', 'ک'=> 'k', 'گ'=> 'g', 'ل'=> 'l', 'ژ'=> 'zh', 'ك'=> 'k', 'م'=> 'm', 'ن'=> 'n', 'ه'=> 'h', 'و'=> 'o', 'ی'=> 'y', 'آ'=> 'a', '٠'=> '0', '١'=> '1', '٢'=> '2', '٣'=> '3', '٤'=> '4', '٥'=> '5', '٦'=> '6', '٧'=> '7', '٨'=> '8', '٩'=> '9',], 'ar'=> [ 'أ'=> 'a', 'ب'=> 'b', 'ت'=> 't', 'ث'=> 'th', 'ج'=> 'g', 'ح'=> 'h', 'خ'=> 'kh', 'د'=> 'd', 'ذ'=> 'th', 'ر'=> 'r', 'ز'=> 'z', 'س'=> 's', 'ش'=> 'sh', 'ص'=> 's', 'ض'=> 'd', 'ط'=> 't', 'ظ'=> 'th', 'ع'=> 'aa', 'غ'=> 'gh', 'ف'=> 'f', 'ق'=> 'k', 'ك'=> 'k', 'ل'=> 'l', 'م'=> 'm', 'ن'=> 'n', 'ه'=> 'h', 'و'=> 'o', 'ي'=> 'y', 'ا'=> 'a', 'إ'=> 'a', 'آ'=> 'a', 'ؤ'=> 'o', 'ئ'=> 'y', 'ء'=> 'aa', '٠'=> '0', '١'=> '1', '٢'=> '2', '٣'=> '3', '٤'=> '4', '٥'=> '5', '٦'=> '6', '٧'=> '7', '٨'=> '8', '٩'=> '9',], 'sr'=> [ 'đ'=> 'dj', 'ž'=> 'z', 'ć'=> 'c', 'č'=> 'c', 'š'=> 's', 'Đ'=> 'Dj', 'Ž'=> 'Z', 'Ć'=> 'C', 'Č'=> 'C', 'Š'=> 'S', 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ђ'=> 'dj', 'е'=> 'e', 'ж'=> 'z', 'з'=> 'z', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ћ'=> 'c', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'c', 'џ'=> 'dz', 'ш'=> 's', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ђ'=> 'Dj', 'Е'=> 'E', 'Ж'=> 'Z', 'З'=> 'Z', 'И'=> 'I', 'Ј'=> 'j', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ћ'=> 'C', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'C', 'Џ'=> 'Dz', 'Ш'=> 'S',], 'sr__cyr'=> [ 'а'=> 'a', 'б'=> 'b', 'в'=> 'v', 'г'=> 'g', 'д'=> 'd', 'ђ'=> 'dj', 'е'=> 'e', 'ж'=> 'z', 'з'=> 'z', 'и'=> 'i', 'ј'=> 'j', 'к'=> 'k', 'л'=> 'l', 'љ'=> 'lj', 'м'=> 'm', 'н'=> 'n', 'њ'=> 'nj', 'о'=> 'o', 'п'=> 'p', 'р'=> 'r', 'с'=> 's', 'т'=> 't', 'ћ'=> 'c', 'у'=> 'u', 'ф'=> 'f', 'х'=> 'h', 'ц'=> 'c', 'ч'=> 'c', 'џ'=> 'dz', 'ш'=> 's', 'А'=> 'A', 'Б'=> 'B', 'В'=> 'V', 'Г'=> 'G', 'Д'=> 'D', 'Ђ'=> 'Dj', 'Е'=> 'E', 'Ж'=> 'Z', 'З'=> 'Z', 'И'=> 'I', 'Ј'=> 'j', 'К'=> 'K', 'Л'=> 'L', 'Љ'=> 'Lj', 'М'=> 'M', 'Н'=> 'N', 'Њ'=> 'Nj', 'О'=> 'O', 'П'=> 'P', 'Р'=> 'R', 'С'=> 'S', 'Т'=> 'T', 'Ћ'=> 'C', 'У'=> 'U', 'Ф'=> 'F', 'Х'=> 'H', 'Ц'=> 'C', 'Ч'=> 'C', 'Џ'=> 'Dz', 'Ш'=> 'S',], 'sr__lat'=> [ 'đ'=> 'dj', 'ž'=> 'z', 'ć'=> 'c', 'č'=> 'c', 'š'=> 's', 'Đ'=> 'Dj', 'Ž'=> 'Z', 'Ć'=> 'C', 'Č'=> 'C', 'Š'=> 'S',], 'az'=> [ 'ç'=> 'c', 'ə'=> 'e', 'ğ'=> 'g', 'ı'=> 'i', 'ö'=> 'o', 'ş'=> 's', 'ü'=> 'u', 'Ç'=> 'C', 'Ə'=> 'E', 'Ğ'=> 'G', 'İ'=> 'I', 'Ö'=> 'O', 'Ş'=> 'S', 'Ü'=> 'U',], 'sk'=> [ 'á'=> 'a', 'ä'=> 'a', 'č'=> 'c', 'ď'=> 'd', 'é'=> 'e', 'í'=> 'i', 'ľ'=> 'l', 'ĺ'=> 'l', 'ň'=> 'n', 'ó'=> 'o', 'ô'=> 'o', 'ŕ'=> 'r', 'š'=> 's', 'ť'=> 't', 'ú'=> 'u', 'ý'=> 'y', 'ž'=> 'z', 'Á'=> 'A', 'Ä'=> 'A', 'Č'=> 'C', 'Ď'=> 'D', 'É'=> 'E', 'Í'=> 'I', 'Ľ'=> 'L', 'Ĺ'=> 'L', 'Ň'=> 'N', 'Ó'=> 'O', 'Ô'=> 'O', 'Ŕ'=> 'R', 'Š'=> 'S', 'Ť'=> 'T', 'Ú'=> 'U', 'Ý'=> 'Y', 'Ž'=> 'Z',], 'fr'=> [ 'Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'fr_at'=> [ 'ß'=> 'sz', 'ẞ'=> 'SZ', 'Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'fr_ch'=> [ 'ß'=> 'ss', 'ẞ'=> 'SS', 'Æ'=> 'AE', 'æ'=> 'ae', 'Œ'=> 'OE', 'œ'=> 'oe', 'â'=> 'a', 'Â'=> 'A', 'à'=> 'a', 'À'=> 'A', 'ä'=> 'a', 'Ä'=> 'A', 'ç'=> 'c', 'Ç'=> 'C', 'é'=> 'e', 'É'=> 'E', 'ê'=> 'e', 'Ê'=> 'E', 'ë'=> 'e', 'Ë'=> 'E', 'è'=> 'e', 'È'=> 'E', 'ï'=> 'i', 'î'=> 'i', 'Ï'=> 'I', 'Î'=> 'I', 'ÿ'=> 'y', 'Ÿ'=> 'Y', 'ô'=> 'o', 'Ô'=> 'O', 'ö'=> 'o', 'Ö'=> 'O', 'û'=> 'u', 'Û'=> 'U', 'ù'=> 'u', 'Ù'=> 'U', 'ü'=> 'u', 'Ü'=> 'U',], 'de'=> [ 'Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'ss', 'ẞ'=> 'SS',], 'de_at'=> [ 'Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'sz', 'ẞ'=> 'SZ',], 'de_ch'=> [ 'Ä'=> 'Ae', 'Ö'=> 'Oe', 'Ü'=> 'Ue', 'ä'=> 'ae', 'ö'=> 'oe', 'ü'=> 'ue', 'ß'=> 'ss', 'ẞ'=> 'SS',], 'bn'=> [ 'ভ্ল'=> 'vl', 'পশ'=> 'psh', 'ব্ধ'=> 'bdh', 'ব্জ'=> 'bj', 'ব্দ'=> 'bd', 'ব্ব'=> 'bb', 'ব্ল'=> 'bl', 'ভ'=> 'v', 'ব'=> 'b', 'চ্ঞ'=> 'cNG', 'চ্ছ'=> 'cch', 'চ্চ'=> 'cc', 'ছ'=> 'ch', 'চ'=> 'c', 'ধ্ন'=> 'dhn', 'ধ্ম'=> 'dhm', 'দ্ঘ'=> 'dgh', 'দ্ধ'=> 'ddh', 'দ্ভ'=> 'dv', 'দ্ম'=> 'dm', 'ড্ড'=> 'DD', 'ঢ'=> 'Dh', 'ধ'=> 'dh', 'দ্গ'=> 'dg', 'দ্দ'=> 'dd', 'ড'=> 'D', 'দ'=> 'd', '।'=> '.', 'ঘ্ন'=> 'Ghn', 'গ্ধ'=> 'Gdh', 'গ্ণ'=> 'GN', 'গ্ন'=> 'Gn', 'গ্ম'=> 'Gm', 'গ্ল'=> 'Gl', 'জ্ঞ'=> 'jNG', 'ঘ'=> 'Gh', 'গ'=> 'g', 'হ্ণ'=> 'hN', 'হ্ন'=> 'hn', 'হ্ম'=> 'hm', 'হ্ল'=> 'hl', 'হ'=> 'h', 'জ্ঝ'=> 'jjh', 'ঝ'=> 'jh', 'জ্জ'=> 'jj', 'জ'=> 'j', 'ক্ষ্ণ'=> 'kxN', 'ক্ষ্ম'=> 'kxm', 'ক্ষ'=> 'ksh', 'কশ'=> 'ksh', 'ক্ক'=> 'kk', 'ক্ট'=> 'kT', 'ক্ত'=> 'kt', 'ক্ল'=> 'kl', 'ক্স'=> 'ks', 'খ'=> 'kh', 'ক'=> 'k', 'ল্ভ'=> 'lv', 'ল্ধ'=> 'ldh', 'লখ'=> 'lkh', 'লঘ'=> 'lgh', 'লফ'=> 'lph', 'ল্ক'=> 'lk', 'ল্গ'=> 'lg', 'ল্ট'=> 'lT', 'ল্ড'=> 'lD', 'ল্প'=> 'lp', 'ল্ম'=> 'lm', 'ল্ল'=> 'll', 'ল্ব'=> 'lb', 'ল'=> 'l', 'ম্থ'=> 'mth', 'ম্ফ'=> 'mf', 'ম্ভ'=> 'mv', 'মপ্ল'=> 'mpl', 'ম্ন'=> 'mn', 'ম্প'=> 'mp', 'ম্ম'=> 'mm', 'ম্ল'=> 'ml', 'ম্ব'=> 'mb', 'ম'=> 'm', '০'=> '0', '১'=> '1', '২'=> '2', '৩'=> '3', '৪'=> '4', '৫'=> '5', '৬'=> '6', '৭'=> '7', '৮'=> '8', '৯'=> '9', 'ঙ্ক্ষ'=> 'Ngkx', 'ঞ্ছ'=> 'nch', 'ঙ্ঘ'=> 'ngh', 'ঙ্খ'=> 'nkh', 'ঞ্ঝ'=> 'njh', 'ঙ্গৌ'=> 'ngOU', 'ঙ্গৈ'=> 'ngOI', 'ঞ্চ'=> 'nc', 'ঙ্ক'=> 'nk', 'ঙ্ষ'=> 'Ngx', 'ঙ্গ'=> 'ngo', 'ঙ্ম'=> 'Ngm', 'ঞ্জ'=> 'nj', 'ন্ধ'=> 'ndh', 'ন্ঠ'=> 'nTh', 'ণ্ঠ'=> 'NTh', 'ন্থ'=> 'nth', 'ঙ্গা'=> 'nga', 'ঙ্গি'=> 'ngi', 'ঙ্গী'=> 'ngI', 'ঙ্গু'=> 'ngu', 'ঙ্গূ'=> 'ngU', 'ঙ্গে'=> 'nge', 'ঙ্গো'=> 'ngO', 'ণ্ঢ'=> 'NDh', 'নশ'=> 'nsh', 'ঙর'=> 'Ngr', 'ঞর'=> 'NGr', 'ংর'=> 'ngr', 'ঙ'=> 'Ng', 'ঞ'=> 'NG', 'ং'=> 'ng', 'ন্ন'=> 'nn', 'ণ্ণ'=> 'NN', 'ণ্ন'=> 'Nn', 'ন্ম'=> 'nm', 'ণ্ম'=> 'Nm', 'ন্দ'=> 'nd', 'ন্ট'=> 'nT', 'ণ্ট'=> 'NT', 'ন্ড'=> 'nD', 'ণ্ড'=> 'ND', 'ন্ত'=> 'nt', 'ন্স'=> 'ns', 'ন'=> 'n', 'ণ'=> 'N', 'ৈ'=> 'OI', 'ৌ'=> 'OU', 'ো'=> 'O', 'ঐ'=> 'OI', 'ঔ'=> 'OU', 'অ'=> 'o', 'ও'=> 'oo', 'ফ্ল'=> 'fl', 'প্ট'=> 'pT', 'প্ত'=> 'pt', 'প্ন'=> 'pn', 'প্প'=> 'pp', 'প্ল'=> 'pl', 'প্স'=> 'ps', 'ফ'=> 'f', 'প'=> 'p', 'ৃ'=> 'rri', 'ঋ'=> 'rri', 'রর‍্য'=> 'rry', '্র্য'=> 'ry', '্রর'=> 'rr', 'ড়্গ'=> 'Rg', 'ঢ়'=> 'Rh', 'ড়'=> 'R', 'র'=> 'r', '্র'=> 'r', 'শ্ছ'=> 'Sch', 'ষ্ঠ'=> 'ShTh', 'ষ্ফ'=> 'Shf', 'স্ক্ল'=> 'skl', 'স্খ'=> 'skh', 'স্থ'=> 'sth', 'স্ফ'=> 'sf', 'শ্চ'=> 'Sc', 'শ্ত'=> 'St', 'শ্ন'=> 'Sn', 'শ্ম'=> 'Sm', 'শ্ল'=> 'Sl', 'ষ্ক'=> 'Shk', 'ষ্ট'=> 'ShT', 'ষ্ণ'=> 'ShN', 'ষ্প'=> 'Shp', 'ষ্ম'=> 'Shm', 'স্প্ল'=> 'spl', 'স্ক'=> 'sk', 'স্ট'=> 'sT', 'স্ত'=> 'st', 'স্ন'=> 'sn', 'স্প'=> 'sp', 'স্ম'=> 'sm', 'স্ল'=> 'sl', 'শ'=> 'S', 'ষ'=> 'Sh', 'স'=> 's', 'ু'=> 'u', 'উ'=> 'u', 'অ্য'=> 'oZ', 'ত্থ'=> 'tth', 'ৎ'=> 'tt', 'ট্ট'=> 'TT', 'ট্ম'=> 'Tm', 'ঠ'=> 'Th', 'ত্ন'=> 'tn', 'ত্ম'=> 'tm', 'থ'=> 'th', 'ত্ত'=> 'tt', 'ট'=> 'T', 'ত'=> 't', 'অ্যা'=> 'AZ', 'া'=> 'a', 'আ'=> 'a', 'য়া'=> 'ya', 'য়'=> 'y', 'ি'=> 'i', 'ই'=> 'i', 'ী'=> 'ee', 'ঈ'=> 'ee', 'ূ'=> 'uu', 'ঊ'=> 'uu', 'ে'=> 'e', 'এ'=> 'e', 'য'=> 'z', '্য'=> 'Z', 'ইয়'=> 'y', 'ওয়'=> 'w', '্ব'=> 'w', 'এক্স'=> 'x', 'ঃ'=> ':', 'ঁ'=> 'nn', '্‌'=> '',], 'en'=> [], 'latin'=> [ '˚'=> '0', '¹'=> '1', '²'=> '2', '³'=> '3', '⁴'=> '4', '⁵'=> '5', '⁶'=> '6', '⁷'=> '7', '⁸'=> '8', '⁹'=> '9', '₀'=> '0', '₁'=> '1', '₂'=> '2', '₃'=> '3', '₄'=> '4', '₅'=> '5', '₆'=> '6', '₇'=> '7', '₈'=> '8', '₉'=> '9', '௦'=> '0', '௧'=> '1', '௨'=> '2', '௩'=> '3', '௪'=> '4', '௫'=> '5', '௬'=> '6', '௭'=> '7', '௮'=> '8', '௯'=> '9', '௰'=> '10', '௱'=> '100', '௲'=> '1000', 'Ꜳ'=> 'AA', 'ꜳ'=> 'aa', 'Æ'=> 'AE', 'æ'=> 'ae', 'Ǽ'=> 'AE', 'ǽ'=> 'ae', 'Ꜵ'=> 'AO', 'ꜵ'=> 'ao', 'Ꜷ'=> 'AU', 'ꜷ'=> 'au', 'Ꜹ'=> 'AV', 'ꜹ'=> 'av', 'Ꜻ'=> 'av', 'ꜻ'=> 'av', 'Ꜽ'=> 'AY', 'ꜽ'=> 'ay', 'ȸ'=> 'db', 'ʣ'=> 'dz', 'ʥ'=> 'dz', 'ʤ'=> 'dezh', '🙰'=> 'et', 'ﬀ'=> 'ff', 'ﬃ'=> 'ffi', 'ﬄ'=> 'ffl', 'ﬁ'=> 'fi', 'ﬂ'=> 'fl', 'ʩ'=> 'feng', 'Ĳ'=> 'IJ', 'ĳ'=> 'ij', 'ʪ'=> 'ls', 'ʫ'=> 'lz', 'ɮ'=> 'lezh', 'ȹ'=> 'qp', 'ʨ'=> 'tc', 'ʦ'=> 'ts', 'ʧ'=> 'tesh', 'Œ'=> 'OE', 'œ'=> 'oe', 'Ꝏ'=> 'OO', 'ꝏ'=> 'oo', 'ẞ'=> 'SS', 'ß'=> 'ss', 'ﬆ'=> 'st', 'ﬅ'=> 'st', 'Ꜩ'=> 'TZ', 'ꜩ'=> 'tz', 'ᵫ'=> 'ue', 'Aι'=> 'Ai', 'αι'=> 'ai', 'Ει'=> 'Ei', 'ει'=> 'ei', 'Οι'=> 'Oi', 'οι'=> 'oi', 'Ου'=> 'Oy', 'ου'=> 'oy', 'Υι'=> 'Yi', 'υι'=> 'yi', 'ἀ'=> 'a', 'ἁ'=> 'a', 'ἂ'=> 'a', 'ἃ'=> 'a', 'ἄ'=> 'a', 'ἅ'=> 'a', 'ἆ'=> 'a', 'ἇ'=> 'a', 'Ἀ'=> 'A', 'Ἁ'=> 'A', 'Ἂ'=> 'A', 'Ἃ'=> 'A', 'Ἄ'=> 'A', 'Ἅ'=> 'A', 'Ἆ'=> 'A', 'Ἇ'=> 'A', 'ᾰ'=> 'a', 'ᾱ'=> 'a', 'ᾲ'=> 'a', 'ᾳ'=> 'a', 'ᾴ'=> 'a', 'ᾶ'=> 'a', 'ᾷ'=> 'a', 'Ᾰ'=> 'A', 'Ᾱ'=> 'A', 'Ὰ'=> 'A', 'Ά'=> 'A', 'ᾼ'=> 'A', 'Ä'=> 'A', 'ä'=> 'a', 'À'=> 'A', 'à'=> 'a', 'Á'=> 'A', 'á'=> 'a', 'Â'=> 'A', 'â'=> 'a', 'Ã'=> 'A', 'ã'=> 'a', 'A̧'=> 'A', 'a̧'=> 'a', 'Ą'=> 'A', 'ą'=> 'a', 'Ⱥ'=> 'A', 'ⱥ'=> 'a', 'Å'=> 'A', 'å'=> 'a', 'Ǻ'=> 'A', 'ǻ'=> 'a', 'Ă'=> 'A', 'ă'=> 'a', 'Ǎ'=> 'A', 'ǎ'=> 'a', 'Ȧ'=> 'A', 'ȧ'=> 'a', 'Ạ'=> 'A', 'ạ'=> 'a', 'Ā'=> 'A', 'ā'=> 'a', 'ª'=> 'a', 'Ɓ'=> 'B', 'Ѣ'=> 'E', 'ѣ'=> 'e', 'Ç'=> 'C', 'ç'=> 'c', 'Ĉ'=> 'C', 'ĉ'=> 'c', 'C̈'=> 'C', 'c̈'=> 'c', 'C̨'=> 'C', 'c̨'=> 'c', 'Ȼ'=> 'C', 'ȼ'=> 'c', 'Č'=> 'C', 'č'=> 'c', 'Ć'=> 'C', 'ć'=> 'c', 'C̀'=> 'C', 'c̀'=> 'c', 'Ċ'=> 'C', 'ċ'=> 'c', 'C̣'=> 'C', 'c̣'=> 'c', 'C̄'=> 'C', 'c̄'=> 'c', 'C̃'=> 'C', 'c̃'=> 'c', 'Ð'=> 'D', 'Đ'=> 'D', 'ð'=> 'd', 'đ'=> 'd', 'È'=> 'E', 'É'=> 'E', 'Ê'=> 'E', 'Ë'=> 'E', 'Ĕ'=> 'E', 'Ė'=> 'E', 'Ȩ'=> 'E', 'ȩ'=> 'e', 'Ę'=> 'E', 'ę'=> 'e', 'Ɇ'=> 'E', 'ɇ'=> 'e', 'Ě'=> 'E', 'ě'=> 'e', 'Ẹ'=> 'E', 'ẹ'=> 'e', 'Ē'=> 'E', 'ē'=> 'e', 'Ẽ'=> 'E', 'ẽ'=> 'e', 'è'=> 'e', 'é'=> 'e', 'ê'=> 'e', 'ë'=> 'e', 'ĕ'=> 'e', 'ė'=> 'e', 'ƒ'=> 'f', 'Ѳ'=> 'F', 'ѳ'=> 'f', 'Ĝ'=> 'G', 'Ġ'=> 'G', 'ĝ'=> 'g', 'ġ'=> 'g', 'Ĥ'=> 'H', 'Ħ'=> 'H', 'ĥ'=> 'h', 'ħ'=> 'h', 'Ì'=> 'I', 'Í'=> 'I', 'Î'=> 'I', 'Ï'=> 'I', 'Ĩ'=> 'I', 'Ĭ'=> 'I', 'Ǐ'=> 'I', 'Į'=> 'I', 'ì'=> 'i', 'í'=> 'i', 'î'=> 'i', 'ï'=> 'i', 'ĩ'=> 'i', 'ĭ'=> 'i', 'ǐ'=> 'i', 'į'=> 'i', 'І'=> 'I', 'і'=> 'i', 'I̧'=> 'I', 'i̧'=> 'i', 'Ɨ'=> 'I', 'ɨ'=> 'i', 'İ'=> 'I', 'i'=> 'i', 'Ị'=> 'I', 'ị'=> 'i', 'Ī'=> 'I', 'ī'=> 'i', 'Ĵ'=> 'J', 'ĵ'=> 'j', 'J́́'=> 'J', 'j́'=> 'j', 'J̀̀'=> 'J', 'j̀'=> 'j', 'J̈'=> 'J', 'j̈'=> 'j', 'J̧'=> 'J', 'j̧'=> 'j', 'J̨'=> 'J', 'j̨'=> 'j', 'Ɉ'=> 'J', 'ɉ'=> 'j', 'J̌'=> 'J', 'ǰ'=> 'j', 'J̇'=> 'J', 'j'=> 'j', 'J̣'=> 'J', 'j̣'=> 'j', 'J̄'=> 'J', 'j̄'=> 'j', 'J̃'=> 'J', 'j̃'=> 'j', 'ĸ'=> 'k', 'Ĺ'=> 'L', 'Ľ'=> 'L', 'Ŀ'=> 'L', 'ĺ'=> 'l', 'ľ'=> 'l', 'ŀ'=> 'l', 'L̀'=> 'L', 'l̀'=> 'l', 'L̂'=> 'L', 'l̂'=> 'l', 'L̈'=> 'L', 'l̈'=> 'l', 'Ļ'=> 'L', 'ļ'=> 'l', 'L̨'=> 'L', 'l̨'=> 'l', 'Ł'=> 'L', 'ł'=> 'l', 'Ƚ'=> 'L', 'ƚ'=> 'l', 'L̇'=> 'L', 'l̇'=> 'l', 'Ḷ'=> 'L', 'ḷ'=> 'l', 'L̄'=> 'L', 'l̄'=> 'l', 'L̃'=> 'L', 'l̃'=> 'l', 'Ñ'=> 'N', 'ñ'=> 'n', 'Ŋ'=> 'N', 'ŋ'=> 'n', 'ŉ'=> 'n', 'Ń'=> 'N', 'ń'=> 'n', 'Ǹ'=> 'N', 'ǹ'=> 'n', 'N̂'=> 'N', 'n̂'=> 'n', 'N̈'=> 'N', 'n̈'=> 'n', 'Ņ'=> 'N', 'ņ'=> 'n', 'N̨'=> 'N', 'n̨'=> 'n', 'Ꞥ'=> 'N', 'ꞥ'=> 'n', 'Ň'=> 'N', 'ň'=> 'n', 'Ṅ'=> 'N', 'ṅ'=> 'n', 'Ṇ'=> 'N', 'ṇ'=> 'n', 'N̄'=> 'N', 'n̄'=> 'n', 'Ö'=> 'O', 'Ò'=> 'O', 'Ó'=> 'O', 'Ô'=> 'O', 'Õ'=> 'O', 'Ō'=> 'O', 'Ŏ'=> 'O', 'Ǒ'=> 'O', 'Ő'=> 'O', 'Ơ'=> 'O', 'Ø'=> 'O', 'Ǿ'=> 'O', 'ö'=> 'o', 'ò'=> 'o', 'ó'=> 'o', 'ô'=> 'o', 'õ'=> 'o', 'ō'=> 'o', 'ŏ'=> 'o', 'ǒ'=> 'o', 'ő'=> 'o', 'ơ'=> 'o', 'ø'=> 'o', 'ǿ'=> 'o', 'º'=> 'o', 'O̧'=> 'O', 'o̧'=> 'o', 'Ǫ'=> 'O', 'ǫ'=> 'o', 'Ɵ'=> 'O', 'ɵ'=> 'o', 'Ȯ'=> 'O', 'ȯ'=> 'o', 'Ọ'=> 'O', 'ọ'=> 'o', 'Ŕ'=> 'R', 'Ŗ'=> 'R', 'ŕ'=> 'r', 'ŗ'=> 'r', 'Ŝ'=> 'S', 'Ș'=> 'S', 'ș'=> 's', 'Ś'=> 'S', 'ś'=> 's', 'S̀'=> 'S', 's̀'=> 's', 'Ŝ̀'=> 'S', 'ŝ'=> 's', 'S̈'=> 'S', 's̈'=> 's', 'Ş'=> 'S', 'ş'=> 's', 'S̨'=> 'S', 's̨'=> 's', 'Ꞩ'=> 'S', 'ꞩ'=> 's', 'Š'=> 'S', 'š'=> 's', 'Ṡ'=> 'S', 'ṡ'=> 's', 'Ṣ'=> 'S', 'ṣ'=> 's', 'S̄'=> 'S', 's̄'=> 's', 'S̃'=> 'S', 's̃'=> 's', 'ſ'=> 's', 'Ţ'=> 'T', 'Ț'=> 'T', 'Ŧ'=> 'T', 'Þ'=> 'TH', 'ţ'=> 't', 'ț'=> 't', 'ŧ'=> 't', 'þ'=> 'th', 'T́'=> 'T', 't́'=> 't', 'T̀'=> 'T', 't̀'=> 't', 'T̂'=> 'T', 't̂'=> 't', 'T̈'=> 'T', 'ẗ'=> 't', 'T̨'=> 'T', 't̨'=> 't', 'Ⱦ'=> 'T', 'ⱦ'=> 't', 'Ť'=> 'T', 'ť'=> 't', 'Ṫ'=> 'T', 'ṫ'=> 't', 'Ṭ'=> 'T', 'ṭ'=> 't', 'T̄'=> 'T', 't̄'=> 't', 'T̃'=> 'T', 't̃'=> 't', 'Ü'=> 'U', 'Ù'=> 'U', 'Ú'=> 'U', 'Û'=> 'U', 'Ũ'=> 'U', 'Ŭ'=> 'U', 'Ű'=> 'U', 'Ų'=> 'U', 'Ư'=> 'U', 'Ǔ'=> 'U', 'Ǖ'=> 'U', 'Ǘ'=> 'U', 'Ǚ'=> 'U', 'Ǜ'=> 'U', 'ü'=> 'u', 'ù'=> 'u', 'ú'=> 'u', 'û'=> 'u', 'ũ'=> 'u', 'ŭ'=> 'u', 'ű'=> 'u', 'ų'=> 'u', 'ư'=> 'u', 'ǔ'=> 'u', 'ǖ'=> 'u', 'ǘ'=> 'u', 'ǚ'=> 'u', 'ǜ'=> 'u', 'U̧'=> 'U', 'u̧'=> 'u', 'Ʉ'=> 'U', 'ʉ'=> 'u', 'U̇'=> 'U', 'u̇'=> 'u', 'Ụ'=> 'U', 'ụ'=> 'u', 'Ū'=> 'U', 'ū'=> 'u', 'Ʊ'=> 'U', 'ʊ'=> 'u', 'Ŵ'=> 'W', 'ŵ'=> 'w', 'Ẁ'=> 'W', 'ẁ'=> 'w', 'Ẃ'=> 'W', 'ẃ'=> 'w', 'Ẅ'=> 'W', 'ẅ'=> 'w', 'Ѵ'=> 'I', 'ѵ'=> 'i', 'Ꙗ'=> 'Ja', 'ꙗ'=> 'ja', 'Є'=> 'Je', 'є'=> 'je', 'Ѥ'=> 'Je', 'ѥ'=> 'je', 'Ѕ'=> 'Dz', 'ѕ'=> 'dz', 'Ꙋ'=> 'U', 'ꙋ'=> 'u', 'Ѡ'=> 'O', 'ѡ'=> 'o', 'Ѿ'=> 'Ot', 'ѿ'=> 'ot', 'Ѫ'=> 'U', 'ѫ'=> 'u', 'Ѧ'=> 'Ja', 'ѧ'=> 'ja', 'Ѭ'=> 'Ju', 'ѭ'=> 'ju', 'Ѩ'=> 'Ja', 'ѩ'=> 'Ja', 'Ѯ'=> 'Ks', 'ѯ'=> 'ks', 'Ѱ'=> 'Ps', 'ѱ'=> 'ps', 'Х'=> 'X', 'х'=> 'x', 'Ý'=> 'Y', 'Ÿ'=> 'Y', 'Ŷ'=> 'Y', 'ý'=> 'y', 'ÿ'=> 'y', 'ŷ'=> 'y', 'Ỳ'=> 'Y', 'ỳ'=> 'y', 'Y̧'=> 'Y', 'y̧'=> 'y', 'Y̨'=> 'Y', 'y̨'=> 'y', 'Ɏ'=> 'Y', 'ɏ'=> 'y', 'Y̌'=> 'Y', 'y̌'=> 'y', 'Ẏ'=> 'Y', 'ẏ'=> 'y', 'Ỵ'=> 'Y', 'ỵ'=> 'y', 'Ȳ'=> 'Y', 'ȳ'=> 'y', 'Ỹ'=> 'Y', 'ỹ'=> 'y', 'Ź'=> 'Z', 'ź'=> 'z', 'Z̀'=> 'Z', 'z̀'=> 'z', 'Ẑ'=> 'Z', 'ẑ'=> 'z', 'Z̈'=> 'Z', 'z̈'=> 'z', 'Z̧'=> 'Z', 'z̧'=> 'z', 'Z̨'=> 'Z', 'z̨'=> 'z', 'Ƶ'=> 'Z', 'ƶ'=> 'z', 'Ž'=> 'Z', 'ž'=> 'z', 'Ż'=> 'Z', 'ż'=> 'z', 'Ẓ'=> 'Z', 'ẓ'=> 'z', 'Z̄'=> 'Z', 'z̄'=> 'z', 'Z̃'=> 'Z', 'z̃'=> 'z',], ' '=> [ "\c2\a0"=> ' ', "\e1\9a\80"=> ' ', "\e2\80\80"=> ' ', "\e2\80\81"=> ' ', "\e2\80\82"=> ' ', "\e2\80\83"=> ' ', "\e2\80\84"=> ' ', "\e2\80\85"=> ' ', "\e2\80\86"=> ' ', "\e2\80\87"=> ' ', "\e2\80\88"=> ' ', "\e2\80\89"=> ' ', "\e2\80\8a"=> ' ', "\e2\80\a8"=> ' ', "\e2\80\a9"=> ' ', "\e2\80\8b"=> ' ', "\e2\80\af"=> ' ', "\e2\81\9f"=> ' ', "\e3\80\80"=> ' ', "\ef\be\a0"=> ' ',], 'msword'=> [ "\c2\ab"=> '<<', "\c2\bb"=> '>>', "\e2\80\98"=> "'", "\e2\80\99"=> "'", "\e2\80\9a"=> "'", "\e2\80\9b"=> "'", "\e2\80\9c"=> '"', "\xe2\x80\x9d" => '"', "\e2\80\9e"=> '"', "\xe2\x80\x9f" => '"', "\e2\80\b9"=> "'", "\e2\80\ba"=> "'", "\e2\80\93"=> '-', "\e2\80\94"=> '-', "\e2\80\a6"=> '...',], 'currency_short'=> [ '€'=> 'EUR', '$'=> '$', '₢'=> 'Cr', '₣'=> 'Fr.', '£'=> 'PS', '₤'=> 'L.', 'ℳ'=> 'M', '₥'=> 'mil', '₦'=> 'N', '₧'=> 'Pts', '₨'=> 'Rs', 'රු'=> 'LKR', 'ரூ'=> 'LKR', '௹'=> 'Rs', 'रू'=> 'NPR', '₹'=> 'Rs', '૱'=> 'Rs', '₩'=> 'W', '₪'=> 'NS', '₸'=> 'KZT', '₫'=> 'D', '֏'=> 'AMD', '₭'=> 'K', '₺'=> 'TL', '₼'=> 'AZN', '₮'=> 'T', '₯'=> 'Dr', '₲'=> 'PYG', '₾'=> 'GEL', '₳'=> 'ARA', '₴'=> 'UAH', '₽'=> 'RUB', '₵'=> 'GHS', '₡'=> 'CL', '¢'=> 'c', '¥'=> 'YEN', '円'=> 'JPY', '৳'=> 'BDT', '元'=> 'CNY', '﷼'=> 'SAR', '៛'=> 'KR', '₠'=> 'ECU', '¤'=> '$?', '฿'=> 'THB', '؋'=> 'AFN',],]


Joomla CMS: Référence du fichier ascii_extras_by_languages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier ascii_extras_by_languages.php

Variables

return ['nl'=> ['='=> ' gelijk ', '%'=> ' procent ', '∑'=> ' som ', '∆'=> ' delta ', '∞'=> ' oneindig ', '♥'=> ' love ', '&'=> ' en ', '+'=> ' plus ',], 'it'=> ['='=> ' uguale ', '%'=> ' percent ', '∑'=> ' somma ', '∆'=> ' delta ', '∞'=> ' infinito ', '♥'=> ' amore ', '&'=> ' e ', '+'=> ' piu ',], 'mk'=> ['='=> ' ednakva ', '%'=> ' procenti ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskonecnost ', '♥'=> ' loveubov ', '&'=> ' i ', '+'=> ' plus ',], 'pt'=> ['='=> ' igual ', '%'=> ' por cento ', '∑'=> ' soma ', '∆'=> ' delta ', '∞'=> ' infinito ', '♥'=> ' amor ', '&'=> ' e ', '+'=> ' mais ',], 'el__greeklish'=> ['='=> ' isos ', '%'=> ' tois ekato ', '∑'=> ' athroisma ', '∆'=> ' delta ', '∞'=> ' apeiro ', '♥'=> ' agape ', '&'=> ' kai ', '+'=> ' syn ',], 'el'=> ['='=> ' isos ', '%'=> ' tois ekato ', '∑'=> ' athroisma ', '∆'=> ' delta ', '∞'=> ' apeiro ', '♥'=> ' agape ', '&'=> ' kai ', '+'=> ' syn ',], 'hi'=> ['='=> ' samana ', '%'=> ' paratisata ', '∑'=> ' yoga ', '∆'=> ' dalata ', '∞'=> ' anata ', '♥'=> ' payara ', '&'=> ' aura ', '+'=> ' palasa ',], 'hy'=> ['='=> ' havasar ', '%'=> ' tvokvos ', '∑'=> ' gvoumar ', '∆'=> ' delta ', '∞'=> ' ansahmanvouthyvoun ', '♥'=> ' ser ', '&'=> ' ev ', '+'=> ' gvoumarats ',], 'sv'=> ['='=> ' lika ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' delta ', '∞'=> ' oandlighet ', '♥'=> ' alskar ', '&'=> ' och ', '+'=> ' plus ',], 'tk'=> ['='=> ' den ', '%'=> ' yuzde ', '∑'=> ' jem ', '∆'=> ' delta ', '∞'=> ' mudimilik ', '♥'=> ' soygi ', '&'=> ' we ', '+'=> ' yzy ',], 'tr'=> ['='=> ' esit ', '%'=> ' yuzde ', '∑'=> ' Toplam ', '∆'=> ' delta ', '∞'=> ' sonsuzluk ', '♥'=> ' ask ', '&'=> ' ve ', '+'=> ' arti ',], 'bg'=> ['='=> ' raven ', '%'=> ' na sto ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' bezkrajnost ', '♥'=> ' obicam ', '&'=> ' i ', '+'=> ' plus ',], 'hu'=> ['='=> ' Egyenlo ', '%'=> ' Szazalek ', '∑'=> ' osszeg ', '∆'=> ' delta ', '∞'=> ' vegtelenitett ', '♥'=> ' love ', '&'=> ' Es ', '+'=> ' Plusz ',], 'my'=> ['='=> ' ttn:ttnnym? ', '%'=> ' raakhngnn:k ', '∑'=> ' ld ', '∆'=> ' m?cwk?n:pe? ', '∞'=> ' ach:m ', '♥'=> ' mettttaa ', '&'=> ' n ', '+'=> ' ape?ng:',], 'hr'=> ['='=> ' Jednaki ', '%'=> ' Posto ', '∑'=> ' zbroj ', '∆'=> ' Delta ', '∞'=> ' beskonacno ', '♥'=> ' ljubav ', '&'=> ' I ', '+'=> ' Plus ',], 'fi'=> ['='=> ' Sama ', '%'=> ' Prosenttia ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' aareton ', '♥'=> ' rakkautta ', '&'=> ' Ja ', '+'=> ' Plus ',], 'ka'=> ['='=> ' tanasts\ 'ori ', '%'=> ' p\ 'rotsent\ 'i ', '∑'=> ' tankha ', '∆'=> ' delt\ 'a ', '∞'=> ' usasrulo ', '♥'=> ' siq\ 'varuli ', '&'=> ' da ', '+'=> ' p\ 'lus ',], 'ru'=> ['='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'ru__passport_2013'=> ['='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'ru__gost_2000_b'=> ['='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'uk'=> ['='=> ' rivnij ', '%'=> ' vidsotkiv ', '∑'=> ' suma ', '∆'=> ' del\ 'ta ', '∞'=> ' neskincennist\' ', '♥'=> ' lubov ', '&'=> ' i ', '+'=> ' plus ',], 'kk'=> ['='=> ' ten\' ', '%'=> ' Pajyzdar ', '∑'=> ' zalpy ', '∆'=> ' ajyrmasylyk, ', '∞'=> ' seksiz ', '♥'=> ' mahabbat ', '&'=> ' z @ne ', '+'=> ' plus ',], 'cs'=> ['='=> ' rovnat se ', '%'=> ' procento ', '∑'=> ' soucet ', '∆'=> ' delta ', '∞'=> ' nekonecno ', '♥'=> ' laska ', '&'=> ' a ', '+'=> ' plus ',], 'da'=> ['='=> ' Lige ', '%'=> ' Prozent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' uendelig ', '♥'=> ' kaerlighed ', '&'=> ' Og ', '+'=> ' Plus ',], 'pl'=> ['='=> ' rowny ', '%'=> ' procent ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' nieskonczonosc ', '♥'=> ' milosc ', '&'=> ' i ', '+'=> ' plus ',], 'ro'=> ['='=> ' egal ', '%'=> ' la suta ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' infinit ', '♥'=> ' dragoste ', '&'=> ' si ', '+'=> ' la care se adauga ',], 'eo'=> ['='=> ' Egalaj ', '%'=> ' Procento ', '∑'=> ' sumo ', '∆'=> ' delto ', '∞'=> ' senfina ', '♥'=> ' amo ', '&'=> ' Kaj ', '+'=> ' Pli ',], 'et'=> ['='=> ' Vordsed ', '%'=> ' Protsenti ', '∑'=> ' summa ', '∆'=> ' o ', '∞'=> ' loputut ', '♥'=> ' armastus ', '&'=> ' Ja ', '+'=> ' Pluss ',], 'lv'=> ['='=> ' vienads ', '%'=> ' procents ', '∑'=> ' summa ', '∆'=> ' delta ', '∞'=> ' bezgaliba ', '♥'=> ' milestiba ', '&'=> ' un ', '+'=> ' pluss ',], 'lt'=> ['='=> ' lygus ', '%'=> ' procentu ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' begalybe ', '♥'=> ' meile ', '&'=> ' ir ', '+'=> ' plius ',], 'no'=> ['='=> ' Lik ', '%'=> ' Prosent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' uendelig ', '♥'=> ' kjaerlighet ', '&'=> ' Og ', '+'=> ' Pluss ',], 'vi'=> ['='=> ' cong bang ', '%'=> ' phan tram ', '∑'=> ' tong so ', '∆'=> ' dong bang ', '∞'=> ' vo cuc ', '♥'=> ' Yeu ', '&'=> ' va ', '+'=> ' them ',], 'ar'=> ['='=> ' mtsawy ', '%'=> ' nsbh mywyh ', '∑'=> ' mjmw\' ', '∆'=> ' dlta ', '∞'=> ' ma la nhayt ', '♥'=> ' hb ', '&'=> ' w ', '+'=> ' zayd ',], 'fa'=> ['='=> ' brabr ', '%'=> ' dr sd ', '∑'=> ' mjmw\' ', '∆'=> ' dlta ', '∞'=> ' by nhayt ', '♥'=> ' \ 'shq ', '&'=> ' w ', '+'=> ' bh \ 'lawh ',], 'sr'=> ['='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'sr__cyr'=> ['='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'sr__lat'=> ['='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'az'=> ['='=> ' b @rab @r ', '%'=> ' faiz ', '∑'=> ' m @bl @g ', '∆'=> ' delta ', '∞'=> ' sonsuzluq ', '♥'=> ' sevgi ', '&'=> ' v@ ', '+'=> ' plus ',], 'sk'=> ['='=> ' rovny ', '%'=> ' percento ', '∑'=> ' sucet ', '∆'=> ' delta ', '∞'=> ' infinity ', '♥'=> ' milovat ', '&'=> ' a ', '+'=> ' viac ',], 'fr'=> ['='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'fr_at'=> ['='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'fr_ch'=> ['='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'de'=> ['='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'de_at'=> ['='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'de_ch'=> ['='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'bn'=> ['='=> ' Saman ', '%'=> ' Satakora ', '∑'=> ' Samasti ', '∆'=> ' Badhip ', '∞'=> ' Ananta ', '♥'=> ' Valobasa ', '&'=> ' Abong ', '+'=> ' Songzojon ',], 'en'=> ['='=> ' equal ', '%'=> ' percent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' infinity ', '♥'=> ' love ', '&'=> ' and ', '+'=> ' plus ',], 'currency'=> ['€'=> ' Euro ', '$'=> ' Dollar ', '₢'=> ' cruzeiro ', '₣'=> ' French franc ', '£'=> ' pound ', '₤'=> ' lira ', '₶'=> ' livre tournois ', 'ℳ'=> ' mark ', '₥'=> ' mill ', '₦'=> ' naira ', '₧'=> ' peseta ', '₨'=> ' rupee ', 'රු'=> ' rupee ', 'ரூ'=> ' rupee ', '௹'=> ' rupee ', 'रू'=> ' rupee ', '₹'=> ' rupee ', '૱'=> ' rupee ', '₩'=> ' won ', '₪'=> ' new shequel ', '₸'=> ' tenge ', '₫'=> ' dong ', '֏'=> ' dram ', '₭'=> ' kip ', '₺'=> ' lira ', '₼'=> ' manat ', '₮'=> ' tugrik ', '₯'=> ' drachma ', '₰'=> ' pfennig ', '₷'=> ' spesmilo ', '₱'=> ' peso ', '﷼‎'=> ' riyal ', '₲'=> ' guarani ', '₾'=> ' lari ', '₳'=> ' austral ', '₴'=> ' hryvnia ', '₽'=> ' ruble ', '₵'=> ' cedi ', '₡'=> ' colon ', '¢'=> ' cent ', '¥'=> ' yen ', '円'=> ' yen ', '৳'=> ' taka ', '元'=> ' yuan ', '﷼'=> ' riyal ', '៛'=> ' riel ', '₠'=> ' European Currency ', '¤'=> ' currency ', '฿'=> ' baht ', '؋'=> ' afghani ',], 'temperature'=> ['°De'=> ' Delisle ', '°Re'=> ' Reaumur ', '°Ro'=> ' Romer ', '°R'=> ' Rankine ', '°C'=> ' Celsius ', '°F'=> ' Fahrenheit ', '°N'=> ' Newton ',], 'latin_symbols'=> ['='=> '=', '%'=> '%', '∑'=> '∑', '∆'=> '∆', '∞'=> '∞', '♥'=> '♥', '&'=> '&', '+'=> '+', '©'=> '(c) ', '®'=> '(r) ', '@'=> '(at) ', '№'=> ' No. ', '℞'=> ' Rx ', '［'=> '[', '＼'=> '\\', '］'=> ']', '＾'=> '^', '＿'=> '_', '｀'=> '`', '‐'=> '-', '‑'=> '-', '‒'=> '-', '–'=> '-', '−'=> '-', '—'=> '-', '―'=> '-', '﹘'=> '-', '│'=> '|', '∖'=> '\\', '∕'=> '/', '⁄'=> '/', '￩'=> '<-', '￫'=> '->', '￪'=> '|', '￬'=> '|', '⁅'=> '[', '⁆'=> ']', '⁎'=> ' *', '、'=> ',', '。'=> '.', '〈'=> '<', '〉'=> '>', '《'=> '<<', '》'=> '>>', '〔'=> '[', '〕'=> ']', '〘'=> '[', '〙'=> ']', '〚'=> '[', '〛'=> ']', '﹝'=> '[', '﹞'=> ']', '︹'=> '[', '︺'=> ']', '﹇'=> '[', '﹈'=> ']', '︐'=> ',', '︑'=> ',', '︒'=> '.', '︓'=> ':', '︔'=> ';', '︕'=> '!', '︖'=> '?', '︙'=> '...', '︰'=> '..', '︵'=> '(', '︶'=> ')', '﹙'=> '(', '﹚'=> ')', '︷'=> '{', '︸'=> '}', '﹛'=> '{', '﹜'=> '}', '︽'=> '<<', '︾'=> '>>', '︿'=> '<', '﹀'=> '>', '×'=> ' *', '÷'=> '/', '≪'=> '<<', '≫'=> '>>', '⦅'=> '((', '⦆'=> '))', '〇'=> '0', '′'=> '\'', '〝'=> '"', '〞' => '"', '«'=> '<<', '»'=> '>>', '‘'=> "'", '’'=> "'", '‚'=> ',', '‛'=> "'", '“'=> '"', '”' => '"', '„'=> '"', '‟' => '"', '‹'=> '<', '›'=> '>', '․'=> '.', '‥'=> '..', '…'=> '...', '″'=> '"', '‴' => '\\, '‶' => '``', '‷' => '```', '‼' => '!!', '⁇' => '??', '⁈' => '?!', '⁉' => '!?', '⁗' => '````', '⩴' => '::=', '⩵' => '==', '⩶' => '===', '﹔' => ';', '﹕' => ':', '﹖' => '?', '﹗' => '!', '﹍' => '_', '﹎' => '_', '﹏' => '_', '﹐' => ',', '﹑' => ',', '﹒' => '.', '﹟' => '#', '﹠' => '&', '﹡' => '*', '﹢' => '+', '﹣' => '-', '﹤' => '<', '﹥' => '>', '﹦' => '=', '﹨' => '\, '﹩' => '$', '﹪' => '%', '﹫' => '@', '！' => '!', '＂' => '"', '＃'=> '#', '＄'=> '$', '％'=> '%', '＆'=> '&', '＇'=> '\'', '（'=> '(', '）'=> ')', '＊'=> ' *', '＋'=> '+', '，'=> ',', '－'=> '-', '．'=> '.', '／'=> '/', '：'=> ':', '；'=> ';', '＜'=> '<', '＝'=> '=', '＞'=> '>', '？'=> '?', '＠'=> '@', '｛'=> '{', '｜'=> '|', '｝'=> '}', '～'=> '~', '｟'=> '((', '｠'=> '))', '￢'=> '!', '￣'=> '-', '￤'=> '|', '￭'=> '#',],]

Documentation des variables

◆ return

return[ 'nl'=> [ '='=> ' gelijk ', '%'=> ' procent ', '∑'=> ' som ', '∆'=> ' delta ', '∞'=> ' oneindig ', '♥'=> ' love ', '&'=> ' en ', '+'=> ' plus ',], 'it'=> [ '='=> ' uguale ', '%'=> ' percent ', '∑'=> ' somma ', '∆'=> ' delta ', '∞'=> ' infinito ', '♥'=> ' amore ', '&'=> ' e ', '+'=> ' piu ',], 'mk'=> [ '='=> ' ednakva ', '%'=> ' procenti ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskonecnost ', '♥'=> ' loveubov ', '&'=> ' i ', '+'=> ' plus ',], 'pt'=> [ '='=> ' igual ', '%'=> ' por cento ', '∑'=> ' soma ', '∆'=> ' delta ', '∞'=> ' infinito ', '♥'=> ' amor ', '&'=> ' e ', '+'=> ' mais ',], 'el__greeklish'=> [ '='=> ' isos ', '%'=> ' tois ekato ', '∑'=> ' athroisma ', '∆'=> ' delta ', '∞'=> ' apeiro ', '♥'=> ' agape ', '&'=> ' kai ', '+'=> ' syn ',], 'el'=> [ '='=> ' isos ', '%'=> ' tois ekato ', '∑'=> ' athroisma ', '∆'=> ' delta ', '∞'=> ' apeiro ', '♥'=> ' agape ', '&'=> ' kai ', '+'=> ' syn ',], 'hi'=> [ '='=> ' samana ', '%'=> ' paratisata ', '∑'=> ' yoga ', '∆'=> ' dalata ', '∞'=> ' anata ', '♥'=> ' payara ', '&'=> ' aura ', '+'=> ' palasa ',], 'hy'=> [ '='=> ' havasar ', '%'=> ' tvokvos ', '∑'=> ' gvoumar ', '∆'=> ' delta ', '∞'=> ' ansahmanvouthyvoun ', '♥'=> ' ser ', '&'=> ' ev ', '+'=> ' gvoumarats ',], 'sv'=> [ '='=> ' lika ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' delta ', '∞'=> ' oandlighet ', '♥'=> ' alskar ', '&'=> ' och ', '+'=> ' plus ',], 'tk'=> [ '='=> ' den ', '%'=> ' yuzde ', '∑'=> ' jem ', '∆'=> ' delta ', '∞'=> ' mudimilik ', '♥'=> ' soygi ', '&'=> ' we ', '+'=> ' yzy ',], 'tr'=> [ '='=> ' esit ', '%'=> ' yuzde ', '∑'=> ' Toplam ', '∆'=> ' delta ', '∞'=> ' sonsuzluk ', '♥'=> ' ask ', '&'=> ' ve ', '+'=> ' arti ',], 'bg'=> [ '='=> ' raven ', '%'=> ' na sto ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' bezkrajnost ', '♥'=> ' obicam ', '&'=> ' i ', '+'=> ' plus ',], 'hu'=> [ '='=> ' Egyenlo ', '%'=> ' Szazalek ', '∑'=> ' osszeg ', '∆'=> ' delta ', '∞'=> ' vegtelenitett ', '♥'=> ' love ', '&'=> ' Es ', '+'=> ' Plusz ',], 'my'=> [ '='=> ' ttn:ttnnym? ', '%'=> ' raakhngnn:k ', '∑'=> ' ld ', '∆'=> ' m?cwk?n:pe? ', '∞'=> ' ach:m ', '♥'=> ' mettttaa ', '&'=> ' n ', '+'=> ' ape?ng:',], 'hr'=> [ '='=> ' Jednaki ', '%'=> ' Posto ', '∑'=> ' zbroj ', '∆'=> ' Delta ', '∞'=> ' beskonacno ', '♥'=> ' ljubav ', '&'=> ' I ', '+'=> ' Plus ',], 'fi'=> [ '='=> ' Sama ', '%'=> ' Prosenttia ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' aareton ', '♥'=> ' rakkautta ', '&'=> ' Ja ', '+'=> ' Plus ',], 'ka'=> [ '='=> ' tanasts\ 'ori ', '%'=> ' p\ 'rotsent\ 'i ', '∑'=> ' tankha ', '∆'=> ' delt\ 'a ', '∞'=> ' usasrulo ', '♥'=> ' siq\ 'varuli ', '&'=> ' da ', '+'=> ' p\ 'lus ',], 'ru'=> [ '='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'ru__passport_2013'=> [ '='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'ru__gost_2000_b'=> [ '='=> ' ravnyj ', '%'=> ' procent ', '∑'=> ' summa ', '∆'=> ' del\ 'ta ', '∞'=> ' beskonecnost\' ', '♥'=> ' lublu ', '&'=> ' i ', '+'=> ' plus ',], 'uk'=> [ '='=> ' rivnij ', '%'=> ' vidsotkiv ', '∑'=> ' suma ', '∆'=> ' del\ 'ta ', '∞'=> ' neskincennist\' ', '♥'=> ' lubov ', '&'=> ' i ', '+'=> ' plus ',], 'kk'=> [ '='=> ' ten\' ', '%'=> ' Pajyzdar ', '∑'=> ' zalpy ', '∆'=> ' ajyrmasylyk, ', '∞'=> ' seksiz ', '♥'=> ' mahabbat ', '&'=> ' z @ne ', '+'=> ' plus ',], 'cs'=> [ '='=> ' rovnat se ', '%'=> ' procento ', '∑'=> ' soucet ', '∆'=> ' delta ', '∞'=> ' nekonecno ', '♥'=> ' laska ', '&'=> ' a ', '+'=> ' plus ',], 'da'=> [ '='=> ' Lige ', '%'=> ' Prozent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' uendelig ', '♥'=> ' kaerlighed ', '&'=> ' Og ', '+'=> ' Plus ',], 'pl'=> [ '='=> ' rowny ', '%'=> ' procent ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' nieskonczonosc ', '♥'=> ' milosc ', '&'=> ' i ', '+'=> ' plus ',], 'ro'=> [ '='=> ' egal ', '%'=> ' la suta ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' infinit ', '♥'=> ' dragoste ', '&'=> ' si ', '+'=> ' la care se adauga ',], 'eo'=> [ '='=> ' Egalaj ', '%'=> ' Procento ', '∑'=> ' sumo ', '∆'=> ' delto ', '∞'=> ' senfina ', '♥'=> ' amo ', '&'=> ' Kaj ', '+'=> ' Pli ',], 'et'=> [ '='=> ' Vordsed ', '%'=> ' Protsenti ', '∑'=> ' summa ', '∆'=> ' o ', '∞'=> ' loputut ', '♥'=> ' armastus ', '&'=> ' Ja ', '+'=> ' Pluss ',], 'lv'=> [ '='=> ' vienads ', '%'=> ' procents ', '∑'=> ' summa ', '∆'=> ' delta ', '∞'=> ' bezgaliba ', '♥'=> ' milestiba ', '&'=> ' un ', '+'=> ' pluss ',], 'lt'=> [ '='=> ' lygus ', '%'=> ' procentu ', '∑'=> ' suma ', '∆'=> ' delta ', '∞'=> ' begalybe ', '♥'=> ' meile ', '&'=> ' ir ', '+'=> ' plius ',], 'no'=> [ '='=> ' Lik ', '%'=> ' Prosent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' uendelig ', '♥'=> ' kjaerlighet ', '&'=> ' Og ', '+'=> ' Pluss ',], 'vi'=> [ '='=> ' cong bang ', '%'=> ' phan tram ', '∑'=> ' tong so ', '∆'=> ' dong bang ', '∞'=> ' vo cuc ', '♥'=> ' Yeu ', '&'=> ' va ', '+'=> ' them ',], 'ar'=> [ '='=> ' mtsawy ', '%'=> ' nsbh mywyh ', '∑'=> ' mjmw\' ', '∆'=> ' dlta ', '∞'=> ' ma la nhayt ', '♥'=> ' hb ', '&'=> ' w ', '+'=> ' zayd ',], 'fa'=> [ '='=> ' brabr ', '%'=> ' dr sd ', '∑'=> ' mjmw\' ', '∆'=> ' dlta ', '∞'=> ' by nhayt ', '♥'=> ' \ 'shq ', '&'=> ' w ', '+'=> ' bh \ 'lawh ',], 'sr'=> [ '='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'sr__cyr'=> [ '='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'sr__lat'=> [ '='=> ' jednak ', '%'=> ' procenat ', '∑'=> ' zbir ', '∆'=> ' delta ', '∞'=> ' beskraj ', '♥'=> ' lubav ', '&'=> ' i ', '+'=> ' vise ',], 'az'=> [ '='=> ' b @rab @r ', '%'=> ' faiz ', '∑'=> ' m @bl @g ', '∆'=> ' delta ', '∞'=> ' sonsuzluq ', '♥'=> ' sevgi ', '&'=> ' v@ ', '+'=> ' plus ',], 'sk'=> [ '='=> ' rovny ', '%'=> ' percento ', '∑'=> ' sucet ', '∆'=> ' delta ', '∞'=> ' infinity ', '♥'=> ' milovat ', '&'=> ' a ', '+'=> ' viac ',], 'fr'=> [ '='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'fr_at'=> [ '='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'fr_ch'=> [ '='=> ' Egal ', '%'=> ' Pourcentage ', '∑'=> ' somme ', '∆'=> ' delta ', '∞'=> ' infini ', '♥'=> ' amour ', '&'=> ' Et ', '+'=> ' Plus ',], 'de'=> [ '='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'de_at'=> [ '='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'de_ch'=> [ '='=> ' gleich ', '%'=> ' Prozent ', '∑'=> ' gesamt ', '∆'=> ' Unterschied ', '∞'=> ' undendlich ', '♥'=> ' liebe ', '&'=> ' und ', '+'=> ' plus ',], 'bn'=> [ '='=> ' Saman ', '%'=> ' Satakora ', '∑'=> ' Samasti ', '∆'=> ' Badhip ', '∞'=> ' Ananta ', '♥'=> ' Valobasa ', '&'=> ' Abong ', '+'=> ' Songzojon ',], 'en'=> [ '='=> ' equal ', '%'=> ' percent ', '∑'=> ' sum ', '∆'=> ' delta ', '∞'=> ' infinity ', '♥'=> ' love ', '&'=> ' and ', '+'=> ' plus ',], 'currency'=> [ '€'=> ' Euro ', '$'=> ' Dollar ', '₢'=> ' cruzeiro ', '₣'=> ' French franc ', '£'=> ' pound ', '₤'=> ' lira ', '₶'=> ' livre tournois ', 'ℳ'=> ' mark ', '₥'=> ' mill ', '₦'=> ' naira ', '₧'=> ' peseta ', '₨'=> ' rupee ', 'රු'=> ' rupee ', 'ரூ'=> ' rupee ', '௹'=> ' rupee ', 'रू'=> ' rupee ', '₹'=> ' rupee ', '૱'=> ' rupee ', '₩'=> ' won ', '₪'=> ' new shequel ', '₸'=> ' tenge ', '₫'=> ' dong ', '֏'=> ' dram ', '₭'=> ' kip ', '₺'=> ' lira ', '₼'=> ' manat ', '₮'=> ' tugrik ', '₯'=> ' drachma ', '₰'=> ' pfennig ', '₷'=> ' spesmilo ', '₱'=> ' peso ', '﷼‎'=> ' riyal ', '₲'=> ' guarani ', '₾'=> ' lari ', '₳'=> ' austral ', '₴'=> ' hryvnia ', '₽'=> ' ruble ', '₵'=> ' cedi ', '₡'=> ' colon ', '¢'=> ' cent ', '¥'=> ' yen ', '円'=> ' yen ', '৳'=> ' taka ', '元'=> ' yuan ', '﷼'=> ' riyal ', '៛'=> ' riel ', '₠'=> ' European Currency ', '¤'=> ' currency ', '฿'=> ' baht ', '؋'=> ' afghani ',], 'temperature'=> [ '°De'=> ' Delisle ', '°Re'=> ' Reaumur ', '°Ro'=> ' Romer ', '°R'=> ' Rankine ', '°C'=> ' Celsius ', '°F'=> ' Fahrenheit ', '°N'=> ' Newton ',], 'latin_symbols'=> [ '='=> '=', '%'=> '%', '∑'=> '∑', '∆'=> '∆', '∞'=> '∞', '♥'=> '♥', '&'=> '&', '+'=> '+', '©'=> '(c) ', '®'=> '(r) ', '@'=> '(at) ', '№'=> ' No. ', '℞'=> ' Rx ', '［'=> '[', '＼'=> '\\', '］'=> ']', '＾'=> '^', '＿'=> '_', '｀'=> '`', '‐'=> '-', '‑'=> '-', '‒'=> '-', '–'=> '-', '−'=> '-', '—'=> '-', '―'=> '-', '﹘'=> '-', '│'=> '|', '∖'=> '\\', '∕'=> '/', '⁄'=> '/', '￩'=> '<-', '￫'=> '->', '￪'=> '|', '￬'=> '|', '⁅'=> '[', '⁆'=> ']', '⁎'=> ' *', '、'=> ',', '。'=> '.', '〈'=> '<', '〉'=> '>', '《'=> '<<', '》'=> '>>', '〔'=> '[', '〕'=> ']', '〘'=> '[', '〙'=> ']', '〚'=> '[', '〛'=> ']', '﹝'=> '[', '﹞'=> ']', '︹'=> '[', '︺'=> ']', '﹇'=> '[', '﹈'=> ']', '︐'=> ',', '︑'=> ',', '︒'=> '.', '︓'=> ':', '︔'=> ';', '︕'=> '!', '︖'=> '?', '︙'=> '...', '︰'=> '..', '︵'=> '(', '︶'=> ')', '﹙'=> '(', '﹚'=> ')', '︷'=> '{', '︸'=> '}', '﹛'=> '{', '﹜'=> '}', '︽'=> '<<', '︾'=> '>>', '︿'=> '<', '﹀'=> '>', '×'=> ' *', '÷'=> '/', '≪'=> '<<', '≫'=> '>>', '⦅'=> '((', '⦆'=> '))', '〇'=> '0', '′'=> '\'', '〝'=> '"', '〞' => '"', '«'=> '<<', '»'=> '>>', '‘'=> "'", '’'=> "'", '‚'=> ',', '‛'=> "'", '“'=> '"', '”' => '"', '„'=> '"', '‟' => '"', '‹'=> '<', '›'=> '>', '․'=> '.', '‥'=> '..', '…'=> '...', '″'=> '"', '‴' => '\\\', '‶' => '``', '‷' => '```', '‼' => '!!', '⁇' => '??', '⁈' => '?!', '⁉' => '!?', '⁗' => '````', '⩴' => '::=', '⩵' => '==', '⩶' => '===', '﹔' => ';', '﹕' => ':', '﹖' => '?', '﹗' => '!', '﹍' => '_', '﹎' => '_', '﹏' => '_', '﹐' => ',', '﹑' => ',', '﹒' => '.', '﹟' => '#', '﹠' => '&', '﹡' => '*', '﹢' => '+', '﹣' => '-', '﹤' => '<', '﹥' => '>', '﹦' => '=', '﹨' => '\', '﹩' => '$', '﹪' => '%', '﹫' => '@', '！' => '!', '＂' => '"', '＃'=> '#', '＄'=> '$', '％'=> '%', '＆'=> '&', '＇'=> '\'', '（'=> '(', '）'=> ')', '＊'=> ' *', '＋'=> '+', '，'=> ',', '－'=> '-', '．'=> '.', '／'=> '/', '：'=> ':', '；'=> ';', '＜'=> '<', '＝'=> '=', '＞'=> '>', '？'=> '?', '＠'=> '@', '｛'=> '{', '｜'=> '|', '｝'=> '}', '～'=> '~', '｟'=> '((', '｠'=> '))', '￢'=> '!', '￣'=> '-', '￤'=> '|', '￭'=> '#',],]


Joomla CMS: Référence du fichier ascii_language_max_key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier ascii_language_max_key.php

Variables

return ['uz'=> 0, 'tk'=> 1, 'th'=> 0, 'ps'=> 0, 'or'=> 0, 'mn'=> 0, 'ko'=> 0, 'ky'=> 0, 'hy'=> 1, 'bn'=> 5, 'be'=> 0, 'am'=> 0, 'ja'=> 0, 'zh'=> 0, 'nl'=> 1, 'it'=> 1, 'mk'=> 1, 'pt'=> 1, 'el__greeklish'=> 2, 'el'=> 2, 'hi'=> 2, 'sv'=> 1, 'tr'=> 1, 'bg'=> 2, 'hu'=> 1, 'my'=> 5, 'hr'=> 2, 'fi'=> 1, 'ka'=> 1, 'ru'=> 1, 'ru__passport_2013'=> 1, 'ru__gost_2000_b'=> 1, 'uk'=> 1, 'kk'=> 1, 'cs'=> 1, 'da'=> 1, 'pl'=> 1, 'ro'=> 1, 'eo'=> 1, 'et'=> 1, 'lv'=> 1, 'lt'=> 1, 'no'=> 1, 'vi'=> 1, 'ar'=> 1, 'fa'=> 1, 'sr'=> 1, 'sr__cyr'=> 1, 'sr__lat'=> 1, 'az'=> 1, 'sk'=> 1, 'fr'=> 1, 'fr_at'=> 1, 'fr_ch'=> 1, 'de'=> 1, 'de_at'=> 1, 'de_ch'=> 1, 'en'=> 0, 'latin'=> 3, ' '=> 1, 'msword'=> 1,]

Documentation des variables

◆ return

return[ 'uz'=> 0, 'tk'=> 1, 'th'=> 0, 'ps'=> 0, 'or'=> 0, 'mn'=> 0, 'ko'=> 0, 'ky'=> 0, 'hy'=> 1, 'bn'=> 5, 'be'=> 0, 'am'=> 0, 'ja'=> 0, 'zh'=> 0, 'nl'=> 1, 'it'=> 1, 'mk'=> 1, 'pt'=> 1, 'el__greeklish'=> 2, 'el'=> 2, 'hi'=> 2, 'sv'=> 1, 'tr'=> 1, 'bg'=> 2, 'hu'=> 1, 'my'=> 5, 'hr'=> 2, 'fi'=> 1, 'ka'=> 1, 'ru'=> 1, 'ru__passport_2013'=> 1, 'ru__gost_2000_b'=> 1, 'uk'=> 1, 'kk'=> 1, 'cs'=> 1, 'da'=> 1, 'pl'=> 1, 'ro'=> 1, 'eo'=> 1, 'et'=> 1, 'lv'=> 1, 'lt'=> 1, 'no'=> 1, 'vi'=> 1, 'ar'=> 1, 'fa'=> 1, 'sr'=> 1, 'sr__cyr'=> 1, 'sr__lat'=> 1, 'az'=> 1, 'sk'=> 1, 'fr'=> 1, 'fr_at'=> 1, 'fr_ch'=> 1, 'de'=> 1, 'de_at'=> 1, 'de_ch'=> 1, 'en'=> 0, 'latin'=> 3, ' '=> 1, 'msword'=> 1,]


Joomla CMS: Référence du fichier ascii_ord.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier ascii_ord.php

Variables

return [''=> 0, "\0"=> 0, "\1"=> 1, "\2"=> 2, "\3"=> 3, "\4"=> 4, "\5"=> 5, "\6"=> 6, "\7"=> 7, "\8"=> 8, "\9"=> 9, "\A"=> 10, "\B"=> 11, "\C"=> 12, "\D"=> 13, "\E"=> 14, "\F"=> 15, "\0"=> 16, "\1"=> 17, "\2"=> 18, "\3"=> 19, "\4"=> 20, "\5"=> 21, "\6"=> 22, "\7"=> 23, "\8"=> 24, "\9"=> 25, "\A"=> 26, "\B"=> 27, "\C"=> 28, "\D"=> 29, "\E"=> 30, "\F"=> 31, "\0"=> 32, "\1"=> 33, "\2"=> 34, "\3"=> 35, "\4"=> 36, "\5"=> 37, "\6"=> 38, "\7"=> 39, "\8"=> 40, "\9"=> 41, "\A"=> 42, "\B"=> 43, "\C"=> 44, "\D"=> 45, "\E"=> 46, "\F"=> 47, "\0"=> 48, "\1"=> 49, "\2"=> 50, "\3"=> 51, "\4"=> 52, "\5"=> 53, "\6"=> 54, "\7"=> 55, "\8"=> 56, "\9"=> 57, "\A"=> 58, "\B"=> 59, "\C"=> 60, "\D"=> 61, "\E"=> 62, "\F"=> 63, "\0"=> 64, "\1"=> 65, "\2"=> 66, "\3"=> 67, "\4"=> 68, "\5"=> 69, "\6"=> 70, "\7"=> 71, "\8"=> 72, "\9"=> 73, "\A"=> 74, "\B"=> 75, "\C"=> 76, "\D"=> 77, "\E"=> 78, "\F"=> 79, "\0"=> 80, "\1"=> 81, "\2"=> 82, "\3"=> 83, "\4"=> 84, "\5"=> 85, "\6"=> 86, "\7"=> 87, "\8"=> 88, "\9"=> 89, "\A"=> 90, "\B"=> 91, "\C"=> 92, "\D"=> 93, "\E"=> 94, "\F"=> 95, "\0"=> 96, "\1"=> 97, "\2"=> 98, "\3"=> 99, "\4"=> 100, "\5"=> 101, "\6"=> 102, "\7"=> 103, "\8"=> 104, "\9"=> 105, "\A"=> 106, "\B"=> 107, "\C"=> 108, "\D"=> 109, "\E"=> 110, "\F"=> 111, "\0"=> 112, "\1"=> 113, "\2"=> 114, "\3"=> 115, "\4"=> 116, "\5"=> 117, "\6"=> 118, "\7"=> 119, "\8"=> 120, "\9"=> 121, "\A"=> 122, "\B"=> 123, "\C"=> 124, "\D"=> 125, "\E"=> 126, "\F"=> 127, "\0"=> 128, "\1"=> 129, "\2"=> 130, "\3"=> 131, "\4"=> 132, "\5"=> 133, "\6"=> 134, "\7"=> 135, "\8"=> 136, "\9"=> 137, "\A"=> 138, "\B"=> 139, "\C"=> 140, "\D"=> 141, "\E"=> 142, "\F"=> 143, "\0"=> 144, "\1"=> 145, "\2"=> 146, "\3"=> 147, "\4"=> 148, "\5"=> 149, "\6"=> 150, "\7"=> 151, "\8"=> 152, "\9"=> 153, "\A"=> 154, "\B"=> 155, "\C"=> 156, "\D"=> 157, "\E"=> 158, "\F"=> 159, "\0"=> 160, "\1"=> 161, "\2"=> 162, "\3"=> 163, "\4"=> 164, "\5"=> 165, "\6"=> 166, "\7"=> 167, "\8"=> 168, "\9"=> 169, "\A"=> 170, "\B"=> 171, "\C"=> 172, "\D"=> 173, "\E"=> 174, "\F"=> 175, "\0"=> 176, "\1"=> 177, "\2"=> 178, "\3"=> 179, "\4"=> 180, "\5"=> 181, "\6"=> 182, "\7"=> 183, "\8"=> 184, "\9"=> 185, "\A"=> 186, "\B"=> 187, "\C"=> 188, "\D"=> 189, "\E"=> 190, "\F"=> 191, "\0"=> 192, "\1"=> 193, "\2"=> 194, "\3"=> 195, "\4"=> 196, "\5"=> 197, "\6"=> 198, "\7"=> 199, "\8"=> 200, "\9"=> 201, "\A"=> 202, "\B"=> 203, "\C"=> 204, "\D"=> 205, "\E"=> 206, "\F"=> 207, "\0"=> 208, "\1"=> 209, "\2"=> 210, "\3"=> 211, "\4"=> 212, "\5"=> 213, "\6"=> 214, "\7"=> 215, "\8"=> 216, "\9"=> 217, "\A"=> 218, "\B"=> 219, "\C"=> 220, "\D"=> 221, "\E"=> 222, "\F"=> 223, "\0"=> 224, "\1"=> 225, "\2"=> 226, "\3"=> 227, "\4"=> 228, "\5"=> 229, "\6"=> 230, "\7"=> 231, "\8"=> 232, "\9"=> 233, "\A"=> 234, "\B"=> 235, "\C"=> 236, "\D"=> 237, "\E"=> 238, "\F"=> 239, "\0"=> 240, "\1"=> 241, "\2"=> 242, "\3"=> 243, "\4"=> 244, "\5"=> 245, "\6"=> 246, "\7"=> 247, "\8"=> 248, "\9"=> 249, "\A"=> 250, "\B"=> 251, "\C"=> 252, "\D"=> 253, "\E"=> 254, "\F"=> 255]

Documentation des variables

◆ return

return[''=> 0, "\00"=> 0, "\01"=> 1, "\02"=> 2, "\03"=> 3, "\04"=> 4, "\05"=> 5, "\06"=> 6, "\07"=> 7, "\08"=> 8, "\09"=> 9, "\0A"=> 10, "\0B"=> 11, "\0C"=> 12, "\0D"=> 13, "\0E"=> 14, "\0F"=> 15, "\10"=> 16, "\11"=> 17, "\12"=> 18, "\13"=> 19, "\14"=> 20, "\15"=> 21, "\16"=> 22, "\17"=> 23, "\18"=> 24, "\19"=> 25, "\1A"=> 26, "\1B"=> 27, "\1C"=> 28, "\1D"=> 29, "\1E"=> 30, "\1F"=> 31, "\20"=> 32, "\21"=> 33, "\22"=> 34, "\23"=> 35, "\24"=> 36, "\25"=> 37, "\26"=> 38, "\27"=> 39, "\28"=> 40, "\29"=> 41, "\2A"=> 42, "\2B"=> 43, "\2C"=> 44, "\2D"=> 45, "\2E"=> 46, "\2F"=> 47, "\30"=> 48, "\31"=> 49, "\32"=> 50, "\33"=> 51, "\34"=> 52, "\35"=> 53, "\36"=> 54, "\37"=> 55, "\38"=> 56, "\39"=> 57, "\3A"=> 58, "\3B"=> 59, "\3C"=> 60, "\3D"=> 61, "\3E"=> 62, "\3F"=> 63, "\40"=> 64, "\41"=> 65, "\42"=> 66, "\43"=> 67, "\44"=> 68, "\45"=> 69, "\46"=> 70, "\47"=> 71, "\48"=> 72, "\49"=> 73, "\4A"=> 74, "\4B"=> 75, "\4C"=> 76, "\4D"=> 77, "\4E"=> 78, "\4F"=> 79, "\50"=> 80, "\51"=> 81, "\52"=> 82, "\53"=> 83, "\54"=> 84, "\55"=> 85, "\56"=> 86, "\57"=> 87, "\58"=> 88, "\59"=> 89, "\5A"=> 90, "\5B"=> 91, "\5C"=> 92, "\5D"=> 93, "\5E"=> 94, "\5F"=> 95, "\60"=> 96, "\61"=> 97, "\62"=> 98, "\63"=> 99, "\64"=> 100, "\65"=> 101, "\66"=> 102, "\67"=> 103, "\68"=> 104, "\69"=> 105, "\6A"=> 106, "\6B"=> 107, "\6C"=> 108, "\6D"=> 109, "\6E"=> 110, "\6F"=> 111, "\70"=> 112, "\71"=> 113, "\72"=> 114, "\73"=> 115, "\74"=> 116, "\75"=> 117, "\76"=> 118, "\77"=> 119, "\78"=> 120, "\79"=> 121, "\7A"=> 122, "\7B"=> 123, "\7C"=> 124, "\7D"=> 125, "\7E"=> 126, "\7F"=> 127, "\80"=> 128, "\81"=> 129, "\82"=> 130, "\83"=> 131, "\84"=> 132, "\85"=> 133, "\86"=> 134, "\87"=> 135, "\88"=> 136, "\89"=> 137, "\8A"=> 138, "\8B"=> 139, "\8C"=> 140, "\8D"=> 141, "\8E"=> 142, "\8F"=> 143, "\90"=> 144, "\91"=> 145, "\92"=> 146, "\93"=> 147, "\94"=> 148, "\95"=> 149, "\96"=> 150, "\97"=> 151, "\98"=> 152, "\99"=> 153, "\9A"=> 154, "\9B"=> 155, "\9C"=> 156, "\9D"=> 157, "\9E"=> 158, "\9F"=> 159, "\A0"=> 160, "\A1"=> 161, "\A2"=> 162, "\A3"=> 163, "\A4"=> 164, "\A5"=> 165, "\A6"=> 166, "\A7"=> 167, "\A8"=> 168, "\A9"=> 169, "\AA"=> 170, "\AB"=> 171, "\AC"=> 172, "\AD"=> 173, "\AE"=> 174, "\AF"=> 175, "\B0"=> 176, "\B1"=> 177, "\B2"=> 178, "\B3"=> 179, "\B4"=> 180, "\B5"=> 181, "\B6"=> 182, "\B7"=> 183, "\B8"=> 184, "\B9"=> 185, "\BA"=> 186, "\BB"=> 187, "\BC"=> 188, "\BD"=> 189, "\BE"=> 190, "\BF"=> 191, "\C0"=> 192, "\C1"=> 193, "\C2"=> 194, "\C3"=> 195, "\C4"=> 196, "\C5"=> 197, "\C6"=> 198, "\C7"=> 199, "\C8"=> 200, "\C9"=> 201, "\CA"=> 202, "\CB"=> 203, "\CC"=> 204, "\CD"=> 205, "\CE"=> 206, "\CF"=> 207, "\D0"=> 208, "\D1"=> 209, "\D2"=> 210, "\D3"=> 211, "\D4"=> 212, "\D5"=> 213, "\D6"=> 214, "\D7"=> 215, "\D8"=> 216, "\D9"=> 217, "\DA"=> 218, "\DB"=> 219, "\DC"=> 220, "\DD"=> 221, "\DE"=> 222, "\DF"=> 223, "\E0"=> 224, "\E1"=> 225, "\E2"=> 226, "\E3"=> 227, "\E4"=> 228, "\E5"=> 229, "\E6"=> 230, "\E7"=> 231, "\E8"=> 232, "\E9"=> 233, "\EA"=> 234, "\EB"=> 235, "\EC"=> 236, "\ED"=> 237, "\EE"=> 238, "\EF"=> 239, "\F0"=> 240, "\F1"=> 241, "\F2"=> 242, "\F3"=> 243, "\F4"=> 244, "\F5"=> 245, "\F6"=> 246, "\F7"=> 247, "\F8"=> 248, "\F9"=> 249, "\FA"=> 250, "\FB"=> 251, "\FC"=> 252, "\FD"=> 253, "\FE"=> 254, "\FF"=> 255]


Joomla CMS: Référence du fichier AsciiSlugger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Slugger
Structures de données | Espaces de nommage
Référence du fichier AsciiSlugger.php

Structures de données

class AsciiSlugger

Espaces de nommage

Symfony\Component\String\Slugger


Joomla CMS: Référence du fichier AsCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Attribute
Structures de données | Espaces de nommage
Référence du fichier AsCommand.php

Structures de données

class AsCommand

Espaces de nommage

Symfony\Component\Console\Attribute


Joomla CMS: Référence du fichier ASN1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier Crypt/DSA/Formats/Signature/ASN1.php

Structures de données

class ASN1

Espaces de nommage

Common
phpseclib3\Crypt\DSA\Formats\Signature


Joomla CMS: Référence du fichier ASN1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier Crypt/EC/Formats/Signature/ASN1.php

Structures de données

class ASN1

Espaces de nommage

Common
phpseclib3\Crypt\EC\Formats\Signature


Joomla CMS: Référence du fichier ASN1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
Structures de données | Espaces de nommage
Référence du fichier File/ASN1.php

Structures de données

class ASN1

Espaces de nommage

ASN1
phpseclib3\File


Joomla CMS: Référence du fichier ASNObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier ASNObject.php

Structures de données

class ASNObject

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier Assert.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier beberlei/assert/lib/Assert/Assert.php

Structures de données

class Assert

Espaces de nommage

Assert


Joomla CMS: Référence du fichier Assert.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
  • assert
  • src
Structures de données | Espaces de nommage
Référence du fichier webmozart/assert/src/Assert.php

Structures de données

class Assert

Espaces de nommage

Webmozart\Assert


Joomla CMS: Référence du fichier Assertable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier Assertable.php

Structures de données

interface Assertable

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier Assertion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier Assertion.php

Structures de données

class Assertion

Espaces de nommage

Assert


Joomla CMS: Référence du fichier AssertionChain.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier AssertionChain.php

Structures de données

class AssertionChain

Espaces de nommage

Assert


Joomla CMS: Référence du fichier AssertionFailedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier AssertionFailedException.php

Structures de données

interface AssertionFailedException

Espaces de nommage

Assert


Joomla CMS: Référence du fichier Asset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Asset.php

Structures de données

class Asset

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier AssetProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier AssetProvider.php

Structures de données

interface AssetProvider

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier AssocField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier AssocField.php

Structures de données

class AssocField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Field


Joomla CMS: Référence du fichier AssociationController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier AssociationController.php

Structures de données

class AssociationController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Controller


Joomla CMS: Référence du fichier AssociationExtensionHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Association
Structures de données | Espaces de nommage
Référence du fichier AssociationExtensionHelper.php

Structures de données

class AssociationExtensionHelper

Espaces de nommage

Joomla\CMS\Association


Joomla CMS: Référence du fichier AssociationExtensionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Association
Structures de données | Espaces de nommage
Référence du fichier AssociationExtensionInterface.php

Structures de données

interface AssociationExtensionInterface

Espaces de nommage

Joomla\CMS\Association


Joomla CMS: Référence du fichier AssociationField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier AssociationField.php

Structures de données

class AssociationField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Field\Modal


Joomla CMS: Référence du fichier AssociationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/Helper/AssociationHelper.php

Structures de données

class AssociationHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Helper


Joomla CMS: Référence du fichier AssociationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_content/src/Helper/AssociationHelper.php

Structures de données

class AssociationHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Helper


Joomla CMS: Référence du fichier AssociationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/src/Helper/AssociationHelper.php

Structures de données

class AssociationHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Helper


Joomla CMS: Référence du fichier AssociationModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier AssociationModel.php

Structures de données

class AssociationModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Model


Joomla CMS: Référence du fichier Associations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier Associations.php

Structures de données

class Associations

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier associations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier content/associations.php

Espaces de nommage

Joomla\Site

Variables

$items = $displayData
if(!empty( $items))( $items as $id=> $item)(is_array($item) &&isset($item['link'])) elseif(isset($item->link)) endif
endforeach

Documentation des variables

◆ $items

$items = $displayData

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier associations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage | Variables
Référence du fichier content/info_block/associations.php

Espaces de nommage

Joomla\Site

Variables

if (!empty( $displayData[ 'item']->associations))
else __pad3__
endif
endforeach

Documentation des variables

◆ __pad3__

else __pad3__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($displayData['item']->associations))


Joomla CMS: Référence du fichier associations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier edit/associations.php

Espaces de nommage

Joomla\Site

Variables

$form = $displayData->getForm()
$options
$doc = Factory::getApplication()->getDocument()
$wa = $doc->getWebAssetManager()

Documentation des variables

◆ $doc

$doc = Factory::getApplication()->getDocument()

◆ $form

$form = $displayData->getForm()

◆ $options

$options
Valeur initiale :
= array(
'formControl' => $form->getFormControl(),
'hidden' => (int) ($form->getValue('language', null, '*') === '*'),
)
$form
$form
Definition: edit/associations.php:16
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

◆ $wa

$wa = $doc->getWebAssetManager()


Joomla CMS: Référence du fichier AssociationsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier AssociationsController.php

Structures de données

class AssociationsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Controller


Joomla CMS: Référence du fichier AssociationServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Association
Structures de données | Espaces de nommage
Référence du fichier AssociationServiceInterface.php

Structures de données

interface AssociationServiceInterface

Espaces de nommage

Joomla\CMS\Association


Joomla CMS: Référence du fichier AssociationServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Association
Espaces de nommage | Fonctions | Variables
Référence du fichier AssociationServiceTrait.php

Espaces de nommage

Joomla\CMS\Association

Fonctions

getAssociationsExtension ()
setAssociationExtension (AssociationExtensionInterface $associationExtension)

Variables

trait AssociationServiceTrait


Joomla CMS: Référence du fichier AssociationsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_associations/src/Helper/AssociationsHelper.php

Structures de données

class AssociationsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Helper


Joomla CMS: Référence du fichier AssociationsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/Helper/AssociationsHelper.php

Structures de données

class AssociationsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Helper


Joomla CMS: Référence du fichier AssociationsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_content/src/Helper/AssociationsHelper.php

Structures de données

class AssociationsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Helper


Joomla CMS: Référence du fichier AssociationsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_menus/src/Helper/AssociationsHelper.php

Structures de données

class AssociationsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Helper


Joomla CMS: Référence du fichier AssociationsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/src/Helper/AssociationsHelper.php

Structures de données

class AssociationsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Helper


Joomla CMS: Référence du fichier AssociationsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier AssociationsModel.php

Structures de données

class AssociationsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Model


Joomla CMS: Référence du fichier AsymmetricKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier AsymmetricKey.php

Structures de données

class AsymmetricKey

Espaces de nommage

AsymmetricKey
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier AtomParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
Structures de données | Espaces de nommage
Référence du fichier AtomParser.php

Structures de données

class AtomParser

Espaces de nommage

Joomla\CMS\Feed\Parser


Joomla CMS: Référence du fichier AtomRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Feed
Structures de données | Espaces de nommage
Référence du fichier AtomRenderer.php

Structures de données

class AtomRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Feed


Joomla CMS: Référence du fichier AttestationObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AttestationObject.php

Structures de données

class AttestationObject

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AttestationObjectLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AttestationObjectLoader.php

Structures de données

class AttestationObjectLoader

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AttestationStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AttestationStatement.php

Structures de données

class AttestationStatement

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AttestationStatementSupport.php

Structures de données

interface AttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AttestationStatementSupportManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier AttestationStatementSupportManager.php

Structures de données

class AttestationStatementSupportManager

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier AttestedCredentialData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AttestedCredentialData.php

Structures de données

class AttestedCredentialData

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier Attribute.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attribute.php

Structures de données

class Attribute

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Attribute.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Structures de données
Référence du fichier symfony/polyfill-php80/Resources/stubs/Attribute.php

Structures de données

class Attribute


Joomla CMS: Référence du fichier AttributeInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Structures de données | Espaces de nommage
Référence du fichier AttributeInterface.php

Structures de données

interface AttributeInterface

Espaces de nommage

enshrined\svgSanitize\data
enshrined


Joomla CMS: Référence du fichier Attributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • CSR
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/X509/CSR/Attributes.php

Structures de données

class Attributes

Espaces de nommage

FG\X509\CSR


Joomla CMS: Référence du fichier Attributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attributes.php

Structures de données

class Attributes

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AttributeType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AttributeType.php

Structures de données

class AttributeType

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AttributeTypeAndValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Composite
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/ASN1/Composite/AttributeTypeAndValue.php

Structures de données

class AttributeTypeAndValue

Espaces de nommage

FG\ASN1\Composite


Joomla CMS: Référence du fichier AttributeTypeAndValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AttributeTypeAndValue.php

Structures de données

class AttributeTypeAndValue

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AttributeValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AttributeValue.php

Structures de données

class AttributeValue

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Authentication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Authentication/Authentication.php

Structures de données

class Authentication

Espaces de nommage

Joomla\CMS\Authentication


Joomla CMS: Référence du fichier Authentication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Authentication.php

Structures de données

class Authentication

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Authentication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/authentication/src/Authentication.php

Structures de données

class Authentication

Espaces de nommage

Joomla\Authentication


Joomla CMS: Référence du fichier Authentication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
Structures de données | Espaces de nommage
Référence du fichier plugins/system/webauthn/src/Authentication.php

Structures de données

class Authentication

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn


Joomla CMS: Référence du fichier AuthenticationExtension.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier AuthenticationExtension.php

Structures de données

class AuthenticationExtension

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier AuthenticationExtensionsClientInputs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier AuthenticationExtensionsClientInputs.php

Structures de données

class AuthenticationExtensionsClientInputs

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier AuthenticationExtensionsClientOutputs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier AuthenticationExtensionsClientOutputs.php

Structures de données

class AuthenticationExtensionsClientOutputs

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier AuthenticationExtensionsClientOutputsLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier AuthenticationExtensionsClientOutputsLoader.php

Structures de données

class AuthenticationExtensionsClientOutputsLoader

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier AuthenticationFailed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
  • Exception
Structures de données | Espaces de nommage
Référence du fichier AuthenticationFailed.php

Structures de données

class AuthenticationFailed

Espaces de nommage

Joomla\CMS\Access\Exception


Joomla CMS: Référence du fichier AuthenticationFailedExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier AuthenticationFailedExceptionHandler.php

Structures de données

class AuthenticationFailedExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier AuthenticationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier AuthenticationHelper.php

Structures de données

class AuthenticationHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier AuthenticationResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
Structures de données | Espaces de nommage
Référence du fichier AuthenticationResponse.php

Structures de données

class AuthenticationResponse

Espaces de nommage

Joomla\CMS\Authentication


Joomla CMS: Référence du fichier AuthenticationStrategyInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticationStrategyInterface.php

Structures de données

interface AuthenticationStrategyInterface

Espaces de nommage

Joomla\Authentication


Joomla CMS: Référence du fichier AuthenticatorAssertionResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorAssertionResponse.php

Structures de données

class AuthenticatorAssertionResponse

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorAssertionResponseValidator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorAssertionResponseValidator.php

Structures de données

class AuthenticatorAssertionResponseValidator

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorAttestationResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorAttestationResponse.php

Structures de données

class AuthenticatorAttestationResponse

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorAttestationResponseValidator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorAttestationResponseValidator.php

Structures de données

class AuthenticatorAttestationResponseValidator

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorData.php

Structures de données

class AuthenticatorData

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorResponse.php

Structures de données

class AuthenticatorResponse

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorSelectionCriteria.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorSelectionCriteria.php

Structures de données

class AuthenticatorSelectionCriteria

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier AuthenticatorStatus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier AuthenticatorStatus.php

Structures de données

class AuthenticatorStatus

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier author.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage | Variables
Référence du fichier author.php

Espaces de nommage

Joomla\Site

Variables

$author = ($displayData['item']->created_by_alias ?: $displayData['item']->author)
else __pad4__
endif

Documentation des variables

◆ $author

else $author = ($displayData['item']->created_by_alias ?: $displayData['item']->author)

◆ __pad4__

else __pad4__

◆ endif

endif


Joomla CMS: Référence du fichier AuthorField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier AuthorField.php

Structures de données

class AuthorField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier AuthorityInfoAccessSyntax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AuthorityInfoAccessSyntax.php

Structures de données

class AuthorityInfoAccessSyntax

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier AuthorityKeyIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier AuthorityKeyIdentifier.php

Structures de données

class AuthorityKeyIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier autoload-fast.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Référence du fichier autoload-fast.php


Joomla CMS: Référence du fichier autoload-pedantic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Variables
Référence du fichier autoload-pedantic.php

Variables

const DO_PEDANTIC_TEST true

Documentation des variables

◆ DO_PEDANTIC_TEST

const DO_PEDANTIC_TEST true


Joomla CMS: Référence du fichier autoload-php7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Référence du fichier autoload-php7.php


Joomla CMS: Référence du fichier autoload-phpunit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Variables
Référence du fichier autoload-phpunit.php

Variables

if (PHP_VERSION_ID >=50300)

Documentation des variables

◆ if

if(PHP_VERSION_ID >=50300)


Joomla CMS: Référence du fichier autoload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
Variables
Référence du fichier autoload.php

Variables

if (PHP_VERSION_ID< 50600)

Documentation des variables

◆ if

if(PHP_VERSION_ID< 50600)


Joomla CMS: Référence du fichier autoload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
Référence du fichier google/recaptcha/src/autoload.php


Joomla CMS: Référence du fichier autoload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Référence du fichier laminas/laminas-zendframework-bridge/src/autoload.php


Joomla CMS: Référence du fichier autoload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Variables
Référence du fichier paragonie/sodium_compat/autoload.php

Variables

if(PHP_VERSION_ID< 70000) | else
if(PHP_VERSION_ID< 70200||!extension_loaded('sodium')) | elseif (!function_exists( 'sodium_crypto_stream_xchacha20_xor'))

Documentation des variables

◆ else

if (!class_exists( 'SodiumException', false)) if (PHP_VERSION_ID >=50300) else
Valeur initiale :
{
require_once dirname(__FILE__) . '/autoload-php7.php'
dirname

Sodium_Compat autoloader.

Paramètres
string $class Class name to be autoloaded.
Renvoie
bool Stop autoloading?

◆ elseif

if (PHP_VERSION_ID< 70200||!extension_loaded( 'sodium')) elseif(!function_exists('sodium_crypto_stream_xchacha20_xor'))


Joomla CMS: Référence du fichier autoload_classmap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Variables
Référence du fichier autoload_classmap.php

Variables

$vendorDir = dirname(__DIR__)
$baseDir = dirname(dirname($vendorDir))

Documentation des variables

◆ $baseDir

$baseDir = dirname(dirname($vendorDir))

Référencé par FilesystemHandler\__construct(), HtmlDocument\_fetchTemplate(), JNamespacePsr4Map\getNamespaces(), et File\upload().

◆ $vendorDir

$vendorDir = dirname(__DIR__)

Référencé par InstalledVersions\getInstalled().


Joomla CMS: Référence du fichier autoload_files.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Variables
Référence du fichier autoload_files.php

Variables

$vendorDir = dirname(__DIR__)
$baseDir = dirname(dirname($vendorDir))

Documentation des variables

◆ $baseDir

$baseDir = dirname(dirname($vendorDir))

◆ $vendorDir

$vendorDir = dirname(__DIR__)


Joomla CMS: Référence du fichier autoload_namespaces.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Variables
Référence du fichier autoload_namespaces.php

Variables

$vendorDir = dirname(__DIR__)
$baseDir = dirname(dirname($vendorDir))

Documentation des variables

◆ $baseDir

$baseDir = dirname(dirname($vendorDir))

◆ $vendorDir

$vendorDir = dirname(__DIR__)


Joomla CMS: Référence du fichier autoload_psr4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • cache
Variables
Référence du fichier administrator/cache/autoload_psr4.php

Variables

return [ 'Joomla\\Component\\Actionlogs\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_actionlogs/src'], 'Joomla\\Component\\Admin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_admin/src'], 'Joomla\\Component\\Associations\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_associations/src'], 'Joomla\\Component\\Banners\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_banners/src'], 'Joomla\\Component\\Banners\\Api\\'=> [JPATH_API . '/components/com_banners/src'], 'Joomla\\Component\\Banners\\Site\\'=> [JPATH_SITE . '/components/com_banners/src'], 'Joomla\\Component\\Cache\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_cache/src'], 'Joomla\\Component\\Categories\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_categories/src'], 'Joomla\\Component\\Categories\\Api\\'=> [JPATH_API . '/components/com_categories/src'], 'Joomla\\Component\\Checkin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_checkin/src'], 'Joomla\\Component\\Config\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_config/src'], 'Joomla\\Component\\Config\\Api\\'=> [JPATH_API . '/components/com_config/src'], 'Joomla\\Component\\Config\\Site\\'=> [JPATH_SITE . '/components/com_config/src'], 'Joomla\\Component\\Contact\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_contact/src'], 'Joomla\\Component\\Contact\\Api\\'=> [JPATH_API . '/components/com_contact/src'], 'Joomla\\Component\\Contact\\Site\\'=> [JPATH_SITE . '/components/com_contact/src'], 'Joomla\\Component\\Content\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_content/src'], 'Joomla\\Component\\Content\\Api\\'=> [JPATH_API . '/components/com_content/src'], 'Joomla\\Component\\Content\\Site\\'=> [JPATH_SITE . '/components/com_content/src'], 'Joomla\\Component\\Contenthistory\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_contenthistory/src'], 'Joomla\\Component\\Contenthistory\\Api\\'=> [JPATH_API . '/components/com_contenthistory/src'], 'Joomla\\Component\\Contenthistory\\Site\\'=> [JPATH_SITE . '/components/com_contenthistory/src'], 'Joomla\\Component\\Cpanel\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_cpanel/src'], 'Joomla\\Component\\Fields\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_fields/src'], 'Joomla\\Component\\Fields\\Api\\'=> [JPATH_API . '/components/com_fields/src'], 'Joomla\\Component\\Fields\\Site\\'=> [JPATH_SITE . '/components/com_fields/src'], 'Joomla\\Component\\Finder\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_finder/src'], 'Joomla\\Component\\Finder\\Site\\'=> [JPATH_SITE . '/components/com_finder/src'], 'Joomla\\Component\\Installer\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_installer/src'], 'Joomla\\Component\\Installer\\Api\\'=> [JPATH_API . '/components/com_installer/src'], 'Joomla\\Component\\Joomlaupdate\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_joomlaupdate/src'], 'Joomla\\Component\\Languages\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_languages/src'], 'Joomla\\Component\\Languages\\Api\\'=> [JPATH_API . '/components/com_languages/src'], 'Joomla\\Component\\Login\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_login/src'], 'Joomla\\Component\\Mails\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_mails/src'], 'Joomla\\Component\\Media\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_media/src'], 'Joomla\\Component\\Media\\Api\\'=> [JPATH_API . '/components/com_media/src'], 'Joomla\\Component\\Media\\Site\\'=> [JPATH_SITE . '/components/com_media/src'], 'Joomla\\Component\\Menus\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_menus/src'], 'Joomla\\Component\\Menus\\Api\\'=> [JPATH_API . '/components/com_menus/src'], 'Joomla\\Component\\Menus\\Site\\'=> [JPATH_SITE . '/components/com_menus/src'], 'Joomla\\Component\\Messages\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_messages/src'], 'Joomla\\Component\\Messages\\Api\\'=> [JPATH_API . '/components/com_messages/src'], 'Joomla\\Component\\Modules\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_modules/src'], 'Joomla\\Component\\Modules\\Api\\'=> [JPATH_API . '/components/com_modules/src'], 'Joomla\\Component\\Modules\\Site\\'=> [JPATH_SITE . '/components/com_modules/src'], 'Joomla\\Component\\Newsfeeds\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Newsfeeds\\Api\\'=> [JPATH_API . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Newsfeeds\\Site\\'=> [JPATH_SITE . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Plugins\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_plugins/src'], 'Joomla\\Component\\Plugins\\Api\\'=> [JPATH_API . '/components/com_plugins/src'], 'Joomla\\Component\\Postinstall\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_postinstall/src'], 'Joomla\\Component\\Privacy\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_privacy/src'], 'Joomla\\Component\\Privacy\\Api\\'=> [JPATH_API . '/components/com_privacy/src'], 'Joomla\\Component\\Privacy\\Site\\'=> [JPATH_SITE . '/components/com_privacy/src'], 'Joomla\\Component\\Redirect\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_redirect/src'], 'Joomla\\Component\\Redirect\\Api\\'=> [JPATH_API . '/components/com_redirect/src'], 'Joomla\\Component\\Scheduler\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_scheduler/src'], 'Joomla\\Component\\Tags\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_tags/src'], 'Joomla\\Component\\Tags\\Api\\'=> [JPATH_API . '/components/com_tags/src'], 'Joomla\\Component\\Tags\\Site\\'=> [JPATH_SITE . '/components/com_tags/src'], 'Joomla\\Component\\Templates\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_templates/src'], 'Joomla\\Component\\Templates\\Api\\'=> [JPATH_API . '/components/com_templates/src'], 'Joomla\\Component\\Users\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_users/src'], 'Joomla\\Component\\Users\\Api\\'=> [JPATH_API . '/components/com_users/src'], 'Joomla\\Component\\Users\\Site\\'=> [JPATH_SITE . '/components/com_users/src'], 'Joomla\\Component\\Workflow\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_workflow/src'], 'Joomla\\Component\\Wrapper\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_wrapper/src'], 'Joomla\\Component\\Wrapper\\Site\\'=> [JPATH_SITE . '/components/com_wrapper/src'], 'Joomla\\Module\\ArticlesArchive\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_archive/src'], 'Joomla\\Module\\ArticlesCategories\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_categories/src'], 'Joomla\\Module\\ArticlesCategory\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_category/src'], 'Joomla\\Module\\ArticlesLatest\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_latest/src'], 'Joomla\\Module\\ArticlesNews\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_news/src'], 'Joomla\\Module\\ArticlesPopular\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_popular/src'], 'Joomla\\Module\\Banners\\Site\\'=> [JPATH_SITE . '/modules/mod_banners/src'], 'Joomla\\Module\\Breadcrumbs\\Site\\'=> [JPATH_SITE . '/modules/mod_breadcrumbs/src'], 'Joomla\\Module\\Feed\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_feed/src'], 'Joomla\\Module\\Feed\\Site\\'=> [JPATH_SITE . '/modules/mod_feed/src'], 'Joomla\\Module\\Finder\\Site\\'=> [JPATH_SITE . '/modules/mod_finder/src'], 'Joomla\\Module\\Footer\\Site\\'=> [JPATH_SITE . '/modules/mod_footer/src'], 'Joomla\\Module\\Languages\\Site\\'=> [JPATH_SITE . '/modules/mod_languages/src'], 'Joomla\\Module\\LatestActions\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_latestactions/src'], 'Joomla\\Module\\Latest\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_latest/src'], 'Joomla\\Module\\Logged\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_logged/src'], 'Joomla\\Module\\Login\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_login/src'], 'Joomla\\Module\\Login\\Site\\'=> [JPATH_SITE . '/modules/mod_login/src'], 'Joomla\\Module\\Loginsupport\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_loginsupport/src'], 'Joomla\\Module\\Menu\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_menu/src'], 'Joomla\\Module\\Menu\\Site\\'=> [JPATH_SITE . '/modules/mod_menu/src'], 'Joomla\\Module\\Popular\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_popular/src'], 'Joomla\\Module\\PrivacyDashboard\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_privacy_dashboard/src'], 'Joomla\\Module\\PrivacyStatus\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_privacy_status/src'], 'Joomla\\Module\\Quickicon\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_quickicon/src'], 'Joomla\\Module\\RandomImage\\Site\\'=> [JPATH_SITE . '/modules/mod_random_image/src'], 'Joomla\\Module\\RelatedItems\\Site\\'=> [JPATH_SITE . '/modules/mod_related_items/src'], 'Joomla\\Module\\Sampledata\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_sampledata/src'], 'Joomla\\Module\\StatsAdmin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_stats_admin/src'], 'Joomla\\Module\\Stats\\Site\\'=> [JPATH_SITE . '/modules/mod_stats/src'], 'Joomla\\Module\\Submenu\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_submenu/src'], 'Joomla\\Module\\Syndicate\\Site\\'=> [JPATH_SITE . '/modules/mod_syndicate/src'], 'Joomla\\Module\\TagsPopular\\Site\\'=> [JPATH_SITE . '/modules/mod_tags_popular/src'], 'Joomla\\Module\\TagsSimilar\\Site\\'=> [JPATH_SITE . '/modules/mod_tags_similar/src'], 'Joomla\\Module\\UsersLatest\\Site\\'=> [JPATH_SITE . '/modules/mod_users_latest/src'], 'Joomla\\Module\\Version\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_version/src'], 'Joomla\\Module\\Whosonline\\Site\\'=> [JPATH_SITE . '/modules/mod_whosonline/src'], 'Joomla\\Module\\Wrapper\\Site\\'=> [JPATH_SITE . '/modules/mod_wrapper/src'], 'Joomla\\Plugin\\Content\\ConfirmConsent\\'=> [JPATH_PLUGINS . '/content/confirmconsent/src'], 'Joomla\\Plugin\\Editors\\CodeMirror\\'=> [JPATH_PLUGINS . '/editors/codemirror/src'], 'Joomla\\Plugin\\Editors\\TinyMCE\\'=> [JPATH_PLUGINS . '/editors/tinymce/src'], 'Joomla\\Plugin\\Filesystem\\Local\\'=> [JPATH_PLUGINS . '/filesystem/local/src'], 'Joomla\\Plugin\\Quickicon\\Joomlaupdate\\'=> [JPATH_PLUGINS . '/quickicon/joomlaupdate/src'], 'Joomla\\Plugin\\System\\Debug\\'=> [JPATH_PLUGINS . '/system/debug/src'], 'Joomla\\Plugin\\System\\PrivacyConsent\\'=> [JPATH_PLUGINS . '/system/privacyconsent/src'], 'Joomla\\Plugin\\System\\Stats\\'=> [JPATH_PLUGINS . '/system/stats/src'], 'Joomla\\Plugin\\System\\Webauthn\\'=> [JPATH_PLUGINS . '/system/webauthn/src'], 'Joomla\\Plugin\\User\\Profile\\'=> [JPATH_PLUGINS . '/user/profile/src'], 'Joomla\\Plugin\\User\\Terms\\'=> [JPATH_PLUGINS . '/user/terms/src'], 'Joomla\\Plugin\\User\\Token\\'=> [JPATH_PLUGINS . '/user/token/src'],]

Documentation des variables

◆ return

return['Joomla\\Component\\Actionlogs\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_actionlogs/src'], 'Joomla\\Component\\Admin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_admin/src'], 'Joomla\\Component\\Associations\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_associations/src'], 'Joomla\\Component\\Banners\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_banners/src'], 'Joomla\\Component\\Banners\\Api\\'=> [JPATH_API . '/components/com_banners/src'], 'Joomla\\Component\\Banners\\Site\\'=> [JPATH_SITE . '/components/com_banners/src'], 'Joomla\\Component\\Cache\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_cache/src'], 'Joomla\\Component\\Categories\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_categories/src'], 'Joomla\\Component\\Categories\\Api\\'=> [JPATH_API . '/components/com_categories/src'], 'Joomla\\Component\\Checkin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_checkin/src'], 'Joomla\\Component\\Config\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_config/src'], 'Joomla\\Component\\Config\\Api\\'=> [JPATH_API . '/components/com_config/src'], 'Joomla\\Component\\Config\\Site\\'=> [JPATH_SITE . '/components/com_config/src'], 'Joomla\\Component\\Contact\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_contact/src'], 'Joomla\\Component\\Contact\\Api\\'=> [JPATH_API . '/components/com_contact/src'], 'Joomla\\Component\\Contact\\Site\\'=> [JPATH_SITE . '/components/com_contact/src'], 'Joomla\\Component\\Content\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_content/src'], 'Joomla\\Component\\Content\\Api\\'=> [JPATH_API . '/components/com_content/src'], 'Joomla\\Component\\Content\\Site\\'=> [JPATH_SITE . '/components/com_content/src'], 'Joomla\\Component\\Contenthistory\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_contenthistory/src'], 'Joomla\\Component\\Contenthistory\\Api\\'=> [JPATH_API . '/components/com_contenthistory/src'], 'Joomla\\Component\\Contenthistory\\Site\\'=> [JPATH_SITE . '/components/com_contenthistory/src'], 'Joomla\\Component\\Cpanel\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_cpanel/src'], 'Joomla\\Component\\Fields\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_fields/src'], 'Joomla\\Component\\Fields\\Api\\'=> [JPATH_API . '/components/com_fields/src'], 'Joomla\\Component\\Fields\\Site\\'=> [JPATH_SITE . '/components/com_fields/src'], 'Joomla\\Component\\Finder\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_finder/src'], 'Joomla\\Component\\Finder\\Site\\'=> [JPATH_SITE . '/components/com_finder/src'], 'Joomla\\Component\\Installer\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_installer/src'], 'Joomla\\Component\\Installer\\Api\\'=> [JPATH_API . '/components/com_installer/src'], 'Joomla\\Component\\Joomlaupdate\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_joomlaupdate/src'], 'Joomla\\Component\\Languages\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_languages/src'], 'Joomla\\Component\\Languages\\Api\\'=> [JPATH_API . '/components/com_languages/src'], 'Joomla\\Component\\Login\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_login/src'], 'Joomla\\Component\\Mails\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_mails/src'], 'Joomla\\Component\\Media\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_media/src'], 'Joomla\\Component\\Media\\Api\\'=> [JPATH_API . '/components/com_media/src'], 'Joomla\\Component\\Media\\Site\\'=> [JPATH_SITE . '/components/com_media/src'], 'Joomla\\Component\\Menus\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_menus/src'], 'Joomla\\Component\\Menus\\Api\\'=> [JPATH_API . '/components/com_menus/src'], 'Joomla\\Component\\Menus\\Site\\'=> [JPATH_SITE . '/components/com_menus/src'], 'Joomla\\Component\\Messages\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_messages/src'], 'Joomla\\Component\\Messages\\Api\\'=> [JPATH_API . '/components/com_messages/src'], 'Joomla\\Component\\Modules\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_modules/src'], 'Joomla\\Component\\Modules\\Api\\'=> [JPATH_API . '/components/com_modules/src'], 'Joomla\\Component\\Modules\\Site\\'=> [JPATH_SITE . '/components/com_modules/src'], 'Joomla\\Component\\Newsfeeds\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Newsfeeds\\Api\\'=> [JPATH_API . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Newsfeeds\\Site\\'=> [JPATH_SITE . '/components/com_newsfeeds/src'], 'Joomla\\Component\\Plugins\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_plugins/src'], 'Joomla\\Component\\Plugins\\Api\\'=> [JPATH_API . '/components/com_plugins/src'], 'Joomla\\Component\\Postinstall\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_postinstall/src'], 'Joomla\\Component\\Privacy\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_privacy/src'], 'Joomla\\Component\\Privacy\\Api\\'=> [JPATH_API . '/components/com_privacy/src'], 'Joomla\\Component\\Privacy\\Site\\'=> [JPATH_SITE . '/components/com_privacy/src'], 'Joomla\\Component\\Redirect\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_redirect/src'], 'Joomla\\Component\\Redirect\\Api\\'=> [JPATH_API . '/components/com_redirect/src'], 'Joomla\\Component\\Scheduler\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_scheduler/src'], 'Joomla\\Component\\Tags\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_tags/src'], 'Joomla\\Component\\Tags\\Api\\'=> [JPATH_API . '/components/com_tags/src'], 'Joomla\\Component\\Tags\\Site\\'=> [JPATH_SITE . '/components/com_tags/src'], 'Joomla\\Component\\Templates\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_templates/src'], 'Joomla\\Component\\Templates\\Api\\'=> [JPATH_API . '/components/com_templates/src'], 'Joomla\\Component\\Users\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_users/src'], 'Joomla\\Component\\Users\\Api\\'=> [JPATH_API . '/components/com_users/src'], 'Joomla\\Component\\Users\\Site\\'=> [JPATH_SITE . '/components/com_users/src'], 'Joomla\\Component\\Workflow\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_workflow/src'], 'Joomla\\Component\\Wrapper\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/components/com_wrapper/src'], 'Joomla\\Component\\Wrapper\\Site\\'=> [JPATH_SITE . '/components/com_wrapper/src'], 'Joomla\\Module\\ArticlesArchive\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_archive/src'], 'Joomla\\Module\\ArticlesCategories\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_categories/src'], 'Joomla\\Module\\ArticlesCategory\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_category/src'], 'Joomla\\Module\\ArticlesLatest\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_latest/src'], 'Joomla\\Module\\ArticlesNews\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_news/src'], 'Joomla\\Module\\ArticlesPopular\\Site\\'=> [JPATH_SITE . '/modules/mod_articles_popular/src'], 'Joomla\\Module\\Banners\\Site\\'=> [JPATH_SITE . '/modules/mod_banners/src'], 'Joomla\\Module\\Breadcrumbs\\Site\\'=> [JPATH_SITE . '/modules/mod_breadcrumbs/src'], 'Joomla\\Module\\Feed\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_feed/src'], 'Joomla\\Module\\Feed\\Site\\'=> [JPATH_SITE . '/modules/mod_feed/src'], 'Joomla\\Module\\Finder\\Site\\'=> [JPATH_SITE . '/modules/mod_finder/src'], 'Joomla\\Module\\Footer\\Site\\'=> [JPATH_SITE . '/modules/mod_footer/src'], 'Joomla\\Module\\Languages\\Site\\'=> [JPATH_SITE . '/modules/mod_languages/src'], 'Joomla\\Module\\LatestActions\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_latestactions/src'], 'Joomla\\Module\\Latest\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_latest/src'], 'Joomla\\Module\\Logged\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_logged/src'], 'Joomla\\Module\\Login\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_login/src'], 'Joomla\\Module\\Login\\Site\\'=> [JPATH_SITE . '/modules/mod_login/src'], 'Joomla\\Module\\Loginsupport\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_loginsupport/src'], 'Joomla\\Module\\Menu\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_menu/src'], 'Joomla\\Module\\Menu\\Site\\'=> [JPATH_SITE . '/modules/mod_menu/src'], 'Joomla\\Module\\Popular\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_popular/src'], 'Joomla\\Module\\PrivacyDashboard\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_privacy_dashboard/src'], 'Joomla\\Module\\PrivacyStatus\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_privacy_status/src'], 'Joomla\\Module\\Quickicon\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_quickicon/src'], 'Joomla\\Module\\RandomImage\\Site\\'=> [JPATH_SITE . '/modules/mod_random_image/src'], 'Joomla\\Module\\RelatedItems\\Site\\'=> [JPATH_SITE . '/modules/mod_related_items/src'], 'Joomla\\Module\\Sampledata\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_sampledata/src'], 'Joomla\\Module\\StatsAdmin\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_stats_admin/src'], 'Joomla\\Module\\Stats\\Site\\'=> [JPATH_SITE . '/modules/mod_stats/src'], 'Joomla\\Module\\Submenu\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_submenu/src'], 'Joomla\\Module\\Syndicate\\Site\\'=> [JPATH_SITE . '/modules/mod_syndicate/src'], 'Joomla\\Module\\TagsPopular\\Site\\'=> [JPATH_SITE . '/modules/mod_tags_popular/src'], 'Joomla\\Module\\TagsSimilar\\Site\\'=> [JPATH_SITE . '/modules/mod_tags_similar/src'], 'Joomla\\Module\\UsersLatest\\Site\\'=> [JPATH_SITE . '/modules/mod_users_latest/src'], 'Joomla\\Module\\Version\\Administrator\\'=> [JPATH_ADMINISTRATOR . '/modules/mod_version/src'], 'Joomla\\Module\\Whosonline\\Site\\'=> [JPATH_SITE . '/modules/mod_whosonline/src'], 'Joomla\\Module\\Wrapper\\Site\\'=> [JPATH_SITE . '/modules/mod_wrapper/src'], 'Joomla\\Plugin\\Content\\ConfirmConsent\\'=> [JPATH_PLUGINS . '/content/confirmconsent/src'], 'Joomla\\Plugin\\Editors\\CodeMirror\\'=> [JPATH_PLUGINS . '/editors/codemirror/src'], 'Joomla\\Plugin\\Editors\\TinyMCE\\'=> [JPATH_PLUGINS . '/editors/tinymce/src'], 'Joomla\\Plugin\\Filesystem\\Local\\'=> [JPATH_PLUGINS . '/filesystem/local/src'], 'Joomla\\Plugin\\Quickicon\\Joomlaupdate\\'=> [JPATH_PLUGINS . '/quickicon/joomlaupdate/src'], 'Joomla\\Plugin\\System\\Debug\\'=> [JPATH_PLUGINS . '/system/debug/src'], 'Joomla\\Plugin\\System\\PrivacyConsent\\'=> [JPATH_PLUGINS . '/system/privacyconsent/src'], 'Joomla\\Plugin\\System\\Stats\\'=> [JPATH_PLUGINS . '/system/stats/src'], 'Joomla\\Plugin\\System\\Webauthn\\'=> [JPATH_PLUGINS . '/system/webauthn/src'], 'Joomla\\Plugin\\User\\Profile\\'=> [JPATH_PLUGINS . '/user/profile/src'], 'Joomla\\Plugin\\User\\Terms\\'=> [JPATH_PLUGINS . '/user/terms/src'], 'Joomla\\Plugin\\User\\Token\\'=> [JPATH_PLUGINS . '/user/token/src'],]


Joomla CMS: Référence du fichier autoload_psr4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Variables
Référence du fichier libraries/vendor/composer/autoload_psr4.php

Variables

$vendorDir = dirname(__DIR__)
$baseDir = dirname(dirname($vendorDir))

Documentation des variables

◆ $baseDir

$baseDir = dirname(dirname($vendorDir))

◆ $vendorDir

$vendorDir = dirname(__DIR__)


Joomla CMS: Référence du fichier autoload_real.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Structures de données | Fonctions
Référence du fichier autoload_real.php

Structures de données

class ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f

Fonctions

composerRequire2399d40fc48ada3450e844df0430bf2f ($fileIdentifier, $file)

Documentation des fonctions

◆ composerRequire2399d40fc48ada3450e844df0430bf2f()

composerRequire2399d40fc48ada3450e844df0430bf2f | ( | $fileIdentifier,
 |  | $file
 | ) |
Paramètres
string | $fileIdentifier
string | $file
Renvoie
void

Référencé par ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\getLoader().


Joomla CMS: Référence du fichier autoload_static.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Structures de données | Espaces de nommage
Référence du fichier autoload_static.php

Structures de données

class ComposerStaticInit2399d40fc48ada3450e844df0430bf2f

Espaces de nommage

Composer\Autoload


Joomla CMS: Référence du fichier Autoloader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Structures de données | Espaces de nommage
Référence du fichier Autoloader.php

Structures de données

class Autoloader

Espaces de nommage

Laminas\ZendFrameworkBridge


Joomla CMS: Référence du fichier Backgroundfill.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Backgroundfill.php

Structures de données

class Backgroundfill

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier backtrace.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • error
Espaces de nommage | Variables
Référence du fichier backtrace.php

Espaces de nommage

Joomla\Site

Variables

$backtraceList = $displayData['backtrace']
if(! $backtraceList) $class = $displayData['class'] ?? 'table table-striped table-bordered'

Documentation des variables

◆ $backtraceList

$backtraceList = $displayData['backtrace']

◆ $class

if (! $backtraceList) $class = $displayData['class'] ?? 'table table-striped table-bordered'


Joomla CMS: Référence du fichier backupcodes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • method
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/method/backupcodes.php

Espaces de nommage

Joomla\Administrator

Variables

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)
if(!empty($this->returnURL)) | if ( $this->record->method !='backupcodes')
if(!empty($this->backupCodes[1+2 * $i])) | endfor

Documentation des variables

◆ $cancelURL

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)

◆ endfor

if (!empty( $this->backupCodes[1+2 *$i])) endfor

◆ if

if (!empty( $this->returnURL)) if($this->record->method !='backupcodes')


Joomla CMS: Référence du fichier backupcodes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • method
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/method/backupcodes.php

Espaces de nommage

Joomla\Site

Variables

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)
if(!empty($this->returnURL)) | if ( $this->record->method !='backupcodes')
if(!empty($this->backupCodes[1+2 * $i])) | endfor

Documentation des variables

◆ $cancelURL

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)

◆ endfor

if (!empty( $this->backupCodes[1+2 *$i])) endfor

◆ if

if (!empty( $this->returnURL)) if($this->record->method !='backupcodes')


Joomla CMS: Référence du fichier BackupcodesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Model/BackupcodesModel.php

Structures de données

class BackupcodesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier BackupcodesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Model/BackupcodesModel.php

Structures de données

class BackupcodesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier bad.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions | Variables
Référence du fichier bad.php

Espaces de nommage

utf8

Fonctions

utf8_bad_find ($str)
utf8_bad_findall ($str)
utf8_bad_strip ($str)
utf8_bad_replace ($str, $replace='?')
utf8_bad_identify ($str, &$i)
utf8_bad_explain ($code)

Variables

const | UTF8_BAD_5OCTET 1
const | UTF8_BAD_6OCTET 2
const | UTF8_BAD_SEQID 3
const | UTF8_BAD_NONSHORT 4
const | UTF8_BAD_SURROGATE 5
const | UTF8_BAD_UNIOUTRANGE 6
const | UTF8_BAD_SEQINCOMPLETE 7

Documentation des fonctions

◆ utf8_bad_explain()

utf8_bad_explain ( $code )

Références UTF8_BAD_5OCTET, UTF8_BAD_6OCTET, UTF8_BAD_NONSHORT, UTF8_BAD_SEQID, UTF8_BAD_SEQINCOMPLETE, UTF8_BAD_SURROGATE, et UTF8_BAD_UNIOUTRANGE.

◆ utf8_bad_find()

utf8_bad_find ( $str )

Références $UTF8_BAD.

◆ utf8_bad_findall()

utf8_bad_findall ( $str )

Références $UTF8_BAD.

◆ utf8_bad_identify()

utf8_bad_identify | ( |  | $str,
 |  | & | $i
 | ) |  |

End of the multi-octet sequence. mUcs4 now contains the final Unicode codepoint to be output

Références $i, $tmp, UTF8_BAD_5OCTET, UTF8_BAD_6OCTET, UTF8_BAD_NONSHORT, UTF8_BAD_SEQID, UTF8_BAD_SEQINCOMPLETE, UTF8_BAD_SURROGATE, et UTF8_BAD_UNIOUTRANGE.

◆ utf8_bad_replace()

utf8_bad_replace | ( | $str,
 |  | $replace = '?'
 | ) |

Références $result, et $UTF8_BAD.

◆ utf8_bad_strip()

utf8_bad_strip ( $str )

Références $result, et $UTF8_BAD.

Documentation des variables

◆ UTF8_BAD_5OCTET

const UTF8_BAD_5OCTET 1

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_6OCTET

const UTF8_BAD_6OCTET 2

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_NONSHORT

const UTF8_BAD_NONSHORT 4

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_SEQID

const UTF8_BAD_SEQID 3

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_SEQINCOMPLETE

const UTF8_BAD_SEQINCOMPLETE 7

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_SURROGATE

const UTF8_BAD_SURROGATE 5

Référencé par utf8_bad_explain(), et utf8_bad_identify().

◆ UTF8_BAD_UNIOUTRANGE

const UTF8_BAD_UNIOUTRANGE 6

Référencé par utf8_bad_explain(), et utf8_bad_identify().


Joomla CMS: Référence du fichier BadConfigurationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier BadConfigurationException.php

Structures de données

class BadConfigurationException

Espaces de nommage

BadConfigurationException
phpseclib3\Exception


Joomla CMS: Référence du fichier BadDecryptionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier BadDecryptionException.php

Structures de données

class BadDecryptionException

Espaces de nommage

BadDecryptionException
phpseclib3\Exception


Joomla CMS: Référence du fichier BadFormatException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier BadFormatException.php

Structures de données

class BadFormatException

Espaces de nommage

Defuse\Crypto\Exception


Joomla CMS: Référence du fichier BadModeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier BadModeException.php

Structures de données

class BadModeException

Espaces de nommage

BadModeException
phpseclib3\Exception


Joomla CMS: Référence du fichier banner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_custom
Espaces de nommage | Variables
Référence du fichier banner.php

Espaces de nommage

Joomla\Site

Variables

$modId = 'mod-custom' . $module->id
if ( $params->get( 'backgroundimage'))

Documentation des variables

◆ $modId

$modId = 'mod-custom' . $module->id

◆ if

if($params->get('backgroundimage'))


Joomla CMS: Référence du fichier Banner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Service
  • Html
Structures de données | Espaces de nommage
Référence du fichier Banner.php

Structures de données

class Banner

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Service\Html


Joomla CMS: Référence du fichier BannerclientField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier BannerclientField.php

Structures de données

class BannerclientField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Field


Joomla CMS: Référence du fichier BannerController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier BannerController.php

Structures de données

class BannerController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier BannerHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier BannerHelper.php

Structures de données

class BannerHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Helper


Joomla CMS: Référence du fichier BannerModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Model/BannerModel.php

Structures de données

class BannerModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier BannerModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_banners/src/Model/BannerModel.php

Structures de données

class BannerModel

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Model


Joomla CMS: Référence du fichier banners.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/helpers/banners.php

Structures de données

class BannersHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier banners.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • banners
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/banners/banners.php

Structures de données

class PlgWebservicesBanners

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier BannersComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier BannersComponent.php

Structures de données

class BannersComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Extension


Joomla CMS: Référence du fichier BannersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Controller/BannersController.php

Structures de données

class BannersController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier BannersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_banners/src/Controller/BannersController.php

Structures de données

class BannersController

Espaces de nommage

Joomla\API
Joomla\Component\Banners\Api\Controller


Joomla CMS: Référence du fichier BannersHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Helper/BannersHelper.php

Structures de données

class BannersHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Helper


Joomla CMS: Référence du fichier BannersHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier modules/mod_banners/src/Helper/BannersHelper.php

Structures de données

class BannersHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Banners\Site\Helper


Joomla CMS: Référence du fichier BannersModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Model/BannersModel.php

Structures de données

class BannersModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier BannersModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_banners/src/Model/BannersModel.php

Structures de données

class BannersModel

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Model


Joomla CMS: Référence du fichier BannerTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier BannerTable.php

Structures de données

class BannerTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Table


Joomla CMS: Référence du fichier bar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Espaces de nommage | Variables
Référence du fichier bar.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$data ['options'] = !empty($data['options']) ? $data['options'] : array()
if(is_array($data['options'])) $filterButton = $data['options']->get('filterButton', true)
$searchButton = $data['options']->get('searchButton', true)
$filters = $data['view']->filterForm->getGroup('filter')
if (empty( $filters[ 'filter_search'])||! $searchButton)
endif

Documentation des variables

◆ $data [1/2]

$data = $displayData

◆ $data [2/2]

$data[ 'options'] = !empty($data['options']) ? $data['options'] : array()

◆ $filterButton

if (is_array( $data[ 'options'])) $filterButton = $data['options']->get('filterButton', true)

◆ $filters

$filters = $data['view']->filterForm->getGroup('filter')

Référencé par Sidebar\addFilter(), TasksRunCommand\doExecute(), ASN1\encode_der(), Scheduler\fetchTaskRecord(), RedisStorage\filter(), FileStorage\filter(), MemcachedStorage\filter(), ComponentHelper\filterText(), FileStorage\find(), RedisStorage\find(), MemcachedStorage\find(), OpenHandler\find(), PdoStorage\find(), X509\getDN(), X509\getDNProp(), Sidebar\getFilters(), FinderIndexCommand\getFilters(), CategoryField\getOptions(), ListModel\getUserStateFromRequest(), BannerModel\loadFormData(), GroupModel\loadFormData(), CategoryModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), FieldModel\loadFormData(), ListModel\populateState(), Stream\prependFilter(), Query\processDynamicTaxonomy(), SqlField\processQuery(), Query\processStaticTaxonomy(), X509\saveCRL(), X509\saveCSR(), X509\saveX509(), LdapClient\search(), TagsController\searchAjax(), TagsHelper\searchTags(), ASN1\setFilters(), et SqlField\setup().

◆ $searchButton

$searchButton = $data['options']->get('searchButton', true)

◆ endif

endif

◆ if

if(empty($filters['filter_search'])||! $searchButton)


Joomla CMS: Référence du fichier Barrett.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier BCMath/Reductions/Barrett.php

Structures de données

class Barrett

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath\Reductions
PHP


Joomla CMS: Référence du fichier Barrett.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier PHP/Reductions/Barrett.php

Structures de données

class Barrett

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier Base.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier Crypt/EC/BaseCurves/Base.php

Structures de données

class Base

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves
Prime


Joomla CMS: Référence du fichier Base.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
Structures de données | Espaces de nommage
Référence du fichier Math/BigInteger/Engines/BCMath/Base.php

Structures de données

class Base

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath
PHP


Joomla CMS: Référence du fichier Base.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
Structures de données | Espaces de nommage
Référence du fichier Math/BigInteger/Engines/PHP/Base.php

Structures de données

class Base

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP
PHP


Joomla CMS: Référence du fichier base.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage
Référence du fichier base.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier Base128.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier Base128.php

Structures de données

class Base128

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier Base16EncodingTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier Base16EncodingTag.php

Structures de données

class Base16EncodingTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier Base32.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Structures de données | Espaces de nommage
Référence du fichier src/Encrypt/Base32.php

Structures de données

class Base32

Espaces de nommage

Joomla\CMS\Encrypt


Joomla CMS: Référence du fichier Base32.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/paragonie/constant_time_encoding/src/Base32.php

Structures de données

class Base32

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Base32Hex.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Base32Hex.php

Structures de données

class Base32Hex

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Base64.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Base64.php

Structures de données

class Base64

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Base64DotSlash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Base64DotSlash.php

Structures de données

class Base64DotSlash

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Base64DotSlashOrdered.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Base64DotSlashOrdered.php

Structures de données

class Base64DotSlashOrdered

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Base64EncodingTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier Base64EncodingTag.php

Structures de données

class Base64EncodingTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier Base64Url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • base64url
  • src
Structures de données | Espaces de nommage
Référence du fichier Base64Url.php

Structures de données

class Base64Url

Espaces de nommage

Base64Url


Joomla CMS: Référence du fichier Base64UrlEncodingTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier Base64UrlEncodingTag.php

Structures de données

class Base64UrlEncodingTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier Base64UrlSafe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Base64UrlSafe.php

Structures de données

class Base64UrlSafe

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier BaseAccept.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier BaseAccept.php

Structures de données

class BaseAccept

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier BaseApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier BaseApplication.php

Structures de données

class BaseApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier BaseController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Structures de données | Espaces de nommage
Référence du fichier BaseController.php

Structures de données

class BaseController

Espaces de nommage

Joomla\CMS\MVC\Controller


Joomla CMS: Référence du fichier BaseDatabaseModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier BaseDatabaseModel.php

Structures de données

class BaseDatabaseModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier BaseDistance.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier BaseDistance.php

Structures de données

class BaseDistance

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier BaseInstallationModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier BaseInstallationModel.php

Structures de données

class BaseInstallationModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier BaseLayout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Layout
Structures de données | Espaces de nommage
Référence du fichier BaseLayout.php

Structures de données

class BaseLayout

Espaces de nommage

Joomla\CMS\Layout


Joomla CMS: Référence du fichier BaseModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier BaseModel.php

Structures de données

class BaseModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier BaseSigner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier BaseSigner.php

Structures de données

class BaseSigner

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier BashCompletionOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
  • Output
Structures de données | Espaces de nommage
Référence du fichier BashCompletionOutput.php

Structures de données

class BashCompletionOutput

Espaces de nommage

Symfony\Component\Console\Completion\Output


Joomla CMS: Référence du fichier Basic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/lcobucci/jwt/src/Claim/Basic.php

Structures de données

class Basic

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier Basic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier plugins/api-authentication/basic/src/Extension/Basic.php

Structures de données

class Basic

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\ApiAuthentication\Basic\Extension


Joomla CMS: Référence du fichier basic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier basic.php

Espaces de nommage

Joomla\Site

Variables

$tagName = $tagName ?? 'button'
$taskAttr = ''
$title = ''
$idAttr = !empty($id) ? ' id="' . $id . '"' : ''
$listAttr = !empty($listCheck) ? ' list-selection' : ''
$formAttr = !empty($form) ? ' form="' . $this->escape($form) . '"' : ''
$validate = !empty($formValidation) ? ' form-validation' : ''
$msgAttr = !empty($message) ? ' confirm-message="' . $this->escape($message) . '"' : ''
if($id==='toolbar-help') if(!empty($task)) elseif(!empty($onclick)) $direction = Factory::getLanguage()->isRtl() ? 'dropdown-menu-end' : ''
if (!( $toggleSplit ?? true) &&isset( $dropdownItems) &&trim( $dropdownItems) !=='')
endif

Documentation des variables

◆ $direction

if ( $id==='toolbar-help') if (!empty( $task)) elseif (!empty( $onclick)) $direction = Factory::getLanguage()->isRtl() ? 'dropdown-menu-end' : ''

◆ $formAttr

$formAttr = !empty($form) ? ' form="' . $this->escape($form) . '"' : ''

◆ $idAttr

$idAttr = !empty($id) ? ' id="' . $id . '"' : ''

◆ $listAttr

$listAttr = !empty($listCheck) ? ' list-selection' : ''

◆ $msgAttr

$msgAttr = !empty($message) ? ' confirm-message="' . $this->escape($message) . '"' : ''

◆ $tagName

string $tagName = $tagName ?? 'button'

Référencé par InputFilter\cleanTags(), et FeedFactory\registerParser().

◆ $taskAttr

$taskAttr = ''

◆ $title

$title = ''

◆ $validate

$validate = !empty($formValidation) ? ' form-validation' : ''

◆ endif

endif

◆ if

if(!($toggleSplit ?? true) &&isset($dropdownItems) &&trim($dropdownItems) !=='')


Joomla CMS: Référence du fichier BasicButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier BasicButton.php

Structures de données

class BasicButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier BasicConstraints.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier BasicConstraints.php

Structures de données

class BasicConstraints

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier batch.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • layouts
  • toolbar
Espaces de nommage | Variables
Référence du fichier administrator/components/com_redirect/layouts/toolbar/batch.php

Espaces de nommage

Joomla\Administrator

Variables

$title = $displayData['title']

Documentation des variables

◆ $title

$title = $displayData['title']


Joomla CMS: Référence du fichier batch.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier layouts/joomla/toolbar/batch.php

Espaces de nommage

Joomla\Site

Variables

$id = isset($displayData['id']) ? $displayData['id'] : ''
$title = $displayData['title']
$message = "{'error': [Joomla.Text._('JLIB_HTML_PLEASE_MAKE_A_SELECTION_FROM_THE_LIST')]}"
$alert = "Joomla.renderMessages(" . $message . ")"

Documentation des variables

◆ $alert

$alert = "Joomla.renderMessages(" . $message . ")"

◆ $id

$id = isset($displayData['id']) ? $displayData['id'] : ''

◆ $message

$message = "{'error': [Joomla.Text._('JLIB_HTML_PLEASE_MAKE_A_SELECTION_FROM_THE_LIST')]}"

Référencé par InvalidStreamPointerPositionException\__construct(), UploadedFileAlreadyMovedException\__construct(), ClassNotFoundError\__construct(), UndefinedFunctionError\__construct(), UndefinedMethodError\__construct(), NestingException\__construct(), FatalError\__construct(), ExtensionOutputError\__construct(), PrepareStatementFailureException\__construct(), ConnectionFailureException\__construct(), InvalidParameterException\__construct(), FilesystemException\__construct(), CommandNotFoundException\__construct(), ParseException\__construct(), RouteNotFoundException\__construct(), InvalidArgumentException\__construct(), MethodNotAllowedException\__construct(), MissingComponentException\__construct(), ExecutionFailureException\__construct(), UnsupportedArchiveException\__construct(), LazyAssertionException\__construct(), UnexpectedResponseException\__construct(), MailDisabledException\__construct(), JsonResponse\__construct(), LogEntry\__construct(), BufferingLogger\__destruct(), ConfirmButton\_getCommand(), BaseLayout\addDebugMessage(), SysinfoModel\addDirectory(), ActionlogModel\addLog(), MessagesCollector\addMessage(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_encrypt(), InstallController\ajax_upload(), AbstractLogger\alert(), Assert\alnum(), Assertion\alnum(), Assert\alpha(), SSH2\append_log(), Symfony\Component\Console\Tester\assertCommandIsSuccessful(), Symfony\Component\VarDumper\Test\assertDumpEquals(), Symfony\Component\VarDumper\Test\assertDumpMatchesFormat(), ParagonIE_Sodium_Crypto\auth(), ParagonIE_Sodium_Crypto32\auth(), ParagonIE_Sodium_Crypto\auth_verify(), ParagonIE_Sodium_Crypto32\auth_verify(), Assertion\base64(), Assertion\between(), Assertion\betweenExclusive(), Assertion\betweenLength(), Assert\boolean(), Assertion\boolean(), RequiredConstraintsViolated\buildMessage(), ErrorHandler\call(), SymfonyStyle\caution(), CssMenu\check(), DebugClassLoader\checkAnnotations(), PlgSystemSef\checkBuffer(), DebugClassLoader\checkClass(), MailHelper\checkContent(), AdminController\checkin(), Assertion\choice(), Assertion\choicesNotEmpty(), Assert\classExists(), Assertion\classExists(), Propel2Collector\collect(), PlgSystemDebug\collectLogs(), SymfonyStyle\comment(), Assert\contains(), Assertion\contains(), Assert\count(), Assertion\count(), Assert\countBetween(), SymfonyStyle\createBlock(), Assertion\createException(), Symfony\Contracts\Service\createNotFoundException(), AbstractLogger\critical(), ParagonIE_Sodium_Compat\crypto_auth(), ParagonIE_Sodium_Compat\crypto_auth_verify(), ParagonIE_Sodium_Compat\crypto_generichash(), ParagonIE_Sodium_Compat\crypto_generichash_update(), ParagonIE_Sodium_Compat\crypto_shorthash(), ParagonIE_Sodium_Compat\crypto_sign(), ParagonIE_Sodium_Compat\crypto_sign_detached(), ParagonIE_Sodium_Compat\crypto_sign_verify_detached(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor(), ParagonIE_Sodium_Compat\crypto_stream_xor(), Assertion\date(), AbstractLogger\debug(), ZIPExtraction\debugMsg(), Assertion\defined(), MethodController\delete(), OptionConfigurator\deprecated(), Assertion\digit(), Assert\digits(), Assert\directory(), Assertion\directory(), Application\doRenderThrowable(), BufferedOutput\doWrite(), TrimmedBufferOutput\doWrite(), StreamOutput\doWrite(), ConsoleSectionOutput\doWrite(), SwiftLogCollector\dump(), Assertion\e164(), Assert\email(), Assertion\email(), AbstractLogger\emergency(), PSSRSA\encodeEMSAPSS(), RSA\encodeEMSAPSS(), Assertion\endsWith(), Assert\endsWith(), UndefinedFunctionErrorEnhancer\enhance(), UndefinedMethodErrorEnhancer\enhance(), ClassNotFoundErrorEnhancer\enhance(), CMSApplication\enqueueMessage(), Core\ensureTrue(), Assertion\eq(), Assert\eq(), Assertion\eqArraySubset(), AbstractLogger\error(), SymfonyStyle\error(), Assertion\extensionLoaded(), Assertion\extensionVersion(), Assert\false(), Assertion\false(), AjaxController\fetchAssociations(), Assert\file(), Assertion\file(), Assert\fileExists(), SSH2\filter(), Application\find(), Application\findNamespace(), Assert\float(), Assertion\float(), OutputFormatter\formatAndWrap(), FormatterHelper\formatBlock(), HtmlErrorRenderer\formatLogMessage(), FormatterHelper\formatSection(), ECSignature\fromAsn1(), MultibyteStringConverter\fromAsn1(), LazyAssertionException\fromErrors(), Serializer\fromString(), Assertion\generateMessage(), SMTP\get_lines(), ActionlogsHelper\getHumanReadableLogMessage(), MessageModel\getItem(), Container\getMethodArgs(), PHPMailer\getSmtpErrorMessage(), Propel2Collector\getStatements(), JoomlatokenField\getTokenForDisplay(), PlgUserToken\getTokenForDisplay(), ArraySerializer\getValueFromKey(), Assertion\greaterOrEqualThan(), Assert\greaterThan(), Assertion\greaterThan(), Assert\greaterThanEq(), ErrorHandler\handleError(), ErrorHandler\handleException(), ParagonIE_Sodium_Core32_XChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core_XChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core_ChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core32_ChaCha20\ietfStreamXorIc(), Assert\implementsInterface(), Assertion\implementsInterface(), Assert\inArray(), Assertion\inArray(), AbstractLogger\info(), SymfonyStyle\info(), LanguagesModel\install(), Assert\integer(), Assertion\integer(), Assert\integerish(), Assertion\integerish(), Assert\interfaceExists(), Assertion\interfaceExists(), ConsoleLogger\interpolate(), MessagesCollector\interpolate(), Assert\ip(), Assertion\ip(), Assert\ipv4(), Assertion\ipv4(), Assert\ipv6(), Assertion\ipv6(), Assert\isAnyOf(), Assert\isAOf(), Assert\isArray(), Assertion\isArray(), Assert\isArrayAccessible(), Assertion\isArrayAccessible(), Assert\isCallable(), Assertion\isCallable(), Assert\isCountable(), Assertion\isCountable(), Assert\isEmpty(), Assert\isInstanceOf(), Assertion\isInstanceOf(), Assert\isInstanceOfAny(), Assert\isIterable(), Assertion\isJsonString(), Assert\isList(), Assert\isMap(), Assert\isNonEmptyList(), Assert\isNonEmptyMap(), Assert\isNotA(), Assertion\isObject(), Assertion\isResource(), Assert\isTraversable(), Assertion\isTraversable(), Assertion\keyExists(), Assert\keyExists(), Assertion\keyIsset(), Assertion\keyNotExists(), Assert\keyNotExists(), Assertion\length(), Assert\length(), Assert\lengthBetween(), Assertion\lessOrEqualThan(), Assert\lessThan(), Assertion\lessThan(), Assert\lessThanEq(), DumpServer\listen(), BufferingLogger\log(), ConsoleLogger\log(), DelegatingPsrLogger\log(), GithubActionReporter\log(), PropelCollector\log(), MessagesCollector\log(), Task\log(), SFTP\logError(), ExportModel\logExport(), ExportModel\logExportEmailed(), SSH2\login_helper(), RemoveModel\logRemove(), RemoveModel\logRemoveBlocked(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), Assert\lower(), Assertion\max(), Assert\maxCount(), Assertion\maxCount(), Assertion\maxLength(), Assert\maxLength(), Directory\message(), Assert\methodExists(), Assertion\methodExists(), Assert\methodNotExists(), Assertion\min(), Assert\minCount(), Assertion\minCount(), Assertion\minLength(), Assert\minLength(), PHPMailer\msgHTML(), Assert\natural(), Assertion\noContent(), Assertion\notBlank(), Assert\notContains(), Assertion\notContains(), SymfonyStyle\note(), Assert\notEmpty(), Assertion\notEmpty(), Assertion\notEmptyKey(), Assert\notEndsWith(), Assertion\notEq(), Assert\notEq(), Assert\notFalse(), AbstractLogger\notice(), Assertion\notInArray(), Assert\notInstanceOf(), Assertion\notIsInstanceOf(), Assert\notNull(), Assertion\notNull(), Assertion\notRegex(), Assert\notRegex(), Assertion\notSame(), Assert\notSame(), Assert\notStartsWith(), Assert\notWhitespaceOnly(), Assert\null(), Assertion\null(), Assert\numeric(), Assertion\numeric(), PluginController\oauthcallback(), Assert\object(), Assertion\objectOrClass(), OptionsResolver\offsetGet(), Joomla\onAfterCheckin(), Joomla\onAfterDispatch(), Joomla\onAfterLogExport(), Joomla\onAfterLogPurge(), Joomla\onAfterPurge(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), Joomla\onApplicationAfterSave(), Joomla\onContentAfterDelete(), PlgContentJoomla\onContentAfterSave(), Joomla\onContentAfterSave(), Joomla\onContentChangeState(), Assert\oneOf(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterSave(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), Joomla\onJoomlaAfterUpdate(), Joomla\onUserAfterDelete(), Joomla\onUserAfterDeleteGroup(), Joomla\onUserAfterLogin(), Joomla\onUserAfterRemind(), Joomla\onUserAfterSave(), Joomla\onUserAfterSaveGroup(), Joomla\onUserLoginFailure(), Joomla\onUserLogout(), PlgWorkflowNotification\onWorkflowAfterTransition(), ZIPExtraction\openArchiveFile(), IndexController\optimise(), ConsoleSectionOutput\overwrite(), ProgressBar\overwrite(), PropelCollector\parseAndLogSqlQuery(), ErrorHandler\parseAnonymousClass(), ArgvInput\parseArgument(), ASNObject\parseIdentifier(), Assertion\phpVersion(), Assert\positiveInteger(), DebugFormatterHelper\progress(), Assertion\propertiesExist(), Assert\propertyExists(), Assertion\propertyExists(), Assert\propertyNotExists(), ActionlogsController\purge(), LinksController\purge(), FinderIndexCommand\purge(), Assert\range(), Assertion\range(), Assert\readable(), Assertion\readable(), ECSignature\readAsn1Content(), MultibyteStringConverter\readAsn1Content(), ECSignature\readAsn1Integer(), MultibyteStringConverter\readAsn1Integer(), Assertion\regex(), Assert\regex(), RegistrationModel\register(), Path\removeRoot(), AdminController\reorder(), Assert\reportInvalidArgument(), Curl\request(), CurlTransport\request(), Assert\resource(), ProcessHelper\run(), AdminController\runTransition(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor(), Assertion\same(), Assert\same(), Assertion\satisfy(), FieldModel\save(), MessageModel\save(), AdminController\saveorder(), Assert\scalar(), Assertion\scalar(), ActionlogModel\sendNotificationEmails(), OptionsResolver\setDeprecated(), SMTP\setError(), ProgressBar\setMessage(), BaseController\setMessage(), PSSRSA\sign(), RSA\sign(), PrivateKey\sign(), Identity\sign(), ParagonIE_Sodium_Crypto32\sign(), ParagonIE_Sodium_Crypto\sign(), ParagonIE_Sodium_Core_Ed25519\sign_detached(), ParagonIE_Sodium_Core32_Ed25519\sign_detached(), ParagonIE_Sodium_Crypto32\sign_detached(), ParagonIE_Sodium_Crypto\sign_detached(), ParagonIE_Sodium_Crypto32\sign_verify_detached(), ParagonIE_Sodium_Crypto\sign_verify_detached(), RSA\signWithPKCS15(), RSA\signWithPSS(), PHPMailer\smtpConnect(), DebugFormatterHelper\start(), Assertion\startsWith(), Assert\startsWith(), Assert\startsWithLetter(), DebugFormatterHelper\stop(), ParagonIE_Sodium_Core32_XChaCha20\streamXorIc(), ParagonIE_Sodium_Core_XChaCha20\streamXorIc(), ParagonIE_Sodium_Core_ChaCha20\streamXorIc(), ParagonIE_Sodium_Core32_ChaCha20\streamXorIc(), Assert\string(), Assertion\string(), Assert\stringNotEmpty(), Assertion\subclassOf(), Assert\subclassOf(), SymfonyStyle\success(), SymfonyStyle\text(), Assert\throws(), IntegerOverflowException\toIntOverflow(), Assert\true(), Assertion\true(), FormatterHelper\truncate(), Assert\unicodeLetters(), Assert\uniqueValues(), Assertion\uniqueValues(), Assert\upper(), Assertion\url(), Assert\uuid(), Assertion\uuid(), Assert\validArrayKey(), LintCommand\validate(), SetupModel\validate(), FormModel\validate(), FormField\validate(), PublicKey\verify(), RSA\verify(), Crypto\VerifyHMAC(), Crypto\verifyHMAC(), RSA\verifyWithPKCS15(), RSA\verifyWithPSS(), Assertion\version(), AbstractLogger\warning(), SymfonyStyle\warning(), PHPMailer\wrapText(), Assert\writable(), SlimCollector\write(), Output\write(), SymfonyStyle\write(), Assertion\writeable(), SymfonyStyle\writeBuffer(), QuestionHelper\writeError(), SymfonyStyle\writeln(), QuestionHelper\writePrompt(), ParagonIE_Sodium_Core_XSalsa20\xsalsa20_xor(), et ParagonIE_Sodium_Core32_XSalsa20\xsalsa20_xor().

◆ $title

$title = $displayData['title']


Joomla CMS: Référence du fichier BCMath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • bcmath_compat
  • src
Structures de données | Espaces de nommage
Référence du fichier bcmath_compat/src/BCMath.php

Structures de données

class BCMath

Espaces de nommage

bcmath_compat


Joomla CMS: Référence du fichier BCMath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/Math/BigInteger/Engines/BCMath.php

Structures de données

class BCMath

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
BCMath


Joomla CMS: Référence du fichier bcmath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • bcmath_compat
  • lib
Référence du fichier bcmath.php


Joomla CMS: Référence du fichier BcMathCalculator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
  • Calculator
Structures de données | Espaces de nommage
Référence du fichier BcMathCalculator.php

Structures de données

class BcMathCalculator

Espaces de nommage

Brick\Math\Internal\Calculator


Joomla CMS: Référence du fichier BCryptHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier src/Authentication/Password/BCryptHandler.php

Structures de données

class BCryptHandler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier BCryptHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Password
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/authentication/src/Password/BCryptHandler.php

Structures de données

class BCryptHandler

Espaces de nommage

Joomla\Authentication\Password


Joomla CMS: Référence du fichier BeforeBatchEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Model
Structures de données | Espaces de nommage
Référence du fichier BeforeBatchEvent.php

Structures de données

class BeforeBatchEvent

Espaces de nommage

Joomla\CMS\Event\Model


Joomla CMS: Référence du fichier BeforeBindEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeBindEvent.php

Structures de données

class BeforeBindEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeCheckinEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeCheckinEvent.php

Structures de données

class BeforeCheckinEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeCheckoutEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeCheckoutEvent.php

Structures de données

class BeforeCheckoutEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeCommandExecuteEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier BeforeCommandExecuteEvent.php

Structures de données

class BeforeCommandExecuteEvent

Espaces de nommage

Joomla\Console\Event


Joomla CMS: Référence du fichier BeforeDeleteEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeDeleteEvent.php

Structures de données

class BeforeDeleteEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeDisplayMethods.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier BeforeDisplayMethods.php

Structures de données

class BeforeDisplayMethods

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier BeforeExtensionBootEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier BeforeExtensionBootEvent.php

Structures de données

class BeforeExtensionBootEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier BeforeHitEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeHitEvent.php

Structures de données

class BeforeHitEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeLoadEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeLoadEvent.php

Structures de données

class BeforeLoadEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeMoveEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeMoveEvent.php

Structures de données

class BeforeMoveEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforePublishEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforePublishEvent.php

Structures de données

class BeforePublishEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeReorderEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeReorderEvent.php

Structures de données

class BeforeReorderEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeResetEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeResetEvent.php

Structures de données

class BeforeResetEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier BeforeStoreEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier BeforeStoreEvent.php

Structures de données

class BeforeStoreEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier Behavior.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier src/HTML/Helpers/Behavior.php

Structures de données

class Behavior

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Behavior.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/typo3/phar-stream-wrapper/src/Behavior.php

Structures de données

class Behavior

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier behindproxy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier behindproxy.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_behindproxy_condition ()
behindproxy_postinstall_action ()

Documentation des fonctions

◆ admin_postinstall_behindproxy_condition()

admin_postinstall_behindproxy_condition ( )

Notifies users of the new Behind Load Balancer option in Global Config, if we detect they might be behind a proxy

Renvoie
boolean
Depuis
3.9.26

Références $app.

◆ behindproxy_postinstall_action()

behindproxy_postinstall_action ( )

Enables the Behind Load Balancer setting in Global Configuration

Renvoie
void
Depuis
3.9.26

Références $config, $configuration, $data, et JPATH_CONFIGURATION.


Joomla CMS: Référence du fichier BigDecimal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Structures de données | Espaces de nommage
Référence du fichier BigDecimal.php

Structures de données

class BigDecimal

Espaces de nommage

Brick\Math


Joomla CMS: Référence du fichier BigFloatTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier BigFloatTag.php

Structures de données

class BigFloatTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier BigInteger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Structures de données | Espaces de nommage
Référence du fichier brick/math/src/BigInteger.php

Structures de données

class BigInteger

Espaces de nommage

Brick\Math


Joomla CMS: Référence du fichier BigInteger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • Utility
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/Utility/BigInteger.php

Structures de données

class BigInteger

Espaces de nommage

FG\Utility
FG


Joomla CMS: Référence du fichier BigInteger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Math/BigInteger.php

Structures de données

class BigInteger

Espaces de nommage

BigInteger
phpseclib3\Math


Joomla CMS: Référence du fichier BigInteger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-core/Util/BigInteger.php

Structures de données

class BigInteger

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier BigIntegerBcmath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • Utility
Structures de données | Espaces de nommage
Référence du fichier BigIntegerBcmath.php

Structures de données

class BigIntegerBcmath

Espaces de nommage

FG\Utility
FG


Joomla CMS: Référence du fichier BigIntegerGmp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • Utility
Structures de données | Espaces de nommage
Référence du fichier BigIntegerGmp.php

Structures de données

class BigIntegerGmp

Espaces de nommage

FG\Utility
FG


Joomla CMS: Référence du fichier BigNumber.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Structures de données | Espaces de nommage
Référence du fichier BigNumber.php

Structures de données

class BigNumber

Espaces de nommage

Brick\Math


Joomla CMS: Référence du fichier BigNumberConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Number
Structures de données | Espaces de nommage
Référence du fichier BigNumberConverter.php

Structures de données

class BigNumberConverter

Espaces de nommage

Ramsey\Uuid\Converter\Number


Joomla CMS: Référence du fichier BigNumberTimeConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Time
Structures de données | Espaces de nommage
Référence du fichier BigNumberTimeConverter.php

Structures de données

class BigNumberTimeConverter

Espaces de nommage

Ramsey\Uuid\Converter\Time


Joomla CMS: Référence du fichier BigRational.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Structures de données | Espaces de nommage
Référence du fichier BigRational.php

Structures de données

class BigRational

Espaces de nommage

Brick\Math


Joomla CMS: Référence du fichier Binary.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier paragonie/constant_time_encoding/src/Binary.php

Structures de données

class Binary

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Binary.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/BaseCurves/Binary.php

Structures de données

class Binary

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves
Binary


Joomla CMS: Référence du fichier BinaryField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
Structures de données | Espaces de nommage
Référence du fichier BinaryField.php

Structures de données

class BinaryField

Espaces de nommage

BigInteger
phpseclib3\Math
Math


Joomla CMS: Référence du fichier BinaryUtils.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier BinaryUtils.php

Structures de données

class BinaryUtils

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier BiometricAccuracyDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier BiometricAccuracyDescriptor.php

Structures de données

class BiometricAccuracyDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier BiometricStatusReport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier BiometricStatusReport.php

Structures de données

class BiometricStatusReport

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier BitString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier BitString.php

Structures de données

class BitString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier BLAKE2b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/BLAKE2b.php

Structures de données

class BLAKE2b

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier BLAKE2b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/BLAKE2b.php

Structures de données

class ParagonIE_Sodium_Core_BLAKE2b


Joomla CMS: Référence du fichier BLAKE2b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/BLAKE2b.php

Structures de données

class ParagonIE_Sodium_Core32_BLAKE2b


Joomla CMS: Référence du fichier BlockCipher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier BlockCipher.php

Structures de données

class BlockCipher

Espaces de nommage

BlockCipher
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier blog.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/category/blog.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$this category | text = $this->category->description
$this category | description = $this->category->text
$results = $app->triggerEvent('onContentAfterTitle', array($this->category->extension . '.categories', &$this->category, &$this->params, 0))
$afterDisplayTitle = trim(implode("\n", $results))
$beforeDisplayContent = trim(implode("\n", $results))
$afterDisplayContent = trim(implode("\n", $results))
$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'
endif
if ( $this->params->get( 'show_category_title', 1))
foreach ( $this->lead_items as & $item)
endforeach
if((int) $this->params->get( 'num_columns') > 1)(int) $this -> params->get('multi_column_order', 0)===0? ' masonry-' | $blogClass = (int) $this->params->get('num_columns')

Documentation des variables

◆ $afterDisplayContent

$afterDisplayContent = trim(implode("\n", $results))

◆ $afterDisplayTitle

$afterDisplayTitle = trim(implode("\n", $results))

◆ $app

$app = Factory::getApplication()

◆ $beforeDisplayContent

$beforeDisplayContent = trim(implode("\n", $results))

◆ $blogClass

if ((int) $this->params->get('num_columns') > 1) (int) $this -> params->get( 'multi_column_order', 0)===0? ' masonry-' $blogClass = (int) $this->params->get('num_columns')

◆ $htag

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'

◆ $results

$results = $app->triggerEvent('onContentAfterTitle', array($this->category->extension . '.categories', &$this->category, &$this->params, 0))

◆ description

$this category description = $this->category->text

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->intro_items as $key=> &$item) ( $this->lead_items as & )

◆ if

if($this->params->get('show_category_title', 1))

◆ text

$this category text = $this->category->description


Joomla CMS: Référence du fichier blog.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • sampledata
  • blog
Structures de données | Espaces de nommage
Référence du fichier plugins/sampledata/blog/blog.php

Structures de données

class PlgSampledataBlog

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier blog_children.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier blog_children.php

Espaces de nommage

Joomla\Site

Variables

$lang = Factory::getLanguage()
$user = Factory::getUser()
$groups = $user->getAuthorisedViewLevels()
endif
if($this->maxLevel > 1 &&count($child->getChildren()) > 0) | else
if($this->maxLevel > 1 &&count($child->getChildren()) > 0) $child | language
if($this->maxLevel > 1 &&count($child->getChildren()) > 0) $this | children [$child->id] = $child->getChildren()
$this | category = $child
$this | maxLevel
endforeach

Documentation des variables

◆ $groups

$groups = $user->getAuthorisedViewLevels()

◆ $lang

$lang = Factory::getLanguage()

◆ $user

$user = Factory::getUser()

◆ category

$this category = $child

◆ children

if ( $this->maxLevel > 1 &&count( $child->getChildren()) > 0) $this children[ $child->id] = $child->getChildren()

Référencé par Construct\__construct(), AttributeTypeAndValue\__toString(), Construct\addChild(), Construct\calculateContentLength(), CategoryView\commonCategoryDisplay(), Construct\count(), CSR\createCSRSequence(), Construct\current(), HtmlView\display(), Construct\getEncodedValue(), Construct\getFirstChild(), Construct\getIterator(), Construct\getNumberOfChildren(), Construct\offsetExists(), Construct\offsetGet(), Construct\offsetSet(), Construct\offsetUnset(), StandardRules\parse(), et Construct\valid().

◆ else

if ( $this->maxLevel > 1 &&count( $child->getChildren()) > 0) else

◆ endforeach

endforeach

◆ endif

endif

◆ language

if ( $this->maxLevel > 1 &&count( $child->getChildren()) > 0) $child language

Référencé par AcceptLanguage\__construct(), Language\__construct(), SiteMenu\__construct(), FeedLink\__construct(), MailTemplate\__construct(), CliApplication\__construct(), ConsoleApplication\__construct(), Token\__construct(), Query\__construct(), Menu\bind(), MapTable\check(), TagTable\check(), NewsfeedTable\check(), BannerTable\check(), FieldTable\check(), Category\check(), Content\check(), ContactTable\generateAlias(), ConsentBoxField\getAssignedArticleUrl(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), TosField\getLabel(), TermsField\getLayoutData(), CategoryeditField\getOptions(), PHPMailer\getTranslations(), PHPMailer\lang(), WebApplication\loadLanguage(), Result\setLanguage(), Document\setLanguage(), PHPMailer\setLanguage(), MenuitemField\setup(), MenuItemByTypeField\setup(), et Menu\store().

◆ maxLevel

$this maxLevel


Joomla CMS: Référence du fichier blog_item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier blog_item.php

Espaces de nommage

Joomla\Site

Variables

$params = $this->item->params
$canEdit = $this->item->params->get('access-edit')
$info = $params->get('info_block_position', 0)
$assocParam = (Associations::isEnabled() && $params->get('show_associations'))
$currentDate = Factory::getDate()->format('Y-m-d H:i:s')
$isUnpublished
if ( $isUnpublished)
endif
$useDefList
else __pad2__
$active = $menu->getActive()
$itemId = $active->id
$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

Documentation des variables

◆ $active

$active = $menu->getActive()

◆ $assocParam

$assocParam = (Associations::isEnabled() && $params->get('show_associations'))

◆ $canEdit

$canEdit = $this->item->params->get('access-edit')

◆ $currentDate

$currentDate = Factory::getDate()->format('Y-m-d H:i:s')

◆ $info

$info = $params->get('info_block_position', 0)

◆ $isUnpublished

$isUnpublished
Valeur initiale :
= ($this->item->state == ContentComponent::CONDITION_UNPUBLISHED || $this->item->publish_up > $currentDate)
|| ($this->item->publish_down < $currentDate && $this->item->publish_down !== null)
$currentDate
$currentDate
Definition: blog_item.php:29
$this
else $this
Definition: administrator/components/com_modules/tmpl/module/edit.php:145
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

◆ $itemId

$itemId = $active->id

◆ $link

$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

◆ $params

$params = $this->item->params

◆ $useDefList

$useDefList
Valeur initiale :
= ($params->get('show_modify_date') || $params->get('show_publish_date') || $params->get('show_create_date')
|| $params->get('show_hits') || $params->get('show_category') || $params->get('show_parent_category') || $params->get('show_author') || $assocParam)
$params
$params
Definition: blog_item.php:22
$assocParam
$assocParam
Definition: blog_item.php:27

◆ __pad2__

else __pad2__

◆ endif

endif

◆ if

if($isUnpublished) ( $isUnpublished )


Joomla CMS: Référence du fichier blog_links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier blog_links.php

Espaces de nommage

Joomla\Site

Variables

endforeach

Documentation des variables

◆ endforeach

endforeach


Joomla CMS: Référence du fichier blog_style_default_item_title.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier blog_style_default_item_title.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData->params
$canEdit = $displayData->params->get('access-edit')
$currentDate = Factory::getDate()->format('Y-m-d H:i:s')
$link = RouteHelper::getArticleRoute($displayData->slug, $displayData->catid, $displayData->language)
else __pad0__
endif

Documentation des variables

◆ $canEdit

$canEdit = $displayData->params->get('access-edit')

◆ $currentDate

$currentDate = Factory::getDate()->format('Y-m-d H:i:s')

◆ $link

$link = RouteHelper::getArticleRoute($displayData->slug, $displayData->catid, $displayData->language)

◆ $params

$params = $displayData->params

◆ __pad0__

else __pad0__

◆ endif

endif


Joomla CMS: Référence du fichier Blowfish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier Blowfish.php

Structures de données

class Blowfish

Espaces de nommage

Blowfish
phpseclib3\Crypt


Joomla CMS: Référence du fichier BMPString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier BMPString.php

Structures de données

class BMPString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier administrator/templates/atum/html/layouts/chromes/body.php

Espaces de nommage

Joomla\Administrator

Variables

$module = $displayData['module']
$params = $displayData['params']
if((string) $module->content==='') $id = $module->id
$user = Factory::getUser()
$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')
$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')
$moduleTag = $params->get('module_tag', 'div')
$bootstrapSize = (int) $params->get('bootstrap_size', 6)
$moduleClass = $bootstrapSize ? 'col-md-' . $bootstrapSize : 'col-md-12'
$headerTag = htmlspecialchars($params->get('header_tag', 'h2'), ENT_QUOTES, 'UTF-8')
$moduleClassSfx = $params->get('moduleclass_sfx', '')
$headerClass = $params->get('header_class')
$url = Route::_('index.php?option=com_modules&task=module.edit&id=' . $id . '&return=' . base64_encode($uri))
endif
if ( $canChange)

Documentation des variables

◆ $bootstrapSize

$bootstrapSize = (int) $params->get('bootstrap_size', 6)

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')

◆ $headerClass

$headerClass = $params->get('header_class')

◆ $headerTag

$headerTag = htmlspecialchars($params->get('header_tag', 'h2'), ENT_QUOTES, 'UTF-8')

◆ $id

if ((string) $module->content==='') $id = $module->id

◆ $module

$module = $displayData['module']

Référencé par AbstractModuleDispatcher\__construct(), PlgContentLoadmodule\_load(), PlgContentLoadmodule\_loadmod(), InstallerScript\addDashboardMenu(), ModuleHelper\cleanModuleList(), HtmlDocument\countModules(), ModuleHelper\createDummyModule(), ModuleAdapter\discover(), CaptiveModel\filterModules(), MultilangstatusHelper\getDefaultHomeModule(), Module\getDispatcher(), ModuleModel\getForm(), ModulelayoutField\getInput(), AbstractModuleDispatcher\getLayoutData(), ModuleHelper\getLayoutPath(), ModulesModel\getListQuery(), ModulesHelper\getModules(), MenuModel\getModules(), TemplateModel\getOverridesList(), ModuleHelper\isEnabled(), PlgContentLoadmodule\onContentPrepare(), ModulesModel\preprocessForm(), ModuleModel\preprocessForm(), ModuleRenderer\render(), ModuleHelper\renderModule(), et ModuleHelper\renderRawModule().

◆ $moduleClass

$moduleClass = $bootstrapSize ? 'col-md-' . $bootstrapSize : 'col-md-12'

◆ $moduleClassSfx

$moduleClassSfx = $params->get('moduleclass_sfx', '')

◆ $moduleTag

$moduleTag = $params->get('module_tag', 'div')

◆ $params

$params = $displayData['params']

◆ $url

$url = Route::_('index.php?option=com_modules&task=module.edit&id=' . $id . '&return=' . base64_encode($uri))
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Route\_(), SitePathway\__construct(), Result\__serialize(), HelpButton\_getCommand(), PopupButton\_getCommand(), InstallModel\_getPackageFromUrl(), LinkModel\activate(), Tobscure\JsonApi\addPaginationLink(), Tobscure\JsonApi\addPaginationLinks(), Document\addScript(), Document\addStyleSheet(), HtmlView\addToolbar(), OpensearchDocument\addUrl(), FormBehavior\ajaxchosen(), AdministratorService\association(), Menus\association(), SiteApplication\authorise(), Client\authorise(), Client\baseString(), AdministratorRouter\build(), InstallationRouter\build(), Router\build(), FormController\cancel(), LinkTable\check(), CMSApplication\checkUserRequireReset(), HTMLHelper\cleanImageURL(), TemplateController\close(), AbstractIdnaConvert\convertUrl(), Icon\create(), TemplateController\createFile(), TemplateModel\createOverride(), OutputFormatter\createStyleFromString(), Router\createUri(), Help\createUrl(), Client\createUrl(), Http\delete(), MethodController\delete(), TemplateController\delete(), HtmlView\display(), DisplayController\display(), ExtensionInstallCommand\doExecute(), UpdateCoreCommand\downloadFile(), InstallerHelper\downloadPackage(), LanguagesModel\downloadPackage(), UpdateModel\downloadPackage(), LinkModel\duplicateUrls(), Icon\edit(), LinkButton\fetchButton(), PopupButton\fetchButton(), X509\fetchURL(), SimpleMetadataStatementRepository\findOneByAAGUIDFromServices(), FilesystemHelper\ftpChmod(), Helper\ftpChmod(), Http\get(), AssociationsHelper\getAssociationHtmlList(), InstallerHelper\getFilenameFromUrl(), Adapter\getItemMenuTitle(), TosField\getLabel(), WrapperHelper\getParams(), LoginHelper\getReturnUrl(), UpdateAdapter\getUpdateSiteResponse(), Totp\getUrl(), BannerModel\getUrl(), ApiModel\getUrl(), DataCollector\getXdebugLink(), Http\head(), httpheaders_postinstall_action(), HTMLHelper\iframe(), Curl\init(), UpdateModel\install(), BannerHelper\isImage(), Uri\isInternal(), ToolbarHelper\jooa11y(), Route\link(), ToolbarHelper\link(), HTMLHelper\link(), Changelog\loadFromXml(), Update\loadFromXml(), Requests\makeGetRequest(), Http\makeTransportRequest(), UserController\menulogout(), PHPMailer\msgHTML(), Client\oauthRequest(), PlgContentContact\onContentPrepare(), Stream\open(), Http\options(), TemplateController\overrides(), UriHelper\parse_url(), Http\patch(), Http\post(), ToolbarHelper\preview(), ExtensionInstallCommand\processUrlInstallation(), TemplateController\publish(), Http\put(), Client\query(), AbstractWebApplication\redirect(), CMSApplication\redirect(), Helper\remotefsize(), FilesystemHelper\remotefsize(), Adapter\remove(), RssRenderer\render(), AtomRenderer\render(), OpensearchDocument\render(), FormController\save(), JavascriptRenderer\setBaseUrl(), OutputFormatterStyle\setHref(), Document\setLink(), JavascriptRenderer\setOpenHandlerUrl(), BaseController\setRedirect(), Buffer\stream_open(), BufferStreamHandler\stream_open(), X509\testForIntermediate(), Client\toUrl(), Http\trace(), TemplateController\uploadFile(), TemplateModel\uploadFile(), X509\validateURL(), et ArticleController\vote().

◆ $user

$user = Factory::getUser()

◆ endif

endif

◆ if

if($module->showtitle) ( $canChange )


Joomla CMS: Référence du fichier body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • template
Espaces de nommage
Référence du fichier installation/template/body.php

Espaces de nommage

Joomla\Installation


Joomla CMS: Référence du fichier body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Espaces de nommage | Variables
Référence du fichier layouts/libraries/html/bootstrap/modal/body.php

Espaces de nommage

Joomla\Site

Variables

$bodyClass = 'modal-body'
$bodyHeight = isset($params['bodyHeight']) ? round((int) $params['bodyHeight'], -1) : ''
if ( $bodyHeight &&$bodyHeight >=20 &&$bodyHeight< 90)

Documentation des variables

◆ $bodyClass

$bodyClass = 'modal-body'

◆ $bodyHeight

$bodyHeight = isset($params['bodyHeight']) ? round((int) $params['bodyHeight'], -1) : ''

Référencé par PopupButton\fetchButton(), ToolbarHelper\jooa11y(), et ToolbarHelper\preview().

◆ if

if($bodyHeight && $bodyHeight >=20 && $bodyHeight< 90)


Joomla CMS: Référence du fichier Boolean.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier Boolean.php

Structures de données

class Boolean

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier BooleanRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier BooleanRule.php

Structures de données

class BooleanRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier BootableExtensionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier BootableExtensionInterface.php

Structures de données

interface BootableExtensionInterface

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier Bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Bootstrap.php

Structures de données

class Bootstrap

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Variables
Référence du fichier bootstrap.php

Variables

defined('JPATH_PLATFORM') or define('JPATH_PLATFORM' | __DIR__
$os = strtoupper(substr(PHP_OS, 0, 3))
$loader = require JPATH_LIBRARIES . '/vendor/autoload.php'
$errorHandler = \Symfony\Component\ErrorHandler\ErrorHandler::register()
if(error_reporting() &E_USER_DEPRECATED) | $behavior = new \TYPO3\PharStreamWrapper\Behavior()

Documentation des variables

◆ $behavior

if (error_reporting() &E_USER_DEPRECATED) $behavior = new \TYPO3\PharStreamWrapper\Behavior()

◆ $errorHandler

$errorHandler = \Symfony\Component\ErrorHandler\ErrorHandler::register()

Register the global exception handler. And set error level to server default error level. The error level may be changed later in boot up process, after application config will be loaded. Do not remove the variable, to allow to use it further, after including this file.

Référencé par Stream\__toString(), Application\execute(), et Application\run().

◆ $loader

$loader = require JPATH_LIBRARIES . '/vendor/autoload.php'

Référencé par ClassLoader\__construct(), DebugClassLoader\checkClasses(), ModuleDispatcher\dispatch(), LegacyComponentDispatcher\dispatch(), ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer(), InstalledVersions\getInstalled(), ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\getLoader(), JNamespacePsr4Map\load(), Application\setCommandLoader(), et TraceableTwigEnvironment\setLoader().

◆ $os

$os = strtoupper(substr(PHP_OS, 0, 3))

Référencé par FtpClient\read().

◆ __DIR__

defined ( 'JPATH_PLATFORM') or define( 'JPATH_PLATFORM' __DIR__

Référencé par Replacements\__construct(), JavascriptRenderer\__construct(), Toolbar\__construct(), Table\addIncludePath(), DatabaseHandler\createDatabaseTable(), HtmlDescriptor\describe(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), DumpCompletionCommand\execute(), PlgUserToken\getAlgorithmFromFormFile(), CaBundle\getBundledCaBundlePath(), Autoloader\getClassLoader(), Normalizer\getData(), Iconv\getData(), Mbstring\getData(), ASCII\getData(), ASCII\getDataIfExists(), PlgEditorCodemirror\getFontInfo(), QuestionHelper\getHiddenResponse(), HttpFactory\getHttpTransports(), InstalledVersions\getInstalled(), PlgSystemStats\getLayoutPaths(), ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\getLoader(), InstalledVersions\getRawData(), Cache\getStores(), DumpCompletionCommand\getSupportedShells(), JLoader\import(), ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\loadClassLoader(), AsymmetricKey\loadPlugins(), Microdata\loadTypes(), PlgUserTerms\onContentPrepareForm(), PlgSystemPrivacyconsent\onContentPrepareForm(), PlgSystemActionLogs\onContentPrepareForm(), PlgUserToken\onContentPrepareForm(), PlgUserProfile\onContentPrepareForm(), PlgEditorCodemirror\onDisplay(), PlgEditorCodemirror\onInit(), Stream\open(), WebApplication\render(), CMSApplication\render(), et PHPMailer\setLanguage().


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-ctype
Référence du fichier vendor/symfony/polyfill-ctype/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
Référence du fichier vendor/symfony/polyfill-iconv/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-grapheme
Référence du fichier vendor/symfony/polyfill-intl-grapheme/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
Référence du fichier vendor/symfony/polyfill-intl-normalizer/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
Référence du fichier vendor/symfony/polyfill-mbstring/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php72
Référence du fichier vendor/symfony/polyfill-php72/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
Référence du fichier vendor/symfony/polyfill-php73/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
Référence du fichier vendor/symfony/polyfill-php80/bootstrap.php


Joomla CMS: Référence du fichier bootstrap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
Référence du fichier vendor/voku/portable-utf8/bootstrap.php


Joomla CMS: Référence du fichier bootstrap80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-ctype
Référence du fichier polyfill-ctype/bootstrap80.php


Joomla CMS: Référence du fichier bootstrap80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
Référence du fichier polyfill-iconv/bootstrap80.php


Joomla CMS: Référence du fichier bootstrap80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-grapheme
Référence du fichier polyfill-intl-grapheme/bootstrap80.php


Joomla CMS: Référence du fichier bootstrap80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
Référence du fichier polyfill-intl-normalizer/bootstrap80.php


Joomla CMS: Référence du fichier bootstrap80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
Référence du fichier polyfill-mbstring/bootstrap80.php


Joomla CMS: Référence du fichier Bootup.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
Structures de données | Espaces de nommage
Référence du fichier Bootup.php

Structures de données

class Bootup

Espaces de nommage

voku\helper


Joomla CMS: Référence du fichier brainpoolP160r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP160r1.php

Structures de données

class brainpoolP160r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP160t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP160t1.php

Structures de données

class brainpoolP160t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP192r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP192r1.php

Structures de données

class brainpoolP192r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP192t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP192t1.php

Structures de données

class brainpoolP192t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP224r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP224r1.php

Structures de données

class brainpoolP224r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP224t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP224t1.php

Structures de données

class brainpoolP224t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP256r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP256r1.php

Structures de données

class brainpoolP256r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP256t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP256t1.php

Structures de données

class brainpoolP256t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP320r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP320r1.php

Structures de données

class brainpoolP320r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP320t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP320t1.php

Structures de données

class brainpoolP320t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP384r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP384r1.php

Structures de données

class brainpoolP384r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP384t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP384t1.php

Structures de données

class brainpoolP384t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP512r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP512r1.php

Structures de données

class brainpoolP512r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier brainpoolP512t1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier brainpoolP512t1.php

Structures de données

class brainpoolP512t1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier BranchesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier BranchesField.php

Structures de données

class BranchesField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Field


Joomla CMS: Référence du fichier BreadcrumbsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier BreadcrumbsHelper.php

Structures de données

class BreadcrumbsHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Breadcrumbs\Site\Helper


Joomla CMS: Référence du fichier BreakObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier BreakObject.php

Structures de données

class BreakObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier Brightness.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Brightness.php

Structures de données

class Brightness

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier Browser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Environment
Structures de données | Espaces de nommage
Référence du fichier Browser.php

Structures de données

class Browser

Espaces de nommage

Joomla\CMS\Environment


Joomla CMS: Référence du fichier Buffer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier Buffer.php

Structures de données

class Buffer

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier BufferedOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier BufferedOutput.php

Structures de données

class BufferedOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier BufferingLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Structures de données | Espaces de nommage
Référence du fichier BufferingLogger.php

Structures de données

class BufferingLogger

Espaces de nommage

Symfony\Component\ErrorHandler


Joomla CMS: Référence du fichier BufferStreamHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Utility
Structures de données | Espaces de nommage
Référence du fichier BufferStreamHandler.php

Structures de données

class BufferStreamHandler

Espaces de nommage

Joomla\CMS\Utility


Joomla CMS: Référence du fichier Builder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier Builder.php

Structures de données

class Builder

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier BuiltIn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
Structures de données | Espaces de nommage
Référence du fichier BuiltIn.php

Structures de données

class BuiltIn

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath
BCMath


Joomla CMS: Référence du fichier BuiltInDomainDefinedAttribute.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier BuiltInDomainDefinedAttribute.php

Structures de données

class BuiltInDomainDefinedAttribute

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier BuiltInDomainDefinedAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier BuiltInDomainDefinedAttributes.php

Structures de données

class BuiltInDomainDefinedAttributes

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier BuiltInStandardAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier BuiltInStandardAttributes.php

Structures de données

class BuiltInStandardAttributes

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier button.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • editors
  • buttons
Espaces de nommage | Variables
Référence du fichier button.php

Espaces de nommage

Joomla\Site

Variables

$button = $displayData
if($button->get('name')) $class = ($button->get('class')) ? ' ' . $button->get('class') : null
$href = '#' . strtolower($button->get('name')) . '_modal'
$link = ($button->get('link')) ? Uri::base() . $button->get('link') : null
$onclick = ($button->get('onclick')) ? ' onclick="' . $button->get('onclick') . '"' : ''
$title = ($button->get('title')) ? $button->get('title') : $button->get('text')
$icon = ($button->get('icon')) ? $button->get('icon') : $button->get('name')
endif

Documentation des variables

◆ $button

$button = $displayData

◆ $class

$class = ($button->get('class')) ? ' ' . $button->get('class') : null

◆ $href

$href = '#' . strtolower($button->get('name')) . '_modal'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par LinkStub\__construct(), HtmlDocument\addFavicon(), HtmlDocument\addHeadLink(), ToolbarHelper\back(), Sanitizer\cleanAttributesOnWhitelist(), Sanitizer\cleanHrefs(), Helper\extractIdReferenceFromHref(), CliDumper\style(), HtmlDumper\style(), HTMLHelper\tooltip(), et Debug\xdebuglink().

◆ $icon

$icon = ($button->get('icon')) ? $button->get('icon') : $button->get('name')

◆ $link

$link = ($button->get('link')) ? Uri::base() . $button->get('link') : null

◆ $onclick

$onclick = ($button->get('onclick')) ? ' onclick="' . $button->get('onclick') . '"' : ''

◆ $title

$title = ($button->get('title')) ? $button->get('title') : $button->get('text')

◆ endif

endif


Joomla CMS: Référence du fichier buttons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • editors
Espaces de nommage | Variables
Référence du fichier editors/buttons.php

Espaces de nommage

Joomla\Site

Variables

$buttons = $displayData
endforeach
endif

Documentation des variables

◆ $buttons

$buttons = $displayData

Référencé par Editor\__construct(), PlgEditorNone\_displayButtons(), Icons\buttons(), Editor\display(), PlgEditorCodemirror\displayButtons(), Editor\getButtons(), SubformField\getInput(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), ToolbarHelper\saveGroup(), et EditorField\setup().

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier buttons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • radio
Espaces de nommage | Variables
Référence du fichier form/field/radio/buttons.php

Espaces de nommage

Joomla\Site

Variables

$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)
$isBtnGroup = strpos(trim($class), 'btn-group') !== false
$isBtnYesNo = strpos(trim($class), 'btn-group-yesno') !== false
$classToggle = $isBtnGroup ? 'btn-check' : 'form-check-input'
$btnClass = $isBtnGroup ? 'btn btn-outline-secondary' : 'form-check-label'
$blockStart = $isBtnGroup ? '' : '<div class="form-check">'
$blockEnd = $isBtnGroup ? '' : '</div>'
$containerClass = trim($class . ' radio' . ($readonly || $disabled ? ' disabled' : '') . ($readonly ? ' readonly' : ''))
$attribs = ['id="' . $id . '"']
if(!empty($disabled)) if(!empty($autofocus)) if($readonly|| $disabled) | if ( $dataAttribute)
foreach($options as $i=> $option) | $disabled = !empty($option->disable) ? 'disabled' : ''
$style = $disabled ? ' style="pointer-events: none"' : ''
if($isBtnYesNo) | $optionClass = !empty($option->class) ? $option->class : $btnClass
$checked = ((string) $option->value === $value) ? 'checked="checked"' : ''
$onclick = !empty($option->onclick) ? 'onclick="' . $option->onclick . '"' : ''
$onchange = !empty($option->onchange) ? 'onchange="' . $option->onchange . '"' : ''
$oid = $id . $i
$ovalue = htmlspecialchars($option->value, ENT_COMPAT, 'UTF-8')
$attributes = array_filter(array($checked, $disabled, ltrim($style), $onchange, $onclick))
if($required) | endif
endforeach

Documentation des variables

◆ $alt

$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)

◆ $attribs

$attribs = ['id="' . $id . '"']

◆ $attributes

$attributes = array_filter(array($checked, $disabled, ltrim($style), $onchange, $onclick))

◆ $blockEnd

$blockEnd = $isBtnGroup ? '' : '</div>'

◆ $blockStart

$blockStart = $isBtnGroup ? '' : '<div class="form-check">'

◆ $btnClass

string $btnClass = $isBtnGroup ? 'btn btn-outline-secondary' : 'form-check-label'

◆ $checked

$checked = ((string) $option->value === $value) ? 'checked="checked"' : ''

◆ $classToggle

$classToggle = $isBtnGroup ? 'btn-check' : 'form-check-input'

◆ $containerClass

$containerClass = trim($class . ' radio' . ($readonly || $disabled ? ' disabled' : '') . ($readonly ? ' readonly' : ''))

◆ $disabled

foreach ( $options as $i=> $option) $disabled = !empty($option->disable) ? 'disabled' : ''

◆ $isBtnGroup

$isBtnGroup = strpos(trim($class), 'btn-group') !== false

◆ $isBtnYesNo

$isBtnYesNo = strpos(trim($class), 'btn-group-yesno') !== false

◆ $oid

$oid = $id . $i

◆ $onchange

$onchange = !empty($option->onchange) ? 'onchange="' . $option->onchange . '"' : ''

◆ $onclick

$onclick = !empty($option->onclick) ? 'onclick="' . $option->onclick . '"' : ''

◆ $optionClass

$optionClass = !empty($option->class) ? $option->class : $btnClass

◆ $ovalue

$ovalue = htmlspecialchars($option->value, ENT_COMPAT, 'UTF-8')

◆ $style

$style = $disabled ? ' style="pointer-events: none"' : ''

Référencé par OutputFormatter\__construct(), PlgContentLoadmodule\_load(), PlgContentLoadmodule\_loadmod(), ColorProcessor\addStyle(), SymfonyStyle\block(), TemplateModel\copyStyles(), SymfonyStyle\createBlock(), OutputFormatter\createStyleFromString(), SymfonyStyle\createTable(), ConsoleApplication\doExecute(), Application\doRun(), CliDumper\dumpKey(), CliDumper\dumpScalar(), OutputFormatter\formatAndWrap(), FormatterHelper\formatBlock(), FormatterHelper\formatSection(), TemplatestyleField\getGroups(), ChromestyleField\getGroups(), StringHelper\increment(), HtmlDocument\mergeHeadData(), PlgContentLoadmodule\onContentPrepare(), PlgContentPagebreak\onContentPrepare(), Parser\parseBlockScalar(), OutputFormatterStyleStack\pop(), ManageModel\publish(), OutputFormatterStyleStack\push(), ModuleHelper\renderModule(), ColorProcessor\replaceColors(), StyleModel\setHome(), Document\setLineEnd(), OutputFormatter\setStyle(), HtmlDumper\style(), et StyleModel\unsetHome().

◆ endforeach

endforeach

◆ endif

if ( $required) endif

◆ if

if (!empty( $disabled)) if (!empty( $autofocus)) if ( $readonly||$disabled) if($dataAttribute)


Joomla CMS: Référence du fichier ByteString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier ByteString.php

Structures de données

class ByteString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier ByteStringObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier ByteStringObject.php

Structures de données

class ByteStringObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier ByteStringWithChunkObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier ByteStringWithChunkObject.php

Structures de données

class ByteStringWithChunkObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier Bzip2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier Bzip2.php

Structures de données

class Bzip2

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier CaBundle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
  • ca-bundle
  • src
Structures de données | Espaces de nommage
Référence du fichier CaBundle.php

Structures de données

class CaBundle

Espaces de nommage

Composer\CaBundle


Joomla CMS: Référence du fichier Cache.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Cache/Cache.php

Structures de données

class Cache

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier Cache.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier plugins/system/cache/src/Extension/Cache.php

Structures de données

class Cache

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Cache\Extension


Joomla CMS: Référence du fichier CacheCacheCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier CacheCacheCollector.php

Structures de données

class CacheCacheCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier CacheConnectingException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CacheConnectingException.php

Structures de données

class CacheConnectingException

Espaces de nommage

Joomla\CMS\Cache\Exception


Joomla CMS: Référence du fichier CacheController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier Cache/CacheController.php

Structures de données

class CacheController

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier CacheController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/CacheController.php

Structures de données

class CacheController

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier CacheControllerFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier CacheControllerFactory.php

Structures de données

class CacheControllerFactory

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier CacheControllerFactoryAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier CacheControllerFactoryAwareInterface.php

Structures de données

interface CacheControllerFactoryAwareInterface

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier CacheControllerFactoryAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Espaces de nommage | Fonctions | Variables
Référence du fichier CacheControllerFactoryAwareTrait.php

Espaces de nommage

Joomla\CMS\Cache

Fonctions

getCacheControllerFactory ()
setCacheControllerFactory (CacheControllerFactoryInterface $cacheControllerFactory=null)

Variables

trait CacheControllerFactoryAwareTrait


Joomla CMS: Référence du fichier CacheControllerFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier CacheControllerFactoryInterface.php

Structures de données

interface CacheControllerFactoryInterface

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier Cached.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Ge/Cached.php

Structures de données

class Cached

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519\Ge


Joomla CMS: Référence du fichier Cached.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core/Curve25519/Ge/Cached.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Ge_Cached


Joomla CMS: Référence du fichier Cached.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core32/Curve25519/Ge/Cached.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Ge_Cached


Joomla CMS: Référence du fichier CachedWordInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier CachedWordInflector.php

Structures de données

class CachedWordInflector

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier CacheExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CacheExceptionInterface.php

Structures de données

interface CacheExceptionInterface

Espaces de nommage

Joomla\CMS\Cache\Exception


Joomla CMS: Référence du fichier CachehandlerField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier CachehandlerField.php

Structures de données

class CachehandlerField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CacheModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier CacheModel.php

Structures de données

class CacheModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cache\Administrator\Model


Joomla CMS: Référence du fichier CacheStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Structures de données | Espaces de nommage
Référence du fichier CacheStorage.php

Structures de données

class CacheStorage

Espaces de nommage

Joomla\CMS\Cache


Joomla CMS: Référence du fichier CacheStorageHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier CacheStorageHelper.php

Structures de données

class CacheStorageHelper

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier CachingLanguageFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier CachingLanguageFactory.php

Structures de données

class CachingLanguageFactory

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier Calculator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
Structures de données | Espaces de nommage
Référence du fichier Calculator.php

Structures de données

class Calculator

Espaces de nommage

Brick\Math\Internal


Joomla CMS: Référence du fichier calendar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/calendar.php

Espaces de nommage

Joomla\Site

Variables

$document = Factory::getApplication()->getDocument()
$lang = Factory::getApplication()->getLanguage()
$inputvalue = ''
$attributes = array()
! $readonly | null
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') | $readonly = isset($attributes['readonly']) && $attributes['readonly'] === 'readonly'
$disabled = isset($attributes['disabled']) && $attributes['disabled'] === 'disabled'
if(is_array($attributes)) | $calendarAttrs
if(is_array($attributes)) | $calendarAttrsStr = ArrayHelper::toString($calendarAttrs)
$strings
if (! $readonly &&! $disabled)

Documentation des variables

◆ $attributes

$attributes = array()

◆ $calendarAttrs

if (is_array( $attributes)) $calendarAttrs
Valeur initiale :
= [
'data-inputfield' => $id
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93

◆ $calendarAttrsStr

if (is_array( $attributes)) $calendarAttrsStr = ArrayHelper::toString($calendarAttrs)

◆ $disabled

$disabled = isset($attributes['disabled']) && $attributes['disabled'] === 'disabled'

◆ $document

$document = Factory::getApplication()->getDocument()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Joomlaupdate\__construct(), PlgContentLoadmodule\_load(), PlgContentLoadmodule\_loadid(), PlgContentLoadmodule\_loadmod(), Factory\createRenderer(), AdministratorApplication\dispatch(), SiteApplication\dispatch(), InstallationApplication\dispatch(), ApiApplication\dispatch(), CategoryFeedView\display(), DisplayController\display(), AbstractRenderer\getDocument(), WebApplication\getDocument(), Factory\getDocument(), SyndicateHelper\getLink(), Cache\getWorkarounds(), Shortcut\initialize(), WebApplication\loadDocument(), InstallationApplication\loadDocument(), Joomla\Plugin\System\Webauthn\PluginTraits\mustDisplayButton(), Cache\onAfterRoute(), PlgSystemAccessibility\onBeforeCompileHead(), ConfigController\save(), TemplatesController\save(), HTMLHelper\script(), Cache\setWorkarounds(), HTMLHelper\stylesheet(), et Document\toArray().

◆ $inputvalue

$inputvalue = ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar().

◆ $lang

$lang = Factory::getApplication()->getLanguage()

◆ $readonly

empty ( $onchange) ? null if ( $required) if (strtoupper( $value)==='NOW') $readonly = isset($attributes['readonly']) && $attributes['readonly'] === 'readonly'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), PrefixField\getInput(), FormField\getLayoutData(), et PlgEditorNone\onDisplay().

◆ $strings

$strings
Valeur initiale :
= [
'SUNDAY', 'MONDAY', 'TUESDAY', 'WEDNESDAY', 'THURSDAY', 'FRIDAY', 'SATURDAY',
'SUN', 'MON', 'TUE', 'WED', 'THU', 'FRI', 'SAT',
'JANUARY', 'FEBRUARY', 'MARCH', 'APRIL', 'MAY', 'JUNE', 'JULY', 'AUGUST', 'SEPTEMBER', 'OCTOBER', 'NOVEMBER', 'DECEMBER',
'JANUARY_SHORT', 'FEBRUARY_SHORT', 'MARCH_SHORT', 'APRIL_SHORT', 'MAY_SHORT', 'JUNE_SHORT',
'JULY_SHORT', 'AUGUST_SHORT', 'SEPTEMBER_SHORT', 'OCTOBER_SHORT', 'NOVEMBER_SHORT', 'DECEMBER_SHORT',
'JCLOSE', 'JCLEAR', 'JLIB_HTML_BEHAVIOR_TODAY',
'JLIB_HTML_BEHAVIOR_WK',
]

Référencé par Text\_(), StringController\_getArray(), StringController\createRef(), OverridesModel\delete(), StringController\getArray(), OverrideModel\getItem(), OverridesModel\getOverrides(), StringController\getRef(), Text\getScriptStrings(), UnicodeString\join(), ByteString\join(), Text\passSprintf(), Text\plural(), StringsModel\refresh(), OverrideModel\save(), Text\script(), et Text\sprintf().

◆ if

if(! $readonly &&! $disabled)

◆ null

! $disabled null
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php, C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

Référencé par Route\_(), Input\__call(), Assertion\__callStatic(), Uri\__clone(), UnicodeString\__clone(), NullObject\__construct(), FalseObject\__construct(), UndefinedObject\__construct(), BreakObject\__construct(), TrueObject\__construct(), OctetString\__construct(), AbstractTime\__construct(), FatalError\__construct(), ArgsStub\__construct(), LinkStub\__construct(), PDOCollector\__construct(), AbstractPunycode\__construct(), ClassStub\__construct(), Request\__construct(), DecimalFractionTag\__construct(), NamePrep\__construct(), Dumper\__construct(), HelperSet\__construct(), SitePathway\__construct(), TokenBinding\__construct(), UpdateOperation\__construct(), ParagonIE_Sodium_Core_Curve25519_Ge_P2\__construct(), ParagonIE_Sodium_Core32_Curve25519_Ge_P2\__construct(), ExecuteTaskEvent\__construct(), ParagonIE_Sodium_Core_Curve25519_Ge_Precomp\__construct(), BaseInstallationModel\__construct(), Input\__construct(), Json\__construct(), ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp\__construct(), LazyAssertionException\__construct(), MonologCollector\__construct(), ConsoleOutput\__construct(), ValidationData\__construct(), ParagonIE_Sodium_Core_Curve25519_Ge_P1p1\__construct(), RandomLibAdapter\__construct(), Signature\__construct(), InputArgument\__construct(), CacheCacheCollector\__construct(), ParagonIE_Sodium_Core_Curve25519_Ge_P3\__construct(), ParagonIE_Sodium_Core32_Curve25519_Ge_P3\__construct(), FidoU2FAttestationStatementSupport\__construct(), PublicKeyCredentialLoader\__construct(), Response\__construct(), StreamOutput\__construct(), ParagonIE_Sodium_Core_Curve25519_Ge_Cached\__construct(), ParagonIE_Sodium_Core32_Curve25519_Ge_Cached\__construct(), AttestationObjectLoader\__construct(), ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1\__construct(), CMSObject\__construct(), ConfigPostProcessor\__construct(), TimeDataCollector\__construct(), LdapUserProvider\__construct(), AndroidKeyAttestationStatementSupport\__construct(), ServerRequest\__construct(), RedisStorage\__construct(), Uri\__construct(), MemcachedStorage\__construct(), PackedAttestationStatementSupport\__construct(), ProgressIndicator\__construct(), Link\__construct(), Ec2Key\__construct(), AuthenticatorAssertionResponseValidator\__construct(), UploadedFile\__construct(), InstallationApplication\__construct(), InputOption\__construct(), FieldController\__construct(), ColorProcessor\__construct(), Language\__construct(), ProgressBar\__construct(), PdoDriver\__construct(), ApiApplication\__construct(), PgsqlDriver\__construct(), AdministratorApplication\__construct(), AsciiSlugger\__construct(), JsonResponse\__construct(), Editor\__construct(), BaseDatabaseModel\__construct(), AbstractMenu\__construct(), JsonApiView\__construct(), FormController\__construct(), JavascriptRenderer\__construct(), DatabaseLogger\__construct(), ApiController\__construct(), Command\__construct(), MysqliDriver\__construct(), AbstractUri\__construct(), InstallerExtension\__construct(), DaemonApplication\__construct(), DebugClassLoader\__construct(), Indexer\__construct(), AbstractCommand\__construct(), Engine\__construct(), Table\__construct(), CMSApplication\__construct(), ErrorHandler\__construct(), Query\__construct(), AbstractCloner\__construct(), BaseController\__construct(), DatabaseDriver\__construct(), PHPMailer\__construct(), BufferingLogger\__destruct(), Query\__destruct(), FeedEntry\__get(), Feed\__get(), Input\__get(), TaskOption\__get(), Data\__get(), Date\__get(), UCMType\__get(), BaseDatabaseModel\__get(), AbstractMenu\__get(), InstallerAdapter\__get(), ConfigPostProcessor\__invoke(), Data\__isset(), FeedEntry\__set(), Feed\__set(), SubformField\__set(), SqliteQuery\__toString(), OtherObject\__toString(), SignedIntegerObject\__toString(), UnsignedIntegerObject\__toString(), SqlsrvQuery\__toString(), TagObject\__toString(), TextStringObject\__toString(), ByteStringObject\__toString(), MapObject\__toString(), ListObject\__toString(), Joomla\Database\Query\__toString(), Stream\__toString(), Uri\__toString(), DatabaseQuery\__toString(), CategoryModel\_buildContentOrderBy(), Stream\_buildContext(), RouteHelper\_findItem(), Module\_getAssetParentId(), Category\_getAssetParentId(), Content\_getAssetParentId(), Language\_getAssetParentId(), WorkflowTable\_getAssetParentId(), MenuType\_getAssetParentId(), InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), BaseDatabaseModel\_getListCount(), InstallModel\_getPackageFromFolder(), InstallModel\_getPackageFromUpload(), Categories\_load(), Editor\_loadEditor(), HtmlDocument\_parseTemplate(), FtpClient\_passive(), HtmlView\_prepareDocument(), Stream\_stream_metadata(), FtpClient\_verifyResponse(), Installer\abort(), JGrid\action(), UserModel\activate(), ModuleController\add(), ItemController\add(), FormController\add(), Application\add(), InputDefinition\addArgument(), Command\addArgument(), InputDefinition\addArguments(), PlgSampledataMultilang\addArticle(), ArrayHelper\addColumn(), PDOCollector\addConnection(), PHPMailer\addCustomHeader(), HtmlView\addCustomTypes(), ArrayInput\addLongOption(), ArgvInput\addLongOption(), ReflectionCaster\addMap(), MessagesCollector\addMessage(), Command\addOption(), Tobscure\JsonApi\addPaginationLinks(), MenusHelper\addPreset(), JWSBuilder\addSignature(), Bootstrap\addTab(), HtmlView\addToolbar(), Zip\addToZipFile(), UserHelper\addUserToGroup(), AbstractString\after(), AbstractString\afterLast(), FormBehavior\ajaxchosen(), Application\all(), Rule\allow(), NewsfeedController\allowAdd(), ArticleController\allowAdd(), AbstractWebApplication\allowCache(), DatabaseDriver\alterDbCharacterSet(), Registry\append(), Stream\appendFilter(), OutputFormatterStyle\apply(), Patcher\apply(), Stream\applyContextToStream(), Cache\appStateSupportsCaching(), AbstractUnicodeString\ascii(), QuestionHelper\ask(), ASN1\asn1map(), Symfony\Component\VarDumper\Test\assertDumpEquals(), Symfony\Component\VarDumper\Test\assertDumpMatchesFormat(), PharInvocationCollection\assertUniqueBaseName(), PharInvocationCollection\assertUniqueInvocation(), Access\assetgrouplist(), Client\authenticate(), SMTP\authenticate(), User\authorise(), QuestionHelper\autocomplete(), PHPMailer\base64EncodeWrapMB(), PharExtensionInterceptor\baseFileContainsPharExtension(), PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues(), ItemModel\batchCopy(), CategoryModel\batchCopy(), AbstractString\before(), AbstractString\beforeLast(), CompletionInput\bind(), DataObject\bind(), Form\bind(), Registry\bindData(), SqlsrvStatement\bindParam(), UserModel\block(), Router\build(), StandardRules\build(), MysqlChangeItem\buildCheckQuery(), PostgresqlChangeItem\buildCheckQuery(), SqlsrvChangeItem\buildCheckQuery(), ContactModel\buildContactExtendedData(), Container\buildObject(), SiteRouter\buildPaginationData(), SiteRouter\buildSefRoute(), WebAssetManager\calculateOrderOfActiveAssets(), PlgUserProfile\calendar(), HTMLHelper\calendar(), DatabaseQuery\call(), LegacyInstallerScript\callOnScript(), MailController\cancel(), TaskController\cancel(), ModuleController\cancel(), CategoryController\cancel(), ItemController\cancel(), OverrideController\cancel(), ComponentController\cancel(), ProfileController\cancel(), FormController\cancel(), LevelModel\canDelete(), TransitionModel\canDelete(), StageModel\canDelete(), TransitionModel\canEditState(), StageModel\canEditState(), JWKSet\canKeyBeUsedWithAlgorithm(), TemplateHelper\canUpload(), UpdateController\captive(), UpdateModel\captiveFileExists(), UpdateModel\captiveLogin(), StubCaster\castEnum(), ExceptionCaster\castFrameStub(), AbstractCloner\castObject(), DsCaster\castPairStub(), ReflectionCaster\castParameter(), ReflectionCaster\castReflectionGenerator(), SymfonyCaster\castRequest(), PgSqlCaster\castResult(), ExceptionCaster\castTraceStub(), XmlReaderCaster\castXmlReader(), SqliteQuery\charLength(), SqlsrvQuery\charLength(), DatabaseQuery\charLength(), Update\check(), AuthenticatorAttestationResponseValidator\check(), MenuTable\check(), TagTable\check(), CoreContent\check(), AuthenticatorAssertionResponseValidator\check(), BannerTable\check(), GroupTable\check(), Menu\check(), Module\check(), ContactTable\check(), Content\check(), User\check(), DebugClassLoader\checkAnnotations(), Captcha\checkAnswer(), CertificateToolbox\checkAttestationMedata(), PlgSystemSef\checkBuffer(), DebugClassLoader\checkCase(), DebugClassLoader\checkClass(), DebugClassLoader\checkClasses(), MailHelper\checkContent(), LibraryAdapter\checkExtensionInFilesystem(), Table\checkIn(), Table\checkOut(), JWSVerifier\checkPayload(), JSONGeneralSerializer\checkPayloadEncoding(), ConfigurationModel\checkTestingSampledata(), Stream\chmod(), SymfonyStyle\choice(), Access\cleanAssetKey(), HTMLHelper\cleanImageURL(), ModuleHelper\cleanModuleList(), InputFilter\cleanTags(), ErrorHandler\cleanTrace(), Table\cleanup(), UpdateModel\cleanUp(), Collection\cleanupAttributes(), Joomla\Database\Query\clear(), ProgressBar\clear(), DatabaseQuery\clear(), User\clearAccessRights(), FieldsHelper\clearFieldsCache(), clearFileInOPCache(), Access\clearStatics(), Joomla\CMS\Tag\clearTagsHelper(), QuestionHelper\cloneInputStream(), AbstractCloner\cloneVar(), CallbackStream\close(), DatabaseHandler\close(), LdapClient\close(), Stream\close(), SMTP\close(), PharInvocationCollection\collect(), AggregatedCollector\collect(), DebugBar\collect(), Propel2Collector\collect(), PharStreamWrapper\collectInvocation(), PDOCollector\collectPDO(), DatabaseQuery\columns(), SymfonyStyle\comment(), ParagonIE_Sodium_Core_Util\compare(), DatabaseModel\compareUpdateVersion(), Application\complete(), LengthCalculator\computeLength(), SqliteQuery\concatenate(), SqlsrvQuery\concatenate(), Joomla\Database\Query\concatenate(), DatabaseQuery\concatenate(), ListCommand\configure(), HelpCommand\configure(), DumpCompletionCommand\configure(), LintCommand\configure(), ServerDumpCommand\configure(), DebugRouterCommand\configure(), ExtensionInstallCommand\configure(), ExtensionDiscoverInstallCommand\configure(), ExtensionsListCommand\configure(), RemoveOldFilesCommand\configure(), FinderIndexCommand\configure(), ChangeUserPasswordCommand\configure(), ExportCommand\configure(), DeleteUserCommand\configure(), ImportCommand\configure(), GetConfigurationCommand\configure(), AddUserToGroupCommand\configure(), RemoveUserFromGroupCommand\configure(), AddUserCommand\configure(), SetConfigurationCommand\configureIO(), ExtensionRemoveCommand\configureIO(), FinderIndexCommand\configureIO(), AbstractConnection\configureOptions(), SqliteDriver\connect(), PdoDriver\connect(), MysqlDriver\connect(), MysqliDriver\connect(), SocketTransport\connect(), Socket\connect(), FtpClient\connect(), SSH2\connect(), JoomlaInstallerScript\contactItems(), AbstractString\containsAny(), FromUtf8\convert(), ToUtf8\convert(), TranscodeUnicode\convert(), ClassNotFoundErrorEnhancer\convertFileToClass(), AbstractIdnaConvert\convertUrl(), Folder\copy(), File\copy(), Stream\copy(), Installer\copyFiles(), ParagonIE_Sodium_Core_Salsa20\core_salsa20(), NewsfeedsHelper\countTagItems(), ContentComponent\countTagItems(), EpochTag\create(), NegativeBigIntegerTag\create(), PositiveBigIntegerTag\create(), Base16EncodingTag\create(), Base64EncodingTag\create(), Base64UrlEncodingTag\create(), TimestampTag\create(), SimpleObject\create(), BigFloatTag\create(), JWSLoaderFactory\create(), JWSBuilder\create(), Folder\create(), WebAssetRegistry\createAsset(), SignedIntegerObject\createBigInteger(), UnsignedIntegerObject\createBigInteger(), SymfonyStyle\createBlock(), ConfigurationModel\createConfiguration(), MVCFactory\createController(), DatabaseDriver\createDatabase(), TokenBinding\createFormArray(), PublicKeyCredentialRpEntity\createFromArray(), RogueListEntry\createFromArray(), Version\createFromArray(), PatternAccuracyDescriptor\createFromArray(), RgbPaletteEntry\createFromArray(), PublicKeyCredentialUserEntity\createFromArray(), ExtensionDescriptor\createFromArray(), CodeAccuracyDescriptor\createFromArray(), MetadataTOCPayload\createFromArray(), AttestedCredentialData\createFromArray(), VerificationMethodDescriptor\createFromArray(), AuthenticatorSelectionCriteria\createFromArray(), EcdaaTrustAnchor\createFromArray(), PublicKeyCredentialRequestOptions\createFromArray(), BiometricAccuracyDescriptor\createFromArray(), BiometricStatusReport\createFromArray(), StatusReport\createFromArray(), DisplayPNGCharacteristicsDescriptor\createFromArray(), PublicKeyCredentialCreationOptions\createFromArray(), MetadataTOCPayloadEntry\createFromArray(), MetadataStatement\createFromArray(), SignedIntegerObject\createFromGmpValue(), UnsignedIntegerObject\createFromGmpValue(), FlattenException\createFromThrowable(), PHPMailer\createHeader(), LanguageHelper\createLanguageList(), Factory\createMailer(), MVCFactory\createModel(), BaseController\createModel(), ContenthistoryHelper\createObjectArray(), Psr17Factory\createResponse(), PublicKeyCredentialLoader\createResponse(), Psr17Factory\createServerRequest(), MetadataManager\createSessionRecord(), Builder\createSignature(), OutputFormatter\createStyleFromString(), MVCFactory\createTable(), TemplateModel\createTemplateOverride(), AsciiSlugger\createTransliterator(), Laminas\Diactoros\createUploadedFile(), UploadedFileFactory\createUploadedFile(), Psr17Factory\createUploadedFile(), Laminas\Diactoros\createUri(), Help\createUrl(), LegacyFactory\createView(), MVCFactory\createView(), Image\cropResize(), ParagonIE_Sodium_Compat\crypto_kx_client_session_keys(), ParagonIE_Sodium_Compat\crypto_kx_server_session_keys(), HTMLHelper\date(), LayoutHelper\debug(), Language\debugFile(), ParagonIE_Sodium_Core_Util\declareScalarType(), SymfonyStyle\definitionList(), MenuType\delete(), MethodController\delete(), DatabaseQuery\delete(), Stream\delete(), CoreContent\deleteByContentId(), ApiController\deleteFiles(), Uri\delVar(), HtmlDescriptor\describe(), CliDescriptor\describe(), JsonDescriptor\describeApplication(), XmlDescriptor\describeApplication(), MarkdownDescriptor\describeApplication(), TextDescriptor\describeApplication(), TextDescriptor\describeInputArgument(), MarkdownDescriptor\describeInputDefinition(), TextDescriptor\describeInputOption(), Manifest\deserializeMetaData(), Manager\destroy(), CallbackStream\detach(), Stream\detach(), Helper\determineBaseFile(), CronExpression\determineTimeZone(), JavascriptRenderer\disableControl(), Connection\disconnect(), DatabaseDriver\disconnect(), Installer\discover_install(), Dispatcher\dispatch(), AdministratorApplication\dispatch(), SiteApplication\dispatch(), ApiApplication\dispatch(), AbstractApplication\dispatchEvent(), CategoryFeedView\display(), FeedView\display(), DisplayController\display(), HtmlView\display(), MethodsController\display(), Captcha\display(), Editor\display(), Microdata\display(), ProgressBar\display(), ConsentsController\displayItem(), JsonapiView\displayList(), ManageController\displayList(), UsersController\displayList(), PlgContentVote\displayVotingData(), BigDecimal\dividedBy(), QuestionHelper\doAsk(), VarCloner\doClone(), TasksRunCommand\doExecute(), ApiApplication\doExecute(), AdministratorApplication\doExecute(), SiteApplication\doExecute(), Application\doExecute(), Parser\doParse(), Application\doRun(), Application\doRunCommand(), VarDumper\dump(), Dumper\dump(), Inline\dump(), AbstractDumper\dump(), DataObject\dump(), DebugBarVarDumper\dump(), DataSet\dump(), JavascriptRenderer\dumpAssets(), Data\dumpChildren(), JavascriptRenderer\dumpHeadAssets(), Data\dumpItem(), CliDumper\dumpKey(), StyleModel\duplicate(), ModuleModel\duplicate(), OverrideController\edit(), TemplateController\edit(), Icon\edit(), ItemController\edit(), FormController\edit(), PrivateKey\emsa_pss_encode(), PublicKey\emsa_pss_verify(), PropelCollector\enablePropelProfiling(), ASN1\encode_der(), ASN1\encodeDER(), SSH2\encryption_algorithm_to_crypt_instance(), SSH2\encryption_algorithm_to_key_size(), UnicodeString\endsWith(), ByteString\endsWith(), UndefinedFunctionErrorEnhancer\enhance(), UndefinedMethodErrorEnhancer\enhance(), ClassNotFoundErrorEnhancer\enhance(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), CMSApplication\enqueueMessage(), CliDumper\enterHash(), Stream\eof(), UnicodeString\equalsTo(), LdapUser\eraseCredentials(), BaseLayout\escape(), HtmlView\escape(), Inline\evaluateScalar(), English\exception1(), English\exception2(), DatabaseQuery\exec(), Backgroundfill\execute(), CaptiveController\execute(), MethodController\execute(), MethodsController\execute(), CommandTester\execute(), HelpCommand\execute(), Query\execute(), ServerDumpCommand\execute(), LintCommand\execute(), TraceablePDOStatement\execute(), AbstractCommand\execute(), MysqliStatement\execute(), SqlsrvStatement\execute(), Application\execute(), PdoDriver\execute(), DatabaseDriver\execute(), MysqliDriver\executeUnpreparedQuery(), Query\explained(), RSAKey\exponentiate(), FieldsHelper\extract(), Bzip2\extract(), Archive\extract(), Gzip\extract(), Tar\extract(), Zip\extractCustom(), Reader\extractData(), Helper\extractIdReferenceFromHref(), RdKafkaCaster\extractMetadata(), ApplicationDescription\extractNamespace(), Application\extractNamespace(), ExceptionCaster\extractSource(), Microdata\fallback(), ArticleModel\featured(), PdoStatement\fetch(), MysqliStatement\fetch(), AjaxController\fetchAssociations(), StandardButton\fetchButton(), SqlsrvStatement\fetchColumn(), MysqliStatement\fetchColumn(), DatabaseModel\fetchSchemaCache(), Scheduler\fetchTaskRecord(), Stream\filesize(), Table\fillNextRows(), TelFilter\filter(), UnsetFilter\filter(), Caster\filter(), SubformField\filter(), FormField\filter(), Uri\filterPort(), Uri\filterQuery(), Bootup\filterRequestUri(), FileStorage\find(), PharInvocationResolver\findByAlias(), PharInvocationCollection\findByCallback(), Resolver\findByElement(), CompleteCommand\findCommand(), JoomlaInstallerScript\finderItems(), DebugClassLoader\findFile(), ClassLoader\findFile(), PharInvocationResolver\findInBaseNames(), RouteHelper\findItem(), Installer\findManifest(), AbstractNegotiator\findMatches(), SimpleMetadataStatementRepository\findOneByAAGUID(), MetadataRepository\findOneByAAGUID(), SimpleMetadataStatementRepository\findOneByAAGUIDFromServices(), SimpleMetadataStatementRepository\findOneByAAGUIDFromSingleStatements(), CredentialRepository\findOneByCredentialId(), TaskOptions\findOption(), DatabaseModel\fixUpdateVersion(), FlattenException\flattenArgs(), NullOutputFormatter\format(), Date\format(), DatabaseQuery\format(), OutputFormatter\formatAndWrap(), DataFormatter\formatBytes(), GetConfigurationCommand\formatConfigValue(), CredentialRepository\formatDate(), HtmlErrorRenderer\formatFile(), OptionsResolver\formatOptions(), ExceptionsCollector\formatThrowableData(), OptionsResolver\formatValue(), Joomla\Database\Query\forShare(), Joomla\Database\Query\forUpdate(), DatabaseQuery\from(), LazyString\fromCallable(), ServerRequestFactory\fromGlobals(), Response\fromJson(), Helper\ftpChmod(), ParagonIE_Sodium_Core32_Curve25519\ge_select(), DefaultTimeGenerator\generate(), Image\generateThumbs(), ViewController\get(), PageController\get(), Calculator\get(), PdoStorage\get(), ValidationData\get(), AbstractView\get(), Http\get(), Categories\get(), Registry\get(), SFTP\get(), Php80\get_debug_type(), SMTP\get_lines(), Php80\get_resource_id(), Joomla\getActionLogParams(), ProviderManager\getAdapter(), ApiController\getAdapter(), Pagination\getAdditionalUrlParam(), RouteHelper\getAdvancedRoute(), InputDefinition\getArgumentCount(), Input\getArray(), Input\getArrayRecursive(), JavascriptRenderer\getAsseticCollection(), FieldTable\getAssetId(), Access\getAssetId(), Access\getAssetName(), Access\getAssetRules(), AssociationHelper\getAssociations(), FlattenException\getAsString(), Server\getAttestationStatementSupportManager(), Entry\getAttribute(), FormField\getAttribute(), Form\getAttribute(), Entry\getAttributeKey(), User\getAuthorisedGroups(), User\getAuthorisedViewLevels(), Uri\getAuthority(), Question\getAutocompleterValues(), HttpFactory\getAvailableDriver(), ProgressBar\getBarOffset(), AbstractNegotiator\getBest(), Nyholm\Psr7\getBody(), QuickIconHelper\getButtons(), UpdateModel\getCheckForSelfUpdate(), MVCFactory\getClassName(), ApplicationHelper\getClientInfo(), DebugBarVarDumper\getClonerOptions(), UpdateModel\getCollectionDetailsUrls(), MysqlImporter\getColumnSql(), MysqliImporter\getColumnSql(), LazyCommand\getCommand(), ApplicationDescription\getCommands(), MessagesModel\getComponentOptions(), LinkStub\getComposerRoot(), Factory\getConfig(), Adapter\getConnection(), RedisStorage\getConnection(), MemcachedStorage\getConnection(), Terminal\getConsoleMode(), CliContextProvider\getContext(), RequestContextProvider\getContext(), SourceContextProvider\getContext(), ExtensionHelper\getCoreExtensionIds(), ClientHelper\getCredentials(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), Cursor\getCurrentPosition(), DebugBar\getCurrentRequestId(), ProfileModel\getData(), InstalledModel\getData(), DebugBar\getData(), RegistrationModel\getData(), MessagesCollector\getDataFormatter(), AbstractDataCollector\getDataFormatter(), DataCollector\getDataFormatter(), DebugHelper\getDebugActions(), Joomla\Component\Media\Administrator\Provider\getDefaultAdapterName(), QuestionHelper\getDefaultAnswer(), VarDumper\getDefaultContextProviders(), DataCollector\getDefaultDataFormatter(), AbstractDataCollector\getDefaultDataFormatter(), Command\getDefaultDescription(), FileLayout\getDefaultIncludePaths(), ConsoleApplication\getDefaultInputDefinition(), Application\getDefaultInputDefinition(), Command\getDefaultName(), AbstractCommand\getDefaultName(), DataCollector\getDefaultVarDumper(), LintCommand\getDirectoryIterator(), Symfony\Component\Console\Tester\getDisplay(), DatabaseFactory\getDriver(), Symfony\Component\VarDumper\Test\getDump(), DebugBarVarDumper\getDumperOptions(), HtmlDumper\getDumpHeader(), EditorField\getEditor(), Result\getElement(), Helper\getElementHref(), JWS\getEncodedPayload(), NullObject\getEncodedValue(), Mbstring\getEncoding(), Adapter\getEntryManager(), CaBundle\getEnvVariable(), CMSObject\getError(), TracedStatement\getErrorCode(), TracedStatement\getErrorMessage(), CommandErrorEvent\getExitCode(), RSAKey\getExponent(), CronExpression\getExpression(), AssociationsHelper\getExtensionHelper(), ExtensionHelper\getExtensionRecord(), AuthenticatorData\getExtensions(), AuthenticatorAssertionResponseValidator\getFacetId(), FeedFactory\getFeed(), FieldsHelper\getFields(), HtmlView\getFields(), FieldsHelper\getFieldTypes(), FieldModel\getFieldValue(), HtmlErrorRenderer\getFileRelative(), ApiModel\getFiles(), WorkflowsModel\getFilterForm(), ListModel\getFilterForm(), FieldsModel\getFilterForm(), FinderHelper\getFinderPluginId(), ArrayInput\getFirstArgument(), ArgvInput\getFirstArgument(), PlgEditorCodemirror\getFontInfo(), OverrideModel\getForm(), TaskModel\getForm(), ArticleModel\getForm(), ProgressBar\getFormatDefinition(), ProgressIndicator\getFormatDefinition(), FieldsPlugin\getFormPath(), ContenthistoryHelper\getFormValues(), UserMessagesField\getGroups(), UserModel\getGroups(), Terminal\getHeight(), HelperFactory\getHelper(), Command\getHelper(), DebugBar\getHttpDriver(), CssMenu\getIconClass(), Language\getIgnoredSearchWords(), Image\getImageFileProperties(), Parameters\getInclude(), OptionsResolver\getInfo(), ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer(), WebAssetManager\getInlineRelation(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), CaptchaField\getInput(), SubformField\getInput(), ErrorListener\getInputString(), JWSVerifier\getInputToVerify(), InstallerHelper\getInstallationXML(), InstalledVersions\getInstalled(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), PlgInstallerWebinstaller\getInstallFrom(), InstalledVersions\getInstallPath(), Inflector\getInstance(), UserGroupsHelper\getInstance(), Categories\getInstance(), ContainerResource\getInstance(), FtpClient\getInstance(), BaseController\getInstance(), DatabaseDriver\getInstance(), CMSApplication\getInstance(), IpHelper\getIp(), AdapterModel\getItem(), UserModel\getItem(), AssociationsHelper\getItem(), TagModel\getItem(), AbstractMenu\getItem(), PluginModel\getItem(), CategoryModel\getItem(), ContactModel\getItem(), NewsfeedModel\getItem(), StyleModel\getItem(), FieldModel\getItem(), ArticleModel\getItem(), ItemModel\getItem(), ModuleModel\getItem(), RouteHelper\getItemid(), Adapter\getItemMenuTitle(), SearchModel\getItems(), PositionsModel\getItems(), CategoriesModel\getItems(), SelectModel\getItems(), SiteMenu\getItems(), CategoryModel\getItems(), ArticlesModel\getItems(), DatabaseDriver\getIterator(), DebugBar\getJavascriptRenderer(), JavascriptRenderer\getJsInitializationCode(), RequestController\getJson(), MetadataRepository\getKnownAuthenticators(), PlgSystemLanguageFilter\getLanguageCookie(), LoginHelper\getLanguageList(), LanguagesModel\getLanguages(), File\getLastErrorMessage(), UserField\getLayoutData(), FormField\getLayoutData(), Parameters\getLimit(), Parser\getLineTag(), SyndicateHelper\getLink(), ArticlesCategoriesHelper\getList(), LatestHelper\getList(), PopularHelper\getList(), Dispatcher\getListeners(), FieldsModel\getListQuery(), AssociationsModel\getListQuery(), UpdatesitesModel\getListQuery(), ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\getLoader(), LoginModel\getLoginModule(), Language\getLowerLimitSearchWord(), Version\getMediaVersion(), CMSApplication\getMenu(), InstallationApplication\getMenu(), MenusHelper\getMenuItems(), MenusHelper\getMenuLinks(), DumpServer\getMessages(), CallbackStream\getMetadata(), Stream\getMetadata(), LanguageHelper\getMetadata(), SingleMetadata\getMetadataStatement(), Container\getMethodArgs(), CaptiveModel\getMethodImage(), AbstractView\getModel(), ModuleHelper\getModule(), Prime\getNAFPoints(), BaseModel\getName(), RouterView\getName(), BaseController\getName(), ApplicationDescription\getNamespaces(), Command\getNativeDefinition(), DayOfMonthField\getNearestWeekday(), Parser\getNextEmbedBlock(), SystemNodeProvider\getNode(), FallbackNodeProvider\getNode(), SimpleObject\getNormalizedData(), SignedIntegerObject\getNormalizedData(), UnsignedIntegerObject\getNormalizedData(), ASNObject\getNumberOfLengthOctets(), OAuth\getOauth64(), DataSet\getObjectsKeys(), Parameters\getOffset(), Input\getOption(), CompletionInput\getOptionFromToken(), ComponentsCategoryField\getOptions(), ConfigComponentsField\getOptions(), SubfieldsField\getOptions(), TagField\getOptions(), Image\getOrientation(), Pagination\getPagesCounter(), Pagination\getPagesLinks(), CategoryModel\getPagination(), Pagination\getPaginationPages(), OptionsResolver\getParameterClassName(), ArgsStub\getParameters(), SiteApplication\getParams(), Installer\getParams(), AsciiSlugger\getParentLocale(), HoursField\getPastTransition(), ApiController\getPath(), LanguagesModel\getPath(), PlgSampledataMultilang\getPath(), SysinfoModel\getPhpInfoArray(), ChecksModel\getPhpOptions(), UpdateModel\getPhpOptions(), PlgQuickiconPhpVersionCheck\getPhpSupport(), Authentication\getPKCredentialRequestOptions(), ProgressBar\getPlaceholderFormatterDefinition(), ProgressIndicator\getPlaceholderFormatterDefinition(), Language\getPluralSuffixes(), Uri\getPort(), MenusHelper\getPresets(), InstalledVersions\getPrettyVersion(), DataObject\getProperty(), Symfony\Contracts\Service\getProvidedServices(), AbstractUri\getQuery(), RandomImageHelper\getRandomImage(), InstalledVersions\getRawData(), FormController\getRedirectToItemAppend(), CategoriesController\getRedirectToListAppend(), InstalledVersions\getReference(), X509\getRegisteredExtension(), AbstractSerializer\getRelationship(), JavascriptRenderer\getRelativeRoot(), TimeDataCollector\getRequestDuration(), ProfileCollector\getRequestDuration(), DebugBar\getRequestIdGenerator(), Nyholm\Psr7\getRequestTarget(), Laminas\Diactoros\getRequestTarget(), Query\getResource(), Container\getResource(), CurlTransport\getResponse(), Curl\getResponse(), Pagination\getResultsCounter(), ArticleController\getReturnPage(), ContactController\getReturnPage(), CronExpression\getRunDate(), Stream\gets(), LdapUser\getSalt(), RSA\getSaltLength(), Language\getSearchDisplayedCharactersNumber(), RouteHelper\getSearchRoute(), SMTP\getServerExt(), Joomla\Application\getSession(), ServiceProviderInterface\getSession(), JoomlaHttpDriver\getSessionValue(), ContentHistory\getSha1(), ReflectionCaster\getSignature(), Multilanguage\getSiteHomePages(), Authentication\getSiteIcon(), CallbackStream\getSize(), Stream\getSize(), SMTP\getSMTPConnection(), Parameters\getSort(), Patcher\getSource(), Joomla\CMS\MVC\Model\getStageForNewItem(), Joomla\CMS\MVC\Model\getState(), ActionButton\getState(), Indexer\getState(), Propel2Collector\getStatements(), StatsAdminHelper\getStats(), Symfony\Component\Console\Tester\getStatusCode(), PlgFieldsSubform\getSubfieldsFromField(), X509\getSubjectDNProp(), Mbstring\getSubpart(), Symfony\Contracts\Service\getSubscribedServices(), AssociationsHelper\getSupportedExtension(), CaBundle\getSystemCaRootBundlePath(), PgsqlDriver\getTableColumns(), Joomla\CMS\Categories\getTableNameForSection(), Tar\getTarInfo(), TaskModel\getTask(), Result\getTaxonomy(), PopularHelper\getTitle(), LatestHelper\getTitle(), Builder\getToken(), CollectedClientData\getTokenBinding(), PhpToken\getTokenName(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), ModulesHelper\getTranslatedModulePosition(), Data\getType(), MenutypesModel\getTypeOptionsFromManifest(), PlgSystemStats\getUniqueId(), UpdateModel\getUpdateInformation(), UpdateAdapter\getUpdateSiteResponse(), Language\getUpperLimitSearchWord(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), AuthenticatorAssertionResponse\getUserHandle(), CMSApplication\getUserState(), ListModel\getUserStateFromRequest(), CMSApplication\getUserStateFromRequest(), DefaultTimeGenerator\getValidNode(), Workflow\getValidTransition(), ArrayHelper\getValue(), ArraySerializer\getValueFromKey(), Router\getVar(), MessagesCollector\getVarDumper(), DataCollector\getVarDumper(), PharInvocation\getVariable(), InstalledVersions\getVersion(), Uuid\getVersion(), Terminal\getWidth(), Cache\getWorkarounds(), TwigProfileCollector\getXdebugLink(), NamespacedTwigProfileCollector\getXdebugLink(), Grapheme\grapheme_strlen(), Grapheme\grapheme_substr(), DatabaseQuery\group(), ArticlesCategoryHelper\groupBy(), Select\groupedlist(), ValidAt\guardLeeway(), OpenHandler\handle(), ErrorHandler\handleError(), ErrorHandler\handleException(), ErrorHandler\handleFatalError(), RssParser\handleImage(), RssParser\handleWebmaster(), Entry\hasAttribute(), ClientHelper\hasCredentials(), Core\hashEquals(), Subject\hasInfiniteLoop(), Language\hasKey(), Joomla\CMS\Tree\hasParent(), Terminal\hasSttyAvailable(), DatabaseQuery\having(), ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), Http\head(), AbstractWebApplication\header(), Table\hit(), RuntimeTests\HKDFTestVector(), ParagonIE_Sodium_Core_HSalsa20\hsalsa20(), Iconv\iconv_mime_decode(), Iconv\iconv_mime_decode_headers(), Iconv\iconv_strlen(), Iconv\iconv_strpos(), Iconv\iconv_strrpos(), Iconv\iconv_substr(), HTMLHelper\image(), PluginHelper\importPlugin(), HoursField\increment(), Indexer\index(), CodePointString\indexOf(), UnicodeString\indexOf(), ByteString\indexOf(), AbstractString\indexOf(), CodePointString\indexOfLast(), UnicodeString\indexOfLast(), ByteString\indexOfLast(), AbstractString\indexOfLast(), ParagonIE_Sodium_Core32_BLAKE2b\init(), ParagonIE_Sodium_Core_BLAKE2b\init(), AdminModel\initBatch(), Terminal\initDimensions(), Editor\initialise(), DataSet\initialise(), InstallationApplication\initialiseApp(), SiteApplication\initialiseApp(), Inline\initialize(), Manager\initialize(), Laminas\Diactoros\initialize(), Symfony\Component\Console\Tester\initOutput(), DatabaseQuery\insert(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), DatabaseDriver\insertObject(), InstallModel\install(), LanguageAdapter\install(), Manager\instance(), Select\integerlist(), ConsoleLogger\interpolate(), Assertion\ip(), Helper\isAbsolutePath(), PlgSystemDebug\isAuthorisedDisplayDebug(), DebugBar\isDataPersisted(), ModuleHelper\isEnabled(), Token\isExpired(), CMSApplication\isHttpsForced(), AbstractField\isInIncrementsOfRanges(), QuestionHelper\isInteractiveInput(), Assertion\isJsonString(), ApiModel\isMediaFile(), TagField\isNested(), Uri\isNonStandardPort(), CaBundle\isOpensslParseSafe(), JWSVerifier\isPayloadEmpty(), TracedStatement\isPrepared(), LintCommand\isReadable(), PlgInstallerWebinstaller\isRTL(), HoursField\isSatisfiedBy(), TracedStatement\isSuccess(), Task\isSuccess(), FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), Task\isValidState(), ByteString\join(), DatabaseQuery\join(), JsonResponse\jsonEncode(), PublicKeyCredentialEntity\jsonSerialize(), PublicKeyCredentialRpEntity\jsonSerialize(), AuthenticatorSelectionCriteria\jsonSerialize(), AttestedCredentialData\jsonSerialize(), PublicKeyCredentialRequestOptions\jsonSerialize(), PublicKeyCredentialCreationOptions\jsonSerialize(), SSH2\key_exchange(), Helper\length(), Joomla\Database\Query\limit(), Menu\linkOptions(), FtpClient\listDetails(), DumpServer\listen(), FtpClient\listNames(), AttestationObjectLoader\load(), User\load(), MetadataRepository\load(), AsymmetricKey\load(), ModuleHelper\load(), Server\loadAndCheckAssertionResponse(), DatabaseDriver\loadAssoc(), ContainerAwareToolbarFactory\loadButtonClass(), JLoader\loadByPsr(), ClassLoader\loadClass(), DaemonApplication\loadConfiguration(), X509\loadCRL(), X509\loadCSR(), InstallationApplication\loadDocument(), Form\loadField(), BannerModel\loadFormData(), GroupModel\loadFormData(), CategoryModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), FieldModel\loadFormData(), Changelog\loadFromXml(), Update\loadFromXml(), AssociationsHelper\loadHelper(), ComponentAdapter\loadLanguage(), DatabaseDriver\loadObject(), MenusHelper\loadPreset(), DatabaseDriver\loadResult(), DatabaseDriver\loadRow(), DatabaseDriver\loadRowList(), X509\loadSPKAC(), HtmlView\loadTemplate(), LdapUserProvider\loadUser(), LdapUserProvider\loadUserByIdentifier(), X509\loadX509(), Symfony\Component\Console\Command\lock(), DelegatingPsrLogger\log(), PropelCollector\log(), SSH2\login(), SSH2\login_helper(), DisplayController\logout(), UserController\logout(), PHPMailer\mailPassthru(), PHPMailer\mailSend(), Cache\makeId(), Http\makeTransportRequest(), Laminas\Diactoros\marshalUriFromSapi(), Negotiator\match(), LanguageNegotiator\match(), AbstractNegotiator\match(), BigNumber\max(), Mbstring\mb_check_encoding(), Mbstring\mb_convert_case(), Mbstring\mb_convert_encoding(), Mbstring\mb_decode_numericentity(), Mbstring\mb_detect_encoding(), Mbstring\mb_detect_order(), Mbstring\mb_encode_numericentity(), Mbstring\mb_http_output(), Mbstring\mb_internal_encoding(), Mbstring\mb_language(), Php72\mb_ord(), Mbstring\mb_str_split(), Mbstring\mb_substitute_character(), Mbstring\mb_substr(), MemcachedStorage\memcachedGetMulti(), ParagonIE_Sodium_Compat\memzero(), ConfigPostProcessor\merge(), Command\mergeApplicationDefinition(), DebugBarVarDumper\mergeClonerOptions(), DebugBarVarDumper\mergeDumperOptions(), ContenthistoryHelper\mergeLabels(), BigNumber\min(), GmpCalculator\modInverse(), Calculator\modInverse(), BigInteger\modInverse(), File\move(), Stream\move(), Table\move(), Nested\moveByReference(), UploadedFile\moveTo(), Prime\multiplyAddPoints(), Joomla\Plugin\System\Webauthn\PluginTraits\mustDisplayButton(), DataSet\next(), ExecRuleHelper\nextExec(), Normalizer\normalize(), UnicodeString\normalize(), PHPMailer\normalizeBreaks(), Laminas\Diactoros\normalizeServer(), DebugClassLoader\normalizeType(), Laminas\Diactoros\normalizeUploadedFiles(), Assertion\notNull(), Joomla\Database\Query\noWait(), Assertion\null(), AssertionChain\nullOr(), PluginController\oauthcallback(), OutputFilter\objectHtmlSafe(), Joomla\Database\Query\offset(), Collection\offsetGet(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetGet(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetGet(), DataSet\offsetGet(), OptionsResolver\offsetGet(), Construct\offsetSet(), Event\offsetSet(), DataSet\offsetSet(), PlgSystemDebug\onAfterDisconnect(), PlgSystemDebug\onBeforeCompileHead(), PlgCaptchaRecaptcha\onCheckAnswer(), ErrorListener\onConsoleError(), ErrorListener\onConsoleTerminate(), Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgMediaActionResize\onContentBeforeSave(), Joomla\onContentChangeState(), PlgContentLoadmodule\onContentPrepare(), PlgContentContact\onContentPrepare(), PlgUserProfile\onContentPrepareData(), FieldsPlugin\onContentPrepareForm(), FieldsPlugin\onCustomFieldsPrepareDom(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), BigDecimal\one(), BigRational\one(), BigInteger\one(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterSave(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), PlgFinderCategories\onFinderChangeState(), PlgAuthenticationCookie\onUserAfterLogin(), PlgSystemLanguageFilter\onUserAfterSave(), PlgUserJoomla\onUserLogout(), Stream\open(), Select\option(), Http\options(), Select\options(), DatabaseQuery\order(), Core\ourStrlen(), Core\ourSubstr(), Stdout\out(), Xml\out(), ProgressBar\overwrite(), CMSPlugin\parameterImplementsEventInterface(), Inline\parse(), ArgvInput\parse(), Parser\parse(), ArgvInput\parseArgument(), Parser\parseFile(), LanguageHelper\parseIniFile(), ArgvInput\parseLongOption(), Inline\parseMapping(), Installer\parseMedia(), SiteRouter\parsePaginationData(), BaseAccept\parseParameters(), WebAssetRegistry\parseRegistryFile(), Util\parseRelationshipPaths(), Inline\parseScalar(), SiteRouter\parseSefRoute(), Inline\parseSequence(), ArgvInput\parseShortOption(), ArgvInput\parseShortOptionSet(), Inline\parseTag(), Uri\parseUri(), MenusHelper\parseXmlNode(), DebugClassLoader\patchMethod(), OutputFormatterStyleStack\pop(), Bootstrap\popover(), StageModel\populateState(), TransitionModel\populateState(), WorkflowModel\populateState(), StagesModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), WorkflowsModel\populateState(), UpdateModel\populateState(), ManageModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), CategoryModel\populateState(), DatabaseModel\populateState(), UpdatesitesModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), ListHelper\positions(), ModuleController\postSaveHook(), Access\preloadComponents(), Content\prepare(), ASCII\prepareAsciiAndExtrasMaps(), ASCII\prepareAsciiExtras(), ASCII\prepareAsciiMaps(), HtmlView\prepareDocument(), Symfony\Component\VarDumper\Test\prepareExpectation(), MultibyteStringConverter\preparePositiveInteger(), ECSignature\preparePositiveInteger(), ArticleModel\prepareTable(), Stream\prependFilter(), Menu\preprocess(), MenuRules\preprocess(), CssMenu\preprocess(), MenusHelper\preprocess(), GroupModel\preprocessForm(), NewsfeedModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), FieldModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), Decoder\process(), AddConsoleCommandPass\process(), Query\processDates(), RssParser\processFeedEntry(), Decoder\processFinite(), JSONGeneralSerializer\processHeaders(), JSONGeneralSerializer\processIsPayloadEncoded(), JSONGeneralSerializer\processPayload(), ResetModel\processResetComplete(), JWSLoader\processSignature(), Query\processString(), PackedAttestationStatementSupport\processWithCertificate(), TPMAttestationStatementSupport\processWithCertificate(), TraceablePDO\profileCall(), SymfonyStyle\progressFinish(), AdminController\publish(), StageModel\publish(), Languages\published(), Redirect\published(), ApiController\putFiles(), FtpClient\pwd(), SFTP\query_stat_cache(), DatabaseDriver\quoteName(), DatabaseDriver\quoteNameStr(), Select\radiolist(), BigInteger\randomBits(), StringStream\read(), Stream\read(), ZIPExtraction\readFileHeader(), Terminal\readFromProcess(), QuestionHelper\readInput(), Zip\readZipInfo(), Asset\rebuild(), UpdatesitesModel\rebuild(), Nested\rebuild(), SMTP\recordLastTransactionID(), Nested\recursiveUpdatePublishedColumn(), StringsModel\refresh(), ServiceProviderInterface\register(), Application\register(), RouterFactory\register(), VarDumper\register(), ErrorHandler\register(), ClassLoader\register(), CMSPlugin\registerLegacyListener(), Date\relative(), Symfony\Component\Console\Command\release(), Task\releaseLock(), Helper\remotefsize(), RuntimeStorage\remove(), NativeStorage\remove(), Registry\remove(), Event\removeArgument(), Installer\removeFiles(), Stream\removeFilter(), UpdateModel\removePackageFiles(), ModuleRenderer\render(), ActionsDropdown\render(), ScriptsRenderer\render(), StylesRenderer\render(), RssRenderer\render(), ImageDocument\render(), SerializerErrorRenderer\render(), PublishedButton\render(), AtomRenderer\render(), LayoutHelper\render(), HtmlErrorRenderer\render(), Dropdown\render(), ToolbarButton\render(), FieldsHelper\render(), Table\render(), CMSApplication\render(), JavascriptRenderer\render(), PopupButton\renderButton(), Table\renderCell(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), HtmlErrorRenderer\renderException(), JavascriptRenderer\renderHead(), ModuleHelper\renderModule(), Table\renderRowSeparator(), TextView\renderSection(), Application\renderThrowable(), AdminModel\reorder(), ByteString\replaceMatches(), Socket\request(), SocketTransport\request(), ErrorHandler\reRegister(), Inflector\reset(), ContainerResource\reset(), CaBundle\reset(), DebugBarVarDumper\resetClonerOptions(), DebugBarVarDumper\resetDumperOptions(), DebugBarHtmlDumper\resetDumpHeader(), BaseLayout\resetOptions(), Microdata\resetParams(), Indexer\resetState(), AbstractAES\resizeKey(), PharInvocationResolver\resolve(), PharInvocationResolver\resolveBaseName(), Reader\resolveContainer(), Reader\resolveManifestLength(), PharInvocationResolver\resolvePossibleAlias(), ApiApplication\respond(), MenusController\resync(), PharInvocationResolver\retrieveInvocation(), ECSignature\retrievePositiveInteger(), MultibyteStringConverter\retrievePositiveInteger(), Joomla\Database\Query\returning(), SiteApplication\route(), CMSApplication\route(), Inflector\rules(), ProcessHelper\run(), Application\run(), Command\run(), Application\runCommand(), Crypt\safeStrlen(), Binary\safeSubstr(), Crypt\safeSubstr(), ParagonIE_Sodium_Core_Salsa20\salsa20(), ParagonIE_Sodium_Core32_Salsa20\salsa20(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor_ic(), Image\sanitizeHeight(), Image\sanitizeWidth(), CMSApplication\sanityCheckSystemVariables(), StyleController\save(), OverrideController\save(), WorkflowModel\save(), MediumModel\save(), FieldModel\save(), UserModel\save(), ApplicationModel\save(), StyleModel\save(), CategoryModel\save(), TaskModel\save(), FormController\save(), User\save(), TemplateModel\save(), AdminModel\save(), ItemModel\save(), PlgInstallerOverride\saveOverrides(), PKCS8\savePrivateKey(), PSS\savePrivateKey(), PKCS8\savePublicKey(), X509\saveX509(), Text\script(), Bootstrap\scrollspy(), TagsController\searchAjax(), SeekingData\seek(), Data\seek(), Stream\seek(), Filter\select(), DatabaseQuery\select(), JWKSet\selectKey(), SMTP\sendCommand(), DebugBar\sendDataInHeaders(), SMTP\sendHello(), Http\sendRequest(), ApplicationModel\sendTestMail(), HttpHeaderSerializer\serialize(), JSONFlattenedSerializer\serialize(), CompactSerializer\serialize(), HelperSet\set(), CMSObject\set(), RuntimeStorage\set(), NativeStorage\set(), Container\set(), DatabaseQuery\set(), Stream\set(), Pagination\setAdditionalUrlParam(), ClassLoader\setApcuPrefix(), Command\setApplication(), AbstractCommand\setApplication(), InputDefinition\setArguments(), Question\setAutocompleterCallback(), Question\setAutocompleterValues(), HtmlDocument\setBuffer(), AbstractDumper\setCharset(), Command\setCode(), FileLayout\setComponent(), Symfony\Contracts\Service\setContainer(), ZIPExtraction\setCorrectPermissions(), ClientHelper\setCredentialsFromRequest(), BaseDatabaseModel\setDbo(), InputArgument\setDefault(), InputOption\setDefault(), OptionsResolver\setDefault(), ErrorHandler\setDefaultLogger(), Command\setDefinition(), X509\setDN(), OpenSSL\setEncryptionMode(), SymmetricKey\setEngine(), PHPMailer\setError(), FieldModel\setFieldValue(), ProgressBar\setFormat(), HtmlDocument\setHeadData(), Log\setInstance(), User\setLastVisit(), FileLayout\setLayoutId(), ErrorHandler\setLoggers(), Question\setMaxAttempts(), ProgressBar\setMaxSteps(), AbstractDumper\setOutput(), OptionsResolver\setPrototype(), Uri\setQuery(), ProgressBar\setRealFormat(), BaseController\setRedirect(), ProgressBar\setRedrawFrequency(), BreadcrumbsHelper\setSeparator(), Joomla\CMS\MVC\Model\setState(), Stream\setStream(), FlattenException\setTrace(), ItemController\setType(), IntervalField\setup(), CaptchaField\setup(), CheckboxField\setup(), TimeField\setup(), CronField\setup(), NumberField\setup(), CalendarField\setup(), FormField\setup(), Captcha\setupField(), InstallerAdapter\setupScriptfile(), DaemonApplication\setupSignalHandlers(), ComponentAdapter\setupUpdates(), CMSApplication\setUserState(), Uri\setVar(), X509\sign(), ParagonIE_Sodium_Core_Ed25519\sign_detached(), ParagonIE_Sodium_Core32_Ed25519\sign_detached(), X509\signCRL(), X509\signCSR(), X509\signSPKAC(), Filter\slider(), AsciiSlugger\slug(), PHPMailer\smtpClose(), PHPMailer\smtpConnect(), Php72\spl_object_id(), CodePointString\split(), UnicodeString\split(), ByteString\split(), AbstractString\split(), Uri\splitQueryValue(), SqlsrvQuery\splitSqlExpression(), Application\splitStringByWidth(), DebugBar\stackData(), ProgressBar\start(), UnicodeString\startsWith(), English\stem(), Language\stem(), ZIPExtraction\step(), NoteTable\store(), RequestTable\store(), UCMBase\store(), ContentHistory\store(), ContactTable\store(), MfaTable\store(), NewsfeedTable\store(), Menu\store(), FtpClient\store(), TemplateModel\storeFileInfo(), SetupModel\storeOptions(), Buffer\stream_open(), BufferStreamHandler\stream_open(), PharStreamWrapper\stream_open(), Assertion\stringify(), Json\stringToObject(), Iconv\strlen1(), Iconv\strlen2(), StringHelper\strspn(), CliDumper\style(), ContactController\submit(), Helper\substr(), ParagonIE_Sodium_Core_Util\substr(), CliDumper\supportsColors(), Inflector\tableize(), DumpCompletionCommand\tailDebugLog(), Symfony\Component\VarDumper\Test\tearDownVarDumper(), Telephone\tel(), Stream\tell(), BigDecimal\ten(), BigRational\ten(), BigInteger\ten(), NumberRule\test(), OptionsRule\test(), FolderPathExistsRule\test(), SubformRule\test(), LoginUniqueFieldRule\test(), LogoutUniqueFieldRule\test(), NotequalsRule\test(), TimeRule\test(), UserIdRule\test(), FormRule\test(), Collection\toArray(), DataSet\toArray(), ECSignature\toAsn1(), MultibyteStringConverter\toAsn1(), Bootstrap\toast(), AbstractString\toByteString(), ByteString\toCodePointString(), ArrayHelper\toInteger(), StringInput\tokenize(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), Bootstrap\tooltip(), HTMLHelper\tooltip(), RSAKey\toPEM(), Date\toSql(), UserGroupsHelper\total(), Query\toUri(), Http\trace(), ExceptionCaster\traceUnshift(), InstallerModel\translate(), CaptiveModel\translateMethodName(), Adapter\translateState(), Language\transliterate(), PharInvocationCollection\triggerDuplicateAliasWarning(), AbstractString\trimSuffix(), AbstractString\truncate(), AjaxChallenge\typeCheckResult(), Joomla\CMS\Event\Result\typeCheckResult(), StringHelper\ucfirst(), Zip\unix2DosTime(), TaskTable\unlock(), InstallerHelper\unpack(), ClassLoader\unregister(), ProviderManager\unregisterProvider(), ZIPExtraction\unserialiseInstance(), CompactSerializer\unserialize(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), Builder\unsign(), Captcha\update(), LanguageAdapter\update(), DatabaseQuery\update(), Nyholm\Psr7\updateHostFromUri(), PgsqlDriver\updateObject(), DatabaseDriver\updateObject(), ParseException\updateRepr(), MetadataManager\updateSessionRecord(), LdapUserProvider\upgradePassword(), File\upload(), UpdateModel\upload(), TemplateModel\uploadFile(), Inflector\urlize(), ParagonIE_Sodium_Compat\use_fallback(), ParagonIE_Sodium_Compat\useNewSodiumAPI(), Mail\useSmtp(), Transliterate\utf8_latin_to_ascii(), utf8_strspn(), AbstractDumper\utf8Encode(), ForwardedValidator\validate(), AddressValidator\validate(), FormField\validate(), Authentication\validateAssertionResponse(), QuestionHelper\validateAttempts(), CaBundle\validateCaFile(), ExecutionRulesRule\validateField(), UsersComponent\validateSection(), ContactComponent\validateSection(), ContentComponent\validateSection(), UsersHelper\validateSection(), X509\validateSignatureCountable(), AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi(), Yubikey\validateYubikeyOtp(), FileLayout\validComponent(), DatabaseQuery\values(), Credentials\verifyAttestation(), PSSRSA\verifyEMSAPSS(), RSA\verifyEMSAPSS(), OptionsResolver\verifyTypes(), DatabaseQuery\where(), Helper\width(), Resource\with(), EC\withContext(), ServerRequest\withParsedBody(), Uri\withPort(), Response\withStatus(), Uri\withUserInfo(), AbstractString\wrap(), ProcessHelper\wrapCallback(), PKCS8\wrapPrivateKey(), Stream\write(), QuestionHelper\writeError(), SymfonyQuestionHelper\writePrompt(), Debug\xdebuglink(), BigDecimal\zero(), BigRational\zero(), et BigInteger\zero().


Joomla CMS: Référence du fichier calendar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • calendar
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/calendar/calendar.php

Structures de données

class PlgFieldsCalendar

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier calendar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • calendar
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/calendar/tmpl/calendar.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') if(is_array($value)) $formatString = $field->fieldparams->get('showtime', 0) ? 'DATE_FORMAT_LC5' : 'DATE_FORMAT_LC4'

Documentation des variables

◆ $formatString

if ( $value=='') if (is_array( $value)) $formatString = $field->fieldparams->get('showtime', 0) ? 'DATE_FORMAT_LC5' : 'DATE_FORMAT_LC4'

Référencé par MethodsModel\formatRelative().

◆ $value

$value = $field->value


Joomla CMS: Référence du fichier CalendarField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier CalendarField.php

Structures de données

class CalendarField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CalendarRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier CalendarRule.php

Structures de données

class CalendarRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier Callback.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier Callback.php

Structures de données

class Callback

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier CallbackController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/CallbackController.php

Structures de données

class CallbackController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier CallbackController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/CallbackController.php

Structures de données

class CallbackController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier CallbackController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Controller
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Cache/Controller/CallbackController.php

Structures de données

class CallbackController

Espaces de nommage

Joomla\CMS\Cache\Controller


Joomla CMS: Référence du fichier CallbackLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier CallbackLogger.php

Structures de données

class CallbackLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier CallbackStream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier CallbackStream.php

Structures de données

class CallbackStream

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier cancelselect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • toolbar
Espaces de nommage | Variables
Référence du fichier cancelselect.php

Espaces de nommage

Joomla\Administrator

Variables

$text = Text::_('JTOOLBAR_CANCEL')

Documentation des variables

◆ $text

string $text = Text::_('JTOOLBAR_CANCEL')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par TextResponse\__construct(), PaginationObject\__construct(), ToolbarButton\__construct(), PlgContentEmailcloak\_cloak(), PlgContentEmailcloak\_getPattern(), DocumentRenderer\_relToAbs(), StringHelper\abridge(), ListField\addOption(), Bootstrap\addSlide(), OutputFilter\ampReplace(), NullOutputFormatterStyle\apply(), OutputFormatterStyle\apply(), OutputFormatter\applyCurrentStyle(), AdministratorService\association(), Menus\association(), ProgressBar\buildLine(), Behavior\calendartranslation(), OutputFilter\cleanText(), Email\cloak(), Icon\create(), TextResponse\createBody(), ModulesModel\createOption(), ModulesHelper\createOption(), RC4\crypt(), Salsa20\crypt(), Ctype\ctype_alnum(), Ctype\ctype_alpha(), Ctype\ctype_cntrl(), Ctype\ctype_digit(), Ctype\ctype_graph(), Ctype\ctype_lower(), Ctype\ctype_print(), Ctype\ctype_punct(), Ctype\ctype_space(), Ctype\ctype_upper(), Ctype\ctype_xdigit(), DatabaseQuery\e(), Icon\edit(), InputFilter\emailToPunycode(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), OutputFormatter\escape(), SqliteDriver\escape(), MysqliDriver\escape(), PdoDriver\escape(), MysqlDriver\escape(), DatabaseQuery\escape(), OutputFormatter\escapeTrailingBackslash(), ConfirmButton\fetchButton(), LinkButton\fetchButton(), StandardButton\fetchButton(), InlinehelpButton\fetchButton(), PopupButton\fetchButton(), ComponentHelper\filterText(), OutputFormatter\formatAndWrap(), HtmlErrorRenderer\formatFile(), HtmlErrorRenderer\formatFileFromText(), ListHelper\genericordering(), AssociationsHelper\getAssociationHtmlList(), TextDescriptor\getCommandAliasesText(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), SelectModel\getItems(), TosField\getLabel(), SpacerField\getLabel(), WorkflowComponentSectionsField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), PredefinedlistField\getOptions(), PluginsField\getOptions(), ModulesModel\getPositions(), ModulesHelper\getTranslatedModulePosition(), PHPMailer\has8bitChars(), Hash\hash(), FinderIndexCommand\index(), ModulesHelper\isTranslatedText(), ToolbarHelper\link(), HTMLHelper\link(), PHPMailer\normalizeBreaks(), PlgContentPagebreak\onContentPrepare(), Select\options(), ListHelper\ordering(), Stdout\out(), Xml\out(), CliApplication\out(), SymmetricKey\pad(), Parser\parseBlockScalar(), SymmetricKey\poly1305(), Modules\positions(), Content\prepare(), Helper\prepareContent(), ContentmapField\prepareLevel(), Icon\print_screen(), FinderIndexCommand\putFilters(), DatabaseDriver\q(), DatabaseQuery\q(), DatabaseDriver\quote(), DatabaseQuery\quote(), ColorProcessor\replaceColors(), MailTemplate\replaceTags(), BaseController\setMessage(), PHPMailer\stripTrailingWSP(), HTMLHelper\tooltip(), StringHelper\truncate(), SymmetricKey\unpad(), et SymfonyQuestionHelper\writePrompt().


Joomla CMS: Référence du fichier CannotDecodeContent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Encoding
Structures de données | Espaces de nommage
Référence du fichier CannotDecodeContent.php

Structures de données

class CannotDecodeContent

Espaces de nommage

Lcobucci\JWT\Encoding


Joomla CMS: Référence du fichier CannotEncodeContent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Encoding
Structures de données | Espaces de nommage
Référence du fichier CannotEncodeContent.php

Structures de données

class CannotEncodeContent

Espaces de nommage

Lcobucci\JWT\Encoding


Joomla CMS: Référence du fichier CannotSignPayload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier CannotSignPayload.php

Structures de données

class CannotSignPayload

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier canonicalComposition.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • unidata
Référence du fichier canonicalComposition.php


Joomla CMS: Référence du fichier canonicalDecomposition.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • unidata
Référence du fichier canonicalDecomposition.php


Joomla CMS: Référence du fichier CapabilitiesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier CapabilitiesModel.php

Structures de données

class CapabilitiesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier Captcha.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Captcha
Structures de données | Espaces de nommage
Référence du fichier Captcha.php

Structures de données

class Captcha

Espaces de nommage

Joomla\CMS\Captcha


Joomla CMS: Référence du fichier CaptchaField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier CaptchaField.php

Structures de données

class CaptchaField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CaptchaRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier CaptchaRule.php

Structures de données

class CaptchaRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier Captive.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier Captive.php

Structures de données

class Captive

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier captive.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • upload
Espaces de nommage | Variables
Référence du fichier captive.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier CaptiveController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/CaptiveController.php

Structures de données

class CaptiveController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier CaptiveController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/CaptiveController.php

Structures de données

class CaptiveController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier CaptiveModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Model/CaptiveModel.php

Structures de données

class CaptiveModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier CaptiveModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Model/CaptiveModel.php

Structures de données

class CaptiveModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier CaptiveRenderOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • DataShape
Structures de données | Espaces de nommage
Référence du fichier CaptiveRenderOptions.php

Structures de données

class CaptiveRenderOptions

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\DataShape


Joomla CMS: Référence du fichier card.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier card.php

Espaces de nommage

Joomla\Site

Variables

$module = $displayData['module']
$params = $displayData['params']
$attribs = $displayData['attribs']
if($module->content===null|| $module->content==='') | $moduleTag = $params->get('module_tag', 'div')
$moduleAttribs = []
$moduleAttribs ['class'] = $module->position . ' card ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')
$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')
$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')
$headerAttribs = []
$headerAttribs ['class'] = $headerClass
if($headerClass !=='card-title') | endif
if($moduleTag !=='div') | $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'

Documentation des variables

◆ $attribs

$attribs = $displayData['attribs']

◆ $header

if ( $moduleTag !=='div') $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'

◆ $headerAttribs [1/2]

$headerAttribs = []

◆ $headerAttribs [2/2]

$headerAttribs[ 'class'] = $headerClass

◆ $headerClass

$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')

◆ $headerTag

$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')

◆ $module

$module = $displayData['module']

◆ $moduleAttribs [1/2]

$moduleAttribs = []

◆ $moduleAttribs [2/2]

$moduleAttribs[ 'class'] = $module->position . ' card ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')

◆ $moduleTag

if ( $module->content===null||$module->content==='') $moduleTag = $params->get('module_tag', 'div')

◆ $params

$params = $displayData['params']

◆ endif

if ( $module->showtitle &&$headerClass==='card-title') endif


Joomla CMS: Référence du fichier caseFolding_full.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier caseFolding_full.php

Variables

return [0=> [0=> 'ß', 1=> 'İ', 2=> 'ŉ', 3=> 'ǰ', 4=> 'ΐ', 5=> 'ΰ', 6=> 'և', 7=> 'ẖ', 8=> 'ẗ', 9=> 'ẘ', 10=> 'ẙ', 11=> 'ẚ', 12=> 'ẞ', 13=> 'ὐ', 14=> 'ὒ', 15=> 'ὔ', 16=> 'ὖ', 17=> 'ᾀ', 18=> 'ᾁ', 19=> 'ᾂ', 20=> 'ᾃ', 21=> 'ᾄ', 22=> 'ᾅ', 23=> 'ᾆ', 24=> 'ᾇ', 25=> 'ᾈ', 26=> 'ᾉ', 27=> 'ᾊ', 28=> 'ᾋ', 29=> 'ᾌ', 30=> 'ᾍ', 31=> 'ᾎ', 32=> 'ᾏ', 33=> 'ᾐ', 34=> 'ᾑ', 35=> 'ᾒ', 36=> 'ᾓ', 37=> 'ᾔ', 38=> 'ᾕ', 39=> 'ᾖ', 40=> 'ᾗ', 41=> 'ᾘ', 42=> 'ᾙ', 43=> 'ᾚ', 44=> 'ᾛ', 45=> 'ᾜ', 46=> 'ᾝ', 47=> 'ᾞ', 48=> 'ᾟ', 49=> 'ᾠ', 50=> 'ᾡ', 51=> 'ᾢ', 52=> 'ᾣ', 53=> 'ᾤ', 54=> 'ᾥ', 55=> 'ᾦ', 56=> 'ᾧ', 57=> 'ᾨ', 58=> 'ᾩ', 59=> 'ᾪ', 60=> 'ᾫ', 61=> 'ᾬ', 62=> 'ᾭ', 63=> 'ᾮ', 64=> 'ᾯ', 65=> 'ᾲ', 66=> 'ᾳ', 67=> 'ᾴ', 68=> 'ᾶ', 69=> 'ᾷ', 70=> 'ᾼ', 71=> 'ῂ', 72=> 'ῃ', 73=> 'ῄ', 74=> 'ῆ', 75=> 'ῇ', 76=> 'ῌ', 77=> 'ῒ', 78=> 'ΐ', 79=> 'ῖ', 80=> 'ῗ', 81=> 'ῢ', 82=> 'ΰ', 83=> 'ῤ', 84=> 'ῦ', 85=> 'ῧ', 86=> 'ῲ', 87=> 'ῳ', 88=> 'ῴ', 89=> 'ῶ', 90=> 'ῷ', 91=> 'ῼ', 92=> 'ﬀ', 93=> 'ﬁ', 94=> 'ﬂ', 95=> 'ﬃ', 96=> 'ﬄ', 97=> 'ﬅ', 98=> 'ﬆ', 99=> 'ﬓ', 100=> 'ﬔ', 101=> 'ﬕ', 102=> 'ﬖ', 103=> 'ﬗ', 104=> 'J̌̌',], 1=> [0=> 'ss', 1=> 'i̇', 2=> 'ʼn', 3=> 'ǰ', 4=> 'ΐ', 5=> 'ΰ', 6=> 'եւ', 7=> 'ẖ', 8=> 'ẗ', 9=> 'ẘ', 10=> 'ẙ', 11=> 'aʾ', 12=> 'ss', 13=> 'ὐ', 14=> 'ὒ', 15=> 'ὔ', 16=> 'ὖ', 17=> 'ἀι', 18=> 'ἁι', 19=> 'ἂι', 20=> 'ἃι', 21=> 'ἄι', 22=> 'ἅι', 23=> 'ἆι', 24=> 'ἇι', 25=> 'ἀι', 26=> 'ἁι', 27=> 'ἂι', 28=> 'ἃι', 29=> 'ἄι', 30=> 'ἅι', 31=> 'ἆι', 32=> 'ἇι', 33=> 'ἠι', 34=> 'ἡι', 35=> 'ἢι', 36=> 'ἣι', 37=> 'ἤι', 38=> 'ἥι', 39=> 'ἦι', 40=> 'ἧι', 41=> 'ἠι', 42=> 'ἡι', 43=> 'ἢι', 44=> 'ἣι', 45=> 'ἤι', 46=> 'ἥι', 47=> 'ἦι', 48=> 'ἧι', 49=> 'ὠι', 50=> 'ὡι', 51=> 'ὢι', 52=> 'ὣι', 53=> 'ὤι', 54=> 'ὥι', 55=> 'ὦι', 56=> 'ὧι', 57=> 'ὠι', 58=> 'ὡι', 59=> 'ὢι', 60=> 'ὣι', 61=> 'ὤι', 62=> 'ὥι', 63=> 'ὦι', 64=> 'ὧι', 65=> 'ὰι', 66=> 'αι', 67=> 'άι', 68=> 'ᾶ', 69=> 'ᾶι', 70=> 'αι', 71=> 'ὴι', 72=> 'ηι', 73=> 'ήι', 74=> 'ῆ', 75=> 'ῆι', 76=> 'ηι', 77=> 'ῒ', 78=> 'ΐ', 79=> 'ῖ', 80=> 'ῗ', 81=> 'ῢ', 82=> 'ΰ', 83=> 'ῤ', 84=> 'ῦ', 85=> 'ῧ', 86=> 'ὼι', 87=> 'ωι', 88=> 'ώι', 89=> 'ῶ', 90=> 'ῶι', 91=> 'ωι', 92=> 'ff', 93=> 'fi', 94=> 'fl', 95=> 'ffi', 96=> 'ffl', 97=> 'st', 98=> 'st', 99=> 'մն', 100=> 'մե', 101=> 'մի', 102=> 'վն', 103=> 'մխ', 104=> 'ǰ',],]

Documentation des variables

◆ return

return[ 0=> [ 0=> 'ß', 1=> 'İ', 2=> 'ŉ', 3=> 'ǰ', 4=> 'ΐ', 5=> 'ΰ', 6=> 'և', 7=> 'ẖ', 8=> 'ẗ', 9=> 'ẘ', 10=> 'ẙ', 11=> 'ẚ', 12=> 'ẞ', 13=> 'ὐ', 14=> 'ὒ', 15=> 'ὔ', 16=> 'ὖ', 17=> 'ᾀ', 18=> 'ᾁ', 19=> 'ᾂ', 20=> 'ᾃ', 21=> 'ᾄ', 22=> 'ᾅ', 23=> 'ᾆ', 24=> 'ᾇ', 25=> 'ᾈ', 26=> 'ᾉ', 27=> 'ᾊ', 28=> 'ᾋ', 29=> 'ᾌ', 30=> 'ᾍ', 31=> 'ᾎ', 32=> 'ᾏ', 33=> 'ᾐ', 34=> 'ᾑ', 35=> 'ᾒ', 36=> 'ᾓ', 37=> 'ᾔ', 38=> 'ᾕ', 39=> 'ᾖ', 40=> 'ᾗ', 41=> 'ᾘ', 42=> 'ᾙ', 43=> 'ᾚ', 44=> 'ᾛ', 45=> 'ᾜ', 46=> 'ᾝ', 47=> 'ᾞ', 48=> 'ᾟ', 49=> 'ᾠ', 50=> 'ᾡ', 51=> 'ᾢ', 52=> 'ᾣ', 53=> 'ᾤ', 54=> 'ᾥ', 55=> 'ᾦ', 56=> 'ᾧ', 57=> 'ᾨ', 58=> 'ᾩ', 59=> 'ᾪ', 60=> 'ᾫ', 61=> 'ᾬ', 62=> 'ᾭ', 63=> 'ᾮ', 64=> 'ᾯ', 65=> 'ᾲ', 66=> 'ᾳ', 67=> 'ᾴ', 68=> 'ᾶ', 69=> 'ᾷ', 70=> 'ᾼ', 71=> 'ῂ', 72=> 'ῃ', 73=> 'ῄ', 74=> 'ῆ', 75=> 'ῇ', 76=> 'ῌ', 77=> 'ῒ', 78=> 'ΐ', 79=> 'ῖ', 80=> 'ῗ', 81=> 'ῢ', 82=> 'ΰ', 83=> 'ῤ', 84=> 'ῦ', 85=> 'ῧ', 86=> 'ῲ', 87=> 'ῳ', 88=> 'ῴ', 89=> 'ῶ', 90=> 'ῷ', 91=> 'ῼ', 92=> 'ﬀ', 93=> 'ﬁ', 94=> 'ﬂ', 95=> 'ﬃ', 96=> 'ﬄ', 97=> 'ﬅ', 98=> 'ﬆ', 99=> 'ﬓ', 100=> 'ﬔ', 101=> 'ﬕ', 102=> 'ﬖ', 103=> 'ﬗ', 104=> 'J̌̌',], 1=> [ 0=> 'ss', 1=> 'i̇', 2=> 'ʼn', 3=> 'ǰ', 4=> 'ΐ', 5=> 'ΰ', 6=> 'եւ', 7=> 'ẖ', 8=> 'ẗ', 9=> 'ẘ', 10=> 'ẙ', 11=> 'aʾ', 12=> 'ss', 13=> 'ὐ', 14=> 'ὒ', 15=> 'ὔ', 16=> 'ὖ', 17=> 'ἀι', 18=> 'ἁι', 19=> 'ἂι', 20=> 'ἃι', 21=> 'ἄι', 22=> 'ἅι', 23=> 'ἆι', 24=> 'ἇι', 25=> 'ἀι', 26=> 'ἁι', 27=> 'ἂι', 28=> 'ἃι', 29=> 'ἄι', 30=> 'ἅι', 31=> 'ἆι', 32=> 'ἇι', 33=> 'ἠι', 34=> 'ἡι', 35=> 'ἢι', 36=> 'ἣι', 37=> 'ἤι', 38=> 'ἥι', 39=> 'ἦι', 40=> 'ἧι', 41=> 'ἠι', 42=> 'ἡι', 43=> 'ἢι', 44=> 'ἣι', 45=> 'ἤι', 46=> 'ἥι', 47=> 'ἦι', 48=> 'ἧι', 49=> 'ὠι', 50=> 'ὡι', 51=> 'ὢι', 52=> 'ὣι', 53=> 'ὤι', 54=> 'ὥι', 55=> 'ὦι', 56=> 'ὧι', 57=> 'ὠι', 58=> 'ὡι', 59=> 'ὢι', 60=> 'ὣι', 61=> 'ὤι', 62=> 'ὥι', 63=> 'ὦι', 64=> 'ὧι', 65=> 'ὰι', 66=> 'αι', 67=> 'άι', 68=> 'ᾶ', 69=> 'ᾶι', 70=> 'αι', 71=> 'ὴι', 72=> 'ηι', 73=> 'ήι', 74=> 'ῆ', 75=> 'ῆι', 76=> 'ηι', 77=> 'ῒ', 78=> 'ΐ', 79=> 'ῖ', 80=> 'ῗ', 81=> 'ῢ', 82=> 'ΰ', 83=> 'ῤ', 84=> 'ῦ', 85=> 'ῧ', 86=> 'ὼι', 87=> 'ωι', 88=> 'ώι', 89=> 'ῶ', 90=> 'ῶι', 91=> 'ωι', 92=> 'ff', 93=> 'fi', 94=> 'fl', 95=> 'ffi', 96=> 'ffl', 97=> 'st', 98=> 'st', 99=> 'մն', 100=> 'մե', 101=> 'մի', 102=> 'վն', 103=> 'մխ', 104=> 'ǰ',],]


Joomla CMS: Référence du fichier Caster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier Caster.php

Structures de données

class Caster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Catalan.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Catalan.php

Structures de données

class Catalan

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier Categories.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier Categories.php

Structures de données

class Categories

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier categories.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/helpers/categories.php

Structures de données

class CategoriesHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier categories.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • categories
Structures de données | Espaces de nommage
Référence du fichier plugins/finder/categories/categories.php

Structures de données

class PlgFinderCategories

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier categories_default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier categories_default.php

Espaces de nommage

Joomla\Site

Variables

endif
else __pad1__
else $displayData parent | description
else $displayData parent $displayData parent | extension

Documentation des variables

◆ __pad1__

else __pad1__

◆ description

else $displayData parent description

◆ endif

endif

◆ extension

else $displayData parent $displayData parent extension

Référencé par CategoryController\__construct(), DisplayController\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), StageController\__construct(), TransitionController\__construct(), TransitionsController\__construct(), StagesController\__construct(), Workflow\__construct(), InstallerAdapter\__construct(), Installer\__construct(), Category\_getAssetName(), WorkflowTable\_getAssetName(), Category\_getAssetParentId(), WorkflowTable\_getAssetParentId(), InstallerScript\addDashboardMenu(), HtmlView\addToolbar(), Joomla\CMS\MVC\Model\addTransitionField(), WorkflowController\allowAdd(), StageController\allowAdd(), TransitionController\allowAdd(), FormController\batch(), CategoryController\cancel(), Adapter\change(), TemplateAdapter\checkExistingExtension(), ModuleAdapter\checkExistingExtension(), PluginAdapter\checkExistingExtension(), InstallerAdapter\checkExistingExtension(), LibraryAdapter\checkExtensionInFilesystem(), CategoryView\commonCategoryDisplay(), Workflow\createAssociation(), Workflow\deleteAssociation(), InstallerAdapter\discover_install(), Installer\discover_install(), DisplayController\display(), HtmlView\display(), Workflow\executeTransition(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), RouteHelper\findItem(), Workflow\getAssociation(), AssociationsHelper\getAssociations(), Workflow\getComponent(), Workflow\getConditionName(), Workflow\getDefaultStageByCategory(), WorkflowstageField\getGroups(), WorkflowconditionField\getOptions(), WorkflowController\getRedirectToItemAppend(), StageController\getRedirectToItemAppend(), CategoryController\getRedirectToItemAppend(), TransitionsController\getRedirectToListAppend(), WorkflowController\getRedirectToListAppend(), StageController\getRedirectToListAppend(), WorkflowsController\getRedirectToListAppend(), StagesController\getRedirectToListAppend(), RouteHelper\getRoute(), Category\getTypeAlias(), Workflow\getValidTransition(), PlgFinderTags\index(), PlgFinderNewsfeeds\index(), PlgFinderContacts\index(), PlgFinderContent\index(), PlgFinderCategories\index(), InstallerAdapter\install(), Adapter\onFinderGarbageCollection(), TemplateAdapter\parseQueries(), ComponentAdapter\parseQueries(), InstallerScript\preflight(), LibraryAdapter\prepareDiscoverInstall(), PluginAdapter\prepareDiscoverInstall(), TemplateAdapter\prepareDiscoverInstall(), Installer\refreshManifestCache(), Adapter\remove(), LanguageAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), ModuleAdapter\removeExtensionFiles(), LanguageAdapter\resetUserLanguage(), CategoryController\save(), WorkflowsController\setDefault(), StagesController\setDefault(), WorkflowstageField\setup(), TransitionField\setup(), WorkflowconditionField\setup(), LanguageAdapter\setupUninstall(), FileAdapter\setupUninstall(), LibraryAdapter\setupUninstall(), PluginAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), PackageAdapter\setupUninstall(), ModuleAdapter\setupUninstall(), ComponentAdapter\setupUninstall(), Joomla\CMS\MVC\Model\setUpWorkflow(), Category\store(), FileAdapter\storeExtension(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), TemplateAdapter\storeExtension(), Installer\uninstall(), InstallerAdapter\uninstall(), et Workflow\updateAssociations().


Joomla CMS: Référence du fichier categories_default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier categories_default_items.php

Espaces de nommage

Joomla\Site

Variables

$class = ' class="first"'
$item = $displayData->item
$items = $displayData->get('items')
$params = $displayData->params
$extension = $displayData->get('extension')
$className = substr($extension, 4)

Documentation des variables

◆ $class

$class = ' class="first"'

◆ $className

$className = substr($extension, 4)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\_(), AbstractTime\__construct(), Input\__get(), WritableContainerLoader\add(), DebugClassLoader\checkAnnotations(), WebAssetRegistry\createAsset(), CategoryFactory\createCategory(), MVCFactory\createController(), ModuleDispatcherFactory\createDispatcher(), ComponentDispatcherFactory\createDispatcher(), MVCFactory\createModel(), RouterFactory\createRouter(), MVCFactory\createTable(), MVCFactory\createView(), UndefinedMethodErrorEnhancer\enhance(), ClassNotFoundErrorEnhancer\enhance(), FeedParser\fetchNamespace(), Editor\getButtons(), MVCFactory\getClassName(), Image\getFilterInstance(), HelperFactory\getHelper(), AbstractView\getName(), InstallerAdapter\getScriptClassName(), Assertion\isInstanceOf(), JLoader\loadByPsr(), LegacyComponent\loadHelper(), Assertion\notIsInstanceOf(), FeedFactory\registerParser(), JavascriptRenderer\setAjaxHandlerClass(), LazyAssertion\setAssertClass(), AssertionChain\setAssertionClassName(), LazyAssertion\setExceptionClass(), JavascriptRenderer\setJavascriptClass(), JavascriptRenderer\setOpenHandlerClass(), Assertion\subclassOf(), et Joomla\CMS\Application\triggerEvent().

◆ $extension

$extension = $displayData->get('extension')

◆ $item

$item = $displayData->item

◆ $items

$items = $displayData->get('items')

◆ $params

$params = $displayData->params


Joomla CMS: Référence du fichier CategoriesComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier CategoriesComponent.php

Structures de données

class CategoriesComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Extension


Joomla CMS: Référence du fichier CategoriesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Controller/CategoriesController.php

Structures de données

class CategoriesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Controller


Joomla CMS: Référence du fichier CategoriesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_categories/src/Controller/CategoriesController.php

Structures de données

class CategoriesController

Espaces de nommage

Joomla\API
Joomla\Component\Categories\Api\Controller


Joomla CMS: Référence du fichier CategoriesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier CategoriesHelper.php

Structures de données

class CategoriesHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Helper


Joomla CMS: Référence du fichier CategoriesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Model/CategoriesModel.php

Structures de données

class CategoriesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Model


Joomla CMS: Référence du fichier CategoriesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Model/CategoriesModel.php

Structures de données

class CategoriesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Model


Joomla CMS: Référence du fichier CategoriesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/CategoriesModel.php

Structures de données

class CategoriesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier CategoriesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Model/CategoriesModel.php

Structures de données

class CategoriesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Model


Joomla CMS: Référence du fichier CategoriesView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier CategoriesView.php

Structures de données

class CategoriesView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage | Variables
Référence du fichier category.php

Espaces de nommage

Joomla\Site

Variables

$title = $this->escape($displayData['item']->category_title)

Documentation des variables

◆ $title

$title = $this->escape($displayData['item']->category_title)


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_banners/src/Service/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Service


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Service/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Service


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Service/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Service


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Service/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Service


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier libraries/src/HTML/Helpers/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Table/Category.php

Structures de données

class Category

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier category_default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier category_default.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData->params
$category = $displayData->get('category')
$extension = $category->extension
$canEdit = $params->get('access-edit')
$className = substr($extension, 4)
$htag = $params->get('show_page_heading') ? 'h2' : 'h1'
$app = Factory::getApplication()
$category text = $category->description
$category description = $category->text
$results = $app->triggerEvent('onContentAfterTitle', array($extension . '.categories', &$category, &$params, 0))
$afterDisplayTitle = trim(implode("\n", $results))
$beforeDisplayContent = trim(implode("\n", $results))
$afterDisplayContent = trim(implode("\n", $results))
if(substr($className, -1)==='s') $tagsData = $category->tags->itemTags
endif
if ( $params->get( 'show_category_title', 1))

Documentation des variables

◆ $afterDisplayContent

$afterDisplayContent = trim(implode("\n", $results))

◆ $afterDisplayTitle

$afterDisplayTitle = trim(implode("\n", $results))

◆ $app

$app = Factory::getApplication()

◆ $beforeDisplayContent

$beforeDisplayContent = trim(implode("\n", $results))

◆ $canEdit

$canEdit = $params->get('access-edit')

◆ $category

$category = $displayData->get('category')

◆ $className

$className = substr($extension, 4)

◆ $extension

$extension = $category->extension

◆ $htag

$htag = $params->get('show_page_heading') ? 'h2' : 'h1'

◆ $params

$params = $displayData->params

Note that this layout opens a div with the page class suffix. If you do not use the category children layout you need to close this div either by overriding this file or in your main layout.

◆ $results

$results = $app->triggerEvent('onContentAfterTitle', array($extension . '.categories', &$category, &$params, 0))

◆ $tagsData

if (substr( $className, -1)==='s') $tagsData = $category->tags->itemTags

This will work for the core components but not necessarily for other components that may have different pluralisation rules.

◆ description

$category description = $category->text

◆ endif

endif

◆ if

if($params->get('show_category_title', 1))

◆ text

$category text = $category->description


Joomla CMS: Référence du fichier CategoryAssociationHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier CategoryAssociationHelper.php

Structures de données

class CategoryAssociationHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Helper


Joomla CMS: Référence du fichier CategoryController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier CategoryController.php

Structures de données

class CategoryController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Controller


Joomla CMS: Référence du fichier categoryedit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier categoryedit.php

Espaces de nommage

Joomla\Administrator

Variables

$html = array()
$classes = array()
$attr = ''
$attr2 = ''
$placeholder = $this->escape(Text::_('JGLOBAL_TYPE_OR_SELECT_CATEGORY'))
if($allowCustom) if($required) if($readonly) else

Documentation des variables

◆ $attr

$attr = ''

Référencé par CollectionAdapter\_startElement(), PdoCaster\castPdo(), SFTP\chgrp(), SFTP\chmod(), SFTP\chown(), InputFilter\cleanTags(), CliDumper\dumpKey(), CliDumper\dumpScalar(), CliDumper\dumpString(), CliDumper\enterHash(), X509\getDN(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), OrderingField\getInput(), Select\options(), Utility\parseAttributes(), SFTP\parseAttributes(), SFTP\parseTime(), SFTP\put(), FeedDocument\render(), SFTP\setstat(), SFTP\setstat_recursive(), CliDumper\style(), HtmlDumper\style(), SFTP\touch(), SFTP\truncate(), et PKCS8\wrapPrivateKey().

◆ $attr2

$attr2 = ''

◆ $classes

$classes = array()

Référencé par AdministratorService\association(), Menus\association(), JLoader\discover(), ClassNotFoundErrorEnhancer\findClassInPath(), AssociationsHelper\getAssociationHtmlList(), ClassNotFoundErrorEnhancer\getClassCandidates(), JLoader\getClassList(), JLoader\import(), Assert\isAnyOf(), Assert\isInstanceOfAny(), JLoader\load(), et JLoader\register().

◆ $html

$html = array()

Référencé par HtmlResponse\__construct(), Pagination\_list_footer(), JGrid\action(), Access\actions(), HtmlDocument\addCustomTag(), AdministratorService\association(), Menus\association(), Icons\buttons(), HtmlResponse\createBody(), Editor\display(), Microdata\display(), PlgContentVote\displayVotingData(), CustomButton\fetchButton(), Select\genericlist(), CssMenu\getIconClass(), AssociationField\getInput(), FiltersField\getInput(), FieldLayoutField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), UploaddirsField\getInput(), OrderingField\getInput(), ModulepositionField\getInput(), SubformField\getInput(), SpacerField\getLabel(), NoteField\getLabel(), Pagination\getLimitBox(), Pagination\getPagesCounter(), Pagination\getResultsCounter(), Select\groupedlist(), PHPMailer\html2text(), SourceContextProvider\htmlEncode(), Links\links(), Links\linksgroups(), MailsHelper\mailtags(), Select\options(), ListHelper\ordering(), ModuleController\orderPosition(), SysinfoModel\parsePhpInfo(), Redirect\published(), Select\radiolist(), AbstractWebApplication\redirect(), ActionsDropdown\render(), PublishedButton\render(), FeaturedButton\render(), Toolbar\render(), PopupButton\renderButton(), Form\renderFieldset(), JavascriptRenderer\renderHead(), Filter\select(), Filter\slider(), Messages\status(), Templates\thumb(), Templates\thumbModal(), ToolbarHelper\title(), ArticlesCategoryHelper\truncate(), StringHelper\truncateComplex(), Access\usergroups(), et Debug\xdebuglink().

◆ $placeholder

$placeholder = $this->escape(Text::_('JGLOBAL_TYPE_OR_SELECT_CATEGORY'))

◆ else

if ( $refreshPage===true) else
Valeur initiale :
{
if (count($options) === 0) {
$options[0] = new \stdClass();
$options[0]->value = 'Uncategorised';
$options[0]->text = 'Uncategorised';
$options[0]->level = '1';
$options[0]->published = '1';
$options[0]->lft = '1';
}
$html[] = HTMLHelper::_('select.genericlist', $options, $name, trim($attr), 'value', 'text', $value, $id)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$value
$value
Definition: com_contact/layouts/field/render.php:21
trim
count
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$options
$options
Definition: administrator/components/com_associations/tmpl/association/edit.php:27
$html
$html
Definition: categoryedit.php:53
$attr
$attr
Definition: categoryedit.php:55


Joomla CMS: Référence du fichier CategoryeditField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier CategoryeditField.php

Structures de données

class CategoryeditField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Field


Joomla CMS: Référence du fichier CategoryFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier Categories/CategoryFactory.php

Structures de données

class CategoryFactory

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier CategoryFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/CategoryFactory.php

Structures de données

class CategoryFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier CategoryFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier CategoryFactoryInterface.php

Structures de données

interface CategoryFactoryInterface

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier CategoryFeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier CategoryFeedView.php

Structures de données

class CategoryFeedView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier CategoryField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Field/Modal/CategoryField.php

Structures de données

class CategoryField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Field\Modal


Joomla CMS: Référence du fichier CategoryField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Form/Field/CategoryField.php

Structures de données

class CategoryField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CategoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier CategoryInterface.php

Structures de données

interface CategoryInterface

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier CategoryModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Model/CategoryModel.php

Structures de données

class CategoryModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Model


Joomla CMS: Référence du fichier CategoryModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Model/CategoryModel.php

Structures de données

class CategoryModel

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Model


Joomla CMS: Référence du fichier CategoryModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/CategoryModel.php

Structures de données

class CategoryModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier CategoryModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Model/CategoryModel.php

Structures de données

class CategoryModel

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Model


Joomla CMS: Référence du fichier CategoryNode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier CategoryNode.php

Structures de données

class CategoryNode

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier CategoryServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier CategoryServiceInterface.php

Structures de données

interface CategoryServiceInterface

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier CategoryServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Espaces de nommage | Fonctions | Variables
Référence du fichier CategoryServiceTrait.php

Espaces de nommage

Joomla\CMS\Categories

Fonctions

getCategory (array $options=[], $section='')
setCategoryFactory (CategoryFactoryInterface $categoryFactory)
countItems (array $items, string $section)
prepareForm (Form $form, $data)
getTableNameForSection (string $section=null)
getStateColumnForSection (string $section=null)

Variables

trait CategoryServiceTrait


Joomla CMS: Référence du fichier CategoryTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier CategoryTable.php

Structures de données

class CategoryTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Table


Joomla CMS: Référence du fichier CategoryView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier CategoryView.php

Structures de données

class CategoryView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier CBORObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier CBORObject.php

Structures de données

interface CBORObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier Certificate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Certificate.php

Structures de données

class Certificate

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificateExtensions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Structures de données | Espaces de nommage
Référence du fichier CertificateExtensions.php

Structures de données

class CertificateExtensions

Espaces de nommage

FG\X509


Joomla CMS: Référence du fichier CertificateIssuer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificateIssuer.php

Structures de données

class CertificateIssuer

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificateList.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificateList.php

Structures de données

class CertificateList

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificatePolicies.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificatePolicies.php

Structures de données

class CertificatePolicies

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificateSerialNumber.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificateSerialNumber.php

Structures de données

class CertificateSerialNumber

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificateSubject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Structures de données | Espaces de nommage
Référence du fichier CertificateSubject.php

Structures de données

class CertificateSubject

Espaces de nommage

FG\X509


Joomla CMS: Référence du fichier CertificateToolbox.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier CertificateToolbox.php

Structures de données

class CertificateToolbox

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier CertificateTrustPath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Structures de données | Espaces de nommage
Référence du fichier CertificateTrustPath.php

Structures de données

class CertificateTrustPath

Espaces de nommage

Webauthn\TrustPath


Joomla CMS: Référence du fichier CertificationRequest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificationRequest.php

Structures de données

class CertificationRequest

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertificationRequestInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertificationRequestInfo.php

Structures de données

class CertificationRequestInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CertPolicyId.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CertPolicyId.php

Structures de données

class CertPolicyId

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier paragonie/sodium_compat/namespaced/Core/ChaCha20.php

Structures de données

class ChaCha20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier ChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/ChaCha20.php

Structures de données

class ParagonIE_Sodium_Core_ChaCha20


Joomla CMS: Référence du fichier ChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core32/ChaCha20.php

Structures de données

class ParagonIE_Sodium_Core32_ChaCha20


Joomla CMS: Référence du fichier ChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/ChaCha20.php

Structures de données

class ChaCha20

Espaces de nommage

ChaCha20
phpseclib3\Crypt


Joomla CMS: Référence du fichier ChainedHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier ChainedHandler.php

Structures de données

class ChainedHandler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier ChainedMonitor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Monitor
Structures de données | Espaces de nommage
Référence du fichier ChainedMonitor.php

Structures de données

class ChainedMonitor

Espaces de nommage

Joomla\Database\Monitor


Joomla CMS: Référence du fichier ChangeItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
Structures de données | Espaces de nommage
Référence du fichier ChangeItem.php

Structures de données

class ChangeItem

Espaces de nommage

Joomla\CMS\Schema


Joomla CMS: Référence du fichier Changelog.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Changelog
Structures de données | Espaces de nommage
Référence du fichier Changelog.php

Structures de données

class Changelog

Espaces de nommage

Joomla\CMS\Changelog


Joomla CMS: Référence du fichier changelog.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • installer
Espaces de nommage
Référence du fichier changelog.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier ChangeSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
Structures de données | Espaces de nommage
Référence du fichier ChangeSet.php

Structures de données

class ChangeSet

Espaces de nommage

Joomla\CMS\Schema


Joomla CMS: Référence du fichier ChangeUserPasswordCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ChangeUserPasswordCommand.php

Structures de données

class ChangeUserPasswordCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier Characteristic_two.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Characteristic_two.php

Structures de données

class Characteristic_two

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CharacterString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier CharacterString.php

Structures de données

class CharacterString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier CharsetNegotiator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier CharsetNegotiator.php

Structures de données

class CharsetNegotiator

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier checkbox.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier checkbox.php

Espaces de nommage

Joomla\Site

Variables

$class = $class ? ' ' . $class : ''
$disabled = $disabled ? ' disabled' : ''
$required = $required ? ' required' : ''
$autofocus = $autofocus ? ' autofocus' : ''
$checked = $checked ? ' checked' : ''
$onclick = $onclick ? ' onclick="' . $onclick . '"' : ''
$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''

Documentation des variables

◆ $autofocus

$autofocus = $autofocus ? ' autofocus' : ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), et FormField\getLayoutData().

◆ $checked

$checked = $checked ? ' checked' : ''

◆ $class

$class = $class ? ' ' . $class : ''

◆ $disabled

$disabled = $disabled ? ' disabled' : ''

◆ $onchange

$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), PrefixField\getInput(), ImptotalField\getInput(), et FormField\getLayoutData().

◆ $onclick

$onclick = $onclick ? ' onclick="' . $onclick . '"' : ''

◆ $required

$required = $required ? ' required' : ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\calendar(), FormField\filter(), MenutypeField\getInput(), CssIdentifierSubstringRule\test(), TelRule\test(), NumberRule\test(), ColorRule\test(), CssIdentifierRule\test(), FilePathRule\test(), OptionsRule\test(), CalendarRule\test(), TimeRule\test(), UrlRule\test(), UserIdRule\test(), PasswordRule\test(), EmailRule\test(), et FormField\validate().


Joomla CMS: Référence du fichier checkboxes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/checkboxes.php

Espaces de nommage

Joomla\Site

Variables

$format = '<input type="checkbox" id="%1$s" name="%2$s" value="%3$s" %4$s>'
$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)
foreach( $options as $i=> $option)((string) $option->value, $checkedOptions, true) ? 'checked' $checked = (!$hasValue && $option->checked) ? 'checked' : $checked
$optionClass = !empty($option->class) ? 'class="form-check-input ' . $option->class . '"' : ' class="form-check-input"'
$optionDisabled = !empty($option->disable) || $disabled ? 'disabled' : ''
$onclick = !empty($option->onclick) ? 'onclick="' . $option->onclick . '"' : ''
$onchange = !empty($option->onchange) ? 'onchange="' . $option->onchange . '"' : ''
$oid = $id . $i
$value = htmlspecialchars($option->value, ENT_COMPAT, 'UTF-8')
$attributes = array_filter(array($checked, $optionClass, $optionDisabled, $onchange, $onclick))
endforeach

Documentation des variables

◆ $alt

$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)

◆ $attributes

$attributes = array_filter(array($checked, $optionClass, $optionDisabled, $onchange, $onclick))

◆ $checked

foreach ($options as $i => $option) ((string) $option->value, $checkedOptions, true) ? 'checked' $checked = (!$hasValue && $option->checked) ? 'checked' : $checked

◆ $format

$format = '<input type="checkbox" id="%1$s" name="%2$s" value="%3$s" %4$s>'

The format of the input tag to be filled in using sprintf. %1 - id %2 - name %3 - value %4 = any other attributes

◆ $oid

$oid = $id . $i

Référencé par ASN1\decodeOID(), Usergroup\delete(), ASN1\encodeOID(), OpenSSH\getAlias(), XML\loadCurveByParam(), ObjectIdentifier\parseOid(), PKCS8\wrapPrivateKey(), et PKCS8\wrapPublicKey().

◆ $onchange

$onchange = !empty($option->onchange) ? 'onchange="' . $option->onchange . '"' : ''

◆ $onclick

$onclick = !empty($option->onclick) ? 'onclick="' . $option->onclick . '"' : ''

◆ $optionClass

$optionClass = !empty($option->class) ? 'class="form-check-input ' . $option->class . '"' : ' class="form-check-input"'

◆ $optionDisabled

$optionDisabled = !empty($option->disable) || $disabled ? 'disabled' : ''

◆ $value

$value = htmlspecialchars($option->value, ENT_COMPAT, 'UTF-8')

◆ endforeach

endforeach


Joomla CMS: Référence du fichier checkboxes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • checkboxes
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/checkboxes/checkboxes.php

Structures de données

class PlgFieldsCheckboxes

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier checkboxes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • checkboxes
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/checkboxes/tmpl/checkboxes.php

Espaces de nommage

Joomla\Plugin

Variables

$fieldValue = $field->value
$texts = array()
$options = $this->getOptionsFromField($field)
foreach ( $options as $value=> $name)

Documentation des variables

◆ $fieldValue

if ( $fieldValue===''||$fieldValue===null) $fieldValue = $field->value

Référencé par PrivacyPlugin\createCustomFieldsDomain(), Iconv\iconv_mime_encode(), DayOfWeekField\isSatisfiedBy(), DayOfMonthField\isSatisfiedBy(), et PgsqlDriver\sqlValue().

◆ $options

$options = $this->getOptionsFromField($field)

◆ $texts

$texts = array()

◆ foreach

foreach($options as $value=> $name)


Joomla CMS: Référence du fichier CheckboxesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier CheckboxesField.php

Structures de données

class CheckboxesField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CheckboxField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier CheckboxField.php

Structures de données

class CheckboxField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CheckEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier CheckEvent.php

Structures de données

class CheckEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier Checkfiles.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Checkfiles.php

Structures de données

class Checkfiles

Espaces de nommage

Joomla\Plugins
Joomla\Plugin\Task\Checkfiles\Extension


Joomla CMS: Référence du fichier CheckIfRehashNeededHandlerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier CheckIfRehashNeededHandlerInterface.php

Structures de données

interface CheckIfRehashNeededHandlerInterface

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier CheckinCheckout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CheckinCheckout.php

Structures de données

class CheckinCheckout

Espaces de nommage

Joomla\CMS\MVC\Controller\Exception


Joomla CMS: Référence du fichier CheckinCheckoutExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier CheckinCheckoutExceptionHandler.php

Structures de données

class CheckinCheckoutExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier CheckinModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier CheckinModel.php

Structures de données

class CheckinModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Checkin\Administrator\Model


Joomla CMS: Référence du fichier CheckJoomlaUpdatesCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier CheckJoomlaUpdatesCommand.php

Structures de données

class CheckJoomlaUpdatesCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier CheckLdapCredentialsListener.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Structures de données | Espaces de nommage
Référence du fichier CheckLdapCredentialsListener.php

Structures de données

class CheckLdapCredentialsListener

Espaces de nommage

Symfony\Component\Ldap\Security


Joomla CMS: Référence du fichier ChecksModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ChecksModel.php

Structures de données

class ChecksModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier CheckUpdatesCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier CheckUpdatesCommand.php

Structures de données

class CheckUpdatesCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ChoiceQuestion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Question
Structures de données | Espaces de nommage
Référence du fichier ChoiceQuestion.php

Structures de données

class ChoiceQuestion

Espaces de nommage

Symfony\Component\Console\Question


Joomla CMS: Référence du fichier chr.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier chr.php

Variables

return [0=> "\0", 1=> "\1", 2=> "\2", 3=> "\3", 4=> "\4", 5=> "\5", 6=> "\6", 7=> "\7", 8=> "\8", 9=> "\9", 10=> "\A", 11=> "\B", 12=> "\C", 13=> "\D", 14=> "\E", 15=> "\F", 16=> "\0", 17=> "\1", 18=> "\2", 19=> "\3", 20=> "\4", 21=> "\5", 22=> "\6", 23=> "\7", 24=> "\8", 25=> "\9", 26=> "\A", 27=> "\B", 28=> "\C", 29=> "\D", 30=> "\E", 31=> "\F", 32=> "\0", 33=> "\1", 34=> "\2", 35=> "\3", 36=> "\4", 37=> "\5", 38=> "\6", 39=> "\7", 40=> "\8", 41=> "\9", 42=> "\A", 43=> "\B", 44=> "\C", 45=> "\D", 46=> "\E", 47=> "\F", 48=> "\0", 49=> "\1", 50=> "\2", 51=> "\3", 52=> "\4", 53=> "\5", 54=> "\6", 55=> "\7", 56=> "\8", 57=> "\9", 58=> "\A", 59=> "\B", 60=> "\C", 61=> "\D", 62=> "\E", 63=> "\F", 64=> "\0", 65=> "\1", 66=> "\2", 67=> "\3", 68=> "\4", 69=> "\5", 70=> "\6", 71=> "\7", 72=> "\8", 73=> "\9", 74=> "\A", 75=> "\B", 76=> "\C", 77=> "\D", 78=> "\E", 79=> "\F", 80=> "\0", 81=> "\1", 82=> "\2", 83=> "\3", 84=> "\4", 85=> "\5", 86=> "\6", 87=> "\7", 88=> "\8", 89=> "\9", 90=> "\A", 91=> "\B", 92=> "\C", 93=> "\D", 94=> "\E", 95=> "\F", 96=> "\0", 97=> "\1", 98=> "\2", 99=> "\3", 100=> "\4", 101=> "\5", 102=> "\6", 103=> "\7", 104=> "\8", 105=> "\9", 106=> "\A", 107=> "\B", 108=> "\C", 109=> "\D", 110=> "\E", 111=> "\F", 112=> "\0", 113=> "\1", 114=> "\2", 115=> "\3", 116=> "\4", 117=> "\5", 118=> "\6", 119=> "\7", 120=> "\8", 121=> "\9", 122=> "\A", 123=> "\B", 124=> "\C", 125=> "\D", 126=> "\E", 127=> "\F", 128=> "\0", 129=> "\1", 130=> "\2", 131=> "\3", 132=> "\4", 133=> "\5", 134=> "\6", 135=> "\7", 136=> "\8", 137=> "\9", 138=> "\A", 139=> "\B", 140=> "\C", 141=> "\D", 142=> "\E", 143=> "\F", 144=> "\0", 145=> "\1", 146=> "\2", 147=> "\3", 148=> "\4", 149=> "\5", 150=> "\6", 151=> "\7", 152=> "\8", 153=> "\9", 154=> "\A", 155=> "\B", 156=> "\C", 157=> "\D", 158=> "\E", 159=> "\F", 160=> "\0", 161=> "\1", 162=> "\2", 163=> "\3", 164=> "\4", 165=> "\5", 166=> "\6", 167=> "\7", 168=> "\8", 169=> "\9", 170=> "\A", 171=> "\B", 172=> "\C", 173=> "\D", 174=> "\E", 175=> "\F", 176=> "\0", 177=> "\1", 178=> "\2", 179=> "\3", 180=> "\4", 181=> "\5", 182=> "\6", 183=> "\7", 184=> "\8", 185=> "\9", 186=> "\A", 187=> "\B", 188=> "\C", 189=> "\D", 190=> "\E", 191=> "\F", 192=> "\0", 193=> "\1", 194=> "\2", 195=> "\3", 196=> "\4", 197=> "\5", 198=> "\6", 199=> "\7", 200=> "\8", 201=> "\9", 202=> "\A", 203=> "\B", 204=> "\C", 205=> "\D", 206=> "\E", 207=> "\F", 208=> "\0", 209=> "\1", 210=> "\2", 211=> "\3", 212=> "\4", 213=> "\5", 214=> "\6", 215=> "\7", 216=> "\8", 217=> "\9", 218=> "\A", 219=> "\B", 220=> "\C", 221=> "\D", 222=> "\E", 223=> "\F", 224=> "\0", 225=> "\1", 226=> "\2", 227=> "\3", 228=> "\4", 229=> "\5", 230=> "\6", 231=> "\7", 232=> "\8", 233=> "\9", 234=> "\A", 235=> "\B", 236=> "\C", 237=> "\D", 238=> "\E", 239=> "\F", 240=> "\0", 241=> "\1", 242=> "\2", 243=> "\3", 244=> "\4", 245=> "\5", 246=> "\6", 247=> "\7", 248=> "\8", 249=> "\9", 250=> "\A", 251=> "\B", 252=> "\C", 253=> "\D", 254=> "\E", 255=> "\F",]

Documentation des variables

◆ return

return[ 0=> "\00", 1=> "\01", 2=> "\02", 3=> "\03", 4=> "\04", 5=> "\05", 6=> "\06", 7=> "\07", 8=> "\08", 9=> "\09", 10=> "\0A", 11=> "\0B", 12=> "\0C", 13=> "\0D", 14=> "\0E", 15=> "\0F", 16=> "\10", 17=> "\11", 18=> "\12", 19=> "\13", 20=> "\14", 21=> "\15", 22=> "\16", 23=> "\17", 24=> "\18", 25=> "\19", 26=> "\1A", 27=> "\1B", 28=> "\1C", 29=> "\1D", 30=> "\1E", 31=> "\1F", 32=> "\20", 33=> "\21", 34=> "\22", 35=> "\23", 36=> "\24", 37=> "\25", 38=> "\26", 39=> "\27", 40=> "\28", 41=> "\29", 42=> "\2A", 43=> "\2B", 44=> "\2C", 45=> "\2D", 46=> "\2E", 47=> "\2F", 48=> "\30", 49=> "\31", 50=> "\32", 51=> "\33", 52=> "\34", 53=> "\35", 54=> "\36", 55=> "\37", 56=> "\38", 57=> "\39", 58=> "\3A", 59=> "\3B", 60=> "\3C", 61=> "\3D", 62=> "\3E", 63=> "\3F", 64=> "\40", 65=> "\41", 66=> "\42", 67=> "\43", 68=> "\44", 69=> "\45", 70=> "\46", 71=> "\47", 72=> "\48", 73=> "\49", 74=> "\4A", 75=> "\4B", 76=> "\4C", 77=> "\4D", 78=> "\4E", 79=> "\4F", 80=> "\50", 81=> "\51", 82=> "\52", 83=> "\53", 84=> "\54", 85=> "\55", 86=> "\56", 87=> "\57", 88=> "\58", 89=> "\59", 90=> "\5A", 91=> "\5B", 92=> "\5C", 93=> "\5D", 94=> "\5E", 95=> "\5F", 96=> "\60", 97=> "\61", 98=> "\62", 99=> "\63", 100=> "\64", 101=> "\65", 102=> "\66", 103=> "\67", 104=> "\68", 105=> "\69", 106=> "\6A", 107=> "\6B", 108=> "\6C", 109=> "\6D", 110=> "\6E", 111=> "\6F", 112=> "\70", 113=> "\71", 114=> "\72", 115=> "\73", 116=> "\74", 117=> "\75", 118=> "\76", 119=> "\77", 120=> "\78", 121=> "\79", 122=> "\7A", 123=> "\7B", 124=> "\7C", 125=> "\7D", 126=> "\7E", 127=> "\7F", 128=> "\80", 129=> "\81", 130=> "\82", 131=> "\83", 132=> "\84", 133=> "\85", 134=> "\86", 135=> "\87", 136=> "\88", 137=> "\89", 138=> "\8A", 139=> "\8B", 140=> "\8C", 141=> "\8D", 142=> "\8E", 143=> "\8F", 144=> "\90", 145=> "\91", 146=> "\92", 147=> "\93", 148=> "\94", 149=> "\95", 150=> "\96", 151=> "\97", 152=> "\98", 153=> "\99", 154=> "\9A", 155=> "\9B", 156=> "\9C", 157=> "\9D", 158=> "\9E", 159=> "\9F", 160=> "\A0", 161=> "\A1", 162=> "\A2", 163=> "\A3", 164=> "\A4", 165=> "\A5", 166=> "\A6", 167=> "\A7", 168=> "\A8", 169=> "\A9", 170=> "\AA", 171=> "\AB", 172=> "\AC", 173=> "\AD", 174=> "\AE", 175=> "\AF", 176=> "\B0", 177=> "\B1", 178=> "\B2", 179=> "\B3", 180=> "\B4", 181=> "\B5", 182=> "\B6", 183=> "\B7", 184=> "\B8", 185=> "\B9", 186=> "\BA", 187=> "\BB", 188=> "\BC", 189=> "\BD", 190=> "\BE", 191=> "\BF", 192=> "\C0", 193=> "\C1", 194=> "\C2", 195=> "\C3", 196=> "\C4", 197=> "\C5", 198=> "\C6", 199=> "\C7", 200=> "\C8", 201=> "\C9", 202=> "\CA", 203=> "\CB", 204=> "\CC", 205=> "\CD", 206=> "\CE", 207=> "\CF", 208=> "\D0", 209=> "\D1", 210=> "\D2", 211=> "\D3", 212=> "\D4", 213=> "\D5", 214=> "\D6", 215=> "\D7", 216=> "\D8", 217=> "\D9", 218=> "\DA", 219=> "\DB", 220=> "\DC", 221=> "\DD", 222=> "\DE", 223=> "\DF", 224=> "\E0", 225=> "\E1", 226=> "\E2", 227=> "\E3", 228=> "\E4", 229=> "\E5", 230=> "\E6", 231=> "\E7", 232=> "\E8", 233=> "\E9", 234=> "\EA", 235=> "\EB", 236=> "\EC", 237=> "\ED", 238=> "\EE", 239=> "\EF", 240=> "\F0", 241=> "\F1", 242=> "\F2", 243=> "\F3", 244=> "\F4", 245=> "\F5", 246=> "\F6", 247=> "\F7", 248=> "\F8", 249=> "\F9", 250=> "\FA", 251=> "\FB", 252=> "\FC", 253=> "\FD", 254=> "\FE", 255=> "\FF",]


Joomla CMS: Référence du fichier ChromestyleField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ChromestyleField.php

Structures de données

class ChromestyleField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier CipherInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
Structures de données | Espaces de nommage
Référence du fichier CipherInterface.php

Structures de données

interface CipherInterface

Espaces de nommage

Joomla\Crypt


Joomla CMS: Référence du fichier Claim.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier Claim.php

Structures de données

interface Claim

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier class-aliases.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • compat
Référence du fichier class-aliases.php


Joomla CMS: Référence du fichier Classic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier Classic.php

Structures de données

class Classic

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier ClassLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Autoload
Structures de données | Espaces de nommage
Référence du fichier src/Autoload/ClassLoader.php

Structures de données

class ClassLoader

Espaces de nommage

Joomla\CMS\Autoload


Joomla CMS: Référence du fichier ClassLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Structures de données | Espaces de nommage | Fonctions
Référence du fichier vendor/composer/ClassLoader.php

Structures de données

class ClassLoader

Espaces de nommage

Composer\Autoload

Fonctions

includeFile ($file)


Joomla CMS: Référence du fichier classmap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Référence du fichier classmap.php


Joomla CMS: Référence du fichier ClassNotFoundError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Structures de données | Espaces de nommage
Référence du fichier ClassNotFoundError.php

Structures de données

class ClassNotFoundError

Espaces de nommage

Symfony\Component\ErrorHandler\Error


Joomla CMS: Référence du fichier ClassNotFoundErrorEnhancer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorEnhancer
Structures de données | Espaces de nommage
Référence du fichier ClassNotFoundErrorEnhancer.php

Structures de données

class ClassNotFoundErrorEnhancer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorEnhancer


Joomla CMS: Référence du fichier ClassStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ClassStub.php

Structures de données

class ClassStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier CleanCacheCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier CleanCacheCommand.php

Structures de données

class CleanCacheCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier CleanupModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier CleanupModel.php

Structures de données

class CleanupModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier Cli.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Structures de données | Espaces de nommage
Référence du fichier Cli.php

Structures de données

class Cli

Espaces de nommage

Joomla\CMS\Input


Joomla CMS: Référence du fichier CliApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier CliApplication.php

Structures de données

class CliApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier ClicksField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ClicksField.php

Structures de données

class ClicksField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Field


Joomla CMS: Référence du fichier CliContextProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
  • ContextProvider
Structures de données | Espaces de nommage
Référence du fichier CliContextProvider.php

Structures de données

class CliContextProvider

Espaces de nommage

Symfony\Component\VarDumper\Dumper\ContextProvider


Joomla CMS: Référence du fichier CliDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier CliDescriptor.php

Structures de données

class CliDescriptor

Espaces de nommage

Symfony\Component\VarDumper\Command\Descriptor


Joomla CMS: Référence du fichier CliDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage
Référence du fichier CliDumper.php

Structures de données

class CliDumper

Espaces de nommage

Symfony\Component\VarDumper\Dumper


Joomla CMS: Référence du fichier Client.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth1
  • src
Structures de données | Espaces de nommage
Référence du fichier oauth1/src/Client.php

Structures de données

class Client

Espaces de nommage

Joomla\OAuth1


Joomla CMS: Référence du fichier Client.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth2
  • src
Structures de données | Espaces de nommage
Référence du fichier oauth2/src/Client.php

Structures de données

class Client

Espaces de nommage

Joomla\OAuth2


Joomla CMS: Référence du fichier ClientController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ClientController.php

Structures de données

class ClientController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier ClientExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
  • src
Structures de données | Espaces de nommage
Référence du fichier ClientExceptionInterface.php

Structures de données

interface ClientExceptionInterface

Espaces de nommage

Psr\Http\Client


Joomla CMS: Référence du fichier ClientHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Client
Structures de données | Espaces de nommage
Référence du fichier ClientHelper.php

Structures de données

class ClientHelper

Espaces de nommage

Joomla\CMS\Client


Joomla CMS: Référence du fichier ClientInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
  • src
Structures de données | Espaces de nommage
Référence du fichier ClientInterface.php

Structures de données

interface ClientInterface

Espaces de nommage

Psr\Http\Client


Joomla CMS: Référence du fichier ClientModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ClientModel.php

Structures de données

class ClientModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier ClientsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Controller/ClientsController.php

Structures de données

class ClientsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier ClientsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_banners/src/Controller/ClientsController.php

Structures de données

class ClientsController

Espaces de nommage

Joomla\API
Joomla\Component\Banners\Api\Controller


Joomla CMS: Référence du fichier ClientsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ClientsModel.php

Structures de données

class ClientsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier ClientTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ClientTable.php

Structures de données

class ClientTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Table


Joomla CMS: Référence du fichier CliErrorRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorRenderer
Structures de données | Espaces de nommage
Référence du fichier CliErrorRenderer.php

Structures de données

class CliErrorRenderer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorRenderer


Joomla CMS: Référence du fichier CliInput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
Structures de données | Espaces de nommage
Référence du fichier CliInput.php

Structures de données

class CliInput

Espaces de nommage

Joomla\CMS\Application\CLI


Joomla CMS: Référence du fichier CliOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
Structures de données | Espaces de nommage
Référence du fichier CliOutput.php

Structures de données

class CliOutput

Espaces de nommage

Joomla\CMS\Application\CLI


Joomla CMS: Référence du fichier CliRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier CliRenderer.php

Structures de données

class CliRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier ClonerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier ClonerInterface.php

Structures de données

interface ClonerInterface

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier cloud.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • tmpl
Espaces de nommage | Variables
Référence du fichier cloud.php

Espaces de nommage

Joomla\Site

Variables

$minsize = $params->get('minsize', 1)
$maxsize = $params->get('maxsize', 2)
else __pad0__
$maxcount = null
foreach($list as $item) | $countdiff = $maxcount - $mincount
foreach( $list as $item)($countdiff===0) | else
endif
endforeach

Documentation des variables

◆ $countdiff

foreach ( $list as $item) $countdiff = $maxcount - $mincount

◆ $maxcount

$maxcount = null

◆ $maxsize

$maxsize = $params->get('maxsize', 2)

◆ $minsize

$minsize = $params->get('minsize', 1)

◆ __pad0__

else __pad0__

◆ else

foreach ($list as $item) ( $countdiff===0) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier cms.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Variables
Référence du fichier cms.php

Variables

if(!defined('JPATH_PLATFORM')) if(!class_exists('JLoader')) if(!class_exists('JLoader')) $loader = require JPATH_LIBRARIES . '/vendor/autoload.php'
$behavior = new \TYPO3\PharStreamWrapper\Behavior()

Documentation des variables

◆ $behavior

$behavior = new \TYPO3\PharStreamWrapper\Behavior()

◆ $loader

if (!defined( 'JPATH_PLATFORM')) if (!class_exists( 'JLoader')) if (!class_exists( 'JLoader')) $loader = require JPATH_LIBRARIES . '/vendor/autoload.php'


Joomla CMS: Référence du fichier CMSApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier CMSApplication.php

Structures de données

class CMSApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier CMSApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier CMSApplicationInterface.php

Structures de données

interface CMSApplicationInterface

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier CMSHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier CMSHelper.php

Structures de données

class CMSHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier CMSObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Object
Structures de données | Espaces de nommage
Référence du fichier CMSObject.php

Structures de données

class CMSObject

Espaces de nommage

Joomla\CMS\Object


Joomla CMS: Référence du fichier CMSPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier CMSPlugin.php

Structures de données

class CMSPlugin

Espaces de nommage

Joomla\CMS\Plugin


Joomla CMS: Référence du fichier CMSWebApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier CMSWebApplicationInterface.php

Structures de données

interface CMSWebApplicationInterface

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier CodeAccuracyDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier CodeAccuracyDescriptor.php

Structures de données

class CodeAccuracyDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier CodecInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier CodecInterface.php

Structures de données

interface CodecInterface

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier codemirror.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
Structures de données | Espaces de nommage
Référence du fichier codemirror.php

Structures de données

class PlgEditorCodemirror

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier CodePointString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier CodePointString.php

Structures de données

class CodePointString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier collapse-default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage
Référence du fichier collapse-default.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier collapse-metismenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage
Référence du fichier collapse-metismenu.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier Collectable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier Collectable.php

Structures de données

interface Collectable

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier CollectedClientData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier CollectedClientData.php

Structures de données

class CollectedClientData

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier Collection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier symfony/ldap/Adapter/ExtLdap/Collection.php

Structures de données

class Collection

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier Collection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier tobscure/json-api/src/Collection.php

Structures de données

class Collection

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier CollectionAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier CollectionAdapter.php

Structures de données

class CollectionAdapter

Espaces de nommage

Joomla\CMS\Updater\Adapter


Joomla CMS: Référence du fichier CollectionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier CollectionInterface.php

Structures de données

interface CollectionInterface

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier color.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • color
Structures de données | Espaces de nommage
Référence du fichier color.php

Structures de données

class PlgFieldsColor

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier color.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • color
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/color.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') if (is_array( $value))

Documentation des variables

◆ $value

$value = $field->value

◆ if

if ( $value=='') if(is_array($value))


Joomla CMS: Référence du fichier Color.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier Color.php

Structures de données

class Color

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier ColorField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ColorField.php

Structures de données

class ColorField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ColorProcessor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
  • Processor
Structures de données | Espaces de nommage
Référence du fichier ColorProcessor.php

Structures de données

class ColorProcessor

Espaces de nommage

Joomla\CMS\Application\CLI\Output\Processor


Joomla CMS: Référence du fichier ColorRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ColorRule.php

Structures de données

class ColorRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier ColorStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
Structures de données | Espaces de nommage
Référence du fichier ColorStyle.php

Structures de données

class ColorStyle

Espaces de nommage

Joomla\CMS\Application\CLI


Joomla CMS: Référence du fichier CombGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier CombGenerator.php

Structures de données

class CombGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier combiningClass.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • unidata
Référence du fichier combiningClass.php


Joomla CMS: Référence du fichier combo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier combo.php

Espaces de nommage

Joomla\Site

Variables

$attr = ''
$val = []
foreach ( $options as $option)

Documentation des variables

◆ $attr

$attr = ''

◆ $val

$val = []
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par BinaryField\__construct(), BufferingLogger\__destruct(), ArrayInput\__toString(), Update\_endElement(), ParagonIE_Sodium_Compat\add(), PHP\bitwise_small_split(), BigInteger\bitwise_split(), PHP\bitwise_split(), PhpSetting\boolean(), BaseAccept\buildParametersString(), BigInteger\create(), Inline\dump(), Inline\dumpArray(), Changelog\endElement(), SqlsrvStatement\execute(), phpseclib3\Crypt\EC\Formats\Keys\extractPoint(), SubformField\filter(), FormField\filter(), Update\find(), Extension\find(), HtmlErrorRenderer\formatLogMessage(), RegistrationModel\getData(), DoublePrecisionFloatObject\getNormalizedData(), HalfPrecisionFloatObject\getNormalizedData(), SinglePrecisionFloatObject\getNormalizedData(), PredefinedlistField\getOptions(), PHP32\initialize(), PHP64\initialize(), ConsoleLogger\interpolate(), MessagesCollector\interpolate(), IpHelper\IPinList(), Inline\isHash(), Http\makeTransportRequest(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), SysinfoModel\parsePhpInfo(), MenusHelper\parseXmlNode(), Decoder\process(), Decoder\processFinite(), Select\radiolist(), Installer\removeFiles(), WarningsModel\return_bytes(), System\server(), PhpSetting\set(), Cookie\set(), RSA\setExponent(), HTMLHelper\setFormatOptions(), RSA\setOpenSSLConfigPath(), RSA\setSmallestPrime(), PgsqlDriver\sqlValue(), PhpSetting\string(), Assertion\stringify(), ParagonIE_Sodium_Compat\sub(), MediaHelper\toBytes(), PgsqlDriver\updateObject(), DatabaseDriver\updateObject(), et OptionsResolver\verifyTypes().

◆ foreach

foreach($options as $option)


Joomla CMS: Référence du fichier ComboField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComboField.php

Structures de données

class ComboField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Command.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier Command.php

Structures de données

class Command

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier CommandCompletionTester.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
Structures de données | Espaces de nommage
Référence du fichier CommandCompletionTester.php

Structures de données

class CommandCompletionTester

Espaces de nommage

Symfony\Component\Console\Tester


Joomla CMS: Référence du fichier CommandErrorEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier CommandErrorEvent.php

Structures de données

class CommandErrorEvent

Espaces de nommage

Joomla\Console\Event


Joomla CMS: Référence du fichier CommandIsSuccessful.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier CommandIsSuccessful.php

Structures de données

class CommandIsSuccessful

Espaces de nommage

Symfony\Component\Console\Tester\Constraint


Joomla CMS: Référence du fichier CommandLoaderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CommandLoader
Structures de données | Espaces de nommage
Référence du fichier CommandLoaderInterface.php

Structures de données

interface CommandLoaderInterface

Espaces de nommage

Symfony\Component\Console\CommandLoader


Joomla CMS: Référence du fichier CommandNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CommandNotFoundException.php

Structures de données

class CommandNotFoundException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier CommandTester.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
Structures de données | Espaces de nommage
Référence du fichier CommandTester.php

Structures de données

class CommandTester

Espaces de nommage

Symfony\Component\Console\Tester


Joomla CMS: Référence du fichier Common.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Base64
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/Base64/Common.php

Structures de données

class ParagonIE_Sodium_Core_Base64_Common


Joomla CMS: Référence du fichier Common.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Espaces de nommage | Fonctions | Variables
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/Formats/Keys/Common.php

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys

Fonctions

static | initialize_static_variables ()
static | setImplicitCurve (BaseCurve $curve)
static | loadCurveByParam (array $params)
static | extractPoint ($str, BaseCurve $curve)
static | encodeParameters (BaseCurve $curve, $returnArray=false, array $options=[])
static | useSpecifiedCurve ()
static | useNamedCurve ()

Variables

trait | Common
static | $childOIDsLoaded = false
static | $useNamedCurves = true


Joomla CMS: Référence du fichier CompactSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier CompactSerializer.php

Structures de données

class CompactSerializer

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier compare.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • compare
Espaces de nommage | Variables
Référence du fichier compare.php

Espaces de nommage

Joomla\Administrator

Variables

$version2 = $this->items[0]
$version1 = $this->items[1]
$object1 = $version1->data
$object2 = $version2->data
$wa = $this->document->getWebAssetManager()
foreach( $object1 as $name=> $value)(isset( $value->value) &&isset( $object2-> $name->value) &&$value->value !=$object2-> $name->value)(is_object($value->value)) foreach($value->value as $subName=> $subValue) if( $subValue->value||$newSubValue)&($subValue->value !=$newSubValue) | nbsp
endif
endforeach
else __pad0__
$object2 $name | value = is_object($object2->$name->value) ? json_encode($object2->$name->value) : $object2->$name->value

Documentation des variables

◆ $object1

$object1 = $version1->data

◆ $object2

$object2 = $version2->data

◆ $version1

$version1 = $this->items[1]

Référencé par Assertion\version().

◆ $version2

$version2 = $this->items[0]

Référencé par Assertion\version().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif

◆ nbsp

foreach($object1 as $name => $value) (isset($value->value) && isset($object2->$name->value) && $value->value != $object2->$name->value) (is_object( $value->value)) foreach ( $value->value as $subName=> $subValue)if ($subValue->value || $newSubValue)& ( $subValue->value !=$newSubValue) nbsp

◆ value

string $max The maximum value = is_object($object2->$name->value) ? json_encode($object2->$name->value) : $object2->$name->value

Référencé par AssertionChain\__call(), BigInteger\__clone(), CharacterString\__construct(), ImgStub\__construct(), RelativeObjectIdentifier\__construct(), DsPairStub\__construct(), OctetString\__construct(), AbstractTime\__construct(), CutStub\__construct(), ConstStub\__construct(), Suggestion\__construct(), TaggedValue\__construct(), UnknownObject\__construct(), UTF8String\__construct(), VisibleString\__construct(), FrameStub\__construct(), GeneralString\__construct(), GraphicString\__construct(), IPAddress\__construct(), EnumStub\__construct(), ArgsStub\__construct(), Boolean\__construct(), UniversalString\__construct(), LinkStub\__construct(), ObjectIdentifier\__construct(), T61String\__construct(), AbstractString\__construct(), NumericString\__construct(), ClassStub\__construct(), MapItem\__construct(), TableCell\__construct(), TraceStub\__construct(), Integer\__construct(), ByteStringObject\__construct(), BMPString\__construct(), GeneralizedTime\__construct(), InvalidArgumentException\__construct(), BaseAccept\__construct(), Basic\__construct(), BigInteger\__construct(), PrintableString\__construct(), BigDecimal\__construct(), GMP\__construct(), BCMath\__construct(), PHP\__construct(), Engine\__construct(), AssertionChain\__construct(), BigInteger\__debugInfo(), SubformField\__set(), AbstractTime\__toString(), GeneralizedTime\__toString(), ObjectIdentifier\__toString(), LazyString\__toString(), Engine\__wakeup(), BigInteger\__wakeup(), BCMath\abs(), GMP\abs(), BigInteger\abs(), PHP32\add(), PHP64\add(), GMP\add(), BCMath\add(), BigInteger\add(), Integer\add(), Users\admin_language(), BigInteger\and(), BigInteger\between(), GMP\bitwise_and(), BigInteger\bitwise_and(), BigInteger\bitwise_leftRotate(), BCMath\bitwise_leftShift(), GMP\bitwise_leftShift(), BigInteger\bitwise_leftShift(), BigInteger\bitwise_not(), GMP\bitwise_or(), BigInteger\bitwise_or(), BigInteger\bitwise_rightRotate(), BCMath\bitwise_rightShift(), GMP\bitwise_rightShift(), BigInteger\bitwise_rightShift(), BigInteger\bitwise_split(), GMP\bitwise_xor(), BigInteger\bitwise_xor(), OctetString\calculateContentLength(), AbstractString\calculateContentLength(), ExceptionCaster\castThrowingCasterException(), AbstractString\checkString(), Integer\compare(), GMP\compare(), PHP32\compare(), PHP64\compare(), BCMath\compare(), BigInteger\compare(), BigInteger\compareTo(), BigInteger\createRecurringModuloFunction(), Integer\divide(), GMP\divide(), BCMath\divide(), BigInteger\divide(), BigInteger\dividedBy(), PHP\divideHelper(), Users\editor(), Integer\equals(), PHP32\equals(), PHP64\equals(), GMP\equals(), BCMath\equals(), BigInteger\equals(), GMP\extendedGCD(), GMP\gcd(), BigInteger\gcd(), ListHelper\genericordering(), BigInteger\getBitLength(), Boolean\getContent(), OctetString\getContent(), UTCTime\getEncodedValue(), Boolean\getEncodedValue(), IPAddress\getEncodedValue(), Integer\getEncodedValue(), GeneralizedTime\getEncodedValue(), ArticleModel\getForm(), MenuField\getGroups(), ContenttypeField\getInput(), ImptotalField\getInput(), ImpmadeField\getInput(), ClicksField\getInput(), AssociationField\getInput(), FieldLayoutField\getInput(), FiltersField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), UploaddirsField\getInput(), TagField\getInput(), TemplatesListField\getInput(), OrderingField\getInput(), ModulesPositioneditField\getInput(), CalendarField\getInput(), EditorField\getInput(), RadioField\getLayoutData(), RadiobasicField\getLayoutData(), TinymcebuilderField\getLayoutData(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), UserField\getLayoutData(), JoomlatokenField\getLayoutData(), CheckboxesField\getLayoutData(), NumberField\getLayoutData(), ColorField\getLayoutData(), MediaField\getLayoutData(), CalendarField\getLayoutData(), FormField\getLayoutData(), ByteStringObject\getLength(), BigInteger\getLength(), BigInteger\getLengthInBytes(), LanguageField\getOptions(), FieldcontextsField\getOptions(), WorkflowcontextsField\getOptions(), WorkflowconditionField\getOptions(), TagField\getOptions(), BigInteger\getPrecision(), BigDecimal\getSign(), BigInteger\getSign(), Joomla\CMS\MVC\Model\getStageForNewItem(), BigDecimal\getUnscaledValue(), User\groups(), PHP64\initialize(), PHP32\initialize(), BCMath\initialize(), GMP\initialize(), PHP\initialize(), BigInteger\isEven(), BCMath\isNegative(), GMP\isNegative(), BigInteger\isNegative(), Integer\isOdd(), BCMath\isOdd(), GMP\isOdd(), BigInteger\isOdd(), PHP\isOdd(), BigInteger\isPrime(), Users\language(), SubformField\loadSubFormData(), BigInteger\lowerThan(), PHP\lshift(), BCMath\make_odd(), GMP\make_odd(), PHP\make_odd(), BigInteger\minus(), BigInteger\mod(), GMP\modInverse(), BigInteger\modInverse(), BigInteger\modPow(), BigDecimal\multipliedBy(), BigInteger\multipliedBy(), PHP32\multiply(), PHP64\multiply(), GMP\multiply(), BCMath\multiply(), BigInteger\multiply(), Integer\multiply(), Integer\negate(), BCMath\negate(), BigInteger\negate(), BigDecimal\negated(), BigInteger\negated(), AssertionChain\nullOr(), BigInteger\or(), BigDecimal\plus(), BigInteger\plus(), Integer\pow(), GMP\pow(), BCMath\pow(), BigInteger\pow(), BigDecimal\power(), BigInteger\power(), BigInteger\powMod(), BigInteger\quotient(), BigInteger\quotientAndRemainder(), GMP\randomRangePrimeInner(), BigInteger\remainder(), BigInteger\root(), GMP\rootInner(), PHP\rshift(), BigDecimal\serialize(), BigInteger\setPrecision(), Engine\setPrecision(), CheckboxField\setup(), SubformField\setup(), FormField\setup(), FormField\setValue(), BigDecimal\sqrt(), BigInteger\sqrt(), Integer\squareRoot(), BigDecimal\stripTrailingZeros(), PHP32\subtract(), PHP64\subtract(), GMP\subtract(), BCMath\subtract(), Integer\subtract(), BigInteger\subtract(), Users\templatestyle(), BCMath\testBit(), GMP\testBit(), BigInteger\testBit(), PHP\testBit(), GMP\testPrimality(), BCMath\testSmallPrimes(), PHP\testSmallPrimes(), BigInteger\toArbitraryBase(), BigInteger\toBase(), BigInteger\toBigDecimal(), Integer\toBigInteger(), BigDecimal\toBigRational(), BigInteger\toBits(), Integer\toBits(), GMP\toBytes(), PHP\toBytes(), BigInteger\toBytes(), Integer\toBytes(), BigInteger\toHex(), BigInteger\toInt(), BCMath\toString(), PHP\toString(), BigInteger\toString(), BigDecimal\unserialize(), BigInteger\unserialize(), BigDecimal\valueWithMinScale(), BigDecimal\withPointMovedLeft(), et BigInteger\xor().


Joomla CMS: Référence du fichier CompareModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier CompareModel.php

Structures de données

class CompareModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Model


Joomla CMS: Référence du fichier Compat.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
Structures de données | Espaces de nommage
Référence du fichier namespaced/Compat.php

Structures de données

class Compat

Espaces de nommage

ParagonIE\Sodium


Joomla CMS: Référence du fichier Compat.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Structures de données
Référence du fichier src/Compat.php

Structures de données

class ParagonIE_Sodium_Compat


Joomla CMS: Référence du fichier compatibilityDecomposition.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • unidata
Référence du fichier compatibilityDecomposition.php


Joomla CMS: Référence du fichier complete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/tmpl/joomlaupdate/complete.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier complete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • registration
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/registration/complete.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier complete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • reset
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/reset/complete.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier CompleteCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier CompleteCommand.php

Structures de données

class CompleteCommand

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier CompletionInput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
Structures de données | Espaces de nommage
Référence du fichier CompletionInput.php

Structures de données

class CompletionInput

Espaces de nommage

Symfony\Component\Console\Completion


Joomla CMS: Référence du fichier CompletionOutputInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
  • Output
Structures de données | Espaces de nommage
Référence du fichier CompletionOutputInterface.php

Structures de données

interface CompletionOutputInterface

Espaces de nommage

Symfony\Component\Console\Completion\Output


Joomla CMS: Référence du fichier CompletionSuggestions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
Structures de données | Espaces de nommage
Référence du fichier CompletionSuggestions.php

Structures de données

class CompletionSuggestions

Espaces de nommage

Symfony\Component\Console\Completion


Joomla CMS: Référence du fichier Component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Component.php

Structures de données

class Component

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier administrator/templates/atum/component.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->getWebAssetManager()
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template atum template active template active template atum rtl rtl ltr image joomla favicon svg icon rel type image svg xml image favicon ico alternate icon rel type image vnd microsoft icon image joomla favicon pinned svg mask icon rel color

Documentation des variables

◆ $wa

$wa = $this->getWebAssetManager()

◆ color

string $saveFormat Format to save the color

Référencé par OutputFormatterStyle\__construct(), OutputFormatterStyle\apply(), MeterField\getLayoutData(), OutputFormatterStyle\setBackground(), OutputFormatterStyle\setForeground(), OutputFormatterStyle\setOption(), OutputFormatterStyle\setOptions(), MeterField\setup(), et OutputFormatterStyle\unsetOption().


Joomla CMS: Référence du fichier component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • system
Espaces de nommage
Référence du fichier administrator/templates/system/component.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
Espaces de nommage | Variables
Référence du fichier templates/cassiopeia/component.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$wa = $this->getWebAssetManager()
$paramsColorName = $this->params->get('colorName', 'colors_standard')
$assetColorName = 'theme.' . $paramsColorName
$paramsFontScheme = $this->params->get('useFontScheme', false)
$fontStyles = ''
if($paramsFontScheme) $wa usePreset ( 'template.cassiopeia.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->useScript( 'template.user') ->addInlineStyle(":root

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assetColorName

$assetColorName = 'theme.' . $paramsColorName

◆ $fontStyles

$fontStyles = ''

◆ $paramsColorName

$paramsColorName = $this->params->get('colorName', 'colors_standard')

◆ $paramsFontScheme

$paramsFontScheme = $this->params->get('useFontScheme', false)

◆ $wa

$wa = $this->getWebAssetManager()

◆ usePreset

if ( $paramsFontScheme) $wa usePreset('template.cassiopeia.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->useScript('template.user') ->addInlineStyle(":root


Joomla CMS: Référence du fichier component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Espaces de nommage
Référence du fichier templates/system/component.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier ComponentAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier ComponentAdapter.php

Structures de données

class ComponentAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier ComponentController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/Controller/ComponentController.php

Structures de données

class ComponentController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Controller


Joomla CMS: Référence du fichier ComponentController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_config/src/Controller/ComponentController.php

Structures de données

class ComponentController

Espaces de nommage

Joomla\API
Joomla\Component\Config\Api\Controller


Joomla CMS: Référence du fichier ComponentDispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier ComponentDispatcher.php

Structures de données

class ComponentDispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ComponentDispatcherFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier Dispatcher/ComponentDispatcherFactory.php

Structures de données

class ComponentDispatcherFactory

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ComponentDispatcherFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/ComponentDispatcherFactory.php

Structures de données

class ComponentDispatcherFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier ComponentDispatcherFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier ComponentDispatcherFactoryInterface.php

Structures de données

interface ComponentDispatcherFactoryInterface

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ComponentHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
Structures de données | Espaces de nommage
Référence du fichier ComponentHelper.php

Structures de données

class ComponentHelper

Espaces de nommage

Joomla\CMS\Component


Joomla CMS: Référence du fichier ComponentInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ComponentInterface.php

Structures de données

interface ComponentInterface

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier ComponentlayoutField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentlayoutField.php

Structures de données

class ComponentlayoutField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ComponentModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ComponentModel.php

Structures de données

class ComponentModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Model


Joomla CMS: Référence du fichier ComponentRecord.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
Structures de données | Espaces de nommage
Référence du fichier ComponentRecord.php

Structures de données

class ComponentRecord

Espaces de nommage

Joomla\CMS\Component


Joomla CMS: Référence du fichier ComponentRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier ComponentRenderer.php

Structures de données

class ComponentRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier ComponentsCategoryField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentsCategoryField.php

Structures de données

class ComponentsCategoryField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Field


Joomla CMS: Référence du fichier ComponentsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentsField.php

Structures de données

class ComponentsField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ComponentsFieldgroupField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentsFieldgroupField.php

Structures de données

class ComponentsFieldgroupField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier ComponentsFieldsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentsFieldsField.php

Structures de données

class ComponentsFieldsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier ComponentsWorkflowField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ComponentsWorkflowField.php

Structures de données

class ComponentsWorkflowField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Field


Joomla CMS: Référence du fichier config.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • config
Structures de données | Espaces de nommage
Référence du fichier config.php

Structures de données

class PlgWebservicesConfig

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Config.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Config.php

Structures de données

class Config

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier ConfigCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier ConfigCollector.php

Structures de données

class ConfigCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier ConfigComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ConfigComponent.php

Structures de données

class ConfigComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Extension


Joomla CMS: Référence du fichier ConfigComponentsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ConfigComponentsField.php

Structures de données

class ConfigComponentsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Field


Joomla CMS: Référence du fichier ConfigController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/Controller/ConfigController.php

Structures de données

class ConfigController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Controller


Joomla CMS: Référence du fichier ConfigController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Controller/ConfigController.php

Structures de données

class ConfigController

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Controller


Joomla CMS: Référence du fichier ConfigHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ConfigHelper.php

Structures de données

class ConfigHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Helper


Joomla CMS: Référence du fichier ConfigModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/Model/ConfigModel.php

Structures de données

class ConfigModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Model


Joomla CMS: Référence du fichier ConfigModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Model/ConfigModel.php

Structures de données

class ConfigModel

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Model


Joomla CMS: Référence du fichier ConfigPostProcessor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Structures de données | Espaces de nommage
Référence du fichier ConfigPostProcessor.php

Structures de données

class ConfigPostProcessor

Espaces de nommage

Laminas\ZendFrameworkBridge


Joomla CMS: Référence du fichier ConfigProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier ConfigProvider.php

Structures de données

class ConfigProvider

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier Configuration.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/Service/HTML/Configuration.php

Structures de données

class Configuration

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Service\HTML


Joomla CMS: Référence du fichier Configuration.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/lcobucci/jwt/src/Configuration.php

Structures de données

class Configuration

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier ConfigurationAwareApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier ConfigurationAwareApplicationInterface.php

Structures de données

interface ConfigurationAwareApplicationInterface

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier ConfigurationModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ConfigurationModel.php

Structures de données

class ConfigurationModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier confirm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • reset
Espaces de nommage | Variables
Référence du fichier confirm.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier ConfirmationQuestion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Question
Structures de données | Espaces de nommage
Référence du fichier ConfirmationQuestion.php

Structures de données

class ConfirmationQuestion

Espaces de nommage

Symfony\Component\Console\Question


Joomla CMS: Référence du fichier ConfirmButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier ConfirmButton.php

Structures de données

class ConfirmButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier confirmconsent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • confirmconsent
Structures de données | Espaces de nommage
Référence du fichier confirmconsent.php

Structures de données

class PlgContentConfirmConsent

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ConfirmModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ConfirmModel.php

Structures de données

class ConfirmModel

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Model


Joomla CMS: Référence du fichier ConjunctionInterceptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Interceptor
Structures de données | Espaces de nommage
Référence du fichier ConjunctionInterceptor.php

Structures de données

class ConjunctionInterceptor

Espaces de nommage

TYPO3\PharStreamWrapper\Interceptor


Joomla CMS: Référence du fichier Connection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier ldap/Adapter/ExtLdap/Connection.php

Structures de données

class Connection

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier Connection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Server
Structures de données | Espaces de nommage
Référence du fichier var-dumper/Server/Connection.php

Structures de données

class Connection

Espaces de nommage

Symfony\Component\VarDumper\Server


Joomla CMS: Référence du fichier ConnectionClosedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ConnectionClosedException.php

Structures de données

class ConnectionClosedException

Espaces de nommage

ConnectionClosedException
phpseclib3\Exception


Joomla CMS: Référence du fichier ConnectionEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier ConnectionEvent.php

Structures de données

class ConnectionEvent

Espaces de nommage

Joomla\Database\Event


Joomla CMS: Référence du fichier ConnectionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ConnectionException.php

Structures de données

class ConnectionException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier ConnectionFailureException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ConnectionFailureException.php

Structures de données

class ConnectionFailureException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier ConnectionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier ConnectionInterface.php

Structures de données

interface ConnectionInterface

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier ConnectionOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier ConnectionOptions.php

Structures de données

class ConnectionOptions

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier ConnectionTimeoutException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ConnectionTimeoutException.php

Structures de données

class ConnectionTimeoutException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier ConsentBoxField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • confirmconsent
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ConsentBoxField.php

Structures de données

class ConsentBoxField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Content\ConfirmConsent\Field


Joomla CMS: Référence du fichier consents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • consents
Structures de données | Espaces de nommage
Référence du fichier consents.php

Structures de données

class PlgPrivacyConsents

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ConsentsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Controller/ConsentsController.php

Structures de données

class ConsentsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Controller


Joomla CMS: Référence du fichier ConsentsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_privacy/src/Controller/ConsentsController.php

Structures de données

class ConsentsController

Espaces de nommage

Joomla\API
Joomla\Component\Privacy\Api\Controller


Joomla CMS: Référence du fichier ConsentsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ConsentsModel.php

Structures de données

class ConsentsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier ConsentTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ConsentTable.php

Structures de données

class ConsentTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Table


Joomla CMS: Référence du fichier Console.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Console.php

Structures de données

class Console

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier ConsoleApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier ConsoleApplication.php

Structures de données

class ConsoleApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier ConsoleCommandEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Structures de données | Espaces de nommage
Référence du fichier ConsoleCommandEvent.php

Structures de données

class ConsoleCommandEvent

Espaces de nommage

Symfony\Component\Console\Event


Joomla CMS: Référence du fichier ConsoleErrorEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Structures de données | Espaces de nommage
Référence du fichier ConsoleErrorEvent.php

Structures de données

class ConsoleErrorEvent

Espaces de nommage

Symfony\Component\Console\Event


Joomla CMS: Référence du fichier ConsoleEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Event/ConsoleEvent.php

Structures de données

class ConsoleEvent

Espaces de nommage

Joomla\Console\Event


Joomla CMS: Référence du fichier ConsoleEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Event/ConsoleEvent.php

Structures de données

class ConsoleEvent

Espaces de nommage

Symfony\Component\Console\Event


Joomla CMS: Référence du fichier ConsoleEvents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/ConsoleEvents.php

Structures de données

class ConsoleEvents

Espaces de nommage

Joomla\Console


Joomla CMS: Référence du fichier ConsoleEvents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier symfony/console/ConsoleEvents.php

Structures de données

class ConsoleEvents

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier ConsoleLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Logger
Structures de données | Espaces de nommage
Référence du fichier ConsoleLogger.php

Structures de données

class ConsoleLogger

Espaces de nommage

Symfony\Component\Console\Logger


Joomla CMS: Référence du fichier ConsoleOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier ConsoleOutput.php

Structures de données

class ConsoleOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier ConsoleOutputInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier ConsoleOutputInterface.php

Structures de données

interface ConsoleOutputInterface

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier ConsoleSectionOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier ConsoleSectionOutput.php

Structures de données

class ConsoleSectionOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier ConsoleSignalEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Structures de données | Espaces de nommage
Référence du fichier ConsoleSignalEvent.php

Structures de données

class ConsoleSignalEvent

Espaces de nommage

Symfony\Component\Console\Event


Joomla CMS: Référence du fichier ConsoleTerminateEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Structures de données | Espaces de nommage
Référence du fichier ConsoleTerminateEvent.php

Structures de données

class ConsoleTerminateEvent

Espaces de nommage

Symfony\Component\Console\Event


Joomla CMS: Référence du fichier constants.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Espaces de nommage | Variables
Référence du fichier constants.php

Espaces de nommage

Sodium

Variables

const | CRYPTO_AEAD_AES256GCM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_KEYBYTES
const | CRYPTO_AEAD_AES256GCM_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NSECBYTES
const | CRYPTO_AEAD_AES256GCM_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_NPUBBYTES
const | CRYPTO_AEAD_AES256GCM_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_AES256GCM_ABYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_ABYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES
const | CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = ParagonIE_Sodium_Compat::CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES
const | CRYPTO_AUTH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_BYTES
const | CRYPTO_AUTH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_AUTH_KEYBYTES
const | CRYPTO_BOX_SEALBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEALBYTES
const | CRYPTO_BOX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SECRETKEYBYTES
const | CRYPTO_BOX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_PUBLICKEYBYTES
const | CRYPTO_BOX_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_KEYPAIRBYTES
const | CRYPTO_BOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_MACBYTES
const | CRYPTO_BOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_NONCEBYTES
const | CRYPTO_BOX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_BOX_SEEDBYTES
const | CRYPTO_KX_BYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_BYTES
const | CRYPTO_KX_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SEEDBYTES
const | CRYPTO_KX_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_PUBLICKEYBYTES
const | CRYPTO_KX_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_KX_SECRETKEYBYTES
const | CRYPTO_GENERICHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES
const | CRYPTO_GENERICHASH_BYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MIN
const | CRYPTO_GENERICHASH_BYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_BYTES_MAX
const | CRYPTO_GENERICHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES
const | CRYPTO_GENERICHASH_KEYBYTES_MIN = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MIN
const | CRYPTO_GENERICHASH_KEYBYTES_MAX = ParagonIE_Sodium_Compat::CRYPTO_GENERICHASH_KEYBYTES_MAX
const | CRYPTO_SCALARMULT_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_BYTES
const | CRYPTO_SCALARMULT_SCALARBYTES = ParagonIE_Sodium_Compat::CRYPTO_SCALARMULT_SCALARBYTES
const | CRYPTO_SHORTHASH_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_BYTES
const | CRYPTO_SHORTHASH_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SHORTHASH_KEYBYTES
const | CRYPTO_SECRETBOX_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_KEYBYTES
const | CRYPTO_SECRETBOX_MACBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_MACBYTES
const | CRYPTO_SECRETBOX_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_SECRETBOX_NONCEBYTES
const | CRYPTO_SIGN_BYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_BYTES
const | CRYPTO_SIGN_SEEDBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SEEDBYTES
const | CRYPTO_SIGN_PUBLICKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_PUBLICKEYBYTES
const | CRYPTO_SIGN_SECRETKEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_SECRETKEYBYTES
const | CRYPTO_SIGN_KEYPAIRBYTES = ParagonIE_Sodium_Compat::CRYPTO_SIGN_KEYPAIRBYTES
const | CRYPTO_STREAM_KEYBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_KEYBYTES
const | CRYPTO_STREAM_NONCEBYTES = ParagonIE_Sodium_Compat::CRYPTO_STREAM_NONCEBYTES


Joomla CMS: Référence du fichier Constraint.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Structures de données | Espaces de nommage
Référence du fichier Constraint.php

Structures de données

interface Constraint

Espaces de nommage

Lcobucci\JWT\Validation


Joomla CMS: Référence du fichier ConstraintViolation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Structures de données | Espaces de nommage
Référence du fichier ConstraintViolation.php

Structures de données

class ConstraintViolation

Espaces de nommage

Lcobucci\JWT\Validation


Joomla CMS: Référence du fichier Construct.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier Construct.php

Structures de données

class Construct

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier ConstStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ConstStub.php

Structures de données

class ConstStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier contact.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/helpers/contact.php

Structures de données

class ContactHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier contact.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • contact
Structures de données | Espaces de nommage
Référence du fichier plugins/content/contact/contact.php

Structures de données

class PlgContentContact

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier contact.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • contact
Structures de données | Espaces de nommage
Référence du fichier plugins/editors-xtd/contact/contact.php

Structures de données

class PlgButtonContact

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier contact.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • contact
Structures de données | Espaces de nommage
Référence du fichier plugins/privacy/contact/contact.php

Structures de données

class PlgPrivacyContact

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier contact.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • contact
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/contact/contact.php

Structures de données

class PlgWebservicesContact

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ContactComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ContactComponent.php

Structures de données

class ContactComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Extension


Joomla CMS: Référence du fichier ContactController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/src/Controller/ContactController.php

Structures de données

class ContactController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Controller


Joomla CMS: Référence du fichier ContactController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_contact/src/Controller/ContactController.php

Structures de données

class ContactController

Espaces de nommage

Joomla\API
Joomla\Component\Contact\Api\Controller


Joomla CMS: Référence du fichier ContactController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Controller/ContactController.php

Structures de données

class ContactController

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Controller


Joomla CMS: Référence du fichier contactcreator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • contactcreator
Structures de données | Espaces de nommage
Référence du fichier contactcreator.php

Structures de données

class PlgUserContactCreator

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ContactEmailMessageRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ContactEmailMessageRule.php

Structures de données

class ContactEmailMessageRule

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Rule


Joomla CMS: Référence du fichier ContactEmailRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ContactEmailRule.php

Structures de données

class ContactEmailRule

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Rule


Joomla CMS: Référence du fichier ContactEmailSubjectRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ContactEmailSubjectRule.php

Structures de données

class ContactEmailSubjectRule

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Rule


Joomla CMS: Référence du fichier ContactField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier ContactField.php

Structures de données

class ContactField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Field\Modal


Joomla CMS: Référence du fichier ContactHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ContactHelper.php

Structures de données

class ContactHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Helper


Joomla CMS: Référence du fichier ContactModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/src/Model/ContactModel.php

Structures de données

class ContactModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Model


Joomla CMS: Référence du fichier ContactModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Model/ContactModel.php

Structures de données

class ContactModel

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Model


Joomla CMS: Référence du fichier contacts.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • contacts
Structures de données | Espaces de nommage
Référence du fichier contacts.php

Structures de données

class PlgFinderContacts

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ContactsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ContactsController.php

Structures de données

class ContactsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Controller


Joomla CMS: Référence du fichier ContactSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier ContactSerializer.php

Structures de données

class ContactSerializer

Espaces de nommage

Joomla\Component\Contact\Api\Serializer


Joomla CMS: Référence du fichier ContactsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ContactsModel.php

Structures de données

class ContactsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Model


Joomla CMS: Référence du fichier ContactTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ContactTable.php

Structures de données

class ContactTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Table


Joomla CMS: Référence du fichier Container.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/di/src/Container.php

Structures de données

class Container

Espaces de nommage

Joomla\DI


Joomla CMS: Référence du fichier Container.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier typo3/phar-stream-wrapper/src/Phar/Container.php

Structures de données

class Container

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier ContainerAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Structures de données | Espaces de nommage
Référence du fichier ContainerAwareInterface.php

Structures de données

interface ContainerAwareInterface

Espaces de nommage

Joomla\DI


Joomla CMS: Référence du fichier ContainerAwareToolbarFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Structures de données | Espaces de nommage
Référence du fichier ContainerAwareToolbarFactory.php

Structures de données

class ContainerAwareToolbarFactory

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier ContainerAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier ContainerAwareTrait.php

Espaces de nommage

Joomla\DI

Fonctions

getContainer ()
setContainer (Container $container)

Variables

trait ContainerAwareTrait


Joomla CMS: Référence du fichier containerclose.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage
Référence du fichier containerclose.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier ContainerCommandLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CommandLoader
Structures de données | Espaces de nommage
Référence du fichier ContainerCommandLoader.php

Structures de données

class ContainerCommandLoader

Espaces de nommage

Symfony\Component\Console\CommandLoader


Joomla CMS: Référence du fichier ContainerControllerResolver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ContainerControllerResolver.php

Structures de données

class ContainerControllerResolver

Espaces de nommage

Joomla\Application\Controller


Joomla CMS: Référence du fichier ContainerExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • container
  • src
Structures de données | Espaces de nommage
Référence du fichier ContainerExceptionInterface.php

Structures de données

interface ContainerExceptionInterface

Espaces de nommage

Psr\Container


Joomla CMS: Référence du fichier ContainerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • container
  • src
Structures de données | Espaces de nommage
Référence du fichier ContainerInterface.php

Structures de données

interface ContainerInterface

Espaces de nommage

Psr\Container


Joomla CMS: Référence du fichier ContainerLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Loader
Structures de données | Espaces de nommage
Référence du fichier ContainerLoader.php

Structures de données

class ContainerLoader

Espaces de nommage

Joomla\Console\Loader


Joomla CMS: Référence du fichier ContainerNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ContainerNotFoundException.php

Structures de données

class ContainerNotFoundException

Espaces de nommage

Joomla\DI\Exception


Joomla CMS: Référence du fichier containeropen.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier containeropen.php

Espaces de nommage

Joomla\Site

Variables

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier ContainerResource.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Structures de données | Espaces de nommage
Référence du fichier ContainerResource.php

Structures de données

class ContainerResource

Espaces de nommage

Joomla\DI


Joomla CMS: Référence du fichier Content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier HTML/Helpers/Content.php

Structures de données

class Content

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Table/Content.php

Structures de données

class Content

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/helpers/content.php

Structures de données

class ContentHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • content
Structures de données | Espaces de nommage
Référence du fichier plugins/finder/content/content.php

Structures de données

class PlgFinderContent

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • content
Structures de données | Espaces de nommage
Référence du fichier plugins/privacy/content/content.php

Structures de données

class PlgPrivacyContent

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier content.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • content
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/content/content.php

Structures de données

class PlgWebservicesContent

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ContentComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ContentComponent.php

Structures de données

class ContentComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Extension


Joomla CMS: Référence du fichier ContentHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Helper/ContentHelper.php

Structures de données

class ContentHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Helper


Joomla CMS: Référence du fichier ContentHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier api/components/com_content/src/Helper/ContentHelper.php

Structures de données

class ContentHelper

Espaces de nommage

Joomla\Api
Joomla\Component\Content\Api\Helper


Joomla CMS: Référence du fichier ContentHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Helper/ContentHelper.php

Structures de données

class ContentHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier ContentHistory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ContentHistory.php

Structures de données

class ContentHistory

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier contenthistory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/helpers/contenthistory.php

Structures de données

class ContenthistoryHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier contenthistory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage
Référence du fichier layouts/joomla/form/field/contenthistory.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier ContenthistoryField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ContenthistoryField.php

Structures de données

class ContenthistoryField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ContenthistoryHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ContenthistoryHelper.php

Structures de données

class ContenthistoryHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Helper


Joomla CMS: Référence du fichier ContentLanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier ContentLanguage.php

Structures de données

class ContentLanguage

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier ContentlanguageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ContentlanguageField.php

Structures de données

class ContentlanguageField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ContentmapField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ContentmapField.php

Structures de données

class ContentmapField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Field


Joomla CMS: Référence du fichier ContentSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier ContentSerializer.php

Structures de données

class ContentSerializer

Espaces de nommage

Joomla\Component\Content\Api\Serializer


Joomla CMS: Référence du fichier ContentType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ContentType.php

Structures de données

class ContentType

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier ContenttypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ContenttypeField.php

Structures de données

class ContenttypeField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ContenttypesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ContenttypesField.php

Structures de données

class ContenttypesField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Field


Joomla CMS: Référence du fichier ContextProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
  • ContextProvider
Structures de données | Espaces de nommage
Référence du fichier ContextProviderInterface.php

Structures de données

interface ContextProviderInterface

Espaces de nommage

Symfony\Component\VarDumper\Dumper\ContextProvider


Joomla CMS: Référence du fichier ContextualizedDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage
Référence du fichier ContextualizedDumper.php

Structures de données

class ContextualizedDumper

Espaces de nommage

Symfony\Component\VarDumper\Dumper


Joomla CMS: Référence du fichier Contrast.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Contrast.php

Structures de données

class Contrast

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier ControllerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ControllerInterface.php

Structures de données

interface ControllerInterface

Espaces de nommage

Joomla\CMS\MVC\Controller


Joomla CMS: Référence du fichier ControllerResolver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ControllerResolver.php

Structures de données

class ControllerResolver

Espaces de nommage

Joomla\Application\Controller


Joomla CMS: Référence du fichier ControllerResolverInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ControllerResolverInterface.php

Structures de données

interface ControllerResolverInterface

Espaces de nommage

Joomla\Application\Controller


Joomla CMS: Référence du fichier ConversionFailed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier ConversionFailed.php

Structures de données

class ConversionFailed

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier cookie.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • cookie
Structures de données | Espaces de nommage
Référence du fichier cookie.php

Structures de données

class PlgAuthenticationCookie

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Cookie.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Structures de données | Espaces de nommage
Référence du fichier src/Input/Cookie.php

Structures de données

class Cookie

Espaces de nommage

Joomla\CMS\Input


Joomla CMS: Référence du fichier Cookie.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/input/src/Cookie.php

Structures de données

class Cookie

Espaces de nommage

Joomla\Input


Joomla CMS: Référence du fichier core.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • mbstring
Espaces de nommage | Fonctions
Référence du fichier mbstring/core.php

Espaces de nommage

utf8

Fonctions

utf8_strlen ($str)
utf8_strpos ($str, $search, $offset=FALSE)
utf8_strrpos ($str, $search, $offset=FALSE)
utf8_substr ($str, $offset, $length=FALSE)
utf8_strtolower ($str)
utf8_strtoupper ($str)

Documentation des fonctions

◆ utf8_strlen()

utf8_strlen ( $str )

Référencé par StringHelper\strlen(), utf8_str_pad(), utf8_str_split(), utf8_strcspn(), utf8_strspn(), utf8_substr_replace(), et utf8_ucfirst().

◆ utf8_strpos()

utf8_strpos | ( | $str,
 |  | $search,
 |  | $offset = FALSE
 | ) |

Références Joomla\Database\Query\$offset.

Référencé par StringHelper\strpos().

◆ utf8_strrpos()

utf8_strrpos | ( | $str,
 |  | $search,
 |  | $offset = FALSE
 | ) |

Références Joomla\Database\Query\$offset.

Référencé par StringHelper\strrpos().

◆ utf8_strtolower()

utf8_strtolower ( $str )

Référencé par StringHelper\strcasecmp(), StringHelper\strtolower(), utf8_ireplace(), utf8_strcasecmp(), et utf8_stristr().

◆ utf8_strtoupper()

utf8_strtoupper ( $str )

Référencé par StringHelper\strtoupper(), utf8_ucfirst(), et utf8_ucwords_callback().

◆ utf8_substr()

utf8_substr | ( | $str,
 |  | $offset,
 |  | $length = FALSE
 | ) |

Références Joomla\Database\Query\$offset.

Référencé par StringHelper\substr(), utf8_str_pad(), utf8_strcspn(), et utf8_strspn().


Joomla CMS: Référence du fichier core.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • native
Espaces de nommage | Fonctions
Référence du fichier native/core.php

Espaces de nommage

utf8

Fonctions

utf8_strlen ($str)
utf8_strpos ($str, $needle, $offset=NULL)
utf8_strrpos ($str, $needle, $offset=NULL)
utf8_substr ($str, $offset, $length=NULL)
utf8_strtolower ($string)
utf8_strtoupper ($string)

Documentation des fonctions

◆ utf8_strlen()

utf8_strlen ( $str )

Référencé par utf8_strpos(), et utf8_strrpos().

◆ utf8_strpos()

utf8_strpos | ( | $str,
 |  | $needle,
 |  | $offset = NULL
 | ) |

Références Joomla\Database\Query\$offset, utf8_strlen(), et utf8_substr().

◆ utf8_strrpos()

utf8_strrpos | ( | $str,
 |  | $needle,
 |  | $offset = NULL
 | ) |

Références Joomla\Database\Query\$offset, utf8_strlen(), et utf8_substr().

◆ utf8_strtolower()

utf8_strtolower ( $string )

Références $i, utf8_from_unicode(), et utf8_to_unicode().

◆ utf8_strtoupper()

utf8_strtoupper ( $string )

Références $i, utf8_from_unicode(), et utf8_to_unicode().

◆ utf8_substr()

utf8_substr | ( | $str,
 |  | $offset,
 |  | $length = NULL
 | ) |

Références Joomla\Database\Query\$offset.

Référencé par utf8_strpos(), et utf8_strrpos().


Joomla CMS: Référence du fichier Core.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier Core.php

Structures de données

class Core

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier CoreAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Structures de données | Espaces de nommage
Référence du fichier CoreAssetItem.php

Structures de données

class CoreAssetItem

Espaces de nommage

Joomla\CMS\WebAsset\AssetItem


Joomla CMS: Référence du fichier CoreButtonsTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Espaces de nommage
Référence du fichier CoreButtonsTrait.php

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier CoreContent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier CoreContent.php

Structures de données

class CoreContent

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier CoreEventAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Espaces de nommage | Fonctions | Variables
Référence du fichier CoreEventAware.php

Espaces de nommage

Joomla\CMS\Event

Fonctions

trait static getEventClassByEventName (string $eventName)

Variables

trait CoreEventAware


Joomla CMS: Référence du fichier CoseSignatureFixer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • Util
Structures de données | Espaces de nommage
Référence du fichier CoseSignatureFixer.php

Structures de données

class CoseSignatureFixer

Espaces de nommage

Webauthn\Util


Joomla CMS: Référence du fichier CountryName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CountryName.php

Structures de données

class CountryName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier cpanel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage
Référence du fichier cpanel.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier CPSuri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CPSuri.php

Structures de données

class CPSuri

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier create-folder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • layouts
  • toolbar
Espaces de nommage | Variables
Référence du fichier create-folder.php

Espaces de nommage

Joomla\Administrator

Variables

$title = Text::_('COM_MEDIA_CREATE_NEW_FOLDER')

Documentation des variables

◆ $title

$title = Text::_('COM_MEDIA_CREATE_NEW_FOLDER')


Joomla CMS: Référence du fichier create.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • icons
Espaces de nommage | Variables
Référence du fichier create.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData['params']
else __pad2__

Documentation des variables

◆ $params

$params = $displayData['params']

◆ __pad2__

else __pad2__


Joomla CMS: Référence du fichier create_date.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage
Référence du fichier create_date.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier create_uploaded_file.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier create_uploaded_file.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

createUploadedFile (array $spec)


Joomla CMS: Référence du fichier create_uploaded_file.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier create_uploaded_file.php

Espaces de nommage

Laminas\Diactoros

Fonctions

createUploadedFile (array $spec)


Joomla CMS: Référence du fichier CreateSessionTableCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier CreateSessionTableCommand.php

Structures de données

class CreateSessionTableCommand

Espaces de nommage

Joomla\Session\Command


Joomla CMS: Référence du fichier CreateSessionTableException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CreateSessionTableException.php

Structures de données

class CreateSessionTableException

Espaces de nommage

Joomla\Session\Exception


Joomla CMS: Référence du fichier Credential.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier Credential.php

Structures de données

class Credential

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier CredentialRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
Structures de données | Espaces de nommage
Référence du fichier multifactorauth/webauthn/src/CredentialRepository.php

Structures de données

class CredentialRepository

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn


Joomla CMS: Référence du fichier CredentialRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
Structures de données | Espaces de nommage
Référence du fichier system/webauthn/src/CredentialRepository.php

Structures de données

class CredentialRepository

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn


Joomla CMS: Référence du fichier Credentials.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier Credentials.php

Structures de données

class Credentials

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn\Helper


Joomla CMS: Référence du fichier CRLDistributionPoints.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CRLDistributionPoints.php

Structures de données

class CRLDistributionPoints

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CRLNumber.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CRLNumber.php

Structures de données

class CRLNumber

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CRLReason.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier CRLReason.php

Structures de données

class CRLReason

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier CronExpression.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier CronExpression.php

Structures de données

class CronExpression

Espaces de nommage

Cron


Joomla CMS: Référence du fichier CronField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier CronField.php

Structures de données

class CronField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier crop.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • crop
Structures de données | Espaces de nommage
Référence du fichier crop.php

Structures de données

class PlgMediaActionCrop

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Crypt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier src/Crypt/Crypt.php

Structures de données

class Crypt

Espaces de nommage

Joomla\CMS\Crypt


Joomla CMS: Référence du fichier Crypt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/crypt/src/Crypt.php

Structures de données

class Crypt

Espaces de nommage

Joomla\Crypt


Joomla CMS: Référence du fichier CryptExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CryptExceptionInterface.php

Structures de données

interface CryptExceptionInterface

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier Crypto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • php-encryption
Structures de données | Variables
Référence du fichier php-encryption/Crypto.php

Structures de données

class | InvalidCiphertextException
class | CannotPerformOperationException
class | CryptoTestFailedException
class | Crypto
class | CryptoExceptionHandler

Variables

$crypto_exception_handler_object_dont_touch_me = new CryptoExceptionHandler()

Documentation des variables

◆ $crypto_exception_handler_object_dont_touch_me

$crypto_exception_handler_object_dont_touch_me = new CryptoExceptionHandler()


Joomla CMS: Référence du fichier Crypto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/defuse/php-encryption/src/Crypto.php

Structures de données

class Crypto

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier Crypto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Cipher
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/crypt/src/Cipher/Crypto.php

Structures de données

class Crypto

Espaces de nommage

Joomla\Crypt\Cipher


Joomla CMS: Référence du fichier Crypto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
Structures de données | Espaces de nommage
Référence du fichier vendor/paragonie/sodium_compat/namespaced/Crypto.php

Structures de données

class Crypto

Espaces de nommage

ParagonIE\Sodium


Joomla CMS: Référence du fichier Crypto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Structures de données
Référence du fichier vendor/paragonie/sodium_compat/src/Crypto.php

Structures de données

class ParagonIE_Sodium_Crypto


Joomla CMS: Référence du fichier Crypto32.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Structures de données
Référence du fichier Crypto32.php

Structures de données

class ParagonIE_Sodium_Crypto32


Joomla CMS: Référence du fichier CryptoCipher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Crypt
  • Cipher
Structures de données | Espaces de nommage
Référence du fichier CryptoCipher.php

Structures de données

class CryptoCipher

Espaces de nommage

Joomla\CMS\Crypt\Cipher


Joomla CMS: Référence du fichier CryptoException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier CryptoException.php

Structures de données

class CryptoException

Espaces de nommage

Defuse\Crypto\Exception


Joomla CMS: Référence du fichier CSR.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • CSR
Structures de données | Espaces de nommage
Référence du fichier CSR.php

Structures de données

class CSR

Espaces de nommage

FG\X509\CSR


Joomla CMS: Référence du fichier CssIdentifierRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier CssIdentifierRule.php

Structures de données

class CssIdentifierRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier CssIdentifierSubstringRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier CssIdentifierSubstringRule.php

Structures de données

class CssIdentifierSubstringRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier CssMenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier CssMenu.php

Structures de données

class CssMenu

Espaces de nommage

Joomla\Administrator
Joomla\Module\Menu\Administrator\Menu


Joomla CMS: Référence du fichier Ctx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • ChaCha20
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/ChaCha20/Ctx.php

Structures de données

class Ctx

Espaces de nommage

ParagonIE\Sodium\Core\ChaCha20


Joomla CMS: Référence du fichier Ctx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • ChaCha20
Structures de données
Référence du fichier src/Core/ChaCha20/Ctx.php

Structures de données

class ParagonIE_Sodium_Core_ChaCha20_Ctx


Joomla CMS: Référence du fichier Ctx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • ChaCha20
Structures de données
Référence du fichier src/Core32/ChaCha20/Ctx.php

Structures de données

class ParagonIE_Sodium_Core32_ChaCha20_Ctx


Joomla CMS: Référence du fichier Ctype.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-ctype
Structures de données | Espaces de nommage
Référence du fichier Ctype.php

Structures de données

class Ctype

Espaces de nommage

Symfony\Polyfill\Ctype


Joomla CMS: Référence du fichier Curl.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Structures de données | Espaces de nommage
Référence du fichier google/recaptcha/src/ReCaptcha/RequestMethod/Curl.php

Structures de données

class Curl

Espaces de nommage

ReCaptcha\RequestMethod


Joomla CMS: Référence du fichier Curl.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Transport
Structures de données | Espaces de nommage
Référence du fichier joomla/http/src/Transport/Curl.php

Structures de données

class Curl

Espaces de nommage

Joomla\Http\Transport


Joomla CMS: Référence du fichier CurlPost.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Structures de données | Espaces de nommage
Référence du fichier CurlPost.php

Structures de données

class CurlPost

Espaces de nommage

ReCaptcha\RequestMethod


Joomla CMS: Référence du fichier CurlTransport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
  • Transport
Structures de données | Espaces de nommage
Référence du fichier CurlTransport.php

Structures de données

class CurlTransport

Espaces de nommage

Joomla\CMS\Http\Transport


Joomla CMS: Référence du fichier CurrentUserInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Structures de données | Espaces de nommage
Référence du fichier CurrentUserInterface.php

Structures de données

interface CurrentUserInterface

Espaces de nommage

Joomla\CMS\User


Joomla CMS: Référence du fichier CurrentUserTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Espaces de nommage | Fonctions | Variables
Référence du fichier CurrentUserTrait.php

Espaces de nommage

Joomla\CMS\User

Fonctions

getCurrentUser ()
setCurrentUser (User $currentUser)

Variables

trait CurrentUserTrait


Joomla CMS: Référence du fichier Cursor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier console/Cursor.php

Structures de données

class Cursor

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier Cursor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier var-dumper/Cloner/Cursor.php

Structures de données

class Cursor

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier Curve.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Curve.php

Structures de données

class Curve

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Curve25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier paragonie/sodium_compat/namespaced/Core/Curve25519.php

Structures de données

class Curve25519

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier Curve25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/Curve25519.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519


Joomla CMS: Référence du fichier Curve25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core32/Curve25519.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519


Joomla CMS: Référence du fichier Curve25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Curve25519.php

Structures de données

class Curve25519

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Curve448.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier Curve448.php

Structures de données

class Curve448

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier CustomButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier CustomButton.php

Structures de données

class CustomButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier CutArrayStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier CutArrayStub.php

Structures de données

class CutArrayStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier CutStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier CutStub.php

Structures de données

class CutStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DaemonApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier DaemonApplication.php

Structures de données

class DaemonApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier Danish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Danish.php

Structures de données

class Danish

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier data.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
  • field
Espaces de nommage | Variables
Référence du fichier data.php

Espaces de nommage

Joomla\Plugin

Variables

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier Data.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier Data.php

Structures de données

class Data

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier Database.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Database.php

Structures de données

class Database

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier DatabaseAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseAwareInterface.php

Structures de données

interface DatabaseAwareInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Espaces de nommage | Fonctions | Variables
Référence du fichier src/MVC/Model/DatabaseAwareTrait.php

Espaces de nommage

Joomla\CMS\MVC\Model

Fonctions

getDbo ()
setDbo (DatabaseInterface $db=null)

Variables

trait DatabaseAwareTrait


Joomla CMS: Référence du fichier DatabaseAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier vendor/joomla/database/src/DatabaseAwareTrait.php

Espaces de nommage

Joomla\Database

Fonctions

getDatabase ()
setDatabase (DatabaseInterface $db)

Variables

trait DatabaseAwareTrait


Joomla CMS: Référence du fichier DatabaseconnectionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier DatabaseconnectionField.php

Structures de données

class DatabaseconnectionField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier DatabaseController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier DatabaseController.php

Structures de données

class DatabaseController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier DatabaseDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseDriver.php

Structures de données

class DatabaseDriver

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseEvents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseEvents.php

Structures de données

class DatabaseEvents

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseExporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseExporter.php

Structures de données

class DatabaseExporter

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseFactory.php

Structures de données

class DatabaseFactory

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier DatabaseHandler.php

Structures de données

class DatabaseHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier DatabaseHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier DatabaseHelper.php

Structures de données

class DatabaseHelper

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Helper


Joomla CMS: Référence du fichier DatabaseImporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseImporter.php

Structures de données

class DatabaseImporter

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseInterface.php

Structures de données

interface DatabaseInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseIterator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseIterator.php

Structures de données

class DatabaseIterator

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier DatabaseLogger.php

Structures de données

class DatabaseLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier DatabaseModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/Model/DatabaseModel.php

Structures de données

class DatabaseModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier DatabaseModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier installation/src/Model/DatabaseModel.php

Structures de données

class DatabaseModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier DatabaseModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier DatabaseModelInterface.php

Structures de données

interface DatabaseModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier DatabaseNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DatabaseNotFoundException.php

Structures de données

class DatabaseNotFoundException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier DatabaseProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier DatabaseProvider.php

Structures de données

class DatabaseProvider

Espaces de nommage

Joomla\Database\Service


Joomla CMS: Référence du fichier DatabaseQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier DatabaseQuery.php

Structures de données

class DatabaseQuery

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier DatabaseStrategy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Strategies
Structures de données | Espaces de nommage
Référence du fichier DatabaseStrategy.php

Structures de données

class DatabaseStrategy

Espaces de nommage

Joomla\Authentication\Strategies


Joomla CMS: Référence du fichier DataCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier DataCollector.php

Structures de données

class DataCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier DataCollectorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier DataCollectorInterface.php

Structures de données

interface DataCollectorInterface

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier DataDumperInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage
Référence du fichier DataDumperInterface.php

Structures de données

interface DataDumperInterface

Espaces de nommage

Symfony\Component\VarDumper\Dumper


Joomla CMS: Référence du fichier DataField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier DataField.php

Structures de données

class DataField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Stats\Field


Joomla CMS: Référence du fichier DataFormatter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/maximebf/debugbar/src/DebugBar/DataFormatter/DataFormatter.php

Structures de données

class DataFormatter

Espaces de nommage

DebugBar\DataFormatter


Joomla CMS: Référence du fichier DataFormatter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
Structures de données | Espaces de nommage
Référence du fichier plugins/system/debug/src/DataFormatter.php

Structures de données

class DataFormatter

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug


Joomla CMS: Référence du fichier DataFormatterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
Structures de données | Espaces de nommage
Référence du fichier DataFormatterInterface.php

Structures de données

interface DataFormatterInterface

Espaces de nommage

DebugBar\DataFormatter


Joomla CMS: Référence du fichier DataObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • data
  • src
Structures de données | Espaces de nommage
Référence du fichier DataObject.php

Structures de données

class DataObject

Espaces de nommage

Joomla\Data


Joomla CMS: Référence du fichier DataSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • data
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/data/src/DataSet.php

Structures de données

class DataSet

Espaces de nommage

Joomla\Data


Joomla CMS: Référence du fichier DataSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Token/DataSet.php

Structures de données

class DataSet

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier DataShapeObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • DataShape
Structures de données | Espaces de nommage
Référence du fichier DataShapeObject.php

Structures de données

class DataShapeObject

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\DataShape


Joomla CMS: Référence du fichier Date.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Date
Structures de données | Espaces de nommage
Référence du fichier Date/Date.php

Structures de données

class Date

Espaces de nommage

Joomla\CMS\Date


Joomla CMS: Référence du fichier Date.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier HTML/Helpers/Date.php

Structures de données

class Date

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier DateCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier DateCaster.php

Structures de données

class DateCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DayOfMonthField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier DayOfMonthField.php

Structures de données

class DayOfMonthField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier DayOfWeekField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier DayOfWeekField.php

Structures de données

class DayOfWeekField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier Debug.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier src/HTML/Helpers/Debug.php

Structures de données

class Debug

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Debug.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Structures de données | Espaces de nommage
Référence du fichier vendor/symfony/error-handler/Debug.php

Structures de données

class Debug

Espaces de nommage

Symfony\Component\ErrorHandler


Joomla CMS: Référence du fichier debug.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/helpers/debug.php

Structures de données

class UsersHelperDebug

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier debug.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
Structures de données | Espaces de nommage
Référence du fichier plugins/system/debug/debug.php

Structures de données

class PlgSystemDebug

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier DebugBar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier DebugBar.php

Structures de données

class DebugBar

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier DebugBarException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier DebugBarException.php

Structures de données

class DebugBarException

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier DebugBarHtmlDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
  • VarDumper
Structures de données | Espaces de nommage
Référence du fichier DebugBarHtmlDumper.php

Structures de données

class DebugBarHtmlDumper

Espaces de nommage

DebugBar\DataFormatter\VarDumper


Joomla CMS: Référence du fichier DebugBarVarDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
Structures de données | Espaces de nommage
Référence du fichier DebugBarVarDumper.php

Structures de données

class DebugBarVarDumper

Espaces de nommage

DebugBar\DataFormatter


Joomla CMS: Référence du fichier DebugClassLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Structures de données | Espaces de nommage
Référence du fichier DebugClassLoader.php

Structures de données

class DebugClassLoader

Espaces de nommage

Symfony\Component\ErrorHandler


Joomla CMS: Référence du fichier DebugEventDispatcherCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier DebugEventDispatcherCommand.php

Structures de données

class DebugEventDispatcherCommand

Espaces de nommage

Joomla\Event\Command


Joomla CMS: Référence du fichier DebugFormatterHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier DebugFormatterHelper.php

Structures de données

class DebugFormatterHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier DebuggroupModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier DebuggroupModel.php

Structures de données

class DebuggroupModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier DebugHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier DebugHelper.php

Structures de données

class DebugHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Helper


Joomla CMS: Référence du fichier DebugMonitor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Monitor
Structures de données | Espaces de nommage
Référence du fichier DebugMonitor.php

Structures de données

class DebugMonitor

Espaces de nommage

Joomla\Database\Monitor


Joomla CMS: Référence du fichier DebugRouterCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier DebugRouterCommand.php

Structures de données

class DebugRouterCommand

Espaces de nommage

Joomla\Router\Command


Joomla CMS: Référence du fichier DebuguserModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier DebuguserModel.php

Structures de données

class DebuguserModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier DecimalFractionTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier DecimalFractionTag.php

Structures de données

class DecimalFractionTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier Decoder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Parsing
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Parsing/Decoder.php

Structures de données

class Decoder

Espaces de nommage

Lcobucci\JWT\Parsing


Joomla CMS: Référence du fichier Decoder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier spomky-labs/cbor-php/src/Decoder.php

Structures de données

class Decoder

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier DecryptionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DecryptionException.php

Structures de données

class DecryptionException

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • tmpl
  • actionlogs
Espaces de nommage | Variables
Référence du fichier administrator/components/com_actionlogs/tmpl/actionlogs/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$wa = $this->document->getWebAssetManager()
else __pad0__
endif
if ( $this->dateRelative) = !empty($class) ? ' class="' . $class . '"' : ''
endforeach

Documentation des variables

◆ $listDirn

else $listDirn = $this->escape($this->state->get('list.direction'))

Référencé par InstallerModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), CacheModel\getData(), InstalledModel\getData(), GroupsModel\getListQuery(), TagsModel\getListQuery(), et CategoriesModel\getListQuery().

◆ $listOrder

else $listOrder = $this->escape($this->state->get('list.ordering'))

Référencé par InstallerModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), TasksModel\_getList(), CacheModel\getData(), InstalledModel\getData(), IndexModel\getListQuery(), ArticlesModel\populateState(), FeaturedModel\populateState(), TagModel\populateState(), et CategoryModel\populateState().

◆ $wa

$wa = $this->document->getWebAssetManager()

Référencé par Jquery\framework(), Bootstrap\framework(), HtmlDocument\getHeadData(), AssociationField\getInput(), Shortcut\initialize(), PlgSystemSchedulerunner\injectLazyJS(), HtmlDocument\mergeHeadData(), HtmlRenderer\render(), et HtmlDocument\setHeadData().

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

else endif

◆ if

if ( $this-> ) = !empty($class) ? ' class="' . $class . '"' : ''

Correctly set the allowing of IP Overrides if behind a trusted proxy/load balancer.

We need to do this as high up the stack as we can, as the default in is to $allowIpOverride = true which is the wrong default for a generic site NOT behind a trusted proxy/load balancer.

Référencé par Response\__construct(), HtmlView\_prepareDocument(), ContactController\allowEdit(), AbstractMenu\authorise(), ExceptionCaster\castFrameStub(), FeedView\display(), HtmlView\display(), DebugHelper\getDebugActions(), HtmlDumper\getDumpHeader(), OrderingField\getInput(), ArticleModel\getItem(), SpacerField\getLabel(), TemplatesHelper\getPositions(), TemplateModel\getTemplate(), PackageManifest\loadManifestFromData(), LibraryManifest\loadManifestFromData(), Requests\makeGetRequest(), PlgUserToken\onContentPrepareForm(), UserGroupsHelper\populateGroupData(), HtmlView\prepareDocument(), UpdateModel\preparePreUpdate(), Templates\thumbModal(), et LanguageAdapter\update().


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • help
Espaces de nommage | Variables
Référence du fichier administrator/components/com_admin/tmpl/help/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
endforeach

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage
Référence du fichier administrator/components/com_admin/tmpl/sysinfo/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • layouts
  • joomla
  • searchtools
Espaces de nommage | Variables
Référence du fichier administrator/components/com_associations/layouts/joomla/searchtools/default.php

Espaces de nommage

Joomla\Administrator

Variables

$data = $displayData
$data ['options'] = !empty($data['options']) ? $data['options'] : array()
$noResultsText = ''
$hideActiveFilters = false
$showFilterButton = false
$showSelector = false
$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'
if(isset($data['view']->filterForm) &&!empty($data['view']->filterForm)) $customOptions
$data ['options'] = array_merge($customOptions, $data['options'])
$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'
$app = Factory::getApplication()
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Route\_(), SitePathway\__construct(), Router\__construct(), InstallationController\__construct(), ConfigController\__construct(), TemplatesController\__construct(), CallbackController\__construct(), LegacyComponentDispatcher\__construct(), ContactsController\__construct(), ItemsController\__construct(), ComponentController\__construct(), ManageController\__construct(), ApiRouter\__construct(), ApplicationController\__construct(), AbstractModuleDispatcher\__construct(), ArticlesController\__construct(), TemplateController\__construct(), ModulesController\__construct(), ArticleController\__construct(), BannersController\__construct(), Cache\__construct(), MethodsController\__construct(), RouterBase\__construct(), Dispatcher\__construct(), UsersController\__construct(), CaptiveController\__construct(), UpdatesitesController\__construct(), MethodController\__construct(), CategoryController\__construct(), ActionlogsController\__construct(), DisplayController\__construct(), JoomlaHttpDriver\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), ComponentDispatcher\__construct(), GroupController\__construct(), FieldController\__construct(), TransitionController\__construct(), OpensearchDocument\__construct(), SiteRouter\__construct(), StageController\__construct(), AdminController\__construct(), TransitionsController\__construct(), JsonResponse\__construct(), StagesController\__construct(), MetadataManager\__construct(), CacheStorage\__construct(), FormController\__construct(), UCMType\__construct(), ApiController\__construct(), Authentication\__construct(), Workflow\__construct(), Pagination\__construct(), BaseController\__construct(), CategoryModel\_buildContentOrderBy(), Categories\_load(), PageController\_noChange(), HtmlView\_prepareDocument(), ContactController\_sendEmail(), HtmlView\_setPath(), RegistrationModel\activate(), ModuleController\add(), PlgSampledataMultilang\addCategory(), HtmlView\addToolbar(), admin_postinstall_behindproxy_condition(), UserModel\block(), UsersModel\buildDateRange(), Session\buildSession(), HTMLHelper\calendar(), CallbackController\callback(), TransitionModel\canDelete(), StageModel\canDelete(), TransitionModel\canEditState(), StageModel\canEditState(), TemplateHelper\canUpload(), MediaHelper\canUpload(), SetConfigurationCommand\checkDb(), CheckinModel\checkin(), Session\checkToken(), TemplateModel\child(), AssociationsModel\clean(), TemplateModel\cleanup(), UpdateModel\cleanUp(), JoomlaStorage\clear(), CategoryView\commonCategoryDisplay(), TemplateModel\copy(), TemplateModel\copyFile(), TemplateModel\copyStyles(), HtmlDocument\countMenuChildren(), MVCFactory\createController(), ApiModel\createFile(), TemplateModel\createFile(), ApiModel\createFolder(), TemplateModel\createFolder(), TemplateModel\createOverride(), UpdateModel\createUpdateFile(), Help\createUrl(), TemplateModel\cropImage(), HTMLHelper\date(), StageTable\delete(), WorkflowTable\delete(), UpdatesitesModel\delete(), OverridesModel\delete(), ApiModel\delete(), ModuleModel\delete(), TemplateModel\deleteFile(), TemplateModel\deleteFolder(), TextDescriptor\describeJoomlaApplication(), DiscoverModel\discover_install(), CategoryFeedView\display(), OpensearchView\display(), FeedView\display(), XmlView\display(), JsonView\display(), HtmlView\display(), CategoriesView\display(), PlgSystemFields\display(), FieldsHelper\displayFieldOnForm(), LanguagesModel\downloadPackage(), ProfileController\edit(), FormController\editAssociations(), Joomla\CMS\MVC\Model\executeTransition(), TemplateModel\extractArchive(), CalendarField\filter(), RouteHelper\findItem(), CollectionAdapter\findUpdate(), ExtensionAdapter\findUpdate(), Dispatcher\getApplication(), TemplateModel\getArchive(), TemplateModel\getBasePath(), CacheModel\getCache(), CapabilitiesModel\getCapabilities(), CategoryModel\getCategory(), RedisStorage\getConnection(), MemcachedStorage\getConnection(), TracksModel\getContent(), TemplateModel\getCoreFile(), TemplateModel\getCoreList(), ClientHelper\getCredentials(), CMSHelper\getCurrentLanguage(), ContentHelper\getCurrentLanguage(), ArchiveModel\getData(), RegistrationModel\getData(), TemplateModel\getFiles(), TemplateModel\getFont(), FormModel\getForm(), ArticleModel\getForm(), TemplateModel\getForm(), BreadcrumbsHelper\getHome(), TemplateModel\getImage(), BaseController\getInstance(), RouteHelper\getItemid(), CategoriesModel\getItems(), AbstractModuleDispatcher\getLayoutData(), StatsHelper\getList(), ArticlesPopularHelper\getList(), BannersHelper\getList(), BreadcrumbsHelper\getList(), TagsSimilarHelper\getList(), LanguagesHelper\getList(), ArticlesArchiveHelper\getList(), LoggedHelper\getList(), ArticlesCategoryHelper\getList(), ArchiveModel\getListQuery(), TagsModel\getListQuery(), FieldsModel\getListQuery(), TemplateModel\getMediaFiles(), LanguageField\getNativeLanguage(), WorkflowComponentSectionsField\getOptions(), TagField\getOptions(), MenusHelper\getPresets(), TemplateModel\getPreview(), CMSApplication\getRouter(), Joomla\Component\Scheduler\Administrator\Traits\getRoutineId(), ServiceProviderInterface\getSession(), TemplateModel\getSource(), StatsAdminHelper\getStats(), PlgSystemSchedulerunner\getSubscribedEvents(), Webauthn\getSubscribedEvents(), TemplateModel\getTemplate(), CheckJoomlaUpdatesCommand\getUpdateInformationFromModel(), UpdateAdapter\getUpdateSiteResponse(), ListModel\getUserStateFromRequest(), Cache\getWorkarounds(), TransitionModel\getWorkflow(), ClientHelper\hasCredentials(), HTMLHelper\includeRelativeFiles(), FinderIndexCommand\index(), InstallModel\install(), LanguagesModel\install(), UpdateModel\install(), Multilanguage\isEnabled(), Joomla\CMS\Workflow\isFunctionalityUsed(), ModuleHelper\load(), LoginModel\loadFormData(), NoteModel\loadFormData(), NewsfeedModel\loadFormData(), BannerModel\loadFormData(), ContactModel\loadFormData(), TemplateModel\loadFormData(), GroupModel\loadFormData(), CategoryModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), FieldModel\loadFormData(), DisplayController\login(), DisplayController\logout(), UserController\logout(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), Cache\makeId(), UserController\menulogout(), PlgWorkflowFeaturing\onAfterDisplay(), PlgWorkflowPublishing\onAfterDisplay(), KeepaliveAssetItem\onAttachCallback(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgButtonImage\onDisplay(), SuggestionsController\opensearchsuggest(), ModuleController\orderPosition(), TransitionModel\populateState(), WorkflowModel\populateState(), StageModel\populateState(), SelectModel\populateState(), NewsfeedModel\populateState(), ArchiveModel\populateState(), ArticleModel\populateState(), TagsModel\populateState(), InstallModel\populateState(), StylesModel\populateState(), StagesModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), WorkflowsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), ManageModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), TagModel\populateState(), LanguageModel\populateState(), RemindModel\populateState(), NewsfeedsModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), StyleModel\populateState(), MenuModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ModuleModel\populateState(), ArticlesModel\populateState(), SuggestionsModel\populateState(), OverridesModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), FormModel\populateState(), OverrideModel\populateState(), TaskModel\populateState(), PluginModel\populateState(), SearchModel\populateState(), RegistrationModel\populateState(), ListModel\populateState(), TemplateModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), Modules\positions(), CategoryView\prepareDocument(), HtmlView\prepareDocument(), Menu\preprocess(), PluginModel\preprocessForm(), ExtensionDiscoverCommand\processDiscover(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), StageModel\publish(), FinderIndexCommand\purge(), AssociationsModel\purge(), UpdatesitesModel\rebuild(), FeedView\reconcileNames(), AdminModel\redirectToAssociations(), StringsModel\refresh(), ServiceProviderInterface\register(), Application\register(), RegistrationModel\register(), PlgSystemPrivacyconsent\remindExpiringConsents(), ManageModel\remove(), ApplicationModel\removeroot(), TemplateModel\renameFile(), MessageRenderer\render(), ModulesRenderer\render(), JsonRenderer\render(), HtmlRenderer\render(), RssRenderer\render(), JsonapiRenderer\render(), AtomRenderer\render(), JsonapiDocument\render(), Document\render(), ModuleHelper\renderModule(), ModuleHelper\renderRawModule(), CurlTransport\request(), StreamTransport\request(), TemplateModel\resizeImage(), TemplatesController\save(), OverrideController\save(), WorkflowModel\save(), StageModel\save(), OverrideModel\save(), TransitionModel\save(), ApplicationModel\save(), MessageModel\save(), ArticleController\save(), StyleModel\save(), FormController\save(), TemplateModel\save(), AdminModel\save(), SetConfigurationCommand\saveConfiguration(), MailModel\send(), Mail\sendMail(), ActionlogModel\sendNotificationEmails(), IndexerController\sendResponse(), ApplicationModel\sendTestMail(), JoomlaStorage\setCookieParams(), ClientHelper\setCredentials(), ItemsController\setDefault(), HtmlView\setDocumentTitle(), ItemController\setType(), CaptchaField\setup(), MenuItemByTypeField\setup(), UpdateCoreCommand\setUpdateModel(), Cache\setWorkarounds(), ContactController\submit(), SuggestionsController\suggest(), CaptiveModel\suppressAllModules(), CaptchaRule\test(), ToolbarHelper\title(), ApiModel\updateFile(), TemplateModel\uploadFile(), et ApplicationModel\writeConfigFile().

◆ $customOptions

if (isset( $data[ 'view']->filterForm) &&!empty( $data[ 'view']->filterForm)) $customOptions
Valeur initiale :
= array(
'filtersHidden' => isset($data['options']['filtersHidden']) && $data['options']['filtersHidden'] ? $data['options']['filtersHidden'] : $hideActiveFilters,
'filterButton' => isset($data['options']['filterButton']) && $data['options']['filterButton'] ? $data['options']['filterButton'] : $showFilterButton,
'defaultLimit' => $data['options']['defaultLimit'] ?? Factory::getApplication()->get('list_limit', 20),
'searchFieldSelector' => '#filter_search',
'selectorFieldName' => $selectorFieldName,
'showSelector' => $showSelector,
'orderFieldSelector' => '#list_fullordering',
'showNoResults' => !empty($noResultsText),
'noResultsText' => !empty($noResultsText) ? $noResultsText : '',
'formSelector' => !empty($data['options']['formSelector']) ? $data['options']['formSelector'] : '#adminForm',
)
$showSelector
$showSelector
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:26
$selectorFieldName
$selectorFieldName
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:27
$noResultsText
$noResultsText
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:23
$showFilterButton
$showFilterButton
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:25
$hideActiveFilters
$hideActiveFilters
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:24
$data
$data
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:18

◆ $data [1/3]

$data = $displayData
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par ImgStub\__construct(), OtherObject\__construct(), StringStream\__construct(), Collection\__construct(), SignedIntegerObject\__construct(), UnsignedIntegerObject\__construct(), TagObject\__construct(), TextStringObject\__construct(), ByteStringObject\__construct(), JsonResponse\__construct(), MapObject\__construct(), ListObject\__construct(), CollectedClientData\__construct(), ComponentRecord\__construct(), RSAKey\__construct(), MenuItem\__construct(), OtherObject\__toString(), SignedIntegerObject\__toString(), UnsignedIntegerObject\__toString(), TagObject\__toString(), TextStringObject\__toString(), Rules\__toString(), AbstractEvent\__unserialize(), Router\__unserialize(), Route\__unserialize(), ComponentAdapter\_buildAdminMenus(), Pagination\_buildDataObject(), PlgContentJoomla\_canDeleteCategories(), ExtensionAdapter\_characterData(), Update\_characterData(), PlgContentJoomla\_countItemsInChildren(), Nested\_getTreeRepositionData(), ContactController\_sendEmail(), Update\_startElement(), Stream\_stream_write(), RegistrationModel\activate(), ItemsController\add(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addCategory(), Inflector\addCountableRule(), Inflector\addPluraliseRule(), Joomla\CMS\Event\Result\addResult(), Inflector\addRule(), Inflector\addSingulariseRule(), MailTemplate\addTemplateData(), Joomla\CMS\MVC\Model\addTransitionField(), NewsfeedController\allowAdd(), ContactController\allowAdd(), ItemController\allowAdd(), BannerController\allowAdd(), ArticleController\allowAdd(), UserController\allowEdit(), TagController\allowEdit(), ContactController\allowEdit(), LevelController\allowEdit(), NewsfeedController\allowEdit(), ItemController\allowEdit(), BannerController\allowEdit(), CategoryController\allowEdit(), FieldController\allowEdit(), TaskController\allowEdit(), WorkflowController\allowEdit(), GroupController\allowEdit(), StageController\allowEdit(), TransitionController\allowEdit(), ArticleController\allowEdit(), ModuleController\allowEdit(), MessageController\allowSave(), GroupController\allowSave(), LevelController\allowSave(), ModuleController\allowSave(), FormController\allowSave(), Registry\append(), Registry\asArray(), Symfony\Component\VarDumper\Test\assertDumpEquals(), Symfony\Component\VarDumper\Test\assertDumpMatchesFormat(), Client\authenticate(), Decoder\base64UrlDecode(), Encoder\base64UrlEncode(), ModuleModel\batchCopy(), behindproxy_postinstall_action(), Form\bind(), Registry\bindData(), Form\bindLevel(), ContactModel\buildContactExtendedData(), Collection\buildResources(), HTMLHelper\calendar(), DebugBarVarDumper\captureVar(), Changelog\characterData(), TPMAttestationStatementSupport\checkCertInfo(), FieldModel\checkDefaultValue(), SetupModel\checkForm(), TPMAttestationStatementSupport\checkPubArea(), SMTP\client_send(), SessionCollector\collect(), RequestDataCollector\collect(), PDOCollector\collect(), AggregatedCollector\collect(), DebugBar\collect(), AbstractWebApplication\compress(), SSH2\connect(), TranscodeUnicode\convert(), Token\convertToDataSet(), SignedIntegerObject\createBigInteger(), UnsignedIntegerObject\createBigInteger(), CategoriesHelper\createCategory(), PrivacyPlugin\createCustomFieldsDomain(), ApiModel\createFile(), LocalAdapter\createFile(), CollectedClientData\createFormJson(), VerificationMethodANDCombinations\createFromArray(), RogueListEntry\createFromArray(), Version\createFromArray(), CertificateTrustPath\createFromArray(), EcdaaKeyIdTrustPath\createFromArray(), PatternAccuracyDescriptor\createFromArray(), RgbPaletteEntry\createFromArray(), CodeAccuracyDescriptor\createFromArray(), MetadataTOCPayload\createFromArray(), VerificationMethodDescriptor\createFromArray(), EcdaaTrustAnchor\createFromArray(), BiometricAccuracyDescriptor\createFromArray(), BiometricStatusReport\createFromArray(), StatusReport\createFromArray(), DisplayPNGCharacteristicsDescriptor\createFromArray(), AttestationStatement\createFromArray(), MetadataTOCPayloadEntry\createFromArray(), PublicKeyCredentialSource\createFromArray(), MetadataStatement\createFromArray(), BigInteger\createFromBinaryString(), SignedIntegerObject\createFromGmpValue(), UnsignedIntegerObject\createFromGmpValue(), JWK\createFromJson(), JWKSet\createFromJson(), JWKSet\createFromKeyData(), AuthenticationExtensionsClientOutputs\createFromString(), PublicKeyCredentialParameters\createFromString(), PublicKeyCredentialUserEntity\createFromString(), PublicKeyCredentialDescriptorCollection\createFromString(), AuthenticatorSelectionCriteria\createFromString(), PublicKeyCredentialRequestOptions\createFromString(), PublicKeyCredentialDescriptor\createFromString(), PublicKeyCredentialCreationOptions\createFromString(), PrivacyPlugin\createItemForTable(), PlgPrivacyUser\createItemForUserTable(), PrivacyPlugin\createItemFromArray(), SignedIntegerObject\createObjectForValue(), UnsignedIntegerObject\createObjectForValue(), UpdateModel\createUpdateFile(), BaseLayout\debug(), PlgSystemStats\debug(), Base64Url\decode(), PgsqlDriver\decodeBinary(), DatabaseDriver\decodeBinary(), Files\decodeData(), InputFilter\decodeFileData(), CryptoCipher\decrypt(), Crypto\decrypt(), SodiumCipher\decrypt(), Sodium\decrypt(), OpenSSL\decrypt(), Crypt\decrypt(), Encrypt\decrypt(), HtmlDescriptor\describe(), CliDescriptor\describe(), JsonDescriptor\describeApplication(), SSH2\disconnect_helper(), TextView\display(), JsonView\display(), HtmlView\display(), JsonapiView\displayList(), CheckJoomlaUpdatesCommand\doExecute(), Parser\doParse(), ContextualizedDumper\dump(), ServerDumper\dump(), HtmlDumper\dump(), ModuleModel\duplicate(), ItemsController\edit(), FormController\editAssociations(), AdminModel\editAssociations(), JsonConverter\encode(), Base64Url\encode(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), Encrypt\encrypt(), CryptoCipher\encrypt(), Crypto\encrypt(), SodiumCipher\encrypt(), Crypt\encrypt(), OpenSSL\encrypt(), Sodium\encrypt(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), PlgWorkflowPublishing\enhanceTransitionForm(), ApiController\execute(), ServerDumpCommand\execute(), MetadataStatementFetcher\fetchMetadataStatement(), MetadataStatementFetcher\fetchTableOfContent(), X509\fetchURL(), Form\filter(), SSH2\filter(), FileStorage\find(), RedisStorage\find(), MemcachedStorage\find(), PdoStorage\find(), LengthCalculator\fixHexLength(), DataFormatter\formatVar(), Agent\forwardData(), ZIPExtraction\fread(), ByteString\fromRandom(), BannerModel\generateTitle(), AdminModel\generateTitle(), Select\genericlist(), ViewController\get(), OutputController\get(), PageController\get(), PdoStorage\get(), FileStorage\get(), SSH2\get_channel_packet(), SMTP\get_lines(), Access\getActionsFromData(), JavascriptRenderer\getAddDatasetCode(), ApcuStorage\getAll(), WincacheStorage\getAll(), FileStorage\getAll(), MemcachedStorage\getAll(), RedisStorage\getAll(), Input\getArrayRecursive(), JsonDescriptor\getCommandData(), ActionlogsHelper\getCsvData(), StatisticsModel\getData(), Rule\getData(), Rules\getData(), ProfileModel\getData(), ApplicationModel\getData(), LanguageStringsCollector\getData(), CacheModel\getData(), BaseLayout\getData(), Pagination\getData(), DebugBar\getData(), RegistrationModel\getData(), Form\getData(), DebugBar\getDataAsHeaders(), Symfony\Component\VarDumper\Test\getDump(), FieldsHelper\getFieldTypes(), FieldModel\getFieldValues(), LocalAdapter\getFiles(), ArticlesModel\getFilterForm(), WorkflowsModel\getFilterForm(), TransitionsModel\getFilterForm(), UsersModel\getFilterForm(), ActionlogsModel\getFilterForm(), FieldsModel\getFilterForm(), TemplatesModel\getForm(), FormModel\getForm(), LinkModel\getForm(), PluginModel\getForm(), SetupModel\getForm(), GroupModel\getForm(), NewsfeedModel\getForm(), WorkflowModel\getForm(), ContactModel\getForm(), BannerModel\getForm(), StageModel\getForm(), TransitionModel\getForm(), CategoryModel\getForm(), ChecksModel\getForm(), StyleModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), ItemModel\getForm(), UpdateModel\getForm(), ModuleModel\getForm(), LanguagesModel\getForm(), FieldsPlugin\getFormPath(), CredentialRepository\getHandleFromUserId(), HtmlDocument\getHeadData(), ListField\getInput(), TagField\getInput(), ModulesPositioneditField\getInput(), GroupedlistField\getInput(), SubformField\getInput(), CategoryeditField\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), Form\getInstance(), NewsfeedModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), UpdatesitesModel\getItems(), RequestController\getJson(), ConsentBoxField\getLabel(), FormField\getLabel(), Dispatcher\getLayoutData(), ContenthistoryField\getLayoutData(), RadioField\getLayoutData(), DataField\getLayoutData(), RadiobasicField\getLayoutData(), RangeField\getLayoutData(), EmailField\getLayoutData(), UrlField\getLayoutData(), TinymcebuilderField\getLayoutData(), ComboField\getLayoutData(), TelephoneField\getLayoutData(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), UserField\getLayoutData(), ModuleorderField\getLayoutData(), JoomlatokenField\getLayoutData(), CheckboxField\getLayoutData(), FileField\getLayoutData(), CheckboxesField\getLayoutData(), TimeField\getLayoutData(), TextareaField\getLayoutData(), MeterField\getLayoutData(), NumberField\getLayoutData(), PasswordField\getLayoutData(), ConsentBoxField\getLayoutData(), ColorField\getLayoutData(), RulesField\getLayoutData(), MediaField\getLayoutData(), TextField\getLayoutData(), CalendarField\getLayoutData(), LengthCalculator\getLengthOfArray(), LengthCalculator\getLengthOfString(), Parser\getNextEmbedBlock(), InfiniteListObject\getNormalizedData(), TextStringObject\getNormalizedData(), ListObject\getNormalizedData(), FieldsListPlugin\getOptionsFromField(), Pagination\getPagesLinks(), Pagination\getPaginationPages(), Helper\getPrimaryLanguage(), UserHelper\getProfile(), DisplayController\getQuickiconContent(), Joomla\Component\Scheduler\Administrator\Traits\getRoutineId(), CMSHelper\getRowData(), ContentHelper\getRowData(), SysinfoModel\getSafeData(), DebugBar\getStackedData(), Joomla\CMS\MVC\Model\getStageForNewItem(), Indexer\getState(), PlgSystemStats\getStatsData(), HelpModel\getToc(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), PlgWorkflowNotification\getUsersFromGroup(), TextStringObject\getValue(), ArraySerializer\getValueFromKey(), Cache\getWorkarounds(), Select\groupedlist(), ParagonIE_Sodium_Core_Util\hash_update(), LengthCalculator\hex2bin(), ECSignature\hex2bin(), SignedIntegerObject\hex2bin(), UnsignedIntegerObject\hex2bin(), SMTP\hmac(), RuntimeTests\HMACTestVector(), Crypto\HMACTestVector(), DatabaseImporter\importData(), Select\integerlist(), Helper\isCommon(), InputFilter\isSafeFile(), Decoder\jsonDecode(), Encoder\jsonEncode(), JsonResponse\jsonEncode(), SSH2\key_exchange(), FtpClient\listDetails(), DumpServer\listen(), FtpClient\listNames(), AuthenticationExtensionsClientOutputsLoader\load(), AttestationObjectLoader\load(), PublicKeyCredentialLoader\load(), User\load(), PuTTY\load(), Form\load(), Server\loadAndCheckAssertionResponse(), Server\loadAndCheckAttestationResponse(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), LoginModel\loadFormData(), MailModel\loadFormData(), UpdatesiteModel\loadFormData(), OverrideModel\loadFormData(), DownloadModel\loadFormData(), NoteModel\loadFormData(), LinkModel\loadFormData(), RequestModel\loadFormData(), ClientModel\loadFormData(), ComponentModel\loadFormData(), FilterModel\loadFormData(), PluginModel\loadFormData(), NewsfeedModel\loadFormData(), LanguageModel\loadFormData(), ProfileModel\loadFormData(), UserModel\loadFormData(), MenuModel\loadFormData(), TagModel\loadFormData(), LevelModel\loadFormData(), WorkflowModel\loadFormData(), BannerModel\loadFormData(), MessageModel\loadFormData(), ContactModel\loadFormData(), StageModel\loadFormData(), TemplateModel\loadFormData(), TransitionModel\loadFormData(), PluginsModel\loadFormData(), GroupModel\loadFormData(), StyleModel\loadFormData(), CategoryModel\loadFormData(), RegistrationModel\loadFormData(), ListModel\loadFormData(), UpdateModel\loadFormData(), ItemModel\loadFormData(), ArticleModel\loadFormData(), ModuleModel\loadFormData(), FieldModel\loadFormData(), Installer\loadMD5Sum(), TrustPathLoader\loadTrustPath(), UserController\login(), Http\makeTransportRequest(), UCMBase\mapBase(), X509\mapOutExtensions(), Rules\merge(), HtmlDocument\mergeHeadData(), PHPMailer\msgHTML(), Client\oauthRequest(), MultibyteStringConverter\octetLength(), ECSignature\octetLength(), Cache\onAfterRoute(), PlgSystemStats\onAjaxSendStats(), PlgContentJoomla\onContentBeforeDelete(), PlgContentJoomla\onContentBeforeSave(), PlgSystemFields\onContentNormaliseRequestData(), PlgUserProfile\onContentPrepareData(), PlgUserToken\onContentPrepareData(), PlgSystemActionLogs\onContentPrepareData(), PlgUserJoomla\onContentPrepareForm(), PlgSystemPrivacyconsent\onContentPrepareForm(), PlgSystemActionLogs\onContentPrepareForm(), PlgWorkflowNotification\onContentPrepareForm(), PlgWorkflowPublishing\onContentPrepareForm(), PlgWorkflowFeaturing\onContentPrepareForm(), PlgUserToken\onContentPrepareForm(), FieldsPlugin\onContentPrepareForm(), PlgSystemFields\onContentPrepareForm(), FieldsPlugin\onCustomFieldsGetTypes(), ContentHelper\onPrepareForm(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgSampledataBlog\onSampledataGetOverview(), PlgSampledataMultilang\onSampledataGetOverview(), PlgUserJoomla\onUserAfterSave(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), PlgSystemRemember\onUserBeforeSave(), PlgUserProfile\onUserBeforeSave(), Parser\parse(), TemplateParser\parseBase64(), Parser\parseClaims(), Parser\parseHeader(), WebAssetRegistry\parseRegistryFile(), Parser\parseSignature(), Parser\parseValue(), Installer\parseXMLInstallFile(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), Http\post(), Form\postProcess(), TagsHelper\postStoreProcess(), ContentComponent\prepareForm(), MultibyteStringConverter\preparePositiveInteger(), ECSignature\preparePositiveInteger(), Joomla\CMS\MVC\Model\preprocessData(), FormModel\preprocessData(), RemindModel\preprocessForm(), ModulesModel\preprocessForm(), MailModel\preprocessForm(), TemplatesModel\preprocessForm(), LoginModel\preprocessForm(), ResetModel\preprocessForm(), Joomla\CMS\MVC\Model\preprocessForm(), ProfileModel\preprocessForm(), UserModel\preprocessForm(), LevelModel\preprocessForm(), FormModel\preprocessForm(), WorkflowModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), TransitionModel\preprocessForm(), BannerModel\preprocessForm(), StageModel\preprocessForm(), RegistrationModel\preprocessForm(), NewsfeedModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ModuleModel\preprocessForm(), TaskModel\preprocessForm(), FieldModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), CategoriesController\preprocessSaveData(), UsersController\preprocessSaveData(), ContactController\preprocessSaveData(), StylesController\preprocessSaveData(), ArticlesController\preprocessSaveData(), ApiController\preprocessSaveData(), Form\process(), RssParser\processPerson(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), ZIPExtraction\processTypeFileUncompressed(), ZIPExtraction\processTypeLink(), PlgExtensionJoomla\processUpdateSites(), ItemsController\publish(), AdminController\publish(), Http\put(), SFTP\put(), Client\query(), PgsqlDriver\quoteBinary(), DatabaseDriver\quoteBinary(), Select\radiolist(), StringStream\read(), AdminModel\redirectToAssociations(), Client\refreshToken(), RegistrationModel\register(), InstalledVersions\reload(), Registry\remove(), JsonRenderer\render(), RssRenderer\render(), Sidebar\render(), AtomRenderer\render(), WebApplication\render(), ActionButton\render(), FeedDocument\render(), PlgSystemStats\render(), InstallationApplication\render(), HtmlDocument\render(), FormField\render(), CMSApplication\render(), JavascriptRenderer\render(), DebugBarVarDumper\renderCapturedVar(), TextView\renderDirectories(), FormField\renderField(), DebugBarVarDumper\renderVar(), ConfigPostProcessor\replaceDependencyConfiguration(), Curl\request(), Stream\request(), Socket\request(), StreamTransport\request(), CurlTransport\request(), SocketTransport\request(), Reader\resolveContainer(), Session\restart(), ECSignature\retrievePositiveInteger(), MultibyteStringConverter\retrievePositiveInteger(), Client\safeEncode(), FileStorage\save(), ConfigController\save(), RedisStorage\save(), MemcachedStorage\save(), StyleController\save(), PdoStorage\save(), GroupModel\save(), OverrideController\save(), WorkflowModel\save(), StageModel\save(), FieldModel\save(), ConfigModel\save(), OverrideModel\save(), TransitionModel\save(), UpdatesiteModel\save(), FormModel\save(), ComponentModel\save(), LanguageModel\save(), ModuleController\save(), UserModel\save(), LevelModel\save(), MenuModel\save(), ProfileModel\save(), ApplicationModel\save(), MessageModel\save(), TemplateModel\save(), PluginModel\save(), RequestModel\save(), StyleModel\save(), CategoryModel\save(), TaskModel\save(), FormController\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), MailModel\send(), SSH2\send_binary_packet(), SSH2\send_channel_packet(), SFTP\send_sftp_packet(), Http\sendRequest(), IndexerController\sendResponse(), ApiController\sendResponse(), PlgSystemStats\sendStats(), JSONFlattenedSerializer\serialize(), JSONGeneralSerializer\serialize(), BaseLayout\setData(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), HtmlDocument\setHeadData(), JsonResponse\setPayload(), Indexer\setState(), ItemController\setType(), UpdateCoreCommand\setUpdateInfo(), Blowfish\setupKey(), Cache\setWorkarounds(), RSA\sign(), ED512\sign(), ED256\sign(), EdDSA\sign(), ES256\sign(), ES256K\sign(), ES384\sign(), ES512\sign(), ECDSA\sign(), SearchTools\sort(), AggregatedCollector\sort(), Parser\splitJwt(), Patcher\splitLines(), Uri\splitQueryValue(), DebugBar\stackData(), Changelog\startElement(), UCMBase\store(), OutputController\store(), Versioning\store(), WincacheStorage\store(), ApcuStorage\store(), PageController\store(), ViewController\store(), CallbackController\store(), UCMContent\store(), FileStorage\store(), MemcachedStorage\store(), RedisStorage\store(), Cache\store(), Buffer\stream_write(), BufferStreamHandler\stream_write(), PharStreamWrapper\stream_write(), Json\stringToObject(), Xml\stringToObject(), Yaml\stringToObject(), Ini\stringToObject(), ContactController\submit(), RuntimeTests\testEncryptDecrypt(), Crypto\TestEncryptDecrypt(), Registry\toFlatten(), Registry\toObject(), RSAKey\toPublic(), InstallerModel\translate(), AjaxChallenge\typeCheckResult(), Joomla\CMS\Event\Result\typeCheckResult(), Strings\unpackSSH2(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), LocalAdapter\updateFile(), ApiModel\updateFile(), GreaterOrEqualsTo\validate(), LesserOrEqualsTo\validate(), EqualsTo\validate(), SetupModel\validate(), MenuModel\validate(), FormModel\validate(), LevelModel\validate(), Token\validate(), TemplateModel\validate(), GroupModel\validate(), CategoryModel\validate(), RequestModel\validate(), ArticleModel\validate(), ModuleModel\validate(), FieldModel\validate(), Form\validate(), Authentication\validateAssertionResponse(), CategoriesHelper\validateCategoryId(), ApplicationModel\validateDbConnection(), Yubikey\validateYubikeyOtp(), ED256\verify(), ED512\verify(), RSA\verify(), ES512\verify(), ES256\verify(), ES256K\verify(), ES384\verify(), ECDSA\verify(), EdDSA\verify(), Credentials\verifyAttestation(), ServerRequest\withParsedBody(), JsonResponse\withPayload(), Joomla\CMS\MVC\Model\workflowAfterSave(), Joomla\CMS\MVC\Model\workflowPreprocessForm(), et Connection\write().

◆ $data [2/3]

$data[ 'options'] = !empty($data['options']) ? $data['options'] : array()

◆ $data [3/3]

$data[ 'options'] = array_merge($customOptions, $data['options'])

◆ $filtersActiveClass

$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'

◆ $hideActiveFilters

$hideActiveFilters = false

◆ $noResultsText

$noResultsText = ''

◆ $selectorFieldName

$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'

◆ $showFilterButton

$showFilterButton = false

◆ $showSelector

$showSelector = false

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
  • associations
Espaces de nommage | Variables
Référence du fichier administrator/components/com_associations/tmpl/associations/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$canManageCheckin = Factory::getUser()->authorise('core.manage', 'com_checkin')
$iconStates
else __pad0__
endif
foreach($this->items as $i=> $item) $canEdit = AssociationsHelper::allowEdit($this->extensionName, $this->typeName, $item->id)
$canCheckin = $canManageCheckin || AssociationsHelper::canCheckinItem($this->extensionName, $this->typeName, $item->id)
$isCheckout = AssociationsHelper::isCheckoutItem($this->extensionName, $this->typeName, $item->id)
else __pad1__
endforeach

Documentation des variables

◆ $canCheckin

$canCheckin = $canManageCheckin || AssociationsHelper::canCheckinItem($this->extensionName, $this->typeName, $item->id)

◆ $canEdit

foreach ( $this->items as $i=> $item) $canEdit = AssociationsHelper::allowEdit($this->extensionName, $this->typeName, $item->id)

Référencé par ItemlanguageField\getOptions().

◆ $canManageCheckin

$canManageCheckin = Factory::getUser()->authorise('core.manage', 'com_checkin')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $isCheckout

$isCheckout = AssociationsHelper::isCheckoutItem($this->extensionName, $this->typeName, $item->id)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banners
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/banners/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
if ( $saveOrder &&!empty( $this->items))
else __pad0__
endif
$item | cat_link = Route::_('index.php?option=com_categories&extension=com_banners&task=edit&type=other&cid[]=' . $item->catid)
$canCreate = $user->authorise('core.create', 'com_banners.category.' . $item->catid)
$canEdit = $user->authorise('core.edit', 'com_banners.category.' . $item->catid)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_banners.category.' . $item->catid) && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder) = 'btn-danger'
else __pad1__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_banners.category.' . $item->catid) && $canCheckin

Référencé par Redirect\published(), et Messages\status().

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_banners.category.' . $item->catid)

Référencé par HtmlView\addToolbar(), CategoryModel\batchCopy(), CategoryModel\batchMove(), TagsHelper\createTagsFromField(), AssociationsHelper\getAssociationHtmlList(), et ItemlanguageField\getOptions().

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_banners.category.' . $item->catid)

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $user

$user = Factory::getUser()

Référencé par BeforeDisplayMethods\__construct(), Validate\__construct(), CredentialRepository\__construct(), PublicKeyCredentialCreationOptions\__construct(), PlgUserJoomla\_getUser(), Categories\_load(), RegistrationModel\activate(), LinkModel\activate(), UserModel\activate(), UserHelper\activateUser(), ActionlogModel\addLog(), PlgSampledataBlog\addMenuItems(), FormView\addToolbar(), HtmlView\addToolbar(), ListView\addToolbar(), UserHelper\addUserToGroup(), ItemController\allowAdd(), CategoryController\allowAdd(), ArticleController\allowAdd(), FormController\allowAdd(), MediaController\allowAdd(), ContactController\allowAdd(), ApiController\allowAdd(), MediaController\allowDelete(), ContactController\allowEdit(), NewsfeedController\allowEdit(), ItemController\allowEdit(), CategoryController\allowEdit(), FieldController\allowEdit(), WorkflowController\allowEdit(), GroupController\allowEdit(), StageController\allowEdit(), TransitionController\allowEdit(), ArticleController\allowEdit(), MediaController\allowEdit(), MethodController\assertCanDelete(), MethodController\assertCanEdit(), MethodsController\assertLoggedInUser(), MethodController\assertLoggedInUser(), SiteApplication\authorise(), ItemModel\batchCopy(), ModuleModel\batchCopy(), FieldModel\batchCopy(), ModuleModel\batchMove(), ItemModel\batchMove(), FieldModel\batchMove(), Joomla\CMS\MVC\Model\batchWorkflowStage(), UserModel\block(), ContactModel\buildContactExtendedData(), Icons\button(), Mfa\canAddEditMethod(), Mfa\canDeleteMethod(), ClientModel\canEditState(), TransitionModel\canEditState(), CategoryModel\canEditState(), GroupModel\canEditState(), StageModel\canEditState(), ArticleModel\canEditState(), WorkflowModel\canEditState(), FieldModel\canEditState(), Joomla\Plugin\System\Webauthn\PluginTraits\canEditUser(), UpdateModel\captiveLogin(), Category\categories(), DaemonApplication\changeIdentity(), MessageTable\check(), GroupTable\check(), FieldTable\check(), Dispatcher\checkAccess(), AdminModel\checkCategoryId(), FormModel\checkin(), FormModel\checkout(), ResetModel\checkResetLimit(), CMSApplication\checkUserRequireReset(), TemplateModel\child(), CategoryView\commonCategoryDisplay(), Factory\createDbo(), PlgPrivacyUser\createItemForUserTable(), PlgPrivacyUser\createNotesDomain(), MetadataManager\createOrUpdateRecord(), PlgPrivacyUser\createProfileDomain(), MetadataManager\createRecordIfNonExisting(), MetadataManager\createSessionRecord(), PlgPrivacyUser\createUserDomain(), MessageModel\delete(), StyleModel\delete(), TracksModel\delete(), MfaTable\delete(), MethodController\delete(), GroupModel\delete(), UserModel\delete(), ModuleModel\delete(), MethodsModel\deleteAll(), HtmlView\display(), DisplayController\display(), MethodsController\display(), ListUserCommand\doExecute(), ChangeUserPasswordCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), AddUserCommand\doExecute(), StyleModel\duplicate(), ModuleModel\duplicate(), LinkModel\duplicateUrls(), ProfileController\edit(), Icon\edit(), ComponentHelper\filterText(), CredentialRepository\formatDate(), MethodsModel\formatRelative(), FilesystemHelper\ftpChmod(), Helper\ftpChmod(), ContentHelper\getActions(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), Access\getAuthorisedViewLevels(), Credentials\getAvatar(), Authentication\getAvatar(), CategoryModel\getCategory(), ConfigHelper\getComponentsWithConfig(), LocalAdapter\getDate(), DatabaseHelper\getDbo(), GroupModel\getForm(), UserModel\getForm(), TagModel\getForm(), TaskModel\getForm(), FormModel\getForm(), ModuleModel\getForm(), Session\getFormToken(), MenuField\getGroups(), AddUserToGroupCommand\getGroups(), RemoveUserFromGroupCommand\getGroups(), FieldsModel\getGroups(), UserModel\getGroups(), CalendarField\getInput(), FtpClient\getInstance(), NewsfeedModel\getItem(), FormModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), Adapter\getItemMenuTitle(), DebuguserModel\getItems(), HistoryModel\getItems(), ArticlesModel\getItems(), TagsHelper\getItemTags(), RequestController\getJson(), TagsPopularHelper\getList(), LatestHelper\getList(), TagsSimilarHelper\getList(), LanguagesHelper\getList(), PopularHelper\getList(), LoggedHelper\getList(), SuggestionsModel\getListQuery(), FeaturedModel\getListQuery(), ActionlogsModel\getListQuery(), MessagesModel\getListQuery(), GroupsModel\getListQuery(), SearchModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), MethodsModel\getMethods(), WhosonlineHelper\getOnlineUserNames(), FieldgroupsField\getOptions(), CategoryField\getOptions(), TransitionField\getOptions(), CategoryeditField\getOptions(), UserHelper\getProfile(), Authentication\getPubKeyCreationOptions(), Credentials\getPubKeyDescriptorsForUser(), Authentication\getPubKeyDescriptorsForUser(), Authentication\getPubkeyRequestOptions(), CaptiveModel\getRecords(), MethodModel\getRenderOptions(), StatsAdminHelper\getStats(), TagsHelper\getTagItemsQuery(), HtmlView\getTagsTitle(), ArticlesModel\getTransitions(), LoginHelper\getType(), Totp\getUrl(), PublicKeyCredentialCreationOptions\getUser(), NotesModel\getUser(), Credentials\getUserEntity(), Authentication\getUserEntity(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), UserHelper\getUserGroups(), UsersLatestHelper\getUsers(), Workflow\getValidTransition(), ClientHelper\hasCredentials(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), CMSApplication\initialiseApp(), BackupcodesModel\isBackupCode(), LdapUser\isEqualTo(), Token\isInAllowedUserGroup(), PlgUserToken\isInAllowedUserGroup(), PublicKeyCredentialCreationOptions\jsonSerialize(), Links\link(), ExportModel\logExport(), ExportModel\logExportEmailed(), FtpClient\login(), CMSApplication\login(), CMSApplication\logout(), RemoveModel\logRemove(), RemoveModel\logRemoveBlocked(), Menu\menuItems(), Joomla\onAfterCheckin(), Joomla\onAfterDispatch(), Joomla\onAfterLogExport(), Joomla\onAfterLogPurge(), Joomla\onAfterPurge(), MetadataManagerListener\onAfterSessionStart(), PlgContentJoomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgSystemActionLogs\onContentPrepareForm(), PlgButtonMenu\onDisplay(), PlgButtonPagebreak\onDisplay(), PlgButtonContact\onDisplay(), PlgButtonArticle\onDisplay(), PlgButtonModule\onDisplay(), PlgButtonImage\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Joomla\onJoomlaAfterUpdate(), PlgPrivacyUser\onPrivacyCanRemoveData(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgPrivacyContent\onPrivacyExportRequest(), PlgPrivacyContact\onPrivacyExportRequest(), PlgPrivacyUser\onPrivacyRemoveData(), PlgUserJoomla\onUserAfterDelete(), PlgSystemFields\onUserAfterDelete(), PlgSystemPrivacyconsent\onUserAfterDelete(), PlgUserToken\onUserAfterDelete(), PlgUserProfile\onUserAfterDelete(), PlgSystemActionLogs\onUserAfterDelete(), Joomla\onUserAfterDelete(), Joomla\onUserAfterRemind(), PlgUserContactCreator\onUserAfterSave(), PlgUserJoomla\onUserAfterSave(), PlgSystemFields\onUserAfterSave(), PlgSystemActionLogs\onUserAfterSave(), PlgSystemLanguageFilter\onUserAfterSave(), Joomla\onUserAfterSave(), PlgAuthenticationJoomla\onUserAuthenticate(), Basic\onUserAuthenticate(), PlgAuthenticationCookie\onUserAuthenticate(), Token\onUserAuthenticate(), PlgUserTerms\onUserBeforeSave(), PlgSystemRemember\onUserBeforeSave(), PlgSystemPrivacyconsent\onUserBeforeSave(), PlgSystemLanguageFilter\onUserBeforeSave(), PlgUserJoomla\onUserLogin(), PlgSystemLanguageFilter\onUserLogin(), PlgUserJoomla\onUserLogout(), Joomla\onUserLogout(), PlgWorkflowNotification\onWorkflowAfterTransition(), Category\options(), Stream\parse_path(), ConfigModel\populateState(), NewsfeedModel\populateState(), TagsModel\populateState(), ArticleModel\populateState(), MessageModel\populateState(), ArticlesModel\populateState(), SuggestionsModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), SearchModel\populateState(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), HtmlView\prepareToolbar(), Menu\preprocess(), CssMenu\preprocess(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), MessageModel\publish(), MapsModel\publish(), IndexModel\publish(), AdminModel\publish(), LdapUserProvider\refreshUser(), BackupcodesModel\regenerateBackupCodes(), RegistrationModel\register(), PlgSystemPrivacyconsent\remindExpiringConsents(), Helper\remotefsize(), FilesystemHelper\remotefsize(), UserHelper\removeUserFromGroup(), ModulesRenderer\render(), LevelsModel\reorder(), CurlTransport\request(), StreamTransport\request(), Credentials\requestAttestation(), LanguageAdapter\resetUserLanguage(), PlgSystemSchedulerunner\runTestCron(), StageModel\save(), WorkflowModel\save(), TransitionModel\save(), UserModel\save(), ProfileModel\save(), StyleModel\save(), TemplateModel\save(), LevelsModel\saveorder(), TagsController\searchAjax(), Filter\select(), MailModel\send(), Email\sendCode(), ActionlogModel\sendNotificationEmails(), ApplicationModel\sendTestMail(), ClientHelper\setCredentials(), ClientHelper\setCredentialsFromRequest(), MethodsModel\setFlag(), StyleModel\setHome(), AbstractMenu\setUser(), UserHelper\setUserGroups(), Filter\slider(), NewsfeedTable\store(), TagTable\store(), WorkflowTable\store(), CoreContent\store(), Category\store(), Content\store(), timingSafeEquals(), StyleModel\unsetHome(), MetadataManager\updateSessionRecord(), LdapUserProvider\upgradePassword(), Mail\useSmtp(), Authentication\validateAssertionResponse(), et Uri\withUserInfo().

◆ $userId

$userId = $user->get('id')

Référencé par CredentialRepository\__construct(), RegistrationModel\activate(), ActionlogModel\addLog(), Users\addNote(), HtmlView\addToolbar(), FormView\addToolbar(), UserHelper\addUserToGroup(), CredentialRepository\attestedCredentialToPublicKeyCredentialSource(), AssociationsHelper\canCheckinItem(), Access\check(), Table\checkOut(), UserHelper\checkSuperUserInUsers(), ConfigurationModel\createRootUser(), MetadataManager\createSessionRecord(), MenuType\delete(), MethodController\delete(), User\delete(), MethodsController\display(), ChangeUserPasswordCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), ProfileController\edit(), Users\filterNotes(), CredentialRepository\formatDate(), UserModel\getAssignedGroups(), Access\getAuthorisedViewLevels(), PlgContentContact\getContactData(), ProfileModel\getData(), UserModel\getForm(), Access\getGroupsByUser(), FormModel\getItem(), ArticleModel\getItem(), DebuguserModel\getItems(), ArticlesModel\getItems(), LatestHelper\getList(), PopularHelper\getList(), NotesModel\getListQuery(), MfaTable\getNumRecords(), UserHelper\getProfile(), NoteController\getRedirectToItemAppend(), JoomlatokenField\getTokenForDisplay(), PlgUserToken\getTokenForDisplay(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), DebuguserModel\getUser(), UsersModel\getUserDisplayedGroups(), UserHelper\getUserGroups(), ConfigurationModel\getUserId(), PlgUserToken\hasTokenProfileFields(), Token\isInAllowedUserGroup(), PlgUserToken\isInAllowedUserGroup(), Token\isTokenEnabledForUser(), PlgSystemPrivacyconsent\isUserConsented(), User\load(), NoteModel\loadFormData(), Users\notes(), Users\notesModal(), PlgSystemPrivacyconsent\onAfterRoute(), PlgUserProfile\onContentPrepareData(), PlgUserToken\onContentPrepareData(), PlgSystemPrivacyconsent\onContentPrepareForm(), PlgUserToken\onContentPrepareForm(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgUserJoomla\onUserAfterDelete(), PlgSystemPrivacyconsent\onUserAfterDelete(), PlgUserToken\onUserAfterDelete(), PlgUserProfile\onUserAfterDelete(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), Joomla\onUserAfterSave(), Token\onUserAuthenticate(), PlgUserTerms\onUserBeforeSave(), PlgSystemPrivacyconsent\onUserBeforeSave(), NoteModel\populateState(), ProfileModel\populateState(), ResetModel\processResetComplete(), ResetModel\processResetRequest(), Nested\publish(), Table\publish(), MessagesModel\purge(), PlgSystemPrivacyconsent\remindExpiringConsents(), UserHelper\removeUserFromGroup(), ConfigurationModel\resetRandUserId(), LanguageAdapter\resetUserLanguage(), ConfigModel\save(), ProfileModel\save(), StyleModel\save(), User\setLastVisit(), JoomlatokenField\setup(), UserHelper\setUserGroups(), NoteTable\store(), ContactTable\store(), MenuType\store(), FilterTable\store(), UsernameRule\test(), EmailRule\test(), TaskTable\unlock(), MetadataManager\updateSessionRecord(), et ConfigurationModel\updateUserIds().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ cat_link

$item cat_link = Route::_('index.php?option=com_categories&extension=com_banners&task=edit&type=other&cid[]=' . $item->catid)

◆ elseif

elseif ( ! $saveOrder ) = 'btn-danger'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Language\_(), BCMath\__callStatic(), QueryElement\__clone(), DatabaseQuery\__clone(), AcceptLanguage\__construct(), OctetString\__construct(), AbstractTime\__construct(), FatalError\__construct(), ArgsStub\__construct(), LinkStub\__construct(), ClassStub\__construct(), Response\__construct(), DisplayController\__construct(), InputArgument\__construct(), Rules\__construct(), Registry\__construct(), UploadedFile\__construct(), InputOption\__construct(), AdminController\__construct(), BaseDatabaseModel\__construct(), Image\__construct(), HtmlView\__construct(), TaskModel\__construct(), DebugClassLoader\__construct(), KeyOrPassword\__construct(), Table\__construct(), BigInteger\__construct(), Query\__construct(), AdminModel\__construct(), BaseController\__construct(), BufferingLogger\__destruct(), EditorField\__set(), SqlsrvQuery\__toString(), Joomla\Database\Query\__toString(), DatabaseQuery\__toString(), PlgContentJoomla\_canDeleteCategories(), PlgContentPagebreak\_createToc(), FileStorage\_deleteFolder(), Update\_endElement(), RouteHelper\_findItem(), FtpClient\_findMode(), Category\_getAssetParentId(), ModulesModel\_getList(), Categories\_load(), HtmlDocument\_parseTemplate(), HtmlView\_prepareDocument(), Browser\_setPlatform(), RegistrationModel\activate(), UserModel\activate(), PHPMailer\addAnAddress(), PHP\addHelper(), WebAssetManager\addInline(), Log\addLoggerInternal(), PHPMailer\addOrEnqueueAnAddress(), ClassLoader\addPsr4(), Inflector\addRule(), JWSBuilder\addSignature(), HtmlView\addToolbar(), ListView\addToolbar(), AbstractWebApplication\appendBody(), NamePrep\applyCharacterMaps(), Patcher\applyHunk(), AbstractUnicodeString\ascii(), ASN1\asn1map(), SMTP\authenticate(), User\authorise(), QuestionHelper\autocomplete(), AdminModel\batch(), ModuleModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), ModuleModel\batchMove(), DataObject\bind(), Form\bindLevel(), Calculator\bitwise(), PHP\bitwise_small_split(), UserModel\block(), StandardRules\build(), MysqlChangeItem\buildCheckQuery(), PostgresqlChangeItem\buildCheckQuery(), SqlsrvChangeItem\buildCheckQuery(), ProgressBar\buildLine(), Route\buildRegexAndVarList(), Number\bytes(), TextDescriptor\calculateTotalWidthForOptions(), MediaHelper\canUpload(), FiberCaster\castFiber(), ExceptionCaster\castFrameStub(), Caster\castObject(), PgSqlCaster\castResult(), ExceptionCaster\castTraceStub(), ReflectionCaster\castType(), Category\categories(), UsersController\changeBlock(), SFTP\chdir(), Usergroup\check(), LinkTable\check(), BannerTable\check(), StageTable\check(), WorkflowTable\check(), Dispatcher\checkAccess(), DebugClassLoader\checkAnnotations(), PackageAdapter\checkExtensionInFilesystem(), ComponentAdapter\checkExtensionInFilesystem(), InstallerAdapter\checkExtensionInFilesystem(), Table\checkIn(), Table\checkOut(), ResetModel\checkResetLimit(), ApcuStorage\clean(), Path\clean(), InputFilter\cleanAttributes(), AbstractUri\cleanPath(), InstallerHelper\cleanupInstall(), Email\cloak(), Calculator\cmp(), PlgSystemDebug\collectLogs(), CategoryView\commonCategoryDisplay(), Application\configureIO(), MysqliDriver\connect(), SocketTransport\connect(), Socket\connect(), ToPunycode\convert(), Stream\copy(), Installer\copyFiles(), BigInteger\create(), PHPMailer\createBody(), TemplateController\createFile(), FlattenException\createFromThrowable(), PHPMailer\createHeader(), EC\createKey(), DSA\createKey(), TemplateModel\createOverride(), DH\createParameters(), OutputFormatter\createStyleFromString(), Uri\createUriString(), Salsa20\crypt(), DebugClassLoader\darwinRealpath(), HTMLHelper\date(), Language\debugFile(), ASN1\decodeTime(), SymmetricKey\decrypt(), LevelController\delete(), MfaTable\delete(), GroupModel\delete(), File\delete(), Folder\delete(), TemplateController\delete(), Stream\delete(), KeyOrPassword\deriveKeys(), HtmlDescriptor\describe(), CliDescriptor\describe(), WebClient\detectBrowser(), WebClient\detectEngine(), LanguageHelper\detectLanguage(), WebClient\detectPlatform(), Reader\determineFileTypeByHeader(), Resolver\determineInvalidSubjects(), CategoryFeedView\display(), FeedView\display(), DisplayController\display(), HtmlView\display(), Microdata\display(), FieldsHelper\displayFieldOnForm(), UsersController\displayList(), LintCommand\displayTxt(), BigDecimal\dividedBy(), PHPMailer\DKIM_Add(), VarCloner\doClone(), TasksRunCommand\doExecute(), ExtensionRemoveCommand\doExecute(), ExtensionInstallCommand\doExecute(), ExtensionDiscoverInstallCommand\doExecute(), Parser\doParse(), InstallerHelper\downloadPackage(), ArrayHelper\dropColumn(), Dumper\dump(), Inline\dump(), Data\dumpItem(), CliDumper\dumpKey(), DataObject\dumpProperty(), CliDumper\dumpString(), Debug\enable(), PHPMailer\encodeHeader(), SymmetricKey\encrypt(), Changelog\endElement(), CodePointString\endsWith(), UnicodeString\endsWith(), ByteString\endsWith(), CliDumper\endValue(), CliDumper\enterHash(), CodePointString\equalsTo(), UnicodeString\equalsTo(), ByteString\equalsTo(), English\exceptionR1(), Query\execute(), MysqliStatement\execute(), Application\execute(), BaseController\execute(), Reader\extractData(), AjaxController\fetchAssociations(), DatabaseModel\fetchSchemaCache(), TelFilter\filter(), UrlFilter\filter(), Caster\filter(), ComponentHelper\filterText(), Application\findAlternatives(), Form\findFieldsByGroup(), SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\fixSelectAliases(), ArrayHelper\flatten(), FlattenException\flattenArgs(), DaemonApplication\fork(), BCMath\format(), OutputFormatter\formatAndWrap(), HtmlErrorRenderer\formatArgs(), DataFormatter\formatCallerInfo(), GetConfigurationCommand\formatConfigValue(), TextDescriptor\formatDefaultValue(), DataFormatter\formatDuration(), DatabaseExporter\from(), BigInteger\fromBase(), UTCTime\fromBinary(), GeneralizedTime\fromBinary(), AbstractUnicodeString\fromCodePoints(), ApcuStorage\gc(), SSH2\generate_identifier(), PHPMailer\generateId(), SFTP\get(), ApcuStorage\getAll(), Input\getArray(), Input\getArrayRecursive(), Access\getAssetName(), AssociationsHelper\getAssociationHtmlList(), Access\getAuthorisedViewLevels(), Helper\getCanonicalPath(), TracksModel\getContent(), SourceContextProvider\getContext(), TemplateModel\getCoreFile(), RegistrationModel\getData(), QuestionHelper\getDefaultAnswer(), Workflow\getDefaultStageByCategory(), ChoiceQuestion\getDefaultValidator(), X509\getDN(), X509\getDNProp(), CMSObject\getError(), FieldsHelper\getFields(), FilterModel\getFilter(), ArgvInput\getFirstArgument(), QuestionHelper\getHiddenResponse(), InstalledVersions\getInstalled(), Uri\getInstance(), BaseController\getInstance(), CMSApplication\getInstance(), FormModel\getItem(), ArticleModel\getItem(), MessageModel\getItem(), ModuleModel\getItem(), WarningsModel\getItems(), PositionsModel\getItems(), SiteMenu\getItems(), ArticlesModel\getItems(), JavascriptRenderer\getJsControlsDefinitionCode(), JavascriptRenderer\getJsInitializationCode(), MysqlImporter\getKeySql(), MysqliImporter\getKeySql(), TinymcebuilderField\getLayoutData(), UserField\getLayoutData(), ColorField\getLayoutData(), MediaField\getLayoutData(), TagsSimilarHelper\getList(), LanguagesHelper\getList(), ArticlesCategoryHelper\getList(), ConsentsModel\getListQuery(), NotesModel\getListQuery(), ActionlogsModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), GroupsModel\getListQuery(), StagesModel\getListQuery(), TransitionsModel\getListQuery(), SearchModel\getListQuery(), LinksModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), PluginsModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), ItemsModel\getMenu(), MenusHelper\getMenuLinks(), DumpServer\getMessages(), Document\getMetaData(), MediaHelper\getMimeType(), BaseController\getModel(), ContentComponent\getModelName(), CronExpression\getMultipleRunDates(), JNamespacePsr4Map\getNamespaces(), Parser\getNextEmbedBlock(), SinglePrecisionFloatObject\getNormalizedData(), DoublePrecisionFloatObject\getNormalizedData(), HalfPrecisionFloatObject\getNormalizedData(), ExtensionDiscoverCommand\getNote(), ExtensionDiscoverInstallCommand\getNote(), DataSet\getObjectsKeys(), IntegerField\getOptions(), TagField\getOptions(), ArrayInput\getParameterOption(), WrapperHelper\getParams(), RouterView\getPath(), En_GBLocalise\getPluralSuffixes(), Fr_FRLocalise\getPluralSuffixes(), ModulesHelper\getPositions(), LazyString\getPrettyName(), OrderingField\getQuery(), RedisCaster\getRedisOptions(), CronExpression\getRunDate(), DatabaseDriver\getServerType(), ReflectionCaster\getSignature(), Factory\getStream(), PlgSystemSchedulerunner\getSubscribedEvents(), InputDefinition\getSynopsis(), Tar\getTarInfo(), Query\getTokenData(), MenutypesModel\getTypeOptionsFromMvc(), MenutypesModel\getTypeOptionsFromXml(), TemplateModel\getUpdatedList(), Updater\getUpdateSites(), Factory\getUser(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), ArrayHelper\getValue(), BaseController\getView(), Cache\getWorkarounds(), Grapheme\grapheme_extract(), Grapheme\grapheme_position(), Select\groupedlist(), ErrorHandler\handleError(), ErrorHandler\handleException(), ErrorHandler\handleFatalError(), ClientHelper\hasCredentials(), Table\hit(), Mbstring\html_encoding_callback(), Iconv\iconv_mime_decode(), Iconv\iconv_substr(), FinderIndexCommand\index(), CodePointString\indexOf(), UnicodeString\indexOf(), ByteString\indexOf(), CodePointString\indexOfLast(), UnicodeString\indexOfLast(), ByteString\indexOfLast(), Terminal\initDimensions(), Terminal\initDimensionsUsingStty(), AsymmetricKey\int2octets(), ConsoleLogger\interpolate(), IpHelper\IPinList(), Helper\isCommon(), CronExpression\isDue(), DayOfWeekField\isSatisfiedBy(), SSH2\key_exchange(), Access\level(), Parser\lexInlineQuotedString(), Route\link(), Raw\load(), PKCS8\load(), PKCS1\load(), Form\load(), Table\load(), DebugClassLoader\loadClass(), ComponentAdapter\loadLanguage(), MenusHelper\loadPreset(), UserController\login(), UserController\logout(), Http\makeTransportRequest(), Iconv\mapFromUtf8(), X509\mapInAttributes(), X509\mapOutAttributes(), Iconv\mapToUtf8(), Laminas\Diactoros\marshalUriFromSapi(), Browser\match(), Php72\mb_chr(), Mbstring\mb_chr(), Php72\mb_ord(), Mbstring\mb_strrpos(), Mbstring\mb_substr(), Menu\menuItems(), Rules\merge(), Stream\move(), Table\move(), PHPMailer\msgHTML(), UnicodeString\normalize(), DebugClassLoader\normalizeType(), Ini\objectToString(), PlgContentFields\onContentPrepare(), PlgContentContact\onContentPrepare(), PlgContentPagebreak\onContentPrepare(), PlgUserProfile\onContentPrepareForm(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgFinderTags\onFinderAfterDelete(), PlgFinderNewsfeeds\onFinderAfterDelete(), PlgFinderContacts\onFinderAfterDelete(), PlgFinderContent\onFinderAfterDelete(), PlgFinderCategories\onFinderDelete(), DSA\onLoad(), ContentHelper\onPrepareForm(), PlgAuthenticationCookie\onUserAfterLogin(), PlgSystemActionLogs\onUserAfterSave(), Joomla\onUserAfterSave(), PlgSystemLanguageFilter\onUserLogin(), Stream\open(), SymmetricKey\openssl_ctr_process(), Category\options(), Tag\options(), Select\options(), ListHelper\ordering(), ProgressBar\overwrite(), StandardRules\parse(), ArrayInput\parse(), Stream\parse_path(), PropelCollector\parseAndLogSqlQuery(), ArgvInput\parseArgument(), Cli\parseArguments(), Parser\parseBlockScalar(), Inline\parseMapping(), PostinstallHelper\parsePath(), SysinfoModel\parsePhpInfo(), InstallerAdapter\parseQueries(), Inline\parseScalar(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), ArgvInput\parseToken(), Parser\parseValue(), SFTP\partial_init_sftp_connection(), DebugClassLoader\patchMethod(), ArrayHelper\pivot(), ItemsModel\populateState(), Document\preloadAssets(), HtmlView\prepareDocument(), PKCS8\preParse(), Menu\preprocess(), CssMenu\preprocess(), ItemsModel\preprocessForm(), ItemModel\preprocessForm(), SSH2\privatekey_login(), ColorProcessor\process(), SqlsrvQuery\processLimit(), SqlField\processQuery(), Query\processString(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), TemplateModel\publish(), SFTP\put(), Client\query(), DatabaseDriver\quoteName(), Engine\randomRangeHelper(), Engine\randomRangePrimeOuter(), ZIPExtraction\readFileHeader(), Normalizer\recompose(), AbstractWebApplication\redirect(), ErrorHandler\register(), RegistrationModel\register(), WebAssetManager\registerAsset(), RssRenderer\render(), AtomRenderer\render(), ToolbarButton\render(), Table\render(), AdministratorApplication\render(), ScriptsRenderer\renderAttributes(), StylesRenderer\renderAttributes(), Table\renderRowSeparator(), Stream\request(), StreamTransport\request(), Reader\resolveStream(), ProcessHelper\run(), Application\run(), Command\run(), Backgroundfill\sanitizeColor(), GroupModel\save(), ApplicationModel\save(), ArticleController\save(), ModuleModel\save(), ItemModel\save(), LevelsModel\saveorder(), AdminModel\saveorder(), BigDecimal\scaleValues(), Inflector\seemsUtf8(), MailModel\send(), Mail\sendMail(), PlgSystemStats\sendStats(), PHPMailer\serverHostname(), Question\setAutocompleterValues(), InputArgument\setDefault(), WorkflowsController\setDefault(), StagesController\setDefault(), InputOption\setDefault(), LdapClient\setDn(), HtmlView\setDocumentTitle(), FieldModel\setFieldValue(), ItemModel\setHome(), ErrorHandler\setLoggers(), Document\setMetaData(), Input\setOption(), BaseLayout\setOptions(), InstallerScript\setParams(), ProgressBar\setProgress(), DatabaseDriver\setQuery(), ProgressBar\setRealFormat(), DebugClassLoader\setReturnType(), Mail\setSender(), AbstractField\setTimeHour(), ItemController\setType(), AccessiblemediaField\setup(), EditorField\setup(), Rijndael\setupKey(), X509\sign(), X509\signCRL(), AsciiSlugger\slug(), PHPMailer\smtpConnect(), AggregatedCollector\sort(), ArrayHelper\sortObjects(), DatabaseModel\splitQueries(), Installer\splitSql(), DatabaseDriver\splitSql(), SqlsrvQuery\splitSqlExpression(), PgsqlDriver\sqlValue(), BCMath\sqrt(), BigDecimal\sqrt(), DebugBar\stackData(), CodePointString\startsWith(), UnicodeString\startsWith(), ByteString\startsWith(), Helper\stem(), ZIPExtraction\step(), Portuguese\step1(), French\step1(), Italian\step1(), Spanish\step1(), English\step1b(), Italian\step3b(), Finnish\step5(), English\step5(), Versioning\store(), Menu\store(), StringHelper\strcasecmp(), StringHelper\strcmp(), Assertion\stringify(), Ini\stringToObject(), CliDumper\style(), HtmlDumper\style(), ParagonIE_Sodium_Core_Util\substr(), PHP\subtractHelper(), FtpClient\syst(), Tag\tags(), Telephone\tel(), TelRule\test(), Templates\thumb(), Templates\thumbModal(), Indexer\toggleTables(), StringInput\tokenize(), Helper\tokenize(), HTMLHelper\tooltipText(), ModulesModel\translate(), Joomla\CMS\Application\triggerEvent(), TranscodeUnicode\ucs4array_utf7(), TranscodeUnicode\ucs4array_utf8(), InstallerAdapter\uninstall(), StyleModel\unsetHome(), AbstractString\unwrap(), TranscodeUnicode\utf8_ucs4array(), PHPMailer\utf8CharBoundary(), AddressValidator\validate(), LevelModel\validate(), Form\validate(), CaBundle\validateCaFile(), DisplayController\validateEntry(), X509\validateSignatureCountable(), Users\value(), IpHelper\workaroundIPIssues(), AbstractString\wrap(), ClassStub\wrapCallable(), PHPMailer\wrapText(), et Stream\write().

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • clients
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/clients/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$purchaseTypes
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$params = $this->state->params ?? new CMSObject()
else __pad2__
$canEdit = $user->authorise('core.edit', 'com_banners')
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_banners') && $canCheckin
endif
else __pad3__
else __pad4__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_banners') && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_banners')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $params

$params = $this->state->params ?? new CMSObject()

Référencé par AssertionChain\__call(), BCMath\__callStatic(), ArgsStub\__construct(), TracedStatement\__construct(), Response\__construct(), AbstractDataCollector\__construct(), InfoCollector\__construct(), ProfileCollector\__construct(), Router\__construct(), Joomla\__construct(), QueryCollector\__construct(), ArrayInput\__toString(), ComponentAdapter\_buildAdminMenus(), CategoryModel\_buildContentOrderBy(), Pagination\_buildDataObject(), HtmlDocument\_fetchTemplate(), PlgUserJoomla\_getUser(), PlgContentLoadmodule\_load(), Captcha\_load(), Editor\_loadEditor(), PlgContentLoadmodule\_loadid(), PlgContentLoadmodule\_loadmod(), HtmlView\_prepareDocument(), ModuleController\add(), ActionlogModel\addLog(), TimeDataCollector\addMeasure(), ProfileCollector\addMeasure(), PHPMailer\addOrEnqueueAnAddress(), Dispatcher\addSubscriber(), Tag\ajaxfield(), Stream\appendFilter(), UpdateModel\applyUpdateSite(), Client\baseString(), IndexerController\batch(), LinksController\batch(), LinksModel\batchProcess(), MysqliStatement\bindValues(), Uri\buildQuery(), AbstractUri\buildQuery(), QueryHelper\buildVotingQuery(), TemplateHelper\canUpload(), MediaHelper\canUpload(), Bootstrap\carousel(), FilterTable\check(), CssMenu\check(), ApiController\checkContent(), MediaController\checkContent(), MediaHelper\checkFileExtension(), TemplateModel\checkFormat(), Checkfiles\checkImages(), PlgContentJoomla\checkMenuItemBeforeSave(), MediaHelper\checkMimeType(), TracedStatement\checkParameters(), ResetModel\checkResetLimit(), PHPMailer\clearQueuedAddresses(), JoomlaInstallerScript\clearStatsCache(), Bootstrap\collapse(), RedirectHelper\collectUrlsEnabled(), CategoryView\commonCategoryDisplay(), JHtmlIcon\create(), Icon\create(), DSA\createKey(), DH\createKey(), DH\createParameters(), MailTemplate\createTemplate(), Help\createUrl(), ChaCha20\decrypt_with_libsodium(), Installer\discover_install(), SiteApplication\dispatch(), FeedView\display(), OpensearchView\display(), CategoriesView\display(), HtmlView\display(), Editor\display(), PlgSystemFields\display(), PlgContentVote\displayVotingData(), Bootstrap\dropdown(), JHtmlIcon\edit(), Icon\edit(), PlgSampledataMultilang\enablePlugin(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), ChaCha20\encrypt_with_libsodium(), MysqliStatement\execute(), PdoStorage\find(), Client\generateAccessToken(), Client\generateRequestToken(), UserModel\getAssignedGroups(), MenuHelper\getBase(), QuickIconHelper\getButtons(), CategoryModel\getCategory(), CategoryModel\getChildren(), EC\getCurve(), ApplicationModel\getData(), ArchiveModel\getData(), InstalledModel\getData(), RegistrationModel\getData(), FeedHelper\getFeed(), ArticlesModel\getFilterForm(), ActionlogsModel\getFilterForm(), RandomImageHelper\getFolder(), TemplateModel\getForm(), BreadcrumbsHelper\getHome(), RandomImageHelper\getImages(), NumberField\getInput(), TextField\getInput(), EditorField\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), Adapter\getItemMenuTitle(), CategoriesModel\getItems(), FeaturedModel\getItems(), PlgSystemStats\getLayoutData(), SyndicateHelper\getLink(), ArticlesCategoriesHelper\getList(), StatsHelper\getList(), TagsPopularHelper\getList(), ArticlesPopularHelper\getList(), BannersHelper\getList(), BreadcrumbsHelper\getList(), LatestHelper\getList(), ArticlesArchiveHelper\getList(), TagsSimilarHelper\getList(), PopularHelper\getList(), LoggedHelper\getList(), ArticlesCategoryHelper\getList(), ArticlesLatestHelper\getList(), ArticlesNewsHelper\getList(), ArchiveModel\getListQuery(), ArticlesModel\getListQuery(), BaseController\getModel(), MenuModel\getModules(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), WhosonlineHelper\getOnlineUserNames(), ListField\getOptions(), FieldsListPlugin\getOptionsFromField(), PlgFieldsSubform\getOptionsFromField(), InstallerScript\getParam(), ArgsStub\getParameters(), TracedStatement\getParameters(), WrapperHelper\getParams(), ComponentRecord\getParams(), MenuItem\getParams(), SiteApplication\getParams(), FieldModel\getParams(), CategoryNode\getParams(), PlgFieldsSubform\getParamsFromField(), FinderHelper\getQuery(), RandomImageHelper\getRandomImage(), LoginHelper\getRegistrationUrl(), PrivacyStatusHelper\getRequestFormPublished(), LoginHelper\getReturnUrl(), StatsAdminHelper\getStats(), SuggestionsController\getSuggestions(), ApiApplication\getTemplate(), AdministratorApplication\getTemplate(), InstallationApplication\getTemplate(), CMSApplication\getTemplate(), LatestActionsHelper\getTitle(), LoggedHelper\getTitle(), PopularHelper\getTitle(), LatestHelper\getTitle(), UsersLatestHelper\getUsers(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), Associations\isEnabled(), MediaHelper\isValidLocalDirectory(), SSH2\key_exchange(), Access\level(), PSS\load(), CssMenu\load(), PKCS8\load(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), XML\loadCurveByParam(), ModuleModel\loadFormData(), PHPMailer\mailPassthru(), PHPMailer\mailSend(), Requests\makeGetRequest(), TimeDataCollector\measure(), ProfileCollector\measure(), Php\objectToString(), PlgSystemActionLogs\onAfterRespond(), Joomla\onContentAfterDelete(), PlgContentVote\onContentAfterDisplay(), PlgSystemFields\onContentAfterDisplay(), Joomla\onContentAfterSave(), PlgSystemFields\onContentAfterTitle(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgContentVote\onContentBeforeDisplay(), PlgSystemFields\onContentBeforeDisplay(), Joomla\onContentChangeState(), PlgContentEmailcloak\onContentPrepare(), PlgContentContact\onContentPrepare(), PlgContentPagebreak\onContentPrepare(), FieldsPlugin\onCustomFieldsPrepareDom(), FieldsPlugin\onCustomFieldsPrepareField(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterSave(), PlgSystemHighlight\onFinderResult(), HtmlDocument\parse(), MenusHelper\parseXmlNode(), ConfigModel\populateState(), SelectModel\populateState(), NewsfeedModel\populateState(), ArchiveModel\populateState(), ArticleModel\populateState(), SearchesModel\populateState(), PositionsModel\populateState(), StylesModel\populateState(), LevelsModel\populateState(), GroupsModel\populateState(), TemplatesModel\populateState(), CategoriesModel\populateState(), LanguagesModel\populateState(), PluginsModel\populateState(), ModulesModel\populateState(), TagModel\populateState(), LanguageModel\populateState(), NewsfeedsModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), ArticlesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), LoginModel\populateState(), StyleModel\populateState(), InstalledModel\populateState(), MenuModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ModuleModel\populateState(), FiltersModel\populateState(), ResetModel\populateState(), SuggestionsModel\populateState(), FeaturedModel\populateState(), CategoryModel\populateState(), FormModel\populateState(), RemindModel\populateState(), ConfirmModel\populateState(), ProfileModel\populateState(), RequestModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), SearchModel\populateState(), IndexModel\populateState(), RegistrationModel\populateState(), TemplateModel\populateState(), FieldModel\populateState(), ItemModel\populateState(), Content\prepare(), SqlsrvStatement\prepare(), Helper\prepareContent(), Stream\prependFilter(), FormModel\preprocessForm(), JHtmlIcon\print_screen(), Icon\print_screen(), Query\processStaticTaxonomy(), Query\processString(), InstalledModel\publish(), ItemModel\rebuild(), FeedView\reconcileNames(), ServiceProviderInterface\register(), RegistrationModel\register(), Dispatcher\removeSubscriber(), HeadRenderer\render(), MessageRenderer\render(), ModulesRenderer\render(), ModuleRenderer\render(), RawDocument\render(), ImageDocument\render(), XmlDocument\render(), ErrorDocument\render(), OpensearchDocument\render(), FeedDocument\render(), HtmlDocument\render(), PopupButton\renderButton(), ModuleHelper\renderModule(), ArticleController\save(), PKCS1\saveParameters(), LibraryHelper\saveParams(), PKCS8\savePrivateKey(), PSS\savePrivateKey(), PSS\savePSSParams(), PKCS8\savePublicKey(), PSS\savePublicKey(), MailModel\send(), IndexerController\sendResponse(), OptionsResolver\setDefault(), LanguagesModel\setDefault(), FieldModel\setFieldValue(), ComponentRecord\setParams(), InstallerScript\setParams(), MenuItem\setParams(), ConfigurationModel\setup(), Installer\setupInstall(), LanguageAdapter\setupUninstall(), Joomla\CMS\MVC\Model\setUpWorkflow(), IndexerController\start(), UiTab\startTabSet(), Bootstrap\startTabSet(), TimeDataCollector\stopMeasure(), ProfileCollector\stopMeasure(), HttpBridgePostRequestMethod\submit(), Post\submit(), SocketPost\submit(), CurlPost\submit(), ContactEmailMessageRule\test(), ContactEmailRule\test(), ContactEmailSubjectRule\test(), PasswordRule\test(), RequestParameters\toArray(), Helper\tokenize(), Indexer\tokenizeToDbShort(), Installer\uninstall(), MailTemplate\updateTemplate(), PublicKey\verify(), ReCaptcha\verify(), Menus\visibility(), PKCS8\wrapPrivateKey(), et PKCS8\wrapPublicKey().

◆ $purchaseTypes

$purchaseTypes
Valeur initiale :
= [
'1' => 'UNLIMITED'

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • download
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/download/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
endforeach

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • tracks
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/tracks/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad5__
foreach ( $this->items as $i=> $item)
endforeach
endif

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad5__

else __pad5__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • tmpl
  • cache
Espaces de nommage | Variables
Référence du fichier administrator/components/com_cache/tmpl/cache/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$wa = $this->document->getWebAssetManager()
else __pad0__
$i = 0
foreach ( $this->data as $folder=> $item)
endforeach
endif

Documentation des variables

◆ $i

$i = 0

Référencé par Stream\__call(), BCMath\__callStatic(), QueryElement\__clone(), DatabaseQuery\__clone(), RelativeObjectIdentifier\__construct(), IA5String\__construct(), ObjectIdentifier\__construct(), ClassStub\__construct(), BinaryField\__construct(), DebugClassLoader\__construct(), CSR\__toString(), CompletionInput\__toString(), Pagination\_buildDataObject(), PlgContentPagebreak\_createToc(), InstallerModel\_getList(), PluginsModel\_getList(), HtmlDocument\_parseTemplate(), JGrid\action(), Access\actions(), UserModel\activate(), ParagonIE_Sodium_Compat\add(), ArrayHelper\addColumn(), PHP\addHelper(), Binary\addPoint(), AbstractString\after(), AbstractString\afterLast(), Registry\append(), ANSI\appendString(), OutputFormatter\applyCurrentStyle(), AbstractUnicodeString\ascii(), ASN1\asn1map(), QuestionHelper\autocomplete(), Engine\base256_lshift(), PHPMailer\base64EncodeWrapMB(), PHP\baseSquare(), ModuleModel\batchCopy(), AbstractString\before(), AbstractString\beforeLast(), FieldTable\bind(), DatabaseQuery\bindArray(), Encoding\binToHex(), Engine\bitwise_leftRotate(), PHP\bitwise_small_split(), PHP\bitwise_split(), PrivateKey\blind(), UserModel\block(), Router\build(), RouterLegacy\build(), Icons\button(), Number\bytes(), Table\calculateColumnsWidth(), TemplateHelper\canUpload(), MediaHelper\canUpload(), DateCaster\castInterval(), Caster\castObject(), AbstractCloner\castObject(), DateCaster\castPeriod(), PgSqlCaster\castResult(), ExceptionCaster\castTraceStub(), DebugClassLoader\checkAnnotations(), DebugClassLoader\checkCase(), DebugClassLoader\checkClasses(), Totp\checkCode(), AbstractString\checkString(), FileStorage\clean(), InputFilter\cleanAttributes(), ModuleHelper\cleanModuleList(), AbstractUri\cleanPath(), InputFilter\cleanTags(), ErrorHandler\cleanTrace(), ParagonIE_Sodium_Core_Util\compare(), PHP\compareHelper(), ParagonIE_Sodium_Core32_BLAKE2b\compress(), ParagonIE_Sodium_Core_BLAKE2b\compress(), ParagonIE_Sodium_Core32_BLAKE2b\context(), ParagonIE_Sodium_Core_BLAKE2b\context(), FromPunycode\convert(), ToPunycode\convert(), ASN1\convert(), ParagonIE_Sodium_Core_Salsa20\core_salsa20(), Autoloader\createAppendAutoloader(), SymfonyStyle\createBlock(), DatabaseModel\createDatabase(), Autoloader\createPrependAutoloader(), RC4\crypt(), Salsa20\crypt(), DebugClassLoader\darwinRealpath(), Base128\decode(), Normalizer\decompose(), SymmetricKey\decrypt(), Rijndael\decryptBlock(), Blowfish\decryptBlock(), MessageModel\delete(), MapsModel\delete(), IndexModel\delete(), UpdatesitesModel\delete(), HistoryModel\delete(), GroupModel\delete(), UserModel\delete(), AdminModel\delete(), SFTP\delete(), SFTP\delete_recursive(), FeedView\display(), HtmlView\display(), PHP\divide_digit(), PHP\divideHelper(), PHPMailer\DKIM_QP(), NativeCalculator\doAdd(), VarCloner\doClone(), NativeCalculator\doMul(), Application\doRenderThrowable(), NativeCalculator\doSub(), ArrayHelper\dropColumn(), CliDumper\dumpString(), PasswordHash\encode64(), ASN1\encode_der(), SymmetricKey\encrypt(), Rijndael\encryptBlock(), Blowfish\encryptBlock(), AbstractString\ensureStart(), Inline\evaluateScalar(), PrivateKey\exponentiate(), Tar\extract(), TemplateModel\extractArchive(), Zip\extractCustom(), ExceptionCaster\extractSource(), ParagonIE_Sodium_Core_Curve25519\fe_invert(), ParagonIE_Sodium_Core32_Curve25519\fe_invert(), ParagonIE_Sodium_Core_Curve25519\fe_neg(), ParagonIE_Sodium_Core32_Curve25519\fe_neg(), ParagonIE_Sodium_Core_Curve25519\fe_normalize(), ParagonIE_Sodium_Core_Curve25519\fe_pow22523(), ParagonIE_Sodium_Core32_Curve25519\fe_pow22523(), AdministratorService\featured(), HtmlErrorRenderer\fileExcerpt(), HeaderSecurity\filter(), Uri\filterInvalidUtf8(), Bootup\filterRequestInputs(), FileStorage\find(), Application\findAlternatives(), Form\findGroup(), ParagonIE_Sodium_Core_BLAKE2b\finish(), DatabaseModel\fix(), SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\fixSelectAliases(), DatabaseQuery\format(), SSH2\format_log(), OutputFormatter\formatAndWrap(), FormatterHelper\formatBlock(), DateCaster\formatInterval(), Strings\formatPack(), Calculator\fromArbitraryBase(), ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray(), SplFixedArray\fromArray(), Integer\fromBinary(), LazyAssertionException\fromErrors(), ByteString\fromRandom(), ParagonIE_Sodium_Core32_BLAKE2b\G(), ParagonIE_Sodium_Core_BLAKE2b\G(), ParagonIE_Sodium_Core32_Curve25519\ge_select(), MtRandGenerator\generate(), EvalBarrett\generateInlineCompare(), EvalBarrett\generateInlineMultiply(), EvalBarrett\generateInlineSubtract1(), ListHelper\genericordering(), UserHelper\genRandomPassword(), PasswordHash\gensalt_blowfish(), SFTP\get(), SSH2\get_channel_packet(), PasswordHash\get_random_bytes(), OpenSSH\getAlias(), PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), MysqliImporter\getAlterTableSql(), TemplateModel\getArchive(), Php\getArrayString(), X509\getChain(), SourceContextProvider\getContext(), LanguageStringsCollector\getData(), DebugBar\getDataAsHeaders(), X509\getDN(), X509\getDNProp(), Integer\getEncodedValue(), CMSObject\getError(), Query\getExcludedTermIds(), ArgvInput\getFirstArgument(), UserMessagesField\getGroups(), ANSI\getHistory(), RandomImageHelper\getImages(), Query\getIncludedTermIds(), ChecksModel\getIniParserAvailability(), UpdateModel\getIniParserAvailability(), PrefixField\getInput(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), FeaturedModel\getItems(), AbstractMenu\getItems(), TinymcebuilderField\getLayoutData(), Pagination\getLimitBox(), StatsHelper\getList(), BreadcrumbsHelper\getList(), ArticlesArchiveHelper\getList(), LanguagesHelper\getList(), SearchModel\getListQuery(), LoginModel\getLoginModule(), BigInteger\getLowestSetBit(), PSSRSA\getMGF1(), RSA\getMGF1(), ModuleHelper\getModule(), ModuleHelper\getModuleById(), ModuleHelper\getModules(), ModulesHelper\getModules(), CronExpression\getMultipleRunDates(), Integer\getNAF(), Prime\getNAFPoints(), DayOfMonthField\getNearestWeekday(), Parser\getNextEmbedBlock(), IntegerField\getOptions(), AliastagField\getOptions(), MenuParentField\getOptions(), CategoryField\getOptions(), GroupparentField\getOptions(), PluginsField\getOptions(), CategoryeditField\getOptions(), CronField\getOptions(), Pagination\getPagesLinks(), Pagination\getPaginationPages(), Path\getPermissions(), RandomImageHelper\getRandomImage(), AbstractField\getRangeForExpression(), Query\getRequiredTermIds(), X509\getRevoked(), X509\getRevokedCertificateExtension(), X509\getRevokedCertificateExtensions(), CronExpression\getRunDate(), ANSI\getScreenHelper(), TracedStatement\getSqlWithParams(), Propel2Collector\getStatements(), QueryCollector\getStatements(), StatsAdminHelper\getStats(), Query\getTokenData(), PlgInstallerOverride\getUpdatedFiles(), Grapheme\grapheme_extract(), User\groups(), ParagonIE_Sodium_Core_Ristretto255\h2c_string_to_hash_sha256(), ParagonIE_Sodium_Core_Ristretto255\h2c_string_to_hash_sha512(), SignalRegistry\handle(), ErrorHandler\handleError(), NamePrep\hangulCompose(), ParagonIE_Sodium_Core_HChaCha20\hChaCha20Bytes(), ParagonIE_Sodium_Core_HSalsa20\hsalsa20(), Mbstring\html_encoding_callback(), Iconv\iconv_mime_decode(), PluginHelper\importPlugin(), MinutesField\increment(), HoursField\increment(), ParagonIE_Sodium_Compat\increment(), Strings\increment_str(), Core\incrementCounter(), FinderIndexCommand\index(), CodePointString\indexOf(), UnicodeString\indexOf(), ByteString\indexOf(), AbstractString\indexOf(), CodePointString\indexOfLast(), UnicodeString\indexOfLast(), ByteString\indexOfLast(), AbstractString\indexOfLast(), ParagonIE_Sodium_Core32_BLAKE2b\init(), ParagonIE_Sodium_Core_BLAKE2b\init(), PHP32\initialize(), PHP64\initialize(), BCMath\initialize(), Select\integerlist(), IpHelper\IPinList(), ParagonIE_Sodium_Compat\is_zero(), BackupcodesModel\isBackupCode(), Parser\isNextLineIndented(), Parser\isNextLineUnIndentedCollection(), InputFilter\isSafeFile(), X509\isSubArrayValid(), HistoryModel\keep(), SSH2\keyboard_interactive_process(), Hash\L1Hash(), Hash\L3Hash(), LdapClient\ldapNetAddr(), Links\link(), JWSLoader\loadAndVerifyWithKeySet(), FormHelper\loadClass(), X509\loadCRL(), SubformField\loadSubFormData(), PHP\lshift(), UCMContent\mapData(), Iconv\mapFromUtf8(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), FromUtf8\mapIso8859_1ToWindows1252(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), Iconv\mapToUtf8(), ToUtf8\mapWindows1252ToIso8859_1(), Engine\maxHelper(), Mbstring\mb_convert_case(), Mbstring\mb_decode_numericentity(), Mbstring\mb_encode_numericentity(), Mbstring\mb_str_split(), Twofish\mdsrem(), ArrayHelper\mergeRecursive(), RSA\mgf1(), Engine\minHelper(), SFTP\mkdir(), ParagonIE_Sodium_Core32_Int32\mulInt32Fast(), ParagonIE_Sodium_Core32_Int64\mulInt64Fast(), ParagonIE_Sodium_Core32_Int32\mulIntFast(), ParagonIE_Sodium_Core32_Int64\mulIntFast(), KoblitzPrime\multiplyAddPoints(), Prime\multiplyAddPoints(), Barrett\multiplyLower(), Base\multiplyPoint(), Montgomery\multiplyPoint(), MontgomeryMult\multiplyReduce(), Hash\nh(), PHP\normalize(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSampledataBlog\onAjaxSampledataApplyStep2(), Adapter\onBuildIndex(), SymmetricKey\openssl_ctr_process(), Pagination\orderDownIcon(), ModuleController\orderPosition(), Pagination\orderUpIcon(), ProgressBar\overwrite(), Strings\packSSH2(), Inline\parse(), Router\parse(), RouterLegacy\parse(), ApiRouter\parseApiRoute(), Cli\parseArguments(), Utility\parseAttributes(), SFTP\parseAttributes(), Parser\parseBlockScalar(), ASNObject\parseContentLength(), Inline\parseMapping(), SysinfoModel\parsePhpInfo(), Inline\parseQuotedScalar(), WebAssetRegistry\parseRegistryFile(), Router\parseRoute(), Inline\parseScalar(), Inline\parseSequence(), ArgvInput\parseShortOptionSet(), Inline\parseTag(), Parser\parseValue(), Text\passSprintf(), DebugClassLoader\patchMethod(), Core\pbkdf2(), Banner\pinned(), SymmetricKey\pkcs12helper(), BCMath\pow(), PlgContentFields\prepare(), MysqliStatement\prepareParameterKeyMapping(), SqlsrvStatement\prepareParameterKeyMapping(), ColorProcessor\process(), DES\processBlock(), Decoder\processFinite(), Hash\processSHA3Block32(), Hash\processSHA3Block64(), Query\processString(), UpdatesitesModel\publish(), ManageModel\publish(), MessageModel\publish(), MapsModel\publish(), StageModel\publish(), WorkflowModel\publish(), IndexModel\publish(), AdminModel\publish(), ItemModel\publish(), Redirect\published(), SFTP\put(), DatabaseDriver\quoteName(), SFTP\read_put_responses(), SFTP\readlist(), Usergroup\rebuild(), Normalizer\recompose(), Montgomery\reduce(), BackupcodesModel\regenerateBackupCodes(), PHP\regularMultiply(), Integer\regularPolynomialMultiply(), Registry\remove(), SFTP\remove_from_stat_cache(), X509\removeDNProp(), X509\removeRevokedCertificateExtension(), RssRenderer\render(), AtomRenderer\render(), Toolbar\render(), Table\render(), Table\renderRow(), AdminModel\reorder(), Table\reorder(), UnicodeString\replace(), MailTemplate\replaceTags(), Agent\requestIdentities(), X509\revoke(), X509\revokedCertificate(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_point_is_canonical(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_scalar_from_string(), PrivateKey\rsaes_oaep_decrypt(), PHP\rshift(), Stem\rv(), Russian\rv(), French\rv(), Stem\rx(), ParagonIE_Sodium_Core_Salsa20\salsa20(), ParagonIE_Sodium_Core32_Salsa20\salsa20(), Salsa20\salsa20(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor_ic(), ConfigController\save(), StyleController\save(), OverrideController\save(), FormController\save(), X509\saveCRL(), LevelsModel\saveorder(), AdminController\saveorder(), Nested\saveorder(), AdminModel\saveorder(), AdminController\saveOrderAjax(), PKCS1\savePrivateKey(), ParagonIE_Sodium_Core_Curve25519\sc25519_sqmul(), ParagonIE_Sodium_Crypto32\scalarmult_throw_if_zero(), ParagonIE_Sodium_Crypto\scalarmult_throw_if_zero(), PHP\scan1divide(), LdapClient\search(), Inflector\seemsUtf8(), Mail\sendMail(), Registry\set(), X509\setDN(), Hash\setHash(), ItemModel\setHome(), RC2\setKey(), SFTP\setListOrder(), SymmetricKey\setPassword(), X509\setRevokedCertificateExtension(), SFTP\setstat(), SFTP\setstat_recursive(), Blowfish\setupInlineCrypt(), Twofish\setupInlineCrypt(), Rijndael\setupInlineCrypt(), DES\setupInlineCrypt(), RC4\setupKey(), Blowfish\setupKey(), Twofish\setupKey(), Rijndael\setupKey(), DES\setupKey(), UserHelper\setUserGroups(), Hash\sha3_32(), Hash\sha3_64(), Hash\sha512(), Montgomery\slidingWindow(), Engine\slidingWindow(), ArrayHelper\sortObjects(), UnicodeString\split(), DatabaseModel\splitQueries(), Installer\splitSql(), DatabaseDriver\splitSql(), SqlsrvQuery\splitSqlExpression(), BCMath\sqrt(), Integer\squareRoot(), Updatesites\state(), Manage\state(), Modules\state(), Messages\status(), English\step1a(), English\step1b(), Finnish\step6(), ParagonIE_Sodium_Core32_BLAKE2b\store64(), DemoTasks\stressMemory(), Random\string(), ParagonIE_Sodium_Core32_BLAKE2b\stringToContext(), ParagonIE_Sodium_Core_BLAKE2b\stringToContext(), Iconv\strlen2(), CliDumper\style(), HtmlDumper\style(), ParagonIE_Sodium_Compat\sub(), X509\subArray(), X509\subArrayUnchecked(), PHP\subtractHelper(), CliDumper\supportsColors(), Strings\switchEndianness(), CssIdentifierRule\test(), ServiceLocatorTest\testGetDoesNotMemoize(), Engine\testPrimality(), Crypt\timingSafeCompare(), timingSafeEquals(), DataSet\toArray(), Calculator\toDecimal(), Zh\tokenise(), Helper\tokenize(), El\toLowerCase(), El\toUpperCase(), PHP\trim(), StringHelper\truncate(), Calculator\twosComplement(), TranscodeUnicode\ucs4_ucs4array(), Hash\uhash(), Strings\unpackSSH2(), ParagonIE_Sodium_Compat\unpad(), X509\unrevoke(), ParagonIE_Sodium_Core32_BLAKE2b\update(), ParagonIE_Sodium_Core_BLAKE2b\update(), SFTP\update_stat_cache(), Access\usergroup(), Access\usergroups(), TranscodeUnicode\utf7_ucs4array(), utf8_bad_identify(), utf8_byte_position(), Php72\utf8_decode(), Php72\utf8_encode(), utf8_ireplace(), utf8_is_valid(), utf8_strtolower(), utf8_strtoupper(), utf8_to_unicode(), Iconv\utf8ToUtf8(), LevelModel\validate(), X509\validateSignatureCountable(), AbstractString\wordwrap(), AbstractString\wrap(), et OpenSSH\wrapPrivateKey().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->data as $folder=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier administrator/components/com_categories/tmpl/categories/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$userId = $user->get('id')
$extension = $this->escape($this->state->get('filter.extension'))
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')
$parts = explode('.', $extension, 2)
$component = $parts[0]
$section = null
if(count($parts) > 1) | if ( $saveOrder &&!empty( $this->items))
else __pad0__
endif
$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', $extension . '.category.' . $item->id) && $item->created_user_id == $userId
$canChange = $user->authorise('core.edit.state', $extension . '.category.' . $item->id) && $canCheckin
if($item->level > 1) | else
$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))
else __pad1__
else __pad2__
if | (isset($this->items[0]) &&property_exists($this->items[0], 'count_published')) ( $item->count_published > 0) ? 'btn-success'
if | (isset($this->items[0]) &&property_exists($this->items[0], 'count_unpublished')) ( $item->count_unpublished > 0) ? 'btn-danger'
if | (isset($this->items[0]) &&property_exists($this->items[0], 'count_archived')) ( $item->count_archived > 0) ? 'btn-info'
if | (isset($this->items[0]) &&property_exists($this->items[0], 'count_trashed')) ( $item->count_trashed > 0) ? 'btn-dark'
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', $extension . '.category.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', $extension . '.category.' . $item->id) && $item->created_user_id == $userId

Référencé par ContactController\allowEdit(), et NewsfeedController\allowEdit().

◆ $component

$component = $parts[0]

Référencé par RouterLegacy\__construct(), LegacyComponent\__construct(), BaseDatabaseModel\__construct(), PlgContentJoomla\_canDeleteStage(), PlgContentJoomla\_countItemsInStage(), RouteHelper\_findItem(), GroupTable\_getAssetName(), GroupTable\_getAssetParentId(), FieldTable\_getAssetParentId(), HtmlView\_setPath(), Access\actions(), HtmlView\addToolbar(), FieldModel\batchCopy(), BaseDatabaseModel\bootComponent(), SiteRouter\buildComponentPreprocess(), MenuRules\buildLookup(), SiteRouter\buildSefRoute(), Construct\calculateContentLength(), ComponentController\cancel(), StageModel\canDelete(), MediaHelper\canUpload(), MediaHelper\checkFileExtension(), MediaHelper\checkMimeType(), TagsModel\countItems(), CategoriesModel\countItems(), Help\createUrl(), ComponentAdapter\discover(), AdministratorApplication\dispatch(), SiteApplication\dispatch(), ApiApplication\dispatch(), DisplayController\display(), HtmlView\display(), JsonapiView\displayList(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), FieldsHelper\extract(), HelpButton\fetchButton(), RouteHelper\findItem(), Joomla\getActionLogParams(), ContentHelper\getActions(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), AssociationHelper\getAssociations(), User\getAuthorisedCategories(), Workflow\getComponent(), SiteRouter\getComponentRouter(), ConfigHelper\getComponentsWithConfig(), Workflow\getConditionName(), ActionlogsHelper\getContentTypeLink(), DebuguserModel\getDebugActions(), DebuggroupModel\getDebugActions(), DebugHelper\getDebugActions(), FileLayout\getDefaultIncludePaths(), Construct\getEncodedValue(), RulesRule\getFieldActions(), MenutypesModel\getFolders(), ContenthistoryHelper\getFormFile(), NumberField\getInput(), RulesField\getInput(), TextField\getInput(), Categories\getInstance(), ItemModel\getItem(), RequestController\getJson(), LanguagesHelper\getList(), DebuguserModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowComponentSectionsField\getOptions(), ComponentsCategoryField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), FieldcontextsField\getOptions(), WorkflowcontextsField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), TransitionField\getOptions(), TemplateModel\getOverridesList(), MenusHelper\getPresets(), MenutypesModel\getTypeOptions(), MenutypesModel\getTypeOptionsByComponent(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromManifest(), MenutypesModel\getTypeOptionsFromMvc(), MenutypesModel\getTypeOptionsFromXml(), ConfigHelper\hasComponentConfig(), ToolbarHelper\help(), PlgWorkflowNotification\isSupported(), PlgWorkflowFeaturing\isSupported(), PlgWorkflowPublishing\isSupported(), Joomla\CMS\Workflow\isWorkflowActive(), AssociationsHelper\loadHelper(), ContenthistoryHelper\loadLanguageFiles(), ConfigHelper\loadLanguageForComponent(), ConfigHelper\loadLanguageForComponents(), PlgSystemLanguageFilter\onAfterDispatch(), PlgWorkflowFeaturing\onAfterDisplay(), PlgWorkflowPublishing\onAfterDisplay(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), PlgWorkflowPublishing\onContentVersioningPrepareTable(), ContentHelper\onPrepareForm(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), PlgWorkflowNotification\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), UriHelper\parse_url(), SiteRouter\parseSefRoute(), ComponentModel\populateState(), ToolbarHelper\preferences(), Access\preloadComponents(), GroupModel\preprocessForm(), CategoryModel\preprocessForm(), FieldModel\preprocessForm(), AdminModel\redirectToAssociations(), ServiceProviderInterface\register(), AdministratorApplication\render(), FileLayout\setComponent(), SiteRouter\setComponentRouter(), ItemController\setType(), Versioning\store(), JoomlaInstallerScript\updateContentTypes(), et FileLayout\validComponent().

◆ $extension

$extension = $this->escape($this->state->get('filter.extension'))
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par WorkflowController\__construct(), WorkflowsController\__construct(), StageController\__construct(), TransitionController\__construct(), DisplayController\__construct(), TransitionsController\__construct(), StagesController\__construct(), CategoryModel\__construct(), Workflow\__construct(), PlgContentJoomla\_canDeleteCategories(), PlgContentJoomla\_countItemsInStage(), TransitionTable\_getAssetName(), StageTable\_getAssetName(), WorkflowTable\_getAssetName(), TransitionTable\_getAssetParentId(), StageTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), Categories\_load(), AuthenticationExtensionsClientOutputs\add(), AuthenticationExtensionsClientInputs\add(), PlgExtensionFinder\addCommonWords(), CertificateExtensions\addExtension(), TraceableTwigEnvironment\addExtension(), Joomla\CMS\MVC\Model\addTransitionField(), AdministratorService\association(), CategoryModel\batchCopy(), CategoryModel\batchMove(), TransitionModel\canDelete(), StageModel\canDelete(), TransitionModel\canEditState(), StageModel\canEditState(), Category\categories(), Dispatcher\checkAccess(), AdminModel\checkCategoryId(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), MediaHelper\checkFileExtension(), AssociationsController\checkin(), Joomla\checkLoggable(), CategoryModel\cleanCache(), LanguageFilesCollector\collect(), DatabaseModel\compareUpdateVersion(), TagsModel\countItems(), CategoriesModel\countItems(), NewsfeedsHelper\countTagItems(), LegacyComponent\countTagItems(), ContentComponent\countTagItems(), PublicKeyCredentialLoader\createResponse(), ModuleAdapter\discover(), LibraryAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), CategoryFeedView\display(), HtmlView\display(), InstallerAdapter\doLoadLanguage(), FileAdapter\extensionExistsInSystem(), Assertion\extensionVersion(), AjaxController\fetchAssociations(), ExtensionsListCommand\filterExtensionsBasedOn(), ExtensionDiscoverListCommand\filterExtensionsBasedOnState(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), CategoriesHelper\getAssociations(), Associations\getAssociations(), CategoryAssociationHelper\getCategoryAssociations(), RouteHelper\getCategoryRoute(), UpdateModel\getCollectionDetailsUrls(), DebugHelper\getComponents(), ExtensionHelper\getCoreExtensionIds(), ActionlogsHelper\getCsvData(), DebugHelper\getDebugActions(), InstallerHelper\getDownloadKey(), InstallerHelper\getDownloadKeyExistsSites(), InstallerHelper\getDownloadKeySupportedSites(), CategoriesModel\getEmptyStateQuery(), InstallerHelper\getExtensionDownloadKey(), MessagesModel\getExtensionName(), SysinfoModel\getExtensions(), X509\getExtensionsHelper(), ExtensionsListCommand\getExtensionsNameAndId(), CategoryModel\getForm(), ItemtypeField\getGroups(), FieldLayoutField\getInput(), ComponentlayoutField\getInput(), Categories\getInstance(), InstallerScript\getInstances(), UpdatesiteModel\getItem(), ModuleModel\getItem(), TagsModel\getItems(), CategoriesModel\getItems(), ItemsModel\getItems(), PlgExtensionFinder\getLanguage(), LanguagesModel\getLanguages(), ActionlogsModel\getListQuery(), TemplatesModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), WorkflowsModel\getListQuery(), ActionlogsModel\getLogsForItem(), ModulesHelper\getModules(), JNamespacePsr4Map\getNamespaces(), UpdateModel\getNonCoreExtensions(), AliastagField\getOptions(), ComponentsField\getOptions(), WorkflowComponentSectionsField\getOptions(), ExtensionField\getOptions(), LogtypeField\getOptions(), ConfigComponentsField\getOptions(), CategoryField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), CategoryeditField\getOptions(), Language\getPaths(), TransitionController\getRedirectToItemAppend(), CategoryController\getRedirectToItemAppend(), CategoriesController\getRedirectToListAppend(), TransitionController\getRedirectToListAppend(), CategoryController\getRedirectToListAppend(), TemplateModel\getSafeName(), LocalAdapter\getSafeName(), AssociationsHelper\getSupportedExtensions(), Adapter\getUrl(), HTMLHelper\includeRelativeFiles(), PlgFinderCategories\index(), Joomla\CMS\Workflow\isFunctionalityUsed(), ApiModel\isMediaFile(), AttestationObjectLoader\load(), Language\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), ManageModel\loadChangelog(), X509\loadCRL(), CategoryModel\loadFormData(), CMSPlugin\loadLanguage(), FileAdapter\loadLanguage(), LibraryAdapter\loadLanguage(), TemplateAdapter\loadLanguage(), PluginAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), Language\loadLanguage(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), PlgContentFinder\onCategoryChangeState(), PlgWorkflowFeaturing\onContentBeforeChangeFeatured(), PlgButtonImage\onDisplay(), PlgExtensionFinder\onExtensionAfterInstall(), PlgFinderContacts\onFinderCategoryChangeState(), PlgFinderNewsfeeds\onFinderCategoryChangeState(), PlgFinderContent\onFinderCategoryChangeState(), PlgSystemActionLogs\onUserAfterSave(), Category\options(), PlgSystemLanguageFilter\parseRule(), StageModel\populateState(), TransitionModel\populateState(), WorkflowModel\populateState(), StagesModel\populateState(), TransitionsModel\populateState(), WorkflowsModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), CategoryModel\populateState(), WorkflowModel\preprocessForm(), TransitionModel\preprocessForm(), StageModel\preprocessForm(), CategoryModel\preprocessForm(), CategoriesController\preprocessSaveData(), StageModel\publish(), CategoryModel\publish(), AdminModel\redirectToAssociations(), PlgExtensionFinder\removeCommonWords(), PackageAdapter\removeExtensionFiles(), PlgSystemActionLogs\renderActionlogsExtensions(), WorkflowModel\save(), ApplicationModel\save(), StyleModel\save(), X509\saveCRL(), X509\saveX509(), ActionlogModel\sendNotificationEmails(), StyleModel\setHome(), ConfigurationModel\setup(), TemplateAdapter\setupUninstall(), Joomla\CMS\MVC\Model\setUpWorkflow(), InstallerModel\translate(), PluginsModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), JoomlaInstallerScript\updateManifestCaches(), CategoriesHelper\validateCategoryId(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $parts

$parts = explode('.', $extension, 2)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Accept\__construct(), AcceptLanguage\__construct(), FeatureEvent\__construct(), DisplayEvent\__construct(), AbstractEvent\__construct(), Uri\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), GroupController\__construct(), InstallationApplication\__construct(), FieldController\__construct(), TransitionController\__construct(), StageController\__construct(), DisplayController\__construct(), TransitionsController\__construct(), StagesController\__construct(), FormField\__construct(), PlgContentJoomla\_canDeleteStage(), PlgContentJoomla\_countItemsInStage(), HtmlView\_createFileName(), TransitionTable\_getAssetName(), StageTable\_getAssetName(), WorkflowTable\_getAssetName(), TransitionTable\_getAssetParentId(), StageTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), JLoader\_load(), FtpClient\_passive(), FtpClient\_verifyResponse(), HtmlErrorRenderer\abbrClass(), HtmlView\addToolbar(), ItemModel\batchCopy(), CategoryModel\batchCopy(), ItemModel\batchMove(), Strings\bits2bin(), BaseAccept\buildParametersString(), SiteRouter\buildSefRoute(), StageModel\canDelete(), FieldModel\canDelete(), FieldsHelper\canEditFieldValue(), FieldModel\canEditState(), Dispatcher\checkAccess(), AbstractIdnaConvert\convertEmailAddress(), TagsModel\countItems(), CategoriesModel\countItems(), NewsfeedsHelper\countTagItems(), ContentComponent\countTagItems(), AbstractEvent\create(), PHPMailer\createBody(), PrivacyPlugin\createCustomFieldsDomain(), BaseController\createFileName(), InstallationApplication\debugLanguage(), Helper\determineBaseFile(), HtmlView\display(), PlgSystemFields\display(), PlgContentVote\displayVotingData(), InstallerHelper\downloadPackage(), ASN1\encodeOID(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), Query\explained(), FieldsHelper\extract(), HTMLHelper\extract(), Application\extractAllNamespaces(), ApplicationDescription\extractNamespace(), Application\extractNamespace(), X509\fetchURL(), Uri\filterQuery(), Application\findAlternatives(), PharInvocationResolver\findInBaseNames(), Strings\formatPack(), ColorStyle\fromString(), ApiController\getAdapter(), Cache\getCacheKey(), Workflow\getComponent(), InstallerHelper\getFilenameFromUrl(), CategoryModel\getForm(), FieldModel\getForm(), Categories\getInstance(), FieldsModel\getListQuery(), PlgSystemLogrotation\getLogFiles(), Joomla\CMS\Workflow\getModelName(), ContentComponent\getModelName(), AliastagField\getOptions(), ComponentsCategoryField\getOptions(), FieldcontextsField\getOptions(), WorkflowcontextsField\getOptions(), ContenttypeField\getOptions(), WorkflowconditionField\getOptions(), TransitionField\getOptions(), ApiController\getPath(), CronExpression\getRunDate(), Workflow\getValidTransition(), JLoader\import(), MinutesField\increment(), HoursField\increment(), PlgFinderCategories\index(), LdapClient\ipToNetAddress(), AbstractField\isInRange(), DayOfWeekField\isSatisfiedBy(), PlgWorkflowNotification\isSupported(), PlgWorkflowFeaturing\isSupported(), PlgWorkflowPublishing\isSupported(), Joomla\CMS\Workflow\isWorkflowActive(), OpenSSH\load(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), PlgSystemFields\onContentPrepare(), PlgSystemFields\onContentPrepareForm(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), PlgWorkflowPublishing\onContentVersioningPrepareTable(), PlgButtonImage\onDisplay(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), Token\onUserAuthenticate(), AbstractUri\parse(), UriHelper\parse_url(), PropelCollector\parseAndLogSqlQuery(), BaseAccept\parseParameters(), PlgSystemLanguageFilter\parseRule(), Uri\parseUri(), WorkflowsModel\populateState(), FieldsModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), CategoryModel\populateState(), FieldModel\populateState(), PlgContentFields\prepare(), Menu\preprocess(), CssMenu\preprocess(), WorkflowModel\preprocessForm(), GroupModel\preprocessForm(), TransitionModel\preprocessForm(), StageModel\preprocessForm(), Query\processString(), DatabaseDriver\quoteNameStr(), AbstractWebApplication\redirect(), AbstractUri\render(), FieldsHelper\render(), Path\resolve(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), MenusController\resync(), PlgSystemLogrotation\rotate(), StageModel\save(), TransitionModel\save(), FlattenException\setTrace(), Joomla\CMS\MVC\Model\setUpWorkflow(), BCMath\sqrt(), SocketPost\submit(), AbstractUri\toString(), InstallerModel\translate(), CompactSerializer\unserialize(), MD5Handler\validatePassword(), et Yubikey\validateYubikeyOtp().

◆ $prefix

$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\_(), PaginationObject\__construct(), Profiler\__construct(), Pagination\__construct(), JLoader\_autoload(), BaseDatabaseModel\_createTable(), MemcachedStorage\_getCacheId(), JGrid\action(), ClassLoader\add(), ReflectionCaster\addAttributes(), BaseModel\addIncludePath(), ReflectionCaster\addMap(), BaseController\addModelPath(), FormHelper\addPrefix(), ClassLoader\addPsr4(), OutputFormatter\applyCurrentStyle(), ActionsDropdown\archive(), DatabaseModel\backupDatabase(), SymfonyStyle\block(), LevelModel\canDelete(), RdKafkaCaster\castBrokerMetadata(), AmqpCaster\castChannel(), ReflectionCaster\castClass(), ReflectionCaster\castClosure(), RdKafkaCaster\castConf(), AmqpCaster\castConnection(), DateCaster\castDateTime(), SplCaster\castDoublyLinkedList(), AmqpCaster\castEnvelope(), AmqpCaster\castExchange(), FiberCaster\castFiber(), SplCaster\castFileInfo(), SplCaster\castFileObject(), ExceptionCaster\castFrameStub(), ReflectionCaster\castFunctionAbstract(), RdKafkaCaster\castKafkaConsumer(), RdKafkaCaster\castMessage(), ReflectionCaster\castParameter(), RdKafkaCaster\castPartitionMetadata(), PdoCaster\castPdo(), PdoCaster\castPdoStatement(), AmqpCaster\castQueue(), RdKafkaCaster\castRdKafka(), RedisCaster\castRedis(), RedisCaster\castRedisArray(), RedisCaster\castRedisCluster(), ReflectionCaster\castReflectionGenerator(), SplCaster\castSplArray(), ExceptionCaster\castThrowingCasterException(), RdKafkaCaster\castTopic(), RdKafkaCaster\castTopicConf(), RdKafkaCaster\castTopicMetadata(), RdKafkaCaster\castTopicPartition(), ExceptionCaster\castTraceStub(), ReflectionCaster\castType(), MemcachedStorage\clean(), ClassNotFoundErrorEnhancer\convertFileToClass(), SymfonyStyle\createBlock(), MVCFactory\createController(), Factory\createDbo(), ApiMVCFactory\createModel(), LegacyFactory\createModel(), MVCFactory\createModel(), BaseController\createModel(), ApiMVCFactory\createTable(), LegacyFactory\createTable(), MVCFactory\createTable(), LegacyFactory\createView(), MVCFactory\createView(), BaseController\createView(), ASN1\decodeTime(), HtmlView\display(), Dumper\dump(), ActionsDropdown\duplicate(), Dropdown\edit(), UndefinedFunctionErrorEnhancer\enhance(), AbstractString\ensureStart(), CliDumper\enterHash(), WorkflowStage\existing(), HTMLHelper\extract(), RdKafkaCaster\extractMetadata(), ActionsDropdown\feature(), FeedParser\fetchNamespace(), ClassNotFoundErrorEnhancer\findClassInPath(), ClassLoader\findFileWithExtension(), ArrayHelper\flatten(), OptionsResolver\formatOptions(), ClassNotFoundErrorEnhancer\getClassCandidates(), MVCFactory\getClassName(), ActionlogsHelper\getContentTypeLink(), DatabaseHelper\getDbo(), InstallerHelper\getDownloadKey(), DatabaseExporter\getGenericTableName(), PrefixField\getInput(), Profiler\getInstance(), BaseController\getInstance(), Table\getInstance(), CMSApplication\getInstance(), CheckinModel\getItems(), MysqlImporter\getKeySql(), MysqliImporter\getKeySql(), TagsSimilarHelper\getList(), BannersModel\getListQuery(), MessagesController\getModel(), NewsfeedsController\getModel(), PreviewController\getModel(), LanguagesController\getModel(), RequestsController\getModel(), PluginsController\getModel(), CategoriesController\getModel(), TagsController\getModel(), HistoryController\getModel(), IndexController\getModel(), TasksController\getModel(), LevelsController\getModel(), FiltersController\getModel(), NotesController\getModel(), ClientsController\getModel(), MapsController\getModel(), FieldsController\getModel(), GroupsController\getModel(), TracksController\getModel(), AssociationsController\getModel(), MenusController\getModel(), ItemsController\getModel(), BannersController\getModel(), ContactController\getModel(), StylesController\getModel(), UsersController\getModel(), ModulesController\getModel(), UpdatesitesController\getModel(), WorkflowsController\getModel(), FeaturedController\getModel(), LinksController\getModel(), TransitionsController\getModel(), StagesController\getModel(), ContactsController\getModel(), ArticlesController\getModel(), ActionlogsController\getModel(), TemplateController\getModel(), ArticleController\getModel(), ApiController\getModel(), FormController\getModel(), BaseController\getModel(), Pagination\getPagesLinks(), DatabaseImporter\getRealTableName(), ReflectionCaster\getSignature(), Factory\getStream(), FeatureModel\getTable(), UserModel\getTable(), GroupModel\getTable(), MenuModel\getTable(), RequestModel\getTable(), WorkflowsModel\getTable(), TransitionsModel\getTable(), PreviewModel\getTable(), StagesModel\getTable(), RemoveModel\getTable(), LevelModel\getTable(), CompareModel\getTable(), CategoryModel\getTable(), RemindModel\getTable(), ConfirmModel\getTable(), PluginModel\getTable(), HistoryModel\getTable(), FormModel\getTable(), ExportModel\getTable(), TemplateModel\getTable(), BaseDatabaseModel\getTable(), TaskModel\getTable(), BannersModel\getTable(), MapsModel\getTable(), IndexModel\getTable(), FieldModel\getTable(), User\getTable(), ModuleModel\getTable(), ItemModel\getTable(), TagsHelper\getTagIds(), DisplayController\getView(), BaseController\getView(), CaBundle\isOpensslParseSafe(), FormHelper\loadClass(), Assert\notStartsWith(), PlgSystemSef\onAfterRender(), FeedParser\parse(), CodePointString\prepend(), UnicodeString\prepend(), ByteString\prepend(), DebugFormatterHelper\progress(), ActionsDropdown\publish(), Dropdown\publish(), AbstractWebApplication\redirect(), FeedParser\registerNamespace(), JLoader\registerPrefix(), PgsqlDriver\replacePrefix(), DatabaseDriver\replacePrefix(), FormController\save(), ClassLoader\set(), HtmlDumper\setDumpBoundaries(), ClassLoader\setPsr4(), PHPMailer\smtpConnect(), DebugFormatterHelper\start(), CodePointString\startsWith(), UnicodeString\startsWith(), ByteString\startsWith(), AbstractString\startsWith(), Assert\startsWith(), DebugFormatterHelper\stop(), CliDumper\style(), Form\syncPaths(), Registry\toFlatten(), ActionsDropdown\trash(), AbstractUnicodeString\trimPrefix(), AbstractString\trimPrefix(), ActionsDropdown\unarchive(), ActionsDropdown\unfeature(), ActionsDropdown\unpublish(), et ActionsDropdown\untrash().

◆ $saveOrder

$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')

◆ $section

$section = null

Référencé par PlgContentJoomla\_countItemsInStage(), Access\actions(), HtmlView\addToolbar(), SysinfoModel\cleanPrivateData(), LegacyComponent\countItems(), CategoriesModel\countItems(), NewsfeedsHelper\countTagItems(), ContentComponent\countTagItems(), CategoryFactory\createCategory(), CliDescriptor\describe(), TextView\display(), HtmlView\display(), FormatterHelper\formatSection(), ContentHelper\getActions(), Joomla\CMS\Categories\getCategory(), LegacyComponent\getCategory(), RulesRule\getFieldActions(), RulesField\getInput(), AssociationsModel\getListQuery(), ComponentsCategoryField\getOptions(), NewsfeedsComponent\getTableNameForSection(), ContactComponent\getTableNameForSection(), PlgWorkflowFeaturing\onAfterDisplay(), PlgWorkflowPublishing\onAfterDisplay(), PlgSystemAccessibility\onBeforeCompileHead(), ConsoleSectionOutput\popStreamContentUntilCurrentSection(), GroupModel\preprocessForm(), CategoryModel\preprocessForm(), FieldModel\preprocessForm(), Ini\stringToObject(), UsersComponent\validateSection(), ContactComponent\validateSection(), ContentComponent\validateSection(), UsersHelper\validateSection(), et LegacyComponent\validateSection().

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ (isset($this->items[0]) &&property_exists($this->items[0], 'count_archived'))

if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_archived'))($item->count_archived > 0) ? 'btn-info'

◆ (isset($this->items[0]) &&property_exists($this->items[0], 'count_published'))

if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_published'))($item->count_published > 0) ? 'btn-success'

◆ (isset($this->items[0]) &&property_exists($this->items[0], 'count_trashed'))

if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_trashed'))($item->count_trashed > 0) ? 'btn-dark'

◆ (isset($this->items[0]) &&property_exists($this->items[0], 'count_unpublished'))

if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_unpublished'))($item->count_unpublished > 0) ? 'btn-danger'

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ else

if ( $item->level > 1) else
Valeur initiale :
{
$parentsStr = ''

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • tmpl
  • checkin
Espaces de nommage | Variables
Référence du fichier administrator/components/com_checkin/tmpl/checkin/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$i = 0
foreach ( $this->items as $table=> $count)
endforeach
endif

Documentation des variables

◆ $i

$i = 0

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $table=> $count)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier administrator/components/com_config/tmpl/application/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • component
Espaces de nommage | Variables
Référence du fichier administrator/components/com_config/tmpl/component/default.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$template = $app->getTemplate()
$wa = $this->document->getWebAssetManager()
if($this->fieldsets) | $xml = $this->form->getXml()
< div class="col-md-3" id="sidebar">< button class="btn btn-sm btn-secondary my-2 options-menu d-md-none" type="button" data-bs-toggle="collapse" data-bs-target=".sidebar-nav" aria-controls="sidebar-nav" aria-expanded="false">< span class="icon-align-justify" aria-hidden="true"></span >< div class="col-md-9" id="config"> | if ( $this->fieldsets)

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $template

$template = $app->getTemplate()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HtmlDocument\_fetchTemplate(), HtmlView\_setPath(), WebAssetRegistry\addTemplateRegistryFile(), ExceptionCaster\castFrameStub(), TemplateModel\child(), TemplateModel\copy(), TemplateModel\copyStyles(), TemplateModel\createOverride(), MailTemplate\createTemplate(), TemplateAdapter\discover(), AdministratorApplication\dispatch(), SiteApplication\dispatch(), JoomlaInstallerScript\fixTemplateMode(), TemplateModel\fixTemplateName(), TemplateModel\getAllTemplateStyles(), SourceContextProvider\getContext(), TemplateModel\getCoreList(), FileLayout\getDefaultIncludePaths(), TemplateModel\getFiles(), TemplateModel\getFont(), StyleModel\getForm(), TemplatestyleField\getGroups(), ChromestyleField\getGroups(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), PositionsModel\getItems(), PluginHelper\getLayoutPath(), ModuleHelper\getLayoutPath(), AbstractStatsField\getLayoutPaths(), JoomlatokenField\getLayoutPaths(), PlgSystemStats\getLayoutPaths(), StylesModel\getListQuery(), TemplateModel\getMediaFiles(), TemplateModel\getOverridesList(), ApiApplication\getTemplate(), AdministratorApplication\getTemplate(), InstallationApplication\getTemplate(), TemplateModel\getTemplate(), CMSApplication\getTemplate(), InfoCollector\getTemplateInfo(), ChromestyleField\getTemplateModuleStyles(), ModulesHelper\getTemplates(), ModulesHelper\getTranslatedModulePosition(), MenutypesModel\getTypeOptionsFromLayouts(), TemplateModel\getUpdatedList(), TwigProfileCollector\getXdebugLink(), NamespacedTwigProfileCollector\getXdebugLink(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), HTMLHelper\includeRelativeFiles(), UpdateModel\isTemplateActive(), HtmlView\loadTemplate(), TemplateParser\parseBinary(), PositionsModel\populateState(), Modules\positions(), TemplateModel\prepareCoreFiles(), TemplatesModel\preprocessForm(), StyleModel\preprocessForm(), ModuleModel\preprocessForm(), HtmlRenderer\render(), SiteApplication\render(), HtmlErrorRenderer\renderException(), ModuleHelper\renderModule(), TemplateModel\save(), SiteApplication\setTemplate(), TemplateModel\storeFileInfo(), Modules\templates(), Templates\thumb(), Templates\thumbModal(), et MailTemplate\updateTemplate().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ $xml

if ( $this->fieldsets) $xml = $this->form->getXml()

Référencé par XmlResponse\__construct(), XmlView\addXmlChild(), InstallerAdapter\canUninstallPackageChild(), TemplateModel\child(), XmlResponse\createBody(), Help\createSiteList(), InstallerHelper\detectType(), XmlView\display(), HtmlView\display(), XML\encodeXMLParameters(), Access\getActionsFromFile(), DebugHelper\getDebugActions(), ContenthistoryHelper\getFormValues(), ComponentlayoutField\getInput(), PositionsModel\getItems(), InstallationApplication\getLocalise(), JNamespacePsr4Map\getNamespaces(), TemplatesHelper\getPositions(), ModulesModel\getPositions(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromMvc(), MenutypesModel\getTypeOptionsFromXml(), Form\getXml(), DatabaseImporter\importData(), Installer\isManifest(), XML\isolateNamespace(), Form\loadFile(), PackageManifest\loadManifestFromData(), LibraryManifest\loadManifestFromData(), Manifest\loadManifestFromXml(), MenusHelper\loadPreset(), DatabaseImporter\mergeStructure(), Installer\parseXMLInstallFile(), LanguageHelper\parseXMLLanguageFile(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), PluginModel\preprocessForm(), StyleModel\preprocessForm(), ModuleModel\preprocessForm(), ItemModel\preprocessForm(), OpensearchDocument\render(), Form\reset(), AccessiblemediaField\setup(), FileAdapter\setupUninstall(), LibraryAdapter\setupUninstall(), PackageAdapter\setupUninstall(), Xml\stringToObject(), et LanguageAdapter\update().

◆ if

<div class="col-md-3" id="sidebar"><button class="btn btn-sm btn-secondary my-2 options-menu d-md-none" type="button" data-bs-toggle="collapse" data-bs-target=".sidebar-nav" aria-controls="sidebar-nav" aria-expanded="false"><span class="icon-align-justify" aria-hidden="true"></span><div class="col-md-9" id="config"> if($this->fieldsets)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Espaces de nommage | Variables
Référence du fichier administrator/components/com_contact/tmpl/contacts/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
$assoc = Associations::isEnabled()
if ( $saveOrder &&!empty( $this->items))
else __pad0__
endif
$n = count($this->items)
$canEdit = $user->authorise('core.edit', 'com_contact.category.' . $item->catid)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', 'com_contact.category.' . $item->catid) && $item->created_by == $userId
$canChange = $user->authorise('core.edit.state', 'com_contact.category.' . $item->catid) && $canCheckin
$item | cat_link = Route::_('index.php?option=com_categories&extension=com_contact&task=edit&type=other&id=' . $item->catid)
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad1__
endforeach

Documentation des variables

◆ $assoc

$assoc = Associations::isEnabled()

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_contact.category.' . $item->catid) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_contact.category.' . $item->catid)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', 'com_contact.category.' . $item->catid) && $item->created_by == $userId

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $n

$n = count($this->items)

Référencé par Result\__serialize(), PlgContentPagebreak\_createNavigation(), Calculator\abs(), Access\actions(), ReflectionCaster\addAttributes(), AbstractString\after(), AbstractString\afterLast(), Registry\append(), ASN1\asn1map(), AbstractString\before(), AbstractString\beforeLast(), Icons\button(), ReflectionCaster\castClass(), FileStorage\clean(), AbstractUri\cleanPath(), ContentHelper\countRelations(), Engine\createRecurringModuloFunction(), ParagonIE_Sodium_Core_X25519\crypto_scalarmult_curve25519_ref10_base(), ParagonIE_Sodium_Core32_X25519\crypto_scalarmult_curve25519_ref10_base(), ASN1\decodeOID(), HtmlView\display(), Registry\exists(), BCMath\extendedGCD(), Engine\extendedGCDHelper(), Tar\extract(), Form\findGroup(), ListHelper\genericordering(), Registry\get(), SMTP\get_lines(), X509\getAttribute(), HtmlView\getFields(), FinderHelper\getGetFields(), FeaturedModel\getItems(), BigInteger\getLowestSetBit(), MenuParentField\getOptions(), GroupparentField\getOptions(), CategoryeditField\getOptions(), Xml\getXmlChildren(), SymmetricKey\ghash(), User\groups(), StringHelper\increment(), AbstractString\indexOf(), AbstractString\indexOfLast(), RSAKey\initPrivateKey(), RSAKey\initPublicKey(), Salsa20\leftRotate(), Links\link(), FormHelper\loadClass(), PHP32\modInverse(), PHP64\modInverse(), BCMath\modInverse(), PHP32\modPow(), PHP64\modPow(), GMP\modPow(), BCMath\modPow(), BigInteger\modPow(), MontgomeryMult\multiplyReduce(), Base\multiplyReduce(), Calculator\neg(), Adapter\onBuildIndex(), PlgContentPagebreak\onContentPrepare(), ModuleController\orderPosition(), SMTP\parseHelloFields(), SymmetricKey\pkcs12helper(), Text\plural(), SymmetricKey\poly1305(), PHP\powHelper(), BCMath\powmod(), PHP32\powMod(), PHP64\powMod(), GMP\powMod(), BCMath\powMod(), BigInteger\powMod(), BuiltIn\powModHelper(), DefaultEngine\powModHelper(), OpenSSL\powModHelper(), Base\powModHelper(), GMP\powModInner(), BCMath\powModInner(), PHP\powModInner(), Engine\powModOuter(), MysqliStatement\prepareParameterKeyMapping(), SqlsrvStatement\prepareParameterKeyMapping(), Montgomery\prepareReduce(), PowerOfTwo\prepareReduce(), Base\prepareReduce(), Usergroup\rebuild(), Classic\reduce(), EvalBarrett\reduce(), PowerOfTwo\reduce(), Montgomery\reduce(), Barrett\reduce(), Barrett\regularBarrett(), Registry\remove(), X509\removeAttribute(), DatabaseDriver\replacePrefix(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), Engine\rootHelper(), GMP\rootInner(), Engine\rootInner(), ParagonIE_Sodium_Core_ChaCha20\rotate(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor_ic(), ConfigController\save(), StyleController\save(), OverrideController\save(), StyleModel\save(), FormController\save(), PuTTY\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), OpenSSH\savePrivateKey(), XML\savePrivateKey(), Raw\savePrivateKey(), PSS\savePrivateKey(), MSBLOB\savePrivateKey(), OpenSSH\savePublicKey(), PuTTY\savePublicKey(), PKCS8\savePublicKey(), PKCS1\savePublicKey(), XML\savePublicKey(), Raw\savePublicKey(), PSS\savePublicKey(), MSBLOB\savePublicKey(), ParagonIE_Sodium_Core_Curve25519\sc25519_sqmul(), ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255(), ParagonIE_Sodium_Compat\scalarmult_ristretto255(), ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255_base(), ParagonIE_Sodium_Compat\scalarmult_ristretto255_base(), Inflector\seemsUtf8(), Registry\set(), X509\setAttribute(), DebugClassLoader\setReturnType(), UserHelper\setUserGroups(), Hash\sha3_32(), Hash\sha3_64(), Montgomery\slidingWindow(), Engine\slidingWindow(), SqlsrvQuery\splitSqlExpression(), BcMathCalculator\sqrt(), GmpCalculator\sqrt(), NativeCalculator\sqrt(), BCMath\sqrt(), Base\squareReduce(), BigInteger\testBit(), Engine\testPrimality(), Zh\tokenise(), Helper\tokenize(), Access\usergroup(), Access\usergroups(), LevelModel\validate(), BigDecimal\withPointMovedLeft(), et BigDecimal\withPointMovedRight().

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ cat_link

$item cat_link = Route::_('index.php?option=com_categories&extension=com_contact&task=edit&type=other&id=' . $item->catid)

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/articles/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
if(strpos($listOrder, 'publish_up') !==false) elseif(strpos($listOrder, 'publish_down') !==false) elseif(strpos($listOrder, 'modified') !==false) | else
if($saveOrder &&!empty($this->items)) | $workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')
$workflow_state = false
$workflow_featured = false
endif
$assoc = Associations::isEnabled()
else __pad0__
if ( $saveOrder)
foreach($this->items as $i=> $item) | $canEdit = $user->authorise('core.edit', 'com_content.article.' . $item->id)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', 'com_content.article.' . $item->id) && $item->created_by == $userId
$canChange = $user->authorise('core.edit.state', 'com_content.article.' . $item->id) && $canCheckin
$canEditCat = $user->authorise('core.edit', 'com_content.category.' . $item->catid)
$canEditOwnCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->catid) && $item->category_uid == $userId
$canEditParCat = $user->authorise('core.edit', 'com_content.category.' . $item->parent_category_id)
$canEditOwnParCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->parent_category_id) && $item->parent_category_uid == $userId
$transitions = ContentHelper::filterTransitions($this->transitions, (int) $item->stage_id, (int) $item->workflow_id)
$transition_ids = ArrayHelper::getColumn($transitions, 'value')
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
$options
else __pad1__
else __pad2__
$ParentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->parent_category_id . '&extension=com_content')
$CurrentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->catid . '&extension=com_content')
$EditCatTxt = Text::_('COM_CONTENT_EDIT_CATEGORY')
else __pad3__
$date = $item->{$orderingColumn}
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assoc

$assoc = Associations::isEnabled()

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_content.article.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

foreach ( $this->items as $i=> $item) $canEdit = $user->authorise('core.edit', 'com_content.article.' . $item->id)

◆ $canEditCat

$canEditCat = $user->authorise('core.edit', 'com_content.category.' . $item->catid)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', 'com_content.article.' . $item->id) && $item->created_by == $userId

◆ $canEditOwnCat

$canEditOwnCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->catid) && $item->category_uid == $userId

◆ $canEditOwnParCat

$canEditOwnParCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->parent_category_id) && $item->parent_category_uid == $userId

◆ $canEditParCat

$canEditParCat = $user->authorise('core.edit', 'com_content.category.' . $item->parent_category_id)

◆ $CurrentCatUrl

$CurrentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->catid . '&extension=com_content')

◆ $date

$date = $item->{$orderingColumn}
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Date\__construct(), LogEntry\__construct(), Log\add(), ActionlogModel\addLog(), GroupTable\check(), FieldTable\check(), HTMLHelper\date(), Joomla\Database\Query\dateAdd(), DatabaseQuery\dateAdd(), Joomla\Database\Query\day(), DatabaseQuery\day(), FeedView\display(), CategoryFeedView\display(), LinkModel\duplicateUrls(), Icon\edit(), ASN1\encode_der(), Query\explained(), CredentialRepository\formatDate(), AssociationHelper\getAssociations(), LocalAdapter\getDate(), Factory\getDate(), CalendarField\getInput(), Date\getInstance(), TagModel\getItem(), ArticlesArchiveHelper\getList(), ActionlogsModel\getListQuery(), HoursField\getPastTransition(), TemplateModel\getSafeName(), ArticlesCategoryHelper\groupByDate(), Joomla\Database\Query\hour(), DatabaseQuery\hour(), MinutesField\increment(), MonthField\increment(), DayOfMonthField\increment(), HoursField\increment(), DayOfWeekField\increment(), MinutesField\isSatisfiedBy(), MonthField\isSatisfiedBy(), HoursField\isSatisfiedBy(), DayOfWeekField\isSatisfiedBy(), DayOfMonthField\isSatisfiedBy(), InstallationApplication\loadDocument(), DelegatingPsrLogger\log(), Joomla\Database\Query\minute(), DatabaseQuery\minute(), Joomla\Database\Query\month(), DatabaseQuery\month(), PlgUserProfile\onUserAfterSave(), PlgUserProfile\onUserBeforeSave(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ContactModel\prepareTable(), Query\processDates(), Query\processString(), WorkflowModel\publish(), Date\relative(), X509\revoke(), PlgInstallerOverride\saveOverrides(), Joomla\Database\Query\second(), DatabaseQuery\second(), WorkflowModel\setDefault(), X509\setEndDate(), User\setLastVisit(), Document\setModifiedDate(), X509\setStartDate(), AbstractField\setTimeHour(), ConsentTable\store(), NoteTable\store(), RequestTable\store(), ContactTable\store(), FilterTable\store(), LinkTable\store(), NewsfeedTable\store(), TagTable\store(), WorkflowTable\store(), CoreContent\store(), Category\store(), Content\store(), X509\timeField(), TemplateModel\validateDate(), X509\validateDate(), Joomla\Database\Query\year(), et DatabaseQuery\year().

◆ $EditCatTxt

$EditCatTxt = Text::_('COM_CONTENT_EDIT_CATEGORY')

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $options

$options
Valeur initiale :
= [
'task_prefix' => 'articles.'

◆ $ParentCatUrl

$ParentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->parent_category_id . '&extension=com_content')

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $transition_ids

$transition_ids = ArrayHelper::getColumn($transitions, 'value')

◆ $transitions

$transitions = ContentHelper::filterTransitions($this->transitions, (int) $item->stage_id, (int) $item->workflow_id)

Référencé par WorkflowsModel\countItems(), ContentHelper\filterTransitions(), ContentComponent\filterTransitions(), ArticlesModel\getTransitions(), et WorkflowController\postSaveHook().

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ $workflow_enabled

if ( $saveOrder &&!empty( $this->items)) $workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')

◆ $workflow_featured

$workflow_featured = false

◆ $workflow_state

$workflow_state = false

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ else

if (Factory::getLanguage() ->isRtl()) else
Valeur initiale :
{
$orderingColumn = 'created'
$orderingColumn
$orderingColumn
Definition: administrator/components/com_workflow/tmpl/workflows/default.php:31

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($workflow_enabled) ( $saveOrder )
Valeur initiale :
=> Text::_($item->stage_title),
'tip_content' => Text::sprintf('JWORKFLOW', Text::_($item->workflow_title)),
'id' => 'workflow-' . $item->id,
'task' => 'articles.runTransition'
]
$item
else $item
Definition: administrator/components/com_menus/tmpl/items/modal.php:165


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/featured/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'fp.ordering'
if(strpos($listOrder, 'publish_up') !==false) elseif(strpos($listOrder, 'publish_down') !==false) elseif(strpos($listOrder, 'modified') !==false) | else
if($saveOrder &&!empty($this->items)) | $workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')
$workflow_state = false
$workflow_featured = false
endif
$assoc = Associations::isEnabled()
else __pad6__
if ( $saveOrder)
$count = count($this->items)
foreach($this->items as $i=> $item) | $ordering = ($listOrder == 'fp.ordering')
$assetId = 'com_content.article.' . $item->id
$canCreate = $user->authorise('core.create', 'com_content.category.' . $item->catid)
$canEdit = $user->authorise('core.edit', 'com_content.article.' . $item->id)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_content.article.' . $item->id) && $canCheckin
$canEditCat = $user->authorise('core.edit', 'com_content.category.' . $item->catid)
$canEditOwnCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->catid) && $item->category_uid == $userId
$canEditParCat = $user->authorise('core.edit', 'com_content.category.' . $item->parent_category_id)
$canEditOwnParCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->parent_category_id) && $item->parent_category_uid == $userId
$transitions = ContentHelper::filterTransitions($this->transitions, (int) $item->stage_id, (int) $item->workflow_id)
$transition_ids = ArrayHelper::getColumn($transitions, 'value')
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
$options
else __pad7__
else __pad8__
$ParentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->parent_category_id . '&extension=com_content')
$CurrentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->catid . '&extension=com_content')
$EditCatTxt = Text::_('COM_CONTENT_EDIT_CATEGORY')
else __pad9__
$date = $item->{$orderingColumn}
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assetId

$assetId = 'com_content.article.' . $item->id

Référencé par Module\_getAssetParentId(), Category\_getAssetParentId(), Content\_getAssetParentId(), TransitionTable\_getAssetParentId(), Language\_getAssetParentId(), GroupTable\_getAssetParentId(), StageTable\_getAssetParentId(), FieldTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), MenuType\_getAssetParentId(), Access\getAssetAncestors(), FieldTable\getAssetId(), et Access\getAssetRules().

◆ $assoc

$assoc = Associations::isEnabled()

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_content.article.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_content.category.' . $item->catid)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_content.article.' . $item->id)

◆ $canEditCat

$canEditCat = $user->authorise('core.edit', 'com_content.category.' . $item->catid)

◆ $canEditOwnCat

$canEditOwnCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->catid) && $item->category_uid == $userId

◆ $canEditOwnParCat

$canEditOwnParCat = $user->authorise('core.edit.own', 'com_content.category.' . $item->parent_category_id) && $item->parent_category_uid == $userId

◆ $canEditParCat

$canEditParCat = $user->authorise('core.edit', 'com_content.category.' . $item->parent_category_id)

◆ $count

$count = count($this->items)

Référencé par FilesystemHandler\__construct(), PlgContentJoomla\_canDeleteCategories(), PlgContentJoomla\_countItemsInCategory(), PlgContentJoomla\_countItemsInChildren(), Stream\_stream_read(), Access\actions(), Access\assetgrouplist(), ItemModel\batchCopy(), CategoryModel\batchCopy(), DatabaseQuery\bind(), XmlReaderCaster\castXmlReader(), AdminModel\checkin(), AssociationsModel\clean(), InputFilter\cleanAttributes(), InputFilter\cleanTags(), Parser\cleanup(), BannerModel\click(), LanguageFilesCollector\collect(), Collection\count(), ListenersPriorityQueue\count(), Assertion\count(), Assert\countBetween(), Subject\countUse(), Subject\countUsedIn(), PasswordHash\crypt_private(), UpdatesitesModel\delete(), DiscoverModel\discover(), ExtensionDiscoverCommand\doExecute(), Application\doRenderThrowable(), PasswordHash\encode64(), Caster\filter(), Users\filterNotes(), FlattenException\flattenArgs(), ParagonIE_Sodium_Core32_Curve25519_Fe\fromArray(), PasswordHash\get_random_bytes(), LanguageErrorsCollector\getCount(), DatabaseDriver\getCount(), FormField\getFieldName(), CheckinModel\getItems(), AbstractMenu\getItems(), SSH2\getLastError(), ArticlesCategoriesHelper\getList(), BreadcrumbsHelper\getList(), PSSRSA\getMGF1(), RSA\getMGF1(), JNamespacePsr4Map\getNamespaces(), ExtensionDiscoverCommand\getNote(), ExtensionDiscoverInstallCommand\getNote(), CategoryNode\getNumItems(), TagField\getOptions(), En_GBLocalise\getPluralSuffixes(), Fr_FRLocalise\getPluralSuffixes(), Language\getPluralSuffixes(), ColorField\getSimpleModeLayoutData(), SignalRegistry\handle(), Table\hasPrimaryKey(), Indexer\index(), LdapUserProvider\loadUserByIdentifier(), Assertion\maxCount(), Menu\menuItemList(), RSA\mgf1(), Assertion\minCount(), OutputStyle\newLine(), SymfonyStyle\newLine(), Users\notes(), Users\notesModal(), Router\parse(), SFTP\parseAttributes(), SysinfoModel\parsePhpInfo(), Core\pbkdf2(), SymmetricKey\pkcs12helper(), Text\plural(), Text\printf(), ExtensionDiscoverInstallCommand\processDiscover(), DatabaseDriver\quoteName(), SFTP\readlink(), SFTP\readlist(), UpdatesitesModel\rebuild(), ASCII\remove_invisible_characters(), Taxonomy\removeOrphanMaps(), RssRenderer\render(), AtomRenderer\render(), Table\renderRowSeparator(), JavascriptRenderer\replaceTagInBuffer(), LanguageAdapter\resetUserLanguage(), Nested\saveorder(), LdapClient\search(), PKCS8\setIterationCount(), SymmetricKey\setPassword(), X509\setRecurLimit(), ArrayHelper\sortObjects(), Text\sprintf(), StringHelper\str_ireplace(), Buffer\stream_read(), BufferStreamHandler\stream_read(), StringWrapper\stream_read(), StreamString\stream_read(), PharStreamWrapper\stream_read(), X509\testForIntermediate(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), Access\usergroups(), utf8_ireplace(), et X509\validateSignatureCountable().

◆ $CurrentCatUrl

$CurrentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->catid . '&extension=com_content')

◆ $date

$date = $item->{$orderingColumn}

◆ $EditCatTxt

$EditCatTxt = Text::_('COM_CONTENT_EDIT_CATEGORY')

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $options

$options
Valeur initiale :
= [
'task_prefix' => 'articles.'

◆ $ordering

foreach ( $this->items as $i=> $item) $ordering = ($listOrder == 'fp.ordering')

Référencé par PluginsModel\_getList(), ArticlesModel\getFilterForm(), PositionsModel\getItems(), LanguagesModel\getLanguages(), TagsSimilarHelper\getList(), ArticlesCategoryHelper\getList(), RequestsModel\getListQuery(), ConsentsModel\getListQuery(), BannersModel\getListQuery(), SearchModel\getListQuery(), NewsfeedsModel\getListQuery(), IndexModel\getListQuery(), ArticlesModel\getListQuery(), OrderingField\getQuery(), Menu\ordering(), SearchesModel\populateState(), PositionsModel\populateState(), ClientsModel\populateState(), GroupsModel\populateState(), StylesModel\populateState(), StagesModel\populateState(), LevelsModel\populateState(), CheckinModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), MessagesModel\populateState(), WorkflowsModel\populateState(), PluginsModel\populateState(), ActionlogsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), TracksModel\populateState(), ManageModel\populateState(), FeaturedModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), NewsfeedsModel\populateState(), CacheModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), InstalledModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ArticlesModel\populateState(), FiltersModel\populateState(), RequestsModel\populateState(), ConsentsModel\populateState(), OverridesModel\populateState(), TemplatesModel\populateState(), MenusModel\populateState(), NotesModel\populateState(), LanguagesModel\populateState(), DatabaseModel\populateState(), BannersModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), IndexModel\populateState(), TasksModel\populateState(), UpdatesitesModel\populateState(), et ListModel\populateState().

◆ $ParentCatUrl

$ParentCatUrl = Route::_('index.php?option=com_categories&task=category.edit&id=' . $item->parent_category_id . '&extension=com_content')

◆ $saveOrder

$saveOrder = $listOrder == 'fp.ordering'

◆ $transition_ids

$transition_ids = ArrayHelper::getColumn($transitions, 'value')

◆ $transitions

$transitions = ContentHelper::filterTransitions($this->transitions, (int) $item->stage_id, (int) $item->workflow_id)

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ $workflow_enabled

if ( $saveOrder &&!empty( $this->items)) $workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')

◆ $workflow_featured

$workflow_featured = false

◆ $workflow_state

$workflow_state = false

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ __pad9__

else __pad9__

◆ else

if (Factory::getLanguage() ->isRtl()) else
Valeur initiale :
{
$orderingColumn = 'created'
$orderingColumn
$orderingColumn
Definition: administrator/components/com_workflow/tmpl/workflows/default.php:31

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($workflow_enabled) ( $saveOrder )
Valeur initiale :
=> Text::_($item->stage_title),
'tip_content' => Text::sprintf('JWORKFLOW', Text::_($item->workflow_title)),
'id' => 'workflow-' . $item->id,
'task' => 'articles.runTransitions'
]
$item
else $item
Definition: administrator/components/com_menus/tmpl/items/modal.php:165


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • tmpl
  • cpanel
Espaces de nommage | Variables
Référence du fichier administrator/components/com_cpanel/tmpl/cpanel/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
if( $this->quickicons)($this->quickicons as $iconmodule) endif

Documentation des variables

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • fields
Espaces de nommage | Variables
Référence du fichier administrator/components/com_fields/tmpl/fields/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = Factory::getUser()
$userId = $user->get('id')
$context = $this->escape($this->state->get('filter.context'))
$component = $this->state->get('filter.component')
$section = $this->state->get('filter.section')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$ordering = ($listOrder == 'a.ordering')
$saveOrder = ($listOrder == 'a.ordering' && strtolower($listDirn) == 'asc')
$category = Categories::getInstance(str_replace('com_', '', $component) . '.' . $section)
if(! $category) if($saveOrder &&!empty($this->items)) $searchToolsOptions = []
if (count( $this->filterForm->getField( 'context') ->options) > 1)
else __pad0__
endif
$canEdit = $user->authorise('core.edit', $component . '.field.' . $item->id)
$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', $component . '.field.' . $item->id) && $item->created_user_id == $userId
$canChange = $user->authorise('core.edit.state', $component . '.field.' . $item->id) && $canCheckin
$iconClass = ''
else __pad1__
else __pad2__

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $canChange

$canChange = $user->authorise('core.edit.state', $component . '.field.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', $component . '.field.' . $item->id)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', $component . '.field.' . $item->id) && $item->created_user_id == $userId

◆ $category

$category = Categories::getInstance(str_replace('com_', '', $component) . '.' . $section)

Référencé par Router\__construct(), LogEntry\__construct(), CategoryNode\__construct(), HtmlView\_prepareDocument(), Log\add(), PlgSampledataMultilang\addCategory(), PlgSystemDebug\collectLogs(), CategoryView\commonCategoryDisplay(), JHtmlIcon\create(), Icon\create(), CategoryFactory\createCategory(), CategoryFeedView\display(), HtmlView\display(), Log\findLoggers(), User\getAuthorisedCategories(), Router\getCategoryId(), RouteHelper\getCategoryRoute(), Router\getCategorySegment(), Workflow\getDefaultStageByCategory(), CategoryModel\getItems(), ArticlesCategoriesHelper\getList(), ArticlesCategoryHelper\getList(), RouteHelper\getRoute(), PopularHelper\getTitle(), LatestHelper\getTitle(), RssParser\handleCategory(), PlgFinderNewsfeeds\index(), PlgFinderContacts\index(), PlgFinderContent\index(), DelegatingPsrLogger\log(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), ContentHelper\onPrepareForm(), HtmlView\prepareDocument(), RssParser\processFeedEntry(), et Adapter\translateState().

◆ $component

$component = $this->state->get('filter.component')

◆ $context

$context = $this->escape($this->state->get('filter.context'))

Référencé par FormController\__construct(), LogEntry\__construct(), Stream\__construct(), BufferingLogger\__destruct(), ItemController\add(), FormController\add(), Log\add(), PlgSampledataMultilang\addAssociations(), ActionlogModel\addLog(), AbstractLogger\alert(), FieldModel\batchMove(), ItemController\cancel(), OverrideController\cancel(), FormController\cancel(), TransitionModel\canEditState(), StageModel\canEditState(), Dispatcher\checkAccess(), BaseController\checkEditId(), PlgContentJoomla\checkMenuItemBeforeSave(), AssociationsModel\clean(), GroupModel\cleanCache(), FieldModel\cleanCache(), FieldModel\cleanupValues(), AbstractCloner\cloneVar(), Stream\copy(), PrivacyPlugin\createCustomFieldsDomain(), AbstractLogger\critical(), ParagonIE_Sodium_Compat\crypto_kdf_derive_from_key(), AbstractLogger\debug(), MapsModel\delete(), IndexModel\delete(), StyleModel\delete(), ModuleModel\delete(), AdminModel\delete(), Stream\delete(), HtmlDescriptor\describe(), CliDescriptor\describe(), TraceableTwigEnvironment\display(), HtmlView\display(), PlgSystemFields\display(), PlgContentVote\displayVotingData(), Parser\doParse(), ContextualizedDumper\dump(), StyleModel\duplicate(), OverrideController\edit(), TemplateController\edit(), FormController\edit(), AbstractLogger\emergency(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), AbstractLogger\error(), ServerDumpCommand\execute(), HtmlDescriptor\extractDate(), ArticleModel\featured(), HtmlErrorRenderer\formatLogMessage(), Joomla\getActionLogParams(), Associations\getAssociations(), AssociationsHelper\getAssociations(), QuickIconHelper\getButtons(), ContentComponent\getCategoryWorkflowContext(), QuickIconsEvent\getContext(), SourceContextProvider\getContext(), OAuthCallbackEvent\getContext(), Joomlaupdate\getCoreUpdateNotification(), FieldsHelper\getFields(), GroupModel\getForm(), TransitionModel\getForm(), FieldModel\getForm(), ItemtypeField\getGroups(), FieldsModel\getGroups(), GroupsModel\getListQuery(), FieldsModel\getListQuery(), ActionlogConfigModel\getLogContentTypeParams(), ActionlogsHelper\getLogContentTypeParams(), FormController\getModel(), Joomla\CMS\Workflow\getModelName(), ContentComponent\getModelName(), FieldgroupsField\getOptions(), ExtensionField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), SubfieldsField\getOptions(), Factory\getStream(), AssociationsHelper\getSupportedExtension(), TransitionModel\getWorkflow(), ErrorHandler\handleError(), BaseController\holdEditId(), Indexer\index(), AbstractLogger\info(), Shortcut\initialize(), ConsoleLogger\interpolate(), MessagesCollector\interpolate(), PlgWorkflowNotification\isSupported(), PlgWorkflowFeaturing\isSupported(), PlgWorkflowPublishing\isSupported(), Joomla\CMS\Workflow\isWorkflowActive(), DumpServer\listen(), GroupModel\loadFormData(), BufferingLogger\log(), ConsoleLogger\log(), DelegatingPsrLogger\log(), MessagesCollector\log(), TraceableTwigEnvironment\mergeGlobals(), Stream\move(), AbstractLogger\notice(), Joomla\onAfterCheckin(), Joomla\onAfterDispatch(), Joomla\onAfterLogExport(), Joomla\onAfterLogPurge(), Joomla\onAfterPurge(), Adapter\onBeforeIndex(), Adapter\onBuildIndex(), PlgContentFinder\onContentAfterDelete(), Joomla\onContentAfterDelete(), PlgContentVote\onContentAfterDisplay(), PlgSystemFields\onContentAfterDisplay(), PlgContentFinder\onContentAfterSave(), PlgContentJoomla\onContentAfterSave(), Joomla\onContentAfterSave(), PlgSystemFields\onContentAfterTitle(), PlgContentJoomla\onContentBeforeChangeState(), PlgWorkflowPublishing\onContentBeforeChangeState(), PlgContentJoomla\onContentBeforeDelete(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgContentVote\onContentBeforeDisplay(), PlgSystemFields\onContentBeforeDisplay(), PlgMediaActionResize\onContentBeforeSave(), PlgContentFinder\onContentBeforeSave(), PlgFieldsSql\onContentBeforeSave(), PlgContentJoomla\onContentBeforeSave(), PlgContentFinder\onContentChangeState(), Joomla\onContentChangeState(), PlgContentJoomla\onContentChangeState(), PlgSystemFields\onContentNormaliseRequestData(), PlgContentFields\onContentPrepare(), PlgContentEmailcloak\onContentPrepare(), PlgContentLoadmodule\onContentPrepare(), PlgContentContact\onContentPrepare(), PlgContentPagebreak\onContentPrepare(), PlgSystemFields\onContentPrepare(), PlgUserProfile\onContentPrepareData(), PlgUserToken\onContentPrepareData(), PlgSystemActionLogs\onContentPrepareData(), PlgWorkflowNotification\onContentPrepareForm(), PlgWorkflowPublishing\onContentPrepareForm(), PlgWorkflowFeaturing\onContentPrepareForm(), PlgSystemFields\onContentPrepareForm(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), PlgWorkflowPublishing\onContentVersioningPrepareTable(), PlgFieldsList\onCustomFieldsPrepareField(), PlgFieldsSubform\onCustomFieldsPrepareField(), PlgButtonFields\onDisplay(), Joomla\onExtensionAfterDelete(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterSave(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), PlgFinderTags\onFinderAfterDelete(), PlgFinderNewsfeeds\onFinderAfterDelete(), PlgFinderContacts\onFinderAfterDelete(), PlgFinderContent\onFinderAfterDelete(), PlgFinderTags\onFinderAfterSave(), PlgFinderCategories\onFinderAfterSave(), PlgFinderContacts\onFinderAfterSave(), PlgFinderNewsfeeds\onFinderAfterSave(), PlgFinderContent\onFinderAfterSave(), PlgFinderTags\onFinderBeforeSave(), PlgFinderCategories\onFinderBeforeSave(), PlgFinderNewsfeeds\onFinderBeforeSave(), PlgFinderContacts\onFinderBeforeSave(), PlgFinderContent\onFinderBeforeSave(), PlgFinderTags\onFinderChangeState(), PlgFinderCategories\onFinderChangeState(), PlgFinderNewsfeeds\onFinderChangeState(), PlgFinderContacts\onFinderChangeState(), PlgFinderContent\onFinderChangeState(), PlgFinderCategories\onFinderDelete(), PlgQuickiconPrivacyCheck\onGetIcons(), PlgQuickiconDownloadkey\onGetIcons(), PlgQuickiconExtensionupdate\onGetIcons(), PlgQuickiconOverrideCheck\onGetIcons(), Joomla\onJoomlaAfterUpdate(), Adapter\onStartIndex(), Joomla\onUserAfterDelete(), Joomla\onUserAfterDeleteGroup(), Joomla\onUserAfterLogin(), Joomla\onUserAfterRemind(), Joomla\onUserAfterSave(), Joomla\onUserAfterSaveGroup(), Joomla\onUserLoginFailure(), Joomla\onUserLogout(), PlgWorkflowNotification\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowBeforeTransition(), PlgWorkflowPublishing\onWorkflowBeforeTransition(), Stream\open(), Parser\parseValue(), WorkflowModel\populateState(), StageModel\populateState(), TransitionModel\populateState(), GroupsModel\populateState(), FieldsModel\populateState(), GroupModel\populateState(), FieldModel\populateState(), Content\prepare(), PlgContentFields\prepare(), Joomla\CMS\MVC\Model\preprocessData(), FormModel\preprocessData(), ManageModel\publish(), MapsModel\publish(), IndexModel\publish(), AdminModel\publish(), AssociationsModel\purge(), BaseController\releaseEditId(), TraceableTwigEnvironment\render(), FieldsHelper\render(), Stream\request(), StreamTransport\request(), StyleController\save(), OverrideController\save(), WorkflowModel\save(), StageModel\save(), TransitionModel\save(), ComponentModel\save(), LanguageModel\save(), TemplateModel\save(), CategoryModel\save(), FormController\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), ActionlogModel\sendNotificationEmails(), QuickIconsEvent\setContext(), OAuthCallbackEvent\setContext(), Stream\setContextOptions(), Versioning\store(), Post\submit(), Joomla\CMS\Workflow\supportFunctionality(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), Stream\upload(), DisplayController\validateEntry(), AbstractLogger\warning(), et Connection\write().

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $ordering

$ordering = ($listOrder == 'a.ordering')

◆ $saveOrder

$saveOrder = ($listOrder == 'a.ordering' && strtolower($listDirn) == 'asc')

◆ $searchToolsOptions

if (! $category) if ( $saveOrder &&!empty( $this->items)) $searchToolsOptions = []

◆ $section

$section = $this->state->get('filter.section')

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ endif

endif

◆ if

if($saveOrder) | ( | count($this->filterForm->getField('context') ->options) | ,
 |  | 1 |
 | ) |  |


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • groups
Espaces de nommage | Variables
Référence du fichier administrator/components/com_fields/tmpl/groups/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = Factory::getUser()
$userId = $user->get('id')
$component = ''
$parts = FieldsHelper::extract($this->state->get('filter.context'))
if($parts) | $listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$ordering = ($listOrder == 'a.ordering')
$saveOrder = ($listOrder == 'a.ordering' && strtolower($listDirn) == 'asc')
if($saveOrder &&!empty($this->items)) | $context = $this->escape($this->state->get('filter.context'))
$searchToolsOptions = []
if (count( $this->filterForm->getField( 'context') ->options) > 1)
else __pad4__
endif
$canEdit = $user->authorise('core.edit', $component . '.fieldgroup.' . $item->id)
$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', $component . '.fieldgroup.' . $item->id) && $item->created_by == $userId
$canChange = $user->authorise('core.edit.state', $component . '.fieldgroup.' . $item->id) && $canCheckin
$iconClass = ''
else __pad5__
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $canChange

$canChange = $user->authorise('core.edit.state', $component . '.fieldgroup.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', $component . '.fieldgroup.' . $item->id)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', $component . '.fieldgroup.' . $item->id) && $item->created_by == $userId

◆ $component

$component = ''

◆ $context

if ( $saveOrder &&!empty( $this->items)) $context = $this->escape($this->state->get('filter.context'))

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

if ( $parts) $listOrder = $this->escape($this->state->get('list.ordering'))

◆ $ordering

$ordering = ($listOrder == 'a.ordering')

◆ $parts

$parts = FieldsHelper::extract($this->state->get('filter.context'))

◆ $saveOrder

$saveOrder = ($listOrder == 'a.ordering' && strtolower($listDirn) == 'asc')

◆ $searchToolsOptions

$searchToolsOptions = []

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) | ( | count($this->filterForm->getField('context') ->options) | ,
 |  | 1 |
 | ) |  |


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • filters
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/filters/default.php

Espaces de nommage

Joomla\Administrator

Variables

$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$wa = $this->document->getWebAssetManager()
else __pad0__
$canCreate = $user->authorise('core.create', 'com_finder')
$canEdit = $user->authorise('core.edit', 'com_finder')
$userAuthoriseCoreManage = $user->authorise('core.manage', 'com_checkin')
$userAuthoriseCoreEditState = $user->authorise('core.edit.state', 'com_finder')
$canChange = $userAuthoriseCoreEditState && $canCheckIn
$escapedTitle = $this->escape($item->title)
endif
else __pad1__
endforeach

Documentation des variables

◆ $canChange

$canChange = $userAuthoriseCoreEditState && $canCheckIn

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_finder')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_finder')

◆ $escapedTitle

$escapedTitle = $this->escape($item->title)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $userAuthoriseCoreEditState

$userAuthoriseCoreEditState = $user->authorise('core.edit.state', 'com_finder')

◆ $userAuthoriseCoreManage

$userAuthoriseCoreManage = $user->authorise('core.manage', 'com_checkin')

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • index
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/index/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$lang = Factory::getLanguage()
$wa = $this->document->getWebAssetManager()
endif
else __pad2__
$canChange = Factory::getUser()->authorise('core.manage', 'com_finder')
foreach ( $this->items as $i=> $item)
$key = LanguageHelper::branchSingular($item->t_title)
$publishStartDate = $item->publish_start_date !== null ? HTMLHelper::_('date', $item->publish_start_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''
$publishEndDate = $item->publish_end_date !== null ? HTMLHelper::_('date', $item->publish_end_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''
$startDate = $item->start_date !== null ? HTMLHelper::_('date', $item->start_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''
$endDate = $item->end_date !== null ? HTMLHelper::_('date', $item->end_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''
endforeach

Documentation des variables

◆ $canChange

$canChange = Factory::getUser()->authorise('core.manage', 'com_finder')

◆ $endDate

$endDate = $item->end_date !== null ? HTMLHelper::_('date', $item->end_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''

Référencé par TPMAttestationStatementSupport\checkCertificate().

◆ $key

$key = LanguageHelper::branchSingular($item->t_title)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\_(), Language\_(), DataSet\__call(), OutputFormatter\__clone(), DsPairStub\__construct(), ParagonIE_Sodium_Core_ChaCha20_IetfCtx\__construct(), ParagonIE_Sodium_Core32_ChaCha20_IetfCtx\__construct(), MapItem\__construct(), ParagonIE_Sodium_Core_ChaCha20_Ctx\__construct(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\__construct(), Entry\__construct(), JWKSet\__construct(), ConfigPostProcessor\__construct(), ParagonIE_Sodium_Core_Poly1305_State\__construct(), ParagonIE_Sodium_Core32_Poly1305_State\__construct(), Aes\__construct(), ComponentRecord\__construct(), InstallerAdapter\__construct(), Table\__construct(), MenuItem\__construct(), BufferingLogger\__destruct(), DataSet\__get(), ConfigPostProcessor\__invoke(), SqliteQuery\__toString(), Pagination\_buildDataObject(), Update\_endElement(), InstallerModel\_getList(), Nested\_getNode(), CollectionAdapter\_startElement(), Update\_startElement(), MapObject\add(), PlgSampledataMultilang\addAssociations(), Mail\addAttachment(), Tobscure\JsonApi\addLink(), JsonapiDocument\addLink(), Tobscure\JsonApi\addMeta(), JsonapiDocument\addMeta(), MessagesModel\addPostInstallationMessage(), Document\addScriptOptions(), TagsHelper\addTagMapping(), Joomla\CMS\MVC\Model\addTransitionField(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Crypto32\aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Crypto\aead_xchacha20poly1305_ietf_encrypt(), RuntimeTests\AESTestVector(), Crypto\AESTestVector(), Container\alias(), UserController\allowEdit(), TagController\allowEdit(), ContactController\allowEdit(), LevelController\allowEdit(), NewsfeedController\allowEdit(), ItemController\allowEdit(), BannerController\allowEdit(), CategoryController\allowEdit(), FieldController\allowEdit(), TaskController\allowEdit(), WorkflowController\allowEdit(), GroupController\allowEdit(), StageController\allowEdit(), TransitionController\allowEdit(), ArticleController\allowEdit(), ModuleController\allowEdit(), MessageController\allowSave(), GroupController\allowSave(), LevelController\allowSave(), ModuleController\allowSave(), FormController\allowSave(), InfiniteMapObject\append(), ArrayHelper\arraySearch(), ASN1\asn1map(), ParagonIE_Sodium_Crypto\auth(), ParagonIE_Sodium_Crypto32\auth(), ParagonIE_Sodium_Crypto\auth_verify(), ParagonIE_Sodium_Crypto32\auth_verify(), Client\baseString(), DatabaseQuery\bind(), MysqliStatement\bindValues(), Router\build(), Container\buildObject(), BaseAccept\buildParametersString(), DatabaseExporter\buildXmlData(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), PgsqlExporter\buildXmlStructure(), AssociationController\cancel(), TaskController\cancel(), CategoryController\cancel(), FormController\cancel(), ContactController\cancel(), JWKSet\canKeyBeUsedFor(), JWKSet\canKeyBeUsedWithAlgorithm(), RdKafkaCaster\castConf(), SplCaster\castFileInfo(), SplCaster\castFileObject(), SymfonyCaster\castRequest(), RdKafkaCaster\castTopicConf(), CoreContent\check(), Content\check(), CertificateToolbox\checkAttestationMedata(), Hmac\checKey(), Table\checkIn(), None\checkKey(), RSAPSS\checkKey(), RSA\checkKey(), RSAPKCS1\checkKey(), ECDSA\checkKey(), EdDSA\checkKey(), KeyChecker\checkKeyAlgorithm(), KeyChecker\checkKeyUsage(), KeyChecker\checkOperation(), Table\checkOut(), TPMAttestationStatementSupport\checkUniquePublicKey(), KeyChecker\checkUsage(), WincacheStorage\clean(), ApcuStorage\clean(), InputFilter\clean(), RedisStorage\clean(), MemcachedStorage\clean(), AssociationsModel\clean(), SessionCollector\collect(), RequestDataCollector\collect(), X509\computeKeyIdentifier(), GetConfigurationCommand\configure(), PdoDriver\connect(), MysqlDriver\connect(), SocketTransport\connect(), Socket\connect(), AbstractField\convertLiterals(), SymfonyStyle\createBlock(), ECKey\createECKeyUsingOpenSSL(), AttestationStatement\createFromArray(), PublicKeyCredentialSource\createFromArray(), MetadataStatement\createFromArray(), KeyOrPassword\createFromKey(), JWKSet\createFromKeyData(), OpenSSL\createHash(), Hmac\createHash(), Ecdsa\createHash(), Client\createHeader(), PrivacyPlugin\createItemFromArray(), DH\createKey(), TagsHelper\createTagsFromField(), MailTemplate\createTemplate(), Router\createUri(), Client\createUrl(), ParagonIE_Sodium_Compat\crypto_aead_aes256gcm_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_chacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_decrypt(), ParagonIE_Sodium_Compat\crypto_aead_xchacha20poly1305_ietf_encrypt(), ParagonIE_Sodium_Compat\crypto_auth(), ParagonIE_Sodium_Compat\crypto_auth_verify(), ParagonIE_Sodium_Compat\crypto_generichash(), ParagonIE_Sodium_Compat\crypto_generichash_init(), ParagonIE_Sodium_Compat\crypto_generichash_init_salt_personal(), ParagonIE_Sodium_Compat\crypto_kdf_derive_from_key(), ParagonIE_Sodium_Compat\crypto_secretbox(), ParagonIE_Sodium_Compat\crypto_secretbox_open(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305(), ParagonIE_Sodium_Compat\crypto_secretbox_xchacha20poly1305_open(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Compat\crypto_shorthash(), ParagonIE_Sodium_Compat\crypto_stream(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20(), ParagonIE_Sodium_Compat\crypto_stream_xchacha20_xor(), ParagonIE_Sodium_Compat\crypto_stream_xor(), Language\debugFile(), InstallationApplication\debugLanguage(), CryptoCipher\decrypt(), SodiumCipher\decrypt(), Sodium\decrypt(), Crypto\decrypt(), Mcrypt\decrypt(), OpenSSL\decrypt(), Crypto\Decrypt(), CredentialRepository\decryptCredential(), File\decryptFile(), File\decryptResource(), Aes\decryptString(), Registry\def(), SSH2\define_array(), User\defParam(), OverridesModel\delete(), User\delete(), MailTemplate\deleteTemplate(), WebClient\detectBrowser(), DiscoverModel\discover(), HtmlView\display(), PlgSystemFields\display(), JsonapiView\displayList(), PHPMailer\DKIM_HeaderC(), JWKSet\doesKeySatisfyRestrictions(), TasksRunCommand\doExecute(), WebApplication\doExecute(), GetConfigurationCommand\doExecute(), Parser\doParse(), Hmac\doVerify(), Ecdsa\doVerify(), Dumper\dump(), Inline\dump(), DataSet\dump(), Inline\dumpArray(), CliDumper\dumpKey(), ArticleController\edit(), FormController\edit(), ASN1\encode_der(), Crypto\encrypt(), CryptoCipher\encrypt(), SodiumCipher\encrypt(), Mcrypt\encrypt(), OpenSSL\encrypt(), Sodium\encrypt(), Crypto\Encrypt(), CredentialRepository\encryptCredential(), File\encryptFile(), File\encryptResource(), Aes\encryptString(), Changelog\endElement(), MysqliStatement\execute(), SqlsrvStatement\execute(), PdoDriver\execute(), DatabaseDriver\execute(), Container\exists(), Query\explained(), PSSRSA\exponentiate(), RSAKey\exponentiate(), Container\extend(), X509\extensions(), HTMLHelper\extract(), PKCS8\extractEncryptionAlgorithm(), RedisStorage\filter(), FileStorage\filter(), MemcachedStorage\filter(), SubformField\filter(), Form\filter(), FormField\filter(), ExtensionsListCommand\filterExtensionsBasedOn(), ExtensionDiscoverListCommand\filterExtensionsBasedOnState(), Uri\filterQuery(), OpenHandler\find(), PdoStorage\find(), CollectedClientData\findData(), JWSBuilder\findSignatureAlgorithm(), ArrayHelper\flatten(), FlattenException\flattenArgs(), HtmlErrorRenderer\formatArgs(), QuestionHelper\formatChoiceQuestionChoices(), GetConfigurationCommand\formatConfig(), TextDescriptor\formatDefaultValue(), HtmlErrorRenderer\formatLogMessage(), OptionsResolver\formatValues(), Configuration\forSymmetricSigner(), Configuration\forUnsecuredSigner(), SplFixedArray\fromArray(), WincacheStorage\gc(), ApcuStorage\gc(), AuthenticationExtensionsClientInputs\get(), AuthenticationExtensionsClientOutputs\get(), JWK\get(), Container\get(), Key\get(), AttestationStatement\get(), CollectedClientData\get(), AbstractApplication\get(), BaseLayout\get(), Pagination\getAdditionalUrlParam(), ApcuStorage\getAll(), WincacheStorage\getAll(), MemcachedStorage\getAll(), RedisStorage\getAll(), AssociationExtensionHelper\getAssociationList(), WebAssetItem\getAttribute(), X509\getAttribute(), DatabaseQuery\getBounded(), QuickIconHelper\getButtons(), Cache\getCacheKey(), Router\getCategories(), X509\getChain(), UpdateModel\getCollectionDetailsUrls(), SysinfoModel\getConfig(), CacheModel\getData(), InstalledModel\getData(), RegistrationModel\getData(), Factory\getDate(), ChoiceQuestion\getDefaultValidator(), TemplateModel\getDirectoryTree(), Symfony\Component\VarDumper\Test\getDump(), DatabaseModel\getErrorsMessage(), Aes\getExpandedKey(), X509\getExtensionHelper(), ExtensionHelper\getExtensionRecord(), ExtensionsListCommand\getExtensionsNameAndId(), FieldsHelper\getFields(), Table\getFields(), FieldModel\getFieldValues(), Zip\getFileData(), ApiModel\getFiles(), MenuField\getGroups(), MenuItemByTypeField\getGroups(), CredentialRepository\getHandleFromUserId(), Signature\getHeaderParameter(), HttpFactory\getHttpTransports(), ActionlogsHelper\getHumanReadableLogMessage(), Table\getId(), Query\getIncludedTermIds(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), Parameters\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), SiteMenu\getItems(), ArticlesModel\getItems(), MetadataStatementFetcher\getJwsPayload(), HS256\getKey(), HS384\getKey(), HS512\getKey(), MapItem\getKey(), HMAC\getKey(), BaseSigner\getKey(), DatabaseImporter\getKeyLookup(), MysqlImporter\getKeyLookup(), MysqliImporter\getKeyLookup(), LanguagesModel\getLanguages(), TagsPopularHelper\getList(), BannersModel\getListQuery(), AssociationsModel\getListQuery(), ArticlesModel\getListQuery(), LoggerRegistry\getLoggerClass(), CallbackStream\getMetadata(), RelativeStream\getMetadata(), Stream\getMetadata(), Container\getNewInstance(), AbstractTransport\getOption(), Http\getOption(), WebAssetItem\getOption(), PdoDriver\getOption(), Client\getOption(), FontsField\getOptions(), ContenttypesField\getOptions(), RedirectField\getOptions(), SqlField\getOptions(), AbstractNegotiator\getOrderedElements(), Parameters\getPage(), MethodModel\getPageTitle(), User\getParam(), BaseAccept\getParameter(), DSA\getParameters(), EC\getParameters(), DH\getParameters(), RouterView\getPath(), Table\getPrimaryKey(), ListenersPriorityQueue\getPriority(), Keychain\getPrivateKey(), CMSObject\getProperties(), Signature\getProtectedHeaderParameter(), PrivateKey\getPublicKey(), X509\getPublicKey(), LanguageController\getRedirectToItemAppend(), NoteController\getRedirectToItemAppend(), Query\getRequiredTermIds(), Container\getResource(), Document\getScriptOptions(), SSH2\getServerPublicHostKey(), Registry\getService(), Propel2Collector\getStatements(), AbstractCommand\getSynopsis(), Command\getSynopsis(), TableCellStyle\getTagOptions(), MailTemplate\getTemplate(), HelpModel\getToc(), Query\getTokenData(), ArticlesModel\getTransitions(), CMSApplication\getUserState(), ListModel\getUserStateFromRequest(), CMSApplication\getUserStateFromRequest(), ArraySerializer\getValueFromKey(), Router\getVar(), SqlsrvQuery\group(), ArticlesCategoryHelper\groupBy(), ArticlesCategoryHelper\groupByDate(), RSA\handleKey(), ECDSA\handleKey(), EdDSA\handleKey(), PSSRSA\handleKey(), AuthenticationExtensionsClientInputs\has(), AuthenticationExtensionsClientOutputs\has(), ListenersPriorityQueue\has(), Key\has(), AttestationStatement\has(), JWK\has(), CollectedClientData\has(), Container\has(), Table\hasField(), Container\hasFlag(), HS256_64\hash(), Hmac\hash(), Signature\hasHeaderParameter(), LoggerRegistry\hasLogger(), BaseAccept\hasParameter(), Table\hasPrimaryKey(), Signature\hasProtectedHeaderParameter(), Registry\hasService(), ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), Table\hit(), SMTP\hmac(), RuntimeTests\HMACTestVector(), Crypto\HMACTestVector(), X509\identifySignatureAlgorithm(), ParagonIE_Sodium_Core_XChaCha20\ietfStream(), ParagonIE_Sodium_Core_ChaCha20\ietfStream(), ParagonIE_Sodium_Core32_ChaCha20\ietfStream(), ParagonIE_Sodium_Core32_XChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core_XChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core_ChaCha20\ietfStreamXorIc(), ParagonIE_Sodium_Core32_ChaCha20\ietfStreamXorIc(), HTMLHelper\image(), JLoader\import(), ParagonIE_Sodium_Core32_BLAKE2b\init(), ParagonIE_Sodium_Core_BLAKE2b\init(), DataSet\initialise(), AndroidSafetyNetAttestationStatementSupport\initJwsVerifier(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), DatabaseDriver\insertObject(), ConsoleLogger\interpolate(), MessagesCollector\interpolate(), ArrayHelper\invert(), Inline\isHash(), HTMLHelper\isRegistered(), ProgressBar\iterate(), SSH2\key_exchange(), SSH2\keyboard_interactive_process(), Assertion\keyExists(), Assert\keyExists(), Assertion\keyIsset(), Assertion\keyNotExists(), Assert\keyNotExists(), PHPMailer\lang(), PreloadManager\link(), FtpClient\listNames(), AuthenticationExtensionsClientOutputsLoader\load(), Raw\load(), PublicKeyLoader\load(), XML\load(), MontgomeryPublic\load(), libsodium\load(), TPMAttestationStatementSupport\load(), MontgomeryPrivate\load(), FidoU2FAttestationStatementSupport\load(), AndroidKeyAttestationStatementSupport\load(), OpenSSH\load(), AndroidSafetyNetAttestationStatementSupport\load(), PSS\load(), PKCS1\load(), PuTTY\load(), AsymmetricKey\load(), JLoader\load(), DH\load(), PKCS8\load(), Table\load(), JWSLoader\loadAndVerifyWithKey(), PublicKeyCredentialLoader\loadArray(), DatabaseDriver\loadAssocList(), X509\loadCSR(), PKCS8\loadEdDSA(), AsymmetricKey\loadFormat(), DatabaseDriver\loadObjectList(), PublicKeyLoader\loadParameters(), AsymmetricKey\loadParameters(), AsymmetricKey\loadParametersFormat(), PublicKeyLoader\loadPrivateKey(), AsymmetricKey\loadPrivateKey(), AsymmetricKey\loadPrivateKeyFormat(), PublicKeyLoader\loadPublicKey(), AsymmetricKey\loadPublicKey(), AsymmetricKey\loadPublicKeyFormat(), DatabaseDriver\loadRowList(), X509\loadSPKAC(), FormHelper\loadType(), X509\loadX509(), Cache\makeId(), Http\makeTransportRequest(), X509\mapOutExtensions(), Finder\mapslist(), Laminas\Diactoros\marshalHeadersFromSapi(), Menu\menuItems(), Menu\menus(), ConfigPostProcessor\merge(), HtmlDocument\mergeHeadData(), ArrayHelper\mergeRecursive(), MontgomeryMult\multiplyReduce(), Laminas\Diactoros\normalizeUploadedFiles(), Assertion\notEmptyKey(), Ini\objectToString(), AggregatedCollector\offsetExists(), DebugBar\offsetExists(), AggregatedCollector\offsetGet(), DebugBar\offsetGet(), PlgSystemDebug\onAfterDisconnect(), PlgContentPagebreak\onContentPrepare(), PlgSystemFields\onContentPrepare(), PlgFieldsCheckboxes\onCustomFieldsBeforePrepareField(), FieldsPlugin\onCustomFieldsGetTypes(), FieldsPlugin\onCustomFieldsPrepareDom(), ParagonIE_Sodium_Core_Poly1305\onetimeauth(), ParagonIE_Sodium_Core32_Poly1305\onetimeauth(), ParagonIE_Sodium_Core_Poly1305\onetimeauth_verify(), ParagonIE_Sodium_Core32_Poly1305\onetimeauth_verify(), RSA\onLoad(), MessagesModel\onProcessList(), PlgUserProfile\onUserAfterSave(), PlgWorkflowNotification\onWorkflowAfterTransition(), Select\options(), StandardRules\parse(), ArrayInput\parse(), AbstractUri\parse(), ArgvInput\parseArgument(), Cli\parseArguments(), SFTP\parseAttributes(), TemplateParser\parseBinary(), Inline\parseMapping(), BaseAccept\parseParameters(), SFTP\parseTime(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), SFTP\partial_init_sftp_connection(), ArrayHelper\pivot(), Crypto\PlainDecrypt(), Crypto\PlainEncrypt(), Text\plural(), UpdatesitesModel\populateState(), AdminModel\populateState(), Form\postProcess(), WorkflowController\postSaveHook(), TagsHelper\postStoreProcess(), OpenSSL\powModHelper(), SqlsrvStatement\prepare(), TemplateModel\prepareCoreFiles(), ContentmapField\prepareLevel(), PKCS8\preParse(), FieldModel\preprocessForm(), TagsHelper\preStoreProcess(), GetConfigurationCommand\processGroupOptions(), Query\processString(), Container\protect(), Nested\publish(), Table\publish(), AssociationsModel\purge(), SFTP\rawlist(), Nested\recursiveUpdatePublishedColumn(), Montgomery\reduce(), Barrett\reduce(), ListModel\refineSearchStringToRegex(), StringsModel\refresh(), LoggerRegistry\register(), Registry\register(), HTMLHelper\register(), Log\registerLogger(), Barrett\regularBarrett(), ArticleController\reload(), ListenersPriorityQueue\remove(), MemcachedStorage\remove(), X509\removeAttribute(), Joomla\CMS\Tree\removeChild(), X509\removeExtensionHelper(), Result\removeInstruction(), RouterViewConfiguration\removeLayout(), UserHelper\removeUserFromGroup(), StylesRenderer\render(), ScriptsRenderer\render(), DebugBarVarDumper\renderCapturedVar(), FormField\renderDataAttributes(), HtmlDescriptor\renderTags(), Table\reorder(), ConfigPostProcessor\replace(), ConfigPostProcessor\replaceDependencyConfiguration(), ConfigPostProcessor\replacementRuleMatch(), MailTemplate\replaceTags(), Curl\request(), Stream\request(), StreamTransport\request(), Socket\request(), CurlTransport\request(), Agent\requestIdentities(), AbstractAES\resizeKey(), Session\restart(), SiteApplication\route(), CMSApplication\route(), Random\safe_serialize(), ParagonIE_Sodium_Core_Salsa20\salsa20(), ParagonIE_Sodium_Core32_Salsa20\salsa20(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor(), SetConfigurationCommand\sanitizeOptions(), MemcachedStorage\save(), StyleController\save(), StageModel\save(), WorkflowModel\save(), UserController\save(), CategoryController\save(), TransitionModel\save(), ModuleController\save(), MessageModel\save(), TemplateModel\save(), ArticleController\save(), RequestModel\save(), CategoryModel\save(), FormController\save(), AdminModel\save(), ItemModel\save(), AdminModel\saveorder(), PKCS1\saveParameters(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), PSS\savePrivateKey(), MSBLOB\savePrivateKey(), PKCS1\savePublicKey(), PKCS8\savePublicKey(), OpenSSH\savePublicKey(), PSS\savePublicKey(), MSBLOB\savePublicKey(), LanguageHelper\saveToIniFile(), PlgAuthenticationLdap\searchByString(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_push(), Filter\select(), JWKSet\selectKey(), Email\sendCode(), HttpHeaderSerializer\serialize(), JSONGeneralSerializer\serialize(), Cookie\set(), AbstractApplication\set(), BaseLayout\set(), Container\set(), Pagination\setAdditionalUrlParam(), WebAssetItem\setAttribute(), X509\setAttribute(), X509\setExtensionHelper(), HTMLHelper\setFormatOptions(), CaptiveRenderOptions\setInput_attributes(), SetupRenderOptions\setInput_attributes(), RouterViewConfiguration\setKey(), Http\setOption(), WebAssetItem\setOption(), PdoDriver\setOption(), Client\setOption(), NativeStorage\setOptions(), User\setParam(), Joomla\CMS\Tree\setParent(), RouterViewConfiguration\setParent(), CategoryNode\setParent(), SSH2\setPreferredAlgorithms(), X509\setPrivateKey(), X509\setPublicKey(), TextField\setup(), FormField\setup(), CMSApplication\setUserState(), Router\setVar(), Cache\setWorkarounds(), Container\share(), RSA\sign(), EdDSA\sign(), ED512\sign(), ED256\sign(), ES256K\sign(), ES512\sign(), ES256\sign(), ES384\sign(), ECDSA\sign(), BaseSigner\sign(), PSSRSA\sign(), RSAPSS\sign(), RSAPKCS1\sign(), RSA\signWithPKCS15(), RSA\signWithPSS(), LdapClient\simple_search(), ParagonIE_Sodium_Core32_SipHash\sipHash24(), ParagonIE_Sodium_Core_SipHash\sipHash24(), Filter\slider(), ApplicationDescription\sortCommands(), ArrayHelper\sortObjects(), SSH2\ssh_agent_login(), Changelog\startElement(), User\store(), ParagonIE_Sodium_Core32_XChaCha20\stream(), ParagonIE_Sodium_Core_XChaCha20\stream(), ParagonIE_Sodium_Core_ChaCha20\stream(), ParagonIE_Sodium_Core32_ChaCha20\stream(), ParagonIE_Sodium_Core32_XChaCha20\streamXorIc(), ParagonIE_Sodium_Core_XChaCha20\streamXorIc(), ParagonIE_Sodium_Core_ChaCha20\streamXorIc(), ParagonIE_Sodium_Core32_ChaCha20\streamXorIc(), Random\string(), Ini\stringToObject(), SSH2\sublogin(), Container\tag(), TagsHelper\tagItem(), EmailRule\test(), RuntimeTests\testEncryptDecrypt(), Crypto\TestEncryptDecrypt(), DataSet\toArray(), Registry\toFlatten(), Helper\tokenize(), RSAKey\toPublic(), ArrayHelper\toString(), InstallerModel\translate(), Finder\typeslist(), DatabaseQuery\unbind(), Assertion\uniqueValues(), TaskTable\unlock(), HTMLHelper\unregister(), TagsHelper\unTagItem(), PgsqlDriver\updateObject(), DatabaseDriver\updateObject(), MailTemplate\updateTemplate(), TemplateParser\validate(), Form\validate(), OpenSSL\validateKey(), SetConfigurationCommand\validateOptions(), X509\validateSignatureHelper(), X509\validateURL(), Hmac\verify(), RSAPKCS1\verify(), RSAPSS\verify(), ED256\verify(), ED512\verify(), RSA\verify(), ES384\verify(), ES256\verify(), ES256K\verify(), ES512\verify(), ECDSA\verify(), BaseSigner\verify(), EdDSA\verify(), PSSRSA\verify(), Signature\verify(), Token\verify(), Crypto\VerifyHMAC(), Crypto\verifyHMAC(), RSA\verifyWithPKCS15(), RSA\verifyWithPSS(), DataSet\walk(), JWKSet\without(), PKCS1\wrapPrivateKey(), OpenSSH\wrapPrivateKey(), PuTTY\wrapPrivateKey(), PKCS8\wrapPrivateKey(), PKCS1\wrapPublicKey(), PuTTY\wrapPublicKey(), PKCS8\wrapPublicKey(), SymfonyQuestionHelper\writePrompt(), MysqliImporter\xmlToCreate(), MysqlImporter\xmlToCreate(), ParagonIE_Sodium_Core32_XSalsa20\xsalsa20(), ParagonIE_Sodium_Core_XSalsa20\xsalsa20(), ParagonIE_Sodium_Core32_XSalsa20\xsalsa20_xor(), et ParagonIE_Sodium_Core_XSalsa20\xsalsa20_xor().

◆ $lang

$lang = Factory::getLanguage()

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $publishEndDate

$publishEndDate = $item->publish_end_date !== null ? HTMLHelper::_('date', $item->publish_end_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''

◆ $publishStartDate

$publishStartDate = $item->publish_start_date !== null ? HTMLHelper::_('date', $item->publish_start_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''

◆ $startDate

$startDate = $item->start_date !== null ? HTMLHelper::_('date', $item->start_date, Text::_('DATE_FORMAT_LC5'), 'UTC') : ''

Référencé par TPMAttestationStatementSupport\checkCertificate().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • indexer
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/indexer/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
if (JDEBUG)

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ if

if(JDEBUG)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • maps
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/maps/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$lang = Factory::getLanguage()
$branchFilter = $this->escape($this->state->get('filter.branch'))
$wa = $this->document->getWebAssetManager()
else __pad3__
endif
$canChange = Factory::getApplication()->getIdentity()->authorise('core.manage', 'com_finder')
foreach ( $this->items as $i=> $item)
if(trim($item->branch_title, ' *')==='Language') | else
$title = $lang->hasKey($key) ? Text::_($key) : $item->title
else __pad4__
if | ($item->level > 1) ((int) $item->count_published > 0) ? 'btn-success'
else __pad5__
else __pad6__
endforeach

Documentation des variables

◆ $branchFilter

$branchFilter = $this->escape($this->state->get('filter.branch'))

◆ $canChange

$canChange = Factory::getApplication()->getIdentity()->authorise('core.manage', 'com_finder')

◆ $lang

$lang = Factory::getLanguage()

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $title

string $title = $lang->hasKey($key) ? Text::_($key) : $item->title
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par FeedLink\__construct(), Result\__serialize(), PlgContentPagebreak\_createToc(), Module\_getAssetTitle(), Category\_getAssetTitle(), Content\_getAssetTitle(), TransitionTable\_getAssetTitle(), Language\_getAssetTitle(), GroupTable\_getAssetTitle(), StageTable\_getAssetTitle(), FieldTable\_getAssetTitle(), WorkflowTable\_getAssetTitle(), MenuType\_getAssetTitle(), PlgContentLoadmodule\_loadmod(), HtmlView\_prepareDocument(), JGrid\action(), PlgSampledataMultilang\addAllCategoriesMenuItem(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addBlogMenuItem(), Taxonomy\addBranch(), PlgSampledataMultilang\addCategory(), Helper\addContentType(), InstallerScript\addDashboardMenu(), PlgSampledataMultilang\addModuleMenu(), Taxonomy\addNode(), Users\addNote(), MenusHelper\addPreset(), ActionButton\addState(), UiTab\addTab(), Bootstrap\addTab(), Result\addTaxonomy(), ListView\addToolbar(), HtmlView\addToolbar(), ItemModel\batchCopy(), CategoryModel\batchCopy(), LanguageHelper\branchLanguageTitle(), DateCaster\castDateTime(), DateCaster\castInterval(), DateCaster\castTimeZone(), Usergroup\check(), TagTable\check(), FilterTable\check(), FieldTable\check(), Category\check(), Content\check(), HtmlDescriptor\describe(), MarkdownDescriptor\describeApplication(), FeedView\display(), CategoryFeedView\display(), HtmlView\display(), Application\doRenderThrowable(), Users\editor(), Query\explained(), PopupButton\fetchButton(), Users\filterNotes(), GroupModel\generateGroupTitle(), StageModel\generateNewTitle(), WorkflowModel\generateNewTitle(), TransitionModel\generateNewTitle(), StyleModel\generateNewTitle(), FieldModel\generateNewTitle(), ModuleModel\generateNewTitle(), AdminModel\generateNewTitle(), CategoryModel\generateNewTitle(), ItemModel\generateNewTitle(), AssociationsHelper\getAssociationHtmlList(), Taxonomy\getBranch(), MapsModel\getEmptyStateQuery(), NoteField\getLabel(), TagsModel\getListQuery(), TasksModel\getListQuery(), LoginModel\getLoginModule(), ModuleHelper\getModule(), Taxonomy\getNodeByTitle(), SiteApplication\getParams(), MenusHelper\getPresets(), OrderingField\getQuery(), AssociationsHelper\getSupportedExtension(), PopularHelper\getTitle(), LatestHelper\getTitle(), FormField\getTitle(), HelpModel\getToc(), AssociationExtensionHelper\getType(), AssociationsHelper\getType(), PlgFinderTags\index(), PlgFinderContacts\index(), PlgFinderContent\index(), PlgFinderCategories\index(), Links\linksgroups(), ToolbarHelper\modal(), Users\notes(), Users\notesModal(), PlgContentPagebreak\onContentPrepare(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), ContentHelper\onPrepareForm(), PlgWorkflowNotification\onWorkflowAfterTransition(), ModuleController\orderPosition(), Table\renderRowSeparator(), WorkflowModel\save(), StageModel\save(), FieldModel\save(), TransitionModel\save(), CategoryModel\save(), ItemModel\save(), Filter\select(), HtmlView\setDocumentTitle(), Table\setFooterTitle(), Table\setHeaderTitle(), Command\setProcessTitle(), ItemController\setType(), Filter\slider(), SearchTools\sort(), Users\templatestyle(), ToolbarHelper\title(), HTMLHelper\tooltip(), et HTMLHelper\tooltipText().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ ($item->level > 1)

if ( $item->level > 1)((int) $item->count_unpublished > 0) ? 'btn-danger' | ( | (int) $item-> | count_published,
 |  | 0 |
 | ) |  |

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ else

if (trim( $item->branch_title, ' *')==='Language') else
Valeur initiale :
{
$key = LanguageHelper::branchSingular($item->title)
$key
$key
Definition: administrator/components/com_finder/tmpl/index/default.php:118
$item
else $item
Definition: administrator/components/com_menus/tmpl/items/modal.php:165

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • searches
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/searches/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad7__
foreach ( $this->items as $i=> $item)
endforeach
endif

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad7__

else __pad7__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • statistics
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/statistics/default.php

Espaces de nommage

Joomla\Administrator

Variables

$lang_string = Text::_($lang_key)
endforeach

Documentation des variables

◆ $lang_string

$lang_string = Text::_($lang_key)

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • database
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/database/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirection = $this->escape($this->state->get('list.direction'))
else __pad0__
foreach($this->changeSet as $i=> $item) $manifest = json_decode($extension->manifest_cache)
endforeach
endif

Documentation des variables

◆ $listDirection

$listDirection = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $manifest

foreach ( $this->changeSet as $i=> $item) $manifest = json_decode($extension->manifest_cache)

Référencé par InstallerAdapter\canUninstallPackageChild(), TemplateModel\copy(), HtmlView\display(), FileAdapter\finaliseInstall(), UpdateModel\finaliseUpgrade(), Installer\findManifest(), TemplateModel\fixTemplateName(), SysinfoModel\getExtensions(), ExtensionsListCommand\getExtensionsNameAndId(), Installer\getManifest(), InstallerAdapter\getManifest(), MenutypesModel\getTypeOptionsFromManifest(), Installer\install(), Joomla\onExtensionAfterInstall(), Joomla\onExtensionAfterUninstall(), Joomla\onExtensionAfterUpdate(), InstallerScript\preflight(), PlgExtensionJoomla\processUpdateSites(), UpdatesitesModel\rebuild(), PackageAdapter\removeExtensionFiles(), InstallerAdapter\setManifest(), LibraryAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), PackageAdapter\setupUninstall(), UpdateModel\translate(), et Installer\update().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • discover
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/discover/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad1__
foreach ( $this->items as $i=> $item)
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • install
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/install/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$tabs = $app->triggerEvent('onInstallerAddInstallationTab', [])
endif
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $tabs

$tabs = $app->triggerEvent('onInstallerAddInstallationTab', [])

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • languages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/languages/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad2__
$version = new Version()
$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())
$i = 0
$language code = $element[1]
$buttonText = (isset($this->installedLang[0][$language->code]) || isset($this->installedLang[1][$language->code])) ? 'REINSTALL' : 'INSTALL'
$buttonClass = (isset($this->installedLang[0][$language->code]) || isset($this->installedLang[1][$language->code])) ? 'btn btn-success btn-sm' : 'btn btn-primary btn-sm'
$onclick = 'document.getElementById(\'install_url\').value = \'' . $language->detailsurl . '\'; Joomla.submitbutton(\'install.install\');'
$minorVersion = $version::MAJOR_VERSION . '.' . $version::MINOR_VERSION
if (strpos( $language->version, $minorVersion) !==0||strpos( $language->version, $currentShortVersion) !==0)
else __pad3__
endif
endforeach

Documentation des variables

◆ $buttonClass

$buttonClass = (isset($this->installedLang[0][$language->code]) || isset($this->installedLang[1][$language->code])) ? 'btn btn-success btn-sm' : 'btn btn-primary btn-sm'

Référencé par InlinehelpButton\fetchButton(), ContainerAwareToolbarFactory\loadButtonClass(), et ToolbarButton\renderButton().

◆ $buttonText

$buttonText = (isset($this->installedLang[0][$language->code]) || isset($this->installedLang[1][$language->code])) ? 'REINSTALL' : 'INSTALL'

◆ $currentShortVersion

$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())

◆ $i

$i = 0

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $minorVersion

$minorVersion = $version::MAJOR_VERSION . '.' . $version::MINOR_VERSION

Référencé par Browser\getMinor(), Browser\getVersion(), et AtomRenderer\render().

◆ $onclick

$onclick = 'document.getElementById(\'install_url\').value = \'' . $language->detailsurl . '\'; Joomla.submitbutton(\'install.install\');'

◆ $version

$version = new Version()

Référencé par Request\__construct(), Response\__construct(), ServerRequest\__construct(), RequestParameters\__construct(), BinaryUtils\applyVersion(), ConfigurationModel\checkTestingSampledata(), Factory\createDocument(), HttplugFactory\createResponse(), Help\createUrl(), OptionConfigurator\deprecated(), TextDescriptor\describeJoomlaApplication(), WebClient\detectEngine(), InstallerHelper\downloadPackage(), Assertion\extensionVersion(), UnrecognizedProtocolVersionException\forVersion(), Serializer\fromStream(), HttpFactory\getHttp(), PlgSystemLogrotation\getLogFiles(), SFTP\getNegotiatedVersion(), PlgQuickiconPhpVersionCheck\getPhpSupport(), PlgCaptchaRecaptcha\getResponse(), Version\getShortVersion(), Factory\getStream(), UpdateAdapter\getUpdateSiteResponse(), VersionHelper\getVersion(), WebAssetItem\getVersion(), MysqlDriver\getVersion(), Browser\identifyBrowserVersion(), CliDumper\isWindowsTrueColor(), Changelog\loadFromXml(), Update\loadFromXml(), Curl\mapProtocolVersion(), Browser\match(), PlgCaptchaRecaptcha\onCheckAnswer(), Installer\parseSchemaUpdates(), Assertion\phpVersion(), JLoader\registerAlias(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), OptionsResolver\setDeprecated(), SFTP\setPreferredVersion(), ConfigurationModel\setup(), PuTTY\setVersion(), Changelog\setVersion(), X509\signCRL(), RequestParameters\toArray(), UuidFactory\uuidFromHashedName(), UuidFactory\uuidFromNsAndName(), Laminas\Diactoros\validateProtocolVersion(), Nyholm\Psr7\withProtocolVersion(), Laminas\Diactoros\withProtocolVersion(), et PuTTY\wrapPrivateKey().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ code

string $statusCode exception error code = $element[1]

Référencé par ConnectionFailureException\__construct(), PrepareStatementFailureException\__construct(), ExecutionFailureException\__construct(), Command\run(), FlattenException\setCode(), et Command\setCode().

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(strpos($language->version, $minorVersion) !==0||strpos($language->version, $currentShortVersion) !==0)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • manage
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/manage/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad4__
$createdDateFormat = Text::_('DATE_FORMAT_LC4')
foreach($this->items as $i=> $item) if ( $item->status==2)
else __pad5__
else __pad6__
endforeach

Documentation des variables

◆ $createdDateFormat

$createdDateFormat = Text::_('DATE_FORMAT_LC4')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ endforeach

endforeach

◆ endif

endif

◆ if

foreach ( $this->items as $i=> $item) if($item->status==2)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • update
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/update/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad7__
if (!empty( $item->infourl))
else __pad8__
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($item->infourl))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • updatesites
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/updatesites/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getApplication()->getIdentity()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad9__
$canEdit = $user->authorise('core.edit', 'com_installer')
if ((int) $item->enabled===2)
endif
else __pad10__
endforeach

Documentation des variables

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_installer')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad10__

else __pad10__

◆ __pad9__

else __pad9__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if((int) $item->enabled===2)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • warnings
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/warnings/default.php

Espaces de nommage

Joomla\Administrator

Variables

endforeach
else __pad11__
endif

Documentation des variables

◆ __pad11__

else __pad11__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • update
Espaces de nommage | Variables
Référence du fichier administrator/components/com_joomlaupdate/tmpl/update/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$password = Factory::getApplication()->getUserState('com_joomlaupdate.password', null)
$filesize = Factory::getApplication()->getUserState('com_joomlaupdate.filesize', null)
$ajaxUrl = Uri::base() . 'components/com_joomlaupdate/extract.php'
$returnUrl = 'index.php?option=com_joomlaupdate&task=update.finalise&' . Factory::getSession()->getFormToken() . '=1'
$helpUrl = Help::createUrl('JHELP_COMPONENTS_JOOMLA_UPDATE', false)

Documentation des variables

◆ $ajaxUrl

$ajaxUrl = Uri::base() . 'components/com_joomlaupdate/extract.php'

◆ $filesize

$filesize = Factory::getApplication()->getUserState('com_joomlaupdate.filesize', null)

Référencé par UpdateModel\createUpdateFile(), et Stream\read().

◆ $helpUrl

$helpUrl = Help::createUrl('JHELP_COMPONENTS_JOOMLA_UPDATE', false)

Référencé par HtmlView\addToolbar().

◆ $password

$password = Factory::getApplication()->getUserState('com_joomlaupdate.password', null)

Référencé par LocalStrategy\authenticate(), DatabaseStrategy\authenticate(), SMTP\authenticate(), Ldap\bind(), Connection\bind(), PasswordHash\CheckPassword(), Factory\createDbo(), KeyOrPassword\createFromPassword(), KeyProtectedByPassword\createRandomPasswordProtectedKey(), UpdateModel\createUpdateFile(), PasswordHash\crypt_private(), File\decryptFileWithPassword(), File\decryptResourceWithPassword(), Crypto\decryptWithPassword(), AbstractUsernamePasswordAuthenticationStrategy\doAuthenticate(), AddUserCommand\doExecute(), File\encryptFileWithPassword(), File\encryptResourceWithPassword(), Crypto\encryptWithPassword(), PKCS1\generateSymmetricKey(), PuTTY\generateV2Key(), PuTTY\generateV3Key(), DatabaseHelper\getDbo(), DatabaseStrategy\getHashedPassword(), PasswordHash\HashPassword(), Encrypt\initialize(), SSH2\keyboard_interactive_login(), PublicKeyLoader\load(), OpenSSH\load(), PSS\load(), PKCS1\load(), PuTTY\load(), AsymmetricKey\load(), DH\load(), PKCS8\load(), AsymmetricKey\loadFormat(), PublicKeyLoader\loadPrivateKey(), AsymmetricKey\loadPrivateKey(), AsymmetricKey\loadPrivateKeyFormat(), LdapUserProvider\loadUser(), SSH2\login_helper(), Basic\onUserAuthenticate(), Core\pbkdf2(), PuTTY\savePrivateKey(), MontgomeryPrivate\savePrivateKey(), libsodium\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), XML\savePrivateKey(), Raw\savePrivateKey(), PSS\savePrivateKey(), MSBLOB\savePrivateKey(), Aes\setPassword(), SymmetricKey\setPassword(), KeyProtectedByPassword\unlockKey(), AbstractUsernamePasswordAuthenticationStrategy\verifyPassword(), phpseclib3\Crypt\Common\Traits\withPassword(), Uri\withUserInfo(), PKCS1\wrapPrivateKey(), OpenSSH\wrapPrivateKey(), PuTTY\wrapPrivateKey(), et PKCS8\wrapPrivateKey().

◆ $returnUrl

$returnUrl = 'index.php?option=com_joomlaupdate&task=update.finalise&' . Factory::getSession()->getFormToken() . '=1'

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • upload
Espaces de nommage | Variables
Référence du fichier administrator/components/com_joomlaupdate/tmpl/upload/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$latestJoomlaVersion = $this->updateInfo['latest']
$currentJoomlaVersion = isset($this->updateInfo['installed']) ? $this->updateInfo['installed'] : JVERSION
endif
endforeach
$maxSizeBytes = Utility::getMaxUploadSize()
$maxSize = HTMLHelper::_('number.bytes', $maxSizeBytes)

Documentation des variables

◆ $currentJoomlaVersion

$currentJoomlaVersion = isset($this->updateInfo['installed']) ? $this->updateInfo['installed'] : JVERSION

◆ $latestJoomlaVersion

$latestJoomlaVersion = $this->updateInfo['latest']

◆ $maxSize

$maxSize = HTMLHelper::_('number.bytes', $maxSizeBytes)

Référencé par TemplateHelper\canUpload(), MediaHelper\canUpload(), et FilesystemHelper\parseSizeUnit().

◆ $maxSizeBytes

$maxSizeBytes = Utility::getMaxUploadSize()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • installed
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/installed/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad0__
$version = new Version()
$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())
$canEdit = $user->authorise('core.edit', 'com_languages')
$canChange = $user->authorise('core.edit.state', 'com_languages')
$minorVersion = $version::MAJOR_VERSION . '.' . $version::MINOR_VERSION
else __pad1__
endif
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_languages')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_languages')

◆ $currentShortVersion

$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $minorVersion

$minorVersion = $version::MAJOR_VERSION . '.' . $version::MINOR_VERSION

◆ $user

$user = Factory::getUser()

◆ $version

$version = new Version()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • languages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/languages/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
if ( $saveOrder &&!empty( $this->items))
else __pad2__
endif
$canEdit = $user->authorise('core.edit', 'com_languages')
$canChange = $user->authorise('core.edit.state', 'com_languages')
if($canChange) $disabledLabel = ''
$disableClassName = 'inactive'
else __pad3__
else __pad4__
else __pad5__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_languages')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_languages')

◆ $disableClassName

$disableClassName = 'inactive'

◆ $disabledLabel

if ( $canChange) $disabledLabel = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • multilangstatus
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/multilangstatus/default.php

Espaces de nommage

Joomla\Administrator

Variables

$notice_disabled = !$this->language_filter && ($this->homes > 1 || $this->switchers != 0)
$notice_switchers = !$this->switchers && ($this->homes > 1 || $this->language_filter)
$content_languages = array_column($this->contentlangs, 'lang_code')
$sitelangs = array_column($this->site_langs, 'element')
$home_pages = array_column($this->homepages, 'language')
else __pad6__
endif
else __pad7__
else __pad8__
endforeach
else __pad9__
if($this->switchers !=0) | else
else __pad10__
else __pad11__
else __pad12__
else __pad13__
foreach | ($this->contentlangs as $contentlang) (!array_key_exists( $contentlang->lang_code, $this->site_langs))
else __pad14__
foreach | ($sitelangs as $sitelang) (!in_array( $sitelang, $content_languages) &&in_array( $sitelang, $home_pages))

Documentation des variables

◆ $content_languages

else $content_languages = array_column($this->contentlangs, 'lang_code')

Référencé par AdministratorService\association(), Menus\association(), et AssociationsHelper\getAssociationHtmlList().

◆ $home_pages

$home_pages = array_column($this->homepages, 'language')

◆ $notice_disabled

$notice_disabled = !$this->language_filter && ($this->homes > 1 || $this->switchers != 0)

◆ $notice_switchers

$notice_switchers = !$this->switchers && ($this->homes > 1 || $this->language_filter)

◆ $sitelangs

$sitelangs = array_column($this->site_langs, 'element')

Référencé par LanguagesHelper\getList().

◆ ($sitelangs as $sitelang)

foreach ( $sitelangs as $sitelang)(!in_array($sitelang, $content_languages) &&in_array($sitelang, $home_pages))

◆ ($this->contentlangs as $contentlang)

foreach ( $this->contentlangs as $contentlang)(!array_key_exists($contentlang->lang_code, $this->site_langs))

◆ __pad10__

else __pad10__

◆ __pad11__

else __pad11__

◆ __pad12__

else __pad12__

◆ __pad13__

else __pad13__

◆ __pad14__

else __pad14__

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ __pad9__

else __pad9__

◆ else

if ( $this->homes > 1) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • overrides
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/overrides/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$client = $this->state->get('filter.client') == 'site' ? Text::_('JSITE') : Text::_('JADMINISTRATOR')
$language = $this->state->get('filter.language')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$oppositeClient = $this->state->get('filter.client') == 'administrator' ? Text::_('JSITE') : Text::_('JADMINISTRATOR')
$oppositeFilename
$oppositeStrings = LanguageHelper::parseIniFile($oppositeFilename)
else __pad15__
$canEdit = Factory::getUser()->authorise('core.edit', 'com_languages')
$i = 0
foreach ( $this->items as $key=> $text)
else __pad16__
endif
endforeach

Documentation des variables

◆ $canEdit

$canEdit = Factory::getUser()->authorise('core.edit', 'com_languages')

◆ $client

$client = $this->state->get('filter.client') == 'site' ? Text::_('JSITE') : Text::_('JADMINISTRATOR')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Route\_(), LangActiveAssetItem\__construct(), InstallationApplication\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), SiteApplication\__construct(), WebApplication\__construct(), CMSApplication\__construct(), PackageAdapter\_getExtensionId(), CollectionAdapter\_startElement(), ApplicationHelper\addClientInfo(), WebAssetRegistry\addTemplateRegistryFile(), HtmlView\addToolbar(), SymfonyCaster\castHttpClient(), TemplateModel\child(), Installer\cleanDiscoveredExtension(), TemplateModel\copy(), Installer\copyManifest(), DistantSingleMetadataFactory\create(), MetadataServiceFactory\create(), MenuFactory\createMenu(), TemplateModel\createOverride(), OverridesModel\delete(), LanguageAdapter\discover_install(), Server\enforceAndroidSafetyNetVerification(), MetadataStatementFetcher\fetch(), MetadataStatementFetcher\fetchMetadataStatement(), MetadataStatementFetcher\fetchTableOfContent(), LanguagesModel\getClient(), PlgSampledataMultilang\getClient(), ApplicationHelper\getClientInfo(), Dispatcher\getController(), ComponentDispatcher\getController(), TemplateModel\getCoreFile(), TemplateModel\getCoreList(), ClientHelper\getCredentials(), TemplateModel\getFiles(), MenutypesModel\getFolders(), TemplateModel\getFont(), OverrideModel\getForm(), MenuField\getGroups(), TemplatestyleField\getGroups(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), Pathway\getInstance(), Router\getInstance(), AbstractMenu\getInstance(), StyleModel\getItem(), ModuleModel\getItem(), TemplatesModel\getItems(), PositionsModel\getItems(), SelectModel\getItems(), ItemsModel\getItems(), LanguageField\getOptions(), OverridesModel\getOverrides(), TemplateModel\getOverridesList(), InstalledModel\getPath(), LanguagesModel\getPath(), PlgSampledataMultilang\getPath(), MenutypesModel\getTypeOptionsByComponent(), MenutypesModel\getTypeOptionsFromLayouts(), TemplateModel\getUpdatedList(), ClientHelper\hasCredentials(), HTMLHelper\includeRelativeFiles(), LanguageAdapter\install(), Route\link(), TemplateAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), Installer\parseFiles(), Installer\parseLanguages(), OverridesModel\populateState(), OverrideModel\populateState(), PluginAdapter\prepareDiscoverInstall(), TemplateAdapter\prepareDiscoverInstall(), ModuleAdapter\prepareDiscoverInstall(), StyleModel\preprocessForm(), ModuleModel\preprocessForm(), InstalledModel\publish(), AdminModel\redirectToAssociations(), StringsModel\refresh(), ModuleAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), Installer\removeFiles(), LanguageAdapter\resetUserLanguage(), OverrideModel\save(), FileLayout\setClient(), ClientHelper\setCredentials(), ClientHelper\setCredentialsFromRequest(), LanguagesModel\setDefault(), PlgSystemHttpHeaders\setStaticHeaders(), ModulepositionField\setup(), ChromestyleField\setup(), TemplateAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), LanguageAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), ModuleAdapter\setupUninstall(), InstalledModel\switchAdminLanguage(), Templates\thumb(), Templates\thumbModal(), et LanguageAdapter\update().

◆ $i

if (isset( $oppositeStrings[ $key]) &&( $oppositeStrings[ $key]==$text)) $i = 0

◆ $language

$language = $this->state->get('filter.language')

Référencé par FeedLink\__construct(), PlgSystemLanguageFilter\__construct(), ConsoleApplication\__construct(), Result\__serialize(), RouteHelper\_findItem(), PlgSampledataMultilang\addAssociations(), PlgSampledataBlog\addMenuItems(), Taxonomy\addNestedNode(), Result\addNestedTaxonomy(), Taxonomy\addNode(), Result\addTaxonomy(), HtmlView\addToolbar(), LanguageHelper\branchSingular(), ContactModel\buildContactExtendedData(), MenuRules\buildLookup(), SetConfigurationCommand\configureIO(), ExtensionRemoveCommand\configureIO(), FinderIndexCommand\configureIO(), InflectorFactory\createForLanguage(), LanguageHelper\createLanguageList(), LanguageAdapter\discover(), CategoryFeedView\display(), HtmlView\display(), AssociationHelper\displayAssociations(), TemplateController\edit(), AdminLanguage\existing(), RouteHelper\findItem(), ASCII\get_language(), RouteHelper\getArticleRoute(), AssociationsHelper\getAssociationHtmlList(), AcceptLanguage\getBasePart(), RouteHelper\getCategoryRoute(), RouteHelper\getComponentTagRoute(), RouteHelper\getComponentTagsRoute(), RouteHelper\getContactRoute(), UsersComponent\getContexts(), Factory\getDate(), AbstractMenu\getDefault(), SiteMenu\getDefault(), OverrideModel\getForm(), Language\getInstance(), TemplateModel\getItem(), RouteHelper\getItemRoute(), TagsHelper\getItemTags(), CliApplication\getLanguage(), WebApplication\getLanguage(), Factory\getLanguage(), ConsoleApplication\getLanguage(), LoginHelper\getLanguageList(), LanguageHelper\getLanguagePath(), LanguagesModel\getLanguages(), TinymcebuilderField\getLayoutData(), TagsPopularHelper\getList(), LanguagesHelper\getList(), TagsSimilarHelper\getList(), BannersModel\getListQuery(), TemplatesModel\getListQuery(), GroupsModel\getListQuery(), FieldsModel\getListQuery(), TagModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), IndexModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), InstallationApplication\getLocaliseAdmin(), MenusModel\getMissingModuleLanguages(), RouteHelper\getNewsfeedRoute(), ItemlanguageField\getOptions(), CategoryField\getOptions(), LanguageclientField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), TemplateController\getRedirectToItemAppend(), RouteHelper\getRoute(), Languages\id(), LanguagesModel\install(), AbstractModuleDispatcher\loadLanguage(), WebApplication\loadLanguage(), UserController\login(), UserController\logout(), Mbstring\mb_get_info(), Mbstring\mb_language(), UserController\menulogout(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSampledataBlog\onAjaxSampledataApplyStep2(), PlgSystemLanguagecode\onContentPrepareForm(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgUserJoomla\onUserAfterSave(), PlgSystemLanguageFilter\parseRule(), TagsModel\populateState(), ItemsModel\populateState(), ArticlesModel\populateState(), OverridesModel\populateState(), TagModel\populateState(), OverrideModel\populateState(), SearchModel\populateState(), TemplateModel\populateState(), JsonapiView\prepareItem(), Menu\preprocess(), MenuRules\preprocess(), CssMenu\preprocess(), NewsfeedModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), AdminModel\redirectToAssociations(), StringsModel\refresh(), OverrideModel\save(), TemplateModel\save(), Filter\select(), MailModel\send(), InstalledController\setDefault(), AbstractMenu\setDefault(), LanguagesModel\setDefault(), OutputFilter\setLanguage(), Helper\stem(), Menu\store(), OutputFilter\stringURLSafe(), ApplicationHelper\stringURLSafe(), OutputFilter\stringUrlSafe(), InstalledController\switchAdminLanguage(), ASCII\to_slugify(), et Helper\tokenize().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $oppositeClient

$oppositeClient = $this->state->get('filter.client') == 'administrator' ? Text::_('JSITE') : Text::_('JADMINISTRATOR')

Référencé par OverrideModel\save().

◆ $oppositeFilename

$oppositeFilename
Valeur initiale :
= constant('JPATH_' . strtoupper($this->state->get('filter.client') === 'site' ? 'administrator' : 'site'))
. '/language/overrides/' . $this->state->get('filter.language', 'en-GB') . '.override.ini'
strtoupper

◆ $oppositeStrings

$oppositeStrings = LanguageHelper::parseIniFile($oppositeFilename)

Référencé par OverrideModel\getItem().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad15__

else __pad15__

◆ __pad16__

else __pad16__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $key=> $text)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • tmpl
  • login
Espaces de nommage | Variables
Référence du fichier administrator/components/com_login/tmpl/login/default.php

Espaces de nommage

Joomla\Administrator

Variables

$loginmodule = \Joomla\Component\Login\Administrator\Model\LoginModel::getLoginModule('mod_login')
$modules = ModuleHelper::getModules('login')

Documentation des variables

◆ $loginmodule

$loginmodule = \Joomla\Component\Login\Administrator\Model\LoginModel::getLoginModule('mod_login')

Get the login modules If you want to use a completely different login module change the value of name in your layout override.

◆ $modules

$modules = ModuleHelper::getModules('login')

Get any other modules in the login position. If you want to use a different position for the modules, change the name here in your override.

Référencé par PlgContentLoadmodule\_load(), PlgContentLoadmodule\_loadid(), ModuleHelper\cleanModuleList(), HtmlDocument\countModules(), CaptiveModel\filterModules(), LoginModel\getLoginModule(), ModuleHelper\getModule(), MultilangstatusHelper\getModule(), ModuleHelper\getModuleById(), ModuleHelper\getModules(), ModulesHelper\getModules(), MenuModel\getModules(), TemplateModel\getOverridesList(), ModuleHelper\load(), et CaptiveModel\onAfterModuleList().


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • tmpl
  • templates
Espaces de nommage | Variables
Référence du fichier administrator/components/com_mails/tmpl/templates/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad0__
endif
$sub_id = str_replace('.', '_', $sub_id)
else __pad1__
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $sub_id

$sub_id = str_replace('.', '_', $sub_id)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
  • file
Espaces de nommage | Variables
Référence du fichier administrator/components/com_media/tmpl/file/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$script = $wa->getAsset('script', 'com_media.edit-images')->getUri(true)
$params = ComponentHelper::getParams('com_media')
$input = Factory::getApplication()->input
$form = $this->form
$tmpl = $input->getCmd('tmpl')
if($tmpl=='component') | $mediaTypes = $input->getString('mediatypes', '0')
$config
$this | useCoreUI = true
$fieldSets = $form->getFieldsets()
endif

Documentation des variables

◆ $config

$config
Valeur initiale :
= [
'apiBaseUrl' => Uri::base() . 'index.php?option=com_media&format=json' . '&mediatypes=' . $mediaTypes
$mediaTypes
if($tmpl=='component') $mediaTypes
Definition: administrator/components/com_media/tmpl/file/default.php:46

Référencé par FeaturedModel\__construct(), ClientsModel\__construct(), BannersModel\__construct(), BaseInstallationModel\__construct(), WorkflowsModel\__construct(), RequestsModel\__construct(), SearchesModel\__construct(), FiltersModel\__construct(), StagesModel\__construct(), TemplatesModel\__construct(), TransitionsModel\__construct(), ConsentsModel\__construct(), ContactsModel\__construct(), LinksModel\__construct(), MessagesModel\__construct(), MenusModel\__construct(), InstallationController\__construct(), InstallerModel\__construct(), NotesModel\__construct(), OverridesModel\__construct(), PositionsModel\__construct(), StylesModel\__construct(), MapsModel\__construct(), MediumModel\__construct(), ModulesModel\__construct(), NewsfeedsModel\__construct(), PluginsModel\__construct(), TagsModel\__construct(), AssociationsModel\__construct(), ConfigController\__construct(), LevelsModel\__construct(), DebuguserModel\__construct(), DiscoverModel\__construct(), TemplatesController\__construct(), ItemsModel\__construct(), ContactsController\__construct(), DebuggroupModel\__construct(), CallbackController\__construct(), FieldsModel\__construct(), CheckinModel\__construct(), ItemsController\__construct(), LanguageModel\__construct(), ComponentController\__construct(), ManageController\__construct(), ArticlesModel\__construct(), PlgExtensionNamespacemap\__construct(), ApplicationController\__construct(), GroupModel\__construct(), ArticlesController\__construct(), HistoryModel\__construct(), ManageModel\__construct(), ModulesController\__construct(), TemplateController\__construct(), UpdatesitesModel\__construct(), ActionlogsModel\__construct(), LanguagesModel\__construct(), ArticleController\__construct(), BaseApplication\__construct(), SelectModel\__construct(), TasksModel\__construct(), BannersController\__construct(), PlgContentVote\__construct(), PlgSystemLogout\__construct(), MediaModel\__construct(), MethodsController\__construct(), GroupsModel\__construct(), TracksModel\__construct(), Basic\__construct(), CategoriesModel\__construct(), UpdateModel\__construct(), UsersController\__construct(), MetadataManagerListener\__construct(), CaptiveController\__construct(), UpdatesitesController\__construct(), UsersModel\__construct(), MethodController\__construct(), ActionlogsController\__construct(), PlgSystemActionLogs\__construct(), CategoryController\__construct(), BaseModel\__construct(), HtmlView\__construct(), UserModel\__construct(), ProfileModel\__construct(), DisplayController\__construct(), FormModel\__construct(), TagModel\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), RegistrationModel\__construct(), InstallationApplication\__construct(), GroupController\__construct(), CacheModel\__construct(), JsonView\__construct(), PluginModel\__construct(), FieldController\__construct(), IndexModel\__construct(), StageController\__construct(), TransitionController\__construct(), InstalledModel\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), AdminController\__construct(), DatabaseModel\__construct(), TransitionsController\__construct(), Joomlaupdate\__construct(), StagesController\__construct(), StyleModel\__construct(), SiteApplication\__construct(), Versionable\__construct(), Token\__construct(), Joomla\__construct(), WebApplication\__construct(), BaseDatabaseModel\__construct(), Checkfiles\__construct(), CategoryModel\__construct(), JsonApiView\__construct(), AbstractView\__construct(), FormController\__construct(), ModuleModel\__construct(), FormView\__construct(), FieldModel\__construct(), Cache\__construct(), ApiController\__construct(), Requests\__construct(), CMSPlugin\__construct(), ArticleModel\__construct(), PlgSystemLanguageFilter\__construct(), SiteStatus\__construct(), Webauthn\__construct(), ListView\__construct(), CliApplication\__construct(), DaemonApplication\__construct(), JsonapiView\__construct(), TaskModel\__construct(), ListModel\__construct(), Adapter\__construct(), PlgSystemHttpHeaders\__construct(), CMSApplication\__construct(), AdminModel\__construct(), BaseController\__construct(), ConfigPostProcessor\__invoke(), BaseDatabaseModel\_createTable(), InstallModel\_getPackageFromUpload(), Editor\_loadEditor(), SiteStatus\alterSiteStatus(), Access\assetgrouplist(), Uri\base(), behindproxy_postinstall_action(), Category\categories(), BannerModel\click(), Joomla\CMS\Categories\countItems(), ContentComponent\countItems(), ContentHelper\countRelations(), ContentComponent\countTagItems(), Ldap\create(), Factory\createConfig(), MVCFactory\createController(), ApiMVCFactory\createModel(), LegacyFactory\createModel(), MVCFactory\createModel(), BaseController\createModel(), ApiMVCFactory\createTable(), LegacyFactory\createTable(), MVCFactory\createTable(), UpdateModel\createUpdateFile(), LegacyFactory\createView(), MVCFactory\createView(), BaseController\createView(), ApiDispatcher\dispatch(), ComponentDispatcher\dispatch(), PropelCollector\enablePropelProfiling(), ComponentHelper\filterText(), GetConfigurationCommand\formatConfig(), Factory\getConfig(), SysinfoModel\getConfig(), ConsoleApplication\getConfig(), CliApplication\getConfig(), WebApplication\getConfig(), Dispatcher\getController(), ComponentDispatcher\getController(), ApplicationModel\getData(), HelperFactory\getHelper(), Module\getHelper(), BaseController\getInstance(), Table\getInstance(), BannersHelper\getList(), BannersModel\getListQuery(), NewsfeedsController\getModel(), LanguagesController\getModel(), MessagesController\getModel(), PreviewController\getModel(), RequestsController\getModel(), PluginsController\getModel(), IndexController\getModel(), CategoriesController\getModel(), HistoryController\getModel(), TagsController\getModel(), TasksController\getModel(), LevelsController\getModel(), ClientsController\getModel(), MapsController\getModel(), FiltersController\getModel(), NotesController\getModel(), GroupsController\getModel(), FieldsController\getModel(), TracksController\getModel(), AssociationsController\getModel(), MenusController\getModel(), ItemsController\getModel(), DisplayController\getModel(), BannersController\getModel(), UsersController\getModel(), ModulesController\getModel(), UpdatesitesController\getModel(), WorkflowsController\getModel(), FeaturedController\getModel(), LinksController\getModel(), TransitionsController\getModel(), StagesController\getModel(), ContactsController\getModel(), ArticlesController\getModel(), ActionlogsController\getModel(), TemplateController\getModel(), ArticleController\getModel(), ApiController\getModel(), FormController\getModel(), BaseController\getModel(), Indexer\getSignature(), PlgSystemSchedulerunner\getSubscribedEvents(), FeatureModel\getTable(), GroupModel\getTable(), UserModel\getTable(), MenuModel\getTable(), WorkflowsModel\getTable(), TransitionsModel\getTable(), PreviewModel\getTable(), StagesModel\getTable(), LevelModel\getTable(), CompareModel\getTable(), CategoryModel\getTable(), PluginModel\getTable(), HistoryModel\getTable(), BannersModel\getTable(), MapsModel\getTable(), IndexModel\getTable(), ModuleModel\getTable(), ItemModel\getTable(), DisplayController\getView(), BaseController\getView(), BannersModel\impress(), PlgSystemSchedulerunner\injectLazyJS(), UpdateModel\install(), Helper\isCommon(), Joomla\CMS\Workflow\isWorkflowActive(), Menu\menuItemList(), Menu\menuItems(), Category\options(), Tag\options(), MessagesModel\purge(), ServiceProviderInterface\register(), Application\register(), ApplicationModel\removeroot(), ConfigPostProcessor\replaceDependencyConfiguration(), ConfigPostProcessor\replaceDependencyFactories(), ConfigPostProcessor\replaceDependencyInvokables(), ConfigPostProcessor\replaceDependencyServices(), PlgSystemSchedulerunner\runLazyCron(), PlgSystemSchedulerunner\runWebCron(), ApplicationModel\save(), MessageModel\save(), Helper\stem(), Tag\tags(), EmailRule\test(), Helper\tokenize(), SetConfigurationCommand\validateOptions(), SiteStatus\writeConfigFile(), et ApplicationModel\writeConfigFile().

◆ $fieldSets

$fieldSets = $form->getFieldsets()

◆ $form

$form = $this->form

Référencé par LastvisitdaterangeField\__construct(), UseractiveField\__construct(), RegistrationdaterangeField\__construct(), LogsdaterangeField\__construct(), Router\__construct(), FormField\__construct(), Joomla\CMS\MVC\Model\addTransitionField(), ContactModel\buildContactExtendedData(), FieldModel\checkDefaultValue(), SetupModel\checkForm(), FormFactory\createForm(), HtmlView\display(), UnicodeString\endsWith(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), PlgWorkflowPublishing\enhanceTransitionForm(), UnicodeString\equalsTo(), UserModel\getAssignedGroups(), RegistrationModel\getData(), ArticlesModel\getFilterForm(), WorkflowsModel\getFilterForm(), TransitionsModel\getFilterForm(), UsersModel\getFilterForm(), ActionlogsModel\getFilterForm(), FieldsModel\getFilterForm(), AssociationModel\getForm(), FileModel\getForm(), OverrideModel\getForm(), LoginModel\getForm(), MailModel\getForm(), NoteModel\getForm(), ResetModel\getForm(), UpdatesiteModel\getForm(), TemplatesModel\getForm(), ModulesModel\getForm(), DownloadModel\getForm(), FormModel\getForm(), LinkModel\getForm(), RequestModel\getForm(), ApplicationModel\getForm(), ComponentModel\getForm(), TemplateModel\getForm(), PluginModel\getForm(), ClientModel\getForm(), SetupModel\getForm(), GroupModel\getForm(), FilterModel\getForm(), ConfigModel\getForm(), NewsfeedModel\getForm(), ProfileModel\getForm(), UserModel\getForm(), RemindModel\getForm(), LanguageModel\getForm(), WorkflowModel\getForm(), TagModel\getForm(), TaskModel\getForm(), MenuModel\getForm(), ContactModel\getForm(), ConfirmModel\getForm(), LevelModel\getForm(), BannerModel\getForm(), MessageModel\getForm(), StageModel\getForm(), TransitionModel\getForm(), CategoryModel\getForm(), ChecksModel\getForm(), StyleModel\getForm(), RegistrationModel\getForm(), ArticleModel\getForm(), FieldModel\getForm(), ItemModel\getForm(), UpdateModel\getForm(), ModuleModel\getForm(), LanguagesModel\getForm(), HtmlView\getForm(), FieldsPlugin\getFormPath(), ResetModel\getResetCompleteForm(), ResetModel\getResetConfirmForm(), Joomla\Component\Scheduler\Administrator\Traits\getRoutineId(), Joomla\CMS\MVC\Model\getStageForNewItem(), UnicodeString\indexOf(), UnicodeString\indexOfLast(), Normalizer\isNormalized(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), Normalizer\normalize(), UnicodeString\normalize(), PlgSystemFields\onContentNormaliseRequestData(), MediaActionPlugin\onContentPrepareForm(), PlgUserJoomla\onContentPrepareForm(), PlgUserTerms\onContentPrepareForm(), PlgContentConfirmConsent\onContentPrepareForm(), PlgSystemPrivacyconsent\onContentPrepareForm(), PlgSystemActionLogs\onContentPrepareForm(), PlgWorkflowNotification\onContentPrepareForm(), PlgWorkflowPublishing\onContentPrepareForm(), PlgWorkflowFeaturing\onContentPrepareForm(), PlgSystemLanguagecode\onContentPrepareForm(), PlgUserToken\onContentPrepareForm(), PlgUserProfile\onContentPrepareForm(), FieldsPlugin\onContentPrepareForm(), PlgSystemFields\onContentPrepareForm(), PlgFieldsMedia\onCustomFieldsPrepareDom(), PlgFieldsEditor\onCustomFieldsPrepareDom(), PlgFieldsImagelist\onCustomFieldsPrepareDom(), PlgFieldsUser\onCustomFieldsPrepareDom(), PlgFieldsColor\onCustomFieldsPrepareDom(), PlgFieldsCalendar\onCustomFieldsPrepareDom(), PlgFieldsUrl\onCustomFieldsPrepareDom(), FieldsListPlugin\onCustomFieldsPrepareDom(), PlgFieldsSql\onCustomFieldsPrepareDom(), PlgFieldsSubform\onCustomFieldsPrepareDom(), ContentHelper\onPrepareForm(), PlgUserTerms\onUserBeforeSave(), PlgSystemPrivacyconsent\onUserBeforeSave(), ContentComponent\prepareForm(), RemindModel\preprocessForm(), ModulesModel\preprocessForm(), MailModel\preprocessForm(), TemplatesModel\preprocessForm(), LoginModel\preprocessForm(), ResetModel\preprocessForm(), Joomla\CMS\MVC\Model\preprocessForm(), ProfileModel\preprocessForm(), UserModel\preprocessForm(), LevelModel\preprocessForm(), FormModel\preprocessForm(), WorkflowModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), TransitionModel\preprocessForm(), BannerModel\preprocessForm(), StageModel\preprocessForm(), RegistrationModel\preprocessForm(), NewsfeedModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ItemsModel\preprocessForm(), ModuleModel\preprocessForm(), TaskModel\preprocessForm(), FieldModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), ConfigController\save(), StyleController\save(), OverrideController\save(), ComponentModel\save(), FormController\save(), FormField\setForm(), Grid\sort(), UnicodeString\startsWith(), ContactController\submit(), SubformRule\test(), ContactEmailRule\test(), FolderPathExistsRule\test(), OptionsRule\test(), CaptchaRule\test(), LoginUniqueFieldRule\test(), EqualsRule\test(), LogoutUniqueFieldRule\test(), UsernameRule\test(), ExecutionRulesRule\test(), EmailRule\test(), SetupModel\validate(), MenuModel\validate(), FormModel\validate(), LevelModel\validate(), TemplateModel\validate(), GroupModel\validate(), CategoryModel\validate(), RequestModel\validate(), ArticleModel\validate(), ModuleModel\validate(), FieldModel\validate(), ExecutionRulesRule\validateField(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ $input

$input = Factory::getApplication()->input

◆ $mediaTypes

if ( $tmpl=='component') $mediaTypes = $input->getString('mediatypes', '0')

Référencé par MediaField\getLayoutData(), et ApiModel\isMediaFile().

◆ $params

$params = ComponentHelper::getParams('com_media')

◆ $script

$script = $wa->getAsset('script', 'com_media.edit-images')->getUri(true)

Référencé par Text\_(), Text\alt(), Bootstrap\framework(), ModulepositionField\getInput(), CaBundle\isOpensslParseSafe(), HtmlDocument\mergeHeadData(), et Text\passSprintf().

◆ $tmpl

$tmpl = $input->getCmd('tmpl')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
  • media
Espaces de nommage | Variables
Référence du fichier administrator/components/com_media/tmpl/media/default.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$params = ComponentHelper::getParams('com_media')
$input = $app->input
$user = $app->getIdentity()
$wa = $this->document->getWebAssetManager()
$tmpl = $input->getCmd('tmpl')
if($tmpl==='component') $mediaTypes = '&mediatypes=' . $input->getString('mediatypes', '0,1,2,3')
$config

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $config

$config
Valeur initiale :
= [
'apiBaseUrl' => Uri::base() . 'index.php?option=com_media&format=json' . $mediaTypes
$mediaTypes
if($tmpl==='component') $mediaTypes
Definition: administrator/components/com_media/tmpl/media/default.php:41

◆ $input

$input = $app->input

◆ $mediaTypes

if ( $tmpl==='component') $mediaTypes = '&mediatypes=' . $input->getString('mediatypes', '0,1,2,3')

◆ $params

$params = ComponentHelper::getParams('com_media')

◆ $tmpl

$tmpl = $input->getCmd('tmpl')

◆ $user

$user = $app->getIdentity()

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
  • joomla
  • searchtools
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/layouts/joomla/searchtools/default.php

Espaces de nommage

Joomla\Administrator

Variables

$data = $displayData
$data ['options'] = !empty($data['options']) ? $data['options'] : array()
$noResultsText = ''
$hideActiveFilters = false
$showFilterButton = false
$showSelector = false
$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'
if(isset($data['view']->filterForm) &&!empty($data['view']->filterForm)) $customOptions
$data ['options'] = array_merge($customOptions, $data['options'])
$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'
$clientIdField = $data['view']->filterForm->getField('client_id')
if ( $clientIdField)
endif

Documentation des variables

◆ $clientIdField

$clientIdField = $data['view']->filterForm->getField('client_id')

◆ $customOptions

if (isset( $data[ 'view']->filterForm) &&!empty( $data[ 'view']->filterForm)) $customOptions
Valeur initiale :
= array(
'filtersHidden' => isset($data['options']['filtersHidden']) && $data['options']['filtersHidden'] ? $data['options']['filtersHidden'] : $hideActiveFilters,
'filterButton' => isset($data['options']['filterButton']) && $data['options']['filterButton'] ? $data['options']['filterButton'] : $showFilterButton,
'defaultLimit' => $data['options']['defaultLimit'] ?? Factory::getApplication()->get('list_limit', 20),
'searchFieldSelector' => '#filter_search',
'selectorFieldName' => $selectorFieldName,
'showSelector' => $showSelector,
'orderFieldSelector' => '#list_fullordering',
'showNoResults' => !empty($noResultsText),
'noResultsText' => !empty($noResultsText) ? $noResultsText : '',
'formSelector' => !empty($data['options']['formSelector']) ? $data['options']['formSelector'] : '#adminForm',
)
$noResultsText
$noResultsText
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:23
$showSelector
$showSelector
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:26
$hideActiveFilters
$hideActiveFilters
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:24
$selectorFieldName
$selectorFieldName
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:27
$data
$data
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:18
$showFilterButton
$showFilterButton
Definition: administrator/components/com_menus/layouts/joomla/searchtools/default.php:25

◆ $data [1/3]

$data = $displayData

◆ $data [2/3]

$data[ 'options'] = !empty($data['options']) ? $data['options'] : array()

◆ $data [3/3]

$data[ 'options'] = array_merge($customOptions, $data['options'])

◆ $filtersActiveClass

$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'

◆ $hideActiveFilters

$hideActiveFilters = false

◆ $noResultsText

$noResultsText = ''

◆ $selectorFieldName

$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'

◆ $showFilterButton

$showFilterButton = false

◆ $showSelector

$showSelector = false

◆ endif

endif

◆ if

if($clientIdField)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • items
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/items/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$app = Factory::getApplication()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$ordering = ($listOrder == 'a.lft')
$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')
$menuType = (string) $app->getUserState('com_menus.items.menutype', '')
if($saveOrder && $menuType &&!empty($this->items)) | $assoc = Associations::isEnabled() && $this->state->get('filter.client_id') == 0
< form action="<?php echo Route::_('index.php?option=com_menus&view=items&menutype='); ?> | method
endif
if ( $saveOrder &&$menuType)
$canCreate = $user->authorise('core.create', 'com_menus.menu.' . $item->menutype_id)
$canEdit = $user->authorise('core.edit', 'com_menus.menu.' . $item->menutype_id)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_menus.menu.' . $item->menutype_id) && $canCheckin
if($item->level > 1) | else
if($menuType) if(! $canChange) | elseif (! $saveOrder)
$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))
else __pad4__
else __pad5__
else __pad6__
else $item | language_title
else __pad7__
else $item | language_image
else $item $item array('title'=> $item->language_title) | true
else __pad8__
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assoc

if ( $saveOrder &&$menuType &&!empty( $this->items)) $assoc = Associations::isEnabled() && $this->state->get('filter.client_id') == 0

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_menus.menu.' . $item->menutype_id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_menus.menu.' . $item->menutype_id)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_menus.menu.' . $item->menutype_id)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $menuType

$menuType = (string) $app->getUserState('com_menus.items.menutype', '')

Référencé par ItemController\allowAdd(), ItemModel\batchCopy(), ItemModel\batchMove(), DisplayController\display(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), ItemsModel\getListQuery(), ItemsModel\getMenu(), MenusHelper\getMenuLinks(), MenuModel\getModules(), MenuParentField\getOptions(), MenuOrderingField\getOptions(), ItemsModel\populateState(), ItemModel\populateState(), ItemModel\save(), et MenuItemByTypeField\setup().

◆ $ordering

$ordering = ($listOrder == 'a.lft')

◆ $prefix

$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))

◆ $saveOrder

$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ else

if ( $item->level > 1) else
Valeur initiale :
{
$parentsStr = ''

◆ elseif

if ( $menuType) if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder && $menuType)

◆ language_image

else $item language_image

◆ language_title

else $item $item language_title

◆ method

<form action="<?php echo Route::_('index.php?option=com_menus&view=items&menutype='); ?> method
Valeur initiale :
="post" name="adminForm"
id="adminForm">
<div class="row">
<div class="col-md-12">
<div id="j-main-container" class="j-main-container">
<?php echo LayoutHelper::render('joomla.searchtools.default', array('view' => $this, 'options' => array('selectorFieldName' => 'menutype')))
name
$this name
Definition: default_cache.php:16
$this
else $this
Definition: administrator/components/com_modules/tmpl/module/edit.php:145

Référencé par Request\__construct(), ServerRequest\__construct(), OpenSSL\__construct(), LazyServiceEventListener\__construct(), LazyServiceEventListener\__invoke(), OpenSSL\decrypt(), OpenSSL\encrypt(), ApiController\execute(), OpenSSL\getBlockSize(), OpenSSL\setEncryptionMode(), Laminas\Diactoros\setMethod(), et MfaTable\store().

◆ true

else $item $item array ( 'title'=> $item->language_title) true

Référencé par StringStream\__construct(), Bootstrap\addSlide(), User\authorise(), KeyProtectedByPassword\changePassword(), AuthenticatorAttestationResponseValidator\check(), AuthenticatorAssertionResponseValidator\check(), CertificateToolbox\checkChain(), StringStream\close(), KeyProtectedByPassword\createRandomPasswordProtectedKey(), PublicKeyCredentialLoader\createResponse(), SSH2\exec(), PharInvocationResolver\findByAlias(), PharInvocationResolver\findByBaseName(), Boolean\fromBinary(), SSH2\get_channel_packet(), InstallerHelper\getDownloadKey(), SpacerField\getLabel(), PublicKeyCredentialLoader\loadArray(), PlgSystemAccessibility\onBeforeCompileHead(), PlgAuthenticationCookie\onUserAfterLogin(), PlgUserJoomla\onUserLogin(), PlgSystemLogout\onUserLogout(), HtmlView\prepareDocument(), FeedView\reconcileNames(), HTMLRegistry\register(), WebAssetRegistry\register(), Config\register(), Logger\register(), Pathway\register(), Dispatcher\register(), Toolbar\register(), CacheController\register(), Language\register(), Document\register(), User\register(), Form\register(), Database\register(), Menu\register(), Application\register(), Router\register(), Authentication\register(), Console\register(), SetConfigurationCommand\sanitizeOptions(), IpHelper\setAllowIpOverrides(), PlgSystemLanguageFilter\setLanguageCookie(), SetNewTagsEvent\setReplaceTags(), BeforeLoadEvent\setReset(), AfterStoreEvent\setResult(), AfterLoadEvent\setResult(), BeforeStoreEvent\setUpdateNulls(), CurlPost\submit(), et PharInvocationCollection\triggerDuplicateAliasWarning().


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menus
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/menus/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$uri = Uri::getInstance()
$return = base64_encode($uri)
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$modMenuId = (int) $this->get('ModMenuId')
$itemIds = []
else __pad16__
$canManageItems = $user->authorise('core.manage', 'com_menus.menu.' . (int) $item->id)
else __pad17__
endif
if ($canManageItems) ( $item->count_published > 0) ? ' btn-success'
else __pad18__
else __pad19__
else __pad20__
else __pad21__
endforeach

Documentation des variables

◆ $canManageItems

$canManageItems = $user->authorise('core.manage', 'com_menus.menu.' . (int) $item->id)

◆ $itemIds

$itemIds = []

Référencé par PlgSampledataBlog\addMenuItems(), MenuModel\delete(), MenuModel\getExtensionElementsForMenuItems(), CategoryModel\getItems(), et ArticlesModel\getItems().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $modMenuId

$modMenuId = (int) $this->get('ModMenuId')

◆ $return

$return = base64_encode($uri)

Référencé par DataSet\__call(), DataSet\__get(), DataSet\__isset(), RegistrationModel\activate(), ParagonIE_Sodium_Core32_Int32\addInt32(), ParagonIE_Sodium_Core32_Int64\addInt64(), HtmlView\addToolbar(), DatabaseModel\backupDatabase(), User\bind(), LanguageHelper\branchPlural(), LanguageHelper\branchSingular(), LegacyInstallerScript\callOnScript(), UserController\cancel(), ModuleController\cancel(), FormController\cancel(), MenuTable\check(), SetupModel\checkForm(), AdminController\checkin(), FileStorage\clean(), ToUnicode\convert(), TemplateModel\createOverride(), TemplateModel\createTemplateOverride(), MenuTable\delete(), TagTable\delete(), ArticleModel\delete(), TemplateModel\deleteFile(), TemplateModel\deleteFolder(), CleanupModel\deleteInstallationFolder(), HtmlView\display(), AssociationHelper\displayAssociations(), MysqliStatement\fetchData(), RulesFilter\filter(), CalendarField\filter(), SubformField\filter(), FormField\filter(), Date\format(), ParagonIE_Sodium_Core32_Int32\fromReverseString(), ParagonIE_Sodium_Core32_Int64\fromReverseString(), ParagonIE_Sodium_Core32_Int32\fromString(), ParagonIE_Sodium_Core32_Int64\fromString(), ParagonIE_Sodium_File\ftell(), AssociationHelper\getAssociations(), CategoryAssociationHelper\getCategoryAssociations(), UpdateModel\getCollectionDetailsUrls(), Table\getColumnAlias(), Adapter\getContentCount(), FilterModel\getFilter(), AbstractWebApplication\getHeaders(), FtpClient\getInstance(), FormModel\getItem(), LanguageModel\getItem(), MenuModel\getItem(), TemplateModel\getItem(), PluginModel\getItem(), StyleModel\getItem(), ModuleModel\getItem(), AdminModel\getItem(), Adapter\getItemMenuTitle(), MetadataRepository\getKnownAuthenticators(), Authentication\getKnownAuthenticators(), TemplateModel\getMaster(), TemplateController\getRedirectToItemAppend(), ArticleController\getRedirectToItemAppend(), ContactController\getRedirectToItemAppend(), FormController\getRedirectToItemAppend(), ArticleController\getReturnPage(), ContactController\getReturnPage(), LoginHelper\getReturnUri(), SuggestionsController\getSuggestions(), GroupModel\getTable(), LevelModel\getTable(), Form\getValue(), ClientHelper\hasCredentials(), ArrayHelper\invert(), Path\isOwner(), DataSet\jsonSerialize(), User\load(), LoginModel\loadFormData(), DisplayController\login(), DisplayController\logout(), UserController\logout(), FromUtf8\mapIso8859_1ToWindows1252(), ToUtf8\mapWindows1252ToIso8859_1(), ParagonIE_Sodium_Core32_Int32\mulInt32Fast(), ParagonIE_Sodium_Core32_Int64\mulInt64Fast(), ParagonIE_Sodium_Core32_Int32\mulIntFast(), ParagonIE_Sodium_Core32_Int64\mulIntFast(), ParagonIE_Sodium_Core32_Int64\orInt64(), Parser\parse(), FilesystemHelper\parseSize(), DatabaseModel\populateDatabase(), LoginModel\populateState(), FormModel\populateState(), ToolbarHelper\preferences(), RemindModel\processRemindRequest(), ResetModel\processResetComplete(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processStaticTaxonomy(), Query\processString(), FinderIndexCommand\purge(), RegistrationModel\register(), Event\removeArgument(), Html\removeBlocks(), AdminController\reorder(), AdminController\runTransition(), ConfigController\save(), TemplatesController\save(), UserController\save(), FormController\save(), TemplateModel\save(), AdminController\saveorder(), AdminController\saveOrderAjax(), ClientHelper\setCredentials(), ClientHelper\setCredentialsFromRequest(), Form\setFields(), TemplatesListField\setup(), UploaddirsField\setup(), SectionField\setup(), TypeField\setup(), ConfigurationModel\setup(), UserField\setup(), CategoryeditField\setup(), PredefinedlistField\setup(), ModuleorderField\setup(), PluginsField\setup(), TimezoneField\setup(), FileField\setup(), CheckboxField\setup(), TimeField\setup(), SubfieldsField\setup(), ConsentBoxField\setup(), CheckboxesField\setup(), SqlField\setup(), RulesField\setup(), NumberField\setup(), TextareaField\setup(), MenuField\setup(), MeterField\setup(), FolderlistField\setup(), FilelistField\setup(), PasswordField\setup(), CalendarField\setup(), ColorField\setup(), DataSet\toArray(), ParagonIE_Sodium_Core32_Int32\toInt32(), ParagonIE_Sodium_Core32_Int64\toInt32(), ParagonIE_Sodium_Core32_Int32\toInt64(), ParagonIE_Sodium_Core32_Int64\toInt64(), TemplateController\uploadFile(), SetupModel\validate(), FormModel\validate(), Form\validate(), ParagonIE_Sodium_Core32_Int32\xorInt32(), et ParagonIE_Sodium_Core32_Int64\xorInt64().

◆ $uri

$uri = Uri::getInstance()

Référencé par LangActiveAssetItem\__construct(), FeedPerson\__construct(), FeedLink\__construct(), WebAssetItem\__construct(), InstallModel\_getPackageFromUrl(), Feed\addCategory(), FeedEntry\addCategory(), Feed\addContributor(), FeedEntry\addContributor(), Uri\base(), AdministratorRouter\build(), Router\build(), SiteRouter\buildBase(), SiteRouter\buildComponentPreprocess(), SiteRouter\buildFormat(), SiteRouter\buildInit(), SiteRouter\buildPaginationData(), SiteRouter\buildRewrite(), PlgSystemLanguageFilter\buildRule(), SiteRouter\buildSefRoute(), MetadataService\buildUri(), CssMenu\check(), QuestionHelper\cloneInputStream(), SocketTransport\connect(), Socket\connect(), DistantSingleMetadataFactory\create(), Icon\create(), WebAssetRegistry\createAsset(), Router\createUri(), Uri\current(), HtmlDescriptor\describe(), AbstractWebApplication\detectRequestUri(), DisplayController\display(), HtmlView\display(), PreloadManager\dnsPrefetch(), Icon\edit(), MetadataStatementFetcher\fetch(), MetadataStatementFetcher\fetchMetadataStatement(), MetadataStatementFetcher\fetchTableOfContent(), Bootup\filterRequestUri(), RouteHelper\getAdvancedRoute(), FeedFactory\getFeed(), HtmlView\getFields(), TemplateModel\getFont(), FinderHelper\getGetFields(), TemplateModel\getImage(), NumberField\getInput(), TextField\getInput(), Uri\getInstance(), MediaField\getLayoutData(), MetadataService\getMetadataStatementFor(), MetadataService\getMetadataTOCPayload(), ListField\getOptions(), LoginHelper\getReturnUri(), ApiRouter\getRoutePath(), RouteHelper\getSearchRoute(), WebAssetItem\getUri(), Uri\isInternal(), Route\link(), PreloadManager\link(), CssMenu\load(), WebApplication\loadSystemUris(), AbstractWebApplication\loadSystemUris(), JavascriptRenderer\makeUriRelativeTo(), KeepaliveAssetItem\onAttachCallback(), PlgSystemLanguageFilter\onUserLogin(), FeedParser\parse(), Router\parse(), Uri\parse(), SiteRouter\parseCheckSSL(), SiteRouter\parseFormat(), SiteRouter\parseInit(), SiteRouter\parsePaginationData(), SiteRouter\parseRawRoute(), WebAssetRegistry\parseRegistryFile(), PlgSystemLanguageFilter\parseRule(), SiteRouter\parseSefRoute(), ConsoleApplication\populateHttpHost(), PlgSystemLanguageFilter\postprocessNonSEFBuildRule(), PlgSystemLanguageFilter\postprocessSEFBuildRule(), PreloadManager\preconnect(), ToolbarHelper\preferences(), PreloadManager\prefetch(), PreloadManager\preload(), Menu\preprocess(), CssMenu\preprocess(), PlgSystemLanguageFilter\preprocessBuildRule(), PreloadManager\prerender(), Router\processBuildRules(), AtomParser\processFeedEntry(), Router\processParseRules(), AbstractWebApplication\redirect(), WebAssetManager\registerAsset(), Curl\request(), Stream\request(), StreamTransport\request(), Socket\request(), CurlTransport\request(), SocketTransport\request(), ContentHelper\resolve(), Uri\root(), AdministratorApplication\route(), SiteApplication\route(), CMSApplication\route(), FeedEntry\setAuthor(), Feed\setAuthor(), Query\toUri(), Client\toUrl(), PunycodeHelper\urlToPunycode(), PunycodeHelper\urlToUTF8(), AndroidSafetyNetAttestationStatementSupport\validateUsingGoogleApi(), et Yubikey\validateYubikeyOtp().

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ ($canManageItems)

if ( $canManageItems)($item->count_trashed > 0) ? ' btn-danger' | ( |  | $item->,
 |  | 0 |
 | ) |  |

◆ __pad16__

else __pad16__

◆ __pad17__

else __pad17__

◆ __pad18__

else __pad18__

◆ __pad19__

else __pad19__

◆ __pad20__

else __pad20__

◆ __pad21__

else __pad21__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menutypes
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/menutypes/default.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input
$tmpl = ($input->getCmd('tmpl') != '') ? '1' : ''
$wa = $this->document->getWebAssetManager()
$i = 0
$menutype = base64_encode(json_encode($menutype))
endforeach

Documentation des variables

◆ $i

$i = 0

◆ $input

$input = Factory::getApplication()->input

◆ $menutype

$menutype = base64_encode(json_encode($menutype))

Référencé par MenuType\check(), CssMenu\check(), XmlView\display(), MultilangstatusHelper\getDefaultHomeModule(), AssociationsModel\getListQuery(), MenusHelper\getMenuItems(), ItemModel\getMenuType(), ItemController\getMenuTypeId(), ItemModel\getMenuTypeId(), MenusHelper\installPreset(), et CssMenu\load().

◆ $tmpl

$tmpl = ($input->getCmd('tmpl') != '') ? '1' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • config
Espaces de nommage | Variables
Référence du fichier administrator/components/com_messages/tmpl/config/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • message
Espaces de nommage
Référence du fichier administrator/components/com_messages/tmpl/message/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • messages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_messages/tmpl/messages/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad0__
endforeach
endif

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/modules/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$clientId = (int) $this->state->get('client_id', 0)
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = ($listOrder == 'a.ordering')
if ( $saveOrder &&!empty( $this->items))
endif
$canCreate = $user->authorise('core.create', 'com_modules')
$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $item->id)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $item->id) && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad3__
else __pad4__
if($item->position) | else
else __pad5__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_modules')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $item->id)

◆ $clientId

$clientId = (int) $this->state->get('client_id', 0)

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = ($listOrder == 'a.ordering')

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ else

if ( $item->position) else

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • select
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/select/default.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$function = $app->input->getCmd('function')
$wa = $this->document->getWebAssetManager()
endif
$name = $this->escape($item->name)
$desc = HTMLHelper::_('string.truncate', $this->escape(strip_tags($item->desc)), 200)
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $desc

$desc = HTMLHelper::_('string.truncate', $this->escape(strip_tags($item->desc)), 200)

Référencé par X509\getDN(), et PlgSystemDebug\onBeforeRespond().

◆ $function

$function = $app->input->getCmd('function')

◆ $name

string $name = $this->escape($item->name)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par TraceableTwigTemplate\__call(), TraceableTwigEnvironment\__call(), CacheController\__call(), LegacyInstallerScript\__call(), WebAssetManager\__call(), TraceablePDO\__call(), Input\__call(), ToolbarButton\__call(), Toolbar\__call(), Stream\__call(), BCMath\__callStatic(), Assert\__callStatic(), AsCommand\__construct(), ConstStub\__construct(), PublicKeyCredentialRpEntity\__construct(), PublicKeyCredentialEntity\__construct(), PublicKeyCredentialUserEntity\__construct(), FetchMediaItemsEvent\__construct(), FetchMediaItemEvent\__construct(), WorkflowFunctionalityUsedEvent\__construct(), WorkflowTransitionEvent\__construct(), FeatureEvent\__construct(), FetchMediaItemUrlEvent\__construct(), BeforeBatchEvent\__construct(), ExecuteTaskEvent\__construct(), AfterStoreEvent\__construct(), AfterDeleteEvent\__construct(), BeforeCheckinEvent\__construct(), BeforeDeleteEvent\__construct(), WebAssetRegistryAssetChanged\__construct(), DisplayEvent\__construct(), AfterLoadEvent\__construct(), AfterReorderEvent\__construct(), BeforeBindEvent\__construct(), BeforeCheckoutEvent\__construct(), BeforeLoadEvent\__construct(), LangActiveAssetItem\__construct(), BeforeStoreEvent\__construct(), SetNewTagsEvent\__construct(), BeforePublishEvent\__construct(), BeforeReorderEvent\__construct(), AfterMoveEvent\__construct(), AjaxInitCreate\__construct(), BeforeMoveEvent\__construct(), AbstractImmutableEvent\__construct(), GetIconEvent\__construct(), OnGetApiAttributes\__construct(), OnGetApiRelation\__construct(), NotifyActionLog\__construct(), FeedPerson\__construct(), OnGetApiFields\__construct(), OutputFormatter\__construct(), WebAssetItem\__construct(), RouterViewConfiguration\__construct(), Toolbar\__construct(), ToolbarButton\__construct(), Form\__construct(), AbstractEvent\__construct(), Table\__construct(), Response\__get(), CaptchaField\__get(), ModuleorderField\__get(), PluginsField\__get(), ModulesModuleField\__get(), ModulesPositionField\__get(), OrderingField\__get(), ModulepositionField\__get(), ChromestyleField\__get(), TimezoneField\__get(), FeedEntry\__get(), FileField\__get(), ModulesPositioneditField\__get(), CheckboxField\__get(), TemplatestyleField\__get(), Feed\__get(), CheckboxesField\__get(), SqlField\__get(), AccessiblemediaField\__get(), Input\__get(), MenuitemField\__get(), TextareaField\__get(), MeterField\__get(), SubformField\__get(), MenuItemByTypeField\__get(), RulesField\__get(), DataShapeObject\__get(), NumberField\__get(), MenuField\__get(), ComponentRecord\__get(), TaskOption\__get(), FolderlistField\__get(), FilelistField\__get(), PasswordField\__get(), TextField\__get(), CategoryeditField\__get(), ConsentBoxField\__get(), CalendarField\__get(), EditorField\__get(), ColorField\__get(), TimeField\__get(), Date\__get(), MediaField\__get(), CliApplication\__get(), ConsoleApplication\__get(), WebClient\__get(), AbstractWebApplication\__get(), ListField\__get(), Result\__get(), BaseDatabaseModel\__get(), FormField\__get(), DatabaseDriver\__get(), DatabaseQuery\__get(), InstallerAdapter\__get(), DataShapeObject\__isset(), Result\__isset(), ModuleorderField\__set(), PluginsField\__set(), ModulesModuleField\__set(), CaptchaField\__set(), ModulesPositionField\__set(), OrderingField\__set(), ModulepositionField\__set(), ChromestyleField\__set(), FeedEntry\__set(), TimeField\__set(), TimezoneField\__set(), FileField\__set(), Feed\__set(), ModulesPositioneditField\__set(), CheckboxField\__set(), TemplatestyleField\__set(), ConsentBoxField\__set(), CheckboxesField\__set(), SqlField\__set(), AccessiblemediaField\__set(), TextareaField\__set(), MenuitemField\__set(), MeterField\__set(), RulesField\__set(), NumberField\__set(), ComponentRecord\__set(), SubformField\__set(), MenuItemByTypeField\__set(), DataShapeObject\__set(), MenuField\__set(), FolderlistField\__set(), FilelistField\__set(), PasswordField\__set(), CategoryeditField\__set(), TextField\__set(), CalendarField\__set(), EditorField\__set(), ColorField\__set(), MediaField\__set(), Result\__set(), FormField\__set(), Rules\__toString(), Result\__unset(), BaseDatabaseModel\_createTable(), PlgEditorNone\_displayButtons(), ExtensionAdapter\_endElement(), CollectionAdapter\_endElement(), Update\_endElement(), TransitionTable\_getAssetParentId(), StageTable\_getAssetParentId(), CacheStorage\_getCacheId(), FileStorage\_getFilePath(), Captcha\_load(), Editor\_loadEditor(), PlgContentLoadmodule\_loadmod(), HtmlDocument\_parseTemplate(), HtmlView\_setPath(), ExtensionAdapter\_startElement(), CollectionAdapter\_startElement(), Update\_startElement(), Access\actions(), AlgorithmManager\add(), Mail\add(), PHPMailer\addAddress(), PHPMailer\addAnAddress(), ArrayInput\addArgument(), MailTemplate\addAttachment(), Mail\addAttachment(), PHPMailer\addAttachment(), OnGetApiAttributes\addAttribute(), Mail\addBcc(), PHPMailer\addBCC(), Feed\addCategory(), FeedEntry\addCategory(), Mail\addCc(), PHPMailer\addCC(), PDOCollector\addConnection(), Stream\addContextEntry(), Feed\addContributor(), FeedEntry\addContributor(), JavascriptRenderer\addControl(), PHPMailer\addCustomHeader(), SysinfoModel\addDirectory(), PHPMailer\addEmbeddedImage(), Sidebar\addEntry(), WebAssetRegistry\addExtensionRegistryFile(), AsymmetricKey\addFileFormat(), Sidebar\addFilter(), TraceableTwigEnvironment\addFilter(), TraceableTwigEnvironment\addFunction(), TraceableTwigEnvironment\addGlobal(), WebAssetManager\addInline(), Pathway\addItem(), ArrayInput\addLongOption(), ArgvInput\addLongOption(), Form\addNode(), ListField\addOption(), PHPMailer\addOrEnqueueAnAddress(), Tobscure\JsonApi\addPaginationLink(), MenusHelper\addPreset(), MailTemplate\addRecipient(), Mail\addRecipient(), Mail\addReplyTo(), PHPMailer\addReplyTo(), SimpleMetadataStatementRepository\addService(), SimpleMetadataStatementRepository\addSingleStatement(), PHPMailer\addStringEmbeddedImage(), ColorProcessor\addStyle(), TraceableTwigEnvironment\addTest(), Zip\addToZipFile(), PlgExtensionJoomla\addUpdateSite(), Laminas\Diactoros\assertHeader(), HeaderSecurity\assertValidName(), WebAssetManager\assetExists(), Access\assetgrouplist(), PHPMailer\attachAll(), Select\booleanlist(), Resource\buildRelationships(), WebAssetManager\calculateOrderOfActiveAssets(), HTMLHelper\calendar(), LegacyInstallerScript\callOnScript(), TransitionModel\canEditState(), StageModel\canEditState(), SplCaster\castFileObject(), NewsfeedTable\check(), BannerTable\check(), DebugClassLoader\checkAnnotations(), DebugClassLoader\checkClass(), LocalAdapter\checkContent(), TemplateModel\checkNewName(), CMSApplication\checkUserRequireReset(), Session\clear(), AbstractWebApplication\clearHeaders(), Email\cloak(), PDOCollector\collect(), TimeDataCollector\collect(), DebugBar\collect(), ProfileCollector\collect(), TraceableTwigEnvironment\compileSource(), TraceableTwigEnvironment\computeAlternatives(), Builder\configureClaim(), Connection\connect(), Parser\convertItems(), Builder\convertItems(), LocalAdapter\copy(), JWSSerializerManagerFactory\create(), Factory\create(), WebAssetRegistry\createAsset(), Factory\createBasic(), Toolbar\createChild(), Factory\createConfig(), MVCFactory\createController(), ModuleDispatcherFactory\createDispatcher(), ComponentDispatcherFactory\createDispatcher(), PrivacyPlugin\createDomain(), Factory\createEqualsTo(), ApiModel\createFile(), LocalAdapter\createFile(), TemplateController\createFile(), TemplateModel\createFile(), ApiModel\createFolder(), LocalAdapter\createFolder(), TemplateModel\createFolder(), FormFactory\createForm(), Factory\createGreaterOrEqualsTo(), Factory\createLesserOrEqualsTo(), ApiMVCFactory\createModel(), LegacyFactory\createModel(), MVCFactory\createModel(), BaseController\createModel(), ContenthistoryHelper\createObjectArray(), TemplateModel\createOverride(), ApiMVCFactory\createTable(), LegacyFactory\createTable(), MVCFactory\createTable(), ContainerAwareToolbarFactory\createToolbar(), LegacyFactory\createView(), MVCFactory\createView(), BaseController\createView(), ContenthistoryHelper\decodeFields(), Input\def(), MapsModel\delete(), IndexModel\delete(), StyleModel\delete(), ModuleModel\delete(), AdminModel\delete(), Stream\deleteContextEntry(), PhpHttpDriver\deleteSessionValue(), JoomlaHttpDriver\deleteSessionValue(), Uri\delVar(), TextDescriptor\describeApplication(), MarkdownDescriptor\describeInputOption(), TextDescriptor\describeJoomlaApplication(), WebClient\detectHeaders(), WebAssetManager\disableAsset(), JavascriptRenderer\disableControl(), WebAssetManager\disablePresetItems(), JavascriptRenderer\disableVendor(), HtmlView\display(), TraceableTwigTemplate\display(), Captcha\display(), TraceableTwigEnvironment\display(), Editor\display(), TraceableTwigTemplate\displayBlock(), PlgEditorCodemirror\displayButtons(), TraceableTwigTemplate\displayParentBlock(), StyleModel\duplicate(), WebAssetManager\enableDependencies(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), Changelog\endElement(), Core\ensureConstantExists(), Core\ensureFunctionExists(), Crypto\EnsureFunctionExists(), WebAssetRegistry\exists(), Input\exists(), AmqpCaster\extractFlags(), ApplicationDescription\extractNamespace(), ArticleModel\featured(), ConfirmButton\fetchButton(), LinkButton\fetchButton(), StandardButton\fetchButton(), PopupButton\fetchButton(), StandardButton\fetchButtonClass(), Form\filter(), Form\findField(), Form\findFieldsByFieldset(), SimpleMetadataStatementRepository\findOneByAAGUIDFromServices(), SimpleMetadataStatementRepository\findOneByAAGUIDFromSingleStatements(), ToolbarButton\findOptionName(), SqlsrvQuery\fixGroupColumns(), RegisteredClaimGiven\forClaim(), Builder\forwardCallToCorrectClaimMethod(), Uuid\fromString(), ContactTable\generateAlias(), PlgUserContactCreator\generateAliasAndName(), EvalBarrett\generateInlineTrim(), FieldModel\generateNewTitle(), Select\genericlist(), DataSet\get(), AttestationStatementSupportManager\get(), ContainerCommandLoader\get(), FactoryCommandLoader\get(), ContainerLoader\get(), HelperSet\get(), Files\get(), WritableContainerLoader\get(), ValidationData\get(), WebAssetRegistry\get(), JoomlaStorage\get(), NativeStorage\get(), Input\get(), Session\get(), Adapter\getAdapter(), ProviderManager\getAdapter(), Installer\getAdapters(), OpenSSH\getAlias(), ApcuStorage\getAll(), WincacheStorage\getAll(), Rules\getAllowed(), PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), MysqliImporter\getAlterTableSql(), XmlDescriptor\getApplicationDocument(), Input\getArgument(), InputDefinition\getArgument(), AbstractEvent\getArgument(), WebAssetManager\getAsset(), FieldTable\getAssetId(), WebAssetManager\getAssets(), WebAssetManager\getAssetState(), MailTemplate\getAttachmentName(), Entry\getAttributeKey(), TraceableTwigEnvironment\getCacheFilename(), TracksModel\getCategoryName(), Token\getClaim(), Token\getClaims(), TracksModel\getClientName(), DebugBar\getCollector(), ApplicationDescription\getCommand(), WebAssetManager\getConnectionsGraph(), SourceContextProvider\getContext(), Dispatcher\getController(), ComponentDispatcher\getController(), DebugBar\getDataAsHeaders(), Dispatcher\getDefaultEvent(), DatabaseFactory\getDriver(), DatabaseImporter\getDropColumnSql(), MysqlImporter\getDropKeySql(), MysqliImporter\getDropKeySql(), PgsqlImporter\getDropSequenceSql(), Result\getElement(), CaBundle\getEnvVariable(), Dispatcher\getEvent(), TraceableTwigEnvironment\getExtension(), Form\getField(), Form\getFieldAttribute(), Table\getFields(), Form\getFieldsets(), Form\getFieldXml(), TemplateModel\getFile(), TraceableTwigEnvironment\getFilter(), ArgvInput\getFirstArgument(), TransitionModel\getForm(), ProgressBar\getFormatDefinition(), ProgressIndicator\getFormatDefinition(), ContenthistoryHelper\getFormValues(), TraceableTwigEnvironment\getFunction(), TemplatestyleField\getGroups(), Token\getHeader(), Laminas\Diactoros\getHeaderLine(), Token\getHeaders(), AbstractWebApplication\getHeaders(), HelperFactory\getHelper(), Module\getHelper(), SubformField\getInput(), Form\getInput(), JsonDescriptor\getInputDefinitionData(), InstalledVersions\getInstalledPackagesByType(), Pathway\getInstance(), WebApplication\getInstance(), Toolbar\getInstance(), CliApplication\getInstance(), CMSApplication\getInstance(), Form\getInstance(), DebuguserModel\getItems(), DebuggroupModel\getItems(), DatabaseFactory\getIterator(), JavascriptRenderer\getJsControlsDefinitionCode(), Form\getLabel(), UserField\getLayoutData(), ModuleorderField\getLayoutData(), FormField\getLayoutData(), PluginHelper\getLayoutPath(), MenusHelper\getLinkKey(), LoginModel\getLoginModule(), CMSApplication\getMenu(), ProgressBar\getMessage(), Document\getMetaData(), CaptiveModel\getMethodImage(), NewsfeedsController\getModel(), PreviewController\getModel(), LanguagesController\getModel(), MessagesController\getModel(), RequestsController\getModel(), PluginsController\getModel(), HistoryController\getModel(), IndexController\getModel(), TagsController\getModel(), CategoriesController\getModel(), TasksController\getModel(), LevelsController\getModel(), NotesController\getModel(), ClientsController\getModel(), FiltersController\getModel(), MapsController\getModel(), FieldsController\getModel(), GroupsController\getModel(), TracksController\getModel(), AssociationsController\getModel(), MenusController\getModel(), ItemsController\getModel(), DisplayController\getModel(), BannersController\getModel(), StylesController\getModel(), ContactController\getModel(), UsersController\getModel(), ModulesController\getModel(), UpdatesitesController\getModel(), WorkflowsController\getModel(), FeaturedController\getModel(), LinksController\getModel(), TransitionsController\getModel(), StagesController\getModel(), ContactsController\getModel(), ArticlesController\getModel(), ActionlogsController\getModel(), AbstractView\getModel(), TemplateController\getModel(), ArticleController\getModel(), ApiController\getModel(), FormController\getModel(), BaseController\getModel(), ModuleHelper\getModule(), PublicKeyCredentialEntity\getName(), LanguageStringsCollector\getName(), SessionCollector\getName(), InfoCollector\getName(), LanguageErrorsCollector\getName(), LanguageFilesCollector\getName(), XmlDocument\getName(), WebAssetItem\getName(), BaseModel\getName(), QueryCollector\getName(), RouterView\getName(), ConsoleApplication\getName(), SubformField\getName(), ToolbarButton\getName(), Form\getName(), CMSApplication\getName(), InstallerAdapter\getName(), BaseController\getName(), FormField\getName(), DatabaseDriver\getName(), JNamespacePsr4Map\getNamespaces(), ASN1\getOID(), ConnectionOptions\getOption(), Connection\getOption(), Input\getOption(), InputDefinition\getOption(), ActionButton\getOption(), ToolbarButton\getOption(), ConnectionOptions\getOptionName(), CategoryeditField\getOptions(), TemplateModel\getOverridesFolder(), InstallerScript\getParam(), TracedStatement\getParameters(), Installer\getParams(), Installer\getPath(), SiteApplication\getPathway(), ProgressBar\getPlaceholderFormatterDefinition(), ProgressIndicator\getPlaceholderFormatterDefinition(), MenusHelper\getPresets(), Symfony\Contracts\Service\getProvidedServices(), DatabaseFactory\getQuery(), AbstractSerializer\getRelationship(), AbstractSerializer\getRelationshipMethodName(), RouteHelper\getRoute(), AdministratorApplication\getRouter(), SiteApplication\getRouter(), ConsoleApplication\getRouter(), CMSApplication\getRouter(), TemplateModel\getSafeName(), LocalAdapter\getSafeName(), SMTP\getServerExt(), DatabaseDriver\getServerType(), PhpHttpDriver\getSessionValue(), JoomlaHttpDriver\getSessionValue(), ContentHistory\getSha1(), PdoStorage\getSqlQuery(), OutputFormatter\getStyle(), Table\getStyleDefinition(), GroupModel\getTable(), RequestModel\getTable(), RemoveModel\getTable(), RemindModel\getTable(), ConfirmModel\getTable(), FormModel\getTable(), TemplateModel\getTable(), ExportModel\getTable(), BaseDatabaseModel\getTable(), TaskModel\getTable(), FieldModel\getTable(), TraceableTwigEnvironment\getTemplateClass(), TraceableTwigEnvironment\getTest(), PhpToken\getTokenName(), UpdateAdapter\getUpdateSiteName(), ListModel\getUserStateFromRequest(), ArrayHelper\getValue(), Form\getValue(), RulesRule\getValueActions(), AbstractUri\getVar(), PharInvocation\getVariable(), DisplayController\getView(), BaseController\getView(), InfoCollector\getWidgets(), LanguageFilesCollector\getWidgets(), Cache\getWorkarounds(), TransitionModel\getWorkflow(), SqlsrvQuery\group(), Select\groupedlist(), RssParser\handleWebmaster(), AttestationStatementSupportManager\has(), FactoryCommandLoader\has(), DataSet\has(), ContainerCommandLoader\has(), HelperSet\has(), ContainerLoader\has(), WritableContainerLoader\has(), ValidationData\has(), JoomlaStorage\has(), NativeStorage\has(), Session\has(), Input\hasArgument(), InputDefinition\hasArgument(), TraceableTwigTemplate\hasBlock(), Token\hasClaim(), DebugBar\hasCollector(), TraceableTwigEnvironment\hasExtension(), Token\hasHeader(), InputDefinition\hasNegation(), Input\hasOption(), InputDefinition\hasOption(), PhpHttpDriver\hasSessionValue(), JoomlaHttpDriver\hasSessionValue(), InputDefinition\hasShortcut(), TimeDataCollector\hasStartedMeasure(), ProfileCollector\hasStartedMeasure(), OutputFormatter\hasStyle(), AbstractUri\hasVar(), PHPMailer\headerLine(), HTMLHelper\iframe(), JavascriptRenderer\ignoreCollector(), ListHelper\images(), ApplicationDescription\inspectApplication(), UpdateModel\install(), Select\integerlist(), WebAssetManager\isAssetActive(), ConnectionOptions\isOption(), TraceableTwigEnvironment\isTemplateFresh(), PublicKeyCredentialEntity\jsonSerialize(), TraceablePDO\lastInsertId(), Access\level(), ToolbarHelper\link(), Folder\listFolderTree(), CssMenu\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), Adapter\loadAllAdapters(), Asset\loadByName(), ManageModel\loadChangelog(), FormHelper\loadClass(), DaemonApplication\loadConfiguration(), XML\loadCurveByParam(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), PluginAdapter\loadLanguage(), AsymmetricKey\loadPlugins(), MenusHelper\loadPreset(), SubformField\loadSubForm(), TraceableTwigEnvironment\loadTemplate(), Pathway\makeItem(), Laminas\Diactoros\marshalHeadersFromSapi(), Laminas\Diactoros\marshalUriFromSapi(), TimeDataCollector\measure(), ProfileCollector\measure(), Menu\menuItemList(), Rules\merge(), DatabaseQuery\merge(), ContenthistoryHelper\mergeLabels(), Form\mergeNode(), Form\mergeNodes(), LocalAdapter\move(), InstallerScript\moveCliFiles(), FeedParser\moveToClosingElement(), FeedParser\moveToNextElement(), ToolbarButton\name(), AbstractImmutableEvent\offsetSet(), AbstractImmutableEvent\offsetUnset(), PlgSystemDebug\onBeforeRespond(), PlgContentLoadmodule\onContentPrepare(), PlgUserJoomla\onContentPrepareForm(), PlgUserTerms\onContentPrepareForm(), PlgSystemPrivacyconsent\onContentPrepareForm(), PlgUserProfile\onContentPrepareForm(), FieldsListPlugin\onCustomFieldsPrepareDom(), PlgButtonPagebreak\onDisplay(), PlgEditorNone\onDisplay(), PlgButtonMenu\onDisplay(), PlgButtonContact\onDisplay(), PlgButtonArticle\onDisplay(), PlgButtonModule\onDisplay(), PlgButtonFields\onDisplay(), PlgButtonImage\onDisplay(), PlgButtonReadmore\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), PlgUserContactCreator\onUserAfterSave(), ListHelper\ordering(), Parser\parse(), PHPMailer\parseAddresses(), SMTP\parseHelloFields(), ArgvInput\parseLongOption(), SysinfoModel\parsePhpInfo(), WebAssetRegistry\parseRegistryFile(), ArgvInput\parseShortOption(), ArgvInput\parseShortOptionSet(), Installer\parseXMLInstallFile(), TransitionModel\populateState(), WorkflowModel\populateState(), StageModel\populateState(), ListModel\populateState(), ListHelper\positions(), ApiController\postFiles(), Form\postProcess(), CategoryModel\preprocessForm(), ItemsModel\preprocessForm(), ManageModel\publish(), MapsModel\publish(), IndexModel\publish(), AdminModel\publish(), ApiController\putFiles(), DatabaseQuery\qn(), DatabaseDriver\qn(), XML\query(), DatabaseDriver\quoteName(), DatabaseQuery\quoteName(), DatabaseDriver\quoteNameString(), Select\radiolist(), Zip\readZipInfo(), UpdatesitesModel\rebuild(), WebAssetRegistry\remove(), JoomlaStorage\remove(), NativeStorage\remove(), Session\remove(), Entry\removeAttribute(), FeedEntry\removeCategory(), Feed\removeCategory(), TraceableTwigEnvironment\removeExtension(), Form\removeField(), TemplateModel\renameFile(), MessageRenderer\render(), TraceableTwigEnvironment\render(), TraceableTwigTemplate\renderBlock(), ErrorHandler\renderException(), Form\renderField(), Form\renderFieldset(), TraceableTwigTemplate\renderParentBlock(), TextView\renderSection(), ConfigPostProcessor\replaceDependencyAliases(), Table\resolveStyle(), WorkflowModel\save(), StageModel\save(), MediumModel\save(), FieldModel\save(), TransitionModel\save(), ComponentModel\save(), LanguageModel\save(), TemplateModel\save(), CategoryModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), PuTTY\savePrivateKey(), JWSSerializerManager\serialize(), Cookie\set(), JoomlaStorage\set(), Session\set(), Input\set(), NativeStorage\set(), Builder\set(), PHPMailer\set(), Adapter\setAdapter(), Input\setArgument(), AbstractEvent\setArgument(), Entry\setAttribute(), FeedEntry\setAuthor(), Feed\setAuthor(), Table\setColumnStyle(), Result\setElement(), Form\setFieldAttribute(), ProgressBar\setFormatDefinition(), Builder\setHeader(), AbstractWebApplication\setHeader(), PhpHttpDriver\setHeaders(), JoomlaHttpDriver\setHeaders(), Pathway\setItemName(), ProgressBar\setMessage(), Document\setMetaData(), AbstractView\setModel(), XmlDocument\setName(), JsonDocument\setName(), RouterViewConfiguration\setName(), Session\setName(), NativeStorage\setName(), Connection\setOption(), Input\setOption(), ActionButton\setOption(), ToolbarButton\setOption(), JavascriptRenderer\setOptions(), InstallerScript\setParams(), RouterViewConfiguration\setParent(), Installer\setPath(), ProgressBar\setPlaceholderFormatterDefinition(), ProgressIndicator\setPlaceholderFormatterDefinition(), Builder\setRegisteredClaim(), MailTemplate\setReplyTo(), PhpHttpDriver\setSessionValue(), JoomlaHttpDriver\setSessionValue(), OpensearchDocument\setShortName(), OutputFormatter\setStyle(), Table\setStyle(), Table\setStyleDefinition(), SqlField\setup(), TemplateAdapter\setupUninstall(), Form\setValue(), Uri\setVar(), PharInvocation\setVariable(), JavascriptRenderer\setVariableName(), ApplicationDescription\sortCommands(), Changelog\startElement(), TimeDataCollector\startMeasure(), ProfileCollector\startMeasure(), TimeDataCollector\stopMeasure(), ProfileCollector\stopMeasure(), FileAdapter\storeExtension(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), TemplateAdapter\storeExtension(), TemplateModel\storeFileInfo(), BufferStreamHandler\stream_open(), BufferStreamHandler\stream_write(), Jquery\token(), TraceableTwigEnvironment\tokenize(), CaptiveModel\translateMethodName(), JWSSerializerManager\unserialize(), Captcha\update(), LanguageAdapter\update(), LocalAdapter\updateFile(), ApiModel\updateFile(), WebAssetManager\useAsset(), WebAssetManager\usePresetItems(), Access\usergroup(), Access\usergroups(), ListHelper\users(), UuidFactory\uuid3(), Uuid\uuid3(), UuidFactory\uuid5(), Uuid\uuid5(), UuidFactory\uuidFromNsAndName(), Ramsey\Uuid\v3(), Ramsey\Uuid\v5(), Form\validate(), X509\validateURL(), Builder\with(), Builder\withClaim(), Builder\withHeader(), et Connection\write().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Espaces de nommage | Variables
Référence du fichier administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
$assoc = Associations::isEnabled()
if ( $saveOrder &&!empty( $this->items))
else __pad0__
endif
$canCreate = $user->authorise('core.create', 'com_newsfeeds.category.' . $item->catid)
$canEdit = $user->authorise('core.edit', 'com_newsfeeds.category.' . $item->catid)
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', 'com_newsfeeds.category.' . $item->catid) && $item->created_by == $user->id
$canChange = $user->authorise('core.edit.state', 'com_newsfeeds.category.' . $item->catid) && $canCheckin
$iconClass = ''
if(! $canChange) elseif (! $saveOrder)
else __pad1__
endforeach

Documentation des variables

◆ $assoc

$assoc = Associations::isEnabled()

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_newsfeeds.category.' . $item->catid) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_newsfeeds.category.' . $item->catid)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_newsfeeds.category.' . $item->catid)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', 'com_newsfeeds.category.' . $item->catid) && $item->created_by == $user->id

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder &&! empty$this->items )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
  • plugins
Espaces de nommage | Variables
Référence du fichier administrator/components/com_plugins/tmpl/plugins/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'ordering'
if ( $saveOrder)
else __pad1__
endif
$canEdit = $user->authorise('core.edit', 'com_plugins')
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_plugins') && $canCheckin
$iconClass = ''
if(! $canChange) elseif (! $saveOrder)
else __pad2__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_plugins') && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_plugins')

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = $listOrder == 'ordering'

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder) ( $saveOrder )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • tmpl
  • messages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_postinstall/tmpl/messages/default.php

Espaces de nommage

Joomla\Administrator

Variables

$adminFormClass = count($this->extension_options) > 1 ? 'form-inline mb-3' : 'visually-hidden'
endif
endforeach

Documentation des variables

◆ $adminFormClass

$adminFormClass = count($this->extension_options) > 1 ? 'form-inline mb-3' : 'visually-hidden'

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • capabilities
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/capabilities/default.php

Espaces de nommage

Joomla\Administrator

Variables

else __pad0__
else __pad1__
endforeach
endif

Documentation des variables

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • consents
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/consents/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$now = Factory::getDate()
$stateIcons = array(-1 => 'delete', 0 => 'archive', 1 => 'publish')
$stateMsgs
else __pad2__
endforeach
endif

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $now

$now = Factory::getDate()

Référencé par Task\acquireLock(), ValidAt\assert(), ValidAt\assertExpiration(), ValidAt\assertIssueTime(), ValidAt\assertMinimumTime(), DateCaster\castInterval(), DateCaster\castPeriod(), TagsSimilarHelper\getList(), TasksModel\getListQuery(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), TaskModel\getTask(), Token\hasBeenIssuedBefore(), Token\isExpired(), PlgSystemPrivacyconsent\onAfterRender(), PlgSystemActionLogs\onAfterRespond(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgAuthenticationCookie\onUserAuthenticate(), PlgSystemPrivacyconsent\remindExpiringConsents(), AtomRenderer\render(), StringWrapper\url_stat(), et StreamString\url_stat().

◆ $stateIcons

$stateIcons = array(-1 => 'delete', 0 => 'archive', 1 => 'publish')

◆ $stateMsgs

$stateMsgs
Valeur initiale :
= array(
-1 => Text::_('COM_PRIVACY_CONSENTS_STATE_INVALIDATED'),
0 => Text::_('COM_PRIVACY_CONSENTS_STATE_OBSOLETE'),
1 => Text::_('COM_PRIVACY_CONSENTS_STATE_VALID')
)

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • request
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/request/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
else __pad3__
foreach ( $this->actionlogs as $i=> $item)
endforeach
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad3__

else __pad3__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->actionlogs as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • requests
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/requests/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$now = Factory::getDate()
$urgentRequestDate = clone $now
else __pad4__
endif
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $now

$now = Factory::getDate()

◆ $urgentRequestDate

$urgentRequestDate = clone $now

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Espaces de nommage | Variables
Référence du fichier administrator/components/com_redirect/tmpl/links/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad0__
$canChange = $user->authorise('core.edit.state', 'com_redirect')
else __pad1__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_redirect')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • select
Espaces de nommage | Variables
Référence du fichier administrator/components/com_scheduler/tmpl/select/default.php

Espaces de nommage

Joomla\Administrator

Variables

$app = $this->app
$wa = $this->document->getWebAssetManager()
foreach($this->items as $item) $name = $this->escape($item->title)
$desc = HTMLHelper::_('string.truncate', $this->escape(strip_tags($item->desc)), 200)
endforeach

Documentation des variables

◆ $app

$app = $this->app

◆ $desc

$desc = HTMLHelper::_('string.truncate', $this->escape(strip_tags($item->desc)), 200)

◆ $name

foreach ( $this->items as $item) $name = $this->escape($item->title)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • tasks
Espaces de nommage | Variables
Référence du fichier administrator/components/com_scheduler/tmpl/tasks/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
try
catch(Exception $e) | $user = $app->getIdentity()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
$section = null
$mode = false
endif
if ( $saveOrder)
$canEdit = $user->authorise('core.edit', 'com_scheduler')
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_scheduler') && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad1__
endforeach
$modalparams
$modalbody = '<div class="p-3"></div>'

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_scheduler') && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_scheduler')

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $modalbody

$modalbody = '<div class="p-3"></div>'

◆ $modalparams

$modalparams
Valeur initiale :
= [
'title' => ''

◆ $mode

$mode = false

Référencé par Aes\__construct(), Stream\__construct(), UserGroupsHelper\__construct(), ContainerResource\__construct(), PlgContentEmailcloak\_cloak(), FtpClient\_findMode(), Stream\_getFilename(), FtpClient\_mode(), LazyCommand\addArgument(), AbstractCommand\addArgument(), Command\addArgument(), LazyCommand\addOption(), AbstractCommand\addOption(), Command\addOption(), FtpClient\append(), Stream\attach(), SplCaster\castDoublyLinkedList(), RedisCaster\castRedis(), FtpClient\chmod(), Stream\chmod(), SFTP\chmod(), WincacheStorage\clean(), ApcuStorage\clean(), FileStorage\clean(), RedisStorage\clean(), MemcachedStorage\clean(), Cache\clean(), QuestionHelper\cloneInputStream(), PdoStatement\convertFetchMode(), PublicKeyCredentialDescriptorCollection\count(), AuthenticationExtensionsClientInputs\count(), AuthenticationExtensionsClientOutputs\count(), JWKSet\count(), Construct\count(), Folder\create(), Psr17Factory\createStreamFromFile(), StreamFactory\createStreamFromFile(), Image\flip(), FilesystemHelper\ftpChmod(), Helper\ftpChmod(), FtpClient\get(), PKCS1\getEncryptionMode(), ArticlesCategoryHelper\getList(), MenusHelper\getMenuLinks(), Path\getPermissions(), Tar\getTarInfo(), Grapheme\grapheme_position(), Iconv\iconv_mime_decode(), Iconv\iconv_mime_decode_headers(), Stream\isReadable(), PlgSystemStats\isUpdateRequired(), Stream\isWritable(), X509\loadCRL(), X509\loadCSR(), X509\loadX509(), Mbstring\mb_convert_case(), PharStreamWrapper\mkdir(), SFTP\mkdir(), SFTP\mkdir_helper(), Stream\open(), SFTP\parseMode(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), Query\processString(), SFTP\put(), FtpClient\read(), SSH2\read(), MailModel\send(), Mail\sendMail(), Container\set(), Mcrypt\setEncryptionMode(), OpenSSL\setEncryptionMode(), Stream\setStream(), CMSApplication\setupLogging(), RSA\sign(), FtpClient\store(), PharStreamWrapper\stream_open(), TranscodeUnicode\ucs4array_utf7(), TranscodeUnicode\utf7_ucs4array(), TranscodeUnicode\utf8_ucs4array(), RSA\verify(), et FtpClient\write().

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $section

$section = null

◆ $user

catch (Exception $e) $user = $app->getIdentity()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad1__

else __pad1__

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($saveOrder)

◆ try

try
Valeur initiale :
{
$app = Factory::getApplication()
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage | Variables
Référence du fichier administrator/components/com_tags/tmpl/tags/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = Factory::getUser()
$userId = $user->get('id')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')
$extension = $this->escape($this->state->get('filter.extension'))
$parts = explode('.', $extension)
$component = $parts[0]
$section = null
$mode = false
if(count($parts) > 1) if($section==='categories') | if ( $saveOrder &&!empty( $this->items))
else __pad0__
endif
$canCreate = $user->authorise('core.create', 'com_tags')
$canEdit = $user->authorise('core.edit', 'com_tags')
$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_tags') && $canCheckin
if($item->level > 1) | else
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad1__
else __pad2__
if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_published'))
if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_unpublished'))
if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_archived'))
if (isset( $this->items[0]) &&property_exists( $this->items[0], 'count_trashed'))
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_tags') && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.manage', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_tags')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_tags')

◆ $component

$component = $parts[0]

◆ $extension

$extension = $this->escape($this->state->get('filter.extension'))

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $mode

$mode = false

◆ $parts

$parts = explode('.', $extension)

◆ $saveOrder

$saveOrder = ($listOrder == 'a.lft' && strtolower($listDirn) == 'asc')

◆ $section

$section = null

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->get('id')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ else

if ( $item->level > 1) else
Valeur initiale :
{
$parentsStr = ''

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if [1/5]

if($saveOrder) ( $saveOrder &&! empty$this->items )

◆ if [2/5]

if(isset($this->items[0]) &&property_exists($this->items[0], 'count_published'))

◆ if [3/5]

if(isset($this->items[0]) &&property_exists($this->items[0], 'count_unpublished'))

◆ if [4/5]

if(isset($this->items[0]) &&property_exists($this->items[0], 'count_archived'))

◆ if [5/5]

if(isset($this->items[0]) &&property_exists($this->items[0], 'count_trashed'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • styles
Espaces de nommage | Variables
Référence du fichier administrator/components/com_templates/tmpl/styles/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$clientId = (int) $this->state->get('client_id', 0)
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
$canEdit = $user->authorise('core.edit', 'com_templates')
$canChange = $user->authorise('core.edit.state', 'com_templates')
else __pad0__
else __pad1__
else __pad2__
else $item | language_title
else __pad3__
else $item | image
else $item $item array('title'=> $item->language_title) | true
else __pad4__
else __pad5__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_templates')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_templates')

◆ $clientId

$clientId = (int) $this->state->get('client_id', 0)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ endforeach

endforeach

◆ endif

endif

◆ image

string $src The path and filename of the image
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HtmlView\display(), Language\store(), et HTMLHelper\tooltip().

◆ language_title

else $item $item language_title

◆ true

else $item $item array ( 'title'=> $item->language_title) true


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier administrator/components/com_templates/tmpl/template/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$input = Factory::getApplication()->input
if ( $this->type=='font')

Documentation des variables

◆ $input

$input = Factory::getApplication()->input

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ if

if($this->type=='font')


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • templates
Espaces de nommage | Variables
Référence du fichier administrator/components/com_templates/tmpl/templates/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
foreach ( $this->items as $i=> $item)
else __pad8__
else __pad9__
else __pad10__
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad10__

else __pad10__

◆ __pad8__

else __pad8__

◆ __pad9__

else __pad9__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • captive
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/captive/default.php

Espaces de nommage

Joomla\Administrator

Variables

$model = $this->getModel()
if(!empty($this->title)) endif

Documentation des variables

◆ $model

$model = $this->getModel()

Référencé par MessageController\action(), LinksController\activate(), UsersController\activate(), InstallerScript\addDashboardMenu(), ItemController\allowEdit(), TransitionController\allowEdit(), MessageController\archive(), TagController\batch(), GroupController\batch(), BannerController\batch(), NewsfeedController\batch(), LinksController\batch(), UserController\batch(), FieldController\batch(), ModuleController\batch(), FormController\batch(), FormController\cancel(), ContentSerializer\category(), NewsfeedSerializer\category(), ContactSerializer\category(), UsersController\changeBlock(), SetConfigurationCommand\checkDb(), AdminController\checkin(), InfoCollector\collect(), CategoryView\commonCategoryDisplay(), ContentSerializer\createdBy(), ContactSerializer\createdBy(), NewsfeedSerializer\createdBy(), TemplateController\createFile(), ApiMVCFactory\createModel(), MVCFactory\createModel(), BaseController\createModel(), OverridesController\delete(), LevelController\delete(), AdminController\delete(), MediaController\delete(), TemplateController\delete(), DisplayController\display(), HtmlView\display(), CheckJoomlaUpdatesCommand\doExecute(), UpdateCoreCommand\doExecute(), StylesController\duplicate(), ModulesController\duplicate(), LinksController\duplicateUrls(), FormController\edit(), FormController\editAssociations(), MenuController\exportXml(), AbstractView\get(), UserModel\getGroups(), AbstractSerializer\getId(), MenutypeField\getInput(), CategoryModel\getItems(), RequestController\getJson(), ArticlesPopularHelper\getList(), LatestHelper\getList(), BannersHelper\getList(), PopularHelper\getList(), DatabaseController\getMenuBadgeData(), DisplayController\getMenuBadgeData(), DiscoverController\getMenuBadgeData(), UpdateController\getMenuBadgeData(), ItemController\getMenuTypeId(), BaseController\getModel(), MenusModel\getModules(), LanguageField\getNativeLanguage(), DisplayController\getQuickiconContent(), PluginsController\getQuickiconContent(), CategoriesController\getQuickiconContent(), ItemsController\getQuickiconContent(), TagsController\getQuickiconContent(), ModulesController\getQuickiconContent(), ArticlesController\getQuickiconContent(), UsersController\getQuickiconContent(), AbstractSerializer\getRelationship(), SuggestionsController\getSuggestions(), PlgWorkflowNotification\getUsersFromGroup(), PlgSystemSchedulerunner\injectLazyJS(), PlgWorkflowFeaturing\isSupported(), PlgWorkflowPublishing\isSupported(), Joomla\CMS\Workflow\isWorkflowActive(), HistoryController\keep(), ContentSerializer\languageAssociations(), ContactSerializer\languageAssociations(), NewsfeedSerializer\languageAssociations(), DisplayController\login(), DisplayController\logout(), ContentSerializer\modifiedBy(), NewsfeedSerializer\modifiedBy(), ContactSerializer\modifiedBy(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), PlgWorkflowPublishing\onContentVersioningPrepareTable(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), PlgWorkflowNotification\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), TemplateController\overrides(), ArticleController\postSaveHook(), ContactController\postSaveHook(), GroupController\postSaveHook(), WorkflowController\postSaveHook(), FieldController\postSaveHook(), ModuleController\postSaveHook(), CategoryController\postSaveHook(), RequestController\postSaveHook(), StylesController\preprocessSaveData(), ExtensionDiscoverCommand\processDiscover(), TemplateController\publish(), ItemsController\publish(), AdminController\publish(), ActionlogsController\purge(), LinksController\purge(), FinderIndexCommand\purge(), AdminController\reorder(), MessageController\republish(), SearchesController\reset(), AdminController\runTransition(), ConfigController\save(), StyleController\save(), OverrideController\save(), ModuleController\save(), MessageModel\save(), FormController\save(), SetConfigurationCommand\saveConfiguration(), AdminController\saveorder(), AdminController\saveOrderAjax(), MailController\send(), InstalledController\setDefault(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), AbstractView\setModel(), ContactController\submit(), InstalledController\switchAdminLanguage(), MessageController\unpublish(), TemplateController\uploadFile(), ContactSerializer\userId(), et ArticleController\vote().

◆ endif

if (!empty( $this->title)) endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • debuggroup
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/debuggroup/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endforeach
foreach($this->actions as $action) | $check = $item->checks[$name]
if($check===true) | $button = 'btn-success'
$text = Text::_('COM_USERS_DEBUG_EXPLICIT_ALLOW')
else __pad0__
endif

Documentation des variables

◆ $button

string $button = 'btn-success'

Référencé par Toolbar\__call(), Toolbar\appendButton(), Icons\button(), Icons\buttons(), Icon\create(), Editor\getButtons(), PlgButtonMenu\onDisplay(), PlgButtonPagebreak\onDisplay(), PlgButtonModule\onDisplay(), PlgButtonContact\onDisplay(), PlgButtonArticle\onDisplay(), PlgButtonFields\onDisplay(), PlgButtonImage\onDisplay(), PlgButtonReadmore\onDisplay(), Toolbar\prependButton(), Toolbar\render(), Toolbar\renderButton(), et ToolbarHelper\saveGroup().

◆ $check

foreach ( $this->actions as $action) $check = $item->checks[$name]

Référencé par ToolbarHelper\addNew(), MediaHelper\canUpload(), ToolbarHelper\checkin(), Autoloader\createAppendAutoloader(), TemplateModel\createFile(), Autoloader\createPrependAutoloader(), MenuField\getGroups(), ItemsModel\getMenu(), UpdateModel\install(), ZIPExtraction\isIgnoredDirectory(), ToolbarHelper\publish(), ToolbarHelper\trash(), et ToolbarHelper\unpublish().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $text

$text = Text::_('COM_USERS_DEBUG_EXPLICIT_ALLOW')

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • debuguser
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/debuguser/default.php

Espaces de nommage

Joomla\Administrator

Variables

$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$loginActions = []
$actions = []
foreach($this->actions as $action) if(in_array($name, ['core.login.site', 'core.login.admin', 'core.login.offline', 'core.login.api', 'core.admin'])) | else
endif
endforeach
foreach($loginActions as $action) | $check = $this->items[0]->checks[$name]
if($check===true) | $button = 'btn-success'
$text = Text::_('COM_USERS_DEBUG_EXPLICIT_ALLOW')
else __pad1__
else __pad2__

Documentation des variables

◆ $actions

$actions = []

Référencé par Access\actions(), PostgresqlChangeItem\buildCheckQuery(), RC2\decryptBlock(), RC2\encryptBlock(), ContentHelper\getActions(), Access\getActionsFromData(), DebugHelper\getDebugActions(), RulesRule\getFieldActions(), DebuguserModel\getItems(), DebuggroupModel\getItems(), RulesRule\getValueActions(), Rules\merge(), Rules\mergeCollection(), et RC2\setupInlineCrypt().

◆ $button

$button = 'btn-success'

◆ $check

foreach ( $actions as $action) $check = $this->items[0]->checks[$name]

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $loginActions

$loginActions = []

◆ $text

$text = Text::_('COM_USERS_DEBUG_EXPLICIT_ALLOW')

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ else

foreach ( $this->actions as $action) if (in_array( $name, [ 'core.login.site', 'core.login.admin', 'core.login.offline', 'core.login.api', 'core.admin'])) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • groups
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/groups/default.php

Espaces de nommage

Joomla\Administrator

Variables

$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$wa = $this->document->getWebAssetManager()
else __pad3__
$canEdit = $user->authorise('core.edit', 'com_users')
if(! $user->authorise('core.admin') &&Access::checkGroup($item->id, 'core.admin')) $canChange = $user->authorise('core.edit.state', 'com_users')
endif
else __pad4__
endforeach

Documentation des variables

◆ $canChange

if (! $user->authorise( 'core.admin') &&Access::checkGroup( $item->id, 'core.admin')) $canChange = $user->authorise('core.edit.state', 'com_users')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_users')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • levels
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/levels/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'a.ordering'
if ( $saveOrder &&!empty( $this->items))
else __pad5__
endif
$count = count($this->items)
$canCreate = $user->authorise('core.create', 'com_users')
$canEdit = $user->authorise('core.edit', 'com_users')
$canChange = $user->authorise('core.edit.state', 'com_users')
$groups = json_decode($item->rules)
if (!Factory::getUser() ->authorise( 'core.admin') &&$groups &&Access::checkGroup( $groups[0], 'core.admin'))
$iconClass = ''
if(! $canChange) elseif (! $saveOrder)
else __pad6__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_users')

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_users')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_users')

◆ $count

$count = count($this->items)

◆ $groups

$groups = json_decode($item->rules)

Référencé par UserGroupsHelper\__construct(), Categories\_load(), UserModel\batchUser(), ContactModel\buildContactExtendedData(), LevelModel\canDelete(), Category\categories(), CategoryView\commonCategoryDisplay(), GetConfigurationCommand\configure(), GroupModel\delete(), HtmlView\display(), ListUserCommand\doExecute(), DeleteUserCommand\doExecute(), Form\filter(), Form\findGroup(), UserGroupsHelper\getAll(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), Access\getAuthorisedViewLevels(), Taxonomy\getBranchTitles(), Form\getFieldset(), Form\getGroup(), Access\getGroupPath(), UserMessagesField\getGroups(), MenuField\getGroups(), ContentmapField\getGroups(), GroupedlistField\getGroups(), TimezoneField\getGroups(), TemplatestyleField\getGroups(), ChromestyleField\getGroups(), AddUserToGroupCommand\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), FieldLayoutField\getInput(), FiltersField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), UserGroupsHelper\getInstance(), NewsfeedModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), Adapter\getItemMenuTitle(), UsersModel\getItems(), ArticlesModel\getItems(), TagsHelper\getItemTags(), TagsPopularHelper\getList(), TagsSimilarHelper\getList(), SuggestionsModel\getListQuery(), FeaturedModel\getListQuery(), GroupsModel\getListQuery(), SearchModel\getListQuery(), FieldsModel\getListQuery(), TagsModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), SubformField\getName(), FormField\getName(), Taxonomy\getNodeByTitle(), WhosonlineHelper\getOnlineUserNames(), UsergrouplistField\getOptions(), CategoryeditField\getOptions(), PlgSystemUpdatenotification\getSuperUsers(), TagsHelper\getTagItemsQuery(), HtmlView\getTagsTitle(), AddUserCommand\getUserGroups(), UsersLatestHelper\getUsers(), PlgWorkflowNotification\getUsersFromGroup(), UsersHelper\getVisibleByGroups(), User\groups(), Token\isInAllowedUserGroup(), PlgUserToken\isInAllowedUserGroup(), Form\load(), UserGroupsHelper\loadAll(), Category\options(), FormHelper\parseShowOnConditions(), GroupsModel\populateExtraData(), UserGroupsHelper\populateGroupsData(), UsersModel\populateState(), Form\postProcess(), PlgContentFields\prepare(), Query\processDynamicTaxonomy(), GetConfigurationCommand\processGroupOptions(), Query\processStaticTaxonomy(), TagsHelper\searchTags(), Filter\select(), UserGroupsHelper\setGroups(), Filter\slider(), User\store(), Access\usergroups(), LevelModel\validate(), et Form\validate().

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = $listOrder == 'a.ordering'

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if [1/2]

if($saveOrder) ( $saveOrder &&! empty$this->items )

◆ if [2/2]

if(!Factory::getUser() ->authorise('core.admin') && $groups &&Access::checkGroup($groups[0], 'core.admin'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • mail
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/mail/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$comUserParams = ComponentHelper::getParams('com_users')
endif

Documentation des variables

◆ $comUserParams

$comUserParams = ComponentHelper::getParams('com_users')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/methods/default.php

Espaces de nommage

Joomla\Administrator

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • notes
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/notes/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad7__
$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', 'com_users.category.' . $item->catid) && $canCheckin
$subject = $item->subject ?: Text::_('COM_USERS_EMPTY_SUBJECT')
endif
else __pad8__
else __pad9__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_users.category.' . $item->catid) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_checkin') || $item->checked_out == $user->get('id') || is_null($item->checked_out)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $subject

$subject = $item->subject ?: Text::_('COM_USERS_EMPTY_SUBJECT')

Référencé par PlgExtensionNamespacemap\__construct(), PlgContentVote\__construct(), PlgSystemLogout\__construct(), PlgSystemActionLogs\__construct(), Joomlaupdate\__construct(), Cache\__construct(), CMSPlugin\__construct(), PlgSystemLanguageFilter\__construct(), Webauthn\__construct(), Adapter\__construct(), PlgSystemHttpHeaders\__construct(), ArrayHelper\addColumn(), Subject\addUse(), Subject\addUsedIn(), Joomla\Component\Scheduler\Administrator\Traits\advertiseRoutines(), MailHelper\cleanSubject(), MailTemplate\createTemplate(), Resolver\determineInvalidSubjects(), PHPMailer\DKIM_Add(), PHPMailer\doCallback(), Ldap\escape(), Adapter\escape(), Resolver\findByElement(), Resolver\findByElementId(), ConsentsModel\invalidateAll(), Token\isRelatedTo(), PHPMailer\mailPassthru(), Resolver\markSubjectAsInvalid(), PlgWorkflowFeaturing\onContentVersioningPrepareTable(), PlgWorkflowPublishing\onContentVersioningPrepareTable(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), Parser\preg_match(), ServiceProviderInterface\register(), RegistrationModel\register(), Builder\relatedTo(), MessageModel\save(), MailModel\send(), Email\sendCode(), Mail\sendMail(), ValidationData\setSubject(), Mail\setSubject(), Builder\setSubject(), X509\sign(), et MailTemplate\updateTemplate().

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ __pad9__

else __pad9__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • users
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/users/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$loggeduser = Factory::getUser()
$mfa = PluginHelper::isEnabled('multifactorauth')
else __pad12__
endif
$canChange = $loggeduser->authorise('core.edit.state', 'com_users')
if ((! $loggeduser->authorise( 'core.admin')) &&Access::check( $item->id, 'core.admin'))
else __pad13__
$self = $loggeduser->id == $item->id
else __pad14__
else HTMLHelper::_('users.blockStates', $self) $item | block
else HTMLHelper::_('users.blockStates', $self) $item | $i
else HTMLHelper::_('users.blockStates', $self) $item | false
$activated = empty($item->activation) ? 0 : 1
if | ($mfa) ( $item->mfaRecords > 0||!empty( $item->otpKey))
else __pad15__
else __pad16__
else __pad17__
endforeach

Documentation des variables

◆ $activated

$activated = empty($item->activation) ? 0 : 1

◆ $canChange

$canChange = $loggeduser->authorise('core.edit.state', 'com_users')

◆ $i

else HTMLHelper::_ ( 'users.blockStates', $self) $item $i

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $loggeduser

$loggeduser = Factory::getUser()

◆ $mfa

$mfa = PluginHelper::isEnabled('multifactorauth')

◆ $self

$self = $loggeduser->id == $item->id

Référencé par Users\blockStates(), et SplFixedArray\fromArray().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ ($mfa)

if ( $mfa)($item->mfaRecords > 0||!empty($item->otpKey))

◆ __pad12__

else __pad12__

◆ __pad13__

else __pad13__

◆ __pad14__

else __pad14__

◆ __pad15__

else __pad15__

◆ __pad16__

else __pad16__

◆ __pad17__

else __pad17__

◆ block

else HTMLHelper::_ ( 'users.blockStates', $self) $item block

Référencé par Application\doExecute(), et User\store().

◆ endforeach

endforeach

◆ endif

endif

◆ false

else false

◆ if

if((! $loggeduser->authorise('core.admin')) &&Access::check($item->id, 'core.admin'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • stages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/stages/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$userId = $user->id
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrderingUrl = ''
$saveOrder = ($listOrder == 's.ordering')
if ( $saveOrder)
if(!empty($this->sidebar)) | endif
if(!empty($this->sidebar)) | else
else __pad0__
$canEdit = $user->authorise('core.edit', $this->extension . '.stage.' . $item->id)
$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $userId || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', $this->extension . '.stage.' . $item->id) && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad1__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', $this->extension . '.stage.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', $this->extension . '.stage.' . $item->id)

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = ($listOrder == 's.ordering')

◆ $saveOrderingUrl

$saveOrderingUrl = ''

Référencé par DraggableList\draggable(), et SortableList\sortable().

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->id

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ else

if (!empty( $this->sidebar)) else
Valeur initiale :
{
echo 'col-md-12'

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($canEdit) ( $saveOrder )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • transitions
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/transitions/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrderingUrl = ''
$saveOrder = ($listOrder == 't.ordering')
if ( $saveOrder)
if(!empty($this->sidebar)) | endif
if(!empty($this->sidebar)) | else
else __pad2__
$canEdit = $user->authorise('core.edit', $this->extension . '.transition.' . $item->id)
$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $user->id || is_null($item->checked_out)
$canChange = $user->authorise('core.edit.state', $this->extension . '.transition.' . $item->id) && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad3__
else __pad4__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', $this->extension . '.transition.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $user->id || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', $this->extension . '.transition.' . $item->id)

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $saveOrder

$saveOrder = ($listOrder == 't.ordering')

◆ $saveOrderingUrl

$saveOrderingUrl = ''

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ else

if (!empty( $this->sidebar)) else
Valeur initiale :
{
echo 'col-md-12'

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($canEdit) ( $saveOrder )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • workflows
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/workflows/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$saveOrder = $listOrder == 'w.ordering'
$orderingColumn = 'created'
$saveOrderingUrl = ''
if(strpos($listOrder, 'modified') !==false) if($saveOrder) | $extension = $this->escape($this->state->get('filter.extension'))
$user = Factory::getUser()
$userId = $user->id
if(!empty($this->sidebar)) | endif
if(!empty($this->sidebar)) | else
else __pad5__
if ( $saveOrder)
$transitions = Route::_('index.php?option=com_workflow&view=transitions&workflow_id=' . $item->id . '&extension=' . $extension)
$edit = Route::_('index.php?option=com_workflow&task=workflow.edit&id=' . $item->id . '&extension=' . $extension)
$canEdit = $user->authorise('core.edit', $extension . '.workflow.' . $item->id)
$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $userId || is_null($item->checked_out)
$canEditOwn = $user->authorise('core.edit.own', $extension . '.workflow.' . $item->id) && $item->created_by == $userId
$canChange = $user->authorise('core.edit.state', $extension . '.workflow.' . $item->id) && $canCheckin
$iconClass = ''
if(! $canChange) | elseif (! $saveOrder)
else __pad6__
endforeach

Documentation des variables

◆ $canChange

$canChange = $user->authorise('core.edit.state', $extension . '.workflow.' . $item->id) && $canCheckin

◆ $canCheckin

$canCheckin = $user->authorise('core.admin', 'com_workflow') || $item->checked_out == $userId || is_null($item->checked_out)

◆ $canEdit

$canEdit = $user->authorise('core.edit', $extension . '.workflow.' . $item->id)

◆ $canEditOwn

$canEditOwn = $user->authorise('core.edit.own', $extension . '.workflow.' . $item->id) && $item->created_by == $userId

◆ $edit

$edit = Route::_('index.php?option=com_workflow&task=workflow.edit&id=' . $item->id . '&extension=' . $extension)

◆ $extension

if (strpos( $listOrder, 'modified') !==false) if ( $saveOrder) $extension = $this->escape($this->state->get('filter.extension'))

◆ $iconClass

$iconClass = ''

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $orderingColumn

$orderingColumn = 'created'

◆ $saveOrder

$saveOrder = $listOrder == 'w.ordering'

◆ $saveOrderingUrl

$saveOrderingUrl = ''

◆ $transitions

$transitions = Route::_('index.php?option=com_workflow&view=transitions&workflow_id=' . $item->id . '&extension=' . $extension)

◆ $user

$user = Factory::getUser()

◆ $userId

$userId = $user->id

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ else

if (!empty( $this->sidebar)) else
Valeur initiale :
{
echo 'col-md-12'

◆ elseif

if (! $canChange) elseif(! $saveOrder)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($canEdit|| $canEditOwn) ( $saveOrder )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_custom
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_custom/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_feed/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

if(empty($rssurl)) if(!empty($feed) &&is_string($feed)) | else
$myrtl = $params->get('rssrtl', 0)
$direction = ' '
if($lang->isRtl() && $myrtl==0) elseif($lang->isRtl() && $myrtl==1) elseif($lang->isRtl() && $myrtl==2) elseif($myrtl==0) elseif($myrtl==1) elseif($myrtl==2) | if ( $feed !=false)
endif
$uri = $feed[$i]->uri || !$feed[$i]->isPermaLink ? trim($feed[$i]->uri) : trim($feed[$i]->guid)
$text = $feed[$i]->content !== '' ? trim($feed[$i]->content) : ''
else __pad0__

Documentation des variables

◆ $direction

$direction = ' '
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par PluginsModel\_getList(), HTMLHelper\calendar(), PositionsModel\getItems(), CalendarField\getLayoutData(), RequestsModel\getListQuery(), ConsentsModel\getListQuery(), SearchModel\getListQuery(), ArticlesCategoryHelper\groupBy(), ArticlesCategoryHelper\groupByDate(), ArticlesCategoryHelper\groupByTags(), PlgSystemAccessibility\onBeforeCompileHead(), SearchesModel\populateState(), PositionsModel\populateState(), ClientsModel\populateState(), LevelsModel\populateState(), GroupsModel\populateState(), StagesModel\populateState(), StylesModel\populateState(), CheckinModel\populateState(), TransitionsModel\populateState(), DiscoverModel\populateState(), MessagesModel\populateState(), WorkflowsModel\populateState(), PluginsModel\populateState(), ActionlogsModel\populateState(), UpdateModel\populateState(), AssociationsModel\populateState(), TracksModel\populateState(), ManageModel\populateState(), FeaturedModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), NewsfeedsModel\populateState(), CacheModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), TagsModel\populateState(), LinksModel\populateState(), InstalledModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ArticlesModel\populateState(), FiltersModel\populateState(), RequestsModel\populateState(), ConsentsModel\populateState(), OverridesModel\populateState(), TemplatesModel\populateState(), MenusModel\populateState(), NotesModel\populateState(), LanguagesModel\populateState(), DatabaseModel\populateState(), BannersModel\populateState(), MapsModel\populateState(), HistoryModel\populateState(), IndexModel\populateState(), TasksModel\populateState(), UpdatesitesModel\populateState(), ListModel\populateState(), Grid\sort(), SearchTools\sort(), et ArrayHelper\sortObjects().

◆ $myrtl

$myrtl = $params->get('rssrtl', 0)

◆ $text

$text = $feed[$i]->content !== '' ? trim($feed[$i]->content) : ''

◆ $uri

$uri = $feed[$i]->uri || !$feed[$i]->isPermaLink ? trim($feed[$i]->uri) : trim($feed[$i]->guid)

◆ __pad0__

else __pad0__

◆ else

if (empty( $rssurl)) if (!empty( $feed) &&is_string( $feed)) else
Valeur initiale :
{
$lang = $app->getLanguage()
$lang
$lang
Definition: administrator/components/com_categories/tmpl/categories/emptystate.php:22
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85

◆ endif

endif

◆ if

if(!empty($uri)) ( $feed ! = false )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_frontend
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_frontend/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_latest/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$moduleId = str_replace(' ', '', $module->title) . $module->id
endif
if ( $item->link)
else __pad0__
else ENT_QUOTES
endforeach
else __pad1__

Documentation des variables

◆ $moduleId

$moduleId = str_replace(' ', '', $module->title) . $module->id

Référencé par ModuleAdapter\_rollback_menu(), ModuleAdapter\_rollback_module(), PlgSampledataMultilang\addModuleInModuleMenu(), et ModuleController\orderPosition().

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ ENT_QUOTES

else ENT_QUOTES

Référencé par PlgContentPagebreak\_createToc(), HelpButton\_getCommand(), Nested\_logtable(), AdministratorService\association(), Menus\association(), BannerTable\check(), TaskTable\check(), InputFilter\checkAttribute(), InputFilter\cleanAttributes(), InputFilter\decode(), FeedView\display(), SMTP\edebug(), PHPMailer\edebug(), BaseLayout\escape(), HtmlView\escape(), AssociationsHelper\getAssociationHtmlList(), InstalledModel\getData(), ActionlogsHelper\getHumanReadableLogMessage(), FiltersField\getInput(), TracedStatement\getParameters(), PHPMailer\html2text(), Joomla\onAfterDispatch(), ModuleController\orderPosition(), Html\parse(), HtmlView\prepareDocument(), ClientModel\prepareTable(), NewsfeedModel\prepareTable(), ContactModel\prepareTable(), ModuleModel\prepareTable(), Query\processString(), Language\tokenise(), StringHelper\truncate(), et Configuration\value().

◆ if

if($item->link)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_latestactions/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

if (count($list)) ( $list as $i=> $item)
endforeach
else __pad0__
endif

Documentation des variables

◆ (count($list))

if (count( $list))($list as $i=> $item)

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_logged/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

else __pad0__
endif
foreach ($users as $user) (isset( $user->editLink))
else __pad1__
else ENT_QUOTES
else __pad2__
endforeach

Documentation des variables

◆ ($users as $user)

foreach ( $users as $user)(isset($user->editLink))

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif

◆ ENT_QUOTES

else ENT_QUOTES


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_login/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $app->getDocument()->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_loginsupport
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_loginsupport/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_menu/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$doc = $app->getDocument()
$class = $enabled ? 'nav flex-column main-nav' : 'nav flex-column main-nav disabled'
$wa = $doc->getWebAssetManager()

Documentation des variables

◆ $class

string $class = $enabled ? 'nav flex-column main-nav' : 'nav flex-column main-nav disabled'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par Language\__construct(), JLoader\_autoload(), JLoader\_load(), HtmlErrorRenderer\abbrClass(), OtherObjectManager\add(), TagObjectManager\add(), Log\addLogEntry(), Bootstrap\addSlide(), JLoader\applyAliasFor(), HTMLHelper\calendar(), Caster\castObject(), AbstractCloner\castObject(), ExceptionCaster\castThrowingCasterException(), DebugClassLoader\checkAnnotations(), DebugClassLoader\checkCase(), DebugClassLoader\checkClass(), ClassNotFoundErrorEnhancer\classExists(), Identifier\create(), Autoloader\createAppendAutoloader(), CacheControllerFactory\createCacheController(), Autoloader\createPrependAutoloader(), Engine\createRecurringModuloFunction(), Factory\createRenderer(), LegacyComponent\createRouter(), JLoader\discover(), Captcha\display(), Application\doRenderThrowable(), SeekingData\dump(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), CliDumper\enterHash(), HtmlDumper\enterHash(), ClassNotFoundErrorEnhancer\findClassInPath(), DebugClassLoader\findFile(), ClassLoader\findFile(), ClassLoader\findFileWithExtension(), EvalBarrett\generateCustomReduction(), Php80\get_debug_type(), Installer\getAdapters(), HttpFactory\getAvailableDriver(), Language\getCallerInfo(), ClassNotFoundErrorEnhancer\getClassCandidates(), ContentType\getContentTable(), LanguageStringsCollector\getData(), Command\getDefaultDescription(), Command\getDefaultName(), AbstractCommand\getDefaultName(), DatabaseFactory\getDriver(), Factory\getFormat(), Session\getHandlers(), CssMenu\getIconClass(), PrefixField\getInput(), ImptotalField\getInput(), MenutypeField\getInput(), Parser\getInstance(), CacheController\getInstance(), Language\getInstance(), ChangeItem\getInstance(), BaseController\getInstance(), DatabaseFactory\getIterator(), DatabaseDriver\getIterator(), TosField\getLabel(), SpacerField\getLabel(), NoteField\getLabel(), FormField\getLayoutData(), LanguagesHelper\getList(), DebugClassLoader\getOwnInterfaces(), LazyString\getPrettyName(), DatabaseFactory\getQuery(), AbstractRenderer\getRenderer(), QueryCollector\getStatements(), Cache\getStores(), Assertion\implementsInterface(), JLoader\import(), PlgFinderCategories\index(), ToolbarHelper\inlinehelp(), ContainerControllerResolver\instantiateController(), ControllerResolver\instantiateController(), Assert\isAnyOf(), Assert\isAOf(), Assert\isInstanceOf(), Assert\isInstanceOfAny(), Assert\isNotA(), HtmlDumper\leaveHash(), JLoader\load(), Installer\loadAdapter(), JLoader\loadAliasFor(), Adapter\loadAllAdapters(), JLoader\loadByAlias(), JLoader\loadByPsr(), JLoader\loadByPsr4(), ClassLoader\loadClass(), FormHelper\loadClass(), DebugClassLoader\loadClass(), ComposerAutoloaderInit2399d40fc48ada3450e844df0430bf2f\loadClassLoader(), DatabaseDriver\loadObject(), DatabaseDriver\loadObjectList(), FormHelper\loadType(), BigInteger\max(), BigInteger\min(), ToolbarHelper\modal(), MontgomeryMult\multiplyReduce(), Base\multiplyReduce(), Assert\notInstanceOf(), Php\objectToString(), PlgCaptchaRecaptcha\onDisplay(), PlgCaptchaRecaptcha_Invisible\onDisplay(), OpenSSL\powModHelper(), Base\powModHelper(), GMP\powModInner(), BCMath\powModInner(), PHP\powModInner(), StandardButton\prepareOptions(), PowerOfTwo\prepareReduce(), Montgomery\prepareReduce(), Base\prepareReduce(), AddConsoleCommandPass\process(), BigInteger\random(), BigInteger\randomPrime(), BigInteger\randomRange(), BigInteger\randomRangePrime(), Classic\reduce(), PowerOfTwo\reduce(), Barrett\reduce(), Montgomery\reduce(), LoggerRegistry\register(), JLoader\register(), Log\registerLogger(), Barrett\regularBarrett(), BigInteger\scan1divide(), Adapter\setAdapter(), Archive\setAdapter(), TraceableTwigEnvironment\setBaseTemplateClass(), DebugClassLoader\setReturnType(), Montgomery\slidingWindow(), Engine\slidingWindow(), Base\squareReduce(), JLoader\stripFirstBackslash(), HtmlDumper\style(), Assert\subclassOf(), LdapUserProvider\supportsClass(), Assert\throws(), ArrayHelper\toObject(), HTMLHelper\tooltip(), et ExceptionCaster\traceUnshift().

◆ $doc

$doc = $app->getDocument()

Référencé par XPath\__construct(), DocumentRenderer\__construct(), Bootstrap\alert(), Bootstrap\button(), DebugClassLoader\checkAnnotations(), DraggableList\draggable(), AssociationField\getInput(), Behavior\highlighter(), PlgSystemSef\onAfterDispatch(), PlgSystemLanguageFilter\onAfterDispatch(), CoreAssetItem\onAttachCallback(), KeepaliveAssetItem\onAttachCallback(), PlgButtonImage\onDisplay(), PlgButtonReadmore\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onInit(), PlgInstallerWebinstaller\onInstallerAddInstallationTab(), JavascriptRenderer\render(), JavascriptRenderer\renderHead(), et Jquery\token().

◆ $wa

$wa = $doc->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_messages
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_messages/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$hideLinks = $app->input->getBool('hidemainmenu')
if($hideLinks|| $countUnread< 1) $route = 'index.php?option=com_messages&view=messages'

Documentation des variables

◆ $hideLinks

$hideLinks = $app->input->getBool('hidemainmenu')

◆ $route

if ( $hideLinks||$countUnread< 1) $route = 'index.php?option=com_messages&view=messages'

Référencé par Result\__serialize(), Router\addRoute(), Router\addRoutes(), AdministratorRouter\build(), SiteRouter\buildFormat(), SiteRouter\buildRewrite(), InstallerAdapter\doDatabaseTransactions(), WebApplication\doExecute(), FinderHelper\getGetFields(), ApiRouter\getMatchingRoutes(), InstallerAdapter\getRoute(), ApiApplication\handlePreflight(), PlgWebservicesContact\onBeforeApiRoute(), ApiRouter\parseApiRoute(), SiteRouter\parseFormat(), Router\parseRoute(), SiteRouter\parseSefRoute(), HtmlView\prepareDocument(), ControllerResolver\resolve(), InstallerAdapter\setRoute(), et Installer\setupInstall().


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_multilangstatus
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_multilangstatus/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$hideLinks = $app->input->getBool('hidemainmenu')
if(! $multilanguageEnabled|| $hideLinks) $modalHTML

Documentation des variables

◆ $hideLinks

$hideLinks = $app->input->getBool('hidemainmenu')

◆ $modalHTML

if (! $multilanguageEnabled||$hideLinks) $modalHTML
Valeur initiale :
= HTMLHelper::_(
'bootstrap.renderModal',
'multiLangModal',
array(
'title' => Text::_('MOD_MULTILANGSTATUS'),
'url' => Route::_('index.php?option=com_languages&view=multilangstatus&tmpl=component'),
'height' => '400px',
'width' => '800px',
'bodyHeight' => 70,
'modalWidth' => 80,
'footer' => '<button type="button" class="btn btn-secondary" data-bs-dismiss="modal">' . Text::_('JTOOLBAR_CLOSE') . '</button>',
)
)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_popular/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$moduleId = str_replace(' ', '', $module->title) . $module->id
$hits_class = ($hits >= 10000 ? 'danger' : ($hits >= 1000 ? 'warning' : ($hits >= 100 ? 'info' : 'secondary')))
endif
if ( $item->link)
else __pad0__
else ENT_QUOTES
endforeach
else __pad1__

Documentation des variables

◆ $hits_class

$hits_class = ($hits >= 10000 ? 'danger' : ($hits >= 1000 ? 'warning' : ($hits >= 100 ? 'info' : 'secondary')))

◆ $moduleId

$moduleId = str_replace(' ', '', $module->title) . $module->id

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ ENT_QUOTES

else ENT_QUOTES

◆ if

if($item->link)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_post_installation_messages
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_post_installation_messages/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$hideLinks = $app->input->getBool('hidemainmenu')
endif

Documentation des variables

◆ $hideLinks

$hideLinks = $app->input->getBool('hidemainmenu')

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_privacy_dashboard/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$totalRequests = 0
$activeRequests = 0
if(count( $list))( $list as $i=> $item)(in_array($item->status, array(0, 1))) endif
endforeach
else __pad0__

Documentation des variables

◆ $activeRequests

$activeRequests = 0

◆ $totalRequests

$totalRequests = 0

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_privacy_status/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

else __pad0__
endif
if ( $privacyPolicyInfo[ 'editLink'] !=='')
else __pad1__
else __pad2__
if ( $requestFormPublished[ 'link'] !=='')
else __pad3__
else __pad4__
else __pad5__
else __pad6__
else __pad7__
else $databaseConnectionEncryption

Documentation des variables

◆ $databaseConnectionEncryption

else $databaseConnectionEncryption

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ endif

endif

◆ if [1/2]

if($privacyPolicyInfo['editLink'] !=='')

◆ if [2/2]

if($requestFormPublished['link'] !=='')


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_quickicon/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $app->getDocument()->getWebAssetManager()
$html = HTMLHelper::_('icons.buttons', $buttons)
endif

Documentation des variables

◆ $html

$html = HTMLHelper::_('icons.buttons', $buttons)

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_sampledata/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

if | ($items) ( $items as $i=> $item)
< li class="list-group-item sampledata-progress-<?php echo $item-> | name
endforeach
endif

Documentation des variables

◆ ($items)

if ( $items)($items as $i=> $item)

◆ endforeach

endforeach

◆ endif

endif

◆ name

<li class="list-group-item sampledata-progress-<?php echo $item-> name


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_stats_admin/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_submenu/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

foreach( $root->getChildren() as $child)($child->hasChildren()) if(substr($child->img, 0, 6)==='class:') elseif(substr($child->img, 0, 6)==='image:') elseif(!empty($child->img)) elseif($child->icon) | else
if | ($params->get('menu_show', 1)) ( 'menu-quicktask') ? ''
$class = htmlspecialchars($params->get('menu_image_css'), ENT_QUOTES, 'UTF-8')
$alt = $params->get('menu_text') ? '' : htmlspecialchars(Text::_($item->title), ENT_QUOTES, 'UTF-8')
endif
$scope = $item->scope !== 'default' ? $item->scope : null
$icon = $params->get('menu-quicktask-icon', 'plus')
$title = Text::_($params->get('menu-quicktask-title'))
if(empty($params->get('menu-quicktask-title'))) | $sronly = Text::_($item->title) . ' - ' . $title
endforeach

Documentation des variables

◆ $alt

$alt = $params->get('menu_text') ? '' : htmlspecialchars(Text::_($item->title), ENT_QUOTES, 'UTF-8')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par ToolbarHelper\addNew(), Text\alt(), ToolbarHelper\apply(), ToolbarHelper\archiveList(), ToolbarHelper\assign(), ToolbarHelper\back(), ToolbarHelper\cancel(), ToolbarHelper\checkin(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), ToolbarHelper\editCss(), ToolbarHelper\editHtml(), ToolbarHelper\editList(), FormField\getLayoutData(), HTMLHelper\image(), ToolbarHelper\makeDefault(), ToolbarHelper\media_manager(), ToolbarHelper\modal(), Pagination\orderDownIcon(), Pagination\orderUpIcon(), ToolbarHelper\preferences(), ToolbarHelper\publish(), ToolbarHelper\publishList(), ToolbarHelper\save(), ToolbarHelper\save2copy(), ToolbarHelper\save2new(), HTMLHelper\tooltip(), ToolbarHelper\trash(), ToolbarHelper\unarchiveList(), ToolbarHelper\unpublish(), et ToolbarHelper\unpublishList().

◆ $class

$class = htmlspecialchars($params->get('menu_image_css'), ENT_QUOTES, 'UTF-8')

◆ $icon

$icon = $params->get('menu-quicktask-icon', 'plus')

◆ $scope

$scope = $item->scope !== 'default' ? $item->scope : null

Référencé par Client\authorise(), Client\createUrl(), Microdata\htmlDiv(), Microdata\htmlMeta(), Microdata\htmlScope(), Microdata\htmlSpan(), Microdata\htmlTag(), ModuleHelper\renderModule(), et ModuleHelper\renderRawModule().

◆ $sronly

if (empty( $params->get( 'menu-quicktask-title'))) $sronly = Text::_($item->title) . ' - ' . $title

◆ $title

$title = Text::_($params->get('menu-quicktask-title'))

◆ ($params->get('menu_show', 1))

if ( $params->get( 'menu_show', 1))('menu-quicktask') ? ''

◆ else

foreach ($root->getChildren() as $child) ( $child->hasChildren()) if (substr( $child->img, 0, 6)==='class:') elseif (substr( $child->img, 0, 6)==='image:') elseif (!empty( $child->img)) elseif ( $child->icon) else
Valeur initiale :
{
$iconImage = ''
$iconImage
$iconImage
Definition: default_submenu.php:84

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_title
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_title/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

if(!empty($title)) endif

Documentation des variables

◆ endif

if (!empty( $title)) endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_toolbar
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_toolbar/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_user
  • tmpl
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_user/tmpl/default.php

Espaces de nommage

Joomla\Administrator

Variables

$hideLinks = $app->input->getBool('hidemainmenu')
$uri = Uri::getInstance()
$route = 'index.php?option=com_users&task=user.edit&id=' . $user->id . '&return=' . base64_encode($uri) . '#attrib-user_details'

Documentation des variables

◆ $hideLinks

$hideLinks = $app->input->getBool('hidemainmenu')

◆ $route

$route = 'index.php?option=com_users&task=user.edit&id=' . $user->id . '&return=' . base64_encode($uri) . '#attrib-user_details'

◆ $uri

$uri = Uri::getInstance()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_version/tmpl/default.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • config
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/config/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
else __pad0__
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/modules/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$editorText = false
$moduleXml = JPATH_SITE . '/modules/' . $this->item['module'] . '/' . $this->item['module'] . '.xml'
if(File::exists($moduleXml)) if (Multilanguage::isEnabled())
endif

Documentation des variables

◆ $editorText

$editorText = false

◆ $moduleXml

$moduleXml = JPATH_SITE . '/modules/' . $this->item['module'] . '/' . $this->item['module'] . '.xml'

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ if

if (File::exists( $moduleXml)) if(Multilanguage::isEnabled())


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • templates
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/templates/default.php

Espaces de nommage

Joomla\Site

Variables

$user = Factory::getUser()
$wa = $this->document->getWebAssetManager()
else __pad1__
endif

Documentation des variables

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad1__

else __pad1__

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/categories/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/category/default.php

Espaces de nommage

Joomla\Site

Variables

$this subtemplatename = 'items'

Documentation des variables

◆ subtemplatename

$this subtemplatename = 'items'


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/contact/default.php

Espaces de nommage

Joomla\Site

Variables

$tparams = $this->item->params
$canDo = ContentHelper::getActions('com_contact', 'category', $this->item->catid)
$canEdit = $canDo->get('core.edit') || ($canDo->get('core.edit.own') && $this->item->created_by === Factory::getUser()->id)
$htag = $tparams->get('show_page_heading') ? 'h2' : 'h1'
endif
$show_contact_category = $tparams->get('show_contact_category')
else __pad1__

Documentation des variables

◆ $canDo

$canDo = ContentHelper::getActions('com_contact', 'category', $this->item->catid)

◆ $canEdit

$canEdit = $canDo->get('core.edit') || ($canDo->get('core.edit.own') && $this->item->created_by === Factory::getUser()->id)

◆ $htag

$htag = $tparams->get('show_page_heading') ? 'h2' : 'h1'

◆ $show_contact_category

$show_contact_category = $tparams->get('show_contact_category')

◆ $tparams

$tparams = $this->item->params

◆ __pad1__

else __pad1__

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/featured/default.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • archive
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/archive/default.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • article
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/article/default.php

Espaces de nommage

Joomla\Site

Variables

$params = $this->item->params
$canEdit = $params->get('access-edit')
$user = Factory::getUser()
$info = $params->get('info_block_position', 0)
$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'
$assocParam = (Associations::isEnabled() && $params->get('show_associations'))
$currentDate = Factory::getDate()->format('Y-m-d H:i:s')
$isNotPublishedYet = $this->item->publish_up > $currentDate
$isExpired = !is_null($this->item->publish_down) && $this->item->publish_down < $currentDate
endif
if(!empty($this->item->pagination) &&! $this->item->paginationposition && $this->item->paginationrelative) $useDefList
if ( $params->get( 'show_title'))
$active = $menu->getActive()
$itemId = $active->id
$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

Documentation des variables

◆ $active

$active = $menu->getActive()

Référencé par PaginationObject\__construct(), RouteHelper\_findItem(), Sidebar\addEntry(), UiTab\addTab(), Bootstrap\addTab(), CategoryView\commonCategoryDisplay(), HtmlDocument\countMenuChildren(), OpensearchView\display(), HtmlView\display(), RouteHelper\findItem(), AbstractMenu\getActive(), CategoryModel\getCategory(), ContactModel\getForm(), RouteHelper\getItemid(), CategoriesModel\getItems(), LanguagesHelper\getList(), UsersModel\getListQuery(), ListHelper\images(), Cache\isExcluded(), UserController\menulogout(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSystemLanguageFilter\onUserLogin(), StandardRules\parse(), NomenuRules\parse(), ListHelper\positions(), MenuRules\preprocess(), SiteApplication\route(), CMSApplication\route(), Filter\select(), MeterField\setup(), ContactController\submit(), et ListHelper\users().

◆ $assocParam

$assocParam = (Associations::isEnabled() && $params->get('show_associations'))

◆ $canEdit

$canEdit = $params->get('access-edit')

◆ $currentDate

$currentDate = Factory::getDate()->format('Y-m-d H:i:s')

Référencé par PlgSampledataMultilang\addArticle(), et CronExpression\getRunDate().

◆ $htag

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'

◆ $info

$info = $params->get('info_block_position', 0)

Référencé par Language\_(), Image\__construct(), ApplicationHelper\addClientInfo(), TraceableTwigEnvironment\addRenderedTemplate(), ResourceCaster\castOpensslX509(), XmlReaderCaster\castXmlReader(), DaemonApplication\changeIdentity(), LintCommand\displayTxt(), SMTP\get_lines(), Language\getCallerInfo(), Terminal\getConsoleMode(), SourceContextProvider\getContext(), InfoCollector\getDatabaseInfo(), Gzip\getFilePosition(), Image\getImageFileProperties(), SysinfoModel\getInfo(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), FontsField\getOptions(), CurlTransport\getResponse(), Curl\getResponse(), Tar\getTarInfo(), Crypto\HKDF(), RuntimeTests\HKDFTestVector(), Crypto\HKDFTestVector(), File\invalidateFileCache(), CaBundle\isOpensslParseSafe(), Mbstring\mb_get_info(), PlgQuickiconDownloadkey\onGetIcons(), TemplateModel\prepareCoreFiles(), SFTP\put(), Terminal\readFromProcess(), Zip\readZipInfo(), Curl\request(), CurlTransport\request(), Query\resetPagination(), CheckJoomlaUpdatesCommand\setUpdateInfo(), InstalledController\switchAdminLanguage(), et Uri\withUserInfo().

◆ $isExpired

$isExpired = !is_null($this->item->publish_down) && $this->item->publish_down < $currentDate

◆ $isNotPublishedYet

$isNotPublishedYet = $this->item->publish_up > $currentDate

◆ $itemId

string $itemId = $active->id

Référencé par AssociationsHelper\allowEdit(), AssociationsHelper\canCheckinItem(), FieldModel\cleanupValues(), PrivacyPlugin\createItemFromArray(), LanguagesModel\delete(), MenuModel\delete(), ContentHistory\deleteOldVersions(), ConsentBoxField\getAssignedMenuItemUrl(), Workflow\getAssociation(), AssociationsHelper\getAssociationHtmlList(), AssociationsHelper\getAssociationList(), AssociationExtensionHelper\getAssociationList(), FieldModel\getFieldValue(), FieldModel\getFieldValues(), ContentHistory\getHashMatch(), OrderingField\getInput(), FormModel\getItem(), AssociationsHelper\getItem(), MenuModel\getItem(), ContenthistoryField\getLayoutData(), HistoryModel\getListQuery(), ActionlogsModel\getLogsForItem(), ItemlanguageField\getOptions(), PlgSystemPrivacyconsent\getPrivacyItemId(), ArticleController\getRedirectToItemAppend(), ContactController\getRedirectToItemAppend(), PrivacyStatusHelper\getRequestFormPublished(), AssociationsHelper\isCheckoutItem(), UserController\login(), HistoryModel\populateState(), JsonapiView\prepareItem(), MenusController\resync(), et FieldModel\setFieldValue().

◆ $link

$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

◆ $params

$params = $this->item->params

◆ $useDefList

if (!empty( $this->item->pagination) &&! $this->item->paginationposition &&$this->item->paginationrelative) $useDefList
Valeur initiale :
= $params->get('show_modify_date') || $params->get('show_publish_date') || $params->get('show_create_date')
|| $params->get('show_hits') || $params->get('show_category') || $params->get('show_parent_category') || $params->get('show_author') || $assocParam
$assocParam
$assocParam
Definition: components/com_content/tmpl/article/default.php:32
$params
$params
Definition: components/com_content/tmpl/article/default.php:25

◆ $user

$user = Factory::getUser()

◆ endif

if (!empty( $this->item->pagination) &&$this->item->paginationposition &&$this->item->paginationrelative) endif

◆ if

if($params->get('show_title'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/categories/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/category/default.php

Espaces de nommage

Joomla\Site

Variables

$this subtemplatename = 'articles'

Documentation des variables

◆ subtemplatename

$this subtemplatename = 'articles'


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/featured/default.php

Espaces de nommage

Joomla\Site

Variables

endif
foreach ( $this->lead_items as & $item)
endforeach
if((int) $this->params->get( 'num_columns') > 1)(int) $this -> params->get('multi_column_order', 0)===0? ' masonry-' $blogClass = (int) $this->params->get('num_columns')

Documentation des variables

◆ $blogClass

if ((int) $this->params->get('num_columns') > 1) (int) $this -> params->get( 'multi_column_order', 0)===0? ' masonry-' $blogClass = (int) $this->params->get('num_columns')

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->intro_items as $key=> &$item) ( $this->lead_items as & )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
  • search
Espaces de nommage | Variables
Référence du fichier components/com_finder/tmpl/search/default.php

Espaces de nommage

Joomla\Site

Variables

else __pad0__
endif

Documentation des variables

◆ __pad0__

else __pad0__

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • layouts
  • joomla
  • searchtools
Espaces de nommage | Variables
Référence du fichier components/com_menus/layouts/joomla/searchtools/default.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$data ['options'] = !empty($data['options']) ? $data['options'] : array()
$noResultsText = ''
$hideActiveFilters = false
$showFilterButton = false
$showSelector = false
$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'
if(isset($data['view']->filterForm) &&!empty($data['view']->filterForm)) $customOptions
$data ['options'] = array_merge($customOptions, $data['options'])
$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'
$clientIdField = $data['view']->filterForm->getField('client_id')
if ( $clientIdField)
endif

Documentation des variables

◆ $clientIdField

$clientIdField = $data['view']->filterForm->getField('client_id')

◆ $customOptions

if (isset( $data[ 'view']->filterForm) &&!empty( $data[ 'view']->filterForm)) $customOptions
Valeur initiale :
= array(
'filtersHidden' => isset($data['options']['filtersHidden']) && $data['options']['filtersHidden'] ? $data['options']['filtersHidden'] : $hideActiveFilters,
'filterButton' => isset($data['options']['filterButton']) && $data['options']['filterButton'] ? $data['options']['filterButton'] : $showFilterButton,
'defaultLimit' => $data['options']['defaultLimit'] ?? Factory::getApplication()->get('list_limit', 20),
'searchFieldSelector' => '#filter_search',
'selectorFieldName' => $selectorFieldName,
'showSelector' => $showSelector,
'orderFieldSelector' => '#list_fullordering',
'showNoResults' => !empty($noResultsText),
'noResultsText' => !empty($noResultsText) ? $noResultsText : '',
'formSelector' => !empty($data['options']['formSelector']) ? $data['options']['formSelector'] : '#adminForm',
)
$showFilterButton
$showFilterButton
Definition: components/com_menus/layouts/joomla/searchtools/default.php:25
$hideActiveFilters
$hideActiveFilters
Definition: components/com_menus/layouts/joomla/searchtools/default.php:24
$data
$data
Definition: components/com_menus/layouts/joomla/searchtools/default.php:18
$selectorFieldName
$selectorFieldName
Definition: components/com_menus/layouts/joomla/searchtools/default.php:27
$noResultsText
$noResultsText
Definition: components/com_menus/layouts/joomla/searchtools/default.php:23
$showSelector
$showSelector
Definition: components/com_menus/layouts/joomla/searchtools/default.php:26

◆ $data [1/3]

$data = $displayData

◆ $data [2/3]

$data[ 'options'] = !empty($data['options']) ? $data['options'] : array()

◆ $data [3/3]

$data[ 'options'] = array_merge($customOptions, $data['options'])

◆ $filtersActiveClass

$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'

◆ $hideActiveFilters

$hideActiveFilters = false

◆ $noResultsText

$noResultsText = ''

◆ $selectorFieldName

$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'

◆ $showFilterButton

$showFilterButton = false

◆ $showSelector

$showSelector = false

◆ endif

endif

◆ if

if($clientIdField)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_newsfeeds/tmpl/categories/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_newsfeeds/tmpl/category/default.php

Espaces de nommage

Joomla\Site

Variables

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'
endif
if ( $this->params->get( 'show_category_title', 1))

Documentation des variables

◆ $htag

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'

◆ endif

endif

◆ if

if($this->params->get('show_category_title', 1))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Espaces de nommage | Variables
Référence du fichier components/com_newsfeeds/tmpl/newsfeed/default.php

Espaces de nommage

Joomla\Site

Variables

if(!empty($this->msg)) | else
$myrtl = $this->item->rtl
$direction = ' '
$isRtl = $lang->isRtl()
if($isRtl && $myrtl==0) elseif($isRtl && $myrtl==1) elseif($isRtl && $myrtl==2) elseif($myrtl==0) elseif($myrtl==1) elseif($myrtl==2) | endif
$images = json_decode($this->item->images)
if ( $this->params->get( 'display_num'))

Documentation des variables

◆ $direction

$direction = ' '

◆ $images

$images = json_decode($this->item->images)

Référencé par RandomImageHelper\getImages(), RandomImageHelper\getRandomImage(), ListHelper\images(), PlgFinderContent\index(), ApiModel\isMediaFile(), et PHPMailer\msgHTML().

◆ $isRtl

$isRtl = $lang->isRtl()

◆ $myrtl

$myrtl = $this->item->rtl

◆ else

if (!empty( $this->msg)) else

◆ endif

endif

◆ if

if($this->params->get('display_num'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • confirm
Espaces de nommage | Variables
Référence du fichier components/com_privacy/tmpl/confirm/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • remind
Espaces de nommage | Variables
Référence du fichier components/com_privacy/tmpl/remind/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • request
Espaces de nommage | Variables
Référence du fichier components/com_privacy/tmpl/request/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach
else __pad0__

Documentation des variables

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tag
Espaces de nommage | Variables
Référence du fichier components/com_tags/tmpl/tag/default.php

Espaces de nommage

Joomla\Site

Variables

$isSingleTag = count($this->item) === 1
$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'
endif
if ( $this->params->get( 'show_tag_title', 1))

Documentation des variables

◆ $htag

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'

◆ $isSingleTag

$isSingleTag = count($this->item) === 1

◆ endif

endif

◆ if

if($this->params->get('show_tag_title', 1))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage | Variables
Référence du fichier components/com_tags/tmpl/tags/default.php

Espaces de nommage

Joomla\Site

Variables

$description = $this->params->get('all_tags_description')
$descriptionImage = $this->params->get('all_tags_description_image')
endif

Documentation des variables

◆ $description

$description = $this->params->get('all_tags_description')

◆ $descriptionImage

$descriptionImage = $this->params->get('all_tags_description_image')

◆ endif

if (!empty( $description)) endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • captive
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/captive/default.php

Espaces de nommage

Joomla\Site

Variables

$model = $this->getModel()
if(!empty($this->title)) endif

Documentation des variables

◆ $model

$model = $this->getModel()

◆ endif

if (!empty( $this->title)) endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • login
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/login/default.php

Espaces de nommage

Joomla\Site

Variables

$cookieLogin = $this->user->get('cookieLogin')
if(!empty($cookieLogin)|| $this->user->get('guest')) else

Documentation des variables

◆ $cookieLogin

$cookieLogin = $this->user->get('cookieLogin')

Référencé par HtmlView\display(), et ProfileController\edit().

◆ else

if (!empty( $cookieLogin)||$this->user->get( 'guest')) else
Valeur initiale :
{
echo $this->loadTemplate('logout')


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/methods/default.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/profile/default.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • registration
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/registration/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • remind
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/remind/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • reset
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/reset/default.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • tmpl
  • wrapper
Espaces de nommage | Variables
Référence du fichier components/com_wrapper/tmpl/wrapper/default.php

Espaces de nommage

Joomla\Site

Variables

else __pad0__
endif
else __pad1__

Documentation des variables

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • error
Espaces de nommage
Référence du fichier installation/tmpl/error/default.php

Espaces de nommage

Joomla\Installation


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • preinstall
Espaces de nommage | Variables
Référence du fichier installation/tmpl/preinstall/default.php

Espaces de nommage

Joomla\Installation

Variables

foreach ($this->options as $option) ( $option->state==='JNO'||$option->state===false)
endif
endforeach

Documentation des variables

◆ ($this->options as $option)

foreach ( $this->options as $option)($option->state==='JNO'|| $option->state===false)

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • remove
Espaces de nommage | Variables
Référence du fichier installation/tmpl/remove/default.php

Espaces de nommage

Joomla\Installation

Variables

if (count( $this->installed_languages->administrator) > 1)
foreach ( $this->installed_languages->administrator as $i=> $lang)
endforeach
$displayTable = false
foreach( $this->phpsettings as $setting)($setting->state !==$setting->recommended) | endif
foreach | ($this->phpsettings as $setting) ( $setting->state !==$setting->recommended)
else __pad0__
$version = new \Joomla\CMS\Version()
$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())
$language | code = $element[1]
else __pad1__

Documentation des variables

◆ $currentShortVersion

$currentShortVersion = preg_replace('#^([0-9\.]+)(|.*)$#', '$1', $version->getShortVersion())

◆ $displayTable

$displayTable = false

◆ $version

$version = new \Joomla\CMS\Version()

◆ ($this->phpsettings as $setting)

foreach ( $this->phpsettings as $setting)($setting->state !==$setting->recommended)

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ code

$language code = $element[1]

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->installed_languages->frontend as $i=> $lang) | ( | $this->installed_languages->administrator as,
 |  | $lang
 | ) |

◆ if

if($this->development) | ( | count($this->installed_languages->administrator) | ,
 |  | 1 |
 | ) |  |


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • setup
Espaces de nommage
Référence du fichier installation/tmpl/setup/default.php

Espaces de nommage

Joomla\Installation


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/subform/default.php

Espaces de nommage

Joomla\Site

Variables

$form = $forms[0]
endforeach

Documentation des variables

◆ $form

$form = $forms[0]

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
Espaces de nommage | Variables
Référence du fichier layouts/joomla/searchtools/default.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$data ['options'] = !empty($data['options']) ? $data['options'] : array()
$noResultsText = ''
$hideActiveFilters = false
$showFilterButton = false
$showSelector = false
$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'
if(isset($data['view']->filterForm) &&!empty($data['view']->filterForm)) $customOptions
$data ['options'] = array_merge($customOptions, $data['options'])
$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'
endif

Documentation des variables

◆ $customOptions

if (isset( $data[ 'view']->filterForm) &&!empty( $data[ 'view']->filterForm)) $customOptions
Valeur initiale :
= array(
'filtersHidden' => isset($data['options']['filtersHidden']) && $data['options']['filtersHidden'] ? $data['options']['filtersHidden'] : $hideActiveFilters,
'filterButton' => isset($data['options']['filterButton']) && $data['options']['filterButton'] ? $data['options']['filterButton'] : $showFilterButton,
'defaultLimit' => $data['options']['defaultLimit'] ?? Factory::getApplication()->get('list_limit', 20),
'searchFieldSelector' => '#filter_search',
'selectorFieldName' => $selectorFieldName,
'showSelector' => $showSelector,
'orderFieldSelector' => '#list_fullordering',
'showNoResults' => !empty($noResultsText),
'noResultsText' => !empty($noResultsText) ? $noResultsText : '',
'formSelector' => !empty($data['options']['formSelector']) ? $data['options']['formSelector'] : '#adminForm',
)
$data
$data
Definition: layouts/joomla/searchtools/default.php:17
$hideActiveFilters
$hideActiveFilters
Definition: layouts/joomla/searchtools/default.php:23
$selectorFieldName
$selectorFieldName
Definition: layouts/joomla/searchtools/default.php:26
$showFilterButton
$showFilterButton
Definition: layouts/joomla/searchtools/default.php:24
$noResultsText
$noResultsText
Definition: layouts/joomla/searchtools/default.php:22
$showSelector
$showSelector
Definition: layouts/joomla/searchtools/default.php:25

◆ $data [1/3]

$data = $displayData

◆ $data [2/3]

$data[ 'options'] = !empty($data['options']) ? $data['options'] : array()

◆ $data [3/3]

$data[ 'options'] = array_merge($customOptions, $data['options'])

◆ $filtersActiveClass

$filtersActiveClass = $hideActiveFilters ? '' : ' js-stools-container-filters-visible'

◆ $hideActiveFilters

$hideActiveFilters = false

◆ $noResultsText

$noResultsText = ''

◆ $selectorFieldName

$selectorFieldName = $data['options']['selectorFieldName'] ?? 'client_id'

◆ $showFilterButton

$showFilterButton = false

◆ $showSelector

$showSelector = false

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_archive/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if(! $list) foreach ( $list as $item)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

if (! $list) foreach($list as $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_categories/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if (! $list)

Documentation des variables

◆ if

if(! $list)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_category/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

endforeach
else __pad0__
endif

Documentation des variables

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_latest/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if(! $list) foreach ( $list as $item)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

if (! $list) foreach($list as $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_news/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

endforeach

Documentation des variables

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_popular/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if(! $list) foreach ( $list as $item)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

if (! $list) foreach($list as $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_banners/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if($headerText) | endif
else __pad0__
$width = $item->params->get('width')
$height = $item->params->get('height')
$alt = $item->params->get('alt')
if ( $target==1)
if(!empty($width)) if(!empty($height)) | elseif ( $target==2)
if(!empty($width)) if(!empty($height)) | else
else __pad1__
endforeach

Documentation des variables

◆ $alt

$alt = $item->params->get('alt')

◆ $height

$height = $item->params->get('height')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par BannerTable\bind(), Checkfiles\checkImages(), HTMLHelper\cleanImageURL(), Image\crop(), Image\cropResize(), Editor\display(), Backgroundfill\execute(), Terminal\getHeight(), Image\getOrientationString(), RandomImageHelper\getRandomImage(), MediaHelper\imageResize(), Terminal\initDimensions(), Terminal\initDimensionsUsingStty(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), Image\prepareDimensions(), Image\resize(), TemplateModel\resizeImage(), Image\sanitizeHeight(), et Image\sanitizeWidth().

◆ $width

$width = $item->params->get('width')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par SymfonyStyle\__construct(), OutputFormatter\applyCurrentStyle(), BannerTable\bind(), PHP\bitwise_split(), Checkfiles\checkImages(), HTMLHelper\cleanImageURL(), Image\crop(), Image\cropResize(), TextDescriptor\describeApplication(), TextDescriptor\describeJoomlaApplication(), Editor\display(), Application\doRenderThrowable(), Backgroundfill\execute(), OutputFormatter\formatAndWrap(), Image\getOrientationString(), RandomImageHelper\getRandomImage(), Terminal\getWidth(), MediaHelper\imageResize(), Terminal\initDimensions(), Terminal\initDimensionsUsingStty(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), Image\prepareDimensions(), Table\renderCell(), Image\resize(), TemplateModel\resizeImage(), Image\sanitizeHeight(), Image\sanitizeWidth(), Table\setColumnMaxWidth(), Table\setColumnWidth(), Table\setColumnWidths(), ToolbarHelper\spacer(), Application\splitStringByWidth(), et AbstractString\wordwrap().

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ else

if (!empty( $width)) if (!empty( $height)) else

◆ elseif

if (!empty( $width)) if (!empty( $height)) elseif($target==2)

◆ endforeach

endforeach

◆ endif

if ( $footerText) endif

◆ if

if($target==1)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_breadcrumbs/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

else __pad0__
$last_item_key = key($list)
$penult_item_key = key($list)
$show_last = $params->get('showLast', 1)
$class = null
else __pad1__
endif
endforeach
$data
$itemsCounter = 0

Documentation des variables

◆ $class

elseif ( $show_last) $class = null

◆ $data

$data
Valeur initiale :
= [
'@context' => 'https://schema.org'

◆ $itemsCounter

$itemsCounter = 0

◆ $last_item_key

$last_item_key = key($list)

◆ $penult_item_key

$penult_item_key = key($list)

◆ $show_last

$show_last = $params->get('showLast', 1)

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_custom
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_custom/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$modId = 'mod-custom' . $module->id
if ( $params->get( 'backgroundimage'))

Documentation des variables

◆ $modId

$modId = 'mod-custom' . $module->id

◆ if

if($params->get('backgroundimage'))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_feed/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if(empty($rssurl)) if(!empty($feed) &&is_string($feed)) else
$myrtl = $params->get('rssrtl', 0)
$direction = ' '
$isRtl = $lang->isRtl()

Documentation des variables

◆ $direction

$direction = ' '

◆ $isRtl

$isRtl = $lang->isRtl()

◆ $myrtl

$myrtl = $params->get('rssrtl', 0)

◆ else

if (empty( $rssurl)) if (!empty( $feed) &&is_string( $feed)) else
Valeur initiale :
{
$lang = $app->getLanguage()
$lang
$lang
Definition: administrator/components/com_categories/tmpl/categories/emptystate.php:22
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_finder/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$lang = $app->getLanguage()
$input
$showLabel = $params->get('show_label', 1)
$labelClass = (!$showLabel ? 'visually-hidden ' : '') . 'finder'
$label = '<label for="mod-finder-searchword' . $module->id . '" class="' . $labelClass . '">' . $params->get('alt_label', Text::_('JSEARCH_FILTER_SUBMIT')) . '</label>'
$output = ''
if($params->get('show_button', 0)) else
$wa = $app->getDocument()->getWebAssetManager()
$show_advanced = $params->get('show_advanced', 0)
endif

Documentation des variables

◆ $input

$input
Valeur initiale :
= '<input type="text" name="q" id="mod-finder-searchword' . $module->id . '" class="js-finder-search-query form-control" value="' . htmlspecialchars($app->input->get('q', '', 'string'), ENT_COMPAT, 'UTF-8') . '"'
. ' placeholder="' . Text::_('MOD_FINDER_SEARCH_VALUE') . '">'
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$module
$module
Definition: administrator/templates/atum/html/layouts/chromes/body.php:18

◆ $label

$label = '<label for="mod-finder-searchword' . $module->id . '" class="' . $labelClass . '">' . $params->get('alt_label', Text::_('JSEARCH_FILTER_SUBMIT')) . '</label>'

◆ $labelClass

$labelClass = (!$showLabel ? 'visually-hidden ' : '') . 'finder'

◆ $lang

$lang = $app->getLanguage()

◆ $output

$output = ''

◆ $show_advanced

$show_advanced = $params->get('show_advanced', 0)

◆ $showLabel

$showLabel = $params->get('show_label', 1)

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ else

if ( $params->get( 'show_button', 0)) else
Valeur initiale :
{
$output .= $label
$output
$output
Definition: modules/mod_finder/tmpl/default.php:29
$label
$label
Definition: modules/mod_finder/tmpl/default.php:27

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_footer
  • tmpl
Espaces de nommage
Référence du fichier modules/mod_footer/tmpl/default.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_languages/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()
if($headerText) | endif
foreach | ($list as $language) ( $language->active)
endforeach
foreach($list as $language) if($params->get('full_name')===0) | if (! $language->active)
else __pad0__
else __pad1__
else __pad2__
else $language title_native
else __pad3__
else __pad4__

Documentation des variables

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ ($list as $language)

foreach ( $list as $language)($language->active)

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ endforeach

endforeach

◆ endif

if ( $footerText) endif

◆ if

foreach ( $list as $language) if ((( $params->get( 'full_name')===0) &&( $params->get( 'image')===0))||(! $language->image)) if(! $language->active) ( ! $language-> active )

◆ title_native

else $language title_native


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_login/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

endif
if (! $params->get( 'usetext', 0))
else __pad0__
else __pad1__

Documentation des variables

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endif

endif

◆ if

if(PluginHelper::isEnabled('system', 'remember')) ( ! $params-> get'usetext', 0 )


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_menu/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()
$id = ''
if ( $tagId=$params->get( 'tag_id', ''))

Documentation des variables

◆ $id

$id = ''

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ if

if($tagId=$params->get('tag_id', ''))


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_random_image/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_related_items/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

foreach($list as $item) if ( $showDate)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ if

foreach ( $list as $item) if($showDate)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_stats/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

foreach ( $list as $item)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

foreach($list as $item)


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_syndicate/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$textClass = ($params->get('display_text', 1) ? '' : 'class="visually-hidden"')
$linkText = '<span class="icon-feed m-1" aria-hidden="true"></span>'
$attribs

Documentation des variables

◆ $attribs

$attribs
Valeur initiale :
= [
'class' => 'mod-syndicate syndicate-module'
]

◆ $linkText

$linkText = '<span class="icon-feed m-1" aria-hidden="true"></span>'

◆ $textClass

$textClass = ($params->get('display_text', 1) ? '' : 'class="visually-hidden"')


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_tags_popular/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

else __pad1__
else $item | language
if($display_count) | endif
endforeach

Documentation des variables

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ language

else $item language


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_tags_similar/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

endif
else __pad0__
endforeach

Documentation des variables

◆ __pad0__

else __pad0__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_users_latest/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

if(!empty( $names))($names as $name) endforeach
endif

Documentation des variables

◆ endforeach

if (!empty($names)) ( $names as $name) endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_whosonline/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$member = Text::plural('MOD_WHOSONLINE_MEMBERS', $count['user'])
endif
foreach($names as $name) endforeach

Documentation des variables

◆ $member

$member = Text::plural('MOD_WHOSONLINE_MEMBERS', $count['user'])

◆ endforeach

foreach ( $names as $name) endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_wrapper/tmpl/default.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagenavigation
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/content/pagenavigation/tmpl/default.php

Espaces de nommage

Joomla\Plugin

Variables

$lang = Factory::getLanguage()
if | ($row->prev) () ? 'right'
endif
if | ($row->next) () ? 'left'

Documentation des variables

◆ $lang

$lang = Factory::getLanguage()

◆ ($row->next)

if ( $row->next)() ? 'left'

◆ ($row->prev)

if ( $row->prev)() ? 'right'

◆ endif

endif


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • folderinstaller
  • tmpl
Espaces de nommage
Référence du fichier plugins/installer/folderinstaller/tmpl/default.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • packageinstaller
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/installer/packageinstaller/tmpl/default.php

Espaces de nommage

Joomla\Plugin

Variables

$return = $this->app->input->getBase64('return')
$maxSizeBytes = FilesystemHelper::fileUploadMaxSize(false)
$maxSize = HTMLHelper::_('number.bytes', $maxSizeBytes)

Documentation des variables

◆ $maxSize

$maxSize = HTMLHelper::_('number.bytes', $maxSizeBytes)

◆ $maxSizeBytes

$maxSizeBytes = FilesystemHelper::fileUploadMaxSize(false)

◆ $return

$return = $this->app->input->getBase64('return')


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • urlinstaller
  • tmpl
Espaces de nommage
Référence du fichier plugins/installer/urlinstaller/tmpl/default.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • webinstaller
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/installer/webinstaller/tmpl/default.php

Espaces de nommage

Joomla\Plugin

Variables

$dir = $this->isRTL() ? ' dir="ltr"' : ''

Documentation des variables

◆ $dir

$dir = $this->isRTL() ? ' dir="ltr"' : ''
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par OpensearchDocument\__construct(), DebugClassLoader\__construct(), HtmlView\_addPath(), FileStorage\_filesInFolder(), FileStorage\_folders(), FileStorage\_getFilePath(), Toolbar\addButtonPath(), Table\addIncludePath(), HTMLHelper\addIncludePath(), BaseController\addPath(), SFTP\chdir(), UpdateCoreCommand\copyFileTo(), MediaHelper\countFiles(), Zip\createZipFile(), DebugClassLoader\darwinRealpath(), ClassLoader\findFileWithExtension(), SqlsrvQuery\fixGroupColumns(), LinkStub\getComposerRoot(), TemplateModel\getDirectoryTree(), RandomImageHelper\getImages(), Path\isOwner(), Directory\message(), SFTP\mkdir(), SFTP\mkdir_helper(), SFTP\nlist(), SFTP\nlist_helper(), LanguageHelper\parseLanguageFiles(), FileAdapter\populateFilesAndFolderList(), TemplateModel\prepareCoreFiles(), SFTP\query_stat_cache(), SFTP\rawlist(), ZIPExtraction\readFileHeader(), SFTP\readlist(), SFTP\realpath(), SFTP\remove_from_stat_cache(), Path\removeRoot(), LocalAdapter\rglob(), SFTP\rmdir(), Document\setDirection(), et SFTP\update_stat_cache().


Joomla CMS: Référence du fichier default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/multifactorauth/webauthn/tmpl/default.php

Espaces de nommage

Joomla\Plugin

Variables

return
endif

Documentation des variables

◆ endif

endif

◆ return

return


Joomla CMS: Référence du fichier default_addform.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Espaces de nommage
Référence du fichier default_addform.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_address.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier default_address.php

Espaces de nommage

Joomla\Site

Variables

$icon = $this->params->get('contact_icons') == 0
else __pad2__
endif
else __pad3__
else __pad4__
else __pad5__
else __pad6__
else __pad7__

Documentation des variables

◆ $icon

$icon = $this->params->get('contact_icons') == 0

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ endif

endif


Joomla CMS: Référence du fichier default_articles.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier com_contact/tmpl/contact/default_articles.php

Espaces de nommage

Joomla\Site

Variables

endforeach
endif

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_articles.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/category/default_articles.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$n = count($this->items)
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$langFilter = false
if(($this->params->get('filter_field')==='tag') &&(Multilanguage::isEnabled())) | $isEditable = false
if(!empty($this->items)) | $currentDate = Factory::getDate()->format('Y-m-d H:i:s')
else __pad3__
endif
else __pad4__
foreach( $this->items as $i=> $article)($this->items[$i]->state==ContentComponent::CONDITION_UNPUBLISHED) | else
else __pad5__
endforeach
else __pad6__
$itemId = Factory::getApplication()->getMenu()->getActive()->id
$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))
else __pad7__
else __pad8__
else __pad9__
else __pad10__
else $author
if( $this->params->get( 'list_show_hits', 1))($this->params->get('show_headings')) $article | hits
if( $this->params->get( 'list_show_votes', 0) &&$this->vote)($this->params->get('show_headings')) $article | rating_count
if( $this->params->get( 'list_show_ratings', 0) &&$this->vote)($this->params->get('show_headings')) $article | rating

Documentation des variables

◆ $author

else $author

◆ $currentDate

if (!empty( $this->items)) $currentDate = Factory::getDate()->format('Y-m-d H:i:s')

◆ $isEditable

if (( $this->params->get( 'filter_field')==='tag') &&(Multilanguage::isEnabled())) $isEditable = false

◆ $itemId

$itemId = Factory::getApplication()->getMenu()->getActive()->id

◆ $langFilter

$langFilter = false

◆ $link

$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $n

$n = count($this->items)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad10__

else __pad10__

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ __pad8__

else __pad8__

◆ __pad9__

else __pad9__

◆ else

if ($this->params->get('list_show_ratings', 0) && $this->vote) ( $this->params->get( 'show_headings')) else

◆ endforeach

endforeach

◆ endif

endif

◆ hits

if ($this->params->get('list_show_hits', 1)) ( $this->params->get( 'show_headings')) $article hits

Référencé par TagTable\check(), NewsfeedTable\check(), ContactTable\check(), Content\check(), HtmlView\display(), et Table\hit().

◆ rating

if ($this->params->get('list_show_ratings', 0) && $this->vote) ( $this->params->get( 'show_headings')) $article rating

◆ rating_count

if ($this->params->get('list_show_votes', 0) && $this->vote) ( $this->params->get( 'show_headings')) $article rating_count


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banners
Espaces de nommage | Variables
Référence du fichier com_banners/tmpl/banners/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = $this->state->get('filter.published')
endif

Documentation des variables

◆ $published

$published = $this->state->get('filter.published')

Référencé par Result\__serialize(), ContactModel\buildContactExtendedData(), NewsfeedModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), MenusModel\getItems(), NotesModel\getListQuery(), ClientsModel\getListQuery(), BannersModel\getListQuery(), LanguagesModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), CategoriesModel\getListQuery(), PluginsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), MenusHelper\getMenuLinks(), CategoryField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), ItemsModel\populateState(), ArticlesModel\populateState(), Nested\publish(), Languages\published(), Nested\recursiveUpdatePublishedColumn(), et TagsHelper\searchTags().

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier com_categories/tmpl/categories/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = (int) $this->state->get('filter.published')
$extension = $this->escape($this->state->get('filter.extension'))
endif

Documentation des variables

◆ $extension

$extension = $this->escape($this->state->get('filter.extension'))

◆ $published

$published = (int) $this->state->get('filter.published')

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Espaces de nommage | Variables
Référence du fichier com_contact/tmpl/contacts/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = $this->state->get('filter.published')
$noUser = true
endif

Documentation des variables

◆ $noUser

$noUser = true

◆ $published

$published = $this->state->get('filter.published')

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/articles/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$params = ComponentHelper::getParams('com_content')
$published = (int) $this->state->get('filter.published')
$user = Factory::getUser()
endif

Documentation des variables

◆ $params

$params = ComponentHelper::getParams('com_content')

◆ $published

$published = (int) $this->state->get('filter.published')

◆ $user

$user = Factory::getUser()

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • fields
Espaces de nommage | Variables
Référence du fichier com_fields/tmpl/fields/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$context = $this->escape($this->state->get('filter.context'))
endif
$options

Documentation des variables

◆ $context

$context = $this->escape($this->state->get('filter.context'))

◆ $options

$options
Valeur initiale :
= array(
HTMLHelper::_('select.option', 'c', Text::_('JLIB_HTML_BATCH_COPY')),
HTMLHelper::_('select.option', 'm', Text::_('JLIB_HTML_BATCH_MOVE'))
)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • groups
Espaces de nommage | Variables
Référence du fichier com_fields/tmpl/groups/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • items
Espaces de nommage | Variables
Référence du fichier com_menus/tmpl/items/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$options
$published = (int) $this->state->get('filter.published')
$clientId = (int) $this->state->get('filter.client_id')
$menuType = Factory::getApplication()->getUserState('com_menus.items.menutype', '')
endif
$opts
else __pad9__

Documentation des variables

◆ $clientId

$clientId = (int) $this->state->get('filter.client_id')

◆ $menuType

$menuType = Factory::getApplication()->getUserState('com_menus.items.menutype', '')

◆ $options

$options
Valeur initiale :
= [
HTMLHelper::_('select.option', 'c', Text::_('JLIB_HTML_BATCH_COPY')),
HTMLHelper::_('select.option', 'm', Text::_('JLIB_HTML_BATCH_MOVE'))
]

◆ $opts

$opts
Valeur initiale :
= array(
'published' => $this->state->get('filter.published'),
'checkacl' => (int) $this->state->get('menutypeid'),
'clientid' => (int) $clientId,
)
$clientId
$clientId
Definition: com_menus/tmpl/items/default_batch_body.php:24

Référencé par MenuField\getGroups(), JavascriptRenderer\getJsControlsDefinitionCode(), et X509\testForIntermediate().

◆ $published

$published = (int) $this->state->get('filter.published')

◆ __pad9__

else __pad9__

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier com_modules/tmpl/modules/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$clientId = $this->state->get('client_id')
$published = 1
$positions = HTMLHelper::_('modules.positions', $clientId, $published)
$positions ['']['items'][] = ModulesHelper::createOption('nochange', Text::_('COM_MODULES_BATCH_POSITION_NOCHANGE'))
$positions ['']['items'][] = ModulesHelper::createOption('noposition', Text::_('COM_MODULES_BATCH_POSITION_NOPOSITION'))
$attr
endif

Documentation des variables

◆ $attr

$attr
Valeur initiale :
= array(
'id' => 'batch-position-id',
)

◆ $clientId

$clientId = $this->state->get('client_id')

◆ $positions [1/3]

$positions = HTMLHelper::_('modules.positions', $clientId, $published)

Référencé par ModulesModel\getActivePositions(), ModulesPositioneditField\getInput(), PositionsModel\getItems(), ModulesHelper\getPositions(), TemplatesHelper\getPositions(), Modules\positions(), et ListHelper\positions().

◆ $positions [2/3]

$positions[''][ 'items'][] = ModulesHelper::createOption('nochange', Text::_('COM_MODULES_BATCH_POSITION_NOCHANGE'))

◆ $positions [3/3]

$positions[''][ 'items'][] = ModulesHelper::createOption('noposition', Text::_('COM_MODULES_BATCH_POSITION_NOPOSITION'))

◆ $published

$published = 1

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Espaces de nommage | Variables
Référence du fichier com_newsfeeds/tmpl/newsfeeds/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = (int) $this->state->get('filter.published')
endif

Documentation des variables

◆ $published

$published = (int) $this->state->get('filter.published')

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Espaces de nommage | Variables
Référence du fichier com_redirect/tmpl/links/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = $this->state->get('filter.published')
$params = $this->params
$separator = $params->get('separator', '|')

Documentation des variables

◆ $params

$params = $this->params

◆ $published

$published = $this->state->get('filter.published')

◆ $separator

$separator = $params->get('separator', '|')

Référencé par LinksController\batch(), SqliteQuery\concatenate(), SqlsrvQuery\concatenate(), Joomla\Database\Query\concatenate(), DatabaseQuery\concatenate(), ArrayHelper\flatten(), Registry\flatten(), SqliteQuery\groupConcat(), Joomla\Database\Query\groupConcat(), SqlsrvQuery\groupConcat(), Task\set(), AsciiSlugger\slug(), ASCII\to_slugify(), et Registry\toFlatten().


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage | Variables
Référence du fichier com_tags/tmpl/tags/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$published = $this->state->get('filter.published')
endif

Documentation des variables

◆ $published

$published = $this->state->get('filter.published')

◆ endif

endif


Joomla CMS: Référence du fichier default_batch_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • users
Espaces de nommage | Variables
Référence du fichier com_users/tmpl/users/default_batch_body.php

Espaces de nommage

Joomla\Administrator

Variables

$options
$resetOptions
$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $options

$options
Valeur initiale :
= array(
HTMLHelper::_('select.option', 'add', Text::_('COM_USERS_BATCH_ADD')),
HTMLHelper::_('select.option', 'del', Text::_('COM_USERS_BATCH_DELETE')),
HTMLHelper::_('select.option', 'set', Text::_('COM_USERS_BATCH_SET'))
)

◆ $resetOptions

$resetOptions
Valeur initiale :
= array(
HTMLHelper::_('select.option', '', Text::_('COM_USERS_NO_ACTION')),
HTMLHelper::_('select.option', 'yes', Text::_('JYES')),
HTMLHelper::_('select.option', 'no', Text::_('JNO'))
)

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banners
Espaces de nommage
Référence du fichier com_banners/tmpl/banners/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Espaces de nommage
Référence du fichier com_categories/tmpl/categories/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Espaces de nommage
Référence du fichier com_contact/tmpl/contacts/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/articles/default_batch_footer.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • fields
Espaces de nommage
Référence du fichier com_fields/tmpl/fields/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • groups
Espaces de nommage
Référence du fichier com_fields/tmpl/groups/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • items
Espaces de nommage | Variables
Référence du fichier com_menus/tmpl/items/default_batch_footer.php

Espaces de nommage

Joomla\Administrator

Variables

$published = $this->state->get('filter.published')
$clientId = $this->state->get('filter.client_id')
$menuType = Factory::getApplication()->getUserState('com_menus.items.menutype', '')
return false
endif

Documentation des variables

◆ $clientId

$clientId = $this->state->get('filter.client_id')

◆ $menuType

$menuType = Factory::getApplication()->getUserState('com_menus.items.menutype', '')

◆ $published

$published = $this->state->get('filter.published')

◆ endif

endif

◆ false

else false

Référencé par Token\__construct(), PHP\addHelper(), CategoryModel\batchFlipordering(), ItemController\cancel(), Dispatcher\checkAccess(), Bootup\filterRequestUri(), ComponentHelper\getComponent(), LibraryHelper\getLibrary(), CallbackStream\getMetadata(), ChecksModel\getPhpOptionsSufficient(), Iconv\iconv_strpos(), Iconv\iconv_strrpos(), HistoryController\keep(), SSH2\login_helper(), GMP\modInverse(), PHP\multiplyHelper(), Barrett\multiplyLower(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), BigRational\power(), ItemsController\publish(), PublishedButton\render(), FeaturedButton\render(), SetConfigurationCommand\sanitizeOptions(), FlattenException\setClass(), ItemsController\setDefault(), MfaTable\store(), PHP\subtractHelper(), et AsymmetricKey\useInternalEngine().


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Espaces de nommage
Référence du fichier com_modules/tmpl/modules/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Espaces de nommage
Référence du fichier com_newsfeeds/tmpl/newsfeeds/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Espaces de nommage
Référence du fichier com_redirect/tmpl/links/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage
Référence du fichier com_tags/tmpl/tags/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_batch_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • users
Espaces de nommage
Référence du fichier com_users/tmpl/users/default_batch_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_cache.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_cache.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_CACHE_SETTINGS')
$this | fieldsname = 'cache'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'cache'

◆ formclass

$this formclass = 'options-form'

◆ name

string $extension The extension name = Text::_('COM_CONFIG_CACHE_SETTINGS')

Layout variables

Référencé par AsCommand\__construct(), OptionConfigurator\__construct(), PublicKeyCredentialEntity\__construct(), Basic\__construct(), MessagesCollector\__construct(), MonologCollector\__construct(), InputArgument\__construct(), AggregatedCollector\__construct(), AbstractImmutableEvent\__construct(), EventImmutable\__construct(), QueryElement\__construct(), BaseModel\__construct(), AbstractEvent\__construct(), ConfigCollector\__construct(), InstallationApplication\__construct(), InputOption\__construct(), FeedPerson\__construct(), Captcha\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), SiteApplication\__construct(), WebAssetItem\__construct(), Application\__construct(), RouterViewConfiguration\__construct(), ToolbarButton\__construct(), Form\__construct(), ConsoleApplication\__construct(), BaseController\__construct(), FormField\__set(), QueryElement\__toString(), AbstractEvent\__unserialize(), Captcha\_load(), Command\addUsage(), OptionConfigurator\allowedTypes(), OptionConfigurator\allowedValues(), UpdateSite\check(), Update\check(), NewsfeedTable\check(), Extension\check(), ClientTable\check(), BannerTable\check(), FieldTable\check(), ContactTable\check(), HelpCommand\configure(), DaemonApplication\daemonize(), OptionConfigurator\default(), UpdatesitesModel\delete(), OptionConfigurator\deprecated(), DaemonApplication\detach(), InstallerAdapter\discover_install(), AddUserCommand\doExecute(), DaemonApplication\execute(), ConfirmButton\fetchButton(), HelpButton\fetchButton(), LinkButton\fetchButton(), StandardButton\fetchButton(), InlinehelpButton\fetchButton(), PopupButton\fetchButton(), Access\getAssetRules(), InstalledModel\getData(), DatabaseDriver\getExporter(), DatabaseDriver\getImporter(), PrefixField\getInput(), ImpmadeField\getInput(), ClicksField\getInput(), AssociationField\getInput(), FieldLayoutField\getInput(), FiltersField\getInput(), ComboField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), ContenthistoryField\getInput(), UploaddirsField\getInput(), TemplatesListField\getInput(), UserField\getInput(), CheckboxesField\getInput(), OrderingField\getInput(), CaptchaField\getInput(), SubformField\getInput(), EditorField\getInput(), MediaField\getInput(), FormField\getInput(), DatabaseDriver\getIterator(), TinymcebuilderField\getLayoutData(), BreadcrumbsHelper\getList(), ModuleHelper\getModule(), BaseModel\getName(), RouterView\getName(), BaseController\getName(), DatabaseDriver\getName(), DatabaseDriver\getQuery(), Command\getSynopsis(), SessionCollector\getWidgets(), LanguageStringsCollector\getWidgets(), LanguageErrorsCollector\getWidgets(), LanguageFilesCollector\getWidgets(), QueryCollector\getWidgets(), PluginHelper\importPlugin(), OptionConfigurator\info(), InstallerAdapter\install(), PackageManifest\loadManifestFromData(), LibraryManifest\loadManifestFromData(), SubformField\loadSubForm(), SubformField\loadSubFormData(), ToolbarButton\name(), OptionConfigurator\normalize(), AbstractImmutableEvent\offsetSet(), EventImmutable\offsetSet(), AbstractImmutableEvent\offsetUnset(), EventImmutable\offsetUnset(), StandardRules\parse(), OptionConfigurator\required(), DaemonApplication\restart(), BufferStreamHandler\seek_end(), BufferStreamHandler\seek_set(), FetchMediaItemUrlEvent\setAdapter(), GetIconEvent\setContext(), SaveSetup\setInput(), Callback\setMethod(), XmlDocument\setName(), RouterViewConfiguration\setName(), QueryElement\setName(), RuntimeStorage\setName(), Command\setName(), AbstractCommand\setName(), Application\setName(), FetchMediaItemUrlEvent\setPath(), GetSetup\setRecord(), Captive\setRecord(), SaveSetup\setRecord(), Validate\setRecord(), AccessiblemediaField\setup(), FileAdapter\setupInstallPaths(), BeforeDisplayMethods\setUser(), Validate\setUser(), DaemonApplication\stop(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), Buffer\stream_eof(), BufferStreamHandler\stream_eof(), Buffer\stream_open(), BufferStreamHandler\stream_open(), Buffer\stream_read(), BufferStreamHandler\stream_read(), Buffer\stream_seek(), Buffer\stream_write(), BufferStreamHandler\stream_write(), et InstallerAdapter\uninstall().


Joomla CMS: Référence du fichier default_children.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier com_contact/tmpl/category/default_children.php

Espaces de nommage

Joomla\Site

Variables

endif
$this | category = $child
$this | maxLevel
endforeach

Documentation des variables

◆ category

$this category = $child

Référencé par LogEntry\__construct(), CategoryView\commonCategoryDisplay(), HtmlView\display(), et HtmlView\prepareDocument().

◆ endforeach

endforeach

◆ endif

endif

◆ maxLevel

$this maxLevel

Référencé par CategoryView\commonCategoryDisplay(), et HtmlView\display().


Joomla CMS: Référence du fichier default_children.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/category/default_children.php

Espaces de nommage

Joomla\Site

Variables

$lang = Factory::getLanguage()
$user = Factory::getUser()
$groups = $user->getAuthorisedViewLevels()
endif
if(count($child->getChildren()) > 0 && $this->maxLevel > 1) | else
if(count($child->getChildren()) > 0 && $this->maxLevel > 1) $child | language
if(count($child->getChildren()) > 0 && $this->maxLevel > 1) $this | children [$child->id] = $child->getChildren()
$this | category = $child
$this | maxLevel
endforeach

Documentation des variables

◆ $groups

$groups = $user->getAuthorisedViewLevels()

◆ $lang

$lang = Factory::getLanguage()

◆ $user

$user = Factory::getUser()

◆ category

$this category = $child

◆ children

if (count( $child->getChildren()) > 0 &&$this->maxLevel > 1) $this children[ $child->id] = $child->getChildren()

◆ else

if (count( $child->getChildren()) > 0 &&$this->maxLevel > 1) else

◆ endforeach

endforeach

◆ endif

endif

◆ language

if (count( $child->getChildren()) > 0 &&$this->maxLevel > 1) $child language

◆ maxLevel

$this maxLevel


Joomla CMS: Référence du fichier default_children.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier com_newsfeeds/tmpl/category/default_children.php

Espaces de nommage

Joomla\Site

Variables

endif
$this | category = $child
$this | maxLevel
endforeach

Documentation des variables

◆ category

$this category = $child

◆ endforeach

endforeach

◆ endif

endif

◆ maxLevel

$this maxLevel


Joomla CMS: Référence du fichier default_component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier default_component.php

Espaces de nommage

Joomla\Site

Variables

$attributes = array()
if($item->anchor_title) if($item->anchor_css) if($item->anchor_rel) if($item->id==$active_id) | $linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($item->browserNav==1) | elseif ( $item->browserNav==2)

Documentation des variables

◆ $attributes

$attributes = array()

◆ $linktype

if ( $item->anchor_title) if ( $item->anchor_css) if ( $item->anchor_rel) if ( $item->id==$active_id) $linktype = $item->title

◆ elseif

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $item->browserNav==1) elseif($item->browserNav==2)


Joomla CMS: Référence du fichier default_config.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage | Variables
Référence du fichier default_config.php

Espaces de nommage

Joomla\Administrator

Variables

foreach ( $this->config as $key=> $value) = false
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

foreach | ( | $this->config as,
 |  | $value
 | ) | = false


Joomla CMS: Référence du fichier default_cookie.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_cookie.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_COOKIE_SETTINGS')
$this | fieldsname = 'cookie'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'cookie'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_COOKIE_SETTINGS')


Joomla CMS: Référence du fichier default_core.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Espaces de nommage | Variables
Référence du fichier default_core.php

Espaces de nommage

Joomla\Site

Variables

else __pad1__
endif

Documentation des variables

◆ __pad1__

else __pad1__

◆ endif

endif


Joomla CMS: Référence du fichier default_custom.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Espaces de nommage | Variables
Référence du fichier default_custom.php

Espaces de nommage

Joomla\Site

Variables

$fieldsets = $this->form->getFieldsets()
if(isset($fieldsets['core'])) if(isset($fieldsets['params'])) | $tmp = $this->data->jcfields ?? array()
$customFields = array()
if (count( $fields))
if(isset($fieldset->label) &&($legend=trim(Text::_($fieldset->label))) !=='') | endif
else __pad2__
else $field | value
endforeach

Documentation des variables

◆ $customFields

$customFields = array()

Référencé par PlgFieldsSubform\getSubfieldsFromField().

◆ $fieldsets

$fieldsets = $this->form->getFieldsets()

◆ $tmp

if (isset( $fieldsets[ 'core'])) if (isset( $fieldsets[ 'params'])) $tmp = $this->data->jcfields ?? array()

Référencé par CSR\__toString(), FtpClient\append(), SiteRouter\buildSefRoute(), TPMAttestationStatementSupport\convertCertificatesToPem(), Installer\discover(), HtmlView\display(), Form\findField(), Form\findFieldsByGroup(), Form\findGroup(), FormattedtextLogger\formatLine(), QuickIconHelper\getButtons(), Microdata\getExpectedTypes(), Form\getFieldsets(), GroupedlistField\getGroups(), ChromestyleField\getGroups(), HeadertagField\getOptions(), ModuletagField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), AndroidSafetyNetAttestationStatementSupport\getResponseBody(), AssociationExtensionHelper\getTypeFieldName(), RssParser\handleWebmaster(), Microdata\htmlTag(), LdapClient\ipToNetAddress(), Path\isOwner(), DaemonApplication\loadConfiguration(), Inline\parseScalar(), FtpClient\read(), ModuleRenderer\render(), ParagonIE_Sodium_Core_SipHash\rotl_64(), JSONGeneralSerializer\serialize(), Installer\setOverwrite(), Installer\setUpgrade(), Uri\setVar(), StringHelper\truncate(), TranscodeUnicode\utf7_ucs4array(), utf8_bad_identify(), utf8_is_valid(), utf8_to_unicode(), et FtpClient\write().

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(count($fields))

◆ value

else $field value


Joomla CMS: Référence du fichier default_database.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_database.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_DATABASE_SETTINGS')
$this | fieldsname = 'database'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'database'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_DATABASE_SETTINGS')


Joomla CMS: Référence du fichier default_debug.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_debug.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_DEBUG_SETTINGS')
$this | fieldsname = 'debug'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'debug'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_DEBUG_SETTINGS')


Joomla CMS: Référence du fichier default_description.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_description.php

Espaces de nommage

Joomla\Administrator

Variables

$client = ApplicationHelper::getClientInfo($this->template->client_id)
$this template xmldata = TemplatesHelper::parseXMLTemplateFile($client->path, $this->template->element)

Documentation des variables

◆ $client

$client = ApplicationHelper::getClientInfo($this->template->client_id)

◆ xmldata

$this template xmldata = TemplatesHelper::parseXMLTemplateFile($client->path, $this->template->element)


Joomla CMS: Référence du fichier default_directory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage | Variables
Référence du fichier default_directory.php

Espaces de nommage

Joomla\Administrator

Variables

endforeach

Documentation des variables

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default_filters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_filters.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_TEXT_FILTER_SETTINGS')
$this | fieldsname = 'filters'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'filters'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_TEXT_FILTER_SETTINGS')


Joomla CMS: Référence du fichier default_folders.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_folders.php

Espaces de nommage

Joomla\Administrator

Variables

$explodeArray = explode('/', rtrim($key, '\\'))
endif
endforeach

Documentation des variables

◆ $explodeArray

$explodeArray = explode('/', rtrim($key, '\\'))

Référencé par HtmlView\addToolbar(), TemplateHelper\canUpload(), TemplateModel\copyFile(), TemplateModel\createOverride(), HtmlView\display(), TemplateModel\extractArchive(), TemplateModel\getCoreFile(), TemplateModel\getFont(), TemplateModel\getSafeName(), TemplateModel\renameFile(), et TemplateModel\save().

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_form.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier com_contact/tmpl/contact/default_form.php

Espaces de nommage

Joomla\Site

Variables

foreach( $this->form->getFieldsets() as $fieldset)($fieldset->name==='captcha' &&! $this->captchaEnabled) endif
$fields = $this->form->getFieldset($fieldset->name)
endforeach

Documentation des variables

◆ $fields

$fields = $this->form->getFieldset($fieldset->name)

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_form.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
  • search
Espaces de nommage | Variables
Référence du fichier com_finder/tmpl/search/default_form.php

Espaces de nommage

Joomla\Site

Variables

if ( $this->params->get( 'show_autosuggest', 1))
endif
if ($this->params->get('show_advanced', 1)) ( $this->params->get( 'expand_advanced', 0))

Documentation des variables

◆ ($this->params->get('show_advanced', 1))

if ( $this->params->get( 'show_advanced', 1))($this->params->get('expand_advanced', 0))

◆ endif

endif

◆ if

if($this->params->get('show_autosuggest', 1))


Joomla CMS: Référence du fichier default_heading.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier default_heading.php

Espaces de nommage

Joomla\Site

Variables

$title = $item->anchor_title ? ' title="' . $item->anchor_title . '"' : ''
$anchor_css = $item->anchor_css ?: ''
$linktype = $item->title
if($item->menu_icon) elseif ( $item->menu_image)

Documentation des variables

◆ $anchor_css

$anchor_css = $item->anchor_css ?: ''

◆ $linktype

$linktype = $item->title

◆ $title

$title = $item->anchor_title ? ' title="' . $item->anchor_title . '"' : ''

◆ elseif

if ( $item->menu_icon) elseif($item->menu_image)


Joomla CMS: Référence du fichier default_item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier default_item.php

Espaces de nommage

Joomla\Site

Variables

$params = &$this->item->params
$canEdit = $this->item->params->get('access-edit')
$info = $this->item->params->get('info_block_position', 0)
$assocParam = (Associations::isEnabled() && $params->get('show_associations'))
$currentDate = Factory::getDate()->format('Y-m-d H:i:s')
$isExpired = !is_null($this->item->publish_down) && $this->item->publish_down < $currentDate
$isNotPublishedYet = $this->item->publish_up > $currentDate
$isUnpublished = $this->item->state == ContentComponent::CONDITION_UNPUBLISHED || $isNotPublishedYet || $isExpired
else __pad11__
endif
$useDefList
else __pad12__
$active = $menu->getActive()
$itemId = $active->id
$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))
if ( $isUnpublished)

Documentation des variables

◆ $active

$active = $menu->getActive()

◆ $assocParam

$assocParam = (Associations::isEnabled() && $params->get('show_associations'))

◆ $canEdit

$canEdit = $this->item->params->get('access-edit')

◆ $currentDate

$currentDate = Factory::getDate()->format('Y-m-d H:i:s')

◆ $info

$info = $this->item->params->get('info_block_position', 0)

◆ $isExpired

$isExpired = !is_null($this->item->publish_down) && $this->item->publish_down < $currentDate

◆ $isNotPublishedYet

$isNotPublishedYet = $this->item->publish_up > $currentDate

◆ $isUnpublished

$isUnpublished = $this->item->state == ContentComponent::CONDITION_UNPUBLISHED || $isNotPublishedYet || $isExpired

◆ $itemId

$itemId = $active->id

◆ $link

$link = new Uri(Route::_('index.php?option=com_users&view=login&Itemid=' . $itemId, false))

◆ $params

$params = &$this->item->params

◆ $useDefList

$useDefList
Valeur initiale :
= ($params->get('show_modify_date') || $params->get('show_publish_date') || $params->get('show_create_date')
|| $params->get('show_hits') || $params->get('show_category') || $params->get('show_parent_category') || $params->get('show_author') || $assocParam)
$assocParam
$assocParam
Definition: default_item.php:28
$params
$params
Definition: default_item.php:23

◆ __pad11__

else __pad11__

◆ __pad12__

else __pad12__

◆ endif

endif

◆ if

if($isUnpublished)


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/categories/default_items.php

Espaces de nommage

Joomla\Site

Variables

endif
if ( $this->maxLevelcat > 1 &&count( $item->getChildren()) > 0)
if($this->maxLevelcat > 1 &&count($item->getChildren()) > 0) $this | items [$item->id] = $item->getChildren()
$this | parent = $item
$this | maxLevelcat
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($this->maxLevelcat > 1 &&count($item->getChildren()) > 0)

◆ items

array $menus List of the menu items = $item->getChildren()

Référencé par ValidationData\__construct(), Domain\addItem(), FeedDocument\addItem(), ListView\addToolbar(), Changelog\characterData(), CategoryView\commonCategoryDisplay(), XmlView\display(), CategoriesView\display(), HtmlView\display(), Changelog\endElement(), ValidationData\get(), PositionsModel\getItems(), CheckinModel\getItems(), AbstractMenu\getMenu(), ValidationData\has(), ListView\initializeView(), ValidationData\setAudience(), ValidationData\setCurrentTime(), ValidationData\setId(), ValidationData\setIssuer(), ValidationData\setSubject(), et HtmlView\toolbar().

◆ maxLevelcat

$this maxLevelcat

Référencé par CategoriesView\display().

◆ parent

$this parent = $item

Référencé par AdapterInstance\__construct(), Container\__construct(), InstallerAdapter\__construct(), ComponentAdapter\_buildAdminMenus(), CollectionAdapter\_endElement(), CollectionAdapter\_getParent(), InstallerAdapter\canUninstallPackageChild(), LibraryAdapter\checkExtensionInFilesystem(), PackageAdapter\checkExtensionInFilesystem(), ComponentAdapter\checkExtensionInFilesystem(), InstallerAdapter\checkExtensionInFilesystem(), CategoryView\commonCategoryDisplay(), FileAdapter\copyBaseFiles(), LibraryAdapter\copyBaseFiles(), TemplateAdapter\copyBaseFiles(), PluginAdapter\copyBaseFiles(), ModuleAdapter\copyBaseFiles(), PackageAdapter\copyBaseFiles(), ComponentAdapter\copyBaseFiles(), PluginAdapter\createExtensionRoot(), ComponentAdapter\createExtensionRoot(), InstallerAdapter\createExtensionRoot(), InstallerAdapter\discover_install(), LanguageAdapter\discover_install(), CategoriesView\display(), HtmlView\display(), InstallerAdapter\doDatabaseTransactions(), ByteString\endsWith(), ByteString\equalsTo(), AbstractGroupButton\fetchId(), DropdownButton\fetchId(), ToolbarButton\fetchId(), FileAdapter\finaliseInstall(), ModuleAdapter\finaliseInstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), Container\get(), AbstractGroupButton\getChildToolbar(), HtmlDumper\getDumpHeader(), FileAdapter\getElement(), Container\getResource(), UpdateAdapter\getUpdateSiteName(), Container\has(), Container\hasFlag(), ByteString\indexOf(), ByteString\indexOfLast(), LanguageAdapter\install(), InstallerAdapter\install(), LibraryAdapter\loadLanguage(), TemplateAdapter\loadLanguage(), PluginAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), FileAdapter\parseOptionalTags(), LibraryAdapter\parseOptionalTags(), TemplateAdapter\parseOptionalTags(), PluginAdapter\parseOptionalTags(), ModuleAdapter\parseOptionalTags(), PackageAdapter\parseOptionalTags(), ComponentAdapter\parseOptionalTags(), InstallerAdapter\parseQueries(), FileAdapter\populateFilesAndFolderList(), LibraryAdapter\prepareDiscoverInstall(), PluginAdapter\prepareDiscoverInstall(), TemplateAdapter\prepareDiscoverInstall(), ModuleAdapter\prepareDiscoverInstall(), ModuleAdapter\refreshManifestCache(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PluginAdapter\refreshManifestCache(), TemplateAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LanguageAdapter\refreshManifestCache(), ComponentAdapter\refreshManifestCache(), LanguageAdapter\removeExtensionFiles(), FileAdapter\removeExtensionFiles(), LibraryAdapter\removeExtensionFiles(), PluginAdapter\removeExtensionFiles(), TemplateAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), ModuleAdapter\removeExtensionFiles(), ComponentAdapter\removeExtensionFiles(), LazyCommand\setApplication(), LazyCommand\setHelperSet(), RouterViewConfiguration\setParent(), ToolbarButton\setParent(), FileAdapter\setupInstallPaths(), LibraryAdapter\setupInstallPaths(), PluginAdapter\setupInstallPaths(), TemplateAdapter\setupInstallPaths(), PackageAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), ComponentAdapter\setupInstallPaths(), InstallerAdapter\setupScriptfile(), LanguageAdapter\setupUninstall(), FileAdapter\setupUninstall(), LibraryAdapter\setupUninstall(), PluginAdapter\setupUninstall(), TemplateAdapter\setupUninstall(), PackageAdapter\setupUninstall(), ModuleAdapter\setupUninstall(), ComponentAdapter\setupUninstall(), ComponentAdapter\setupUpdates(), ByteString\startsWith(), FileAdapter\storeExtension(), LibraryAdapter\storeExtension(), PluginAdapter\storeExtension(), PackageAdapter\storeExtension(), TemplateAdapter\storeExtension(), UpdateAdapter\toggleUpdateSite(), PackageAdapter\triggerManifestScript(), InstallerAdapter\triggerManifestScript(), LanguageAdapter\update(), et InstallerAdapter\update().


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/category/default_items.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$canDo = ContactHelper::getActions('com_contact', 'category', $this->category->id)
$canEdit = $canDo->get('core.edit')
$userId = Factory::getUser()->id
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad0__
foreach( $this->items as $i=> $item)($this->items[$i]->published==0) else
$location = array()
endforeach

Documentation des variables

◆ $canDo

$canDo = ContactHelper::getActions('com_contact', 'category', $this->category->id)

Référencé par HtmlView\addToolbar(), FormView\addToolbar(), ListView\addToolbar(), DisplayController\canView(), et HtmlView\display().

◆ $canEdit

$canEdit = $canDo->get('core.edit')

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $location

$location = array()

Référencé par PlgExtensionJoomla\addUpdateSite(), DateCaster\castDateTime(), DateCaster\castTimeZone(), TemplateModel\copyFile(), TemplateController\createFile(), TemplateModel\createFile(), TemplateModel\createFolder(), TemplateModel\deleteFolder(), ASN1\encode_der(), ASN1\encodeDER(), LanguageStringsCollector\getData(), TimezoneField\getGroups(), QueryCollector\getStatements(), CaBundle\getSystemCaRootBundlePath(), PlgContentPagenavigation\onContentBeforeDisplay(), TemplateController\uploadFile(), et TemplateModel\uploadFile().

◆ $userId

$userId = Factory::getUser()->id

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ else

foreach ($this->items as $i => $item) ( $this->items[ $i]->published==0) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/featured/default_items.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad11__
foreach( $this->items as $i=> $item)($this->items[$i]->published==0) else
endforeach

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad11__

else __pad11__

◆ else

foreach ($this->items as $i => $item) ( $this->items[ $i]->published==0) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • archive
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/archive/default_items.php

Espaces de nommage

Joomla\Site

Variables

$params = $this->params
else __pad0__
endif
if($params->get('show_author') &&!empty($item->author)) $author = '<span itemprop="name">' . $author . '</span>'
else __pad1__
$useDefList

Documentation des variables

◆ $author

else $author = '<span itemprop="name">' . $author . '</span>'

Référencé par HtmlView\_prepareDocument(), Dispatcher\checkAccess(), CategoryFeedView\display(), FeedView\display(), Editor\display(), PlgEditorNone\onDisplay(), PlgButtonImage\onDisplay(), PlgEditorCodemirror\onDisplay(), RssParser\processFeedEntry(), FeedEntry\setAuthor(), et Feed\setAuthor().

◆ $params

$params = $this->params

◆ $useDefList

$useDefList
Valeur initiale :
= ($params->get('show_modify_date') || $params->get('show_publish_date') || $params->get('show_create_date')
|| $params->get('show_hits') || $params->get('show_category') || $params->get('show_parent_category'))
$params
$params
Definition: components/com_content/tmpl/archive/default_items.php:18

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endif

endif


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/categories/default_items.php

Espaces de nommage

Joomla\Site

Variables

endif
if (count( $item->getChildren()) > 0 &&$this->maxLevelcat > 1)
if(count($item->getChildren()) > 0 && $this->maxLevelcat > 1) $this | items [$item->id] = $item->getChildren()
$this | parent = $item
$this | maxLevelcat
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(count($item->getChildren()) > 0 && $this->maxLevelcat > 1)

◆ items

if (count( $item->getChildren()) > 0 &&$this->maxLevelcat > 1) $this items[ $item->id] = $item->getChildren()

◆ maxLevelcat

$this maxLevelcat

◆ parent

$this parent = $item


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier components/com_newsfeeds/tmpl/categories/default_items.php

Espaces de nommage

Joomla\Site

Variables

endif
if (count( $item->getChildren()) > 0 &&$this->maxLevelcat > 1)
if(count($item->getChildren()) > 0 && $this->maxLevelcat > 1) $this | items [$item->id] = $item->getChildren()
$this | parent = $item
$this | maxLevelcat
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(count($item->getChildren()) > 0 && $this->maxLevelcat > 1)

◆ items

if (count( $item->getChildren()) > 0 &&$this->maxLevelcat > 1) $this items[ $item->id] = $item->getChildren()

◆ maxLevelcat

$this maxLevelcat

◆ parent

$this parent = $item


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier components/com_newsfeeds/tmpl/category/default_items.php

Espaces de nommage

Joomla\Site

Variables

$n = count($this->items)
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad0__
else ENT_COMPAT

Documentation des variables

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $n

$n = count($this->items)

◆ __pad0__

else __pad0__

◆ ENT_COMPAT

else ENT_COMPAT
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par UiTab\addTab(), Users\admin_language(), DatabaseExporter\buildXmlData(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), OutputFilter\cleanText(), InputFilter\decode(), CategoryFeedView\display(), FeedView\display(), CategoriesView\display(), HtmlView\display(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), Exception\errorMessage(), HtmlErrorRenderer\escape(), BreadcrumbsHelper\getHome(), PrefixField\getInput(), ImpmadeField\getInput(), ClicksField\getInput(), MenutypeField\getInput(), EditorField\getInput(), TosField\getLabel(), SpacerField\getLabel(), BreadcrumbsHelper\getList(), Mbstring\html_encoding_callback(), Languages\id(), Users\language(), Route\link(), Pathway\makeItem(), Mbstring\mb_convert_encoding(), PlgContentConfirmConsent\onContentPrepareForm(), PlgSystemLanguagecode\onContentPrepareForm(), FieldsListPlugin\onCustomFieldsPrepareDom(), ModuleRenderer\render(), RssRenderer\render(), AtomRenderer\render(), ScriptsRenderer\renderAttributes(), StylesRenderer\renderAttributes(), FormField\renderDataAttributes(), MessageModel\save(), BreadcrumbsHelper\setSeparator(), Users\templatestyle(), HTMLHelper\tooltip(), et Users\value().


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tag
Espaces de nommage | Variables
Référence du fichier components/com_tags/tmpl/tag/default_items.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$canEdit = $user->authorise('core.edit', 'com_tags')
$canCreate = $user->authorise('core.create', 'com_tags')
$canEditState = $user->authorise('core.edit.state', 'com_tags')
endif
else __pad0__
else __pad1__
$images = json_decode($item->core_images)
if ( $this->params->get( 'tag_list_show_item_description', 1))
endforeach

Documentation des variables

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_tags')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_tags')

◆ $canEditState

$canEditState = $user->authorise('core.edit.state', 'com_tags')

Référencé par WorkflowModel\getForm(), StageModel\getForm(), et TransitionModel\getForm().

◆ $images

$images = json_decode($item->core_images)

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($this->params->get('tag_list_show_item_description', 1))


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage | Variables
Référence du fichier components/com_tags/tmpl/tags/default_items.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$user = Factory::getUser()
$canEdit = $user->authorise('core.edit', 'com_tags')
$canCreate = $user->authorise('core.create', 'com_tags')
$canEditState = $user->authorise('core.edit.state', 'com_tags')
$columns = $this->params->get('tag_columns', 1)
if($columns< 1) | $bsspans = floor(12 / $columns)
if($bsspans< 1) | $bscolumns = min($columns, floor(12 / $bsspans))
$n = count($this->items)
endif
else __pad4__
$imageOptions = []
if($images->image_intro_caption) | $imageOptions ['class'] = 'caption'
if(($i===0 && $n===1)|| $i===$n - 1|| $bscolumns===1||(($i+1) % $bscolumns===0)) | endforeach

Documentation des variables

◆ $bscolumns

if ( $bsspans< 1) $bscolumns = min($columns, floor(12 / $bsspans))

◆ $bsspans

if ( $columns< 1) $bsspans = floor(12 / $columns)

◆ $canCreate

$canCreate = $user->authorise('core.create', 'com_tags')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_tags')

◆ $canEditState

$canEditState = $user->authorise('core.edit.state', 'com_tags')

◆ $columns

$columns = $this->params->get('tag_columns', 1)

Référencé par LinksModel\batchProcess(), Table\calculateNumberOfColumns(), TemplateModel\copyStyles(), ConfigurationModel\createRootUser(), MetadataManager\createSessionRecord(), MysqlImporter\getKeySql(), MysqliImporter\getKeySql(), TextareaField\getLayoutData(), Table\getNumberOfColumns(), Table\getRowColumns(), SqliteDriver\getTableColumns(), PgsqlDriver\insertObject(), Cursor\moveLeft(), Cursor\moveRight(), PlgSystemActionLogs\onUserAfterSave(), TemplateAdapter\parseQueries(), Table\renderRow(), PlgInstallerOverride\saveOverrides(), SSH2\setWindowSize(), PgsqlDriver\sqlValue(), et PgsqlDriver\updateObject().

◆ $imageOptions [1/2]

$imageOptions = []

◆ $imageOptions [2/2]

if ( $images->image_intro_caption) $imageOptions[ 'class'] = 'caption'

◆ $n

$n = count($this->items)

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ endforeach

if (( $i===0 &&$n===1)||$i===$n - 1||$bscolumns===1||(( $i+1) % $bscolumns===0)) endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_categories/tmpl/default_items.php

Espaces de nommage

Joomla\Site

Variables

$input = $app->input
$option = $input->getCmd('option')
$view = $input->getCmd('view')
$id = $input->getInt('id')
foreach( $list as $item)($id==$item->id &&in_array($view, array('category', 'categories')) && $option=='com_content') | $levelup = $item->level - $startLevel - 1
endif
if( $params->get('show_children', 0) &&(($params->get('maxlevel', 0)==0)||($params->get('maxlevel') >=($item->level - $startLevel))) &&count($item->getChildren())) | $temp = $list
$list = $item->getChildren()
endforeach

Documentation des variables

◆ $id

$id = $input->getInt('id')

◆ $input

$input = $app->input

◆ $levelup

foreach ($list as $item) ( $id==$item->id &&in_array( $view, array( 'category', 'categories')) &&$option=='com_content') $levelup = $item->level - $startLevel - 1

◆ $list

$list = $item->getChildren()

◆ $option

$option = $input->getCmd('option')

◆ $temp

if ($params->get( 'show_children', 0) &&(( $params->get( 'maxlevel', 0)==0)||( $params->get( 'maxlevel') >=( $item->level - $startLevel))) &&count( $item->getChildren())) $temp = $list
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par BinaryField\__construct(), Engine\__construct(), Rules\__toString(), Engine\__wakeup(), BigInteger\__wakeup(), BCMath\abs(), GMP\abs(), PHP\abs(), PHP32\add(), PHP64\add(), Integer\add(), GMP\add(), BCMath\add(), PHP\addHelper(), Taxonomy\addNestedNode(), UserHelper\addUserToGroup(), SSH2\append_log(), ANSI\appendString(), ASN1\asn1map(), Engine\base256_lshift(), PHP\baseSquare(), GMP\bitwise_and(), Engine\bitwise_leftRotate(), BCMath\bitwise_leftShift(), GMP\bitwise_leftShift(), PHP\bitwise_leftShift(), Engine\bitwise_not(), GMP\bitwise_or(), BCMath\bitwise_rightShift(), GMP\bitwise_rightShift(), PHP\bitwise_rightShift(), PHP\bitwise_split(), GMP\bitwise_xor(), HTMLHelper\call(), Adapter\categoryAccessChange(), Adapter\categoryStateChange(), CoreContent\check(), Module\check(), Content\check(), SFTP\chmod(), SSH2\connect(), GMP\createRecurringModuloFunction(), Salsa20\crypt(), ASN1\decodeLength(), ASN1\decodeOID(), RC2\decrypt(), Rijndael\decryptBlock(), SFTP\delete_recursive(), Prime\derivePoint(), HtmlView\directoryTree(), HtmlView\display(), BCMath\div(), PHP\divide_digit(), PHP\divideHelper(), Montgomery\doubleAndAddPoint(), Ed25519\doublePoint(), PublicKey\emsa_pss_verify(), ASN1\encode_der(), ASN1\encodeLength(), ASN1\encodeOID(), XML\encodeXMLParameters(), RC2\encrypt(), Rijndael\encryptBlock(), SSH2\exec(), KoblitzPrime\extendedGCD(), BCMath\extendedGCD(), Engine\extendedGCDHelper(), ASN1\extractBER(), X509\fetchURL(), EvalBarrett\float2string(), HtmlView\folderTree(), BCMath\format(), EvalBarrett\generateCustomReduction(), PuTTY\generateV2Key(), PuTTY\generateV3Key(), SFTP\get(), CategoryNode\getChildren(), ProfileModel\getData(), ApplicationModel\getData(), RegistrationModel\getData(), TemplateModel\getFile(), ContactModel\getForm(), PluginHelper\getLayoutPath(), ModuleHelper\getLayoutPath(), BannersModel\getListQuery(), Mfa\getMfaMethods(), SiteApplication\getParams(), CategoryNode\getSibling(), PlgSystemUpdatenotification\getSuperUsers(), SFTP\getSupportedVersions(), SymmetricKey\ghash(), Hash\hash(), Strings\increment_str(), PHP64\initialize(), BCMath\initialize(), GMP\initialize(), PHP\initialize(), Adapter\itemAccessChange(), Adapter\itemStateChange(), PHP\karatsuba(), PHP\karatsubaSquare(), SSH2\key_exchange(), XML\load(), Raw\load(), OpenSSH\load(), PuTTY\load(), PKCS8\load(), phpseclib3\Crypt\EC\Formats\Keys\loadCurveByParam(), X509\loadSPKAC(), FinderHelper\logSearch(), PHP\lshift(), Http\makeTransportRequest(), X509\mapOutAttributes(), X509\mapOutExtensions(), HtmlView\mediaFolderTree(), HtmlView\mediaTree(), SFTP\mkdir(), GMP\modInverse(), Integer\modInverse(), PHP32\multiply(), PHP64\multiply(), GMP\multiply(), BCMath\multiply(), Prime\multiplyAddPoints(), Barrett\multiplyLower(), MontgomeryMult\multiplyReduce(), Base\multiplyReduce(), BCMath\negate(), GMP\negate(), PHP\negate(), Base\negatePoint(), Hash\nh(), SFTP\nlist_helper(), PlgFinderCategories\onFinderChangeState(), SymmetricKey\openssl_ctr_process(), SymmetricKey\pkcs12helper(), BCMath\pow(), Integer\pow(), GMP\pow(), PHP\powHelper(), BuiltIn\powModHelper(), DefaultEngine\powModHelper(), Base\powModHelper(), Engine\powModOuter(), Montgomery\prepareReduce(), Menu\preprocess(), Hash\processSHA3Block32(), Hash\processSHA3Block64(), SFTP\put(), SFTP\query_stat_cache(), Engine\randomRangeHelper(), Engine\randomRangePrimeOuter(), PrivateKey\raw_encrypt(), PublicKey\raw_encrypt(), SSH2\read_remaining_bytes(), SFTP\readlist(), Ed25519\recoverX(), Classic\reduce(), PowerOfTwo\reduce(), Montgomery\reduce(), Barrett\reduce(), RegistrationModel\register(), Barrett\regularBarrett(), PHP\regularMultiply(), Integer\regularPolynomialMultiply(), InputFilter\remove(), SFTP\remove_from_stat_cache(), UserHelper\removeUserFromGroup(), Agent\requestIdentities(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), PHP\rshift(), PSS\savePSSParams(), PHP\scan1divide(), Filter\select(), SSH2\send_binary_packet(), SSH2\send_channel_packet(), ActionlogModel\sendNotificationEmails(), BCMath\setBitmask(), X509\setEndDate(), SymmetricKey\setEngine(), HtmlView\setLayout(), Engine\setPrecision(), SFTP\setstat_recursive(), RC4\setupKey(), Rijndael\setupKey(), UserHelper\setUserGroups(), Hash\sha3_pad(), Hash\sha512(), PrivateKey\sign(), Montgomery\slidingWindow(), Engine\slidingWindow(), BCMath\sqrt(), Integer\squareRoot(), TemplateModel\storeFileInfo(), PHP32\subtract(), PHP64\subtract(), GMP\subtract(), BCMath\subtract(), Integer\subtract(), PHP\subtractHelper(), BigInteger\toBytes(), BCMath\toBytes(), GMP\toBytes(), Engine\toBytesHelper(), Helper\tokenize(), PHP\toString(), Strings\unpackSSH2(), SFTP\update_stat_cache(), PSSRSA\verifyEMSAPSS(), RSA\verifyEMSAPSS(), KoblitzPrime\verifyPoint(), et Prime\verifyPoint().

◆ $view

$view = $input->getCmd('view')

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_articles_category/tmpl/default_items.php

Espaces de nommage

Joomla\Site

Variables

foreach( $items as $item)($params->get('link_titles')==1) $link = htmlspecialchars($item->link, ENT_COMPAT, 'UTF-8', false)
$title = htmlspecialchars($item->title, ENT_COMPAT, 'UTF-8', false)
else __pad1__
endif
if ( $params->get( 'show_readmore'))
elseif ( $item->alternative_readmore)
else __pad2__
endforeach

Documentation des variables

◆ $link

foreach ($items as $item) ( $params->get( 'link_titles')==1) $link = htmlspecialchars($item->link, ENT_COMPAT, 'UTF-8', false)

◆ $title

$title = htmlspecialchars($item->title, ENT_COMPAT, 'UTF-8', false)

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ elseif

elseif($item->alternative_readmore)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($params->get('show_readmore'))


Joomla CMS: Référence du fichier default_links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier com_contact/tmpl/contact/default_links.php

Espaces de nommage

Joomla\Site

Variables

$label = $this->item->params->get('link' . $char . '_name')
if(! $link) endif
$link = (0 === strpos($link, 'http')) ? $link : 'http://' . $link
endforeach

Documentation des variables

◆ $label

$label = $this->item->params->get('link' . $char . '_name')

◆ $link

$link = (0 === strpos($link, 'http')) ? $link : 'http://' . $link

◆ endforeach

endforeach

◆ endif

if (! $link) endif


Joomla CMS: Référence du fichier default_links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • article
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/article/default_links.php

Espaces de nommage

Joomla\Site

Variables

$urls = json_decode($this->item->urls)
$params = $this->item->params
foreach($urlarray as $url) | $label = $url[1]
$target = $url[2]
$id = $url[3]
if(! $link) | endif
switch($target) | endforeach

Documentation des variables

◆ $id

$id = $url[3]

◆ $label

$label = $url[1]

◆ $params

$params = $this->item->params

◆ $target

$target = $url[2]

Référencé par InstallerHelper\downloadPackage(), UpdateModel\downloadPackage(), Manifest\fromContent(), Stub\fromContent(), AssociationsHelper\getAssociationHtmlList(), DayOfMonthField\getNearestWeekday(), Nyholm\Psr7\getRequestTarget(), Laminas\Diactoros\getRequestTarget(), MediaHelper\imageResize(), MinutesField\increment(), HoursField\increment(), FileAdapter\populateFilesAndFolderList(), AdminModel\redirectToAssociations(), FileAdapter\removeExtensionFiles(), ConfigPostProcessor\replaceDependencyAliases(), ConfigPostProcessor\replaceDependencyInvokables(), HtmlDumper\style(), SFTP\symlink(), TaskModel\wildcardIfMatch(), et Behavior\withAssertion().

◆ $urls

$urls = json_decode($this->item->urls)

Référencé par LinkTable\check().

◆ endforeach

switch ( $target) endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier com_content/tmpl/featured/default_links.php

Espaces de nommage

Joomla\Site

Variables

endforeach

Documentation des variables

◆ endforeach

endforeach


Joomla CMS: Référence du fichier default_locale.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_locale.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_LOCATION_SETTINGS')
$this | fieldsname = 'locale'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'locale'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_LOCATION_SETTINGS')


Joomla CMS: Référence du fichier default_logging.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_logging.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_LOGGING_SETTINGS')
$this | fieldsname = 'logging'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'logging'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_LOGGING_SETTINGS')


Joomla CMS: Référence du fichier default_logging_custom.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_logging_custom.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_LOGGING_CUSTOM_SETTINGS')
$this | fieldsname = 'logging_custom'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'logging_custom'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_LOGGING_CUSTOM_SETTINGS')


Joomla CMS: Référence du fichier default_login.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • login
Espaces de nommage | Variables
Référence du fichier default_login.php

Espaces de nommage

Joomla\Site

Variables

$usersConfig = ComponentHelper::getParams('com_users')
endif
if (( $this->params->get( 'logindescription_show')==1 &&str_replace(' ', '', $this->params->get( 'login_description', '')) !='')||$this->params->get( 'login_image') !='')

Documentation des variables

◆ $usersConfig

$usersConfig = ComponentHelper::getParams('com_users')

◆ endif

endif

◆ if

if(($this->params->get('logindescription_show')==1 &&str_replace(' ', '', $this->params->get('login_description', '')) !='')|| $this->params->get('login_image') !='')


Joomla CMS: Référence du fichier default_logout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • login
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/login/default_logout.php

Espaces de nommage

Joomla\Site

Variables

endif
if (( $this->params->get( 'logoutdescription_show')==1 &&str_replace(' ', '', $this->params->get( 'logout_description')) !='')||$this->params->get( 'logout_image') !='')
else __pad0__

Documentation des variables

◆ __pad0__

else __pad0__

◆ endif

endif

◆ if

if(($this->params->get('logoutdescription_show')==1 &&str_replace(' ', '', $this->params->get('logout_description')) !='')|| $this->params->get('logout_image') !='')


Joomla CMS: Référence du fichier default_logout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • tmpl
Espaces de nommage | Variables
Référence du fichier modules/mod_login/tmpl/default_logout.php

Espaces de nommage

Joomla\Site

Variables

else __pad2__
endif

Documentation des variables

◆ __pad2__

else __pad2__

◆ endif

endif


Joomla CMS: Référence du fichier default_mail.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_mail.php

Espaces de nommage

Joomla\Administrator

Variables

$ajaxUri = Route::_('index.php?option=com_config&task=application.sendtestmail&format=json&' . Session::getFormToken() . '=1')
$this | name = Text::_('COM_CONFIG_MAIL_SETTINGS')
$this | fieldsname = 'mail'
$this | formclass = 'options-form'

Documentation des variables

◆ $ajaxUri

$ajaxUri = Route::_('index.php?option=com_config&task=application.sendtestmail&format=json&' . Session::getFormToken() . '=1')

◆ fieldsname

$this fieldsname = 'mail'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_MAIL_SETTINGS')


Joomla CMS: Référence du fichier default_media_folders.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_media_folders.php

Espaces de nommage

Joomla\Administrator

Variables

$explodeArray = explode('/', rtrim($key, '\\'))
endif
endforeach

Documentation des variables

◆ $explodeArray

$explodeArray = explode('/', rtrim($key, '\\'))

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • installer
Espaces de nommage | Variables
Référence du fichier default_message.php

Espaces de nommage

Joomla\Administrator

Variables

$state = $this->get('State')
$message1 = $state->get('message')
$message2 = $state->get('extension_message')
if($message1) endif

Documentation des variables

◆ $message1

$message1 = $state->get('message')

Référencé par HtmlView\display(), et DatabaseModel\getErrorsMessage().

◆ $message2

$message2 = $state->get('extension_message')

Référencé par HtmlView\display(), et DatabaseModel\getErrorsMessage().

◆ $state

$state = $this->get('State')

Référencé par Response\__construct(), CSR\__construct(), Result\__serialize(), Taxonomy\addBranch(), Taxonomy\addNestedNode(), Result\addNestedTaxonomy(), Taxonomy\addNode(), Result\addTaxonomy(), HtmlView\addToolbar(), IndexerController\batch(), LinksModel\batchProcess(), CategoryView\commonCategoryDisplay(), Workflow\createAssociation(), Client\createUrl(), ParagonIE_Sodium_Compat\crypto_kdf_derive_from_key(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_pull(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_push(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_rekey(), Rijndael\decryptBlock(), FeedView\display(), CategoriesView\display(), HtmlView\display(), ExtensionDiscoverListCommand\doExecute(), WebAssetManager\enableDependencies(), Rijndael\encryptBlock(), AdministratorService\featured(), ExtensionDiscoverListCommand\filterExtensionsBasedOnState(), ParagonIE_Sodium_Core_SecretStream_State\fromString(), ParagonIE_Sodium_Core32_SecretStream_State\fromString(), ComponentModel\getComponent(), ComponentModel\getForm(), TemplateModel\getForm(), PositionsModel\getItems(), ClientsModel\getItems(), FiltersModel\getListQuery(), ConsentsModel\getListQuery(), FeaturedModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), GroupsModel\getListQuery(), LinksModel\getListQuery(), FieldsModel\getListQuery(), AssociationsModel\getListQuery(), MapsModel\getListQuery(), IndexModel\getListQuery(), ArticlesModel\getListQuery(), ModulesModel\getListQuery(), UsersModel\getListQuery(), CategoryeditField\getOptions(), Indexer\getSignature(), Indexer\getState(), ModulesHelper\getTemplates(), TemplateModel\getUpdatedList(), Encoding\hexToBin(), Indexer\index(), FinderIndexCommand\index(), AbstractWebApplication\isRedirectState(), Task\isValidState(), ParagonIE_Sodium_Core_Poly1305\onetimeauth(), ParagonIE_Sodium_Core32_Poly1305\onetimeauth(), ParagonIE_Sodium_Core_Poly1305\onetimeauth_verify(), ParagonIE_Sodium_Core32_Poly1305\onetimeauth_verify(), PlgFinderCategories\onFinderChangeState(), IndexerController\optimize(), PositionsModel\populateState(), Modules\positions(), Nested\publish(), Table\publish(), Redirect\published(), Indexer\resetState(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_push(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_rekey(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_rekey(), SiteApplication\setDetectBrowser(), HtmlDocument\setHtml5(), SiteApplication\setLanguageFilter(), Installer\setOverwrite(), Indexer\setState(), Installer\setUpgrade(), IndexerController\start(), Messages\status(), Modules\templates(), Indexer\toggleTables(), Indexer\tokenizeToDbShort(), et Workflow\updateAssociations().

◆ endif

if ( $message2) endif


Joomla CMS: Référence du fichier default_metadata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier administrator/components/com_config/tmpl/application/default_metadata.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_METADATA_SETTINGS')
$this | fieldsname = 'metadata'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'metadata'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_METADATA_SETTINGS')


Joomla CMS: Référence du fichier default_metadata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • config
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/config/default_metadata.php

Espaces de nommage

Joomla\Site

Variables

foreach ( $this->form->getFieldset( 'metadata') as $field)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

foreach($this->form->getFieldset('metadata') as $field)


Joomla CMS: Référence du fichier default_modal_child_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_modal_child_body.php

Espaces de nommage

Joomla\Administrator

Variables

$options = []
if(count($this->styles) > 0) $fancySelectData

Documentation des variables

◆ $fancySelectData

if (count( $this->styles) > 0) $fancySelectData
Valeur initiale :
= [
'autocomplete' => 'off'

◆ $options

$options = []


Joomla CMS: Référence du fichier default_modal_child_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_child_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_copy_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_copy_body.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_copy_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_copy_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_delete_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_delete_body.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_delete_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_modal_delete_footer.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input

Documentation des variables

◆ $input

$input = Factory::getApplication()->input


Joomla CMS: Référence du fichier default_modal_file_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_modal_file_body.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input
endif
$cMax = $this->state->get('params')->get('upload_limit')
$maxSize = HTMLHelper::_('number.bytes', Utility::getMaxUploadSize($cMax . 'MB'))

Documentation des variables

◆ $cMax

$cMax = $this->state->get('params')->get('upload_limit')

◆ $input

$input = Factory::getApplication()->input

◆ $maxSize

$maxSize = HTMLHelper::_('number.bytes', Utility::getMaxUploadSize($cMax . 'MB'))

◆ endif

endif


Joomla CMS: Référence du fichier default_modal_file_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_file_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_folder_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_modal_folder_body.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input
endif

Documentation des variables

◆ $input

$input = Factory::getApplication()->input

◆ endif

endif


Joomla CMS: Référence du fichier default_modal_folder_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_modal_folder_footer.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input

Documentation des variables

◆ $input

$input = Factory::getApplication()->input


Joomla CMS: Référence du fichier default_modal_rename_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_rename_body.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_rename_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_rename_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_resize_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_resize_body.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_modal_resize_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage
Référence du fichier default_modal_resize_footer.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_navigation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier application/default_navigation.php

Espaces de nommage

Joomla\Administrator

Variables

endif
foreach ( $this->components as $component)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->components as $component)


Joomla CMS: Référence du fichier default_navigation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • component
Espaces de nommage | Variables
Référence du fichier component/default_navigation.php

Espaces de nommage

Joomla\Administrator

Variables

endif
foreach($this->components as $component) if ( $this->currentComponent===$component)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif

◆ if

foreach ( $this->components as $component) if($this->currentComponent===$component)


Joomla CMS: Référence du fichier default_options.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier modules/default_options.php

Espaces de nommage

Joomla\Site

Variables

$fieldSets = $this->form->getFieldsets('params')
$i = 0
$class = isset($fieldSet->class) && !empty($fieldSet->class) ? $fieldSet->class : ''
endif
endforeach

Documentation des variables

◆ $class

$class = isset($fieldSet->class) && !empty($fieldSet->class) ? $fieldSet->class : ''

◆ $fieldSets

$fieldSets = $this->form->getFieldsets('params')

◆ $i

$i = 0

◆ endforeach

endforeach

◆ endif

foreach ($this->form->getFieldset($name) as $field) (Multilanguage::isEnabled() &&$this->item[ 'module']==='mod_menu' &&$field->getAttribute( 'name')==='menutype') endif


Joomla CMS: Référence du fichier default_options.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • templates
Espaces de nommage | Variables
Référence du fichier templates/default_options.php

Espaces de nommage

Joomla\Site

Variables

$fieldSets = $this->form->getFieldsets('params')

Documentation des variables

◆ $fieldSets

$fieldSets = $this->form->getFieldsets('params')


Joomla CMS: Référence du fichier default_params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Espaces de nommage | Variables
Référence du fichier default_params.php

Espaces de nommage

Joomla\Site

Variables

$fields = $this->form->getFieldset('params')
else __pad3__
else $field value
endif
endforeach

Documentation des variables

◆ $fields

$fields = $this->form->getFieldset('params')

◆ __pad3__

else __pad3__

◆ endforeach

endforeach

◆ endif

endif

◆ value

else $field value


Joomla CMS: Référence du fichier default_permissions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_permissions.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_PERMISSION_SETTINGS')
$this | description = ''
$this | fieldsname = 'permissions'
$this | formclass = 'form-no-columns options-form'
$this | showlabel = false

Documentation des variables

◆ description

string $descClass The class name to use for the description = ''

Référencé par InputArgument\__construct(), InputOption\__construct(), Command\__construct(), Update\check(), TosField\getLabel(), SpacerField\getLabel(), FormField\getLayoutData(), PackageManifest\loadManifestFromData(), HtmlDocument\mergeHeadData(), OpensearchDocument\render(), HtmlDocument\resetHeadData(), AbstractCommand\setDescription(), Command\setDescription(), Document\setDescription(), HtmlDocument\setHeadData(), et AccessiblemediaField\setup().

◆ fieldsname

$this fieldsname = 'permissions'

◆ formclass

$this formclass = 'form-no-columns options-form'

◆ name

$this name = Text::_('COM_CONFIG_PERMISSION_SETTINGS')

◆ showlabel

$this showlabel = false


Joomla CMS: Référence du fichier default_phpinfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage
Référence du fichier default_phpinfo.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_phpsettings.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage
Référence du fichier default_phpsettings.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_profile.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier default_profile.php

Espaces de nommage

Joomla\Site

Variables

foreach( $fields as $profile)($profile->value) $profile | text = htmlspecialchars($profile->value, ENT_COMPAT, 'UTF-8')
else __pad8__
break
case | __pad9__
case $profile Text::_('DATE_FORMAT_LC4') | false
default | __pad10__
endswitch
endif
endforeach

Documentation des variables

◆ __pad10__

default __pad10__

◆ __pad8__

else __pad8__

◆ __pad9__

case __pad9__

◆ break

break

◆ endforeach

endforeach

◆ endif

endif

◆ endswitch

endswitch

◆ false

case $profile Text::_ ( 'DATE_FORMAT_LC4') false

◆ text

string $text The label text = htmlspecialchars($profile->value, ENT_COMPAT, 'UTF-8')

Layout variables

Référencé par PhpToken\__construct(), PaginationObject\__construct(), ListHelper\genericordering(), ImptotalField\getInput(), MenuParentField\getOptions(), PhpToken\getTokenName(), User\groups(), PhpToken\is(), Modules\positionList(), et ToolbarHelper\saveGroup().


Joomla CMS: Référence du fichier default_proxy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_proxy.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_PROXY_SETTINGS')
$this | fieldsname = 'proxy'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'proxy'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_PROXY_SETTINGS')


Joomla CMS: Référence du fichier default_result.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
  • search
Espaces de nommage | Variables
Référence du fichier default_result.php

Espaces de nommage

Joomla\Site

Variables

$user = Factory::getApplication()->getIdentity()
$show_description = $this->params->get('show_description', 1)
if($show_description) | $showImage = $this->params->get('show_image', 0)
$imageClass = $this->params->get('image_class', '')
$extraAttr = []
if($showImage &&!empty($this->result->imageUrl) && $imageClass !=='') | $icon = ''
if(!empty($this->result->mime)) | $show_url = ''
else __pad1__
else $this result | imageUrl
else $this result $this result | imageAlt
endif
else __pad2__
$taxonomies = $this->result->getTaxonomy()
endforeach
if (count( $taxonomy_text))

Documentation des variables

◆ $extraAttr

else $this result $this result $extraAttr = []

◆ $icon

if ( $showImage &&!empty( $this->result->imageUrl) &&$imageClass !=='') $icon = ''

◆ $imageClass

$imageClass = $this->params->get('image_class', '')

◆ $show_description

$show_description = $this->params->get('show_description', 1)

◆ $show_url

if (!empty( $this->result->mime)) $show_url = ''

◆ $showImage

if ( $show_description) $showImage = $this->params->get('show_image', 0)

◆ $taxonomies

$taxonomies = $this->result->getTaxonomy()

Référencé par Taxonomy\getBranch(), FinderIndexCommand\getFilters(), SearchModel\getListQuery(), et Taxonomy\getTaxonomy().

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(count($taxonomy_text))

◆ imageAlt

else $this result $this result imageAlt

◆ imageUrl

else $this result imageUrl


Joomla CMS: Référence du fichier default_results.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
  • search
Espaces de nommage | Variables
Référence du fichier default_results.php

Espaces de nommage

Joomla\Site

Variables

$linkUrl = Route::_($uri->toString(array('path', 'query')))
$link = '<a href="' . $linkUrl . '">' . $this->escape($this->suggested) . '</a>'
endif
$multilang = Factory::getApplication()->getLanguageFilter() ? '_MULTILANG' : ''
return
< ol id="search-result-list" class="js-highlight com-finder__results-list" start="<?php echo (int) $this-> pagination | limitstart
$this | baseUrl = Uri::getInstance()->toString(array('scheme', 'host', 'port'))
foreach($this->results as $i=> $result) $this result | counter = $i + 1
$layout = $this->getLayoutFile($this->result->layout)
endforeach
$total = (int) $this->pagination->total
$limit = (int) $this->pagination->limit * $this->pagination->pagesCurrent

Documentation des variables

◆ $layout

$layout = $this->getLayoutFile($this->result->layout)

◆ $limit

$limit = (int) $this->pagination->limit * $this->pagination->pagesCurrent

Référencé par Pagination\__construct(), Pagination\_buildDataObject(), InstallerModel\_getList(), PluginsModel\_getList(), BaseDatabaseModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), GroupsModel\_getList(), TasksModel\_getList(), FieldsModel\_getList(), Tobscure\JsonApi\addPaginationLink(), Tobscure\JsonApi\addPaginationLinks(), Checkfiles\checkImages(), RC2\decryptBlock(), JsonapiView\displayList(), RC2\encryptBlock(), ApplicationDescription\extractNamespace(), Application\extractNamespace(), CacheModel\getData(), ArchiveModel\getData(), InstalledModel\getData(), Integer\getEncodedValue(), PositionsModel\getItems(), FeaturedModel\getItems(), CheckinModel\getItems(), CategoryModel\getItems(), Adapter\getItems(), LanguagesModel\getLanguages(), Parameters\getLimit(), Pagination\getLimitBox(), TagsModel\getListQuery(), ListModel\getPagination(), Pagination\getResultsCounter(), ListModel\getStart(), Assertion\greaterOrEqualThan(), Assert\greaterThan(), Assertion\greaterThan(), Assert\greaterThanEq(), Assertion\lessOrEqualThan(), Assert\lessThan(), Assertion\lessThan(), Assert\lessThanEq(), Adapter\onBuildIndex(), ArchiveModel\populateState(), FeaturedModel\populateState(), TagModel\populateState(), CategoryModel\populateState(), ListModel\populateState(), Table\renderRowSeparator(), DatabaseDriver\setQuery(), RC2\setupInlineCrypt(), CodePointString\split(), UnicodeString\split(), ByteString\split(), AbstractString\split(), utf8_locate_current_chr(), et utf8_locate_next_chr().

◆ $link

$link = '<a href="' . $linkUrl . '">' . $this->escape($this->suggested) . '</a>'

◆ $linkUrl

$linkUrl = Route::_($uri->toString(array('path', 'query')))

Référencé par PlgSystemSef\onAfterDispatch().

◆ $multilang

$multilang = Factory::getApplication()->getLanguageFilter() ? '_MULTILANG' : ''

◆ $total

$total = (int) $this->pagination->total

Référencé par Pagination\__construct(), InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), Tobscure\JsonApi\addPaginationLinks(), Router\build(), RouterLegacy\build(), FeedView\display(), LoginModel\getLoginModule(), ModuleHelper\getModule(), ModuleHelper\getModuleById(), ModuleHelper\getModules(), CronExpression\getMultipleRunDates(), Pagination\getResultsCounter(), ListModel\getStart(), AdaptersModel\getTotal(), MediaModel\getTotal(), CheckinModel\getTotal(), PositionsModel\getTotal(), InstalledModel\getTotal(), Adapter\onStartIndex(), Router\parse(), RouterLegacy\parse(), et UserGroupsHelper\total().

◆ baseUrl

$this baseUrl = Uri::getInstance()->toString(array('scheme', 'host', 'port'))

Référencé par JavascriptRenderer\__construct(), JavascriptRenderer\getAssets(), et JavascriptRenderer\setBaseUrl().

◆ counter

boolean $charcounter Does this field support a character counter = $i + 1

Référencé par ParagonIE_Sodium_Core_SecretStream_State\__construct(), ParagonIE_Sodium_Core32_SecretStream_State\__construct(), PublicKeyCredentialSource\__construct(), ParagonIE_Sodium_Core_SecretStream_State\counterReset(), ParagonIE_Sodium_Core32_SecretStream_State\counterReset(), Salsa20\createPoly1305Key(), Salsa20\crypt(), ParagonIE_Sodium_Core_SecretStream_State\getCounter(), ParagonIE_Sodium_Core32_SecretStream_State\getCounter(), CssMenu\getCounter(), ChaCha20\isValidEngineHelper(), Language\loadLanguage(), ParagonIE_Sodium_Core32_SecretStream_State\needsRekey(), ParagonIE_Sodium_Core_SecretStream_State\needsRekey(), Salsa20\setCounter(), et PublicKeyCredentialSource\setCounter().

◆ endforeach

endforeach

◆ endif

endif

◆ limitstart

<ol id="search-result-list" class="js-highlight com-finder__results-list" start="<?php echo (int) $this-> pagination limitstart

Référencé par Pagination\__construct(), Pagination\getListFooter(), Pagination\getPaginationLinks(), Pagination\getResultsCounter(), et Pagination\orderUpIcon().

◆ return

return


Joomla CMS: Référence du fichier default_seo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier administrator/components/com_config/tmpl/application/default_seo.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_SEO_SETTINGS')
$this | fieldsname = 'seo'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'seo'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_SEO_SETTINGS')


Joomla CMS: Référence du fichier default_seo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • config
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/config/default_seo.php

Espaces de nommage

Joomla\Site

Variables

foreach ( $this->form->getFieldset( 'seo') as $field)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

foreach($this->form->getFieldset('seo') as $field)


Joomla CMS: Référence du fichier default_separator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier default_separator.php

Espaces de nommage

Joomla\Site

Variables

$title = $item->anchor_title ? ' title="' . $item->anchor_title . '"' : ''
$anchor_css = $item->anchor_css ?: ''
$linktype = $item->title
if($item->menu_icon) elseif ( $item->menu_image)

Documentation des variables

◆ $anchor_css

$anchor_css = $item->anchor_css ?: ''

◆ $linktype

$linktype = $item->title

◆ $title

$title = $item->anchor_title ? ' title="' . $item->anchor_title . '"' : ''

◆ elseif

if ( $item->menu_icon) elseif($item->menu_image)


Joomla CMS: Référence du fichier default_server.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_server.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_SERVER_SETTINGS')
$this | fieldsname = 'server'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'server'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_SERVER_SETTINGS')


Joomla CMS: Référence du fichier default_session.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_session.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_SESSION_SETTINGS')
$this | fieldsname = 'session'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'session'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_SESSION_SETTINGS')


Joomla CMS: Référence du fichier default_site.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier administrator/components/com_config/tmpl/application/default_site.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_SITE_SETTINGS')
$this | fieldsname = 'site'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'site'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_SITE_SETTINGS')


Joomla CMS: Référence du fichier default_site.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • config
Espaces de nommage | Variables
Référence du fichier components/com_config/tmpl/config/default_site.php

Espaces de nommage

Joomla\Site

Variables

foreach ( $this->form->getFieldset( 'site') as $field)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ foreach

foreach($this->form->getFieldset('site') as $field)


Joomla CMS: Référence du fichier default_stage_body.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage
Référence du fichier default_stage_body.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_stage_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier default_stage_footer.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier default_submenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier default_submenu.php

Espaces de nommage

Joomla\Administrator

Variables

$class = 'item'
$currentParams = $current->getParams()
if(! $this->enabled) elseif($current->type=='separator') elseif($current->hasChildren()) if($current->level==1) elseif($current->level==2) elseif($current->level==3) if($current->type=='separator') | else
$linkClass = []
$dataToggle = ''
$iconClass = ''
$itemIconClass = ''
$itemImage = ''
$link = $current->link
$icon = $this->getIconClass($current)
$ajax = !empty($current->ajaxbadge) ? '<span class="menu-badge"><span class="icon-spin icon-spinner mt-1 system-counter" data-url="' . $current->ajaxbadge . '"></span></span>' : ''
$iconImage = $current->icon
$homeImage = ''
if($currentParams->get('menu-quicktask') &&(int) $this->params->get('shownew', 1)===1) if(!empty($current->dashboard)) | if ( $this->enabled &&$current->hasChildren())

Documentation des variables

◆ $ajax

$ajax = !empty($current->ajaxbadge) ? '<span class="menu-badge"><span class="icon-spin icon-spinner mt-1 system-counter" data-url="' . $current->ajaxbadge . '"></span></span>' : ''

◆ $class

$class = 'item'

◆ $currentParams

$currentParams = $current->getParams()

◆ $dataToggle

$dataToggle = ''

◆ $homeImage

$homeImage = ''

◆ $icon

string $icon = $this->getIconClass($current)

Layout variables

Référencé par PublicKeyCredentialRpEntity\__construct(), PublicKeyCredentialEntity\__construct(), PublicKeyCredentialUserEntity\__construct(), ActionsDropdown\addCustomItem(), ActionButton\addState(), ToolbarHelper\custom(), HtmlView\display(), Icon\edit(), AdministratorService\featured(), InlinehelpButton\fetchButton(), QuickIconHelper\getButtons(), PublicKeyCredentialEntity\getIcon(), ToolbarHelper\jooa11y(), PublicKeyCredentialEntity\jsonSerialize(), ToolbarHelper\modal(), ToolbarHelper\preview(), Redirect\published(), Grid\sort(), SearchTools\sort(), Messages\status(), et ToolbarHelper\title().

◆ $iconClass

$iconClass = ''

◆ $iconImage

$iconImage = $current->icon

Référencé par Menu\preprocess().

◆ $itemIconClass

$itemIconClass = ''

◆ $itemImage

if ( $iconClass==='' &&$itemIconClass) if ( $iconImage) $itemImage = ''

◆ $link

$link = $current->link

◆ $linkClass

$linkClass = []

◆ else

if ( $icon=='' &&$iconClass=='' &&$current->level==1 &&$current->target=='') if ( $link !='' &&$current->target !='') elseif ( $link !='' &&$current->type !=='separator') elseif ( $current->title !='' &&$current->type !=='separator') elseif ( $current->title !='' &&$current->type==='separator') else
Valeur initiale :
{
echo '<li class="' . $class . '">'
$class
$class
Definition: default_submenu.php:24

◆ if

if ( $currentParams->get( 'menu-quicktask') &&(int) $this->params->get( 'shownew', 1)===1) if (!empty( $current->dashboard)) if($this->enabled && $current->hasChildren())


Joomla CMS: Référence du fichier default_system.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Espaces de nommage
Référence du fichier default_system.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_texts.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
  • media
Espaces de nommage
Référence du fichier default_texts.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier default_tree.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_tree.php

Espaces de nommage

Joomla\Administrator

Variables

$fileArray = explode('/', $this->fileName)
$count = 0
$keyArrayCount = count($keyArray)
if(count($fileArray) >=$keyArrayCount) else
$explodeArray = explode('/', $key)
endif
if (is_object( $value))
endforeach

Documentation des variables

◆ $count

$count = 0

◆ $explodeArray

$explodeArray = explode('/', $key)

◆ $fileArray

$fileArray = explode('/', $this->fileName)

◆ $keyArrayCount

$keyArrayCount = count($keyArray)

◆ else

if (count( $fileArray) >=$keyArrayCount) else
Valeur initiale :
{
$class = 'folder'
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(is_object($value))


Joomla CMS: Référence du fichier default_tree_media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_tree_media.php

Espaces de nommage

Joomla\Administrator

Variables

$fileArray = explode('/', $this->fileName)
$count = 0
$keyArrayCount = count($keyArray)
if(count($fileArray) >=$keyArrayCount) else
$explodeArray = explode('/', $key)
endif
endforeach

Documentation des variables

◆ $count

$count = 0

◆ $explodeArray

$explodeArray = explode('/', $key)

◆ $fileArray

$fileArray = explode('/', $this->fileName)

◆ $keyArrayCount

$keyArrayCount = count($keyArray)

◆ else

if (count( $fileArray) >=$keyArrayCount) else
Valeur initiale :
{
$class = 'folder'
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_updated_files.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier default_updated_files.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input
else __pad6__
foreach ( $this->updatedList as $i=> $value)
$created_date = $value->created_date
else __pad7__
else $value modified_date
endif
endforeach

Documentation des variables

◆ $created_date

$created_date = $value->created_date

Référencé par LinkTable\store().

◆ $input

$input = Factory::getApplication()->input

◆ __pad6__

else __pad6__

◆ __pad7__

else __pad7__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->updatedList as $i=> $value)

◆ modified_date

else $value modified_date

Référencé par LinkTable\store().


Joomla CMS: Référence du fichier default_url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Espaces de nommage | Variables
Référence du fichier default_url.php

Espaces de nommage

Joomla\Site

Variables

$attributes = array()
if($item->anchor_title) if($item->anchor_css) if($item->anchor_rel) | $linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($item->browserNav==1) | elseif ( $item->browserNav==2)

Documentation des variables

◆ $attributes

$attributes = array()

◆ $linktype

if ( $item->anchor_title) if ( $item->anchor_css) if ( $item->anchor_rel) $linktype = $item->title

◆ elseif

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $item->browserNav==1) elseif($item->browserNav==2)


Joomla CMS: Référence du fichier default_user_custom_fields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier default_user_custom_fields.php

Espaces de nommage

Joomla\Site

Variables

$params = $this->item->params
$displayGroups = $params->get('show_user_custom_fields')
$userFieldGroups = array()
if(! $displayGroups||! $this->contactUser) endif
endforeach

Documentation des variables

◆ $displayGroups

$displayGroups = $params->get('show_user_custom_fields')

◆ $params

$params = $this->item->params

◆ $userFieldGroups

$userFieldGroups = array()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier default_webservices.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Espaces de nommage | Variables
Référence du fichier default_webservices.php

Espaces de nommage

Joomla\Administrator

Variables

$this | name = Text::_('COM_CONFIG_WEBSERVICES_SETTINGS')
$this | fieldsname = 'webservices'
$this | formclass = 'options-form'

Documentation des variables

◆ fieldsname

$this fieldsname = 'webservices'

◆ formclass

$this formclass = 'options-form'

◆ name

$this name = Text::_('COM_CONFIG_WEBSERVICES_SETTINGS')


Joomla CMS: Référence du fichier DefaultEngine.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
Structures de données | Espaces de nommage
Référence du fichier BCMath/DefaultEngine.php

Structures de données

class DefaultEngine

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath
PHP


Joomla CMS: Référence du fichier DefaultEngine.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • GMP
Structures de données | Espaces de nommage
Référence du fichier GMP/DefaultEngine.php

Structures de données

class DefaultEngine

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\GMP
GMP


Joomla CMS: Référence du fichier DefaultEngine.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
Structures de données | Espaces de nommage
Référence du fichier PHP/DefaultEngine.php

Structures de données

class DefaultEngine

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP
PHP


Joomla CMS: Référence du fichier DefaultTimeGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier DefaultTimeGenerator.php

Structures de données

class DefaultTimeGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier DefaultUuidBuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Builder
Structures de données | Espaces de nommage
Référence du fichier DefaultUuidBuilder.php

Structures de données

class DefaultUuidBuilder

Espaces de nommage

Ramsey\Uuid\Builder


Joomla CMS: Référence du fichier DefaultView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
Structures de données | Espaces de nommage
Référence du fichier DefaultView.php

Structures de données

class DefaultView

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\View


Joomla CMS: Référence du fichier defines.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • includes
Espaces de nommage | Variables
Référence du fichier administrator/includes/defines.php

Espaces de nommage

Joomla\Administrator

Variables

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)
const | JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)
const | JPATH_SITE JPATH_ROOT
const | JPATH_CONFIGURATION JPATH_ROOT
const | JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'
const | JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'
const | JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'
const | JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'
const | JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'
const | JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'
const | JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'
const | JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'
const | JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

Documentation des variables

◆ $parts

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)

◆ JPATH_ADMINISTRATOR

const JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'

Référencé par LastvisitdaterangeField\__construct(), DisplayController\__construct(), UseractiveField\__construct(), RegistrationdaterangeField\__construct(), LogsdaterangeField\__construct(), FormattedtextLogger\__construct(), Language\__construct(), Access\actions(), PlgSampledataMultilang\addAllCategoriesMenuItem(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addBlogMenuItem(), PlgSampledataMultilang\addCategory(), PlgExtensionFinder\addCommonWords(), HtmlView\addToolbar(), Users\admin_language(), Uri\base(), AdministratorRouter\build(), PlgSystemLogrotation\clearCacheGroups(), PlgSystemActionLogs\clearCacheGroups(), PlgSystemPrivacyconsent\clearCacheGroups(), SetConfigurationCommand\configureIO(), ExtensionRemoveCommand\configureIO(), FinderIndexCommand\configureIO(), ConfigurationModel\createConfiguration(), LanguageHelper\createLanguageList(), ModuleAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), Dispatcher\dispatch(), InstallationApplication\dispatch(), HtmlView\display(), RemoveOldFilesCommand\doExecute(), TasksListCommand\doExecute(), Users\editor(), AdminLanguage\existing(), AjaxController\fetchAssociations(), DatabaseModel\fetchSchemaCache(), UpdateModel\finaliseUpgrade(), ContentHelper\getActions(), CapabilitiesModel\getCapabilities(), ApplicationHelper\getClientInfo(), DebugHelper\getComponents(), ActionlogsHelper\getContentTypeLink(), UsersComponent\getContexts(), ContactComponent\getContexts(), ContentComponent\getContexts(), Dispatcher\getController(), StatisticsModel\getData(), DebugHelper\getDebugActions(), FileLayout\getDefaultIncludePaths(), SysinfoModel\getDirectory(), MessagesModel\getExtensionName(), RulesRule\getFieldActions(), FileModel\getForm(), ComponentModel\getForm(), TaskModel\getForm(), ContactModel\getForm(), StyleModel\getForm(), ModuleModel\getForm(), ContenthistoryHelper\getFormFile(), ComponentlayoutField\getInput(), RulesField\getInput(), InstallerHelper\getInstallationXML(), ItemModel\getItem(), ItemsModel\getItems(), RequestController\getJson(), LoginHelper\getLanguageList(), AbstractStatsField\getLayoutPaths(), WebcronLinkField\getLayoutPaths(), PlgSystemStats\getLayoutPaths(), InstallationApplication\getLocaliseAdmin(), PlgQuickiconDownloadkey\getMissingDownloadKeyInfo(), BaseController\getModel(), ModulesHelper\getModules(), JNamespacePsr4Map\getNamespaces(), ComponentsField\getOptions(), AliastagField\getOptions(), ComponentsCategoryField\getOptions(), ConfigComponentsField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), LanguageclientField\getOptions(), ContenttypeField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), TemplatesHelper\getPositions(), MenusHelper\getPresets(), HistoryModel\getSha1Hash(), AssociationsHelper\getSupportedExtension(), ChromestyleField\getTemplateModuleStyles(), ArticlesModel\getTransitions(), ModulesHelper\getTranslatedModulePosition(), MenutypesModel\getTypeOptions(), MenutypesModel\getTypeOptionsFromManifest(), ChangeSet\getUpdateFiles(), BaseController\getView(), ContentComponent\getWorkflowContexts(), ConfigHelper\hasComponentConfig(), DatabaseModel\initialise(), ActionlogsHelper\loadActionLogPluginsLanguage(), FormModel\loadForm(), AssociationsHelper\loadHelper(), LegacyComponent\loadHelper(), ApiDispatcher\loadLanguage(), Dispatcher\loadLanguage(), TemplateAdapter\loadLanguage(), PluginAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), ContenthistoryHelper\loadLanguageFiles(), ConfigHelper\loadLanguageForComponent(), SiteApplication\loadLibraryLanguage(), CMSApplication\loadLibraryLanguage(), LanguageHelper\loadPluginLanguage(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), Joomla\Component\Scheduler\Administrator\Traits\logTask(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), ContentHelper\onPrepareForm(), MessagesModel\onProcessList(), PostinstallHelper\parsePath(), PlgSystemLanguageFilter\parseRule(), ItemsModel\populateState(), JoomlaInstallerScript\postflight(), UpdateModel\preparePreUpdate(), Menu\preprocess(), CssMenu\preprocess(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), CategoryModel\preprocessForm(), ModuleModel\preprocessForm(), FieldModel\preprocessForm(), ItemModel\preprocessForm(), UpdatesitesModel\rebuild(), PlgExtensionFinder\removeCommonWords(), PlgSystemActionLogs\renderActionlogsExtensions(), StyleController\save(), ModuleController\save(), ApplicationModel\save(), MessageModel\save(), ActionlogModel\sendNotificationEmails(), InstalledController\setDefault(), ConfigurationModel\setup(), ComponentAdapter\setupInstallPaths(), ModuleAdapter\setupUninstall(), ComponentAdapter\setupUninstall(), InstalledController\switchAdminLanguage(), InstallerModel\translate(), PluginsModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), et SetupModel\validateDbConnection().

◆ JPATH_API

const JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'

Référencé par Uri\base(), LanguageAdapter\discover(), ComponentAdapter\discover(), ApplicationHelper\getClientInfo(), InstallerHelper\getInstallationXML(), JNamespacePsr4Map\getNamespaces(), ComponentAdapter\loadLanguage(), UpdatesitesModel\rebuild(), ComponentAdapter\setupInstallPaths(), et ComponentAdapter\setupUninstall().

◆ JPATH_CACHE

const JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'

Référencé par Cache\__construct(), PlgSystemUpdatenotification\clearCacheGroups(), PlgSystemStats\clearCacheGroups(), CacheModel\getCache(), SysinfoModel\getDirectory(), et ApplicationModel\save().

◆ JPATH_CLI

const JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

Référencé par ApplicationHelper\getClientInfo().

◆ JPATH_CONFIGURATION

const JPATH_CONFIGURATION JPATH_ROOT

Référencé par CacheStorage\__construct(), behindproxy_postinstall_action(), ConfigurationModel\createConfiguration(), ConfigurationModel\deleteConfiguration(), Factory\getConfig(), SysinfoModel\getDirectory(), ChecksModel\getPhpOptions(), ServiceProviderInterface\register(), Config\register(), et ApplicationModel\writeConfigFile().

◆ JPATH_INSTALLATION

const JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'

Référencé par DatabaseHelper\checkRemoteDbHost(), SetConfigurationCommand\configureIO(), LanguageAdapter\createContentLanguage(), CleanupModel\deleteInstallationFolder(), ApplicationHelper\getClientInfo(), et InstallationApplication\getLocalise().

◆ JPATH_LIBRARIES

const JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'

Référencé par SysinfoModel\getDirectory(), Session\getHandlers(), JNamespacePsr4Map\getNamespaces(), JNamespacePsr4Map\load(), et ActionlogsHelper\loadTranslationFiles().

◆ JPATH_MANIFESTS

const JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'

Référencé par InstallerAdapter\canUninstallPackageChild(), PackageAdapter\checkExtensionInFilesystem(), LibraryAdapter\discover(), FileAdapter\finaliseInstall(), FileAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), UpdateModel\finaliseUpgrade(), LibraryAdapter\prepareDiscoverInstall(), LibraryAdapter\refreshManifestCache(), FileAdapter\refreshManifestCache(), PackageAdapter\refreshManifestCache(), LibraryAdapter\removeExtensionFiles(), PackageAdapter\removeExtensionFiles(), FileAdapter\setupInstallPaths(), PackageAdapter\setupInstallPaths(), FileAdapter\setupUninstall(), LibraryAdapter\setupUninstall(), et PackageAdapter\setupUninstall().

◆ JPATH_PLUGINS

const JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'

Référencé par Captcha\_load(), Editor\_loadEditor(), ConfigurationModel\checkTestingSampledata(), Users\editor(), DatabaseModel\fetchSchemaCache(), StatisticsModel\getData(), SysinfoModel\getDirectory(), PluginModel\getForm(), FieldsPlugin\getFormPath(), PluginModel\getItem(), TinymcebuilderField\getLayoutData(), PluginHelper\getLayoutPath(), AbstractStatsField\getLayoutPaths(), JNamespacePsr4Map\getNamespaces(), FontsField\getOptions(), PluginsField\getOptions(), MetadataRepository\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), CMSPlugin\loadLanguage(), PluginAdapter\loadLanguage(), LanguageHelper\loadPluginLanguage(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), MediaActionPlugin\onContentPrepareForm(), FieldsPlugin\onCustomFieldsGetTypes(), PlgSystemLanguageFilter\parseRule(), PluginModel\preprocessForm(), StringsModel\refresh(), PluginAdapter\setupInstallPaths(), PluginAdapter\setupUninstall(), InstallerModel\translate(), PluginsModel\translate(), et UpdateModel\translateExtensionName().

◆ JPATH_ROOT

const JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par SubformField\__set(), Stream\_getFilename(), WebAssetRegistry\addRegistryFile(), File\append(), HTMLHelper\calendar(), Path\check(), Path\clean(), SysinfoModel\cleanSectionPrivateData(), UpdateModel\cleanUp(), LanguageErrorsCollector\collect(), LanguageFilesCollector\collect(), QueryCollector\collect(), PlgSystemDebug\collectLogs(), JoomlaInstallerScript\convertTablesToUtf8mb4(), HTMLHelper\convertToRelativePath(), Folder\copy(), File\copy(), Folder\create(), ConfigurationModel\createConfiguration(), TemplateModel\createOverride(), File\delete(), Folder\delete(), CleanupModel\deleteInstallationFolder(), JoomlaInstallerScript\deleteUnexistingFiles(), TextView\display(), UpdateModel\finaliseUpgrade(), JoomlaInstallerScript\fixFilenameCasing(), DataFormatter\formatPath(), PlgFileSystemLocal\getAdapters(), TemplateModel\getBasePath(), TemplateModel\getCoreFile(), LanguageStringsCollector\getData(), FileLayout\getDefaultIncludePaths(), SysinfoModel\getDirectory(), TemplateModel\getDirectoryTree(), TemplateModel\getFile(), TemplateModel\getForm(), ContenthistoryHelper\getFormFile(), TemplateModel\getImage(), Authentication\getKnownAuthenticators(), TinymcebuilderField\getLayoutData(), MediaField\getLayoutData(), CalendarField\getLayoutData(), TemplateModel\getMediaFiles(), TemplatesListField\getOptions(), FolderlistField\getOptions(), FilelistField\getOptions(), TemplateModel\getOverridesList(), ChecksModel\getPhpOptions(), TemplateModel\getSource(), Stream\getStream(), Factory\getStream(), TemplateModel\getTemplate(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), HTMLHelper\includeRelativeFiles(), WebAssetItem\isPathAbsolute(), Folder\listFolderTree(), File\move(), Folder\move(), InstallerScript\moveCliFiles(), JoomlaInstallerScript\moveRemainingTemplateFiles(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Installer\parseMedia(), PostinstallHelper\parsePath(), WebAssetRegistry\parseRegistryFile(), FileAdapter\populateFilesAndFolderList(), ServiceProviderInterface\register(), JLoader\registerNamespace(), JLoader\registerPrefix(), FileAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), Path\removeRoot(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), ApplicationModel\save(), TemplateModel\save(), AccessiblemediaField\setup(), FileAdapter\setupInstallPaths(), Menu\store(), Form\syncPaths(), FilePathRule\test(), FolderPathExistsRule\test(), Templates\thumb(), Templates\thumbModal(), JoomlaInstallerScript\updateManifestCaches(), File\upload(), File\write(), et Debug\xdebuglink().

◆ JPATH_SITE

const JPATH_SITE JPATH_ROOT

Référencé par Language\__construct(), ContactController\_sendEmail(), PlgExtensionFinder\addCommonWords(), ContactModel\buildContactExtendedData(), PlgSystemLogrotation\clearCacheGroups(), PlgSystemActionLogs\clearCacheGroups(), PlgSystemPrivacyconsent\clearCacheGroups(), FinderIndexCommand\configureIO(), TemplateModel\copy(), LanguageAdapter\createContentLanguage(), LegacyComponent\createRouter(), UpdateModel\createUpdateFile(), ModuleAdapter\discover(), PluginAdapter\discover(), TemplateAdapter\discover(), LanguageAdapter\discover(), ComponentAdapter\discover(), InstallationApplication\dispatch(), HtmlView\display(), DatabaseModel\fetchSchemaCache(), CategoriesModel\getAssoc(), CategoryModel\getAssoc(), LegacyComponent\getCategory(), ApplicationHelper\getClientInfo(), MessagesModel\getComponentOptions(), FileLayout\getDefaultIncludePaths(), SysinfoModel\getDirectory(), MessagesModel\getExtensionName(), RandomImageHelper\getFolder(), StyleModel\getForm(), ModuleModel\getForm(), FieldLayoutField\getInput(), InstallerHelper\getInstallationXML(), AbstractStatsField\getLayoutPaths(), JoomlatokenField\getLayoutPaths(), LanguagesHelper\getList(), InstallationApplication\getLocaliseAdmin(), ModulesHelper\getModules(), JNamespacePsr4Map\getNamespaces(), LanguageclientField\getOptions(), TemplatesHelper\getPositions(), ChromestyleField\getTemplateModuleStyles(), ModulesHelper\getTranslatedModulePosition(), Users\image(), ListHelper\images(), PlgFinderCategories\index(), LanguageAdapter\install(), Path\isOwner(), Users\language(), LanguageHelper\loadComponentLanguage(), FormModel\loadForm(), Dispatcher\loadLanguage(), FileAdapter\loadLanguage(), LibraryAdapter\loadLanguage(), TemplateAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), SiteApplication\loadLibraryLanguage(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSystemLanguagecode\onContentPrepareForm(), MessagesModel\onProcessList(), PlgSystemLanguageFilter\onUserLogin(), SiteRouter\parseInit(), ComponentModel\populateState(), UpdateModel\preparePreUpdate(), ModuleModel\preprocessForm(), UpdatesitesModel\rebuild(), TemplateAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), ComponentAdapter\setupInstallPaths(), PackageAdapter\setupUninstall(), ModuleAdapter\setupUninstall(), ComponentAdapter\setupUninstall(), InstallerModel\translate(), ModulesModel\translate(), et UpdateModel\translateExtensionName().

◆ JPATH_THEMES

const JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HtmlView\__construct(), OpensearchDocument\__construct(), HtmlView\_setPath(), FileLayout\getDefaultIncludePaths(), SysinfoModel\getDirectory(), PluginHelper\getLayoutPath(), ModuleHelper\getLayoutPath(), JoomlatokenField\getLayoutPaths(), Pagination\getListFooter(), Pagination\getPagesLinks(), MenusHelper\getPresets(), AdministratorApplication\getTemplate(), HTMLHelper\includeRelativeFiles(), HtmlView\loadTemplate(), MessageRenderer\render(), HtmlRenderer\render(), WebApplication\render(), InstallationApplication\render(), SiteApplication\render(), CMSApplication\render(), ModuleHelper\renderModule(), et SiteApplication\setTemplate().


Joomla CMS: Référence du fichier defines.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • includes
Espaces de nommage | Variables
Référence du fichier api/includes/defines.php

Espaces de nommage

Joomla\API

Variables

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)
const | JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)
const | JPATH_SITE JPATH_ROOT
const | JPATH_CONFIGURATION JPATH_ROOT
const | JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'
const | JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'
const | JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'
const | JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'
const | JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'
const | JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'
const | JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'
const | JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'
const | JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

Documentation des variables

◆ $parts

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)

◆ JPATH_ADMINISTRATOR

const JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'

◆ JPATH_API

const JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'

◆ JPATH_CACHE

const JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'

◆ JPATH_CLI

const JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

◆ JPATH_CONFIGURATION

const JPATH_CONFIGURATION JPATH_ROOT

◆ JPATH_INSTALLATION

const JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'

◆ JPATH_LIBRARIES

const JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'

◆ JPATH_MANIFESTS

const JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'

◆ JPATH_PLUGINS

const JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'

◆ JPATH_ROOT

const JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)

◆ JPATH_SITE

const JPATH_SITE JPATH_ROOT

◆ JPATH_THEMES

const JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'


Joomla CMS: Référence du fichier defines.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • includes
Espaces de nommage | Variables
Référence du fichier includes/defines.php

Espaces de nommage

Joomla\Site

Variables

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)
const | JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)
const | JPATH_SITE JPATH_ROOT
const | JPATH_CONFIGURATION JPATH_ROOT
const | JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'
const | JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'
const | JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'
const | JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'
const | JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'
const | JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'
const | JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'
const | JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'
const | JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

Documentation des variables

◆ $parts

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)

◆ JPATH_ADMINISTRATOR

const JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'

◆ JPATH_API

const JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'

◆ JPATH_CACHE

const JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'

◆ JPATH_CLI

const JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

◆ JPATH_CONFIGURATION

const JPATH_CONFIGURATION JPATH_ROOT

◆ JPATH_INSTALLATION

const JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'

◆ JPATH_LIBRARIES

const JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'

◆ JPATH_MANIFESTS

const JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'

◆ JPATH_PLUGINS

const JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'

◆ JPATH_ROOT

const JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)

◆ JPATH_SITE

const JPATH_SITE JPATH_ROOT

◆ JPATH_THEMES

const JPATH_THEMES JPATH_BASE . DIRECTORY_SEPARATOR . 'templates'


Joomla CMS: Référence du fichier defines.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • includes
Espaces de nommage | Variables
Référence du fichier installation/includes/defines.php

Espaces de nommage

Joomla\Installation

Variables

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)
const | JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)
const | JPATH_SITE JPATH_ROOT
const | JPATH_CONFIGURATION JPATH_ROOT
const | JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'
const | JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'
const | JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'
const | JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'
const | JPATH_THEMES JPATH_BASE
const | JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'
const | JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'
const | JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'
const | JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

Documentation des variables

◆ $parts

$parts = explode(DIRECTORY_SEPARATOR, JPATH_BASE)

◆ JPATH_ADMINISTRATOR

const JPATH_ADMINISTRATOR JPATH_ROOT . DIRECTORY_SEPARATOR . 'administrator'

◆ JPATH_API

const JPATH_API JPATH_ROOT . DIRECTORY_SEPARATOR . 'api'

◆ JPATH_CACHE

const JPATH_CACHE JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'cache'

◆ JPATH_CLI

const JPATH_CLI JPATH_ROOT . DIRECTORY_SEPARATOR . 'cli'

◆ JPATH_CONFIGURATION

const JPATH_CONFIGURATION JPATH_ROOT

◆ JPATH_INSTALLATION

const JPATH_INSTALLATION JPATH_ROOT . DIRECTORY_SEPARATOR . 'installation'

◆ JPATH_LIBRARIES

const JPATH_LIBRARIES JPATH_ROOT . DIRECTORY_SEPARATOR . 'libraries'

◆ JPATH_MANIFESTS

const JPATH_MANIFESTS JPATH_ADMINISTRATOR . DIRECTORY_SEPARATOR . 'manifests'

◆ JPATH_PLUGINS

const JPATH_PLUGINS JPATH_ROOT . DIRECTORY_SEPARATOR . 'plugins'

◆ JPATH_ROOT

const JPATH_ROOT implode(DIRECTORY_SEPARATOR, $parts)

◆ JPATH_SITE

const JPATH_SITE JPATH_ROOT

◆ JPATH_THEMES

const JPATH_THEMES JPATH_BASE


Joomla CMS: Référence du fichier DegradedNumberConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Number
Structures de données | Espaces de nommage
Référence du fichier DegradedNumberConverter.php

Structures de données

class DegradedNumberConverter

Espaces de nommage

Ramsey\Uuid\Converter\Number


Joomla CMS: Référence du fichier DegradedTimeConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Time
Structures de données | Espaces de nommage
Référence du fichier DegradedTimeConverter.php

Structures de données

class DegradedTimeConverter

Espaces de nommage

Ramsey\Uuid\Converter\Time


Joomla CMS: Référence du fichier DegradedUuid.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier DegradedUuid.php

Structures de données

class DegradedUuid

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier DegradedUuidBuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Builder
Structures de données | Espaces de nommage
Référence du fichier DegradedUuidBuilder.php

Structures de données

class DegradedUuidBuilder

Espaces de nommage

Ramsey\Uuid\Builder


Joomla CMS: Référence du fichier DelegatingPsrLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Structures de données | Espaces de nommage
Référence du fichier DelegatingPsrLogger.php

Structures de données

class DelegatingPsrLogger

Espaces de nommage

Joomla\CMS\Log


Joomla CMS: Référence du fichier delete.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • layouts
  • toolbar
Espaces de nommage | Variables
Référence du fichier delete.php

Espaces de nommage

Joomla\Administrator

Variables

$title = Text::_('JTOOLBAR_DELETE')

Documentation des variables

◆ $title

$title = Text::_('JTOOLBAR_DELETE')


Joomla CMS: Référence du fichier DeleteUserCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier DeleteUserCommand.php

Structures de données

class DeleteUserCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier DemoTasks.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier DemoTasks.php

Structures de données

class DemoTasks

Espaces de nommage

Joomla\Plugins
Joomla\Plugin\Task\DemoTasks\Extension


Joomla CMS: Référence du fichier DependencyResolutionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DependencyResolutionException.php

Structures de données

class DependencyResolutionException

Espaces de nommage

Joomla\DI\Exception


Joomla CMS: Référence du fichier DerivedKeys.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier DerivedKeys.php

Structures de données

class DerivedKeys

Espaces de nommage

Defuse\Crypto
Defuse


Joomla CMS: Référence du fichier DES.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier DES.php

Structures de données

class DES

Espaces de nommage

DES
phpseclib3\Crypt


Joomla CMS: Référence du fichier Descriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier Descriptor.php

Structures de données

class Descriptor

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier DescriptorHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Helper/DescriptorHelper.php

Structures de données

class DescriptorHelper

Espaces de nommage

Joomla\Console\Helper


Joomla CMS: Référence du fichier DescriptorHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Helper/DescriptorHelper.php

Structures de données

class DescriptorHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier DescriptorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier DescriptorInterface.php

Structures de données

interface DescriptorInterface

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier DeserializationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Exception/DeserializationException.php

Structures de données

class DeserializationException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier DeserializationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier typo3/phar-stream-wrapper/src/Phar/DeserializationException.php

Structures de données

class DeserializationException

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier DH.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier DH.php

Structures de données

class DH

Espaces de nommage

DH
phpseclib3\Crypt


Joomla CMS: Référence du fichier DHParameter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DHParameter.php

Structures de données

class DHParameter

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DigestInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DigestInfo.php

Structures de données

class DigestInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Directory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Directory.php

Structures de données

class Directory

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Service\HTML


Joomla CMS: Référence du fichier DirectoryString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DirectoryString.php

Structures de données

class DirectoryString

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier disabled.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • tmpl
Espaces de nommage
Référence du fichier administrator/modules/mod_logged/tmpl/disabled.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier disabled.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • tmpl
Espaces de nommage
Référence du fichier modules/mod_whosonline/tmpl/disabled.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier DiscoverController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier DiscoverController.php

Structures de données

class DiscoverController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier DiscoverModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier DiscoverModel.php

Structures de données

class DiscoverModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_associations/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cpanel/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cpanel\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_login/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Login\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier administrator/modules/mod_quickicon/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Administrator
Joomla\Module\Quickicon\Administrator\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_contenthistory/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Contenthistory\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_fields/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Fields\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_media
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_media/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Media\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_menus/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Menus\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier components/com_modules/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Component\Modules\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/event/src/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier modules/mod_articles_latest/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesLatest\Site\Dispatcher


Joomla CMS: Référence du fichier Dispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier modules/mod_articles_news/src/Dispatcher/Dispatcher.php

Structures de données

class Dispatcher

Espaces de nommage

Joomla\Site
Joomla\Module\ArticlesNews\Site\Dispatcher


Joomla CMS: Référence du fichier DispatcherAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier DispatcherAwareInterface.php

Structures de données

interface DispatcherAwareInterface

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier DispatcherAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier DispatcherAwareTrait.php

Espaces de nommage

Joomla\Event

Fonctions

getDispatcher ()
setDispatcher (DispatcherInterface $dispatcher)

Variables

trait DispatcherAwareTrait


Joomla CMS: Référence du fichier DispatcherInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier src/Dispatcher/DispatcherInterface.php

Structures de données

interface DispatcherInterface

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier DispatcherInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/event/src/DispatcherInterface.php

Structures de données

interface DispatcherInterface

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_actionlogs/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_associations/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cache/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cache\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_checkin/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Checkin\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cpanel/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cpanel\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_login/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Login\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_mails/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_postinstall/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Postinstall\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_redirect/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_scheduler/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_banners/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_contenthistory/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Contenthistory\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_fields/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Fields\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_finder/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_modules/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Modules\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_wrapper/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Site
Joomla\Component\Wrapper\Site\Controller


Joomla CMS: Référence du fichier DisplayController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier installation/src/Controller/DisplayController.php

Structures de données

class DisplayController

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Controller


Joomla CMS: Référence du fichier DisplayEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • View
Structures de données | Espaces de nommage
Référence du fichier DisplayEvent.php

Structures de données

class DisplayEvent

Espaces de nommage

Joomla\CMS\Event\View


Joomla CMS: Référence du fichier DisplayPNGCharacteristicsDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier DisplayPNGCharacteristicsDescriptor.php

Structures de données

class DisplayPNGCharacteristicsDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier DisplayText.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DisplayText.php

Structures de données

class DisplayText

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DisplayTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage | Fonctions | Variables
Référence du fichier DisplayTrait.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits

Fonctions

onDisplay ( $name, $content, $width, $height, $col, $row, $buttons=true, $id=null, $asset=null, $author=null, $params=[])

Variables

trait DisplayTrait


Joomla CMS: Référence du fichier DistantSingleMetadata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier DistantSingleMetadata.php

Structures de données

class DistantSingleMetadata

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier DistantSingleMetadataFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier DistantSingleMetadataFactory.php

Structures de données

class DistantSingleMetadataFactory

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier DistributionPoint.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DistributionPoint.php

Structures de données

class DistributionPoint

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DistributionPointName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DistributionPointName.php

Structures de données

class DistributionPointName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DivisionByZeroException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DivisionByZeroException.php

Structures de données

class DivisionByZeroException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier DNSName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • SAN
Structures de données | Espaces de nommage
Référence du fichier DNSName.php

Structures de données

class DNSName

Espaces de nommage

FG\X509\SAN


Joomla CMS: Référence du fichier DoctrineCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier DoctrineCaster.php

Structures de données

class DoctrineCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DoctrineCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier DoctrineCollector.php

Structures de données

class DoctrineCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier Document.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier src/Document/Document.php

Structures de données

class Document

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier Document.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier src/Service/Provider/Document.php

Structures de données

class Document

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Document.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/tobscure/json-api/src/Document.php

Structures de données

class Document

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier DocumentRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier DocumentRenderer.php

Structures de données

class DocumentRenderer

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier Domain.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Export
Structures de données | Espaces de nommage
Référence du fichier Domain.php

Structures de données

class Domain

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Export


Joomla CMS: Référence du fichier DOMCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier DOMCaster.php

Structures de données

class DOMCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DoublePrecisionFloatObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier DoublePrecisionFloatObject.php

Structures de données

class DoublePrecisionFloatObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier downloadkey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • downloadkey
Structures de données | Espaces de nommage
Référence du fichier downloadkey.php

Structures de données

class PlgQuickiconDownloadkey

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier DownloadModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier DownloadModel.php

Structures de données

class DownloadModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier DownloadSource.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
Structures de données | Espaces de nommage
Référence du fichier DownloadSource.php

Structures de données

class DownloadSource

Espaces de nommage

Joomla\CMS\Updater


Joomla CMS: Référence du fichier DraggableList.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier DraggableList.php

Structures de données

class DraggableList

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier DriverNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DriverNotFoundException.php

Structures de données

class DriverNotFoundException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier dropdown-metismenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage | Variables
Référence du fichier dropdown-metismenu.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()
$attributes = []
$attributes ['class'] = 'mod-menu mod-menu_dropdown-metismenu metismenu mod-list ' . $class_sfx
if($tagId=$params->get('tag_id', '')) $start = (int) $params->get('startLevel', 1)

Documentation des variables

◆ $attributes [1/2]

$attributes = []

◆ $attributes [2/2]

$attributes[ 'class'] = 'mod-menu mod-menu_dropdown-metismenu metismenu mod-list ' . $class_sfx

◆ $start

if ( $tagId=$params->get( 'tag_id', '')) $start = (int) $params->get('startLevel', 1)

Référencé par TimeDataCollector\addMeasure(), ProfileCollector\addMeasure(), SSH2\append_log(), PHPMailer\base64EncodeWrapMB(), ProfileCollector\collect(), SSH2\connect(), SymmetricKey\decrypt(), TraceableTwigTemplate\display(), SymmetricKey\encrypt(), ExceptionsCollector\formatThrowableData(), SFTP\get(), CacheModel\getData(), InstalledModel\getData(), X509\getDN(), RouterView\getPath(), ListModel\getStart(), Grapheme\grapheme_extract(), Grapheme\grapheme_substr(), Totp\hashToInt(), Behavior\highlighter(), Iconv\iconv_substr(), Select\integerlist(), Profiler\mark(), Mbstring\mb_substr(), PlgContentLoadmodule\onContentPrepare(), SymmetricKey\openssl_ctr_process(), Crypto\our_substr(), Core\ourSubstr(), Parser\parse(), SiteRouter\parsePaginationData(), SFTP\put(), Html\removeBlocks(), Reader\resolveFourByteLittleEndian(), Reader\resolveTwoByteBigEndian(), Binary\safeSubstr(), Crypt\safeSubstr(), SSH2\send_binary_packet(), SFTP\send_sftp_packet(), Session\setTimers(), CodePointString\slice(), UnicodeString\slice(), ByteString\slice(), CodePointString\splice(), UnicodeString\splice(), ByteString\splice(), Installer\splitSql(), DatabaseDriver\splitSql(), SqlsrvQuery\splitSqlExpression(), TimeDataCollector\startMeasure(), ProfileCollector\startMeasure(), StringHelper\strcspn(), StringHelper\strspn(), ParagonIE_Sodium_Core_Util\substr(), StringHelper\substr_replace(), utf8_strcspn(), utf8_strspn(), utf8_substr_replace(), et Stream\write().

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier dropdown-metismenu_component.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage | Variables
Référence du fichier dropdown-metismenu_component.php

Espaces de nommage

Joomla\Site

Variables

$attributes = []
if($item->anchor_title) if($item->anchor_css) if($item->anchor_rel) if($item->id==$active_id) | $linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($item->browserNav==1) | elseif ( $item->browserNav==2)

Documentation des variables

◆ $attributes

$attributes = []

◆ $linktype

if ( $item->anchor_title) if ( $item->anchor_css) if ( $item->anchor_rel) if ( $item->id==$active_id) $linktype = $item->title

◆ elseif

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $item->browserNav==1) elseif($item->browserNav==2)


Joomla CMS: Référence du fichier dropdown-metismenu_heading.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage | Variables
Référence du fichier dropdown-metismenu_heading.php

Espaces de nommage

Joomla\Site

Variables

$attributes = []
if($item->anchor_title) | $attributes ['class'] = 'mod-menu__heading nav-header'
$attributes ['class'] = $item->anchor_css ? ' ' . $item->anchor_css : null
$linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($showAll && $item->deeper) | else

Documentation des variables

◆ $attributes [1/3]

$attributes = []

◆ $attributes [2/3]

if ( $item->anchor_title) $attributes[ 'class'] = 'mod-menu__heading nav-header'

◆ $attributes [3/3]

$attributes[ 'class'] = $item->anchor_css ? ' ' . $item->anchor_css : null

◆ $linktype

$linktype = $item->title

◆ else

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $showAll &&$item->deeper) else
Valeur initiale :
{
echo '<span ' . ArrayHelper::toString($attributes) . '>' . $linktype . '</span>'
$attributes
$attributes
Definition: dropdown-metismenu_heading.php:16
$linktype
$linktype
Definition: dropdown-metismenu_heading.php:25


Joomla CMS: Référence du fichier dropdown-metismenu_separator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage | Variables
Référence du fichier dropdown-metismenu_separator.php

Espaces de nommage

Joomla\Site

Variables

$attributes = []
if($item->anchor_title) | $attributes ['class'] = 'mod-menu__separator separator'
$attributes ['class'] = $item->anchor_css ? ' ' . $item->anchor_css : null
$linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($showAll && $item->deeper) | else

Documentation des variables

◆ $attributes [1/3]

$attributes = []

◆ $attributes [2/3]

if ( $item->anchor_title) $attributes[ 'class'] = 'mod-menu__separator separator'

◆ $attributes [3/3]

$attributes[ 'class'] = $item->anchor_css ? ' ' . $item->anchor_css : null

◆ $linktype

$linktype = $item->title

◆ else

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $showAll &&$item->deeper) else
Valeur initiale :
{
echo '<span ' . ArrayHelper::toString($attributes) . '>' . $linktype . '</span>'
$linktype
$linktype
Definition: dropdown-metismenu_separator.php:25
$attributes
$attributes
Definition: dropdown-metismenu_separator.php:16


Joomla CMS: Référence du fichier dropdown-metismenu_url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Espaces de nommage | Variables
Référence du fichier dropdown-metismenu_url.php

Espaces de nommage

Joomla\Site

Variables

$attributes = []
if($item->anchor_title) if($item->anchor_css) if($item->anchor_rel) | $linktype = $item->title
if($item->menu_icon) elseif($item->menu_image) if($item->browserNav==1) | elseif ( $item->browserNav==2)

Documentation des variables

◆ $attributes

$attributes = []

◆ $linktype

if ( $item->anchor_title) if ( $item->anchor_css) if ( $item->anchor_rel) $linktype = $item->title

◆ elseif

if ( $item->menu_icon) elseif ( $item->menu_image) if ( $item->browserNav==1) elseif($item->browserNav==2)


Joomla CMS: Référence du fichier Dropdown.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Dropdown.php

Structures de données

class Dropdown

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier dropdown.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier dropdown.php

Espaces de nommage

Joomla\Site

Variables

$direction = Factory::getLanguage()->isRtl() ? 'dropdown-menu-end' : ''
< div id="<?php echo $id; ?> class
if (trim( $dropdownItems) !=='')
endif
else __pad12__

Documentation des variables

◆ $direction

$direction = Factory::getLanguage()->isRtl() ? 'dropdown-menu-end' : ''

◆ __pad12__

else __pad12__

◆ class

<div id="<?php echo $id; ?> class
Valeur initiale :
="btn-group dropdown-<?php echo $name ?? ''; ?>" role="group">
<button type="button" class="<?php echo $caretClass ?? ''; ?> dropdown-toggle-split"
data-bs-toggle="dropdown" data-bs-target=".dropdown-menu" data-bs-display="static" aria-haspopup="true" aria-expanded="false">
<span class="visually-hidden"><?php echo Text::_('JGLOBAL_TOGGLE_DROPDOWN')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php.

Référencé par Toolbar\__call(), ClassNotFoundError\__construct(), UndefinedFunctionError\__construct(), UndefinedMethodError\__construct(), TraceablePDO\__construct(), FatalError\__construct(), Dumper\__construct(), SitePathway\__construct(), ExecuteTaskEvent\__construct(), GetMethod\__construct(), AjaxInitCreate\__construct(), Captive\__construct(), GetSetup\__construct(), CompleteCommand\__construct(), Yaml\__construct(), Http\__construct(), LazyServiceEventListener\__construct(), CredentialRepository\__construct(), GMP\__construct(), SiteRouter\__construct(), BCMath\__construct(), SiteMenu\__construct(), Integer\__construct(), AndroidSafetyNetAttestationStatementSupport\__construct(), DatabaseIterator\__construct(), PHP\__construct(), Toolbar\__construct(), CliApplication\__construct(), Indexer\__construct(), Token\__construct(), Engine\__construct(), Task\__construct(), ErrorHandler\__construct(), Query\__construct(), Engine\__debugInfo(), AbstractWebApplication\__get(), DatabaseDriver\__get(), LazyServiceEventListener\__invoke(), Route\__serialize(), Stub\__sleep(), LazyString\__toString(), Categories\_load(), Toolbar\addButtonPath(), WebAssetManager\addInline(), Inflector\addPluraliseRule(), Joomla\CMS\Event\Result\addResult(), Inflector\addSingulariseRule(), Inflector\addWord(), Toolbar\appendButton(), Table\appendRow(), AbstractUnicodeString\ascii(), MethodsController\assertLoggedInUser(), MethodController\assertLoggedInUser(), Client\authenticate(), PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues(), Engine\bitwise_not(), Engine\bitwise_split(), FinderComponent\boot(), BannersComponent\boot(), ContactComponent\boot(), Mfa\canAddEditMethod(), Mfa\canDeleteMethod(), AbstractCloner\castObject(), DsCaster\castPairStub(), AuthenticatorAssertionResponseValidator\check(), AndroidKeyAttestationStatementSupport\checkAbsenceOfAllApplicationsTag(), DebugClassLoader\checkAnnotations(), FidoU2FAttestationStatementSupport\checkCertificate(), AndroidKeyAttestationStatementSupport\checkCertificateAndGetPublicKey(), DebugClassLoader\checkClasses(), FieldModel\checkDefaultValue(), CMSApplication\checkSession(), TPMAttestationStatementSupport\checkUniquePublicKey(), ErrorHandler\cleanTrace(), Connection\configureOptions(), AbstractEvent\create(), Factory\createDbo(), ModuleDispatcherFactory\createDispatcher(), ComponentDispatcherFactory\createDispatcher(), Factory\createDocument(), PublicKeyCredentialSource\createFromArray(), PublicKeyCredentialSource\createFromPublicKeyCredential(), FlattenException\createFromThrowable(), SymmetricKey\createInlineCryptFunction(), Factory\createLanguage(), MVCFactory\createModel(), Engine\createRecurringModuloFunction(), PublicKeyCredentialLoader\createResponse(), Connection\createSocket(), MVCFactory\createTable(), DatabaseQuery\dateFormat(), ExecRuleHelper\dateTimeToSql(), Sodium\decrypt(), MfaTable\delete(), MethodController\delete(), AbstractView\dispatchEvent(), BaseDatabaseModel\dispatchEvent(), MethodsController\display(), PHP\divideHelper(), ImportCommand\doExecute(), Montgomery\doubleAndAddPoint(), Data\dump(), DebugClassLoader\enable(), Sodium\encrypt(), AbstractString\endsWith(), AbstractString\equalsTo(), DatabaseQuery\escape(), LintCommand\execute(), InstallationApplication\executeController(), Container\exists(), FidoU2FAttestationStatementSupport\extractPublicKey(), CredentialRepository\formatDate(), MethodsModel\formatRelative(), Sodium\generateKey(), ApiApplication\getApiRouter(), Toolbar\getButtonPath(), Factory\getCache(), Joomla\CMS\Cache\getCacheControllerFactory(), Language\getCallerInfo(), OtherObjectManager\getClassForValue(), TagObjectManager\getClassForValue(), ComponentHelper\getComponentName(), SourceContextProvider\getContext(), LanguageStringsCollector\getData(), VarDumper\getDefaultContextProviders(), Command\getDefaultDescription(), Command\getDefaultName(), ConfigProvider\getDependencies(), Joomla\CMS\Event\getEventClassByEventName(), ContactModel\getForm(), ComposerStaticInit2399d40fc48ada3450e844df0430bf2f\getInitializer(), OrderingField\getInput(), CacheController\getInstance(), Cache\getInstance(), AbstractMenu\getInstance(), Toolbar\getInstance(), Installer\getInstance(), BaseController\getInstance(), User\getInstance(), Language\getInstance(), DatabaseDriver\getInstance(), Document\getInstance(), Form\getInstance(), FormModel\getItem(), LanguageModel\getItem(), MenuModel\getItem(), TemplateModel\getItem(), PluginModel\getItem(), StyleModel\getItem(), Adapter\getItem(), ModuleModel\getItem(), AdminModel\getItem(), Adapter\getItems(), Data\getIterator(), DatabaseFactory\getIterator(), TemplateModel\getMaster(), CMSApplication\getMenu(), MenusHelper\getMenuItems(), MethodsModel\getMethods(), CronExpression\getMultipleRunDates(), Integer\getNAF(), Command\getNativeDefinition(), MemcachedCaster\getOptionConstants(), ConnectionOptions\getOptionName(), FinderHelper\getQuery(), CaptiveModel\getRecords(), CronExpression\getRunDate(), HTMLHelper\getServiceRegistry(), Joomla\Application\getSession(), CliApplication\getSession(), QueryCollector\getStatements(), CheckLdapCredentialsListener\getSubscribedEvents(), Symfony\Contracts\Service\getSubscribedServices(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), AbstractString\indexOf(), AbstractString\indexOfLast(), AndroidSafetyNetAttestationStatementSupport\initJwsVerifier(), CronExpression\isDue(), DatabaseQuery\isNullDatetime(), PHPassHandler\isSupported(), SodiumCipher\isSupported(), Sodium\isSupported(), DatabaseHandler\isSupported(), FidoU2FAttestationStatementSupport\isValid(), AndroidKeyAttestationStatementSupport\isValid(), OpenSSL\isValidEngine(), Montgomery\isValidEngine(), Base\isValidEngine(), EmptyTrustPath\jsonSerialize(), EcdaaKeyIdTrustPath\jsonSerialize(), CertificateTrustPath\jsonSerialize(), DumpServer\listen(), AuthenticationExtensionsClientOutputsLoader\load(), AttestationObjectLoader\load(), Server\loadAndCheckAssertionResponse(), Server\loadAndCheckAttestationResponse(), AbstractRenderer\loadDocument(), InstallationApplication\loadDocument(), Form\loadField(), Joomla\CMS\MVC\Model\loadForm(), DatabaseDriver\loadObject(), DatabaseDriver\loadObjectList(), TrustPathLoader\loadTrustPath(), Symfony\Component\Console\Command\lock(), Http\makeTransportRequest(), X509\mapInExtensions(), X509\mapOutExtensions(), DatabaseQuery\nullDate(), Data\offsetSet(), DataSet\offsetSet(), Data\offsetUnset(), TrustPathLoader\oldTrustPathTypes(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSystemLanguageFilter\onAfterInitialise(), RSA\onLoad(), PlgUserJoomla\onUserAfterSave(), PlgSystemLanguageFilter\onUserLogin(), PlgWorkflowNotification\onWorkflowAfterTransition(), CMSPlugin\parameterImplementsEventInterface(), DebugClassLoader\patchReturnTypeWillChange(), PHP\powHelper(), GMP\powModInner(), BCMath\powModInner(), PHP\powModInner(), Toolbar\prependButton(), GroupModel\preprocessForm(), AddConsoleCommandPass\process(), TPMAttestationStatementSupport\processWithCertificate(), PackedAttestationStatementSupport\processWithSelfAttestation(), DatabaseQuery\quote(), DatabaseQuery\quoteName(), Engine\randomRangeHelper(), Engine\randomRangePrimeInner(), BackupcodesModel\regenerateBackupCodes(), WebAssetRegistry\register(), HTMLRegistry\register(), Toolbar\register(), Pathway\register(), Dispatcher\register(), CacheController\register(), Logger\register(), Language\register(), Document\register(), User\register(), Form\register(), Module\register(), ServiceProviderInterface\register(), Menu\register(), Database\register(), Router\register(), Application\register(), Authentication\register(), Console\register(), ModuleDispatcherFactory\register(), ComponentDispatcherFactory\register(), CategoryFactory\register(), HelperFactory\register(), RouterFactory\register(), MVCFactory\register(), WebAssetManager\registerAsset(), Session\registerSessionHandlerAsService(), PharStreamWrapper\registerStreamWrapper(), ModuleRenderer\render(), ByteString\replaceMatches(), ControllerResolver\resolve(), Session\restart(), Engine\rootHelper(), Engine\rootInner(), SiteApplication\route(), ProcessHelper\run(), Command\run(), SSH2\send_binary_packet(), Email\sendCode(), Archive\setAdapter(), LazyAssertion\setAssertClass(), AssertionChain\setAssertionClassName(), BCMath\setBitmask(), Table\setColumnMaxWidth(), Symfony\Contracts\Service\setContainer(), OptionsResolver\setDefault(), LazyAssertion\setExceptionClass(), Engine\setModExpEngine(), DatabaseDriver\setQuery(), Integer\setRecurringModuloFunction(), HtmlDumper\setTheme(), FormField\setup(), InstallerAdapter\setupScriptfile(), DaemonApplication\signal(), Engine\slidingWindow(), Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler(), LdapAuthenticator\start(), Session\start(), AbstractString\startsWith(), Event\stop(), LdapUserProvider\supportsClass(), Engine\testPrimality(), ServiceLocatorTest\testThrowsOnCircularReference(), ServiceLocatorTest\testThrowsOnUndefinedInternalService(), Inflector\toPlural(), Inflector\toSingular(), PublicKey\toString(), PrivateKey\toString(), Dispatcher\triggerEvent(), ZIPExtraction\unserialiseInstance(), FormField\validate(), Credentials\verifyAttestation(), et Connection\write().

◆ endif

endif

◆ if

if(trim($dropdownItems) !=='')


Joomla CMS: Référence du fichier DropdownButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier DropdownButton.php

Structures de données

class DropdownButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier DSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier DSA.php

Structures de données

class DSA

Espaces de nommage

DSA
phpseclib3\Crypt


Joomla CMS: Référence du fichier DSAParams.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DSAParams.php

Structures de données

class DSAParams

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DSAPrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DSAPrivateKey.php

Structures de données

class DSAPrivateKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DSAPublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DSAPublicKey.php

Structures de données

class DSAPublicKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DsCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier DsCaster.php

Structures de données

class DsCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DsPairStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier DsPairStub.php

Structures de données

class DsPairStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier DssSigValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier DssSigValue.php

Structures de données

class DssSigValue

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier DummyPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier DummyPlugin.php

Structures de données

class DummyPlugin

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier dump.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Resources
  • functions
Référence du fichier dump.php


Joomla CMS: Référence du fichier DumpableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • data
  • src
Structures de données | Espaces de nommage
Référence du fichier DumpableInterface.php

Structures de données

interface DumpableInterface

Espaces de nommage

Joomla\Data


Joomla CMS: Référence du fichier DumpCompletionCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier DumpCompletionCommand.php

Structures de données

class DumpCompletionCommand

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier DumpDescriptorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier DumpDescriptorInterface.php

Structures de données

interface DumpDescriptorInterface

Espaces de nommage

Symfony\Component\VarDumper\Command\Descriptor


Joomla CMS: Référence du fichier Dumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier console/Helper/Dumper.php

Structures de données

class Dumper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier Dumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier yaml/Dumper.php

Structures de données

class Dumper

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier DumperInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier DumperInterface.php

Structures de données

interface DumperInterface

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier DumpException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Exception
Structures de données | Espaces de nommage
Référence du fichier DumpException.php

Structures de données

class DumpException

Espaces de nommage

Symfony\Component\Yaml\Exception


Joomla CMS: Référence du fichier DumpServer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Server
Structures de données | Espaces de nommage
Référence du fichier DumpServer.php

Structures de données

class DumpServer

Espaces de nommage

Symfony\Component\VarDumper\Server


Joomla CMS: Référence du fichier Dutch.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Dutch.php

Structures de données

class Dutch

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier EC.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier EC.php

Structures de données

class EC

Espaces de nommage

EC
phpseclib3\Crypt


Joomla CMS: Référence du fichier Ec2Key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Structures de données | Espaces de nommage
Référence du fichier Ec2Key.php

Structures de données

class Ec2Key

Espaces de nommage

Cose\Key


Joomla CMS: Référence du fichier EcdaaKeyIdTrustPath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Structures de données | Espaces de nommage
Référence du fichier EcdaaKeyIdTrustPath.php

Structures de données

class EcdaaKeyIdTrustPath

Espaces de nommage

Webauthn\TrustPath


Joomla CMS: Référence du fichier EcdaaTrustAnchor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier EcdaaTrustAnchor.php

Structures de données

class EcdaaTrustAnchor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier ECDSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECDSA.php

Structures de données

class ECDSA

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ECDSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-ecdsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-ecdsa/ECDSA.php

Structures de données

class ECDSA

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Ecdsa.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier Ecdsa.php

Structures de données

class Ecdsa

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier EcdsaSigValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier EcdsaSigValue.php

Structures de données

class EcdsaSigValue

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier EchoLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier EchoLogger.php

Structures de données

class EchoLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier ECKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier ECKey.php

Structures de données

class ECKey

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier ECParameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ECParameters.php

Structures de données

class ECParameters

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ECPoint.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ECPoint.php

Structures de données

class ECPoint

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ECPrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ECPrivateKey.php

Structures de données

class ECPrivateKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ECSignature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECSignature.php

Structures de données

class ECSignature

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ECSignature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-core/Util/ECSignature.php

Structures de données

class ECSignature

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier Ed25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier paragonie/sodium_compat/namespaced/Core/Ed25519.php

Structures de données

class Ed25519

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier Ed25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/Ed25519.php

Structures de données

class ParagonIE_Sodium_Core_Ed25519


Joomla CMS: Référence du fichier Ed25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core32/Ed25519.php

Structures de données

class ParagonIE_Sodium_Core32_Ed25519


Joomla CMS: Référence du fichier Ed25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Ed25519.php

Structures de données

class Ed25519

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Ed25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • EdDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/EdDSA/Ed25519.php

Structures de données

class Ed25519

Espaces de nommage

Cose\Algorithm\Signature\EdDSA


Joomla CMS: Référence du fichier ED256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • EdDSA
Structures de données | Espaces de nommage
Référence du fichier ED256.php

Structures de données

class ED256

Espaces de nommage

Cose\Algorithm\Signature\EdDSA


Joomla CMS: Référence du fichier Ed448.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier Ed448.php

Structures de données

class Ed448

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier ED512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • EdDSA
Structures de données | Espaces de nommage
Référence du fichier ED512.php

Structures de données

class ED512

Espaces de nommage

Cose\Algorithm\Signature\EdDSA


Joomla CMS: Référence du fichier EdDSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • EdDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/EdDSA/EdDSA.php

Structures de données

class EdDSA

Espaces de nommage

Cose\Algorithm\Signature\EdDSA


Joomla CMS: Référence du fichier EdDSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-eddsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-eddsa/EdDSA.php

Structures de données

class EdDSA

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Edgedetect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Edgedetect.php

Structures de données

class Edgedetect

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier EDIPartyName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier EDIPartyName.php

Structures de données

class EDIPartyName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
  • association
Espaces de nommage | Variables
Référence du fichier administrator/components/com_associations/tmpl/association/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$options

Documentation des variables

◆ $options

array $options
Valeur initiale :
= [
'layout' => $this->app->input->get('layout', '', 'string')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par RawDocument\__construct(), ImageDocument\__construct(), Category\__construct(), ApcuHandler\__construct(), Cookie\__construct(), Http\__construct(), Response\__construct(), LangActiveAssetItem\__construct(), JsonDocument\__construct(), TransitionButton\__construct(), JsonapiDocument\__construct(), Session\__construct(), Json\__construct(), Files\__construct(), CacheController\__construct(), RedisStorage\__construct(), XmlDocument\__construct(), MemcachedStorage\__construct(), Cache\__construct(), FileStorage\__construct(), MemcachedHandler\__construct(), RedisHandler\__construct(), AdapterInstance\__construct(), Cli\__construct(), ErrorDocument\__construct(), Logger\__construct(), DatabaseStrategy\__construct(), NativeStorage\__construct(), JoomlaStorage\__construct(), Input\__construct(), OpensearchDocument\__construct(), SiteMenu\__construct(), Captcha\__construct(), FileLayout\__construct(), ActionButton\__construct(), OAuth\__construct(), CacheStorage\__construct(), WebAssetItem\__construct(), AbstractMenu\__construct(), ColorStyle\__construct(), ToolbarButton\__construct(), Form\__construct(), Categories\__construct(), HtmlDocument\__construct(), Task\__construct(), InstallerAdapter\__construct(), FtpClient\__construct(), FeedDocument\__construct(), Query\__construct(), Document\__construct(), DatabaseDriver\__construct(), PlgUserJoomla\_getUser(), Captcha\_load(), Stream\_mkdir(), JGrid\action(), JavascriptRenderer\addControl(), Sidebar\addFilter(), WebAssetManager\addInline(), Log\addLogger(), Log\addLoggerInternal(), MessagesModel\addPostInstallationMessage(), Document\addScript(), Document\addScriptOptions(), ActionButton\addState(), Document\addStyleSheet(), Joomla\Component\Scheduler\Administrator\Traits\advertiseRoutines(), FormBehavior\ajaxchosen(), Bootstrap\alert(), Access\assetgrouplist(), Authentication\authenticate(), Authentication\authorise(), IndexerController\batch(), Modules\batchOptions(), FieldTable\bind(), UserModel\block(), Session\buildSession(), Bootstrap\button(), TextDescriptor\calculateTotalWidthForOptions(), SetConfigurationCommand\checkDb(), DatabaseHelper\checkDbServerParameters(), DatabaseHelper\checkRemoteDbHost(), PlgSystemLogrotation\clearCacheGroups(), PlgSystemActionLogs\clearCacheGroups(), PlgSystemUpdatenotification\clearCacheGroups(), PlgSystemStats\clearCacheGroups(), PlgSystemPrivacyconsent\clearCacheGroups(), Banner\clientlist(), CommandCompletionTester\complete(), AbstractConnection\configureOptions(), Connection\configureOptions(), SMTP\connect(), WebAssetRegistry\createAsset(), CacheControllerFactory\createCacheController(), CategoryFactory\createCategory(), ConfigurationModel\createConfiguration(), DatabaseModel\createDatabase(), DatabaseDriver\createDatabase(), DatabaseModel\createDb(), Factory\createDbo(), FormFactory\createForm(), MenuFactory\createMenu(), ModulesModel\createOptionGroup(), ModulesHelper\createOptionGroup(), Adapter\createQuery(), ConfigurationModel\createRootUser(), OutputFormatter\createStyleFromString(), LayoutHelper\debug(), Fixed\decodeRecordOptions(), Totp\decodeRecordOptions(), Email\decodeRecordOptions(), Yubikey\decodeRecordOptions(), DescriptorHelper\describe(), MarkdownDescriptor\describe(), TextDescriptor\describe(), Descriptor\describe(), JsonDescriptor\describeApplication(), XmlDescriptor\describeApplication(), MarkdownDescriptor\describeApplication(), TextDescriptor\describeApplication(), JsonDescriptor\describeCommand(), MarkdownDescriptor\describeCommand(), TextDescriptor\describeCommand(), XmlDescriptor\describeCommand(), TextDescriptor\describeConsoleCommand(), JsonDescriptor\describeInputArgument(), TextDescriptor\describeInputArgument(), JsonDescriptor\describeInputDefinition(), TextDescriptor\describeInputDefinition(), JsonDescriptor\describeInputOption(), TextDescriptor\describeInputOption(), TextDescriptor\describeJoomlaApplication(), HtmlView\display(), AdministratorApplication\doExecute(), GetConfigurationCommand\doExecute(), SetConfigurationCommand\doExecute(), PluginsHelper\elementOptions(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), XML\encodeXMLParameters(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), Contrast\execute(), Brightness\execute(), Smooth\execute(), Backgroundfill\execute(), CommandTester\execute(), WorkflowStage\existing(), Image\filter(), Update\find(), Extension\find(), CollectionAdapter\findUpdate(), ExtensionAdapter\findUpdate(), PluginsHelper\folderOptions(), SearchTools\form(), OptionsResolver\formatOptions(), ColorStyle\fromString(), Crypt\generateKey(), OpenSSL\generateKey(), Select\genericlist(), ListHelper\genericordering(), UsersHelper\getActiveOptions(), ModulesModel\getActivePositions(), Adapter\getAdapter(), ModulesHelper\getAssignmentOptions(), AssociationsHelper\getAssociationHtmlList(), HttpFactory\getAvailableDriver(), CacheModel\getCache(), Factory\getCache(), Cache\getCacheController(), Router\getCategories(), Joomla\CMS\Categories\getCategory(), LegacyComponent\getCategory(), CategoryModel\getCategory(), TemplatesHelper\getClientOptions(), ModulesHelper\getClientOptions(), InstallerHelper\getClientOptions(), BannersHelper\getClientOptions(), MessagesModel\getComponentOptions(), DatabaseDriver\getCreateDatabaseQuery(), ClientHelper\getCredentials(), DatabaseHelper\getDbo(), DatabaseFactory\getDriver(), HtmlDumper\getDumpHeader(), DatabaseHelper\getEncryptionSettings(), InstallerHelper\getExtensionGroups(), InstallerHelper\getExtensionTypes(), FeedFactory\getFeed(), ApiModel\getFile(), ApiModel\getFiles(), ApiController\getFiles(), Factory\getFormat(), ContenthistoryHelper\getFormFile(), MenuField\getGroups(), ItemtypeField\getGroups(), UsersHelper\getGroups(), HttpFactory\getHttp(), UploaddirsField\getInput(), CacheController\getInstance(), Cache\getInstance(), Captcha\getInstance(), AbstractMenu\getInstance(), Categories\getInstance(), FtpClient\getInstance(), Form\getInstance(), MediumModel\getItem(), MediaModel\getItems(), CategoriesModel\getItems(), JavascriptRenderer\getJsControlsDefinitionCode(), ComboField\getLayoutData(), TextField\getLayoutData(), DebugHelper\getLevelsOptions(), ArticlesCategoriesHelper\getList(), CMSApplication\getMenu(), DatabaseHelper\getMinimumServerVersion(), LanguageField\getNativeLanguage(), PackageField\getOptions(), ModuletagField\getOptions(), FieldgroupsField\getOptions(), HeadertagField\getOptions(), IntegerField\getOptions(), LocationField\getOptions(), NewsfeedsField\getOptions(), ExtensionstatusField\getOptions(), AliastagField\getOptions(), PluginElementField\getOptions(), PluginTypeField\getOptions(), TemplatelocationField\getOptions(), FolderField\getOptions(), ComponentsField\getOptions(), TemplatenameField\getOptions(), SearchfilterField\getOptions(), SessionhandlerField\getOptions(), WorkflowComponentSectionsField\getOptions(), MenuParentField\getOptions(), ExtensionField\getOptions(), FontsField\getOptions(), ComponentsCategoryField\getOptions(), CachehandlerField\getOptions(), LogtypeField\getOptions(), MenuOrderingField\getOptions(), MenuPresetField\getOptions(), ItemlanguageField\getOptions(), ConfigComponentsField\getOptions(), AuthorField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), TaskTypeField\getOptions(), ComponentsWorkflowField\getOptions(), ContenttypesField\getOptions(), CategoryField\getOptions(), DatabaseconnectionField\getOptions(), LogcreatorField\getOptions(), LimitboxField\getOptions(), LanguageField\getOptions(), ContenttypeField\getOptions(), TypeField\getOptions(), TemplatesListField\getOptions(), GroupparentField\getOptions(), SubfieldsField\getOptions(), UsergrouplistField\getOptions(), ListField\getOptions(), BaseLayout\getOptions(), WorkflowconditionField\getOptions(), TransitionField\getOptions(), PredefinedlistField\getOptions(), PluginsField\getOptions(), ModulesModuleField\getOptions(), ModulesPositionField\getOptions(), RedirectField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), CronField\getOptions(), FolderlistField\getOptions(), FilelistField\getOptions(), WebAssetItem\getOptions(), TextField\getOptions(), SqlField\getOptions(), ToolbarButton\getOptions(), Pagination\getPaginationLinks(), SiteApplication\getPathway(), ChecksModel\getPhpOptions(), UpdateModel\getPhpOptions(), ChecksModel\getPhpOptionsSufficient(), ModulesHelper\getPositions(), FinderHelper\getQuery(), UsersHelper\getRangeOptions(), RedisCaster\getRedisOptions(), ResetModel\getResetCompleteForm(), ResetModel\getResetConfirmForm(), AdministratorApplication\getRouter(), SiteApplication\getRouter(), ConsoleApplication\getRouter(), CMSApplication\getRouter(), ContentHistory\getSha1(), SMTP\getSMTPConnection(), MessagesHelper\getStateOptions(), ModulesHelper\getStateOptions(), UsersHelper\getStateOptions(), InstallerHelper\getStateOptions(), GroupModel\getTable(), RequestModel\getTable(), RemoveModel\getTable(), RemindModel\getTable(), ConfirmModel\getTable(), FormModel\getTable(), TemplateModel\getTable(), ExportModel\getTable(), BaseDatabaseModel\getTable(), TaskModel\getTable(), FieldModel\getTable(), TaskModel\getTask(), TemplatesHelper\getTemplateOptions(), MenutypesModel\getTypeOptions(), MenutypesModel\getTypeOptionsByComponent(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromManifest(), MenutypesModel\getTypeOptionsFromMvc(), MenutypesModel\getTypeOptionsFromXml(), UpdateAdapter\getUpdateSiteResponse(), FiltersField\getUserGroups(), RulesField\getUserGroups(), Cache\getWorkarounds(), Select\groupedlist(), User\groups(), DatabaseModel\handleOldDatabase(), ClientHelper\hasCredentials(), BCryptHandler\hashPassword(), Argon2iHandler\hashPassword(), Argon2idHandler\hashPassword(), UserHelper\hashPassword(), ContenthistoryHelper\hideFields(), DatabaseModel\initialise(), AdministratorApplication\initialiseApp(), InstallationApplication\initialiseApp(), SiteApplication\initialiseApp(), CMSApplication\initialiseApp(), Symfony\Component\Console\Tester\initOutput(), Select\integerlist(), InputFilter\isSafeFile(), Access\level(), Raw\load(), Installer\loadAdapter(), Adapter\loadAllAdapters(), DaemonApplication\loadConfiguration(), Registry\loadFile(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), Registry\loadString(), UserController\login(), AdministratorApplication\login(), SiteApplication\login(), CMSApplication\login(), DisplayController\logout(), UserController\logout(), CMSApplication\logout(), Finder\mapslist(), PHPMailer\mb_pathinfo(), Menu\menuItemList(), DebugBarVarDumper\mergeClonerOptions(), DebugBarVarDumper\mergeDumperOptions(), PharStreamWrapper\mkdir(), Bootstrap\modal(), Json\objectToString(), Xml\objectToString(), Ini\objectToString(), Bootstrap\offcanvas(), PlgFieldsList\onCustomFieldsBeforePrepareField(), PlgFieldsCheckboxes\onCustomFieldsBeforePrepareField(), PlgFieldsRadio\onCustomFieldsBeforePrepareField(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), PlgQuickiconPrivacyCheck\onGetIcons(), PlgQuickiconExtensionupdate\onGetIcons(), PlgQuickiconOverrideCheck\onGetIcons(), PlgAuthenticationCookie\onUserAfterLogin(), PlgUserJoomla\onUserAfterLogin(), Joomla\onUserAfterLogin(), PlgUserJoomla\onUserLogin(), PlgUserJoomla\onUserLogout(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), Select\option(), Select\options(), SearchTools\optionsToRegistry(), WebAssetRegistry\parseRegistryFile(), DaemonApplication\pcntlWait(), Bootstrap\popover(), SearchModel\populateState(), Modules\positionList(), Modules\positions(), ApiController\postFiles(), SqlsrvStatement\prepare(), ConfirmButton\prepareOptions(), StandardButton\prepareOptions(), HelpButton\prepareOptions(), InlinehelpButton\prepareOptions(), LinkButton\prepareOptions(), PopupButton\prepareOptions(), ToolbarButton\prepareOptions(), TagField\prepareOptionsNested(), GetConfigurationCommand\processGroupOptions(), ContenthistoryHelper\processLookupFields(), PluginsHelper\publishedOptions(), RedirectHelper\publishedOptions(), Languages\publishedOptions(), Ldap\query(), Database\register(), WebAssetManager\registerAsset(), PublishedButton\render(), TransitionButton\render(), FeaturedButton\render(), LayoutHelper\render(), WebApplication\render(), ActionButton\render(), Toolbar\render(), InstallationApplication\render(), CustomButton\renderButton(), DropdownButton\renderButton(), PopupButton\renderButton(), ToolbarButton\renderButton(), SpacerField\renderField(), Form\renderField(), FormField\renderField(), Form\renderFieldset(), Bootstrap\renderModal(), CurlTransport\request(), StreamTransport\request(), DebugBarVarDumper\resetClonerOptions(), DebugBarVarDumper\resetDumperOptions(), OptionsResolver\resolve(), SetConfigurationCommand\retrieveOptionsFromInput(), ApplicationTester\run(), SetConfigurationCommand\sanitizeOptions(), ApplicationModel\save(), SetConfigurationCommand\saveConfiguration(), ToolbarHelper\saveGroup(), PKCS1\saveParameters(), PuTTY\savePrivateKey(), OpenSSH\savePrivateKey(), PKCS1\savePrivateKey(), PKCS8\savePrivateKey(), PSS\savePrivateKey(), PSS\savePSSParams(), OpenSSH\savePublicKey(), PKCS8\savePublicKey(), PSS\savePublicKey(), XML\savePublicKey(), HTMLHelper\script(), Bootstrap\scrollspy(), Filter\select(), IndexerController\sendResponse(), Adapter\setAdapter(), HtmlDocument\setBuffer(), ClientHelper\setCredentials(), HTMLHelper\setFormatOptions(), Curl\setoptArray(), BaseLayout\setOptions(), JavascriptRenderer\setOptions(), SetConfigurationCommand\setOptions(), FtpClient\setOptions(), JoomlaStorage\setOptions(), ActionButton\setOptions(), ToolbarButton\setOptions(), NativeStorage\setOptions(), Session\setOptions(), ConfigurationModel\setup(), Cache\setWorkarounds(), Filter\slider(), PHPMailer\smtpConnect(), IndexerController\start(), Bootstrap\startAccordion(), SetupModel\storeOptions(), PharStreamWrapper\stream_open(), Json\stringToObject(), Ini\stringToObject(), HTMLHelper\stylesheet(), FileLayout\sublayout(), Post\submit(), CurlPost\submit(), CompletionSuggestions\suggestOptions(), Bootstrap\tab(), Modules\templates(), Modules\templateStates(), OptionsRule\test(), Bootstrap\toast(), Image\toFile(), Bootstrap\tooltip(), Parameters\toString(), PublicKey\toString(), PrivateKey\toString(), Registry\toString(), Modules\types(), Finder\typeslist(), JoomlaInstallerScript\update(), Access\usergroup(), Yubikey\validateAgainstRecord(), DatabaseHelper\validateConnectionParameters(), SetupModel\validateDbConnection(), PKCS1\wrapPrivateKey(), OpenSSH\wrapPrivateKey(), PuTTY\wrapPrivateKey(), PKCS8\wrapPrivateKey(), Output\write(), JsonDescriptor\writeData(), Output\writeln(), et TextDescriptor\writeText().

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banner
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/banner/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • client
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/client/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • category
Espaces de nommage | Variables
Référence du fichier administrator/components/com_categories/tmpl/category/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$input = $app->input
$assoc = Associations::isEnabled()
$extensionassoc = array_key_exists('item_associations', $this->form->getFieldsets())
$this | ignore_fieldsets = ['jmetadata', 'item_associations']
$c = Factory::getApplication()->bootComponent($this->state->get('category.extension'))
if($c instanceof WorkflowServiceInterface) $this | useCoreUI = true
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assoc

$assoc = Associations::isEnabled()

Référencé par Joomla\CMS\MVC\Model\addTransitionField(), Workflow\executeTransition(), ContentType\fieldmapExpand(), UCMType\fieldmapExpand(), CategoryModel\getItem(), ContactModel\getItem(), NewsfeedModel\getItem(), ArticleModel\getItem(), LanguagesHelper\getList(), CategoriesModel\getListQuery(), Ini\objectToString(), PlgSystemLanguageFilter\onUserLogin(), et CategoryModel\save().

◆ $c

$c = Factory::getApplication()->bootComponent($this->state->get('category.extension'))

Référencé par BinaryField\__construct(), ParagonIE_Sodium_Core32_Curve25519_Fe\__debugInfo(), Stub\__sleep(), ParagonIE_Sodium_Compat\add(), ReflectionCaster\addAttributes(), Feed\addContributor(), FeedEntry\addContributor(), ReflectionCaster\addExtra(), ReflectionCaster\addMap(), Binary\addPoint(), Ed448\addPoint(), Ed25519\addPoint(), AbstractUnicodeString\ascii(), QuestionHelper\autocomplete(), Encoding\binToHex(), ParagonIE_Sodium_Crypto\box(), SplCaster\castArrayIterator(), SplCaster\castArrayObject(), ReflectionCaster\castAttribute(), RdKafkaCaster\castBrokerMetadata(), AmqpCaster\castChannel(), ReflectionCaster\castClass(), ReflectionCaster\castClassConstant(), ReflectionCaster\castClosure(), DsCaster\castCollection(), RdKafkaCaster\castCollectionMetadata(), RdKafkaCaster\castConf(), AmqpCaster\castConnection(), StubCaster\castCutArray(), SplCaster\castDoublyLinkedList(), StubCaster\castEnum(), AmqpCaster\castEnvelope(), IntlCaster\castError(), AmqpCaster\castExchange(), ReflectionCaster\castExtension(), SplCaster\castFileInfo(), SplCaster\castFileObject(), ReflectionCaster\castFunctionAbstract(), ReflectionCaster\castGenerator(), SplCaster\castHeap(), ImagineCaster\castImage(), IntlCaster\castIntlCalendar(), IntlCaster\castIntlDateFormatter(), IntlCaster\castIntlTimeZone(), RdKafkaCaster\castKafkaConsumer(), DsCaster\castMap(), MemcachedCaster\castMemcached(), RdKafkaCaster\castMessage(), IntlCaster\castMessageFormatter(), ReflectionCaster\castMethod(), MysqliCaster\castMysqliDriver(), IntlCaster\castNumberFormatter(), SplCaster\castObjectStorage(), SplCaster\castOuterIterator(), DsCaster\castPair(), DsCaster\castPairStub(), ReflectionCaster\castParameter(), RdKafkaCaster\castPartitionMetadata(), PdoCaster\castPdo(), PdoCaster\castPdoStatement(), ReflectionCaster\castProperty(), ProxyManagerCaster\castProxy(), AmqpCaster\castQueue(), UuidCaster\castRamseyUuid(), RdKafkaCaster\castRdKafka(), RedisCaster\castRedis(), RedisCaster\castRedisArray(), RedisCaster\castRedisCluster(), ReflectionCaster\castReference(), ReflectionCaster\castReflectionGenerator(), SplCaster\castSplArray(), StubCaster\castStub(), RdKafkaCaster\castTopic(), RdKafkaCaster\castTopicConf(), RdKafkaCaster\castTopicMetadata(), RdKafkaCaster\castTopicPartition(), ReflectionCaster\castType(), SplCaster\castWeakReference(), ReflectionCaster\castZendExtension(), ASN1\convert(), ParagonIE_Sodium_Core_Salsa20\core_salsa20(), DSA\createParameters(), Salsa20\createPoly1305Key(), Normalizer\decompose(), NativeCalculator\doSub(), Montgomery\doubleAndAddPoint(), Ed448\doublePoint(), Binary\doublePoint(), Ed25519\doublePoint(), SymmetricKey\encrypt(), ParagonIE_Sodium_Core_Curve25519\equal(), ParagonIE_Sodium_Core32_Curve25519\equal(), PSSRSA\exponentiate(), RSAKey\exponentiate(), Container\extend(), KoblitzPrime\extendedGCD(), BCMath\extendedGCD(), Engine\extendedGCDHelper(), RdKafkaCaster\extractMetadata(), ExceptionCaster\extractSource(), ParagonIE_Sodium_Core32_BLAKE2b\G(), ParagonIE_Sodium_Core_BLAKE2b\G(), DebugBar\getDataAsHeaders(), Query\getExcludedTermIds(), Query\getIncludedTermIds(), SearchModel\getListQuery(), PSSRSA\getMGF1(), RSA\getMGF1(), MemcachedCaster\getNonDefaultOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), ComponentsFieldgroupField\getOptions(), Query\getRequiredTermIds(), Query\getTokenData(), ParagonIE_Sodium_Core_HChaCha20\hChaCha20(), ParagonIE_Sodium_Core32_HChaCha20\hChaCha20(), Encoding\hexToBin(), ParagonIE_Sodium_Core_HSalsa20\hsalsa20(), Mbstring\html_encoding_callback(), Iconv\iconv_mime_decode(), Iconv\iconv_mime_encode(), ParagonIE_Sodium_Compat\increment(), FinderIndexCommand\index(), KoblitzPrime\jacobianDoublePoint(), SubformField\loadSubFormData(), Mbstring\mb_decode_numericentity(), Mbstring\mb_encode_numericentity(), Mbstring\mb_substitute_character(), RSA\mgf1(), ParagonIE_Sodium_Core32_Int32\mulInt32Fast(), ParagonIE_Sodium_Core32_Int64\mulInt64Fast(), ParagonIE_Sodium_Core32_Int32\mulIntFast(), ParagonIE_Sodium_Core32_Int64\mulIntFast(), ArgvInput\parseArgument(), DebugClassLoader\patchMethod(), SymmetricKey\pkcs12helper(), Menu\preprocess(), CssMenu\preprocess(), Query\processString(), ChaCha20\quarterRound(), Salsa20\quarterRound(), FeedEntry\removeContributor(), Feed\removeContributor(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_point_is_canonical(), ParagonIE_Sodium_Core_Salsa20\rotate(), ParagonIE_Sodium_Core_SipHash\rotl_64(), ParagonIE_Sodium_Core32_BLAKE2b\rotr64(), PrivateKey\rsadp(), PrivateKey\rsaes_oaep_decrypt(), PublicKey\rsaes_oaep_encrypt(), PrivateKey\rsaes_pkcs1_v1_5_decrypt(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), ParagonIE_Sodium_Core_Salsa20\salsa20(), ParagonIE_Sodium_Core32_Salsa20\salsa20(), ParagonIE_Sodium_Core_Salsa20\salsa20_xor_ic(), ParagonIE_Sodium_Core32_Salsa20\salsa20_xor_ic(), Command\setCode(), DES\setupInlineCrypt(), DES\setupKey(), BCMath\sqrt(), Integer\squareRoot(), Dutch\step4(), CliDumper\style(), HtmlDumper\style(), ParagonIE_Sodium_Compat\sub(), ParagonIE_Sodium_Compat\unpad(), TranscodeUnicode\utf7_ucs4array(), utf8_byte_position(), Php72\utf8_decode(), Unescaper\utf8chr(), et AbstractDumper\utf8Encode().

◆ $extensionassoc

$extensionassoc = array_key_exists('item_associations', $this->form->getFieldsets())

◆ $input

$input = $app->input
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par InstallationController\__construct(), ConfigController\__construct(), SaveSetup\__construct(), TemplatesController\__construct(), ContactsController\__construct(), CallbackController\__construct(), Rules\__construct(), ItemsController\__construct(), ManageController\__construct(), ComponentController\__construct(), AbstractModuleDispatcher\__construct(), ApplicationController\__construct(), ArticlesController\__construct(), ModulesController\__construct(), TemplateController\__construct(), ArticleController\__construct(), BaseApplication\__construct(), BannersController\__construct(), MethodsController\__construct(), Dispatcher\__construct(), UsersController\__construct(), CaptiveController\__construct(), UCMBase\__construct(), UpdatesitesController\__construct(), MethodController\__construct(), ActionlogsController\__construct(), CategoryController\__construct(), DisplayController\__construct(), WorkflowController\__construct(), WorkflowsController\__construct(), ComponentDispatcher\__construct(), InstallationApplication\__construct(), JoomlaStorage\__construct(), GroupController\__construct(), FieldController\__construct(), TransitionController\__construct(), StageController\__construct(), ApiApplication\__construct(), AdministratorApplication\__construct(), AdminController\__construct(), TransitionsController\__construct(), StagesController\__construct(), SiteApplication\__construct(), WebApplication\__construct(), FormController\__construct(), ApiController\__construct(), DaemonApplication\__construct(), ConsoleApplication\__construct(), CMSApplication\__construct(), Application\__construct(), BaseController\__construct(), FormField\__get(), PlgContentPagebreak\_createToc(), InstallModel\_getPackageFromFolder(), InstallModel\_getPackageFromUpload(), InstallModel\_getPackageFromUrl(), ConsoleSectionOutput\addContent(), HtmlView\addToolbar(), NamePrep\applyCanonicalOrdering(), PHP\array_repeat(), QuestionHelper\ask(), Session\buildSession(), NamePrep\combine(), DumpCompletionCommand\complete(), HelpCommand\complete(), ServerDumpCommand\complete(), LintCommand\complete(), Application\complete(), ExtensionDiscoverCommand\configureIO(), SiteDownCommand\configureIO(), SiteUpCommand\configureIO(), ExtensionInstallCommand\configureIO(), ExtensionDiscoverInstallCommand\configureIO(), ExtensionsListCommand\configureIO(), SetConfigurationCommand\configureIO(), TasksListCommand\configureIO(), ListUserCommand\configureIO(), ExtensionRemoveCommand\configureIO(), UpdateCoreCommand\configureIO(), TasksRunCommand\configureIO(), GetConfigurationCommand\configureIO(), ChangeUserPasswordCommand\configureIO(), TasksStateCommand\configureIO(), DeleteUserCommand\configureIO(), FinderIndexCommand\configureIO(), AddUserToGroupCommand\configureIO(), RemoveUserFromGroupCommand\configureIO(), AddUserCommand\configureIO(), Application\configureIO(), ToUnicode\convert(), CompleteCommand\createCompletionInput(), MVCFactory\createController(), ModuleDispatcherFactory\createDispatcher(), ComponentDispatcherFactory\createDispatcher(), Factory\createDocument(), HTMLHelper\date(), DiscoverModel\discover_install(), DisplayController\display(), HtmlView\display(), CheckUpdatesCommand\doExecute(), RemoveOldFilesCommand\doExecute(), SessionGcCommand\doExecute(), TasksRunCommand\doExecute(), TasksListCommand\doExecute(), ListUserCommand\doExecute(), CreateSessionTableCommand\doExecute(), SessionMetadataGcCommand\doExecute(), ChangeUserPasswordCommand\doExecute(), ExtensionDiscoverListCommand\doExecute(), DeleteUserCommand\doExecute(), SiteDownCommand\doExecute(), SiteUpCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), ImportCommand\doExecute(), CheckJoomlaUpdatesCommand\doExecute(), AddUserCommand\doExecute(), ExtensionDiscoverCommand\doExecute(), UpdateCoreCommand\doExecute(), ExtensionRemoveCommand\doExecute(), FinderIndexCommand\doExecute(), ExtensionInstallCommand\doExecute(), ExtensionDiscoverInstallCommand\doExecute(), ExtensionsListCommand\doExecute(), Application\doExecute(), GetConfigurationCommand\doExecute(), SetConfigurationCommand\doExecute(), Application\doRun(), Application\doRunCommand(), Dumper\dump(), Yaml\dump(), FormController\editAssociations(), PasswordHash\encode64(), HelpCommand\execute(), ServerDumpCommand\execute(), DumpCompletionCommand\execute(), LintCommand\execute(), AbstractCommand\execute(), Bzip2\extract(), Gzip\extract(), SubformField\filter(), Form\filter(), FormField\filter(), Bootup\filterString(), Normalise\fromCamelCase(), CompletionInput\fromTokens(), EvalBarrett\generateInlineMultiply(), PasswordHash\gensalt_blowfish(), PasswordHash\gensalt_private(), Application\getCommandName(), ApplicationHelper\getComponentName(), Module\getDispatcher(), RemindModel\getForm(), ConfirmModel\getForm(), OAuthCallbackEvent\getInput(), CliApplication\getInput(), ConsoleApplication\getInput(), ErrorListener\getInputString(), BaseController\getInstance(), OverrideModel\getItem(), ArticlesModel\getItems(), AbstractModuleDispatcher\getLayoutData(), ArticlesCategoryHelper\getList(), ModuleHelper\getModules(), ItemlanguageField\getOptions(), TemplateModel\getSource(), ListModel\getUserStateFromRequest(), NamePrep\hangulCompose(), HS256_64\hash(), Totp\hashToInt(), NewsfeedModel\hit(), ArticleModel\hit(), ContactModel\hit(), CategoryModel\hit(), DataSet\initialise(), OutputFilter\linkXHTMLSafe(), OutputFilter\linkXhtmlSafe(), LoginModel\loadFormData(), UserController\login(), UserController\logout(), Rules\mergeCollection(), PluginController\oauthcallback(), PlgCaptchaRecaptcha_Invisible\onCheckAnswer(), PlgCaptchaRecaptcha\onCheckAnswer(), PlgContentPagebreak\onContentPrepare(), PlgSystemFields\onContentPrepareForm(), Html\parse(), Helper\parse(), Yaml\parse(), Parser\parse(), ConsoleApplication\populateHttpHost(), LoginModel\populateState(), DownloadModel\populateState(), ComponentModel\populateState(), FeaturedModel\populateState(), MessageModel\populateState(), SuggestionsModel\populateState(), HistoryModel\populateState(), SearchModel\populateState(), Form\postProcess(), Txt\process(), Rtf\process(), Html\process(), Query\processString(), Html\removeBlocks(), AdministratorApplication\render(), QuestionHelper\resetIOCodepage(), SingleCommandApplication\run(), Application\run(), Command\run(), Application\runCommand(), Backgroundfill\sanitizeColor(), CMSApplication\sanityCheckSystemVariables(), GroupModel\save(), StageModel\save(), WorkflowModel\save(), FieldModel\save(), TransitionModel\save(), CategoryModel\save(), ModuleModel\save(), StringsModel\search(), ApplicationModel\sendTestMail(), ClientHelper\setCredentialsFromRequest(), OAuthCallbackEvent\setInput(), Table\setRules(), TransitionField\setup(), ECDSA\sign(), RSAPSS\sign(), RSAPKCS1\sign(), RSA\sign(), EdDSA\sign(), StringHelper\str_pad(), ContactEmailRule\test(), FolderPathExistsRule\test(), NotequalsRule\test(), LoginUniqueFieldRule\test(), EqualsRule\test(), LogoutUniqueFieldRule\test(), ExecutionRulesRule\test(), EmailRule\test(), JWK\thumbprint(), Normalise\toCamelCase(), Normalise\toDashSeparated(), El\tokenise(), Zh\tokenise(), Language\tokenise(), StringInput\tokenize(), Helper\tokenize(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), Normalise\toKey(), Normalise\toSpaceSeparated(), Normalise\toUnderscoreSeparated(), Normalise\toVariable(), TranscodeUnicode\ucs4_ucs4array(), TranscodeUnicode\ucs4array_ucs4(), TranscodeUnicode\ucs4array_utf7(), TranscodeUnicode\ucs4array_utf7imap(), TranscodeUnicode\ucs4array_utf8(), JWSSerializerManager\unserialize(), CompactSerializer\unserialize(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), Cli\unserialize(), Input\unserialize(), UpdateModel\upload(), TranscodeUnicode\utf7_ucs4array(), TranscodeUnicode\utf7imap_ucs4array(), utf8_str_pad(), TranscodeUnicode\utf8_ucs4array(), Form\validate(), FormField\validate(), HMAC\verify(), RSAPKCS1\verify(), RSAPSS\verify(), RSA\verify(), ECDSA\verify(), EdDSA\verify(), et JWSVerifier\verifySignature().

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

Référencé par RouterViewConfiguration\addLayout(), HtmlView\addToolbar(), ListView\addToolbar(), MenuRules\buildLookup(), Icons\button(), Dispatcher\checkAccess(), CMSApplication\checkUserRequireReset(), CategoryView\commonCategoryDisplay(), LayoutHelper\debug(), DisplayController\display(), HtmlView\display(), ToolbarButton\fetchIconClass(), ActionButton\fetchIconClass(), RouteHelper\getArticleRoute(), AssociationHelper\getAssociations(), CategoryAssociationHelper\getCategoryAssociations(), RouteHelper\getCategoryRoute(), Adapter\getItem(), Adapter\getItems(), ActionButton\getLayout(), ToolbarButton\getLayout(), HtmlView\getLayoutFile(), PluginHelper\getLayoutPath(), ModuleHelper\getLayoutPath(), TemplateModel\getOverridesList(), FormController\getRedirectToItemAppend(), ChromestyleField\getTemplateModuleStyles(), MenutypesModel\getTypeOptionsFromLayouts(), ToolbarButton\layout(), Links\link(), Links\linksgroups(), ManageModel\loadChangelog(), HtmlView\loadTemplate(), PlgSystemPrivacyconsent\onAfterRoute(), FieldsPlugin\onCustomFieldsGetTypes(), FieldsPlugin\onCustomFieldsPrepareDom(), AssociationsModel\populateState(), ModulesModel\populateState(), ContactsModel\populateState(), NewsfeedsModel\populateState(), ItemsModel\populateState(), UsersModel\populateState(), CategoriesModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), ArticlesModel\populateState(), NotesModel\populateState(), PlgContentFields\prepare(), HtmlView\prepareDocument(), HtmlView\prepareToolbar(), MenuRules\preprocess(), ItemModel\preprocessForm(), RouterViewConfiguration\removeLayout(), Sidebar\render(), LayoutHelper\render(), ToolbarButton\render(), Toolbar\render(), ToolbarButton\renderButton(), ActionButton\setLayout(), HtmlView\setLayout(), ToolbarHelper\title(), et DisplayController\validateEntry().

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

Référencé par SubformField\getInput(), ArticleController\getRedirectToItemAppend(), ContactController\getRedirectToItemAppend(), FormController\getRedirectToItemAppend(), FormController\getRedirectToListAppend(), SubformField\loadSubForm(), et HtmlView\prepareToolbar().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = ['jmetadata', 'item_associations']

◆ useCoreUI

if ( $c instanceof WorkflowServiceInterface) $this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage | Variables
Référence du fichier administrator/components/com_contact/tmpl/contact/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$input = $app->input
$assoc = Associations::isEnabled()
$this | ignore_fieldsets = ['details', 'item_associations', 'jmetadata']
$this | useCoreUI = true
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assoc

$assoc = Associations::isEnabled()

◆ $input

$input = $app->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = ['details', 'item_associations', 'jmetadata']

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • article
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/article/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | configFieldsets = array('editorConfig')
$this | hiddenFieldsets = array('basic-limited')
$fieldsetsInImages = ['image-intro', 'image-full']
$fieldsetsInLinks = ['linka', 'linkb', 'linkc']
$this | ignore_fieldsets = array_merge(array('jmetadata', 'item_associations'), $fieldsetsInImages, $fieldsetsInLinks)
$this | useCoreUI = true
$params = clone $this->state->get('params')
$input = Factory::getApplication()->input
$assoc = Associations::isEnabled()
$showArticleOptions = $params->get('show_article_options', 1)
if(! $assoc||! $showArticleOptions) if(! $showArticleOptions) | $isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
foreach ( $fieldsetsInImages as $fieldset)
endforeach
endif

Documentation des variables

◆ $assoc

$assoc = Associations::isEnabled()

◆ $fieldsetsInImages

$fieldsetsInImages = ['image-intro', 'image-full']

◆ $fieldsetsInLinks

$fieldsetsInLinks = ['linka', 'linkb', 'linkc']

◆ $input

$input = Factory::getApplication()->input

◆ $isModal

if (! $assoc||! $showArticleOptions) if (! $showArticleOptions) $isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $params

$params = clone $this->state->get('params')

◆ $showArticleOptions

$showArticleOptions = $params->get('show_article_options', 1)

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ configFieldsets

$this configFieldsets = array('editorConfig')

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($fieldsetsInLinks as $fieldset) ( $fieldsetsInImages as )

◆ hiddenFieldsets

$this hiddenFieldsets = array('basic-limited')

◆ ignore_fieldsets

$this ignore_fieldsets = array_merge(array('jmetadata', 'item_associations'), $fieldsetsInImages, $fieldsetsInLinks)

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • field
Espaces de nommage | Variables
Référence du fichier administrator/components/com_fields/tmpl/field/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$input = $app->input
$this useCoreUI = true
$wa = $this->document->getWebAssetManager()
endforeach
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $input

$input = $app->input

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • group
Espaces de nommage | Variables
Référence du fichier administrator/components/com_fields/tmpl/group/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$input = $app->input
$this useCoreUI = true
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $input

$input = $app->input

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • filter
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/filter/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$this | ignore_fieldsets = ['jbasic']
$this | useCoreUI = true
$wa = $this->document->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = ['jbasic']

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • updatesite
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/updatesite/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • language
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/language/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • override
Espaces de nommage | Variables
Référence du fichier administrator/components/com_languages/tmpl/override/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$expired = ($this->state->get('cache_expired') == 1 ) ? '1' : ''
$wa = $this->document->getWebAssetManager()
endif

Documentation des variables

◆ $expired

$expired = ($this->state->get('cache_expired') == 1 ) ? '1' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier administrator/components/com_mails/tmpl/template/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $this->document->getWebAssetManager()
$this useCoreUI = true
$input = $app->input
$sub_id = str_replace('.', '_', $sub_id)
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $input

$input = $app->input

◆ $sub_id

$sub_id = str_replace('.', '_', $sub_id)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • item
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/item/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$this | useCoreUI = true
$wa = $this->document->getWebAssetManager()
$assoc = Associations::isEnabled()
$input = Factory::getApplication()->input
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
$clientId = $this->state->get('item.client_id', 0)
$lang = Factory::getLanguage()->getTag()
if ( $clientId===1)
endif
if(! $isModal && $this->item->type=='container') $this | fields
$this | fieldsets = array()
$this | ignore_fieldsets = array('aliasoptions', 'request', 'item_associations')

Documentation des variables

◆ $assoc

$assoc = Associations::isEnabled()

◆ $clientId

$clientId = $this->state->get('item.client_id', 0)

Référencé par ModulepositionField\__get(), ChromestyleField\__get(), PackageAdapter\_getExtensionId(), ComponentAdapter\_updateMenus(), HtmlView\addToolbar(), ExtensionHelper\checkIfCoreExtension(), PlgSystemActionLogs\clearCacheGroups(), LanguageHelper\createLanguageList(), MetadataManager\createSessionRecord(), StyleTable\delete(), TracksModel\delete(), CliDescriptor\describe(), LanguageAdapter\discover(), AdministratorApplication\dispatch(), DisplayController\display(), ServerDumpCommand\execute(), TemplateAdapter\finaliseUninstall(), JoomlaInstallerScript\fixTemplateMode(), ModulesModel\getActivePositions(), ModulesHelper\getAssignmentOptions(), TracksModel\getBaseName(), CMSApplication\getClientId(), TracksModel\getClientName(), InstalledModel\getData(), ModulesModel\getEmptyStateQuery(), InstallerHelper\getExtensionDownloadKey(), ExtensionHelper\getExtensionRecord(), StyleModel\getForm(), ItemModel\getForm(), ModuleModel\getForm(), MenuField\getGroups(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), ModulesPositioneditField\getInput(), ModulepositionField\getInput(), InstallerHelper\getInstallationXML(), PositionsModel\getItems(), LanguagesModel\getLanguageList(), PlgSampledataMultilang\getLanguageList(), SelectModel\getListQuery(), TracksModel\getListQuery(), DiscoverModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), StylesModel\getListQuery(), TemplatesModel\getListQuery(), MenusModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), ManageModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), InstallationApplication\getLocaliseAdmin(), MenusHelper\getMenuLinks(), MenusHelper\getMenuTypes(), MenusModel\getModMenuId(), ModulesHelper\getModules(), ItemModel\getModules(), TemplatenameField\getOptions(), MenuParentField\getOptions(), ModulesPositionField\getOptions(), ModulesModuleField\getOptions(), ModulesHelper\getPositions(), TemplatesHelper\getPositions(), TemplatesHelper\getTemplateOptions(), ModulesHelper\getTemplates(), ModulesHelper\getTranslatedModulePosition(), LanguageAdapter\install(), CMSApplication\isHttpsForced(), Menu\linkOptions(), DumpServer\listen(), ModuleModel\loadFormData(), Menu\menuItems(), Menu\menus(), PlgUserJoomla\onUserLogout(), ModuleController\orderPosition(), SelectModel\populateState(), MenutypesModel\populateState(), PositionsModel\populateState(), StylesModel\populateState(), ModulesModel\populateState(), ItemsModel\populateState(), MenuModel\populateState(), InstalledModel\populateState(), TemplatesModel\populateState(), MenusModel\populateState(), ItemModel\populateState(), Modules\positionList(), Modules\positions(), StyleModel\preprocessForm(), ItemsModel\preprocessForm(), ModuleModel\preprocessForm(), ItemModel\preprocessForm(), InstalledController\setDefault(), StyleModel\setHome(), ModulepositionField\setup(), ChromestyleField\setup(), TemplateAdapter\setupUninstall(), StyleTable\store(), TemplateAdapter\storeExtension(), Modules\templates(), LanguageAdapter\update(), et MetadataManager\updateSessionRecord().

◆ $input

$input = Factory::getApplication()->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $lang

$lang = Factory::getLanguage()->getTag()

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ fields

if ( $this->item->type !='component') $this fields
Valeur initiale :
= array(
'id',
'client_id',
'menutype',
'parent_id',
'menuordering',
'published',
'publish_up',
'publish_down',
'home',
'access',
'language',
'note',
)

Référencé par Uuid\__construct(), Item\addField(), FormattedtextLogger\formatLine(), Uuid\getClockSeqHiAndReservedHex(), Uuid\getClockSeqLowHex(), FieldFactory\getField(), Uuid\getLeastSignificantBitsHex(), Uuid\getMostSignificantBitsHex(), Uuid\getNodeHex(), Uuid\getTimeHiAndVersionHex(), Uuid\getTimeLowHex(), Uuid\getTimeMidHex(), Uuid\getTimestampHex(), FormattedtextLogger\parseFields(), et Uuid\unserialize().

◆ fieldsets

$this fieldsets = array()

Référencé par HtmlView\display().

◆ if

if($this->item->type !='component')

◆ ignore_fieldsets

$this ignore_fieldsets = array('aliasoptions', 'request', 'item_associations')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menu
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/menu/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • message
Espaces de nommage | Variables
Référence du fichier administrator/components/com_messages/tmpl/message/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • module
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/module/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$hasContent = isset($this->item->xml->customContent)
$hasContentFieldName = 'content'
if($hasContent) $this | fieldsets = $this->form->getFieldsets('params')
$this | useCoreUI = true
$wa = $this->document->getWebAssetManager()
$input = Factory::getApplication()->input
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
if( $this->item->xml)( $this->item->xml->description)($this->item->xml) | else
$this | fieldset = 'description'
$short_description = Text::_($this->item->xml->description)
$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)
if (! $long_description)
endif
else __pad0__
$html = LayoutHelper::render('joomla.edit.fieldset', $this)
$this | fields
else __pad1__
else $this
$this | ignore_fieldsets = array('basic', 'description')

Documentation des variables

◆ $hasContent

$hasContent = isset($this->item->xml->customContent)

◆ $hasContentFieldName

$hasContentFieldName = 'content'

◆ $html

$html = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $input

$input = Factory::getApplication()->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $long_description

$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $short_description

$short_description = Text::_($this->item->xml->description)

◆ $this

else $this

Référencé par LazyAssertion\__call(), AssertionChain\__call(), WebAssetManager\__call(), Toolbar\__call(), Stream\__call(), QueryElement\__clone(), DatabaseQuery\__clone(), UndefinedFunctionError\__construct(), UndefinedMethodError\__construct(), ClassNotFoundError\__construct(), TraceablePDO\__construct(), CutStub\__construct(), ECDSA\__construct(), FatalError\__construct(), SwiftLogCollector\__construct(), GenericLinkProvider\__construct(), DataShapeObject\__construct(), Dumper\__construct(), SlimCollector\__construct(), ConsoleSectionOutput\__construct(), AbstractTransport\__construct(), DescriptorHelper\__construct(), Response\__construct(), Router\__construct(), Factory\__construct(), ConfigPostProcessor\__construct(), CallbackLogger\__construct(), ComponentDispatcher\__construct(), JoomlaStorage\__construct(), SiteRouter\__construct(), ChangeSet\__construct(), AdminController\__construct(), DatabaseIterator\__construct(), PropelCollector\__construct(), Adapter\__construct(), BaseDatabaseModel\__construct(), FormController\__construct(), ApiController\__construct(), Toolbar\__construct(), CMSPlugin\__construct(), PlgSystemLanguageFilter\__construct(), MysqliStatement\__construct(), LdapClient\__construct(), InstallerAdapter\__construct(), Table\__construct(), BaseController\__construct(), CryptoExceptionHandler\__construct(), FormattedtextLogger\__destruct(), DataShapeObject\__get(), TaskOption\__get(), WebClient\__get(), DatabaseQuery\__get(), LazyServiceEventListener\__invoke(), DataShapeObject\__isset(), FeedEntry\__set(), Feed\__set(), DataShapeObject\__set(), PdoDriver\__sleep(), PublicKeyCredential\__toString(), CMSObject\__toString(), Joomla\Database\Query\__toString(), ArrayInput\__toString(), JsonResponse\__toString(), DatabaseQuery\__toString(), User\__wakeup(), ExtensionAdapter\_endElement(), Update\_endElement(), HtmlDocument\_fetchTemplate(), InstallerModel\_getList(), Nested\_getNode(), Categories\_load(), HtmlDocument\_parseTemplate(), HtmlView\_prepareDocument(), Stream\_stream_truncate(), BigDecimal\abs(), BigInteger\abs(), EntryManager\add(), ListenersPriorityQueue\add(), WebAssetRegistry\add(), Patcher\add(), Mail\add(), Integer\add(), Application\add(), OptionsResolver\addAllowedTypes(), OptionsResolver\addAllowedValues(), Event\addArgument(), LazyCommand\addArgument(), AbstractCommand\addArgument(), Command\addArgument(), JavascriptRenderer\addAssets(), Mail\addAttachment(), Mail\addBcc(), Feed\addCategory(), FeedEntry\addCategory(), Mail\addCc(), Joomla\CMS\Tree\addChild(), DebugBar\addCollector(), Application\addCommand(), Feed\addContributor(), FeedEntry\addContributor(), JavascriptRenderer\addControl(), Inflector\addCountableRule(), HtmlDocument\addCustomTag(), BaseLayout\addDebugMessage(), Feed\addEntry(), Dispatcher\addEvent(), WebAssetRegistry\addExtensionRegistryFile(), HtmlDocument\addFavicon(), HtmlDocument\addHeadLink(), OpensearchDocument\addImage(), FileLayout\addIncludePath(), FileLayout\addIncludePaths(), WebAssetManager\addInline(), JavascriptRenderer\addInlineAssets(), FeedDocument\addItem(), RouterViewConfiguration\addLayout(), Tobscure\JsonApi\addLink(), FeedEntry\addLink(), JsonapiDocument\addLink(), Log\addLogEntry(), MonologCollector\addLogger(), Tobscure\JsonApi\addMeta(), JsonapiDocument\addMeta(), OptionsResolver\addNormalizer(), LazyCommand\addOption(), AbstractCommand\addOption(), ListField\addOption(), InputDefinition\addOption(), Command\addOption(), PHPMailer\addOrEnqueueAnAddress(), BaseController\addPath(), Inflector\addPluraliseRule(), Binary\addPoint(), MessagesModel\addPostInstallationMessage(), ColorProcessor\addPredefinedStyles(), WebAssetRegistry\addRegistryFile(), Joomla\CMS\Event\Result\addResult(), Router\addRoute(), Router\addRoutes(), Table\addRow(), Table\addRows(), Document\addScript(), Document\addScriptDeclaration(), Document\addScriptOptions(), JWS\addSignature(), JWSBuilder\addSignature(), Inflector\addSingulariseRule(), ActionButton\addState(), ColorProcessor\addStyle(), Document\addStyleDeclaration(), Document\addStyleSheet(), WebAssetRegistry\addTemplateRegistryFile(), HtmlView\addToolbar(), ListView\addToolbar(), OpensearchDocument\addUrl(), LazyCommand\addUsage(), Command\addUsage(), Subject\addUse(), Subject\addUsedIn(), Inflector\addWord(), AbstractString\after(), AbstractString\afterLast(), Container\alias(), DatabaseQuery\alias(), AssertionChain\all(), CategoryController\allowAdd(), FormController\allowAdd(), ApiController\allowAdd(), CategoryController\allowEdit(), FieldController\allowEdit(), WorkflowController\allowEdit(), GroupController\allowEdit(), TransitionController\allowEdit(), StageController\allowEdit(), ContactController\allowEdit(), OptionConfigurator\allowedTypes(), OptionConfigurator\allowedValues(), CodePointString\append(), UnicodeString\append(), ByteString\append(), AbstractWebApplication\appendBody(), Toolbar\appendButton(), Table\appendRow(), DataShapeObject\asArray(), AbstractUnicodeString\ascii(), SymfonyStyle\askQuestion(), PermittedFor\assert(), RelatedTo\assert(), IdentifiedBy\assert(), ValidAt\assert(), DatabaseImporter\asXml(), DatabaseExporter\asXml(), AdminModel\batchCopy(), CategoryModel\batchCopy(), Joomla\CMS\MVC\Model\batchWorkflowStage(), AbstractString\before(), AbstractString\beforeLast(), DataObject\bind(), Form\bind(), Table\bind(), DatabaseQuery\bind(), Engine\bitwise_leftRotate(), Engine\bitwise_split(), PrivateKey\blind(), StandardRules\build(), ContactModel\buildContactExtendedData(), ProgressBar\buildLine(), DatabaseQuery\call(), ByteString\camel(), LevelModel\canDelete(), KeyProtectedByPassword\changePassword(), MysqliImporter\check(), MysqlImporter\check(), PgsqlImporter\check(), Usergroup\check(), Asset\check(), MysqlExporter\check(), MysqliExporter\check(), User\check(), Nested\check(), Table\check(), Dispatcher\checkAccess(), Table\checkIn(), Adapter\checkItemAccess(), Table\checkOut(), CodePointString\chunk(), UnicodeString\chunk(), ByteString\chunk(), InputFilter\clean(), MemcachedStorage\clear(), Joomla\Database\Query\clear(), DataSet\clear(), DatabaseQuery\clear(), OptionsResolver\clear(), Mail\clearAttachments(), BaseLayout\clearDebugMessages(), AbstractWebApplication\clearHeaders(), FileLayout\clearIncludePaths(), Cursor\clearLine(), Cursor\clearLineAfter(), Dispatcher\clearListeners(), Cursor\clearOutput(), Cursor\clearScreen(), SMTP\client_send(), CodePointString\codePointsAt(), AbstractString\collapseWhitespace(), ExceptionsCollector\collect(), PharStreamWrapper\collectInvocation(), PlgSystemDebug\collectLogs(), PDOCollector\collectPDO(), DatabaseQuery\columns(), CategoryView\commonCategoryDisplay(), Integer\compare(), BigDecimal\compareTo(), BigInteger\compareTo(), X509\computeKeyIdentifier(), ListCommand\configure(), HelpCommand\configure(), DumpCompletionCommand\configure(), AbstractGroupButton\configure(), CompleteCommand\configure(), LintCommand\configure(), ServerDumpCommand\configure(), Builder\configureClaim(), PdoDriver\connect(), MysqliDriver\connect(), POP3\connect(), Microdata\content(), LibraryAdapter\copyBaseFiles(), TemplateAdapter\copyBaseFiles(), PluginAdapter\copyBaseFiles(), ModuleAdapter\copyBaseFiles(), PackageAdapter\copyBaseFiles(), ComponentAdapter\copyBaseFiles(), ParagonIE_Sodium_Core_SecretStream_State\counterReset(), ParagonIE_Sodium_Core32_SecretStream_State\counterReset(), JWSBuilder\create(), Container\createChild(), MVCFactory\createController(), ComponentDispatcherFactory\createDispatcher(), SymmetricKey\createInlineCryptFunction(), MVCFactory\createModel(), Salsa20\createPoly1305Key(), Engine\createRecurringModuloFunction(), ContainerAwareToolbarFactory\createToolbar(), Image\crop(), GuidStringCodec\decode(), TimestampFirstCombCodec\decode(), StringCodec\decode(), SymmetricKey\decrypt(), MfaTable\decryptOptions(), OptionConfigurator\default(), OptionsResolver\define(), MenuType\delete(), MfaTable\delete(), Usergroup\delete(), ApiModel\delete(), User\delete(), DatabaseQuery\delete(), OptionConfigurator\deprecated(), WebAssetManager\disableAsset(), JavascriptRenderer\disableControl(), WebAssetManager\disablePresetItems(), DatabaseDriver\disconnect(), Installer\discover_install(), SiteApplication\dispatch(), WebAssetRegistry\dispatchAssetChanged(), AbstractApplication\dispatchEvent(), Task\dispatchExitEvent(), TextView\display(), DisplayController\display(), HtmlView\display(), ProgressIndicator\display(), ManageController\displayList(), Integer\divide(), BigDecimal\dividedBy(), BigInteger\dividedBy(), PHP\divideHelper(), Application\doExecute(), Montgomery\doubleAndAddPoint(), Binary\doublePoint(), Ecdsa\doVerify(), DatabaseDriver\dropTable(), SeekingData\dump(), AbstractDumper\dump(), DataObject\dump(), Data\dump(), DataSet\dump(), DatabaseQuery\dump(), Data\dumpChildren(), Microdata\enable(), WebAssetManager\enableDependencies(), Joomla\CMS\MVC\Model\enableWorkflowBatch(), SymmetricKey\encrypt(), Changelog\endElement(), Joomla\Component\Scheduler\Administrator\Traits\endRoutine(), AbstractString\ensureStart(), HtmlDumper\enterHash(), Integer\equals(), BigDecimal\exactlyDividedBy(), DatabaseQuery\exec(), Query\execute(), TraceablePDOStatement\execute(), AbstractApplication\execute(), AbstractWebApplication\execute(), MysqliStatement\execute(), Application\execute(), InstallationApplication\executeController(), Workflow\executeTransition(), PrivateKey\exponentiate(), Engine\extendedGCDHelper(), DatabaseQuery\extendWhere(), Bzip2\extract(), Gzip\extract(), Microdata\fallback(), ArticleModel\featured(), MysqliStatement\fetch(), FeedParser\fetchNamespace(), Collection\fields(), Resource\fields(), CalendarField\filter(), SubformField\filter(), Image\filter(), Form\filter(), FormField\filter(), Uri\filterPath(), Uri\filterQueryOrFragment(), Uri\filterUserInfoPart(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), MemcachedStorage\find(), Update\find(), Form\findField(), Form\findFieldsByFieldset(), Form\findFieldsByGroup(), Form\findGroup(), RouteHelper\findItem(), CollectionAdapter\findUpdate(), ExtensionAdapter\findUpdate(), SqlsrvQuery\fixGroupColumns(), Image\flip(), ByteString\folded(), DatabaseQuery\format(), Joomla\Database\Query\forShare(), Joomla\Database\Query\forUpdate(), DatabaseImporter\from(), DatabaseExporter\from(), DatabaseQuery\from(), Base32\fromBin(), BigInteger\gcd(), RequestIdGenerator\generate(), CombGenerator\generate(), Symfony\Contracts\Service\get(), PageController\get(), SMTP\get_lines(), FlattenException\getAllPrevious(), AbstractCommand\getApplication(), AbstractEvent\getArgument(), FlattenException\getAsString(), Resource\getAttributes(), TemplateModel\getBasePath(), Uuid\getBytes(), Joomla\DI\getContainer(), ProfileModel\getData(), RegistrationModel\getData(), Joomla\Database\getDatabase(), TemplateModel\getDirectoryTree(), DatabaseFactory\getDriver(), DatabaseDriver\getExporter(), Form\getField(), Form\getFieldAttribute(), Form\getFieldsets(), ApiModel\getFile(), TemplateModel\getFile(), ApiModel\getFiles(), TaskModel\getForm(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), DatabaseStrategy\getHashedPassword(), ASNObject\getIdentifier(), DatabaseDriver\getImporter(), ImptotalField\getInput(), OrderingField\getInput(), EditorField\getInput(), Input\getInputForRequestMethod(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), TaskModel\getItem(), ItemModel\getItem(), DebugBar\getJavascriptRenderer(), LanguagesModel\getLanguages(), MediaField\getLayoutData(), PlgSystemStats\getLayoutData(), FormField\getLayoutData(), FiltersModel\getListQuery(), SuggestionsModel\getListQuery(), NotesModel\getListQuery(), FeaturedModel\getListQuery(), SelectModel\getListQuery(), TracksModel\getListQuery(), ClientsModel\getListQuery(), LevelsModel\getListQuery(), SearchesModel\getListQuery(), MessagesModel\getListQuery(), LanguagesModel\getListQuery(), StylesModel\getListQuery(), TemplatesModel\getListQuery(), StagesModel\getListQuery(), LinksModel\getListQuery(), GroupsModel\getListQuery(), MenusModel\getListQuery(), MapsModel\getListQuery(), DebuguserModel\getListQuery(), DebuggroupModel\getListQuery(), ItemsModel\getListQuery(), UsersModel\getListQuery(), BigInteger\getLowestSetBit(), Version\getMediaVersion(), CMSApplication\getMenu(), BaseModel\getName(), AbstractView\getName(), RouterView\getName(), BaseController\getName(), DatabaseDriver\getName(), Table\getNextOrder(), Date\getOffsetFromGmt(), LanguageField\getOptions(), RouterView\getPath(), CMSObject\getProperties(), OrderingField\getQuery(), DatabaseDriver\getQuery(), AbstractSerializer\getRelationship(), Container\getResource(), SSH2\getResourceId(), Resource\getResources(), Joomla\CMS\Tree\getRoot(), Nested\getRootId(), SysinfoModel\getSafeData(), SSH2\getServerPublicHostKey(), SMTP\getSMTPConnection(), TemplateModel\getSource(), PlgFinderTags\getStateQuery(), PlgFinderCategories\getStateQuery(), PlgSystemHttpHeaders\getStaticHeaderConfiguration(), TemplateModel\getTemplate(), Builder\getToken(), ContentType\getTypeId(), MenutypesModel\getTypeOptions(), Data\getValue(), SqlsrvQuery\group(), DatabaseQuery\group(), OpenHandler\handle(), ErrorHandler\handleException(), RssParser\handleImage(), Table\hasField(), Subject\hasInfiniteLoop(), DebugBar\hasStackedData(), DatabaseQuery\having(), Cursor\hide(), Table\hit(), AbstractString\ignoreCase(), JavascriptRenderer\ignoreCollector(), MinutesField\increment(), MonthField\increment(), DayOfMonthField\increment(), HoursField\increment(), DayOfWeekField\increment(), ParagonIE_Sodium_Core_SecretStream_State\incrementCounter(), ParagonIE_Sodium_Core32_SecretStream_State\incrementCounter(), PlgFinderTags\index(), PlgFinderContacts\index(), PlgFinderNewsfeeds\index(), PlgFinderContent\index(), PlgFinderCategories\index(), OptionConfigurator\info(), Module\init(), DataSet\initialise(), DebugBar\initStackSession(), DatabaseQuery\insert(), ApplicationDescription\inspectApplication(), InstallModel\install(), LanguageAdapter\install(), Installer\install(), Table\isCheckedOut(), Joomla\CMS\Workflow\isFunctionalityUsed(), Mail\isHtml(), DatabaseQuery\isNullDatetime(), SymmetricKey\isValidEngineHelper(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), Prime\jacobianAddPointMixedXY(), ByteString\join(), DatabaseQuery\join(), ToolbarButton\layout(), Joomla\Database\Query\limit(), Table\load(), Installer\loadAdapter(), UserGroupsHelper\loadAll(), Adapter\loadAllAdapters(), Server\loadAndCheckAssertionResponse(), Registry\loadArray(), Toolbar\loadButtonType(), DaemonApplication\loadConfiguration(), WebApplication\loadDocument(), InstallationApplication\loadDocument(), Form\loadField(), FieldModel\loadFormData(), Changelog\loadFromXml(), Update\loadFromXml(), Joomla\CMS\Application\loadIdentity(), PluginAdapter\loadLanguage(), WebApplication\loadLanguage(), ComponentAdapter\loadLanguage(), FileLayout\loadLanguageSuffixes(), PackageManifest\loadManifestFromData(), LibraryManifest\loadManifestFromData(), Registry\loadObject(), ErrorDocument\loadRenderer(), Document\loadRenderer(), WebApplication\loadSession(), Registry\loadString(), TraceableTwigEnvironment\loadTemplate(), HtmlView\loadTemplate(), FileLayout\loadVersionSuffixes(), WebAssetManager\lock(), SqliteDriver\lockTable(), PgsqlDriver\lockTable(), MysqlDriver\lockTable(), MysqliDriver\lockTable(), ByteString\lower(), DataShapeObject\merge(), Registry\merge(), DatabaseQuery\merge(), HtmlDocument\mergeHeadData(), BigDecimal\minus(), BigRational\minus(), BigInteger\minus(), Table\move(), Nested\moveByReference(), Cursor\moveDown(), Cursor\moveLeft(), Cursor\moveRight(), Cursor\moveToColumn(), Cursor\moveToPosition(), Cursor\moveUp(), BigDecimal\multipliedBy(), BigInteger\multipliedBy(), Integer\multiply(), ToolbarButton\name(), BCMath\negate(), GMP\negate(), PHP\negate(), DatabaseIterator\next(), OptionConfigurator\normalize(), UnicodeString\normalize(), Joomla\Database\Query\noWait(), AssertionChain\nullOr(), Joomla\Database\Query\offset(), OptionsResolver\offsetGet(), Feed\offsetSet(), DataSet\offsetUnset(), SSH2\on_channel_open(), PlgSystemLanguageFilter\onAfterInitialise(), PlgFieldsEditor\onCustomFieldsPrepareDom(), PlgEditorCodemirror\onDisplay(), Adapter\onFinderGarbageCollection(), PlgFileSystemLocal\onSetupProviders(), Joomla\onUserAfterLogin(), PlgUserToken\onUserAfterSave(), Joomla\onUserLoginFailure(), PlgUserJoomla\onUserLogout(), Joomla\onUserLogout(), PlgWorkflowFeaturing\onWorkflowBeforeTransition(), DatabaseQuery\order(), ParagonIE_Sodium_Core32_Int64\orInt64(), Stdout\out(), Xml\out(), CliApplication\out(), ByteString\padBoth(), ByteString\padEnd(), ByteString\padStart(), NomenuRules\parse(), Document\parse(), Parser\parseClaims(), Parser\parseHeader(), TemplateAdapter\parseQueries(), InstallerAdapter\parseQueries(), SiteRouter\parseSefRoute(), BigDecimal\plus(), BigRational\plus(), BigInteger\plus(), ConsoleSectionOutput\popStreamContentUntilCurrentSection(), DownloadModel\populateState(), ListModel\populateState(), Form\postProcess(), BigRational\power(), BigDecimal\power(), BigInteger\power(), PHP\powHelper(), GMP\powModInner(), BCMath\powModInner(), PHP\powModInner(), HtmlView\prepareDocument(), CategoryView\prepareDocument(), JsonapiView\prepareItem(), PdoDriver\prepareStatement(), CodePointString\prepend(), UnicodeString\prepend(), ByteString\prepend(), AbstractWebApplication\prependBody(), Toolbar\prependButton(), MenuRules\preprocess(), CssMenu\preprocess(), Router\processBuildRules(), FeedParser\processElement(), AtomParser\processFeedEntry(), RssParser\processFeedEntry(), Router\processParseRules(), Microdata\property(), Nested\publish(), Table\publish(), DatabaseQuery\querySet(), BigInteger\quotient(), Base\rangeCheck(), ZIPExtraction\readFileHeader(), SFTP\readlist(), Usergroup\rebuild(), Asset\rebuild(), Nested\rebuild(), Ed448\recoverX(), Ed25519\recoverX(), SignalRegistry\register(), DescriptorHelper\register(), ClassLoader\register(), WebAssetManager\registerAsset(), BaseController\registerDefaultTask(), Joomla\CMS\Application\registerEvent(), CMSPlugin\registerListener(), FeedParser\registerNamespace(), FeedFactory\registerParser(), Container\registerServiceProvider(), BaseController\registerTask(), ParagonIE_Sodium_Core_SecretStream_State\rekey(), ParagonIE_Sodium_Core32_SecretStream_State\rekey(), ListenersPriorityQueue\remove(), WebAssetRegistry\remove(), OptionsResolver\remove(), Mail\removeAttachment(), FeedEntry\removeCategory(), Feed\removeCategory(), FeedEntry\removeContributor(), Feed\removeContributor(), Feed\removeEntry(), Dispatcher\removeEvent(), Form\removeField(), Form\removeGroup(), FileLayout\removeIncludePath(), FileLayout\removeIncludePaths(), RouterViewConfiguration\removeLayout(), FeedEntry\removeLink(), ActionButton\removeState(), SqliteDriver\renameTable(), PgsqlDriver\renameTable(), MysqlDriver\renameTable(), MysqliDriver\renameTable(), ApiApplication\render(), SiteApplication\render(), Toolbar\renderButton(), JavascriptRenderer\renderOnShutdown(), Table\reorder(), AbstractString\repeat(), CodePointString\replace(), UnicodeString\replace(), ByteString\replace(), ByteString\replaceMatches(), ConfigPostProcessor\replacementRuleMatch(), CurlTransport\request(), OptionConfigurator\required(), ErrorHandler\reRegister(), Patcher\reset(), WebAssetManager\reset(), Table\reset(), HtmlDocument\resetHeadData(), Image\resize(), OptionsResolver\resolve(), Session\restart(), Cursor\restorePosition(), Joomla\Database\Query\returning(), ByteString\reverse(), Feed\reverseItems(), Engine\rootInner(), Image\rotate(), SingleCommandApplication\run(), Application\runCommand(), Client\safeEncode(), Sanitizer\sanitize(), MemcachedStorage\save(), CategoryModel\save(), User\save(), ModuleModel\save(), TemplateModel\save(), AdminModel\save(), ItemModel\save(), Cursor\savePosition(), SeekingData\seek(), Data\seek(), DatabaseQuery\select(), JWKSet\selectKey(), SqliteQuery\selectRowNumber(), DebugBar\sendDataInHeaders(), AbstractWebApplication\sendHeaders(), HelperSet\set(), BaseLayout\set(), Container\set(), DatabaseQuery\set(), PHPMailer\set(), Adapter\setAdapter(), Archive\setAdapter(), JavascriptRenderer\setAjaxHandlerAutoShow(), JavascriptRenderer\setAjaxHandlerClass(), Command\setAliases(), OptionsResolver\setAllowedTypes(), OptionsResolver\setAllowedValues(), Event\setArgument(), AbstractEvent\setArgument(), LazyAssertion\setAssertClass(), AssertionChain\setAssertionClassName(), FlattenException\setAsString(), WebAssetItem\setAttribute(), FeedEntry\setAuthor(), Feed\setAuthor(), Question\setAutocompleterCallback(), SingleCommandApplication\setAutoExit(), Document\setBase(), JavascriptRenderer\setBasePath(), JavascriptRenderer\setBaseUrl(), JavascriptRenderer\setBindAjaxHandlerToFetch(), JavascriptRenderer\setBindAjaxHandlerToJquery(), JavascriptRenderer\setBindAjaxHandlerToXHR(), Mail\setBody(), AbstractWebApplication\setBody(), TableStyle\setBorderFormat(), Document\setBuffer(), HtmlDocument\setBuffer(), TableStyle\setCellHeaderFormat(), TableStyle\setCellRowContentFormat(), TableStyle\setCellRowFormat(), ReCaptcha\setChallengeTimeout(), Document\setCharset(), FlattenException\setClass(), LazyCommand\setCode(), FlattenException\setCode(), Command\setCode(), Table\setColumnMaxWidth(), Table\setColumnStyle(), Table\setColumnWidth(), Table\setColumnWidths(), AbstractApplication\setConfiguration(), Joomla\DI\setContainer(), Route\setController(), TableStyle\setCrossingChars(), PlgSystemHttpHeaders\setCspHeader(), JavascriptRenderer\setCspNonce(), Relationship\setData(), JsonapiDocument\setData(), Document\setData(), BaseLayout\setData(), MessagesCollector\setDataFormatter(), DataCollector\setDataFormatter(), DatabaseExporter\setDbo(), DatabaseImporter\setDbo(), BaseLayout\setDebug(), OptionsResolver\setDefault(), WorkflowModel\setDefault(), StageModel\setDefault(), Application\setDefaultCommand(), OptionsResolver\setDefaults(), Route\setDefaults(), OptionsResolver\setDefined(), LazyCommand\setDefinition(), Command\setDefinition(), OptionsResolver\setDeprecated(), Command\setDescription(), Document\setDescription(), Document\setDirection(), Joomla\Event\setDispatcher(), XmlDocument\setDownload(), OutputFormatterStyleStack\setEmptyStyle(), JavascriptRenderer\setEnableJqueryNoConflict(), FeedItem\setEnclosure(), ChoiceQuestion\setErrorMessage(), JsonapiDocument\setErrors(), Document\setErrors(), Dispatcher\setEvent(), LazyAssertion\setExceptionClass(), ReCaptcha\setExpectedAction(), ReCaptcha\setExpectedApkPackageName(), ReCaptcha\setExpectedHostname(), Session\setExpire(), CronExpression\setExpression(), Toolbar\setFactory(), Document\setFactory(), Form\setField(), Form\setFieldAttribute(), Form\setFields(), FlattenException\setFile(), Table\setFooterTitle(), TableStyle\setFooterTitleFormat(), FormField\setForm(), Joomla\CMS\Form\setFormFactory(), Uri\setFragment(), Document\setGenerator(), UserGroupsHelper\setGroups(), NativeStorage\setHandler(), HtmlDocument\setHeadData(), AbstractWebApplication\setHeader(), FlattenException\setHeaders(), Table\setHeaders(), Table\setHeaderTitle(), TableStyle\setHeaderTitleFormat(), LazyCommand\setHelp(), Command\setHelp(), Question\setHidden(), Command\setHidden(), Question\setHiddenFallback(), Table\setHorizontal(), TableStyle\setHorizontalBorderChars(), Uri\setHost(), DebugBar\setHttpDriver(), Session\setId(), RuntimeStorage\setId(), NativeStorage\setId(), FileLayout\setIncludePaths(), JavascriptRenderer\setIncludeVendors(), OptionsResolver\setInfo(), JavascriptRenderer\setInitialization(), Symfony\Component\Console\Tester\setInputs(), Toolbar\setItems(), JavascriptRenderer\setJavascriptClass(), JsonapiDocument\setJsonapi(), Document\setJsonapi(), Crypt\setKey(), RouterViewConfiguration\setKey(), DES\setKey(), Document\setLanguage(), User\setLastVisit(), ActionButton\setLayout(), FileLayout\setLayoutId(), DatabaseQuery\setLimit(), FlattenException\setLine(), Document\setLineEnd(), Document\setLink(), PreloadManager\setLinkProvider(), Tobscure\JsonApi\setLinks(), PropelCollector\setLogQueriesToLogger(), InstallerAdapter\setManifest(), Question\setMaxAttempts(), CronExpression\setMaxIterationCount(), Version\setMediaVersion(), Document\setMediaVersion(), FlattenException\setMessage(), Tobscure\JsonApi\setMeta(), Document\setMetaData(), Route\setMethods(), Document\setMimeEncoding(), Document\setModifiedDate(), DatabaseDriver\setMonitor(), Question\setMultiline(), ChoiceQuestion\setMultiselect(), XmlDocument\setName(), JsonDocument\setName(), RouterViewConfiguration\setName(), QueryElement\setName(), Session\setName(), RuntimeStorage\setName(), NativeStorage\setName(), Command\setName(), RouterViewConfiguration\setNestable(), Question\setNormalizer(), OptionsResolver\setNormalizer(), JavascriptRenderer\setOpenHandlerClass(), JavascriptRenderer\setOpenHandlerUrl(), Http\setOption(), WebAssetItem\setOption(), ActionButton\setOption(), ToolbarButton\setOption(), Client\setOption(), BaseLayout\setOptions(), ActionButton\setOptions(), ToolbarButton\setOptions(), NativeStorage\setOptions(), AbstractDumper\setOutput(), CliApplication\setOutput(), TableStyle\setPaddingChar(), TableStyle\setPadType(), InstallerScript\setParams(), Joomla\CMS\Tree\setParent(), RouterViewConfiguration\setParent(), ToolbarButton\setParent(), CategoryNode\setParent(), CronExpression\setPart(), Uri\setPass(), Uri\setPath(), Route\setPattern(), Uri\setPort(), Engine\setPrecision(), Document\setPreloadManager(), FlattenException\setPrevious(), CliOutput\setProcessor(), LazyCommand\setProcessTitle(), Command\setProcessTitle(), ChoiceQuestion\setPrompt(), OptionsResolver\setPrototype(), DatabaseQuery\setQuery(), DatabaseDriver\setQuery(), BaseController\setRedirect(), PrimeField\setReduction(), Route\setRegex(), Builder\setRegisteredClaim(), DebugBar\setRequestIdGenerator(), OptionsResolver\setRequired(), InstallerAdapter\setRoute(), Route\setRouteVariables(), Table\setRow(), Route\setRules(), Uri\setScheme(), ReCaptcha\setScoreThreshold(), Mail\setSender(), Joomla\Application\setSession(), ConsoleApplication\setSession(), OpensearchDocument\setShortName(), DebugBar\setStackAlwaysUseSessionStorage(), DebugBar\setStackDataSessionNamespace(), Profiler\setStart(), Session\setState(), FlattenException\setStatusCode(), FlattenException\setStatusText(), DebugBar\setStorage(), Table\setStyle(), Mail\setSubject(), FileLayout\setSuffixes(), Document\setTab(), SymmetricKey\setTag(), Document\setTitle(), Client\setToken(), FlattenException\setTrace(), Question\setTrimmable(), Microdata\setType(), Document\setType(), ParagonIE_Sodium_Core32_Int32\setUnsignedInt(), ParagonIE_Sodium_Core32_Int64\setUnsignedInt(), CaptchaField\setup(), SymmetricKey\setup(), SymmetricKey\setupGCM(), InstallerAdapter\setupScriptfile(), PluginAdapter\setupUninstall(), Uri\setUser(), JavascriptRenderer\setUseRequireJs(), Question\setValidator(), MessagesCollector\setVarDumper(), DataCollector\setVarDumper(), JavascriptRenderer\setVariableName(), SingleCommandApplication\setVersion(), TableStyle\setVerticalBorderChars(), Document\setWebAssetManager(), BigInteger\shiftedLeft(), BigInteger\shiftedRight(), Cursor\show(), PrivateKey\sign(), Builder\sign(), CodePointString\slice(), UnicodeString\slice(), ByteString\slice(), PHPMailer\smtpConnect(), PHPMailer\smtpSend(), CodePointString\splice(), UnicodeString\splice(), ByteString\splice(), CodePointString\split(), UnicodeString\split(), ByteString\split(), AbstractString\split(), DebugBar\stackData(), Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler(), Session\start(), Joomla\Component\Scheduler\Administrator\Traits\startRoutine(), SMTP\startTLS(), Italian\stem(), Romanian\stem(), Dutch\stem(), German\stem(), English\stem(), Italian\step0(), French\step0(), French\step6(), MenuType\store(), PageController\store(), Menu\store(), WorkflowTable\store(), User\store(), Nested\store(), PluginAdapter\storeExtension(), CoreContent\storeUcmBase(), BigDecimal\stripTrailingZeros(), Integer\subtract(), CompletionSuggestions\suggestOption(), CompletionSuggestions\suggestOptions(), CompletionSuggestions\suggestValue(), CompletionSuggestions\suggestValues(), CaptiveModel\suppressAllModules(), Form\syncPaths(), Container\tag(), TagsHelper\tagItem(), LogoutUniqueFieldRule\test(), LoginUniqueFieldRule\test(), EqualsRule\test(), NotequalsRule\test(), FormRule\test(), Engine\testPrimality(), LazyAssertion\that(), ByteString\title(), FlattenException\toArray(), BigDecimal\toBigDecimal(), BigDecimal\toBigInteger(), BigInteger\toBigInteger(), BigRational\toBigRational(), BigInteger\toBigRational(), Base32\toBin(), Engine\toBytesHelper(), AbstractString\toByteString(), BigDecimal\toFloat(), BigInteger\toInt(), BigIntegerGmp\toInteger(), DatabaseQuery\toQuerySet(), BigDecimal\toScale(), PHP\toString(), Uuid\toString(), Joomla\CMS\Application\triggerEvent(), PackageAdapter\triggerManifestScript(), InstallerAdapter\triggerManifestScript(), ByteString\trim(), ByteString\trimEnd(), AbstractString\trimPrefix(), ByteString\trimStart(), AbstractString\trimSuffix(), AbstractString\truncate(), LazyAssertion\tryAll(), DatabaseQuery\unbind(), Installer\uninstall(), InstallerAdapter\uninstall(), TaskTable\unlock(), SqliteDriver\unlockTables(), MysqlDriver\unlockTables(), PgsqlDriver\unlockTables(), MysqliDriver\unlockTables(), ClassLoader\unregister(), BaseController\unregisterTask(), Builder\unsign(), Installer\update(), DatabaseQuery\update(), ByteString\upper(), WebAssetManager\useAsset(), RequestDataCollector\useHtmlVarDumper(), ConfigCollector\useHtmlVarDumper(), ExceptionsCollector\useHtmlVarDumper(), MessagesCollector\useHtmlVarDumper(), WebAssetManager\usePresetItems(), GreaterOrEqualsTo\validate(), EqualsTo\validate(), LesserOrEqualsTo\validate(), Form\validate(), FormField\validate(), DatabaseQuery\values(), Image\watermark(), DatabaseQuery\where(), Collection\with(), JWKSet\with(), Resource\with(), Nyholm\Psr7\withAddedHeader(), Laminas\Diactoros\withAddedHeader(), Behavior\withAssertion(), Link\withAttribute(), ServerRequest\withAttribute(), Nyholm\Psr7\withBody(), Laminas\Diactoros\withBody(), Data\withContext(), EC\withContext(), ServerRequest\withCookieParams(), DatabaseExporter\withData(), JsonResponse\withEncodingOptions(), Uri\withFragment(), Identity\withHash(), AsymmetricKey\withHash(), RSA\withHash(), Nyholm\Psr7\withHeader(), Laminas\Diactoros\withHeader(), Builder\withHeader(), Uri\withHost(), Link\withHref(), RSA\withLabel(), Fig\Link\withLink(), GenericLinkProvider\withLink(), Data\withMaxDepth(), Data\withMaxItemsPerDepth(), Nyholm\Psr7\withMethod(), Laminas\Diactoros\withMethod(), RSA\withMGFHash(), JWKSet\without(), Link\withoutAttribute(), ServerRequest\withoutAttribute(), Nyholm\Psr7\withoutHeader(), Laminas\Diactoros\withoutHeader(), Fig\Link\withoutLink(), GenericLinkProvider\withoutLink(), Link\withoutRel(), Identity\withPadding(), RSA\withPadding(), ServerRequest\withParsedBody(), phpseclib3\Crypt\Common\Traits\withPassword(), Uri\withPath(), JWSBuilder\withPayload(), JsonResponse\withPayload(), GenericLanguageInflectorFactory\withPluralRules(), BigDecimal\withPointMovedLeft(), BigDecimal\withPointMovedRight(), Uri\withPort(), Nyholm\Psr7\withProtocolVersion(), Laminas\Diactoros\withProtocolVersion(), Identity\withPublicKey(), Identity\withPublicKeyBlob(), Uri\withQuery(), ServerRequest\withQueryParams(), Data\withRefHandles(), Link\withRel(), Nyholm\Psr7\withRequestTarget(), Laminas\Diactoros\withRequestTarget(), RSA\withSaltLength(), Uri\withScheme(), Identity\withSignatureFormat(), DSA\withSignatureFormat(), EC\withSignatureFormat(), GenericLanguageInflectorFactory\withSingularRules(), Response\withStatus(), DatabaseExporter\withStructure(), DatabaseImporter\withStructure(), ServerRequest\withUploadedFiles(), Nyholm\Psr7\withUri(), Laminas\Diactoros\withUri(), Uri\withUserInfo(), AbstractString\wordwrap(), ParagonIE_Sodium_Core32_Int32\xorInt32(), ParagonIE_Sodium_Core32_Int64\xorInt64(), ParagonIE_Sodium_Core32_SecretStream_State\xorNonce(), et ParagonIE_Sodium_Core_SecretStream_State\xorNonce().

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ else

if($this->item->xml) ($this->item->xml->description) ( $this->item->xml) else
Valeur initiale :
{
echo Text::_('COM_MODULES_ERR_XML')

◆ endif

endif

◆ fields

$this fields
Valeur initiale :
= array(
'showtitle',
'position',
'published',
'publish_up',
'publish_down',
'access',
'ordering',
'language',
'note'
)

◆ fieldset

bool $groupByFieldset Whether group the subform fields by it s fieldset = 'description'

Référencé par AccessiblemediaField\setup().

◆ fieldsets

$this fieldsets = $this->form->getFieldsets('params')

◆ if

if(! $long_description)

◆ ignore_fieldsets

$this ignore_fieldsets = array('basic', 'description')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Espaces de nommage | Variables
Référence du fichier administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$input = $app->input
$assoc = Associations::isEnabled()
$this | ignore_fieldsets = array('images', 'jbasic', 'jmetadata', 'item_associations')
$this | useCoreUI = true
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
endforeach
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assoc

$assoc = Associations::isEnabled()

◆ $input

$input = $app->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = array('images', 'jbasic', 'jmetadata', 'item_associations')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
  • plugin
Espaces de nommage | Variables
Référence du fichier administrator/components/com_plugins/tmpl/plugin/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | fieldsets = $this->form->getFieldsets('params')
$this | useCoreUI = true
$input = Factory::getApplication()->input
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
if( $this->item->xml)( $this->item->xml->description)($this->item->xml) | else
$this | fieldset = 'description'
$short_description = Text::_($this->item->xml->description)
$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)
if (! $long_description)
endif
else __pad0__
$html = LayoutHelper::render('joomla.edit.fieldset', $this)
$this | fields
$this | ignore_fieldsets = array('basic', 'description')

Documentation des variables

◆ $html

$html = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $input

$input = Factory::getApplication()->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $long_description

$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $short_description

$short_description = Text::_($this->item->xml->description)

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ else

if($this->item->xml) ($this->item->xml->description) ( $this->item->xml) else
Valeur initiale :
{
echo Text::_('COM_PLUGINS_XML_ERR')

◆ endif

endif

◆ fields

$this fields
Valeur initiale :
= array(
'enabled',
'access',
'ordering',
'folder',
'element',
'note',
)

◆ fieldset

$this fieldset = 'description'

◆ fieldsets

$this fieldsets = $this->form->getFieldsets('params')

◆ if

if(! $long_description)

◆ ignore_fieldsets

$this ignore_fieldsets = array('basic', 'description')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • request
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/request/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • link
Espaces de nommage | Variables
Référence du fichier administrator/components/com_redirect/tmpl/link/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
endif

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • task
Espaces de nommage | Variables
Référence du fichier administrator/components/com_scheduler/tmpl/task/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = $this->app
$input = $app->getInput()
$this | ignore_fieldsets = ['aside', 'details', 'exec_hist', 'custom-cron-rules', 'basic', 'advanced', 'priority']
$this | useCoreUI = true
$advancedFieldsets = $this->form->getFieldsets('params')
continue
endif
$this | ignore_fieldsets [] = $fieldset->name
endforeach
if ( $this->item->taskOption)
$short_description = Text::_($taskOption->desc)
$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)
else __pad0__

Documentation des variables

◆ $advancedFieldsets

$advancedFieldsets = $this->form->getFieldsets('params')

◆ $app

$app = $this->app

◆ $input

$input = $app->getInput()

◆ $long_description

$long_description = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $short_description

$short_description = Text::_($taskOption->desc)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ continue

continue

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(! $long_description)

◆ ignore_fieldsets [1/2]

$this ignore_fieldsets = ['aside', 'details', 'exec_hist', 'custom-cron-rules', 'basic', 'advanced', 'priority']

◆ ignore_fieldsets [2/2]

$this ignore_fieldsets[] = $fieldset->name

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tag
Espaces de nommage | Variables
Référence du fichier administrator/components/com_tags/tmpl/tag/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | ignore_fieldsets = ['jmetadata']
$this | useCoreUI = true

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ ignore_fieldsets

$this ignore_fieldsets = ['jmetadata']

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • style
Espaces de nommage | Variables
Référence du fichier administrator/components/com_templates/tmpl/style/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | useCoreUI = true
$user = Factory::getUser()
$this | fieldset = 'description'
$description = LayoutHelper::render('joomla.edit.fieldset', $this)
endif
$html = LayoutHelper::render('joomla.edit.fieldset', $this)
$this | fields
$this | fieldsets = array()
$this | ignore_fieldsets = array('basic', 'description')

Documentation des variables

◆ $description

$description = LayoutHelper::render('joomla.edit.fieldset', $this)

Référencé par Result\__serialize(), DebugClassLoader\checkAnnotations(), PrivacyPlugin\createDomain(), JsonDescriptor\describeApplication(), MarkdownDescriptor\describeApplication(), TextDescriptor\describeApplication(), TextDescriptor\describeCommand(), TextDescriptor\describeJoomlaApplication(), InstallerAdapter\discover_install(), CategoryFeedView\display(), FeedView\display(), XmlDescriptor\getApplicationDocument(), NoteField\getLabel(), FormField\getLayoutData(), SiteApplication\getParams(), InstallerAdapter\install(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), et AddConsoleCommandPass\process().

◆ $html

$html = LayoutHelper::render('joomla.edit.fieldset', $this)

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ fields

$this fields
Valeur initiale :
= array(
'home',
'client_id',
'template'
)

◆ fieldset

$this fieldset = 'description'

◆ fieldsets

$this fieldsets = array()

◆ ignore_fieldsets

$this ignore_fieldsets = array('basic', 'description')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • group
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/group/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | useCoreUI = true
$this | ignore_fieldsets = array('group_details')

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ ignore_fieldsets

$this ignore_fieldsets = array('group_details')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • level
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/level/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • method
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/method/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)
if(!empty($this->returnURL)) $recordId = (int) $this->record->id ?? 0
$method = $this->record->method ?? $this->getModel()->getState('method')
$userId = (int) $this->user->id ?? 0
$headingLevel = 2

Documentation des variables

◆ $cancelURL

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)

◆ $headingLevel

$headingLevel = 2

◆ $method

$method = $this->record->method ?? $this->getModel()->getState('method')

Référencé par DataSet\__call(), LazyAssertion\__call(), AssertionChain\__call(), WebAssetManager\__call(), Assert\__callStatic(), Assertion\__callStatic(), Request\__construct(), Callback\__construct(), Router\__construct(), ServerRequest\__construct(), ViewController\_makeId(), Installer\abort(), Mail\add(), SMTP\authenticate(), Client\baseString(), CallbackController\callback(), DebugClassLoader\checkAnnotations(), Joomla\Application\checkToken(), BaseController\checkToken(), InputFilter\clean(), X509\computeKeyIdentifier(), PHPMailer\createBody(), Psr17Factory\createRequest(), HttplugFactory\createRequest(), Psr17Factory\createServerRequest(), ConsoleApplication\doExecute(), ApiController\execute(), Assertion\generateMessage(), ViewController\get(), AbstractView\get(), ManageModel\getListQuery(), MethodModel\getMethod(), Nyholm\Psr7\getMethod(), Container\getMethodArgs(), MethodsModel\getMethods(), Mfa\getMfaMethods(), LazyString\getPrettyName(), CaptiveModel\getRecords(), AbstractSerializer\getRelationship(), Symfony\Contracts\Service\getSubscribedServices(), ApiApplication\handlePreflight(), Container\hasFlag(), Http\makeTransportRequest(), MethodModel\methodExists(), Assert\methodExists(), Assert\methodNotExists(), Client\oauthRequest(), ApiRouter\parseApiRoute(), Router\parseRoute(), MethodModel\populateMfaMethods(), FeedParser\processElement(), TraceablePDO\profileCall(), Client\query(), BaseController\registerDefaultTask(), BaseController\registerTask(), Curl\request(), Stream\request(), StreamTransport\request(), Socket\request(), CurlTransport\request(), SocketTransport\request(), SMTP\setDebugOutput(), SymmetricKey\setPassword(), Client\signRequest(), Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler(), SSH2\sublogin(), PackageAdapter\triggerManifestScript(), InstallerAdapter\triggerManifestScript(), AsymmetricKey\validatePlugin(), et Nyholm\Psr7\withMethod().

◆ $recordId

if (!empty( $this->returnURL)) $recordId = (int) $this->record->id ?? 0

Référencé par ApiController\add(), ContactController\allowEdit(), NewsfeedController\allowEdit(), BannerController\allowEdit(), CategoryController\allowEdit(), FieldController\allowEdit(), TaskController\allowEdit(), WorkflowController\allowEdit(), GroupController\allowEdit(), TransitionController\allowEdit(), StageController\allowEdit(), ArticleController\allowEdit(), ModuleController\allowEdit(), FormController\allowSave(), FormController\cancel(), OverrideController\edit(), MediaController\edit(), FormController\edit(), MenutypeField\getInput(), LanguageController\getRedirectToItemAppend(), NoteController\getRedirectToItemAppend(), TemplateController\getRedirectToItemAppend(), WorkflowController\getRedirectToItemAppend(), StageController\getRedirectToItemAppend(), TransitionController\getRedirectToItemAppend(), FieldController\getRedirectToItemAppend(), GroupController\getRedirectToItemAppend(), CategoryController\getRedirectToItemAppend(), ArticleController\getRedirectToItemAppend(), ModuleController\getRedirectToItemAppend(), ContactController\getRedirectToItemAppend(), FormController\getRedirectToItemAppend(), WorkflowController\postSaveHook(), StyleController\save(), OverrideController\save(), FormController\save(), et ItemController\setType().

◆ $userId

$userId = (int) $this->user->id ?? 0


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • note
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/note/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • user
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/user/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$input = Factory::getApplication()->input
$fieldsets = $this->form->getFieldsets()
$settings = array()
$this | useCoreUI = true
endif
$this | ignore_fieldsets = array('user_details')

Documentation des variables

◆ $fieldsets

$fieldsets = $this->form->getFieldsets()

Référencé par Form\getFieldsets(), et Installer\getParams().

◆ $input

$input = Factory::getApplication()->input

◆ $settings

$settings = array()

Référencé par SetConfigurationCommand\checkDb(), ChecksModel\getPhpSettings(), et UpdateModel\getPhpSettings().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = array('user_details')

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • stage
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/stage/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = $app->getIdentity()
$input = $app->input
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
$clientId = $this->state->get('item.client_id', 0)
$lang = Factory::getLanguage()->getTag()
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $clientId

$clientId = $this->state->get('item.client_id', 0)

◆ $input

$input = $app->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $lang

$lang = Factory::getLanguage()->getTag()

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $user

$user = $app->getIdentity()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • transition
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/transition/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = $app->getIdentity()
$this | ignore_fieldsets = ['params', 'transition', 'permissions']
$this | useCoreUI = true
$isModal = $this->input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $this->input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $isModal

$isModal = $this->input->get('layout') === 'modal'

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $this->input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $user

$user = $app->getIdentity()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = ['params', 'transition', 'permissions']

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • workflow
Espaces de nommage | Variables
Référence du fichier administrator/components/com_workflow/tmpl/workflow/edit.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$app = Factory::getApplication()
$user = $app->getIdentity()
$input = $app->input
$isModal = $input->get('layout') === 'modal'
$layout = $isModal ? 'modal' : 'edit'
$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''
$clientId = $this->state->get('item.client_id', 0)
$lang = Factory::getLanguage()->getTag()
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $clientId

$clientId = $this->state->get('item.client_id', 0)

◆ $input

$input = $app->input

◆ $isModal

$isModal = $input->get('layout') === 'modal'

◆ $lang

$lang = Factory::getLanguage()->getTag()

◆ $layout

$layout = $isModal ? 'modal' : 'edit'

◆ $tmpl

$tmpl = $isModal || $input->get('tmpl', '', 'cmd') === 'component' ? '&tmpl=component' : ''

◆ $user

$user = $app->getIdentity()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • form
Espaces de nommage | Variables
Référence du fichier components/com_contact/tmpl/form/edit.php

Espaces de nommage

Joomla\Site

Variables

$this | tab_name = 'com-contact-form'
$this | ignore_fieldsets = array('details', 'item_associations', 'language')
$this | useCoreUI = true
endif
else __pad12__

Documentation des variables

◆ __pad12__

else __pad12__

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = array('details', 'item_associations', 'language')

◆ tab_name

$this tab_name = 'com-contact-form'

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • form
Espaces de nommage | Variables
Référence du fichier components/com_content/tmpl/form/edit.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$this | tab_name = 'com-content-form'
$this | ignore_fieldsets = array('image-intro', 'image-full', 'jmetadata', 'item_associations')
$this | useCoreUI = true
$params = $this->state->get('params')
$editoroptions = isset($params->show_publishing_options)
endif
else __pad13__

Documentation des variables

◆ $editoroptions

$editoroptions = isset($params->show_publishing_options)

◆ $params

$params = $this->state->get('params')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad13__

else __pad13__

◆ endif

endif

◆ ignore_fieldsets

$this ignore_fieldsets = array('image-intro', 'image-full', 'jmetadata', 'item_associations')

◆ tab_name

$this tab_name = 'com-content-form'

◆ useCoreUI

$this useCoreUI = true


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • method
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/method/edit.php

Espaces de nommage

Joomla\Site

Variables

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)
if(!empty($this->returnURL)) $recordId = (int) $this->record->id ?? 0
$method = $this->record->method ?? $this->getModel()->getState('method')
$userId = (int) $this->user->id ?? 0
$headingLevel = 2

Documentation des variables

◆ $cancelURL

$cancelURL = Route::_('index.php?option=com_users&task=methods.display&user_id=' . $this->user->id)

◆ $headingLevel

$headingLevel = 2

◆ $method

$method = $this->record->method ?? $this->getModel()->getState('method')

◆ $recordId

if (!empty( $this->returnURL)) $recordId = (int) $this->record->id ?? 0

◆ $userId

$userId = (int) $this->user->id ?? 0


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/profile/edit.php

Espaces de nommage

Joomla\Site

Variables

$lang = Factory::getLanguage()
$wa = $this->document->getWebAssetManager()
endif
endforeach

Documentation des variables

◆ $lang

$lang = Factory::getLanguage()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier edit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • icons
Espaces de nommage | Variables
Référence du fichier layouts/joomla/content/icons/edit.php

Espaces de nommage

Joomla\Site

Variables

$article = $displayData['article']
$tooltip = $displayData['tooltip']
$nowDate = strtotime(Factory::getDate())
$icon = $article->state ? 'edit' : 'eye-slash'
$currentDate = Factory::getDate()->format('Y-m-d H:i:s')
$isUnpublished
if($isUnpublished) $aria_described = 'editarticle-' . (int) $article->id

Documentation des variables

◆ $aria_described

if ( $isUnpublished) $aria_described = 'editarticle-' . (int) $article->id

Référencé par Icon\edit().

◆ $article

$article = $displayData['article']

Référencé par Router\__construct(), PlgSampledataMultilang\addArticle(), JHtmlIcon\edit(), Icon\edit(), ConsentBoxField\getAssignedArticleUrl(), TosField\getLabel(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), ArticlesCategoryHelper\getList(), PlgContentFinder\onContentAfterDelete(), Joomla\onContentAfterDelete(), PlgContentFinder\onContentAfterSave(), Joomla\onContentAfterSave(), PlgContentJoomla\onContentAfterSave(), PlgContentFinder\onContentBeforeSave(), PlgContentLoadmodule\onContentPrepare(), PlgSystemPrivacyconsent\onPrivacyCheckPrivacyPolicyPublished(), et Content\prepare().

◆ $currentDate

$currentDate = Factory::getDate()->format('Y-m-d H:i:s')

◆ $icon

$icon = $article->state ? 'edit' : 'eye-slash'

◆ $isUnpublished

$isUnpublished
Valeur initiale :
= ($article->publish_up > $currentDate)
|| !is_null($article->publish_down) && ($article->publish_down < $currentDate)
$article
$article
Definition: layouts/joomla/content/icons/edit.php:16
$currentDate
$currentDate
Definition: layouts/joomla/content/icons/edit.php:21

◆ $nowDate

$nowDate = strtotime(Factory::getDate())

Référencé par ContactModel\buildContactExtendedData(), Icon\edit(), AssociationHelper\getAssociations(), NewsfeedModel\getItem(), ArticleModel\getItem(), ContactModel\getItem(), TagsPopularHelper\getList(), BannersModel\getListQuery(), FeaturedModel\getListQuery(), SearchModel\getListQuery(), TagsHelper\getTagItemsQuery(), ArchiveModel\getYears(), Table\publish(), PublishedButton\render(), et FeaturedButton\render().

◆ $tooltip

$tooltip = $displayData['tooltip']
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par AdministratorService\association(), Menus\association(), Icon\edit(), AssociationsHelper\getAssociationHtmlList(), et HTMLHelper\tooltip().


Joomla CMS: Référence du fichier edit_assignment.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • module
Espaces de nommage | Variables
Référence du fichier com_modules/tmpl/module/edit_assignment.php

Espaces de nommage

Joomla\Administrator

Variables

$menuTypes = MenusHelper::getMenuLinks()
foreach | ($menuTypes as &$type) (count( $type->links))
foreach( $type->links as $i=> $link)($prevlevel< $link->level) elseif($prevlevel > $link->level) | else
$selected = 0
if($this->item->assignment==0) elseif($this->item->assignment< 0) elseif($this->item->assignment > 0) | $uselessMenuItem = in_array($link->type, array('separator', 'heading', 'alias', 'url'))
$id = 'jform_menuselect'
else __pad2__
endif
if(!isset($type->links[$i+1])) | $prevlevel = $link->level
endforeach

Documentation des variables

◆ $id

string $id = 'jform_menuselect'

Layout variables

Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par PublicKeyCredentialRpEntity\__construct(), PublicKeyCredentialUserEntity\__construct(), Credential\__construct(), PublicKeyCredential\__construct(), PublicKeyCredentialDescriptor\__construct(), TaskOption\__get(), FileStorage\_checkExpire(), RouteHelper\_findItem(), MenuType\_getAssetName(), Module\_getAssetParentId(), Category\_getAssetParentId(), Content\_getAssetParentId(), TransitionTable\_getAssetParentId(), Language\_getAssetParentId(), GroupTable\_getAssetParentId(), StageTable\_getAssetParentId(), FieldTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), MenuType\_getAssetParentId(), MemcachedStorage\_getCacheId(), CacheStorage\_getCacheId(), PackageAdapter\_getExtensionId(), FileStorage\_getFilePath(), Nested\_getNode(), PlgUserJoomla\_getUser(), Categories\_load(), PlgContentLoadmodule\_loadid(), HtmlView\_prepareDocument(), Task\acquireLock(), MessageController\action(), PlgSampledataMultilang\addAssociations(), ActionsDropdown\addCustomItem(), Taxonomy\addMap(), Bootstrap\addSlide(), UiTab\addTab(), Bootstrap\addTab(), Joomla\CMS\MVC\Model\addTransitionField(), MfaTable\afterDelete(), PlgSystemHttpHeaders\applyHashesToCspRule(), UpdateModel\applyUpdateSite(), MessageController\archive(), ActionsDropdown\archive(), MessagesModel\archiveMessage(), AbstractMenu\authorise(), FormController\batch(), CategoryModel\batchFlipordering(), UserModel\batchUser(), Select\booleanlist(), Router\build(), StandardRules\build(), HTMLHelper\calendar(), AssociationController\cancel(), ContentHelper\canDeleteState(), Adapter\change(), Usergroup\check(), MenuType\check(), ViewLevel\check(), StageTable\check(), WorkflowTable\check(), Dispatcher\checkAccess(), BaseController\checkEditId(), AssociationsController\checkin(), BannerModel\click(), BannerTable\clicks(), TemplateController\close(), ApcuStorage\contains(), WincacheStorage\contains(), FileStorage\contains(), MemcachedStorage\contains(), RedisStorage\contains(), Cache\contains(), NewsfeedsHelper\countItems(), NewsfeedsHelper\countTagItems(), Symfony\Contracts\Service\createCircularReferenceException(), TemplateController\createFile(), PublicKeyCredentialUserEntity\createFromArray(), Symfony\Contracts\Service\createNotFoundException(), AsciiSlugger\createTransliterator(), PasswordHash\crypt_private(), Versioning\delete(), UpdatesitesModel\delete(), OverridesController\delete(), MfaTable\delete(), Usergroup\delete(), MethodController\delete(), TemplateController\delete(), RouterView\detachRule(), Router\detachRule(), DiscoverModel\discover_install(), FeedView\display(), DisplayController\display(), Captcha\display(), Editor\display(), AssociationHelper\displayAssociations(), FieldsController\displayItem(), GroupsController\displayItem(), ConsentsController\displayItem(), MenusController\displayItem(), StylesController\displayItem(), ModulesController\displayItem(), ItemsController\displayItem(), OverridesController\displayItem(), CategoriesController\displayItem(), TasksRunCommand\doExecute(), ActionsDropdown\duplicate(), AssociationController\edit(), Dropdown\edit(), ToolbarButton\ensureUniqueId(), Query\explained(), MenuController\exportXml(), FileAdapter\extensionExistsInSystem(), ActionsDropdown\feature(), Scheduler\fetchTaskRecord(), RulesFilter\filter(), UpdateModel\finaliseUpgrade(), RouteHelper\findItem(), Router\fixSegment(), Select\genericlist(), ViewController\get(), Versioning\get(), OutputController\get(), ApcuStorage\get(), WincacheStorage\get(), Symfony\Contracts\Service\get(), PageController\get(), PdoStorage\get(), FileStorage\get(), UserGroupsHelper\get(), MemcachedStorage\get(), Categories\get(), RedisStorage\get(), Cache\get(), ContentHelper\getActions(), PlgSampledataMultilang\getAdminId(), RouteHelper\getArticleRoute(), Router\getArticleSegment(), Access\getAssetAncestors(), Access\getAssetRules(), AssociationHelper\getAssociations(), Associations\getAssociations(), AssociationsHelper\getAssociations(), AssociationsHelper\getAssociationsForItem(), X509\getAttribute(), Access\getAuthorisedViewLevels(), DebugFormatterHelper\getBorder(), Router\getCategoriesSegment(), CategoryAssociationHelper\getCategoryAssociations(), RouteHelper\getCategoryRoute(), Router\getCategorySegment(), ApplicationHelper\getClientInfo(), RouteHelper\getComponentTagRoute(), SSH2\getConnectionByResourceId(), RouteHelper\getContactRoute(), Router\getContactSegment(), ActionlogsHelper\getContentTypeLink(), X509\getExtension(), X509\getExtensionHelper(), TransitionsModel\getFilterForm(), FormModel\getForm(), WorkflowModel\getForm(), StageModel\getForm(), TransitionModel\getForm(), ArticleModel\getForm(), ModuleModel\getForm(), RouteHelper\getFormRoute(), Router\getFormSegment(), CredentialRepository\getHandleFromUserId(), PublicKeyCredentialRpEntity\getId(), PublicKeyCredentialUserEntity\getId(), Credential\getId(), PublicKeyCredentialDescriptor\getId(), FormField\getId(), Document\getIncluded(), AssociationField\getInput(), SubformField\getInput(), Mail\getInstance(), MessagesModel\getItem(), AssociationsHelper\getItem(), AbstractMenu\getItem(), Adapter\getItem(), TemplatesModel\getItems(), CategoryModel\getItems(), ArticlesModel\getItems(), TagsHelper\getItemTags(), FormField\getLayoutData(), TagsSimilarHelper\getList(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LoginModel\getMenuLanguage(), Router\getMethodSegment(), ModuleHelper\getModuleById(), ItemModel\getModules(), RouteHelper\getNewsfeedRoute(), Router\getNewsfeedSegment(), MenuParentField\getOptions(), TagField\getOptions(), InstallerScript\getParam(), AbstractMenu\getParams(), Adapter\getPluginType(), ProviderManager\getProvider(), X509\getRegisteredExtension(), X509\getRevokedCertificateExtension(), RouteHelper\getRoute(), JWS\getSignature(), ArchiveModel\getSlugColumn(), ContactModel\getSlugColumn(), CategoryModel\getSlugColumn(), DebugBar\getStackedData(), QueryCollector\getStatements(), ItemModel\getStoreId(), SelectModel\getStoreId(), ClientsModel\getStoreId(), SearchesModel\getStoreId(), TasksModel\getStoreId(), LevelsModel\getStoreId(), MessagesModel\getStoreId(), PluginsModel\getStoreId(), StylesModel\getStoreId(), CacheModel\getStoreId(), FiltersModel\getStoreId(), GroupsModel\getStoreId(), FieldsModel\getStoreId(), LinksModel\getStoreId(), ContactsModel\getStoreId(), RequestsModel\getStoreId(), NewsfeedsModel\getStoreId(), TagsModel\getStoreId(), SuggestionsModel\getStoreId(), ConsentsModel\getStoreId(), InstalledModel\getStoreId(), UsersModel\getStoreId(), AssociationsModel\getStoreId(), CategoriesModel\getStoreId(), FeaturedModel\getStoreId(), ModulesModel\getStoreId(), DebuggroupModel\getStoreId(), DebuguserModel\getStoreId(), NotesModel\getStoreId(), TemplatesModel\getStoreId(), ArticlesModel\getStoreId(), ItemsModel\getStoreId(), LanguagesModel\getStoreId(), BannersModel\getStoreId(), MapsModel\getStoreId(), IndexModel\getStoreId(), SearchModel\getStoreId(), ListModel\getStoreId(), UpdatesitesModel\getStoreId(), RouteHelper\getTagRoute(), TagsHelper\getTagTreeArray(), Taxonomy\getTaxonomy(), UCMType\getTypeId(), UpdateModel\getUpdateInformation(), UpdateModel\getUpdateSitesInfo(), Adapter\getUrl(), Factory\getUser(), Joomla\Plugin\System\Webauthn\PluginTraits\getUserFromData(), Select\groupedlist(), ErrorHandler\handleError(), PublicKeyCredentialDescriptorCollection\has(), Symfony\Contracts\Service\has(), UserGroupsHelper\has(), BaseController\holdEditId(), Builder\identifiedBy(), Captcha\initialise(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), DatabaseDriver\insertObject(), LanguagesModel\install(), Token\isIdentifiedBy(), Task\isValidId(), PublicKeyCredentialRpEntity\jsonSerialize(), Access\level(), Folder\listFolderTree(), User\load(), UserGroupsHelper\load(), PlgInstallerOverride\load(), PublicKeyCredentialLoader\loadArray(), ApcuStorage\lock(), FileStorage\lock(), Cache\lock(), MemcachedStorage\lock(), FileStorage\makeFilename(), Requests\makeGetRequest(), X509\mapInAttributes(), X509\mapInExtensions(), X509\mapOutAttributes(), X509\mapOutExtensions(), Document\mergeResource(), Behavior\multiselect(), PlgSystemPrivacyconsent\onAfterRoute(), Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), PlgContentJoomla\onContentBeforeChangeState(), PlgContentLoadmodule\onContentPrepare(), PlgSystemActionLogs\onContentPrepareData(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgCaptchaRecaptcha\onDisplay(), PlgCaptchaRecaptcha_Invisible\onDisplay(), PlgEditorCodemirror\onDisplay(), PlgFinderTags\onFinderAfterDelete(), PlgFinderNewsfeeds\onFinderAfterDelete(), PlgFinderContacts\onFinderAfterDelete(), PlgFinderContent\onFinderAfterDelete(), PlgFinderCategories\onFinderDelete(), Select\options(), ListHelper\ordering(), Menu\ordering(), TemplateController\overrides(), MenuModel\populateState(), CategoryModel\populateState(), ListHelper\positions(), ArticleController\postSaveHook(), ContactController\postSaveHook(), PlgContentFields\prepare(), HtmlView\prepareDocument(), MenuRules\preprocess(), AddConsoleCommandPass\process(), DebugFormatterHelper\progress(), ActionsDropdown\publish(), UpdatesitesModel\publish(), TemplateController\publish(), ManageModel\publish(), InstalledModel\publish(), TemplateModel\publish(), Select\radiolist(), ItemModel\rebuild(), AdminModel\redirectToAssociations(), ManageModel\refresh(), X509\registerExtension(), Adapter\reindex(), BaseController\releaseEditId(), Task\releaseLock(), PublicKeyCredentialDescriptorCollection\remove(), WincacheStorage\remove(), ApcuStorage\remove(), ManageModel\remove(), FileStorage\remove(), MemcachedStorage\remove(), RedisStorage\remove(), Cache\remove(), Adapter\remove(), X509\removeAttribute(), X509\removeExtension(), PackageAdapter\removeExtensionFiles(), X509\removeExtensionHelper(), X509\removeRevokedCertificateExtension(), JavascriptRenderer\render(), MessageController\republish(), MessagesModel\republishMessage(), PlgSystemSchedulerunner\runScheduler(), PlgSystemSchedulerunner\runTestCron(), PlgSystemSchedulerunner\runWebCron(), FileStorage\save(), RedisStorage\save(), MemcachedStorage\save(), PdoStorage\save(), FieldModel\save(), MenuModel\save(), CategoryModel\save(), TaskModel\save(), AdminModel\save(), ItemModel\save(), AbstractMenu\setActive(), X509\setAttribute(), WorkflowsController\setDefault(), StagesController\setDefault(), AbstractMenu\setDefault(), LanguagesModel\setDefault(), X509\setExtension(), X509\setExtensionHelper(), X509\setExtensionValue(), StyleModel\setHome(), ValidationData\setId(), Builder\setId(), Session\setId(), NativeStorage\setId(), Pathway\setItemName(), User\setLastVisit(), InstallerScript\setParams(), CategoryNode\setParent(), X509\setRevokedCertificateExtension(), Task\skipExecution(), DebugFormatterHelper\start(), DebugFormatterHelper\stop(), OutputController\store(), Versioning\store(), MfaTable\store(), WincacheStorage\store(), ApcuStorage\store(), PageController\store(), ViewController\store(), Menu\store(), CallbackController\store(), FileStorage\store(), MemcachedStorage\store(), RedisStorage\store(), Cache\store(), ContactController\submit(), ActionsDropdown\trash(), Menu\treerecurse(), ActionsDropdown\unarchive(), ActionsDropdown\unfeature(), InstallerAdapter\uninstall(), ApcuStorage\unlock(), FileStorage\unlock(), MemcachedStorage\unlock(), Cache\unlock(), MessageController\unpublish(), ActionsDropdown\unpublish(), MessagesModel\unpublishMessage(), StyleModel\unsetHome(), TagsHelper\unTagItem(), ActionsDropdown\untrash(), TemplateController\uploadFile(), Access\usergroup(), DisplayController\validateEntry(), ArticleController\vote(), et Joomla\CMS\MVC\Model\workflowAfterSave().

◆ $menuTypes

$menuTypes = MenusHelper::getMenuLinks()

Référencé par MenusModel\getItems(), ItemsModel\getListQuery(), MenusHelper\getMenuLinks(), et PlgSampledataBlog\onAjaxSampledataApplyStep2().

◆ $prevlevel

if (!isset( $type->links[ $i+1])) $prevlevel = $link->level

◆ $selected

$selected = 0

◆ $uselessMenuItem

if ( $this->item->assignment==0) elseif ( $this->item->assignment< 0) elseif ( $this->item->assignment > 0) $uselessMenuItem = in_array($link->type, array('separator', 'heading', 'alias', 'url'))

◆ ($menuTypes as &$type)

foreach ( $menuTypes as & $type)(count($type->links))

◆ __pad2__

else __pad2__

◆ else

foreach ($type->links as $i => $link) ( $prevlevel< $link->level) elseif ( $prevlevel > $link->level) else
Valeur initiale :
{
echo '</li>'

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier edit_assignment.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • style
Espaces de nommage | Variables
Référence du fichier com_templates/tmpl/style/edit_assignment.php

Espaces de nommage

Joomla\Administrator

Variables

$menuTypes = MenusHelper::getMenuLinks()
$user = Factory::getUser()
$wa = $this->document->getWebAssetManager()
if($link->template_style_id==$this->item->id) if($link->checked_out && $link->checked_out !=$user->id) endif
endforeach

Documentation des variables

◆ $menuTypes

$menuTypes = MenusHelper::getMenuLinks()

◆ $user

$user = Factory::getUser()

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

if ( $link->template_style_id==$this->item->id) if ( $link->checked_out &&$link->checked_out !=$user->id) endif


Joomla CMS: Référence du fichier edit_container.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • item
Espaces de nommage | Variables
Référence du fichier edit_container.php

Espaces de nommage

Joomla\Administrator

Variables

$menuLinks = MenusHelper::getMenuLinks('main')
$wa = $this->document->getWebAssetManager()
if (!empty( $menuLinks))
if(count($menuLinks)) | $params = new Registry($this->item->params)
$hiddenLinks = (array) $params->get('hideitems')
endif
if($prevlevel< $link->level) elseif($prevlevel > $link->level) | else
$selected = in_array($link->value, $hiddenLinks) ? 1 : 0
if(!isset($menuLinks[$i+1])) | $prevlevel = $link->level
endforeach

Documentation des variables

◆ $hiddenLinks

$hiddenLinks = (array) $params->get('hideitems')

◆ $menuLinks

$menuLinks = MenusHelper::getMenuLinks('main')

◆ $params

if (count( $menuLinks)) $params = new Registry($this->item->params)

◆ $prevlevel

if (!isset( $menuLinks[ $i+1])) $prevlevel = $link->level

◆ $selected

$selected = in_array($link->value, $hiddenLinks) ? 1 : 0

Référencé par Access\actions(), Access\assetgrouplist(), Select\booleanlist(), Select\genericlist(), ChoiceQuestion\getDefaultValidator(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), Pagination\getLimitBox(), ListField\getOptions(), WorkflowconditionField\getOptions(), Select\integerlist(), Access\level(), Menu\menuItemList(), Select\options(), ListHelper\ordering(), Select\radiolist(), Grid\sort(), SearchTools\sort(), Access\usergroup(), Access\usergroups(), et RSA\withPadding().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ else

if ( $prevlevel< $link->level) elseif ( $prevlevel > $link->level) else
Valeur initiale :
{
echo '</li>'

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($link->value==1) ( ! empty$menuLinks )


Joomla CMS: Référence du fichier edit_display.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Espaces de nommage | Variables
Référence du fichier edit_display.php

Espaces de nommage

Joomla\Administrator

Variables

$this fieldset = 'jbasic'

Documentation des variables

◆ fieldset

$this fieldset = 'jbasic'


Joomla CMS: Référence du fichier edit_groups.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • user
Espaces de nommage
Référence du fichier edit_groups.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier edit_lock.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • icons
Espaces de nommage | Variables
Référence du fichier edit_lock.php

Espaces de nommage

Joomla\Site

Variables

if(isset($displayData['ariaDescribed'])) elseif(isset($displayData['article'])) elseif(isset($displayData['contact'])) $tooltip = $displayData['tooltip']

Documentation des variables

◆ $tooltip

if (isset( $displayData[ 'ariaDescribed'])) elseif (isset( $displayData[ 'article'])) elseif (isset( $displayData[ 'contact'])) $tooltip = $displayData['tooltip']


Joomla CMS: Référence du fichier edit_modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
  • joomla
  • menu
Espaces de nommage | Variables
Référence du fichier layouts/joomla/menu/edit_modules.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$form = $displayData->getForm()
$input = $app->input
$component = $input->getCmd('option', 'com_content')
if($component=='com_categories') | $saveHistory = ComponentHelper::getParams($component)->get('save_history', 0)
$fields
$hiddenFields = $displayData->get('hidden_fields') ?: array()
if(! $saveHistory) | $html = array()
$html [] = '<fieldset><ul class="list-unstyled">'

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $component

$component = $input->getCmd('option', 'com_content')

◆ $fields

$fields
Valeur initiale :
= $displayData->get('fields') ?: array(
array('parent', 'parent_id'),
array('published', 'state', 'enabled'),
array('category', 'catid'),
'featured',
'sticky',
'access',
'language',
'tags',
'note',
'version_note',
)
$displayData
$displayData
Definition: administrator/components/com_banners/tmpl/banners/emptystate.php:16

Référencé par Table\__construct(), SqliteQuery\__toString(), ContactController\_sendEmail(), OnGetApiFields\addFields(), OnGetApiFields\addRelations(), JoomlaInstallerScript\addUserAuthProviderColumn(), ArticleModel\batchMove(), TaskTable\bind(), DegradedUuidBuilder\build(), DefaultUuidBuilder\build(), DatabaseExporter\buildXmlData(), PgsqlExporter\buildXmlStructure(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), LevelModel\canDelete(), PgSqlCaster\castResult(), CheckinModel\checkin(), ArticleModel\cleanupPostBatchCopy(), PrivacyPlugin\createCustomFieldsDomain(), StringCodec\decode(), HtmlView\display(), PlgSystemFields\display(), StringCodec\encode(), OrderedTimeCodec\encodeBinary(), Collection\fields(), Form\filter(), Form\findField(), Form\findFieldsByFieldset(), Form\findFieldsByGroup(), Form\findGroup(), CMSHelper\getDataObject(), Item\getFields(), FieldsHelper\getFields(), Parameters\getFields(), HtmlView\getFields(), Table\getFields(), Form\getFieldset(), FieldsHelper\getFieldTypes(), FinderHelper\getGetFields(), Form\getGroup(), CheckinModel\getItems(), AssociationsModel\getListQuery(), Nested\getRootId(), CMSHelper\getRowData(), CronExpression\getRunDate(), Parameters\getSort(), PgsqlDriver\getTableColumns(), SqliteDriver\getTableColumns(), MysqlDriver\getTableColumns(), MysqliDriver\getTableColumns(), AssociationExtensionHelper\getType(), AssociationsHelper\getType(), AssociationExtensionHelper\getTypeFieldName(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), DatabaseDriver\insertObject(), Form\load(), Table\load(), UCMContent\mapData(), Form\mergeNodes(), Nested\moveByReference(), PlgSystemFields\onContentPrepare(), PlgUserProfile\onContentPrepareForm(), SMTP\parseHelloFields(), Form\postProcess(), PlgContentFields\prepare(), NewsfeedModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), Nested\rebuildPath(), Form\renderFieldset(), Form\setField(), PgsqlDriver\updateObject(), DatabaseDriver\updateObject(), ConfigurationModel\updateUserIds(), UuidFactory\uuid(), UuidFactory\uuidFromHashedName(), et Form\validate().

◆ $form

$form = $displayData->getForm()

◆ $hiddenFields

$hiddenFields = $displayData->get('hidden_fields') ?: array()

◆ $html [1/2]

if (! $saveHistory) $html = array()

◆ $html [2/2]

foreach ( $fields as $field) $html[] = '<fieldset><ul class="list-unstyled">'

◆ $input

$input = $app->input

◆ $saveHistory

if ( $component=='com_categories') $saveHistory = ComponentHelper::getParams($component)->get('save_history', 0)


Joomla CMS: Référence du fichier edit_modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • item
Espaces de nommage | Variables
Référence du fichier tmpl/item/edit_modules.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this | fields = array('toggle_modules_assigned','toggle_modules_published')
foreach( $this->modules as $i=> & $module)(is_null( $module->menuid))(! $module->except|| $module->menuid< 0) | else
endif
else __pad0__
else __pad1__
else __pad2__
else __pad3__
endforeach

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad0__

else __pad0__

◆ __pad1__

else __pad1__

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ else

if ( $module->published) else

◆ endforeach

endforeach

◆ endif

endif

◆ fields

$this fields = array('toggle_modules_assigned','toggle_modules_published')


Joomla CMS: Référence du fichier editor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • editor
Structures de données | Espaces de nommage
Référence du fichier editor.php

Structures de données

class PlgFieldsEditor

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier editor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • editor
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/editor.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if ( $value=='')

Documentation des variables

◆ $value

$value = $field->value

◆ if

if($value=='')


Joomla CMS: Référence du fichier Editor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Editor
Structures de données | Espaces de nommage
Référence du fichier Editor.php

Structures de données

class Editor

Espaces de nommage

Joomla\CMS\Editor


Joomla CMS: Référence du fichier EditorField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier EditorField.php

Structures de données

class EditorField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier El.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Language
Structures de données | Espaces de nommage
Référence du fichier El.php

Structures de données

class El

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer\Language


Joomla CMS: Référence du fichier element.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • layouts
  • editors
  • codemirror
Espaces de nommage | Variables
Référence du fichier element.php

Espaces de nommage

Joomla\Plugin

Variables

$options = $displayData->options
$params = $displayData->params
$name = $displayData->name
$id = $displayData->id
$cols = $displayData->cols
$rows = $displayData->rows
$content = $displayData->content
$extJS = JDEBUG ? '.js' : '.min.js'
$modifier = $params->get('fullScreenMod', array()) ? implode(' + ', $params->get('fullScreenMod', array())) . ' + ' : ''
$basePath = $displayData->basePath
$modePath = $displayData->modePath
$modPath = 'mod-path="' . Uri::root() . $modePath . $extJS . '"'
$fskeys = $params->get('fullScreenMod', array())
$fskeys [] = $params->get('fullScreen', 'F10')
$fullScreenCombo = implode('-', $fskeys)
$fsCombo = 'fs-combo=' . json_encode($fullScreenCombo)
$option = 'options=\'' . json_encode($options) . '\''
$mediaVersion = Factory::getDocument()->getMediaVersion()
$editor = 'editor="' . ltrim(HTMLHelper::_('script', $basePath . 'lib/codemirror' . $extJS, ['version' => 'auto', 'pathOnly' => true]), '/') . '?' . $mediaVersion . '"'
$addons = 'addons="' . ltrim(HTMLHelper::_('script', $basePath . 'lib/addons' . $extJS, ['version' => 'auto', 'pathOnly' => true]), '/') . '?' . $mediaVersion . '"'

Documentation des variables

◆ $addons

$addons = 'addons="' . ltrim(HTMLHelper::_('script', $basePath . 'lib/addons' . $extJS, ['version' => 'auto', 'pathOnly' => true]), '/') . '?' . $mediaVersion . '"'

◆ $basePath

$basePath = $displayData->basePath

Référencé par FileLayout\__construct(), JavascriptRenderer\__construct(), JavascriptRenderer\addAssets(), Path\check(), LanguageHelper\createLanguageList(), LayoutHelper\debug(), LanguageAdapter\discover(), LanguageHelper\exists(), DatabaseModel\fetchSchemaCache(), JavascriptRenderer\getAssets(), JavascriptRenderer\getBasePath(), MessagesModel\getExtensionName(), LocalAdapter\getFile(), LocalAdapter\getFiles(), BaseController\getInstance(), DebugBar\getJavascriptRenderer(), LanguageHelper\getKnownLanguages(), LanguageHelper\getLanguagePath(), JavascriptRenderer\getRelativeRoot(), LanguageAdapter\install(), Language\load(), CMSPlugin\loadLanguage(), TemplateAdapter\loadLanguage(), PluginAdapter\prepareDiscoverInstall(), ModulesModel\preprocessForm(), LayoutHelper\render(), ModuleHelper\renderModule(), TemplateAdapter\setupInstallPaths(), ModuleAdapter\setupInstallPaths(), FileLayout\sublayout(), et LanguageAdapter\update().

◆ $cols

$cols = $displayData->cols

Référencé par SqlsrvQuery\group().

◆ $content

$content = $displayData->content

◆ $editor

$editor = 'editor="' . ltrim(HTMLHelper::_('script', $basePath . 'lib/codemirror' . $extJS, ['version' => 'auto', 'pathOnly' => true]), '/') . '?' . $mediaVersion . '"'

◆ $extJS

$extJS = JDEBUG ? '.js' : '.min.js'

◆ $fsCombo

$fsCombo = 'fs-combo=' . json_encode($fullScreenCombo)

◆ $fskeys [1/2]

$fskeys = $params->get('fullScreenMod', array())

◆ $fskeys [2/2]

$fskeys[] = $params->get('fullScreen', 'F10')

◆ $fullScreenCombo

$fullScreenCombo = implode('-', $fskeys)

◆ $id

$id = $displayData->id

◆ $mediaVersion

$mediaVersion = Factory::getDocument()->getMediaVersion()

Référencé par Version\getMediaVersion(), et Version\setMediaVersion().

◆ $modePath

$modePath = $displayData->modePath

◆ $modifier

$modifier = $params->get('fullScreenMod', array()) ? implode(' + ', $params->get('fullScreenMod', array())) . ' + ' : ''

Référencé par Query\processString().

◆ $modPath

$modPath = 'mod-path="' . Uri::root() . $modePath . $extJS . '"'

◆ $name

$name = $displayData->name

◆ $option

$option = 'options=\'' . json_encode($options) . '\''

◆ $options

$options = $displayData->options

◆ $params

$params = $displayData->params

◆ $rows

$rows = $displayData->rows

Référencé par ChangeSet\__construct(), Nested\_logtable(), RegistrationModel\activate(), DatabaseExporter\buildXmlData(), ChangeItem\check(), JoomlaInstallerScript\convertTablesToUtf8mb4(), CliDescriptor\describe(), FeedView\display(), ModuleModel\duplicate(), FieldModel\getFieldValues(), ConfigModel\getItem(), TextareaField\getLayoutData(), StatsHelper\getList(), ArticlesArchiveHelper\getList(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), StatsAdminHelper\getStats(), SqliteDriver\getTableKeys(), SymfonyStyle\horizontalTable(), DatabaseImporter\importData(), ActionlogsHelper\loadActionLogPluginsLanguage(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgFieldsSubform\onCustomFieldsPrepareField(), RegistrationModel\register(), MailModel\send(), SSH2\setWindowSize(), SymfonyStyle\table(), et Finder\typeslist().


Joomla CMS: Référence du fichier Element.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier Element.php

Structures de données

class Element

Espaces de nommage

ASN1
phpseclib3\File\ASN1


Joomla CMS: Référence du fichier ElementInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier ElementInterface.php

Structures de données

interface ElementInterface

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier Email.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier libraries/src/HTML/Helpers/Email.php

Structures de données

class Email

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Email.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/email/src/Extension/Email.php

Structures de données

class Email

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Email\Extension


Joomla CMS: Référence du fichier email.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier email.php

Espaces de nommage

Joomla\Site

Variables

$attributes

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= [
'type="email"',
'inputmode="email"',
'name="' . $name . '"',
'class="form-control validate-email' . (!empty($class) ? ' ' . $class : '') . '"',
'id="' . $id . '"',
'value="' . htmlspecialchars(PunycodeHelper::emailToUTF8($value), ENT_COMPAT, 'UTF-8') . '"',
$spellcheck ? '' : 'spellcheck="false"',
!empty($size) ? 'size="' . $size . '"' : '',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
$onchange ? 'onchange="' . $onchange . '"' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$multiple ? 'multiple' : '',
!empty($maxLength) ? 'maxlength="' . $maxLength . '"' : '',
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
$required ? 'required' : '',
$autofocus ? 'autofocus' : '',
$dataAttribute,
]
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$value
$value
Definition: com_contact/layouts/field/render.php:21
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$size
$size
Definition: slider.php:67
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17


Joomla CMS: Référence du fichier emailcloak.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • emailcloak
Structures de données | Espaces de nommage
Référence du fichier emailcloak.php

Structures de données

class PlgContentEmailcloak

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier EmailField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier EmailField.php

Structures de données

class EmailField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier EmailRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier EmailRule.php

Structures de données

class EmailRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier Emboss.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Emboss.php

Structures de données

class Emboss

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier emoji.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier emoji.php

Variables

return ['CHARACTER_GRINNING_FACE'=> "\1F600}", 'CHARACTER_BEAMING_FACE_WITH_SMILING_EYES'=> "\1F601}", 'CHARACTER_FACE_WITH_TEARS_OF_JOY'=> "\1F602}", 'CHARACTER_ROLLING_ON_THE_FLOOR_LAUGHING'=> "\1F923}", 'CHARACTER_GRINNING_FACE_WITH_BIG_EYES'=> "\1F603}", 'CHARACTER_GRINNING_FACE_WITH_SMILING_EYES'=> "\1F604}", 'CHARACTER_GRINNING_FACE_WITH_SWEAT'=> "\1F605}", 'CHARACTER_GRINNING_SQUINTING_FACE'=> "\1F606}", 'CHARACTER_WINKING_FACE'=> "\1F609}", 'CHARACTER_SMILING_FACE_WITH_SMILING_EYES'=> "\1F60A}", 'CHARACTER_FACE_SAVORING_FOOD'=> "\1F60B}", 'CHARACTER_SMILING_FACE_WITH_SUNGLASSES'=> "\1F60E}", 'CHARACTER_SMILING_FACE_WITH_HEART_EYES'=> "\1F60D}", 'CHARACTER_FACE_BLOWING_A_KISS'=> "\1F618}", 'CHARACTER_SMILING_FACE_WITH_3_HEARTS'=> "\1F970}", 'CHARACTER_KISSING_FACE'=> "\1F617}", 'CHARACTER_KISSING_FACE_WITH_SMILING_EYES'=> "\1F619}", 'CHARACTER_KISSING_FACE_WITH_CLOSED_EYES'=> "\1F61A}", 'CHARACTER_SMILING_FACE'=> "\263A}\FE0F}", 'CHARACTER_SLIGHTLY_SMILING_FACE'=> "\1F642}", 'CHARACTER_HUGGING_FACE'=> "\1F917}", 'CHARACTER_STAR_STRUCK'=> "\1F929}", 'CHARACTER_THINKING_FACE'=> "\1F914}", 'CHARACTER_FACE_WITH_RAISED_EYEBROW'=> "\1F928}", 'CHARACTER_NEUTRAL_FACE'=> "\1F610}", 'CHARACTER_EXPRESSIONLESS_FACE'=> "\1F611}", 'CHARACTER_FACE_WITHOUT_MOUTH'=> "\1F636}", 'CHARACTER_FACE_WITH_ROLLING_EYES'=> "\1F644}", 'CHARACTER_SMIRKING_FACE'=> "\1F60F}", 'CHARACTER_PERSEVERING_FACE'=> "\1F623}", 'CHARACTER_SAD_BUT_RELIEVED_FACE'=> "\1F625}", 'CHARACTER_FACE_WITH_OPEN_MOUTH'=> "\1F62E}", 'CHARACTER_ZIPPER_MOUTH_FACE'=> "\1F910}", 'CHARACTER_HUSHED_FACE'=> "\1F62F}", 'CHARACTER_SLEEPY_FACE'=> "\1F62A}", 'CHARACTER_TIRED_FACE'=> "\1F62B}", 'CHARACTER_SLEEPING_FACE'=> "\1F634}", 'CHARACTER_RELIEVED_FACE'=> "\1F60C}", 'CHARACTER_FACE_WITH_TONGUE'=> "\1F61B}", 'CHARACTER_WINKING_FACE_WITH_TONGUE'=> "\1F61C}", 'CHARACTER_SQUINTING_FACE_WITH_TONGUE'=> "\1F61D}", 'CHARACTER_DROOLING_FACE'=> "\1F924}", 'CHARACTER_UNAMUSED_FACE'=> "\1F612}", 'CHARACTER_DOWNCAST_FACE_WITH_SWEAT'=> "\1F613}", 'CHARACTER_PENSIVE_FACE'=> "\1F614}", 'CHARACTER_CONFUSED_FACE'=> "\1F615}", 'CHARACTER_UPSIDE_DOWN_FACE'=> "\1F643}", 'CHARACTER_MONEY_MOUTH_FACE'=> "\1F911}", 'CHARACTER_ASTONISHED_FACE'=> "\1F632}", 'CHARACTER_FROWNING_FACE'=> "\2639}\FE0F}", 'CHARACTER_SLIGHTLY_FROWNING_FACE'=> "\1F641}", 'CHARACTER_CONFOUNDED_FACE'=> "\1F616}", 'CHARACTER_DISAPPOINTED_FACE'=> "\1F61E}", 'CHARACTER_WORRIED_FACE'=> "\1F61F}", 'CHARACTER_FACE_WITH_STEAM_FROM_NOSE'=> "\1F624}", 'CHARACTER_CRYING_FACE'=> "\1F622}", 'CHARACTER_LOUDLY_CRYING_FACE'=> "\1F62D}", 'CHARACTER_FROWNING_FACE_WITH_OPEN_MOUTH'=> "\1F626}", 'CHARACTER_ANGUISHED_FACE'=> "\1F627}", 'CHARACTER_FEARFUL_FACE'=> "\1F628}", 'CHARACTER_WEARY_FACE'=> "\1F629}", 'CHARACTER_EXPLODING_HEAD'=> "\1F92F}", 'CHARACTER_GRIMACING_FACE'=> "\1F62C}", 'CHARACTER_ANXIOUS_FACE_WITH_SWEAT'=> "\1F630}", 'CHARACTER_FACE_SCREAMING_IN_FEAR'=> "\1F631}", 'CHARACTER_HOT_FACE'=> "\1F975}", 'CHARACTER_COLD_FACE'=> "\1F976}", 'CHARACTER_FLUSHED_FACE'=> "\1F633}", 'CHARACTER_ZANY_FACE'=> "\1F92A}", 'CHARACTER_DIZZY_FACE'=> "\1F635}", 'CHARACTER_POUTING_FACE'=> "\1F621}", 'CHARACTER_ANGRY_FACE'=> "\1F620}", 'CHARACTER_FACE_WITH_SYMBOLS_ON_MOUTH'=> "\1F92C}", 'CHARACTER_FACE_WITH_MEDICAL_MASK'=> "\1F637}", 'CHARACTER_FACE_WITH_THERMOMETER'=> "\1F912}", 'CHARACTER_FACE_WITH_HEAD_BANDAGE'=> "\1F915}", 'CHARACTER_NAUSEATED_FACE'=> "\1F922}", 'CHARACTER_FACE_VOMITING'=> "\1F92E}", 'CHARACTER_SNEEZING_FACE'=> "\1F927}", 'CHARACTER_SMILING_FACE_WITH_HALO'=> "\1F607}", 'CHARACTER_COWBOY_HAT_FACE'=> "\1F920}", 'CHARACTER_PARTYING_FACE'=> "\1F973}", 'CHARACTER_WOOZY_FACE'=> "\1F974}", 'CHARACTER_PLEADING_FACE'=> "\1F97A}", 'CHARACTER_LYING_FACE'=> "\1F925}", 'CHARACTER_SHUSHING_FACE'=> "\1F92B}", 'CHARACTER_FACE_WITH_HAND_OVER_MOUTH'=> "\1F92D}", 'CHARACTER_FACE_WITH_MONOCLE'=> "\1F9D0}", 'CHARACTER_NERD_FACE'=> "\1F913}", 'CHARACTER_SMILING_FACE_WITH_HORNS'=> "\1F608}", 'CHARACTER_ANGRY_FACE_WITH_HORNS'=> "\1F47F}", 'CHARACTER_CLOWN_FACE'=> "\1F921}", 'CHARACTER_OGRE'=> "\1F479}", 'CHARACTER_GOBLIN'=> "\1F47A}", 'CHARACTER_SKULL'=> "\1F480}", 'CHARACTER_SKULL_AND_CROSSBONES'=> "\2620}\FE0F}", 'CHARACTER_GHOST'=> "\1F47B}", 'CHARACTER_ALIEN'=> "\1F47D}", 'CHARACTER_ALIEN_MONSTER'=> "\1F47E}", 'CHARACTER_ROBOT_FACE'=> "\1F916}", 'CHARACTER_PILE_OF_POO'=> "\1F4A9}", 'CHARACTER_GRINNING_CAT_FACE'=> "\1F63A}", 'CHARACTER_GRINNING_CAT_FACE_WITH_SMILING_EYES'=> "\1F638}", 'CHARACTER_CAT_FACE_WITH_TEARS_OF_JOY'=> "\1F639}", 'CHARACTER_SMILING_CAT_FACE_WITH_HEART_EYES'=> "\1F63B}", 'CHARACTER_CAT_FACE_WITH_WRY_SMILE'=> "\1F63C}", 'CHARACTER_KISSING_CAT_FACE'=> "\1F63D}", 'CHARACTER_WEARY_CAT_FACE'=> "\1F640}", 'CHARACTER_CRYING_CAT_FACE'=> "\1F63F}", 'CHARACTER_POUTING_CAT_FACE'=> "\1F63E}", 'CHARACTER_SEE_NO_EVIL_MONKEY'=> "\1F648}", 'CHARACTER_HEAR_NO_EVIL_MONKEY'=> "\1F649}", 'CHARACTER_SPEAK_NO_EVIL_MONKEY'=> "\1F64A}", 'CHARACTER_LIGHT_SKIN_TONE'=> "\1F3FB}", 'CHARACTER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3FC}", 'CHARACTER_MEDIUM_SKIN_TONE'=> "\1F3FD}", 'CHARACTER_MEDIUM_DARK_SKIN_TONE'=> "\1F3FE}", 'CHARACTER_DARK_SKIN_TONE'=> "\1F3FF}", 'CHARACTER_BABY'=> "\1F476}", 'CHARACTER_BABY_LIGHT_SKIN_TONE'=> "\1F476}\1F3FB}", 'CHARACTER_BABY_MEDIUM_LIGHT_SKIN_TONE'=> "\1F476}\1F3FC}", 'CHARACTER_BABY_MEDIUM_SKIN_TONE'=> "\1F476}\1F3FD}", 'CHARACTER_BABY_MEDIUM_DARK_SKIN_TONE'=> "\1F476}\1F3FE}", 'CHARACTER_BABY_DARK_SKIN_TONE'=> "\1F476}\1F3FF}", 'CHARACTER_CHILD'=> "\1F9D2}", 'CHARACTER_CHILD_LIGHT_SKIN_TONE'=> "\1F9D2}\1F3FB}", 'CHARACTER_CHILD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D2}\1F3FC}", 'CHARACTER_CHILD_MEDIUM_SKIN_TONE'=> "\1F9D2}\1F3FD}", 'CHARACTER_CHILD_MEDIUM_DARK_SKIN_TONE'=> "\1F9D2}\1F3FE}", 'CHARACTER_CHILD_DARK_SKIN_TONE'=> "\1F9D2}\1F3FF}", 'CHARACTER_BOY'=> "\1F466}", 'CHARACTER_BOY_LIGHT_SKIN_TONE'=> "\1F466}\1F3FB}", 'CHARACTER_BOY_MEDIUM_LIGHT_SKIN_TONE'=> "\1F466}\1F3FC}", 'CHARACTER_BOY_MEDIUM_SKIN_TONE'=> "\1F466}\1F3FD}", 'CHARACTER_BOY_MEDIUM_DARK_SKIN_TONE'=> "\1F466}\1F3FE}", 'CHARACTER_BOY_DARK_SKIN_TONE'=> "\1F466}\1F3FF}", 'CHARACTER_GIRL'=> "\1F467}", 'CHARACTER_GIRL_LIGHT_SKIN_TONE'=> "\1F467}\1F3FB}", 'CHARACTER_GIRL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F467}\1F3FC}", 'CHARACTER_GIRL_MEDIUM_SKIN_TONE'=> "\1F467}\1F3FD}", 'CHARACTER_GIRL_MEDIUM_DARK_SKIN_TONE'=> "\1F467}\1F3FE}", 'CHARACTER_GIRL_DARK_SKIN_TONE'=> "\1F467}\1F3FF}", 'CHARACTER_ADULT'=> "\1F9D1}", 'CHARACTER_ADULT_LIGHT_SKIN_TONE'=> "\1F9D1}\1F3FB}", 'CHARACTER_ADULT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D1}\1F3FC}", 'CHARACTER_ADULT_MEDIUM_SKIN_TONE'=> "\1F9D1}\1F3FD}", 'CHARACTER_ADULT_MEDIUM_DARK_SKIN_TONE'=> "\1F9D1}\1F3FE}", 'CHARACTER_ADULT_DARK_SKIN_TONE'=> "\1F9D1}\1F3FF}", 'CHARACTER_MAN'=> "\1F468}", 'CHARACTER_MAN_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}", 'CHARACTER_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}", 'CHARACTER_MAN_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}", 'CHARACTER_MAN_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}", 'CHARACTER_MAN_DARK_SKIN_TONE'=> "\1F468}\1F3FF}", 'CHARACTER_WOMAN'=> "\1F469}", 'CHARACTER_WOMAN_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}", 'CHARACTER_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}", 'CHARACTER_WOMAN_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}", 'CHARACTER_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}", 'CHARACTER_WOMAN_DARK_SKIN_TONE'=> "\1F469}\1F3FF}", 'CHARACTER_OLDER_ADULT'=> "\1F9D3}", 'CHARACTER_OLDER_ADULT_LIGHT_SKIN_TONE'=> "\1F9D3}\1F3FB}", 'CHARACTER_OLDER_ADULT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D3}\1F3FC}", 'CHARACTER_OLDER_ADULT_MEDIUM_SKIN_TONE'=> "\1F9D3}\1F3FD}", 'CHARACTER_OLDER_ADULT_MEDIUM_DARK_SKIN_TONE'=> "\1F9D3}\1F3FE}", 'CHARACTER_OLDER_ADULT_DARK_SKIN_TONE'=> "\1F9D3}\1F3FF}", 'CHARACTER_OLD_MAN'=> "\1F474}", 'CHARACTER_OLD_MAN_LIGHT_SKIN_TONE'=> "\1F474}\1F3FB}", 'CHARACTER_OLD_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F474}\1F3FC}", 'CHARACTER_OLD_MAN_MEDIUM_SKIN_TONE'=> "\1F474}\1F3FD}", 'CHARACTER_OLD_MAN_MEDIUM_DARK_SKIN_TONE'=> "\1F474}\1F3FE}", 'CHARACTER_OLD_MAN_DARK_SKIN_TONE'=> "\1F474}\1F3FF}", 'CHARACTER_OLD_WOMAN'=> "\1F475}", 'CHARACTER_OLD_WOMAN_LIGHT_SKIN_TONE'=> "\1F475}\1F3FB}", 'CHARACTER_OLD_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F475}\1F3FC}", 'CHARACTER_OLD_WOMAN_MEDIUM_SKIN_TONE'=> "\1F475}\1F3FD}", 'CHARACTER_OLD_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\1F475}\1F3FE}", 'CHARACTER_OLD_WOMAN_DARK_SKIN_TONE'=> "\1F475}\1F3FF}", 'CHARACTER_MAN_HEALTH_WORKER'=> "\1F468}\200D}\2695}\FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\2695}\FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\2695}\FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\2695}\FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\2695}\FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER'=> "\1F469}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\2695}\FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\2695}\FE0F}", 'CHARACTER_MAN_STUDENT'=> "\1F468}\200D}\1F393}", 'CHARACTER_MAN_STUDENT_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F393}", 'CHARACTER_MAN_STUDENT_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT'=> "\1F469}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F393}", 'CHARACTER_WOMAN_STUDENT_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F393}", 'CHARACTER_MAN_TEACHER'=> "\1F468}\200D}\1F3EB}", 'CHARACTER_MAN_TEACHER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F3EB}", 'CHARACTER_MAN_TEACHER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER'=> "\1F469}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F3EB}", 'CHARACTER_WOMAN_TEACHER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F3EB}", 'CHARACTER_MAN_JUDGE'=> "\1F468}\200D}\2696}\FE0F}", 'CHARACTER_MAN_JUDGE_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\2696}\FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\2696}\FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\2696}\FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\2696}\FE0F}", 'CHARACTER_MAN_JUDGE_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE'=> "\1F469}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\2696}\FE0F}", 'CHARACTER_WOMAN_JUDGE_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\2696}\FE0F}", 'CHARACTER_MAN_FARMER'=> "\1F468}\200D}\1F33E}", 'CHARACTER_MAN_FARMER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F33E}", 'CHARACTER_MAN_FARMER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER'=> "\1F469}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F33E}", 'CHARACTER_WOMAN_FARMER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F33E}", 'CHARACTER_MAN_COOK'=> "\1F468}\200D}\1F373}", 'CHARACTER_MAN_COOK_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F373}", 'CHARACTER_MAN_COOK_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F373}", 'CHARACTER_MAN_COOK_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F373}", 'CHARACTER_MAN_COOK_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F373}", 'CHARACTER_MAN_COOK_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F373}", 'CHARACTER_WOMAN_COOK'=> "\1F469}\200D}\1F373}", 'CHARACTER_WOMAN_COOK_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F373}", 'CHARACTER_WOMAN_COOK_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F373}", 'CHARACTER_MAN_MECHANIC'=> "\1F468}\200D}\1F527}", 'CHARACTER_MAN_MECHANIC_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F527}", 'CHARACTER_MAN_MECHANIC_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC'=> "\1F469}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F527}", 'CHARACTER_WOMAN_MECHANIC_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F527}", 'CHARACTER_MAN_FACTORY_WORKER'=> "\1F468}\200D}\1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER'=> "\1F469}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F3ED}", 'CHARACTER_MAN_OFFICE_WORKER'=> "\1F468}\200D}\1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER'=> "\1F469}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F4BC}", 'CHARACTER_MAN_SCIENTIST'=> "\1F468}\200D}\1F52C}", 'CHARACTER_MAN_SCIENTIST_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F52C}", 'CHARACTER_MAN_SCIENTIST_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST'=> "\1F469}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F52C}", 'CHARACTER_WOMAN_SCIENTIST_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F52C}", 'CHARACTER_MAN_TECHNOLOGIST'=> "\1F468}\200D}\1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST'=> "\1F469}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F4BB}", 'CHARACTER_MAN_SINGER'=> "\1F468}\200D}\1F3A4}", 'CHARACTER_MAN_SINGER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F3A4}", 'CHARACTER_MAN_SINGER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER'=> "\1F469}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F3A4}", 'CHARACTER_WOMAN_SINGER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F3A4}", 'CHARACTER_MAN_ARTIST'=> "\1F468}\200D}\1F3A8}", 'CHARACTER_MAN_ARTIST_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F3A8}", 'CHARACTER_MAN_ARTIST_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST'=> "\1F469}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F3A8}", 'CHARACTER_WOMAN_ARTIST_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F3A8}", 'CHARACTER_MAN_PILOT'=> "\1F468}\200D}\2708}\FE0F}", 'CHARACTER_MAN_PILOT_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\2708}\FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\2708}\FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\2708}\FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\2708}\FE0F}", 'CHARACTER_MAN_PILOT_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT'=> "\1F469}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\2708}\FE0F}", 'CHARACTER_WOMAN_PILOT_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\2708}\FE0F}", 'CHARACTER_MAN_ASTRONAUT'=> "\1F468}\200D}\1F680}", 'CHARACTER_MAN_ASTRONAUT_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F680}", 'CHARACTER_MAN_ASTRONAUT_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT'=> "\1F469}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F680}", 'CHARACTER_WOMAN_ASTRONAUT_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F680}", 'CHARACTER_MAN_FIREFIGHTER'=> "\1F468}\200D}\1F692}", 'CHARACTER_MAN_FIREFIGHTER_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F692}", 'CHARACTER_MAN_FIREFIGHTER_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER'=> "\1F469}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F692}", 'CHARACTER_POLICE_OFFICER'=> "\1F46E}", 'CHARACTER_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FB}", 'CHARACTER_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FC}", 'CHARACTER_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\1F46E}\1F3FD}", 'CHARACTER_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\1F46E}\1F3FE}", 'CHARACTER_POLICE_OFFICER_DARK_SKIN_TONE'=> "\1F46E}\1F3FF}", 'CHARACTER_MAN_POLICE_OFFICER'=> "\1F46E}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\1F46E}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\1F46E}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_DARK_SKIN_TONE'=> "\1F46E}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER'=> "\1F46E}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F46E}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\1F46E}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\1F46E}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_DARK_SKIN_TONE'=> "\1F46E}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_DETECTIVE'=> "\1F575}\FE0F}", 'CHARACTER_DETECTIVE_LIGHT_SKIN_TONE'=> "\1F575}\1F3FB}", 'CHARACTER_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F575}\1F3FC}", 'CHARACTER_DETECTIVE_MEDIUM_SKIN_TONE'=> "\1F575}\1F3FD}", 'CHARACTER_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\1F575}\1F3FE}", 'CHARACTER_DETECTIVE_DARK_SKIN_TONE'=> "\1F575}\1F3FF}", 'CHARACTER_MAN_DETECTIVE'=> "\1F575}\FE0F}\200D}\2642}\FE0F}", 'CHARACTER_MAN_DETECTIVE_LIGHT_SKIN_TONE'=> "\1F575}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F575}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_SKIN_TONE'=> "\1F575}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\1F575}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_DETECTIVE_DARK_SKIN_TONE'=> "\1F575}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE'=> "\1F575}\FE0F}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE_LIGHT_SKIN_TONE'=> "\1F575}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F575}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_SKIN_TONE'=> "\1F575}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\1F575}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DETECTIVE_DARK_SKIN_TONE'=> "\1F575}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_GUARD'=> "\1F482}", 'CHARACTER_GUARD_LIGHT_SKIN_TONE'=> "\1F482}\1F3FB}", 'CHARACTER_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F482}\1F3FC}", 'CHARACTER_GUARD_MEDIUM_SKIN_TONE'=> "\1F482}\1F3FD}", 'CHARACTER_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\1F482}\1F3FE}", 'CHARACTER_GUARD_DARK_SKIN_TONE'=> "\1F482}\1F3FF}", 'CHARACTER_MAN_GUARD'=> "\1F482}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GUARD_LIGHT_SKIN_TONE'=> "\1F482}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F482}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_SKIN_TONE'=> "\1F482}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\1F482}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GUARD_DARK_SKIN_TONE'=> "\1F482}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GUARD'=> "\1F482}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GUARD_LIGHT_SKIN_TONE'=> "\1F482}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F482}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_SKIN_TONE'=> "\1F482}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\1F482}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GUARD_DARK_SKIN_TONE'=> "\1F482}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_CONSTRUCTION_WORKER'=> "\1F477}", 'CHARACTER_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\1F477}\1F3FB}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F477}\1F3FC}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\1F477}\1F3FD}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F477}\1F3FE}", 'CHARACTER_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\1F477}\1F3FF}", 'CHARACTER_MAN_CONSTRUCTION_WORKER'=> "\1F477}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\1F477}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F477}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\1F477}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F477}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\1F477}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER'=> "\1F477}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\1F477}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F477}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\1F477}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\1F477}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\1F477}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PRINCE'=> "\1F934}", 'CHARACTER_PRINCE_LIGHT_SKIN_TONE'=> "\1F934}\1F3FB}", 'CHARACTER_PRINCE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F934}\1F3FC}", 'CHARACTER_PRINCE_MEDIUM_SKIN_TONE'=> "\1F934}\1F3FD}", 'CHARACTER_PRINCE_MEDIUM_DARK_SKIN_TONE'=> "\1F934}\1F3FE}", 'CHARACTER_PRINCE_DARK_SKIN_TONE'=> "\1F934}\1F3FF}", 'CHARACTER_PRINCESS'=> "\1F478}", 'CHARACTER_PRINCESS_LIGHT_SKIN_TONE'=> "\1F478}\1F3FB}", 'CHARACTER_PRINCESS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F478}\1F3FC}", 'CHARACTER_PRINCESS_MEDIUM_SKIN_TONE'=> "\1F478}\1F3FD}", 'CHARACTER_PRINCESS_MEDIUM_DARK_SKIN_TONE'=> "\1F478}\1F3FE}", 'CHARACTER_PRINCESS_DARK_SKIN_TONE'=> "\1F478}\1F3FF}", 'CHARACTER_PERSON_WEARING_TURBAN'=> "\1F473}", 'CHARACTER_PERSON_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\1F473}\1F3FB}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F473}\1F3FC}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\1F473}\1F3FD}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\1F473}\1F3FE}", 'CHARACTER_PERSON_WEARING_TURBAN_DARK_SKIN_TONE'=> "\1F473}\1F3FF}", 'CHARACTER_MAN_WEARING_TURBAN'=> "\1F473}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\1F473}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F473}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\1F473}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\1F473}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_DARK_SKIN_TONE'=> "\1F473}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN'=> "\1F473}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\1F473}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F473}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\1F473}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\1F473}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_DARK_SKIN_TONE'=> "\1F473}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_WITH_CHINESE_CAP'=> "\1F472}", 'CHARACTER_MAN_WITH_CHINESE_CAP_LIGHT_SKIN_TONE'=> "\1F472}\1F3FB}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_LIGHT_SKIN_TONE'=> "\1F472}\1F3FC}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_SKIN_TONE'=> "\1F472}\1F3FD}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_DARK_SKIN_TONE'=> "\1F472}\1F3FE}", 'CHARACTER_MAN_WITH_CHINESE_CAP_DARK_SKIN_TONE'=> "\1F472}\1F3FF}", 'CHARACTER_WOMAN_WITH_HEADSCARF'=> "\1F9D5}", 'CHARACTER_WOMAN_WITH_HEADSCARF_LIGHT_SKIN_TONE'=> "\1F9D5}\1F3FB}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D5}\1F3FC}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_SKIN_TONE'=> "\1F9D5}\1F3FD}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_DARK_SKIN_TONE'=> "\1F9D5}\1F3FE}", 'CHARACTER_WOMAN_WITH_HEADSCARF_DARK_SKIN_TONE'=> "\1F9D5}\1F3FF}", 'CHARACTER_BEARDED_PERSON'=> "\1F9D4}", 'CHARACTER_BEARDED_PERSON_LIGHT_SKIN_TONE'=> "\1F9D4}\1F3FB}", 'CHARACTER_BEARDED_PERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D4}\1F3FC}", 'CHARACTER_BEARDED_PERSON_MEDIUM_SKIN_TONE'=> "\1F9D4}\1F3FD}", 'CHARACTER_BEARDED_PERSON_MEDIUM_DARK_SKIN_TONE'=> "\1F9D4}\1F3FE}", 'CHARACTER_BEARDED_PERSON_DARK_SKIN_TONE'=> "\1F9D4}\1F3FF}", 'CHARACTER_BLOND_HAIRED_PERSON'=> "\1F471}", 'CHARACTER_BLOND_HAIRED_PERSON_LIGHT_SKIN_TONE'=> "\1F471}\1F3FB}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\1F471}\1F3FC}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_SKIN_TONE'=> "\1F471}\1F3FD}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_DARK_SKIN_TONE'=> "\1F471}\1F3FE}", 'CHARACTER_BLOND_HAIRED_PERSON_DARK_SKIN_TONE'=> "\1F471}\1F3FF}", 'CHARACTER_BLOND_HAIRED_MAN'=> "\1F471}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_LIGHT_SKIN_TONE'=> "\1F471}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F471}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_SKIN_TONE'=> "\1F471}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_DARK_SKIN_TONE'=> "\1F471}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_DARK_SKIN_TONE'=> "\1F471}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN'=> "\1F471}\200D}\2640}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_LIGHT_SKIN_TONE'=> "\1F471}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F471}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_SKIN_TONE'=> "\1F471}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\1F471}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_DARK_SKIN_TONE'=> "\1F471}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_RED_HAIRED'=> "\1F468}\200D}\1F9B0}", 'CHARACTER_MAN_RED_HAIRED_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F9B0}", 'CHARACTER_MAN_RED_HAIRED_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED'=> "\1F469}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F9B0}", 'CHARACTER_MAN_CURLY_HAIRED'=> "\1F468}\200D}\1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED'=> "\1F469}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F9B1}", 'CHARACTER_MAN_BALD'=> "\1F468}\200D}\1F9B2}", 'CHARACTER_MAN_BALD_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F9B2}", 'CHARACTER_MAN_BALD_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD'=> "\1F469}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F9B2}", 'CHARACTER_WOMAN_BALD_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F9B2}", 'CHARACTER_MAN_WHITE_HAIRED'=> "\1F468}\200D}\1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_LIGHT_SKIN_TONE'=> "\1F468}\1F3FB}\200D}\1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F468}\1F3FC}\200D}\1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_SKIN_TONE'=> "\1F468}\1F3FD}\200D}\1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F468}\1F3FE}\200D}\1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_DARK_SKIN_TONE'=> "\1F468}\1F3FF}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED'=> "\1F469}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_LIGHT_SKIN_TONE'=> "\1F469}\1F3FB}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F469}\1F3FC}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_SKIN_TONE'=> "\1F469}\1F3FD}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\1F469}\1F3FE}\200D}\1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_DARK_SKIN_TONE'=> "\1F469}\1F3FF}\200D}\1F9B3}", 'CHARACTER_MAN_IN_TUXEDO'=> "\1F935}", 'CHARACTER_MAN_IN_TUXEDO_LIGHT_SKIN_TONE'=> "\1F935}\1F3FB}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F935}\1F3FC}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_SKIN_TONE'=> "\1F935}\1F3FD}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_DARK_SKIN_TONE'=> "\1F935}\1F3FE}", 'CHARACTER_MAN_IN_TUXEDO_DARK_SKIN_TONE'=> "\1F935}\1F3FF}", 'CHARACTER_BRIDE_WITH_VEIL'=> "\1F470}", 'CHARACTER_BRIDE_WITH_VEIL_LIGHT_SKIN_TONE'=> "\1F470}\1F3FB}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F470}\1F3FC}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_SKIN_TONE'=> "\1F470}\1F3FD}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_DARK_SKIN_TONE'=> "\1F470}\1F3FE}", 'CHARACTER_BRIDE_WITH_VEIL_DARK_SKIN_TONE'=> "\1F470}\1F3FF}", 'CHARACTER_PREGNANT_WOMAN'=> "\1F930}", 'CHARACTER_PREGNANT_WOMAN_LIGHT_SKIN_TONE'=> "\1F930}\1F3FB}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F930}\1F3FC}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_SKIN_TONE'=> "\1F930}\1F3FD}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\1F930}\1F3FE}", 'CHARACTER_PREGNANT_WOMAN_DARK_SKIN_TONE'=> "\1F930}\1F3FF}", 'CHARACTER_BREAST_FEEDING'=> "\1F931}", 'CHARACTER_BREAST_FEEDING_LIGHT_SKIN_TONE'=> "\1F931}\1F3FB}", 'CHARACTER_BREAST_FEEDING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F931}\1F3FC}", 'CHARACTER_BREAST_FEEDING_MEDIUM_SKIN_TONE'=> "\1F931}\1F3FD}", 'CHARACTER_BREAST_FEEDING_MEDIUM_DARK_SKIN_TONE'=> "\1F931}\1F3FE}", 'CHARACTER_BREAST_FEEDING_DARK_SKIN_TONE'=> "\1F931}\1F3FF}", 'CHARACTER_BABY_ANGEL'=> "\1F47C}", 'CHARACTER_BABY_ANGEL_LIGHT_SKIN_TONE'=> "\1F47C}\1F3FB}", 'CHARACTER_BABY_ANGEL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F47C}\1F3FC}", 'CHARACTER_BABY_ANGEL_MEDIUM_SKIN_TONE'=> "\1F47C}\1F3FD}", 'CHARACTER_BABY_ANGEL_MEDIUM_DARK_SKIN_TONE'=> "\1F47C}\1F3FE}", 'CHARACTER_BABY_ANGEL_DARK_SKIN_TONE'=> "\1F47C}\1F3FF}", 'CHARACTER_SANTA_CLAUS'=> "\1F385}", 'CHARACTER_SANTA_CLAUS_LIGHT_SKIN_TONE'=> "\1F385}\1F3FB}", 'CHARACTER_SANTA_CLAUS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F385}\1F3FC}", 'CHARACTER_SANTA_CLAUS_MEDIUM_SKIN_TONE'=> "\1F385}\1F3FD}", 'CHARACTER_SANTA_CLAUS_MEDIUM_DARK_SKIN_TONE'=> "\1F385}\1F3FE}", 'CHARACTER_SANTA_CLAUS_DARK_SKIN_TONE'=> "\1F385}\1F3FF}", 'CHARACTER_MRS_CLAUS'=> "\1F936}", 'CHARACTER_MRS_CLAUS_LIGHT_SKIN_TONE'=> "\1F936}\1F3FB}", 'CHARACTER_MRS_CLAUS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F936}\1F3FC}", 'CHARACTER_MRS_CLAUS_MEDIUM_SKIN_TONE'=> "\1F936}\1F3FD}", 'CHARACTER_MRS_CLAUS_MEDIUM_DARK_SKIN_TONE'=> "\1F936}\1F3FE}", 'CHARACTER_MRS_CLAUS_DARK_SKIN_TONE'=> "\1F936}\1F3FF}", 'CHARACTER_SUPERHERO'=> "\1F9B8}", 'CHARACTER_SUPERHERO_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FB}", 'CHARACTER_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FC}", 'CHARACTER_SUPERHERO_MEDIUM_SKIN_TONE'=> "\1F9B8}\1F3FD}", 'CHARACTER_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\1F9B8}\1F3FE}", 'CHARACTER_SUPERHERO_DARK_SKIN_TONE'=> "\1F9B8}\1F3FF}", 'CHARACTER_WOMAN_SUPERHERO'=> "\1F9B8}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERHERO_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_SKIN_TONE'=> "\1F9B8}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\1F9B8}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERHERO_DARK_SKIN_TONE'=> "\1F9B8}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_SUPERHERO'=> "\1F9B8}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERHERO_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B8}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_SKIN_TONE'=> "\1F9B8}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\1F9B8}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERHERO_DARK_SKIN_TONE'=> "\1F9B8}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_SUPERVILLAIN'=> "\1F9B9}", 'CHARACTER_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FB}", 'CHARACTER_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FC}", 'CHARACTER_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\1F9B9}\1F3FD}", 'CHARACTER_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\1F9B9}\1F3FE}", 'CHARACTER_SUPERVILLAIN_DARK_SKIN_TONE'=> "\1F9B9}\1F3FF}", 'CHARACTER_WOMAN_SUPERVILLAIN'=> "\1F9B9}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\1F9B9}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\1F9B9}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_DARK_SKIN_TONE'=> "\1F9B9}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN'=> "\1F9B9}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B9}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\1F9B9}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\1F9B9}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_DARK_SKIN_TONE'=> "\1F9B9}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_MAGE'=> "\1F9D9}", 'CHARACTER_MAGE_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FB}", 'CHARACTER_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FC}", 'CHARACTER_MAGE_MEDIUM_SKIN_TONE'=> "\1F9D9}\1F3FD}", 'CHARACTER_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F9D9}\1F3FE}", 'CHARACTER_MAGE_DARK_SKIN_TONE'=> "\1F9D9}\1F3FF}", 'CHARACTER_WOMAN_MAGE'=> "\1F9D9}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MAGE_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_SKIN_TONE'=> "\1F9D9}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F9D9}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MAGE_DARK_SKIN_TONE'=> "\1F9D9}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_MAGE'=> "\1F9D9}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MAGE_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D9}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_SKIN_TONE'=> "\1F9D9}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F9D9}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MAGE_DARK_SKIN_TONE'=> "\1F9D9}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_FAIRY'=> "\1F9DA}", 'CHARACTER_FAIRY_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FB}", 'CHARACTER_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FC}", 'CHARACTER_FAIRY_MEDIUM_SKIN_TONE'=> "\1F9DA}\1F3FD}", 'CHARACTER_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\1F9DA}\1F3FE}", 'CHARACTER_FAIRY_DARK_SKIN_TONE'=> "\1F9DA}\1F3FF}", 'CHARACTER_WOMAN_FAIRY'=> "\1F9DA}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FAIRY_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_SKIN_TONE'=> "\1F9DA}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\1F9DA}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FAIRY_DARK_SKIN_TONE'=> "\1F9DA}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_FAIRY'=> "\1F9DA}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FAIRY_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DA}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_SKIN_TONE'=> "\1F9DA}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\1F9DA}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FAIRY_DARK_SKIN_TONE'=> "\1F9DA}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_VAMPIRE'=> "\1F9DB}", 'CHARACTER_VAMPIRE_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FB}", 'CHARACTER_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FC}", 'CHARACTER_VAMPIRE_MEDIUM_SKIN_TONE'=> "\1F9DB}\1F3FD}", 'CHARACTER_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\1F9DB}\1F3FE}", 'CHARACTER_VAMPIRE_DARK_SKIN_TONE'=> "\1F9DB}\1F3FF}", 'CHARACTER_WOMAN_VAMPIRE'=> "\1F9DB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_VAMPIRE_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_SKIN_TONE'=> "\1F9DB}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\1F9DB}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_VAMPIRE_DARK_SKIN_TONE'=> "\1F9DB}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_VAMPIRE'=> "\1F9DB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_VAMPIRE_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DB}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_SKIN_TONE'=> "\1F9DB}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\1F9DB}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_VAMPIRE_DARK_SKIN_TONE'=> "\1F9DB}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_MERPERSON'=> "\1F9DC}", 'CHARACTER_MERPERSON_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FB}", 'CHARACTER_MERPERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FC}", 'CHARACTER_MERPERSON_MEDIUM_SKIN_TONE'=> "\1F9DC}\1F3FD}", 'CHARACTER_MERPERSON_MEDIUM_DARK_SKIN_TONE'=> "\1F9DC}\1F3FE}", 'CHARACTER_MERPERSON_DARK_SKIN_TONE'=> "\1F9DC}\1F3FF}", 'CHARACTER_MERMAID'=> "\1F9DC}\200D}\2640}\FE0F}", 'CHARACTER_MERMAID_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_MERMAID_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_MERMAID_MEDIUM_SKIN_TONE'=> "\1F9DC}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_MERMAID_MEDIUM_DARK_SKIN_TONE'=> "\1F9DC}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_MERMAID_DARK_SKIN_TONE'=> "\1F9DC}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MERMAN'=> "\1F9DC}\200D}\2642}\FE0F}", 'CHARACTER_MERMAN_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MERMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DC}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MERMAN_MEDIUM_SKIN_TONE'=> "\1F9DC}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MERMAN_MEDIUM_DARK_SKIN_TONE'=> "\1F9DC}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MERMAN_DARK_SKIN_TONE'=> "\1F9DC}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_ELF'=> "\1F9DD}", 'CHARACTER_ELF_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FB}", 'CHARACTER_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FC}", 'CHARACTER_ELF_MEDIUM_SKIN_TONE'=> "\1F9DD}\1F3FD}", 'CHARACTER_ELF_MEDIUM_DARK_SKIN_TONE'=> "\1F9DD}\1F3FE}", 'CHARACTER_ELF_DARK_SKIN_TONE'=> "\1F9DD}\1F3FF}", 'CHARACTER_WOMAN_ELF'=> "\1F9DD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ELF_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_SKIN_TONE'=> "\1F9DD}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_DARK_SKIN_TONE'=> "\1F9DD}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ELF_DARK_SKIN_TONE'=> "\1F9DD}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_ELF'=> "\1F9DD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ELF_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9DD}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_SKIN_TONE'=> "\1F9DD}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_DARK_SKIN_TONE'=> "\1F9DD}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ELF_DARK_SKIN_TONE'=> "\1F9DD}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_GENIE'=> "\1F9DE}", 'CHARACTER_WOMAN_GENIE'=> "\1F9DE}\200D}\2640}\FE0F}", 'CHARACTER_MAN_GENIE'=> "\1F9DE}\200D}\2642}\FE0F}", 'CHARACTER_ZOMBIE'=> "\1F9DF}", 'CHARACTER_WOMAN_ZOMBIE'=> "\1F9DF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_ZOMBIE'=> "\1F9DF}\200D}\2642}\FE0F}", 'CHARACTER_PERSON_FROWNING'=> "\1F64D}", 'CHARACTER_PERSON_FROWNING_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FB}", 'CHARACTER_PERSON_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FC}", 'CHARACTER_PERSON_FROWNING_MEDIUM_SKIN_TONE'=> "\1F64D}\1F3FD}", 'CHARACTER_PERSON_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\1F64D}\1F3FE}", 'CHARACTER_PERSON_FROWNING_DARK_SKIN_TONE'=> "\1F64D}\1F3FF}", 'CHARACTER_MAN_FROWNING'=> "\1F64D}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FROWNING_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_SKIN_TONE'=> "\1F64D}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\1F64D}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FROWNING_DARK_SKIN_TONE'=> "\1F64D}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_FROWNING'=> "\1F64D}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FROWNING_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64D}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_SKIN_TONE'=> "\1F64D}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\1F64D}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FROWNING_DARK_SKIN_TONE'=> "\1F64D}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_POUTING'=> "\1F64E}", 'CHARACTER_PERSON_POUTING_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FB}", 'CHARACTER_PERSON_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FC}", 'CHARACTER_PERSON_POUTING_MEDIUM_SKIN_TONE'=> "\1F64E}\1F3FD}", 'CHARACTER_PERSON_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\1F64E}\1F3FE}", 'CHARACTER_PERSON_POUTING_DARK_SKIN_TONE'=> "\1F64E}\1F3FF}", 'CHARACTER_MAN_POUTING'=> "\1F64E}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POUTING_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_SKIN_TONE'=> "\1F64E}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\1F64E}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_POUTING_DARK_SKIN_TONE'=> "\1F64E}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_POUTING'=> "\1F64E}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POUTING_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64E}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_SKIN_TONE'=> "\1F64E}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\1F64E}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_POUTING_DARK_SKIN_TONE'=> "\1F64E}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_GESTURING_NO'=> "\1F645}", 'CHARACTER_PERSON_GESTURING_NO_LIGHT_SKIN_TONE'=> "\1F645}\1F3FB}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F645}\1F3FC}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\1F645}\1F3FD}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\1F645}\1F3FE}", 'CHARACTER_PERSON_GESTURING_NO_DARK_SKIN_TONE'=> "\1F645}\1F3FF}", 'CHARACTER_MAN_GESTURING_NO'=> "\1F645}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_NO_LIGHT_SKIN_TONE'=> "\1F645}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F645}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\1F645}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\1F645}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_NO_DARK_SKIN_TONE'=> "\1F645}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO'=> "\1F645}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_LIGHT_SKIN_TONE'=> "\1F645}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F645}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\1F645}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\1F645}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_DARK_SKIN_TONE'=> "\1F645}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_GESTURING_OK'=> "\1F646}", 'CHARACTER_PERSON_GESTURING_OK_LIGHT_SKIN_TONE'=> "\1F646}\1F3FB}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\1F646}\1F3FC}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\1F646}\1F3FD}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\1F646}\1F3FE}", 'CHARACTER_PERSON_GESTURING_OK_DARK_SKIN_TONE'=> "\1F646}\1F3FF}", 'CHARACTER_MAN_GESTURING_OK'=> "\1F646}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_OK_LIGHT_SKIN_TONE'=> "\1F646}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\1F646}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\1F646}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\1F646}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GESTURING_OK_DARK_SKIN_TONE'=> "\1F646}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK'=> "\1F646}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_LIGHT_SKIN_TONE'=> "\1F646}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\1F646}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\1F646}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\1F646}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_DARK_SKIN_TONE'=> "\1F646}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_TIPPING_HAND'=> "\1F481}", 'CHARACTER_PERSON_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\1F481}\1F3FB}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F481}\1F3FC}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\1F481}\1F3FD}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F481}\1F3FE}", 'CHARACTER_PERSON_TIPPING_HAND_DARK_SKIN_TONE'=> "\1F481}\1F3FF}", 'CHARACTER_MAN_TIPPING_HAND'=> "\1F481}\200D}\2642}\FE0F}", 'CHARACTER_MAN_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\1F481}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F481}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\1F481}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F481}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_TIPPING_HAND_DARK_SKIN_TONE'=> "\1F481}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND'=> "\1F481}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\1F481}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F481}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\1F481}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F481}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_DARK_SKIN_TONE'=> "\1F481}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_RAISING_HAND'=> "\1F64B}", 'CHARACTER_PERSON_RAISING_HAND_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FB}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FC}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\1F64B}\1F3FD}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F64B}\1F3FE}", 'CHARACTER_PERSON_RAISING_HAND_DARK_SKIN_TONE'=> "\1F64B}\1F3FF}", 'CHARACTER_MAN_RAISING_HAND'=> "\1F64B}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RAISING_HAND_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\1F64B}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F64B}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RAISING_HAND_DARK_SKIN_TONE'=> "\1F64B}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND'=> "\1F64B}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64B}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\1F64B}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F64B}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_DARK_SKIN_TONE'=> "\1F64B}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_BOWING'=> "\1F647}", 'CHARACTER_PERSON_BOWING_LIGHT_SKIN_TONE'=> "\1F647}\1F3FB}", 'CHARACTER_PERSON_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F647}\1F3FC}", 'CHARACTER_PERSON_BOWING_MEDIUM_SKIN_TONE'=> "\1F647}\1F3FD}", 'CHARACTER_PERSON_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\1F647}\1F3FE}", 'CHARACTER_PERSON_BOWING_DARK_SKIN_TONE'=> "\1F647}\1F3FF}", 'CHARACTER_MAN_BOWING'=> "\1F647}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOWING_LIGHT_SKIN_TONE'=> "\1F647}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F647}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_SKIN_TONE'=> "\1F647}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\1F647}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOWING_DARK_SKIN_TONE'=> "\1F647}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_BOWING'=> "\1F647}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOWING_LIGHT_SKIN_TONE'=> "\1F647}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F647}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_SKIN_TONE'=> "\1F647}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\1F647}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOWING_DARK_SKIN_TONE'=> "\1F647}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_FACEPALMING'=> "\1F926}", 'CHARACTER_PERSON_FACEPALMING_LIGHT_SKIN_TONE'=> "\1F926}\1F3FB}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F926}\1F3FC}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_SKIN_TONE'=> "\1F926}\1F3FD}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\1F926}\1F3FE}", 'CHARACTER_PERSON_FACEPALMING_DARK_SKIN_TONE'=> "\1F926}\1F3FF}", 'CHARACTER_MAN_FACEPALMING'=> "\1F926}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FACEPALMING_LIGHT_SKIN_TONE'=> "\1F926}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F926}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_SKIN_TONE'=> "\1F926}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\1F926}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_FACEPALMING_DARK_SKIN_TONE'=> "\1F926}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING'=> "\1F926}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING_LIGHT_SKIN_TONE'=> "\1F926}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F926}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_SKIN_TONE'=> "\1F926}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\1F926}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_FACEPALMING_DARK_SKIN_TONE'=> "\1F926}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_SHRUGGING'=> "\1F937}", 'CHARACTER_PERSON_SHRUGGING_LIGHT_SKIN_TONE'=> "\1F937}\1F3FB}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F937}\1F3FC}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_SKIN_TONE'=> "\1F937}\1F3FD}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\1F937}\1F3FE}", 'CHARACTER_PERSON_SHRUGGING_DARK_SKIN_TONE'=> "\1F937}\1F3FF}", 'CHARACTER_MAN_SHRUGGING'=> "\1F937}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SHRUGGING_LIGHT_SKIN_TONE'=> "\1F937}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F937}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_SKIN_TONE'=> "\1F937}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\1F937}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SHRUGGING_DARK_SKIN_TONE'=> "\1F937}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING'=> "\1F937}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING_LIGHT_SKIN_TONE'=> "\1F937}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F937}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_SKIN_TONE'=> "\1F937}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\1F937}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SHRUGGING_DARK_SKIN_TONE'=> "\1F937}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_GETTING_MASSAGE'=> "\1F486}", 'CHARACTER_PERSON_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\1F486}\1F3FB}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F486}\1F3FC}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\1F486}\1F3FD}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F486}\1F3FE}", 'CHARACTER_PERSON_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\1F486}\1F3FF}", 'CHARACTER_MAN_GETTING_MASSAGE'=> "\1F486}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\1F486}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F486}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\1F486}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F486}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\1F486}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE'=> "\1F486}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\1F486}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F486}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\1F486}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\1F486}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\1F486}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_GETTING_HAIRCUT'=> "\1F487}", 'CHARACTER_PERSON_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\1F487}\1F3FB}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F487}\1F3FC}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\1F487}\1F3FD}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\1F487}\1F3FE}", 'CHARACTER_PERSON_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\1F487}\1F3FF}", 'CHARACTER_MAN_GETTING_HAIRCUT'=> "\1F487}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\1F487}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F487}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\1F487}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\1F487}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\1F487}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT'=> "\1F487}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\1F487}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F487}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\1F487}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\1F487}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\1F487}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_WALKING'=> "\1F6B6}", 'CHARACTER_PERSON_WALKING_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FB}", 'CHARACTER_PERSON_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FC}", 'CHARACTER_PERSON_WALKING_MEDIUM_SKIN_TONE'=> "\1F6B6}\1F3FD}", 'CHARACTER_PERSON_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B6}\1F3FE}", 'CHARACTER_PERSON_WALKING_DARK_SKIN_TONE'=> "\1F6B6}\1F3FF}", 'CHARACTER_MAN_WALKING'=> "\1F6B6}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WALKING_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_SKIN_TONE'=> "\1F6B6}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B6}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_WALKING_DARK_SKIN_TONE'=> "\1F6B6}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_WALKING'=> "\1F6B6}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WALKING_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B6}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_SKIN_TONE'=> "\1F6B6}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B6}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_WALKING_DARK_SKIN_TONE'=> "\1F6B6}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_RUNNING'=> "\1F3C3}", 'CHARACTER_PERSON_RUNNING_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FB}", 'CHARACTER_PERSON_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FC}", 'CHARACTER_PERSON_RUNNING_MEDIUM_SKIN_TONE'=> "\1F3C3}\1F3FD}", 'CHARACTER_PERSON_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C3}\1F3FE}", 'CHARACTER_PERSON_RUNNING_DARK_SKIN_TONE'=> "\1F3C3}\1F3FF}", 'CHARACTER_MAN_RUNNING'=> "\1F3C3}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RUNNING_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_SKIN_TONE'=> "\1F3C3}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C3}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_RUNNING_DARK_SKIN_TONE'=> "\1F3C3}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_RUNNING'=> "\1F3C3}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RUNNING_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C3}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_SKIN_TONE'=> "\1F3C3}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C3}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_RUNNING_DARK_SKIN_TONE'=> "\1F3C3}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_DANCING'=> "\1F483}", 'CHARACTER_WOMAN_DANCING_LIGHT_SKIN_TONE'=> "\1F483}\1F3FB}", 'CHARACTER_WOMAN_DANCING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F483}\1F3FC}", 'CHARACTER_WOMAN_DANCING_MEDIUM_SKIN_TONE'=> "\1F483}\1F3FD}", 'CHARACTER_WOMAN_DANCING_MEDIUM_DARK_SKIN_TONE'=> "\1F483}\1F3FE}", 'CHARACTER_WOMAN_DANCING_DARK_SKIN_TONE'=> "\1F483}\1F3FF}", 'CHARACTER_MAN_DANCING'=> "\1F57A}", 'CHARACTER_MAN_DANCING_LIGHT_SKIN_TONE'=> "\1F57A}\1F3FB}", 'CHARACTER_MAN_DANCING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F57A}\1F3FC}", 'CHARACTER_MAN_DANCING_MEDIUM_SKIN_TONE'=> "\1F57A}\1F3FD}", 'CHARACTER_MAN_DANCING_MEDIUM_DARK_SKIN_TONE'=> "\1F57A}\1F3FE}", 'CHARACTER_MAN_DANCING_DARK_SKIN_TONE'=> "\1F57A}\1F3FF}", 'CHARACTER_PEOPLE_WITH_BUNNY_EARS'=> "\1F46F}", 'CHARACTER_MEN_WITH_BUNNY_EARS'=> "\1F46F}\200D}\2642}\FE0F}", 'CHARACTER_WOMEN_WITH_BUNNY_EARS'=> "\1F46F}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_IN_STEAMY_ROOM'=> "\1F9D6}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FB}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FC}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\1F9D6}\1F3FD}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FE}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FF}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM'=> "\1F9D6}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\1F9D6}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM'=> "\1F9D6}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D6}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\1F9D6}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\1F9D6}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_PERSON_CLIMBING'=> "\1F9D7}", 'CHARACTER_PERSON_CLIMBING_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FB}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FC}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_SKIN_TONE'=> "\1F9D7}\1F3FD}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\1F9D7}\1F3FE}", 'CHARACTER_PERSON_CLIMBING_DARK_SKIN_TONE'=> "\1F9D7}\1F3FF}", 'CHARACTER_WOMAN_CLIMBING'=> "\1F9D7}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CLIMBING_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_SKIN_TONE'=> "\1F9D7}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\1F9D7}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CLIMBING_DARK_SKIN_TONE'=> "\1F9D7}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_CLIMBING'=> "\1F9D7}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CLIMBING_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D7}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_SKIN_TONE'=> "\1F9D7}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\1F9D7}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CLIMBING_DARK_SKIN_TONE'=> "\1F9D7}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_PERSON_IN_LOTUS_POSITION'=> "\1F9D8}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FB}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FC}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\1F9D8}\1F3FD}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\1F9D8}\1F3FE}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\1F9D8}\1F3FF}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION'=> "\1F9D8}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\1F9D8}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\1F9D8}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\1F9D8}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION'=> "\1F9D8}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9D8}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\1F9D8}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\1F9D8}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\1F9D8}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_PERSON_TAKING_BATH'=> "\1F6C0}", 'CHARACTER_PERSON_TAKING_BATH_LIGHT_SKIN_TONE'=> "\1F6C0}\1F3FB}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6C0}\1F3FC}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_SKIN_TONE'=> "\1F6C0}\1F3FD}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_DARK_SKIN_TONE'=> "\1F6C0}\1F3FE}", 'CHARACTER_PERSON_TAKING_BATH_DARK_SKIN_TONE'=> "\1F6C0}\1F3FF}", 'CHARACTER_PERSON_IN_BED'=> "\1F6CC}", 'CHARACTER_PERSON_IN_BED_LIGHT_SKIN_TONE'=> "\1F6CC}\1F3FB}", 'CHARACTER_PERSON_IN_BED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6CC}\1F3FC}", 'CHARACTER_PERSON_IN_BED_MEDIUM_SKIN_TONE'=> "\1F6CC}\1F3FD}", 'CHARACTER_PERSON_IN_BED_MEDIUM_DARK_SKIN_TONE'=> "\1F6CC}\1F3FE}", 'CHARACTER_PERSON_IN_BED_DARK_SKIN_TONE'=> "\1F6CC}\1F3FF}", 'CHARACTER_MAN_IN_SUIT_LEVITATING'=> "\1F574}\FE0F}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_LIGHT_SKIN_TONE'=> "\1F574}\1F3FB}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F574}\1F3FC}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_SKIN_TONE'=> "\1F574}\1F3FD}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_DARK_SKIN_TONE'=> "\1F574}\1F3FE}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_DARK_SKIN_TONE'=> "\1F574}\1F3FF}", 'CHARACTER_SPEAKING_HEAD'=> "\1F5E3}\FE0F}", 'CHARACTER_BUST_IN_SILHOUETTE'=> "\1F464}", 'CHARACTER_BUSTS_IN_SILHOUETTE'=> "\1F465}", 'CHARACTER_PERSON_FENCING'=> "\1F93A}", 'CHARACTER_HORSE_RACING'=> "\1F3C7}", 'CHARACTER_HORSE_RACING_LIGHT_SKIN_TONE'=> "\1F3C7}\1F3FB}", 'CHARACTER_HORSE_RACING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C7}\1F3FC}", 'CHARACTER_HORSE_RACING_MEDIUM_SKIN_TONE'=> "\1F3C7}\1F3FD}", 'CHARACTER_HORSE_RACING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C7}\1F3FE}", 'CHARACTER_HORSE_RACING_DARK_SKIN_TONE'=> "\1F3C7}\1F3FF}", 'CHARACTER_SKIER'=> "\26F7}\FE0F}", 'CHARACTER_SNOWBOARDER'=> "\1F3C2}", 'CHARACTER_SNOWBOARDER_LIGHT_SKIN_TONE'=> "\1F3C2}\1F3FB}", 'CHARACTER_SNOWBOARDER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C2}\1F3FC}", 'CHARACTER_SNOWBOARDER_MEDIUM_SKIN_TONE'=> "\1F3C2}\1F3FD}", 'CHARACTER_SNOWBOARDER_MEDIUM_DARK_SKIN_TONE'=> "\1F3C2}\1F3FE}", 'CHARACTER_SNOWBOARDER_DARK_SKIN_TONE'=> "\1F3C2}\1F3FF}", 'CHARACTER_PERSON_GOLFING'=> "\1F3CC}\FE0F}", 'CHARACTER_PERSON_GOLFING_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FB}", 'CHARACTER_PERSON_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FC}", 'CHARACTER_PERSON_GOLFING_MEDIUM_SKIN_TONE'=> "\1F3CC}\1F3FD}", 'CHARACTER_PERSON_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CC}\1F3FE}", 'CHARACTER_PERSON_GOLFING_DARK_SKIN_TONE'=> "\1F3CC}\1F3FF}", 'CHARACTER_MAN_GOLFING'=> "\1F3CC}\FE0F}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GOLFING_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_SKIN_TONE'=> "\1F3CC}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CC}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_GOLFING_DARK_SKIN_TONE'=> "\1F3CC}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_GOLFING'=> "\1F3CC}\FE0F}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GOLFING_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CC}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_SKIN_TONE'=> "\1F3CC}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CC}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_GOLFING_DARK_SKIN_TONE'=> "\1F3CC}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_SURFING'=> "\1F3C4}", 'CHARACTER_PERSON_SURFING_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FB}", 'CHARACTER_PERSON_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FC}", 'CHARACTER_PERSON_SURFING_MEDIUM_SKIN_TONE'=> "\1F3C4}\1F3FD}", 'CHARACTER_PERSON_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C4}\1F3FE}", 'CHARACTER_PERSON_SURFING_DARK_SKIN_TONE'=> "\1F3C4}\1F3FF}", 'CHARACTER_MAN_SURFING'=> "\1F3C4}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SURFING_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_SKIN_TONE'=> "\1F3C4}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C4}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SURFING_DARK_SKIN_TONE'=> "\1F3C4}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_SURFING'=> "\1F3C4}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SURFING_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3C4}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_SKIN_TONE'=> "\1F3C4}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\1F3C4}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SURFING_DARK_SKIN_TONE'=> "\1F3C4}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_ROWING_BOAT'=> "\1F6A3}", 'CHARACTER_PERSON_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FB}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FC}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\1F6A3}\1F3FD}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\1F6A3}\1F3FE}", 'CHARACTER_PERSON_ROWING_BOAT_DARK_SKIN_TONE'=> "\1F6A3}\1F3FF}", 'CHARACTER_MAN_ROWING_BOAT'=> "\1F6A3}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\1F6A3}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\1F6A3}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_ROWING_BOAT_DARK_SKIN_TONE'=> "\1F6A3}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT'=> "\1F6A3}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6A3}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\1F6A3}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\1F6A3}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_DARK_SKIN_TONE'=> "\1F6A3}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_SWIMMING'=> "\1F3CA}", 'CHARACTER_PERSON_SWIMMING_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FB}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FC}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_SKIN_TONE'=> "\1F3CA}\1F3FD}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CA}\1F3FE}", 'CHARACTER_PERSON_SWIMMING_DARK_SKIN_TONE'=> "\1F3CA}\1F3FF}", 'CHARACTER_MAN_SWIMMING'=> "\1F3CA}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SWIMMING_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_SKIN_TONE'=> "\1F3CA}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CA}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_SWIMMING_DARK_SKIN_TONE'=> "\1F3CA}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_SWIMMING'=> "\1F3CA}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SWIMMING_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CA}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_SKIN_TONE'=> "\1F3CA}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\1F3CA}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_SWIMMING_DARK_SKIN_TONE'=> "\1F3CA}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_BOUNCING_BALL'=> "\26F9}\FE0F}", 'CHARACTER_PERSON_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\26F9}\1F3FB}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\26F9}\1F3FC}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\26F9}\1F3FD}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\26F9}\1F3FE}", 'CHARACTER_PERSON_BOUNCING_BALL_DARK_SKIN_TONE'=> "\26F9}\1F3FF}", 'CHARACTER_MAN_BOUNCING_BALL'=> "\26F9}\FE0F}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\26F9}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\26F9}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\26F9}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\26F9}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_DARK_SKIN_TONE'=> "\26F9}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL'=> "\26F9}\FE0F}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\26F9}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\26F9}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\26F9}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\26F9}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_DARK_SKIN_TONE'=> "\26F9}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_LIFTING_WEIGHTS'=> "\1F3CB}\FE0F}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FB}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FC}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\1F3CB}\1F3FD}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\1F3CB}\1F3FE}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\1F3CB}\1F3FF}", 'CHARACTER_MAN_LIFTING_WEIGHTS'=> "\1F3CB}\FE0F}\200D}\2642}\FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\1F3CB}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\1F3CB}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\1F3CB}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS'=> "\1F3CB}\FE0F}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F3CB}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\1F3CB}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\1F3CB}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\1F3CB}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_BIKING'=> "\1F6B4}", 'CHARACTER_PERSON_BIKING_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FB}", 'CHARACTER_PERSON_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FC}", 'CHARACTER_PERSON_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B4}\1F3FD}", 'CHARACTER_PERSON_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B4}\1F3FE}", 'CHARACTER_PERSON_BIKING_DARK_SKIN_TONE'=> "\1F6B4}\1F3FF}", 'CHARACTER_MAN_BIKING'=> "\1F6B4}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BIKING_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B4}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B4}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_BIKING_DARK_SKIN_TONE'=> "\1F6B4}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_BIKING'=> "\1F6B4}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BIKING_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B4}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B4}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B4}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_BIKING_DARK_SKIN_TONE'=> "\1F6B4}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_MOUNTAIN_BIKING'=> "\1F6B5}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FB}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FC}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B5}\1F3FD}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B5}\1F3FE}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\1F6B5}\1F3FF}", 'CHARACTER_MAN_MOUNTAIN_BIKING'=> "\1F6B5}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B5}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B5}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\1F6B5}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING'=> "\1F6B5}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F6B5}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\1F6B5}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\1F6B5}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\1F6B5}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_RACING_CAR'=> "\1F3CE}\FE0F}", 'CHARACTER_MOTORCYCLE'=> "\1F3CD}\FE0F}", 'CHARACTER_PERSON_CARTWHEELING'=> "\1F938}", 'CHARACTER_PERSON_CARTWHEELING_LIGHT_SKIN_TONE'=> "\1F938}\1F3FB}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F938}\1F3FC}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\1F938}\1F3FD}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\1F938}\1F3FE}", 'CHARACTER_PERSON_CARTWHEELING_DARK_SKIN_TONE'=> "\1F938}\1F3FF}", 'CHARACTER_MAN_CARTWHEELING'=> "\1F938}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CARTWHEELING_LIGHT_SKIN_TONE'=> "\1F938}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F938}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\1F938}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\1F938}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_CARTWHEELING_DARK_SKIN_TONE'=> "\1F938}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING'=> "\1F938}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_LIGHT_SKIN_TONE'=> "\1F938}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F938}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\1F938}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\1F938}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_DARK_SKIN_TONE'=> "\1F938}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PEOPLE_WRESTLING'=> "\1F93C}", 'CHARACTER_MEN_WRESTLING'=> "\1F93C}\200D}\2642}\FE0F}", 'CHARACTER_WOMEN_WRESTLING'=> "\1F93C}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_PLAYING_WATER_POLO'=> "\1F93D}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FB}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FC}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\1F93D}\1F3FD}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\1F93D}\1F3FE}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\1F93D}\1F3FF}", 'CHARACTER_MAN_PLAYING_WATER_POLO'=> "\1F93D}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\1F93D}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\1F93D}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\1F93D}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO'=> "\1F93D}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93D}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\1F93D}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\1F93D}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\1F93D}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_PLAYING_HANDBALL'=> "\1F93E}", 'CHARACTER_PERSON_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FB}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FC}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\1F93E}\1F3FD}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\1F93E}\1F3FE}", 'CHARACTER_PERSON_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\1F93E}\1F3FF}", 'CHARACTER_MAN_PLAYING_HANDBALL'=> "\1F93E}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\1F93E}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\1F93E}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\1F93E}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL'=> "\1F93E}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\1F93E}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\1F93E}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\1F93E}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\1F93E}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_PERSON_JUGGLING'=> "\1F939}", 'CHARACTER_PERSON_JUGGLING_LIGHT_SKIN_TONE'=> "\1F939}\1F3FB}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F939}\1F3FC}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_SKIN_TONE'=> "\1F939}\1F3FD}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\1F939}\1F3FE}", 'CHARACTER_PERSON_JUGGLING_DARK_SKIN_TONE'=> "\1F939}\1F3FF}", 'CHARACTER_MAN_JUGGLING'=> "\1F939}\200D}\2642}\FE0F}", 'CHARACTER_MAN_JUGGLING_LIGHT_SKIN_TONE'=> "\1F939}\1F3FB}\200D}\2642}\FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F939}\1F3FC}\200D}\2642}\FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_SKIN_TONE'=> "\1F939}\1F3FD}\200D}\2642}\FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\1F939}\1F3FE}\200D}\2642}\FE0F}", 'CHARACTER_MAN_JUGGLING_DARK_SKIN_TONE'=> "\1F939}\1F3FF}\200D}\2642}\FE0F}", 'CHARACTER_WOMAN_JUGGLING'=> "\1F939}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_JUGGLING_LIGHT_SKIN_TONE'=> "\1F939}\1F3FB}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\1F939}\1F3FC}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_SKIN_TONE'=> "\1F939}\1F3FD}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\1F939}\1F3FE}\200D}\2640}\FE0F}", 'CHARACTER_WOMAN_JUGGLING_DARK_SKIN_TONE'=> "\1F939}\1F3FF}\200D}\2640}\FE0F}", 'CHARACTER_MAN_AND_WOMAN_HOLDING_HANDS'=> "\1F46B}", 'CHARACTER_TWO_MEN_HOLDING_HANDS'=> "\1F46C}", 'CHARACTER_TWO_WOMEN_HOLDING_HANDS'=> "\1F46D}", 'CHARACTER_KISS'=> "\1F48F}", 'CHARACTER_KISS_WOMAN_MAN'=> "\1F469}\200D}\2764}\FE0F}\200D}\1F48B}\200D}\1F468}", 'CHARACTER_KISS_MAN_MAN'=> "\1F468}\200D}\2764}\FE0F}\200D}\1F48B}\200D}\1F468}", 'CHARACTER_KISS_WOMAN_WOMAN'=> "\1F469}\200D}\2764}\FE0F}\200D}\1F48B}\200D}\1F469}", 'CHARACTER_COUPLE_WITH_HEART'=> "\1F491}", 'CHARACTER_COUPLE_WITH_HEART_WOMAN_MAN'=> "\1F469}\200D}\2764}\FE0F}\200D}\1F468}", 'CHARACTER_COUPLE_WITH_HEART_MAN_MAN'=> "\1F468}\200D}\2764}\FE0F}\200D}\1F468}", 'CHARACTER_COUPLE_WITH_HEART_WOMAN_WOMAN'=> "\1F469}\200D}\2764}\FE0F}\200D}\1F469}", 'CHARACTER_FAMILY'=> "\1F46A}", 'CHARACTER_FAMILY_MAN_WOMAN_BOY'=> "\1F468}\200D}\1F469}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL'=> "\1F468}\200D}\1F469}\200D}\1F467}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL_BOY'=> "\1F468}\200D}\1F469}\200D}\1F467}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_BOY_BOY'=> "\1F468}\200D}\1F469}\200D}\1F466}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL_GIRL'=> "\1F468}\200D}\1F469}\200D}\1F467}\200D}\1F467}", 'CHARACTER_FAMILY_MAN_MAN_BOY'=> "\1F468}\200D}\1F468}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_MAN_GIRL'=> "\1F468}\200D}\1F468}\200D}\1F467}", 'CHARACTER_FAMILY_MAN_MAN_GIRL_BOY'=> "\1F468}\200D}\1F468}\200D}\1F467}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_MAN_BOY_BOY'=> "\1F468}\200D}\1F468}\200D}\1F466}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_MAN_GIRL_GIRL'=> "\1F468}\200D}\1F468}\200D}\1F467}\200D}\1F467}", 'CHARACTER_FAMILY_WOMAN_WOMAN_BOY'=> "\1F469}\200D}\1F469}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL'=> "\1F469}\200D}\1F469}\200D}\1F467}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL_BOY'=> "\1F469}\200D}\1F469}\200D}\1F467}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_BOY_BOY'=> "\1F469}\200D}\1F469}\200D}\1F466}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL_GIRL'=> "\1F469}\200D}\1F469}\200D}\1F467}\200D}\1F467}", 'CHARACTER_FAMILY_MAN_BOY'=> "\1F468}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_BOY_BOY'=> "\1F468}\200D}\1F466}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_GIRL'=> "\1F468}\200D}\1F467}", 'CHARACTER_FAMILY_MAN_GIRL_BOY'=> "\1F468}\200D}\1F467}\200D}\1F466}", 'CHARACTER_FAMILY_MAN_GIRL_GIRL'=> "\1F468}\200D}\1F467}\200D}\1F467}", 'CHARACTER_FAMILY_WOMAN_BOY'=> "\1F469}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_BOY_BOY'=> "\1F469}\200D}\1F466}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_GIRL'=> "\1F469}\200D}\1F467}", 'CHARACTER_FAMILY_WOMAN_GIRL_BOY'=> "\1F469}\200D}\1F467}\200D}\1F466}", 'CHARACTER_FAMILY_WOMAN_GIRL_GIRL'=> "\1F469}\200D}\1F467}\200D}\1F467}", 'CHARACTER_SELFIE'=> "\1F933}", 'CHARACTER_SELFIE_LIGHT_SKIN_TONE'=> "\1F933}\1F3FB}", 'CHARACTER_SELFIE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F933}\1F3FC}", 'CHARACTER_SELFIE_MEDIUM_SKIN_TONE'=> "\1F933}\1F3FD}", 'CHARACTER_SELFIE_MEDIUM_DARK_SKIN_TONE'=> "\1F933}\1F3FE}", 'CHARACTER_SELFIE_DARK_SKIN_TONE'=> "\1F933}\1F3FF}", 'CHARACTER_FLEXED_BICEPS'=> "\1F4AA}", 'CHARACTER_FLEXED_BICEPS_LIGHT_SKIN_TONE'=> "\1F4AA}\1F3FB}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F4AA}\1F3FC}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_SKIN_TONE'=> "\1F4AA}\1F3FD}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_DARK_SKIN_TONE'=> "\1F4AA}\1F3FE}", 'CHARACTER_FLEXED_BICEPS_DARK_SKIN_TONE'=> "\1F4AA}\1F3FF}", 'CHARACTER_LEG'=> "\1F9B5}", 'CHARACTER_LEG_LIGHT_SKIN_TONE'=> "\1F9B5}\1F3FB}", 'CHARACTER_LEG_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B5}\1F3FC}", 'CHARACTER_LEG_MEDIUM_SKIN_TONE'=> "\1F9B5}\1F3FD}", 'CHARACTER_LEG_MEDIUM_DARK_SKIN_TONE'=> "\1F9B5}\1F3FE}", 'CHARACTER_LEG_DARK_SKIN_TONE'=> "\1F9B5}\1F3FF}", 'CHARACTER_FOOT'=> "\1F9B6}", 'CHARACTER_FOOT_LIGHT_SKIN_TONE'=> "\1F9B6}\1F3FB}", 'CHARACTER_FOOT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F9B6}\1F3FC}", 'CHARACTER_FOOT_MEDIUM_SKIN_TONE'=> "\1F9B6}\1F3FD}", 'CHARACTER_FOOT_MEDIUM_DARK_SKIN_TONE'=> "\1F9B6}\1F3FE}", 'CHARACTER_FOOT_DARK_SKIN_TONE'=> "\1F9B6}\1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT'=> "\1F448}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_LIGHT_SKIN_TONE'=> "\1F448}\1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F448}\1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_SKIN_TONE'=> "\1F448}\1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_DARK_SKIN_TONE'=> "\1F448}\1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_DARK_SKIN_TONE'=> "\1F448}\1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT'=> "\1F449}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_LIGHT_SKIN_TONE'=> "\1F449}\1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_LIGHT_SKIN_TONE'=> "\1F449}\1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_SKIN_TONE'=> "\1F449}\1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_DARK_SKIN_TONE'=> "\1F449}\1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_DARK_SKIN_TONE'=> "\1F449}\1F3FF}", 'CHARACTER_INDEX_POINTING_UP'=> "\261D}\FE0F}", 'CHARACTER_INDEX_POINTING_UP_LIGHT_SKIN_TONE'=> "\261D}\1F3FB}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\261D}\1F3FC}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_SKIN_TONE'=> "\261D}\1F3FD}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_DARK_SKIN_TONE'=> "\261D}\1F3FE}", 'CHARACTER_INDEX_POINTING_UP_DARK_SKIN_TONE'=> "\261D}\1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP'=> "\1F446}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_LIGHT_SKIN_TONE'=> "\1F446}\1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\1F446}\1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_SKIN_TONE'=> "\1F446}\1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_DARK_SKIN_TONE'=> "\1F446}\1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_DARK_SKIN_TONE'=> "\1F446}\1F3FF}", 'CHARACTER_MIDDLE_FINGER'=> "\1F595}", 'CHARACTER_MIDDLE_FINGER_LIGHT_SKIN_TONE'=> "\1F595}\1F3FB}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F595}\1F3FC}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_SKIN_TONE'=> "\1F595}\1F3FD}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_DARK_SKIN_TONE'=> "\1F595}\1F3FE}", 'CHARACTER_MIDDLE_FINGER_DARK_SKIN_TONE'=> "\1F595}\1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN'=> "\1F447}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_LIGHT_SKIN_TONE'=> "\1F447}\1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F447}\1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_SKIN_TONE'=> "\1F447}\1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_DARK_SKIN_TONE'=> "\1F447}\1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_DARK_SKIN_TONE'=> "\1F447}\1F3FF}", 'CHARACTER_VICTORY_HAND'=> "\270C}\FE0F}", 'CHARACTER_VICTORY_HAND_LIGHT_SKIN_TONE'=> "\270C}\1F3FB}", 'CHARACTER_VICTORY_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\270C}\1F3FC}", 'CHARACTER_VICTORY_HAND_MEDIUM_SKIN_TONE'=> "\270C}\1F3FD}", 'CHARACTER_VICTORY_HAND_MEDIUM_DARK_SKIN_TONE'=> "\270C}\1F3FE}", 'CHARACTER_VICTORY_HAND_DARK_SKIN_TONE'=> "\270C}\1F3FF}", 'CHARACTER_CROSSED_FINGERS'=> "\1F91E}", 'CHARACTER_CROSSED_FINGERS_LIGHT_SKIN_TONE'=> "\1F91E}\1F3FB}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F91E}\1F3FC}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_SKIN_TONE'=> "\1F91E}\1F3FD}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_DARK_SKIN_TONE'=> "\1F91E}\1F3FE}", 'CHARACTER_CROSSED_FINGERS_DARK_SKIN_TONE'=> "\1F91E}\1F3FF}", 'CHARACTER_VULCAN_SALUTE'=> "\1F596}", 'CHARACTER_VULCAN_SALUTE_LIGHT_SKIN_TONE'=> "\1F596}\1F3FB}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F596}\1F3FC}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_SKIN_TONE'=> "\1F596}\1F3FD}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_DARK_SKIN_TONE'=> "\1F596}\1F3FE}", 'CHARACTER_VULCAN_SALUTE_DARK_SKIN_TONE'=> "\1F596}\1F3FF}", 'CHARACTER_SIGN_OF_THE_HORNS'=> "\1F918}", 'CHARACTER_SIGN_OF_THE_HORNS_LIGHT_SKIN_TONE'=> "\1F918}\1F3FB}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F918}\1F3FC}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_SKIN_TONE'=> "\1F918}\1F3FD}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_DARK_SKIN_TONE'=> "\1F918}\1F3FE}", 'CHARACTER_SIGN_OF_THE_HORNS_DARK_SKIN_TONE'=> "\1F918}\1F3FF}", 'CHARACTER_CALL_ME_HAND'=> "\1F919}", 'CHARACTER_CALL_ME_HAND_LIGHT_SKIN_TONE'=> "\1F919}\1F3FB}", 'CHARACTER_CALL_ME_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F919}\1F3FC}", 'CHARACTER_CALL_ME_HAND_MEDIUM_SKIN_TONE'=> "\1F919}\1F3FD}", 'CHARACTER_CALL_ME_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F919}\1F3FE}", 'CHARACTER_CALL_ME_HAND_DARK_SKIN_TONE'=> "\1F919}\1F3FF}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED'=> "\1F590}\FE0F}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_LIGHT_SKIN_TONE'=> "\1F590}\1F3FB}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_LIGHT_SKIN_TONE'=> "\1F590}\1F3FC}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_SKIN_TONE'=> "\1F590}\1F3FD}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_DARK_SKIN_TONE'=> "\1F590}\1F3FE}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_DARK_SKIN_TONE'=> "\1F590}\1F3FF}", 'CHARACTER_RAISED_HAND'=> "\270B}", 'CHARACTER_RAISED_HAND_LIGHT_SKIN_TONE'=> "\270B}\1F3FB}", 'CHARACTER_RAISED_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\270B}\1F3FC}", 'CHARACTER_RAISED_HAND_MEDIUM_SKIN_TONE'=> "\270B}\1F3FD}", 'CHARACTER_RAISED_HAND_MEDIUM_DARK_SKIN_TONE'=> "\270B}\1F3FE}", 'CHARACTER_RAISED_HAND_DARK_SKIN_TONE'=> "\270B}\1F3FF}", 'CHARACTER_OK_HAND'=> "\1F44C}", 'CHARACTER_OK_HAND_LIGHT_SKIN_TONE'=> "\1F44C}\1F3FB}", 'CHARACTER_OK_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44C}\1F3FC}", 'CHARACTER_OK_HAND_MEDIUM_SKIN_TONE'=> "\1F44C}\1F3FD}", 'CHARACTER_OK_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F44C}\1F3FE}", 'CHARACTER_OK_HAND_DARK_SKIN_TONE'=> "\1F44C}\1F3FF}", 'CHARACTER_THUMBS_UP'=> "\1F44D}", 'CHARACTER_THUMBS_UP_LIGHT_SKIN_TONE'=> "\1F44D}\1F3FB}", 'CHARACTER_THUMBS_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44D}\1F3FC}", 'CHARACTER_THUMBS_UP_MEDIUM_SKIN_TONE'=> "\1F44D}\1F3FD}", 'CHARACTER_THUMBS_UP_MEDIUM_DARK_SKIN_TONE'=> "\1F44D}\1F3FE}", 'CHARACTER_THUMBS_UP_DARK_SKIN_TONE'=> "\1F44D}\1F3FF}", 'CHARACTER_THUMBS_DOWN'=> "\1F44E}", 'CHARACTER_THUMBS_DOWN_LIGHT_SKIN_TONE'=> "\1F44E}\1F3FB}", 'CHARACTER_THUMBS_DOWN_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44E}\1F3FC}", 'CHARACTER_THUMBS_DOWN_MEDIUM_SKIN_TONE'=> "\1F44E}\1F3FD}", 'CHARACTER_THUMBS_DOWN_MEDIUM_DARK_SKIN_TONE'=> "\1F44E}\1F3FE}", 'CHARACTER_THUMBS_DOWN_DARK_SKIN_TONE'=> "\1F44E}\1F3FF}", 'CHARACTER_RAISED_FIST'=> "\270A}", 'CHARACTER_RAISED_FIST_LIGHT_SKIN_TONE'=> "\270A}\1F3FB}", 'CHARACTER_RAISED_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\270A}\1F3FC}", 'CHARACTER_RAISED_FIST_MEDIUM_SKIN_TONE'=> "\270A}\1F3FD}", 'CHARACTER_RAISED_FIST_MEDIUM_DARK_SKIN_TONE'=> "\270A}\1F3FE}", 'CHARACTER_RAISED_FIST_DARK_SKIN_TONE'=> "\270A}\1F3FF}", 'CHARACTER_ONCOMING_FIST'=> "\1F44A}", 'CHARACTER_ONCOMING_FIST_LIGHT_SKIN_TONE'=> "\1F44A}\1F3FB}", 'CHARACTER_ONCOMING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44A}\1F3FC}", 'CHARACTER_ONCOMING_FIST_MEDIUM_SKIN_TONE'=> "\1F44A}\1F3FD}", 'CHARACTER_ONCOMING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\1F44A}\1F3FE}", 'CHARACTER_ONCOMING_FIST_DARK_SKIN_TONE'=> "\1F44A}\1F3FF}", 'CHARACTER_LEFT_FACING_FIST'=> "\1F91B}", 'CHARACTER_LEFT_FACING_FIST_LIGHT_SKIN_TONE'=> "\1F91B}\1F3FB}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F91B}\1F3FC}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_SKIN_TONE'=> "\1F91B}\1F3FD}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\1F91B}\1F3FE}", 'CHARACTER_LEFT_FACING_FIST_DARK_SKIN_TONE'=> "\1F91B}\1F3FF}", 'CHARACTER_RIGHT_FACING_FIST'=> "\1F91C}", 'CHARACTER_RIGHT_FACING_FIST_LIGHT_SKIN_TONE'=> "\1F91C}\1F3FB}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\1F91C}\1F3FC}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_SKIN_TONE'=> "\1F91C}\1F3FD}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\1F91C}\1F3FE}", 'CHARACTER_RIGHT_FACING_FIST_DARK_SKIN_TONE'=> "\1F91C}\1F3FF}", 'CHARACTER_RAISED_BACK_OF_HAND'=> "\1F91A}", 'CHARACTER_RAISED_BACK_OF_HAND_LIGHT_SKIN_TONE'=> "\1F91A}\1F3FB}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F91A}\1F3FC}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_SKIN_TONE'=> "\1F91A}\1F3FD}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F91A}\1F3FE}", 'CHARACTER_RAISED_BACK_OF_HAND_DARK_SKIN_TONE'=> "\1F91A}\1F3FF}", 'CHARACTER_WAVING_HAND'=> "\1F44B}", 'CHARACTER_WAVING_HAND_LIGHT_SKIN_TONE'=> "\1F44B}\1F3FB}", 'CHARACTER_WAVING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44B}\1F3FC}", 'CHARACTER_WAVING_HAND_MEDIUM_SKIN_TONE'=> "\1F44B}\1F3FD}", 'CHARACTER_WAVING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\1F44B}\1F3FE}", 'CHARACTER_WAVING_HAND_DARK_SKIN_TONE'=> "\1F44B}\1F3FF}", 'CHARACTER_LOVE_YOU_GESTURE'=> "\1F91F}", 'CHARACTER_LOVE_YOU_GESTURE_LIGHT_SKIN_TONE'=> "\1F91F}\1F3FB}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F91F}\1F3FC}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_SKIN_TONE'=> "\1F91F}\1F3FD}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_DARK_SKIN_TONE'=> "\1F91F}\1F3FE}", 'CHARACTER_LOVE_YOU_GESTURE_DARK_SKIN_TONE'=> "\1F91F}\1F3FF}", 'CHARACTER_WRITING_HAND'=> "\270D}\FE0F}", 'CHARACTER_WRITING_HAND_LIGHT_SKIN_TONE'=> "\270D}\1F3FB}", 'CHARACTER_WRITING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\270D}\1F3FC}", 'CHARACTER_WRITING_HAND_MEDIUM_SKIN_TONE'=> "\270D}\1F3FD}", 'CHARACTER_WRITING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\270D}\1F3FE}", 'CHARACTER_WRITING_HAND_DARK_SKIN_TONE'=> "\270D}\1F3FF}", 'CHARACTER_CLAPPING_HANDS'=> "\1F44F}", 'CHARACTER_CLAPPING_HANDS_LIGHT_SKIN_TONE'=> "\1F44F}\1F3FB}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F44F}\1F3FC}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_SKIN_TONE'=> "\1F44F}\1F3FD}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\1F44F}\1F3FE}", 'CHARACTER_CLAPPING_HANDS_DARK_SKIN_TONE'=> "\1F44F}\1F3FF}", 'CHARACTER_OPEN_HANDS'=> "\1F450}", 'CHARACTER_OPEN_HANDS_LIGHT_SKIN_TONE'=> "\1F450}\1F3FB}", 'CHARACTER_OPEN_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F450}\1F3FC}", 'CHARACTER_OPEN_HANDS_MEDIUM_SKIN_TONE'=> "\1F450}\1F3FD}", 'CHARACTER_OPEN_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\1F450}\1F3FE}", 'CHARACTER_OPEN_HANDS_DARK_SKIN_TONE'=> "\1F450}\1F3FF}", 'CHARACTER_RAISING_HANDS'=> "\1F64C}", 'CHARACTER_RAISING_HANDS_LIGHT_SKIN_TONE'=> "\1F64C}\1F3FB}", 'CHARACTER_RAISING_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64C}\1F3FC}", 'CHARACTER_RAISING_HANDS_MEDIUM_SKIN_TONE'=> "\1F64C}\1F3FD}", 'CHARACTER_RAISING_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\1F64C}\1F3FE}", 'CHARACTER_RAISING_HANDS_DARK_SKIN_TONE'=> "\1F64C}\1F3FF}", 'CHARACTER_PALMS_UP_TOGETHER'=> "\1F932}", 'CHARACTER_PALMS_UP_TOGETHER_LIGHT_SKIN_TONE'=> "\1F932}\1F3FB}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_LIGHT_SKIN_TONE'=> "\1F932}\1F3FC}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_SKIN_TONE'=> "\1F932}\1F3FD}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_DARK_SKIN_TONE'=> "\1F932}\1F3FE}", 'CHARACTER_PALMS_UP_TOGETHER_DARK_SKIN_TONE'=> "\1F932}\1F3FF}", 'CHARACTER_FOLDED_HANDS'=> "\1F64F}", 'CHARACTER_FOLDED_HANDS_LIGHT_SKIN_TONE'=> "\1F64F}\1F3FB}", 'CHARACTER_FOLDED_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\1F64F}\1F3FC}", 'CHARACTER_FOLDED_HANDS_MEDIUM_SKIN_TONE'=> "\1F64F}\1F3FD}", 'CHARACTER_FOLDED_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\1F64F}\1F3FE}", 'CHARACTER_FOLDED_HANDS_DARK_SKIN_TONE'=> "\1F64F}\1F3FF}", 'CHARACTER_HANDSHAKE'=> "\1F91D}", 'CHARACTER_NAIL_POLISH'=> "\1F485}", 'CHARACTER_NAIL_POLISH_LIGHT_SKIN_TONE'=> "\1F485}\1F3FB}", 'CHARACTER_NAIL_POLISH_MEDIUM_LIGHT_SKIN_TONE'=> "\1F485}\1F3FC}", 'CHARACTER_NAIL_POLISH_MEDIUM_SKIN_TONE'=> "\1F485}\1F3FD}", 'CHARACTER_NAIL_POLISH_MEDIUM_DARK_SKIN_TONE'=> "\1F485}\1F3FE}", 'CHARACTER_NAIL_POLISH_DARK_SKIN_TONE'=> "\1F485}\1F3FF}", 'CHARACTER_EAR'=> "\1F442}", 'CHARACTER_EAR_LIGHT_SKIN_TONE'=> "\1F442}\1F3FB}", 'CHARACTER_EAR_MEDIUM_LIGHT_SKIN_TONE'=> "\1F442}\1F3FC}", 'CHARACTER_EAR_MEDIUM_SKIN_TONE'=> "\1F442}\1F3FD}", 'CHARACTER_EAR_MEDIUM_DARK_SKIN_TONE'=> "\1F442}\1F3FE}", 'CHARACTER_EAR_DARK_SKIN_TONE'=> "\1F442}\1F3FF}", 'CHARACTER_NOSE'=> "\1F443}", 'CHARACTER_NOSE_LIGHT_SKIN_TONE'=> "\1F443}\1F3FB}", 'CHARACTER_NOSE_MEDIUM_LIGHT_SKIN_TONE'=> "\1F443}\1F3FC}", 'CHARACTER_NOSE_MEDIUM_SKIN_TONE'=> "\1F443}\1F3FD}", 'CHARACTER_NOSE_MEDIUM_DARK_SKIN_TONE'=> "\1F443}\1F3FE}", 'CHARACTER_NOSE_DARK_SKIN_TONE'=> "\1F443}\1F3FF}", 'CHARACTER_RED_HAIRED'=> "\1F9B0}", 'CHARACTER_CURLY_HAIRED'=> "\1F9B1}", 'CHARACTER_BALD'=> "\1F9B2}", 'CHARACTER_WHITE_HAIRED'=> "\1F9B3}", 'CHARACTER_FOOTPRINTS'=> "\1F463}", 'CHARACTER_EYES'=> "\1F440}", 'CHARACTER_EYE'=> "\1F441}\FE0F}", 'CHARACTER_EYE_IN_SPEECH_BUBBLE'=> "\1F441}\FE0F}\200D}\1F5E8}\FE0F}", 'CHARACTER_BRAIN'=> "\1F9E0}", 'CHARACTER_BONE'=> "\1F9B4}", 'CHARACTER_TOOTH'=> "\1F9B7}", 'CHARACTER_TONGUE'=> "\1F445}", 'CHARACTER_MOUTH'=> "\1F444}", 'CHARACTER_KISS_MARK'=> "\1F48B}", 'CHARACTER_HEART_WITH_ARROW'=> "\1F498}", 'CHARACTER_RED_HEART'=> "\2764}\FE0F}", 'CHARACTER_BEATING_HEART'=> "\1F493}", 'CHARACTER_BROKEN_HEART'=> "\1F494}", 'CHARACTER_TWO_HEARTS'=> "\1F495}", 'CHARACTER_SPARKLING_HEART'=> "\1F496}", 'CHARACTER_GROWING_HEART'=> "\1F497}", 'CHARACTER_BLUE_HEART'=> "\1F499}", 'CHARACTER_GREEN_HEART'=> "\1F49A}", 'CHARACTER_YELLOW_HEART'=> "\1F49B}", 'CHARACTER_ORANGE_HEART'=> "\1F9E1}", 'CHARACTER_PURPLE_HEART'=> "\1F49C}", 'CHARACTER_BLACK_HEART'=> "\1F5A4}", 'CHARACTER_HEART_WITH_RIBBON'=> "\1F49D}", 'CHARACTER_REVOLVING_HEARTS'=> "\1F49E}", 'CHARACTER_HEART_DECORATION'=> "\1F49F}", 'CHARACTER_HEAVY_HEART_EXCLAMATION'=> "\2763}\FE0F}", 'CHARACTER_LOVE_LETTER'=> "\1F48C}", 'CHARACTER_ZZZ'=> "\1F4A4}", 'CHARACTER_ANGER_SYMBOL'=> "\1F4A2}", 'CHARACTER_BOMB'=> "\1F4A3}", 'CHARACTER_COLLISION'=> "\1F4A5}", 'CHARACTER_SWEAT_DROPLETS'=> "\1F4A6}", 'CHARACTER_DASHING_AWAY'=> "\1F4A8}", 'CHARACTER_DIZZY'=> "\1F4AB}", 'CHARACTER_SPEECH_BALLOON'=> "\1F4AC}", 'CHARACTER_LEFT_SPEECH_BUBBLE'=> "\1F5E8}\FE0F}", 'CHARACTER_RIGHT_ANGER_BUBBLE'=> "\1F5EF}\FE0F}", 'CHARACTER_THOUGHT_BALLOON'=> "\1F4AD}", 'CHARACTER_HOLE'=> "\1F573}\FE0F}", 'CHARACTER_GLASSES'=> "\1F453}", 'CHARACTER_SUNGLASSES'=> "\1F576}\FE0F}", 'CHARACTER_GOGGLES'=> "\1F97D}", 'CHARACTER_LAB_COAT'=> "\1F97C}", 'CHARACTER_NECKTIE'=> "\1F454}", 'CHARACTER_T_SHIRT'=> "\1F455}", 'CHARACTER_JEANS'=> "\1F456}", 'CHARACTER_SCARF'=> "\1F9E3}", 'CHARACTER_GLOVES'=> "\1F9E4}", 'CHARACTER_COAT'=> "\1F9E5}", 'CHARACTER_SOCKS'=> "\1F9E6}", 'CHARACTER_DRESS'=> "\1F457}", 'CHARACTER_KIMONO'=> "\1F458}", 'CHARACTER_BIKINI'=> "\1F459}", 'CHARACTER_WOMAN_S_CLOTHES'=> "\1F45A}", 'CHARACTER_PURSE'=> "\1F45B}", 'CHARACTER_HANDBAG'=> "\1F45C}", 'CHARACTER_CLUTCH_BAG'=> "\1F45D}", 'CHARACTER_SHOPPING_BAGS'=> "\1F6CD}\FE0F}", 'CHARACTER_SCHOOL_BACKPACK'=> "\1F392}", 'CHARACTER_MAN_S_SHOE'=> "\1F45E}", 'CHARACTER_RUNNING_SHOE'=> "\1F45F}", 'CHARACTER_HIKING_BOOT'=> "\1F97E}", 'CHARACTER_WOMAN_S_FLAT_SHOE'=> "\1F97F}", 'CHARACTER_HIGH_HEELED_SHOE'=> "\1F460}", 'CHARACTER_WOMAN_S_SANDAL'=> "\1F461}", 'CHARACTER_WOMAN_S_BOOT'=> "\1F462}", 'CHARACTER_CROWN'=> "\1F451}", 'CHARACTER_WOMAN_S_HAT'=> "\1F452}", 'CHARACTER_TOP_HAT'=> "\1F3A9}", 'CHARACTER_GRADUATION_CAP'=> "\1F393}", 'CHARACTER_BILLED_CAP'=> "\1F9E2}", 'CHARACTER_RESCUE_WORKER_S_HELMET'=> "\26D1}\FE0F}", 'CHARACTER_PRAYER_BEADS'=> "\1F4FF}", 'CHARACTER_LIPSTICK'=> "\1F484}", 'CHARACTER_RING'=> "\1F48D}", 'CHARACTER_GEM_STONE'=> "\1F48E}", 'CHARACTER_MONKEY_FACE'=> "\1F435}", 'CHARACTER_MONKEY'=> "\1F412}", 'CHARACTER_GORILLA'=> "\1F98D}", 'CHARACTER_DOG_FACE'=> "\1F436}", 'CHARACTER_DOG'=> "\1F415}", 'CHARACTER_POODLE'=> "\1F429}", 'CHARACTER_WOLF_FACE'=> "\1F43A}", 'CHARACTER_FOX_FACE'=> "\1F98A}", 'CHARACTER_RACCOON'=> "\1F99D}", 'CHARACTER_CAT_FACE'=> "\1F431}", 'CHARACTER_CAT'=> "\1F408}", 'CHARACTER_LION_FACE'=> "\1F981}", 'CHARACTER_TIGER_FACE'=> "\1F42F}", 'CHARACTER_TIGER'=> "\1F405}", 'CHARACTER_LEOPARD'=> "\1F406}", 'CHARACTER_HORSE_FACE'=> "\1F434}", 'CHARACTER_HORSE'=> "\1F40E}", 'CHARACTER_UNICORN_FACE'=> "\1F984}", 'CHARACTER_ZEBRA'=> "\1F993}", 'CHARACTER_DEER'=> "\1F98C}", 'CHARACTER_COW_FACE'=> "\1F42E}", 'CHARACTER_OX'=> "\1F402}", 'CHARACTER_WATER_BUFFALO'=> "\1F403}", 'CHARACTER_COW'=> "\1F404}", 'CHARACTER_PIG_FACE'=> "\1F437}", 'CHARACTER_PIG'=> "\1F416}", 'CHARACTER_BOAR'=> "\1F417}", 'CHARACTER_PIG_NOSE'=> "\1F43D}", 'CHARACTER_RAM'=> "\1F40F}", 'CHARACTER_EWE'=> "\1F411}", 'CHARACTER_GOAT'=> "\1F410}", 'CHARACTER_CAMEL'=> "\1F42A}", 'CHARACTER_TWO_HUMP_CAMEL'=> "\1F42B}", 'CHARACTER_LLAMA'=> "\1F999}", 'CHARACTER_GIRAFFE'=> "\1F992}", 'CHARACTER_ELEPHANT'=> "\1F418}", 'CHARACTER_RHINOCEROS'=> "\1F98F}", 'CHARACTER_HIPPOPOTAMUS'=> "\1F99B}", 'CHARACTER_MOUSE_FACE'=> "\1F42D}", 'CHARACTER_MOUSE'=> "\1F401}", 'CHARACTER_RAT'=> "\1F400}", 'CHARACTER_HAMSTER_FACE'=> "\1F439}", 'CHARACTER_RABBIT_FACE'=> "\1F430}", 'CHARACTER_RABBIT'=> "\1F407}", 'CHARACTER_CHIPMUNK'=> "\1F43F}\FE0F}", 'CHARACTER_HEDGEHOG'=> "\1F994}", 'CHARACTER_BAT'=> "\1F987}", 'CHARACTER_BEAR_FACE'=> "\1F43B}", 'CHARACTER_KOALA'=> "\1F428}", 'CHARACTER_PANDA_FACE'=> "\1F43C}", 'CHARACTER_KANGAROO'=> "\1F998}", 'CHARACTER_BADGER'=> "\1F9A1}", 'CHARACTER_PAW_PRINTS'=> "\1F43E}", 'CHARACTER_TURKEY'=> "\1F983}", 'CHARACTER_CHICKEN'=> "\1F414}", 'CHARACTER_ROOSTER'=> "\1F413}", 'CHARACTER_HATCHING_CHICK'=> "\1F423}", 'CHARACTER_BABY_CHICK'=> "\1F424}", 'CHARACTER_FRONT_FACING_BABY_CHICK'=> "\1F425}", 'CHARACTER_BIRD'=> "\1F426}", 'CHARACTER_PENGUIN'=> "\1F427}", 'CHARACTER_DOVE'=> "\1F54A}\FE0F}", 'CHARACTER_EAGLE'=> "\1F985}", 'CHARACTER_DUCK'=> "\1F986}", 'CHARACTER_SWAN'=> "\1F9A2}", 'CHARACTER_OWL'=> "\1F989}", 'CHARACTER_PEACOCK'=> "\1F99A}", 'CHARACTER_PARROT'=> "\1F99C}", 'CHARACTER_FROG_FACE'=> "\1F438}", 'CHARACTER_CROCODILE'=> "\1F40A}", 'CHARACTER_TURTLE'=> "\1F422}", 'CHARACTER_LIZARD'=> "\1F98E}", 'CHARACTER_SNAKE'=> "\1F40D}", 'CHARACTER_DRAGON_FACE'=> "\1F432}", 'CHARACTER_DRAGON'=> "\1F409}", 'CHARACTER_SAUROPOD'=> "\1F995}", 'CHARACTER_T_REX'=> "\1F996}", 'CHARACTER_SPOUTING_WHALE'=> "\1F433}", 'CHARACTER_WHALE'=> "\1F40B}", 'CHARACTER_DOLPHIN'=> "\1F42C}", 'CHARACTER_FISH'=> "\1F41F}", 'CHARACTER_TROPICAL_FISH'=> "\1F420}", 'CHARACTER_BLOWFISH'=> "\1F421}", 'CHARACTER_SHARK'=> "\1F988}", 'CHARACTER_OCTOPUS'=> "\1F419}", 'CHARACTER_SPIRAL_SHELL'=> "\1F41A}", 'CHARACTER_CRAB'=> "\1F980}", 'CHARACTER_LOBSTER'=> "\1F99E}", 'CHARACTER_SHRIMP'=> "\1F990}", 'CHARACTER_SQUID'=> "\1F991}", 'CHARACTER_SNAIL'=> "\1F40C}", 'CHARACTER_BUTTERFLY'=> "\1F98B}", 'CHARACTER_BUG'=> "\1F41B}", 'CHARACTER_ANT'=> "\1F41C}", 'CHARACTER_HONEYBEE'=> "\1F41D}", 'CHARACTER_LADY_BEETLE'=> "\1F41E}", 'CHARACTER_CRICKET'=> "\1F997}", 'CHARACTER_SPIDER'=> "\1F577}\FE0F}", 'CHARACTER_SPIDER_WEB'=> "\1F578}\FE0F}", 'CHARACTER_SCORPION'=> "\1F982}", 'CHARACTER_MOSQUITO'=> "\1F99F}", 'CHARACTER_MICROBE'=> "\1F9A0}", 'CHARACTER_BOUQUET'=> "\1F490}", 'CHARACTER_CHERRY_BLOSSOM'=> "\1F338}", 'CHARACTER_WHITE_FLOWER'=> "\1F4AE}", 'CHARACTER_ROSETTE'=> "\1F3F5}\FE0F}", 'CHARACTER_ROSE'=> "\1F339}", 'CHARACTER_WILTED_FLOWER'=> "\1F940}", 'CHARACTER_HIBISCUS'=> "\1F33A}", 'CHARACTER_SUNFLOWER'=> "\1F33B}", 'CHARACTER_BLOSSOM'=> "\1F33C}", 'CHARACTER_TULIP'=> "\1F337}", 'CHARACTER_SEEDLING'=> "\1F331}", 'CHARACTER_EVERGREEN_TREE'=> "\1F332}", 'CHARACTER_DECIDUOUS_TREE'=> "\1F333}", 'CHARACTER_PALM_TREE'=> "\1F334}", 'CHARACTER_CACTUS'=> "\1F335}", 'CHARACTER_SHEAF_OF_RICE'=> "\1F33E}", 'CHARACTER_HERB'=> "\1F33F}", 'CHARACTER_SHAMROCK'=> "\2618}\FE0F}", 'CHARACTER_FOUR_LEAF_CLOVER'=> "\1F340}", 'CHARACTER_MAPLE_LEAF'=> "\1F341}", 'CHARACTER_FALLEN_LEAF'=> "\1F342}", 'CHARACTER_LEAF_FLUTTERING_IN_WIND'=> "\1F343}", 'CHARACTER_GRAPES'=> "\1F347}", 'CHARACTER_MELON'=> "\1F348}", 'CHARACTER_WATERMELON'=> "\1F349}", 'CHARACTER_TANGERINE'=> "\1F34A}", 'CHARACTER_LEMON'=> "\1F34B}", 'CHARACTER_BANANA'=> "\1F34C}", 'CHARACTER_PINEAPPLE'=> "\1F34D}", 'CHARACTER_MANGO'=> "\1F96D}", 'CHARACTER_RED_APPLE'=> "\1F34E}", 'CHARACTER_GREEN_APPLE'=> "\1F34F}", 'CHARACTER_PEAR'=> "\1F350}", 'CHARACTER_PEACH'=> "\1F351}", 'CHARACTER_CHERRIES'=> "\1F352}", 'CHARACTER_STRAWBERRY'=> "\1F353}", 'CHARACTER_KIWI_FRUIT'=> "\1F95D}", 'CHARACTER_TOMATO'=> "\1F345}", 'CHARACTER_COCONUT'=> "\1F965}", 'CHARACTER_AVOCADO'=> "\1F951}", 'CHARACTER_EGGPLANT'=> "\1F346}", 'CHARACTER_POTATO'=> "\1F954}", 'CHARACTER_CARROT'=> "\1F955}", 'CHARACTER_EAR_OF_CORN'=> "\1F33D}", 'CHARACTER_HOT_PEPPER'=> "\1F336}\FE0F}", 'CHARACTER_CUCUMBER'=> "\1F952}", 'CHARACTER_LEAFY_GREEN'=> "\1F96C}", 'CHARACTER_BROCCOLI'=> "\1F966}", 'CHARACTER_MUSHROOM'=> "\1F344}", 'CHARACTER_PEANUTS'=> "\1F95C}", 'CHARACTER_CHESTNUT'=> "\1F330}", 'CHARACTER_BREAD'=> "\1F35E}", 'CHARACTER_CROISSANT'=> "\1F950}", 'CHARACTER_BAGUETTE_BREAD'=> "\1F956}", 'CHARACTER_PRETZEL'=> "\1F968}", 'CHARACTER_BAGEL'=> "\1F96F}", 'CHARACTER_PANCAKES'=> "\1F95E}", 'CHARACTER_CHEESE_WEDGE'=> "\1F9C0}", 'CHARACTER_MEAT_ON_BONE'=> "\1F356}", 'CHARACTER_POULTRY_LEG'=> "\1F357}", 'CHARACTER_CUT_OF_MEAT'=> "\1F969}", 'CHARACTER_BACON'=> "\1F953}", 'CHARACTER_HAMBURGER'=> "\1F354}", 'CHARACTER_FRENCH_FRIES'=> "\1F35F}", 'CHARACTER_PIZZA'=> "\1F355}", 'CHARACTER_HOT_DOG'=> "\1F32D}", 'CHARACTER_SANDWICH'=> "\1F96A}", 'CHARACTER_TACO'=> "\1F32E}", 'CHARACTER_BURRITO'=> "\1F32F}", 'CHARACTER_STUFFED_FLATBREAD'=> "\1F959}", 'CHARACTER_EGG'=> "\1F95A}", 'CHARACTER_COOKING'=> "\1F373}", 'CHARACTER_SHALLOW_PAN_OF_FOOD'=> "\1F958}", 'CHARACTER_POT_OF_FOOD'=> "\1F372}", 'CHARACTER_BOWL_WITH_SPOON'=> "\1F963}", 'CHARACTER_GREEN_SALAD'=> "\1F957}", 'CHARACTER_POPCORN'=> "\1F37F}", 'CHARACTER_SALT'=> "\1F9C2}", 'CHARACTER_CANNED_FOOD'=> "\1F96B}", 'CHARACTER_BENTO_BOX'=> "\1F371}", 'CHARACTER_RICE_CRACKER'=> "\1F358}", 'CHARACTER_RICE_BALL'=> "\1F359}", 'CHARACTER_COOKED_RICE'=> "\1F35A}", 'CHARACTER_CURRY_RICE'=> "\1F35B}", 'CHARACTER_STEAMING_BOWL'=> "\1F35C}", 'CHARACTER_SPAGHETTI'=> "\1F35D}", 'CHARACTER_ROASTED_SWEET_POTATO'=> "\1F360}", 'CHARACTER_ODEN'=> "\1F362}", 'CHARACTER_SUSHI'=> "\1F363}", 'CHARACTER_FRIED_SHRIMP'=> "\1F364}", 'CHARACTER_FISH_CAKE_WITH_SWIRL'=> "\1F365}", 'CHARACTER_MOON_CAKE'=> "\1F96E}", 'CHARACTER_DANGO'=> "\1F361}", 'CHARACTER_DUMPLING'=> "\1F95F}", 'CHARACTER_FORTUNE_COOKIE'=> "\1F960}", 'CHARACTER_TAKEOUT_BOX'=> "\1F961}", 'CHARACTER_SOFT_ICE_CREAM'=> "\1F366}", 'CHARACTER_SHAVED_ICE'=> "\1F367}", 'CHARACTER_ICE_CREAM'=> "\1F368}", 'CHARACTER_DOUGHNUT'=> "\1F369}", 'CHARACTER_COOKIE'=> "\1F36A}", 'CHARACTER_BIRTHDAY_CAKE'=> "\1F382}", 'CHARACTER_SHORTCAKE'=> "\1F370}", 'CHARACTER_CUPCAKE'=> "\1F9C1}", 'CHARACTER_PIE'=> "\1F967}", 'CHARACTER_CHOCOLATE_BAR'=> "\1F36B}", 'CHARACTER_CANDY'=> "\1F36C}", 'CHARACTER_LOLLIPOP'=> "\1F36D}", 'CHARACTER_CUSTARD'=> "\1F36E}", 'CHARACTER_HONEY_POT'=> "\1F36F}", 'CHARACTER_BABY_BOTTLE'=> "\1F37C}", 'CHARACTER_GLASS_OF_MILK'=> "\1F95B}", 'CHARACTER_HOT_BEVERAGE'=> "\2615}", 'CHARACTER_TEACUP_WITHOUT_HANDLE'=> "\1F375}", 'CHARACTER_SAKE'=> "\1F376}", 'CHARACTER_BOTTLE_WITH_POPPING_CORK'=> "\1F37E}", 'CHARACTER_WINE_GLASS'=> "\1F377}", 'CHARACTER_COCKTAIL_GLASS'=> "\1F378}", 'CHARACTER_TROPICAL_DRINK'=> "\1F379}", 'CHARACTER_BEER_MUG'=> "\1F37A}", 'CHARACTER_CLINKING_BEER_MUGS'=> "\1F37B}", 'CHARACTER_CLINKING_GLASSES'=> "\1F942}", 'CHARACTER_TUMBLER_GLASS'=> "\1F943}", 'CHARACTER_CUP_WITH_STRAW'=> "\1F964}", 'CHARACTER_CHOPSTICKS'=> "\1F962}", 'CHARACTER_FORK_AND_KNIFE_WITH_PLATE'=> "\1F37D}\FE0F}", 'CHARACTER_FORK_AND_KNIFE'=> "\1F374}", 'CHARACTER_SPOON'=> "\1F944}", 'CHARACTER_KITCHEN_KNIFE'=> "\1F52A}", 'CHARACTER_AMPHORA'=> "\1F3FA}", 'CHARACTER_GLOBE_SHOWING_EUROPE_AFRICA'=> "\1F30D}", 'CHARACTER_GLOBE_SHOWING_AMERICAS'=> "\1F30E}", 'CHARACTER_GLOBE_SHOWING_ASIA_AUSTRALIA'=> "\1F30F}", 'CHARACTER_GLOBE_WITH_MERIDIANS'=> "\1F310}", 'CHARACTER_WORLD_MAP'=> "\1F5FA}\FE0F}", 'CHARACTER_MAP_OF_JAPAN'=> "\1F5FE}", 'CHARACTER_COMPASS'=> "\1F9ED}", 'CHARACTER_SNOW_CAPPED_MOUNTAIN'=> "\1F3D4}\FE0F}", 'CHARACTER_MOUNTAIN'=> "\26F0}\FE0F}", 'CHARACTER_VOLCANO'=> "\1F30B}", 'CHARACTER_MOUNT_FUJI'=> "\1F5FB}", 'CHARACTER_CAMPING'=> "\1F3D5}\FE0F}", 'CHARACTER_BEACH_WITH_UMBRELLA'=> "\1F3D6}\FE0F}", 'CHARACTER_DESERT'=> "\1F3DC}\FE0F}", 'CHARACTER_DESERT_ISLAND'=> "\1F3DD}\FE0F}", 'CHARACTER_NATIONAL_PARK'=> "\1F3DE}\FE0F}", 'CHARACTER_STADIUM'=> "\1F3DF}\FE0F}", 'CHARACTER_CLASSICAL_BUILDING'=> "\1F3DB}\FE0F}", 'CHARACTER_BUILDING_CONSTRUCTION'=> "\1F3D7}\FE0F}", 'CHARACTER_BRICKS'=> "\1F9F1}", 'CHARACTER_HOUSES'=> "\1F3D8}\FE0F}", 'CHARACTER_DERELICT_HOUSE'=> "\1F3DA}\FE0F}", 'CHARACTER_HOUSE'=> "\1F3E0}", 'CHARACTER_HOUSE_WITH_GARDEN'=> "\1F3E1}", 'CHARACTER_OFFICE_BUILDING'=> "\1F3E2}", 'CHARACTER_JAPANESE_POST_OFFICE'=> "\1F3E3}", 'CHARACTER_POST_OFFICE'=> "\1F3E4}", 'CHARACTER_HOSPITAL'=> "\1F3E5}", 'CHARACTER_BANK'=> "\1F3E6}", 'CHARACTER_HOTEL'=> "\1F3E8}", 'CHARACTER_LOVE_HOTEL'=> "\1F3E9}", 'CHARACTER_CONVENIENCE_STORE'=> "\1F3EA}", 'CHARACTER_SCHOOL'=> "\1F3EB}", 'CHARACTER_DEPARTMENT_STORE'=> "\1F3EC}", 'CHARACTER_FACTORY'=> "\1F3ED}", 'CHARACTER_JAPANESE_CASTLE'=> "\1F3EF}", 'CHARACTER_CASTLE'=> "\1F3F0}", 'CHARACTER_WEDDING'=> "\1F492}", 'CHARACTER_TOKYO_TOWER'=> "\1F5FC}", 'CHARACTER_STATUE_OF_LIBERTY'=> "\1F5FD}", 'CHARACTER_CHURCH'=> "\26EA}", 'CHARACTER_MOSQUE'=> "\1F54C}", 'CHARACTER_SYNAGOGUE'=> "\1F54D}", 'CHARACTER_SHINTO_SHRINE'=> "\26E9}\FE0F}", 'CHARACTER_KAABA'=> "\1F54B}", 'CHARACTER_FOUNTAIN'=> "\26F2}", 'CHARACTER_TENT'=> "\26FA}", 'CHARACTER_FOGGY'=> "\1F301}", 'CHARACTER_NIGHT_WITH_STARS'=> "\1F303}", 'CHARACTER_CITYSCAPE'=> "\1F3D9}\FE0F}", 'CHARACTER_SUNRISE_OVER_MOUNTAINS'=> "\1F304}", 'CHARACTER_SUNRISE'=> "\1F305}", 'CHARACTER_CITYSCAPE_AT_DUSK'=> "\1F306}", 'CHARACTER_SUNSET'=> "\1F307}", 'CHARACTER_BRIDGE_AT_NIGHT'=> "\1F309}", 'CHARACTER_HOT_SPRINGS'=> "\2668}\FE0F}", 'CHARACTER_MILKY_WAY'=> "\1F30C}", 'CHARACTER_CAROUSEL_HORSE'=> "\1F3A0}", 'CHARACTER_FERRIS_WHEEL'=> "\1F3A1}", 'CHARACTER_ROLLER_COASTER'=> "\1F3A2}", 'CHARACTER_BARBER_POLE'=> "\1F488}", 'CHARACTER_CIRCUS_TENT'=> "\1F3AA}", 'CHARACTER_LOCOMOTIVE'=> "\1F682}", 'CHARACTER_RAILWAY_CAR'=> "\1F683}", 'CHARACTER_HIGH_SPEED_TRAIN'=> "\1F684}", 'CHARACTER_BULLET_TRAIN'=> "\1F685}", 'CHARACTER_TRAIN'=> "\1F686}", 'CHARACTER_METRO'=> "\1F687}", 'CHARACTER_LIGHT_RAIL'=> "\1F688}", 'CHARACTER_STATION'=> "\1F689}", 'CHARACTER_TRAM'=> "\1F68A}", 'CHARACTER_MONORAIL'=> "\1F69D}", 'CHARACTER_MOUNTAIN_RAILWAY'=> "\1F69E}", 'CHARACTER_TRAM_CAR'=> "\1F68B}", 'CHARACTER_BUS'=> "\1F68C}", 'CHARACTER_ONCOMING_BUS'=> "\1F68D}", 'CHARACTER_TROLLEYBUS'=> "\1F68E}", 'CHARACTER_MINIBUS'=> "\1F690}", 'CHARACTER_AMBULANCE'=> "\1F691}", 'CHARACTER_FIRE_ENGINE'=> "\1F692}", 'CHARACTER_POLICE_CAR'=> "\1F693}", 'CHARACTER_ONCOMING_POLICE_CAR'=> "\1F694}", 'CHARACTER_TAXI'=> "\1F695}", 'CHARACTER_ONCOMING_TAXI'=> "\1F696}", 'CHARACTER_AUTOMOBILE'=> "\1F697}", 'CHARACTER_ONCOMING_AUTOMOBILE'=> "\1F698}", 'CHARACTER_SPORT_UTILITY_VEHICLE'=> "\1F699}", 'CHARACTER_DELIVERY_TRUCK'=> "\1F69A}", 'CHARACTER_ARTICULATED_LORRY'=> "\1F69B}", 'CHARACTER_TRACTOR'=> "\1F69C}", 'CHARACTER_BICYCLE'=> "\1F6B2}", 'CHARACTER_KICK_SCOOTER'=> "\1F6F4}", 'CHARACTER_SKATEBOARD'=> "\1F6F9}", 'CHARACTER_MOTOR_SCOOTER'=> "\1F6F5}", 'CHARACTER_BUS_STOP'=> "\1F68F}", 'CHARACTER_MOTORWAY'=> "\1F6E3}\FE0F}", 'CHARACTER_RAILWAY_TRACK'=> "\1F6E4}\FE0F}", 'CHARACTER_OIL_DRUM'=> "\1F6E2}\FE0F}", 'CHARACTER_FUEL_PUMP'=> "\26FD}", 'CHARACTER_POLICE_CAR_LIGHT'=> "\1F6A8}", 'CHARACTER_HORIZONTAL_TRAFFIC_LIGHT'=> "\1F6A5}", 'CHARACTER_VERTICAL_TRAFFIC_LIGHT'=> "\1F6A6}", 'CHARACTER_STOP_SIGN'=> "\1F6D1}", 'CHARACTER_CONSTRUCTION'=> "\1F6A7}", 'CHARACTER_ANCHOR'=> "\2693}", 'CHARACTER_SAILBOAT'=> "\26F5}", 'CHARACTER_CANOE'=> "\1F6F6}", 'CHARACTER_SPEEDBOAT'=> "\1F6A4}", 'CHARACTER_PASSENGER_SHIP'=> "\1F6F3}\FE0F}", 'CHARACTER_FERRY'=> "\26F4}\FE0F}", 'CHARACTER_MOTOR_BOAT'=> "\1F6E5}\FE0F}", 'CHARACTER_SHIP'=> "\1F6A2}", 'CHARACTER_AIRPLANE'=> "\2708}\FE0F}", 'CHARACTER_SMALL_AIRPLANE'=> "\1F6E9}\FE0F}", 'CHARACTER_AIRPLANE_DEPARTURE'=> "\1F6EB}", 'CHARACTER_AIRPLANE_ARRIVAL'=> "\1F6EC}", 'CHARACTER_SEAT'=> "\1F4BA}", 'CHARACTER_HELICOPTER'=> "\1F681}", 'CHARACTER_SUSPENSION_RAILWAY'=> "\1F69F}", 'CHARACTER_MOUNTAIN_CABLEWAY'=> "\1F6A0}", 'CHARACTER_AERIAL_TRAMWAY'=> "\1F6A1}", 'CHARACTER_SATELLITE'=> "\1F6F0}\FE0F}", 'CHARACTER_ROCKET'=> "\1F680}", 'CHARACTER_FLYING_SAUCER'=> "\1F6F8}", 'CHARACTER_BELLHOP_BELL'=> "\1F6CE}\FE0F}", 'CHARACTER_LUGGAGE'=> "\1F9F3}", 'CHARACTER_HOURGLASS_DONE'=> "\231B}", 'CHARACTER_HOURGLASS_NOT_DONE'=> "\23F3}", 'CHARACTER_WATCH'=> "\231A}", 'CHARACTER_ALARM_CLOCK'=> "\23F0}", 'CHARACTER_STOPWATCH'=> "\23F1}\FE0F}", 'CHARACTER_TIMER_CLOCK'=> "\23F2}\FE0F}", 'CHARACTER_MANTELPIECE_CLOCK'=> "\1F570}\FE0F}", 'CHARACTER_TWELVE_O_CLOCK'=> "\1F55B}", 'CHARACTER_TWELVE_THIRTY'=> "\1F567}", 'CHARACTER_ONE_O_CLOCK'=> "\1F550}", 'CHARACTER_ONE_THIRTY'=> "\1F55C}", 'CHARACTER_TWO_O_CLOCK'=> "\1F551}", 'CHARACTER_TWO_THIRTY'=> "\1F55D}", 'CHARACTER_THREE_O_CLOCK'=> "\1F552}", 'CHARACTER_THREE_THIRTY'=> "\1F55E}", 'CHARACTER_FOUR_O_CLOCK'=> "\1F553}", 'CHARACTER_FOUR_THIRTY'=> "\1F55F}", 'CHARACTER_FIVE_O_CLOCK'=> "\1F554}", 'CHARACTER_FIVE_THIRTY'=> "\1F560}", 'CHARACTER_SIX_O_CLOCK'=> "\1F555}", 'CHARACTER_SIX_THIRTY'=> "\1F561}", 'CHARACTER_SEVEN_O_CLOCK'=> "\1F556}", 'CHARACTER_SEVEN_THIRTY'=> "\1F562}", 'CHARACTER_EIGHT_O_CLOCK'=> "\1F557}", 'CHARACTER_EIGHT_THIRTY'=> "\1F563}", 'CHARACTER_NINE_O_CLOCK'=> "\1F558}", 'CHARACTER_NINE_THIRTY'=> "\1F564}", 'CHARACTER_TEN_O_CLOCK'=> "\1F559}", 'CHARACTER_TEN_THIRTY'=> "\1F565}", 'CHARACTER_ELEVEN_O_CLOCK'=> "\1F55A}", 'CHARACTER_ELEVEN_THIRTY'=> "\1F566}", 'CHARACTER_NEW_MOON'=> "\1F311}", 'CHARACTER_WAXING_CRESCENT_MOON'=> "\1F312}", 'CHARACTER_FIRST_QUARTER_MOON'=> "\1F313}", 'CHARACTER_WAXING_GIBBOUS_MOON'=> "\1F314}", 'CHARACTER_FULL_MOON'=> "\1F315}", 'CHARACTER_WANING_GIBBOUS_MOON'=> "\1F316}", 'CHARACTER_LAST_QUARTER_MOON'=> "\1F317}", 'CHARACTER_WANING_CRESCENT_MOON'=> "\1F318}", 'CHARACTER_CRESCENT_MOON'=> "\1F319}", 'CHARACTER_NEW_MOON_FACE'=> "\1F31A}", 'CHARACTER_FIRST_QUARTER_MOON_FACE'=> "\1F31B}", 'CHARACTER_LAST_QUARTER_MOON_FACE'=> "\1F31C}", 'CHARACTER_THERMOMETER'=> "\1F321}\FE0F}", 'CHARACTER_SUN'=> "\2600}\FE0F}", 'CHARACTER_FULL_MOON_FACE'=> "\1F31D}", 'CHARACTER_SUN_WITH_FACE'=> "\1F31E}", 'CHARACTER_STAR'=> "\2B50}", 'CHARACTER_GLOWING_STAR'=> "\1F31F}", 'CHARACTER_SHOOTING_STAR'=> "\1F320}", 'CHARACTER_CLOUD'=> "\2601}\FE0F}", 'CHARACTER_SUN_BEHIND_CLOUD'=> "\26C5}", 'CHARACTER_CLOUD_WITH_LIGHTNING_AND_RAIN'=> "\26C8}\FE0F}", 'CHARACTER_SUN_BEHIND_SMALL_CLOUD'=> "\1F324}\FE0F}", 'CHARACTER_SUN_BEHIND_LARGE_CLOUD'=> "\1F325}\FE0F}", 'CHARACTER_SUN_BEHIND_RAIN_CLOUD'=> "\1F326}\FE0F}", 'CHARACTER_CLOUD_WITH_RAIN'=> "\1F327}\FE0F}", 'CHARACTER_CLOUD_WITH_SNOW'=> "\1F328}\FE0F}", 'CHARACTER_CLOUD_WITH_LIGHTNING'=> "\1F329}\FE0F}", 'CHARACTER_TORNADO'=> "\1F32A}\FE0F}", 'CHARACTER_FOG'=> "\1F32B}\FE0F}", 'CHARACTER_WIND_FACE'=> "\1F32C}\FE0F}", 'CHARACTER_CYCLONE'=> "\1F300}", 'CHARACTER_RAINBOW'=> "\1F308}", 'CHARACTER_CLOSED_UMBRELLA'=> "\1F302}", 'CHARACTER_UMBRELLA'=> "\2602}\FE0F}", 'CHARACTER_UMBRELLA_WITH_RAIN_DROPS'=> "\2614}", 'CHARACTER_UMBRELLA_ON_GROUND'=> "\26F1}\FE0F}", 'CHARACTER_HIGH_VOLTAGE'=> "\26A1}", 'CHARACTER_SNOWFLAKE'=> "\2744}\FE0F}", 'CHARACTER_SNOWMAN'=> "\2603}\FE0F}", 'CHARACTER_SNOWMAN_WITHOUT_SNOW'=> "\26C4}", 'CHARACTER_COMET'=> "\2604}\FE0F}", 'CHARACTER_FIRE'=> "\1F525}", 'CHARACTER_DROPLET'=> "\1F4A7}", 'CHARACTER_WATER_WAVE'=> "\1F30A}", 'CHARACTER_JACK_O_LANTERN'=> "\1F383}", 'CHARACTER_CHRISTMAS_TREE'=> "\1F384}", 'CHARACTER_FIREWORKS'=> "\1F386}", 'CHARACTER_SPARKLER'=> "\1F387}", 'CHARACTER_FIRECRACKER'=> "\1F9E8}", 'CHARACTER_SPARKLES'=> "\2728}", 'CHARACTER_BALLOON'=> "\1F388}", 'CHARACTER_PARTY_POPPER'=> "\1F389}", 'CHARACTER_CONFETTI_BALL'=> "\1F38A}", 'CHARACTER_TANABATA_TREE'=> "\1F38B}", 'CHARACTER_PINE_DECORATION'=> "\1F38D}", 'CHARACTER_JAPANESE_DOLLS'=> "\1F38E}", 'CHARACTER_CARP_STREAMER'=> "\1F38F}", 'CHARACTER_WIND_CHIME'=> "\1F390}", 'CHARACTER_MOON_VIEWING_CEREMONY'=> "\1F391}", 'CHARACTER_RED_ENVELOPE'=> "\1F9E7}", 'CHARACTER_RIBBON'=> "\1F380}", 'CHARACTER_WRAPPED_GIFT'=> "\1F381}", 'CHARACTER_REMINDER_RIBBON'=> "\1F397}\FE0F}", 'CHARACTER_ADMISSION_TICKETS'=> "\1F39F}\FE0F}", 'CHARACTER_TICKET'=> "\1F3AB}", 'CHARACTER_MILITARY_MEDAL'=> "\1F396}\FE0F}", 'CHARACTER_TROPHY'=> "\1F3C6}", 'CHARACTER_SPORTS_MEDAL'=> "\1F3C5}", 'CHARACTER_1ST_PLACE_MEDAL'=> "\1F947}", 'CHARACTER_2ND_PLACE_MEDAL'=> "\1F948}", 'CHARACTER_3RD_PLACE_MEDAL'=> "\1F949}", 'CHARACTER_SOCCER_BALL'=> "\26BD}", 'CHARACTER_BASEBALL'=> "\26BE}", 'CHARACTER_SOFTBALL'=> "\1F94E}", 'CHARACTER_BASKETBALL'=> "\1F3C0}", 'CHARACTER_VOLLEYBALL'=> "\1F3D0}", 'CHARACTER_AMERICAN_FOOTBALL'=> "\1F3C8}", 'CHARACTER_RUGBY_FOOTBALL'=> "\1F3C9}", 'CHARACTER_TENNIS'=> "\1F3BE}", 'CHARACTER_FLYING_DISC'=> "\1F94F}", 'CHARACTER_BOWLING'=> "\1F3B3}", 'CHARACTER_CRICKET_GAME'=> "\1F3CF}", 'CHARACTER_FIELD_HOCKEY'=> "\1F3D1}", 'CHARACTER_ICE_HOCKEY'=> "\1F3D2}", 'CHARACTER_LACROSSE'=> "\1F94D}", 'CHARACTER_PING_PONG'=> "\1F3D3}", 'CHARACTER_BADMINTON'=> "\1F3F8}", 'CHARACTER_BOXING_GLOVE'=> "\1F94A}", 'CHARACTER_MARTIAL_ARTS_UNIFORM'=> "\1F94B}", 'CHARACTER_GOAL_NET'=> "\1F945}", 'CHARACTER_FLAG_IN_HOLE'=> "\26F3}", 'CHARACTER_ICE_SKATE'=> "\26F8}\FE0F}", 'CHARACTER_FISHING_POLE'=> "\1F3A3}", 'CHARACTER_RUNNING_SHIRT'=> "\1F3BD}", 'CHARACTER_SKIS'=> "\1F3BF}", 'CHARACTER_SLED'=> "\1F6F7}", 'CHARACTER_CURLING_STONE'=> "\1F94C}", 'CHARACTER_DIRECT_HIT'=> "\1F3AF}", 'CHARACTER_POOL_8_BALL'=> "\1F3B1}", 'CHARACTER_CRYSTAL_BALL'=> "\1F52E}", 'CHARACTER_NAZAR_AMULET'=> "\1F9FF}", 'CHARACTER_VIDEO_GAME'=> "\1F3AE}", 'CHARACTER_JOYSTICK'=> "\1F579}\FE0F}", 'CHARACTER_SLOT_MACHINE'=> "\1F3B0}", 'CHARACTER_GAME_DIE'=> "\1F3B2}", 'CHARACTER_JIGSAW'=> "\1F9E9}", 'CHARACTER_TEDDY_BEAR'=> "\1F9F8}", 'CHARACTER_SPADE_SUIT'=> "\2660}\FE0F}", 'CHARACTER_HEART_SUIT'=> "\2665}\FE0F}", 'CHARACTER_DIAMOND_SUIT'=> "\2666}\FE0F}", 'CHARACTER_CLUB_SUIT'=> "\2663}\FE0F}", 'CHARACTER_CHESS_PAWN'=> "\265F}\FE0F}", 'CHARACTER_JOKER'=> "\1F0CF}", 'CHARACTER_MAHJONG_RED_DRAGON'=> "\1F004}", 'CHARACTER_FLOWER_PLAYING_CARDS'=> "\1F3B4}", 'CHARACTER_PERFORMING_ARTS'=> "\1F3AD}", 'CHARACTER_FRAMED_PICTURE'=> "\1F5BC}\FE0F}", 'CHARACTER_ARTIST_PALETTE'=> "\1F3A8}", 'CHARACTER_THREAD'=> "\1F9F5}", 'CHARACTER_YARN'=> "\1F9F6}", 'CHARACTER_MUTED_SPEAKER'=> "\1F507}", 'CHARACTER_SPEAKER_LOW_VOLUME'=> "\1F508}", 'CHARACTER_SPEAKER_MEDIUM_VOLUME'=> "\1F509}", 'CHARACTER_SPEAKER_HIGH_VOLUME'=> "\1F50A}", 'CHARACTER_LOUDSPEAKER'=> "\1F4E2}", 'CHARACTER_MEGAPHONE'=> "\1F4E3}", 'CHARACTER_POSTAL_HORN'=> "\1F4EF}", 'CHARACTER_BELL'=> "\1F514}", 'CHARACTER_BELL_WITH_SLASH'=> "\1F515}", 'CHARACTER_MUSICAL_SCORE'=> "\1F3BC}", 'CHARACTER_MUSICAL_NOTE'=> "\1F3B5}", 'CHARACTER_MUSICAL_NOTES'=> "\1F3B6}", 'CHARACTER_STUDIO_MICROPHONE'=> "\1F399}\FE0F}", 'CHARACTER_LEVEL_SLIDER'=> "\1F39A}\FE0F}", 'CHARACTER_CONTROL_KNOBS'=> "\1F39B}\FE0F}", 'CHARACTER_MICROPHONE'=> "\1F3A4}", 'CHARACTER_HEADPHONE'=> "\1F3A7}", 'CHARACTER_RADIO'=> "\1F4FB}", 'CHARACTER_SAXOPHONE'=> "\1F3B7}", 'CHARACTER_GUITAR'=> "\1F3B8}", 'CHARACTER_MUSICAL_KEYBOARD'=> "\1F3B9}", 'CHARACTER_TRUMPET'=> "\1F3BA}", 'CHARACTER_VIOLIN'=> "\1F3BB}", 'CHARACTER_DRUM'=> "\1F941}", 'CHARACTER_MOBILE_PHONE'=> "\1F4F1}", 'CHARACTER_MOBILE_PHONE_WITH_ARROW'=> "\1F4F2}", 'CHARACTER_TELEPHONE'=> "\260E}\FE0F}", 'CHARACTER_TELEPHONE_RECEIVER'=> "\1F4DE}", 'CHARACTER_PAGER'=> "\1F4DF}", 'CHARACTER_FAX_MACHINE'=> "\1F4E0}", 'CHARACTER_BATTERY'=> "\1F50B}", 'CHARACTER_ELECTRIC_PLUG'=> "\1F50C}", 'CHARACTER_LAPTOP_COMPUTER'=> "\1F4BB}", 'CHARACTER_DESKTOP_COMPUTER'=> "\1F5A5}\FE0F}", 'CHARACTER_PRINTER'=> "\1F5A8}\FE0F}", 'CHARACTER_KEYBOARD'=> "\2328}\FE0F}", 'CHARACTER_COMPUTER_MOUSE'=> "\1F5B1}\FE0F}", 'CHARACTER_TRACKBALL'=> "\1F5B2}\FE0F}", 'CHARACTER_COMPUTER_DISK'=> "\1F4BD}", 'CHARACTER_FLOPPY_DISK'=> "\1F4BE}", 'CHARACTER_OPTICAL_DISK'=> "\1F4BF}", 'CHARACTER_DVD'=> "\1F4C0}", 'CHARACTER_ABACUS'=> "\1F9EE}", 'CHARACTER_MOVIE_CAMERA'=> "\1F3A5}", 'CHARACTER_FILM_FRAMES'=> "\1F39E}\FE0F}", 'CHARACTER_FILM_PROJECTOR'=> "\1F4FD}\FE0F}", 'CHARACTER_CLAPPER_BOARD'=> "\1F3AC}", 'CHARACTER_TELEVISION'=> "\1F4FA}", 'CHARACTER_CAMERA'=> "\1F4F7}", 'CHARACTER_CAMERA_WITH_FLASH'=> "\1F4F8}", 'CHARACTER_VIDEO_CAMERA'=> "\1F4F9}", 'CHARACTER_VIDEOCASSETTE'=> "\1F4FC}", 'CHARACTER_MAGNIFYING_GLASS_TILTED_LEFT'=> "\1F50D}", 'CHARACTER_MAGNIFYING_GLASS_TILTED_RIGHT'=> "\1F50E}", 'CHARACTER_CANDLE'=> "\1F56F}\FE0F}", 'CHARACTER_LIGHT_BULB'=> "\1F4A1}", 'CHARACTER_FLASHLIGHT'=> "\1F526}", 'CHARACTER_RED_PAPER_LANTERN'=> "\1F3EE}", 'CHARACTER_NOTEBOOK_WITH_DECORATIVE_COVER'=> "\1F4D4}", 'CHARACTER_CLOSED_BOOK'=> "\1F4D5}", 'CHARACTER_OPEN_BOOK'=> "\1F4D6}", 'CHARACTER_GREEN_BOOK'=> "\1F4D7}", 'CHARACTER_BLUE_BOOK'=> "\1F4D8}", 'CHARACTER_ORANGE_BOOK'=> "\1F4D9}", 'CHARACTER_BOOKS'=> "\1F4DA}", 'CHARACTER_NOTEBOOK'=> "\1F4D3}", 'CHARACTER_LEDGER'=> "\1F4D2}", 'CHARACTER_PAGE_WITH_CURL'=> "\1F4C3}", 'CHARACTER_SCROLL'=> "\1F4DC}", 'CHARACTER_PAGE_FACING_UP'=> "\1F4C4}", 'CHARACTER_NEWSPAPER'=> "\1F4F0}", 'CHARACTER_ROLLED_UP_NEWSPAPER'=> "\1F5DE}\FE0F}", 'CHARACTER_BOOKMARK_TABS'=> "\1F4D1}", 'CHARACTER_BOOKMARK'=> "\1F516}", 'CHARACTER_LABEL'=> "\1F3F7}\FE0F}", 'CHARACTER_MONEY_BAG'=> "\1F4B0}", 'CHARACTER_YEN_BANKNOTE'=> "\1F4B4}", 'CHARACTER_DOLLAR_BANKNOTE'=> "\1F4B5}", 'CHARACTER_EURO_BANKNOTE'=> "\1F4B6}", 'CHARACTER_POUND_BANKNOTE'=> "\1F4B7}", 'CHARACTER_MONEY_WITH_WINGS'=> "\1F4B8}", 'CHARACTER_CREDIT_CARD'=> "\1F4B3}", 'CHARACTER_RECEIPT'=> "\1F9FE}", 'CHARACTER_CHART_INCREASING_WITH_YEN'=> "\1F4B9}", 'CHARACTER_CURRENCY_EXCHANGE'=> "\1F4B1}", 'CHARACTER_HEAVY_DOLLAR_SIGN'=> "\1F4B2}", 'CHARACTER_ENVELOPE'=> "\2709}\FE0F}", 'CHARACTER_E_MAIL'=> "\1F4E7}", 'CHARACTER_INCOMING_ENVELOPE'=> "\1F4E8}", 'CHARACTER_ENVELOPE_WITH_ARROW'=> "\1F4E9}", 'CHARACTER_OUTBOX_TRAY'=> "\1F4E4}", 'CHARACTER_INBOX_TRAY'=> "\1F4E5}", 'CHARACTER_PACKAGE'=> "\1F4E6}", 'CHARACTER_CLOSED_MAILBOX_WITH_RAISED_FLAG'=> "\1F4EB}", 'CHARACTER_CLOSED_MAILBOX_WITH_LOWERED_FLAG'=> "\1F4EA}", 'CHARACTER_OPEN_MAILBOX_WITH_RAISED_FLAG'=> "\1F4EC}", 'CHARACTER_OPEN_MAILBOX_WITH_LOWERED_FLAG'=> "\1F4ED}", 'CHARACTER_POSTBOX'=> "\1F4EE}", 'CHARACTER_BALLOT_BOX_WITH_BALLOT'=> "\1F5F3}\FE0F}", 'CHARACTER_PENCIL'=> "\270F}\FE0F}", 'CHARACTER_BLACK_NIB'=> "\2712}\FE0F}", 'CHARACTER_FOUNTAIN_PEN'=> "\1F58B}\FE0F}", 'CHARACTER_PEN'=> "\1F58A}\FE0F}", 'CHARACTER_PAINTBRUSH'=> "\1F58C}\FE0F}", 'CHARACTER_CRAYON'=> "\1F58D}\FE0F}", 'CHARACTER_MEMO'=> "\1F4DD}", 'CHARACTER_BRIEFCASE'=> "\1F4BC}", 'CHARACTER_FILE_FOLDER'=> "\1F4C1}", 'CHARACTER_OPEN_FILE_FOLDER'=> "\1F4C2}", 'CHARACTER_CARD_INDEX_DIVIDERS'=> "\1F5C2}\FE0F}", 'CHARACTER_CALENDAR'=> "\1F4C5}", 'CHARACTER_TEAR_OFF_CALENDAR'=> "\1F4C6}", 'CHARACTER_SPIRAL_NOTEPAD'=> "\1F5D2}\FE0F}", 'CHARACTER_SPIRAL_CALENDAR'=> "\1F5D3}\FE0F}", 'CHARACTER_CARD_INDEX'=> "\1F4C7}", 'CHARACTER_CHART_INCREASING'=> "\1F4C8}", 'CHARACTER_CHART_DECREASING'=> "\1F4C9}", 'CHARACTER_BAR_CHART'=> "\1F4CA}", 'CHARACTER_CLIPBOARD'=> "\1F4CB}", 'CHARACTER_PUSHPIN'=> "\1F4CC}", 'CHARACTER_ROUND_PUSHPIN'=> "\1F4CD}", 'CHARACTER_PAPERCLIP'=> "\1F4CE}", 'CHARACTER_LINKED_PAPERCLIPS'=> "\1F587}\FE0F}", 'CHARACTER_STRAIGHT_RULER'=> "\1F4CF}", 'CHARACTER_TRIANGULAR_RULER'=> "\1F4D0}", 'CHARACTER_SCISSORS'=> "\2702}\FE0F}", 'CHARACTER_CARD_FILE_BOX'=> "\1F5C3}\FE0F}", 'CHARACTER_FILE_CABINET'=> "\1F5C4}\FE0F}", 'CHARACTER_WASTEBASKET'=> "\1F5D1}\FE0F}", 'CHARACTER_LOCKED'=> "\1F512}", 'CHARACTER_UNLOCKED'=> "\1F513}", 'CHARACTER_LOCKED_WITH_PEN'=> "\1F50F}", 'CHARACTER_LOCKED_WITH_KEY'=> "\1F510}", 'CHARACTER_KEY'=> "\1F511}", 'CHARACTER_OLD_KEY'=> "\1F5DD}\FE0F}", 'CHARACTER_HAMMER'=> "\1F528}", 'CHARACTER_PICK'=> "\26CF}\FE0F}", 'CHARACTER_HAMMER_AND_PICK'=> "\2692}\FE0F}", 'CHARACTER_HAMMER_AND_WRENCH'=> "\1F6E0}\FE0F}", 'CHARACTER_DAGGER'=> "\1F5E1}\FE0F}", 'CHARACTER_CROSSED_SWORDS'=> "\2694}\FE0F}", 'CHARACTER_PISTOL'=> "\1F52B}", 'CHARACTER_BOW_AND_ARROW'=> "\1F3F9}", 'CHARACTER_SHIELD'=> "\1F6E1}\FE0F}", 'CHARACTER_WRENCH'=> "\1F527}", 'CHARACTER_NUT_AND_BOLT'=> "\1F529}", 'CHARACTER_GEAR'=> "\2699}\FE0F}", 'CHARACTER_CLAMP'=> "\1F5DC}\FE0F}", 'CHARACTER_BALANCE_SCALE'=> "\2696}\FE0F}", 'CHARACTER_LINK'=> "\1F517}", 'CHARACTER_CHAINS'=> "\26D3}\FE0F}", 'CHARACTER_TOOLBOX'=> "\1F9F0}", 'CHARACTER_MAGNET'=> "\1F9F2}", 'CHARACTER_ALEMBIC'=> "\2697}\FE0F}", 'CHARACTER_TEST_TUBE'=> "\1F9EA}", 'CHARACTER_PETRI_DISH'=> "\1F9EB}", 'CHARACTER_DNA'=> "\1F9EC}", 'CHARACTER_MICROSCOPE'=> "\1F52C}", 'CHARACTER_TELESCOPE'=> "\1F52D}", 'CHARACTER_SATELLITE_ANTENNA'=> "\1F4E1}", 'CHARACTER_SYRINGE'=> "\1F489}", 'CHARACTER_PILL'=> "\1F48A}", 'CHARACTER_DOOR'=> "\1F6AA}", 'CHARACTER_BED'=> "\1F6CF}\FE0F}", 'CHARACTER_COUCH_AND_LAMP'=> "\1F6CB}\FE0F}", 'CHARACTER_TOILET'=> "\1F6BD}", 'CHARACTER_SHOWER'=> "\1F6BF}", 'CHARACTER_BATHTUB'=> "\1F6C1}", 'CHARACTER_LOTION_BOTTLE'=> "\1F9F4}", 'CHARACTER_SAFETY_PIN'=> "\1F9F7}", 'CHARACTER_BROOM'=> "\1F9F9}", 'CHARACTER_BASKET'=> "\1F9FA}", 'CHARACTER_ROLL_OF_PAPER'=> "\1F9FB}", 'CHARACTER_SOAP'=> "\1F9FC}", 'CHARACTER_SPONGE'=> "\1F9FD}", 'CHARACTER_FIRE_EXTINGUISHER'=> "\1F9EF}", 'CHARACTER_SHOPPING_CART'=> "\1F6D2}", 'CHARACTER_CIGARETTE'=> "\1F6AC}", 'CHARACTER_COFFIN'=> "\26B0}\FE0F}", 'CHARACTER_FUNERAL_URN'=> "\26B1}\FE0F}", 'CHARACTER_MOAI'=> "\1F5FF}", 'CHARACTER_ATM_SIGN'=> "\1F3E7}", 'CHARACTER_LITTER_IN_BIN_SIGN'=> "\1F6AE}", 'CHARACTER_POTABLE_WATER'=> "\1F6B0}", 'CHARACTER_WHEELCHAIR_SYMBOL'=> "\267F}", 'CHARACTER_MEN_S_ROOM'=> "\1F6B9}", 'CHARACTER_WOMEN_S_ROOM'=> "\1F6BA}", 'CHARACTER_RESTROOM'=> "\1F6BB}", 'CHARACTER_BABY_SYMBOL'=> "\1F6BC}", 'CHARACTER_WATER_CLOSET'=> "\1F6BE}", 'CHARACTER_PASSPORT_CONTROL'=> "\1F6C2}", 'CHARACTER_CUSTOMS'=> "\1F6C3}", 'CHARACTER_BAGGAGE_CLAIM'=> "\1F6C4}", 'CHARACTER_LEFT_LUGGAGE'=> "\1F6C5}", 'CHARACTER_WARNING'=> "\26A0}\FE0F}", 'CHARACTER_CHILDREN_CROSSING'=> "\1F6B8}", 'CHARACTER_NO_ENTRY'=> "\26D4}", 'CHARACTER_PROHIBITED'=> "\1F6AB}", 'CHARACTER_NO_BICYCLES'=> "\1F6B3}", 'CHARACTER_NO_SMOKING'=> "\1F6AD}", 'CHARACTER_NO_LITTERING'=> "\1F6AF}", 'CHARACTER_NON_POTABLE_WATER'=> "\1F6B1}", 'CHARACTER_NO_PEDESTRIANS'=> "\1F6B7}", 'CHARACTER_NO_MOBILE_PHONES'=> "\1F4F5}", 'CHARACTER_NO_ONE_UNDER_EIGHTEEN'=> "\1F51E}", 'CHARACTER_RADIOACTIVE'=> "\2622}\FE0F}", 'CHARACTER_BIOHAZARD'=> "\2623}\FE0F}", 'CHARACTER_UP_ARROW'=> "\2B06}\FE0F}", 'CHARACTER_UP_RIGHT_ARROW'=> "\2197}\FE0F}", 'CHARACTER_RIGHT_ARROW'=> "\27A1}\FE0F}", 'CHARACTER_DOWN_RIGHT_ARROW'=> "\2198}\FE0F}", 'CHARACTER_DOWN_ARROW'=> "\2B07}\FE0F}", 'CHARACTER_DOWN_LEFT_ARROW'=> "\2199}\FE0F}", 'CHARACTER_LEFT_ARROW'=> "\2B05}\FE0F}", 'CHARACTER_UP_LEFT_ARROW'=> "\2196}\FE0F}", 'CHARACTER_UP_DOWN_ARROW'=> "\2195}\FE0F}", 'CHARACTER_LEFT_RIGHT_ARROW'=> "\2194}\FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_LEFT'=> "\21A9}\FE0F}", 'CHARACTER_LEFT_ARROW_CURVING_RIGHT'=> "\21AA}\FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_UP'=> "\2934}\FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_DOWN'=> "\2935}\FE0F}", 'CHARACTER_CLOCKWISE_VERTICAL_ARROWS'=> "\1F503}", 'CHARACTER_COUNTERCLOCKWISE_ARROWS_BUTTON'=> "\1F504}", 'CHARACTER_BACK_ARROW'=> "\1F519}", 'CHARACTER_END_ARROW'=> "\1F51A}", 'CHARACTER_ON_ARROW'=> "\1F51B}", 'CHARACTER_SOON_ARROW'=> "\1F51C}", 'CHARACTER_TOP_ARROW'=> "\1F51D}", 'CHARACTER_PLACE_OF_WORSHIP'=> "\1F6D0}", 'CHARACTER_ATOM_SYMBOL'=> "\269B}\FE0F}", 'CHARACTER_OM'=> "\1F549}\FE0F}", 'CHARACTER_STAR_OF_DAVID'=> "\2721}\FE0F}", 'CHARACTER_WHEEL_OF_DHARMA'=> "\2638}\FE0F}", 'CHARACTER_YIN_YANG'=> "\262F}\FE0F}", 'CHARACTER_LATIN_CROSS'=> "\271D}\FE0F}", 'CHARACTER_ORTHODOX_CROSS'=> "\2626}\FE0F}", 'CHARACTER_STAR_AND_CRESCENT'=> "\262A}\FE0F}", 'CHARACTER_PEACE_SYMBOL'=> "\262E}\FE0F}", 'CHARACTER_MENORAH'=> "\1F54E}", 'CHARACTER_DOTTED_SIX_POINTED_STAR'=> "\1F52F}", 'CHARACTER_ARIES'=> "\2648}", 'CHARACTER_TAURUS'=> "\2649}", 'CHARACTER_GEMINI'=> "\264A}", 'CHARACTER_CANCER'=> "\264B}", 'CHARACTER_LEO'=> "\264C}", 'CHARACTER_VIRGO'=> "\264D}", 'CHARACTER_LIBRA'=> "\264E}", 'CHARACTER_SCORPIO'=> "\264F}", 'CHARACTER_SAGITTARIUS'=> "\2650}", 'CHARACTER_CAPRICORN'=> "\2651}", 'CHARACTER_AQUARIUS'=> "\2652}", 'CHARACTER_PISCES'=> "\2653}", 'CHARACTER_OPHIUCHUS'=> "\26CE}", 'CHARACTER_SHUFFLE_TRACKS_BUTTON'=> "\1F500}", 'CHARACTER_REPEAT_BUTTON'=> "\1F501}", 'CHARACTER_REPEAT_SINGLE_BUTTON'=> "\1F502}", 'CHARACTER_PLAY_BUTTON'=> "\25B6}\FE0F}", 'CHARACTER_FAST_FORWARD_BUTTON'=> "\23E9}", 'CHARACTER_NEXT_TRACK_BUTTON'=> "\23ED}\FE0F}", 'CHARACTER_PLAY_OR_PAUSE_BUTTON'=> "\23EF}\FE0F}", 'CHARACTER_REVERSE_BUTTON'=> "\25C0}\FE0F}", 'CHARACTER_FAST_REVERSE_BUTTON'=> "\23EA}", 'CHARACTER_LAST_TRACK_BUTTON'=> "\23EE}\FE0F}", 'CHARACTER_UPWARDS_BUTTON'=> "\1F53C}", 'CHARACTER_FAST_UP_BUTTON'=> "\23EB}", 'CHARACTER_DOWNWARDS_BUTTON'=> "\1F53D}", 'CHARACTER_FAST_DOWN_BUTTON'=> "\23EC}", 'CHARACTER_PAUSE_BUTTON'=> "\23F8}\FE0F}", 'CHARACTER_STOP_BUTTON'=> "\23F9}\FE0F}", 'CHARACTER_RECORD_BUTTON'=> "\23FA}\FE0F}", 'CHARACTER_EJECT_BUTTON'=> "\23CF}\FE0F}", 'CHARACTER_CINEMA'=> "\1F3A6}", 'CHARACTER_DIM_BUTTON'=> "\1F505}", 'CHARACTER_BRIGHT_BUTTON'=> "\1F506}", 'CHARACTER_ANTENNA_BARS'=> "\1F4F6}", 'CHARACTER_VIBRATION_MODE'=> "\1F4F3}", 'CHARACTER_MOBILE_PHONE_OFF'=> "\1F4F4}", 'CHARACTER_FEMALE_SIGN'=> "\2640}\FE0F}", 'CHARACTER_MALE_SIGN'=> "\2642}\FE0F}", 'CHARACTER_MEDICAL_SYMBOL'=> "\2695}\FE0F}", 'CHARACTER_INFINITY'=> "\267E}\FE0F}", 'CHARACTER_RECYCLING_SYMBOL'=> "\267B}\FE0F}", 'CHARACTER_FLEUR_DE_LIS'=> "\269C}\FE0F}", 'CHARACTER_TRIDENT_EMBLEM'=> "\1F531}", 'CHARACTER_NAME_BADGE'=> "\1F4DB}", 'CHARACTER_JAPANESE_SYMBOL_FOR_BEGINNER'=> "\1F530}", 'CHARACTER_HEAVY_LARGE_CIRCLE'=> "\2B55}", 'CHARACTER_WHITE_HEAVY_CHECK_MARK'=> "\2705}", 'CHARACTER_BALLOT_BOX_WITH_CHECK'=> "\2611}\FE0F}", 'CHARACTER_HEAVY_CHECK_MARK'=> "\2714}\FE0F}", 'CHARACTER_HEAVY_MULTIPLICATION_X'=> "\2716}\FE0F}", 'CHARACTER_CROSS_MARK'=> "\274C}", 'CHARACTER_CROSS_MARK_BUTTON'=> "\274E}", 'CHARACTER_HEAVY_PLUS_SIGN'=> "\2795}", 'CHARACTER_HEAVY_MINUS_SIGN'=> "\2796}", 'CHARACTER_HEAVY_DIVISION_SIGN'=> "\2797}", 'CHARACTER_CURLY_LOOP'=> "\27B0}", 'CHARACTER_DOUBLE_CURLY_LOOP'=> "\27BF}", 'CHARACTER_PART_ALTERNATION_MARK'=> "\303D}\FE0F}", 'CHARACTER_EIGHT_SPOKED_ASTERISK'=> "\2733}\FE0F}", 'CHARACTER_EIGHT_POINTED_STAR'=> "\2734}\FE0F}", 'CHARACTER_SPARKLE'=> "\2747}\FE0F}", 'CHARACTER_DOUBLE_EXCLAMATION_MARK'=> "\203C}\FE0F}", 'CHARACTER_EXCLAMATION_QUESTION_MARK'=> "\2049}\FE0F}", 'CHARACTER_QUESTION_MARK'=> "\2753}", 'CHARACTER_WHITE_QUESTION_MARK'=> "\2754}", 'CHARACTER_WHITE_EXCLAMATION_MARK'=> "\2755}", 'CHARACTER_EXCLAMATION_MARK'=> "\2757}", 'CHARACTER_WAVY_DASH'=> "\3030}\FE0F}", 'CHARACTER_COPYRIGHT'=> "\00A9}\FE0F}", 'CHARACTER_REGISTERED'=> "\00AE}\FE0F}", 'CHARACTER_TRADE_MARK'=> "\2122}\FE0F}", 'CHARACTER_KEYCAP_HASH'=> "\0023}\FE0F}\20E3}", 'CHARACTER_KEYCAP_ASTERISK'=> "\002A}\FE0F}\20E3}", 'CHARACTER_KEYCAP_0'=> "\0030}\FE0F}\20E3}", 'CHARACTER_KEYCAP_1'=> "\0031}\FE0F}\20E3}", 'CHARACTER_KEYCAP_2'=> "\0032}\FE0F}\20E3}", 'CHARACTER_KEYCAP_3'=> "\0033}\FE0F}\20E3}", 'CHARACTER_KEYCAP_4'=> "\0034}\FE0F}\20E3}", 'CHARACTER_KEYCAP_5'=> "\0035}\FE0F}\20E3}", 'CHARACTER_KEYCAP_6'=> "\0036}\FE0F}\20E3}", 'CHARACTER_KEYCAP_7'=> "\0037}\FE0F}\20E3}", 'CHARACTER_KEYCAP_8'=> "\0038}\FE0F}\20E3}", 'CHARACTER_KEYCAP_9'=> "\0039}\FE0F}\20E3}", 'CHARACTER_KEYCAP_10'=> "\1F51F}", 'CHARACTER_HUNDRED_POINTS'=> "\1F4AF}", 'CHARACTER_INPUT_LATIN_UPPERCASE'=> "\1F520}", 'CHARACTER_INPUT_LATIN_LOWERCASE'=> "\1F521}", 'CHARACTER_INPUT_NUMBERS'=> "\1F522}", 'CHARACTER_INPUT_SYMBOLS'=> "\1F523}", 'CHARACTER_INPUT_LATIN_LETTERS'=> "\1F524}", 'CHARACTER_A_BUTTON_BLOOD_TYPE'=> "\1F170}\FE0F}", 'CHARACTER_AB_BUTTON_BLOOD_TYPE'=> "\1F18E}", 'CHARACTER_B_BUTTON_BLOOD_TYPE'=> "\1F171}\FE0F}", 'CHARACTER_CL_BUTTON'=> "\1F191}", 'CHARACTER_COOL_BUTTON'=> "\1F192}", 'CHARACTER_FREE_BUTTON'=> "\1F193}", 'CHARACTER_INFORMATION'=> "\2139}\FE0F}", 'CHARACTER_ID_BUTTON'=> "\1F194}", 'CHARACTER_CIRCLED_M'=> "\24C2}\FE0F}", 'CHARACTER_NEW_BUTTON'=> "\1F195}", 'CHARACTER_NG_BUTTON'=> "\1F196}", 'CHARACTER_O_BUTTON_BLOOD_TYPE'=> "\1F17E}\FE0F}", 'CHARACTER_OK_BUTTON'=> "\1F197}", 'CHARACTER_P_BUTTON'=> "\1F17F}\FE0F}", 'CHARACTER_SOS_BUTTON'=> "\1F198}", 'CHARACTER_UP_BUTTON'=> "\1F199}", 'CHARACTER_VS_BUTTON'=> "\1F19A}", 'CHARACTER_JAPANESE_HERE_BUTTON'=> "\1F201}", 'CHARACTER_JAPANESE_SERVICE_CHARGE_BUTTON'=> "\1F202}\FE0F}", 'CHARACTER_JAPANESE_MONTHLY_AMOUNT_BUTTON'=> "\1F237}\FE0F}", 'CHARACTER_JAPANESE_NOT_FREE_OF_CHARGE_BUTTON'=> "\1F236}", 'CHARACTER_JAPANESE_RESERVED_BUTTON'=> "\1F22F}", 'CHARACTER_JAPANESE_BARGAIN_BUTTON'=> "\1F250}", 'CHARACTER_JAPANESE_DISCOUNT_BUTTON'=> "\1F239}", 'CHARACTER_JAPANESE_FREE_OF_CHARGE_BUTTON'=> "\1F21A}", 'CHARACTER_JAPANESE_PROHIBITED_BUTTON'=> "\1F232}", 'CHARACTER_JAPANESE_ACCEPTABLE_BUTTON'=> "\1F251}", 'CHARACTER_JAPANESE_APPLICATION_BUTTON'=> "\1F238}", 'CHARACTER_JAPANESE_PASSING_GRADE_BUTTON'=> "\1F234}", 'CHARACTER_JAPANESE_VACANCY_BUTTON'=> "\1F233}", 'CHARACTER_JAPANESE_CONGRATULATIONS_BUTTON'=> "\3297}\FE0F}", 'CHARACTER_JAPANESE_SECRET_BUTTON'=> "\3299}\FE0F}", 'CHARACTER_JAPANESE_OPEN_FOR_BUSINESS_BUTTON'=> "\1F23A}", 'CHARACTER_JAPANESE_NO_VACANCY_BUTTON'=> "\1F235}", 'CHARACTER_BLACK_SMALL_SQUARE'=> "\25AA}\FE0F}", 'CHARACTER_WHITE_SMALL_SQUARE'=> "\25AB}\FE0F}", 'CHARACTER_WHITE_MEDIUM_SQUARE'=> "\25FB}\FE0F}", 'CHARACTER_BLACK_MEDIUM_SQUARE'=> "\25FC}\FE0F}", 'CHARACTER_WHITE_MEDIUM_SMALL_SQUARE'=> "\25FD}", 'CHARACTER_BLACK_MEDIUM_SMALL_SQUARE'=> "\25FE}", 'CHARACTER_BLACK_LARGE_SQUARE'=> "\2B1B}", 'CHARACTER_WHITE_LARGE_SQUARE'=> "\2B1C}", 'CHARACTER_LARGE_ORANGE_DIAMOND'=> "\1F536}", 'CHARACTER_LARGE_BLUE_DIAMOND'=> "\1F537}", 'CHARACTER_SMALL_ORANGE_DIAMOND'=> "\1F538}", 'CHARACTER_SMALL_BLUE_DIAMOND'=> "\1F539}", 'CHARACTER_RED_TRIANGLE_POINTED_UP'=> "\1F53A}", 'CHARACTER_RED_TRIANGLE_POINTED_DOWN'=> "\1F53B}", 'CHARACTER_DIAMOND_WITH_A_DOT'=> "\1F4A0}", 'CHARACTER_RADIO_BUTTON'=> "\1F518}", 'CHARACTER_BLACK_SQUARE_BUTTON'=> "\1F532}", 'CHARACTER_WHITE_SQUARE_BUTTON'=> "\1F533}", 'CHARACTER_WHITE_CIRCLE'=> "\26AA}", 'CHARACTER_BLACK_CIRCLE'=> "\26AB}", 'CHARACTER_RED_CIRCLE'=> "\1F534}", 'CHARACTER_BLUE_CIRCLE'=> "\1F535}", 'CHARACTER_CHEQUERED_FLAG'=> "\1F3C1}", 'CHARACTER_TRIANGULAR_FLAG'=> "\1F6A9}", 'CHARACTER_CROSSED_FLAGS'=> "\1F38C}", 'CHARACTER_BLACK_FLAG'=> "\1F3F4}", 'CHARACTER_WHITE_FLAG'=> "\1F3F3}\FE0F}", 'CHARACTER_RAINBOW_FLAG'=> "\1F3F3}\FE0F}\200D}\1F308}", 'CHARACTER_PIRATE_FLAG'=> "\1F3F4}\200D}\2620}\FE0F}", 'CHARACTER_FLAGS_FOR_ASCENSION_ISLAND'=> "\1F1E6}\1F1E8}", 'CHARACTER_FLAGS_FOR_ANDORRA'=> "\1F1E6}\1F1E9}", 'CHARACTER_FLAGS_FOR_UNITED_ARAB_EMIRATES'=> "\1F1E6}\1F1EA}", 'CHARACTER_FLAGS_FOR_AFGHANISTAN'=> "\1F1E6}\1F1EB}", 'CHARACTER_FLAGS_FOR_ANTIGUA_AND_BARBUDA'=> "\1F1E6}\1F1EC}", 'CHARACTER_FLAGS_FOR_ANGUILLA'=> "\1F1E6}\1F1EE}", 'CHARACTER_FLAGS_FOR_ALBANIA'=> "\1F1E6}\1F1F1}", 'CHARACTER_FLAGS_FOR_ARMENIA'=> "\1F1E6}\1F1F2}", 'CHARACTER_FLAGS_FOR_ANGOLA'=> "\1F1E6}\1F1F4}", 'CHARACTER_FLAGS_FOR_ANTARCTICA'=> "\1F1E6}\1F1F6}", 'CHARACTER_FLAGS_FOR_ARGENTINA'=> "\1F1E6}\1F1F7}", 'CHARACTER_FLAGS_FOR_AMERICAN_SAMOA'=> "\1F1E6}\1F1F8}", 'CHARACTER_FLAGS_FOR_AUSTRIA'=> "\1F1E6}\1F1F9}", 'CHARACTER_FLAGS_FOR_AUSTRALIA'=> "\1F1E6}\1F1FA}", 'CHARACTER_FLAGS_FOR_ARUBA'=> "\1F1E6}\1F1FC}", 'CHARACTER_FLAGS_FOR_ALAND_ISLANDS'=> "\1F1E6}\1F1FD}", 'CHARACTER_FLAGS_FOR_AZERBAIJAN'=> "\1F1E6}\1F1FF}", 'CHARACTER_FLAGS_FOR_BOSNIA_AND_HERZEGOVINA'=> "\1F1E7}\1F1E6}", 'CHARACTER_FLAGS_FOR_BARBADOS'=> "\1F1E7}\1F1E7}", 'CHARACTER_FLAGS_FOR_BANGLADESH'=> "\1F1E7}\1F1E9}", 'CHARACTER_FLAGS_FOR_BELGIUM'=> "\1F1E7}\1F1EA}", 'CHARACTER_FLAGS_FOR_BURKINA_FASO'=> "\1F1E7}\1F1EB}", 'CHARACTER_FLAGS_FOR_BULGARIA'=> "\1F1E7}\1F1EC}", 'CHARACTER_FLAGS_FOR_BAHRAIN'=> "\1F1E7}\1F1ED}", 'CHARACTER_FLAGS_FOR_BURUNDI'=> "\1F1E7}\1F1EE}", 'CHARACTER_FLAGS_FOR_BENIN'=> "\1F1E7}\1F1EF}", 'CHARACTER_FLAGS_FOR_ST_BARTHELEMY'=> "\1F1E7}\1F1F1}", 'CHARACTER_FLAGS_FOR_BERMUDA'=> "\1F1E7}\1F1F2}", 'CHARACTER_FLAGS_FOR_BRUNEI'=> "\1F1E7}\1F1F3}", 'CHARACTER_FLAGS_FOR_BOLIVIA'=> "\1F1E7}\1F1F4}", 'CHARACTER_FLAGS_FOR_CARIBBEAN_NETHERLANDS'=> "\1F1E7}\1F1F6}", 'CHARACTER_FLAGS_FOR_BRAZIL'=> "\1F1E7}\1F1F7}", 'CHARACTER_FLAGS_FOR_BAHAMAS'=> "\1F1E7}\1F1F8}", 'CHARACTER_FLAGS_FOR_BHUTAN'=> "\1F1E7}\1F1F9}", 'CHARACTER_FLAGS_FOR_BOUVET_ISLAND'=> "\1F1E7}\1F1FB}", 'CHARACTER_FLAGS_FOR_BOTSWANA'=> "\1F1E7}\1F1FC}", 'CHARACTER_FLAGS_FOR_BELARUS'=> "\1F1E7}\1F1FE}", 'CHARACTER_FLAGS_FOR_BELIZE'=> "\1F1E7}\1F1FF}", 'CHARACTER_FLAGS_FOR_CANADA'=> "\1F1E8}\1F1E6}", 'CHARACTER_FLAGS_FOR_COCOS_KEELING_ISLANDS'=> "\1F1E8}\1F1E8}", 'CHARACTER_FLAGS_FOR_CONGO_KINSHASA'=> "\1F1E8}\1F1E9}", 'CHARACTER_FLAGS_FOR_CENTRAL_AFRICAN_REPUBLIC'=> "\1F1E8}\1F1EB}", 'CHARACTER_FLAGS_FOR_CONGO_BRAZZAVILLE'=> "\1F1E8}\1F1EC}", 'CHARACTER_FLAGS_FOR_SWITZERLAND'=> "\1F1E8}\1F1ED}", 'CHARACTER_FLAGS_FOR_COTE_D_IVOIRE'=> "\1F1E8}\1F1EE}", 'CHARACTER_FLAGS_FOR_COOK_ISLANDS'=> "\1F1E8}\1F1F0}", 'CHARACTER_FLAGS_FOR_CHILE'=> "\1F1E8}\1F1F1}", 'CHARACTER_FLAGS_FOR_CAMEROON'=> "\1F1E8}\1F1F2}", 'CHARACTER_FLAGS_FOR_CHINA'=> "\1F1E8}\1F1F3}", 'CHARACTER_FLAGS_FOR_COLOMBIA'=> "\1F1E8}\1F1F4}", 'CHARACTER_FLAGS_FOR_CLIPPERTON_ISLAND'=> "\1F1E8}\1F1F5}", 'CHARACTER_FLAGS_FOR_COSTA_RICA'=> "\1F1E8}\1F1F7}", 'CHARACTER_FLAGS_FOR_CUBA'=> "\1F1E8}\1F1FA}", 'CHARACTER_FLAGS_FOR_CAPE_VERDE'=> "\1F1E8}\1F1FB}", 'CHARACTER_FLAGS_FOR_CURACAO'=> "\1F1E8}\1F1FC}", 'CHARACTER_FLAGS_FOR_CHRISTMAS_ISLAND'=> "\1F1E8}\1F1FD}", 'CHARACTER_FLAGS_FOR_CYPRUS'=> "\1F1E8}\1F1FE}", 'CHARACTER_FLAGS_FOR_CZECHIA'=> "\1F1E8}\1F1FF}", 'CHARACTER_FLAGS_FOR_GERMANY'=> "\1F1E9}\1F1EA}", 'CHARACTER_FLAGS_FOR_DIEGO_GARCIA'=> "\1F1E9}\1F1EC}", 'CHARACTER_FLAGS_FOR_DJIBOUTI'=> "\1F1E9}\1F1EF}", 'CHARACTER_FLAGS_FOR_DENMARK'=> "\1F1E9}\1F1F0}", 'CHARACTER_FLAGS_FOR_DOMINICA'=> "\1F1E9}\1F1F2}", 'CHARACTER_FLAGS_FOR_DOMINICAN_REPUBLIC'=> "\1F1E9}\1F1F4}", 'CHARACTER_FLAGS_FOR_ALGERIA'=> "\1F1E9}\1F1FF}", 'CHARACTER_FLAGS_FOR_CEUTA_AND_MELILLA'=> "\1F1EA}\1F1E6}", 'CHARACTER_FLAGS_FOR_ECUADOR'=> "\1F1EA}\1F1E8}", 'CHARACTER_FLAGS_FOR_ESTONIA'=> "\1F1EA}\1F1EA}", 'CHARACTER_FLAGS_FOR_EGYPT'=> "\1F1EA}\1F1EC}", 'CHARACTER_FLAGS_FOR_WESTERN_SAHARA'=> "\1F1EA}\1F1ED}", 'CHARACTER_FLAGS_FOR_ERITREA'=> "\1F1EA}\1F1F7}", 'CHARACTER_FLAGS_FOR_SPAIN'=> "\1F1EA}\1F1F8}", 'CHARACTER_FLAGS_FOR_ETHIOPIA'=> "\1F1EA}\1F1F9}", 'CHARACTER_FLAGS_FOR_EUROPEAN_UNION'=> "\1F1EA}\1F1FA}", 'CHARACTER_FLAGS_FOR_FINLAND'=> "\1F1EB}\1F1EE}", 'CHARACTER_FLAGS_FOR_FIJI'=> "\1F1EB}\1F1EF}", 'CHARACTER_FLAGS_FOR_FALKLAND_ISLANDS'=> "\1F1EB}\1F1F0}", 'CHARACTER_FLAGS_FOR_MICRONESIA'=> "\1F1EB}\1F1F2}", 'CHARACTER_FLAGS_FOR_FAROE_ISLANDS'=> "\1F1EB}\1F1F4}", 'CHARACTER_FLAGS_FOR_FRANCE'=> "\1F1EB}\1F1F7}", 'CHARACTER_FLAGS_FOR_GABON'=> "\1F1EC}\1F1E6}", 'CHARACTER_FLAGS_FOR_UNITED_KINGDOM'=> "\1F1EC}\1F1E7}", 'CHARACTER_FLAGS_FOR_GRENADA'=> "\1F1EC}\1F1E9}", 'CHARACTER_FLAGS_FOR_GEORGIA'=> "\1F1EC}\1F1EA}", 'CHARACTER_FLAGS_FOR_FRENCH_GUIANA'=> "\1F1EC}\1F1EB}", 'CHARACTER_FLAGS_FOR_GUERNSEY'=> "\1F1EC}\1F1EC}", 'CHARACTER_FLAGS_FOR_GHANA'=> "\1F1EC}\1F1ED}", 'CHARACTER_FLAGS_FOR_GIBRALTAR'=> "\1F1EC}\1F1EE}", 'CHARACTER_FLAGS_FOR_GREENLAND'=> "\1F1EC}\1F1F1}", 'CHARACTER_FLAGS_FOR_GAMBIA'=> "\1F1EC}\1F1F2}", 'CHARACTER_FLAGS_FOR_GUINEA'=> "\1F1EC}\1F1F3}", 'CHARACTER_FLAGS_FOR_GUADELOUPE'=> "\1F1EC}\1F1F5}", 'CHARACTER_FLAGS_FOR_EQUATORIAL_GUINEA'=> "\1F1EC}\1F1F6}", 'CHARACTER_FLAGS_FOR_GREECE'=> "\1F1EC}\1F1F7}", 'CHARACTER_FLAGS_FOR_SOUTH_GEORGIA_AND_SOUTH_SANDWICH_ISLANDS'=> "\1F1EC}\1F1F8}", 'CHARACTER_FLAGS_FOR_GUATEMALA'=> "\1F1EC}\1F1F9}", 'CHARACTER_FLAGS_FOR_GUAM'=> "\1F1EC}\1F1FA}", 'CHARACTER_FLAGS_FOR_GUINEA_BISSAU'=> "\1F1EC}\1F1FC}", 'CHARACTER_FLAGS_FOR_GUYANA'=> "\1F1EC}\1F1FE}", 'CHARACTER_FLAGS_FOR_HONG_KONG_SAR_CHINA'=> "\1F1ED}\1F1F0}", 'CHARACTER_FLAGS_FOR_HEARD_AND_MCDONALD_ISLANDS'=> "\1F1ED}\1F1F2}", 'CHARACTER_FLAGS_FOR_HONDURAS'=> "\1F1ED}\1F1F3}", 'CHARACTER_FLAGS_FOR_CROATIA'=> "\1F1ED}\1F1F7}", 'CHARACTER_FLAGS_FOR_HAITI'=> "\1F1ED}\1F1F9}", 'CHARACTER_FLAGS_FOR_HUNGARY'=> "\1F1ED}\1F1FA}", 'CHARACTER_FLAGS_FOR_CANARY_ISLANDS'=> "\1F1EE}\1F1E8}", 'CHARACTER_FLAGS_FOR_INDONESIA'=> "\1F1EE}\1F1E9}", 'CHARACTER_FLAGS_FOR_IRELAND'=> "\1F1EE}\1F1EA}", 'CHARACTER_FLAGS_FOR_ISRAEL'=> "\1F1EE}\1F1F1}", 'CHARACTER_FLAGS_FOR_ISLE_OF_MAN'=> "\1F1EE}\1F1F2}", 'CHARACTER_FLAGS_FOR_INDIA'=> "\1F1EE}\1F1F3}", 'CHARACTER_FLAGS_FOR_BRITISH_INDIAN_OCEAN_TERRITORY'=> "\1F1EE}\1F1F4}", 'CHARACTER_FLAGS_FOR_IRAQ'=> "\1F1EE}\1F1F6}", 'CHARACTER_FLAGS_FOR_IRAN'=> "\1F1EE}\1F1F7}", 'CHARACTER_FLAGS_FOR_ICELAND'=> "\1F1EE}\1F1F8}", 'CHARACTER_FLAGS_FOR_ITALY'=> "\1F1EE}\1F1F9}", 'CHARACTER_FLAGS_FOR_JERSEY'=> "\1F1EF}\1F1EA}", 'CHARACTER_FLAGS_FOR_JAMAICA'=> "\1F1EF}\1F1F2}", 'CHARACTER_FLAGS_FOR_JORDAN'=> "\1F1EF}\1F1F4}", 'CHARACTER_FLAGS_FOR_JAPAN'=> "\1F1EF}\1F1F5}", 'CHARACTER_FLAGS_FOR_KENYA'=> "\1F1F0}\1F1EA}", 'CHARACTER_FLAGS_FOR_KYRGYZSTAN'=> "\1F1F0}\1F1EC}", 'CHARACTER_FLAGS_FOR_CAMBODIA'=> "\1F1F0}\1F1ED}", 'CHARACTER_FLAGS_FOR_KIRIBATI'=> "\1F1F0}\1F1EE}", 'CHARACTER_FLAGS_FOR_COMOROS'=> "\1F1F0}\1F1F2}", 'CHARACTER_FLAGS_FOR_ST_KITTS_AND_NEVIS'=> "\1F1F0}\1F1F3}", 'CHARACTER_FLAGS_FOR_NORTH_KOREA'=> "\1F1F0}\1F1F5}", 'CHARACTER_FLAGS_FOR_SOUTH_KOREA'=> "\1F1F0}\1F1F7}", 'CHARACTER_FLAGS_FOR_KUWAIT'=> "\1F1F0}\1F1FC}", 'CHARACTER_FLAGS_FOR_CAYMAN_ISLANDS'=> "\1F1F0}\1F1FE}", 'CHARACTER_FLAGS_FOR_KAZAKHSTAN'=> "\1F1F0}\1F1FF}", 'CHARACTER_FLAGS_FOR_LAOS'=> "\1F1F1}\1F1E6}", 'CHARACTER_FLAGS_FOR_LEBANON'=> "\1F1F1}\1F1E7}", 'CHARACTER_FLAGS_FOR_ST_LUCIA'=> "\1F1F1}\1F1E8}", 'CHARACTER_FLAGS_FOR_LIECHTENSTEIN'=> "\1F1F1}\1F1EE}", 'CHARACTER_FLAGS_FOR_SRI_LANKA'=> "\1F1F1}\1F1F0}", 'CHARACTER_FLAGS_FOR_LIBERIA'=> "\1F1F1}\1F1F7}", 'CHARACTER_FLAGS_FOR_LESOTHO'=> "\1F1F1}\1F1F8}", 'CHARACTER_FLAGS_FOR_LITHUANIA'=> "\1F1F1}\1F1F9}", 'CHARACTER_FLAGS_FOR_LUXEMBOURG'=> "\1F1F1}\1F1FA}", 'CHARACTER_FLAGS_FOR_LATVIA'=> "\1F1F1}\1F1FB}", 'CHARACTER_FLAGS_FOR_LIBYA'=> "\1F1F1}\1F1FE}", 'CHARACTER_FLAGS_FOR_MOROCCO'=> "\1F1F2}\1F1E6}", 'CHARACTER_FLAGS_FOR_MONACO'=> "\1F1F2}\1F1E8}", 'CHARACTER_FLAGS_FOR_MOLDOVA'=> "\1F1F2}\1F1E9}", 'CHARACTER_FLAGS_FOR_MONTENEGRO'=> "\1F1F2}\1F1EA}", 'CHARACTER_FLAGS_FOR_ST_MARTIN'=> "\1F1F2}\1F1EB}", 'CHARACTER_FLAGS_FOR_MADAGASCAR'=> "\1F1F2}\1F1EC}", 'CHARACTER_FLAGS_FOR_MARSHALL_ISLANDS'=> "\1F1F2}\1F1ED}", 'CHARACTER_FLAGS_FOR_MACEDONIA'=> "\1F1F2}\1F1F0}", 'CHARACTER_FLAGS_FOR_MALI'=> "\1F1F2}\1F1F1}", 'CHARACTER_FLAGS_FOR_MYANMAR_BURMA'=> "\1F1F2}\1F1F2}", 'CHARACTER_FLAGS_FOR_MONGOLIA'=> "\1F1F2}\1F1F3}", 'CHARACTER_FLAGS_FOR_MACAU_SAR_CHINA'=> "\1F1F2}\1F1F4}", 'CHARACTER_FLAGS_FOR_NORTHERN_MARIANA_ISLANDS'=> "\1F1F2}\1F1F5}", 'CHARACTER_FLAGS_FOR_MARTINIQUE'=> "\1F1F2}\1F1F6}", 'CHARACTER_FLAGS_FOR_MAURITANIA'=> "\1F1F2}\1F1F7}", 'CHARACTER_FLAGS_FOR_MONTSERRAT'=> "\1F1F2}\1F1F8}", 'CHARACTER_FLAGS_FOR_MALTA'=> "\1F1F2}\1F1F9}", 'CHARACTER_FLAGS_FOR_MAURITIUS'=> "\1F1F2}\1F1FA}", 'CHARACTER_FLAGS_FOR_MALDIVES'=> "\1F1F2}\1F1FB}", 'CHARACTER_FLAGS_FOR_MALAWI'=> "\1F1F2}\1F1FC}", 'CHARACTER_FLAGS_FOR_MEXICO'=> "\1F1F2}\1F1FD}", 'CHARACTER_FLAGS_FOR_MALAYSIA'=> "\1F1F2}\1F1FE}", 'CHARACTER_FLAGS_FOR_MOZAMBIQUE'=> "\1F1F2}\1F1FF}", 'CHARACTER_FLAGS_FOR_NAMIBIA'=> "\1F1F3}\1F1E6}", 'CHARACTER_FLAGS_FOR_NEW_CALEDONIA'=> "\1F1F3}\1F1E8}", 'CHARACTER_FLAGS_FOR_NIGER'=> "\1F1F3}\1F1EA}", 'CHARACTER_FLAGS_FOR_NORFOLK_ISLAND'=> "\1F1F3}\1F1EB}", 'CHARACTER_FLAGS_FOR_NIGERIA'=> "\1F1F3}\1F1EC}", 'CHARACTER_FLAGS_FOR_NICARAGUA'=> "\1F1F3}\1F1EE}", 'CHARACTER_FLAGS_FOR_NETHERLANDS'=> "\1F1F3}\1F1F1}", 'CHARACTER_FLAGS_FOR_NORWAY'=> "\1F1F3}\1F1F4}", 'CHARACTER_FLAGS_FOR_NEPAL'=> "\1F1F3}\1F1F5}", 'CHARACTER_FLAGS_FOR_NAURU'=> "\1F1F3}\1F1F7}", 'CHARACTER_FLAGS_FOR_NIUE'=> "\1F1F3}\1F1FA}", 'CHARACTER_FLAGS_FOR_NEW_ZEALAND'=> "\1F1F3}\1F1FF}", 'CHARACTER_FLAGS_FOR_OMAN'=> "\1F1F4}\1F1F2}", 'CHARACTER_FLAGS_FOR_PANAMA'=> "\1F1F5}\1F1E6}", 'CHARACTER_FLAGS_FOR_PERU'=> "\1F1F5}\1F1EA}", 'CHARACTER_FLAGS_FOR_FRENCH_POLYNESIA'=> "\1F1F5}\1F1EB}", 'CHARACTER_FLAGS_FOR_PAPUA_NEW_GUINEA'=> "\1F1F5}\1F1EC}", 'CHARACTER_FLAGS_FOR_PHILIPPINES'=> "\1F1F5}\1F1ED}", 'CHARACTER_FLAGS_FOR_PAKISTAN'=> "\1F1F5}\1F1F0}", 'CHARACTER_FLAGS_FOR_POLAND'=> "\1F1F5}\1F1F1}", 'CHARACTER_FLAGS_FOR_ST_PIERRE_AND_MIQUELON'=> "\1F1F5}\1F1F2}", 'CHARACTER_FLAGS_FOR_PITCAIRN_ISLANDS'=> "\1F1F5}\1F1F3}", 'CHARACTER_FLAGS_FOR_PUERTO_RICO'=> "\1F1F5}\1F1F7}", 'CHARACTER_FLAGS_FOR_PALESTINIAN_TERRITORIES'=> "\1F1F5}\1F1F8}", 'CHARACTER_FLAGS_FOR_PORTUGAL'=> "\1F1F5}\1F1F9}", 'CHARACTER_FLAGS_FOR_PALAU'=> "\1F1F5}\1F1FC}", 'CHARACTER_FLAGS_FOR_PARAGUAY'=> "\1F1F5}\1F1FE}", 'CHARACTER_FLAGS_FOR_QATAR'=> "\1F1F6}\1F1E6}", 'CHARACTER_FLAGS_FOR_REUNION'=> "\1F1F7}\1F1EA}", 'CHARACTER_FLAGS_FOR_ROMANIA'=> "\1F1F7}\1F1F4}", 'CHARACTER_FLAGS_FOR_SERBIA'=> "\1F1F7}\1F1F8}", 'CHARACTER_FLAGS_FOR_RUSSIA'=> "\1F1F7}\1F1FA}", 'CHARACTER_FLAGS_FOR_RWANDA'=> "\1F1F7}\1F1FC}", 'CHARACTER_FLAGS_FOR_SAUDI_ARABIA'=> "\1F1F8}\1F1E6}", 'CHARACTER_FLAGS_FOR_SOLOMON_ISLANDS'=> "\1F1F8}\1F1E7}", 'CHARACTER_FLAGS_FOR_SEYCHELLES'=> "\1F1F8}\1F1E8}", 'CHARACTER_FLAGS_FOR_SUDAN'=> "\1F1F8}\1F1E9}", 'CHARACTER_FLAGS_FOR_SWEDEN'=> "\1F1F8}\1F1EA}", 'CHARACTER_FLAGS_FOR_SINGAPORE'=> "\1F1F8}\1F1EC}", 'CHARACTER_FLAGS_FOR_ST_HELENA'=> "\1F1F8}\1F1ED}", 'CHARACTER_FLAGS_FOR_SLOVENIA'=> "\1F1F8}\1F1EE}", 'CHARACTER_FLAGS_FOR_SVALBARD_AND_JAN_MAYEN'=> "\1F1F8}\1F1EF}", 'CHARACTER_FLAGS_FOR_SLOVAKIA'=> "\1F1F8}\1F1F0}", 'CHARACTER_FLAGS_FOR_SIERRA_LEONE'=> "\1F1F8}\1F1F1}", 'CHARACTER_FLAGS_FOR_SAN_MARINO'=> "\1F1F8}\1F1F2}", 'CHARACTER_FLAGS_FOR_SENEGAL'=> "\1F1F8}\1F1F3}", 'CHARACTER_FLAGS_FOR_SOMALIA'=> "\1F1F8}\1F1F4}", 'CHARACTER_FLAGS_FOR_SURINAME'=> "\1F1F8}\1F1F7}", 'CHARACTER_FLAGS_FOR_SOUTH_SUDAN'=> "\1F1F8}\1F1F8}", 'CHARACTER_FLAGS_FOR_SAO_TOME_AND_PRINCIPE'=> "\1F1F8}\1F1F9}", 'CHARACTER_FLAGS_FOR_EL_SALVADOR'=> "\1F1F8}\1F1FB}", 'CHARACTER_FLAGS_FOR_SINT_MAARTEN'=> "\1F1F8}\1F1FD}", 'CHARACTER_FLAGS_FOR_SYRIA'=> "\1F1F8}\1F1FE}", 'CHARACTER_FLAGS_FOR_SWAZILAND'=> "\1F1F8}\1F1FF}", 'CHARACTER_FLAGS_FOR_TRISTAN_DA_CUNHA'=> "\1F1F9}\1F1E6}", 'CHARACTER_FLAGS_FOR_TURKS_AND_CAICOS_ISLANDS'=> "\1F1F9}\1F1E8}", 'CHARACTER_FLAGS_FOR_CHAD'=> "\1F1F9}\1F1E9}", 'CHARACTER_FLAGS_FOR_FRENCH_SOUTHERN_TERRITORIES'=> "\1F1F9}\1F1EB}", 'CHARACTER_FLAGS_FOR_TOGO'=> "\1F1F9}\1F1EC}", 'CHARACTER_FLAGS_FOR_THAILAND'=> "\1F1F9}\1F1ED}", 'CHARACTER_FLAGS_FOR_TAJIKISTAN'=> "\1F1F9}\1F1EF}", 'CHARACTER_FLAGS_FOR_TOKELAU'=> "\1F1F9}\1F1F0}", 'CHARACTER_FLAGS_FOR_TIMOR_LESTE'=> "\1F1F9}\1F1F1}", 'CHARACTER_FLAGS_FOR_TURKMENISTAN'=> "\1F1F9}\1F1F2}", 'CHARACTER_FLAGS_FOR_TUNISIA'=> "\1F1F9}\1F1F3}", 'CHARACTER_FLAGS_FOR_TONGA'=> "\1F1F9}\1F1F4}", 'CHARACTER_FLAGS_FOR_TURKEY'=> "\1F1F9}\1F1F7}", 'CHARACTER_FLAGS_FOR_TRINIDAD_AND_TOBAGO'=> "\1F1F9}\1F1F9}", 'CHARACTER_FLAGS_FOR_TUVALU'=> "\1F1F9}\1F1FB}", 'CHARACTER_FLAGS_FOR_TAIWAN'=> "\1F1F9}\1F1FC}", 'CHARACTER_FLAGS_FOR_TANZANIA'=> "\1F1F9}\1F1FF}", 'CHARACTER_FLAGS_FOR_UKRAINE'=> "\1F1FA}\1F1E6}", 'CHARACTER_FLAGS_FOR_UGANDA'=> "\1F1FA}\1F1EC}", 'CHARACTER_FLAGS_FOR_US_OUTLYING_ISLANDS'=> "\1F1FA}\1F1F2}", 'CHARACTER_FLAGS_FOR_UNITED_NATIONS'=> "\1F1FA}\1F1F3}", 'CHARACTER_FLAGS_FOR_UNITED_STATES'=> "\1F1FA}\1F1F8}", 'CHARACTER_FLAGS_FOR_URUGUAY'=> "\1F1FA}\1F1FE}", 'CHARACTER_FLAGS_FOR_UZBEKISTAN'=> "\1F1FA}\1F1FF}", 'CHARACTER_FLAGS_FOR_VATICAN_CITY'=> "\1F1FB}\1F1E6}", 'CHARACTER_FLAGS_FOR_ST_VINCENT_AND_GRENADINES'=> "\1F1FB}\1F1E8}", 'CHARACTER_FLAGS_FOR_VENEZUELA'=> "\1F1FB}\1F1EA}", 'CHARACTER_FLAGS_FOR_BRITISH_VIRGIN_ISLANDS'=> "\1F1FB}\1F1EC}", 'CHARACTER_FLAGS_FOR_US_VIRGIN_ISLANDS'=> "\1F1FB}\1F1EE}", 'CHARACTER_FLAGS_FOR_VIETNAM'=> "\1F1FB}\1F1F3}", 'CHARACTER_FLAGS_FOR_VANUATU'=> "\1F1FB}\1F1FA}", 'CHARACTER_FLAGS_FOR_WALLIS_AND_FUTUNA'=> "\1F1FC}\1F1EB}", 'CHARACTER_FLAGS_FOR_SAMOA'=> "\1F1FC}\1F1F8}", 'CHARACTER_FLAGS_FOR_KOSOVO'=> "\1F1FD}\1F1F0}", 'CHARACTER_FLAGS_FOR_YEMEN'=> "\1F1FE}\1F1EA}", 'CHARACTER_FLAGS_FOR_MAYOTTE'=> "\1F1FE}\1F1F9}", 'CHARACTER_FLAGS_FOR_SOUTH_AFRICA'=> "\1F1FF}\1F1E6}", 'CHARACTER_FLAGS_FOR_ZAMBIA'=> "\1F1FF}\1F1F2}", 'CHARACTER_FLAGS_FOR_ZIMBABWE'=> "\1F1FF}\1F1FC}", 'CHARACTER_FLAGS_FOR_ENGLAND'=> "\1F3F4}\E0067}\E0062}\E0065}\E006E}\E0067}\E007F}", 'CHARACTER_FLAGS_FOR_SCOTLAND'=> "\1F3F4}\E0067}\E0062}\E0073}\E0063}\E0074}\E007F}", 'CHARACTER_FLAGS_FOR_WALES'=> "\1F3F4}\E0067}\E0062}\E0077}\E006C}\E0073}\E007F}",]

Documentation des variables

◆ return

return[ 'CHARACTER_GRINNING_FACE'=> "\{1F600}", 'CHARACTER_BEAMING_FACE_WITH_SMILING_EYES'=> "\{1F601}", 'CHARACTER_FACE_WITH_TEARS_OF_JOY'=> "\{1F602}", 'CHARACTER_ROLLING_ON_THE_FLOOR_LAUGHING'=> "\{1F923}", 'CHARACTER_GRINNING_FACE_WITH_BIG_EYES'=> "\{1F603}", 'CHARACTER_GRINNING_FACE_WITH_SMILING_EYES'=> "\{1F604}", 'CHARACTER_GRINNING_FACE_WITH_SWEAT'=> "\{1F605}", 'CHARACTER_GRINNING_SQUINTING_FACE'=> "\{1F606}", 'CHARACTER_WINKING_FACE'=> "\{1F609}", 'CHARACTER_SMILING_FACE_WITH_SMILING_EYES'=> "\{1F60A}", 'CHARACTER_FACE_SAVORING_FOOD'=> "\{1F60B}", 'CHARACTER_SMILING_FACE_WITH_SUNGLASSES'=> "\{1F60E}", 'CHARACTER_SMILING_FACE_WITH_HEART_EYES'=> "\{1F60D}", 'CHARACTER_FACE_BLOWING_A_KISS'=> "\{1F618}", 'CHARACTER_SMILING_FACE_WITH_3_HEARTS'=> "\{1F970}", 'CHARACTER_KISSING_FACE'=> "\{1F617}", 'CHARACTER_KISSING_FACE_WITH_SMILING_EYES'=> "\{1F619}", 'CHARACTER_KISSING_FACE_WITH_CLOSED_EYES'=> "\{1F61A}", 'CHARACTER_SMILING_FACE'=> "\{263A}\{FE0F}", 'CHARACTER_SLIGHTLY_SMILING_FACE'=> "\{1F642}", 'CHARACTER_HUGGING_FACE'=> "\{1F917}", 'CHARACTER_STAR_STRUCK'=> "\{1F929}", 'CHARACTER_THINKING_FACE'=> "\{1F914}", 'CHARACTER_FACE_WITH_RAISED_EYEBROW'=> "\{1F928}", 'CHARACTER_NEUTRAL_FACE'=> "\{1F610}", 'CHARACTER_EXPRESSIONLESS_FACE'=> "\{1F611}", 'CHARACTER_FACE_WITHOUT_MOUTH'=> "\{1F636}", 'CHARACTER_FACE_WITH_ROLLING_EYES'=> "\{1F644}", 'CHARACTER_SMIRKING_FACE'=> "\{1F60F}", 'CHARACTER_PERSEVERING_FACE'=> "\{1F623}", 'CHARACTER_SAD_BUT_RELIEVED_FACE'=> "\{1F625}", 'CHARACTER_FACE_WITH_OPEN_MOUTH'=> "\{1F62E}", 'CHARACTER_ZIPPER_MOUTH_FACE'=> "\{1F910}", 'CHARACTER_HUSHED_FACE'=> "\{1F62F}", 'CHARACTER_SLEEPY_FACE'=> "\{1F62A}", 'CHARACTER_TIRED_FACE'=> "\{1F62B}", 'CHARACTER_SLEEPING_FACE'=> "\{1F634}", 'CHARACTER_RELIEVED_FACE'=> "\{1F60C}", 'CHARACTER_FACE_WITH_TONGUE'=> "\{1F61B}", 'CHARACTER_WINKING_FACE_WITH_TONGUE'=> "\{1F61C}", 'CHARACTER_SQUINTING_FACE_WITH_TONGUE'=> "\{1F61D}", 'CHARACTER_DROOLING_FACE'=> "\{1F924}", 'CHARACTER_UNAMUSED_FACE'=> "\{1F612}", 'CHARACTER_DOWNCAST_FACE_WITH_SWEAT'=> "\{1F613}", 'CHARACTER_PENSIVE_FACE'=> "\{1F614}", 'CHARACTER_CONFUSED_FACE'=> "\{1F615}", 'CHARACTER_UPSIDE_DOWN_FACE'=> "\{1F643}", 'CHARACTER_MONEY_MOUTH_FACE'=> "\{1F911}", 'CHARACTER_ASTONISHED_FACE'=> "\{1F632}", 'CHARACTER_FROWNING_FACE'=> "\{2639}\{FE0F}", 'CHARACTER_SLIGHTLY_FROWNING_FACE'=> "\{1F641}", 'CHARACTER_CONFOUNDED_FACE'=> "\{1F616}", 'CHARACTER_DISAPPOINTED_FACE'=> "\{1F61E}", 'CHARACTER_WORRIED_FACE'=> "\{1F61F}", 'CHARACTER_FACE_WITH_STEAM_FROM_NOSE'=> "\{1F624}", 'CHARACTER_CRYING_FACE'=> "\{1F622}", 'CHARACTER_LOUDLY_CRYING_FACE'=> "\{1F62D}", 'CHARACTER_FROWNING_FACE_WITH_OPEN_MOUTH'=> "\{1F626}", 'CHARACTER_ANGUISHED_FACE'=> "\{1F627}", 'CHARACTER_FEARFUL_FACE'=> "\{1F628}", 'CHARACTER_WEARY_FACE'=> "\{1F629}", 'CHARACTER_EXPLODING_HEAD'=> "\{1F92F}", 'CHARACTER_GRIMACING_FACE'=> "\{1F62C}", 'CHARACTER_ANXIOUS_FACE_WITH_SWEAT'=> "\{1F630}", 'CHARACTER_FACE_SCREAMING_IN_FEAR'=> "\{1F631}", 'CHARACTER_HOT_FACE'=> "\{1F975}", 'CHARACTER_COLD_FACE'=> "\{1F976}", 'CHARACTER_FLUSHED_FACE'=> "\{1F633}", 'CHARACTER_ZANY_FACE'=> "\{1F92A}", 'CHARACTER_DIZZY_FACE'=> "\{1F635}", 'CHARACTER_POUTING_FACE'=> "\{1F621}", 'CHARACTER_ANGRY_FACE'=> "\{1F620}", 'CHARACTER_FACE_WITH_SYMBOLS_ON_MOUTH'=> "\{1F92C}", 'CHARACTER_FACE_WITH_MEDICAL_MASK'=> "\{1F637}", 'CHARACTER_FACE_WITH_THERMOMETER'=> "\{1F912}", 'CHARACTER_FACE_WITH_HEAD_BANDAGE'=> "\{1F915}", 'CHARACTER_NAUSEATED_FACE'=> "\{1F922}", 'CHARACTER_FACE_VOMITING'=> "\{1F92E}", 'CHARACTER_SNEEZING_FACE'=> "\{1F927}", 'CHARACTER_SMILING_FACE_WITH_HALO'=> "\{1F607}", 'CHARACTER_COWBOY_HAT_FACE'=> "\{1F920}", 'CHARACTER_PARTYING_FACE'=> "\{1F973}", 'CHARACTER_WOOZY_FACE'=> "\{1F974}", 'CHARACTER_PLEADING_FACE'=> "\{1F97A}", 'CHARACTER_LYING_FACE'=> "\{1F925}", 'CHARACTER_SHUSHING_FACE'=> "\{1F92B}", 'CHARACTER_FACE_WITH_HAND_OVER_MOUTH'=> "\{1F92D}", 'CHARACTER_FACE_WITH_MONOCLE'=> "\{1F9D0}", 'CHARACTER_NERD_FACE'=> "\{1F913}", 'CHARACTER_SMILING_FACE_WITH_HORNS'=> "\{1F608}", 'CHARACTER_ANGRY_FACE_WITH_HORNS'=> "\{1F47F}", 'CHARACTER_CLOWN_FACE'=> "\{1F921}", 'CHARACTER_OGRE'=> "\{1F479}", 'CHARACTER_GOBLIN'=> "\{1F47A}", 'CHARACTER_SKULL'=> "\{1F480}", 'CHARACTER_SKULL_AND_CROSSBONES'=> "\{2620}\{FE0F}", 'CHARACTER_GHOST'=> "\{1F47B}", 'CHARACTER_ALIEN'=> "\{1F47D}", 'CHARACTER_ALIEN_MONSTER'=> "\{1F47E}", 'CHARACTER_ROBOT_FACE'=> "\{1F916}", 'CHARACTER_PILE_OF_POO'=> "\{1F4A9}", 'CHARACTER_GRINNING_CAT_FACE'=> "\{1F63A}", 'CHARACTER_GRINNING_CAT_FACE_WITH_SMILING_EYES'=> "\{1F638}", 'CHARACTER_CAT_FACE_WITH_TEARS_OF_JOY'=> "\{1F639}", 'CHARACTER_SMILING_CAT_FACE_WITH_HEART_EYES'=> "\{1F63B}", 'CHARACTER_CAT_FACE_WITH_WRY_SMILE'=> "\{1F63C}", 'CHARACTER_KISSING_CAT_FACE'=> "\{1F63D}", 'CHARACTER_WEARY_CAT_FACE'=> "\{1F640}", 'CHARACTER_CRYING_CAT_FACE'=> "\{1F63F}", 'CHARACTER_POUTING_CAT_FACE'=> "\{1F63E}", 'CHARACTER_SEE_NO_EVIL_MONKEY'=> "\{1F648}", 'CHARACTER_HEAR_NO_EVIL_MONKEY'=> "\{1F649}", 'CHARACTER_SPEAK_NO_EVIL_MONKEY'=> "\{1F64A}", 'CHARACTER_LIGHT_SKIN_TONE'=> "\{1F3FB}", 'CHARACTER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3FC}", 'CHARACTER_MEDIUM_SKIN_TONE'=> "\{1F3FD}", 'CHARACTER_MEDIUM_DARK_SKIN_TONE'=> "\{1F3FE}", 'CHARACTER_DARK_SKIN_TONE'=> "\{1F3FF}", 'CHARACTER_BABY'=> "\{1F476}", 'CHARACTER_BABY_LIGHT_SKIN_TONE'=> "\{1F476}\{1F3FB}", 'CHARACTER_BABY_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F476}\{1F3FC}", 'CHARACTER_BABY_MEDIUM_SKIN_TONE'=> "\{1F476}\{1F3FD}", 'CHARACTER_BABY_MEDIUM_DARK_SKIN_TONE'=> "\{1F476}\{1F3FE}", 'CHARACTER_BABY_DARK_SKIN_TONE'=> "\{1F476}\{1F3FF}", 'CHARACTER_CHILD'=> "\{1F9D2}", 'CHARACTER_CHILD_LIGHT_SKIN_TONE'=> "\{1F9D2}\{1F3FB}", 'CHARACTER_CHILD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D2}\{1F3FC}", 'CHARACTER_CHILD_MEDIUM_SKIN_TONE'=> "\{1F9D2}\{1F3FD}", 'CHARACTER_CHILD_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D2}\{1F3FE}", 'CHARACTER_CHILD_DARK_SKIN_TONE'=> "\{1F9D2}\{1F3FF}", 'CHARACTER_BOY'=> "\{1F466}", 'CHARACTER_BOY_LIGHT_SKIN_TONE'=> "\{1F466}\{1F3FB}", 'CHARACTER_BOY_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F466}\{1F3FC}", 'CHARACTER_BOY_MEDIUM_SKIN_TONE'=> "\{1F466}\{1F3FD}", 'CHARACTER_BOY_MEDIUM_DARK_SKIN_TONE'=> "\{1F466}\{1F3FE}", 'CHARACTER_BOY_DARK_SKIN_TONE'=> "\{1F466}\{1F3FF}", 'CHARACTER_GIRL'=> "\{1F467}", 'CHARACTER_GIRL_LIGHT_SKIN_TONE'=> "\{1F467}\{1F3FB}", 'CHARACTER_GIRL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F467}\{1F3FC}", 'CHARACTER_GIRL_MEDIUM_SKIN_TONE'=> "\{1F467}\{1F3FD}", 'CHARACTER_GIRL_MEDIUM_DARK_SKIN_TONE'=> "\{1F467}\{1F3FE}", 'CHARACTER_GIRL_DARK_SKIN_TONE'=> "\{1F467}\{1F3FF}", 'CHARACTER_ADULT'=> "\{1F9D1}", 'CHARACTER_ADULT_LIGHT_SKIN_TONE'=> "\{1F9D1}\{1F3FB}", 'CHARACTER_ADULT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D1}\{1F3FC}", 'CHARACTER_ADULT_MEDIUM_SKIN_TONE'=> "\{1F9D1}\{1F3FD}", 'CHARACTER_ADULT_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D1}\{1F3FE}", 'CHARACTER_ADULT_DARK_SKIN_TONE'=> "\{1F9D1}\{1F3FF}", 'CHARACTER_MAN'=> "\{1F468}", 'CHARACTER_MAN_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}", 'CHARACTER_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}", 'CHARACTER_MAN_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}", 'CHARACTER_MAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}", 'CHARACTER_MAN_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}", 'CHARACTER_WOMAN'=> "\{1F469}", 'CHARACTER_WOMAN_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}", 'CHARACTER_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}", 'CHARACTER_WOMAN_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}", 'CHARACTER_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}", 'CHARACTER_WOMAN_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}", 'CHARACTER_OLDER_ADULT'=> "\{1F9D3}", 'CHARACTER_OLDER_ADULT_LIGHT_SKIN_TONE'=> "\{1F9D3}\{1F3FB}", 'CHARACTER_OLDER_ADULT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D3}\{1F3FC}", 'CHARACTER_OLDER_ADULT_MEDIUM_SKIN_TONE'=> "\{1F9D3}\{1F3FD}", 'CHARACTER_OLDER_ADULT_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D3}\{1F3FE}", 'CHARACTER_OLDER_ADULT_DARK_SKIN_TONE'=> "\{1F9D3}\{1F3FF}", 'CHARACTER_OLD_MAN'=> "\{1F474}", 'CHARACTER_OLD_MAN_LIGHT_SKIN_TONE'=> "\{1F474}\{1F3FB}", 'CHARACTER_OLD_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F474}\{1F3FC}", 'CHARACTER_OLD_MAN_MEDIUM_SKIN_TONE'=> "\{1F474}\{1F3FD}", 'CHARACTER_OLD_MAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F474}\{1F3FE}", 'CHARACTER_OLD_MAN_DARK_SKIN_TONE'=> "\{1F474}\{1F3FF}", 'CHARACTER_OLD_WOMAN'=> "\{1F475}", 'CHARACTER_OLD_WOMAN_LIGHT_SKIN_TONE'=> "\{1F475}\{1F3FB}", 'CHARACTER_OLD_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F475}\{1F3FC}", 'CHARACTER_OLD_WOMAN_MEDIUM_SKIN_TONE'=> "\{1F475}\{1F3FD}", 'CHARACTER_OLD_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F475}\{1F3FE}", 'CHARACTER_OLD_WOMAN_DARK_SKIN_TONE'=> "\{1F475}\{1F3FF}", 'CHARACTER_MAN_HEALTH_WORKER'=> "\{1F468}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_HEALTH_WORKER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER'=> "\{1F469}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{2695}\{FE0F}", 'CHARACTER_WOMAN_HEALTH_WORKER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{2695}\{FE0F}", 'CHARACTER_MAN_STUDENT'=> "\{1F468}\{200D}\{1F393}", 'CHARACTER_MAN_STUDENT_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F393}", 'CHARACTER_MAN_STUDENT_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F393}", 'CHARACTER_MAN_STUDENT_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT'=> "\{1F469}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F393}", 'CHARACTER_WOMAN_STUDENT_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F393}", 'CHARACTER_MAN_TEACHER'=> "\{1F468}\{200D}\{1F3EB}", 'CHARACTER_MAN_TEACHER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F3EB}", 'CHARACTER_MAN_TEACHER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F3EB}", 'CHARACTER_MAN_TEACHER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER'=> "\{1F469}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F3EB}", 'CHARACTER_WOMAN_TEACHER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F3EB}", 'CHARACTER_MAN_JUDGE'=> "\{1F468}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_JUDGE_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_JUDGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_JUDGE_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE'=> "\{1F469}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{2696}\{FE0F}", 'CHARACTER_WOMAN_JUDGE_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{2696}\{FE0F}", 'CHARACTER_MAN_FARMER'=> "\{1F468}\{200D}\{1F33E}", 'CHARACTER_MAN_FARMER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F33E}", 'CHARACTER_MAN_FARMER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F33E}", 'CHARACTER_MAN_FARMER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER'=> "\{1F469}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F33E}", 'CHARACTER_WOMAN_FARMER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F33E}", 'CHARACTER_MAN_COOK'=> "\{1F468}\{200D}\{1F373}", 'CHARACTER_MAN_COOK_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F373}", 'CHARACTER_MAN_COOK_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F373}", 'CHARACTER_MAN_COOK_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F373}", 'CHARACTER_MAN_COOK_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F373}", 'CHARACTER_MAN_COOK_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK'=> "\{1F469}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F373}", 'CHARACTER_WOMAN_COOK_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F373}", 'CHARACTER_MAN_MECHANIC'=> "\{1F468}\{200D}\{1F527}", 'CHARACTER_MAN_MECHANIC_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F527}", 'CHARACTER_MAN_MECHANIC_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F527}", 'CHARACTER_MAN_MECHANIC_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC'=> "\{1F469}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F527}", 'CHARACTER_WOMAN_MECHANIC_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F527}", 'CHARACTER_MAN_FACTORY_WORKER'=> "\{1F468}\{200D}\{1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F3ED}", 'CHARACTER_MAN_FACTORY_WORKER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER'=> "\{1F469}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F3ED}", 'CHARACTER_WOMAN_FACTORY_WORKER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F3ED}", 'CHARACTER_MAN_OFFICE_WORKER'=> "\{1F468}\{200D}\{1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F4BC}", 'CHARACTER_MAN_OFFICE_WORKER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER'=> "\{1F469}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F4BC}", 'CHARACTER_WOMAN_OFFICE_WORKER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F4BC}", 'CHARACTER_MAN_SCIENTIST'=> "\{1F468}\{200D}\{1F52C}", 'CHARACTER_MAN_SCIENTIST_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F52C}", 'CHARACTER_MAN_SCIENTIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F52C}", 'CHARACTER_MAN_SCIENTIST_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST'=> "\{1F469}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F52C}", 'CHARACTER_WOMAN_SCIENTIST_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F52C}", 'CHARACTER_MAN_TECHNOLOGIST'=> "\{1F468}\{200D}\{1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F4BB}", 'CHARACTER_MAN_TECHNOLOGIST_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST'=> "\{1F469}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F4BB}", 'CHARACTER_WOMAN_TECHNOLOGIST_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F4BB}", 'CHARACTER_MAN_SINGER'=> "\{1F468}\{200D}\{1F3A4}", 'CHARACTER_MAN_SINGER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F3A4}", 'CHARACTER_MAN_SINGER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F3A4}", 'CHARACTER_MAN_SINGER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER'=> "\{1F469}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F3A4}", 'CHARACTER_WOMAN_SINGER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F3A4}", 'CHARACTER_MAN_ARTIST'=> "\{1F468}\{200D}\{1F3A8}", 'CHARACTER_MAN_ARTIST_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F3A8}", 'CHARACTER_MAN_ARTIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F3A8}", 'CHARACTER_MAN_ARTIST_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST'=> "\{1F469}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F3A8}", 'CHARACTER_WOMAN_ARTIST_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F3A8}", 'CHARACTER_MAN_PILOT'=> "\{1F468}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_PILOT_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_PILOT_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_PILOT_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT'=> "\{1F469}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{2708}\{FE0F}", 'CHARACTER_WOMAN_PILOT_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{2708}\{FE0F}", 'CHARACTER_MAN_ASTRONAUT'=> "\{1F468}\{200D}\{1F680}", 'CHARACTER_MAN_ASTRONAUT_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F680}", 'CHARACTER_MAN_ASTRONAUT_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F680}", 'CHARACTER_MAN_ASTRONAUT_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT'=> "\{1F469}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F680}", 'CHARACTER_WOMAN_ASTRONAUT_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F680}", 'CHARACTER_MAN_FIREFIGHTER'=> "\{1F468}\{200D}\{1F692}", 'CHARACTER_MAN_FIREFIGHTER_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F692}", 'CHARACTER_MAN_FIREFIGHTER_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F692}", 'CHARACTER_MAN_FIREFIGHTER_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER'=> "\{1F469}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F692}", 'CHARACTER_WOMAN_FIREFIGHTER_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F692}", 'CHARACTER_POLICE_OFFICER'=> "\{1F46E}", 'CHARACTER_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FB}", 'CHARACTER_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FC}", 'CHARACTER_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\{1F46E}\{1F3FD}", 'CHARACTER_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FE}", 'CHARACTER_POLICE_OFFICER_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FF}", 'CHARACTER_MAN_POLICE_OFFICER'=> "\{1F46E}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\{1F46E}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POLICE_OFFICER_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER'=> "\{1F46E}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F46E}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_SKIN_TONE'=> "\{1F46E}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_MEDIUM_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POLICE_OFFICER_DARK_SKIN_TONE'=> "\{1F46E}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_DETECTIVE'=> "\{1F575}\{FE0F}", 'CHARACTER_DETECTIVE_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FB}", 'CHARACTER_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FC}", 'CHARACTER_DETECTIVE_MEDIUM_SKIN_TONE'=> "\{1F575}\{1F3FD}", 'CHARACTER_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\{1F575}\{1F3FE}", 'CHARACTER_DETECTIVE_DARK_SKIN_TONE'=> "\{1F575}\{1F3FF}", 'CHARACTER_MAN_DETECTIVE'=> "\{1F575}\{FE0F}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_DETECTIVE_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_SKIN_TONE'=> "\{1F575}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\{1F575}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_DETECTIVE_DARK_SKIN_TONE'=> "\{1F575}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE'=> "\{1F575}\{FE0F}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F575}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_SKIN_TONE'=> "\{1F575}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE_MEDIUM_DARK_SKIN_TONE'=> "\{1F575}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DETECTIVE_DARK_SKIN_TONE'=> "\{1F575}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_GUARD'=> "\{1F482}", 'CHARACTER_GUARD_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FB}", 'CHARACTER_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FC}", 'CHARACTER_GUARD_MEDIUM_SKIN_TONE'=> "\{1F482}\{1F3FD}", 'CHARACTER_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\{1F482}\{1F3FE}", 'CHARACTER_GUARD_DARK_SKIN_TONE'=> "\{1F482}\{1F3FF}", 'CHARACTER_MAN_GUARD'=> "\{1F482}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GUARD_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_SKIN_TONE'=> "\{1F482}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\{1F482}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GUARD_DARK_SKIN_TONE'=> "\{1F482}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GUARD'=> "\{1F482}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GUARD_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F482}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_SKIN_TONE'=> "\{1F482}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GUARD_MEDIUM_DARK_SKIN_TONE'=> "\{1F482}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GUARD_DARK_SKIN_TONE'=> "\{1F482}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_CONSTRUCTION_WORKER'=> "\{1F477}", 'CHARACTER_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FB}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FC}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\{1F477}\{1F3FD}", 'CHARACTER_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F477}\{1F3FE}", 'CHARACTER_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\{1F477}\{1F3FF}", 'CHARACTER_MAN_CONSTRUCTION_WORKER'=> "\{1F477}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\{1F477}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F477}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\{1F477}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER'=> "\{1F477}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F477}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_SKIN_TONE'=> "\{1F477}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_MEDIUM_DARK_SKIN_TONE'=> "\{1F477}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CONSTRUCTION_WORKER_DARK_SKIN_TONE'=> "\{1F477}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PRINCE'=> "\{1F934}", 'CHARACTER_PRINCE_LIGHT_SKIN_TONE'=> "\{1F934}\{1F3FB}", 'CHARACTER_PRINCE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F934}\{1F3FC}", 'CHARACTER_PRINCE_MEDIUM_SKIN_TONE'=> "\{1F934}\{1F3FD}", 'CHARACTER_PRINCE_MEDIUM_DARK_SKIN_TONE'=> "\{1F934}\{1F3FE}", 'CHARACTER_PRINCE_DARK_SKIN_TONE'=> "\{1F934}\{1F3FF}", 'CHARACTER_PRINCESS'=> "\{1F478}", 'CHARACTER_PRINCESS_LIGHT_SKIN_TONE'=> "\{1F478}\{1F3FB}", 'CHARACTER_PRINCESS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F478}\{1F3FC}", 'CHARACTER_PRINCESS_MEDIUM_SKIN_TONE'=> "\{1F478}\{1F3FD}", 'CHARACTER_PRINCESS_MEDIUM_DARK_SKIN_TONE'=> "\{1F478}\{1F3FE}", 'CHARACTER_PRINCESS_DARK_SKIN_TONE'=> "\{1F478}\{1F3FF}", 'CHARACTER_PERSON_WEARING_TURBAN'=> "\{1F473}", 'CHARACTER_PERSON_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FB}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FC}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\{1F473}\{1F3FD}", 'CHARACTER_PERSON_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F473}\{1F3FE}", 'CHARACTER_PERSON_WEARING_TURBAN_DARK_SKIN_TONE'=> "\{1F473}\{1F3FF}", 'CHARACTER_MAN_WEARING_TURBAN'=> "\{1F473}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\{1F473}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F473}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WEARING_TURBAN_DARK_SKIN_TONE'=> "\{1F473}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN'=> "\{1F473}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F473}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_SKIN_TONE'=> "\{1F473}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F473}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WEARING_TURBAN_DARK_SKIN_TONE'=> "\{1F473}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_WITH_CHINESE_CAP'=> "\{1F472}", 'CHARACTER_MAN_WITH_CHINESE_CAP_LIGHT_SKIN_TONE'=> "\{1F472}\{1F3FB}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F472}\{1F3FC}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_SKIN_TONE'=> "\{1F472}\{1F3FD}", 'CHARACTER_MAN_WITH_CHINESE_CAP_MEDIUM_DARK_SKIN_TONE'=> "\{1F472}\{1F3FE}", 'CHARACTER_MAN_WITH_CHINESE_CAP_DARK_SKIN_TONE'=> "\{1F472}\{1F3FF}", 'CHARACTER_WOMAN_WITH_HEADSCARF'=> "\{1F9D5}", 'CHARACTER_WOMAN_WITH_HEADSCARF_LIGHT_SKIN_TONE'=> "\{1F9D5}\{1F3FB}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D5}\{1F3FC}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_SKIN_TONE'=> "\{1F9D5}\{1F3FD}", 'CHARACTER_WOMAN_WITH_HEADSCARF_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D5}\{1F3FE}", 'CHARACTER_WOMAN_WITH_HEADSCARF_DARK_SKIN_TONE'=> "\{1F9D5}\{1F3FF}", 'CHARACTER_BEARDED_PERSON'=> "\{1F9D4}", 'CHARACTER_BEARDED_PERSON_LIGHT_SKIN_TONE'=> "\{1F9D4}\{1F3FB}", 'CHARACTER_BEARDED_PERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D4}\{1F3FC}", 'CHARACTER_BEARDED_PERSON_MEDIUM_SKIN_TONE'=> "\{1F9D4}\{1F3FD}", 'CHARACTER_BEARDED_PERSON_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D4}\{1F3FE}", 'CHARACTER_BEARDED_PERSON_DARK_SKIN_TONE'=> "\{1F9D4}\{1F3FF}", 'CHARACTER_BLOND_HAIRED_PERSON'=> "\{1F471}", 'CHARACTER_BLOND_HAIRED_PERSON_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FB}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FC}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_SKIN_TONE'=> "\{1F471}\{1F3FD}", 'CHARACTER_BLOND_HAIRED_PERSON_MEDIUM_DARK_SKIN_TONE'=> "\{1F471}\{1F3FE}", 'CHARACTER_BLOND_HAIRED_PERSON_DARK_SKIN_TONE'=> "\{1F471}\{1F3FF}", 'CHARACTER_BLOND_HAIRED_MAN'=> "\{1F471}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_SKIN_TONE'=> "\{1F471}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F471}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_MAN_DARK_SKIN_TONE'=> "\{1F471}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN'=> "\{1F471}\{200D}\{2640}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F471}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_SKIN_TONE'=> "\{1F471}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F471}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_BLOND_HAIRED_WOMAN_DARK_SKIN_TONE'=> "\{1F471}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_RED_HAIRED'=> "\{1F468}\{200D}\{1F9B0}", 'CHARACTER_MAN_RED_HAIRED_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F9B0}", 'CHARACTER_MAN_RED_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F9B0}", 'CHARACTER_MAN_RED_HAIRED_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED'=> "\{1F469}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F9B0}", 'CHARACTER_WOMAN_RED_HAIRED_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F9B0}", 'CHARACTER_MAN_CURLY_HAIRED'=> "\{1F468}\{200D}\{1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F9B1}", 'CHARACTER_MAN_CURLY_HAIRED_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED'=> "\{1F469}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F9B1}", 'CHARACTER_WOMAN_CURLY_HAIRED_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F9B1}", 'CHARACTER_MAN_BALD'=> "\{1F468}\{200D}\{1F9B2}", 'CHARACTER_MAN_BALD_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F9B2}", 'CHARACTER_MAN_BALD_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F9B2}", 'CHARACTER_MAN_BALD_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD'=> "\{1F469}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F9B2}", 'CHARACTER_WOMAN_BALD_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F9B2}", 'CHARACTER_MAN_WHITE_HAIRED'=> "\{1F468}\{200D}\{1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FB}\{200D}\{1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F468}\{1F3FC}\{200D}\{1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F468}\{1F3FD}\{200D}\{1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F468}\{1F3FE}\{200D}\{1F9B3}", 'CHARACTER_MAN_WHITE_HAIRED_DARK_SKIN_TONE'=> "\{1F468}\{1F3FF}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED'=> "\{1F469}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FB}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F469}\{1F3FC}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_SKIN_TONE'=> "\{1F469}\{1F3FD}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_MEDIUM_DARK_SKIN_TONE'=> "\{1F469}\{1F3FE}\{200D}\{1F9B3}", 'CHARACTER_WOMAN_WHITE_HAIRED_DARK_SKIN_TONE'=> "\{1F469}\{1F3FF}\{200D}\{1F9B3}", 'CHARACTER_MAN_IN_TUXEDO'=> "\{1F935}", 'CHARACTER_MAN_IN_TUXEDO_LIGHT_SKIN_TONE'=> "\{1F935}\{1F3FB}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F935}\{1F3FC}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_SKIN_TONE'=> "\{1F935}\{1F3FD}", 'CHARACTER_MAN_IN_TUXEDO_MEDIUM_DARK_SKIN_TONE'=> "\{1F935}\{1F3FE}", 'CHARACTER_MAN_IN_TUXEDO_DARK_SKIN_TONE'=> "\{1F935}\{1F3FF}", 'CHARACTER_BRIDE_WITH_VEIL'=> "\{1F470}", 'CHARACTER_BRIDE_WITH_VEIL_LIGHT_SKIN_TONE'=> "\{1F470}\{1F3FB}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F470}\{1F3FC}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_SKIN_TONE'=> "\{1F470}\{1F3FD}", 'CHARACTER_BRIDE_WITH_VEIL_MEDIUM_DARK_SKIN_TONE'=> "\{1F470}\{1F3FE}", 'CHARACTER_BRIDE_WITH_VEIL_DARK_SKIN_TONE'=> "\{1F470}\{1F3FF}", 'CHARACTER_PREGNANT_WOMAN'=> "\{1F930}", 'CHARACTER_PREGNANT_WOMAN_LIGHT_SKIN_TONE'=> "\{1F930}\{1F3FB}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F930}\{1F3FC}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_SKIN_TONE'=> "\{1F930}\{1F3FD}", 'CHARACTER_PREGNANT_WOMAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F930}\{1F3FE}", 'CHARACTER_PREGNANT_WOMAN_DARK_SKIN_TONE'=> "\{1F930}\{1F3FF}", 'CHARACTER_BREAST_FEEDING'=> "\{1F931}", 'CHARACTER_BREAST_FEEDING_LIGHT_SKIN_TONE'=> "\{1F931}\{1F3FB}", 'CHARACTER_BREAST_FEEDING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F931}\{1F3FC}", 'CHARACTER_BREAST_FEEDING_MEDIUM_SKIN_TONE'=> "\{1F931}\{1F3FD}", 'CHARACTER_BREAST_FEEDING_MEDIUM_DARK_SKIN_TONE'=> "\{1F931}\{1F3FE}", 'CHARACTER_BREAST_FEEDING_DARK_SKIN_TONE'=> "\{1F931}\{1F3FF}", 'CHARACTER_BABY_ANGEL'=> "\{1F47C}", 'CHARACTER_BABY_ANGEL_LIGHT_SKIN_TONE'=> "\{1F47C}\{1F3FB}", 'CHARACTER_BABY_ANGEL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F47C}\{1F3FC}", 'CHARACTER_BABY_ANGEL_MEDIUM_SKIN_TONE'=> "\{1F47C}\{1F3FD}", 'CHARACTER_BABY_ANGEL_MEDIUM_DARK_SKIN_TONE'=> "\{1F47C}\{1F3FE}", 'CHARACTER_BABY_ANGEL_DARK_SKIN_TONE'=> "\{1F47C}\{1F3FF}", 'CHARACTER_SANTA_CLAUS'=> "\{1F385}", 'CHARACTER_SANTA_CLAUS_LIGHT_SKIN_TONE'=> "\{1F385}\{1F3FB}", 'CHARACTER_SANTA_CLAUS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F385}\{1F3FC}", 'CHARACTER_SANTA_CLAUS_MEDIUM_SKIN_TONE'=> "\{1F385}\{1F3FD}", 'CHARACTER_SANTA_CLAUS_MEDIUM_DARK_SKIN_TONE'=> "\{1F385}\{1F3FE}", 'CHARACTER_SANTA_CLAUS_DARK_SKIN_TONE'=> "\{1F385}\{1F3FF}", 'CHARACTER_MRS_CLAUS'=> "\{1F936}", 'CHARACTER_MRS_CLAUS_LIGHT_SKIN_TONE'=> "\{1F936}\{1F3FB}", 'CHARACTER_MRS_CLAUS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F936}\{1F3FC}", 'CHARACTER_MRS_CLAUS_MEDIUM_SKIN_TONE'=> "\{1F936}\{1F3FD}", 'CHARACTER_MRS_CLAUS_MEDIUM_DARK_SKIN_TONE'=> "\{1F936}\{1F3FE}", 'CHARACTER_MRS_CLAUS_DARK_SKIN_TONE'=> "\{1F936}\{1F3FF}", 'CHARACTER_SUPERHERO'=> "\{1F9B8}", 'CHARACTER_SUPERHERO_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FB}", 'CHARACTER_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FC}", 'CHARACTER_SUPERHERO_MEDIUM_SKIN_TONE'=> "\{1F9B8}\{1F3FD}", 'CHARACTER_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FE}", 'CHARACTER_SUPERHERO_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FF}", 'CHARACTER_WOMAN_SUPERHERO'=> "\{1F9B8}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERHERO_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_SKIN_TONE'=> "\{1F9B8}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERHERO_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_SUPERHERO'=> "\{1F9B8}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERHERO_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B8}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_SKIN_TONE'=> "\{1F9B8}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERHERO_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERHERO_DARK_SKIN_TONE'=> "\{1F9B8}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_SUPERVILLAIN'=> "\{1F9B9}", 'CHARACTER_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FB}", 'CHARACTER_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FC}", 'CHARACTER_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\{1F9B9}\{1F3FD}", 'CHARACTER_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FE}", 'CHARACTER_SUPERVILLAIN_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FF}", 'CHARACTER_WOMAN_SUPERVILLAIN'=> "\{1F9B9}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\{1F9B9}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SUPERVILLAIN_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN'=> "\{1F9B9}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B9}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_SKIN_TONE'=> "\{1F9B9}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SUPERVILLAIN_DARK_SKIN_TONE'=> "\{1F9B9}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAGE'=> "\{1F9D9}", 'CHARACTER_MAGE_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FB}", 'CHARACTER_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FC}", 'CHARACTER_MAGE_MEDIUM_SKIN_TONE'=> "\{1F9D9}\{1F3FD}", 'CHARACTER_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FE}", 'CHARACTER_MAGE_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FF}", 'CHARACTER_WOMAN_MAGE'=> "\{1F9D9}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MAGE_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_SKIN_TONE'=> "\{1F9D9}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MAGE_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_MAGE'=> "\{1F9D9}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MAGE_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D9}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_SKIN_TONE'=> "\{1F9D9}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MAGE_DARK_SKIN_TONE'=> "\{1F9D9}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_FAIRY'=> "\{1F9DA}", 'CHARACTER_FAIRY_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FB}", 'CHARACTER_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FC}", 'CHARACTER_FAIRY_MEDIUM_SKIN_TONE'=> "\{1F9DA}\{1F3FD}", 'CHARACTER_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FE}", 'CHARACTER_FAIRY_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FF}", 'CHARACTER_WOMAN_FAIRY'=> "\{1F9DA}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FAIRY_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_SKIN_TONE'=> "\{1F9DA}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FAIRY_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_FAIRY'=> "\{1F9DA}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FAIRY_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DA}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_SKIN_TONE'=> "\{1F9DA}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FAIRY_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FAIRY_DARK_SKIN_TONE'=> "\{1F9DA}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_VAMPIRE'=> "\{1F9DB}", 'CHARACTER_VAMPIRE_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FB}", 'CHARACTER_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FC}", 'CHARACTER_VAMPIRE_MEDIUM_SKIN_TONE'=> "\{1F9DB}\{1F3FD}", 'CHARACTER_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FE}", 'CHARACTER_VAMPIRE_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FF}", 'CHARACTER_WOMAN_VAMPIRE'=> "\{1F9DB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_VAMPIRE_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_SKIN_TONE'=> "\{1F9DB}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_VAMPIRE_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_VAMPIRE'=> "\{1F9DB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_VAMPIRE_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DB}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_SKIN_TONE'=> "\{1F9DB}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_VAMPIRE_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_VAMPIRE_DARK_SKIN_TONE'=> "\{1F9DB}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERPERSON'=> "\{1F9DC}", 'CHARACTER_MERPERSON_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FB}", 'CHARACTER_MERPERSON_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FC}", 'CHARACTER_MERPERSON_MEDIUM_SKIN_TONE'=> "\{1F9DC}\{1F3FD}", 'CHARACTER_MERPERSON_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FE}", 'CHARACTER_MERPERSON_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FF}", 'CHARACTER_MERMAID'=> "\{1F9DC}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAID_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAID_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAID_MEDIUM_SKIN_TONE'=> "\{1F9DC}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAID_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAID_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MERMAN'=> "\{1F9DC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERMAN_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERMAN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DC}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERMAN_MEDIUM_SKIN_TONE'=> "\{1F9DC}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERMAN_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MERMAN_DARK_SKIN_TONE'=> "\{1F9DC}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_ELF'=> "\{1F9DD}", 'CHARACTER_ELF_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FB}", 'CHARACTER_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FC}", 'CHARACTER_ELF_MEDIUM_SKIN_TONE'=> "\{1F9DD}\{1F3FD}", 'CHARACTER_ELF_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FE}", 'CHARACTER_ELF_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FF}", 'CHARACTER_WOMAN_ELF'=> "\{1F9DD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ELF_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_SKIN_TONE'=> "\{1F9DD}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ELF_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ELF_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_ELF'=> "\{1F9DD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ELF_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9DD}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_SKIN_TONE'=> "\{1F9DD}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ELF_MEDIUM_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ELF_DARK_SKIN_TONE'=> "\{1F9DD}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_GENIE'=> "\{1F9DE}", 'CHARACTER_WOMAN_GENIE'=> "\{1F9DE}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_GENIE'=> "\{1F9DE}\{200D}\{2642}\{FE0F}", 'CHARACTER_ZOMBIE'=> "\{1F9DF}", 'CHARACTER_WOMAN_ZOMBIE'=> "\{1F9DF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_ZOMBIE'=> "\{1F9DF}\{200D}\{2642}\{FE0F}", 'CHARACTER_PERSON_FROWNING'=> "\{1F64D}", 'CHARACTER_PERSON_FROWNING_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FB}", 'CHARACTER_PERSON_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FC}", 'CHARACTER_PERSON_FROWNING_MEDIUM_SKIN_TONE'=> "\{1F64D}\{1F3FD}", 'CHARACTER_PERSON_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FE}", 'CHARACTER_PERSON_FROWNING_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FF}", 'CHARACTER_MAN_FROWNING'=> "\{1F64D}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FROWNING_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_SKIN_TONE'=> "\{1F64D}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FROWNING_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_FROWNING'=> "\{1F64D}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FROWNING_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64D}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_SKIN_TONE'=> "\{1F64D}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FROWNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FROWNING_DARK_SKIN_TONE'=> "\{1F64D}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_POUTING'=> "\{1F64E}", 'CHARACTER_PERSON_POUTING_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FB}", 'CHARACTER_PERSON_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FC}", 'CHARACTER_PERSON_POUTING_MEDIUM_SKIN_TONE'=> "\{1F64E}\{1F3FD}", 'CHARACTER_PERSON_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FE}", 'CHARACTER_PERSON_POUTING_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FF}", 'CHARACTER_MAN_POUTING'=> "\{1F64E}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POUTING_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_SKIN_TONE'=> "\{1F64E}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_POUTING_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_POUTING'=> "\{1F64E}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POUTING_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64E}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_SKIN_TONE'=> "\{1F64E}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POUTING_MEDIUM_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_POUTING_DARK_SKIN_TONE'=> "\{1F64E}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_GESTURING_NO'=> "\{1F645}", 'CHARACTER_PERSON_GESTURING_NO_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FB}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FC}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\{1F645}\{1F3FD}", 'CHARACTER_PERSON_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\{1F645}\{1F3FE}", 'CHARACTER_PERSON_GESTURING_NO_DARK_SKIN_TONE'=> "\{1F645}\{1F3FF}", 'CHARACTER_MAN_GESTURING_NO'=> "\{1F645}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_NO_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\{1F645}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\{1F645}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_NO_DARK_SKIN_TONE'=> "\{1F645}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO'=> "\{1F645}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F645}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_SKIN_TONE'=> "\{1F645}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_MEDIUM_DARK_SKIN_TONE'=> "\{1F645}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_NO_DARK_SKIN_TONE'=> "\{1F645}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_GESTURING_OK'=> "\{1F646}", 'CHARACTER_PERSON_GESTURING_OK_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FB}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FC}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\{1F646}\{1F3FD}", 'CHARACTER_PERSON_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\{1F646}\{1F3FE}", 'CHARACTER_PERSON_GESTURING_OK_DARK_SKIN_TONE'=> "\{1F646}\{1F3FF}", 'CHARACTER_MAN_GESTURING_OK'=> "\{1F646}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_OK_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\{1F646}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\{1F646}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GESTURING_OK_DARK_SKIN_TONE'=> "\{1F646}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK'=> "\{1F646}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F646}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_SKIN_TONE'=> "\{1F646}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_MEDIUM_DARK_SKIN_TONE'=> "\{1F646}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GESTURING_OK_DARK_SKIN_TONE'=> "\{1F646}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_TIPPING_HAND'=> "\{1F481}", 'CHARACTER_PERSON_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FB}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FC}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\{1F481}\{1F3FD}", 'CHARACTER_PERSON_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F481}\{1F3FE}", 'CHARACTER_PERSON_TIPPING_HAND_DARK_SKIN_TONE'=> "\{1F481}\{1F3FF}", 'CHARACTER_MAN_TIPPING_HAND'=> "\{1F481}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\{1F481}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F481}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_TIPPING_HAND_DARK_SKIN_TONE'=> "\{1F481}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND'=> "\{1F481}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F481}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_SKIN_TONE'=> "\{1F481}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F481}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_TIPPING_HAND_DARK_SKIN_TONE'=> "\{1F481}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_RAISING_HAND'=> "\{1F64B}", 'CHARACTER_PERSON_RAISING_HAND_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FB}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FC}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\{1F64B}\{1F3FD}", 'CHARACTER_PERSON_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FE}", 'CHARACTER_PERSON_RAISING_HAND_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FF}", 'CHARACTER_MAN_RAISING_HAND'=> "\{1F64B}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RAISING_HAND_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\{1F64B}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RAISING_HAND_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND'=> "\{1F64B}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64B}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_SKIN_TONE'=> "\{1F64B}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RAISING_HAND_DARK_SKIN_TONE'=> "\{1F64B}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_BOWING'=> "\{1F647}", 'CHARACTER_PERSON_BOWING_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FB}", 'CHARACTER_PERSON_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FC}", 'CHARACTER_PERSON_BOWING_MEDIUM_SKIN_TONE'=> "\{1F647}\{1F3FD}", 'CHARACTER_PERSON_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\{1F647}\{1F3FE}", 'CHARACTER_PERSON_BOWING_DARK_SKIN_TONE'=> "\{1F647}\{1F3FF}", 'CHARACTER_MAN_BOWING'=> "\{1F647}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOWING_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_SKIN_TONE'=> "\{1F647}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\{1F647}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOWING_DARK_SKIN_TONE'=> "\{1F647}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_BOWING'=> "\{1F647}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOWING_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F647}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_SKIN_TONE'=> "\{1F647}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOWING_MEDIUM_DARK_SKIN_TONE'=> "\{1F647}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOWING_DARK_SKIN_TONE'=> "\{1F647}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_FACEPALMING'=> "\{1F926}", 'CHARACTER_PERSON_FACEPALMING_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FB}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FC}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_SKIN_TONE'=> "\{1F926}\{1F3FD}", 'CHARACTER_PERSON_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F926}\{1F3FE}", 'CHARACTER_PERSON_FACEPALMING_DARK_SKIN_TONE'=> "\{1F926}\{1F3FF}", 'CHARACTER_MAN_FACEPALMING'=> "\{1F926}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FACEPALMING_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_SKIN_TONE'=> "\{1F926}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F926}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_FACEPALMING_DARK_SKIN_TONE'=> "\{1F926}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING'=> "\{1F926}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F926}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_SKIN_TONE'=> "\{1F926}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F926}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_FACEPALMING_DARK_SKIN_TONE'=> "\{1F926}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_SHRUGGING'=> "\{1F937}", 'CHARACTER_PERSON_SHRUGGING_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FB}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FC}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_SKIN_TONE'=> "\{1F937}\{1F3FD}", 'CHARACTER_PERSON_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\{1F937}\{1F3FE}", 'CHARACTER_PERSON_SHRUGGING_DARK_SKIN_TONE'=> "\{1F937}\{1F3FF}", 'CHARACTER_MAN_SHRUGGING'=> "\{1F937}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SHRUGGING_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_SKIN_TONE'=> "\{1F937}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\{1F937}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SHRUGGING_DARK_SKIN_TONE'=> "\{1F937}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING'=> "\{1F937}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F937}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_SKIN_TONE'=> "\{1F937}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING_MEDIUM_DARK_SKIN_TONE'=> "\{1F937}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SHRUGGING_DARK_SKIN_TONE'=> "\{1F937}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_GETTING_MASSAGE'=> "\{1F486}", 'CHARACTER_PERSON_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FB}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FC}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\{1F486}\{1F3FD}", 'CHARACTER_PERSON_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F486}\{1F3FE}", 'CHARACTER_PERSON_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\{1F486}\{1F3FF}", 'CHARACTER_MAN_GETTING_MASSAGE'=> "\{1F486}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\{1F486}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F486}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\{1F486}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE'=> "\{1F486}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F486}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_SKIN_TONE'=> "\{1F486}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_MEDIUM_DARK_SKIN_TONE'=> "\{1F486}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_MASSAGE_DARK_SKIN_TONE'=> "\{1F486}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_GETTING_HAIRCUT'=> "\{1F487}", 'CHARACTER_PERSON_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FB}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FC}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\{1F487}\{1F3FD}", 'CHARACTER_PERSON_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\{1F487}\{1F3FE}", 'CHARACTER_PERSON_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\{1F487}\{1F3FF}", 'CHARACTER_MAN_GETTING_HAIRCUT'=> "\{1F487}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\{1F487}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\{1F487}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\{1F487}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT'=> "\{1F487}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F487}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_SKIN_TONE'=> "\{1F487}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_MEDIUM_DARK_SKIN_TONE'=> "\{1F487}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GETTING_HAIRCUT_DARK_SKIN_TONE'=> "\{1F487}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_WALKING'=> "\{1F6B6}", 'CHARACTER_PERSON_WALKING_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FB}", 'CHARACTER_PERSON_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FC}", 'CHARACTER_PERSON_WALKING_MEDIUM_SKIN_TONE'=> "\{1F6B6}\{1F3FD}", 'CHARACTER_PERSON_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FE}", 'CHARACTER_PERSON_WALKING_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FF}", 'CHARACTER_MAN_WALKING'=> "\{1F6B6}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WALKING_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_SKIN_TONE'=> "\{1F6B6}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_WALKING_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_WALKING'=> "\{1F6B6}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WALKING_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B6}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_SKIN_TONE'=> "\{1F6B6}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WALKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_WALKING_DARK_SKIN_TONE'=> "\{1F6B6}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_RUNNING'=> "\{1F3C3}", 'CHARACTER_PERSON_RUNNING_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FB}", 'CHARACTER_PERSON_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FC}", 'CHARACTER_PERSON_RUNNING_MEDIUM_SKIN_TONE'=> "\{1F3C3}\{1F3FD}", 'CHARACTER_PERSON_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FE}", 'CHARACTER_PERSON_RUNNING_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FF}", 'CHARACTER_MAN_RUNNING'=> "\{1F3C3}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RUNNING_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_SKIN_TONE'=> "\{1F3C3}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_RUNNING_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_RUNNING'=> "\{1F3C3}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RUNNING_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C3}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_SKIN_TONE'=> "\{1F3C3}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RUNNING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_RUNNING_DARK_SKIN_TONE'=> "\{1F3C3}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_DANCING'=> "\{1F483}", 'CHARACTER_WOMAN_DANCING_LIGHT_SKIN_TONE'=> "\{1F483}\{1F3FB}", 'CHARACTER_WOMAN_DANCING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F483}\{1F3FC}", 'CHARACTER_WOMAN_DANCING_MEDIUM_SKIN_TONE'=> "\{1F483}\{1F3FD}", 'CHARACTER_WOMAN_DANCING_MEDIUM_DARK_SKIN_TONE'=> "\{1F483}\{1F3FE}", 'CHARACTER_WOMAN_DANCING_DARK_SKIN_TONE'=> "\{1F483}\{1F3FF}", 'CHARACTER_MAN_DANCING'=> "\{1F57A}", 'CHARACTER_MAN_DANCING_LIGHT_SKIN_TONE'=> "\{1F57A}\{1F3FB}", 'CHARACTER_MAN_DANCING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F57A}\{1F3FC}", 'CHARACTER_MAN_DANCING_MEDIUM_SKIN_TONE'=> "\{1F57A}\{1F3FD}", 'CHARACTER_MAN_DANCING_MEDIUM_DARK_SKIN_TONE'=> "\{1F57A}\{1F3FE}", 'CHARACTER_MAN_DANCING_DARK_SKIN_TONE'=> "\{1F57A}\{1F3FF}", 'CHARACTER_PEOPLE_WITH_BUNNY_EARS'=> "\{1F46F}", 'CHARACTER_MEN_WITH_BUNNY_EARS'=> "\{1F46F}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMEN_WITH_BUNNY_EARS'=> "\{1F46F}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_IN_STEAMY_ROOM'=> "\{1F9D6}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FB}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FC}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\{1F9D6}\{1F3FD}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FE}", 'CHARACTER_PERSON_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FF}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM'=> "\{1F9D6}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\{1F9D6}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM'=> "\{1F9D6}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D6}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_SKIN_TONE'=> "\{1F9D6}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_STEAMY_ROOM_DARK_SKIN_TONE'=> "\{1F9D6}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_PERSON_CLIMBING'=> "\{1F9D7}", 'CHARACTER_PERSON_CLIMBING_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FB}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FC}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_SKIN_TONE'=> "\{1F9D7}\{1F3FD}", 'CHARACTER_PERSON_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FE}", 'CHARACTER_PERSON_CLIMBING_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FF}", 'CHARACTER_WOMAN_CLIMBING'=> "\{1F9D7}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CLIMBING_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_SKIN_TONE'=> "\{1F9D7}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CLIMBING_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_CLIMBING'=> "\{1F9D7}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CLIMBING_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D7}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_SKIN_TONE'=> "\{1F9D7}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CLIMBING_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CLIMBING_DARK_SKIN_TONE'=> "\{1F9D7}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_PERSON_IN_LOTUS_POSITION'=> "\{1F9D8}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FB}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FC}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\{1F9D8}\{1F3FD}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FE}", 'CHARACTER_PERSON_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FF}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION'=> "\{1F9D8}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\{1F9D8}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION'=> "\{1F9D8}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9D8}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_SKIN_TONE'=> "\{1F9D8}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_MEDIUM_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_IN_LOTUS_POSITION_DARK_SKIN_TONE'=> "\{1F9D8}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_PERSON_TAKING_BATH'=> "\{1F6C0}", 'CHARACTER_PERSON_TAKING_BATH_LIGHT_SKIN_TONE'=> "\{1F6C0}\{1F3FB}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6C0}\{1F3FC}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_SKIN_TONE'=> "\{1F6C0}\{1F3FD}", 'CHARACTER_PERSON_TAKING_BATH_MEDIUM_DARK_SKIN_TONE'=> "\{1F6C0}\{1F3FE}", 'CHARACTER_PERSON_TAKING_BATH_DARK_SKIN_TONE'=> "\{1F6C0}\{1F3FF}", 'CHARACTER_PERSON_IN_BED'=> "\{1F6CC}", 'CHARACTER_PERSON_IN_BED_LIGHT_SKIN_TONE'=> "\{1F6CC}\{1F3FB}", 'CHARACTER_PERSON_IN_BED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6CC}\{1F3FC}", 'CHARACTER_PERSON_IN_BED_MEDIUM_SKIN_TONE'=> "\{1F6CC}\{1F3FD}", 'CHARACTER_PERSON_IN_BED_MEDIUM_DARK_SKIN_TONE'=> "\{1F6CC}\{1F3FE}", 'CHARACTER_PERSON_IN_BED_DARK_SKIN_TONE'=> "\{1F6CC}\{1F3FF}", 'CHARACTER_MAN_IN_SUIT_LEVITATING'=> "\{1F574}\{FE0F}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_LIGHT_SKIN_TONE'=> "\{1F574}\{1F3FB}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F574}\{1F3FC}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_SKIN_TONE'=> "\{1F574}\{1F3FD}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_MEDIUM_DARK_SKIN_TONE'=> "\{1F574}\{1F3FE}", 'CHARACTER_MAN_IN_SUIT_LEVITATING_DARK_SKIN_TONE'=> "\{1F574}\{1F3FF}", 'CHARACTER_SPEAKING_HEAD'=> "\{1F5E3}\{FE0F}", 'CHARACTER_BUST_IN_SILHOUETTE'=> "\{1F464}", 'CHARACTER_BUSTS_IN_SILHOUETTE'=> "\{1F465}", 'CHARACTER_PERSON_FENCING'=> "\{1F93A}", 'CHARACTER_HORSE_RACING'=> "\{1F3C7}", 'CHARACTER_HORSE_RACING_LIGHT_SKIN_TONE'=> "\{1F3C7}\{1F3FB}", 'CHARACTER_HORSE_RACING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C7}\{1F3FC}", 'CHARACTER_HORSE_RACING_MEDIUM_SKIN_TONE'=> "\{1F3C7}\{1F3FD}", 'CHARACTER_HORSE_RACING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C7}\{1F3FE}", 'CHARACTER_HORSE_RACING_DARK_SKIN_TONE'=> "\{1F3C7}\{1F3FF}", 'CHARACTER_SKIER'=> "\{26F7}\{FE0F}", 'CHARACTER_SNOWBOARDER'=> "\{1F3C2}", 'CHARACTER_SNOWBOARDER_LIGHT_SKIN_TONE'=> "\{1F3C2}\{1F3FB}", 'CHARACTER_SNOWBOARDER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C2}\{1F3FC}", 'CHARACTER_SNOWBOARDER_MEDIUM_SKIN_TONE'=> "\{1F3C2}\{1F3FD}", 'CHARACTER_SNOWBOARDER_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C2}\{1F3FE}", 'CHARACTER_SNOWBOARDER_DARK_SKIN_TONE'=> "\{1F3C2}\{1F3FF}", 'CHARACTER_PERSON_GOLFING'=> "\{1F3CC}\{FE0F}", 'CHARACTER_PERSON_GOLFING_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FB}", 'CHARACTER_PERSON_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FC}", 'CHARACTER_PERSON_GOLFING_MEDIUM_SKIN_TONE'=> "\{1F3CC}\{1F3FD}", 'CHARACTER_PERSON_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FE}", 'CHARACTER_PERSON_GOLFING_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FF}", 'CHARACTER_MAN_GOLFING'=> "\{1F3CC}\{FE0F}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GOLFING_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_SKIN_TONE'=> "\{1F3CC}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_GOLFING_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_GOLFING'=> "\{1F3CC}\{FE0F}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GOLFING_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CC}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_SKIN_TONE'=> "\{1F3CC}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GOLFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_GOLFING_DARK_SKIN_TONE'=> "\{1F3CC}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_SURFING'=> "\{1F3C4}", 'CHARACTER_PERSON_SURFING_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FB}", 'CHARACTER_PERSON_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FC}", 'CHARACTER_PERSON_SURFING_MEDIUM_SKIN_TONE'=> "\{1F3C4}\{1F3FD}", 'CHARACTER_PERSON_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FE}", 'CHARACTER_PERSON_SURFING_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FF}", 'CHARACTER_MAN_SURFING'=> "\{1F3C4}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SURFING_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_SKIN_TONE'=> "\{1F3C4}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SURFING_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_SURFING'=> "\{1F3C4}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SURFING_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3C4}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_SKIN_TONE'=> "\{1F3C4}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SURFING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SURFING_DARK_SKIN_TONE'=> "\{1F3C4}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_ROWING_BOAT'=> "\{1F6A3}", 'CHARACTER_PERSON_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FB}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FC}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\{1F6A3}\{1F3FD}", 'CHARACTER_PERSON_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FE}", 'CHARACTER_PERSON_ROWING_BOAT_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FF}", 'CHARACTER_MAN_ROWING_BOAT'=> "\{1F6A3}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\{1F6A3}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_ROWING_BOAT_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT'=> "\{1F6A3}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6A3}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_SKIN_TONE'=> "\{1F6A3}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_MEDIUM_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_ROWING_BOAT_DARK_SKIN_TONE'=> "\{1F6A3}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_SWIMMING'=> "\{1F3CA}", 'CHARACTER_PERSON_SWIMMING_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FB}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FC}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_SKIN_TONE'=> "\{1F3CA}\{1F3FD}", 'CHARACTER_PERSON_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FE}", 'CHARACTER_PERSON_SWIMMING_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FF}", 'CHARACTER_MAN_SWIMMING'=> "\{1F3CA}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SWIMMING_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_SKIN_TONE'=> "\{1F3CA}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_SWIMMING_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING'=> "\{1F3CA}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CA}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_SKIN_TONE'=> "\{1F3CA}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_SWIMMING_DARK_SKIN_TONE'=> "\{1F3CA}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_BOUNCING_BALL'=> "\{26F9}\{FE0F}", 'CHARACTER_PERSON_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FB}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FC}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\{26F9}\{1F3FD}", 'CHARACTER_PERSON_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\{26F9}\{1F3FE}", 'CHARACTER_PERSON_BOUNCING_BALL_DARK_SKIN_TONE'=> "\{26F9}\{1F3FF}", 'CHARACTER_MAN_BOUNCING_BALL'=> "\{26F9}\{FE0F}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\{26F9}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\{26F9}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BOUNCING_BALL_DARK_SKIN_TONE'=> "\{26F9}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL'=> "\{26F9}\{FE0F}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{26F9}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_SKIN_TONE'=> "\{26F9}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_MEDIUM_DARK_SKIN_TONE'=> "\{26F9}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BOUNCING_BALL_DARK_SKIN_TONE'=> "\{26F9}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_LIFTING_WEIGHTS'=> "\{1F3CB}\{FE0F}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FB}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FC}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\{1F3CB}\{1F3FD}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FE}", 'CHARACTER_PERSON_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FF}", 'CHARACTER_MAN_LIFTING_WEIGHTS'=> "\{1F3CB}\{FE0F}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\{1F3CB}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS'=> "\{1F3CB}\{FE0F}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F3CB}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_SKIN_TONE'=> "\{1F3CB}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_MEDIUM_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_LIFTING_WEIGHTS_DARK_SKIN_TONE'=> "\{1F3CB}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_BIKING'=> "\{1F6B4}", 'CHARACTER_PERSON_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FB}", 'CHARACTER_PERSON_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FC}", 'CHARACTER_PERSON_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B4}\{1F3FD}", 'CHARACTER_PERSON_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FE}", 'CHARACTER_PERSON_BIKING_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FF}", 'CHARACTER_MAN_BIKING'=> "\{1F6B4}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B4}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_BIKING_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_BIKING'=> "\{1F6B4}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B4}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B4}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_BIKING_DARK_SKIN_TONE'=> "\{1F6B4}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_MOUNTAIN_BIKING'=> "\{1F6B5}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FB}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FC}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B5}\{1F3FD}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FE}", 'CHARACTER_PERSON_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FF}", 'CHARACTER_MAN_MOUNTAIN_BIKING'=> "\{1F6B5}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B5}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING'=> "\{1F6B5}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F6B5}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_SKIN_TONE'=> "\{1F6B5}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_MEDIUM_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_MOUNTAIN_BIKING_DARK_SKIN_TONE'=> "\{1F6B5}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_RACING_CAR'=> "\{1F3CE}\{FE0F}", 'CHARACTER_MOTORCYCLE'=> "\{1F3CD}\{FE0F}", 'CHARACTER_PERSON_CARTWHEELING'=> "\{1F938}", 'CHARACTER_PERSON_CARTWHEELING_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FB}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FC}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\{1F938}\{1F3FD}", 'CHARACTER_PERSON_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\{1F938}\{1F3FE}", 'CHARACTER_PERSON_CARTWHEELING_DARK_SKIN_TONE'=> "\{1F938}\{1F3FF}", 'CHARACTER_MAN_CARTWHEELING'=> "\{1F938}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CARTWHEELING_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\{1F938}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\{1F938}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_CARTWHEELING_DARK_SKIN_TONE'=> "\{1F938}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING'=> "\{1F938}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F938}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_SKIN_TONE'=> "\{1F938}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_MEDIUM_DARK_SKIN_TONE'=> "\{1F938}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_CARTWHEELING_DARK_SKIN_TONE'=> "\{1F938}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PEOPLE_WRESTLING'=> "\{1F93C}", 'CHARACTER_MEN_WRESTLING'=> "\{1F93C}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMEN_WRESTLING'=> "\{1F93C}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_PLAYING_WATER_POLO'=> "\{1F93D}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FB}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FC}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\{1F93D}\{1F3FD}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FE}", 'CHARACTER_PERSON_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FF}", 'CHARACTER_MAN_PLAYING_WATER_POLO'=> "\{1F93D}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\{1F93D}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO'=> "\{1F93D}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93D}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_SKIN_TONE'=> "\{1F93D}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_MEDIUM_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_WATER_POLO_DARK_SKIN_TONE'=> "\{1F93D}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_PLAYING_HANDBALL'=> "\{1F93E}", 'CHARACTER_PERSON_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FB}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FC}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\{1F93E}\{1F3FD}", 'CHARACTER_PERSON_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FE}", 'CHARACTER_PERSON_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FF}", 'CHARACTER_MAN_PLAYING_HANDBALL'=> "\{1F93E}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\{1F93E}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL'=> "\{1F93E}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F93E}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_SKIN_TONE'=> "\{1F93E}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_MEDIUM_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_PLAYING_HANDBALL_DARK_SKIN_TONE'=> "\{1F93E}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_PERSON_JUGGLING'=> "\{1F939}", 'CHARACTER_PERSON_JUGGLING_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FB}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FC}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_SKIN_TONE'=> "\{1F939}\{1F3FD}", 'CHARACTER_PERSON_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\{1F939}\{1F3FE}", 'CHARACTER_PERSON_JUGGLING_DARK_SKIN_TONE'=> "\{1F939}\{1F3FF}", 'CHARACTER_MAN_JUGGLING'=> "\{1F939}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_JUGGLING_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FB}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FC}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_SKIN_TONE'=> "\{1F939}\{1F3FD}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\{1F939}\{1F3FE}\{200D}\{2642}\{FE0F}", 'CHARACTER_MAN_JUGGLING_DARK_SKIN_TONE'=> "\{1F939}\{1F3FF}\{200D}\{2642}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING'=> "\{1F939}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FB}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F939}\{1F3FC}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_SKIN_TONE'=> "\{1F939}\{1F3FD}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING_MEDIUM_DARK_SKIN_TONE'=> "\{1F939}\{1F3FE}\{200D}\{2640}\{FE0F}", 'CHARACTER_WOMAN_JUGGLING_DARK_SKIN_TONE'=> "\{1F939}\{1F3FF}\{200D}\{2640}\{FE0F}", 'CHARACTER_MAN_AND_WOMAN_HOLDING_HANDS'=> "\{1F46B}", 'CHARACTER_TWO_MEN_HOLDING_HANDS'=> "\{1F46C}", 'CHARACTER_TWO_WOMEN_HOLDING_HANDS'=> "\{1F46D}", 'CHARACTER_KISS'=> "\{1F48F}", 'CHARACTER_KISS_WOMAN_MAN'=> "\{1F469}\{200D}\{2764}\{FE0F}\{200D}\{1F48B}\{200D}\{1F468}", 'CHARACTER_KISS_MAN_MAN'=> "\{1F468}\{200D}\{2764}\{FE0F}\{200D}\{1F48B}\{200D}\{1F468}", 'CHARACTER_KISS_WOMAN_WOMAN'=> "\{1F469}\{200D}\{2764}\{FE0F}\{200D}\{1F48B}\{200D}\{1F469}", 'CHARACTER_COUPLE_WITH_HEART'=> "\{1F491}", 'CHARACTER_COUPLE_WITH_HEART_WOMAN_MAN'=> "\{1F469}\{200D}\{2764}\{FE0F}\{200D}\{1F468}", 'CHARACTER_COUPLE_WITH_HEART_MAN_MAN'=> "\{1F468}\{200D}\{2764}\{FE0F}\{200D}\{1F468}", 'CHARACTER_COUPLE_WITH_HEART_WOMAN_WOMAN'=> "\{1F469}\{200D}\{2764}\{FE0F}\{200D}\{1F469}", 'CHARACTER_FAMILY'=> "\{1F46A}", 'CHARACTER_FAMILY_MAN_WOMAN_BOY'=> "\{1F468}\{200D}\{1F469}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL'=> "\{1F468}\{200D}\{1F469}\{200D}\{1F467}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL_BOY'=> "\{1F468}\{200D}\{1F469}\{200D}\{1F467}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_BOY_BOY'=> "\{1F468}\{200D}\{1F469}\{200D}\{1F466}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_WOMAN_GIRL_GIRL'=> "\{1F468}\{200D}\{1F469}\{200D}\{1F467}\{200D}\{1F467}", 'CHARACTER_FAMILY_MAN_MAN_BOY'=> "\{1F468}\{200D}\{1F468}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_MAN_GIRL'=> "\{1F468}\{200D}\{1F468}\{200D}\{1F467}", 'CHARACTER_FAMILY_MAN_MAN_GIRL_BOY'=> "\{1F468}\{200D}\{1F468}\{200D}\{1F467}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_MAN_BOY_BOY'=> "\{1F468}\{200D}\{1F468}\{200D}\{1F466}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_MAN_GIRL_GIRL'=> "\{1F468}\{200D}\{1F468}\{200D}\{1F467}\{200D}\{1F467}", 'CHARACTER_FAMILY_WOMAN_WOMAN_BOY'=> "\{1F469}\{200D}\{1F469}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL'=> "\{1F469}\{200D}\{1F469}\{200D}\{1F467}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL_BOY'=> "\{1F469}\{200D}\{1F469}\{200D}\{1F467}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_BOY_BOY'=> "\{1F469}\{200D}\{1F469}\{200D}\{1F466}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_WOMAN_GIRL_GIRL'=> "\{1F469}\{200D}\{1F469}\{200D}\{1F467}\{200D}\{1F467}", 'CHARACTER_FAMILY_MAN_BOY'=> "\{1F468}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_BOY_BOY'=> "\{1F468}\{200D}\{1F466}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_GIRL'=> "\{1F468}\{200D}\{1F467}", 'CHARACTER_FAMILY_MAN_GIRL_BOY'=> "\{1F468}\{200D}\{1F467}\{200D}\{1F466}", 'CHARACTER_FAMILY_MAN_GIRL_GIRL'=> "\{1F468}\{200D}\{1F467}\{200D}\{1F467}", 'CHARACTER_FAMILY_WOMAN_BOY'=> "\{1F469}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_BOY_BOY'=> "\{1F469}\{200D}\{1F466}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_GIRL'=> "\{1F469}\{200D}\{1F467}", 'CHARACTER_FAMILY_WOMAN_GIRL_BOY'=> "\{1F469}\{200D}\{1F467}\{200D}\{1F466}", 'CHARACTER_FAMILY_WOMAN_GIRL_GIRL'=> "\{1F469}\{200D}\{1F467}\{200D}\{1F467}", 'CHARACTER_SELFIE'=> "\{1F933}", 'CHARACTER_SELFIE_LIGHT_SKIN_TONE'=> "\{1F933}\{1F3FB}", 'CHARACTER_SELFIE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F933}\{1F3FC}", 'CHARACTER_SELFIE_MEDIUM_SKIN_TONE'=> "\{1F933}\{1F3FD}", 'CHARACTER_SELFIE_MEDIUM_DARK_SKIN_TONE'=> "\{1F933}\{1F3FE}", 'CHARACTER_SELFIE_DARK_SKIN_TONE'=> "\{1F933}\{1F3FF}", 'CHARACTER_FLEXED_BICEPS'=> "\{1F4AA}", 'CHARACTER_FLEXED_BICEPS_LIGHT_SKIN_TONE'=> "\{1F4AA}\{1F3FB}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F4AA}\{1F3FC}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_SKIN_TONE'=> "\{1F4AA}\{1F3FD}", 'CHARACTER_FLEXED_BICEPS_MEDIUM_DARK_SKIN_TONE'=> "\{1F4AA}\{1F3FE}", 'CHARACTER_FLEXED_BICEPS_DARK_SKIN_TONE'=> "\{1F4AA}\{1F3FF}", 'CHARACTER_LEG'=> "\{1F9B5}", 'CHARACTER_LEG_LIGHT_SKIN_TONE'=> "\{1F9B5}\{1F3FB}", 'CHARACTER_LEG_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B5}\{1F3FC}", 'CHARACTER_LEG_MEDIUM_SKIN_TONE'=> "\{1F9B5}\{1F3FD}", 'CHARACTER_LEG_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B5}\{1F3FE}", 'CHARACTER_LEG_DARK_SKIN_TONE'=> "\{1F9B5}\{1F3FF}", 'CHARACTER_FOOT'=> "\{1F9B6}", 'CHARACTER_FOOT_LIGHT_SKIN_TONE'=> "\{1F9B6}\{1F3FB}", 'CHARACTER_FOOT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F9B6}\{1F3FC}", 'CHARACTER_FOOT_MEDIUM_SKIN_TONE'=> "\{1F9B6}\{1F3FD}", 'CHARACTER_FOOT_MEDIUM_DARK_SKIN_TONE'=> "\{1F9B6}\{1F3FE}", 'CHARACTER_FOOT_DARK_SKIN_TONE'=> "\{1F9B6}\{1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT'=> "\{1F448}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_LIGHT_SKIN_TONE'=> "\{1F448}\{1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F448}\{1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_SKIN_TONE'=> "\{1F448}\{1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_MEDIUM_DARK_SKIN_TONE'=> "\{1F448}\{1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_LEFT_DARK_SKIN_TONE'=> "\{1F448}\{1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT'=> "\{1F449}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_LIGHT_SKIN_TONE'=> "\{1F449}\{1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F449}\{1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_SKIN_TONE'=> "\{1F449}\{1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_MEDIUM_DARK_SKIN_TONE'=> "\{1F449}\{1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_RIGHT_DARK_SKIN_TONE'=> "\{1F449}\{1F3FF}", 'CHARACTER_INDEX_POINTING_UP'=> "\{261D}\{FE0F}", 'CHARACTER_INDEX_POINTING_UP_LIGHT_SKIN_TONE'=> "\{261D}\{1F3FB}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\{261D}\{1F3FC}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_SKIN_TONE'=> "\{261D}\{1F3FD}", 'CHARACTER_INDEX_POINTING_UP_MEDIUM_DARK_SKIN_TONE'=> "\{261D}\{1F3FE}", 'CHARACTER_INDEX_POINTING_UP_DARK_SKIN_TONE'=> "\{261D}\{1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP'=> "\{1F446}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_LIGHT_SKIN_TONE'=> "\{1F446}\{1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F446}\{1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_SKIN_TONE'=> "\{1F446}\{1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_MEDIUM_DARK_SKIN_TONE'=> "\{1F446}\{1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_UP_DARK_SKIN_TONE'=> "\{1F446}\{1F3FF}", 'CHARACTER_MIDDLE_FINGER'=> "\{1F595}", 'CHARACTER_MIDDLE_FINGER_LIGHT_SKIN_TONE'=> "\{1F595}\{1F3FB}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F595}\{1F3FC}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_SKIN_TONE'=> "\{1F595}\{1F3FD}", 'CHARACTER_MIDDLE_FINGER_MEDIUM_DARK_SKIN_TONE'=> "\{1F595}\{1F3FE}", 'CHARACTER_MIDDLE_FINGER_DARK_SKIN_TONE'=> "\{1F595}\{1F3FF}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN'=> "\{1F447}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_LIGHT_SKIN_TONE'=> "\{1F447}\{1F3FB}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F447}\{1F3FC}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_SKIN_TONE'=> "\{1F447}\{1F3FD}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_MEDIUM_DARK_SKIN_TONE'=> "\{1F447}\{1F3FE}", 'CHARACTER_BACKHAND_INDEX_POINTING_DOWN_DARK_SKIN_TONE'=> "\{1F447}\{1F3FF}", 'CHARACTER_VICTORY_HAND'=> "\{270C}\{FE0F}", 'CHARACTER_VICTORY_HAND_LIGHT_SKIN_TONE'=> "\{270C}\{1F3FB}", 'CHARACTER_VICTORY_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{270C}\{1F3FC}", 'CHARACTER_VICTORY_HAND_MEDIUM_SKIN_TONE'=> "\{270C}\{1F3FD}", 'CHARACTER_VICTORY_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{270C}\{1F3FE}", 'CHARACTER_VICTORY_HAND_DARK_SKIN_TONE'=> "\{270C}\{1F3FF}", 'CHARACTER_CROSSED_FINGERS'=> "\{1F91E}", 'CHARACTER_CROSSED_FINGERS_LIGHT_SKIN_TONE'=> "\{1F91E}\{1F3FB}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F91E}\{1F3FC}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_SKIN_TONE'=> "\{1F91E}\{1F3FD}", 'CHARACTER_CROSSED_FINGERS_MEDIUM_DARK_SKIN_TONE'=> "\{1F91E}\{1F3FE}", 'CHARACTER_CROSSED_FINGERS_DARK_SKIN_TONE'=> "\{1F91E}\{1F3FF}", 'CHARACTER_VULCAN_SALUTE'=> "\{1F596}", 'CHARACTER_VULCAN_SALUTE_LIGHT_SKIN_TONE'=> "\{1F596}\{1F3FB}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F596}\{1F3FC}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_SKIN_TONE'=> "\{1F596}\{1F3FD}", 'CHARACTER_VULCAN_SALUTE_MEDIUM_DARK_SKIN_TONE'=> "\{1F596}\{1F3FE}", 'CHARACTER_VULCAN_SALUTE_DARK_SKIN_TONE'=> "\{1F596}\{1F3FF}", 'CHARACTER_SIGN_OF_THE_HORNS'=> "\{1F918}", 'CHARACTER_SIGN_OF_THE_HORNS_LIGHT_SKIN_TONE'=> "\{1F918}\{1F3FB}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F918}\{1F3FC}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_SKIN_TONE'=> "\{1F918}\{1F3FD}", 'CHARACTER_SIGN_OF_THE_HORNS_MEDIUM_DARK_SKIN_TONE'=> "\{1F918}\{1F3FE}", 'CHARACTER_SIGN_OF_THE_HORNS_DARK_SKIN_TONE'=> "\{1F918}\{1F3FF}", 'CHARACTER_CALL_ME_HAND'=> "\{1F919}", 'CHARACTER_CALL_ME_HAND_LIGHT_SKIN_TONE'=> "\{1F919}\{1F3FB}", 'CHARACTER_CALL_ME_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F919}\{1F3FC}", 'CHARACTER_CALL_ME_HAND_MEDIUM_SKIN_TONE'=> "\{1F919}\{1F3FD}", 'CHARACTER_CALL_ME_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F919}\{1F3FE}", 'CHARACTER_CALL_ME_HAND_DARK_SKIN_TONE'=> "\{1F919}\{1F3FF}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED'=> "\{1F590}\{FE0F}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_LIGHT_SKIN_TONE'=> "\{1F590}\{1F3FB}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F590}\{1F3FC}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_SKIN_TONE'=> "\{1F590}\{1F3FD}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_MEDIUM_DARK_SKIN_TONE'=> "\{1F590}\{1F3FE}", 'CHARACTER_HAND_WITH_FINGERS_SPLAYED_DARK_SKIN_TONE'=> "\{1F590}\{1F3FF}", 'CHARACTER_RAISED_HAND'=> "\{270B}", 'CHARACTER_RAISED_HAND_LIGHT_SKIN_TONE'=> "\{270B}\{1F3FB}", 'CHARACTER_RAISED_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{270B}\{1F3FC}", 'CHARACTER_RAISED_HAND_MEDIUM_SKIN_TONE'=> "\{270B}\{1F3FD}", 'CHARACTER_RAISED_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{270B}\{1F3FE}", 'CHARACTER_RAISED_HAND_DARK_SKIN_TONE'=> "\{270B}\{1F3FF}", 'CHARACTER_OK_HAND'=> "\{1F44C}", 'CHARACTER_OK_HAND_LIGHT_SKIN_TONE'=> "\{1F44C}\{1F3FB}", 'CHARACTER_OK_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44C}\{1F3FC}", 'CHARACTER_OK_HAND_MEDIUM_SKIN_TONE'=> "\{1F44C}\{1F3FD}", 'CHARACTER_OK_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F44C}\{1F3FE}", 'CHARACTER_OK_HAND_DARK_SKIN_TONE'=> "\{1F44C}\{1F3FF}", 'CHARACTER_THUMBS_UP'=> "\{1F44D}", 'CHARACTER_THUMBS_UP_LIGHT_SKIN_TONE'=> "\{1F44D}\{1F3FB}", 'CHARACTER_THUMBS_UP_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44D}\{1F3FC}", 'CHARACTER_THUMBS_UP_MEDIUM_SKIN_TONE'=> "\{1F44D}\{1F3FD}", 'CHARACTER_THUMBS_UP_MEDIUM_DARK_SKIN_TONE'=> "\{1F44D}\{1F3FE}", 'CHARACTER_THUMBS_UP_DARK_SKIN_TONE'=> "\{1F44D}\{1F3FF}", 'CHARACTER_THUMBS_DOWN'=> "\{1F44E}", 'CHARACTER_THUMBS_DOWN_LIGHT_SKIN_TONE'=> "\{1F44E}\{1F3FB}", 'CHARACTER_THUMBS_DOWN_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44E}\{1F3FC}", 'CHARACTER_THUMBS_DOWN_MEDIUM_SKIN_TONE'=> "\{1F44E}\{1F3FD}", 'CHARACTER_THUMBS_DOWN_MEDIUM_DARK_SKIN_TONE'=> "\{1F44E}\{1F3FE}", 'CHARACTER_THUMBS_DOWN_DARK_SKIN_TONE'=> "\{1F44E}\{1F3FF}", 'CHARACTER_RAISED_FIST'=> "\{270A}", 'CHARACTER_RAISED_FIST_LIGHT_SKIN_TONE'=> "\{270A}\{1F3FB}", 'CHARACTER_RAISED_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{270A}\{1F3FC}", 'CHARACTER_RAISED_FIST_MEDIUM_SKIN_TONE'=> "\{270A}\{1F3FD}", 'CHARACTER_RAISED_FIST_MEDIUM_DARK_SKIN_TONE'=> "\{270A}\{1F3FE}", 'CHARACTER_RAISED_FIST_DARK_SKIN_TONE'=> "\{270A}\{1F3FF}", 'CHARACTER_ONCOMING_FIST'=> "\{1F44A}", 'CHARACTER_ONCOMING_FIST_LIGHT_SKIN_TONE'=> "\{1F44A}\{1F3FB}", 'CHARACTER_ONCOMING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44A}\{1F3FC}", 'CHARACTER_ONCOMING_FIST_MEDIUM_SKIN_TONE'=> "\{1F44A}\{1F3FD}", 'CHARACTER_ONCOMING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F44A}\{1F3FE}", 'CHARACTER_ONCOMING_FIST_DARK_SKIN_TONE'=> "\{1F44A}\{1F3FF}", 'CHARACTER_LEFT_FACING_FIST'=> "\{1F91B}", 'CHARACTER_LEFT_FACING_FIST_LIGHT_SKIN_TONE'=> "\{1F91B}\{1F3FB}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F91B}\{1F3FC}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_SKIN_TONE'=> "\{1F91B}\{1F3FD}", 'CHARACTER_LEFT_FACING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F91B}\{1F3FE}", 'CHARACTER_LEFT_FACING_FIST_DARK_SKIN_TONE'=> "\{1F91B}\{1F3FF}", 'CHARACTER_RIGHT_FACING_FIST'=> "\{1F91C}", 'CHARACTER_RIGHT_FACING_FIST_LIGHT_SKIN_TONE'=> "\{1F91C}\{1F3FB}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F91C}\{1F3FC}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_SKIN_TONE'=> "\{1F91C}\{1F3FD}", 'CHARACTER_RIGHT_FACING_FIST_MEDIUM_DARK_SKIN_TONE'=> "\{1F91C}\{1F3FE}", 'CHARACTER_RIGHT_FACING_FIST_DARK_SKIN_TONE'=> "\{1F91C}\{1F3FF}", 'CHARACTER_RAISED_BACK_OF_HAND'=> "\{1F91A}", 'CHARACTER_RAISED_BACK_OF_HAND_LIGHT_SKIN_TONE'=> "\{1F91A}\{1F3FB}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F91A}\{1F3FC}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_SKIN_TONE'=> "\{1F91A}\{1F3FD}", 'CHARACTER_RAISED_BACK_OF_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F91A}\{1F3FE}", 'CHARACTER_RAISED_BACK_OF_HAND_DARK_SKIN_TONE'=> "\{1F91A}\{1F3FF}", 'CHARACTER_WAVING_HAND'=> "\{1F44B}", 'CHARACTER_WAVING_HAND_LIGHT_SKIN_TONE'=> "\{1F44B}\{1F3FB}", 'CHARACTER_WAVING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44B}\{1F3FC}", 'CHARACTER_WAVING_HAND_MEDIUM_SKIN_TONE'=> "\{1F44B}\{1F3FD}", 'CHARACTER_WAVING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{1F44B}\{1F3FE}", 'CHARACTER_WAVING_HAND_DARK_SKIN_TONE'=> "\{1F44B}\{1F3FF}", 'CHARACTER_LOVE_YOU_GESTURE'=> "\{1F91F}", 'CHARACTER_LOVE_YOU_GESTURE_LIGHT_SKIN_TONE'=> "\{1F91F}\{1F3FB}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F91F}\{1F3FC}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_SKIN_TONE'=> "\{1F91F}\{1F3FD}", 'CHARACTER_LOVE_YOU_GESTURE_MEDIUM_DARK_SKIN_TONE'=> "\{1F91F}\{1F3FE}", 'CHARACTER_LOVE_YOU_GESTURE_DARK_SKIN_TONE'=> "\{1F91F}\{1F3FF}", 'CHARACTER_WRITING_HAND'=> "\{270D}\{FE0F}", 'CHARACTER_WRITING_HAND_LIGHT_SKIN_TONE'=> "\{270D}\{1F3FB}", 'CHARACTER_WRITING_HAND_MEDIUM_LIGHT_SKIN_TONE'=> "\{270D}\{1F3FC}", 'CHARACTER_WRITING_HAND_MEDIUM_SKIN_TONE'=> "\{270D}\{1F3FD}", 'CHARACTER_WRITING_HAND_MEDIUM_DARK_SKIN_TONE'=> "\{270D}\{1F3FE}", 'CHARACTER_WRITING_HAND_DARK_SKIN_TONE'=> "\{270D}\{1F3FF}", 'CHARACTER_CLAPPING_HANDS'=> "\{1F44F}", 'CHARACTER_CLAPPING_HANDS_LIGHT_SKIN_TONE'=> "\{1F44F}\{1F3FB}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F44F}\{1F3FC}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_SKIN_TONE'=> "\{1F44F}\{1F3FD}", 'CHARACTER_CLAPPING_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\{1F44F}\{1F3FE}", 'CHARACTER_CLAPPING_HANDS_DARK_SKIN_TONE'=> "\{1F44F}\{1F3FF}", 'CHARACTER_OPEN_HANDS'=> "\{1F450}", 'CHARACTER_OPEN_HANDS_LIGHT_SKIN_TONE'=> "\{1F450}\{1F3FB}", 'CHARACTER_OPEN_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F450}\{1F3FC}", 'CHARACTER_OPEN_HANDS_MEDIUM_SKIN_TONE'=> "\{1F450}\{1F3FD}", 'CHARACTER_OPEN_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\{1F450}\{1F3FE}", 'CHARACTER_OPEN_HANDS_DARK_SKIN_TONE'=> "\{1F450}\{1F3FF}", 'CHARACTER_RAISING_HANDS'=> "\{1F64C}", 'CHARACTER_RAISING_HANDS_LIGHT_SKIN_TONE'=> "\{1F64C}\{1F3FB}", 'CHARACTER_RAISING_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64C}\{1F3FC}", 'CHARACTER_RAISING_HANDS_MEDIUM_SKIN_TONE'=> "\{1F64C}\{1F3FD}", 'CHARACTER_RAISING_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\{1F64C}\{1F3FE}", 'CHARACTER_RAISING_HANDS_DARK_SKIN_TONE'=> "\{1F64C}\{1F3FF}", 'CHARACTER_PALMS_UP_TOGETHER'=> "\{1F932}", 'CHARACTER_PALMS_UP_TOGETHER_LIGHT_SKIN_TONE'=> "\{1F932}\{1F3FB}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F932}\{1F3FC}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_SKIN_TONE'=> "\{1F932}\{1F3FD}", 'CHARACTER_PALMS_UP_TOGETHER_MEDIUM_DARK_SKIN_TONE'=> "\{1F932}\{1F3FE}", 'CHARACTER_PALMS_UP_TOGETHER_DARK_SKIN_TONE'=> "\{1F932}\{1F3FF}", 'CHARACTER_FOLDED_HANDS'=> "\{1F64F}", 'CHARACTER_FOLDED_HANDS_LIGHT_SKIN_TONE'=> "\{1F64F}\{1F3FB}", 'CHARACTER_FOLDED_HANDS_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F64F}\{1F3FC}", 'CHARACTER_FOLDED_HANDS_MEDIUM_SKIN_TONE'=> "\{1F64F}\{1F3FD}", 'CHARACTER_FOLDED_HANDS_MEDIUM_DARK_SKIN_TONE'=> "\{1F64F}\{1F3FE}", 'CHARACTER_FOLDED_HANDS_DARK_SKIN_TONE'=> "\{1F64F}\{1F3FF}", 'CHARACTER_HANDSHAKE'=> "\{1F91D}", 'CHARACTER_NAIL_POLISH'=> "\{1F485}", 'CHARACTER_NAIL_POLISH_LIGHT_SKIN_TONE'=> "\{1F485}\{1F3FB}", 'CHARACTER_NAIL_POLISH_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F485}\{1F3FC}", 'CHARACTER_NAIL_POLISH_MEDIUM_SKIN_TONE'=> "\{1F485}\{1F3FD}", 'CHARACTER_NAIL_POLISH_MEDIUM_DARK_SKIN_TONE'=> "\{1F485}\{1F3FE}", 'CHARACTER_NAIL_POLISH_DARK_SKIN_TONE'=> "\{1F485}\{1F3FF}", 'CHARACTER_EAR'=> "\{1F442}", 'CHARACTER_EAR_LIGHT_SKIN_TONE'=> "\{1F442}\{1F3FB}", 'CHARACTER_EAR_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F442}\{1F3FC}", 'CHARACTER_EAR_MEDIUM_SKIN_TONE'=> "\{1F442}\{1F3FD}", 'CHARACTER_EAR_MEDIUM_DARK_SKIN_TONE'=> "\{1F442}\{1F3FE}", 'CHARACTER_EAR_DARK_SKIN_TONE'=> "\{1F442}\{1F3FF}", 'CHARACTER_NOSE'=> "\{1F443}", 'CHARACTER_NOSE_LIGHT_SKIN_TONE'=> "\{1F443}\{1F3FB}", 'CHARACTER_NOSE_MEDIUM_LIGHT_SKIN_TONE'=> "\{1F443}\{1F3FC}", 'CHARACTER_NOSE_MEDIUM_SKIN_TONE'=> "\{1F443}\{1F3FD}", 'CHARACTER_NOSE_MEDIUM_DARK_SKIN_TONE'=> "\{1F443}\{1F3FE}", 'CHARACTER_NOSE_DARK_SKIN_TONE'=> "\{1F443}\{1F3FF}", 'CHARACTER_RED_HAIRED'=> "\{1F9B0}", 'CHARACTER_CURLY_HAIRED'=> "\{1F9B1}", 'CHARACTER_BALD'=> "\{1F9B2}", 'CHARACTER_WHITE_HAIRED'=> "\{1F9B3}", 'CHARACTER_FOOTPRINTS'=> "\{1F463}", 'CHARACTER_EYES'=> "\{1F440}", 'CHARACTER_EYE'=> "\{1F441}\{FE0F}", 'CHARACTER_EYE_IN_SPEECH_BUBBLE'=> "\{1F441}\{FE0F}\{200D}\{1F5E8}\{FE0F}", 'CHARACTER_BRAIN'=> "\{1F9E0}", 'CHARACTER_BONE'=> "\{1F9B4}", 'CHARACTER_TOOTH'=> "\{1F9B7}", 'CHARACTER_TONGUE'=> "\{1F445}", 'CHARACTER_MOUTH'=> "\{1F444}", 'CHARACTER_KISS_MARK'=> "\{1F48B}", 'CHARACTER_HEART_WITH_ARROW'=> "\{1F498}", 'CHARACTER_RED_HEART'=> "\{2764}\{FE0F}", 'CHARACTER_BEATING_HEART'=> "\{1F493}", 'CHARACTER_BROKEN_HEART'=> "\{1F494}", 'CHARACTER_TWO_HEARTS'=> "\{1F495}", 'CHARACTER_SPARKLING_HEART'=> "\{1F496}", 'CHARACTER_GROWING_HEART'=> "\{1F497}", 'CHARACTER_BLUE_HEART'=> "\{1F499}", 'CHARACTER_GREEN_HEART'=> "\{1F49A}", 'CHARACTER_YELLOW_HEART'=> "\{1F49B}", 'CHARACTER_ORANGE_HEART'=> "\{1F9E1}", 'CHARACTER_PURPLE_HEART'=> "\{1F49C}", 'CHARACTER_BLACK_HEART'=> "\{1F5A4}", 'CHARACTER_HEART_WITH_RIBBON'=> "\{1F49D}", 'CHARACTER_REVOLVING_HEARTS'=> "\{1F49E}", 'CHARACTER_HEART_DECORATION'=> "\{1F49F}", 'CHARACTER_HEAVY_HEART_EXCLAMATION'=> "\{2763}\{FE0F}", 'CHARACTER_LOVE_LETTER'=> "\{1F48C}", 'CHARACTER_ZZZ'=> "\{1F4A4}", 'CHARACTER_ANGER_SYMBOL'=> "\{1F4A2}", 'CHARACTER_BOMB'=> "\{1F4A3}", 'CHARACTER_COLLISION'=> "\{1F4A5}", 'CHARACTER_SWEAT_DROPLETS'=> "\{1F4A6}", 'CHARACTER_DASHING_AWAY'=> "\{1F4A8}", 'CHARACTER_DIZZY'=> "\{1F4AB}", 'CHARACTER_SPEECH_BALLOON'=> "\{1F4AC}", 'CHARACTER_LEFT_SPEECH_BUBBLE'=> "\{1F5E8}\{FE0F}", 'CHARACTER_RIGHT_ANGER_BUBBLE'=> "\{1F5EF}\{FE0F}", 'CHARACTER_THOUGHT_BALLOON'=> "\{1F4AD}", 'CHARACTER_HOLE'=> "\{1F573}\{FE0F}", 'CHARACTER_GLASSES'=> "\{1F453}", 'CHARACTER_SUNGLASSES'=> "\{1F576}\{FE0F}", 'CHARACTER_GOGGLES'=> "\{1F97D}", 'CHARACTER_LAB_COAT'=> "\{1F97C}", 'CHARACTER_NECKTIE'=> "\{1F454}", 'CHARACTER_T_SHIRT'=> "\{1F455}", 'CHARACTER_JEANS'=> "\{1F456}", 'CHARACTER_SCARF'=> "\{1F9E3}", 'CHARACTER_GLOVES'=> "\{1F9E4}", 'CHARACTER_COAT'=> "\{1F9E5}", 'CHARACTER_SOCKS'=> "\{1F9E6}", 'CHARACTER_DRESS'=> "\{1F457}", 'CHARACTER_KIMONO'=> "\{1F458}", 'CHARACTER_BIKINI'=> "\{1F459}", 'CHARACTER_WOMAN_S_CLOTHES'=> "\{1F45A}", 'CHARACTER_PURSE'=> "\{1F45B}", 'CHARACTER_HANDBAG'=> "\{1F45C}", 'CHARACTER_CLUTCH_BAG'=> "\{1F45D}", 'CHARACTER_SHOPPING_BAGS'=> "\{1F6CD}\{FE0F}", 'CHARACTER_SCHOOL_BACKPACK'=> "\{1F392}", 'CHARACTER_MAN_S_SHOE'=> "\{1F45E}", 'CHARACTER_RUNNING_SHOE'=> "\{1F45F}", 'CHARACTER_HIKING_BOOT'=> "\{1F97E}", 'CHARACTER_WOMAN_S_FLAT_SHOE'=> "\{1F97F}", 'CHARACTER_HIGH_HEELED_SHOE'=> "\{1F460}", 'CHARACTER_WOMAN_S_SANDAL'=> "\{1F461}", 'CHARACTER_WOMAN_S_BOOT'=> "\{1F462}", 'CHARACTER_CROWN'=> "\{1F451}", 'CHARACTER_WOMAN_S_HAT'=> "\{1F452}", 'CHARACTER_TOP_HAT'=> "\{1F3A9}", 'CHARACTER_GRADUATION_CAP'=> "\{1F393}", 'CHARACTER_BILLED_CAP'=> "\{1F9E2}", 'CHARACTER_RESCUE_WORKER_S_HELMET'=> "\{26D1}\{FE0F}", 'CHARACTER_PRAYER_BEADS'=> "\{1F4FF}", 'CHARACTER_LIPSTICK'=> "\{1F484}", 'CHARACTER_RING'=> "\{1F48D}", 'CHARACTER_GEM_STONE'=> "\{1F48E}", 'CHARACTER_MONKEY_FACE'=> "\{1F435}", 'CHARACTER_MONKEY'=> "\{1F412}", 'CHARACTER_GORILLA'=> "\{1F98D}", 'CHARACTER_DOG_FACE'=> "\{1F436}", 'CHARACTER_DOG'=> "\{1F415}", 'CHARACTER_POODLE'=> "\{1F429}", 'CHARACTER_WOLF_FACE'=> "\{1F43A}", 'CHARACTER_FOX_FACE'=> "\{1F98A}", 'CHARACTER_RACCOON'=> "\{1F99D}", 'CHARACTER_CAT_FACE'=> "\{1F431}", 'CHARACTER_CAT'=> "\{1F408}", 'CHARACTER_LION_FACE'=> "\{1F981}", 'CHARACTER_TIGER_FACE'=> "\{1F42F}", 'CHARACTER_TIGER'=> "\{1F405}", 'CHARACTER_LEOPARD'=> "\{1F406}", 'CHARACTER_HORSE_FACE'=> "\{1F434}", 'CHARACTER_HORSE'=> "\{1F40E}", 'CHARACTER_UNICORN_FACE'=> "\{1F984}", 'CHARACTER_ZEBRA'=> "\{1F993}", 'CHARACTER_DEER'=> "\{1F98C}", 'CHARACTER_COW_FACE'=> "\{1F42E}", 'CHARACTER_OX'=> "\{1F402}", 'CHARACTER_WATER_BUFFALO'=> "\{1F403}", 'CHARACTER_COW'=> "\{1F404}", 'CHARACTER_PIG_FACE'=> "\{1F437}", 'CHARACTER_PIG'=> "\{1F416}", 'CHARACTER_BOAR'=> "\{1F417}", 'CHARACTER_PIG_NOSE'=> "\{1F43D}", 'CHARACTER_RAM'=> "\{1F40F}", 'CHARACTER_EWE'=> "\{1F411}", 'CHARACTER_GOAT'=> "\{1F410}", 'CHARACTER_CAMEL'=> "\{1F42A}", 'CHARACTER_TWO_HUMP_CAMEL'=> "\{1F42B}", 'CHARACTER_LLAMA'=> "\{1F999}", 'CHARACTER_GIRAFFE'=> "\{1F992}", 'CHARACTER_ELEPHANT'=> "\{1F418}", 'CHARACTER_RHINOCEROS'=> "\{1F98F}", 'CHARACTER_HIPPOPOTAMUS'=> "\{1F99B}", 'CHARACTER_MOUSE_FACE'=> "\{1F42D}", 'CHARACTER_MOUSE'=> "\{1F401}", 'CHARACTER_RAT'=> "\{1F400}", 'CHARACTER_HAMSTER_FACE'=> "\{1F439}", 'CHARACTER_RABBIT_FACE'=> "\{1F430}", 'CHARACTER_RABBIT'=> "\{1F407}", 'CHARACTER_CHIPMUNK'=> "\{1F43F}\{FE0F}", 'CHARACTER_HEDGEHOG'=> "\{1F994}", 'CHARACTER_BAT'=> "\{1F987}", 'CHARACTER_BEAR_FACE'=> "\{1F43B}", 'CHARACTER_KOALA'=> "\{1F428}", 'CHARACTER_PANDA_FACE'=> "\{1F43C}", 'CHARACTER_KANGAROO'=> "\{1F998}", 'CHARACTER_BADGER'=> "\{1F9A1}", 'CHARACTER_PAW_PRINTS'=> "\{1F43E}", 'CHARACTER_TURKEY'=> "\{1F983}", 'CHARACTER_CHICKEN'=> "\{1F414}", 'CHARACTER_ROOSTER'=> "\{1F413}", 'CHARACTER_HATCHING_CHICK'=> "\{1F423}", 'CHARACTER_BABY_CHICK'=> "\{1F424}", 'CHARACTER_FRONT_FACING_BABY_CHICK'=> "\{1F425}", 'CHARACTER_BIRD'=> "\{1F426}", 'CHARACTER_PENGUIN'=> "\{1F427}", 'CHARACTER_DOVE'=> "\{1F54A}\{FE0F}", 'CHARACTER_EAGLE'=> "\{1F985}", 'CHARACTER_DUCK'=> "\{1F986}", 'CHARACTER_SWAN'=> "\{1F9A2}", 'CHARACTER_OWL'=> "\{1F989}", 'CHARACTER_PEACOCK'=> "\{1F99A}", 'CHARACTER_PARROT'=> "\{1F99C}", 'CHARACTER_FROG_FACE'=> "\{1F438}", 'CHARACTER_CROCODILE'=> "\{1F40A}", 'CHARACTER_TURTLE'=> "\{1F422}", 'CHARACTER_LIZARD'=> "\{1F98E}", 'CHARACTER_SNAKE'=> "\{1F40D}", 'CHARACTER_DRAGON_FACE'=> "\{1F432}", 'CHARACTER_DRAGON'=> "\{1F409}", 'CHARACTER_SAUROPOD'=> "\{1F995}", 'CHARACTER_T_REX'=> "\{1F996}", 'CHARACTER_SPOUTING_WHALE'=> "\{1F433}", 'CHARACTER_WHALE'=> "\{1F40B}", 'CHARACTER_DOLPHIN'=> "\{1F42C}", 'CHARACTER_FISH'=> "\{1F41F}", 'CHARACTER_TROPICAL_FISH'=> "\{1F420}", 'CHARACTER_BLOWFISH'=> "\{1F421}", 'CHARACTER_SHARK'=> "\{1F988}", 'CHARACTER_OCTOPUS'=> "\{1F419}", 'CHARACTER_SPIRAL_SHELL'=> "\{1F41A}", 'CHARACTER_CRAB'=> "\{1F980}", 'CHARACTER_LOBSTER'=> "\{1F99E}", 'CHARACTER_SHRIMP'=> "\{1F990}", 'CHARACTER_SQUID'=> "\{1F991}", 'CHARACTER_SNAIL'=> "\{1F40C}", 'CHARACTER_BUTTERFLY'=> "\{1F98B}", 'CHARACTER_BUG'=> "\{1F41B}", 'CHARACTER_ANT'=> "\{1F41C}", 'CHARACTER_HONEYBEE'=> "\{1F41D}", 'CHARACTER_LADY_BEETLE'=> "\{1F41E}", 'CHARACTER_CRICKET'=> "\{1F997}", 'CHARACTER_SPIDER'=> "\{1F577}\{FE0F}", 'CHARACTER_SPIDER_WEB'=> "\{1F578}\{FE0F}", 'CHARACTER_SCORPION'=> "\{1F982}", 'CHARACTER_MOSQUITO'=> "\{1F99F}", 'CHARACTER_MICROBE'=> "\{1F9A0}", 'CHARACTER_BOUQUET'=> "\{1F490}", 'CHARACTER_CHERRY_BLOSSOM'=> "\{1F338}", 'CHARACTER_WHITE_FLOWER'=> "\{1F4AE}", 'CHARACTER_ROSETTE'=> "\{1F3F5}\{FE0F}", 'CHARACTER_ROSE'=> "\{1F339}", 'CHARACTER_WILTED_FLOWER'=> "\{1F940}", 'CHARACTER_HIBISCUS'=> "\{1F33A}", 'CHARACTER_SUNFLOWER'=> "\{1F33B}", 'CHARACTER_BLOSSOM'=> "\{1F33C}", 'CHARACTER_TULIP'=> "\{1F337}", 'CHARACTER_SEEDLING'=> "\{1F331}", 'CHARACTER_EVERGREEN_TREE'=> "\{1F332}", 'CHARACTER_DECIDUOUS_TREE'=> "\{1F333}", 'CHARACTER_PALM_TREE'=> "\{1F334}", 'CHARACTER_CACTUS'=> "\{1F335}", 'CHARACTER_SHEAF_OF_RICE'=> "\{1F33E}", 'CHARACTER_HERB'=> "\{1F33F}", 'CHARACTER_SHAMROCK'=> "\{2618}\{FE0F}", 'CHARACTER_FOUR_LEAF_CLOVER'=> "\{1F340}", 'CHARACTER_MAPLE_LEAF'=> "\{1F341}", 'CHARACTER_FALLEN_LEAF'=> "\{1F342}", 'CHARACTER_LEAF_FLUTTERING_IN_WIND'=> "\{1F343}", 'CHARACTER_GRAPES'=> "\{1F347}", 'CHARACTER_MELON'=> "\{1F348}", 'CHARACTER_WATERMELON'=> "\{1F349}", 'CHARACTER_TANGERINE'=> "\{1F34A}", 'CHARACTER_LEMON'=> "\{1F34B}", 'CHARACTER_BANANA'=> "\{1F34C}", 'CHARACTER_PINEAPPLE'=> "\{1F34D}", 'CHARACTER_MANGO'=> "\{1F96D}", 'CHARACTER_RED_APPLE'=> "\{1F34E}", 'CHARACTER_GREEN_APPLE'=> "\{1F34F}", 'CHARACTER_PEAR'=> "\{1F350}", 'CHARACTER_PEACH'=> "\{1F351}", 'CHARACTER_CHERRIES'=> "\{1F352}", 'CHARACTER_STRAWBERRY'=> "\{1F353}", 'CHARACTER_KIWI_FRUIT'=> "\{1F95D}", 'CHARACTER_TOMATO'=> "\{1F345}", 'CHARACTER_COCONUT'=> "\{1F965}", 'CHARACTER_AVOCADO'=> "\{1F951}", 'CHARACTER_EGGPLANT'=> "\{1F346}", 'CHARACTER_POTATO'=> "\{1F954}", 'CHARACTER_CARROT'=> "\{1F955}", 'CHARACTER_EAR_OF_CORN'=> "\{1F33D}", 'CHARACTER_HOT_PEPPER'=> "\{1F336}\{FE0F}", 'CHARACTER_CUCUMBER'=> "\{1F952}", 'CHARACTER_LEAFY_GREEN'=> "\{1F96C}", 'CHARACTER_BROCCOLI'=> "\{1F966}", 'CHARACTER_MUSHROOM'=> "\{1F344}", 'CHARACTER_PEANUTS'=> "\{1F95C}", 'CHARACTER_CHESTNUT'=> "\{1F330}", 'CHARACTER_BREAD'=> "\{1F35E}", 'CHARACTER_CROISSANT'=> "\{1F950}", 'CHARACTER_BAGUETTE_BREAD'=> "\{1F956}", 'CHARACTER_PRETZEL'=> "\{1F968}", 'CHARACTER_BAGEL'=> "\{1F96F}", 'CHARACTER_PANCAKES'=> "\{1F95E}", 'CHARACTER_CHEESE_WEDGE'=> "\{1F9C0}", 'CHARACTER_MEAT_ON_BONE'=> "\{1F356}", 'CHARACTER_POULTRY_LEG'=> "\{1F357}", 'CHARACTER_CUT_OF_MEAT'=> "\{1F969}", 'CHARACTER_BACON'=> "\{1F953}", 'CHARACTER_HAMBURGER'=> "\{1F354}", 'CHARACTER_FRENCH_FRIES'=> "\{1F35F}", 'CHARACTER_PIZZA'=> "\{1F355}", 'CHARACTER_HOT_DOG'=> "\{1F32D}", 'CHARACTER_SANDWICH'=> "\{1F96A}", 'CHARACTER_TACO'=> "\{1F32E}", 'CHARACTER_BURRITO'=> "\{1F32F}", 'CHARACTER_STUFFED_FLATBREAD'=> "\{1F959}", 'CHARACTER_EGG'=> "\{1F95A}", 'CHARACTER_COOKING'=> "\{1F373}", 'CHARACTER_SHALLOW_PAN_OF_FOOD'=> "\{1F958}", 'CHARACTER_POT_OF_FOOD'=> "\{1F372}", 'CHARACTER_BOWL_WITH_SPOON'=> "\{1F963}", 'CHARACTER_GREEN_SALAD'=> "\{1F957}", 'CHARACTER_POPCORN'=> "\{1F37F}", 'CHARACTER_SALT'=> "\{1F9C2}", 'CHARACTER_CANNED_FOOD'=> "\{1F96B}", 'CHARACTER_BENTO_BOX'=> "\{1F371}", 'CHARACTER_RICE_CRACKER'=> "\{1F358}", 'CHARACTER_RICE_BALL'=> "\{1F359}", 'CHARACTER_COOKED_RICE'=> "\{1F35A}", 'CHARACTER_CURRY_RICE'=> "\{1F35B}", 'CHARACTER_STEAMING_BOWL'=> "\{1F35C}", 'CHARACTER_SPAGHETTI'=> "\{1F35D}", 'CHARACTER_ROASTED_SWEET_POTATO'=> "\{1F360}", 'CHARACTER_ODEN'=> "\{1F362}", 'CHARACTER_SUSHI'=> "\{1F363}", 'CHARACTER_FRIED_SHRIMP'=> "\{1F364}", 'CHARACTER_FISH_CAKE_WITH_SWIRL'=> "\{1F365}", 'CHARACTER_MOON_CAKE'=> "\{1F96E}", 'CHARACTER_DANGO'=> "\{1F361}", 'CHARACTER_DUMPLING'=> "\{1F95F}", 'CHARACTER_FORTUNE_COOKIE'=> "\{1F960}", 'CHARACTER_TAKEOUT_BOX'=> "\{1F961}", 'CHARACTER_SOFT_ICE_CREAM'=> "\{1F366}", 'CHARACTER_SHAVED_ICE'=> "\{1F367}", 'CHARACTER_ICE_CREAM'=> "\{1F368}", 'CHARACTER_DOUGHNUT'=> "\{1F369}", 'CHARACTER_COOKIE'=> "\{1F36A}", 'CHARACTER_BIRTHDAY_CAKE'=> "\{1F382}", 'CHARACTER_SHORTCAKE'=> "\{1F370}", 'CHARACTER_CUPCAKE'=> "\{1F9C1}", 'CHARACTER_PIE'=> "\{1F967}", 'CHARACTER_CHOCOLATE_BAR'=> "\{1F36B}", 'CHARACTER_CANDY'=> "\{1F36C}", 'CHARACTER_LOLLIPOP'=> "\{1F36D}", 'CHARACTER_CUSTARD'=> "\{1F36E}", 'CHARACTER_HONEY_POT'=> "\{1F36F}", 'CHARACTER_BABY_BOTTLE'=> "\{1F37C}", 'CHARACTER_GLASS_OF_MILK'=> "\{1F95B}", 'CHARACTER_HOT_BEVERAGE'=> "\{2615}", 'CHARACTER_TEACUP_WITHOUT_HANDLE'=> "\{1F375}", 'CHARACTER_SAKE'=> "\{1F376}", 'CHARACTER_BOTTLE_WITH_POPPING_CORK'=> "\{1F37E}", 'CHARACTER_WINE_GLASS'=> "\{1F377}", 'CHARACTER_COCKTAIL_GLASS'=> "\{1F378}", 'CHARACTER_TROPICAL_DRINK'=> "\{1F379}", 'CHARACTER_BEER_MUG'=> "\{1F37A}", 'CHARACTER_CLINKING_BEER_MUGS'=> "\{1F37B}", 'CHARACTER_CLINKING_GLASSES'=> "\{1F942}", 'CHARACTER_TUMBLER_GLASS'=> "\{1F943}", 'CHARACTER_CUP_WITH_STRAW'=> "\{1F964}", 'CHARACTER_CHOPSTICKS'=> "\{1F962}", 'CHARACTER_FORK_AND_KNIFE_WITH_PLATE'=> "\{1F37D}\{FE0F}", 'CHARACTER_FORK_AND_KNIFE'=> "\{1F374}", 'CHARACTER_SPOON'=> "\{1F944}", 'CHARACTER_KITCHEN_KNIFE'=> "\{1F52A}", 'CHARACTER_AMPHORA'=> "\{1F3FA}", 'CHARACTER_GLOBE_SHOWING_EUROPE_AFRICA'=> "\{1F30D}", 'CHARACTER_GLOBE_SHOWING_AMERICAS'=> "\{1F30E}", 'CHARACTER_GLOBE_SHOWING_ASIA_AUSTRALIA'=> "\{1F30F}", 'CHARACTER_GLOBE_WITH_MERIDIANS'=> "\{1F310}", 'CHARACTER_WORLD_MAP'=> "\{1F5FA}\{FE0F}", 'CHARACTER_MAP_OF_JAPAN'=> "\{1F5FE}", 'CHARACTER_COMPASS'=> "\{1F9ED}", 'CHARACTER_SNOW_CAPPED_MOUNTAIN'=> "\{1F3D4}\{FE0F}", 'CHARACTER_MOUNTAIN'=> "\{26F0}\{FE0F}", 'CHARACTER_VOLCANO'=> "\{1F30B}", 'CHARACTER_MOUNT_FUJI'=> "\{1F5FB}", 'CHARACTER_CAMPING'=> "\{1F3D5}\{FE0F}", 'CHARACTER_BEACH_WITH_UMBRELLA'=> "\{1F3D6}\{FE0F}", 'CHARACTER_DESERT'=> "\{1F3DC}\{FE0F}", 'CHARACTER_DESERT_ISLAND'=> "\{1F3DD}\{FE0F}", 'CHARACTER_NATIONAL_PARK'=> "\{1F3DE}\{FE0F}", 'CHARACTER_STADIUM'=> "\{1F3DF}\{FE0F}", 'CHARACTER_CLASSICAL_BUILDING'=> "\{1F3DB}\{FE0F}", 'CHARACTER_BUILDING_CONSTRUCTION'=> "\{1F3D7}\{FE0F}", 'CHARACTER_BRICKS'=> "\{1F9F1}", 'CHARACTER_HOUSES'=> "\{1F3D8}\{FE0F}", 'CHARACTER_DERELICT_HOUSE'=> "\{1F3DA}\{FE0F}", 'CHARACTER_HOUSE'=> "\{1F3E0}", 'CHARACTER_HOUSE_WITH_GARDEN'=> "\{1F3E1}", 'CHARACTER_OFFICE_BUILDING'=> "\{1F3E2}", 'CHARACTER_JAPANESE_POST_OFFICE'=> "\{1F3E3}", 'CHARACTER_POST_OFFICE'=> "\{1F3E4}", 'CHARACTER_HOSPITAL'=> "\{1F3E5}", 'CHARACTER_BANK'=> "\{1F3E6}", 'CHARACTER_HOTEL'=> "\{1F3E8}", 'CHARACTER_LOVE_HOTEL'=> "\{1F3E9}", 'CHARACTER_CONVENIENCE_STORE'=> "\{1F3EA}", 'CHARACTER_SCHOOL'=> "\{1F3EB}", 'CHARACTER_DEPARTMENT_STORE'=> "\{1F3EC}", 'CHARACTER_FACTORY'=> "\{1F3ED}", 'CHARACTER_JAPANESE_CASTLE'=> "\{1F3EF}", 'CHARACTER_CASTLE'=> "\{1F3F0}", 'CHARACTER_WEDDING'=> "\{1F492}", 'CHARACTER_TOKYO_TOWER'=> "\{1F5FC}", 'CHARACTER_STATUE_OF_LIBERTY'=> "\{1F5FD}", 'CHARACTER_CHURCH'=> "\{26EA}", 'CHARACTER_MOSQUE'=> "\{1F54C}", 'CHARACTER_SYNAGOGUE'=> "\{1F54D}", 'CHARACTER_SHINTO_SHRINE'=> "\{26E9}\{FE0F}", 'CHARACTER_KAABA'=> "\{1F54B}", 'CHARACTER_FOUNTAIN'=> "\{26F2}", 'CHARACTER_TENT'=> "\{26FA}", 'CHARACTER_FOGGY'=> "\{1F301}", 'CHARACTER_NIGHT_WITH_STARS'=> "\{1F303}", 'CHARACTER_CITYSCAPE'=> "\{1F3D9}\{FE0F}", 'CHARACTER_SUNRISE_OVER_MOUNTAINS'=> "\{1F304}", 'CHARACTER_SUNRISE'=> "\{1F305}", 'CHARACTER_CITYSCAPE_AT_DUSK'=> "\{1F306}", 'CHARACTER_SUNSET'=> "\{1F307}", 'CHARACTER_BRIDGE_AT_NIGHT'=> "\{1F309}", 'CHARACTER_HOT_SPRINGS'=> "\{2668}\{FE0F}", 'CHARACTER_MILKY_WAY'=> "\{1F30C}", 'CHARACTER_CAROUSEL_HORSE'=> "\{1F3A0}", 'CHARACTER_FERRIS_WHEEL'=> "\{1F3A1}", 'CHARACTER_ROLLER_COASTER'=> "\{1F3A2}", 'CHARACTER_BARBER_POLE'=> "\{1F488}", 'CHARACTER_CIRCUS_TENT'=> "\{1F3AA}", 'CHARACTER_LOCOMOTIVE'=> "\{1F682}", 'CHARACTER_RAILWAY_CAR'=> "\{1F683}", 'CHARACTER_HIGH_SPEED_TRAIN'=> "\{1F684}", 'CHARACTER_BULLET_TRAIN'=> "\{1F685}", 'CHARACTER_TRAIN'=> "\{1F686}", 'CHARACTER_METRO'=> "\{1F687}", 'CHARACTER_LIGHT_RAIL'=> "\{1F688}", 'CHARACTER_STATION'=> "\{1F689}", 'CHARACTER_TRAM'=> "\{1F68A}", 'CHARACTER_MONORAIL'=> "\{1F69D}", 'CHARACTER_MOUNTAIN_RAILWAY'=> "\{1F69E}", 'CHARACTER_TRAM_CAR'=> "\{1F68B}", 'CHARACTER_BUS'=> "\{1F68C}", 'CHARACTER_ONCOMING_BUS'=> "\{1F68D}", 'CHARACTER_TROLLEYBUS'=> "\{1F68E}", 'CHARACTER_MINIBUS'=> "\{1F690}", 'CHARACTER_AMBULANCE'=> "\{1F691}", 'CHARACTER_FIRE_ENGINE'=> "\{1F692}", 'CHARACTER_POLICE_CAR'=> "\{1F693}", 'CHARACTER_ONCOMING_POLICE_CAR'=> "\{1F694}", 'CHARACTER_TAXI'=> "\{1F695}", 'CHARACTER_ONCOMING_TAXI'=> "\{1F696}", 'CHARACTER_AUTOMOBILE'=> "\{1F697}", 'CHARACTER_ONCOMING_AUTOMOBILE'=> "\{1F698}", 'CHARACTER_SPORT_UTILITY_VEHICLE'=> "\{1F699}", 'CHARACTER_DELIVERY_TRUCK'=> "\{1F69A}", 'CHARACTER_ARTICULATED_LORRY'=> "\{1F69B}", 'CHARACTER_TRACTOR'=> "\{1F69C}", 'CHARACTER_BICYCLE'=> "\{1F6B2}", 'CHARACTER_KICK_SCOOTER'=> "\{1F6F4}", 'CHARACTER_SKATEBOARD'=> "\{1F6F9}", 'CHARACTER_MOTOR_SCOOTER'=> "\{1F6F5}", 'CHARACTER_BUS_STOP'=> "\{1F68F}", 'CHARACTER_MOTORWAY'=> "\{1F6E3}\{FE0F}", 'CHARACTER_RAILWAY_TRACK'=> "\{1F6E4}\{FE0F}", 'CHARACTER_OIL_DRUM'=> "\{1F6E2}\{FE0F}", 'CHARACTER_FUEL_PUMP'=> "\{26FD}", 'CHARACTER_POLICE_CAR_LIGHT'=> "\{1F6A8}", 'CHARACTER_HORIZONTAL_TRAFFIC_LIGHT'=> "\{1F6A5}", 'CHARACTER_VERTICAL_TRAFFIC_LIGHT'=> "\{1F6A6}", 'CHARACTER_STOP_SIGN'=> "\{1F6D1}", 'CHARACTER_CONSTRUCTION'=> "\{1F6A7}", 'CHARACTER_ANCHOR'=> "\{2693}", 'CHARACTER_SAILBOAT'=> "\{26F5}", 'CHARACTER_CANOE'=> "\{1F6F6}", 'CHARACTER_SPEEDBOAT'=> "\{1F6A4}", 'CHARACTER_PASSENGER_SHIP'=> "\{1F6F3}\{FE0F}", 'CHARACTER_FERRY'=> "\{26F4}\{FE0F}", 'CHARACTER_MOTOR_BOAT'=> "\{1F6E5}\{FE0F}", 'CHARACTER_SHIP'=> "\{1F6A2}", 'CHARACTER_AIRPLANE'=> "\{2708}\{FE0F}", 'CHARACTER_SMALL_AIRPLANE'=> "\{1F6E9}\{FE0F}", 'CHARACTER_AIRPLANE_DEPARTURE'=> "\{1F6EB}", 'CHARACTER_AIRPLANE_ARRIVAL'=> "\{1F6EC}", 'CHARACTER_SEAT'=> "\{1F4BA}", 'CHARACTER_HELICOPTER'=> "\{1F681}", 'CHARACTER_SUSPENSION_RAILWAY'=> "\{1F69F}", 'CHARACTER_MOUNTAIN_CABLEWAY'=> "\{1F6A0}", 'CHARACTER_AERIAL_TRAMWAY'=> "\{1F6A1}", 'CHARACTER_SATELLITE'=> "\{1F6F0}\{FE0F}", 'CHARACTER_ROCKET'=> "\{1F680}", 'CHARACTER_FLYING_SAUCER'=> "\{1F6F8}", 'CHARACTER_BELLHOP_BELL'=> "\{1F6CE}\{FE0F}", 'CHARACTER_LUGGAGE'=> "\{1F9F3}", 'CHARACTER_HOURGLASS_DONE'=> "\{231B}", 'CHARACTER_HOURGLASS_NOT_DONE'=> "\{23F3}", 'CHARACTER_WATCH'=> "\{231A}", 'CHARACTER_ALARM_CLOCK'=> "\{23F0}", 'CHARACTER_STOPWATCH'=> "\{23F1}\{FE0F}", 'CHARACTER_TIMER_CLOCK'=> "\{23F2}\{FE0F}", 'CHARACTER_MANTELPIECE_CLOCK'=> "\{1F570}\{FE0F}", 'CHARACTER_TWELVE_O_CLOCK'=> "\{1F55B}", 'CHARACTER_TWELVE_THIRTY'=> "\{1F567}", 'CHARACTER_ONE_O_CLOCK'=> "\{1F550}", 'CHARACTER_ONE_THIRTY'=> "\{1F55C}", 'CHARACTER_TWO_O_CLOCK'=> "\{1F551}", 'CHARACTER_TWO_THIRTY'=> "\{1F55D}", 'CHARACTER_THREE_O_CLOCK'=> "\{1F552}", 'CHARACTER_THREE_THIRTY'=> "\{1F55E}", 'CHARACTER_FOUR_O_CLOCK'=> "\{1F553}", 'CHARACTER_FOUR_THIRTY'=> "\{1F55F}", 'CHARACTER_FIVE_O_CLOCK'=> "\{1F554}", 'CHARACTER_FIVE_THIRTY'=> "\{1F560}", 'CHARACTER_SIX_O_CLOCK'=> "\{1F555}", 'CHARACTER_SIX_THIRTY'=> "\{1F561}", 'CHARACTER_SEVEN_O_CLOCK'=> "\{1F556}", 'CHARACTER_SEVEN_THIRTY'=> "\{1F562}", 'CHARACTER_EIGHT_O_CLOCK'=> "\{1F557}", 'CHARACTER_EIGHT_THIRTY'=> "\{1F563}", 'CHARACTER_NINE_O_CLOCK'=> "\{1F558}", 'CHARACTER_NINE_THIRTY'=> "\{1F564}", 'CHARACTER_TEN_O_CLOCK'=> "\{1F559}", 'CHARACTER_TEN_THIRTY'=> "\{1F565}", 'CHARACTER_ELEVEN_O_CLOCK'=> "\{1F55A}", 'CHARACTER_ELEVEN_THIRTY'=> "\{1F566}", 'CHARACTER_NEW_MOON'=> "\{1F311}", 'CHARACTER_WAXING_CRESCENT_MOON'=> "\{1F312}", 'CHARACTER_FIRST_QUARTER_MOON'=> "\{1F313}", 'CHARACTER_WAXING_GIBBOUS_MOON'=> "\{1F314}", 'CHARACTER_FULL_MOON'=> "\{1F315}", 'CHARACTER_WANING_GIBBOUS_MOON'=> "\{1F316}", 'CHARACTER_LAST_QUARTER_MOON'=> "\{1F317}", 'CHARACTER_WANING_CRESCENT_MOON'=> "\{1F318}", 'CHARACTER_CRESCENT_MOON'=> "\{1F319}", 'CHARACTER_NEW_MOON_FACE'=> "\{1F31A}", 'CHARACTER_FIRST_QUARTER_MOON_FACE'=> "\{1F31B}", 'CHARACTER_LAST_QUARTER_MOON_FACE'=> "\{1F31C}", 'CHARACTER_THERMOMETER'=> "\{1F321}\{FE0F}", 'CHARACTER_SUN'=> "\{2600}\{FE0F}", 'CHARACTER_FULL_MOON_FACE'=> "\{1F31D}", 'CHARACTER_SUN_WITH_FACE'=> "\{1F31E}", 'CHARACTER_STAR'=> "\{2B50}", 'CHARACTER_GLOWING_STAR'=> "\{1F31F}", 'CHARACTER_SHOOTING_STAR'=> "\{1F320}", 'CHARACTER_CLOUD'=> "\{2601}\{FE0F}", 'CHARACTER_SUN_BEHIND_CLOUD'=> "\{26C5}", 'CHARACTER_CLOUD_WITH_LIGHTNING_AND_RAIN'=> "\{26C8}\{FE0F}", 'CHARACTER_SUN_BEHIND_SMALL_CLOUD'=> "\{1F324}\{FE0F}", 'CHARACTER_SUN_BEHIND_LARGE_CLOUD'=> "\{1F325}\{FE0F}", 'CHARACTER_SUN_BEHIND_RAIN_CLOUD'=> "\{1F326}\{FE0F}", 'CHARACTER_CLOUD_WITH_RAIN'=> "\{1F327}\{FE0F}", 'CHARACTER_CLOUD_WITH_SNOW'=> "\{1F328}\{FE0F}", 'CHARACTER_CLOUD_WITH_LIGHTNING'=> "\{1F329}\{FE0F}", 'CHARACTER_TORNADO'=> "\{1F32A}\{FE0F}", 'CHARACTER_FOG'=> "\{1F32B}\{FE0F}", 'CHARACTER_WIND_FACE'=> "\{1F32C}\{FE0F}", 'CHARACTER_CYCLONE'=> "\{1F300}", 'CHARACTER_RAINBOW'=> "\{1F308}", 'CHARACTER_CLOSED_UMBRELLA'=> "\{1F302}", 'CHARACTER_UMBRELLA'=> "\{2602}\{FE0F}", 'CHARACTER_UMBRELLA_WITH_RAIN_DROPS'=> "\{2614}", 'CHARACTER_UMBRELLA_ON_GROUND'=> "\{26F1}\{FE0F}", 'CHARACTER_HIGH_VOLTAGE'=> "\{26A1}", 'CHARACTER_SNOWFLAKE'=> "\{2744}\{FE0F}", 'CHARACTER_SNOWMAN'=> "\{2603}\{FE0F}", 'CHARACTER_SNOWMAN_WITHOUT_SNOW'=> "\{26C4}", 'CHARACTER_COMET'=> "\{2604}\{FE0F}", 'CHARACTER_FIRE'=> "\{1F525}", 'CHARACTER_DROPLET'=> "\{1F4A7}", 'CHARACTER_WATER_WAVE'=> "\{1F30A}", 'CHARACTER_JACK_O_LANTERN'=> "\{1F383}", 'CHARACTER_CHRISTMAS_TREE'=> "\{1F384}", 'CHARACTER_FIREWORKS'=> "\{1F386}", 'CHARACTER_SPARKLER'=> "\{1F387}", 'CHARACTER_FIRECRACKER'=> "\{1F9E8}", 'CHARACTER_SPARKLES'=> "\{2728}", 'CHARACTER_BALLOON'=> "\{1F388}", 'CHARACTER_PARTY_POPPER'=> "\{1F389}", 'CHARACTER_CONFETTI_BALL'=> "\{1F38A}", 'CHARACTER_TANABATA_TREE'=> "\{1F38B}", 'CHARACTER_PINE_DECORATION'=> "\{1F38D}", 'CHARACTER_JAPANESE_DOLLS'=> "\{1F38E}", 'CHARACTER_CARP_STREAMER'=> "\{1F38F}", 'CHARACTER_WIND_CHIME'=> "\{1F390}", 'CHARACTER_MOON_VIEWING_CEREMONY'=> "\{1F391}", 'CHARACTER_RED_ENVELOPE'=> "\{1F9E7}", 'CHARACTER_RIBBON'=> "\{1F380}", 'CHARACTER_WRAPPED_GIFT'=> "\{1F381}", 'CHARACTER_REMINDER_RIBBON'=> "\{1F397}\{FE0F}", 'CHARACTER_ADMISSION_TICKETS'=> "\{1F39F}\{FE0F}", 'CHARACTER_TICKET'=> "\{1F3AB}", 'CHARACTER_MILITARY_MEDAL'=> "\{1F396}\{FE0F}", 'CHARACTER_TROPHY'=> "\{1F3C6}", 'CHARACTER_SPORTS_MEDAL'=> "\{1F3C5}", 'CHARACTER_1ST_PLACE_MEDAL'=> "\{1F947}", 'CHARACTER_2ND_PLACE_MEDAL'=> "\{1F948}", 'CHARACTER_3RD_PLACE_MEDAL'=> "\{1F949}", 'CHARACTER_SOCCER_BALL'=> "\{26BD}", 'CHARACTER_BASEBALL'=> "\{26BE}", 'CHARACTER_SOFTBALL'=> "\{1F94E}", 'CHARACTER_BASKETBALL'=> "\{1F3C0}", 'CHARACTER_VOLLEYBALL'=> "\{1F3D0}", 'CHARACTER_AMERICAN_FOOTBALL'=> "\{1F3C8}", 'CHARACTER_RUGBY_FOOTBALL'=> "\{1F3C9}", 'CHARACTER_TENNIS'=> "\{1F3BE}", 'CHARACTER_FLYING_DISC'=> "\{1F94F}", 'CHARACTER_BOWLING'=> "\{1F3B3}", 'CHARACTER_CRICKET_GAME'=> "\{1F3CF}", 'CHARACTER_FIELD_HOCKEY'=> "\{1F3D1}", 'CHARACTER_ICE_HOCKEY'=> "\{1F3D2}", 'CHARACTER_LACROSSE'=> "\{1F94D}", 'CHARACTER_PING_PONG'=> "\{1F3D3}", 'CHARACTER_BADMINTON'=> "\{1F3F8}", 'CHARACTER_BOXING_GLOVE'=> "\{1F94A}", 'CHARACTER_MARTIAL_ARTS_UNIFORM'=> "\{1F94B}", 'CHARACTER_GOAL_NET'=> "\{1F945}", 'CHARACTER_FLAG_IN_HOLE'=> "\{26F3}", 'CHARACTER_ICE_SKATE'=> "\{26F8}\{FE0F}", 'CHARACTER_FISHING_POLE'=> "\{1F3A3}", 'CHARACTER_RUNNING_SHIRT'=> "\{1F3BD}", 'CHARACTER_SKIS'=> "\{1F3BF}", 'CHARACTER_SLED'=> "\{1F6F7}", 'CHARACTER_CURLING_STONE'=> "\{1F94C}", 'CHARACTER_DIRECT_HIT'=> "\{1F3AF}", 'CHARACTER_POOL_8_BALL'=> "\{1F3B1}", 'CHARACTER_CRYSTAL_BALL'=> "\{1F52E}", 'CHARACTER_NAZAR_AMULET'=> "\{1F9FF}", 'CHARACTER_VIDEO_GAME'=> "\{1F3AE}", 'CHARACTER_JOYSTICK'=> "\{1F579}\{FE0F}", 'CHARACTER_SLOT_MACHINE'=> "\{1F3B0}", 'CHARACTER_GAME_DIE'=> "\{1F3B2}", 'CHARACTER_JIGSAW'=> "\{1F9E9}", 'CHARACTER_TEDDY_BEAR'=> "\{1F9F8}", 'CHARACTER_SPADE_SUIT'=> "\{2660}\{FE0F}", 'CHARACTER_HEART_SUIT'=> "\{2665}\{FE0F}", 'CHARACTER_DIAMOND_SUIT'=> "\{2666}\{FE0F}", 'CHARACTER_CLUB_SUIT'=> "\{2663}\{FE0F}", 'CHARACTER_CHESS_PAWN'=> "\{265F}\{FE0F}", 'CHARACTER_JOKER'=> "\{1F0CF}", 'CHARACTER_MAHJONG_RED_DRAGON'=> "\{1F004}", 'CHARACTER_FLOWER_PLAYING_CARDS'=> "\{1F3B4}", 'CHARACTER_PERFORMING_ARTS'=> "\{1F3AD}", 'CHARACTER_FRAMED_PICTURE'=> "\{1F5BC}\{FE0F}", 'CHARACTER_ARTIST_PALETTE'=> "\{1F3A8}", 'CHARACTER_THREAD'=> "\{1F9F5}", 'CHARACTER_YARN'=> "\{1F9F6}", 'CHARACTER_MUTED_SPEAKER'=> "\{1F507}", 'CHARACTER_SPEAKER_LOW_VOLUME'=> "\{1F508}", 'CHARACTER_SPEAKER_MEDIUM_VOLUME'=> "\{1F509}", 'CHARACTER_SPEAKER_HIGH_VOLUME'=> "\{1F50A}", 'CHARACTER_LOUDSPEAKER'=> "\{1F4E2}", 'CHARACTER_MEGAPHONE'=> "\{1F4E3}", 'CHARACTER_POSTAL_HORN'=> "\{1F4EF}", 'CHARACTER_BELL'=> "\{1F514}", 'CHARACTER_BELL_WITH_SLASH'=> "\{1F515}", 'CHARACTER_MUSICAL_SCORE'=> "\{1F3BC}", 'CHARACTER_MUSICAL_NOTE'=> "\{1F3B5}", 'CHARACTER_MUSICAL_NOTES'=> "\{1F3B6}", 'CHARACTER_STUDIO_MICROPHONE'=> "\{1F399}\{FE0F}", 'CHARACTER_LEVEL_SLIDER'=> "\{1F39A}\{FE0F}", 'CHARACTER_CONTROL_KNOBS'=> "\{1F39B}\{FE0F}", 'CHARACTER_MICROPHONE'=> "\{1F3A4}", 'CHARACTER_HEADPHONE'=> "\{1F3A7}", 'CHARACTER_RADIO'=> "\{1F4FB}", 'CHARACTER_SAXOPHONE'=> "\{1F3B7}", 'CHARACTER_GUITAR'=> "\{1F3B8}", 'CHARACTER_MUSICAL_KEYBOARD'=> "\{1F3B9}", 'CHARACTER_TRUMPET'=> "\{1F3BA}", 'CHARACTER_VIOLIN'=> "\{1F3BB}", 'CHARACTER_DRUM'=> "\{1F941}", 'CHARACTER_MOBILE_PHONE'=> "\{1F4F1}", 'CHARACTER_MOBILE_PHONE_WITH_ARROW'=> "\{1F4F2}", 'CHARACTER_TELEPHONE'=> "\{260E}\{FE0F}", 'CHARACTER_TELEPHONE_RECEIVER'=> "\{1F4DE}", 'CHARACTER_PAGER'=> "\{1F4DF}", 'CHARACTER_FAX_MACHINE'=> "\{1F4E0}", 'CHARACTER_BATTERY'=> "\{1F50B}", 'CHARACTER_ELECTRIC_PLUG'=> "\{1F50C}", 'CHARACTER_LAPTOP_COMPUTER'=> "\{1F4BB}", 'CHARACTER_DESKTOP_COMPUTER'=> "\{1F5A5}\{FE0F}", 'CHARACTER_PRINTER'=> "\{1F5A8}\{FE0F}", 'CHARACTER_KEYBOARD'=> "\{2328}\{FE0F}", 'CHARACTER_COMPUTER_MOUSE'=> "\{1F5B1}\{FE0F}", 'CHARACTER_TRACKBALL'=> "\{1F5B2}\{FE0F}", 'CHARACTER_COMPUTER_DISK'=> "\{1F4BD}", 'CHARACTER_FLOPPY_DISK'=> "\{1F4BE}", 'CHARACTER_OPTICAL_DISK'=> "\{1F4BF}", 'CHARACTER_DVD'=> "\{1F4C0}", 'CHARACTER_ABACUS'=> "\{1F9EE}", 'CHARACTER_MOVIE_CAMERA'=> "\{1F3A5}", 'CHARACTER_FILM_FRAMES'=> "\{1F39E}\{FE0F}", 'CHARACTER_FILM_PROJECTOR'=> "\{1F4FD}\{FE0F}", 'CHARACTER_CLAPPER_BOARD'=> "\{1F3AC}", 'CHARACTER_TELEVISION'=> "\{1F4FA}", 'CHARACTER_CAMERA'=> "\{1F4F7}", 'CHARACTER_CAMERA_WITH_FLASH'=> "\{1F4F8}", 'CHARACTER_VIDEO_CAMERA'=> "\{1F4F9}", 'CHARACTER_VIDEOCASSETTE'=> "\{1F4FC}", 'CHARACTER_MAGNIFYING_GLASS_TILTED_LEFT'=> "\{1F50D}", 'CHARACTER_MAGNIFYING_GLASS_TILTED_RIGHT'=> "\{1F50E}", 'CHARACTER_CANDLE'=> "\{1F56F}\{FE0F}", 'CHARACTER_LIGHT_BULB'=> "\{1F4A1}", 'CHARACTER_FLASHLIGHT'=> "\{1F526}", 'CHARACTER_RED_PAPER_LANTERN'=> "\{1F3EE}", 'CHARACTER_NOTEBOOK_WITH_DECORATIVE_COVER'=> "\{1F4D4}", 'CHARACTER_CLOSED_BOOK'=> "\{1F4D5}", 'CHARACTER_OPEN_BOOK'=> "\{1F4D6}", 'CHARACTER_GREEN_BOOK'=> "\{1F4D7}", 'CHARACTER_BLUE_BOOK'=> "\{1F4D8}", 'CHARACTER_ORANGE_BOOK'=> "\{1F4D9}", 'CHARACTER_BOOKS'=> "\{1F4DA}", 'CHARACTER_NOTEBOOK'=> "\{1F4D3}", 'CHARACTER_LEDGER'=> "\{1F4D2}", 'CHARACTER_PAGE_WITH_CURL'=> "\{1F4C3}", 'CHARACTER_SCROLL'=> "\{1F4DC}", 'CHARACTER_PAGE_FACING_UP'=> "\{1F4C4}", 'CHARACTER_NEWSPAPER'=> "\{1F4F0}", 'CHARACTER_ROLLED_UP_NEWSPAPER'=> "\{1F5DE}\{FE0F}", 'CHARACTER_BOOKMARK_TABS'=> "\{1F4D1}", 'CHARACTER_BOOKMARK'=> "\{1F516}", 'CHARACTER_LABEL'=> "\{1F3F7}\{FE0F}", 'CHARACTER_MONEY_BAG'=> "\{1F4B0}", 'CHARACTER_YEN_BANKNOTE'=> "\{1F4B4}", 'CHARACTER_DOLLAR_BANKNOTE'=> "\{1F4B5}", 'CHARACTER_EURO_BANKNOTE'=> "\{1F4B6}", 'CHARACTER_POUND_BANKNOTE'=> "\{1F4B7}", 'CHARACTER_MONEY_WITH_WINGS'=> "\{1F4B8}", 'CHARACTER_CREDIT_CARD'=> "\{1F4B3}", 'CHARACTER_RECEIPT'=> "\{1F9FE}", 'CHARACTER_CHART_INCREASING_WITH_YEN'=> "\{1F4B9}", 'CHARACTER_CURRENCY_EXCHANGE'=> "\{1F4B1}", 'CHARACTER_HEAVY_DOLLAR_SIGN'=> "\{1F4B2}", 'CHARACTER_ENVELOPE'=> "\{2709}\{FE0F}", 'CHARACTER_E_MAIL'=> "\{1F4E7}", 'CHARACTER_INCOMING_ENVELOPE'=> "\{1F4E8}", 'CHARACTER_ENVELOPE_WITH_ARROW'=> "\{1F4E9}", 'CHARACTER_OUTBOX_TRAY'=> "\{1F4E4}", 'CHARACTER_INBOX_TRAY'=> "\{1F4E5}", 'CHARACTER_PACKAGE'=> "\{1F4E6}", 'CHARACTER_CLOSED_MAILBOX_WITH_RAISED_FLAG'=> "\{1F4EB}", 'CHARACTER_CLOSED_MAILBOX_WITH_LOWERED_FLAG'=> "\{1F4EA}", 'CHARACTER_OPEN_MAILBOX_WITH_RAISED_FLAG'=> "\{1F4EC}", 'CHARACTER_OPEN_MAILBOX_WITH_LOWERED_FLAG'=> "\{1F4ED}", 'CHARACTER_POSTBOX'=> "\{1F4EE}", 'CHARACTER_BALLOT_BOX_WITH_BALLOT'=> "\{1F5F3}\{FE0F}", 'CHARACTER_PENCIL'=> "\{270F}\{FE0F}", 'CHARACTER_BLACK_NIB'=> "\{2712}\{FE0F}", 'CHARACTER_FOUNTAIN_PEN'=> "\{1F58B}\{FE0F}", 'CHARACTER_PEN'=> "\{1F58A}\{FE0F}", 'CHARACTER_PAINTBRUSH'=> "\{1F58C}\{FE0F}", 'CHARACTER_CRAYON'=> "\{1F58D}\{FE0F}", 'CHARACTER_MEMO'=> "\{1F4DD}", 'CHARACTER_BRIEFCASE'=> "\{1F4BC}", 'CHARACTER_FILE_FOLDER'=> "\{1F4C1}", 'CHARACTER_OPEN_FILE_FOLDER'=> "\{1F4C2}", 'CHARACTER_CARD_INDEX_DIVIDERS'=> "\{1F5C2}\{FE0F}", 'CHARACTER_CALENDAR'=> "\{1F4C5}", 'CHARACTER_TEAR_OFF_CALENDAR'=> "\{1F4C6}", 'CHARACTER_SPIRAL_NOTEPAD'=> "\{1F5D2}\{FE0F}", 'CHARACTER_SPIRAL_CALENDAR'=> "\{1F5D3}\{FE0F}", 'CHARACTER_CARD_INDEX'=> "\{1F4C7}", 'CHARACTER_CHART_INCREASING'=> "\{1F4C8}", 'CHARACTER_CHART_DECREASING'=> "\{1F4C9}", 'CHARACTER_BAR_CHART'=> "\{1F4CA}", 'CHARACTER_CLIPBOARD'=> "\{1F4CB}", 'CHARACTER_PUSHPIN'=> "\{1F4CC}", 'CHARACTER_ROUND_PUSHPIN'=> "\{1F4CD}", 'CHARACTER_PAPERCLIP'=> "\{1F4CE}", 'CHARACTER_LINKED_PAPERCLIPS'=> "\{1F587}\{FE0F}", 'CHARACTER_STRAIGHT_RULER'=> "\{1F4CF}", 'CHARACTER_TRIANGULAR_RULER'=> "\{1F4D0}", 'CHARACTER_SCISSORS'=> "\{2702}\{FE0F}", 'CHARACTER_CARD_FILE_BOX'=> "\{1F5C3}\{FE0F}", 'CHARACTER_FILE_CABINET'=> "\{1F5C4}\{FE0F}", 'CHARACTER_WASTEBASKET'=> "\{1F5D1}\{FE0F}", 'CHARACTER_LOCKED'=> "\{1F512}", 'CHARACTER_UNLOCKED'=> "\{1F513}", 'CHARACTER_LOCKED_WITH_PEN'=> "\{1F50F}", 'CHARACTER_LOCKED_WITH_KEY'=> "\{1F510}", 'CHARACTER_KEY'=> "\{1F511}", 'CHARACTER_OLD_KEY'=> "\{1F5DD}\{FE0F}", 'CHARACTER_HAMMER'=> "\{1F528}", 'CHARACTER_PICK'=> "\{26CF}\{FE0F}", 'CHARACTER_HAMMER_AND_PICK'=> "\{2692}\{FE0F}", 'CHARACTER_HAMMER_AND_WRENCH'=> "\{1F6E0}\{FE0F}", 'CHARACTER_DAGGER'=> "\{1F5E1}\{FE0F}", 'CHARACTER_CROSSED_SWORDS'=> "\{2694}\{FE0F}", 'CHARACTER_PISTOL'=> "\{1F52B}", 'CHARACTER_BOW_AND_ARROW'=> "\{1F3F9}", 'CHARACTER_SHIELD'=> "\{1F6E1}\{FE0F}", 'CHARACTER_WRENCH'=> "\{1F527}", 'CHARACTER_NUT_AND_BOLT'=> "\{1F529}", 'CHARACTER_GEAR'=> "\{2699}\{FE0F}", 'CHARACTER_CLAMP'=> "\{1F5DC}\{FE0F}", 'CHARACTER_BALANCE_SCALE'=> "\{2696}\{FE0F}", 'CHARACTER_LINK'=> "\{1F517}", 'CHARACTER_CHAINS'=> "\{26D3}\{FE0F}", 'CHARACTER_TOOLBOX'=> "\{1F9F0}", 'CHARACTER_MAGNET'=> "\{1F9F2}", 'CHARACTER_ALEMBIC'=> "\{2697}\{FE0F}", 'CHARACTER_TEST_TUBE'=> "\{1F9EA}", 'CHARACTER_PETRI_DISH'=> "\{1F9EB}", 'CHARACTER_DNA'=> "\{1F9EC}", 'CHARACTER_MICROSCOPE'=> "\{1F52C}", 'CHARACTER_TELESCOPE'=> "\{1F52D}", 'CHARACTER_SATELLITE_ANTENNA'=> "\{1F4E1}", 'CHARACTER_SYRINGE'=> "\{1F489}", 'CHARACTER_PILL'=> "\{1F48A}", 'CHARACTER_DOOR'=> "\{1F6AA}", 'CHARACTER_BED'=> "\{1F6CF}\{FE0F}", 'CHARACTER_COUCH_AND_LAMP'=> "\{1F6CB}\{FE0F}", 'CHARACTER_TOILET'=> "\{1F6BD}", 'CHARACTER_SHOWER'=> "\{1F6BF}", 'CHARACTER_BATHTUB'=> "\{1F6C1}", 'CHARACTER_LOTION_BOTTLE'=> "\{1F9F4}", 'CHARACTER_SAFETY_PIN'=> "\{1F9F7}", 'CHARACTER_BROOM'=> "\{1F9F9}", 'CHARACTER_BASKET'=> "\{1F9FA}", 'CHARACTER_ROLL_OF_PAPER'=> "\{1F9FB}", 'CHARACTER_SOAP'=> "\{1F9FC}", 'CHARACTER_SPONGE'=> "\{1F9FD}", 'CHARACTER_FIRE_EXTINGUISHER'=> "\{1F9EF}", 'CHARACTER_SHOPPING_CART'=> "\{1F6D2}", 'CHARACTER_CIGARETTE'=> "\{1F6AC}", 'CHARACTER_COFFIN'=> "\{26B0}\{FE0F}", 'CHARACTER_FUNERAL_URN'=> "\{26B1}\{FE0F}", 'CHARACTER_MOAI'=> "\{1F5FF}", 'CHARACTER_ATM_SIGN'=> "\{1F3E7}", 'CHARACTER_LITTER_IN_BIN_SIGN'=> "\{1F6AE}", 'CHARACTER_POTABLE_WATER'=> "\{1F6B0}", 'CHARACTER_WHEELCHAIR_SYMBOL'=> "\{267F}", 'CHARACTER_MEN_S_ROOM'=> "\{1F6B9}", 'CHARACTER_WOMEN_S_ROOM'=> "\{1F6BA}", 'CHARACTER_RESTROOM'=> "\{1F6BB}", 'CHARACTER_BABY_SYMBOL'=> "\{1F6BC}", 'CHARACTER_WATER_CLOSET'=> "\{1F6BE}", 'CHARACTER_PASSPORT_CONTROL'=> "\{1F6C2}", 'CHARACTER_CUSTOMS'=> "\{1F6C3}", 'CHARACTER_BAGGAGE_CLAIM'=> "\{1F6C4}", 'CHARACTER_LEFT_LUGGAGE'=> "\{1F6C5}", 'CHARACTER_WARNING'=> "\{26A0}\{FE0F}", 'CHARACTER_CHILDREN_CROSSING'=> "\{1F6B8}", 'CHARACTER_NO_ENTRY'=> "\{26D4}", 'CHARACTER_PROHIBITED'=> "\{1F6AB}", 'CHARACTER_NO_BICYCLES'=> "\{1F6B3}", 'CHARACTER_NO_SMOKING'=> "\{1F6AD}", 'CHARACTER_NO_LITTERING'=> "\{1F6AF}", 'CHARACTER_NON_POTABLE_WATER'=> "\{1F6B1}", 'CHARACTER_NO_PEDESTRIANS'=> "\{1F6B7}", 'CHARACTER_NO_MOBILE_PHONES'=> "\{1F4F5}", 'CHARACTER_NO_ONE_UNDER_EIGHTEEN'=> "\{1F51E}", 'CHARACTER_RADIOACTIVE'=> "\{2622}\{FE0F}", 'CHARACTER_BIOHAZARD'=> "\{2623}\{FE0F}", 'CHARACTER_UP_ARROW'=> "\{2B06}\{FE0F}", 'CHARACTER_UP_RIGHT_ARROW'=> "\{2197}\{FE0F}", 'CHARACTER_RIGHT_ARROW'=> "\{27A1}\{FE0F}", 'CHARACTER_DOWN_RIGHT_ARROW'=> "\{2198}\{FE0F}", 'CHARACTER_DOWN_ARROW'=> "\{2B07}\{FE0F}", 'CHARACTER_DOWN_LEFT_ARROW'=> "\{2199}\{FE0F}", 'CHARACTER_LEFT_ARROW'=> "\{2B05}\{FE0F}", 'CHARACTER_UP_LEFT_ARROW'=> "\{2196}\{FE0F}", 'CHARACTER_UP_DOWN_ARROW'=> "\{2195}\{FE0F}", 'CHARACTER_LEFT_RIGHT_ARROW'=> "\{2194}\{FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_LEFT'=> "\{21A9}\{FE0F}", 'CHARACTER_LEFT_ARROW_CURVING_RIGHT'=> "\{21AA}\{FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_UP'=> "\{2934}\{FE0F}", 'CHARACTER_RIGHT_ARROW_CURVING_DOWN'=> "\{2935}\{FE0F}", 'CHARACTER_CLOCKWISE_VERTICAL_ARROWS'=> "\{1F503}", 'CHARACTER_COUNTERCLOCKWISE_ARROWS_BUTTON'=> "\{1F504}", 'CHARACTER_BACK_ARROW'=> "\{1F519}", 'CHARACTER_END_ARROW'=> "\{1F51A}", 'CHARACTER_ON_ARROW'=> "\{1F51B}", 'CHARACTER_SOON_ARROW'=> "\{1F51C}", 'CHARACTER_TOP_ARROW'=> "\{1F51D}", 'CHARACTER_PLACE_OF_WORSHIP'=> "\{1F6D0}", 'CHARACTER_ATOM_SYMBOL'=> "\{269B}\{FE0F}", 'CHARACTER_OM'=> "\{1F549}\{FE0F}", 'CHARACTER_STAR_OF_DAVID'=> "\{2721}\{FE0F}", 'CHARACTER_WHEEL_OF_DHARMA'=> "\{2638}\{FE0F}", 'CHARACTER_YIN_YANG'=> "\{262F}\{FE0F}", 'CHARACTER_LATIN_CROSS'=> "\{271D}\{FE0F}", 'CHARACTER_ORTHODOX_CROSS'=> "\{2626}\{FE0F}", 'CHARACTER_STAR_AND_CRESCENT'=> "\{262A}\{FE0F}", 'CHARACTER_PEACE_SYMBOL'=> "\{262E}\{FE0F}", 'CHARACTER_MENORAH'=> "\{1F54E}", 'CHARACTER_DOTTED_SIX_POINTED_STAR'=> "\{1F52F}", 'CHARACTER_ARIES'=> "\{2648}", 'CHARACTER_TAURUS'=> "\{2649}", 'CHARACTER_GEMINI'=> "\{264A}", 'CHARACTER_CANCER'=> "\{264B}", 'CHARACTER_LEO'=> "\{264C}", 'CHARACTER_VIRGO'=> "\{264D}", 'CHARACTER_LIBRA'=> "\{264E}", 'CHARACTER_SCORPIO'=> "\{264F}", 'CHARACTER_SAGITTARIUS'=> "\{2650}", 'CHARACTER_CAPRICORN'=> "\{2651}", 'CHARACTER_AQUARIUS'=> "\{2652}", 'CHARACTER_PISCES'=> "\{2653}", 'CHARACTER_OPHIUCHUS'=> "\{26CE}", 'CHARACTER_SHUFFLE_TRACKS_BUTTON'=> "\{1F500}", 'CHARACTER_REPEAT_BUTTON'=> "\{1F501}", 'CHARACTER_REPEAT_SINGLE_BUTTON'=> "\{1F502}", 'CHARACTER_PLAY_BUTTON'=> "\{25B6}\{FE0F}", 'CHARACTER_FAST_FORWARD_BUTTON'=> "\{23E9}", 'CHARACTER_NEXT_TRACK_BUTTON'=> "\{23ED}\{FE0F}", 'CHARACTER_PLAY_OR_PAUSE_BUTTON'=> "\{23EF}\{FE0F}", 'CHARACTER_REVERSE_BUTTON'=> "\{25C0}\{FE0F}", 'CHARACTER_FAST_REVERSE_BUTTON'=> "\{23EA}", 'CHARACTER_LAST_TRACK_BUTTON'=> "\{23EE}\{FE0F}", 'CHARACTER_UPWARDS_BUTTON'=> "\{1F53C}", 'CHARACTER_FAST_UP_BUTTON'=> "\{23EB}", 'CHARACTER_DOWNWARDS_BUTTON'=> "\{1F53D}", 'CHARACTER_FAST_DOWN_BUTTON'=> "\{23EC}", 'CHARACTER_PAUSE_BUTTON'=> "\{23F8}\{FE0F}", 'CHARACTER_STOP_BUTTON'=> "\{23F9}\{FE0F}", 'CHARACTER_RECORD_BUTTON'=> "\{23FA}\{FE0F}", 'CHARACTER_EJECT_BUTTON'=> "\{23CF}\{FE0F}", 'CHARACTER_CINEMA'=> "\{1F3A6}", 'CHARACTER_DIM_BUTTON'=> "\{1F505}", 'CHARACTER_BRIGHT_BUTTON'=> "\{1F506}", 'CHARACTER_ANTENNA_BARS'=> "\{1F4F6}", 'CHARACTER_VIBRATION_MODE'=> "\{1F4F3}", 'CHARACTER_MOBILE_PHONE_OFF'=> "\{1F4F4}", 'CHARACTER_FEMALE_SIGN'=> "\{2640}\{FE0F}", 'CHARACTER_MALE_SIGN'=> "\{2642}\{FE0F}", 'CHARACTER_MEDICAL_SYMBOL'=> "\{2695}\{FE0F}", 'CHARACTER_INFINITY'=> "\{267E}\{FE0F}", 'CHARACTER_RECYCLING_SYMBOL'=> "\{267B}\{FE0F}", 'CHARACTER_FLEUR_DE_LIS'=> "\{269C}\{FE0F}", 'CHARACTER_TRIDENT_EMBLEM'=> "\{1F531}", 'CHARACTER_NAME_BADGE'=> "\{1F4DB}", 'CHARACTER_JAPANESE_SYMBOL_FOR_BEGINNER'=> "\{1F530}", 'CHARACTER_HEAVY_LARGE_CIRCLE'=> "\{2B55}", 'CHARACTER_WHITE_HEAVY_CHECK_MARK'=> "\{2705}", 'CHARACTER_BALLOT_BOX_WITH_CHECK'=> "\{2611}\{FE0F}", 'CHARACTER_HEAVY_CHECK_MARK'=> "\{2714}\{FE0F}", 'CHARACTER_HEAVY_MULTIPLICATION_X'=> "\{2716}\{FE0F}", 'CHARACTER_CROSS_MARK'=> "\{274C}", 'CHARACTER_CROSS_MARK_BUTTON'=> "\{274E}", 'CHARACTER_HEAVY_PLUS_SIGN'=> "\{2795}", 'CHARACTER_HEAVY_MINUS_SIGN'=> "\{2796}", 'CHARACTER_HEAVY_DIVISION_SIGN'=> "\{2797}", 'CHARACTER_CURLY_LOOP'=> "\{27B0}", 'CHARACTER_DOUBLE_CURLY_LOOP'=> "\{27BF}", 'CHARACTER_PART_ALTERNATION_MARK'=> "\{303D}\{FE0F}", 'CHARACTER_EIGHT_SPOKED_ASTERISK'=> "\{2733}\{FE0F}", 'CHARACTER_EIGHT_POINTED_STAR'=> "\{2734}\{FE0F}", 'CHARACTER_SPARKLE'=> "\{2747}\{FE0F}", 'CHARACTER_DOUBLE_EXCLAMATION_MARK'=> "\{203C}\{FE0F}", 'CHARACTER_EXCLAMATION_QUESTION_MARK'=> "\{2049}\{FE0F}", 'CHARACTER_QUESTION_MARK'=> "\{2753}", 'CHARACTER_WHITE_QUESTION_MARK'=> "\{2754}", 'CHARACTER_WHITE_EXCLAMATION_MARK'=> "\{2755}", 'CHARACTER_EXCLAMATION_MARK'=> "\{2757}", 'CHARACTER_WAVY_DASH'=> "\{3030}\{FE0F}", 'CHARACTER_COPYRIGHT'=> "\{00A9}\{FE0F}", 'CHARACTER_REGISTERED'=> "\{00AE}\{FE0F}", 'CHARACTER_TRADE_MARK'=> "\{2122}\{FE0F}", 'CHARACTER_KEYCAP_HASH'=> "\{0023}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_ASTERISK'=> "\{002A}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_0'=> "\{0030}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_1'=> "\{0031}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_2'=> "\{0032}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_3'=> "\{0033}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_4'=> "\{0034}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_5'=> "\{0035}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_6'=> "\{0036}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_7'=> "\{0037}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_8'=> "\{0038}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_9'=> "\{0039}\{FE0F}\{20E3}", 'CHARACTER_KEYCAP_10'=> "\{1F51F}", 'CHARACTER_HUNDRED_POINTS'=> "\{1F4AF}", 'CHARACTER_INPUT_LATIN_UPPERCASE'=> "\{1F520}", 'CHARACTER_INPUT_LATIN_LOWERCASE'=> "\{1F521}", 'CHARACTER_INPUT_NUMBERS'=> "\{1F522}", 'CHARACTER_INPUT_SYMBOLS'=> "\{1F523}", 'CHARACTER_INPUT_LATIN_LETTERS'=> "\{1F524}", 'CHARACTER_A_BUTTON_BLOOD_TYPE'=> "\{1F170}\{FE0F}", 'CHARACTER_AB_BUTTON_BLOOD_TYPE'=> "\{1F18E}", 'CHARACTER_B_BUTTON_BLOOD_TYPE'=> "\{1F171}\{FE0F}", 'CHARACTER_CL_BUTTON'=> "\{1F191}", 'CHARACTER_COOL_BUTTON'=> "\{1F192}", 'CHARACTER_FREE_BUTTON'=> "\{1F193}", 'CHARACTER_INFORMATION'=> "\{2139}\{FE0F}", 'CHARACTER_ID_BUTTON'=> "\{1F194}", 'CHARACTER_CIRCLED_M'=> "\{24C2}\{FE0F}", 'CHARACTER_NEW_BUTTON'=> "\{1F195}", 'CHARACTER_NG_BUTTON'=> "\{1F196}", 'CHARACTER_O_BUTTON_BLOOD_TYPE'=> "\{1F17E}\{FE0F}", 'CHARACTER_OK_BUTTON'=> "\{1F197}", 'CHARACTER_P_BUTTON'=> "\{1F17F}\{FE0F}", 'CHARACTER_SOS_BUTTON'=> "\{1F198}", 'CHARACTER_UP_BUTTON'=> "\{1F199}", 'CHARACTER_VS_BUTTON'=> "\{1F19A}", 'CHARACTER_JAPANESE_HERE_BUTTON'=> "\{1F201}", 'CHARACTER_JAPANESE_SERVICE_CHARGE_BUTTON'=> "\{1F202}\{FE0F}", 'CHARACTER_JAPANESE_MONTHLY_AMOUNT_BUTTON'=> "\{1F237}\{FE0F}", 'CHARACTER_JAPANESE_NOT_FREE_OF_CHARGE_BUTTON'=> "\{1F236}", 'CHARACTER_JAPANESE_RESERVED_BUTTON'=> "\{1F22F}", 'CHARACTER_JAPANESE_BARGAIN_BUTTON'=> "\{1F250}", 'CHARACTER_JAPANESE_DISCOUNT_BUTTON'=> "\{1F239}", 'CHARACTER_JAPANESE_FREE_OF_CHARGE_BUTTON'=> "\{1F21A}", 'CHARACTER_JAPANESE_PROHIBITED_BUTTON'=> "\{1F232}", 'CHARACTER_JAPANESE_ACCEPTABLE_BUTTON'=> "\{1F251}", 'CHARACTER_JAPANESE_APPLICATION_BUTTON'=> "\{1F238}", 'CHARACTER_JAPANESE_PASSING_GRADE_BUTTON'=> "\{1F234}", 'CHARACTER_JAPANESE_VACANCY_BUTTON'=> "\{1F233}", 'CHARACTER_JAPANESE_CONGRATULATIONS_BUTTON'=> "\{3297}\{FE0F}", 'CHARACTER_JAPANESE_SECRET_BUTTON'=> "\{3299}\{FE0F}", 'CHARACTER_JAPANESE_OPEN_FOR_BUSINESS_BUTTON'=> "\{1F23A}", 'CHARACTER_JAPANESE_NO_VACANCY_BUTTON'=> "\{1F235}", 'CHARACTER_BLACK_SMALL_SQUARE'=> "\{25AA}\{FE0F}", 'CHARACTER_WHITE_SMALL_SQUARE'=> "\{25AB}\{FE0F}", 'CHARACTER_WHITE_MEDIUM_SQUARE'=> "\{25FB}\{FE0F}", 'CHARACTER_BLACK_MEDIUM_SQUARE'=> "\{25FC}\{FE0F}", 'CHARACTER_WHITE_MEDIUM_SMALL_SQUARE'=> "\{25FD}", 'CHARACTER_BLACK_MEDIUM_SMALL_SQUARE'=> "\{25FE}", 'CHARACTER_BLACK_LARGE_SQUARE'=> "\{2B1B}", 'CHARACTER_WHITE_LARGE_SQUARE'=> "\{2B1C}", 'CHARACTER_LARGE_ORANGE_DIAMOND'=> "\{1F536}", 'CHARACTER_LARGE_BLUE_DIAMOND'=> "\{1F537}", 'CHARACTER_SMALL_ORANGE_DIAMOND'=> "\{1F538}", 'CHARACTER_SMALL_BLUE_DIAMOND'=> "\{1F539}", 'CHARACTER_RED_TRIANGLE_POINTED_UP'=> "\{1F53A}", 'CHARACTER_RED_TRIANGLE_POINTED_DOWN'=> "\{1F53B}", 'CHARACTER_DIAMOND_WITH_A_DOT'=> "\{1F4A0}", 'CHARACTER_RADIO_BUTTON'=> "\{1F518}", 'CHARACTER_BLACK_SQUARE_BUTTON'=> "\{1F532}", 'CHARACTER_WHITE_SQUARE_BUTTON'=> "\{1F533}", 'CHARACTER_WHITE_CIRCLE'=> "\{26AA}", 'CHARACTER_BLACK_CIRCLE'=> "\{26AB}", 'CHARACTER_RED_CIRCLE'=> "\{1F534}", 'CHARACTER_BLUE_CIRCLE'=> "\{1F535}", 'CHARACTER_CHEQUERED_FLAG'=> "\{1F3C1}", 'CHARACTER_TRIANGULAR_FLAG'=> "\{1F6A9}", 'CHARACTER_CROSSED_FLAGS'=> "\{1F38C}", 'CHARACTER_BLACK_FLAG'=> "\{1F3F4}", 'CHARACTER_WHITE_FLAG'=> "\{1F3F3}\{FE0F}", 'CHARACTER_RAINBOW_FLAG'=> "\{1F3F3}\{FE0F}\{200D}\{1F308}", 'CHARACTER_PIRATE_FLAG'=> "\{1F3F4}\{200D}\{2620}\{FE0F}", 'CHARACTER_FLAGS_FOR_ASCENSION_ISLAND'=> "\{1F1E6}\{1F1E8}", 'CHARACTER_FLAGS_FOR_ANDORRA'=> "\{1F1E6}\{1F1E9}", 'CHARACTER_FLAGS_FOR_UNITED_ARAB_EMIRATES'=> "\{1F1E6}\{1F1EA}", 'CHARACTER_FLAGS_FOR_AFGHANISTAN'=> "\{1F1E6}\{1F1EB}", 'CHARACTER_FLAGS_FOR_ANTIGUA_AND_BARBUDA'=> "\{1F1E6}\{1F1EC}", 'CHARACTER_FLAGS_FOR_ANGUILLA'=> "\{1F1E6}\{1F1EE}", 'CHARACTER_FLAGS_FOR_ALBANIA'=> "\{1F1E6}\{1F1F1}", 'CHARACTER_FLAGS_FOR_ARMENIA'=> "\{1F1E6}\{1F1F2}", 'CHARACTER_FLAGS_FOR_ANGOLA'=> "\{1F1E6}\{1F1F4}", 'CHARACTER_FLAGS_FOR_ANTARCTICA'=> "\{1F1E6}\{1F1F6}", 'CHARACTER_FLAGS_FOR_ARGENTINA'=> "\{1F1E6}\{1F1F7}", 'CHARACTER_FLAGS_FOR_AMERICAN_SAMOA'=> "\{1F1E6}\{1F1F8}", 'CHARACTER_FLAGS_FOR_AUSTRIA'=> "\{1F1E6}\{1F1F9}", 'CHARACTER_FLAGS_FOR_AUSTRALIA'=> "\{1F1E6}\{1F1FA}", 'CHARACTER_FLAGS_FOR_ARUBA'=> "\{1F1E6}\{1F1FC}", 'CHARACTER_FLAGS_FOR_ALAND_ISLANDS'=> "\{1F1E6}\{1F1FD}", 'CHARACTER_FLAGS_FOR_AZERBAIJAN'=> "\{1F1E6}\{1F1FF}", 'CHARACTER_FLAGS_FOR_BOSNIA_AND_HERZEGOVINA'=> "\{1F1E7}\{1F1E6}", 'CHARACTER_FLAGS_FOR_BARBADOS'=> "\{1F1E7}\{1F1E7}", 'CHARACTER_FLAGS_FOR_BANGLADESH'=> "\{1F1E7}\{1F1E9}", 'CHARACTER_FLAGS_FOR_BELGIUM'=> "\{1F1E7}\{1F1EA}", 'CHARACTER_FLAGS_FOR_BURKINA_FASO'=> "\{1F1E7}\{1F1EB}", 'CHARACTER_FLAGS_FOR_BULGARIA'=> "\{1F1E7}\{1F1EC}", 'CHARACTER_FLAGS_FOR_BAHRAIN'=> "\{1F1E7}\{1F1ED}", 'CHARACTER_FLAGS_FOR_BURUNDI'=> "\{1F1E7}\{1F1EE}", 'CHARACTER_FLAGS_FOR_BENIN'=> "\{1F1E7}\{1F1EF}", 'CHARACTER_FLAGS_FOR_ST_BARTHELEMY'=> "\{1F1E7}\{1F1F1}", 'CHARACTER_FLAGS_FOR_BERMUDA'=> "\{1F1E7}\{1F1F2}", 'CHARACTER_FLAGS_FOR_BRUNEI'=> "\{1F1E7}\{1F1F3}", 'CHARACTER_FLAGS_FOR_BOLIVIA'=> "\{1F1E7}\{1F1F4}", 'CHARACTER_FLAGS_FOR_CARIBBEAN_NETHERLANDS'=> "\{1F1E7}\{1F1F6}", 'CHARACTER_FLAGS_FOR_BRAZIL'=> "\{1F1E7}\{1F1F7}", 'CHARACTER_FLAGS_FOR_BAHAMAS'=> "\{1F1E7}\{1F1F8}", 'CHARACTER_FLAGS_FOR_BHUTAN'=> "\{1F1E7}\{1F1F9}", 'CHARACTER_FLAGS_FOR_BOUVET_ISLAND'=> "\{1F1E7}\{1F1FB}", 'CHARACTER_FLAGS_FOR_BOTSWANA'=> "\{1F1E7}\{1F1FC}", 'CHARACTER_FLAGS_FOR_BELARUS'=> "\{1F1E7}\{1F1FE}", 'CHARACTER_FLAGS_FOR_BELIZE'=> "\{1F1E7}\{1F1FF}", 'CHARACTER_FLAGS_FOR_CANADA'=> "\{1F1E8}\{1F1E6}", 'CHARACTER_FLAGS_FOR_COCOS_KEELING_ISLANDS'=> "\{1F1E8}\{1F1E8}", 'CHARACTER_FLAGS_FOR_CONGO_KINSHASA'=> "\{1F1E8}\{1F1E9}", 'CHARACTER_FLAGS_FOR_CENTRAL_AFRICAN_REPUBLIC'=> "\{1F1E8}\{1F1EB}", 'CHARACTER_FLAGS_FOR_CONGO_BRAZZAVILLE'=> "\{1F1E8}\{1F1EC}", 'CHARACTER_FLAGS_FOR_SWITZERLAND'=> "\{1F1E8}\{1F1ED}", 'CHARACTER_FLAGS_FOR_COTE_D_IVOIRE'=> "\{1F1E8}\{1F1EE}", 'CHARACTER_FLAGS_FOR_COOK_ISLANDS'=> "\{1F1E8}\{1F1F0}", 'CHARACTER_FLAGS_FOR_CHILE'=> "\{1F1E8}\{1F1F1}", 'CHARACTER_FLAGS_FOR_CAMEROON'=> "\{1F1E8}\{1F1F2}", 'CHARACTER_FLAGS_FOR_CHINA'=> "\{1F1E8}\{1F1F3}", 'CHARACTER_FLAGS_FOR_COLOMBIA'=> "\{1F1E8}\{1F1F4}", 'CHARACTER_FLAGS_FOR_CLIPPERTON_ISLAND'=> "\{1F1E8}\{1F1F5}", 'CHARACTER_FLAGS_FOR_COSTA_RICA'=> "\{1F1E8}\{1F1F7}", 'CHARACTER_FLAGS_FOR_CUBA'=> "\{1F1E8}\{1F1FA}", 'CHARACTER_FLAGS_FOR_CAPE_VERDE'=> "\{1F1E8}\{1F1FB}", 'CHARACTER_FLAGS_FOR_CURACAO'=> "\{1F1E8}\{1F1FC}", 'CHARACTER_FLAGS_FOR_CHRISTMAS_ISLAND'=> "\{1F1E8}\{1F1FD}", 'CHARACTER_FLAGS_FOR_CYPRUS'=> "\{1F1E8}\{1F1FE}", 'CHARACTER_FLAGS_FOR_CZECHIA'=> "\{1F1E8}\{1F1FF}", 'CHARACTER_FLAGS_FOR_GERMANY'=> "\{1F1E9}\{1F1EA}", 'CHARACTER_FLAGS_FOR_DIEGO_GARCIA'=> "\{1F1E9}\{1F1EC}", 'CHARACTER_FLAGS_FOR_DJIBOUTI'=> "\{1F1E9}\{1F1EF}", 'CHARACTER_FLAGS_FOR_DENMARK'=> "\{1F1E9}\{1F1F0}", 'CHARACTER_FLAGS_FOR_DOMINICA'=> "\{1F1E9}\{1F1F2}", 'CHARACTER_FLAGS_FOR_DOMINICAN_REPUBLIC'=> "\{1F1E9}\{1F1F4}", 'CHARACTER_FLAGS_FOR_ALGERIA'=> "\{1F1E9}\{1F1FF}", 'CHARACTER_FLAGS_FOR_CEUTA_AND_MELILLA'=> "\{1F1EA}\{1F1E6}", 'CHARACTER_FLAGS_FOR_ECUADOR'=> "\{1F1EA}\{1F1E8}", 'CHARACTER_FLAGS_FOR_ESTONIA'=> "\{1F1EA}\{1F1EA}", 'CHARACTER_FLAGS_FOR_EGYPT'=> "\{1F1EA}\{1F1EC}", 'CHARACTER_FLAGS_FOR_WESTERN_SAHARA'=> "\{1F1EA}\{1F1ED}", 'CHARACTER_FLAGS_FOR_ERITREA'=> "\{1F1EA}\{1F1F7}", 'CHARACTER_FLAGS_FOR_SPAIN'=> "\{1F1EA}\{1F1F8}", 'CHARACTER_FLAGS_FOR_ETHIOPIA'=> "\{1F1EA}\{1F1F9}", 'CHARACTER_FLAGS_FOR_EUROPEAN_UNION'=> "\{1F1EA}\{1F1FA}", 'CHARACTER_FLAGS_FOR_FINLAND'=> "\{1F1EB}\{1F1EE}", 'CHARACTER_FLAGS_FOR_FIJI'=> "\{1F1EB}\{1F1EF}", 'CHARACTER_FLAGS_FOR_FALKLAND_ISLANDS'=> "\{1F1EB}\{1F1F0}", 'CHARACTER_FLAGS_FOR_MICRONESIA'=> "\{1F1EB}\{1F1F2}", 'CHARACTER_FLAGS_FOR_FAROE_ISLANDS'=> "\{1F1EB}\{1F1F4}", 'CHARACTER_FLAGS_FOR_FRANCE'=> "\{1F1EB}\{1F1F7}", 'CHARACTER_FLAGS_FOR_GABON'=> "\{1F1EC}\{1F1E6}", 'CHARACTER_FLAGS_FOR_UNITED_KINGDOM'=> "\{1F1EC}\{1F1E7}", 'CHARACTER_FLAGS_FOR_GRENADA'=> "\{1F1EC}\{1F1E9}", 'CHARACTER_FLAGS_FOR_GEORGIA'=> "\{1F1EC}\{1F1EA}", 'CHARACTER_FLAGS_FOR_FRENCH_GUIANA'=> "\{1F1EC}\{1F1EB}", 'CHARACTER_FLAGS_FOR_GUERNSEY'=> "\{1F1EC}\{1F1EC}", 'CHARACTER_FLAGS_FOR_GHANA'=> "\{1F1EC}\{1F1ED}", 'CHARACTER_FLAGS_FOR_GIBRALTAR'=> "\{1F1EC}\{1F1EE}", 'CHARACTER_FLAGS_FOR_GREENLAND'=> "\{1F1EC}\{1F1F1}", 'CHARACTER_FLAGS_FOR_GAMBIA'=> "\{1F1EC}\{1F1F2}", 'CHARACTER_FLAGS_FOR_GUINEA'=> "\{1F1EC}\{1F1F3}", 'CHARACTER_FLAGS_FOR_GUADELOUPE'=> "\{1F1EC}\{1F1F5}", 'CHARACTER_FLAGS_FOR_EQUATORIAL_GUINEA'=> "\{1F1EC}\{1F1F6}", 'CHARACTER_FLAGS_FOR_GREECE'=> "\{1F1EC}\{1F1F7}", 'CHARACTER_FLAGS_FOR_SOUTH_GEORGIA_AND_SOUTH_SANDWICH_ISLANDS'=> "\{1F1EC}\{1F1F8}", 'CHARACTER_FLAGS_FOR_GUATEMALA'=> "\{1F1EC}\{1F1F9}", 'CHARACTER_FLAGS_FOR_GUAM'=> "\{1F1EC}\{1F1FA}", 'CHARACTER_FLAGS_FOR_GUINEA_BISSAU'=> "\{1F1EC}\{1F1FC}", 'CHARACTER_FLAGS_FOR_GUYANA'=> "\{1F1EC}\{1F1FE}", 'CHARACTER_FLAGS_FOR_HONG_KONG_SAR_CHINA'=> "\{1F1ED}\{1F1F0}", 'CHARACTER_FLAGS_FOR_HEARD_AND_MCDONALD_ISLANDS'=> "\{1F1ED}\{1F1F2}", 'CHARACTER_FLAGS_FOR_HONDURAS'=> "\{1F1ED}\{1F1F3}", 'CHARACTER_FLAGS_FOR_CROATIA'=> "\{1F1ED}\{1F1F7}", 'CHARACTER_FLAGS_FOR_HAITI'=> "\{1F1ED}\{1F1F9}", 'CHARACTER_FLAGS_FOR_HUNGARY'=> "\{1F1ED}\{1F1FA}", 'CHARACTER_FLAGS_FOR_CANARY_ISLANDS'=> "\{1F1EE}\{1F1E8}", 'CHARACTER_FLAGS_FOR_INDONESIA'=> "\{1F1EE}\{1F1E9}", 'CHARACTER_FLAGS_FOR_IRELAND'=> "\{1F1EE}\{1F1EA}", 'CHARACTER_FLAGS_FOR_ISRAEL'=> "\{1F1EE}\{1F1F1}", 'CHARACTER_FLAGS_FOR_ISLE_OF_MAN'=> "\{1F1EE}\{1F1F2}", 'CHARACTER_FLAGS_FOR_INDIA'=> "\{1F1EE}\{1F1F3}", 'CHARACTER_FLAGS_FOR_BRITISH_INDIAN_OCEAN_TERRITORY'=> "\{1F1EE}\{1F1F4}", 'CHARACTER_FLAGS_FOR_IRAQ'=> "\{1F1EE}\{1F1F6}", 'CHARACTER_FLAGS_FOR_IRAN'=> "\{1F1EE}\{1F1F7}", 'CHARACTER_FLAGS_FOR_ICELAND'=> "\{1F1EE}\{1F1F8}", 'CHARACTER_FLAGS_FOR_ITALY'=> "\{1F1EE}\{1F1F9}", 'CHARACTER_FLAGS_FOR_JERSEY'=> "\{1F1EF}\{1F1EA}", 'CHARACTER_FLAGS_FOR_JAMAICA'=> "\{1F1EF}\{1F1F2}", 'CHARACTER_FLAGS_FOR_JORDAN'=> "\{1F1EF}\{1F1F4}", 'CHARACTER_FLAGS_FOR_JAPAN'=> "\{1F1EF}\{1F1F5}", 'CHARACTER_FLAGS_FOR_KENYA'=> "\{1F1F0}\{1F1EA}", 'CHARACTER_FLAGS_FOR_KYRGYZSTAN'=> "\{1F1F0}\{1F1EC}", 'CHARACTER_FLAGS_FOR_CAMBODIA'=> "\{1F1F0}\{1F1ED}", 'CHARACTER_FLAGS_FOR_KIRIBATI'=> "\{1F1F0}\{1F1EE}", 'CHARACTER_FLAGS_FOR_COMOROS'=> "\{1F1F0}\{1F1F2}", 'CHARACTER_FLAGS_FOR_ST_KITTS_AND_NEVIS'=> "\{1F1F0}\{1F1F3}", 'CHARACTER_FLAGS_FOR_NORTH_KOREA'=> "\{1F1F0}\{1F1F5}", 'CHARACTER_FLAGS_FOR_SOUTH_KOREA'=> "\{1F1F0}\{1F1F7}", 'CHARACTER_FLAGS_FOR_KUWAIT'=> "\{1F1F0}\{1F1FC}", 'CHARACTER_FLAGS_FOR_CAYMAN_ISLANDS'=> "\{1F1F0}\{1F1FE}", 'CHARACTER_FLAGS_FOR_KAZAKHSTAN'=> "\{1F1F0}\{1F1FF}", 'CHARACTER_FLAGS_FOR_LAOS'=> "\{1F1F1}\{1F1E6}", 'CHARACTER_FLAGS_FOR_LEBANON'=> "\{1F1F1}\{1F1E7}", 'CHARACTER_FLAGS_FOR_ST_LUCIA'=> "\{1F1F1}\{1F1E8}", 'CHARACTER_FLAGS_FOR_LIECHTENSTEIN'=> "\{1F1F1}\{1F1EE}", 'CHARACTER_FLAGS_FOR_SRI_LANKA'=> "\{1F1F1}\{1F1F0}", 'CHARACTER_FLAGS_FOR_LIBERIA'=> "\{1F1F1}\{1F1F7}", 'CHARACTER_FLAGS_FOR_LESOTHO'=> "\{1F1F1}\{1F1F8}", 'CHARACTER_FLAGS_FOR_LITHUANIA'=> "\{1F1F1}\{1F1F9}", 'CHARACTER_FLAGS_FOR_LUXEMBOURG'=> "\{1F1F1}\{1F1FA}", 'CHARACTER_FLAGS_FOR_LATVIA'=> "\{1F1F1}\{1F1FB}", 'CHARACTER_FLAGS_FOR_LIBYA'=> "\{1F1F1}\{1F1FE}", 'CHARACTER_FLAGS_FOR_MOROCCO'=> "\{1F1F2}\{1F1E6}", 'CHARACTER_FLAGS_FOR_MONACO'=> "\{1F1F2}\{1F1E8}", 'CHARACTER_FLAGS_FOR_MOLDOVA'=> "\{1F1F2}\{1F1E9}", 'CHARACTER_FLAGS_FOR_MONTENEGRO'=> "\{1F1F2}\{1F1EA}", 'CHARACTER_FLAGS_FOR_ST_MARTIN'=> "\{1F1F2}\{1F1EB}", 'CHARACTER_FLAGS_FOR_MADAGASCAR'=> "\{1F1F2}\{1F1EC}", 'CHARACTER_FLAGS_FOR_MARSHALL_ISLANDS'=> "\{1F1F2}\{1F1ED}", 'CHARACTER_FLAGS_FOR_MACEDONIA'=> "\{1F1F2}\{1F1F0}", 'CHARACTER_FLAGS_FOR_MALI'=> "\{1F1F2}\{1F1F1}", 'CHARACTER_FLAGS_FOR_MYANMAR_BURMA'=> "\{1F1F2}\{1F1F2}", 'CHARACTER_FLAGS_FOR_MONGOLIA'=> "\{1F1F2}\{1F1F3}", 'CHARACTER_FLAGS_FOR_MACAU_SAR_CHINA'=> "\{1F1F2}\{1F1F4}", 'CHARACTER_FLAGS_FOR_NORTHERN_MARIANA_ISLANDS'=> "\{1F1F2}\{1F1F5}", 'CHARACTER_FLAGS_FOR_MARTINIQUE'=> "\{1F1F2}\{1F1F6}", 'CHARACTER_FLAGS_FOR_MAURITANIA'=> "\{1F1F2}\{1F1F7}", 'CHARACTER_FLAGS_FOR_MONTSERRAT'=> "\{1F1F2}\{1F1F8}", 'CHARACTER_FLAGS_FOR_MALTA'=> "\{1F1F2}\{1F1F9}", 'CHARACTER_FLAGS_FOR_MAURITIUS'=> "\{1F1F2}\{1F1FA}", 'CHARACTER_FLAGS_FOR_MALDIVES'=> "\{1F1F2}\{1F1FB}", 'CHARACTER_FLAGS_FOR_MALAWI'=> "\{1F1F2}\{1F1FC}", 'CHARACTER_FLAGS_FOR_MEXICO'=> "\{1F1F2}\{1F1FD}", 'CHARACTER_FLAGS_FOR_MALAYSIA'=> "\{1F1F2}\{1F1FE}", 'CHARACTER_FLAGS_FOR_MOZAMBIQUE'=> "\{1F1F2}\{1F1FF}", 'CHARACTER_FLAGS_FOR_NAMIBIA'=> "\{1F1F3}\{1F1E6}", 'CHARACTER_FLAGS_FOR_NEW_CALEDONIA'=> "\{1F1F3}\{1F1E8}", 'CHARACTER_FLAGS_FOR_NIGER'=> "\{1F1F3}\{1F1EA}", 'CHARACTER_FLAGS_FOR_NORFOLK_ISLAND'=> "\{1F1F3}\{1F1EB}", 'CHARACTER_FLAGS_FOR_NIGERIA'=> "\{1F1F3}\{1F1EC}", 'CHARACTER_FLAGS_FOR_NICARAGUA'=> "\{1F1F3}\{1F1EE}", 'CHARACTER_FLAGS_FOR_NETHERLANDS'=> "\{1F1F3}\{1F1F1}", 'CHARACTER_FLAGS_FOR_NORWAY'=> "\{1F1F3}\{1F1F4}", 'CHARACTER_FLAGS_FOR_NEPAL'=> "\{1F1F3}\{1F1F5}", 'CHARACTER_FLAGS_FOR_NAURU'=> "\{1F1F3}\{1F1F7}", 'CHARACTER_FLAGS_FOR_NIUE'=> "\{1F1F3}\{1F1FA}", 'CHARACTER_FLAGS_FOR_NEW_ZEALAND'=> "\{1F1F3}\{1F1FF}", 'CHARACTER_FLAGS_FOR_OMAN'=> "\{1F1F4}\{1F1F2}", 'CHARACTER_FLAGS_FOR_PANAMA'=> "\{1F1F5}\{1F1E6}", 'CHARACTER_FLAGS_FOR_PERU'=> "\{1F1F5}\{1F1EA}", 'CHARACTER_FLAGS_FOR_FRENCH_POLYNESIA'=> "\{1F1F5}\{1F1EB}", 'CHARACTER_FLAGS_FOR_PAPUA_NEW_GUINEA'=> "\{1F1F5}\{1F1EC}", 'CHARACTER_FLAGS_FOR_PHILIPPINES'=> "\{1F1F5}\{1F1ED}", 'CHARACTER_FLAGS_FOR_PAKISTAN'=> "\{1F1F5}\{1F1F0}", 'CHARACTER_FLAGS_FOR_POLAND'=> "\{1F1F5}\{1F1F1}", 'CHARACTER_FLAGS_FOR_ST_PIERRE_AND_MIQUELON'=> "\{1F1F5}\{1F1F2}", 'CHARACTER_FLAGS_FOR_PITCAIRN_ISLANDS'=> "\{1F1F5}\{1F1F3}", 'CHARACTER_FLAGS_FOR_PUERTO_RICO'=> "\{1F1F5}\{1F1F7}", 'CHARACTER_FLAGS_FOR_PALESTINIAN_TERRITORIES'=> "\{1F1F5}\{1F1F8}", 'CHARACTER_FLAGS_FOR_PORTUGAL'=> "\{1F1F5}\{1F1F9}", 'CHARACTER_FLAGS_FOR_PALAU'=> "\{1F1F5}\{1F1FC}", 'CHARACTER_FLAGS_FOR_PARAGUAY'=> "\{1F1F5}\{1F1FE}", 'CHARACTER_FLAGS_FOR_QATAR'=> "\{1F1F6}\{1F1E6}", 'CHARACTER_FLAGS_FOR_REUNION'=> "\{1F1F7}\{1F1EA}", 'CHARACTER_FLAGS_FOR_ROMANIA'=> "\{1F1F7}\{1F1F4}", 'CHARACTER_FLAGS_FOR_SERBIA'=> "\{1F1F7}\{1F1F8}", 'CHARACTER_FLAGS_FOR_RUSSIA'=> "\{1F1F7}\{1F1FA}", 'CHARACTER_FLAGS_FOR_RWANDA'=> "\{1F1F7}\{1F1FC}", 'CHARACTER_FLAGS_FOR_SAUDI_ARABIA'=> "\{1F1F8}\{1F1E6}", 'CHARACTER_FLAGS_FOR_SOLOMON_ISLANDS'=> "\{1F1F8}\{1F1E7}", 'CHARACTER_FLAGS_FOR_SEYCHELLES'=> "\{1F1F8}\{1F1E8}", 'CHARACTER_FLAGS_FOR_SUDAN'=> "\{1F1F8}\{1F1E9}", 'CHARACTER_FLAGS_FOR_SWEDEN'=> "\{1F1F8}\{1F1EA}", 'CHARACTER_FLAGS_FOR_SINGAPORE'=> "\{1F1F8}\{1F1EC}", 'CHARACTER_FLAGS_FOR_ST_HELENA'=> "\{1F1F8}\{1F1ED}", 'CHARACTER_FLAGS_FOR_SLOVENIA'=> "\{1F1F8}\{1F1EE}", 'CHARACTER_FLAGS_FOR_SVALBARD_AND_JAN_MAYEN'=> "\{1F1F8}\{1F1EF}", 'CHARACTER_FLAGS_FOR_SLOVAKIA'=> "\{1F1F8}\{1F1F0}", 'CHARACTER_FLAGS_FOR_SIERRA_LEONE'=> "\{1F1F8}\{1F1F1}", 'CHARACTER_FLAGS_FOR_SAN_MARINO'=> "\{1F1F8}\{1F1F2}", 'CHARACTER_FLAGS_FOR_SENEGAL'=> "\{1F1F8}\{1F1F3}", 'CHARACTER_FLAGS_FOR_SOMALIA'=> "\{1F1F8}\{1F1F4}", 'CHARACTER_FLAGS_FOR_SURINAME'=> "\{1F1F8}\{1F1F7}", 'CHARACTER_FLAGS_FOR_SOUTH_SUDAN'=> "\{1F1F8}\{1F1F8}", 'CHARACTER_FLAGS_FOR_SAO_TOME_AND_PRINCIPE'=> "\{1F1F8}\{1F1F9}", 'CHARACTER_FLAGS_FOR_EL_SALVADOR'=> "\{1F1F8}\{1F1FB}", 'CHARACTER_FLAGS_FOR_SINT_MAARTEN'=> "\{1F1F8}\{1F1FD}", 'CHARACTER_FLAGS_FOR_SYRIA'=> "\{1F1F8}\{1F1FE}", 'CHARACTER_FLAGS_FOR_SWAZILAND'=> "\{1F1F8}\{1F1FF}", 'CHARACTER_FLAGS_FOR_TRISTAN_DA_CUNHA'=> "\{1F1F9}\{1F1E6}", 'CHARACTER_FLAGS_FOR_TURKS_AND_CAICOS_ISLANDS'=> "\{1F1F9}\{1F1E8}", 'CHARACTER_FLAGS_FOR_CHAD'=> "\{1F1F9}\{1F1E9}", 'CHARACTER_FLAGS_FOR_FRENCH_SOUTHERN_TERRITORIES'=> "\{1F1F9}\{1F1EB}", 'CHARACTER_FLAGS_FOR_TOGO'=> "\{1F1F9}\{1F1EC}", 'CHARACTER_FLAGS_FOR_THAILAND'=> "\{1F1F9}\{1F1ED}", 'CHARACTER_FLAGS_FOR_TAJIKISTAN'=> "\{1F1F9}\{1F1EF}", 'CHARACTER_FLAGS_FOR_TOKELAU'=> "\{1F1F9}\{1F1F0}", 'CHARACTER_FLAGS_FOR_TIMOR_LESTE'=> "\{1F1F9}\{1F1F1}", 'CHARACTER_FLAGS_FOR_TURKMENISTAN'=> "\{1F1F9}\{1F1F2}", 'CHARACTER_FLAGS_FOR_TUNISIA'=> "\{1F1F9}\{1F1F3}", 'CHARACTER_FLAGS_FOR_TONGA'=> "\{1F1F9}\{1F1F4}", 'CHARACTER_FLAGS_FOR_TURKEY'=> "\{1F1F9}\{1F1F7}", 'CHARACTER_FLAGS_FOR_TRINIDAD_AND_TOBAGO'=> "\{1F1F9}\{1F1F9}", 'CHARACTER_FLAGS_FOR_TUVALU'=> "\{1F1F9}\{1F1FB}", 'CHARACTER_FLAGS_FOR_TAIWAN'=> "\{1F1F9}\{1F1FC}", 'CHARACTER_FLAGS_FOR_TANZANIA'=> "\{1F1F9}\{1F1FF}", 'CHARACTER_FLAGS_FOR_UKRAINE'=> "\{1F1FA}\{1F1E6}", 'CHARACTER_FLAGS_FOR_UGANDA'=> "\{1F1FA}\{1F1EC}", 'CHARACTER_FLAGS_FOR_US_OUTLYING_ISLANDS'=> "\{1F1FA}\{1F1F2}", 'CHARACTER_FLAGS_FOR_UNITED_NATIONS'=> "\{1F1FA}\{1F1F3}", 'CHARACTER_FLAGS_FOR_UNITED_STATES'=> "\{1F1FA}\{1F1F8}", 'CHARACTER_FLAGS_FOR_URUGUAY'=> "\{1F1FA}\{1F1FE}", 'CHARACTER_FLAGS_FOR_UZBEKISTAN'=> "\{1F1FA}\{1F1FF}", 'CHARACTER_FLAGS_FOR_VATICAN_CITY'=> "\{1F1FB}\{1F1E6}", 'CHARACTER_FLAGS_FOR_ST_VINCENT_AND_GRENADINES'=> "\{1F1FB}\{1F1E8}", 'CHARACTER_FLAGS_FOR_VENEZUELA'=> "\{1F1FB}\{1F1EA}", 'CHARACTER_FLAGS_FOR_BRITISH_VIRGIN_ISLANDS'=> "\{1F1FB}\{1F1EC}", 'CHARACTER_FLAGS_FOR_US_VIRGIN_ISLANDS'=> "\{1F1FB}\{1F1EE}", 'CHARACTER_FLAGS_FOR_VIETNAM'=> "\{1F1FB}\{1F1F3}", 'CHARACTER_FLAGS_FOR_VANUATU'=> "\{1F1FB}\{1F1FA}", 'CHARACTER_FLAGS_FOR_WALLIS_AND_FUTUNA'=> "\{1F1FC}\{1F1EB}", 'CHARACTER_FLAGS_FOR_SAMOA'=> "\{1F1FC}\{1F1F8}", 'CHARACTER_FLAGS_FOR_KOSOVO'=> "\{1F1FD}\{1F1F0}", 'CHARACTER_FLAGS_FOR_YEMEN'=> "\{1F1FE}\{1F1EA}", 'CHARACTER_FLAGS_FOR_MAYOTTE'=> "\{1F1FE}\{1F1F9}", 'CHARACTER_FLAGS_FOR_SOUTH_AFRICA'=> "\{1F1FF}\{1F1E6}", 'CHARACTER_FLAGS_FOR_ZAMBIA'=> "\{1F1FF}\{1F1F2}", 'CHARACTER_FLAGS_FOR_ZIMBABWE'=> "\{1F1FF}\{1F1FC}", 'CHARACTER_FLAGS_FOR_ENGLAND'=> "\{1F3F4}\{E0067}\{E0062}\{E0065}\{E006E}\{E0067}\{E007F}", 'CHARACTER_FLAGS_FOR_SCOTLAND'=> "\{1F3F4}\{E0067}\{E0062}\{E0073}\{E0063}\{E0074}\{E007F}", 'CHARACTER_FLAGS_FOR_WALES'=> "\{1F3F4}\{E0067}\{E0062}\{E0077}\{E006C}\{E0073}\{E007F}",]


Joomla CMS: Référence du fichier empty_state.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • tasks
Espaces de nommage | Variables
Référence du fichier empty_state.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_scheduler'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_SCHEDULER'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_scheduler'))
Valeur initiale :
=> 'index.php?option=com_scheduler&task=task.add',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/J4.x:Task_Scheduler',
'icon' => 'icon-clock clock',
]


Joomla CMS: Référence du fichier EmptyResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier EmptyResponse.php

Structures de données

class EmptyResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banners
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/banners/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_banners')||count( $user->getAuthorisedCategories( 'com_banners', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_BANNERS'

Référencé par LayoutHelper\debug(), ModuleDispatcher\dispatch(), PlgEditorCodemirror\onDisplay(), PlgEditorCodemirror\onInit(), MessageRenderer\render(), ModulesRenderer\render(), LayoutHelper\render(), FileLayout\render(), BaseLayout\render(), FieldsHelper\render(), ModuleHelper\renderModule(), et FileLayout\sublayout().

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_banners')||count($user->getAuthorisedCategories('com_banners', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • clients
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/clients/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (count(Factory::getApplication() ->getIdentity() ->getAuthorisedCategories( 'com_banners', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_BANNERS_CLIENT'

◆ if

if(count(Factory::getApplication() ->getIdentity() ->getAuthorisedCategories('com_banners', 'core.create')) > 0)
Valeur initiale :
=> 'index.php?option=com_banners&view=clients',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Help40:Banners:_Clients',
'icon' => 'icon-bookmark banners',
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • tracks
Espaces de nommage | Variables
Référence du fichier administrator/components/com_banners/tmpl/tracks/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_BANNERS_TRACKS'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • tmpl
  • cache
Espaces de nommage | Variables
Référence du fichier administrator/components/com_cache/tmpl/cache/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CACHE'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier administrator/components/com_categories/tmpl/categories/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$extension = $this->state->get('filter.extension')
$component = $this->state->get('filter.component')
$section = $this->state->get('filter.section')
$lang = Factory::getApplication()->getLanguage()
if($lang->hasKey($component_title_key=strtoupper($component .($section ? "_$section" :'')) . '_CATEGORIES_TITLE')) elseif($lang->hasKey($component_section_key=strtoupper($component .($section ? "_$section" :'')))) else
$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', $extension))

Documentation des variables

◆ $component

$component = $this->state->get('filter.component')

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CATEGORIES'

◆ $extension

$extension = $this->state->get('filter.extension')

◆ $lang

$lang = Factory::getApplication()->getLanguage()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par LastvisitdaterangeField\__construct(), SitePathway\__construct(), UseractiveField\__construct(), RegistrationdaterangeField\__construct(), LogsdaterangeField\__construct(), Token\__construct(), HtmlDocument\_fetchTemplate(), RouteHelper\_findItem(), PlgExtensionFinder\addCommonWords(), HtmlView\addToolbar(), IndexerController\batch(), PlgSystemLanguageFilter\buildRule(), HTMLHelper\calendar(), Factory\createDocument(), Factory\createLanguage(), Help\createUrl(), InstallationApplication\debugLanguage(), LegacyComponentDispatcher\dispatch(), HtmlView\display(), PlgSystemFields\display(), InstallerAdapter\doLoadLanguage(), Users\editor(), Query\explained(), ExceptionCaster\extractSource(), AjaxController\fetchAssociations(), ColorField\getAdvancedModeLayoutData(), ASCII\getAllLanguages(), Helper\getCommonWords(), ComponentModel\getComponent(), DebugHelper\getComponents(), StatisticsModel\getData(), InstalledModel\getData(), DebugHelper\getDebugActions(), Helper\getDefaultLanguage(), MessagesModel\getExtensionName(), TemplateModel\getFiles(), ComponentModel\getForm(), TemplatestyleField\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), ItemModel\getItem(), PositionsModel\getItems(), SelectModel\getItems(), ItemsModel\getItems(), ColorField\getLayoutData(), CalendarField\getLayoutData(), LanguagesHelper\getList(), SuggestionsModel\getListQuery(), InstallationApplication\getLocaliseAdmin(), ModulesHelper\getModules(), AliastagField\getOptions(), ComponentsField\getOptions(), LanguageField\getOptions(), ComponentsCategoryField\getOptions(), ConfigComponentsField\getOptions(), ContenttypesField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), ContenttypeField\getOptions(), PluginsField\getOptions(), ModulesModel\getPositions(), MenusHelper\getPresets(), Helper\getPrimaryLanguage(), PrivacyStatusHelper\getRequestFormPublished(), LoginHelper\getReturnUrl(), AssociationsHelper\getSupportedExtension(), ModulesHelper\getTranslatedModulePosition(), MenutypesModel\getTypeOptions(), MenutypesModel\getTypeOptionsFromLayouts(), DatabaseModel\initialise(), AdministratorApplication\initialiseApp(), SiteApplication\initialiseApp(), CMSApplication\initialiseApp(), Helper\isCommon(), ActionlogsHelper\loadActionLogPluginsLanguage(), InstallationApplication\loadDocument(), Form\loadField(), CMSPlugin\loadLanguage(), ContenthistoryHelper\loadLanguageFiles(), ConfigHelper\loadLanguageForComponent(), FileLayout\loadLanguageSuffixes(), LanguageHelper\loadPluginLanguage(), HtmlView\loadTemplate(), MailsHelper\loadTranslationFiles(), ActionlogsHelper\loadTranslationFiles(), AdministratorApplication\login(), Finder\mapslist(), Mbstring\mb_language(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSampledataMultilang\onAjaxSampledataApplyStep2(), PlgSystemAccessibility\onBeforeCompileHead(), PlgContentJoomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgInstallerWebinstaller\onInstallerAddInstallationTab(), PlgWorkflowNotification\onWorkflowAfterTransition(), TemplateAdapter\parseQueries(), PlgSystemLanguageFilter\parseRule(), SuggestionsModel\populateState(), PlgSystemLanguageFilter\postprocessNonSEFBuildRule(), ContentmapField\prepareLevel(), PlgSystemLanguageFilter\preprocessBuildRule(), ModulesModel\preprocessForm(), TemplatesModel\preprocessForm(), GroupModel\preprocessForm(), PluginModel\preprocessForm(), StyleModel\preprocessForm(), CategoryModel\preprocessForm(), ModuleModel\preprocessForm(), FieldModel\preprocessForm(), Query\processString(), Application\register(), PlgExtensionFinder\removeCommonWords(), MessageModel\save(), ArticleController\save(), ActionlogModel\sendNotificationEmails(), Document\setLanguage(), BreadcrumbsHelper\setSeparator(), CalendarField\setup(), Filter\slider(), Helper\stem(), OutputFilter\stringURLSafe(), Helper\tokenize(), Indexer\tokenizeToDb(), Indexer\tokenizeToDbShort(), InstallerModel\translate(), PluginsModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), Finder\typeslist(), et SetupModel\validateDbConnection().

◆ $section

$section = $this->state->get('filter.section')

◆ else

if ( $lang->hasKey( $component_title_key=strtoupper( $component .( $section ? "_$section" :'')) . '_CATEGORIES_TITLE')) elseif ( $lang->hasKey( $component_section_key=strtoupper( $component .( $section ? "_$section" :'')))) else
Valeur initiale :
{
$title = Text::_('COM_CATEGORIES_CATEGORIES_BASE_TITLE')
$title
$title
Definition: administrator/components/com_finder/tmpl/maps/default.php:99

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', $extension))
Valeur initiale :
=> 'index.php?option=com_categories&extension=' . $extension,
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Category',
'title' => $title,
'icon' => 'icon-folder categories content-categories',
]
$title
$title
Definition: administrator/components/com_finder/tmpl/maps/default.php:99
$extension
$extension
Definition: administrator/components/com_categories/tmpl/categories/emptystate.php:17


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • tmpl
  • checkin
Espaces de nommage | Variables
Référence du fichier administrator/components/com_checkin/tmpl/checkin/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CHECKIN'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Espaces de nommage | Variables
Référence du fichier administrator/components/com_contact/tmpl/contacts/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_contact')||count( $user->getAuthorisedCategories( 'com_contact', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CONTACT'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_contact')||count($user->getAuthorisedCategories('com_contact', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/articles/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_content')||count( $user->getAuthorisedCategories( 'com_content', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CONTENT'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_content')||count($user->getAuthorisedCategories('com_content', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • featured
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/featured/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_content')||count( $user->getAuthorisedCategories( 'com_content', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_CONTENT'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_content')||count($user->getAuthorisedCategories('com_content', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • filters
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/filters/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_finder'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_FINDER'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_finder'))
Valeur initiale :
=> 'index.php?option=com_finder&view=filters',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Smart_Search_quickstart_guide',
'icon' => 'icon-search-plus finder',
'btnadd' => Text::_('COM_FINDER_FILTERS_EMPTYSTATE_BUTTON_ADD'),
'content' => Text::_('COM_FINDER_FILTERS_EMPTYSTATE_CONTENT'),
'title' => Text::_('COM_FINDER_FILTERS_TOOLBAR_TITLE'),
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • index
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/index/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
endif

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_FINDER'

◆ endif

endif


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • maps
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/maps/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_FINDER'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • searches
Espaces de nommage | Variables
Référence du fichier administrator/components/com_finder/tmpl/searches/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_FINDER'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • discover
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/discover/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_INSTALLER'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • update
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/update/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_content')||count( $user->getAuthorisedCategories( 'com_content', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_INSTALLER'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_content')||count($user->getAuthorisedCategories('com_content', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • warnings
Espaces de nommage | Variables
Référence du fichier administrator/components/com_installer/tmpl/warnings/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Help4.x:Information:_Warnings'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • messages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_messages/tmpl/messages/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_messages') &&Factory::getApplication() ->getIdentity() ->authorise( 'core.manage', 'com_users'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_MESSAGES'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_messages') &&Factory::getApplication() ->getIdentity() ->authorise('core.manage', 'com_users'))
Valeur initiale :
=> 'index.php?option=com_messages&view=messages',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Help40:Private_Messages',
'icon' => 'icon-envelope inbox',
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/modules/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_modules'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_MODULES'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_modules'))
Valeur initiale :
=> 'index.php?option=com_modules&view=select&client_id=' . $this->clientId,
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Module',
'icon' => 'icon-cube module',
'title' => Text::_('COM_MODULES_EMPTYSTATE_TITLE_' . ($this->clientId ? 'ADMINISTRATOR' : 'SITE')),
]
$clientId
$clientId
Definition: administrator/components/com_menus/tmpl/item/edit.php:40


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Espaces de nommage | Variables
Référence du fichier administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
if ( $user->authorise( 'core.create', 'com_newsfeeds')||count( $user->getAuthorisedCategories( 'com_newsfeeds', 'core.create')) > 0)

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_NEWSFEEDS'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ if

if($user->authorise('core.create', 'com_newsfeeds')||count($user->getAuthorisedCategories('com_newsfeeds', 'core.create')) > 0)


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • tmpl
  • messages
Espaces de nommage | Variables
Référence du fichier administrator/components/com_postinstall/tmpl/messages/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$adminFormClass = count($this->extension_options) > 1 ? 'form-inline mb-3' : 'visually-hidden'
$displayData

Documentation des variables

◆ $adminFormClass

$adminFormClass = count($this->extension_options) > 1 ? 'form-inline mb-3' : 'visually-hidden'

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_POSTINSTALL'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • consents
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/consents/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_PRIVACY_CONSENTS'


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • requests
Espaces de nommage | Variables
Référence du fichier administrator/components/com_privacy/tmpl/requests/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->get( 'mailonline', 1))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_PRIVACY_REQUESTS'

◆ if

if(Factory::getApplication() ->get('mailonline', 1))
Valeur initiale :
=> 'index.php?option=com_privacy&view=requests',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Help40:Privacy:_Information_Requests',
'icon' => 'icon-lock',
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Espaces de nommage | Variables
Référence du fichier administrator/components/com_redirect/tmpl/links/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
$user = Factory::getApplication()->getIdentity()
endif

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_REDIRECT'

◆ $user

$user = Factory::getApplication()->getIdentity()

◆ endif

endif


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tags
Espaces de nommage | Variables
Référence du fichier administrator/components/com_tags/tmpl/tags/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_tags'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_TAGS'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_tags'))
Valeur initiale :
=> 'index.php?option=com_tags&task=tag.add',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/J3.x:How_To_Use_Content_Tags_in_Joomla!',
'icon' => 'icon-tags tags',
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • notes
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/notes/emptystate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData
if (Factory::getApplication() ->getIdentity() ->authorise( 'core.create', 'com_users'))

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_USERS_NOTES'

◆ if

if(Factory::getApplication() ->getIdentity() ->authorise('core.create', 'com_users'))
Valeur initiale :
=> 'index.php?option=com_users&view=notes',
'helpURL' => 'https://docs.joomla.org/Special:MyLanguage/Help40:User_Notes',
'icon' => 'icon-users user',
]


Joomla CMS: Référence du fichier emptystate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier layouts/joomla/content/emptystate.php

Espaces de nommage

Joomla\Site

Variables

$textPrefix = $displayData['textPrefix'] ?? ''
if(! $textPrefix) $formURL = $displayData['formURL'] ?? ''
$createURL = $displayData['createURL'] ?? ''
$helpURL = $displayData['helpURL'] ?? ''
$title = $displayData['title'] ?? Text::_($textPrefix . '_EMPTYSTATE_TITLE')
$content = $displayData['content'] ?? Text::_($textPrefix . '_EMPTYSTATE_CONTENT')
$icon = $displayData['icon'] ?? 'icon-copy article'
$append = $displayData['formAppend'] ?? ''
$btnadd = $displayData['btnadd'] ?? Text::_($textPrefix . '_EMPTYSTATE_BUTTON_ADD')
endif
if ( $helpURL)

Documentation des variables

◆ $append

$append = $displayData['formAppend'] ?? ''

Référencé par NoteController\getRedirectToItemAppend(), WorkflowController\getRedirectToItemAppend(), StageController\getRedirectToItemAppend(), TransitionController\getRedirectToItemAppend(), GroupController\getRedirectToItemAppend(), CategoryController\getRedirectToItemAppend(), ArticleController\getRedirectToItemAppend(), ModuleController\getRedirectToItemAppend(), ContactController\getRedirectToItemAppend(), FormController\getRedirectToItemAppend(), ModulesController\getRedirectToListAppend(), TransitionsController\getRedirectToListAppend(), WorkflowController\getRedirectToListAppend(), StageController\getRedirectToListAppend(), TransitionController\getRedirectToListAppend(), GroupController\getRedirectToListAppend(), CategoryController\getRedirectToListAppend(), ModuleController\getRedirectToListAppend(), et FormController\getRedirectToListAppend().

◆ $btnadd

$btnadd = $displayData['btnadd'] ?? Text::_($textPrefix . '_EMPTYSTATE_BUTTON_ADD')

◆ $content

$content = $displayData['content'] ?? Text::_($textPrefix . '_EMPTYSTATE_CONTENT')

◆ $createURL

$createURL = $displayData['createURL'] ?? ''

◆ $formURL

if (! $textPrefix) $formURL = $displayData['formURL'] ?? ''

◆ $helpURL

$helpURL = $displayData['helpURL'] ?? ''

Référencé par PluginModel\preprocessForm(), StyleModel\preprocessForm(), ModuleModel\preprocessForm(), et ItemModel\preprocessForm().

◆ $icon

$icon = $displayData['icon'] ?? 'icon-copy article'

◆ $textPrefix

$textPrefix = $displayData['textPrefix'] ?? ''

◆ $title

$title = $displayData['title'] ?? Text::_($textPrefix . '_EMPTYSTATE_TITLE')

◆ endif

endif

◆ if

if($helpURL)


Joomla CMS: Référence du fichier emptystate_module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier emptystate_module.php

Espaces de nommage

Joomla\Site

Variables

$icon = $displayData['icon'] ?? 'icon-copy article'
$textPrefix = $displayData['textPrefix'] ?? ''
$textSuffix = $displayData['textSuffix'] ?? ''
$title = $displayData['title'] ?? ''
$componentLangString = $textPrefix . '_EMPTYSTATE_TITLE' . $textSuffix
$moduleLangString = $textPrefix . '_EMPTYSTATE_MODULE_TITLE' . $textSuffix
if (! $title)

Documentation des variables

◆ $componentLangString

$componentLangString = $textPrefix . '_EMPTYSTATE_TITLE' . $textSuffix

◆ $icon

$icon = $displayData['icon'] ?? 'icon-copy article'

◆ $moduleLangString

$moduleLangString = $textPrefix . '_EMPTYSTATE_MODULE_TITLE' . $textSuffix

◆ $textPrefix

$textPrefix = $displayData['textPrefix'] ?? ''

◆ $textSuffix

$textSuffix = $displayData['textSuffix'] ?? ''

◆ $title

$title = $displayData['title'] ?? ''

◆ if

if(! $title)


Joomla CMS: Référence du fichier EmptyTrustPath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Structures de données | Espaces de nommage
Référence du fichier EmptyTrustPath.php

Structures de données

class EmptyTrustPath

Espaces de nommage

Webauthn\TrustPath


Joomla CMS: Référence du fichier Encoder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Parsing
Structures de données | Espaces de nommage
Référence du fichier Encoder.php

Structures de données

class Encoder

Espaces de nommage

Lcobucci\JWT\Parsing


Joomla CMS: Référence du fichier EncoderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier EncoderInterface.php

Structures de données

interface EncoderInterface

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier Encoding.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier defuse/php-encryption/src/Encoding.php

Structures de données

class Encoding

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier Encoding.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier paragonie/constant_time_encoding/src/Encoding.php

Structures de données

class Encoding

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier EncodingHelperInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • EncodingHelper
Structures de données | Espaces de nommage
Référence du fichier EncodingHelperInterface.php

Structures de données

interface EncodingHelperInterface

Espaces de nommage

Algo26\IdnaConvert\EncodingHelper


Joomla CMS: Référence du fichier EncodingNegotiator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier EncodingNegotiator.php

Structures de données

class EncodingNegotiator

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier encodings.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier encodings.php

Variables

return ['ISO-8859-1', 'ISO-8859-2', 'ISO-8859-3', 'ISO-8859-4', 'ISO-8859-5', 'ISO-8859-6', 'ISO-8859-7', 'ISO-8859-8', 'ISO-8859-9', 'ISO-8859-10', 'ISO-8859-13', 'ISO-8859-14', 'ISO-8859-15', 'ISO-8859-16', 'WINDOWS-1251', 'WINDOWS-1252', 'WINDOWS-1254', 'CP932', 'CP936', 'CP950', 'CP866', 'CP850', 'CP51932', 'CP50220', 'CP50221', 'CP50222', 'ISO-2022-JP', 'ISO-2022-KR', 'JIS', 'JIS-ms', 'EUC-CN', 'EUC-JP', 'ANSI_X3.4-1968', 'ANSI_X3.4-1986', 'ASCII', 'CP367', 'IBM367', 'ISO-IR-6', 'ISO646-US', 'ISO_646.IRV:1991', 'US', 'US-ASCII', 'CSASCII', 'UTF-8', 'ISO-10646-UCS-2', 'UCS-2', 'CSUNICODE', 'UCS-2BE', 'UNICODE-1-1', 'UNICODEBIG', 'CSUNICODE11', 'UCS-2LE', 'UNICODELITTLE', 'ISO-10646-UCS-4', 'UCS-4', 'CSUCS4', 'UCS-4BE', 'UCS-4LE', 'UTF-16', 'UTF-16BE', 'UTF-16LE', 'UTF-32', 'UTF-32BE', 'UTF-32LE', 'UNICODE-1-1-UTF-7', 'UTF-7', 'CSUNICODE11UTF7', 'UCS-2-INTERNAL', 'UCS-2-SWAPPED', 'UCS-4-INTERNAL', 'UCS-4-SWAPPED', 'C99', 'JAVA', 'CP819', 'IBM819', 'ISO-IR-100', 'ISO8859-1', 'ISO_8859-1', 'ISO_8859-1:1987', 'L1', 'LATIN1', 'CSISOLATIN1', 'ISO-IR-101', 'ISO8859-2', 'ISO_8859-2', 'ISO_8859-2:1987', 'L2', 'LATIN2', 'CSISOLATIN2', 'ISO-IR-109', 'ISO8859-3', 'ISO_8859-3', 'ISO_8859-3:1988', 'L3', 'LATIN3', 'CSISOLATIN3', 'ISO-IR-110', 'ISO8859-4', 'ISO_8859-4', 'ISO_8859-4:1988', 'L4', 'LATIN4', 'CSISOLATIN4', 'CYRILLIC', 'ISO-IR-144', 'ISO8859-5', 'ISO_8859-5', 'ISO_8859-5:1988', 'CSISOLATINCYRILLIC', 'ARABIC', 'ASMO-708', 'ECMA-114', 'ISO-IR-127', 'ISO8859-6', 'ISO_8859-6', 'ISO_8859-6:1987', 'CSISOLATINARABIC', 'ECMA-118', 'ELOT_928', 'GREEK', 'GREEK8', 'ISO-IR-126', 'ISO8859-7', 'ISO_8859-7', 'ISO_8859-7:1987', 'ISO_8859-7:2003', 'CSISOLATINGREEK', 'HEBREW', 'ISO-IR-138', 'ISO8859-8', 'ISO_8859-8', 'ISO_8859-8:1988', 'CSISOLATINHEBREW', 'ISO-IR-148', 'ISO8859-9', 'ISO_8859-9', 'ISO_8859-9:1989', 'L5', 'LATIN5', 'CSISOLATIN5', 'ISO-IR-157', 'ISO8859-10', 'ISO_8859-10', 'ISO_8859-10:1992', 'L6', 'LATIN6', 'CSISOLATIN6', 'ISO-8859-11', 'ISO8859-11', 'ISO_8859-11', 'ISO-IR-179', 'ISO8859-13', 'ISO_8859-13', 'L7', 'LATIN7', 'ISO-CELTIC', 'ISO-IR-199', 'ISO8859-14', 'ISO_8859-14', 'ISO_8859-14:1998', 'L8', 'LATIN8', 'ISO-IR-203', 'ISO8859-15', 'ISO_8859-15', 'ISO_8859-15:1998', 'LATIN-9', 'ISO-IR-226', 'ISO8859-16', 'ISO_8859-16', 'ISO_8859-16:2001', 'L10', 'LATIN10', 'KOI8-R', 'CSKOI8R', 'KOI8-U', 'KOI8-RU', 'CP1250', 'MS-EE', 'WINDOWS-1250', 'CP1251', 'MS-CYRL', 'CP1252', 'MS-ANSI', 'CP1253', 'MS-GREEK', 'WINDOWS-1253', 'CP1254', 'MS-TURK', 'CP1255', 'MS-HEBR', 'WINDOWS-1255', 'CP1256', 'MS-ARAB', 'WINDOWS-1256', 'CP1257', 'WINBALTRIM', 'WINDOWS-1257', 'CP1258', 'WINDOWS-1258', '850', 'IBM850', 'CSPC850MULTILINGUAL', '862', 'CP862', 'IBM862', 'CSPC862LATINHEBREW', '866', 'IBM866', 'CSIBM866', 'MAC', 'MACINTOSH', 'MACROMAN', 'CSMACINTOSH', 'MACCENTRALEUROPE', 'MACICELAND', 'MACCROATIAN', 'MACROMANIA', 'MACCYRILLIC', 'MACUKRAINE', 'MACGREEK', 'MACTURKISH', 'MACHEBREW', 'MACARABIC', 'MACTHAI', 'HP-ROMAN8', 'R8', 'ROMAN8', 'CSHPROMAN8', 'NEXTSTEP', 'ARMSCII-8', 'GEORGIAN-ACADEMY', 'GEORGIAN-PS', 'KOI8-T', 'CP154', 'CYRILLIC-ASIAN', 'PT154', 'PTCP154', 'CSPTCP154', 'KZ-1048', 'RK1048', 'STRK1048-2002', 'CSKZ1048', 'MULELAO-1', 'CP1133', 'IBM-CP1133', 'ISO-IR-166', 'TIS-620', 'TIS620', 'TIS620-0', 'TIS620.2529-1', 'TIS620.2533-0', 'TIS620.2533-1', 'CP874', 'WINDOWS-874', 'VISCII', 'VISCII1.1-1', 'CSVISCII', 'TCVN', 'TCVN-5712', 'TCVN5712-1', 'TCVN5712-1:1993', 'ISO-IR-14', 'ISO646-JP', 'JIS_C6220-1969-RO', 'JP', 'CSISO14JISC6220RO', 'JISX0201-1976', 'JIS_X0201', 'X0201', 'CSHALFWIDTHKATAKANA', 'ISO-IR-87', 'JIS0208', 'JIS_C6226-1983', 'JIS_X0208', 'JIS_X0208-1983', 'JIS_X0208-1990', 'X0208', 'CSISO87JISX0208', 'ISO-IR-159', 'JIS_X0212', 'JIS_X0212-1990', 'JIS_X0212.1990-0', 'X0212', 'CSISO159JISX02121990', 'CN', 'GB_1988-80', 'ISO-IR-57', 'ISO646-CN', 'CSISO57GB1988', 'CHINESE', 'GB_2312-80', 'ISO-IR-58', 'CSISO58GB231280', 'CN-GB-ISOIR165', 'ISO-IR-165', 'ISO-IR-149', 'KOREAN', 'KSC_5601', 'KS_C_5601-1987', 'KS_C_5601-1989', 'CSKSC56011987', 'EUCJP', 'EXTENDED_UNIX_CODE_PACKED_FORMAT_FOR_JAPANESE', 'CSEUCPKDFMTJAPANESE', 'MS_KANJI', 'SHIFT-JIS', 'SHIFT_JIS', 'SJIS', 'CSSHIFTJIS', 'CSISO2022JP', 'ISO-2022-JP-1', 'ISO-2022-JP-2', 'CSISO2022JP2', 'CN-GB', 'EUCCN', 'GB2312', 'CSGB2312', 'GBK', 'MS936', 'WINDOWS-936', 'GB18030', 'ISO-2022-CN', 'CSISO2022CN', 'ISO-2022-CN-EXT', 'HZ', 'HZ-GB-2312', 'EUC-TW', 'EUCTW', 'CSEUCTW', 'BIG-5', 'BIG-FIVE', 'BIG5', 'BIGFIVE', 'CN-BIG5', 'CSBIG5', 'BIG5-HKSCS:1999', 'BIG5-HKSCS:2001', 'BIG5-HKSCS', 'BIG5-HKSCS:2004', 'BIG5HKSCS', 'EUC-KR', 'EUCKR', 'CSEUCKR', 'CP949', 'UHC', 'CP1361', 'JOHAB', 'CSISO2022KR', 'CP856', 'CP922', 'CP943', 'CP1046', 'CP1124', 'CP1129', 'CP1161', 'IBM-1161', 'IBM1161', 'CSIBM1161', 'CP1162', 'IBM-1162', 'IBM1162', 'CSIBM1162', 'CP1163', 'IBM-1163', 'IBM1163', 'CSIBM1163', 'DEC-KANJI', 'DEC-HANYU', '437', 'CP437', 'IBM437', 'CSPC8CODEPAGE437', 'CP737', 'CP775', 'IBM775', 'CSPC775BALTIC', '852', 'CP852', 'IBM852', 'CSPCP852', 'CP853', '855', 'CP855', 'IBM855', 'CSIBM855', '857', 'CP857', 'IBM857', 'CSIBM857', 'CP858', '860', 'CP860', 'IBM860', 'CSIBM860', '861', 'CP-IS', 'CP861', 'IBM861', 'CSIBM861', '863', 'CP863', 'IBM863', 'CSIBM863', 'CP864', 'IBM864', 'CSIBM864', '865', 'CP865', 'IBM865', 'CSIBM865', '869', 'CP-GR', 'CP869', 'IBM869', 'CSIBM869', 'CP1125', 'EUC-JISX0213', 'SHIFT_JISX0213', 'ISO-2022-JP-3', 'BIG5-2003', 'ISO-IR-230', 'TDS565', 'ATARI', 'ATARIST', 'RISCOS-LATIN1',]

Documentation des variables

◆ return

return[ 'ISO-8859-1', 'ISO-8859-2', 'ISO-8859-3', 'ISO-8859-4', 'ISO-8859-5', 'ISO-8859-6', 'ISO-8859-7', 'ISO-8859-8', 'ISO-8859-9', 'ISO-8859-10', 'ISO-8859-13', 'ISO-8859-14', 'ISO-8859-15', 'ISO-8859-16', 'WINDOWS-1251', 'WINDOWS-1252', 'WINDOWS-1254', 'CP932', 'CP936', 'CP950', 'CP866', 'CP850', 'CP51932', 'CP50220', 'CP50221', 'CP50222', 'ISO-2022-JP', 'ISO-2022-KR', 'JIS', 'JIS-ms', 'EUC-CN', 'EUC-JP', 'ANSI_X3.4-1968', 'ANSI_X3.4-1986', 'ASCII', 'CP367', 'IBM367', 'ISO-IR-6', 'ISO646-US', 'ISO_646.IRV:1991', 'US', 'US-ASCII', 'CSASCII', 'UTF-8', 'ISO-10646-UCS-2', 'UCS-2', 'CSUNICODE', 'UCS-2BE', 'UNICODE-1-1', 'UNICODEBIG', 'CSUNICODE11', 'UCS-2LE', 'UNICODELITTLE', 'ISO-10646-UCS-4', 'UCS-4', 'CSUCS4', 'UCS-4BE', 'UCS-4LE', 'UTF-16', 'UTF-16BE', 'UTF-16LE', 'UTF-32', 'UTF-32BE', 'UTF-32LE', 'UNICODE-1-1-UTF-7', 'UTF-7', 'CSUNICODE11UTF7', 'UCS-2-INTERNAL', 'UCS-2-SWAPPED', 'UCS-4-INTERNAL', 'UCS-4-SWAPPED', 'C99', 'JAVA', 'CP819', 'IBM819', 'ISO-IR-100', 'ISO8859-1', 'ISO_8859-1', 'ISO_8859-1:1987', 'L1', 'LATIN1', 'CSISOLATIN1', 'ISO-IR-101', 'ISO8859-2', 'ISO_8859-2', 'ISO_8859-2:1987', 'L2', 'LATIN2', 'CSISOLATIN2', 'ISO-IR-109', 'ISO8859-3', 'ISO_8859-3', 'ISO_8859-3:1988', 'L3', 'LATIN3', 'CSISOLATIN3', 'ISO-IR-110', 'ISO8859-4', 'ISO_8859-4', 'ISO_8859-4:1988', 'L4', 'LATIN4', 'CSISOLATIN4', 'CYRILLIC', 'ISO-IR-144', 'ISO8859-5', 'ISO_8859-5', 'ISO_8859-5:1988', 'CSISOLATINCYRILLIC', 'ARABIC', 'ASMO-708', 'ECMA-114', 'ISO-IR-127', 'ISO8859-6', 'ISO_8859-6', 'ISO_8859-6:1987', 'CSISOLATINARABIC', 'ECMA-118', 'ELOT_928', 'GREEK', 'GREEK8', 'ISO-IR-126', 'ISO8859-7', 'ISO_8859-7', 'ISO_8859-7:1987', 'ISO_8859-7:2003', 'CSISOLATINGREEK', 'HEBREW', 'ISO-IR-138', 'ISO8859-8', 'ISO_8859-8', 'ISO_8859-8:1988', 'CSISOLATINHEBREW', 'ISO-IR-148', 'ISO8859-9', 'ISO_8859-9', 'ISO_8859-9:1989', 'L5', 'LATIN5', 'CSISOLATIN5', 'ISO-IR-157', 'ISO8859-10', 'ISO_8859-10', 'ISO_8859-10:1992', 'L6', 'LATIN6', 'CSISOLATIN6', 'ISO-8859-11', 'ISO8859-11', 'ISO_8859-11', 'ISO-IR-179', 'ISO8859-13', 'ISO_8859-13', 'L7', 'LATIN7', 'ISO-CELTIC', 'ISO-IR-199', 'ISO8859-14', 'ISO_8859-14', 'ISO_8859-14:1998', 'L8', 'LATIN8', 'ISO-IR-203', 'ISO8859-15', 'ISO_8859-15', 'ISO_8859-15:1998', 'LATIN-9', 'ISO-IR-226', 'ISO8859-16', 'ISO_8859-16', 'ISO_8859-16:2001', 'L10', 'LATIN10', 'KOI8-R', 'CSKOI8R', 'KOI8-U', 'KOI8-RU', 'CP1250', 'MS-EE', 'WINDOWS-1250', 'CP1251', 'MS-CYRL', 'CP1252', 'MS-ANSI', 'CP1253', 'MS-GREEK', 'WINDOWS-1253', 'CP1254', 'MS-TURK', 'CP1255', 'MS-HEBR', 'WINDOWS-1255', 'CP1256', 'MS-ARAB', 'WINDOWS-1256', 'CP1257', 'WINBALTRIM', 'WINDOWS-1257', 'CP1258', 'WINDOWS-1258', '850', 'IBM850', 'CSPC850MULTILINGUAL', '862', 'CP862', 'IBM862', 'CSPC862LATINHEBREW', '866', 'IBM866', 'CSIBM866', 'MAC', 'MACINTOSH', 'MACROMAN', 'CSMACINTOSH', 'MACCENTRALEUROPE', 'MACICELAND', 'MACCROATIAN', 'MACROMANIA', 'MACCYRILLIC', 'MACUKRAINE', 'MACGREEK', 'MACTURKISH', 'MACHEBREW', 'MACARABIC', 'MACTHAI', 'HP-ROMAN8', 'R8', 'ROMAN8', 'CSHPROMAN8', 'NEXTSTEP', 'ARMSCII-8', 'GEORGIAN-ACADEMY', 'GEORGIAN-PS', 'KOI8-T', 'CP154', 'CYRILLIC-ASIAN', 'PT154', 'PTCP154', 'CSPTCP154', 'KZ-1048', 'RK1048', 'STRK1048-2002', 'CSKZ1048', 'MULELAO-1', 'CP1133', 'IBM-CP1133', 'ISO-IR-166', 'TIS-620', 'TIS620', 'TIS620-0', 'TIS620.2529-1', 'TIS620.2533-0', 'TIS620.2533-1', 'CP874', 'WINDOWS-874', 'VISCII', 'VISCII1.1-1', 'CSVISCII', 'TCVN', 'TCVN-5712', 'TCVN5712-1', 'TCVN5712-1:1993', 'ISO-IR-14', 'ISO646-JP', 'JIS_C6220-1969-RO', 'JP', 'CSISO14JISC6220RO', 'JISX0201-1976', 'JIS_X0201', 'X0201', 'CSHALFWIDTHKATAKANA', 'ISO-IR-87', 'JIS0208', 'JIS_C6226-1983', 'JIS_X0208', 'JIS_X0208-1983', 'JIS_X0208-1990', 'X0208', 'CSISO87JISX0208', 'ISO-IR-159', 'JIS_X0212', 'JIS_X0212-1990', 'JIS_X0212.1990-0', 'X0212', 'CSISO159JISX02121990', 'CN', 'GB_1988-80', 'ISO-IR-57', 'ISO646-CN', 'CSISO57GB1988', 'CHINESE', 'GB_2312-80', 'ISO-IR-58', 'CSISO58GB231280', 'CN-GB-ISOIR165', 'ISO-IR-165', 'ISO-IR-149', 'KOREAN', 'KSC_5601', 'KS_C_5601-1987', 'KS_C_5601-1989', 'CSKSC56011987', 'EUCJP', 'EXTENDED_UNIX_CODE_PACKED_FORMAT_FOR_JAPANESE', 'CSEUCPKDFMTJAPANESE', 'MS_KANJI', 'SHIFT-JIS', 'SHIFT_JIS', 'SJIS', 'CSSHIFTJIS', 'CSISO2022JP', 'ISO-2022-JP-1', 'ISO-2022-JP-2', 'CSISO2022JP2', 'CN-GB', 'EUCCN', 'GB2312', 'CSGB2312', 'GBK', 'MS936', 'WINDOWS-936', 'GB18030', 'ISO-2022-CN', 'CSISO2022CN', 'ISO-2022-CN-EXT', 'HZ', 'HZ-GB-2312', 'EUC-TW', 'EUCTW', 'CSEUCTW', 'BIG-5', 'BIG-FIVE', 'BIG5', 'BIGFIVE', 'CN-BIG5', 'CSBIG5', 'BIG5-HKSCS:1999', 'BIG5-HKSCS:2001', 'BIG5-HKSCS', 'BIG5-HKSCS:2004', 'BIG5HKSCS', 'EUC-KR', 'EUCKR', 'CSEUCKR', 'CP949', 'UHC', 'CP1361', 'JOHAB', 'CSISO2022KR', 'CP856', 'CP922', 'CP943', 'CP1046', 'CP1124', 'CP1129', 'CP1161', 'IBM-1161', 'IBM1161', 'CSIBM1161', 'CP1162', 'IBM-1162', 'IBM1162', 'CSIBM1162', 'CP1163', 'IBM-1163', 'IBM1163', 'CSIBM1163', 'DEC-KANJI', 'DEC-HANYU', '437', 'CP437', 'IBM437', 'CSPC8CODEPAGE437', 'CP737', 'CP775', 'IBM775', 'CSPC775BALTIC', '852', 'CP852', 'IBM852', 'CSPCP852', 'CP853', '855', 'CP855', 'IBM855', 'CSIBM855', '857', 'CP857', 'IBM857', 'CSIBM857', 'CP858', '860', 'CP860', 'IBM860', 'CSIBM860', '861', 'CP-IS', 'CP861', 'IBM861', 'CSIBM861', '863', 'CP863', 'IBM863', 'CSIBM863', 'CP864', 'IBM864', 'CSIBM864', '865', 'CP865', 'IBM865', 'CSIBM865', '869', 'CP-GR', 'CP869', 'IBM869', 'CSIBM869', 'CP1125', 'EUC-JISX0213', 'SHIFT_JISX0213', 'ISO-2022-JP-3', 'BIG5-2003', 'ISO-IR-230', 'TDS565', 'ATARI', 'ATARIST', 'RISCOS-LATIN1',]


Joomla CMS: Référence du fichier Encrypt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier Encrypt.php

Structures de données

class Encrypt

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Service


Joomla CMS: Référence du fichier EncryptedData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier EncryptedData.php

Structures de données

class EncryptedData

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier EncryptedPrivateKeyInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier EncryptedPrivateKeyInfo.php

Structures de données

class EncryptedPrivateKeyInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier EncryptionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier EncryptionException.php

Structures de données

class EncryptionException

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier endtab.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • tab
Espaces de nommage
Référence du fichier endtab.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier endtabset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • tab
Espaces de nommage
Référence du fichier endtabset.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier Engine.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier Engine.php

Structures de données

class Engine

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
Engine


Joomla CMS: Référence du fichier English.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier English.php

Structures de données

class English

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier EnglishInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier EnglishInflector.php

Structures de données

class EnglishInflector

Espaces de nommage

Symfony\Component\String\Inflector


Joomla CMS: Référence du fichier Entry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
Structures de données | Espaces de nommage
Référence du fichier Entry.php

Structures de données

class Entry

Espaces de nommage

Symfony\Component\Ldap


Joomla CMS: Référence du fichier EntryManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier EntryManager.php

Structures de données

class EntryManager

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier EntryManagerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier EntryManagerInterface.php

Structures de données

interface EntryManagerInterface

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier Enumerated.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier Enumerated.php

Structures de données

class Enumerated

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier EnumStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier EnumStub.php

Structures de données

class EnumStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier EnvironmentIsBrokenException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier EnvironmentIsBrokenException.php

Structures de données

class EnvironmentIsBrokenException

Espaces de nommage

Defuse\Crypto\Exception


Joomla CMS: Référence du fichier EpochTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier EpochTag.php

Structures de données

class EpochTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier EqualsRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier EqualsRule.php

Structures de données

class EqualsRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier EqualsTo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier EqualsTo.php

Structures de données

class EqualsTo

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier error.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Référence du fichier error.html.php


Joomla CMS: Référence du fichier error.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier administrator/templates/atum/error.php

Espaces de nommage

Joomla\Administrator

Variables

$user = Factory::getUser()
if($user->guest) else

Documentation des variables

◆ $user

$user = Factory::getUser()

◆ else

if ( $user->guest) else
Valeur initiale :
{
require __DIR__ . '/error_full.php'
__DIR__
defined('JPATH_PLATFORM') or define('JPATH_PLATFORM' __DIR__
Definition: bootstrap.php:14


Joomla CMS: Référence du fichier error.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • system
Espaces de nommage | Variables
Référence du fichier administrator/templates/system/error.php

Espaces de nommage

Joomla\Administrator

Variables

endif
$loop = $this->setError($this->_error->getPrevious())
endwhile

Documentation des variables

◆ $loop

$loop = $this->setError($this->_error->getPrevious())

Référencé par Iconv\iconv().

◆ endif

endif

◆ endwhile

endwhile


Joomla CMS: Référence du fichier error.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • template
Espaces de nommage | Variables
Référence du fichier installation/template/error.php

Espaces de nommage

Joomla\Installation

Variables

$loop = $this->setError($this->_error->getPrevious())
endwhile
endif

Documentation des variables

◆ $loop

$loop = $this->setError($this->_error->getPrevious())

◆ endif

endif

◆ endwhile

endwhile


Joomla CMS: Référence du fichier error.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
Espaces de nommage | Variables
Référence du fichier templates/cassiopeia/error.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$wa = $this->getWebAssetManager()
$option = $app->input->getCmd('option', '')
$view = $app->input->getCmd('view', '')
$layout = $app->input->getCmd('layout', '')
$task = $app->input->getCmd('task', '')
$itemid = $app->input->getCmd('Itemid', '')
$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')
$menu = $app->getMenu()->getActive()
$pageclass = $menu !== null ? $menu->getParams()->get('pageclass_sfx', '') : ''
$templatePath = 'media/templates/site/cassiopeia'
$paramsColorName = $this->params->get('colorName', 'colors_standard')
$assetColorName = 'theme.' . $paramsColorName
$paramsFontScheme = $this->params->get('useFontScheme', false)
$fontStyles = ''
if($paramsFontScheme) $wa | usePreset ( 'template.cassiopeia.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->useScript( 'template.user') ->addInlineStyle(":root
if($this->params->get('logoFile')) elseif($this->params->get('siteTitle')) | else
$wrapper = $this->params->get('fluidContainer') ? 'wrapper-fluid' : 'wrapper-static'
if ( $this->params->get( 'brand', 1))
endif
$loop = $this->setError($this->_error->getPrevious())
endwhile

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assetColorName

$assetColorName = 'theme.' . $paramsColorName

◆ $fontStyles

$fontStyles = ''

◆ $itemid

$itemid = $app->input->getCmd('Itemid', '')

◆ $layout

$layout = $app->input->getCmd('layout', '')

◆ $loop

$loop = $this->setError($this->_error->getPrevious())

◆ $menu

$menu = $app->getMenu()->getActive()

◆ $option

$option = $app->input->getCmd('option', '')

◆ $pageclass

$pageclass = $menu !== null ? $menu->getParams()->get('pageclass_sfx', '') : ''

◆ $paramsColorName

$paramsColorName = $this->params->get('colorName', 'colors_standard')

◆ $paramsFontScheme

$paramsFontScheme = $this->params->get('useFontScheme', false)

◆ $sitename

$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')

◆ $task

$task = $app->input->getCmd('task', '')

◆ $templatePath

$templatePath = 'media/templates/site/cassiopeia'

Référencé par ExceptionCaster\castFrameStub(), et ItemModel\preprocessForm().

◆ $view

$view = $app->input->getCmd('view', '')

◆ $wa

$wa = $this->getWebAssetManager()

◆ $wrapper

$wrapper = $this->params->get('fluidContainer') ? 'wrapper-fluid' : 'wrapper-static'

Référencé par Stream\addContextEntry(), Stream\deleteContextEntry(), et HtmlView\display().

◆ else

if ( $this->params->get( 'logoFile')) elseif ( $this->params->get( 'siteTitle')) else
Valeur initiale :
{
$logo = HTMLHelper::_('image', 'logo.svg', $sitename, ['class' => 'logo d-inline-block'], true, 0)
$sitename
$sitename
Definition: templates/cassiopeia/error.php:29

◆ endif

endif

◆ endwhile

endwhile

◆ if

if($this->params->get('brand', 1))

◆ usePreset

if ( $paramsFontScheme) $wa usePreset('template.cassiopeia.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->useScript('template.user') ->addInlineStyle(":root


Joomla CMS: Référence du fichier error.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Espaces de nommage | Variables
Référence du fichier templates/system/error.php

Espaces de nommage

Joomla\Site

Variables

endif
$loop = $this->setError($this->_error->getPrevious())
endwhile

Documentation des variables

◆ $loop

$loop = $this->setError($this->_error->getPrevious())

◆ endif

endif

◆ endwhile

endwhile


Joomla CMS: Référence du fichier error_full.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier error_full.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$input = $app->input
$wa = $this->getWebAssetManager()
$option = $input->get('option', '')
$view = $input->get('view', '')
$layout = $input->get('layout', 'default')
$task = $input->get('task', 'display')
$cpanel = $option === 'com_cpanel'
$hiddenMenu = $app->input->get('hidemainmenu')
$logoBrandLarge
$logoBrandSmall
$logoBrandLargeAlt
$logoBrandSmallAlt
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $cpanel

$cpanel = $option === 'com_cpanel'

◆ $hiddenMenu

$hiddenMenu = $app->input->get('hidemainmenu')

◆ $input

$input = $app->input

◆ $layout

$layout = $input->get('layout', 'default')

◆ $logoBrandLarge

$logoBrandLarge
Valeur initiale :
= $this->params->get('logoBrandLarge')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandLarge'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-large.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandLargeAlt

$logoBrandLargeAlt
Valeur initiale :
= empty($this->params->get('logoBrandLargeAlt')) && empty($this->params->get('emptyLogoBrandLargeAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandLargeAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandSmall

$logoBrandSmall
Valeur initiale :
= $this->params->get('logoBrandSmall')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandSmall'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-small.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandSmallAlt

$logoBrandSmallAlt
Valeur initiale :
= empty($this->params->get('logoBrandSmallAlt')) && empty($this->params->get('emptyLogoBrandSmallAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandSmallAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $option

$option = $input->get('option', '')

Référencé par CacheController\__construct(), Cache\__construct(), Color\__construct(), ColorStyle\__construct(), ComponentAdapter\_buildAdminMenus(), HtmlView\_setPath(), Stream\_stream_metadata(), ComponentAdapter\_updateMenus(), OptionsResolver\addAllowedTypes(), OptionsResolver\addAllowedValues(), ArrayInput\addLongOption(), ArgvInput\addLongOption(), OptionsResolver\addNormalizer(), InputDefinition\addOption(), InputDefinition\addOptions(), MenutypesModel\addReverseLookupUrl(), ASN1\asn1map(), FormController\batch(), FieldTable\bind(), CompletionInput\bind(), TextDescriptor\calculateTotalWidthForOptions(), CMSApplication\checkUserRequireReset(), CommandCompletionTester\complete(), DatabaseModel\createDatabase(), ModulesModel\createOption(), ModulesHelper\createOption(), Help\createSiteList(), OutputFormatter\createStyleFromString(), OptionConfigurator\define(), OptionsResolver\define(), MarkdownDescriptor\describeInputDefinition(), TextDescriptor\describeInputDefinition(), JsonDescriptor\describeInputOption(), TextDescriptor\describeInputOption(), MarkdownDescriptor\describeInputOption(), ApiDispatcher\dispatch(), ComponentDispatcher\dispatch(), HtmlView\display(), GetConfigurationCommand\doExecute(), Dropdown\edit(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), InputOption\equals(), TaskOptions\findOption(), OptionsResolver\formatOptions(), OptionsResolverIntrospector\getAllowedTypes(), OptionsResolverIntrospector\getAllowedValues(), ComponentHelper\getComponent(), ComponentModel\getComponent(), ApplicationHelper\getComponentName(), OptionsResolverIntrospector\getDefault(), OptionsResolverIntrospector\getDeprecation(), ComponentModel\getForm(), MenuField\getGroups(), GroupedlistField\getGroups(), UsersHelper\getGroups(), RemoveUserFromGroupCommand\getGroups(), OptionsResolver\getInfo(), JsonDescriptor\getInputDefinitionData(), XmlDescriptor\getInputDefinitionDocument(), JsonDescriptor\getInputOptionData(), XmlDescriptor\getInputOptionDocument(), OptionsResolverIntrospector\getLazyClosures(), LanguagesHelper\getList(), TagsSimilarHelper\getList(), ArticlesCategoryHelper\getList(), MemcachedCaster\getNonDefaultOptions(), OptionsResolverIntrospector\getNormalizers(), InstalledModel\getOption(), InputDefinition\getOptionDefaults(), FieldgroupsField\getOptions(), ComponentsCategoryField\getOptions(), MenuOrderingField\getOptions(), CategoryField\getOptions(), ContenttypeField\getOptions(), LanguageField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), TextField\getOptions(), FieldsListPlugin\getOptionsFromField(), PlgFieldsSubform\getOptionsFromField(), ComponentHelper\getParams(), SiteApplication\getParams(), ChecksModel\getPhpOptions(), UpdateModel\getPhpOptions(), ChecksModel\getPhpOptionsSufficient(), ModulesModel\getPositions(), ChangeUserPasswordCommand\getStringFromOption(), DeleteUserCommand\getStringFromOption(), AddUserCommand\getStringFromOption(), AddUserToGroupCommand\getStringFromOption(), RemoveUserFromGroupCommand\getStringFromOption(), ColorStyle\getStyle(), PlgFieldsSubform\getSubfieldsFromField(), InputDefinition\getSynopsis(), MenutypesModel\getTypeOptions(), RulesField\getUserGroups(), Workflow\getValidTransition(), OptionsResolver\hasDefault(), OptionsResolver\isDeprecated(), ComponentHelper\isEnabled(), ComponentHelper\isInstalled(), OptionsResolver\isMissing(), OptionsResolver\isNested(), OptionsResolver\isRequired(), ComponentModel\loadFormData(), OptionsResolver\offsetExists(), OptionsResolver\offsetGet(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSystemPrivacyconsent\onAfterRoute(), Joomla\onApplicationAfterSave(), Joomla\onContentAfterDelete(), Joomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), Joomla\onContentChangeState(), FieldsListPlugin\onCustomFieldsPrepareDom(), Joomla\onExtensionAfterSave(), ContentHelper\onPrepareForm(), PlgUserTerms\onUserBeforeSave(), PlgSystemPrivacyconsent\onUserBeforeSave(), PlgUserProfile\onUserBeforeSave(), ArgvInput\parseShortOptionSet(), Modules\positions(), TagField\prepareOptionsNested(), Menu\preprocess(), CssMenu\preprocess(), ItemModel\preprocessForm(), GetConfigurationCommand\processGroupOptions(), GetConfigurationCommand\processSingleOption(), OptionsResolver\remove(), OptionsResolver\resolve(), MenusController\resync(), SetConfigurationCommand\retrieveOptionsFromInput(), ItemModel\save(), Color\set(), OptionsResolver\setAllowedTypes(), OptionsResolver\setAllowedValues(), FileLayout\setComponent(), OptionsResolver\setDefault(), OptionsResolver\setDefaults(), OptionsResolver\setDefined(), OptionsResolver\setDeprecated(), OptionsResolver\setInfo(), OptionsResolver\setNormalizer(), OutputFormatterStyle\setOption(), OptionsResolver\setRequired(), PharStreamWrapper\stream_metadata(), PharStreamWrapper\stream_set_option(), CompletionSuggestions\suggestOption(), CompletionSuggestions\suggestOptions(), Color\unset(), OutputFormatterStyle\unsetOption(), FileLayout\validComponent(), et BashCompletionOutput\write().

◆ $task

string $task = $input->get('task', 'display')

Référencé par ExecRuleHelper\__construct(), JGrid\action(), ActionsDropdown\addCustomItem(), ToolbarHelper\addNew(), ActionButton\addState(), ToolbarHelper\apply(), ActionsDropdown\archive(), ToolbarHelper\archiveList(), ToolbarHelper\assign(), ToolbarHelper\cancel(), UsersController\changeBlock(), Dispatcher\checkAccess(), ToolbarHelper\checkin(), CMSApplication\checkUserRequireReset(), ToolbarHelper\custom(), ToolbarHelper\deleteList(), Dispatcher\dispatch(), ApiDispatcher\dispatch(), ComponentDispatcher\dispatch(), DisplayController\display(), TasksRunCommand\doExecute(), TasksListCommand\doExecute(), ActionsDropdown\duplicate(), ToolbarHelper\editCss(), ToolbarHelper\editHtml(), ToolbarHelper\editList(), CaptiveController\execute(), MethodsController\execute(), ApiController\execute(), MethodController\execute(), BaseController\execute(), InstallationApplication\executeController(), ActionsDropdown\feature(), ConfirmButton\fetchButton(), StandardButton\fetchButton(), PlgSystemTasknotification\getDataFromTask(), BaseController\getInstance(), MethodModel\getPageTitle(), TaskModel\getTask(), BaseController\getTask(), ToolbarHelper\makeDefault(), PlgSystemPrivacyconsent\onAfterRoute(), PlgSystemFields\onUserAfterSave(), Joomla\onUserAfterSave(), PlgUserTerms\onUserBeforeSave(), PlgSystemPrivacyconsent\onUserBeforeSave(), PlgUserProfile\onUserBeforeSave(), Pagination\orderDownIcon(), Pagination\orderUpIcon(), WorkflowController\postSaveHook(), ModuleController\postSaveHook(), ActionsDropdown\publish(), TemplateController\publish(), Dropdown\publish(), ItemsController\publish(), AdminController\publish(), ToolbarHelper\publish(), ToolbarHelper\publishList(), BaseController\registerTask(), PlgSystemSchedulerunner\runTestCron(), PlgSystemSchedulerunner\runWebCron(), OverrideController\save(), UserController\save(), FormController\save(), ToolbarHelper\save(), ToolbarHelper\save2copy(), ToolbarHelper\save2new(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), SearchTools\sort(), ActionsDropdown\trash(), ToolbarHelper\trash(), ActionsDropdown\unarchive(), ToolbarHelper\unarchiveList(), ActionsDropdown\unfeature(), ActionsDropdown\unpublish(), ToolbarHelper\unpublish(), ToolbarHelper\unpublishList(), et BaseController\unregisterTask().

◆ $view

$view = $input->get('view', '')

Référencé par RouteHelper\_findItem(), ViewController\_makeId(), Router\build(), NomenuRules\build(), StandardRules\build(), MenuRules\buildLookup(), DisplayController\canView(), Dispatcher\checkAccess(), CMSApplication\checkUserRequireReset(), MVCFactory\createView(), BaseController\createView(), DisplayController\display(), HtmlView\display(), MethodsController\display(), RouteHelper\findItem(), ViewController\get(), AssociationHelper\getAssociations(), AssociationsHelper\getAssociationsForItem(), SetupModel\getForm(), ChecksModel\getForm(), LanguagesModel\getForm(), ComponentlayoutField\getInput(), TagsSimilarHelper\getList(), ArticlesCategoryHelper\getList(), TemplateModel\getOverridesList(), RouterView\getPath(), RouteHelper\getRoute(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromMvc(), Adapter\getUrl(), DisplayController\getView(), BaseController\getView(), PlgSystemPrivacyconsent\onAfterRoute(), PlgContentPagenavigation\onContentBeforeDisplay(), PlgContentPagebreak\onContentPrepare(), StandardRules\parse(), NomenuRules\parse(), MenuRules\preprocess(), ItemModel\preprocessForm(), AdminModel\redirectToAssociations(), RouterView\registerView(), et SetupModel\validate().

◆ $wa

$wa = $this->getWebAssetManager()

◆ width

integer $previewWidth The image preview width =device-width

Référencé par FormatterHelper\formatBlock(), QuestionHelper\formatChoiceQuestionChoices(), EditorField\getInput(), MeterField\getLayoutData(), PlgButtonReadmore\onDisplay(), MeterField\setup(), EditorField\setup(), MediaField\setup(), Helper\strlen(), Helper\strlenWithoutDecoration(), et FormatterHelper\truncate().


Joomla CMS: Référence du fichier error_login.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier error_login.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$input = $app->input
$wa = $this->getWebAssetManager()
$option = $input->get('option', '')
$view = $input->get('view', '')
$layout = $input->get('layout', 'default')
$task = $input->get('task', 'display')
$logoBrandLarge
$loginLogo
$logoBrandSmall
$logoBrandLargeAlt
$logoBrandSmallAlt
$loginLogoAlt
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $input

$input = $app->input

◆ $layout

$layout = $input->get('layout', 'default')

◆ $loginLogo

$loginLogo
Valeur initiale :
= $this->params->get('loginLogo')
? Uri::root() . $this->params->get('loginLogo')
: Uri::root() . 'media/templates/administrator/atum/images/logos/login.svg'

◆ $loginLogoAlt

$loginLogoAlt
Valeur initiale :
= empty($this->params->get('loginLogoAlt')) && empty($this->params->get('emptyLoginLogoAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('loginLogoAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandLarge

$logoBrandLarge
Valeur initiale :
= $this->params->get('logoBrandLarge')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandLarge'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-large.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandLargeAlt

$logoBrandLargeAlt
Valeur initiale :
= empty($this->params->get('logoBrandLargeAlt')) && empty($this->params->get('emptyLogoBrandLargeAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandLargeAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandSmall

$logoBrandSmall
Valeur initiale :
= $this->params->get('logoBrandSmall')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandSmall'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-small.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandSmallAlt

$logoBrandSmallAlt
Valeur initiale :
= empty($this->params->get('logoBrandSmallAlt')) && empty($this->params->get('emptyLogoBrandSmallAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandSmallAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $option

$option = $input->get('option', '')

◆ $task

$task = $input->get('task', 'display')

◆ $view

$view = $input->get('view', '')

◆ $wa

$wa = $this->getWebAssetManager()

◆ width

$wa usePreset ( 'template.atum.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width


Joomla CMS: Référence du fichier ErrorDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier ErrorDocument.php

Structures de données

class ErrorDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier ErrorEnhancerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorEnhancer
Structures de données | Espaces de nommage
Référence du fichier ErrorEnhancerInterface.php

Structures de données

interface ErrorEnhancerInterface

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorEnhancer


Joomla CMS: Référence du fichier ErrorEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier ErrorEvent.php

Structures de données

class ErrorEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier ErrorHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Structures de données | Espaces de nommage
Référence du fichier symfony/error-handler/ErrorHandler.php

Structures de données

class ErrorHandler

Espaces de nommage

Symfony\Component\ErrorHandler


Joomla CMS: Référence du fichier ErrorHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier tobscure/json-api/src/ErrorHandler.php

Structures de données

class ErrorHandler

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier ErrorListener.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • EventListener
Structures de données | Espaces de nommage
Référence du fichier ErrorListener.php

Structures de données

class ErrorListener

Espaces de nommage

Symfony\Component\Console\EventListener


Joomla CMS: Référence du fichier ErrorRendererInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorRenderer
Structures de données | Espaces de nommage
Référence du fichier ErrorRendererInterface.php

Structures de données

interface ErrorRendererInterface

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorRenderer


Joomla CMS: Référence du fichier ES256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256.php

Structures de données

class ES256

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ES256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-ecdsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-ecdsa/ES256.php

Structures de données

class ES256

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier ES256K.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256K.php

Structures de données

class ES256K

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ES256K.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-experimental
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-experimental/ES256K.php

Structures de données

class ES256K

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier ES384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES384.php

Structures de données

class ES384

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ES384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-ecdsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-ecdsa/ES384.php

Structures de données

class ES384

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier ES512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES512.php

Structures de données

class ES512

Espaces de nommage

Cose\Algorithm\Signature\ECDSA


Joomla CMS: Référence du fichier ES512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-ecdsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-ecdsa/ES512.php

Structures de données

class ES512

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Escaper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier Escaper.php

Structures de données

class Escaper

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier EvalBarrett.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier BCMath/Reductions/EvalBarrett.php

Structures de données

class EvalBarrett

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath\Reductions
PHP


Joomla CMS: Référence du fichier EvalBarrett.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier PHP/Reductions/EvalBarrett.php

Structures de données

class EvalBarrett

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier Event.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier Event.php

Structures de données

class Event

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier EventAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Espaces de nommage | Fonctions | Variables
Référence du fichier EventAware.php

Espaces de nommage

Joomla\CMS\Application

Fonctions

getDispatcher ()
getLogger ()
registerEvent ($event, callable $handler)
triggerEvent ($eventName, $args=[])

Variables

trait EventAware


Joomla CMS: Référence du fichier EventAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier EventAwareInterface.php

Structures de données

interface EventAwareInterface

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier EventImmutable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier EventImmutable.php

Structures de données

class EventImmutable

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier EventInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier EventInterface.php

Structures de données

interface EventInterface

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier EventReturnAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier EventReturnAware.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier EvolvableLinkInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
  • src
Structures de données | Espaces de nommage
Référence du fichier EvolvableLinkInterface.php

Structures de données

interface EvolvableLinkInterface

Espaces de nommage

Psr\Link


Joomla CMS: Référence du fichier EvolvableLinkProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
  • src
Structures de données | Espaces de nommage
Référence du fichier EvolvableLinkProviderInterface.php

Structures de données

interface EvolvableLinkProviderInterface

Espaces de nommage

Psr\Link


Joomla CMS: Référence du fichier EvolvableLinkProviderTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier EvolvableLinkProviderTrait.php

Espaces de nommage

Fig\Link

Fonctions

withLink (LinkInterface $link)
withoutLink (LinkInterface $link)

Variables

trait EvolvableLinkProviderTrait


Joomla CMS: Référence du fichier EvolvableLinkTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Espaces de nommage | Variables
Référence du fichier EvolvableLinkTrait.php

Espaces de nommage

Fig\Link

Variables

trait EvolvableLinkTrait


Joomla CMS: Référence du fichier exception.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier exception.html.php

Variables

foreach (array_reverse( $exception->getAllPrevious(), true) as $index=> $previousException) = $this->abbrClass($exception->getClass())
$exceptionAsArray = $exception->toArray()
$exceptionWithUserCode = []
$exceptionAsArrayCount = count($exceptionAsArray)
$last = $exceptionAsArrayCount - 1

Documentation des variables

◆ $exceptionAsArray

$exceptionAsArray = $exception->toArray()

◆ $exceptionAsArrayCount

$exceptionAsArrayCount = count($exceptionAsArray)

◆ $exceptionWithUserCode

$exceptionWithUserCode = []

◆ $last

$last = $exceptionAsArrayCount - 1

Référencé par Stream\__call(), Symfony\Contracts\Service\createNotFoundException(), UndefinedFunctionErrorEnhancer\enhance(), UndefinedMethodErrorEnhancer\enhance(), IntegerField\getOptions(), PlgSystemStats\isUpdateRequired(), Ini\objectToString(), PlgSystemPrivacyconsent\onAfterRender(), PlgSystemActionLogs\onAfterRespond(), Core\pbkdf2(), Hash\pdf(), CssMenu\preprocess(), Zip\readZipInfo(), Table\renderRow(), WarningsModel\return_bytes(), X509\setAttribute(), et Encoding\trimTrailingWhitespace().

◆ foreach

foreach(array_reverse($exception->getAllPrevious(), true) as $index=> $previousException) = $this->abbrClass($exception->getClass())


Joomla CMS: Référence du fichier Exception.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Espaces de nommage
Référence du fichier lcobucci/jwt/src/Exception.php

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier Exception.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier phpmailer/phpmailer/src/Exception.php

Structures de données

class Exception

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier Exception.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier typo3/phar-stream-wrapper/src/Exception.php

Structures de données

class Exception

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier Exception.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Structures de données | Espaces de nommage
Référence du fichier willdurand/negotiation/src/Negotiation/Exception/Exception.php

Structures de données

interface Exception

Espaces de nommage

Negotiation\Exception


Joomla CMS: Référence du fichier exception_full.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier exception_full.html.php

Variables

if (class_exists(\Symfony\Component\HttpKernel\Kernel::class)) = $this->include('views/exception.html.php', $context)

Documentation des variables

◆ if

if(class_exists(\Symfony\Component\HttpKernel\Kernel::class)) = $this->include('views/exception.html.php', $context)


Joomla CMS: Référence du fichier ExceptionCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ExceptionCaster.php

Structures de données

class ExceptionCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier ExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ExceptionHandler.php

Structures de données

class ExceptionHandler

Espaces de nommage

Joomla\CMS\Exception


Joomla CMS: Référence du fichier ExceptionHandlerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
  • Handler
Structures de données | Espaces de nommage
Référence du fichier ExceptionHandlerInterface.php

Structures de données

interface ExceptionHandlerInterface

Espaces de nommage

Tobscure\JsonApi\Exception\Handler


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/ldap/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/options-resolver/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/string/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Symfony\Component\String\Exception


Joomla CMS: Référence du fichier ExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/yaml/Exception/ExceptionInterface.php

Structures de données

interface ExceptionInterface

Espaces de nommage

Symfony\Component\Yaml\Exception


Joomla CMS: Référence du fichier ExceptionsCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier ExceptionsCollector.php

Structures de données

class ExceptionsCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier ExecRuleHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ExecRuleHelper.php

Structures de données

class ExecRuleHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Helper


Joomla CMS: Référence du fichier ExecuteTaskEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier ExecuteTaskEvent.php

Structures de données

class ExecuteTaskEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Event


Joomla CMS: Référence du fichier ExecutionFailureException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ExecutionFailureException.php

Structures de données

class ExecutionFailureException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier ExecutionRuleField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ExecutionRuleField.php

Structures de données

class ExecutionRuleField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier ExecutionRulesRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ExecutionRulesRule.php

Structures de données

class ExecutionRulesRule

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Rule


Joomla CMS: Référence du fichier ExistsRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ExistsRule.php

Structures de données

class ExistsRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier ExplicitlyTaggedObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier ExplicitlyTaggedObject.php

Structures de données

class ExplicitlyTaggedObject

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier ExportCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier ExportCommand.php

Structures de données

class ExportCommand

Espaces de nommage

Joomla\Database\Command


Joomla CMS: Référence du fichier ExportModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ExportModel.php

Structures de données

class ExportModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier Extension.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier src/Table/Extension.php

Structures de données

class Extension

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier Extension.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Extension.php

Structures de données

class Extension

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ExtensionAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier ExtensionAdapter.php

Structures de données

class ExtensionAdapter

Espaces de nommage

Joomla\CMS\Updater\Adapter


Joomla CMS: Référence du fichier ExtensionAttribute.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ExtensionAttribute.php

Structures de données

class ExtensionAttribute

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ExtensionAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ExtensionAttributes.php

Structures de données

class ExtensionAttributes

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ExtensionDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier ExtensionDescriptor.php

Structures de données

class ExtensionDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier ExtensionDiscoverCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionDiscoverCommand.php

Structures de données

class ExtensionDiscoverCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ExtensionDiscoverInstallCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionDiscoverInstallCommand.php

Structures de données

class ExtensionDiscoverInstallCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ExtensionDiscoverListCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionDiscoverListCommand.php

Structures de données

class ExtensionDiscoverListCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ExtensionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ExtensionField.php

Structures de données

class ExtensionField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Field


Joomla CMS: Référence du fichier ExtensionHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ExtensionHelper.php

Structures de données

class ExtensionHelper

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier ExtensionInstallCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionInstallCommand.php

Structures de données

class ExtensionInstallCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ExtensionManagerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ExtensionManagerInterface.php

Structures de données

interface ExtensionManagerInterface

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier ExtensionManagerTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Espaces de nommage | Variables
Référence du fichier ExtensionManagerTrait.php

Espaces de nommage

Joomla\CMS\Extension

Variables

trait ExtensionManagerTrait


Joomla CMS: Référence du fichier ExtensionNamespaceMapper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Espaces de nommage
Référence du fichier ExtensionNamespaceMapper.php

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier ExtensionOutputChecker.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier ExtensionOutputChecker.php

Structures de données

interface ExtensionOutputChecker

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier ExtensionOutputCheckerHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier ExtensionOutputCheckerHandler.php

Structures de données

class ExtensionOutputCheckerHandler

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier ExtensionOutputError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Structures de données | Espaces de nommage
Référence du fichier ExtensionOutputError.php

Structures de données

class ExtensionOutputError

Espaces de nommage

Webauthn\AuthenticationExtensions


Joomla CMS: Référence du fichier ExtensionRemoveCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionRemoveCommand.php

Structures de données

class ExtensionRemoveCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier extensions.classmap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Référence du fichier extensions.classmap.php


Joomla CMS: Référence du fichier Extensions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Extensions.php

Structures de données

class Extensions

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ExtensionsListCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ExtensionsListCommand.php

Structures de données

class ExtensionsListCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ExtensionstatusField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ExtensionstatusField.php

Structures de données

class ExtensionstatusField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Field


Joomla CMS: Référence du fichier extensionupdate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • extensionupdate
Structures de données | Espaces de nommage
Référence du fichier extensionupdate.php

Structures de données

class PlgQuickiconExtensionupdate

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ExtKeyUsageSyntax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ExtKeyUsageSyntax.php

Structures de données

class ExtKeyUsageSyntax

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier extract-tentative-return-types.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • bin
Variables
Référence du fichier extract-tentative-return-types.php

Variables

echo;while(false !==$file=fgets(\STDIN)) { $code=file_get_contents(substr( $file, 0, -1)); if(!str_contains( $code, ' @tentative-return-type')) { continue; } $code=preg_split('{^\s *(?:(?:abstract)?class|interface|trait)([^\s]++)}m', $code, -1, \PREG_SPLIT_DELIM_CAPTURE); if(1===count( $code)) { continue; } for( $i=1;null !==$class=$code[ $i] ?? null;$i+=2) { $methods=$code[1+$i]; if(!str_contains( $methods, ' @tentative-return-type')) { continue; } echo " '$class' => n "; preg_replace_callback('{@tentative-return-type.*?[\function ([^(]++

Documentation des variables

◆ n

n


Joomla CMS: Référence du fichier extract.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
Structures de données | Espaces de nommage | Fonctions | Variables
Référence du fichier extract.php

Structures de données

class ZIPExtraction

Espaces de nommage

Joomla\Administrator

Fonctions

if(defined('_JOOMLA_UPDATE_TESTING')) clearFileInOPCache (string $file)
timingSafeEquals ($known, $user)
setLongTimeout ()
setHugeMemoryLimit ()

Variables

const | _JOOMLA_UPDATE 1
$retArray
$configuration = getConfiguration()
$enabled = !empty($configuration)
if($enabled) | if (! $enabled)

Documentation des fonctions

◆ clearFileInOPCache()

if (defined( '_JOOMLA_UPDATE_TESTING')) clearFileInOPCache ( string $file )

Invalidate a file in OPcache.

Only applies if the file has a .php extension.

Paramètres
string $file The filepath to clear from OPcache
Renvoie
boolean
Depuis
4.0.4

Références null.

Référencé par ZIPExtraction\processLastExtractedFile(), et ZIPExtraction\processTypeLink().

◆ setHugeMemoryLimit()

setHugeMemoryLimit ( )

Sets the memory limit to 1GiB

Renvoie
void
Depuis
4.2.0

◆ setLongTimeout()

setLongTimeout ( )

Sets the PHP timeout to 3600 seconds

Renvoie
void
Depuis
4.2.0

◆ timingSafeEquals()

timingSafeEquals | ( | $known,
 |  | $user
 | ) |

A timing safe equals comparison.

Uses the built-in hash_equals() method if it exists. It SHOULD exist, as it's available since PHP 5.6 whereas even Joomla 4.0 requires PHP 7.2 or later. If for any reason the built-in function is not available (for example, a host has disabled it because they do not understand the first thing about security) we will fall back to a safe, userland implementation.

Paramètres
string | $known | The known value to check against
string | $user | The user submitted value to check
Renvoie
boolean True if the two strings are identical.
Depuis
4.0.4
Voir également
http://blog.ircmaxell.com/2014/11/its-all-about-time.html

Références $i, $result, et $user.

Documentation des variables

◆ $configuration

$configuration = getConfiguration()

Référencé par behindproxy_postinstall_action(), SiteStatus\writeConfigFile(), et ApplicationModel\writeConfigFile().

◆ $enabled

$enabled = !empty($configuration)

Référencé par JGrid\action(), PlgExtensionJoomla\addUpdateSite(), TasksListCommand\doExecute(), UpdatesitesModel\getListQuery(), PlgSystemUpdatenotification\getSuperUsers(), InstallerHelper\getUpdateSitesInformation(), ModuleHelper\isAdminMultilang(), Multilanguage\isEnabled(), Microdata\isEnabled(), Associations\isEnabled(), CssMenu\load(), Token\onUserAuthenticate(), Pagination\orderDownIcon(), Pagination\orderUpIcon(), Banner\pinned(), OpenSSH\setBinaryOutput(), Cache\setCaching(), JavascriptRenderer\setEnableJqueryNoConflict(), JavascriptRenderer\setIncludeVendors(), PDOCollector\setRenderSqlWithParams(), DebugBar\setStackAlwaysUseSessionStorage(), JavascriptRenderer\setUseRequireJs(), SMTP\setVerp(), Updatesites\state(), Manage\state(), Modules\state(), et UpdateAdapter\toggleUpdateSite().

◆ $retArray

$retArray
Valeur initiale :
= [
'status' => true

◆ _JOOMLA_UPDATE

const _JOOMLA_UPDATE 1

Should you want to debug this file, please add a new line ABOVE this comment with the following contents (excluding the space star space at the start of this line):

define('_JOOMLA_UPDATE_DEBUG', 1);

This will do two things:

  • it will create the joomla_update.txt file in your site's temporary directory (default: tmp). This file contains a debug log, detailing everything extract.php is doing during the extraction of the Joomla update ZIP file.
  • It will prevent extract.php from being overwritten during the update with a new version. This is useful if you are testing any changes in extract.php you do not want accidentally overwritten, or if you are given a modified extract.php by a Joomla core contributor with changes which might fix your update problem.

◆ if

if ( $enabled) if(! $enabled)


Joomla CMS: Référence du fichier ExtractableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier ExtractableInterface.php

Structures de données

interface ExtractableInterface

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier Factory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier src/Document/Factory.php

Structures de données

class Factory

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier Factory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
Structures de données | Espaces de nommage
Référence du fichier src/Factory.php

Structures de données

class Factory

Espaces de nommage

Joomla\CMS


Joomla CMS: Référence du fichier Factory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/registry/src/Factory.php

Structures de données

class Factory

Espaces de nommage

Joomla\Registry


Joomla CMS: Référence du fichier Factory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier vendor/lcobucci/jwt/src/Claim/Factory.php

Structures de données

class Factory

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier FactoryCommandLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CommandLoader
Structures de données | Espaces de nommage
Référence du fichier FactoryCommandLoader.php

Structures de données

class FactoryCommandLoader

Espaces de nommage

Symfony\Component\Console\CommandLoader


Joomla CMS: Référence du fichier FactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier FactoryInterface.php

Structures de données

interface FactoryInterface

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier FallbackExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
  • Handler
Structures de données | Espaces de nommage
Référence du fichier FallbackExceptionHandler.php

Structures de données

class FallbackExceptionHandler

Espaces de nommage

Tobscure\JsonApi\Exception\Handler


Joomla CMS: Référence du fichier FallbackNodeProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Node
Structures de données | Espaces de nommage
Référence du fichier FallbackNodeProvider.php

Structures de données

class FallbackNodeProvider

Espaces de nommage

Ramsey\Uuid\Provider\Node


Joomla CMS: Référence du fichier FalseObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier FalseObject.php

Structures de données

class FalseObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier fatal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Espaces de nommage | Variables
Référence du fichier fatal.php

Espaces de nommage

Joomla\Site

Variables

$template = '{{statusCode_statusText}}'
if(file_exists(__DIR__ . '/fatal-error.html')) if (file_exists(__DIR__ . '/fatal-error.custom.php'))

Documentation des variables

◆ $template

$template = '{{statusCode_statusText}}'

◆ if

if (file_exists(__DIR__ . '/fatal-error.html')) if(file_exists(__DIR__ . '/fatal-error.custom.php'))

User supplied fatal error page.

Allow overriding Joomla supplied page to prevent changes being wiped on Joomla upgrade. We allow it to be a PHP file so that any post-processing, alerting etc can happen.


Joomla CMS: Référence du fichier FatalError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Structures de données | Espaces de nommage
Référence du fichier FatalError.php

Structures de données

class FatalError

Espaces de nommage

Symfony\Component\ErrorHandler\Error


Joomla CMS: Référence du fichier Fe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Fe.php

Structures de données

class Fe

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519


Joomla CMS: Référence du fichier Fe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
Structures de données
Référence du fichier src/Core/Curve25519/Fe.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Fe


Joomla CMS: Référence du fichier Fe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
Structures de données
Référence du fichier src/Core32/Curve25519/Fe.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Fe


Joomla CMS: Référence du fichier FeaturedButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Button
Structures de données | Espaces de nommage
Référence du fichier FeaturedButton.php

Structures de données

class FeaturedButton

Espaces de nommage

Joomla\CMS\Button


Joomla CMS: Référence du fichier FeaturedController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FeaturedController.php

Structures de données

class FeaturedController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Controller


Joomla CMS: Référence du fichier FeaturedModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/Model/FeaturedModel.php

Structures de données

class FeaturedModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Model


Joomla CMS: Référence du fichier FeaturedModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Model/FeaturedModel.php

Structures de données

class FeaturedModel

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Model


Joomla CMS: Référence du fichier FeaturedModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/FeaturedModel.php

Structures de données

class FeaturedModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier FeaturedTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier FeaturedTable.php

Structures de données

class FeaturedTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Table


Joomla CMS: Référence du fichier FeatureEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Event
  • Model
Structures de données | Espaces de nommage
Référence du fichier FeatureEvent.php

Structures de données

class FeatureEvent

Espaces de nommage

Joomla\Component\Content\Administrator\Event\Model


Joomla CMS: Référence du fichier FeatureModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FeatureModel.php

Structures de données

class FeatureModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Model


Joomla CMS: Référence du fichier FeatureSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier FeatureSet.php

Structures de données

class FeatureSet

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier featuring.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • featuring
Structures de données | Espaces de nommage
Référence du fichier featuring.php

Structures de données

class PlgWorkflowFeaturing

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Feed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier Feed.php

Structures de données

class Feed

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier FeedDocument.php

Structures de données

class FeedDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier FeedEnclosure.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedEnclosure.php

Structures de données

class FeedEnclosure

Espaces de nommage

Joomla\CMS\Document\Feed


Joomla CMS: Référence du fichier FeedEntry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedEntry.php

Structures de données

class FeedEntry

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedFactory.php

Structures de données

class FeedFactory

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/modules/mod_feed/src/Helper/FeedHelper.php

Structures de données

class FeedHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Feed\Administrator\Helper


Joomla CMS: Référence du fichier FeedHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier modules/mod_feed/src/Helper/FeedHelper.php

Structures de données

class FeedHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Feed\Site\Helper


Joomla CMS: Référence du fichier FeedImage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedImage.php

Structures de données

class FeedImage

Espaces de nommage

Joomla\CMS\Document\Feed


Joomla CMS: Référence du fichier FeedItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedItem.php

Structures de données

class FeedItem

Espaces de nommage

Joomla\CMS\Document\Feed


Joomla CMS: Référence du fichier FeedLink.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedLink.php

Structures de données

class FeedLink

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedParser.php

Structures de données

class FeedParser

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedPerson.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Structures de données | Espaces de nommage
Référence du fichier FeedPerson.php

Structures de données

class FeedPerson

Espaces de nommage

Joomla\CMS\Feed


Joomla CMS: Référence du fichier FeedRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier FeedRenderer.php

Structures de données

class FeedRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier FeedsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FeedsController.php

Structures de données

class FeedsController

Espaces de nommage

Joomla\API
Joomla\Component\Newsfeeds\Api\Controller


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/View/Category/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Category


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier com_content/src/View/Category/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Category


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Featured
Structures de données | Espaces de nommage
Référence du fichier com_content/src/View/Featured/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Featured


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • View
  • Search
Structures de données | Espaces de nommage
Référence du fichier com_finder/src/View/Search/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\View\Search


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tag
Structures de données | Espaces de nommage
Référence du fichier com_tags/src/View/Tag/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\View\Tag


Joomla CMS: Référence du fichier FeedView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tags
Structures de données | Espaces de nommage
Référence du fichier com_tags/src/View/Tags/FeedView.php

Structures de données

class FeedView

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\View\Tags


Joomla CMS: Référence du fichier FetchMediaItemEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier FetchMediaItemEvent.php

Structures de données

class FetchMediaItemEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier FetchMediaItemsEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier FetchMediaItemsEvent.php

Structures de données

class FetchMediaItemsEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier FetchMediaItemUrlEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier FetchMediaItemUrlEvent.php

Structures de données

class FetchMediaItemUrlEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier FetchMode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier FetchMode.php

Structures de données

class FetchMode

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier FetchOrientation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier FetchOrientation.php

Structures de données

class FetchOrientation

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier FiberCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier FiberCaster.php

Structures de données

class FiberCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier FidoU2FAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/FidoU2FAttestationStatementSupport.php

Structures de données

class FidoU2FAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier FidoU2FAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php

Structures de données

class FidoU2FAttestationStatementSupport

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn\Hotfix


Joomla CMS: Référence du fichier FidoU2FAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/system/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php

Structures de données

class FidoU2FAttestationStatementSupport

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\Hotfix


Joomla CMS: Référence du fichier Field.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Export
Structures de données | Espaces de nommage
Référence du fichier Field.php

Structures de données

class Field

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Export


Joomla CMS: Référence du fichier FieldcontextsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FieldcontextsField.php

Structures de données

class FieldcontextsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier FieldController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FieldController.php

Structures de données

class FieldController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Controller


Joomla CMS: Référence du fichier FieldElement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier FieldElement.php

Structures de données

class FieldElement

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier FieldFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier FieldFactory.php

Structures de données

class FieldFactory

Espaces de nommage

Cron


Joomla CMS: Référence du fichier FieldFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier FieldFactoryInterface.php

Structures de données

interface FieldFactoryInterface

Espaces de nommage

Cron


Joomla CMS: Référence du fichier FieldgroupsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FieldgroupsField.php

Structures de données

class FieldgroupsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier FieldID.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier FieldID.php

Structures de données

class FieldID

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier FieldInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier FieldInterface.php

Structures de données

interface FieldInterface

Espaces de nommage

Cron


Joomla CMS: Référence du fichier FieldLayoutField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FieldLayoutField.php

Structures de données

class FieldLayoutField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier FieldModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FieldModel.php

Structures de données

class FieldModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Model


Joomla CMS: Référence du fichier fields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/helpers/fields.php

Structures de données

class FieldsHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier fields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • fields
Structures de données | Espaces de nommage
Référence du fichier plugins/content/fields/fields.php

Structures de données

class PlgContentFields

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier fields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • fields
Structures de données | Espaces de nommage
Référence du fichier plugins/editors-xtd/fields/fields.php

Structures de données

class PlgButtonFields

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier fields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • fields
Structures de données | Espaces de nommage
Référence du fichier plugins/system/fields/fields.php

Structures de données

class PlgSystemFields

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier FieldsComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier FieldsComponent.php

Structures de données

class FieldsComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Extension


Joomla CMS: Référence du fichier FieldsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/Controller/FieldsController.php

Structures de données

class FieldsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Controller


Joomla CMS: Référence du fichier FieldsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_fields/src/Controller/FieldsController.php

Structures de données

class FieldsController

Espaces de nommage

Joomla\API
Joomla\Component\Fields\Api\Controller


Joomla CMS: Référence du fichier fieldset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier fieldset.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$form = $displayData->getForm()
$name = $displayData->get('fieldset')
$fieldSet = $form->getFieldset($name)
if(empty($fieldSet)) | $ignoreFields = $displayData->get('ignore_fields') ? : array()
$extraFields = $displayData->get('extra_fields') ? : array()
if(!empty($displayData->showOptions)|| $displayData->get('show_options', 1)) | else
$html [] = '<div class="hidden">'

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $extraFields

$extraFields = $displayData->get('extra_fields') ? : array()

◆ $fieldSet

$fieldSet = $form->getFieldset($name)

◆ $form

$form = $displayData->getForm()

◆ $html

foreach ( $fieldSet as $field) $html[] = '<div class="hidden">'

◆ $ignoreFields

if (empty( $fieldSet)) $ignoreFields = $displayData->get('ignore_fields') ? : array()

◆ $name

$name = $displayData->get('fieldset')

◆ else

if (!empty( $displayData->showOptions)||$displayData->get( 'show_options', 1)) else
Valeur initiale :
{
$html = array()
$html
$html[]
Definition: fieldset.php:49


Joomla CMS: Référence du fichier FieldsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier FieldsHelper.php

Structures de données

class FieldsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Helper


Joomla CMS: Référence du fichier FieldsListPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier FieldsListPlugin.php

Structures de données

class FieldsListPlugin

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Plugin


Joomla CMS: Référence du fichier FieldsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FieldsModel.php

Structures de données

class FieldsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Model


Joomla CMS: Référence du fichier FieldsPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier FieldsPlugin.php

Structures de données

class FieldsPlugin

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Plugin


Joomla CMS: Référence du fichier FieldsServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Fields
Structures de données | Espaces de nommage
Référence du fichier FieldsServiceInterface.php

Structures de données

interface FieldsServiceInterface

Espaces de nommage

Joomla\CMS\Fields


Joomla CMS: Référence du fichier FieldTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier FieldTable.php

Structures de données

class FieldTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Table


Joomla CMS: Référence du fichier File.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/File.php

Structures de données

class File

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier File.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/defuse/php-encryption/src/File.php

Structures de données

class File

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier File.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/File.php

Structures de données

class File

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier File.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
Structures de données | Espaces de nommage
Référence du fichier vendor/paragonie/sodium_compat/namespaced/File.php

Structures de données

class File

Espaces de nommage

ParagonIE\Sodium


Joomla CMS: Référence du fichier File.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Structures de données
Référence du fichier vendor/paragonie/sodium_compat/src/File.php

Structures de données

class ParagonIE_Sodium_File


Joomla CMS: Référence du fichier file.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier file.php

Espaces de nommage

Joomla\Site

Variables

$maxSize = HTMLHelper::_('number.bytes', Utility::getMaxUploadSize())

Documentation des variables

◆ $maxSize

$maxSize = HTMLHelper::_('number.bytes', Utility::getMaxUploadSize())


Joomla CMS: Référence du fichier FileAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier FileAdapter.php

Structures de données

class FileAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier FileCouldNotBeRead.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Key
Espaces de nommage
Référence du fichier FileCouldNotBeRead.php

Espaces de nommage

Lcobucci\JWT\Signer\Key


Joomla CMS: Référence du fichier FileExistsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier FileExistsException.php

Structures de données

class FileExistsException

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Exception


Joomla CMS: Référence du fichier FileField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier FileField.php

Structures de données

class FileField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier FileLayout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Layout
Structures de données | Espaces de nommage
Référence du fichier FileLayout.php

Structures de données

class FileLayout

Espaces de nommage

Joomla\CMS\Layout


Joomla CMS: Référence du fichier FilelistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier FilelistField.php

Structures de données

class FilelistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier FileModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FileModel.php

Structures de données

class FileModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Model


Joomla CMS: Référence du fichier FileNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Exception/FileNotFoundException.php

Structures de données

class FileNotFoundException

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Exception


Joomla CMS: Référence du fichier FileNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/phpseclib/phpseclib/phpseclib/Exception/FileNotFoundException.php

Structures de données

class FileNotFoundException

Espaces de nommage

FileNotFoundException
phpseclib3\Exception


Joomla CMS: Référence du fichier FilePathRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier FilePathRule.php

Structures de données

class FilePathRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier Files.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Structures de données | Espaces de nommage
Référence du fichier src/Input/Files.php

Structures de données

class Files

Espaces de nommage

Joomla\CMS\Input


Joomla CMS: Référence du fichier Files.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/input/src/Files.php

Structures de données

class Files

Espaces de nommage

Joomla\Input


Joomla CMS: Référence du fichier FileStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Cache/Storage/FileStorage.php

Structures de données

class FileStorage

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier FileStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/maximebf/debugbar/src/DebugBar/Storage/FileStorage.php

Structures de données

class FileStorage

Espaces de nommage

DebugBar\Storage


Joomla CMS: Référence du fichier FileStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • Storage
Structures de données | Espaces de nommage
Référence du fichier plugins/system/debug/src/Storage/FileStorage.php

Structures de données

class FileStorage

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\Storage


Joomla CMS: Référence du fichier FilesystemException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier FilesystemException.php

Structures de données

class FilesystemException

Espaces de nommage

Joomla\Filesystem\Exception


Joomla CMS: Référence du fichier FilesystemHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier FilesystemHandler.php

Structures de données

class FilesystemHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier FilesystemHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier FilesystemHelper.php

Structures de données

class FilesystemHelper

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier Filter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Filter.php

Structures de données

class Filter

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Service\HTML


Joomla CMS: Référence du fichier FilterController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FilterController.php

Structures de données

class FilterController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier FilterModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FilterModel.php

Structures de données

class FilterModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier filters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Espaces de nommage | Variables
Référence du fichier filters.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$filters = $data['view']->filterForm->getGroup('filter')
$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
$dataShowOn = " data-showon='" . json_encode(FormHelper::parseShowOnConditions($field->showon, $field->formControl, $field->group)) . "'"
endif
endforeach

Documentation des variables

◆ $data

$data = $displayData

◆ $dataShowOn

$dataShowOn = " data-showon='" . json_encode(FormHelper::parseShowOnConditions($field->showon, $field->formControl, $field->group)) . "'"

◆ $filters

$filters = $data['view']->filterForm->getGroup('filter')

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier FiltersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FiltersController.php

Structures de données

class FiltersController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier FiltersField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FiltersField.php

Structures de données

class FiltersField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Field


Joomla CMS: Référence du fichier FiltersModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier FiltersModel.php

Structures de données

class FiltersModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier FilterTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier FilterTable.php

Structures de données

class FilterTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Table


Joomla CMS: Référence du fichier finalisation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
Espaces de nommage
Référence du fichier finalisation.php

Espaces de nommage

Joomla\Administrator
Joomla\CMS\Filesystem
Joomla\CMS\Language


Joomla CMS: Référence du fichier finaliseconfirm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • update
Espaces de nommage | Variables
Référence du fichier finaliseconfirm.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()


Joomla CMS: Référence du fichier finder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • finder
Structures de données | Espaces de nommage
Référence du fichier content/finder/finder.php

Structures de données

class PlgContentFinder

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier finder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • finder
Structures de données | Espaces de nommage
Référence du fichier extension/finder/finder.php

Structures de données

class PlgExtensionFinder

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Finder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Finder.php

Structures de données

class Finder

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Service\HTML


Joomla CMS: Référence du fichier FinderComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier FinderComponent.php

Structures de données

class FinderComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Extension


Joomla CMS: Référence du fichier FinderHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Helper/FinderHelper.php

Structures de données

class FinderHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Helper


Joomla CMS: Référence du fichier FinderHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_finder/src/Helper/FinderHelper.php

Structures de données

class FinderHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Helper


Joomla CMS: Référence du fichier FinderHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier modules/mod_finder/src/Helper/FinderHelper.php

Structures de données

class FinderHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Finder\Site\Helper


Joomla CMS: Référence du fichier FinderIndexCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier FinderIndexCommand.php

Structures de données

class FinderIndexCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier Fingerprint.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Traits
Espaces de nommage
Référence du fichier Fingerprint.php

Espaces de nommage

Common
phpseclib3\Crypt\Common\Traits


Joomla CMS: Référence du fichier FiniteField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • Common
Structures de données | Espaces de nommage
Référence du fichier FiniteField.php

Structures de données

class FiniteField

Espaces de nommage

BigInteger
phpseclib3\Math\Common
Math


Joomla CMS: Référence du fichier Finnish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Finnish.php

Structures de données

class Finnish

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier firsttime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/methods/firsttime.php

Espaces de nommage

Joomla\Administrator

Variables

$headingLevel = 2

Documentation des variables

◆ $headingLevel

$headingLevel = 2


Joomla CMS: Référence du fichier firsttime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/methods/firsttime.php

Espaces de nommage

Joomla\Site

Variables

$headingLevel = 2

Documentation des variables

◆ $headingLevel

$headingLevel = 2


Joomla CMS: Référence du fichier Fixed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Fixed.php

Structures de données

class Fixed

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Fixed\Extension


Joomla CMS: Référence du fichier FixedTimeProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Time
Structures de données | Espaces de nommage
Référence du fichier FixedTimeProvider.php

Structures de données

class FixedTimeProvider

Espaces de nommage

Ramsey\Uuid\Provider\Time


Joomla CMS: Référence du fichier FlattenException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Exception
Structures de données | Espaces de nommage
Référence du fichier FlattenException.php

Structures de données

class FlattenException

Espaces de nommage

Symfony\Component\ErrorHandler\Exception


Joomla CMS: Référence du fichier Folder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/Folder.php

Structures de données

class Folder

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier Folder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Folder.php

Structures de données

class Folder

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier FolderField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FolderField.php

Structures de données

class FolderField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Field


Joomla CMS: Référence du fichier folderinstaller.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • folderinstaller
Structures de données | Espaces de nommage
Référence du fichier folderinstaller.php

Structures de données

class PlgInstallerFolderInstaller

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier FolderlistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier FolderlistField.php

Structures de données

class FolderlistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier FolderPathExistsRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier FolderPathExistsRule.php

Structures de données

class FolderPathExistsRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier FontsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier FontsField.php

Structures de données

class FontsField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\CodeMirror\Field


Joomla CMS: Référence du fichier footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Espaces de nommage
Référence du fichier footer.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier Form.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier Form/Form.php

Structures de données

class Form

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier Form.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier HTML/Helpers/Form.php

Structures de données

class Form

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Form.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/Form.php

Structures de données

class Form

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier FormatInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
Structures de données | Espaces de nommage
Référence du fichier FormatInterface.php

Structures de données

interface FormatInterface

Espaces de nommage

Joomla\Registry


Joomla CMS: Référence du fichier FormattedtextLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier FormattedtextLogger.php

Structures de données

class FormattedtextLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier FormatterHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier FormatterHelper.php

Structures de données

class FormatterHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier FormBehavior.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier FormBehavior.php

Structures de données

class FormBehavior

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier FormBehaviorTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Espaces de nommage | Fonctions | Variables
Référence du fichier FormBehaviorTrait.php

Espaces de nommage

Joomla\CMS\MVC\Model

Fonctions

loadForm ($name, $source=null, $options=array(), $clear=false, $xpath=null)
loadFormData ()
preprocessData ($context, &$data, $group='content')
preprocessForm (Form $form, $data, $group='content')
getFormFactory ()

Variables

trait FormBehaviorTrait


Joomla CMS: Référence du fichier FormController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Structures de données | Espaces de nommage
Référence du fichier FormController.php

Structures de données

class FormController

Espaces de nommage

Joomla\CMS\MVC\Controller


Joomla CMS: Référence du fichier FormFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormFactory.php

Structures de données

class FormFactory

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormFactoryAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormFactoryAwareInterface.php

Structures de données

interface FormFactoryAwareInterface

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormFactoryAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Espaces de nommage | Fonctions | Variables
Référence du fichier FormFactoryAwareTrait.php

Espaces de nommage

Joomla\CMS\Form

Fonctions

getFormFactory ()
setFormFactory (FormFactoryInterface $formFactory=null)

Variables

trait FormFactoryAwareTrait


Joomla CMS: Référence du fichier FormFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormFactoryInterface.php

Structures de données

interface FormFactoryInterface

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormField.php

Structures de données

class FormField

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormFilterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormFilterInterface.php

Structures de données

interface FormFilterInterface

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormHelper.php

Structures de données

class FormHelper

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Model/FormModel.php

Structures de données

class FormModel

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Model


Joomla CMS: Référence du fichier FormModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Model/FormModel.php

Structures de données

class FormModel

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Model


Joomla CMS: Référence du fichier FormModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Model/FormModel.php

Structures de données

class FormModel

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Model


Joomla CMS: Référence du fichier FormModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier libraries/src/MVC/Model/FormModel.php

Structures de données

class FormModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier FormModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier FormModelInterface.php

Structures de données

interface FormModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier FormRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Structures de données | Espaces de nommage
Référence du fichier FormRule.php

Structures de données

class FormRule

Espaces de nommage

Joomla\CMS\Form


Joomla CMS: Référence du fichier FormValidateAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Structures de données | Espaces de nommage
Référence du fichier FormValidateAssetItem.php

Structures de données

class FormValidateAssetItem

Espaces de nommage

Joomla\CMS\WebAsset\AssetItem


Joomla CMS: Référence du fichier FormView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier FormView.php

Structures de données

class FormView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier ForwardedValidator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Validator
Structures de données | Espaces de nommage
Référence du fichier ForwardedValidator.php

Structures de données

class ForwardedValidator

Espaces de nommage

Joomla\Session\Validator


Joomla CMS: Référence du fichier FrameStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier FrameStub.php

Structures de données

class FrameStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier framework.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • includes
Espaces de nommage | Variables
Référence du fichier administrator/includes/framework.php

Espaces de nommage

Joomla\Administrator

Variables

$config = new JConfig()
const | JDEBUG ($config->error_reporting) $config->debug
if(empty($config->log_deprecated)) | else

Documentation des variables

◆ $config

$config = new JConfig()

◆ else

if (JDEBUG||$config->error_reporting==='maximum') if (property_exists( $config, 'behind_loadbalancer') &&$config->behind_loadbalancer==1) else
Valeur initiale :
{
set_error_handler(['Joomla\CMS\Exception\ExceptionHandler', 'handleUserDeprecatedErrors'], E_USER_DEPRECATED)
set_error_handler
E_USER_DEPRECATED

Correctly set the allowing of IP Overrides if behind a trusted proxy/load balancer.

We need to do this as high up the stack as we can, as the default in is to $allowIpOverride = true which is the wrong default for a generic site NOT behind a trusted proxy/load balancer.

◆ JDEBUG

const JDEBUG( $config->error_reporting) $config->debug
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par InstallationApplication\__construct(), Webauthn\__construct(), CMSApplication\__construct(), BaseController\__construct(), Tag\ajaxfield(), LanguageHelper\branchSingular(), BaseController\checkEditId(), HtmlView\display(), ApiApplication\doExecute(), AdministratorApplication\doExecute(), SiteApplication\doExecute(), Access\getAssetRules(), TinymcebuilderField\getLayoutData(), ConsoleApplication\getLongVersion(), CliRenderer\getTrace(), ExceptionHandler\handleUserDeprecatedErrors(), BaseController\holdEditId(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\includeRelativeFiles(), HTMLHelper\includeRelativeFiles(), PlgSystemDebug\onAfterDisconnect(), PlgSystemDebug\onAfterRespond(), Cache\onAfterRoute(), PlgSystemDebug\onAjaxDebug(), PlgSystemDebug\onBeforeCompileHead(), PlgSystemDebug\onBeforeRespond(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Access\preloadComponents(), Access\preloadPermissions(), Query\processString(), ServiceProviderInterface\register(), Database\register(), BaseController\releaseEditId(), XmlRenderer\render(), JsonRenderer\render(), HtmlRenderer\render(), JsonapiRenderer\render(), OpensearchDocument\render(), CMSApplication\render(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), ModuleHelper\renderModule(), ModuleHelper\renderRawModule(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), et IndexerController\sendResponse().


Joomla CMS: Référence du fichier framework.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • includes
Espaces de nommage | Variables
Référence du fichier api/includes/framework.php

Espaces de nommage

Joomla\API

Variables

$config = new JConfig()
const | JDEBUG ($config->error_reporting) $config->debug
if(empty($config->log_deprecated)) | else

Documentation des variables

◆ $config

$config = new JConfig()

◆ else

if (JDEBUG||$config->error_reporting==='maximum') if (property_exists( $config, 'behind_loadbalancer') &&$config->behind_loadbalancer==1) else
Valeur initiale :
{
set_error_handler(['Joomla\CMS\Exception\ExceptionHandler', 'handleUserDeprecatedErrors'], E_USER_DEPRECATED)
set_error_handler
E_USER_DEPRECATED

Correctly set the allowing of IP Overrides if behind a trusted proxy/load balancer.

We need to do this as high up the stack as we can, as the default in is to $allowIpOverride = true which is the wrong default for a generic site NOT behind a trusted proxy/load balancer.

◆ JDEBUG

const JDEBUG( $config->error_reporting) $config->debug


Joomla CMS: Référence du fichier framework.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • includes
Espaces de nommage | Variables
Référence du fichier includes/framework.php

Espaces de nommage

Joomla\Site

Variables

$config = new JConfig()
switch($config->error_reporting) if(!defined('JDEBUG')) if(empty($config->log_deprecated)) else

Documentation des variables

◆ $config

$config = new JConfig()

◆ else

if (JDEBUG||$config->error_reporting==='maximum') if (property_exists( $config, 'behind_loadbalancer') &&$config->behind_loadbalancer==1) else
Valeur initiale :
{
set_error_handler(['Joomla\CMS\Exception\ExceptionHandler', 'handleUserDeprecatedErrors'], E_USER_DEPRECATED)
set_error_handler
E_USER_DEPRECATED

Correctly set the allowing of IP Overrides if behind a trusted proxy/load balancer.

We need to do this as high up the stack as we can, as the default in is to $allowIpOverride = true which is the wrong default for a generic site NOT behind a trusted proxy/load balancer.


Joomla CMS: Référence du fichier framework.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • includes
Espaces de nommage | Variables
Référence du fichier installation/includes/framework.php

Espaces de nommage

Joomla\Installation

Variables

const JDEBUG = false
if (file_exists(JPATH_CONFIGURATION . '/configuration.php') &&(filesize(JPATH_CONFIGURATION . '/configuration.php') > 10) &&!file_exists(JPATH_INSTALLATION . '/index.php'))

Documentation des variables

◆ if

if(file_exists(JPATH_CONFIGURATION . '/configuration.php') &&(filesize(JPATH_CONFIGURATION . '/configuration.php') > 10) &&!file_exists(JPATH_INSTALLATION . '/index.php'))

◆ JDEBUG

const JDEBUG = false


Joomla CMS: Référence du fichier French.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier French.php

Structures de données

class French

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier FrenchInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier FrenchInflector.php

Structures de données

class FrenchInflector

Espaces de nommage

Symfony\Component\String\Inflector


Joomla CMS: Référence du fichier from.big5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.big5.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp037.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp037.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp1006.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp1006.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp1026.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp1026.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp424.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp424.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp437.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp437.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp500.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp500.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp737.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp737.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp775.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp775.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp850.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp850.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp852.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp852.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp855.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp855.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp856.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp856.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp857.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp857.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp860.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp860.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp861.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp861.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp862.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp862.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp863.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp863.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp864.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp864.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp865.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp865.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp866.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp866.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp869.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp869.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp874.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp874.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp875.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp875.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp932.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp932.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp936.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp936.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp949.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp949.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.cp950.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.cp950.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-1.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-10.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-10.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-11.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-11.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-13.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-13.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-14.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-14.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-15.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-15.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-16.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-16.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-2.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-3.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-4.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-5.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-6.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-6.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-7.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-8.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.iso-8859-9.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.iso-8859-9.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.koi8-r.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.koi8-r.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.koi8-u.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.koi8-u.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.us-ascii.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.us-ascii.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1250.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1250.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1251.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1251.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1252.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1252.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1253.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1253.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1254.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1254.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1255.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1255.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1256.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1257.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1257.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier from.windows-1258.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Variables
Référence du fichier from.windows-1258.php

Variables

static $data
$result =& $data

Documentation des variables

◆ $data

$data
static

◆ $result

return $result =& $data


Joomla CMS: Référence du fichier FromPunycode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Punycode
Structures de données | Espaces de nommage
Référence du fichier FromPunycode.php

Structures de données

class FromPunycode

Espaces de nommage

Algo26\IdnaConvert\Punycode


Joomla CMS: Référence du fichier FromUtf8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • EncodingHelper
Structures de données | Espaces de nommage
Référence du fichier FromUtf8.php

Structures de données

class FromUtf8

Espaces de nommage

Algo26\IdnaConvert\EncodingHelper


Joomla CMS: Référence du fichier frontediting_modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier frontediting_modules.php

Espaces de nommage

Joomla\Site

Variables

$moduleHtml = &$displayData['moduleHtml']
$mod = $displayData['module']
$position = $displayData['position']
$menusEditing = $displayData['menusediting']
$parameters = ComponentHelper::getParams('com_modules')
$redirectUri = '&return=' . urlencode(base64_encode(Uri::getInstance()->toString()))
$target = '_blank'
$itemid = Factory::getApplication()->input->get('Itemid', '0', 'int')
$editUrl = Uri::base() . 'administrator/index.php?option=com_modules&task=module.edit&id=' . (int) $mod->id
if($parameters->get('redirect_edit', 'site')==='site') $count = 0

Documentation des variables

◆ $count

if ( $parameters->get( 'redirect_edit', 'site')==='site') $count = 0

◆ $editUrl

$editUrl = Uri::base() . 'administrator/index.php?option=com_modules&task=module.edit&id=' . (int) $mod->id

◆ $itemid

$itemid = Factory::getApplication()->input->get('Itemid', '0', 'int')

Référencé par CategoryModel\_buildContentOrderBy(), Menus\association(), SiteApplication\authorise(), SiteRouter\buildInit(), Versioning\delete(), Versioning\get(), ArticlesArchiveHelper\getList(), LanguagesHelper\getList(), UserController\menulogout(), ArchiveModel\populateState(), TagsModel\populateState(), TagModel\populateState(), et CategoryModel\populateState().

◆ $menusEditing

$menusEditing = $displayData['menusediting']

Référencé par ModulesRenderer\render().

◆ $mod

$mod = $displayData['module']

Référencé par PlgContentLoadmodule\_loadmod(), ANSI\appendString(), Strings\bin2bits(), Integer\getEncodedValue(), BcMathCalculator\modPow(), GmpCalculator\modPow(), NativeCalculator\modPow(), BigInteger\modPow(), BigInteger\powerMod(), ModulesRenderer\render(), et PHP\toString().

◆ $moduleHtml

$moduleHtml = &$displayData['moduleHtml']

◆ $parameters

$parameters = ComponentHelper::getParams('com_modules')

Référencé par BaseAccept\__construct(), Client\baseString(), BaseAccept\buildParametersString(), TPMAttestationStatementSupport\checkPubArea(), Client\createHeader(), PdoStatement\execute(), MysqliStatement\execute(), SqlsrvStatement\execute(), Client\generateAccessToken(), Assertion\generateMessage(), Client\generateRequestToken(), ArgsStub\getParameters(), BaseAccept\getParameters(), Propel2Collector\getStatements(), CMSApplication\logout(), Client\oauthRequest(), BaseAccept\parseParameters(), Client\signRequest(), et Client\toUrl().

◆ $position

$position = $displayData['position']
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par PhpToken\__construct(), RouteHelper\_findItem(), Nested\_getTreeRepositionData(), PlgContentLoadmodule\_load(), HTMLHelper\addFileToBuffer(), DisplayController\addModule(), ModuleModel\batchCopy(), ModuleModel\batchMove(), Router\build(), Table\calculateColumnsWidth(), Russian\checkGroup1(), HtmlView\display(), PHPMailer\encodeHeader(), PHPMailer\encodeQ(), Gzip\extract(), Table\fillCells(), ECSignature\fromAsn1(), MultibyteStringConverter\fromAsn1(), ModuleModel\generateNewTitle(), ModulesModel\getActivePositions(), FieldFactory\getField(), Gzip\getFilePosition(), WebAssetManager\getInlineRelation(), PositionsModel\getItems(), ConsentBoxField\getLabel(), FormField\getLabel(), ColorField\getLayoutData(), ModulesModel\getListQuery(), ModuleHelper\getModules(), ModulesHelper\getPositions(), ModulesModel\getPositions(), CronExpression\getRunDate(), PgsqlDriver\getStringPositionSql(), Tar\getTarInfo(), ModulesHelper\getTranslatedModulePosition(), MinutesField\increment(), HoursField\increment(), Stem\inR1(), Stem\inR2(), Stem\inRv(), FieldFactory\instantiateField(), Nested\move(), Nested\moveByReference(), DataSet\next(), DataSet\offsetUnset(), PlgContentLoadmodule\onContentPrepare(), ModuleController\orderPosition(), Modules\positions(), SqlsrvQuery\processLimit(), ECSignature\readAsn1Content(), MultibyteStringConverter\readAsn1Content(), ECSignature\readAsn1Integer(), MultibyteStringConverter\readAsn1Integer(), ModulesRenderer\render(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), SiteApplication\route(), CMSApplication\route(), Stem\rx(), Stem\search(), CronExpression\setExpression(), Nested\setLocation(), CronExpression\setPart(), Italian\step0(), Romanian\step0(), Spanish\step0(), English\step0(), Portuguese\step1(), German\step1(), Swedish\step1(), Danish\step1(), Finnish\step1(), Norwegian\step1(), Russian\step1(), French\step1(), Italian\step1(), Dutch\step1(), Spanish\step1(), Romanian\step1(), English\step1a(), English\step1b(), English\step1c(), German\step2(), Finnish\step2(), Dutch\step2(), Russian\step2(), Portuguese\step2(), Romanian\step2(), English\step2(), Italian\step2(), Spanish\step2a(), French\step2a(), Spanish\step2b(), French\step2b(), Danish\step3(), Swedish\step3(), Norwegian\step3(), German\step3(), Russian\step3(), Finnish\step3(), Romanian\step3(), Spanish\step3(), English\step3(), Dutch\step3a(), Dutch\step3b(), Russian\step4(), Portuguese\step4(), Finnish\step4(), Romanian\step4(), English\step4(), French\step4(), Finnish\step5(), English\step5(), Finnish\step6(), BufferStreamHandler\stream_tell(), et PhpToken\tokenize().

◆ $redirectUri

$redirectUri = '&return=' . urlencode(base64_encode(Uri::getInstance()->toString()))

Référencé par PlgSystemLanguageFilter\parseRule().

◆ $target

$target = '_blank'


Joomla CMS: Référence du fichier FrontendlanguageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier FrontendlanguageField.php

Structures de données

class FrontendlanguageField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier FtpClient.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Client
Structures de données | Espaces de nommage
Référence du fichier src/Client/FtpClient.php

Structures de données

class FtpClient

Espaces de nommage

Joomla\CMS\Client


Joomla CMS: Référence du fichier FtpClient.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Clients
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Clients/FtpClient.php

Structures de données

class FtpClient

Espaces de nommage

Joomla\Filesystem\Clients


Joomla CMS: Référence du fichier full_image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier full_image.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData->params
$images = json_decode($displayData->images)
if(empty($images->image_fulltext)) $imgclass = empty($images->float_fulltext) ? $params->get('float_fulltext') : $images->float_fulltext
$layoutAttr
endif

Documentation des variables

◆ $images

$images = json_decode($displayData->images)

◆ $imgclass

if (empty( $images->image_fulltext)) $imgclass = empty($images->float_fulltext) ? $params->get('float_fulltext') : $images->float_fulltext

◆ $layoutAttr

$layoutAttr
Valeur initiale :
= [
'src' => $images->image_fulltext
$images
$images
Definition: full_image.php:16

◆ $params

$params = $displayData->params

◆ endif

endif


Joomla CMS: Référence du fichier function.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • deprecation-contracts
Référence du fichier function.php


Joomla CMS: Référence du fichier functions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Espaces de nommage | Fonctions
Référence du fichier beberlei/assert/lib/Assert/functions.php

Espaces de nommage

Assert

Fonctions

that ($value, $defaultMessage=null, string $defaultPropertyPath=null)
thatAll ($values, $defaultMessage=null, string $defaultPropertyPath=null)
thatNullOr ($value, $defaultMessage=null, string $defaultPropertyPath=null)
lazy ()


Joomla CMS: Référence du fichier functions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Espaces de nommage | Fonctions
Référence du fichier ramsey/uuid/src/functions.php

Espaces de nommage

Ramsey\Uuid

Fonctions

v1 ($node=null, $clockSeq=null)
v3 ($ns, $name)
v4 ()
v5 ($ns, $name)


Joomla CMS: Référence du fichier functions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Resources
Espaces de nommage
Référence du fichier symfony/string/Resources/functions.php

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier GeneralizedTime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier GeneralizedTime.php

Structures de données

class GeneralizedTime

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier GeneralName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier GeneralName.php

Structures de données

class GeneralName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier GeneralNames.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier GeneralNames.php

Structures de données

class GeneralNames

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier GeneralString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier GeneralString.php

Structures de données

class GeneralString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier GeneralSubtree.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier GeneralSubtree.php

Structures de données

class GeneralSubtree

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier GeneralSubtrees.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier GeneralSubtrees.php

Structures de données

class GeneralSubtrees

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier generate_docs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • build
Variables
Référence du fichier generate_docs.php

Variables

$readmeGenerator = new \voku\PhpReadmeHelper\GenerateApi()
$readmeGenerator templateMethod
$readmeText

Documentation des variables

◆ $readmeGenerator

$readmeGenerator = new \voku\PhpReadmeHelper\GenerateApi()

◆ $readmeText

$readmeText
Valeur initiale :
= ($readmeGenerator)->generate(
__DIR__ . '/../src/voku/helper/ASCII.php',
__DIR__ . '/docs/base.md'
)
$readmeGenerator
$readmeGenerator
Definition: generate_docs.php:6
__DIR__
defined('JPATH_PLATFORM') or define('JPATH_PLATFORM' __DIR__
Definition: bootstrap.php:14

◆ templateMethod

$readmeGenerator templateMethod
Valeur initiale :
= <<<RAW
#### %name%
<a href="#voku-php-readme-class-methods">↑</a>
%description%
**Parameters:**
%params%
**Return:**
%return%
--------
RAW
description
$this description
Definition: default_permissions.php:17


Joomla CMS: Référence du fichier generate_max_key_length.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • build
Variables
Référence du fichier generate_max_key_length.php

Variables

$languages = \voku\helper\ASCII::getAllLanguages()
$languagesKeyLengths = []

Documentation des variables

◆ $languages

$languages = \voku\helper\ASCII::getAllLanguages()

Référencé par AdministratorService\association(), Menus\association(), LanguageHelper\branchLanguageTitle(), TemplateModel\copy(), CachingLanguageFactory\createLanguage(), LanguageAdapter\discover(), AssociationHelper\displayAssociations(), AdminLanguage\existing(), AssociationsHelper\getAssociationHtmlList(), MultilangstatusHelper\getContacts(), InstalledModel\getData(), Language\getInstance(), LoginHelper\getLanguageList(), LanguagesModel\getLanguages(), LanguagesHelper\getList(), MenusHelper\getMenuLinks(), MenusModel\getMissingModuleLanguages(), FrontendlanguageField\getOptions(), LanguageField\getOptions(), LanguageclientField\getOptions(), SiteApplication\getParams(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSampledataMultilang\onAjaxSampledataApplyStep1(), PlgSystemLanguagecode\onContentPrepareForm(), NewsfeedModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), AdminModel\redirectToAssociations(), ItemModel\setHome(), et ConfigurationModel\setup().

◆ $languagesKeyLengths

$languagesKeyLengths = []


Joomla CMS: Référence du fichier GenericDataException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier GenericDataException.php

Structures de données

class GenericDataException

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier GenericEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier GenericEvent.php

Structures de données

class GenericEvent

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier GenericLanguageInflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier GenericLanguageInflectorFactory.php

Structures de données

class GenericLanguageInflectorFactory

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier GenericLinkProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Structures de données | Espaces de nommage
Référence du fichier fig/link-util/src/GenericLinkProvider.php

Structures de données

class GenericLinkProvider

Espaces de nommage

Fig\Link


Joomla CMS: Référence du fichier GenericLinkProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
Structures de données | Espaces de nommage
Référence du fichier symfony/web-link/GenericLinkProvider.php

Structures de données

class GenericLinkProvider

Espaces de nommage

Symfony\Component\WebLink


Joomla CMS: Référence du fichier GenericObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier GenericObject.php

Structures de données

class GenericObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier GenericTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier GenericTag.php

Structures de données

class GenericTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier German.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier German.php

Structures de données

class German

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier GetConfigurationCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier GetConfigurationCommand.php

Structures de données

class GetConfigurationCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier GetIconEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • QuickIcon
Structures de données | Espaces de nommage
Référence du fichier GetIconEvent.php

Structures de données

class GetIconEvent

Espaces de nommage

Joomla\CMS\Event\QuickIcon


Joomla CMS: Référence du fichier GetMethod.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier GetMethod.php

Structures de données

class GetMethod

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier GetSetup.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier GetSetup.php

Structures de données

class GetSetup

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier GithubActionReporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CI
Structures de données | Espaces de nommage
Référence du fichier GithubActionReporter.php

Structures de données

class GithubActionReporter

Espaces de nommage

Symfony\Component\Console\CI


Joomla CMS: Référence du fichier global.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier global.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$form = $displayData->getForm()
$input = $app->input
$component = $input->getCmd('option', 'com_content')
if($component==='com_categories') | $saveHistory = ComponentHelper::getParams($component)->get('save_history', 0)
$fields
$hiddenFields = $displayData->get('hidden_fields') ?: array()
if(! $saveHistory) if(!Multilanguage::isEnabled()) | $html = array()
$html [] = '<fieldset class="form-vertical">'

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $component

$component = $input->getCmd('option', 'com_content')

◆ $fields

$fields
Valeur initiale :
= $displayData->get('fields') ?: array(
'transition',
array('parent', 'parent_id'),
array('published', 'state', 'enabled'),
array('category', 'catid'),
'featured',
'sticky',
'access',
'language',
'tags',
'note',
'version_note',
)
$displayData
$displayData
Definition: administrator/components/com_banners/tmpl/banners/emptystate.php:16

◆ $form

$form = $displayData->getForm()

◆ $hiddenFields

$hiddenFields = $displayData->get('hidden_fields') ?: array()

◆ $html [1/2]

if (! $saveHistory) if (!Multilanguage::isEnabled()) $html = array()

◆ $html [2/2]

foreach ( $fields as $field) $html[] = '<fieldset class="form-vertical">'

◆ $input

$input = $app->input

◆ $saveHistory

if ( $component==='com_categories') $saveHistory = ComponentHelper::getParams($component)->get('save_history', 0)


Joomla CMS: Référence du fichier GlobalFilters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier GlobalFilters.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Référence du fichier GMP.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier GMP.php

Structures de données

class GMP

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
GMP


Joomla CMS: Référence du fichier GmpCalculator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
  • Calculator
Structures de données | Espaces de nommage
Référence du fichier GmpCalculator.php

Structures de données

class GmpCalculator

Espaces de nommage

Brick\Math\Internal\Calculator


Joomla CMS: Référence du fichier GmpCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier GmpCaster.php

Structures de données

class GmpCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Grapheme.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-grapheme
Structures de données | Espaces de nommage | Variables
Référence du fichier Grapheme.php

Structures de données

class Grapheme

Espaces de nommage

Symfony\Polyfill\Intl\Grapheme

Variables

const SYMFONY_GRAPHEME_CLUSTER_RX ((float) \PCRE_VERSION < 10 ? (float) \PCRE_VERSION >= 8.32 : (float) \PCRE_VERSION >= 10.39) ? '\X' : Grapheme::GRAPHEME_CLUSTER_RX


Joomla CMS: Référence du fichier GraphicString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier GraphicString.php

Structures de données

class GraphicString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier Grayscale.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Grayscale.php

Structures de données

class Grayscale

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier GreaterOrEqualsTo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier GreaterOrEqualsTo.php

Structures de données

class GreaterOrEqualsTo

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier Grid.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Grid.php

Structures de données

class Grid

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier groupclose.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage
Référence du fichier groupclose.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier GroupController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/Controller/GroupController.php

Structures de données

class GroupController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Controller


Joomla CMS: Référence du fichier GroupController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_users/src/Controller/GroupController.php

Structures de données

class GroupController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier groupedlist-fancy-select.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier groupedlist-fancy-select.php

Espaces de nommage

Joomla\Site

Variables

$html = array()
$attr = ''
$attr2 = ''
if($required) if($readonly) else

Documentation des variables

◆ $attr

if ( $readonly||$disabled) $attr = ''

◆ $attr2

$attr2 = ''

◆ $html

$html = array()

◆ else

if ( $required) if ( $readonly) else
Valeur initiale :
{
$html[] = HTMLHelper::_(
'select.groupedlist',
$groups,
$name,
array(
'list.attr' => $attr, 'id' => $id, 'list.select' => $value, 'group.items' => null, 'option.key.toHtml' => false,
'option.text.toHtml' => false,
)
)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$value
$value
Definition: com_contact/layouts/field/render.php:21
$html
$html
Definition: groupedlist-fancy-select.php:50
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$attr
$attr
Definition: groupedlist-fancy-select.php:51
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80
$groups
$groups
Definition: administrator/components/com_users/tmpl/levels/default.php:85


Joomla CMS: Référence du fichier groupedlist.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier groupedlist.php

Espaces de nommage

Joomla\Site

Variables

$html = array()
$attr = ''
if($readonly) else

Documentation des variables

◆ $attr

if ( $readonly||$disabled) $attr = ''

◆ $html

$html = array()

◆ else

if ( $readonly) else
Valeur initiale :
{
$html[] = HTMLHelper::_(
'select.groupedlist',
$groups,
$name,
array(
'list.attr' => $attr, 'id' => $id, 'list.select' => $value, 'group.items' => null, 'option.key.toHtml' => false,
'option.text.toHtml' => false,
)
)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$value
$value
Definition: com_contact/layouts/field/render.php:21
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80
$groups
$groups
Definition: administrator/components/com_users/tmpl/levels/default.php:85
$html
$html
Definition: groupedlist.php:48
$attr
$attr
Definition: groupedlist.php:49


Joomla CMS: Référence du fichier GroupedlistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier GroupedlistField.php

Structures de données

class GroupedlistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier GroupModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/Model/GroupModel.php

Structures de données

class GroupModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Model


Joomla CMS: Référence du fichier GroupModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_users/src/Model/GroupModel.php

Structures de données

class GroupModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier groupopen.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage
Référence du fichier groupopen.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier GroupparentField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier GroupparentField.php

Structures de données

class GroupparentField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Field


Joomla CMS: Référence du fichier groupsclose.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage
Référence du fichier groupsclose.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier GroupsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/Controller/GroupsController.php

Structures de données

class GroupsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Controller


Joomla CMS: Référence du fichier GroupsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/GroupsController.php

Structures de données

class GroupsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier GroupsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_fields/src/Controller/GroupsController.php

Structures de données

class GroupsController

Espaces de nommage

Joomla\API
Joomla\Component\Fields\Api\Controller


Joomla CMS: Référence du fichier GroupsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_users/src/Controller/GroupsController.php

Structures de données

class GroupsController

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\Controller


Joomla CMS: Référence du fichier groupseparator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage
Référence du fichier groupseparator.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier GroupsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/Model/GroupsModel.php

Structures de données

class GroupsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Model


Joomla CMS: Référence du fichier GroupsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_users/src/Model/GroupsModel.php

Structures de données

class GroupsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier groupsopen.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage
Référence du fichier groupsopen.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier GroupTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier GroupTable.php

Structures de données

class GroupTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Table


Joomla CMS: Référence du fichier GuidStringCodec.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier GuidStringCodec.php

Structures de données

class GuidStringCodec

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier Gzip.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier Gzip.php

Structures de données

class Gzip

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier H.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/H.php

Structures de données

class H

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519


Joomla CMS: Référence du fichier H.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
Structures de données
Référence du fichier src/Core/Curve25519/H.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_H


Joomla CMS: Référence du fichier H.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
Structures de données
Référence du fichier src/Core32/Curve25519/H.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_H


Joomla CMS: Référence du fichier HalfPrecisionFloatObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier HalfPrecisionFloatObject.php

Structures de données

class HalfPrecisionFloatObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier HandlerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Password
Structures de données | Espaces de nommage
Référence du fichier authentication/src/Password/HandlerInterface.php

Structures de données

interface HandlerInterface

Espaces de nommage

Joomla\Authentication\Password


Joomla CMS: Référence du fichier HandlerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier session/src/HandlerInterface.php

Structures de données

interface HandlerInterface

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier Hash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/Hash.php

Structures de données

class Hash

Espaces de nommage

Hash
phpseclib3\Crypt


Joomla CMS: Référence du fichier Hash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-core/Util/Hash.php

Structures de données

class Hash

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier HashAlgorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier HashAlgorithm.php

Structures de données

class HashAlgorithm

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier HChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/HChaCha20.php

Structures de données

class HChaCha20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier HChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/HChaCha20.php

Structures de données

class ParagonIE_Sodium_Core_HChaCha20


Joomla CMS: Référence du fichier HChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/HChaCha20.php

Structures de données

class ParagonIE_Sodium_Core32_HChaCha20


Joomla CMS: Référence du fichier header-item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier header-item.php

Espaces de nommage

Joomla\Administrator

Variables

$module = $displayData['module']
if ((string) $module->content==='')

Documentation des variables

◆ $module

$module = $displayData['module']

◆ if

if((string) $module->content==='')


Joomla CMS: Référence du fichier header.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Espaces de nommage | Variables
Référence du fichier header.php

Espaces de nommage

Joomla\Site

Variables

if(isset($params['title'])) endif

Documentation des variables

◆ endif

endif


Joomla CMS: Référence du fichier HeaderSecurity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier HeaderSecurity.php

Structures de données

class HeaderSecurity

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier HeadertagField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier HeadertagField.php

Structures de données

class HeadertagField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier HeadRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier HeadRenderer.php

Structures de données

class HeadRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier Help.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Help
Structures de données | Espaces de nommage
Référence du fichier Help.php

Structures de données

class Help

Espaces de nommage

Joomla\CMS\Help


Joomla CMS: Référence du fichier HelpButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier HelpButton.php

Structures de données

class HelpButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier HelpCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Command/HelpCommand.php

Structures de données

class HelpCommand

Espaces de nommage

Joomla\Console\Command


Joomla CMS: Référence du fichier HelpCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Command/HelpCommand.php

Structures de données

class HelpCommand

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier Helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Helper.php

Structures de données

class Helper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier Helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/enshrined/svg-sanitize/src/Helper.php

Structures de données

class Helper

Espaces de nommage

enshrined\svgSanitize


Joomla CMS: Référence du fichier Helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/filesystem/src/Helper.php

Structures de données

class Helper

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier Helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/console/Helper/Helper.php

Structures de données

class Helper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier Helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/typo3/phar-stream-wrapper/src/Helper.php

Structures de données

class Helper

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier helper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier helper.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier HelperFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/HelperFactory.php

Structures de données

class HelperFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier HelperFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier Helper/HelperFactory.php

Structures de données

class HelperFactory

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier HelperFactoryAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier HelperFactoryAwareInterface.php

Structures de données

interface HelperFactoryAwareInterface

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier HelperFactoryAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Espaces de nommage | Fonctions | Variables
Référence du fichier HelperFactoryAwareTrait.php

Espaces de nommage

Joomla\CMS\Helper

Fonctions

getHelperFactory ()
setHelperFactory (HelperFactory $helperFactory)

Variables

trait HelperFactoryAwareTrait


Joomla CMS: Référence du fichier HelperFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier HelperFactoryInterface.php

Structures de données

interface HelperFactoryInterface

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier HelperInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier HelperInterface.php

Structures de données

interface HelperInterface

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier HelperSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier HelperSet.php

Structures de données

class HelperSet

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier HelpModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier HelpModel.php

Structures de données

class HelpModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Model


Joomla CMS: Référence du fichier Hex.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier Hex.php

Structures de données

class Hex

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier hidden.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier hidden.php

Espaces de nommage

Joomla\Site

Variables

$class = !empty($class) ? ' class="' . $class . '"' : ''
$disabled = $disabled ? ' disabled' : ''
$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''
$dataAttribute

Documentation des variables

◆ $class

$class = !empty($class) ? ' class="' . $class . '"' : ''

◆ $dataAttribute

$dataAttribute

◆ $disabled

$disabled = $disabled ? ' disabled' : ''

◆ $onchange

$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''


Joomla CMS: Référence du fichier HiddenField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier HiddenField.php

Structures de données

class HiddenField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier highlight.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • highlight
Structures de données | Espaces de nommage
Référence du fichier highlight.php

Structures de données

class PlgSystemHighlight

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier HistoryController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/Controller/HistoryController.php

Structures de données

class HistoryController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Controller


Joomla CMS: Référence du fichier HistoryController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_contenthistory/src/Controller/HistoryController.php

Structures de données

class HistoryController

Espaces de nommage

Joomla\API
Joomla\Component\Contenthistory\Api\Controller


Joomla CMS: Référence du fichier HistoryModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier HistoryModel.php

Structures de données

class HistoryModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Model


Joomla CMS: Référence du fichier hits.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage
Référence du fichier hits.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier HMAC.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-hmac
Structures de données | Espaces de nommage
Référence du fichier HMAC.php

Structures de données

class HMAC

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Hmac.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Signer/Hmac.php

Structures de données

class Hmac

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier Hmac.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Mac/Hmac.php

Structures de données

class Hmac

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier HoldInstructionCode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier HoldInstructionCode.php

Structures de données

class HoldInstructionCode

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier horizontal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • tmpl
Espaces de nommage | Variables
Référence du fichier horizontal.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()
endforeach

Documentation des variables

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ endforeach

endforeach


Joomla CMS: Référence du fichier HoursField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier HoursField.php

Structures de données

class HoursField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier HS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-experimental
Structures de données | Espaces de nommage
Référence du fichier HS1.php

Structures de données

class HS1

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier HS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Mac/HS256.php

Structures de données

class HS256

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier HS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-hmac
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-hmac/HS256.php

Structures de données

class HS256

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier HS256_64.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-experimental
Structures de données | Espaces de nommage
Référence du fichier HS256_64.php

Structures de données

class HS256_64

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier HS256Truncated64.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier HS256Truncated64.php

Structures de données

class HS256Truncated64

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier HS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Mac/HS384.php

Structures de données

class HS384

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier HS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-hmac
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-hmac/HS384.php

Structures de données

class HS384

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier HS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Mac/HS512.php

Structures de données

class HS512

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier HS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-hmac
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-hmac/HS512.php

Structures de données

class HS512

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier HSalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/HSalsa20.php

Structures de données

class HSalsa20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier HSalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/HSalsa20.php

Structures de données

class ParagonIE_Sodium_Core_HSalsa20


Joomla CMS: Référence du fichier HSalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/HSalsa20.php

Structures de données

class ParagonIE_Sodium_Core32_HSalsa20


Joomla CMS: Référence du fichier htaccesssvg.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier htaccesssvg.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_htaccesssvg_condition ()

Documentation des fonctions

◆ admin_postinstall_htaccesssvg_condition()

admin_postinstall_htaccesssvg_condition ( )

Notifies users of a change in the default .htaccess file regarding hardening against XSS in SVG's

This check returns true regardless of condition.

Renvoie
boolean
Depuis
3.9.21


Joomla CMS: Référence du fichier Html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Parser
Structures de données | Espaces de nommage
Référence du fichier Html.php

Structures de données

class Html

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer\Parser


Joomla CMS: Référence du fichier html5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier html5.php

Espaces de nommage

Joomla\Site

Variables

$module = $displayData['module']
$params = $displayData['params']
if((string) $module->content==='') | $moduleTag = htmlspecialchars($params->get('module_tag', 'div'), ENT_QUOTES, 'UTF-8')
$moduleAttribs = []
$moduleAttribs ['class'] = 'moduletable ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')
$bootstrapSize = (int) $params->get('bootstrap_size', 0)
$moduleAttribs ['class'] = $bootstrapSize !== 0 ? ' col-md-' . $bootstrapSize : ''
$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')
$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')
$headerAttribs = []
if($headerClass !=='') if($moduleTag !=='div') | $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'
if((bool) $module->showtitle) | endif

Documentation des variables

◆ $bootstrapSize

$bootstrapSize = (int) $params->get('bootstrap_size', 0)

◆ $header

if ( $headerClass !=='') if ( $moduleTag !=='div') $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'

Référencé par JWS\addSignature(), JWSBuilder\addSignature(), AndroidSafetyNetAttestationStatementSupport\checkGoogleApiResponse(), Client\createHeader(), PHPMailer\createHeader(), ParagonIE_Sodium_Compat\crypto_secretstream_xchacha20poly1305_init_pull(), Reader\determineFileTypeByHeader(), PHPMailer\DKIM_Add(), AbstractSerializer\filterHeader(), JWSBuilder\findSignatureAlgorithm(), AbstractNegotiator\getBest(), Nyholm\Psr7\getHeader(), Request\getHeader(), Laminas\Diactoros\getHeader(), Nyholm\Psr7\getHeaderLine(), MetadataStatementFetcher\getJwsPayload(), SqlField\getOptions(), AbstractNegotiator\getOrderedElements(), Cache\getWorkarounds(), Nyholm\Psr7\hasHeader(), Laminas\Diactoros\hasHeader(), PHPMailer\mailPassthru(), PHPMailer\mailSend(), Laminas\Diactoros\marshalUriFromSapi(), AbstractNegotiator\match(), Parser\parse(), Parser\parseHeader(), AbstractNegotiator\parseHeader(), Parser\parseSignature(), AbstractTransport\processHeaders(), JSONGeneralSerializer\processHeaders(), Table\render(), Curl\request(), Stream\request(), Socket\request(), Encoding\saveBytesToChecksummedAsciiSafeString(), ParagonIE_Sodium_Crypto32\secretstream_xchacha20poly1305_init_pull(), ParagonIE_Sodium_Crypto\secretstream_xchacha20poly1305_init_pull(), SSH2\send_binary_packet(), AbstractWebApplication\sendHeaders(), PHPMailer\sendmailSend(), JSONFlattenedSerializer\serialize(), AbstractSerializer\serializeHeaders(), HtmlDumper\setDumpHeader(), Nyholm\Psr7\setHeaders(), Laminas\Diactoros\setHeaders(), PlgSystemHttpHeaders\setStaticHeaders(), PHPMailer\smtpSend(), JSONFlattenedSerializer\unserialize(), JSONGeneralSerializer\unserialize(), Nyholm\Psr7\updateHostFromUri(), Nyholm\Psr7\validateAndTrimHeader(), Nyholm\Psr7\withAddedHeader(), Laminas\Diactoros\withAddedHeader(), Nyholm\Psr7\withHeader(), Laminas\Diactoros\withHeader(), Nyholm\Psr7\withoutHeader(), Laminas\Diactoros\withoutHeader(), et Laminas\Diactoros\withUri().

◆ $headerAttribs

$headerAttribs = []

◆ $headerClass

$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')

◆ $headerTag

$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')

◆ $module

$module = $displayData['module']

◆ $moduleAttribs [1/3]

$moduleAttribs = []

◆ $moduleAttribs [2/3]

$moduleAttribs[ 'class'] = 'moduletable ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')

◆ $moduleAttribs [3/3]

$moduleAttribs[ 'class'] = $bootstrapSize !== 0 ? ' col-md-' . $bootstrapSize : ''

◆ $moduleTag

if ((string) $module->content==='') $moduleTag = htmlspecialchars($params->get('module_tag', 'div'), ENT_QUOTES, 'UTF-8')

◆ $params

$params = $displayData['params']

◆ endif

if ((bool) $module->showtitle) endif


Joomla CMS: Référence du fichier HtmlDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier HtmlDescriptor.php

Structures de données

class HtmlDescriptor

Espaces de nommage

Symfony\Component\VarDumper\Command\Descriptor


Joomla CMS: Référence du fichier HtmlDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier HtmlDocument.php

Structures de données

class HtmlDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier HtmlDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage | Fonctions
Référence du fichier HtmlDumper.php

Structures de données

class HtmlDumper

Espaces de nommage

Symfony\Component\VarDumper\Dumper

Fonctions

esc (string $str)


Joomla CMS: Référence du fichier HtmlErrorRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorRenderer
Structures de données | Espaces de nommage
Référence du fichier HtmlErrorRenderer.php

Structures de données

class HtmlErrorRenderer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorRenderer


Joomla CMS: Référence du fichier HTMLHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
Structures de données | Espaces de nommage
Référence du fichier HTMLHelper.php

Structures de données

class HTMLHelper

Espaces de nommage

Joomla\CMS\HTML


Joomla CMS: Référence du fichier HTMLRegistry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier HTMLRegistry.php

Structures de données

class HTMLRegistry

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier HTMLRegistryAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
Espaces de nommage | Fonctions | Variables
Référence du fichier HTMLRegistryAwareTrait.php

Espaces de nommage

Joomla\CMS\HTML

Fonctions

getRegistry ()
setRegistry (Registry $registry=null)

Variables

trait HTMLRegistryAwareTrait


Joomla CMS: Référence du fichier HtmlRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier HtmlRenderer.php

Structures de données

class HtmlRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier HtmlResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier HtmlResponse.php

Structures de données

class HtmlResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • View
  • Actionlogs
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_actionlogs/src/View/Actionlogs/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\View\Actionlogs


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Help
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/View/Help/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\View\Help


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Sysinfo
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/View/Sysinfo/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\View\Sysinfo


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • View
  • Association
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_associations/src/View/Association/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\View\Association


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • View
  • Associations
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_associations/src/View/Associations/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\View\Associations


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Banner
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Banner/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Banner


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Banners
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Banners/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Banners


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Client
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Client/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Client


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Clients
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Clients/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Clients


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Download
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Download/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Download


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Tracks
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/src/View/Tracks/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Tracks


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • View
  • Cache
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cache/src/View/Cache/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cache\Administrator\View\Cache


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • View
  • Categories
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/View/Categories/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\View\Categories


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/src/View/Category/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Categories\Administrator\View\Category


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • View
  • Checkin
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_checkin/src/View/Checkin/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Checkin\Administrator\View\Checkin


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • View
  • Application
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/View/Application/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\View\Application


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • View
  • Component
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/View/Component/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\View\Component


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • View
  • Contact
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/src/View/Contact/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\View\Contact


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • View
  • Contacts
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/src/View/Contacts/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contact\Administrator\View\Contacts


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Article
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/View/Article/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\View\Article


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Articles
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/View/Articles/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\View\Articles


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Featured
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/src/View/Featured/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\View\Featured


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • Compare
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/View/Compare/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\View\Compare


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • History
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/View/History/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\View\History


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • Preview
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/src/View/Preview/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\View\Preview


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • View
  • Cpanel
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cpanel/src/View/Cpanel/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Cpanel\Administrator\View\Cpanel


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Field
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/View/Field/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\View\Field


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Fields
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/View/Fields/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\View\Fields


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Group
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/View/Group/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\View\Group


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Groups
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/src/View/Groups/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\View\Groups


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Filter
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Filter/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Filter


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Filters
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Filters/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Filters


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Index
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Index/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Index


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Indexer/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Indexer


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Maps
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Maps/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Maps


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Searches
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Searches/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Searches


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Statistics
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/View/Statistics/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\View\Statistics


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Database
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Database/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Database


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Discover
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Discover/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Discover


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Install
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Install/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Install


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Installer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Installer/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Installer


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Languages
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Languages/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Languages


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Manage
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Manage/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Manage


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Update
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Update/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Update


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Updatesite
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Updatesite/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Updatesite


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Updatesites
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Updatesites/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Updatesites


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Warnings
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/View/Warnings/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\View\Warnings


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Joomlaupdate
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/src/View/Joomlaupdate/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\View\Joomlaupdate


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Update
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/src/View/Update/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\View\Update


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Upload
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/src/View/Upload/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\View\Upload


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Installed
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Installed/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Installed


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Language
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Language/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Language


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Languages
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Languages/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Languages


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Multilangstatus
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Multilangstatus/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Multilangstatus


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Override
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Override/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Override


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Overrides
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/View/Overrides/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\View\Overrides


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • View
  • Login
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_login/src/View/Login/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Login\Administrator\View\Login


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • View
  • Template
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_mails/src/View/Template/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\View\Template


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • View
  • Templates
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_mails/src/View/Templates/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\View\Templates


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • View
  • File
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/View/File/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\View\File


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • View
  • Media
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/View/Media/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\View\Media


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Item
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/View/Item/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Item


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Items
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/View/Items/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Items


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menu
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/View/Menu/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Menu


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menus
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/View/Menus/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Menus


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menutypes
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/View/Menutypes/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Menutypes


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Config
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/View/Config/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\View\Config


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Message
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/View/Message/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\View\Message


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Messages
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/View/Messages/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\View\Messages


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Module
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/View/Module/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\View\Module


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Modules
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/View/Modules/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\View\Modules


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Select
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/View/Select/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\View\Select


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeed
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/src/View/Newsfeed/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\View\Newsfeed


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeeds
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/src/View/Newsfeeds/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\View\Newsfeeds


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • View
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/src/View/Plugin/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\View\Plugin


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • View
  • Plugins
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/src/View/Plugins/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\View\Plugins


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • View
  • Messages
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_postinstall/src/View/Messages/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Postinstall\Administrator\View\Messages


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Capabilities
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/View/Capabilities/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\View\Capabilities


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Consents
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/View/Consents/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\View\Consents


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Request
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/View/Request/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\View\Request


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Requests
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/View/Requests/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\View\Requests


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • View
  • Link
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_redirect/src/View/Link/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\View\Link


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • View
  • Links
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_redirect/src/View/Links/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\View\Links


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Select
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_scheduler/src/View/Select/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\View\Select


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Task
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_scheduler/src/View/Task/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\View\Task


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Tasks
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_scheduler/src/View/Tasks/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\View\Tasks


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • View
  • Tag
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/View/Tag/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\View\Tag


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • View
  • Tags
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/View/Tags/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\View\Tags


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Style
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/View/Style/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\View\Style


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Styles
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/View/Styles/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\View\Styles


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Template
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/View/Template/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\View\Template


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Templates
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/View/Templates/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\View\Templates


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Captive
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Captive/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Captive


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Debuggroup
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Debuggroup/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Debuggroup


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Debuguser
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Debuguser/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Debuguser


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Group
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Group/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Group


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Groups
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Groups/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Groups


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Level
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Level/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Level


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Levels
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Levels/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Levels


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Mail
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Mail/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Mail


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Method
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Method/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Method


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Methods
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Methods/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Methods


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Note
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Note/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Note


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Notes
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Notes/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Notes


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • User
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/User/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\User


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Users
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/View/Users/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View\Users


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Stage
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Stage/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Stage


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Stages
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Stages/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Stages


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Transition
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Transition/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Transition


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Transitions
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Transitions/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Transitions


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Workflow/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Workflow


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Workflows
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/src/View/Workflows/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\View\Workflows


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Config
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/View/Config/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\View\Config


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Modules
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/View/Modules/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\View\Modules


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Templates
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/View/Templates/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\View\Templates


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Categories
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/View/Categories/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Categories


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/View/Category/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Category


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Contact
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/View/Contact/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Contact


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Featured
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/View/Featured/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Featured


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Form
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/View/Form/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Form


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Archive
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Archive/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Archive


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Article
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Article/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Article


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Categories
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Categories/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Categories


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Category/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Category


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Featured
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Featured/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Featured


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Form
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/View/Form/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\View\Form


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • View
  • Search
Structures de données | Espaces de nommage
Référence du fichier components/com_finder/src/View/Search/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\View\Search


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Categories
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/View/Categories/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\View\Categories


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Category
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/View/Category/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\View\Category


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeed
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/View/Newsfeed/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\View\Newsfeed


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Confirm
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/View/Confirm/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\View\Confirm


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Remind
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/View/Remind/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\View\Remind


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Request
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/View/Request/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\View\Request


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tag
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/View/Tag/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\View\Tag


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tags
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/View/Tags/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\View\Tags


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Captive
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Captive/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\View\Captive


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Login
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Login/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\View\Login


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Method
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Method/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\View\Method


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Methods
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Methods/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\View\Methods


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Profile
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Profile/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\View\Profile


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Registration
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Registration/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\View\Registration


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Remind
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Remind/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\View\Remind


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Reset
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/View/Reset/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\View\Reset


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • View
  • Wrapper
Structures de données | Espaces de nommage
Référence du fichier components/com_wrapper/src/View/Wrapper/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Site
Joomla\Component\Wrapper\Site\View\Wrapper


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Error
Structures de données | Espaces de nommage
Référence du fichier installation/src/View/Error/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\View\Error


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Preinstall
Structures de données | Espaces de nommage
Référence du fichier installation/src/View/Preinstall/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\View\Preinstall


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Remove
Structures de données | Espaces de nommage
Référence du fichier installation/src/View/Remove/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\View\Remove


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Setup
Structures de données | Espaces de nommage
Référence du fichier installation/src/View/Setup/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\View\Setup


Joomla CMS: Référence du fichier HtmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier libraries/src/MVC/View/HtmlView.php

Structures de données

class HtmlView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier Http.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
Structures de données | Espaces de nommage
Référence du fichier src/Http/Http.php

Structures de données

class Http

Espaces de nommage

Joomla\CMS\Http


Joomla CMS: Référence du fichier Http.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/http/src/Http.php

Structures de données

class Http

Espaces de nommage

Joomla\Http


Joomla CMS: Référence du fichier http_build_url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • jakeasmith
  • http_build_url
  • src
Référence du fichier http_build_url.php


Joomla CMS: Référence du fichier HttpBridgePostRequestMethod.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Captcha
  • Google
Structures de données | Espaces de nommage
Référence du fichier HttpBridgePostRequestMethod.php

Structures de données

class HttpBridgePostRequestMethod

Espaces de nommage

Joomla\CMS\Captcha\Google


Joomla CMS: Référence du fichier HttpDriverInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier HttpDriverInterface.php

Structures de données

interface HttpDriverInterface

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier HttpFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
Structures de données | Espaces de nommage
Référence du fichier src/Http/HttpFactory.php

Structures de données

class HttpFactory

Espaces de nommage

Joomla\CMS\Http


Joomla CMS: Référence du fichier HttpFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/http/src/HttpFactory.php

Structures de données

class HttpFactory

Espaces de nommage

Joomla\Http


Joomla CMS: Référence du fichier httpheaders.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • httpheaders
Structures de données | Espaces de nommage
Référence du fichier httpheaders.php

Structures de données

class PlgSystemHttpHeaders

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier HttpHeaderSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
Structures de données | Espaces de nommage
Référence du fichier HttpHeaderSerializer.php

Structures de données

class HttpHeaderSerializer

Espaces de nommage

Symfony\Component\WebLink


Joomla CMS: Référence du fichier HttplugFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
  • Factory
Structures de données | Espaces de nommage
Référence du fichier HttplugFactory.php

Structures de données

class HttplugFactory

Espaces de nommage

Nyholm\Psr7\Factory


Joomla CMS: Référence du fichier IA5String.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier IA5String.php

Structures de données

class IA5String

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier icon.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • helpers
Structures de données | Espaces de nommage
Référence du fichier components/com_content/helpers/icon.php

Structures de données

class JHtmlIcon

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier icon.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • quickicons
Espaces de nommage | Variables
Référence du fichier layouts/joomla/quickicons/icon.php

Espaces de nommage

Joomla\Site

Variables

$id = empty($displayData['id']) ? '' : (' id="' . $displayData['id'] . '"')
$target = empty($displayData['target']) ? '' : (' target="' . $displayData['target'] . '"')
$onclick = empty($displayData['onclick']) ? '' : (' onclick="' . $displayData['onclick'] . '"')
if(isset($displayData['ajaxurl'])) | else
$title = empty($displayData['title']) ? '' : (' title="' . $this->escape($displayData['title']) . '"')
$text = empty($displayData['text']) ? '' : ('<span class="j-links-link">' . $displayData['text'] . '</span>')
$class = empty($displayData['class']) ? '' : (' class="' . $this->escape($displayData['class']) . '"')
if (isset( $displayData[ 'linkadd']))
if(isset($displayData['image'])) | endif

Documentation des variables

◆ $class

$class = empty($displayData['class']) ? '' : (' class="' . $this->escape($displayData['class']) . '"')

◆ $id

$id = empty($displayData['id']) ? '' : (' id="' . $displayData['id'] . '"')

◆ $onclick

$onclick = empty($displayData['onclick']) ? '' : (' onclick="' . $displayData['onclick'] . '"')

◆ $target

$target = empty($displayData['target']) ? '' : (' target="' . $displayData['target'] . '"')

◆ $text

$text = empty($displayData['text']) ? '' : ('<span class="j-links-link">' . $displayData['text'] . '</span>')

◆ $title

$title = empty($displayData['title']) ? '' : (' title="' . $this->escape($displayData['title']) . '"')

◆ else

if (isset( $displayData[ 'ajaxurl'])) else
Valeur initiale :
{
$dataUrl = ''

◆ endif

if (isset( $displayData[ 'image'])) endif

◆ if

if(isset($displayData['linkadd']))


Joomla CMS: Référence du fichier Icon.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/Service/HTML/Icon.php

Structures de données

class Icon

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Administrator\Service\HTML


Joomla CMS: Référence du fichier Icon.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier com_content/src/Service/HTML/Icon.php

Structures de données

class Icon

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Service\HTML


Joomla CMS: Référence du fichier iconclass.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • button
Espaces de nommage | Variables
Référence du fichier button/iconclass.php

Espaces de nommage

Joomla\Site

Variables

$displayData ['html'] = false

Documentation des variables

◆ $displayData

$displayData[ 'html'] = false


Joomla CMS: Référence du fichier iconclass.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • icon
Espaces de nommage | Variables
Référence du fichier icon/iconclass.php

Espaces de nommage

Joomla\Site

Variables

$icon = $displayData['icon']
$iconFixed = $displayData['fixed'] ?? null
$iconPrefix = $displayData['prefix'] ?? 'icon-'
$iconSuffix = $displayData['suffix'] ?? null
$tabindex = $displayData['tabindex'] ?? null
$title = $displayData['title'] ?? null
$html = $displayData['html'] ?? true
if ( $html !==false)

Documentation des variables

◆ $html

$html = $displayData['html'] ?? true

◆ $icon

switch ( $icon) if ( $iconFixed) $icon = $displayData['icon']

◆ $iconFixed

$iconFixed = $displayData['fixed'] ?? null

◆ $iconPrefix

$iconPrefix = $displayData['prefix'] ?? 'icon-'

◆ $iconSuffix

$iconSuffix = $displayData['suffix'] ?? null

◆ $tabindex

$tabindex = $displayData['tabindex'] ?? null

◆ $title

$title = $displayData['title'] ?? null

◆ if

if($html !==false)


Joomla CMS: Référence du fichier iconclass.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier toolbar/iconclass.php

Espaces de nommage

Joomla\Site

Variables

$displayData ['html'] = false

Documentation des variables

◆ $displayData

$displayData[ 'html'] = false


Joomla CMS: Référence du fichier Icons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Icons.php

Structures de données

class Icons

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier icons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier icons.php

Espaces de nommage

Joomla\Site

Variables

$canEdit = $displayData['params']->get('access-edit')
$articleId = $displayData['item']->id
endif

Documentation des variables

◆ $articleId

$articleId = $displayData['item']->id

Référencé par PlgSystemPrivacyconsent\onPrivacyCheckPrivacyPolicyPublished(), et ArticleController\save().

◆ $canEdit

$canEdit = $displayData['params']->get('access-edit')

◆ endif

endif


Joomla CMS: Référence du fichier Iconv.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
Structures de données | Espaces de nommage
Référence du fichier Iconv.php

Structures de données

class Iconv

Espaces de nommage

Symfony\Polyfill\Iconv


Joomla CMS: Référence du fichier IdentifiedBy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier IdentifiedBy.php

Structures de données

class IdentifiedBy

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier Identifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier Identifier.php

Structures de données

class Identifier

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier Identity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
  • Agent
Structures de données | Espaces de nommage
Référence du fichier Identity.php

Structures de données

class Identity

Espaces de nommage

phpseclib3\System\SSH\Agent
SSH


Joomla CMS: Référence du fichier IdentityAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Espaces de nommage | Fonctions | Variables
Référence du fichier IdentityAware.php

Espaces de nommage

Joomla\CMS\Application

Fonctions

getIdentity ()
loadIdentity (User $identity=null)
setUserFactory (UserFactoryInterface $userFactory)

Variables

trait IdentityAware
$userFactory


Joomla CMS: Référence du fichier IdnaConvertInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
Structures de données | Espaces de nommage
Référence du fichier IdnaConvertInterface.php

Structures de données

interface IdnaConvertInterface

Espaces de nommage

Algo26\IdnaConvert


Joomla CMS: Référence du fichier IetfCtx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • ChaCha20
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/ChaCha20/IetfCtx.php

Structures de données

class IetfCtx

Espaces de nommage

ParagonIE\Sodium\Core\ChaCha20


Joomla CMS: Référence du fichier IetfCtx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • ChaCha20
Structures de données
Référence du fichier src/Core/ChaCha20/IetfCtx.php

Structures de données

class ParagonIE_Sodium_Core_ChaCha20_IetfCtx


Joomla CMS: Référence du fichier IetfCtx.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • ChaCha20
Structures de données
Référence du fichier src/Core32/ChaCha20/IetfCtx.php

Structures de données

class ParagonIE_Sodium_Core32_ChaCha20_IetfCtx


Joomla CMS: Référence du fichier iframe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Espaces de nommage | Variables
Référence du fichier iframe.php

Espaces de nommage

Joomla\Site

Variables

$iframeAttributes
if(isset($params['title'])) if(isset($params['height'])) if (isset( $params[ 'width']))

Documentation des variables

◆ $iframeAttributes

$iframeAttributes
Valeur initiale :
= array(
'class' => 'iframe',
'src' => $params['url']
)
$params
$params
Definition: administrator/components/com_banners/tmpl/clients/default.php:39

◆ if

if (isset( $params[ 'title'])) if (isset( $params[ 'height'])) if(isset($params['width']))


Joomla CMS: Référence du fichier IgnoreTokenBindingHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TokenBinding
Structures de données | Espaces de nommage
Référence du fichier IgnoreTokenBindingHandler.php

Structures de données

class IgnoreTokenBindingHandler

Espaces de nommage

Webauthn\TokenBinding


Joomla CMS: Référence du fichier Image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
Structures de données | Espaces de nommage
Référence du fichier Image.php

Structures de données

class Image

Espaces de nommage

Joomla\CMS\Image


Joomla CMS: Référence du fichier image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
Espaces de nommage | Variables
Référence du fichier layouts/joomla/html/image.php

Espaces de nommage

Joomla\Site

Variables

$img = HTMLHelper::_('cleanImageURL', $displayData['src'])
$displayData ['src'] = $this->escape($img->url)
if(isset($displayData['alt'])) if ( $img->attributes[ 'width'] > 0 &&$img->attributes[ 'height'] > 0)

Documentation des variables

◆ $displayData

$displayData[ 'src'] = $this->escape($img->url)

◆ $img

$img = HTMLHelper::_('cleanImageURL', $displayData['src'])

Référencé par RandomImageHelper\getImages().

◆ if

if (isset( $displayData[ 'alt'])) if($img->attributes['width'] > 0 && $img->attributes['height'] > 0)


Joomla CMS: Référence du fichier image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • image
Structures de données | Espaces de nommage
Référence du fichier plugins/editors-xtd/image/image.php

Structures de données

class PlgButtonImage

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ImageDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier ImageDocument.php

Structures de données

class ImageDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier ImageFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
Structures de données | Espaces de nommage
Référence du fichier ImageFilter.php

Structures de données

class ImageFilter

Espaces de nommage

Joomla\CMS\Image


Joomla CMS: Référence du fichier imagelist.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • imagelist
Structures de données | Espaces de nommage
Référence du fichier imagelist.php

Structures de données

class PlgFieldsImagelist

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier imagelist.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • imagelist
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/imagelist.php

Espaces de nommage

Joomla\Plugin

Variables

if($field->value=='') | $class = $fieldParams->get('image_class')
if($class) | $value = (array) $field->value
$buffer = ''
foreach ( $value as $path)

Documentation des variables

◆ $buffer

$buffer = ''

Référencé par DatabaseExporter\__toString(), Nested\_logtable(), File\append(), FtpClient\append(), Patcher\apply(), MysqliExporter\buildXml(), MysqlExporter\buildXml(), PgsqlExporter\buildXml(), DatabaseExporter\buildXmlData(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), PgsqlExporter\buildXmlStructure(), PlgSystemSef\checkBuffer(), FtpClient\create(), ConfigurationModel\createConfiguration(), Zip\createZipFile(), Salsa20\crypt(), SymmetricKey\decrypt(), SymmetricKey\encrypt(), Bzip2\extract(), Gzip\extract(), Tar\extract(), Zip\extractCustom(), Zip\extractNative(), FtpClient\get(), Profiler\getBuffer(), HelpModel\getToc(), ChangeSet\getUpdateQueries(), PlgSystemSef\onAfterRender(), SymmetricKey\openssl_ctr_process(), SymmetricKey\openssl_ofb_process(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), DatabaseModel\populateDatabase(), DebugFormatterHelper\progress(), FtpClient\read(), SSH2\read_remaining_bytes(), HeadRenderer\render(), ModulesRenderer\render(), CliRenderer\render(), StylesRenderer\render(), ScriptsRenderer\render(), ScriptsRenderer\renderAttributes(), StylesRenderer\renderAttributes(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), ScriptsRenderer\renderInlineElement(), StylesRenderer\renderInlineElement(), DatabaseModel\splitQueries(), Indexer\tokenizeToDb(), ProcessHelper\wrapCallback(), File\write(), FtpClient\write(), et Stream\writeFile().

◆ $class

if ( $field->value=='') $class = $fieldParams->get('image_class')

◆ $value

if ( $class) $value = (array) $field->value

◆ foreach

foreach($value as $path)


Joomla CMS: Référence du fichier ImagelistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ImagelistField.php

Structures de données

class ImagelistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ImagineCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ImagineCaster.php

Structures de données

class ImagineCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier ImgStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ImgStub.php

Structures de données

class ImgStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier ImmutableNodeInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tree
Structures de données | Espaces de nommage
Référence du fichier ImmutableNodeInterface.php

Structures de données

interface ImmutableNodeInterface

Espaces de nommage

Joomla\CMS\Tree


Joomla CMS: Référence du fichier ImmutableNodeTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tree
Espaces de nommage | Fonctions | Variables
Référence du fichier ImmutableNodeTrait.php

Espaces de nommage

Joomla\CMS\Tree

Fonctions

& getChildren ($recursive=false)
getParent ()
getRoot ()
hasChildren ()
hasParent ()
getSibling ($right=true)

Variables

trait ImmutableNodeTrait
$_children = array()
$_leftSibling = null
$_rightSibling = null


Joomla CMS: Référence du fichier ImpmadeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ImpmadeField.php

Structures de données

class ImpmadeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Field


Joomla CMS: Référence du fichier import.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Variables
Référence du fichier import.legacy.php

Variables

if(!defined('JPATH_PLATFORM')) $os = strtoupper(substr(PHP_OS, 0, 3))

Documentation des variables

◆ $os

if (!defined( 'JPATH_PLATFORM')) $os = strtoupper(substr(PHP_OS, 0, 3))


Joomla CMS: Référence du fichier import.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Variables
Référence du fichier import.php

Variables

if(!defined('JPATH_PLATFORM')) $os = strtoupper(substr(PHP_OS, 0, 3))

Documentation des variables

◆ $os

if (!defined( 'JPATH_PLATFORM')) $os = strtoupper(substr(PHP_OS, 0, 3))


Joomla CMS: Référence du fichier ImportCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier ImportCommand.php

Structures de données

class ImportCommand

Espaces de nommage

Joomla\Database\Command


Joomla CMS: Référence du fichier ImptotalField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ImptotalField.php

Structures de données

class ImptotalField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Field


Joomla CMS: Référence du fichier InconsistentSetupException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InconsistentSetupException.php

Structures de données

class InconsistentSetupException

Espaces de nommage

InconsistentSetupException
phpseclib3\Exception


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
Espaces de nommage | Variables
Référence du fichier administrator/index.php

Espaces de nommage

Joomla\Administrator

Variables

const | JOOMLA_MINIMUM_PHP '7.2.5'
const | _JEXEC (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Documentation des variables

◆ _JEXEC

const _JEXEC(version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Constant that is checked in included files to prevent direct access. define() is used rather than "const" to not error for PHP 5.2 and lower

◆ JOOMLA_MINIMUM_PHP

const JOOMLA_MINIMUM_PHP '7.2.5'

Référencé par UpdateModel\getTargetMinimumPHPVersion().


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier administrator/templates/atum/index.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$input = $app->input
$wa = $this->getWebAssetManager()
$option = $input->get('option', '')
$view = $input->get('view', '')
$layout = $input->get('layout', 'default')
$task = $input->get('task', 'display')
$cpanel = $option === 'com_cpanel' || ($option === 'com_admin' && $view === 'help')
$hiddenMenu = $app->input->get('hidemainmenu')
$sidebarState = $input->cookie->get('atumSidebarState', '')
$a11y_mono = (bool) $app->getIdentity()->getParam('a11y_mono', '')
$a11y_contrast = (bool) $app->getIdentity()->getParam('a11y_contrast', '')
$a11y_highlight = (bool) $app->getIdentity()->getParam('a11y_highlight', '')
$a11y_font = (bool) $app->getIdentity()->getParam('a11y_font', '')
$logoBrandLarge
$logoBrandSmall
$logoBrandLargeAlt
$logoBrandSmallAlt
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width

Documentation des variables

◆ $a11y_contrast

$a11y_contrast = (bool) $app->getIdentity()->getParam('a11y_contrast', '')

◆ $a11y_font

$a11y_font = (bool) $app->getIdentity()->getParam('a11y_font', '')

◆ $a11y_highlight

$a11y_highlight = (bool) $app->getIdentity()->getParam('a11y_highlight', '')

◆ $a11y_mono

$a11y_mono = (bool) $app->getIdentity()->getParam('a11y_mono', '')

◆ $app

$app = Factory::getApplication()

◆ $cpanel

$cpanel = $option === 'com_cpanel' || ($option === 'com_admin' && $view === 'help')

◆ $hiddenMenu

$hiddenMenu = $app->input->get('hidemainmenu')

◆ $input

$input = $app->input

◆ $layout

$layout = $input->get('layout', 'default')

◆ $logoBrandLarge

$logoBrandLarge
Valeur initiale :
= $this->params->get('logoBrandLarge')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandLarge'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-large.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandLargeAlt

$logoBrandLargeAlt
Valeur initiale :
= empty($this->params->get('logoBrandLargeAlt')) && empty($this->params->get('emptyLogoBrandLargeAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandLargeAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandSmall

$logoBrandSmall
Valeur initiale :
= $this->params->get('logoBrandSmall')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandSmall'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-small.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandSmallAlt

$logoBrandSmallAlt
Valeur initiale :
= empty($this->params->get('logoBrandSmallAlt')) && empty($this->params->get('emptyLogoBrandSmallAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandSmallAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $option

$option = $input->get('option', '')

◆ $sidebarState

$sidebarState = $input->cookie->get('atumSidebarState', '')

◆ $task

$task = $input->get('task', 'display')

◆ $view

$view = $input->get('view', '')

◆ $wa

$wa = $this->getWebAssetManager()

◆ width

$wa usePreset ( 'template.atum.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • system
Espaces de nommage
Référence du fichier administrator/templates/system/index.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
Espaces de nommage | Variables
Référence du fichier api/index.php

Espaces de nommage

Joomla\API

Variables

const | JOOMLA_MINIMUM_PHP '7.2.5'
const | _JEXEC (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Documentation des variables

◆ _JEXEC

const _JEXEC(version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Constant that is checked in included files to prevent direct access. define() is used rather than "const" to not cause an error for PHP 5.2 and lower

◆ JOOMLA_MINIMUM_PHP

const JOOMLA_MINIMUM_PHP '7.2.5'


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
Espaces de nommage | Variables
Référence du fichier index.php

Espaces de nommage

Joomla\Site

Variables

const | JOOMLA_MINIMUM_PHP '7.2.5'
const | _JEXEC (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Documentation des variables

◆ _JEXEC

const _JEXEC(version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Constant that is checked in included files to prevent direct access. define() is used rather than "const" to not error for PHP 5.2 and lower

◆ JOOMLA_MINIMUM_PHP

const JOOMLA_MINIMUM_PHP '7.2.5'


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
Espaces de nommage | Variables
Référence du fichier installation/index.php

Espaces de nommage

Joomla\Installation

Variables

const | JOOMLA_MINIMUM_PHP '7.2.5'
const | _JEXEC (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Documentation des variables

◆ _JEXEC

const _JEXEC(version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) 1

Constant that is checked in included files to prevent direct access. define() is used rather than "const" to not error for PHP 5.2 and lower

◆ JOOMLA_MINIMUM_PHP

const JOOMLA_MINIMUM_PHP '7.2.5'

NOTE: This file should remain compatible with PHP 5.2 to allow us to run our PHP minimum check and show a friendly error message Define the application's minimum supported PHP version as a constant so it can be referenced within the application.


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • template
Espaces de nommage
Référence du fichier installation/template/index.php

Espaces de nommage

Joomla\Installation


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
Espaces de nommage | Variables
Référence du fichier templates/cassiopeia/index.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$wa = $this->getWebAssetManager()
$option = $app->input->getCmd('option', '')
$view = $app->input->getCmd('view', '')
$layout = $app->input->getCmd('layout', '')
$task = $app->input->getCmd('task', '')
$itemid = $app->input->getCmd('Itemid', '')
$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')
$menu = $app->getMenu()->getActive()
$pageclass = $menu !== null ? $menu->getParams()->get('pageclass_sfx', '') : ''
$paramsColorName = $this->params->get('colorName', 'colors_standard')
$assetColorName = 'theme.' . $paramsColorName
$paramsFontScheme = $this->params->get('useFontScheme', false)
$fontStyles = ''
if($paramsFontScheme) $wa | usePreset ( 'template.cassiopeia.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->useScript( 'template.user') ->addInlineStyle(":root
if($this->params->get('logoFile')) elseif($this->params->get('siteTitle')) | else
$hasClass = ''
if($this->countModules('sidebar-left', true)) if($this->countModules('sidebar-right', true)) | $wrapper = $this->params->get('fluidContainer') ? 'wrapper-fluid' : 'wrapper-static'
$stickyHeader = $this->params->get('stickyHeader') ? 'position-sticky sticky-top' : ''
if($this->countModules('topbar')) if($this->countModules('below-top')) | if ( $this->params->get( 'brand', 1))
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assetColorName

$assetColorName = 'theme.' . $paramsColorName

◆ $fontStyles

$fontStyles = ''

◆ $hasClass

$hasClass = ''

◆ $itemid

$itemid = $app->input->getCmd('Itemid', '')

◆ $layout

$layout = $app->input->getCmd('layout', '')

◆ $menu

$menu = $app->getMenu()->getActive()

◆ $option

$option = $app->input->getCmd('option', '')

◆ $pageclass

$pageclass = $menu !== null ? $menu->getParams()->get('pageclass_sfx', '') : ''

◆ $paramsColorName

$paramsColorName = $this->params->get('colorName', 'colors_standard')

◆ $paramsFontScheme

$paramsFontScheme = $this->params->get('useFontScheme', false)

◆ $sitename

$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')

◆ $stickyHeader

$stickyHeader = $this->params->get('stickyHeader') ? 'position-sticky sticky-top' : ''

◆ $task

$task = $app->input->getCmd('task', '')

◆ $view

$view = $app->input->getCmd('view', '')

◆ $wa

$wa = $this->getWebAssetManager()

◆ $wrapper

if ( $this->countModules( 'sidebar-left', true)) if ( $this->countModules( 'sidebar-right', true)) $wrapper = $this->params->get('fluidContainer') ? 'wrapper-fluid' : 'wrapper-static'

◆ else

if ( $this->params->get( 'logoFile')) elseif ( $this->params->get( 'siteTitle')) else
Valeur initiale :
{
$logo = HTMLHelper::_('image', 'logo.svg', $sitename, ['class' => 'logo d-inline-block'], true, 0)
$sitename
$sitename
Definition: templates/cassiopeia/index.php:34

◆ endif

if ($this->countModules('menu', true) || $this->countModules('search', true)) ( $this->countModules( 'menu', true)) if ( $this->countModules( 'search', true)) endif

◆ if

if ( $this->countModules( 'topbar')) if ( $this->countModules( 'below-top')) if($this->params->get('brand', 1))

◆ usePreset

if ( $paramsFontScheme) $wa usePreset('template.cassiopeia.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->useScript('template.user') ->addInlineStyle(":root


Joomla CMS: Référence du fichier index.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Espaces de nommage
Référence du fichier templates/system/index.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier IndexController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier IndexController.php

Structures de données

class IndexController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier Indexer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier Indexer.php

Structures de données

class Indexer

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier IndexerController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier IndexerController.php

Structures de données

class IndexerController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier IndexerModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier IndexerModel.php

Structures de données

class IndexerModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier IndexModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier IndexModel.php

Structures de données

class IndexModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier InfiniteListObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier InfiniteListObject.php

Structures de données

class InfiniteListObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier InfiniteMapObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier InfiniteMapObject.php

Structures de données

class InfiniteMapObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • English
Structures de données | Espaces de nommage
Référence du fichier English/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\English


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • French
Structures de données | Espaces de nommage
Référence du fichier French/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\French


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Structures de données | Espaces de nommage
Référence du fichier NorwegianBokmal/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\NorwegianBokmal


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Structures de données | Espaces de nommage
Référence du fichier Portuguese/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\Portuguese


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Spanish
Structures de données | Espaces de nommage
Référence du fichier Spanish/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\Spanish


Joomla CMS: Référence du fichier Inflectible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Turkish
Structures de données | Espaces de nommage
Référence du fichier Turkish/Inflectible.php

Structures de données

class Inflectible

Espaces de nommage

Doctrine\Inflector\Rules\Turkish


Joomla CMS: Référence du fichier Inflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Common
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php

Structures de données

class Inflector

Espaces de nommage

Doctrine\Common\Inflector


Joomla CMS: Référence du fichier Inflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier doctrine/inflector/lib/Doctrine/Inflector/Inflector.php

Structures de données

class Inflector

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier Inflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/string/src/Inflector.php

Structures de données

class Inflector

Espaces de nommage

Joomla\String


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • English
Structures de données | Espaces de nommage
Référence du fichier Rules/English/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\English


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • French
Structures de données | Espaces de nommage
Référence du fichier Rules/French/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\French


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Structures de données | Espaces de nommage
Référence du fichier Rules/NorwegianBokmal/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\NorwegianBokmal


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Structures de données | Espaces de nommage
Référence du fichier Rules/Portuguese/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\Portuguese


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Spanish
Structures de données | Espaces de nommage
Référence du fichier Rules/Spanish/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\Spanish


Joomla CMS: Référence du fichier InflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Turkish
Structures de données | Espaces de nommage
Référence du fichier Rules/Turkish/InflectorFactory.php

Structures de données

class InflectorFactory

Espaces de nommage

Doctrine\Inflector\Rules\Turkish


Joomla CMS: Référence du fichier InflectorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier InflectorInterface.php

Structures de données

interface InflectorInterface

Espaces de nommage

Symfony\Component\String\Inflector


Joomla CMS: Référence du fichier info_block.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier info_block.php

Espaces de nommage

Joomla\Site

Variables

$blockPosition = $displayData['params']->get('info_block_position', 0)
endif

Documentation des variables

◆ $blockPosition

$blockPosition = $displayData['params']->get('info_block_position', 0)

◆ endif

endif


Joomla CMS: Référence du fichier InfoCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier InfoCollector.php

Structures de données

class InfoCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier Ini.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Structures de données | Espaces de nommage
Référence du fichier Ini.php

Structures de données

class Ini

Espaces de nommage

Joomla\Registry\Format


Joomla CMS: Référence du fichier InjectContentTypeTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Espaces de nommage
Référence du fichier InjectContentTypeTrait.php

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier Inline.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier Inline.php

Structures de données

class Inline

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier inlinehelp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage
Référence du fichier inlinehelp.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier InlinehelpButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier InlinehelpButton.php

Structures de données

class InlinehelpButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier InMemory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Key
Structures de données | Espaces de nommage
Référence du fichier InMemory.php

Structures de données

class InMemory

Espaces de nommage

Lcobucci\JWT\Signer\Key


Joomla CMS: Référence du fichier InMemoryLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier InMemoryLogger.php

Structures de données

class InMemoryLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier Input.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Structures de données | Espaces de nommage
Référence du fichier src/Input/Input.php

Structures de données

class Input

Espaces de nommage

Joomla\CMS\Input


Joomla CMS: Référence du fichier Input.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/input/src/Input.php

Structures de données

class Input

Espaces de nommage

Joomla\Input


Joomla CMS: Référence du fichier Input.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier vendor/symfony/console/Input/Input.php

Structures de données

class Input

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InputArgument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier InputArgument.php

Structures de données

class InputArgument

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InputAwareHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier InputAwareHelper.php

Structures de données

class InputAwareHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier InputAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier InputAwareInterface.php

Structures de données

interface InputAwareInterface

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InputDefinition.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier InputDefinition.php

Structures de données

class InputDefinition

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InputFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filter
Structures de données | Espaces de nommage
Référence du fichier src/Filter/InputFilter.php

Structures de données

class InputFilter

Espaces de nommage

Joomla\CMS\Filter


Joomla CMS: Référence du fichier InputFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filter
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filter/src/InputFilter.php

Structures de données

class InputFilter

Espaces de nommage

Joomla\Filter


Joomla CMS: Référence du fichier InputInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier InputInterface.php

Structures de données

interface InputInterface

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InputOption.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier InputOption.php

Structures de données

class InputOption

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier InstallationApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier InstallationApplication.php

Structures de données

class InstallationApplication

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Application


Joomla CMS: Référence du fichier InstallationController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier InstallationController.php

Structures de données

class InstallationController

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Controller


Joomla CMS: Référence du fichier InstallationRouter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier InstallationRouter.php

Structures de données

class InstallationRouter

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Router


Joomla CMS: Référence du fichier InstallController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier InstallController.php

Structures de données

class InstallController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier installed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Référence du fichier installed.php


Joomla CMS: Référence du fichier InstalledController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier InstalledController.php

Structures de données

class InstalledController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier InstalledModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier InstalledModel.php

Structures de données

class InstalledModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Référence du fichier InstalledVersions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Structures de données | Espaces de nommage
Référence du fichier InstalledVersions.php

Structures de données

class InstalledVersions

Espaces de nommage

Composer


Joomla CMS: Référence du fichier Installer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier Installer.php

Structures de données

class Installer

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier installer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/helpers/installer.php

Structures de données

class InstallerHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier installer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • installer
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/installer/installer.php

Structures de données

class PlgWebservicesInstaller

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier InstallerAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier InstallerAdapter.php

Structures de données

class InstallerAdapter

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier InstallerComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier InstallerComponent.php

Structures de données

class InstallerComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Extension


Joomla CMS: Référence du fichier InstallerExtension.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier InstallerExtension.php

Structures de données

class InstallerExtension

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier InstallerHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/Helper/InstallerHelper.php

Structures de données

class InstallerHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Helper


Joomla CMS: Référence du fichier InstallerHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Installer/InstallerHelper.php

Structures de données

class InstallerHelper

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier InstallerModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier InstallerModel.php

Structures de données

class InstallerModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier InstallerScript.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier InstallerScript.php

Structures de données

class InstallerScript

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier InstallerScriptInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier InstallerScriptInterface.php

Structures de données

interface InstallerScriptInterface

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier InstallModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier InstallModel.php

Structures de données

class InstallModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier InsufficientSetupException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InsufficientSetupException.php

Structures de données

class InsufficientSetupException

Espaces de nommage

InsufficientSetupException
phpseclib3\Exception


Joomla CMS: Référence du fichier Int32.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier Int32.php

Structures de données

class ParagonIE_Sodium_Core32_Int32


Joomla CMS: Référence du fichier Int64.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier Int64.php

Structures de données

class ParagonIE_Sodium_Core32_Int64


Joomla CMS: Référence du fichier IntarrayFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier IntarrayFilter.php

Structures de données

class IntarrayFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • integer
Structures de données | Espaces de nommage
Référence du fichier integer.php

Structures de données

class PlgFieldsInteger

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • integer
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/integer.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') if(is_array($value)) else

Documentation des variables

◆ $value

$value = $field->value

◆ else

if ( $value=='') if (is_array( $value)) else
Valeur initiale :
{
$value = (int) $value
$value
$value
Definition: tmpl/integer.php:13


Joomla CMS: Référence du fichier Integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/ASN1/Universal/Integer.php

Structures de données

class Integer

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier Integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BinaryField
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Math/BinaryField/Integer.php

Structures de données

class Integer

Espaces de nommage

BigInteger
phpseclib3\Math\BinaryField
Math


Joomla CMS: Référence du fichier Integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • Common
  • FiniteField
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Math/Common/FiniteField/Integer.php

Structures de données

class Integer

Espaces de nommage

BigInteger
phpseclib3\Math\Common\FiniteField
Math


Joomla CMS: Référence du fichier Integer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • PrimeField
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Math/PrimeField/Integer.php

Structures de données

class Integer

Espaces de nommage

BigInteger
phpseclib3\Math\PrimeField
Math


Joomla CMS: Référence du fichier IntegerField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier IntegerField.php

Structures de données

class IntegerField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier IntegerOverflowException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier IntegerOverflowException.php

Structures de données

class IntegerOverflowException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier IntervalField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier IntervalField.php

Structures de données

class IntervalField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier IntlCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier IntlCaster.php

Structures de données

class IntlCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier intro_image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier intro_image.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData->params
$images = json_decode($displayData->images)
if(empty($images->image_intro)) $imgclass = empty($images->float_intro) ? $params->get('float_intro') : $images->float_intro
$layoutAttr
else __pad5__
endif

Documentation des variables

◆ $images

$images = json_decode($displayData->images)

◆ $imgclass

if (empty( $images->image_intro)) $imgclass = empty($images->float_intro) ? $params->get('float_intro') : $images->float_intro

◆ $layoutAttr

$layoutAttr
Valeur initiale :
= [
'src' => $images->image_intro
$images
$images
Definition: intro_image.php:18

◆ $params

$params = $displayData->params

◆ __pad5__

else __pad5__

◆ endif

endif


Joomla CMS: Référence du fichier introduction.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • httpheaders
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier introduction.php

Espaces de nommage

Joomla\Plugin

Fonctions

httpheaders_postinstall_condition ()
httpheaders_postinstall_action ()

Documentation des fonctions

◆ httpheaders_postinstall_action()

httpheaders_postinstall_action ( )

Enables the HTTPHeaders plugin

Renvoie
void
Depuis
4.0.0

Références $db, $query, $url, et Joomla\CMS\MVC\Model\getDbo().

◆ httpheaders_postinstall_condition()

httpheaders_postinstall_condition ( )

Checks if the plugin is enabled. If not it returns true, meaning that the message concerning the HTTPHeaders Plugin should be displayed.

Renvoie
integer
Depuis
4.0.0

Références PluginHelper\isEnabled().


Joomla CMS: Référence du fichier InvalidActionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidActionException.php

Structures de données

class InvalidActionException

Espaces de nommage

Joomla\CMS\WebAsset\Exception


Joomla CMS: Référence du fichier InvalidArgument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidArgument.php

Structures de données

class InvalidArgument

Espaces de nommage

Negotiation\Exception


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier beberlei/assert/lib/Assert/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Assert


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Exception/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier psr/log/Psr/Log/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Exception/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/options-resolver/Exception/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/string/Exception/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Symfony\Component\String\Exception


Joomla CMS: Référence du fichier InvalidArgumentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
  • assert
  • src
Structures de données | Espaces de nommage
Référence du fichier webmozart/assert/src/InvalidArgumentException.php

Structures de données

class InvalidArgumentException

Espaces de nommage

Webmozart\Assert


Joomla CMS: Référence du fichier InvalidCharacterException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidCharacterException.php

Structures de données

class InvalidCharacterException

Espaces de nommage

Algo26\IdnaConvert\Exception


Joomla CMS: Référence du fichier InvalidCredentialsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidCredentialsException.php

Structures de données

class InvalidCredentialsException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier InvalidHeader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidHeader.php

Structures de données

class InvalidHeader

Espaces de nommage

Negotiation\Exception


Joomla CMS: Référence du fichier InvalidIdnVersionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidIdnVersionException.php

Structures de données

class InvalidIdnVersionException

Espaces de nommage

Algo26\IdnaConvert\Exception


Joomla CMS: Référence du fichier InvalidityDate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier InvalidityDate.php

Structures de données

class InvalidityDate

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier InvalidKeyException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidKeyException.php

Structures de données

class InvalidKeyException

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier InvalidKeyProvided.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier InvalidKeyProvided.php

Structures de données

class InvalidKeyProvided

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier InvalidKeyTypeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidKeyTypeException.php

Structures de données

class InvalidKeyTypeException

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier InvalidLanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidLanguage.php

Structures de données

class InvalidLanguage

Espaces de nommage

Negotiation\Exception


Joomla CMS: Référence du fichier InvalidMediaType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidMediaType.php

Structures de données

class InvalidMediaType

Espaces de nommage

Negotiation\Exception


Joomla CMS: Référence du fichier InvalidOptionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidOptionException.php

Structures de données

class InvalidOptionException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier InvalidOptionsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidOptionsException.php

Structures de données

class InvalidOptionsException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier InvalidParameterException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidParameterException.php

Structures de données

class InvalidParameterException

Espaces de nommage

Tobscure\JsonApi\Exception


Joomla CMS: Référence du fichier InvalidParameterExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier src/Error/JsonApi/InvalidParameterExceptionHandler.php

Structures de données

class InvalidParameterExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier InvalidParameterExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
  • Handler
Structures de données | Espaces de nommage
Référence du fichier vendor/tobscure/json-api/src/Exception/Handler/InvalidParameterExceptionHandler.php

Structures de données

class InvalidParameterExceptionHandler

Espaces de nommage

Tobscure\JsonApi\Exception\Handler


Joomla CMS: Référence du fichier InvalidPathException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidPathException.php

Structures de données

class InvalidPathException

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Exception


Joomla CMS: Référence du fichier InvalidResponseCodeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidResponseCodeException.php

Structures de données

class InvalidResponseCodeException

Espaces de nommage

Joomla\Http\Exception


Joomla CMS: Référence du fichier InvalidRouteExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier InvalidRouteExceptionHandler.php

Structures de données

class InvalidRouteExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier InvalidSessionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidSessionException.php

Structures de données

class InvalidSessionException

Espaces de nommage

Joomla\Session\Exception


Joomla CMS: Référence du fichier InvalidStreamPointerPositionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidStreamPointerPositionException.php

Structures de données

class InvalidStreamPointerPositionException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier InvalidTokenStructure.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Structures de données | Espaces de nommage
Référence du fichier InvalidTokenStructure.php

Structures de données

class InvalidTokenStructure

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier InvalidUuidStringException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier InvalidUuidStringException.php

Structures de données

class InvalidUuidStringException

Espaces de nommage

Ramsey\Uuid\Exception


Joomla CMS: Référence du fichier IOException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier IOException.php

Structures de données

class IOException

Espaces de nommage

Defuse\Crypto\Exception


Joomla CMS: Référence du fichier IPAddress.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • SAN
Structures de données | Espaces de nommage
Référence du fichier IPAddress.php

Structures de données

class IPAddress

Espaces de nommage

FG\X509\SAN


Joomla CMS: Référence du fichier IpHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • utilities
  • src
Structures de données | Espaces de nommage
Référence du fichier IpHelper.php

Structures de données

class IpHelper

Espaces de nommage

Joomla\Utilities


Joomla CMS: Référence du fichier IssuedBy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier IssuedBy.php

Structures de données

class IssuedBy

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier IssuerAltName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier IssuerAltName.php

Structures de données

class IssuerAltName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier IssuingDistributionPoint.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier IssuingDistributionPoint.php

Structures de données

class IssuingDistributionPoint

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Italian.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Italian.php

Structures de données

class Italian

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage | Variables
Référence du fichier item.php

Espaces de nommage

Joomla\Site

Variables

$options
$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
else __pad9__
endif

Documentation des variables

◆ $options

$options
Valeur initiale :
= array(
HTMLHelper::_('select.option', 'c', Text::_('JLIB_HTML_BATCH_COPY')),
HTMLHelper::_('select.option', 'm', Text::_('JLIB_HTML_BATCH_MOVE'))
)

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

◆ __pad9__

else __pad9__

◆ endif

endif


Joomla CMS: Référence du fichier Item.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Export
Structures de données | Espaces de nommage
Référence du fichier Item.php

Structures de données

class Item

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Export


Joomla CMS: Référence du fichier ItemController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ItemController.php

Structures de données

class ItemController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier ItemlanguageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ItemlanguageField.php

Structures de données

class ItemlanguageField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Field


Joomla CMS: Référence du fichier ItemModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/Model/ItemModel.php

Structures de données

class ItemModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Model


Joomla CMS: Référence du fichier ItemModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier libraries/src/MVC/Model/ItemModel.php

Structures de données

class ItemModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier ItemModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier ItemModelInterface.php

Structures de données

interface ItemModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier ItemsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/Controller/ItemsController.php

Structures de données

class ItemsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier ItemsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_menus/src/Controller/ItemsController.php

Structures de données

class ItemsController

Espaces de nommage

Joomla\API
Joomla\Component\Menus\Api\Controller


Joomla CMS: Référence du fichier ItemsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ItemsModel.php

Structures de données

class ItemsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Model


Joomla CMS: Référence du fichier ItemtypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ItemtypeField.php

Structures de données

class ItemtypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Associations\Administrator\Field


Joomla CMS: Référence du fichier ItunesRssParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
  • Rss
Structures de données | Espaces de nommage
Référence du fichier ItunesRssParser.php

Structures de données

class ItunesRssParser

Espaces de nommage

Joomla\CMS\Feed\Parser\Rss


Joomla CMS: Référence du fichier JavascriptRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/maximebf/debugbar/src/DebugBar/JavascriptRenderer.php

Structures de données

class JavascriptRenderer

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier JavascriptRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
Structures de données | Espaces de nommage
Référence du fichier plugins/system/debug/src/JavascriptRenderer.php

Structures de données

class JavascriptRenderer

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug


Joomla CMS: Référence du fichier JGrid.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier JGrid.php

Structures de données

class JGrid

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier jooa11y.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • jooa11y
Structures de données | Espaces de nommage
Référence du fichier jooa11y.php

Structures de données

class PlgSystemJooa11y

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Joomla.php

Structures de données

class Joomla

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Actionlog\Joomla\Extension


Joomla CMS: Référence du fichier joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • cli
Espaces de nommage | Variables
Référence du fichier cli/joomla.php

Espaces de nommage

Joomla\Cli

Variables

const | _JEXEC = 1
const | JOOMLA_MINIMUM_PHP = '7.2.5'
if(version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) if(file_exists(dirname(__DIR__) . '/defines.php')) if(!defined('_JDEFINES')) if(!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor')) | if (!file_exists(JPATH_CONFIGURATION . '/configuration.php')||(filesize(JPATH_CONFIGURATION . '/configuration.php')< 10))
$container = \Joomla\CMS\Factory::getContainer()
$app = \Joomla\CMS\Factory::getContainer()->get(\Joomla\Console\Application::class)

Documentation des variables

◆ $app

$app = \Joomla\CMS\Factory::getContainer()->get(\Joomla\Console\Application::class)

◆ $container

$container = \Joomla\CMS\Factory::getContainer()

◆ _JEXEC

const _JEXEC = 1

◆ if

if (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<')) if (file_exists(dirname(__DIR__) . '/defines.php')) if (!defined( '_JDEFINES')) if (!file_exists(JPATH_LIBRARIES . '/vendor/autoload.php')||!is_dir(JPATH_ROOT . '/media/vendor')) if(!file_exists(JPATH_CONFIGURATION . '/configuration.php')||(filesize(JPATH_CONFIGURATION . '/configuration.php')< 10))

◆ JOOMLA_MINIMUM_PHP

const JOOMLA_MINIMUM_PHP = '7.2.5'


Joomla CMS: Référence du fichier joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • joomla
Structures de données | Espaces de nommage
Référence du fichier plugins/authentication/joomla/joomla.php

Structures de données

class PlgAuthenticationJoomla

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • joomla
Structures de données | Espaces de nommage
Référence du fichier plugins/content/joomla/joomla.php

Structures de données

class PlgContentJoomla

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • joomla
Structures de données | Espaces de nommage
Référence du fichier plugins/extension/joomla/joomla.php

Structures de données

class PlgExtensionJoomla

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier joomla.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • joomla
Structures de données | Espaces de nommage
Référence du fichier plugins/user/joomla/joomla.php

Structures de données

class PlgUserJoomla

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier JoomlaHttpDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
Structures de données | Espaces de nommage
Référence du fichier JoomlaHttpDriver.php

Structures de données

class JoomlaHttpDriver

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug


Joomla CMS: Référence du fichier JoomlaSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JoomlaSerializer.php

Structures de données

class JoomlaSerializer

Espaces de nommage

Joomla\CMS\Serializer


Joomla CMS: Référence du fichier JoomlaStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • Storage
Structures de données | Espaces de nommage
Référence du fichier JoomlaStorage.php

Structures de données

class JoomlaStorage

Espaces de nommage

Joomla\CMS\Session\Storage


Joomla CMS: Référence du fichier JoomlatokenField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • token
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier JoomlatokenField.php

Structures de données

class JoomlatokenField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\User\Token\Field


Joomla CMS: Référence du fichier Joomlaupdate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Joomlaupdate.php

Structures de données

class Joomlaupdate

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Quickicon\Joomlaupdate\Extension


Joomla CMS: Référence du fichier Jquery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Jquery.php

Structures de données

class Jquery

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier json-exception-polyfill.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • compat
Référence du fichier json-exception-polyfill.php


Joomla CMS: Référence du fichier Json.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Structures de données | Espaces de nommage
Référence du fichier src/Input/Json.php

Structures de données

class Json

Espaces de nommage

Joomla\CMS\Input


Joomla CMS: Référence du fichier Json.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/input/src/Json.php

Structures de données

class Json

Espaces de nommage

Joomla\Input


Joomla CMS: Référence du fichier Json.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/registry/src/Format/Json.php

Structures de données

class Json

Espaces de nommage

Joomla\Registry\Format


Joomla CMS: Référence du fichier JsonapiDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier JsonapiDocument.php

Structures de données

class JsonapiDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier JsonapiRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier JsonapiRenderer.php

Structures de données

class JsonapiRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier JsonApiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier JsonApiView.php

Structures de données

class JsonApiView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • View
  • Banners
Structures de données | Espaces de nommage
Référence du fichier com_banners/src/View/Banners/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Banners\Api\View\Banners


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • View
  • Clients
Structures de données | Espaces de nommage
Référence du fichier com_banners/src/View/Clients/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Banners\Api\View\Clients


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
  • View
  • Categories
Structures de données | Espaces de nommage
Référence du fichier com_categories/src/View/Categories/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Categories\Api\View\Categories


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • View
  • Application
Structures de données | Espaces de nommage
Référence du fichier com_config/src/View/Application/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Config\Api\View\Application


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • View
  • Component
Structures de données | Espaces de nommage
Référence du fichier com_config/src/View/Component/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Config\Api\View\Component


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • View
  • Contacts
Structures de données | Espaces de nommage
Référence du fichier com_contact/src/View/Contacts/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Contact\Api\View\Contacts


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • View
  • Articles
Structures de données | Espaces de nommage
Référence du fichier com_content/src/View/Articles/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Content\Api\View\Articles


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
  • View
  • History
Structures de données | Espaces de nommage
Référence du fichier com_contenthistory/src/View/History/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Contenthistory\Api\View\History


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • View
  • Fields
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/View/Fields/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Fields\Api\View\Fields


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • View
  • Groups
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/View/Groups/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Fields\Api\View\Groups


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
  • View
  • Manage
Structures de données | Espaces de nommage
Référence du fichier com_installer/src/View/Manage/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Installer\Api\View\Manage


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Languages
Structures de données | Espaces de nommage
Référence du fichier com_languages/src/View/Languages/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\View\Languages


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Overrides
Structures de données | Espaces de nommage
Référence du fichier com_languages/src/View/Overrides/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\View\Overrides


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Strings
Structures de données | Espaces de nommage
Référence du fichier com_languages/src/View/Strings/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\View\Strings


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • View
  • Adapters
Structures de données | Espaces de nommage
Référence du fichier com_media/src/View/Adapters/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\View\Adapters


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • View
  • Media
Structures de données | Espaces de nommage
Référence du fichier com_media/src/View/Media/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\View\Media


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • View
  • Items
Structures de données | Espaces de nommage
Référence du fichier com_menus/src/View/Items/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Menus\Api\View\Items


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • View
  • Menus
Structures de données | Espaces de nommage
Référence du fichier com_menus/src/View/Menus/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Menus\Api\View\Menus


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
  • View
  • Messages
Structures de données | Espaces de nommage
Référence du fichier com_messages/src/View/Messages/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Messages\Api\View\Messages


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
  • View
  • Modules
Structures de données | Espaces de nommage
Référence du fichier com_modules/src/View/Modules/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Modules\Api\View\Modules


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • View
  • Feeds
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/src/View/Feeds/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Newsfeeds\Api\View\Feeds


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
  • View
  • Plugins
Structures de données | Espaces de nommage
Référence du fichier com_plugins/src/View/Plugins/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Plugins\Api\View\Plugins


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • View
  • Consents
Structures de données | Espaces de nommage
Référence du fichier com_privacy/src/View/Consents/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Privacy\Api\View\Consents


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • View
  • Requests
Structures de données | Espaces de nommage
Référence du fichier com_privacy/src/View/Requests/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Privacy\Api\View\Requests


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
  • View
  • Redirect
Structures de données | Espaces de nommage
Référence du fichier com_redirect/src/View/Redirect/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Redirect\Api\View\Redirect


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
  • View
  • Tags
Structures de données | Espaces de nommage
Référence du fichier com_tags/src/View/Tags/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Tags\Api\View\Tags


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
  • View
  • Styles
Structures de données | Espaces de nommage
Référence du fichier com_templates/src/View/Styles/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Templates\Api\View\Styles


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Groups
Structures de données | Espaces de nommage
Référence du fichier com_users/src/View/Groups/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\View\Groups


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Levels
Structures de données | Espaces de nommage
Référence du fichier com_users/src/View/Levels/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\View\Levels


Joomla CMS: Référence du fichier JsonapiView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Users
Structures de données | Espaces de nommage
Référence du fichier com_users/src/View/Users/JsonapiView.php

Structures de données

class JsonapiView

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\View\Users


Joomla CMS: Référence du fichier JSONController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier JSONController.php

Structures de données

class JSONController

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Controller


Joomla CMS: Référence du fichier JsonConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier JsonConverter.php

Structures de données

class JsonConverter

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier JsonDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier JsonDescriptor.php

Structures de données

class JsonDescriptor

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier JsonDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier JsonDocument.php

Structures de données

class JsonDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier JsonException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
  • Resources
  • stubs
Référence du fichier JsonException.php


Joomla CMS: Référence du fichier JSONFlattenedSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JSONFlattenedSerializer.php

Structures de données

class JSONFlattenedSerializer

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier JSONGeneralSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JSONGeneralSerializer.php

Structures de données

class JSONGeneralSerializer

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier JsonRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier installation/src/Error/Renderer/JsonRenderer.php

Structures de données

class JsonRenderer

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Error\Renderer


Joomla CMS: Référence du fichier JsonRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Error/Renderer/JsonRenderer.php

Structures de données

class JsonRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier JsonResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier installation/src/Response/JsonResponse.php

Structures de données

class JsonResponse

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Response


Joomla CMS: Référence du fichier JsonResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Response/JsonResponse.php

Structures de données

class JsonResponse

Espaces de nommage

Joomla\CMS\Response


Joomla CMS: Référence du fichier JsonResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/laminas/laminas-diactoros/src/Response/JsonResponse.php

Structures de données

class JsonResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier JsonView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Sysinfo
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/src/View/Sysinfo/JsonView.php

Structures de données

class JsonView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\View\Sysinfo


Joomla CMS: Référence du fichier JsonView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Style
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/View/Style/JsonView.php

Structures de données

class JsonView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\View\Style


Joomla CMS: Référence du fichier JsonView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier libraries/src/MVC/View/JsonView.php

Structures de données

class JsonView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier JWK.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier JWK.php

Structures de données

class JWK

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier JWKSet.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier JWKSet.php

Structures de données

class JWKSet

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier JWS.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWS.php

Structures de données

class JWS

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSBuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSBuilder.php

Structures de données

class JWSBuilder

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSBuilderFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSBuilderFactory.php

Structures de données

class JWSBuilderFactory

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSLoader.php

Structures de données

class JWSLoader

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSLoaderFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSLoaderFactory.php

Structures de données

class JWSLoaderFactory

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JWSSerializer.php

Structures de données

interface JWSSerializer

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier JWSSerializerManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JWSSerializerManager.php

Structures de données

class JWSSerializerManager

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier JWSSerializerManagerFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier JWSSerializerManagerFactory.php

Structures de données

class JWSSerializerManagerFactory

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier JWSTokenSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSTokenSupport.php

Structures de données

class JWSTokenSupport

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSVerifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSVerifier.php

Structures de données

class JWSVerifier

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWSVerifierFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier JWSVerifierFactory.php

Structures de données

class JWSVerifierFactory

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier JWT.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Structures de données | Espaces de nommage
Référence du fichier JWT.php

Structures de données

interface JWT

Espaces de nommage

Jose\Component\Core


Joomla CMS: Référence du fichier KeepaliveAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Structures de données | Espaces de nommage
Référence du fichier KeepaliveAssetItem.php

Structures de données

class KeepaliveAssetItem

Espaces de nommage

Joomla\CMS\WebAsset\AssetItem


Joomla CMS: Référence du fichier Key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier defuse/php-encryption/src/Key.php

Structures de données

class Key

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier Key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/crypt/src/Key.php

Structures de données

class Key

Espaces de nommage

Joomla\Crypt


Joomla CMS: Référence du fichier Key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Signer/Key.php

Structures de données

class Key

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier Key.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Key/Key.php

Structures de données

class Key

Espaces de nommage

Cose\Key


Joomla CMS: Référence du fichier Keychain.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier Keychain.php

Structures de données

class Keychain

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier KeyChecker.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier KeyChecker.php

Structures de données

class KeyChecker

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier KeyIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier KeyIdentifier.php

Structures de données

class KeyIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier KeyNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier KeyNotFoundException.php

Structures de données

class KeyNotFoundException

Espaces de nommage

Joomla\DI\Exception


Joomla CMS: Référence du fichier KeyOrPassword.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier KeyOrPassword.php

Structures de données

class KeyOrPassword

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier KeyProtectedByPassword.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier KeyProtectedByPassword.php

Structures de données

class KeyProtectedByPassword

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier KeyPurposeId.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier KeyPurposeId.php

Structures de données

class KeyPurposeId

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier KeyUsage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier KeyUsage.php

Structures de données

class KeyUsage

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier KnownButtons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier KnownButtons.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Référence du fichier KoblitzPrime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier KoblitzPrime.php

Structures de données

class KoblitzPrime

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves
KoblitzPrime


Joomla CMS: Référence du fichier label.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
  • privacyconsent
Espaces de nommage | Variables
Référence du fichier system/privacyconsent/label.php

Espaces de nommage

Joomla\Plugin

Variables

$text = $label ? (string) $label : (string) $name
$required = true
$class = 'required'
if($privacyLink) else
$label = $link . '<span class="star" aria-hidden="true">&#160;*</span>'

Documentation des variables

◆ $class

$class = 'required'

◆ $label

$label = $link . '<span class="star" aria-hidden="true">&#160;*</span>'

◆ $required

$required = true

◆ $text

$text = $label ? (string) $label : (string) $name

◆ else

if ( $privacyLink) else
Valeur initiale :
{
$link = '<span class="' . $class . '">' . $text . '</span>'
$link
$link
Definition: administrator/components/com_menus/tmpl/items/modal.php:35
$text
$text
Definition: system/privacyconsent/label.php:54
$class
$class
Definition: system/privacyconsent/label.php:61


Joomla CMS: Référence du fichier label.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
  • terms
Espaces de nommage | Variables
Référence du fichier user/terms/label.php

Espaces de nommage

Joomla\Plugin

Variables

$text = $label ? (string) $label : (string) $name
$required = true
$class = 'required'
if($article) else
$label = $link . '<span class="star" aria-hidden="true">&#160;*</span>'

Documentation des variables

◆ $class

$class = 'required'

◆ $label

$label = $link . '<span class="star" aria-hidden="true">&#160;*</span>'

◆ $required

$required = true

◆ $text

$text = $label ? (string) $label : (string) $name

◆ else

if ( $article) else
Valeur initiale :
{
$link = '<span class="' . $class . '">' . $text . '</span>'
$text
$text
Definition: user/terms/label.php:53
$link
$link
Definition: administrator/components/com_menus/tmpl/items/modal.php:35
$class
$class
Definition: user/terms/label.php:60


Joomla CMS: Référence du fichier LangActiveAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Structures de données | Espaces de nommage
Référence du fichier LangActiveAssetItem.php

Structures de données

class LangActiveAssetItem

Espaces de nommage

Joomla\CMS\WebAsset\AssetItem


Joomla CMS: Référence du fichier langforum.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • help
Espaces de nommage | Variables
Référence du fichier langforum.php

Espaces de nommage

Joomla\Administrator

Variables

$forumId = (int) Text::_('MOD_MENU_HELP_SUPPORT_OFFICIAL_LANGUAGE_FORUM_VALUE')
if(empty($forumId)) $forumUrl = 'https://forum.joomla.org/viewforum.php?f=' . $forumId

Documentation des variables

◆ $forumId

$forumId = (int) Text::_('MOD_MENU_HELP_SUPPORT_OFFICIAL_LANGUAGE_FORUM_VALUE')

◆ $forumUrl

if (empty( $forumId)) $forumUrl = 'https://forum.joomla.org/viewforum.php?f=' . $forumId


Joomla CMS: Référence du fichier Language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Language.php

Structures de données

class Language

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier Language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Language/Language.php

Structures de données

class Language

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier Language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Language.php

Structures de données

class Language

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Table/Language.php

Structures de données

class Language

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier Language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/doctrine/inflector/lib/Doctrine/Inflector/Language.php

Structures de données

class Language

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/helpers/language.php

Structures de données

class FinderHelperLanguage

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier layouts/joomla/content/language.php

Espaces de nommage

Joomla\Site

Variables

$item = $displayData
if($item->language===' *') elseif($item->language_image) elseif($item->language_title) else

Documentation des variables

◆ $item

$item = $displayData

◆ else

if ( $item->language===' *') elseif ( $item->language_image) elseif ( $item->language_title) else
Valeur initiale :
{
echo Text::_('JUNDEFINED')


Joomla CMS: Référence du fichier language.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage
Référence du fichier layouts/joomla/html/batch/language.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier languageaccess340.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier languageaccess340.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_languageaccess340_condition ()

Documentation des fonctions

◆ admin_postinstall_languageaccess340_condition()

admin_postinstall_languageaccess340_condition ( )

Checks if the installation is affected by the issue with content languages access in 3.4.0

https://github.com/joomla/joomla-cms/pull/6194 boolean 3.4.1

Références $db, $query, et Joomla\CMS\MVC\Model\getDbo().


Joomla CMS: Référence du fichier LanguageAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier LanguageAdapter.php

Structures de données

class LanguageAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier LanguageclientField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LanguageclientField.php

Structures de données

class LanguageclientField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Field


Joomla CMS: Référence du fichier languagecode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • languagecode
Structures de données | Espaces de nommage
Référence du fichier languagecode.php

Structures de données

class PlgSystemLanguagecode

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier LanguageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Controller/LanguageController.php

Structures de données

class LanguageController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier LanguageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier installation/src/Controller/LanguageController.php

Structures de données

class LanguageController

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Controller


Joomla CMS: Référence du fichier LanguageErrorsCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier LanguageErrorsCollector.php

Structures de données

class LanguageErrorsCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier LanguageFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier LanguageFactory.php

Structures de données

class LanguageFactory

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier LanguageFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier LanguageFactoryInterface.php

Structures de données

interface LanguageFactoryInterface

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier LanguageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Field
  • Installation
Structures de données | Espaces de nommage
Référence du fichier installation/src/Form/Field/Installation/LanguageField.php

Structures de données

class LanguageField

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Form\Field\Installation


Joomla CMS: Référence du fichier LanguageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Form/Field/LanguageField.php

Structures de données

class LanguageField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier LanguageFilesCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier LanguageFilesCollector.php

Structures de données

class LanguageFilesCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier languagefilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • languagefilter
Structures de données | Espaces de nommage
Référence du fichier languagefilter.php

Structures de données

class PlgSystemLanguageFilter

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier LanguageHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Helper/LanguageHelper.php

Structures de données

class LanguageHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Helper


Joomla CMS: Référence du fichier LanguageHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Language/LanguageHelper.php

Structures de données

class LanguageHelper

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier LanguageInflectorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier LanguageInflectorFactory.php

Structures de données

interface LanguageInflectorFactory

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier LanguageModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier LanguageModel.php

Structures de données

class LanguageModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Référence du fichier LanguageNegotiator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier LanguageNegotiator.php

Structures de données

class LanguageNegotiator

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier languages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • languages
Structures de données | Espaces de nommage
Référence du fichier languages.php

Structures de données

class PlgWebservicesLanguages

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Languages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Languages.php

Structures de données

class Languages

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Service\HTML


Joomla CMS: Référence du fichier LanguagesComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier LanguagesComponent.php

Structures de données

class LanguagesComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Extension


Joomla CMS: Référence du fichier LanguagesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Controller/LanguagesController.php

Structures de données

class LanguagesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier LanguagesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_languages/src/Controller/LanguagesController.php

Structures de données

class LanguagesController

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\Controller


Joomla CMS: Référence du fichier LanguagesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Helper/LanguagesHelper.php

Structures de données

class LanguagesHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Helper


Joomla CMS: Référence du fichier LanguagesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier modules/mod_languages/src/Helper/LanguagesHelper.php

Structures de données

class LanguagesHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Languages\Site\Helper


Joomla CMS: Référence du fichier LanguagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/Model/LanguagesModel.php

Structures de données

class LanguagesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier LanguagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Model/LanguagesModel.php

Structures de données

class LanguagesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Référence du fichier LanguagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier installation/src/Model/LanguagesModel.php

Structures de données

class LanguagesModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier LanguageStringsCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier LanguageStringsCollector.php

Structures de données

class LanguageStringsCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier LastvisitdaterangeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier LastvisitdaterangeField.php

Structures de données

class LastvisitdaterangeField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier LatestActionsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier LatestActionsHelper.php

Structures de données

class LatestActionsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\LatestActions\Administrator\Helper


Joomla CMS: Référence du fichier LatestHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier LatestHelper.php

Structures de données

class LatestHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Latest\Administrator\Helper


Joomla CMS: Référence du fichier LayoutHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Layout
Structures de données | Espaces de nommage
Référence du fichier LayoutHelper.php

Structures de données

class LayoutHelper

Espaces de nommage

Joomla\CMS\Layout


Joomla CMS: Référence du fichier LayoutInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Layout
Structures de données | Espaces de nommage
Référence du fichier LayoutInterface.php

Structures de données

interface LayoutInterface

Espaces de nommage

Joomla\CMS\Layout


Joomla CMS: Référence du fichier LazyAssertion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier LazyAssertion.php

Structures de données

class LazyAssertion

Espaces de nommage

Assert


Joomla CMS: Référence du fichier LazyAssertionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Structures de données | Espaces de nommage
Référence du fichier LazyAssertionException.php

Structures de données

class LazyAssertionException

Espaces de nommage

Assert


Joomla CMS: Référence du fichier LazyCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier LazyCommand.php

Structures de données

class LazyCommand

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier LazyServiceEventListener.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier LazyServiceEventListener.php

Structures de données

class LazyServiceEventListener

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier LazyString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier LazyString.php

Structures de données

class LazyString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier lcobucci-clock-polyfill.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • compat
Espaces de nommage
Référence du fichier lcobucci-clock-polyfill.php

Espaces de nommage

Lcobucci\Clock


Joomla CMS: Référence du fichier ldap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • ldap
Structures de données | Espaces de nommage
Référence du fichier ldap.php

Structures de données

class PlgAuthenticationLdap

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Ldap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
Structures de données | Espaces de nommage
Référence du fichier Ldap.php

Structures de données

class Ldap

Espaces de nommage

Symfony\Component\Ldap


Joomla CMS: Référence du fichier LdapAuthenticator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Structures de données | Espaces de nommage
Référence du fichier LdapAuthenticator.php

Structures de données

class LdapAuthenticator

Espaces de nommage

Symfony\Component\Ldap\Security


Joomla CMS: Référence du fichier LdapBadge.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Structures de données | Espaces de nommage
Référence du fichier LdapBadge.php

Structures de données

class LdapBadge

Espaces de nommage

Symfony\Component\Ldap\Security


Joomla CMS: Référence du fichier LdapClient.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • ldap
  • src
Structures de données | Espaces de nommage
Référence du fichier LdapClient.php

Structures de données

class LdapClient

Espaces de nommage

Joomla\Ldap


Joomla CMS: Référence du fichier LdapException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier LdapException.php

Structures de données

class LdapException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier LdapInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
Structures de données | Espaces de nommage
Référence du fichier LdapInterface.php

Structures de données

interface LdapInterface

Espaces de nommage

Symfony\Component\Ldap


Joomla CMS: Référence du fichier LdapUser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Structures de données | Espaces de nommage
Référence du fichier LdapUser.php

Structures de données

class LdapUser

Espaces de nommage

Symfony\Component\Ldap\Security


Joomla CMS: Référence du fichier LdapUserProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Structures de données | Espaces de nommage
Référence du fichier LdapUserProvider.php

Structures de données

class LdapUserProvider

Espaces de nommage

Symfony\Component\Ldap\Security


Joomla CMS: Référence du fichier LeewayCannotBeNegative.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier LeewayCannotBeNegative.php

Structures de données

class LeewayCannotBeNegative

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier LegacyComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier LegacyComponent.php

Structures de données

class LegacyComponent

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier LegacyComponentDispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier LegacyComponentDispatcher.php

Structures de données

class LegacyComponentDispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier LegacyFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Structures de données | Espaces de nommage
Référence du fichier LegacyFactory.php

Structures de données

class LegacyFactory

Espaces de nommage

Joomla\CMS\MVC\Factory


Joomla CMS: Référence du fichier LegacyInstallerScript.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier LegacyInstallerScript.php

Structures de données

class LegacyInstallerScript

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier LegacyModelLoaderTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Espaces de nommage
Référence du fichier LegacyModelLoaderTrait.php

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier LengthCalculator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier LengthCalculator.php

Structures de données

class LengthCalculator

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier LesserOrEqualsTo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier LesserOrEqualsTo.php

Structures de données

class LesserOrEqualsTo

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier LevelController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier LevelController.php

Structures de données

class LevelController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier LevelModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier LevelModel.php

Structures de données

class LevelModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier LevelsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/LevelsController.php

Structures de données

class LevelsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier LevelsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_users/src/Controller/LevelsController.php

Structures de données

class LevelsController

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\Controller


Joomla CMS: Référence du fichier LevelsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LevelsField.php

Structures de données

class LevelsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Field


Joomla CMS: Référence du fichier LevelsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier LevelsModel.php

Structures de données

class LevelsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier LibraryAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier LibraryAdapter.php

Structures de données

class LibraryAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier LibraryHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier LibraryHelper.php

Structures de données

class LibraryHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier LibraryManifest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Manifest
Structures de données | Espaces de nommage
Référence du fichier LibraryManifest.php

Structures de données

class LibraryManifest

Espaces de nommage

Joomla\CMS\Installer\Manifest


Joomla CMS: Référence du fichier libsodium.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier libsodium.php

Structures de données

class libsodium

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier LimitableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Structures de données | Espaces de nommage
Référence du fichier LimitableInterface.php

Structures de données

interface LimitableInterface

Espaces de nommage

Joomla\Database\Query


Joomla CMS: Référence du fichier LimitboxField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier LimitboxField.php

Structures de données

class LimitboxField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Structures de données | Espaces de nommage
Référence du fichier fig/link-util/src/Link.php

Structures de données

class Link

Espaces de nommage

Fig\Link


Joomla CMS: Référence du fichier Link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
Structures de données | Espaces de nommage
Référence du fichier symfony/web-link/Link.php

Structures de données

class Link

Espaces de nommage

Symfony\Component\WebLink


Joomla CMS: Référence du fichier link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Espaces de nommage | Variables
Référence du fichier links/link.php

Espaces de nommage

Joomla\Site

Variables

$id = empty($displayData['id']) ? '' : (' id="' . $displayData['id'] . '"')
$target = empty($displayData['target']) ? '' : (' target="' . $displayData['target'] . '"')
$rel = empty($displayData['rel']) ? '' : (' rel="' . $displayData['rel'] . '"')
$onclick = empty($displayData['onclick']) ? '' : (' onclick="' . $displayData['onclick'] . '"')
$title = empty($displayData['title']) ? '' : (' title="' . $this->escape($displayData['title']) . '"')
$text = empty($displayData['text']) ? '' : ('<span class="j-links-link">' . $displayData['text'] . '</span>')

Documentation des variables

◆ $id

$id = empty($displayData['id']) ? '' : (' id="' . $displayData['id'] . '"')

◆ $onclick

$onclick = empty($displayData['onclick']) ? '' : (' onclick="' . $displayData['onclick'] . '"')

◆ $rel

$rel = empty($displayData['rel']) ? '' : (' rel="' . $displayData['rel'] . '"')

◆ $target

$target = empty($displayData['target']) ? '' : (' target="' . $displayData['target'] . '"')

◆ $text

$text = empty($displayData['text']) ? '' : ('<span class="j-links-link">' . $displayData['text'] . '</span>')

◆ $title

$title = empty($displayData['title']) ? '' : (' title="' . $this->escape($displayData['title']) . '"')


Joomla CMS: Référence du fichier link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • pagination
Espaces de nommage | Variables
Référence du fichier pagination/link.php

Espaces de nommage

Joomla\Site

Variables

$item = $displayData['data']
$display = $item->text
$app = Factory::getApplication()
switch((string) $item->text) if($icon !==null) if($displayData['active']) else
if ( $displayData[ 'active'])
else __pad10__
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $display

$display = $item->text

Référencé par Symfony\Component\Console\Tester\getDisplay(), Symfony\Component\Console\Tester\getErrorOutput(), ProgressBar\initPlaceholderFormatters(), et Telephone\tel().

◆ $item

$item = $displayData['data']

◆ __pad10__

else __pad10__

◆ else

switch ((string) $item->text) if ( $icon !==null) if ( $displayData[ 'active']) else
Valeur initiale :
{
$class = (property_exists($item, 'active') && $item->active) ? 'active' : 'disabled'
$item
$item
Definition: pagination/link.php:16
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ endif

endif

◆ if

if($displayData['active'])


Joomla CMS: Référence du fichier link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier toolbar/link.php

Espaces de nommage

Joomla\Site

Variables

$margin = (strpos($url ?? '', 'index.php?option=com_config') === false) ? '' : 'ms-auto'
$target = empty($target) ? '' : 'target="' . $target . '"'

Documentation des variables

◆ $margin

$margin = (strpos($url ?? '', 'index.php?option=com_config') === false) ? '' : 'ms-auto'

Référencé par TextView\renderSection().

◆ $target

$target = empty($target) ? '' : 'target="' . $target . '"'


Joomla CMS: Référence du fichier LinkButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier LinkButton.php

Structures de données

class LinkButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier LinkController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier LinkController.php

Structures de données

class LinkController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Controller


Joomla CMS: Référence du fichier LinkInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
  • src
Structures de données | Espaces de nommage
Référence du fichier LinkInterface.php

Structures de données

interface LinkInterface

Espaces de nommage

Psr\Link


Joomla CMS: Référence du fichier LinkModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier LinkModel.php

Structures de données

class LinkModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Model


Joomla CMS: Référence du fichier LinkProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
  • src
Structures de données | Espaces de nommage
Référence du fichier LinkProviderInterface.php

Structures de données

interface LinkProviderInterface

Espaces de nommage

Psr\Link


Joomla CMS: Référence du fichier LinkProviderTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier LinkProviderTrait.php

Espaces de nommage

Fig\Link

Fonctions

getLinks ()
getLinksByRel ($rel)

Variables

trait LinkProviderTrait


Joomla CMS: Référence du fichier Links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Links.php

Structures de données

class Links

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier links.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • pagination
Espaces de nommage | Variables
Référence du fichier links.php

Espaces de nommage

Joomla\Site

Variables

$list = $displayData['list']
$pages = $list['pages']
$options = new Registry($displayData['options'])
$showLimitBox = $options->get('showLimitBox', false)
$showPagesLinks = $options->get('showPagesLinks', true)
$showLimitStart = $options->get('showLimitStart', true)
$currentPage = 1
$range = 1
$step = 5
endif
endforeach
if ( $showLimitStart)

Documentation des variables

◆ $currentPage

$currentPage = 1

◆ $list

$list = $displayData['list']

◆ $options

$options = new Registry($displayData['options'])

◆ $pages

$pages = $list['pages']

◆ $range

$range = 1

Référencé par NamePrep\applyCharacterMaps(), ActionlogsModel\buildDateRange(), UsersModel\buildDateRange(), UsersModel\getListQuery(), AbstractField\getRangeForExpression(), AbstractField\isInIncrementsOfRanges(), ParagonIE_Sodium_Compat\randombytes_uniform(), et AbstractField\validate().

◆ $showLimitBox

$showLimitBox = $options->get('showLimitBox', false)

◆ $showLimitStart

$showLimitStart = $options->get('showLimitStart', true)

◆ $showPagesLinks

$showPagesLinks = $options->get('showPagesLinks', true)

◆ $step

$step = 5

Référencé par ComponentAdapter\_rollback_menu(), Installer\abort(), Installer\copyFiles(), Language\getCallerInfo(), TimeField\getLayoutData(), IntegerField\getOptions(), PHP64\initialize(), PHP32\initialize(), AbstractField\isInIncrementsOfRanges(), SymfonyStyle\progressAdvance(), Installer\pushStep(), Engine\rootInner(), et AbstractField\validate().

◆ endforeach

endforeach

◆ endif

endif

◆ if

if($showLimitStart)


Joomla CMS: Référence du fichier LinksController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier LinksController.php

Structures de données

class LinksController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Controller


Joomla CMS: Référence du fichier LinksModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier LinksModel.php

Structures de données

class LinksModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Model


Joomla CMS: Référence du fichier LinksTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier LinksTrait.php

Espaces de nommage

Tobscure\JsonApi

Fonctions

getLinks ()
setLinks (array $links)
addLink ($key, $value)
addPaginationLinks ($url, array $queryParams, $offset, $limit, $total=null)
addPaginationLink ($name, $url, array $queryParams, $offset, $limit)

Variables

trait LinksTrait


Joomla CMS: Référence du fichier LinkStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier LinkStub.php

Structures de données

class LinkStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier LinkTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier com_finder/src/Table/LinkTable.php

Structures de données

class LinkTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Table


Joomla CMS: Référence du fichier LinkTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier com_redirect/src/Table/LinkTable.php

Structures de données

class LinkTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Table


Joomla CMS: Référence du fichier LinkTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier LinkTrait.php

Espaces de nommage

Fig\Link

Fonctions

getHref ()
isTemplated ()
getRels ()
getAttributes ()

Variables

trait LinkTrait
$href = ''
$rel = []
$attributes = []


Joomla CMS: Référence du fichier LintCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Command
Structures de données | Espaces de nommage
Référence du fichier LintCommand.php

Structures de données

class LintCommand

Espaces de nommage

Symfony\Component\Yaml\Command


Joomla CMS: Référence du fichier list-fancy-select.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier list-fancy-select.php

Espaces de nommage

Joomla\Site

Variables

$html = array()
$attr = ''
if($readonly|| $disabled) | $attr2 = ''
if($required) if($readonly) | else

Documentation des variables

◆ $attr

$attr = ''

◆ $attr2

$attr2 = ''

◆ $html

$html = array()

◆ else

if ( $required) if ( $readonly) else
Valeur initiale :
{
$html[] = HTMLHelper::_('select.genericlist', $options, $name, trim($attr), 'value', 'text', $value, $id)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$attr
$attr
Definition: list-fancy-select.php:51
$value
$value
Definition: com_contact/layouts/field/render.php:21
$html
$html
Definition: list-fancy-select.php:50
trim
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$options
$options
Definition: administrator/components/com_associations/tmpl/association/edit.php:27


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/methods/list.php

Espaces de nommage

Joomla\Administrator

Variables

$model = $this->getModel()
$canAddEdit = MfaHelper::canAddEditMethod($this->user)
$canDelete = MfaHelper::canDeleteMethod($this->user)
endifif ($method['canDisable'] && $canDelete) ('index.php?option=com_users &task=method.delete &id=' .(int) $record->id .($this->returnURL ? '&returnurl=' . $this->escape(urlencode($this->returnURL)) :'') . '&user_id=' . $this->user->id . '&' . Factory::getApplication() ->getFormToken() . '=1')?>" title
endif
endforeach

Documentation des variables

◆ $canAddEdit

$canAddEdit = MfaHelper::canAddEditMethod($this->user)

◆ $canDelete

$canDelete = MfaHelper::canDeleteMethod($this->user)

◆ $model

$model = $this->getModel()

◆ ($method['canDisable'] && $canDelete)

endifif ( $method[ 'canDisable'] &&$canDelete)( 'index.php?option=com_users &task=method.delete &id=' .(int) $record->id .( $this->returnURL ? '&returnurl=' . $this->escape(urlencode( $this->returnURL)) :'') . '&user_id=' . $this->user->id . '&' . Factory::getApplication() ->getFormToken() . '=1')?>" title
Valeur initiale :
="<?php echo Text::_('JACTION_DELETE') ?> <?php echo $this->escape($record->title); ?>">
<span class="icon icon-trash" aria-hidden="true"></span>
<span class="visually-hidden"><?php echo Text::_('JACTION_DELETE')

◆ endforeach

endforeach

◆ endif

if ($canAddEdit && (empty($method['active']) || $method['allowMultiple'])) ('index.php?option=com_users&task=method.add&method=' . $this->escape(urlencode($method['name'])) . ($this->returnURL ? '&returnurl=' . $this->escape(urlencode($this->returnURL)) : '') . '&user_id=' . $this->user->id)?>" class endif
Valeur initiale :
="com-users-methods-list-method-addnew btn btn-outline-primary btn-sm"
>
<span class="icon-plus-2" aria-hidden="true"></span>
<?php echo Text::sprintf('COM_USERS_MFA_ADD_AUTHENTICATOR_OF_TYPE', $method['display'])
$method
$method
Definition: administrator/components/com_users/tmpl/method/edit.php:29


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tag
Espaces de nommage | Variables
Référence du fichier components/com_tags/tmpl/tag/list.php

Espaces de nommage

Joomla\Site

Variables

$n = count($this->items)
$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'
endif
if ( $this->params->get( 'show_tag_title', 1))

Documentation des variables

◆ $htag

$htag = $this->params->get('show_page_heading') ? 'h2' : 'h1'

◆ $n

$n = count($this->items)

◆ endif

endif

◆ if

if($this->params->get('show_tag_title', 1))


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • methods
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/methods/list.php

Espaces de nommage

Joomla\Site

Variables

$model = $this->getModel()
$canAddEdit = MfaHelper::canAddEditMethod($this->user)
$canDelete = MfaHelper::canDeleteMethod($this->user)
endifif ($method['canDisable'] && $canDelete) ('index.php?option=com_users &task=method.delete &id=' .(int) $record->id .($this->returnURL ? '&returnurl=' . $this->escape(urlencode($this->returnURL)) :'') . '&user_id=' . $this->user->id . '&' . Factory::getApplication() ->getFormToken() . '=1')?>" title
endif
endforeach

Documentation des variables

◆ $canAddEdit

$canAddEdit = MfaHelper::canAddEditMethod($this->user)

◆ $canDelete

$canDelete = MfaHelper::canDeleteMethod($this->user)

◆ $model

$model = $this->getModel()

◆ ($method['canDisable'] && $canDelete)

endifif ( $method[ 'canDisable'] &&$canDelete)( 'index.php?option=com_users &task=method.delete &id=' .(int) $record->id .( $this->returnURL ? '&returnurl=' . $this->escape(urlencode( $this->returnURL)) :'') . '&user_id=' . $this->user->id . '&' . Factory::getApplication() ->getFormToken() . '=1')?>" title
Valeur initiale :
="<?php echo Text::_('JACTION_DELETE') ?> <?php echo $this->escape($record->title); ?>">
<span class="icon icon-trash" aria-hidden="true"></span>
<span class="visually-hidden"><?php echo Text::_('JACTION_DELETE')

◆ endforeach

endforeach

◆ endif

if ($canAddEdit && (empty($method['active']) || $method['allowMultiple'])) ('index.php?option=com_users&task=method.add&method=' . $this->escape(urlencode($method['name'])) . ($this->returnURL ? '&returnurl=' . $this->escape(urlencode($this->returnURL)) : '') . '&user_id=' . $this->user->id)?>" class endif
Valeur initiale :
="com-users-methods-list-method-addnew btn btn-outline-primary btn-sm"
>
<span class="icon-plus-2" aria-hidden="true"></span>
<?php echo Text::sprintf('COM_USERS_MFA_ADD_AUTHENTICATOR_OF_TYPE', $method['display'])
$method
$method
Definition: administrator/components/com_users/tmpl/method/edit.php:29


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/list.php

Espaces de nommage

Joomla\Site

Variables

$html = array()
$attr = ''
if($readonly|| $disabled) if($readonly) else
$listoptions ['option.key'] = 'value'
$listoptions ['option.text'] = 'text'
$listoptions ['list.select'] = $value
$listoptions ['id'] = $id
$listoptions ['list.translate'] = false
$listoptions ['option.attr'] = 'optionattr'
$listoptions ['list.attr'] = trim($attr)
$html [] = HTMLHelper::_('select.genericlist', $options, $name, $listoptions)

Documentation des variables

◆ $attr

$attr = ''

◆ $html [1/2]

$html = array()

◆ $html [2/2]

$html[] = HTMLHelper::_('select.genericlist', $options, $name, $listoptions)

◆ $listoptions [1/7]

$listoptions[ 'option.key'] = 'value'

◆ $listoptions [2/7]

$listoptions[ 'option.text'] = 'text'

◆ $listoptions [3/7]

$listoptions[ 'list.select'] = $value

◆ $listoptions [4/7]

$listoptions[ 'id'] = $id

◆ $listoptions [5/7]

$listoptions[ 'list.translate'] = false

◆ $listoptions [6/7]

$listoptions[ 'option.attr'] = 'optionattr'

◆ $listoptions [7/7]

$listoptions[ 'list.attr'] = trim($attr)

◆ else

if ( $readonly||$disabled) if ( $readonly) else
Valeur initiale :
{
$listoptions = array()
$listoptions
$listoptions['option.key']
Definition: layouts/joomla/form/field/list.php:85


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • pagination
Espaces de nommage | Variables
Référence du fichier layouts/joomla/pagination/list.php

Espaces de nommage

Joomla\Site

Variables

$list = $displayData['list']
foreach($list['pages'] as $page) endforeach

Documentation des variables

◆ $list

$list = $displayData['list']

◆ endforeach

foreach ( $list[ 'pages'] as $page) endforeach


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Espaces de nommage | Variables
Référence du fichier layouts/joomla/searchtools/default/list.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$list = $data['view']->filterForm->getGroup('list')
if ($list) ( $list as $fieldName=> $field)
endforeach
endif

Documentation des variables

◆ $data

$data = $displayData

◆ $list

$list = $data['view']->filterForm->getGroup('list')

◆ ($list)

if ( $list)($list as $fieldName=> $field)

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • list
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/list/list.php

Structures de données

class PlgFieldsList

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • list
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/list/tmpl/list.php

Espaces de nommage

Joomla\Plugin

Variables

$fieldValue = $field->value
$texts = array()
$options = $this->getOptionsFromField($field)
foreach ( $options as $value=> $name)

Documentation des variables

◆ $fieldValue

if ( $fieldValue=='') $fieldValue = $field->value

◆ $options

$options = $this->getOptionsFromField($field)

◆ $texts

$texts = array()

◆ foreach

foreach($options as $value=> $name)


Joomla CMS: Référence du fichier list_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tag
Espaces de nommage | Variables
Référence du fichier list_items.php

Espaces de nommage

Joomla\Site

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
endif
else __pad2__
foreach( $this->items as $i=> $item)($item->core_state==0) else
else __pad3__
endforeach

Documentation des variables

◆ $listDirn

else $listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

else $listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ else

foreach ($this->items as $i => $item) ( $item->core_state==0) else

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier ListCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Command
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Command/ListCommand.php

Structures de données

class ListCommand

Espaces de nommage

Joomla\Console\Command


Joomla CMS: Référence du fichier ListCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Command/ListCommand.php

Structures de données

class ListCommand

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier ListenersPriorityQueue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier ListenersPriorityQueue.php

Structures de données

class ListenersPriorityQueue

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier ListField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ListField.php

Structures de données

class ListField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ListHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier ListHelper.php

Structures de données

class ListHelper

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier ListModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier ListModel.php

Structures de données

class ListModel

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier ListModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier ListModelInterface.php

Structures de données

interface ListModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier ListObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier ListObject.php

Structures de données

class ListObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier ListUserCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier ListUserCommand.php

Structures de données

class ListUserCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ListView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier ListView.php

Structures de données

class ListView

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier loader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Structures de données | Fonctions
Référence du fichier loader.php

Structures de données

class JLoader

Fonctions

if(!function_exists('jexit')) jimport ($path, $base=null)

Documentation des fonctions

◆ jimport()

if (!function_exists( 'jexit')) jimport | ( | $path,
 |  | $base = null
 | ) |

Intelligent file importer.

Paramètres
string | $path | A dot syntax path.
string | $base | Search this directory for the class.
Renvoie
boolean True on success.
Depuis
1.7.0
Obsolète:
5.0 Classes should be autoloaded. Use JLoader::registerPrefix() or JLoader::registerNamespace() to register an autoloader for your files.

Global application exit.

This function provides a single exit point for the platform.

Paramètres
mixed $message Exit code or string. Defaults to zero.
Renvoie
void
Depuis
1.7.0

Références $base, $path, et JLoader\import().


Joomla CMS: Référence du fichier LoaderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Loader
Structures de données | Espaces de nommage
Référence du fichier LoaderInterface.php

Structures de données

interface LoaderInterface

Espaces de nommage

Joomla\Console\Loader


Joomla CMS: Référence du fichier loadmodule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • loadmodule
Structures de données | Espaces de nommage
Référence du fichier loadmodule.php

Structures de données

class PlgContentLoadmodule

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier local.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
  • local
Structures de données | Espaces de nommage
Référence du fichier local.php

Structures de données

class PlgFileSystemLocal

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier LocalAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
  • local
  • src
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier LocalAdapter.php

Structures de données

class LocalAdapter

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Filesystem\Local\Adapter


Joomla CMS: Référence du fichier LocalFileReference.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Key
Structures de données | Espaces de nommage
Référence du fichier LocalFileReference.php

Structures de données

class LocalFileReference

Espaces de nommage

Lcobucci\JWT\Signer\Key


Joomla CMS: Référence du fichier localise.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • language
  • en-GB
Structures de données | Espaces de nommage
Référence du fichier administrator/language/en-GB/localise.php

Structures de données

class En_GBLocalise

Espaces de nommage

Joomla\Language


Joomla CMS: Référence du fichier localise.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • language
  • fr-FR
Structures de données | Espaces de nommage
Référence du fichier administrator/language/fr-FR/localise.php

Structures de données

class Fr_FRLocalise

Espaces de nommage

Joomla\Language


Joomla CMS: Référence du fichier localise.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • language
  • en-GB
Structures de données | Espaces de nommage
Référence du fichier language/en-GB/localise.php

Structures de données

class En_GBLocalise

Espaces de nommage

Joomla\Language


Joomla CMS: Référence du fichier localise.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • language
  • fr-FR
Structures de données | Espaces de nommage
Référence du fichier language/fr-FR/localise.php

Structures de données

class Fr_FRLocalise

Espaces de nommage

Joomla\Language


Joomla CMS: Référence du fichier LocalizationCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier LocalizationCollector.php

Structures de données

class LocalizationCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier LocalStrategy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Strategies
Structures de données | Espaces de nommage
Référence du fichier LocalStrategy.php

Structures de données

class LocalStrategy

Espaces de nommage

Joomla\Authentication\Strategies


Joomla CMS: Référence du fichier LocationField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LocationField.php

Structures de données

class LocationField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Field


Joomla CMS: Référence du fichier LockableTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Espaces de nommage | Fonctions | Variables
Référence du fichier LockableTrait.php

Espaces de nommage

Symfony\Component\Console\Command

Fonctions

lock (string $name=null, bool $blocking=false)
release ()

Variables

trait LockableTrait


Joomla CMS: Référence du fichier log.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • log
Structures de données | Espaces de nommage
Référence du fichier log.php

Structures de données

class PlgSystemLog

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Log.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Structures de données | Espaces de nommage
Référence du fichier Log.php

Structures de données

class Log

Espaces de nommage

Joomla\CMS\Log


Joomla CMS: Référence du fichier LogcreatorField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LogcreatorField.php

Structures de données

class LogcreatorField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Field


Joomla CMS: Référence du fichier LogEntry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Structures de données | Espaces de nommage
Référence du fichier LogEntry.php

Structures de données

class LogEntry

Espaces de nommage

Joomla\CMS\Log


Joomla CMS: Référence du fichier LoggedHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier LoggedHelper.php

Structures de données

class LoggedHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Logged\Administrator\Helper


Joomla CMS: Référence du fichier Logger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Structures de données | Espaces de nommage
Référence du fichier Log/Logger.php

Structures de données

class Logger

Espaces de nommage

Joomla\CMS\Log


Joomla CMS: Référence du fichier Logger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/Logger.php

Structures de données

class Logger

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier LoggerAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier LoggerAwareInterface.php

Structures de données

interface LoggerAwareInterface

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier LoggerAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Espaces de nommage | Fonctions | Variables
Référence du fichier LoggerAwareTrait.php

Espaces de nommage

Psr\Log

Fonctions

setLogger (LoggerInterface $logger)

Variables

trait LoggerAwareTrait


Joomla CMS: Référence du fichier LoggerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier LoggerInterface.php

Structures de données

interface LoggerInterface

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier LoggerRegistry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Structures de données | Espaces de nommage
Référence du fichier LoggerRegistry.php

Structures de données

class LoggerRegistry

Espaces de nommage

Joomla\CMS\Log


Joomla CMS: Référence du fichier LoggerTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Espaces de nommage | Variables
Référence du fichier LoggerTrait.php

Espaces de nommage

Psr\Log

Variables

trait LoggerTrait


Joomla CMS: Référence du fichier LoggingMonitor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Monitor
Structures de données | Espaces de nommage
Référence du fichier LoggingMonitor.php

Structures de données

class LoggingMonitor

Espaces de nommage

Joomla\Database\Monitor


Joomla CMS: Référence du fichier LogicException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier LogicException.php

Structures de données

class LogicException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier login.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Espaces de nommage | Variables
Référence du fichier login.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$input = $app->input
$wa = $this->getWebAssetManager()
$option = $input->get('option', '')
$view = $input->get('view', '')
$layout = $input->get('layout', 'default')
$task = $input->get('task', 'display')
$logoBrandLarge
$loginLogo
$logoBrandSmall
$logoBrandLargeAlt
$logoBrandSmallAlt
$loginLogoAlt
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $input

$input = $app->input

◆ $layout

$layout = $input->get('layout', 'default')

◆ $loginLogo

$loginLogo
Valeur initiale :
= $this->params->get('loginLogo')
? Uri::root() . $this->params->get('loginLogo')
: Uri::root() . 'media/templates/administrator/atum/images/logos/login.svg'

◆ $loginLogoAlt

$loginLogoAlt
Valeur initiale :
= empty($this->params->get('loginLogoAlt')) && empty($this->params->get('emptyLoginLogoAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('loginLogoAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandLarge

$logoBrandLarge
Valeur initiale :
= $this->params->get('logoBrandLarge')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandLarge'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-large.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandLargeAlt

$logoBrandLargeAlt
Valeur initiale :
= empty($this->params->get('logoBrandLargeAlt')) && empty($this->params->get('emptyLogoBrandLargeAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandLargeAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $logoBrandSmall

$logoBrandSmall
Valeur initiale :
= $this->params->get('logoBrandSmall')
? Uri::root() . htmlspecialchars($this->params->get('logoBrandSmall'), ENT_QUOTES)
: Uri::root() . 'media/templates/administrator/atum/images/logos/brand-small.svg'
ENT_QUOTES
else ENT_QUOTES
Definition: administrator/modules/mod_latest/tmpl/default.php:40

◆ $logoBrandSmallAlt

$logoBrandSmallAlt
Valeur initiale :
= empty($this->params->get('logoBrandSmallAlt')) && empty($this->params->get('emptyLogoBrandSmallAlt'))
? 'alt=""'
: 'alt="' . htmlspecialchars($this->params->get('logoBrandSmallAlt'), ENT_COMPAT, 'UTF-8') . '"'
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28

◆ $option

$option = $input->get('option', '')

◆ $task

$task = $input->get('task', 'display')

◆ $view

$view = $input->get('view', '')

◆ $wa

$wa = $this->getWebAssetManager()

◆ width

$wa usePreset ( 'template.atum.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width =device-width


Joomla CMS: Référence du fichier LoginHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier administrator/modules/mod_login/src/Helper/LoginHelper.php

Structures de données

class LoginHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Login\Administrator\Helper


Joomla CMS: Référence du fichier LoginHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier modules/mod_login/src/Helper/LoginHelper.php

Structures de données

class LoginHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Login\Site\Helper


Joomla CMS: Référence du fichier LoginModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_login/src/Model/LoginModel.php

Structures de données

class LoginModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Login\Administrator\Model


Joomla CMS: Référence du fichier LoginModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Model/LoginModel.php

Structures de données

class LoginModel

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier LoginUniqueFieldRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier LoginUniqueFieldRule.php

Structures de données

class LoginUniqueFieldRule

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Rule


Joomla CMS: Référence du fichier LogLevel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier LogLevel.php

Structures de données

class LogLevel

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier logout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • logout
Structures de données | Espaces de nommage
Référence du fichier logout.php

Structures de données

class PlgSystemLogout

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier LogoutUniqueFieldRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Rule
Structures de données | Espaces de nommage
Référence du fichier LogoutUniqueFieldRule.php

Structures de données

class LogoutUniqueFieldRule

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Rule


Joomla CMS: Référence du fichier logrotation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • logrotation
Structures de données | Espaces de nommage
Référence du fichier logrotation.php

Structures de données

class PlgSystemLogrotation

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier logs.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier logs.html.php

Variables

$channelIsDefined = isset($logs[0]['channel'])

Documentation des variables

◆ $channelIsDefined

$channelIsDefined = isset($logs[0]['channel'])


Joomla CMS: Référence du fichier LogsdaterangeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LogsdaterangeField.php

Structures de données

class LogsdaterangeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Field


Joomla CMS: Référence du fichier LogtypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier LogtypeField.php

Structures de données

class LogtypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Field


Joomla CMS: Référence du fichier lowerCase.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
  • Resources
  • unidata
Référence du fichier lowerCase.php


Joomla CMS: Référence du fichier Mac.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Structures de données | Espaces de nommage
Référence du fichier Mac.php

Structures de données

interface Mac

Espaces de nommage

Cose\Algorithm\Mac


Joomla CMS: Référence du fichier MacAlgorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Algorithm
Structures de données | Espaces de nommage
Référence du fichier MacAlgorithm.php

Structures de données

interface MacAlgorithm

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Mail.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
Structures de données | Espaces de nommage
Référence du fichier Mail.php

Structures de données

class Mail

Espaces de nommage

Joomla\CMS\Mail


Joomla CMS: Référence du fichier MailController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier MailController.php

Structures de données

class MailController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier MailDisabledException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MailDisabledException.php

Structures de données

class MailDisabledException

Espaces de nommage

Joomla\CMS\Mail\Exception


Joomla CMS: Référence du fichier MailHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
Structures de données | Espaces de nommage
Référence du fichier MailHelper.php

Structures de données

class MailHelper

Espaces de nommage

Joomla\CMS\Mail


Joomla CMS: Référence du fichier MailModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MailModel.php

Structures de données

class MailModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier MailsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MailsHelper.php

Structures de données

class MailsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Helper


Joomla CMS: Référence du fichier MailTemplate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
Structures de données | Espaces de nommage
Référence du fichier MailTemplate.php

Structures de données

class MailTemplate

Espaces de nommage

Joomla\CMS\Mail


Joomla CMS: Référence du fichier main.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Espaces de nommage | Variables
Référence du fichier main.php

Espaces de nommage

Joomla\Site

Variables

$modalClasses = array('modal')
if(!isset($params['animation'])|| $params['animation']) | $modalWidth = isset($params['modalWidth']) ? round((int) $params['modalWidth'], -1) : ''
$modalDialogClass = ''
if($modalWidth && $modalWidth > 0 && $modalWidth<=100) | $modalAttributes
if(isset($params['backdrop'])) if(isset($params['keyboard'])) | if (isset( $params[ 'url']))
if (!isset( $params[ 'closeButton'])||isset( $params[ 'title'])||$params[ 'closeButton'])

Documentation des variables

◆ $modalAttributes

if ( $modalWidth &&$modalWidth > 0 &&$modalWidth<=100) $modalAttributes
Valeur initiale :
= array(
'tabindex' => '-1',
'class' => 'joomla-modal ' . implode(' ', $modalClasses)
)
implode
$modalClasses
$modalClasses
Definition: main.php:38

◆ $modalClasses

$modalClasses = array('modal')

◆ $modalDialogClass

$modalDialogClass = ''

◆ $modalWidth

if (!isset( $params[ 'animation'])||$params[ 'animation']) $modalWidth = isset($params['modalWidth']) ? round((int) $params['modalWidth'], -1) : ''

Référencé par PopupButton\fetchButton(), ToolbarHelper\jooa11y(), et ToolbarHelper\preview().

◆ if [1/2]

if (isset( $params[ 'backdrop'])) if (isset( $params[ 'keyboard'])) if(isset($params['url']))

◆ if [2/2]

if(!isset($params['closeButton'])||isset($params['title'])|| $params['closeButton'])


Joomla CMS: Référence du fichier manage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
  • webauthn
Espaces de nommage | Variables
Référence du fichier manage.php

Espaces de nommage

Joomla\Plugin

Variables

try
$loggedInUser = $app->getIdentity()
catch(Exception $e) $defaultDisplayData
if ( $attestationSupport)
$authMetadata = $knownAuthenticators[$aaguid->toString()] ?? $knownAuthenticators['']

Documentation des variables

◆ $authMetadata

$authMetadata = $knownAuthenticators[$aaguid->toString()] ?? $knownAuthenticators['']

◆ $defaultDisplayData

catch (Exception $e) $defaultDisplayData
Valeur initiale :
= [
'user' => $loggedInUser
$loggedInUser
$loggedInUser
Definition: manage.php:41

◆ $loggedInUser

$loggedInUser = $app->getIdentity()

Référencé par Joomla\onUserAfterLogin(), et Joomla\onUserLoginFailure().

◆ if

if($attestationSupport)

◆ try

try
Valeur initiale :
{
$app = Factory::getApplication()
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier Manage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Manage.php

Structures de données

class Manage

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Service\HTML


Joomla CMS: Référence du fichier ManageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/src/Controller/ManageController.php

Structures de données

class ManageController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier ManageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_installer/src/Controller/ManageController.php

Structures de données

class ManageController

Espaces de nommage

Joomla\API
Joomla\Component\Installer\Api\Controller


Joomla CMS: Référence du fichier ManageModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ManageModel.php

Structures de données

class ManageModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier Manager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier typo3/phar-stream-wrapper/src/Manager.php

Structures de données

class Manager

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier Manager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Manager.php

Structures de données

class Manager

Espaces de nommage

Cose\Algorithm


Joomla CMS: Référence du fichier ManagerFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
Structures de données | Espaces de nommage
Référence du fichier ManagerFactory.php

Structures de données

class ManagerFactory

Espaces de nommage

Cose\Algorithm


Joomla CMS: Référence du fichier Manifest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Structures de données | Espaces de nommage
Référence du fichier src/Installer/Manifest.php

Structures de données

class Manifest

Espaces de nommage

Joomla\CMS\Installer


Joomla CMS: Référence du fichier Manifest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier vendor/typo3/phar-stream-wrapper/src/Phar/Manifest.php

Structures de données

class Manifest

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier MapItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier MapItem.php

Structures de données

class MapItem

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier MapObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier MapObject.php

Structures de données

class MapObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier MapsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier MapsController.php

Structures de données

class MapsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier MapsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MapsModel.php

Structures de données

class MapsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier MapTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MapTable.php

Structures de données

class MapTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Table


Joomla CMS: Référence du fichier MarkdownDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier MarkdownDescriptor.php

Structures de données

class MarkdownDescriptor

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier marshal_headers_from_sapi.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_headers_from_sapi.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

marshalHeadersFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_headers_from_sapi.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_headers_from_sapi.php

Espaces de nommage

Laminas\Diactoros

Fonctions

marshalHeadersFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_method_from_sapi.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_method_from_sapi.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

marshalMethodFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_method_from_sapi.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_method_from_sapi.php

Espaces de nommage

Laminas\Diactoros

Fonctions

marshalMethodFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_protocol_version_from_sapi.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_protocol_version_from_sapi.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

marshalProtocolVersionFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_protocol_version_from_sapi.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_protocol_version_from_sapi.php

Espaces de nommage

Laminas\Diactoros

Fonctions

marshalProtocolVersionFromSapi (array $server)


Joomla CMS: Référence du fichier marshal_uri_from_sapi.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_uri_from_sapi.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

marshalUriFromSapi (array $server, array $headers)


Joomla CMS: Référence du fichier marshal_uri_from_sapi.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier marshal_uri_from_sapi.php

Espaces de nommage

Laminas\Diactoros

Fonctions

marshalUriFromSapi (array $server, array $headers)


Joomla CMS: Référence du fichier MaskGenAlgorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier MaskGenAlgorithm.php

Structures de données

class MaskGenAlgorithm

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier MathException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MathException.php

Structures de données

class MathException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier Mbstring.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
Structures de données | Espaces de nommage
Référence du fichier Mbstring.php

Structures de données

class Mbstring

Espaces de nommage

Symfony\Polyfill\Mbstring


Joomla CMS: Référence du fichier Mcrypt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
  • AES
Structures de données | Espaces de nommage
Référence du fichier Mcrypt.php

Structures de données

class Mcrypt

Espaces de nommage

Joomla\CMS\Encrypt\AES


Joomla CMS: Référence du fichier MD5Handler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier MD5Handler.php

Structures de données

class MD5Handler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/helpers/media.php

Structures de données

class MediaHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/media.php

Espaces de nommage

Joomla\Admin

Variables

$attr = ''
switch($preview) if($showPreview) | $url
$doc = Factory::getDocument()
$wam = $doc->getWebAssetManager()
$modalHTML
if(count($doc->getScriptOptions('media-picker'))===0) base | path

Documentation des variables

◆ $attr

$attr = ''

◆ $doc

$doc = Factory::getDocument()

◆ $modalHTML

$modalHTML
Valeur initiale :
= HTMLHelper::_(
'bootstrap.renderModal',
'imageModal_' . $id,
[
'url' => $url,
'title' => Text::_('JLIB_FORM_CHANGE_IMAGE'),
'closeButton' => true,
'height' => '100%',
'width' => '100%',
'modalWidth' => '80',
'bodyHeight' => '60',
'footer' => '<button type="button" class="btn btn-success button-save-selected">' . Text::_('JSELECT') . '</button>'
. '<button type="button" class="btn btn-secondary" data-bs-dismiss="modal">' . Text::_('JCANCEL') . '</button>',
]
)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$url
switch($preview) if($showPreview) $url
Definition: layouts/joomla/form/field/media.php:109

◆ $url

$url
Valeur initiale :
= ($readonly ? ''
: ($link ?: 'index.php?option=com_media&view=media&tmpl=component&mediatypes=' . $mediaTypes
. '&asset=' . $asset . '&author=' . $authorId)
. '&fieldid={field-media-id}&path=' . $folder)
$folder
$folder
Definition: mod_random_image.php:17
$link
$link
Definition: administrator/components/com_menus/tmpl/items/modal.php:35
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$mediaTypes
if($tmpl=='component') $mediaTypes
Definition: administrator/components/com_media/tmpl/file/default.php:46

◆ $wam

$wam = $doc->getWebAssetManager()

Référencé par ScriptsRenderer\render(), et StylesRenderer\render().

◆ path

string $preview The preview image relative path
Valeur initiale :
="<?php echo Uri::root(); ?>"
root-folder="<?php echo ComponentHelper::getParams('com_media')->get('file_path', 'images'); ?>"
url="<?php echo $url; ?>"
modal-container=".modal"
modal-width="100%"
modal-height="400px"
input=".field-media-input"
button-select=".button-select"
button-clear=".button-clear"
button-save-selected=".button-save-selected"
preview="static"
preview-container=".field-media-preview"
preview-width="<?php echo $previewWidth; ?>"
preview-height="<?php echo $previewHeight; ?>"
supported-extensions="<?php echo str_replace('"', '&quot
width
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width
Definition: error_full.php:73
Joomla\Database\Query\clear
clear($clause=null)
Definition: PostgresqlQueryBuilder.php:246
modal
if($class) if($size) if($required) if(! $readonly) if(! $readonly)< joomla-field-user class="field-user-wrapper" url="<?php echo (string) $uri; ?> modal
Definition: layouts/joomla/form/field/user.php:114

Référencé par Uri\__construct(), FormattedtextLogger\__construct(), RouterViewConfiguration\__construct(), FormattedtextLogger\__destruct(), Uri\__toString(), Stream\_stream_open(), Stream\_stream_read(), Stream\_stream_stat(), Stream\_stream_write(), FormattedtextLogger\addEntry(), TagTable\check(), Menu\check(), DumpCompletionCommand\configure(), InstalledModel\getPath(), LanguagesModel\getPath(), PlgSampledataMultilang\getPath(), FormattedtextLogger\initFile(), Image\loadFile(), MenusHelper\loadPreset(), PlgButtonReadmore\onDisplay(), Uri\parseUri(), Nested\rebuildPath(), AbstractUri\render(), RouterViewConfiguration\setName(), RouterViewConfiguration\setParent(), Uri\setPath(), et Uri\withPath().


Joomla CMS: Référence du fichier media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • media
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/media/media.php

Structures de données

class PlgFieldsMedia

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • media
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/media/tmpl/media.php

Espaces de nommage

Joomla\Plugin

Variables

if(empty($field->value)||empty($field->value['imagefile'])) $class = $fieldParams->get('image_class')
$options
if ( $class)

Documentation des variables

◆ $class

if (empty( $field->value)||empty( $field->value[ 'imagefile'])) $class = $fieldParams->get('image_class')

◆ $options

$options
Valeur initiale :
= [
'src' => $field->value['imagefile']
$field
$field
Definition: administrator/components/com_users/tmpl/users/modal.php:24

◆ if

if($class)
Valeur initiale :
=> empty($field->value['alt_text']) && empty($field->value['alt_empty']) ? false : $field->value['alt_text'],
]
$field
$field
Definition: administrator/components/com_users/tmpl/users/modal.php:24
false
return false
Definition: com_menus/tmpl/items/default_batch_footer.php:24


Joomla CMS: Référence du fichier media.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • media
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/media/media.php

Structures de données

class PlgWebservicesMedia

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier MediaActionPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier MediaActionPlugin.php

Structures de données

class MediaActionPlugin

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Plugin


Joomla CMS: Référence du fichier MediaController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier MediaController.php

Structures de données

class MediaController

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Controller


Joomla CMS: Référence du fichier MediaField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier MediaField.php

Structures de données

class MediaField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier MediaHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MediaHelper.php

Structures de données

class MediaHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier MediaModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/src/Model/MediaModel.php

Structures de données

class MediaModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Model


Joomla CMS: Référence du fichier MediaModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier api/components/com_media/src/Model/MediaModel.php

Structures de données

class MediaModel

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Model


Joomla CMS: Référence du fichier MediaProviderEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier MediaProviderEvent.php

Structures de données

class MediaProviderEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier MediaRssParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
  • Rss
Structures de données | Espaces de nommage
Référence du fichier MediaRssParser.php

Structures de données

class MediaRssParser

Espaces de nommage

Joomla\CMS\Feed\Parser\Rss


Joomla CMS: Référence du fichier MediumModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MediumModel.php

Structures de données

class MediumModel

Espaces de nommage

Joomla\API
Joomla\Component\Media\Api\Model


Joomla CMS: Référence du fichier MemcachedCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier MemcachedCaster.php

Structures de données

class MemcachedCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier MemcachedHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier MemcachedHandler.php

Structures de données

class MemcachedHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier MemcachedStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier src/Cache/Storage/MemcachedStorage.php

Structures de données

class MemcachedStorage

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier MemcachedStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Structures de données | Espaces de nommage
Référence du fichier vendor/maximebf/debugbar/src/DebugBar/Storage/MemcachedStorage.php

Structures de données

class MemcachedStorage

Espaces de nommage

DebugBar\Storage


Joomla CMS: Référence du fichier MemoryCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier MemoryCollector.php

Structures de données

class MemoryCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • menu
Structures de données | Espaces de nommage
Référence du fichier menu.php

Structures de données

class PlgButtonMenu

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier administrator/modules/mod_submenu/src/Menu/Menu.php

Structures de données

class Menu

Espaces de nommage

Joomla\Administrator
Joomla\Module\Submenu\Administrator\Menu


Joomla CMS: Référence du fichier Menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier libraries/src/HTML/Helpers/Menu.php

Structures de données

class Menu

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Menu.php

Structures de données

class Menu

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier Menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Table/Menu.php

Structures de données

class Menu

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier MenuController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier MenuController.php

Structures de données

class MenuController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier MenuFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier MenuFactory.php

Structures de données

class MenuFactory

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier MenuFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier MenuFactoryInterface.php

Structures de données

interface MenuFactoryInterface

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier MenuField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/Field/Modal/MenuField.php

Structures de données

class MenuField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field\Modal


Joomla CMS: Référence du fichier MenuField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Form/Field/MenuField.php

Structures de données

class MenuField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier MenuHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MenuHelper.php

Structures de données

class MenuHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Menu\Site\Helper


Joomla CMS: Référence du fichier MenuItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier MenuItem.php

Structures de données

class MenuItem

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier MenuItemByTypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenuItemByTypeField.php

Structures de données

class MenuItemByTypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field


Joomla CMS: Référence du fichier MenuitemField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenuitemField.php

Structures de données

class MenuitemField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier MenuModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MenuModel.php

Structures de données

class MenuModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Model


Joomla CMS: Référence du fichier MenuOrderingField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenuOrderingField.php

Structures de données

class MenuOrderingField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field


Joomla CMS: Référence du fichier MenuParentField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenuParentField.php

Structures de données

class MenuParentField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field


Joomla CMS: Référence du fichier MenuPresetField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenuPresetField.php

Structures de données

class MenuPresetField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field


Joomla CMS: Référence du fichier MenuRules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
  • Rules
Structures de données | Espaces de nommage
Référence du fichier MenuRules.php

Structures de données

class MenuRules

Espaces de nommage

Joomla\CMS\Component\Router\Rules


Joomla CMS: Référence du fichier Menus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Menus.php

Structures de données

class Menus

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Service\HTML


Joomla CMS: Référence du fichier menus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/helpers/menus.php

Structures de données

class MenusHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier menus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • menus
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/menus/menus.php

Structures de données

class PlgWebservicesMenus

Espaces de nommage

Joomla\Menus


Joomla CMS: Référence du fichier MenusComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier MenusComponent.php

Structures de données

class MenusComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Extension


Joomla CMS: Référence du fichier MenusController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/src/Controller/MenusController.php

Structures de données

class MenusController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Controller


Joomla CMS: Référence du fichier MenusController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_menus/src/Controller/MenusController.php

Structures de données

class MenusController

Espaces de nommage

Joomla\API
Joomla\Component\Menus\Api\Controller


Joomla CMS: Référence du fichier MenusHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MenusHelper.php

Structures de données

class MenusHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Helper


Joomla CMS: Référence du fichier MenusModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MenusModel.php

Structures de données

class MenusModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Model


Joomla CMS: Référence du fichier MenuTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MenuTable.php

Structures de données

class MenuTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Table


Joomla CMS: Référence du fichier MenuType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MenuType.php

Structures de données

class MenuType

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier MenutypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MenutypeField.php

Structures de données

class MenutypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Field


Joomla CMS: Référence du fichier MenutypesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MenutypesModel.php

Structures de données

class MenutypesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Model


Joomla CMS: Référence du fichier MenuTypeTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MenuTypeTable.php

Structures de données

class MenuTypeTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\Table


Joomla CMS: Référence du fichier message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • system
Espaces de nommage | Variables
Référence du fichier layouts/joomla/system/message.php

Espaces de nommage

Joomla\Site

Variables

$msgList = $displayData['msgList']
$document = Factory::getDocument()
$msgOutput = ''
$alert
if (is_array( $msgList) &&!empty( $msgList))

Documentation des variables

◆ $alert

$alert
Valeur initiale :
= [
CMSApplication::MSG_EMERGENCY => 'danger'

Référencé par ConfirmButton\_getCommand(), StandardButton\_getCommand(), et HtmlView\addToolbar().

◆ $document

$document = Factory::getDocument()

◆ $msgList

$msgList = $displayData['msgList']

Référencé par MessageRenderer\render().

◆ $msgOutput

$msgOutput = ''

◆ if

if(is_array($msgList) &&!empty($msgList))


Joomla CMS: Référence du fichier message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
  • privacyconsent
Espaces de nommage
Référence du fichier layouts/plugins/system/privacyconsent/message.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
  • terms
Espaces de nommage
Référence du fichier layouts/plugins/user/terms/message.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • message
Structures de données | Espaces de nommage
Référence du fichier plugins/privacy/message/message.php

Structures de données

class PlgPrivacyMessage

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier message.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
Espaces de nommage
Référence du fichier plugins/system/stats/layouts/message.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier MessageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_messages/src/Controller/MessageController.php

Structures de données

class MessageController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Controller


Joomla CMS: Référence du fichier MessageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_postinstall/src/Controller/MessageController.php

Structures de données

class MessageController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Postinstall\Administrator\Controller


Joomla CMS: Référence du fichier MessageFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier MessageFactory.php

Structures de données

interface MessageFactory

Espaces de nommage

Http\Message


Joomla CMS: Référence du fichier MessageInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier MessageInterface.php

Structures de données

interface MessageInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier MessageModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier MessageModel.php

Structures de données

class MessageModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Model


Joomla CMS: Référence du fichier MessagequeueLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier MessagequeueLogger.php

Structures de données

class MessagequeueLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier MessageRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier MessageRenderer.php

Structures de données

class MessageRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier messages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • messages
Structures de données | Espaces de nommage
Référence du fichier messages.php

Structures de données

class PlgWebservicesMessages

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Messages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Messages.php

Structures de données

class Messages

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Service\HTML


Joomla CMS: Référence du fichier MessagesAggregateInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier MessagesAggregateInterface.php

Structures de données

interface MessagesAggregateInterface

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier MessagesCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier MessagesCollector.php

Structures de données

class MessagesCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier MessagesComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier MessagesComponent.php

Structures de données

class MessagesComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Extension


Joomla CMS: Référence du fichier MessagesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/src/Controller/MessagesController.php

Structures de données

class MessagesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Controller


Joomla CMS: Référence du fichier MessagesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_messages/src/Controller/MessagesController.php

Structures de données

class MessagesController

Espaces de nommage

Joomla\API
Joomla\Component\Messages\Api\Controller


Joomla CMS: Référence du fichier MessagesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MessagesHelper.php

Structures de données

class MessagesHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Helper


Joomla CMS: Référence du fichier MessagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_messages/src/Model/MessagesModel.php

Structures de données

class MessagesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Model


Joomla CMS: Référence du fichier MessagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_postinstall/src/Model/MessagesModel.php

Structures de données

class MessagesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Postinstall\Administrator\Model


Joomla CMS: Référence du fichier MessageStatesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier MessageStatesField.php

Structures de données

class MessageStatesField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Field


Joomla CMS: Référence du fichier MessageTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MessageTable.php

Structures de données

class MessageTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Table


Joomla CMS: Référence du fichier MessageTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier laminas/laminas-diactoros/src/MessageTrait.php

Espaces de nommage

Laminas\Diactoros

Fonctions

getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($header)
getHeader ($header)
getHeaderLine ($name)
withHeader ($header, $value)
withAddedHeader ($header, $value)
withoutHeader ($header)
getBody ()
withBody (StreamInterface $body)
getStream ($stream, string $modeIfNotInstance)
setHeaders (array $originalHeaders)
validateProtocolVersion ($version)
filterHeaderValue ($values)
assertHeader ($name)

Variables

trait MessageTrait
$headerNames = []
$protocol = '1.1'
$stream


Joomla CMS: Référence du fichier MessageTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier nyholm/psr7/src/MessageTrait.php

Espaces de nommage

Nyholm\Psr7

Fonctions

getProtocolVersion ()
withProtocolVersion ($version)
getHeaders ()
hasHeader ($header)
getHeader ($header)
getHeaderLine ($header)
withHeader ($header, $value)
withAddedHeader ($header, $value)
withoutHeader ($header)
getBody ()
withBody (StreamInterface $body)
setHeaders (array $headers)
validateAndTrimHeader ($header, $values)

Variables

trait MessageTrait
$headerNames = []
$protocol = '1.1'
$stream


Joomla CMS: Référence du fichier metadata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier metadata.php

Espaces de nommage

Joomla\Site

Variables

$form = $displayData->getForm()
$fieldSets = $form->getFieldsets('metadata')
endif
if($name==='jmetadata') foreach($form->getFieldset($name) as $field) endforeach

Documentation des variables

◆ $fieldSets

$fieldSets = $form->getFieldsets('metadata')

◆ $form

$form = $displayData->getForm()

◆ endforeach

if ( $name==='jmetadata') foreach ( $form->getFieldset( $name) as $field) endforeach

◆ endif

endif


Joomla CMS: Référence du fichier MetadataManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
Structures de données | Espaces de nommage
Référence du fichier MetadataManager.php

Structures de données

class MetadataManager

Espaces de nommage

Joomla\CMS\Session


Joomla CMS: Référence du fichier MetadataManagerListener.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • EventListener
Structures de données | Espaces de nommage
Référence du fichier MetadataManagerListener.php

Structures de données

class MetadataManagerListener

Espaces de nommage

Joomla\CMS\Session\EventListener


Joomla CMS: Référence du fichier MetadataRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataRepository.php

Structures de données

class MetadataRepository

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn


Joomla CMS: Référence du fichier MetadataService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataService.php

Structures de données

class MetadataService

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataServiceFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataServiceFactory.php

Structures de données

class MetadataServiceFactory

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataStatement.php

Structures de données

class MetadataStatement

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataStatementFetcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataStatementFetcher.php

Structures de données

class MetadataStatementFetcher

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataStatementRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataStatementRepository.php

Structures de données

interface MetadataStatementRepository

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataTOCPayload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataTOCPayload.php

Structures de données

class MetadataTOCPayload

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetadataTOCPayloadEntry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier MetadataTOCPayloadEntry.php

Structures de données

class MetadataTOCPayloadEntry

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier MetasRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier MetasRenderer.php

Structures de données

class MetasRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier MetaTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier MetaTrait.php

Espaces de nommage

Tobscure\JsonApi

Fonctions

getMeta ()
setMeta (array $meta)
addMeta ($key, $value)

Variables

trait MetaTrait


Joomla CMS: Référence du fichier meter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier meter.php

Espaces de nommage

Joomla\Site

Variables

$class = 'progress-bar ' . $class
$value = (float) $value
$data = ''
$attributes

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
$class,
!empty($width) ? ' style="width:' . $width . ';"' : '',
$data,
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$width
$width
Definition: modules/mod_banners/tmpl/default.php:34
$class
$class
Definition: meter.php:54
$data
$data
Definition: meter.php:63

◆ $class

$class = 'progress-bar ' . $class

◆ $data

$data = ''

◆ $value

$value = (float) $value


Joomla CMS: Référence du fichier MeterField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier MeterField.php

Structures de données

class MeterField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier MethodController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/MethodController.php

Structures de données

class MethodController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier MethodController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/MethodController.php

Structures de données

class MethodController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier MethodDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • DataShape
Structures de données | Espaces de nommage
Référence du fichier MethodDescriptor.php

Structures de données

class MethodDescriptor

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\DataShape


Joomla CMS: Référence du fichier MethodModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Model/MethodModel.php

Structures de données

class MethodModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier MethodModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Model/MethodModel.php

Structures de données

class MethodModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier MethodNotAllowedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MethodNotAllowedException.php

Structures de données

class MethodNotAllowedException

Espaces de nommage

Joomla\Router\Exception


Joomla CMS: Référence du fichier MethodsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/MethodsController.php

Structures de données

class MethodsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier MethodsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/MethodsController.php

Structures de données

class MethodsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier MethodsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Model/MethodsModel.php

Structures de données

class MethodsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier MethodsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Model/MethodsModel.php

Structures de données

class MethodsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier Mfa.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier Mfa.php

Structures de données

class Mfa

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Helper


Joomla CMS: Référence du fichier MfaTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier MfaTable.php

Structures de données

class MfaTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Table


Joomla CMS: Référence du fichier Microdata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Microdata
Structures de données | Espaces de nommage
Référence du fichier Microdata.php

Structures de données

class Microdata

Espaces de nommage

Joomla\CMS\Microdata


Joomla CMS: Référence du fichier MinutesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier MinutesField.php

Structures de données

class MinutesField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier MissingComponentException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MissingComponentException.php

Structures de données

class MissingComponentException

Espaces de nommage

Joomla\CMS\Component\Exception


Joomla CMS: Référence du fichier MissingInputException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MissingInputException.php

Structures de données

class MissingInputException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier MissingOptionsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier MissingOptionsException.php

Structures de données

class MissingOptionsException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier Mixin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
  • assert
  • src
Espaces de nommage
Référence du fichier Mixin.php

Espaces de nommage

Webmozart\Assert


Joomla CMS: Référence du fichier mod_articles_archive.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
Espaces de nommage | Variables
Référence du fichier mod_articles_archive.php

Espaces de nommage

Joomla\Site

Variables

$list = ArticlesArchiveHelper::getList($params)

Documentation des variables

◆ $list

$list = ArticlesArchiveHelper::getList($params)


Joomla CMS: Référence du fichier mod_articles_categories.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
Espaces de nommage | Variables
Référence du fichier mod_articles_categories.php

Espaces de nommage

Joomla\Site

Variables

$cacheid = md5($module->id)
$cacheparams = new \stdClass()
$cacheparams | cachemode = 'id'
$cacheparams | method = 'getList'
$cacheparams | methodparams = $params
$cacheparams | modeparams = $cacheid
$list = ModuleHelper::moduleCache($module, $params, $cacheparams)
$startLevel = $list ? reset($list)->getParent()->level : null

Documentation des variables

◆ $cacheid

$cacheid = md5($module->id)

◆ $cacheparams

$cacheparams = new \stdClass()

Référencé par ModuleRenderer\render().

◆ $list

$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

◆ $startLevel

$startLevel = $list ? reset($list)->getParent()->level : null

◆ cachemode

$cacheparams cachemode = 'id'

◆ method

$cacheparams method = 'getList'

◆ methodparams

$cacheparams methodparams = $params

◆ modeparams

$cacheparams modeparams = $cacheid


Joomla CMS: Référence du fichier mod_articles_category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
Espaces de nommage | Variables
Référence du fichier mod_articles_category.php

Espaces de nommage

Joomla\Site

Variables

$input = $app->input
$mode = $params->get('mode', 'normal')
$idbase = null
switch($mode) | $cacheid = md5(serialize(array ($idbase, $module->module, $module->id)))
$cacheparams = new \stdClass()
$cacheparams | cachemode = 'id'
$cacheparams | method = 'getList'
$cacheparams | methodparams = $params
$cacheparams | modeparams = $cacheid
$list = ModuleHelper::moduleCache($module, $params, $cacheparams)
$article_grouping = $params->get('article_grouping', 'none')
$article_grouping_direction = $params->get('article_grouping_direction', 'ksort')
$grouped = $article_grouping !== 'none'
if ( $list &&$grouped)

Documentation des variables

◆ $article_grouping

$article_grouping = $params->get('article_grouping', 'none')

◆ $article_grouping_direction

$article_grouping_direction = $params->get('article_grouping_direction', 'ksort')

◆ $cacheid

switch ( $mode) $cacheid = md5(serialize(array ($idbase, $module->module, $module->id)))

◆ $cacheparams

$cacheparams = new \stdClass()

◆ $grouped

$grouped = $article_grouping !== 'none'

Référencé par Normalise\fromCamelCase(), ArticlesCategoryHelper\groupBy(), ArticlesCategoryHelper\groupByDate(), et ArticlesCategoryHelper\groupByTags().

◆ $idbase

$idbase = null

◆ $input

$input = $app->input

◆ $list

$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

◆ $mode

$mode = $params->get('mode', 'normal')

◆ cachemode

$cacheparams cachemode = 'id'

◆ if

if($list && $grouped)

◆ method

$cacheparams method = 'getList'

◆ methodparams

$cacheparams methodparams = $params

◆ modeparams

$cacheparams modeparams = $cacheid


Joomla CMS: Référence du fichier mod_articles_popular.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
Espaces de nommage | Variables
Référence du fichier mod_articles_popular.php

Espaces de nommage

Joomla\Site

Variables

if(!ComponentHelper::getParams('com_content') ->get('record_hits', 1)) $list = ArticlesPopularHelper::getList($params)

Documentation des variables

◆ $list

if (!ComponentHelper::getParams( 'com_content') ->get( 'record_hits', 1)) $list = ArticlesPopularHelper::getList($params)


Joomla CMS: Référence du fichier mod_banners.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
Espaces de nommage | Variables
Référence du fichier mod_banners.php

Espaces de nommage

Joomla\Site

Variables

$headerText = trim($params->get('header_text', ''))
$footerText = trim($params->get('footer_text', ''))
$model = $app->bootComponent('com_banners')->getMVCFactory()->createModel('Banners', 'Site', ['ignore_request' => true])
$list = BannersHelper::getList($params, $model, $app)

Documentation des variables

◆ $footerText

$footerText = trim($params->get('footer_text', ''))

◆ $headerText

$headerText = trim($params->get('header_text', ''))

◆ $list

$list = BannersHelper::getList($params, $model, $app)

◆ $model

$model = $app->bootComponent('com_banners')->getMVCFactory()->createModel('Banners', 'Site', ['ignore_request' => true])


Joomla CMS: Référence du fichier mod_breadcrumbs.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
Espaces de nommage | Variables
Référence du fichier mod_breadcrumbs.php

Espaces de nommage

Joomla\Site

Variables

$list = BreadcrumbsHelper::getList($params, $app)
$count = count($list)
if (! $params->get( 'showHome', 1))

Documentation des variables

◆ $count

$count = count($list)

◆ $list

$list = BreadcrumbsHelper::getList($params, $app)

◆ if

if(! $params->get('showHome', 1))


Joomla CMS: Référence du fichier mod_custom.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_custom
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_custom/mod_custom.php

Espaces de nommage

Joomla\Administrator

Variables

if($params->def('prepare_content', 1)) $module content = preg_replace('*src\=\"(?!administrator\/)images/*', 'src="../images/', $module->content)

Documentation des variables

◆ content

if ( $params->def( 'prepare_content', 1)) $module content = preg_replace('*src\=\"(?!administrator\/)images/*', 'src="../images/', $module->content)

Référencé par ConsoleSectionOutput\addContent(), Module\check(), ConsoleSectionOutput\clear(), Microdata\content(), Microdata\display(), ConsoleSectionOutput\getContent(), TracksModel\getContent(), Microdata\resetParams(), Key\setContent(), et Grid\sort().


Joomla CMS: Référence du fichier mod_custom.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_custom
Espaces de nommage | Variables
Référence du fichier modules/mod_custom/mod_custom.php

Espaces de nommage

Joomla\Site

Variables

if ( $params->def( 'prepare_content', 1))

Documentation des variables

◆ if

if($params->def('prepare_content', 1))


Joomla CMS: Référence du fichier mod_feed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_feed/mod_feed.php

Espaces de nommage

Joomla\Administrator

Variables

$feed = \Joomla\Module\Feed\Administrator\Helper\FeedHelper::getFeed($params)
$rssurl = $params->get('rssurl', '')
$rssrtl = $params->get('rssrtl', 0)

Documentation des variables

◆ $feed

$feed = \Joomla\Module\Feed\Administrator\Helper\FeedHelper::getFeed($params)

Référencé par HtmlView\display(), FeedHelper\getFeed(), AtomParser\handleAuthor(), RssParser\handleCategory(), RssParser\handleCloud(), AtomParser\handleContributor(), RssParser\handleCopyright(), RssParser\handleDescription(), AtomParser\handleGenerator(), RssParser\handleGenerator(), AtomParser\handleId(), RssParser\handleImage(), RssParser\handleLanguage(), RssParser\handleLastBuildDate(), AtomParser\handleLink(), RssParser\handleLink(), RssParser\handleManagingEditor(), RssParser\handlePubDate(), AtomParser\handleRights(), RssParser\handleSkipDays(), RssParser\handleSkipHours(), AtomParser\handleSubtitle(), AtomParser\handleTitle(), RssParser\handleTitle(), RssParser\handleTtl(), AtomParser\handleUpdated(), RssParser\handleWebmaster(), FeedParser\parse(), FeedParser\processElement(), RssRenderer\render(), et AtomRenderer\render().

◆ $rssrtl

$rssrtl = $params->get('rssrtl', 0)

◆ $rssurl

$rssurl = $params->get('rssurl', '')

Référencé par FeedHelper\getFeed().


Joomla CMS: Référence du fichier mod_feed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
Espaces de nommage | Variables
Référence du fichier modules/mod_feed/mod_feed.php

Espaces de nommage

Joomla\Site

Variables

$rssurl = $params->get('rssurl', '')
$rssrtl = $params->get('rssrtl', 0)
$feed = FeedHelper::getFeed($params)

Documentation des variables

◆ $feed

$feed = FeedHelper::getFeed($params)

◆ $rssrtl

$rssrtl = $params->get('rssrtl', 0)

◆ $rssurl

$rssurl = $params->get('rssurl', '')


Joomla CMS: Référence du fichier mod_finder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
Espaces de nommage | Variables
Référence du fichier mod_finder.php

Espaces de nommage

Joomla\Site

Variables

$cparams = ComponentHelper::getParams('com_finder')
if($params->get('opensearch', $cparams->get('opensearch', 1))) $route = RouteHelper::getSearchRoute($params->get('searchfilter', null))
$query = FinderHelper::getQuery($params)

Documentation des variables

◆ $cparams

$cparams = ComponentHelper::getParams('com_finder')

Référencé par CategoryView\commonCategoryDisplay(), et SysinfoModel\getDirectory().

◆ $query

$query = FinderHelper::getQuery($params)

Référencé par ChangeItem\__construct(), SqliteQuery\__toString(), SqlsrvQuery\__toString(), Joomla\Database\Query\__toString(), DatabaseQuery\__toString(), ComponentAdapter\_buildAdminMenus(), PlgContentJoomla\_countItemsInCategory(), PlgContentJoomla\_countItemsInChildren(), PlgContentJoomla\_countItemsInStage(), Module\_getAssetParentId(), Category\_getAssetParentId(), Content\_getAssetParentId(), GroupTable\_getAssetParentId(), WorkflowTable\_getAssetParentId(), PackageAdapter\_getExtensionId(), InstallerModel\_getList(), PluginsModel\_getList(), BaseDatabaseModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), GroupsModel\_getList(), TasksModel\_getList(), FieldsModel\_getList(), BaseDatabaseModel\_getListCount(), MapsModel\_getListCount(), ListModel\_getListQuery(), Nested\_getNode(), Categories\_load(), Nested\_logtable(), ModuleAdapter\_rollback_menu(), ModuleAdapter\_rollback_module(), Nested\_runQuery(), ComponentAdapter\_updateMenus(), Installer\abort(), Task\acquireLock(), RegistrationModel\activate(), LinkModel\activate(), UserHelper\activateUser(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addAssociations(), PlgExtensionFinder\addCommonWords(), Helper\addContentType(), Taxonomy\addMap(), PlgSampledataMultilang\addModuleInModuleMenu(), MessagesModel\addPostInstallationMessage(), TagsHelper\addTagMapping(), PlgExtensionJoomla\addUpdateSite(), JoomlaInstallerScript\addUserAuthProviderColumn(), UserHelper\addUserToGroup(), admin_postinstall_languageaccess340_condition(), MfaTable\afterDelete(), Table\appendPrimaryKeys(), UpdateModel\applyUpdateSite(), MessagesModel\archiveMessage(), Access\assetgroups(), AdministratorService\association(), Menus\association(), ItemModel\batchCopy(), ModuleModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), CategoryModel\batchFlipordering(), ItemModel\batchMove(), CategoryModel\batchMove(), LinksModel\batchProcess(), UserModel\batchReset(), UserModel\batchUser(), User\bind(), Router\build(), RouterLegacy\build(), NomenuRules\build(), StandardRules\build(), RouterView\build(), SiteRouter\buildComponentPreprocess(), ContactModel\buildContactExtendedData(), SiteRouter\buildSefRoute(), MetadataService\buildUri(), LevelModel\canDelete(), ContentHelper\canDeleteState(), Category\categories(), Adapter\categoryAccessChange(), Adapter\categoryStateChange(), Adapter\change(), Usergroup\check(), LinkTable\check(), MenuType\check(), ViewLevel\check(), Asset\check(), StageTable\check(), WorkflowTable\check(), User\check(), Nested\check(), Adapter\checkCategoryAccess(), DiscoverModel\checkExtensions(), CheckinModel\checkin(), Table\checkIn(), Adapter\checkItemAccess(), TemplateModel\checkNewName(), Table\checkOut(), MetadataManager\checkSessionRecordExists(), AssociationsModel\clean(), Installer\cleanDiscoveredExtension(), ArticleModel\cleanupPostBatchCopy(), FieldModel\cleanupValues(), JoomlaInstallerScript\clearStatsCache(), BannerModel\click(), BannerTable\clicks(), Banner\clientlist(), DatabaseHandler\close(), TagsHelper\convertPathsToNames(), MysqliDriver\convertUtf8mb4QueryToUtf8(), TemplateModel\copyStyles(), NewsfeedsHelper\countItems(), WorkflowsModel\countItems(), ArticlesModel\countItemsByMonth(), HtmlDocument\countMenuChildren(), NewsfeedsHelper\countTagItems(), Workflow\createAssociation(), DatabaseHandler\createDatabaseTable(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), Adapter\createQuery(), ConfigurationModel\createRootUser(), MetadataManager\createSessionRecord(), MenuTable\delete(), StageTable\delete(), WorkflowTable\delete(), Versioning\delete(), UCMContent\delete(), UpdatesitesModel\delete(), StyleTable\delete(), TracksModel\delete(), MenuType\delete(), Usergroup\delete(), ModuleModel\delete(), ActionlogsModel\delete(), User\delete(), FieldModel\delete(), AdminModel\delete(), ArticleModel\delete(), MethodsModel\deleteAll(), Workflow\deleteAssociation(), CoreContent\deleteByContentId(), ContentHistory\deleteOldVersions(), MetadataManager\deletePriorTo(), MailTemplate\deleteTemplate(), DatabaseHandler\destroy(), PlgSampledataMultilang\disableModuleMainMenu(), PlgSystemStats\disablePlugin(), DiscoverModel\discover(), FeedView\display(), HtmlView\display(), ListUserCommand\doExecute(), AddUserToGroupCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), ModuleModel\duplicate(), LinkModel\duplicateUrls(), Users\editor(), PluginsHelper\elementOptions(), PlgSampledataMultilang\enablePlugin(), WorkflowStage\existing(), ContentLanguage\existing(), Query\explained(), FileAdapter\extensionExistsInSystem(), ContactModel\featured(), ArticleModel\featured(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), UpdateModel\finaliseUpgrade(), Update\find(), Extension\find(), ChangeItem\fix(), DatabaseModel\fixSchemaVersion(), Router\fixSegment(), JoomlaInstallerScript\fixTemplateMode(), PluginsHelper\folderOptions(), DatabaseQuery\format(), ServerRequestFactory\fromGlobals(), ListHelper\genericordering(), Versioning\get(), ModulesModel\getActivePositions(), PlgSampledataMultilang\getAdminId(), StyleModel\getAdminTemplate(), RouteHelper\getAdvancedRoute(), ConfigHelper\getAllComponents(), ExtensionsListCommand\getAllExtensionsFromDB(), TemplateModel\getAllTemplateStyles(), Router\getArticleId(), FieldTable\getAssetId(), Access\getAssetRules(), ConsentBoxField\getAssignedArticleUrl(), FieldsHelper\getAssignedCategoriesIds(), FieldsHelper\getAssignedCategoriesTitles(), ConsentBoxField\getAssignedMenuItemUrl(), Workflow\getAssociation(), AssociationsHelper\getAssociationHtmlList(), CategoriesHelper\getAssociations(), Associations\getAssociations(), User\getAuthorisedCategories(), Access\getAuthorisedViewLevels(), Taxonomy\getBranchTitles(), Router\getCategoriesId(), Router\getCategoriesSegment(), Router\getCategoryId(), TracksModel\getCategoryName(), BannersModel\getCategoryOrders(), UpdateModel\getCheckForSelfUpdate(), TracksModel\getClientName(), BannersHelper\getClientOptions(), Helper\getCommonWords(), MessagesModel\getComponentOptions(), DebugHelper\getComponents(), PgsqlDriver\getConnectionEncryption(), PlgContentContact\getContactData(), Router\getContactId(), MultilangstatusHelper\getContacts(), Adapter\getContentCount(), MultilangstatusHelper\getContentlangs(), ExtensionHelper\getCoreExtensionIds(), PgsqlDriver\getCreateDbQuery(), PrivacyDashboardHelper\getData(), StatisticsModel\getData(), ArchiveModel\getData(), MultilangstatusHelper\getDefaultHomeModule(), Workflow\getDefaultStageByCategory(), UpdateModel\getDisabledUpdateSites(), EditorField\getEditor(), ListModel\getEmptyStateQuery(), DiscoverModel\getEmptyStateQuery(), TagsModel\getEmptyStateQuery(), MapsModel\getEmptyStateQuery(), ModulesModel\getEmptyStateQuery(), CategoriesModel\getEmptyStateQuery(), UpdateModel\getEmptyStateQuery(), AssociationsHelper\getEnabledExtensions(), InstallerHelper\getExtensionDownloadKey(), MenuModel\getExtensionElementsForMenuItems(), InstallerHelper\getExtensionGroups(), MessagesModel\getExtensionName(), ExtensionHelper\getExtensionRecord(), TemplatesModel\getExtensions(), SysinfoModel\getExtensions(), InstallerHelper\getExtensionTypes(), FieldsHelper\getFieldsPluginId(), FieldModel\getFieldValues(), FinderIndexCommand\getFilters(), TemplateModel\getForm(), Router\getFormSegment(), DebuggroupModel\getGroup(), AddUserCommand\getGroupId(), AddUserToGroupCommand\getGroupId(), RemoveUserFromGroupCommand\getGroupId(), MenuField\getGroups(), UserMessagesField\getGroups(), ContentmapField\getGroups(), WorkflowstageField\getGroups(), TemplatestyleField\getGroups(), AddUserToGroupCommand\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), RemoveUserFromGroupCommand\getGroups(), FieldsModel\getGroups(), Access\getGroupsByUser(), Access\getGroupTitle(), ContentHistory\getHashMatch(), MultilangstatusHelper\getHomes(), PlugininfoField\getInput(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), OrderingField\getInput(), RulesField\getInput(), ChangeItem\getInstance(), InstallerScript\getInstances(), ConfigModel\getItem(), MessagesModel\getItem(), NewsfeedModel\getItem(), UpdatesiteModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), FieldModel\getItem(), ArticleModel\getItem(), Adapter\getItem(), ModuleModel\getItem(), InstallerScript\getItemArray(), RouteHelper\getItemid(), Adapter\getItemMenuTitle(), MenusModel\getItems(), TemplatesModel\getItems(), LanguagesModel\getItems(), PositionsModel\getItems(), UsersModel\getItems(), CheckinModel\getItems(), ClientsModel\getItems(), Adapter\getItems(), TagsHelper\getItemTags(), UpdatesitesModel\getJoomlaUpdateSitesIds(), TosField\getLabel(), MultilangstatusHelper\getLangswitchers(), PlgExtensionFinder\getLanguage(), AssociationsHelper\getLanguagefilterPluginId(), CMSHelper\getLanguageId(), ContentHelper\getLanguageId(), LanguagesModel\getLanguageList(), PlgSampledataMultilang\getLanguageList(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), StatsHelper\getList(), TagsPopularHelper\getList(), ArticlesArchiveHelper\getList(), TagsSimilarHelper\getList(), LoggedHelper\getList(), RequestsModel\getListQuery(), FiltersModel\getListQuery(), ConsentsModel\getListQuery(), NotesModel\getListQuery(), SelectModel\getListQuery(), ActionlogsModel\getListQuery(), ArchiveModel\getListQuery(), TracksModel\getListQuery(), FeaturedModel\getListQuery(), DiscoverModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), LevelsModel\getListQuery(), BannersModel\getListQuery(), SearchesModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), TemplatesModel\getListQuery(), StylesModel\getListQuery(), StagesModel\getListQuery(), GroupsModel\getListQuery(), TransitionsModel\getListQuery(), SearchModel\getListQuery(), LinksModel\getListQuery(), TagModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), MenusModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), MapsModel\getListQuery(), IndexModel\getListQuery(), DebuguserModel\getListQuery(), PluginsModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), PlgFinderTags\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), HistoryModel\getListQuery(), PlgFinderNewsfeeds\getListQuery(), DatabaseModel\getListQuery(), PlgFinderContent\getListQuery(), PlgFinderCategories\getListQuery(), PlgFinderContacts\getListQuery(), UpdatesitesModel\getListQuery(), Adapter\getListQuery(), ActionlogConfigModel\getLogContentTypeParams(), ActionlogsModel\getLogDataAsIterator(), ActionlogsModel\getLogDataQuery(), ActionlogsModel\getLogsData(), ActionlogsModel\getLogsForItem(), ContenthistoryHelper\getLookupValue(), ItemsModel\getMenu(), MenusHelper\getMenuItems(), LoginModel\getMenuLanguage(), MenusHelper\getMenuLinks(), MenusHelper\getMenuTypes(), MenusModel\getMissingModuleLanguages(), MenusModel\getModMenuId(), MultilangstatusHelper\getModule(), ModulesHelper\getModules(), MenuModel\getModules(), ItemModel\getModules(), PgsqlDriver\getNamesKey(), Router\getNewsfeedId(), Table\getNextOrder(), Taxonomy\getNodeByTitle(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), MfaTable\getNumRecords(), WhosonlineHelper\getOnlineCount(), WhosonlineHelper\getOnlineUserNames(), FieldgroupsField\getOptions(), FrontendlanguageField\getOptions(), AliastagField\getOptions(), NewsfeedsField\getOptions(), ComponentsField\getOptions(), SearchfilterField\getOptions(), MenuParentField\getOptions(), ExtensionField\getOptions(), ComponentsCategoryField\getOptions(), MenuOrderingField\getOptions(), LogtypeField\getOptions(), ConfigComponentsField\getOptions(), AuthorField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsFieldgroupField\getOptions(), ContenttypesField\getOptions(), ComponentsWorkflowField\getOptions(), LogcreatorField\getOptions(), ContenttypeField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), PlgQuickiconOverrideCheck\getOverridePluginId(), RouterView\getPath(), Nested\getPath(), IndexModel\getPluginState(), Adapter\getPluginType(), ModulesHelper\getPositions(), TemplateModel\getPreview(), UCMContent\getPrimaryKey(), PrivacyHelper\getPrivacyConsentPluginId(), PluginorderingField\getQuery(), OrderingField\getQuery(), RedirectHelper\getRedirectPluginId(), PrivacyStatusHelper\getRequestFormPublished(), Nested\getRootId(), DatabaseModel\getSchemaVersion(), RouteHelper\getSearchRoute(), LanguageAdapter\getSefString(), PgsqlDriver\getSequenceIsCalled(), PgsqlDriver\getSequenceLastValue(), Multilanguage\getSiteHomePages(), Updater\getSitesWithUpdates(), StyleModel\getSiteTemplates(), ArchiveModel\getSlugColumn(), ContactModel\getSlugColumn(), CategoryModel\getSlugColumn(), PlgFinderTags\getStateQuery(), PlgFinderCategories\getStateQuery(), Adapter\getStateQuery(), StatsAdminHelper\getStats(), MultilangstatusHelper\getStatus(), SearchModel\getStoreId(), PlgSystemUpdatenotification\getSuperUsers(), SqliteDriver\getTableList(), PgsqlDriver\getTableList(), PgsqlDriver\getTableSequences(), TagsHelper\getTagIds(), TagsHelper\getTagItemsQuery(), TagsHelper\getTagNames(), Taxonomy\getTaxonomy(), MailTemplate\getTemplate(), TemplateModel\getTemplate(), TemplateModel\getTemplateList(), TemplatesHelper\getTemplateOptions(), ModulesHelper\getTemplates(), ChromestyleField\getTemplates(), Query\getTokenData(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), FilterModel\getTotal(), IndexModel\getTotalIndexed(), ArticlesModel\getTransitions(), Nested\getTree(), UCMType\getType(), UCMType\getTypeByAlias(), UCMType\getTypeByTable(), ContentType\getTypeId(), UCMType\getTypeId(), Adapter\getTypeId(), MenutypesModel\getTypeOptions(), TagsHelper\getTypes(), TemplateModel\getUpdatedList(), UpdateModel\getUpdateInformation(), ChangeSet\getUpdateQueries(), Adapter\getUpdateQueryByIds(), PlgFinderTags\getUpdateQueryByTime(), Adapter\getUpdateQueryByTime(), LanguagesModel\getUpdateSite(), UpdateAdapter\getUpdateSiteName(), Updater\getUpdateSites(), UpdateModel\getUpdateSitesInfo(), InstallerHelper\getUpdateSitesInformation(), UsersModel\getUserDisplayedGroups(), FiltersField\getUserGroups(), AddUserCommand\getUserGroups(), AddUserToGroupCommand\getUserId(), UserHelper\getUserId(), RegistrationModel\getUserIdFromToken(), UsersLatestHelper\getUsers(), Access\getUsersByGroup(), Workflow\getValidTransition(), ItemModel\getViewLevels(), UsersHelper\getVisibleByGroups(), ArchiveModel\getYears(), Table\hasPrimaryKey(), MessagesModel\hideMessages(), Table\hit(), httpheaders_postinstall_action(), BannersModel\impress(), Indexer\index(), MysqlDriver\insertObject(), MysqliDriver\insertObject(), PgsqlDriver\insertObject(), DatabaseDriver\insertObject(), ConsentsModel\invalidate(), ConsentsModel\invalidateAll(), Table\isCheckedOut(), Multilanguage\isEnabled(), UpdateModel\isTemplateActive(), Token\isTokenEnabledForUser(), PlgSystemPrivacyconsent\isUserConsented(), Adapter\itemAccessChange(), Adapter\itemStateChange(), Access\level(), Menu\linkOptions(), User\load(), UserGroupsHelper\load(), PlgInstallerOverride\load(), Table\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), UserGroupsHelper\loadAll(), ManageModel\loadChangelog(), XML\loadCurveByParam(), XML\loadCurveByParamRFC4050(), LanguageHelper\loadPluginLanguage(), LdapUserProvider\loadUserByIdentifier(), UserFactory\loadUserByUsername(), MenusHelper\loadXml(), FinderHelper\logSearch(), Finder\mapslist(), Laminas\Diactoros\marshalUriFromSapi(), Menu\menuItems(), Menu\menus(), DatabaseQuery\merge(), DatabaseImporter\mergeStructure(), Nested\move(), Table\move(), Nested\moveByReference(), PlgSystemDebug\onAfterDisconnect(), PlgSystemPrivacyconsent\onAfterRender(), PlgSystemActionLogs\onAfterRespond(), PlgContentJoomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), Joomla\onContentChangeState(), PlgContentJoomla\onContentChangeState(), PlgUserProfile\onContentPrepareData(), PlgSystemActionLogs\onContentPrepareData(), PlgExtensionJoomla\onExtensionAfterUninstall(), PlgFinderCategories\onFinderChangeState(), Adapter\onFinderGarbageCollection(), PlgSystemHighlight\onFinderResult(), ContentHelper\onPrepareForm(), PlgSystemPrivacyconsent\onPrivacyCheckPrivacyPolicyPublished(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgPrivacyContent\onPrivacyExportRequest(), PlgPrivacyContact\onPrivacyExportRequest(), PlgUserJoomla\onUserAfterDelete(), PlgSystemPrivacyconsent\onUserAfterDelete(), PlgUserToken\onUserAfterDelete(), PlgUserProfile\onUserAfterDelete(), PlgSystemActionLogs\onUserAfterDelete(), PlgAuthenticationCookie\onUserAfterLogin(), PlgAuthenticationCookie\onUserAfterLogout(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), PlgSystemActionLogs\onUserAfterSave(), PlgAuthenticationJoomla\onUserAuthenticate(), Basic\onUserAuthenticate(), PlgAuthenticationCookie\onUserAuthenticate(), PlgSystemRemember\onUserBeforeSave(), PlgUserJoomla\onUserLogin(), Joomla\onUserLoginFailure(), Indexer\optimize(), Category\options(), Tag\options(), Nested\orderDown(), ListHelper\ordering(), Menu\ordering(), ModuleController\orderPosition(), Nested\orderUp(), Stream\parse_path(), ApiRouter\parseApiRoute(), TemplateAdapter\parseQueries(), Installer\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), Adapter\pluginDisable(), DatabaseModel\populateDatabase(), GroupsModel\populateExtraData(), Modules\positionList(), WorkflowController\postSaveHook(), Access\preloadComponents(), Access\preloadPermissions(), PdoDriver\prepareStatement(), MysqliDriver\prepareStatement(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ContactModel\prepareTable(), Menu\preprocess(), RouterLegacy\preprocess(), MenuRules\preprocess(), RouterBase\preprocess(), RouterView\preprocess(), CssMenu\preprocess(), PluginModel\preprocessForm(), FormModel\preprocessForm(), ExtensionDiscoverInstallCommand\processDiscover(), Query\processDynamicTaxonomy(), SqliteQuery\processLimit(), Joomla\Database\Query\processLimit(), SqlsrvQuery\processLimit(), SqlField\processQuery(), RemindModel\processRemindRequest(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processStaticTaxonomy(), Nested\publish(), Table\publish(), LinksModel\purge(), MessagesModel\purge(), DiscoverModel\purge(), UpdateModel\purge(), MapsModel\purge(), AssociationsModel\purge(), FinderIndexCommand\putFilters(), Ldap\query(), XML\query(), JsonApiView\queryEncode(), DatabaseQuery\querySet(), DatabaseHandler\read(), Usergroup\rebuild(), Asset\rebuild(), UpdatesitesModel\rebuild(), Nested\rebuild(), ItemModel\rebuild(), Nested\rebuildPath(), Nested\recursiveUpdatePublishedColumn(), StringsModel\refresh(), RegistrationModel\register(), Task\releaseLock(), PlgSystemPrivacyconsent\remindExpiringConsents(), Adapter\remove(), Indexer\remove(), PlgExtensionFinder\removeCommonWords(), PlgWorkflowNotification\removeLocked(), Taxonomy\removeMaps(), Taxonomy\removeOrphanMaps(), Taxonomy\removeOrphanNodes(), Table\reorder(), MessagesModel\republishMessage(), MessagesModel\resetMessages(), LanguageAdapter\resetUserLanguage(), MenusHelper\resolveAlias(), MenusController\resync(), FieldModel\save(), ConfigModel\save(), UpdatesiteModel\save(), ApplicationModel\save(), StyleModel\save(), CategoryModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), Nested\saveorder(), LibraryHelper\saveParams(), PlgSystemStats\saveParams(), StringsModel\search(), TagsHelper\searchTags(), Filter\select(), MailModel\send(), ActionlogModel\sendNotificationEmails(), FieldModel\setFieldValue(), MethodsModel\setFlag(), StyleModel\setHome(), User\setLastVisit(), InstallerScript\setParams(), DatabaseDriver\setQuery(), Installer\setSchemaVersion(), ConfigurationModel\setup(), SqlField\setup(), TemplateAdapter\setupUninstall(), UserHelper\setUserGroups(), PgsqlDriver\showTables(), Task\skipExecution(), Filter\slider(), DatabaseModel\splitQueries(), Installer\splitSql(), DatabaseDriver\splitSql(), StyleTable\store(), MenuType\store(), Menu\store(), User\store(), Nested\store(), Taxonomy\storeNode(), CoreContent\storeUcmBase(), ArticleModel\storeVote(), Query\suggested(), MfaTable\switchDefaultRecord(), TagsHelper\tagDeleteInstances(), Tag\tags(), Users\templatestyle(), UsernameRule\test(), UserIdRule\test(), EmailRule\test(), UpdateAdapter\toggleUpdateSite(), Indexer\tokenizeToDbShort(), UserGroupsHelper\total(), Query\toUri(), Finder\typeslist(), SqliteQuery\union(), SqlsrvQuery\union(), DatabaseQuery\union(), DatabaseQuery\unionAll(), TaskTable\unlock(), MessagesModel\unpublishMessage(), StyleModel\unsetHome(), TagsHelper\unTagItem(), Workflow\updateAssociations(), JoomlaInstallerScript\updateContentTypes(), TemplatesModel\updated(), Updater\updateLastCheckTimestamp(), JoomlaInstallerScript\updateManifestCaches(), MetadataManager\updateSessionRecord(), ConfigurationModel\updateUserIds(), User\userlist(), ListHelper\users(), RequestModel\validate(), ServerRequest\withQueryParams(), et DatabaseHandler\write().

◆ $route

if ( $params->get( 'opensearch', $cparams->get( 'opensearch', 1))) $route = RouteHelper::getSearchRoute($params->get('searchfilter', null))


Joomla CMS: Référence du fichier mod_footer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_footer
Espaces de nommage | Variables
Référence du fichier mod_footer.php

Espaces de nommage

Joomla\Site

Variables

$date = Factory::getDate()
$cur_year = HTMLHelper::_('date', $date, 'Y')
$csite_name = $app->get('sitename')
if(is_int(StringHelper::strpos(Text::_('MOD_FOOTER_LINE1'), '%date%'))) else

Documentation des variables

◆ $csite_name

$csite_name = $app->get('sitename')

◆ $cur_year

$cur_year = HTMLHelper::_('date', $date, 'Y')

◆ $date

$date = Factory::getDate()

◆ else

if (is_int(StringHelper::strpos( $line1, '%sitename%'))) else
Valeur initiale :
{
$line1 = Text::_('MOD_FOOTER_LINE1')


Joomla CMS: Référence du fichier mod_frontend.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_frontend
Espaces de nommage | Variables
Référence du fichier mod_frontend.php

Espaces de nommage

Joomla\Administrator

Variables

$sitename = htmlspecialchars($app->get('sitename', ''), ENT_QUOTES, 'UTF-8')

Documentation des variables

◆ $sitename

$sitename = htmlspecialchars($app->get('sitename', ''), ENT_QUOTES, 'UTF-8')

Référencé par MessageModel\save().


Joomla CMS: Référence du fichier mod_languages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
Espaces de nommage | Variables
Référence du fichier mod_languages.php

Espaces de nommage

Joomla\Site

Variables

$headerText = $params->get('header_text')
$footerText = $params->get('footer_text')
$list = LanguagesHelper::getList($params)

Documentation des variables

◆ $footerText

$footerText = $params->get('footer_text')

◆ $headerText

$headerText = $params->get('header_text')

◆ $list

$list = LanguagesHelper::getList($params)


Joomla CMS: Référence du fichier mod_latest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
Espaces de nommage | Variables
Référence du fichier mod_latest.php

Espaces de nommage

Joomla\Administrator

Variables

$model = $app->bootComponent('com_content')->getMVCFactory()->createModel('Articles', 'Administrator', ['ignore_request' => true])
$list = LatestHelper::getList($params, $model)
$workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')
if($workflow_enabled) if($params->get('automatic_title', 0)) if(count($list)) else

Documentation des variables

◆ $list

$list = LatestHelper::getList($params, $model)

Référencé par PlgContentPagebreak\_createToc(), Pagination\_list_footer(), Pagination\_list_render(), HtmlView\addCustomTypes(), ResourceCaster\castDba(), LanguageHelper\createLanguageList(), Help\createSiteList(), SymfonyStyle\definitionList(), HtmlView\display(), ConfirmButton\fetchButton(), StandardButton\fetchButton(), AddUserToGroupCommand\getGroups(), LanguagesModel\getItems(), SetupModel\getLanguages(), Pagination\getListFooter(), Pagination\getPagesLinks(), Pagination\getPaginationLinks(), Pagination\getPaginationPages(), MenutypesModel\getTypeOptions(), AddUserCommand\getUserGroups(), ArticlesCategoryHelper\groupBy(), ArticlesCategoryHelper\groupByDate(), ArticlesCategoryHelper\groupByTags(), Menu\linkOptions(), FtpClient\listNames(), PlgContentPagenavigation\onContentBeforeDisplay(), PHPMailer\parseAddresses(), ListModel\populateState(), Command\setAliases(), PlgInstallerOverride\storeAfterEventFiles(), PlgInstallerOverride\storeBeforeEventFiles(), et Menu\treerecurse().

◆ $model

$model = $app->bootComponent('com_content')->getMVCFactory()->createModel('Articles', 'Administrator', ['ignore_request' => true])

◆ $workflow_enabled

$workflow_enabled = ComponentHelper::getParams('com_content')->get('workflow_enabled')

◆ else

if ( $workflow_enabled) if ( $params->get( 'automatic_title', 0)) if (count( $list)) else
Valeur initiale :
{
$app->getLanguage()->load('com_content')
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier mod_latestactions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
Espaces de nommage | Variables
Référence du fichier mod_latestactions.php

Espaces de nommage

Joomla\Administrator

Variables

if(! $app->getIdentity() ->authorise('core.admin')) $list = LatestActionsHelper::getList($params)
if ( $params->get( 'automatic_title', 0))

Documentation des variables

◆ $list

if (! $app->getIdentity() ->authorise( 'core.admin')) $list = LatestActionsHelper::getList($params)

◆ if

if($params->get('automatic_title', 0))


Joomla CMS: Référence du fichier mod_logged.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
Espaces de nommage | Variables
Référence du fichier mod_logged.php

Espaces de nommage

Joomla\Administrator

Variables

if($params->get('automatic_title', 0)) if($app->get('session_metadata', true)) else

Documentation des variables

◆ else

if ( $params->get( 'automatic_title', 0)) if ( $app->get( 'session_metadata', true)) else
Valeur initiale :
{
require ModuleHelper::getLayoutPath('mod_logged', 'disabled')


Joomla CMS: Référence du fichier mod_login.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_login/mod_login.php

Espaces de nommage

Joomla\Administrator

Variables

$langs = LoginHelper::getLanguageList()
$extraButtons = AuthenticationHelper::getLoginButtons('form-login')
$return = LoginHelper::getReturnUri()

Documentation des variables

◆ $extraButtons

$extraButtons = AuthenticationHelper::getLoginButtons('form-login')

◆ $langs

$langs = LoginHelper::getLanguageList()

Référencé par LanguageAdapter\getSefString().

◆ $return

$return = LoginHelper::getReturnUri()


Joomla CMS: Référence du fichier mod_login.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
Espaces de nommage | Variables
Référence du fichier modules/mod_login/mod_login.php

Espaces de nommage

Joomla\Site

Variables

$formId = 'login-form-' . $module->id
$type = LoginHelper::getType()
$return = LoginHelper::getReturnUrl($params, $type)
$registerLink = LoginHelper::getRegistrationUrl($params)
$extraButtons = AuthenticationHelper::getLoginButtons($formId)
$user = Factory::getUser()
$layout = $params->get('layout', 'default')
if (! $user->guest)

Documentation des variables

◆ $extraButtons

$extraButtons = AuthenticationHelper::getLoginButtons($formId)

◆ $formId

$formId = 'login-form-' . $module->id

Référencé par JGrid\action(), ToolbarHelper\custom(), DraggableList\draggable(), StandardButton\fetchButton(), et SortableList\sortable().

◆ $layout

$layout = $params->get('layout', 'default')

◆ $registerLink

$registerLink = LoginHelper::getRegistrationUrl($params)

◆ $return

$return = LoginHelper::getReturnUrl($params, $type)

◆ $type

$type = LoginHelper::getType()

Référencé par WebAssetManager\__call(), Toolbar\__call(), BCMath\__callStatic(), PublicKeyCredentialParameters\__construct(), Credential\__construct(), PublicKeyCredential\__construct(), BaseAccept\__construct(), JoomlaSerializer\__construct(), PublicKeyCredentialDescriptor\__construct(), UCMBase\__construct(), UCMContent\__construct(), FeedPerson\__construct(), TaskOption\__construct(), PublicKeyCredentialSource\__construct(), FeedLink\__construct(), Microdata\__construct(), LazyString\__toString(), HtmlView\_addPath(), HtmlView\_createFileName(), FeedFactory\_fetchFeedParser(), PackageAdapter\_getExtensionId(), InstallModel\_getPackageFromFolder(), HtmlDocument\_parseTemplate(), HtmlView\_setPath(), Installer\abort(), WebAssetRegistry\add(), Mail\addAttachment(), PHPMailer\addAttachment(), AbstractCloner\addCasters(), Feed\addContributor(), FeedEntry\addContributor(), PHPMailer\addEmbeddedImage(), HtmlDocument\addFavicon(), WebAssetManager\addInline(), BaseController\addPath(), PHPMailer\addrAppend(), MailTemplate\addRecipient(), Document\addScriptDeclaration(), PHPMailer\addStringAttachment(), PHPMailer\addStringEmbeddedImage(), Document\addStyleDeclaration(), PlgExtensionJoomla\addUpdateSite(), FormBehavior\ajaxchosen(), PlgSystemHttpHeaders\applyHashesToCspRule(), WebAssetManager\assetExists(), PHPMailer\attachAll(), CategoryModel\batchCopy(), CategoryModel\batchMove(), PdoStatement\bindParam(), SymfonyStyle\block(), MysqlChangeItem\buildCheckQuery(), PostgresqlChangeItem\buildCheckQuery(), WebAssetManager\calculateOrderOfActiveAssets(), ErrorHandler\call(), JWKSet\canKeyBeUsedFor(), Joomla\Database\Query\castAs(), AmqpCaster\castExchange(), AbstractCloner\castResource(), DebugClassLoader\checkAnnotations(), CertificateToolbox\checkAttestationMedata(), MysqlChangeItem\checkDefault(), FieldModel\checkDefaultValue(), ExtensionHelper\checkIfCoreExtension(), InputFilter\clean(), Installer\cleanDiscoveredExtension(), ErrorHandler\cleanTrace(), AbstractCloner\cloneVar(), PdoStatement\convertParameterType(), SymfonyStyle\createBlock(), CacheControllerFactory\createCacheController(), Factory\createConfig(), PrivacyPlugin\createCustomFieldsDomain(), DatabaseModel\createDatabase(), Factory\createDocument(), TemplateController\createFile(), TemplateModel\createFile(), BaseController\createFileName(), Factory\createRenderer(), LegacyFactory\createView(), MVCFactory\createView(), BaseController\createView(), ParagonIE_Sodium_Core_Util\declareScalarType(), UCMContent\delete(), TracksModel\delete(), MethodController\delete(), ApiModel\delete(), Router\detachRule(), InstallerHelper\detectType(), WebAssetManager\disableAsset(), Installer\discover_install(), WebAssetRegistry\dispatchAssetChanged(), HtmlView\display(), ConsoleApplication\doExecute(), ExtensionsListCommand\doExecute(), Application\doRenderThrowable(), Data\dumpItem(), CliDumper\dumpScalar(), WebAssetManager\enableDependencies(), UndefinedFunctionErrorEnhancer\enhance(), CMSApplication\enqueueMessage(), ConsoleApplication\enqueueMessage(), CliApplication\enqueueMessage(), CliDumper\enterHash(), HtmlDumper\enterHash(), WebAssetRegistry\exists(), Tar\extract(), Microdata\fallback(), SFTP\filetype(), Caster\filter(), Image\filter(), JavascriptRenderer\filterAssetArray(), ExtensionsListCommand\filterExtensionsBasedOn(), MysqlChangeItem\fixUtf8mb4TypeChecks(), LdapClient\generatePassword(), WebAssetRegistry\get(), SSH2\get_channel_packet(), Php80\get_debug_type(), SFTP\get_xstat_cache_prop(), Archive\getAdapter(), WebAssetManager\getAsset(), JavascriptRenderer\getAsseticCollection(), WebAssetManager\getAssets(), JavascriptRenderer\getAssets(), WebAssetManager\getAssetState(), AssociationsHelper\getAssociations(), TracksModel\getBaseName(), Factory\getConfig(), TemplateModel\getCoreFile(), WebAssetManager\getDependenciesForAsset(), X509\getDN(), X509\getDNProp(), PluginAdapter\getElement(), Microdata\getExpectedDisplayType(), Microdata\getExpectedTypes(), InstallerHelper\getExtensionDownloadKey(), ExtensionHelper\getExtensionRecord(), InstallerHelper\getExtensionTypes(), Image\getFilterInstance(), Factory\getFormat(), FieldsPlugin\getFormPath(), ItemtypeField\getGroups(), RandomImageHelper\getImages(), Document\getIncluded(), InstallerHelper\getInstallationXML(), InstalledVersions\getInstalledPackagesByType(), CacheController\getInstance(), Cache\getInstance(), BaseController\getInstance(), Table\getInstance(), Document\getInstance(), ItemModel\getItem(), PositionsModel\getItems(), PluginHelper\getLayoutPath(), BannersModel\getListQuery(), TracksModel\getListQuery(), DiscoverModel\getListQuery(), UpdateModel\getListQuery(), AssociationsModel\getListQuery(), IndexModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ManageModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), MenusHelper\getMenuLinks(), JNamespacePsr4Map\getNamespaces(), DataSet\getObjectsKeys(), TaskTypeField\getOptions(), PredefinedlistField\getOptions(), Resource\getOwnFields(), OptionsResolver\getParameterClassName(), DSA\getParameters(), EC\getParameters(), DH\getParameters(), PluginHelper\getPlugin(), Symfony\Contracts\Service\getProvidedServices(), PrivateKey\getPublicKey(), AbstractRenderer\getRenderer(), LoginHelper\getReturnUrl(), ReflectionCaster\getSignature(), FeatureModel\getTable(), GroupModel\getTable(), UserModel\getTable(), MenuModel\getTable(), WorkflowsModel\getTable(), TransitionsModel\getTable(), PreviewModel\getTable(), StagesModel\getTable(), LevelModel\getTable(), CompareModel\getTable(), CategoryModel\getTable(), PluginModel\getTable(), HistoryModel\getTable(), BannersModel\getTable(), MapsModel\getTable(), IndexModel\getTable(), User\getTable(), ModuleModel\getTable(), ItemModel\getTable(), SqliteDriver\getTableList(), LatestHelper\getTitle(), PublicKeyCredentialParameters\getType(), Credential\getType(), PublicKeyCredentialDescriptor\getType(), BaseAccept\getType(), CollectedClientData\getType(), UCMBase\getType(), PublicKeyCredentialSource\getType(), Microdata\getType(), UCMType\getTypeByTable(), AssociationExtensionHelper\getTypeInformation(), AssociationExtensionHelper\getTypeTitle(), ListModel\getUserStateFromRequest(), CMSApplication\getUserStateFromRequest(), ArrayHelper\getValue(), DisplayController\getView(), BaseController\getView(), Grapheme\grapheme_extract(), ArticlesCategoryHelper\groupByDate(), ErrorHandler\handleError(), ErrorHandler\handleException(), Iconv\iconv_get_encoding(), Iconv\iconv_set_encoding(), PluginHelper\importPlugin(), WebAssetManager\isAssetActive(), PluginHelper\isEnabled(), ApiModel\isMediaFile(), Microdata\isPropertyInType(), Microdata\isTypeAvailable(), FieldsPlugin\isTypeSupported(), Browser\isViewable(), PublicKeyCredentialParameters\jsonSerialize(), PublicKeyCredentialDescriptor\jsonSerialize(), PublicKeyCredentialSource\jsonSerialize(), SSH2\key_exchange(), SSH2\keyboard_interactive_process(), CliDumper\leaveHash(), HtmlDumper\leaveHash(), FtpClient\listDetails(), SSH2\load(), OpenSSH\load(), PKCS8\load(), PSS\load(), PuTTY\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), ContainerAwareToolbarFactory\loadButtonClass(), Toolbar\loadButtonType(), FormHelper\loadClass(), XML\loadCurveByParam(), XML\loadCurveByParamRFC4050(), InstallationApplication\loadDocument(), Form\loadField(), FormHelper\loadFieldClass(), FormHelper\loadFieldType(), Image\loadFile(), FormHelper\loadFilterClass(), FormHelper\loadFilterType(), AsymmetricKey\loadFormat(), Iconv\loadMap(), AsymmetricKey\loadParametersFormat(), AsymmetricKey\loadPlugins(), AsymmetricKey\loadPrivateKeyFormat(), AsymmetricKey\loadPublicKeyFormat(), ErrorDocument\loadRenderer(), Document\loadRenderer(), FormHelper\loadRuleClass(), FormHelper\loadRuleType(), TrustPathLoader\loadTrustPath(), FormHelper\loadType(), GithubActionReporter\log(), SSH2\login_helper(), Cache\makeId(), UCMBase\mapBase(), UCMContent\mapData(), X509\mapInDNs(), X509\mapOutDNs(), Mbstring\mb_get_info(), HtmlDocument\mergeHeadData(), Form\mergeNodes(), Document\mergeResource(), DebugClassLoader\normalizeType(), OptionsResolver\offsetGet(), PlgSampledataBlog\onAjaxSampledataApplyStep2(), PlgMediaActionResize\onContentBeforeSave(), CMSPlugin\parameterImplementsEventInterface(), SFTP\parseAttributes(), SMTP\parseHelloFields(), BaseAccept\parseParameters(), DebugClassLoader\patchMethod(), Ec2Key\pem(), RsaKey\pem(), PositionsModel\populateState(), ItemModel\populateState(), LegacyInstallerScript\postflight(), ArticleController\postSaveHook(), ContactController\postSaveHook(), LegacyInstallerScript\preflight(), InstallerScript\preflight(), ItemModel\preprocessForm(), SSH2\privatekey_login(), UpdatesitesModel\rebuild(), WebAssetManager\registerAsset(), WebAssetRegistry\remove(), TemplateModel\renameFile(), ScriptsRenderer\render(), StylesRenderer\render(), ImageDocument\render(), FeedDocument\render(), Toolbar\renderButton(), Table\renderColumnSeparator(), Table\renderRowSeparator(), Agent\requestIdentities(), HtmlDocument\resetHeadData(), HtmlDocument\resetHeadDatum(), WebAssetItem\resolvePath(), Assert\resource(), PublicKey\rsaes_pkcs1_v1_5_encrypt(), Inflector\rules(), Microdata\sanitizeType(), UCMContent\save(), PuTTY\savePublicKey(), JWKSet\selectKey(), MailController\send(), SFTP\send_sftp_packet(), Archive\setAdapter(), FeedEntry\setAuthor(), Feed\setAuthor(), Document\setCharset(), InstalledController\setDefault(), OptionsResolver\setDefault(), ErrorHandler\setDefaultLogger(), X509\setDN(), X509\setDNProp(), ErrorHandler\setLoggers(), BaseController\setMessage(), PHPMailer\setMessageType(), Document\setMimeEncoding(), InstallerScript\setParams(), BaseController\setPath(), BaseController\setRedirect(), Microdata\setType(), Document\setType(), ItemController\setType(), Installer\setupInstall(), Identity\sign(), SFTP\stat_helper(), StringHelper\str_pad(), InstalledController\switchAdminLanguage(), SFTP\symlink(), DumpCompletionCommand\tailDebugLog(), Image\toFile(), Parameters\toString(), PublicKey\toString(), PrivateKey\toString(), Menu\treerecurse(), Installer\uninstall(), WebAssetManager\useAsset(), utf8_str_pad(), FormField\validate(), AsymmetricKey\validatePlugin(), OptionsResolver\verifyTypes(), ProcessHelper\wrapCallback(), PuTTY\wrapPrivateKey(), PuTTY\wrapPublicKey(), OutputStyle\write(), Output\write(), SymfonyStyle\write(), SymfonyStyle\writeBuffer(), OutputStyle\writeln(), et SymfonyStyle\writeln().

◆ $user

$user = Factory::getUser()

◆ if

if(! $user->guest)


Joomla CMS: Référence du fichier mod_loginsupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_loginsupport
Espaces de nommage | Variables
Référence du fichier mod_loginsupport.php

Espaces de nommage

Joomla\Administrator

Variables

if ( $params->get( 'automatic_title'))

Documentation des variables

◆ if

if($params->get('automatic_title'))


Joomla CMS: Référence du fichier mod_menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
Espaces de nommage | Variables
Référence du fichier administrator/modules/mod_menu/mod_menu.php

Espaces de nommage

Joomla\Administrator

Variables

$enabled = !$app->input->getBool('hidemainmenu')
$menu = new CssMenu($app)
$root = $menu->load($params, $enabled)
$root level = 0

Documentation des variables

◆ $enabled

$enabled = !$app->input->getBool('hidemainmenu')

◆ $menu

$menu = new CssMenu($app)

Référencé par SitePathway\__construct(), Router\__construct(), RouterBase\__construct(), SiteRouter\__construct(), HtmlView\_prepareDocument(), AbstractMenu\authorise(), ModuleModel\batchCopy(), HtmlDocument\countMenuChildren(), Joomla\CMS\Component\Router\createRouter(), RouterFactory\createRouter(), LegacyComponent\createRouter(), MenuHelper\getActive(), CategoryModel\getCategory(), MenuHelper\getDefault(), MenuField\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), BreadcrumbsHelper\getHome(), ComponentlayoutField\getInput(), RouteHelper\getItemid(), CategoriesModel\getItems(), LanguagesHelper\getList(), ArticlesArchiveHelper\getList(), ArticlesCategoryHelper\getList(), ItemModel\getMenuTypeId(), BaseController\getModel(), SiteApplication\getParams(), AbstractMenu\getParams(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromMvc(), MenutypesModel\getTypeOptionsFromXml(), UpdateModel\isTemplateActive(), Menu\menuItems(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSampledataBlog\onAjaxSampledataApplyStep2(), PlgSystemLanguageFilter\onUserLogin(), FeaturedModel\populateState(), CategoryModel\populateState(), HtmlView\prepareDocument(), et CategoriesView\prepareDocument().

◆ $root

$root = $menu->load($params, $enabled)

Référencé par Patcher\add(), Patcher\addFile(), XmlView\display(), X509\extensions(), JavascriptRenderer\getAssets(), LinkStub\getComposerRoot(), MenusHelper\getMenuItems(), Joomla\CMS\Tree\getRoot(), MenusHelper\installPreset(), X509\isSubArrayValid(), CssMenu\load(), JavascriptRenderer\makeUriRelativeTo(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), Xml\objectToString(), FieldsPlugin\onCustomFieldsGetTypes(), IndexModel\purge(), Uri\reset(), Uri\root(), GMP\rootInner(), Engine\rootInner(), ComponentModel\save(), X509\subArray(), et X509\subArrayUnchecked().

◆ level

$root level = 0

Référencé par MenuParentField\getOptions(), GroupparentField\getOptions(), CategoryeditField\getOptions(), User\groups(), Nested\moveByReference(), Nested\store(), et Access\usergroup().


Joomla CMS: Référence du fichier mod_menu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
Espaces de nommage | Variables
Référence du fichier modules/mod_menu/mod_menu.php

Espaces de nommage

Joomla\Site

Variables

$list = MenuHelper::getList($params)
$base = MenuHelper::getBase($params)
$active = MenuHelper::getActive($params)
$default = MenuHelper::getDefault()
$active_id = $active->id
$default_id = $default->id
$path = $base->tree
$showAll = $params->get('showAllChildren', 1)
$class_sfx = htmlspecialchars($params->get('class_sfx', ''), ENT_COMPAT, 'UTF-8')

Documentation des variables

◆ $active

$active = MenuHelper::getActive($params)

◆ $active_id

$active_id = $active->id

◆ $base

$base = MenuHelper::getBase($params)

Référencé par GMP\__construct(), PaginationObject\__construct(), BCMath\__construct(), PHP\__construct(), Engine\__construct(), BigInteger\__construct(), JLoader\_load(), Uri\base(), Client\baseString(), Number\bytes(), TemplateModel\createFile(), TemplateModel\createFolder(), TemplateModel\deleteFolder(), HtmlView\display(), InstallerAdapter\doLoadLanguage(), DataFormatter\formatBytes(), BigInteger\fromArbitraryBase(), Calculator\fromArbitraryBase(), BigInteger\fromBase(), GmpCalculator\fromBase(), Calculator\fromBase(), ParagonIE_Sodium_Core32_Curve25519\ge_select(), UserHelper\genRandomPassword(), MenuHelper\getBase(), JLoader\import(), PHP32\initialize(), PHP64\initialize(), BCMath\initialize(), GMP\initialize(), PHP\initialize(), ArrayHelper\invert(), IpHelper\IPinList(), Uri\isInternal(), jimport(), XML\loadCurveByParam(), TemplateAdapter\loadLanguage(), BcMathCalculator\modPow(), GmpCalculator\modPow(), NativeCalculator\modPow(), PlgSystemSef\onAfterRender(), BigInteger\parse(), FilesystemHelper\parseSizeUnit(), ItemModel\preprocessForm(), LdapClient\read(), StringsModel\refresh(), Uri\reset(), SiteApplication\route(), CMSApplication\route(), ItemModel\save(), X509\setSerialNumber(), Client\signRequest(), Calculator\toArbitraryBase(), BigInteger\toArbitraryBase(), GmpCalculator\toBase(), Calculator\toBase(), BigInteger\toBase(), et Query\toUri().

◆ $class_sfx

$class_sfx = htmlspecialchars($params->get('class_sfx', ''), ENT_COMPAT, 'UTF-8')

◆ $default

$default = MenuHelper::getDefault()

◆ $default_id

$default_id = $default->id

◆ $list

$list = MenuHelper::getList($params)

◆ $path

$path = $base->tree
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\_(), FilesystemHandler\__construct(), FileStorage\__construct(), OpensearchDocument\__construct(), Language\__construct(), HtmlView\_addPath(), FileStorage\_checkExpire(), FileStorage\_cleanPath(), PlgContentPagebreak\_createNavigation(), PlgContentPagebreak\_createToc(), FileStorage\_deleteFolder(), FileStorage\_filesInFolder(), FileStorage\_folders(), Folder\_items(), Captcha\_load(), JLoader\_load(), Editor\_loadEditor(), HtmlView\_prepareDocument(), HtmlView\_setPath(), MediaController\add(), Mail\addAttachment(), PHPMailer\addAttachment(), Toolbar\addButtonPath(), PlgExtensionFinder\addCommonWords(), SysinfoModel\addDirectory(), PHPMailer\addEmbeddedImage(), HTMLHelper\addFileToBuffer(), HtmlView\addHelperPath(), BaseModel\addIncludePath(), CacheController\addIncludePath(), FileLayout\addIncludePath(), Table\addIncludePath(), CacheStorage\addIncludePath(), Cache\addIncludePath(), HTMLHelper\addIncludePath(), BaseController\addModelPath(), FormHelper\addPath(), BaseController\addPath(), MenusHelper\addPreset(), WebAssetRegistry\addRegistryFile(), HtmlView\addTemplatePath(), BaseController\addViewPath(), Users\admin_language(), Registry\append(), PharExtensionInterceptor\assert(), PharMetaDataInterceptor\assert(), ConjunctionInterceptor\assert(), Behavior\assert(), Manager\assert(), PharStreamWrapper\assert(), PHPMailer\attachAll(), PharExtensionInterceptor\baseFileContainsPharExtension(), PharMetaDataInterceptor\baseFileDoesNotHaveMetaDataIssues(), StandardRules\build(), Path\canChmod(), FtpClient\chdir(), Path\check(), FieldModel\checkDefaultValue(), Checkfiles\checkImages(), FtpClient\chmod(), Path\clean(), PharStreamWrapper\collectInvocation(), ClassNotFoundErrorEnhancer\convertFileToClass(), HTMLHelper\convertToRelativePath(), Folder\copy(), File\copy(), TemplateAdapter\copyBaseFiles(), PluginAdapter\copyBaseFiles(), ModuleAdapter\copyBaseFiles(), ComponentAdapter\copyBaseFiles(), TemplateModel\copyFile(), Installer\copyManifest(), Folder\create(), FtpClient\create(), Symfony\Contracts\Service\createCircularReferenceException(), ConfigurationModel\createConfiguration(), DatabaseHandler\createDatabaseTable(), ApiModel\createFile(), LocalAdapter\createFile(), ApiModel\createFolder(), LocalAdapter\createFolder(), TemplateModel\createFolder(), TemplateModel\createOverride(), LegacyComponent\createRouter(), LegacyFactory\createView(), Zip\createZipFile(), TemplateModel\cropImage(), MediumModel\delete(), LocalAdapter\delete(), Folder\delete(), ApiModel\delete(), FtpClient\delete(), SFTP\delete(), SFTP\delete_recursive(), ConfigurationModel\deleteConfiguration(), TemplateModel\deleteFolder(), Helper\determineBaseFile(), ModuleDispatcher\dispatch(), LegacyComponentDispatcher\dispatch(), MediaController\displayItem(), PlgContentVote\displayVotingData(), ExtensionInstallCommand\doExecute(), MediaController\edit(), PHPMailer\encodeFile(), Registry\exists(), Folder\exists(), LanguageHelper\exists(), X509\extensions(), Archive\extract(), Tar\extract(), Registry\extract(), TemplateModel\extractArchive(), Zip\extractCustom(), LocalFileReference\file(), InMemory\file(), SFTP\file_exists(), SFTP\fileatime(), SFTP\filegroup(), PHPMailer\fileIsAccessible(), SFTP\filemtime(), SFTP\fileowner(), SFTP\fileperms(), Folder\files(), SFTP\filesize(), SFTP\filetype(), FileAdapter\finaliseInstall(), Path\find(), ClassNotFoundErrorEnhancer\findClassInPath(), PharInvocationResolver\findInBaseNames(), Folder\folders(), DataFormatter\formatPath(), AbstractDataCollector\formatPath(), FilesystemHelper\ftpChmod(), Helper\ftpChmod(), FileStorage\get(), Registry\get(), Task\get(), SFTP\get_lstat_cache_prop(), SFTP\get_stat_cache_prop(), SFTP\get_xstat_cache_prop(), FileStorage\getAll(), TemplateModel\getArchive(), Helper\getCanonicalPath(), LegacyComponent\getCategory(), Router\getCategorySegment(), ClassNotFoundErrorEnhancer\getClassCandidates(), TemplateModel\getCoreList(), LocalAdapter\getEncodedPath(), X509\getExtension(), X509\getExtensionHelper(), X509\getExtensions(), X509\getExtensionsHelper(), ApiModel\getFile(), TemplateModel\getFile(), LocalAdapter\getFile(), FileModel\getFileInformation(), LocalAdapter\getFileName(), ApiModel\getFiles(), LocalAdapter\getFiles(), TemplateModel\getFiles(), InstalledModel\getFolders(), TemplateModel\getFont(), ComponentModel\getForm(), ContenthistoryHelper\getFormFile(), FieldsPlugin\getFormPath(), TemplateModel\getImage(), Image\getImageFileProperties(), InstallerHelper\getInstallationXML(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), CacheController\getInstance(), BaseController\getInstance(), MediumModel\getItem(), PluginModel\getItem(), StyleModel\getItem(), ModuleModel\getItem(), MediaModel\getItems(), PositionsModel\getItems(), SelectModel\getItems(), MediaField\getLayoutData(), LocalAdapter\getLocalPath(), PlgSystemLogrotation\getLogFiles(), TemplateModel\getMediaFiles(), ModulesHelper\getModules(), JNamespacePsr4Map\getNamespaces(), FolderlistField\getOptions(), FilelistField\getOptions(), TemplateModel\getOverridesFolder(), TemplateModel\getOverridesList(), RouterView\getPath(), InstalledModel\getPath(), LanguagesModel\getPath(), Image\getPath(), PlgSampledataMultilang\getPath(), LocalAdapter\getPathInformation(), Path\getPermissions(), ModulesModel\getPositions(), X509\getPublicKey(), LocalAdapter\getResource(), ApiRouter\getRoutePath(), Authentication\getSiteIcon(), ChromestyleField\getTemplateModuleStyles(), ModulesHelper\getTranslatedModulePosition(), MenutypesModel\getTypeOptionsFromLayouts(), MenutypesModel\getTypeOptionsFromMvc(), TemplateModel\getUpdatedList(), WebAssetItem\getUri(), ApiModel\getUrl(), LocalAdapter\getUrl(), Helper\hasPharPrefix(), HTMLHelper\image(), JLoader\import(), HTMLHelper\includeRelativeFiles(), Installer\install(), ConjunctionInterceptor\invokeAssertions(), SFTP\is_dir(), SFTP\is_file(), SFTP\is_link(), SFTP\is_readable(), SFTP\is_writable(), SFTP\is_writeable(), Helper\isAbsolutePath(), Tar\isBelow(), Zip\isBelow(), ApiModel\isMediaFile(), Path\isOwner(), WebAssetItem\isPathAbsolute(), WebAssetItem\isPathExternal(), PHPMailer\isPermittedPath(), X509\isSubArrayValid(), jimport(), Users\language(), FtpClient\listDetails(), Folder\listFolderTree(), FtpClient\listNames(), JNamespacePsr4Map\load(), Language\load(), JLoader\loadByPsr(), FormHelper\loadClass(), Image\loadFile(), FileAdapter\loadLanguage(), LibraryAdapter\loadLanguage(), TemplateAdapter\loadLanguage(), PluginAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), PackageAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), WebApplication\loadSystemUris(), AbstractWebApplication\loadSystemUris(), Microdata\loadTypes(), FileStorage\lock(), Folder\makeSafe(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), Laminas\Diactoros\marshalUriFromSapi(), PHPMailer\mb_pathinfo(), FtpClient\mkdir(), File\move(), Folder\move(), Helper\normalizePath(), Helper\normalizeWindowsPath(), PlgContentPagenavigation\onContentBeforeDisplay(), FieldsPlugin\onContentPrepareForm(), FieldsPlugin\onCustomFieldsGetTypes(), FieldsPlugin\onCustomFieldsPrepareField(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), Installer\parseFiles(), SiteRouter\parseInit(), Installer\parseLanguages(), Installer\parseMedia(), PostinstallHelper\parsePath(), WebAssetRegistry\parseRegistryFile(), WebAssetRegistry\parseRegistryFiles(), Util\parseRelationshipPaths(), PlgSystemLanguageFilter\parseRule(), Installer\parseXMLInstallFile(), LanguageHelper\parseXMLLanguageFile(), FileAdapter\populateFilesAndFolderList(), ComponentModel\populateState(), ApiController\postFiles(), ToolbarHelper\preferences(), HtmlView\prepareDocument(), UpdateModel\preparePreUpdate(), GroupModel\preprocessForm(), CategoryModel\preprocessForm(), FieldModel\preprocessForm(), ItemModel\preprocessForm(), ExtensionInstallCommand\processPathInstallation(), ExtensionInstallCommand\processUrlInstallation(), ApiController\putFiles(), SFTP\query_stat_cache(), Key\readFile(), SFTP\realpath(), Nested\rebuild(), Nested\rebuildPath(), AbstractWebApplication\redirect(), StringsModel\refresh(), JLoader\register(), JLoader\registerNamespace(), JLoader\registerPrefix(), Helper\remotefsize(), FilesystemHelper\remotefsize(), FileStorage\remove(), Registry\remove(), SFTP\remove_from_stat_cache(), LanguageAdapter\removeExtensionFiles(), X509\removeExtensionHelper(), Installer\removeFiles(), FileLayout\removeIncludePath(), ApiRouter\removeIndexPhpFromPath(), Helper\removePharPrefix(), TemplateModel\renameFile(), FileLayout\render(), Socket\request(), SocketTransport\request(), TemplateModel\resizeImage(), PharInvocationResolver\resolve(), Manager\resolve(), Path\resolve(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), PharInvocationResolver\resolveBaseName(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\resolveFileUrl(), WebAssetItem\resolvePath(), PharInvocationResolver\resolvePossibleAlias(), Uri\root(), PlgSystemLogrotation\rotate(), MediumModel\save(), ApplicationModel\save(), ApiModel\search(), LocalAdapter\search(), Cookie\set(), Registry\set(), Task\set(), JavascriptRenderer\setBasePath(), ZIPExtraction\setCorrectPermissions(), X509\setExtensionHelper(), Form\setField(), BaseController\setPath(), Path\setPermissions(), SFTP\setstat_recursive(), LanguageAdapter\setupUninstall(), FileStorage\store(), TemplateModel\storeFileInfo(), Buffer\stream_open(), BufferStreamHandler\stream_open(), StreamString\stream_open(), PharStreamWrapper\stream_open(), X509\subArray(), X509\subArrayUnchecked(), Form\syncPaths(), FilePathRule\test(), Image\toFile(), InstallerModel\translate(), UpdateModel\translateExtensionName(), FileStorage\unlock(), Installer\update(), SFTP\update_stat_cache(), LocalAdapter\updateFile(), ApiModel\updateFile(), TemplateModel\uploadFile(), StreamString\url_stat(), PharStreamWrapper\url_stat(), Joomla\CMS\MVC\Model\workflowAfterSave(), UploadedFile\writeFile(), et JNamespacePsr4Map\writeNamespaceFile().

◆ $showAll

$showAll = $params->get('showAllChildren', 1)

Référencé par MenuField\getGroups(), et LimitboxField\getOptions().


Joomla CMS: Référence du fichier mod_messages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_messages
Espaces de nommage | Variables
Référence du fichier mod_messages.php

Espaces de nommage

Joomla\Administrator

Variables

if(! $app->getIdentity() ->authorise('core.login.admin')||! $app->getIdentity() ->authorise('core.manage', 'com_messages')) | try
$messages = $messagesModel->getItems()
catch(RuntimeException $e) | $countUnread = count($messages)

Documentation des variables

◆ $countUnread

catch (RuntimeException $e) $countUnread = count($messages)

◆ $messages

$messages = $messagesModel->getItems()

Référencé par JsonResponse\__construct(), StandardButton\_getCommand(), HtmlDocument\_parseTemplate(), ActionlogModel\addLog(), HtmlView\addToolbar(), SymfonyStyle\block(), SymfonyStyle\createBlock(), ConsoleApplication\doExecute(), Application\doRenderThrowable(), CMSApplication\enqueueMessage(), FormatterHelper\formatBlock(), QuestionHelper\formatChoiceQuestionChoices(), MessageRenderer\getData(), DatabaseModel\getErrorsMessage(), WarningsModel\getItems(), AbstractTime\getLastDateTimeErrors(), CliApplication\getMessageQueue(), ConsoleApplication\getMessageQueue(), CompleteCommand\log(), Joomla\onContentChangeState(), ActionlogModel\sendNotificationEmails(), SymfonyStyle\text(), SetupModel\validate(), OutputStyle\write(), Output\write(), SymfonyStyle\write(), OutputStyle\writeln(), Output\writeln(), et SymfonyStyle\writeln().

◆ try

if (! $app->getIdentity() ->authorise( 'core.login.admin')||! $app->getIdentity() ->authorise( 'core.manage', 'com_messages')) try
Valeur initiale :
{
$messagesModel = $app->bootComponent('com_messages')->getMVCFactory()
->createModel('Messages', 'Administrator', ['ignore_request' => true])
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier mod_multilangstatus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_multilangstatus
Espaces de nommage | Variables
Référence du fichier mod_multilangstatus.php

Espaces de nommage

Joomla\Administrator

Variables

$multilanguageEnabled = Multilanguage::isEnabled($app, Factory::getContainer()->get(DatabaseInterface::class))

Documentation des variables

◆ $multilanguageEnabled

$multilanguageEnabled = Multilanguage::isEnabled($app, Factory::getContainer()->get(DatabaseInterface::class))


Joomla CMS: Référence du fichier mod_popular.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
Espaces de nommage | Variables
Référence du fichier mod_popular.php

Espaces de nommage

Joomla\Administrator

Variables

$model = $app->bootComponent('com_content')->getMVCFactory()->createModel('Articles', 'Administrator', ['ignore_request' => true])
$list = PopularHelper::getList($params, $model)

Documentation des variables

◆ $list

$list = PopularHelper::getList($params, $model)

◆ $model

$model = $app->bootComponent('com_content')->getMVCFactory()->createModel('Articles', 'Administrator', ['ignore_request' => true])


Joomla CMS: Référence du fichier mod_post_installation_messages.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_post_installation_messages
Espaces de nommage | Variables
Référence du fichier mod_post_installation_messages.php

Espaces de nommage

Joomla\Administrator

Variables

try
$messagesCount = $messagesModel->getItemsCount()
catch(RuntimeException $e) $joomlaFilesExtensionId = ExtensionHelper::getExtensionRecord('joomla', 'file')->extension_id

Documentation des variables

◆ $joomlaFilesExtensionId

catch (RuntimeException $e) $joomlaFilesExtensionId = ExtensionHelper::getExtensionRecord('joomla', 'file')->extension_id

◆ $messagesCount

$messagesCount = $messagesModel->getItemsCount()

◆ try

try
Valeur initiale :
{
$messagesModel = $app->bootComponent('com_postinstall')->getMVCFactory()
->createModel('Messages', 'Administrator', ['ignore_request' => true])
$app
$app
Definition: administrator/components/com_associations/layouts/joomla/searchtools/default.php:85


Joomla CMS: Référence du fichier mod_privacy_dashboard.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
Espaces de nommage | Variables
Référence du fichier mod_privacy_dashboard.php

Espaces de nommage

Joomla\Administrator

Variables

$lang = $app->getLanguage()
$list = PrivacyDashboardHelper::getData()
if(count($list)) else

Documentation des variables

◆ $lang

$lang = $app->getLanguage()

◆ $list

$list = PrivacyDashboardHelper::getData()

◆ else

if (count( $list)) else
Valeur initiale :
{
echo LayoutHelper::render('joomla.content.emptystate_module', [
'textPrefix' => 'COM_PRIVACY_REQUESTS',
'icon' => 'icon-lock',
])


Joomla CMS: Référence du fichier mod_privacy_status.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
Espaces de nommage | Variables
Référence du fichier mod_privacy_status.php

Espaces de nommage

Joomla\Administrator

Variables

$lang = $app->getLanguage()
$privacyPolicyInfo = PrivacyStatusHelper::getPrivacyPolicyInfo()
$requestFormPublished = PrivacyStatusHelper::getRequestFormPublished()
$privacyConsentPluginId = PrivacyHelper::getPrivacyConsentPluginId()
$sendMailEnabled = (bool) $app->get('mailonline', 1)
$numberOfUrgentRequests = PrivacyStatusHelper::getNumberUrgentRequests()
$urgentRequestDays = (int) ComponentHelper::getParams('com_privacy')->get('notify', 14)
$databaseConnectionEncryption = Factory::getContainer()->get('DatabaseDriver')->getConnectionEncryption()

Documentation des variables

◆ $databaseConnectionEncryption

$databaseConnectionEncryption = Factory::getContainer()->get('DatabaseDriver')->getConnectionEncryption()

◆ $lang

$lang = $app->getLanguage()

◆ $numberOfUrgentRequests

$numberOfUrgentRequests = PrivacyStatusHelper::getNumberUrgentRequests()

◆ $privacyConsentPluginId

$privacyConsentPluginId = PrivacyHelper::getPrivacyConsentPluginId()

◆ $privacyPolicyInfo

$privacyPolicyInfo = PrivacyStatusHelper::getPrivacyPolicyInfo()

◆ $requestFormPublished

$requestFormPublished = PrivacyStatusHelper::getRequestFormPublished()

◆ $sendMailEnabled

$sendMailEnabled = (bool) $app->get('mailonline', 1)

◆ $urgentRequestDays

$urgentRequestDays = (int) ComponentHelper::getParams('com_privacy')->get('notify', 14)


Joomla CMS: Référence du fichier mod_random_image.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
Espaces de nommage | Variables
Référence du fichier mod_random_image.php

Espaces de nommage

Joomla\Site

Variables

$link = $params->get('link')
$folder = RandomImageHelper::getFolder($params)
$images = RandomImageHelper::getImages($params, $folder)
$image = RandomImageHelper::getRandomImage($params, $images)

Documentation des variables

◆ $folder

$folder = RandomImageHelper::getFolder($params)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par ChangeSet\__construct(), PluginsField\__get(), FileStorage\_deleteFolder(), ExtensionHelper\checkIfCoreExtension(), FileStorage\clean(), Installer\cleanDiscoveredExtension(), TemplateModel\copy(), FileAdapter\copyBaseFiles(), PackageAdapter\copyBaseFiles(), TemplateModel\createTemplateOverride(), Folder\delete(), JoomlaInstallerScript\deleteUnexistingFiles(), LibraryAdapter\discover(), PluginAdapter\discover(), RemoveOldFilesCommand\doExecute(), PackageAdapter\finaliseUninstall(), FileStorage\getAll(), TemplateModel\getCoreFile(), SysinfoModel\getDirectory(), InstallerHelper\getExtensionDownloadKey(), InstallerHelper\getExtensionGroups(), ExtensionHelper\getExtensionRecord(), LocalAdapter\getFiles(), RandomImageHelper\getFolder(), TemplateModel\getFont(), PluginModel\getForm(), RandomImageHelper\getImages(), InstallerHelper\getInstallationXML(), ChangeSet\getInstance(), MediaField\getLayoutData(), DiscoverModel\getListQuery(), UpdateModel\getListQuery(), PluginsModel\getListQuery(), ManageModel\getListQuery(), DatabaseModel\getListQuery(), UpdatesitesModel\getListQuery(), PluginsField\getOptions(), FolderlistField\getOptions(), TemplateModel\getOverridesFolder(), TemplateModel\getOverridesList(), MenusHelper\getPresets(), PluginorderingField\getQuery(), MenutypesModel\getTypeOptionsFromLayouts(), PluginAdapter\loadLanguage(), ModuleAdapter\loadLanguage(), ComponentAdapter\loadLanguage(), PackageManifest\loadManifestFromData(), Installer\parseFiles(), Installer\parseLanguages(), Installer\parseMedia(), FileAdapter\populateFilesAndFolderList(), PluginModel\preprocessForm(), FileAdapter\removeExtensionFiles(), InstallerScript\removeFiles(), Installer\removeFiles(), et DaemonApplication\writeProcessIdFile().

◆ $image

$image = RandomImageHelper::getRandomImage($params, $images)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par OpensearchDocument\addImage(), Checkfiles\checkImages(), TemplateModel\cropImage(), TemplateModel\getImage(), Authentication\getKnownAuthenticators(), RandomImageHelper\getRandomImage(), RssParser\handleImage(), OpensearchDocument\render(), TemplateModel\resizeImage(), et HTMLHelper\tooltip().

◆ $images

$images = RandomImageHelper::getImages($params, $folder)

◆ $link

$link = $params->get('link')


Joomla CMS: Référence du fichier mod_related_items.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
Espaces de nommage | Variables
Référence du fichier mod_related_items.php

Espaces de nommage

Joomla\Site

Variables

$cacheparams = new \stdClass()
$cacheparams | cachemode = 'safeuri'
$cacheparams | method = 'getList'
$cacheparams | methodparams = $params
$cacheparams | modeparams = array('id' => 'int', 'Itemid' => 'int')
$list = ModuleHelper::moduleCache($module, $params, $cacheparams)
if(!count($list)) | $showDate = $params->get('showDate', 0)

Documentation des variables

◆ $cacheparams

$cacheparams = new \stdClass()

◆ $list

$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

◆ $showDate

if (!count( $list)) $showDate = $params->get('showDate', 0)

◆ cachemode

$cacheparams cachemode = 'safeuri'

◆ method

$cacheparams method = 'getList'

◆ methodparams

$cacheparams methodparams = $params

◆ modeparams

$cacheparams modeparams = array('id' => 'int', 'Itemid' => 'int')


Joomla CMS: Référence du fichier mod_sampledata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
Espaces de nommage | Variables
Référence du fichier mod_sampledata.php

Espaces de nommage

Joomla\Administrator

Variables

$items = \Joomla\Module\Sampledata\Administrator\Helper\SampledataHelper::getList()

Documentation des variables

◆ $items

$items = \Joomla\Module\Sampledata\Administrator\Helper\SampledataHelper::getList()

Référencé par RouteHelper\_findItem(), AdministratorService\association(), Menus\association(), TasksModel\attachTaskOptions(), MenuRules\buildLookup(), Category\categories(), Adapter\categoryAccessChange(), Adapter\categoryStateChange(), CssMenu\check(), CategoryView\commonCategoryDisplay(), TraceableTwigEnvironment\computeAlternatives(), Parser\convertItems(), Builder\convertItems(), NewsfeedsHelper\countItems(), Joomla\CMS\Categories\countItems(), LegacyComponent\countItems(), WorkflowsModel\countItems(), TagsModel\countItems(), ContentComponent\countItems(), CategoriesModel\countItems(), ContentHelper\countRelations(), NewsfeedsHelper\countTagItems(), LegacyComponent\countTagItems(), ContentComponent\countTagItems(), PrivacyPlugin\createCustomFieldsDomain(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), FeedView\display(), CategoryFeedView\display(), CategoriesView\display(), HtmlView\display(), JsonapiView\displayList(), Changelog\endElement(), AdminLanguage\existing(), ContentLanguage\existing(), RouteHelper\findItem(), ListHelper\genericordering(), AssociationsHelper\getAssociationHtmlList(), AssociationExtensionHelper\getAssociationList(), Associations\getAssociations(), Joomla\CMS\Tree\getChildren(), CategoryNode\getChildren(), Token\getClaims(), DebugHelper\getComponents(), AbstractMenu\getDefault(), SiteMenu\getDefault(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), Token\getHeaders(), RouteHelper\getItemid(), SuggestionsModel\getItems(), MenusModel\getItems(), FeaturedModel\getItems(), Domain\getItems(), FetchMediaItemsEvent\getItems(), SearchModel\getItems(), TemplatesModel\getItems(), TagModel\getItems(), PositionsModel\getItems(), GroupsModel\getItems(), WorkflowsModel\getItems(), CategoryModel\getItems(), SelectModel\getItems(), SearchesModel\getItems(), UsersModel\getItems(), CheckinModel\getItems(), HistoryModel\getItems(), ClientsModel\getItems(), AbstractMenu\getItems(), TagsModel\getItems(), CategoriesModel\getItems(), UpdatesitesModel\getItems(), ItemsModel\getItems(), Adapter\getItems(), ArticlesModel\getItems(), ArticlesCategoriesHelper\getList(), StatsHelper\getList(), ArticlesPopularHelper\getList(), LatestHelper\getList(), BreadcrumbsHelper\getList(), PopularHelper\getList(), ArticlesCategoryHelper\getList(), AbstractMenu\getMenu(), ComponentsField\getOptions(), WorkflowComponentSectionsField\getOptions(), ConfigComponentsField\getOptions(), ComponentsWorkflowField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsFieldgroupField\getOptions(), TransitionField\getOptions(), SqlField\getOptions(), StatsAdminHelper\getStats(), ArticlesModel\getTransitions(), InstallerHelper\getUpdateSitesInformation(), ArticlesCategoryHelper\groupByDate(), BannersModel\impress(), PlgSystemSchedulerunner\injectLazyJS(), Menu\menuItems(), Adapter\onBuildIndex(), Joomla\onContentChangeState(), Adapter\onFinderGarbageCollection(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgPrivacyContent\onPrivacyExportRequest(), PlgPrivacyContact\onPrivacyExportRequest(), Category\options(), Tag\options(), SiteRouter\parseSefRoute(), Adapter\pluginDisable(), GroupsModel\populateExtraData(), ItemModel\rebuild(), Adapter\remove(), MenusController\resync(), FetchMediaItemsEvent\setItems(), Toolbar\setItems(), Tag\tags(), InstallerModel\translate(), PluginsModel\translate(), UpdateModel\translate(), et ModulesModel\translate().


Joomla CMS: Référence du fichier mod_stats.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
Espaces de nommage | Variables
Référence du fichier mod_stats.php

Espaces de nommage

Joomla\Site

Variables

$serverinfo = $params->get('serverinfo', 0)
$siteinfo = $params->get('siteinfo', 0)
$list = StatsHelper::getList($params)

Documentation des variables

◆ $list

$list = StatsHelper::getList($params)

◆ $serverinfo

$serverinfo = $params->get('serverinfo', 0)

◆ $siteinfo

$siteinfo = $params->get('siteinfo', 0)


Joomla CMS: Référence du fichier mod_stats_admin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
Espaces de nommage | Variables
Référence du fichier mod_stats_admin.php

Espaces de nommage

Joomla\Administrator

Variables

$serverinfo = $params->get('serverinfo')
$siteinfo = $params->get('siteinfo')
$list = StatsAdminHelper::getStats($params, $app, Factory::getContainer()->get(DatabaseInterface::class))

Documentation des variables

◆ $list

$list = StatsAdminHelper::getStats($params, $app, Factory::getContainer()->get(DatabaseInterface::class))

◆ $serverinfo

$serverinfo = $params->get('serverinfo')

Référencé par StatsHelper\getList(), et StatsAdminHelper\getStats().

◆ $siteinfo

$siteinfo = $params->get('siteinfo')

Référencé par StatsHelper\getList(), et StatsAdminHelper\getStats().


Joomla CMS: Référence du fichier mod_submenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
Espaces de nommage | Variables
Référence du fichier mod_submenu.php

Espaces de nommage

Joomla\Administrator

Variables

$menutype = $params->get('menutype', '*')
$root = false
if($menutype===' *' else )

Documentation des variables

◆ $menutype

$menutype = $params->get('menutype', '*')

◆ $root

$root = false

◆ else

if ( $menutype===' *' else)
Valeur initiale :
{
$root = MenusHelper::getMenuItems($menutype, true)
Joomla\Component\Menus\Administrator\Helper\MenusHelper\getMenuItems
static getMenuItems($menutype, $enabledOnly=false, $exclude=array())
Definition: MenusHelper.php:300
$root
$root
Definition: mod_submenu.php:19
$menutype
$menutype
Definition: mod_submenu.php:18


Joomla CMS: Référence du fichier mod_syndicate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
Espaces de nommage | Variables
Référence du fichier mod_syndicate.php

Espaces de nommage

Joomla\Site

Variables

$link = SyndicateHelper::getLink($params, $app->getDocument())
if($link===null) $text = htmlspecialchars($params->get('text', ''), ENT_COMPAT, 'UTF-8')

Documentation des variables

◆ $link

$link = SyndicateHelper::getLink($params, $app->getDocument())

◆ $text

if ( $link===null) $text = htmlspecialchars($params->get('text', ''), ENT_COMPAT, 'UTF-8')


Joomla CMS: Référence du fichier mod_tags_popular.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
Espaces de nommage | Variables
Référence du fichier mod_tags_popular.php

Espaces de nommage

Joomla\Site

Variables

$cacheparams = new \stdClass()
$cacheparams | cachemode = 'safeuri'
$cacheparams | method = 'getList'
$cacheparams | methodparams = $params
$cacheparams | modeparams = array('id' => 'array', 'Itemid' => 'int')
$list = ModuleHelper::moduleCache($module, $params, $cacheparams)
if(!count($list) &&! $params->get('no_results_text')) | $display_count = $params->get('display_count', 0)

Documentation des variables

◆ $cacheparams

$cacheparams = new \stdClass()

◆ $display_count

if (!count( $list) &&! $params->get( 'no_results_text')) $display_count = $params->get('display_count', 0)

◆ $list

$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

◆ cachemode

$cacheparams cachemode = 'safeuri'

◆ method

$cacheparams method = 'getList'

◆ methodparams

$cacheparams methodparams = $params

◆ modeparams

$cacheparams modeparams = array('id' => 'array', 'Itemid' => 'int')


Joomla CMS: Référence du fichier mod_tags_similar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
Espaces de nommage | Variables
Référence du fichier mod_tags_similar.php

Espaces de nommage

Joomla\Site

Variables

$cacheparams = new \stdClass()
$cacheparams | cachemode = 'safeuri'
$cacheparams | method = 'getList'
$cacheparams | methodparams = $params
$cacheparams | modeparams = array('id' => 'array', 'Itemid' => 'int')
$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

Documentation des variables

◆ $cacheparams

$cacheparams = new \stdClass()

◆ $list

$list = ModuleHelper::moduleCache($module, $params, $cacheparams)

◆ cachemode

$cacheparams cachemode = 'safeuri'

◆ method

$cacheparams method = 'getList'

◆ methodparams

$cacheparams methodparams = $params

◆ modeparams

$cacheparams modeparams = array('id' => 'array', 'Itemid' => 'int')


Joomla CMS: Référence du fichier mod_title.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_title
Espaces de nommage | Variables
Référence du fichier mod_title.php

Espaces de nommage

Joomla\Administrator

Variables

if (isset( $app->JComponentTitle))

Documentation des variables

◆ if

if(isset($app->JComponentTitle))


Joomla CMS: Référence du fichier mod_toolbar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_toolbar
Espaces de nommage | Variables
Référence du fichier mod_toolbar.php

Espaces de nommage

Joomla\Administrator

Variables

$toolbar = Toolbar::getInstance('toolbar')->render()

Documentation des variables

◆ $toolbar

$toolbar = Toolbar::getInstance('toolbar')->render()

Référencé par HtmlView\addToolbar(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), et HtmlView\toolbar().


Joomla CMS: Référence du fichier mod_user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_user
Espaces de nommage | Variables
Référence du fichier mod_user.php

Espaces de nommage

Joomla\Administrator

Variables

$user = $app->getIdentity()

Documentation des variables

◆ $user

$user = $app->getIdentity()


Joomla CMS: Référence du fichier mod_users_latest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
Espaces de nommage | Variables
Référence du fichier mod_users_latest.php

Espaces de nommage

Joomla\Site

Variables

$shownumber = $params->get('shownumber', 5)
$names = UsersLatestHelper::getUsers($params)

Documentation des variables

◆ $names

$names = UsersLatestHelper::getUsers($params)

Référencé par BCMath\__callStatic(), JWSSerializerManagerFactory\create(), Form\findField(), Form\findFieldsByGroup(), Form\findGroup(), CertificateSubject\fromBinary(), Application\getAbbreviations(), HttpFactory\getHttpTransports(), Pathway\getPathwayNames(), ApplicationDescription\inspectApplication(), XML\query(), TraceableTwigEnvironment\resolveTemplate(), FieldModel\save(), et X509\validateURL().

◆ $shownumber

$shownumber = $params->get('shownumber', 5)


Joomla CMS: Référence du fichier mod_version.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
Espaces de nommage | Variables
Référence du fichier mod_version.php

Espaces de nommage

Joomla\Administrator

Variables

$version = \Joomla\Module\Version\Administrator\Helper\VersionHelper::getVersion()

Documentation des variables

◆ $version

$version = \Joomla\Module\Version\Administrator\Helper\VersionHelper::getVersion()


Joomla CMS: Référence du fichier mod_whosonline.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
Espaces de nommage | Variables
Référence du fichier mod_whosonline.php

Espaces de nommage

Joomla\Site

Variables

if($app->get('session_metadata', true)) else

Documentation des variables

◆ else

if ( $app->get( 'session_metadata', true)) else
Valeur initiale :
{
require ModuleHelper::getLayoutPath('mod_whosonline', 'disabled')


Joomla CMS: Référence du fichier mod_wrapper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
Espaces de nommage | Variables
Référence du fichier mod_wrapper.php

Espaces de nommage

Joomla\Site

Variables

$params = WrapperHelper::getParams($params)
$load = $params->get('load')
$url = htmlspecialchars($params->get('url', ''), ENT_COMPAT, 'UTF-8')
$target = htmlspecialchars($params->get('target', ''), ENT_COMPAT, 'UTF-8')
$width = htmlspecialchars($params->get('width', ''), ENT_COMPAT, 'UTF-8')
$height = htmlspecialchars($params->get('height', ''), ENT_COMPAT, 'UTF-8')
$ititle = $module->title
$id = $module->id
$lazyloading = $params->get('lazyloading', 'lazy')

Documentation des variables

◆ $height

$height = htmlspecialchars($params->get('height', ''), ENT_COMPAT, 'UTF-8')

◆ $id

$id = $module->id

◆ $ititle

$ititle = $module->title

◆ $lazyloading

$lazyloading = $params->get('lazyloading', 'lazy')

◆ $load

$load = $params->get('load')

Référencé par WrapperHelper\getParams().

◆ $params

$params = WrapperHelper::getParams($params)

◆ $target

$target = htmlspecialchars($params->get('target', ''), ENT_COMPAT, 'UTF-8')

◆ $url

$url = htmlspecialchars($params->get('url', ''), ENT_COMPAT, 'UTF-8')

◆ $width

$width = htmlspecialchars($params->get('width', ''), ENT_COMPAT, 'UTF-8')


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
  • associations
Espaces de nommage | Variables
Référence du fichier administrator/components/com_associations/tmpl/associations/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $this->document->getWebAssetManager()
$function = $app->input->getCmd('function', 'jSelectAssociation')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$canManageCheckin = Factory::getUser()->authorise('core.manage', 'com_checkin')
$iconStates
else __pad2__
endif
$canCheckin = $canManageCheckin || AssociationsHelper::canCheckinItem($this->extensionName, $this->typeName, $item->id)
$isCheckout = AssociationsHelper::isCheckoutItem($this->extensionName, $this->typeName, $item->id)
data id
else __pad3__
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $canCheckin

$canCheckin = $canManageCheckin || AssociationsHelper::canCheckinItem($this->extensionName, $this->typeName, $item->id)

◆ $canManageCheckin

$canManageCheckin = Factory::getUser()->authorise('core.manage', 'com_checkin')

◆ $function

$function = $app->input->getCmd('function', 'jSelectAssociation')
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HTMLHelper\_(), ArgsStub\__construct(), TraceableTwigEnvironment\addFunction(), DisplayController\addModule(), RouterLegacy\build(), ErrorHandler\call(), HTMLHelper\call(), ReflectionCaster\castReflectionGenerator(), DebugClassLoader\checkClasses(), Ctype\convert_int_to_char_for_ctype(), DebugClassLoader\disable(), Application\doRenderThrowable(), DebugClassLoader\enable(), ClassNotFoundErrorEnhancer\getClassCandidates(), DataSet\getObjectsKeys(), ArgsStub\getParameters(), RouterLegacy\parse(), HTMLHelper\register(), Language\setIgnoredSearchWordsCallback(), Language\setLowerLimitSearchWordCallback(), Language\setPluralSuffixesCallback(), Integer\setRecurringModuloFunction(), Language\setSearchDisplayedCharactersNumberCallback(), Language\setTransliterator(), et Language\setUpperLimitSearchWordCallback().

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $isCheckout

$isCheckout = AssociationsHelper::isCheckoutItem($this->extensionName, $this->typeName, $item->id)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ __pad3__

else __pad3__

◆ endforeach

endforeach

◆ endif

endif

◆ id

integer $authorId The author id
Valeur initiale :
="<?php echo $item->id; ?>">
<?php echo $this->escape($item->title)
$item
else $item
Definition: administrator/components/com_menus/tmpl/items/modal.php:165


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Espaces de nommage | Variables
Référence du fichier administrator/components/com_categories/tmpl/categories/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$extension = $this->escape($this->state->get('filter.extension'))
$function = $app->input->getCmd('function', 'jSelectCategory')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
else __pad3__
$iconStates
foreach( $this->items as $i=> $item)($item->language &&Multilanguage::isEnabled()) elseif (!Multilanguage::isEnabled())
else __pad4__
endif
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $extension

$extension = $this->escape($this->state->get('filter.extension'))

◆ $function

$function = $app->input->getCmd('function', 'jSelectCategory')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ __pad3__

else __pad3__

◆ __pad4__

else __pad4__

◆ elseif

foreach ($this->items as $i => $item) ( $item->language &&Multilanguage::isEnabled()) elseif(!Multilanguage::isEnabled())

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • category
Espaces de nommage
Référence du fichier administrator/components/com_categories/tmpl/category/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contact
Espaces de nommage
Référence du fichier administrator/components/com_contact/tmpl/contact/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Espaces de nommage | Variables
Référence du fichier administrator/components/com_contact/tmpl/contacts/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $this->document->getWebAssetManager()
$function = $app->input->getCmd('function', 'jSelectContact')
$editor = $app->input->getCmd('editor', '')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$onclick = $this->escape($function)
$multilang = Multilanguage::isEnabled()
if (!empty( $editor))
else __pad2__
endif
$iconStates
foreach( $this->items as $i=> $item)($item->language && $multilang) elseif (! $multilang)
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $editor

$editor = $app->input->getCmd('editor', '')

Référencé par Editor\__construct(), Editor\getButtons(), EditorField\getEditor(), SysinfoModel\getEditor(), EditorField\getInput(), Editor\getInstance(), CMSApplication\initialiseApp(), et Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay().

◆ $function

$function = $app->input->getCmd('function', 'jSelectContact')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $multilang

$multilang = Multilanguage::isEnabled()

Référencé par LanguagesHelper\getList().

◆ $onclick

string $onclick = $this->escape($function)

Référencé par AdministratorService\featured(), ImpmadeField\getInput(), ClicksField\getInput(), et FormField\getLayoutData().

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad2__

else __pad2__

◆ elseif

foreach ($this->items as $i => $item) ( $item->language &&$multilang) elseif(! $multilang)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($editor))


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • article
Espaces de nommage
Référence du fichier administrator/components/com_content/tmpl/article/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/articles/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $this->document->getWebAssetManager()
$function = $app->input->getCmd('function', 'jSelectArticle')
$editor = $app->input->getCmd('editor', '')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$onclick = $this->escape($function)
$multilang = Multilanguage::isEnabled()
if (!empty( $editor))
else __pad4__
endif
$iconStates
foreach( $this->items as $i=> $item)($item->language && $multilang) elseif (! $multilang)
$attribs
else __pad5__
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $attribs

$attribs
Valeur initiale :
= 'data-function="' . $this->escape($onclick) . '"'
. ' data-id="' . $item->id . '"'
. ' data-title="' . $this->escape($item->title) . '"'
. ' data-cat-id="' . $this->escape($item->catid) . '"'
. ' data-uri="' . $this->escape(RouteHelper::getArticleRoute($item->id, $item->catid, $item->language)) . '"'
. ' data-language="' . $this->escape($lang) . '"'
$lang
$lang
Definition: administrator/components/com_categories/tmpl/categories/emptystate.php:22
$onclick
$onclick
Definition: administrator/components/com_content/tmpl/articles/modal.php:38
$item
else $item
Definition: administrator/components/com_menus/tmpl/items/modal.php:165
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par HtmlDocument\_parseTemplate(), HtmlView\_prepareDocument(), CategoryView\addFeed(), HtmlDocument\addHeadLink(), Document\addScript(), Document\addStyleSheet(), Access\assetgrouplist(), Select\booleanlist(), HTMLHelper\calendar(), JHtmlIcon\create(), Icon\create(), JHtmlIcon\edit(), Icon\edit(), Select\genericlist(), UpdateModel\getCollectionDetailsUrls(), TosField\getLabel(), ConsentBoxField\getLabel(), Select\groupedlist(), HTMLHelper\iframe(), HTMLHelper\image(), Select\integerlist(), Access\level(), HTMLHelper\link(), Menu\menuItemList(), ListHelper\ordering(), Select\radiolist(), ModuleRenderer\render(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), ScriptsRenderer\renderInlineElement(), StylesRenderer\renderInlineElement(), ModuleHelper\renderModule(), HTMLHelper\script(), HTMLHelper\stylesheet(), Form\token(), et Access\usergroup().

◆ $editor

$editor = $app->input->getCmd('editor', '')

◆ $function

$function = $app->input->getCmd('function', 'jSelectArticle')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $multilang

$multilang = Multilanguage::isEnabled()

◆ $onclick

$onclick = $this->escape($function)

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad4__

else __pad4__

◆ __pad5__

else __pad5__

◆ elseif

foreach ($this->items as $i => $item) ( $item->language &&$multilang) elseif(! $multilang)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($editor))


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • history
Espaces de nommage | Variables
Référence du fichier administrator/components/com_contenthistory/tmpl/history/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$hash = $this->state->get('sha1_hash')
$formUrl = 'index.php?option=com_contenthistory&view=history&layout=modal&tmpl=component&item_id=' . $this->state->get('item_id') . '&' . Session::getFormToken() . '=1'
$wa = $this->document->getWebAssetManager()
$i = 0
foreach ( $this->items as $item)
endif
else __pad1__
endforeach

Documentation des variables

◆ $formUrl

$formUrl = 'index.php?option=com_contenthistory&view=history&layout=modal&tmpl=component&item_id=' . $this->state->get('item_id') . '&' . Session::getFormToken() . '=1'

◆ $hash

$hash = $this->state->get('sha1_hash')

Référencé par PlgSystemLogout\__construct(), Hash\__construct(), Cache\_getStorage(), CallbackController\_makeId(), PlgSystemHttpHeaders\applyHashesToCspRule(), Category\categories(), Argon2idHandler\checkIfRehashNeeded(), BCryptHandler\checkIfRehashNeeded(), Argon2iHandler\checkIfRehashNeeded(), ChainedHandler\checkIfRehashNeeded(), PasswordHash\CheckPassword(), X509\computeKeyIdentifier(), Builder\createSignature(), PasswordHash\crypt_private(), ParagonIE_Sodium_Compat\crypto_pwhash_scryptsalsa208sha256_str_verify(), ParagonIE_Sodium_Compat\crypto_pwhash_str_verify(), RSA\encodeEMSA15(), PSSRSA\encodeEMSAPSS(), RSA\encodeEMSAPSS(), CombGenerator\generate(), Access\getAssetRules(), Factory\getCache(), Totp\getCode(), X509\getDN(), Categories\getInstance(), AuthorField\getOptions(), LogcreatorField\getOptions(), LimitboxField\getOptions(), PredefinedlistField\getOptions(), SiteApplication\getParams(), FileLayout\getPath(), SSH2\getServerPublicHostKey(), Argon2iHandler\hashPassword(), PasswordHash\HashPassword(), Crypto\HKDF(), PluginHelper\import(), InstallerHelper\isChecksumValid(), UpdateModel\isChecksumValid(), PuTTY\load(), PKCS8\load(), Joomla\CMS\MVC\Model\loadForm(), FormModel\loadForm(), HtmlDocument\mergeHeadData(), MessagesModel\onProcessList(), Category\options(), Tag\options(), Parser\parseSignature(), SSH2\privatekey_login(), PlgSystemSchedulerunner\runWebCron(), Hash\setHash(), SymmetricKey\setPassword(), Hash\sha512(), RSA\sign(), Php72\spl_object_id(), Ini\stringToObject(), Tag\tags(), UuidFactory\uuidFromHashedName(), UuidFactory\uuidFromNsAndName(), RSA\verify(), PSSRSA\verifyEMSAPSS(), RSA\verifyEMSAPSS(), Identity\withHash(), PuTTY\wrapPrivateKey(), et PKCS8\wrapPrivateKey().

◆ $i

$i = 0

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad1__

else __pad1__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $item)


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • fields
Espaces de nommage | Variables
Référence du fichier administrator/components/com_fields/tmpl/fields/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$editor = Factory::getApplication()->input->get('editor', '', 'cmd')
else __pad3__
$iconStates
foreach ( $this->items as $i=> $item)
endforeach
endif

Documentation des variables

◆ $editor

$editor = Factory::getApplication()->input->get('editor', '', 'cmd')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad3__

else __pad3__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • item
Espaces de nommage
Référence du fichier administrator/components/com_menus/tmpl/item/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • items
Espaces de nommage | Variables
Référence du fichier administrator/components/com_menus/tmpl/items/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $this->document->getWebAssetManager()
$function = $app->input->get('function', 'jSelectMenuItem', 'cmd')
$editor = $app->input->getCmd('editor', '')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$link = 'index.php?option=com_menus&view=items&layout=modal&tmpl=component&' . Session::getFormToken() . '=1'
$multilang = Multilanguage::isEnabled()
if (!empty( $editor))
else __pad10__
endif
if($item->language && $multilang) | elseif (! $multilang)
$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))
else __pad11__
else __pad12__
else __pad13__
else $item | language_image
else $item $item | language_title
else $item $item array('title'=> $item->language_title) | true
else __pad14__
else __pad15__
else $item
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $editor

$editor = $app->input->getCmd('editor', '')

◆ $function

$function = $app->input->get('function', 'jSelectMenuItem', 'cmd')

◆ $item

else $item

Référencé par GenericLinkProvider\__construct(), SitePathway\__construct(), MapObject\__construct(), ListObject\__construct(), Data\__get(), RouteHelper\_findItem(), InstallerModel\_getList(), PluginsModel\_getList(), Pagination\_item_active(), Pagination\_item_inactive(), HtmlView\_prepareDocument(), MessageController\action(), Access\actions(), InfiniteListObject\add(), ArrayHelper\addColumn(), Domain\addItem(), FeedDocument\addItem(), TagsHelper\addTagMapping(), XmlView\addXmlChild(), ContactController\allowEdit(), NewsfeedController\allowEdit(), ItemController\allowEdit(), TransitionController\allowEdit(), ArrayHelper\arrayFromObject(), AdministratorService\association(), Menus\association(), TasksModel\attachTaskOptions(), NomenuRules\build(), StandardRules\build(), SiteRouter\buildComponentPreprocess(), SiteRouter\buildInit(), MenuRules\buildLookup(), SiteRouter\buildSefRoute(), WebAssetManager\calculateOrderOfActiveAssets(), AssociationsHelper\canCheckinItem(), RequestController\canTransition(), Category\categories(), Adapter\categoryAccessChange(), Adapter\categoryStateChange(), Adapter\change(), ChangeSet\check(), AssociationsController\checkin(), BannerModel\click(), DebugBar\collect(), NewsfeedsHelper\countItems(), WorkflowsModel\countItems(), ContentHelper\countRelations(), NewsfeedsHelper\countTagItems(), JavascriptRenderer\createAsseticCollection(), PrivacyPlugin\createCustomFieldsDomain(), PublicKeyCredentialDescriptorCollection\createFromArray(), DisplayPNGCharacteristicsDescriptor\createFromArray(), PrivacyPlugin\createItemFromArray(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), FeedView\display(), CategoryFeedView\display(), VcfView\display(), XmlView\display(), HtmlView\display(), PlgSystemFields\display(), JsonapiView\displayList(), ArrayHelper\dropColumn(), JavascriptRenderer\dumpAssets(), Data\dumpItem(), MenuController\exportXml(), FieldsHelper\extract(), Application\findAlternatives(), RouteHelper\findItem(), ChangeSet\fix(), HtmlErrorRenderer\formatArgs(), RouteHelper\getAdvancedRoute(), ApcuStorage\getAll(), WincacheStorage\getAll(), FileStorage\getAll(), MemcachedStorage\getAll(), RedisStorage\getAll(), AssociationsHelper\getAssociationHtmlList(), AssociationHelper\getAssociations(), Associations\getAssociations(), CategoryAssociationHelper\getCategoryAssociations(), RouteHelper\getCategoryRoute(), DebugHelper\getComponents(), RouteHelper\getComponentTagRoute(), RouteHelper\getComponentTagsRoute(), TracksModel\getContent(), Helper\getContentExtras(), LanguageStringsCollector\getData(), RulesRule\getFieldActions(), FieldsHelper\getFields(), PluginModel\getForm(), WorkflowModel\getForm(), StageModel\getForm(), TransitionModel\getForm(), StyleModel\getForm(), ItemModel\getForm(), ModuleModel\getForm(), ContentmapField\getGroups(), BreadcrumbsHelper\getHome(), ConfigModel\getItem(), UpdatesiteModel\getItem(), TransitionModel\getItem(), MessageModel\getItem(), TemplateModel\getItem(), ContactModel\getItem(), NewsfeedModel\getItem(), TaskModel\getItem(), GroupModel\getItem(), ArticleModel\getItem(), Adapter\getItem(), AdminModel\getItem(), RouteHelper\getItemid(), MenusModel\getItems(), FeaturedModel\getItems(), FetchMediaItemsEvent\getItems(), TemplatesModel\getItems(), TagModel\getItems(), CategoryModel\getItems(), SelectModel\getItems(), SearchesModel\getItems(), UsersModel\getItems(), ClientsModel\getItems(), AbstractMenu\getItems(), BannersModel\getItems(), UpdatesitesModel\getItems(), ItemsModel\getItems(), Adapter\getItems(), ArticlesModel\getItems(), ArticlesPopularHelper\getList(), LatestHelper\getList(), LanguagesHelper\getList(), ArticlesArchiveHelper\getList(), PopularHelper\getList(), ArticlesCategoryHelper\getList(), TemplateModel\getMaster(), AbstractMenu\getMenu(), DatabaseController\getMenuBadgeData(), MenusHelper\getMenuItems(), BaseController\getModel(), InfiniteListObject\getNormalizedData(), ListObject\getNormalizedData(), ComponentsField\getOptions(), AliastagField\getOptions(), WorkflowComponentSectionsField\getOptions(), ExtensionField\getOptions(), ConfigComponentsField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), ComponentsWorkflowField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), SqlField\getOptions(), Pathway\getPathwayNames(), LoginHelper\getRegistrationUrl(), LoginHelper\getReturnUrl(), RouteHelper\getRoute(), RouteHelper\getSearchRoute(), Indexer\getSignature(), TemplateModel\getSource(), QueryCollector\getStatements(), ChangeSet\getStatus(), Data\getStub(), HtmlView\getTagsTitle(), Data\getType(), InstallerHelper\getUpdateSitesInformation(), BannerModel\getUrl(), Data\getValue(), ArticlesCategoryHelper\groupBy(), ArticlesCategoryHelper\groupByDate(), ArticlesCategoryHelper\groupByTags(), BannersModel\impress(), PlgFinderTags\index(), PlgFinderNewsfeeds\index(), PlgFinderContacts\index(), PlgFinderContent\index(), PlgFinderCategories\index(), Indexer\index(), BaseDatabaseModel\isCheckedOut(), AssociationsHelper\isCheckoutItem(), Adapter\itemAccessChange(), Adapter\itemStateChange(), MenusHelper\loadXml(), Pathway\makeItem(), Menu\menuItems(), UserController\menulogout(), Ini\objectToString(), OptionsResolver\offsetGet(), PlgSystemLanguageFilter\onAfterDispatch(), PlgSystemFields\onContentAfterDisplay(), PlgSystemFields\onContentAfterTitle(), PlgSystemFields\onContentBeforeDisplay(), PlgMediaActionResize\onContentBeforeSave(), PlgFieldsSql\onContentBeforeSave(), PlgContentJoomla\onContentBeforeSave(), PlgContentFields\onContentPrepare(), PlgSystemFields\onContentPrepare(), PlgFieldsList\onCustomFieldsPrepareField(), PlgFieldsSubform\onCustomFieldsPrepareField(), PlgFinderCategories\onFinderChangeState(), Adapter\onFinderGarbageCollection(), PlgSystemHighlight\onFinderResult(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyContent\onPrivacyExportRequest(), PlgPrivacyContact\onPrivacyExportRequest(), MessagesModel\onProcessList(), PlgSystemFields\onUserAfterDelete(), PlgSystemLanguageFilter\onUserLogin(), PlgWorkflowNotification\onWorkflowAfterTransition(), Category\options(), Tag\options(), Router\parse(), SiteRouter\parseRawRoute(), WebAssetRegistry\parseRegistryFile(), SiteRouter\parseSefRoute(), MenusHelper\parseXmlNode(), Adapter\pluginDisable(), GroupsModel\populateExtraData(), GroupController\postSaveHook(), FieldController\postSaveHook(), CategoryController\postSaveHook(), PlgContentFields\prepare(), Helper\prepareContent(), HtmlView\prepareDocument(), JsonapiView\prepareItem(), JsonApiView\prepareItem(), ContentmapField\prepareLevel(), PlgSystemFields\prepareTagItem(), Menu\preprocess(), CssMenu\preprocess(), MenusHelper\preprocess(), ItemModel\rebuild(), FeedView\reconcileNames(), CategoryFeedView\reconcileNames(), Adapter\reindex(), Adapter\remove(), ActionsDropdown\render(), StylesRenderer\render(), ScriptsRenderer\render(), PrivacyHelper\renderDataAsXml(), StylesRenderer\renderElement(), ScriptsRenderer\renderElement(), ScriptsRenderer\renderInlineElement(), StylesRenderer\renderInlineElement(), MenusHelper\resolveAlias(), PharInvocationResolver\resolveBaseName(), MenusController\resync(), SiteApplication\route(), CMSApplication\route(), StyleController\save(), ModuleController\save(), ArticleController\save(), SeekingData\seek(), Data\seek(), InputDefinition\setDefinition(), FetchMediaItemEvent\setItem(), FetchMediaItemsEvent\setItems(), Italian\step0(), Spanish\step0(), Tag\tags(), ContactEmailRule\test(), ContactEmailMessageRule\test(), ContactEmailSubjectRule\test(), ArrayHelper\toString(), Query\toUri(), InstallerModel\translate(), PluginsModel\translate(), UpdateModel\translate(), ModulesModel\translate(), UpdateModel\translateExtensionName(), Adapter\translateState(), Access\usergroups(), AbstractMediaItemValidationEvent\validate(), ContactComponent\validateSection(), et LegacyComponent\validateSection().

◆ $link

$link = 'index.php?option=com_menus&view=items&layout=modal&tmpl=component&' . Session::getFormToken() . '=1'

Référencé par GenericLinkProvider\__construct(), SitePathway\__construct(), PaginationObject\__construct(), PlgContentEmailcloak\_getPattern(), HtmlView\_prepareDocument(), ComponentAdapter\_updateMenus(), Sidebar\addEntry(), CategoryView\addFeed(), Pathway\addItem(), FeedEntry\addLink(), AtomParser\bestLinkForUri(), PgSqlCaster\castLink(), FeedView\display(), CategoryFeedView\display(), DisplayController\display(), HtmlView\display(), Dropdown\edit(), PlgInstallerOverride\finalize(), HtmlErrorRenderer\formatFile(), RouteHelper\getArticleRoute(), RouteHelper\getCategoryRoute(), RouteHelper\getComponentTagRoute(), RouteHelper\getComponentTagsRoute(), RouteHelper\getContactRoute(), MediaHelper\getContentTypeLink(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), PlugininfoField\getInput(), MenutypeField\getInput(), ModulepositionField\getInput(), NumberField\getInput(), TextField\getInput(), ItemModel\getItem(), RouteHelper\getItemRoute(), TosField\getLabel(), ContenthistoryField\getLayoutData(), PrivacyField\getLayoutData(), MediaField\getLayoutData(), SyndicateHelper\getLink(), Fig\Link\getLinksByRel(), GenericLinkProvider\getLinksByRel(), MenusHelper\getMenuLinks(), RouteHelper\getNewsfeedRoute(), ListField\getOptions(), RouteHelper\getRoute(), AtomParser\handleLink(), RssParser\handleLink(), Indexer\index(), Links\link(), Links\links(), Pathway\makeItem(), PlgSystemSef\onAfterDispatch(), PlgSystemPrivacyconsent\onAfterRoute(), PlgButtonMenu\onDisplay(), PlgButtonPagebreak\onDisplay(), PlgButtonContact\onDisplay(), PlgButtonArticle\onDisplay(), PlgButtonModule\onDisplay(), PlgButtonFields\onDisplay(), PlgButtonImage\onDisplay(), ItemModel\populateState(), ArticleController\postSaveHook(), ContactController\postSaveHook(), ItemModel\preprocessForm(), AtomParser\processFeedEntry(), RssParser\processFeedEntry(), RemindModel\processRemindRequest(), ResetModel\processResetRequest(), SFTP\readlink(), UpdatesitesModel\rebuild(), FeedView\reconcileNames(), FeedEntry\removeLink(), HttpHeaderSerializer\serialize(), SFTP\symlink(), Fig\Link\withLink(), GenericLinkProvider\withLink(), Fig\Link\withoutLink(), GenericLinkProvider\withoutLink(), et Debug\xdebuglink().

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $multilang

$multilang = Multilanguage::isEnabled()

◆ $prefix

$prefix = LayoutHelper::render('joomla.html.treeprefix', array('level' => $item->level))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad10__

else __pad10__

◆ __pad11__

else __pad11__

◆ __pad12__

else __pad12__

◆ __pad13__

else __pad13__

◆ __pad14__

else __pad14__

◆ __pad15__

else __pad15__

◆ elseif

if ( $item->language &&$multilang) elseif(! $multilang)

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($editor))

◆ language_image

else $item language_image

◆ language_title

else $item $item language_title

◆ true

else $item $item array ( 'title'=> $item->language_title) true


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • module
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/module/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/modules/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$editor = Factory::getApplication()->input->get('editor', '', 'cmd')
$link = 'index.php?option=com_modules&view=modules&layout=modal&tmpl=component&' . Session::getFormToken() . '=1'
if (!empty( $editor))
$iconStates
foreach ( $this->items as $i=> $item)
endif
endforeach

Documentation des variables

◆ $editor

$editor = Factory::getApplication()->input->get('editor', '', 'cmd')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $link

$link = 'index.php?option=com_modules&view=modules&layout=modal&tmpl=component&' . Session::getFormToken() . '=1'

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $i=> $item)

◆ if

if(!empty($editor))


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • select
Espaces de nommage | Variables
Référence du fichier administrator/components/com_modules/tmpl/select/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$this modalLink = '&tmpl=component&view=module&layout=modal'

Documentation des variables

◆ modalLink

$this modalLink = '&tmpl=component&view=module&layout=modal'

Référencé par HtmlView\display().


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/tmpl/newsfeed/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Espaces de nommage | Variables
Référence du fichier administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$function = $app->input->getCmd('function', 'jSelectNewsfeed')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$multilang = Multilanguage::isEnabled()
else __pad2__
endif
$iconStates
foreach( $this->items as $i=> $item)($item->language && $multilang) elseif (! $multilang)
endforeach

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $function

$function = $app->input->getCmd('function', 'jSelectNewsfeed')

◆ $iconStates

$iconStates
Valeur initiale :
= array(
-2 => 'icon-trash',
0 => 'icon-times',
1 => 'icon-check',
2 => 'icon-folder',
)

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $multilang

$multilang = Multilanguage::isEnabled()

◆ __pad2__

else __pad2__

◆ elseif

foreach ($this->items as $i => $item) ( $item->language &&$multilang) elseif(! $multilang)

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
  • plugin
Espaces de nommage
Référence du fichier administrator/components/com_plugins/tmpl/plugin/modal.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • select
Espaces de nommage | Variables
Référence du fichier administrator/components/com_scheduler/tmpl/select/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$this modalLink = '&tmpl=component&view=select&layout=modal'
try

Documentation des variables

◆ modalLink

$this modalLink = '&tmpl=component&view=select&layout=modal'

◆ try

try
Valeur initiale :
{
echo $this->loadTemplate()

Référencé par CaptchaField\setup().


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • notes
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/notes/modal.php

Espaces de nommage

Joomla\Administrator

Variables

else __pad10__
else int $item id
else __pad11__
endif
$category_image = $item->cparams->get('image')
endforeach

Documentation des variables

◆ $category_image

$category_image = $item->cparams->get('image')

◆ __pad10__

else __pad10__

◆ __pad11__

else __pad11__

◆ endforeach

endforeach

◆ endif

endif

◆ id

else int $item id


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • users
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/users/modal.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$input = Factory::getApplication()->input
$field = $input->getCmd('field')
$listOrder = $this->escape($this->state->get('list.ordering'))
$listDirn = $this->escape($this->state->get('list.direction'))
$enabledStates = array(0 => 'icon-check', 1 => 'icon-times')
$activatedStates = array(0 => 'icon-check', 1 => 'icon-times')
$userRequired = (int) $input->get('required', 0, 'int')
$onClick = "window.parent.jSelectUser(this);window.parent.Joomla.Modal.getCurrent().close()"
endif
else __pad18__
$i = 0
foreach ( $this->items as $item)
endforeach

Documentation des variables

◆ $activatedStates

$activatedStates = array(0 => 'icon-check', 1 => 'icon-times')

◆ $enabledStates

$enabledStates = array(0 => 'icon-check', 1 => 'icon-times')

◆ $field

$field = $input->getCmd('field')

Référencé par InstallerModel\_getList(), FieldsModel\_getList(), Item\addField(), Joomla\CMS\MVC\Model\addTransitionField(), ArticleModel\batchMove(), TaskTable\bind(), Table\bind(), DatabaseExporter\buildXmlData(), MysqlExporter\buildXmlStructure(), MysqliExporter\buildXmlStructure(), PgsqlExporter\buildXmlStructure(), FieldsHelper\canEditFieldValue(), PgSqlCaster\castResult(), SqliteQuery\charLength(), SqlsrvQuery\charLength(), DatabaseQuery\charLength(), ArticleModel\cleanupPostBatchCopy(), PrivacyPlugin\createCustomFieldsDomain(), PrivacyPlugin\createItemFromArray(), SMTP\data(), HtmlView\display(), PlgSystemFields\display(), FieldsHelper\displayFieldOnForm(), JsonapiView\displayItem(), JsonapiView\displayList(), Form\filter(), Form\findField(), Form\findFieldsByGroup(), FormattedtextLogger\formatLine(), DatabaseImporter\getAddColumnSql(), PgsqlImporter\getAddIndexSql(), PgsqlImporter\getAddSequenceSql(), PgsqlImporter\getAlterTableSql(), MysqlImporter\getAlterTableSql(), MysqliImporter\getAlterTableSql(), DatabaseImporter\getChangeColumnSql(), MysqlImporter\getChangeColumnSql(), MysqliImporter\getChangeColumnSql(), PgsqlImporter\getChangeSequenceSql(), MysqlImporter\getColumnSql(), MysqliImporter\getColumnSql(), CMSHelper\getDataObject(), DebugHelper\getDebugActions(), X509\getDN(), FieldsHelper\getFields(), Form\getFieldset(), ActionlogsModel\getFilterForm(), TemplateModel\getForm(), ContenthistoryHelper\getFormValues(), Form\getGroup(), Form\getInput(), PlgInstallerWebinstaller\getInstallFrom(), Form\getLabel(), FieldsListPlugin\getOptionsFromField(), PlgFieldsSubform\getOptionsFromField(), Installer\getParams(), PlgFieldsSubform\getParamsFromField(), CMSHelper\getRowData(), CronExpression\getRunDate(), PgsqlImporter\getSetvalSequenceSql(), Parameters\getSort(), Joomla\CMS\MVC\Model\getStageForNewItem(), PlgFieldsSubform\getSubfieldsFromField(), PgsqlDriver\getTableColumns(), SqliteDriver\getTableColumns(), MysqlDriver\getTableColumns(), MysqliDriver\getTableColumns(), ContenthistoryHelper\hideFields(), Form\load(), Table\load(), ManageModel\loadChangelog(), Form\loadField(), LdapUserProvider\loadUser(), UCMContent\mapData(), PlgSystemFields\onContentNormaliseRequestData(), PlgSystemFields\onContentPrepare(), PlgUserProfile\onContentPrepareForm(), PlgFieldsList\onCustomFieldsBeforePrepareField(), PlgFieldsCheckboxes\onCustomFieldsBeforePrepareField(), PlgFieldsRadio\onCustomFieldsBeforePrepareField(), PlgFieldsMedia\onCustomFieldsBeforePrepareField(), PlgFieldsSubform\onCustomFieldsBeforePrepareField(), PlgFieldsMedia\onCustomFieldsPrepareDom(), PlgFieldsImagelist\onCustomFieldsPrepareDom(), PlgFieldsEditor\onCustomFieldsPrepareDom(), PlgFieldsColor\onCustomFieldsPrepareDom(), PlgFieldsCalendar\onCustomFieldsPrepareDom(), PlgFieldsUser\onCustomFieldsPrepareDom(), PlgFieldsUrl\onCustomFieldsPrepareDom(), FieldsListPlugin\onCustomFieldsPrepareDom(), PlgFieldsSql\onCustomFieldsPrepareDom(), FieldsPlugin\onCustomFieldsPrepareDom(), PlgFieldsSubform\onCustomFieldsPrepareDom(), PlgFieldsList\onCustomFieldsPrepareField(), FieldsPlugin\onCustomFieldsPrepareField(), PlgFieldsSubform\onCustomFieldsPrepareField(), ContentHelper\onPrepareForm(), PlgWorkflowFeaturing\onTableBeforeStore(), PlgWorkflowPublishing\onTableBeforeStore(), FormHelper\parseShowOnConditions(), ListModel\populateState(), Form\postProcess(), PlgContentFields\prepare(), JsonapiView\prepareItem(), NewsfeedModel\preprocessForm(), CategoryModel\preprocessForm(), ContactModel\preprocessForm(), ArticleModel\preprocessForm(), ItemModel\preprocessForm(), UsersController\preprocessSaveData(), ContactController\preprocessSaveData(), ArticlesController\preprocessSaveData(), PrivacyHelper\renderDataAsXml(), Form\renderField(), Form\renderFieldset(), FieldModel\save(), ComponentModel\save(), FormController\save(), FieldModel\setFieldValue(), Captcha\setupField(), OptionsRule\test(), SubformRule\test(), EqualsRule\test(), NotequalsRule\test(), ConfigurationModel\updateUserIds(), Form\validate(), MysqliImporter\xmlToCreate(), et MysqlImporter\xmlToCreate().

◆ $i

$i = 0

◆ $input

$input = Factory::getApplication()->input

◆ $listDirn

$listDirn = $this->escape($this->state->get('list.direction'))

◆ $listOrder

$listOrder = $this->escape($this->state->get('list.ordering'))

◆ $onClick

$onClick = "window.parent.jSelectUser(this);window.parent.Joomla.Modal.getCurrent().close()"

◆ $userRequired

$userRequired = (int) $input->get('required', 0, 'int')

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ __pad18__

else __pad18__

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->items as $item)


Joomla CMS: Référence du fichier modal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • editors
  • buttons
Espaces de nommage | Variables
Référence du fichier layouts/joomla/editors/buttons/modal.php

Espaces de nommage

Joomla\Site

Variables

$button = $displayData
if(! $button->get('modal')) | $class = ($button->get('class')) ? $button->get('class') : null
$href = '#' . strtolower($button->get('name')) . '_modal'
$link = ($button->get('link')) ? Uri::base() . $button->get('link') : null
$onclick = ($button->get('onclick')) ? ' onclick="' . $button->get('onclick') . '"' : ''
$title = ($button->get('title')) ? $button->get('title') : $button->get('text')
$options = is_array($button->get('options')) ? $button->get('options') : array()
$confirm = ''
if(is_array($button->get('options')) &&isset($options['confirmText']) &&isset($options['confirmCallback'])) if(null !==$button->get('id')) | else

Documentation des variables

◆ $button

$button = $displayData

◆ $class

$class = ($button->get('class')) ? $button->get('class') : null

◆ $confirm

$confirm = ''

◆ $href

$href = '#' . strtolower($button->get('name')) . '_modal'

◆ $link

$link = ($button->get('link')) ? Uri::base() . $button->get('link') : null

◆ $onclick

$onclick = ($button->get('onclick')) ? ' onclick="' . $button->get('onclick') . '"' : ''

◆ $options

$options = is_array($button->get('options')) ? $button->get('options') : array()

◆ $title

$title = ($button->get('title')) ? $button->get('title') : $button->get('text')

◆ else

if (is_array( $button->get( 'options')) &&isset( $options[ 'confirmText']) &&isset( $options[ 'confirmCallback'])) if (null !==$button->get( 'id')) else
Valeur initiale :
{
$id = strtolower($button->get('name')) . '_modal'
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
strtolower
$button
$button
Definition: layouts/joomla/editors/buttons/modal.php:17


Joomla CMS: Référence du fichier ModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier ModelInterface.php

Structures de données

interface ModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier modify_date.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage
Référence du fichier modify_date.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • module
Structures de données | Espaces de nommage
Référence du fichier module.php

Structures de données

class PlgButtonModule

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier src/Extension/Module.php

Structures de données

class Module

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier Module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier src/Extension/Service/Provider/Module.php

Structures de données

class Module

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier Module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier src/Table/Module.php

Structures de données

class Module

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier Module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/laminas/laminas-diactoros/src/Module.php

Structures de données

class Module

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier Module.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/laminas/laminas-zendframework-bridge/src/Module.php

Structures de données

class Module

Espaces de nommage

Laminas\ZendFrameworkBridge


Joomla CMS: Référence du fichier ModuleAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier ModuleAdapter.php

Structures de données

class ModuleAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier ModuleController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ModuleController.php

Structures de données

class ModuleController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Controller


Joomla CMS: Référence du fichier ModuleDispatcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier ModuleDispatcher.php

Structures de données

class ModuleDispatcher

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ModuleDispatcherFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier Dispatcher/ModuleDispatcherFactory.php

Structures de données

class ModuleDispatcherFactory

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ModuleDispatcherFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/ModuleDispatcherFactory.php

Structures de données

class ModuleDispatcherFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier ModuleDispatcherFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Structures de données | Espaces de nommage
Référence du fichier ModuleDispatcherFactoryInterface.php

Structures de données

interface ModuleDispatcherFactoryInterface

Espaces de nommage

Joomla\CMS\Dispatcher


Joomla CMS: Référence du fichier ModuleHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ModuleHelper.php

Structures de données

class ModuleHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier ModuleInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ModuleInterface.php

Structures de données

interface ModuleInterface

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier ModulelayoutField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModulelayoutField.php

Structures de données

class ModulelayoutField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ModuleLayoutRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier ModuleLayoutRule.php

Structures de données

class ModuleLayoutRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier ModuleModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ModuleModel.php

Structures de données

class ModuleModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Model


Joomla CMS: Référence du fichier moduleorder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier moduleorder.php

Espaces de nommage

Joomla\Site

Variables

$attributes ['dataid'] = 'data-id="' . $id . '"'
$attributes ['data-url'] = 'data-url="index.php?option=com_modules&task=module.orderPosition&' . $token . '"'
$attributes ['data-element'] = 'data-element="parent_' . $id . '"'
$attributes ['data-ordering'] = 'data-ordering="' . $ordering . '"'
$attributes ['data-position-element'] = 'data-position-element="' . $element . '"'
$attributes ['data-client-id'] = 'data-client-id="' . $clientId . '"'
$attributes ['data-name'] = 'data-name="' . $name . '"'
$attributes ['data-module-id'] = 'data-module-id="' . $moduleId . '"'

Documentation des variables

◆ $attributes [1/8]

$attributes[ 'dataid'] = 'data-id="' . $id . '"'

◆ $attributes [2/8]

$attributes[ 'data-url'] = 'data-url="index.php?option=com_modules&task=module.orderPosition&' . $token . '"'

◆ $attributes [3/8]

$attributes[ 'data-element'] = 'data-element="parent_' . $id . '"'

◆ $attributes [4/8]

$attributes[ 'data-ordering'] = 'data-ordering="' . $ordering . '"'

◆ $attributes [5/8]

$attributes[ 'data-position-element'] = 'data-position-element="' . $element . '"'

◆ $attributes [6/8]

$attributes[ 'data-client-id'] = 'data-client-id="' . $clientId . '"'

◆ $attributes [7/8]

$attributes[ 'data-name'] = 'data-name="' . $name . '"'

◆ $attributes [8/8]

$attributes[ 'data-module-id'] = 'data-module-id="' . $moduleId . '"'


Joomla CMS: Référence du fichier ModuleorderField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModuleorderField.php

Structures de données

class ModuleorderField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ModulepositionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModulepositionField.php

Structures de données

class ModulepositionField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ModuleRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier ModuleRenderer.php

Structures de données

class ModuleRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier Modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Modules.php

Structures de données

class Modules

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Service\HTML


Joomla CMS: Référence du fichier modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/helpers/modules.php

Structures de données

class ModulesHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier modules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • modules
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/modules/modules.php

Structures de données

class PlgWebservicesModules

Espaces de nommage

Joomla\Modules


Joomla CMS: Référence du fichier ModulesComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier ModulesComponent.php

Structures de données

class ModulesComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Extension


Joomla CMS: Référence du fichier ModulesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/Controller/ModulesController.php

Structures de données

class ModulesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Controller


Joomla CMS: Référence du fichier ModulesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_modules/src/Controller/ModulesController.php

Structures de données

class ModulesController

Espaces de nommage

Joomla\API
Joomla\Component\Modules\Api\Controller


Joomla CMS: Référence du fichier ModulesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Controller/ModulesController.php

Structures de données

class ModulesController

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Controller


Joomla CMS: Référence du fichier ModulesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ModulesHelper.php

Structures de données

class ModulesHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Helper


Joomla CMS: Référence du fichier ModulesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/src/Model/ModulesModel.php

Structures de données

class ModulesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Model


Joomla CMS: Référence du fichier ModulesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Model/ModulesModel.php

Structures de données

class ModulesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Model


Joomla CMS: Référence du fichier ModulesModuleField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModulesModuleField.php

Structures de données

class ModulesModuleField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Field


Joomla CMS: Référence du fichier modulespositionedit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier modulespositionedit.php

Espaces de nommage

Joomla\Administrator

Variables

$attributes
$selectAttr

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
'class="' . $class . '"',
' allow-custom',
' search-placeholder="' . $this->escape(Text::_('JGLOBAL_TYPE_OR_SELECT_SOME_OPTIONS')) . '" ',
)
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par LangActiveAssetItem\__construct(), WebAssetItem\__construct(), WebAssetManager\addInline(), ListField\addOption(), IndexerController\batch(), MenuRules\buildLookup(), Collection\cleanupAttributes(), MailHelper\convertRelativeToAbsoluteUrls(), WebAssetRegistry\createAsset(), Factory\createDocument(), PreloadManager\dnsPrefetch(), X509\extensions(), ComponentHelper\filterText(), RouteHelper\findItem(), FormField\getAttribute(), X509\getAttribute(), OnGetApiAttributes\getAttributes(), Resource\getAttributes(), WebAssetItem\getAttributes(), X509\getAttributes(), Document\getInstance(), SiteMenu\getItems(), AbstractMenu\getItems(), Collection\getSingleEntry(), MenutypesModel\getTypeOptionsFromManifest(), HTMLHelper\image(), PreloadManager\link(), AbstractRenderer\loadDocument(), InstallationApplication\loadDocument(), X509\mapInAttributes(), X509\mapOutAttributes(), Resource\mergeAttributes(), PlgSystemSef\onAfterRender(), PreloadManager\preconnect(), PreloadManager\prefetch(), PreloadManager\preload(), PreloadManager\prerender(), WebAssetManager\registerAsset(), X509\removeAttribute(), ScriptsRenderer\renderAttributes(), StylesRenderer\renderAttributes(), LdapClient\search(), X509\setAttribute(), FormField\setup(), Resource\toArray(), et Form\token().

◆ $selectAttr

$selectAttr
Valeur initiale :
= array(
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
strlen($hint) ? 'placeholder="' . $this->escape($hint) . '"' : '',
$onchange ? ' onchange="' . $onchange . '"' : '',
$autofocus ? ' autofocus' : '',
)
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
strlen
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54


Joomla CMS: Référence du fichier ModulesPositioneditField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModulesPositioneditField.php

Structures de données

class ModulesPositioneditField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Field


Joomla CMS: Référence du fichier ModulesPositionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier com_modules/src/Field/ModulesPositionField.php

Structures de données

class ModulesPositionField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Field


Joomla CMS: Référence du fichier ModulesPositionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier com_users/src/Field/ModulesPositionField.php

Structures de données

class ModulesPositionField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Field


Joomla CMS: Référence du fichier ModulesRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier ModulesRenderer.php

Structures de données

class ModulesRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier ModuletagField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier ModuletagField.php

Structures de données

class ModuletagField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier MonologCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier MonologCollector.php

Structures de données

class MonologCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier Montgomery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier Crypt/EC/BaseCurves/Montgomery.php

Structures de données

class Montgomery

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves


Joomla CMS: Référence du fichier Montgomery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
Structures de données | Espaces de nommage
Référence du fichier Math/BigInteger/Engines/PHP/Montgomery.php

Structures de données

class Montgomery

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP
PHP


Joomla CMS: Référence du fichier Montgomery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier Math/BigInteger/Engines/PHP/Reductions/Montgomery.php

Structures de données

class Montgomery

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier MontgomeryMult.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier MontgomeryMult.php

Structures de données

class MontgomeryMult

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier MontgomeryPrivate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier MontgomeryPrivate.php

Structures de données

class MontgomeryPrivate

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier MontgomeryPublic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier MontgomeryPublic.php

Structures de données

class MontgomeryPublic

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier MonthField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Structures de données | Espaces de nommage
Référence du fichier MonthField.php

Structures de données

class MonthField

Espaces de nommage

Cron


Joomla CMS: Référence du fichier MSBLOB.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier MSBLOB.php

Structures de données

class MSBLOB

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier MtRandGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier MtRandGenerator.php

Structures de données

class MtRandGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier MultibyteStringConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier MultibyteStringConverter.php

Structures de données

class MultibyteStringConverter

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier multifactorauth.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier multifactorauth.php

Espaces de nommage

Joomla\Administrator

Fonctions

com_users_postinstall_mfa_condition ()

Documentation des fonctions

◆ com_users_postinstall_mfa_condition()

com_users_postinstall_mfa_condition ( )

Post-installation message about the new Multi-factor Authentication: condition check.

Returns true if neither of the two new core MFA plugins are enabled.

Renvoie
boolean
Depuis
4.2.0


Joomla CMS: Référence du fichier MultiFactorAuthenticationHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Espaces de nommage
Référence du fichier MultiFactorAuthenticationHandler.php

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier multilang.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • sampledata
  • multilang
Structures de données | Espaces de nommage
Référence du fichier multilang.php

Structures de données

class PlgSampledataMultilang

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier MultilangstatusHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier MultilangstatusHelper.php

Structures de données

class MultilangstatusHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Helper


Joomla CMS: Référence du fichier Multilanguage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier Multilanguage.php

Structures de données

class Multilanguage

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier MVCComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier MVCComponent.php

Structures de données

class MVCComponent

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier MVCFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/MVCFactory.php

Structures de données

class MVCFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier MVCFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Structures de données | Espaces de nommage
Référence du fichier MVC/Factory/MVCFactory.php

Structures de données

class MVCFactory

Espaces de nommage

Joomla\CMS\MVC\Factory


Joomla CMS: Référence du fichier MVCFactoryAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Espaces de nommage | Fonctions | Variables
Référence du fichier MVCFactoryAwareTrait.php

Espaces de nommage

Joomla\CMS\MVC\Factory

Fonctions

getMVCFactory ()
setMVCFactory (MVCFactoryInterface $mvcFactory)

Variables

trait MVCFactoryAwareTrait


Joomla CMS: Référence du fichier MVCFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Structures de données | Espaces de nommage
Référence du fichier MVCFactoryInterface.php

Structures de données

interface MVCFactoryInterface

Espaces de nommage

Joomla\CMS\MVC\Factory


Joomla CMS: Référence du fichier MVCFactoryServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Structures de données | Espaces de nommage
Référence du fichier MVCFactoryServiceInterface.php

Structures de données

interface MVCFactoryServiceInterface

Espaces de nommage

Joomla\CMS\MVC\Factory


Joomla CMS: Référence du fichier MVCFactoryServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Espaces de nommage | Fonctions | Variables
Référence du fichier MVCFactoryServiceTrait.php

Espaces de nommage

Joomla\CMS\MVC\Factory

Fonctions

getMVCFactory ()
setMVCFactory (MVCFactoryInterface $mvcFactory)

Variables

trait MVCFactoryServiceTrait


Joomla CMS: Référence du fichier MysqlChangeItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
  • ChangeItem
Structures de données | Espaces de nommage
Référence du fichier MysqlChangeItem.php

Structures de données

class MysqlChangeItem

Espaces de nommage

Joomla\CMS\Schema\ChangeItem


Joomla CMS: Référence du fichier MysqlDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysql
Structures de données | Espaces de nommage
Référence du fichier MysqlDriver.php

Structures de données

class MysqlDriver

Espaces de nommage

Joomla\Database\Mysql


Joomla CMS: Référence du fichier MysqlExporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysql
Structures de données | Espaces de nommage
Référence du fichier MysqlExporter.php

Structures de données

class MysqlExporter

Espaces de nommage

Joomla\Database\Mysql


Joomla CMS: Référence du fichier MysqliCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier MysqliCaster.php

Structures de données

class MysqliCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier MysqliDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Structures de données | Espaces de nommage
Référence du fichier MysqliDriver.php

Structures de données

class MysqliDriver

Espaces de nommage

Joomla\Database\Mysqli


Joomla CMS: Référence du fichier MysqliExporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Structures de données | Espaces de nommage
Référence du fichier MysqliExporter.php

Structures de données

class MysqliExporter

Espaces de nommage

Joomla\Database\Mysqli


Joomla CMS: Référence du fichier MysqliImporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Structures de données | Espaces de nommage
Référence du fichier MysqliImporter.php

Structures de données

class MysqliImporter

Espaces de nommage

Joomla\Database\Mysqli


Joomla CMS: Référence du fichier MysqlImporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysql
Structures de données | Espaces de nommage
Référence du fichier MysqlImporter.php

Structures de données

class MysqlImporter

Espaces de nommage

Joomla\Database\Mysql


Joomla CMS: Référence du fichier MysqliQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Structures de données | Espaces de nommage
Référence du fichier MysqliQuery.php

Structures de données

class MysqliQuery

Espaces de nommage

Joomla\Database\Mysqli


Joomla CMS: Référence du fichier MysqliStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Structures de données | Espaces de nommage
Référence du fichier MysqliStatement.php

Structures de données

class MysqliStatement

Espaces de nommage

Joomla\Database\Mysqli


Joomla CMS: Référence du fichier MysqlQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysql
Structures de données | Espaces de nommage
Référence du fichier MysqlQuery.php

Structures de données

class MysqlQuery

Espaces de nommage

Joomla\Database\Mysql


Joomla CMS: Référence du fichier MysqlQueryBuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Espaces de nommage | Fonctions | Variables
Référence du fichier MysqlQueryBuilder.php

Espaces de nommage

Joomla\Database\Query

Fonctions

regexp ($value)
rand ()
findInSet ($value, $set)
selectRowNumber ($orderBy, $orderColumnAlias)
castAs (string $type, string $value, ?string $length=null)

Variables

trait MysqlQueryBuilder


Joomla CMS: Référence du fichier Name.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Name.php

Structures de données

class Name

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier NameConstraints.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier NameConstraints.php

Structures de données

class NameConstraints

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier NamePrep.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Structures de données | Espaces de nommage
Référence du fichier NamePrep.php

Structures de données

class NamePrep

Espaces de nommage

Algo26\IdnaConvert\NamePrep


Joomla CMS: Référence du fichier NamePrepData2003.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Structures de données | Espaces de nommage
Référence du fichier NamePrepData2003.php

Structures de données

class NamePrepData2003

Espaces de nommage

Algo26\IdnaConvert\NamePrep


Joomla CMS: Référence du fichier NamePrepData2008.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Structures de données | Espaces de nommage
Référence du fichier NamePrepData2008.php

Structures de données

class NamePrepData2008

Espaces de nommage

Algo26\IdnaConvert\NamePrep


Joomla CMS: Référence du fichier NamePrepDataInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Structures de données | Espaces de nommage
Référence du fichier NamePrepDataInterface.php

Structures de données

interface NamePrepDataInterface

Espaces de nommage

Algo26\IdnaConvert\NamePrep


Joomla CMS: Référence du fichier NamePrepInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Structures de données | Espaces de nommage
Référence du fichier NamePrepInterface.php

Structures de données

interface NamePrepInterface

Espaces de nommage

Algo26\IdnaConvert\NamePrep


Joomla CMS: Référence du fichier namespaced.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Référence du fichier namespaced.php


Joomla CMS: Référence du fichier NamespacedTwigProfileCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier NamespacedTwigProfileCollector.php

Structures de données

class NamespacedTwigProfileCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier namespacemap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Structures de données
Référence du fichier libraries/namespacemap.php

Structures de données

class JNamespacePsr4Map


Joomla CMS: Référence du fichier namespacemap.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • namespacemap
Structures de données | Espaces de nommage
Référence du fichier plugins/extension/namespacemap/namespacemap.php

Structures de données

class PlgExtensionNamespacemap

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier NamespaceNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Exception/NamespaceNotFoundException.php

Structures de données

class NamespaceNotFoundException

Espaces de nommage

Joomla\Console\Exception


Joomla CMS: Référence du fichier NamespaceNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Exception/NamespaceNotFoundException.php

Structures de données

class NamespaceNotFoundException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier NamespaceParserInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
Structures de données | Espaces de nommage
Référence du fichier NamespaceParserInterface.php

Structures de données

interface NamespaceParserInterface

Espaces de nommage

Joomla\CMS\Feed\Parser


Joomla CMS: Référence du fichier NativeCalculator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
  • Calculator
Structures de données | Espaces de nommage
Référence du fichier NativeCalculator.php

Structures de données

class NativeCalculator

Espaces de nommage

Brick\Math\Internal\Calculator


Joomla CMS: Référence du fichier NativeStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Storage
Structures de données | Espaces de nommage
Référence du fichier NativeStorage.php

Structures de données

class NativeStorage

Espaces de nommage

Joomla\Session\Storage


Joomla CMS: Référence du fichier navigation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagebreak
  • tmpl
Espaces de nommage | Variables
Référence du fichier navigation.php

Espaces de nommage

Joomla\Plugin

Variables

$lang = Factory::getLanguage()
if( $links[ 'previous'])() ? 'right' $title = htmlspecialchars($this->list[$page]->title, ENT_QUOTES, 'UTF-8')
$ariaLabel = Text::_('JPREVIOUS') . ': ' . $title . ' (' . Text::sprintf('JLIB_HTML_PAGE_CURRENT_OF_TOTAL', $page, $n) . ')'
endif

Documentation des variables

◆ $ariaLabel

$ariaLabel = Text::_('JPREVIOUS') . ': ' . $title . ' (' . Text::sprintf('JLIB_HTML_PAGE_CURRENT_OF_TOTAL', $page, $n) . ')'

◆ $lang

$lang = Factory::getLanguage()

◆ $title

if ($links['next']) () ? 'left' $title = htmlspecialchars($this->list[$page]->title, ENT_QUOTES, 'UTF-8')

◆ endif

endif


Joomla CMS: Référence du fichier Negate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Negate.php

Structures de données

class Negate

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier NegativeBigIntegerTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier NegativeBigIntegerTag.php

Structures de données

class NegativeBigIntegerTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier NegativeNumberException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NegativeNumberException.php

Structures de données

class NegativeNumberException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier Negotiator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Structures de données | Espaces de nommage
Référence du fichier Negotiator.php

Structures de données

class Negotiator

Espaces de nommage

Negotiation


Joomla CMS: Référence du fichier Nested.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Nested.php

Structures de données

class Nested

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier NestingException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • Exceptions
Structures de données | Espaces de nommage
Référence du fichier NestingException.php

Structures de données

class NestingException

Espaces de nommage

enshrined\svgSanitize\Exceptions


Joomla CMS: Référence du fichier netscape_ca_policy_url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier netscape_ca_policy_url.php

Structures de données

class netscape_ca_policy_url

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier netscape_cert_type.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier netscape_cert_type.php

Structures de données

class netscape_cert_type

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier netscape_comment.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier netscape_comment.php

Structures de données

class netscape_comment

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier NetworkAddress.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier NetworkAddress.php

Structures de données

class NetworkAddress

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier NetworkExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
  • src
Structures de données | Espaces de nommage
Référence du fichier NetworkExceptionInterface.php

Structures de données

interface NetworkExceptionInterface

Espaces de nommage

Psr\Http\Client


Joomla CMS: Référence du fichier NewsfeedController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier NewsfeedController.php

Structures de données

class NewsfeedController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Controller


Joomla CMS: Référence du fichier NewsfeedField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Field
  • Modal
Structures de données | Espaces de nommage
Référence du fichier NewsfeedField.php

Structures de données

class NewsfeedField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Field\Modal


Joomla CMS: Référence du fichier NewsfeedModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/src/Model/NewsfeedModel.php

Structures de données

class NewsfeedModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Model


Joomla CMS: Référence du fichier NewsfeedModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Model/NewsfeedModel.php

Structures de données

class NewsfeedModel

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Model


Joomla CMS: Référence du fichier newsfeeds.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/helpers/newsfeeds.php

Structures de données

class NewsfeedsHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier newsfeeds.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • newsfeeds
Structures de données | Espaces de nommage
Référence du fichier plugins/finder/newsfeeds/newsfeeds.php

Structures de données

class PlgFinderNewsfeeds

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier newsfeeds.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • newsfeeds
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/newsfeeds/newsfeeds.php

Structures de données

class PlgWebservicesNewsfeeds

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier NewsfeedsComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier NewsfeedsComponent.php

Structures de données

class NewsfeedsComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Extension


Joomla CMS: Référence du fichier NewsfeedsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier NewsfeedsController.php

Structures de données

class NewsfeedsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Controller


Joomla CMS: Référence du fichier NewsfeedSerializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier NewsfeedSerializer.php

Structures de données

class NewsfeedSerializer

Espaces de nommage

Joomla\Component\Newsfeeds\Api\Serializer


Joomla CMS: Référence du fichier NewsfeedsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier NewsfeedsField.php

Structures de données

class NewsfeedsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Field


Joomla CMS: Référence du fichier NewsfeedsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier NewsfeedsHelper.php

Structures de données

class NewsfeedsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Helper


Joomla CMS: Référence du fichier NewsfeedsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier NewsfeedsModel.php

Structures de données

class NewsfeedsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Model


Joomla CMS: Référence du fichier NewsfeedTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier NewsfeedTable.php

Structures de données

class NewsfeedTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Newsfeeds\Administrator\Table


Joomla CMS: Référence du fichier nistb233.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistb233.php

Structures de données

class nistb233

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistb409.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistb409.php

Structures de données

class nistb409

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistk163.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistk163.php

Structures de données

class nistk163

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistk233.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistk233.php

Structures de données

class nistk233

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistk283.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistk283.php

Structures de données

class nistk283

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistk409.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistk409.php

Structures de données

class nistk409

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistp192.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistp192.php

Structures de données

class nistp192

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistp224.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistp224.php

Structures de données

class nistp224

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistp256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistp256.php

Structures de données

class nistp256

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistp384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistp384.php

Structures de données

class nistp384

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistp521.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistp521.php

Structures de données

class nistp521

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier nistt571.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier nistt571.php

Structures de données

class nistt571

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier noCard.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier noCard.php

Espaces de nommage

Joomla\Site

Variables

$module = $displayData['module']
$params = $displayData['params']
$attribs = $displayData['attribs']
if($module->content===null|| $module->content==='') | $moduleTag = $params->get('module_tag', 'div')
$moduleAttribs = []
$moduleAttribs ['class'] = $module->position . ' no-card ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')
$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')
$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')
$headerAttribs = []
if($headerClass !=='') if($moduleTag !=='div') | $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'
if($module->showtitle) | endif

Documentation des variables

◆ $attribs

$attribs = $displayData['attribs']

◆ $header

if ( $headerClass !=='') if ( $moduleTag !=='div') $header = '<' . $headerTag . ' ' . ArrayHelper::toString($headerAttribs) . '>' . $module->title . '</' . $headerTag . '>'

◆ $headerAttribs

$headerAttribs = []

◆ $headerClass

$headerClass = htmlspecialchars($params->get('header_class', ''), ENT_QUOTES, 'UTF-8')

◆ $headerTag

$headerTag = htmlspecialchars($params->get('header_tag', 'h3'), ENT_QUOTES, 'UTF-8')

◆ $module

$module = $displayData['module']

◆ $moduleAttribs [1/2]

$moduleAttribs = []

◆ $moduleAttribs [2/2]

$moduleAttribs[ 'class'] = $module->position . ' no-card ' . htmlspecialchars($params->get('moduleclass_sfx', ''), ENT_QUOTES, 'UTF-8')

◆ $moduleTag

if ( $module->content===null||$module->content==='') $moduleTag = $params->get('module_tag', 'div')

◆ $params

$params = $displayData['params']

◆ endif

if ( $module->showtitle) endif


Joomla CMS: Référence du fichier NoConfigurationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NoConfigurationException.php

Structures de données

class NoConfigurationException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier NoConstraintsGiven.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Structures de données | Espaces de nommage
Référence du fichier NoConstraintsGiven.php

Structures de données

class NoConstraintsGiven

Espaces de nommage

Lcobucci\JWT\Validation


Joomla CMS: Référence du fichier NodeInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tree
Structures de données | Espaces de nommage
Référence du fichier NodeInterface.php

Structures de données

interface NodeInterface

Espaces de nommage

Joomla\CMS\Tree


Joomla CMS: Référence du fichier NodeProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
Structures de données | Espaces de nommage
Référence du fichier NodeProviderInterface.php

Structures de données

interface NodeProviderInterface

Espaces de nommage

Ramsey\Uuid\Provider


Joomla CMS: Référence du fichier NodeTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tree
Espaces de nommage | Fonctions | Variables
Référence du fichier NodeTrait.php

Espaces de nommage

Joomla\CMS\Tree

Fonctions

setParent (NodeInterface $parent)
addChild (NodeInterface $child)
removeChild (NodeInterface $child)
setSibling (NodeInterface $sibling, $right=true)

Variables

trait NodeTrait


Joomla CMS: Référence du fichier noitems.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Espaces de nommage | Variables
Référence du fichier noitems.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData

Documentation des variables

◆ $data

$data = $displayData


Joomla CMS: Référence du fichier NoKeyLoadedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NoKeyLoadedException.php

Structures de données

class NoKeyLoadedException

Espaces de nommage

NoKeyLoadedException
phpseclib3\Exception


Joomla CMS: Référence du fichier NomenuRules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
  • Rules
Structures de données | Espaces de nommage
Référence du fichier NomenuRules.php

Structures de données

class NomenuRules

Espaces de nommage

Joomla\CMS\Component\Router\Rules


Joomla CMS: Référence du fichier None.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Signer/None.php

Structures de données

class None

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier None.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-none
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-none/None.php

Structures de données

class None

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier none.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • chromes
Espaces de nommage
Référence du fichier layouts/chromes/none.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier none.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • none
Structures de données | Espaces de nommage
Référence du fichier plugins/editors/none/none.php

Structures de données

class PlgEditorNone

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier NoneAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier NoneAttestationStatementSupport.php

Structures de données

class NoneAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier NoopWordInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier NoopWordInflector.php

Structures de données

class NoopWordInflector

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier Normalise.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
Structures de données | Espaces de nommage
Référence du fichier Normalise.php

Structures de données

class Normalise

Espaces de nommage

Joomla\String


Joomla CMS: Référence du fichier normalize_server.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier normalize_server.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

normalizeServer (array $server, callable $apacheRequestHeaderCallback=null)


Joomla CMS: Référence du fichier normalize_server.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier normalize_server.php

Espaces de nommage

Laminas\Diactoros

Fonctions

normalizeServer (array $server, callable $apacheRequestHeaderCallback=null)


Joomla CMS: Référence du fichier normalize_uploaded_files.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier normalize_uploaded_files.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

normalizeUploadedFiles (array $files)


Joomla CMS: Référence du fichier normalize_uploaded_files.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier normalize_uploaded_files.php

Espaces de nommage

Laminas\Diactoros

Fonctions

normalizeUploadedFiles (array $files)


Joomla CMS: Référence du fichier Normalizer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
Structures de données | Espaces de nommage
Référence du fichier Normalizer.php

Structures de données

class Normalizer

Espaces de nommage

Symfony\Polyfill\Intl\Normalizer


Joomla CMS: Référence du fichier Normalizer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • stubs
Structures de données
Référence du fichier Resources/stubs/Normalizer.php

Structures de données

class Normalizer


Joomla CMS: Référence du fichier Norwegian.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Norwegian.php

Structures de données

class Norwegian

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier NoSuchOptionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NoSuchOptionException.php

Structures de données

class NoSuchOptionException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier NoSupportedAlgorithmsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NoSupportedAlgorithmsException.php

Structures de données

class NoSupportedAlgorithmsException

Espaces de nommage

NoSupportedAlgorithmsException
phpseclib3\Exception


Joomla CMS: Référence du fichier NotAcceptable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NotAcceptable.php

Structures de données

class NotAcceptable

Espaces de nommage

Joomla\CMS\Application\Exception


Joomla CMS: Référence du fichier NotAcceptableExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier NotAcceptableExceptionHandler.php

Structures de données

class NotAcceptableExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier NotAllowed.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NotAllowed.php

Structures de données

class NotAllowed

Espaces de nommage

Joomla\CMS\Access\Exception


Joomla CMS: Référence du fichier NotAllowedExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier NotAllowedExceptionHandler.php

Structures de données

class NotAllowedExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier NotBoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NotBoundException.php

Structures de données

class NotBoundException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier NoteController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier NoteController.php

Structures de données

class NoteController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier NoteField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier NoteField.php

Structures de données

class NoteField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier NoteModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier NoteModel.php

Structures de données

class NoteModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier NotequalsRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier NotequalsRule.php

Structures de données

class NotequalsRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier NotesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier NotesController.php

Structures de données

class NotesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier NotesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier NotesModel.php

Structures de données

class NotesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier NoteTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier NoteTable.php

Structures de données

class NoteTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Table


Joomla CMS: Référence du fichier NotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
Structures de données | Espaces de nommage
Référence du fichier NotFoundException.php

Structures de données

class NotFoundException

Espaces de nommage

Wamania\Snowball


Joomla CMS: Référence du fichier NotFoundExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • container
  • src
Structures de données | Espaces de nommage
Référence du fichier NotFoundExceptionInterface.php

Structures de données

interface NotFoundExceptionInterface

Espaces de nommage

Psr\Container


Joomla CMS: Référence du fichier NoticeReference.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier NoticeReference.php

Structures de données

class NoticeReference

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier notification.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • notification
Structures de données | Espaces de nommage
Référence du fichier notification.php

Structures de données

class PlgWorkflowNotification

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier NotifyActionLog.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier NotifyActionLog.php

Structures de données

class NotifyActionLog

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier NotImplementedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NotImplementedException.php

Structures de données

class NotImplementedException

Espaces de nommage

FG\ASN1\Exception


Joomla CMS: Référence du fichier noupdate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage | Variables
Référence du fichier noupdate.php

Espaces de nommage

Joomla\Administrator

Variables

$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'
$displayData
endif
$content = LayoutHelper::render('joomla.content.emptystate', $displayData)

Documentation des variables

◆ $content

$content = LayoutHelper::render('joomla.content.emptystate', $displayData)
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par MediaController\add(), WebAssetManager\addInline(), Document\addScriptDeclaration(), Document\addStyleDeclaration(), AbstractWebApplication\appendBody(), Patcher\apply(), ASN1\asn1map(), Table\calculateColumnsWidth(), MailHelper\checkContent(), Microdata\content(), MailHelper\convertRelativeToAbsoluteUrls(), JavascriptRenderer\createAsseticCollection(), StreamFactory\createStream(), Psr17Factory\createStream(), ASN1\decodeOID(), ASN1\decodeTime(), Microdata\display(), JavascriptRenderer\dumpAssets(), MediaController\edit(), ASN1\encode_der(), BufferedOutput\fetch(), TrimmedBufferOutput\fetch(), MetadataStatementFetcher\fetch(), MetadataStatementFetcher\fetchTableOfContent(), HtmlErrorRenderer\fileExcerpt(), GeneralizedTime\fromBinary(), Manifest\fromContent(), SFTP\get(), Microdata\getContent(), TracksModel\getContent(), SocketTransport\getResponse(), Socket\getResponse(), CurlTransport\getResponse(), Curl\getResponse(), Microdata\htmlDiv(), Microdata\htmlMeta(), Microdata\htmlSpan(), Microdata\htmlTag(), PlgEditorNone\onDisplay(), Joomla\Plugin\Editors\TinyMCE\PluginTraits\onDisplay(), PlgEditorCodemirror\onDisplay(), ApiController\postFiles(), Helper\prepareContent(), AbstractWebApplication\prependBody(), ApiController\putFiles(), PhpInputStream\read(), ECSignature\readAsn1Content(), MultibyteStringConverter\readAsn1Content(), HeadRenderer\render(), ComponentRenderer\render(), MessageRenderer\render(), ModuleRenderer\render(), ModulesRenderer\render(), StylesRenderer\render(), ScriptsRenderer\render(), Table\renderCell(), JavascriptRenderer\renderHead(), ScriptsRenderer\renderInlineElement(), StylesRenderer\renderInlineElement(), Curl\request(), Stream\request(), Socket\request(), StreamTransport\request(), CurlTransport\request(), SocketTransport\request(), Reader\resolveFourByteLittleEndian(), Reader\resolveManifestLength(), Reader\resolveTwoByteBigEndian(), MediumModel\save(), Mail\setBody(), AbstractWebApplication\setBody(), Document\setBuffer(), HtmlDocument\setBuffer(), Document\setMetaData(), SocketPost\submit(), HTMLHelper\tooltipText(), MarkdownDescriptor\write(), Descriptor\write(), JNamespacePsr4Map\writeNamespaceFile(), et TextDescriptor\writeText().

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_JOOMLAUPDATE' . $this->messagePrefix

◆ $uploadLink

$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'

◆ endif

endif


Joomla CMS: Référence du fichier NullLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Structures de données | Espaces de nommage
Référence du fichier NullLogger.php

Structures de données

class NullLogger

Espaces de nommage

Psr\Log


Joomla CMS: Référence du fichier NullObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/ASN1/Universal/NullObject.php

Structures de données

class NullObject

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier NullObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier spomky-labs/cbor-php/src/OtherObject/NullObject.php

Structures de données

class NullObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier NullOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier NullOutput.php

Structures de données

class NullOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier NullOutputFormatter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier NullOutputFormatter.php

Structures de données

class NullOutputFormatter

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier NullOutputFormatterStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier NullOutputFormatterStyle.php

Structures de données

class NullOutputFormatterStyle

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier Number.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Number.php

Structures de données

class Number

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier number.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier number.php

Espaces de nommage

Joomla\Site

Variables

$attributes
if(is_numeric($value)) else
$value = ($required && isset($min)) ? $min : $value

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
!empty($class) ? 'class="form-control ' . $class . '"' : 'class="form-control"',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
!empty($onchange) ? 'onchange="' . $onchange . '"' : '',
isset($max) ? 'max="' . $max . '"' : '',
!empty($step) ? 'step="' . $step . '"' : '',
isset($min) ? 'min="' . $min . '"' : '',
$required ? 'required' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$autofocus ? 'autofocus' : '',
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$step
$step
Definition: links.php:29
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ $value

$value = ($required && isset($min)) ? $min : $value

◆ else

if (is_numeric( $value)) else
Valeur initiale :
{
$value = ''
$value
$value
Definition: number.php:69


Joomla CMS: Référence du fichier NumberConverterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
Structures de données | Espaces de nommage
Référence du fichier NumberConverterInterface.php

Structures de données

interface NumberConverterInterface

Espaces de nommage

Ramsey\Uuid\Converter


Joomla CMS: Référence du fichier NumberField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier NumberField.php

Structures de données

class NumberField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier NumberFormatException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier NumberFormatException.php

Structures de données

class NumberFormatException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier NumberRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier NumberRule.php

Structures de données

class NumberRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier NumericString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier NumericString.php

Structures de données

class NumericString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier NumericUserIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier NumericUserIdentifier.php

Structures de données

class NumericUserIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier OAuth.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier OAuth.php

Structures de données

class OAuth

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier OAuthCallbackEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier OAuthCallbackEvent.php

Structures de données

class OAuthCallbackEvent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Event


Joomla CMS: Référence du fichier OAuthTokenProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier OAuthTokenProvider.php

Structures de données

interface OAuthTokenProvider

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier ObjectCreateEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier ObjectCreateEvent.php

Structures de données

class ObjectCreateEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier ObjectDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier ObjectDescriptor.php

Structures de données

class ObjectDescriptor

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier ObjectIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier ObjectIdentifier.php

Structures de données

class ObjectIdentifier

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier OctetString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier OctetString.php

Structures de données

class OctetString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier offline.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
Espaces de nommage | Variables
Référence du fichier cassiopeia/offline.php

Espaces de nommage

Joomla\Site

Variables

$extraButtons = AuthenticationHelper::getLoginButtons('form-login')
$app = Factory::getApplication()
$wa = $this->getWebAssetManager()
$fullWidth = 1
$templatePath = 'media/templates/site/cassiopeia'
$paramsColorName = $this->params->get('colorName', 'colors_standard')
$assetColorName = 'theme.' . $paramsColorName
$paramsFontScheme = $this->params->get('useFontScheme', false)
$fontStyles = ''
if($paramsFontScheme) $wa | usePreset ( 'template.cassiopeia.' .( $this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle( 'template.active.language') ->useStyle( 'template.offline') ->useStyle( 'template.user') ->useScript( 'template.user') ->addInlineStyle(":root
$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')
if($this->params->get('logoFile')) elseif($this->params->get('siteTitle')) | else
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $assetColorName

$assetColorName = 'theme.' . $paramsColorName

◆ $extraButtons

$extraButtons = AuthenticationHelper::getLoginButtons('form-login')

◆ $fontStyles

$fontStyles = ''

◆ $fullWidth

$fullWidth = 1

◆ $paramsColorName

$paramsColorName = $this->params->get('colorName', 'colors_standard')

◆ $paramsFontScheme

$paramsFontScheme = $this->params->get('useFontScheme', false)

◆ $sitename

$sitename = htmlspecialchars($app->get('sitename'), ENT_QUOTES, 'UTF-8')

◆ $templatePath

$templatePath = 'media/templates/site/cassiopeia'

◆ $wa

$wa = $this->getWebAssetManager()

◆ else

if (!empty( $logo)) else
Valeur initiale :
{
$logo = '<img src="' . $templatePath . '/images/logo.svg" class="logo d-inline-block" alt="' . $sitename . '">'
$templatePath
$templatePath
Definition: cassiopeia/offline.php:29
$sitename
$sitename
Definition: cassiopeia/offline.php:79

◆ endif

endif

◆ usePreset

if ( $paramsFontScheme) $wa usePreset('template.cassiopeia.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.offline') ->useStyle('template.user') ->useScript('template.user') ->addInlineStyle(":root


Joomla CMS: Référence du fichier offline.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Espaces de nommage | Variables
Référence du fichier system/offline.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$wa = $this->getWebAssetManager()
endif

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $wa

$wa = $this->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier OID.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier OID.php

Structures de données

class OID

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier OkpKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Structures de données | Espaces de nommage
Référence du fichier OkpKey.php

Structures de données

class OkpKey

Espaces de nommage

Cose\Key


Joomla CMS: Référence du fichier OneAsymmetricKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier OneAsymmetricKey.php

Structures de données

class OneAsymmetricKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier OnGetApiAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Serializer
  • Events
Structures de données | Espaces de nommage
Référence du fichier OnGetApiAttributes.php

Structures de données

class OnGetApiAttributes

Espaces de nommage

Joomla\CMS\Serializer\Events


Joomla CMS: Référence du fichier OnGetApiFields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
  • Event
Structures de données | Espaces de nommage
Référence du fichier OnGetApiFields.php

Structures de données

class OnGetApiFields

Espaces de nommage

Joomla\CMS\MVC\View\Event


Joomla CMS: Référence du fichier OnGetApiRelation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Serializer
  • Events
Structures de données | Espaces de nommage
Référence du fichier OnGetApiRelation.php

Structures de données

class OnGetApiRelation

Espaces de nommage

Joomla\CMS\Serializer\Events


Joomla CMS: Référence du fichier OpenHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier OpenHandler.php

Structures de données

class OpenHandler

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier OpensearchDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier OpensearchDocument.php

Structures de données

class OpensearchDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier OpensearchImage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Opensearch
Structures de données | Espaces de nommage
Référence du fichier OpensearchImage.php

Structures de données

class OpensearchImage

Espaces de nommage

Joomla\CMS\Document\Opensearch


Joomla CMS: Référence du fichier OpensearchUrl.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Opensearch
Structures de données | Espaces de nommage
Référence du fichier OpensearchUrl.php

Structures de données

class OpensearchUrl

Espaces de nommage

Joomla\CMS\Document\Opensearch


Joomla CMS: Référence du fichier OpensearchView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • View
  • Search
Structures de données | Espaces de nommage
Référence du fichier OpensearchView.php

Structures de données

class OpensearchView

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\View\Search


Joomla CMS: Référence du fichier OpenSSH.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier Common/Formats/Keys/OpenSSH.php

Structures de données

class OpenSSH

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Keys


Joomla CMS: Référence du fichier OpenSSH.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/OpenSSH.php

Structures de données

class OpenSSH

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys


Joomla CMS: Référence du fichier OpenSSH.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Keys/OpenSSH.php

Structures de données

class OpenSSH

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier OpenSSH.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/OpenSSH.php

Structures de données

class OpenSSH

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
  • AES
Structures de données | Espaces de nommage
Référence du fichier src/Encrypt/AES/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

Joomla\CMS\Encrypt\AES


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Cipher
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/crypt/src/Cipher/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

Joomla\Crypt\Cipher


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier vendor/lcobucci/jwt/src/Signer/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
Structures de données | Espaces de nommage
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/BCMath/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\BCMath
BCMath


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
Engines


Joomla CMS: Référence du fichier OpenSSL.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
Structures de données | Espaces de nommage
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/PHP/OpenSSL.php

Structures de données

class OpenSSL

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP
PHP


Joomla CMS: Référence du fichier OpenSslGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier OpenSslGenerator.php

Structures de données

class OpenSslGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier OptionConfigurator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
Structures de données | Espaces de nommage
Référence du fichier OptionConfigurator.php

Structures de données

class OptionConfigurator

Espaces de nommage

Symfony\Component\OptionsResolver


Joomla CMS: Référence du fichier OptionDefinitionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier OptionDefinitionException.php

Structures de données

class OptionDefinitionException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier Options.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
Structures de données | Espaces de nommage
Référence du fichier Options.php

Structures de données

interface Options

Espaces de nommage

Symfony\Component\OptionsResolver


Joomla CMS: Référence du fichier options_default.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier options_default.php

Espaces de nommage

Joomla\Site

Variables

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
if(!empty($displayData->description)) | endif
$fieldsnames = explode(',', $displayData->fieldsname)
foreach( $fieldsnames as $fieldname)($displayData->form->getFieldset($fieldname) as $field) | $groupClass = $field->type === 'Spacer' ? ' field-spacer' : ''
$datashowon = ' data-showon=\'' . json_encode(FormHelper::parseShowOnConditions($field->showon, $field->formControl, $field->group)) . '\''
if (isset( $displayData->showlabel))
else __pad6__
endforeach

Documentation des variables

◆ $datashowon

$datashowon = ' data-showon=\'' . json_encode(FormHelper::parseShowOnConditions($field->showon, $field->formControl, $field->group)) . '\''

◆ $fieldsnames

$fieldsnames = explode(',', $displayData->fieldsname)

◆ $groupClass

foreach ($fieldsnames as $fieldname) ( $displayData->form->getFieldset( $fieldname) as $field) $groupClass = $field->type === 'Spacer' ? ' field-spacer' : ''

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

◆ __pad6__

else __pad6__

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(isset($displayData->showlabel))


Joomla CMS: Référence du fichier OptionsResolver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
Structures de données | Espaces de nommage
Référence du fichier OptionsResolver.php

Structures de données

class OptionsResolver

Espaces de nommage

Symfony\Component\OptionsResolver


Joomla CMS: Référence du fichier OptionsResolverIntrospector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Debug
Structures de données | Espaces de nommage
Référence du fichier OptionsResolverIntrospector.php

Structures de données

class OptionsResolverIntrospector

Espaces de nommage

Symfony\Component\OptionsResolver\Debug


Joomla CMS: Référence du fichier OptionsRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier OptionsRule.php

Structures de données

class OptionsRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier ORAddress.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ORAddress.php

Structures de données

class ORAddress

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ord.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier joomla/string/src/phputf8/ord.php

Espaces de nommage

utf8

Fonctions

utf8_ord ($chr)

Documentation des fonctions

◆ utf8_ord()

utf8_ord ( $chr )

UTF-8 aware alternative to ord Returns the unicode ordinal for a character

Joomla modification - As of PHP 7.4, curly brace access has been deprecated. As a result this function has been modified to use square brace syntax See https://github.com/php/php-src/commit/d574df63dc375f5fc9202ce5afde23f866b6450a for additional references

Paramètres
string UTF-8 encoded character
Renvoie
int unicode ordinal for the character
Voir également
http://www.php.net/ord
http://www.php.net/manual/en/function.ord.php#46267

Référencé par StringHelper\ord().


Joomla CMS: Référence du fichier ord.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier voku/portable-utf8/src/voku/helper/data/ord.php

Variables

return [''=> 0, "\0"=> 0, "\1"=> 1, "\2"=> 2, "\3"=> 3, "\4"=> 4, "\5"=> 5, "\6"=> 6, "\7"=> 7, "\8"=> 8, "\9"=> 9, "\A"=> 10, "\B"=> 11, "\C"=> 12, "\D"=> 13, "\E"=> 14, "\F"=> 15, "\0"=> 16, "\1"=> 17, "\2"=> 18, "\3"=> 19, "\4"=> 20, "\5"=> 21, "\6"=> 22, "\7"=> 23, "\8"=> 24, "\9"=> 25, "\A"=> 26, "\B"=> 27, "\C"=> 28, "\D"=> 29, "\E"=> 30, "\F"=> 31, "\0"=> 32, "\1"=> 33, "\2"=> 34, "\3"=> 35, "\4"=> 36, "\5"=> 37, "\6"=> 38, "\7"=> 39, "\8"=> 40, "\9"=> 41, "\A"=> 42, "\B"=> 43, "\C"=> 44, "\D"=> 45, "\E"=> 46, "\F"=> 47, "\0"=> 48, "\1"=> 49, "\2"=> 50, "\3"=> 51, "\4"=> 52, "\5"=> 53, "\6"=> 54, "\7"=> 55, "\8"=> 56, "\9"=> 57, "\A"=> 58, "\B"=> 59, "\C"=> 60, "\D"=> 61, "\E"=> 62, "\F"=> 63, "\0"=> 64, "\1"=> 65, "\2"=> 66, "\3"=> 67, "\4"=> 68, "\5"=> 69, "\6"=> 70, "\7"=> 71, "\8"=> 72, "\9"=> 73, "\A"=> 74, "\B"=> 75, "\C"=> 76, "\D"=> 77, "\E"=> 78, "\F"=> 79, "\0"=> 80, "\1"=> 81, "\2"=> 82, "\3"=> 83, "\4"=> 84, "\5"=> 85, "\6"=> 86, "\7"=> 87, "\8"=> 88, "\9"=> 89, "\A"=> 90, "\B"=> 91, "\C"=> 92, "\D"=> 93, "\E"=> 94, "\F"=> 95, "\0"=> 96, "\1"=> 97, "\2"=> 98, "\3"=> 99, "\4"=> 100, "\5"=> 101, "\6"=> 102, "\7"=> 103, "\8"=> 104, "\9"=> 105, "\A"=> 106, "\B"=> 107, "\C"=> 108, "\D"=> 109, "\E"=> 110, "\F"=> 111, "\0"=> 112, "\1"=> 113, "\2"=> 114, "\3"=> 115, "\4"=> 116, "\5"=> 117, "\6"=> 118, "\7"=> 119, "\8"=> 120, "\9"=> 121, "\A"=> 122, "\B"=> 123, "\C"=> 124, "\D"=> 125, "\E"=> 126, "\F"=> 127, "\0"=> 128, "\1"=> 129, "\2"=> 130, "\3"=> 131, "\4"=> 132, "\5"=> 133, "\6"=> 134, "\7"=> 135, "\8"=> 136, "\9"=> 137, "\A"=> 138, "\B"=> 139, "\C"=> 140, "\D"=> 141, "\E"=> 142, "\F"=> 143, "\0"=> 144, "\1"=> 145, "\2"=> 146, "\3"=> 147, "\4"=> 148, "\5"=> 149, "\6"=> 150, "\7"=> 151, "\8"=> 152, "\9"=> 153, "\A"=> 154, "\B"=> 155, "\C"=> 156, "\D"=> 157, "\E"=> 158, "\F"=> 159, "\0"=> 160, "\1"=> 161, "\2"=> 162, "\3"=> 163, "\4"=> 164, "\5"=> 165, "\6"=> 166, "\7"=> 167, "\8"=> 168, "\9"=> 169, "\A"=> 170, "\B"=> 171, "\C"=> 172, "\D"=> 173, "\E"=> 174, "\F"=> 175, "\0"=> 176, "\1"=> 177, "\2"=> 178, "\3"=> 179, "\4"=> 180, "\5"=> 181, "\6"=> 182, "\7"=> 183, "\8"=> 184, "\9"=> 185, "\A"=> 186, "\B"=> 187, "\C"=> 188, "\D"=> 189, "\E"=> 190, "\F"=> 191, "\0"=> 192, "\1"=> 193, "\2"=> 194, "\3"=> 195, "\4"=> 196, "\5"=> 197, "\6"=> 198, "\7"=> 199, "\8"=> 200, "\9"=> 201, "\A"=> 202, "\B"=> 203, "\C"=> 204, "\D"=> 205, "\E"=> 206, "\F"=> 207, "\0"=> 208, "\1"=> 209, "\2"=> 210, "\3"=> 211, "\4"=> 212, "\5"=> 213, "\6"=> 214, "\7"=> 215, "\8"=> 216, "\9"=> 217, "\A"=> 218, "\B"=> 219, "\C"=> 220, "\D"=> 221, "\E"=> 222, "\F"=> 223, "\0"=> 224, "\1"=> 225, "\2"=> 226, "\3"=> 227, "\4"=> 228, "\5"=> 229, "\6"=> 230, "\7"=> 231, "\8"=> 232, "\9"=> 233, "\A"=> 234, "\B"=> 235, "\C"=> 236, "\D"=> 237, "\E"=> 238, "\F"=> 239, "\0"=> 240, "\1"=> 241, "\2"=> 242, "\3"=> 243, "\4"=> 244, "\5"=> 245, "\6"=> 246, "\7"=> 247, "\8"=> 248, "\9"=> 249, "\A"=> 250, "\B"=> 251, "\C"=> 252, "\D"=> 253, "\E"=> 254, "\F"=> 255,]

Documentation des variables

◆ return

return[ ''=> 0, "\00"=> 0, "\01"=> 1, "\02"=> 2, "\03"=> 3, "\04"=> 4, "\05"=> 5, "\06"=> 6, "\07"=> 7, "\08"=> 8, "\09"=> 9, "\0A"=> 10, "\0B"=> 11, "\0C"=> 12, "\0D"=> 13, "\0E"=> 14, "\0F"=> 15, "\10"=> 16, "\11"=> 17, "\12"=> 18, "\13"=> 19, "\14"=> 20, "\15"=> 21, "\16"=> 22, "\17"=> 23, "\18"=> 24, "\19"=> 25, "\1A"=> 26, "\1B"=> 27, "\1C"=> 28, "\1D"=> 29, "\1E"=> 30, "\1F"=> 31, "\20"=> 32, "\21"=> 33, "\22"=> 34, "\23"=> 35, "\24"=> 36, "\25"=> 37, "\26"=> 38, "\27"=> 39, "\28"=> 40, "\29"=> 41, "\2A"=> 42, "\2B"=> 43, "\2C"=> 44, "\2D"=> 45, "\2E"=> 46, "\2F"=> 47, "\30"=> 48, "\31"=> 49, "\32"=> 50, "\33"=> 51, "\34"=> 52, "\35"=> 53, "\36"=> 54, "\37"=> 55, "\38"=> 56, "\39"=> 57, "\3A"=> 58, "\3B"=> 59, "\3C"=> 60, "\3D"=> 61, "\3E"=> 62, "\3F"=> 63, "\40"=> 64, "\41"=> 65, "\42"=> 66, "\43"=> 67, "\44"=> 68, "\45"=> 69, "\46"=> 70, "\47"=> 71, "\48"=> 72, "\49"=> 73, "\4A"=> 74, "\4B"=> 75, "\4C"=> 76, "\4D"=> 77, "\4E"=> 78, "\4F"=> 79, "\50"=> 80, "\51"=> 81, "\52"=> 82, "\53"=> 83, "\54"=> 84, "\55"=> 85, "\56"=> 86, "\57"=> 87, "\58"=> 88, "\59"=> 89, "\5A"=> 90, "\5B"=> 91, "\5C"=> 92, "\5D"=> 93, "\5E"=> 94, "\5F"=> 95, "\60"=> 96, "\61"=> 97, "\62"=> 98, "\63"=> 99, "\64"=> 100, "\65"=> 101, "\66"=> 102, "\67"=> 103, "\68"=> 104, "\69"=> 105, "\6A"=> 106, "\6B"=> 107, "\6C"=> 108, "\6D"=> 109, "\6E"=> 110, "\6F"=> 111, "\70"=> 112, "\71"=> 113, "\72"=> 114, "\73"=> 115, "\74"=> 116, "\75"=> 117, "\76"=> 118, "\77"=> 119, "\78"=> 120, "\79"=> 121, "\7A"=> 122, "\7B"=> 123, "\7C"=> 124, "\7D"=> 125, "\7E"=> 126, "\7F"=> 127, "\80"=> 128, "\81"=> 129, "\82"=> 130, "\83"=> 131, "\84"=> 132, "\85"=> 133, "\86"=> 134, "\87"=> 135, "\88"=> 136, "\89"=> 137, "\8A"=> 138, "\8B"=> 139, "\8C"=> 140, "\8D"=> 141, "\8E"=> 142, "\8F"=> 143, "\90"=> 144, "\91"=> 145, "\92"=> 146, "\93"=> 147, "\94"=> 148, "\95"=> 149, "\96"=> 150, "\97"=> 151, "\98"=> 152, "\99"=> 153, "\9A"=> 154, "\9B"=> 155, "\9C"=> 156, "\9D"=> 157, "\9E"=> 158, "\9F"=> 159, "\A0"=> 160, "\A1"=> 161, "\A2"=> 162, "\A3"=> 163, "\A4"=> 164, "\A5"=> 165, "\A6"=> 166, "\A7"=> 167, "\A8"=> 168, "\A9"=> 169, "\AA"=> 170, "\AB"=> 171, "\AC"=> 172, "\AD"=> 173, "\AE"=> 174, "\AF"=> 175, "\B0"=> 176, "\B1"=> 177, "\B2"=> 178, "\B3"=> 179, "\B4"=> 180, "\B5"=> 181, "\B6"=> 182, "\B7"=> 183, "\B8"=> 184, "\B9"=> 185, "\BA"=> 186, "\BB"=> 187, "\BC"=> 188, "\BD"=> 189, "\BE"=> 190, "\BF"=> 191, "\C0"=> 192, "\C1"=> 193, "\C2"=> 194, "\C3"=> 195, "\C4"=> 196, "\C5"=> 197, "\C6"=> 198, "\C7"=> 199, "\C8"=> 200, "\C9"=> 201, "\CA"=> 202, "\CB"=> 203, "\CC"=> 204, "\CD"=> 205, "\CE"=> 206, "\CF"=> 207, "\D0"=> 208, "\D1"=> 209, "\D2"=> 210, "\D3"=> 211, "\D4"=> 212, "\D5"=> 213, "\D6"=> 214, "\D7"=> 215, "\D8"=> 216, "\D9"=> 217, "\DA"=> 218, "\DB"=> 219, "\DC"=> 220, "\DD"=> 221, "\DE"=> 222, "\DF"=> 223, "\E0"=> 224, "\E1"=> 225, "\E2"=> 226, "\E3"=> 227, "\E4"=> 228, "\E5"=> 229, "\E6"=> 230, "\E7"=> 231, "\E8"=> 232, "\E9"=> 233, "\EA"=> 234, "\EB"=> 235, "\EC"=> 236, "\ED"=> 237, "\EE"=> 238, "\EF"=> 239, "\F0"=> 240, "\F1"=> 241, "\F2"=> 242, "\F3"=> 243, "\F4"=> 244, "\F5"=> 245, "\F6"=> 246, "\F7"=> 247, "\F8"=> 248, "\F9"=> 249, "\FA"=> 250, "\FB"=> 251, "\FC"=> 252, "\FD"=> 253, "\FE"=> 254, "\FF"=> 255,]


Joomla CMS: Référence du fichier OrderedTimeCodec.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier OrderedTimeCodec.php

Structures de données

class OrderedTimeCodec

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier OrderingField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier OrderingField.php

Structures de données

class OrderingField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier OrganizationalUnitNames.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier OrganizationalUnitNames.php

Structures de données

class OrganizationalUnitNames

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier OrganizationName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier OrganizationName.php

Structures de données

class OrganizationName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Original.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Base64
Structures de données
Référence du fichier Original.php

Structures de données

class ParagonIE_Sodium_Core_Base64_Original


Joomla CMS: Référence du fichier OtherObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier OtherObject.php

Structures de données

class OtherObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier OtherObjectManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier OtherObjectManager.php

Structures de données

class OtherObjectManager

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier OtherPrimeInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier OtherPrimeInfo.php

Structures de données

class OtherPrimeInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier OtherPrimeInfos.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier OtherPrimeInfos.php

Structures de données

class OtherPrimeInfos

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier outline.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier outline.php

Espaces de nommage

Joomla\Site

Variables

$module = $displayData['module']

Documentation des variables

◆ $module

$module = $displayData['module']


Joomla CMS: Référence du fichier OutOfMemoryError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Structures de données | Espaces de nommage
Référence du fichier OutOfMemoryError.php

Structures de données

class OutOfMemoryError

Espaces de nommage

Symfony\Component\ErrorHandler\Error


Joomla CMS: Référence du fichier Output.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier Output.php

Structures de données

class Output

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier OutputController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Controller
Structures de données | Espaces de nommage
Référence du fichier OutputController.php

Structures de données

class OutputController

Espaces de nommage

Joomla\CMS\Cache\Controller


Joomla CMS: Référence du fichier OutputFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filter
Structures de données | Espaces de nommage
Référence du fichier src/Filter/OutputFilter.php

Structures de données

class OutputFilter

Espaces de nommage

Joomla\CMS\Filter


Joomla CMS: Référence du fichier OutputFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filter
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filter/src/OutputFilter.php

Structures de données

class OutputFilter

Espaces de nommage

Joomla\Filter


Joomla CMS: Référence du fichier OutputFormatter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier OutputFormatter.php

Structures de données

class OutputFormatter

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier OutputFormatterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier OutputFormatterInterface.php

Structures de données

interface OutputFormatterInterface

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier OutputFormatterStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier OutputFormatterStyle.php

Structures de données

class OutputFormatterStyle

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier OutputFormatterStyleInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier OutputFormatterStyleInterface.php

Structures de données

interface OutputFormatterStyleInterface

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier OutputFormatterStyleStack.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier OutputFormatterStyleStack.php

Structures de données

class OutputFormatterStyleStack

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier OutputInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier OutputInterface.php

Structures de données

interface OutputInterface

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier OutputStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Style
Structures de données | Espaces de nommage
Référence du fichier OutputStyle.php

Structures de données

class OutputStyle

Espaces de nommage

Symfony\Component\Console\Style


Joomla CMS: Référence du fichier override.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • override
Structures de données | Espaces de nommage
Référence du fichier override.php

Structures de données

class PlgInstallerOverride

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier overridecheck.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • overridecheck
Structures de données | Espaces de nommage
Référence du fichier overridecheck.php

Structures de données

class PlgQuickiconOverrideCheck

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier OverrideController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier OverrideController.php

Structures de données

class OverrideController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier OverrideModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier OverrideModel.php

Structures de données

class OverrideModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Répertoire de référence de polyfill-mbstring

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
Répertoire de référence de polyfill-mbstring

Répertoires

répertoire Resources

Fichiers

fichier | vendor/symfony/polyfill-mbstring/bootstrap.php
fichier | polyfill-mbstring/bootstrap80.php
fichier | Mbstring.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier LatestActionsHelper.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | TemplateHelper.php
fichier | TemplatesHelper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Répertoire de référence de Command

Fichiers

fichier | Command.php
fichier | CompleteCommand.php
fichier | DumpCompletionCommand.php
fichier | symfony/console/Command/HelpCommand.php
fichier | LazyCommand.php
fichier | symfony/console/Command/ListCommand.php
fichier | LockableTrait.php
fichier | SignalableCommandInterface.php


Joomla CMS: Répertoire de référence de system

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
Répertoire de référence de system

Répertoires

répertoire | accessibility
répertoire | actionlogs
répertoire | cache
répertoire | debug
répertoire | fields
répertoire | highlight
répertoire | httpheaders
répertoire | jooa11y
répertoire | languagecode
répertoire | languagefilter
répertoire | log
répertoire | logout
répertoire | logrotation
répertoire | privacyconsent
répertoire | redirect
répertoire | remember
répertoire | schedulerunner
répertoire | sef
répertoire | sessiongc
répertoire | shortcut
répertoire | skipto
répertoire | stats
répertoire | tasknotification
répertoire | updatenotification
répertoire | webauthn


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier SiteStatus.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_fields/src/Controller/FieldsController.php
fichier | api/components/com_fields/src/Controller/GroupsController.php


Joomla CMS: Répertoire de référence de ChangeItem

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
  • ChangeItem
Répertoire de référence de ChangeItem

Fichiers

fichier | MysqlChangeItem.php
fichier | PostgresqlChangeItem.php
fichier | SqlsrvChangeItem.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_stats_admin/tmpl/default.php


Joomla CMS: Répertoire de référence de http

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
Répertoire de référence de http

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Répertoire de référence de src

Répertoires

répertoire | Command
répertoire | Exception
répertoire | Handler
répertoire | Storage
répertoire | Validator

Fichiers

fichier | session/src/HandlerInterface.php
fichier | vendor/joomla/session/src/Session.php
fichier | SessionEvent.php
fichier | SessionEvents.php
fichier | SessionInterface.php
fichier | SessionState.php
fichier | joomla/session/src/StorageInterface.php
fichier | ValidatorInterface.php


Joomla CMS: Répertoire de référence de doctrine

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
Répertoire de référence de doctrine

Répertoires

répertoire inflector


Joomla CMS: Répertoire de référence de repeatable-table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable-table
Répertoire de référence de repeatable-table

Fichiers

fichier | table/section-byfieldsets.php
fichier | table/section.php


Joomla CMS: Répertoire de référence de com_languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
Répertoire de référence de com_languages

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de contacts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • contacts
Répertoire de référence de contacts

Fichiers

fichier contacts.php


Joomla CMS: Répertoire de référence de Fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Fields
Répertoire de référence de Fields

Fichiers

fichier FieldsServiceInterface.php


Joomla CMS: Répertoire de référence de Captive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Captive
Répertoire de référence de Captive

Fichiers

fichier components/com_users/src/View/Captive/HtmlView.php


Joomla CMS: Répertoire de référence de History

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
  • View
  • History
Répertoire de référence de History

Fichiers

fichier com_contenthistory/src/View/History/JsonapiView.php


Joomla CMS: Répertoire de référence de fixed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
Répertoire de référence de fixed

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Event
répertoire | Exception
répertoire | Web

Fichiers

fichier | AbstractApplication.php
fichier | AbstractWebApplication.php
fichier | ApplicationEvents.php
fichier | ApplicationInterface.php
fichier | ConfigurationAwareApplicationInterface.php
fichier | SessionAwareWebApplicationInterface.php
fichier | SessionAwareWebApplicationTrait.php
fichier | vendor/joomla/application/src/WebApplication.php
fichier | WebApplicationInterface.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | BannerController.php
fichier | administrator/components/com_banners/src/Controller/BannersController.php
fichier | ClientController.php
fichier | administrator/components/com_banners/src/Controller/ClientsController.php
fichier | administrator/components/com_banners/src/Controller/DisplayController.php
fichier | TracksController.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesNewsHelper.php


Joomla CMS: Répertoire de référence de Resolver

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Resolver
Répertoire de référence de Resolver

Fichiers

fichier | PharInvocation.php
fichier | PharInvocationCollection.php
fichier | PharInvocationResolver.php


Joomla CMS: Répertoire de référence de Workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Workflow
Répertoire de référence de Workflow

Fichiers

fichier administrator/components/com_workflow/src/View/Workflow/HtmlView.php


Joomla CMS: Répertoire de référence de tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • tags
Répertoire de référence de tags

Fichiers

fichier plugins/webservices/tags/tags.php


Joomla CMS: Répertoire de référence de modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • modal
Répertoire de référence de modal

Fichiers

fichier | layouts/libraries/html/bootstrap/modal/body.php
fichier | footer.php
fichier | header.php
fichier | iframe.php
fichier | main.php


Joomla CMS: Répertoire de référence de SecretStream

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • SecretStream
Répertoire de référence de SecretStream

Fichiers

fichier src/Core32/SecretStream/State.php


Joomla CMS: Répertoire de référence de profile

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • profile
Répertoire de référence de profile

Répertoires

répertoire src

Fichiers

fichier profile.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire | assets
répertoire | bin
répertoire | views


Joomla CMS: Répertoire de référence de Renderer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
Répertoire de référence de Renderer

Répertoires

répertoire | Feed
répertoire | Html


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • services
Répertoire de référence de services

Fichiers

fichier administrator/modules/mod_quickicon/services/provider.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • textarea
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/textarea/tmpl/textarea.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal

Fichiers

fichier | ItemlanguageField.php
fichier | ItemtypeField.php


Joomla CMS: Répertoire de référence de Engines

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Répertoire de référence de Engines

Répertoires

répertoire | BCMath
répertoire | GMP
répertoire | PHP

Fichiers

fichier | phpseclib/phpseclib/Math/BigInteger/Engines/BCMath.php
fichier | Engine.php
fichier | GMP.php
fichier | vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/OpenSSL.php
fichier | PHP.php
fichier | PHP32.php
fichier | PHP64.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | MessageStatesField.php
fichier | UserMessagesField.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ContenthistoryHelper.php


Joomla CMS: Répertoire de référence de mail

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • mail
Répertoire de référence de mail

Fichiers

fichier administrator/components/com_users/tmpl/mail/default.php


Joomla CMS: Répertoire de référence de Error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
Répertoire de référence de Error

Répertoires

répertoire | JsonApi
répertoire | Renderer

Fichiers

fichier | AbstractRenderer.php
fichier | Error/RendererInterface.php


Joomla CMS: Répertoire de référence de Editor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Editor
Répertoire de référence de Editor

Fichiers

fichier Editor.php


Joomla CMS: Répertoire de référence de views

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Répertoire de référence de views

Fichiers

fichier | error.html.php
fichier | exception.html.php
fichier | exception_full.html.php
fichier | logs.html.php
fichier | trace.html.php
fichier | traces.html.php
fichier | traces_text.html.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Categories
répertoire | Category
répertoire | Contact
répertoire | Featured
répertoire | Form


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_contact/src/Helper/AssociationsHelper.php
fichier | ContactHelper.php


Joomla CMS: Répertoire de référence de debug

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
Répertoire de référence de debug

Répertoires

répertoire src

Fichiers

fichier plugins/system/debug/debug.php


Joomla CMS: Répertoire de référence de mod_logged

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
Répertoire de référence de mod_logged

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_logged.php


Joomla CMS: Répertoire de référence de Templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • View
  • Templates
Répertoire de référence de Templates

Fichiers

fichier administrator/components/com_mails/src/View/Templates/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_tags/src/Controller/DisplayController.php
fichier | TagController.php
fichier | administrator/components/com_tags/src/Controller/TagsController.php


Joomla CMS: Répertoire de référence de polyfill-intl-normalizer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
Répertoire de référence de polyfill-intl-normalizer

Répertoires

répertoire Resources

Fichiers

fichier | vendor/symfony/polyfill-intl-normalizer/bootstrap.php
fichier | polyfill-intl-normalizer/bootstrap80.php
fichier | Normalizer.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_messages
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_messages/tmpl/default.php


Joomla CMS: Répertoire de référence de Helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Répertoire de référence de Helpers

Fichiers

fichier | HTML/Helpers/Access.php
fichier | ActionsDropdown.php
fichier | AdminLanguage.php
fichier | src/HTML/Helpers/Behavior.php
fichier | Bootstrap.php
fichier | libraries/src/HTML/Helpers/Category.php
fichier | HTML/Helpers/Content.php
fichier | ContentLanguage.php
fichier | HTML/Helpers/Date.php
fichier | src/HTML/Helpers/Debug.php
fichier | DraggableList.php
fichier | Dropdown.php
fichier | libraries/src/HTML/Helpers/Email.php
fichier | HTML/Helpers/Form.php
fichier | FormBehavior.php
fichier | Grid.php
fichier | Icons.php
fichier | JGrid.php
fichier | Jquery.php
fichier | Links.php
fichier | ListHelper.php
fichier | libraries/src/HTML/Helpers/Menu.php
fichier | Number.php
fichier | SearchTools.php
fichier | Select.php
fichier | Sidebar.php
fichier | SortableList.php
fichier | src/HTML/Helpers/StringHelper.php
fichier | Tag.php
fichier | Telephone.php
fichier | UiTab.php
fichier | HTML/Helpers/User.php
fichier | WorkflowStage.php


Joomla CMS: Répertoire de référence de Traits

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Traits
Répertoire de référence de Traits

Fichiers

fichier | Fingerprint.php
fichier | PasswordProtected.php


Joomla CMS: Répertoire de référence de Date

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Date
Répertoire de référence de Date

Fichiers

fichier Date/Date.php


Joomla CMS: Répertoire de référence de codemirror

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
Répertoire de référence de codemirror

Répertoires

répertoire | layouts
répertoire | src

Fichiers

fichier codemirror.php


Joomla CMS: Répertoire de référence de Storage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Répertoire de référence de Storage

Fichiers

fichier | libraries/vendor/maximebf/debugbar/src/DebugBar/Storage/FileStorage.php
fichier | vendor/maximebf/debugbar/src/DebugBar/Storage/MemcachedStorage.php
fichier | PdoStorage.php
fichier | vendor/maximebf/debugbar/src/DebugBar/Storage/RedisStorage.php
fichier | maximebf/debugbar/src/DebugBar/Storage/StorageInterface.php


Joomla CMS: Répertoire de référence de tracks

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • tracks
Répertoire de référence de tracks

Fichiers

fichier | administrator/components/com_banners/tmpl/tracks/default.php
fichier | administrator/components/com_banners/tmpl/tracks/emptystate.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier StyleTable.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | laminas/laminas-diactoros/src/Exception/DeserializationException.php
fichier | laminas/laminas-diactoros/src/Exception/ExceptionInterface.php
fichier | laminas/laminas-diactoros/src/Exception/InvalidArgumentException.php
fichier | InvalidStreamPointerPositionException.php
fichier | SerializationException.php
fichier | UnreadableStreamException.php
fichier | UnrecognizedProtocolVersionException.php
fichier | UnrewindableStreamException.php
fichier | UnseekableStreamException.php
fichier | UntellableStreamException.php
fichier | UnwritableStreamException.php
fichier | UploadedFileAlreadyMovedException.php
fichier | UploadedFileErrorException.php


Joomla CMS: Répertoire de référence de categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • categories
Répertoire de référence de categories

Fichiers

fichier | components/com_contact/tmpl/categories/default.php
fichier | components/com_contact/tmpl/categories/default_items.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire messages


Joomla CMS: Répertoire de référence de Language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Language
Répertoire de référence de Language

Fichiers

fichier administrator/components/com_languages/src/View/Language/HtmlView.php


Joomla CMS: Répertoire de référence de Query

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Répertoire de référence de Query

Fichiers

fichier | LimitableInterface.php
fichier | MysqlQueryBuilder.php
fichier | PostgresqlQueryBuilder.php
fichier | PreparableInterface.php
fichier | QueryElement.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire History


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_privacy/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de http-message

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
Répertoire de référence de http-message

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/multifactorauth/webauthn/tmpl/default.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ConfigComponentsField.php
fichier | FiltersField.php


Joomla CMS: Répertoire de référence de api

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
Répertoire de référence de api

Répertoires

répertoire | components
répertoire | includes

Fichiers

fichier api/index.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier RedirectComponent.php


Joomla CMS: Répertoire de référence de quickicons

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • quickicons
Répertoire de référence de quickicons

Fichiers

fichier layouts/joomla/quickicons/icon.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire | field
répertoire | fields


Joomla CMS: Répertoire de référence de Select

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Select
Répertoire de référence de Select

Fichiers

fichier administrator/components/com_modules/src/View/Select/HtmlView.php


Joomla CMS: Répertoire de référence de token

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
Répertoire de référence de token

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_messages/src/Controller/ConfigController.php
fichier | administrator/components/com_messages/src/Controller/DisplayController.php
fichier | com_messages/src/Controller/MessageController.php
fichier | administrator/components/com_messages/src/Controller/MessagesController.php


Joomla CMS: Répertoire de référence de Strategies

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Strategies
Répertoire de référence de Strategies

Fichiers

fichier | DatabaseStrategy.php
fichier | LocalStrategy.php


Joomla CMS: Répertoire de référence de vendor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
Répertoire de référence de vendor

Répertoires

répertoire | algo26-matthias
répertoire | beberlei
répertoire | brick
répertoire | composer
répertoire | defuse
répertoire | doctrine
répertoire | dragonmantank
répertoire | enshrined
répertoire | fgrosse
répertoire | fig
répertoire | google
répertoire | jakeasmith
répertoire | joomla
répertoire | laminas
répertoire | lcobucci
répertoire | maximebf
répertoire | nyholm
répertoire | paragonie
répertoire | php-http
répertoire | phpmailer
répertoire | phpseclib
répertoire | psr
répertoire | ramsey
répertoire | spomky-labs
répertoire | symfony
répertoire | tobscure
répertoire | typo3
répertoire | voku
répertoire | wamania
répertoire | web-auth
répertoire | web-token
répertoire | webmozart
répertoire | willdurand

Fichiers

fichier autoload.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_users/src/Controller/CallbackController.php
fichier | administrator/components/com_users/src/Controller/CaptiveController.php
fichier | administrator/components/com_users/src/Controller/DisplayController.php
fichier | com_users/src/Controller/GroupController.php
fichier | administrator/components/com_users/src/Controller/GroupsController.php
fichier | LevelController.php
fichier | administrator/components/com_users/src/Controller/LevelsController.php
fichier | MailController.php
fichier | administrator/components/com_users/src/Controller/MethodController.php
fichier | administrator/components/com_users/src/Controller/MethodsController.php
fichier | NoteController.php
fichier | NotesController.php
fichier | administrator/components/com_users/src/Controller/UserController.php
fichier | administrator/components/com_users/src/Controller/UsersController.php


Joomla CMS: Répertoire de référence de Adapters

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • View
  • Adapters
Répertoire de référence de Adapters

Fichiers

fichier com_media/src/View/Adapters/JsonapiView.php


Joomla CMS: Répertoire de référence de helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
Répertoire de référence de helper

Répertoires

répertoire data

Fichiers

fichier ASCII.php


Joomla CMS: Répertoire de référence de languagecode

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • languagecode
Répertoire de référence de languagecode

Fichiers

fichier languagecode.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire field

Fichiers

fichier | plugins/system/stats/layouts/message.php
fichier | layouts/stats.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Error
répertoire | Preinstall
répertoire | Remove
répertoire | Setup

Fichiers

fichier DefaultView.php


Joomla CMS: Répertoire de référence de com_admin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
Répertoire de référence de com_admin

Répertoires

répertoire | postinstall
répertoire | services
répertoire | src
répertoire | tmpl

Fichiers

fichier script.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_installer/src/Controller/ManageController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Key

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Key
Répertoire de référence de Key

Fichiers

fichier | FileCouldNotBeRead.php
fichier | InMemory.php
fichier | LocalFileReference.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Compare
répertoire | History
répertoire | Preview


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ApplicationModel.php
fichier | ComponentModel.php


Joomla CMS: Répertoire de référence de Remind

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Remind
Répertoire de référence de Remind

Fichiers

fichier components/com_users/src/View/Remind/HtmlView.php


Joomla CMS: Répertoire de référence de associations

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
  • associations
Répertoire de référence de associations

Fichiers

fichier | administrator/components/com_associations/tmpl/associations/default.php
fichier | administrator/components/com_associations/tmpl/associations/modal.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
  • services
Répertoire de référence de services

Fichiers

fichier plugins/system/shortcut/services/provider.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | capabilities
répertoire | consents
répertoire | request
répertoire | requests


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Répertoire de référence de Application

Répertoires

répertoire | CLI
répertoire | Exception

Fichiers

fichier | AdministratorApplication.php
fichier | ApiApplication.php
fichier | ApplicationHelper.php
fichier | BaseApplication.php
fichier | CliApplication.php
fichier | CMSApplication.php
fichier | CMSApplicationInterface.php
fichier | CMSWebApplicationInterface.php
fichier | ConsoleApplication.php
fichier | DaemonApplication.php
fichier | EventAware.php
fichier | EventAwareInterface.php
fichier | ExtensionNamespaceMapper.php
fichier | IdentityAware.php
fichier | MultiFactorAuthenticationHandler.php
fichier | SiteApplication.php
fichier | src/Application/WebApplication.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_users/src/Model/BackupcodesModel.php
fichier | components/com_users/src/Model/CaptiveModel.php
fichier | components/com_users/src/Model/LoginModel.php
fichier | components/com_users/src/Model/MethodModel.php
fichier | components/com_users/src/Model/MethodsModel.php
fichier | ProfileModel.php
fichier | RegistrationModel.php
fichier | com_users/src/Model/RemindModel.php
fichier | ResetModel.php


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
  • Adapter
Répertoire de référence de Adapter

Fichiers

fichier | CollectionAdapter.php
fichier | ExtensionAdapter.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Taggable.php


Joomla CMS: Répertoire de référence de com_fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
Répertoire de référence de com_fields

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de privacy

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
Répertoire de référence de privacy

Répertoires

répertoire | actionlogs
répertoire | consents
répertoire | contact
répertoire | content
répertoire | message
répertoire | user


Joomla CMS: Répertoire de référence de PDO

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
  • PDO
Répertoire de référence de PDO

Fichiers

fichier | PDOCollector.php
fichier | TraceablePDO.php
fichier | TraceablePDOStatement.php
fichier | TracedStatement.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | InvalidResponseCodeException.php
fichier | UnexpectedResponseException.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire form


Joomla CMS: Répertoire de référence de phar-stream-wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
Répertoire de référence de phar-stream-wrapper

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • Exception
Répertoire de référence de Exception

Fichiers

fichier UnsupportedStorageException.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | TemplatelocationField.php
fichier | TemplatenameField.php


Joomla CMS: Répertoire de référence de codemirror

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • layouts
  • editors
  • codemirror
Répertoire de référence de codemirror

Fichiers

fichier | element.php
fichier | styles.php


Joomla CMS: Répertoire de référence de Test

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Test
Répertoire de référence de Test

Fichiers

fichier VarDumperTestTrait.php


Joomla CMS: Répertoire de référence de subform

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
Répertoire de référence de subform

Répertoires

répertoire | repeatable
répertoire | repeatable-table

Fichiers

fichier | layouts/joomla/form/field/subform/default.php
fichier | repeatable-table.php
fichier | repeatable.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_menus/services/provider.php


Joomla CMS: Répertoire de référence de button

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • button
Répertoire de référence de button

Fichiers

fichier | action-button.php
fichier | button/iconclass.php
fichier | transition-button.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire | stubs
répertoire | unidata


Joomla CMS: Répertoire de référence de mod_privacy_dashboard

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
Répertoire de référence de mod_privacy_dashboard

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_privacy_dashboard.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PrivacyStatusHelper.php


Joomla CMS: Répertoire de référence de toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • layouts
  • toolbar
Répertoire de référence de toolbar

Fichiers

fichier | create-folder.php
fichier | delete.php
fichier | upload.php


Joomla CMS: Répertoire de référence de color

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • color
Répertoire de référence de color

Répertoires

répertoire tmpl

Fichiers

fichier color.php


Joomla CMS: Répertoire de référence de select

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • select
Répertoire de référence de select

Fichiers

fichier | administrator/components/com_scheduler/tmpl/select/default.php
fichier | administrator/components/com_scheduler/tmpl/select/modal.php


Joomla CMS: Répertoire de référence de Application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Application
Répertoire de référence de Application

Fichiers

fichier InstallationApplication.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | ConnectionFailureException.php
fichier | DatabaseNotFoundException.php
fichier | ExecutionFailureException.php
fichier | PrepareStatementFailureException.php
fichier | QueryTypeAlreadyDefinedException.php
fichier | UnknownTypeException.php
fichier | UnsupportedAdapterException.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_related_items/tmpl/default.php


Joomla CMS: Répertoire de référence de Request

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Request
Répertoire de référence de Request

Fichiers

fichier components/com_privacy/src/View/Request/HtmlView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire login


Joomla CMS: Répertoire de référence de calendar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • calendar
Répertoire de référence de calendar

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/calendar/calendar.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | CommandNotFoundException.php
fichier | symfony/console/Exception/ExceptionInterface.php
fichier | symfony/console/Exception/InvalidArgumentException.php
fichier | InvalidOptionException.php
fichier | LogicException.php
fichier | MissingInputException.php
fichier | symfony/console/Exception/NamespaceNotFoundException.php
fichier | console/Exception/RuntimeException.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Filter
répertoire | Filters
répertoire | Index
répertoire | Indexer
répertoire | Maps
répertoire | Searches
répertoire | Statistics


Joomla CMS: Répertoire de référence de Curve25519

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
Répertoire de référence de Curve25519

Répertoires

répertoire Ge

Fichiers

fichier | src/Core/Curve25519/Fe.php
fichier | src/Core/Curve25519/H.php


Joomla CMS: Répertoire de référence de System

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
Répertoire de référence de System

Répertoires

répertoire SSH


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier RedirectHelper.php


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • contact
Répertoire de référence de contact

Fichiers

fichier plugins/content/contact/contact.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Form
Répertoire de référence de Form

Fichiers

fichier components/com_contact/src/View/Form/HtmlView.php


Joomla CMS: Répertoire de référence de search

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
  • search
Répertoire de référence de search

Fichiers

fichier | components/com_finder/tmpl/search/default.php
fichier | com_finder/tmpl/search/default_form.php
fichier | default_result.php
fichier | default_results.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Ge

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Répertoire de référence de Ge

Fichiers

fichier | namespaced/Core/Curve25519/Ge/Cached.php
fichier | namespaced/Core/Curve25519/Ge/P1p1.php
fichier | namespaced/Core/Curve25519/Ge/P2.php
fichier | namespaced/Core/Curve25519/Ge/P3.php
fichier | namespaced/Core/Curve25519/Ge/Precomp.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ConfigHelper.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire | field
répertoire | fields


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de com_categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
Répertoire de référence de com_categories

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de skipto

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • skipto
Répertoire de référence de skipto

Fichiers

fichier skipto.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_feed/tmpl/default.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_categories/src/Model/CategoriesModel.php
fichier | administrator/components/com_categories/src/Model/CategoryModel.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | administrator/components/com_languages/src/Helper/LanguagesHelper.php
fichier | MultilangstatusHelper.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Categories


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • services
Répertoire de référence de services

Fichiers

fichier modules/mod_articles_latest/services/provider.php


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • form
Répertoire de référence de form

Fichiers

fichier components/com_content/tmpl/form/edit.php


Joomla CMS: Répertoire de référence de RequestMethod

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Répertoire de référence de RequestMethod

Fichiers

fichier | google/recaptcha/src/ReCaptcha/RequestMethod/Curl.php
fichier | CurlPost.php
fichier | Post.php
fichier | google/recaptcha/src/ReCaptcha/RequestMethod/Socket.php
fichier | SocketPost.php


Joomla CMS: Répertoire de référence de captive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • captive
Répertoire de référence de captive

Fichiers

fichier | administrator/components/com_users/tmpl/captive/default.php
fichier | administrator/components/com_users/tmpl/captive/select.php


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier ArticleField.php


Joomla CMS: Répertoire de référence de com_contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
Répertoire de référence de com_contact

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_languages/src/Controller/DisplayController.php
fichier | InstalledController.php
fichier | administrator/components/com_languages/src/Controller/LanguageController.php
fichier | administrator/components/com_languages/src/Controller/LanguagesController.php
fichier | OverrideController.php
fichier | administrator/components/com_languages/src/Controller/OverridesController.php
fichier | administrator/components/com_languages/src/Controller/StringsController.php


Joomla CMS: Répertoire de référence de update

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • update
Répertoire de référence de update

Fichiers

fichier | administrator/components/com_installer/tmpl/update/default.php
fichier | administrator/components/com_installer/tmpl/update/emptystate.php


Joomla CMS: Répertoire de référence de api-authentication

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
Répertoire de référence de api-authentication

Répertoires

répertoire | basic
répertoire | token


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
Répertoire de référence de fields

Répertoires

répertoire | calendar
répertoire | checkboxes
répertoire | color
répertoire | editor
répertoire | imagelist
répertoire | integer
répertoire | list
répertoire | media
répertoire | radio
répertoire | sql
répertoire | subform
répertoire | text
répertoire | textarea
répertoire | url
répertoire | user
répertoire | usergrouplist


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier components/com_tags/src/Helper/RouteHelper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
Répertoire de référence de src

Répertoires

répertoire | data
répertoire | ElementReference
répertoire | Exceptions

Fichiers

fichier | libraries/vendor/enshrined/svg-sanitize/src/Helper.php
fichier | Sanitizer.php
fichier | svg-scanner.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de com_menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
Répertoire de référence de com_menus

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Support

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
  • Support
Répertoire de référence de Support

Fichiers

fichier src/Filesystem/Support/StringController.php


Joomla CMS: Répertoire de référence de Profiler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Profiler
Répertoire de référence de Profiler

Fichiers

fichier Profiler.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_checkin/services/provider.php


Joomla CMS: Répertoire de référence de privacy

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • privacy
Répertoire de référence de privacy

Fichiers

fichier privacy.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | config
répertoire | message
répertoire | messages


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Event
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Répertoire de référence de toolbar

Fichiers

fichier | base.php
fichier | basic.php
fichier | layouts/joomla/toolbar/batch.php
fichier | containerclose.php
fichier | containeropen.php
fichier | dropdown.php
fichier | toolbar/iconclass.php
fichier | inlinehelp.php
fichier | toolbar/link.php
fichier | popup.php
fichier | separator.php
fichier | standard.php
fichier | layouts/joomla/toolbar/title.php
fichier | versions.php


Joomla CMS: Répertoire de référence de Groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • View
  • Groups
Répertoire de référence de Groups

Fichiers

fichier com_fields/src/View/Groups/JsonapiView.php


Joomla CMS: Répertoire de référence de mod_custom

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_custom
Répertoire de référence de mod_custom

Fichiers

fichier banner.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Help
répertoire | Sysinfo


Joomla CMS: Répertoire de référence de Messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
  • View
  • Messages
Répertoire de référence de Messages

Fichiers

fichier com_messages/src/View/Messages/JsonapiView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Search


Joomla CMS: Répertoire de référence de Autoload

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Autoload
Répertoire de référence de Autoload

Fichiers

fichier src/Autoload/ClassLoader.php


Joomla CMS: Répertoire de référence de Update

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Update
Répertoire de référence de Update

Fichiers

fichier administrator/components/com_joomlaupdate/src/View/Update/HtmlView.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Versionable.php


Joomla CMS: Répertoire de référence de icon

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • icon
Répertoire de référence de icon

Fichiers

fichier icon/iconclass.php


Joomla CMS: Répertoire de référence de finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
Répertoire de référence de finder

Répertoires

répertoire | categories
répertoire | contacts
répertoire | content
répertoire | newsfeeds
répertoire | tags


Joomla CMS: Répertoire de référence de Error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Error
Répertoire de référence de Error

Répertoires

répertoire Renderer


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
Répertoire de référence de src

Répertoires

répertoire voku


Joomla CMS: Répertoire de référence de Exceptions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • Exceptions
Répertoire de référence de Exceptions

Fichiers

fichier NestingException.php


Joomla CMS: Répertoire de référence de html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
Répertoire de référence de html

Répertoires

répertoire batch

Fichiers

fichier | layouts/joomla/html/image.php
fichier | treeprefix.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Répertoire de référence de src

Fichiers

fichier | vendor/paragonie/constant_time_encoding/src/Base32.php
fichier | Base32Hex.php
fichier | Base64.php
fichier | Base64DotSlash.php
fichier | Base64DotSlashOrdered.php
fichier | Base64UrlSafe.php
fichier | paragonie/constant_time_encoding/src/Binary.php
fichier | EncoderInterface.php
fichier | paragonie/constant_time_encoding/src/Encoding.php
fichier | Hex.php
fichier | RFC4648.php


Joomla CMS: Répertoire de référence de Client

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Client
Répertoire de référence de Client

Fichiers

fichier | ClientHelper.php
fichier | src/Client/FtpClient.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Link
répertoire | Links


Joomla CMS: Répertoire de référence de Overrides

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Overrides
Répertoire de référence de Overrides

Fichiers

fichier administrator/components/com_languages/src/View/Overrides/HtmlView.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_contenthistory/helpers/contenthistory.php


Joomla CMS: Répertoire de référence de administrator

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
Répertoire de référence de administrator

Répertoires

répertoire | cache
répertoire | components
répertoire | includes
répertoire | language
répertoire | modules
répertoire | templates

Fichiers

fichier administrator/index.php


Joomla CMS: Répertoire de référence de grid

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • grid
Répertoire de référence de grid

Fichiers

fichier sort.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier RandomImageHelper.php


Joomla CMS: Répertoire de référence de Interceptor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Interceptor
Répertoire de référence de Interceptor

Fichiers

fichier | ConjunctionInterceptor.php
fichier | PharExtensionInterceptor.php
fichier | PharMetaDataInterceptor.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | symfony/string/Exception/ExceptionInterface.php
fichier | symfony/string/Exception/InvalidArgumentException.php
fichier | string/Exception/RuntimeException.php


Joomla CMS: Répertoire de référence de Attribute

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Attribute
Répertoire de référence de Attribute

Fichiers

fichier AsCommand.php


Joomla CMS: Répertoire de référence de Log

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
  • Log
Répertoire de référence de Log

Fichiers

fichier | AbstractLogger.php
fichier | psr/log/Psr/Log/InvalidArgumentException.php
fichier | LoggerAwareInterface.php
fichier | LoggerAwareTrait.php
fichier | LoggerInterface.php
fichier | LoggerTrait.php
fichier | LogLevel.php
fichier | NullLogger.php


Joomla CMS: Répertoire de référence de sodium_compat

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
Répertoire de référence de sodium_compat

Répertoires

répertoire | lib
répertoire | namespaced
répertoire | src

Fichiers

fichier | autoload-fast.php
fichier | autoload-pedantic.php
fichier | autoload-php7.php
fichier | autoload-phpunit.php
fichier | paragonie/sodium_compat/autoload.php


Joomla CMS: Répertoire de référence de editors-xtd

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
Répertoire de référence de editors-xtd

Répertoires

répertoire | article
répertoire | contact
répertoire | fields
répertoire | image
répertoire | menu
répertoire | module
répertoire | pagebreak
répertoire | readmore


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_contact/src/Model/CategoriesModel.php
fichier | components/com_contact/src/Model/CategoryModel.php
fichier | components/com_contact/src/Model/ContactModel.php
fichier | components/com_contact/src/Model/FeaturedModel.php
fichier | components/com_contact/src/Model/FormModel.php


Joomla CMS: Répertoire de référence de mod_articles_archive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
Répertoire de référence de mod_articles_archive

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_articles_archive.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Installer
Répertoire de référence de Installer

Fichiers

fichier administrator/components/com_installer/src/View/Installer/HtmlView.php


Joomla CMS: Répertoire de référence de PrimeField

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • PrimeField
Répertoire de référence de PrimeField

Fichiers

fichier phpseclib/phpseclib/phpseclib/Math/PrimeField/Integer.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Item
répertoire | Items
répertoire | Menu
répertoire | Menus
répertoire | Menutypes


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | InvalidActionException.php
fichier | UnknownAssetException.php
fichier | src/WebAsset/Exception/UnsatisfiedDependencyException.php
fichier | WebAssetExceptionInterface.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_content/src/Helper/AssociationsHelper.php
fichier | administrator/components/com_content/src/Helper/ContentHelper.php


Joomla CMS: Répertoire de référence de config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • config
Répertoire de référence de config

Fichiers

fichier administrator/components/com_messages/tmpl/config/default.php


Joomla CMS: Répertoire de référence de Groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Groups
Répertoire de référence de Groups

Fichiers

fichier administrator/components/com_users/src/View/Groups/HtmlView.php


Joomla CMS: Répertoire de référence de Rules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
  • Rules
Répertoire de référence de Rules

Fichiers

fichier | MenuRules.php
fichier | NomenuRules.php
fichier | RulesInterface.php
fichier | StandardRules.php


Joomla CMS: Répertoire de référence de Featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Featured
Répertoire de référence de Featured

Fichiers

fichier components/com_contact/src/View/Featured/HtmlView.php


Joomla CMS: Répertoire de référence de Profile

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Profile
Répertoire de référence de Profile

Fichiers

fichier components/com_users/src/View/Profile/HtmlView.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • helpers
Répertoire de référence de helpers

Fichiers

fichier com_finder/helpers/route.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • joomla
Répertoire de référence de joomla

Fichiers

fichier plugins/authentication/joomla/joomla.php


Joomla CMS: Répertoire de référence de phpseclib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
Répertoire de référence de phpseclib

Répertoires

répertoire | Common
répertoire | Crypt
répertoire | Exception
répertoire | File
répertoire | Math
répertoire | Net
répertoire | System

Fichiers

fichier vendor/phpseclib/phpseclib/phpseclib/bootstrap.php


Joomla CMS: Répertoire de référence de actionlogs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • tmpl
  • actionlogs
Répertoire de référence de actionlogs

Fichiers

fichier administrator/components/com_actionlogs/tmpl/actionlogs/default.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de components

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
Répertoire de référence de components

Répertoires

répertoire | com_actionlogs
répertoire | com_admin
répertoire | com_ajax
répertoire | com_associations
répertoire | com_banners
répertoire | com_cache
répertoire | com_categories
répertoire | com_checkin
répertoire | com_config
répertoire | com_contact
répertoire | com_content
répertoire | com_contenthistory
répertoire | com_cpanel
répertoire | com_fields
répertoire | com_finder
répertoire | com_installer
répertoire | com_joomlaupdate
répertoire | com_languages
répertoire | com_login
répertoire | com_mails
répertoire | com_media
répertoire | com_menus
répertoire | com_messages
répertoire | com_modules
répertoire | com_newsfeeds
répertoire | com_plugins
répertoire | com_postinstall
répertoire | com_privacy
répertoire | com_redirect
répertoire | com_scheduler
répertoire | com_tags
répertoire | com_templates
répertoire | com_users
répertoire | com_workflow
répertoire | com_wrapper


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier com_categories/src/Service/HTML/AdministratorService.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier api/components/com_content/src/Helper/ContentHelper.php


Joomla CMS: Répertoire de référence de authentication

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
Répertoire de référence de authentication

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire | joomla
répertoire | toolbar


Joomla CMS: Répertoire de référence de com_finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
Répertoire de référence de com_finder

Répertoires

répertoire | helpers
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de article

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • article
Répertoire de référence de article

Fichiers

fichier | components/com_content/tmpl/article/default.php
fichier | com_content/tmpl/article/default_links.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
  • services
Répertoire de référence de services

Fichiers

fichier plugins/actionlog/joomla/services/provider.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Contact
répertoire | Contacts


Joomla CMS: Répertoire de référence de Spanish

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Spanish
Répertoire de référence de Spanish

Fichiers

fichier | Spanish/Inflectible.php
fichier | Rules/Spanish/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Spanish/Rules.php
fichier | Spanish/Uninflected.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_contact/src/Helper/AssociationHelper.php
fichier | components/com_contact/src/Helper/RouteHelper.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_privacy_status/tmpl/default.php


Joomla CMS: Répertoire de référence de links

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • links
Répertoire de référence de links

Fichiers

fichier | groupclose.php
fichier | groupopen.php
fichier | groupsclose.php
fichier | groupseparator.php
fichier | groupsopen.php
fichier | links/link.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_fields/src/Controller/DisplayController.php
fichier | FieldController.php
fichier | administrator/components/com_fields/src/Controller/FieldsController.php
fichier | com_fields/src/Controller/GroupController.php
fichier | administrator/components/com_fields/src/Controller/GroupsController.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Exception
Répertoire de référence de Exception

Fichiers

fichier ThrowingCasterException.php


Joomla CMS: Répertoire de référence de Format

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Répertoire de référence de Format

Fichiers

fichier | Ini.php
fichier | vendor/joomla/registry/src/Format/Json.php
fichier | Php.php
fichier | vendor/joomla/registry/src/Format/Xml.php
fichier | joomla/registry/src/Format/Yaml.php


Joomla CMS: Répertoire de référence de Captcha

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Captcha
Répertoire de référence de Captcha

Répertoires

répertoire Google

Fichiers

fichier Captcha.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | com_newsfeeds/src/Controller/AjaxController.php
fichier | administrator/components/com_newsfeeds/src/Controller/DisplayController.php
fichier | NewsfeedController.php
fichier | NewsfeedsController.php


Joomla CMS: Répertoire de référence de data

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Répertoire de référence de data

Fichiers

fichier | caseFolding_full.php
fichier | chr.php
fichier | emoji.php
fichier | encodings.php
fichier | voku/portable-utf8/src/voku/helper/data/ord.php
fichier | transliterator_list.php
fichier | utf8_fix.php
fichier | win1252_to_utf8.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_content/src/Helper/AssociationHelper.php
fichier | QueryHelper.php
fichier | components/com_content/src/Helper/RouteHelper.php


Joomla CMS: Répertoire de référence de ReCaptcha

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
Répertoire de référence de ReCaptcha

Répertoires

répertoire RequestMethod

Fichiers

fichier | ReCaptcha.php
fichier | RequestMethod.php
fichier | RequestParameters.php
fichier | libraries/vendor/google/recaptcha/src/ReCaptcha/Response.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Helper
répertoire | Model
répertoire | Rule
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier com_joomlaupdate/src/Model/UpdateModel.php


Joomla CMS: Répertoire de référence de mod_menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • mod_menu
Répertoire de référence de mod_menu

Fichiers

fichier | collapse-metismenu.php
fichier | dropdown-metismenu.php
fichier | dropdown-metismenu_component.php
fichier | dropdown-metismenu_heading.php
fichier | dropdown-metismenu_separator.php
fichier | dropdown-metismenu_url.php


Joomla CMS: Répertoire de référence de com_modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
Répertoire de référence de com_modules

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de maps

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • maps
Répertoire de référence de maps

Fichiers

fichier | administrator/components/com_finder/tmpl/maps/default.php
fichier | administrator/components/com_finder/tmpl/maps/emptystate.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier RedirectField.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Répertoire de référence de src

Fichiers

fichier | MessageFactory.php
fichier | php-http/message-factory/src/RequestFactory.php
fichier | php-http/message-factory/src/ResponseFactory.php
fichier | php-http/message-factory/src/StreamFactory.php
fichier | php-http/message-factory/src/UriFactory.php


Joomla CMS: Répertoire de référence de Multilangstatus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Multilangstatus
Répertoire de référence de Multilangstatus

Fichiers

fichier administrator/components/com_languages/src/View/Multilangstatus/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesArchiveHelper.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier MessagesComponent.php


Joomla CMS: Répertoire de référence de Error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Répertoire de référence de Error

Fichiers

fichier | ClassNotFoundError.php
fichier | FatalError.php
fichier | OutOfMemoryError.php
fichier | UndefinedFunctionError.php
fichier | UndefinedMethodError.php


Joomla CMS: Répertoire de référence de Storage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Storage
Répertoire de référence de Storage

Fichiers

fichier | NativeStorage.php
fichier | RuntimeStorage.php


Joomla CMS: Répertoire de référence de cli

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • cli
Répertoire de référence de cli

Fichiers

fichier cli/joomla.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_contenthistory/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Button

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Répertoire de référence de Button

Fichiers

fichier | AbstractGroupButton.php
fichier | BasicButton.php
fichier | ConfirmButton.php
fichier | CustomButton.php
fichier | DropdownButton.php
fichier | HelpButton.php
fichier | InlinehelpButton.php
fichier | LinkButton.php
fichier | PopupButton.php
fichier | SeparatorButton.php
fichier | StandardButton.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | CryptExceptionInterface.php
fichier | DecryptionException.php
fichier | EncryptionException.php
fichier | InvalidKeyException.php
fichier | InvalidKeyTypeException.php
fichier | UnsupportedCipherException.php


Joomla CMS: Répertoire de référence de Composite

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Composite
Répertoire de référence de Composite

Fichiers

fichier | fgrosse/phpasn1/lib/ASN1/Composite/AttributeTypeAndValue.php
fichier | RDNString.php
fichier | fgrosse/phpasn1/lib/ASN1/Composite/RelativeDistinguishedName.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier LanguageclientField.php


Joomla CMS: Répertoire de référence de phputf8

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Répertoire de référence de phputf8

Répertoires

répertoire | mbstring
répertoire | native
répertoire | utils

Fichiers

fichier | joomla/string/src/phputf8/ord.php
fichier | str_ireplace.php
fichier | str_pad.php
fichier | str_split.php
fichier | strcasecmp.php
fichier | strcspn.php
fichier | stristr.php
fichier | strrev.php
fichier | strspn.php
fichier | substr_replace.php
fichier | trim.php
fichier | ucfirst.php
fichier | ucwords.php
fichier | utf8.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | link
répertoire | links


Joomla CMS: Répertoire de référence de uuid

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
Répertoire de référence de uuid

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de native

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • native
Répertoire de référence de native

Fichiers

fichier native/core.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | FilterTable.php
fichier | com_finder/src/Table/LinkTable.php
fichier | MapTable.php


Joomla CMS: Répertoire de référence de router

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
Répertoire de référence de router

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de data

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • data
Répertoire de référence de data

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • installer
Répertoire de référence de installer

Fichiers

fichier changelog.php


Joomla CMS: Répertoire de référence de subform

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • subform
Répertoire de référence de subform

Répertoires

répertoire tmpl

Fichiers

fichier subform.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ExtensionstatusField.php
fichier | FolderField.php
fichier | LocationField.php
fichier | PackageField.php
fichier | com_installer/src/Field/TypeField.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_modules/src/Controller/ModulesController.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • usergrouplist
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/usergrouplist.php


Joomla CMS: Répertoire de référence de plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
Répertoire de référence de plugins

Répertoires

répertoire | editors
répertoire | system
répertoire | user


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Répertoire de référence de Categories

Fichiers

fichier | Categories.php
fichier | Categories/CategoryFactory.php
fichier | CategoryFactoryInterface.php
fichier | CategoryInterface.php
fichier | CategoryNode.php
fichier | CategoryServiceInterface.php
fichier | CategoryServiceTrait.php
fichier | SectionNotFoundException.php


Joomla CMS: Répertoire de référence de postinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • httpheaders
  • postinstall
Répertoire de référence de postinstall

Fichiers

fichier introduction.php


Joomla CMS: Répertoire de référence de File

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • View
  • File
Répertoire de référence de File

Fichiers

fichier administrator/components/com_media/src/View/File/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier modules/mod_feed/src/Helper/FeedHelper.php


Joomla CMS: Répertoire de référence de Index

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Index
Répertoire de référence de Index

Fichiers

fichier administrator/components/com_finder/src/View/Index/HtmlView.php


Joomla CMS: Répertoire de référence de accessibility

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • accessibility
Répertoire de référence de accessibility

Fichiers

fichier accessibility.php


Joomla CMS: Répertoire de référence de Tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Répertoire de référence de Tag

Fichiers

fichier | Base16EncodingTag.php
fichier | Base64EncodingTag.php
fichier | Base64UrlEncodingTag.php
fichier | BigFloatTag.php
fichier | DecimalFractionTag.php
fichier | EpochTag.php
fichier | GenericTag.php
fichier | NegativeBigIntegerTag.php
fichier | PositiveBigIntegerTag.php
fichier | TagObjectManager.php
fichier | TimestampTag.php


Joomla CMS: Répertoire de référence de Preview

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • Preview
Répertoire de référence de Preview

Fichiers

fichier administrator/components/com_contenthistory/src/View/Preview/HtmlView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Confirm
répertoire | Remind
répertoire | Request


Joomla CMS: Répertoire de référence de Clients

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • View
  • Clients
Répertoire de référence de Clients

Fichiers

fichier com_banners/src/View/Clients/JsonapiView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
  • services
Répertoire de référence de services

Fichiers

fichier plugins/task/requests/services/provider.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier modules/mod_articles_news/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Plugins


Joomla CMS: Répertoire de référence de tinymce

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
Répertoire de référence de tinymce

Répertoires

répertoire src

Fichiers

fichier tinymce.php


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-ecdsa

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-ecdsa
Répertoire de référence de jwt-signature-algorithm-ecdsa

Fichiers

fichier | web-token/jwt-signature-algorithm-ecdsa/ECDSA.php
fichier | web-token/jwt-signature-algorithm-ecdsa/ES256.php
fichier | web-token/jwt-signature-algorithm-ecdsa/ES384.php
fichier | web-token/jwt-signature-algorithm-ecdsa/ES512.php


Joomla CMS: Répertoire de référence de Overrides

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Overrides
Répertoire de référence de Overrides

Fichiers

fichier com_languages/src/View/Overrides/JsonapiView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_categories/src/Controller/CategoriesController.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | MfaTable.php
fichier | NoteTable.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_plugins/helpers/plugins.php


Joomla CMS: Répertoire de référence de mod_latestactions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
Répertoire de référence de mod_latestactions

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_latestactions.php


Joomla CMS: Répertoire de référence de Consents

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • View
  • Consents
Répertoire de référence de Consents

Fichiers

fichier com_privacy/src/View/Consents/JsonapiView.php


Joomla CMS: Répertoire de référence de media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • media
Répertoire de référence de media

Fichiers

fichier plugins/webservices/media/media.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Répertoire de référence de src

Répertoires

répertoire | Claim
répertoire | Encoding
répertoire | Parsing
répertoire | Signer
répertoire | Token
répertoire | Validation

Fichiers

fichier | Builder.php
fichier | Claim.php
fichier | libraries/vendor/lcobucci/jwt/src/Configuration.php
fichier | lcobucci/jwt/src/Exception.php
fichier | libraries/vendor/lcobucci/jwt/src/Parser.php
fichier | lcobucci/jwt/src/Signature.php
fichier | Signer.php
fichier | libraries/vendor/lcobucci/jwt/src/Token.php
fichier | ValidationData.php
fichier | Validator.php


Joomla CMS: Répertoire de référence de Form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Form
Répertoire de référence de Form

Fichiers

fichier components/com_content/src/View/Form/HtmlView.php


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier administrator/components/com_categories/src/Field/Modal/CategoryField.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_privacy/src/Controller/DisplayController.php
fichier | components/com_privacy/src/Controller/RequestController.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | FileExistsException.php
fichier | administrator/components/com_media/src/Exception/FileNotFoundException.php
fichier | InvalidPathException.php


Joomla CMS: Répertoire de référence de Signature

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Signature
Répertoire de référence de Signature

Fichiers

fichier Common/Formats/Signature/Raw.php


Joomla CMS: Répertoire de référence de Levels

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Levels
Répertoire de référence de Levels

Fichiers

fichier administrator/components/com_users/src/View/Levels/HtmlView.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier ExceptionHandler.php


Joomla CMS: Répertoire de référence de logrotation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • logrotation
Répertoire de référence de logrotation

Fichiers

fichier logrotation.php


Joomla CMS: Répertoire de référence de Users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Users
Répertoire de référence de Users

Fichiers

fichier com_users/src/View/Users/JsonapiView.php


Joomla CMS: Répertoire de référence de methods

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • methods
Répertoire de référence de methods

Fichiers

fichier | components/com_users/tmpl/methods/default.php
fichier | components/com_users/tmpl/methods/firsttime.php
fichier | components/com_users/tmpl/methods/list.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | DatabaseController.php
fichier | DiscoverController.php
fichier | administrator/components/com_installer/src/Controller/DisplayController.php
fichier | InstallController.php
fichier | administrator/components/com_installer/src/Controller/ManageController.php
fichier | com_installer/src/Controller/UpdateController.php
fichier | UpdatesiteController.php
fichier | UpdatesitesController.php


Joomla CMS: Répertoire de référence de Result

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Répertoire de référence de Result

Fichiers

fichier | ResultAware.php
fichier | ResultAwareInterface.php
fichier | ResultTypeArrayAware.php
fichier | ResultTypeBooleanAware.php
fichier | ResultTypeFloatAware.php
fichier | ResultTypeIntegerAware.php
fichier | ResultTypeMixedAware.php
fichier | ResultTypeNumericAware.php
fichier | ResultTypeObjectAware.php
fichier | ResultTypeStringAware.php


Joomla CMS: Répertoire de référence de Login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Login
Répertoire de référence de Login

Fichiers

fichier components/com_users/src/View/Login/HtmlView.php


Joomla CMS: Répertoire de référence de History

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • History
Répertoire de référence de History

Fichiers

fichier administrator/components/com_contenthistory/src/View/History/HtmlView.php


Joomla CMS: Répertoire de référence de consents

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • consents
Répertoire de référence de consents

Fichiers

fichier | administrator/components/com_privacy/tmpl/consents/default.php
fichier | administrator/components/com_privacy/tmpl/consents/emptystate.php


Joomla CMS: Répertoire de référence de NorwegianBokmal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Répertoire de référence de NorwegianBokmal

Fichiers

fichier | NorwegianBokmal/Inflectible.php
fichier | Rules/NorwegianBokmal/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/NorwegianBokmal/Rules.php
fichier | NorwegianBokmal/Uninflected.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | association
répertoire | associations


Joomla CMS: Répertoire de référence de Tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
  • View
  • Tags
Répertoire de référence de Tags

Fichiers

fichier com_tags/src/View/Tags/JsonapiView.php


Joomla CMS: Répertoire de référence de helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
Répertoire de référence de helper

Répertoires

répertoire data

Fichiers

fichier | Bootup.php
fichier | UTF8.php


Joomla CMS: Répertoire de référence de Encoding

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Encoding
Répertoire de référence de Encoding

Fichiers

fichier | CannotDecodeContent.php
fichier | CannotEncodeContent.php


Joomla CMS: Répertoire de référence de constant_time_encoding

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
Répertoire de référence de constant_time_encoding

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de com_languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
Répertoire de référence de com_languages

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • profile
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier TosField.php


Joomla CMS: Répertoire de référence de VarDumper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
  • VarDumper
Répertoire de référence de VarDumper

Fichiers

fichier | DebugBarHtmlDumper.php
fichier | SeekingData.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • helpers
Répertoire de référence de helpers

Fichiers

fichier com_tags/helpers/route.php


Joomla CMS: Répertoire de référence de Internal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
Répertoire de référence de Internal

Répertoires

répertoire Calculator

Fichiers

fichier Calculator.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_banners/src/Model/BannerModel.php
fichier | components/com_banners/src/Model/BannersModel.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | com_content/src/Controller/AjaxController.php
fichier | administrator/components/com_content/src/Controller/ArticleController.php
fichier | administrator/components/com_content/src/Controller/ArticlesController.php
fichier | administrator/components/com_content/src/Controller/DisplayController.php
fichier | FeaturedController.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_languages/src/Controller/LanguagesController.php
fichier | api/components/com_languages/src/Controller/OverridesController.php
fichier | api/components/com_languages/src/Controller/StringsController.php


Joomla CMS: Répertoire de référence de help

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • help
Répertoire de référence de help

Fichiers

fichier | administrator/components/com_admin/tmpl/help/default.php
fichier | langforum.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_modules/src/Controller/DisplayController.php
fichier | ModuleController.php
fichier | administrator/components/com_modules/src/Controller/ModulesController.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • token
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier JoomlatokenField.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
  • services
Répertoire de référence de services

Fichiers

fichier plugins/behaviour/versionable/services/provider.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier administrator/components/com_admin/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de requests

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • requests
Répertoire de référence de requests

Fichiers

fichier | administrator/components/com_privacy/tmpl/requests/default.php
fichier | administrator/components/com_privacy/tmpl/requests/emptystate.php


Joomla CMS: Répertoire de référence de ElementReference

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • ElementReference
Répertoire de référence de ElementReference

Fichiers

fichier | Resolver.php
fichier | Subject.php
fichier | Usage.php


Joomla CMS: Répertoire de référence de Cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
Répertoire de référence de Cache

Répertoires

répertoire | Controller
répertoire | Exception
répertoire | Storage

Fichiers

fichier | libraries/src/Cache/Cache.php
fichier | Cache/CacheController.php
fichier | CacheControllerFactory.php
fichier | CacheControllerFactoryAwareInterface.php
fichier | CacheControllerFactoryAwareTrait.php
fichier | CacheControllerFactoryInterface.php
fichier | CacheStorage.php


Joomla CMS: Répertoire de référence de finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • finder
Répertoire de référence de finder

Fichiers

fichier content/finder/finder.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier DemoTasks.php


Joomla CMS: Répertoire de référence de config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • config
Répertoire de référence de config

Fichiers

fichier replacements.php


Joomla CMS: Répertoire de référence de paragonie

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
Répertoire de référence de paragonie

Répertoires

répertoire | constant_time_encoding
répertoire | sodium_compat


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier | AbstractModuleDispatcher.php
fichier | ApiDispatcher.php
fichier | ComponentDispatcher.php
fichier | Dispatcher/ComponentDispatcherFactory.php
fichier | ComponentDispatcherFactoryInterface.php
fichier | libraries/src/Dispatcher/Dispatcher.php
fichier | src/Dispatcher/DispatcherInterface.php
fichier | LegacyComponentDispatcher.php
fichier | ModuleDispatcher.php
fichier | Dispatcher/ModuleDispatcherFactory.php
fichier | ModuleDispatcherFactoryInterface.php


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
  • View
  • Categories
Répertoire de référence de Categories

Fichiers

fichier com_categories/src/View/Categories/JsonapiView.php


Joomla CMS: Répertoire de référence de ExtLdap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Répertoire de référence de ExtLdap

Fichiers

fichier | libraries/vendor/symfony/ldap/Adapter/ExtLdap/Adapter.php
fichier | symfony/ldap/Adapter/ExtLdap/Collection.php
fichier | ldap/Adapter/ExtLdap/Connection.php
fichier | ConnectionOptions.php
fichier | EntryManager.php
fichier | libraries/vendor/symfony/ldap/Adapter/ExtLdap/Query.php
fichier | UpdateOperation.php


Joomla CMS: Répertoire de référence de Mac

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Mac
Répertoire de référence de Mac

Fichiers

fichier | web-auth/cose-lib/src/Algorithm/Mac/Hmac.php
fichier | web-auth/cose-lib/src/Algorithm/Mac/HS256.php
fichier | HS256Truncated64.php
fichier | web-auth/cose-lib/src/Algorithm/Mac/HS384.php
fichier | web-auth/cose-lib/src/Algorithm/Mac/HS512.php
fichier | Mac.php


Joomla CMS: Répertoire de référence de psr7

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
Répertoire de référence de psr7

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Newsfeed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeed
Répertoire de référence de Newsfeed

Fichiers

fichier components/com_newsfeeds/src/View/Newsfeed/HtmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_postinstall/services/provider.php


Joomla CMS: Répertoire de référence de Hotfix

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Hotfix
Répertoire de référence de Hotfix

Fichiers

fichier | plugins/system/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php
fichier | plugins/system/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php
fichier | plugins/system/webauthn/src/Hotfix/Server.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_contenthistory/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier | components/com_banners/src/Service/Category.php
fichier | components/com_banners/src/Service/Router.php


Joomla CMS: Répertoire de référence de mod_whosonline

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
Répertoire de référence de mod_whosonline

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_whosonline.php


Joomla CMS: Répertoire de référence de Support

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Support
Répertoire de référence de Support

Fichiers

fichier vendor/joomla/filesystem/src/Support/StringController.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesCategoriesHelper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de dragonmantank

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
Répertoire de référence de dragonmantank

Répertoires

répertoire cron-expression


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Field
répertoire | Fields
répertoire | Group
répertoire | Groups


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • ldap
  • src
Répertoire de référence de src

Fichiers

fichier LdapClient.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier CategoryTable.php


Joomla CMS: Répertoire de référence de mod_menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
Répertoire de référence de mod_menu

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier modules/mod_menu/mod_menu.php


Joomla CMS: Répertoire de référence de com_ajax

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_ajax
Répertoire de référence de com_ajax

Fichiers

fichier administrator/components/com_ajax/ajax.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | BannerTable.php
fichier | ClientTable.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Consents
répertoire | Requests


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
  • local
  • src
  • Adapter
Répertoire de référence de Adapter

Fichiers

fichier LocalAdapter.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Tag
répertoire | Tags


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | FieldModel.php
fichier | FieldsModel.php
fichier | com_fields/src/Model/GroupModel.php
fichier | com_fields/src/Model/GroupsModel.php


Joomla CMS: Répertoire de référence de Turkish

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Turkish
Répertoire de référence de Turkish

Fichiers

fichier | Turkish/Inflectible.php
fichier | Rules/Turkish/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Turkish/Rules.php
fichier | Turkish/Uninflected.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Languages
répertoire | Overrides
répertoire | Strings


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | AuthenticationHelper.php
fichier | CMSHelper.php
fichier | libraries/src/Helper/ContentHelper.php
fichier | Helper/HelperFactory.php
fichier | HelperFactoryAwareInterface.php
fichier | HelperFactoryAwareTrait.php
fichier | HelperFactoryInterface.php
fichier | LibraryHelper.php
fichier | MediaHelper.php
fichier | ModuleHelper.php
fichier | libraries/src/Helper/RouteHelper.php
fichier | TagsHelper.php
fichier | UserGroupsHelper.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | DebugFormatterHelper.php
fichier | symfony/console/Helper/DescriptorHelper.php
fichier | console/Helper/Dumper.php
fichier | FormatterHelper.php
fichier | libraries/vendor/symfony/console/Helper/Helper.php
fichier | HelperInterface.php
fichier | HelperSet.php
fichier | InputAwareHelper.php
fichier | ProcessHelper.php
fichier | ProgressBar.php
fichier | ProgressIndicator.php
fichier | QuestionHelper.php
fichier | SymfonyQuestionHelper.php
fichier | vendor/symfony/console/Helper/Table.php
fichier | TableCell.php
fichier | TableCellStyle.php
fichier | TableRows.php
fichier | TableSeparator.php
fichier | TableStyle.php


Joomla CMS: Répertoire de référence de php-stemmer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
Répertoire de référence de php-stemmer

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier | components/com_content/src/Service/Category.php
fichier | components/com_content/src/Service/Router.php


Joomla CMS: Répertoire de référence de Filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Répertoire de référence de Filter

Fichiers

fichier | Backgroundfill.php
fichier | Brightness.php
fichier | Contrast.php
fichier | Edgedetect.php
fichier | Emboss.php
fichier | Grayscale.php
fichier | Negate.php
fichier | Sketchy.php
fichier | Smooth.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | help
répertoire | sysinfo


Joomla CMS: Répertoire de référence de Tree

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tree
Répertoire de référence de Tree

Fichiers

fichier | ImmutableNodeInterface.php
fichier | ImmutableNodeTrait.php
fichier | NodeInterface.php
fichier | NodeTrait.php


Joomla CMS: Répertoire de référence de Confirm

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Confirm
Répertoire de référence de Confirm

Fichiers

fichier components/com_privacy/src/View/Confirm/HtmlView.php


Joomla CMS: Répertoire de référence de batch

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Répertoire de référence de batch

Fichiers

fichier | access.php
fichier | adminlanguage.php
fichier | item.php
fichier | layouts/joomla/html/batch/language.php
fichier | html/batch/tag.php
fichier | layouts/joomla/html/batch/user.php
fichier | workflowstage.php


Joomla CMS: Répertoire de référence de Wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • View
  • Wrapper
Répertoire de référence de Wrapper

Fichiers

fichier components/com_wrapper/src/View/Wrapper/HtmlView.php


Joomla CMS: Répertoire de référence de Joomla_422-Stable-Full_Package_French_v1

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
Répertoire de référence de Joomla_422-Stable-Full_Package_French_v1

Répertoires

répertoire | administrator
répertoire | api
répertoire | cli
répertoire | components
répertoire | includes
répertoire | installation
répertoire | language
répertoire | layouts
répertoire | libraries
répertoire | modules
répertoire | plugins
répertoire | templates

Fichiers

fichier index.php


Joomla CMS: Répertoire de référence de French

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • French
Répertoire de référence de French

Fichiers

fichier | French/Inflectible.php
fichier | Rules/French/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/French/Rules.php
fichier | French/Uninflected.php


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • layouts
  • joomla
  • form
Répertoire de référence de form

Répertoires

répertoire field


Joomla CMS: Répertoire de référence de newsfeed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Répertoire de référence de newsfeed

Fichiers

fichier components/com_newsfeeds/tmpl/newsfeed/default.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier com_newsfeeds/src/Service/HTML/AdministratorService.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Répertoire de référence de Menu

Fichiers

fichier | AbstractMenu.php
fichier | AdministratorMenu.php
fichier | AdministratorMenuItem.php
fichier | MenuFactory.php
fichier | MenuFactoryInterface.php
fichier | MenuItem.php
fichier | SiteMenu.php


Joomla CMS: Répertoire de référence de Token

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Répertoire de référence de Token

Fichiers

fichier | lcobucci/jwt/src/Token/DataSet.php
fichier | InvalidTokenStructure.php
fichier | Plain.php
fichier | RegisteredClaimGiven.php
fichier | RegisteredClaims.php
fichier | lcobucci/jwt/src/Token/Signature.php
fichier | UnsupportedHeaderFound.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
  • Event
Répertoire de référence de Event

Fichiers

fichier OnGetApiFields.php


Joomla CMS: Répertoire de référence de registry

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
Répertoire de référence de registry

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de AES

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
  • AES
Répertoire de référence de AES

Fichiers

fichier | AbstractAES.php
fichier | AesInterface.php
fichier | Mcrypt.php
fichier | src/Encrypt/AES/OpenSSL.php


Joomla CMS: Répertoire de référence de remind

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • remind
Répertoire de référence de remind

Fichiers

fichier components/com_users/tmpl/remind/default.php


Joomla CMS: Répertoire de référence de Cron

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
  • Cron
Répertoire de référence de Cron

Fichiers

fichier | AbstractField.php
fichier | CronExpression.php
fichier | DayOfMonthField.php
fichier | DayOfWeekField.php
fichier | FieldFactory.php
fichier | FieldFactoryInterface.php
fichier | FieldInterface.php
fichier | HoursField.php
fichier | MinutesField.php
fichier | MonthField.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier DatabaseProvider.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_modules/helpers/modules.php


Joomla CMS: Répertoire de référence de Modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
  • View
  • Modules
Répertoire de référence de Modules

Fichiers

fichier com_modules/src/View/Modules/JsonapiView.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
  • Command
Répertoire de référence de Command

Fichiers

fichier DebugRouterCommand.php


Joomla CMS: Répertoire de référence de nyholm

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
Répertoire de référence de nyholm

Répertoires

répertoire psr7


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
  • services
Répertoire de référence de services

Fichiers

fichier plugins/task/sitestatus/services/provider.php


Joomla CMS: Répertoire de référence de Maps

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Répertoire de référence de Maps

Fichiers

fichier | AccessDescription.php
fichier | AdministrationDomainName.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AlgorithmIdentifier.php
fichier | AnotherName.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attribute.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Attributes.php
fichier | AttributeType.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/AttributeTypeAndValue.php
fichier | AttributeValue.php
fichier | AuthorityInfoAccessSyntax.php
fichier | AuthorityKeyIdentifier.php
fichier | BaseDistance.php
fichier | BasicConstraints.php
fichier | BuiltInDomainDefinedAttribute.php
fichier | BuiltInDomainDefinedAttributes.php
fichier | BuiltInStandardAttributes.php
fichier | Certificate.php
fichier | CertificateIssuer.php
fichier | CertificateList.php
fichier | CertificatePolicies.php
fichier | CertificateSerialNumber.php
fichier | CertificationRequest.php
fichier | CertificationRequestInfo.php
fichier | CertPolicyId.php
fichier | Characteristic_two.php
fichier | CountryName.php
fichier | CPSuri.php
fichier | CRLDistributionPoints.php
fichier | CRLNumber.php
fichier | CRLReason.php
fichier | Curve.php
fichier | DHParameter.php
fichier | DigestInfo.php
fichier | DirectoryString.php
fichier | DisplayText.php
fichier | DistributionPoint.php
fichier | DistributionPointName.php
fichier | DSAParams.php
fichier | DSAPrivateKey.php
fichier | DSAPublicKey.php
fichier | DssSigValue.php
fichier | EcdsaSigValue.php
fichier | ECParameters.php
fichier | ECPoint.php
fichier | ECPrivateKey.php
fichier | EDIPartyName.php
fichier | EncryptedData.php
fichier | EncryptedPrivateKeyInfo.php
fichier | vendor/phpseclib/phpseclib/phpseclib/File/ASN1/Maps/Extension.php
fichier | ExtensionAttribute.php
fichier | ExtensionAttributes.php
fichier | Extensions.php
fichier | ExtKeyUsageSyntax.php
fichier | FieldElement.php
fichier | FieldID.php
fichier | GeneralName.php
fichier | GeneralNames.php
fichier | GeneralSubtree.php
fichier | GeneralSubtrees.php
fichier | HashAlgorithm.php
fichier | HoldInstructionCode.php
fichier | InvalidityDate.php
fichier | IssuerAltName.php
fichier | IssuingDistributionPoint.php
fichier | KeyIdentifier.php
fichier | KeyPurposeId.php
fichier | KeyUsage.php
fichier | MaskGenAlgorithm.php
fichier | Name.php
fichier | NameConstraints.php
fichier | netscape_ca_policy_url.php
fichier | netscape_cert_type.php
fichier | netscape_comment.php
fichier | NetworkAddress.php
fichier | NoticeReference.php
fichier | NumericUserIdentifier.php
fichier | OneAsymmetricKey.php
fichier | ORAddress.php
fichier | OrganizationalUnitNames.php
fichier | OrganizationName.php
fichier | OtherPrimeInfo.php
fichier | OtherPrimeInfos.php
fichier | PBEParameter.php
fichier | PBES2params.php
fichier | PBKDF2params.php
fichier | PBMAC1params.php
fichier | Pentanomial.php
fichier | PersonalName.php
fichier | PKCS9String.php
fichier | PolicyInformation.php
fichier | PolicyMappings.php
fichier | PolicyQualifierId.php
fichier | PolicyQualifierInfo.php
fichier | PostalAddress.php
fichier | Prime_p.php
fichier | PrivateDomainName.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PrivateKey.php
fichier | PrivateKeyInfo.php
fichier | PrivateKeyUsagePeriod.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PublicKey.php
fichier | PublicKeyAndChallenge.php
fichier | PublicKeyInfo.php
fichier | RC2CBCParameter.php
fichier | RDNSequence.php
fichier | ReasonFlags.php
fichier | phpseclib/phpseclib/phpseclib/File/ASN1/Maps/RelativeDistinguishedName.php
fichier | RevokedCertificate.php
fichier | RSAPrivateKey.php
fichier | RSAPublicKey.php
fichier | RSASSA_PSS_params.php
fichier | SignedPublicKeyAndChallenge.php
fichier | SpecifiedECDomain.php
fichier | SubjectAltName.php
fichier | SubjectDirectoryAttributes.php
fichier | SubjectInfoAccessSyntax.php
fichier | SubjectPublicKeyInfo.php
fichier | TBSCertificate.php
fichier | TBSCertList.php
fichier | TerminalIdentifier.php
fichier | Time.php
fichier | Trinomial.php
fichier | UniqueIdentifier.php
fichier | UserNotice.php
fichier | Validity.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_banners/helpers/banners.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
  • services
Répertoire de référence de services

Fichiers

fichier plugins/api-authentication/token/services/provider.php


Joomla CMS: Répertoire de référence de mod_banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
Répertoire de référence de mod_banners

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_banners.php


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-none

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-none
Répertoire de référence de jwt-signature-algorithm-none

Fichiers

fichier web-token/jwt-signature-algorithm-none/None.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_contenthistory/src/Controller/DisplayController.php
fichier | administrator/components/com_contenthistory/src/Controller/HistoryController.php
fichier | PreviewController.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesCategoryHelper.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | ExecRuleHelper.php
fichier | SchedulerHelper.php


Joomla CMS: Répertoire de référence de Serializer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Serializer
Répertoire de référence de Serializer

Répertoires

répertoire Events

Fichiers

fichier JoomlaSerializer.php


Joomla CMS: Répertoire de référence de com_content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
Répertoire de référence de com_content

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Encrypt

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Répertoire de référence de Encrypt

Répertoires

répertoire AES

Fichiers

fichier | Aes.php
fichier | src/Encrypt/Base32.php
fichier | Randval.php
fichier | RandValInterface.php
fichier | libraries/src/Encrypt/Totp.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Event
Répertoire de référence de Event

Répertoires

répertoire Model


Joomla CMS: Répertoire de référence de web-auth

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
Répertoire de référence de web-auth

Répertoires

répertoire | cose-lib
répertoire | metadata-service
répertoire | webauthn-lib


Joomla CMS: Répertoire de référence de languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • languages
Répertoire de référence de languages

Fichiers

fichier languages.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier SyndicateHelper.php


Joomla CMS: Répertoire de référence de Serializer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Serializer
Répertoire de référence de Serializer

Fichiers

fichier ContentSerializer.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_config/src/Controller/ApplicationController.php
fichier | api/components/com_config/src/Controller/ComponentController.php


Joomla CMS: Répertoire de référence de mod_tags_popular

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
Répertoire de référence de mod_tags_popular

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_tags_popular.php


Joomla CMS: Répertoire de référence de menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • menu
Répertoire de référence de menu

Fichiers

fichier menu.php


Joomla CMS: Répertoire de référence de multilang

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • sampledata
  • multilang
Répertoire de référence de multilang

Fichiers

fichier multilang.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier administrator/components/com_cache/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de Html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Service
  • Html
Répertoire de référence de Html

Fichiers

fichier Banner.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_sampledata/tmpl/default.php


Joomla CMS: Répertoire de référence de crypt

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
Répertoire de référence de crypt

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier FontsField.php


Joomla CMS: Répertoire de référence de com_mails

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
Répertoire de référence de com_mails

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de styles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • styles
Répertoire de référence de styles

Fichiers

fichier administrator/components/com_templates/tmpl/styles/default.php


Joomla CMS: Répertoire de référence de remove

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • remove
Répertoire de référence de remove

Fichiers

fichier installation/tmpl/remove/default.php


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier MediaActionPlugin.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • urlinstaller
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/installer/urlinstaller/tmpl/default.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PluginsHelper.php


Joomla CMS: Répertoire de référence de Renderer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Error
  • Renderer
Répertoire de référence de Renderer

Fichiers

fichier installation/src/Error/Renderer/JsonRenderer.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de item

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • item
Répertoire de référence de item

Fichiers

fichier | administrator/components/com_menus/tmpl/item/edit.php
fichier | edit_container.php
fichier | tmpl/item/edit_modules.php
fichier | administrator/components/com_menus/tmpl/item/modal.php


Joomla CMS: Répertoire de référence de lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
Répertoire de référence de lib

Répertoires

répertoire Doctrine


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire form


Joomla CMS: Répertoire de référence de stage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • stage
Répertoire de référence de stage

Fichiers

fichier administrator/components/com_workflow/tmpl/stage/edit.php


Joomla CMS: Répertoire de référence de com_config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
Répertoire de référence de com_config

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de negotiation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
Répertoire de référence de negotiation

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Registration

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Registration
Répertoire de référence de Registration

Fichiers

fichier components/com_users/src/View/Registration/HtmlView.php


Joomla CMS: Répertoire de référence de libraries

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
Répertoire de référence de libraries

Répertoires

répertoire | php-encryption
répertoire | phpass
répertoire | src
répertoire | vendor

Fichiers

fichier | bootstrap.php
fichier | classmap.php
fichier | cms.php
fichier | extensions.classmap.php
fichier | import.legacy.php
fichier | import.php
fichier | loader.php
fichier | libraries/namespacemap.php


Joomla CMS: Répertoire de référence de sessiongc

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • sessiongc
Répertoire de référence de sessiongc

Fichiers

fichier sessiongc.php


Joomla CMS: Répertoire de référence de edit

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Répertoire de référence de edit

Fichiers

fichier | admin_modules.php
fichier | edit/associations.php
fichier | fieldset.php
fichier | frontediting_modules.php
fichier | global.php
fichier | metadata.php
fichier | params.php
fichier | publishingdata.php
fichier | title_alias.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • calendar
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/calendar/tmpl/calendar.php


Joomla CMS: Répertoire de référence de Download

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Download
Répertoire de référence de Download

Fichiers

fichier administrator/components/com_banners/src/View/Download/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier administrator/components/com_installer/src/Helper/InstallerHelper.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • layouts
  • joomla
  • form
  • field
Répertoire de référence de field

Fichiers

fichier categoryedit.php


Joomla CMS: Répertoire de référence de atum

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
Répertoire de référence de atum

Répertoires

répertoire html

Fichiers

fichier | administrator/templates/atum/component.php
fichier | cpanel.php
fichier | administrator/templates/atum/error.php
fichier | error_full.php
fichier | error_login.php
fichier | administrator/templates/atum/index.php
fichier | login.php


Joomla CMS: Répertoire de référence de jooa11y

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • jooa11y
Répertoire de référence de jooa11y

Fichiers

fichier jooa11y.php


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • form
Répertoire de référence de form

Fichiers

fichier components/com_contact/tmpl/form/edit.php


Joomla CMS: Répertoire de référence de mbstring

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • mbstring
Répertoire de référence de mbstring

Fichiers

fichier mbstring/core.php


Joomla CMS: Répertoire de référence de Output

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
Répertoire de référence de Output

Répertoires

répertoire Processor

Fichiers

fichier | Stdout.php
fichier | src/Application/CLI/Output/Xml.php


Joomla CMS: Répertoire de référence de Utility

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • Utility
Répertoire de référence de Utility

Fichiers

fichier | fgrosse/phpasn1/lib/Utility/BigInteger.php
fichier | BigIntegerBcmath.php
fichier | BigIntegerGmp.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Groups
répertoire | Levels
répertoire | Users


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier | components/com_contact/src/Service/Category.php
fichier | components/com_contact/src/Service/Router.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_installer/services/provider.php


Joomla CMS: Répertoire de référence de webauthn

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
Répertoire de référence de webauthn

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Links

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • View
  • Links
Répertoire de référence de Links

Fichiers

fichier administrator/components/com_redirect/src/View/Links/HtmlView.php


Joomla CMS: Répertoire de référence de actionlog

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
Répertoire de référence de actionlog

Répertoires

répertoire joomla


Joomla CMS: Répertoire de référence de overrides

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • overrides
Répertoire de référence de overrides

Fichiers

fichier administrator/components/com_languages/tmpl/overrides/default.php


Joomla CMS: Répertoire de référence de components

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
Répertoire de référence de components

Répertoires

répertoire | com_banners
répertoire | com_categories
répertoire | com_config
répertoire | com_contact
répertoire | com_content
répertoire | com_contenthistory
répertoire | com_fields
répertoire | com_installer
répertoire | com_languages
répertoire | com_media
répertoire | com_menus
répertoire | com_messages
répertoire | com_modules
répertoire | com_newsfeeds
répertoire | com_plugins
répertoire | com_privacy
répertoire | com_redirect
répertoire | com_tags
répertoire | com_templates
répertoire | com_users


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de installation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
Répertoire de référence de installation

Répertoires

répertoire | includes
répertoire | src
répertoire | template
répertoire | tmpl

Fichiers

fichier installation/index.php


Joomla CMS: Répertoire de référence de utils

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Répertoire de référence de utils

Fichiers

fichier | ascii.php
fichier | bad.php
fichier | patterns.php
fichier | position.php
fichier | specials.php
fichier | unicode.php
fichier | validation.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier ContactComponent.php


Joomla CMS: Répertoire de référence de mod_articles_news

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
Répertoire de référence de mod_articles_news

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | categories
répertoire | category
répertoire | contact
répertoire | featured
répertoire | form


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Database
répertoire | Discover
répertoire | Install
répertoire | Installer
répertoire | Languages
répertoire | Manage
répertoire | Update
répertoire | Updatesite
répertoire | Updatesites
répertoire | Warnings


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Checkfiles.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier plugins/multifactorauth/email/src/Extension/Email.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • services
Répertoire de référence de services

Fichiers

fichier modules/mod_articles_news/services/provider.php


Joomla CMS: Répertoire de référence de Manage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
  • View
  • Manage
Répertoire de référence de Manage

Fichiers

fichier com_installer/src/View/Manage/JsonapiView.php


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier | FieldsListPlugin.php
fichier | FieldsPlugin.php


Joomla CMS: Répertoire de référence de imagelist

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • imagelist
Répertoire de référence de imagelist

Répertoires

répertoire tmpl

Fichiers

fichier imagelist.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier TagsComponent.php


Joomla CMS: Répertoire de référence de Phar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Répertoire de référence de Phar

Fichiers

fichier | typo3/phar-stream-wrapper/src/Phar/Container.php
fichier | typo3/phar-stream-wrapper/src/Phar/DeserializationException.php
fichier | vendor/typo3/phar-stream-wrapper/src/Phar/Manifest.php
fichier | Reader.php
fichier | ReaderException.php
fichier | typo3/phar-stream-wrapper/src/Phar/Stub.php


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier administrator/components/com_menus/src/Field/Modal/MenuField.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Répertoire de référence de src

Répertoires

répertoire Exception

Fichiers

fichier | tobscure/json-api/src/AbstractSerializer.php
fichier | tobscure/json-api/src/Collection.php
fichier | vendor/tobscure/json-api/src/Document.php
fichier | ElementInterface.php
fichier | tobscure/json-api/src/ErrorHandler.php
fichier | LinksTrait.php
fichier | MetaTrait.php
fichier | tobscure/json-api/src/Parameters.php
fichier | Relationship.php
fichier | Resource.php
fichier | SerializerInterface.php
fichier | tobscure/json-api/src/Util.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | installed
répertoire | language
répertoire | languages
répertoire | multilangstatus
répertoire | override
répertoire | overrides


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
Répertoire de référence de Exception

Répertoires

répertoire Handler

Fichiers

fichier InvalidParameterException.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_media/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de data

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Répertoire de référence de data

Fichiers

fichier | ascii_by_languages.php
fichier | ascii_extras_by_languages.php
fichier | ascii_language_max_key.php
fichier | ascii_ord.php
fichier | x000.php
fichier | x001.php
fichier | x002.php
fichier | x003.php
fichier | x004.php
fichier | x005.php
fichier | x006.php
fichier | x007.php
fichier | x009.php
fichier | x00a.php
fichier | x00b.php
fichier | x00c.php
fichier | x00d.php
fichier | x00e.php
fichier | x00f.php
fichier | x010.php
fichier | x011.php
fichier | x012.php
fichier | x013.php
fichier | x014.php
fichier | x015.php
fichier | x016.php
fichier | x017.php
fichier | x018.php
fichier | x01d.php
fichier | x01e.php
fichier | x01f.php
fichier | x020.php
fichier | x021.php
fichier | x022.php
fichier | x023.php
fichier | x024.php
fichier | x025.php
fichier | x026.php
fichier | x027.php
fichier | x028.php
fichier | x029.php
fichier | x02a.php
fichier | x02c.php
fichier | x02e.php
fichier | x02f.php
fichier | x030.php
fichier | x031.php
fichier | x032.php
fichier | x033.php
fichier | x04d.php
fichier | x04e.php
fichier | x04f.php
fichier | x050.php
fichier | x051.php
fichier | x052.php
fichier | x053.php
fichier | x054.php
fichier | x055.php
fichier | x056.php
fichier | x057.php
fichier | x058.php
fichier | x059.php
fichier | x05a.php
fichier | x05b.php
fichier | x05c.php
fichier | x05d.php
fichier | x05e.php
fichier | x05f.php
fichier | x060.php
fichier | x061.php
fichier | x062.php
fichier | x063.php
fichier | x064.php
fichier | x065.php
fichier | x066.php
fichier | x067.php
fichier | x068.php
fichier | x069.php
fichier | x06a.php
fichier | x06b.php
fichier | x06c.php
fichier | x06d.php
fichier | x06e.php
fichier | x06f.php
fichier | x070.php
fichier | x071.php
fichier | x072.php
fichier | x073.php
fichier | x074.php
fichier | x075.php
fichier | x076.php
fichier | x077.php
fichier | x078.php
fichier | x079.php
fichier | x07a.php
fichier | x07b.php
fichier | x07c.php
fichier | x07d.php
fichier | x07e.php
fichier | x07f.php
fichier | x080.php
fichier | x081.php
fichier | x082.php
fichier | x083.php
fichier | x084.php
fichier | x085.php
fichier | x086.php
fichier | x087.php
fichier | x088.php
fichier | x089.php
fichier | x08a.php
fichier | x08b.php
fichier | x08c.php
fichier | x08d.php
fichier | x08e.php
fichier | x08f.php
fichier | x090.php
fichier | x091.php
fichier | x092.php
fichier | x093.php
fichier | x094.php
fichier | x095.php
fichier | x096.php
fichier | x097.php
fichier | x098.php
fichier | x099.php
fichier | x09a.php
fichier | x09b.php
fichier | x09c.php
fichier | x09d.php
fichier | x09e.php
fichier | x09f.php
fichier | x0a0.php
fichier | x0a1.php
fichier | x0a2.php
fichier | x0a3.php
fichier | x0a4.php
fichier | x0ac.php
fichier | x0ad.php
fichier | x0ae.php
fichier | x0af.php
fichier | x0b0.php
fichier | x0b1.php
fichier | x0b2.php
fichier | x0b3.php
fichier | x0b4.php
fichier | x0b5.php
fichier | x0b6.php
fichier | x0b7.php
fichier | x0b8.php
fichier | x0b9.php
fichier | x0ba.php
fichier | x0bb.php
fichier | x0bc.php
fichier | x0bd.php
fichier | x0be.php
fichier | x0bf.php
fichier | x0c0.php
fichier | x0c1.php
fichier | x0c2.php
fichier | x0c3.php
fichier | x0c4.php
fichier | x0c5.php
fichier | x0c6.php
fichier | x0c7.php
fichier | x0c8.php
fichier | x0c9.php
fichier | x0ca.php
fichier | x0cb.php
fichier | x0cc.php
fichier | x0cd.php
fichier | x0ce.php
fichier | x0cf.php
fichier | x0d0.php
fichier | x0d1.php
fichier | x0d2.php
fichier | x0d3.php
fichier | x0d4.php
fichier | x0d5.php
fichier | x0d6.php
fichier | x0d7.php
fichier | x0f9.php
fichier | x0fa.php
fichier | x0fb.php
fichier | x0fc.php
fichier | x0fd.php
fichier | x0fe.php
fichier | x0ff.php
fichier | x1d4.php
fichier | x1d5.php
fichier | x1d6.php
fichier | x1d7.php
fichier | x1f1.php


Joomla CMS: Répertoire de référence de link-util

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
Répertoire de référence de link-util

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_breadcrumbs/tmpl/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • utilities
  • src
Répertoire de référence de src

Fichiers

fichier | ArrayHelper.php
fichier | IpHelper.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_contact/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de postinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • postinstall
Répertoire de référence de postinstall

Fichiers

fichier multifactorauth.php


Joomla CMS: Répertoire de référence de com_plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
Répertoire de référence de com_plugins

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_categories/services/provider.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | MethodNotAllowedException.php
fichier | vendor/joomla/router/src/Exception/RouteNotFoundException.php


Joomla CMS: Répertoire de référence de Keys

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Répertoire de référence de Keys

Fichiers

fichier | Common/Formats/Keys/OpenSSH.php
fichier | PKCS.php
fichier | Common/Formats/Keys/PKCS1.php
fichier | Common/Formats/Keys/PKCS8.php
fichier | Common/Formats/Keys/PuTTY.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_privacy/src/Controller/ConsentsController.php
fichier | administrator/components/com_privacy/src/Controller/DisplayController.php
fichier | administrator/components/com_privacy/src/Controller/RequestController.php
fichier | administrator/components/com_privacy/src/Controller/RequestsController.php


Joomla CMS: Répertoire de référence de Remind

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • View
  • Remind
Répertoire de référence de Remind

Fichiers

fichier components/com_privacy/src/View/Remind/HtmlView.php


Joomla CMS: Répertoire de référence de com_modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
Répertoire de référence de com_modules

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PostinstallHelper.php


Joomla CMS: Répertoire de référence de Module

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Module
Répertoire de référence de Module

Fichiers

fichier administrator/components/com_modules/src/View/Module/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • src
Répertoire de référence de src

Répertoires

répertoire | Dispatcher
répertoire | Helper


Joomla CMS: Répertoire de référence de user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
Répertoire de référence de user

Répertoires

répertoire | contactcreator
répertoire | joomla
répertoire | profile
répertoire | terms
répertoire | token


Joomla CMS: Répertoire de référence de url

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • url
Répertoire de référence de url

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/url/url.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | NotImplementedException.php
fichier | ParserException.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_redirect/src/Controller/DisplayController.php
fichier | LinkController.php
fichier | LinksController.php


Joomla CMS: Répertoire de référence de Config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Config
Répertoire de référence de Config

Fichiers

fichier components/com_config/src/View/Config/HtmlView.php


Joomla CMS: Répertoire de référence de level

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • level
Répertoire de référence de level

Fichiers

fichier administrator/components/com_users/tmpl/level/edit.php


Joomla CMS: Répertoire de référence de integer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • integer
Répertoire de référence de integer

Répertoires

répertoire tmpl

Fichiers

fichier integer.php


Joomla CMS: Répertoire de référence de DataFormatter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
Répertoire de référence de DataFormatter

Répertoires

répertoire VarDumper

Fichiers

fichier | libraries/vendor/maximebf/debugbar/src/DebugBar/DataFormatter/DataFormatter.php
fichier | DataFormatterInterface.php
fichier | DebugBarVarDumper.php


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier PrivacyPlugin.php


Joomla CMS: Répertoire de référence de items

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • items
Répertoire de référence de items

Fichiers

fichier | administrator/components/com_menus/tmpl/items/default.php
fichier | com_menus/tmpl/items/default_batch_body.php
fichier | com_menus/tmpl/items/default_batch_footer.php
fichier | administrator/components/com_menus/tmpl/items/modal.php


Joomla CMS: Répertoire de référence de phpmailer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
Répertoire de référence de phpmailer

Répertoires

répertoire phpmailer


Joomla CMS: Répertoire de référence de Tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • View
  • Tag
Répertoire de référence de Tag

Fichiers

fichier administrator/components/com_tags/src/View/Tag/HtmlView.php


Joomla CMS: Répertoire de référence de Config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Config
Répertoire de référence de Config

Fichiers

fichier administrator/components/com_messages/src/View/Config/HtmlView.php


Joomla CMS: Répertoire de référence de actionlogs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • actionlogs
Répertoire de référence de actionlogs

Fichiers

fichier privacy/actionlogs/actionlogs.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier | application/src/Event/ApplicationErrorEvent.php
fichier | ApplicationEvent.php


Joomla CMS: Répertoire de référence de Node

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Node
Répertoire de référence de Node

Fichiers

fichier | FallbackNodeProvider.php
fichier | RandomNodeProvider.php
fichier | SystemNodeProvider.php


Joomla CMS: Répertoire de référence de Style

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Style
Répertoire de référence de Style

Fichiers

fichier | administrator/components/com_templates/src/View/Style/HtmlView.php
fichier | administrator/components/com_templates/src/View/Style/JsonView.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Exception
Répertoire de référence de Exception

Fichiers

fichier UnparsableImageException.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
  • assert
  • src
Répertoire de référence de src

Fichiers

fichier | webmozart/assert/src/Assert.php
fichier | webmozart/assert/src/InvalidArgumentException.php
fichier | Mixin.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • templates
Répertoire de référence de templates

Fichiers

fichier | components/com_config/tmpl/templates/default.php
fichier | templates/default_options.php


Joomla CMS: Répertoire de référence de Groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Groups
Répertoire de référence de Groups

Fichiers

fichier com_users/src/View/Groups/JsonapiView.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire | menu
répertoire | searchtools


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
Répertoire de référence de src

Répertoires

répertoire | Cipher
répertoire | Exception

Fichiers

fichier | CipherInterface.php
fichier | vendor/joomla/crypt/src/Crypt.php
fichier | joomla/crypt/src/Key.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | item
répertoire | items
répertoire | menu
répertoire | menus
répertoire | menutypes


Joomla CMS: Répertoire de référence de Psr

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
  • Psr
Répertoire de référence de Psr

Répertoires

répertoire Log


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_wrapper/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_finder/services/provider.php


Joomla CMS: Répertoire de référence de AttestationStatement

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Répertoire de référence de AttestationStatement

Fichiers

fichier | libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/AndroidKeyAttestationStatementSupport.php
fichier | AndroidSafetyNetAttestationStatementSupport.php
fichier | AttestationObject.php
fichier | AttestationObjectLoader.php
fichier | AttestationStatement.php
fichier | AttestationStatementSupport.php
fichier | AttestationStatementSupportManager.php
fichier | libraries/vendor/web-auth/webauthn-lib/src/AttestationStatement/FidoU2FAttestationStatementSupport.php
fichier | NoneAttestationStatementSupport.php
fichier | PackedAttestationStatementSupport.php
fichier | TPMAttestationStatementSupport.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Actionlogs


Joomla CMS: Répertoire de référence de com_media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_media
Répertoire de référence de com_media

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Bridge

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Répertoire de référence de Bridge

Répertoires

répertoire | SwiftMailer
répertoire | Twig

Fichiers

fichier | CacheCacheCollector.php
fichier | DoctrineCollector.php
fichier | MonologCollector.php
fichier | NamespacedTwigProfileCollector.php
fichier | Propel2Collector.php
fichier | PropelCollector.php
fichier | SlimCollector.php
fichier | TwigProfileCollector.php


Joomla CMS: Répertoire de référence de methods

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • methods
Répertoire de référence de methods

Fichiers

fichier | administrator/components/com_users/tmpl/methods/default.php
fichier | administrator/components/com_users/tmpl/methods/firsttime.php
fichier | administrator/components/com_users/tmpl/methods/list.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier administrator/modules/mod_login/src/Helper/LoginHelper.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_media/helpers/media.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Common

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Répertoire de référence de Common

Répertoires

répertoire | Formats
répertoire | Traits

Fichiers

fichier | AsymmetricKey.php
fichier | BlockCipher.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/Common/PrivateKey.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/Common/PublicKey.php
fichier | StreamCipher.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/Common/SymmetricKey.php


Joomla CMS: Répertoire de référence de editor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • editor
Répertoire de référence de editor

Répertoires

répertoire tmpl

Fichiers

fichier editor.php


Joomla CMS: Répertoire de référence de Events

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Serializer
  • Events
Répertoire de référence de Events

Fichiers

fichier | OnGetApiAttributes.php
fichier | OnGetApiRelation.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_admin/services/provider.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier LatestHelper.php


Joomla CMS: Répertoire de référence de service-contracts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Répertoire de référence de service-contracts

Répertoires

répertoire | Attribute
répertoire | Test

Fichiers

fichier | ResetInterface.php
fichier | ServiceLocatorTrait.php
fichier | symfony/service-contracts/ServiceProviderInterface.php
fichier | ServiceSubscriberInterface.php
fichier | ServiceSubscriberTrait.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier | com_contact/src/Service/HTML/AdministratorService.php
fichier | com_contact/src/Service/HTML/Icon.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • profile
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de local

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
  • local
Répertoire de référence de local

Répertoires

répertoire src

Fichiers

fichier local.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Config
répertoire | Message
répertoire | Messages


Joomla CMS: Répertoire de référence de mod_syndicate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
Répertoire de référence de mod_syndicate

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_syndicate.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | StageHelper.php
fichier | WorkflowHelper.php


Joomla CMS: Répertoire de référence de Article

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Article
Répertoire de référence de Article

Fichiers

fichier components/com_content/src/View/Article/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_templates/src/Controller/DisplayController.php
fichier | StyleController.php
fichier | administrator/components/com_templates/src/Controller/StylesController.php
fichier | com_templates/src/Controller/TemplateController.php


Joomla CMS: Répertoire de référence de console

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Répertoire de référence de console

Répertoires

répertoire | Attribute
répertoire | CI
répertoire | Command
répertoire | CommandLoader
répertoire | Completion
répertoire | DependencyInjection
répertoire | Descriptor
répertoire | Event
répertoire | EventListener
répertoire | Exception
répertoire | Formatter
répertoire | Helper
répertoire | Input
répertoire | Logger
répertoire | Output
répertoire | Question
répertoire | SignalRegistry
répertoire | Style
répertoire | Tester

Fichiers

fichier | libraries/vendor/symfony/console/Application.php
fichier | Color.php
fichier | symfony/console/ConsoleEvents.php
fichier | console/Cursor.php
fichier | SingleCommandApplication.php
fichier | Terminal.php


Joomla CMS: Répertoire de référence de Application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • View
  • Application
Répertoire de référence de Application

Fichiers

fichier administrator/components/com_config/src/View/Application/HtmlView.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier multifactorauth/webauthn/src/Extension/Webauthn.php


Joomla CMS: Répertoire de référence de Formats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
Répertoire de référence de Formats

Répertoires

répertoire | Keys
répertoire | Signature


Joomla CMS: Répertoire de référence de com_tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
Répertoire de référence de com_tags

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier administrator/components/com_login/src/Model/LoginModel.php


Joomla CMS: Répertoire de référence de Number

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Number
Répertoire de référence de Number

Fichiers

fichier | BigNumberConverter.php
fichier | DegradedNumberConverter.php


Joomla CMS: Répertoire de référence de Internal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Internal
Répertoire de référence de Internal

Fichiers

fichier TentativeTypes.php


Joomla CMS: Répertoire de référence de Response

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Répertoire de référence de Response

Fichiers

fichier | Response/ArraySerializer.php
fichier | EmptyResponse.php
fichier | HtmlResponse.php
fichier | InjectContentTypeTrait.php
fichier | libraries/vendor/laminas/laminas-diactoros/src/Response/JsonResponse.php
fichier | RedirectResponse.php
fichier | laminas/laminas-diactoros/src/Response/Serializer.php
fichier | TextResponse.php
fichier | XmlResponse.php


Joomla CMS: Répertoire de référence de html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
Répertoire de référence de html

Répertoires

répertoire bootstrap


Joomla CMS: Répertoire de référence de plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
Répertoire de référence de plugins

Répertoires

répertoire | actionlog
répertoire | api-authentication
répertoire | authentication
répertoire | behaviour
répertoire | captcha
répertoire | content
répertoire | editors
répertoire | editors-xtd
répertoire | extension
répertoire | fields
répertoire | filesystem
répertoire | finder
répertoire | installer
répertoire | media-action
répertoire | multifactorauth
répertoire | privacy
répertoire | quickicon
répertoire | sampledata
répertoire | system
répertoire | task
répertoire | user
répertoire | webservices
répertoire | workflow


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | AlreadyPunycodeException.php
fichier | InvalidCharacterException.php
fichier | InvalidIdnVersionException.php


Joomla CMS: Répertoire de référence de Indexer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Indexer
Répertoire de référence de Indexer

Fichiers

fichier administrator/components/com_finder/src/View/Indexer/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_config/src/Controller/ApplicationController.php
fichier | administrator/components/com_config/src/Controller/ComponentController.php
fichier | administrator/components/com_config/src/Controller/DisplayController.php
fichier | administrator/components/com_config/src/Controller/RequestController.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Wrapper


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | BaseInstallationModel.php
fichier | ChecksModel.php
fichier | CleanupModel.php
fichier | ConfigurationModel.php
fichier | installation/src/Model/DatabaseModel.php
fichier | installation/src/Model/LanguagesModel.php
fichier | SetupModel.php


Joomla CMS: Répertoire de référence de Keys

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Répertoire de référence de Keys

Fichiers

fichier | MSBLOB.php
fichier | RSA/Formats/Keys/OpenSSH.php
fichier | RSA/Formats/Keys/PKCS1.php
fichier | RSA/Formats/Keys/PKCS8.php
fichier | PSS.php
fichier | RSA/Formats/Keys/PuTTY.php
fichier | RSA/Formats/Keys/Raw.php
fichier | RSA/Formats/Keys/XML.php


Joomla CMS: Répertoire de référence de GMP

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • GMP
Répertoire de référence de GMP

Fichiers

fichier GMP/DefaultEngine.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Items
répertoire | Menus


Joomla CMS: Répertoire de référence de Opensearch

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Opensearch
Répertoire de référence de Opensearch

Fichiers

fichier | OpensearchImage.php
fichier | OpensearchUrl.php


Joomla CMS: Répertoire de référence de com_wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
Répertoire de référence de com_wrapper

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de compat

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • compat
Répertoire de référence de compat

Fichiers

fichier | class-aliases.php
fichier | json-exception-polyfill.php
fichier | lcobucci-clock-polyfill.php


Joomla CMS: Répertoire de référence de ldap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • ldap
Répertoire de référence de ldap

Fichiers

fichier ldap.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier FieldsHelper.php


Joomla CMS: Répertoire de référence de Utility

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Utility
Répertoire de référence de Utility

Fichiers

fichier | BufferStreamHandler.php
fichier | Utility.php


Joomla CMS: Répertoire de référence de installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
Répertoire de référence de installer

Répertoires

répertoire | folderinstaller
répertoire | override
répertoire | packageinstaller
répertoire | urlinstaller
répertoire | webinstaller


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Checkin


Joomla CMS: Répertoire de référence de Component

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
Répertoire de référence de Component

Répertoires

répertoire | Exception
répertoire | Router

Fichiers

fichier | ComponentHelper.php
fichier | ComponentRecord.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | administrator/modules/mod_menu/tmpl/default.php
fichier | default_submenu.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • media
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/media/tmpl/media.php


Joomla CMS: Répertoire de référence de unidata

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
  • Resources
  • unidata
Répertoire de référence de unidata

Fichiers

fichier | lowerCase.php
fichier | titleCaseRegexp.php
fichier | upperCase.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Contacts


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ExtensionField.php
fichier | LogcreatorField.php
fichier | LogsdaterangeField.php
fichier | LogtypeField.php
fichier | PlugininfoField.php


Joomla CMS: Répertoire de référence de unidata

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • unidata
Répertoire de référence de unidata

Fichiers

fichier | canonicalComposition.php
fichier | canonicalDecomposition.php
fichier | combiningClass.php
fichier | compatibilityDecomposition.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_categories/helpers/categories.php


Joomla CMS: Répertoire de référence de cose-lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
Répertoire de référence de cose-lib

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_submenu/tmpl/default.php


Joomla CMS: Répertoire de référence de Featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Featured
Répertoire de référence de Featured

Fichiers

fichier | com_content/src/View/Featured/FeedView.php
fichier | components/com_content/src/View/Featured/HtmlView.php


Joomla CMS: Répertoire de référence de categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • categories
Répertoire de référence de categories

Fichiers

fichier | components/com_newsfeeds/tmpl/categories/default.php
fichier | components/com_newsfeeds/tmpl/categories/default_items.php


Joomla CMS: Répertoire de référence de polyfill-iconv

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
Répertoire de référence de polyfill-iconv

Répertoires

répertoire Resources

Fichiers

fichier | vendor/symfony/polyfill-iconv/bootstrap.php
fichier | polyfill-iconv/bootstrap80.php
fichier | Iconv.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
  • services
Répertoire de référence de services

Fichiers

fichier plugins/multifactorauth/totp/services/provider.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
Répertoire de référence de Command

Répertoires

répertoire Descriptor

Fichiers

fichier ServerDumpCommand.php


Joomla CMS: Répertoire de référence de filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • filter
Répertoire de référence de filter

Fichiers

fichier administrator/components/com_finder/tmpl/filter/edit.php


Joomla CMS: Répertoire de référence de pagebreak

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagebreak
Répertoire de référence de pagebreak

Répertoires

répertoire tmpl

Fichiers

fichier plugins/content/pagebreak/pagebreak.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier InstallerComponent.php


Joomla CMS: Répertoire de référence de metadata-service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
Répertoire de référence de metadata-service

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_finder/src/Controller/DisplayController.php
fichier | SuggestionsController.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier QuickIconHelper.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Répertoire de référence de Event

Répertoires

répertoire | Model
répertoire | MultiFactor
répertoire | Plugin
répertoire | QuickIcon
répertoire | Result
répertoire | Table
répertoire | View
répertoire | WebAsset
répertoire | Workflow

Fichiers

fichier | src/Event/AbstractEvent.php
fichier | AbstractImmutableEvent.php
fichier | AfterExtensionBootEvent.php
fichier | BeforeExtensionBootEvent.php
fichier | CoreEventAware.php
fichier | ErrorEvent.php
fichier | GenericEvent.php
fichier | ReshapeArgumentsAware.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_messages/src/Model/ConfigModel.php
fichier | MessageModel.php
fichier | com_messages/src/Model/MessagesModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Parser

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
Répertoire de référence de Parser

Répertoires

répertoire Rss

Fichiers

fichier | AtomParser.php
fichier | NamespaceParserInterface.php
fichier | RssParser.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_tags/src/Controller/TagsController.php


Joomla CMS: Répertoire de référence de Sqlite

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlite
Répertoire de référence de Sqlite

Fichiers

fichier | SqliteDriver.php
fichier | SqliteQuery.php


Joomla CMS: Répertoire de référence de loadmodule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • loadmodule
Répertoire de référence de loadmodule

Fichiers

fichier loadmodule.php


Joomla CMS: Répertoire de référence de webauthn

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
Répertoire de référence de webauthn

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • content
Répertoire de référence de content

Fichiers

fichier plugins/privacy/content/content.php


Joomla CMS: Répertoire de référence de emailcloak

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • emailcloak
Répertoire de référence de emailcloak

Fichiers

fichier emailcloak.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • sql
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/sql.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_postinstall/src/Controller/DisplayController.php
fichier | com_postinstall/src/Controller/MessageController.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_messages/services/provider.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | RequeststatusField.php
fichier | RequesttypeField.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • subform
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/subform.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_users/src/Controller/CallbackController.php
fichier | components/com_users/src/Controller/CaptiveController.php
fichier | components/com_users/src/Controller/DisplayController.php
fichier | components/com_users/src/Controller/MethodController.php
fichier | components/com_users/src/Controller/MethodsController.php
fichier | ProfileController.php
fichier | RegistrationController.php
fichier | RemindController.php
fichier | ResetController.php
fichier | components/com_users/src/Controller/UserController.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • helpers
Répertoire de référence de helpers

Fichiers

fichier | administrator/components/com_users/helpers/debug.php
fichier | administrator/components/com_users/helpers/users.php


Joomla CMS: Répertoire de référence de Router

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Répertoire de référence de Router

Répertoires

répertoire Exception

Fichiers

fichier | AdministratorRouter.php
fichier | ApiRouter.php
fichier | src/Router/Route.php
fichier | libraries/src/Router/Router.php
fichier | SiteRouter.php
fichier | SiteRouterAwareInterface.php
fichier | SiteRouterAwareTrait.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • layouts
  • field
Répertoire de référence de field

Fichiers

fichier com_fields/layouts/field/render.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire form


Joomla CMS: Répertoire de référence de php-encryption

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
Répertoire de référence de php-encryption

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Storage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • Storage
Répertoire de référence de Storage

Fichiers

fichier plugins/system/debug/src/Storage/FileStorage.php


Joomla CMS: Répertoire de référence de Rsa

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Rsa
Répertoire de référence de Rsa

Fichiers

fichier | Rsa/Sha256.php
fichier | Rsa/Sha384.php
fichier | Rsa/Sha512.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de laminas-zendframework-bridge

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
Répertoire de référence de laminas-zendframework-bridge

Répertoires

répertoire | config
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • base64url
  • src
Répertoire de référence de src

Fichiers

fichier Base64Url.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal

Fichiers

fichier | MenuItemByTypeField.php
fichier | MenuOrderingField.php
fichier | MenuParentField.php
fichier | MenuPresetField.php
fichier | MenutypeField.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher


Joomla CMS: Répertoire de référence de message-factory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
Répertoire de référence de message-factory

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Router

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Router
Répertoire de référence de Router

Fichiers

fichier InstallationRouter.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
Répertoire de référence de src

Répertoires

répertoire | DataCollector
répertoire | Storage

Fichiers

fichier | AbstractDataCollector.php
fichier | plugins/system/debug/src/DataFormatter.php
fichier | plugins/system/debug/src/JavascriptRenderer.php
fichier | JoomlaHttpDriver.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de update

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • update
Répertoire de référence de update

Fichiers

fichier | administrator/components/com_joomlaupdate/tmpl/update/default.php
fichier | finaliseconfirm.php


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Répertoire de référence de Adapter

Fichiers

fichier | ComponentAdapter.php
fichier | FileAdapter.php
fichier | LanguageAdapter.php
fichier | LibraryAdapter.php
fichier | ModuleAdapter.php
fichier | PackageAdapter.php
fichier | PluginAdapter.php
fichier | TemplateAdapter.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | GroupparentField.php
fichier | LevelsField.php
fichier | com_users/src/Field/ModulesPositionField.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Répertoire de référence de src

Fichiers

fichier | laminas/laminas-zendframework-bridge/src/autoload.php
fichier | Autoloader.php
fichier | ConfigPostProcessor.php
fichier | vendor/laminas/laminas-zendframework-bridge/src/Module.php
fichier | Replacements.php
fichier | RewriteRules.php


Joomla CMS: Répertoire de référence de com_fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
Répertoire de référence de com_fields

Répertoires

répertoire | layouts
répertoire | src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • list
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/list/tmpl/list.php


Joomla CMS: Répertoire de référence de extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
Répertoire de référence de extension

Répertoires

répertoire | finder
répertoire | joomla
répertoire | namespacemap


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | captive
répertoire | login
répertoire | method
répertoire | methods
répertoire | profile
répertoire | registration
répertoire | remind
répertoire | reset


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | MenuTable.php
fichier | MenuTypeTable.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Extension
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de com_users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
Répertoire de référence de com_users

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire charset


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
Répertoire de référence de src

Répertoires

répertoire | Access
répertoire | Adapter
répertoire | Application
répertoire | Association
répertoire | Authentication
répertoire | Autoload
répertoire | Button
répertoire | Cache
répertoire | Captcha
répertoire | Categories
répertoire | Changelog
répertoire | Client
répertoire | Component
répertoire | Console
répertoire | Crypt
répertoire | Date
répertoire | Dispatcher
répertoire | Document
répertoire | Editor
répertoire | Encrypt
répertoire | Environment
répertoire | Error
répertoire | Event
répertoire | Exception
répertoire | Extension
répertoire | Feed
répertoire | Fields
répertoire | Filesystem
répertoire | Filter
répertoire | Form
répertoire | Help
répertoire | Helper
répertoire | HTML
répertoire | Http
répertoire | Image
répertoire | Input
répertoire | Installer
répertoire | Language
répertoire | Layout
répertoire | Log
répertoire | Mail
répertoire | Menu
répertoire | Microdata
répertoire | MVC
répertoire | Object
répertoire | Pagination
répertoire | Pathway
répertoire | Plugin
répertoire | Profiler
répertoire | Response
répertoire | Router
répertoire | Schema
répertoire | Serializer
répertoire | Service
répertoire | Session
répertoire | String
répertoire | Table
répertoire | Tag
répertoire | Toolbar
répertoire | Tree
répertoire | UCM
répertoire | Updater
répertoire | Uri
répertoire | User
répertoire | Utility
répertoire | Versioning
répertoire | WebAsset
répertoire | Workflow

Fichiers

fichier | src/Factory.php
fichier | src/Version.php


Joomla CMS: Répertoire de référence de Constraint

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Répertoire de référence de Constraint

Fichiers

fichier | IdentifiedBy.php
fichier | IssuedBy.php
fichier | LeewayCannotBeNegative.php
fichier | PermittedFor.php
fichier | RelatedTo.php
fichier | SignedWith.php
fichier | ValidAt.php


Joomla CMS: Répertoire de référence de mod_post_installation_messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_post_installation_messages
Répertoire de référence de mod_post_installation_messages

Répertoires

répertoire tmpl

Fichiers

fichier mod_post_installation_messages.php


Joomla CMS: Répertoire de référence de com_media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
Répertoire de référence de com_media

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de urlinstaller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • urlinstaller
Répertoire de référence de urlinstaller

Répertoires

répertoire tmpl

Fichiers

fichier urlinstaller.php


Joomla CMS: Répertoire de référence de compare

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • compare
Répertoire de référence de compare

Fichiers

fichier compare.php


Joomla CMS: Répertoire de référence de shortcut

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
Répertoire de référence de shortcut

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de Microdata

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Microdata
Répertoire de référence de Microdata

Fichiers

fichier Microdata.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | Asset.php
fichier | libraries/src/Table/Category.php
fichier | Table/Content.php
fichier | ContentHistory.php
fichier | ContentType.php
fichier | CoreContent.php
fichier | src/Table/Extension.php
fichier | libraries/src/Table/Language.php
fichier | libraries/src/Table/Menu.php
fichier | MenuType.php
fichier | src/Table/Module.php
fichier | Nested.php
fichier | src/Table/Table.php
fichier | TableInterface.php
fichier | Ucm.php
fichier | Table/Update.php
fichier | UpdateSite.php
fichier | Table/User.php
fichier | Usergroup.php
fichier | ViewLevel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de httpheaders

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • httpheaders
Répertoire de référence de httpheaders

Répertoires

répertoire postinstall

Fichiers

fichier httpheaders.php


Joomla CMS: Répertoire de référence de assets

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • assets
Répertoire de référence de assets

Répertoires

répertoire images


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_media
  • src
Répertoire de référence de src

Répertoires

répertoire Dispatcher


Joomla CMS: Répertoire de référence de SwiftMailer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • SwiftMailer
Répertoire de référence de SwiftMailer

Fichiers

fichier | SwiftLogCollector.php
fichier | SwiftMailCollector.php


Joomla CMS: Répertoire de référence de Form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
Répertoire de référence de Form

Répertoires

répertoire | Field
répertoire | Filter
répertoire | Rule

Fichiers

fichier | Form/Form.php
fichier | FormFactory.php
fichier | FormFactoryAwareInterface.php
fichier | FormFactoryAwareTrait.php
fichier | FormFactoryInterface.php
fichier | FormField.php
fichier | FormFilterInterface.php
fichier | FormHelper.php
fichier | FormRule.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | DebugHelper.php
fichier | Mfa.php
fichier | UsersHelper.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | administrator/components/com_finder/src/Helper/FinderHelper.php
fichier | administrator/components/com_finder/src/Helper/LanguageHelper.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire cache


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier UnsupportedPasswordHandlerException.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_admin/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Répertoire de référence de Toolbar

Répertoires

répertoire Button

Fichiers

fichier | ContainerAwareToolbarFactory.php
fichier | CoreButtonsTrait.php
fichier | Toolbar/Toolbar.php
fichier | ToolbarButton.php
fichier | ToolbarFactoryInterface.php
fichier | ToolbarHelper.php


Joomla CMS: Répertoire de référence de login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • login
Répertoire de référence de login

Fichiers

fichier | components/com_users/tmpl/login/default.php
fichier | default_login.php
fichier | components/com_users/tmpl/login/default_logout.php


Joomla CMS: Répertoire de référence de com_privacy

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
Répertoire de référence de com_privacy

Répertoires

répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de assert

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
  • assert
Répertoire de référence de assert

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier | Manage.php
fichier | Updatesites.php


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • contact
Répertoire de référence de contact

Fichiers

fichier plugins/webservices/contact/contact.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Password

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Répertoire de référence de Password

Fichiers

fichier | src/Authentication/Password/Argon2idHandler.php
fichier | src/Authentication/Password/Argon2iHandler.php
fichier | src/Authentication/Password/BCryptHandler.php
fichier | ChainedHandler.php
fichier | CheckIfRehashNeededHandlerInterface.php
fichier | MD5Handler.php
fichier | PHPassHandler.php


Joomla CMS: Répertoire de référence de Input

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Input
Répertoire de référence de Input

Fichiers

fichier | Cli.php
fichier | src/Input/Cookie.php
fichier | src/Input/Files.php
fichier | src/Input/Input.php
fichier | src/Input/Json.php


Joomla CMS: Répertoire de référence de Traits

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
  • Common
  • Traits
Répertoire de référence de Traits

Fichiers

fichier ReadBytes.php


Joomla CMS: Répertoire de référence de stages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • stages
Répertoire de référence de stages

Fichiers

fichier administrator/components/com_workflow/tmpl/stages/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_user
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_user/tmpl/default.php


Joomla CMS: Répertoire de référence de Media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • View
  • Media
Répertoire de référence de Media

Fichiers

fichier com_media/src/View/Media/JsonapiView.php


Joomla CMS: Répertoire de référence de token

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
  • token
Répertoire de référence de token

Fichiers

fichier layouts/plugins/user/token/token.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
  • src
Répertoire de référence de src

Fichiers

fichier | vendor/joomla/input/src/Cookie.php
fichier | vendor/joomla/input/src/Files.php
fichier | vendor/joomla/input/src/Input.php
fichier | vendor/joomla/input/src/Json.php


Joomla CMS: Répertoire de référence de Math

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
Répertoire de référence de Math

Répertoires

répertoire | BigInteger
répertoire | BinaryField
répertoire | Common
répertoire | PrimeField

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Math/BigInteger.php
fichier | BinaryField.php
fichier | PrimeField.php


Joomla CMS: Répertoire de référence de override

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • override
Répertoire de référence de override

Fichiers

fichier administrator/components/com_languages/tmpl/override/edit.php


Joomla CMS: Répertoire de référence de lcobucci

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
Répertoire de référence de lcobucci

Répertoires

répertoire jwt


Joomla CMS: Répertoire de référence de Loader

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
  • Loader
Répertoire de référence de Loader

Fichiers

fichier | WritableContainerLoader.php
fichier | WritableLoaderInterface.php


Joomla CMS: Répertoire de référence de Environment

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Environment
Répertoire de référence de Environment

Fichiers

fichier Browser.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_mails/services/provider.php


Joomla CMS: Répertoire de référence de Search

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • View
  • Search
Répertoire de référence de Search

Fichiers

fichier | com_finder/src/View/Search/FeedView.php
fichier | components/com_finder/src/View/Search/HtmlView.php
fichier | OpensearchView.php


Joomla CMS: Répertoire de référence de tasks

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • tasks
Répertoire de référence de tasks

Fichiers

fichier | administrator/components/com_scheduler/tmpl/tasks/default.php
fichier | empty_state.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_associations/services/provider.php


Joomla CMS: Répertoire de référence de algo26-matthias

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
Répertoire de référence de algo26-matthias

Répertoires

répertoire idna-convert


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier ContentComponent.php


Joomla CMS: Répertoire de référence de usergrouplist

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • usergrouplist
Répertoire de référence de usergrouplist

Répertoires

répertoire tmpl

Fichiers

fichier usergrouplist.php


Joomla CMS: Répertoire de référence de stubs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Répertoire de référence de stubs

Fichiers

fichier | symfony/polyfill-php80/Resources/stubs/Attribute.php
fichier | Resources/stubs/PhpToken.php
fichier | Stringable.php
fichier | UnhandledMatchError.php
fichier | ValueError.php


Joomla CMS: Répertoire de référence de requests

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
Répertoire de référence de requests

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de Tasks

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Tasks
Répertoire de référence de Tasks

Fichiers

fichier administrator/components/com_scheduler/src/View/Tasks/HtmlView.php


Joomla CMS: Répertoire de référence de registration

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • registration
Répertoire de référence de registration

Fichiers

fichier | components/com_users/tmpl/registration/complete.php
fichier | components/com_users/tmpl/registration/default.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | AccessException.php
fichier | symfony/options-resolver/Exception/ExceptionInterface.php
fichier | symfony/options-resolver/Exception/InvalidArgumentException.php
fichier | InvalidOptionsException.php
fichier | MissingOptionsException.php
fichier | NoConfigurationException.php
fichier | NoSuchOptionException.php
fichier | OptionDefinitionException.php
fichier | UndefinedOptionsException.php


Joomla CMS: Répertoire de référence de Languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Languages
Répertoire de référence de Languages

Fichiers

fichier administrator/components/com_languages/src/View/Languages/HtmlView.php


Joomla CMS: Répertoire de référence de polyfill-php72

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php72
Répertoire de référence de polyfill-php72

Fichiers

fichier | vendor/symfony/polyfill-php72/bootstrap.php
fichier | Php72.php


Joomla CMS: Répertoire de référence de postinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • updatenotification
  • postinstall
Répertoire de référence de postinstall

Fichiers

fichier updatecachetime.php


Joomla CMS: Répertoire de référence de lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
Répertoire de référence de lib

Répertoires

répertoire Assert


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • services
Répertoire de référence de services

Fichiers

fichier plugins/system/webauthn/services/provider.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
  • ca-bundle
  • src
Répertoire de référence de src

Fichiers

fichier CaBundle.php


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • fields
Répertoire de référence de fields

Fichiers

fichier plugins/system/fields/fields.php


Joomla CMS: Répertoire de référence de Common

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Common
Répertoire de référence de Common

Répertoires

répertoire Functions


Joomla CMS: Répertoire de référence de lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • bcmath_compat
  • lib
Répertoire de référence de lib

Fichiers

fichier bcmath.php


Joomla CMS: Répertoire de référence de style

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • style
Répertoire de référence de style

Fichiers

fichier | administrator/components/com_templates/tmpl/style/edit.php
fichier | com_templates/tmpl/style/edit_assignment.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
Répertoire de référence de src

Répertoires

répertoire ReCaptcha

Fichiers

fichier google/recaptcha/src/autoload.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
Répertoire de référence de src

Répertoires

répertoire | Dispatcher
répertoire | Event
répertoire | Helper


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier LanguagesComponent.php


Joomla CMS: Répertoire de référence de html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
Répertoire de référence de html

Répertoires

répertoire layouts


Joomla CMS: Répertoire de référence de none

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • none
Répertoire de référence de none

Fichiers

fichier plugins/editors/none/none.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Category
Répertoire de référence de Category

Fichiers

fichier components/com_newsfeeds/src/View/Category/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de Updatesites

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Updatesites
Répertoire de référence de Updatesites

Fichiers

fichier administrator/components/com_installer/src/View/Updatesites/HtmlView.php


Joomla CMS: Répertoire de référence de Dumper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Répertoire de référence de Dumper

Répertoires

répertoire ContextProvider

Fichiers

fichier | AbstractDumper.php
fichier | CliDumper.php
fichier | ContextualizedDumper.php
fichier | DataDumperInterface.php
fichier | HtmlDumper.php
fichier | ServerDumper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
Répertoire de référence de src

Répertoires

répertoire | Command
répertoire | Exception

Fichiers

fichier | ResolvedRoute.php
fichier | vendor/joomla/router/src/Route.php
fichier | libraries/vendor/joomla/router/src/Router.php
fichier | vendor/joomla/router/src/RouterInterface.php


Joomla CMS: Répertoire de référence de downloadkey

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • downloadkey
Répertoire de référence de downloadkey

Fichiers

fichier downloadkey.php


Joomla CMS: Répertoire de référence de Plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • View
  • Plugins
Répertoire de référence de Plugins

Fichiers

fichier administrator/components/com_plugins/src/View/Plugins/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Serializer
répertoire | View


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | confirm
répertoire | remind
répertoire | request


Joomla CMS: Répertoire de référence de totp

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
Répertoire de référence de totp

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_login/tmpl/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_languages/tmpl/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filter
  • src
Répertoire de référence de src

Fichiers

fichier | vendor/joomla/filter/src/InputFilter.php
fichier | vendor/joomla/filter/src/OutputFilter.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_tags/services/provider.php


Joomla CMS: Répertoire de référence de module

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • module
Répertoire de référence de module

Fichiers

fichier | administrator/components/com_modules/tmpl/module/edit.php
fichier | com_modules/tmpl/module/edit_assignment.php
fichier | administrator/components/com_modules/tmpl/module/modal.php


Joomla CMS: Répertoire de référence de com_banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
Répertoire de référence de com_banners

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de mod_sampledata

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
Répertoire de référence de mod_sampledata

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_sampledata.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Messages


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_workflow/src/Controller/DisplayController.php
fichier | StageController.php
fichier | StagesController.php
fichier | TransitionController.php
fichier | TransitionsController.php
fichier | WorkflowController.php
fichier | WorkflowsController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • bcmath_compat
  • src
Répertoire de référence de src

Fichiers

fichier bcmath_compat/src/BCMath.php


Joomla CMS: Répertoire de référence de deprecation-contracts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • deprecation-contracts
Répertoire de référence de deprecation-contracts

Fichiers

fichier function.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_privacy_dashboard/tmpl/default.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire joomla


Joomla CMS: Répertoire de référence de Security

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Security
Répertoire de référence de Security

Fichiers

fichier | CheckLdapCredentialsListener.php
fichier | LdapAuthenticator.php
fichier | LdapBadge.php
fichier | LdapUser.php
fichier | LdapUserProvider.php


Joomla CMS: Répertoire de référence de com_cpanel

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
Répertoire de référence de com_cpanel

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de web-token

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
Répertoire de référence de web-token

Répertoires

répertoire | jwt-core
répertoire | jwt-signature
répertoire | jwt-signature-algorithm-ecdsa
répertoire | jwt-signature-algorithm-eddsa
répertoire | jwt-signature-algorithm-experimental
répertoire | jwt-signature-algorithm-hmac
répertoire | jwt-signature-algorithm-none
répertoire | jwt-signature-algorithm-rsa


Joomla CMS: Répertoire de référence de Template

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • View
  • Template
Répertoire de référence de Template

Fichiers

fichier administrator/components/com_mails/src/View/Template/HtmlView.php


Joomla CMS: Répertoire de référence de groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • groups
Répertoire de référence de groups

Fichiers

fichier | administrator/components/com_fields/tmpl/groups/default.php
fichier | com_fields/tmpl/groups/default_batch_body.php
fichier | com_fields/tmpl/groups/default_batch_footer.php


Joomla CMS: Répertoire de référence de svg-sanitize

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
Répertoire de référence de svg-sanitize

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de includes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • includes
Répertoire de référence de includes

Fichiers

fichier | api/includes/app.php
fichier | api/includes/defines.php
fichier | api/includes/framework.php


Joomla CMS: Répertoire de référence de tasknotification

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • tasknotification
Répertoire de référence de tasknotification

Fichiers

fichier tasknotification.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | banner
répertoire | banners
répertoire | client
répertoire | clients
répertoire | download
répertoire | tracks


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Provider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Service
  • Provider
Répertoire de référence de Provider

Fichiers

fichier installation/src/Service/Provider/Application.php


Joomla CMS: Répertoire de référence de maximebf

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
Répertoire de référence de maximebf

Répertoires

répertoire debugbar


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Categories
Répertoire de référence de Categories

Fichiers

fichier components/com_content/src/View/Categories/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • languages
Répertoire de référence de languages

Fichiers

fichier administrator/components/com_languages/tmpl/languages/default.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_fields/services/provider.php


Joomla CMS: Répertoire de référence de authentication

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
Répertoire de référence de authentication

Répertoires

répertoire | cookie
répertoire | joomla
répertoire | ldap


Joomla CMS: Répertoire de référence de Database

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Database
Répertoire de référence de Database

Fichiers

fichier administrator/components/com_installer/src/View/Database/HtmlView.php


Joomla CMS: Répertoire de référence de language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • language
Répertoire de référence de language

Fichiers

fichier administrator/components/com_languages/tmpl/language/edit.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier NewsfeedTable.php


Joomla CMS: Répertoire de référence de newsfeed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeed
Répertoire de référence de newsfeed

Fichiers

fichier | administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php
fichier | edit_display.php
fichier | administrator/components/com_newsfeeds/tmpl/newsfeed/modal.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • tmpl
  • templates
Répertoire de référence de templates

Fichiers

fichier administrator/components/com_mails/tmpl/templates/default.php


Joomla CMS: Répertoire de référence de CSR

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • CSR
Répertoire de référence de CSR

Fichiers

fichier | fgrosse/phpasn1/lib/X509/CSR/Attributes.php
fichier | CSR.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_loginsupport
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_loginsupport/tmpl/default.php


Joomla CMS: Répertoire de référence de en-GB

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • language
  • en-GB
Répertoire de référence de en-GB

Fichiers

fichier administrator/language/en-GB/localise.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | AbstractStatsField.php
fichier | DataField.php
fichier | UniqueidField.php


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier ActionLogPlugin.php


Joomla CMS: Répertoire de référence de template

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Répertoire de référence de template

Fichiers

fichier | administrator/components/com_templates/tmpl/template/default.php
fichier | default_description.php
fichier | default_folders.php
fichier | default_media_folders.php
fichier | default_modal_child_body.php
fichier | default_modal_child_footer.php
fichier | default_modal_copy_body.php
fichier | default_modal_copy_footer.php
fichier | default_modal_delete_body.php
fichier | default_modal_delete_footer.php
fichier | default_modal_file_body.php
fichier | default_modal_file_footer.php
fichier | default_modal_folder_body.php
fichier | default_modal_folder_footer.php
fichier | default_modal_rename_body.php
fichier | default_modal_rename_footer.php
fichier | default_modal_resize_body.php
fichier | default_modal_resize_footer.php
fichier | default_tree.php
fichier | default_tree_media.php
fichier | default_updated_files.php
fichier | readonly.php


Joomla CMS: Répertoire de référence de category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • category
Répertoire de référence de category

Fichiers

fichier | components/com_content/tmpl/category/blog.php
fichier | blog_children.php
fichier | blog_item.php
fichier | blog_links.php
fichier | components/com_content/tmpl/category/default.php
fichier | com_content/tmpl/category/default_articles.php
fichier | com_content/tmpl/category/default_children.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier Credentials.php


Joomla CMS: Répertoire de référence de webauthn-lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
Répertoire de référence de webauthn-lib

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de mod_related_items

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
Répertoire de référence de mod_related_items

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_related_items.php


Joomla CMS: Répertoire de référence de com_users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
Répertoire de référence de com_users

Répertoires

répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Répertoire de référence de src

Répertoires

répertoire | Clients
répertoire | Exception
répertoire | Stream
répertoire | Support

Fichiers

fichier | Buffer.php
fichier | vendor/joomla/filesystem/src/File.php
fichier | vendor/joomla/filesystem/src/Folder.php
fichier | libraries/vendor/joomla/filesystem/src/Helper.php
fichier | vendor/joomla/filesystem/src/Patcher.php
fichier | vendor/joomla/filesystem/src/Path.php
fichier | vendor/joomla/filesystem/src/Stream.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_custom
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_custom/tmpl/default.php


Joomla CMS: Répertoire de référence de Override

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Override
Répertoire de référence de Override

Fichiers

fichier administrator/components/com_languages/src/View/Override/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier modules/mod_login/src/Helper/LoginHelper.php


Joomla CMS: Répertoire de référence de com_fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
Répertoire de référence de com_fields

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | AuthenticationFailed.php
fichier | NotAllowed.php


Joomla CMS: Répertoire de référence de Associations

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • View
  • Associations
Répertoire de référence de Associations

Fichiers

fichier administrator/components/com_associations/src/View/Associations/HtmlView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | File
répertoire | Media


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | CompareModel.php
fichier | HistoryModel.php
fichier | PreviewModel.php


Joomla CMS: Répertoire de référence de Generator

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Répertoire de référence de Generator

Fichiers

fichier | CombGenerator.php
fichier | DefaultTimeGenerator.php
fichier | MtRandGenerator.php
fichier | OpenSslGenerator.php
fichier | PeclUuidRandomGenerator.php
fichier | PeclUuidTimeGenerator.php
fichier | RandomBytesGenerator.php
fichier | RandomGeneratorFactory.php
fichier | RandomGeneratorInterface.php
fichier | RandomLibAdapter.php
fichier | SodiumRandomGenerator.php
fichier | TimeGeneratorFactory.php
fichier | TimeGeneratorInterface.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_config/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de com_messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
Répertoire de référence de com_messages

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de color

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • color
Répertoire de référence de color

Fichiers

fichier | advanced.php
fichier | simple.php
fichier | slider.php


Joomla CMS: Répertoire de référence de tab

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • tab
Répertoire de référence de tab

Fichiers

fichier | addtab.php
fichier | endtab.php
fichier | endtabset.php
fichier | starttabset.php


Joomla CMS: Répertoire de référence de CLI

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
Répertoire de référence de CLI

Répertoires

répertoire Output

Fichiers

fichier | CliInput.php
fichier | CliOutput.php
fichier | ColorStyle.php


Joomla CMS: Répertoire de référence de FiniteField

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • Common
  • FiniteField
Répertoire de référence de FiniteField

Fichiers

fichier phpseclib/phpseclib/phpseclib/Math/Common/FiniteField/Integer.php


Joomla CMS: Répertoire de référence de EncodingHelper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • EncodingHelper
Répertoire de référence de EncodingHelper

Fichiers

fichier | EncodingHelperInterface.php
fichier | FromUtf8.php
fichier | ToUtf8.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PrivacyDashboardHelper.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal

Fichiers

fichier | AssocField.php
fichier | VotelistField.php
fichier | VoteradioField.php


Joomla CMS: Répertoire de référence de Client

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Client
Répertoire de référence de Client

Fichiers

fichier administrator/components/com_banners/src/View/Client/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Curves

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Répertoire de référence de Curves

Fichiers

fichier | brainpoolP160r1.php
fichier | brainpoolP160t1.php
fichier | brainpoolP192r1.php
fichier | brainpoolP192t1.php
fichier | brainpoolP224r1.php
fichier | brainpoolP224t1.php
fichier | brainpoolP256r1.php
fichier | brainpoolP256t1.php
fichier | brainpoolP320r1.php
fichier | brainpoolP320t1.php
fichier | brainpoolP384r1.php
fichier | brainpoolP384t1.php
fichier | brainpoolP512r1.php
fichier | brainpoolP512t1.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Curve25519.php
fichier | Curve448.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/Curves/Ed25519.php
fichier | Ed448.php
fichier | nistb233.php
fichier | nistb409.php
fichier | nistk163.php
fichier | nistk233.php
fichier | nistk283.php
fichier | nistk409.php
fichier | nistp192.php
fichier | nistp224.php
fichier | nistp256.php
fichier | nistp384.php
fichier | nistp521.php
fichier | nistt571.php
fichier | prime192v1.php
fichier | prime192v2.php
fichier | prime192v3.php
fichier | prime239v1.php
fichier | prime239v2.php
fichier | prime239v3.php
fichier | prime256v1.php
fichier | secp112r1.php
fichier | secp112r2.php
fichier | secp128r1.php
fichier | secp128r2.php
fichier | secp160k1.php
fichier | secp160r1.php
fichier | secp160r2.php
fichier | secp192k1.php
fichier | secp192r1.php
fichier | secp224k1.php
fichier | secp224r1.php
fichier | secp256k1.php
fichier | secp256r1.php
fichier | secp384r1.php
fichier | secp521r1.php
fichier | sect113r1.php
fichier | sect113r2.php
fichier | sect131r1.php
fichier | sect131r2.php
fichier | sect163k1.php
fichier | sect163r1.php
fichier | sect163r2.php
fichier | sect193r1.php
fichier | sect193r2.php
fichier | sect233k1.php
fichier | sect233r1.php
fichier | sect239k1.php
fichier | sect283k1.php
fichier | sect283r1.php
fichier | sect409k1.php
fichier | sect409r1.php
fichier | sect571k1.php
fichier | sect571r1.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Menus.php


Joomla CMS: Répertoire de référence de com_content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
Répertoire de référence de com_content

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
  • media
Répertoire de référence de media

Fichiers

fichier | administrator/components/com_media/tmpl/media/default.php
fichier | default_texts.php


Joomla CMS: Répertoire de référence de Serializer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • Serializer
Répertoire de référence de Serializer

Fichiers

fichier ContactSerializer.php


Joomla CMS: Répertoire de référence de Net

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Net
Répertoire de référence de Net

Répertoires

répertoire SFTP

Fichiers

fichier | SFTP.php
fichier | Net/SSH2.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_contact/src/Model/ContactModel.php
fichier | ContactsModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • user
Répertoire de référence de user

Fichiers

fichier plugins/privacy/user/user.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de buttons

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • editors
  • buttons
Répertoire de référence de buttons

Fichiers

fichier | button.php
fichier | layouts/joomla/editors/buttons/modal.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • field
Répertoire de référence de field

Fichiers

fichier administrator/components/com_fields/tmpl/field/edit.php


Joomla CMS: Répertoire de référence de ChaCha20

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • ChaCha20
Répertoire de référence de ChaCha20

Fichiers

fichier | src/Core/ChaCha20/Ctx.php
fichier | src/Core/ChaCha20/IetfCtx.php


Joomla CMS: Répertoire de référence de DH

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
Répertoire de référence de DH

Répertoires

répertoire Formats

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Crypt/DH/Parameters.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/DH/PrivateKey.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/DH/PublicKey.php


Joomla CMS: Répertoire de référence de Cpanel

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • View
  • Cpanel
Répertoire de référence de Cpanel

Fichiers

fichier administrator/components/com_cpanel/src/View/Cpanel/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_plugins/src/Controller/DisplayController.php
fichier | com_plugins/src/Controller/PluginController.php
fichier | administrator/components/com_plugins/src/Controller/PluginsController.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier AdminComponent.php


Joomla CMS: Répertoire de référence de Util

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • Util
Répertoire de référence de Util

Fichiers

fichier CoseSignatureFixer.php


Joomla CMS: Répertoire de référence de sampledata

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • sampledata
Répertoire de référence de sampledata

Répertoires

répertoire | blog
répertoire | multilang


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier TagTable.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | categories
répertoire | category


Joomla CMS: Répertoire de référence de Calculator

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Internal
  • Calculator
Répertoire de référence de Calculator

Fichiers

fichier | BcMathCalculator.php
fichier | GmpCalculator.php
fichier | NativeCalculator.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_installer/src/Model/DatabaseModel.php
fichier | DiscoverModel.php
fichier | InstallerModel.php
fichier | InstallModel.php
fichier | administrator/components/com_installer/src/Model/LanguagesModel.php
fichier | ManageModel.php
fichier | com_installer/src/Model/UpdateModel.php
fichier | UpdatesiteModel.php
fichier | UpdatesitesModel.php
fichier | WarningsModel.php


Joomla CMS: Répertoire de référence de privacyconsent

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • privacyconsent
Répertoire de référence de privacyconsent

Répertoires

répertoire src

Fichiers

fichier privacyconsent.php


Joomla CMS: Répertoire de référence de email

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
Répertoire de référence de email

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth2
  • src
Répertoire de référence de src

Fichiers

fichier oauth2/src/Client.php


Joomla CMS: Répertoire de référence de Mysql

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysql
Répertoire de référence de Mysql

Fichiers

fichier | MysqlDriver.php
fichier | MysqlExporter.php
fichier | MysqlImporter.php
fichier | MysqlQuery.php


Joomla CMS: Répertoire de référence de polyfill-intl-grapheme

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-grapheme
Répertoire de référence de polyfill-intl-grapheme

Fichiers

fichier | vendor/symfony/polyfill-intl-grapheme/bootstrap.php
fichier | polyfill-intl-grapheme/bootstrap80.php
fichier | Grapheme.php


Joomla CMS: Répertoire de référence de toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • toolbar
Répertoire de référence de toolbar

Fichiers

fichier cancelselect.php


Joomla CMS: Répertoire de référence de EventListener

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • EventListener
Répertoire de référence de EventListener

Fichiers

fichier ErrorListener.php


Joomla CMS: Répertoire de référence de categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • categories
Répertoire de référence de categories

Fichiers

fichier | components/com_content/tmpl/categories/default.php
fichier | components/com_content/tmpl/categories/default_items.php


Joomla CMS: Répertoire de référence de MultiFactor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Répertoire de référence de MultiFactor

Fichiers

fichier | BeforeDisplayMethods.php
fichier | Callback.php
fichier | Captive.php
fichier | GetMethod.php
fichier | GetSetup.php
fichier | NotifyActionLog.php
fichier | SaveSetup.php
fichier | Validate.php


Joomla CMS: Répertoire de référence de polyfill-php73

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
Répertoire de référence de polyfill-php73

Répertoires

répertoire Resources

Fichiers

fichier | vendor/symfony/polyfill-php73/bootstrap.php
fichier | Php73.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_contenthistory/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesLatestHelper.php


Joomla CMS: Répertoire de référence de Level

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Level
Répertoire de référence de Level

Fichiers

fichier administrator/components/com_users/src/View/Level/HtmlView.php


Joomla CMS: Répertoire de référence de Items

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Items
Répertoire de référence de Items

Fichiers

fichier administrator/components/com_menus/src/View/Items/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Répertoire de référence de src

Répertoires

répertoire | Exception
répertoire | Transport

Fichiers

fichier | AbstractTransport.php
fichier | vendor/joomla/http/src/Http.php
fichier | vendor/joomla/http/src/HttpFactory.php
fichier | libraries/vendor/joomla/http/src/Response.php
fichier | vendor/joomla/http/src/TransportInterface.php


Joomla CMS: Répertoire de référence de Debuggroup

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Debuggroup
Répertoire de référence de Debuggroup

Fichiers

fichier administrator/components/com_users/src/View/Debuggroup/HtmlView.php


Joomla CMS: Répertoire de référence de Requests

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • View
  • Requests
Répertoire de référence de Requests

Fichiers

fichier com_privacy/src/View/Requests/JsonapiView.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • templates
Répertoire de référence de templates

Fichiers

fichier administrator/components/com_templates/tmpl/templates/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_banners/tmpl/default.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire toolbar


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ArchiveModel.php
fichier | components/com_content/src/Model/ArticleModel.php
fichier | components/com_content/src/Model/ArticlesModel.php
fichier | components/com_content/src/Model/CategoriesModel.php
fichier | components/com_content/src/Model/CategoryModel.php
fichier | components/com_content/src/Model/FeaturedModel.php
fichier | components/com_content/src/Model/FormModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de cassiopeia

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
Répertoire de référence de cassiopeia

Répertoires

répertoire html

Fichiers

fichier | templates/cassiopeia/component.php
fichier | templates/cassiopeia/error.php
fichier | templates/cassiopeia/index.php
fichier | cassiopeia/offline.php


Joomla CMS: Répertoire de référence de checkboxes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • checkboxes
Répertoire de référence de checkboxes

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/checkboxes/checkboxes.php


Joomla CMS: Répertoire de référence de database

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
Répertoire de référence de database

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Export
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Plugin
répertoire | Removal
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de notification

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • notification
Répertoire de référence de notification

Fichiers

fichier notification.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Command
Répertoire de référence de Command

Fichiers

fichier | ExportCommand.php
fichier | ImportCommand.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | com_categories/src/Controller/AjaxController.php
fichier | administrator/components/com_categories/src/Controller/CategoriesController.php
fichier | CategoryController.php
fichier | administrator/components/com_categories/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de recaptcha_invisible

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • captcha
  • recaptcha_invisible
Répertoire de référence de recaptcha_invisible

Fichiers

fichier recaptcha_invisible.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_latestactions/tmpl/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire searchtools


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_plugins/services/provider.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • privacyconsent
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier PrivacyField.php


Joomla CMS: Répertoire de référence de Reset

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Reset
Répertoire de référence de Reset

Fichiers

fichier components/com_users/src/View/Reset/HtmlView.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier plugins/api-authentication/token/src/Extension/Token.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • container
  • src
Répertoire de référence de src

Fichiers

fichier | ContainerExceptionInterface.php
fichier | ContainerInterface.php
fichier | NotFoundExceptionInterface.php


Joomla CMS: Répertoire de référence de base64url

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • base64url
Répertoire de référence de base64url

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menus
Répertoire de référence de menus

Fichiers

fichier administrator/components/com_menus/tmpl/menus/default.php


Joomla CMS: Répertoire de référence de Feeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • View
  • Feeds
Répertoire de référence de Feeds

Fichiers

fichier com_newsfeeds/src/View/Feeds/JsonapiView.php


Joomla CMS: Répertoire de référence de com_redirect

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
Répertoire de référence de com_redirect

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
Répertoire de référence de src

Répertoires

répertoire | Field
répertoire | PluginTraits


Joomla CMS: Répertoire de référence de modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • modules
Répertoire de référence de modules

Fichiers

fichier | administrator/components/com_modules/tmpl/modules/default.php
fichier | com_modules/tmpl/modules/default_batch_body.php
fichier | com_modules/tmpl/modules/default_batch_footer.php
fichier | administrator/components/com_modules/tmpl/modules/emptystate.php
fichier | administrator/components/com_modules/tmpl/modules/modal.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire stubs


Joomla CMS: Répertoire de référence de modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
Répertoire de référence de modules

Répertoires

répertoire | mod_articles_archive
répertoire | mod_articles_categories
répertoire | mod_articles_category
répertoire | mod_articles_latest
répertoire | mod_articles_news
répertoire | mod_articles_popular
répertoire | mod_banners
répertoire | mod_breadcrumbs
répertoire | mod_custom
répertoire | mod_feed
répertoire | mod_finder
répertoire | mod_footer
répertoire | mod_languages
répertoire | mod_login
répertoire | mod_menu
répertoire | mod_random_image
répertoire | mod_related_items
répertoire | mod_stats
répertoire | mod_syndicate
répertoire | mod_tags_popular
répertoire | mod_tags_similar
répertoire | mod_users_latest
répertoire | mod_whosonline
répertoire | mod_wrapper


Joomla CMS: Répertoire de référence de Access

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
Répertoire de référence de Access

Répertoires

répertoire Exception

Fichiers

fichier | Access/Access.php
fichier | Rule.php
fichier | src/Access/Rules.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Répertoire de référence de src

Fichiers

fichier | RequestFactoryInterface.php
fichier | ResponseFactoryInterface.php
fichier | ServerRequestFactoryInterface.php
fichier | StreamFactoryInterface.php
fichier | UploadedFileFactoryInterface.php
fichier | UriFactoryInterface.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
Répertoire de référence de Controller

Répertoires

répertoire Exception

Fichiers

fichier | AdminController.php
fichier | libraries/src/MVC/Controller/ApiController.php
fichier | BaseController.php
fichier | ControllerInterface.php
fichier | FormController.php


Joomla CMS: Répertoire de référence de group

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • group
Répertoire de référence de group

Fichiers

fichier administrator/components/com_fields/tmpl/group/edit.php


Joomla CMS: Répertoire de référence de com_privacy

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
Répertoire de référence de com_privacy

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_menus/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de mod_login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
Répertoire de référence de mod_login

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier modules/mod_login/mod_login.php


Joomla CMS: Répertoire de référence de voku

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
Répertoire de référence de voku

Répertoires

répertoire | portable-ascii
répertoire | portable-utf8


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | AssociationModel.php
fichier | AssociationsModel.php


Joomla CMS: Répertoire de référence de messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • messages
Répertoire de référence de messages

Fichiers

fichier | administrator/components/com_messages/tmpl/messages/default.php
fichier | administrator/components/com_messages/tmpl/messages/emptystate.php


Joomla CMS: Répertoire de référence de Archive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Archive
Répertoire de référence de Archive

Fichiers

fichier components/com_content/src/View/Archive/HtmlView.php


Joomla CMS: Répertoire de référence de Reductions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
  • Reductions
Répertoire de référence de Reductions

Fichiers

fichier | BCMath/Reductions/Barrett.php
fichier | BCMath/Reductions/EvalBarrett.php


Joomla CMS: Répertoire de référence de Select

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Select
Répertoire de référence de Select

Fichiers

fichier administrator/components/com_scheduler/src/View/Select/HtmlView.php


Joomla CMS: Répertoire de référence de components

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
Répertoire de référence de components

Répertoires

répertoire | com_ajax
répertoire | com_banners
répertoire | com_config
répertoire | com_contact
répertoire | com_content
répertoire | com_contenthistory
répertoire | com_fields
répertoire | com_finder
répertoire | com_media
répertoire | com_menus
répertoire | com_modules
répertoire | com_newsfeeds
répertoire | com_privacy
répertoire | com_tags
répertoire | com_users
répertoire | com_wrapper


Joomla CMS: Répertoire de référence de includes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • includes
Répertoire de référence de includes

Fichiers

fichier | installation/includes/app.php
fichier | installation/includes/defines.php
fichier | installation/includes/framework.php


Joomla CMS: Répertoire de référence de session

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
Répertoire de référence de session

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Button

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Button
Répertoire de référence de Button

Fichiers

fichier | ActionButton.php
fichier | FeaturedButton.php
fichier | PublishedButton.php
fichier | TransitionButton.php


Joomla CMS: Répertoire de référence de Rss

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
  • Rss
Répertoire de référence de Rss

Fichiers

fichier | ItunesRssParser.php
fichier | MediaRssParser.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de template

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • template
Répertoire de référence de template

Fichiers

fichier | installation/template/body.php
fichier | installation/template/error.php
fichier | installation/template/index.php


Joomla CMS: Répertoire de référence de Formatter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Répertoire de référence de Formatter

Fichiers

fichier | NullOutputFormatter.php
fichier | NullOutputFormatterStyle.php
fichier | OutputFormatter.php
fichier | OutputFormatterInterface.php
fichier | OutputFormatterStyle.php
fichier | OutputFormatterStyleInterface.php
fichier | OutputFormatterStyleStack.php
fichier | WrappableOutputFormatterInterface.php


Joomla CMS: Répertoire de référence de DataCollector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Répertoire de référence de DataCollector

Fichiers

fichier | InfoCollector.php
fichier | LanguageErrorsCollector.php
fichier | LanguageFilesCollector.php
fichier | LanguageStringsCollector.php
fichier | ProfileCollector.php
fichier | QueryCollector.php
fichier | SessionCollector.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | article
répertoire | articles
répertoire | featured


Joomla CMS: Répertoire de référence de com_tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
Répertoire de référence de com_tags

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
  • src
Répertoire de référence de src

Répertoires

répertoire Cron


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • Exception
Répertoire de référence de Exception

Fichiers

fichier NotAcceptable.php


Joomla CMS: Répertoire de référence de quickicon

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
Répertoire de référence de quickicon

Répertoires

répertoire | downloadkey
répertoire | extensionupdate
répertoire | joomlaupdate
répertoire | overridecheck
répertoire | phpversioncheck
répertoire | privacycheck


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | com_menus/src/Controller/AjaxController.php
fichier | administrator/components/com_menus/src/Controller/DisplayController.php
fichier | ItemController.php
fichier | administrator/components/com_menus/src/Controller/ItemsController.php
fichier | MenuController.php
fichier | administrator/components/com_menus/src/Controller/MenusController.php


Joomla CMS: Répertoire de référence de Error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Error
Répertoire de référence de Error

Fichiers

fichier installation/src/View/Error/HtmlView.php


Joomla CMS: Répertoire de référence de Util

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Répertoire de référence de Util

Fichiers

fichier | web-token/jwt-core/Util/BigInteger.php
fichier | ECKey.php
fichier | web-token/jwt-core/Util/ECSignature.php
fichier | web-token/jwt-core/Util/Hash.php
fichier | JsonConverter.php
fichier | KeyChecker.php
fichier | RSAKey.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Répertoire de référence de src

Répertoires

répertoire | Exception
répertoire | functions
répertoire | Request
répertoire | Response

Fichiers

fichier | laminas/laminas-diactoros/src/AbstractSerializer.php
fichier | CallbackStream.php
fichier | ConfigProvider.php
fichier | HeaderSecurity.php
fichier | laminas/laminas-diactoros/src/MessageTrait.php
fichier | vendor/laminas/laminas-diactoros/src/Module.php
fichier | PhpInputStream.php
fichier | RelativeStream.php
fichier | laminas/laminas-diactoros/src/Request.php
fichier | laminas/laminas-diactoros/src/RequestFactory.php
fichier | laminas/laminas-diactoros/src/RequestTrait.php
fichier | libraries/vendor/laminas/laminas-diactoros/src/Response.php
fichier | laminas/laminas-diactoros/src/ResponseFactory.php
fichier | laminas/laminas-diactoros/src/ServerRequest.php
fichier | ServerRequestFactory.php
fichier | vendor/laminas/laminas-diactoros/src/Stream.php
fichier | laminas/laminas-diactoros/src/StreamFactory.php
fichier | laminas/laminas-diactoros/src/UploadedFile.php
fichier | UploadedFileFactory.php
fichier | vendor/laminas/laminas-diactoros/src/Uri.php
fichier | laminas/laminas-diactoros/src/UriFactory.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_tags/src/Model/TagModel.php
fichier | administrator/components/com_tags/src/Model/TagsModel.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_login
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | modules/mod_login/tmpl/default.php
fichier | modules/mod_login/tmpl/default_logout.php


Joomla CMS: Répertoire de référence de login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • tmpl
  • login
Répertoire de référence de login

Fichiers

fichier administrator/components/com_login/tmpl/login/default.php


Joomla CMS: Répertoire de référence de demotasks

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
Répertoire de référence de demotasks

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | FieldTable.php
fichier | GroupTable.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier TagsPopularHelper.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | DivisionByZeroException.php
fichier | IntegerOverflowException.php
fichier | MathException.php
fichier | NegativeNumberException.php
fichier | NumberFormatException.php
fichier | RoundingNecessaryException.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier modules/mod_languages/src/Helper/LanguagesHelper.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Languages.php


Joomla CMS: Répertoire de référence de Traits

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Traits
Répertoire de référence de Traits

Fichiers

fichier TaskPluginTrait.php


Joomla CMS: Répertoire de référence de var-dumper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
Répertoire de référence de var-dumper

Répertoires

répertoire | Caster
répertoire | Cloner
répertoire | Command
répertoire | Dumper
répertoire | Exception
répertoire | Resources
répertoire | Server
répertoire | Test

Fichiers

fichier VarDumper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Updatesite

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Updatesite
Répertoire de référence de Updatesite

Fichiers

fichier administrator/components/com_installer/src/View/Updatesite/HtmlView.php


Joomla CMS: Répertoire de référence de jakeasmith

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • jakeasmith
Répertoire de référence de jakeasmith

Répertoires

répertoire http_build_url


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier plugins/api-authentication/basic/src/Extension/Basic.php


Joomla CMS: Répertoire de référence de DSA

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
Répertoire de référence de DSA

Répertoires

répertoire Formats

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Crypt/DSA/Parameters.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/DSA/PrivateKey.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/DSA/PublicKey.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier com_associations/src/Helper/AssociationsHelper.php


Joomla CMS: Répertoire de référence de Ge

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Répertoire de référence de Ge

Fichiers

fichier | src/Core32/Curve25519/Ge/Cached.php
fichier | src/Core32/Curve25519/Ge/P1p1.php
fichier | src/Core32/Curve25519/Ge/P2.php
fichier | src/Core32/Curve25519/Ge/P3.php
fichier | src/Core32/Curve25519/Ge/Precomp.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_newsfeeds/helpers/newsfeeds.php


Joomla CMS: Répertoire de référence de newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
  • newsfeeds
Répertoire de référence de newsfeeds

Fichiers

fichier | administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php
fichier | com_newsfeeds/tmpl/newsfeeds/default_batch_body.php
fichier | com_newsfeeds/tmpl/newsfeeds/default_batch_footer.php
fichier | administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php
fichier | administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php


Joomla CMS: Répertoire de référence de override

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • override
Répertoire de référence de override

Fichiers

fichier override.php


Joomla CMS: Répertoire de référence de EventListener

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • EventListener
Répertoire de référence de EventListener

Fichiers

fichier MetadataManagerListener.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_cpanel/services/provider.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier | Filter.php
fichier | Finder.php
fichier | administrator/components/com_finder/src/Service/HTML/Query.php


Joomla CMS: Répertoire de référence de Session

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
Répertoire de référence de Session

Répertoires

répertoire | EventListener
répertoire | Exception
répertoire | Storage

Fichiers

fichier | MetadataManager.php
fichier | src/Session/Session.php
fichier | SessionFactory.php
fichier | SessionManager.php


Joomla CMS: Répertoire de référence de com_contenthistory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contenthistory
Répertoire de référence de com_contenthistory

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de privacyconsent

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
  • privacyconsent
Répertoire de référence de privacyconsent

Fichiers

fichier | system/privacyconsent/label.php
fichier | layouts/plugins/system/privacyconsent/message.php


Joomla CMS: Répertoire de référence de cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • tmpl
  • cache
Répertoire de référence de cache

Fichiers

fichier | administrator/components/com_cache/tmpl/cache/default.php
fichier | administrator/components/com_cache/tmpl/cache/emptystate.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_newsfeeds/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de Output

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Répertoire de référence de Output

Fichiers

fichier | BufferedOutput.php
fichier | ConsoleOutput.php
fichier | ConsoleOutputInterface.php
fichier | ConsoleSectionOutput.php
fichier | NullOutput.php
fichier | Output.php
fichier | OutputInterface.php
fichier | StreamOutput.php
fichier | TrimmedBufferOutput.php


Joomla CMS: Répertoire de référence de Transport

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Transport
Répertoire de référence de Transport

Fichiers

fichier | joomla/http/src/Transport/Curl.php
fichier | joomla/http/src/Transport/Socket.php
fichier | vendor/joomla/http/src/Transport/Stream.php


Joomla CMS: Répertoire de référence de info_block

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Répertoire de référence de info_block

Fichiers

fichier | content/info_block/associations.php
fichier | author.php
fichier | category.php
fichier | create_date.php
fichier | hits.php
fichier | modify_date.php
fichier | parent_category.php
fichier | publish_date.php


Joomla CMS: Répertoire de référence de lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Répertoire de référence de lib

Fichiers

fichier | constants.php
fichier | namespaced.php
fichier | php72compat.php
fichier | php72compat_const.php
fichier | ristretto255.php
fichier | sodium_compat.php
fichier | stream-xchacha20.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Répertoire de référence de src

Fichiers

fichier | AuthenticatorStatus.php
fichier | BiometricAccuracyDescriptor.php
fichier | BiometricStatusReport.php
fichier | CodeAccuracyDescriptor.php
fichier | DisplayPNGCharacteristicsDescriptor.php
fichier | DistantSingleMetadata.php
fichier | DistantSingleMetadataFactory.php
fichier | EcdaaTrustAnchor.php
fichier | ExtensionDescriptor.php
fichier | MetadataService.php
fichier | MetadataServiceFactory.php
fichier | MetadataStatement.php
fichier | MetadataStatementFetcher.php
fichier | MetadataStatementRepository.php
fichier | MetadataTOCPayload.php
fichier | MetadataTOCPayloadEntry.php
fichier | PatternAccuracyDescriptor.php
fichier | RgbPaletteEntry.php
fichier | RogueListEntry.php
fichier | SimpleMetadataStatementRepository.php
fichier | SingleMetadata.php
fichier | StatusReport.php
fichier | VerificationMethodANDCombinations.php
fichier | VerificationMethodDescriptor.php
fichier | vendor/web-auth/metadata-service/src/Version.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Répertoire de référence de src

Fichiers

fichier | AbstractUri.php
fichier | vendor/joomla/uri/src/Uri.php
fichier | UriHelper.php
fichier | UriImmutable.php
fichier | joomla/uri/src/UriInterface.php


Joomla CMS: Répertoire de référence de Handler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
  • Handler
Répertoire de référence de Handler

Fichiers

fichier | ExceptionHandlerInterface.php
fichier | FallbackExceptionHandler.php
fichier | vendor/tobscure/json-api/src/Exception/Handler/InvalidParameterExceptionHandler.php
fichier | ResponseBag.php


Joomla CMS: Répertoire de référence de Signature

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Signature
Répertoire de référence de Signature

Fichiers

fichier | Crypt/DSA/Formats/Signature/ASN1.php
fichier | DSA/Formats/Signature/Raw.php
fichier | Crypt/DSA/Formats/Signature/SSH2.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier SampledataHelper.php


Joomla CMS: Répertoire de référence de multilangstatus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • multilangstatus
Répertoire de référence de multilangstatus

Fichiers

fichier administrator/components/com_languages/tmpl/multilangstatus/default.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_joomlaupdate/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Password

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Password
Répertoire de référence de Password

Fichiers

fichier | vendor/joomla/authentication/src/Password/Argon2idHandler.php
fichier | vendor/joomla/authentication/src/Password/Argon2iHandler.php
fichier | vendor/joomla/authentication/src/Password/BCryptHandler.php
fichier | authentication/src/Password/HandlerInterface.php


Joomla CMS: Répertoire de référence de Task

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
  • Task
Répertoire de référence de Task

Fichiers

fichier administrator/components/com_scheduler/src/View/Task/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier joomla/console/src/Helper/DescriptorHelper.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • services
Répertoire de référence de services

Fichiers

fichier plugins/multifactorauth/webauthn/services/provider.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_banners/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de recaptcha

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
Répertoire de référence de recaptcha

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | select
répertoire | task
répertoire | tasks


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ComponentsFieldgroupField.php
fichier | ComponentsFieldsField.php
fichier | FieldcontextsField.php
fichier | FieldgroupsField.php
fichier | FieldLayoutField.php
fichier | SectionField.php
fichier | SubfieldsField.php
fichier | com_fields/src/Field/TypeField.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ArticlesPopularHelper.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | com_scheduler/src/Model/SelectModel.php
fichier | TaskModel.php
fichier | TasksModel.php


Joomla CMS: Répertoire de référence de mod_wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
Répertoire de référence de mod_wrapper

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_wrapper.php


Joomla CMS: Répertoire de référence de category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • category
Répertoire de référence de category

Fichiers

fichier | administrator/components/com_categories/tmpl/category/edit.php
fichier | administrator/components/com_categories/tmpl/category/modal.php


Joomla CMS: Répertoire de référence de com_menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
Répertoire de référence de com_menus

Répertoires

répertoire | helpers
répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de ldap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
Répertoire de référence de ldap

Répertoires

répertoire | Adapter
répertoire | Exception
répertoire | Security

Fichiers

fichier | Entry.php
fichier | Ldap.php
fichier | LdapInterface.php


Joomla CMS: Répertoire de référence de mod_custom

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_custom
Répertoire de référence de mod_custom

Répertoires

répertoire tmpl

Fichiers

fichier administrator/modules/mod_custom/mod_custom.php


Joomla CMS: Répertoire de référence de User

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Répertoire de référence de User

Fichiers

fichier | CurrentUserInterface.php
fichier | CurrentUserTrait.php
fichier | User/User.php
fichier | UserFactory.php
fichier | UserFactoryInterface.php
fichier | UserHelper.php


Joomla CMS: Répertoire de référence de newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • newsfeeds
Répertoire de référence de newsfeeds

Fichiers

fichier plugins/webservices/newsfeeds/newsfeeds.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | com_contact/src/Controller/AjaxController.php
fichier | administrator/components/com_contact/src/Controller/ContactController.php
fichier | ContactsController.php
fichier | administrator/components/com_contact/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • src
Répertoire de référence de src

Répertoires

répertoire Dispatcher


Joomla CMS: Répertoire de référence de Doctrine

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
Répertoire de référence de Doctrine

Répertoires

répertoire | Common
répertoire | Inflector


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_cache/services/provider.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire chromes

Fichiers

fichier status.php


Joomla CMS: Répertoire de référence de images

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • assets
  • images
Répertoire de référence de images

Fichiers

fichier symfony-ghost.svg.php


Joomla CMS: Répertoire de référence de ca-bundle

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
  • ca-bundle
Répertoire de référence de ca-bundle

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Helper
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de com_redirect

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
Répertoire de référence de com_redirect

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de com_ajax

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_ajax
Répertoire de référence de com_ajax

Fichiers

fichier components/com_ajax/ajax.php


Joomla CMS: Répertoire de référence de Changelog

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Changelog
Répertoire de référence de Changelog

Fichiers

fichier Changelog.php


Joomla CMS: Répertoire de référence de category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
  • category
Répertoire de référence de category

Fichiers

fichier | components/com_newsfeeds/tmpl/category/default.php
fichier | com_newsfeeds/tmpl/category/default_children.php
fichier | components/com_newsfeeds/tmpl/category/default_items.php


Joomla CMS: Répertoire de référence de Menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
  • src
  • Menu
Répertoire de référence de Menu

Fichiers

fichier administrator/modules/mod_submenu/src/Menu/Menu.php


Joomla CMS: Répertoire de référence de Curve25519

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
Répertoire de référence de Curve25519

Répertoires

répertoire Ge

Fichiers

fichier | src/Core32/Curve25519/Fe.php
fichier | src/Core32/Curve25519/H.php


Joomla CMS: Répertoire de référence de Question

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Question
Répertoire de référence de Question

Fichiers

fichier | ChoiceQuestion.php
fichier | ConfirmationQuestion.php
fichier | Question.php


Joomla CMS: Répertoire de référence de Workflows

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Workflows
Répertoire de référence de Workflows

Fichiers

fichier administrator/components/com_workflow/src/View/Workflows/HtmlView.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Répertoire de référence de field

Répertoires

répertoire | color
répertoire | media
répertoire | radio
répertoire | subform

Fichiers

fichier | layouts/joomla/form/field/calendar.php
fichier | checkbox.php
fichier | layouts/joomla/form/field/checkboxes.php
fichier | combo.php
fichier | layouts/joomla/form/field/contenthistory.php
fichier | email.php
fichier | file.php
fichier | groupedlist-fancy-select.php
fichier | groupedlist.php
fichier | hidden.php
fichier | list-fancy-select.php
fichier | layouts/joomla/form/field/list.php
fichier | layouts/joomla/form/field/media.php
fichier | meter.php
fichier | moduleorder.php
fichier | number.php
fichier | password.php
fichier | radiobasic.php
fichier | range.php
fichier | rules.php
fichier | form/field/tag.php
fichier | tel.php
fichier | layouts/joomla/form/field/text.php
fichier | layouts/joomla/form/field/textarea.php
fichier | time.php
fichier | layouts/joomla/form/field/url.php
fichier | layouts/joomla/form/field/user.php


Joomla CMS: Répertoire de référence de sitestatus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
Répertoire de référence de sitestatus

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Articles


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier ConnectionEvent.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | BranchesField.php
fichier | ContentmapField.php
fichier | ContenttypesField.php
fichier | SearchfilterField.php


Joomla CMS: Répertoire de référence de Formats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
Répertoire de référence de Formats

Répertoires

répertoire Keys


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier joomla/console/src/Exception/NamespaceNotFoundException.php


Joomla CMS: Répertoire de référence de Fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • View
  • Fields
Répertoire de référence de Fields

Fichiers

fichier com_fields/src/View/Fields/JsonapiView.php


Joomla CMS: Répertoire de référence de Rule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Rule
Répertoire de référence de Rule

Fichiers

fichier | LoginUniqueFieldRule.php
fichier | LogoutUniqueFieldRule.php


Joomla CMS: Répertoire de référence de application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
Répertoire de référence de application

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Field
Répertoire de référence de Field

Fichiers

fichier administrator/components/com_fields/src/View/Field/HtmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
  • services
Répertoire de référence de services

Fichiers

fichier plugins/multifactorauth/yubikey/services/provider.php


Joomla CMS: Répertoire de référence de Converter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
Répertoire de référence de Converter

Répertoires

répertoire | Number
répertoire | Time

Fichiers

fichier | NumberConverterInterface.php
fichier | TimeConverterInterface.php


Joomla CMS: Répertoire de référence de captcha

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • captcha
Répertoire de référence de captcha

Répertoires

répertoire | recaptcha
répertoire | recaptcha_invisible


Joomla CMS: Répertoire de référence de ldap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • ldap
Répertoire de référence de ldap

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Newsfeed
répertoire | Newsfeeds


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Messages.php


Joomla CMS: Répertoire de référence de com_banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
Répertoire de référence de com_banners

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | compare
répertoire | history
répertoire | preview


Joomla CMS: Répertoire de référence de Install

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Install
Répertoire de référence de Install

Fichiers

fichier administrator/components/com_installer/src/View/Install/HtmlView.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_fields/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_finder/src/Controller/DisplayController.php
fichier | FilterController.php
fichier | FiltersController.php
fichier | IndexController.php
fichier | IndexerController.php
fichier | MapsController.php
fichier | SearchesController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de polyfill-php80

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
Répertoire de référence de polyfill-php80

Répertoires

répertoire Resources

Fichiers

fichier | vendor/symfony/polyfill-php80/bootstrap.php
fichier | Php80.php
fichier | PhpToken.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_contenthistory/src/Controller/HistoryController.php


Joomla CMS: Répertoire de référence de phpmailer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
Répertoire de référence de phpmailer

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
Répertoire de référence de user

Répertoires

répertoire | terms
répertoire | token


Joomla CMS: Répertoire de référence de Languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Languages
Répertoire de référence de Languages

Fichiers

fichier com_languages/src/View/Languages/JsonapiView.php


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • contact
Répertoire de référence de contact

Fichiers

fichier plugins/privacy/contact/contact.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Indexer
répertoire | Model
répertoire | Response
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de icons

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • icons
Répertoire de référence de icons

Fichiers

fichier | create.php
fichier | layouts/joomla/content/icons/edit.php
fichier | edit_lock.php


Joomla CMS: Répertoire de référence de searchtools

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
Répertoire de référence de searchtools

Répertoires

répertoire | default
répertoire | grid

Fichiers

fichier layouts/joomla/searchtools/default.php


Joomla CMS: Répertoire de référence de sql

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • sql
Répertoire de référence de sql

Répertoires

répertoire tmpl

Fichiers

fichier sql.php


Joomla CMS: Répertoire de référence de mod_login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_login
Répertoire de référence de mod_login

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier administrator/modules/mod_login/mod_login.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • token
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • finder
Répertoire de référence de finder

Fichiers

fichier extension/finder/finder.php


Joomla CMS: Répertoire de référence de com_plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
Répertoire de référence de com_plugins

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • joomla
  • form
Répertoire de référence de form

Répertoires

répertoire field


Joomla CMS: Répertoire de référence de com_newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
Répertoire de référence de com_newsfeeds

Répertoires

répertoire | helpers
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_fields/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de jwt

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
Répertoire de référence de jwt

Répertoires

répertoire | compat
répertoire | src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • packageinstaller
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/installer/packageinstaller/tmpl/default.php


Joomla CMS: Répertoire de référence de PHP52

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • PHP52
Répertoire de référence de PHP52

Fichiers

fichier SplFixedArray.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | DataShape
répertoire | Dispatcher
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
  • Categories
Répertoire de référence de Categories

Fichiers

fichier components/com_newsfeeds/src/View/Categories/HtmlView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Tags


Joomla CMS: Répertoire de référence de index

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • index
Répertoire de référence de index

Fichiers

fichier | administrator/components/com_finder/tmpl/index/default.php
fichier | administrator/components/com_finder/tmpl/index/emptystate.php


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Categories
Répertoire de référence de Categories

Fichiers

fichier components/com_contact/src/View/Categories/HtmlView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • folderinstaller
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/installer/folderinstaller/tmpl/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_custom
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_custom/tmpl/default.php


Joomla CMS: Répertoire de référence de messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • messages
Répertoire de référence de messages

Fichiers

fichier messages.php


Joomla CMS: Répertoire de référence de Base64

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Base64
Répertoire de référence de Base64

Fichiers

fichier | paragonie/sodium_compat/src/Core/Base64/Common.php
fichier | Original.php
fichier | UrlSafe.php


Joomla CMS: Répertoire de référence de com_templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
Répertoire de référence de com_templates

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de actionlogs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • actionlogs
Répertoire de référence de actionlogs

Fichiers

fichier system/actionlogs/actionlogs.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • layouts
  • joomla
  • form
  • field
Répertoire de référence de field

Fichiers

fichier modulespositionedit.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
  • Exception
Répertoire de référence de Exception

Fichiers

fichier src/Router/Exception/RouteNotFoundException.php


Joomla CMS: Répertoire de référence de ContextProvider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
  • ContextProvider
Répertoire de référence de ContextProvider

Fichiers

fichier | CliContextProvider.php
fichier | ContextProviderInterface.php
fichier | RequestContextProvider.php
fichier | SourceContextProvider.php


Joomla CMS: Répertoire de référence de Discover

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Discover
Répertoire de référence de Discover

Fichiers

fichier administrator/components/com_installer/src/View/Discover/HtmlView.php


Joomla CMS: Répertoire de référence de task

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • tmpl
  • task
Répertoire de référence de task

Fichiers

fichier administrator/components/com_scheduler/tmpl/task/edit.php


Joomla CMS: Répertoire de référence de com_scheduler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
Répertoire de référence de com_scheduler

Répertoires

répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de portable-ascii

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
Répertoire de référence de portable-ascii

Répertoires

répertoire | build
répertoire | src


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • contact
Répertoire de référence de contact

Fichiers

fichier plugins/editors-xtd/contact/contact.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | database
répertoire | discover
répertoire | install
répertoire | installer
répertoire | languages
répertoire | manage
répertoire | update
répertoire | updatesite
répertoire | updatesites
répertoire | warnings


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
  • services
Répertoire de référence de services

Fichiers

fichier plugins/quickicon/joomlaupdate/services/provider.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML

Fichiers

fichier Encrypt.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ActionlogConfigModel.php
fichier | ActionlogModel.php
fichier | ActionlogsModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
  • src
Répertoire de référence de src

Fichiers

fichier | EvolvableLinkInterface.php
fichier | EvolvableLinkProviderInterface.php
fichier | LinkInterface.php
fichier | LinkProviderInterface.php


Joomla CMS: Répertoire de référence de lib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
Répertoire de référence de lib

Répertoires

répertoire | ASN1
répertoire | Utility
répertoire | X509


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | FilterModel.php
fichier | FiltersModel.php
fichier | IndexerModel.php
fichier | IndexModel.php
fichier | MapsModel.php
fichier | SearchesModel.php
fichier | StatisticsModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | joomlaupdate
répertoire | update
répertoire | upload


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Archive
répertoire | Article
répertoire | Categories
répertoire | Category
répertoire | Featured
répertoire | Form


Joomla CMS: Répertoire de référence de SecretStream

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • SecretStream
Répertoire de référence de SecretStream

Fichiers

fichier src/Core/SecretStream/State.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire | chromes
répertoire | joomla
répertoire | libraries
répertoire | plugins


Joomla CMS: Répertoire de référence de input

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • input
Répertoire de référence de input

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | ContainerNotFoundException.php
fichier | DependencyResolutionException.php
fichier | KeyNotFoundException.php
fichier | ProtectedKeyException.php


Joomla CMS: Répertoire de référence de recaptcha

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • captcha
  • recaptcha
Répertoire de référence de recaptcha

Fichiers

fichier recaptcha.php


Joomla CMS: Répertoire de référence de string

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Répertoire de référence de string

Répertoires

répertoire | Exception
répertoire | Inflector
répertoire | Resources
répertoire | Slugger

Fichiers

fichier | symfony/string/AbstractString.php
fichier | AbstractUnicodeString.php
fichier | ByteString.php
fichier | CodePointString.php
fichier | LazyString.php
fichier | UnicodeString.php


Joomla CMS: Répertoire de référence de stubs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
  • Resources
  • stubs
Répertoire de référence de stubs

Fichiers

fichier JsonException.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire search


Joomla CMS: Répertoire de référence de cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • cache
Répertoire de référence de cache

Fichiers

fichier administrator/cache/autoload_psr4.php


Joomla CMS: Répertoire de référence de Common

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Common
Répertoire de référence de Common

Répertoires

répertoire Inflector


Joomla CMS: Répertoire de référence de webinstaller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • webinstaller
Répertoire de référence de webinstaller

Répertoires

répertoire tmpl

Fichiers

fichier webinstaller.php


Joomla CMS: Répertoire de référence de sidebars

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • sidebars
Répertoire de référence de sidebars

Fichiers

fichier submenu.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
  • services
Répertoire de référence de services

Fichiers

fichier plugins/behaviour/taggable/services/provider.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier ContactTable.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de filters

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • filters
Répertoire de référence de filters

Fichiers

fichier | administrator/components/com_finder/tmpl/filters/default.php
fichier | administrator/components/com_finder/tmpl/filters/emptystate.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | HelpModel.php
fichier | SysinfoModel.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_users/src/Service/Router.php


Joomla CMS: Répertoire de référence de Menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • src
  • Menu
Répertoire de référence de Menu

Fichiers

fichier CssMenu.php


Joomla CMS: Répertoire de référence de English

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • English
Répertoire de référence de English

Fichiers

fichier | English/Inflectible.php
fichier | Rules/English/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/English/Rules.php
fichier | English/Uninflected.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | FlattenException.php
fichier | SilencedErrorContext.php


Joomla CMS: Répertoire de référence de Time

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Time
Répertoire de référence de Time

Fichiers

fichier | FixedTimeProvider.php
fichier | SystemTimeProvider.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Templates.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • joomla
Répertoire de référence de joomla

Fichiers

fichier plugins/extension/joomla/joomla.php


Joomla CMS: Répertoire de référence de com_postinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
Répertoire de référence de com_postinstall

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Provider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Répertoire de référence de Provider

Fichiers

fichier | libraries/src/Service/Provider/Application.php
fichier | libraries/src/Service/Provider/Authentication.php
fichier | Service/Provider/CacheController.php
fichier | Config.php
fichier | Console.php
fichier | Database.php
fichier | libraries/src/Service/Provider/Dispatcher.php
fichier | src/Service/Provider/Document.php
fichier | Service/Provider/Form.php
fichier | HTMLRegistry.php
fichier | libraries/src/Service/Provider/Language.php
fichier | Service/Provider/Logger.php
fichier | libraries/src/Service/Provider/Menu.php
fichier | Service/Provider/Pathway.php
fichier | libraries/src/Service/Provider/Router.php
fichier | src/Service/Provider/Session.php
fichier | Service/Provider/Toolbar.php
fichier | Service/Provider/User.php
fichier | Service/Provider/WebAssetRegistry.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
Répertoire de référence de templates

Répertoires

répertoire | atum
répertoire | system


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier | console/src/Event/ApplicationErrorEvent.php
fichier | BeforeCommandExecuteEvent.php
fichier | CommandErrorEvent.php
fichier | joomla/console/src/Event/ConsoleEvent.php
fichier | TerminateEvent.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | CronField.php
fichier | ExecutionRuleField.php
fichier | IntervalField.php
fichier | TaskStateField.php
fichier | TaskTypeField.php
fichier | WebcronLinkField.php


Joomla CMS: Répertoire de référence de terms

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • terms
Répertoire de référence de terms

Répertoires

répertoire src

Fichiers

fichier terms.php


Joomla CMS: Répertoire de référence de Preinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Preinstall
Répertoire de référence de Preinstall

Fichiers

fichier installation/src/View/Preinstall/HtmlView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • text
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/text/tmpl/text.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | components/com_finder/src/Helper/FinderHelper.php
fichier | components/com_finder/src/Helper/RouteHelper.php


Joomla CMS: Répertoire de référence de bin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • bin
Répertoire de référence de bin

Fichiers

fichier extract-tentative-return-types.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
  • Command
Répertoire de référence de Command

Fichiers

fichier DebugEventDispatcherCommand.php


Joomla CMS: Répertoire de référence de media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • media
Répertoire de référence de media

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/media/media.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Event
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Rule
répertoire | Scheduler
répertoire | Table
répertoire | Task
répertoire | Traits
répertoire | View


Joomla CMS: Répertoire de référence de Server

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Server
Répertoire de référence de Server

Fichiers

fichier | var-dumper/Server/Connection.php
fichier | DumpServer.php


Joomla CMS: Répertoire de référence de history

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • history
Répertoire de référence de history

Fichiers

fichier administrator/components/com_contenthistory/tmpl/history/modal.php


Joomla CMS: Répertoire de référence de Searches

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Searches
Répertoire de référence de Searches

Fichiers

fichier administrator/components/com_finder/src/View/Searches/HtmlView.php


Joomla CMS: Répertoire de référence de preinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • preinstall
Répertoire de référence de preinstall

Fichiers

fichier installation/tmpl/preinstall/default.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | CategoriesHelper.php
fichier | CategoryAssociationHelper.php


Joomla CMS: Répertoire de référence de Installation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Field
  • Installation
Répertoire de référence de Installation

Fichiers

fichier | installation/src/Form/Field/Installation/LanguageField.php
fichier | PrefixField.php


Joomla CMS: Répertoire de référence de mod_latest

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
Répertoire de référence de mod_latest

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_latest.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Model
Répertoire de référence de Model

Fichiers

fichier BeforeBatchEvent.php


Joomla CMS: Répertoire de référence de system

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • system
Répertoire de référence de system

Fichiers

fichier | templates/system/component.php
fichier | templates/system/error.php
fichier | fatal.php
fichier | templates/system/index.php
fichier | system/offline.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_newsfeeds/src/Model/NewsfeedModel.php
fichier | NewsfeedsModel.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • confirmconsent
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier ConsentBoxField.php


Joomla CMS: Répertoire de référence de Inflector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Common
  • Inflector
Répertoire de référence de Inflector

Fichiers

fichier doctrine/inflector/lib/Doctrine/Common/Inflector/Inflector.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de brick

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
Répertoire de référence de brick

Répertoires

répertoire math


Joomla CMS: Répertoire de référence de mod_articles_category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
Répertoire de référence de mod_articles_category

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_articles_category.php


Joomla CMS: Répertoire de référence de Styles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
  • View
  • Styles
Répertoire de référence de Styles

Fichiers

fichier com_templates/src/View/Styles/JsonapiView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Capabilities
répertoire | Consents
répertoire | Export
répertoire | Request
répertoire | Requests


Joomla CMS: Répertoire de référence de Newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeeds
Répertoire de référence de Newsfeeds

Fichiers

fichier administrator/components/com_newsfeeds/src/View/Newsfeeds/HtmlView.php


Joomla CMS: Répertoire de référence de Component

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • View
  • Component
Répertoire de référence de Component

Fichiers

fichier administrator/components/com_config/src/View/Component/HtmlView.php


Joomla CMS: Répertoire de référence de Crypt

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Crypt
Répertoire de référence de Crypt

Répertoires

répertoire Cipher

Fichiers

fichier src/Crypt/Crypt.php


Joomla CMS: Répertoire de référence de com_config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
Répertoire de référence de com_config

Répertoires

répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | cloud.php
fichier | modules/mod_tags_popular/tmpl/default.php


Joomla CMS: Répertoire de référence de laminas

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
Répertoire de référence de laminas

Répertoires

répertoire | laminas-diactoros
répertoire | laminas-zendframework-bridge


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_users/services/provider.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | CacheConnectingException.php
fichier | CacheExceptionInterface.php
fichier | UnsupportedCacheException.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
  • services
Répertoire de référence de services

Fichiers

fichier plugins/api-authentication/basic/services/provider.php


Joomla CMS: Répertoire de référence de Banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • View
  • Banners
Répertoire de référence de Banners

Fichiers

fichier com_banners/src/View/Banners/JsonapiView.php


Joomla CMS: Répertoire de référence de Constraint

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
  • Constraint
Répertoire de référence de Constraint

Fichiers

fichier CommandIsSuccessful.php


Joomla CMS: Répertoire de référence de Modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
  • Modules
Répertoire de référence de Modules

Fichiers

fichier administrator/components/com_modules/src/View/Modules/HtmlView.php


Joomla CMS: Répertoire de référence de Method

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Method
Répertoire de référence de Method

Fichiers

fichier administrator/components/com_users/src/View/Method/HtmlView.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Categories
répertoire | Category


Joomla CMS: Répertoire de référence de Installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
Répertoire de référence de Installer

Répertoires

répertoire | Adapter
répertoire | Manifest

Fichiers

fichier | Installer.php
fichier | InstallerAdapter.php
fichier | InstallerExtension.php
fichier | libraries/src/Installer/InstallerHelper.php
fichier | InstallerScript.php
fichier | InstallerScriptInterface.php
fichier | LegacyInstallerScript.php
fichier | src/Installer/Manifest.php


Joomla CMS: Répertoire de référence de error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • error
Répertoire de référence de error

Fichiers

fichier backtrace.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_contact/src/Controller/ContactController.php
fichier | components/com_contact/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de debuggroup

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • debuggroup
Répertoire de référence de debuggroup

Fichiers

fichier administrator/components/com_users/tmpl/debuggroup/default.php


Joomla CMS: Répertoire de référence de build

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • build
Répertoire de référence de build

Fichiers

fichier | generate_docs.php
fichier | generate_max_key_length.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_messages/src/Controller/MessagesController.php


Joomla CMS: Répertoire de référence de Actionlogs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • View
  • Actionlogs
Répertoire de référence de Actionlogs

Fichiers

fichier administrator/components/com_actionlogs/src/View/Actionlogs/HtmlView.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier ExecuteTaskEvent.php


Joomla CMS: Répertoire de référence de Debuguser

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Debuguser
Répertoire de référence de Debuguser

Fichiers

fichier administrator/components/com_users/src/View/Debuguser/HtmlView.php


Joomla CMS: Répertoire de référence de Claim

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Répertoire de référence de Claim

Fichiers

fichier | libraries/vendor/lcobucci/jwt/src/Claim/Basic.php
fichier | EqualsTo.php
fichier | vendor/lcobucci/jwt/src/Claim/Factory.php
fichier | GreaterOrEqualsTo.php
fichier | LesserOrEqualsTo.php
fichier | Validatable.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
Répertoire de référence de src

Répertoires

répertoire | Application
répertoire | Controller
répertoire | Error
répertoire | Form
répertoire | Helper
répertoire | Model
répertoire | Response
répertoire | Router
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire | button
répertoire | content
répertoire | edit
répertoire | editors
répertoire | error
répertoire | form
répertoire | html
répertoire | icon
répertoire | installer
répertoire | links
répertoire | pagination
répertoire | quickicons
répertoire | searchtools
répertoire | sidebars
répertoire | system
répertoire | tinymce
répertoire | toolbar


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_contact/services/provider.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_wrapper/services/provider.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier FinderComponent.php


Joomla CMS: Répertoire de référence de database

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • database
Répertoire de référence de database

Fichiers

fichier administrator/components/com_installer/tmpl/database/default.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier FeedsController.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • joomla
Répertoire de référence de joomla

Fichiers

fichier plugins/content/joomla/joomla.php


Joomla CMS: Répertoire de référence de Http

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
Répertoire de référence de Http

Répertoires

répertoire Transport

Fichiers

fichier | src/Http/Http.php
fichier | src/Http/HttpFactory.php
fichier | libraries/src/Http/Response.php
fichier | src/Http/TransportInterface.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | ArticleTable.php
fichier | FeaturedTable.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • src
Répertoire de référence de src

Répertoires

répertoire | Dispatcher
répertoire | Helper


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Modules


Joomla CMS: Répertoire de référence de extensionupdate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • extensionupdate
Répertoire de référence de extensionupdate

Fichiers

fichier extensionupdate.php


Joomla CMS: Répertoire de référence de laragon

  • C:
  • laragon
Répertoire de référence de laragon

Répertoires

répertoire www


Joomla CMS: Répertoire de référence de com_banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
Répertoire de référence de com_banners

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_popular/tmpl/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
Répertoire de référence de src

Répertoires

répertoire Format

Fichiers

fichier | vendor/joomla/registry/src/Factory.php
fichier | FormatInterface.php
fichier | vendor/joomla/registry/src/Registry.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier UnableToWriteBody.php


Joomla CMS: Répertoire de référence de mod_languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_languages
Répertoire de référence de mod_languages

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_languages.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier administrator/components/com_checkin/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_modules
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Fixed.php


Joomla CMS: Répertoire de référence de featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • featured
Répertoire de référence de featured

Fichiers

fichier | components/com_contact/tmpl/featured/default.php
fichier | components/com_contact/tmpl/featured/default_items.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de includes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • includes
Répertoire de référence de includes

Fichiers

fichier | includes/app.php
fichier | includes/defines.php
fichier | includes/framework.php


Joomla CMS: Répertoire de référence de highlight

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • highlight
Répertoire de référence de highlight

Fichiers

fichier highlight.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latestactions
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_tags/src/Model/TagModel.php
fichier | components/com_tags/src/Model/TagsModel.php


Joomla CMS: Répertoire de référence de Response

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Response
Répertoire de référence de Response

Fichiers

fichier libraries/src/Response/JsonResponse.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Event
Répertoire de référence de Event

Fichiers

fichier | ConsoleCommandEvent.php
fichier | ConsoleErrorEvent.php
fichier | symfony/console/Event/ConsoleEvent.php
fichier | ConsoleSignalEvent.php
fichier | ConsoleTerminateEvent.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier UsersComponent.php


Joomla CMS: Répertoire de référence de EC

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
Répertoire de référence de EC

Répertoires

répertoire | BaseCurves
répertoire | Curves
répertoire | Formats

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/Parameters.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/PrivateKey.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/PublicKey.php


Joomla CMS: Répertoire de référence de remind

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • remind
Répertoire de référence de remind

Fichiers

fichier components/com_privacy/tmpl/remind/default.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal

Fichiers

fichier | CategoryeditField.php
fichier | ComponentsCategoryField.php


Joomla CMS: Répertoire de référence de Storage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Répertoire de référence de Storage

Fichiers

fichier | ApcuStorage.php
fichier | CacheStorageHelper.php
fichier | libraries/src/Cache/Storage/FileStorage.php
fichier | src/Cache/Storage/MemcachedStorage.php
fichier | src/Cache/Storage/RedisStorage.php
fichier | WincacheStorage.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | StyleModel.php
fichier | StylesModel.php
fichier | com_templates/src/Model/TemplateModel.php
fichier | administrator/components/com_templates/src/Model/TemplatesModel.php


Joomla CMS: Répertoire de référence de Style

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Style
Répertoire de référence de Style

Fichiers

fichier | OutputStyle.php
fichier | StyleInterface.php
fichier | SymfonyStyle.php


Joomla CMS: Répertoire de référence de Export

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Export
Répertoire de référence de Export

Fichiers

fichier com_privacy/src/View/Export/XmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_config/services/provider.php


Joomla CMS: Répertoire de référence de com_cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
Répertoire de référence de com_cache

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de ASN1

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Répertoire de référence de ASN1

Répertoires

répertoire | Composite
répertoire | Exception
répertoire | Universal

Fichiers

fichier | fgrosse/phpasn1/lib/ASN1/AbstractString.php
fichier | AbstractTime.php
fichier | ASNObject.php
fichier | Base128.php
fichier | Construct.php
fichier | ExplicitlyTaggedObject.php
fichier | Identifier.php
fichier | OID.php
fichier | Parsable.php
fichier | TemplateParser.php
fichier | UnknownConstructedObject.php
fichier | UnknownObject.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
Répertoire de référence de src

Répertoires

répertoire | Extension
répertoire | Field
répertoire | Hotfix
répertoire | PluginTraits

Fichiers

fichier | plugins/system/webauthn/src/Authentication.php
fichier | system/webauthn/src/CredentialRepository.php
fichier | MetadataRepository.php


Joomla CMS: Répertoire de référence de Styles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Styles
Répertoire de référence de Styles

Fichiers

fichier administrator/components/com_templates/src/View/Styles/HtmlView.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier TemplatesComponent.php


Joomla CMS: Répertoire de référence de warnings

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • warnings
Répertoire de référence de warnings

Fichiers

fichier | administrator/components/com_installer/tmpl/warnings/default.php
fichier | administrator/components/com_installer/tmpl/warnings/emptystate.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Transitions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Transitions
Répertoire de référence de Transitions

Fichiers

fichier administrator/components/com_workflow/src/View/Transitions/HtmlView.php


Joomla CMS: Répertoire de référence de Items

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • View
  • Items
Répertoire de référence de Items

Fichiers

fichier com_menus/src/View/Items/JsonapiView.php


Joomla CMS: Répertoire de référence de Object

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Object
Répertoire de référence de Object

Fichiers

fichier CMSObject.php


Joomla CMS: Répertoire de référence de modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
Répertoire de référence de modules

Répertoires

répertoire | mod_custom
répertoire | mod_feed
répertoire | mod_frontend
répertoire | mod_latest
répertoire | mod_latestactions
répertoire | mod_logged
répertoire | mod_login
répertoire | mod_loginsupport
répertoire | mod_menu
répertoire | mod_messages
répertoire | mod_multilangstatus
répertoire | mod_popular
répertoire | mod_post_installation_messages
répertoire | mod_privacy_dashboard
répertoire | mod_privacy_status
répertoire | mod_quickicon
répertoire | mod_sampledata
répertoire | mod_stats_admin
répertoire | mod_submenu
répertoire | mod_title
répertoire | mod_toolbar
répertoire | mod_user
répertoire | mod_version


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier ConfigComponent.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Cpanel


Joomla CMS: Répertoire de référence de mod_popular

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
Répertoire de référence de mod_popular

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_popular.php


Joomla CMS: Répertoire de référence de Algorithm

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
Répertoire de référence de Algorithm

Répertoires

répertoire | Mac
répertoire | Signature

Fichiers

fichier | web-auth/cose-lib/src/Algorithm/Algorithm.php
fichier | web-auth/cose-lib/src/Algorithm/Manager.php
fichier | ManagerFactory.php


Joomla CMS: Répertoire de référence de Remove

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Remove
Répertoire de référence de Remove

Fichiers

fichier installation/src/View/Remove/HtmlView.php


Joomla CMS: Répertoire de référence de www

  • C:
  • laragon
  • www
Répertoire de référence de www

Répertoires

répertoire _install


Joomla CMS: Répertoire de référence de Filesystem

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Répertoire de référence de Filesystem

Répertoires

répertoire | Streams
répertoire | Support

Fichiers

fichier | src/Filesystem/File.php
fichier | FilesystemHelper.php
fichier | src/Filesystem/Folder.php
fichier | src/Filesystem/Patcher.php
fichier | src/Filesystem/Path.php
fichier | src/Filesystem/Stream.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_footer
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_footer/tmpl/default.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_menus/src/Controller/ItemsController.php
fichier | api/components/com_menus/src/Controller/MenusController.php


Joomla CMS: Répertoire de référence de web-link

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
Répertoire de référence de web-link

Répertoires

répertoire EventListener

Fichiers

fichier | symfony/web-link/GenericLinkProvider.php
fichier | HttpHeaderSerializer.php
fichier | symfony/web-link/Link.php


Joomla CMS: Répertoire de référence de Fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Fields
Répertoire de référence de Fields

Fichiers

fichier administrator/components/com_fields/src/View/Fields/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
Répertoire de référence de src

Répertoires

répertoire | Command
répertoire | Descriptor
répertoire | Event
répertoire | Exception
répertoire | Helper
répertoire | Loader

Fichiers

fichier | libraries/vendor/joomla/console/src/Application.php
fichier | joomla/console/src/ConsoleEvents.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Captive
répertoire | Login
répertoire | Method
répertoire | Methods
répertoire | Profile
répertoire | Registration
répertoire | Remind
répertoire | Reset


Joomla CMS: Répertoire de référence de Mail

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Mail
Répertoire de référence de Mail

Fichiers

fichier administrator/components/com_users/src/View/Mail/HtmlView.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_config/src/Service/Router.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Répertoire de référence de src

Répertoires

répertoire | Core
répertoire | Core32
répertoire | PHP52

Fichiers

fichier | src/Compat.php
fichier | vendor/paragonie/sodium_compat/src/Crypto.php
fichier | Crypto32.php
fichier | vendor/paragonie/sodium_compat/src/File.php
fichier | SodiumException.php


Joomla CMS: Répertoire de référence de Rules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Répertoire de référence de Rules

Répertoires

répertoire | English
répertoire | French
répertoire | NorwegianBokmal
répertoire | Portuguese
répertoire | Spanish
répertoire | Turkish

Fichiers

fichier | Pattern.php
fichier | Patterns.php
fichier | Ruleset.php
fichier | Substitution.php
fichier | Substitutions.php
fichier | Transformation.php
fichier | Transformations.php
fichier | Word.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Field
Répertoire de référence de Field

Répertoires

répertoire Installation


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Joomla.php


Joomla CMS: Répertoire de référence de Article

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Article
Répertoire de référence de Article

Fichiers

fichier administrator/components/com_content/src/View/Article/HtmlView.php


Joomla CMS: Répertoire de référence de Indexer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Répertoire de référence de Indexer

Répertoires

répertoire | Language
répertoire | Parser

Fichiers

fichier | administrator/components/com_finder/src/Indexer/Adapter.php
fichier | administrator/components/com_finder/src/Indexer/Helper.php
fichier | Indexer.php
fichier | administrator/components/com_finder/src/Indexer/Language.php
fichier | administrator/components/com_finder/src/Indexer/Parser.php
fichier | administrator/components/com_finder/src/Indexer/Query.php
fichier | Result.php
fichier | Taxonomy.php
fichier | administrator/components/com_finder/src/Indexer/Token.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Fields
répertoire | Groups


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | AdaptersController.php
fichier | MediaController.php


Joomla CMS: Répertoire de référence de Serializer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Répertoire de référence de Serializer

Fichiers

fichier | CompactSerializer.php
fichier | JSONFlattenedSerializer.php
fichier | JSONGeneralSerializer.php
fichier | JWSSerializer.php
fichier | JWSSerializerManager.php
fichier | JWSSerializerManagerFactory.php
fichier | web-token/jwt-signature/Serializer/Serializer.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • webinstaller
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/installer/webinstaller/tmpl/default.php


Joomla CMS: Répertoire de référence de Checkin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • View
  • Checkin
Répertoire de référence de Checkin

Fichiers

fichier administrator/components/com_checkin/src/View/Checkin/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PrivacyHelper.php


Joomla CMS: Répertoire de référence de logout

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • logout
Répertoire de référence de logout

Fichiers

fichier logout.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ModuleModel.php
fichier | administrator/components/com_modules/src/Model/ModulesModel.php
fichier | PositionsModel.php
fichier | com_modules/src/Model/SelectModel.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | AdapterModel.php
fichier | AdaptersModel.php
fichier | api/components/com_media/src/Model/MediaModel.php
fichier | MediumModel.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_content/helpers/content.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire Provider


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier modules/mod_articles_latest/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de list

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • list
Répertoire de référence de list

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/list/list.php


Joomla CMS: Répertoire de référence de Association

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • View
  • Association
Répertoire de référence de Association

Fichiers

fichier administrator/components/com_associations/src/View/Association/HtmlView.php


Joomla CMS: Répertoire de référence de chromes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
  • chromes
Répertoire de référence de chromes

Fichiers

fichier | administrator/templates/atum/html/layouts/chromes/body.php
fichier | header-item.php
fichier | administrator/templates/atum/html/layouts/chromes/title.php
fichier | well.php


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • contact
Répertoire de référence de contact

Fichiers

fichier | components/com_contact/tmpl/contact/default.php
fichier | default_address.php
fichier | com_contact/tmpl/contact/default_articles.php
fichier | com_contact/tmpl/contact/default_form.php
fichier | com_contact/tmpl/contact/default_links.php
fichier | default_profile.php
fichier | default_user_custom_fields.php


Joomla CMS: Répertoire de référence de workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • workflow
Répertoire de référence de workflow

Fichiers

fichier administrator/components/com_workflow/tmpl/workflow/edit.php


Joomla CMS: Répertoire de référence de categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • tmpl
  • categories
Répertoire de référence de categories

Fichiers

fichier | administrator/components/com_categories/tmpl/categories/default.php
fichier | com_categories/tmpl/categories/default_batch_body.php
fichier | com_categories/tmpl/categories/default_batch_footer.php
fichier | administrator/components/com_categories/tmpl/categories/emptystate.php
fichier | administrator/components/com_categories/tmpl/categories/modal.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire data

Fichiers

fichier symfony/string/Resources/functions.php


Joomla CMS: Répertoire de référence de plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • plugins
Répertoire de référence de plugins

Fichiers

fichier plugins/webservices/plugins/plugins.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | BadConfigurationException.php
fichier | BadDecryptionException.php
fichier | BadModeException.php
fichier | ConnectionClosedException.php
fichier | libraries/vendor/phpseclib/phpseclib/phpseclib/Exception/FileNotFoundException.php
fichier | InconsistentSetupException.php
fichier | InsufficientSetupException.php
fichier | NoKeyLoadedException.php
fichier | NoSupportedAlgorithmsException.php
fichier | UnableToConnectException.php
fichier | UnsupportedAlgorithmException.php
fichier | UnsupportedCurveException.php
fichier | UnsupportedFormatException.php
fichier | phpseclib/phpseclib/phpseclib/Exception/UnsupportedOperationException.php


Joomla CMS: Répertoire de référence de Templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Templates
Répertoire de référence de Templates

Fichiers

fichier administrator/components/com_templates/src/View/Templates/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Répertoire de référence de src

Répertoires

répertoire | AttestationStatement
répertoire | AuthenticationExtensions
répertoire | TokenBinding
répertoire | TrustPath
répertoire | Util

Fichiers

fichier | AttestedCredentialData.php
fichier | AuthenticatorAssertionResponse.php
fichier | AuthenticatorAssertionResponseValidator.php
fichier | AuthenticatorAttestationResponse.php
fichier | AuthenticatorAttestationResponseValidator.php
fichier | AuthenticatorData.php
fichier | AuthenticatorResponse.php
fichier | AuthenticatorSelectionCriteria.php
fichier | CertificateToolbox.php
fichier | CollectedClientData.php
fichier | Credential.php
fichier | PublicKeyCredential.php
fichier | PublicKeyCredentialCreationOptions.php
fichier | PublicKeyCredentialDescriptor.php
fichier | PublicKeyCredentialDescriptorCollection.php
fichier | PublicKeyCredentialEntity.php
fichier | PublicKeyCredentialLoader.php
fichier | PublicKeyCredentialOptions.php
fichier | PublicKeyCredentialParameters.php
fichier | PublicKeyCredentialRequestOptions.php
fichier | PublicKeyCredentialRpEntity.php
fichier | PublicKeyCredentialSource.php
fichier | PublicKeyCredentialSourceRepository.php
fichier | PublicKeyCredentialUserEntity.php
fichier | libraries/vendor/web-auth/webauthn-lib/src/Server.php
fichier | web-auth/webauthn-lib/src/StringStream.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire checkin


Joomla CMS: Répertoire de référence de Association

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Association
Répertoire de référence de Association

Fichiers

fichier | AssociationExtensionHelper.php
fichier | AssociationExtensionInterface.php
fichier | AssociationServiceInterface.php
fichier | AssociationServiceTrait.php


Joomla CMS: Répertoire de référence de versionable

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
Répertoire de référence de versionable

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • config
Répertoire de référence de config

Fichiers

fichier | components/com_config/tmpl/config/default.php
fichier | components/com_config/tmpl/config/default_metadata.php
fichier | components/com_config/tmpl/config/default_seo.php
fichier | components/com_config/tmpl/config/default_site.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | BannerclientField.php
fichier | ClicksField.php
fichier | ImpmadeField.php
fichier | ImptotalField.php


Joomla CMS: Répertoire de référence de Document

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Répertoire de référence de Document

Répertoires

répertoire | Feed
répertoire | Opensearch
répertoire | Renderer

Fichiers

fichier | src/Document/Document.php
fichier | DocumentRenderer.php
fichier | ErrorDocument.php
fichier | src/Document/Factory.php
fichier | FactoryInterface.php
fichier | FeedDocument.php
fichier | HtmlDocument.php
fichier | ImageDocument.php
fichier | JsonapiDocument.php
fichier | JsonDocument.php
fichier | OpensearchDocument.php
fichier | PreloadManager.php
fichier | PreloadManagerInterface.php
fichier | RawDocument.php
fichier | Document/RendererInterface.php
fichier | XmlDocument.php


Joomla CMS: Répertoire de référence de basic

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
Répertoire de référence de basic

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier BannersComponent.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Processor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
  • Processor
Répertoire de référence de Processor

Fichiers

fichier | ColorProcessor.php
fichier | ProcessorInterface.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_newsfeeds/src/Helper/AssociationHelper.php
fichier | components/com_newsfeeds/src/Helper/RouteHelper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
Répertoire de référence de src

Répertoires

répertoire voku


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • jakeasmith
  • http_build_url
  • src
Répertoire de référence de src

Fichiers

fichier http_build_url.php


Joomla CMS: Répertoire de référence de select

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
  • select
Répertoire de référence de select

Fichiers

fichier | administrator/components/com_modules/tmpl/select/default.php
fichier | administrator/components/com_modules/tmpl/select/modal.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_title
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_title/tmpl/default.php


Joomla CMS: Répertoire de référence de Featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Featured
Répertoire de référence de Featured

Fichiers

fichier administrator/components/com_content/src/View/Featured/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de mod_submenu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
Répertoire de référence de mod_submenu

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_submenu.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_workflow/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de com_contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
Répertoire de référence de com_contact

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Article
répertoire | Articles
répertoire | Featured


Joomla CMS: Répertoire de référence de user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • user
Répertoire de référence de user

Fichiers

fichier | administrator/components/com_users/tmpl/user/edit.php
fichier | edit_groups.php


Joomla CMS: Répertoire de référence de terms

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
  • terms
Répertoire de référence de terms

Fichiers

fichier | user/terms/label.php
fichier | layouts/plugins/user/terms/message.php


Joomla CMS: Répertoire de référence de Tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • View
  • Tags
Répertoire de référence de Tags

Fichiers

fichier administrator/components/com_tags/src/View/Tags/HtmlView.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_banners/src/Model/BannerModel.php
fichier | administrator/components/com_banners/src/Model/BannersModel.php
fichier | ClientModel.php
fichier | ClientsModel.php
fichier | DownloadModel.php
fichier | TracksModel.php


Joomla CMS: Répertoire de référence de voku

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
Répertoire de référence de voku

Répertoires

répertoire helper


Joomla CMS: Répertoire de référence de Keys

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Répertoire de référence de Keys

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/Formats/Keys/Common.php
fichier | libsodium.php
fichier | MontgomeryPrivate.php
fichier | MontgomeryPublic.php
fichier | EC/Formats/Keys/OpenSSH.php
fichier | EC/Formats/Keys/PKCS1.php
fichier | EC/Formats/Keys/PKCS8.php
fichier | EC/Formats/Keys/PuTTY.php
fichier | EC/Formats/Keys/XML.php


Joomla CMS: Répertoire de référence de client

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • client
Répertoire de référence de client

Fichiers

fichier administrator/components/com_banners/tmpl/client/edit.php


Joomla CMS: Répertoire de référence de blog

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • sampledata
  • blog
Répertoire de référence de blog

Fichiers

fichier plugins/sampledata/blog/blog.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_privacy/services/provider.php


Joomla CMS: Répertoire de référence de system

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
Répertoire de référence de system

Répertoires

répertoire | privacyconsent
répertoire | webauthn


Joomla CMS: Répertoire de référence de Requests

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Requests
Répertoire de référence de Requests

Fichiers

fichier administrator/components/com_privacy/src/View/Requests/HtmlView.php


Joomla CMS: Répertoire de référence de com_contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
Répertoire de référence de com_contact

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Image

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
Répertoire de référence de Image

Répertoires

répertoire | Exception
répertoire | Filter

Fichiers

fichier | Image.php
fichier | ImageFilter.php


Joomla CMS: Répertoire de référence de math

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
Répertoire de référence de math

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_menus/src/Helper/AssociationsHelper.php
fichier | MenusHelper.php


Joomla CMS: Répertoire de référence de bootstrap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
Répertoire de référence de bootstrap

Répertoires

répertoire | modal
répertoire | tab


Joomla CMS: Répertoire de référence de mod_feed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
Répertoire de référence de mod_feed

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier modules/mod_feed/mod_feed.php


Joomla CMS: Répertoire de référence de Contacts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • View
  • Contacts
Répertoire de référence de Contacts

Fichiers

fichier com_contact/src/View/Contacts/JsonapiView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_stats/tmpl/default.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Application
répertoire | Component


Joomla CMS: Répertoire de référence de html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
Répertoire de référence de html

Répertoires

répertoire | layouts
répertoire | mod_custom
répertoire | mod_menu


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ComponentsWorkflowField.php
fichier | WorkflowcontextsField.php


Joomla CMS: Répertoire de référence de Inflector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Inflector
Répertoire de référence de Inflector

Fichiers

fichier | EnglishInflector.php
fichier | FrenchInflector.php
fichier | InflectorInterface.php


Joomla CMS: Répertoire de référence de banner

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banner
Répertoire de référence de banner

Fichiers

fichier administrator/components/com_banners/tmpl/banner/edit.php


Joomla CMS: Répertoire de référence de Group

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Group
Répertoire de référence de Group

Fichiers

fichier administrator/components/com_fields/src/View/Group/HtmlView.php


Joomla CMS: Répertoire de référence de Hotfix

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Hotfix
Répertoire de référence de Hotfix

Fichiers

fichier | plugins/multifactorauth/webauthn/src/Hotfix/AndroidKeyAttestationStatementSupport.php
fichier | plugins/multifactorauth/webauthn/src/Hotfix/FidoU2FAttestationStatementSupport.php
fichier | plugins/multifactorauth/webauthn/src/Hotfix/Server.php


Joomla CMS: Répertoire de référence de config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • config
Répertoire de référence de config

Fichiers

fichier config.php


Joomla CMS: Répertoire de référence de Installed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
  • Installed
Répertoire de référence de Installed

Fichiers

fichier administrator/components/com_languages/src/View/Installed/HtmlView.php


Joomla CMS: Répertoire de référence de com_modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
Répertoire de référence de com_modules

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de log

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • log
Répertoire de référence de log

Répertoires

répertoire Psr


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_menus/helpers/menus.php


Joomla CMS: Répertoire de référence de symfony

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
Répertoire de référence de symfony

Répertoires

répertoire | console
répertoire | deprecation-contracts
répertoire | error-handler
répertoire | ldap
répertoire | options-resolver
répertoire | polyfill-ctype
répertoire | polyfill-iconv
répertoire | polyfill-intl-grapheme
répertoire | polyfill-intl-normalizer
répertoire | polyfill-mbstring
répertoire | polyfill-php72
répertoire | polyfill-php73
répertoire | polyfill-php80
répertoire | service-contracts
répertoire | string
répertoire | var-dumper
répertoire | web-link
répertoire | yaml


Joomla CMS: Répertoire de référence de Response

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Response
Répertoire de référence de Response

Fichiers

fichier installation/src/Response/JsonResponse.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Joomlaupdate
répertoire | Update
répertoire | Upload


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire cpanel


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • url
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/url/tmpl/url.php


Joomla CMS: Répertoire de référence de Stream

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Stream
Répertoire de référence de Stream

Fichiers

fichier StringWrapper.php


Joomla CMS: Répertoire de référence de Signature

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Signature
Répertoire de référence de Signature

Fichiers

fichier | Crypt/EC/Formats/Signature/ASN1.php
fichier | EC/Formats/Signature/Raw.php
fichier | Crypt/EC/Formats/Signature/SSH2.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier com_postinstall/src/Model/MessagesModel.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | application
répertoire | component


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier CategoriesComponent.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
Répertoire de référence de src

Répertoires

répertoire | Extension
répertoire | Helper
répertoire | Hotfix

Fichiers

fichier multifactorauth/webauthn/src/CredentialRepository.php


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
Répertoire de référence de form

Répertoires

répertoire field

Fichiers

fichier | renderfield.php
fichier | renderlabel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher


Joomla CMS: Répertoire de référence de Keys

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
  • Formats
  • Keys
Répertoire de référence de Keys

Fichiers

fichier | DH/Formats/Keys/PKCS1.php
fichier | DH/Formats/Keys/PKCS8.php


Joomla CMS: Répertoire de référence de tinymce

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
Répertoire de référence de tinymce

Répertoires

répertoire field


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Répertoire de référence de src

Fichiers

fichier | MessageInterface.php
fichier | RequestInterface.php
fichier | ResponseInterface.php
fichier | ServerRequestInterface.php
fichier | StreamInterface.php
fichier | UploadedFileInterface.php
fichier | psr/http-message/src/UriInterface.php


Joomla CMS: Répertoire de référence de Modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Modules
Répertoire de référence de Modules

Fichiers

fichier components/com_config/src/View/Modules/HtmlView.php


Joomla CMS: Répertoire de référence de tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tags
Répertoire de référence de tags

Fichiers

fichier | components/com_tags/tmpl/tags/default.php
fichier | components/com_tags/tmpl/tags/default_items.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_users/src/Controller/GroupsController.php
fichier | api/components/com_users/src/Controller/LevelsController.php
fichier | api/components/com_users/src/Controller/UsersController.php


Joomla CMS: Répertoire de référence de functions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Resources
  • functions
Répertoire de référence de functions

Fichiers

fichier dump.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | contact
répertoire | contacts


Joomla CMS: Répertoire de référence de Google

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Captcha
  • Google
Répertoire de référence de Google

Fichiers

fichier HttpBridgePostRequestMethod.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier QuickIconsEvent.php


Joomla CMS: Répertoire de référence de toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • layouts
  • toolbar
Répertoire de référence de toolbar

Fichiers

fichier administrator/components/com_redirect/layouts/toolbar/batch.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier WrapperComponent.php


Joomla CMS: Répertoire de référence de Descriptor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
  • Descriptor
Répertoire de référence de Descriptor

Fichiers

fichier | CliDescriptor.php
fichier | DumpDescriptorInterface.php
fichier | HtmlDescriptor.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de com_tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
Répertoire de référence de com_tags

Répertoires

répertoire | helpers
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de error

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • error
Répertoire de référence de error

Fichiers

fichier installation/tmpl/error/default.php


Joomla CMS: Répertoire de référence de User

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • User
Répertoire de référence de User

Fichiers

fichier administrator/components/com_users/src/View/User/HtmlView.php


Joomla CMS: Répertoire de référence de webmozart

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • webmozart
Répertoire de référence de webmozart

Répertoires

répertoire assert


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • fields
Répertoire de référence de fields

Fichiers

fichier plugins/content/fields/fields.php


Joomla CMS: Répertoire de référence de Message

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Message
Répertoire de référence de Message

Fichiers

fichier administrator/components/com_messages/src/View/Message/HtmlView.php


Joomla CMS: Répertoire de référence de WebAsset

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Répertoire de référence de WebAsset

Répertoires

répertoire | AssetItem
répertoire | Exception

Fichiers

fichier | WebAssetAttachBehaviorInterface.php
fichier | WebAssetItem.php
fichier | WebAssetItemInterface.php
fichier | WebAssetManager.php
fichier | WebAssetManagerInterface.php
fichier | WebAsset/WebAssetRegistry.php
fichier | WebAssetRegistryInterface.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire functions


Joomla CMS: Répertoire de référence de Core32

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Répertoire de référence de Core32

Répertoires

répertoire | ChaCha20
répertoire | Curve25519
répertoire | Poly1305
répertoire | SecretStream

Fichiers

fichier | src/Core32/BLAKE2b.php
fichier | paragonie/sodium_compat/src/Core32/ChaCha20.php
fichier | paragonie/sodium_compat/src/Core32/Curve25519.php
fichier | paragonie/sodium_compat/src/Core32/Ed25519.php
fichier | src/Core32/HChaCha20.php
fichier | src/Core32/HSalsa20.php
fichier | Int32.php
fichier | Int64.php
fichier | src/Core32/Poly1305.php
fichier | paragonie/sodium_compat/src/Core32/Salsa20.php
fichier | src/Core32/SipHash.php
fichier | paragonie/sodium_compat/src/Core32/Util.php
fichier | src/Core32/X25519.php
fichier | src/Core32/XChaCha20.php
fichier | 2/XSalsa20.php


Joomla CMS: Répertoire de référence de system

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • system
Répertoire de référence de system

Fichiers

fichier | administrator/templates/system/component.php
fichier | administrator/templates/system/error.php
fichier | administrator/templates/system/index.php


Joomla CMS: Répertoire de référence de group

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • group
Répertoire de référence de group

Fichiers

fichier administrator/components/com_users/tmpl/group/edit.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ActionlogsHelper.php


Joomla CMS: Répertoire de référence de Language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Répertoire de référence de Language

Fichiers

fichier | Associations.php
fichier | CachingLanguageFactory.php
fichier | libraries/src/Language/Language.php
fichier | LanguageFactory.php
fichier | LanguageFactoryInterface.php
fichier | libraries/src/Language/LanguageHelper.php
fichier | Multilanguage.php
fichier | Text.php
fichier | Transliterate.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier BannerHelper.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_scheduler/src/Controller/DisplayController.php
fichier | TaskController.php
fichier | TasksController.php


Joomla CMS: Répertoire de référence de Common

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
  • Common
Répertoire de référence de Common

Répertoires

répertoire Traits


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • fields
Répertoire de référence de fields

Fichiers

fichier plugins/editors-xtd/fields/fields.php


Joomla CMS: Répertoire de référence de Newsfeed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • View
  • Newsfeed
Répertoire de référence de Newsfeed

Fichiers

fichier administrator/components/com_newsfeeds/src/View/Newsfeed/HtmlView.php


Joomla CMS: Répertoire de référence de request

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • request
Répertoire de référence de request

Fichiers

fichier | administrator/components/com_privacy/tmpl/request/default.php
fichier | administrator/components/com_privacy/tmpl/request/edit.php


Joomla CMS: Répertoire de référence de mod_title

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_title
Répertoire de référence de mod_title

Répertoires

répertoire tmpl

Fichiers

fichier mod_title.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | InstalledModel.php
fichier | LanguageModel.php
fichier | administrator/components/com_languages/src/Model/LanguagesModel.php
fichier | OverrideModel.php
fichier | OverridesModel.php
fichier | StringsModel.php


Joomla CMS: Répertoire de référence de Renderer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Répertoire de référence de Renderer

Fichiers

fichier | CliRenderer.php
fichier | FeedRenderer.php
fichier | HtmlRenderer.php
fichier | JsonapiRenderer.php
fichier | libraries/src/Error/Renderer/JsonRenderer.php
fichier | XmlRenderer.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | AlreadyExistsException.php
fichier | ConnectionException.php
fichier | ConnectionTimeoutException.php
fichier | DriverNotFoundException.php
fichier | symfony/ldap/Exception/ExceptionInterface.php
fichier | InvalidCredentialsException.php
fichier | LdapException.php
fichier | NotBoundException.php
fichier | UpdateOperationException.php


Joomla CMS: Répertoire de référence de groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • groups
Répertoire de référence de groups

Fichiers

fichier administrator/components/com_users/tmpl/groups/default.php


Joomla CMS: Répertoire de référence de Contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Contact
Répertoire de référence de Contact

Fichiers

fichier | components/com_contact/src/View/Contact/HtmlView.php
fichier | VcfView.php


Joomla CMS: Répertoire de référence de component

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • component
Répertoire de référence de component

Fichiers

fichier | administrator/components/com_config/tmpl/component/default.php
fichier | component/default_navigation.php


Joomla CMS: Répertoire de référence de Builder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Builder
Répertoire de référence de Builder

Fichiers

fichier | DefaultUuidBuilder.php
fichier | DegradedUuidBuilder.php
fichier | UuidBuilderInterface.php


Joomla CMS: Répertoire de référence de messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • tmpl
  • messages
Répertoire de référence de messages

Fichiers

fichier | administrator/components/com_postinstall/tmpl/messages/default.php
fichier | administrator/components/com_postinstall/tmpl/messages/emptystate.php


Joomla CMS: Répertoire de référence de sysinfo

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • tmpl
  • sysinfo
Répertoire de référence de sysinfo

Fichiers

fichier | administrator/components/com_admin/tmpl/sysinfo/default.php
fichier | default_config.php
fichier | default_directory.php
fichier | default_phpinfo.php
fichier | default_phpsettings.php
fichier | default_system.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | willdurand/negotiation/src/Negotiation/Exception/Exception.php
fichier | InvalidArgument.php
fichier | InvalidHeader.php
fichier | InvalidLanguage.php
fichier | InvalidMediaType.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | tag
répertoire | tags


Joomla CMS: Répertoire de référence de ECDSA

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • ECDSA
Répertoire de référence de ECDSA

Fichiers

fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECDSA.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ECSignature.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES256K.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES384.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/ECDSA/ES512.php


Joomla CMS: Répertoire de référence de Export

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Export
Répertoire de référence de Export

Fichiers

fichier | Domain.php
fichier | Field.php
fichier | Item.php


Joomla CMS: Répertoire de référence de utilities

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • utilities
Répertoire de référence de utilities

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire joomla


Joomla CMS: Répertoire de référence de Monitor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Monitor
Répertoire de référence de Monitor

Fichiers

fichier | ChainedMonitor.php
fichier | DebugMonitor.php
fichier | LoggingMonitor.php


Joomla CMS: Répertoire de référence de users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • users
Répertoire de référence de users

Fichiers

fichier | administrator/components/com_users/tmpl/users/default.php
fichier | com_users/tmpl/users/default_batch_body.php
fichier | com_users/tmpl/users/default_batch_footer.php
fichier | administrator/components/com_users/tmpl/users/modal.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_media
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_media/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Debug

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Debug
Répertoire de référence de Debug

Fichiers

fichier OptionsResolverIntrospector.php


Joomla CMS: Répertoire de référence de Template

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
  • Template
Répertoire de référence de Template

Fichiers

fichier administrator/components/com_templates/src/View/Template/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Répertoire de référence de src

Répertoires

répertoire Command

Fichiers

fichier | vendor/joomla/event/src/AbstractEvent.php
fichier | libraries/vendor/joomla/event/src/Dispatcher.php
fichier | DispatcherAwareInterface.php
fichier | DispatcherAwareTrait.php
fichier | vendor/joomla/event/src/DispatcherInterface.php
fichier | Event.php
fichier | EventImmutable.php
fichier | EventInterface.php
fichier | LazyServiceEventListener.php
fichier | ListenersPriorityQueue.php
fichier | Priority.php
fichier | SubscriberInterface.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_tags/src/Service/Router.php


Joomla CMS: Répertoire de référence de levels

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • levels
Répertoire de référence de levels

Fichiers

fichier administrator/components/com_users/tmpl/levels/default.php


Joomla CMS: Répertoire de référence de Core

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Répertoire de référence de Core

Répertoires

répertoire | Base64
répertoire | ChaCha20
répertoire | Curve25519
répertoire | Poly1305
répertoire | SecretStream

Fichiers

fichier | src/Core/BLAKE2b.php
fichier | paragonie/sodium_compat/src/Core/ChaCha20.php
fichier | paragonie/sodium_compat/src/Core/Curve25519.php
fichier | paragonie/sodium_compat/src/Core/Ed25519.php
fichier | src/Core/HChaCha20.php
fichier | src/Core/HSalsa20.php
fichier | src/Core/Poly1305.php
fichier | Ristretto255.php
fichier | paragonie/sodium_compat/src/Core/Salsa20.php
fichier | src/Core/SipHash.php
fichier | paragonie/sodium_compat/src/Core/Util.php
fichier | src/Core/X25519.php
fichier | src/Core/XChaCha20.php
fichier | XSalsa20.php


Joomla CMS: Répertoire de référence de Methods

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Methods
Répertoire de référence de Methods

Fichiers

fichier administrator/components/com_users/src/View/Methods/HtmlView.php


Joomla CMS: Répertoire de référence de Signer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Répertoire de référence de Signer

Répertoires

répertoire | Ecdsa
répertoire | Hmac
répertoire | Key
répertoire | Rsa

Fichiers

fichier | BaseSigner.php
fichier | CannotSignPayload.php
fichier | Ecdsa.php
fichier | lcobucci/jwt/src/Signer/Hmac.php
fichier | InvalidKeyProvided.php
fichier | lcobucci/jwt/src/Signer/Key.php
fichier | Keychain.php
fichier | lcobucci/jwt/src/Signer/None.php
fichier | vendor/lcobucci/jwt/src/Signer/OpenSSL.php
fichier | Rsa.php


Joomla CMS: Répertoire de référence de Logger

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Répertoire de référence de Logger

Fichiers

fichier | CallbackLogger.php
fichier | DatabaseLogger.php
fichier | EchoLogger.php
fichier | FormattedtextLogger.php
fichier | InMemoryLogger.php
fichier | MessagequeueLogger.php
fichier | SyslogLogger.php
fichier | W3cLogger.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_contact/helpers/contact.php


Joomla CMS: Répertoire de référence de banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • banners
Répertoire de référence de banners

Fichiers

fichier plugins/webservices/banners/banners.php


Joomla CMS: Répertoire de référence de method

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • method
Répertoire de référence de method

Fichiers

fichier | administrator/components/com_users/tmpl/method/backupcodes.php
fichier | administrator/components/com_users/tmpl/method/edit.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
  • field
Répertoire de référence de field

Fichiers

fichier | data.php
fichier | uniqueid.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
  • Exception
Répertoire de référence de Exception

Fichiers

fichier MailDisabledException.php


Joomla CMS: Répertoire de référence de stats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
Répertoire de référence de stats

Répertoires

répertoire | layouts
répertoire | src

Fichiers

fichier stats.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier UpdatesiteTable.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | PluginElementField.php
fichier | PluginorderingField.php
fichier | PluginTypeField.php


Joomla CMS: Répertoire de référence de polyfill-ctype

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-ctype
Répertoire de référence de polyfill-ctype

Fichiers

fichier | vendor/symfony/polyfill-ctype/bootstrap.php
fichier | polyfill-ctype/bootstrap80.php
fichier | Ctype.php


Joomla CMS: Répertoire de référence de com_wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
Répertoire de référence de com_wrapper

Répertoires

répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tinymcebuilder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
  • field
  • tinymcebuilder
Répertoire de référence de tinymcebuilder

Fichiers

fichier | setaccess.php
fichier | setoptions.php


Joomla CMS: Répertoire de référence de Portuguese

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Répertoire de référence de Portuguese

Fichiers

fichier | Portuguese/Inflectible.php
fichier | Rules/Portuguese/InflectorFactory.php
fichier | vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Portuguese/Rules.php
fichier | Portuguese/Uninflected.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_privacy/src/Service/Router.php


Joomla CMS: Répertoire de référence de folderinstaller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • folderinstaller
Répertoire de référence de folderinstaller

Répertoires

répertoire tmpl

Fichiers

fichier folderinstaller.php


Joomla CMS: Répertoire de référence de Category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Category
Répertoire de référence de Category

Fichiers

fichier | com_contact/src/View/Category/FeedView.php
fichier | components/com_contact/src/View/Category/HtmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
  • services
Répertoire de référence de services

Fichiers

fichier plugins/system/cache/services/provider.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de file

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
  • file
Répertoire de référence de file

Fichiers

fichier administrator/components/com_media/tmpl/file/default.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | TemplateslistField.php
fichier | TinymcebuilderField.php
fichier | UploaddirsField.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | modules/mod_articles_categories/tmpl/default.php
fichier | modules/mod_articles_categories/tmpl/default_items.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ApiModel.php
fichier | FileModel.php
fichier | administrator/components/com_media/src/Model/MediaModel.php


Joomla CMS: Répertoire de référence de Attribute

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
  • Attribute
Répertoire de référence de Attribute

Fichiers

fichier | Required.php
fichier | SubscribedService.php


Joomla CMS: Répertoire de référence de pagenavigation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagenavigation
Répertoire de référence de pagenavigation

Répertoires

répertoire tmpl

Fichiers

fichier pagenavigation.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Users.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Adapters
répertoire | Media


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
  • services
Répertoire de référence de services

Fichiers

fichier plugins/multifactorauth/email/services/provider.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier system/webauthn/src/Extension/Webauthn.php


Joomla CMS: Répertoire de référence de Manifest

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Manifest
Répertoire de référence de Manifest

Fichiers

fichier | LibraryManifest.php
fichier | PackageManifest.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Command
Répertoire de référence de Command

Fichiers

fichier CreateSessionTableCommand.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire joomla


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contact
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_contact/src/Controller/ContactController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth1
  • src
Répertoire de référence de src

Fichiers

fichier oauth1/src/Client.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_newsfeeds/services/provider.php


Joomla CMS: Répertoire de référence de message

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • message
Répertoire de référence de message

Fichiers

fichier plugins/privacy/message/message.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier administrator/components/com_login/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de Templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
  • Templates
Répertoire de référence de Templates

Fichiers

fichier components/com_config/src/View/Templates/HtmlView.php


Joomla CMS: Répertoire de référence de com_menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
Répertoire de référence de com_menus

Répertoires

répertoire | layouts
répertoire | src


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_config/src/Controller/ConfigController.php
fichier | components/com_config/src/Controller/DisplayController.php
fichier | components/com_config/src/Controller/ModulesController.php
fichier | TemplatesController.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_redirect/services/provider.php


Joomla CMS: Répertoire de référence de packageinstaller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • packageinstaller
Répertoire de référence de packageinstaller

Répertoires

répertoire tmpl

Fichiers

fichier packageinstaller.php


Joomla CMS: Répertoire de référence de archive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • archive
Répertoire de référence de archive

Fichiers

fichier | components/com_content/tmpl/archive/default.php
fichier | components/com_content/tmpl/archive/default_items.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_tags/src/Controller/DisplayController.php
fichier | components/com_tags/src/Controller/TagsController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_fields
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tag
Répertoire de référence de Tag

Fichiers

fichier | com_tags/src/View/Tag/FeedView.php
fichier | components/com_tags/src/View/Tag/HtmlView.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire unidata


Joomla CMS: Répertoire de référence de Signature

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
Répertoire de référence de Signature

Répertoires

répertoire | ECDSA
répertoire | EdDSA
répertoire | RSA

Fichiers

fichier web-auth/cose-lib/src/Algorithm/Signature/Signature.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
Répertoire de référence de helpers

Répertoires

répertoire indexer

Fichiers

fichier administrator/components/com_finder/helpers/language.php


Joomla CMS: Répertoire de référence de message

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • tmpl
  • message
Répertoire de référence de message

Fichiers

fichier | administrator/components/com_messages/tmpl/message/default.php
fichier | administrator/components/com_messages/tmpl/message/edit.php


Joomla CMS: Répertoire de référence de joomlaupdate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Répertoire de référence de joomlaupdate

Fichiers

fichier | administrator/components/com_joomlaupdate/tmpl/joomlaupdate/complete.php
fichier | noupdate.php
fichier | preupdatecheck.php
fichier | reinstall.php
fichier | selfupdate.php
fichier | update.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier | administrator/components/com_admin/src/Service/HTML/Configuration.php
fichier | Directory.php
fichier | PhpSetting.php
fichier | System.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Removal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Removal
Répertoire de référence de Removal

Fichiers

fichier com_privacy/src/Removal/Status.php


Joomla CMS: Répertoire de référence de Webauthn

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
  • Webauthn
Répertoire de référence de Webauthn

Fichiers

fichier | Ajax.php
fichier | AjaxChallenge.php
fichier | AjaxCreate.php
fichier | AjaxDelete.php
fichier | AjaxInitCreate.php
fichier | AjaxLogin.php
fichier | AjaxSaveLabel.php


Joomla CMS: Répertoire de référence de Poly1305

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Poly1305
Répertoire de référence de Poly1305

Fichiers

fichier namespaced/Core/Poly1305/State.php


Joomla CMS: Répertoire de référence de SignalRegistry

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • SignalRegistry
Répertoire de référence de SignalRegistry

Fichiers

fichier SignalRegistry.php


Joomla CMS: Répertoire de référence de com_actionlogs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
Répertoire de référence de com_actionlogs

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Task

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Task
Répertoire de référence de Task

Fichiers

fichier | com_scheduler/src/Task/Status.php
fichier | Task.php
fichier | TaskOption.php
fichier | TaskOptions.php


Joomla CMS: Répertoire de référence de Slugger

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Slugger
Répertoire de référence de Slugger

Fichiers

fichier | AsciiSlugger.php
fichier | SluggerInterface.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_content/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de yaml

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Répertoire de référence de yaml

Répertoires

répertoire | Command
répertoire | Exception
répertoire | Tag

Fichiers

fichier | yaml/Dumper.php
fichier | Escaper.php
fichier | Inline.php
fichier | libraries/vendor/symfony/yaml/Parser.php
fichier | Unescaper.php
fichier | symfony/yaml/Yaml.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_finder/src/Service/Router.php


Joomla CMS: Répertoire de référence de spomky-labs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
Répertoire de référence de spomky-labs

Répertoires

répertoire | base64url
répertoire | cbor-php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Joomlaupdate.php


Joomla CMS: Répertoire de référence de chromes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • layouts
  • chromes
Répertoire de référence de chromes

Fichiers

fichier | card.php
fichier | noCard.php


Joomla CMS: Répertoire de référence de language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • language
Répertoire de référence de language

Répertoires

répertoire | en-GB
répertoire | fr-FR


Joomla CMS: Répertoire de référence de Rule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Rule
Répertoire de référence de Rule

Fichiers

fichier | ContactEmailMessageRule.php
fichier | ContactEmailRule.php
fichier | ContactEmailSubjectRule.php


Joomla CMS: Répertoire de référence de chromes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • chromes
Répertoire de référence de chromes

Fichiers

fichier | html5.php
fichier | layouts/chromes/none.php
fichier | outline.php
fichier | table.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • View
Répertoire de référence de View

Fichiers

fichier DisplayEvent.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | AssociationController.php
fichier | AssociationsController.php
fichier | administrator/components/com_associations/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
Répertoire de référence de src

Répertoires

répertoire | Adapter
répertoire | Controller
répertoire | Dispatcher
répertoire | Event
répertoire | Exception
répertoire | Model
répertoire | Plugin
répertoire | Provider
répertoire | View


Joomla CMS: Répertoire de référence de capabilities

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • tmpl
  • capabilities
Répertoire de référence de capabilities

Fichiers

fichier administrator/components/com_privacy/tmpl/capabilities/default.php


Joomla CMS: Répertoire de référence de Upload

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Upload
Répertoire de référence de Upload

Fichiers

fichier administrator/components/com_joomlaupdate/src/View/Upload/HtmlView.php


Joomla CMS: Répertoire de référence de String

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • String
Répertoire de référence de String

Fichiers

fichier PunycodeHelper.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_content/services/provider.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_frontend
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_frontend/tmpl/default.php


Joomla CMS: Répertoire de référence de articles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • articles
Répertoire de référence de articles

Fichiers

fichier | administrator/components/com_content/tmpl/articles/default.php
fichier | com_content/tmpl/articles/default_batch_body.php
fichier | com_content/tmpl/articles/default_batch_footer.php
fichier | administrator/components/com_content/tmpl/articles/emptystate.php
fichier | administrator/components/com_content/tmpl/articles/modal.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | BadFormatException.php
fichier | CryptoException.php
fichier | EnvironmentIsBrokenException.php
fichier | IOException.php
fichier | WrongKeyOrModifiedCiphertextException.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Serializer
répertoire | View


Joomla CMS: Répertoire de référence de tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • tmpl
  • tag
Répertoire de référence de tag

Fichiers

fichier | components/com_tags/tmpl/tag/default.php
fichier | components/com_tags/tmpl/tag/default_items.php
fichier | components/com_tags/tmpl/tag/list.php
fichier | list_items.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de redirect

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • redirect
Répertoire de référence de redirect

Fichiers

fichier plugins/system/redirect/redirect.php


Joomla CMS: Répertoire de référence de BigInteger

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
Répertoire de référence de BigInteger

Répertoires

répertoire Engines


Joomla CMS: Répertoire de référence de Captive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Captive
Répertoire de référence de Captive

Fichiers

fichier administrator/components/com_users/src/View/Captive/HtmlView.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire editors


Joomla CMS: Répertoire de référence de radio

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • radio
Répertoire de référence de radio

Répertoires

répertoire tmpl

Fichiers

fichier radio.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Feeds


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • layouts
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire searchtools


Joomla CMS: Répertoire de référence de mod_loginsupport

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_loginsupport
Répertoire de référence de mod_loginsupport

Répertoires

répertoire tmpl

Fichiers

fichier mod_loginsupport.php


Joomla CMS: Répertoire de référence de AssetItem

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Répertoire de référence de AssetItem

Fichiers

fichier | CoreAssetItem.php
fichier | FormValidateAssetItem.php
fichier | KeepaliveAssetItem.php
fichier | LangActiveAssetItem.php
fichier | TableColumnsAssetItem.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagenavigation
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/content/pagenavigation/tmpl/default.php


Joomla CMS: Répertoire de référence de Item

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Item
Répertoire de référence de Item

Fichiers

fichier administrator/components/com_menus/src/View/Item/HtmlView.php


Joomla CMS: Répertoire de référence de Banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Banners
Répertoire de référence de Banners

Fichiers

fichier administrator/components/com_banners/src/View/Banners/HtmlView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_articles_popular/tmpl/default.php


Joomla CMS: Répertoire de référence de Descriptor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Répertoire de référence de Descriptor

Fichiers

fichier | symfony/console/Descriptor/ApplicationDescription.php
fichier | Descriptor.php
fichier | DescriptorInterface.php
fichier | JsonDescriptor.php
fichier | MarkdownDescriptor.php
fichier | symfony/console/Descriptor/TextDescriptor.php
fichier | XmlDescriptor.php


Joomla CMS: Répertoire de référence de Tester

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
Répertoire de référence de Tester

Répertoires

répertoire Constraint

Fichiers

fichier | ApplicationTester.php
fichier | CommandCompletionTester.php
fichier | CommandTester.php
fichier | TesterTrait.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Répertoire de référence de src

Fichiers

fichier | EvolvableLinkProviderTrait.php
fichier | EvolvableLinkTrait.php
fichier | fig/link-util/src/GenericLinkProvider.php
fichier | fig/link-util/src/Link.php
fichier | LinkProviderTrait.php
fichier | LinkTrait.php
fichier | Relations.php
fichier | TemplatedHrefTrait.php


Joomla CMS: Répertoire de référence de Poly1305

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Poly1305
Répertoire de référence de Poly1305

Fichiers

fichier src/Core/Poly1305/State.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • imagelist
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/imagelist.php


Joomla CMS: Répertoire de référence de Scheduler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Scheduler
Répertoire de référence de Scheduler

Fichiers

fichier Scheduler.php


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • layouts
  • fields
Répertoire de référence de fields

Fichiers

fichier com_fields/layouts/fields/render.php


Joomla CMS: Répertoire de référence de portable-utf8

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
Répertoire de référence de portable-utf8

Répertoires

répertoire src

Fichiers

fichier vendor/voku/portable-utf8/bootstrap.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier administrator/components/com_cpanel/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de textarea

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • textarea
Répertoire de référence de textarea

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/textarea/textarea.php


Joomla CMS: Répertoire de référence de Stemmer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Répertoire de référence de Stemmer

Fichiers

fichier | Catalan.php
fichier | Danish.php
fichier | Dutch.php
fichier | English.php
fichier | Finnish.php
fichier | French.php
fichier | German.php
fichier | Italian.php
fichier | Norwegian.php
fichier | Portuguese.php
fichier | Romanian.php
fichier | Russian.php
fichier | Spanish.php
fichier | Stem.php
fichier | Stemmer.php
fichier | Swedish.php


Joomla CMS: Répertoire de référence de menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • menus
Répertoire de référence de menus

Fichiers

fichier plugins/webservices/menus/menus.php


Joomla CMS: Répertoire de référence de languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • languages
Répertoire de référence de languages

Fichiers

fichier administrator/components/com_installer/tmpl/languages/default.php


Joomla CMS: Répertoire de référence de searchtools

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
  • joomla
  • searchtools
Répertoire de référence de searchtools

Fichiers

fichier administrator/components/com_menus/layouts/joomla/searchtools/default.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de Menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_menus
  • src
  • View
  • Menus
Répertoire de référence de Menus

Fichiers

fichier com_menus/src/View/Menus/JsonapiView.php


Joomla CMS: Répertoire de référence de Groups

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • View
  • Groups
Répertoire de référence de Groups

Fichiers

fichier administrator/components/com_fields/src/View/Groups/HtmlView.php


Joomla CMS: Répertoire de référence de RSA

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
Répertoire de référence de RSA

Répertoires

répertoire Formats

Fichiers

fichier | phpseclib/phpseclib/phpseclib/Crypt/RSA/PrivateKey.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/RSA/PublicKey.php


Joomla CMS: Répertoire de référence de com_installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
Répertoire de référence de com_installer

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de fgrosse

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
Répertoire de référence de fgrosse

Répertoires

répertoire phpasn1


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier ModulesHelper.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de mod_user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_user
Répertoire de référence de mod_user

Répertoires

répertoire tmpl

Fichiers

fichier mod_user.php


Joomla CMS: Répertoire de référence de container

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • container
Répertoire de référence de container

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Répertoire de référence de Extension

Répertoires

répertoire Service

Fichiers

fichier | BootableExtensionInterface.php
fichier | Component.php
fichier | ComponentInterface.php
fichier | DummyPlugin.php
fichier | ExtensionHelper.php
fichier | ExtensionManagerInterface.php
fichier | ExtensionManagerTrait.php
fichier | LegacyComponent.php
fichier | src/Extension/Module.php
fichier | ModuleInterface.php
fichier | MVCComponent.php
fichier | PluginInterface.php


Joomla CMS: Répertoire de référence de webauthn

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • system
  • webauthn
Répertoire de référence de webauthn

Fichiers

fichier manage.php


Joomla CMS: Répertoire de référence de UCM

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • UCM
Répertoire de référence de UCM

Fichiers

fichier | UCM.php
fichier | UCMBase.php
fichier | UCMContent.php
fichier | UCMType.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_languages/services/provider.php


Joomla CMS: Répertoire de référence de BinaryField

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BinaryField
Répertoire de référence de BinaryField

Fichiers

fichier phpseclib/phpseclib/phpseclib/Math/BinaryField/Integer.php


Joomla CMS: Répertoire de référence de editors

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • editors
Répertoire de référence de editors

Répertoires

répertoire buttons

Fichiers

fichier editors/buttons.php


Joomla CMS: Répertoire de référence de json-api

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
Répertoire de référence de json-api

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_version/tmpl/default.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier SchedulerComponent.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire wrapper


Joomla CMS: Répertoire de référence de phpseclib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
Répertoire de référence de phpseclib

Répertoires

répertoire | bcmath_compat
répertoire | phpseclib


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Shortcut.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal


Joomla CMS: Répertoire de référence de Mysqli

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Mysqli
Répertoire de référence de Mysqli

Fichiers

fichier | MysqliDriver.php
fichier | MysqliExporter.php
fichier | MysqliImporter.php
fichier | MysqliQuery.php
fichier | MysqliStatement.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | field
répertoire | fields
répertoire | group
répertoire | groups


Joomla CMS: Répertoire de référence de mod_privacy_status

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
Répertoire de référence de mod_privacy_status

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_privacy_status.php


Joomla CMS: Répertoire de référence de jwt-signature

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Répertoire de référence de jwt-signature

Répertoires

répertoire | Algorithm
répertoire | Serializer

Fichiers

fichier | JWS.php
fichier | JWSBuilder.php
fichier | JWSBuilderFactory.php
fichier | JWSLoader.php
fichier | JWSLoaderFactory.php
fichier | JWSTokenSupport.php
fichier | JWSVerifier.php
fichier | JWSVerifierFactory.php
fichier | web-token/jwt-signature/Signature.php


Joomla CMS: Répertoire de référence de Time

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Time
Répertoire de référence de Time

Fichiers

fichier | BigNumberTimeConverter.php
fichier | DegradedTimeConverter.php
fichier | PhpTimeConverter.php


Joomla CMS: Répertoire de référence de language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • language
Répertoire de référence de language

Répertoires

répertoire | en-GB
répertoire | fr-FR


Joomla CMS: Répertoire de référence de Application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • View
  • Application
Répertoire de référence de Application

Fichiers

fichier com_config/src/View/Application/JsonapiView.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • helpers
Répertoire de référence de helpers

Fichiers

fichier components/com_content/helpers/icon.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Field
Répertoire de référence de Field

Répertoires

répertoire Modal

Fichiers

fichier NewsfeedsField.php


Joomla CMS: Répertoire de référence de Punycode

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Punycode
Répertoire de référence de Punycode

Fichiers

fichier | AbstractPunycode.php
fichier | FromPunycode.php
fichier | PunycodeInterface.php
fichier | ToPunycode.php


Joomla CMS: Répertoire de référence de phpseclib

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
Répertoire de référence de phpseclib

Répertoires

répertoire phpseclib


Joomla CMS: Répertoire de référence de functions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Répertoire de référence de functions

Fichiers

fichier | create_uploaded_file.legacy.php
fichier | create_uploaded_file.php
fichier | marshal_headers_from_sapi.legacy.php
fichier | marshal_headers_from_sapi.php
fichier | marshal_method_from_sapi.legacy.php
fichier | marshal_method_from_sapi.php
fichier | marshal_protocol_version_from_sapi.legacy.php
fichier | marshal_protocol_version_from_sapi.php
fichier | marshal_uri_from_sapi.legacy.php
fichier | marshal_uri_from_sapi.php
fichier | normalize_server.legacy.php
fichier | normalize_server.php
fichier | normalize_uploaded_files.legacy.php
fichier | normalize_uploaded_files.php
fichier | parse_cookie_header.legacy.php
fichier | parse_cookie_header.php


Joomla CMS: Répertoire de référence de Mail

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
Répertoire de référence de Mail

Répertoires

répertoire | Exception
répertoire | language

Fichiers

fichier | Mail.php
fichier | MailHelper.php
fichier | MailTemplate.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_toolbar
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_toolbar/tmpl/default.php


Joomla CMS: Répertoire de référence de featuring

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • featuring
Répertoire de référence de featuring

Fichiers

fichier featuring.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_syndicate/tmpl/default.php


Joomla CMS: Répertoire de référence de media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • media
Répertoire de référence de media

Fichiers

fichier accessiblemedia.php


Joomla CMS: Répertoire de référence de Update

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Update
Répertoire de référence de Update

Fichiers

fichier administrator/components/com_installer/src/View/Update/HtmlView.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier ModulesComponent.php


Joomla CMS: Répertoire de référence de mod_toolbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_toolbar
Répertoire de référence de mod_toolbar

Répertoires

répertoire tmpl

Fichiers

fichier mod_toolbar.php


Joomla CMS: Répertoire de référence de Layout

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Layout
Répertoire de référence de Layout

Fichiers

fichier | BaseLayout.php
fichier | FileLayout.php
fichier | LayoutHelper.php
fichier | LayoutInterface.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Privacy.php


Joomla CMS: Répertoire de référence de Test

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
  • Test
Répertoire de référence de Test

Fichiers

fichier ServiceLocatorTest.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-rsa

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Répertoire de référence de jwt-signature-algorithm-rsa

Répertoires

répertoire Util

Fichiers

fichier | web-token/jwt-signature-algorithm-rsa/PS256.php
fichier | web-token/jwt-signature-algorithm-rsa/PS384.php
fichier | web-token/jwt-signature-algorithm-rsa/PS512.php
fichier | web-token/jwt-signature-algorithm-rsa/RS256.php
fichier | web-token/jwt-signature-algorithm-rsa/RS384.php
fichier | web-token/jwt-signature-algorithm-rsa/RS512.php
fichier | web-token/jwt-signature-algorithm-rsa/RSA.php
fichier | RSAPKCS1.php
fichier | RSAPSS.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_users/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de Descriptor

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Descriptor
Répertoire de référence de Descriptor

Fichiers

fichier | joomla/console/src/Descriptor/ApplicationDescription.php
fichier | joomla/console/src/Descriptor/TextDescriptor.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | modules/mod_articles_category/tmpl/default.php
fichier | modules/mod_articles_category/tmpl/default_items.php


Joomla CMS: Répertoire de référence de searchtools

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • layouts
  • joomla
  • searchtools
Répertoire de référence de searchtools

Fichiers

fichier administrator/components/com_associations/layouts/joomla/searchtools/default.php


Joomla CMS: Répertoire de référence de google

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
Répertoire de référence de google

Répertoires

répertoire recaptcha


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier NewsfeedField.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Style
répertoire | Styles
répertoire | Template
répertoire | Templates


Joomla CMS: Répertoire de référence de webservices

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
Répertoire de référence de webservices

Répertoires

répertoire | banners
répertoire | config
répertoire | contact
répertoire | content
répertoire | installer
répertoire | languages
répertoire | media
répertoire | menus
répertoire | messages
répertoire | modules
répertoire | newsfeeds
répertoire | plugins
répertoire | privacy
répertoire | redirect
répertoire | tags
répertoire | templates
répertoire | users


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • layouts
  • form
  • field
Répertoire de référence de field

Fichiers

fichier webcron_link.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • helpers
Répertoire de référence de helpers

Fichiers

fichier com_newsfeeds/helpers/route.php


Joomla CMS: Répertoire de référence de com_newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
Répertoire de référence de com_newsfeeds

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Articles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • View
  • Articles
Répertoire de référence de Articles

Fichiers

fichier administrator/components/com_content/src/View/Articles/HtmlView.php


Joomla CMS: Répertoire de référence de options-resolver

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
Répertoire de référence de options-resolver

Répertoires

répertoire | Debug
répertoire | Exception

Fichiers

fichier | OptionConfigurator.php
fichier | Options.php
fichier | OptionsResolver.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_banners/src/Controller/BannersController.php
fichier | api/components/com_banners/src/Controller/ClientsController.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier | ModulesModuleField.php
fichier | ModulesPositioneditField.php
fichier | com_modules/src/Field/ModulesPositionField.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | archive
répertoire | article
répertoire | categories
répertoire | category
répertoire | featured
répertoire | form


Joomla CMS: Répertoire de référence de Feed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
Répertoire de référence de Feed

Répertoires

répertoire Parser

Fichiers

fichier | Feed.php
fichier | FeedEntry.php
fichier | FeedFactory.php
fichier | FeedLink.php
fichier | FeedParser.php
fichier | FeedPerson.php


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Adapter
Répertoire de référence de Adapter

Fichiers

fichier | libraries/src/Adapter/Adapter.php
fichier | AdapterInstance.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Exception
Répertoire de référence de Exception

Fichiers

fichier MissingComponentException.php


Joomla CMS: Répertoire de référence de debuguser

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • debuguser
Répertoire de référence de debuguser

Fichiers

fichier administrator/components/com_users/tmpl/debuguser/default.php


Joomla CMS: Répertoire de référence de Filters

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Filters
Répertoire de référence de Filters

Fichiers

fichier administrator/components/com_finder/src/View/Filters/HtmlView.php


Joomla CMS: Répertoire de référence de fig

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
Répertoire de référence de fig

Répertoires

répertoire link-util


Joomla CMS: Répertoire de référence de mod_frontend

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_frontend
Répertoire de référence de mod_frontend

Répertoires

répertoire tmpl

Fichiers

fichier mod_frontend.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | tag
répertoire | tags


Joomla CMS: Répertoire de référence de JsonApi

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Répertoire de référence de JsonApi

Fichiers

fichier | AuthenticationFailedExceptionHandler.php
fichier | CheckinCheckoutExceptionHandler.php
fichier | src/Error/JsonApi/InvalidParameterExceptionHandler.php
fichier | InvalidRouteExceptionHandler.php
fichier | NotAcceptableExceptionHandler.php
fichier | NotAllowedExceptionHandler.php
fichier | ResourceNotFoundExceptionHandler.php
fichier | SaveExceptionHandler.php
fichier | SendEmailExceptionHandler.php


Joomla CMS: Répertoire de référence de Methods

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Methods
Répertoire de référence de Methods

Fichiers

fichier components/com_users/src/View/Methods/HtmlView.php


Joomla CMS: Répertoire de référence de manage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • manage
Répertoire de référence de manage

Fichiers

fichier administrator/components/com_installer/tmpl/manage/default.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier CacheModel.php


Joomla CMS: Répertoire de référence de Input

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Répertoire de référence de Input

Fichiers

fichier | ArgvInput.php
fichier | ArrayInput.php
fichier | vendor/symfony/console/Input/Input.php
fichier | InputArgument.php
fichier | InputAwareInterface.php
fichier | InputDefinition.php
fichier | InputInterface.php
fichier | InputOption.php
fichier | StreamableInputInterface.php
fichier | StringInput.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Répertoire de référence de Model

Fichiers

fichier | AdminModel.php
fichier | BaseDatabaseModel.php
fichier | BaseModel.php
fichier | src/MVC/Model/DatabaseAwareTrait.php
fichier | DatabaseModelInterface.php
fichier | FormBehaviorTrait.php
fichier | libraries/src/MVC/Model/FormModel.php
fichier | FormModelInterface.php
fichier | libraries/src/MVC/Model/ItemModel.php
fichier | ItemModelInterface.php
fichier | LegacyModelLoaderTrait.php
fichier | ListModel.php
fichier | ListModelInterface.php
fichier | ModelInterface.php
fichier | StateBehaviorTrait.php
fichier | StatefulModelInterface.php
fichier | WorkflowBehaviorTrait.php
fichier | WorkflowModelInterface.php


Joomla CMS: Répertoire de référence de voku

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
Répertoire de référence de voku

Répertoires

répertoire helper


Joomla CMS: Répertoire de référence de menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menu
Répertoire de référence de menu

Fichiers

fichier administrator/components/com_menus/tmpl/menu/edit.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier components/com_wrapper/src/Service/Router.php


Joomla CMS: Répertoire de référence de Sysinfo

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Sysinfo
Répertoire de référence de Sysinfo

Fichiers

fichier | administrator/components/com_admin/src/View/Sysinfo/HtmlView.php
fichier | administrator/components/com_admin/src/View/Sysinfo/JsonView.php
fichier | TextView.php


Joomla CMS: Répertoire de référence de BaseCurves

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Répertoire de référence de BaseCurves

Fichiers

fichier | Crypt/EC/BaseCurves/Base.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/EC/BaseCurves/Binary.php
fichier | KoblitzPrime.php
fichier | Crypt/EC/BaseCurves/Montgomery.php
fichier | Prime.php
fichier | TwistedEdwards.php


Joomla CMS: Répertoire de référence de SSH

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
Répertoire de référence de SSH

Répertoires

répertoire | Agent
répertoire | Common

Fichiers

fichier Agent.php


Joomla CMS: Répertoire de référence de Clients

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Clients
Répertoire de référence de Clients

Fichiers

fichier vendor/joomla/filesystem/src/Clients/FtpClient.php


Joomla CMS: Répertoire de référence de postinstall

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Répertoire de référence de postinstall

Fichiers

fichier | addnosniff.php
fichier | behindproxy.php
fichier | htaccesssvg.php
fichier | languageaccess340.php
fichier | statscollection.php
fichier | textfilter3919.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | ConfirmModel.php
fichier | com_privacy/src/Model/RemindModel.php
fichier | components/com_privacy/src/Model/RequestModel.php


Joomla CMS: Répertoire de référence de willdurand

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
Répertoire de référence de willdurand

Répertoires

répertoire negotiation


Joomla CMS: Répertoire de référence de Logger

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Logger
Répertoire de référence de Logger

Fichiers

fichier ConsoleLogger.php


Joomla CMS: Répertoire de référence de rotate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • rotate
Répertoire de référence de rotate

Fichiers

fichier rotate.php


Joomla CMS: Répertoire de référence de links

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • links
Répertoire de référence de links

Fichiers

fichier | administrator/components/com_redirect/tmpl/links/default.php
fichier | default_addform.php
fichier | com_redirect/tmpl/links/default_batch_body.php
fichier | com_redirect/tmpl/links/default_batch_footer.php
fichier | administrator/components/com_redirect/tmpl/links/emptystate.php


Joomla CMS: Répertoire de référence de Updater

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
Répertoire de référence de Updater

Répertoires

répertoire Adapter

Fichiers

fichier | DownloadSource.php
fichier | Updater/Update.php
fichier | UpdateAdapter.php
fichier | Updater.php


Joomla CMS: Répertoire de référence de TokenBinding

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TokenBinding
Répertoire de référence de TokenBinding

Fichiers

fichier | IgnoreTokenBindingHandler.php
fichier | TokenBinding.php
fichier | TokenBindingHandler.php
fichier | TokenBindingNotSupportedHandler.php


Joomla CMS: Répertoire de référence de cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
Répertoire de référence de cache

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de filesystem

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
Répertoire de référence de filesystem

Répertoires

répertoire local


Joomla CMS: Répertoire de référence de updatesites

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • updatesites
Répertoire de référence de updatesites

Fichiers

fichier administrator/components/com_installer/tmpl/updatesites/default.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Répertoire de référence de src

Répertoires

répertoire Exception

Fichiers

fichier | Core.php
fichier | vendor/defuse/php-encryption/src/Crypto.php
fichier | DerivedKeys.php
fichier | defuse/php-encryption/src/Encoding.php
fichier | vendor/defuse/php-encryption/src/File.php
fichier | defuse/php-encryption/src/Key.php
fichier | KeyOrPassword.php
fichier | KeyProtectedByPassword.php
fichier | RuntimeTests.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Manage


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | DumpException.php
fichier | symfony/yaml/Exception/ExceptionInterface.php
fichier | ParseException.php
fichier | yaml/Exception/RuntimeException.php


Joomla CMS: Répertoire de référence de File

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
Répertoire de référence de File

Répertoires

répertoire ASN1

Fichiers

fichier | ANSI.php
fichier | File/ASN1.php
fichier | X509.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | captive
répertoire | debuggroup
répertoire | debuguser
répertoire | group
répertoire | groups
répertoire | level
répertoire | levels
répertoire | mail
répertoire | method
répertoire | methods
répertoire | note
répertoire | notes
répertoire | user
répertoire | users


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_newsfeeds/src/Model/CategoriesModel.php
fichier | components/com_newsfeeds/src/Model/CategoryModel.php
fichier | components/com_newsfeeds/src/Model/NewsfeedModel.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Crypt

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Répertoire de référence de Crypt

Répertoires

répertoire | Common
répertoire | DH
répertoire | DSA
répertoire | EC
répertoire | RSA

Fichiers

fichier | AES.php
fichier | Blowfish.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/ChaCha20.php
fichier | DES.php
fichier | DH.php
fichier | DSA.php
fichier | EC.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/Hash.php
fichier | PublicKeyLoader.php
fichier | Random.php
fichier | RC2.php
fichier | RC4.php
fichier | Rijndael.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/RSA.php
fichier | phpseclib/phpseclib/phpseclib/Crypt/Salsa20.php
fichier | TripleDES.php
fichier | Twofish.php


Joomla CMS: Répertoire de référence de multifactorauth

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
Répertoire de référence de multifactorauth

Répertoires

répertoire | email
répertoire | fixed
répertoire | totp
répertoire | webauthn
répertoire | yubikey


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier FieldsComponent.php


Joomla CMS: Répertoire de référence de inflector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
Répertoire de référence de inflector

Répertoires

répertoire lib


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
Répertoire de référence de src

Répertoires

répertoire phputf8

Fichiers

fichier | joomla/string/src/Inflector.php
fichier | Normalise.php
fichier | vendor/joomla/string/src/StringHelper.php


Joomla CMS: Répertoire de référence de data

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Resources
  • data
Répertoire de référence de data

Fichiers

fichier | wcswidth_table_wide.php
fichier | wcswidth_table_zero.php


Joomla CMS: Répertoire de référence de Joomlaupdate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • View
  • Joomlaupdate
Répertoire de référence de Joomlaupdate

Fichiers

fichier administrator/components/com_joomlaupdate/src/View/Joomlaupdate/HtmlView.php


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-hmac

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-hmac
Répertoire de référence de jwt-signature-algorithm-hmac

Fichiers

fichier | HMAC.php
fichier | web-token/jwt-signature-algorithm-hmac/HS256.php
fichier | web-token/jwt-signature-algorithm-hmac/HS384.php
fichier | web-token/jwt-signature-algorithm-hmac/HS512.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_quickicon/tmpl/default.php


Joomla CMS: Répertoire de référence de MVC

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
Répertoire de référence de MVC

Répertoires

répertoire | Controller
répertoire | Factory
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de Categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • View
  • Categories
Répertoire de référence de Categories

Fichiers

fichier administrator/components/com_categories/src/View/Categories/HtmlView.php


Joomla CMS: Répertoire de référence de task

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
Répertoire de référence de task

Répertoires

répertoire | checkfiles
répertoire | demotasks
répertoire | requests
répertoire | sitestatus


Joomla CMS: Répertoire de référence de association

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • tmpl
  • association
Répertoire de référence de association

Fichiers

fichier administrator/components/com_associations/tmpl/association/edit.php


Joomla CMS: Répertoire de référence de php-http

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
Répertoire de référence de php-http

Répertoires

répertoire message-factory


Joomla CMS: Répertoire de référence de behaviour

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
Répertoire de référence de behaviour

Répertoires

répertoire | taggable
répertoire | versionable


Joomla CMS: Répertoire de référence de Key

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Répertoire de référence de Key

Fichiers

fichier | Ec2Key.php
fichier | web-auth/cose-lib/src/Key/Key.php
fichier | OkpKey.php
fichier | RsaKey.php
fichier | web-auth/cose-lib/src/Key/SymmetricKey.php


Joomla CMS: Répertoire de référence de mod_version

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
Répertoire de référence de mod_version

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_version.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
Répertoire de référence de src

Répertoires

répertoire | EncodingHelper
répertoire | Exception
répertoire | NamePrep
répertoire | Punycode
répertoire | TranscodeUnicode

Fichiers

fichier | AbstractIdnaConvert.php
fichier | IdnaConvertInterface.php
fichier | ToIdn.php
fichier | ToUnicode.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Model
répertoire | Rule
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Plugin
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_redirect/helpers/redirect.php


Joomla CMS: Répertoire de référence de DependencyInjection

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • DependencyInjection
Répertoire de référence de DependencyInjection

Fichiers

fichier AddConsoleCommandPass.php


Joomla CMS: Répertoire de référence de privacycheck

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • privacycheck
Répertoire de référence de privacycheck

Fichiers

fichier privacycheck.php


Joomla CMS: Répertoire de référence de bcmath_compat

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • bcmath_compat
Répertoire de référence de bcmath_compat

Répertoires

répertoire | lib
répertoire | src


Joomla CMS: Répertoire de référence de DebugBar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Répertoire de référence de DebugBar

Répertoires

répertoire | Bridge
répertoire | DataCollector
répertoire | DataFormatter
répertoire | Storage

Fichiers

fichier | DebugBar.php
fichier | DebugBarException.php
fichier | HttpDriverInterface.php
fichier | libraries/vendor/maximebf/debugbar/src/DebugBar/JavascriptRenderer.php
fichier | OpenHandler.php
fichier | PhpHttpDriver.php
fichier | RequestIdGenerator.php
fichier | RequestIdGeneratorInterface.php
fichier | StandardDebugBar.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Répertoire de référence de src

Répertoires

répertoire Exception

Fichiers

fichier | Archive.php
fichier | Bzip2.php
fichier | ExtractableInterface.php
fichier | Gzip.php
fichier | Tar.php
fichier | Zip.php


Joomla CMS: Répertoire de référence de Resources

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
Répertoire de référence de Resources

Répertoires

répertoire stubs


Joomla CMS: Répertoire de référence de Versioning

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Versioning
Répertoire de référence de Versioning

Fichiers

fichier | VersionableControllerTrait.php
fichier | VersionableModelTrait.php
fichier | VersionableTableInterface.php
fichier | Versioning.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Styles


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Yubikey.php


Joomla CMS: Répertoire de référence de Help

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Help
Répertoire de référence de Help

Fichiers

fichier administrator/components/com_admin/src/View/Help/HtmlView.php


Joomla CMS: Répertoire de référence de Media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • View
  • Media
Répertoire de référence de Media

Fichiers

fichier administrator/components/com_media/src/View/Media/HtmlView.php


Joomla CMS: Répertoire de référence de banners

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • banners
Répertoire de référence de banners

Fichiers

fichier | administrator/components/com_banners/tmpl/banners/default.php
fichier | com_banners/tmpl/banners/default_batch_body.php
fichier | com_banners/tmpl/banners/default_batch_footer.php
fichier | administrator/components/com_banners/tmpl/banners/emptystate.php


Joomla CMS: Répertoire de référence de Plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
  • View
  • Plugins
Répertoire de référence de Plugins

Fichiers

fichier com_plugins/src/View/Plugins/JsonapiView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagebreak
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | navigation.php
fichier | toc.php


Joomla CMS: Répertoire de référence de phpass

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • phpass
Répertoire de référence de phpass

Fichiers

fichier PasswordHash.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier Requests.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | installation/src/Controller/DisplayController.php
fichier | InstallationController.php
fichier | JSONController.php
fichier | installation/src/Controller/LanguageController.php


Joomla CMS: Répertoire de référence de searches

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • searches
Répertoire de référence de searches

Fichiers

fichier | administrator/components/com_finder/tmpl/searches/default.php
fichier | administrator/components/com_finder/tmpl/searches/emptystate.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | module
répertoire | modules
répertoire | select


Joomla CMS: Répertoire de référence de confirmconsent

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • confirmconsent
Répertoire de référence de confirmconsent

Répertoires

répertoire src

Fichiers

fichier confirmconsent.php


Joomla CMS: Répertoire de référence de AuthenticationExtensions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AuthenticationExtensions
Répertoire de référence de AuthenticationExtensions

Fichiers

fichier | AuthenticationExtension.php
fichier | AuthenticationExtensionsClientInputs.php
fichier | AuthenticationExtensionsClientOutputs.php
fichier | AuthenticationExtensionsClientOutputsLoader.php
fichier | ExtensionOutputChecker.php
fichier | ExtensionOutputCheckerHandler.php
fichier | ExtensionOutputError.php


Joomla CMS: Répertoire de référence de Pagination

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pagination
Répertoire de référence de Pagination

Fichiers

fichier | Pagination.php
fichier | PaginationObject.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_menus/src/Model/ItemModel.php
fichier | ItemsModel.php
fichier | MenuModel.php
fichier | MenusModel.php
fichier | MenutypesModel.php


Joomla CMS: Répertoire de référence de Articles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • View
  • Articles
Répertoire de référence de Articles

Fichiers

fichier com_content/src/View/Articles/JsonapiView.php


Joomla CMS: Répertoire de référence de Statistics

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Statistics
Répertoire de référence de Statistics

Fichiers

fichier administrator/components/com_finder/src/View/Statistics/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | View


Joomla CMS: Répertoire de référence de CI

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CI
Répertoire de référence de CI

Fichiers

fichier GithubActionReporter.php


Joomla CMS: Répertoire de référence de OtherObject

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Répertoire de référence de OtherObject

Fichiers

fichier | BreakObject.php
fichier | DoublePrecisionFloatObject.php
fichier | FalseObject.php
fichier | GenericObject.php
fichier | HalfPrecisionFloatObject.php
fichier | spomky-labs/cbor-php/src/OtherObject/NullObject.php
fichier | OtherObjectManager.php
fichier | SimpleObject.php
fichier | SinglePrecisionFloatObject.php
fichier | TrueObject.php
fichier | UndefinedObject.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire toolbar


Joomla CMS: Répertoire de référence de note

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • note
Répertoire de référence de note

Fichiers

fichier administrator/components/com_users/tmpl/note/edit.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Installed
répertoire | Language
répertoire | Languages
répertoire | Multilangstatus
répertoire | Override
répertoire | Overrides


Joomla CMS: Répertoire de référence de Codec

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Répertoire de référence de Codec

Fichiers

fichier | CodecInterface.php
fichier | GuidStringCodec.php
fichier | OrderedTimeCodec.php
fichier | StringCodec.php
fichier | TimestampFirstCombCodec.php
fichier | TimestampLastCombCodec.php


Joomla CMS: Répertoire de référence de tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tags
Répertoire de référence de tags

Fichiers

fichier | administrator/components/com_tags/tmpl/tags/default.php
fichier | com_tags/tmpl/tags/default_batch_body.php
fichier | com_tags/tmpl/tags/default_batch_footer.php
fichier | administrator/components/com_tags/tmpl/tags/emptystate.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • confirmconsent
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de com_users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
Répertoire de référence de com_users

Répertoires

répertoire | helpers
répertoire | postinstall
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | newsfeed
répertoire | newsfeeds


Joomla CMS: Répertoire de référence de com_categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_categories
Répertoire de référence de com_categories

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de composer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Répertoire de référence de composer

Répertoires

répertoire ca-bundle

Fichiers

fichier | autoload_classmap.php
fichier | autoload_files.php
fichier | autoload_namespaces.php
fichier | libraries/vendor/composer/autoload_psr4.php
fichier | autoload_real.php
fichier | autoload_static.php
fichier | vendor/composer/ClassLoader.php
fichier | installed.php
fichier | InstalledVersions.php
fichier | platform_check.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • user
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/user/tmpl/user.php


Joomla CMS: Répertoire de référence de jwt-core

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
Répertoire de référence de jwt-core

Répertoires

répertoire Util

Fichiers

fichier | web-token/jwt-core/Algorithm.php
fichier | AlgorithmManager.php
fichier | AlgorithmManagerFactory.php
fichier | JWK.php
fichier | JWKSet.php
fichier | JWT.php


Joomla CMS: Répertoire de référence de Agent

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
  • Agent
Répertoire de référence de Agent

Fichiers

fichier Identity.php


Joomla CMS: Répertoire de référence de tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • tmpl
  • tag
Répertoire de référence de tag

Fichiers

fichier administrator/components/com_tags/tmpl/tag/edit.php


Joomla CMS: Répertoire de référence de mod_tags_similar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
Répertoire de référence de mod_tags_similar

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_tags_similar.php


Joomla CMS: Répertoire de référence de download

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • download
Répertoire de référence de download

Fichiers

fichier administrator/components/com_banners/tmpl/download/default.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_content/src/Model/ArticleModel.php
fichier | administrator/components/com_content/src/Model/ArticlesModel.php
fichier | administrator/components/com_content/src/Model/FeaturedModel.php
fichier | FeatureModel.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier PrivacyComponent.php


Joomla CMS: Répertoire de référence de PHP

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
Répertoire de référence de PHP

Répertoires

répertoire Reductions

Fichiers

fichier | Math/BigInteger/Engines/PHP/Base.php
fichier | PHP/DefaultEngine.php
fichier | Math/BigInteger/Engines/PHP/Montgomery.php
fichier | vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/PHP/OpenSSL.php


Joomla CMS: Répertoire de référence de Formats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
  • Formats
Répertoire de référence de Formats

Répertoires

répertoire Keys


Joomla CMS: Répertoire de référence de Html

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Répertoire de référence de Html

Fichiers

fichier | ComponentRenderer.php
fichier | HeadRenderer.php
fichier | MessageRenderer.php
fichier | MetasRenderer.php
fichier | ModuleRenderer.php
fichier | ModulesRenderer.php
fichier | ScriptsRenderer.php
fichier | StylesRenderer.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Command
Répertoire de référence de Command

Fichiers

fichier | AbstractCommand.php
fichier | joomla/console/src/Command/HelpCommand.php
fichier | joomla/console/src/Command/ListCommand.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
Répertoire de référence de templates

Répertoires

répertoire | cassiopeia
répertoire | system


Joomla CMS: Répertoire de référence de uri

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
Répertoire de référence de uri

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Feed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Feed
Répertoire de référence de Feed

Fichiers

fichier | AtomRenderer.php
fichier | RssRenderer.php


Joomla CMS: Répertoire de référence de installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • installer
Répertoire de référence de installer

Fichiers

fichier default_message.php


Joomla CMS: Répertoire de référence de Parsing

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Parsing
Répertoire de référence de Parsing

Fichiers

fichier | lcobucci/jwt/src/Parsing/Decoder.php
fichier | Encoder.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | modules/mod_whosonline/tmpl/default.php
fichier | modules/mod_whosonline/tmpl/disabled.php


Joomla CMS: Répertoire de référence de mod_stats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
Répertoire de référence de mod_stats

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_stats.php


Joomla CMS: Répertoire de référence de Authentication

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
Répertoire de référence de Authentication

Répertoires

répertoire Password

Fichiers

fichier | libraries/src/Authentication/Authentication.php
fichier | AuthenticationResponse.php
fichier | ProviderAwareAuthenticationPluginInterface.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Service
Répertoire de référence de Service

Fichiers

fichier | components/com_newsfeeds/src/Service/Category.php
fichier | components/com_newsfeeds/src/Service/Router.php


Joomla CMS: Répertoire de référence de oauth2

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth2
Répertoire de référence de oauth2

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | PluginModel.php
fichier | PluginsModel.php


Joomla CMS: Répertoire de référence de data

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Répertoire de référence de data

Fichiers

fichier | AllowedAttributes.php
fichier | AllowedTags.php
fichier | AttributeInterface.php
fichier | TagInterface.php
fichier | XPath.php


Joomla CMS: Répertoire de référence de Category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • View
  • Category
Répertoire de référence de Category

Fichiers

fichier administrator/components/com_categories/src/View/Category/HtmlView.php


Joomla CMS: Répertoire de référence de vote

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • vote
Répertoire de référence de vote

Répertoires

répertoire tmpl

Fichiers

fichier vote.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • privacyconsent
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de statistics

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • statistics
Répertoire de référence de statistics

Fichiers

fichier administrator/components/com_finder/tmpl/statistics/default.php


Joomla CMS: Répertoire de référence de oauth1

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • oauth1
Répertoire de référence de oauth1

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de mod_quickicon

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
Répertoire de référence de mod_quickicon

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier | CMSPlugin.php
fichier | PluginHelper.php


Joomla CMS: Répertoire de référence de Log

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
Répertoire de référence de Log

Répertoires

répertoire Logger

Fichiers

fichier | DelegatingPsrLogger.php
fichier | Log.php
fichier | LogEntry.php
fichier | Log/Logger.php
fichier | LoggerRegistry.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_mails/src/Controller/DisplayController.php
fichier | com_mails/src/Controller/TemplateController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_category
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Module
répertoire | Modules
répertoire | Select


Joomla CMS: Répertoire de référence de application

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • tmpl
  • application
Répertoire de référence de application

Fichiers

fichier | administrator/components/com_config/tmpl/application/default.php
fichier | default_cache.php
fichier | default_cookie.php
fichier | default_database.php
fichier | default_debug.php
fichier | default_filters.php
fichier | default_locale.php
fichier | default_logging.php
fichier | default_logging_custom.php
fichier | default_mail.php
fichier | administrator/components/com_config/tmpl/application/default_metadata.php
fichier | application/default_navigation.php
fichier | default_permissions.php
fichier | default_proxy.php
fichier | administrator/components/com_config/tmpl/application/default_seo.php
fichier | default_server.php
fichier | default_session.php
fichier | administrator/components/com_config/tmpl/application/default_site.php
fichier | default_webservices.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier VersionHelper.php


Joomla CMS: Répertoire de référence de workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
Répertoire de référence de workflow

Répertoires

répertoire | featuring
répertoire | notification
répertoire | publishing


Joomla CMS: Répertoire de référence de Pgsql

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pgsql
Répertoire de référence de Pgsql

Fichiers

fichier | PgsqlDriver.php
fichier | PgsqlExporter.php
fichier | PgsqlImporter.php
fichier | PgsqlQuery.php


Joomla CMS: Répertoire de référence de com_templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
Répertoire de référence de com_templates

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_feed
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_feed/tmpl/default.php


Joomla CMS: Répertoire de référence de com_installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_installer
Répertoire de référence de com_installer

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_post_installation_messages
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_post_installation_messages/tmpl/default.php


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • tmpl
  • fields
Répertoire de référence de fields

Fichiers

fichier | administrator/components/com_fields/tmpl/fields/default.php
fichier | com_fields/tmpl/fields/default_batch_body.php
fichier | com_fields/tmpl/fields/default_batch_footer.php
fichier | administrator/components/com_fields/tmpl/fields/modal.php


Joomla CMS: Répertoire de référence de publishing

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • publishing
Répertoire de référence de publishing

Fichiers

fichier publishing.php


Joomla CMS: Répertoire de référence de Filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filter
Répertoire de référence de Filter

Fichiers

fichier | src/Filter/InputFilter.php
fichier | src/Filter/OutputFilter.php


Joomla CMS: Répertoire de référence de event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
Répertoire de référence de event

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier ContactField.php


Joomla CMS: Répertoire de référence de workflows

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • workflows
Répertoire de référence de workflows

Fichiers

fichier administrator/components/com_workflow/tmpl/workflows/default.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier modules/mod_finder/src/Helper/FinderHelper.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_wrapper/tmpl/default.php


Joomla CMS: Répertoire de référence de Rule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Rule
Répertoire de référence de Rule

Fichiers

fichier | PrefixRule.php
fichier | installation/src/Form/Rule/UsernameRule.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de crop

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • crop
Répertoire de référence de crop

Fichiers

fichier crop.php


Joomla CMS: Répertoire de référence de Consents

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Consents
Répertoire de référence de Consents

Fichiers

fichier administrator/components/com_privacy/src/View/Consents/HtmlView.php


Joomla CMS: Répertoire de référence de radio

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • radio
Répertoire de référence de radio

Fichiers

fichier | form/field/radio/buttons.php
fichier | switcher.php


Joomla CMS: Répertoire de référence de string

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
Répertoire de référence de string

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier WhosonlineHelper.php


Joomla CMS: Répertoire de référence de mod_articles_latest

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
Répertoire de référence de mod_articles_latest

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • content
Répertoire de référence de content

Fichiers

fichier plugins/webservices/content/content.php


Joomla CMS: Répertoire de référence de text

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • text
Répertoire de référence de text

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/text/text.php


Joomla CMS: Répertoire de référence de Users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Users
Répertoire de référence de Users

Fichiers

fichier administrator/components/com_users/src/View/Users/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_banners
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier modules/mod_banners/src/Helper/BannersHelper.php


Joomla CMS: Répertoire de référence de Ecdsa

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Répertoire de référence de Ecdsa

Fichiers

fichier | ConversionFailed.php
fichier | MultibyteStringConverter.php
fichier | Ecdsa/Sha256.php
fichier | Ecdsa/Sha384.php
fichier | Ecdsa/Sha512.php
fichier | SignatureConverter.php


Joomla CMS: Répertoire de référence de idna-convert

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
Répertoire de référence de idna-convert

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier MessageTable.php


Joomla CMS: Répertoire de référence de Group

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Group
Répertoire de référence de Group

Fichiers

fichier administrator/components/com_users/src/View/Group/HtmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_workflow/services/provider.php


Joomla CMS: Répertoire de référence de Capabilities

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Capabilities
Répertoire de référence de Capabilities

Fichiers

fichier administrator/components/com_privacy/src/View/Capabilities/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | ActionlogsController.php
fichier | administrator/components/com_actionlogs/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Login


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | StageModel.php
fichier | StagesModel.php
fichier | TransitionModel.php
fichier | TransitionsModel.php
fichier | WorkflowModel.php
fichier | WorkflowsModel.php


Joomla CMS: Répertoire de référence de Command

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Command
Répertoire de référence de Command

Fichiers

fichier LintCommand.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Stage
répertoire | Stages
répertoire | Transition
répertoire | Transitions
répertoire | Workflow
répertoire | Workflows


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier | com_content/src/Service/HTML/AdministratorService.php
fichier | com_content/src/Service/HTML/Icon.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • templates
  • cassiopeia
  • html
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire chromes


Joomla CMS: Répertoire de référence de Feed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Feed
Répertoire de référence de Feed

Fichiers

fichier | FeedEnclosure.php
fichier | FeedImage.php
fichier | FeedItem.php


Joomla CMS: Répertoire de référence de pagebreak

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • pagebreak
Répertoire de référence de pagebreak

Fichiers

fichier plugins/editors-xtd/pagebreak/pagebreak.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Banner
répertoire | Banners
répertoire | Client
répertoire | Clients
répertoire | Download
répertoire | Tracks


Joomla CMS: Répertoire de référence de com_privacy

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
Répertoire de référence de com_privacy

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Loader

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Loader
Répertoire de référence de Loader

Fichiers

fichier | ContainerLoader.php
fichier | LoaderInterface.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • terms
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_login/services/provider.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier LoggedHelper.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_associations/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_scheduler/services/provider.php


Joomla CMS: Répertoire de référence de cbor-php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
Répertoire de référence de cbor-php

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de mod_articles_categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
Répertoire de référence de mod_articles_categories

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_articles_categories.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
  • field
Répertoire de référence de field

Répertoires

répertoire tinymcebuilder

Fichiers

fichier tinymcebuilder.php


Joomla CMS: Répertoire de référence de editors

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • layouts
  • editors
Répertoire de référence de editors

Répertoires

répertoire codemirror


Joomla CMS: Répertoire de référence de Category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • View
  • Category
Répertoire de référence de Category

Fichiers

fichier | com_content/src/View/Category/FeedView.php
fichier | components/com_content/src/View/Category/HtmlView.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | _item.php
fichier | modules/mod_articles_news/tmpl/default.php
fichier | horizontal.php
fichier | vertical.php


Joomla CMS: Répertoire de référence de namespacemap

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • extension
  • namespacemap
Répertoire de référence de namespacemap

Fichiers

fichier plugins/extension/namespacemap/namespacemap.php


Joomla CMS: Répertoire de référence de Poly1305

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Poly1305
Répertoire de référence de Poly1305

Fichiers

fichier src/Core32/Poly1305/State.php


Joomla CMS: Répertoire de référence de Provider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
Répertoire de référence de Provider

Répertoires

répertoire | Node
répertoire | Time

Fichiers

fichier | NodeProviderInterface.php
fichier | TimeProviderInterface.php


Joomla CMS: Répertoire de référence de request

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • request
Répertoire de référence de request

Fichiers

fichier components/com_privacy/tmpl/request/default.php


Joomla CMS: Répertoire de référence de Menutypes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menutypes
Répertoire de référence de Menutypes

Fichiers

fichier administrator/components/com_menus/src/View/Menutypes/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | Service


Joomla CMS: Répertoire de référence de Transition

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Transition
Répertoire de référence de Transition

Fichiers

fichier administrator/components/com_workflow/src/View/Transition/HtmlView.php


Joomla CMS: Répertoire de référence de taggable

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
Répertoire de référence de taggable

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de mod_multilangstatus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_multilangstatus
Répertoire de référence de mod_multilangstatus

Répertoires

répertoire tmpl

Fichiers

fichier mod_multilangstatus.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Note

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Note
Répertoire de référence de Note

Fichiers

fichier administrator/components/com_users/src/View/Note/HtmlView.php


Joomla CMS: Répertoire de référence de Help

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Help
Répertoire de référence de Help

Fichiers

fichier Help.php


Joomla CMS: Répertoire de référence de contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contact
Répertoire de référence de contact

Fichiers

fichier | administrator/components/com_contact/tmpl/contact/edit.php
fichier | administrator/components/com_contact/tmpl/contact/modal.php


Joomla CMS: Répertoire de référence de filesystem

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
Répertoire de référence de filesystem

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Transport

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
  • Transport
Répertoire de référence de Transport

Fichiers

fichier | CurlTransport.php
fichier | SocketTransport.php
fichier | StreamTransport.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_latest/tmpl/default.php


Joomla CMS: Répertoire de référence de checkin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • tmpl
  • checkin
Répertoire de référence de checkin

Fichiers

fichier | administrator/components/com_checkin/tmpl/checkin/default.php
fichier | administrator/components/com_checkin/tmpl/checkin/emptystate.php


Joomla CMS: Répertoire de référence de newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • newsfeeds
Répertoire de référence de newsfeeds

Fichiers

fichier plugins/finder/newsfeeds/newsfeeds.php


Joomla CMS: Répertoire de référence de mod_breadcrumbs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
Répertoire de référence de mod_breadcrumbs

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_breadcrumbs.php


Joomla CMS: Répertoire de référence de com_finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
Répertoire de référence de com_finder

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Method

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • View
  • Method
Répertoire de référence de Method

Fichiers

fichier components/com_users/src/View/Method/HtmlView.php


Joomla CMS: Répertoire de référence de editors

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
Répertoire de référence de editors

Répertoires

répertoire tinymce


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | components/com_config/src/Model/ConfigModel.php
fichier | components/com_config/src/Model/FormModel.php
fichier | components/com_config/src/Model/ModulesModel.php
fichier | components/com_config/src/Model/TemplatesModel.php


Joomla CMS: Répertoire de référence de Assert

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
  • lib
  • Assert
Répertoire de référence de Assert

Fichiers

fichier | beberlei/assert/lib/Assert/Assert.php
fichier | Assertion.php
fichier | AssertionChain.php
fichier | AssertionFailedException.php
fichier | beberlei/assert/lib/Assert/functions.php
fichier | beberlei/assert/lib/Assert/InvalidArgumentException.php
fichier | LazyAssertion.php
fichier | LazyAssertionException.php


Joomla CMS: Répertoire de référence de Algorithm

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Algorithm
Répertoire de référence de Algorithm

Fichiers

fichier | MacAlgorithm.php
fichier | SignatureAlgorithm.php


Joomla CMS: Répertoire de référence de consents

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • consents
Répertoire de référence de consents

Fichiers

fichier consents.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_joomlaupdate/src/Controller/DisplayController.php
fichier | com_joomlaupdate/src/Controller/UpdateController.php


Joomla CMS: Répertoire de référence de Serializer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
  • src
  • Serializer
Répertoire de référence de Serializer

Fichiers

fichier NewsfeedSerializer.php


Joomla CMS: Répertoire de référence de installer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • installer
Répertoire de référence de installer

Fichiers

fichier plugins/webservices/installer/installer.php


Joomla CMS: Répertoire de référence de Core

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Répertoire de référence de Core

Répertoires

répertoire | ChaCha20
répertoire | Curve25519
répertoire | Poly1305

Fichiers

fichier | namespaced/Core/BLAKE2b.php
fichier | paragonie/sodium_compat/namespaced/Core/ChaCha20.php
fichier | paragonie/sodium_compat/namespaced/Core/Curve25519.php
fichier | paragonie/sodium_compat/namespaced/Core/Ed25519.php
fichier | namespaced/Core/HChaCha20.php
fichier | namespaced/Core/HSalsa20.php
fichier | namespaced/Core/Poly1305.php
fichier | paragonie/sodium_compat/namespaced/Core/Salsa20.php
fichier | namespaced/Core/SipHash.php
fichier | paragonie/sodium_compat/namespaced/Core/Util.php
fichier | namespaced/Core/X25519.php
fichier | namespaced/Core/XChaCha20.php
fichier | Xsalsa20.php


Joomla CMS: Répertoire de référence de libraries

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
Répertoire de référence de libraries

Répertoires

répertoire html


Joomla CMS: Répertoire de référence de ErrorRenderer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorRenderer
Répertoire de référence de ErrorRenderer

Fichiers

fichier | CliErrorRenderer.php
fichier | ErrorRendererInterface.php
fichier | HtmlErrorRenderer.php
fichier | SerializerErrorRenderer.php


Joomla CMS: Répertoire de référence de ramsey

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
Répertoire de référence de ramsey

Répertoires

répertoire uuid


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | components/com_content/src/Controller/ArticleController.php
fichier | components/com_content/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Storage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • Storage
Répertoire de référence de Storage

Fichiers

fichier JoomlaStorage.php


Joomla CMS: Répertoire de référence de tobscure

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
Répertoire de référence de tobscure

Répertoires

répertoire json-api


Joomla CMS: Répertoire de référence de Uri

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Uri
Répertoire de référence de Uri

Fichiers

fichier src/Uri/Uri.php


Joomla CMS: Répertoire de référence de error-handler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Répertoire de référence de error-handler

Répertoires

répertoire | Error
répertoire | ErrorEnhancer
répertoire | ErrorRenderer
répertoire | Exception
répertoire | Internal
répertoire | Resources

Fichiers

fichier | BufferingLogger.php
fichier | vendor/symfony/error-handler/Debug.php
fichier | DebugClassLoader.php
fichier | symfony/error-handler/ErrorHandler.php
fichier | ThrowableUtils.php


Joomla CMS: Répertoire de référence de phpversioncheck

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • phpversioncheck
Répertoire de référence de phpversioncheck

Fichiers

fichier phpversioncheck.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de Router

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Répertoire de référence de Router

Répertoires

répertoire Rules

Fichiers

fichier | RouterBase.php
fichier | Component/Router/RouterFactory.php
fichier | RouterFactoryInterface.php
fichier | src/Component/Router/RouterInterface.php
fichier | RouterLegacy.php
fichier | RouterServiceInterface.php
fichier | RouterServiceTrait.php
fichier | RouterView.php
fichier | RouterViewConfiguration.php


Joomla CMS: Répertoire de référence de Pathway

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pathway
Répertoire de référence de Pathway

Fichiers

fichier | Pathway/Pathway.php
fichier | SitePathway.php


Joomla CMS: Répertoire de référence de categories

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • categories
Répertoire de référence de categories

Fichiers

fichier plugins/finder/categories/categories.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | UnknownArchiveException.php
fichier | UnsupportedArchiveException.php


Joomla CMS: Répertoire de référence de Inflector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Répertoire de référence de Inflector

Répertoires

répertoire Rules

Fichiers

fichier | CachedWordInflector.php
fichier | GenericLanguageInflectorFactory.php
fichier | doctrine/inflector/lib/Doctrine/Inflector/Inflector.php
fichier | InflectorFactory.php
fichier | libraries/vendor/doctrine/inflector/lib/Doctrine/Inflector/Language.php
fichier | LanguageInflectorFactory.php
fichier | NoopWordInflector.php
fichier | RulesetInflector.php
fichier | WordInflector.php


Joomla CMS: Répertoire de référence de com_content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
Répertoire de référence de com_content

Répertoires

répertoire | helpers
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • integer
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/integer.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
Répertoire de référence de src

Répertoires

répertoire Negotiation


Joomla CMS: Répertoire de référence de installed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • tmpl
  • installed
Répertoire de référence de installed

Fichiers

fichier administrator/components/com_languages/tmpl/installed/default.php


Joomla CMS: Répertoire de référence de Messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • View
  • Messages
Répertoire de référence de Messages

Fichiers

fichier administrator/components/com_messages/src/View/Messages/HtmlView.php


Joomla CMS: Répertoire de référence de Stage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Stage
Répertoire de référence de Stage

Fichiers

fichier administrator/components/com_workflow/src/View/Stage/HtmlView.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | InvalidUuidStringException.php
fichier | vendor/ramsey/uuid/src/Exception/UnsatisfiedDependencyException.php
fichier | ramsey/uuid/src/Exception/UnsupportedOperationException.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Template
répertoire | Templates


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_multilangstatus
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier administrator/modules/mod_multilangstatus/tmpl/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
Répertoire de référence de src

Répertoires

répertoire DebugBar


Joomla CMS: Répertoire de référence de Stages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • View
  • Stages
Répertoire de référence de Stages

Fichiers

fichier administrator/components/com_workflow/src/View/Stages/HtmlView.php


Joomla CMS: Répertoire de référence de TrustPath

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Répertoire de référence de TrustPath

Fichiers

fichier | CertificateTrustPath.php
fichier | EcdaaKeyIdTrustPath.php
fichier | EmptyTrustPath.php
fichier | TrustPath.php
fichier | TrustPathLoader.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
  • services
Répertoire de référence de services

Fichiers

fichier plugins/task/checkfiles/services/provider.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | CapabilitiesModel.php
fichier | ConsentsModel.php
fichier | ExportModel.php
fichier | RemoveModel.php
fichier | administrator/components/com_privacy/src/Model/RequestModel.php
fichier | RequestsModel.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | file
répertoire | media


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_logged
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | administrator/modules/mod_logged/tmpl/default.php
fichier | administrator/modules/mod_logged/tmpl/disabled.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier StatsAdminHelper.php


Joomla CMS: Répertoire de référence de PluginTraits

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Répertoire de référence de PluginTraits

Fichiers

fichier | AdditionalLoginButtons.php
fichier | AjaxHandler.php
fichier | AjaxHandlerChallenge.php
fichier | AjaxHandlerCreate.php
fichier | AjaxHandlerDelete.php
fichier | AjaxHandlerInitCreate.php
fichier | AjaxHandlerLogin.php
fichier | AjaxHandlerSaveLabel.php
fichier | EventReturnAware.php
fichier | UserDeletion.php
fichier | UserProfileFields.php


Joomla CMS: Répertoire de référence de Completion

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
Répertoire de référence de Completion

Répertoires

répertoire Output

Fichiers

fichier | CompletionInput.php
fichier | CompletionSuggestions.php
fichier | Suggestion.php


Joomla CMS: Répertoire de référence de Strings

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • View
  • Strings
Répertoire de référence de Strings

Fichiers

fichier com_languages/src/View/Strings/JsonapiView.php


Joomla CMS: Répertoire de référence de Tracks

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Tracks
Répertoire de référence de Tracks

Fichiers

fichier | administrator/components/com_banners/src/View/Tracks/HtmlView.php
fichier | RawView.php


Joomla CMS: Répertoire de référence de default

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Répertoire de référence de default

Fichiers

fichier | bar.php
fichier | filters.php
fichier | layouts/joomla/searchtools/default/list.php
fichier | noitems.php
fichier | selector.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | administrator/components/com_users/src/Model/BackupcodesModel.php
fichier | administrator/components/com_users/src/Model/CaptiveModel.php
fichier | DebuggroupModel.php
fichier | DebuguserModel.php
fichier | com_users/src/Model/GroupModel.php
fichier | com_users/src/Model/GroupsModel.php
fichier | LevelModel.php
fichier | LevelsModel.php
fichier | MailModel.php
fichier | administrator/components/com_users/src/Model/MethodModel.php
fichier | administrator/components/com_users/src/Model/MethodsModel.php
fichier | NoteModel.php
fichier | NotesModel.php
fichier | UserModel.php
fichier | UsersModel.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Categories
répertoire | Category
répertoire | Newsfeed


Joomla CMS: Répertoire de référence de fr-FR

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • language
  • fr-FR
Répertoire de référence de fr-FR

Fichiers

fichier language/fr-FR/localise.php


Joomla CMS: Répertoire de référence de Reductions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Répertoire de référence de Reductions

Fichiers

fichier | PHP/Reductions/Barrett.php
fichier | Classic.php
fichier | PHP/Reductions/EvalBarrett.php
fichier | Math/BigInteger/Engines/PHP/Reductions/Montgomery.php
fichier | MontgomeryMult.php
fichier | PowerOfTwo.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_actionlogs/services/provider.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • checkboxes
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier plugins/fields/checkboxes/tmpl/checkboxes.php


Joomla CMS: Répertoire de référence de http-factory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
Répertoire de référence de http-factory

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Répertoire de référence de Filter

Fichiers

fichier | IntarrayFilter.php
fichier | RawFilter.php
fichier | RulesFilter.php
fichier | SafehtmlFilter.php
fichier | TelFilter.php
fichier | UnsetFilter.php
fichier | UrlFilter.php


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Modules.php


Joomla CMS: Répertoire de référence de token

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • token
Répertoire de référence de token

Répertoires

répertoire src

Fichiers

fichier plugins/user/token/token.php


Joomla CMS: Répertoire de référence de Validator

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Validator
Répertoire de référence de Validator

Fichiers

fichier | AddressValidator.php
fichier | ForwardedValidator.php


Joomla CMS: Répertoire de référence de Cache

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • View
  • Cache
Répertoire de référence de Cache

Fichiers

fichier administrator/components/com_cache/src/View/Cache/HtmlView.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_joomlaupdate/services/provider.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier plugins/system/cache/src/Extension/Cache.php


Joomla CMS: Répertoire de référence de discover

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • discover
Répertoire de référence de discover

Fichiers

fichier | administrator/components/com_installer/tmpl/discover/default.php
fichier | administrator/components/com_installer/tmpl/discover/emptystate.php


Joomla CMS: Répertoire de référence de Maps

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Maps
Répertoire de référence de Maps

Fichiers

fichier administrator/components/com_finder/src/View/Maps/HtmlView.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | ConsentTable.php
fichier | RequestTable.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | style
répertoire | styles
répertoire | template
répertoire | templates


Joomla CMS: Répertoire de référence de notes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • notes
Répertoire de référence de notes

Fichiers

fichier | administrator/components/com_users/tmpl/notes/default.php
fichier | administrator/components/com_users/tmpl/notes/emptystate.php
fichier | administrator/components/com_users/tmpl/notes/modal.php


Joomla CMS: Répertoire de référence de Universal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Répertoire de référence de Universal

Fichiers

fichier | BitString.php
fichier | BMPString.php
fichier | Boolean.php
fichier | CharacterString.php
fichier | Enumerated.php
fichier | GeneralizedTime.php
fichier | GeneralString.php
fichier | GraphicString.php
fichier | IA5String.php
fichier | fgrosse/phpasn1/lib/ASN1/Universal/Integer.php
fichier | fgrosse/phpasn1/lib/ASN1/Universal/NullObject.php
fichier | NumericString.php
fichier | ObjectDescriptor.php
fichier | ObjectIdentifier.php
fichier | OctetString.php
fichier | PrintableString.php
fichier | RelativeObjectIdentifier.php
fichier | Sequence.php
fichier | Set.php
fichier | T61String.php
fichier | UniversalString.php
fichier | UTCTime.php
fichier | UTF8String.php
fichier | VisibleString.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_articles_latest/tmpl/default.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier MenusComponent.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | View


Joomla CMS: Répertoire de référence de Request

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Request
Répertoire de référence de Request

Fichiers

fichier | Request/ArraySerializer.php
fichier | laminas/laminas-diactoros/src/Request/Serializer.php


Joomla CMS: Répertoire de référence de com_messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_messages
Répertoire de référence de com_messages

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
  • services
Répertoire de référence de services

Fichiers

fichier plugins/task/demotasks/services/provider.php


Joomla CMS: Répertoire de référence de Factory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Factory
Répertoire de référence de Factory

Fichiers

fichier | ApiMVCFactory.php
fichier | LegacyFactory.php
fichier | MVC/Factory/MVCFactory.php
fichier | MVCFactoryAwareTrait.php
fichier | MVCFactoryInterface.php
fichier | MVCFactoryServiceInterface.php
fichier | MVCFactoryServiceTrait.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_finder/tmpl/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_random_image/tmpl/default.php


Joomla CMS: Répertoire de référence de Notes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
  • Notes
Répertoire de référence de Notes

Fichiers

fichier administrator/components/com_users/src/View/Notes/HtmlView.php


Joomla CMS: Répertoire de référence de Tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Tag
Répertoire de référence de Tag

Fichiers

fichier TaggedValue.php


Joomla CMS: Répertoire de référence de Modal

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • Field
  • Modal
Répertoire de référence de Modal

Fichiers

fichier AssociationField.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier MenuHelper.php


Joomla CMS: Répertoire de référence de Rule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Rule
Répertoire de référence de Rule

Fichiers

fichier ExecutionRulesRule.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_modules/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
  • src
Répertoire de référence de src

Répertoires

répertoire Extension


Joomla CMS: Répertoire de référence de Cipher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Cipher
Répertoire de référence de Cipher

Fichiers

fichier | vendor/joomla/crypt/src/Cipher/Crypto.php
fichier | vendor/joomla/crypt/src/Cipher/OpenSSL.php
fichier | Sodium.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
Répertoire de référence de joomla

Répertoires

répertoire | application
répertoire | archive
répertoire | authentication
répertoire | console
répertoire | crypt
répertoire | data
répertoire | database
répertoire | di
répertoire | event
répertoire | filesystem
répertoire | filter
répertoire | http
répertoire | input
répertoire | ldap
répertoire | oauth1
répertoire | oauth2
répertoire | registry
répertoire | router
répertoire | session
répertoire | string
répertoire | uri
répertoire | utilities


Joomla CMS: Répertoire de référence de profile

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • profile
Répertoire de référence de profile

Fichiers

fichier | components/com_users/tmpl/profile/default.php
fichier | default_core.php
fichier | default_custom.php
fichier | default_params.php
fichier | components/com_users/tmpl/profile/edit.php


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-experimental

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-experimental
Répertoire de référence de jwt-signature-algorithm-experimental

Fichiers

fichier | web-token/jwt-signature-algorithm-experimental/ES256K.php
fichier | HS1.php
fichier | HS256_64.php
fichier | web-token/jwt-signature-algorithm-experimental/RS1.php


Joomla CMS: Répertoire de référence de assert

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
  • assert
Répertoire de référence de assert

Répertoires

répertoire lib


Joomla CMS: Répertoire de référence de com_newsfeeds

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_newsfeeds
Répertoire de référence de com_newsfeeds

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de pagination

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • pagination
Répertoire de référence de pagination

Fichiers

fichier | pagination/link.php
fichier | links.php
fichier | layouts/joomla/pagination/list.php


Joomla CMS: Répertoire de référence de fields

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • layouts
  • fields
Répertoire de référence de fields

Fichiers

fichier com_contact/layouts/fields/render.php


Joomla CMS: Répertoire de référence de image

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • image
Répertoire de référence de image

Fichiers

fichier plugins/editors-xtd/image/image.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | View


Joomla CMS: Répertoire de référence de di

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
Répertoire de référence de di

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Sqlazure

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlazure
Répertoire de référence de Sqlazure

Fichiers

fichier | SqlazureDriver.php
fichier | SqlazureQuery.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | categories
répertoire | category
répertoire | newsfeed


Joomla CMS: Répertoire de référence de com_contenthistory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
Répertoire de référence de com_contenthistory

Répertoires

répertoire | helpers
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de mod_footer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_footer
Répertoire de référence de mod_footer

Répertoires

répertoire tmpl

Fichiers

fichier mod_footer.php


Joomla CMS: Répertoire de référence de module

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • module
Répertoire de référence de module

Fichiers

fichier module.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Répertoire de référence de src

Fichiers

fichier | phpmailer/phpmailer/src/Exception.php
fichier | OAuth.php
fichier | OAuthTokenProvider.php
fichier | PHPMailer.php
fichier | POP3.php
fichier | SMTP.php


Joomla CMS: Répertoire de référence de schedulerunner

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • schedulerunner
Répertoire de référence de schedulerunner

Fichiers

fichier schedulerunner.php


Joomla CMS: Répertoire de référence de updatesite

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • updatesite
Répertoire de référence de updatesite

Fichiers

fichier administrator/components/com_installer/tmpl/updatesite/edit.php


Joomla CMS: Répertoire de référence de featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • featured
Répertoire de référence de featured

Fichiers

fichier | administrator/components/com_content/tmpl/featured/default.php
fichier | default_stage_body.php
fichier | default_stage_footer.php
fichier | administrator/components/com_content/tmpl/featured/emptystate.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_plugins/src/Controller/PluginsController.php


Joomla CMS: Répertoire de référence de field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • layouts
  • field
Répertoire de référence de field

Fichiers

fichier com_contact/layouts/field/render.php


Joomla CMS: Répertoire de référence de mod_finder

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_finder
Répertoire de référence de mod_finder

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_finder.php


Joomla CMS: Répertoire de référence de upload

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • upload
Répertoire de référence de upload

Fichiers

fichier | captive.php
fichier | administrator/components/com_joomlaupdate/tmpl/upload/default.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier DatabaseHelper.php


Joomla CMS: Répertoire de référence de Tag

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Répertoire de référence de Tag

Fichiers

fichier | TagApiSerializerTrait.php
fichier | TaggableTableInterface.php
fichier | TaggableTableTrait.php
fichier | TagServiceInterface.php
fichier | TagServiceTrait.php


Joomla CMS: Répertoire de référence de preview

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • preview
Répertoire de référence de preview

Fichiers

fichier preview.php


Joomla CMS: Répertoire de référence de template

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • tmpl
  • template
Répertoire de référence de template

Fichiers

fichier administrator/components/com_mails/tmpl/template/edit.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_media/services/provider.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier MailsHelper.php


Joomla CMS: Répertoire de référence de Event

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Event
Répertoire de référence de Event

Fichiers

fichier | AbstractMediaItemValidationEvent.php
fichier | FetchMediaItemEvent.php
fichier | FetchMediaItemsEvent.php
fichier | FetchMediaItemUrlEvent.php
fichier | MediaProviderEvent.php
fichier | OAuthCallbackEvent.php


Joomla CMS: Répertoire de référence de PluginTraits

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Répertoire de référence de PluginTraits

Fichiers

fichier | ActiveSiteTemplate.php
fichier | DisplayTrait.php
fichier | GlobalFilters.php
fichier | KnownButtons.php
fichier | ResolveFiles.php
fichier | ToolbarPresets.php
fichier | XTDButtons.php


Joomla CMS: Répertoire de référence de Util

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
  • Util
Répertoire de référence de Util

Fichiers

fichier web-token/jwt-signature-algorithm-rsa/Util/RSA.php


Joomla CMS: Répertoire de référence de Filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • View
  • Filter
Répertoire de référence de Filter

Fichiers

fichier administrator/components/com_finder/src/View/Filter/HtmlView.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_templates/src/Controller/StylesController.php


Joomla CMS: Répertoire de référence de enshrined

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
Répertoire de référence de enshrined

Répertoires

répertoire svg-sanitize


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_modules/services/provider.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Captive
répertoire | Debuggroup
répertoire | Debuguser
répertoire | Group
répertoire | Groups
répertoire | Level
répertoire | Levels
répertoire | Mail
répertoire | Method
répertoire | Methods
répertoire | Note
répertoire | Notes
répertoire | User
répertoire | Users

Fichiers

fichier SiteTemplateTrait.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier WrapperHelper.php


Joomla CMS: Répertoire de référence de transition

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • transition
Répertoire de référence de transition

Fichiers

fichier administrator/components/com_workflow/tmpl/transition/edit.php


Joomla CMS: Répertoire de référence de Twig

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • Twig
Répertoire de référence de Twig

Fichiers

fichier | TimeableTwigExtensionProfiler.php
fichier | TraceableTwigEnvironment.php
fichier | TraceableTwigTemplate.php
fichier | TwigCollector.php


Joomla CMS: Répertoire de référence de mod_articles_popular

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_popular
Répertoire de référence de mod_articles_popular

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_articles_popular.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | config
répertoire | modules
répertoire | templates


Joomla CMS: Répertoire de référence de Curve25519

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
Répertoire de référence de Curve25519

Répertoires

répertoire Ge

Fichiers

fichier | namespaced/Core/Curve25519/Fe.php
fichier | namespaced/Core/Curve25519/H.php


Joomla CMS: Répertoire de référence de cpanel

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • tmpl
  • cpanel
Répertoire de référence de cpanel

Fichiers

fichier administrator/components/com_cpanel/tmpl/cpanel/default.php


Joomla CMS: Répertoire de référence de Login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • View
  • Login
Répertoire de référence de Login

Fichiers

fichier administrator/components/com_login/src/View/Login/HtmlView.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_latest
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de indexer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
  • indexer
Répertoire de référence de indexer

Fichiers

fichier administrator/components/com_finder/tmpl/indexer/default.php


Joomla CMS: Répertoire de référence de Clients

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Clients
Répertoire de référence de Clients

Fichiers

fichier administrator/components/com_banners/src/View/Clients/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier administrator/components/com_banners/src/Helper/BannersHelper.php


Joomla CMS: Répertoire de référence de debugbar

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
Répertoire de référence de debugbar

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de mod_custom

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_custom
Répertoire de référence de mod_custom

Répertoires

répertoire tmpl

Fichiers

fichier modules/mod_custom/mod_custom.php


Joomla CMS: Répertoire de référence de languagefilter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • languagefilter
Répertoire de référence de languagefilter

Fichiers

fichier languagefilter.php


Joomla CMS: Répertoire de référence de contactcreator

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • contactcreator
Répertoire de référence de contactcreator

Fichiers

fichier contactcreator.php


Joomla CMS: Répertoire de référence de cron-expression

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • dragonmantank
  • cron-expression
Répertoire de référence de cron-expression

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Select
répertoire | Task
répertoire | Tasks


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/modules/mod_quickicon/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de indexer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Répertoire de référence de indexer

Fichiers

fichier | adapter.php
fichier | helper.php
fichier | parser.php
fichier | query.php
fichier | result.php
fichier | taxonomy.php
fichier | administrator/components/com_finder/helpers/indexer/token.php


Joomla CMS: Répertoire de référence de link

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • link
Répertoire de référence de link

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de BCMath

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • BCMath
Répertoire de référence de BCMath

Répertoires

répertoire Reductions

Fichiers

fichier | Math/BigInteger/Engines/BCMath/Base.php
fichier | BuiltIn.php
fichier | BCMath/DefaultEngine.php
fichier | vendor/phpseclib/phpseclib/phpseclib/Math/BigInteger/Engines/BCMath/OpenSSL.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_banners
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Banners
répertoire | Clients


Joomla CMS: Répertoire de référence de SAN

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • SAN
Répertoire de référence de SAN

Fichiers

fichier | DNSName.php
fichier | IPAddress.php
fichier | SubjectAlternativeNames.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_breadcrumbs
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier BreadcrumbsHelper.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier FilesystemException.php


Joomla CMS: Répertoire de référence de contacts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • tmpl
  • contacts
Répertoire de référence de contacts

Fichiers

fichier | administrator/components/com_contact/tmpl/contacts/default.php
fichier | com_contact/tmpl/contacts/default_batch_body.php
fichier | com_contact/tmpl/contacts/default_batch_footer.php
fichier | administrator/components/com_contact/tmpl/contacts/emptystate.php
fichier | administrator/components/com_contact/tmpl/contacts/modal.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Répertoire de référence de src

Répertoires

répertoire | OtherObject
répertoire | Tag

Fichiers

fichier | AbstractCBORObject.php
fichier | ByteStringObject.php
fichier | ByteStringWithChunkObject.php
fichier | CBORObject.php
fichier | spomky-labs/cbor-php/src/Decoder.php
fichier | InfiniteListObject.php
fichier | InfiniteMapObject.php
fichier | LengthCalculator.php
fichier | ListObject.php
fichier | MapItem.php
fichier | MapObject.php
fichier | OtherObject.php
fichier | SignedIntegerObject.php
fichier | vendor/spomky-labs/cbor-php/src/Stream.php
fichier | spomky-labs/cbor-php/src/StringStream.php
fichier | TagObject.php
fichier | TextStringObject.php
fichier | TextStringWithChunkObject.php
fichier | UnsignedIntegerObject.php
fichier | Utils.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
  • src
Répertoire de référence de src

Répertoires

répertoire Menu


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • data
  • src
Répertoire de référence de src

Fichiers

fichier | DataObject.php
fichier | joomla/data/src/DataSet.php
fichier | DumpableInterface.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Messages


Joomla CMS: Répertoire de référence de Tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
  • Tags
Répertoire de référence de Tags

Fichiers

fichier | com_tags/src/View/Tags/FeedView.php
fichier | components/com_tags/src/View/Tags/HtmlView.php


Joomla CMS: Répertoire de référence de joomla

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • joomla
Répertoire de référence de joomla

Fichiers

fichier plugins/user/joomla/joomla.php


Joomla CMS: Répertoire de référence de Web

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Web
Répertoire de référence de Web

Fichiers

fichier WebClient.php


Joomla CMS: Répertoire de référence de Provider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Provider
Répertoire de référence de Provider

Fichiers

fichier | ProviderInterface.php
fichier | ProviderManager.php
fichier | ProviderManagerHelperTrait.php


Joomla CMS: Répertoire de référence de content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • content
Répertoire de référence de content

Fichiers

fichier plugins/finder/content/content.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
Répertoire de référence de src

Répertoires

répertoire Stemmer

Fichiers

fichier | NotFoundException.php
fichier | StemmerFactory.php
fichier | StemmerManager.php


Joomla CMS: Répertoire de référence de readmore

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • readmore
Répertoire de référence de readmore

Fichiers

fichier plugins/editors-xtd/readmore/readmore.php


Joomla CMS: Répertoire de référence de Validation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Répertoire de référence de Validation

Répertoires

répertoire Constraint

Fichiers

fichier | Constraint.php
fichier | ConstraintViolation.php
fichier | NoConstraintsGiven.php
fichier | RequiredConstraintsViolated.php
fichier | Validation/Validator.php


Joomla CMS: Répertoire de référence de ChaCha20

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • ChaCha20
Répertoire de référence de ChaCha20

Fichiers

fichier | namespaced/Core/ChaCha20/Ctx.php
fichier | namespaced/Core/ChaCha20/IetfCtx.php


Joomla CMS: Répertoire de référence de Languages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Languages
Répertoire de référence de Languages

Fichiers

fichier administrator/components/com_installer/src/View/Languages/HtmlView.php


Joomla CMS: Répertoire de référence de Parser

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Parser
Répertoire de référence de Parser

Fichiers

fichier | Html.php
fichier | Rtf.php
fichier | Txt.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_users_latest/tmpl/default.php


Joomla CMS: Répertoire de référence de wamania

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
Répertoire de référence de wamania

Répertoires

répertoire php-stemmer


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | SearchModel.php
fichier | SuggestionsModel.php


Joomla CMS: Répertoire de référence de checkfiles

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
Répertoire de référence de checkfiles

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Field
répertoire | Helper
répertoire | Model
répertoire | Plugin
répertoire | View


Joomla CMS: Répertoire de référence de console

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
Répertoire de référence de console

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • src
Répertoire de référence de src

Répertoires

répertoire Field


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier TagsSimilarHelper.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Tag
répertoire | Tags


Joomla CMS: Répertoire de référence de com_login

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
Répertoire de référence de com_login

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_categories
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de link

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • tmpl
  • link
Répertoire de référence de link

Fichiers

fichier administrator/components/com_redirect/tmpl/link/edit.php


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Adapter
Répertoire de référence de Adapter

Fichiers

fichier administrator/components/com_media/src/Adapter/AdapterInterface.php


Joomla CMS: Répertoire de référence de Request

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Request
Répertoire de référence de Request

Fichiers

fichier administrator/components/com_privacy/src/View/Request/HtmlView.php


Joomla CMS: Répertoire de référence de Contacts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • View
  • Contacts
Répertoire de référence de Contacts

Fichiers

fichier administrator/components/com_contact/src/View/Contacts/HtmlView.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier RelatedItemsHelper.php


Joomla CMS: Répertoire de référence de C:

  • C:
Répertoire de référence de C:

Répertoires

répertoire laragon


Joomla CMS: Répertoire de référence de mod_messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_messages
Répertoire de référence de mod_messages

Répertoires

répertoire tmpl

Fichiers

fichier mod_messages.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de system

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • system
Répertoire de référence de system

Fichiers

fichier layouts/joomla/system/message.php


Joomla CMS: Répertoire de référence de psr

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
Répertoire de référence de psr

Répertoires

répertoire | container
répertoire | http-client
répertoire | http-factory
répertoire | http-message
répertoire | link
répertoire | log


Joomla CMS: Répertoire de référence de EdDSA

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • EdDSA
Répertoire de référence de EdDSA

Fichiers

fichier | web-auth/cose-lib/src/Algorithm/Signature/EdDSA/Ed25519.php
fichier | ED256.php
fichier | ED512.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/EdDSA/EdDSA.php


Joomla CMS: Répertoire de référence de yubikey

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
Répertoire de référence de yubikey

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de confirm

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • tmpl
  • confirm
Répertoire de référence de confirm

Fichiers

fichier components/com_privacy/tmpl/confirm/default.php


Joomla CMS: Répertoire de référence de Banner

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Banner
Répertoire de référence de Banner

Fichiers

fichier administrator/components/com_banners/src/View/Banner/HtmlView.php


Joomla CMS: Répertoire de référence de Manage

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Manage
Répertoire de référence de Manage

Fichiers

fichier administrator/components/com_installer/src/View/Manage/HtmlView.php


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • View
  • Plugin
Répertoire de référence de Plugin

Fichiers

fichier administrator/components/com_plugins/src/View/Plugin/HtmlView.php


Joomla CMS: Répertoire de référence de SFTP

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Net
  • SFTP
Répertoire de référence de SFTP

Fichiers

fichier vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php


Joomla CMS: Répertoire de référence de Common

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • Common
Répertoire de référence de Common

Répertoires

répertoire FiniteField

Fichiers

fichier FiniteField.php


Joomla CMS: Répertoire de référence de Output

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
  • Output
Répertoire de référence de Output

Fichiers

fichier | BashCompletionOutput.php
fichier | CompletionOutputInterface.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | ContainerControllerResolver.php
fichier | ControllerResolver.php
fichier | ControllerResolverInterface.php


Joomla CMS: Répertoire de référence de Ge

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Répertoire de référence de Ge

Fichiers

fichier | src/Core/Curve25519/Ge/Cached.php
fichier | src/Core/Curve25519/Ge/P1p1.php
fichier | src/Core/Curve25519/Ge/P2.php
fichier | src/Core/Curve25519/Ge/P3.php
fichier | src/Core/Curve25519/Ge/Precomp.php


Joomla CMS: Répertoire de référence de NamePrep

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • NamePrep
Répertoire de référence de NamePrep

Fichiers

fichier | NamePrep.php
fichier | NamePrepData2003.php
fichier | NamePrepData2008.php
fichier | NamePrepDataInterface.php
fichier | NamePrepInterface.php


Joomla CMS: Répertoire de référence de mod_random_image

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
Répertoire de référence de mod_random_image

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_random_image.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | stage
répertoire | stages
répertoire | transition
répertoire | transitions
répertoire | workflow
répertoire | workflows


Joomla CMS: Répertoire de référence de method

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • method
Répertoire de référence de method

Fichiers

fichier | components/com_users/tmpl/method/backupcodes.php
fichier | components/com_users/tmpl/method/edit.php


Joomla CMS: Répertoire de référence de com_media

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_media
Répertoire de référence de com_media

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de ChaCha20

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • ChaCha20
Répertoire de référence de ChaCha20

Fichiers

fichier | src/Core32/ChaCha20/Ctx.php
fichier | src/Core32/ChaCha20/IetfCtx.php


Joomla CMS: Répertoire de référence de repeatable

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable
Répertoire de référence de repeatable

Fichiers

fichier | section-byfieldsets.php
fichier | section.php


Joomla CMS: Répertoire de référence de includes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • includes
Répertoire de référence de includes

Fichiers

fichier | administrator/includes/app.php
fichier | administrator/includes/defines.php
fichier | administrator/includes/framework.php


Joomla CMS: Répertoire de référence de Keys

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Répertoire de référence de Keys

Fichiers

fichier | DSA/Formats/Keys/OpenSSH.php
fichier | DSA/Formats/Keys/PKCS1.php
fichier | DSA/Formats/Keys/PKCS8.php
fichier | DSA/Formats/Keys/PuTTY.php
fichier | DSA/Formats/Keys/Raw.php
fichier | DSA/Formats/Keys/XML.php


Joomla CMS: Répertoire de référence de en-GB

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • language
  • en-GB
Répertoire de référence de en-GB

Fichiers

fichier language/en-GB/localise.php


Joomla CMS: Répertoire de référence de Workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Workflow
Répertoire de référence de Workflow

Fichiers

fichier | Workflow.php
fichier | WorkflowPluginTrait.php
fichier | WorkflowServiceInterface.php
fichier | WorkflowServiceTrait.php


Joomla CMS: Répertoire de référence de Cipher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Crypt
  • Cipher
Répertoire de référence de Cipher

Fichiers

fichier | CryptoCipher.php
fichier | SodiumCipher.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
  • services
Répertoire de référence de services

Fichiers

fichier plugins/multifactorauth/fixed/services/provider.php


Joomla CMS: Répertoire de référence de Pdo

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pdo
Répertoire de référence de Pdo

Fichiers

fichier | PdoDriver.php
fichier | PdoQuery.php
fichier | PdoStatement.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire actionlogs


Joomla CMS: Répertoire de référence de Handler

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Répertoire de référence de Handler

Fichiers

fichier | ApcuHandler.php
fichier | DatabaseHandler.php
fichier | FilesystemHandler.php
fichier | MemcachedHandler.php
fichier | RedisHandler.php
fichier | WincacheHandler.php


Joomla CMS: Répertoire de référence de modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • modules
Répertoire de référence de modules

Fichiers

fichier plugins/webservices/modules/modules.php


Joomla CMS: Répertoire de référence de com_contenthistory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_contenthistory
Répertoire de référence de com_contenthistory

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | plugin
répertoire | plugins


Joomla CMS: Répertoire de référence de users

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • users
Répertoire de référence de users

Fichiers

fichier plugins/webservices/users/users.php


Joomla CMS: Répertoire de référence de Menus

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menus
Répertoire de référence de Menus

Fichiers

fichier administrator/components/com_menus/src/View/Menus/HtmlView.php


Joomla CMS: Répertoire de référence de plugins

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
  • plugins
Répertoire de référence de plugins

Fichiers

fichier administrator/components/com_plugins/tmpl/plugins/default.php


Joomla CMS: Répertoire de référence de Warnings

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • View
  • Warnings
Répertoire de référence de Warnings

Fichiers

fichier administrator/components/com_installer/src/View/Warnings/HtmlView.php


Joomla CMS: Répertoire de référence de modules

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • tmpl
  • modules
Répertoire de référence de modules

Fichiers

fichier | components/com_config/tmpl/modules/default.php
fichier | modules/default_options.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | CheckinCheckout.php
fichier | ResourceNotFound.php
fichier | Save.php
fichier | SendEmail.php


Joomla CMS: Répertoire de référence de overridecheck

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • overridecheck
Répertoire de référence de overridecheck

Fichiers

fichier overridecheck.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_modules
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier components/com_modules/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de WebAsset

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • WebAsset
Répertoire de référence de WebAsset

Fichiers

fichier | src/Event/WebAsset/AbstractEvent.php
fichier | WebAssetRegistryAssetChanged.php


Joomla CMS: Répertoire de référence de RSA

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Répertoire de référence de RSA

Fichiers

fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/PS256.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/PS384.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/PS512.php
fichier | PSSRSA.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/RS1.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/RS256.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/RS384.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/RS512.php
fichier | web-auth/cose-lib/src/Algorithm/Signature/RSA/RSA.php


Joomla CMS: Répertoire de référence de Adapter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Répertoire de référence de Adapter

Répertoires

répertoire ExtLdap

Fichiers

fichier | AbstractConnection.php
fichier | AbstractQuery.php
fichier | libraries/vendor/symfony/ldap/Adapter/AdapterInterface.php
fichier | CollectionInterface.php
fichier | ConnectionInterface.php
fichier | EntryManagerInterface.php
fichier | symfony/ldap/Adapter/QueryInterface.php


Joomla CMS: Répertoire de référence de user

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • user
Répertoire de référence de user

Répertoires

répertoire tmpl

Fichiers

fichier plugins/fields/user/user.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier CheckinModel.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_menu
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | collapse-default.php
fichier | modules/mod_menu/tmpl/default.php
fichier | default_component.php
fichier | default_heading.php
fichier | default_separator.php
fichier | default_url.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_fields/helpers/fields.php


Joomla CMS: Répertoire de référence de cookie

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • authentication
  • cookie
Répertoire de référence de cookie

Fichiers

fichier cookie.php


Joomla CMS: Répertoire de référence de updatenotification

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • updatenotification
Répertoire de référence de updatenotification

Répertoires

répertoire postinstall

Fichiers

fichier updatenotification.php


Joomla CMS: Répertoire de référence de typo3

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
Répertoire de référence de typo3

Répertoires

répertoire phar-stream-wrapper


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier NewsfeedsComponent.php


Joomla CMS: Répertoire de référence de sef

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • sef
Répertoire de référence de sef

Fichiers

fichier sef.php


Joomla CMS: Répertoire de référence de editors

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
Répertoire de référence de editors

Répertoires

répertoire | codemirror
répertoire | none
répertoire | tinymce


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Répertoire de référence de src

Répertoires

répertoire | Command
répertoire | Event
répertoire | Exception
répertoire | Monitor
répertoire | Mysql
répertoire | Mysqli
répertoire | Pdo
répertoire | Pgsql
répertoire | Query
répertoire | Service
répertoire | Sqlazure
répertoire | Sqlite
répertoire | Sqlsrv

Fichiers

fichier | DatabaseAwareInterface.php
fichier | vendor/joomla/database/src/DatabaseAwareTrait.php
fichier | DatabaseDriver.php
fichier | DatabaseEvents.php
fichier | DatabaseExporter.php
fichier | DatabaseFactory.php
fichier | DatabaseImporter.php
fichier | DatabaseInterface.php
fichier | DatabaseIterator.php
fichier | DatabaseQuery.php
fichier | FetchMode.php
fichier | FetchOrientation.php
fichier | ParameterType.php
fichier | joomla/database/src/QueryInterface.php
fichier | QueryMonitorInterface.php
fichier | StatementInterface.php
fichier | UTF8MB4SupportInterface.php


Joomla CMS: Répertoire de référence de language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
  • language
Répertoire de référence de language

Fichiers

fichier phpmailer.lang-en_gb.php


Joomla CMS: Répertoire de référence de clients

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • tmpl
  • clients
Répertoire de référence de clients

Fichiers

fichier | administrator/components/com_banners/tmpl/clients/default.php
fichier | administrator/components/com_banners/tmpl/clients/emptystate.php


Joomla CMS: Répertoire de référence de Contact

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • src
  • View
  • Contact
Répertoire de référence de Contact

Fichiers

fichier administrator/components/com_contact/src/View/Contact/HtmlView.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire Provider


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Service
  • HTML
Répertoire de référence de HTML

Fichiers

fichier Redirect.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier RedirectController.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier com_redirect/src/Table/LinkTable.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | api/components/com_privacy/src/Controller/ConsentsController.php
fichier | api/components/com_privacy/src/Controller/RequestsController.php


Joomla CMS: Répertoire de référence de form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • layouts
  • form
Répertoire de référence de form

Répertoires

répertoire field


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • vote
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier | rating.php
fichier | tmpl/vote.php


Joomla CMS: Répertoire de référence de http-client

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
Répertoire de référence de http-client

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de http_build_url

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • jakeasmith
  • http_build_url
Répertoire de référence de http_build_url

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de remember

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • remember
Répertoire de référence de remember

Fichiers

fichier remember.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier MessagesHelper.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_login/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de charset

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Répertoire de référence de charset

Fichiers

fichier | from.big5.php
fichier | from.cp037.php
fichier | from.cp1006.php
fichier | from.cp1026.php
fichier | from.cp424.php
fichier | from.cp437.php
fichier | from.cp500.php
fichier | from.cp737.php
fichier | from.cp775.php
fichier | from.cp850.php
fichier | from.cp852.php
fichier | from.cp855.php
fichier | from.cp856.php
fichier | from.cp857.php
fichier | from.cp860.php
fichier | from.cp861.php
fichier | from.cp862.php
fichier | from.cp863.php
fichier | from.cp864.php
fichier | from.cp865.php
fichier | from.cp866.php
fichier | from.cp869.php
fichier | from.cp874.php
fichier | from.cp875.php
fichier | from.cp932.php
fichier | from.cp936.php
fichier | from.cp949.php
fichier | from.cp950.php
fichier | from.iso-8859-1.php
fichier | from.iso-8859-10.php
fichier | from.iso-8859-11.php
fichier | from.iso-8859-13.php
fichier | from.iso-8859-14.php
fichier | from.iso-8859-15.php
fichier | from.iso-8859-16.php
fichier | from.iso-8859-2.php
fichier | from.iso-8859-3.php
fichier | from.iso-8859-4.php
fichier | from.iso-8859-5.php
fichier | from.iso-8859-6.php
fichier | from.iso-8859-7.php
fichier | from.iso-8859-8.php
fichier | from.iso-8859-9.php
fichier | from.koi8-r.php
fichier | from.koi8-u.php
fichier | from.us-ascii.php
fichier | from.windows-1250.php
fichier | from.windows-1251.php
fichier | from.windows-1252.php
fichier | from.windows-1253.php
fichier | from.windows-1254.php
fichier | from.windows-1255.php
fichier | from.windows-1256.php
fichier | from.windows-1257.php
fichier | from.windows-1258.php
fichier | translit.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier WebauthnField.php


Joomla CMS: Répertoire de référence de _install

  • C:
  • laragon
  • www
  • _install
Répertoire de référence de _install

Répertoires

répertoire Joomla_422-Stable-Full_Package_French_v1


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier | com_newsfeeds/src/Helper/AssociationsHelper.php
fichier | NewsfeedsHelper.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Application
répertoire | Component


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_tags_similar/tmpl/default.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | libraries/src/Cache/Controller/CallbackController.php
fichier | OutputController.php
fichier | PageController.php
fichier | ViewController.php


Joomla CMS: Répertoire de référence de Menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menu
Répertoire de référence de Menu

Fichiers

fichier | administrator/components/com_menus/src/View/Menu/HtmlView.php
fichier | com_menus/src/View/Menu/XmlView.php


Joomla CMS: Répertoire de référence de Setup

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • View
  • Setup
Répertoire de référence de Setup

Fichiers

fichier installation/src/View/Setup/HtmlView.php


Joomla CMS: Répertoire de référence de log

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • log
Répertoire de référence de log

Fichiers

fichier log.php


Joomla CMS: Répertoire de référence de System

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
  • System
Répertoire de référence de System

Répertoires

répertoire Webauthn


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_contenthistory/services/provider.php


Joomla CMS: Répertoire de référence de mod_menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_menu
Répertoire de référence de mod_menu

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier administrator/modules/mod_menu/mod_menu.php


Joomla CMS: Répertoire de référence de resize

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • resize
Répertoire de référence de resize

Fichiers

fichier resize.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • editor
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/editor.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier administrator/modules/mod_feed/src/Helper/FeedHelper.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Cache


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_categories/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de menu

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
  • joomla
  • menu
Répertoire de référence de menu

Fichiers

fichier layouts/joomla/menu/edit_modules.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Model
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de com_associations

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
Répertoire de référence de com_associations

Répertoires

répertoire | layouts
répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Répertoire de référence de Table

Fichiers

fichier | src/Event/Table/AbstractEvent.php
fichier | AfterBindEvent.php
fichier | AfterCheckinEvent.php
fichier | AfterCheckoutEvent.php
fichier | AfterDeleteEvent.php
fichier | AfterHitEvent.php
fichier | AfterLoadEvent.php
fichier | AfterMoveEvent.php
fichier | AfterPublishEvent.php
fichier | AfterReorderEvent.php
fichier | AfterResetEvent.php
fichier | AfterStoreEvent.php
fichier | BeforeBindEvent.php
fichier | BeforeCheckinEvent.php
fichier | BeforeCheckoutEvent.php
fichier | BeforeDeleteEvent.php
fichier | BeforeHitEvent.php
fichier | BeforeLoadEvent.php
fichier | BeforeMoveEvent.php
fichier | BeforePublishEvent.php
fichier | BeforeReorderEvent.php
fichier | BeforeResetEvent.php
fichier | BeforeStoreEvent.php
fichier | CheckEvent.php
fichier | ObjectCreateEvent.php
fichier | SetNewTagsEvent.php


Joomla CMS: Répertoire de référence de Provider

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Répertoire de référence de Provider

Fichiers

fichier | Extension/Service/Provider/CategoryFactory.php
fichier | Extension/Service/Provider/ComponentDispatcherFactory.php
fichier | Extension/Service/Provider/HelperFactory.php
fichier | src/Extension/Service/Provider/Module.php
fichier | Extension/Service/Provider/ModuleDispatcherFactory.php
fichier | Extension/Service/Provider/MVCFactory.php
fichier | Extension/Service/Provider/RouterFactory.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
Répertoire de référence de Service

Répertoires

répertoire Provider


Joomla CMS: Répertoire de référence de tags

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • tags
Répertoire de référence de tags

Fichiers

fichier plugins/finder/tags/tags.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Helper
répertoire | Serializer
répertoire | View


Joomla CMS: Répertoire de référence de article

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • article
Répertoire de référence de article

Fichiers

fichier article.php


Joomla CMS: Répertoire de référence de wrapper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • tmpl
  • wrapper
Répertoire de référence de wrapper

Fichiers

fichier components/com_wrapper/tmpl/wrapper/default.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • color
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/color.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire Redirect


Joomla CMS: Répertoire de référence de Formats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
Répertoire de référence de Formats

Répertoires

répertoire | Keys
répertoire | Signature


Joomla CMS: Répertoire de référence de article

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • article
Répertoire de référence de article

Fichiers

fichier | administrator/components/com_content/tmpl/article/edit.php
fichier | administrator/components/com_content/tmpl/article/modal.php
fichier | administrator/components/com_content/tmpl/article/pagebreak.php


Joomla CMS: Répertoire de référence de Form

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
Répertoire de référence de Form

Répertoires

répertoire | Field
répertoire | Rule


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • helpers
Répertoire de référence de helpers

Fichiers

fichier administrator/components/com_installer/helpers/installer.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • helpers
Répertoire de référence de helpers

Fichiers

fichier com_contact/helpers/route.php


Joomla CMS: Répertoire de référence de stubs

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-intl-normalizer
  • Resources
  • stubs
Répertoire de référence de stubs

Fichiers

fichier Resources/stubs/Normalizer.php


Joomla CMS: Répertoire de référence de setup

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
  • setup
Répertoire de référence de setup

Fichiers

fichier installation/tmpl/setup/default.php


Joomla CMS: Répertoire de référence de layouts

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • layouts
Répertoire de référence de layouts

Répertoires

répertoire joomla


Joomla CMS: Répertoire de référence de Sqlsrv

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlsrv
Répertoire de référence de Sqlsrv

Fichiers

fichier | SqlsrvDriver.php
fichier | SqlsrvQuery.php
fichier | SqlsrvStatement.php


Joomla CMS: Répertoire de référence de X509

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Répertoire de référence de X509

Répertoires

répertoire | CSR
répertoire | SAN

Fichiers

fichier | fgrosse/phpasn1/lib/X509/AlgorithmIdentifier.php
fichier | CertificateExtensions.php
fichier | CertificateSubject.php
fichier | fgrosse/phpasn1/lib/X509/PrivateKey.php
fichier | fgrosse/phpasn1/lib/X509/PublicKey.php


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier StatsHelper.php


Joomla CMS: Répertoire de référence de fr-FR

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • language
  • fr-FR
Répertoire de référence de fr-FR

Fichiers

fichier administrator/language/fr-FR/localise.php


Joomla CMS: Répertoire de référence de QuickIcon

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • QuickIcon
Répertoire de référence de QuickIcon

Fichiers

fichier GetIconEvent.php


Joomla CMS: Répertoire de référence de jwt-signature-algorithm-eddsa

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-eddsa
Répertoire de référence de jwt-signature-algorithm-eddsa

Fichiers

fichier web-token/jwt-signature-algorithm-eddsa/EdDSA.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Répertoire de référence de src

Répertoires

répertoire | Interceptor
répertoire | Phar
répertoire | Resolver

Fichiers

fichier | Assertable.php
fichier | vendor/typo3/phar-stream-wrapper/src/Behavior.php
fichier | Collectable.php
fichier | typo3/phar-stream-wrapper/src/Exception.php
fichier | libraries/vendor/typo3/phar-stream-wrapper/src/Helper.php
fichier | typo3/phar-stream-wrapper/src/Manager.php
fichier | PharStreamWrapper.php
fichier | Resolvable.php


Joomla CMS: Répertoire de référence de Levels

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • View
  • Levels
Répertoire de référence de Levels

Fichiers

fichier com_users/src/View/Levels/JsonapiView.php


Joomla CMS: Répertoire de référence de com_config

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
Répertoire de référence de com_config

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Functions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Common
  • Functions
Répertoire de référence de Functions

Fichiers

fichier Strings.php


Joomla CMS: Répertoire de référence de content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
Répertoire de référence de content

Répertoires

répertoire | confirmconsent
répertoire | contact
répertoire | emailcloak
répertoire | fields
répertoire | finder
répertoire | joomla
répertoire | loadmodule
répertoire | pagebreak
répertoire | pagenavigation
répertoire | vote


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_content
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier api/components/com_content/src/Controller/ArticlesController.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Répertoire de référence de src

Répertoires

répertoire Factory

Fichiers

fichier | nyholm/psr7/src/MessageTrait.php
fichier | nyholm/psr7/src/Request.php
fichier | nyholm/psr7/src/RequestTrait.php
fichier | libraries/vendor/nyholm/psr7/src/Response.php
fichier | nyholm/psr7/src/ServerRequest.php
fichier | vendor/nyholm/psr7/src/Stream.php
fichier | nyholm/psr7/src/UploadedFile.php
fichier | vendor/nyholm/psr7/src/Uri.php


Joomla CMS: Répertoire de référence de Language

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Language
Répertoire de référence de Language

Fichiers

fichier | El.php
fichier | Zh.php


Joomla CMS: Répertoire de référence de joomlaupdate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
Répertoire de référence de joomlaupdate

Répertoires

répertoire | services
répertoire | src


Joomla CMS: Répertoire de référence de mod_users_latest

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
Répertoire de référence de mod_users_latest

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_users_latest.php


Joomla CMS: Répertoire de référence de php-encryption

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • php-encryption
Répertoire de référence de php-encryption

Fichiers

fichier php-encryption/Crypto.php


Joomla CMS: Répertoire de référence de DataShape

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • DataShape
Répertoire de référence de DataShape

Fichiers

fichier | CaptiveRenderOptions.php
fichier | DataShapeObject.php
fichier | MethodDescriptor.php
fichier | SetupRenderOptions.php


Joomla CMS: Répertoire de référence de Console

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Répertoire de référence de Console

Répertoires

répertoire Loader

Fichiers

fichier | AddUserCommand.php
fichier | AddUserToGroupCommand.php
fichier | ChangeUserPasswordCommand.php
fichier | CheckJoomlaUpdatesCommand.php
fichier | CheckUpdatesCommand.php
fichier | CleanCacheCommand.php
fichier | DeleteUserCommand.php
fichier | ExtensionDiscoverCommand.php
fichier | ExtensionDiscoverInstallCommand.php
fichier | ExtensionDiscoverListCommand.php
fichier | ExtensionInstallCommand.php
fichier | ExtensionRemoveCommand.php
fichier | ExtensionsListCommand.php
fichier | FinderIndexCommand.php
fichier | GetConfigurationCommand.php
fichier | ListUserCommand.php
fichier | RemoveOldFilesCommand.php
fichier | RemoveUserFromGroupCommand.php
fichier | SessionGcCommand.php
fichier | SessionMetadataGcCommand.php
fichier | SetConfigurationCommand.php
fichier | SiteDownCommand.php
fichier | SiteUpCommand.php
fichier | TasksListCommand.php
fichier | TasksRunCommand.php
fichier | TasksStateCommand.php
fichier | UpdateCoreCommand.php


Joomla CMS: Répertoire de référence de TranscodeUnicode

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • TranscodeUnicode
Répertoire de référence de TranscodeUnicode

Fichiers

fichier | TranscodeUnicode.php
fichier | TranscodeUnicodeInterface.php


Joomla CMS: Répertoire de référence de com_checkin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
Répertoire de référence de com_checkin

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Hmac

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Hmac
Répertoire de référence de Hmac

Fichiers

fichier | Hmac/Sha256.php
fichier | Hmac/Sha384.php
fichier | Hmac/Sha512.php


Joomla CMS: Répertoire de référence de laminas-diactoros

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
Répertoire de référence de laminas-diactoros

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de content

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Répertoire de référence de content

Répertoires

répertoire | icons
répertoire | info_block

Fichiers

fichier | content/associations.php
fichier | blog_style_default_item_title.php
fichier | categories_default.php
fichier | categories_default_items.php
fichier | category_default.php
fichier | layouts/joomla/content/emptystate.php
fichier | emptystate_module.php
fichier | full_image.php
fichier | icons.php
fichier | info_block.php
fichier | intro_image.php
fichier | layouts/joomla/content/language.php
fichier | options_default.php
fichier | layouts/joomla/content/readmore.php
fichier | layouts/joomla/content/tags.php
fichier | text_filters.php


Joomla CMS: Répertoire de référence de Exception

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Exception
Répertoire de référence de Exception

Fichiers

fichier | CreateSessionTableException.php
fichier | InvalidSessionException.php
fichier | UnsupportedDatabaseDriverException.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Event
  • Model
Répertoire de référence de Model

Fichiers

fichier FeatureEvent.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Dispatcher
répertoire | Helper
répertoire | Model
répertoire | Service
répertoire | View


Joomla CMS: Répertoire de référence de EventListener

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • web-link
  • EventListener
Répertoire de référence de EventListener

Fichiers

fichier AddLinkHeaderListener.php


Joomla CMS: Répertoire de référence de Extension

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
  • src
  • Extension
Répertoire de référence de Extension

Fichiers

fichier plugins/multifactorauth/totp/src/Extension/Totp.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | LinkModel.php
fichier | LinksModel.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire HTML


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_archive
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier modules/mod_articles_archive/tmpl/default.php


Joomla CMS: Répertoire de référence de Service

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Service
Répertoire de référence de Service

Répertoires

répertoire Html


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
  • src
Répertoire de référence de src

Fichiers

fichier | ClientExceptionInterface.php
fichier | ClientInterface.php
fichier | NetworkExceptionInterface.php
fichier | RequestExceptionInterface.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Répertoire de référence de src

Répertoires

répertoire | Exception
répertoire | Internal

Fichiers

fichier | BigDecimal.php
fichier | brick/math/src/BigInteger.php
fichier | BigNumber.php
fichier | BigRational.php
fichier | RoundingMode.php


Joomla CMS: Répertoire de référence de mod_feed

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_feed
Répertoire de référence de mod_feed

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier administrator/modules/mod_feed/mod_feed.php


Joomla CMS: Répertoire de référence de Redirect

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
  • View
  • Redirect
Répertoire de référence de Redirect

Fichiers

fichier com_redirect/src/View/Redirect/JsonapiView.php


Joomla CMS: Répertoire de référence de Cloner

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Répertoire de référence de Cloner

Fichiers

fichier | AbstractCloner.php
fichier | ClonerInterface.php
fichier | var-dumper/Cloner/Cursor.php
fichier | Data.php
fichier | DumperInterface.php
fichier | symfony/var-dumper/Cloner/Stub.php
fichier | VarCloner.php


Joomla CMS: Répertoire de référence de CommandLoader

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • CommandLoader
Répertoire de référence de CommandLoader

Fichiers

fichier | CommandLoaderInterface.php
fichier | ContainerCommandLoader.php
fichier | FactoryCommandLoader.php


Joomla CMS: Répertoire de référence de Response

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Response
Répertoire de référence de Response

Fichiers

fichier administrator/components/com_finder/src/Response/Response.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Répertoire de référence de src

Répertoires

répertoire | Builder
répertoire | Codec
répertoire | Converter
répertoire | Exception
répertoire | Generator
répertoire | Provider

Fichiers

fichier | BinaryUtils.php
fichier | DegradedUuid.php
fichier | FeatureSet.php
fichier | ramsey/uuid/src/functions.php
fichier | Uuid.php
fichier | UuidFactory.php
fichier | UuidFactoryInterface.php
fichier | UuidInterface.php


Joomla CMS: Répertoire de référence de featured

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • tmpl
  • featured
Répertoire de référence de featured

Fichiers

fichier | components/com_content/tmpl/featured/default.php
fichier | default_item.php
fichier | com_content/tmpl/featured/default_links.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier | administrator/components/com_media/src/Controller/ApiController.php
fichier | administrator/components/com_media/src/Controller/DisplayController.php
fichier | com_media/src/Controller/PluginController.php


Joomla CMS: Répertoire de référence de mod_stats_admin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
Répertoire de référence de mod_stats_admin

Répertoires

répertoire | src
répertoire | tmpl

Fichiers

fichier mod_stats_admin.php


Joomla CMS: Répertoire de référence de media-action

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
Répertoire de référence de media-action

Répertoires

répertoire | crop
répertoire | resize
répertoire | rotate


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier PopularHelper.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Plugin
répertoire | Plugins


Joomla CMS: Répertoire de référence de Schema

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
Répertoire de référence de Schema

Répertoires

répertoire ChangeItem

Fichiers

fichier | ChangeItem.php
fichier | ChangeSet.php


Joomla CMS: Répertoire de référence de phpasn1

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
Répertoire de référence de phpasn1

Répertoires

répertoire lib


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Répertoire de référence de View

Répertoires

répertoire Event

Fichiers

fichier | AbstractView.php
fichier | CategoriesView.php
fichier | CategoryFeedView.php
fichier | CategoryView.php
fichier | FormView.php
fichier | GenericDataException.php
fichier | libraries/src/MVC/View/HtmlView.php
fichier | JsonApiView.php
fichier | libraries/src/MVC/View/JsonView.php
fichier | ListView.php
fichier | ViewInterface.php


Joomla CMS: Répertoire de référence de ASN1

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
Répertoire de référence de ASN1

Répertoires

répertoire Maps

Fichiers

fichier Element.php


Joomla CMS: Répertoire de référence de Controller

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • src
  • Controller
Répertoire de référence de Controller

Fichiers

fichier components/com_fields/src/Controller/DisplayController.php


Joomla CMS: Répertoire de référence de Messages

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • View
  • Messages
Répertoire de référence de Messages

Fichiers

fichier administrator/components/com_postinstall/src/View/Messages/HtmlView.php


Joomla CMS: Répertoire de référence de searchtools

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_menus
  • layouts
  • joomla
  • searchtools
Répertoire de référence de searchtools

Fichiers

fichier components/com_menus/layouts/joomla/searchtools/default.php


Joomla CMS: Répertoire de référence de defuse

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
Répertoire de référence de defuse

Répertoires

répertoire php-encryption


Joomla CMS: Répertoire de référence de Workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Workflow
Répertoire de référence de Workflow

Fichiers

fichier | src/Event/Workflow/AbstractEvent.php
fichier | WorkflowFunctionalityUsedEvent.php
fichier | WorkflowTransitionEvent.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier TaskTable.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
Répertoire de référence de src

Répertoires

répertoire | Algorithm
répertoire | Key

Fichiers

fichier | Algorithms.php
fichier | Verifier.php


Joomla CMS: Répertoire de référence de menutypes

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • tmpl
  • menutypes
Répertoire de référence de menutypes

Fichiers

fichier administrator/components/com_menus/tmpl/menutypes/default.php


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier | StageTable.php
fichier | TransitionTable.php
fichier | WorkflowTable.php


Joomla CMS: Répertoire de référence de beberlei

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • beberlei
Répertoire de référence de beberlei

Répertoires

répertoire assert


Joomla CMS: Répertoire de référence de Compare

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • View
  • Compare
Répertoire de référence de Compare

Fichiers

fichier administrator/components/com_contenthistory/src/View/Compare/HtmlView.php


Joomla CMS: Répertoire de référence de archive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
Répertoire de référence de archive

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de Helper

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
  • src
  • Helper
Répertoire de référence de Helper

Fichiers

fichier UsersLatestHelper.php


Joomla CMS: Répertoire de référence de install

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • tmpl
  • install
Répertoire de référence de install

Fichiers

fichier administrator/components/com_installer/tmpl/install/default.php


Joomla CMS: Répertoire de référence de com_workflow

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
Répertoire de référence de com_workflow

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl


Joomla CMS: Répertoire de référence de Plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Plugin
Répertoire de référence de Plugin

Répertoires

répertoire System


Joomla CMS: Répertoire de référence de Table

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Table
Répertoire de référence de Table

Fichiers

fichier TemplateTable.php


Joomla CMS: Répertoire de référence de Factory

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
  • Factory
Répertoire de référence de Factory

Fichiers

fichier | HttplugFactory.php
fichier | Psr17Factory.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
Répertoire de référence de src

Répertoires

répertoire | Exception
répertoire | Password
répertoire | Strategies

Fichiers

fichier | AbstractUsernamePasswordAuthenticationStrategy.php
fichier | libraries/vendor/joomla/authentication/src/Authentication.php
fichier | AuthenticationStrategyInterface.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • terms
  • src
  • Field
Répertoire de référence de Field

Fichiers

fichier TermsField.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | error
répertoire | preinstall
répertoire | remove
répertoire | setup


Joomla CMS: Répertoire de référence de HTML

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
Répertoire de référence de HTML

Répertoires

répertoire Helpers

Fichiers

fichier | HTMLHelper.php
fichier | HTMLRegistryAwareTrait.php
fichier | src/HTML/Registry.php


Joomla CMS: Répertoire de référence de plugin

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • tmpl
  • plugin
Répertoire de référence de plugin

Fichiers

fichier | administrator/components/com_plugins/tmpl/plugin/edit.php
fichier | administrator/components/com_plugins/tmpl/plugin/modal.php


Joomla CMS: Répertoire de référence de captive

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • captive
Répertoire de référence de captive

Fichiers

fichier | components/com_users/tmpl/captive/default.php
fichier | components/com_users/tmpl/captive/select.php


Joomla CMS: Répertoire de référence de ErrorEnhancer

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorEnhancer
Répertoire de référence de ErrorEnhancer

Fichiers

fichier | ClassNotFoundErrorEnhancer.php
fichier | ErrorEnhancerInterface.php
fichier | UndefinedFunctionErrorEnhancer.php
fichier | UndefinedMethodErrorEnhancer.php


Joomla CMS: Répertoire de référence de category

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • tmpl
  • category
Répertoire de référence de category

Fichiers

fichier | components/com_contact/tmpl/category/default.php
fichier | com_contact/tmpl/category/default_children.php
fichier | components/com_contact/tmpl/category/default_items.php


Joomla CMS: Répertoire de référence de Negotiation

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • willdurand
  • negotiation
  • src
  • Negotiation
Répertoire de référence de Negotiation

Répertoires

répertoire Exception

Fichiers

fichier | AbstractNegotiator.php
fichier | Accept.php
fichier | AcceptCharset.php
fichier | AcceptEncoding.php
fichier | AcceptHeader.php
fichier | AcceptLanguage.php
fichier | AcceptMatch.php
fichier | BaseAccept.php
fichier | CharsetNegotiator.php
fichier | EncodingNegotiator.php
fichier | LanguageNegotiator.php
fichier | Negotiator.php


Joomla CMS: Répertoire de référence de redirect

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • redirect
Répertoire de référence de redirect

Fichiers

fichier plugins/webservices/redirect/redirect.php


Joomla CMS: Répertoire de référence de filter

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filter
Répertoire de référence de filter

Répertoires

répertoire src


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Config
répertoire | Modules
répertoire | Templates


Joomla CMS: Répertoire de référence de transitions

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • tmpl
  • transitions
Répertoire de référence de transitions

Fichiers

fichier administrator/components/com_workflow/tmpl/transitions/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
Répertoire de référence de src

Répertoires

répertoire | Controller
répertoire | Extension
répertoire | Model
répertoire | Table
répertoire | View


Joomla CMS: Répertoire de référence de Link

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • View
  • Link
Répertoire de référence de Link

Fichiers

fichier administrator/components/com_redirect/src/View/Link/HtmlView.php


Joomla CMS: Répertoire de référence de Model

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Model
Répertoire de référence de Model

Fichiers

fichier | com_mails/src/Model/TemplateModel.php
fichier | administrator/components/com_mails/src/Model/TemplatesModel.php


Joomla CMS: Répertoire de référence de Dispatcher

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • src
  • Dispatcher
Répertoire de référence de Dispatcher

Fichiers

fichier administrator/components/com_cpanel/src/Dispatcher/Dispatcher.php


Joomla CMS: Répertoire de référence de View

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • src
  • View
Répertoire de référence de View

Répertoires

répertoire | Association
répertoire | Associations


Joomla CMS: Répertoire de référence de Streams

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
  • Streams
Répertoire de référence de Streams

Fichiers

fichier StreamString.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_templates/services/provider.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_submenu
  • src
Répertoire de référence de src

Répertoires

répertoire Menu


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | template
répertoire | templates


Joomla CMS: Répertoire de référence de tinymce

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • tinymce
Répertoire de référence de tinymce

Fichiers

fichier | layouts/joomla/tinymce/textarea.php
fichier | togglebutton.php


Joomla CMS: Répertoire de référence de Field

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Répertoire de référence de Field

Fichiers

fichier | AccessiblemediaField.php
fichier | AccesslevelField.php
fichier | AliastagField.php
fichier | AuthorField.php
fichier | CachehandlerField.php
fichier | CalendarField.php
fichier | CaptchaField.php
fichier | libraries/src/Form/Field/CategoryField.php
fichier | CheckboxesField.php
fichier | CheckboxField.php
fichier | ChromestyleField.php
fichier | ColorField.php
fichier | ComboField.php
fichier | ComponentlayoutField.php
fichier | ComponentsField.php
fichier | ContenthistoryField.php
fichier | ContentlanguageField.php
fichier | ContenttypeField.php
fichier | DatabaseconnectionField.php
fichier | EditorField.php
fichier | EmailField.php
fichier | FileField.php
fichier | FilelistField.php
fichier | FolderlistField.php
fichier | FrontendlanguageField.php
fichier | GroupedlistField.php
fichier | HeadertagField.php
fichier | HiddenField.php
fichier | ImagelistField.php
fichier | IntegerField.php
fichier | libraries/src/Form/Field/LanguageField.php
fichier | LastvisitdaterangeField.php
fichier | LimitboxField.php
fichier | ListField.php
fichier | MediaField.php
fichier | libraries/src/Form/Field/MenuField.php
fichier | MenuitemField.php
fichier | MeterField.php
fichier | ModulelayoutField.php
fichier | ModuleorderField.php
fichier | ModulepositionField.php
fichier | ModuletagField.php
fichier | NoteField.php
fichier | NumberField.php
fichier | OrderingField.php
fichier | PasswordField.php
fichier | PluginsField.php
fichier | PluginstatusField.php
fichier | PredefinedlistField.php
fichier | RadiobasicField.php
fichier | RadioField.php
fichier | RangeField.php
fichier | RedirectStatusField.php
fichier | RegistrationdaterangeField.php
fichier | RulesField.php
fichier | SessionhandlerField.php
fichier | SpacerField.php
fichier | SqlField.php
fichier | StatusField.php
fichier | SubformField.php
fichier | TagField.php
fichier | TelephoneField.php
fichier | TemplatestyleField.php
fichier | TextareaField.php
fichier | TextField.php
fichier | TimeField.php
fichier | TimezoneField.php
fichier | TransitionField.php
fichier | UrlField.php
fichier | UseractiveField.php
fichier | UserField.php
fichier | UsergrouplistField.php
fichier | UserstateField.php
fichier | WorkflowComponentSectionsField.php
fichier | WorkflowconditionField.php
fichier | WorkflowstageField.php


Joomla CMS: Répertoire de référence de services

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • services
Répertoire de référence de services

Fichiers

fichier administrator/components/com_banners/services/provider.php


Joomla CMS: Répertoire de référence de Component

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_config
  • src
  • View
  • Component
Répertoire de référence de Component

Fichiers

fichier com_config/src/View/Component/JsonapiView.php


Joomla CMS: Répertoire de référence de DataCollector

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Répertoire de référence de DataCollector

Répertoires

répertoire PDO

Fichiers

fichier | AggregatedCollector.php
fichier | AssetProvider.php
fichier | ConfigCollector.php
fichier | DataCollector.php
fichier | DataCollectorInterface.php
fichier | ExceptionsCollector.php
fichier | LocalizationCollector.php
fichier | MemoryCollector.php
fichier | MessagesAggregateInterface.php
fichier | MessagesCollector.php
fichier | PhpInfoCollector.php
fichier | Renderable.php
fichier | RequestDataCollector.php
fichier | TimeDataCollector.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Répertoire de référence de src

Répertoires

répertoire Exception

Fichiers

fichier | joomla/di/src/Container.php
fichier | ContainerAwareInterface.php
fichier | ContainerAwareTrait.php
fichier | ContainerResource.php
fichier | joomla/di/src/ServiceProviderInterface.php


Joomla CMS: Répertoire de référence de Rule

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Répertoire de référence de Rule

Fichiers

fichier | BooleanRule.php
fichier | CalendarRule.php
fichier | CaptchaRule.php
fichier | ColorRule.php
fichier | CssIdentifierRule.php
fichier | CssIdentifierSubstringRule.php
fichier | EmailRule.php
fichier | EqualsRule.php
fichier | ExistsRule.php
fichier | FilePathRule.php
fichier | FolderPathExistsRule.php
fichier | ModuleLayoutRule.php
fichier | NotequalsRule.php
fichier | NumberRule.php
fichier | OptionsRule.php
fichier | PasswordRule.php
fichier | RulesRule.php
fichier | SubformRule.php
fichier | TelRule.php
fichier | TimeRule.php
fichier | UrlRule.php
fichier | UserIdRule.php
fichier | libraries/src/Form/Rule/UsernameRule.php


Joomla CMS: Répertoire de référence de helpers

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • helpers
Répertoire de référence de helpers

Fichiers

fichier | template.php
fichier | administrator/components/com_templates/helpers/templates.php


Joomla CMS: Répertoire de référence de Caster

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Répertoire de référence de Caster

Fichiers

fichier | AmqpCaster.php
fichier | ArgsStub.php
fichier | Caster.php
fichier | ClassStub.php
fichier | ConstStub.php
fichier | CutArrayStub.php
fichier | CutStub.php
fichier | DateCaster.php
fichier | DoctrineCaster.php
fichier | DOMCaster.php
fichier | DsCaster.php
fichier | DsPairStub.php
fichier | EnumStub.php
fichier | ExceptionCaster.php
fichier | FiberCaster.php
fichier | FrameStub.php
fichier | GmpCaster.php
fichier | ImagineCaster.php
fichier | ImgStub.php
fichier | IntlCaster.php
fichier | LinkStub.php
fichier | MemcachedCaster.php
fichier | MysqliCaster.php
fichier | PdoCaster.php
fichier | PgSqlCaster.php
fichier | ProxyManagerCaster.php
fichier | RdKafkaCaster.php
fichier | RedisCaster.php
fichier | ReflectionCaster.php
fichier | ResourceCaster.php
fichier | SplCaster.php
fichier | StubCaster.php
fichier | SymfonyCaster.php
fichier | TraceStub.php
fichier | UuidCaster.php
fichier | XmlReaderCaster.php
fichier | XmlResourceCaster.php


Joomla CMS: Répertoire de référence de com_joomlaupdate

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
Répertoire de référence de com_joomlaupdate

Répertoires

répertoire | services
répertoire | src
répertoire | tmpl

Fichiers

fichier | extract.php
fichier | finalisation.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • filesystem
  • local
  • src
Répertoire de référence de src

Répertoires

répertoire Adapter


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • radio
  • tmpl
Répertoire de référence de tmpl

Fichiers

fichier tmpl/radio.php


Joomla CMS: Répertoire de référence de tmpl

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • tmpl
Répertoire de référence de tmpl

Répertoires

répertoire | filter
répertoire | filters
répertoire | index
répertoire | indexer
répertoire | maps
répertoire | searches
répertoire | statistics


Joomla CMS: Répertoire de référence de reset

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • reset
Répertoire de référence de reset

Fichiers

fichier | components/com_users/tmpl/reset/complete.php
fichier | confirm.php
fichier | components/com_users/tmpl/reset/default.php


Joomla CMS: Répertoire de référence de src

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • src
Répertoire de référence de src

Répertoires

répertoire Helper


Joomla CMS: Répertoire de référence de Formats

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
Répertoire de référence de Formats

Répertoires

répertoire | Keys
répertoire | Signature


Joomla CMS: Répertoire de référence de namespaced

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
Répertoire de référence de namespaced

Répertoires

répertoire Core

Fichiers

fichier | namespaced/Compat.php
fichier | vendor/paragonie/sodium_compat/namespaced/Crypto.php
fichier | vendor/paragonie/sodium_compat/namespaced/File.php


Joomla CMS: Répertoire de référence de templates

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • templates
Répertoire de référence de templates

Fichiers

fichier plugins/webservices/templates/templates.php


Joomla CMS: Exemples

Exemples
Liste de tous les exemples :
  • C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php
  • C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php
  • C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php
  • example.com
  • List-Unsubscribe
  • of
  • see


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- $ -

  • $a11y_contrast : administrator/templates/atum/index.php
  • $a11y_font : administrator/templates/atum/index.php
  • $a11y_highlight : administrator/templates/atum/index.php
  • $a11y_mono : administrator/templates/atum/index.php
  • $actions : administrator/components/com_users/tmpl/debuguser/default.php
  • $activated : administrator/components/com_users/tmpl/users/default.php
  • $activatedStates : administrator/components/com_users/tmpl/users/modal.php
  • $active : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php , addtab.php , modules/mod_menu/mod_menu.php
  • $active_id : modules/mod_menu/mod_menu.php
  • $activeLineColor : styles.php
  • $activeRequests : administrator/modules/mod_privacy_dashboard/tmpl/default.php
  • $addonAfterHtml : layouts/joomla/form/field/text.php
  • $addonBeforeHtml : layouts/joomla/form/field/text.php
  • $addons : element.php
  • $adminFormClass : administrator/components/com_postinstall/tmpl/messages/default.php , administrator/components/com_postinstall/tmpl/messages/emptystate.php
  • $advancedFieldsets : administrator/components/com_scheduler/tmpl/task/edit.php
  • $afterDisplayContent : components/com_content/tmpl/category/blog.php , category_default.php
  • $afterDisplayTitle : components/com_content/tmpl/category/blog.php , category_default.php
  • $ajax : default_submenu.php
  • $ajaxUri : default_mail.php , rules.php
  • $ajaxUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $alert : layouts/joomla/system/message.php , layouts/joomla/toolbar/batch.php
  • $allowEntryBatching : administrator/components/com_users/tmpl/captive/select.php , components/com_users/tmpl/captive/select.php
  • $allSliders : slider.php
  • $alpha : slider.php
  • $alt : administrator/modules/mod_submenu/tmpl/default.php , layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php , radiobasic.php , modules/mod_banners/tmpl/default.php
  • $anchor_css : default_heading.php , default_separator.php
  • $app : administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , webcron_link.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/includes/app.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , api/includes/app.php , cli/joomla.php , components/com_ajax/ajax.php , components/com_content/tmpl/category/blog.php , includes/app.php , category_default.php , admin_modules.php , fieldset.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , global.php , params.php , administrator/components/com_associations/tmpl/associations/modal.php , pagination/link.php , templates/cassiopeia/component.php , administrator/components/com_categories/tmpl/categories/modal.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , administrator/components/com_categories/tmpl/category/edit.php , cassiopeia/offline.php , system/offline.php , administrator/components/com_config/tmpl/component/default.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_media/tmpl/media/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/select/default.php
  • $append : layouts/joomla/content/emptystate.php
  • $argv : svg-scanner.php
  • $aria_described : layouts/joomla/content/icons/edit.php
  • $ariaDescribedBy : password.php
  • $ariaLabel : navigation.php
  • $article : layouts/joomla/content/icons/edit.php
  • $article_grouping : mod_articles_category.php
  • $article_grouping_direction : mod_articles_category.php
  • $articleId : icons.php
  • $assetColorName : templates/cassiopeia/component.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , cassiopeia/offline.php
  • $assetId : administrator/components/com_content/tmpl/featured/default.php
  • $assetRule : rules.php
  • $assoc : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php
  • $assocParam : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php
  • $attr : layouts/joomla/form/field/list.php , layouts/joomla/form/field/media.php , switcher.php , form/field/tag.php , workflowstage.php , categoryedit.php , com_modules/tmpl/modules/default_batch_body.php , combo.php , groupedlist-fancy-select.php , groupedlist.php , list-fancy-select.php
  • $attr2 : categoryedit.php , groupedlist-fancy-select.php , list-fancy-select.php , form/field/tag.php
  • $attribs : administrator/components/com_content/tmpl/articles/modal.php , well.php , transition-button.php , form/field/radio/buttons.php , modules/mod_syndicate/tmpl/default.php , card.php , noCard.php
  • $attributes : modulespositionedit.php , layouts/joomla/form/field/calendar.php , layouts/joomla/form/field/checkboxes.php , email.php , meter.php , moduleorder.php , number.php , password.php , form/field/radio/buttons.php , switcher.php , range.php , tel.php , layouts/joomla/form/field/text.php , layouts/joomla/form/field/textarea.php , time.php , layouts/joomla/form/field/url.php , default_component.php , default_url.php , plugins/fields/url/tmpl/url.php , dropdown-metismenu.php , dropdown-metismenu_component.php , dropdown-metismenu_heading.php , dropdown-metismenu_separator.php , dropdown-metismenu_url.php
  • $authMetadata : manage.php
  • $author : components/com_content/tmpl/archive/default_items.php , com_content/tmpl/category/default_articles.php , author.php
  • $authorised : layouts/joomla/content/tags.php
  • $autocomplete : advanced.php , slider.php
  • $autofocus : checkbox.php , advanced.php , slider.php
  • $b : styles.php
  • $backtraceList : backtrace.php
  • $base : modules/mod_menu/mod_menu.php
  • $baseDir : autoload_classmap.php , autoload_files.php , autoload_namespaces.php , libraries/vendor/composer/autoload_psr4.php
  • $basePath : element.php
  • $beforeDisplayContent : components/com_content/tmpl/category/blog.php , category_default.php
  • $behavior : bootstrap.php , cms.php
  • $bindNames : tmpl/sql.php
  • $blockEnd : form/field/radio/buttons.php
  • $blockPosition : info_block.php
  • $blockStart : form/field/radio/buttons.php
  • $blogClass : components/com_content/tmpl/category/blog.php , components/com_content/tmpl/featured/default.php
  • $bodyClass : layouts/libraries/html/bootstrap/modal/body.php
  • $bodyHeight : layouts/libraries/html/bootstrap/modal/body.php
  • $bootstrapSize : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php
  • $branchFilter : administrator/components/com_finder/tmpl/maps/default.php
  • $bscolumns : components/com_tags/tmpl/tags/default_items.php
  • $bsspans : components/com_tags/tmpl/tags/default_items.php
  • $btnadd : layouts/joomla/content/emptystate.php
  • $btnClass : form/field/radio/buttons.php
  • $buffer : tmpl/imagelist.php
  • $button : administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , button.php , layouts/joomla/editors/buttons/modal.php
  • $buttonClass : administrator/components/com_installer/tmpl/languages/default.php
  • $buttons : editors/buttons.php
  • $buttonText : administrator/components/com_installer/tmpl/languages/default.php
  • $c : administrator/components/com_categories/tmpl/category/edit.php
  • $cacheid : mod_articles_categories.php , mod_articles_category.php
  • $cacheparams : mod_articles_categories.php , mod_articles_category.php , mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php
  • $calendarAttrs : layouts/joomla/form/field/calendar.php
  • $calendarAttrsStr : layouts/joomla/form/field/calendar.php
  • $canAddEdit : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • $cancelURL : administrator/components/com_users/tmpl/method/backupcodes.php , administrator/components/com_users/tmpl/method/edit.php , components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/method/edit.php
  • $canChange : administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_menus/tmpl/items/default.php
  • $canCheckin : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $canCreate : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php
  • $canDelete : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • $canDo : components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/contact/default.php
  • $canEdit : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/article/default.php , blog_item.php , default_item.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php , blog_style_default_item_title.php , category_default.php , icons.php
  • $canEditCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditOwn : administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $canEditOwnCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditOwnParCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditParCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditState : components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php
  • $canManageCheckin : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php
  • $canManageItems : administrator/components/com_menus/tmpl/menus/default.php
  • $caption : sort.php
  • $category : administrator/components/com_fields/tmpl/fields/default.php , category_default.php
  • $category_image : administrator/components/com_users/tmpl/notes/modal.php
  • $channelIsDefined : logs.html.php
  • $check : administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php
  • $checkboxName : action-button.php , transition-button.php
  • $checked : update.php , checkbox.php , layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $class : administrator/modules/mod_menu/tmpl/default.php , default_submenu.php , administrator/modules/mod_submenu/tmpl/default.php , modules/default_options.php , com_contact/layouts/field/render.php , categories_default_items.php , button.php , layouts/joomla/editors/buttons/modal.php , backtrace.php , checkbox.php , advanced.php , simple.php , slider.php , hidden.php , meter.php , repeatable-table.php , repeatable.php , renderfield.php , layouts/joomla/quickicons/icon.php , system/privacyconsent/label.php , user/terms/label.php , traces.html.php , modules/mod_breadcrumbs/tmpl/default.php , tmpl/imagelist.php , plugins/fields/media/tmpl/media.php
  • $class_sfx : modules/mod_menu/mod_menu.php
  • $classes : categoryedit.php , renderlabel.php
  • $className : categories_default_items.php , category_default.php
  • $classToggle : form/field/radio/buttons.php
  • $classVisibility : update.php
  • $client : administrator/components/com_languages/tmpl/overrides/default.php , default_description.php
  • $clientId : administrator/components/com_menus/tmpl/item/edit.php , com_menus/tmpl/items/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php , administrator/components/com_modules/tmpl/modules/default.php , com_modules/tmpl/modules/default_batch_body.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $clientIdField : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php
  • $cMax : default_modal_file_body.php
  • $color : slider.php , styles.php
  • $colors : advanced.php
  • $cols : element.php
  • $columns : components/com_tags/tmpl/tags/default_items.php
  • $compatibilityTypes : preupdatecheck.php
  • $component : administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_tags/tmpl/tags/default.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php , global.php
  • $componentLangString : emptystate_module.php
  • $comUserParams : administrator/components/com_users/tmpl/mail/default.php
  • $config : administrator/components/com_media/tmpl/file/default.php , administrator/components/com_media/tmpl/media/default.php , administrator/includes/framework.php , api/includes/framework.php , includes/framework.php
  • $configFieldsets : params.php
  • $configuration : extract.php
  • $confirm : layouts/joomla/editors/buttons/modal.php
  • $container : administrator/includes/app.php , api/includes/app.php , cli/joomla.php , includes/app.php , installation/includes/app.php
  • $containerClass : form/field/radio/buttons.php
  • $content : noupdate.php , layouts/joomla/content/emptystate.php , element.php
  • $content_languages : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $context : administrator/components/com_fields/tmpl/fields/default.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_fields/tmpl/groups/default.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php
  • $control : advanced.php
  • $cookieLogin : components/com_users/tmpl/login/default.php
  • $count : administrator/components/com_content/tmpl/featured/default.php , default_tree.php , default_tree_media.php , administrator/components/com_users/tmpl/levels/default.php , frontediting_modules.php , mod_breadcrumbs.php
  • $countdiff : cloud.php
  • $countUnread : mod_messages.php
  • $cpanel : error_full.php , administrator/templates/atum/index.php
  • $cparams : mod_finder.php
  • $created_date : default_updated_files.php
  • $createdDateFormat : administrator/components/com_installer/tmpl/manage/default.php
  • $createURL : layouts/joomla/content/emptystate.php
  • $crypto_exception_handler_object_dont_touch_me : php-encryption/Crypto.php
  • $csite_name : mod_footer.php
  • $cur_year : mod_footer.php
  • $CurrentCatUrl : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $currentDate : components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php , blog_style_default_item_title.php , layouts/joomla/content/icons/edit.php
  • $currentJoomlaVersion : preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php
  • $currentPage : links.php
  • $currentParams : default_submenu.php
  • $currentShortVersion : administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/installed/default.php , installation/tmpl/remove/default.php
  • $customFields : default_custom.php
  • $customOptions : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $data : filters.php , layouts/joomla/searchtools/default/list.php , noitems.php , selector.php , layouts/joomla/searchtools/default.php , sort.php , layouts/joomla/tinymce/textarea.php , from.big5.php , from.cp037.php , from.cp1006.php , from.cp1026.php , from.cp424.php , from.cp437.php , from.cp500.php , from.cp737.php , from.cp775.php , from.cp850.php , from.cp852.php , from.cp855.php , from.cp856.php , from.cp857.php , from.cp860.php , from.cp861.php , from.cp862.php , from.cp863.php , from.cp864.php , from.cp865.php , from.cp866.php , from.cp869.php , from.cp874.php , from.cp875.php , from.cp932.php , from.cp936.php , from.cp949.php , from.cp950.php , from.iso-8859-1.php , from.iso-8859-10.php , from.iso-8859-11.php , from.iso-8859-13.php , from.iso-8859-14.php , from.iso-8859-15.php , from.iso-8859-16.php , from.iso-8859-2.php , from.iso-8859-3.php , from.iso-8859-4.php , from.iso-8859-5.php , from.iso-8859-6.php , from.iso-8859-7.php , from.iso-8859-8.php , from.iso-8859-9.php , from.koi8-r.php , from.koi8-u.php , from.us-ascii.php , from.windows-1250.php , from.windows-1251.php , from.windows-1252.php , from.windows-1253.php , from.windows-1254.php , from.windows-1255.php , from.windows-1256.php , from.windows-1257.php , from.windows-1258.php , modules/mod_breadcrumbs/tmpl/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , meter.php , bar.php
  • $dataAttribute : advanced.php , slider.php , hidden.php
  • $databaseConnectionEncryption : mod_privacy_status.php , administrator/modules/mod_privacy_status/tmpl/default.php
  • $datashowon : options_default.php
  • $dataShowOn : filters.php
  • $dataToggle : default_submenu.php
  • $date : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , mod_footer.php
  • $db : tmpl/sql.php
  • $default : transition-button.php , slider.php , modules/mod_menu/mod_menu.php
  • $default_id : modules/mod_menu/mod_menu.php
  • $defaultDisplayData : manage.php
  • $desc : administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/select/default.php
  • $descClass : renderfield.php
  • $description : administrator/components/com_templates/tmpl/style/edit.php , components/com_tags/tmpl/tags/default.php
  • $descriptionImage : components/com_tags/tmpl/tags/default.php
  • $dir : plugins/installer/webinstaller/tmpl/default.php
  • $direction : administrator/modules/mod_feed/tmpl/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , layouts/joomla/content/readmore.php , advanced.php , basic.php , dropdown.php , modules/mod_feed/tmpl/default.php
  • $disableClassName : administrator/components/com_languages/tmpl/languages/default.php
  • $disabled : action-button.php , transition-button.php , layouts/joomla/form/field/calendar.php , checkbox.php , advanced.php , simple.php , slider.php , hidden.php , form/field/radio/buttons.php
  • $disabledLabel : administrator/components/com_languages/tmpl/languages/default.php
  • $display : pagination/link.php
  • $display_count : mod_tags_popular.php
  • $displayData : administrator/components/com_banners/tmpl/banners/emptystate.php , administrator/components/com_banners/tmpl/clients/emptystate.php , administrator/components/com_banners/tmpl/tracks/emptystate.php , administrator/components/com_cache/tmpl/cache/emptystate.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_checkin/tmpl/checkin/emptystate.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_content/tmpl/articles/emptystate.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_finder/tmpl/filters/emptystate.php , administrator/components/com_finder/tmpl/index/emptystate.php , administrator/components/com_finder/tmpl/maps/emptystate.php , administrator/components/com_finder/tmpl/searches/emptystate.php , administrator/components/com_installer/tmpl/discover/emptystate.php , administrator/components/com_installer/tmpl/update/emptystate.php , administrator/components/com_installer/tmpl/warnings/emptystate.php , noupdate.php , reinstall.php , selfupdate.php , update.php , administrator/components/com_messages/tmpl/messages/emptystate.php , administrator/components/com_modules/tmpl/modules/emptystate.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_postinstall/tmpl/messages/emptystate.php , administrator/components/com_privacy/tmpl/consents/emptystate.php , administrator/components/com_privacy/tmpl/requests/emptystate.php , administrator/components/com_redirect/tmpl/links/emptystate.php , empty_state.php , administrator/components/com_tags/tmpl/tags/emptystate.php , administrator/components/com_users/tmpl/notes/emptystate.php , button/iconclass.php , layouts/joomla/html/image.php , toolbar/iconclass.php
  • $displayGroups : default_user_custom_fields.php
  • $displayTable : installation/tmpl/remove/default.php
  • $displayValues : slider.php
  • $doc : administrator/modules/mod_menu/tmpl/default.php , edit/associations.php , layouts/joomla/form/field/media.php , tinymcebuilder.php
  • $document : layouts/joomla/form/field/calendar.php , password.php , rules.php , layouts/joomla/system/message.php
  • $edit : administrator/components/com_workflow/tmpl/workflows/default.php
  • $EditCatTxt : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $editor : administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , element.php
  • $editoroptions : components/com_content/tmpl/form/edit.php
  • $editorText : components/com_config/tmpl/modules/default.php
  • $editUrl : frontediting_modules.php
  • $enabled : extract.php , administrator/modules/mod_menu/mod_menu.php
  • $enabledStates : administrator/components/com_users/tmpl/users/modal.php
  • $endDate : administrator/components/com_finder/tmpl/index/default.php
  • $errorHandler : bootstrap.php
  • $escapedTitle : administrator/components/com_finder/tmpl/filters/default.php
  • $exceptionAsArray : exception.html.php
  • $exceptionAsArrayCount : exception.html.php
  • $exceptionWithUserCode : exception.html.php
  • $expired : administrator/components/com_languages/tmpl/override/edit.php
  • $explodeArray : default_folders.php , default_media_folders.php , default_tree.php , default_tree_media.php
  • $extension : administrator/components/com_categories/tmpl/categories/default.php , com_categories/tmpl/categories/default_batch_body.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , categories_default_items.php , category_default.php
  • $extensionassoc : administrator/components/com_categories/tmpl/category/edit.php
  • $extJS : element.php
  • $extraAttr : default_result.php
  • $extraButtons : administrator/modules/mod_login/mod_login.php , modules/mod_login/mod_login.php , cassiopeia/offline.php
  • $extraFields : fieldset.php , params.php
  • $fancySelectData : default_modal_child_body.php
  • $feed : administrator/modules/mod_feed/mod_feed.php , modules/mod_feed/mod_feed.php
  • $field : administrator/components/com_users/tmpl/users/modal.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php
  • $fields : layouts/joomla/menu/edit_modules.php , com_contact/layouts/fields/render.php , com_contact/tmpl/contact/default_form.php , com_fields/layouts/fields/render.php , default_params.php , admin_modules.php , global.php , publishingdata.php
  • $fieldSet : fieldset.php
  • $fieldsets : administrator/components/com_users/tmpl/user/edit.php , default_custom.php
  • $fieldSets : administrator/components/com_media/tmpl/file/default.php , modules/default_options.php , templates/default_options.php , metadata.php , params.php
  • $fieldsetsInImages : administrator/components/com_content/tmpl/article/edit.php
  • $fieldsetsInLinks : administrator/components/com_content/tmpl/article/edit.php
  • $fieldsnames : options_default.php , text_filters.php
  • $fieldValue : plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/list/tmpl/list.php
  • $fileArray : default_tree.php , default_tree_media.php
  • $files_to_scan : svg-scanner.php
  • $filesize : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $filterButton : bar.php
  • $filters : bar.php , filters.php
  • $filtersActiveClass : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $folder : mod_random_image.php
  • $fontFamily : styles.php
  • $fontSize : styles.php
  • $fontStyles : templates/cassiopeia/component.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , cassiopeia/offline.php
  • $footerText : mod_banners.php , mod_languages.php
  • $form : administrator/components/com_media/tmpl/file/default.php , layouts/joomla/menu/edit_modules.php , admin_modules.php , edit/associations.php , fieldset.php , global.php , metadata.php , params.php , publishingdata.php , title_alias.php , accessiblemedia.php , layouts/joomla/form/field/subform/default.php
  • $format : components/com_ajax/ajax.php , layouts/joomla/form/field/checkboxes.php , advanced.php , slider.php , radiobasic.php
  • $formatString : plugins/fields/calendar/tmpl/calendar.php
  • $formAttr : basic.php , standard.php
  • $formfields : accessiblemedia.php
  • $formId : modules/mod_login/mod_login.php
  • $formURL : layouts/joomla/content/emptystate.php
  • $formUrl : administrator/components/com_contenthistory/tmpl/history/modal.php
  • $forumId : langforum.php
  • $forumUrl : langforum.php
  • $fsCombo : element.php
  • $fskeys : element.php
  • $fullScreenCombo : element.php
  • $fullWidth : cassiopeia/offline.php
  • $function : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php
  • $g : styles.php
  • $groupClass : options_default.php
  • $grouped : mod_articles_category.php
  • $groups : administrator/components/com_users/tmpl/levels/default.php , blog_children.php , com_content/tmpl/category/default_children.php , workflowstage.php , tmpl/usergrouplist.php
  • $halfstar : rating.php
  • $hasClass : templates/cassiopeia/index.php
  • $hasContent : administrator/components/com_modules/tmpl/module/edit.php
  • $hasContentFieldName : administrator/components/com_modules/tmpl/module/edit.php
  • $hash : administrator/components/com_contenthistory/tmpl/history/modal.php
  • $header : html5.php , card.php , noCard.php
  • $headerAttribs : html5.php , card.php , noCard.php
  • $headerClass : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $headerIcon : well.php
  • $headerTag : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $headerText : mod_banners.php , mod_languages.php
  • $heading : sort.php
  • $headingLevel : administrator/components/com_users/tmpl/method/edit.php , administrator/components/com_users/tmpl/methods/firsttime.php , components/com_users/tmpl/method/edit.php , components/com_users/tmpl/methods/firsttime.php
  • $height : modules/mod_banners/tmpl/default.php , mod_wrapper.php
  • $helper : params.php
  • $helpURL : layouts/joomla/content/emptystate.php
  • $helpUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $hiddenFields : layouts/joomla/menu/edit_modules.php , admin_modules.php , global.php , publishingdata.php
  • $hiddenFieldsets : params.php
  • $hiddenLinks : edit_container.php
  • $hiddenMenu : error_full.php , administrator/templates/atum/index.php
  • $hideActiveFilters : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $hideDescription : renderfield.php
  • $hideLabel : renderfield.php
  • $hideLinks : administrator/modules/mod_messages/tmpl/default.php , administrator/modules/mod_multilangstatus/tmpl/default.php , administrator/modules/mod_post_installation_messages/tmpl/default.php , administrator/modules/mod_user/tmpl/default.php
  • $highlightMatchColor : styles.php
  • $hint : advanced.php , slider.php
  • $hits_class : administrator/modules/mod_popular/tmpl/default.php
  • $home_pages : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $homeImage : default_submenu.php
  • $href : button.php , layouts/joomla/editors/buttons/modal.php
  • $htag : components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/article/default.php , components/com_content/tmpl/category/blog.php , components/com_newsfeeds/tmpl/category/default.php , components/com_tags/tmpl/tag/default.php , components/com_tags/tmpl/tag/list.php , category_default.php
  • $html : categoryedit.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/modules/mod_quickicon/tmpl/default.php , admin_modules.php , fieldset.php , global.php , groupedlist-fancy-select.php , groupedlist.php , list-fancy-select.php , layouts/joomla/form/field/list.php , form/field/tag.php , icon/iconclass.php
  • $i : administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , modules/default_options.php
  • $icon : default_submenu.php , administrator/modules/mod_submenu/tmpl/default.php , default_address.php , default_result.php , layouts/joomla/content/emptystate.php , emptystate_module.php , layouts/joomla/content/icons/edit.php , button.php , icon/iconclass.php , sort.php , layouts/joomla/toolbar/title.php
  • $iconClass : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , default_submenu.php
  • $iconFixed : icon/iconclass.php
  • $iconHalfstar : rating.php
  • $iconImage : default_submenu.php
  • $iconPrefix : icon/iconclass.php
  • $iconStar : rating.php
  • $iconStates : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php
  • $iconSuffix : icon/iconclass.php
  • $id : com_modules/tmpl/module/edit_assignment.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , com_content/tmpl/article/default_links.php , action-button.php , transition-button.php , renderfield.php , renderlabel.php , links/link.php , layouts/joomla/quickicons/icon.php , sort.php , layouts/joomla/toolbar/batch.php , addtab.php , modules/mod_articles_categories/tmpl/default_items.php , modules/mod_menu/tmpl/default.php , mod_wrapper.php , element.php
  • $idAttr : basic.php , popup.php , standard.php
  • $idbase : mod_articles_category.php
  • $iframeAttributes : iframe.php
  • $ignoreFields : fieldset.php , params.php
  • $ignoreFieldsetFields : params.php
  • $ignoreFieldsets : params.php
  • $image : mod_random_image.php
  • $imageClass : default_result.php
  • $imageOptions : components/com_tags/tmpl/tags/default_items.php
  • $images : components/com_newsfeeds/tmpl/newsfeed/default.php , components/com_tags/tmpl/tag/default_items.php , full_image.php , intro_image.php , mod_random_image.php
  • $img : layouts/joomla/html/image.php , rating.php
  • $imgclass : full_image.php , intro_image.php
  • $info : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php
  • $inheritedGroupParentAssetRule : rules.php
  • $inheritedGroupRule : rules.php
  • $inheritedParentGroupRule : rules.php
  • $input : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_media/tmpl/media/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_templates/tmpl/template/default.php , default_modal_delete_footer.php , default_modal_file_body.php , default_modal_folder_body.php , default_modal_folder_footer.php , default_updated_files.php , readonly.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , components/com_ajax/ajax.php , admin_modules.php , global.php , switcher.php , modules/mod_articles_categories/tmpl/default_items.php , mod_articles_category.php , modules/mod_finder/tmpl/default.php
  • $inputAttributes : layouts/joomla/form/field/user.php
  • $inputclass : advanced.php
  • $inputvalue : layouts/joomla/form/field/calendar.php
  • $isBtnGroup : form/field/radio/buttons.php
  • $isBtnYesNo : form/field/radio/buttons.php
  • $isCheckout : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php
  • $isEditable : com_content/tmpl/category/default_articles.php
  • $isExpired : components/com_content/tmpl/article/default.php , default_item.php
  • $isFirstUserCode : traces.html.php
  • $isMail : com_contact/layouts/fields/render.php
  • $isModal : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $isNotPublishedYet : components/com_content/tmpl/article/default.php , default_item.php
  • $isRtl : components/com_newsfeeds/tmpl/newsfeed/default.php , modules/mod_feed/tmpl/default.php
  • $isSingleTag : components/com_tags/tmpl/tag/default.php
  • $issues : platform_check.php
  • $isSuperUserGroup : rules.php
  • $isUnpublished : blog_item.php , default_item.php , layouts/joomla/content/icons/edit.php
  • $item : administrator/components/com_menus/tmpl/items/modal.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php , categories_default_items.php , layouts/joomla/content/language.php , layouts/joomla/content/readmore.php , pagination/link.php
  • $itemIconClass : default_submenu.php
  • $itemid : frontediting_modules.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $itemId : components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php
  • $itemIds : administrator/components/com_menus/tmpl/menus/default.php
  • $itemImage : default_submenu.php
  • $items : mod_sampledata.php , content/associations.php , categories_default_items.php , tmpl/sql.php
  • $itemsCounter : modules/mod_breadcrumbs/tmpl/default.php
  • $ititle : mod_wrapper.php
  • $joomlaFilesExtensionId : mod_post_installation_messages.php
  • $key : administrator/components/com_finder/tmpl/index/default.php
  • $keyArrayCount : default_tree.php , default_tree_media.php
  • $keywords : advanced.php
  • $label : com_contact/layouts/field/render.php , com_contact/tmpl/contact/default_links.php , com_content/tmpl/article/default_links.php , com_fields/layouts/field/render.php , system/privacyconsent/label.php , user/terms/label.php , modules/mod_finder/tmpl/default.php
  • $labelClass : preupdatecheck.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php , modules/mod_finder/tmpl/default.php
  • $lang : administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , mod_privacy_dashboard.php , mod_privacy_status.php , blog_children.php , com_content/tmpl/category/default_children.php , components/com_users/tmpl/profile/edit.php , layouts/joomla/form/field/calendar.php , modules/mod_finder/tmpl/default.php , navigation.php , plugins/content/pagenavigation/tmpl/default.php
  • $lang_string : administrator/components/com_finder/tmpl/statistics/default.php
  • $langFilter : com_content/tmpl/category/default_articles.php
  • $langs : administrator/modules/mod_login/mod_login.php
  • $language : administrator/components/com_languages/tmpl/overrides/default.php
  • $languages : generate_max_key_length.php
  • $languagesKeyLengths : generate_max_key_length.php
  • $last : exception.html.php
  • $last_item_key : modules/mod_breadcrumbs/tmpl/default.php
  • $latestJoomlaVersion : preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php
  • $layout : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , default_results.php , modules/mod_login/mod_login.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $layoutAttr : full_image.php , intro_image.php
  • $lazyloading : mod_wrapper.php
  • $levelup : modules/mod_articles_categories/tmpl/default_items.php
  • $limit : default_results.php
  • $lineHeight : styles.php
  • $link : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , default_submenu.php , com_contact/tmpl/contact/default_links.php , components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php , default_results.php , blog_style_default_item_title.php , button.php , layouts/joomla/editors/buttons/modal.php , modules/mod_articles_category/tmpl/default_items.php , mod_random_image.php , mod_syndicate.php
  • $link_class : layouts/joomla/content/tags.php
  • $linkClass : default_submenu.php
  • $linkText : modules/mod_syndicate/tmpl/default.php
  • $linktype : default_component.php , default_heading.php , default_separator.php , default_url.php , dropdown-metismenu_component.php , dropdown-metismenu_heading.php , dropdown-metismenu_separator.php , dropdown-metismenu_url.php
  • $linkUrl : default_results.php
  • $list : mod_breadcrumbs.php , modules/mod_articles_categories/tmpl/default_items.php , layouts/joomla/pagination/list.php , mod_latest.php , mod_latestactions.php , mod_popular.php , mod_privacy_dashboard.php , mod_stats_admin.php , layouts/joomla/form/field/text.php , links.php , layouts/joomla/searchtools/default/list.php , mod_articles_archive.php , mod_articles_categories.php , mod_articles_category.php , mod_articles_popular.php , mod_banners.php , mod_languages.php , modules/mod_menu/mod_menu.php , mod_related_items.php , mod_stats.php , mod_tags_popular.php , mod_tags_similar.php
  • $listAttr : popup.php , basic.php , standard.php
  • $listDirection : administrator/components/com_installer/tmpl/database/default.php
  • $listDirn : administrator/components/com_users/tmpl/users/modal.php , list_items.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/featured/default_items.php , com_content/tmpl/category/default_articles.php , components/com_newsfeeds/tmpl/category/default_items.php
  • $listoptions : layouts/joomla/form/field/list.php
  • $listOrder : administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/featured/default_items.php , components/com_newsfeeds/tmpl/category/default_items.php , list_items.php , administrator/components/com_users/tmpl/debuggroup/default.php , com_content/tmpl/category/default_articles.php , administrator/components/com_workflow/tmpl/transitions/default.php
  • $load : mod_wrapper.php
  • $loader : cms.php , bootstrap.php
  • $location : components/com_contact/tmpl/category/default_items.php
  • $loggedInUser : manage.php
  • $loggeduser : administrator/components/com_users/tmpl/users/default.php
  • $loginActions : administrator/components/com_users/tmpl/debuguser/default.php
  • $loginLogo : error_login.php , login.php
  • $loginLogoAlt : login.php , error_login.php
  • $loginmodule : administrator/components/com_login/tmpl/login/default.php
  • $logoBrandLarge : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $logoBrandLargeAlt : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $logoBrandSmall : error_full.php , error_login.php , administrator/templates/atum/index.php , login.php
  • $logoBrandSmallAlt : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $long_description : administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • $loop : administrator/templates/system/error.php , installation/template/error.php , templates/system/error.php , templates/cassiopeia/error.php
  • $manifest : administrator/components/com_installer/tmpl/database/default.php
  • $margin : toolbar/link.php
  • $maxcount : cloud.php
  • $maxSize : administrator/components/com_joomlaupdate/tmpl/upload/default.php , default_modal_file_body.php , file.php
  • $maxsize : cloud.php
  • $maxSize : plugins/installer/packageinstaller/tmpl/default.php
  • $maxSizeBytes : administrator/components/com_joomlaupdate/tmpl/upload/default.php , plugins/installer/packageinstaller/tmpl/default.php
  • $mediaTypes : administrator/components/com_media/tmpl/media/default.php , administrator/components/com_media/tmpl/file/default.php
  • $mediaVersion : element.php
  • $member : modules/mod_whosonline/tmpl/default.php
  • $menu : templates/cassiopeia/error.php , templates/cassiopeia/index.php , administrator/modules/mod_menu/mod_menu.php
  • $menuLinks : edit_container.php
  • $menusEditing : frontediting_modules.php
  • $menuType : administrator/components/com_menus/tmpl/items/default.php , com_menus/tmpl/items/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php
  • $menutype : mod_submenu.php , administrator/components/com_menus/tmpl/menutypes/default.php
  • $menuTypes : com_modules/tmpl/module/edit_assignment.php , com_templates/tmpl/style/edit_assignment.php
  • $message : layouts/joomla/toolbar/batch.php
  • $message1 : default_message.php
  • $message2 : default_message.php
  • $messages : mod_messages.php
  • $messagesCount : mod_post_installation_messages.php
  • $method : administrator/components/com_users/tmpl/method/edit.php , components/com_users/tmpl/method/edit.php
  • $methodName : administrator/components/com_users/tmpl/captive/select.php , components/com_users/tmpl/captive/select.php
  • $mfa : administrator/components/com_users/tmpl/users/default.php
  • $minorVersion : administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/installed/default.php
  • $minsize : cloud.php
  • $mod : frontediting_modules.php
  • $modalAttributes : main.php
  • $modalAttrs : popup.php
  • $modalbody : administrator/components/com_scheduler/tmpl/tasks/default.php
  • $modalClasses : main.php
  • $modalDialogClass : main.php
  • $modalHTML : layouts/joomla/form/field/media.php , layouts/joomla/form/field/user.php , administrator/modules/mod_multilangstatus/tmpl/default.php
  • $modalparams : administrator/components/com_scheduler/tmpl/tasks/default.php
  • $modalWidth : main.php
  • $mode : administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , mod_articles_category.php
  • $model : administrator/components/com_users/tmpl/methods/list.php , mod_latest.php , mod_popular.php , components/com_users/tmpl/methods/list.php , mod_banners.php , components/com_users/tmpl/captive/default.php , administrator/components/com_users/tmpl/captive/default.php
  • $modePath : element.php
  • $modId : banner.php , modules/mod_custom/tmpl/default.php
  • $modifier : element.php
  • $modMenuId : administrator/components/com_menus/tmpl/menus/default.php
  • $modPath : element.php
  • $module : administrator/templates/atum/html/layouts/chromes/body.php , header-item.php , administrator/templates/atum/html/layouts/chromes/title.php , html5.php , outline.php , table.php , noCard.php , card.php , well.php
  • $moduleAttribs : html5.php , card.php , noCard.php , html5.php
  • $moduleClass : administrator/templates/atum/html/layouts/chromes/body.php , well.php
  • $moduleClassSfx : administrator/templates/atum/html/layouts/chromes/body.php , well.php
  • $moduleCollapsedHtml : status.php
  • $moduleHtml : status.php , frontediting_modules.php
  • $moduleId : administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php
  • $moduleLangString : emptystate_module.php
  • $modulePosition : status.php
  • $modules : status.php , administrator/components/com_login/tmpl/login/default.php
  • $moduleTag : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $moduleXml : components/com_config/tmpl/modules/default.php
  • $msgAttr : standard.php , basic.php
  • $msgList : layouts/joomla/system/message.php
  • $msgOutput : layouts/joomla/system/message.php
  • $multilang : administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , default_results.php , administrator/components/com_contact/tmpl/contacts/modal.php
  • $multilanguageEnabled : mod_multilangstatus.php
  • $myrtl : administrator/modules/mod_feed/tmpl/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , modules/mod_feed/tmpl/default.php
  • $n : administrator/components/com_contact/tmpl/contacts/default.php , com_content/tmpl/category/default_articles.php , components/com_newsfeeds/tmpl/category/default_items.php , components/com_tags/tmpl/tags/default_items.php , components/com_tags/tmpl/tag/list.php
  • $name : administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/select/default.php , element.php , fieldset.php
  • $names : mod_users_latest.php
  • $namespace : traces.html.php
  • $noResultsText : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php
  • $notice_disabled : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $notice_switchers : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $noUser : com_contact/tmpl/contacts/default_batch_body.php
  • $now : administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php
  • $nowDate : layouts/joomla/content/icons/edit.php
  • $numberOfUrgentRequests : mod_privacy_status.php
  • $object1 : compare.php
  • $object2 : compare.php
  • $oid : layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $onchange : checkbox.php , advanced.php , slider.php , hidden.php , form/field/radio/buttons.php , layouts/joomla/form/field/checkboxes.php
  • $onClick : administrator/components/com_users/tmpl/users/modal.php
  • $onclick : administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , button.php , layouts/joomla/editors/buttons/modal.php , checkbox.php , slider.php , form/field/radio/buttons.php , links/link.php , layouts/joomla/quickicons/icon.php , layouts/joomla/form/field/checkboxes.php , administrator/components/com_installer/tmpl/languages/default.php
  • $opentab : params.php
  • $oppositeClient : administrator/components/com_languages/tmpl/overrides/default.php
  • $oppositeFilename : administrator/components/com_languages/tmpl/overrides/default.php
  • $oppositeStrings : administrator/components/com_languages/tmpl/overrides/default.php
  • $option : error_full.php , error_login.php , administrator/templates/atum/index.php , modules/mod_articles_categories/tmpl/default_items.php , element.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , login.php
  • $optionClass : layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $optionDisabled : layouts/joomla/form/field/checkboxes.php
  • $optionId : switcher.php
  • $optionNo : layouts/joomla/html/batch/user.php
  • $options : administrator/components/com_associations/tmpl/association/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , com_fields/tmpl/fields/default_batch_body.php , com_menus/tmpl/items/default_batch_body.php , default_modal_child_body.php , edit/associations.php , layouts/joomla/editors/buttons/modal.php , item.php , tmpl/vote.php , element.php , plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/media/tmpl/media.php , tmpl/radio.php , plugins/fields/list/tmpl/list.php , links.php , com_users/tmpl/users/default_batch_body.php
  • $optionValue : switcher.php
  • $opts : com_menus/tmpl/items/default_batch_body.php
  • $ordering : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_fields/tmpl/fields/default.php
  • $orderingColumn : administrator/components/com_workflow/tmpl/workflows/default.php
  • $os : bootstrap.php , import.legacy.php , import.php
  • $output : modules/mod_finder/tmpl/default.php , com_fields/layouts/fields/render.php
  • $outputFieldsets : params.php
  • $ovalue : form/field/radio/buttons.php
  • $pageclass : templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $pages : links.php
  • $parameters : frontediting_modules.php
  • $params : styles.php , element.php , full_image.php , mod_wrapper.php , blog_style_default_item_title.php , table.php , components/com_content/tmpl/archive/default_items.php , edit_container.php , default_user_custom_fields.php , administrator/components/com_content/tmpl/article/edit.php , com_redirect/tmpl/links/default_batch_body.php , default_item.php , com_content/tmpl/articles/default_batch_body.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_media/tmpl/media/default.php , well.php , com_content/tmpl/article/default_links.php , blog_item.php , html5.php , category_default.php , create.php , layouts/joomla/content/readmore.php , card.php , noCard.php , administrator/components/com_media/tmpl/file/default.php , administrator/templates/atum/html/layouts/chromes/body.php , components/com_content/tmpl/article/default.php , components/com_content/tmpl/form/edit.php , categories_default_items.php , intro_image.php
  • $paramsColorName : cassiopeia/offline.php , templates/cassiopeia/component.php , templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $paramsFontScheme : cassiopeia/offline.php , templates/cassiopeia/component.php , templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $ParentCatUrl : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $parts : installation/includes/defines.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_fields/tmpl/groups/default.php , com_contact/layouts/fields/render.php , administrator/components/com_categories/tmpl/categories/default.php , api/includes/defines.php , components/com_ajax/ajax.php , includes/defines.php , com_fields/layouts/fields/render.php , administrator/includes/defines.php
  • $password : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $path : modules/mod_menu/mod_menu.php
  • $pathHalfstar : rating.php
  • $pathStar : rating.php
  • $penult_item_key : modules/mod_breadcrumbs/tmpl/default.php
  • $PHPMAILER_LANG : phpmailer.lang-en_gb.php
  • $placeholder : categoryedit.php
  • $position : advanced.php , slider.php , frontediting_modules.php
  • $positions : com_modules/tmpl/modules/default_batch_body.php
  • $prefix : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_categories/tmpl/categories/default.php , com_fields/layouts/field/render.php , administrator/components/com_menus/tmpl/items/modal.php
  • $presetButtonClasses : tinymcebuilder.php
  • $preview : slider.php
  • $prevlevel : com_modules/tmpl/module/edit_assignment.php , edit_container.php
  • $privacyConsentPluginId : mod_privacy_status.php
  • $privacyPolicyInfo : mod_privacy_status.php
  • $published : com_banners/tmpl/banners/default_batch_body.php , com_modules/tmpl/modules/default_batch_body.php , com_newsfeeds/tmpl/newsfeeds/default_batch_body.php , com_categories/tmpl/categories/default_batch_body.php , com_contact/tmpl/contacts/default_batch_body.php , com_content/tmpl/articles/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php , com_tags/tmpl/tags/default_batch_body.php , com_menus/tmpl/items/default_batch_body.php , com_redirect/tmpl/links/default_batch_body.php
  • $publishEndDate : administrator/components/com_finder/tmpl/index/default.php
  • $publishStartDate : administrator/components/com_finder/tmpl/index/default.php
  • $purchaseTypes : administrator/components/com_banners/tmpl/clients/default.php
  • $query : tmpl/sql.php , mod_finder.php
  • $r : styles.php
  • $range : links.php
  • $rating : rating.php
  • $rcount : rating.php
  • $readmeGenerator : generate_docs.php
  • $readmeText : generate_docs.php
  • $readonly : slider.php , simple.php , advanced.php , layouts/joomla/form/field/calendar.php
  • $recordId : components/com_users/tmpl/method/edit.php , administrator/components/com_users/tmpl/method/edit.php
  • $redirectUri : frontediting_modules.php
  • $registerLink : modules/mod_login/mod_login.php
  • $rel : links/link.php , renderfield.php
  • $renderer : status.php
  • $requestFormPublished : mod_privacy_status.php
  • $required : system/privacyconsent/label.php , checkbox.php , advanced.php , slider.php , user/terms/label.php
  • $resetOptions : com_users/tmpl/users/default_batch_body.php
  • $result : from.big5.php , from.cp424.php , from.cp775.php , from.cp856.php , from.cp862.php , from.cp866.php , from.iso-8859-1.php , from.iso-8859-14.php , from.iso-8859-3.php , from.iso-8859-7.php , from.cp932.php , from.windows-1254.php , from.koi8-u.php , from.windows-1252.php , from.windows-1251.php , from.windows-1250.php , from.iso-8859-6.php , from.iso-8859-16.php , from.iso-8859-5.php , from.cp875.php , from.cp864.php , from.cp874.php , from.cp861.php , from.cp860.php , from.cp737.php , from.cp1006.php , from.cp500.php , from.iso-8859-11.php , from.cp1026.php , from.windows-1256.php , rules.php , from.iso-8859-13.php , from.cp037.php , from.cp437.php , from.cp850.php , from.cp852.php , from.cp855.php , from.cp857.php , from.cp863.php , from.cp865.php , from.cp869.php , from.cp936.php , from.cp949.php , from.cp950.php , from.iso-8859-10.php , from.iso-8859-15.php , from.iso-8859-2.php , from.iso-8859-4.php , from.iso-8859-8.php , from.iso-8859-9.php , from.koi8-r.php , from.us-ascii.php , from.windows-1253.php , from.windows-1255.php , from.windows-1257.php , from.windows-1258.php , tmpl/subform.php
  • $results : svg-scanner.php , components/com_content/tmpl/category/blog.php , category_default.php , components/com_ajax/ajax.php
  • $retArray : extract.php
  • $return : plugins/installer/packageinstaller/tmpl/default.php , modules/mod_login/mod_login.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/modules/mod_login/mod_login.php
  • $returnUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $root : administrator/modules/mod_menu/mod_menu.php , mod_submenu.php
  • $route : administrator/modules/mod_messages/tmpl/default.php , mod_finder.php , administrator/modules/mod_user/tmpl/default.php
  • $rows : element.php
  • $rssrtl : administrator/modules/mod_feed/mod_feed.php , modules/mod_feed/mod_feed.php
  • $rssurl : modules/mod_feed/mod_feed.php , administrator/modules/mod_feed/mod_feed.php
  • $sanitizer : svg-scanner.php
  • $saveFormat : slider.php
  • $saveHistory : layouts/joomla/menu/edit_modules.php , global.php
  • $saveOrder : administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $saveOrderingUrl : administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php
  • $scope : administrator/modules/mod_submenu/tmpl/default.php
  • $script : administrator/components/com_media/tmpl/file/default.php
  • $searchButton : bar.php
  • $searchToolsOptions : administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php
  • $section : administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_scheduler/tmpl/tasks/default.php
  • $selectAttr : modulespositionedit.php
  • $selected : sort.php , edit_container.php , com_modules/tmpl/module/edit_assignment.php
  • $selector : starttabset.php
  • $selectorFieldName : components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php
  • $self : administrator/components/com_users/tmpl/users/default.php
  • $sendMailEnabled : mod_privacy_status.php
  • $separator : com_redirect/tmpl/links/default_batch_body.php , traces.html.php
  • $serverinfo : mod_stats_admin.php , mod_stats.php
  • $settings : administrator/components/com_users/tmpl/user/edit.php
  • $short_description : administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php
  • $show_advanced : modules/mod_finder/tmpl/default.php
  • $show_contact_category : components/com_contact/tmpl/contact/default.php
  • $show_description : default_result.php
  • $show_last : modules/mod_breadcrumbs/tmpl/default.php
  • $show_url : default_result.php
  • $showAll : modules/mod_menu/mod_menu.php
  • $showArticleOptions : administrator/components/com_content/tmpl/article/edit.php
  • $showDate : mod_related_items.php
  • $showFilterButton : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php
  • $showImage : default_result.php
  • $showLabel : modules/mod_finder/tmpl/default.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php
  • $showLimitBox : links.php
  • $showLimitStart : links.php
  • $shownMethods : components/com_users/tmpl/captive/select.php , administrator/components/com_users/tmpl/captive/select.php
  • $shownumber : mod_users_latest.php
  • $showPagesLinks : links.php
  • $showSelector : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php
  • $sidebarState : administrator/templates/atum/index.php
  • $siteinfo : mod_stats_admin.php , mod_stats.php
  • $sitelangs : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $sitename : templates/cassiopeia/error.php , cassiopeia/offline.php , templates/cassiopeia/index.php , mod_frontend.php
  • $size : slider.php
  • $sort : sort.php
  • $sql : tmpl/sql.php
  • $sronly : administrator/modules/mod_submenu/tmpl/default.php
  • $star : rating.php
  • $stars : rating.php
  • $start : dropdown-metismenu.php
  • $startDate : administrator/components/com_finder/tmpl/index/default.php
  • $startLevel : mod_articles_categories.php
  • $startMem : administrator/includes/app.php , api/includes/app.php , includes/app.php
  • $startTime : includes/app.php , api/includes/app.php , administrator/includes/app.php
  • $state : default_message.php
  • $stateIcons : administrator/components/com_privacy/tmpl/consents/default.php
  • $stateMsgs : administrator/components/com_privacy/tmpl/consents/default.php
  • $step : links.php
  • $stickyHeader : templates/cassiopeia/index.php
  • $strings : layouts/joomla/form/field/calendar.php
  • $style : form/field/radio/buttons.php
  • $sub_id : administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_mails/tmpl/templates/default.php
  • $subject : administrator/components/com_users/tmpl/notes/default.php
  • $sublayout : repeatable.php
  • $suffix : com_fields/layouts/field/render.php
  • $tabindex : icon/iconclass.php
  • $table_head : repeatable-table.php
  • $tabName : params.php
  • $tabs : administrator/components/com_installer/tmpl/install/default.php
  • $tagName : basic.php , standard.php , popup.php
  • $tagsData : category_default.php
  • $target : layouts/joomla/quickicons/icon.php , mod_wrapper.php , toolbar/link.php , com_content/tmpl/article/default_links.php , frontediting_modules.php , links/link.php
  • $task : templates/cassiopeia/error.php , login.php , administrator/templates/atum/index.php , templates/cassiopeia/index.php , error_login.php , error_full.php , transition-button.php
  • $taskAttr : standard.php , basic.php
  • $taskPrefix : action-button.php
  • $taxonomies : default_result.php
  • $temp : modules/mod_articles_categories/tmpl/default_items.php
  • $template : fatal.php , administrator/components/com_config/tmpl/component/default.php
  • $templatePath : templates/cassiopeia/error.php , cassiopeia/offline.php
  • $text : administrator/components/com_users/tmpl/debuguser/default.php , administrator/modules/mod_feed/tmpl/default.php , user/terms/label.php , administrator/components/com_users/tmpl/debuggroup/default.php , system/privacyconsent/label.php , mod_syndicate.php , layouts/joomla/quickicons/icon.php , cancelselect.php , links/link.php
  • $textClass : modules/mod_syndicate/tmpl/default.php
  • $textPrefix : layouts/joomla/content/emptystate.php , emptystate_module.php
  • $texts : tmpl/radio.php , tmpl/sql.php , plugins/fields/list/tmpl/list.php , tmpl/usergrouplist.php , plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/user/tmpl/user.php
  • $textSuffix : emptystate_module.php
  • $this : administrator/components/com_modules/tmpl/module/edit.php
  • $tipContent : transition-button.php
  • $tipTitle : action-button.php , transition-button.php
  • $title : administrator/components/com_finder/tmpl/maps/default.php , delete.php , emptystate_module.php , upload.php , default_heading.php , basic.php , navigation.php , button.php , modules/mod_articles_category/tmpl/default_items.php , addtab.php , layouts/joomla/editors/buttons/modal.php , administrator/components/com_redirect/layouts/toolbar/batch.php , layouts/joomla/quickicons/icon.php , links/link.php , category.php , title_alias.php , layouts/joomla/content/emptystate.php , layouts/joomla/toolbar/batch.php , create-folder.php , parent_category.php , icon/iconclass.php , administrator/modules/mod_submenu/tmpl/default.php , default_separator.php
  • $tmp : default_custom.php
  • $tmpl : administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $toolbar : mod_toolbar.php
  • $tooltip : edit_lock.php , layouts/joomla/content/icons/edit.php
  • $total : default_results.php
  • $totalRequests : administrator/modules/mod_privacy_dashboard/tmpl/default.php
  • $tparams : components/com_contact/tmpl/contact/default.php
  • $transition_ids : administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_content/tmpl/articles/default.php
  • $transitions : transition-button.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_content/tmpl/articles/default.php
  • $type : modules/mod_login/mod_login.php
  • $updatePossible : preupdatecheck.php
  • $uploadLink : reinstall.php , update.php , noupdate.php
  • $urgentRequestDate : administrator/components/com_privacy/tmpl/requests/default.php
  • $urgentRequestDays : mod_privacy_status.php
  • $uri : tmpl/vote.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/modules/mod_feed/tmpl/default.php , layouts/joomla/form/field/user.php , administrator/modules/mod_user/tmpl/default.php
  • $url : layouts/joomla/form/field/media.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , mod_wrapper.php
  • $urls : com_content/tmpl/article/default_links.php
  • $useDefList : components/com_content/tmpl/archive/default_items.php , blog_item.php , components/com_content/tmpl/article/default.php , default_item.php
  • $uselessMenuItem : com_modules/tmpl/module/edit_assignment.php
  • $user : administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_banners/tmpl/banners/emptystate.php , blog_children.php , administrator/components/com_contact/tmpl/contacts/default.php , well.php , administrator/components/com_categories/tmpl/categories/default.php , modules/mod_login/mod_login.php , com_content/tmpl/articles/default_batch_body.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_content/tmpl/articles/emptystate.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_installer/tmpl/update/emptystate.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , components/com_config/tmpl/templates/default.php , mod_user.php , components/com_content/tmpl/article/default.php , administrator/components/com_redirect/tmpl/links/emptystate.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , com_content/tmpl/category/default_children.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_fields/tmpl/fields/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_banners/tmpl/clients/default.php , default_result.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_menus/tmpl/items/default.php , administrator/templates/atum/error.php , administrator/templates/atum/html/layouts/chromes/body.php
  • $userAuthoriseCoreEditState : administrator/components/com_finder/tmpl/filters/default.php
  • $userAuthoriseCoreManage : administrator/components/com_finder/tmpl/filters/default.php
  • $userFieldGroups : default_user_custom_fields.php
  • $userId : administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_content/tmpl/featured/default.php , components/com_users/tmpl/method/edit.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_users/tmpl/method/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_content/tmpl/articles/default.php , components/com_contact/tmpl/category/default_items.php
  • $userRequired : administrator/components/com_users/tmpl/users/modal.php
  • $usersConfig : default_login.php
  • $UTF8_ar : utf8.php
  • $UTF8_BAD : patterns.php
  • $UTF8_MATCH : patterns.php
  • $UTF8_VALID : patterns.php
  • $val : combo.php
  • $valBar1 : tinymcebuilder.php
  • $valBar2 : tinymcebuilder.php
  • $validate : slider.php , basic.php , standard.php , advanced.php
  • $valMenu : tinymcebuilder.php
  • $value : com_fields/layouts/field/render.php , tmpl/imagelist.php , tmpl/sql.php , tmpl/radio.php , plugins/fields/calendar/tmpl/calendar.php , tmpl/color.php , com_contact/layouts/field/render.php , layouts/joomla/form/field/checkboxes.php , range.php , tmpl/usergrouplist.php , plugins/fields/user/tmpl/user.php , plugins/fields/text/tmpl/text.php , plugins/fields/url/tmpl/url.php , tmpl/editor.php , number.php , plugins/fields/textarea/tmpl/textarea.php , tmpl/integer.php , meter.php
  • $valueClass : com_fields/layouts/field/render.php
  • $vendorDir : autoload_classmap.php , libraries/vendor/composer/autoload_psr4.php , autoload_files.php , autoload_namespaces.php
  • $version : administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_installer/tmpl/languages/default.php , installation/tmpl/remove/default.php , mod_version.php
  • $version1 : compare.php
  • $version2 : compare.php
  • $versionFields : layouts/stats.php
  • $view : error_full.php , templates/cassiopeia/index.php , login.php , modules/mod_articles_categories/tmpl/default_items.php , templates/cassiopeia/error.php , administrator/templates/atum/index.php , error_login.php
  • $wa : administrator/components/com_users/tmpl/notes/default.php , modules/mod_finder/tmpl/default.php , preupdatecheck.php , administrator/components/com_admin/tmpl/help/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_associations/tmpl/association/edit.php , administrator/components/com_banners/tmpl/banner/edit.php , administrator/components/com_banners/tmpl/banners/default.php , components/com_content/tmpl/categories/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_content/tmpl/featured/default.php , options_default.php , error_full.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_languages/tmpl/override/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , templates/cassiopeia/component.php , administrator/components/com_languages/tmpl/installed/default.php , components/com_config/tmpl/templates/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_users/tmpl/group/edit.php , styles.php , item.php , edit/associations.php , list_items.php , versions.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_templates/tmpl/template/default.php , login.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_privacy/tmpl/request/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_menus/tmpl/menu/edit.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_tags/tmpl/tag/edit.php , rating.php , administrator/components/com_installer/tmpl/updatesite/edit.php , administrator/components/com_privacy/tmpl/request/default.php , data.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/templates/atum/component.php , administrator/components/com_users/tmpl/users/modal.php , captive.php , components/com_newsfeeds/tmpl/categories/default.php , administrator/modules/mod_menu/tmpl/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/mail/default.php , administrator/components/com_users/tmpl/users/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_config/tmpl/component/default.php , administrator/modules/mod_quickicon/tmpl/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_redirect/tmpl/link/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_messages/tmpl/message/edit.php , templates/cassiopeia/index.php , components/com_tags/tmpl/tags/default_items.php , containeropen.php , administrator/components/com_modules/tmpl/module/edit.php , update.php , filters.php , tinymcebuilder.php , administrator/components/com_banners/tmpl/client/edit.php , administrator/components/com_categories/tmpl/category/edit.php , components/com_config/tmpl/modules/default.php , edit_container.php , com_users/tmpl/users/default_batch_body.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/modules/mod_login/tmpl/default.php , finaliseconfirm.php , cassiopeia/offline.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_modules/tmpl/module/modal.php , administrator/components/com_menus/tmpl/items/default.php , modules/mod_wrapper/tmpl/default.php , components/com_config/tmpl/config/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_content/tmpl/article/pagebreak.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_content/tmpl/article/edit.php , error_login.php , administrator/components/com_finder/tmpl/searches/default.php , components/com_contact/tmpl/category/default_items.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/templates/atum/index.php , administrator/components/com_finder/tmpl/index/default.php , components/com_contact/tmpl/categories/default.php , compare.php , password.php , horizontal.php , tmpl/item/edit_modules.php , administrator/components/com_scheduler/tmpl/task/edit.php , com_content/tmpl/category/default_articles.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , default_stage_footer.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , reinstall.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_joomlaupdate/tmpl/update/default.php , webcron_link.php , modules/mod_languages/tmpl/default.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , components/com_users/tmpl/profile/edit.php , components/com_contact/tmpl/featured/default_items.php , administrator/components/com_finder/tmpl/indexer/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_users/tmpl/note/edit.php , system/offline.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_config/tmpl/application/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_modules/tmpl/modules/default.php , layouts/joomla/tinymce/textarea.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_languages/tmpl/language/edit.php , administrator/components/com_banners/tmpl/download/default.php , slider.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_messages/tmpl/config/default.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_categories/tmpl/categories/default.php , advanced.php , dropdown-metismenu.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_users/tmpl/groups/default.php , templates/cassiopeia/error.php , administrator/components/com_users/tmpl/user/edit.php , vertical.php , administrator/components/com_mails/tmpl/template/edit.php , modules/mod_menu/tmpl/default.php , com_content/tmpl/articles/default_batch_footer.php , administrator/components/com_users/tmpl/level/edit.php
  • $wam : layouts/joomla/form/field/media.php
  • $width : mod_wrapper.php , modules/mod_banners/tmpl/default.php
  • $workflow_enabled : administrator/components/com_content/tmpl/articles/default.php , mod_latest.php , administrator/components/com_content/tmpl/featured/default.php
  • $workflow_featured : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $workflow_state : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $wrapper : templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $xml : administrator/components/com_config/tmpl/component/default.php , params.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- ( -

  • (!empty($this->nonCoreExtensions)) : preupdatecheck.php
  • ($canManageItems) : administrator/components/com_menus/tmpl/menus/default.php
  • ($data['group']==0) : preupdatecheck.php
  • ($is_child) : separator.php
  • ($item->level > 1) : administrator/components/com_finder/tmpl/maps/default.php
  • ($items) : administrator/modules/mod_sampledata/tmpl/default.php
  • ($list as $language) : modules/mod_languages/tmpl/default.php
  • ($list) : layouts/joomla/searchtools/default/list.php
  • ($menuTypes as &$type) : com_modules/tmpl/module/edit_assignment.php
  • ($method['canDisable'] && $canDelete) : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • ($mfa) : administrator/components/com_users/tmpl/users/default.php
  • ($params->get('menu_show', 1)) : administrator/modules/mod_submenu/tmpl/default.php
  • ($row->next) : plugins/content/pagenavigation/tmpl/default.php
  • ($row->prev) : plugins/content/pagenavigation/tmpl/default.php
  • ($sitelangs as $sitelang) : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • ($this->contentlangs as $contentlang) : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • ($this->options as $option) : installation/tmpl/preinstall/default.php
  • ($this->params->get('show_advanced', 1)) : com_finder/tmpl/search/default_form.php
  • ($this->phpsettings as $setting) : installation/tmpl/remove/default.php
  • ($users as $user) : administrator/modules/mod_logged/tmpl/default.php
  • (array_keys($toolbarPreset) as $presetName) : tinymcebuilder.php
  • (count($list)) : administrator/modules/mod_latestactions/tmpl/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_archived')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_published')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_trashed')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_unpublished')) : administrator/components/com_categories/tmpl/categories/default.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- _ -

  • __DIR__ : bootstrap.php
  • __pad0__ : administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_content/tmpl/articles/default.php , tmpl/item/edit_modules.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , components/com_config/tmpl/config/default.php , compare.php , administrator/components/com_modules/tmpl/module/edit.php , components/com_contact/tmpl/category/default_items.php , components/com_content/tmpl/archive/default_items.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , components/com_finder/tmpl/search/default.php , components/com_newsfeeds/tmpl/category/default_items.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , components/com_privacy/tmpl/request/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_privacy/tmpl/capabilities/default.php , components/com_users/tmpl/login/default_logout.php , components/com_wrapper/tmpl/wrapper/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_redirect/tmpl/links/default.php , installation/tmpl/remove/default.php , blog_style_default_item_title.php , administrator/components/com_scheduler/tmpl/task/edit.php , modules/mod_articles_category/tmpl/default.php , _item.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_tags/tmpl/tags/default.php , modules/mod_banners/tmpl/default.php , modules/mod_breadcrumbs/tmpl/default.php , administrator/components/com_templates/tmpl/styles/default.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default.php , preupdatecheck.php , administrator/components/com_users/tmpl/debuggroup/default.php , cloud.php , modules/mod_tags_similar/tmpl/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/modules/mod_feed/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php
  • __pad10__ : administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/notes/modal.php , default_profile.php , com_content/tmpl/category/default_articles.php , pagination/link.php
  • __pad11__ : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/notes/modal.php , components/com_contact/tmpl/featured/default_items.php , default_item.php , submenu.php , administrator/components/com_installer/tmpl/warnings/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php
  • __pad12__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , components/com_contact/tmpl/form/edit.php , default_item.php , dropdown.php
  • __pad13__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , components/com_content/tmpl/form/edit.php , separator.php
  • __pad14__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , standard.php
  • __pad15__ : administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php
  • __pad16__ : administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/default.php
  • __pad17__ : administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/default.php
  • __pad18__ : administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/modal.php
  • __pad19__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad1__ : installation/tmpl/remove/default.php , categories_default.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_banners/tmpl/default.php , modules/mod_breadcrumbs/tmpl/default.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default.php , modules/mod_tags_popular/tmpl/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_mails/tmpl/templates/default.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_privacy/tmpl/capabilities/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , components/com_config/tmpl/templates/default.php , components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/archive/default_items.php , default_result.php , components/com_tags/tmpl/tag/default_items.php , default_core.php , components/com_wrapper/tmpl/wrapper/default.php
  • __pad20__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad21__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad2__ : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/languages/default.php , tmpl/item/edit_modules.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , blog_item.php , default_result.php , list_items.php , default_custom.php , create.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default_logout.php , default_address.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , preview.php
  • __pad3__ : administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_content/tmpl/articles/default.php , content/info_block/associations.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/languages/default.php , default_address.php , default_params.php , com_content/tmpl/category/default_articles.php , list_items.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_privacy/tmpl/request/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , modules/mod_languages/tmpl/default.php
  • __pad4__ : administrator/components/com_banners/tmpl/clients/default.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/manage/default.php , default_address.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , com_content/tmpl/category/default_articles.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , modules/mod_languages/tmpl/default.php , author.php
  • __pad5__ : administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_templates/tmpl/styles/default.php , default_address.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_modules/tmpl/modules/default.php , intro_image.php , administrator/components/com_languages/tmpl/languages/default.php , com_content/tmpl/category/default_articles.php
  • __pad6__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , default_address.php , com_content/tmpl/category/default_articles.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/manage/default.php , options_default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_menus/tmpl/items/default.php , default_updated_files.php
  • __pad7__ : default_address.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_installer/tmpl/update/default.php , com_content/tmpl/category/default_articles.php , layouts/joomla/content/readmore.php , default_updated_files.php , administrator/components/com_menus/tmpl/items/default.php
  • __pad8__ : administrator/components/com_content/tmpl/featured/default.php , password.php , administrator/components/com_installer/tmpl/update/default.php , com_content/tmpl/category/default_articles.php , default_profile.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_users/tmpl/notes/default.php
  • __pad9__ : default_profile.php , item.php , com_menus/tmpl/items/default_batch_body.php , com_content/tmpl/category/default_articles.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_users/tmpl/notes/default.php
  • _JEXEC : api/index.php , installation/index.php , index.php , cli/joomla.php , administrator/index.php
  • _JOOMLA_UPDATE : extract.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- a -

  • admin_postinstall_addnosniff_condition() : addnosniff.php
  • admin_postinstall_behindproxy_condition() : behindproxy.php
  • admin_postinstall_htaccesssvg_condition() : htaccesssvg.php
  • admin_postinstall_languageaccess340_condition() : languageaccess340.php
  • admin_postinstall_statscollection_condition() : statscollection.php
  • admin_postinstall_textfilter3919_condition() : textfilter3919.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- b -

  • baseUrl : default_results.php
  • behindproxy_postinstall_action() : behindproxy.php
  • block : administrator/components/com_users/tmpl/users/default.php
  • break : preupdatecheck.php , default_profile.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- c -

  • cachemode : mod_articles_categories.php , mod_articles_category.php , mod_tags_popular.php , mod_tags_similar.php , mod_related_items.php
  • cat_link : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_contact/tmpl/contacts/default.php
  • category : com_contact/tmpl/category/default_children.php , blog_children.php , com_content/tmpl/category/default_children.php , com_newsfeeds/tmpl/category/default_children.php
  • children : blog_children.php , com_content/tmpl/category/default_children.php
  • class : dropdown.php
  • clearFileInOPCache() : extract.php
  • code : administrator/components/com_installer/tmpl/languages/default.php , installation/tmpl/remove/default.php
  • color : administrator/templates/atum/component.php
  • com_users_postinstall_mfa_condition() : multifactorauth.php
  • composerRequire2399d40fc48ada3450e844df0430bf2f() : autoload_real.php
  • configFieldsets : administrator/components/com_content/tmpl/article/edit.php
  • content : administrator/modules/mod_custom/mod_custom.php
  • continue : administrator/components/com_scheduler/tmpl/task/edit.php
  • counter : default_results.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- d -

  • description : default_permissions.php , components/com_content/tmpl/category/blog.php , category_default.php , categories_default.php
  • DO_PEDANTIC_TEST : autoload-pedantic.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- e -

  • else : categoryedit.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , edit_container.php , default_tree.php , com_contact/layouts/fields/render.php , modules/mod_finder/tmpl/default.php , mod_footer.php , components/com_contact/tmpl/category/default_items.php , cloud.php , mod_whosonline.php , default_tree_media.php , components/com_contact/tmpl/featured/default_items.php , tmpl/integer.php , plugins/fields/url/tmpl/url.php , blog_children.php , templates/cassiopeia/error.php , dropdown-metismenu_heading.php , tmpl/item/edit_modules.php , administrator/components/com_users/tmpl/debuguser/default.php , com_content/tmpl/category/default_articles.php , dropdown-metismenu_separator.php , templates/cassiopeia/index.php , com_content/tmpl/category/default_children.php , cassiopeia/offline.php , administrator/components/com_workflow/tmpl/stages/default.php , com_fields/layouts/fields/render.php , components/com_newsfeeds/tmpl/newsfeed/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , list_items.php , components/com_users/tmpl/login/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , includes/framework.php , layouts/joomla/content/language.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/includes/framework.php , fieldset.php , layouts/joomla/editors/buttons/modal.php , administrator/modules/mod_feed/tmpl/default.php , advanced.php , groupedlist-fancy-select.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_finder/tmpl/maps/default.php , com_modules/tmpl/module/edit_assignment.php , mod_latest.php , groupedlist.php , list-fancy-select.php , mod_logged.php , layouts/joomla/form/field/list.php , number.php , administrator/components/com_modules/tmpl/modules/default.php , default_submenu.php , rules.php , repeatable-table.php , mod_privacy_dashboard.php , form/field/tag.php , renderfield.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , mod_submenu.php , pagination/link.php , layouts/joomla/quickicons/icon.php , administrator/modules/mod_submenu/tmpl/default.php , submenu.php , system/privacyconsent/label.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/templates/atum/error.php , user/terms/label.php , paragonie/sodium_compat/autoload.php , api/includes/framework.php , modules/mod_banners/tmpl/default.php , modules/mod_feed/tmpl/default.php
  • elseif : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , layouts/joomla/content/readmore.php , standard.php , paragonie/sodium_compat/autoload.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_banners/tmpl/default.php , default_component.php , default_heading.php , default_separator.php , default_url.php , dropdown-metismenu_component.php , dropdown-metismenu_url.php
  • eName : administrator/components/com_content/tmpl/article/pagebreak.php
  • endfor : administrator/components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/method/backupcodes.php , vertical.php
  • endforeach : administrator/components/com_content/tmpl/articles/default.php , text_filters.php , metadata.php , administrator/components/com_content/tmpl/articles/modal.php , editors/buttons.php , layouts/joomla/form/field/checkboxes.php , administrator/components/com_content/tmpl/featured/default.php , simple.php , accessiblemedia.php , compare.php , form/field/radio/buttons.php , switcher.php , administrator/components/com_contenthistory/tmpl/history/modal.php , rules.php , layouts/joomla/form/field/subform/default.php , preview.php , section-byfieldsets.php , section.php , administrator/components/com_fields/tmpl/field/edit.php , table/section-byfieldsets.php , table/section.php , administrator/components/com_fields/tmpl/fields/modal.php , repeatable.php , layouts/joomla/form/field/text.php , administrator/components/com_fields/tmpl/groups/default.php , links.php , layouts/joomla/pagination/list.php , administrator/components/com_finder/tmpl/filters/default.php , filters.php , layouts/joomla/searchtools/default/list.php , administrator/components/com_finder/tmpl/index/default.php , submenu.php , setoptions.php , administrator/components/com_finder/tmpl/maps/default.php , tinymcebuilder.php , modules/mod_articles_archive/tmpl/default.php , administrator/components/com_finder/tmpl/searches/default.php , modules/mod_articles_categories/tmpl/default_items.php , modules/mod_articles_category/tmpl/default.php , administrator/components/com_finder/tmpl/statistics/default.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_articles_latest/tmpl/default.php , administrator/components/com_installer/tmpl/database/default.php , modules/mod_articles_news/tmpl/default.php , horizontal.php , administrator/components/com_installer/tmpl/discover/default.php , modules/mod_articles_popular/tmpl/default.php , modules/mod_banners/tmpl/default.php , administrator/components/com_installer/tmpl/install/default.php , modules/mod_breadcrumbs/tmpl/default.php , modules/mod_languages/tmpl/default.php , administrator/components/com_installer/tmpl/languages/default.php , modules/mod_related_items/tmpl/default.php , modules/mod_stats/tmpl/default.php , administrator/components/com_installer/tmpl/manage/default.php , cloud.php , modules/mod_tags_popular/tmpl/default.php , administrator/components/com_installer/tmpl/update/default.php , modules/mod_tags_similar/tmpl/default.php , modules/mod_users_latest/tmpl/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , modules/mod_whosonline/tmpl/default.php , toc.php , administrator/components/com_installer/tmpl/warnings/default.php , layouts/stats.php , preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_mails/tmpl/templates/default.php , edit_container.php , tmpl/item/edit_modules.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_messages/tmpl/messages/default.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_postinstall/tmpl/messages/default.php , administrator/components/com_privacy/tmpl/capabilities/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/request/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_templates/tmpl/styles/default.php , default_folders.php , default_media_folders.php , default_tree.php , default_tree_media.php , default_updated_files.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/methods/list.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/notes/modal.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , administrator/modules/mod_sampledata/tmpl/default.php , administrator/modules/mod_submenu/tmpl/default.php , components/com_config/tmpl/config/default_metadata.php , components/com_config/tmpl/config/default_seo.php , components/com_config/tmpl/config/default_site.php , modules/default_options.php , components/com_contact/tmpl/categories/default_items.php , com_contact/tmpl/category/default_children.php , components/com_contact/tmpl/category/default_items.php , com_contact/tmpl/contact/default_articles.php , com_contact/tmpl/contact/default_form.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , com_contact/tmpl/contact/default_links.php , default_profile.php , administrator/components/com_admin/tmpl/help/default.php , default_user_custom_fields.php , components/com_contact/tmpl/featured/default_items.php , default_config.php , com_content/tmpl/article/default_links.php , components/com_content/tmpl/categories/default_items.php , default_directory.php , components/com_content/tmpl/category/blog.php , blog_children.php , administrator/components/com_associations/tmpl/associations/default.php , blog_links.php , com_content/tmpl/category/default_articles.php , administrator/components/com_associations/tmpl/associations/modal.php , com_content/tmpl/category/default_children.php , components/com_content/tmpl/featured/default.php , administrator/components/com_banners/tmpl/banners/default.php , com_content/tmpl/featured/default_links.php , default_result.php , administrator/components/com_banners/tmpl/clients/default.php , default_results.php , components/com_newsfeeds/tmpl/categories/default_items.php , administrator/components/com_banners/tmpl/download/default.php , com_newsfeeds/tmpl/category/default_children.php , components/com_privacy/tmpl/confirm/default.php , administrator/components/com_banners/tmpl/tracks/default.php , components/com_privacy/tmpl/remind/default.php , components/com_privacy/tmpl/request/default.php , administrator/components/com_cache/tmpl/cache/default.php , components/com_tags/tmpl/tag/default_items.php , list_items.php , administrator/components/com_categories/tmpl/categories/default.php , components/com_tags/tmpl/tags/default_items.php , components/com_users/tmpl/methods/list.php , administrator/components/com_categories/tmpl/categories/modal.php , default_custom.php , default_params.php , administrator/components/com_checkin/tmpl/checkin/default.php , components/com_users/tmpl/profile/edit.php , components/com_users/tmpl/registration/default.php , application/default_navigation.php , components/com_users/tmpl/remind/default.php , components/com_users/tmpl/reset/complete.php , component/default_navigation.php , confirm.php , components/com_users/tmpl/reset/default.php , administrator/components/com_contact/tmpl/contacts/default.php , installation/tmpl/preinstall/default.php , installation/tmpl/remove/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , content/associations.php , content/info_block/associations.php , administrator/components/com_content/tmpl/article/edit.php , options_default.php , layouts/joomla/content/tags.php
  • endif : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , rating.php , administrator/components/com_postinstall/tmpl/messages/default.php , administrator/modules/mod_title/tmpl/default.php , administrator/templates/atum/html/layouts/chromes/body.php , administrator/templates/system/error.php , templates/cassiopeia/error.php , modules/default_options.php , content/info_block/associations.php , data.php , card.php , components/com_contact/tmpl/contact/default.php , default_address.php , com_contact/tmpl/contact/default_form.php , templates/system/error.php , default_user_custom_fields.php , components/com_contact/tmpl/featured/default.php , cassiopeia/offline.php , system/offline.php , components/com_content/tmpl/article/default.php , com_content/tmpl/article/default_links.php , components/com_content/tmpl/category/blog.php , layouts/joomla/searchtools/default/list.php , com_content/tmpl/category/default_articles.php , com_content/tmpl/category/default_children.php , item.php , layouts/joomla/form/field/user.php , components/com_finder/tmpl/search/default.php , com_finder/tmpl/search/default_form.php , administrator/components/com_users/tmpl/user/edit.php , form/field/radio/buttons.php , components/com_newsfeeds/tmpl/category/default.php , com_newsfeeds/tmpl/category/default_children.php , layouts/joomla/content/readmore.php , components/com_config/tmpl/templates/default.php , components/com_tags/tmpl/tag/default.php , components/com_tags/tmpl/tag/default_items.php , list_items.php , categories_default.php , icons.php , noCard.php , components/com_content/tmpl/featured/default.php , components/com_privacy/tmpl/confirm/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_categories/tmpl/category/edit.php , application/default_navigation.php , metadata.php , administrator/components/com_contact/tmpl/contacts/default.php , com_contact/tmpl/contacts/default_batch_body.php , layouts/joomla/content/tags.php , button.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , password.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , editors/buttons.php , components/com_menus/layouts/joomla/searchtools/default.php , com_fields/tmpl/groups/default_batch_body.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_finder/tmpl/index/default.php , section.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_installer/tmpl/database/default.php , section-byfieldsets.php , table/section-byfieldsets.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/warnings/default.php , components/com_tags/tmpl/tags/default.php , installation/template/error.php , options_default.php , table/section.php , layouts/joomla/form/field/text.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_languages/tmpl/override/edit.php , administrator/components/com_mails/tmpl/template/edit.php , pagination/link.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/modules/mod_popular/tmpl/default.php , links.php , com_menus/tmpl/items/default_batch_body.php , components/com_users/tmpl/profile/default.php , components/com_users/tmpl/methods/list.php , installation/tmpl/preinstall/default.php , default_login.php , installation/tmpl/remove/default.php , renderfield.php , filters.php , administrator/components/com_modules/tmpl/modules/default.php , components/com_users/tmpl/remind/default.php , default_params.php , sort.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , components/com_privacy/tmpl/remind/default.php , components/com_users/tmpl/registration/complete.php , submenu.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_redirect/tmpl/links/emptystate.php , components/com_tags/tmpl/tag/list.php , default_core.php , basic.php , administrator/components/com_plugins/tmpl/plugins/default.php , separator.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_modules/tmpl/select/default.php , components/com_wrapper/tmpl/wrapper/default.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_menus/tmpl/menu/edit.php , com_menus/tmpl/items/default_batch_footer.php , _item.php , administrator/components/com_templates/tmpl/styles/default.php , table.php , html5.php , modules/mod_breadcrumbs/tmpl/default.php , confirm.php , modules/mod_banners/tmpl/default.php , modules/mod_articles_categories/tmpl/default_items.php , reinstall.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , blog_style_default_item_title.php , modules/mod_login/tmpl/default_logout.php , administrator/components/com_users/tmpl/groups/default.php , modules/mod_login/tmpl/default.php , category_default.php , modules/mod_random_image/tmpl/default.php , administrator/components/com_users/tmpl/methods/list.php , header.php , full_image.php , modules/mod_tags_popular/tmpl/default.php , transition-button.php , cloud.php , modules/mod_languages/tmpl/default.php , modules/mod_tags_similar/tmpl/default.php , administrator/components/com_workflow/tmpl/transition/edit.php , standard.php , info_block.php , toc.php , administrator/modules/mod_feed/tmpl/default.php , navigation.php , modules/mod_users_latest/tmpl/default.php , plugins/content/pagenavigation/tmpl/default.php , administrator/modules/mod_login/tmpl/default.php , tmpl/subform.php , administrator/modules/mod_post_installation_messages/tmpl/default.php , plugins/multifactorauth/webauthn/tmpl/default.php , administrator/modules/mod_submenu/tmpl/default.php , well.php , components/com_config/tmpl/modules/default.php , modules/mod_whosonline/tmpl/default.php , components/com_contact/tmpl/category/default_items.php , com_contact/tmpl/contact/default_articles.php , default_profile.php , components/com_contact/tmpl/featured/default_items.php , components/com_content/tmpl/archive/default_items.php , components/com_content/tmpl/categories/default_items.php , blog_item.php , templates/cassiopeia/index.php , com_fields/layouts/field/render.php , default_result.php , components/com_privacy/tmpl/request/default.php , default_item.php , components/com_newsfeeds/tmpl/newsfeed/default.php , intro_image.php , components/com_newsfeeds/tmpl/categories/default_items.php , components/com_content/tmpl/form/edit.php , com_categories/tmpl/categories/default_batch_body.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/modal.php , com_content/tmpl/articles/default_batch_body.php , compare.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , default_results.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , repeatable.php , preupdatecheck.php , rules.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_media/tmpl/file/default.php , components/com_users/tmpl/login/default_logout.php , administrator/components/com_menus/tmpl/items/default.php , bar.php , layouts/joomla/quickicons/icon.php , components/com_users/tmpl/methods/default.php , components/com_users/tmpl/profile/edit.php , com_modules/tmpl/modules/default_batch_body.php , layouts/joomla/searchtools/default.php , default_custom.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , dropdown.php , components/com_users/tmpl/captive/default.php , components/com_users/tmpl/registration/default.php , administrator/components/com_redirect/tmpl/link/edit.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_articles_category/tmpl/default.php , components/com_users/tmpl/reset/default.php , com_templates/tmpl/style/edit_assignment.php , default_folders.php , default_modal_file_body.php , modules/mod_finder/tmpl/default.php , default_updated_files.php , administrator/components/com_users/tmpl/captive/default.php , administrator/components/com_users/tmpl/debuguser/default.php , content/associations.php , administrator/components/com_users/tmpl/methods/default.php , administrator/components/com_users/tmpl/notes/default.php , components/com_users/tmpl/reset/complete.php , layouts/joomla/content/emptystate.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , author.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/modules/mod_sampledata/tmpl/default.php , components/com_config/tmpl/config/default.php , com_contact/tmpl/category/default_children.php , com_contact/tmpl/contact/default_links.php , com_contact/layouts/field/render.php , components/com_contact/tmpl/form/edit.php , blog_children.php , components/com_content/tmpl/archive/default.php , components/com_contact/tmpl/categories/default_items.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_categories/tmpl/categories/default.php , component/default_navigation.php , administrator/components/com_content/tmpl/articles/default.php , preview.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_finder/tmpl/index/emptystate.php , default_message.php , noupdate.php , administrator/components/com_languages/tmpl/language/edit.php , administrator/components/com_mails/tmpl/templates/default.php , tmpl/item/edit_modules.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_modules/tmpl/modules/modal.php , com_newsfeeds/tmpl/newsfeeds/default_batch_body.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_templates/tmpl/style/edit.php , default_media_folders.php , default_tree_media.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/mail/default.php , administrator/components/com_users/tmpl/notes/modal.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_quickicon/tmpl/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_privacy/tmpl/capabilities/default.php , default_modal_folder_body.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_languages/tmpl/installed/default.php , edit_container.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_privacy/tmpl/request/default.php , com_tags/tmpl/tags/default_batch_body.php , administrator/components/com_users/tmpl/levels/default.php , default_tree.php , administrator/components/com_privacy/tmpl/consents/default.php , com_banners/tmpl/banners/default_batch_body.php , update.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_banners/tmpl/tracks/default.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_banners/tmpl/clients/default.php
  • endswitch : default_profile.php
  • endwhile : installation/template/error.php , templates/system/error.php , templates/cassiopeia/error.php , administrator/templates/system/error.php
  • ENT_COMPAT : components/com_newsfeeds/tmpl/category/default_items.php
  • ENT_QUOTES : administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php
  • extension : categories_default.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- f -

  • false : com_menus/tmpl/items/default_batch_footer.php , administrator/components/com_users/tmpl/users/default.php , default_profile.php
  • fields : administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_templates/tmpl/style/edit.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • fieldset : administrator/components/com_modules/tmpl/module/edit.php , edit_display.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_templates/tmpl/style/edit.php
  • fieldsets : administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • fieldsname : administrator/components/com_config/tmpl/application/default_site.php , default_webservices.php , default_cache.php , default_cookie.php , default_database.php , default_debug.php , default_filters.php , default_locale.php , default_logging.php , default_logging_custom.php , default_mail.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_permissions.php , default_proxy.php , administrator/components/com_config/tmpl/application/default_seo.php , default_server.php , default_session.php
  • for : vertical.php , rating.php , tmpl/vote.php
  • foreach : installation/tmpl/remove/default.php , components/com_config/tmpl/config/default_site.php , submenu.php , tinymcebuilder.php , exception.html.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_templates/tmpl/templates/default.php , plugins/fields/user/tmpl/user.php , modules/mod_articles_latest/tmpl/default.php , administrator/components/com_modules/tmpl/modules/modal.php , modules/mod_stats/tmpl/default.php , combo.php , tmpl/usergrouplist.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_finder/tmpl/index/default.php , plugins/fields/checkboxes/tmpl/checkboxes.php , administrator/components/com_contenthistory/tmpl/history/modal.php , default_config.php , administrator/components/com_banners/tmpl/tracks/default.php , tmpl/sql.php , administrator/components/com_cache/tmpl/cache/default.php , tmpl/imagelist.php , administrator/components/com_checkin/tmpl/checkin/default.php , application/default_navigation.php , administrator/components/com_content/tmpl/article/edit.php , plugins/fields/list/tmpl/list.php , administrator/components/com_fields/tmpl/fields/modal.php , tmpl/radio.php , modules/mod_articles_archive/tmpl/default.php , components/com_content/tmpl/featured/default.php , components/com_config/tmpl/config/default_seo.php , modules/mod_articles_popular/tmpl/default.php , toc.php , default_updated_files.php , administrator/components/com_installer/tmpl/discover/default.php , preupdatecheck.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_privacy/tmpl/request/default.php , status.php , components/com_config/tmpl/config/default_metadata.php , components/com_content/tmpl/category/blog.php
  • formclass : default_database.php , default_proxy.php , default_filters.php , administrator/components/com_config/tmpl/application/default_site.php , default_permissions.php , default_webservices.php , default_logging_custom.php , default_debug.php , default_logging.php , default_cache.php , default_cookie.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_locale.php , administrator/components/com_config/tmpl/application/default_seo.php , default_server.php , default_mail.php , default_session.php


Joomla CMS: Variables globale

- a -

  • admin_postinstall_addnosniff_condition() : addnosniff.php
  • admin_postinstall_behindproxy_condition() : behindproxy.php
  • admin_postinstall_htaccesssvg_condition() : htaccesssvg.php
  • admin_postinstall_languageaccess340_condition() : languageaccess340.php
  • admin_postinstall_statscollection_condition() : statscollection.php
  • admin_postinstall_textfilter3919_condition() : textfilter3919.php

- b -

  • behindproxy_postinstall_action() : behindproxy.php

- c -

  • clearFileInOPCache() : extract.php
  • com_users_postinstall_mfa_condition() : multifactorauth.php
  • composerRequire2399d40fc48ada3450e844df0430bf2f() : autoload_real.php

- h -

  • httpheaders_postinstall_action() : introduction.php
  • httpheaders_postinstall_condition() : introduction.php

- j -

  • jimport() : loader.php

- s -

  • setHugeMemoryLimit() : extract.php
  • setLongTimeout() : extract.php
  • sysexit() : svg-scanner.php

- t -

  • timingSafeEquals() : extract.php

- u -

  • updatecachetime_postinstall_action() : updatecachetime.php
  • updatecachetime_postinstall_condition() : updatecachetime.php
  • utf8_accents_to_ascii() : ascii.php
  • utf8_bad_explain() : bad.php
  • utf8_bad_find() : bad.php
  • utf8_bad_findall() : bad.php
  • utf8_bad_identify() : bad.php
  • utf8_bad_replace() : bad.php
  • utf8_bad_strip() : bad.php
  • utf8_byte_position() : position.php
  • utf8_compliant() : validation.php
  • utf8_from_unicode() : unicode.php
  • utf8_ireplace() : str_ireplace.php
  • utf8_is_ascii() : ascii.php
  • utf8_is_ascii_ctrl() : ascii.php
  • utf8_is_valid() : validation.php
  • utf8_is_word_chars() : specials.php
  • utf8_locate_current_chr() : position.php
  • utf8_locate_next_chr() : position.php
  • utf8_ltrim() : trim.php
  • utf8_ord() : joomla/string/src/phputf8/ord.php
  • utf8_rtrim() : trim.php
  • utf8_specials_pattern() : specials.php
  • utf8_str_pad() : str_pad.php
  • utf8_str_split() : str_split.php
  • utf8_strcasecmp() : strcasecmp.php
  • utf8_strcspn() : strcspn.php
  • utf8_strip_ascii_ctrl() : ascii.php
  • utf8_strip_non_ascii() : ascii.php
  • utf8_strip_non_ascii_ctrl() : ascii.php
  • utf8_strip_specials() : specials.php
  • utf8_stristr() : stristr.php
  • utf8_strlen() : mbstring/core.php , native/core.php
  • utf8_strpos() : mbstring/core.php , native/core.php
  • utf8_strrev() : strrev.php
  • utf8_strrpos() : mbstring/core.php , native/core.php
  • utf8_strspn() : strspn.php
  • utf8_strtolower() : mbstring/core.php , native/core.php
  • utf8_strtoupper() : mbstring/core.php , native/core.php
  • utf8_substr() : mbstring/core.php , native/core.php
  • utf8_substr_replace() : substr_replace.php
  • utf8_to_unicode() : unicode.php
  • utf8_trim() : trim.php
  • utf8_ucfirst() : ucfirst.php
  • utf8_ucwords() : ucwords.php
  • utf8_ucwords_callback() : ucwords.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- h -

  • hiddenFieldsets : administrator/components/com_content/tmpl/article/edit.php
  • hits : com_content/tmpl/category/default_articles.php
  • httpheaders_postinstall_action() : introduction.php
  • httpheaders_postinstall_condition() : introduction.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- i -

  • id : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_users/tmpl/notes/modal.php
  • if : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_workflow/tmpl/workflows/default.php , bar.php , layouts/joomla/system/message.php , administrator/includes/app.php , basic.php , dropdown.php , edit_container.php , administrator/modules/mod_feed/tmpl/default.php , layouts/libraries/html/bootstrap/modal/body.php , iframe.php , administrator/modules/mod_latest/tmpl/default.php , main.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , mod_latestactions.php , manage.php , autoload.php , fatal.php , templates/cassiopeia/index.php , banner.php , templates/cassiopeia/error.php , plugins/fields/url/tmpl/url.php , plugins/fields/textarea/tmpl/textarea.php , plugins/fields/text/tmpl/text.php , plugins/fields/media/tmpl/media.php , tmpl/editor.php , tmpl/color.php , modules/mod_related_items/tmpl/default.php , modules/mod_menu/tmpl/default.php , modules/mod_login/tmpl/default.php , modules/mod_login/mod_login.php , modules/mod_languages/tmpl/default.php , modules/mod_custom/tmpl/default.php , modules/mod_custom/mod_custom.php , mod_breadcrumbs.php , modules/mod_banners/tmpl/default.php , _item.php , modules/mod_articles_category/tmpl/default_items.php , mod_articles_category.php , modules/mod_articles_categories/tmpl/default.php , traces_text.html.php , traces.html.php , trace.html.php , exception_full.html.php , mod_loginsupport.php , utf8.php , autoload-phpunit.php , administrator/components/com_menus/tmpl/items/modal.php , default_submenu.php , php72compat.php , administrator/modules/mod_popular/tmpl/default.php , administrator/components/com_config/tmpl/component/default.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_messages/tmpl/messages/emptystate.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_modules/tmpl/module/edit.php , layouts/joomla/quickicons/icon.php , links.php , pagination/link.php , icon/iconclass.php , layouts/joomla/html/image.php , layouts/joomla/html/batch/user.php , renderlabel.php , renderfield.php , layouts/joomla/form/field/user.php , layouts/joomla/form/field/url.php , rules.php , form/field/radio/buttons.php , password.php , layouts/joomla/form/field/calendar.php , layouts/joomla/content/readmore.php , options_default.php , content/info_block/associations.php , emptystate_module.php , layouts/joomla/content/emptystate.php , category_default.php , installation/tmpl/remove/default.php , installation/includes/framework.php , installation/includes/app.php , includes/app.php , default_custom.php , components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/login/default_logout.php , default_login.php , components/com_tags/tmpl/tag/list.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tag/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , components/com_newsfeeds/tmpl/category/default.php , components/com_newsfeeds/tmpl/categories/default_items.php , components/com_menus/layouts/joomla/searchtools/default.php , default_result.php , com_finder/tmpl/search/default_form.php , com_fields/layouts/fields/render.php , com_fields/layouts/field/render.php , default_item.php , blog_item.php , components/com_content/tmpl/category/blog.php , components/com_content/tmpl/categories/default_items.php , components/com_content/tmpl/article/default.php , components/com_contact/tmpl/categories/default_items.php , com_contact/layouts/field/render.php , components/com_config/tmpl/modules/default.php , cli/joomla.php , api/includes/app.php , well.php , administrator/templates/atum/html/layouts/chromes/title.php , mod_title.php , administrator/templates/atum/html/layouts/chromes/body.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_modules/tmpl/modules/default.php , header-item.php , administrator/components/com_modules/tmpl/modules/emptystate.php , administrator/components/com_banners/tmpl/banners/emptystate.php , component/default_navigation.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_finder/tmpl/filters/emptystate.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/notes/emptystate.php , administrator/components/com_users/tmpl/method/backupcodes.php , administrator/components/com_users/tmpl/levels/default.php , default_tree.php , administrator/components/com_templates/tmpl/template/default.php , administrator/components/com_tags/tmpl/tags/emptystate.php , administrator/components/com_tags/tmpl/tags/default.php , empty_state.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_privacy/tmpl/requests/emptystate.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_finder/tmpl/indexer/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_banners/tmpl/clients/emptystate.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_installer/tmpl/update/emptystate.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , administrator/components/com_languages/tmpl/languages/default.php , preupdatecheck.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , extract.php , administrator/components/com_content/tmpl/articles/emptystate.php
  • ignore_fieldsets : administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_tags/tmpl/tag/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_finder/tmpl/filter/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_users/tmpl/group/edit.php , administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_modules/tmpl/module/edit.php , components/com_contact/tmpl/form/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_templates/tmpl/style/edit.php
  • image : administrator/components/com_templates/tmpl/styles/default.php
  • imageAlt : default_result.php
  • imageUrl : default_result.php
  • items : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- j -

  • JDEBUG : administrator/includes/framework.php , api/includes/framework.php , installation/includes/framework.php
  • jimport() : loader.php
  • JOOMLA_MINIMUM_PHP : index.php , installation/index.php , administrator/index.php , api/index.php , cli/joomla.php
  • JPATH_ADMINISTRATOR : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_API : includes/defines.php , installation/includes/defines.php , administrator/includes/defines.php , api/includes/defines.php
  • JPATH_BASE : installation/includes/app.php
  • JPATH_CACHE : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_CLI : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_CONFIGURATION : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_INSTALLATION : api/includes/defines.php , includes/defines.php , installation/includes/defines.php , administrator/includes/defines.php
  • JPATH_LIBRARIES : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_MANIFESTS : includes/defines.php , api/includes/defines.php , installation/includes/defines.php , administrator/includes/defines.php
  • JPATH_PLUGINS : api/includes/defines.php , installation/includes/defines.php , administrator/includes/defines.php , includes/defines.php
  • JPATH_ROOT : installation/includes/defines.php , administrator/includes/defines.php , api/includes/defines.php , includes/defines.php
  • JPATH_SITE : administrator/includes/defines.php , installation/includes/defines.php , includes/defines.php , api/includes/defines.php
  • JPATH_THEMES : installation/includes/defines.php , administrator/includes/defines.php , includes/defines.php , api/includes/defines.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- l -

  • language : blog_children.php , com_content/tmpl/category/default_children.php , modules/mod_tags_popular/tmpl/default.php
  • language_image : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php
  • language_title : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_menus/tmpl/items/default.php
  • level : administrator/modules/mod_menu/mod_menu.php
  • limitstart : default_results.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- m -

  • maxLevel : com_contact/tmpl/category/default_children.php , blog_children.php , com_newsfeeds/tmpl/category/default_children.php , com_content/tmpl/category/default_children.php
  • maxLevelcat : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php
  • method : administrator/components/com_menus/tmpl/items/default.php , mod_articles_categories.php , mod_articles_category.php , mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php
  • methodparams : mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php , mod_articles_categories.php , mod_articles_category.php
  • modal : layouts/joomla/form/field/user.php
  • modalLink : administrator/components/com_scheduler/tmpl/select/modal.php , administrator/components/com_modules/tmpl/select/modal.php
  • modeparams : mod_tags_popular.php , mod_related_items.php , mod_articles_category.php , mod_articles_categories.php , mod_tags_similar.php
  • modified_date : default_updated_files.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- n -

  • n : extract-tentative-return-types.php
  • name : default_cache.php , default_database.php , administrator/modules/mod_sampledata/tmpl/default.php , default_webservices.php , default_logging.php , default_session.php , default_server.php , administrator/components/com_config/tmpl/application/default_seo.php , default_proxy.php , default_permissions.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_mail.php , administrator/components/com_config/tmpl/application/default_site.php , default_logging_custom.php , default_locale.php , default_filters.php , default_debug.php , default_cookie.php
  • nbsp : compare.php
  • null : layouts/joomla/form/field/calendar.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- p -

  • parent : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php
  • path : layouts/joomla/form/field/media.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- r -

  • rating : com_content/tmpl/category/default_articles.php
  • rating_count : com_content/tmpl/category/default_articles.php
  • return : win1252_to_utf8.php , utf8_fix.php , transliterator_list.php , voku/portable-utf8/src/voku/helper/data/ord.php , encodings.php , emoji.php , chr.php , caseFolding_full.php , x1f1.php , x1d7.php , x1d6.php , x1d5.php , x1d4.php , x0ff.php , x0fe.php , x0fd.php , x0fc.php , x0fb.php , x0fa.php , x0f9.php , x0d7.php , x0d6.php , x0d5.php , x0d4.php , x0d3.php , x0d2.php , x0d1.php , x0d0.php , x0cf.php , x0ce.php , x0cd.php , x0cc.php , x0cb.php , x0ca.php , x0c9.php , x0c8.php , x0c7.php , x0c6.php , x0c5.php , x0c4.php , x0c3.php , x0c2.php , x0c1.php , x0c0.php , x0bf.php , x0be.php , x0bd.php , x0bc.php , x0bb.php , x0ba.php , x0b9.php , x0b8.php , x0b7.php , x0b6.php , x0b5.php , x0b4.php , x0b3.php , x0b2.php , x0b1.php , x0b0.php , x0af.php , x0ae.php , x0ad.php , x0ac.php , x0a4.php , x0a3.php , x0a2.php , x0a1.php , x0a0.php , x09f.php , x09e.php , x09d.php , x09c.php , x09b.php , x09a.php , x099.php , x098.php , x097.php , x096.php , x095.php , x094.php , x093.php , x092.php , x091.php , x090.php , x08f.php , x08e.php , x08d.php , x08c.php , x08b.php , x08a.php , x089.php , x088.php , x087.php , x086.php , x085.php , x084.php , x083.php , x082.php , x081.php , x080.php , x07f.php , x07e.php , x07d.php , x07c.php , x07b.php , x07a.php , x079.php , x078.php , x077.php , x076.php , x075.php , x074.php , x073.php , x072.php , x071.php , x070.php , x06f.php , x06e.php , x06d.php , x06c.php , x06b.php , x06a.php , x069.php , x068.php , x067.php , x066.php , x065.php , x064.php , x063.php , x062.php , x061.php , x060.php , x05f.php , x05e.php , x05d.php , x05c.php , x05b.php , x05a.php , x059.php , x058.php , x057.php , x056.php , x055.php , x054.php , x053.php , x052.php , x051.php , x050.php , x04f.php , x04e.php , x04d.php , x033.php , x032.php , x031.php , x030.php , x02f.php , x02e.php , x02c.php , x02a.php , x029.php , x028.php , x026.php , x025.php , x024.php , x023.php , x022.php , x021.php , x020.php , x01f.php , x01e.php , x01d.php , x016.php , x015.php , x014.php , x012.php , x011.php , x00d.php , x00c.php , x00b.php , x00a.php , x006.php , x005.php , x004.php , x003.php , x001.php , x000.php , ascii_ord.php , ascii_language_max_key.php , ascii_extras_by_languages.php , ascii_by_languages.php , wcswidth_table_zero.php , wcswidth_table_wide.php , titleCaseRegexp.php , replacements.php , default_results.php , administrator/cache/autoload_psr4.php , plugins/multifactorauth/webauthn/tmpl/default.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- s -

  • setHugeMemoryLimit() : extract.php
  • setLongTimeout() : extract.php
  • showlabel : default_permissions.php
  • SODIUM_BASE64_VARIANT_ORIGINAL : php72compat_const.php
  • SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING : php72compat_const.php
  • SODIUM_BASE64_VARIANT_URLSAFE : php72compat_const.php
  • SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AUTH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_AUTH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_MACBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SEALBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_KDF_BYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_KDF_BYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_KDF_CONTEXTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KDF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_PRIMITIVE : php72compat_const.php
  • SODIUM_CRYPTO_KX_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SESSIONKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SALTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_STRPREFIX : php72compat_const.php
  • SODIUM_CRYPTO_SCALARMULT_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SCALARMULT_SCALARBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_MACBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY : php72compat_const.php
  • SODIUM_CRYPTO_SHORTHASH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SHORTHASH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_XCHACHA20_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_XCHACHA20_NONCEBYTES : php72compat_const.php
  • SODIUM_LIBRARY_MAJOR_VERSION : php72compat_const.php
  • SODIUM_LIBRARY_MINOR_VERSION : php72compat_const.php
  • SODIUM_LIBRARY_VERSION : php72compat_const.php
  • subtemplatename : components/com_contact/tmpl/category/default.php , components/com_content/tmpl/category/default.php
  • sysexit() : svg-scanner.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- t -

  • tab_name : components/com_contact/tmpl/form/edit.php , components/com_content/tmpl/form/edit.php
  • templateMethod : generate_docs.php
  • text : default_profile.php , components/com_content/tmpl/category/blog.php , category_default.php
  • timingSafeEquals() : extract.php
  • title_native : modules/mod_languages/tmpl/default.php
  • true : administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php
  • try : administrator/components/com_scheduler/tmpl/tasks/default.php , manage.php , mod_messages.php , mod_post_installation_messages.php , administrator/components/com_scheduler/tmpl/select/modal.php , tmpl/sql.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- u -

  • updatecachetime_postinstall_action() : updatecachetime.php
  • updatecachetime_postinstall_condition() : updatecachetime.php
  • useCoreUI : administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_tags/tmpl/tag/edit.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_users/tmpl/group/edit.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_workflow/tmpl/transition/edit.php , components/com_contact/tmpl/form/edit.php , administrator/components/com_menus/tmpl/item/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php
  • usePreset : templates/cassiopeia/component.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , cassiopeia/offline.php
  • utf8_accents_to_ascii() : ascii.php
  • UTF8_BAD_5OCTET : bad.php
  • UTF8_BAD_6OCTET : bad.php
  • utf8_bad_explain() : bad.php
  • utf8_bad_find() : bad.php
  • utf8_bad_findall() : bad.php
  • utf8_bad_identify() : bad.php
  • UTF8_BAD_NONSHORT : bad.php
  • utf8_bad_replace() : bad.php
  • UTF8_BAD_SEQID : bad.php
  • UTF8_BAD_SEQINCOMPLETE : bad.php
  • utf8_bad_strip() : bad.php
  • UTF8_BAD_SURROGATE : bad.php
  • UTF8_BAD_UNIOUTRANGE : bad.php
  • utf8_byte_position() : position.php
  • utf8_compliant() : validation.php
  • utf8_from_unicode() : unicode.php
  • utf8_ireplace() : str_ireplace.php
  • utf8_is_ascii() : ascii.php
  • utf8_is_ascii_ctrl() : ascii.php
  • utf8_is_valid() : validation.php
  • utf8_is_word_chars() : specials.php
  • utf8_locate_current_chr() : position.php
  • utf8_locate_next_chr() : position.php
  • utf8_ltrim() : trim.php
  • utf8_ord() : joomla/string/src/phputf8/ord.php
  • utf8_rtrim() : trim.php
  • utf8_specials_pattern() : specials.php
  • utf8_str_pad() : str_pad.php
  • utf8_str_split() : str_split.php
  • utf8_strcasecmp() : strcasecmp.php
  • utf8_strcspn() : strcspn.php
  • utf8_strip_ascii_ctrl() : ascii.php
  • utf8_strip_non_ascii() : ascii.php
  • utf8_strip_non_ascii_ctrl() : ascii.php
  • utf8_strip_specials() : specials.php
  • utf8_stristr() : stristr.php
  • utf8_strlen() : mbstring/core.php , native/core.php
  • utf8_strpos() : native/core.php , mbstring/core.php
  • utf8_strrev() : strrev.php
  • utf8_strrpos() : mbstring/core.php , native/core.php
  • utf8_strspn() : strspn.php
  • utf8_strtolower() : native/core.php , mbstring/core.php
  • utf8_strtoupper() : native/core.php , mbstring/core.php
  • utf8_substr() : mbstring/core.php , native/core.php
  • utf8_substr_replace() : substr_replace.php
  • utf8_to_unicode() : unicode.php
  • utf8_trim() : trim.php
  • utf8_ucfirst() : ucfirst.php
  • utf8_ucwords() : ucwords.php
  • utf8_ucwords_callback() : ucwords.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- v -

  • value : compare.php , default_params.php , default_custom.php


Joomla CMS: Variables globale

- $ -

  • $a11y_contrast : administrator/templates/atum/index.php
  • $a11y_font : administrator/templates/atum/index.php
  • $a11y_highlight : administrator/templates/atum/index.php
  • $a11y_mono : administrator/templates/atum/index.php
  • $actions : administrator/components/com_users/tmpl/debuguser/default.php
  • $activated : administrator/components/com_users/tmpl/users/default.php
  • $activatedStates : administrator/components/com_users/tmpl/users/modal.php
  • $active : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php , addtab.php , modules/mod_menu/mod_menu.php
  • $active_id : modules/mod_menu/mod_menu.php
  • $activeLineColor : styles.php
  • $activeRequests : administrator/modules/mod_privacy_dashboard/tmpl/default.php
  • $addonAfterHtml : layouts/joomla/form/field/text.php
  • $addonBeforeHtml : layouts/joomla/form/field/text.php
  • $addons : element.php
  • $adminFormClass : administrator/components/com_postinstall/tmpl/messages/default.php , administrator/components/com_postinstall/tmpl/messages/emptystate.php
  • $advancedFieldsets : administrator/components/com_scheduler/tmpl/task/edit.php
  • $afterDisplayContent : components/com_content/tmpl/category/blog.php , category_default.php
  • $afterDisplayTitle : components/com_content/tmpl/category/blog.php , category_default.php
  • $ajax : default_submenu.php
  • $ajaxUri : default_mail.php , rules.php
  • $ajaxUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $alert : layouts/joomla/system/message.php , layouts/joomla/toolbar/batch.php
  • $allowEntryBatching : administrator/components/com_users/tmpl/captive/select.php , components/com_users/tmpl/captive/select.php
  • $allSliders : slider.php
  • $alpha : slider.php
  • $alt : administrator/modules/mod_submenu/tmpl/default.php , layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php , radiobasic.php , modules/mod_banners/tmpl/default.php
  • $anchor_css : default_heading.php , default_separator.php
  • $app : administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , webcron_link.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/includes/app.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , api/includes/app.php , cli/joomla.php , components/com_ajax/ajax.php , components/com_content/tmpl/category/blog.php , includes/app.php , category_default.php , admin_modules.php , fieldset.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , global.php , params.php , administrator/components/com_associations/tmpl/associations/modal.php , pagination/link.php , templates/cassiopeia/component.php , administrator/components/com_categories/tmpl/categories/modal.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , administrator/components/com_categories/tmpl/category/edit.php , cassiopeia/offline.php , system/offline.php , administrator/components/com_config/tmpl/component/default.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_media/tmpl/media/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/select/default.php
  • $append : layouts/joomla/content/emptystate.php
  • $argv : svg-scanner.php
  • $aria_described : layouts/joomla/content/icons/edit.php
  • $ariaDescribedBy : password.php
  • $ariaLabel : navigation.php
  • $article : layouts/joomla/content/icons/edit.php
  • $article_grouping : mod_articles_category.php
  • $article_grouping_direction : mod_articles_category.php
  • $articleId : icons.php
  • $assetColorName : templates/cassiopeia/component.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , cassiopeia/offline.php
  • $assetId : administrator/components/com_content/tmpl/featured/default.php
  • $assetRule : rules.php
  • $assoc : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php
  • $assocParam : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php
  • $attr : layouts/joomla/form/field/list.php , layouts/joomla/form/field/media.php , switcher.php , form/field/tag.php , workflowstage.php , categoryedit.php , com_modules/tmpl/modules/default_batch_body.php , combo.php , groupedlist-fancy-select.php , groupedlist.php , list-fancy-select.php
  • $attr2 : categoryedit.php , groupedlist-fancy-select.php , list-fancy-select.php , form/field/tag.php
  • $attribs : administrator/components/com_content/tmpl/articles/modal.php , well.php , transition-button.php , form/field/radio/buttons.php , modules/mod_syndicate/tmpl/default.php , card.php , noCard.php
  • $attributes : modulespositionedit.php , layouts/joomla/form/field/calendar.php , layouts/joomla/form/field/checkboxes.php , email.php , meter.php , moduleorder.php , number.php , password.php , form/field/radio/buttons.php , switcher.php , range.php , tel.php , layouts/joomla/form/field/text.php , layouts/joomla/form/field/textarea.php , time.php , layouts/joomla/form/field/url.php , default_component.php , default_url.php , plugins/fields/url/tmpl/url.php , dropdown-metismenu.php , dropdown-metismenu_component.php , dropdown-metismenu_heading.php , dropdown-metismenu_separator.php , dropdown-metismenu_url.php
  • $authMetadata : manage.php
  • $author : components/com_content/tmpl/archive/default_items.php , com_content/tmpl/category/default_articles.php , author.php
  • $authorised : layouts/joomla/content/tags.php
  • $autocomplete : advanced.php , slider.php
  • $autofocus : checkbox.php , advanced.php , slider.php
  • $b : styles.php
  • $backtraceList : backtrace.php
  • $base : modules/mod_menu/mod_menu.php
  • $baseDir : autoload_classmap.php , autoload_files.php , autoload_namespaces.php , libraries/vendor/composer/autoload_psr4.php
  • $basePath : element.php
  • $beforeDisplayContent : components/com_content/tmpl/category/blog.php , category_default.php
  • $behavior : bootstrap.php , cms.php
  • $bindNames : tmpl/sql.php
  • $blockEnd : form/field/radio/buttons.php
  • $blockPosition : info_block.php
  • $blockStart : form/field/radio/buttons.php
  • $blogClass : components/com_content/tmpl/category/blog.php , components/com_content/tmpl/featured/default.php
  • $bodyClass : layouts/libraries/html/bootstrap/modal/body.php
  • $bodyHeight : layouts/libraries/html/bootstrap/modal/body.php
  • $bootstrapSize : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php
  • $branchFilter : administrator/components/com_finder/tmpl/maps/default.php
  • $bscolumns : components/com_tags/tmpl/tags/default_items.php
  • $bsspans : components/com_tags/tmpl/tags/default_items.php
  • $btnadd : layouts/joomla/content/emptystate.php
  • $btnClass : form/field/radio/buttons.php
  • $buffer : tmpl/imagelist.php
  • $button : administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , button.php , layouts/joomla/editors/buttons/modal.php
  • $buttonClass : administrator/components/com_installer/tmpl/languages/default.php
  • $buttons : editors/buttons.php
  • $buttonText : administrator/components/com_installer/tmpl/languages/default.php
  • $c : administrator/components/com_categories/tmpl/category/edit.php
  • $cacheid : mod_articles_categories.php , mod_articles_category.php
  • $cacheparams : mod_articles_categories.php , mod_articles_category.php , mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php
  • $calendarAttrs : layouts/joomla/form/field/calendar.php
  • $calendarAttrsStr : layouts/joomla/form/field/calendar.php
  • $canAddEdit : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • $cancelURL : administrator/components/com_users/tmpl/method/backupcodes.php , administrator/components/com_users/tmpl/method/edit.php , components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/method/edit.php
  • $canChange : administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_menus/tmpl/items/default.php
  • $canCheckin : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $canCreate : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php
  • $canDelete : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • $canDo : components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/contact/default.php
  • $canEdit : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/article/default.php , blog_item.php , default_item.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php , blog_style_default_item_title.php , category_default.php , icons.php
  • $canEditCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditOwn : administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $canEditOwnCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditOwnParCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditParCat : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $canEditState : components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tags/default_items.php
  • $canManageCheckin : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php
  • $canManageItems : administrator/components/com_menus/tmpl/menus/default.php
  • $caption : sort.php
  • $category : administrator/components/com_fields/tmpl/fields/default.php , category_default.php
  • $category_image : administrator/components/com_users/tmpl/notes/modal.php
  • $channelIsDefined : logs.html.php
  • $check : administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php
  • $checkboxName : action-button.php , transition-button.php
  • $checked : update.php , checkbox.php , layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $class : administrator/modules/mod_menu/tmpl/default.php , default_submenu.php , administrator/modules/mod_submenu/tmpl/default.php , modules/default_options.php , com_contact/layouts/field/render.php , categories_default_items.php , button.php , layouts/joomla/editors/buttons/modal.php , backtrace.php , checkbox.php , advanced.php , simple.php , slider.php , hidden.php , meter.php , repeatable-table.php , repeatable.php , renderfield.php , layouts/joomla/quickicons/icon.php , system/privacyconsent/label.php , user/terms/label.php , traces.html.php , modules/mod_breadcrumbs/tmpl/default.php , tmpl/imagelist.php , plugins/fields/media/tmpl/media.php
  • $class_sfx : modules/mod_menu/mod_menu.php
  • $classes : categoryedit.php , renderlabel.php
  • $className : categories_default_items.php , category_default.php
  • $classToggle : form/field/radio/buttons.php
  • $classVisibility : update.php
  • $client : administrator/components/com_languages/tmpl/overrides/default.php , default_description.php
  • $clientId : administrator/components/com_menus/tmpl/item/edit.php , com_menus/tmpl/items/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php , administrator/components/com_modules/tmpl/modules/default.php , com_modules/tmpl/modules/default_batch_body.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $clientIdField : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php
  • $cMax : default_modal_file_body.php
  • $color : slider.php , styles.php
  • $colors : advanced.php
  • $cols : element.php
  • $columns : components/com_tags/tmpl/tags/default_items.php
  • $compatibilityTypes : preupdatecheck.php
  • $component : administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_tags/tmpl/tags/default.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php , global.php
  • $componentLangString : emptystate_module.php
  • $comUserParams : administrator/components/com_users/tmpl/mail/default.php
  • $config : administrator/components/com_media/tmpl/file/default.php , administrator/components/com_media/tmpl/media/default.php , administrator/includes/framework.php , api/includes/framework.php , includes/framework.php
  • $configFieldsets : params.php
  • $configuration : extract.php
  • $confirm : layouts/joomla/editors/buttons/modal.php
  • $container : administrator/includes/app.php , api/includes/app.php , cli/joomla.php , includes/app.php , installation/includes/app.php
  • $containerClass : form/field/radio/buttons.php
  • $content : noupdate.php , layouts/joomla/content/emptystate.php , element.php
  • $content_languages : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $context : administrator/components/com_fields/tmpl/fields/default.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_fields/tmpl/groups/default.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php
  • $control : advanced.php
  • $cookieLogin : components/com_users/tmpl/login/default.php
  • $count : administrator/components/com_content/tmpl/featured/default.php , default_tree.php , default_tree_media.php , administrator/components/com_users/tmpl/levels/default.php , frontediting_modules.php , mod_breadcrumbs.php
  • $countdiff : cloud.php
  • $countUnread : mod_messages.php
  • $cpanel : error_full.php , administrator/templates/atum/index.php
  • $cparams : mod_finder.php
  • $created_date : default_updated_files.php
  • $createdDateFormat : administrator/components/com_installer/tmpl/manage/default.php
  • $createURL : layouts/joomla/content/emptystate.php
  • $crypto_exception_handler_object_dont_touch_me : php-encryption/Crypto.php
  • $csite_name : mod_footer.php
  • $cur_year : mod_footer.php
  • $CurrentCatUrl : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $currentDate : components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php , blog_style_default_item_title.php , layouts/joomla/content/icons/edit.php
  • $currentJoomlaVersion : preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php
  • $currentPage : links.php
  • $currentParams : default_submenu.php
  • $currentShortVersion : administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/installed/default.php , installation/tmpl/remove/default.php
  • $customFields : default_custom.php
  • $customOptions : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $data : filters.php , layouts/joomla/searchtools/default/list.php , noitems.php , selector.php , layouts/joomla/searchtools/default.php , sort.php , layouts/joomla/tinymce/textarea.php , from.big5.php , from.cp037.php , from.cp1006.php , from.cp1026.php , from.cp424.php , from.cp437.php , from.cp500.php , from.cp737.php , from.cp775.php , from.cp850.php , from.cp852.php , from.cp855.php , from.cp856.php , from.cp857.php , from.cp860.php , from.cp861.php , from.cp862.php , from.cp863.php , from.cp864.php , from.cp865.php , from.cp866.php , from.cp869.php , from.cp874.php , from.cp875.php , from.cp932.php , from.cp936.php , from.cp949.php , from.cp950.php , from.iso-8859-1.php , from.iso-8859-10.php , from.iso-8859-11.php , from.iso-8859-13.php , from.iso-8859-14.php , from.iso-8859-15.php , from.iso-8859-16.php , from.iso-8859-2.php , from.iso-8859-3.php , from.iso-8859-4.php , from.iso-8859-5.php , from.iso-8859-6.php , from.iso-8859-7.php , from.iso-8859-8.php , from.iso-8859-9.php , from.koi8-r.php , from.koi8-u.php , from.us-ascii.php , from.windows-1250.php , from.windows-1251.php , from.windows-1252.php , from.windows-1253.php , from.windows-1254.php , from.windows-1255.php , from.windows-1256.php , from.windows-1257.php , from.windows-1258.php , modules/mod_breadcrumbs/tmpl/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , meter.php , bar.php
  • $dataAttribute : advanced.php , slider.php , hidden.php
  • $databaseConnectionEncryption : mod_privacy_status.php , administrator/modules/mod_privacy_status/tmpl/default.php
  • $datashowon : options_default.php
  • $dataShowOn : filters.php
  • $dataToggle : default_submenu.php
  • $date : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , mod_footer.php
  • $db : tmpl/sql.php
  • $default : transition-button.php , slider.php , modules/mod_menu/mod_menu.php
  • $default_id : modules/mod_menu/mod_menu.php
  • $defaultDisplayData : manage.php
  • $desc : administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/select/default.php
  • $descClass : renderfield.php
  • $description : administrator/components/com_templates/tmpl/style/edit.php , components/com_tags/tmpl/tags/default.php
  • $descriptionImage : components/com_tags/tmpl/tags/default.php
  • $dir : plugins/installer/webinstaller/tmpl/default.php
  • $direction : administrator/modules/mod_feed/tmpl/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , layouts/joomla/content/readmore.php , advanced.php , basic.php , dropdown.php , modules/mod_feed/tmpl/default.php
  • $disableClassName : administrator/components/com_languages/tmpl/languages/default.php
  • $disabled : action-button.php , transition-button.php , layouts/joomla/form/field/calendar.php , checkbox.php , advanced.php , simple.php , slider.php , hidden.php , form/field/radio/buttons.php
  • $disabledLabel : administrator/components/com_languages/tmpl/languages/default.php
  • $display : pagination/link.php
  • $display_count : mod_tags_popular.php
  • $displayData : administrator/components/com_banners/tmpl/banners/emptystate.php , administrator/components/com_banners/tmpl/clients/emptystate.php , administrator/components/com_banners/tmpl/tracks/emptystate.php , administrator/components/com_cache/tmpl/cache/emptystate.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_checkin/tmpl/checkin/emptystate.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_content/tmpl/articles/emptystate.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_finder/tmpl/filters/emptystate.php , administrator/components/com_finder/tmpl/index/emptystate.php , administrator/components/com_finder/tmpl/maps/emptystate.php , administrator/components/com_finder/tmpl/searches/emptystate.php , administrator/components/com_installer/tmpl/discover/emptystate.php , administrator/components/com_installer/tmpl/update/emptystate.php , administrator/components/com_installer/tmpl/warnings/emptystate.php , noupdate.php , reinstall.php , selfupdate.php , update.php , administrator/components/com_messages/tmpl/messages/emptystate.php , administrator/components/com_modules/tmpl/modules/emptystate.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_postinstall/tmpl/messages/emptystate.php , administrator/components/com_privacy/tmpl/consents/emptystate.php , administrator/components/com_privacy/tmpl/requests/emptystate.php , administrator/components/com_redirect/tmpl/links/emptystate.php , empty_state.php , administrator/components/com_tags/tmpl/tags/emptystate.php , administrator/components/com_users/tmpl/notes/emptystate.php , button/iconclass.php , layouts/joomla/html/image.php , toolbar/iconclass.php
  • $displayGroups : default_user_custom_fields.php
  • $displayTable : installation/tmpl/remove/default.php
  • $displayValues : slider.php
  • $doc : administrator/modules/mod_menu/tmpl/default.php , edit/associations.php , layouts/joomla/form/field/media.php , tinymcebuilder.php
  • $document : layouts/joomla/form/field/calendar.php , password.php , rules.php , layouts/joomla/system/message.php
  • $edit : administrator/components/com_workflow/tmpl/workflows/default.php
  • $EditCatTxt : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $editor : administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , element.php
  • $editoroptions : components/com_content/tmpl/form/edit.php
  • $editorText : components/com_config/tmpl/modules/default.php
  • $editUrl : frontediting_modules.php
  • $enabled : extract.php , administrator/modules/mod_menu/mod_menu.php
  • $enabledStates : administrator/components/com_users/tmpl/users/modal.php
  • $endDate : administrator/components/com_finder/tmpl/index/default.php
  • $errorHandler : bootstrap.php
  • $escapedTitle : administrator/components/com_finder/tmpl/filters/default.php
  • $exceptionAsArray : exception.html.php
  • $exceptionAsArrayCount : exception.html.php
  • $exceptionWithUserCode : exception.html.php
  • $expired : administrator/components/com_languages/tmpl/override/edit.php
  • $explodeArray : default_folders.php , default_media_folders.php , default_tree.php , default_tree_media.php
  • $extension : administrator/components/com_categories/tmpl/categories/default.php , com_categories/tmpl/categories/default_batch_body.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , categories_default_items.php , category_default.php
  • $extensionassoc : administrator/components/com_categories/tmpl/category/edit.php
  • $extJS : element.php
  • $extraAttr : default_result.php
  • $extraButtons : administrator/modules/mod_login/mod_login.php , modules/mod_login/mod_login.php , cassiopeia/offline.php
  • $extraFields : fieldset.php , params.php
  • $fancySelectData : default_modal_child_body.php
  • $feed : administrator/modules/mod_feed/mod_feed.php , modules/mod_feed/mod_feed.php
  • $field : administrator/components/com_users/tmpl/users/modal.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php
  • $fields : layouts/joomla/menu/edit_modules.php , com_contact/layouts/fields/render.php , com_contact/tmpl/contact/default_form.php , com_fields/layouts/fields/render.php , default_params.php , admin_modules.php , global.php , publishingdata.php
  • $fieldSet : fieldset.php
  • $fieldsets : administrator/components/com_users/tmpl/user/edit.php , default_custom.php
  • $fieldSets : administrator/components/com_media/tmpl/file/default.php , modules/default_options.php , templates/default_options.php , metadata.php , params.php
  • $fieldsetsInImages : administrator/components/com_content/tmpl/article/edit.php
  • $fieldsetsInLinks : administrator/components/com_content/tmpl/article/edit.php
  • $fieldsnames : options_default.php , text_filters.php
  • $fieldValue : plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/list/tmpl/list.php
  • $fileArray : default_tree.php , default_tree_media.php
  • $files_to_scan : svg-scanner.php
  • $filesize : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $filterButton : bar.php
  • $filters : bar.php , filters.php
  • $filtersActiveClass : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $folder : mod_random_image.php
  • $fontFamily : styles.php
  • $fontSize : styles.php
  • $fontStyles : templates/cassiopeia/component.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , cassiopeia/offline.php
  • $footerText : mod_banners.php , mod_languages.php
  • $form : administrator/components/com_media/tmpl/file/default.php , layouts/joomla/menu/edit_modules.php , admin_modules.php , edit/associations.php , fieldset.php , global.php , metadata.php , params.php , publishingdata.php , title_alias.php , accessiblemedia.php , layouts/joomla/form/field/subform/default.php
  • $format : components/com_ajax/ajax.php , layouts/joomla/form/field/checkboxes.php , advanced.php , slider.php , radiobasic.php
  • $formatString : plugins/fields/calendar/tmpl/calendar.php
  • $formAttr : basic.php , standard.php
  • $formfields : accessiblemedia.php
  • $formId : modules/mod_login/mod_login.php
  • $formURL : layouts/joomla/content/emptystate.php
  • $formUrl : administrator/components/com_contenthistory/tmpl/history/modal.php
  • $forumId : langforum.php
  • $forumUrl : langforum.php
  • $fsCombo : element.php
  • $fskeys : element.php
  • $fullScreenCombo : element.php
  • $fullWidth : cassiopeia/offline.php
  • $function : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php
  • $g : styles.php
  • $groupClass : options_default.php
  • $grouped : mod_articles_category.php
  • $groups : administrator/components/com_users/tmpl/levels/default.php , blog_children.php , com_content/tmpl/category/default_children.php , workflowstage.php , tmpl/usergrouplist.php
  • $halfstar : rating.php
  • $hasClass : templates/cassiopeia/index.php
  • $hasContent : administrator/components/com_modules/tmpl/module/edit.php
  • $hasContentFieldName : administrator/components/com_modules/tmpl/module/edit.php
  • $hash : administrator/components/com_contenthistory/tmpl/history/modal.php
  • $header : html5.php , card.php , noCard.php
  • $headerAttribs : html5.php , card.php , noCard.php
  • $headerClass : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $headerIcon : well.php
  • $headerTag : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $headerText : mod_banners.php , mod_languages.php
  • $heading : sort.php
  • $headingLevel : administrator/components/com_users/tmpl/method/edit.php , administrator/components/com_users/tmpl/methods/firsttime.php , components/com_users/tmpl/method/edit.php , components/com_users/tmpl/methods/firsttime.php
  • $height : modules/mod_banners/tmpl/default.php , mod_wrapper.php
  • $helper : params.php
  • $helpURL : layouts/joomla/content/emptystate.php
  • $helpUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $hiddenFields : layouts/joomla/menu/edit_modules.php , admin_modules.php , global.php , publishingdata.php
  • $hiddenFieldsets : params.php
  • $hiddenLinks : edit_container.php
  • $hiddenMenu : error_full.php , administrator/templates/atum/index.php
  • $hideActiveFilters : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php
  • $hideDescription : renderfield.php
  • $hideLabel : renderfield.php
  • $hideLinks : administrator/modules/mod_messages/tmpl/default.php , administrator/modules/mod_multilangstatus/tmpl/default.php , administrator/modules/mod_post_installation_messages/tmpl/default.php , administrator/modules/mod_user/tmpl/default.php
  • $highlightMatchColor : styles.php
  • $hint : advanced.php , slider.php
  • $hits_class : administrator/modules/mod_popular/tmpl/default.php
  • $home_pages : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $homeImage : default_submenu.php
  • $href : button.php , layouts/joomla/editors/buttons/modal.php
  • $htag : components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/article/default.php , components/com_content/tmpl/category/blog.php , components/com_newsfeeds/tmpl/category/default.php , components/com_tags/tmpl/tag/default.php , components/com_tags/tmpl/tag/list.php , category_default.php
  • $html : categoryedit.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/modules/mod_quickicon/tmpl/default.php , admin_modules.php , fieldset.php , global.php , groupedlist-fancy-select.php , groupedlist.php , list-fancy-select.php , layouts/joomla/form/field/list.php , form/field/tag.php , icon/iconclass.php
  • $i : administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , modules/default_options.php
  • $icon : default_submenu.php , administrator/modules/mod_submenu/tmpl/default.php , default_address.php , default_result.php , layouts/joomla/content/emptystate.php , emptystate_module.php , layouts/joomla/content/icons/edit.php , button.php , icon/iconclass.php , sort.php , layouts/joomla/toolbar/title.php
  • $iconClass : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , default_submenu.php
  • $iconFixed : icon/iconclass.php
  • $iconHalfstar : rating.php
  • $iconImage : default_submenu.php
  • $iconPrefix : icon/iconclass.php
  • $iconStar : rating.php
  • $iconStates : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php
  • $iconSuffix : icon/iconclass.php
  • $id : com_modules/tmpl/module/edit_assignment.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , com_content/tmpl/article/default_links.php , action-button.php , transition-button.php , renderfield.php , renderlabel.php , links/link.php , layouts/joomla/quickicons/icon.php , sort.php , layouts/joomla/toolbar/batch.php , addtab.php , modules/mod_articles_categories/tmpl/default_items.php , modules/mod_menu/tmpl/default.php , mod_wrapper.php , element.php
  • $idAttr : basic.php , popup.php , standard.php
  • $idbase : mod_articles_category.php
  • $iframeAttributes : iframe.php
  • $ignoreFields : fieldset.php , params.php
  • $ignoreFieldsetFields : params.php
  • $ignoreFieldsets : params.php
  • $image : mod_random_image.php
  • $imageClass : default_result.php
  • $imageOptions : components/com_tags/tmpl/tags/default_items.php
  • $images : components/com_newsfeeds/tmpl/newsfeed/default.php , components/com_tags/tmpl/tag/default_items.php , full_image.php , intro_image.php , mod_random_image.php
  • $img : layouts/joomla/html/image.php , rating.php
  • $imgclass : full_image.php , intro_image.php
  • $info : components/com_content/tmpl/article/default.php , blog_item.php , default_item.php
  • $inheritedGroupParentAssetRule : rules.php
  • $inheritedGroupRule : rules.php
  • $inheritedParentGroupRule : rules.php
  • $input : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_media/tmpl/media/default.php , layouts/joomla/menu/edit_modules.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_templates/tmpl/template/default.php , default_modal_delete_footer.php , default_modal_file_body.php , default_modal_folder_body.php , default_modal_folder_footer.php , default_updated_files.php , readonly.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , components/com_ajax/ajax.php , admin_modules.php , global.php , switcher.php , modules/mod_articles_categories/tmpl/default_items.php , mod_articles_category.php , modules/mod_finder/tmpl/default.php
  • $inputAttributes : layouts/joomla/form/field/user.php
  • $inputclass : advanced.php
  • $inputvalue : layouts/joomla/form/field/calendar.php
  • $isBtnGroup : form/field/radio/buttons.php
  • $isBtnYesNo : form/field/radio/buttons.php
  • $isCheckout : administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php
  • $isEditable : com_content/tmpl/category/default_articles.php
  • $isExpired : components/com_content/tmpl/article/default.php , default_item.php
  • $isFirstUserCode : traces.html.php
  • $isMail : com_contact/layouts/fields/render.php
  • $isModal : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $isNotPublishedYet : components/com_content/tmpl/article/default.php , default_item.php
  • $isRtl : components/com_newsfeeds/tmpl/newsfeed/default.php , modules/mod_feed/tmpl/default.php
  • $isSingleTag : components/com_tags/tmpl/tag/default.php
  • $issues : platform_check.php
  • $isSuperUserGroup : rules.php
  • $isUnpublished : blog_item.php , default_item.php , layouts/joomla/content/icons/edit.php
  • $item : administrator/components/com_menus/tmpl/items/modal.php , com_contact/layouts/fields/render.php , com_fields/layouts/fields/render.php , categories_default_items.php , layouts/joomla/content/language.php , layouts/joomla/content/readmore.php , pagination/link.php
  • $itemIconClass : default_submenu.php
  • $itemid : frontediting_modules.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $itemId : components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php
  • $itemIds : administrator/components/com_menus/tmpl/menus/default.php
  • $itemImage : default_submenu.php
  • $items : mod_sampledata.php , content/associations.php , categories_default_items.php , tmpl/sql.php
  • $itemsCounter : modules/mod_breadcrumbs/tmpl/default.php
  • $ititle : mod_wrapper.php
  • $joomlaFilesExtensionId : mod_post_installation_messages.php
  • $key : administrator/components/com_finder/tmpl/index/default.php
  • $keyArrayCount : default_tree.php , default_tree_media.php
  • $keywords : advanced.php
  • $label : com_contact/layouts/field/render.php , com_contact/tmpl/contact/default_links.php , com_content/tmpl/article/default_links.php , com_fields/layouts/field/render.php , system/privacyconsent/label.php , user/terms/label.php , modules/mod_finder/tmpl/default.php
  • $labelClass : preupdatecheck.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php , modules/mod_finder/tmpl/default.php
  • $lang : administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , mod_privacy_dashboard.php , mod_privacy_status.php , blog_children.php , com_content/tmpl/category/default_children.php , components/com_users/tmpl/profile/edit.php , layouts/joomla/form/field/calendar.php , modules/mod_finder/tmpl/default.php , navigation.php , plugins/content/pagenavigation/tmpl/default.php
  • $lang_string : administrator/components/com_finder/tmpl/statistics/default.php
  • $langFilter : com_content/tmpl/category/default_articles.php
  • $langs : administrator/modules/mod_login/mod_login.php
  • $language : administrator/components/com_languages/tmpl/overrides/default.php
  • $languages : generate_max_key_length.php
  • $languagesKeyLengths : generate_max_key_length.php
  • $last : exception.html.php
  • $last_item_key : modules/mod_breadcrumbs/tmpl/default.php
  • $latestJoomlaVersion : preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php
  • $layout : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , error_full.php , error_login.php , administrator/templates/atum/index.php , login.php , default_results.php , modules/mod_login/mod_login.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $layoutAttr : full_image.php , intro_image.php
  • $lazyloading : mod_wrapper.php
  • $levelup : modules/mod_articles_categories/tmpl/default_items.php
  • $limit : default_results.php
  • $lineHeight : styles.php
  • $link : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , default_submenu.php , com_contact/tmpl/contact/default_links.php , components/com_content/tmpl/article/default.php , blog_item.php , com_content/tmpl/category/default_articles.php , default_item.php , default_results.php , blog_style_default_item_title.php , button.php , layouts/joomla/editors/buttons/modal.php , modules/mod_articles_category/tmpl/default_items.php , mod_random_image.php , mod_syndicate.php
  • $link_class : layouts/joomla/content/tags.php
  • $linkClass : default_submenu.php
  • $linkText : modules/mod_syndicate/tmpl/default.php
  • $linktype : default_component.php , default_heading.php , default_separator.php , default_url.php , dropdown-metismenu_component.php , dropdown-metismenu_heading.php , dropdown-metismenu_separator.php , dropdown-metismenu_url.php
  • $linkUrl : default_results.php
  • $list : mod_breadcrumbs.php , modules/mod_articles_categories/tmpl/default_items.php , layouts/joomla/pagination/list.php , mod_latest.php , mod_latestactions.php , mod_popular.php , mod_privacy_dashboard.php , mod_stats_admin.php , layouts/joomla/form/field/text.php , links.php , layouts/joomla/searchtools/default/list.php , mod_articles_archive.php , mod_articles_categories.php , mod_articles_category.php , mod_articles_popular.php , mod_banners.php , mod_languages.php , modules/mod_menu/mod_menu.php , mod_related_items.php , mod_stats.php , mod_tags_popular.php , mod_tags_similar.php
  • $listAttr : popup.php , basic.php , standard.php
  • $listDirection : administrator/components/com_installer/tmpl/database/default.php
  • $listDirn : administrator/components/com_users/tmpl/users/modal.php , list_items.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/featured/default_items.php , com_content/tmpl/category/default_articles.php , components/com_newsfeeds/tmpl/category/default_items.php
  • $listoptions : layouts/joomla/form/field/list.php
  • $listOrder : administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , components/com_contact/tmpl/category/default_items.php , components/com_contact/tmpl/featured/default_items.php , components/com_newsfeeds/tmpl/category/default_items.php , list_items.php , administrator/components/com_users/tmpl/debuggroup/default.php , com_content/tmpl/category/default_articles.php , administrator/components/com_workflow/tmpl/transitions/default.php
  • $load : mod_wrapper.php
  • $loader : cms.php , bootstrap.php
  • $location : components/com_contact/tmpl/category/default_items.php
  • $loggedInUser : manage.php
  • $loggeduser : administrator/components/com_users/tmpl/users/default.php
  • $loginActions : administrator/components/com_users/tmpl/debuguser/default.php
  • $loginLogo : error_login.php , login.php
  • $loginLogoAlt : login.php , error_login.php
  • $loginmodule : administrator/components/com_login/tmpl/login/default.php
  • $logoBrandLarge : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $logoBrandLargeAlt : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $logoBrandSmall : error_full.php , error_login.php , administrator/templates/atum/index.php , login.php
  • $logoBrandSmallAlt : error_full.php , administrator/templates/atum/index.php , login.php , error_login.php
  • $long_description : administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • $loop : administrator/templates/system/error.php , installation/template/error.php , templates/system/error.php , templates/cassiopeia/error.php
  • $manifest : administrator/components/com_installer/tmpl/database/default.php
  • $margin : toolbar/link.php
  • $maxcount : cloud.php
  • $maxSize : administrator/components/com_joomlaupdate/tmpl/upload/default.php , default_modal_file_body.php , file.php
  • $maxsize : cloud.php
  • $maxSize : plugins/installer/packageinstaller/tmpl/default.php
  • $maxSizeBytes : administrator/components/com_joomlaupdate/tmpl/upload/default.php , plugins/installer/packageinstaller/tmpl/default.php
  • $mediaTypes : administrator/components/com_media/tmpl/media/default.php , administrator/components/com_media/tmpl/file/default.php
  • $mediaVersion : element.php
  • $member : modules/mod_whosonline/tmpl/default.php
  • $menu : templates/cassiopeia/error.php , templates/cassiopeia/index.php , administrator/modules/mod_menu/mod_menu.php
  • $menuLinks : edit_container.php
  • $menusEditing : frontediting_modules.php
  • $menuType : administrator/components/com_menus/tmpl/items/default.php , com_menus/tmpl/items/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php
  • $menutype : mod_submenu.php , administrator/components/com_menus/tmpl/menutypes/default.php
  • $menuTypes : com_modules/tmpl/module/edit_assignment.php , com_templates/tmpl/style/edit_assignment.php
  • $message : layouts/joomla/toolbar/batch.php
  • $message1 : default_message.php
  • $message2 : default_message.php
  • $messages : mod_messages.php
  • $messagesCount : mod_post_installation_messages.php
  • $method : administrator/components/com_users/tmpl/method/edit.php , components/com_users/tmpl/method/edit.php
  • $methodName : administrator/components/com_users/tmpl/captive/select.php , components/com_users/tmpl/captive/select.php
  • $mfa : administrator/components/com_users/tmpl/users/default.php
  • $minorVersion : administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/installed/default.php
  • $minsize : cloud.php
  • $mod : frontediting_modules.php
  • $modalAttributes : main.php
  • $modalAttrs : popup.php
  • $modalbody : administrator/components/com_scheduler/tmpl/tasks/default.php
  • $modalClasses : main.php
  • $modalDialogClass : main.php
  • $modalHTML : layouts/joomla/form/field/media.php , layouts/joomla/form/field/user.php , administrator/modules/mod_multilangstatus/tmpl/default.php
  • $modalparams : administrator/components/com_scheduler/tmpl/tasks/default.php
  • $modalWidth : main.php
  • $mode : administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , mod_articles_category.php
  • $model : administrator/components/com_users/tmpl/methods/list.php , mod_latest.php , mod_popular.php , components/com_users/tmpl/methods/list.php , mod_banners.php , components/com_users/tmpl/captive/default.php , administrator/components/com_users/tmpl/captive/default.php
  • $modePath : element.php
  • $modId : banner.php , modules/mod_custom/tmpl/default.php
  • $modifier : element.php
  • $modMenuId : administrator/components/com_menus/tmpl/menus/default.php
  • $modPath : element.php
  • $module : administrator/templates/atum/html/layouts/chromes/body.php , header-item.php , administrator/templates/atum/html/layouts/chromes/title.php , html5.php , outline.php , table.php , noCard.php , card.php , well.php
  • $moduleAttribs : html5.php , card.php , noCard.php , html5.php
  • $moduleClass : administrator/templates/atum/html/layouts/chromes/body.php , well.php
  • $moduleClassSfx : administrator/templates/atum/html/layouts/chromes/body.php , well.php
  • $moduleCollapsedHtml : status.php
  • $moduleHtml : status.php , frontediting_modules.php
  • $moduleId : administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php
  • $moduleLangString : emptystate_module.php
  • $modulePosition : status.php
  • $modules : status.php , administrator/components/com_login/tmpl/login/default.php
  • $moduleTag : administrator/templates/atum/html/layouts/chromes/body.php , well.php , html5.php , card.php , noCard.php
  • $moduleXml : components/com_config/tmpl/modules/default.php
  • $msgAttr : standard.php , basic.php
  • $msgList : layouts/joomla/system/message.php
  • $msgOutput : layouts/joomla/system/message.php
  • $multilang : administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , default_results.php , administrator/components/com_contact/tmpl/contacts/modal.php
  • $multilanguageEnabled : mod_multilangstatus.php
  • $myrtl : administrator/modules/mod_feed/tmpl/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , modules/mod_feed/tmpl/default.php
  • $n : administrator/components/com_contact/tmpl/contacts/default.php , com_content/tmpl/category/default_articles.php , components/com_newsfeeds/tmpl/category/default_items.php , components/com_tags/tmpl/tags/default_items.php , components/com_tags/tmpl/tag/list.php
  • $name : administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/select/default.php , element.php , fieldset.php
  • $names : mod_users_latest.php
  • $namespace : traces.html.php
  • $noResultsText : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php
  • $notice_disabled : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $notice_switchers : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $noUser : com_contact/tmpl/contacts/default_batch_body.php
  • $now : administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/requests/default.php
  • $nowDate : layouts/joomla/content/icons/edit.php
  • $numberOfUrgentRequests : mod_privacy_status.php
  • $object1 : compare.php
  • $object2 : compare.php
  • $oid : layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $onchange : checkbox.php , advanced.php , slider.php , hidden.php , form/field/radio/buttons.php , layouts/joomla/form/field/checkboxes.php
  • $onClick : administrator/components/com_users/tmpl/users/modal.php
  • $onclick : administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/modal.php , button.php , layouts/joomla/editors/buttons/modal.php , checkbox.php , slider.php , form/field/radio/buttons.php , links/link.php , layouts/joomla/quickicons/icon.php , layouts/joomla/form/field/checkboxes.php , administrator/components/com_installer/tmpl/languages/default.php
  • $opentab : params.php
  • $oppositeClient : administrator/components/com_languages/tmpl/overrides/default.php
  • $oppositeFilename : administrator/components/com_languages/tmpl/overrides/default.php
  • $oppositeStrings : administrator/components/com_languages/tmpl/overrides/default.php
  • $option : error_full.php , error_login.php , administrator/templates/atum/index.php , modules/mod_articles_categories/tmpl/default_items.php , element.php , templates/cassiopeia/error.php , templates/cassiopeia/index.php , login.php
  • $optionClass : layouts/joomla/form/field/checkboxes.php , form/field/radio/buttons.php
  • $optionDisabled : layouts/joomla/form/field/checkboxes.php
  • $optionId : switcher.php
  • $optionNo : layouts/joomla/html/batch/user.php
  • $options : administrator/components/com_associations/tmpl/association/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php , com_fields/tmpl/fields/default_batch_body.php , com_menus/tmpl/items/default_batch_body.php , default_modal_child_body.php , edit/associations.php , layouts/joomla/editors/buttons/modal.php , item.php , tmpl/vote.php , element.php , plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/media/tmpl/media.php , tmpl/radio.php , plugins/fields/list/tmpl/list.php , links.php , com_users/tmpl/users/default_batch_body.php
  • $optionValue : switcher.php
  • $opts : com_menus/tmpl/items/default_batch_body.php
  • $ordering : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_fields/tmpl/fields/default.php
  • $orderingColumn : administrator/components/com_workflow/tmpl/workflows/default.php
  • $os : bootstrap.php , import.legacy.php , import.php
  • $output : modules/mod_finder/tmpl/default.php , com_fields/layouts/fields/render.php
  • $outputFieldsets : params.php
  • $ovalue : form/field/radio/buttons.php
  • $pageclass : templates/cassiopeia/error.php , templates/cassiopeia/index.php
  • $pages : links.php
  • $parameters : frontediting_modules.php
  • $params : styles.php , element.php , full_image.php , mod_wrapper.php , blog_style_default_item_title.php , table.php , components/com_content/tmpl/archive/default_items.php , edit_container.php , default_user_custom_fields.php , administrator/components/com_content/tmpl/article/edit.php , com_redirect/tmpl/links/default_batch_body.php , default_item.php , com_content/tmpl/articles/default_batch_body.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_media/tmpl/media/default.php , well.php , com_content/tmpl/article/default_links.php , blog_item.php , html5.php , category_default.php , create.php , layouts/joomla/content/readmore.php , card.php , noCard.php , administrator/components/com_media/tmpl/file/default.php , administrator/templates/atum/html/layouts/chromes/body.php , components/com_content/tmpl/article/default.php , components/com_content/tmpl/form/edit.php , categories_default_items.php , intro_image.php
  • $paramsColorName : cassiopeia/offline.php , templates/cassiopeia/component.php , templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $paramsFontScheme : cassiopeia/offline.php , templates/cassiopeia/component.php , templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $ParentCatUrl : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $parts : installation/includes/defines.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_fields/tmpl/groups/default.php , com_contact/layouts/fields/render.php , administrator/components/com_categories/tmpl/categories/default.php , api/includes/defines.php , components/com_ajax/ajax.php , includes/defines.php , com_fields/layouts/fields/render.php , administrator/includes/defines.php
  • $password : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $path : modules/mod_menu/mod_menu.php
  • $pathHalfstar : rating.php
  • $pathStar : rating.php
  • $penult_item_key : modules/mod_breadcrumbs/tmpl/default.php
  • $PHPMAILER_LANG : phpmailer.lang-en_gb.php
  • $placeholder : categoryedit.php
  • $position : advanced.php , slider.php , frontediting_modules.php
  • $positions : com_modules/tmpl/modules/default_batch_body.php
  • $prefix : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_categories/tmpl/categories/default.php , com_fields/layouts/field/render.php , administrator/components/com_menus/tmpl/items/modal.php
  • $presetButtonClasses : tinymcebuilder.php
  • $preview : slider.php
  • $prevlevel : com_modules/tmpl/module/edit_assignment.php , edit_container.php
  • $privacyConsentPluginId : mod_privacy_status.php
  • $privacyPolicyInfo : mod_privacy_status.php
  • $published : com_banners/tmpl/banners/default_batch_body.php , com_modules/tmpl/modules/default_batch_body.php , com_newsfeeds/tmpl/newsfeeds/default_batch_body.php , com_categories/tmpl/categories/default_batch_body.php , com_contact/tmpl/contacts/default_batch_body.php , com_content/tmpl/articles/default_batch_body.php , com_menus/tmpl/items/default_batch_footer.php , com_tags/tmpl/tags/default_batch_body.php , com_menus/tmpl/items/default_batch_body.php , com_redirect/tmpl/links/default_batch_body.php
  • $publishEndDate : administrator/components/com_finder/tmpl/index/default.php
  • $publishStartDate : administrator/components/com_finder/tmpl/index/default.php
  • $purchaseTypes : administrator/components/com_banners/tmpl/clients/default.php
  • $query : tmpl/sql.php , mod_finder.php
  • $r : styles.php
  • $range : links.php
  • $rating : rating.php
  • $rcount : rating.php
  • $readmeGenerator : generate_docs.php
  • $readmeText : generate_docs.php
  • $readonly : slider.php , simple.php , advanced.php , layouts/joomla/form/field/calendar.php
  • $recordId : components/com_users/tmpl/method/edit.php , administrator/components/com_users/tmpl/method/edit.php
  • $redirectUri : frontediting_modules.php
  • $registerLink : modules/mod_login/mod_login.php
  • $rel : links/link.php , renderfield.php
  • $renderer : status.php
  • $requestFormPublished : mod_privacy_status.php
  • $required : system/privacyconsent/label.php , checkbox.php , advanced.php , slider.php , user/terms/label.php
  • $resetOptions : com_users/tmpl/users/default_batch_body.php
  • $result : from.big5.php , from.cp424.php , from.cp775.php , from.cp856.php , from.cp862.php , from.cp866.php , from.iso-8859-1.php , from.iso-8859-14.php , from.iso-8859-3.php , from.iso-8859-7.php , from.cp932.php , from.windows-1254.php , from.koi8-u.php , from.windows-1252.php , from.windows-1251.php , from.windows-1250.php , from.iso-8859-6.php , from.iso-8859-16.php , from.iso-8859-5.php , from.cp875.php , from.cp864.php , from.cp874.php , from.cp861.php , from.cp860.php , from.cp737.php , from.cp1006.php , from.cp500.php , from.iso-8859-11.php , from.cp1026.php , from.windows-1256.php , rules.php , from.iso-8859-13.php , from.cp037.php , from.cp437.php , from.cp850.php , from.cp852.php , from.cp855.php , from.cp857.php , from.cp863.php , from.cp865.php , from.cp869.php , from.cp936.php , from.cp949.php , from.cp950.php , from.iso-8859-10.php , from.iso-8859-15.php , from.iso-8859-2.php , from.iso-8859-4.php , from.iso-8859-8.php , from.iso-8859-9.php , from.koi8-r.php , from.us-ascii.php , from.windows-1253.php , from.windows-1255.php , from.windows-1257.php , from.windows-1258.php , tmpl/subform.php
  • $results : svg-scanner.php , components/com_content/tmpl/category/blog.php , category_default.php , components/com_ajax/ajax.php
  • $retArray : extract.php
  • $return : plugins/installer/packageinstaller/tmpl/default.php , modules/mod_login/mod_login.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/modules/mod_login/mod_login.php
  • $returnUrl : administrator/components/com_joomlaupdate/tmpl/update/default.php
  • $root : administrator/modules/mod_menu/mod_menu.php , mod_submenu.php
  • $route : administrator/modules/mod_messages/tmpl/default.php , mod_finder.php , administrator/modules/mod_user/tmpl/default.php
  • $rows : element.php
  • $rssrtl : administrator/modules/mod_feed/mod_feed.php , modules/mod_feed/mod_feed.php
  • $rssurl : modules/mod_feed/mod_feed.php , administrator/modules/mod_feed/mod_feed.php
  • $sanitizer : svg-scanner.php
  • $saveFormat : slider.php
  • $saveHistory : layouts/joomla/menu/edit_modules.php , global.php
  • $saveOrder : administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_workflow/tmpl/workflows/default.php
  • $saveOrderingUrl : administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php
  • $scope : administrator/modules/mod_submenu/tmpl/default.php
  • $script : administrator/components/com_media/tmpl/file/default.php
  • $searchButton : bar.php
  • $searchToolsOptions : administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_fields/tmpl/groups/default.php
  • $section : administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_scheduler/tmpl/tasks/default.php
  • $selectAttr : modulespositionedit.php
  • $selected : sort.php , edit_container.php , com_modules/tmpl/module/edit_assignment.php
  • $selector : starttabset.php
  • $selectorFieldName : components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php
  • $self : administrator/components/com_users/tmpl/users/default.php
  • $sendMailEnabled : mod_privacy_status.php
  • $separator : com_redirect/tmpl/links/default_batch_body.php , traces.html.php
  • $serverinfo : mod_stats_admin.php , mod_stats.php
  • $settings : administrator/components/com_users/tmpl/user/edit.php
  • $short_description : administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php
  • $show_advanced : modules/mod_finder/tmpl/default.php
  • $show_contact_category : components/com_contact/tmpl/contact/default.php
  • $show_description : default_result.php
  • $show_last : modules/mod_breadcrumbs/tmpl/default.php
  • $show_url : default_result.php
  • $showAll : modules/mod_menu/mod_menu.php
  • $showArticleOptions : administrator/components/com_content/tmpl/article/edit.php
  • $showDate : mod_related_items.php
  • $showFilterButton : administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php
  • $showImage : default_result.php
  • $showLabel : modules/mod_finder/tmpl/default.php , com_contact/layouts/field/render.php , com_fields/layouts/field/render.php
  • $showLimitBox : links.php
  • $showLimitStart : links.php
  • $shownMethods : components/com_users/tmpl/captive/select.php , administrator/components/com_users/tmpl/captive/select.php
  • $shownumber : mod_users_latest.php
  • $showPagesLinks : links.php
  • $showSelector : administrator/components/com_menus/layouts/joomla/searchtools/default.php , components/com_menus/layouts/joomla/searchtools/default.php , layouts/joomla/searchtools/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php
  • $sidebarState : administrator/templates/atum/index.php
  • $siteinfo : mod_stats_admin.php , mod_stats.php
  • $sitelangs : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • $sitename : templates/cassiopeia/error.php , cassiopeia/offline.php , templates/cassiopeia/index.php , mod_frontend.php
  • $size : slider.php
  • $sort : sort.php
  • $sql : tmpl/sql.php
  • $sronly : administrator/modules/mod_submenu/tmpl/default.php
  • $star : rating.php
  • $stars : rating.php
  • $start : dropdown-metismenu.php
  • $startDate : administrator/components/com_finder/tmpl/index/default.php
  • $startLevel : mod_articles_categories.php
  • $startMem : administrator/includes/app.php , api/includes/app.php , includes/app.php
  • $startTime : includes/app.php , api/includes/app.php , administrator/includes/app.php
  • $state : default_message.php
  • $stateIcons : administrator/components/com_privacy/tmpl/consents/default.php
  • $stateMsgs : administrator/components/com_privacy/tmpl/consents/default.php
  • $step : links.php
  • $stickyHeader : templates/cassiopeia/index.php
  • $strings : layouts/joomla/form/field/calendar.php
  • $style : form/field/radio/buttons.php
  • $sub_id : administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_mails/tmpl/templates/default.php
  • $subject : administrator/components/com_users/tmpl/notes/default.php
  • $sublayout : repeatable.php
  • $suffix : com_fields/layouts/field/render.php
  • $tabindex : icon/iconclass.php
  • $table_head : repeatable-table.php
  • $tabName : params.php
  • $tabs : administrator/components/com_installer/tmpl/install/default.php
  • $tagName : basic.php , standard.php , popup.php
  • $tagsData : category_default.php
  • $target : layouts/joomla/quickicons/icon.php , mod_wrapper.php , toolbar/link.php , com_content/tmpl/article/default_links.php , frontediting_modules.php , links/link.php
  • $task : templates/cassiopeia/error.php , login.php , administrator/templates/atum/index.php , templates/cassiopeia/index.php , error_login.php , error_full.php , transition-button.php
  • $taskAttr : standard.php , basic.php
  • $taskPrefix : action-button.php
  • $taxonomies : default_result.php
  • $temp : modules/mod_articles_categories/tmpl/default_items.php
  • $template : fatal.php , administrator/components/com_config/tmpl/component/default.php
  • $templatePath : templates/cassiopeia/error.php , cassiopeia/offline.php
  • $text : administrator/components/com_users/tmpl/debuguser/default.php , administrator/modules/mod_feed/tmpl/default.php , user/terms/label.php , administrator/components/com_users/tmpl/debuggroup/default.php , system/privacyconsent/label.php , mod_syndicate.php , layouts/joomla/quickicons/icon.php , cancelselect.php , links/link.php
  • $textClass : modules/mod_syndicate/tmpl/default.php
  • $textPrefix : layouts/joomla/content/emptystate.php , emptystate_module.php
  • $texts : tmpl/radio.php , tmpl/sql.php , plugins/fields/list/tmpl/list.php , tmpl/usergrouplist.php , plugins/fields/checkboxes/tmpl/checkboxes.php , plugins/fields/user/tmpl/user.php
  • $textSuffix : emptystate_module.php
  • $this : administrator/components/com_modules/tmpl/module/edit.php
  • $tipContent : transition-button.php
  • $tipTitle : action-button.php , transition-button.php
  • $title : administrator/components/com_finder/tmpl/maps/default.php , delete.php , emptystate_module.php , upload.php , default_heading.php , basic.php , navigation.php , button.php , modules/mod_articles_category/tmpl/default_items.php , addtab.php , layouts/joomla/editors/buttons/modal.php , administrator/components/com_redirect/layouts/toolbar/batch.php , layouts/joomla/quickicons/icon.php , links/link.php , category.php , title_alias.php , layouts/joomla/content/emptystate.php , layouts/joomla/toolbar/batch.php , create-folder.php , parent_category.php , icon/iconclass.php , administrator/modules/mod_submenu/tmpl/default.php , default_separator.php
  • $tmp : default_custom.php
  • $tmpl : administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php
  • $toolbar : mod_toolbar.php
  • $tooltip : edit_lock.php , layouts/joomla/content/icons/edit.php
  • $total : default_results.php
  • $totalRequests : administrator/modules/mod_privacy_dashboard/tmpl/default.php
  • $tparams : components/com_contact/tmpl/contact/default.php
  • $transition_ids : administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_content/tmpl/articles/default.php
  • $transitions : transition-button.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_content/tmpl/articles/default.php
  • $type : modules/mod_login/mod_login.php
  • $updatePossible : preupdatecheck.php
  • $uploadLink : reinstall.php , update.php , noupdate.php
  • $urgentRequestDate : administrator/components/com_privacy/tmpl/requests/default.php
  • $urgentRequestDays : mod_privacy_status.php
  • $uri : tmpl/vote.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/modules/mod_feed/tmpl/default.php , layouts/joomla/form/field/user.php , administrator/modules/mod_user/tmpl/default.php
  • $url : layouts/joomla/form/field/media.php , administrator/templates/atum/html/layouts/chromes/body.php , well.php , mod_wrapper.php
  • $urls : com_content/tmpl/article/default_links.php
  • $useDefList : components/com_content/tmpl/archive/default_items.php , blog_item.php , components/com_content/tmpl/article/default.php , default_item.php
  • $uselessMenuItem : com_modules/tmpl/module/edit_assignment.php
  • $user : administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_banners/tmpl/banners/emptystate.php , blog_children.php , administrator/components/com_contact/tmpl/contacts/default.php , well.php , administrator/components/com_categories/tmpl/categories/default.php , modules/mod_login/mod_login.php , com_content/tmpl/articles/default_batch_body.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_content/tmpl/articles/emptystate.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_installer/tmpl/update/emptystate.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , components/com_config/tmpl/templates/default.php , mod_user.php , components/com_content/tmpl/article/default.php , administrator/components/com_redirect/tmpl/links/emptystate.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , com_content/tmpl/category/default_children.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_fields/tmpl/fields/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_banners/tmpl/clients/default.php , default_result.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_menus/tmpl/items/default.php , administrator/templates/atum/error.php , administrator/templates/atum/html/layouts/chromes/body.php
  • $userAuthoriseCoreEditState : administrator/components/com_finder/tmpl/filters/default.php
  • $userAuthoriseCoreManage : administrator/components/com_finder/tmpl/filters/default.php
  • $userFieldGroups : default_user_custom_fields.php
  • $userId : administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_content/tmpl/featured/default.php , components/com_users/tmpl/method/edit.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_users/tmpl/method/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_content/tmpl/articles/default.php , components/com_contact/tmpl/category/default_items.php
  • $userRequired : administrator/components/com_users/tmpl/users/modal.php
  • $usersConfig : default_login.php
  • $UTF8_ar : utf8.php
  • $UTF8_BAD : patterns.php
  • $UTF8_MATCH : patterns.php
  • $UTF8_VALID : patterns.php
  • $val : combo.php
  • $valBar1 : tinymcebuilder.php
  • $valBar2 : tinymcebuilder.php
  • $validate : slider.php , basic.php , standard.php , advanced.php
  • $valMenu : tinymcebuilder.php
  • $value : com_fields/layouts/field/render.php , tmpl/imagelist.php , tmpl/sql.php , tmpl/radio.php , plugins/fields/calendar/tmpl/calendar.php , tmpl/color.php , com_contact/layouts/field/render.php , layouts/joomla/form/field/checkboxes.php , range.php , tmpl/usergrouplist.php , plugins/fields/user/tmpl/user.php , plugins/fields/text/tmpl/text.php , plugins/fields/url/tmpl/url.php , tmpl/editor.php , number.php , plugins/fields/textarea/tmpl/textarea.php , tmpl/integer.php , meter.php
  • $valueClass : com_fields/layouts/field/render.php
  • $vendorDir : autoload_classmap.php , libraries/vendor/composer/autoload_psr4.php , autoload_files.php , autoload_namespaces.php
  • $version : administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_installer/tmpl/languages/default.php , installation/tmpl/remove/default.php , mod_version.php
  • $version1 : compare.php
  • $version2 : compare.php
  • $versionFields : layouts/stats.php
  • $view : error_full.php , templates/cassiopeia/index.php , login.php , modules/mod_articles_categories/tmpl/default_items.php , templates/cassiopeia/error.php , administrator/templates/atum/index.php , error_login.php
  • $wa : administrator/components/com_users/tmpl/notes/default.php , modules/mod_finder/tmpl/default.php , preupdatecheck.php , administrator/components/com_admin/tmpl/help/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_associations/tmpl/association/edit.php , administrator/components/com_banners/tmpl/banner/edit.php , administrator/components/com_banners/tmpl/banners/default.php , components/com_content/tmpl/categories/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_media/tmpl/media/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_content/tmpl/featured/default.php , options_default.php , error_full.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_languages/tmpl/override/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , templates/cassiopeia/component.php , administrator/components/com_languages/tmpl/installed/default.php , components/com_config/tmpl/templates/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_users/tmpl/group/edit.php , styles.php , item.php , edit/associations.php , list_items.php , versions.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_templates/tmpl/template/default.php , login.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_privacy/tmpl/request/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_menus/tmpl/menu/edit.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_tags/tmpl/tag/edit.php , rating.php , administrator/components/com_installer/tmpl/updatesite/edit.php , administrator/components/com_privacy/tmpl/request/default.php , data.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/templates/atum/component.php , administrator/components/com_users/tmpl/users/modal.php , captive.php , components/com_newsfeeds/tmpl/categories/default.php , administrator/modules/mod_menu/tmpl/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/mail/default.php , administrator/components/com_users/tmpl/users/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_config/tmpl/component/default.php , administrator/modules/mod_quickicon/tmpl/default.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_redirect/tmpl/link/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_messages/tmpl/message/edit.php , templates/cassiopeia/index.php , components/com_tags/tmpl/tags/default_items.php , containeropen.php , administrator/components/com_modules/tmpl/module/edit.php , update.php , filters.php , tinymcebuilder.php , administrator/components/com_banners/tmpl/client/edit.php , administrator/components/com_categories/tmpl/category/edit.php , components/com_config/tmpl/modules/default.php , edit_container.php , com_users/tmpl/users/default_batch_body.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/modules/mod_login/tmpl/default.php , finaliseconfirm.php , cassiopeia/offline.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_modules/tmpl/module/modal.php , administrator/components/com_menus/tmpl/items/default.php , modules/mod_wrapper/tmpl/default.php , components/com_config/tmpl/config/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_content/tmpl/article/pagebreak.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/components/com_content/tmpl/article/edit.php , error_login.php , administrator/components/com_finder/tmpl/searches/default.php , components/com_contact/tmpl/category/default_items.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/templates/atum/index.php , administrator/components/com_finder/tmpl/index/default.php , components/com_contact/tmpl/categories/default.php , compare.php , password.php , horizontal.php , tmpl/item/edit_modules.php , administrator/components/com_scheduler/tmpl/task/edit.php , com_content/tmpl/category/default_articles.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_installer/tmpl/manage/default.php , default_stage_footer.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , reinstall.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_joomlaupdate/tmpl/update/default.php , webcron_link.php , modules/mod_languages/tmpl/default.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , components/com_users/tmpl/profile/edit.php , components/com_contact/tmpl/featured/default_items.php , administrator/components/com_finder/tmpl/indexer/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_users/tmpl/note/edit.php , system/offline.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_config/tmpl/application/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_modules/tmpl/modules/default.php , layouts/joomla/tinymce/textarea.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_languages/tmpl/language/edit.php , administrator/components/com_banners/tmpl/download/default.php , slider.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_messages/tmpl/config/default.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_categories/tmpl/categories/default.php , advanced.php , dropdown-metismenu.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_users/tmpl/groups/default.php , templates/cassiopeia/error.php , administrator/components/com_users/tmpl/user/edit.php , vertical.php , administrator/components/com_mails/tmpl/template/edit.php , modules/mod_menu/tmpl/default.php , com_content/tmpl/articles/default_batch_footer.php , administrator/components/com_users/tmpl/level/edit.php
  • $wam : layouts/joomla/form/field/media.php
  • $width : mod_wrapper.php , modules/mod_banners/tmpl/default.php
  • $workflow_enabled : administrator/components/com_content/tmpl/articles/default.php , mod_latest.php , administrator/components/com_content/tmpl/featured/default.php
  • $workflow_featured : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $workflow_state : administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/featured/default.php
  • $wrapper : templates/cassiopeia/index.php , templates/cassiopeia/error.php
  • $xml : administrator/components/com_config/tmpl/component/default.php , params.php


Joomla CMS: Variables globale

- ( -

  • (!empty($this->nonCoreExtensions)) : preupdatecheck.php
  • ($canManageItems) : administrator/components/com_menus/tmpl/menus/default.php
  • ($data['group']==0) : preupdatecheck.php
  • ($is_child) : separator.php
  • ($item->level > 1) : administrator/components/com_finder/tmpl/maps/default.php
  • ($items) : administrator/modules/mod_sampledata/tmpl/default.php
  • ($list as $language) : modules/mod_languages/tmpl/default.php
  • ($list) : layouts/joomla/searchtools/default/list.php
  • ($menuTypes as &$type) : com_modules/tmpl/module/edit_assignment.php
  • ($method['canDisable'] && $canDelete) : administrator/components/com_users/tmpl/methods/list.php , components/com_users/tmpl/methods/list.php
  • ($mfa) : administrator/components/com_users/tmpl/users/default.php
  • ($params->get('menu_show', 1)) : administrator/modules/mod_submenu/tmpl/default.php
  • ($row->next) : plugins/content/pagenavigation/tmpl/default.php
  • ($row->prev) : plugins/content/pagenavigation/tmpl/default.php
  • ($sitelangs as $sitelang) : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • ($this->contentlangs as $contentlang) : administrator/components/com_languages/tmpl/multilangstatus/default.php
  • ($this->options as $option) : installation/tmpl/preinstall/default.php
  • ($this->params->get('show_advanced', 1)) : com_finder/tmpl/search/default_form.php
  • ($this->phpsettings as $setting) : installation/tmpl/remove/default.php
  • ($users as $user) : administrator/modules/mod_logged/tmpl/default.php
  • (array_keys($toolbarPreset) as $presetName) : tinymcebuilder.php
  • (count($list)) : administrator/modules/mod_latestactions/tmpl/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_archived')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_published')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_trashed')) : administrator/components/com_categories/tmpl/categories/default.php
  • (isset($this->items[0]) &&property_exists($this->items[0], 'count_unpublished')) : administrator/components/com_categories/tmpl/categories/default.php


Joomla CMS: Variables globale

- _ -

  • __DIR__ : bootstrap.php
  • __pad0__ : administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_content/tmpl/articles/default.php , tmpl/item/edit_modules.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , components/com_config/tmpl/config/default.php , compare.php , administrator/components/com_modules/tmpl/module/edit.php , components/com_contact/tmpl/category/default_items.php , components/com_content/tmpl/archive/default_items.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , components/com_finder/tmpl/search/default.php , components/com_newsfeeds/tmpl/category/default_items.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , components/com_privacy/tmpl/request/default.php , components/com_tags/tmpl/tag/default_items.php , administrator/components/com_privacy/tmpl/capabilities/default.php , components/com_users/tmpl/login/default_logout.php , components/com_wrapper/tmpl/wrapper/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_redirect/tmpl/links/default.php , installation/tmpl/remove/default.php , blog_style_default_item_title.php , administrator/components/com_scheduler/tmpl/task/edit.php , modules/mod_articles_category/tmpl/default.php , _item.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_installer/tmpl/database/default.php , administrator/components/com_tags/tmpl/tags/default.php , modules/mod_banners/tmpl/default.php , modules/mod_breadcrumbs/tmpl/default.php , administrator/components/com_templates/tmpl/styles/default.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default.php , preupdatecheck.php , administrator/components/com_users/tmpl/debuggroup/default.php , cloud.php , modules/mod_tags_similar/tmpl/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/modules/mod_feed/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/components/com_mails/tmpl/templates/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php
  • __pad10__ : administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/notes/modal.php , default_profile.php , com_content/tmpl/category/default_articles.php , pagination/link.php
  • __pad11__ : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/notes/modal.php , components/com_contact/tmpl/featured/default_items.php , default_item.php , submenu.php , administrator/components/com_installer/tmpl/warnings/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php
  • __pad12__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , components/com_contact/tmpl/form/edit.php , default_item.php , dropdown.php
  • __pad13__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , components/com_content/tmpl/form/edit.php , separator.php
  • __pad14__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php , standard.php
  • __pad15__ : administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_users/tmpl/users/default.php
  • __pad16__ : administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/default.php
  • __pad17__ : administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/default.php
  • __pad18__ : administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_users/tmpl/users/modal.php
  • __pad19__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad1__ : installation/tmpl/remove/default.php , categories_default.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_banners/tmpl/default.php , modules/mod_breadcrumbs/tmpl/default.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default.php , modules/mod_tags_popular/tmpl/default.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_mails/tmpl/templates/default.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_privacy/tmpl/capabilities/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , components/com_config/tmpl/templates/default.php , components/com_contact/tmpl/contact/default.php , components/com_content/tmpl/archive/default_items.php , default_result.php , components/com_tags/tmpl/tag/default_items.php , default_core.php , components/com_wrapper/tmpl/wrapper/default.php
  • __pad20__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad21__ : administrator/components/com_menus/tmpl/menus/default.php
  • __pad2__ : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_finder/tmpl/index/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_languages/tmpl/languages/default.php , tmpl/item/edit_modules.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , blog_item.php , default_result.php , list_items.php , default_custom.php , create.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_languages/tmpl/default.php , modules/mod_login/tmpl/default_logout.php , default_address.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , preview.php
  • __pad3__ : administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_content/tmpl/articles/default.php , content/info_block/associations.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_banners/tmpl/clients/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/languages/default.php , default_address.php , default_params.php , com_content/tmpl/category/default_articles.php , list_items.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_privacy/tmpl/request/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , modules/mod_languages/tmpl/default.php
  • __pad4__ : administrator/components/com_banners/tmpl/clients/default.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/manage/default.php , default_address.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , com_content/tmpl/category/default_articles.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , modules/mod_languages/tmpl/default.php , author.php
  • __pad5__ : administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_banners/tmpl/tracks/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_templates/tmpl/styles/default.php , default_address.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_modules/tmpl/modules/default.php , intro_image.php , administrator/components/com_languages/tmpl/languages/default.php , com_content/tmpl/category/default_articles.php
  • __pad6__ : administrator/components/com_languages/tmpl/multilangstatus/default.php , default_address.php , com_content/tmpl/category/default_articles.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/manage/default.php , options_default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_menus/tmpl/items/default.php , default_updated_files.php
  • __pad7__ : default_address.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_installer/tmpl/update/default.php , com_content/tmpl/category/default_articles.php , layouts/joomla/content/readmore.php , default_updated_files.php , administrator/components/com_menus/tmpl/items/default.php
  • __pad8__ : administrator/components/com_content/tmpl/featured/default.php , password.php , administrator/components/com_installer/tmpl/update/default.php , com_content/tmpl/category/default_articles.php , default_profile.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_users/tmpl/notes/default.php
  • __pad9__ : default_profile.php , item.php , com_menus/tmpl/items/default_batch_body.php , com_content/tmpl/category/default_articles.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_users/tmpl/notes/default.php
  • _JEXEC : api/index.php , installation/index.php , index.php , cli/joomla.php , administrator/index.php
  • _JOOMLA_UPDATE : extract.php


Joomla CMS: Variables globale

- b -

  • baseUrl : default_results.php
  • block : administrator/components/com_users/tmpl/users/default.php
  • break : preupdatecheck.php , default_profile.php


Joomla CMS: Variables globale

- c -

  • cachemode : mod_articles_categories.php , mod_articles_category.php , mod_tags_popular.php , mod_tags_similar.php , mod_related_items.php
  • cat_link : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_contact/tmpl/contacts/default.php
  • category : com_contact/tmpl/category/default_children.php , blog_children.php , com_content/tmpl/category/default_children.php , com_newsfeeds/tmpl/category/default_children.php
  • children : blog_children.php , com_content/tmpl/category/default_children.php
  • class : dropdown.php
  • code : administrator/components/com_installer/tmpl/languages/default.php , installation/tmpl/remove/default.php
  • color : administrator/templates/atum/component.php
  • configFieldsets : administrator/components/com_content/tmpl/article/edit.php
  • content : administrator/modules/mod_custom/mod_custom.php
  • continue : administrator/components/com_scheduler/tmpl/task/edit.php
  • counter : default_results.php


Joomla CMS: Variables globale

- d -

  • description : default_permissions.php , components/com_content/tmpl/category/blog.php , category_default.php , categories_default.php
  • DO_PEDANTIC_TEST : autoload-pedantic.php


Joomla CMS: Variables globale

- e -

  • else : categoryedit.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , edit_container.php , default_tree.php , com_contact/layouts/fields/render.php , modules/mod_finder/tmpl/default.php , mod_footer.php , components/com_contact/tmpl/category/default_items.php , cloud.php , mod_whosonline.php , default_tree_media.php , components/com_contact/tmpl/featured/default_items.php , tmpl/integer.php , plugins/fields/url/tmpl/url.php , blog_children.php , templates/cassiopeia/error.php , dropdown-metismenu_heading.php , tmpl/item/edit_modules.php , administrator/components/com_users/tmpl/debuguser/default.php , com_content/tmpl/category/default_articles.php , dropdown-metismenu_separator.php , templates/cassiopeia/index.php , com_content/tmpl/category/default_children.php , cassiopeia/offline.php , administrator/components/com_workflow/tmpl/stages/default.php , com_fields/layouts/fields/render.php , components/com_newsfeeds/tmpl/newsfeed/default.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , list_items.php , components/com_users/tmpl/login/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , includes/framework.php , layouts/joomla/content/language.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/includes/framework.php , fieldset.php , layouts/joomla/editors/buttons/modal.php , administrator/modules/mod_feed/tmpl/default.php , advanced.php , groupedlist-fancy-select.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_finder/tmpl/maps/default.php , com_modules/tmpl/module/edit_assignment.php , mod_latest.php , groupedlist.php , list-fancy-select.php , mod_logged.php , layouts/joomla/form/field/list.php , number.php , administrator/components/com_modules/tmpl/modules/default.php , default_submenu.php , rules.php , repeatable-table.php , mod_privacy_dashboard.php , form/field/tag.php , renderfield.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_plugins/tmpl/plugin/edit.php , mod_submenu.php , pagination/link.php , layouts/joomla/quickicons/icon.php , administrator/modules/mod_submenu/tmpl/default.php , submenu.php , system/privacyconsent/label.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/templates/atum/error.php , user/terms/label.php , paragonie/sodium_compat/autoload.php , api/includes/framework.php , modules/mod_banners/tmpl/default.php , modules/mod_feed/tmpl/default.php
  • elseif : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_content/tmpl/articles/default.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , layouts/joomla/content/readmore.php , standard.php , paragonie/sodium_compat/autoload.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_banners/tmpl/default.php , default_component.php , default_heading.php , default_separator.php , default_url.php , dropdown-metismenu_component.php , dropdown-metismenu_url.php
  • eName : administrator/components/com_content/tmpl/article/pagebreak.php
  • endfor : administrator/components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/method/backupcodes.php , vertical.php
  • endforeach : administrator/components/com_content/tmpl/articles/default.php , text_filters.php , metadata.php , administrator/components/com_content/tmpl/articles/modal.php , editors/buttons.php , layouts/joomla/form/field/checkboxes.php , administrator/components/com_content/tmpl/featured/default.php , simple.php , accessiblemedia.php , compare.php , form/field/radio/buttons.php , switcher.php , administrator/components/com_contenthistory/tmpl/history/modal.php , rules.php , layouts/joomla/form/field/subform/default.php , preview.php , section-byfieldsets.php , section.php , administrator/components/com_fields/tmpl/field/edit.php , table/section-byfieldsets.php , table/section.php , administrator/components/com_fields/tmpl/fields/modal.php , repeatable.php , layouts/joomla/form/field/text.php , administrator/components/com_fields/tmpl/groups/default.php , links.php , layouts/joomla/pagination/list.php , administrator/components/com_finder/tmpl/filters/default.php , filters.php , layouts/joomla/searchtools/default/list.php , administrator/components/com_finder/tmpl/index/default.php , submenu.php , setoptions.php , administrator/components/com_finder/tmpl/maps/default.php , tinymcebuilder.php , modules/mod_articles_archive/tmpl/default.php , administrator/components/com_finder/tmpl/searches/default.php , modules/mod_articles_categories/tmpl/default_items.php , modules/mod_articles_category/tmpl/default.php , administrator/components/com_finder/tmpl/statistics/default.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_articles_latest/tmpl/default.php , administrator/components/com_installer/tmpl/database/default.php , modules/mod_articles_news/tmpl/default.php , horizontal.php , administrator/components/com_installer/tmpl/discover/default.php , modules/mod_articles_popular/tmpl/default.php , modules/mod_banners/tmpl/default.php , administrator/components/com_installer/tmpl/install/default.php , modules/mod_breadcrumbs/tmpl/default.php , modules/mod_languages/tmpl/default.php , administrator/components/com_installer/tmpl/languages/default.php , modules/mod_related_items/tmpl/default.php , modules/mod_stats/tmpl/default.php , administrator/components/com_installer/tmpl/manage/default.php , cloud.php , modules/mod_tags_popular/tmpl/default.php , administrator/components/com_installer/tmpl/update/default.php , modules/mod_tags_similar/tmpl/default.php , modules/mod_users_latest/tmpl/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , modules/mod_whosonline/tmpl/default.php , toc.php , administrator/components/com_installer/tmpl/warnings/default.php , layouts/stats.php , preupdatecheck.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_languages/tmpl/installed/default.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_mails/tmpl/templates/default.php , edit_container.php , tmpl/item/edit_modules.php , administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_menus/tmpl/menutypes/default.php , administrator/components/com_messages/tmpl/messages/default.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_modules/tmpl/modules/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_modules/tmpl/select/default.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_postinstall/tmpl/messages/default.php , administrator/components/com_privacy/tmpl/capabilities/default.php , administrator/components/com_privacy/tmpl/consents/default.php , administrator/components/com_privacy/tmpl/request/default.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_scheduler/tmpl/select/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_tags/tmpl/tags/default.php , com_templates/tmpl/style/edit_assignment.php , administrator/components/com_templates/tmpl/styles/default.php , default_folders.php , default_media_folders.php , default_tree.php , default_tree_media.php , default_updated_files.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/debuguser/default.php , administrator/components/com_users/tmpl/groups/default.php , administrator/components/com_users/tmpl/levels/default.php , administrator/components/com_users/tmpl/methods/list.php , administrator/components/com_users/tmpl/notes/default.php , administrator/components/com_users/tmpl/notes/modal.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , administrator/modules/mod_sampledata/tmpl/default.php , administrator/modules/mod_submenu/tmpl/default.php , components/com_config/tmpl/config/default_metadata.php , components/com_config/tmpl/config/default_seo.php , components/com_config/tmpl/config/default_site.php , modules/default_options.php , components/com_contact/tmpl/categories/default_items.php , com_contact/tmpl/category/default_children.php , components/com_contact/tmpl/category/default_items.php , com_contact/tmpl/contact/default_articles.php , com_contact/tmpl/contact/default_form.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , com_contact/tmpl/contact/default_links.php , default_profile.php , administrator/components/com_admin/tmpl/help/default.php , default_user_custom_fields.php , components/com_contact/tmpl/featured/default_items.php , default_config.php , com_content/tmpl/article/default_links.php , components/com_content/tmpl/categories/default_items.php , default_directory.php , components/com_content/tmpl/category/blog.php , blog_children.php , administrator/components/com_associations/tmpl/associations/default.php , blog_links.php , com_content/tmpl/category/default_articles.php , administrator/components/com_associations/tmpl/associations/modal.php , com_content/tmpl/category/default_children.php , components/com_content/tmpl/featured/default.php , administrator/components/com_banners/tmpl/banners/default.php , com_content/tmpl/featured/default_links.php , default_result.php , administrator/components/com_banners/tmpl/clients/default.php , default_results.php , components/com_newsfeeds/tmpl/categories/default_items.php , administrator/components/com_banners/tmpl/download/default.php , com_newsfeeds/tmpl/category/default_children.php , components/com_privacy/tmpl/confirm/default.php , administrator/components/com_banners/tmpl/tracks/default.php , components/com_privacy/tmpl/remind/default.php , components/com_privacy/tmpl/request/default.php , administrator/components/com_cache/tmpl/cache/default.php , components/com_tags/tmpl/tag/default_items.php , list_items.php , administrator/components/com_categories/tmpl/categories/default.php , components/com_tags/tmpl/tags/default_items.php , components/com_users/tmpl/methods/list.php , administrator/components/com_categories/tmpl/categories/modal.php , default_custom.php , default_params.php , administrator/components/com_checkin/tmpl/checkin/default.php , components/com_users/tmpl/profile/edit.php , components/com_users/tmpl/registration/default.php , application/default_navigation.php , components/com_users/tmpl/remind/default.php , components/com_users/tmpl/reset/complete.php , component/default_navigation.php , confirm.php , components/com_users/tmpl/reset/default.php , administrator/components/com_contact/tmpl/contacts/default.php , installation/tmpl/preinstall/default.php , installation/tmpl/remove/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , content/associations.php , content/info_block/associations.php , administrator/components/com_content/tmpl/article/edit.php , options_default.php , layouts/joomla/content/tags.php
  • endif : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_associations/tmpl/associations/default.php , administrator/components/com_associations/layouts/joomla/searchtools/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/modules/mod_privacy_dashboard/tmpl/default.php , rating.php , administrator/components/com_postinstall/tmpl/messages/default.php , administrator/modules/mod_title/tmpl/default.php , administrator/templates/atum/html/layouts/chromes/body.php , administrator/templates/system/error.php , templates/cassiopeia/error.php , modules/default_options.php , content/info_block/associations.php , data.php , card.php , components/com_contact/tmpl/contact/default.php , default_address.php , com_contact/tmpl/contact/default_form.php , templates/system/error.php , default_user_custom_fields.php , components/com_contact/tmpl/featured/default.php , cassiopeia/offline.php , system/offline.php , components/com_content/tmpl/article/default.php , com_content/tmpl/article/default_links.php , components/com_content/tmpl/category/blog.php , layouts/joomla/searchtools/default/list.php , com_content/tmpl/category/default_articles.php , com_content/tmpl/category/default_children.php , item.php , layouts/joomla/form/field/user.php , components/com_finder/tmpl/search/default.php , com_finder/tmpl/search/default_form.php , administrator/components/com_users/tmpl/user/edit.php , form/field/radio/buttons.php , components/com_newsfeeds/tmpl/category/default.php , com_newsfeeds/tmpl/category/default_children.php , layouts/joomla/content/readmore.php , components/com_config/tmpl/templates/default.php , components/com_tags/tmpl/tag/default.php , components/com_tags/tmpl/tag/default_items.php , list_items.php , categories_default.php , icons.php , noCard.php , components/com_content/tmpl/featured/default.php , components/com_privacy/tmpl/confirm/default.php , administrator/components/com_categories/tmpl/categories/modal.php , administrator/components/com_categories/tmpl/category/edit.php , application/default_navigation.php , metadata.php , administrator/components/com_contact/tmpl/contacts/default.php , com_contact/tmpl/contacts/default_batch_body.php , layouts/joomla/content/tags.php , button.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_contenthistory/tmpl/history/modal.php , password.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_fields/tmpl/fields/default.php , editors/buttons.php , components/com_menus/layouts/joomla/searchtools/default.php , com_fields/tmpl/groups/default_batch_body.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_finder/tmpl/index/default.php , section.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_installer/tmpl/database/default.php , section-byfieldsets.php , table/section-byfieldsets.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_installer/tmpl/warnings/default.php , components/com_tags/tmpl/tags/default.php , installation/template/error.php , options_default.php , table/section.php , layouts/joomla/form/field/text.php , administrator/components/com_languages/tmpl/multilangstatus/default.php , administrator/components/com_languages/tmpl/override/edit.php , administrator/components/com_mails/tmpl/template/edit.php , pagination/link.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/modules/mod_popular/tmpl/default.php , links.php , com_menus/tmpl/items/default_batch_body.php , components/com_users/tmpl/profile/default.php , components/com_users/tmpl/methods/list.php , installation/tmpl/preinstall/default.php , default_login.php , installation/tmpl/remove/default.php , renderfield.php , filters.php , administrator/components/com_modules/tmpl/modules/default.php , components/com_users/tmpl/remind/default.php , default_params.php , sort.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , components/com_privacy/tmpl/remind/default.php , components/com_users/tmpl/registration/complete.php , submenu.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_redirect/tmpl/links/emptystate.php , components/com_tags/tmpl/tag/list.php , default_core.php , basic.php , administrator/components/com_plugins/tmpl/plugins/default.php , separator.php , administrator/components/com_redirect/tmpl/links/default.php , administrator/components/com_modules/tmpl/select/default.php , components/com_wrapper/tmpl/wrapper/default.php , com_modules/tmpl/module/edit_assignment.php , administrator/components/com_tags/tmpl/tags/default.php , administrator/components/com_menus/tmpl/menu/edit.php , com_menus/tmpl/items/default_batch_footer.php , _item.php , administrator/components/com_templates/tmpl/styles/default.php , table.php , html5.php , modules/mod_breadcrumbs/tmpl/default.php , confirm.php , modules/mod_banners/tmpl/default.php , modules/mod_articles_categories/tmpl/default_items.php , reinstall.php , administrator/components/com_templates/tmpl/templates/default.php , administrator/components/com_installer/tmpl/updatesites/default.php , blog_style_default_item_title.php , modules/mod_login/tmpl/default_logout.php , administrator/components/com_users/tmpl/groups/default.php , modules/mod_login/tmpl/default.php , category_default.php , modules/mod_random_image/tmpl/default.php , administrator/components/com_users/tmpl/methods/list.php , header.php , full_image.php , modules/mod_tags_popular/tmpl/default.php , transition-button.php , cloud.php , modules/mod_languages/tmpl/default.php , modules/mod_tags_similar/tmpl/default.php , administrator/components/com_workflow/tmpl/transition/edit.php , standard.php , info_block.php , toc.php , administrator/modules/mod_feed/tmpl/default.php , navigation.php , modules/mod_users_latest/tmpl/default.php , plugins/content/pagenavigation/tmpl/default.php , administrator/modules/mod_login/tmpl/default.php , tmpl/subform.php , administrator/modules/mod_post_installation_messages/tmpl/default.php , plugins/multifactorauth/webauthn/tmpl/default.php , administrator/modules/mod_submenu/tmpl/default.php , well.php , components/com_config/tmpl/modules/default.php , modules/mod_whosonline/tmpl/default.php , components/com_contact/tmpl/category/default_items.php , com_contact/tmpl/contact/default_articles.php , default_profile.php , components/com_contact/tmpl/featured/default_items.php , components/com_content/tmpl/archive/default_items.php , components/com_content/tmpl/categories/default_items.php , blog_item.php , templates/cassiopeia/index.php , com_fields/layouts/field/render.php , default_result.php , components/com_privacy/tmpl/request/default.php , default_item.php , components/com_newsfeeds/tmpl/newsfeed/default.php , intro_image.php , components/com_newsfeeds/tmpl/categories/default_items.php , components/com_content/tmpl/form/edit.php , com_categories/tmpl/categories/default_batch_body.php , administrator/components/com_checkin/tmpl/checkin/default.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_contact/tmpl/contacts/modal.php , com_content/tmpl/articles/default_batch_body.php , compare.php , administrator/components/com_cpanel/tmpl/cpanel/default.php , default_results.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_finder/tmpl/filters/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_installer/tmpl/discover/default.php , administrator/components/com_installer/tmpl/languages/default.php , repeatable.php , preupdatecheck.php , rules.php , administrator/components/com_languages/tmpl/languages/default.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_media/tmpl/file/default.php , components/com_users/tmpl/login/default_logout.php , administrator/components/com_menus/tmpl/items/default.php , bar.php , layouts/joomla/quickicons/icon.php , components/com_users/tmpl/methods/default.php , components/com_users/tmpl/profile/edit.php , com_modules/tmpl/modules/default_batch_body.php , layouts/joomla/searchtools/default.php , default_custom.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/modal.php , dropdown.php , components/com_users/tmpl/captive/default.php , components/com_users/tmpl/registration/default.php , administrator/components/com_redirect/tmpl/link/edit.php , modules/mod_articles_category/tmpl/default_items.php , modules/mod_articles_category/tmpl/default.php , components/com_users/tmpl/reset/default.php , com_templates/tmpl/style/edit_assignment.php , default_folders.php , default_modal_file_body.php , modules/mod_finder/tmpl/default.php , default_updated_files.php , administrator/components/com_users/tmpl/captive/default.php , administrator/components/com_users/tmpl/debuguser/default.php , content/associations.php , administrator/components/com_users/tmpl/methods/default.php , administrator/components/com_users/tmpl/notes/default.php , components/com_users/tmpl/reset/complete.php , layouts/joomla/content/emptystate.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/workflows/default.php , author.php , administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/modules/mod_sampledata/tmpl/default.php , components/com_config/tmpl/config/default.php , com_contact/tmpl/category/default_children.php , com_contact/tmpl/contact/default_links.php , com_contact/layouts/field/render.php , components/com_contact/tmpl/form/edit.php , blog_children.php , components/com_content/tmpl/archive/default.php , components/com_contact/tmpl/categories/default_items.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_categories/tmpl/categories/default.php , component/default_navigation.php , administrator/components/com_content/tmpl/articles/default.php , preview.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_finder/tmpl/index/emptystate.php , default_message.php , noupdate.php , administrator/components/com_languages/tmpl/language/edit.php , administrator/components/com_mails/tmpl/templates/default.php , tmpl/item/edit_modules.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_modules/tmpl/modules/modal.php , com_newsfeeds/tmpl/newsfeeds/default_batch_body.php , components/com_tags/tmpl/tags/default_items.php , administrator/components/com_privacy/tmpl/requests/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_templates/tmpl/style/edit.php , default_media_folders.php , default_tree_media.php , administrator/components/com_users/tmpl/debuggroup/default.php , administrator/components/com_users/tmpl/mail/default.php , administrator/components/com_users/tmpl/notes/modal.php , administrator/components/com_workflow/tmpl/stage/edit.php , administrator/components/com_workflow/tmpl/workflow/edit.php , administrator/modules/mod_latest/tmpl/default.php , administrator/modules/mod_quickicon/tmpl/default.php , administrator/modules/mod_latestactions/tmpl/default.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_privacy/tmpl/capabilities/default.php , default_modal_folder_body.php , administrator/components/com_cache/tmpl/cache/default.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_fields/tmpl/fields/modal.php , administrator/components/com_installer/tmpl/install/default.php , administrator/components/com_languages/tmpl/installed/default.php , edit_container.php , administrator/components/com_messages/tmpl/messages/default.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_privacy/tmpl/request/default.php , com_tags/tmpl/tags/default_batch_body.php , administrator/components/com_users/tmpl/levels/default.php , default_tree.php , administrator/components/com_privacy/tmpl/consents/default.php , com_banners/tmpl/banners/default_batch_body.php , update.php , administrator/components/com_menus/tmpl/menus/default.php , administrator/components/com_banners/tmpl/tracks/default.php , com_fields/tmpl/fields/default_batch_body.php , administrator/components/com_joomlaupdate/tmpl/upload/default.php , administrator/components/com_banners/tmpl/clients/default.php
  • endswitch : default_profile.php
  • endwhile : installation/template/error.php , templates/system/error.php , templates/cassiopeia/error.php , administrator/templates/system/error.php
  • ENT_COMPAT : components/com_newsfeeds/tmpl/category/default_items.php
  • ENT_QUOTES : administrator/modules/mod_logged/tmpl/default.php , administrator/modules/mod_popular/tmpl/default.php , administrator/modules/mod_latest/tmpl/default.php
  • extension : categories_default.php


Joomla CMS: Variables globale

- f -

  • false : com_menus/tmpl/items/default_batch_footer.php , administrator/components/com_users/tmpl/users/default.php , default_profile.php
  • fields : administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_templates/tmpl/style/edit.php , tmpl/item/edit_modules.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • fieldset : administrator/components/com_modules/tmpl/module/edit.php , edit_display.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_templates/tmpl/style/edit.php
  • fieldsets : administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_modules/tmpl/module/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php
  • fieldsname : administrator/components/com_config/tmpl/application/default_site.php , default_webservices.php , default_cache.php , default_cookie.php , default_database.php , default_debug.php , default_filters.php , default_locale.php , default_logging.php , default_logging_custom.php , default_mail.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_permissions.php , default_proxy.php , administrator/components/com_config/tmpl/application/default_seo.php , default_server.php , default_session.php
  • for : vertical.php , rating.php , tmpl/vote.php
  • foreach : installation/tmpl/remove/default.php , components/com_config/tmpl/config/default_site.php , submenu.php , tinymcebuilder.php , exception.html.php , administrator/components/com_users/tmpl/users/modal.php , administrator/components/com_templates/tmpl/templates/default.php , plugins/fields/user/tmpl/user.php , modules/mod_articles_latest/tmpl/default.php , administrator/components/com_modules/tmpl/modules/modal.php , modules/mod_stats/tmpl/default.php , combo.php , tmpl/usergrouplist.php , administrator/components/com_finder/tmpl/searches/default.php , administrator/components/com_finder/tmpl/maps/default.php , administrator/components/com_finder/tmpl/index/default.php , plugins/fields/checkboxes/tmpl/checkboxes.php , administrator/components/com_contenthistory/tmpl/history/modal.php , default_config.php , administrator/components/com_banners/tmpl/tracks/default.php , tmpl/sql.php , administrator/components/com_cache/tmpl/cache/default.php , tmpl/imagelist.php , administrator/components/com_checkin/tmpl/checkin/default.php , application/default_navigation.php , administrator/components/com_content/tmpl/article/edit.php , plugins/fields/list/tmpl/list.php , administrator/components/com_fields/tmpl/fields/modal.php , tmpl/radio.php , modules/mod_articles_archive/tmpl/default.php , components/com_content/tmpl/featured/default.php , components/com_config/tmpl/config/default_seo.php , modules/mod_articles_popular/tmpl/default.php , toc.php , default_updated_files.php , administrator/components/com_installer/tmpl/discover/default.php , preupdatecheck.php , administrator/components/com_languages/tmpl/overrides/default.php , administrator/components/com_privacy/tmpl/request/default.php , status.php , components/com_config/tmpl/config/default_metadata.php , components/com_content/tmpl/category/blog.php
  • formclass : default_database.php , default_proxy.php , default_filters.php , administrator/components/com_config/tmpl/application/default_site.php , default_permissions.php , default_webservices.php , default_logging_custom.php , default_debug.php , default_logging.php , default_cache.php , default_cookie.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_locale.php , administrator/components/com_config/tmpl/application/default_seo.php , default_server.php , default_mail.php , default_session.php


Joomla CMS: Variables globale

- h -

  • hiddenFieldsets : administrator/components/com_content/tmpl/article/edit.php
  • hits : com_content/tmpl/category/default_articles.php


Joomla CMS: Variables globale

- i -

  • id : administrator/components/com_associations/tmpl/associations/modal.php , administrator/components/com_users/tmpl/notes/modal.php
  • if : administrator/components/com_banners/tmpl/banners/default.php , administrator/components/com_categories/tmpl/categories/emptystate.php , administrator/components/com_content/tmpl/articles/modal.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_workflow/tmpl/workflows/default.php , bar.php , layouts/joomla/system/message.php , administrator/includes/app.php , basic.php , dropdown.php , edit_container.php , administrator/modules/mod_feed/tmpl/default.php , layouts/libraries/html/bootstrap/modal/body.php , iframe.php , administrator/modules/mod_latest/tmpl/default.php , main.php , administrator/components/com_content/tmpl/featured/default.php , administrator/components/com_menus/tmpl/items/default.php , mod_latestactions.php , manage.php , autoload.php , fatal.php , templates/cassiopeia/index.php , banner.php , templates/cassiopeia/error.php , plugins/fields/url/tmpl/url.php , plugins/fields/textarea/tmpl/textarea.php , plugins/fields/text/tmpl/text.php , plugins/fields/media/tmpl/media.php , tmpl/editor.php , tmpl/color.php , modules/mod_related_items/tmpl/default.php , modules/mod_menu/tmpl/default.php , modules/mod_login/tmpl/default.php , modules/mod_login/mod_login.php , modules/mod_languages/tmpl/default.php , modules/mod_custom/tmpl/default.php , modules/mod_custom/mod_custom.php , mod_breadcrumbs.php , modules/mod_banners/tmpl/default.php , _item.php , modules/mod_articles_category/tmpl/default_items.php , mod_articles_category.php , modules/mod_articles_categories/tmpl/default.php , traces_text.html.php , traces.html.php , trace.html.php , exception_full.html.php , mod_loginsupport.php , utf8.php , autoload-phpunit.php , administrator/components/com_menus/tmpl/items/modal.php , default_submenu.php , php72compat.php , administrator/modules/mod_popular/tmpl/default.php , administrator/components/com_config/tmpl/component/default.php , administrator/components/com_content/tmpl/featured/emptystate.php , administrator/components/com_messages/tmpl/messages/emptystate.php , administrator/modules/mod_privacy_status/tmpl/default.php , administrator/components/com_modules/tmpl/module/edit.php , layouts/joomla/quickicons/icon.php , links.php , pagination/link.php , icon/iconclass.php , layouts/joomla/html/image.php , layouts/joomla/html/batch/user.php , renderlabel.php , renderfield.php , layouts/joomla/form/field/user.php , layouts/joomla/form/field/url.php , rules.php , form/field/radio/buttons.php , password.php , layouts/joomla/form/field/calendar.php , layouts/joomla/content/readmore.php , options_default.php , content/info_block/associations.php , emptystate_module.php , layouts/joomla/content/emptystate.php , category_default.php , installation/tmpl/remove/default.php , installation/includes/framework.php , installation/includes/app.php , includes/app.php , default_custom.php , components/com_users/tmpl/method/backupcodes.php , components/com_users/tmpl/login/default_logout.php , default_login.php , components/com_tags/tmpl/tag/list.php , components/com_tags/tmpl/tag/default_items.php , components/com_tags/tmpl/tag/default.php , components/com_newsfeeds/tmpl/newsfeed/default.php , components/com_newsfeeds/tmpl/category/default.php , components/com_newsfeeds/tmpl/categories/default_items.php , components/com_menus/layouts/joomla/searchtools/default.php , default_result.php , com_finder/tmpl/search/default_form.php , com_fields/layouts/fields/render.php , com_fields/layouts/field/render.php , default_item.php , blog_item.php , components/com_content/tmpl/category/blog.php , components/com_content/tmpl/categories/default_items.php , components/com_content/tmpl/article/default.php , components/com_contact/tmpl/categories/default_items.php , com_contact/layouts/field/render.php , components/com_config/tmpl/modules/default.php , cli/joomla.php , api/includes/app.php , well.php , administrator/templates/atum/html/layouts/chromes/title.php , mod_title.php , administrator/templates/atum/html/layouts/chromes/body.php , administrator/components/com_fields/tmpl/fields/default.php , administrator/components/com_modules/tmpl/modules/default.php , header-item.php , administrator/components/com_modules/tmpl/modules/emptystate.php , administrator/components/com_banners/tmpl/banners/emptystate.php , component/default_navigation.php , administrator/components/com_fields/tmpl/groups/default.php , administrator/components/com_modules/tmpl/modules/modal.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/default.php , administrator/components/com_finder/tmpl/filters/emptystate.php , administrator/components/com_newsfeeds/tmpl/newsfeeds/emptystate.php , administrator/components/com_workflow/tmpl/transitions/default.php , administrator/components/com_workflow/tmpl/stages/default.php , administrator/components/com_users/tmpl/users/default.php , administrator/components/com_users/tmpl/notes/emptystate.php , administrator/components/com_users/tmpl/method/backupcodes.php , administrator/components/com_users/tmpl/levels/default.php , default_tree.php , administrator/components/com_templates/tmpl/template/default.php , administrator/components/com_tags/tmpl/tags/emptystate.php , administrator/components/com_tags/tmpl/tags/default.php , empty_state.php , administrator/components/com_scheduler/tmpl/tasks/default.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_privacy/tmpl/requests/emptystate.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_contact/tmpl/contacts/default.php , administrator/components/com_finder/tmpl/indexer/default.php , administrator/components/com_plugins/tmpl/plugins/default.php , administrator/components/com_installer/tmpl/languages/default.php , administrator/components/com_actionlogs/tmpl/actionlogs/default.php , administrator/components/com_banners/tmpl/clients/emptystate.php , administrator/components/com_contact/tmpl/contacts/emptystate.php , administrator/components/com_installer/tmpl/manage/default.php , administrator/components/com_installer/tmpl/update/default.php , administrator/components/com_contact/tmpl/contacts/modal.php , administrator/components/com_installer/tmpl/update/emptystate.php , administrator/components/com_installer/tmpl/updatesites/default.php , administrator/components/com_menus/layouts/joomla/searchtools/default.php , administrator/components/com_languages/tmpl/languages/default.php , preupdatecheck.php , administrator/components/com_categories/tmpl/categories/default.php , administrator/components/com_content/tmpl/articles/default.php , extract.php , administrator/components/com_content/tmpl/articles/emptystate.php
  • ignore_fieldsets : administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_tags/tmpl/tag/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_finder/tmpl/filter/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_users/tmpl/group/edit.php , administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_modules/tmpl/module/edit.php , components/com_contact/tmpl/form/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_templates/tmpl/style/edit.php
  • image : administrator/components/com_templates/tmpl/styles/default.php
  • imageAlt : default_result.php
  • imageUrl : default_result.php
  • items : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php


Joomla CMS: Variables globale

- j -

  • JDEBUG : administrator/includes/framework.php , api/includes/framework.php , installation/includes/framework.php
  • JOOMLA_MINIMUM_PHP : administrator/index.php , installation/index.php , api/index.php , cli/joomla.php , index.php
  • JPATH_ADMINISTRATOR : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_API : installation/includes/defines.php , administrator/includes/defines.php , api/includes/defines.php , includes/defines.php
  • JPATH_BASE : installation/includes/app.php
  • JPATH_CACHE : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_CLI : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_CONFIGURATION : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_INSTALLATION : includes/defines.php , installation/includes/defines.php , api/includes/defines.php , administrator/includes/defines.php
  • JPATH_LIBRARIES : administrator/includes/defines.php , api/includes/defines.php , includes/defines.php , installation/includes/defines.php
  • JPATH_MANIFESTS : installation/includes/defines.php , administrator/includes/defines.php , includes/defines.php , api/includes/defines.php
  • JPATH_PLUGINS : includes/defines.php , administrator/includes/defines.php , api/includes/defines.php , installation/includes/defines.php
  • JPATH_ROOT : administrator/includes/defines.php , installation/includes/defines.php , includes/defines.php , api/includes/defines.php
  • JPATH_SITE : installation/includes/defines.php , api/includes/defines.php , administrator/includes/defines.php , includes/defines.php
  • JPATH_THEMES : api/includes/defines.php , installation/includes/defines.php , administrator/includes/defines.php , includes/defines.php


Joomla CMS: Variables globale

- l -

  • language : blog_children.php , com_content/tmpl/category/default_children.php , modules/mod_tags_popular/tmpl/default.php
  • language_image : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php
  • language_title : administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_templates/tmpl/styles/default.php , administrator/components/com_menus/tmpl/items/default.php
  • level : administrator/modules/mod_menu/mod_menu.php
  • limitstart : default_results.php


Joomla CMS: Variables globale

- m -

  • maxLevel : com_contact/tmpl/category/default_children.php , blog_children.php , com_newsfeeds/tmpl/category/default_children.php , com_content/tmpl/category/default_children.php
  • maxLevelcat : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php
  • method : administrator/components/com_menus/tmpl/items/default.php , mod_articles_categories.php , mod_articles_category.php , mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php
  • methodparams : mod_related_items.php , mod_tags_popular.php , mod_tags_similar.php , mod_articles_categories.php , mod_articles_category.php
  • modal : layouts/joomla/form/field/user.php
  • modalLink : administrator/components/com_scheduler/tmpl/select/modal.php , administrator/components/com_modules/tmpl/select/modal.php
  • modeparams : mod_tags_popular.php , mod_related_items.php , mod_articles_category.php , mod_articles_categories.php , mod_tags_similar.php
  • modified_date : default_updated_files.php


Joomla CMS: Variables globale

- n -

  • n : extract-tentative-return-types.php
  • name : default_cache.php , default_database.php , administrator/modules/mod_sampledata/tmpl/default.php , default_webservices.php , default_logging.php , default_session.php , default_server.php , administrator/components/com_config/tmpl/application/default_seo.php , default_proxy.php , default_permissions.php , administrator/components/com_config/tmpl/application/default_metadata.php , default_mail.php , administrator/components/com_config/tmpl/application/default_site.php , default_logging_custom.php , default_locale.php , default_filters.php , default_debug.php , default_cookie.php
  • nbsp : compare.php
  • null : layouts/joomla/form/field/calendar.php


Joomla CMS: Variables globale

- p -

  • parent : components/com_contact/tmpl/categories/default_items.php , components/com_content/tmpl/categories/default_items.php , components/com_newsfeeds/tmpl/categories/default_items.php
  • path : layouts/joomla/form/field/media.php


Joomla CMS: Variables globale

- r -

  • rating : com_content/tmpl/category/default_articles.php
  • rating_count : com_content/tmpl/category/default_articles.php
  • return : win1252_to_utf8.php , utf8_fix.php , transliterator_list.php , voku/portable-utf8/src/voku/helper/data/ord.php , encodings.php , emoji.php , chr.php , caseFolding_full.php , x1f1.php , x1d7.php , x1d6.php , x1d5.php , x1d4.php , x0ff.php , x0fe.php , x0fd.php , x0fc.php , x0fb.php , x0fa.php , x0f9.php , x0d7.php , x0d6.php , x0d5.php , x0d4.php , x0d3.php , x0d2.php , x0d1.php , x0d0.php , x0cf.php , x0ce.php , x0cd.php , x0cc.php , x0cb.php , x0ca.php , x0c9.php , x0c8.php , x0c7.php , x0c6.php , x0c5.php , x0c4.php , x0c3.php , x0c2.php , x0c1.php , x0c0.php , x0bf.php , x0be.php , x0bd.php , x0bc.php , x0bb.php , x0ba.php , x0b9.php , x0b8.php , x0b7.php , x0b6.php , x0b5.php , x0b4.php , x0b3.php , x0b2.php , x0b1.php , x0b0.php , x0af.php , x0ae.php , x0ad.php , x0ac.php , x0a4.php , x0a3.php , x0a2.php , x0a1.php , x0a0.php , x09f.php , x09e.php , x09d.php , x09c.php , x09b.php , x09a.php , x099.php , x098.php , x097.php , x096.php , x095.php , x094.php , x093.php , x092.php , x091.php , x090.php , x08f.php , x08e.php , x08d.php , x08c.php , x08b.php , x08a.php , x089.php , x088.php , x087.php , x086.php , x085.php , x084.php , x083.php , x082.php , x081.php , x080.php , x07f.php , x07e.php , x07d.php , x07c.php , x07b.php , x07a.php , x079.php , x078.php , x077.php , x076.php , x075.php , x074.php , x073.php , x072.php , x071.php , x070.php , x06f.php , x06e.php , x06d.php , x06c.php , x06b.php , x06a.php , x069.php , x068.php , x067.php , x066.php , x065.php , x064.php , x063.php , x062.php , x061.php , x060.php , x05f.php , x05e.php , x05d.php , x05c.php , x05b.php , x05a.php , x059.php , x058.php , x057.php , x056.php , x055.php , x054.php , x053.php , x052.php , x051.php , x050.php , x04f.php , x04e.php , x04d.php , x033.php , x032.php , x031.php , x030.php , x02f.php , x02e.php , x02c.php , x02a.php , x029.php , x028.php , x026.php , x025.php , x024.php , x023.php , x022.php , x021.php , x020.php , x01f.php , x01e.php , x01d.php , x016.php , x015.php , x014.php , x012.php , x011.php , x00d.php , x00c.php , x00b.php , x00a.php , x006.php , x005.php , x004.php , x003.php , x001.php , x000.php , ascii_ord.php , ascii_language_max_key.php , ascii_extras_by_languages.php , ascii_by_languages.php , wcswidth_table_zero.php , wcswidth_table_wide.php , titleCaseRegexp.php , replacements.php , default_results.php , administrator/cache/autoload_psr4.php , plugins/multifactorauth/webauthn/tmpl/default.php


Joomla CMS: Variables globale

- s -

  • showlabel : default_permissions.php
  • SODIUM_BASE64_VARIANT_ORIGINAL : php72compat_const.php
  • SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING : php72compat_const.php
  • SODIUM_BASE64_VARIANT_URLSAFE : php72compat_const.php
  • SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES : php72compat_const.php
  • SODIUM_CRYPTO_AUTH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_AUTH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_MACBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SEALBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_BOX_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_KDF_BYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_KDF_BYTES_MIN : php72compat_const.php
  • SODIUM_CRYPTO_KDF_CONTEXTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KDF_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_PRIMITIVE : php72compat_const.php
  • SODIUM_CRYPTO_KX_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_KX_SESSIONKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SALTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX : php72compat_const.php
  • SODIUM_CRYPTO_PWHASH_STRPREFIX : php72compat_const.php
  • SODIUM_CRYPTO_SCALARMULT_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SCALARMULT_SCALARBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_MACBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETBOX_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH : php72compat_const.php
  • SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY : php72compat_const.php
  • SODIUM_CRYPTO_SHORTHASH_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SHORTHASH_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_BYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_KEYPAIRBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_SECRETKEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_SIGN_SEEDBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_NONCEBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_XCHACHA20_KEYBYTES : php72compat_const.php
  • SODIUM_CRYPTO_STREAM_XCHACHA20_NONCEBYTES : php72compat_const.php
  • SODIUM_LIBRARY_MAJOR_VERSION : php72compat_const.php
  • SODIUM_LIBRARY_MINOR_VERSION : php72compat_const.php
  • SODIUM_LIBRARY_VERSION : php72compat_const.php
  • subtemplatename : components/com_content/tmpl/category/default.php , components/com_contact/tmpl/category/default.php


Joomla CMS: Variables globale

- t -

  • tab_name : components/com_contact/tmpl/form/edit.php , components/com_content/tmpl/form/edit.php
  • templateMethod : generate_docs.php
  • text : default_profile.php , components/com_content/tmpl/category/blog.php , category_default.php
  • title_native : modules/mod_languages/tmpl/default.php
  • true : administrator/components/com_menus/tmpl/items/default.php , administrator/components/com_menus/tmpl/items/modal.php , administrator/components/com_templates/tmpl/styles/default.php
  • try : administrator/components/com_scheduler/tmpl/tasks/default.php , manage.php , mod_messages.php , mod_post_installation_messages.php , administrator/components/com_scheduler/tmpl/select/modal.php , tmpl/sql.php


Joomla CMS: Variables globale

- u -

  • useCoreUI : administrator/components/com_categories/tmpl/category/edit.php , administrator/components/com_contact/tmpl/contact/edit.php , administrator/components/com_fields/tmpl/field/edit.php , administrator/components/com_media/tmpl/file/default.php , administrator/components/com_users/tmpl/group/edit.php , administrator/components/com_users/tmpl/user/edit.php , administrator/components/com_menus/tmpl/item/edit.php , administrator/components/com_workflow/tmpl/transition/edit.php , components/com_contact/tmpl/form/edit.php , administrator/components/com_fields/tmpl/group/edit.php , administrator/components/com_modules/tmpl/module/edit.php , components/com_content/tmpl/form/edit.php , administrator/components/com_newsfeeds/tmpl/newsfeed/edit.php , administrator/components/com_content/tmpl/article/edit.php , administrator/components/com_finder/tmpl/filter/edit.php , administrator/components/com_plugins/tmpl/plugin/edit.php , administrator/components/com_scheduler/tmpl/task/edit.php , administrator/components/com_templates/tmpl/style/edit.php , administrator/components/com_mails/tmpl/template/edit.php , administrator/components/com_tags/tmpl/tag/edit.php
  • usePreset : cassiopeia/offline.php , templates/cassiopeia/error.php , templates/cassiopeia/component.php , templates/cassiopeia/index.php
  • UTF8_BAD_5OCTET : bad.php
  • UTF8_BAD_6OCTET : bad.php
  • UTF8_BAD_NONSHORT : bad.php
  • UTF8_BAD_SEQID : bad.php
  • UTF8_BAD_SEQINCOMPLETE : bad.php
  • UTF8_BAD_SURROGATE : bad.php
  • UTF8_BAD_UNIOUTRANGE : bad.php


Joomla CMS: Variables globale

- v -

  • value : compare.php , default_params.php , default_custom.php


Joomla CMS: Variables globale

- w -

  • width : error_full.php , login.php , administrator/templates/atum/index.php , error_login.php


Joomla CMS: Variables globale

- x -

  • xmldata : default_description.php


Joomla CMS: Variables globale

- y -

  • y : x002.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- w -

  • width : error_full.php , login.php , administrator/templates/atum/index.php , error_login.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- x -

  • xmldata : default_description.php


Joomla CMS: Variables globale

Liste de toutes les fonctions, variables, macros, enumérations, et définitions de type avec des liens vers les fichiers auxquels ils appartiennent :

- y -

  • y : x002.php


Joomla CMS: Pages associées

Pages associées
Liste de toutes les pages de documentation associées :
Liste des éléments obsolètes


Joomla CMS: Référence du fichier WrapperComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier WrapperComponent.php

Structures de données

class WrapperComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Wrapper\Administrator\Extension


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • fixed
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/fixed/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SetConfigurationCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier SetConfigurationCommand.php

Structures de données

class SetConfigurationCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier x023.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x023.php

Variables

return ['[?]', '[?]', '[?]', '^', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '<', '> ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '^', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '<', '> ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier StyleTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier StyleTable.php

Structures de données

class StyleTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Table


Joomla CMS: Référence du fichier Utility.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Utility
Structures de données | Espaces de nommage
Référence du fichier Utility.php

Structures de données

class Utility

Espaces de nommage

Joomla\CMS\Utility


Joomla CMS: Référence du fichier WritableContainerLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
  • Loader
Structures de données | Espaces de nommage
Référence du fichier WritableContainerLoader.php

Structures de données

class WritableContainerLoader

Espaces de nommage

Joomla\CMS\Console\Loader


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_wrapper
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_wrapper/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier tasknotification.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • tasknotification
Structures de données | Espaces de nommage
Référence du fichier tasknotification.php

Structures de données

class PlgSystemTasknotification

Espaces de nommage

Joomla\Plugins


Joomla CMS: Référence du fichier UnsupportedOperationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Exception/UnsupportedOperationException.php

Structures de données

class UnsupportedOperationException

Espaces de nommage

UnsupportedOperationException
phpseclib3\Exception


Joomla CMS: Référence du fichier x086.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x086.php

Variables

return ['Tuo ', 'Wu ', 'Rui ', 'Rui ', 'Qi ', 'Heng ', 'Lu ', 'Su ', 'Tui ', 'Mang ', 'Yun ', 'Pin ', 'Yu ', 'Xun ', 'Ji ', 'Jiong ', 'Xian ', 'Mo ', 'Hagi ', 'Su ', 'Jiong ', '[?] ', 'Nie ', 'Bo ', 'Rang ', 'Yi ', 'Xian ', 'Yu ', 'Ju ', 'Lian ', 'Lian ', 'Yin ', 'Qiang ', 'Ying ', 'Long ', 'Tong ', 'Wei ', 'Yue ', 'Ling ', 'Qu ', 'Yao ', 'Fan ', 'Mi ', 'Lan ', 'Kui ', 'Lan ', 'Ji ', 'Dang ', 'Katsura ', 'Lei ', 'Lei ', 'Hua ', 'Feng ', 'Zhi ', 'Wei ', 'Kui ', 'Zhan ', 'Huai ', 'Li ', 'Ji ', 'Mi ', 'Lei ', 'Huai ', 'Luo ', 'Ji ', 'Kui ', 'Lu ', 'Jian ', 'San ', '[?] ', 'Lei ', 'Quan ', 'Xiao ', 'Yi ', 'Luan ', 'Men ', 'Bie ', 'Hu ', 'Hu ', 'Lu ', 'Nue ', 'Lu ', 'Si ', 'Xiao ', 'Qian ', 'Chu ', 'Hu ', 'Xu ', 'Cuo ', 'Fu ', 'Xu ', 'Xu ', 'Lu ', 'Hu ', 'Yu ', 'Hao ', 'Jiao ', 'Ju ', 'Guo ', 'Bao ', 'Yan ', 'Zhan ', 'Zhan ', 'Kui ', 'Ban ', 'Xi ', 'Shu ', 'Chong ', 'Qiu ', 'Diao ', 'Ji ', 'Qiu ', 'Cheng ', 'Shi ', '[?] ', 'Di ', 'Zhe ', 'She ', 'Yu ', 'Gan ', 'Zi ', 'Hong ', 'Hui ', 'Meng ', 'Ge ', 'Sui ', 'Xia ', 'Chai ', 'Shi ', 'Yi ', 'Ma ', 'Xiang ', 'Fang ', 'E ', 'Pa ', 'Chi ', 'Qian ', 'Wen ', 'Wen ', 'Rui ', 'Bang ', 'Bi ', 'Yue ', 'Yue ', 'Jun ', 'Qi ', 'Ran ', 'Yin ', 'Qi ', 'Tian ', 'Yuan ', 'Jue ', 'Hui ', 'Qin ', 'Qi ', 'Zhong ', 'Ya ', 'Ci ', 'Mu ', 'Wang ', 'Fen ', 'Fen ', 'Hang ', 'Gong ', 'Zao ', 'Fu ', 'Ran ', 'Jie ', 'Fu ', 'Chi ', 'Dou ', 'Piao ', 'Xian ', 'Ni ', 'Te ', 'Qiu ', 'You ', 'Zha ', 'Ping ', 'Chi ', 'You ', 'He ', 'Han ', 'Ju ', 'Li ', 'Fu ', 'Ran ', 'Zha ', 'Gou ', 'Pi ', 'Bo ', 'Xian ', 'Zhu ', 'Diao ', 'Bie ', 'Bing ', 'Gu ', 'Ran ', 'Qu ', 'She ', 'Tie ', 'Ling ', 'Gu ', 'Dan ', 'Gu ', 'Ying ', 'Li ', 'Cheng ', 'Qu ', 'Mou ', 'Ge ', 'Ci ', 'Hui ', 'Hui ', 'Mang ', 'Fu ', 'Yang ', 'Wa ', 'Lie ', 'Zhu ', 'Yi ', 'Xian ', 'Kuo ', 'Jiao ', 'Li ', 'Yi ', 'Ping ', 'Ji ', 'Ha ', 'She ', 'Yi ', 'Wang ', 'Mo ', 'Qiong ', 'Qie ', 'Gui ', 'Gong ', 'Zhi ', 'Man ', 'Ebi ', 'Zhi ', 'Jia ', 'Rao ', 'Si ', 'Qi ', 'Xing ', 'Lie ', 'Qiu ', 'Shao ', 'Yong ', 'Jia ', 'Shui ', 'Che ', 'Bai ', 'E ', 'Han ']

Documentation des variables

◆ return

return[ 'Tuo ', 'Wu ', 'Rui ', 'Rui ', 'Qi ', 'Heng ', 'Lu ', 'Su ', 'Tui ', 'Mang ', 'Yun ', 'Pin ', 'Yu ', 'Xun ', 'Ji ', 'Jiong ', 'Xian ', 'Mo ', 'Hagi ', 'Su ', 'Jiong ', '[?] ', 'Nie ', 'Bo ', 'Rang ', 'Yi ', 'Xian ', 'Yu ', 'Ju ', 'Lian ', 'Lian ', 'Yin ', 'Qiang ', 'Ying ', 'Long ', 'Tong ', 'Wei ', 'Yue ', 'Ling ', 'Qu ', 'Yao ', 'Fan ', 'Mi ', 'Lan ', 'Kui ', 'Lan ', 'Ji ', 'Dang ', 'Katsura ', 'Lei ', 'Lei ', 'Hua ', 'Feng ', 'Zhi ', 'Wei ', 'Kui ', 'Zhan ', 'Huai ', 'Li ', 'Ji ', 'Mi ', 'Lei ', 'Huai ', 'Luo ', 'Ji ', 'Kui ', 'Lu ', 'Jian ', 'San ', '[?] ', 'Lei ', 'Quan ', 'Xiao ', 'Yi ', 'Luan ', 'Men ', 'Bie ', 'Hu ', 'Hu ', 'Lu ', 'Nue ', 'Lu ', 'Si ', 'Xiao ', 'Qian ', 'Chu ', 'Hu ', 'Xu ', 'Cuo ', 'Fu ', 'Xu ', 'Xu ', 'Lu ', 'Hu ', 'Yu ', 'Hao ', 'Jiao ', 'Ju ', 'Guo ', 'Bao ', 'Yan ', 'Zhan ', 'Zhan ', 'Kui ', 'Ban ', 'Xi ', 'Shu ', 'Chong ', 'Qiu ', 'Diao ', 'Ji ', 'Qiu ', 'Cheng ', 'Shi ', '[?] ', 'Di ', 'Zhe ', 'She ', 'Yu ', 'Gan ', 'Zi ', 'Hong ', 'Hui ', 'Meng ', 'Ge ', 'Sui ', 'Xia ', 'Chai ', 'Shi ', 'Yi ', 'Ma ', 'Xiang ', 'Fang ', 'E ', 'Pa ', 'Chi ', 'Qian ', 'Wen ', 'Wen ', 'Rui ', 'Bang ', 'Bi ', 'Yue ', 'Yue ', 'Jun ', 'Qi ', 'Ran ', 'Yin ', 'Qi ', 'Tian ', 'Yuan ', 'Jue ', 'Hui ', 'Qin ', 'Qi ', 'Zhong ', 'Ya ', 'Ci ', 'Mu ', 'Wang ', 'Fen ', 'Fen ', 'Hang ', 'Gong ', 'Zao ', 'Fu ', 'Ran ', 'Jie ', 'Fu ', 'Chi ', 'Dou ', 'Piao ', 'Xian ', 'Ni ', 'Te ', 'Qiu ', 'You ', 'Zha ', 'Ping ', 'Chi ', 'You ', 'He ', 'Han ', 'Ju ', 'Li ', 'Fu ', 'Ran ', 'Zha ', 'Gou ', 'Pi ', 'Bo ', 'Xian ', 'Zhu ', 'Diao ', 'Bie ', 'Bing ', 'Gu ', 'Ran ', 'Qu ', 'She ', 'Tie ', 'Ling ', 'Gu ', 'Dan ', 'Gu ', 'Ying ', 'Li ', 'Cheng ', 'Qu ', 'Mou ', 'Ge ', 'Ci ', 'Hui ', 'Hui ', 'Mang ', 'Fu ', 'Yang ', 'Wa ', 'Lie ', 'Zhu ', 'Yi ', 'Xian ', 'Kuo ', 'Jiao ', 'Li ', 'Yi ', 'Ping ', 'Ji ', 'Ha ', 'She ', 'Yi ', 'Wang ', 'Mo ', 'Qiong ', 'Qie ', 'Gui ', 'Gong ', 'Zhi ', 'Man ', 'Ebi ', 'Zhi ', 'Jia ', 'Rao ', 'Si ', 'Qi ', 'Xing ', 'Lie ', 'Qiu ', 'Shao ', 'Yong ', 'Jia ', 'Shui ', 'Che ', 'Bai ', 'E ', 'Han ']


Joomla CMS: Référence du fichier upload.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • layouts
  • toolbar
Espaces de nommage | Variables
Référence du fichier upload.php

Espaces de nommage

Joomla\Administrator

Variables

$title = Text::_('JTOOLBAR_UPLOAD')

Documentation des variables

◆ $title

$title = Text::_('JTOOLBAR_UPLOAD')


Joomla CMS: Référence du fichier usergrouplist.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • usergrouplist
Structures de données | Espaces de nommage
Référence du fichier usergrouplist.php

Structures de données

class PlgFieldsUsergrouplist

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SymfonyStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Style
Structures de données | Espaces de nommage
Référence du fichier SymfonyStyle.php

Structures de données

class SymfonyStyle

Espaces de nommage

Symfony\Component\Console\Style


Joomla CMS: Référence du fichier Usergroup.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Usergroup.php

Structures de données

class Usergroup

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier Salsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier paragonie/sodium_compat/namespaced/Core/Salsa20.php

Structures de données

class Salsa20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier ResultTypeBooleanAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeBooleanAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeBooleanAware


Joomla CMS: Référence du fichier usergrouplist.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • usergrouplist
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/usergrouplist.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
$texts = array()
$groups = UsersHelper::getGroups()
foreach ( $groups as $group)

Documentation des variables

◆ $groups

$groups = UsersHelper::getGroups()

◆ $texts

$texts = array()

◆ $value

if ( $value=='') $value = $field->value

◆ foreach

foreach($groups as $group)


Joomla CMS: Référence du fichier Util.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/Util.php

Structures de données

class ParagonIE_Sodium_Core_Util


Joomla CMS: Référence du fichier PreviewModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier PreviewModel.php

Structures de données

class PreviewModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Model


Joomla CMS: Référence du fichier XmlResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier XmlResponse.php

Structures de données

class XmlResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier PopularHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_popular
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PopularHelper.php

Structures de données

class PopularHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Popular\Administrator\Helper


Joomla CMS: Référence du fichier SignedPublicKeyAndChallenge.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SignedPublicKeyAndChallenge.php

Structures de données

class SignedPublicKeyAndChallenge

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier WebApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier src/Application/WebApplication.php

Structures de données

class WebApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier x0c2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c2.php

Variables

return ['syon', 'syonj', 'syonh', 'syod', 'syol', 'syolg', 'syolm', 'syolb', 'syols', 'syolt', 'syolp', 'syolh', 'syom', 'syob', 'syobs', 'syos', 'syoss', 'syong', 'syoj', 'syoc', 'syok', 'syot', 'syop', 'syoh', 'su', 'sug', 'sugg', 'sugs', 'sun', 'sunj', 'sunh', 'sud', 'sul', 'sulg', 'sulm', 'sulb', 'suls', 'sult', 'sulp', 'sulh', 'sum', 'sub', 'subs', 'sus', 'suss', 'sung', 'suj', 'suc', 'suk', 'sut', 'sup', 'suh', 'sweo', 'sweog', 'sweogg', 'sweogs', 'sweon', 'sweonj', 'sweonh', 'sweod', 'sweol', 'sweolg', 'sweolm', 'sweolb', 'sweols', 'sweolt', 'sweolp', 'sweolh', 'sweom', 'sweob', 'sweobs', 'sweos', 'sweoss', 'sweong', 'sweoj', 'sweoc', 'sweok', 'sweot', 'sweop', 'sweoh', 'swe', 'sweg', 'swegg', 'swegs', 'swen', 'swenj', 'swenh', 'swed', 'swel', 'swelg', 'swelm', 'swelb', 'swels', 'swelt', 'swelp', 'swelh', 'swem', 'sweb', 'swebs', 'swes', 'swess', 'sweng', 'swej', 'swec', 'swek', 'swet', 'swep', 'sweh', 'swi', 'swig', 'swigg', 'swigs', 'swin', 'swinj', 'swinh', 'swid', 'swil', 'swilg', 'swilm', 'swilb', 'swils', 'swilt', 'swilp', 'swilh', 'swim', 'swib', 'swibs', 'swis', 'swiss', 'swing', 'swij', 'swic', 'swik', 'swit', 'swip', 'swih', 'syu', 'syug', 'syugg', 'syugs', 'syun', 'syunj', 'syunh', 'syud', 'syul', 'syulg', 'syulm', 'syulb', 'syuls', 'syult', 'syulp', 'syulh', 'syum', 'syub', 'syubs', 'syus', 'syuss', 'syung', 'syuj', 'syuc', 'syuk', 'syut', 'syup', 'syuh', 'seu', 'seug', 'seugg', 'seugs', 'seun', 'seunj', 'seunh', 'seud', 'seul', 'seulg', 'seulm', 'seulb', 'seuls', 'seult', 'seulp', 'seulh', 'seum', 'seub', 'seubs', 'seus', 'seuss', 'seung', 'seuj', 'seuc', 'seuk', 'seut', 'seup', 'seuh', 'syi', 'syig', 'syigg', 'syigs', 'syin', 'syinj', 'syinh', 'syid', 'syil', 'syilg', 'syilm', 'syilb', 'syils', 'syilt', 'syilp', 'syilh', 'syim', 'syib', 'syibs', 'syis', 'syiss', 'sying', 'syij', 'syic', 'syik', 'syit', 'syip', 'syih', 'si', 'sig', 'sigg', 'sigs', 'sin', 'sinj', 'sinh', 'sid', 'sil', 'silg', 'silm', 'silb', 'sils', 'silt', 'silp', 'silh', 'sim', 'sib', 'sibs', 'sis', 'siss', 'sing', 'sij', 'sic', 'sik', 'sit', 'sip', 'sih', 'ssa', 'ssag', 'ssagg', 'ssags', 'ssan', 'ssanj', 'ssanh', 'ssad']

Documentation des variables

◆ return

return[ 'syon', 'syonj', 'syonh', 'syod', 'syol', 'syolg', 'syolm', 'syolb', 'syols', 'syolt', 'syolp', 'syolh', 'syom', 'syob', 'syobs', 'syos', 'syoss', 'syong', 'syoj', 'syoc', 'syok', 'syot', 'syop', 'syoh', 'su', 'sug', 'sugg', 'sugs', 'sun', 'sunj', 'sunh', 'sud', 'sul', 'sulg', 'sulm', 'sulb', 'suls', 'sult', 'sulp', 'sulh', 'sum', 'sub', 'subs', 'sus', 'suss', 'sung', 'suj', 'suc', 'suk', 'sut', 'sup', 'suh', 'sweo', 'sweog', 'sweogg', 'sweogs', 'sweon', 'sweonj', 'sweonh', 'sweod', 'sweol', 'sweolg', 'sweolm', 'sweolb', 'sweols', 'sweolt', 'sweolp', 'sweolh', 'sweom', 'sweob', 'sweobs', 'sweos', 'sweoss', 'sweong', 'sweoj', 'sweoc', 'sweok', 'sweot', 'sweop', 'sweoh', 'swe', 'sweg', 'swegg', 'swegs', 'swen', 'swenj', 'swenh', 'swed', 'swel', 'swelg', 'swelm', 'swelb', 'swels', 'swelt', 'swelp', 'swelh', 'swem', 'sweb', 'swebs', 'swes', 'swess', 'sweng', 'swej', 'swec', 'swek', 'swet', 'swep', 'sweh', 'swi', 'swig', 'swigg', 'swigs', 'swin', 'swinj', 'swinh', 'swid', 'swil', 'swilg', 'swilm', 'swilb', 'swils', 'swilt', 'swilp', 'swilh', 'swim', 'swib', 'swibs', 'swis', 'swiss', 'swing', 'swij', 'swic', 'swik', 'swit', 'swip', 'swih', 'syu', 'syug', 'syugg', 'syugs', 'syun', 'syunj', 'syunh', 'syud', 'syul', 'syulg', 'syulm', 'syulb', 'syuls', 'syult', 'syulp', 'syulh', 'syum', 'syub', 'syubs', 'syus', 'syuss', 'syung', 'syuj', 'syuc', 'syuk', 'syut', 'syup', 'syuh', 'seu', 'seug', 'seugg', 'seugs', 'seun', 'seunj', 'seunh', 'seud', 'seul', 'seulg', 'seulm', 'seulb', 'seuls', 'seult', 'seulp', 'seulh', 'seum', 'seub', 'seubs', 'seus', 'seuss', 'seung', 'seuj', 'seuc', 'seuk', 'seut', 'seup', 'seuh', 'syi', 'syig', 'syigg', 'syigs', 'syin', 'syinj', 'syinh', 'syid', 'syil', 'syilg', 'syilm', 'syilb', 'syils', 'syilt', 'syilp', 'syilh', 'syim', 'syib', 'syibs', 'syis', 'syiss', 'sying', 'syij', 'syic', 'syik', 'syit', 'syip', 'syih', 'si', 'sig', 'sigg', 'sigs', 'sin', 'sinj', 'sinh', 'sid', 'sil', 'silg', 'silm', 'silb', 'sils', 'silt', 'silp', 'silh', 'sim', 'sib', 'sibs', 'sis', 'siss', 'sing', 'sij', 'sic', 'sik', 'sit', 'sip', 'sih', 'ssa', 'ssag', 'ssagg', 'ssags', 'ssan', 'ssanj', 'ssanh', 'ssad']


Joomla CMS: Référence du fichier ReflectionCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ReflectionCaster.php

Structures de données

class ReflectionCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/Common/PrivateKey.php

Structures de données

interface PrivateKey

Espaces de nommage

Common
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier radiobasic.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier radiobasic.php

Espaces de nommage

Joomla\Site

Variables

$format = '<input type="radio" id="%1$s" name="%2$s" value="%3$s" %4$s>'
$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)

Documentation des variables

◆ $alt

$alt = preg_replace('/[^a-zA-Z0-9_\-]/', '_', $name)

◆ $format

$format = '<input type="radio" id="%1$s" name="%2$s" value="%3$s" %4$s>'

The format of the input tag to be filled in using sprintf. %1 - id %2 - name %3 - value %4 = any other attributes


Joomla CMS: Référence du fichier TraceablePDOStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
  • PDO
Structures de données | Espaces de nommage
Référence du fichier TraceablePDOStatement.php

Structures de données

class TraceablePDOStatement

Espaces de nommage

DebugBar\DataCollector\PDO


Joomla CMS: Référence du fichier subform.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • subform
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/subform.php

Espaces de nommage

Joomla\Plugin

Variables

if(! $context||empty($field->subform_rows)) | $result = ''
foreach($field->subform_rows as $subform_row) if(trim($result) !='') | endif

Documentation des variables

◆ $result

if (! $context||empty( $field->subform_rows)) $result = ''

◆ endif

foreach ( $field->subform_rows as $subform_row) if (trim( $result) !='') endif


Joomla CMS: Référence du fichier StringCodec.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier StringCodec.php

Structures de données

class StringCodec

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier UnsupportedCurveException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedCurveException.php

Structures de données

class UnsupportedCurveException

Espaces de nommage

UnsupportedCurveException
phpseclib3\Exception


Joomla CMS: Référence du fichier SystemTimeProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Time
Structures de données | Espaces de nommage
Référence du fichier SystemTimeProvider.php

Structures de données

class SystemTimeProvider

Espaces de nommage

Ramsey\Uuid\Provider\Time


Joomla CMS: Référence du fichier x014.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x014.php

Variables

return ['[?]', 'e', 'aai', 'i', 'ii', 'o', 'oo', 'oo', 'ee', 'i', 'a', 'aa', 'we', 'we', 'wi', 'wi', 'wii', 'wii', 'wo', 'wo', 'woo', 'woo', 'woo', 'wa', 'wa', 'waa', 'waa', 'waa', 'ai', 'w', '\'', 't', 'k', 'sh', 's', 'n', 'w', 'n', '[?]', 'w', 'c', '?', 'l', 'en', 'in', 'on', 'an', 'pe', 'paai', 'pi', 'pii', 'po', 'poo', 'poo', 'hee', 'hi', 'pa', 'paa', 'pwe', 'pwe', 'pwi', 'pwi', 'pwii', 'pwii', 'pwo', 'pwo', 'pwoo', 'pwoo', 'pwa', 'pwa', 'pwaa', 'pwaa', 'pwaa', 'p', 'p', 'h', 'te', 'taai', 'ti', 'tii', 'to', 'too', 'too', 'dee', 'di', 'ta', 'taa', 'twe', 'twe', 'twi', 'twi', 'twii', 'twii', 'two', 'two', 'twoo', 'twoo', 'twa', 'twa', 'twaa', 'twaa', 'twaa', 't', 'tte', 'tti', 'tto', 'tta', 'ke', 'kaai', 'ki', 'kii', 'ko', 'koo', 'koo', 'ka', 'kaa', 'kwe', 'kwe', 'kwi', 'kwi', 'kwii', 'kwii', 'kwo', 'kwo', 'kwoo', 'kwoo', 'kwa', 'kwa', 'kwaa', 'kwaa', 'kwaa', 'k', 'kw', 'keh', 'kih', 'koh', 'kah', 'ce', 'caai', 'ci', 'cii', 'co', 'coo', 'coo', 'ca', 'caa', 'cwe', 'cwe', 'cwi', 'cwi', 'cwii', 'cwii', 'cwo', 'cwo', 'cwoo', 'cwoo', 'cwa', 'cwa', 'cwaa', 'cwaa', 'cwaa', 'c', 'th', 'me', 'maai', 'mi', 'mii', 'mo', 'moo', 'moo', 'ma', 'maa', 'mwe', 'mwe', 'mwi', 'mwi', 'mwii', 'mwii', 'mwo', 'mwo', 'mwoo', 'mwoo', 'mwa', 'mwa', 'mwaa', 'mwaa', 'mwaa', 'm', 'm', 'mh', 'm', 'm', 'ne', 'naai', 'ni', 'nii', 'no', 'noo', 'noo', 'na', 'naa', 'nwe', 'nwe', 'nwa', 'nwa', 'nwaa', 'nwaa', 'nwaa', 'n', 'ng', 'nh', 'le', 'laai', 'li', 'lii', 'lo', 'loo', 'loo', 'la', 'laa', 'lwe', 'lwe', 'lwi', 'lwi', 'lwii', 'lwii', 'lwo', 'lwo', 'lwoo', 'lwoo', 'lwa', 'lwa', 'lwaa', 'lwaa', 'l', 'l', 'l', 'se', 'saai', 'si', 'sii', 'so', 'soo', 'soo', 'sa', 'saa', 'swe', 'swe', 'swi', 'swi', 'swii', 'swii', 'swo', 'swo', 'swoo', 'swoo']

Documentation des variables

◆ return

return['[?]', 'e', 'aai', 'i', 'ii', 'o', 'oo', 'oo', 'ee', 'i', 'a', 'aa', 'we', 'we', 'wi', 'wi', 'wii', 'wii', 'wo', 'wo', 'woo', 'woo', 'woo', 'wa', 'wa', 'waa', 'waa', 'waa', 'ai', 'w', '\'', 't', 'k', 'sh', 's', 'n', 'w', 'n', '[?]', 'w', 'c', '?', 'l', 'en', 'in', 'on', 'an', 'pe', 'paai', 'pi', 'pii', 'po', 'poo', 'poo', 'hee', 'hi', 'pa', 'paa', 'pwe', 'pwe', 'pwi', 'pwi', 'pwii', 'pwii', 'pwo', 'pwo', 'pwoo', 'pwoo', 'pwa', 'pwa', 'pwaa', 'pwaa', 'pwaa', 'p', 'p', 'h', 'te', 'taai', 'ti', 'tii', 'to', 'too', 'too', 'dee', 'di', 'ta', 'taa', 'twe', 'twe', 'twi', 'twi', 'twii', 'twii', 'two', 'two', 'twoo', 'twoo', 'twa', 'twa', 'twaa', 'twaa', 'twaa', 't', 'tte', 'tti', 'tto', 'tta', 'ke', 'kaai', 'ki', 'kii', 'ko', 'koo', 'koo', 'ka', 'kaa', 'kwe', 'kwe', 'kwi', 'kwi', 'kwii', 'kwii', 'kwo', 'kwo', 'kwoo', 'kwoo', 'kwa', 'kwa', 'kwaa', 'kwaa', 'kwaa', 'k', 'kw', 'keh', 'kih', 'koh', 'kah', 'ce', 'caai', 'ci', 'cii', 'co', 'coo', 'coo', 'ca', 'caa', 'cwe', 'cwe', 'cwi', 'cwi', 'cwii', 'cwii', 'cwo', 'cwo', 'cwoo', 'cwoo', 'cwa', 'cwa', 'cwaa', 'cwaa', 'cwaa', 'c', 'th', 'me', 'maai', 'mi', 'mii', 'mo', 'moo', 'moo', 'ma', 'maa', 'mwe', 'mwe', 'mwi', 'mwi', 'mwii', 'mwii', 'mwo', 'mwo', 'mwoo', 'mwoo', 'mwa', 'mwa', 'mwaa', 'mwaa', 'mwaa', 'm', 'm', 'mh', 'm', 'm', 'ne', 'naai', 'ni', 'nii', 'no', 'noo', 'noo', 'na', 'naa', 'nwe', 'nwe', 'nwa', 'nwa', 'nwaa', 'nwaa', 'nwaa', 'n', 'ng', 'nh', 'le', 'laai', 'li', 'lii', 'lo', 'loo', 'loo', 'la', 'laa', 'lwe', 'lwe', 'lwi', 'lwi', 'lwii', 'lwii', 'lwo', 'lwo', 'lwoo', 'lwoo', 'lwa', 'lwa', 'lwaa', 'lwaa', 'l', 'l', 'l', 'se', 'saai', 'si', 'sii', 'so', 'soo', 'soo', 'sa', 'saa', 'swe', 'swe', 'swi', 'swi', 'swii', 'swii', 'swo', 'swo', 'swoo', 'swoo']


Joomla CMS: Référence du fichier RandomLibAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier RandomLibAdapter.php

Structures de données

class RandomLibAdapter

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier x097.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x097.php

Variables

return ['Xu ', 'Ji ', 'Mu ', 'Chen ', 'Xiao ', 'Zha ', 'Ting ', 'Zhen ', 'Pei ', 'Mei ', 'Ling ', 'Qi ', 'Chou ', 'Huo ', 'Sha ', 'Fei ', 'Weng ', 'Zhan ', 'Yin ', 'Ni ', 'Chou ', 'Tun ', 'Lin ', '[?] ', 'Dong ', 'Ying ', 'Wu ', 'Ling ', 'Shuang ', 'Ling ', 'Xia ', 'Hong ', 'Yin ', 'Mo ', 'Mai ', 'Yun ', 'Liu ', 'Meng ', 'Bin ', 'Wu ', 'Wei ', 'Huo ', 'Yin ', 'Xi ', 'Yi ', 'Ai ', 'Dan ', 'Deng ', 'Xian ', 'Yu ', 'Lu ', 'Long ', 'Dai ', 'Ji ', 'Pang ', 'Yang ', 'Ba ', 'Pi ', 'Wei ', '[?] ', 'Xi ', 'Ji ', 'Mai ', 'Meng ', 'Meng ', 'Lei ', 'Li ', 'Huo ', 'Ai ', 'Fei ', 'Dai ', 'Long ', 'Ling ', 'Ai ', 'Feng ', 'Li ', 'Bao ', '[?] ', 'He ', 'He ', 'Bing ', 'Qing ', 'Qing ', 'Jing ', 'Tian ', 'Zhen ', 'Jing ', 'Cheng ', 'Qing ', 'Jing ', 'Jing ', 'Dian ', 'Jing ', 'Tian ', 'Fei ', 'Fei ', 'Kao ', 'Mi ', 'Mian ', 'Mian ', 'Pao ', 'Ye ', 'Tian ', 'Hui ', 'Ye ', 'Ge ', 'Ding ', 'Cha ', 'Jian ', 'Ren ', 'Di ', 'Du ', 'Wu ', 'Ren ', 'Qin ', 'Jin ', 'Xue ', 'Niu ', 'Ba ', 'Yin ', 'Sa ', 'Na ', 'Mo ', 'Zu ', 'Da ', 'Ban ', 'Yi ', 'Yao ', 'Tao ', 'Tuo ', 'Jia ', 'Hong ', 'Pao ', 'Yang ', 'Tomo ', 'Yin ', 'Jia ', 'Tao ', 'Ji ', 'Xie ', 'An ', 'An ', 'Hen ', 'Gong ', 'Kohaze ', 'Da ', 'Qiao ', 'Ting ', 'Wan ', 'Ying ', 'Sui ', 'Tiao ', 'Qiao ', 'Xuan ', 'Kong ', 'Beng ', 'Ta ', 'Zhang ', 'Bing ', 'Kuo ', 'Ju ', 'La ', 'Xie ', 'Rou ', 'Bang ', 'Yi ', 'Qiu ', 'Qiu ', 'He ', 'Xiao ', 'Mu ', 'Ju ', 'Jian ', 'Bian ', 'Di ', 'Jian ', 'On ', 'Tao ', 'Gou ', 'Ta ', 'Bei ', 'Xie ', 'Pan ', 'Ge ', 'Bi ', 'Kuo ', 'Tang ', 'Lou ', 'Gui ', 'Qiao ', 'Xue ', 'Ji ', 'Jian ', 'Jiang ', 'Chan ', 'Da ', 'Huo ', 'Xian ', 'Qian ', 'Du ', 'Wa ', 'Jian ', 'Lan ', 'Wei ', 'Ren ', 'Fu ', 'Mei ', 'Juan ', 'Ge ', 'Wei ', 'Qiao ', 'Han ', 'Chang ', '[?] ', 'Rou ', 'Xun ', 'She ', 'Wei ', 'Ge ', 'Bei ', 'Tao ', 'Gou ', 'Yun ', '[?] ', 'Bi ', 'Wei ', 'Hui ', 'Du ', 'Wa ', 'Du ', 'Wei ', 'Ren ', 'Fu ', 'Han ', 'Wei ', 'Yun ', 'Tao ', 'Jiu ', 'Jiu ', 'Xian ', 'Xie ', 'Xian ', 'Ji ', 'Yin ', 'Za ', 'Yun ', 'Shao ', 'Le ', 'Peng ', 'Heng ', 'Ying ', 'Yun ', 'Peng ', 'Yin ', 'Yin ', 'Xiang ']

Documentation des variables

◆ return

return[ 'Xu ', 'Ji ', 'Mu ', 'Chen ', 'Xiao ', 'Zha ', 'Ting ', 'Zhen ', 'Pei ', 'Mei ', 'Ling ', 'Qi ', 'Chou ', 'Huo ', 'Sha ', 'Fei ', 'Weng ', 'Zhan ', 'Yin ', 'Ni ', 'Chou ', 'Tun ', 'Lin ', '[?] ', 'Dong ', 'Ying ', 'Wu ', 'Ling ', 'Shuang ', 'Ling ', 'Xia ', 'Hong ', 'Yin ', 'Mo ', 'Mai ', 'Yun ', 'Liu ', 'Meng ', 'Bin ', 'Wu ', 'Wei ', 'Huo ', 'Yin ', 'Xi ', 'Yi ', 'Ai ', 'Dan ', 'Deng ', 'Xian ', 'Yu ', 'Lu ', 'Long ', 'Dai ', 'Ji ', 'Pang ', 'Yang ', 'Ba ', 'Pi ', 'Wei ', '[?] ', 'Xi ', 'Ji ', 'Mai ', 'Meng ', 'Meng ', 'Lei ', 'Li ', 'Huo ', 'Ai ', 'Fei ', 'Dai ', 'Long ', 'Ling ', 'Ai ', 'Feng ', 'Li ', 'Bao ', '[?] ', 'He ', 'He ', 'Bing ', 'Qing ', 'Qing ', 'Jing ', 'Tian ', 'Zhen ', 'Jing ', 'Cheng ', 'Qing ', 'Jing ', 'Jing ', 'Dian ', 'Jing ', 'Tian ', 'Fei ', 'Fei ', 'Kao ', 'Mi ', 'Mian ', 'Mian ', 'Pao ', 'Ye ', 'Tian ', 'Hui ', 'Ye ', 'Ge ', 'Ding ', 'Cha ', 'Jian ', 'Ren ', 'Di ', 'Du ', 'Wu ', 'Ren ', 'Qin ', 'Jin ', 'Xue ', 'Niu ', 'Ba ', 'Yin ', 'Sa ', 'Na ', 'Mo ', 'Zu ', 'Da ', 'Ban ', 'Yi ', 'Yao ', 'Tao ', 'Tuo ', 'Jia ', 'Hong ', 'Pao ', 'Yang ', 'Tomo ', 'Yin ', 'Jia ', 'Tao ', 'Ji ', 'Xie ', 'An ', 'An ', 'Hen ', 'Gong ', 'Kohaze ', 'Da ', 'Qiao ', 'Ting ', 'Wan ', 'Ying ', 'Sui ', 'Tiao ', 'Qiao ', 'Xuan ', 'Kong ', 'Beng ', 'Ta ', 'Zhang ', 'Bing ', 'Kuo ', 'Ju ', 'La ', 'Xie ', 'Rou ', 'Bang ', 'Yi ', 'Qiu ', 'Qiu ', 'He ', 'Xiao ', 'Mu ', 'Ju ', 'Jian ', 'Bian ', 'Di ', 'Jian ', 'On ', 'Tao ', 'Gou ', 'Ta ', 'Bei ', 'Xie ', 'Pan ', 'Ge ', 'Bi ', 'Kuo ', 'Tang ', 'Lou ', 'Gui ', 'Qiao ', 'Xue ', 'Ji ', 'Jian ', 'Jiang ', 'Chan ', 'Da ', 'Huo ', 'Xian ', 'Qian ', 'Du ', 'Wa ', 'Jian ', 'Lan ', 'Wei ', 'Ren ', 'Fu ', 'Mei ', 'Juan ', 'Ge ', 'Wei ', 'Qiao ', 'Han ', 'Chang ', '[?] ', 'Rou ', 'Xun ', 'She ', 'Wei ', 'Ge ', 'Bei ', 'Tao ', 'Gou ', 'Yun ', '[?] ', 'Bi ', 'Wei ', 'Hui ', 'Du ', 'Wa ', 'Du ', 'Wei ', 'Ren ', 'Fu ', 'Han ', 'Wei ', 'Yun ', 'Tao ', 'Jiu ', 'Jiu ', 'Xian ', 'Xie ', 'Xian ', 'Ji ', 'Yin ', 'Za ', 'Yun ', 'Shao ', 'Le ', 'Peng ', 'Heng ', 'Ying ', 'Yun ', 'Peng ', 'Yin ', 'Yin ', 'Xiang ']


Joomla CMS: Référence du fichier TextDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier symfony/console/Descriptor/TextDescriptor.php

Structures de données

class TextDescriptor

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier RequestTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier laminas/laminas-diactoros/src/RequestTrait.php

Espaces de nommage

Laminas\Diactoros

Fonctions

initialize ( $uri=null, string $method=null, $body='php://memory', array $headers=[])
createUri ($uri)
getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
setMethod ($method)
getHostFromUri ()

Variables

trait RequestTrait
$method = 'GET'
$requestTarget
$uri


Joomla CMS: Référence du fichier UriInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/uri/src/UriInterface.php

Structures de données

interface UriInterface

Espaces de nommage

Joomla\Uri


Joomla CMS: Référence du fichier Ristretto255.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier Ristretto255.php

Structures de données

class ParagonIE_Sodium_Core_Ristretto255


Joomla CMS: Référence du fichier Status.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Removal
Structures de données | Espaces de nommage
Référence du fichier com_privacy/src/Removal/Status.php

Structures de données

class Status

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Removal


Joomla CMS: Référence du fichier SubjectAltName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SubjectAltName.php

Structures de données

class SubjectAltName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier UnsetFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier UnsetFilter.php

Structures de données

class UnsetFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier administrator/components/com_finder/helpers/indexer/token.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier SodiumRandomGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier SodiumRandomGenerator.php

Structures de données

class SodiumRandomGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier StreamOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier StreamOutput.php

Structures de données

class StreamOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier Telephone.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Telephone.php

Structures de données

class Telephone

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier password.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier password.php

Espaces de nommage

Joomla\Site

Variables

$document = Factory::getApplication()->getDocument()
$wa = $document->getWebAssetManager()
if($lock) | $ariaDescribedBy = $rules ? $name . '-rules ' : ''
$attributes
if($rules) | if ( $rules)
endif
else __pad8__

Documentation des variables

◆ $ariaDescribedBy

$ariaDescribedBy = $rules ? $name . '-rules ' : ''

◆ $attributes

$attributes
Valeur initiale :
= array(
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
!empty($class) ? 'class="form-control ' . $class . '"' : 'class="form-control"',
!empty($ariaDescribedBy) ? 'aria-describedby="' . trim($ariaDescribedBy) . '"' : '',
$readonly ? 'readonly' : '',
$disabled ? 'disabled' : '',
!empty($size) ? 'size="' . $size . '"' : '',
!empty($maxLength) ? 'maxlength="' . $maxLength . '"' : '',
$required ? 'required' : '',
$autofocus ? 'autofocus' : '',
!empty($minLength) ? 'data-min-length="' . $minLength . '"' : '',
!empty($minIntegers) ? 'data-min-integers="' . $minIntegers . '"' : '',
!empty($minSymbols) ? 'data-min-symbols="' . $minSymbols . '"' : '',
!empty($minUppercase) ? 'data-min-uppercase="' . $minUppercase . '"' : '',
!empty($minLowercase) ? 'data-min-lowercase="' . $minLowercase . '"' : '',
!empty($forcePassword) ? 'data-min-force="' . $forcePassword . '"' : '',
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$size
$size
Definition: slider.php:67
trim
$ariaDescribedBy
if($lock) $ariaDescribedBy
Definition: password.php:86
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ $document

$document = Factory::getApplication()->getDocument()

◆ $wa

$wa = $document->getWebAssetManager()

◆ __pad8__

else __pad8__

◆ endif

endif

◆ if

if ( $rules) if($rules)


Joomla CMS: Référence du fichier RequestExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-client
  • src
Structures de données | Espaces de nommage
Référence du fichier RequestExceptionInterface.php

Structures de données

interface RequestExceptionInterface

Espaces de nommage

Psr\Http\Client


Joomla CMS: Référence du fichier secp160r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp160r2.php

Structures de données

class secp160r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier UserController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Controller/UserController.php

Structures de données

class UserController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier x05d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05d.php

Variables

return ['Lang ', 'Kan ', 'Lao ', 'Lai ', 'Xian ', 'Que ', 'Kong ', 'Chong ', 'Chong ', 'Ta ', 'Lin ', 'Hua ', 'Ju ', 'Lai ', 'Qi ', 'Min ', 'Kun ', 'Kun ', 'Zu ', 'Gu ', 'Cui ', 'Ya ', 'Ya ', 'Gang ', 'Lun ', 'Lun ', 'Leng ', 'Jue ', 'Duo ', 'Zheng ', 'Guo ', 'Yin ', 'Dong ', 'Han ', 'Zheng ', 'Wei ', 'Yao ', 'Pi ', 'Yan ', 'Song ', 'Jie ', 'Beng ', 'Zu ', 'Jue ', 'Dong ', 'Zhan ', 'Gu ', 'Yin ', '[?] ', 'Ze ', 'Huang ', 'Yu ', 'Wei ', 'Yang ', 'Feng ', 'Qiu ', 'Dun ', 'Ti ', 'Yi ', 'Zhi ', 'Shi ', 'Zai ', 'Yao ', 'E ', 'Zhu ', 'Kan ', 'Lu ', 'Yan ', 'Mei ', 'Gan ', 'Ji ', 'Ji ', 'Huan ', 'Ting ', 'Sheng ', 'Mei ', 'Qian ', 'Wu ', 'Yu ', 'Zong ', 'Lan ', 'Jue ', 'Yan ', 'Yan ', 'Wei ', 'Zong ', 'Cha ', 'Sui ', 'Rong ', 'Yamashina ', 'Qin ', 'Yu ', 'Kewashii ', 'Lou ', 'Tu ', 'Dui ', 'Xi ', 'Weng ', 'Cang ', 'Dang ', 'Hong ', 'Jie ', 'Ai ', 'Liu ', 'Wu ', 'Song ', 'Qiao ', 'Zi ', 'Wei ', 'Beng ', 'Dian ', 'Cuo ', 'Qian ', 'Yong ', 'Nie ', 'Cuo ', 'Ji ', '[?] ', 'Tao ', 'Song ', 'Zong ', 'Jiang ', 'Liao ', 'Kang ', 'Chan ', 'Die ', 'Cen ', 'Ding ', 'Tu ', 'Lou ', 'Zhang ', 'Zhan ', 'Zhan ', 'Ao ', 'Cao ', 'Qu ', 'Qiang ', 'Zui ', 'Zui ', 'Dao ', 'Dao ', 'Xi ', 'Yu ', 'Bo ', 'Long ', 'Xiang ', 'Ceng ', 'Bo ', 'Qin ', 'Jiao ', 'Yan ', 'Lao ', 'Zhan ', 'Lin ', 'Liao ', 'Liao ', 'Jin ', 'Deng ', 'Duo ', 'Zun ', 'Jiao ', 'Gui ', 'Yao ', 'Qiao ', 'Yao ', 'Jue ', 'Zhan ', 'Yi ', 'Xue ', 'Nao ', 'Ye ', 'Ye ', 'Yi ', 'E ', 'Xian ', 'Ji ', 'Xie ', 'Ke ', 'Xi ', 'Di ', 'Ao ', 'Zui ', '[?] ', 'Ni ', 'Rong ', 'Dao ', 'Ling ', 'Za ', 'Yu ', 'Yue ', 'Yin ', '[?] ', 'Jie ', 'Li ', 'Sui ', 'Long ', 'Long ', 'Dian ', 'Ying ', 'Xi ', 'Ju ', 'Chan ', 'Ying ', 'Kui ', 'Yan ', 'Wei ', 'Nao ', 'Quan ', 'Chao ', 'Cuan ', 'Luan ', 'Dian ', 'Dian ', '[?] ', 'Yan ', 'Yan ', 'Yan ', 'Nao ', 'Yan ', 'Chuan ', 'Gui ', 'Chuan ', 'Zhou ', 'Huang ', 'Jing ', 'Xun ', 'Chao ', 'Chao ', 'Lie ', 'Gong ', 'Zuo ', 'Qiao ', 'Ju ', 'Gong ', 'Kek ', 'Wu ', 'Pwu ', 'Pwu ', 'Chai ', 'Qiu ', 'Qiu ', 'Ji ', 'Yi ', 'Si ', 'Ba ', 'Zhi ', 'Zhao ', 'Xiang ', 'Yi ', 'Jin ', 'Xun ', 'Juan ', 'Phas ', 'Xun ', 'Jin ', 'Fu ']

Documentation des variables

◆ return

return[ 'Lang ', 'Kan ', 'Lao ', 'Lai ', 'Xian ', 'Que ', 'Kong ', 'Chong ', 'Chong ', 'Ta ', 'Lin ', 'Hua ', 'Ju ', 'Lai ', 'Qi ', 'Min ', 'Kun ', 'Kun ', 'Zu ', 'Gu ', 'Cui ', 'Ya ', 'Ya ', 'Gang ', 'Lun ', 'Lun ', 'Leng ', 'Jue ', 'Duo ', 'Zheng ', 'Guo ', 'Yin ', 'Dong ', 'Han ', 'Zheng ', 'Wei ', 'Yao ', 'Pi ', 'Yan ', 'Song ', 'Jie ', 'Beng ', 'Zu ', 'Jue ', 'Dong ', 'Zhan ', 'Gu ', 'Yin ', '[?] ', 'Ze ', 'Huang ', 'Yu ', 'Wei ', 'Yang ', 'Feng ', 'Qiu ', 'Dun ', 'Ti ', 'Yi ', 'Zhi ', 'Shi ', 'Zai ', 'Yao ', 'E ', 'Zhu ', 'Kan ', 'Lu ', 'Yan ', 'Mei ', 'Gan ', 'Ji ', 'Ji ', 'Huan ', 'Ting ', 'Sheng ', 'Mei ', 'Qian ', 'Wu ', 'Yu ', 'Zong ', 'Lan ', 'Jue ', 'Yan ', 'Yan ', 'Wei ', 'Zong ', 'Cha ', 'Sui ', 'Rong ', 'Yamashina ', 'Qin ', 'Yu ', 'Kewashii ', 'Lou ', 'Tu ', 'Dui ', 'Xi ', 'Weng ', 'Cang ', 'Dang ', 'Hong ', 'Jie ', 'Ai ', 'Liu ', 'Wu ', 'Song ', 'Qiao ', 'Zi ', 'Wei ', 'Beng ', 'Dian ', 'Cuo ', 'Qian ', 'Yong ', 'Nie ', 'Cuo ', 'Ji ', '[?] ', 'Tao ', 'Song ', 'Zong ', 'Jiang ', 'Liao ', 'Kang ', 'Chan ', 'Die ', 'Cen ', 'Ding ', 'Tu ', 'Lou ', 'Zhang ', 'Zhan ', 'Zhan ', 'Ao ', 'Cao ', 'Qu ', 'Qiang ', 'Zui ', 'Zui ', 'Dao ', 'Dao ', 'Xi ', 'Yu ', 'Bo ', 'Long ', 'Xiang ', 'Ceng ', 'Bo ', 'Qin ', 'Jiao ', 'Yan ', 'Lao ', 'Zhan ', 'Lin ', 'Liao ', 'Liao ', 'Jin ', 'Deng ', 'Duo ', 'Zun ', 'Jiao ', 'Gui ', 'Yao ', 'Qiao ', 'Yao ', 'Jue ', 'Zhan ', 'Yi ', 'Xue ', 'Nao ', 'Ye ', 'Ye ', 'Yi ', 'E ', 'Xian ', 'Ji ', 'Xie ', 'Ke ', 'Xi ', 'Di ', 'Ao ', 'Zui ', '[?] ', 'Ni ', 'Rong ', 'Dao ', 'Ling ', 'Za ', 'Yu ', 'Yue ', 'Yin ', '[?] ', 'Jie ', 'Li ', 'Sui ', 'Long ', 'Long ', 'Dian ', 'Ying ', 'Xi ', 'Ju ', 'Chan ', 'Ying ', 'Kui ', 'Yan ', 'Wei ', 'Nao ', 'Quan ', 'Chao ', 'Cuan ', 'Luan ', 'Dian ', 'Dian ', '[?] ', 'Yan ', 'Yan ', 'Yan ', 'Nao ', 'Yan ', 'Chuan ', 'Gui ', 'Chuan ', 'Zhou ', 'Huang ', 'Jing ', 'Xun ', 'Chao ', 'Chao ', 'Lie ', 'Gong ', 'Zuo ', 'Qiao ', 'Ju ', 'Gong ', 'Kek ', 'Wu ', 'Pwu ', 'Pwu ', 'Chai ', 'Qiu ', 'Qiu ', 'Ji ', 'Yi ', 'Si ', 'Ba ', 'Zhi ', 'Zhao ', 'Xiang ', 'Yi ', 'Jin ', 'Xun ', 'Juan ', 'Phas ', 'Xun ', 'Jin ', 'Fu ']


Joomla CMS: Référence du fichier SignalRegistry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • SignalRegistry
Structures de données | Espaces de nommage
Référence du fichier SignalRegistry.php

Structures de données

class SignalRegistry

Espaces de nommage

Symfony\Component\Console\SignalRegistry


Joomla CMS: Référence du fichier ServiceLocatorTest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
  • Test
Structures de données | Espaces de nommage
Référence du fichier ServiceLocatorTest.php

Structures de données

class ServiceLocatorTest

Espaces de nommage

Symfony\Contracts\Service\Test


Joomla CMS: Référence du fichier stristr.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier stristr.php

Espaces de nommage

utf8

Fonctions

utf8_stristr ($str, $search)

Documentation des fonctions

◆ utf8_stristr()

utf8_stristr | ( | $str,
 |  | $search
 | ) |

Références utf8_strtolower().

Référencé par StringHelper\stristr().


Joomla CMS: Référence du fichier repeatable-table.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
Espaces de nommage | Variables
Référence du fichier repeatable-table.php

Espaces de nommage

Joomla\Site

Variables

if($multiple) | $class = $class ? ' ' . $class : ''
$table_head = ''
if(!empty($groupByFieldset)) | else

Documentation des variables

◆ $class

if ( $multiple) $class = $class ? ' ' . $class : ''

◆ $table_head

$table_head = ''

◆ else

if (!empty( $groupByFieldset)) else
Valeur initiale :
{
foreach ($tmpl->getGroup('') as $field) {
$table_head .= '<th scope="col" style="width:45%">' . strip_tags($field->label);
if ($field->description) {
$table_head .= '<span class="icon-info-circle" aria-hidden="true" tabindex="0"></span><div role="tooltip" id="tip-' . $field->id . '">' . Text::_($field->description) . '</div>';
}
$table_head .= '</th>';
}
$sublayout = 'section'
$tmpl
$tmpl
Definition: administrator/components/com_categories/tmpl/category/edit.php:51
$field
$field
Definition: administrator/components/com_users/tmpl/users/modal.php:24
$table_head
$table_head
Definition: repeatable-table.php:48
$sublayout
$sublayout
Definition: repeatable.php:47


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Response/Response.php

Structures de données

class Response

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Response


Joomla CMS: Référence du fichier schedulerunner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • schedulerunner
Structures de données | Espaces de nommage
Référence du fichier schedulerunner.php

Structures de données

class PlgSystemSchedulerunner

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Sidebar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Sidebar.php

Structures de données

class Sidebar

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_redirect/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x09b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09b.php

Variables

return ['Ti ', 'Li ', 'Bin ', 'Zong ', 'Ti ', 'Peng ', 'Song ', 'Zheng ', 'Quan ', 'Zong ', 'Shun ', 'Jian ', 'Duo ', 'Hu ', 'La ', 'Jiu ', 'Qi ', 'Lian ', 'Zhen ', 'Bin ', 'Peng ', 'Mo ', 'San ', 'Man ', 'Man ', 'Seng ', 'Xu ', 'Lie ', 'Qian ', 'Qian ', 'Nong ', 'Huan ', 'Kuai ', 'Ning ', 'Bin ', 'Lie ', 'Rang ', 'Dou ', 'Dou ', 'Nao ', 'Hong ', 'Xi ', 'Dou ', 'Han ', 'Dou ', 'Dou ', 'Jiu ', 'Chang ', 'Yu ', 'Yu ', 'Li ', 'Juan ', 'Fu ', 'Qian ', 'Gui ', 'Zong ', 'Liu ', 'Gui ', 'Shang ', 'Yu ', 'Gui ', 'Mei ', 'Ji ', 'Qi ', 'Jie ', 'Kui ', 'Hun ', 'Ba ', 'Po ', 'Mei ', 'Xu ', 'Yan ', 'Xiao ', 'Liang ', 'Yu ', 'Tui ', 'Qi ', 'Wang ', 'Liang ', 'Wei ', 'Jian ', 'Chi ', 'Piao ', 'Bi ', 'Mo ', 'Ji ', 'Xu ', 'Chou ', 'Yan ', 'Zhan ', 'Yu ', 'Dao ', 'Ren ', 'Ji ', 'Eri ', 'Gong ', 'Tuo ', 'Diao ', 'Ji ', 'Xu ', 'E ', 'E ', 'Sha ', 'Hang ', 'Tun ', 'Mo ', 'Jie ', 'Shen ', 'Fan ', 'Yuan ', 'Bi ', 'Lu ', 'Wen ', 'Hu ', 'Lu ', 'Za ', 'Fang ', 'Fen ', 'Na ', 'You ', 'Namazu ', 'Todo ', 'He ', 'Xia ', 'Qu ', 'Han ', 'Pi ', 'Ling ', 'Tuo ', 'Bo ', 'Qiu ', 'Ping ', 'Fu ', 'Bi ', 'Ji ', 'Wei ', 'Ju ', 'Diao ', 'Bo ', 'You ', 'Gun ', 'Pi ', 'Nian ', 'Xing ', 'Tai ', 'Bao ', 'Fu ', 'Zha ', 'Ju ', 'Gu ', 'Kajika ', 'Tong ', '[?] ', 'Ta ', 'Jie ', 'Shu ', 'Hou ', 'Xiang ', 'Er ', 'An ', 'Wei ', 'Tiao ', 'Zhu ', 'Yin ', 'Lie ', 'Luo ', 'Tong ', 'Yi ', 'Qi ', 'Bing ', 'Wei ', 'Jiao ', 'Bu ', 'Gui ', 'Xian ', 'Ge ', 'Hui ', 'Bora ', 'Mate ', 'Kao ', 'Gori ', 'Duo ', 'Jun ', 'Ti ', 'Man ', 'Xiao ', 'Za ', 'Sha ', 'Qin ', 'Yu ', 'Nei ', 'Zhe ', 'Gun ', 'Geng ', 'Su ', 'Wu ', 'Qiu ', 'Ting ', 'Fu ', 'Wan ', 'You ', 'Li ', 'Sha ', 'Sha ', 'Gao ', 'Meng ', 'Ugui ', 'Asari ', 'Subashiri ', 'Kazunoko ', 'Yong ', 'Ni ', 'Zi ', 'Qi ', 'Qing ', 'Xiang ', 'Nei ', 'Chun ', 'Ji ', 'Diao ', 'Qie ', 'Gu ', 'Zhou ', 'Dong ', 'Lai ', 'Fei ', 'Ni ', 'Yi ', 'Kun ', 'Lu ', 'Jiu ', 'Chang ', 'Jing ', 'Lun ', 'Ling ', 'Zou ', 'Li ', 'Meng ', 'Zong ', 'Zhi ', 'Nian ', 'Shachi ', 'Dojou ', 'Sukesou ', 'Shi ', 'Shen ', 'Hun ', 'Shi ', 'Hou ', 'Xing ', 'Zhu ', 'La ', 'Zong ', 'Ji ', 'Bian ', 'Bian ']

Documentation des variables

◆ return

return[ 'Ti ', 'Li ', 'Bin ', 'Zong ', 'Ti ', 'Peng ', 'Song ', 'Zheng ', 'Quan ', 'Zong ', 'Shun ', 'Jian ', 'Duo ', 'Hu ', 'La ', 'Jiu ', 'Qi ', 'Lian ', 'Zhen ', 'Bin ', 'Peng ', 'Mo ', 'San ', 'Man ', 'Man ', 'Seng ', 'Xu ', 'Lie ', 'Qian ', 'Qian ', 'Nong ', 'Huan ', 'Kuai ', 'Ning ', 'Bin ', 'Lie ', 'Rang ', 'Dou ', 'Dou ', 'Nao ', 'Hong ', 'Xi ', 'Dou ', 'Han ', 'Dou ', 'Dou ', 'Jiu ', 'Chang ', 'Yu ', 'Yu ', 'Li ', 'Juan ', 'Fu ', 'Qian ', 'Gui ', 'Zong ', 'Liu ', 'Gui ', 'Shang ', 'Yu ', 'Gui ', 'Mei ', 'Ji ', 'Qi ', 'Jie ', 'Kui ', 'Hun ', 'Ba ', 'Po ', 'Mei ', 'Xu ', 'Yan ', 'Xiao ', 'Liang ', 'Yu ', 'Tui ', 'Qi ', 'Wang ', 'Liang ', 'Wei ', 'Jian ', 'Chi ', 'Piao ', 'Bi ', 'Mo ', 'Ji ', 'Xu ', 'Chou ', 'Yan ', 'Zhan ', 'Yu ', 'Dao ', 'Ren ', 'Ji ', 'Eri ', 'Gong ', 'Tuo ', 'Diao ', 'Ji ', 'Xu ', 'E ', 'E ', 'Sha ', 'Hang ', 'Tun ', 'Mo ', 'Jie ', 'Shen ', 'Fan ', 'Yuan ', 'Bi ', 'Lu ', 'Wen ', 'Hu ', 'Lu ', 'Za ', 'Fang ', 'Fen ', 'Na ', 'You ', 'Namazu ', 'Todo ', 'He ', 'Xia ', 'Qu ', 'Han ', 'Pi ', 'Ling ', 'Tuo ', 'Bo ', 'Qiu ', 'Ping ', 'Fu ', 'Bi ', 'Ji ', 'Wei ', 'Ju ', 'Diao ', 'Bo ', 'You ', 'Gun ', 'Pi ', 'Nian ', 'Xing ', 'Tai ', 'Bao ', 'Fu ', 'Zha ', 'Ju ', 'Gu ', 'Kajika ', 'Tong ', '[?] ', 'Ta ', 'Jie ', 'Shu ', 'Hou ', 'Xiang ', 'Er ', 'An ', 'Wei ', 'Tiao ', 'Zhu ', 'Yin ', 'Lie ', 'Luo ', 'Tong ', 'Yi ', 'Qi ', 'Bing ', 'Wei ', 'Jiao ', 'Bu ', 'Gui ', 'Xian ', 'Ge ', 'Hui ', 'Bora ', 'Mate ', 'Kao ', 'Gori ', 'Duo ', 'Jun ', 'Ti ', 'Man ', 'Xiao ', 'Za ', 'Sha ', 'Qin ', 'Yu ', 'Nei ', 'Zhe ', 'Gun ', 'Geng ', 'Su ', 'Wu ', 'Qiu ', 'Ting ', 'Fu ', 'Wan ', 'You ', 'Li ', 'Sha ', 'Sha ', 'Gao ', 'Meng ', 'Ugui ', 'Asari ', 'Subashiri ', 'Kazunoko ', 'Yong ', 'Ni ', 'Zi ', 'Qi ', 'Qing ', 'Xiang ', 'Nei ', 'Chun ', 'Ji ', 'Diao ', 'Qie ', 'Gu ', 'Zhou ', 'Dong ', 'Lai ', 'Fei ', 'Ni ', 'Yi ', 'Kun ', 'Lu ', 'Jiu ', 'Chang ', 'Jing ', 'Lun ', 'Ling ', 'Zou ', 'Li ', 'Meng ', 'Zong ', 'Zhi ', 'Nian ', 'Shachi ', 'Dojou ', 'Sukesou ', 'Shi ', 'Shen ', 'Hun ', 'Shi ', 'Hou ', 'Xing ', 'Zhu ', 'La ', 'Zong ', 'Ji ', 'Bian ', 'Bian ']


Joomla CMS: Référence du fichier x010.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x010.php


Joomla CMS: Référence du fichier x0cf.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0cf.php

Variables

return ['ke', 'keg', 'kegg', 'kegs', 'ken', 'kenj', 'kenh', 'ked', 'kel', 'kelg', 'kelm', 'kelb', 'kels', 'kelt', 'kelp', 'kelh', 'kem', 'keb', 'kebs', 'kes', 'kess', 'keng', 'kej', 'kec', 'kek', 'ket', 'kep', 'keh', 'kyeo', 'kyeog', 'kyeogg', 'kyeogs', 'kyeon', 'kyeonj', 'kyeonh', 'kyeod', 'kyeol', 'kyeolg', 'kyeolm', 'kyeolb', 'kyeols', 'kyeolt', 'kyeolp', 'kyeolh', 'kyeom', 'kyeob', 'kyeobs', 'kyeos', 'kyeoss', 'kyeong', 'kyeoj', 'kyeoc', 'kyeok', 'kyeot', 'kyeop', 'kyeoh', 'kye', 'kyeg', 'kyegg', 'kyegs', 'kyen', 'kyenj', 'kyenh', 'kyed', 'kyel', 'kyelg', 'kyelm', 'kyelb', 'kyels', 'kyelt', 'kyelp', 'kyelh', 'kyem', 'kyeb', 'kyebs', 'kyes', 'kyess', 'kyeng', 'kyej', 'kyec', 'kyek', 'kyet', 'kyep', 'kyeh', 'ko', 'kog', 'kogg', 'kogs', 'kon', 'konj', 'konh', 'kod', 'kol', 'kolg', 'kolm', 'kolb', 'kols', 'kolt', 'kolp', 'kolh', 'kom', 'kob', 'kobs', 'kos', 'koss', 'kong', 'koj', 'koc', 'kok', 'kot', 'kop', 'koh', 'kwa', 'kwag', 'kwagg', 'kwags', 'kwan', 'kwanj', 'kwanh', 'kwad', 'kwal', 'kwalg', 'kwalm', 'kwalb', 'kwals', 'kwalt', 'kwalp', 'kwalh', 'kwam', 'kwab', 'kwabs', 'kwas', 'kwass', 'kwang', 'kwaj', 'kwac', 'kwak', 'kwat', 'kwap', 'kwah', 'kwae', 'kwaeg', 'kwaegg', 'kwaegs', 'kwaen', 'kwaenj', 'kwaenh', 'kwaed', 'kwael', 'kwaelg', 'kwaelm', 'kwaelb', 'kwaels', 'kwaelt', 'kwaelp', 'kwaelh', 'kwaem', 'kwaeb', 'kwaebs', 'kwaes', 'kwaess', 'kwaeng', 'kwaej', 'kwaec', 'kwaek', 'kwaet', 'kwaep', 'kwaeh', 'koe', 'koeg', 'koegg', 'koegs', 'koen', 'koenj', 'koenh', 'koed', 'koel', 'koelg', 'koelm', 'koelb', 'koels', 'koelt', 'koelp', 'koelh', 'koem', 'koeb', 'koebs', 'koes', 'koess', 'koeng', 'koej', 'koec', 'koek', 'koet', 'koep', 'koeh', 'kyo', 'kyog', 'kyogg', 'kyogs', 'kyon', 'kyonj', 'kyonh', 'kyod', 'kyol', 'kyolg', 'kyolm', 'kyolb', 'kyols', 'kyolt', 'kyolp', 'kyolh', 'kyom', 'kyob', 'kyobs', 'kyos', 'kyoss', 'kyong', 'kyoj', 'kyoc', 'kyok', 'kyot', 'kyop', 'kyoh', 'ku', 'kug', 'kugg', 'kugs', 'kun', 'kunj', 'kunh', 'kud', 'kul', 'kulg', 'kulm', 'kulb', 'kuls', 'kult', 'kulp', 'kulh', 'kum', 'kub', 'kubs', 'kus', 'kuss', 'kung', 'kuj', 'kuc', 'kuk', 'kut', 'kup', 'kuh', 'kweo', 'kweog', 'kweogg', 'kweogs']

Documentation des variables

◆ return

return[ 'ke', 'keg', 'kegg', 'kegs', 'ken', 'kenj', 'kenh', 'ked', 'kel', 'kelg', 'kelm', 'kelb', 'kels', 'kelt', 'kelp', 'kelh', 'kem', 'keb', 'kebs', 'kes', 'kess', 'keng', 'kej', 'kec', 'kek', 'ket', 'kep', 'keh', 'kyeo', 'kyeog', 'kyeogg', 'kyeogs', 'kyeon', 'kyeonj', 'kyeonh', 'kyeod', 'kyeol', 'kyeolg', 'kyeolm', 'kyeolb', 'kyeols', 'kyeolt', 'kyeolp', 'kyeolh', 'kyeom', 'kyeob', 'kyeobs', 'kyeos', 'kyeoss', 'kyeong', 'kyeoj', 'kyeoc', 'kyeok', 'kyeot', 'kyeop', 'kyeoh', 'kye', 'kyeg', 'kyegg', 'kyegs', 'kyen', 'kyenj', 'kyenh', 'kyed', 'kyel', 'kyelg', 'kyelm', 'kyelb', 'kyels', 'kyelt', 'kyelp', 'kyelh', 'kyem', 'kyeb', 'kyebs', 'kyes', 'kyess', 'kyeng', 'kyej', 'kyec', 'kyek', 'kyet', 'kyep', 'kyeh', 'ko', 'kog', 'kogg', 'kogs', 'kon', 'konj', 'konh', 'kod', 'kol', 'kolg', 'kolm', 'kolb', 'kols', 'kolt', 'kolp', 'kolh', 'kom', 'kob', 'kobs', 'kos', 'koss', 'kong', 'koj', 'koc', 'kok', 'kot', 'kop', 'koh', 'kwa', 'kwag', 'kwagg', 'kwags', 'kwan', 'kwanj', 'kwanh', 'kwad', 'kwal', 'kwalg', 'kwalm', 'kwalb', 'kwals', 'kwalt', 'kwalp', 'kwalh', 'kwam', 'kwab', 'kwabs', 'kwas', 'kwass', 'kwang', 'kwaj', 'kwac', 'kwak', 'kwat', 'kwap', 'kwah', 'kwae', 'kwaeg', 'kwaegg', 'kwaegs', 'kwaen', 'kwaenj', 'kwaenh', 'kwaed', 'kwael', 'kwaelg', 'kwaelm', 'kwaelb', 'kwaels', 'kwaelt', 'kwaelp', 'kwaelh', 'kwaem', 'kwaeb', 'kwaebs', 'kwaes', 'kwaess', 'kwaeng', 'kwaej', 'kwaec', 'kwaek', 'kwaet', 'kwaep', 'kwaeh', 'koe', 'koeg', 'koegg', 'koegs', 'koen', 'koenj', 'koenh', 'koed', 'koel', 'koelg', 'koelm', 'koelb', 'koels', 'koelt', 'koelp', 'koelh', 'koem', 'koeb', 'koebs', 'koes', 'koess', 'koeng', 'koej', 'koec', 'koek', 'koet', 'koep', 'koeh', 'kyo', 'kyog', 'kyogg', 'kyogs', 'kyon', 'kyonj', 'kyonh', 'kyod', 'kyol', 'kyolg', 'kyolm', 'kyolb', 'kyols', 'kyolt', 'kyolp', 'kyolh', 'kyom', 'kyob', 'kyobs', 'kyos', 'kyoss', 'kyong', 'kyoj', 'kyoc', 'kyok', 'kyot', 'kyop', 'kyoh', 'ku', 'kug', 'kugg', 'kugs', 'kun', 'kunj', 'kunh', 'kud', 'kul', 'kulg', 'kulm', 'kulb', 'kuls', 'kult', 'kulp', 'kulh', 'kum', 'kub', 'kubs', 'kus', 'kuss', 'kung', 'kuj', 'kuc', 'kuk', 'kut', 'kup', 'kuh', 'kweo', 'kweog', 'kweogg', 'kweogs']


Joomla CMS: Référence du fichier RS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/RS384.php

Structures de données

class RS384

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier pagenavigation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagenavigation
Structures de données | Espaces de nommage
Référence du fichier pagenavigation.php

Structures de données

class PlgContentPagenavigation

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier publishingdata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier publishingdata.php

Espaces de nommage

Joomla\Site

Variables

$form = $displayData->getForm()
$fields
$hiddenFields = $displayData->get('hidden_fields') ?: array()

Documentation des variables

◆ $fields

$fields
Valeur initiale :
= $displayData->get('fields') ?: array(
'publish_up',
'publish_down',
'featured_up',
'featured_down',
array('created', 'created_time'),
array('created_by', 'created_user_id'),
'created_by_alias',
array('modified', 'modified_time'),
array('modified_by', 'modified_user_id'),
'version',
'hits',
'id'
)
$displayData
$displayData
Definition: administrator/components/com_banners/tmpl/banners/emptystate.php:16

◆ $form

$form = $displayData->getForm()

◆ $hiddenFields

$hiddenFields = $displayData->get('hidden_fields') ?: array()


Joomla CMS: Référence du fichier UTF8String.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier UTF8String.php

Structures de données

class UTF8String

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier RouterLegacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterLegacy.php

Structures de données

class RouterLegacy

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier TemplatenameField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TemplatenameField.php

Structures de données

class TemplatenameField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Field


Joomla CMS: Référence du fichier route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • helpers
Structures de données | Espaces de nommage
Référence du fichier com_tags/helpers/route.php

Structures de données

class TagsHelperRoute

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier XmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • View
  • Export
Structures de données | Espaces de nommage
Référence du fichier com_privacy/src/View/Export/XmlView.php

Structures de données

class XmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\View\Export


Joomla CMS: Référence du fichier PublicKeyCredentialRequestOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialRequestOptions.php

Structures de données

class PublicKeyCredentialRequestOptions

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier UnsupportedAlgorithmException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedAlgorithmException.php

Structures de données

class UnsupportedAlgorithmException

Espaces de nommage

UnsupportedAlgorithmException
phpseclib3\Exception


Joomla CMS: Référence du fichier UploadedFileFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier UploadedFileFactoryInterface.php

Structures de données

interface UploadedFileFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier TableColumnsAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • AssetItem
Structures de données | Espaces de nommage
Référence du fichier TableColumnsAssetItem.php

Structures de données

class TableColumnsAssetItem

Espaces de nommage

Joomla\CMS\WebAsset\AssetItem


Joomla CMS: Référence du fichier Sha256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Hmac
Structures de données | Espaces de nommage
Référence du fichier Hmac/Sha256.php

Structures de données

class Sha256

Espaces de nommage

Lcobucci\JWT\Signer\Hmac


Joomla CMS: Référence du fichier urlinstaller.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • urlinstaller
Structures de données | Espaces de nommage
Référence du fichier urlinstaller.php

Structures de données

class PlgInstallerUrlInstaller

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • French
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/French/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\French


Joomla CMS: Référence du fichier TagModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/Model/TagModel.php

Structures de données

class TagModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Model


Joomla CMS: Référence du fichier StreamFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/StreamFactory.php

Structures de données

class StreamFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier RawDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier RawDocument.php

Structures de données

class RawDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier x032.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x032.php

Variables

return ['(g)', '(n)', '(d)', '(r)', '(m)', '(b)', '(s)', '()', '(j)', '(c)', '(k)', '(t)', '(p)', '(h)', '(ga)', '(na)', '(da)', '(ra)', '(ma)', '(ba)', '(sa)', '(a)', '(ja)', '(ca)', '(ka)', '(ta)', '(pa)', '(ha)', '(ju)', '[?]', '[?]', '[?]', '(1) ', '(2) ', '(3) ', '(4) ', '(5) ', '(6) ', '(7) ', '(8) ', '(9) ', '(10) ', '(Yue) ', '(Huo) ', '(Shui) ', '(Mu) ', '(Jin) ', '(Tu) ', '(Ri) ', '(Zhu) ', '(You) ', '(She) ', '(Ming) ', '(Te) ', '(Cai) ', '(Zhu) ', '(Lao) ', '(Dai) ', '(Hu) ', '(Xue) ', '(Jian) ', '(Qi) ', '(Zi) ', '(Xie) ', '(Ji) ', '(Xiu) ', '<<', '>>', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '21', '22', '23', '24', '25', '26', '27', '28', '29', '30', '31', '32', '33', '34', '35', '(g)', '(n)', '(d)', '(r)', '(m)', '(b)', '(s)', '()', '(j)', '(c)', '(k)', '(t)', '(p)', '(h)', '(ga)', '(na)', '(da)', '(ra)', '(ma)', '(ba)', '(sa)', '(a)', '(ja)', '(ca)', '(ka)', '(ta)', '(pa)', '(ha)', '[?]', '[?]', '[?]', 'KIS ', '(1) ', '(2) ', '(3) ', '(4) ', '(5) ', '(6) ', '(7) ', '(8) ', '(9) ', '(10) ', '(Yue) ', '(Huo) ', '(Shui) ', '(Mu) ', '(Jin) ', '(Tu) ', '(Ri) ', '(Zhu) ', '(You) ', '(She) ', '(Ming) ', '(Te) ', '(Cai) ', '(Zhu) ', '(Lao) ', '(Mi) ', '(Nan) ', '(Nu) ', '(Shi) ', '(You) ', '(Yin) ', '(Zhu) ', '(Xiang) ', '(Xiu) ', '(Xie) ', '(Zheng) ', '(Shang) ', '(Zhong) ', '(Xia) ', '(Zuo) ', '(You) ', '(Yi) ', '(Zong) ', '(Xue) ', '(Jian) ', '(Qi) ', '(Zi) ', '(Xie) ', '(Ye) ', '36', '37', '38', '39', '40', '41', '42', '43', '44', '45', '46', '47', '48', '49', '50', '1M', '2M', '3M', '4M', '5M', '6M', '7M', '8M', '9M', '10M', '11M', '12M', 'Hg', 'erg', 'eV', 'LTD', 'a', 'i', 'u', 'u', 'o', 'ka', 'ki', 'ku', 'ke', 'ko', 'sa', 'si', 'su', 'se', 'so', 'ta', 'ti', 'tu', 'te', 'to', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'hi', 'hu', 'he', 'ho', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'yu', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wi', 'we', 'wo']

Documentation des variables

◆ return

return['(g)', '(n)', '(d)', '(r)', '(m)', '(b)', '(s)', '()', '(j)', '(c)', '(k)', '(t)', '(p)', '(h)', '(ga)', '(na)', '(da)', '(ra)', '(ma)', '(ba)', '(sa)', '(a)', '(ja)', '(ca)', '(ka)', '(ta)', '(pa)', '(ha)', '(ju)', '[?]', '[?]', '[?]', '(1) ', '(2) ', '(3) ', '(4) ', '(5) ', '(6) ', '(7) ', '(8) ', '(9) ', '(10) ', '(Yue) ', '(Huo) ', '(Shui) ', '(Mu) ', '(Jin) ', '(Tu) ', '(Ri) ', '(Zhu) ', '(You) ', '(She) ', '(Ming) ', '(Te) ', '(Cai) ', '(Zhu) ', '(Lao) ', '(Dai) ', '(Hu) ', '(Xue) ', '(Jian) ', '(Qi) ', '(Zi) ', '(Xie) ', '(Ji) ', '(Xiu) ', '<<', '>>', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '21', '22', '23', '24', '25', '26', '27', '28', '29', '30', '31', '32', '33', '34', '35', '(g)', '(n)', '(d)', '(r)', '(m)', '(b)', '(s)', '()', '(j)', '(c)', '(k)', '(t)', '(p)', '(h)', '(ga)', '(na)', '(da)', '(ra)', '(ma)', '(ba)', '(sa)', '(a)', '(ja)', '(ca)', '(ka)', '(ta)', '(pa)', '(ha)', '[?]', '[?]', '[?]', 'KIS ', '(1) ', '(2) ', '(3) ', '(4) ', '(5) ', '(6) ', '(7) ', '(8) ', '(9) ', '(10) ', '(Yue) ', '(Huo) ', '(Shui) ', '(Mu) ', '(Jin) ', '(Tu) ', '(Ri) ', '(Zhu) ', '(You) ', '(She) ', '(Ming) ', '(Te) ', '(Cai) ', '(Zhu) ', '(Lao) ', '(Mi) ', '(Nan) ', '(Nu) ', '(Shi) ', '(You) ', '(Yin) ', '(Zhu) ', '(Xiang) ', '(Xiu) ', '(Xie) ', '(Zheng) ', '(Shang) ', '(Zhong) ', '(Xia) ', '(Zuo) ', '(You) ', '(Yi) ', '(Zong) ', '(Xue) ', '(Jian) ', '(Qi) ', '(Zi) ', '(Xie) ', '(Ye) ', '36', '37', '38', '39', '40', '41', '42', '43', '44', '45', '46', '47', '48', '49', '50', '1M', '2M', '3M', '4M', '5M', '6M', '7M', '8M', '9M', '10M', '11M', '12M', 'Hg', 'erg', 'eV', 'LTD', 'a', 'i', 'u', 'u', 'o', 'ka', 'ki', 'ku', 'ke', 'ko', 'sa', 'si', 'su', 'se', 'so', 'ta', 'ti', 'tu', 'te', 'to', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'hi', 'hu', 'he', 'ho', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'yu', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wi', 'we', 'wo']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier UriFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier UriFactoryInterface.php

Structures de données

interface UriFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier ReshapeArgumentsAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
Espaces de nommage
Référence du fichier ReshapeArgumentsAware.php

Espaces de nommage

Joomla\CMS\Event


Joomla CMS: Référence du fichier Yubikey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Yubikey.php

Structures de données

class Yubikey

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Yubikey\Extension


Joomla CMS: Référence du fichier ToolbarHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Structures de données | Espaces de nommage
Référence du fichier ToolbarHelper.php

Structures de données

class ToolbarHelper

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contact
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contact/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Spanish
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Spanish/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\Spanish


Joomla CMS: Référence du fichier Patterns.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Patterns.php

Structures de données

class Patterns

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier position.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions
Référence du fichier position.php

Espaces de nommage

utf8

Fonctions

utf8_byte_position ()
utf8_locate_current_chr (&$str, $idx)
utf8_locate_next_chr (&$str, $idx)

Documentation des fonctions

◆ utf8_byte_position()

utf8_byte_position ( )

Références $c, $i, Joomla\Database\Query\$offset, $result, utf8_locate_current_chr(), et utf8_locate_next_chr().

◆ utf8_locate_current_chr()

utf8_locate_current_chr | ( | & | $str,
 |  |  | $idx
 | ) |  |

Références $limit.

Référencé par utf8_byte_position().

◆ utf8_locate_next_chr()

utf8_locate_next_chr | ( | & | $str,
 |  |  | $idx
 | ) |  |

Références $limit.

Référencé par utf8_byte_position().


Joomla CMS: Référence du fichier x05f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05f.php

Variables

return ['Kai ', 'Bian ', 'Yi ', 'Qi ', 'Nong ', 'Fen ', 'Ju ', 'Yan ', 'Yi ', 'Zang ', 'Bi ', 'Yi ', 'Yi ', 'Er ', 'San ', 'Shi ', 'Er ', 'Shi ', 'Shi ', 'Gong ', 'Diao ', 'Yin ', 'Hu ', 'Fu ', 'Hong ', 'Wu ', 'Tui ', 'Chi ', 'Jiang ', 'Ba ', 'Shen ', 'Di ', 'Zhang ', 'Jue ', 'Tao ', 'Fu ', 'Di ', 'Mi ', 'Xian ', 'Hu ', 'Chao ', 'Nu ', 'Jing ', 'Zhen ', 'Yi ', 'Mi ', 'Quan ', 'Wan ', 'Shao ', 'Ruo ', 'Xuan ', 'Jing ', 'Dun ', 'Zhang ', 'Jiang ', 'Qiang ', 'Peng ', 'Dan ', 'Qiang ', 'Bi ', 'Bi ', 'She ', 'Dan ', 'Jian ', 'Gou ', 'Sei ', 'Fa ', 'Bi ', 'Kou ', 'Nagi ', 'Bie ', 'Xiao ', 'Dan ', 'Kuo ', 'Qiang ', 'Hong ', 'Mi ', 'Kuo ', 'Wan ', 'Jue ', 'Ji ', 'Ji ', 'Gui ', 'Dang ', 'Lu ', 'Lu ', 'Tuan ', 'Hui ', 'Zhi ', 'Hui ', 'Hui ', 'Yi ', 'Yi ', 'Yi ', 'Yi ', 'Huo ', 'Huo ', 'Shan ', 'Xing ', 'Wen ', 'Tong ', 'Yan ', 'Yan ', 'Yu ', 'Chi ', 'Cai ', 'Biao ', 'Diao ', 'Bin ', 'Peng ', 'Yong ', 'Piao ', 'Zhang ', 'Ying ', 'Chi ', 'Chi ', 'Zhuo ', 'Tuo ', 'Ji ', 'Pang ', 'Zhong ', 'Yi ', 'Wang ', 'Che ', 'Bi ', 'Chi ', 'Ling ', 'Fu ', 'Wang ', 'Zheng ', 'Cu ', 'Wang ', 'Jing ', 'Dai ', 'Xi ', 'Xun ', 'Hen ', 'Yang ', 'Huai ', 'Lu ', 'Hou ', 'Wa ', 'Cheng ', 'Zhi ', 'Xu ', 'Jing ', 'Tu ', 'Cong ', '[?] ', 'Lai ', 'Cong ', 'De ', 'Pai ', 'Xi ', '[?] ', 'Qi ', 'Chang ', 'Zhi ', 'Cong ', 'Zhou ', 'Lai ', 'Yu ', 'Xie ', 'Jie ', 'Jian ', 'Chi ', 'Jia ', 'Bian ', 'Huang ', 'Fu ', 'Xun ', 'Wei ', 'Pang ', 'Yao ', 'Wei ', 'Xi ', 'Zheng ', 'Piao ', 'Chi ', 'De ', 'Zheng ', 'Zheng ', 'Bie ', 'De ', 'Chong ', 'Che ', 'Jiao ', 'Wei ', 'Jiao ', 'Hui ', 'Mei ', 'Long ', 'Xiang ', 'Bao ', 'Qu ', 'Xin ', 'Shu ', 'Bi ', 'Yi ', 'Le ', 'Ren ', 'Dao ', 'Ding ', 'Gai ', 'Ji ', 'Ren ', 'Ren ', 'Chan ', 'Tan ', 'Te ', 'Te ', 'Gan ', 'Qi ', 'Shi ', 'Cun ', 'Zhi ', 'Wang ', 'Mang ', 'Xi ', 'Fan ', 'Ying ', 'Tian ', 'Min ', 'Min ', 'Zhong ', 'Chong ', 'Wu ', 'Ji ', 'Wu ', 'Xi ', 'Ye ', 'You ', 'Wan ', 'Cong ', 'Zhong ', 'Kuai ', 'Yu ', 'Bian ', 'Zhi ', 'Qi ', 'Cui ', 'Chen ', 'Tai ', 'Tun ', 'Qian ', 'Nian ', 'Hun ', 'Xiong ', 'Niu ', 'Wang ', 'Xian ', 'Xin ', 'Kang ', 'Hu ', 'Kai ', 'Fen ']

Documentation des variables

◆ return

return[ 'Kai ', 'Bian ', 'Yi ', 'Qi ', 'Nong ', 'Fen ', 'Ju ', 'Yan ', 'Yi ', 'Zang ', 'Bi ', 'Yi ', 'Yi ', 'Er ', 'San ', 'Shi ', 'Er ', 'Shi ', 'Shi ', 'Gong ', 'Diao ', 'Yin ', 'Hu ', 'Fu ', 'Hong ', 'Wu ', 'Tui ', 'Chi ', 'Jiang ', 'Ba ', 'Shen ', 'Di ', 'Zhang ', 'Jue ', 'Tao ', 'Fu ', 'Di ', 'Mi ', 'Xian ', 'Hu ', 'Chao ', 'Nu ', 'Jing ', 'Zhen ', 'Yi ', 'Mi ', 'Quan ', 'Wan ', 'Shao ', 'Ruo ', 'Xuan ', 'Jing ', 'Dun ', 'Zhang ', 'Jiang ', 'Qiang ', 'Peng ', 'Dan ', 'Qiang ', 'Bi ', 'Bi ', 'She ', 'Dan ', 'Jian ', 'Gou ', 'Sei ', 'Fa ', 'Bi ', 'Kou ', 'Nagi ', 'Bie ', 'Xiao ', 'Dan ', 'Kuo ', 'Qiang ', 'Hong ', 'Mi ', 'Kuo ', 'Wan ', 'Jue ', 'Ji ', 'Ji ', 'Gui ', 'Dang ', 'Lu ', 'Lu ', 'Tuan ', 'Hui ', 'Zhi ', 'Hui ', 'Hui ', 'Yi ', 'Yi ', 'Yi ', 'Yi ', 'Huo ', 'Huo ', 'Shan ', 'Xing ', 'Wen ', 'Tong ', 'Yan ', 'Yan ', 'Yu ', 'Chi ', 'Cai ', 'Biao ', 'Diao ', 'Bin ', 'Peng ', 'Yong ', 'Piao ', 'Zhang ', 'Ying ', 'Chi ', 'Chi ', 'Zhuo ', 'Tuo ', 'Ji ', 'Pang ', 'Zhong ', 'Yi ', 'Wang ', 'Che ', 'Bi ', 'Chi ', 'Ling ', 'Fu ', 'Wang ', 'Zheng ', 'Cu ', 'Wang ', 'Jing ', 'Dai ', 'Xi ', 'Xun ', 'Hen ', 'Yang ', 'Huai ', 'Lu ', 'Hou ', 'Wa ', 'Cheng ', 'Zhi ', 'Xu ', 'Jing ', 'Tu ', 'Cong ', '[?] ', 'Lai ', 'Cong ', 'De ', 'Pai ', 'Xi ', '[?] ', 'Qi ', 'Chang ', 'Zhi ', 'Cong ', 'Zhou ', 'Lai ', 'Yu ', 'Xie ', 'Jie ', 'Jian ', 'Chi ', 'Jia ', 'Bian ', 'Huang ', 'Fu ', 'Xun ', 'Wei ', 'Pang ', 'Yao ', 'Wei ', 'Xi ', 'Zheng ', 'Piao ', 'Chi ', 'De ', 'Zheng ', 'Zheng ', 'Bie ', 'De ', 'Chong ', 'Che ', 'Jiao ', 'Wei ', 'Jiao ', 'Hui ', 'Mei ', 'Long ', 'Xiang ', 'Bao ', 'Qu ', 'Xin ', 'Shu ', 'Bi ', 'Yi ', 'Le ', 'Ren ', 'Dao ', 'Ding ', 'Gai ', 'Ji ', 'Ren ', 'Ren ', 'Chan ', 'Tan ', 'Te ', 'Te ', 'Gan ', 'Qi ', 'Shi ', 'Cun ', 'Zhi ', 'Wang ', 'Mang ', 'Xi ', 'Fan ', 'Ying ', 'Tian ', 'Min ', 'Min ', 'Zhong ', 'Chong ', 'Wu ', 'Ji ', 'Wu ', 'Xi ', 'Ye ', 'You ', 'Wan ', 'Cong ', 'Zhong ', 'Kuai ', 'Yu ', 'Bian ', 'Zhi ', 'Qi ', 'Cui ', 'Chen ', 'Tai ', 'Tun ', 'Qian ', 'Nian ', 'Hun ', 'Xiong ', 'Niu ', 'Wang ', 'Xian ', 'Xin ', 'Kang ', 'Hu ', 'Kai ', 'Fen ']


Joomla CMS: Référence du fichier Version.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/web-auth/metadata-service/src/Version.php

Structures de données

class Version

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier x076.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x076.php

Variables

return ['Yu ', 'Cui ', 'Ya ', 'Zhu ', 'Cu ', 'Dan ', 'Shen ', 'Zhung ', 'Ji ', 'Yu ', 'Hou ', 'Feng ', 'La ', 'Yang ', 'Shen ', 'Tu ', 'Yu ', 'Gua ', 'Wen ', 'Huan ', 'Ku ', 'Jia ', 'Yin ', 'Yi ', 'Lu ', 'Sao ', 'Jue ', 'Chi ', 'Xi ', 'Guan ', 'Yi ', 'Wen ', 'Ji ', 'Chuang ', 'Ban ', 'Lei ', 'Liu ', 'Chai ', 'Shou ', 'Nue ', 'Dian ', 'Da ', 'Pie ', 'Tan ', 'Zhang ', 'Biao ', 'Shen ', 'Cu ', 'Luo ', 'Yi ', 'Zong ', 'Chou ', 'Zhang ', 'Zhai ', 'Sou ', 'Suo ', 'Que ', 'Diao ', 'Lou ', 'Lu ', 'Mo ', 'Jin ', 'Yin ', 'Ying ', 'Huang ', 'Fu ', 'Liao ', 'Long ', 'Qiao ', 'Liu ', 'Lao ', 'Xian ', 'Fei ', 'Dan ', 'Yin ', 'He ', 'Yan ', 'Ban ', 'Xian ', 'Guan ', 'Guai ', 'Nong ', 'Yu ', 'Wei ', 'Yi ', 'Yong ', 'Pi ', 'Lei ', 'Li ', 'Shu ', 'Dan ', 'Lin ', 'Dian ', 'Lin ', 'Lai ', 'Pie ', 'Ji ', 'Chi ', 'Yang ', 'Xian ', 'Jie ', 'Zheng ', '[?] ', 'Li ', 'Huo ', 'Lai ', 'Shaku ', 'Dian ', 'Xian ', 'Ying ', 'Yin ', 'Qu ', 'Yong ', 'Tan ', 'Dian ', 'Luo ', 'Luan ', 'Luan ', 'Bo ', '[?] ', 'Gui ', 'Po ', 'Fa ', 'Deng ', 'Fa ', 'Bai ', 'Bai ', 'Qie ', 'Bi ', 'Zao ', 'Zao ', 'Mao ', 'De ', 'Pa ', 'Jie ', 'Huang ', 'Gui ', 'Ci ', 'Ling ', 'Gao ', 'Mo ', 'Ji ', 'Jiao ', 'Peng ', 'Gao ', 'Ai ', 'E ', 'Hao ', 'Han ', 'Bi ', 'Wan ', 'Chou ', 'Qian ', 'Xi ', 'Ai ', 'Jiong ', 'Hao ', 'Huang ', 'Hao ', 'Ze ', 'Cui ', 'Hao ', 'Xiao ', 'Ye ', 'Po ', 'Hao ', 'Jiao ', 'Ai ', 'Xing ', 'Huang ', 'Li ', 'Piao ', 'He ', 'Jiao ', 'Pi ', 'Gan ', 'Pao ', 'Zhou ', 'Jun ', 'Qiu ', 'Cun ', 'Que ', 'Zha ', 'Gu ', 'Jun ', 'Jun ', 'Zhou ', 'Zha ', 'Gu ', 'Zhan ', 'Du ', 'Min ', 'Qi ', 'Ying ', 'Yu ', 'Bei ', 'Zhao ', 'Zhong ', 'Pen ', 'He ', 'Ying ', 'He ', 'Yi ', 'Bo ', 'Wan ', 'He ', 'Ang ', 'Zhan ', 'Yan ', 'Jian ', 'He ', 'Yu ', 'Kui ', 'Fan ', 'Gai ', 'Dao ', 'Pan ', 'Fu ', 'Qiu ', 'Sheng ', 'Dao ', 'Lu ', 'Zhan ', 'Meng ', 'Li ', 'Jin ', 'Xu ', 'Jian ', 'Pan ', 'Guan ', 'An ', 'Lu ', 'Shu ', 'Zhou ', 'Dang ', 'An ', 'Gu ', 'Li ', 'Mu ', 'Cheng ', 'Gan ', 'Xu ', 'Mang ', 'Mang ', 'Zhi ', 'Qi ', 'Ruan ', 'Tian ', 'Xiang ', 'Dun ', 'Xin ', 'Xi ', 'Pan ', 'Feng ', 'Dun ', 'Min ']

Documentation des variables

◆ return

return[ 'Yu ', 'Cui ', 'Ya ', 'Zhu ', 'Cu ', 'Dan ', 'Shen ', 'Zhung ', 'Ji ', 'Yu ', 'Hou ', 'Feng ', 'La ', 'Yang ', 'Shen ', 'Tu ', 'Yu ', 'Gua ', 'Wen ', 'Huan ', 'Ku ', 'Jia ', 'Yin ', 'Yi ', 'Lu ', 'Sao ', 'Jue ', 'Chi ', 'Xi ', 'Guan ', 'Yi ', 'Wen ', 'Ji ', 'Chuang ', 'Ban ', 'Lei ', 'Liu ', 'Chai ', 'Shou ', 'Nue ', 'Dian ', 'Da ', 'Pie ', 'Tan ', 'Zhang ', 'Biao ', 'Shen ', 'Cu ', 'Luo ', 'Yi ', 'Zong ', 'Chou ', 'Zhang ', 'Zhai ', 'Sou ', 'Suo ', 'Que ', 'Diao ', 'Lou ', 'Lu ', 'Mo ', 'Jin ', 'Yin ', 'Ying ', 'Huang ', 'Fu ', 'Liao ', 'Long ', 'Qiao ', 'Liu ', 'Lao ', 'Xian ', 'Fei ', 'Dan ', 'Yin ', 'He ', 'Yan ', 'Ban ', 'Xian ', 'Guan ', 'Guai ', 'Nong ', 'Yu ', 'Wei ', 'Yi ', 'Yong ', 'Pi ', 'Lei ', 'Li ', 'Shu ', 'Dan ', 'Lin ', 'Dian ', 'Lin ', 'Lai ', 'Pie ', 'Ji ', 'Chi ', 'Yang ', 'Xian ', 'Jie ', 'Zheng ', '[?] ', 'Li ', 'Huo ', 'Lai ', 'Shaku ', 'Dian ', 'Xian ', 'Ying ', 'Yin ', 'Qu ', 'Yong ', 'Tan ', 'Dian ', 'Luo ', 'Luan ', 'Luan ', 'Bo ', '[?] ', 'Gui ', 'Po ', 'Fa ', 'Deng ', 'Fa ', 'Bai ', 'Bai ', 'Qie ', 'Bi ', 'Zao ', 'Zao ', 'Mao ', 'De ', 'Pa ', 'Jie ', 'Huang ', 'Gui ', 'Ci ', 'Ling ', 'Gao ', 'Mo ', 'Ji ', 'Jiao ', 'Peng ', 'Gao ', 'Ai ', 'E ', 'Hao ', 'Han ', 'Bi ', 'Wan ', 'Chou ', 'Qian ', 'Xi ', 'Ai ', 'Jiong ', 'Hao ', 'Huang ', 'Hao ', 'Ze ', 'Cui ', 'Hao ', 'Xiao ', 'Ye ', 'Po ', 'Hao ', 'Jiao ', 'Ai ', 'Xing ', 'Huang ', 'Li ', 'Piao ', 'He ', 'Jiao ', 'Pi ', 'Gan ', 'Pao ', 'Zhou ', 'Jun ', 'Qiu ', 'Cun ', 'Que ', 'Zha ', 'Gu ', 'Jun ', 'Jun ', 'Zhou ', 'Zha ', 'Gu ', 'Zhan ', 'Du ', 'Min ', 'Qi ', 'Ying ', 'Yu ', 'Bei ', 'Zhao ', 'Zhong ', 'Pen ', 'He ', 'Ying ', 'He ', 'Yi ', 'Bo ', 'Wan ', 'He ', 'Ang ', 'Zhan ', 'Yan ', 'Jian ', 'He ', 'Yu ', 'Kui ', 'Fan ', 'Gai ', 'Dao ', 'Pan ', 'Fu ', 'Qiu ', 'Sheng ', 'Dao ', 'Lu ', 'Zhan ', 'Meng ', 'Li ', 'Jin ', 'Xu ', 'Jian ', 'Pan ', 'Guan ', 'An ', 'Lu ', 'Shu ', 'Zhou ', 'Dang ', 'An ', 'Gu ', 'Li ', 'Mu ', 'Cheng ', 'Gan ', 'Xu ', 'Mang ', 'Mang ', 'Zhi ', 'Qi ', 'Ruan ', 'Tian ', 'Xiang ', 'Dun ', 'Xin ', 'Xi ', 'Pan ', 'Feng ', 'Dun ', 'Min ']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x013.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x013.php


Joomla CMS: Référence du fichier SignedIntegerObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier SignedIntegerObject.php

Structures de données

class SignedIntegerObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier RemoveOldFilesCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier RemoveOldFilesCommand.php

Structures de données

class RemoveOldFilesCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier x08e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08e.php

Variables

return ['Chu ', 'Jing ', 'Nie ', 'Xiao ', 'Bo ', 'Chi ', 'Qun ', 'Mou ', 'Shu ', 'Lang ', 'Yong ', 'Jiao ', 'Chou ', 'Qiao ', '[?] ', 'Ta ', 'Jian ', 'Qi ', 'Wo ', 'Wei ', 'Zhuo ', 'Jie ', 'Ji ', 'Nie ', 'Ju ', 'Ju ', 'Lun ', 'Lu ', 'Leng ', 'Huai ', 'Ju ', 'Chi ', 'Wan ', 'Quan ', 'Ti ', 'Bo ', 'Zu ', 'Qie ', 'Ji ', 'Cu ', 'Zong ', 'Cai ', 'Zong ', 'Peng ', 'Zhi ', 'Zheng ', 'Dian ', 'Zhi ', 'Yu ', 'Duo ', 'Dun ', 'Chun ', 'Yong ', 'Zhong ', 'Di ', 'Zhe ', 'Chen ', 'Chuai ', 'Jian ', 'Gua ', 'Tang ', 'Ju ', 'Fu ', 'Zu ', 'Die ', 'Pian ', 'Rou ', 'Nuo ', 'Ti ', 'Cha ', 'Tui ', 'Jian ', 'Dao ', 'Cuo ', 'Xi ', 'Ta ', 'Qiang ', 'Zhan ', 'Dian ', 'Ti ', 'Ji ', 'Nie ', 'Man ', 'Liu ', 'Zhan ', 'Bi ', 'Chong ', 'Lu ', 'Liao ', 'Cu ', 'Tang ', 'Dai ', 'Suo ', 'Xi ', 'Kui ', 'Ji ', 'Zhi ', 'Qiang ', 'Di ', 'Man ', 'Zong ', 'Lian ', 'Beng ', 'Zao ', 'Nian ', 'Bie ', 'Tui ', 'Ju ', 'Deng ', 'Ceng ', 'Xian ', 'Fan ', 'Chu ', 'Zhong ', 'Dun ', 'Bo ', 'Cu ', 'Zu ', 'Jue ', 'Jue ', 'Lin ', 'Ta ', 'Qiao ', 'Qiao ', 'Pu ', 'Liao ', 'Dun ', 'Cuan ', 'Kuang ', 'Zao ', 'Ta ', 'Bi ', 'Bi ', 'Zhu ', 'Ju ', 'Chu ', 'Qiao ', 'Dun ', 'Chou ', 'Ji ', 'Wu ', 'Yue ', 'Nian ', 'Lin ', 'Lie ', 'Zhi ', 'Li ', 'Zhi ', 'Chan ', 'Chu ', 'Duan ', 'Wei ', 'Long ', 'Lin ', 'Xian ', 'Wei ', 'Zuan ', 'Lan ', 'Xie ', 'Rang ', 'Xie ', 'Nie ', 'Ta ', 'Qu ', 'Jie ', 'Cuan ', 'Zuan ', 'Xi ', 'Kui ', 'Jue ', 'Lin ', 'Shen ', 'Gong ', 'Dan ', 'Segare ', 'Qu ', 'Ti ', 'Duo ', 'Duo ', 'Gong ', 'Lang ', 'Nerau ', 'Luo ', 'Ai ', 'Ji ', 'Ju ', 'Tang ', 'Utsuke ', '[?] ', 'Yan ', 'Shitsuke ', 'Kang ', 'Qu ', 'Lou ', 'Lao ', 'Tuo ', 'Zhi ', 'Yagate ', 'Ti ', 'Dao ', 'Yagate ', 'Yu ', 'Che ', 'Ya ', 'Gui ', 'Jun ', 'Wei ', 'Yue ', 'Xin ', 'Di ', 'Xuan ', 'Fan ', 'Ren ', 'Shan ', 'Qiang ', 'Shu ', 'Tun ', 'Chen ', 'Dai ', 'E ', 'Na ', 'Qi ', 'Mao ', 'Ruan ', 'Ren ', 'Fan ', 'Zhuan ', 'Hong ', 'Hu ', 'Qu ', 'Huang ', 'Di ', 'Ling ', 'Dai ', 'Ao ', 'Zhen ', 'Fan ', 'Kuang ', 'Ang ', 'Peng ', 'Bei ', 'Gu ', 'Ku ', 'Pao ', 'Zhu ', 'Rong ', 'E ', 'Ba ', 'Zhou ', 'Zhi ', 'Yao ', 'Ke ', 'Yi ', 'Qing ', 'Shi ', 'Ping ']

Documentation des variables

◆ return

return[ 'Chu ', 'Jing ', 'Nie ', 'Xiao ', 'Bo ', 'Chi ', 'Qun ', 'Mou ', 'Shu ', 'Lang ', 'Yong ', 'Jiao ', 'Chou ', 'Qiao ', '[?] ', 'Ta ', 'Jian ', 'Qi ', 'Wo ', 'Wei ', 'Zhuo ', 'Jie ', 'Ji ', 'Nie ', 'Ju ', 'Ju ', 'Lun ', 'Lu ', 'Leng ', 'Huai ', 'Ju ', 'Chi ', 'Wan ', 'Quan ', 'Ti ', 'Bo ', 'Zu ', 'Qie ', 'Ji ', 'Cu ', 'Zong ', 'Cai ', 'Zong ', 'Peng ', 'Zhi ', 'Zheng ', 'Dian ', 'Zhi ', 'Yu ', 'Duo ', 'Dun ', 'Chun ', 'Yong ', 'Zhong ', 'Di ', 'Zhe ', 'Chen ', 'Chuai ', 'Jian ', 'Gua ', 'Tang ', 'Ju ', 'Fu ', 'Zu ', 'Die ', 'Pian ', 'Rou ', 'Nuo ', 'Ti ', 'Cha ', 'Tui ', 'Jian ', 'Dao ', 'Cuo ', 'Xi ', 'Ta ', 'Qiang ', 'Zhan ', 'Dian ', 'Ti ', 'Ji ', 'Nie ', 'Man ', 'Liu ', 'Zhan ', 'Bi ', 'Chong ', 'Lu ', 'Liao ', 'Cu ', 'Tang ', 'Dai ', 'Suo ', 'Xi ', 'Kui ', 'Ji ', 'Zhi ', 'Qiang ', 'Di ', 'Man ', 'Zong ', 'Lian ', 'Beng ', 'Zao ', 'Nian ', 'Bie ', 'Tui ', 'Ju ', 'Deng ', 'Ceng ', 'Xian ', 'Fan ', 'Chu ', 'Zhong ', 'Dun ', 'Bo ', 'Cu ', 'Zu ', 'Jue ', 'Jue ', 'Lin ', 'Ta ', 'Qiao ', 'Qiao ', 'Pu ', 'Liao ', 'Dun ', 'Cuan ', 'Kuang ', 'Zao ', 'Ta ', 'Bi ', 'Bi ', 'Zhu ', 'Ju ', 'Chu ', 'Qiao ', 'Dun ', 'Chou ', 'Ji ', 'Wu ', 'Yue ', 'Nian ', 'Lin ', 'Lie ', 'Zhi ', 'Li ', 'Zhi ', 'Chan ', 'Chu ', 'Duan ', 'Wei ', 'Long ', 'Lin ', 'Xian ', 'Wei ', 'Zuan ', 'Lan ', 'Xie ', 'Rang ', 'Xie ', 'Nie ', 'Ta ', 'Qu ', 'Jie ', 'Cuan ', 'Zuan ', 'Xi ', 'Kui ', 'Jue ', 'Lin ', 'Shen ', 'Gong ', 'Dan ', 'Segare ', 'Qu ', 'Ti ', 'Duo ', 'Duo ', 'Gong ', 'Lang ', 'Nerau ', 'Luo ', 'Ai ', 'Ji ', 'Ju ', 'Tang ', 'Utsuke ', '[?] ', 'Yan ', 'Shitsuke ', 'Kang ', 'Qu ', 'Lou ', 'Lao ', 'Tuo ', 'Zhi ', 'Yagate ', 'Ti ', 'Dao ', 'Yagate ', 'Yu ', 'Che ', 'Ya ', 'Gui ', 'Jun ', 'Wei ', 'Yue ', 'Xin ', 'Di ', 'Xuan ', 'Fan ', 'Ren ', 'Shan ', 'Qiang ', 'Shu ', 'Tun ', 'Chen ', 'Dai ', 'E ', 'Na ', 'Qi ', 'Mao ', 'Ruan ', 'Ren ', 'Fan ', 'Zhuan ', 'Hong ', 'Hu ', 'Qu ', 'Huang ', 'Di ', 'Ling ', 'Dai ', 'Ao ', 'Zhen ', 'Fan ', 'Kuang ', 'Ang ', 'Peng ', 'Bei ', 'Gu ', 'Ku ', 'Pao ', 'Zhu ', 'Rong ', 'E ', 'Ba ', 'Zhou ', 'Zhi ', 'Yao ', 'Ke ', 'Yi ', 'Qing ', 'Shi ', 'Ping ']


Joomla CMS: Référence du fichier Versionable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Versionable.php

Structures de données

class Versionable

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Behaviour\Versionable\Extension


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier TemplatesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TemplatesController.php

Structures de données

class TemplatesController

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Controller


Joomla CMS: Référence du fichier UnknownArchiveException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnknownArchiveException.php

Structures de données

class UnknownArchiveException

Espaces de nommage

Joomla\Archive\Exception


Joomla CMS: Référence du fichier UCMBase.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • UCM
Structures de données | Espaces de nommage
Référence du fichier UCMBase.php

Structures de données

class UCMBase

Espaces de nommage

Joomla\CMS\UCM


Joomla CMS: Référence du fichier PgsqlExporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pgsql
Structures de données | Espaces de nommage
Référence du fichier PgsqlExporter.php

Structures de données

class PgsqlExporter

Espaces de nommage

Joomla\Database\Pgsql


Joomla CMS: Référence du fichier renderlabel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
Espaces de nommage | Variables
Référence du fichier renderlabel.php

Espaces de nommage

Joomla\Site

Variables

$classes = array_filter((array) $classes)
$id = $for . '-lbl'
if ( $required)

Documentation des variables

◆ $classes

$classes = array_filter((array) $classes)

◆ $id

$id = $for . '-lbl'

◆ if

if(!empty($classes))


Joomla CMS: Référence du fichier StagesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier StagesController.php

Structures de données

class StagesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DSA/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

DSA
phpseclib3\Crypt\DSA


Joomla CMS: Référence du fichier POP3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier POP3.php

Structures de données

class POP3

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier x0d5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d5.php

Variables

return ['pyuk', 'pyut', 'pyup', 'pyuh', 'peu', 'peug', 'peugg', 'peugs', 'peun', 'peunj', 'peunh', 'peud', 'peul', 'peulg', 'peulm', 'peulb', 'peuls', 'peult', 'peulp', 'peulh', 'peum', 'peub', 'peubs', 'peus', 'peuss', 'peung', 'peuj', 'peuc', 'peuk', 'peut', 'peup', 'peuh', 'pyi', 'pyig', 'pyigg', 'pyigs', 'pyin', 'pyinj', 'pyinh', 'pyid', 'pyil', 'pyilg', 'pyilm', 'pyilb', 'pyils', 'pyilt', 'pyilp', 'pyilh', 'pyim', 'pyib', 'pyibs', 'pyis', 'pyiss', 'pying', 'pyij', 'pyic', 'pyik', 'pyit', 'pyip', 'pyih', 'pi', 'pig', 'pigg', 'pigs', 'pin', 'pinj', 'pinh', 'pid', 'pil', 'pilg', 'pilm', 'pilb', 'pils', 'pilt', 'pilp', 'pilh', 'pim', 'pib', 'pibs', 'pis', 'piss', 'ping', 'pij', 'pic', 'pik', 'pit', 'pip', 'pih', 'ha', 'hag', 'hagg', 'hags', 'han', 'hanj', 'hanh', 'had', 'hal', 'halg', 'halm', 'halb', 'hals', 'halt', 'halp', 'halh', 'ham', 'hab', 'habs', 'has', 'hass', 'hang', 'haj', 'hac', 'hak', 'hat', 'hap', 'hah', 'hae', 'haeg', 'haegg', 'haegs', 'haen', 'haenj', 'haenh', 'haed', 'hael', 'haelg', 'haelm', 'haelb', 'haels', 'haelt', 'haelp', 'haelh', 'haem', 'haeb', 'haebs', 'haes', 'haess', 'haeng', 'haej', 'haec', 'haek', 'haet', 'haep', 'haeh', 'hya', 'hyag', 'hyagg', 'hyags', 'hyan', 'hyanj', 'hyanh', 'hyad', 'hyal', 'hyalg', 'hyalm', 'hyalb', 'hyals', 'hyalt', 'hyalp', 'hyalh', 'hyam', 'hyab', 'hyabs', 'hyas', 'hyass', 'hyang', 'hyaj', 'hyac', 'hyak', 'hyat', 'hyap', 'hyah', 'hyae', 'hyaeg', 'hyaegg', 'hyaegs', 'hyaen', 'hyaenj', 'hyaenh', 'hyaed', 'hyael', 'hyaelg', 'hyaelm', 'hyaelb', 'hyaels', 'hyaelt', 'hyaelp', 'hyaelh', 'hyaem', 'hyaeb', 'hyaebs', 'hyaes', 'hyaess', 'hyaeng', 'hyaej', 'hyaec', 'hyaek', 'hyaet', 'hyaep', 'hyaeh', 'heo', 'heog', 'heogg', 'heogs', 'heon', 'heonj', 'heonh', 'heod', 'heol', 'heolg', 'heolm', 'heolb', 'heols', 'heolt', 'heolp', 'heolh', 'heom', 'heob', 'heobs', 'heos', 'heoss', 'heong', 'heoj', 'heoc', 'heok', 'heot', 'heop', 'heoh', 'he', 'heg', 'hegg', 'hegs', 'hen', 'henj', 'henh', 'hed', 'hel', 'helg', 'helm', 'helb', 'hels', 'helt', 'help', 'helh', 'hem', 'heb', 'hebs', 'hes', 'hess', 'heng', 'hej', 'hec', 'hek', 'het', 'hep', 'heh']

Documentation des variables

◆ return

return[ 'pyuk', 'pyut', 'pyup', 'pyuh', 'peu', 'peug', 'peugg', 'peugs', 'peun', 'peunj', 'peunh', 'peud', 'peul', 'peulg', 'peulm', 'peulb', 'peuls', 'peult', 'peulp', 'peulh', 'peum', 'peub', 'peubs', 'peus', 'peuss', 'peung', 'peuj', 'peuc', 'peuk', 'peut', 'peup', 'peuh', 'pyi', 'pyig', 'pyigg', 'pyigs', 'pyin', 'pyinj', 'pyinh', 'pyid', 'pyil', 'pyilg', 'pyilm', 'pyilb', 'pyils', 'pyilt', 'pyilp', 'pyilh', 'pyim', 'pyib', 'pyibs', 'pyis', 'pyiss', 'pying', 'pyij', 'pyic', 'pyik', 'pyit', 'pyip', 'pyih', 'pi', 'pig', 'pigg', 'pigs', 'pin', 'pinj', 'pinh', 'pid', 'pil', 'pilg', 'pilm', 'pilb', 'pils', 'pilt', 'pilp', 'pilh', 'pim', 'pib', 'pibs', 'pis', 'piss', 'ping', 'pij', 'pic', 'pik', 'pit', 'pip', 'pih', 'ha', 'hag', 'hagg', 'hags', 'han', 'hanj', 'hanh', 'had', 'hal', 'halg', 'halm', 'halb', 'hals', 'halt', 'halp', 'halh', 'ham', 'hab', 'habs', 'has', 'hass', 'hang', 'haj', 'hac', 'hak', 'hat', 'hap', 'hah', 'hae', 'haeg', 'haegg', 'haegs', 'haen', 'haenj', 'haenh', 'haed', 'hael', 'haelg', 'haelm', 'haelb', 'haels', 'haelt', 'haelp', 'haelh', 'haem', 'haeb', 'haebs', 'haes', 'haess', 'haeng', 'haej', 'haec', 'haek', 'haet', 'haep', 'haeh', 'hya', 'hyag', 'hyagg', 'hyags', 'hyan', 'hyanj', 'hyanh', 'hyad', 'hyal', 'hyalg', 'hyalm', 'hyalb', 'hyals', 'hyalt', 'hyalp', 'hyalh', 'hyam', 'hyab', 'hyabs', 'hyas', 'hyass', 'hyang', 'hyaj', 'hyac', 'hyak', 'hyat', 'hyap', 'hyah', 'hyae', 'hyaeg', 'hyaegg', 'hyaegs', 'hyaen', 'hyaenj', 'hyaenh', 'hyaed', 'hyael', 'hyaelg', 'hyaelm', 'hyaelb', 'hyaels', 'hyaelt', 'hyaelp', 'hyaelh', 'hyaem', 'hyaeb', 'hyaebs', 'hyaes', 'hyaess', 'hyaeng', 'hyaej', 'hyaec', 'hyaek', 'hyaet', 'hyaep', 'hyaeh', 'heo', 'heog', 'heogg', 'heogs', 'heon', 'heonj', 'heonh', 'heod', 'heol', 'heolg', 'heolm', 'heolb', 'heols', 'heolt', 'heolp', 'heolh', 'heom', 'heob', 'heobs', 'heos', 'heoss', 'heong', 'heoj', 'heoc', 'heok', 'heot', 'heop', 'heoh', 'he', 'heg', 'hegg', 'hegs', 'hen', 'henj', 'henh', 'hed', 'hel', 'helg', 'helm', 'helb', 'hels', 'helt', 'help', 'helh', 'hem', 'heb', 'hebs', 'hes', 'hess', 'heng', 'hej', 'hec', 'hek', 'het', 'hep', 'heh']


Joomla CMS: Référence du fichier TokenBindingHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TokenBinding
Structures de données | Espaces de nommage
Référence du fichier TokenBindingHandler.php

Structures de données

interface TokenBindingHandler

Espaces de nommage

Webauthn\TokenBinding


Joomla CMS: Référence du fichier PhpToken.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Référence du fichier Resources/stubs/PhpToken.php


Joomla CMS: Référence du fichier PublicKeyCredentialUserEntity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialUserEntity.php

Structures de données

class PublicKeyCredentialUserEntity

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier x015.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x015.php

Variables

return ['swa', 'swa', 'swaa', 'swaa', 'swaa', 's', 's', 'sw', 's', 'sk', 'skw', 'sW', 'spwa', 'stwa', 'skwa', 'scwa', 'she', 'shi', 'shii', 'sho', 'shoo', 'sha', 'shaa', 'shwe', 'shwe', 'shwi', 'shwi', 'shwii', 'shwii', 'shwo', 'shwo', 'shwoo', 'shwoo', 'shwa', 'shwa', 'shwaa', 'shwaa', 'sh', 'ye', 'yaai', 'yi', 'yii', 'yo', 'yoo', 'yoo', 'ya', 'yaa', 'ywe', 'ywe', 'ywi', 'ywi', 'ywii', 'ywii', 'ywo', 'ywo', 'ywoo', 'ywoo', 'ywa', 'ywa', 'ywaa', 'ywaa', 'ywaa', 'y', 'y', 'y', 'yi', 're', 're', 'le', 'raai', 'ri', 'rii', 'ro', 'roo', 'lo', 'ra', 'raa', 'la', 'rwaa', 'rwaa', 'r', 'r', 'r', 'fe', 'faai', 'fi', 'fii', 'fo', 'foo', 'fa', 'faa', 'fwaa', 'fwaa', 'f', 'the', 'the', 'thi', 'thi', 'thii', 'thii', 'tho', 'thoo', 'tha', 'thaa', 'thwaa', 'thwaa', 'th', 'tthe', 'tthi', 'ttho', 'ttha', 'tth', 'tye', 'tyi', 'tyo', 'tya', 'he', 'hi', 'hii', 'ho', 'hoo', 'ha', 'haa', 'h', 'h', 'hk', 'qaai', 'qi', 'qii', 'qo', 'qoo', 'qa', 'qaa', 'q', 'tlhe', 'tlhi', 'tlho', 'tlha', 're', 'ri', 'ro', 'ra', 'ngaai', 'ngi', 'ngii', 'ngo', 'ngoo', 'nga', 'ngaa', 'ng', 'nng', 'she', 'shi', 'sho', 'sha', 'the', 'thi', 'tho', 'tha', 'th', 'lhi', 'lhii', 'lho', 'lhoo', 'lha', 'lhaa', 'lh', 'the', 'thi', 'thii', 'tho', 'thoo', 'tha', 'thaa', 'th', 'b', 'e', 'i', 'o', 'a', 'we', 'wi', 'wo', 'wa', 'ne', 'ni', 'no', 'na', 'ke', 'ki', 'ko', 'ka', 'he', 'hi', 'ho', 'ha', 'ghu', 'gho', 'ghe', 'ghee', 'ghi', 'gha', 'ru', 'ro', 're', 'ree', 'ri', 'ra', 'wu', 'wo', 'we', 'wee', 'wi', 'wa', 'hwu', 'hwo', 'hwe', 'hwee', 'hwi', 'hwa', 'thu', 'tho', 'the', 'thee', 'thi', 'tha', 'ttu', 'tto', 'tte', 'ttee', 'tti', 'tta', 'pu', 'po', 'pe', 'pee', 'pi', 'pa', 'p', 'gu', 'go', 'ge', 'gee', 'gi', 'ga', 'khu', 'kho', 'khe', 'khee', 'khi', 'kha', 'kku', 'kko', 'kke', 'kkee', 'kki']

Documentation des variables

◆ return

return[ 'swa', 'swa', 'swaa', 'swaa', 'swaa', 's', 's', 'sw', 's', 'sk', 'skw', 'sW', 'spwa', 'stwa', 'skwa', 'scwa', 'she', 'shi', 'shii', 'sho', 'shoo', 'sha', 'shaa', 'shwe', 'shwe', 'shwi', 'shwi', 'shwii', 'shwii', 'shwo', 'shwo', 'shwoo', 'shwoo', 'shwa', 'shwa', 'shwaa', 'shwaa', 'sh', 'ye', 'yaai', 'yi', 'yii', 'yo', 'yoo', 'yoo', 'ya', 'yaa', 'ywe', 'ywe', 'ywi', 'ywi', 'ywii', 'ywii', 'ywo', 'ywo', 'ywoo', 'ywoo', 'ywa', 'ywa', 'ywaa', 'ywaa', 'ywaa', 'y', 'y', 'y', 'yi', 're', 're', 'le', 'raai', 'ri', 'rii', 'ro', 'roo', 'lo', 'ra', 'raa', 'la', 'rwaa', 'rwaa', 'r', 'r', 'r', 'fe', 'faai', 'fi', 'fii', 'fo', 'foo', 'fa', 'faa', 'fwaa', 'fwaa', 'f', 'the', 'the', 'thi', 'thi', 'thii', 'thii', 'tho', 'thoo', 'tha', 'thaa', 'thwaa', 'thwaa', 'th', 'tthe', 'tthi', 'ttho', 'ttha', 'tth', 'tye', 'tyi', 'tyo', 'tya', 'he', 'hi', 'hii', 'ho', 'hoo', 'ha', 'haa', 'h', 'h', 'hk', 'qaai', 'qi', 'qii', 'qo', 'qoo', 'qa', 'qaa', 'q', 'tlhe', 'tlhi', 'tlho', 'tlha', 're', 'ri', 'ro', 'ra', 'ngaai', 'ngi', 'ngii', 'ngo', 'ngoo', 'nga', 'ngaa', 'ng', 'nng', 'she', 'shi', 'sho', 'sha', 'the', 'thi', 'tho', 'tha', 'th', 'lhi', 'lhii', 'lho', 'lhoo', 'lha', 'lhaa', 'lh', 'the', 'thi', 'thii', 'tho', 'thoo', 'tha', 'thaa', 'th', 'b', 'e', 'i', 'o', 'a', 'we', 'wi', 'wo', 'wa', 'ne', 'ni', 'no', 'na', 'ke', 'ki', 'ko', 'ka', 'he', 'hi', 'ho', 'ha', 'ghu', 'gho', 'ghe', 'ghee', 'ghi', 'gha', 'ru', 'ro', 're', 'ree', 'ri', 'ra', 'wu', 'wo', 'we', 'wee', 'wi', 'wa', 'hwu', 'hwo', 'hwe', 'hwee', 'hwi', 'hwa', 'thu', 'tho', 'the', 'thee', 'thi', 'tha', 'ttu', 'tto', 'tte', 'ttee', 'tti', 'tta', 'pu', 'po', 'pe', 'pee', 'pi', 'pa', 'p', 'gu', 'go', 'ge', 'gee', 'gi', 'ga', 'khu', 'kho', 'khe', 'khee', 'khi', 'kha', 'kku', 'kko', 'kke', 'kkee', 'kki']


Joomla CMS: Référence du fichier x018.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x018.php


Joomla CMS: Référence du fichier TemplateModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_templates/src/Model/TemplateModel.php

Structures de données

class TemplateModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Model


Joomla CMS: Référence du fichier phpmailer.lang-en_gb.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Mail
  • language
Variables
Référence du fichier phpmailer.lang-en_gb.php

Variables

$PHPMAILER_LANG ['authenticate'] = Text::_('PHPMAILER_AUTHENTICATE')
$PHPMAILER_LANG ['connect_host'] = Text::_('PHPMAILER_CONNECT_HOST')
$PHPMAILER_LANG ['data_not_accepted'] = Text::_('PHPMAILER_DATA_NOT_ACCEPTED')
$PHPMAILER_LANG ['empty_message'] = Text::_('PHPMAILER_EMPTY_MESSAGE')
$PHPMAILER_LANG ['encoding'] = Text::_('PHPMAILER_ENCODING')
$PHPMAILER_LANG ['execute'] = Text::_('PHPMAILER_EXECUTE')
$PHPMAILER_LANG ['file_access'] = Text::_('PHPMAILER_FILE_ACCESS')
$PHPMAILER_LANG ['file_open'] = Text::_('PHPMAILER_FILE_OPEN')
$PHPMAILER_LANG ['from_failed'] = Text::_('PHPMAILER_FROM_FAILED')
$PHPMAILER_LANG ['instantiate'] = Text::_('PHPMAILER_INSTANTIATE')
$PHPMAILER_LANG ['invalid_address'] = Text::_('PHPMAILER_INVALID_ADDRESS')
$PHPMAILER_LANG ['mailer_not_supported'] = Text::_('PHPMAILER_MAILER_IS_NOT_SUPPORTED')
$PHPMAILER_LANG ['provide_address'] = Text::_('PHPMAILER_PROVIDE_ADDRESS')
$PHPMAILER_LANG ['recipients_failed'] = Text::_('PHPMAILER_RECIPIENTS_FAILED')
$PHPMAILER_LANG ['signing'] = Text::_('PHPMAILER_SIGNING_ERROR')
$PHPMAILER_LANG ['smtp_connect_failed'] = Text::_('PHPMAILER_SMTP_CONNECT_FAILED')
$PHPMAILER_LANG ['smtp_error'] = Text::_('PHPMAILER_SMTP_ERROR')
$PHPMAILER_LANG ['variable_set'] = Text::_('PHPMAILER_VARIABLE_SET')
$PHPMAILER_LANG ['extension_missing'] = Text::_('PHPMAILER_EXTENSION_MISSING')

Documentation des variables

◆ $PHPMAILER_LANG [1/19]

$PHPMAILER_LANG[ 'authenticate'] = Text::_('PHPMAILER_AUTHENTICATE')

Référencé par PHPMailer\setLanguage().

◆ $PHPMAILER_LANG [2/19]

$PHPMAILER_LANG[ 'connect_host'] = Text::_('PHPMAILER_CONNECT_HOST')

◆ $PHPMAILER_LANG [3/19]

$PHPMAILER_LANG[ 'data_not_accepted'] = Text::_('PHPMAILER_DATA_NOT_ACCEPTED')

◆ $PHPMAILER_LANG [4/19]

$PHPMAILER_LANG[ 'empty_message'] = Text::_('PHPMAILER_EMPTY_MESSAGE')

◆ $PHPMAILER_LANG [5/19]

$PHPMAILER_LANG[ 'encoding'] = Text::_('PHPMAILER_ENCODING')

◆ $PHPMAILER_LANG [6/19]

$PHPMAILER_LANG[ 'execute'] = Text::_('PHPMAILER_EXECUTE')

◆ $PHPMAILER_LANG [7/19]

$PHPMAILER_LANG[ 'file_access'] = Text::_('PHPMAILER_FILE_ACCESS')

◆ $PHPMAILER_LANG [8/19]

$PHPMAILER_LANG[ 'file_open'] = Text::_('PHPMAILER_FILE_OPEN')

◆ $PHPMAILER_LANG [9/19]

$PHPMAILER_LANG[ 'from_failed'] = Text::_('PHPMAILER_FROM_FAILED')

◆ $PHPMAILER_LANG [10/19]

$PHPMAILER_LANG[ 'instantiate'] = Text::_('PHPMAILER_INSTANTIATE')

◆ $PHPMAILER_LANG [11/19]

$PHPMAILER_LANG[ 'invalid_address'] = Text::_('PHPMAILER_INVALID_ADDRESS')

◆ $PHPMAILER_LANG [12/19]

$PHPMAILER_LANG[ 'mailer_not_supported'] = Text::_('PHPMAILER_MAILER_IS_NOT_SUPPORTED')

◆ $PHPMAILER_LANG [13/19]

$PHPMAILER_LANG[ 'provide_address'] = Text::_('PHPMAILER_PROVIDE_ADDRESS')

◆ $PHPMAILER_LANG [14/19]

$PHPMAILER_LANG[ 'recipients_failed'] = Text::_('PHPMAILER_RECIPIENTS_FAILED')

◆ $PHPMAILER_LANG [15/19]

$PHPMAILER_LANG[ 'signing'] = Text::_('PHPMAILER_SIGNING_ERROR')

◆ $PHPMAILER_LANG [16/19]

$PHPMAILER_LANG[ 'smtp_connect_failed'] = Text::_('PHPMAILER_SMTP_CONNECT_FAILED')

◆ $PHPMAILER_LANG [17/19]

$PHPMAILER_LANG[ 'smtp_error'] = Text::_('PHPMAILER_SMTP_ERROR')

◆ $PHPMAILER_LANG [18/19]

$PHPMAILER_LANG[ 'variable_set'] = Text::_('PHPMAILER_VARIABLE_SET')

◆ $PHPMAILER_LANG [19/19]

$PHPMAILER_LANG[ 'extension_missing'] = Text::_('PHPMAILER_EXTENSION_MISSING')


Joomla CMS: Référence du fichier user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • privacy
  • user
Structures de données | Espaces de nommage
Référence du fichier plugins/privacy/user/user.php

Structures de données

class PlgPrivacyUser

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SessionAwareWebApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier SessionAwareWebApplicationInterface.php

Structures de données

interface SessionAwareWebApplicationInterface

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier UnseekableStreamException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnseekableStreamException.php

Structures de données

class UnseekableStreamException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier Signature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/Signature.php

Structures de données

interface Signature

Espaces de nommage

Cose\Algorithm\Signature


Joomla CMS: Référence du fichier QueryElement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Structures de données | Espaces de nommage
Référence du fichier QueryElement.php

Structures de données

class QueryElement

Espaces de nommage

Joomla\Database\Query


Joomla CMS: Référence du fichier ResultTypeIntegerAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeIntegerAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeIntegerAware


Joomla CMS: Référence du fichier Text.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier Text.php

Structures de données

class Text

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_finder/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Service


Joomla CMS: Référence du fichier RedirectField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier RedirectField.php

Structures de données

class RedirectField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Field


Joomla CMS: Référence du fichier WorkflowconditionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier WorkflowconditionField.php

Structures de données

class WorkflowconditionField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Server.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/web-auth/webauthn-lib/src/Server.php

Structures de données

class Server

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier specials.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions
Référence du fichier specials.php

Espaces de nommage

utf8

Fonctions

utf8_specials_pattern ()
utf8_is_word_chars ($str)
utf8_strip_specials ($string, $repl='')

Documentation des fonctions

◆ utf8_is_word_chars()

utf8_is_word_chars ( $str )

Références utf8_specials_pattern().

◆ utf8_specials_pattern()

utf8_specials_pattern ( )

Références utf8_from_unicode().

Référencé par utf8_is_word_chars(), et utf8_strip_specials().

◆ utf8_strip_specials()

utf8_strip_specials | ( | $string,
 |  | $repl = ''
 | ) |

Références utf8_specials_pattern().


Joomla CMS: Référence du fichier x087.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x087.php

Variables

return ['Shu ', 'Xuan ', 'Feng ', 'Shen ', 'Zhen ', 'Fu ', 'Xian ', 'Zhe ', 'Wu ', 'Fu ', 'Li ', 'Lang ', 'Bi ', 'Chu ', 'Yuan ', 'You ', 'Jie ', 'Dan ', 'Yan ', 'Ting ', 'Dian ', 'Shui ', 'Hui ', 'Gua ', 'Zhi ', 'Song ', 'Fei ', 'Ju ', 'Mi ', 'Qi ', 'Qi ', 'Yu ', 'Jun ', 'Zha ', 'Meng ', 'Qiang ', 'Si ', 'Xi ', 'Lun ', 'Li ', 'Die ', 'Tiao ', 'Tao ', 'Kun ', 'Gan ', 'Han ', 'Yu ', 'Bang ', 'Fei ', 'Pi ', 'Wei ', 'Dun ', 'Yi ', 'Yuan ', 'Su ', 'Quan ', 'Qian ', 'Rui ', 'Ni ', 'Qing ', 'Wei ', 'Liang ', 'Guo ', 'Wan ', 'Dong ', 'E ', 'Ban ', 'Di ', 'Wang ', 'Can ', 'Yang ', 'Ying ', 'Guo ', 'Chan ', '[?] ', 'La ', 'Ke ', 'Ji ', 'He ', 'Ting ', 'Mai ', 'Xu ', 'Mian ', 'Yu ', 'Jie ', 'Shi ', 'Xuan ', 'Huang ', 'Yan ', 'Bian ', 'Rou ', 'Wei ', 'Fu ', 'Yuan ', 'Mei ', 'Wei ', 'Fu ', 'Ruan ', 'Xie ', 'You ', 'Qiu ', 'Mao ', 'Xia ', 'Ying ', 'Shi ', 'Chong ', 'Tang ', 'Zhu ', 'Zong ', 'Ti ', 'Fu ', 'Yuan ', 'Hui ', 'Meng ', 'La ', 'Du ', 'Hu ', 'Qiu ', 'Die ', 'Li ', 'Gua ', 'Yun ', 'Ju ', 'Nan ', 'Lou ', 'Qun ', 'Rong ', 'Ying ', 'Jiang ', '[?] ', 'Lang ', 'Pang ', 'Si ', 'Xi ', 'Ci ', 'Xi ', 'Yuan ', 'Weng ', 'Lian ', 'Sou ', 'Ban ', 'Rong ', 'Rong ', 'Ji ', 'Wu ', 'Qiu ', 'Han ', 'Qin ', 'Yi ', 'Bi ', 'Hua ', 'Tang ', 'Yi ', 'Du ', 'Nai ', 'He ', 'Hu ', 'Hui ', 'Ma ', 'Ming ', 'Yi ', 'Wen ', 'Ying ', 'Teng ', 'Yu ', 'Cang ', 'So ', 'Ebi ', 'Man ', '[?] ', 'Shang ', 'Zhe ', 'Cao ', 'Chi ', 'Di ', 'Ao ', 'Lu ', 'Wei ', 'Zhi ', 'Tang ', 'Chen ', 'Piao ', 'Qu ', 'Pi ', 'Yu ', 'Jian ', 'Luo ', 'Lou ', 'Qin ', 'Zhong ', 'Yin ', 'Jiang ', 'Shuai ', 'Wen ', 'Jiao ', 'Wan ', 'Zhi ', 'Zhe ', 'Ma ', 'Ma ', 'Guo ', 'Liu ', 'Mao ', 'Xi ', 'Cong ', 'Li ', 'Man ', 'Xiao ', 'Kamakiri ', 'Zhang ', 'Mang ', 'Xiang ', 'Mo ', 'Zui ', 'Si ', 'Qiu ', 'Te ', 'Zhi ', 'Peng ', 'Peng ', 'Jiao ', 'Qu ', 'Bie ', 'Liao ', 'Pan ', 'Gui ', 'Xi ', 'Ji ', 'Zhuan ', 'Huang ', 'Fei ', 'Lao ', 'Jue ', 'Jue ', 'Hui ', 'Yin ', 'Chan ', 'Jiao ', 'Shan ', 'Rao ', 'Xiao ', 'Mou ', 'Chong ', 'Xun ', 'Si ', '[?] ', 'Cheng ', 'Dang ', 'Li ', 'Xie ', 'Shan ', 'Yi ', 'Jing ', 'Da ', 'Chan ', 'Qi ']

Documentation des variables

◆ return

return[ 'Shu ', 'Xuan ', 'Feng ', 'Shen ', 'Zhen ', 'Fu ', 'Xian ', 'Zhe ', 'Wu ', 'Fu ', 'Li ', 'Lang ', 'Bi ', 'Chu ', 'Yuan ', 'You ', 'Jie ', 'Dan ', 'Yan ', 'Ting ', 'Dian ', 'Shui ', 'Hui ', 'Gua ', 'Zhi ', 'Song ', 'Fei ', 'Ju ', 'Mi ', 'Qi ', 'Qi ', 'Yu ', 'Jun ', 'Zha ', 'Meng ', 'Qiang ', 'Si ', 'Xi ', 'Lun ', 'Li ', 'Die ', 'Tiao ', 'Tao ', 'Kun ', 'Gan ', 'Han ', 'Yu ', 'Bang ', 'Fei ', 'Pi ', 'Wei ', 'Dun ', 'Yi ', 'Yuan ', 'Su ', 'Quan ', 'Qian ', 'Rui ', 'Ni ', 'Qing ', 'Wei ', 'Liang ', 'Guo ', 'Wan ', 'Dong ', 'E ', 'Ban ', 'Di ', 'Wang ', 'Can ', 'Yang ', 'Ying ', 'Guo ', 'Chan ', '[?] ', 'La ', 'Ke ', 'Ji ', 'He ', 'Ting ', 'Mai ', 'Xu ', 'Mian ', 'Yu ', 'Jie ', 'Shi ', 'Xuan ', 'Huang ', 'Yan ', 'Bian ', 'Rou ', 'Wei ', 'Fu ', 'Yuan ', 'Mei ', 'Wei ', 'Fu ', 'Ruan ', 'Xie ', 'You ', 'Qiu ', 'Mao ', 'Xia ', 'Ying ', 'Shi ', 'Chong ', 'Tang ', 'Zhu ', 'Zong ', 'Ti ', 'Fu ', 'Yuan ', 'Hui ', 'Meng ', 'La ', 'Du ', 'Hu ', 'Qiu ', 'Die ', 'Li ', 'Gua ', 'Yun ', 'Ju ', 'Nan ', 'Lou ', 'Qun ', 'Rong ', 'Ying ', 'Jiang ', '[?] ', 'Lang ', 'Pang ', 'Si ', 'Xi ', 'Ci ', 'Xi ', 'Yuan ', 'Weng ', 'Lian ', 'Sou ', 'Ban ', 'Rong ', 'Rong ', 'Ji ', 'Wu ', 'Qiu ', 'Han ', 'Qin ', 'Yi ', 'Bi ', 'Hua ', 'Tang ', 'Yi ', 'Du ', 'Nai ', 'He ', 'Hu ', 'Hui ', 'Ma ', 'Ming ', 'Yi ', 'Wen ', 'Ying ', 'Teng ', 'Yu ', 'Cang ', 'So ', 'Ebi ', 'Man ', '[?] ', 'Shang ', 'Zhe ', 'Cao ', 'Chi ', 'Di ', 'Ao ', 'Lu ', 'Wei ', 'Zhi ', 'Tang ', 'Chen ', 'Piao ', 'Qu ', 'Pi ', 'Yu ', 'Jian ', 'Luo ', 'Lou ', 'Qin ', 'Zhong ', 'Yin ', 'Jiang ', 'Shuai ', 'Wen ', 'Jiao ', 'Wan ', 'Zhi ', 'Zhe ', 'Ma ', 'Ma ', 'Guo ', 'Liu ', 'Mao ', 'Xi ', 'Cong ', 'Li ', 'Man ', 'Xiao ', 'Kamakiri ', 'Zhang ', 'Mang ', 'Xiang ', 'Mo ', 'Zui ', 'Si ', 'Qiu ', 'Te ', 'Zhi ', 'Peng ', 'Peng ', 'Jiao ', 'Qu ', 'Bie ', 'Liao ', 'Pan ', 'Gui ', 'Xi ', 'Ji ', 'Zhuan ', 'Huang ', 'Fei ', 'Lao ', 'Jue ', 'Jue ', 'Hui ', 'Yin ', 'Chan ', 'Jiao ', 'Shan ', 'Rao ', 'Xiao ', 'Mou ', 'Chong ', 'Xun ', 'Si ', '[?] ', 'Cheng ', 'Dang ', 'Li ', 'Xie ', 'Shan ', 'Yi ', 'Jing ', 'Da ', 'Chan ', 'Qi ']


Joomla CMS: Référence du fichier RegisteredClaimGiven.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Structures de données | Espaces de nommage
Référence du fichier RegisteredClaimGiven.php

Structures de données

class RegisteredClaimGiven

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier secp224r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp224r1.php

Structures de données

class secp224r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Uri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/nyholm/psr7/src/Uri.php

Structures de données

class Uri

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier reinstall.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage | Variables
Référence du fichier reinstall.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'
$displayData
endif

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_JOOMLAUPDATE_REINSTALL'

◆ $uploadLink

$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier ToPunycode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Punycode
Structures de données | Espaces de nommage
Référence du fichier ToPunycode.php

Structures de données

class ToPunycode

Espaces de nommage

Algo26\IdnaConvert\Punycode


Joomla CMS: Référence du fichier Romanian.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Romanian.php

Structures de données

class Romanian

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier sect193r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect193r1.php

Structures de données

class sect193r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Smooth.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Smooth.php

Structures de données

class Smooth

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier SessionManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
Structures de données | Espaces de nommage
Référence du fichier SessionManager.php

Structures de données

class SessionManager

Espaces de nommage

Joomla\CMS\Session


Joomla CMS: Référence du fichier TrustPathLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Structures de données | Espaces de nommage
Référence du fichier TrustPathLoader.php

Structures de données

class TrustPathLoader

Espaces de nommage

Webauthn\TrustPath


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/task/requests/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/RS256.php

Structures de données

class RS256

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier TimeGeneratorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier TimeGeneratorFactory.php

Structures de données

class TimeGeneratorFactory

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier separator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier separator.php

Espaces de nommage

Joomla\Site

Variables

if ($is_child) (!empty( $text))
else __pad13__
endif

Documentation des variables

◆ ($is_child)

if ( $is_child)(!empty($text))

◆ __pad13__

else __pad13__

◆ endif

endif


Joomla CMS: Référence du fichier TracedStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
  • PDO
Structures de données | Espaces de nommage
Référence du fichier TracedStatement.php

Structures de données

class TracedStatement

Espaces de nommage

DebugBar\DataCollector\PDO


Joomla CMS: Référence du fichier RsaKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Structures de données | Espaces de nommage
Référence du fichier RsaKey.php

Structures de données

class RsaKey

Espaces de nommage

Cose\Key


Joomla CMS: Référence du fichier StatsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_stats
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier StatsHelper.php

Structures de données

class StatsHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Stats\Site\Helper


Joomla CMS: Référence du fichier Updatesites.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Updatesites.php

Structures de données

class Updatesites

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Service\HTML


Joomla CMS: Référence du fichier StubCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier StubCaster.php

Structures de données

class StubCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_messages/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier RulesFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier RulesFilter.php

Structures de données

class RulesFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier UuidFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier UuidFactory.php

Structures de données

class UuidFactory

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier pagebreak.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • pagebreak
Structures de données | Espaces de nommage
Référence du fichier plugins/editors-xtd/pagebreak/pagebreak.php

Structures de données

class PlgButtonPagebreak

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier secp128r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp128r2.php

Structures de données

class secp128r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Session.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier src/Service/Provider/Session.php

Structures de données

class Session

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier WorkflowComponentSectionsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier WorkflowComponentSectionsField.php

Structures de données

class WorkflowComponentSectionsField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier UriFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier php-http/message-factory/src/UriFactory.php

Structures de données

interface UriFactory

Espaces de nommage

Http\Message


Joomla CMS: Référence du fichier SearchfilterField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier SearchfilterField.php

Structures de données

class SearchfilterField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Field


Joomla CMS: Référence du fichier UploadedFileErrorException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UploadedFileErrorException.php

Structures de données

class UploadedFileErrorException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier RdKafkaCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier RdKafkaCaster.php

Structures de données

class RdKafkaCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Validatable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Claim
Structures de données | Espaces de nommage
Référence du fichier Validatable.php

Structures de données

interface Validatable

Espaces de nommage

Lcobucci\JWT\Claim


Joomla CMS: Référence du fichier ParserException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ParserException.php

Structures de données

class ParserException

Espaces de nommage

FG\ASN1\Exception


Joomla CMS: Référence du fichier ThrowableUtils.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
Structures de données | Espaces de nommage
Référence du fichier ThrowableUtils.php

Structures de données

class ThrowableUtils

Espaces de nommage

Symfony\Component\ErrorHandler


Joomla CMS: Référence du fichier Swedish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Swedish.php

Structures de données

class Swedish

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier x011.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x011.php

Variables

return ['g', 'gg', 'n', 'd', 'dd', 'r', 'm', 'b', 'bb', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', 'ng', 'nn', 'nd', 'nb', 'dg', 'rn', 'rr', 'rh', 'rN', 'mb', 'mN', 'bg', 'bn', '', 'bs', 'bsg', 'bst', 'bsb', 'bss', 'bsj', 'bj', 'bc', 'bt', 'bp', 'bN', 'bbN', 'sg', 'sn', 'sd', 'sr', 'sm', 'sb', 'sbg', 'sss', 's', 'sj', 'sc', 'sk', 'st', 'sp', 'sh', '', '', '', '', 'Z', 'g', 'd', 'm', 'b', 's', 'Z', '', 'j', 'c', 't', 'p', 'N', 'j', '', '', '', '', 'ck', 'ch', '', '', 'pb', 'pN', 'hh', 'Q', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', 'a', 'ae', 'ya', 'yae', 'eo', 'e', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', 'yo', 'u', 'weo', 'we', 'wi', 'yu', 'eu', 'yi', 'i', 'a-o', 'a-u', 'ya-o', 'ya-yo', 'eo-o', 'eo-u', 'eo-eu', 'yeo-o', 'yeo-u', 'o-eo', 'o-e', 'o-ye', 'o-o', 'o-u', 'yo-ya', 'yo-yae', 'yo-yeo', 'yo-o', 'yo-i', 'u-a', 'u-ae', 'u-eo-eu', 'u-ye', 'u-u', 'yu-a', 'yu-eo', 'yu-e', 'yu-yeo', 'yu-ye', 'yu-u', 'yu-i', 'eu-u', 'eu-eu', 'yi-u', 'i-a', 'i-ya', 'i-o', 'i-u', 'i-eu', 'i-U', 'U', 'U-eo', 'U-u', 'U-i', 'UU', '[?]', '[?]', '[?]', '[?]', '[?]', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'l', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'lh', 'm', 'b', 'bs', 's', 'ss', 'ng', 'j', 'c', 'k', 't', 'p', 'h', 'gl', 'gsg', 'ng', 'nd', 'ns', 'nZ', 'nt', 'dg', 'tl', 'lgs', 'ln', 'ld', 'lth', 'll', 'lmg', 'lms', 'lbs', 'lbh', 'rNp', 'lss', 'lZ', 'lk', 'lQ', 'mg', 'ml', 'mb', 'ms', 'mss', 'mZ', 'mc', 'mh', 'mN', 'bl', 'bp', 'ph', 'pN', 'sg', 'sd', 'sl', 'sb', 'Z', 'g', 'ss', '', 'kh', 'N', 'Ns', 'NZ', 'pb', 'pN', 'hn', 'hl', 'hm', 'hb', 'Q', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'g', 'gg', 'n', 'd', 'dd', 'r', 'm', 'b', 'bb', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', 'ng', 'nn', 'nd', 'nb', 'dg', 'rn', 'rr', 'rh', 'rN', 'mb', 'mN', 'bg', 'bn', '', 'bs', 'bsg', 'bst', 'bsb', 'bss', 'bsj', 'bj', 'bc', 'bt', 'bp', 'bN', 'bbN', 'sg', 'sn', 'sd', 'sr', 'sm', 'sb', 'sbg', 'sss', 's', 'sj', 'sc', 'sk', 'st', 'sp', 'sh', '', '', '', '', 'Z', 'g', 'd', 'm', 'b', 's', 'Z', '', 'j', 'c', 't', 'p', 'N', 'j', '', '', '', '', 'ck', 'ch', '', '', 'pb', 'pN', 'hh', 'Q', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', 'a', 'ae', 'ya', 'yae', 'eo', 'e', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', 'yo', 'u', 'weo', 'we', 'wi', 'yu', 'eu', 'yi', 'i', 'a-o', 'a-u', 'ya-o', 'ya-yo', 'eo-o', 'eo-u', 'eo-eu', 'yeo-o', 'yeo-u', 'o-eo', 'o-e', 'o-ye', 'o-o', 'o-u', 'yo-ya', 'yo-yae', 'yo-yeo', 'yo-o', 'yo-i', 'u-a', 'u-ae', 'u-eo-eu', 'u-ye', 'u-u', 'yu-a', 'yu-eo', 'yu-e', 'yu-yeo', 'yu-ye', 'yu-u', 'yu-i', 'eu-u', 'eu-eu', 'yi-u', 'i-a', 'i-ya', 'i-o', 'i-u', 'i-eu', 'i-U', 'U', 'U-eo', 'U-u', 'U-i', 'UU', '[?]', '[?]', '[?]', '[?]', '[?]', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'l', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'lh', 'm', 'b', 'bs', 's', 'ss', 'ng', 'j', 'c', 'k', 't', 'p', 'h', 'gl', 'gsg', 'ng', 'nd', 'ns', 'nZ', 'nt', 'dg', 'tl', 'lgs', 'ln', 'ld', 'lth', 'll', 'lmg', 'lms', 'lbs', 'lbh', 'rNp', 'lss', 'lZ', 'lk', 'lQ', 'mg', 'ml', 'mb', 'ms', 'mss', 'mZ', 'mc', 'mh', 'mN', 'bl', 'bp', 'ph', 'pN', 'sg', 'sd', 'sl', 'sb', 'Z', 'g', 'ss', '', 'kh', 'N', 'Ns', 'NZ', 'pb', 'pN', 'hn', 'hl', 'hm', 'hb', 'Q', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier sql.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • sql
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/sql.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') | $db = Factory::getDbo()
$query = $db->getQuery(true)
$sql = $fieldParams->get('query', '')
$bindNames = $query->bindArray($value, ParameterType::STRING)
try
$items = $db->loadObjectList()
catch(Exception $e) | $texts = array()
foreach ( $items as $item)

Documentation des variables

◆ $bindNames

$bindNames = $query->bindArray($value, ParameterType::STRING)

Référencé par PlgExtensionFinder\addCommonWords().

◆ $db

if ( $value=='') $db = Factory::getDbo()

Référencé par Ucm\__construct(), ContentType\__construct(), Language\__construct(), UpdateSite\__construct(), ViewLevel\__construct(), FeaturedTable\__construct(), Usergroup\__construct(), MenuType\__construct(), MessageTable\__construct(), MapTable\__construct(), UserFactory\__construct(), StyleTable\__construct(), ConsentTable\__construct(), TemplateTable\__construct(), Update\__construct(), LinkTable\__construct(), UpdatesiteTable\__construct(), Module\__construct(), ClientTable\__construct(), NoteTable\__construct(), WorkflowTable\__construct(), StageTable\__construct(), GroupTable\__construct(), Menu\__construct(), FieldTable\__construct(), BannerTable\__construct(), Category\__construct(), RequestTable\__construct(), Content\__construct(), AdapterInstance\__construct(), ContentHistory\__construct(), TransitionTable\__construct(), CredentialRepository\__construct(), TagTable\__construct(), CoreContent\__construct(), FilterTable\__construct(), User\__construct(), Extension\__construct(), NewsfeedTable\__construct(), ContactTable\__construct(), RouterFactory\__construct(), Asset\__construct(), ChangeSet\__construct(), TaskTable\__construct(), Router\__construct(), MfaTable\__construct(), MetadataManager\__construct(), BaseDatabaseModel\__construct(), Workflow\__construct(), UpdateCoreCommand\__construct(), Indexer\__construct(), ChangeItem\__construct(), FinderIndexCommand\__construct(), Table\__construct(), Query\__construct(), ComponentAdapter\_buildAdminMenus(), CategoryModel\_buildContentOrderBy(), PlgContentJoomla\_countItemsInCategory(), PlgContentJoomla\_countItemsInChildren(), PlgContentJoomla\_countItemsInStage(), ExtensionAdapter\_endElement(), Update\_endElement(), GroupTable\_getAssetParentId(), PackageAdapter\_getExtensionId(), InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), Categories\_load(), ModuleAdapter\_rollback_menu(), ModuleAdapter\_rollback_module(), ComponentAdapter\_updateMenus(), Installer\abort(), Task\acquireLock(), RegistrationModel\activate(), LinkModel\activate(), UserHelper\activateUser(), PlgSampledataMultilang\addArticle(), PlgSampledataMultilang\addAssociations(), PlgExtensionFinder\addCommonWords(), Helper\addContentType(), ActionlogModel\addLog(), Taxonomy\addMap(), PlgSampledataMultilang\addModuleInModuleMenu(), MessagesModel\addPostInstallationMessage(), TagsHelper\addTagMapping(), PlgExtensionJoomla\addUpdateSite(), JoomlaInstallerScript\addUserAuthProviderColumn(), UserHelper\addUserToGroup(), admin_postinstall_languageaccess340_condition(), MfaTable\afterDelete(), UpdateModel\applyUpdateSite(), MessagesModel\archiveMessage(), Access\assetgroups(), AdministratorService\association(), Menus\association(), DatabaseModel\backupDatabase(), ItemModel\batchCopy(), ModuleModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), CategoryModel\batchFlipordering(), ItemModel\batchMove(), CategoryModel\batchMove(), LinksModel\batchProcess(), UserModel\batchReset(), UserModel\batchUser(), ContactModel\buildContactExtendedData(), LevelModel\canDelete(), ContentHelper\canDeleteState(), Category\categories(), Usergroup\check(), LinkTable\check(), ViewLevel\check(), StageTable\check(), WorkflowTable\check(), SetConfigurationCommand\checkDb(), DatabaseHelper\checkDbServerParameters(), DiscoverModel\checkExtensions(), CheckinModel\checkin(), TemplateModel\checkNewName(), ConfigurationModel\checkTestingSampledata(), AssociationsModel\clean(), Installer\cleanDiscoveredExtension(), ArticleModel\cleanupPostBatchCopy(), JoomlaInstallerScript\clearStatsCache(), BannerModel\click(), Banner\clientlist(), TagsHelper\convertPathsToNames(), JoomlaInstallerScript\convertTablesToUtf8mb4(), TemplateModel\copyStyles(), NewsfeedsHelper\countItems(), WorkflowsModel\countItems(), ArticlesModel\countItemsByMonth(), HtmlDocument\countMenuChildren(), ContentHelper\countRelations(), NewsfeedsHelper\countTagItems(), DatabaseModel\createDatabase(), DatabaseModel\createDb(), Factory\createDbo(), PlgPrivacyUser\createNotesDomain(), PlgPrivacyUser\createProfileDomain(), ConfigurationModel\createRootUser(), MVCFactory\createTable(), DatabaseModel\createTables(), MailTemplate\createTemplate(), ExecRuleHelper\dateTimeToSql(), MenuTable\delete(), StageTable\delete(), WorkflowTable\delete(), Versioning\delete(), UCMContent\delete(), UpdatesitesModel\delete(), TracksModel\delete(), Usergroup\delete(), ModuleModel\delete(), ActionlogsModel\delete(), AdminModel\delete(), ArticleModel\delete(), MethodsModel\deleteAll(), CoreContent\deleteByContentId(), ContentHistory\deleteOldVersions(), MailTemplate\deleteTemplate(), PlgSampledataMultilang\disableModuleMainMenu(), PlgSystemStats\disablePlugin(), DiscoverModel\discover(), ListUserCommand\doExecute(), DeleteUserCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), JoomlaInstallerScript\dropUtf8ConversionTable(), ModuleModel\duplicate(), LinkModel\duplicateUrls(), Users\editor(), PluginsHelper\elementOptions(), PrivateKey\emsa_pss_encode(), PublicKey\emsa_pss_verify(), PlgSampledataMultilang\enablePlugin(), PSSRSA\encodeEMSAPSS(), RSA\encodeEMSAPSS(), WorkflowStage\existing(), ContentLanguage\existing(), FileAdapter\extensionExistsInSystem(), ContactModel\featured(), ArticleModel\featured(), DatabaseModel\fetchSchemaCache(), LanguageAdapter\finaliseUninstall(), FileAdapter\finaliseUninstall(), LibraryAdapter\finaliseUninstall(), TemplateAdapter\finaliseUninstall(), PluginAdapter\finaliseUninstall(), PackageAdapter\finaliseUninstall(), ComponentAdapter\finaliseUninstall(), UpdateModel\finaliseUpgrade(), DatabaseModel\fix(), DatabaseModel\fixSchemaVersion(), JoomlaInstallerScript\fixTemplateMode(), PluginsHelper\folderOptions(), ListHelper\genericordering(), Versioning\get(), ModulesModel\getActivePositions(), PlgSampledataMultilang\getAdminId(), StyleModel\getAdminTemplate(), ConfigHelper\getAllComponents(), ExtensionsListCommand\getAllExtensionsFromDB(), TemplateModel\getAllTemplateStyles(), FieldTable\getAssetId(), Access\getAssetRules(), ConsentBoxField\getAssignedArticleUrl(), FieldsHelper\getAssignedCategoriesIds(), FieldsHelper\getAssignedCategoriesTitles(), ConsentBoxField\getAssignedMenuItemUrl(), AssociationsHelper\getAssociationHtmlList(), CategoriesHelper\getAssociations(), AssociationHelper\getAssociations(), Associations\getAssociations(), User\getAuthorisedCategories(), Access\getAuthorisedViewLevels(), Taxonomy\getBranchTitles(), TracksModel\getCategoryName(), BannersModel\getCategoryOrders(), UpdateModel\getCheckForSelfUpdate(), TracksModel\getClientName(), BannersHelper\getClientOptions(), Helper\getCommonWords(), MessagesModel\getComponentOptions(), DebugHelper\getComponents(), PlgContentContact\getContactData(), MultilangstatusHelper\getContacts(), MultilangstatusHelper\getContentlangs(), ExtensionHelper\getCoreExtensionIds(), PrivacyDashboardHelper\getData(), StatisticsModel\getData(), DatabaseHelper\getDbo(), MultilangstatusHelper\getDefaultHomeModule(), UpdateModel\getDisabledUpdateSites(), EditorField\getEditor(), TagsModel\getEmptyStateQuery(), AssociationsHelper\getEnabledExtensions(), InstallerHelper\getExtensionDownloadKey(), MenuModel\getExtensionElementsForMenuItems(), InstallerHelper\getExtensionGroups(), MessagesModel\getExtensionName(), ExtensionHelper\getExtensionRecord(), TemplatesModel\getExtensions(), SysinfoModel\getExtensions(), InstallerHelper\getExtensionTypes(), FieldsHelper\getFieldsPluginId(), FinderIndexCommand\getFilters(), TemplateModel\getForm(), DebuggroupModel\getGroup(), AddUserCommand\getGroupId(), AddUserToGroupCommand\getGroupId(), RemoveUserFromGroupCommand\getGroupId(), UserMessagesField\getGroups(), MenuField\getGroups(), ContentmapField\getGroups(), WorkflowstageField\getGroups(), TemplatestyleField\getGroups(), AddUserToGroupCommand\getGroups(), MenuitemField\getGroups(), MenuItemByTypeField\getGroups(), RemoveUserFromGroupCommand\getGroups(), FieldsModel\getGroups(), Access\getGroupsByUser(), Access\getGroupTitle(), ContentHistory\getHashMatch(), MultilangstatusHelper\getHomes(), SysinfoModel\getInfo(), PlugininfoField\getInput(), FieldLayoutField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), RulesField\getInput(), ChangeSet\getInstance(), ChangeItem\getInstance(), Table\getInstance(), InstallerScript\getInstances(), ConfigModel\getItem(), MessagesModel\getItem(), NewsfeedModel\getItem(), UpdatesiteModel\getItem(), MessageModel\getItem(), ContactModel\getItem(), FieldModel\getItem(), ArticleModel\getItem(), ModuleModel\getItem(), InstallerScript\getItemArray(), MenusModel\getItems(), TemplatesModel\getItems(), LanguagesModel\getItems(), PositionsModel\getItems(), UsersModel\getItems(), CheckinModel\getItems(), ClientsModel\getItems(), TagsHelper\getItemTags(), UpdatesitesModel\getJoomlaUpdateSitesIds(), TosField\getLabel(), MultilangstatusHelper\getLangswitchers(), PlgExtensionFinder\getLanguage(), AssociationsHelper\getLanguagefilterPluginId(), CMSHelper\getLanguageId(), ContentHelper\getLanguageId(), LanguagesModel\getLanguageList(), PlgSampledataMultilang\getLanguageList(), TermsField\getLayoutData(), PrivacyField\getLayoutData(), StatsHelper\getList(), TagsPopularHelper\getList(), TagsSimilarHelper\getList(), ArticlesArchiveHelper\getList(), LoggedHelper\getList(), RequestsModel\getListQuery(), FiltersModel\getListQuery(), ConsentsModel\getListQuery(), SuggestionsModel\getListQuery(), NotesModel\getListQuery(), FeaturedModel\getListQuery(), SelectModel\getListQuery(), ActionlogsModel\getListQuery(), ArchiveModel\getListQuery(), TracksModel\getListQuery(), DiscoverModel\getListQuery(), ClientsModel\getListQuery(), UpdateModel\getListQuery(), BannersModel\getListQuery(), LevelsModel\getListQuery(), SearchesModel\getListQuery(), MessagesModel\getListQuery(), TasksModel\getListQuery(), LanguagesModel\getListQuery(), TemplatesModel\getListQuery(), StylesModel\getListQuery(), GroupsModel\getListQuery(), StagesModel\getListQuery(), TransitionsModel\getListQuery(), SearchModel\getListQuery(), LinksModel\getListQuery(), TagModel\getListQuery(), FieldsModel\getListQuery(), ContactsModel\getListQuery(), NewsfeedsModel\getListQuery(), TagsModel\getListQuery(), MenusModel\getListQuery(), AssociationsModel\getListQuery(), CategoriesModel\getListQuery(), MapsModel\getListQuery(), IndexModel\getListQuery(), DebuguserModel\getListQuery(), PluginsModel\getListQuery(), DebuggroupModel\getListQuery(), WorkflowsModel\getListQuery(), ArticlesModel\getListQuery(), ItemsModel\getListQuery(), ModulesModel\getListQuery(), PlgFinderTags\getListQuery(), UsersModel\getListQuery(), ManageModel\getListQuery(), HistoryModel\getListQuery(), PlgFinderNewsfeeds\getListQuery(), DatabaseModel\getListQuery(), PlgFinderContent\getListQuery(), PlgFinderCategories\getListQuery(), PlgFinderContacts\getListQuery(), UpdatesitesModel\getListQuery(), InstallationApplication\getLocaliseAdmin(), ActionlogConfigModel\getLogContentTypeParams(), ActionlogsModel\getLogDataAsIterator(), ActionlogsModel\getLogDataQuery(), ActionlogsModel\getLogsData(), ActionlogsModel\getLogsForItem(), ContenthistoryHelper\getLookupValue(), ItemsModel\getMenu(), MenusHelper\getMenuItems(), LoginModel\getMenuLanguage(), MenusHelper\getMenuLinks(), MenusHelper\getMenuTypes(), DatabaseHelper\getMinimumServerVersion(), MenusModel\getMissingModuleLanguages(), MenusModel\getModMenuId(), MultilangstatusHelper\getModule(), ModulesHelper\getModules(), MenuModel\getModules(), ItemModel\getModules(), Taxonomy\getNodeByTitle(), UpdateModel\getNonCoreExtensions(), UpdateModel\getNonCorePlugins(), PrivacyStatusHelper\getNumberUrgentRequests(), RequestsModel\getNumberUrgentRequests(), MfaTable\getNumRecords(), WhosonlineHelper\getOnlineCount(), WhosonlineHelper\getOnlineUserNames(), FieldgroupsField\getOptions(), FrontendlanguageField\getOptions(), AliastagField\getOptions(), NewsfeedsField\getOptions(), ComponentsField\getOptions(), SearchfilterField\getOptions(), MenuParentField\getOptions(), ExtensionField\getOptions(), ComponentsCategoryField\getOptions(), LogtypeField\getOptions(), MenuOrderingField\getOptions(), ConfigComponentsField\getOptions(), ContenttypesField\getOptions(), ComponentsWorkflowField\getOptions(), ComponentsFieldgroupField\getOptions(), ComponentsFieldsField\getOptions(), AuthorField\getOptions(), LogcreatorField\getOptions(), ContenttypeField\getOptions(), TransitionField\getOptions(), PluginsField\getOptions(), TagField\getOptions(), CategoryeditField\getOptions(), SqlField\getOptions(), IndexModel\getPluginState(), ModulesHelper\getPositions(), TemplateModel\getPreview(), UCMContent\getPrimaryKey(), PrivacyHelper\getPrivacyConsentPluginId(), PluginorderingField\getQuery(), OrderingField\getQuery(), DatabaseFactory\getQuery(), QueryHelper\getQueryDate(), RedirectHelper\getRedirectPluginId(), GroupModel\getReorderConditions(), WorkflowModel\getReorderConditions(), BannerModel\getReorderConditions(), CategoryModel\getReorderConditions(), PluginModel\getReorderConditions(), FieldModel\getReorderConditions(), ItemModel\getReorderConditions(), ModuleModel\getReorderConditions(), PrivacyStatusHelper\getRequestFormPublished(), DatabaseModel\getSchemaVersion(), LanguageAdapter\getSefString(), Multilanguage\getSiteHomePages(), Updater\getSitesWithUpdates(), StyleModel\getSiteTemplates(), ArchiveModel\getSlugColumn(), Indexer\getState(), StatsAdminHelper\getStats(), MultilangstatusHelper\getStatus(), PlgSystemUpdatenotification\getSuperUsers(), TagsHelper\getTagIds(), TagsHelper\getTagItemsQuery(), TagsHelper\getTagNames(), TaskModel\getTask(), Taxonomy\getTaxonomy(), MailTemplate\getTemplate(), TemplateModel\getTemplate(), TemplateModel\getTemplateList(), TemplatesHelper\getTemplateOptions(), ModulesHelper\getTemplates(), ChromestyleField\getTemplates(), Query\getTokenData(), Token\getTokenSeedForUser(), PlgUserToken\getTokenSeedForUser(), FilterModel\getTotal(), IndexModel\getTotalIndexed(), ArticlesModel\getTransitions(), ContentType\getTypeId(), MenutypesModel\getTypeOptions(), TagsHelper\getTypes(), TemplateModel\getUpdatedList(), UpdateModel\getUpdateInformation(), LanguagesModel\getUpdateSite(), UpdateAdapter\getUpdateSiteName(), Updater\getUpdateSites(), UpdateModel\getUpdateSitesInfo(), InstallerHelper\getUpdateSitesInformation(), UsersModel\getUserDisplayedGroups(), FiltersField\getUserGroups(), AddUserCommand\getUserGroups(), AddUserToGroupCommand\getUserId(), UserHelper\getUserId(), RegistrationModel\getUserIdFromToken(), UsersLatestHelper\getUsers(), Access\getUsersByGroup(), ItemModel\getViewLevels(), UsersHelper\getVisibleByGroups(), ArchiveModel\getYears(), DatabaseModel\handleOldDatabase(), PlgUserToken\hasTokenProfileFields(), MessagesModel\hideMessages(), httpheaders_postinstall_action(), BannersModel\impress(), Indexer\index(), ConsentsModel\invalidate(), ConsentsModel\invalidateAll(), Table\isCheckedOut(), Multilanguage\isEnabled(), UpdateModel\isTemplateActive(), Token\isTokenEnabledForUser(), PlgSystemPrivacyconsent\isUserConsented(), Access\level(), Menu\linkOptions(), UserGroupsHelper\load(), PlgInstallerOverride\load(), ActionlogsHelper\loadActionLogPluginsLanguage(), UserGroupsHelper\loadAll(), ManageModel\loadChangelog(), LanguageHelper\loadPluginLanguage(), MenusHelper\loadXml(), FinderHelper\logSearch(), Finder\mapslist(), Menu\menuItems(), Menu\menus(), PlgSystemDebug\onAfterDisconnect(), PlgSystemPrivacyconsent\onAfterRender(), PlgSystemActionLogs\onAfterRespond(), PlgContentJoomla\onContentAfterSave(), PlgContentPagenavigation\onContentBeforeDisplay(), Joomla\onContentChangeState(), PlgContentJoomla\onContentChangeState(), PlgUserProfile\onContentPrepareData(), PlgSystemActionLogs\onContentPrepareData(), PlgExtensionJoomla\onExtensionAfterUninstall(), Adapter\onFinderGarbageCollection(), ContentHelper\onPrepareForm(), PlgPrivacyActionlogs\onPrivacyExportRequest(), PlgPrivacyConsents\onPrivacyExportRequest(), PlgPrivacyMessage\onPrivacyExportRequest(), PlgUserToken\onUserAfterDelete(), PlgUserProfile\onUserAfterDelete(), PlgSystemActionLogs\onUserAfterDelete(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), PlgSystemActionLogs\onUserAfterSave(), PlgAuthenticationJoomla\onUserAuthenticate(), Basic\onUserAuthenticate(), PlgSystemRemember\onUserBeforeSave(), Joomla\onUserLoginFailure(), Indexer\optimize(), Category\options(), Tag\options(), QueryHelper\orderbySecondary(), Menu\ordering(), ModuleController\orderPosition(), TemplateAdapter\parseQueries(), Installer\parseQueries(), Installer\parseSchemaUpdates(), Installer\parseSQLFiles(), DatabaseModel\populateDatabase(), GroupsModel\populateExtraData(), Modules\positionList(), JoomlaInstallerScript\postflight(), WorkflowController\postSaveHook(), Access\preloadComponents(), Access\preloadPermissions(), NewsfeedModel\prepareTable(), BannerModel\prepareTable(), ContactModel\prepareTable(), PluginModel\preprocessForm(), FormModel\preprocessForm(), ExtensionDiscoverInstallCommand\processDiscover(), Query\processDynamicTaxonomy(), SqlField\processQuery(), RemindModel\processRemindRequest(), ResetModel\processResetConfirm(), ResetModel\processResetRequest(), Query\processStaticTaxonomy(), TemplateModel\publish(), LinksModel\purge(), MessagesModel\purge(), OverridesModel\purge(), DiscoverModel\purge(), UpdateModel\purge(), IndexModel\purge(), MapsModel\purge(), AssociationsModel\purge(), FinderIndexCommand\putFilters(), Usergroup\rebuild(), UpdatesitesModel\rebuild(), ItemModel\rebuild(), StringsModel\refresh(), ServiceProviderInterface\register(), Database\register(), RegistrationModel\register(), Task\releaseLock(), PlgSystemPrivacyconsent\remindExpiringConsents(), Indexer\remove(), PlgExtensionFinder\removeCommonWords(), Taxonomy\removeMaps(), Taxonomy\removeOrphanMaps(), Taxonomy\removeOrphanNodes(), MessagesModel\republishMessage(), SearchesModel\reset(), MessagesModel\resetMessages(), LanguageAdapter\resetUserLanguage(), MenusHelper\resolveAlias(), MenusController\resync(), PrivateKey\rsaes_oaep_decrypt(), PublicKey\rsaes_oaep_encrypt(), FieldModel\save(), ConfigModel\save(), UpdatesiteModel\save(), ApplicationModel\save(), StyleModel\save(), CategoryModel\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), LibraryHelper\saveParams(), PlgSystemStats\saveParams(), StringsModel\search(), TagsHelper\searchTags(), Filter\select(), MailModel\send(), ActionlogModel\sendNotificationEmails(), Joomla\Database\setDatabase(), Joomla\CMS\MVC\Model\setDbo(), DatabaseImporter\setDbo(), BaseDatabaseModel\setDbo(), Table\setDbo(), MethodsModel\setFlag(), StyleModel\setHome(), User\setLastVisit(), InstallerScript\setParams(), Installer\setSchemaVersion(), ConfigurationModel\setup(), TemplateAdapter\setupUninstall(), UserHelper\setUserGroups(), Task\skipExecution(), Filter\slider(), Menu\store(), Taxonomy\storeNode(), CoreContent\storeUcmBase(), ArticleModel\storeVote(), MfaTable\switchDefaultRecord(), TagsHelper\tagDeleteInstances(), Tag\tags(), Users\templatestyle(), ExistsRule\test(), UserIdRule\test(), UsernameRule\test(), EmailRule\test(), Indexer\toggleTables(), UpdateAdapter\toggleUpdateSite(), Date\toSql(), UserGroupsHelper\total(), Finder\typeslist(), JoomlaInstallerScript\uninstallEosPlugin(), MessagesModel\unpublishMessage(), StyleModel\unsetHome(), TagsHelper\unTagItem(), JoomlaInstallerScript\updateContentTypes(), TemplatesModel\updated(), JoomlaInstallerScript\updateDatabaseMysql(), Updater\updateLastCheckTimestamp(), JoomlaInstallerScript\updateManifestCaches(), MailTemplate\updateTemplate(), ConfigurationModel\updateUserIds(), User\userlist(), ListHelper\users(), RequestModel\validate(), SetupModel\validateDbConnection(), PSSRSA\verifyEMSAPSS(), et RSA\verifyEMSAPSS().

◆ $items

$items = $db->loadObjectList()

◆ $query

$query = $db->getQuery(true)

◆ $sql

$sql = $fieldParams->get('query', '')

Référencé par DatabaseDriver\execute(), PdoStorage\find(), PdoStorage\get(), PgsqlImporter\getAddSequenceSql(), PgsqlImporter\getChangeSequenceSql(), MysqlImporter\getColumnSql(), MysqliImporter\getColumnSql(), DatabaseDriver\getQuery(), PdoStorage\getSqlQuery(), PropelCollector\log(), DatabaseImporter\mergeStructure(), PropelCollector\parseAndLogSqlQuery(), MysqliStatement\prepareParameterKeyMapping(), SqlsrvStatement\prepareParameterKeyMapping(), TraceablePDO\profileCall(), DatabaseDriver\replacePrefix(), PdoStorage\save(), DatabaseDriver\setQuery(), Installer\splitSql(), LoggingMonitor\startQuery(), ChainedMonitor\startQuery(), et DebugMonitor\startQuery().

◆ $texts

catch (Exception $e) $texts = array()

◆ $value

$value = $field->value

◆ foreach

foreach($items as $item)

◆ try

try
Valeur initiale :
{
$db->setQuery($query)
$db
if($value=='') $db
Definition: tmpl/sql.php:22
$query
$query
Definition: tmpl/sql.php:24


Joomla CMS: Référence du fichier ToolbarPresets.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier ToolbarPresets.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Référence du fichier TemplateHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TemplateHelper.php

Structures de données

class TemplateHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Helper


Joomla CMS: Référence du fichier P1p1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Ge/P1p1.php

Structures de données

class P1p1

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519\Ge


Joomla CMS: Référence du fichier TasksRunCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier TasksRunCommand.php

Structures de données

class TasksRunCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier ViewLevel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier ViewLevel.php

Structures de données

class ViewLevel

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier SerializerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier SerializerInterface.php

Structures de données

interface SerializerInterface

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier TransportInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/http/src/TransportInterface.php

Structures de données

interface TransportInterface

Espaces de nommage

Joomla\Http


Joomla CMS: Référence du fichier x00a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x00a.php

Variables

return ['[?]', '[?]', 'N', '[?]', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', '[?]', 'ee', 'ai', '[?]', '[?]', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bb', 'm', 'y', 'r', '[?]', 'l', 'll', '[?]', 'v', 'sh', '[?]', 's', 'h', '[?]', '[?]', '\'', '[?]', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', '[?]', 'ee', 'ai', '[?]', '[?]', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'khh', 'ghh', 'z', 'rr', '[?]', 'f', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'N', 'H', '', '', 'G.E.O.', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', 'eN', '[?]', 'e', 'ai', 'oN', '[?]', 'o', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'ya', 'r', '[?]', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '\'', '\'', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', 'eN', '[?]', 'e', 'ai', 'oN', '[?]', 'o', 'au', '', '[?]', '[?]', 'AUM', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', 'N', '[?]', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', '[?]', 'ee', 'ai', '[?]', '[?]', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bb', 'm', 'y', 'r', '[?]', 'l', 'll', '[?]', 'v', 'sh', '[?]', 's', 'h', '[?]', '[?]', '\'', '[?]', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', '[?]', 'ee', 'ai', '[?]', '[?]', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'khh', 'ghh', 'z', 'rr', '[?]', 'f', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'N', 'H', '', '', 'G.E.O.', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', 'eN', '[?]', 'e', 'ai', 'oN', '[?]', 'o', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'ya', 'r', '[?]', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '\'', '\'', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', 'eN', '[?]', 'e', 'ai', 'oN', '[?]', 'o', 'au', '', '[?]', '[?]', 'AUM', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier x096.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x096.php

Variables

return ['Fa ', 'Ge ', 'He ', 'Kun ', 'Jiu ', 'Yue ', 'Lang ', 'Du ', 'Yu ', 'Yan ', 'Chang ', 'Xi ', 'Wen ', 'Hun ', 'Yan ', 'E ', 'Chan ', 'Lan ', 'Qu ', 'Hui ', 'Kuo ', 'Que ', 'Ge ', 'Tian ', 'Ta ', 'Que ', 'Kan ', 'Huan ', 'Fu ', 'Fu ', 'Le ', 'Dui ', 'Xin ', 'Qian ', 'Wu ', 'Yi ', 'Tuo ', 'Yin ', 'Yang ', 'Dou ', 'E ', 'Sheng ', 'Ban ', 'Pei ', 'Keng ', 'Yun ', 'Ruan ', 'Zhi ', 'Pi ', 'Jing ', 'Fang ', 'Yang ', 'Yin ', 'Zhen ', 'Jie ', 'Cheng ', 'E ', 'Qu ', 'Di ', 'Zu ', 'Zuo ', 'Dian ', 'Ling ', 'A ', 'Tuo ', 'Tuo ', 'Po ', 'Bing ', 'Fu ', 'Ji ', 'Lu ', 'Long ', 'Chen ', 'Xing ', 'Duo ', 'Lou ', 'Mo ', 'Jiang ', 'Shu ', 'Duo ', 'Xian ', 'Er ', 'Gui ', 'Yu ', 'Gai ', 'Shan ', 'Xun ', 'Qiao ', 'Xing ', 'Chun ', 'Fu ', 'Bi ', 'Xia ', 'Shan ', 'Sheng ', 'Zhi ', 'Pu ', 'Dou ', 'Yuan ', 'Zhen ', 'Chu ', 'Xian ', 'Tou ', 'Nie ', 'Yun ', 'Xian ', 'Pei ', 'Pei ', 'Zou ', 'Yi ', 'Dui ', 'Lun ', 'Yin ', 'Ju ', 'Chui ', 'Chen ', 'Pi ', 'Ling ', 'Tao ', 'Xian ', 'Lu ', 'Sheng ', 'Xian ', 'Yin ', 'Zhu ', 'Yang ', 'Reng ', 'Shan ', 'Chong ', 'Yan ', 'Yin ', 'Yu ', 'Ti ', 'Yu ', 'Long ', 'Wei ', 'Wei ', 'Nie ', 'Dui ', 'Sui ', 'An ', 'Huang ', 'Jie ', 'Sui ', 'Yin ', 'Gai ', 'Yan ', 'Hui ', 'Ge ', 'Yun ', 'Wu ', 'Wei ', 'Ai ', 'Xi ', 'Tang ', 'Ji ', 'Zhang ', 'Dao ', 'Ao ', 'Xi ', 'Yin ', '[?] ', 'Rao ', 'Lin ', 'Tui ', 'Deng ', 'Pi ', 'Sui ', 'Sui ', 'Yu ', 'Xian ', 'Fen ', 'Ni ', 'Er ', 'Ji ', 'Dao ', 'Xi ', 'Yin ', 'E ', 'Hui ', 'Long ', 'Xi ', 'Li ', 'Li ', 'Li ', 'Zhui ', 'He ', 'Zhi ', 'Zhun ', 'Jun ', 'Nan ', 'Yi ', 'Que ', 'Yan ', 'Qian ', 'Ya ', 'Xiong ', 'Ya ', 'Ji ', 'Gu ', 'Huan ', 'Zhi ', 'Gou ', 'Jun ', 'Ci ', 'Yong ', 'Ju ', 'Chu ', 'Hu ', 'Za ', 'Luo ', 'Yu ', 'Chou ', 'Diao ', 'Sui ', 'Han ', 'Huo ', 'Shuang ', 'Guan ', 'Chu ', 'Za ', 'Yong ', 'Ji ', 'Xi ', 'Chou ', 'Liu ', 'Li ', 'Nan ', 'Xue ', 'Za ', 'Ji ', 'Ji ', 'Yu ', 'Yu ', 'Xue ', 'Na ', 'Fou ', 'Se ', 'Mu ', 'Wen ', 'Fen ', 'Pang ', 'Yun ', 'Li ', 'Li ', 'Ang ', 'Ling ', 'Lei ', 'An ', 'Bao ', 'Meng ', 'Dian ', 'Dang ', 'Xing ', 'Wu ', 'Zhao ']

Documentation des variables

◆ return

return[ 'Fa ', 'Ge ', 'He ', 'Kun ', 'Jiu ', 'Yue ', 'Lang ', 'Du ', 'Yu ', 'Yan ', 'Chang ', 'Xi ', 'Wen ', 'Hun ', 'Yan ', 'E ', 'Chan ', 'Lan ', 'Qu ', 'Hui ', 'Kuo ', 'Que ', 'Ge ', 'Tian ', 'Ta ', 'Que ', 'Kan ', 'Huan ', 'Fu ', 'Fu ', 'Le ', 'Dui ', 'Xin ', 'Qian ', 'Wu ', 'Yi ', 'Tuo ', 'Yin ', 'Yang ', 'Dou ', 'E ', 'Sheng ', 'Ban ', 'Pei ', 'Keng ', 'Yun ', 'Ruan ', 'Zhi ', 'Pi ', 'Jing ', 'Fang ', 'Yang ', 'Yin ', 'Zhen ', 'Jie ', 'Cheng ', 'E ', 'Qu ', 'Di ', 'Zu ', 'Zuo ', 'Dian ', 'Ling ', 'A ', 'Tuo ', 'Tuo ', 'Po ', 'Bing ', 'Fu ', 'Ji ', 'Lu ', 'Long ', 'Chen ', 'Xing ', 'Duo ', 'Lou ', 'Mo ', 'Jiang ', 'Shu ', 'Duo ', 'Xian ', 'Er ', 'Gui ', 'Yu ', 'Gai ', 'Shan ', 'Xun ', 'Qiao ', 'Xing ', 'Chun ', 'Fu ', 'Bi ', 'Xia ', 'Shan ', 'Sheng ', 'Zhi ', 'Pu ', 'Dou ', 'Yuan ', 'Zhen ', 'Chu ', 'Xian ', 'Tou ', 'Nie ', 'Yun ', 'Xian ', 'Pei ', 'Pei ', 'Zou ', 'Yi ', 'Dui ', 'Lun ', 'Yin ', 'Ju ', 'Chui ', 'Chen ', 'Pi ', 'Ling ', 'Tao ', 'Xian ', 'Lu ', 'Sheng ', 'Xian ', 'Yin ', 'Zhu ', 'Yang ', 'Reng ', 'Shan ', 'Chong ', 'Yan ', 'Yin ', 'Yu ', 'Ti ', 'Yu ', 'Long ', 'Wei ', 'Wei ', 'Nie ', 'Dui ', 'Sui ', 'An ', 'Huang ', 'Jie ', 'Sui ', 'Yin ', 'Gai ', 'Yan ', 'Hui ', 'Ge ', 'Yun ', 'Wu ', 'Wei ', 'Ai ', 'Xi ', 'Tang ', 'Ji ', 'Zhang ', 'Dao ', 'Ao ', 'Xi ', 'Yin ', '[?] ', 'Rao ', 'Lin ', 'Tui ', 'Deng ', 'Pi ', 'Sui ', 'Sui ', 'Yu ', 'Xian ', 'Fen ', 'Ni ', 'Er ', 'Ji ', 'Dao ', 'Xi ', 'Yin ', 'E ', 'Hui ', 'Long ', 'Xi ', 'Li ', 'Li ', 'Li ', 'Zhui ', 'He ', 'Zhi ', 'Zhun ', 'Jun ', 'Nan ', 'Yi ', 'Que ', 'Yan ', 'Qian ', 'Ya ', 'Xiong ', 'Ya ', 'Ji ', 'Gu ', 'Huan ', 'Zhi ', 'Gou ', 'Jun ', 'Ci ', 'Yong ', 'Ju ', 'Chu ', 'Hu ', 'Za ', 'Luo ', 'Yu ', 'Chou ', 'Diao ', 'Sui ', 'Han ', 'Huo ', 'Shuang ', 'Guan ', 'Chu ', 'Za ', 'Yong ', 'Ji ', 'Xi ', 'Chou ', 'Liu ', 'Li ', 'Nan ', 'Xue ', 'Za ', 'Ji ', 'Ji ', 'Yu ', 'Yu ', 'Xue ', 'Na ', 'Fou ', 'Se ', 'Mu ', 'Wen ', 'Fen ', 'Pang ', 'Yun ', 'Li ', 'Li ', 'Ang ', 'Ling ', 'Lei ', 'An ', 'Bao ', 'Meng ', 'Dian ', 'Dang ', 'Xing ', 'Wu ', 'Zhao ']


Joomla CMS: Référence du fichier section-byfieldsets.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable
Espaces de nommage | Variables
Référence du fichier section-byfieldsets.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier StringsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Controller/StringsController.php

Structures de données

class StringsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier SaveExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier SaveExceptionHandler.php

Structures de données

class SaveExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier SymfonyQuestionHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier SymfonyQuestionHelper.php

Structures de données

class SymfonyQuestionHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier x0a2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0a2.php

Variables

return ['kax', 'ka', 'kap', 'kuox', 'kuo', 'kuop', 'kot', 'kox', 'ko', 'kop', 'ket', 'kex', 'ke', 'kep', 'kut', 'kux', 'ku', 'kup', 'kurx', 'kur', 'ggit', 'ggix', 'ggi', 'ggiex', 'ggie', 'ggiep', 'ggat', 'ggax', 'gga', 'ggap', 'gguot', 'gguox', 'gguo', 'gguop', 'ggot', 'ggox', 'ggo', 'ggop', 'gget', 'ggex', 'gge', 'ggep', 'ggut', 'ggux', 'ggu', 'ggup', 'ggurx', 'ggur', 'mgiex', 'mgie', 'mgat', 'mgax', 'mga', 'mgap', 'mguox', 'mguo', 'mguop', 'mgot', 'mgox', 'mgo', 'mgop', 'mgex', 'mge', 'mgep', 'mgut', 'mgux', 'mgu', 'mgup', 'mgurx', 'mgur', 'hxit', 'hxix', 'hxi', 'hxip', 'hxiet', 'hxiex', 'hxie', 'hxiep', 'hxat', 'hxax', 'hxa', 'hxap', 'hxuot', 'hxuox', 'hxuo', 'hxuop', 'hxot', 'hxox', 'hxo', 'hxop', 'hxex', 'hxe', 'hxep', 'ngiex', 'ngie', 'ngiep', 'ngat', 'ngax', 'nga', 'ngap', 'nguot', 'nguox', 'nguo', 'ngot', 'ngox', 'ngo', 'ngop', 'ngex', 'nge', 'ngep', 'hit', 'hiex', 'hie', 'hat', 'hax', 'ha', 'hap', 'huot', 'huox', 'huo', 'huop', 'hot', 'hox', 'ho', 'hop', 'hex', 'he', 'hep', 'wat', 'wax', 'wa', 'wap', 'wuox', 'wuo', 'wuop', 'wox', 'wo', 'wop', 'wex', 'we', 'wep', 'zit', 'zix', 'zi', 'zip', 'ziex', 'zie', 'ziep', 'zat', 'zax', 'za', 'zap', 'zuox', 'zuo', 'zuop', 'zot', 'zox', 'zo', 'zop', 'zex', 'ze', 'zep', 'zut', 'zux', 'zu', 'zup', 'zurx', 'zur', 'zyt', 'zyx', 'zy', 'zyp', 'zyrx', 'zyr', 'cit', 'cix', 'ci', 'cip', 'ciet', 'ciex', 'cie', 'ciep', 'cat', 'cax', 'ca', 'cap', 'cuox', 'cuo', 'cuop', 'cot', 'cox', 'co', 'cop', 'cex', 'ce', 'cep', 'cut', 'cux', 'cu', 'cup', 'curx', 'cur', 'cyt', 'cyx', 'cy', 'cyp', 'cyrx', 'cyr', 'zzit', 'zzix', 'zzi', 'zzip', 'zziet', 'zziex', 'zzie', 'zziep', 'zzat', 'zzax', 'zza', 'zzap', 'zzox', 'zzo', 'zzop', 'zzex', 'zze', 'zzep', 'zzux', 'zzu', 'zzup', 'zzurx', 'zzur', 'zzyt', 'zzyx', 'zzy', 'zzyp', 'zzyrx', 'zzyr', 'nzit', 'nzix', 'nzi', 'nzip', 'nziex', 'nzie', 'nziep', 'nzat', 'nzax', 'nza', 'nzap', 'nzuox', 'nzuo', 'nzox', 'nzop', 'nzex', 'nze', 'nzux', 'nzu']

Documentation des variables

◆ return

return[ 'kax', 'ka', 'kap', 'kuox', 'kuo', 'kuop', 'kot', 'kox', 'ko', 'kop', 'ket', 'kex', 'ke', 'kep', 'kut', 'kux', 'ku', 'kup', 'kurx', 'kur', 'ggit', 'ggix', 'ggi', 'ggiex', 'ggie', 'ggiep', 'ggat', 'ggax', 'gga', 'ggap', 'gguot', 'gguox', 'gguo', 'gguop', 'ggot', 'ggox', 'ggo', 'ggop', 'gget', 'ggex', 'gge', 'ggep', 'ggut', 'ggux', 'ggu', 'ggup', 'ggurx', 'ggur', 'mgiex', 'mgie', 'mgat', 'mgax', 'mga', 'mgap', 'mguox', 'mguo', 'mguop', 'mgot', 'mgox', 'mgo', 'mgop', 'mgex', 'mge', 'mgep', 'mgut', 'mgux', 'mgu', 'mgup', 'mgurx', 'mgur', 'hxit', 'hxix', 'hxi', 'hxip', 'hxiet', 'hxiex', 'hxie', 'hxiep', 'hxat', 'hxax', 'hxa', 'hxap', 'hxuot', 'hxuox', 'hxuo', 'hxuop', 'hxot', 'hxox', 'hxo', 'hxop', 'hxex', 'hxe', 'hxep', 'ngiex', 'ngie', 'ngiep', 'ngat', 'ngax', 'nga', 'ngap', 'nguot', 'nguox', 'nguo', 'ngot', 'ngox', 'ngo', 'ngop', 'ngex', 'nge', 'ngep', 'hit', 'hiex', 'hie', 'hat', 'hax', 'ha', 'hap', 'huot', 'huox', 'huo', 'huop', 'hot', 'hox', 'ho', 'hop', 'hex', 'he', 'hep', 'wat', 'wax', 'wa', 'wap', 'wuox', 'wuo', 'wuop', 'wox', 'wo', 'wop', 'wex', 'we', 'wep', 'zit', 'zix', 'zi', 'zip', 'ziex', 'zie', 'ziep', 'zat', 'zax', 'za', 'zap', 'zuox', 'zuo', 'zuop', 'zot', 'zox', 'zo', 'zop', 'zex', 'ze', 'zep', 'zut', 'zux', 'zu', 'zup', 'zurx', 'zur', 'zyt', 'zyx', 'zy', 'zyp', 'zyrx', 'zyr', 'cit', 'cix', 'ci', 'cip', 'ciet', 'ciex', 'cie', 'ciep', 'cat', 'cax', 'ca', 'cap', 'cuox', 'cuo', 'cuop', 'cot', 'cox', 'co', 'cop', 'cex', 'ce', 'cep', 'cut', 'cux', 'cu', 'cup', 'curx', 'cur', 'cyt', 'cyx', 'cy', 'cyp', 'cyrx', 'cyr', 'zzit', 'zzix', 'zzi', 'zzip', 'zziet', 'zziex', 'zzie', 'zziep', 'zzat', 'zzax', 'zza', 'zzap', 'zzox', 'zzo', 'zzop', 'zzex', 'zze', 'zzep', 'zzux', 'zzu', 'zzup', 'zzurx', 'zzur', 'zzyt', 'zzyx', 'zzy', 'zzyp', 'zzyrx', 'zzyr', 'nzit', 'nzix', 'nzi', 'nzip', 'nziex', 'nzie', 'nziep', 'nzat', 'nzax', 'nza', 'nzap', 'nzuox', 'nzuo', 'nzox', 'nzop', 'nzex', 'nze', 'nzux', 'nzu']


Joomla CMS: Référence du fichier SymmetricKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/Common/SymmetricKey.php

Structures de données

class SymmetricKey

Espaces de nommage

Base
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier XSalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier 2/XSalsa20.php

Structures de données

class ParagonIE_Sodium_Core32_XSalsa20


Joomla CMS: Référence du fichier WorkflowstageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier WorkflowstageField.php

Structures de données

class WorkflowstageField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier TranscodeUnicode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • TranscodeUnicode
Structures de données | Espaces de nommage
Référence du fichier TranscodeUnicode.php

Structures de données

class TranscodeUnicode

Espaces de nommage

IdnaConvert
Algo26\IdnaConvert\TranscodeUnicode


Joomla CMS: Référence du fichier X25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/X25519.php

Structures de données

class X25519

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • English
Structures de données | Espaces de nommage
Référence du fichier English/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\English


Joomla CMS: Référence du fichier TemplatelocationField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TemplatelocationField.php

Structures de données

class TemplatelocationField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Field


Joomla CMS: Référence du fichier ValueError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Référence du fichier ValueError.php


Joomla CMS: Référence du fichier VerificationMethodDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier VerificationMethodDescriptor.php

Structures de données

class VerificationMethodDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier SSH2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Net
Structures de données | Espaces de nommage
Référence du fichier Net/SSH2.php

Structures de données

class SSH2

Espaces de nommage

SSH2
phpseclib3\Net


Joomla CMS: Référence du fichier UnsupportedPasswordHandlerException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • authentication
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedPasswordHandlerException.php

Structures de données

class UnsupportedPasswordHandlerException

Espaces de nommage

Joomla\Authentication\Exception


Joomla CMS: Référence du fichier query.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier query.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/system/webauthn/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/Stream.php

Structures de données

class Stream

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Service


Joomla CMS: Référence du fichier PdoDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pdo
Structures de données | Espaces de nommage
Référence du fichier PdoDriver.php

Structures de données

class PdoDriver

Espaces de nommage

Joomla\Database\Pdo


Joomla CMS: Référence du fichier Update.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
Structures de données | Espaces de nommage
Référence du fichier Updater/Update.php

Structures de données

class Update

Espaces de nommage

Joomla\CMS\Updater


Joomla CMS: Référence du fichier ResultTypeFloatAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeFloatAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeFloatAware


Joomla CMS: Référence du fichier RoundingNecessaryException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier RoundingNecessaryException.php

Structures de données

class RoundingNecessaryException

Espaces de nommage

Brick\Math\Exception


Joomla CMS: Référence du fichier Poly1305.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Poly1305.php

Structures de données

class Poly1305

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier text_filters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier text_filters.php

Espaces de nommage

Joomla\Site

Variables

$fieldsnames = explode(',', $displayData->fieldsname)
foreach( $fieldsnames as $fieldname)($displayData->form->getFieldset($fieldname) as $field) endforeach

Documentation des variables

◆ $fieldsnames

$fieldsnames = explode(',', $displayData->fieldsname)

◆ endforeach

endforeach


Joomla CMS: Référence du fichier treeprefix.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
Espaces de nommage
Référence du fichier treeprefix.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier ResourceCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ResourceCaster.php

Structures de données

class ResourceCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier UrlRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier UrlRule.php

Structures de données

class UrlRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier SessionState.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier SessionState.php

Structures de données

class SessionState

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier x082.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x082.php

Variables

return ['Yao ', 'Yu ', 'Chong ', 'Xi ', 'Xi ', 'Jiu ', 'Yu ', 'Yu ', 'Xing ', 'Ju ', 'Jiu ', 'Xin ', 'She ', 'She ', 'Yadoru ', 'Jiu ', 'Shi ', 'Tan ', 'Shu ', 'Shi ', 'Tian ', 'Dan ', 'Pu ', 'Pu ', 'Guan ', 'Hua ', 'Tan ', 'Chuan ', 'Shun ', 'Xia ', 'Wu ', 'Zhou ', 'Dao ', 'Gang ', 'Shan ', 'Yi ', '[?] ', 'Pa ', 'Tai ', 'Fan ', 'Ban ', 'Chuan ', 'Hang ', 'Fang ', 'Ban ', 'Que ', 'Hesaki ', 'Zhong ', 'Jian ', 'Cang ', 'Ling ', 'Zhu ', 'Ze ', 'Duo ', 'Bo ', 'Xian ', 'Ge ', 'Chuan ', 'Jia ', 'Lu ', 'Hong ', 'Pang ', 'Xi ', '[?] ', 'Fu ', 'Zao ', 'Feng ', 'Li ', 'Shao ', 'Yu ', 'Lang ', 'Ting ', '[?] ', 'Wei ', 'Bo ', 'Meng ', 'Nian ', 'Ju ', 'Huang ', 'Shou ', 'Zong ', 'Bian ', 'Mao ', 'Die ', '[?] ', 'Bang ', 'Cha ', 'Yi ', 'Sao ', 'Cang ', 'Cao ', 'Lou ', 'Dai ', 'Sori ', 'Yao ', 'Tong ', 'Yofune ', 'Dang ', 'Tan ', 'Lu ', 'Yi ', 'Jie ', 'Jian ', 'Huo ', 'Meng ', 'Qi ', 'Lu ', 'Lu ', 'Chan ', 'Shuang ', 'Gen ', 'Liang ', 'Jian ', 'Jian ', 'Se ', 'Yan ', 'Fu ', 'Ping ', 'Yan ', 'Yan ', 'Cao ', 'Cao ', 'Yi ', 'Le ', 'Ting ', 'Qiu ', 'Ai ', 'Nai ', 'Tiao ', 'Jiao ', 'Jie ', 'Peng ', 'Wan ', 'Yi ', 'Chai ', 'Mian ', 'Mie ', 'Gan ', 'Qian ', 'Yu ', 'Yu ', 'Shuo ', 'Qiong ', 'Tu ', 'Xia ', 'Qi ', 'Mang ', 'Zi ', 'Hui ', 'Sui ', 'Zhi ', 'Xiang ', 'Bi ', 'Fu ', 'Tun ', 'Wei ', 'Wu ', 'Zhi ', 'Qi ', 'Shan ', 'Wen ', 'Qian ', 'Ren ', 'Fou ', 'Kou ', 'Jie ', 'Lu ', 'Xu ', 'Ji ', 'Qin ', 'Qi ', 'Yuan ', 'Fen ', 'Ba ', 'Rui ', 'Xin ', 'Ji ', 'Hua ', 'Hua ', 'Fang ', 'Wu ', 'Jue ', 'Gou ', 'Zhi ', 'Yun ', 'Qin ', 'Ao ', 'Chu ', 'Mao ', 'Ya ', 'Fei ', 'Reng ', 'Hang ', 'Cong ', 'Yin ', 'You ', 'Bian ', 'Yi ', 'Susa ', 'Wei ', 'Li ', 'Pi ', 'E ', 'Xian ', 'Chang ', 'Cang ', 'Meng ', 'Su ', 'Yi ', 'Yuan ', 'Ran ', 'Ling ', 'Tai ', 'Tiao ', 'Di ', 'Miao ', 'Qiong ', 'Li ', 'Yong ', 'Ke ', 'Mu ', 'Pei ', 'Bao ', 'Gou ', 'Min ', 'Yi ', 'Yi ', 'Ju ', 'Pi ', 'Ruo ', 'Ku ', 'Zhu ', 'Ni ', 'Bo ', 'Bing ', 'Shan ', 'Qiu ', 'Yao ', 'Xian ', 'Ben ', 'Hong ', 'Ying ', 'Zha ', 'Dong ', 'Ju ', 'Die ', 'Nie ', 'Gan ', 'Hu ', 'Ping ', 'Mei ', 'Fu ', 'Sheng ', 'Gu ', 'Bi ', 'Wei ']

Documentation des variables

◆ return

return[ 'Yao ', 'Yu ', 'Chong ', 'Xi ', 'Xi ', 'Jiu ', 'Yu ', 'Yu ', 'Xing ', 'Ju ', 'Jiu ', 'Xin ', 'She ', 'She ', 'Yadoru ', 'Jiu ', 'Shi ', 'Tan ', 'Shu ', 'Shi ', 'Tian ', 'Dan ', 'Pu ', 'Pu ', 'Guan ', 'Hua ', 'Tan ', 'Chuan ', 'Shun ', 'Xia ', 'Wu ', 'Zhou ', 'Dao ', 'Gang ', 'Shan ', 'Yi ', '[?] ', 'Pa ', 'Tai ', 'Fan ', 'Ban ', 'Chuan ', 'Hang ', 'Fang ', 'Ban ', 'Que ', 'Hesaki ', 'Zhong ', 'Jian ', 'Cang ', 'Ling ', 'Zhu ', 'Ze ', 'Duo ', 'Bo ', 'Xian ', 'Ge ', 'Chuan ', 'Jia ', 'Lu ', 'Hong ', 'Pang ', 'Xi ', '[?] ', 'Fu ', 'Zao ', 'Feng ', 'Li ', 'Shao ', 'Yu ', 'Lang ', 'Ting ', '[?] ', 'Wei ', 'Bo ', 'Meng ', 'Nian ', 'Ju ', 'Huang ', 'Shou ', 'Zong ', 'Bian ', 'Mao ', 'Die ', '[?] ', 'Bang ', 'Cha ', 'Yi ', 'Sao ', 'Cang ', 'Cao ', 'Lou ', 'Dai ', 'Sori ', 'Yao ', 'Tong ', 'Yofune ', 'Dang ', 'Tan ', 'Lu ', 'Yi ', 'Jie ', 'Jian ', 'Huo ', 'Meng ', 'Qi ', 'Lu ', 'Lu ', 'Chan ', 'Shuang ', 'Gen ', 'Liang ', 'Jian ', 'Jian ', 'Se ', 'Yan ', 'Fu ', 'Ping ', 'Yan ', 'Yan ', 'Cao ', 'Cao ', 'Yi ', 'Le ', 'Ting ', 'Qiu ', 'Ai ', 'Nai ', 'Tiao ', 'Jiao ', 'Jie ', 'Peng ', 'Wan ', 'Yi ', 'Chai ', 'Mian ', 'Mie ', 'Gan ', 'Qian ', 'Yu ', 'Yu ', 'Shuo ', 'Qiong ', 'Tu ', 'Xia ', 'Qi ', 'Mang ', 'Zi ', 'Hui ', 'Sui ', 'Zhi ', 'Xiang ', 'Bi ', 'Fu ', 'Tun ', 'Wei ', 'Wu ', 'Zhi ', 'Qi ', 'Shan ', 'Wen ', 'Qian ', 'Ren ', 'Fou ', 'Kou ', 'Jie ', 'Lu ', 'Xu ', 'Ji ', 'Qin ', 'Qi ', 'Yuan ', 'Fen ', 'Ba ', 'Rui ', 'Xin ', 'Ji ', 'Hua ', 'Hua ', 'Fang ', 'Wu ', 'Jue ', 'Gou ', 'Zhi ', 'Yun ', 'Qin ', 'Ao ', 'Chu ', 'Mao ', 'Ya ', 'Fei ', 'Reng ', 'Hang ', 'Cong ', 'Yin ', 'You ', 'Bian ', 'Yi ', 'Susa ', 'Wei ', 'Li ', 'Pi ', 'E ', 'Xian ', 'Chang ', 'Cang ', 'Meng ', 'Su ', 'Yi ', 'Yuan ', 'Ran ', 'Ling ', 'Tai ', 'Tiao ', 'Di ', 'Miao ', 'Qiong ', 'Li ', 'Yong ', 'Ke ', 'Mu ', 'Pei ', 'Bao ', 'Gou ', 'Min ', 'Yi ', 'Yi ', 'Ju ', 'Pi ', 'Ruo ', 'Ku ', 'Zhu ', 'Ni ', 'Bo ', 'Bing ', 'Shan ', 'Qiu ', 'Yao ', 'Xian ', 'Ben ', 'Hong ', 'Ying ', 'Zha ', 'Dong ', 'Ju ', 'Die ', 'Nie ', 'Gan ', 'Hu ', 'Ping ', 'Mei ', 'Fu ', 'Sheng ', 'Gu ', 'Bi ', 'Wei ']


Joomla CMS: Référence du fichier TextDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier joomla/console/src/Descriptor/TextDescriptor.php

Structures de données

class TextDescriptor

Espaces de nommage

Joomla\Console\Descriptor


Joomla CMS: Référence du fichier VarDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
Structures de données | Espaces de nommage
Référence du fichier VarDumper.php

Structures de données

class VarDumper

Espaces de nommage

Symfony\Component\VarDumper


Joomla CMS: Référence du fichier PositiveBigIntegerTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier PositiveBigIntegerTag.php

Structures de données

class PositiveBigIntegerTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier RFC4648.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • constant_time_encoding
  • src
Structures de données | Espaces de nommage
Référence du fichier RFC4648.php

Structures de données

class RFC4648

Espaces de nommage

ParagonIE\ConstantTime
ParagonIE


Joomla CMS: Référence du fichier tinymce.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
Structures de données | Espaces de nommage
Référence du fichier tinymce.php

Structures de données

class PlgEditorTinymce

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PhpTimeConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
  • Time
Structures de données | Espaces de nommage
Référence du fichier PhpTimeConverter.php

Structures de données

class PhpTimeConverter

Espaces de nommage

Ramsey\Uuid\Converter\Time


Joomla CMS: Référence du fichier PharMetaDataInterceptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Interceptor
Structures de données | Espaces de nommage
Référence du fichier PharMetaDataInterceptor.php

Structures de données

class PharMetaDataInterceptor

Espaces de nommage

TYPO3\PharStreamWrapper\Interceptor


Joomla CMS: Référence du fichier SetNewTagsEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Table
Structures de données | Espaces de nommage
Référence du fichier SetNewTagsEvent.php

Structures de données

class SetNewTagsEvent

Espaces de nommage

Joomla\CMS\Event\Table


Joomla CMS: Référence du fichier PdoStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pdo
Structures de données | Espaces de nommage
Référence du fichier PdoStatement.php

Structures de données

class PdoStatement

Espaces de nommage

Joomla\Database\Pdo


Joomla CMS: Référence du fichier PrivateKeyInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PrivateKeyInfo.php

Structures de données

class PrivateKeyInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x075.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x075.php

Variables

return ['Zhui ', 'Ping ', 'Bian ', 'Zhou ', 'Zhen ', 'Senchigura ', 'Ci ', 'Ying ', 'Qi ', 'Xian ', 'Lou ', 'Di ', 'Ou ', 'Meng ', 'Zhuan ', 'Peng ', 'Lin ', 'Zeng ', 'Wu ', 'Pi ', 'Dan ', 'Weng ', 'Ying ', 'Yan ', 'Gan ', 'Dai ', 'Shen ', 'Tian ', 'Tian ', 'Han ', 'Chang ', 'Sheng ', 'Qing ', 'Sheng ', 'Chan ', 'Chan ', 'Rui ', 'Sheng ', 'Su ', 'Sen ', 'Yong ', 'Shuai ', 'Lu ', 'Fu ', 'Yong ', 'Beng ', 'Feng ', 'Ning ', 'Tian ', 'You ', 'Jia ', 'Shen ', 'Zha ', 'Dian ', 'Fu ', 'Nan ', 'Dian ', 'Ping ', 'Ting ', 'Hua ', 'Ting ', 'Quan ', 'Zi ', 'Meng ', 'Bi ', 'Qi ', 'Liu ', 'Xun ', 'Liu ', 'Chang ', 'Mu ', 'Yun ', 'Fan ', 'Fu ', 'Geng ', 'Tian ', 'Jie ', 'Jie ', 'Quan ', 'Wei ', 'Fu ', 'Tian ', 'Mu ', 'Tap ', 'Pan ', 'Jiang ', 'Wa ', 'Da ', 'Nan ', 'Liu ', 'Ben ', 'Zhen ', 'Chu ', 'Mu ', 'Mu ', 'Ce ', 'Cen ', 'Gai ', 'Bi ', 'Da ', 'Zhi ', 'Lue ', 'Qi ', 'Lue ', 'Pan ', 'Kesa ', 'Fan ', 'Hua ', 'Yu ', 'Yu ', 'Mu ', 'Jun ', 'Yi ', 'Liu ', 'Yu ', 'Die ', 'Chou ', 'Hua ', 'Dang ', 'Chuo ', 'Ji ', 'Wan ', 'Jiang ', 'Sheng ', 'Chang ', 'Tuan ', 'Lei ', 'Ji ', 'Cha ', 'Liu ', 'Tatamu ', 'Tuan ', 'Lin ', 'Jiang ', 'Jiang ', 'Chou ', 'Bo ', 'Die ', 'Die ', 'Pi ', 'Nie ', 'Dan ', 'Shu ', 'Shu ', 'Zhi ', 'Yi ', 'Chuang ', 'Nai ', 'Ding ', 'Bi ', 'Jie ', 'Liao ', 'Gong ', 'Ge ', 'Jiu ', 'Zhou ', 'Xia ', 'Shan ', 'Xu ', 'Nue ', 'Li ', 'Yang ', 'Chen ', 'You ', 'Ba ', 'Jie ', 'Jue ', 'Zhi ', 'Xia ', 'Cui ', 'Bi ', 'Yi ', 'Li ', 'Zong ', 'Chuang ', 'Feng ', 'Zhu ', 'Pao ', 'Pi ', 'Gan ', 'Ke ', 'Ci ', 'Xie ', 'Qi ', 'Dan ', 'Zhen ', 'Fa ', 'Zhi ', 'Teng ', 'Ju ', 'Ji ', 'Fei ', 'Qu ', 'Dian ', 'Jia ', 'Xian ', 'Cha ', 'Bing ', 'Ni ', 'Zheng ', 'Yong ', 'Jing ', 'Quan ', 'Chong ', 'Tong ', 'Yi ', 'Kai ', 'Wei ', 'Hui ', 'Duo ', 'Yang ', 'Chi ', 'Zhi ', 'Hen ', 'Ya ', 'Mei ', 'Dou ', 'Jing ', 'Xiao ', 'Tong ', 'Tu ', 'Mang ', 'Pi ', 'Xiao ', 'Suan ', 'Pu ', 'Li ', 'Zhi ', 'Cuo ', 'Duo ', 'Wu ', 'Sha ', 'Lao ', 'Shou ', 'Huan ', 'Xian ', 'Yi ', 'Peng ', 'Zhang ', 'Guan ', 'Tan ', 'Fei ', 'Ma ', 'Lin ', 'Chi ', 'Ji ', 'Dian ', 'An ', 'Chi ', 'Bi ', 'Bei ', 'Min ', 'Gu ', 'Dui ', 'E ', 'Wei ']

Documentation des variables

◆ return

return[ 'Zhui ', 'Ping ', 'Bian ', 'Zhou ', 'Zhen ', 'Senchigura ', 'Ci ', 'Ying ', 'Qi ', 'Xian ', 'Lou ', 'Di ', 'Ou ', 'Meng ', 'Zhuan ', 'Peng ', 'Lin ', 'Zeng ', 'Wu ', 'Pi ', 'Dan ', 'Weng ', 'Ying ', 'Yan ', 'Gan ', 'Dai ', 'Shen ', 'Tian ', 'Tian ', 'Han ', 'Chang ', 'Sheng ', 'Qing ', 'Sheng ', 'Chan ', 'Chan ', 'Rui ', 'Sheng ', 'Su ', 'Sen ', 'Yong ', 'Shuai ', 'Lu ', 'Fu ', 'Yong ', 'Beng ', 'Feng ', 'Ning ', 'Tian ', 'You ', 'Jia ', 'Shen ', 'Zha ', 'Dian ', 'Fu ', 'Nan ', 'Dian ', 'Ping ', 'Ting ', 'Hua ', 'Ting ', 'Quan ', 'Zi ', 'Meng ', 'Bi ', 'Qi ', 'Liu ', 'Xun ', 'Liu ', 'Chang ', 'Mu ', 'Yun ', 'Fan ', 'Fu ', 'Geng ', 'Tian ', 'Jie ', 'Jie ', 'Quan ', 'Wei ', 'Fu ', 'Tian ', 'Mu ', 'Tap ', 'Pan ', 'Jiang ', 'Wa ', 'Da ', 'Nan ', 'Liu ', 'Ben ', 'Zhen ', 'Chu ', 'Mu ', 'Mu ', 'Ce ', 'Cen ', 'Gai ', 'Bi ', 'Da ', 'Zhi ', 'Lue ', 'Qi ', 'Lue ', 'Pan ', 'Kesa ', 'Fan ', 'Hua ', 'Yu ', 'Yu ', 'Mu ', 'Jun ', 'Yi ', 'Liu ', 'Yu ', 'Die ', 'Chou ', 'Hua ', 'Dang ', 'Chuo ', 'Ji ', 'Wan ', 'Jiang ', 'Sheng ', 'Chang ', 'Tuan ', 'Lei ', 'Ji ', 'Cha ', 'Liu ', 'Tatamu ', 'Tuan ', 'Lin ', 'Jiang ', 'Jiang ', 'Chou ', 'Bo ', 'Die ', 'Die ', 'Pi ', 'Nie ', 'Dan ', 'Shu ', 'Shu ', 'Zhi ', 'Yi ', 'Chuang ', 'Nai ', 'Ding ', 'Bi ', 'Jie ', 'Liao ', 'Gong ', 'Ge ', 'Jiu ', 'Zhou ', 'Xia ', 'Shan ', 'Xu ', 'Nue ', 'Li ', 'Yang ', 'Chen ', 'You ', 'Ba ', 'Jie ', 'Jue ', 'Zhi ', 'Xia ', 'Cui ', 'Bi ', 'Yi ', 'Li ', 'Zong ', 'Chuang ', 'Feng ', 'Zhu ', 'Pao ', 'Pi ', 'Gan ', 'Ke ', 'Ci ', 'Xie ', 'Qi ', 'Dan ', 'Zhen ', 'Fa ', 'Zhi ', 'Teng ', 'Ju ', 'Ji ', 'Fei ', 'Qu ', 'Dian ', 'Jia ', 'Xian ', 'Cha ', 'Bing ', 'Ni ', 'Zheng ', 'Yong ', 'Jing ', 'Quan ', 'Chong ', 'Tong ', 'Yi ', 'Kai ', 'Wei ', 'Hui ', 'Duo ', 'Yang ', 'Chi ', 'Zhi ', 'Hen ', 'Ya ', 'Mei ', 'Dou ', 'Jing ', 'Xiao ', 'Tong ', 'Tu ', 'Mang ', 'Pi ', 'Xiao ', 'Suan ', 'Pu ', 'Li ', 'Zhi ', 'Cuo ', 'Duo ', 'Wu ', 'Sha ', 'Lao ', 'Shou ', 'Huan ', 'Xian ', 'Yi ', 'Peng ', 'Zhang ', 'Guan ', 'Tan ', 'Fei ', 'Ma ', 'Lin ', 'Chi ', 'Ji ', 'Dian ', 'An ', 'Chi ', 'Bi ', 'Bei ', 'Min ', 'Gu ', 'Dui ', 'E ', 'Wei ']


Joomla CMS: Référence du fichier XmlView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • src
  • View
  • Menu
Structures de données | Espaces de nommage
Référence du fichier com_menus/src/View/Menu/XmlView.php

Structures de données

class XmlView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Menus\Administrator\View\Menu


Joomla CMS: Référence du fichier SipHash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/SipHash.php

Structures de données

class ParagonIE_Sodium_Core_SipHash


Joomla CMS: Référence du fichier RuntimeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Exception
Structures de données | Espaces de nommage
Référence du fichier string/Exception/RuntimeException.php

Structures de données

class RuntimeException

Espaces de nommage

Symfony\Component\String\Exception


Joomla CMS: Référence du fichier x067.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x067.php

Variables

return ['Zui ', 'Can ', 'Xu ', 'Hui ', 'Yin ', 'Qie ', 'Fen ', 'Pi ', 'Yue ', 'You ', 'Ruan ', 'Peng ', 'Ban ', 'Fu ', 'Ling ', 'Fei ', 'Qu ', '[?] ', 'Nu ', 'Tiao ', 'Shuo ', 'Zhen ', 'Lang ', 'Lang ', 'Juan ', 'Ming ', 'Huang ', 'Wang ', 'Tun ', 'Zhao ', 'Ji ', 'Qi ', 'Ying ', 'Zong ', 'Wang ', 'Tong ', 'Lang ', '[?] ', 'Meng ', 'Long ', 'Mu ', 'Deng ', 'Wei ', 'Mo ', 'Ben ', 'Zha ', 'Zhu ', 'Zhu ', '[?] ', 'Zhu ', 'Ren ', 'Ba ', 'Po ', 'Duo ', 'Duo ', 'Dao ', 'Li ', 'Qiu ', 'Ji ', 'Jiu ', 'Bi ', 'Xiu ', 'Ting ', 'Ci ', 'Sha ', 'Eburi ', 'Za ', 'Quan ', 'Qian ', 'Yu ', 'Gan ', 'Wu ', 'Cha ', 'Shan ', 'Xun ', 'Fan ', 'Wu ', 'Zi ', 'Li ', 'Xing ', 'Cai ', 'Cun ', 'Ren ', 'Shao ', 'Tuo ', 'Di ', 'Zhang ', 'Mang ', 'Chi ', 'Yi ', 'Gu ', 'Gong ', 'Du ', 'Yi ', 'Qi ', 'Shu ', 'Gang ', 'Tiao ', 'Moku ', 'Soma ', 'Tochi ', 'Lai ', 'Sugi ', 'Mang ', 'Yang ', 'Ma ', 'Miao ', 'Si ', 'Yuan ', 'Hang ', 'Fei ', 'Bei ', 'Jie ', 'Dong ', 'Gao ', 'Yao ', 'Xian ', 'Chu ', 'Qun ', 'Pa ', 'Shu ', 'Hua ', 'Xin ', 'Chou ', 'Zhu ', 'Chou ', 'Song ', 'Ban ', 'Song ', 'Ji ', 'Yue ', 'Jin ', 'Gou ', 'Ji ', 'Mao ', 'Pi ', 'Bi ', 'Wang ', 'Ang ', 'Fang ', 'Fen ', 'Yi ', 'Fu ', 'Nan ', 'Xi ', 'Hu ', 'Ya ', 'Dou ', 'Xun ', 'Zhen ', 'Yao ', 'Lin ', 'Rui ', 'E ', 'Mei ', 'Zhao ', 'Guo ', 'Zhi ', 'Cong ', 'Yun ', 'Waku ', 'Dou ', 'Shu ', 'Zao ', '[?] ', 'Li ', 'Haze ', 'Jian ', 'Cheng ', 'Matsu ', 'Qiang ', 'Feng ', 'Nan ', 'Xiao ', 'Xian ', 'Ku ', 'Ping ', 'Yi ', 'Xi ', 'Zhi ', 'Guai ', 'Xiao ', 'Jia ', 'Jia ', 'Gou ', 'Fu ', 'Mo ', 'Yi ', 'Ye ', 'Ye ', 'Shi ', 'Nie ', 'Bi ', 'Duo ', 'Yi ', 'Ling ', 'Bing ', 'Ni ', 'La ', 'He ', 'Pan ', 'Fan ', 'Zhong ', 'Dai ', 'Ci ', 'Yang ', 'Fu ', 'Bo ', 'Mou ', 'Gan ', 'Qi ', 'Ran ', 'Rou ', 'Mao ', 'Zhao ', 'Song ', 'Zhe ', 'Xia ', 'You ', 'Shen ', 'Ju ', 'Tuo ', 'Zuo ', 'Nan ', 'Ning ', 'Yong ', 'Di ', 'Zhi ', 'Zha ', 'Cha ', 'Dan ', 'Gu ', 'Pu ', 'Jiu ', 'Ao ', 'Fu ', 'Jian ', 'Bo ', 'Duo ', 'Ke ', 'Nai ', 'Zhu ', 'Bi ', 'Liu ', 'Chai ', 'Zha ', 'Si ', 'Zhu ', 'Pei ', 'Shi ', 'Guai ', 'Cha ', 'Yao ', 'Jue ', 'Jiu ', 'Shi ']

Documentation des variables

◆ return

return[ 'Zui ', 'Can ', 'Xu ', 'Hui ', 'Yin ', 'Qie ', 'Fen ', 'Pi ', 'Yue ', 'You ', 'Ruan ', 'Peng ', 'Ban ', 'Fu ', 'Ling ', 'Fei ', 'Qu ', '[?] ', 'Nu ', 'Tiao ', 'Shuo ', 'Zhen ', 'Lang ', 'Lang ', 'Juan ', 'Ming ', 'Huang ', 'Wang ', 'Tun ', 'Zhao ', 'Ji ', 'Qi ', 'Ying ', 'Zong ', 'Wang ', 'Tong ', 'Lang ', '[?] ', 'Meng ', 'Long ', 'Mu ', 'Deng ', 'Wei ', 'Mo ', 'Ben ', 'Zha ', 'Zhu ', 'Zhu ', '[?] ', 'Zhu ', 'Ren ', 'Ba ', 'Po ', 'Duo ', 'Duo ', 'Dao ', 'Li ', 'Qiu ', 'Ji ', 'Jiu ', 'Bi ', 'Xiu ', 'Ting ', 'Ci ', 'Sha ', 'Eburi ', 'Za ', 'Quan ', 'Qian ', 'Yu ', 'Gan ', 'Wu ', 'Cha ', 'Shan ', 'Xun ', 'Fan ', 'Wu ', 'Zi ', 'Li ', 'Xing ', 'Cai ', 'Cun ', 'Ren ', 'Shao ', 'Tuo ', 'Di ', 'Zhang ', 'Mang ', 'Chi ', 'Yi ', 'Gu ', 'Gong ', 'Du ', 'Yi ', 'Qi ', 'Shu ', 'Gang ', 'Tiao ', 'Moku ', 'Soma ', 'Tochi ', 'Lai ', 'Sugi ', 'Mang ', 'Yang ', 'Ma ', 'Miao ', 'Si ', 'Yuan ', 'Hang ', 'Fei ', 'Bei ', 'Jie ', 'Dong ', 'Gao ', 'Yao ', 'Xian ', 'Chu ', 'Qun ', 'Pa ', 'Shu ', 'Hua ', 'Xin ', 'Chou ', 'Zhu ', 'Chou ', 'Song ', 'Ban ', 'Song ', 'Ji ', 'Yue ', 'Jin ', 'Gou ', 'Ji ', 'Mao ', 'Pi ', 'Bi ', 'Wang ', 'Ang ', 'Fang ', 'Fen ', 'Yi ', 'Fu ', 'Nan ', 'Xi ', 'Hu ', 'Ya ', 'Dou ', 'Xun ', 'Zhen ', 'Yao ', 'Lin ', 'Rui ', 'E ', 'Mei ', 'Zhao ', 'Guo ', 'Zhi ', 'Cong ', 'Yun ', 'Waku ', 'Dou ', 'Shu ', 'Zao ', '[?] ', 'Li ', 'Haze ', 'Jian ', 'Cheng ', 'Matsu ', 'Qiang ', 'Feng ', 'Nan ', 'Xiao ', 'Xian ', 'Ku ', 'Ping ', 'Yi ', 'Xi ', 'Zhi ', 'Guai ', 'Xiao ', 'Jia ', 'Jia ', 'Gou ', 'Fu ', 'Mo ', 'Yi ', 'Ye ', 'Ye ', 'Shi ', 'Nie ', 'Bi ', 'Duo ', 'Yi ', 'Ling ', 'Bing ', 'Ni ', 'La ', 'He ', 'Pan ', 'Fan ', 'Zhong ', 'Dai ', 'Ci ', 'Yang ', 'Fu ', 'Bo ', 'Mou ', 'Gan ', 'Qi ', 'Ran ', 'Rou ', 'Mao ', 'Zhao ', 'Song ', 'Zhe ', 'Xia ', 'You ', 'Shen ', 'Ju ', 'Tuo ', 'Zuo ', 'Nan ', 'Ning ', 'Yong ', 'Di ', 'Zhi ', 'Zha ', 'Cha ', 'Dan ', 'Gu ', 'Pu ', 'Jiu ', 'Ao ', 'Fu ', 'Jian ', 'Bo ', 'Duo ', 'Ke ', 'Nai ', 'Zhu ', 'Bi ', 'Liu ', 'Chai ', 'Zha ', 'Si ', 'Zhu ', 'Pei ', 'Shi ', 'Guai ', 'Cha ', 'Yao ', 'Jue ', 'Jiu ', 'Shi ']


Joomla CMS: Référence du fichier TaskOption.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Task
Structures de données | Espaces de nommage
Référence du fichier TaskOption.php

Structures de données

class TaskOption

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Task


Joomla CMS: Référence du fichier UsernameRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier installation/src/Form/Rule/UsernameRule.php

Structures de données

class UsernameRule

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Form\Rule


Joomla CMS: Référence du fichier Sketchy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Filter
Structures de données | Espaces de nommage
Référence du fichier Sketchy.php

Structures de données

class Sketchy

Espaces de nommage

Joomla\CMS\Image\Filter


Joomla CMS: Référence du fichier taxonomy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier taxonomy.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • helpers
Structures de données | Espaces de nommage
Référence du fichier com_contact/helpers/route.php

Structures de données

class ContactHelperRoute

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier SinglePrecisionFloatObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier SinglePrecisionFloatObject.php

Structures de données

class SinglePrecisionFloatObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier TableRows.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TableRows.php

Structures de données

class TableRows

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier x1d7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x1d7.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9']


Joomla CMS: Référence du fichier textarea.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/textarea.php

Espaces de nommage

Joomla\Site

Variables

if($charcounter) $attributes

Documentation des variables

◆ $attributes

if ( $charcounter) $attributes
Valeur initiale :
= array(
$columns ?: '',
$rows ?: '',
!empty($class) ? 'class="form-control ' . $class . $charcounter . '"' : 'class="form-control' . $charcounter . '"',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
$onchange ? 'onchange="' . $onchange . '"' : '',
$onclick ? 'onclick="' . $onclick . '"' : '',
$required ? 'required' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$autofocus ? 'autofocus' : '',
$spellcheck ? '' : 'spellcheck="false"',
$maxlength ?: '',
!empty($counterlabel) ? $counterlabel : '',
$dataAttribute,
)
$onclick
$onclick
Definition: administrator/components/com_contact/tmpl/contacts/modal.php:36
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$rows
$rows
Definition: element.php:24
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
$columns
$columns
Definition: components/com_tags/tmpl/tags/default_items.php:32
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17


Joomla CMS: Référence du fichier State.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Poly1305
Structures de données
Référence du fichier src/Core/Poly1305/State.php

Structures de données

class ParagonIE_Sodium_Core_Poly1305_State


Joomla CMS: Référence du fichier parse_cookie_header.legacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier parse_cookie_header.legacy.php

Espaces de nommage

Zend\Diactoros

Fonctions

parseCookieHeader ($cookieHeader)


Joomla CMS: Référence du fichier WrongKeyOrModifiedCiphertextException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier WrongKeyOrModifiedCiphertextException.php

Structures de données

class WrongKeyOrModifiedCiphertextException

Espaces de nommage

Defuse\Crypto\Exception


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/laminas/laminas-diactoros/src/Stream.php

Structures de données

class Stream

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier PdoQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pdo
Structures de données | Espaces de nommage
Référence du fichier PdoQuery.php

Structures de données

class PdoQuery

Espaces de nommage

Joomla\Database\Pdo


Joomla CMS: Référence du fichier TripleDES.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier TripleDES.php

Structures de données

class TripleDES

Espaces de nommage

TripleDES
phpseclib3\Crypt


Joomla CMS: Référence du fichier TokenBindingNotSupportedHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TokenBinding
Structures de données | Espaces de nommage
Référence du fichier TokenBindingNotSupportedHandler.php

Structures de données

class TokenBindingNotSupportedHandler

Espaces de nommage

Webauthn\TokenBinding


Joomla CMS: Référence du fichier Query.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Query.php

Structures de données

class Query

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier parent_category.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage | Variables
Référence du fichier parent_category.php

Espaces de nommage

Joomla\Site

Variables

$title = $this->escape($displayData['item']->parent_title)

Documentation des variables

◆ $title

$title = $this->escape($displayData['item']->parent_title)


Joomla CMS: Référence du fichier stream-xchacha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Référence du fichier stream-xchacha20.php


Joomla CMS: Référence du fichier x080.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x080.php

Variables

return ['Yao ', 'Lao ', '[?] ', 'Kao ', 'Mao ', 'Zhe ', 'Qi ', 'Gou ', 'Gou ', 'Gou ', 'Die ', 'Die ', 'Er ', 'Shua ', 'Ruan ', 'Er ', 'Nai ', 'Zhuan ', 'Lei ', 'Ting ', 'Zi ', 'Geng ', 'Chao ', 'Hao ', 'Yun ', 'Pa ', 'Pi ', 'Chi ', 'Si ', 'Chu ', 'Jia ', 'Ju ', 'He ', 'Chu ', 'Lao ', 'Lun ', 'Ji ', 'Tang ', 'Ou ', 'Lou ', 'Nou ', 'Gou ', 'Pang ', 'Ze ', 'Lou ', 'Ji ', 'Lao ', 'Huo ', 'You ', 'Mo ', 'Huai ', 'Er ', 'Zhe ', 'Ting ', 'Ye ', 'Da ', 'Song ', 'Qin ', 'Yun ', 'Chi ', 'Dan ', 'Dan ', 'Hong ', 'Geng ', 'Zhi ', '[?] ', 'Nie ', 'Dan ', 'Zhen ', 'Che ', 'Ling ', 'Zheng ', 'You ', 'Wa ', 'Liao ', 'Long ', 'Zhi ', 'Ning ', 'Tiao ', 'Er ', 'Ya ', 'Die ', 'Gua ', '[?] ', 'Lian ', 'Hao ', 'Sheng ', 'Lie ', 'Pin ', 'Jing ', 'Ju ', 'Bi ', 'Di ', 'Guo ', 'Wen ', 'Xu ', 'Ping ', 'Cong ', 'Shikato ', '[?] ', 'Ting ', 'Yu ', 'Cong ', 'Kui ', 'Tsuraneru ', 'Kui ', 'Cong ', 'Lian ', 'Weng ', 'Kui ', 'Lian ', 'Lian ', 'Cong ', 'Ao ', 'Sheng ', 'Song ', 'Ting ', 'Kui ', 'Nie ', 'Zhi ', 'Dan ', 'Ning ', 'Qie ', 'Ji ', 'Ting ', 'Ting ', 'Long ', 'Yu ', 'Yu ', 'Zhao ', 'Si ', 'Su ', 'Yi ', 'Su ', 'Si ', 'Zhao ', 'Zhao ', 'Rou ', 'Yi ', 'Le ', 'Ji ', 'Qiu ', 'Ken ', 'Cao ', 'Ge ', 'Di ', 'Huan ', 'Huang ', 'Yi ', 'Ren ', 'Xiao ', 'Ru ', 'Zhou ', 'Yuan ', 'Du ', 'Gang ', 'Rong ', 'Gan ', 'Cha ', 'Wo ', 'Chang ', 'Gu ', 'Zhi ', 'Han ', 'Fu ', 'Fei ', 'Fen ', 'Pei ', 'Pang ', 'Jian ', 'Fang ', 'Zhun ', 'You ', 'Na ', 'Hang ', 'Ken ', 'Ran ', 'Gong ', 'Yu ', 'Wen ', 'Yao ', 'Jin ', 'Pi ', 'Qian ', 'Xi ', 'Xi ', 'Fei ', 'Ken ', 'Jing ', 'Tai ', 'Shen ', 'Zhong ', 'Zhang ', 'Xie ', 'Shen ', 'Wei ', 'Zhou ', 'Die ', 'Dan ', 'Fei ', 'Ba ', 'Bo ', 'Qu ', 'Tian ', 'Bei ', 'Gua ', 'Tai ', 'Zi ', 'Ku ', 'Zhi ', 'Ni ', 'Ping ', 'Zi ', 'Fu ', 'Pang ', 'Zhen ', 'Xian ', 'Zuo ', 'Pei ', 'Jia ', 'Sheng ', 'Zhi ', 'Bao ', 'Mu ', 'Qu ', 'Hu ', 'Ke ', 'Yi ', 'Yin ', 'Xu ', 'Yang ', 'Long ', 'Dong ', 'Ka ', 'Lu ', 'Jing ', 'Nu ', 'Yan ', 'Pang ', 'Kua ', 'Yi ', 'Guang ', 'Gai ', 'Ge ', 'Dong ', 'Zhi ', 'Xiao ', 'Xiong ', 'Xiong ', 'Er ', 'E ', 'Xing ', 'Pian ', 'Neng ', 'Zi ', 'Gui ']

Documentation des variables

◆ return

return[ 'Yao ', 'Lao ', '[?] ', 'Kao ', 'Mao ', 'Zhe ', 'Qi ', 'Gou ', 'Gou ', 'Gou ', 'Die ', 'Die ', 'Er ', 'Shua ', 'Ruan ', 'Er ', 'Nai ', 'Zhuan ', 'Lei ', 'Ting ', 'Zi ', 'Geng ', 'Chao ', 'Hao ', 'Yun ', 'Pa ', 'Pi ', 'Chi ', 'Si ', 'Chu ', 'Jia ', 'Ju ', 'He ', 'Chu ', 'Lao ', 'Lun ', 'Ji ', 'Tang ', 'Ou ', 'Lou ', 'Nou ', 'Gou ', 'Pang ', 'Ze ', 'Lou ', 'Ji ', 'Lao ', 'Huo ', 'You ', 'Mo ', 'Huai ', 'Er ', 'Zhe ', 'Ting ', 'Ye ', 'Da ', 'Song ', 'Qin ', 'Yun ', 'Chi ', 'Dan ', 'Dan ', 'Hong ', 'Geng ', 'Zhi ', '[?] ', 'Nie ', 'Dan ', 'Zhen ', 'Che ', 'Ling ', 'Zheng ', 'You ', 'Wa ', 'Liao ', 'Long ', 'Zhi ', 'Ning ', 'Tiao ', 'Er ', 'Ya ', 'Die ', 'Gua ', '[?] ', 'Lian ', 'Hao ', 'Sheng ', 'Lie ', 'Pin ', 'Jing ', 'Ju ', 'Bi ', 'Di ', 'Guo ', 'Wen ', 'Xu ', 'Ping ', 'Cong ', 'Shikato ', '[?] ', 'Ting ', 'Yu ', 'Cong ', 'Kui ', 'Tsuraneru ', 'Kui ', 'Cong ', 'Lian ', 'Weng ', 'Kui ', 'Lian ', 'Lian ', 'Cong ', 'Ao ', 'Sheng ', 'Song ', 'Ting ', 'Kui ', 'Nie ', 'Zhi ', 'Dan ', 'Ning ', 'Qie ', 'Ji ', 'Ting ', 'Ting ', 'Long ', 'Yu ', 'Yu ', 'Zhao ', 'Si ', 'Su ', 'Yi ', 'Su ', 'Si ', 'Zhao ', 'Zhao ', 'Rou ', 'Yi ', 'Le ', 'Ji ', 'Qiu ', 'Ken ', 'Cao ', 'Ge ', 'Di ', 'Huan ', 'Huang ', 'Yi ', 'Ren ', 'Xiao ', 'Ru ', 'Zhou ', 'Yuan ', 'Du ', 'Gang ', 'Rong ', 'Gan ', 'Cha ', 'Wo ', 'Chang ', 'Gu ', 'Zhi ', 'Han ', 'Fu ', 'Fei ', 'Fen ', 'Pei ', 'Pang ', 'Jian ', 'Fang ', 'Zhun ', 'You ', 'Na ', 'Hang ', 'Ken ', 'Ran ', 'Gong ', 'Yu ', 'Wen ', 'Yao ', 'Jin ', 'Pi ', 'Qian ', 'Xi ', 'Xi ', 'Fei ', 'Ken ', 'Jing ', 'Tai ', 'Shen ', 'Zhong ', 'Zhang ', 'Xie ', 'Shen ', 'Wei ', 'Zhou ', 'Die ', 'Dan ', 'Fei ', 'Ba ', 'Bo ', 'Qu ', 'Tian ', 'Bei ', 'Gua ', 'Tai ', 'Zi ', 'Ku ', 'Zhi ', 'Ni ', 'Ping ', 'Zi ', 'Fu ', 'Pang ', 'Zhen ', 'Xian ', 'Zuo ', 'Pei ', 'Jia ', 'Sheng ', 'Zhi ', 'Bao ', 'Mu ', 'Qu ', 'Hu ', 'Ke ', 'Yi ', 'Yin ', 'Xu ', 'Yang ', 'Long ', 'Dong ', 'Ka ', 'Lu ', 'Jing ', 'Nu ', 'Yan ', 'Pang ', 'Kua ', 'Yi ', 'Guang ', 'Gai ', 'Ge ', 'Dong ', 'Zhi ', 'Xiao ', 'Xiong ', 'Xiong ', 'Er ', 'E ', 'Xing ', 'Pian ', 'Neng ', 'Zi ', 'Gui ']


Joomla CMS: Référence du fichier ToUtf8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • EncodingHelper
Structures de données | Espaces de nommage
Référence du fichier ToUtf8.php

Structures de données

class ToUtf8

Espaces de nommage

Algo26\IdnaConvert\EncodingHelper


Joomla CMS: Référence du fichier ReaderException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier ReaderException.php

Structures de données

class ReaderException

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_categories
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_categories/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier SimpleObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier SimpleObject.php

Structures de données

class SimpleObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier x07a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07a.php

Variables

return ['Xi ', 'Kao ', 'Lang ', 'Fu ', 'Ze ', 'Shui ', 'Lu ', 'Kun ', 'Gan ', 'Geng ', 'Ti ', 'Cheng ', 'Tu ', 'Shao ', 'Shui ', 'Ya ', 'Lun ', 'Lu ', 'Gu ', 'Zuo ', 'Ren ', 'Zhun ', 'Bang ', 'Bai ', 'Ji ', 'Zhi ', 'Zhi ', 'Kun ', 'Leng ', 'Peng ', 'Ke ', 'Bing ', 'Chou ', 'Zu ', 'Yu ', 'Su ', 'Lue ', '[?] ', 'Yi ', 'Xi ', 'Bian ', 'Ji ', 'Fu ', 'Bi ', 'Nuo ', 'Jie ', 'Zhong ', 'Zong ', 'Xu ', 'Cheng ', 'Dao ', 'Wen ', 'Lian ', 'Zi ', 'Yu ', 'Ji ', 'Xu ', 'Zhen ', 'Zhi ', 'Dao ', 'Jia ', 'Ji ', 'Gao ', 'Gao ', 'Gu ', 'Rong ', 'Sui ', 'You ', 'Ji ', 'Kang ', 'Mu ', 'Shan ', 'Men ', 'Zhi ', 'Ji ', 'Lu ', 'Su ', 'Ji ', 'Ying ', 'Wen ', 'Qiu ', 'Se ', '[?] ', 'Yi ', 'Huang ', 'Qie ', 'Ji ', 'Sui ', 'Xiao ', 'Pu ', 'Jiao ', 'Zhuo ', 'Tong ', 'Sai ', 'Lu ', 'Sui ', 'Nong ', 'Se ', 'Hui ', 'Rang ', 'Nuo ', 'Yu ', 'Bin ', 'Ji ', 'Tui ', 'Wen ', 'Cheng ', 'Huo ', 'Gong ', 'Lu ', 'Biao ', '[?] ', 'Rang ', 'Zhuo ', 'Li ', 'Zan ', 'Xue ', 'Wa ', 'Jiu ', 'Qiong ', 'Xi ', 'Qiong ', 'Kong ', 'Yu ', 'Sen ', 'Jing ', 'Yao ', 'Chuan ', 'Zhun ', 'Tu ', 'Lao ', 'Qie ', 'Zhai ', 'Yao ', 'Bian ', 'Bao ', 'Yao ', 'Bing ', 'Wa ', 'Zhu ', 'Jiao ', 'Qiao ', 'Diao ', 'Wu ', 'Gui ', 'Yao ', 'Zhi ', 'Chuang ', 'Yao ', 'Tiao ', 'Jiao ', 'Chuang ', 'Jiong ', 'Xiao ', 'Cheng ', 'Kou ', 'Cuan ', 'Wo ', 'Dan ', 'Ku ', 'Ke ', 'Zhui ', 'Xu ', 'Su ', 'Guan ', 'Kui ', 'Dou ', '[?] ', 'Yin ', 'Wo ', 'Wa ', 'Ya ', 'Yu ', 'Ju ', 'Qiong ', 'Yao ', 'Yao ', 'Tiao ', 'Chao ', 'Yu ', 'Tian ', 'Diao ', 'Ju ', 'Liao ', 'Xi ', 'Wu ', 'Kui ', 'Chuang ', 'Zhao ', '[?] ', 'Kuan ', 'Long ', 'Cheng ', 'Cui ', 'Piao ', 'Zao ', 'Cuan ', 'Qiao ', 'Qiong ', 'Dou ', 'Zao ', 'Long ', 'Qie ', 'Li ', 'Chu ', 'Shi ', 'Fou ', 'Qian ', 'Chu ', 'Hong ', 'Qi ', 'Qian ', 'Gong ', 'Shi ', 'Shu ', 'Miao ', 'Ju ', 'Zhan ', 'Zhu ', 'Ling ', 'Long ', 'Bing ', 'Jing ', 'Jing ', 'Zhang ', 'Yi ', 'Si ', 'Jun ', 'Hong ', 'Tong ', 'Song ', 'Jing ', 'Diao ', 'Yi ', 'Shu ', 'Jing ', 'Qu ', 'Jie ', 'Ping ', 'Duan ', 'Shao ', 'Zhuan ', 'Ceng ', 'Deng ', 'Cui ', 'Huai ', 'Jing ', 'Kan ', 'Jing ', 'Zhu ', 'Zhu ', 'Le ', 'Peng ', 'Yu ', 'Chi ', 'Gan ']

Documentation des variables

◆ return

return[ 'Xi ', 'Kao ', 'Lang ', 'Fu ', 'Ze ', 'Shui ', 'Lu ', 'Kun ', 'Gan ', 'Geng ', 'Ti ', 'Cheng ', 'Tu ', 'Shao ', 'Shui ', 'Ya ', 'Lun ', 'Lu ', 'Gu ', 'Zuo ', 'Ren ', 'Zhun ', 'Bang ', 'Bai ', 'Ji ', 'Zhi ', 'Zhi ', 'Kun ', 'Leng ', 'Peng ', 'Ke ', 'Bing ', 'Chou ', 'Zu ', 'Yu ', 'Su ', 'Lue ', '[?] ', 'Yi ', 'Xi ', 'Bian ', 'Ji ', 'Fu ', 'Bi ', 'Nuo ', 'Jie ', 'Zhong ', 'Zong ', 'Xu ', 'Cheng ', 'Dao ', 'Wen ', 'Lian ', 'Zi ', 'Yu ', 'Ji ', 'Xu ', 'Zhen ', 'Zhi ', 'Dao ', 'Jia ', 'Ji ', 'Gao ', 'Gao ', 'Gu ', 'Rong ', 'Sui ', 'You ', 'Ji ', 'Kang ', 'Mu ', 'Shan ', 'Men ', 'Zhi ', 'Ji ', 'Lu ', 'Su ', 'Ji ', 'Ying ', 'Wen ', 'Qiu ', 'Se ', '[?] ', 'Yi ', 'Huang ', 'Qie ', 'Ji ', 'Sui ', 'Xiao ', 'Pu ', 'Jiao ', 'Zhuo ', 'Tong ', 'Sai ', 'Lu ', 'Sui ', 'Nong ', 'Se ', 'Hui ', 'Rang ', 'Nuo ', 'Yu ', 'Bin ', 'Ji ', 'Tui ', 'Wen ', 'Cheng ', 'Huo ', 'Gong ', 'Lu ', 'Biao ', '[?] ', 'Rang ', 'Zhuo ', 'Li ', 'Zan ', 'Xue ', 'Wa ', 'Jiu ', 'Qiong ', 'Xi ', 'Qiong ', 'Kong ', 'Yu ', 'Sen ', 'Jing ', 'Yao ', 'Chuan ', 'Zhun ', 'Tu ', 'Lao ', 'Qie ', 'Zhai ', 'Yao ', 'Bian ', 'Bao ', 'Yao ', 'Bing ', 'Wa ', 'Zhu ', 'Jiao ', 'Qiao ', 'Diao ', 'Wu ', 'Gui ', 'Yao ', 'Zhi ', 'Chuang ', 'Yao ', 'Tiao ', 'Jiao ', 'Chuang ', 'Jiong ', 'Xiao ', 'Cheng ', 'Kou ', 'Cuan ', 'Wo ', 'Dan ', 'Ku ', 'Ke ', 'Zhui ', 'Xu ', 'Su ', 'Guan ', 'Kui ', 'Dou ', '[?] ', 'Yin ', 'Wo ', 'Wa ', 'Ya ', 'Yu ', 'Ju ', 'Qiong ', 'Yao ', 'Yao ', 'Tiao ', 'Chao ', 'Yu ', 'Tian ', 'Diao ', 'Ju ', 'Liao ', 'Xi ', 'Wu ', 'Kui ', 'Chuang ', 'Zhao ', '[?] ', 'Kuan ', 'Long ', 'Cheng ', 'Cui ', 'Piao ', 'Zao ', 'Cuan ', 'Qiao ', 'Qiong ', 'Dou ', 'Zao ', 'Long ', 'Qie ', 'Li ', 'Chu ', 'Shi ', 'Fou ', 'Qian ', 'Chu ', 'Hong ', 'Qi ', 'Qian ', 'Gong ', 'Shi ', 'Shu ', 'Miao ', 'Ju ', 'Zhan ', 'Zhu ', 'Ling ', 'Long ', 'Bing ', 'Jing ', 'Jing ', 'Zhang ', 'Yi ', 'Si ', 'Jun ', 'Hong ', 'Tong ', 'Song ', 'Jing ', 'Diao ', 'Yi ', 'Shu ', 'Jing ', 'Qu ', 'Jie ', 'Ping ', 'Duan ', 'Shao ', 'Zhuan ', 'Ceng ', 'Deng ', 'Cui ', 'Huai ', 'Jing ', 'Kan ', 'Jing ', 'Zhu ', 'Zhu ', 'Le ', 'Peng ', 'Yu ', 'Chi ', 'Gan ']


Joomla CMS: Référence du fichier PhpInfoCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier PhpInfoCollector.php

Structures de données

class PhpInfoCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier RawView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • View
  • Tracks
Structures de données | Espaces de nommage
Référence du fichier RawView.php

Structures de données

class RawView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\View\Tracks


Joomla CMS: Référence du fichier Tag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Tag.php

Structures de données

class Tag

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier SocketPost.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Structures de données | Espaces de nommage
Référence du fichier SocketPost.php

Structures de données

class SocketPost

Espaces de nommage

ReCaptcha\RequestMethod


Joomla CMS: Référence du fichier Php80.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
Structures de données | Espaces de nommage
Référence du fichier Php80.php

Structures de données

class Php80

Espaces de nommage

Symfony\Polyfill\Php80


Joomla CMS: Référence du fichier SilencedErrorContext.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Exception
Structures de données | Espaces de nommage
Référence du fichier SilencedErrorContext.php

Structures de données

class SilencedErrorContext

Espaces de nommage

Symfony\Component\ErrorHandler\Exception


Joomla CMS: Référence du fichier PostalAddress.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PostalAddress.php

Structures de données

class PostalAddress

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SessionEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier SessionEvent.php

Structures de données

class SessionEvent

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier SymmetricKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Key
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Key/SymmetricKey.php

Structures de données

class SymmetricKey

Espaces de nommage

Cose\Key


Joomla CMS: Référence du fichier str_pad.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier str_pad.php

Espaces de nommage

utf8

Fonctions

utf8_str_pad ($input, $length, $padStr=' ', $type=STR_PAD_RIGHT)

Documentation des fonctions

◆ utf8_str_pad()

utf8_str_pad | ( | $input,
 |  | $length,
 |  | $padStr = ' ',
 |  | $type = STR_PAD_RIGHT
 | ) |

Références $input, $type, utf8_strlen(), et utf8_substr().

Référencé par StringHelper\str_pad().


Joomla CMS: Référence du fichier WorkflowStage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier WorkflowStage.php

Structures de données

class WorkflowStage

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier skipto.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • skipto
Structures de données | Espaces de nommage
Référence du fichier skipto.php

Structures de données

class PlgSystemSkipto

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

EC
phpseclib3\Crypt\EC


Joomla CMS: Référence du fichier RSAPrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RSAPrivateKey.php

Structures de données

class RSAPrivateKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Portuguese.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Portuguese.php

Structures de données

class Portuguese

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier Sha512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Rsa
Structures de données | Espaces de nommage
Référence du fichier Rsa/Sha512.php

Structures de données

class Sha512

Espaces de nommage

Lcobucci\JWT\Signer\Rsa


Joomla CMS: Référence du fichier Raw.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier Common/Formats/Signature/Raw.php

Structures de données

class Raw

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Signature


Joomla CMS: Référence du fichier UnknownObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier UnknownObject.php

Structures de données

class UnknownObject

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier RouterBase.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterBase.php

Structures de données

class RouterBase

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier TemplatesComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier TemplatesComponent.php

Structures de données

class TemplatesComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Extension


Joomla CMS: Référence du fichier ResultTypeNumericAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeNumericAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeNumericAware


Joomla CMS: Référence du fichier PolicyInformation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PolicyInformation.php

Structures de données

class PolicyInformation

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier sect163r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect163r1.php

Structures de données

class sect163r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Zip.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier Zip.php

Structures de données

class Zip

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/webauthn/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RequestController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Controller/RequestController.php

Structures de données

class RequestController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Controller


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/nyholm/psr7/src/Stream.php

Structures de données

class Stream

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier TaskTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier TaskTable.php

Structures de données

class TaskTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Table


Joomla CMS: Référence du fichier UnknownConstructedObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier UnknownConstructedObject.php

Structures de données

class UnknownConstructedObject

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier x05b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05b.php

Variables

return ['Gui ', 'Deng ', 'Zhi ', 'Xu ', 'Yi ', 'Hua ', 'Xi ', 'Hui ', 'Rao ', 'Xi ', 'Yan ', 'Chan ', 'Jiao ', 'Mei ', 'Fan ', 'Fan ', 'Xian ', 'Yi ', 'Wei ', 'Jiao ', 'Fu ', 'Shi ', 'Bi ', 'Shan ', 'Sui ', 'Qiang ', 'Lian ', 'Huan ', 'Xin ', 'Niao ', 'Dong ', 'Yi ', 'Can ', 'Ai ', 'Niang ', 'Neng ', 'Ma ', 'Tiao ', 'Chou ', 'Jin ', 'Ci ', 'Yu ', 'Pin ', 'Yong ', 'Xu ', 'Nai ', 'Yan ', 'Tai ', 'Ying ', 'Can ', 'Niao ', 'Wo ', 'Ying ', 'Mian ', 'Kaka ', 'Ma ', 'Shen ', 'Xing ', 'Ni ', 'Du ', 'Liu ', 'Yuan ', 'Lan ', 'Yan ', 'Shuang ', 'Ling ', 'Jiao ', 'Niang ', 'Lan ', 'Xian ', 'Ying ', 'Shuang ', 'Shuai ', 'Quan ', 'Mi ', 'Li ', 'Luan ', 'Yan ', 'Zhu ', 'Lan ', 'Zi ', 'Jie ', 'Jue ', 'Jue ', 'Kong ', 'Yun ', 'Zi ', 'Zi ', 'Cun ', 'Sun ', 'Fu ', 'Bei ', 'Zi ', 'Xiao ', 'Xin ', 'Meng ', 'Si ', 'Tai ', 'Bao ', 'Ji ', 'Gu ', 'Nu ', 'Xue ', '[?] ', 'Zhuan ', 'Hai ', 'Luan ', 'Sun ', 'Huai ', 'Mie ', 'Cong ', 'Qian ', 'Shu ', 'Chan ', 'Ya ', 'Zi ', 'Ni ', 'Fu ', 'Zi ', 'Li ', 'Xue ', 'Bo ', 'Ru ', 'Lai ', 'Nie ', 'Nie ', 'Ying ', 'Luan ', 'Mian ', 'Zhu ', 'Rong ', 'Ta ', 'Gui ', 'Zhai ', 'Qiong ', 'Yu ', 'Shou ', 'An ', 'Tu ', 'Song ', 'Wan ', 'Rou ', 'Yao ', 'Hong ', 'Yi ', 'Jing ', 'Zhun ', 'Mi ', 'Zhu ', 'Dang ', 'Hong ', 'Zong ', 'Guan ', 'Zhou ', 'Ding ', 'Wan ', 'Yi ', 'Bao ', 'Shi ', 'Shi ', 'Chong ', 'Shen ', 'Ke ', 'Xuan ', 'Shi ', 'You ', 'Huan ', 'Yi ', 'Tiao ', 'Shi ', 'Xian ', 'Gong ', 'Cheng ', 'Qun ', 'Gong ', 'Xiao ', 'Zai ', 'Zha ', 'Bao ', 'Hai ', 'Yan ', 'Xiao ', 'Jia ', 'Shen ', 'Chen ', 'Rong ', 'Huang ', 'Mi ', 'Kou ', 'Kuan ', 'Bin ', 'Su ', 'Cai ', 'Zan ', 'Ji ', 'Yuan ', 'Ji ', 'Yin ', 'Mi ', 'Kou ', 'Qing ', 'Que ', 'Zhen ', 'Jian ', 'Fu ', 'Ning ', 'Bing ', 'Huan ', 'Mei ', 'Qin ', 'Han ', 'Yu ', 'Shi ', 'Ning ', 'Qin ', 'Ning ', 'Zhi ', 'Yu ', 'Bao ', 'Kuan ', 'Ning ', 'Qin ', 'Mo ', 'Cha ', 'Ju ', 'Gua ', 'Qin ', 'Hu ', 'Wu ', 'Liao ', 'Shi ', 'Zhu ', 'Zhai ', 'Shen ', 'Wei ', 'Xie ', 'Kuan ', 'Hui ', 'Liao ', 'Jun ', 'Huan ', 'Yi ', 'Yi ', 'Bao ', 'Qin ', 'Chong ', 'Bao ', 'Feng ', 'Cun ', 'Dui ', 'Si ', 'Xun ', 'Dao ', 'Lu ', 'Dui ', 'Shou ']

Documentation des variables

◆ return

return[ 'Gui ', 'Deng ', 'Zhi ', 'Xu ', 'Yi ', 'Hua ', 'Xi ', 'Hui ', 'Rao ', 'Xi ', 'Yan ', 'Chan ', 'Jiao ', 'Mei ', 'Fan ', 'Fan ', 'Xian ', 'Yi ', 'Wei ', 'Jiao ', 'Fu ', 'Shi ', 'Bi ', 'Shan ', 'Sui ', 'Qiang ', 'Lian ', 'Huan ', 'Xin ', 'Niao ', 'Dong ', 'Yi ', 'Can ', 'Ai ', 'Niang ', 'Neng ', 'Ma ', 'Tiao ', 'Chou ', 'Jin ', 'Ci ', 'Yu ', 'Pin ', 'Yong ', 'Xu ', 'Nai ', 'Yan ', 'Tai ', 'Ying ', 'Can ', 'Niao ', 'Wo ', 'Ying ', 'Mian ', 'Kaka ', 'Ma ', 'Shen ', 'Xing ', 'Ni ', 'Du ', 'Liu ', 'Yuan ', 'Lan ', 'Yan ', 'Shuang ', 'Ling ', 'Jiao ', 'Niang ', 'Lan ', 'Xian ', 'Ying ', 'Shuang ', 'Shuai ', 'Quan ', 'Mi ', 'Li ', 'Luan ', 'Yan ', 'Zhu ', 'Lan ', 'Zi ', 'Jie ', 'Jue ', 'Jue ', 'Kong ', 'Yun ', 'Zi ', 'Zi ', 'Cun ', 'Sun ', 'Fu ', 'Bei ', 'Zi ', 'Xiao ', 'Xin ', 'Meng ', 'Si ', 'Tai ', 'Bao ', 'Ji ', 'Gu ', 'Nu ', 'Xue ', '[?] ', 'Zhuan ', 'Hai ', 'Luan ', 'Sun ', 'Huai ', 'Mie ', 'Cong ', 'Qian ', 'Shu ', 'Chan ', 'Ya ', 'Zi ', 'Ni ', 'Fu ', 'Zi ', 'Li ', 'Xue ', 'Bo ', 'Ru ', 'Lai ', 'Nie ', 'Nie ', 'Ying ', 'Luan ', 'Mian ', 'Zhu ', 'Rong ', 'Ta ', 'Gui ', 'Zhai ', 'Qiong ', 'Yu ', 'Shou ', 'An ', 'Tu ', 'Song ', 'Wan ', 'Rou ', 'Yao ', 'Hong ', 'Yi ', 'Jing ', 'Zhun ', 'Mi ', 'Zhu ', 'Dang ', 'Hong ', 'Zong ', 'Guan ', 'Zhou ', 'Ding ', 'Wan ', 'Yi ', 'Bao ', 'Shi ', 'Shi ', 'Chong ', 'Shen ', 'Ke ', 'Xuan ', 'Shi ', 'You ', 'Huan ', 'Yi ', 'Tiao ', 'Shi ', 'Xian ', 'Gong ', 'Cheng ', 'Qun ', 'Gong ', 'Xiao ', 'Zai ', 'Zha ', 'Bao ', 'Hai ', 'Yan ', 'Xiao ', 'Jia ', 'Shen ', 'Chen ', 'Rong ', 'Huang ', 'Mi ', 'Kou ', 'Kuan ', 'Bin ', 'Su ', 'Cai ', 'Zan ', 'Ji ', 'Yuan ', 'Ji ', 'Yin ', 'Mi ', 'Kou ', 'Qing ', 'Que ', 'Zhen ', 'Jian ', 'Fu ', 'Ning ', 'Bing ', 'Huan ', 'Mei ', 'Qin ', 'Han ', 'Yu ', 'Shi ', 'Ning ', 'Qin ', 'Ning ', 'Zhi ', 'Yu ', 'Bao ', 'Kuan ', 'Ning ', 'Qin ', 'Mo ', 'Cha ', 'Ju ', 'Gua ', 'Qin ', 'Hu ', 'Wu ', 'Liao ', 'Shi ', 'Zhu ', 'Zhai ', 'Shen ', 'Wei ', 'Xie ', 'Kuan ', 'Hui ', 'Liao ', 'Jun ', 'Huan ', 'Yi ', 'Yi ', 'Bao ', 'Qin ', 'Chong ', 'Bao ', 'Feng ', 'Cun ', 'Dui ', 'Si ', 'Xun ', 'Dao ', 'Lu ', 'Dui ', 'Shou ']


Joomla CMS: Référence du fichier x0ba.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ba.php

Variables

return ['mya', 'myag', 'myagg', 'myags', 'myan', 'myanj', 'myanh', 'myad', 'myal', 'myalg', 'myalm', 'myalb', 'myals', 'myalt', 'myalp', 'myalh', 'myam', 'myab', 'myabs', 'myas', 'myass', 'myang', 'myaj', 'myac', 'myak', 'myat', 'myap', 'myah', 'myae', 'myaeg', 'myaegg', 'myaegs', 'myaen', 'myaenj', 'myaenh', 'myaed', 'myael', 'myaelg', 'myaelm', 'myaelb', 'myaels', 'myaelt', 'myaelp', 'myaelh', 'myaem', 'myaeb', 'myaebs', 'myaes', 'myaess', 'myaeng', 'myaej', 'myaec', 'myaek', 'myaet', 'myaep', 'myaeh', 'meo', 'meog', 'meogg', 'meogs', 'meon', 'meonj', 'meonh', 'meod', 'meol', 'meolg', 'meolm', 'meolb', 'meols', 'meolt', 'meolp', 'meolh', 'meom', 'meob', 'meobs', 'meos', 'meoss', 'meong', 'meoj', 'meoc', 'meok', 'meot', 'meop', 'meoh', 'me', 'meg', 'megg', 'megs', 'men', 'menj', 'menh', 'med', 'mel', 'melg', 'melm', 'melb', 'mels', 'melt', 'melp', 'melh', 'mem', 'meb', 'mebs', 'mes', 'mess', 'meng', 'mej', 'mec', 'mek', 'met', 'mep', 'meh', 'myeo', 'myeog', 'myeogg', 'myeogs', 'myeon', 'myeonj', 'myeonh', 'myeod', 'myeol', 'myeolg', 'myeolm', 'myeolb', 'myeols', 'myeolt', 'myeolp', 'myeolh', 'myeom', 'myeob', 'myeobs', 'myeos', 'myeoss', 'myeong', 'myeoj', 'myeoc', 'myeok', 'myeot', 'myeop', 'myeoh', 'mye', 'myeg', 'myegg', 'myegs', 'myen', 'myenj', 'myenh', 'myed', 'myel', 'myelg', 'myelm', 'myelb', 'myels', 'myelt', 'myelp', 'myelh', 'myem', 'myeb', 'myebs', 'myes', 'myess', 'myeng', 'myej', 'myec', 'myek', 'myet', 'myep', 'myeh', 'mo', 'mog', 'mogg', 'mogs', 'mon', 'monj', 'monh', 'mod', 'mol', 'molg', 'molm', 'molb', 'mols', 'molt', 'molp', 'molh', 'mom', 'mob', 'mobs', 'mos', 'moss', 'mong', 'moj', 'moc', 'mok', 'mot', 'mop', 'moh', 'mwa', 'mwag', 'mwagg', 'mwags', 'mwan', 'mwanj', 'mwanh', 'mwad', 'mwal', 'mwalg', 'mwalm', 'mwalb', 'mwals', 'mwalt', 'mwalp', 'mwalh', 'mwam', 'mwab', 'mwabs', 'mwas', 'mwass', 'mwang', 'mwaj', 'mwac', 'mwak', 'mwat', 'mwap', 'mwah', 'mwae', 'mwaeg', 'mwaegg', 'mwaegs', 'mwaen', 'mwaenj', 'mwaenh', 'mwaed', 'mwael', 'mwaelg', 'mwaelm', 'mwaelb', 'mwaels', 'mwaelt', 'mwaelp', 'mwaelh', 'mwaem', 'mwaeb', 'mwaebs', 'mwaes', 'mwaess', 'mwaeng', 'mwaej', 'mwaec', 'mwaek', 'mwaet', 'mwaep', 'mwaeh', 'moe', 'moeg', 'moegg', 'moegs']

Documentation des variables

◆ return

return[ 'mya', 'myag', 'myagg', 'myags', 'myan', 'myanj', 'myanh', 'myad', 'myal', 'myalg', 'myalm', 'myalb', 'myals', 'myalt', 'myalp', 'myalh', 'myam', 'myab', 'myabs', 'myas', 'myass', 'myang', 'myaj', 'myac', 'myak', 'myat', 'myap', 'myah', 'myae', 'myaeg', 'myaegg', 'myaegs', 'myaen', 'myaenj', 'myaenh', 'myaed', 'myael', 'myaelg', 'myaelm', 'myaelb', 'myaels', 'myaelt', 'myaelp', 'myaelh', 'myaem', 'myaeb', 'myaebs', 'myaes', 'myaess', 'myaeng', 'myaej', 'myaec', 'myaek', 'myaet', 'myaep', 'myaeh', 'meo', 'meog', 'meogg', 'meogs', 'meon', 'meonj', 'meonh', 'meod', 'meol', 'meolg', 'meolm', 'meolb', 'meols', 'meolt', 'meolp', 'meolh', 'meom', 'meob', 'meobs', 'meos', 'meoss', 'meong', 'meoj', 'meoc', 'meok', 'meot', 'meop', 'meoh', 'me', 'meg', 'megg', 'megs', 'men', 'menj', 'menh', 'med', 'mel', 'melg', 'melm', 'melb', 'mels', 'melt', 'melp', 'melh', 'mem', 'meb', 'mebs', 'mes', 'mess', 'meng', 'mej', 'mec', 'mek', 'met', 'mep', 'meh', 'myeo', 'myeog', 'myeogg', 'myeogs', 'myeon', 'myeonj', 'myeonh', 'myeod', 'myeol', 'myeolg', 'myeolm', 'myeolb', 'myeols', 'myeolt', 'myeolp', 'myeolh', 'myeom', 'myeob', 'myeobs', 'myeos', 'myeoss', 'myeong', 'myeoj', 'myeoc', 'myeok', 'myeot', 'myeop', 'myeoh', 'mye', 'myeg', 'myegg', 'myegs', 'myen', 'myenj', 'myenh', 'myed', 'myel', 'myelg', 'myelm', 'myelb', 'myels', 'myelt', 'myelp', 'myelh', 'myem', 'myeb', 'myebs', 'myes', 'myess', 'myeng', 'myej', 'myec', 'myek', 'myet', 'myep', 'myeh', 'mo', 'mog', 'mogg', 'mogs', 'mon', 'monj', 'monh', 'mod', 'mol', 'molg', 'molm', 'molb', 'mols', 'molt', 'molp', 'molh', 'mom', 'mob', 'mobs', 'mos', 'moss', 'mong', 'moj', 'moc', 'mok', 'mot', 'mop', 'moh', 'mwa', 'mwag', 'mwagg', 'mwags', 'mwan', 'mwanj', 'mwanh', 'mwad', 'mwal', 'mwalg', 'mwalm', 'mwalb', 'mwals', 'mwalt', 'mwalp', 'mwalh', 'mwam', 'mwab', 'mwabs', 'mwas', 'mwass', 'mwang', 'mwaj', 'mwac', 'mwak', 'mwat', 'mwap', 'mwah', 'mwae', 'mwaeg', 'mwaegg', 'mwaegs', 'mwaen', 'mwaenj', 'mwaenh', 'mwaed', 'mwael', 'mwaelg', 'mwaelm', 'mwaelb', 'mwaels', 'mwaelt', 'mwaelp', 'mwaelh', 'mwaem', 'mwaeb', 'mwaebs', 'mwaes', 'mwaess', 'mwaeng', 'mwaej', 'mwaec', 'mwaek', 'mwaet', 'mwaep', 'mwaeh', 'moe', 'moeg', 'moegg', 'moegs']


Joomla CMS: Référence du fichier UCMContent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • UCM
Structures de données | Espaces de nommage
Référence du fichier UCMContent.php

Structures de données

class UCMContent

Espaces de nommage

Joomla\CMS\UCM


Joomla CMS: Référence du fichier ServerDumper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
Structures de données | Espaces de nommage
Référence du fichier ServerDumper.php

Structures de données

class ServerDumper

Espaces de nommage

Symfony\Component\VarDumper\Dumper


Joomla CMS: Référence du fichier PublicKeyCredentialParameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialParameters.php

Structures de données

class PublicKeyCredentialParameters

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier WebAssetRegistry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/WebAssetRegistry.php

Structures de données

class WebAssetRegistry

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier UpdatesiteModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier UpdatesiteModel.php

Structures de données

class UpdatesiteModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier VotelistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier VotelistField.php

Structures de données

class VotelistField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Field


Joomla CMS: Référence du fichier TransitionButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Button
Structures de données | Espaces de nommage
Référence du fichier TransitionButton.php

Structures de données

class TransitionButton

Espaces de nommage

Joomla\CMS\Button


Joomla CMS: Référence du fichier WhosonlineHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_whosonline
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier WhosonlineHelper.php

Structures de données

class WhosonlineHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Whosonline\Site\Helper


Joomla CMS: Référence du fichier TaskTypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TaskTypeField.php

Structures de données

class TaskTypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier PrivacyField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • privacyconsent
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PrivacyField.php

Structures de données

class PrivacyField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\PrivacyConsent\Field


Joomla CMS: Référence du fichier Update.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Table/Update.php

Structures de données

class Update

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier transition-button.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • button
Espaces de nommage | Variables
Référence du fichier transition-button.php

Espaces de nommage

Joomla\Site

Variables

$disabled = empty($options['transitions']) || !empty($options['disabled'])
$id = $options['id']
$tipTitle = $options['tip_title']
$tipContent = $options['tip_content']
$checkboxName = $options['checkbox_name']
$task = $options['task']
$default
$transitions = array_merge($default, $options['transitions'])
$attribs
endif

Documentation des variables

◆ $attribs

$attribs
Valeur initiale :
= [
'id' => 'transition-select_' . (int) $row ?? ''

◆ $checkboxName

$checkboxName = $options['checkbox_name']

◆ $default

$default
Valeur initiale :
= [
HTMLHelper::_('select.option', '', $this->escape($options['title'])),
HTMLHelper::_('select.option', '-1', '--------', ['disable' => true])
]
$options
$options
Definition: administrator/components/com_associations/tmpl/association/edit.php:27

Référencé par Input\__call(), LazyCommand\addArgument(), AbstractCommand\addArgument(), Command\addArgument(), LazyCommand\addOption(), AbstractCommand\addOption(), Command\addOption(), SymfonyStyle\ask(), SymfonyStyle\choice(), SymfonyStyle\confirm(), CMSObject\def(), Registry\def(), TextDescriptor\describeInputArgument(), TextDescriptor\describeInputOption(), RouteHelper\findItem(), TextDescriptor\formatDefaultValue(), DataSet\get(), Files\get(), CMSObject\get(), AbstractView\get(), AbstractApplication\get(), JoomlaStorage\get(), RuntimeStorage\get(), NativeStorage\get(), Input\get(), Session\get(), Registry\get(), Task\get(), Stream\get(), AbstractEvent\getArgument(), ServerRequest\getAttribute(), WebAssetItem\getAttribute(), FormField\getAttribute(), Form\getAttribute(), HttpFactory\getAvailableDriver(), QuickIconHelper\getButtons(), CMSApplication\getCfg(), Token\getClaim(), ApplicationHelper\getComponentName(), QuestionHelper\getDefaultAnswer(), LintCommand\getDirectoryIterator(), Dispatcher\getEvent(), Form\getFieldAttribute(), InstallerHelper\getFilenameFromUrl(), ExecRuleHelper\getFromTask(), Token\getHeader(), Parameters\getInput(), XmlDescriptor\getInputArgumentDocument(), XmlDescriptor\getInputOptionDocument(), LanguagesHelper\getList(), AbstractTransport\getOption(), Http\getOption(), WebAssetItem\getOption(), ActionButton\getOption(), ToolbarButton\getOption(), Client\getOption(), TransitionField\getOptions(), User\getParam(), BaseAccept\getParameter(), ArrayInput\getParameterOption(), ArgvInput\getParameterOption(), Installer\getPath(), ListenersPriorityQueue\getPriority(), Joomla\CMS\MVC\Model\getState(), CMSApplication\getUserState(), ListModel\getUserStateFromRequest(), CMSApplication\getUserStateFromRequest(), ArrayHelper\getValue(), Form\getValue(), AbstractUri\getVar(), Container\hasFlag(), Helper\isCommon(), LintCommand\isReadable(), Form\loadField(), Laminas\Diactoros\marshalUriFromSapi(), PlgUserToken\onUserAfterSave(), UpdatesitesModel\populateState(), MenuRules\preprocess(), PublishedButton\render(), TransitionButton\render(), FeaturedButton\render(), Form\renderField(), AbstractView\setModel(), CaptchaField\setup(), CheckboxField\setup(), ArrayHelper\toInteger(), et SymfonyQuestionHelper\writePrompt().

◆ $disabled

$disabled = empty($options['transitions']) || !empty($options['disabled'])

◆ $id

$id = $options['id']

◆ $task

$task = $options['task']

◆ $tipContent

$tipContent = $options['tip_content']

◆ $tipTitle

$tipTitle = $options['tip_title']

◆ $transitions

$transitions = array_merge($default, $options['transitions'])

◆ endif

endif
Valeur initiale :
=> [
'class' => 'form-select form-select-sm w-auto',
'onchange' => "this.form.transition_id.value=this.value;Joomla.listItemTask('" . $checkboxName . $this->escape($row ?? '') . "', '" . $task . "')"]
]
$checkboxName
$checkboxName
Definition: transition-button.php:34
$task
$task
Definition: transition-button.php:35


Joomla CMS: Référence du fichier ResponseFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier ResponseFactoryInterface.php

Structures de données

interface ResponseFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier TextareaField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TextareaField.php

Structures de données

class TextareaField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier x070.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x070.php

Variables

return ['You ', 'Yang ', 'Lu ', 'Si ', 'Jie ', 'Ying ', 'Du ', 'Wang ', 'Hui ', 'Xie ', 'Pan ', 'Shen ', 'Biao ', 'Chan ', 'Mo ', 'Liu ', 'Jian ', 'Pu ', 'Se ', 'Cheng ', 'Gu ', 'Bin ', 'Huo ', 'Xian ', 'Lu ', 'Qin ', 'Han ', 'Ying ', 'Yong ', 'Li ', 'Jing ', 'Xiao ', 'Ying ', 'Sui ', 'Wei ', 'Xie ', 'Huai ', 'Hao ', 'Zhu ', 'Long ', 'Lai ', 'Dui ', 'Fan ', 'Hu ', 'Lai ', '[?] ', '[?] ', 'Ying ', 'Mi ', 'Ji ', 'Lian ', 'Jian ', 'Ying ', 'Fen ', 'Lin ', 'Yi ', 'Jian ', 'Yue ', 'Chan ', 'Dai ', 'Rang ', 'Jian ', 'Lan ', 'Fan ', 'Shuang ', 'Yuan ', 'Zhuo ', 'Feng ', 'She ', 'Lei ', 'Lan ', 'Cong ', 'Qu ', 'Yong ', 'Qian ', 'Fa ', 'Guan ', 'Que ', 'Yan ', 'Hao ', 'Hyeng ', 'Sa ', 'Zan ', 'Luan ', 'Yan ', 'Li ', 'Mi ', 'Shan ', 'Tan ', 'Dang ', 'Jiao ', 'Chan ', '[?] ', 'Hao ', 'Ba ', 'Zhu ', 'Lan ', 'Lan ', 'Nang ', 'Wan ', 'Luan ', 'Xun ', 'Xian ', 'Yan ', 'Gan ', 'Yan ', 'Yu ', 'Huo ', 'Si ', 'Mie ', 'Guang ', 'Deng ', 'Hui ', 'Xiao ', 'Xiao ', 'Hu ', 'Hong ', 'Ling ', 'Zao ', 'Zhuan ', 'Jiu ', 'Zha ', 'Xie ', 'Chi ', 'Zhuo ', 'Zai ', 'Zai ', 'Can ', 'Yang ', 'Qi ', 'Zhong ', 'Fen ', 'Niu ', 'Jiong ', 'Wen ', 'Po ', 'Yi ', 'Lu ', 'Chui ', 'Pi ', 'Kai ', 'Pan ', 'Yan ', 'Kai ', 'Pang ', 'Mu ', 'Chao ', 'Liao ', 'Gui ', 'Kang ', 'Tun ', 'Guang ', 'Xin ', 'Zhi ', 'Guang ', 'Guang ', 'Wei ', 'Qiang ', '[?] ', 'Da ', 'Xia ', 'Zheng ', 'Zhu ', 'Ke ', 'Zhao ', 'Fu ', 'Ba ', 'Duo ', 'Duo ', 'Ling ', 'Zhuo ', 'Xuan ', 'Ju ', 'Tan ', 'Pao ', 'Jiong ', 'Pao ', 'Tai ', 'Tai ', 'Bing ', 'Yang ', 'Tong ', 'Han ', 'Zhu ', 'Zha ', 'Dian ', 'Wei ', 'Shi ', 'Lian ', 'Chi ', 'Huang ', '[?] ', 'Hu ', 'Shuo ', 'Lan ', 'Jing ', 'Jiao ', 'Xu ', 'Xing ', 'Quan ', 'Lie ', 'Huan ', 'Yang ', 'Xiao ', 'Xiu ', 'Xian ', 'Yin ', 'Wu ', 'Zhou ', 'Yao ', 'Shi ', 'Wei ', 'Tong ', 'Xue ', 'Zai ', 'Kai ', 'Hong ', 'Luo ', 'Xia ', 'Zhu ', 'Xuan ', 'Zheng ', 'Po ', 'Yan ', 'Hui ', 'Guang ', 'Zhe ', 'Hui ', 'Kao ', '[?] ', 'Fan ', 'Shao ', 'Ye ', 'Hui ', '[?] ', 'Tang ', 'Jin ', 'Re ', '[?] ', 'Xi ', 'Fu ', 'Jiong ', 'Che ', 'Pu ', 'Jing ', 'Zhuo ', 'Ting ', 'Wan ', 'Hai ', 'Peng ', 'Lang ', 'Shan ', 'Hu ', 'Feng ', 'Chi ', 'Rong ']

Documentation des variables

◆ return

return[ 'You ', 'Yang ', 'Lu ', 'Si ', 'Jie ', 'Ying ', 'Du ', 'Wang ', 'Hui ', 'Xie ', 'Pan ', 'Shen ', 'Biao ', 'Chan ', 'Mo ', 'Liu ', 'Jian ', 'Pu ', 'Se ', 'Cheng ', 'Gu ', 'Bin ', 'Huo ', 'Xian ', 'Lu ', 'Qin ', 'Han ', 'Ying ', 'Yong ', 'Li ', 'Jing ', 'Xiao ', 'Ying ', 'Sui ', 'Wei ', 'Xie ', 'Huai ', 'Hao ', 'Zhu ', 'Long ', 'Lai ', 'Dui ', 'Fan ', 'Hu ', 'Lai ', '[?] ', '[?] ', 'Ying ', 'Mi ', 'Ji ', 'Lian ', 'Jian ', 'Ying ', 'Fen ', 'Lin ', 'Yi ', 'Jian ', 'Yue ', 'Chan ', 'Dai ', 'Rang ', 'Jian ', 'Lan ', 'Fan ', 'Shuang ', 'Yuan ', 'Zhuo ', 'Feng ', 'She ', 'Lei ', 'Lan ', 'Cong ', 'Qu ', 'Yong ', 'Qian ', 'Fa ', 'Guan ', 'Que ', 'Yan ', 'Hao ', 'Hyeng ', 'Sa ', 'Zan ', 'Luan ', 'Yan ', 'Li ', 'Mi ', 'Shan ', 'Tan ', 'Dang ', 'Jiao ', 'Chan ', '[?] ', 'Hao ', 'Ba ', 'Zhu ', 'Lan ', 'Lan ', 'Nang ', 'Wan ', 'Luan ', 'Xun ', 'Xian ', 'Yan ', 'Gan ', 'Yan ', 'Yu ', 'Huo ', 'Si ', 'Mie ', 'Guang ', 'Deng ', 'Hui ', 'Xiao ', 'Xiao ', 'Hu ', 'Hong ', 'Ling ', 'Zao ', 'Zhuan ', 'Jiu ', 'Zha ', 'Xie ', 'Chi ', 'Zhuo ', 'Zai ', 'Zai ', 'Can ', 'Yang ', 'Qi ', 'Zhong ', 'Fen ', 'Niu ', 'Jiong ', 'Wen ', 'Po ', 'Yi ', 'Lu ', 'Chui ', 'Pi ', 'Kai ', 'Pan ', 'Yan ', 'Kai ', 'Pang ', 'Mu ', 'Chao ', 'Liao ', 'Gui ', 'Kang ', 'Tun ', 'Guang ', 'Xin ', 'Zhi ', 'Guang ', 'Guang ', 'Wei ', 'Qiang ', '[?] ', 'Da ', 'Xia ', 'Zheng ', 'Zhu ', 'Ke ', 'Zhao ', 'Fu ', 'Ba ', 'Duo ', 'Duo ', 'Ling ', 'Zhuo ', 'Xuan ', 'Ju ', 'Tan ', 'Pao ', 'Jiong ', 'Pao ', 'Tai ', 'Tai ', 'Bing ', 'Yang ', 'Tong ', 'Han ', 'Zhu ', 'Zha ', 'Dian ', 'Wei ', 'Shi ', 'Lian ', 'Chi ', 'Huang ', '[?] ', 'Hu ', 'Shuo ', 'Lan ', 'Jing ', 'Jiao ', 'Xu ', 'Xing ', 'Quan ', 'Lie ', 'Huan ', 'Yang ', 'Xiao ', 'Xiu ', 'Xian ', 'Yin ', 'Wu ', 'Zhou ', 'Yao ', 'Shi ', 'Wei ', 'Tong ', 'Xue ', 'Zai ', 'Kai ', 'Hong ', 'Luo ', 'Xia ', 'Zhu ', 'Xuan ', 'Zheng ', 'Po ', 'Yan ', 'Hui ', 'Guang ', 'Zhe ', 'Hui ', 'Kao ', '[?] ', 'Fan ', 'Shao ', 'Ye ', 'Hui ', '[?] ', 'Tang ', 'Jin ', 'Re ', '[?] ', 'Xi ', 'Fu ', 'Jiong ', 'Che ', 'Pu ', 'Jing ', 'Zhuo ', 'Ting ', 'Wan ', 'Hai ', 'Peng ', 'Lang ', 'Shan ', 'Hu ', 'Feng ', 'Chi ', 'Rong ']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_admin/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Substitution.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Substitution.php

Structures de données

class Substitution

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier Result.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier Result.php

Structures de données

class Result

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier SignatureAlgorithm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Algorithm
Structures de données | Espaces de nommage
Référence du fichier SignatureAlgorithm.php

Structures de données

interface SignatureAlgorithm

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier x0a1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0a1.php

Variables

return ['dit', 'dix', 'di', 'dip', 'diex', 'die', 'diep', 'dat', 'dax', 'da', 'dap', 'duox', 'duo', 'dot', 'dox', 'do', 'dop', 'dex', 'de', 'dep', 'dut', 'dux', 'du', 'dup', 'durx', 'dur', 'tit', 'tix', 'ti', 'tip', 'tiex', 'tie', 'tiep', 'tat', 'tax', 'ta', 'tap', 'tuot', 'tuox', 'tuo', 'tuop', 'tot', 'tox', 'to', 'top', 'tex', 'te', 'tep', 'tut', 'tux', 'tu', 'tup', 'turx', 'tur', 'ddit', 'ddix', 'ddi', 'ddip', 'ddiex', 'ddie', 'ddiep', 'ddat', 'ddax', 'dda', 'ddap', 'dduox', 'dduo', 'dduop', 'ddot', 'ddox', 'ddo', 'ddop', 'ddex', 'dde', 'ddep', 'ddut', 'ddux', 'ddu', 'ddup', 'ddurx', 'ddur', 'ndit', 'ndix', 'ndi', 'ndip', 'ndiex', 'ndie', 'ndat', 'ndax', 'nda', 'ndap', 'ndot', 'ndox', 'ndo', 'ndop', 'ndex', 'nde', 'ndep', 'ndut', 'ndux', 'ndu', 'ndup', 'ndurx', 'ndur', 'hnit', 'hnix', 'hni', 'hnip', 'hniet', 'hniex', 'hnie', 'hniep', 'hnat', 'hnax', 'hna', 'hnap', 'hnuox', 'hnuo', 'hnot', 'hnox', 'hnop', 'hnex', 'hne', 'hnep', 'hnut', 'nit', 'nix', 'ni', 'nip', 'niex', 'nie', 'niep', 'nax', 'na', 'nap', 'nuox', 'nuo', 'nuop', 'not', 'nox', 'no', 'nop', 'nex', 'ne', 'nep', 'nut', 'nux', 'nu', 'nup', 'nurx', 'nur', 'hlit', 'hlix', 'hli', 'hlip', 'hliex', 'hlie', 'hliep', 'hlat', 'hlax', 'hla', 'hlap', 'hluox', 'hluo', 'hluop', 'hlox', 'hlo', 'hlop', 'hlex', 'hle', 'hlep', 'hlut', 'hlux', 'hlu', 'hlup', 'hlurx', 'hlur', 'hlyt', 'hlyx', 'hly', 'hlyp', 'hlyrx', 'hlyr', 'lit', 'lix', 'li', 'lip', 'liet', 'liex', 'lie', 'liep', 'lat', 'lax', 'la', 'lap', 'luot', 'luox', 'luo', 'luop', 'lot', 'lox', 'lo', 'lop', 'lex', 'le', 'lep', 'lut', 'lux', 'lu', 'lup', 'lurx', 'lur', 'lyt', 'lyx', 'ly', 'lyp', 'lyrx', 'lyr', 'git', 'gix', 'gi', 'gip', 'giet', 'giex', 'gie', 'giep', 'gat', 'gax', 'ga', 'gap', 'guot', 'guox', 'guo', 'guop', 'got', 'gox', 'go', 'gop', 'get', 'gex', 'ge', 'gep', 'gut', 'gux', 'gu', 'gup', 'gurx', 'gur', 'kit', 'kix', 'ki', 'kip', 'kiex', 'kie', 'kiep', 'kat']

Documentation des variables

◆ return

return[ 'dit', 'dix', 'di', 'dip', 'diex', 'die', 'diep', 'dat', 'dax', 'da', 'dap', 'duox', 'duo', 'dot', 'dox', 'do', 'dop', 'dex', 'de', 'dep', 'dut', 'dux', 'du', 'dup', 'durx', 'dur', 'tit', 'tix', 'ti', 'tip', 'tiex', 'tie', 'tiep', 'tat', 'tax', 'ta', 'tap', 'tuot', 'tuox', 'tuo', 'tuop', 'tot', 'tox', 'to', 'top', 'tex', 'te', 'tep', 'tut', 'tux', 'tu', 'tup', 'turx', 'tur', 'ddit', 'ddix', 'ddi', 'ddip', 'ddiex', 'ddie', 'ddiep', 'ddat', 'ddax', 'dda', 'ddap', 'dduox', 'dduo', 'dduop', 'ddot', 'ddox', 'ddo', 'ddop', 'ddex', 'dde', 'ddep', 'ddut', 'ddux', 'ddu', 'ddup', 'ddurx', 'ddur', 'ndit', 'ndix', 'ndi', 'ndip', 'ndiex', 'ndie', 'ndat', 'ndax', 'nda', 'ndap', 'ndot', 'ndox', 'ndo', 'ndop', 'ndex', 'nde', 'ndep', 'ndut', 'ndux', 'ndu', 'ndup', 'ndurx', 'ndur', 'hnit', 'hnix', 'hni', 'hnip', 'hniet', 'hniex', 'hnie', 'hniep', 'hnat', 'hnax', 'hna', 'hnap', 'hnuox', 'hnuo', 'hnot', 'hnox', 'hnop', 'hnex', 'hne', 'hnep', 'hnut', 'nit', 'nix', 'ni', 'nip', 'niex', 'nie', 'niep', 'nax', 'na', 'nap', 'nuox', 'nuo', 'nuop', 'not', 'nox', 'no', 'nop', 'nex', 'ne', 'nep', 'nut', 'nux', 'nu', 'nup', 'nurx', 'nur', 'hlit', 'hlix', 'hli', 'hlip', 'hliex', 'hlie', 'hliep', 'hlat', 'hlax', 'hla', 'hlap', 'hluox', 'hluo', 'hluop', 'hlox', 'hlo', 'hlop', 'hlex', 'hle', 'hlep', 'hlut', 'hlux', 'hlu', 'hlup', 'hlurx', 'hlur', 'hlyt', 'hlyx', 'hly', 'hlyp', 'hlyrx', 'hlyr', 'lit', 'lix', 'li', 'lip', 'liet', 'liex', 'lie', 'liep', 'lat', 'lax', 'la', 'lap', 'luot', 'luox', 'luo', 'luop', 'lot', 'lox', 'lo', 'lop', 'lex', 'le', 'lep', 'lut', 'lux', 'lu', 'lup', 'lurx', 'lur', 'lyt', 'lyx', 'ly', 'lyp', 'lyrx', 'lyr', 'git', 'gix', 'gi', 'gip', 'giet', 'giex', 'gie', 'giep', 'gat', 'gax', 'ga', 'gap', 'guot', 'guox', 'guo', 'guop', 'got', 'gox', 'go', 'gop', 'get', 'gex', 'ge', 'gep', 'gut', 'gux', 'gu', 'gup', 'gurx', 'gur', 'kit', 'kix', 'ki', 'kip', 'kiex', 'kie', 'kiep', 'kat']


Joomla CMS: Référence du fichier RulesetInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier RulesetInflector.php

Structures de données

class RulesetInflector

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier x0b0.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b0.php

Variables

return ['ggwem', 'ggweb', 'ggwebs', 'ggwes', 'ggwess', 'ggweng', 'ggwej', 'ggwec', 'ggwek', 'ggwet', 'ggwep', 'ggweh', 'ggwi', 'ggwig', 'ggwigg', 'ggwigs', 'ggwin', 'ggwinj', 'ggwinh', 'ggwid', 'ggwil', 'ggwilg', 'ggwilm', 'ggwilb', 'ggwils', 'ggwilt', 'ggwilp', 'ggwilh', 'ggwim', 'ggwib', 'ggwibs', 'ggwis', 'ggwiss', 'ggwing', 'ggwij', 'ggwic', 'ggwik', 'ggwit', 'ggwip', 'ggwih', 'ggyu', 'ggyug', 'ggyugg', 'ggyugs', 'ggyun', 'ggyunj', 'ggyunh', 'ggyud', 'ggyul', 'ggyulg', 'ggyulm', 'ggyulb', 'ggyuls', 'ggyult', 'ggyulp', 'ggyulh', 'ggyum', 'ggyub', 'ggyubs', 'ggyus', 'ggyuss', 'ggyung', 'ggyuj', 'ggyuc', 'ggyuk', 'ggyut', 'ggyup', 'ggyuh', 'ggeu', 'ggeug', 'ggeugg', 'ggeugs', 'ggeun', 'ggeunj', 'ggeunh', 'ggeud', 'ggeul', 'ggeulg', 'ggeulm', 'ggeulb', 'ggeuls', 'ggeult', 'ggeulp', 'ggeulh', 'ggeum', 'ggeub', 'ggeubs', 'ggeus', 'ggeuss', 'ggeung', 'ggeuj', 'ggeuc', 'ggeuk', 'ggeut', 'ggeup', 'ggeuh', 'ggyi', 'ggyig', 'ggyigg', 'ggyigs', 'ggyin', 'ggyinj', 'ggyinh', 'ggyid', 'ggyil', 'ggyilg', 'ggyilm', 'ggyilb', 'ggyils', 'ggyilt', 'ggyilp', 'ggyilh', 'ggyim', 'ggyib', 'ggyibs', 'ggyis', 'ggyiss', 'ggying', 'ggyij', 'ggyic', 'ggyik', 'ggyit', 'ggyip', 'ggyih', 'ggi', 'ggig', 'ggigg', 'ggigs', 'ggin', 'gginj', 'gginh', 'ggid', 'ggil', 'ggilg', 'ggilm', 'ggilb', 'ggils', 'ggilt', 'ggilp', 'ggilh', 'ggim', 'ggib', 'ggibs', 'ggis', 'ggiss', 'gging', 'ggij', 'ggic', 'ggik', 'ggit', 'ggip', 'ggih', 'na', 'nag', 'nagg', 'nags', 'nan', 'nanj', 'nanh', 'nad', 'nal', 'nalg', 'nalm', 'nalb', 'nals', 'nalt', 'nalp', 'nalh', 'nam', 'nab', 'nabs', 'nas', 'nass', 'nang', 'naj', 'nac', 'nak', 'nat', 'nap', 'nah', 'nae', 'naeg', 'naegg', 'naegs', 'naen', 'naenj', 'naenh', 'naed', 'nael', 'naelg', 'naelm', 'naelb', 'naels', 'naelt', 'naelp', 'naelh', 'naem', 'naeb', 'naebs', 'naes', 'naess', 'naeng', 'naej', 'naec', 'naek', 'naet', 'naep', 'naeh', 'nya', 'nyag', 'nyagg', 'nyags', 'nyan', 'nyanj', 'nyanh', 'nyad', 'nyal', 'nyalg', 'nyalm', 'nyalb', 'nyals', 'nyalt', 'nyalp', 'nyalh', 'nyam', 'nyab', 'nyabs', 'nyas', 'nyass', 'nyang', 'nyaj', 'nyac', 'nyak', 'nyat', 'nyap', 'nyah', 'nyae', 'nyaeg', 'nyaegg', 'nyaegs', 'nyaen', 'nyaenj', 'nyaenh', 'nyaed', 'nyael', 'nyaelg', 'nyaelm', 'nyaelb', 'nyaels', 'nyaelt', 'nyaelp', 'nyaelh', 'nyaem', 'nyaeb', 'nyaebs', 'nyaes']

Documentation des variables

◆ return

return[ 'ggwem', 'ggweb', 'ggwebs', 'ggwes', 'ggwess', 'ggweng', 'ggwej', 'ggwec', 'ggwek', 'ggwet', 'ggwep', 'ggweh', 'ggwi', 'ggwig', 'ggwigg', 'ggwigs', 'ggwin', 'ggwinj', 'ggwinh', 'ggwid', 'ggwil', 'ggwilg', 'ggwilm', 'ggwilb', 'ggwils', 'ggwilt', 'ggwilp', 'ggwilh', 'ggwim', 'ggwib', 'ggwibs', 'ggwis', 'ggwiss', 'ggwing', 'ggwij', 'ggwic', 'ggwik', 'ggwit', 'ggwip', 'ggwih', 'ggyu', 'ggyug', 'ggyugg', 'ggyugs', 'ggyun', 'ggyunj', 'ggyunh', 'ggyud', 'ggyul', 'ggyulg', 'ggyulm', 'ggyulb', 'ggyuls', 'ggyult', 'ggyulp', 'ggyulh', 'ggyum', 'ggyub', 'ggyubs', 'ggyus', 'ggyuss', 'ggyung', 'ggyuj', 'ggyuc', 'ggyuk', 'ggyut', 'ggyup', 'ggyuh', 'ggeu', 'ggeug', 'ggeugg', 'ggeugs', 'ggeun', 'ggeunj', 'ggeunh', 'ggeud', 'ggeul', 'ggeulg', 'ggeulm', 'ggeulb', 'ggeuls', 'ggeult', 'ggeulp', 'ggeulh', 'ggeum', 'ggeub', 'ggeubs', 'ggeus', 'ggeuss', 'ggeung', 'ggeuj', 'ggeuc', 'ggeuk', 'ggeut', 'ggeup', 'ggeuh', 'ggyi', 'ggyig', 'ggyigg', 'ggyigs', 'ggyin', 'ggyinj', 'ggyinh', 'ggyid', 'ggyil', 'ggyilg', 'ggyilm', 'ggyilb', 'ggyils', 'ggyilt', 'ggyilp', 'ggyilh', 'ggyim', 'ggyib', 'ggyibs', 'ggyis', 'ggyiss', 'ggying', 'ggyij', 'ggyic', 'ggyik', 'ggyit', 'ggyip', 'ggyih', 'ggi', 'ggig', 'ggigg', 'ggigs', 'ggin', 'gginj', 'gginh', 'ggid', 'ggil', 'ggilg', 'ggilm', 'ggilb', 'ggils', 'ggilt', 'ggilp', 'ggilh', 'ggim', 'ggib', 'ggibs', 'ggis', 'ggiss', 'gging', 'ggij', 'ggic', 'ggik', 'ggit', 'ggip', 'ggih', 'na', 'nag', 'nagg', 'nags', 'nan', 'nanj', 'nanh', 'nad', 'nal', 'nalg', 'nalm', 'nalb', 'nals', 'nalt', 'nalp', 'nalh', 'nam', 'nab', 'nabs', 'nas', 'nass', 'nang', 'naj', 'nac', 'nak', 'nat', 'nap', 'nah', 'nae', 'naeg', 'naegg', 'naegs', 'naen', 'naenj', 'naenh', 'naed', 'nael', 'naelg', 'naelm', 'naelb', 'naels', 'naelt', 'naelp', 'naelh', 'naem', 'naeb', 'naebs', 'naes', 'naess', 'naeng', 'naej', 'naec', 'naek', 'naet', 'naep', 'naeh', 'nya', 'nyag', 'nyagg', 'nyags', 'nyan', 'nyanj', 'nyanh', 'nyad', 'nyal', 'nyalg', 'nyalm', 'nyalb', 'nyals', 'nyalt', 'nyalp', 'nyalh', 'nyam', 'nyab', 'nyabs', 'nyas', 'nyass', 'nyang', 'nyaj', 'nyac', 'nyak', 'nyat', 'nyap', 'nyah', 'nyae', 'nyaeg', 'nyaegg', 'nyaegs', 'nyaen', 'nyaenj', 'nyaenh', 'nyaed', 'nyael', 'nyaelg', 'nyaelm', 'nyaelb', 'nyaels', 'nyaelt', 'nyaelp', 'nyaelh', 'nyaem', 'nyaeb', 'nyaebs', 'nyaes']


Joomla CMS: Référence du fichier Stub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier typo3/phar-stream-wrapper/src/Phar/Stub.php

Structures de données

class Stub

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier Trinomial.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Trinomial.php

Structures de données

class Trinomial

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier PKCS8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DH/Formats/Keys/PKCS8.php

Structures de données

class PKCS8

Espaces de nommage

DH
phpseclib3\Crypt\DH\Formats\Keys


Joomla CMS: Référence du fichier SimpleMetadataStatementRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier SimpleMetadataStatementRepository.php

Structures de données

class SimpleMetadataStatementRepository

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier PS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/PS256.php

Structures de données

class PS256

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier PHPMailer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier PHPMailer.php

Structures de données

class PHPMailer

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier SpacerField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier SpacerField.php

Structures de données

class SpacerField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier x0d2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d2.php

Variables

return ['toels', 'toelt', 'toelp', 'toelh', 'toem', 'toeb', 'toebs', 'toes', 'toess', 'toeng', 'toej', 'toec', 'toek', 'toet', 'toep', 'toeh', 'tyo', 'tyog', 'tyogg', 'tyogs', 'tyon', 'tyonj', 'tyonh', 'tyod', 'tyol', 'tyolg', 'tyolm', 'tyolb', 'tyols', 'tyolt', 'tyolp', 'tyolh', 'tyom', 'tyob', 'tyobs', 'tyos', 'tyoss', 'tyong', 'tyoj', 'tyoc', 'tyok', 'tyot', 'tyop', 'tyoh', 'tu', 'tug', 'tugg', 'tugs', 'tun', 'tunj', 'tunh', 'tud', 'tul', 'tulg', 'tulm', 'tulb', 'tuls', 'tult', 'tulp', 'tulh', 'tum', 'tub', 'tubs', 'tus', 'tuss', 'tung', 'tuj', 'tuc', 'tuk', 'tut', 'tup', 'tuh', 'tweo', 'tweog', 'tweogg', 'tweogs', 'tweon', 'tweonj', 'tweonh', 'tweod', 'tweol', 'tweolg', 'tweolm', 'tweolb', 'tweols', 'tweolt', 'tweolp', 'tweolh', 'tweom', 'tweob', 'tweobs', 'tweos', 'tweoss', 'tweong', 'tweoj', 'tweoc', 'tweok', 'tweot', 'tweop', 'tweoh', 'twe', 'tweg', 'twegg', 'twegs', 'twen', 'twenj', 'twenh', 'twed', 'twel', 'twelg', 'twelm', 'twelb', 'twels', 'twelt', 'twelp', 'twelh', 'twem', 'tweb', 'twebs', 'twes', 'twess', 'tweng', 'twej', 'twec', 'twek', 'twet', 'twep', 'tweh', 'twi', 'twig', 'twigg', 'twigs', 'twin', 'twinj', 'twinh', 'twid', 'twil', 'twilg', 'twilm', 'twilb', 'twils', 'twilt', 'twilp', 'twilh', 'twim', 'twib', 'twibs', 'twis', 'twiss', 'twing', 'twij', 'twic', 'twik', 'twit', 'twip', 'twih', 'tyu', 'tyug', 'tyugg', 'tyugs', 'tyun', 'tyunj', 'tyunh', 'tyud', 'tyul', 'tyulg', 'tyulm', 'tyulb', 'tyuls', 'tyult', 'tyulp', 'tyulh', 'tyum', 'tyub', 'tyubs', 'tyus', 'tyuss', 'tyung', 'tyuj', 'tyuc', 'tyuk', 'tyut', 'tyup', 'tyuh', 'teu', 'teug', 'teugg', 'teugs', 'teun', 'teunj', 'teunh', 'teud', 'teul', 'teulg', 'teulm', 'teulb', 'teuls', 'teult', 'teulp', 'teulh', 'teum', 'teub', 'teubs', 'teus', 'teuss', 'teung', 'teuj', 'teuc', 'teuk', 'teut', 'teup', 'teuh', 'tyi', 'tyig', 'tyigg', 'tyigs', 'tyin', 'tyinj', 'tyinh', 'tyid', 'tyil', 'tyilg', 'tyilm', 'tyilb', 'tyils', 'tyilt', 'tyilp', 'tyilh', 'tyim', 'tyib', 'tyibs', 'tyis', 'tyiss', 'tying', 'tyij', 'tyic', 'tyik', 'tyit', 'tyip', 'tyih', 'ti', 'tig', 'tigg', 'tigs', 'tin', 'tinj', 'tinh', 'tid', 'til', 'tilg', 'tilm', 'tilb', 'tils', 'tilt', 'tilp', 'tilh']

Documentation des variables

◆ return

return[ 'toels', 'toelt', 'toelp', 'toelh', 'toem', 'toeb', 'toebs', 'toes', 'toess', 'toeng', 'toej', 'toec', 'toek', 'toet', 'toep', 'toeh', 'tyo', 'tyog', 'tyogg', 'tyogs', 'tyon', 'tyonj', 'tyonh', 'tyod', 'tyol', 'tyolg', 'tyolm', 'tyolb', 'tyols', 'tyolt', 'tyolp', 'tyolh', 'tyom', 'tyob', 'tyobs', 'tyos', 'tyoss', 'tyong', 'tyoj', 'tyoc', 'tyok', 'tyot', 'tyop', 'tyoh', 'tu', 'tug', 'tugg', 'tugs', 'tun', 'tunj', 'tunh', 'tud', 'tul', 'tulg', 'tulm', 'tulb', 'tuls', 'tult', 'tulp', 'tulh', 'tum', 'tub', 'tubs', 'tus', 'tuss', 'tung', 'tuj', 'tuc', 'tuk', 'tut', 'tup', 'tuh', 'tweo', 'tweog', 'tweogg', 'tweogs', 'tweon', 'tweonj', 'tweonh', 'tweod', 'tweol', 'tweolg', 'tweolm', 'tweolb', 'tweols', 'tweolt', 'tweolp', 'tweolh', 'tweom', 'tweob', 'tweobs', 'tweos', 'tweoss', 'tweong', 'tweoj', 'tweoc', 'tweok', 'tweot', 'tweop', 'tweoh', 'twe', 'tweg', 'twegg', 'twegs', 'twen', 'twenj', 'twenh', 'twed', 'twel', 'twelg', 'twelm', 'twelb', 'twels', 'twelt', 'twelp', 'twelh', 'twem', 'tweb', 'twebs', 'twes', 'twess', 'tweng', 'twej', 'twec', 'twek', 'twet', 'twep', 'tweh', 'twi', 'twig', 'twigg', 'twigs', 'twin', 'twinj', 'twinh', 'twid', 'twil', 'twilg', 'twilm', 'twilb', 'twils', 'twilt', 'twilp', 'twilh', 'twim', 'twib', 'twibs', 'twis', 'twiss', 'twing', 'twij', 'twic', 'twik', 'twit', 'twip', 'twih', 'tyu', 'tyug', 'tyugg', 'tyugs', 'tyun', 'tyunj', 'tyunh', 'tyud', 'tyul', 'tyulg', 'tyulm', 'tyulb', 'tyuls', 'tyult', 'tyulp', 'tyulh', 'tyum', 'tyub', 'tyubs', 'tyus', 'tyuss', 'tyung', 'tyuj', 'tyuc', 'tyuk', 'tyut', 'tyup', 'tyuh', 'teu', 'teug', 'teugg', 'teugs', 'teun', 'teunj', 'teunh', 'teud', 'teul', 'teulg', 'teulm', 'teulb', 'teuls', 'teult', 'teulp', 'teulh', 'teum', 'teub', 'teubs', 'teus', 'teuss', 'teung', 'teuj', 'teuc', 'teuk', 'teut', 'teup', 'teuh', 'tyi', 'tyig', 'tyigg', 'tyigs', 'tyin', 'tyinj', 'tyinh', 'tyid', 'tyil', 'tyilg', 'tyilm', 'tyilb', 'tyils', 'tyilt', 'tyilp', 'tyilh', 'tyim', 'tyib', 'tyibs', 'tyis', 'tyiss', 'tying', 'tyij', 'tyic', 'tyik', 'tyit', 'tyip', 'tyih', 'ti', 'tig', 'tigg', 'tigs', 'tin', 'tinj', 'tinh', 'tid', 'til', 'tilg', 'tilm', 'tilb', 'tils', 'tilt', 'tilp', 'tilh']


Joomla CMS: Référence du fichier PreparableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Structures de données | Espaces de nommage
Référence du fichier PreparableInterface.php

Structures de données

interface PreparableInterface

Espaces de nommage

Joomla\Database\Query


Joomla CMS: Référence du fichier versions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier versions.php

Espaces de nommage

Joomla\Site

Variables

$wa = Factory::getDocument()->getWebAssetManager()

Documentation des variables

◆ $wa

$wa = Factory::getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier x081.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x081.php

Variables

return ['Cheng ', 'Tiao ', 'Zhi ', 'Cui ', 'Mei ', 'Xie ', 'Cui ', 'Xie ', 'Mo ', 'Mai ', 'Ji ', 'Obiyaakasu ', '[?] ', 'Kuai ', 'Sa ', 'Zang ', 'Qi ', 'Nao ', 'Mi ', 'Nong ', 'Luan ', 'Wan ', 'Bo ', 'Wen ', 'Guan ', 'Qiu ', 'Jiao ', 'Jing ', 'Rou ', 'Heng ', 'Cuo ', 'Lie ', 'Shan ', 'Ting ', 'Mei ', 'Chun ', 'Shen ', 'Xie ', 'De ', 'Zui ', 'Cu ', 'Xiu ', 'Xin ', 'Tuo ', 'Pao ', 'Cheng ', 'Nei ', 'Fu ', 'Dou ', 'Tuo ', 'Niao ', 'Noy ', 'Pi ', 'Gu ', 'Gua ', 'Li ', 'Lian ', 'Zhang ', 'Cui ', 'Jie ', 'Liang ', 'Zhou ', 'Pi ', 'Biao ', 'Lun ', 'Pian ', 'Guo ', 'Kui ', 'Chui ', 'Dan ', 'Tian ', 'Nei ', 'Jing ', 'Jie ', 'La ', 'Yi ', 'An ', 'Ren ', 'Shen ', 'Chuo ', 'Fu ', 'Fu ', 'Ju ', 'Fei ', 'Qiang ', 'Wan ', 'Dong ', 'Pi ', 'Guo ', 'Zong ', 'Ding ', 'Wu ', 'Mei ', 'Ruan ', 'Zhuan ', 'Zhi ', 'Cou ', 'Gua ', 'Ou ', 'Di ', 'An ', 'Xing ', 'Nao ', 'Yu ', 'Chuan ', 'Nan ', 'Yun ', 'Zhong ', 'Rou ', 'E ', 'Sai ', 'Tu ', 'Yao ', 'Jian ', 'Wei ', 'Jiao ', 'Yu ', 'Jia ', 'Duan ', 'Bi ', 'Chang ', 'Fu ', 'Xian ', 'Ni ', 'Mian ', 'Wa ', 'Teng ', 'Tui ', 'Bang ', 'Qian ', 'Lu ', 'Wa ', 'Sou ', 'Tang ', 'Su ', 'Zhui ', 'Ge ', 'Yi ', 'Bo ', 'Liao ', 'Ji ', 'Pi ', 'Xie ', 'Gao ', 'Lu ', 'Bin ', 'Ou ', 'Chang ', 'Lu ', 'Guo ', 'Pang ', 'Chuai ', 'Piao ', 'Jiang ', 'Fu ', 'Tang ', 'Mo ', 'Xi ', 'Zhuan ', 'Lu ', 'Jiao ', 'Ying ', 'Lu ', 'Zhi ', 'Tara ', 'Chun ', 'Lian ', 'Tong ', 'Peng ', 'Ni ', 'Zha ', 'Liao ', 'Cui ', 'Gui ', 'Xiao ', 'Teng ', 'Fan ', 'Zhi ', 'Jiao ', 'Shan ', 'Wu ', 'Cui ', 'Run ', 'Xiang ', 'Sui ', 'Fen ', 'Ying ', 'Tan ', 'Zhua ', 'Dan ', 'Kuai ', 'Nong ', 'Tun ', 'Lian ', 'Bi ', 'Yong ', 'Jue ', 'Chu ', 'Yi ', 'Juan ', 'La ', 'Lian ', 'Sao ', 'Tun ', 'Gu ', 'Qi ', 'Cui ', 'Bin ', 'Xun ', 'Ru ', 'Huo ', 'Zang ', 'Xian ', 'Biao ', 'Xing ', 'Kuan ', 'La ', 'Yan ', 'Lu ', 'Huo ', 'Zang ', 'Luo ', 'Qu ', 'Zang ', 'Luan ', 'Ni ', 'Zang ', 'Chen ', 'Qian ', 'Wo ', 'Guang ', 'Zang ', 'Lin ', 'Guang ', 'Zi ', 'Jiao ', 'Nie ', 'Chou ', 'Ji ', 'Gao ', 'Chou ', 'Mian ', 'Nie ', 'Zhi ', 'Zhi ', 'Ge ', 'Jian ', 'Die ', 'Zhi ', 'Xiu ', 'Tai ', 'Zhen ', 'Jiu ', 'Xian ', 'Yu ', 'Cha ']

Documentation des variables

◆ return

return[ 'Cheng ', 'Tiao ', 'Zhi ', 'Cui ', 'Mei ', 'Xie ', 'Cui ', 'Xie ', 'Mo ', 'Mai ', 'Ji ', 'Obiyaakasu ', '[?] ', 'Kuai ', 'Sa ', 'Zang ', 'Qi ', 'Nao ', 'Mi ', 'Nong ', 'Luan ', 'Wan ', 'Bo ', 'Wen ', 'Guan ', 'Qiu ', 'Jiao ', 'Jing ', 'Rou ', 'Heng ', 'Cuo ', 'Lie ', 'Shan ', 'Ting ', 'Mei ', 'Chun ', 'Shen ', 'Xie ', 'De ', 'Zui ', 'Cu ', 'Xiu ', 'Xin ', 'Tuo ', 'Pao ', 'Cheng ', 'Nei ', 'Fu ', 'Dou ', 'Tuo ', 'Niao ', 'Noy ', 'Pi ', 'Gu ', 'Gua ', 'Li ', 'Lian ', 'Zhang ', 'Cui ', 'Jie ', 'Liang ', 'Zhou ', 'Pi ', 'Biao ', 'Lun ', 'Pian ', 'Guo ', 'Kui ', 'Chui ', 'Dan ', 'Tian ', 'Nei ', 'Jing ', 'Jie ', 'La ', 'Yi ', 'An ', 'Ren ', 'Shen ', 'Chuo ', 'Fu ', 'Fu ', 'Ju ', 'Fei ', 'Qiang ', 'Wan ', 'Dong ', 'Pi ', 'Guo ', 'Zong ', 'Ding ', 'Wu ', 'Mei ', 'Ruan ', 'Zhuan ', 'Zhi ', 'Cou ', 'Gua ', 'Ou ', 'Di ', 'An ', 'Xing ', 'Nao ', 'Yu ', 'Chuan ', 'Nan ', 'Yun ', 'Zhong ', 'Rou ', 'E ', 'Sai ', 'Tu ', 'Yao ', 'Jian ', 'Wei ', 'Jiao ', 'Yu ', 'Jia ', 'Duan ', 'Bi ', 'Chang ', 'Fu ', 'Xian ', 'Ni ', 'Mian ', 'Wa ', 'Teng ', 'Tui ', 'Bang ', 'Qian ', 'Lu ', 'Wa ', 'Sou ', 'Tang ', 'Su ', 'Zhui ', 'Ge ', 'Yi ', 'Bo ', 'Liao ', 'Ji ', 'Pi ', 'Xie ', 'Gao ', 'Lu ', 'Bin ', 'Ou ', 'Chang ', 'Lu ', 'Guo ', 'Pang ', 'Chuai ', 'Piao ', 'Jiang ', 'Fu ', 'Tang ', 'Mo ', 'Xi ', 'Zhuan ', 'Lu ', 'Jiao ', 'Ying ', 'Lu ', 'Zhi ', 'Tara ', 'Chun ', 'Lian ', 'Tong ', 'Peng ', 'Ni ', 'Zha ', 'Liao ', 'Cui ', 'Gui ', 'Xiao ', 'Teng ', 'Fan ', 'Zhi ', 'Jiao ', 'Shan ', 'Wu ', 'Cui ', 'Run ', 'Xiang ', 'Sui ', 'Fen ', 'Ying ', 'Tan ', 'Zhua ', 'Dan ', 'Kuai ', 'Nong ', 'Tun ', 'Lian ', 'Bi ', 'Yong ', 'Jue ', 'Chu ', 'Yi ', 'Juan ', 'La ', 'Lian ', 'Sao ', 'Tun ', 'Gu ', 'Qi ', 'Cui ', 'Bin ', 'Xun ', 'Ru ', 'Huo ', 'Zang ', 'Xian ', 'Biao ', 'Xing ', 'Kuan ', 'La ', 'Yan ', 'Lu ', 'Huo ', 'Zang ', 'Luo ', 'Qu ', 'Zang ', 'Luan ', 'Ni ', 'Zang ', 'Chen ', 'Qian ', 'Wo ', 'Guang ', 'Zang ', 'Lin ', 'Guang ', 'Zi ', 'Jiao ', 'Nie ', 'Chou ', 'Ji ', 'Gao ', 'Chou ', 'Mian ', 'Nie ', 'Zhi ', 'Zhi ', 'Ge ', 'Jian ', 'Die ', 'Zhi ', 'Xiu ', 'Tai ', 'Zhen ', 'Jiu ', 'Xian ', 'Yu ', 'Cha ']


Joomla CMS: Référence du fichier Pentanomial.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Pentanomial.php

Structures de données

class Pentanomial

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier standard.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier standard.php

Espaces de nommage

Joomla\Site

Variables

$tagName = $tagName ?? 'button'
$taskAttr = ''
$idAttr = !empty($id) ? ' id="' . $id . '"' : ''
$listAttr = !empty($listCheck) ? ' list-selection' : ''
$formAttr = !empty($form) ? ' form="' . $this->escape($form) . '"' : ''
$validate = !empty($formValidation) ? ' form-validation' : ''
$msgAttr = !empty($message) ? ' confirm-message="' . $this->escape($message) . '"' : ''
if(!empty($task)) elseif (!empty( $onclick))
else __pad14__
endif

Documentation des variables

◆ $formAttr

$formAttr = !empty($form) ? ' form="' . $this->escape($form) . '"' : ''

◆ $idAttr

$idAttr = !empty($id) ? ' id="' . $id . '"' : ''

◆ $listAttr

$listAttr = !empty($listCheck) ? ' list-selection' : ''

◆ $msgAttr

$msgAttr = !empty($message) ? ' confirm-message="' . $this->escape($message) . '"' : ''

◆ $tagName

$tagName = $tagName ?? 'button'

◆ $taskAttr

$taskAttr = ''

◆ $validate

$validate = !empty($formValidation) ? ' form-validation' : ''

◆ __pad14__

else __pad14__

◆ elseif

if (!empty( $task)) elseif(!empty($onclick))

◆ endif

endif


Joomla CMS: Référence du fichier RemindController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier RemindController.php

Structures de données

class RemindController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier ProgressBar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ProgressBar.php

Structures de données

class ProgressBar

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier Required.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
  • Attribute
Structures de données | Espaces de nommage
Référence du fichier Required.php

Structures de données

class Required

Espaces de nommage

Symfony\Contracts\Service\Attribute


Joomla CMS: Référence du fichier x078.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x078.php

Variables

return ['Dang ', 'Ma ', 'Sha ', 'Dan ', 'Jue ', 'Li ', 'Fu ', 'Min ', 'Nuo ', 'Huo ', 'Kang ', 'Zhi ', 'Qi ', 'Kan ', 'Jie ', 'Fen ', 'E ', 'Ya ', 'Pi ', 'Zhe ', 'Yan ', 'Sui ', 'Zhuan ', 'Che ', 'Dun ', 'Pan ', 'Yan ', '[?] ', 'Feng ', 'Fa ', 'Mo ', 'Zha ', 'Qu ', 'Yu ', 'Luo ', 'Tuo ', 'Tuo ', 'Di ', 'Zhai ', 'Zhen ', 'Ai ', 'Fei ', 'Mu ', 'Zhu ', 'Li ', 'Bian ', 'Nu ', 'Ping ', 'Peng ', 'Ling ', 'Pao ', 'Le ', 'Po ', 'Bo ', 'Po ', 'Shen ', 'Za ', 'Nuo ', 'Li ', 'Long ', 'Tong ', '[?] ', 'Li ', 'Aragane ', 'Chu ', 'Keng ', 'Quan ', 'Zhu ', 'Kuang ', 'Huo ', 'E ', 'Nao ', 'Jia ', 'Lu ', 'Wei ', 'Ai ', 'Luo ', 'Ken ', 'Xing ', 'Yan ', 'Tong ', 'Peng ', 'Xi ', '[?] ', 'Hong ', 'Shuo ', 'Xia ', 'Qiao ', '[?] ', 'Wei ', 'Qiao ', '[?] ', 'Keng ', 'Xiao ', 'Que ', 'Chan ', 'Lang ', 'Hong ', 'Yu ', 'Xiao ', 'Xia ', 'Mang ', 'Long ', 'Iong ', 'Che ', 'Che ', 'E ', 'Liu ', 'Ying ', 'Mang ', 'Que ', 'Yan ', 'Sha ', 'Kun ', 'Yu ', '[?] ', 'Kaki ', 'Lu ', 'Chen ', 'Jian ', 'Nue ', 'Song ', 'Zhuo ', 'Keng ', 'Peng ', 'Yan ', 'Zhui ', 'Kong ', 'Ceng ', 'Qi ', 'Zong ', 'Qing ', 'Lin ', 'Jun ', 'Bo ', 'Ding ', 'Min ', 'Diao ', 'Jian ', 'He ', 'Lu ', 'Ai ', 'Sui ', 'Que ', 'Ling ', 'Bei ', 'Yin ', 'Dui ', 'Wu ', 'Qi ', 'Lun ', 'Wan ', 'Dian ', 'Gang ', 'Pei ', 'Qi ', 'Chen ', 'Ruan ', 'Yan ', 'Die ', 'Ding ', 'Du ', 'Tuo ', 'Jie ', 'Ying ', 'Bian ', 'Ke ', 'Bi ', 'Wei ', 'Shuo ', 'Zhen ', 'Duan ', 'Xia ', 'Dang ', 'Ti ', 'Nao ', 'Peng ', 'Jian ', 'Di ', 'Tan ', 'Cha ', 'Seki ', 'Qi ', '[?] ', 'Feng ', 'Xuan ', 'Que ', 'Que ', 'Ma ', 'Gong ', 'Nian ', 'Su ', 'E ', 'Ci ', 'Liu ', 'Si ', 'Tang ', 'Bang ', 'Hua ', 'Pi ', 'Wei ', 'Sang ', 'Lei ', 'Cuo ', 'Zhen ', 'Xia ', 'Qi ', 'Lian ', 'Pan ', 'Wei ', 'Yun ', 'Dui ', 'Zhe ', 'Ke ', 'La ', '[?] ', 'Qing ', 'Gun ', 'Zhuan ', 'Chan ', 'Qi ', 'Ao ', 'Peng ', 'Lu ', 'Lu ', 'Kan ', 'Qiang ', 'Chen ', 'Yin ', 'Lei ', 'Biao ', 'Qi ', 'Mo ', 'Qi ', 'Cui ', 'Zong ', 'Qing ', 'Chuo ', '[?] ', 'Ji ', 'Shan ', 'Lao ', 'Qu ', 'Zeng ', 'Deng ', 'Jian ', 'Xi ', 'Lin ', 'Ding ', 'Dian ', 'Huang ', 'Pan ', 'Za ', 'Qiao ', 'Di ', 'Li ']

Documentation des variables

◆ return

return[ 'Dang ', 'Ma ', 'Sha ', 'Dan ', 'Jue ', 'Li ', 'Fu ', 'Min ', 'Nuo ', 'Huo ', 'Kang ', 'Zhi ', 'Qi ', 'Kan ', 'Jie ', 'Fen ', 'E ', 'Ya ', 'Pi ', 'Zhe ', 'Yan ', 'Sui ', 'Zhuan ', 'Che ', 'Dun ', 'Pan ', 'Yan ', '[?] ', 'Feng ', 'Fa ', 'Mo ', 'Zha ', 'Qu ', 'Yu ', 'Luo ', 'Tuo ', 'Tuo ', 'Di ', 'Zhai ', 'Zhen ', 'Ai ', 'Fei ', 'Mu ', 'Zhu ', 'Li ', 'Bian ', 'Nu ', 'Ping ', 'Peng ', 'Ling ', 'Pao ', 'Le ', 'Po ', 'Bo ', 'Po ', 'Shen ', 'Za ', 'Nuo ', 'Li ', 'Long ', 'Tong ', '[?] ', 'Li ', 'Aragane ', 'Chu ', 'Keng ', 'Quan ', 'Zhu ', 'Kuang ', 'Huo ', 'E ', 'Nao ', 'Jia ', 'Lu ', 'Wei ', 'Ai ', 'Luo ', 'Ken ', 'Xing ', 'Yan ', 'Tong ', 'Peng ', 'Xi ', '[?] ', 'Hong ', 'Shuo ', 'Xia ', 'Qiao ', '[?] ', 'Wei ', 'Qiao ', '[?] ', 'Keng ', 'Xiao ', 'Que ', 'Chan ', 'Lang ', 'Hong ', 'Yu ', 'Xiao ', 'Xia ', 'Mang ', 'Long ', 'Iong ', 'Che ', 'Che ', 'E ', 'Liu ', 'Ying ', 'Mang ', 'Que ', 'Yan ', 'Sha ', 'Kun ', 'Yu ', '[?] ', 'Kaki ', 'Lu ', 'Chen ', 'Jian ', 'Nue ', 'Song ', 'Zhuo ', 'Keng ', 'Peng ', 'Yan ', 'Zhui ', 'Kong ', 'Ceng ', 'Qi ', 'Zong ', 'Qing ', 'Lin ', 'Jun ', 'Bo ', 'Ding ', 'Min ', 'Diao ', 'Jian ', 'He ', 'Lu ', 'Ai ', 'Sui ', 'Que ', 'Ling ', 'Bei ', 'Yin ', 'Dui ', 'Wu ', 'Qi ', 'Lun ', 'Wan ', 'Dian ', 'Gang ', 'Pei ', 'Qi ', 'Chen ', 'Ruan ', 'Yan ', 'Die ', 'Ding ', 'Du ', 'Tuo ', 'Jie ', 'Ying ', 'Bian ', 'Ke ', 'Bi ', 'Wei ', 'Shuo ', 'Zhen ', 'Duan ', 'Xia ', 'Dang ', 'Ti ', 'Nao ', 'Peng ', 'Jian ', 'Di ', 'Tan ', 'Cha ', 'Seki ', 'Qi ', '[?] ', 'Feng ', 'Xuan ', 'Que ', 'Que ', 'Ma ', 'Gong ', 'Nian ', 'Su ', 'E ', 'Ci ', 'Liu ', 'Si ', 'Tang ', 'Bang ', 'Hua ', 'Pi ', 'Wei ', 'Sang ', 'Lei ', 'Cuo ', 'Zhen ', 'Xia ', 'Qi ', 'Lian ', 'Pan ', 'Wei ', 'Yun ', 'Dui ', 'Zhe ', 'Ke ', 'La ', '[?] ', 'Qing ', 'Gun ', 'Zhuan ', 'Chan ', 'Qi ', 'Ao ', 'Peng ', 'Lu ', 'Lu ', 'Kan ', 'Qiang ', 'Chen ', 'Yin ', 'Lei ', 'Biao ', 'Qi ', 'Mo ', 'Qi ', 'Cui ', 'Zong ', 'Qing ', 'Chuo ', '[?] ', 'Ji ', 'Shan ', 'Lao ', 'Qu ', 'Zeng ', 'Deng ', 'Jian ', 'Xi ', 'Lin ', 'Ding ', 'Dian ', 'Huang ', 'Pan ', 'Za ', 'Qiao ', 'Di ', 'Li ']


Joomla CMS: Référence du fichier RadiobasicField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RadiobasicField.php

Structures de données

class RadiobasicField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier WorkflowFunctionalityUsedEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier WorkflowFunctionalityUsedEvent.php

Structures de données

class WorkflowFunctionalityUsedEvent

Espaces de nommage

Joomla\CMS\Event\Workflow


Joomla CMS: Référence du fichier SwiftLogCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • SwiftMailer
Structures de données | Espaces de nommage
Référence du fichier SwiftLogCollector.php

Structures de données

class SwiftLogCollector

Espaces de nommage

DebugBar\Bridge\SwiftMailer


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_contenthistory/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier ServerRequestInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier ServerRequestInterface.php

Structures de données

interface ServerRequestInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier x0bf.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0bf.php

Variables

return ['bbess', 'bbeng', 'bbej', 'bbec', 'bbek', 'bbet', 'bbep', 'bbeh', 'bbyeo', 'bbyeog', 'bbyeogg', 'bbyeogs', 'bbyeon', 'bbyeonj', 'bbyeonh', 'bbyeod', 'bbyeol', 'bbyeolg', 'bbyeolm', 'bbyeolb', 'bbyeols', 'bbyeolt', 'bbyeolp', 'bbyeolh', 'bbyeom', 'bbyeob', 'bbyeobs', 'bbyeos', 'bbyeoss', 'bbyeong', 'bbyeoj', 'bbyeoc', 'bbyeok', 'bbyeot', 'bbyeop', 'bbyeoh', 'bbye', 'bbyeg', 'bbyegg', 'bbyegs', 'bbyen', 'bbyenj', 'bbyenh', 'bbyed', 'bbyel', 'bbyelg', 'bbyelm', 'bbyelb', 'bbyels', 'bbyelt', 'bbyelp', 'bbyelh', 'bbyem', 'bbyeb', 'bbyebs', 'bbyes', 'bbyess', 'bbyeng', 'bbyej', 'bbyec', 'bbyek', 'bbyet', 'bbyep', 'bbyeh', 'bbo', 'bbog', 'bbogg', 'bbogs', 'bbon', 'bbonj', 'bbonh', 'bbod', 'bbol', 'bbolg', 'bbolm', 'bbolb', 'bbols', 'bbolt', 'bbolp', 'bbolh', 'bbom', 'bbob', 'bbobs', 'bbos', 'bboss', 'bbong', 'bboj', 'bboc', 'bbok', 'bbot', 'bbop', 'bboh', 'bbwa', 'bbwag', 'bbwagg', 'bbwags', 'bbwan', 'bbwanj', 'bbwanh', 'bbwad', 'bbwal', 'bbwalg', 'bbwalm', 'bbwalb', 'bbwals', 'bbwalt', 'bbwalp', 'bbwalh', 'bbwam', 'bbwab', 'bbwabs', 'bbwas', 'bbwass', 'bbwang', 'bbwaj', 'bbwac', 'bbwak', 'bbwat', 'bbwap', 'bbwah', 'bbwae', 'bbwaeg', 'bbwaegg', 'bbwaegs', 'bbwaen', 'bbwaenj', 'bbwaenh', 'bbwaed', 'bbwael', 'bbwaelg', 'bbwaelm', 'bbwaelb', 'bbwaels', 'bbwaelt', 'bbwaelp', 'bbwaelh', 'bbwaem', 'bbwaeb', 'bbwaebs', 'bbwaes', 'bbwaess', 'bbwaeng', 'bbwaej', 'bbwaec', 'bbwaek', 'bbwaet', 'bbwaep', 'bbwaeh', 'bboe', 'bboeg', 'bboegg', 'bboegs', 'bboen', 'bboenj', 'bboenh', 'bboed', 'bboel', 'bboelg', 'bboelm', 'bboelb', 'bboels', 'bboelt', 'bboelp', 'bboelh', 'bboem', 'bboeb', 'bboebs', 'bboes', 'bboess', 'bboeng', 'bboej', 'bboec', 'bboek', 'bboet', 'bboep', 'bboeh', 'bbyo', 'bbyog', 'bbyogg', 'bbyogs', 'bbyon', 'bbyonj', 'bbyonh', 'bbyod', 'bbyol', 'bbyolg', 'bbyolm', 'bbyolb', 'bbyols', 'bbyolt', 'bbyolp', 'bbyolh', 'bbyom', 'bbyob', 'bbyobs', 'bbyos', 'bbyoss', 'bbyong', 'bbyoj', 'bbyoc', 'bbyok', 'bbyot', 'bbyop', 'bbyoh', 'bbu', 'bbug', 'bbugg', 'bbugs', 'bbun', 'bbunj', 'bbunh', 'bbud', 'bbul', 'bbulg', 'bbulm', 'bbulb', 'bbuls', 'bbult', 'bbulp', 'bbulh', 'bbum', 'bbub', 'bbubs', 'bbus', 'bbuss', 'bbung', 'bbuj', 'bbuc', 'bbuk', 'bbut', 'bbup', 'bbuh', 'bbweo', 'bbweog', 'bbweogg', 'bbweogs', 'bbweon', 'bbweonj', 'bbweonh', 'bbweod', 'bbweol', 'bbweolg', 'bbweolm', 'bbweolb', 'bbweols', 'bbweolt', 'bbweolp', 'bbweolh', 'bbweom', 'bbweob', 'bbweobs', 'bbweos', 'bbweoss', 'bbweong', 'bbweoj', 'bbweoc']

Documentation des variables

◆ return

return[ 'bbess', 'bbeng', 'bbej', 'bbec', 'bbek', 'bbet', 'bbep', 'bbeh', 'bbyeo', 'bbyeog', 'bbyeogg', 'bbyeogs', 'bbyeon', 'bbyeonj', 'bbyeonh', 'bbyeod', 'bbyeol', 'bbyeolg', 'bbyeolm', 'bbyeolb', 'bbyeols', 'bbyeolt', 'bbyeolp', 'bbyeolh', 'bbyeom', 'bbyeob', 'bbyeobs', 'bbyeos', 'bbyeoss', 'bbyeong', 'bbyeoj', 'bbyeoc', 'bbyeok', 'bbyeot', 'bbyeop', 'bbyeoh', 'bbye', 'bbyeg', 'bbyegg', 'bbyegs', 'bbyen', 'bbyenj', 'bbyenh', 'bbyed', 'bbyel', 'bbyelg', 'bbyelm', 'bbyelb', 'bbyels', 'bbyelt', 'bbyelp', 'bbyelh', 'bbyem', 'bbyeb', 'bbyebs', 'bbyes', 'bbyess', 'bbyeng', 'bbyej', 'bbyec', 'bbyek', 'bbyet', 'bbyep', 'bbyeh', 'bbo', 'bbog', 'bbogg', 'bbogs', 'bbon', 'bbonj', 'bbonh', 'bbod', 'bbol', 'bbolg', 'bbolm', 'bbolb', 'bbols', 'bbolt', 'bbolp', 'bbolh', 'bbom', 'bbob', 'bbobs', 'bbos', 'bboss', 'bbong', 'bboj', 'bboc', 'bbok', 'bbot', 'bbop', 'bboh', 'bbwa', 'bbwag', 'bbwagg', 'bbwags', 'bbwan', 'bbwanj', 'bbwanh', 'bbwad', 'bbwal', 'bbwalg', 'bbwalm', 'bbwalb', 'bbwals', 'bbwalt', 'bbwalp', 'bbwalh', 'bbwam', 'bbwab', 'bbwabs', 'bbwas', 'bbwass', 'bbwang', 'bbwaj', 'bbwac', 'bbwak', 'bbwat', 'bbwap', 'bbwah', 'bbwae', 'bbwaeg', 'bbwaegg', 'bbwaegs', 'bbwaen', 'bbwaenj', 'bbwaenh', 'bbwaed', 'bbwael', 'bbwaelg', 'bbwaelm', 'bbwaelb', 'bbwaels', 'bbwaelt', 'bbwaelp', 'bbwaelh', 'bbwaem', 'bbwaeb', 'bbwaebs', 'bbwaes', 'bbwaess', 'bbwaeng', 'bbwaej', 'bbwaec', 'bbwaek', 'bbwaet', 'bbwaep', 'bbwaeh', 'bboe', 'bboeg', 'bboegg', 'bboegs', 'bboen', 'bboenj', 'bboenh', 'bboed', 'bboel', 'bboelg', 'bboelm', 'bboelb', 'bboels', 'bboelt', 'bboelp', 'bboelh', 'bboem', 'bboeb', 'bboebs', 'bboes', 'bboess', 'bboeng', 'bboej', 'bboec', 'bboek', 'bboet', 'bboep', 'bboeh', 'bbyo', 'bbyog', 'bbyogg', 'bbyogs', 'bbyon', 'bbyonj', 'bbyonh', 'bbyod', 'bbyol', 'bbyolg', 'bbyolm', 'bbyolb', 'bbyols', 'bbyolt', 'bbyolp', 'bbyolh', 'bbyom', 'bbyob', 'bbyobs', 'bbyos', 'bbyoss', 'bbyong', 'bbyoj', 'bbyoc', 'bbyok', 'bbyot', 'bbyop', 'bbyoh', 'bbu', 'bbug', 'bbugg', 'bbugs', 'bbun', 'bbunj', 'bbunh', 'bbud', 'bbul', 'bbulg', 'bbulm', 'bbulb', 'bbuls', 'bbult', 'bbulp', 'bbulh', 'bbum', 'bbub', 'bbubs', 'bbus', 'bbuss', 'bbung', 'bbuj', 'bbuc', 'bbuk', 'bbut', 'bbup', 'bbuh', 'bbweo', 'bbweog', 'bbweogg', 'bbweogs', 'bbweon', 'bbweonj', 'bbweonh', 'bbweod', 'bbweol', 'bbweolg', 'bbweolm', 'bbweolb', 'bbweols', 'bbweolt', 'bbweolp', 'bbweolh', 'bbweom', 'bbweob', 'bbweobs', 'bbweos', 'bbweoss', 'bbweong', 'bbweoj', 'bbweoc']


Joomla CMS: Référence du fichier VisibleString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier VisibleString.php

Structures de données

class VisibleString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier PasswordProtected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Traits
Espaces de nommage | Fonctions | Variables
Référence du fichier PasswordProtected.php

Espaces de nommage

Common
phpseclib3\Crypt\Common\Traits

Fonctions

withPassword ($password=false)

Variables

trait PasswordProtected


Joomla CMS: Référence du fichier RandomNodeProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Node
Structures de données | Espaces de nommage
Référence du fichier RandomNodeProvider.php

Structures de données

class RandomNodeProvider

Espaces de nommage

Ramsey\Uuid\Provider\Node


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cpanel
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cpanel/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier PrivateDomainName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PrivateDomainName.php

Structures de données

class PrivateDomainName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier RoundingMode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • brick
  • math
  • src
Structures de données | Espaces de nommage
Référence du fichier RoundingMode.php

Structures de données

class RoundingMode

Espaces de nommage

Brick\Math


Joomla CMS: Référence du fichier sect163r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect163r2.php

Structures de données

class sect163r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier TextField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TextField.php

Structures de données

class TextField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier WorkflowTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier WorkflowTable.php

Structures de données

class WorkflowTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Table


Joomla CMS: Référence du fichier SocketTransport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
  • Transport
Structures de données | Espaces de nommage
Référence du fichier SocketTransport.php

Structures de données

class SocketTransport

Espaces de nommage

Joomla\CMS\Http\Transport


Joomla CMS: Référence du fichier Ucm.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Ucm.php

Structures de données

class Ucm

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier Route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/router/src/Route.php

Structures de données

class Route

Espaces de nommage

Joomla\Router


Joomla CMS: Référence du fichier privacycheck.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • privacycheck
Structures de données | Espaces de nommage
Référence du fichier privacycheck.php

Structures de données

class PlgQuickiconPrivacyCheck

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x079.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x079.php

Variables

return ['Tani ', 'Jiao ', '[?] ', 'Zhang ', 'Qiao ', 'Dun ', 'Xian ', 'Yu ', 'Zhui ', 'He ', 'Huo ', 'Zhai ', 'Lei ', 'Ke ', 'Chu ', 'Ji ', 'Que ', 'Dang ', 'Yi ', 'Jiang ', 'Pi ', 'Pi ', 'Yu ', 'Pin ', 'Qi ', 'Ai ', 'Kai ', 'Jian ', 'Yu ', 'Ruan ', 'Meng ', 'Pao ', 'Ci ', '[?] ', '[?] ', 'Mie ', 'Ca ', 'Xian ', 'Kuang ', 'Lei ', 'Lei ', 'Zhi ', 'Li ', 'Li ', 'Fan ', 'Que ', 'Pao ', 'Ying ', 'Li ', 'Long ', 'Long ', 'Mo ', 'Bo ', 'Shuang ', 'Guan ', 'Lan ', 'Zan ', 'Yan ', 'Shi ', 'Shi ', 'Li ', 'Reng ', 'She ', 'Yue ', 'Si ', 'Qi ', 'Ta ', 'Ma ', 'Xie ', 'Xian ', 'Xian ', 'Zhi ', 'Qi ', 'Zhi ', 'Beng ', 'Dui ', 'Zhong ', '[?] ', 'Yi ', 'Shi ', 'You ', 'Zhi ', 'Tiao ', 'Fu ', 'Fu ', 'Mi ', 'Zu ', 'Zhi ', 'Suan ', 'Mei ', 'Zuo ', 'Qu ', 'Hu ', 'Zhu ', 'Shen ', 'Sui ', 'Ci ', 'Chai ', 'Mi ', 'Lu ', 'Yu ', 'Xiang ', 'Wu ', 'Tiao ', 'Piao ', 'Zhu ', 'Gui ', 'Xia ', 'Zhi ', 'Ji ', 'Gao ', 'Zhen ', 'Gao ', 'Shui ', 'Jin ', 'Chen ', 'Gai ', 'Kun ', 'Di ', 'Dao ', 'Huo ', 'Tao ', 'Qi ', 'Gu ', 'Guan ', 'Zui ', 'Ling ', 'Lu ', 'Bing ', 'Jin ', 'Dao ', 'Zhi ', 'Lu ', 'Shan ', 'Bei ', 'Zhe ', 'Hui ', 'You ', 'Xi ', 'Yin ', 'Zi ', 'Huo ', 'Zhen ', 'Fu ', 'Yuan ', 'Wu ', 'Xian ', 'Yang ', 'Ti ', 'Yi ', 'Mei ', 'Si ', 'Di ', '[?] ', 'Zhuo ', 'Zhen ', 'Yong ', 'Ji ', 'Gao ', 'Tang ', 'Si ', 'Ma ', 'Ta ', '[?] ', 'Xuan ', 'Qi ', 'Yu ', 'Xi ', 'Ji ', 'Si ', 'Chan ', 'Tan ', 'Kuai ', 'Sui ', 'Li ', 'Nong ', 'Ni ', 'Dao ', 'Li ', 'Rang ', 'Yue ', 'Ti ', 'Zan ', 'Lei ', 'Rou ', 'Yu ', 'Yu ', 'Chi ', 'Xie ', 'Qin ', 'He ', 'Tu ', 'Xiu ', 'Si ', 'Ren ', 'Tu ', 'Zi ', 'Cha ', 'Gan ', 'Yi ', 'Xian ', 'Bing ', 'Nian ', 'Qiu ', 'Qiu ', 'Chong ', 'Fen ', 'Hao ', 'Yun ', 'Ke ', 'Miao ', 'Zhi ', 'Geng ', 'Bi ', 'Zhi ', 'Yu ', 'Mi ', 'Ku ', 'Ban ', 'Pi ', 'Ni ', 'Li ', 'You ', 'Zu ', 'Pi ', 'Ba ', 'Ling ', 'Mo ', 'Cheng ', 'Nian ', 'Qin ', 'Yang ', 'Zuo ', 'Zhi ', 'Zhi ', 'Shu ', 'Ju ', 'Zi ', 'Huo ', 'Ji ', 'Cheng ', 'Tong ', 'Zhi ', 'Huo ', 'He ', 'Yin ', 'Zi ', 'Zhi ', 'Jie ', 'Ren ', 'Du ', 'Yi ', 'Zhu ', 'Hui ', 'Nong ', 'Fu ']

Documentation des variables

◆ return

return[ 'Tani ', 'Jiao ', '[?] ', 'Zhang ', 'Qiao ', 'Dun ', 'Xian ', 'Yu ', 'Zhui ', 'He ', 'Huo ', 'Zhai ', 'Lei ', 'Ke ', 'Chu ', 'Ji ', 'Que ', 'Dang ', 'Yi ', 'Jiang ', 'Pi ', 'Pi ', 'Yu ', 'Pin ', 'Qi ', 'Ai ', 'Kai ', 'Jian ', 'Yu ', 'Ruan ', 'Meng ', 'Pao ', 'Ci ', '[?] ', '[?] ', 'Mie ', 'Ca ', 'Xian ', 'Kuang ', 'Lei ', 'Lei ', 'Zhi ', 'Li ', 'Li ', 'Fan ', 'Que ', 'Pao ', 'Ying ', 'Li ', 'Long ', 'Long ', 'Mo ', 'Bo ', 'Shuang ', 'Guan ', 'Lan ', 'Zan ', 'Yan ', 'Shi ', 'Shi ', 'Li ', 'Reng ', 'She ', 'Yue ', 'Si ', 'Qi ', 'Ta ', 'Ma ', 'Xie ', 'Xian ', 'Xian ', 'Zhi ', 'Qi ', 'Zhi ', 'Beng ', 'Dui ', 'Zhong ', '[?] ', 'Yi ', 'Shi ', 'You ', 'Zhi ', 'Tiao ', 'Fu ', 'Fu ', 'Mi ', 'Zu ', 'Zhi ', 'Suan ', 'Mei ', 'Zuo ', 'Qu ', 'Hu ', 'Zhu ', 'Shen ', 'Sui ', 'Ci ', 'Chai ', 'Mi ', 'Lu ', 'Yu ', 'Xiang ', 'Wu ', 'Tiao ', 'Piao ', 'Zhu ', 'Gui ', 'Xia ', 'Zhi ', 'Ji ', 'Gao ', 'Zhen ', 'Gao ', 'Shui ', 'Jin ', 'Chen ', 'Gai ', 'Kun ', 'Di ', 'Dao ', 'Huo ', 'Tao ', 'Qi ', 'Gu ', 'Guan ', 'Zui ', 'Ling ', 'Lu ', 'Bing ', 'Jin ', 'Dao ', 'Zhi ', 'Lu ', 'Shan ', 'Bei ', 'Zhe ', 'Hui ', 'You ', 'Xi ', 'Yin ', 'Zi ', 'Huo ', 'Zhen ', 'Fu ', 'Yuan ', 'Wu ', 'Xian ', 'Yang ', 'Ti ', 'Yi ', 'Mei ', 'Si ', 'Di ', '[?] ', 'Zhuo ', 'Zhen ', 'Yong ', 'Ji ', 'Gao ', 'Tang ', 'Si ', 'Ma ', 'Ta ', '[?] ', 'Xuan ', 'Qi ', 'Yu ', 'Xi ', 'Ji ', 'Si ', 'Chan ', 'Tan ', 'Kuai ', 'Sui ', 'Li ', 'Nong ', 'Ni ', 'Dao ', 'Li ', 'Rang ', 'Yue ', 'Ti ', 'Zan ', 'Lei ', 'Rou ', 'Yu ', 'Yu ', 'Chi ', 'Xie ', 'Qin ', 'He ', 'Tu ', 'Xiu ', 'Si ', 'Ren ', 'Tu ', 'Zi ', 'Cha ', 'Gan ', 'Yi ', 'Xian ', 'Bing ', 'Nian ', 'Qiu ', 'Qiu ', 'Chong ', 'Fen ', 'Hao ', 'Yun ', 'Ke ', 'Miao ', 'Zhi ', 'Geng ', 'Bi ', 'Zhi ', 'Yu ', 'Mi ', 'Ku ', 'Ban ', 'Pi ', 'Ni ', 'Li ', 'You ', 'Zu ', 'Pi ', 'Ba ', 'Ling ', 'Mo ', 'Cheng ', 'Nian ', 'Qin ', 'Yang ', 'Zuo ', 'Zhi ', 'Zhi ', 'Shu ', 'Ju ', 'Zi ', 'Huo ', 'Ji ', 'Cheng ', 'Tong ', 'Zhi ', 'Huo ', 'He ', 'Yin ', 'Zi ', 'Zhi ', 'Jie ', 'Ren ', 'Du ', 'Yi ', 'Zhu ', 'Hui ', 'Nong ', 'Fu ']


Joomla CMS: Référence du fichier PhpSetting.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier PhpSetting.php

Structures de données

class PhpSetting

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Service\HTML


Joomla CMS: Référence du fichier ProcessHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ProcessHelper.php

Structures de données

class ProcessHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier RSAPublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RSAPublicKey.php

Structures de données

class RSAPublicKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Sha256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Rsa
Structures de données | Espaces de nommage
Référence du fichier Rsa/Sha256.php

Structures de données

class Sha256

Espaces de nommage

Lcobucci\JWT\Signer\Rsa


Joomla CMS: Référence du fichier url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • url
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/url/url.php

Structures de données

class PlgFieldsUrl

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x058.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x058.php

Variables

return ['Ku ', 'Ke ', 'Tang ', 'Kun ', 'Ni ', 'Jian ', 'Dui ', 'Jin ', 'Gang ', 'Yu ', 'E ', 'Peng ', 'Gu ', 'Tu ', 'Leng ', '[?] ', 'Ya ', 'Qian ', '[?] ', 'An ', '[?] ', 'Duo ', 'Nao ', 'Tu ', 'Cheng ', 'Yin ', 'Hun ', 'Bi ', 'Lian ', 'Guo ', 'Die ', 'Zhuan ', 'Hou ', 'Bao ', 'Bao ', 'Yu ', 'Di ', 'Mao ', 'Jie ', 'Ruan ', 'E ', 'Geng ', 'Kan ', 'Zong ', 'Yu ', 'Huang ', 'E ', 'Yao ', 'Yan ', 'Bao ', 'Ji ', 'Mei ', 'Chang ', 'Du ', 'Tuo ', 'Yin ', 'Feng ', 'Zhong ', 'Jie ', 'Zhen ', 'Feng ', 'Gang ', 'Chuan ', 'Jian ', 'Pyeng ', 'Toride ', 'Xiang ', 'Huang ', 'Leng ', 'Duan ', '[?] ', 'Xuan ', 'Ji ', 'Ji ', 'Kuai ', 'Ying ', 'Ta ', 'Cheng ', 'Yong ', 'Kai ', 'Su ', 'Su ', 'Shi ', 'Mi ', 'Ta ', 'Weng ', 'Cheng ', 'Tu ', 'Tang ', 'Que ', 'Zhong ', 'Li ', 'Peng ', 'Bang ', 'Sai ', 'Zang ', 'Dui ', 'Tian ', 'Wu ', 'Cheng ', 'Xun ', 'Ge ', 'Zhen ', 'Ai ', 'Gong ', 'Yan ', 'Kan ', 'Tian ', 'Yuan ', 'Wen ', 'Xie ', 'Liu ', 'Ama ', 'Lang ', 'Chang ', 'Peng ', 'Beng ', 'Chen ', 'Cu ', 'Lu ', 'Ou ', 'Qian ', 'Mei ', 'Mo ', 'Zhuan ', 'Shuang ', 'Shu ', 'Lou ', 'Chi ', 'Man ', 'Biao ', 'Jing ', 'Qi ', 'Shu ', 'Di ', 'Zhang ', 'Kan ', 'Yong ', 'Dian ', 'Chen ', 'Zhi ', 'Xi ', 'Guo ', 'Qiang ', 'Jin ', 'Di ', 'Shang ', 'Mu ', 'Cui ', 'Yan ', 'Ta ', 'Zeng ', 'Qi ', 'Qiang ', 'Liang ', '[?] ', 'Zhui ', 'Qiao ', 'Zeng ', 'Xu ', 'Shan ', 'Shan ', 'Ba ', 'Pu ', 'Kuai ', 'Dong ', 'Fan ', 'Que ', 'Mo ', 'Dun ', 'Dun ', 'Dun ', 'Di ', 'Sheng ', 'Duo ', 'Duo ', 'Tan ', 'Deng ', 'Wu ', 'Fen ', 'Huang ', 'Tan ', 'Da ', 'Ye ', 'Sho ', 'Mama ', 'Yu ', 'Qiang ', 'Ji ', 'Qiao ', 'Ken ', 'Yi ', 'Pi ', 'Bi ', 'Dian ', 'Jiang ', 'Ye ', 'Yong ', 'Bo ', 'Tan ', 'Lan ', 'Ju ', 'Huai ', 'Dang ', 'Rang ', 'Qian ', 'Xun ', 'Lan ', 'Xi ', 'He ', 'Ai ', 'Ya ', 'Dao ', 'Hao ', 'Ruan ', 'Mama ', 'Lei ', 'Kuang ', 'Lu ', 'Yan ', 'Tan ', 'Wei ', 'Huai ', 'Long ', 'Long ', 'Rui ', 'Li ', 'Lin ', 'Rang ', 'Ten ', 'Xun ', 'Yan ', 'Lei ', 'Ba ', '[?] ', 'Shi ', 'Ren ', '[?] ', 'Zhuang ', 'Zhuang ', 'Sheng ', 'Yi ', 'Mai ', 'Ke ', 'Zhu ', 'Zhuang ', 'Hu ', 'Hu ', 'Kun ', 'Yi ', 'Hu ', 'Xu ', 'Kun ', 'Shou ', 'Mang ', 'Zun ']

Documentation des variables

◆ return

return[ 'Ku ', 'Ke ', 'Tang ', 'Kun ', 'Ni ', 'Jian ', 'Dui ', 'Jin ', 'Gang ', 'Yu ', 'E ', 'Peng ', 'Gu ', 'Tu ', 'Leng ', '[?] ', 'Ya ', 'Qian ', '[?] ', 'An ', '[?] ', 'Duo ', 'Nao ', 'Tu ', 'Cheng ', 'Yin ', 'Hun ', 'Bi ', 'Lian ', 'Guo ', 'Die ', 'Zhuan ', 'Hou ', 'Bao ', 'Bao ', 'Yu ', 'Di ', 'Mao ', 'Jie ', 'Ruan ', 'E ', 'Geng ', 'Kan ', 'Zong ', 'Yu ', 'Huang ', 'E ', 'Yao ', 'Yan ', 'Bao ', 'Ji ', 'Mei ', 'Chang ', 'Du ', 'Tuo ', 'Yin ', 'Feng ', 'Zhong ', 'Jie ', 'Zhen ', 'Feng ', 'Gang ', 'Chuan ', 'Jian ', 'Pyeng ', 'Toride ', 'Xiang ', 'Huang ', 'Leng ', 'Duan ', '[?] ', 'Xuan ', 'Ji ', 'Ji ', 'Kuai ', 'Ying ', 'Ta ', 'Cheng ', 'Yong ', 'Kai ', 'Su ', 'Su ', 'Shi ', 'Mi ', 'Ta ', 'Weng ', 'Cheng ', 'Tu ', 'Tang ', 'Que ', 'Zhong ', 'Li ', 'Peng ', 'Bang ', 'Sai ', 'Zang ', 'Dui ', 'Tian ', 'Wu ', 'Cheng ', 'Xun ', 'Ge ', 'Zhen ', 'Ai ', 'Gong ', 'Yan ', 'Kan ', 'Tian ', 'Yuan ', 'Wen ', 'Xie ', 'Liu ', 'Ama ', 'Lang ', 'Chang ', 'Peng ', 'Beng ', 'Chen ', 'Cu ', 'Lu ', 'Ou ', 'Qian ', 'Mei ', 'Mo ', 'Zhuan ', 'Shuang ', 'Shu ', 'Lou ', 'Chi ', 'Man ', 'Biao ', 'Jing ', 'Qi ', 'Shu ', 'Di ', 'Zhang ', 'Kan ', 'Yong ', 'Dian ', 'Chen ', 'Zhi ', 'Xi ', 'Guo ', 'Qiang ', 'Jin ', 'Di ', 'Shang ', 'Mu ', 'Cui ', 'Yan ', 'Ta ', 'Zeng ', 'Qi ', 'Qiang ', 'Liang ', '[?] ', 'Zhui ', 'Qiao ', 'Zeng ', 'Xu ', 'Shan ', 'Shan ', 'Ba ', 'Pu ', 'Kuai ', 'Dong ', 'Fan ', 'Que ', 'Mo ', 'Dun ', 'Dun ', 'Dun ', 'Di ', 'Sheng ', 'Duo ', 'Duo ', 'Tan ', 'Deng ', 'Wu ', 'Fen ', 'Huang ', 'Tan ', 'Da ', 'Ye ', 'Sho ', 'Mama ', 'Yu ', 'Qiang ', 'Ji ', 'Qiao ', 'Ken ', 'Yi ', 'Pi ', 'Bi ', 'Dian ', 'Jiang ', 'Ye ', 'Yong ', 'Bo ', 'Tan ', 'Lan ', 'Ju ', 'Huai ', 'Dang ', 'Rang ', 'Qian ', 'Xun ', 'Lan ', 'Xi ', 'He ', 'Ai ', 'Ya ', 'Dao ', 'Hao ', 'Ruan ', 'Mama ', 'Lei ', 'Kuang ', 'Lu ', 'Yan ', 'Tan ', 'Wei ', 'Huai ', 'Long ', 'Long ', 'Rui ', 'Li ', 'Lin ', 'Rang ', 'Ten ', 'Xun ', 'Yan ', 'Lei ', 'Ba ', '[?] ', 'Shi ', 'Ren ', '[?] ', 'Zhuang ', 'Zhuang ', 'Sheng ', 'Yi ', 'Mai ', 'Ke ', 'Zhu ', 'Zhuang ', 'Hu ', 'Hu ', 'Kun ', 'Yi ', 'Hu ', 'Xu ', 'Kun ', 'Shou ', 'Mang ', 'Zun ']


Joomla CMS: Référence du fichier Propel2Collector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier Propel2Collector.php

Structures de données

class Propel2Collector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_menus
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_menus/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier ResponseInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier ResponseInterface.php

Structures de données

interface ResponseInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier x0ff.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ff.php

Variables

return ['[?]', '!', '"', '#', '$', '%', '&', '\, '(', ')', '*', '+', ',', '-', '.', '/', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', ':', ';', '<', '=', '>', '?', '@', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', '[', '\, ']', '^', '_', '`', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '{', '|', '}', '~', '[?]', '[?]', '.', '[', ']', ',', '*', 'wo', 'a', 'i', 'u', 'e', 'o', 'ya', 'yu', 'yo', 'tu', '+', 'a', 'i', 'u', 'e', 'o', 'ka', 'ki', 'ku', 'ke', 'ko', 'sa', 'si', 'su', 'se', 'so', 'ta', 'ti', 'tu', 'te', 'to', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'hi', 'hu', 'he', 'ho', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'yu', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'n', ':', ';', '', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'dd', 'r', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'rh', 'm', 'b', 'bb', 'bs', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', '[?]', '[?]', '[?]', 'a', 'ae', 'ya', 'yae', 'eo', 'e', '[?]', '[?]', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', '[?]', '[?]', 'yo', 'u', 'weo', 'we', 'wi', 'yu', '[?]', '[?]', 'eu', 'yi', 'i', '[?]', '[?]', '[?]', '/C', 'PS', '!', '-', '|', 'Y=', 'W=', '[?]', '|', '-', '|', '-', '|', '#', 'O', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '{', '|', '}', '', '', '', '']

Documentation des variables

◆ return

return['[?]', '!', '"', '#', '$', '%', '&', '\', '(', ')', '*', '+', ',', '-', '.', '/', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', ':', ';', '<', '=', '>', '?', '@', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', '[', '\', ']', '^', '_', '`', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '{', '|', '}', '~', '[?]', '[?]', '.', '[', ']', ',', '*', 'wo', 'a', 'i', 'u', 'e', 'o', 'ya', 'yu', 'yo', 'tu', '+', 'a', 'i', 'u', 'e', 'o', 'ka', 'ki', 'ku', 'ke', 'ko', 'sa', 'si', 'su', 'se', 'so', 'ta', 'ti', 'tu', 'te', 'to', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'hi', 'hu', 'he', 'ho', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'yu', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'n', ':', ';', '', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'dd', 'r', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'rh', 'm', 'b', 'bb', 'bs', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', '[?]', '[?]', '[?]', 'a', 'ae', 'ya', 'yae', 'eo', 'e', '[?]', '[?]', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', '[?]', '[?]', 'yo', 'u', 'weo', 'we', 'wi', 'yu', '[?]', '[?]', 'eu', 'yi', 'i', '[?]', '[?]', '[?]', '/C', 'PS', '!', '-', '|', 'Y=', 'W=', '[?]', '|', '-', '|', '-', '|', '#', 'O', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '{', '|', '}', '', '', '', '']


Joomla CMS: Référence du fichier RuntimeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Exception
Structures de données | Espaces de nommage
Référence du fichier yaml/Exception/RuntimeException.php

Structures de données

class RuntimeException

Espaces de nommage

Symfony\Component\Yaml\Exception


Joomla CMS: Référence du fichier RendererInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier Document/RendererInterface.php

Structures de données

interface RendererInterface

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier TimeableTwigExtensionProfiler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • Twig
Structures de données | Espaces de nommage
Référence du fichier TimeableTwigExtensionProfiler.php

Structures de données

class TimeableTwigExtensionProfiler

Espaces de nommage

DebugBar\Bridge\Twig
DebugBar


Joomla CMS: Référence du fichier PrepareStatementFailureException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier PrepareStatementFailureException.php

Structures de données

class PrepareStatementFailureException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier VersionHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_version
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier VersionHelper.php

Structures de données

class VersionHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Version\Administrator\Helper


Joomla CMS: Référence du fichier Signature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature/Signature.php

Structures de données

class Signature

Espaces de nommage

Jose\Component\Signature


Joomla CMS: Référence du fichier Php73.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php73
Structures de données | Espaces de nommage
Référence du fichier Php73.php

Structures de données

class Php73

Espaces de nommage

Symfony\Polyfill\Php73


Joomla CMS: Référence du fichier TPMAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier TPMAttestationStatementSupport.php

Structures de données

class TPMAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier x005.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x005.php

Variables

return ['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'A', 'B', 'G', 'D', 'E', 'Z', 'E', 'E', 'T`', 'Zh', 'I', 'L', 'Kh', 'Ts', 'K', 'H', 'Dz', 'Gh', 'Ch', 'M', 'Y', 'N', 'Sh', 'O', 'Ch`', 'P', 'J', 'Rh', 'S', 'V', 'T', 'R', 'Ts`', 'W', 'P`', 'K`', 'O', 'F', '[?]', '[?]', '<', '\'', '/', '!', ',', '?', '.', '[?]', 'a', 'b', 'g', 'd', 'e', 'z', 'e', 'e', 't`', 'zh', 'i', 'l', 'kh', 'ts', 'k', 'h', 'dz', 'gh', 'ch', 'm', 'y', 'n', 'sh', 'o', 'ch`', 'p', 'j', 'rh', 's', 'v', 't', 'r', 'ts`', 'w', 'p`', 'k`', 'o', 'f', 'ew', '[?]', ':', '-', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '@', 'e', 'a', 'o', 'i', 'e', 'e', 'a', 'a', 'o', 'o', 'u', '\'', '', '-', '-', '|', '', '', ':', '', '', 'n', 'o', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'A', 'b', 'g', 'd', 'h', 'v', 'z', 'KH', 't', 'y', 'k', 'k', 'l', 'm', 'm', 'n', 'n', 's', '`', 'p', 'p', 'TS', 'TS', 'q', 'r', 'SH', 't', '[?]', '[?]', '[?]', '[?]', '[?]', 'V', 'OY', 'i', '\'', '"', 'v', 'n', 'q', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'A', 'B', 'G', 'D', 'E', 'Z', 'E', 'E', 'T`', 'Zh', 'I', 'L', 'Kh', 'Ts', 'K', 'H', 'Dz', 'Gh', 'Ch', 'M', 'Y', 'N', 'Sh', 'O', 'Ch`', 'P', 'J', 'Rh', 'S', 'V', 'T', 'R', 'Ts`', 'W', 'P`', 'K`', 'O', 'F', '[?]', '[?]', '<', '\'', '/', '!', ',', '?', '.', '[?]', 'a', 'b', 'g', 'd', 'e', 'z', 'e', 'e', 't`', 'zh', 'i', 'l', 'kh', 'ts', 'k', 'h', 'dz', 'gh', 'ch', 'm', 'y', 'n', 'sh', 'o', 'ch`', 'p', 'j', 'rh', 's', 'v', 't', 'r', 'ts`', 'w', 'p`', 'k`', 'o', 'f', 'ew', '[?]', ':', '-', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '@', 'e', 'a', 'o', 'i', 'e', 'e', 'a', 'a', 'o', 'o', 'u', '\'', '', '-', '-', '|', '', '', ':', '', '', 'n', 'o', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'A', 'b', 'g', 'd', 'h', 'v', 'z', 'KH', 't', 'y', 'k', 'k', 'l', 'm', 'm', 'n', 'n', 's', '`', 'p', 'p', 'TS', 'TS', 'q', 'r', 'SH', 't', '[?]', '[?]', '[?]', '[?]', '[?]', 'V', 'OY', 'i', '\'', '"', 'v', 'n', 'q', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier RouteNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
  • Exception
Structures de données | Espaces de nommage
Référence du fichier src/Router/Exception/RouteNotFoundException.php

Structures de données

class RouteNotFoundException

Espaces de nommage

Joomla\CMS\Router\Exception


Joomla CMS: Référence du fichier SqlsrvQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlsrv
Structures de données | Espaces de nommage
Référence du fichier SqlsrvQuery.php

Structures de données

class SqlsrvQuery

Espaces de nommage

Joomla\Database\Sqlsrv


Joomla CMS: Référence du fichier Set.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier Set.php

Structures de données

class Set

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier TimeGeneratorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier TimeGeneratorInterface.php

Structures de données

interface TimeGeneratorInterface

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier State.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • SecretStream
Structures de données
Référence du fichier src/Core32/SecretStream/State.php

Structures de données

class ParagonIE_Sodium_Core32_SecretStream_State


Joomla CMS: Référence du fichier sef.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • sef
Structures de données | Espaces de nommage
Référence du fichier sef.php

Structures de données

class PlgSystemSef

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ValidAt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier ValidAt.php

Structures de données

class ValidAt

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier WebAssetItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetItem.php

Structures de données

class WebAssetItem

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier section-byfieldsets.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable-table
Espaces de nommage | Variables
Référence du fichier table/section-byfieldsets.php

Espaces de nommage

Joomla\Site

Variables

endforeach
endif

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier PgsqlDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pgsql
Structures de données | Espaces de nommage
Référence du fichier PgsqlDriver.php

Structures de données

class PgsqlDriver

Espaces de nommage

Joomla\Database\Pgsql


Joomla CMS: Référence du fichier RequestIdGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier RequestIdGenerator.php

Structures de données

class RequestIdGenerator

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier Xsalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier Xsalsa20.php

Structures de données

class Xsalsa20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier PostinstallHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PostinstallHelper.php

Structures de données

class PostinstallHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Postinstall\Administrator\Helper


Joomla CMS: Référence du fichier UpdateAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
Structures de données | Espaces de nommage
Référence du fichier UpdateAdapter.php

Structures de données

class UpdateAdapter

Espaces de nommage

Joomla\CMS\Updater


Joomla CMS: Référence du fichier x1f1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x1f1.php

Variables

return ['0.', '0,', '1,', '2,', '3,', '4,', '5,', '6,', '7,', '8,', '9,', '', '', '', '', '', '(A)', '(B)', '(C)', '(D)', '(E)', '(F)', '(G)', '(H)', '(I)', '(J)', '(K)', '(L)', '(M)', '(N)', '(O)', '(P)', '(Q)', '(R)', '(S)', '(T)', '(U)', '(V)', '(W)', '(X)', '(Y)', '(Z)', 48=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 80=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 112=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 230=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z',]

Documentation des variables

◆ return

return[ '0.', '0,', '1,', '2,', '3,', '4,', '5,', '6,', '7,', '8,', '9,', '', '', '', '', '', '(A)', '(B)', '(C)', '(D)', '(E)', '(F)', '(G)', '(H)', '(I)', '(J)', '(K)', '(L)', '(M)', '(N)', '(O)', '(P)', '(Q)', '(R)', '(S)', '(T)', '(U)', '(V)', '(W)', '(X)', '(Y)', '(Z)', 48=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 80=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 112=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 230=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z',]


Joomla CMS: Référence du fichier Versioning.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Versioning
Structures de données | Espaces de nommage
Référence du fichier Versioning.php

Structures de données

class Versioning

Espaces de nommage

Joomla\CMS\Versioning


Joomla CMS: Référence du fichier Parameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DSA/Parameters.php

Structures de données

class Parameters

Espaces de nommage

DSA
phpseclib3\Crypt\DSA


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • basic
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/api-authentication/basic/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RouterFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterFactoryInterface.php

Structures de données

interface RouterFactoryInterface

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier Stringable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Référence du fichier Stringable.php


Joomla CMS: Référence du fichier WorkflowModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier WorkflowModel.php

Structures de données

class WorkflowModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier SchedulerComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier SchedulerComponent.php

Structures de données

class SchedulerComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Extension


Joomla CMS: Référence du fichier redirect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_redirect/helpers/redirect.php

Structures de données

class RedirectHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier UpdatesitesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier UpdatesitesModel.php

Structures de données

class UpdatesitesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier RedisStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Structures de données | Espaces de nommage
Référence du fichier vendor/maximebf/debugbar/src/DebugBar/Storage/RedisStorage.php

Structures de données

class RedisStorage

Espaces de nommage

DebugBar\Storage


Joomla CMS: Référence du fichier Pathway.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pathway
Structures de données | Espaces de nommage
Référence du fichier Pathway/Pathway.php

Structures de données

class Pathway

Espaces de nommage

Joomla\CMS\Pathway


Joomla CMS: Référence du fichier StagesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StagesModel.php

Structures de données

class StagesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier ParameterType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier ParameterType.php

Structures de données

class ParameterType

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier popup.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier popup.php

Espaces de nommage

Joomla\Site

Variables

$tagName = $tagName ?? 'button'
$modalAttrs ['data-bs-toggle'] = 'modal'
$modalAttrs ['data-bs-target'] = '#' . $selector
$idAttr = !empty($id) ? ' id="' . $id . '"' : ''
$listAttr = !empty($listCheck) ? ' list-selection' : ''

Documentation des variables

◆ $idAttr

$idAttr = !empty($id) ? ' id="' . $id . '"' : ''

◆ $listAttr

$listAttr = !empty($listCheck) ? ' list-selection' : ''

◆ $modalAttrs [1/2]

$modalAttrs[ 'data-bs-toggle'] = 'modal'

◆ $modalAttrs [2/2]

$modalAttrs[ 'data-bs-target'] = '#' . $selector

◆ $tagName

$tagName = $tagName ?? 'button'


Joomla CMS: Référence du fichier sort.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • grid
Espaces de nommage | Variables
Référence du fichier sort.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$icon = 'icon-sort'
$sort = ''
$caption = ''
$selected = ''
$id = ''
$heading = !empty($data->title) ? Text::_($data->title) : Text::_('JGRID_HEADING_ORDERING')
endif

Documentation des variables

◆ $caption

$caption = ''

◆ $data

$data = $displayData

◆ $heading

$heading = !empty($data->title) ? Text::_($data->title) : Text::_('JGRID_HEADING_ORDERING')

Référencé par PlgContentPagebreak\_createToc(), PHPMailer\DKIM_HeaderC(), NoteField\getLabel(), et CssMenu\load().

◆ $icon

$icon = 'icon-sort'

◆ $id

$id = ''

◆ $selected

$selected = ''

◆ $sort

if ( $data->order===$data->selected) $sort = ''

Référencé par SFTP\comparator(), WebAssetManager\getAssets(), et Parameters\getSort().

◆ endif

endif


Joomla CMS: Référence du fichier SendEmail.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
  • Exception
Structures de données | Espaces de nommage
Référence du fichier SendEmail.php

Structures de données

class SendEmail

Espaces de nommage

Joomla\CMS\MVC\Controller\Exception


Joomla CMS: Référence du fichier plugins.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/helpers/plugins.php

Structures de données

class PluginsHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x08b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08b.php

Variables

return ['Mou ', 'Ye ', 'Wei ', '[?] ', 'Teng ', 'Zou ', 'Shan ', 'Jian ', 'Bo ', 'Ku ', 'Huang ', 'Huo ', 'Ge ', 'Ying ', 'Mi ', 'Xiao ', 'Mi ', 'Xi ', 'Qiang ', 'Chen ', 'Nue ', 'Ti ', 'Su ', 'Bang ', 'Chi ', 'Qian ', 'Shi ', 'Jiang ', 'Yuan ', 'Xie ', 'Xue ', 'Tao ', 'Yao ', 'Yao ', '[?] ', 'Yu ', 'Biao ', 'Cong ', 'Qing ', 'Li ', 'Mo ', 'Mo ', 'Shang ', 'Zhe ', 'Miu ', 'Jian ', 'Ze ', 'Jie ', 'Lian ', 'Lou ', 'Can ', 'Ou ', 'Guan ', 'Xi ', 'Zhuo ', 'Ao ', 'Ao ', 'Jin ', 'Zhe ', 'Yi ', 'Hu ', 'Jiang ', 'Man ', 'Chao ', 'Han ', 'Hua ', 'Chan ', 'Xu ', 'Zeng ', 'Se ', 'Xi ', 'She ', 'Dui ', 'Zheng ', 'Nao ', 'Lan ', 'E ', 'Ying ', 'Jue ', 'Ji ', 'Zun ', 'Jiao ', 'Bo ', 'Hui ', 'Zhuan ', 'Mu ', 'Zen ', 'Zha ', 'Shi ', 'Qiao ', 'Tan ', 'Zen ', 'Pu ', 'Sheng ', 'Xuan ', 'Zao ', 'Tan ', 'Dang ', 'Sui ', 'Qian ', 'Ji ', 'Jiao ', 'Jing ', 'Lian ', 'Nou ', 'Yi ', 'Ai ', 'Zhan ', 'Pi ', 'Hui ', 'Hua ', 'Yi ', 'Yi ', 'Shan ', 'Rang ', 'Nou ', 'Qian ', 'Zhui ', 'Ta ', 'Hu ', 'Zhou ', 'Hao ', 'Ye ', 'Ying ', 'Jian ', 'Yu ', 'Jian ', 'Hui ', 'Du ', 'Zhe ', 'Xuan ', 'Zan ', 'Lei ', 'Shen ', 'Wei ', 'Chan ', 'Li ', 'Yi ', 'Bian ', 'Zhe ', 'Yan ', 'E ', 'Chou ', 'Wei ', 'Chou ', 'Yao ', 'Chan ', 'Rang ', 'Yin ', 'Lan ', 'Chen ', 'Huo ', 'Zhe ', 'Huan ', 'Zan ', 'Yi ', 'Dang ', 'Zhan ', 'Yan ', 'Du ', 'Yan ', 'Ji ', 'Ding ', 'Fu ', 'Ren ', 'Ji ', 'Jie ', 'Hong ', 'Tao ', 'Rang ', 'Shan ', 'Qi ', 'Tuo ', 'Xun ', 'Yi ', 'Xun ', 'Ji ', 'Ren ', 'Jiang ', 'Hui ', 'Ou ', 'Ju ', 'Ya ', 'Ne ', 'Xu ', 'E ', 'Lun ', 'Xiong ', 'Song ', 'Feng ', 'She ', 'Fang ', 'Jue ', 'Zheng ', 'Gu ', 'He ', 'Ping ', 'Zu ', 'Shi ', 'Xiong ', 'Zha ', 'Su ', 'Zhen ', 'Di ', 'Zou ', 'Ci ', 'Qu ', 'Zhao ', 'Bi ', 'Yi ', 'Yi ', 'Kuang ', 'Lei ', 'Shi ', 'Gua ', 'Shi ', 'Jie ', 'Hui ', 'Cheng ', 'Zhu ', 'Shen ', 'Hua ', 'Dan ', 'Gou ', 'Quan ', 'Gui ', 'Xun ', 'Yi ', 'Zheng ', 'Gai ', 'Xiang ', 'Cha ', 'Hun ', 'Xu ', 'Zhou ', 'Jie ', 'Wu ', 'Yu ', 'Qiao ', 'Wu ', 'Gao ', 'You ', 'Hui ', 'Kuang ', 'Shuo ', 'Song ', 'Ai ', 'Qing ', 'Zhu ', 'Zou ', 'Nuo ', 'Du ', 'Zhuo ', 'Fei ', 'Ke ', 'Wei ']

Documentation des variables

◆ return

return[ 'Mou ', 'Ye ', 'Wei ', '[?] ', 'Teng ', 'Zou ', 'Shan ', 'Jian ', 'Bo ', 'Ku ', 'Huang ', 'Huo ', 'Ge ', 'Ying ', 'Mi ', 'Xiao ', 'Mi ', 'Xi ', 'Qiang ', 'Chen ', 'Nue ', 'Ti ', 'Su ', 'Bang ', 'Chi ', 'Qian ', 'Shi ', 'Jiang ', 'Yuan ', 'Xie ', 'Xue ', 'Tao ', 'Yao ', 'Yao ', '[?] ', 'Yu ', 'Biao ', 'Cong ', 'Qing ', 'Li ', 'Mo ', 'Mo ', 'Shang ', 'Zhe ', 'Miu ', 'Jian ', 'Ze ', 'Jie ', 'Lian ', 'Lou ', 'Can ', 'Ou ', 'Guan ', 'Xi ', 'Zhuo ', 'Ao ', 'Ao ', 'Jin ', 'Zhe ', 'Yi ', 'Hu ', 'Jiang ', 'Man ', 'Chao ', 'Han ', 'Hua ', 'Chan ', 'Xu ', 'Zeng ', 'Se ', 'Xi ', 'She ', 'Dui ', 'Zheng ', 'Nao ', 'Lan ', 'E ', 'Ying ', 'Jue ', 'Ji ', 'Zun ', 'Jiao ', 'Bo ', 'Hui ', 'Zhuan ', 'Mu ', 'Zen ', 'Zha ', 'Shi ', 'Qiao ', 'Tan ', 'Zen ', 'Pu ', 'Sheng ', 'Xuan ', 'Zao ', 'Tan ', 'Dang ', 'Sui ', 'Qian ', 'Ji ', 'Jiao ', 'Jing ', 'Lian ', 'Nou ', 'Yi ', 'Ai ', 'Zhan ', 'Pi ', 'Hui ', 'Hua ', 'Yi ', 'Yi ', 'Shan ', 'Rang ', 'Nou ', 'Qian ', 'Zhui ', 'Ta ', 'Hu ', 'Zhou ', 'Hao ', 'Ye ', 'Ying ', 'Jian ', 'Yu ', 'Jian ', 'Hui ', 'Du ', 'Zhe ', 'Xuan ', 'Zan ', 'Lei ', 'Shen ', 'Wei ', 'Chan ', 'Li ', 'Yi ', 'Bian ', 'Zhe ', 'Yan ', 'E ', 'Chou ', 'Wei ', 'Chou ', 'Yao ', 'Chan ', 'Rang ', 'Yin ', 'Lan ', 'Chen ', 'Huo ', 'Zhe ', 'Huan ', 'Zan ', 'Yi ', 'Dang ', 'Zhan ', 'Yan ', 'Du ', 'Yan ', 'Ji ', 'Ding ', 'Fu ', 'Ren ', 'Ji ', 'Jie ', 'Hong ', 'Tao ', 'Rang ', 'Shan ', 'Qi ', 'Tuo ', 'Xun ', 'Yi ', 'Xun ', 'Ji ', 'Ren ', 'Jiang ', 'Hui ', 'Ou ', 'Ju ', 'Ya ', 'Ne ', 'Xu ', 'E ', 'Lun ', 'Xiong ', 'Song ', 'Feng ', 'She ', 'Fang ', 'Jue ', 'Zheng ', 'Gu ', 'He ', 'Ping ', 'Zu ', 'Shi ', 'Xiong ', 'Zha ', 'Su ', 'Zhen ', 'Di ', 'Zou ', 'Ci ', 'Qu ', 'Zhao ', 'Bi ', 'Yi ', 'Yi ', 'Kuang ', 'Lei ', 'Shi ', 'Gua ', 'Shi ', 'Jie ', 'Hui ', 'Cheng ', 'Zhu ', 'Shen ', 'Hua ', 'Dan ', 'Gou ', 'Quan ', 'Gui ', 'Xun ', 'Yi ', 'Zheng ', 'Gai ', 'Xiang ', 'Cha ', 'Hun ', 'Xu ', 'Zhou ', 'Jie ', 'Wu ', 'Yu ', 'Qiao ', 'Wu ', 'Gao ', 'You ', 'Hui ', 'Kuang ', 'Shuo ', 'Song ', 'Ai ', 'Qing ', 'Zhu ', 'Zou ', 'Nuo ', 'Du ', 'Zhuo ', 'Fei ', 'Ke ', 'Wei ']


Joomla CMS: Référence du fichier Substitutions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Substitutions.php

Structures de données

class Substitutions

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier secp128r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp128r1.php

Structures de données

class secp128r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier SubscriberInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier SubscriberInterface.php

Structures de données

interface SubscriberInterface

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier Transformation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Transformation.php

Structures de données

class Transformation

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier TransitionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TransitionField.php

Structures de données

class TransitionField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier UnrecognizedProtocolVersionException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnrecognizedProtocolVersionException.php

Structures de données

class UnrecognizedProtocolVersionException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier SearchesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier SearchesController.php

Structures de données

class SearchesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Controller


Joomla CMS: Référence du fichier TemplatestyleField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TemplatestyleField.php

Structures de données

class TemplatestyleField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier RouterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier src/Component/Router/RouterInterface.php

Structures de données

interface RouterInterface

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier php72compat_const.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Variables
Référence du fichier php72compat_const.php

Variables

const | SODIUM_LIBRARY_MAJOR_VERSION = 9
const | SODIUM_LIBRARY_MINOR_VERSION = 1
const | SODIUM_LIBRARY_VERSION = '1.0.8'
const | SODIUM_BASE64_VARIANT_ORIGINAL = 1
const | SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING = 3
const | SODIUM_BASE64_VARIANT_URLSAFE = 5
const | SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING = 7
const | SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES = 32
const | SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES = 0
const | SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES = 12
const | SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES = 16
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = 32
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = 0
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = 8
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = 16
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = 32
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = 0
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = 12
const | SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = 16
const | SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES = 32
const | SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES = 0
const | SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES = 24
const | SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES = 16
const | SODIUM_CRYPTO_AUTH_BYTES = 32
const | SODIUM_CRYPTO_AUTH_KEYBYTES = 32
const | SODIUM_CRYPTO_BOX_SEALBYTES = 16
const | SODIUM_CRYPTO_BOX_SECRETKEYBYTES = 32
const | SODIUM_CRYPTO_BOX_PUBLICKEYBYTES = 32
const | SODIUM_CRYPTO_BOX_KEYPAIRBYTES = 64
const | SODIUM_CRYPTO_BOX_MACBYTES = 16
const | SODIUM_CRYPTO_BOX_NONCEBYTES = 24
const | SODIUM_CRYPTO_BOX_SEEDBYTES = 32
const | SODIUM_CRYPTO_KDF_BYTES_MIN = 16
const | SODIUM_CRYPTO_KDF_BYTES_MAX = 64
const | SODIUM_CRYPTO_KDF_CONTEXTBYTES = 8
const | SODIUM_CRYPTO_KDF_KEYBYTES = 32
const | SODIUM_CRYPTO_KX_BYTES = 32
const | SODIUM_CRYPTO_KX_PRIMITIVE = 'x25519blake2b'
const | SODIUM_CRYPTO_KX_SEEDBYTES = 32
const | SODIUM_CRYPTO_KX_KEYPAIRBYTES = 64
const | SODIUM_CRYPTO_KX_PUBLICKEYBYTES = 32
const | SODIUM_CRYPTO_KX_SECRETKEYBYTES = 32
const | SODIUM_CRYPTO_KX_SESSIONKEYBYTES = 32
const | SODIUM_CRYPTO_GENERICHASH_BYTES = 32
const | SODIUM_CRYPTO_GENERICHASH_BYTES_MIN = 16
const | SODIUM_CRYPTO_GENERICHASH_BYTES_MAX = 64
const | SODIUM_CRYPTO_GENERICHASH_KEYBYTES = 32
const | SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN = 16
const | SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX = 64
const | SODIUM_CRYPTO_PWHASH_SALTBYTES = 16
const | SODIUM_CRYPTO_PWHASH_STRPREFIX = '$argon2id$'
const | SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 = 1
const | SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 = 2
const | SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE = 33554432
const | SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE = 4
const | SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE = 134217728
const | SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE = 6
const | SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE = 536870912
const | SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE = 8
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES = 32
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX = '$7$'
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE = 534288
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE = 16777216
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE = 33554432
const | SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE = 1073741824
const | SODIUM_CRYPTO_SCALARMULT_BYTES = 32
const | SODIUM_CRYPTO_SCALARMULT_SCALARBYTES = 32
const | SODIUM_CRYPTO_SHORTHASH_BYTES = 8
const | SODIUM_CRYPTO_SHORTHASH_KEYBYTES = 16
const | SODIUM_CRYPTO_SECRETBOX_KEYBYTES = 32
const | SODIUM_CRYPTO_SECRETBOX_MACBYTES = 16
const | SODIUM_CRYPTO_SECRETBOX_NONCEBYTES = 24
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES = 17
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES = 24
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES = 32
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH = 0
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL = 1
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY = 2
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL = 3
const | SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX = 0x3fffffff80
const | SODIUM_CRYPTO_SIGN_BYTES = 64
const | SODIUM_CRYPTO_SIGN_SEEDBYTES = 32
const | SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES = 32
const | SODIUM_CRYPTO_SIGN_SECRETKEYBYTES = 64
const | SODIUM_CRYPTO_SIGN_KEYPAIRBYTES = 96
const | SODIUM_CRYPTO_STREAM_KEYBYTES = 32
const | SODIUM_CRYPTO_STREAM_NONCEBYTES = 24
const | SODIUM_CRYPTO_STREAM_XCHACHA20_KEYBYTES = 32
const | SODIUM_CRYPTO_STREAM_XCHACHA20_NONCEBYTES = 24

Documentation des variables

◆ SODIUM_BASE64_VARIANT_ORIGINAL

const SODIUM_BASE64_VARIANT_ORIGINAL = 1

◆ SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING

const SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING = 3

◆ SODIUM_BASE64_VARIANT_URLSAFE

const SODIUM_BASE64_VARIANT_URLSAFE = 5

◆ SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING

const SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING = 7

◆ SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES

const SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES = 16

◆ SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES

const SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES = 32

◆ SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES

const SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES = 12

◆ SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES

const SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES = 0

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES = 16

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES = 16

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES = 32

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES = 12

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES = 0

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES = 32

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES = 8

◆ SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES

const SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES = 0

◆ SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES

const SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES = 16

◆ SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES

const SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES = 32

◆ SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES

const SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES = 24

◆ SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES

const SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES = 0

◆ SODIUM_CRYPTO_AUTH_BYTES

const SODIUM_CRYPTO_AUTH_BYTES = 32

◆ SODIUM_CRYPTO_AUTH_KEYBYTES

const SODIUM_CRYPTO_AUTH_KEYBYTES = 32

◆ SODIUM_CRYPTO_BOX_KEYPAIRBYTES

const SODIUM_CRYPTO_BOX_KEYPAIRBYTES = 64

◆ SODIUM_CRYPTO_BOX_MACBYTES

const SODIUM_CRYPTO_BOX_MACBYTES = 16

◆ SODIUM_CRYPTO_BOX_NONCEBYTES

const SODIUM_CRYPTO_BOX_NONCEBYTES = 24

◆ SODIUM_CRYPTO_BOX_PUBLICKEYBYTES

const SODIUM_CRYPTO_BOX_PUBLICKEYBYTES = 32

◆ SODIUM_CRYPTO_BOX_SEALBYTES

const SODIUM_CRYPTO_BOX_SEALBYTES = 16

◆ SODIUM_CRYPTO_BOX_SECRETKEYBYTES

const SODIUM_CRYPTO_BOX_SECRETKEYBYTES = 32

◆ SODIUM_CRYPTO_BOX_SEEDBYTES

const SODIUM_CRYPTO_BOX_SEEDBYTES = 32

◆ SODIUM_CRYPTO_GENERICHASH_BYTES

const SODIUM_CRYPTO_GENERICHASH_BYTES = 32

◆ SODIUM_CRYPTO_GENERICHASH_BYTES_MAX

const SODIUM_CRYPTO_GENERICHASH_BYTES_MAX = 64

◆ SODIUM_CRYPTO_GENERICHASH_BYTES_MIN

const SODIUM_CRYPTO_GENERICHASH_BYTES_MIN = 16

◆ SODIUM_CRYPTO_GENERICHASH_KEYBYTES

const SODIUM_CRYPTO_GENERICHASH_KEYBYTES = 32

◆ SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX

const SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX = 64

◆ SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN

const SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN = 16

◆ SODIUM_CRYPTO_KDF_BYTES_MAX

const SODIUM_CRYPTO_KDF_BYTES_MAX = 64

◆ SODIUM_CRYPTO_KDF_BYTES_MIN

const SODIUM_CRYPTO_KDF_BYTES_MIN = 16

◆ SODIUM_CRYPTO_KDF_CONTEXTBYTES

const SODIUM_CRYPTO_KDF_CONTEXTBYTES = 8

◆ SODIUM_CRYPTO_KDF_KEYBYTES

const SODIUM_CRYPTO_KDF_KEYBYTES = 32

◆ SODIUM_CRYPTO_KX_BYTES

const SODIUM_CRYPTO_KX_BYTES = 32

◆ SODIUM_CRYPTO_KX_KEYPAIRBYTES

const SODIUM_CRYPTO_KX_KEYPAIRBYTES = 64

◆ SODIUM_CRYPTO_KX_PRIMITIVE

const SODIUM_CRYPTO_KX_PRIMITIVE = 'x25519blake2b'

◆ SODIUM_CRYPTO_KX_PUBLICKEYBYTES

const SODIUM_CRYPTO_KX_PUBLICKEYBYTES = 32

◆ SODIUM_CRYPTO_KX_SECRETKEYBYTES

const SODIUM_CRYPTO_KX_SECRETKEYBYTES = 32

◆ SODIUM_CRYPTO_KX_SEEDBYTES

const SODIUM_CRYPTO_KX_SEEDBYTES = 32

◆ SODIUM_CRYPTO_KX_SESSIONKEYBYTES

const SODIUM_CRYPTO_KX_SESSIONKEYBYTES = 32

◆ SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13

const SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 = 1

Référencé par PuTTY\generateV3Key().

◆ SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13

const SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 = 2

Référencé par PuTTY\generateV3Key().

◆ SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE

const SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE = 33554432

Référencé par Argon2iHandler\hashPassword().

◆ SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE

const SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE = 134217728

◆ SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE

const SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE = 536870912

◆ SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE

const SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE = 4

Référencé par Argon2iHandler\hashPassword().

◆ SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE

const SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE = 6

◆ SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE

const SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE = 8

◆ SODIUM_CRYPTO_PWHASH_SALTBYTES

const SODIUM_CRYPTO_PWHASH_SALTBYTES = 16

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE = 16777216

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE = 1073741824

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE = 534288

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE = 33554432

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES = 32

◆ SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX

const SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX = '$7$'

◆ SODIUM_CRYPTO_PWHASH_STRPREFIX

const SODIUM_CRYPTO_PWHASH_STRPREFIX = '$argon2id$'

◆ SODIUM_CRYPTO_SCALARMULT_BYTES

const SODIUM_CRYPTO_SCALARMULT_BYTES = 32

◆ SODIUM_CRYPTO_SCALARMULT_SCALARBYTES

const SODIUM_CRYPTO_SCALARMULT_SCALARBYTES = 32

◆ SODIUM_CRYPTO_SECRETBOX_KEYBYTES

const SODIUM_CRYPTO_SECRETBOX_KEYBYTES = 32

◆ SODIUM_CRYPTO_SECRETBOX_MACBYTES

const SODIUM_CRYPTO_SECRETBOX_MACBYTES = 16

◆ SODIUM_CRYPTO_SECRETBOX_NONCEBYTES

const SODIUM_CRYPTO_SECRETBOX_NONCEBYTES = 24

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES = 17

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES = 24

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES = 32

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX = 0x3fffffff80

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL = 3

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL = 1

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH = 0

◆ SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY

const SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY = 2

◆ SODIUM_CRYPTO_SHORTHASH_BYTES

const SODIUM_CRYPTO_SHORTHASH_BYTES = 8

◆ SODIUM_CRYPTO_SHORTHASH_KEYBYTES

const SODIUM_CRYPTO_SHORTHASH_KEYBYTES = 16

◆ SODIUM_CRYPTO_SIGN_BYTES

const SODIUM_CRYPTO_SIGN_BYTES = 64

◆ SODIUM_CRYPTO_SIGN_KEYPAIRBYTES

const SODIUM_CRYPTO_SIGN_KEYPAIRBYTES = 96

◆ SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES

const SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES = 32

◆ SODIUM_CRYPTO_SIGN_SECRETKEYBYTES

const SODIUM_CRYPTO_SIGN_SECRETKEYBYTES = 64

◆ SODIUM_CRYPTO_SIGN_SEEDBYTES

const SODIUM_CRYPTO_SIGN_SEEDBYTES = 32

◆ SODIUM_CRYPTO_STREAM_KEYBYTES

const SODIUM_CRYPTO_STREAM_KEYBYTES = 32

◆ SODIUM_CRYPTO_STREAM_NONCEBYTES

const SODIUM_CRYPTO_STREAM_NONCEBYTES = 24

◆ SODIUM_CRYPTO_STREAM_XCHACHA20_KEYBYTES

const SODIUM_CRYPTO_STREAM_XCHACHA20_KEYBYTES = 32

◆ SODIUM_CRYPTO_STREAM_XCHACHA20_NONCEBYTES

const SODIUM_CRYPTO_STREAM_XCHACHA20_NONCEBYTES = 24

◆ SODIUM_LIBRARY_MAJOR_VERSION

const SODIUM_LIBRARY_MAJOR_VERSION = 9

Référencé par ParagonIE_Sodium_Compat\library_version_major().

◆ SODIUM_LIBRARY_MINOR_VERSION

const SODIUM_LIBRARY_MINOR_VERSION = 1

Référencé par ParagonIE_Sodium_Compat\library_version_minor().

◆ SODIUM_LIBRARY_VERSION

const SODIUM_LIBRARY_VERSION = '1.0.8'


Joomla CMS: Référence du fichier Salsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core/Salsa20.php

Structures de données

class ParagonIE_Sodium_Core_Salsa20


Joomla CMS: Référence du fichier StatusReport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier StatusReport.php

Structures de données

class StatusReport

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier x02e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x02e.php

Variables

return ['r', 'r.', '[?]', '[?]', '[?]', '[?]', 'T', 'T.', '[?]', 's', '[?]', '[]', '\\', '/', '[?]', '__', '[?]', '[?]', '>', '%', '[?]', '[?]', '>', '=', '[?]', '/', '-', '~', '\\', '/', '~', '~', '|-', '-|', '[?]', '[?]', '[?]', '[?]', '<=', '=>', '((', '))', '[?]', '[?]', '::', '[?]', '?', '\'', 'o', '.', ',', '.', ',', ';', '[?]', '[?]', '[?]', '[?]', '----', '------', 'x', '|', '[?]', '[?]', '=', ',', '"', '`--', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'r', 'r.', '[?]', '[?]', '[?]', '[?]', 'T', 'T.', '[?]', 's', '[?]', '[]', '\\', '/', '[?]', '__', '[?]', '[?]', '>', '%', '[?]', '[?]', '>', '=', '[?]', '/', '-', '~', '\\', '/', '~', '~', '|-', '-|', '[?]', '[?]', '[?]', '[?]', '<=', '=>', '((', '))', '[?]', '[?]', '::', '[?]', '?', '\'', 'o', '.', ',', '.', ',', ';', '[?]', '[?]', '[?]', '[?]', '----', '------', 'x', '|', '[?]', '[?]', '=', ',', '"', '`--', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier traces.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier traces.html.php

Variables

$separator = strrpos($exception['class'], '\\')
$namespace = substr($exception['class'], 0, $separator)
$class = substr($exception['class'], $separator)
if(''===$class) else if ('' !==$namespace) = $class
if ( $exception[ 'message'] &&$index > 1) = $index
$isFirstUserCode = true

Documentation des variables

◆ $class

$class = substr($exception['class'], $separator)

◆ $isFirstUserCode

$isFirstUserCode = true

◆ $namespace

$namespace = substr($exception['class'], 0, $separator)

Référencé par CategoryFactory\__construct(), MVCFactory\__construct(), RouterFactory\__construct(), Application\all(), Factory\createConfig(), MarkdownDescriptor\describeApplication(), TextDescriptor\describeApplication(), TextDescriptor\describeJoomlaApplication(), Application\findNamespace(), Application\getAllCommands(), XmlDescriptor\getApplicationDocument(), Factory\getConfig(), Factory\getFormat(), JNamespacePsr4Map\getNamespaces(), JNamespacePsr4Map\load(), FeedParser\parse(), WebAssetRegistry\parseRegistryFile(), DebugClassLoader\patchMethod(), FeedParser\processElement(), FeedParser\registerNamespace(), JLoader\registerNamespace(), XML\savePublicKey(), InstallationApplication\setCfg(), XML\setNamespace(), FlattenException\setTrace(), CaptchaRule\test(), et JNamespacePsr4Map\writeNamespaceFile().

◆ $separator

$separator = strrpos($exception['class'], '\\')

◆ if [1/2]

if (''===$class) else if('' !==$namespace) = $class

◆ if [2/2]

if($exception['message'] && $index > 1) = $index


Joomla CMS: Référence du fichier rotate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • rotate
Structures de données | Espaces de nommage
Référence du fichier rotate.php

Structures de données

class PlgMediaActionRotate

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier secp112r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp112r1.php

Structures de données

class secp112r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x02c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x02c.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 'L', 'l', 'L', 'P', 'R', 'a', 't', 'H', 'h', 'K', 'k', 'Z', 'z', '', 'M', 'A', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 'L', 'l', 'L', 'P', 'R', 'a', 't', 'H', 'h', 'K', 'k', 'Z', 'z', '', 'M', 'A', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier RedirectComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier RedirectComponent.php

Structures de données

class RedirectComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Extension


Joomla CMS: Référence du fichier StandardRules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
  • Rules
Structures de données | Espaces de nommage
Référence du fichier StandardRules.php

Structures de données

class StandardRules

Espaces de nommage

Joomla\CMS\Component\Router\Rules


Joomla CMS: Référence du fichier UuidBuilderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Builder
Structures de données | Espaces de nommage
Référence du fichier UuidBuilderInterface.php

Structures de données

interface UuidBuilderInterface

Espaces de nommage

Ramsey\Uuid\Builder


Joomla CMS: Référence du fichier x009.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x009.php


Joomla CMS: Référence du fichier RemindModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_privacy/src/Model/RemindModel.php

Structures de données

class RemindModel

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Model


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • services
Structures de données | Espaces de nommage
Référence du fichier modules/mod_articles_news/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier SqliteQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlite
Structures de données | Espaces de nommage
Référence du fichier SqliteQuery.php

Structures de données

class SqliteQuery

Espaces de nommage

Joomla\Database\Sqlite


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_associations
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_associations/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x025.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x025.php

Variables

return ['-', '-', '|', '|', '-', '-', '|', '|', '-', '-', '|', '|', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '-', '-', '|', '|', '-', '|', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '/', '\\', 'X', '-', '|', '-', '|', '-', '|', '-', '|', '-', '|', '-', '|', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '-', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '^', '^', '^', '^', '>', '>', '>', '>', '>', '>', 'V', 'V', 'V', 'V', '<', '<', '<', '<', '<', '<', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', '#', '#', '#', '#', '#', '^', '^', '^', 'O', '#', '#', '#', '#', 'O', 'O', 'O', 'O', '/', '\\\\', '\\\\', '#', '#', '#', '#', '/']

Documentation des variables

◆ return

return['-', '-', '|', '|', '-', '-', '|', '|', '-', '-', '|', '|', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '-', '-', '|', '|', '-', '|', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '+', '/', '\\', 'X', '-', '|', '-', '|', '-', '|', '-', '|', '-', '|', '-', '|', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '-', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '#', '^', '^', '^', '^', '>', '>', '>', '>', '>', '>', 'V', 'V', 'V', 'V', '<', '<', '<', '<', '<', '<', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', ' *', '#', '#', '#', '#', '#', '^', '^', '^', 'O', '#', '#', '#', '#', 'O', 'O', 'O', 'O', '/', '\\\\', '\\\\', '#', '#', '#', '#', '/']


Joomla CMS: Référence du fichier SendEmailExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier SendEmailExceptionHandler.php

Structures de données

class SendEmailExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier SqlazureQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlazure
Structures de données | Espaces de nommage
Référence du fichier SqlazureQuery.php

Structures de données

class SqlazureQuery

Espaces de nommage

Joomla\Database\Sqlazure


Joomla CMS: Référence du fichier TemplateController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_mails/src/Controller/TemplateController.php

Structures de données

class TemplateController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Controller


Joomla CMS: Référence du fichier PolicyMappings.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PolicyMappings.php

Structures de données

class PolicyMappings

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SeekingData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataFormatter
  • VarDumper
Structures de données | Espaces de nommage
Référence du fichier SeekingData.php

Structures de données

class SeekingData

Espaces de nommage

DebugBar\DataFormatter\VarDumper


Joomla CMS: Référence du fichier x054.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x054.php

Variables

return ['Mie ', 'Xu ', 'Mang ', 'Chi ', 'Ge ', 'Xuan ', 'Yao ', 'Zi ', 'He ', 'Ji ', 'Diao ', 'Cun ', 'Tong ', 'Ming ', 'Hou ', 'Li ', 'Tu ', 'Xiang ', 'Zha ', 'Xia ', 'Ye ', 'Lu ', 'A ', 'Ma ', 'Ou ', 'Xue ', 'Yi ', 'Jun ', 'Chou ', 'Lin ', 'Tun ', 'Yin ', 'Fei ', 'Bi ', 'Qin ', 'Qin ', 'Jie ', 'Bu ', 'Fou ', 'Ba ', 'Dun ', 'Fen ', 'E ', 'Han ', 'Ting ', 'Hang ', 'Shun ', 'Qi ', 'Hong ', 'Zhi ', 'Shen ', 'Wu ', 'Wu ', 'Chao ', 'Ne ', 'Xue ', 'Xi ', 'Chui ', 'Dou ', 'Wen ', 'Hou ', 'Ou ', 'Wu ', 'Gao ', 'Ya ', 'Jun ', 'Lu ', 'E ', 'Ge ', 'Mei ', 'Ai ', 'Qi ', 'Cheng ', 'Wu ', 'Gao ', 'Fu ', 'Jiao ', 'Hong ', 'Chi ', 'Sheng ', 'Ne ', 'Tun ', 'Fu ', 'Yi ', 'Dai ', 'Ou ', 'Li ', 'Bai ', 'Yuan ', 'Kuai ', '[?] ', 'Qiang ', 'Wu ', 'E ', 'Shi ', 'Quan ', 'Pen ', 'Wen ', 'Ni ', 'M ', 'Ling ', 'Ran ', 'You ', 'Di ', 'Zhou ', 'Shi ', 'Zhou ', 'Tie ', 'Xi ', 'Yi ', 'Qi ', 'Ping ', 'Zi ', 'Gu ', 'Zi ', 'Wei ', 'Xu ', 'He ', 'Nao ', 'Xia ', 'Pei ', 'Yi ', 'Xiao ', 'Shen ', 'Hu ', 'Ming ', 'Da ', 'Qu ', 'Ju ', 'Gem ', 'Za ', 'Tuo ', 'Duo ', 'Pou ', 'Pao ', 'Bi ', 'Fu ', 'Yang ', 'He ', 'Zha ', 'He ', 'Hai ', 'Jiu ', 'Yong ', 'Fu ', 'Que ', 'Zhou ', 'Wa ', 'Ka ', 'Gu ', 'Ka ', 'Zuo ', 'Bu ', 'Long ', 'Dong ', 'Ning ', 'Tha ', 'Si ', 'Xian ', 'Huo ', 'Qi ', 'Er ', 'E ', 'Guang ', 'Zha ', 'Xi ', 'Yi ', 'Lie ', 'Zi ', 'Mie ', 'Mi ', 'Zhi ', 'Yao ', 'Ji ', 'Zhou ', 'Ge ', 'Shuai ', 'Zan ', 'Xiao ', 'Ke ', 'Hui ', 'Kua ', 'Huai ', 'Tao ', 'Xian ', 'E ', 'Xuan ', 'Xiu ', 'Wai ', 'Yan ', 'Lao ', 'Yi ', 'Ai ', 'Pin ', 'Shen ', 'Tong ', 'Hong ', 'Xiong ', 'Chi ', 'Wa ', 'Ha ', 'Zai ', 'Yu ', 'Di ', 'Pai ', 'Xiang ', 'Ai ', 'Hen ', 'Kuang ', 'Ya ', 'Da ', 'Xiao ', 'Bi ', 'Yue ', '[?] ', 'Hua ', 'Sasou ', 'Kuai ', 'Duo ', '[?] ', 'Ji ', 'Nong ', 'Mou ', 'Yo ', 'Hao ', 'Yuan ', 'Long ', 'Pou ', 'Mang ', 'Ge ', 'E ', 'Chi ', 'Shao ', 'Li ', 'Na ', 'Zu ', 'He ', 'Ku ', 'Xiao ', 'Xian ', 'Lao ', 'Bo ', 'Zhe ', 'Zha ', 'Liang ', 'Ba ', 'Mie ', 'Le ', 'Sui ', 'Fou ', 'Bu ', 'Han ', 'Heng ', 'Geng ', 'Shuo ', 'Ge ']

Documentation des variables

◆ return

return[ 'Mie ', 'Xu ', 'Mang ', 'Chi ', 'Ge ', 'Xuan ', 'Yao ', 'Zi ', 'He ', 'Ji ', 'Diao ', 'Cun ', 'Tong ', 'Ming ', 'Hou ', 'Li ', 'Tu ', 'Xiang ', 'Zha ', 'Xia ', 'Ye ', 'Lu ', 'A ', 'Ma ', 'Ou ', 'Xue ', 'Yi ', 'Jun ', 'Chou ', 'Lin ', 'Tun ', 'Yin ', 'Fei ', 'Bi ', 'Qin ', 'Qin ', 'Jie ', 'Bu ', 'Fou ', 'Ba ', 'Dun ', 'Fen ', 'E ', 'Han ', 'Ting ', 'Hang ', 'Shun ', 'Qi ', 'Hong ', 'Zhi ', 'Shen ', 'Wu ', 'Wu ', 'Chao ', 'Ne ', 'Xue ', 'Xi ', 'Chui ', 'Dou ', 'Wen ', 'Hou ', 'Ou ', 'Wu ', 'Gao ', 'Ya ', 'Jun ', 'Lu ', 'E ', 'Ge ', 'Mei ', 'Ai ', 'Qi ', 'Cheng ', 'Wu ', 'Gao ', 'Fu ', 'Jiao ', 'Hong ', 'Chi ', 'Sheng ', 'Ne ', 'Tun ', 'Fu ', 'Yi ', 'Dai ', 'Ou ', 'Li ', 'Bai ', 'Yuan ', 'Kuai ', '[?] ', 'Qiang ', 'Wu ', 'E ', 'Shi ', 'Quan ', 'Pen ', 'Wen ', 'Ni ', 'M ', 'Ling ', 'Ran ', 'You ', 'Di ', 'Zhou ', 'Shi ', 'Zhou ', 'Tie ', 'Xi ', 'Yi ', 'Qi ', 'Ping ', 'Zi ', 'Gu ', 'Zi ', 'Wei ', 'Xu ', 'He ', 'Nao ', 'Xia ', 'Pei ', 'Yi ', 'Xiao ', 'Shen ', 'Hu ', 'Ming ', 'Da ', 'Qu ', 'Ju ', 'Gem ', 'Za ', 'Tuo ', 'Duo ', 'Pou ', 'Pao ', 'Bi ', 'Fu ', 'Yang ', 'He ', 'Zha ', 'He ', 'Hai ', 'Jiu ', 'Yong ', 'Fu ', 'Que ', 'Zhou ', 'Wa ', 'Ka ', 'Gu ', 'Ka ', 'Zuo ', 'Bu ', 'Long ', 'Dong ', 'Ning ', 'Tha ', 'Si ', 'Xian ', 'Huo ', 'Qi ', 'Er ', 'E ', 'Guang ', 'Zha ', 'Xi ', 'Yi ', 'Lie ', 'Zi ', 'Mie ', 'Mi ', 'Zhi ', 'Yao ', 'Ji ', 'Zhou ', 'Ge ', 'Shuai ', 'Zan ', 'Xiao ', 'Ke ', 'Hui ', 'Kua ', 'Huai ', 'Tao ', 'Xian ', 'E ', 'Xuan ', 'Xiu ', 'Wai ', 'Yan ', 'Lao ', 'Yi ', 'Ai ', 'Pin ', 'Shen ', 'Tong ', 'Hong ', 'Xiong ', 'Chi ', 'Wa ', 'Ha ', 'Zai ', 'Yu ', 'Di ', 'Pai ', 'Xiang ', 'Ai ', 'Hen ', 'Kuang ', 'Ya ', 'Da ', 'Xiao ', 'Bi ', 'Yue ', '[?] ', 'Hua ', 'Sasou ', 'Kuai ', 'Duo ', '[?] ', 'Ji ', 'Nong ', 'Mou ', 'Yo ', 'Hao ', 'Yuan ', 'Long ', 'Pou ', 'Mang ', 'Ge ', 'E ', 'Chi ', 'Shao ', 'Li ', 'Na ', 'Zu ', 'He ', 'Ku ', 'Xiao ', 'Xian ', 'Lao ', 'Bo ', 'Zhe ', 'Zha ', 'Liang ', 'Ba ', 'Mie ', 'Le ', 'Sui ', 'Fou ', 'Bu ', 'Han ', 'Heng ', 'Geng ', 'Shuo ', 'Ge ']


Joomla CMS: Référence du fichier UuidFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier UuidFactoryInterface.php

Structures de données

interface UuidFactoryInterface

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier TemplateslistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TemplateslistField.php

Structures de données

class TemplatesListField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\Field


Joomla CMS: Référence du fichier RequiredConstraintsViolated.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Structures de données | Espaces de nommage
Référence du fichier RequiredConstraintsViolated.php

Structures de données

class RequiredConstraintsViolated

Espaces de nommage

Lcobucci\JWT\Validation


Joomla CMS: Référence du fichier UniqueIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier UniqueIdentifier.php

Structures de données

class UniqueIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SMTP.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpmailer
  • phpmailer
  • src
Structures de données | Espaces de nommage
Référence du fichier SMTP.php

Structures de données

class SMTP

Espaces de nommage

PHPMailer\PHPMailer


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_actionlogs/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier RS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-experimental
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-experimental/RS1.php

Structures de données

class RS1

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • email
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/email/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier StreamString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
  • Streams
Structures de données | Espaces de nommage
Référence du fichier StreamString.php

Structures de données

class StreamString

Espaces de nommage

Joomla\CMS\Filesystem\Streams


Joomla CMS: Référence du fichier secp112r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp112r2.php

Structures de données

class secp112r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Yaml.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier symfony/yaml/Yaml.php

Structures de données

class Yaml

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier Updater.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Updater
Structures de données | Espaces de nommage
Référence du fichier Updater.php

Structures de données

class Updater

Espaces de nommage

Joomla\CMS\Updater


Joomla CMS: Référence du fichier Stemmer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Stemmer.php

Structures de données

interface Stemmer

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier UriImmutable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Structures de données | Espaces de nommage
Référence du fichier UriImmutable.php

Structures de données

class UriImmutable

Espaces de nommage

Joomla\Uri


Joomla CMS: Référence du fichier StringWrapper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Stream
Structures de données | Espaces de nommage
Référence du fichier StringWrapper.php

Structures de données

class StringWrapper

Espaces de nommage

Joomla\Filesystem\Stream


Joomla CMS: Référence du fichier TagObjectManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier TagObjectManager.php

Structures de données

class TagObjectManager

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier x0bc.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0bc.php

Variables

return ['mil', 'milg', 'milm', 'milb', 'mils', 'milt', 'milp', 'milh', 'mim', 'mib', 'mibs', 'mis', 'miss', 'ming', 'mij', 'mic', 'mik', 'mit', 'mip', 'mih', 'ba', 'bag', 'bagg', 'bags', 'ban', 'banj', 'banh', 'bad', 'bal', 'balg', 'balm', 'balb', 'bals', 'balt', 'balp', 'balh', 'bam', 'bab', 'babs', 'bas', 'bass', 'bang', 'baj', 'bac', 'bak', 'bat', 'bap', 'bah', 'bae', 'baeg', 'baegg', 'baegs', 'baen', 'baenj', 'baenh', 'baed', 'bael', 'baelg', 'baelm', 'baelb', 'baels', 'baelt', 'baelp', 'baelh', 'baem', 'baeb', 'baebs', 'baes', 'baess', 'baeng', 'baej', 'baec', 'baek', 'baet', 'baep', 'baeh', 'bya', 'byag', 'byagg', 'byags', 'byan', 'byanj', 'byanh', 'byad', 'byal', 'byalg', 'byalm', 'byalb', 'byals', 'byalt', 'byalp', 'byalh', 'byam', 'byab', 'byabs', 'byas', 'byass', 'byang', 'byaj', 'byac', 'byak', 'byat', 'byap', 'byah', 'byae', 'byaeg', 'byaegg', 'byaegs', 'byaen', 'byaenj', 'byaenh', 'byaed', 'byael', 'byaelg', 'byaelm', 'byaelb', 'byaels', 'byaelt', 'byaelp', 'byaelh', 'byaem', 'byaeb', 'byaebs', 'byaes', 'byaess', 'byaeng', 'byaej', 'byaec', 'byaek', 'byaet', 'byaep', 'byaeh', 'beo', 'beog', 'beogg', 'beogs', 'beon', 'beonj', 'beonh', 'beod', 'beol', 'beolg', 'beolm', 'beolb', 'beols', 'beolt', 'beolp', 'beolh', 'beom', 'beob', 'beobs', 'beos', 'beoss', 'beong', 'beoj', 'beoc', 'beok', 'beot', 'beop', 'beoh', 'be', 'beg', 'begg', 'begs', 'ben', 'benj', 'benh', 'bed', 'bel', 'belg', 'belm', 'belb', 'bels', 'belt', 'belp', 'belh', 'bem', 'beb', 'bebs', 'bes', 'bess', 'beng', 'bej', 'bec', 'bek', 'bet', 'bep', 'beh', 'byeo', 'byeog', 'byeogg', 'byeogs', 'byeon', 'byeonj', 'byeonh', 'byeod', 'byeol', 'byeolg', 'byeolm', 'byeolb', 'byeols', 'byeolt', 'byeolp', 'byeolh', 'byeom', 'byeob', 'byeobs', 'byeos', 'byeoss', 'byeong', 'byeoj', 'byeoc', 'byeok', 'byeot', 'byeop', 'byeoh', 'bye', 'byeg', 'byegg', 'byegs', 'byen', 'byenj', 'byenh', 'byed', 'byel', 'byelg', 'byelm', 'byelb', 'byels', 'byelt', 'byelp', 'byelh', 'byem', 'byeb', 'byebs', 'byes', 'byess', 'byeng', 'byej', 'byec', 'byek', 'byet', 'byep', 'byeh', 'bo', 'bog', 'bogg', 'bogs', 'bon', 'bonj', 'bonh', 'bod', 'bol', 'bolg', 'bolm', 'bolb']

Documentation des variables

◆ return

return[ 'mil', 'milg', 'milm', 'milb', 'mils', 'milt', 'milp', 'milh', 'mim', 'mib', 'mibs', 'mis', 'miss', 'ming', 'mij', 'mic', 'mik', 'mit', 'mip', 'mih', 'ba', 'bag', 'bagg', 'bags', 'ban', 'banj', 'banh', 'bad', 'bal', 'balg', 'balm', 'balb', 'bals', 'balt', 'balp', 'balh', 'bam', 'bab', 'babs', 'bas', 'bass', 'bang', 'baj', 'bac', 'bak', 'bat', 'bap', 'bah', 'bae', 'baeg', 'baegg', 'baegs', 'baen', 'baenj', 'baenh', 'baed', 'bael', 'baelg', 'baelm', 'baelb', 'baels', 'baelt', 'baelp', 'baelh', 'baem', 'baeb', 'baebs', 'baes', 'baess', 'baeng', 'baej', 'baec', 'baek', 'baet', 'baep', 'baeh', 'bya', 'byag', 'byagg', 'byags', 'byan', 'byanj', 'byanh', 'byad', 'byal', 'byalg', 'byalm', 'byalb', 'byals', 'byalt', 'byalp', 'byalh', 'byam', 'byab', 'byabs', 'byas', 'byass', 'byang', 'byaj', 'byac', 'byak', 'byat', 'byap', 'byah', 'byae', 'byaeg', 'byaegg', 'byaegs', 'byaen', 'byaenj', 'byaenh', 'byaed', 'byael', 'byaelg', 'byaelm', 'byaelb', 'byaels', 'byaelt', 'byaelp', 'byaelh', 'byaem', 'byaeb', 'byaebs', 'byaes', 'byaess', 'byaeng', 'byaej', 'byaec', 'byaek', 'byaet', 'byaep', 'byaeh', 'beo', 'beog', 'beogg', 'beogs', 'beon', 'beonj', 'beonh', 'beod', 'beol', 'beolg', 'beolm', 'beolb', 'beols', 'beolt', 'beolp', 'beolh', 'beom', 'beob', 'beobs', 'beos', 'beoss', 'beong', 'beoj', 'beoc', 'beok', 'beot', 'beop', 'beoh', 'be', 'beg', 'begg', 'begs', 'ben', 'benj', 'benh', 'bed', 'bel', 'belg', 'belm', 'belb', 'bels', 'belt', 'belp', 'belh', 'bem', 'beb', 'bebs', 'bes', 'bess', 'beng', 'bej', 'bec', 'bek', 'bet', 'bep', 'beh', 'byeo', 'byeog', 'byeogg', 'byeogs', 'byeon', 'byeonj', 'byeonh', 'byeod', 'byeol', 'byeolg', 'byeolm', 'byeolb', 'byeols', 'byeolt', 'byeolp', 'byeolh', 'byeom', 'byeob', 'byeobs', 'byeos', 'byeoss', 'byeong', 'byeoj', 'byeoc', 'byeok', 'byeot', 'byeop', 'byeoh', 'bye', 'byeg', 'byegg', 'byegs', 'byen', 'byenj', 'byenh', 'byed', 'byel', 'byelg', 'byelm', 'byelb', 'byels', 'byelt', 'byelp', 'byelh', 'byem', 'byeb', 'byebs', 'byes', 'byess', 'byeng', 'byej', 'byec', 'byek', 'byet', 'byep', 'byeh', 'bo', 'bog', 'bogg', 'bogs', 'bon', 'bonj', 'bonh', 'bod', 'bol', 'bolg', 'bolm', 'bolb']


Joomla CMS: Référence du fichier UsersHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier UsersHelper.php

Structures de données

class UsersHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Helper


Joomla CMS: Référence du fichier P2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core32/Curve25519/Ge/P2.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Ge_P2


Joomla CMS: Référence du fichier plugins.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • plugins
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/plugins/plugins.php

Structures de données

class PlgWebservicesPlugins

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x069.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x069.php

Variables

return ['Wan ', 'Guo ', 'Lu ', 'Hao ', 'Jie ', 'Yi ', 'Chou ', 'Ju ', 'Ju ', 'Cheng ', 'Zuo ', 'Liang ', 'Qiang ', 'Zhi ', 'Zhui ', 'Ya ', 'Ju ', 'Bei ', 'Jiao ', 'Zhuo ', 'Zi ', 'Bin ', 'Peng ', 'Ding ', 'Chu ', 'Chang ', 'Kunugi ', 'Momiji ', 'Jian ', 'Gui ', 'Xi ', 'Du ', 'Qian ', 'Kunugi ', 'Soko ', 'Shide ', 'Luo ', 'Zhi ', 'Ken ', 'Myeng ', 'Tafu ', '[?] ', 'Peng ', 'Zhan ', '[?] ', 'Tuo ', 'Sen ', 'Duo ', 'Ye ', 'Fou ', 'Wei ', 'Wei ', 'Duan ', 'Jia ', 'Zong ', 'Jian ', 'Yi ', 'Shen ', 'Xi ', 'Yan ', 'Yan ', 'Chuan ', 'Zhan ', 'Chun ', 'Yu ', 'He ', 'Zha ', 'Wo ', 'Pian ', 'Bi ', 'Yao ', 'Huo ', 'Xu ', 'Ruo ', 'Yang ', 'La ', 'Yan ', 'Ben ', 'Hun ', 'Kui ', 'Jie ', 'Kui ', 'Si ', 'Feng ', 'Xie ', 'Tuo ', 'Zhi ', 'Jian ', 'Mu ', 'Mao ', 'Chu ', 'Hu ', 'Hu ', 'Lian ', 'Leng ', 'Ting ', 'Nan ', 'Yu ', 'You ', 'Mei ', 'Song ', 'Xuan ', 'Xuan ', 'Ying ', 'Zhen ', 'Pian ', 'Ye ', 'Ji ', 'Jie ', 'Ye ', 'Chu ', 'Shun ', 'Yu ', 'Cou ', 'Wei ', 'Mei ', 'Di ', 'Ji ', 'Jie ', 'Kai ', 'Qiu ', 'Ying ', 'Rou ', 'Heng ', 'Lou ', 'Le ', 'Hazou ', 'Katsura ', 'Pin ', 'Muro ', 'Gai ', 'Tan ', 'Lan ', 'Yun ', 'Yu ', 'Chen ', 'Lu ', 'Ju ', 'Sakaki ', '[?] ', 'Pi ', 'Xie ', 'Jia ', 'Yi ', 'Zhan ', 'Fu ', 'Nai ', 'Mi ', 'Lang ', 'Rong ', 'Gu ', 'Jian ', 'Ju ', 'Ta ', 'Yao ', 'Zhen ', 'Bang ', 'Sha ', 'Yuan ', 'Zi ', 'Ming ', 'Su ', 'Jia ', 'Yao ', 'Jie ', 'Huang ', 'Gan ', 'Fei ', 'Zha ', 'Qian ', 'Ma ', 'Sun ', 'Yuan ', 'Xie ', 'Rong ', 'Shi ', 'Zhi ', 'Cui ', 'Yun ', 'Ting ', 'Liu ', 'Rong ', 'Tang ', 'Que ', 'Zhai ', 'Si ', 'Sheng ', 'Ta ', 'Ke ', 'Xi ', 'Gu ', 'Qi ', 'Kao ', 'Gao ', 'Sun ', 'Pan ', 'Tao ', 'Ge ', 'Xun ', 'Dian ', 'Nou ', 'Ji ', 'Shuo ', 'Gou ', 'Chui ', 'Qiang ', 'Cha ', 'Qian ', 'Huai ', 'Mei ', 'Xu ', 'Gang ', 'Gao ', 'Zhuo ', 'Tuo ', 'Hashi ', 'Yang ', 'Dian ', 'Jia ', 'Jian ', 'Zui ', 'Kashi ', 'Ori ', 'Bin ', 'Zhu ', '[?] ', 'Xi ', 'Qi ', 'Lian ', 'Hui ', 'Yong ', 'Qian ', 'Guo ', 'Gai ', 'Gai ', 'Tuan ', 'Hua ', 'Cu ', 'Sen ', 'Cui ', 'Beng ', 'You ', 'Hu ', 'Jiang ', 'Hu ', 'Huan ', 'Kui ', 'Yi ', 'Nie ', 'Gao ', 'Kang ', 'Gui ', 'Gui ', 'Cao ', 'Man ', 'Jin ']

Documentation des variables

◆ return

return[ 'Wan ', 'Guo ', 'Lu ', 'Hao ', 'Jie ', 'Yi ', 'Chou ', 'Ju ', 'Ju ', 'Cheng ', 'Zuo ', 'Liang ', 'Qiang ', 'Zhi ', 'Zhui ', 'Ya ', 'Ju ', 'Bei ', 'Jiao ', 'Zhuo ', 'Zi ', 'Bin ', 'Peng ', 'Ding ', 'Chu ', 'Chang ', 'Kunugi ', 'Momiji ', 'Jian ', 'Gui ', 'Xi ', 'Du ', 'Qian ', 'Kunugi ', 'Soko ', 'Shide ', 'Luo ', 'Zhi ', 'Ken ', 'Myeng ', 'Tafu ', '[?] ', 'Peng ', 'Zhan ', '[?] ', 'Tuo ', 'Sen ', 'Duo ', 'Ye ', 'Fou ', 'Wei ', 'Wei ', 'Duan ', 'Jia ', 'Zong ', 'Jian ', 'Yi ', 'Shen ', 'Xi ', 'Yan ', 'Yan ', 'Chuan ', 'Zhan ', 'Chun ', 'Yu ', 'He ', 'Zha ', 'Wo ', 'Pian ', 'Bi ', 'Yao ', 'Huo ', 'Xu ', 'Ruo ', 'Yang ', 'La ', 'Yan ', 'Ben ', 'Hun ', 'Kui ', 'Jie ', 'Kui ', 'Si ', 'Feng ', 'Xie ', 'Tuo ', 'Zhi ', 'Jian ', 'Mu ', 'Mao ', 'Chu ', 'Hu ', 'Hu ', 'Lian ', 'Leng ', 'Ting ', 'Nan ', 'Yu ', 'You ', 'Mei ', 'Song ', 'Xuan ', 'Xuan ', 'Ying ', 'Zhen ', 'Pian ', 'Ye ', 'Ji ', 'Jie ', 'Ye ', 'Chu ', 'Shun ', 'Yu ', 'Cou ', 'Wei ', 'Mei ', 'Di ', 'Ji ', 'Jie ', 'Kai ', 'Qiu ', 'Ying ', 'Rou ', 'Heng ', 'Lou ', 'Le ', 'Hazou ', 'Katsura ', 'Pin ', 'Muro ', 'Gai ', 'Tan ', 'Lan ', 'Yun ', 'Yu ', 'Chen ', 'Lu ', 'Ju ', 'Sakaki ', '[?] ', 'Pi ', 'Xie ', 'Jia ', 'Yi ', 'Zhan ', 'Fu ', 'Nai ', 'Mi ', 'Lang ', 'Rong ', 'Gu ', 'Jian ', 'Ju ', 'Ta ', 'Yao ', 'Zhen ', 'Bang ', 'Sha ', 'Yuan ', 'Zi ', 'Ming ', 'Su ', 'Jia ', 'Yao ', 'Jie ', 'Huang ', 'Gan ', 'Fei ', 'Zha ', 'Qian ', 'Ma ', 'Sun ', 'Yuan ', 'Xie ', 'Rong ', 'Shi ', 'Zhi ', 'Cui ', 'Yun ', 'Ting ', 'Liu ', 'Rong ', 'Tang ', 'Que ', 'Zhai ', 'Si ', 'Sheng ', 'Ta ', 'Ke ', 'Xi ', 'Gu ', 'Qi ', 'Kao ', 'Gao ', 'Sun ', 'Pan ', 'Tao ', 'Ge ', 'Xun ', 'Dian ', 'Nou ', 'Ji ', 'Shuo ', 'Gou ', 'Chui ', 'Qiang ', 'Cha ', 'Qian ', 'Huai ', 'Mei ', 'Xu ', 'Gang ', 'Gao ', 'Zhuo ', 'Tuo ', 'Hashi ', 'Yang ', 'Dian ', 'Jia ', 'Jian ', 'Zui ', 'Kashi ', 'Ori ', 'Bin ', 'Zhu ', '[?] ', 'Xi ', 'Qi ', 'Lian ', 'Hui ', 'Yong ', 'Qian ', 'Guo ', 'Gai ', 'Gai ', 'Tuan ', 'Hua ', 'Cu ', 'Sen ', 'Cui ', 'Beng ', 'You ', 'Hu ', 'Jiang ', 'Hu ', 'Huan ', 'Kui ', 'Yi ', 'Nie ', 'Gao ', 'Kang ', 'Gui ', 'Gui ', 'Cao ', 'Man ', 'Jin ']


Joomla CMS: Référence du fichier vote.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • vote
Structures de données | Espaces de nommage
Référence du fichier vote.php

Structures de données

class PlgContentVote

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier utf8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Variables
Référence du fichier utf8.php

Espaces de nommage

utf8

Variables

if(!defined('UTF8')) if(extension_loaded('mbstring')) $UTF8_ar = array()
if (!defined( 'UTF8_CORE'))

Documentation des variables

◆ $UTF8_ar

if (!defined( 'UTF8')) if (extension_loaded( 'mbstring')) $UTF8_ar = array()

Put the current directory in this constant If string overloading is active, it will break many of the native implementations. mbstring.func_overload must be set to 0, 1 or 4 in php.ini (string overloading disabled). Also need to check we have the correct internal mbstring encoding Check whether PCRE has been compiled with UTF-8 support

◆ if

if(!defined('UTF8_CORE'))

Load the smartest implementations of utf8_strpos, utf8_strrpos and utf8_substr Load the native implementation of utf8_substr_replace


Joomla CMS: Référence du fichier WebAssetExceptionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • Exception
Structures de données | Espaces de nommage
Référence du fichier WebAssetExceptionInterface.php

Structures de données

interface WebAssetExceptionInterface

Espaces de nommage

Joomla\CMS\WebAsset\Exception


Joomla CMS: Référence du fichier PaginationObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pagination
Structures de données | Espaces de nommage
Référence du fichier PaginationObject.php

Structures de données

class PaginationObject

Espaces de nommage

Joomla\CMS\Pagination


Joomla CMS: Référence du fichier Path.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/Path.php

Structures de données

class Path

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier submenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • sidebars
Espaces de nommage | Variables
Référence du fichier submenu.php

Espaces de nommage

Joomla\Site

Variables

if( $displayData->displayMenu)( $displayData->list as $item)(isset($item[2]) && $item[2]==1) if($displayData->hide) else
else __pad11__
endif
endforeach
foreach ( $displayData->filters as $filter)

Documentation des variables

◆ __pad11__

else __pad11__

◆ else

if($displayData->displayMenu) ($displayData->list as $item) (isset( $item[2]) &&$item[2]==1) if ( $displayData->hide) else

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($displayData->filters as $filter)


Joomla CMS: Référence du fichier XChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/XChaCha20.php

Structures de données

class ParagonIE_Sodium_Core32_XChaCha20


Joomla CMS: Référence du fichier UniversalString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier UniversalString.php

Structures de données

class UniversalString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier x1d5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x1d5.php

Variables

return [0=> 'w', 'x', 'y', 'z', 4=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 30=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 56=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 82=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 108=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 134=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 160=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 186=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 212=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 238=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z',]

Documentation des variables

◆ return

return[ 0=> 'w', 'x', 'y', 'z', 4=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 30=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 56=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 82=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 108=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 134=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 160=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 186=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 212=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 238=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z',]


Joomla CMS: Référence du fichier TemplateModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_mails/src/Model/TemplateModel.php

Structures de données

class TemplateModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Model


Joomla CMS: Référence du fichier PSS.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier PSS.php

Structures de données

class PSS

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier UTF8MB4SupportInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier UTF8MB4SupportInterface.php

Structures de données

interface UTF8MB4SupportInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier Utils.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier Utils.php

Structures de données

class Utils

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier PluginsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_plugins
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_plugins/src/Controller/PluginsController.php

Structures de données

class PluginsController

Espaces de nommage

Joomla\API
Joomla\Component\Plugins\Api\Controller


Joomla CMS: Référence du fichier Prime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier Prime.php

Structures de données

class Prime

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves
Prime


Joomla CMS: Référence du fichier UnsupportedStorageException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedStorageException.php

Structures de données

class UnsupportedStorageException

Espaces de nommage

Joomla\CMS\Session\Exception


Joomla CMS: Référence du fichier x033.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x033.php

Variables

return ['apartment', 'alpha', 'ampere', 'are', 'inning', 'inch', 'won', 'escudo', 'acre', 'ounce', 'ohm', 'kai-ri', 'carat', 'calorie', 'gallon', 'gamma', 'giga', 'guinea', 'curie', 'guilder', 'kilo', 'kilogram', 'kilometer', 'kilowatt', 'gram', 'gram ton', 'cruzeiro', 'krone', 'case', 'koruna', 'co-op', 'cycle', 'centime', 'shilling', 'centi', 'cent', 'dozen', 'desi', 'dollar', 'ton', 'nano', 'knot', 'heights', 'percent', 'parts', 'barrel', 'piaster', 'picul', 'pico', 'building', 'farad', 'feet', 'bushel', 'franc', 'hectare', 'peso', 'pfennig', 'hertz', 'pence', 'page', 'beta', 'point', 'volt', 'hon', 'pound', 'hall', 'horn', 'micro', 'mile', 'mach', 'mark', 'mansion', 'micron', 'milli', 'millibar', 'mega', 'megaton', 'meter', 'yard', 'yard', 'yuan', 'liter', 'lira', 'rupee', 'ruble', 'rem', 'roentgen', 'watt', '0h', '1h', '2h', '3h', '4h', '5h', '6h', '7h', '8h', '9h', '10h', '11h', '12h', '13h', '14h', '15h', '16h', '17h', '18h', '19h', '20h', '21h', '22h', '23h', '24h', 'hPa', 'da', 'AU', 'bar', 'oV', 'pc', 'dm', 'dm^2', 'dm^3', 'IU', 'Heisei', 'Syouwa', 'Taisyou', 'Meiji', 'Inc.', 'pA', 'nA', 'microamp', 'mA', 'kA', 'kB', 'MB', 'GB', 'cal', 'kcal', 'pF', 'nF', 'microFarad', 'microgram', 'mg', 'kg', 'Hz', 'kHz', 'MHz', 'GHz', 'THz', 'microliter', 'ml', 'dl', 'kl', 'fm', 'nm', 'micrometer', 'mm', 'cm', 'km', 'mm^2', 'cm^2', 'm^2', 'km^2', 'mm^3', 'cm^3', 'm^3', 'km^3', 'm/s', 'm/s^2', 'Pa', 'kPa', 'MPa', 'GPa', 'rad', 'rad/s', 'rad/s^2', 'ps', 'ns', 'microsecond', 'ms', 'pV', 'nV', 'microvolt', 'mV', 'kV', 'MV', 'pW', 'nW', 'microwatt', 'mW', 'kW', 'MW', 'kOhm', 'MOhm', 'a.m.', 'Bq', 'cc', 'cd', 'C/kg', 'Co.', 'dB', 'Gy', 'ha', 'HP', 'in', 'K.K.', 'KM', 'kt', 'lm', 'ln', 'log', 'lx', 'mb', 'mil', 'mol', 'pH', 'p.m.', 'PPM', 'PR', 'sr', 'Sv', 'Wb', '[?]', '[?]', '1d', '2d', '3d', '4d', '5d', '6d', '7d', '8d', '9d', '10d', '11d', '12d', '13d', '14d', '15d', '16d', '17d', '18d', '19d', '20d', '21d', '22d', '23d', '24d', '25d', '26d', '27d', '28d', '29d', '30d', '31d', 'gal']

Documentation des variables

◆ return

return[ 'apartment', 'alpha', 'ampere', 'are', 'inning', 'inch', 'won', 'escudo', 'acre', 'ounce', 'ohm', 'kai-ri', 'carat', 'calorie', 'gallon', 'gamma', 'giga', 'guinea', 'curie', 'guilder', 'kilo', 'kilogram', 'kilometer', 'kilowatt', 'gram', 'gram ton', 'cruzeiro', 'krone', 'case', 'koruna', 'co-op', 'cycle', 'centime', 'shilling', 'centi', 'cent', 'dozen', 'desi', 'dollar', 'ton', 'nano', 'knot', 'heights', 'percent', 'parts', 'barrel', 'piaster', 'picul', 'pico', 'building', 'farad', 'feet', 'bushel', 'franc', 'hectare', 'peso', 'pfennig', 'hertz', 'pence', 'page', 'beta', 'point', 'volt', 'hon', 'pound', 'hall', 'horn', 'micro', 'mile', 'mach', 'mark', 'mansion', 'micron', 'milli', 'millibar', 'mega', 'megaton', 'meter', 'yard', 'yard', 'yuan', 'liter', 'lira', 'rupee', 'ruble', 'rem', 'roentgen', 'watt', '0h', '1h', '2h', '3h', '4h', '5h', '6h', '7h', '8h', '9h', '10h', '11h', '12h', '13h', '14h', '15h', '16h', '17h', '18h', '19h', '20h', '21h', '22h', '23h', '24h', 'hPa', 'da', 'AU', 'bar', 'oV', 'pc', 'dm', 'dm^2', 'dm^3', 'IU', 'Heisei', 'Syouwa', 'Taisyou', 'Meiji', 'Inc.', 'pA', 'nA', 'microamp', 'mA', 'kA', 'kB', 'MB', 'GB', 'cal', 'kcal', 'pF', 'nF', 'microFarad', 'microgram', 'mg', 'kg', 'Hz', 'kHz', 'MHz', 'GHz', 'THz', 'microliter', 'ml', 'dl', 'kl', 'fm', 'nm', 'micrometer', 'mm', 'cm', 'km', 'mm^2', 'cm^2', 'm^2', 'km^2', 'mm^3', 'cm^3', 'm^3', 'km^3', 'm/s', 'm/s^2', 'Pa', 'kPa', 'MPa', 'GPa', 'rad', 'rad/s', 'rad/s^2', 'ps', 'ns', 'microsecond', 'ms', 'pV', 'nV', 'microvolt', 'mV', 'kV', 'MV', 'pW', 'nW', 'microwatt', 'mW', 'kW', 'MW', 'kOhm', 'MOhm', 'a.m.', 'Bq', 'cc', 'cd', 'C/kg', 'Co.', 'dB', 'Gy', 'ha', 'HP', 'in', 'K.K.', 'KM', 'kt', 'lm', 'ln', 'log', 'lx', 'mb', 'mil', 'mol', 'pH', 'p.m.', 'PPM', 'PR', 'sr', 'Sv', 'Wb', '[?]', '[?]', '1d', '2d', '3d', '4d', '5d', '6d', '7d', '8d', '9d', '10d', '11d', '12d', '13d', '14d', '15d', '16d', '17d', '18d', '19d', '20d', '21d', '22d', '23d', '24d', '25d', '26d', '27d', '28d', '29d', '30d', '31d', 'gal']


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
Structures de données | Espaces de nommage
Référence du fichier src/Access/Rules.php

Structures de données

class Rules

Espaces de nommage

Joomla\CMS\Access


Joomla CMS: Référence du fichier ristretto255.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Référence du fichier ristretto255.php


Joomla CMS: Référence du fichier RSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
  • Util
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/Util/RSA.php

Structures de données

class RSA

Espaces de nommage

Jose\Component\Signature\Algorithm\Util


Joomla CMS: Référence du fichier Signature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier lcobucci/jwt/src/Signature.php

Structures de données

class Signature

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier PKCS8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/PKCS8.php

Structures de données

class PKCS8

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier RSAPKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier RSAPKCS1.php

Structures de données

class RSAPKCS1

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Request.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier nyholm/psr7/src/Request.php

Structures de données

class Request

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier styles.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • codemirror
  • layouts
  • editors
  • codemirror
Espaces de nommage | Variables
Référence du fichier styles.php

Espaces de nommage

Joomla\Plugin

Variables

$params = $displayData->params
$fontFamily = $displayData->fontFamily ?? 'monospace'
$fontSize = $params->get('fontSize', 13) . 'px;'
$lineHeight = $params->get('lineHeight', 1.2) . 'em;'
$color = $params->get('activeLineColor', '#a4c2eb')
$r = hexdec($color[1] . $color[2])
$g = hexdec($color[3] . $color[4])
$b = hexdec($color[5] . $color[6])
$activeLineColor = 'rgba(' . $r . ', ' . $g . ', ' . $b . ', .5)'
$highlightMatchColor = 'rgba(' . $r . ', ' . $g . ', ' . $b . ', .5)'
$wa = Factory::getApplication()->getDocument()->getWebAssetManager()

Documentation des variables

◆ $activeLineColor

$activeLineColor = 'rgba(' . $r . ', ' . $g . ', ' . $b . ', .5)'

◆ $b

$b = hexdec($color[5] . $color[6])

Référencé par LanguageField\_sortLanguages(), GmpCalculator\add(), BcMathCalculator\add(), NativeCalculator\add(), BigIntegerBcmath\add(), BigIntegerGmp\add(), Ed448\addPoint(), Ed25519\addPoint(), GmpCalculator\and(), Calculator\and(), Encoding\binToHex(), Calculator\bitwise(), ExceptionCaster\castThrowingCasterException(), ParagonIE_Sodium_Core_Curve25519\cmov(), ParagonIE_Sodium_Core32_Curve25519\cmov(), Calculator\cmp(), TimeDataCollector\collect(), ProfileCollector\collect(), SFTP\comparator(), AcceptMatch\compare(), Integer\compare(), BigDecimal\compareTo(), Color\convertHexColorToAnsi(), Color\degradeHexColorToAnsi(), GmpCalculator\divQ(), BcMathCalculator\divQ(), NativeCalculator\divQ(), GmpCalculator\divQR(), BcMathCalculator\divQR(), NativeCalculator\divQR(), GmpCalculator\divR(), BcMathCalculator\divR(), NativeCalculator\divR(), Calculator\divRound(), NativeCalculator\doAdd(), NativeCalculator\doCmp(), NativeCalculator\doDiv(), NativeCalculator\doMul(), NativeCalculator\doSub(), Montgomery\doubleAndAddPoint(), Ed448\doublePoint(), Ed25519\doublePoint(), phpseclib3\Crypt\EC\Formats\Keys\encodeParameters(), XML\encodeXMLParameters(), ParagonIE_Sodium_Core_Curve25519\equal(), ParagonIE_Sodium_Core32_Curve25519\equal(), BigDecimal\exactlyDividedBy(), BCMath\extendedGCD(), Engine\extendedGCDHelper(), ParagonIE_Sodium_Core_Ristretto255\fe_cneg(), ParagonIE_Sodium_Core_X25519\fe_cswap(), ParagonIE_Sodium_Core_Curve25519\fe_normalize(), FileStorage\find(), RedisStorage\find(), ParagonIE_Sodium_Core32_BLAKE2b\G(), ParagonIE_Sodium_Core_BLAKE2b\G(), GmpCalculator\gcd(), Calculator\gcd(), Calculator\gcdExtended(), ParagonIE_Sodium_Core_Curve25519\ge_cmov8_cached(), ParagonIE_Sodium_Core_Curve25519\ge_cmov_cached(), ParagonIE_Sodium_Core32_Curve25519\ge_select(), TemplateModel\getCoreList(), LoginHelper\getLanguageList(), LanguagesModel\getLanguages(), MessagesCollector\getMessages(), AliastagField\getOptions(), LanguageField\getOptions(), TypeField\getOptions(), SubfieldsField\getOptions(), AbstractNegotiator\getOrderedElements(), CronExpression\getRunDate(), Color\getSaturation(), Hash\hash(), Calculator\init(), ParagonIE_Sodium_Core32_Int64\isGreaterThan(), ParagonIE_Sodium_Core32_Int32\isGreaterThan(), ParagonIE_Sodium_Core32_Int64\isLessThanInt(), ParagonIE_Sodium_Core32_Int32\isLessThanInt(), XML\loadCurveByParam(), XML\loadCurveByParamRFC4050(), ConfigPostProcessor\merge(), BigDecimal\minus(), Calculator\mod(), BigIntegerBcmath\modulus(), BigIntegerGmp\modulus(), BcMathCalculator\mul(), GmpCalculator\mul(), NativeCalculator\mul(), ParagonIE_Sodium_Core32_Int32\mulInt32Fast(), ParagonIE_Sodium_Core32_Int64\mulInt64Fast(), ParagonIE_Sodium_Core32_Int32\mulIntFast(), ParagonIE_Sodium_Core32_Int64\mulIntFast(), BigIntegerBcmath\multiply(), BigIntegerGmp\multiply(), Montgomery\multiplyPoint(), GmpCalculator\or(), Calculator\or(), ParagonIE_Sodium_Core32_Int64\orInt64(), NativeCalculator\pad(), SymmetricKey\pkcs12helper(), BigDecimal\plus(), ChaCha20\quarterRound(), Salsa20\quarterRound(), ParagonIE_Sodium_Core_Curve25519\sc25519_mul(), ParagonIE_Sodium_Core_Ed25519\scalar_add(), BigDecimal\scaleValues(), Hash\setHash(), Hash\sha512(), ParagonIE_Sodium_Core32_SipHash\sipHash24(), ParagonIE_Sodium_Core_SipHash\sipHash24(), AggregatedCollector\sort(), JWKSet\sortKeys(), ArrayHelper\sortObjects(), Integer\squareRoot(), Italian\step0(), Spanish\step0(), HtmlDumper\style(), BcMathCalculator\sub(), GmpCalculator\sub(), BigIntegerBcmath\subtract(), BigIntegerGmp\subtract(), Strings\switchEndianness(), AbstractString\toByteString(), BigIntegerGmp\toPower(), BigIntegerBcmath\toPower(), Hash\uhash(), ParagonIE_Sodium_Core_Util\verify_16(), ParagonIE_Sodium_Core_Util\verify_32(), AbstractString\wordwrap(), GmpCalculator\xor(), Calculator\xor(), ParagonIE_Sodium_Core32_Int32\xorInt32(), ParagonIE_Sodium_Core32_Int64\xorInt64(), et ParagonIE_Sodium_Core_Util\xorStrings().

◆ $color

$color = $params->get('activeLineColor', '#a4c2eb')

◆ $fontFamily

$fontFamily = $displayData->fontFamily ?? 'monospace'

◆ $fontSize

$fontSize = $params->get('fontSize', 13) . 'px;'

◆ $g

$g = hexdec($color[3] . $color[4])

Référencé par BinaryField\__construct(), Binary\addPoint(), Ed448\addPoint(), Ed25519\addPoint(), Color\convertHexColorToAnsi(), Color\degradeHexColorToAnsi(), Ed25519\doublePoint(), GMP\extendedGCD(), ParagonIE_Sodium_Core_X25519\fe_cswap(), ParagonIE_Sodium_Core_Curve25519\fe_mul(), ParagonIE_Sodium_Core_Curve25519\fe_normalize(), ParagonIE_Sodium_Core_Curve25519\fe_sub(), ParagonIE_Sodium_Core32_Curve25519\fe_sub(), Color\getSaturation(), PlgSystemUpdatenotification\getSuperUsers(), SSH2\key_exchange(), Calculator\modInverse(), Engine\rootInner(), et Hash\sha512().

◆ $highlightMatchColor

$highlightMatchColor = 'rgba(' . $r . ', ' . $g . ', ' . $b . ', .5)'

◆ $lineHeight

$lineHeight = $params->get('lineHeight', 1.2) . 'em;'

◆ $params

$params = $displayData->params

◆ $r

$r = hexdec($color[1] . $color[2])

Référencé par ClassStub\__construct(), BinaryField\__construct(), AdminController\__construct(), BaseDatabaseModel\__construct(), FormController\__construct(), ApiController\__construct(), BaseController\__construct(), LazyString\__toString(), QuestionHelper\autocomplete(), PrivateKey\blind(), AbstractCloner\castObject(), GMP\compare(), ParagonIE_Sodium_Core32_BLAKE2b\compress(), ParagonIE_Sodium_Core_BLAKE2b\compress(), Color\convertHexColorToAnsi(), Blowfish\decryptBlock(), Color\degradeHexColorToAnsi(), RouterView\detachRule(), Router\detachRule(), BigInteger\divide(), PHP\divideHelper(), GmpCalculator\divQR(), BcMathCalculator\divQR(), NativeCalculator\divQR(), Calculator\divRound(), VarCloner\doClone(), NativeCalculator\doDiv(), Data\dumpItem(), Blowfish\encryptBlock(), HtmlDumper\enterHash(), PrivateKey\exponentiate(), PKCS8\extractEncryptionAlgorithm(), Bootup\filterRequestInputs(), ParagonIE_Sodium_Core32_BLAKE2b\G(), ParagonIE_Sodium_Core_BLAKE2b\G(), GMP\gcd(), ParagonIE_Sodium_Core_Curve25519\ge_add(), ParagonIE_Sodium_Core32_Curve25519\ge_add(), ParagonIE_Sodium_Core_Curve25519\ge_madd(), ParagonIE_Sodium_Core32_Curve25519\ge_madd(), ParagonIE_Sodium_Core_Curve25519\ge_msub(), ParagonIE_Sodium_Core32_Curve25519\ge_msub(), ParagonIE_Sodium_Core_Curve25519\ge_p1p1_to_p2(), ParagonIE_Sodium_Core32_Curve25519\ge_p1p1_to_p2(), ParagonIE_Sodium_Core_Curve25519\ge_p1p1_to_p3(), ParagonIE_Sodium_Core32_Curve25519\ge_p1p1_to_p3(), ParagonIE_Sodium_Core_Curve25519\ge_p2_dbl(), ParagonIE_Sodium_Core32_Curve25519\ge_p2_dbl(), ParagonIE_Sodium_Core_Curve25519\ge_sub(), ParagonIE_Sodium_Core32_Curve25519\ge_sub(), LinkStub\getComposerRoot(), Command\getDefaultDescription(), Command\getDefaultName(), AbstractCommand\getDefaultName(), Integer\getEncodedValue(), BaseModel\getName(), RouterView\getName(), BaseController\getName(), ArgsStub\getParameters(), LazyString\getPrettyName(), Color\getSaturation(), Prime\jacobianAddPoint(), Prime\jacobianAddPointMixedX(), Prime\jacobianAddPointMixedXY(), Integer\modInverse(), BCMath\mul(), KoblitzPrime\multiplyAddPoints(), Base\multiplyAddPoints(), Base\multiplyPoint(), Normalizer\normalize(), SysinfoModel\parsePhpInfo(), SymmetricKey\poly1305(), Integer\polynomialDivide(), BCMath\pow(), AddConsoleCommandPass\process(), DES\processBlock(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), ParagonIE_Sodium_Compat\ristretto255_from_hash(), ParagonIE_Sodium_Compat\ristretto255_is_valid_point(), SSH2\save(), ParagonIE_Sodium_Core_Ed25519\scalar_random(), BCMath\scan1divide(), GMP\scan1divide(), BigInteger\scan1divide(), PHP\scan1divide(), Command\setCode(), ConsoleErrorEvent\setExitCode(), ApplicationErrorEvent\setExitCode(), CommandErrorEvent\setExitCode(), DES\setupInlineCrypt(), Blowfish\setupKey(), Rijndael\setupKey(), DES\setupKey(), Hash\sha3_32(), Hash\sha3_64(), PrivateKey\sign(), X509\sign(), Integer\squareRoot(), Random\string(), HtmlDumper\style(), Strings\switchEndianness(), Engine\testPrimality(), BCMath\testSmallPrimes(), PHP\testSmallPrimes(), et PublicKey\verify().

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier UnknownTypeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnknownTypeException.php

Structures de données

class UnknownTypeException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier PS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/PS512.php

Structures de données

class PS512

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier RequestModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Model/RequestModel.php

Structures de données

class RequestModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier patterns.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Variables
Référence du fichier patterns.php

Espaces de nommage

utf8

Variables

$UTF8_VALID
$UTF8_MATCH
$UTF8_BAD

Documentation des variables

◆ $UTF8_BAD

$UTF8_BAD
Valeur initiale :
=
'([\x00-\x7F]'. # ASCII (including control chars)
'|[\xC2-\xDF][\x80-\xBF]'. # non-overlong 2-byte
'|\xE0[\xA0-\xBF][\x80-\xBF]'. # excluding overlongs
'|[\xE1-\xEC\xEE\xEF][\x80-\xBF]{2}'. # straight 3-byte
'|\xED[\x80-\x9F][\x80-\xBF]'. # excluding surrogates
'|\xF0[\x90-\xBF][\x80-\xBF]{2}'. # planes 1-3
'|[\xF1-\xF3][\x80-\xBF]{3}'. # planes 4-15
'|\xF4[\x80-\x8F][\x80-\xBF]{2}'. # plane 16
'|(.{1}))'

Référencé par utf8_bad_find(), utf8_bad_findall(), utf8_bad_replace(), et utf8_bad_strip().

◆ $UTF8_MATCH

$UTF8_MATCH
Valeur initiale :
=
'([\x00-\x7F])'. # ASCII (including control chars)
'|([\xC2-\xDF][\x80-\xBF])'. # non-overlong 2-byte
'|(\xE0[\xA0-\xBF][\x80-\xBF])'. # excluding overlongs
'|([\xE1-\xEC\xEE\xEF][\x80-\xBF]{2})'. # straight 3-byte
'|(\xED[\x80-\x9F][\x80-\xBF])'. # excluding surrogates
'|(\xF0[\x90-\xBF][\x80-\xBF]{2})'. # planes 1-3
'|([\xF1-\xF3][\x80-\xBF]{3})'. # planes 4-15
'|(\xF4[\x80-\x8F][\x80-\xBF]{2})'

◆ $UTF8_VALID

$UTF8_VALID
Valeur initiale :
= '^('.
'[\x00-\x7F]'. # ASCII (including control chars)
'|[\xC2-\xDF][\x80-\xBF]'. # non-overlong 2-byte
'|\xE0[\xA0-\xBF][\x80-\xBF]'. # excluding overlongs
'|[\xE1-\xEC\xEE\xEF][\x80-\xBF]{2}'. # straight 3-byte
'|\xED[\x80-\x9F][\x80-\xBF]'. # excluding surrogates
'|\xF0[\x90-\xBF][\x80-\xBF]{2}'. # planes 1-3
'|[\xF1-\xF3][\x80-\xBF]{3}'. # planes 4-15
'|\xF4[\x80-\x8F][\x80-\xBF]{2}'. # plane 16
')*$'


Joomla CMS: Référence du fichier radio.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • radio
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/radio.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
$texts = array()
$options = $this->getOptionsFromField($field)
foreach ( $options as $optionValue=> $optionText)

Documentation des variables

◆ $options

$options = $this->getOptionsFromField($field)

◆ $texts

$texts = array()

◆ $value

if ( $value=='') $value = $field->value

◆ foreach

foreach($options as $optionValue=> $optionText)


Joomla CMS: Référence du fichier TagsComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier TagsComponent.php

Structures de données

class TagsComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Extension


Joomla CMS: Référence du fichier UntellableStreamException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UntellableStreamException.php

Structures de données

class UntellableStreamException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier PharInvocationResolver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Resolver
Structures de données | Espaces de nommage
Référence du fichier PharInvocationResolver.php

Structures de données

class PharInvocationResolver

Espaces de nommage

TYPO3\PharStreamWrapper\Resolver


Joomla CMS: Référence du fichier Registry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
Structures de données | Espaces de nommage
Référence du fichier src/HTML/Registry.php

Structures de données

class Registry

Espaces de nommage

Joomla\CMS\HTML


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_finder/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Helper


Joomla CMS: Référence du fichier well.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier well.php

Espaces de nommage

Joomla\Administrator

Variables

$module = $displayData['module']
$params = $displayData['params']
$attribs = $displayData['attribs']
if((string) $module->content==='') $id = $module->id
$user = Factory::getUser()
$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')
$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')
$moduleTag = $params->get('module_tag', 'div')
$bootstrapSize = (int) $params->get('bootstrap_size', 12)
$moduleClass = $bootstrapSize ? 'col-md-' . $bootstrapSize : 'col-md-12'
$headerTag = htmlspecialchars($params->get('header_tag', 'h2'), ENT_QUOTES, 'UTF-8')
$moduleClassSfx = $params->get('moduleclass_sfx', '')
$headerClass = $params->get('header_class') ? ' class="' . htmlspecialchars($params->get('header_class'), ENT_QUOTES, 'UTF-8') . '"' : ''
$headerIcon = $params->get('header_icon') ? '<span class="' . htmlspecialchars($params->get('header_icon'), ENT_QUOTES, 'UTF-8') . '" aria-hidden="true"></span>' : ''
$url = Route::_('index.php?option=com_modules&task=module.edit&id=' . $id . '&return=' . base64_encode($uri))
endif
if ( $canChange)

Documentation des variables

◆ $attribs

$attribs = $displayData['attribs']

◆ $bootstrapSize

$bootstrapSize = (int) $params->get('bootstrap_size', 12)

◆ $canChange

$canChange = $user->authorise('core.edit.state', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')

◆ $canEdit

$canEdit = $user->authorise('core.edit', 'com_modules.module.' . $id) && $user->authorise('core.manage', 'com_modules')

◆ $headerClass

$headerClass = $params->get('header_class') ? ' class="' . htmlspecialchars($params->get('header_class'), ENT_QUOTES, 'UTF-8') . '"' : ''

◆ $headerIcon

$headerIcon = $params->get('header_icon') ? '<span class="' . htmlspecialchars($params->get('header_icon'), ENT_QUOTES, 'UTF-8') . '" aria-hidden="true"></span>' : ''

◆ $headerTag

$headerTag = htmlspecialchars($params->get('header_tag', 'h2'), ENT_QUOTES, 'UTF-8')

◆ $id

if ((string) $module->content==='') $id = $module->id

◆ $module

$module = $displayData['module']

◆ $moduleClass

$moduleClass = $bootstrapSize ? 'col-md-' . $bootstrapSize : 'col-md-12'

◆ $moduleClassSfx

$moduleClassSfx = $params->get('moduleclass_sfx', '')

◆ $moduleTag

$moduleTag = $params->get('module_tag', 'div')

◆ $params

$params = $displayData['params']

◆ $url

$url = Route::_('index.php?option=com_modules&task=module.edit&id=' . $id . '&return=' . base64_encode($uri))

◆ $user

$user = Factory::getUser()

◆ endif

endif

◆ if

if($module->showtitle) ( $canChange )


Joomla CMS: Référence du fichier Signer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier Signer.php

Structures de données

interface Signer

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier TwistedEdwards.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • BaseCurves
Structures de données | Espaces de nommage
Référence du fichier TwistedEdwards.php

Structures de données

class TwistedEdwards

Espaces de nommage

EC
phpseclib3\Crypt\EC\BaseCurves
Prime


Joomla CMS: Référence du fichier TimeRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier TimeRule.php

Structures de données

class TimeRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier User.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier HTML/Helpers/User.php

Structures de données

class User

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Suggestion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Completion
Structures de données | Espaces de nommage
Référence du fichier Suggestion.php

Structures de données

class Suggestion

Espaces de nommage

Symfony\Component\Console\Completion


Joomla CMS: Référence du fichier P3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Ge/P3.php

Structures de données

class P3

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519\Ge


Joomla CMS: Référence du fichier win1252_to_utf8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier win1252_to_utf8.php

Variables

return [0x80=> "\2\2\c", 0x82=> "\2\0\a", 0x83=> "\6\2", 0x84=> "\2\0\e", 0x85=> "\2\0\6", 0x86=> "\2\0\0", 0x87=> "\2\0\1", 0x88=> "\b\6", 0x89=> "\2\0\0", 0x8a=> "\5\0", 0x8b=> "\2\0\9", 0x8c=> "\5\2", 0x8e=> "\5\d", 0x91=> "\2\0\8", 0x92=> "\2\0\9", 0x93=> "\2\0\c", 0x94=> "\2\0\d", 0x95=> "\2\0\2", 0x96=> "\2\0\3", 0x97=> "\2\0\4", 0x98=> "\b\c", 0x99=> "\2\4\2", 0x9a=> "\5\1", 0x9b=> "\2\0\a", 0x9c=> "\5\3", 0x9e=> "\5\e", 0x9f=> "\5\8", 0xa0=> "\2\0", 0xa1=> "\2\1", 0xa2=> "\2\2", 0xa3=> "\2\3", 0xa4=> "\2\4", 0xa5=> "\2\5", 0xa6=> "\2\6", 0xa7=> "\2\7", 0xa8=> "\2\8", 0xa9=> "\2\9", 0xaa=> "\2\a", 0xab=> "\2\b", 0xac=> "\2\c", 0xad=> "\2\d", 0xae=> "\2\e", 0xaf=> "\2\f", 0xb0=> "\2\0", 0xb1=> "\2\1", 0xb2=> "\2\2", 0xb3=> "\2\3", 0xb4=> "\2\4", 0xb5=> "\2\5", 0xb6=> "\2\6", 0xb7=> "\2\7", 0xb8=> "\2\8", 0xb9=> "\2\9", 0xba=> "\2\a", 0xbb=> "\2\b", 0xbc=> "\2\c", 0xbd=> "\2\d", 0xbe=> "\2\e", 0xbf=> "\2\f", 0xc0=> "\3\0", 0xc1=> "\3\1", 0xc2=> "\3\2", 0xc3=> "\3\3", 0xc4=> "\3\4", 0xc5=> "\3\5", 0xc6=> "\3\6", 0xc7=> "\3\7", 0xc8=> "\3\8", 0xc9=> "\3\9", 0xca=> "\3\a", 0xcb=> "\3\b", 0xcc=> "\3\c", 0xcd=> "\3\d", 0xce=> "\3\e", 0xcf=> "\3\f", 0xd0=> "\3\0", 0xd1=> "\3\1", 0xd2=> "\3\2", 0xd3=> "\3\3", 0xd4=> "\3\4", 0xd5=> "\3\5", 0xd6=> "\3\6", 0xd7=> "\3\7", 0xd8=> "\3\8", 0xd9=> "\3\9", 0xda=> "\3\a", 0xdb=> "\3\b", 0xdc=> "\3\c", 0xdd=> "\3\d", 0xde=> "\3\e", 0xdf=> "\3\f", 0xe0=> "\3\0", 0xe1=> "\3\1", 0xe2=> "\3\2", 0xe3=> "\3\3", 0xe4=> "\3\4", 0xe5=> "\3\5", 0xe6=> "\3\6", 0xe7=> "\3\7", 0xe8=> "\3\8", 0xe9=> "\3\9", 0xea=> "\3\a", 0xeb=> "\3\b", 0xec=> "\3\c", 0xed=> "\3\d", 0xee=> "\3\e", 0xef=> "\3\f", 0xf0=> "\3\0", 0xf1=> "\3\1", 0xf2=> "\3\2", 0xf3=> "\3\3", 0xf4=> "\3\4", 0xf5=> "\3\5", 0xf6=> "\3\6", 0xf7=> "\3\7", 0xf8=> "\3\8", 0xf9=> "\3\9", 0xfa=> "\3\a", 0xfb=> "\3\b", 0xfc=> "\3\c", 0xfd=> "\3\d", 0xfe=> "\3\e",]

Documentation des variables

◆ return

return[ 0x80=> "\e2\82\ac", 0x82=> "\e2\80\9a", 0x83=> "\c6\92", 0x84=> "\e2\80\9e", 0x85=> "\e2\80\a6", 0x86=> "\e2\80\a0", 0x87=> "\e2\80\a1", 0x88=> "\cb\86", 0x89=> "\e2\80\b0", 0x8a=> "\c5\a0", 0x8b=> "\e2\80\b9", 0x8c=> "\c5\92", 0x8e=> "\c5\bd", 0x91=> "\e2\80\98", 0x92=> "\e2\80\99", 0x93=> "\e2\80\9c", 0x94=> "\e2\80\9d", 0x95=> "\e2\80\a2", 0x96=> "\e2\80\93", 0x97=> "\e2\80\94", 0x98=> "\cb\9c", 0x99=> "\e2\84\a2", 0x9a=> "\c5\a1", 0x9b=> "\e2\80\ba", 0x9c=> "\c5\93", 0x9e=> "\c5\be", 0x9f=> "\c5\b8", 0xa0=> "\c2\a0", 0xa1=> "\c2\a1", 0xa2=> "\c2\a2", 0xa3=> "\c2\a3", 0xa4=> "\c2\a4", 0xa5=> "\c2\a5", 0xa6=> "\c2\a6", 0xa7=> "\c2\a7", 0xa8=> "\c2\a8", 0xa9=> "\c2\a9", 0xaa=> "\c2\aa", 0xab=> "\c2\ab", 0xac=> "\c2\ac", 0xad=> "\c2\ad", 0xae=> "\c2\ae", 0xaf=> "\c2\af", 0xb0=> "\c2\b0", 0xb1=> "\c2\b1", 0xb2=> "\c2\b2", 0xb3=> "\c2\b3", 0xb4=> "\c2\b4", 0xb5=> "\c2\b5", 0xb6=> "\c2\b6", 0xb7=> "\c2\b7", 0xb8=> "\c2\b8", 0xb9=> "\c2\b9", 0xba=> "\c2\ba", 0xbb=> "\c2\bb", 0xbc=> "\c2\bc", 0xbd=> "\c2\bd", 0xbe=> "\c2\be", 0xbf=> "\c2\bf", 0xc0=> "\c3\80", 0xc1=> "\c3\81", 0xc2=> "\c3\82", 0xc3=> "\c3\83", 0xc4=> "\c3\84", 0xc5=> "\c3\85", 0xc6=> "\c3\86", 0xc7=> "\c3\87", 0xc8=> "\c3\88", 0xc9=> "\c3\89", 0xca=> "\c3\8a", 0xcb=> "\c3\8b", 0xcc=> "\c3\8c", 0xcd=> "\c3\8d", 0xce=> "\c3\8e", 0xcf=> "\c3\8f", 0xd0=> "\c3\90", 0xd1=> "\c3\91", 0xd2=> "\c3\92", 0xd3=> "\c3\93", 0xd4=> "\c3\94", 0xd5=> "\c3\95", 0xd6=> "\c3\96", 0xd7=> "\c3\97", 0xd8=> "\c3\98", 0xd9=> "\c3\99", 0xda=> "\c3\9a", 0xdb=> "\c3\9b", 0xdc=> "\c3\9c", 0xdd=> "\c3\9d", 0xde=> "\c3\9e", 0xdf=> "\c3\9f", 0xe0=> "\c3\a0", 0xe1=> "\c3\a1", 0xe2=> "\c3\a2", 0xe3=> "\c3\a3", 0xe4=> "\c3\a4", 0xe5=> "\c3\a5", 0xe6=> "\c3\a6", 0xe7=> "\c3\a7", 0xe8=> "\c3\a8", 0xe9=> "\c3\a9", 0xea=> "\c3\aa", 0xeb=> "\c3\ab", 0xec=> "\c3\ac", 0xed=> "\c3\ad", 0xee=> "\c3\ae", 0xef=> "\c3\af", 0xf0=> "\c3\b0", 0xf1=> "\c3\b1", 0xf2=> "\c3\b2", 0xf3=> "\c3\b3", 0xf4=> "\c3\b4", 0xf5=> "\c3\b5", 0xf6=> "\c3\b6", 0xf7=> "\c3\b7", 0xf8=> "\c3\b8", 0xf9=> "\c3\b9", 0xfa=> "\c3\ba", 0xfb=> "\c3\bb", 0xfc=> "\c3\bc", 0xfd=> "\c3\bd", 0xfe=> "\c3\be",]


Joomla CMS: Référence du fichier SubjectAlternativeNames.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
  • SAN
Structures de données | Espaces de nommage
Référence du fichier SubjectAlternativeNames.php

Structures de données

class SubjectAlternativeNames

Espaces de nommage

FG\X509\SAN


Joomla CMS: Référence du fichier strspn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier strspn.php

Espaces de nommage

utf8

Fonctions

utf8_strspn ($str, $mask, $start=NULL, $length=NULL)

Documentation des fonctions

◆ utf8_strspn()

utf8_strspn | ( | $str,
 |  | $mask,
 |  | $start = NULL,
 |  | $length = NULL
 | ) |

Références $start, null, utf8_strlen(), et utf8_substr().

Référencé par StringHelper\strspn().


Joomla CMS: Référence du fichier updatenotification.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • updatenotification
Structures de données | Espaces de nommage
Référence du fichier updatenotification.php

Structures de données

class PlgSystemUpdatenotification

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier StringStream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier spomky-labs/cbor-php/src/StringStream.php

Structures de données

class StringStream

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier Spanish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Spanish.php

Structures de données

class Spanish

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier SyslogLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier SyslogLogger.php

Structures de données

class SyslogLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier ProviderManagerHelperTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Provider
Espaces de nommage | Fonctions | Variables
Référence du fichier ProviderManagerHelperTrait.php

Espaces de nommage

Joomla\API
Joomla\Component\Media\Administrator\Provider

Fonctions

getProviderManager ()
getProvider (string $id)
getAdapter (string $name)
resolveAdapterAndPath (string $path)
getDefaultAdapterName ()

Variables

trait ProviderManagerHelperTrait
$defaultAdapterName = null


Joomla CMS: Référence du fichier ToolbarFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Structures de données | Espaces de nommage
Référence du fichier ToolbarFactoryInterface.php

Structures de données

interface ToolbarFactoryInterface

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier Query.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/ldap/Adapter/ExtLdap/Query.php

Structures de données

class Query

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier Version.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
Structures de données | Espaces de nommage
Référence du fichier src/Version.php

Structures de données

class Version

Espaces de nommage

Joomla\CMS


Joomla CMS: Référence du fichier SubjectInfoAccessSyntax.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SubjectInfoAccessSyntax.php

Structures de données

class SubjectInfoAccessSyntax

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x06b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06b.php

Variables

return ['Xiang ', 'Nong ', 'Bo ', 'Chan ', 'Lan ', 'Ju ', 'Shuang ', 'She ', 'Wei ', 'Cong ', 'Quan ', 'Qu ', 'Cang ', '[?] ', 'Yu ', 'Luo ', 'Li ', 'Zan ', 'Luan ', 'Dang ', 'Jue ', 'Em ', 'Lan ', 'Lan ', 'Zhu ', 'Lei ', 'Li ', 'Ba ', 'Nang ', 'Yu ', 'Ling ', 'Tsuki ', 'Qian ', 'Ci ', 'Huan ', 'Xin ', 'Yu ', 'Yu ', 'Qian ', 'Ou ', 'Xu ', 'Chao ', 'Chu ', 'Chi ', 'Kai ', 'Yi ', 'Jue ', 'Xi ', 'Xu ', 'Xia ', 'Yu ', 'Kuai ', 'Lang ', 'Kuan ', 'Shuo ', 'Xi ', 'Ai ', 'Yi ', 'Qi ', 'Hu ', 'Chi ', 'Qin ', 'Kuan ', 'Kan ', 'Kuan ', 'Kan ', 'Chuan ', 'Sha ', 'Gua ', 'Yin ', 'Xin ', 'Xie ', 'Yu ', 'Qian ', 'Xiao ', 'Yi ', 'Ge ', 'Wu ', 'Tan ', 'Jin ', 'Ou ', 'Hu ', 'Ti ', 'Huan ', 'Xu ', 'Pen ', 'Xi ', 'Xiao ', 'Xu ', 'Xi ', 'Sen ', 'Lian ', 'Chu ', 'Yi ', 'Kan ', 'Yu ', 'Chuo ', 'Huan ', 'Zhi ', 'Zheng ', 'Ci ', 'Bu ', 'Wu ', 'Qi ', 'Bu ', 'Bu ', 'Wai ', 'Ju ', 'Qian ', 'Chi ', 'Se ', 'Chi ', 'Se ', 'Zhong ', 'Sui ', 'Sui ', 'Li ', 'Cuo ', 'Yu ', 'Li ', 'Gui ', 'Dai ', 'Dai ', 'Si ', 'Jian ', 'Zhe ', 'Mo ', 'Mo ', 'Yao ', 'Mo ', 'Cu ', 'Yang ', 'Tian ', 'Sheng ', 'Dai ', 'Shang ', 'Xu ', 'Xun ', 'Shu ', 'Can ', 'Jue ', 'Piao ', 'Qia ', 'Qiu ', 'Su ', 'Qing ', 'Yun ', 'Lian ', 'Yi ', 'Fou ', 'Zhi ', 'Ye ', 'Can ', 'Hun ', 'Dan ', 'Ji ', 'Ye ', 'Zhen ', 'Yun ', 'Wen ', 'Chou ', 'Bin ', 'Ti ', 'Jin ', 'Shang ', 'Yin ', 'Diao ', 'Cu ', 'Hui ', 'Cuan ', 'Yi ', 'Dan ', 'Du ', 'Jiang ', 'Lian ', 'Bin ', 'Du ', 'Tsukusu ', 'Jian ', 'Shu ', 'Ou ', 'Duan ', 'Zhu ', 'Yin ', 'Qing ', 'Yi ', 'Sha ', 'Que ', 'Ke ', 'Yao ', 'Jun ', 'Dian ', 'Hui ', 'Hui ', 'Gu ', 'Que ', 'Ji ', 'Yi ', 'Ou ', 'Hui ', 'Duan ', 'Yi ', 'Xiao ', 'Wu ', 'Guan ', 'Mu ', 'Mei ', 'Mei ', 'Ai ', 'Zuo ', 'Du ', 'Yu ', 'Bi ', 'Bi ', 'Bi ', 'Pi ', 'Pi ', 'Bi ', 'Chan ', 'Mao ', '[?] ', '[?] ', 'Pu ', 'Mushiru ', 'Jia ', 'Zhan ', 'Sai ', 'Mu ', 'Tuo ', 'Xun ', 'Er ', 'Rong ', 'Xian ', 'Ju ', 'Mu ', 'Hao ', 'Qiu ', 'Dou ', 'Mushiru ', 'Tan ', 'Pei ', 'Ju ', 'Duo ', 'Cui ', 'Bi ', 'San ', '[?] ', 'Mao ', 'Sui ', 'Yu ', 'Yu ', 'Tuo ', 'He ', 'Jian ', 'Ta ', 'San ']

Documentation des variables

◆ return

return[ 'Xiang ', 'Nong ', 'Bo ', 'Chan ', 'Lan ', 'Ju ', 'Shuang ', 'She ', 'Wei ', 'Cong ', 'Quan ', 'Qu ', 'Cang ', '[?] ', 'Yu ', 'Luo ', 'Li ', 'Zan ', 'Luan ', 'Dang ', 'Jue ', 'Em ', 'Lan ', 'Lan ', 'Zhu ', 'Lei ', 'Li ', 'Ba ', 'Nang ', 'Yu ', 'Ling ', 'Tsuki ', 'Qian ', 'Ci ', 'Huan ', 'Xin ', 'Yu ', 'Yu ', 'Qian ', 'Ou ', 'Xu ', 'Chao ', 'Chu ', 'Chi ', 'Kai ', 'Yi ', 'Jue ', 'Xi ', 'Xu ', 'Xia ', 'Yu ', 'Kuai ', 'Lang ', 'Kuan ', 'Shuo ', 'Xi ', 'Ai ', 'Yi ', 'Qi ', 'Hu ', 'Chi ', 'Qin ', 'Kuan ', 'Kan ', 'Kuan ', 'Kan ', 'Chuan ', 'Sha ', 'Gua ', 'Yin ', 'Xin ', 'Xie ', 'Yu ', 'Qian ', 'Xiao ', 'Yi ', 'Ge ', 'Wu ', 'Tan ', 'Jin ', 'Ou ', 'Hu ', 'Ti ', 'Huan ', 'Xu ', 'Pen ', 'Xi ', 'Xiao ', 'Xu ', 'Xi ', 'Sen ', 'Lian ', 'Chu ', 'Yi ', 'Kan ', 'Yu ', 'Chuo ', 'Huan ', 'Zhi ', 'Zheng ', 'Ci ', 'Bu ', 'Wu ', 'Qi ', 'Bu ', 'Bu ', 'Wai ', 'Ju ', 'Qian ', 'Chi ', 'Se ', 'Chi ', 'Se ', 'Zhong ', 'Sui ', 'Sui ', 'Li ', 'Cuo ', 'Yu ', 'Li ', 'Gui ', 'Dai ', 'Dai ', 'Si ', 'Jian ', 'Zhe ', 'Mo ', 'Mo ', 'Yao ', 'Mo ', 'Cu ', 'Yang ', 'Tian ', 'Sheng ', 'Dai ', 'Shang ', 'Xu ', 'Xun ', 'Shu ', 'Can ', 'Jue ', 'Piao ', 'Qia ', 'Qiu ', 'Su ', 'Qing ', 'Yun ', 'Lian ', 'Yi ', 'Fou ', 'Zhi ', 'Ye ', 'Can ', 'Hun ', 'Dan ', 'Ji ', 'Ye ', 'Zhen ', 'Yun ', 'Wen ', 'Chou ', 'Bin ', 'Ti ', 'Jin ', 'Shang ', 'Yin ', 'Diao ', 'Cu ', 'Hui ', 'Cuan ', 'Yi ', 'Dan ', 'Du ', 'Jiang ', 'Lian ', 'Bin ', 'Du ', 'Tsukusu ', 'Jian ', 'Shu ', 'Ou ', 'Duan ', 'Zhu ', 'Yin ', 'Qing ', 'Yi ', 'Sha ', 'Que ', 'Ke ', 'Yao ', 'Jun ', 'Dian ', 'Hui ', 'Hui ', 'Gu ', 'Que ', 'Ji ', 'Yi ', 'Ou ', 'Hui ', 'Duan ', 'Yi ', 'Xiao ', 'Wu ', 'Guan ', 'Mu ', 'Mei ', 'Mei ', 'Ai ', 'Zuo ', 'Du ', 'Yu ', 'Bi ', 'Bi ', 'Bi ', 'Pi ', 'Pi ', 'Bi ', 'Chan ', 'Mao ', '[?] ', '[?] ', 'Pu ', 'Mushiru ', 'Jia ', 'Zhan ', 'Sai ', 'Mu ', 'Tuo ', 'Xun ', 'Er ', 'Rong ', 'Xian ', 'Ju ', 'Mu ', 'Hao ', 'Qiu ', 'Dou ', 'Mushiru ', 'Tan ', 'Pei ', 'Ju ', 'Duo ', 'Cui ', 'Bi ', 'San ', '[?] ', 'Mao ', 'Sui ', 'Yu ', 'Yu ', 'Tuo ', 'He ', 'Jian ', 'Ta ', 'San ']


Joomla CMS: Référence du fichier ResolvedRoute.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
Structures de données | Espaces de nommage
Référence du fichier ResolvedRoute.php

Structures de données

class ResolvedRoute

Espaces de nommage

Joomla\Router


Joomla CMS: Référence du fichier StylesRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier StylesRenderer.php

Structures de données

class StylesRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Templates.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Templates.php

Structures de données

class Templates

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Service\HTML


Joomla CMS: Référence du fichier UnsatisfiedDependencyException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • Exception
Structures de données | Espaces de nommage
Référence du fichier src/WebAsset/Exception/UnsatisfiedDependencyException.php

Structures de données

class UnsatisfiedDependencyException

Espaces de nommage

Joomla\CMS\WebAsset\Exception


Joomla CMS: Référence du fichier Transliterate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Language
Structures de données | Espaces de nommage
Référence du fichier Transliterate.php

Structures de données

class Transliterate

Espaces de nommage

Joomla\CMS\Language


Joomla CMS: Référence du fichier RgbPaletteEntry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier RgbPaletteEntry.php

Structures de données

class RgbPaletteEntry

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier Pathway.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/Pathway.php

Structures de données

class Pathway

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier PluginstatusField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier PluginstatusField.php

Structures de données

class PluginstatusField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier RouterViewConfiguration.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterViewConfiguration.php

Structures de données

class RouterViewConfiguration

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier SubformField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier SubformField.php

Structures de données

class SubformField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ScriptsRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Html
Structures de données | Espaces de nommage
Référence du fichier ScriptsRenderer.php

Structures de données

class ScriptsRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Html


Joomla CMS: Référence du fichier x0b1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b1.php

Variables

return ['nyaess', 'nyaeng', 'nyaej', 'nyaec', 'nyaek', 'nyaet', 'nyaep', 'nyaeh', 'neo', 'neog', 'neogg', 'neogs', 'neon', 'neonj', 'neonh', 'neod', 'neol', 'neolg', 'neolm', 'neolb', 'neols', 'neolt', 'neolp', 'neolh', 'neom', 'neob', 'neobs', 'neos', 'neoss', 'neong', 'neoj', 'neoc', 'neok', 'neot', 'neop', 'neoh', 'ne', 'neg', 'negg', 'negs', 'nen', 'nenj', 'nenh', 'ned', 'nel', 'nelg', 'nelm', 'nelb', 'nels', 'nelt', 'nelp', 'nelh', 'nem', 'neb', 'nebs', 'nes', 'ness', 'neng', 'nej', 'nec', 'nek', 'net', 'nep', 'neh', 'nyeo', 'nyeog', 'nyeogg', 'nyeogs', 'nyeon', 'nyeonj', 'nyeonh', 'nyeod', 'nyeol', 'nyeolg', 'nyeolm', 'nyeolb', 'nyeols', 'nyeolt', 'nyeolp', 'nyeolh', 'nyeom', 'nyeob', 'nyeobs', 'nyeos', 'nyeoss', 'nyeong', 'nyeoj', 'nyeoc', 'nyeok', 'nyeot', 'nyeop', 'nyeoh', 'nye', 'nyeg', 'nyegg', 'nyegs', 'nyen', 'nyenj', 'nyenh', 'nyed', 'nyel', 'nyelg', 'nyelm', 'nyelb', 'nyels', 'nyelt', 'nyelp', 'nyelh', 'nyem', 'nyeb', 'nyebs', 'nyes', 'nyess', 'nyeng', 'nyej', 'nyec', 'nyek', 'nyet', 'nyep', 'nyeh', 'no', 'nog', 'nogg', 'nogs', 'non', 'nonj', 'nonh', 'nod', 'nol', 'nolg', 'nolm', 'nolb', 'nols', 'nolt', 'nolp', 'nolh', 'nom', 'nob', 'nobs', 'nos', 'noss', 'nong', 'noj', 'noc', 'nok', 'not', 'nop', 'noh', 'nwa', 'nwag', 'nwagg', 'nwags', 'nwan', 'nwanj', 'nwanh', 'nwad', 'nwal', 'nwalg', 'nwalm', 'nwalb', 'nwals', 'nwalt', 'nwalp', 'nwalh', 'nwam', 'nwab', 'nwabs', 'nwas', 'nwass', 'nwang', 'nwaj', 'nwac', 'nwak', 'nwat', 'nwap', 'nwah', 'nwae', 'nwaeg', 'nwaegg', 'nwaegs', 'nwaen', 'nwaenj', 'nwaenh', 'nwaed', 'nwael', 'nwaelg', 'nwaelm', 'nwaelb', 'nwaels', 'nwaelt', 'nwaelp', 'nwaelh', 'nwaem', 'nwaeb', 'nwaebs', 'nwaes', 'nwaess', 'nwaeng', 'nwaej', 'nwaec', 'nwaek', 'nwaet', 'nwaep', 'nwaeh', 'noe', 'noeg', 'noegg', 'noegs', 'noen', 'noenj', 'noenh', 'noed', 'noel', 'noelg', 'noelm', 'noelb', 'noels', 'noelt', 'noelp', 'noelh', 'noem', 'noeb', 'noebs', 'noes', 'noess', 'noeng', 'noej', 'noec', 'noek', 'noet', 'noep', 'noeh', 'nyo', 'nyog', 'nyogg', 'nyogs', 'nyon', 'nyonj', 'nyonh', 'nyod', 'nyol', 'nyolg', 'nyolm', 'nyolb', 'nyols', 'nyolt', 'nyolp', 'nyolh', 'nyom', 'nyob', 'nyobs', 'nyos', 'nyoss', 'nyong', 'nyoj', 'nyoc']

Documentation des variables

◆ return

return[ 'nyaess', 'nyaeng', 'nyaej', 'nyaec', 'nyaek', 'nyaet', 'nyaep', 'nyaeh', 'neo', 'neog', 'neogg', 'neogs', 'neon', 'neonj', 'neonh', 'neod', 'neol', 'neolg', 'neolm', 'neolb', 'neols', 'neolt', 'neolp', 'neolh', 'neom', 'neob', 'neobs', 'neos', 'neoss', 'neong', 'neoj', 'neoc', 'neok', 'neot', 'neop', 'neoh', 'ne', 'neg', 'negg', 'negs', 'nen', 'nenj', 'nenh', 'ned', 'nel', 'nelg', 'nelm', 'nelb', 'nels', 'nelt', 'nelp', 'nelh', 'nem', 'neb', 'nebs', 'nes', 'ness', 'neng', 'nej', 'nec', 'nek', 'net', 'nep', 'neh', 'nyeo', 'nyeog', 'nyeogg', 'nyeogs', 'nyeon', 'nyeonj', 'nyeonh', 'nyeod', 'nyeol', 'nyeolg', 'nyeolm', 'nyeolb', 'nyeols', 'nyeolt', 'nyeolp', 'nyeolh', 'nyeom', 'nyeob', 'nyeobs', 'nyeos', 'nyeoss', 'nyeong', 'nyeoj', 'nyeoc', 'nyeok', 'nyeot', 'nyeop', 'nyeoh', 'nye', 'nyeg', 'nyegg', 'nyegs', 'nyen', 'nyenj', 'nyenh', 'nyed', 'nyel', 'nyelg', 'nyelm', 'nyelb', 'nyels', 'nyelt', 'nyelp', 'nyelh', 'nyem', 'nyeb', 'nyebs', 'nyes', 'nyess', 'nyeng', 'nyej', 'nyec', 'nyek', 'nyet', 'nyep', 'nyeh', 'no', 'nog', 'nogg', 'nogs', 'non', 'nonj', 'nonh', 'nod', 'nol', 'nolg', 'nolm', 'nolb', 'nols', 'nolt', 'nolp', 'nolh', 'nom', 'nob', 'nobs', 'nos', 'noss', 'nong', 'noj', 'noc', 'nok', 'not', 'nop', 'noh', 'nwa', 'nwag', 'nwagg', 'nwags', 'nwan', 'nwanj', 'nwanh', 'nwad', 'nwal', 'nwalg', 'nwalm', 'nwalb', 'nwals', 'nwalt', 'nwalp', 'nwalh', 'nwam', 'nwab', 'nwabs', 'nwas', 'nwass', 'nwang', 'nwaj', 'nwac', 'nwak', 'nwat', 'nwap', 'nwah', 'nwae', 'nwaeg', 'nwaegg', 'nwaegs', 'nwaen', 'nwaenj', 'nwaenh', 'nwaed', 'nwael', 'nwaelg', 'nwaelm', 'nwaelb', 'nwaels', 'nwaelt', 'nwaelp', 'nwaelh', 'nwaem', 'nwaeb', 'nwaebs', 'nwaes', 'nwaess', 'nwaeng', 'nwaej', 'nwaec', 'nwaek', 'nwaet', 'nwaep', 'nwaeh', 'noe', 'noeg', 'noegg', 'noegs', 'noen', 'noenj', 'noenh', 'noed', 'noel', 'noelg', 'noelm', 'noelb', 'noels', 'noelt', 'noelp', 'noelh', 'noem', 'noeb', 'noebs', 'noes', 'noess', 'noeng', 'noej', 'noec', 'noek', 'noet', 'noep', 'noeh', 'nyo', 'nyog', 'nyogg', 'nyogs', 'nyon', 'nyonj', 'nyonh', 'nyod', 'nyol', 'nyolg', 'nyolm', 'nyolb', 'nyols', 'nyolt', 'nyolp', 'nyolh', 'nyom', 'nyob', 'nyobs', 'nyos', 'nyoss', 'nyong', 'nyoj', 'nyoc']


Joomla CMS: Référence du fichier x064.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x064.php

Variables

return ['Chan ', 'Ge ', 'Lou ', 'Zong ', 'Geng ', 'Jiao ', 'Gou ', 'Qin ', 'Yong ', 'Que ', 'Chou ', 'Chi ', 'Zhan ', 'Sun ', 'Sun ', 'Bo ', 'Chu ', 'Rong ', 'Beng ', 'Cuo ', 'Sao ', 'Ke ', 'Yao ', 'Dao ', 'Zhi ', 'Nu ', 'Xie ', 'Jian ', 'Sou ', 'Qiu ', 'Gao ', 'Xian ', 'Shuo ', 'Sang ', 'Jin ', 'Mie ', 'E ', 'Chui ', 'Nuo ', 'Shan ', 'Ta ', 'Jie ', 'Tang ', 'Pan ', 'Ban ', 'Da ', 'Li ', 'Tao ', 'Hu ', 'Zhi ', 'Wa ', 'Xia ', 'Qian ', 'Wen ', 'Qiang ', 'Tian ', 'Zhen ', 'E ', 'Xi ', 'Nuo ', 'Quan ', 'Cha ', 'Zha ', 'Ge ', 'Wu ', 'En ', 'She ', 'Kang ', 'She ', 'Shu ', 'Bai ', 'Yao ', 'Bin ', 'Sou ', 'Tan ', 'Sa ', 'Chan ', 'Suo ', 'Liao ', 'Chong ', 'Chuang ', 'Guo ', 'Bing ', 'Feng ', 'Shuai ', 'Di ', 'Qi ', 'Sou ', 'Zhai ', 'Lian ', 'Tang ', 'Chi ', 'Guan ', 'Lu ', 'Luo ', 'Lou ', 'Zong ', 'Gai ', 'Hu ', 'Zha ', 'Chuang ', 'Tang ', 'Hua ', 'Cui ', 'Nai ', 'Mo ', 'Jiang ', 'Gui ', 'Ying ', 'Zhi ', 'Ao ', 'Zhi ', 'Nie ', 'Man ', 'Shan ', 'Kou ', 'Shu ', 'Suo ', 'Tuan ', 'Jiao ', 'Mo ', 'Mo ', 'Zhe ', 'Xian ', 'Keng ', 'Piao ', 'Jiang ', 'Yin ', 'Gou ', 'Qian ', 'Lue ', 'Ji ', 'Ying ', 'Jue ', 'Pie ', 'Pie ', 'Lao ', 'Dun ', 'Xian ', 'Ruan ', 'Kui ', 'Zan ', 'Yi ', 'Xun ', 'Cheng ', 'Cheng ', 'Sa ', 'Nao ', 'Heng ', 'Si ', 'Qian ', 'Huang ', 'Da ', 'Zun ', 'Nian ', 'Lin ', 'Zheng ', 'Hui ', 'Zhuang ', 'Jiao ', 'Ji ', 'Cao ', 'Dan ', 'Dan ', 'Che ', 'Bo ', 'Che ', 'Jue ', 'Xiao ', 'Liao ', 'Ben ', 'Fu ', 'Qiao ', 'Bo ', 'Cuo ', 'Zhuo ', 'Zhuan ', 'Tuo ', 'Pu ', 'Qin ', 'Dun ', 'Nian ', '[?] ', 'Xie ', 'Lu ', 'Jiao ', 'Cuan ', 'Ta ', 'Han ', 'Qiao ', 'Zhua ', 'Jian ', 'Gan ', 'Yong ', 'Lei ', 'Kuo ', 'Lu ', 'Shan ', 'Zhuo ', 'Ze ', 'Pu ', 'Chuo ', 'Ji ', 'Dang ', 'Suo ', 'Cao ', 'Qing ', 'Jing ', 'Huan ', 'Jie ', 'Qin ', 'Kuai ', 'Dan ', 'Xi ', 'Ge ', 'Pi ', 'Bo ', 'Ao ', 'Ju ', 'Ye ', '[?] ', 'Mang ', 'Sou ', 'Mi ', 'Ji ', 'Tai ', 'Zhuo ', 'Dao ', 'Xing ', 'Lan ', 'Ca ', 'Ju ', 'Ye ', 'Ru ', 'Ye ', 'Ye ', 'Ni ', 'Hu ', 'Ji ', 'Bin ', 'Ning ', 'Ge ', 'Zhi ', 'Jie ', 'Kuo ', 'Mo ', 'Jian ', 'Xie ', 'Lie ', 'Tan ', 'Bai ', 'Sou ', 'Lu ', 'Lue ', 'Rao ', 'Zhi ']

Documentation des variables

◆ return

return[ 'Chan ', 'Ge ', 'Lou ', 'Zong ', 'Geng ', 'Jiao ', 'Gou ', 'Qin ', 'Yong ', 'Que ', 'Chou ', 'Chi ', 'Zhan ', 'Sun ', 'Sun ', 'Bo ', 'Chu ', 'Rong ', 'Beng ', 'Cuo ', 'Sao ', 'Ke ', 'Yao ', 'Dao ', 'Zhi ', 'Nu ', 'Xie ', 'Jian ', 'Sou ', 'Qiu ', 'Gao ', 'Xian ', 'Shuo ', 'Sang ', 'Jin ', 'Mie ', 'E ', 'Chui ', 'Nuo ', 'Shan ', 'Ta ', 'Jie ', 'Tang ', 'Pan ', 'Ban ', 'Da ', 'Li ', 'Tao ', 'Hu ', 'Zhi ', 'Wa ', 'Xia ', 'Qian ', 'Wen ', 'Qiang ', 'Tian ', 'Zhen ', 'E ', 'Xi ', 'Nuo ', 'Quan ', 'Cha ', 'Zha ', 'Ge ', 'Wu ', 'En ', 'She ', 'Kang ', 'She ', 'Shu ', 'Bai ', 'Yao ', 'Bin ', 'Sou ', 'Tan ', 'Sa ', 'Chan ', 'Suo ', 'Liao ', 'Chong ', 'Chuang ', 'Guo ', 'Bing ', 'Feng ', 'Shuai ', 'Di ', 'Qi ', 'Sou ', 'Zhai ', 'Lian ', 'Tang ', 'Chi ', 'Guan ', 'Lu ', 'Luo ', 'Lou ', 'Zong ', 'Gai ', 'Hu ', 'Zha ', 'Chuang ', 'Tang ', 'Hua ', 'Cui ', 'Nai ', 'Mo ', 'Jiang ', 'Gui ', 'Ying ', 'Zhi ', 'Ao ', 'Zhi ', 'Nie ', 'Man ', 'Shan ', 'Kou ', 'Shu ', 'Suo ', 'Tuan ', 'Jiao ', 'Mo ', 'Mo ', 'Zhe ', 'Xian ', 'Keng ', 'Piao ', 'Jiang ', 'Yin ', 'Gou ', 'Qian ', 'Lue ', 'Ji ', 'Ying ', 'Jue ', 'Pie ', 'Pie ', 'Lao ', 'Dun ', 'Xian ', 'Ruan ', 'Kui ', 'Zan ', 'Yi ', 'Xun ', 'Cheng ', 'Cheng ', 'Sa ', 'Nao ', 'Heng ', 'Si ', 'Qian ', 'Huang ', 'Da ', 'Zun ', 'Nian ', 'Lin ', 'Zheng ', 'Hui ', 'Zhuang ', 'Jiao ', 'Ji ', 'Cao ', 'Dan ', 'Dan ', 'Che ', 'Bo ', 'Che ', 'Jue ', 'Xiao ', 'Liao ', 'Ben ', 'Fu ', 'Qiao ', 'Bo ', 'Cuo ', 'Zhuo ', 'Zhuan ', 'Tuo ', 'Pu ', 'Qin ', 'Dun ', 'Nian ', '[?] ', 'Xie ', 'Lu ', 'Jiao ', 'Cuan ', 'Ta ', 'Han ', 'Qiao ', 'Zhua ', 'Jian ', 'Gan ', 'Yong ', 'Lei ', 'Kuo ', 'Lu ', 'Shan ', 'Zhuo ', 'Ze ', 'Pu ', 'Chuo ', 'Ji ', 'Dang ', 'Suo ', 'Cao ', 'Qing ', 'Jing ', 'Huan ', 'Jie ', 'Qin ', 'Kuai ', 'Dan ', 'Xi ', 'Ge ', 'Pi ', 'Bo ', 'Ao ', 'Ju ', 'Ye ', '[?] ', 'Mang ', 'Sou ', 'Mi ', 'Ji ', 'Tai ', 'Zhuo ', 'Dao ', 'Xing ', 'Lan ', 'Ca ', 'Ju ', 'Ye ', 'Ru ', 'Ye ', 'Ye ', 'Ni ', 'Hu ', 'Ji ', 'Bin ', 'Ning ', 'Ge ', 'Zhi ', 'Jie ', 'Kuo ', 'Mo ', 'Jian ', 'Xie ', 'Lie ', 'Tan ', 'Bai ', 'Sou ', 'Lu ', 'Lue ', 'Rao ', 'Zhi ']


Joomla CMS: Référence du fichier trim.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier trim.php

Espaces de nommage

utf8

Fonctions

utf8_ltrim ( $str, $charlist=FALSE)
utf8_rtrim ( $str, $charlist=FALSE)
utf8_trim ( $str, $charlist=FALSE)

Documentation des fonctions

◆ utf8_ltrim()

utf8_ltrim | ( | $str,
 |  | $charlist = FALSE
 | ) |

Référencé par StringHelper\ltrim(), et utf8_trim().

◆ utf8_rtrim()

utf8_rtrim | ( | $str,
 |  | $charlist = FALSE
 | ) |

Référencé par StringHelper\rtrim(), et utf8_trim().

◆ utf8_trim()

utf8_trim | ( | $str,
 |  | $charlist = FALSE
 | ) |

Références utf8_ltrim(), et utf8_rtrim().

Référencé par StringHelper\trim().


Joomla CMS: Référence du fichier TemplatesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_mails/src/Model/TemplatesModel.php

Structures de données

class TemplatesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Model


Joomla CMS: Référence du fichier RouterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/router/src/RouterInterface.php

Structures de données

interface RouterInterface

Espaces de nommage

Joomla\Router


Joomla CMS: Référence du fichier PlugininfoField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_actionlogs
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PlugininfoField.php

Structures de données

class PlugininfoField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Actionlogs\Administrator\Field


Joomla CMS: Référence du fichier UnsupportedCacheException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedCacheException.php

Structures de données

class UnsupportedCacheException

Espaces de nommage

Joomla\CMS\Cache\Exception


Joomla CMS: Référence du fichier RuntimeException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Exception
Structures de données | Espaces de nommage
Référence du fichier console/Exception/RuntimeException.php

Structures de données

class RuntimeException

Espaces de nommage

Symfony\Component\Console\Exception


Joomla CMS: Référence du fichier RS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/RS256.php

Structures de données

class RS256

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier SubjectPublicKeyInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SubjectPublicKeyInfo.php

Structures de données

class SubjectPublicKeyInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier StatsAdminHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_stats_admin
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier StatsAdminHelper.php

Structures de données

class StatsAdminHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\StatsAdmin\Administrator\Helper


Joomla CMS: Référence du fichier Rsa.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
Structures de données | Espaces de nommage
Référence du fichier Rsa.php

Structures de données

class Rsa

Espaces de nommage

Lcobucci\JWT\Signer


Joomla CMS: Référence du fichier StreamFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier php-http/message-factory/src/StreamFactory.php

Structures de données

interface StreamFactory

Espaces de nommage

Http\Message


Joomla CMS: Référence du fichier text.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • text
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/text/text.php

Structures de données

class PlgFieldsText

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/modules/mod_quickicon/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier SiteDownCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier SiteDownCommand.php

Structures de données

class SiteDownCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier WebAssetManagerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetManagerInterface.php

Structures de données

interface WebAssetManagerInterface

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier ResponseBag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
  • Exception
  • Handler
Structures de données | Espaces de nommage
Référence du fichier ResponseBag.php

Structures de données

class ResponseBag

Espaces de nommage

Tobscure\JsonApi\Exception\Handler


Joomla CMS: Référence du fichier x0cd.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0cd.php

Variables

return ['cyess', 'cyeng', 'cyej', 'cyec', 'cyek', 'cyet', 'cyep', 'cyeh', 'co', 'cog', 'cogg', 'cogs', 'con', 'conj', 'conh', 'cod', 'col', 'colg', 'colm', 'colb', 'cols', 'colt', 'colp', 'colh', 'com', 'cob', 'cobs', 'cos', 'coss', 'cong', 'coj', 'coc', 'cok', 'cot', 'cop', 'coh', 'cwa', 'cwag', 'cwagg', 'cwags', 'cwan', 'cwanj', 'cwanh', 'cwad', 'cwal', 'cwalg', 'cwalm', 'cwalb', 'cwals', 'cwalt', 'cwalp', 'cwalh', 'cwam', 'cwab', 'cwabs', 'cwas', 'cwass', 'cwang', 'cwaj', 'cwac', 'cwak', 'cwat', 'cwap', 'cwah', 'cwae', 'cwaeg', 'cwaegg', 'cwaegs', 'cwaen', 'cwaenj', 'cwaenh', 'cwaed', 'cwael', 'cwaelg', 'cwaelm', 'cwaelb', 'cwaels', 'cwaelt', 'cwaelp', 'cwaelh', 'cwaem', 'cwaeb', 'cwaebs', 'cwaes', 'cwaess', 'cwaeng', 'cwaej', 'cwaec', 'cwaek', 'cwaet', 'cwaep', 'cwaeh', 'coe', 'coeg', 'coegg', 'coegs', 'coen', 'coenj', 'coenh', 'coed', 'coel', 'coelg', 'coelm', 'coelb', 'coels', 'coelt', 'coelp', 'coelh', 'coem', 'coeb', 'coebs', 'coes', 'coess', 'coeng', 'coej', 'coec', 'coek', 'coet', 'coep', 'coeh', 'cyo', 'cyog', 'cyogg', 'cyogs', 'cyon', 'cyonj', 'cyonh', 'cyod', 'cyol', 'cyolg', 'cyolm', 'cyolb', 'cyols', 'cyolt', 'cyolp', 'cyolh', 'cyom', 'cyob', 'cyobs', 'cyos', 'cyoss', 'cyong', 'cyoj', 'cyoc', 'cyok', 'cyot', 'cyop', 'cyoh', 'cu', 'cug', 'cugg', 'cugs', 'cun', 'cunj', 'cunh', 'cud', 'cul', 'culg', 'culm', 'culb', 'culs', 'cult', 'culp', 'culh', 'cum', 'cub', 'cubs', 'cus', 'cuss', 'cung', 'cuj', 'cuc', 'cuk', 'cut', 'cup', 'cuh', 'cweo', 'cweog', 'cweogg', 'cweogs', 'cweon', 'cweonj', 'cweonh', 'cweod', 'cweol', 'cweolg', 'cweolm', 'cweolb', 'cweols', 'cweolt', 'cweolp', 'cweolh', 'cweom', 'cweob', 'cweobs', 'cweos', 'cweoss', 'cweong', 'cweoj', 'cweoc', 'cweok', 'cweot', 'cweop', 'cweoh', 'cwe', 'cweg', 'cwegg', 'cwegs', 'cwen', 'cwenj', 'cwenh', 'cwed', 'cwel', 'cwelg', 'cwelm', 'cwelb', 'cwels', 'cwelt', 'cwelp', 'cwelh', 'cwem', 'cweb', 'cwebs', 'cwes', 'cwess', 'cweng', 'cwej', 'cwec', 'cwek', 'cwet', 'cwep', 'cweh', 'cwi', 'cwig', 'cwigg', 'cwigs', 'cwin', 'cwinj', 'cwinh', 'cwid', 'cwil', 'cwilg', 'cwilm', 'cwilb', 'cwils', 'cwilt', 'cwilp', 'cwilh', 'cwim', 'cwib', 'cwibs', 'cwis', 'cwiss', 'cwing', 'cwij', 'cwic']

Documentation des variables

◆ return

return[ 'cyess', 'cyeng', 'cyej', 'cyec', 'cyek', 'cyet', 'cyep', 'cyeh', 'co', 'cog', 'cogg', 'cogs', 'con', 'conj', 'conh', 'cod', 'col', 'colg', 'colm', 'colb', 'cols', 'colt', 'colp', 'colh', 'com', 'cob', 'cobs', 'cos', 'coss', 'cong', 'coj', 'coc', 'cok', 'cot', 'cop', 'coh', 'cwa', 'cwag', 'cwagg', 'cwags', 'cwan', 'cwanj', 'cwanh', 'cwad', 'cwal', 'cwalg', 'cwalm', 'cwalb', 'cwals', 'cwalt', 'cwalp', 'cwalh', 'cwam', 'cwab', 'cwabs', 'cwas', 'cwass', 'cwang', 'cwaj', 'cwac', 'cwak', 'cwat', 'cwap', 'cwah', 'cwae', 'cwaeg', 'cwaegg', 'cwaegs', 'cwaen', 'cwaenj', 'cwaenh', 'cwaed', 'cwael', 'cwaelg', 'cwaelm', 'cwaelb', 'cwaels', 'cwaelt', 'cwaelp', 'cwaelh', 'cwaem', 'cwaeb', 'cwaebs', 'cwaes', 'cwaess', 'cwaeng', 'cwaej', 'cwaec', 'cwaek', 'cwaet', 'cwaep', 'cwaeh', 'coe', 'coeg', 'coegg', 'coegs', 'coen', 'coenj', 'coenh', 'coed', 'coel', 'coelg', 'coelm', 'coelb', 'coels', 'coelt', 'coelp', 'coelh', 'coem', 'coeb', 'coebs', 'coes', 'coess', 'coeng', 'coej', 'coec', 'coek', 'coet', 'coep', 'coeh', 'cyo', 'cyog', 'cyogg', 'cyogs', 'cyon', 'cyonj', 'cyonh', 'cyod', 'cyol', 'cyolg', 'cyolm', 'cyolb', 'cyols', 'cyolt', 'cyolp', 'cyolh', 'cyom', 'cyob', 'cyobs', 'cyos', 'cyoss', 'cyong', 'cyoj', 'cyoc', 'cyok', 'cyot', 'cyop', 'cyoh', 'cu', 'cug', 'cugg', 'cugs', 'cun', 'cunj', 'cunh', 'cud', 'cul', 'culg', 'culm', 'culb', 'culs', 'cult', 'culp', 'culh', 'cum', 'cub', 'cubs', 'cus', 'cuss', 'cung', 'cuj', 'cuc', 'cuk', 'cut', 'cup', 'cuh', 'cweo', 'cweog', 'cweogg', 'cweogs', 'cweon', 'cweonj', 'cweonh', 'cweod', 'cweol', 'cweolg', 'cweolm', 'cweolb', 'cweols', 'cweolt', 'cweolp', 'cweolh', 'cweom', 'cweob', 'cweobs', 'cweos', 'cweoss', 'cweong', 'cweoj', 'cweoc', 'cweok', 'cweot', 'cweop', 'cweoh', 'cwe', 'cweg', 'cwegg', 'cwegs', 'cwen', 'cwenj', 'cwenh', 'cwed', 'cwel', 'cwelg', 'cwelm', 'cwelb', 'cwels', 'cwelt', 'cwelp', 'cwelh', 'cwem', 'cweb', 'cwebs', 'cwes', 'cwess', 'cweng', 'cwej', 'cwec', 'cwek', 'cwet', 'cwep', 'cweh', 'cwi', 'cwig', 'cwigg', 'cwigs', 'cwin', 'cwinj', 'cwinh', 'cwid', 'cwil', 'cwilg', 'cwilm', 'cwilb', 'cwils', 'cwilt', 'cwilp', 'cwilh', 'cwim', 'cwib', 'cwibs', 'cwis', 'cwiss', 'cwing', 'cwij', 'cwic']


Joomla CMS: Référence du fichier ResetController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ResetController.php

Structures de données

class ResetController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier x02a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x02a.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '::=', '==', '===', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '::=', '==', '===', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier privacyconsent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • privacyconsent
Structures de données | Espaces de nommage
Référence du fichier privacyconsent.php

Structures de données

class PlgSystemPrivacyconsent

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PHP32.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier PHP32.php

Structures de données

class PHP32

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
PHP32


Joomla CMS: Référence du fichier PBES2params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PBES2params.php

Structures de données

class PBES2params

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SplFixedArray.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • PHP52
Structures de données
Référence du fichier SplFixedArray.php

Structures de données

class SplFixedArray


Joomla CMS: Référence du fichier WebAssetManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetManager.php

Structures de données

class WebAssetManager

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier TransitionModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier TransitionModel.php

Structures de données

class TransitionModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier tags.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier layouts/joomla/content/tags.php

Espaces de nommage

Joomla\Site

Variables

$authorised = Factory::getUser()->getAuthorisedViewLevels()
$link_class = $tagParams->get('tag_link_class', 'btn-info')
endif
endforeach

Documentation des variables

◆ $authorised

$authorised = Factory::getUser()->getAuthorisedViewLevels()

Référencé par HtmlView\display(), Access\getAuthorisedViewLevels(), ArticlesPopularHelper\getList(), ArticlesCategoryHelper\getList(), et PlgSystemActionLogs\onUserAfterSave().

◆ $link_class

$link_class = $tagParams->get('tag_link_class', 'btn-info')

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DH/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

DH
phpseclib3\Crypt\DH


Joomla CMS: Référence du fichier render.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • layouts
  • fields
Espaces de nommage | Variables
Référence du fichier com_fields/layouts/fields/render.php

Espaces de nommage

Joomla\Site

Variables

if(!array_key_exists('item', $displayData)||!array_key_exists('context', $displayData)) | $item = $displayData['item']
if(! $item) | $context = $displayData['context']
if(! $context) | $parts = explode('.', $context)
$component = $parts[0]
$fields = null
if(array_key_exists('fields', $displayData)) | else
if(empty($fields)) | $output = array()
foreach($fields as $field) | if (empty( $output))

Documentation des variables

◆ $component

$component = $parts[0]

◆ $context

if (! $item) $context = $displayData['context']

◆ $fields

$fields = null

◆ $item

if (!array_key_exists( 'item', $displayData)||!array_key_exists( 'context', $displayData)) $item = $displayData['item']

◆ $output

if (empty( $fields)) $output = array()

Référencé par AbstractDumper\__construct(), CliDumper\__construct(), HtmlDumper\__construct(), CliApplication\__construct(), ConsoleApplication\__construct(), Application\__construct(), ContactController\_sendEmail(), QuestionHelper\ask(), QuestionHelper\autocomplete(), ExtensionDiscoverCommand\configureIO(), SiteDownCommand\configureIO(), SiteUpCommand\configureIO(), ExtensionInstallCommand\configureIO(), ExtensionDiscoverInstallCommand\configureIO(), ExtensionsListCommand\configureIO(), SetConfigurationCommand\configureIO(), TasksListCommand\configureIO(), ListUserCommand\configureIO(), ExtensionRemoveCommand\configureIO(), UpdateCoreCommand\configureIO(), TasksRunCommand\configureIO(), GetConfigurationCommand\configureIO(), ChangeUserPasswordCommand\configureIO(), TasksStateCommand\configureIO(), DeleteUserCommand\configureIO(), FinderIndexCommand\configureIO(), AddUserToGroupCommand\configureIO(), RemoveUserFromGroupCommand\configureIO(), AddUserCommand\configureIO(), Application\configureIO(), PasswordHash\crypt_private(), BaseLayout\debug(), InstallationApplication\debugLanguage(), DescriptorHelper\describe(), HtmlDescriptor\describe(), CliDescriptor\describe(), HtmlView\display(), QuestionHelper\doAsk(), RemoveOldFilesCommand\doExecute(), CheckUpdatesCommand\doExecute(), SessionGcCommand\doExecute(), TasksRunCommand\doExecute(), TasksListCommand\doExecute(), ListUserCommand\doExecute(), CreateSessionTableCommand\doExecute(), SessionMetadataGcCommand\doExecute(), ChangeUserPasswordCommand\doExecute(), ExtensionDiscoverListCommand\doExecute(), DeleteUserCommand\doExecute(), SiteDownCommand\doExecute(), SiteUpCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), AddUserToGroupCommand\doExecute(), ImportCommand\doExecute(), CheckJoomlaUpdatesCommand\doExecute(), AddUserCommand\doExecute(), ExtensionDiscoverCommand\doExecute(), UpdateCoreCommand\doExecute(), ExtensionRemoveCommand\doExecute(), FinderIndexCommand\doExecute(), ExtensionInstallCommand\doExecute(), ExtensionDiscoverInstallCommand\doExecute(), ExtensionsListCommand\doExecute(), Application\doExecute(), GetConfigurationCommand\doExecute(), SetConfigurationCommand\doExecute(), Application\doRenderThrowable(), Application\doRun(), Application\doRunCommand(), Dumper\dump(), Inline\dump(), AbstractDumper\dump(), HtmlDumper\dump(), DebugBarVarDumper\dump(), Inline\dumpArray(), Icon\edit(), PasswordHash\encode64(), BaseLayout\escape(), SSH2\exec(), HelpCommand\execute(), ServerDumpCommand\execute(), DumpCompletionCommand\execute(), LintCommand\execute(), AbstractCommand\execute(), Bzip2\extract(), Gzip\extract(), Form\filter(), SSH2\format_log(), OutputFormatter\formatAndWrap(), DataFormatter\formatVar(), EvalBarrett\generateInlineMultiply(), PasswordHash\gensalt_blowfish(), PasswordHash\gensalt_private(), PasswordHash\get_random_bytes(), X509\getDN(), QuestionHelper\getHiddenResponse(), Symfony\Component\Console\Tester\getOutput(), CliApplication\getOutput(), SysinfoModel\getPHPInfo(), ANSI\getScreenHelper(), Hash\hash(), Terminal\hasSttyAvailable(), QuestionHelper\isInteractiveInput(), CaBundle\isOpensslParseSafe(), ManageModel\loadChangelog(), Directory\message(), PlgContentLoadmodule\onContentPrepare(), FieldsPlugin\onCustomFieldsPrepareField(), Inline\parseMapping(), Inline\parseQuotedScalar(), Inline\parseScalar(), Inline\parseSequence(), Core\pbkdf2(), Form\postProcess(), PlgContentFields\prepare(), ANSI\processCoordinate(), Application\renderThrowable(), ProcessHelper\run(), SingleCommandApplication\run(), LazyCommand\run(), Application\run(), Command\run(), Application\runCommand(), AbstractDumper\setOutput(), CliApplication\setOutput(), ApplicationHelper\stringURLSafe(), DumpCompletionCommand\tailDebugLog(), ArrayHelper\toString(), TranscodeUnicode\ucs4_ucs4array(), TranscodeUnicode\ucs4array_ucs4(), TranscodeUnicode\ucs4array_utf7(), TranscodeUnicode\ucs4array_utf8(), TranscodeUnicode\utf7_ucs4array(), TranscodeUnicode\utf8_ucs4array(), ProcessHelper\wrapCallback(), BashCompletionOutput\write(), SymfonyQuestionHelper\writeError(), QuestionHelper\writeError(), SymfonyQuestionHelper\writePrompt(), et QuestionHelper\writePrompt().

◆ $parts

if (! $context) $parts = explode('.', $context)

◆ else

if (array_key_exists( 'fields', $displayData)) else
Valeur initiale :
{
$fields = $item->jcfields ?: FieldsHelper::getFields($context, $item, true)
$context
if(! $item) $context
Definition: com_fields/layouts/fields/render.php:27
Joomla\Component\Fields\Administrator\Helper\FieldsHelper\getFields
static getFields( $context, $item=null, $prepareValue=false, array $valuesToOverride=null, bool $includeSubformFields=false)
Definition: FieldsHelper.php:101
$item
if(!array_key_exists('item', $displayData)||!array_key_exists('context', $displayData)) $item
Definition: com_fields/layouts/fields/render.php:21
$fields
$fields
Definition: com_fields/layouts/fields/render.php:35

◆ if

foreach ( $fields as $field) if(empty($output))


Joomla CMS: Référence du fichier PdoCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier PdoCaster.php

Structures de données

class PdoCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Turkish
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Turkish/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\Turkish


Joomla CMS: Référence du fichier RendererInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
Structures de données | Espaces de nommage
Référence du fichier Error/RendererInterface.php

Structures de données

interface RendererInterface

Espaces de nommage

Joomla\CMS\Error


Joomla CMS: Référence du fichier SymfonyCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier SymfonyCaster.php

Structures de données

class SymfonyCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_content/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Requests.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • requests
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Requests.php

Structures de données

class Requests

Espaces de nommage

Joomla\Plugins
Joomla\Plugin\Task\Requests\Extension


Joomla CMS: Référence du fichier SetupModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier SetupModel.php

Structures de données

class SetupModel

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Model


Joomla CMS: Référence du fichier UnhandledMatchError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
  • Resources
  • stubs
Référence du fichier UnhandledMatchError.php


Joomla CMS: Référence du fichier QueryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/database/src/QueryInterface.php

Structures de données

interface QueryInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier Workflow.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier Workflow.php

Structures de données

class Workflow

Espaces de nommage

Joomla\CMS\Workflow


Joomla CMS: Référence du fichier SessionFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
Structures de données | Espaces de nommage
Référence du fichier SessionFactory.php

Structures de données

class SessionFactory

Espaces de nommage

Joomla\CMS\Session


Joomla CMS: Référence du fichier VersionableTableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Versioning
Structures de données | Espaces de nommage
Référence du fichier VersionableTableInterface.php

Structures de données

interface VersionableTableInterface

Espaces de nommage

Joomla\CMS\Versioning


Joomla CMS: Référence du fichier x0d0.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d0.php

Variables

return ['kweon', 'kweonj', 'kweonh', 'kweod', 'kweol', 'kweolg', 'kweolm', 'kweolb', 'kweols', 'kweolt', 'kweolp', 'kweolh', 'kweom', 'kweob', 'kweobs', 'kweos', 'kweoss', 'kweong', 'kweoj', 'kweoc', 'kweok', 'kweot', 'kweop', 'kweoh', 'kwe', 'kweg', 'kwegg', 'kwegs', 'kwen', 'kwenj', 'kwenh', 'kwed', 'kwel', 'kwelg', 'kwelm', 'kwelb', 'kwels', 'kwelt', 'kwelp', 'kwelh', 'kwem', 'kweb', 'kwebs', 'kwes', 'kwess', 'kweng', 'kwej', 'kwec', 'kwek', 'kwet', 'kwep', 'kweh', 'kwi', 'kwig', 'kwigg', 'kwigs', 'kwin', 'kwinj', 'kwinh', 'kwid', 'kwil', 'kwilg', 'kwilm', 'kwilb', 'kwils', 'kwilt', 'kwilp', 'kwilh', 'kwim', 'kwib', 'kwibs', 'kwis', 'kwiss', 'kwing', 'kwij', 'kwic', 'kwik', 'kwit', 'kwip', 'kwih', 'kyu', 'kyug', 'kyugg', 'kyugs', 'kyun', 'kyunj', 'kyunh', 'kyud', 'kyul', 'kyulg', 'kyulm', 'kyulb', 'kyuls', 'kyult', 'kyulp', 'kyulh', 'kyum', 'kyub', 'kyubs', 'kyus', 'kyuss', 'kyung', 'kyuj', 'kyuc', 'kyuk', 'kyut', 'kyup', 'kyuh', 'keu', 'keug', 'keugg', 'keugs', 'keun', 'keunj', 'keunh', 'keud', 'keul', 'keulg', 'keulm', 'keulb', 'keuls', 'keult', 'keulp', 'keulh', 'keum', 'keub', 'keubs', 'keus', 'keuss', 'keung', 'keuj', 'keuc', 'keuk', 'keut', 'keup', 'keuh', 'kyi', 'kyig', 'kyigg', 'kyigs', 'kyin', 'kyinj', 'kyinh', 'kyid', 'kyil', 'kyilg', 'kyilm', 'kyilb', 'kyils', 'kyilt', 'kyilp', 'kyilh', 'kyim', 'kyib', 'kyibs', 'kyis', 'kyiss', 'kying', 'kyij', 'kyic', 'kyik', 'kyit', 'kyip', 'kyih', 'ki', 'kig', 'kigg', 'kigs', 'kin', 'kinj', 'kinh', 'kid', 'kil', 'kilg', 'kilm', 'kilb', 'kils', 'kilt', 'kilp', 'kilh', 'kim', 'kib', 'kibs', 'kis', 'kiss', 'king', 'kij', 'kic', 'kik', 'kit', 'kip', 'kih', 'ta', 'tag', 'tagg', 'tags', 'tan', 'tanj', 'tanh', 'tad', 'tal', 'talg', 'talm', 'talb', 'tals', 'talt', 'talp', 'talh', 'tam', 'tab', 'tabs', 'tas', 'tass', 'tang', 'taj', 'tac', 'tak', 'tat', 'tap', 'tah', 'tae', 'taeg', 'taegg', 'taegs', 'taen', 'taenj', 'taenh', 'taed', 'tael', 'taelg', 'taelm', 'taelb', 'taels', 'taelt', 'taelp', 'taelh', 'taem', 'taeb', 'taebs', 'taes', 'taess', 'taeng', 'taej', 'taec', 'taek', 'taet', 'taep', 'taeh', 'tya', 'tyag', 'tyagg', 'tyags', 'tyan', 'tyanj', 'tyanh', 'tyad']

Documentation des variables

◆ return

return[ 'kweon', 'kweonj', 'kweonh', 'kweod', 'kweol', 'kweolg', 'kweolm', 'kweolb', 'kweols', 'kweolt', 'kweolp', 'kweolh', 'kweom', 'kweob', 'kweobs', 'kweos', 'kweoss', 'kweong', 'kweoj', 'kweoc', 'kweok', 'kweot', 'kweop', 'kweoh', 'kwe', 'kweg', 'kwegg', 'kwegs', 'kwen', 'kwenj', 'kwenh', 'kwed', 'kwel', 'kwelg', 'kwelm', 'kwelb', 'kwels', 'kwelt', 'kwelp', 'kwelh', 'kwem', 'kweb', 'kwebs', 'kwes', 'kwess', 'kweng', 'kwej', 'kwec', 'kwek', 'kwet', 'kwep', 'kweh', 'kwi', 'kwig', 'kwigg', 'kwigs', 'kwin', 'kwinj', 'kwinh', 'kwid', 'kwil', 'kwilg', 'kwilm', 'kwilb', 'kwils', 'kwilt', 'kwilp', 'kwilh', 'kwim', 'kwib', 'kwibs', 'kwis', 'kwiss', 'kwing', 'kwij', 'kwic', 'kwik', 'kwit', 'kwip', 'kwih', 'kyu', 'kyug', 'kyugg', 'kyugs', 'kyun', 'kyunj', 'kyunh', 'kyud', 'kyul', 'kyulg', 'kyulm', 'kyulb', 'kyuls', 'kyult', 'kyulp', 'kyulh', 'kyum', 'kyub', 'kyubs', 'kyus', 'kyuss', 'kyung', 'kyuj', 'kyuc', 'kyuk', 'kyut', 'kyup', 'kyuh', 'keu', 'keug', 'keugg', 'keugs', 'keun', 'keunj', 'keunh', 'keud', 'keul', 'keulg', 'keulm', 'keulb', 'keuls', 'keult', 'keulp', 'keulh', 'keum', 'keub', 'keubs', 'keus', 'keuss', 'keung', 'keuj', 'keuc', 'keuk', 'keut', 'keup', 'keuh', 'kyi', 'kyig', 'kyigg', 'kyigs', 'kyin', 'kyinj', 'kyinh', 'kyid', 'kyil', 'kyilg', 'kyilm', 'kyilb', 'kyils', 'kyilt', 'kyilp', 'kyilh', 'kyim', 'kyib', 'kyibs', 'kyis', 'kyiss', 'kying', 'kyij', 'kyic', 'kyik', 'kyit', 'kyip', 'kyih', 'ki', 'kig', 'kigg', 'kigs', 'kin', 'kinj', 'kinh', 'kid', 'kil', 'kilg', 'kilm', 'kilb', 'kils', 'kilt', 'kilp', 'kilh', 'kim', 'kib', 'kibs', 'kis', 'kiss', 'king', 'kij', 'kic', 'kik', 'kit', 'kip', 'kih', 'ta', 'tag', 'tagg', 'tags', 'tan', 'tanj', 'tanh', 'tad', 'tal', 'talg', 'talm', 'talb', 'tals', 'talt', 'talp', 'talh', 'tam', 'tab', 'tabs', 'tas', 'tass', 'tang', 'taj', 'tac', 'tak', 'tat', 'tap', 'tah', 'tae', 'taeg', 'taegg', 'taegs', 'taen', 'taenj', 'taenh', 'taed', 'tael', 'taelg', 'taelm', 'taelb', 'taels', 'taelt', 'taelp', 'taelh', 'taem', 'taeb', 'taebs', 'taes', 'taess', 'taeng', 'taej', 'taec', 'taek', 'taet', 'taep', 'taeh', 'tya', 'tyag', 'tyagg', 'tyags', 'tyan', 'tyanj', 'tyanh', 'tyad']


Joomla CMS: Référence du fichier PublicKeyCredentialRpEntity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialRpEntity.php

Structures de données

class PublicKeyCredentialRpEntity

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier params.php

Espaces de nommage

Joomla\Site

Variables

$app = Factory::getApplication()
$form = $displayData->getForm()
$fieldSets = $form->getFieldsets()
$helper = $displayData->get('useCoreUI', false) ? 'uitab' : 'bootstrap'
if(empty($fieldSets)) | $ignoreFieldsets = $displayData->get('ignore_fieldsets') ?: array()
$outputFieldsets = $displayData->get('output_fieldsets') ?: array()
$ignoreFieldsetFields = $displayData->get('ignore_fieldset_fields') ?: array()
$ignoreFields = $displayData->get('ignore_fields') ?: array()
$extraFields = $displayData->get('extra_fields') ?: array()
$tabName = $displayData->get('tab_name') ?: 'myTab'
$hiddenFieldsets = $displayData->get('hiddenFieldsets') ?: array()
$configFieldsets = $displayData->get('configFieldsets') ?: array()
if(! $displayData->get('show_options', 1)) | $opentab = false
$xml = $form->getXml()

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $configFieldsets

$configFieldsets = $displayData->get('configFieldsets') ?: array()

◆ $extraFields

$extraFields = $displayData->get('extra_fields') ?: array()

◆ $fieldSets

$fieldSets = $form->getFieldsets()

◆ $form

$form = $displayData->getForm()

◆ $helper

$helper = $displayData->get('useCoreUI', false) ? 'uitab' : 'bootstrap'

Référencé par HelperSet\__construct(), Versionable\__construct(), MessageController\action(), MessagesModel\addPostInstallationMessage(), HtmlView\addToolbar(), AssociationsHelper\allowAdd(), AssociationsHelper\allowEdit(), AssociationsHelper\canCheckinItem(), ApiController\checkContent(), MediaController\checkContent(), LocalAdapter\checkContent(), HelpCommand\complete(), LegacyComponent\countItems(), LegacyComponent\countTagItems(), TagTable\delete(), Application\doRunCommand(), HelpCommand\execute(), AssociationsHelper\getAssociationList(), LegacyComponent\getContexts(), HelperFactory\getHelper(), Joomla\CMS\Helper\getHelperFactory(), AssociationsHelper\getItem(), Dispatcher\getLayoutData(), ItemlanguageField\getOptions(), HistoryModel\getSha1Hash(), AssociationsHelper\getSupportedExtension(), AssociationsHelper\getTypeFieldName(), AssociationsHelper\isCheckoutItem(), HtmlView\loadHelper(), MessagesModel\onProcessList(), Application\runCommand(), HelperSet\set(), AssociationsHelper\typeSupportsCheckout(), et LegacyComponent\validateSection().

◆ $hiddenFieldsets

$hiddenFieldsets = $displayData->get('hiddenFieldsets') ?: array()

◆ $ignoreFields

$ignoreFields = $displayData->get('ignore_fields') ?: array()

◆ $ignoreFieldsetFields

$ignoreFieldsetFields = $displayData->get('ignore_fieldset_fields') ?: array()

◆ $ignoreFieldsets

if (empty( $fieldSets)) $ignoreFieldsets = $displayData->get('ignore_fieldsets') ?: array()

◆ $opentab

if (! $displayData->get( 'show_options', 1)) $opentab = false

◆ $outputFieldsets

$outputFieldsets = $displayData->get('output_fieldsets') ?: array()

◆ $tabName

$tabName = $displayData->get('tab_name') ?: 'myTab'

◆ $xml

$xml = $form->getXml()


Joomla CMS: Référence du fichier ServiceProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/di/src/ServiceProviderInterface.php

Structures de données

interface ServiceProviderInterface

Espaces de nommage

Joomla\DI


Joomla CMS: Référence du fichier resize.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • media-action
  • resize
Structures de données | Espaces de nommage
Référence du fichier resize.php

Structures de données

class PlgMediaActionResize

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x00d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x00d.php

Variables

return ['[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', 'lll', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', '[?]', 'e', 'ee', 'ai', '', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'ae', 'aae', 'i', 'ii', 'u', 'uu', 'R', 'RR', 'L', 'LL', 'e', 'ee', 'ai', 'o', 'oo', 'au', '[?]', '[?]', '[?]', 'k', 'kh', 'g', 'gh', 'ng', 'nng', 'c', 'ch', 'j', 'jh', 'ny', 'jny', 'nyj', 'tt', 'tth', 'dd', 'ddh', 'nn', 'nndd', 't', 'th', 'd', 'dh', 'n', '[?]', 'nd', 'p', 'ph', 'b', 'bh', 'm', 'mb', 'y', 'r', '[?]', 'l', '[?]', '[?]', 'v', 'sh', 'ss', 's', 'h', 'll', 'f', '[?]', '[?]', '[?]', '', '[?]', '[?]', '[?]', '[?]', 'aa', 'ae', 'aae', 'i', 'ii', 'u', '[?]', 'uu', '[?]', 'R', 'e', 'ee', 'ai', 'o', 'oo', 'au', 'L', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', ' . ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', 'lll', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', '[?]', 'e', 'ee', 'ai', '', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'ae', 'aae', 'i', 'ii', 'u', 'uu', 'R', 'RR', 'L', 'LL', 'e', 'ee', 'ai', 'o', 'oo', 'au', '[?]', '[?]', '[?]', 'k', 'kh', 'g', 'gh', 'ng', 'nng', 'c', 'ch', 'j', 'jh', 'ny', 'jny', 'nyj', 'tt', 'tth', 'dd', 'ddh', 'nn', 'nndd', 't', 'th', 'd', 'dh', 'n', '[?]', 'nd', 'p', 'ph', 'b', 'bh', 'm', 'mb', 'y', 'r', '[?]', 'l', '[?]', '[?]', 'v', 'sh', 'ss', 's', 'h', 'll', 'f', '[?]', '[?]', '[?]', '', '[?]', '[?]', '[?]', '[?]', 'aa', 'ae', 'aae', 'i', 'ii', 'u', '[?]', 'uu', '[?]', 'R', 'e', 'ee', 'ai', 'o', 'oo', 'au', 'L', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', ' . ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier x004.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x004.php

Variables

return ['Ie', 'Io', 'Dj', 'Gj', 'Ie', 'Dz', 'I', 'Yi', 'J', 'Lj', 'Nj', 'Tsh', 'Kj', 'I', 'U', 'Dzh', 'A', 'B', 'V', 'G', 'D', 'E', 'Zh', 'Z', 'I', 'I', 'K', 'L', 'M', 'N', 'O', 'P', 'R', 'S', 'T', 'U', 'F', 'Kh', 'Ts', 'Ch', 'Sh', 'Shch', '\'', 'Y', '\'', 'E', 'Iu', 'Ia', 'a', 'b', 'v', 'g', 'd', 'e', 'zh', 'z', 'i', 'i', 'k', 'l', 'm', 'n', 'o', 'p', 'r', 's', 't', 'u', 'f', 'kh', 'ts', 'ch', 'sh', 'shch', '\'', 'y', '\'', 'e', 'iu', 'ia', 'ie', 'io', 'dj', 'gj', 'ie', 'dz', 'i', 'yi', 'j', 'lj', 'nj', 'tsh', 'kj', 'i', 'u', 'dzh', 'O', 'o', 'E', 'e', 'Ie', 'ie', 'E', 'e', 'Ie', 'ie', 'O', 'o', 'Io', 'io', 'Ks', 'ks', 'Ps', 'ps', 'F', 'f', 'Y', 'y', 'Y', 'y', 'u', 'u', 'O', 'o', 'O', 'o', 'Ot', 'ot', 'Q', 'q', ' *1000 *', '', '', '', '', '[?]', ' *100.000 *', ' *1.000.000 *', '[?]', '[?]', '"', '"', 'R\'', 'r\'', 'G\'', 'g\'', 'G\'', 'g\'', 'G\'', 'g\'', 'Zh\'', 'zh\'', 'Z\'', 'z\'', 'K\'', 'k\'', 'K\'', 'k\'', 'K\'', 'k\'', 'K\'', 'k\'', 'N\'', 'n\'', 'Ng', 'ng', 'P\'', 'p\'', 'Kh', 'kh', 'S\'', 's\'', 'T\'', 't\'', 'U', 'u', 'U\'', 'u\'', 'Kh\'', 'kh\'', 'Tts', 'tts', 'Ch\'', 'ch\'', 'Ch\'', 'ch\'', 'H', 'h', 'Ch', 'ch', 'Ch\'', 'ch\'', '`', 'Zh', 'zh', 'K\'', 'k\'', '[?]', '[?]', 'N\'', 'n\'', '[?]', '[?]', 'Ch', 'ch', '[?]', '[?]', '[?]', 'a', 'a', 'A', 'a', 'Ae', 'ae', 'Ie', 'ie', '@', '@', '@', '@', 'Zh', 'zh', 'Z', 'z', 'Dz', 'dz', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'O', 'o', 'E', 'e', 'U', 'u', 'U', 'u', 'U', 'u', 'Ch', 'ch', '[?]', '[?]', 'Y', 'y', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'Ie', 'Io', 'Dj', 'Gj', 'Ie', 'Dz', 'I', 'Yi', 'J', 'Lj', 'Nj', 'Tsh', 'Kj', 'I', 'U', 'Dzh', 'A', 'B', 'V', 'G', 'D', 'E', 'Zh', 'Z', 'I', 'I', 'K', 'L', 'M', 'N', 'O', 'P', 'R', 'S', 'T', 'U', 'F', 'Kh', 'Ts', 'Ch', 'Sh', 'Shch', '\'', 'Y', '\'', 'E', 'Iu', 'Ia', 'a', 'b', 'v', 'g', 'd', 'e', 'zh', 'z', 'i', 'i', 'k', 'l', 'm', 'n', 'o', 'p', 'r', 's', 't', 'u', 'f', 'kh', 'ts', 'ch', 'sh', 'shch', '\'', 'y', '\'', 'e', 'iu', 'ia', 'ie', 'io', 'dj', 'gj', 'ie', 'dz', 'i', 'yi', 'j', 'lj', 'nj', 'tsh', 'kj', 'i', 'u', 'dzh', 'O', 'o', 'E', 'e', 'Ie', 'ie', 'E', 'e', 'Ie', 'ie', 'O', 'o', 'Io', 'io', 'Ks', 'ks', 'Ps', 'ps', 'F', 'f', 'Y', 'y', 'Y', 'y', 'u', 'u', 'O', 'o', 'O', 'o', 'Ot', 'ot', 'Q', 'q', ' *1000 *', '', '', '', '', '[?]', ' *100.000 *', ' *1.000.000 *', '[?]', '[?]', '"', '"', 'R\'', 'r\'', 'G\'', 'g\'', 'G\'', 'g\'', 'G\'', 'g\'', 'Zh\'', 'zh\'', 'Z\'', 'z\'', 'K\'', 'k\'', 'K\'', 'k\'', 'K\'', 'k\'', 'K\'', 'k\'', 'N\'', 'n\'', 'Ng', 'ng', 'P\'', 'p\'', 'Kh', 'kh', 'S\'', 's\'', 'T\'', 't\'', 'U', 'u', 'U\'', 'u\'', 'Kh\'', 'kh\'', 'Tts', 'tts', 'Ch\'', 'ch\'', 'Ch\'', 'ch\'', 'H', 'h', 'Ch', 'ch', 'Ch\'', 'ch\'', '`', 'Zh', 'zh', 'K\'', 'k\'', '[?]', '[?]', 'N\'', 'n\'', '[?]', '[?]', 'Ch', 'ch', '[?]', '[?]', '[?]', 'a', 'a', 'A', 'a', 'Ae', 'ae', 'Ie', 'ie', '@', '@', '@', '@', 'Zh', 'zh', 'Z', 'z', 'Dz', 'dz', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'O', 'o', 'E', 'e', 'U', 'u', 'U', 'u', 'U', 'u', 'Ch', 'ch', '[?]', '[?]', 'Y', 'y', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier x020.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x020.php

Variables

return [' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', '', '', '', '', '-', '-', '-', '-', '--', '--', '||', '_', '\'', '\'', ',', '\'', '"', '"', ',,', '"', '+', '++', '*', '*>', '.', '..', '...', '.', "\n", "\n\n", '', '', '', '', '', ' ', '%0', '%00', '\, '\', '\\, '`', '``', '```', '^', '<', '>', '*', '!!', '!?', '-', '_', '-', '^', '***', '--', '/', '-[', ']-', '??', '?!', '!?', '7', 'PP', '(][)', '*', '[?]', '[?]', '[?]', '%', '~', '[?]', '[?]', '[?]', "''''", '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ' ', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '0', 'i', '', '', '4', '5', '6', '7', '8', '9', '+', '-', '=', '(', ')', 'n', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '+', '-', '=', '(', ')', '[?]', 'a', 'e', 'o', 'x', '[?]', 'h', 'k', 'l', 'm', 'n', 'p', 's', 't', '[?]', '[?]', '[?]', 'ECU', 'CL', 'Cr', 'Fr.', 'L.', 'mil', 'N', 'Pts', 'Rs', 'W', 'NS', 'D', 'EUR', 'K', 'T', 'Dr', 'Pf', 'P', 'G', 'A', 'UAH', 'C|', 'L', 'Sm', 'T', 'Rs', 'L', 'M', 'm', 'R', 'l', 'BTC', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ]

Documentation des variables

◆ return

return[' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', '', '', '', '', '-', '-', '-', '-', '--', '--', '||', '_', '\'', '\'', ',', '\'', '"', '"', ',,', '"', '+', '++', '*', '*>', '.', '..', '...', '.', "\n", "\n\n", '', '', '', '', '', ' ', '%0', '%00', '\', '\\', '\\\', '`', '``', '```', '^', '<', '>', '*', '!!', '!?', '-', '_', '-', '^', '***', '--', '/', '-[', ']-', '??', '?!', '!?', '7', 'PP', '(][)', '*', '[?]', '[?]', '[?]', '%', '~', '[?]', '[?]', '[?]', "''''", '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ' ', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '0', 'i', '', '', '4', '5', '6', '7', '8', '9', '+', '-', '=', '(', ')', 'n', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '+', '-', '=', '(', ')', '[?]', 'a', 'e', 'o', 'x', '[?]', 'h', 'k', 'l', 'm', 'n', 'p', 's', 't', '[?]', '[?]', '[?]', 'ECU', 'CL', 'Cr', 'Fr.', 'L.', 'mil', 'N', 'Pts', 'Rs', 'W', 'NS', 'D', 'EUR', 'K', 'T', 'Dr', 'Pf', 'P', 'G', 'A', 'UAH', 'C|', 'L', 'Sm', 'T', 'Rs', 'L', 'M', 'm', 'R', 'l', 'BTC', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ]


Joomla CMS: Référence du fichier x071.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x071.php

Variables

return ['Hu ', 'Xi ', 'Shu ', 'He ', 'Xun ', 'Ku ', 'Jue ', 'Xiao ', 'Xi ', 'Yan ', 'Han ', 'Zhuang ', 'Jun ', 'Di ', 'Xie ', 'Ji ', 'Wu ', '[?] ', '[?] ', 'Han ', 'Yan ', 'Huan ', 'Men ', 'Ju ', 'Chou ', 'Bei ', 'Fen ', 'Lin ', 'Kun ', 'Hun ', 'Tun ', 'Xi ', 'Cui ', 'Wu ', 'Hong ', 'Ju ', 'Fu ', 'Wo ', 'Jiao ', 'Cong ', 'Feng ', 'Ping ', 'Qiong ', 'Ruo ', 'Xi ', 'Qiong ', 'Xin ', 'Zhuo ', 'Yan ', 'Yan ', 'Yi ', 'Jue ', 'Yu ', 'Gang ', 'Ran ', 'Pi ', 'Gu ', '[?] ', 'Sheng ', 'Chang ', 'Shao ', '[?] ', '[?] ', '[?] ', '[?] ', 'Chen ', 'He ', 'Kui ', 'Zhong ', 'Duan ', 'Xia ', 'Hui ', 'Feng ', 'Lian ', 'Xuan ', 'Xing ', 'Huang ', 'Jiao ', 'Jian ', 'Bi ', 'Ying ', 'Zhu ', 'Wei ', 'Tuan ', 'Tian ', 'Xi ', 'Nuan ', 'Nuan ', 'Chan ', 'Yan ', 'Jiong ', 'Jiong ', 'Yu ', 'Mei ', 'Sha ', 'Wei ', 'Ye ', 'Xin ', 'Qiong ', 'Rou ', 'Mei ', 'Huan ', 'Xu ', 'Zhao ', 'Wei ', 'Fan ', 'Qiu ', 'Sui ', 'Yang ', 'Lie ', 'Zhu ', 'Jie ', 'Gao ', 'Gua ', 'Bao ', 'Hu ', 'Yun ', 'Xia ', '[?] ', '[?] ', 'Bian ', 'Gou ', 'Tui ', 'Tang ', 'Chao ', 'Shan ', 'N ', 'Bo ', 'Huang ', 'Xie ', 'Xi ', 'Wu ', 'Xi ', 'Yun ', 'He ', 'He ', 'Xi ', 'Yun ', 'Xiong ', 'Nai ', 'Shan ', 'Qiong ', 'Yao ', 'Xun ', 'Mi ', 'Lian ', 'Ying ', 'Wen ', 'Rong ', 'Oozutsu ', '[?] ', 'Qiang ', 'Liu ', 'Xi ', 'Bi ', 'Biao ', 'Zong ', 'Lu ', 'Jian ', 'Shou ', 'Yi ', 'Lou ', 'Feng ', 'Sui ', 'Yi ', 'Tong ', 'Jue ', 'Zong ', 'Yun ', 'Hu ', 'Yi ', 'Zhi ', 'Ao ', 'Wei ', 'Liao ', 'Han ', 'Ou ', 'Re ', 'Jiong ', 'Man ', '[?] ', 'Shang ', 'Cuan ', 'Zeng ', 'Jian ', 'Xi ', 'Xi ', 'Xi ', 'Yi ', 'Xiao ', 'Chi ', 'Huang ', 'Chan ', 'Ye ', 'Qian ', 'Ran ', 'Yan ', 'Xian ', 'Qiao ', 'Zun ', 'Deng ', 'Dun ', 'Shen ', 'Jiao ', 'Fen ', 'Si ', 'Liao ', 'Yu ', 'Lin ', 'Tong ', 'Shao ', 'Fen ', 'Fan ', 'Yan ', 'Xun ', 'Lan ', 'Mei ', 'Tang ', 'Yi ', 'Jing ', 'Men ', '[?] ', '[?] ', 'Ying ', 'Yu ', 'Yi ', 'Xue ', 'Lan ', 'Tai ', 'Zao ', 'Can ', 'Sui ', 'Xi ', 'Que ', 'Cong ', 'Lian ', 'Hui ', 'Zhu ', 'Xie ', 'Ling ', 'Wei ', 'Yi ', 'Xie ', 'Zhao ', 'Hui ', 'Tatsu ', 'Nung ', 'Lan ', 'Ru ', 'Xian ', 'Kao ', 'Xun ', 'Jin ', 'Chou ', 'Chou ', 'Yao ']

Documentation des variables

◆ return

return[ 'Hu ', 'Xi ', 'Shu ', 'He ', 'Xun ', 'Ku ', 'Jue ', 'Xiao ', 'Xi ', 'Yan ', 'Han ', 'Zhuang ', 'Jun ', 'Di ', 'Xie ', 'Ji ', 'Wu ', '[?] ', '[?] ', 'Han ', 'Yan ', 'Huan ', 'Men ', 'Ju ', 'Chou ', 'Bei ', 'Fen ', 'Lin ', 'Kun ', 'Hun ', 'Tun ', 'Xi ', 'Cui ', 'Wu ', 'Hong ', 'Ju ', 'Fu ', 'Wo ', 'Jiao ', 'Cong ', 'Feng ', 'Ping ', 'Qiong ', 'Ruo ', 'Xi ', 'Qiong ', 'Xin ', 'Zhuo ', 'Yan ', 'Yan ', 'Yi ', 'Jue ', 'Yu ', 'Gang ', 'Ran ', 'Pi ', 'Gu ', '[?] ', 'Sheng ', 'Chang ', 'Shao ', '[?] ', '[?] ', '[?] ', '[?] ', 'Chen ', 'He ', 'Kui ', 'Zhong ', 'Duan ', 'Xia ', 'Hui ', 'Feng ', 'Lian ', 'Xuan ', 'Xing ', 'Huang ', 'Jiao ', 'Jian ', 'Bi ', 'Ying ', 'Zhu ', 'Wei ', 'Tuan ', 'Tian ', 'Xi ', 'Nuan ', 'Nuan ', 'Chan ', 'Yan ', 'Jiong ', 'Jiong ', 'Yu ', 'Mei ', 'Sha ', 'Wei ', 'Ye ', 'Xin ', 'Qiong ', 'Rou ', 'Mei ', 'Huan ', 'Xu ', 'Zhao ', 'Wei ', 'Fan ', 'Qiu ', 'Sui ', 'Yang ', 'Lie ', 'Zhu ', 'Jie ', 'Gao ', 'Gua ', 'Bao ', 'Hu ', 'Yun ', 'Xia ', '[?] ', '[?] ', 'Bian ', 'Gou ', 'Tui ', 'Tang ', 'Chao ', 'Shan ', 'N ', 'Bo ', 'Huang ', 'Xie ', 'Xi ', 'Wu ', 'Xi ', 'Yun ', 'He ', 'He ', 'Xi ', 'Yun ', 'Xiong ', 'Nai ', 'Shan ', 'Qiong ', 'Yao ', 'Xun ', 'Mi ', 'Lian ', 'Ying ', 'Wen ', 'Rong ', 'Oozutsu ', '[?] ', 'Qiang ', 'Liu ', 'Xi ', 'Bi ', 'Biao ', 'Zong ', 'Lu ', 'Jian ', 'Shou ', 'Yi ', 'Lou ', 'Feng ', 'Sui ', 'Yi ', 'Tong ', 'Jue ', 'Zong ', 'Yun ', 'Hu ', 'Yi ', 'Zhi ', 'Ao ', 'Wei ', 'Liao ', 'Han ', 'Ou ', 'Re ', 'Jiong ', 'Man ', '[?] ', 'Shang ', 'Cuan ', 'Zeng ', 'Jian ', 'Xi ', 'Xi ', 'Xi ', 'Yi ', 'Xiao ', 'Chi ', 'Huang ', 'Chan ', 'Ye ', 'Qian ', 'Ran ', 'Yan ', 'Xian ', 'Qiao ', 'Zun ', 'Deng ', 'Dun ', 'Shen ', 'Jiao ', 'Fen ', 'Si ', 'Liao ', 'Yu ', 'Lin ', 'Tong ', 'Shao ', 'Fen ', 'Fan ', 'Yan ', 'Xun ', 'Lan ', 'Mei ', 'Tang ', 'Yi ', 'Jing ', 'Men ', '[?] ', '[?] ', 'Ying ', 'Yu ', 'Yi ', 'Xue ', 'Lan ', 'Tai ', 'Zao ', 'Can ', 'Sui ', 'Xi ', 'Que ', 'Cong ', 'Lian ', 'Hui ', 'Zhu ', 'Xie ', 'Ling ', 'Wei ', 'Yi ', 'Xie ', 'Zhao ', 'Hui ', 'Tatsu ', 'Nung ', 'Lan ', 'Ru ', 'Xian ', 'Kao ', 'Xun ', 'Jin ', 'Chou ', 'Chou ', 'Yao ']


Joomla CMS: Référence du fichier Util.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier paragonie/sodium_compat/namespaced/Core/Util.php

Structures de données

class Util

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier RelativeDistinguishedName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/RelativeDistinguishedName.php

Structures de données

class RelativeDistinguishedName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier QuickIconsEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier QuickIconsEvent.php

Structures de données

class QuickIconsEvent

Espaces de nommage

Joomla\Administrator
Joomla\Module\Quickicon\Administrator\Event


Joomla CMS: Référence du fichier ViewInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • View
Structures de données | Espaces de nommage
Référence du fichier ViewInterface.php

Structures de données

interface ViewInterface

Espaces de nommage

Joomla\CMS\MVC\View


Joomla CMS: Référence du fichier WebApplicationInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier WebApplicationInterface.php

Structures de données

interface WebApplicationInterface

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier TerminateEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • console
  • src
  • Event
Structures de données | Espaces de nommage
Référence du fichier TerminateEvent.php

Structures de données

class TerminateEvent

Espaces de nommage

Joomla\Console\Event


Joomla CMS: Référence du fichier repeatable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
Espaces de nommage | Variables
Référence du fichier repeatable.php

Espaces de nommage

Joomla\Site

Variables

if($multiple) $class = $class ? ' ' . $class : ''
$sublayout = empty($groupByFieldset) ? 'section' : 'section-byfieldsets'
endif
endforeach

Documentation des variables

◆ $class

if ( $multiple) $class = $class ? ' ' . $class : ''

◆ $sublayout

$sublayout = empty($groupByFieldset) ? 'section' : 'section-byfieldsets'

Référencé par FileLayout\sublayout().

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier TokenBinding.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TokenBinding
Structures de données | Espaces de nommage
Référence du fichier TokenBinding.php

Structures de données

class TokenBinding

Espaces de nommage

Webauthn\TokenBinding


Joomla CMS: Référence du fichier translit.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-iconv
  • Resources
  • charset
Référence du fichier translit.php


Joomla CMS: Référence du fichier x017.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x017.php


Joomla CMS: Référence du fichier WorkflowcontextsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier WorkflowcontextsField.php

Structures de données

class WorkflowcontextsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Field


Joomla CMS: Référence du fichier SessionGcCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier SessionGcCommand.php

Structures de données

class SessionGcCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier UserHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Structures de données | Espaces de nommage
Référence du fichier UserHelper.php

Structures de données

class UserHelper

Espaces de nommage

Joomla\CMS\User


Joomla CMS: Référence du fichier State.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • SecretStream
Structures de données
Référence du fichier src/Core/SecretStream/State.php

Structures de données

class ParagonIE_Sodium_Core_SecretStream_State


Joomla CMS: Référence du fichier T61String.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier T61String.php

Structures de données

class T61String

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier x061.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x061.php

Variables

return ['Qiao ', 'Chou ', 'Bei ', 'Xuan ', 'Wei ', 'Ge ', 'Qian ', 'Wei ', 'Yu ', 'Yu ', 'Bi ', 'Xuan ', 'Huan ', 'Min ', 'Bi ', 'Yi ', 'Mian ', 'Yong ', 'Kai ', 'Dang ', 'Yin ', 'E ', 'Chen ', 'Mou ', 'Ke ', 'Ke ', 'Yu ', 'Ai ', 'Qie ', 'Yan ', 'Nuo ', 'Gan ', 'Yun ', 'Zong ', 'Sai ', 'Leng ', 'Fen ', '[?] ', 'Kui ', 'Kui ', 'Que ', 'Gong ', 'Yun ', 'Su ', 'Su ', 'Qi ', 'Yao ', 'Song ', 'Huang ', 'Ji ', 'Gu ', 'Ju ', 'Chuang ', 'Ni ', 'Xie ', 'Kai ', 'Zheng ', 'Yong ', 'Cao ', 'Sun ', 'Shen ', 'Bo ', 'Kai ', 'Yuan ', 'Xie ', 'Hun ', 'Yong ', 'Yang ', 'Li ', 'Sao ', 'Tao ', 'Yin ', 'Ci ', 'Xu ', 'Qian ', 'Tai ', 'Huang ', 'Yun ', 'Shen ', 'Ming ', '[?] ', 'She ', 'Cong ', 'Piao ', 'Mo ', 'Mu ', 'Guo ', 'Chi ', 'Can ', 'Can ', 'Can ', 'Cui ', 'Min ', 'Te ', 'Zhang ', 'Tong ', 'Ao ', 'Shuang ', 'Man ', 'Guan ', 'Que ', 'Zao ', 'Jiu ', 'Hui ', 'Kai ', 'Lian ', 'Ou ', 'Song ', 'Jin ', 'Yin ', 'Lu ', 'Shang ', 'Wei ', 'Tuan ', 'Man ', 'Qian ', 'She ', 'Yong ', 'Qing ', 'Kang ', 'Di ', 'Zhi ', 'Lou ', 'Juan ', 'Qi ', 'Qi ', 'Yu ', 'Ping ', 'Liao ', 'Cong ', 'You ', 'Chong ', 'Zhi ', 'Tong ', 'Cheng ', 'Qi ', 'Qu ', 'Peng ', 'Bei ', 'Bie ', 'Chun ', 'Jiao ', 'Zeng ', 'Chi ', 'Lian ', 'Ping ', 'Kui ', 'Hui ', 'Qiao ', 'Cheng ', 'Yin ', 'Yin ', 'Xi ', 'Xi ', 'Dan ', 'Tan ', 'Duo ', 'Dui ', 'Dui ', 'Su ', 'Jue ', 'Ce ', 'Xiao ', 'Fan ', 'Fen ', 'Lao ', 'Lao ', 'Chong ', 'Han ', 'Qi ', 'Xian ', 'Min ', 'Jing ', 'Liao ', 'Wu ', 'Can ', 'Jue ', 'Cu ', 'Xian ', 'Tan ', 'Sheng ', 'Pi ', 'Yi ', 'Chu ', 'Xian ', 'Nao ', 'Dan ', 'Tan ', 'Jing ', 'Song ', 'Han ', 'Jiao ', 'Wai ', 'Huan ', 'Dong ', 'Qin ', 'Qin ', 'Qu ', 'Cao ', 'Ken ', 'Xie ', 'Ying ', 'Ao ', 'Mao ', 'Yi ', 'Lin ', 'Se ', 'Jun ', 'Huai ', 'Men ', 'Lan ', 'Ai ', 'Lin ', 'Yan ', 'Gua ', 'Xia ', 'Chi ', 'Yu ', 'Yin ', 'Dai ', 'Meng ', 'Ai ', 'Meng ', 'Dui ', 'Qi ', 'Mo ', 'Lan ', 'Men ', 'Chou ', 'Zhi ', 'Nuo ', 'Nuo ', 'Yan ', 'Yang ', 'Bo ', 'Zhi ', 'Kuang ', 'Kuang ', 'You ', 'Fu ', 'Liu ', 'Mie ', 'Cheng ', '[?] ', 'Chan ', 'Meng ', 'Lan ', 'Huai ', 'Xuan ', 'Rang ', 'Chan ', 'Ji ', 'Ju ', 'Huan ', 'She ', 'Yi ']

Documentation des variables

◆ return

return[ 'Qiao ', 'Chou ', 'Bei ', 'Xuan ', 'Wei ', 'Ge ', 'Qian ', 'Wei ', 'Yu ', 'Yu ', 'Bi ', 'Xuan ', 'Huan ', 'Min ', 'Bi ', 'Yi ', 'Mian ', 'Yong ', 'Kai ', 'Dang ', 'Yin ', 'E ', 'Chen ', 'Mou ', 'Ke ', 'Ke ', 'Yu ', 'Ai ', 'Qie ', 'Yan ', 'Nuo ', 'Gan ', 'Yun ', 'Zong ', 'Sai ', 'Leng ', 'Fen ', '[?] ', 'Kui ', 'Kui ', 'Que ', 'Gong ', 'Yun ', 'Su ', 'Su ', 'Qi ', 'Yao ', 'Song ', 'Huang ', 'Ji ', 'Gu ', 'Ju ', 'Chuang ', 'Ni ', 'Xie ', 'Kai ', 'Zheng ', 'Yong ', 'Cao ', 'Sun ', 'Shen ', 'Bo ', 'Kai ', 'Yuan ', 'Xie ', 'Hun ', 'Yong ', 'Yang ', 'Li ', 'Sao ', 'Tao ', 'Yin ', 'Ci ', 'Xu ', 'Qian ', 'Tai ', 'Huang ', 'Yun ', 'Shen ', 'Ming ', '[?] ', 'She ', 'Cong ', 'Piao ', 'Mo ', 'Mu ', 'Guo ', 'Chi ', 'Can ', 'Can ', 'Can ', 'Cui ', 'Min ', 'Te ', 'Zhang ', 'Tong ', 'Ao ', 'Shuang ', 'Man ', 'Guan ', 'Que ', 'Zao ', 'Jiu ', 'Hui ', 'Kai ', 'Lian ', 'Ou ', 'Song ', 'Jin ', 'Yin ', 'Lu ', 'Shang ', 'Wei ', 'Tuan ', 'Man ', 'Qian ', 'She ', 'Yong ', 'Qing ', 'Kang ', 'Di ', 'Zhi ', 'Lou ', 'Juan ', 'Qi ', 'Qi ', 'Yu ', 'Ping ', 'Liao ', 'Cong ', 'You ', 'Chong ', 'Zhi ', 'Tong ', 'Cheng ', 'Qi ', 'Qu ', 'Peng ', 'Bei ', 'Bie ', 'Chun ', 'Jiao ', 'Zeng ', 'Chi ', 'Lian ', 'Ping ', 'Kui ', 'Hui ', 'Qiao ', 'Cheng ', 'Yin ', 'Yin ', 'Xi ', 'Xi ', 'Dan ', 'Tan ', 'Duo ', 'Dui ', 'Dui ', 'Su ', 'Jue ', 'Ce ', 'Xiao ', 'Fan ', 'Fen ', 'Lao ', 'Lao ', 'Chong ', 'Han ', 'Qi ', 'Xian ', 'Min ', 'Jing ', 'Liao ', 'Wu ', 'Can ', 'Jue ', 'Cu ', 'Xian ', 'Tan ', 'Sheng ', 'Pi ', 'Yi ', 'Chu ', 'Xian ', 'Nao ', 'Dan ', 'Tan ', 'Jing ', 'Song ', 'Han ', 'Jiao ', 'Wai ', 'Huan ', 'Dong ', 'Qin ', 'Qin ', 'Qu ', 'Cao ', 'Ken ', 'Xie ', 'Ying ', 'Ao ', 'Mao ', 'Yi ', 'Lin ', 'Se ', 'Jun ', 'Huai ', 'Men ', 'Lan ', 'Ai ', 'Lin ', 'Yan ', 'Gua ', 'Xia ', 'Chi ', 'Yu ', 'Yin ', 'Dai ', 'Meng ', 'Ai ', 'Meng ', 'Dui ', 'Qi ', 'Mo ', 'Lan ', 'Men ', 'Chou ', 'Zhi ', 'Nuo ', 'Nuo ', 'Yan ', 'Yang ', 'Bo ', 'Zhi ', 'Kuang ', 'Kuang ', 'You ', 'Fu ', 'Liu ', 'Mie ', 'Cheng ', '[?] ', 'Chan ', 'Meng ', 'Lan ', 'Huai ', 'Xuan ', 'Rang ', 'Chan ', 'Ji ', 'Ju ', 'Huan ', 'She ', 'Yi ']


Joomla CMS: Référence du fichier PKCS9String.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PKCS9String.php

Structures de données

class PKCS9String

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier TesterTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Tester
Espaces de nommage | Fonctions | Variables
Référence du fichier TesterTrait.php

Espaces de nommage

Symfony\Component\Console\Tester

Fonctions

getDisplay (bool $normalize=false)
getErrorOutput (bool $normalize=false)
getInput ()
getOutput ()
getStatusCode ()
assertCommandIsSuccessful (string $message='')
setInputs (array $inputs)
initOutput (array $options)
static createStream (array $inputs)

Variables

trait TesterTrait
$inputs = []
$captureStreamsIndependently = false
$input
$statusCode


Joomla CMS: Référence du fichier textfilter3919.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier textfilter3919.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_textfilter3919_condition ()

Documentation des fonctions

◆ admin_postinstall_textfilter3919_condition()

admin_postinstall_textfilter3919_condition ( )

Notifies users the changes from the default textfilter.

This check returns true regardless of condition.

Renvoie
boolean
Depuis
3.9.19


Joomla CMS: Référence du fichier x024.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x024.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '1', '2', '3', '4', '5', '6', '7', '8', '9', '10', '11', '12', '13', '14', '15', '16', '17', '18', '19', '20', '(1)', '(2)', '(3)', '(4)', '(5)', '(6)', '(7)', '(8)', '(9)', '(10)', '(11)', '(12)', '(13)', '(14)', '(15)', '(16)', '(17)', '(18)', '(19)', '(20)', '1.', '2.', '3.', '4.', '5.', '6.', '7.', '8.', '9.', '10.', '11.', '12.', '13.', '14.', '15.', '16.', '17.', '18.', '19.', '20.', '(a)', '(b)', '(c)', '(d)', '(e)', '(f)', '(g)', '(h)', '(i)', '(j)', '(k)', '(l)', '(m)', '(n)', '(o)', '(p)', '(q)', '(r)', '(s)', '(t)', '(u)', '(v)', '(w)', '(x)', '(y)', '(z)', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '0', '11', '12', '13', '14', '15', '16', '17', '18', '19', '20', '1', '2', '3', '4', '5', '6', '7', '8', '9', '10', '0']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '1', '2', '3', '4', '5', '6', '7', '8', '9', '10', '11', '12', '13', '14', '15', '16', '17', '18', '19', '20', '(1)', '(2)', '(3)', '(4)', '(5)', '(6)', '(7)', '(8)', '(9)', '(10)', '(11)', '(12)', '(13)', '(14)', '(15)', '(16)', '(17)', '(18)', '(19)', '(20)', '1.', '2.', '3.', '4.', '5.', '6.', '7.', '8.', '9.', '10.', '11.', '12.', '13.', '14.', '15.', '16.', '17.', '18.', '19.', '20.', '(a)', '(b)', '(c)', '(d)', '(e)', '(f)', '(g)', '(h)', '(i)', '(j)', '(k)', '(l)', '(m)', '(n)', '(o)', '(p)', '(q)', '(r)', '(s)', '(t)', '(u)', '(v)', '(w)', '(x)', '(y)', '(z)', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '0', '11', '12', '13', '14', '15', '16', '17', '18', '19', '20', '1', '2', '3', '4', '5', '6', '7', '8', '9', '10', '0']


Joomla CMS: Référence du fichier PreloadManagerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier PreloadManagerInterface.php

Structures de données

interface PreloadManagerInterface

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier Task.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Task
Structures de données | Espaces de nommage
Référence du fichier Task.php

Structures de données

class Task

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Task


Joomla CMS: Référence du fichier XChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/XChaCha20.php

Structures de données

class XChaCha20

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier PharInvocationCollection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Resolver
Structures de données | Espaces de nommage
Référence du fichier PharInvocationCollection.php

Structures de données

class PharInvocationCollection

Espaces de nommage

TYPO3\PharStreamWrapper\Resolver


Joomla CMS: Référence du fichier RequestIdGeneratorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier RequestIdGeneratorInterface.php

Structures de données

interface RequestIdGeneratorInterface

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier TemplatesHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TemplatesHelper.php

Structures de données

class TemplatesHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Helper


Joomla CMS: Référence du fichier SignatureConverter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier SignatureConverter.php

Structures de données

interface SignatureConverter

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier titleCaseRegexp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
  • Resources
  • unidata
Variables
Référence du fichier titleCaseRegexp.php

Variables

return

Documentation des variables

◆ return

return


Joomla CMS: Référence du fichier Raw.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Signature/Raw.php

Structures de données

class Raw

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Signature


Joomla CMS: Référence du fichier UsersComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier UsersComponent.php

Structures de données

class UsersComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Extension


Joomla CMS: Référence du fichier PublicKeyCredentialEntity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialEntity.php

Structures de données

class PublicKeyCredentialEntity

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier WorkflowServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Workflow
Espaces de nommage | Fonctions | Variables
Référence du fichier WorkflowServiceTrait.php

Espaces de nommage

Joomla\CMS\Workflow

Fonctions

supportFunctionality ($functionality, $context)
isFunctionalityUsed ($functionality, $extension)
getModelName ($context)
static getConditions (string $extension)
isWorkflowActive ($context)

Variables

trait WorkflowServiceTrait


Joomla CMS: Référence du fichier Save.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
  • Exception
Structures de données | Espaces de nommage
Référence du fichier Save.php

Structures de données

class Save

Espaces de nommage

Joomla\CMS\MVC\Controller\Exception


Joomla CMS: Référence du fichier ResponseFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/ResponseFactory.php

Structures de données

class ResponseFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier QueryHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier QueryHelper.php

Structures de données

class QueryHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Helper


Joomla CMS: Référence du fichier RequestContextProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
  • ContextProvider
Structures de données | Espaces de nommage
Référence du fichier RequestContextProvider.php

Structures de données

class RequestContextProvider

Espaces de nommage

Symfony\Component\VarDumper\Dumper\ContextProvider


Joomla CMS: Référence du fichier SyndicateHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_syndicate
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier SyndicateHelper.php

Structures de données

class SyndicateHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Syndicate\Site\Helper


Joomla CMS: Référence du fichier Usage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • ElementReference
Structures de données | Espaces de nommage
Référence du fichier Usage.php

Structures de données

class Usage

Espaces de nommage

enshrined\svgSanitize\ElementReference


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_media/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier PublicKeyAndChallenge.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PublicKeyAndChallenge.php

Structures de données

class PublicKeyAndChallenge

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x030.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x030.php

Variables

return [' ', ', ', '. ', '"', '[JIS]', '"', '/', '0', '<', '> ', '<<', '>> ', '[', '] ', '{', '} ', '[(', ')] ', '@', 'X ', '[', '] ', ' ', '((', ')) ', ' ', '~ ', '``', '\'\'', ',,', '@', '1', '2', '3', '4', '5', '6', '7', '8', '9', '', '', '', '', '', '', '~', '+', '+', '+', '+', '', '@', ' 'zi', 'su', 'zu', 'se', 'ze', 'so', 'zo', 'ta', 'da', 'chi', 'di', 'tsu', 'tsu', 'du', 'te', 'de', 'to', 'do', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'ba', 'pa', 'hi', 'bi', 'pi', 'hu', 'bu', 'pu', 'he', 'be', 'pe', 'ho', 'bo', 'po', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'ya', 'yu', 'yu', 'yo', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wa', 'wi', 'we', 'wo', 'n', 'vu', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '"', '"', '[?]', '[?]', 'a', 'a', 'i', 'i', 'u', 'u', 'e', 'e', 'o', 'o', 'ka', 'ga', 'ki', 'gi', 'ku', 'gu', 'ke', 'ge', 'ko', 'go', 'sa', 'za', 'shi', 'zi', 'su', 'zu', 'se', 'ze', 'so', 'zo', 'ta', 'da', 'chi', 'di', 'tsu', 'tsu', 'du', 'te', 'de', 'to', 'do', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'ba', 'pa', 'hi', 'bi', 'pi', 'hu', 'bu', 'pu', 'he', 'be', 'pe', 'ho', 'bo', 'po', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'ya', 'yu', 'yu', 'yo', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wa', 'wi', 'we', 'wo', 'n', 'vu', 'ka', 'ke', 'va', 'vi', 've', 'vo', '', '', '"', '"',]

Documentation des variables

◆ return

return[' ', ', ', '. ', '"', '[JIS]', '"', '/', '0', '<', '> ', '<<', '>> ', '[', '] ', '{', '} ', '[(', ')] ', '@', 'X ', '[', '] ', ' ', '((', ')) ', ' ', '~ ', '``', '\'\'', ',,', '@', '1', '2', '3', '4', '5', '6', '7', '8', '9', '', '', '', '', '', '', '~', '+', '+', '+', '+', '', '@', ' 'zi', 'su', 'zu', 'se', 'ze', 'so', 'zo', 'ta', 'da', 'chi', 'di', 'tsu', 'tsu', 'du', 'te', 'de', 'to', 'do', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'ba', 'pa', 'hi', 'bi', 'pi', 'hu', 'bu', 'pu', 'he', 'be', 'pe', 'ho', 'bo', 'po', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'ya', 'yu', 'yu', 'yo', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wa', 'wi', 'we', 'wo', 'n', 'vu', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '"', '"', '[?]', '[?]', 'a', 'a', 'i', 'i', 'u', 'u', 'e', 'e', 'o', 'o', 'ka', 'ga', 'ki', 'gi', 'ku', 'gu', 'ke', 'ge', 'ko', 'go', 'sa', 'za', 'shi', 'zi', 'su', 'zu', 'se', 'ze', 'so', 'zo', 'ta', 'da', 'chi', 'di', 'tsu', 'tsu', 'du', 'te', 'de', 'to', 'do', 'na', 'ni', 'nu', 'ne', 'no', 'ha', 'ba', 'pa', 'hi', 'bi', 'pi', 'hu', 'bu', 'pu', 'he', 'be', 'pe', 'ho', 'bo', 'po', 'ma', 'mi', 'mu', 'me', 'mo', 'ya', 'ya', 'yu', 'yu', 'yo', 'yo', 'ra', 'ri', 'ru', 're', 'ro', 'wa', 'wa', 'wi', 'we', 'wo', 'n', 'vu', 'ka', 'ke', 'va', 'vi', 've', 'vo', '', '', '"', '"',]


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Net
  • SFTP
Structures de données | Espaces de nommage
Référence du fichier vendor/phpseclib/phpseclib/phpseclib/Net/SFTP/Stream.php

Structures de données

class Stream

Espaces de nommage

SFTP
phpseclib3\Net\SFTP


Joomla CMS: Référence du fichier RC2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier RC2.php

Structures de données

class RC2

Espaces de nommage

RC2
phpseclib3\Crypt


Joomla CMS: Référence du fichier TagsPopularHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_popular
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TagsPopularHelper.php

Structures de données

class TagsPopularHelper

Espaces de nommage

Joomla\Site
Joomla\Module\TagsPopular\Site\Helper


Joomla CMS: Référence du fichier x089.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x089.php

Variables

return ['Ji ', 'Zhi ', 'Gua ', 'Ken ', 'Che ', 'Ti ', 'Ti ', 'Fu ', 'Chong ', 'Xie ', 'Bian ', 'Die ', 'Kun ', 'Duan ', 'Xiu ', 'Xiu ', 'He ', 'Yuan ', 'Bao ', 'Bao ', 'Fu ', 'Yu ', 'Tuan ', 'Yan ', 'Hui ', 'Bei ', 'Chu ', 'Lu ', 'Ena ', 'Hitoe ', 'Yun ', 'Da ', 'Gou ', 'Da ', 'Huai ', 'Rong ', 'Yuan ', 'Ru ', 'Nai ', 'Jiong ', 'Suo ', 'Ban ', 'Tun ', 'Chi ', 'Sang ', 'Niao ', 'Ying ', 'Jie ', 'Qian ', 'Huai ', 'Ku ', 'Lian ', 'Bao ', 'Li ', 'Zhe ', 'Shi ', 'Lu ', 'Yi ', 'Die ', 'Xie ', 'Xian ', 'Wei ', 'Biao ', 'Cao ', 'Ji ', 'Jiang ', 'Sen ', 'Bao ', 'Xiang ', 'Chihaya ', 'Pu ', 'Jian ', 'Zhuan ', 'Jian ', 'Zui ', 'Ji ', 'Dan ', 'Za ', 'Fan ', 'Bo ', 'Xiang ', 'Xin ', 'Bie ', 'Rao ', 'Man ', 'Lan ', 'Ao ', 'Duo ', 'Gui ', 'Cao ', 'Sui ', 'Nong ', 'Chan ', 'Lian ', 'Bi ', 'Jin ', 'Dang ', 'Shu ', 'Tan ', 'Bi ', 'Lan ', 'Pu ', 'Ru ', 'Zhi ', '[?] ', 'Shu ', 'Wa ', 'Shi ', 'Bai ', 'Xie ', 'Bo ', 'Chen ', 'Lai ', 'Long ', 'Xi ', 'Xian ', 'Lan ', 'Zhe ', 'Dai ', 'Tasuki ', 'Zan ', 'Shi ', 'Jian ', 'Pan ', 'Yi ', 'Ran ', 'Ya ', 'Xi ', 'Xi ', 'Yao ', 'Feng ', 'Tan ', '[?] ', 'Biao ', 'Fu ', 'Ba ', 'He ', 'Ji ', 'Ji ', 'Jian ', 'Guan ', 'Bian ', 'Yan ', 'Gui ', 'Jue ', 'Pian ', 'Mao ', 'Mi ', 'Mi ', 'Mie ', 'Shi ', 'Si ', 'Zhan ', 'Luo ', 'Jue ', 'Mi ', 'Tiao ', 'Lian ', 'Yao ', 'Zhi ', 'Jun ', 'Xi ', 'Shan ', 'Wei ', 'Xi ', 'Tian ', 'Yu ', 'Lan ', 'E ', 'Du ', 'Qin ', 'Pang ', 'Ji ', 'Ming ', 'Ying ', 'Gou ', 'Qu ', 'Zhan ', 'Jin ', 'Guan ', 'Deng ', 'Jian ', 'Luo ', 'Qu ', 'Jian ', 'Wei ', 'Jue ', 'Qu ', 'Luo ', 'Lan ', 'Shen ', 'Di ', 'Guan ', 'Jian ', 'Guan ', 'Yan ', 'Gui ', 'Mi ', 'Shi ', 'Zhan ', 'Lan ', 'Jue ', 'Ji ', 'Xi ', 'Di ', 'Tian ', 'Yu ', 'Gou ', 'Jin ', 'Qu ', 'Jiao ', 'Jiu ', 'Jin ', 'Cu ', 'Jue ', 'Zhi ', 'Chao ', 'Ji ', 'Gu ', 'Dan ', 'Zui ', 'Di ', 'Shang ', 'Hua ', 'Quan ', 'Ge ', 'Chi ', 'Jie ', 'Gui ', 'Gong ', 'Hong ', 'Jie ', 'Hun ', 'Qiu ', 'Xing ', 'Su ', 'Ni ', 'Ji ', 'Lu ', 'Zhi ', 'Zha ', 'Bi ', 'Xing ', 'Hu ', 'Shang ', 'Gong ', 'Zhi ', 'Xue ', 'Chu ', 'Xi ', 'Yi ', 'Lu ', 'Jue ', 'Xi ', 'Yan ', 'Xi ']

Documentation des variables

◆ return

return[ 'Ji ', 'Zhi ', 'Gua ', 'Ken ', 'Che ', 'Ti ', 'Ti ', 'Fu ', 'Chong ', 'Xie ', 'Bian ', 'Die ', 'Kun ', 'Duan ', 'Xiu ', 'Xiu ', 'He ', 'Yuan ', 'Bao ', 'Bao ', 'Fu ', 'Yu ', 'Tuan ', 'Yan ', 'Hui ', 'Bei ', 'Chu ', 'Lu ', 'Ena ', 'Hitoe ', 'Yun ', 'Da ', 'Gou ', 'Da ', 'Huai ', 'Rong ', 'Yuan ', 'Ru ', 'Nai ', 'Jiong ', 'Suo ', 'Ban ', 'Tun ', 'Chi ', 'Sang ', 'Niao ', 'Ying ', 'Jie ', 'Qian ', 'Huai ', 'Ku ', 'Lian ', 'Bao ', 'Li ', 'Zhe ', 'Shi ', 'Lu ', 'Yi ', 'Die ', 'Xie ', 'Xian ', 'Wei ', 'Biao ', 'Cao ', 'Ji ', 'Jiang ', 'Sen ', 'Bao ', 'Xiang ', 'Chihaya ', 'Pu ', 'Jian ', 'Zhuan ', 'Jian ', 'Zui ', 'Ji ', 'Dan ', 'Za ', 'Fan ', 'Bo ', 'Xiang ', 'Xin ', 'Bie ', 'Rao ', 'Man ', 'Lan ', 'Ao ', 'Duo ', 'Gui ', 'Cao ', 'Sui ', 'Nong ', 'Chan ', 'Lian ', 'Bi ', 'Jin ', 'Dang ', 'Shu ', 'Tan ', 'Bi ', 'Lan ', 'Pu ', 'Ru ', 'Zhi ', '[?] ', 'Shu ', 'Wa ', 'Shi ', 'Bai ', 'Xie ', 'Bo ', 'Chen ', 'Lai ', 'Long ', 'Xi ', 'Xian ', 'Lan ', 'Zhe ', 'Dai ', 'Tasuki ', 'Zan ', 'Shi ', 'Jian ', 'Pan ', 'Yi ', 'Ran ', 'Ya ', 'Xi ', 'Xi ', 'Yao ', 'Feng ', 'Tan ', '[?] ', 'Biao ', 'Fu ', 'Ba ', 'He ', 'Ji ', 'Ji ', 'Jian ', 'Guan ', 'Bian ', 'Yan ', 'Gui ', 'Jue ', 'Pian ', 'Mao ', 'Mi ', 'Mi ', 'Mie ', 'Shi ', 'Si ', 'Zhan ', 'Luo ', 'Jue ', 'Mi ', 'Tiao ', 'Lian ', 'Yao ', 'Zhi ', 'Jun ', 'Xi ', 'Shan ', 'Wei ', 'Xi ', 'Tian ', 'Yu ', 'Lan ', 'E ', 'Du ', 'Qin ', 'Pang ', 'Ji ', 'Ming ', 'Ying ', 'Gou ', 'Qu ', 'Zhan ', 'Jin ', 'Guan ', 'Deng ', 'Jian ', 'Luo ', 'Qu ', 'Jian ', 'Wei ', 'Jue ', 'Qu ', 'Luo ', 'Lan ', 'Shen ', 'Di ', 'Guan ', 'Jian ', 'Guan ', 'Yan ', 'Gui ', 'Mi ', 'Shi ', 'Zhan ', 'Lan ', 'Jue ', 'Ji ', 'Xi ', 'Di ', 'Tian ', 'Yu ', 'Gou ', 'Jin ', 'Qu ', 'Jiao ', 'Jiu ', 'Jin ', 'Cu ', 'Jue ', 'Zhi ', 'Chao ', 'Ji ', 'Gu ', 'Dan ', 'Zui ', 'Di ', 'Shang ', 'Hua ', 'Quan ', 'Ge ', 'Chi ', 'Jie ', 'Gui ', 'Gong ', 'Hong ', 'Jie ', 'Hun ', 'Qiu ', 'Xing ', 'Su ', 'Ni ', 'Ji ', 'Lu ', 'Zhi ', 'Zha ', 'Bi ', 'Xing ', 'Hu ', 'Shang ', 'Gong ', 'Zhi ', 'Xue ', 'Chu ', 'Xi ', 'Yi ', 'Lu ', 'Jue ', 'Xi ', 'Yan ', 'Xi ']


Joomla CMS: Référence du fichier ParseException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ParseException.php

Structures de données

class ParseException

Espaces de nommage

Symfony\Component\Yaml\Exception


Joomla CMS: Référence du fichier Poly1305.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/Poly1305.php

Structures de données

class ParagonIE_Sodium_Core_Poly1305


Joomla CMS: Référence du fichier UpdatesiteTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier UpdatesiteTable.php

Structures de données

class UpdatesiteTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Table


Joomla CMS: Référence du fichier WebApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/application/src/WebApplication.php

Structures de données

class WebApplication

Espaces de nommage

Joomla\Application


Joomla CMS: Référence du fichier PKCS8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier Common/Formats/Keys/PKCS8.php

Structures de données

class PKCS8

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Keys


Joomla CMS: Référence du fichier StringController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
  • Support
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Support/StringController.php

Structures de données

class StringController

Espaces de nommage

Joomla\Filesystem\Support


Joomla CMS: Référence du fichier RouterFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier Component/Router/RouterFactory.php

Structures de données

class RouterFactory

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier UuidInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier UuidInterface.php

Structures de données

interface UuidInterface

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier Uri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/laminas/laminas-diactoros/src/Uri.php

Structures de données

class Uri

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier UserIdRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier UserIdRule.php

Structures de données

class UserIdRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier RouterFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Extension/Service/Provider/RouterFactory.php

Structures de données

class RouterFactory

Espaces de nommage

Joomla\CMS\Extension\Service\Provider


Joomla CMS: Référence du fichier WebcronLinkField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier WebcronLinkField.php

Structures de données

class WebcronLinkField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier UsergrouplistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier UsergrouplistField.php

Structures de données

class UsergrouplistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Unescaper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier Unescaper.php

Structures de données

class Unescaper

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier x084.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x084.php

Variables

return ['Hu ', 'Qi ', 'He ', 'Cui ', 'Tao ', 'Chun ', 'Bei ', 'Chang ', 'Huan ', 'Fei ', 'Lai ', 'Qi ', 'Meng ', 'Ping ', 'Wei ', 'Dan ', 'Sha ', 'Huan ', 'Yan ', 'Yi ', 'Tiao ', 'Qi ', 'Wan ', 'Ce ', 'Nai ', 'Kutabireru ', 'Tuo ', 'Jiu ', 'Tie ', 'Luo ', '[?] ', '[?] ', 'Meng ', '[?] ', 'Yaji ', '[?] ', 'Ying ', 'Ying ', 'Ying ', 'Xiao ', 'Sa ', 'Qiu ', 'Ke ', 'Xiang ', 'Wan ', 'Yu ', 'Yu ', 'Fu ', 'Lian ', 'Xuan ', 'Yuan ', 'Nan ', 'Ze ', 'Wo ', 'Chun ', 'Xiao ', 'Yu ', 'Pian ', 'Mao ', 'An ', 'E ', 'Luo ', 'Ying ', 'Huo ', 'Gua ', 'Jiang ', 'Mian ', 'Zuo ', 'Zuo ', 'Ju ', 'Bao ', 'Rou ', 'Xi ', 'Xie ', 'An ', 'Qu ', 'Jian ', 'Fu ', 'Lu ', 'Jing ', 'Pen ', 'Feng ', 'Hong ', 'Hong ', 'Hou ', 'Yan ', 'Tu ', 'Zhu ', 'Zi ', 'Xiang ', 'Shen ', 'Ge ', 'Jie ', 'Jing ', 'Mi ', 'Huang ', 'Shen ', 'Pu ', 'Gai ', 'Dong ', 'Zhou ', 'Qian ', 'Wei ', 'Bo ', 'Wei ', 'Pa ', 'Ji ', 'Hu ', 'Zang ', 'Jia ', 'Duan ', 'Yao ', 'Jun ', 'Cong ', 'Quan ', 'Wei ', 'Xian ', 'Kui ', 'Ting ', 'Hun ', 'Xi ', 'Shi ', 'Qi ', 'Lan ', 'Zong ', 'Yao ', 'Yuan ', 'Mei ', 'Yun ', 'Shu ', 'Di ', 'Zhuan ', 'Guan ', 'Sukumo ', 'Xue ', 'Chan ', 'Kai ', 'Kui ', '[?] ', 'Jiang ', 'Lou ', 'Wei ', 'Pai ', '[?] ', 'Sou ', 'Yin ', 'Shi ', 'Chun ', 'Shi ', 'Yun ', 'Zhen ', 'Lang ', 'Nu ', 'Meng ', 'He ', 'Que ', 'Suan ', 'Yuan ', 'Li ', 'Ju ', 'Xi ', 'Pang ', 'Chu ', 'Xu ', 'Tu ', 'Liu ', 'Wo ', 'Zhen ', 'Qian ', 'Zu ', 'Po ', 'Cuo ', 'Yuan ', 'Chu ', 'Yu ', 'Kuai ', 'Pan ', 'Pu ', 'Pu ', 'Na ', 'Shuo ', 'Xi ', 'Fen ', 'Yun ', 'Zheng ', 'Jian ', 'Ji ', 'Ruo ', 'Cang ', 'En ', 'Mi ', 'Hao ', 'Sun ', 'Zhen ', 'Ming ', 'Sou ', 'Xu ', 'Liu ', 'Xi ', 'Gu ', 'Lang ', 'Rong ', 'Weng ', 'Gai ', 'Cuo ', 'Shi ', 'Tang ', 'Luo ', 'Ru ', 'Suo ', 'Xian ', 'Bei ', 'Yao ', 'Gui ', 'Bi ', 'Zong ', 'Gun ', 'Za ', 'Xiu ', 'Ce ', 'Hai ', 'Lan ', '[?] ', 'Ji ', 'Li ', 'Can ', 'Lang ', 'Yu ', '[?] ', 'Ying ', 'Mo ', 'Diao ', 'Tiao ', 'Mao ', 'Tong ', 'Zhu ', 'Peng ', 'An ', 'Lian ', 'Cong ', 'Xi ', 'Ping ', 'Qiu ', 'Jin ', 'Chun ', 'Jie ', 'Wei ', 'Tui ', 'Cao ', 'Yu ', 'Yi ', 'Ji ', 'Liao ', 'Bi ', 'Lu ', 'Su ']

Documentation des variables

◆ return

return[ 'Hu ', 'Qi ', 'He ', 'Cui ', 'Tao ', 'Chun ', 'Bei ', 'Chang ', 'Huan ', 'Fei ', 'Lai ', 'Qi ', 'Meng ', 'Ping ', 'Wei ', 'Dan ', 'Sha ', 'Huan ', 'Yan ', 'Yi ', 'Tiao ', 'Qi ', 'Wan ', 'Ce ', 'Nai ', 'Kutabireru ', 'Tuo ', 'Jiu ', 'Tie ', 'Luo ', '[?] ', '[?] ', 'Meng ', '[?] ', 'Yaji ', '[?] ', 'Ying ', 'Ying ', 'Ying ', 'Xiao ', 'Sa ', 'Qiu ', 'Ke ', 'Xiang ', 'Wan ', 'Yu ', 'Yu ', 'Fu ', 'Lian ', 'Xuan ', 'Yuan ', 'Nan ', 'Ze ', 'Wo ', 'Chun ', 'Xiao ', 'Yu ', 'Pian ', 'Mao ', 'An ', 'E ', 'Luo ', 'Ying ', 'Huo ', 'Gua ', 'Jiang ', 'Mian ', 'Zuo ', 'Zuo ', 'Ju ', 'Bao ', 'Rou ', 'Xi ', 'Xie ', 'An ', 'Qu ', 'Jian ', 'Fu ', 'Lu ', 'Jing ', 'Pen ', 'Feng ', 'Hong ', 'Hong ', 'Hou ', 'Yan ', 'Tu ', 'Zhu ', 'Zi ', 'Xiang ', 'Shen ', 'Ge ', 'Jie ', 'Jing ', 'Mi ', 'Huang ', 'Shen ', 'Pu ', 'Gai ', 'Dong ', 'Zhou ', 'Qian ', 'Wei ', 'Bo ', 'Wei ', 'Pa ', 'Ji ', 'Hu ', 'Zang ', 'Jia ', 'Duan ', 'Yao ', 'Jun ', 'Cong ', 'Quan ', 'Wei ', 'Xian ', 'Kui ', 'Ting ', 'Hun ', 'Xi ', 'Shi ', 'Qi ', 'Lan ', 'Zong ', 'Yao ', 'Yuan ', 'Mei ', 'Yun ', 'Shu ', 'Di ', 'Zhuan ', 'Guan ', 'Sukumo ', 'Xue ', 'Chan ', 'Kai ', 'Kui ', '[?] ', 'Jiang ', 'Lou ', 'Wei ', 'Pai ', '[?] ', 'Sou ', 'Yin ', 'Shi ', 'Chun ', 'Shi ', 'Yun ', 'Zhen ', 'Lang ', 'Nu ', 'Meng ', 'He ', 'Que ', 'Suan ', 'Yuan ', 'Li ', 'Ju ', 'Xi ', 'Pang ', 'Chu ', 'Xu ', 'Tu ', 'Liu ', 'Wo ', 'Zhen ', 'Qian ', 'Zu ', 'Po ', 'Cuo ', 'Yuan ', 'Chu ', 'Yu ', 'Kuai ', 'Pan ', 'Pu ', 'Pu ', 'Na ', 'Shuo ', 'Xi ', 'Fen ', 'Yun ', 'Zheng ', 'Jian ', 'Ji ', 'Ruo ', 'Cang ', 'En ', 'Mi ', 'Hao ', 'Sun ', 'Zhen ', 'Ming ', 'Sou ', 'Xu ', 'Liu ', 'Xi ', 'Gu ', 'Lang ', 'Rong ', 'Weng ', 'Gai ', 'Cuo ', 'Shi ', 'Tang ', 'Luo ', 'Ru ', 'Suo ', 'Xian ', 'Bei ', 'Yao ', 'Gui ', 'Bi ', 'Zong ', 'Gun ', 'Za ', 'Xiu ', 'Ce ', 'Hai ', 'Lan ', '[?] ', 'Ji ', 'Li ', 'Can ', 'Lang ', 'Yu ', '[?] ', 'Ying ', 'Mo ', 'Diao ', 'Tiao ', 'Mao ', 'Tong ', 'Zhu ', 'Peng ', 'An ', 'Lian ', 'Cong ', 'Xi ', 'Ping ', 'Qiu ', 'Jin ', 'Chun ', 'Jie ', 'Wei ', 'Tui ', 'Cao ', 'Yu ', 'Yi ', 'Ji ', 'Liao ', 'Bi ', 'Lu ', 'Su ']


Joomla CMS: Référence du fichier sect283k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect283k1.php

Structures de données

class sect283k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier PKCS.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier PKCS.php

Structures de données

class PKCS

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Keys
RSA


Joomla CMS: Référence du fichier x026.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x026.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '#', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '#', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier SpecifiedECDomain.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SpecifiedECDomain.php

Structures de données

class SpecifiedECDomain

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier readonly.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • tmpl
  • template
Espaces de nommage | Variables
Référence du fichier readonly.php

Espaces de nommage

Joomla\Administrator

Variables

$input = Factory::getApplication()->input

Documentation des variables

◆ $input

$input = Factory::getApplication()->input


Joomla CMS: Référence du fichier PgsqlQuery.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pgsql
Structures de données | Espaces de nommage
Référence du fichier PgsqlQuery.php

Structures de données

class PgsqlQuery

Espaces de nommage

Joomla\Database\Pgsql


Joomla CMS: Référence du fichier WebAssetRegistryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetRegistryInterface.php

Structures de données

interface WebAssetRegistryInterface

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier ValidationData.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier ValidationData.php

Structures de données

class ValidationData

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier ProxyManagerCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier ProxyManagerCaster.php

Structures de données

class ProxyManagerCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Serializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Response/Serializer.php

Structures de données

class Serializer

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier UTCTime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier UTCTime.php

Structures de données

class UTCTime

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier PreloadManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier PreloadManager.php

Structures de données

class PreloadManager

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier Socket.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Transport
Structures de données | Espaces de nommage
Référence du fichier joomla/http/src/Transport/Socket.php

Structures de données

class Socket

Espaces de nommage

Joomla\Http\Transport


Joomla CMS: Référence du fichier WincacheStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier WincacheStorage.php

Structures de données

class WincacheStorage

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier WorkflowPluginTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Workflow
Espaces de nommage
Référence du fichier WorkflowPluginTrait.php

Espaces de nommage

Joomla\CMS\Workflow


Joomla CMS: Référence du fichier x085.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x085.php

Variables

return ['Bu ', 'Zhang ', 'Luo ', 'Jiang ', 'Man ', 'Yan ', 'Ling ', 'Ji ', 'Piao ', 'Gun ', 'Han ', 'Di ', 'Su ', 'Lu ', 'She ', 'Shang ', 'Di ', 'Mie ', 'Xun ', 'Man ', 'Bo ', 'Di ', 'Cuo ', 'Zhe ', 'Sen ', 'Xuan ', 'Wei ', 'Hu ', 'Ao ', 'Mi ', 'Lou ', 'Cu ', 'Zhong ', 'Cai ', 'Po ', 'Jiang ', 'Mi ', 'Cong ', 'Niao ', 'Hui ', 'Jun ', 'Yin ', 'Jian ', 'Yan ', 'Shu ', 'Yin ', 'Kui ', 'Chen ', 'Hu ', 'Sha ', 'Kou ', 'Qian ', 'Ma ', 'Zang ', 'Sonoko ', 'Qiang ', 'Dou ', 'Lian ', 'Lin ', 'Kou ', 'Ai ', 'Bi ', 'Li ', 'Wei ', 'Ji ', 'Xun ', 'Sheng ', 'Fan ', 'Meng ', 'Ou ', 'Chan ', 'Dian ', 'Xun ', 'Jiao ', 'Rui ', 'Rui ', 'Lei ', 'Yu ', 'Qiao ', 'Chu ', 'Hua ', 'Jian ', 'Mai ', 'Yun ', 'Bao ', 'You ', 'Qu ', 'Lu ', 'Rao ', 'Hui ', 'E ', 'Teng ', 'Fei ', 'Jue ', 'Zui ', 'Fa ', 'Ru ', 'Fen ', 'Kui ', 'Shun ', 'Rui ', 'Ya ', 'Xu ', 'Fu ', 'Jue ', 'Dang ', 'Wu ', 'Tong ', 'Si ', 'Xiao ', 'Xi ', 'Long ', 'Yun ', '[?] ', 'Qi ', 'Jian ', 'Yun ', 'Sun ', 'Ling ', 'Yu ', 'Xia ', 'Yong ', 'Ji ', 'Hong ', 'Si ', 'Nong ', 'Lei ', 'Xuan ', 'Yun ', 'Yu ', 'Xi ', 'Hao ', 'Bo ', 'Hao ', 'Ai ', 'Wei ', 'Hui ', 'Wei ', 'Ji ', 'Ci ', 'Xiang ', 'Luan ', 'Mie ', 'Yi ', 'Leng ', 'Jiang ', 'Can ', 'Shen ', 'Qiang ', 'Lian ', 'Ke ', 'Yuan ', 'Da ', 'Ti ', 'Tang ', 'Xie ', 'Bi ', 'Zhan ', 'Sun ', 'Lian ', 'Fan ', 'Ding ', 'Jie ', 'Gu ', 'Xie ', 'Shu ', 'Jian ', 'Kao ', 'Hong ', 'Sa ', 'Xin ', 'Xun ', 'Yao ', 'Hie ', 'Sou ', 'Shu ', 'Xun ', 'Dui ', 'Pin ', 'Wei ', 'Neng ', 'Chou ', 'Mai ', 'Ru ', 'Piao ', 'Tai ', 'Qi ', 'Zao ', 'Chen ', 'Zhen ', 'Er ', 'Ni ', 'Ying ', 'Gao ', 'Cong ', 'Xiao ', 'Qi ', 'Fa ', 'Jian ', 'Xu ', 'Kui ', 'Jie ', 'Bian ', 'Diao ', 'Mi ', 'Lan ', 'Jin ', 'Cang ', 'Miao ', 'Qiong ', 'Qie ', 'Xian ', '[?] ', 'Ou ', 'Xian ', 'Su ', 'Lu ', 'Yi ', 'Xu ', 'Xie ', 'Li ', 'Yi ', 'La ', 'Lei ', 'Xiao ', 'Di ', 'Zhi ', 'Bei ', 'Teng ', 'Yao ', 'Mo ', 'Huan ', 'Piao ', 'Fan ', 'Sou ', 'Tan ', 'Tui ', 'Qiong ', 'Qiao ', 'Wei ', 'Liu ', 'Hui ', '[?] ', 'Gao ', 'Yun ', '[?] ', 'Li ', 'Shu ', 'Chu ', 'Ai ', 'Lin ', 'Zao ', 'Xuan ', 'Chen ', 'Lai ', 'Huo ']

Documentation des variables

◆ return

return[ 'Bu ', 'Zhang ', 'Luo ', 'Jiang ', 'Man ', 'Yan ', 'Ling ', 'Ji ', 'Piao ', 'Gun ', 'Han ', 'Di ', 'Su ', 'Lu ', 'She ', 'Shang ', 'Di ', 'Mie ', 'Xun ', 'Man ', 'Bo ', 'Di ', 'Cuo ', 'Zhe ', 'Sen ', 'Xuan ', 'Wei ', 'Hu ', 'Ao ', 'Mi ', 'Lou ', 'Cu ', 'Zhong ', 'Cai ', 'Po ', 'Jiang ', 'Mi ', 'Cong ', 'Niao ', 'Hui ', 'Jun ', 'Yin ', 'Jian ', 'Yan ', 'Shu ', 'Yin ', 'Kui ', 'Chen ', 'Hu ', 'Sha ', 'Kou ', 'Qian ', 'Ma ', 'Zang ', 'Sonoko ', 'Qiang ', 'Dou ', 'Lian ', 'Lin ', 'Kou ', 'Ai ', 'Bi ', 'Li ', 'Wei ', 'Ji ', 'Xun ', 'Sheng ', 'Fan ', 'Meng ', 'Ou ', 'Chan ', 'Dian ', 'Xun ', 'Jiao ', 'Rui ', 'Rui ', 'Lei ', 'Yu ', 'Qiao ', 'Chu ', 'Hua ', 'Jian ', 'Mai ', 'Yun ', 'Bao ', 'You ', 'Qu ', 'Lu ', 'Rao ', 'Hui ', 'E ', 'Teng ', 'Fei ', 'Jue ', 'Zui ', 'Fa ', 'Ru ', 'Fen ', 'Kui ', 'Shun ', 'Rui ', 'Ya ', 'Xu ', 'Fu ', 'Jue ', 'Dang ', 'Wu ', 'Tong ', 'Si ', 'Xiao ', 'Xi ', 'Long ', 'Yun ', '[?] ', 'Qi ', 'Jian ', 'Yun ', 'Sun ', 'Ling ', 'Yu ', 'Xia ', 'Yong ', 'Ji ', 'Hong ', 'Si ', 'Nong ', 'Lei ', 'Xuan ', 'Yun ', 'Yu ', 'Xi ', 'Hao ', 'Bo ', 'Hao ', 'Ai ', 'Wei ', 'Hui ', 'Wei ', 'Ji ', 'Ci ', 'Xiang ', 'Luan ', 'Mie ', 'Yi ', 'Leng ', 'Jiang ', 'Can ', 'Shen ', 'Qiang ', 'Lian ', 'Ke ', 'Yuan ', 'Da ', 'Ti ', 'Tang ', 'Xie ', 'Bi ', 'Zhan ', 'Sun ', 'Lian ', 'Fan ', 'Ding ', 'Jie ', 'Gu ', 'Xie ', 'Shu ', 'Jian ', 'Kao ', 'Hong ', 'Sa ', 'Xin ', 'Xun ', 'Yao ', 'Hie ', 'Sou ', 'Shu ', 'Xun ', 'Dui ', 'Pin ', 'Wei ', 'Neng ', 'Chou ', 'Mai ', 'Ru ', 'Piao ', 'Tai ', 'Qi ', 'Zao ', 'Chen ', 'Zhen ', 'Er ', 'Ni ', 'Ying ', 'Gao ', 'Cong ', 'Xiao ', 'Qi ', 'Fa ', 'Jian ', 'Xu ', 'Kui ', 'Jie ', 'Bian ', 'Diao ', 'Mi ', 'Lan ', 'Jin ', 'Cang ', 'Miao ', 'Qiong ', 'Qie ', 'Xian ', '[?] ', 'Ou ', 'Xian ', 'Su ', 'Lu ', 'Yi ', 'Xu ', 'Xie ', 'Li ', 'Yi ', 'La ', 'Lei ', 'Xiao ', 'Di ', 'Zhi ', 'Bei ', 'Teng ', 'Yao ', 'Mo ', 'Huan ', 'Piao ', 'Fan ', 'Sou ', 'Tan ', 'Tui ', 'Qiong ', 'Qiao ', 'Wei ', 'Liu ', 'Hui ', '[?] ', 'Gao ', 'Yun ', '[?] ', 'Li ', 'Shu ', 'Chu ', 'Ai ', 'Lin ', 'Zao ', 'Xuan ', 'Chen ', 'Lai ', 'Huo ']


Joomla CMS: Référence du fichier SlimCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier SlimCollector.php

Structures de données

class SlimCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier Registry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/registry/src/Registry.php

Structures de données

class Registry

Espaces de nommage

Joomla\Registry


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/http/src/Response.php

Structures de données

class Response

Espaces de nommage

Joomla\Http


Joomla CMS: Référence du fichier radio.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • radio
Structures de données | Espaces de nommage
Référence du fichier radio.php

Structures de données

class PlgFieldsRadio

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier svg-scanner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
Fonctions | Variables
Référence du fichier svg-scanner.php

Fonctions

sysexit ( $results, $status)

Variables

global | $argv
$results
$files_to_scan = $argv
if(empty( $files_to_scan)) | $sanitizer = new enshrined\svgSanitize\Sanitizer()

Documentation des fonctions

◆ sysexit()

sysexit | ( | $results,
 |  | $status
 | ) |

Références $results.

Documentation des variables

◆ $argv

global $argv

Référencé par ArgvInput\__construct(), et Cli\parseArguments().

◆ $files_to_scan

$files_to_scan = $argv

◆ $results

$results
Valeur initiale :
= array(
'totals' => array(
'errors' => 0,
),
'files' => array(
),
)

Référencé par sysexit().

◆ $sanitizer

if (empty($files_to_scan)) $sanitizer = new enshrined\svgSanitize\Sanitizer()

Référencé par MediaHelper\canUpload().


Joomla CMS: Référence du fichier XmlResourceCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier XmlResourceCaster.php

Structures de données

class XmlResourceCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier PSSRSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier PSSRSA.php

Structures de données

class PSSRSA

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier UploadedFile.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier nyholm/psr7/src/UploadedFile.php

Structures de données

class UploadedFile

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier Precomp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core32/Curve25519/Ge/Precomp.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Ge_Precomp


Joomla CMS: Référence du fichier UnwritableStreamException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnwritableStreamException.php

Structures de données

class UnwritableStreamException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier P3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core32/Curve25519/Ge/P3.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Ge_P3


Joomla CMS: Référence du fichier Token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Token.php

Structures de données

class Token

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier Psr17Factory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
  • Factory
Structures de données | Espaces de nommage
Référence du fichier Psr17Factory.php

Structures de données

class Psr17Factory

Espaces de nommage

Nyholm\Psr7\Factory


Joomla CMS: Référence du fichier secp160k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp160k1.php

Structures de données

class secp160k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier TagField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TagField.php

Structures de données

class TagField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier sessiongc.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • sessiongc
Structures de données | Espaces de nommage
Référence du fichier sessiongc.php

Structures de données

class PlgSystemSessionGc

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/NorwegianBokmal/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\NorwegianBokmal


Joomla CMS: Référence du fichier x0fa.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0fa.php

Variables

return ['Chey ', 'Thak ', 'Thak ', 'Thang ', 'Thayk ', 'Thong ', 'Pho ', 'Phok ', 'Hang ', 'Hang ', 'Hyen ', 'Hwak ', 'Wu ', 'Huo ', '[?] ', '[?] ', 'Zhong ', '[?] ', 'Qing ', '[?] ', '[?] ', 'Xi ', 'Zhu ', 'Yi ', 'Li ', 'Shen ', 'Xiang ', 'Fu ', 'Jing ', 'Jing ', 'Yu ', '[?] ', 'Hagi ', '[?] ', 'Zhu ', '[?] ', '[?] ', 'Yi ', 'Du ', '[?] ', '[?] ', '[?] ', 'Fan ', 'Si ', 'Guan ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'Chey ', 'Thak ', 'Thak ', 'Thang ', 'Thayk ', 'Thong ', 'Pho ', 'Phok ', 'Hang ', 'Hang ', 'Hyen ', 'Hwak ', 'Wu ', 'Huo ', '[?] ', '[?] ', 'Zhong ', '[?] ', 'Qing ', '[?] ', '[?] ', 'Xi ', 'Zhu ', 'Yi ', 'Li ', 'Shen ', 'Xiang ', 'Fu ', 'Jing ', 'Jing ', 'Yu ', '[?] ', 'Hagi ', '[?] ', 'Zhu ', '[?] ', '[?] ', 'Yi ', 'Du ', '[?] ', '[?] ', '[?] ', 'Fan ', 'Si ', 'Guan ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier Parsable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier Parsable.php

Structures de données

interface Parsable

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier PublicKeyCredentialDescriptorCollection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialDescriptorCollection.php

Structures de données

class PublicKeyCredentialDescriptorCollection

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier PublicKeyCredentialSourceRepository.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialSourceRepository.php

Structures de données

interface PublicKeyCredentialSourceRepository

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier PrivacyDashboardHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_dashboard
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PrivacyDashboardHelper.php

Structures de données

class PrivacyDashboardHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\PrivacyDashboard\Administrator\Helper


Joomla CMS: Référence du fichier SplCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier SplCaster.php

Structures de données

class SplCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier parser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier parser.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier PHP64.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier PHP64.php

Structures de données

class PHP64

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
PHP


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_scheduler/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/Portuguese/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\Portuguese


Joomla CMS: Référence du fichier ResetInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Structures de données | Espaces de nommage
Référence du fichier ResetInterface.php

Structures de données

interface ResetInterface

Espaces de nommage

Symfony\Contracts\Service


Joomla CMS: Référence du fichier PublicKeyCredential.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredential.php

Structures de données

class PublicKeyCredential

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier RS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/RS512.php

Structures de données

class RS512

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier TaggableTableTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Espaces de nommage | Fonctions | Variables
Référence du fichier TaggableTableTrait.php

Espaces de nommage

Joomla\CMS\Tag

Fonctions

getTagsHelper ()
setTagsHelper (TagsHelper $tagsHelper)
clearTagsHelper ()

Variables

trait TaggableTableTrait


Joomla CMS: Référence du fichier x093.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x093.php

Variables

return ['Lun ', 'Kua ', 'Ling ', 'Bei ', 'Lu ', 'Li ', 'Qiang ', 'Pou ', 'Juan ', 'Min ', 'Zui ', 'Peng ', 'An ', 'Pi ', 'Xian ', 'Ya ', 'Zhui ', 'Lei ', 'A ', 'Kong ', 'Ta ', 'Kun ', 'Du ', 'Wei ', 'Chui ', 'Zi ', 'Zheng ', 'Ben ', 'Nie ', 'Cong ', 'Qun ', 'Tan ', 'Ding ', 'Qi ', 'Qian ', 'Zhuo ', 'Qi ', 'Yu ', 'Jin ', 'Guan ', 'Mao ', 'Chang ', 'Tian ', 'Xi ', 'Lian ', 'Tao ', 'Gu ', 'Cuo ', 'Shu ', 'Zhen ', 'Lu ', 'Meng ', 'Lu ', 'Hua ', 'Biao ', 'Ga ', 'Lai ', 'Ken ', 'Kazari ', 'Bu ', 'Nai ', 'Wan ', 'Zan ', '[?] ', 'De ', 'Xian ', '[?] ', 'Huo ', 'Liang ', '[?] ', 'Men ', 'Kai ', 'Ying ', 'Di ', 'Lian ', 'Guo ', 'Xian ', 'Du ', 'Tu ', 'Wei ', 'Cong ', 'Fu ', 'Rou ', 'Ji ', 'E ', 'Rou ', 'Chen ', 'Ti ', 'Zha ', 'Hong ', 'Yang ', 'Duan ', 'Xia ', 'Yu ', 'Keng ', 'Xing ', 'Huang ', 'Wei ', 'Fu ', 'Zhao ', 'Cha ', 'Qie ', 'She ', 'Hong ', 'Kui ', 'Tian ', 'Mou ', 'Qiao ', 'Qiao ', 'Hou ', 'Tou ', 'Cong ', 'Huan ', 'Ye ', 'Min ', 'Jian ', 'Duan ', 'Jian ', 'Song ', 'Kui ', 'Hu ', 'Xuan ', 'Duo ', 'Jie ', 'Zhen ', 'Bian ', 'Zhong ', 'Zi ', 'Xiu ', 'Ye ', 'Mei ', 'Pai ', 'Ai ', 'Jie ', '[?] ', 'Mei ', 'Chuo ', 'Ta ', 'Bang ', 'Xia ', 'Lian ', 'Suo ', 'Xi ', 'Liu ', 'Zu ', 'Ye ', 'Nou ', 'Weng ', 'Rong ', 'Tang ', 'Suo ', 'Qiang ', 'Ge ', 'Shuo ', 'Chui ', 'Bo ', 'Pan ', 'Sa ', 'Bi ', 'Sang ', 'Gang ', 'Zi ', 'Wu ', 'Ying ', 'Huang ', 'Tiao ', 'Liu ', 'Kai ', 'Sun ', 'Sha ', 'Sou ', 'Wan ', 'Hao ', 'Zhen ', 'Zhen ', 'Luo ', 'Yi ', 'Yuan ', 'Tang ', 'Nie ', 'Xi ', 'Jia ', 'Ge ', 'Ma ', 'Juan ', 'Kasugai ', 'Habaki ', 'Suo ', '[?] ', '[?] ', '[?] ', 'Na ', 'Lu ', 'Suo ', 'Ou ', 'Zu ', 'Tuan ', 'Xiu ', 'Guan ', 'Xuan ', 'Lian ', 'Shou ', 'Ao ', 'Man ', 'Mo ', 'Luo ', 'Bi ', 'Wei ', 'Liu ', 'Di ', 'Qiao ', 'Cong ', 'Yi ', 'Lu ', 'Ao ', 'Keng ', 'Qiang ', 'Cui ', 'Qi ', 'Chang ', 'Tang ', 'Man ', 'Yong ', 'Chan ', 'Feng ', 'Jing ', 'Biao ', 'Shu ', 'Lou ', 'Xiu ', 'Cong ', 'Long ', 'Zan ', 'Jian ', 'Cao ', 'Li ', 'Xia ', 'Xi ', 'Kang ', '[?] ', 'Beng ', '[?] ', '[?] ', 'Zheng ', 'Lu ', 'Hua ', 'Ji ', 'Pu ', 'Hui ', 'Qiang ', 'Po ', 'Lin ', 'Suo ', 'Xiu ', 'San ', 'Cheng ']

Documentation des variables

◆ return

return[ 'Lun ', 'Kua ', 'Ling ', 'Bei ', 'Lu ', 'Li ', 'Qiang ', 'Pou ', 'Juan ', 'Min ', 'Zui ', 'Peng ', 'An ', 'Pi ', 'Xian ', 'Ya ', 'Zhui ', 'Lei ', 'A ', 'Kong ', 'Ta ', 'Kun ', 'Du ', 'Wei ', 'Chui ', 'Zi ', 'Zheng ', 'Ben ', 'Nie ', 'Cong ', 'Qun ', 'Tan ', 'Ding ', 'Qi ', 'Qian ', 'Zhuo ', 'Qi ', 'Yu ', 'Jin ', 'Guan ', 'Mao ', 'Chang ', 'Tian ', 'Xi ', 'Lian ', 'Tao ', 'Gu ', 'Cuo ', 'Shu ', 'Zhen ', 'Lu ', 'Meng ', 'Lu ', 'Hua ', 'Biao ', 'Ga ', 'Lai ', 'Ken ', 'Kazari ', 'Bu ', 'Nai ', 'Wan ', 'Zan ', '[?] ', 'De ', 'Xian ', '[?] ', 'Huo ', 'Liang ', '[?] ', 'Men ', 'Kai ', 'Ying ', 'Di ', 'Lian ', 'Guo ', 'Xian ', 'Du ', 'Tu ', 'Wei ', 'Cong ', 'Fu ', 'Rou ', 'Ji ', 'E ', 'Rou ', 'Chen ', 'Ti ', 'Zha ', 'Hong ', 'Yang ', 'Duan ', 'Xia ', 'Yu ', 'Keng ', 'Xing ', 'Huang ', 'Wei ', 'Fu ', 'Zhao ', 'Cha ', 'Qie ', 'She ', 'Hong ', 'Kui ', 'Tian ', 'Mou ', 'Qiao ', 'Qiao ', 'Hou ', 'Tou ', 'Cong ', 'Huan ', 'Ye ', 'Min ', 'Jian ', 'Duan ', 'Jian ', 'Song ', 'Kui ', 'Hu ', 'Xuan ', 'Duo ', 'Jie ', 'Zhen ', 'Bian ', 'Zhong ', 'Zi ', 'Xiu ', 'Ye ', 'Mei ', 'Pai ', 'Ai ', 'Jie ', '[?] ', 'Mei ', 'Chuo ', 'Ta ', 'Bang ', 'Xia ', 'Lian ', 'Suo ', 'Xi ', 'Liu ', 'Zu ', 'Ye ', 'Nou ', 'Weng ', 'Rong ', 'Tang ', 'Suo ', 'Qiang ', 'Ge ', 'Shuo ', 'Chui ', 'Bo ', 'Pan ', 'Sa ', 'Bi ', 'Sang ', 'Gang ', 'Zi ', 'Wu ', 'Ying ', 'Huang ', 'Tiao ', 'Liu ', 'Kai ', 'Sun ', 'Sha ', 'Sou ', 'Wan ', 'Hao ', 'Zhen ', 'Zhen ', 'Luo ', 'Yi ', 'Yuan ', 'Tang ', 'Nie ', 'Xi ', 'Jia ', 'Ge ', 'Ma ', 'Juan ', 'Kasugai ', 'Habaki ', 'Suo ', '[?] ', '[?] ', '[?] ', 'Na ', 'Lu ', 'Suo ', 'Ou ', 'Zu ', 'Tuan ', 'Xiu ', 'Guan ', 'Xuan ', 'Lian ', 'Shou ', 'Ao ', 'Man ', 'Mo ', 'Luo ', 'Bi ', 'Wei ', 'Liu ', 'Di ', 'Qiao ', 'Cong ', 'Yi ', 'Lu ', 'Ao ', 'Keng ', 'Qiang ', 'Cui ', 'Qi ', 'Chang ', 'Tang ', 'Man ', 'Yong ', 'Chan ', 'Feng ', 'Jing ', 'Biao ', 'Shu ', 'Lou ', 'Xiu ', 'Cong ', 'Long ', 'Zan ', 'Jian ', 'Cao ', 'Li ', 'Xia ', 'Xi ', 'Kang ', '[?] ', 'Beng ', '[?] ', '[?] ', 'Zheng ', 'Lu ', 'Hua ', 'Ji ', 'Pu ', 'Hui ', 'Qiang ', 'Po ', 'Lin ', 'Suo ', 'Xiu ', 'San ', 'Cheng ']


Joomla CMS: Référence du fichier UnsatisfiedDependencyException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier vendor/ramsey/uuid/src/Exception/UnsatisfiedDependencyException.php

Structures de données

class UnsatisfiedDependencyException

Espaces de nommage

Ramsey\Uuid\Exception


Joomla CMS: Référence du fichier TagServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Espaces de nommage
Référence du fichier TagServiceTrait.php

Espaces de nommage

Joomla\CMS\Tag


Joomla CMS: Référence du fichier PdoStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Structures de données | Espaces de nommage
Référence du fichier PdoStorage.php

Structures de données

class PdoStorage

Espaces de nommage

DebugBar\Storage


Joomla CMS: Référence du fichier Relations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Structures de données | Espaces de nommage
Référence du fichier Relations.php

Structures de données

interface Relations

Espaces de nommage

Fig\Link


Joomla CMS: Référence du fichier Raw.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Signature/Raw.php

Structures de données

class Raw

Espaces de nommage

DSA
phpseclib3\Crypt\EC\Formats\Signature
EC


Joomla CMS: Référence du fichier SitePathway.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pathway
Structures de données | Espaces de nommage
Référence du fichier SitePathway.php

Structures de données

class SitePathway

Espaces de nommage

Joomla\CMS\Pathway


Joomla CMS: Référence du fichier Uri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/uri/src/Uri.php

Structures de données

class Uri

Espaces de nommage

Joomla\Uri


Joomla CMS: Référence du fichier x000.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x000.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', ' ', '!', '"', '#', '$', '%', '&', '\, '(', ')', '*', '+', ',', '-', '.', '/', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', ':', ';', '<', '=', '>', '?', '@', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', '[', '\, ']', '^', '_', '`', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '{', '|', '}', '~', '', 'EUR', '', ',', 'f', ',,', '...', '+', '++', '^', '%0', 'S', '<', 'OE', '', 'Z', '', '', '\, '\, '"', '"', '*', '-', '--', '~', 'tm', 's', '>', 'oe', '', 'z', 'Y', ' ', '!', 'C/', 'PS', '$?', 'Y=', '|', 'SS', '"', '(c)', 'a', '<<', '!', '', '(r)', '-', 'deg', '+-', '2', '3', '\'', 'u', 'P', ' *', ',', '1', 'o', '>>', '1/4', '1/2', '3/4', '?', 'A', 'A', 'A', 'A', 'A', 'A', 'AE', 'C', 'E', 'E', 'E', 'E', 'I', 'I', 'I', 'I', 'D', 'N', 'O', 'O', 'O', 'O', 'O', 'x', 'O', 'U', 'U', 'U', 'U', 'Y', 'Th', 'ss', 'a', 'a', 'a', 'a', 'a', 'a', 'ae', 'c', 'e', 'e', 'e', 'e', 'i', 'i', 'i', 'i', 'd', 'n', 'o', 'o', 'o', 'o', 'o', '/', 'o', 'u', 'u', 'u', 'u', 'y', 'th', 'y',]

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', ' ', '!', '"', '#', '$', '%', '&', '\', '(', ')', '*', '+', ',', '-', '.', '/', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', ':', ';', '<', '=', '>', '?', '@', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', '[', '\', ']', '^', '_', '`', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', '{', '|', '}', '~', '', 'EUR', '', ',', 'f', ',,', '...', '+', '++', '^', '%0', 'S', '<', 'OE', '', 'Z', '', '', '\', '\', '"', '"', '*', '-', '--', '~', 'tm', 's', '>', 'oe', '', 'z', 'Y', ' ', '!', 'C/', 'PS', '$?', 'Y=', '|', 'SS', '"', '(c)', 'a', '<<', '!', '', '(r)', '-', 'deg', '+-', '2', '3', '\'', 'u', 'P', ' *', ',', '1', 'o', '>>', '1/4', '1/2', '3/4', '?', 'A', 'A', 'A', 'A', 'A', 'A', 'AE', 'C', 'E', 'E', 'E', 'E', 'I', 'I', 'I', 'I', 'D', 'N', 'O', 'O', 'O', 'O', 'O', 'x', 'O', 'U', 'U', 'U', 'U', 'Y', 'Th', 'ss', 'a', 'a', 'a', 'a', 'a', 'a', 'ae', 'c', 'e', 'e', 'e', 'e', 'i', 'i', 'i', 'i', 'd', 'n', 'o', 'o', 'o', 'o', 'o', '/', 'o', 'u', 'u', 'u', 'u', 'y', 'th', 'y',]


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_mails/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/laminas/laminas-diactoros/src/Response.php

Structures de données

class Response

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier RangeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RangeField.php

Structures de données

class RangeField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier sect239k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect239k1.php

Structures de données

class sect239k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier tel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier tel.php

Espaces de nommage

Joomla\Site

Variables

$attributes

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
!empty($size) ? 'size="' . $size . '"' : '',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$autofocus ? 'autofocus' : '',
$spellcheck ? '' : 'spellcheck="false"',
$onchange ? 'onchange="' . $onchange . '"' : '',
!empty($maxLength) ? $maxLength : '',
$required ? 'required' : '',
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$size
$size
Definition: slider.php:67
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54


Joomla CMS: Référence du fichier TraceablePDO.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
  • PDO
Structures de données | Espaces de nommage
Référence du fichier TraceablePDO.php

Structures de données

class TraceablePDO

Espaces de nommage

DebugBar\DataCollector\PDO


Joomla CMS: Référence du fichier Tar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
Structures de données | Espaces de nommage
Référence du fichier Tar.php

Structures de données

class Tar

Espaces de nommage

Joomla\Archive


Joomla CMS: Référence du fichier SiteApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
Structures de données | Espaces de nommage
Référence du fichier SiteApplication.php

Structures de données

class SiteApplication

Espaces de nommage

Joomla\CMS\Application


Joomla CMS: Référence du fichier SluggerInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
  • Slugger
Structures de données | Espaces de nommage
Référence du fichier SluggerInterface.php

Structures de données

interface SluggerInterface

Espaces de nommage

Symfony\Component\String\Slugger


Joomla CMS: Référence du fichier RequesttypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier RequesttypeField.php

Structures de données

class RequesttypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Field


Joomla CMS: Référence du fichier PS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/PS512.php

Structures de données

class PS512

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier title.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • toolbar
Espaces de nommage | Variables
Référence du fichier layouts/joomla/toolbar/title.php

Espaces de nommage

Joomla\Site

Variables

$icon = empty($displayData['icon']) ? 'dot-circle' : preg_replace('#\.[^ .]*$#', '', $displayData['icon'])

Documentation des variables

◆ $icon

$icon = empty($displayData['icon']) ? 'dot-circle' : preg_replace('#\.[^ .]*$#', '', $displayData['icon'])


Joomla CMS: Référence du fichier PackageAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier PackageAdapter.php

Structures de données

class PackageAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier UpdateSite.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier UpdateSite.php

Structures de données

class UpdateSite

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier x0ca.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ca.php

Variables

return ['jjael', 'jjaelg', 'jjaelm', 'jjaelb', 'jjaels', 'jjaelt', 'jjaelp', 'jjaelh', 'jjaem', 'jjaeb', 'jjaebs', 'jjaes', 'jjaess', 'jjaeng', 'jjaej', 'jjaec', 'jjaek', 'jjaet', 'jjaep', 'jjaeh', 'jjya', 'jjyag', 'jjyagg', 'jjyags', 'jjyan', 'jjyanj', 'jjyanh', 'jjyad', 'jjyal', 'jjyalg', 'jjyalm', 'jjyalb', 'jjyals', 'jjyalt', 'jjyalp', 'jjyalh', 'jjyam', 'jjyab', 'jjyabs', 'jjyas', 'jjyass', 'jjyang', 'jjyaj', 'jjyac', 'jjyak', 'jjyat', 'jjyap', 'jjyah', 'jjyae', 'jjyaeg', 'jjyaegg', 'jjyaegs', 'jjyaen', 'jjyaenj', 'jjyaenh', 'jjyaed', 'jjyael', 'jjyaelg', 'jjyaelm', 'jjyaelb', 'jjyaels', 'jjyaelt', 'jjyaelp', 'jjyaelh', 'jjyaem', 'jjyaeb', 'jjyaebs', 'jjyaes', 'jjyaess', 'jjyaeng', 'jjyaej', 'jjyaec', 'jjyaek', 'jjyaet', 'jjyaep', 'jjyaeh', 'jjeo', 'jjeog', 'jjeogg', 'jjeogs', 'jjeon', 'jjeonj', 'jjeonh', 'jjeod', 'jjeol', 'jjeolg', 'jjeolm', 'jjeolb', 'jjeols', 'jjeolt', 'jjeolp', 'jjeolh', 'jjeom', 'jjeob', 'jjeobs', 'jjeos', 'jjeoss', 'jjeong', 'jjeoj', 'jjeoc', 'jjeok', 'jjeot', 'jjeop', 'jjeoh', 'jje', 'jjeg', 'jjegg', 'jjegs', 'jjen', 'jjenj', 'jjenh', 'jjed', 'jjel', 'jjelg', 'jjelm', 'jjelb', 'jjels', 'jjelt', 'jjelp', 'jjelh', 'jjem', 'jjeb', 'jjebs', 'jjes', 'jjess', 'jjeng', 'jjej', 'jjec', 'jjek', 'jjet', 'jjep', 'jjeh', 'jjyeo', 'jjyeog', 'jjyeogg', 'jjyeogs', 'jjyeon', 'jjyeonj', 'jjyeonh', 'jjyeod', 'jjyeol', 'jjyeolg', 'jjyeolm', 'jjyeolb', 'jjyeols', 'jjyeolt', 'jjyeolp', 'jjyeolh', 'jjyeom', 'jjyeob', 'jjyeobs', 'jjyeos', 'jjyeoss', 'jjyeong', 'jjyeoj', 'jjyeoc', 'jjyeok', 'jjyeot', 'jjyeop', 'jjyeoh', 'jjye', 'jjyeg', 'jjyegg', 'jjyegs', 'jjyen', 'jjyenj', 'jjyenh', 'jjyed', 'jjyel', 'jjyelg', 'jjyelm', 'jjyelb', 'jjyels', 'jjyelt', 'jjyelp', 'jjyelh', 'jjyem', 'jjyeb', 'jjyebs', 'jjyes', 'jjyess', 'jjyeng', 'jjyej', 'jjyec', 'jjyek', 'jjyet', 'jjyep', 'jjyeh', 'jjo', 'jjog', 'jjogg', 'jjogs', 'jjon', 'jjonj', 'jjonh', 'jjod', 'jjol', 'jjolg', 'jjolm', 'jjolb', 'jjols', 'jjolt', 'jjolp', 'jjolh', 'jjom', 'jjob', 'jjobs', 'jjos', 'jjoss', 'jjong', 'jjoj', 'jjoc', 'jjok', 'jjot', 'jjop', 'jjoh', 'jjwa', 'jjwag', 'jjwagg', 'jjwags', 'jjwan', 'jjwanj', 'jjwanh', 'jjwad', 'jjwal', 'jjwalg', 'jjwalm', 'jjwalb', 'jjwals', 'jjwalt', 'jjwalp', 'jjwalh', 'jjwam', 'jjwab', 'jjwabs', 'jjwas', 'jjwass', 'jjwang', 'jjwaj', 'jjwac', 'jjwak', 'jjwat', 'jjwap', 'jjwah', 'jjwae', 'jjwaeg', 'jjwaegg', 'jjwaegs', 'jjwaen', 'jjwaenj', 'jjwaenh', 'jjwaed', 'jjwael', 'jjwaelg', 'jjwaelm', 'jjwaelb']

Documentation des variables

◆ return

return[ 'jjael', 'jjaelg', 'jjaelm', 'jjaelb', 'jjaels', 'jjaelt', 'jjaelp', 'jjaelh', 'jjaem', 'jjaeb', 'jjaebs', 'jjaes', 'jjaess', 'jjaeng', 'jjaej', 'jjaec', 'jjaek', 'jjaet', 'jjaep', 'jjaeh', 'jjya', 'jjyag', 'jjyagg', 'jjyags', 'jjyan', 'jjyanj', 'jjyanh', 'jjyad', 'jjyal', 'jjyalg', 'jjyalm', 'jjyalb', 'jjyals', 'jjyalt', 'jjyalp', 'jjyalh', 'jjyam', 'jjyab', 'jjyabs', 'jjyas', 'jjyass', 'jjyang', 'jjyaj', 'jjyac', 'jjyak', 'jjyat', 'jjyap', 'jjyah', 'jjyae', 'jjyaeg', 'jjyaegg', 'jjyaegs', 'jjyaen', 'jjyaenj', 'jjyaenh', 'jjyaed', 'jjyael', 'jjyaelg', 'jjyaelm', 'jjyaelb', 'jjyaels', 'jjyaelt', 'jjyaelp', 'jjyaelh', 'jjyaem', 'jjyaeb', 'jjyaebs', 'jjyaes', 'jjyaess', 'jjyaeng', 'jjyaej', 'jjyaec', 'jjyaek', 'jjyaet', 'jjyaep', 'jjyaeh', 'jjeo', 'jjeog', 'jjeogg', 'jjeogs', 'jjeon', 'jjeonj', 'jjeonh', 'jjeod', 'jjeol', 'jjeolg', 'jjeolm', 'jjeolb', 'jjeols', 'jjeolt', 'jjeolp', 'jjeolh', 'jjeom', 'jjeob', 'jjeobs', 'jjeos', 'jjeoss', 'jjeong', 'jjeoj', 'jjeoc', 'jjeok', 'jjeot', 'jjeop', 'jjeoh', 'jje', 'jjeg', 'jjegg', 'jjegs', 'jjen', 'jjenj', 'jjenh', 'jjed', 'jjel', 'jjelg', 'jjelm', 'jjelb', 'jjels', 'jjelt', 'jjelp', 'jjelh', 'jjem', 'jjeb', 'jjebs', 'jjes', 'jjess', 'jjeng', 'jjej', 'jjec', 'jjek', 'jjet', 'jjep', 'jjeh', 'jjyeo', 'jjyeog', 'jjyeogg', 'jjyeogs', 'jjyeon', 'jjyeonj', 'jjyeonh', 'jjyeod', 'jjyeol', 'jjyeolg', 'jjyeolm', 'jjyeolb', 'jjyeols', 'jjyeolt', 'jjyeolp', 'jjyeolh', 'jjyeom', 'jjyeob', 'jjyeobs', 'jjyeos', 'jjyeoss', 'jjyeong', 'jjyeoj', 'jjyeoc', 'jjyeok', 'jjyeot', 'jjyeop', 'jjyeoh', 'jjye', 'jjyeg', 'jjyegg', 'jjyegs', 'jjyen', 'jjyenj', 'jjyenh', 'jjyed', 'jjyel', 'jjyelg', 'jjyelm', 'jjyelb', 'jjyels', 'jjyelt', 'jjyelp', 'jjyelh', 'jjyem', 'jjyeb', 'jjyebs', 'jjyes', 'jjyess', 'jjyeng', 'jjyej', 'jjyec', 'jjyek', 'jjyet', 'jjyep', 'jjyeh', 'jjo', 'jjog', 'jjogg', 'jjogs', 'jjon', 'jjonj', 'jjonh', 'jjod', 'jjol', 'jjolg', 'jjolm', 'jjolb', 'jjols', 'jjolt', 'jjolp', 'jjolh', 'jjom', 'jjob', 'jjobs', 'jjos', 'jjoss', 'jjong', 'jjoj', 'jjoc', 'jjok', 'jjot', 'jjop', 'jjoh', 'jjwa', 'jjwag', 'jjwagg', 'jjwags', 'jjwan', 'jjwanj', 'jjwanh', 'jjwad', 'jjwal', 'jjwalg', 'jjwalm', 'jjwalb', 'jjwals', 'jjwalt', 'jjwalp', 'jjwalh', 'jjwam', 'jjwab', 'jjwabs', 'jjwas', 'jjwass', 'jjwang', 'jjwaj', 'jjwac', 'jjwak', 'jjwat', 'jjwap', 'jjwah', 'jjwae', 'jjwaeg', 'jjwaegg', 'jjwaegs', 'jjwaen', 'jjwaenj', 'jjwaenh', 'jjwaed', 'jjwael', 'jjwaelg', 'jjwaelm', 'jjwaelb']


Joomla CMS: Référence du fichier ProcessorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
  • Processor
Structures de données | Espaces de nommage
Référence du fichier ProcessorInterface.php

Structures de données

interface ProcessorInterface

Espaces de nommage

Joomla\CMS\Application\CLI\Output\Processor


Joomla CMS: Référence du fichier ProfileCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier ProfileCollector.php

Structures de données

class ProfileCollector

Espaces de nommage

Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier TracksModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier TracksModel.php

Structures de données

class TracksModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Model


Joomla CMS: Référence du fichier symfony-ghost.svg.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • assets
  • images
Référence du fichier symfony-ghost.svg.php


Joomla CMS: Référence du fichier UnsupportedOperationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ramsey/uuid/src/Exception/UnsupportedOperationException.php

Structures de données

class UnsupportedOperationException

Espaces de nommage

Ramsey\Uuid\Exception


Joomla CMS: Référence du fichier UndefinedMethodErrorEnhancer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorEnhancer
Structures de données | Espaces de nommage
Référence du fichier UndefinedMethodErrorEnhancer.php

Structures de données

class UndefinedMethodErrorEnhancer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorEnhancer


Joomla CMS: Référence du fichier PeclUuidTimeGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier PeclUuidTimeGenerator.php

Structures de données

class PeclUuidTimeGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier RulesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RulesField.php

Structures de données

class RulesField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier RequestController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_config
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_config/src/Controller/RequestController.php

Structures de données

class RequestController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Config\Administrator\Controller


Joomla CMS: Référence du fichier StageModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StageModel.php

Structures de données

class StageModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier UriFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/UriFactory.php

Structures de données

class UriFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier PKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/PKCS1.php

Structures de données

class PKCS1

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier Sanitizer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
Structures de données | Espaces de nommage
Référence du fichier Sanitizer.php

Structures de données

class Sanitizer

Espaces de nommage

enshrined\svgSanitize
enshrined


Joomla CMS: Référence du fichier pagebreak.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • tmpl
  • article
Espaces de nommage | Variables
Référence du fichier administrator/components/com_content/tmpl/article/pagebreak.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$this eName = Factory::getApplication()->input->getCmd('e_name', '')

Documentation des variables

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ eName

$this eName = Factory::getApplication()->input->getCmd('e_name', '')


Joomla CMS: Référence du fichier ServerDumpCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Command
Structures de données | Espaces de nommage
Référence du fichier ServerDumpCommand.php

Structures de données

class ServerDumpCommand

Espaces de nommage

Symfony\Component\VarDumper\Command


Joomla CMS: Référence du fichier x003.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x003.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', 'a', 'e', 'i', 'o', 'u', 'c', 'd', 'h', 'm', 'r', 't', 'v', 'x', '[?]', '[?]', '[?]', '[?]', '\'', ',', '[?]', '[?]', '[?]', '[?]', '', '[?]', '[?]', '[?]', '?', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', 'A', ';', 'E', 'E', 'I', '[?]', 'O', '[?]', 'U', 'O', 'I', 'A', 'B', 'G', 'D', 'E', 'Z', 'E', 'Th', 'I', 'K', 'L', 'M', 'N', 'Ks', 'O', 'P', 'R', '[?]', 'S', 'T', 'U', 'Ph', 'Kh', 'Ps', 'O', 'I', 'U', 'a', 'e', 'e', 'i', 'u', 'a', 'b', 'g', 'd', 'e', 'z', 'e', 'th', 'i', 'k', 'l', 'm', 'n', 'x', 'o', 'p', 'r', 's', 's', 't', 'u', 'ph', 'kh', 'ps', 'o', 'i', 'u', 'o', 'u', 'o', '[?]', 'b', 'th', 'U', 'U', 'U', 'ph', 'p', '&', '[?]', '[?]', 'St', 'st', 'W', 'w', 'Q', 'q', 'Sp', 'sp', 'Sh', 'sh', 'F', 'f', 'Kh', 'kh', 'H', 'h', 'G', 'g', 'CH', 'ch', 'Ti', 'ti', 'k', 'r', 'c', 'j', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', 'a', 'e', 'i', 'o', 'u', 'c', 'd', 'h', 'm', 'r', 't', 'v', 'x', '[?]', '[?]', '[?]', '[?]', '\'', ',', '[?]', '[?]', '[?]', '[?]', '', '[?]', '[?]', '[?]', '?', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', 'A', ';', 'E', 'E', 'I', '[?]', 'O', '[?]', 'U', 'O', 'I', 'A', 'B', 'G', 'D', 'E', 'Z', 'E', 'Th', 'I', 'K', 'L', 'M', 'N', 'Ks', 'O', 'P', 'R', '[?]', 'S', 'T', 'U', 'Ph', 'Kh', 'Ps', 'O', 'I', 'U', 'a', 'e', 'e', 'i', 'u', 'a', 'b', 'g', 'd', 'e', 'z', 'e', 'th', 'i', 'k', 'l', 'm', 'n', 'x', 'o', 'p', 'r', 's', 's', 't', 'u', 'ph', 'kh', 'ps', 'o', 'i', 'u', 'o', 'u', 'o', '[?]', 'b', 'th', 'U', 'U', 'U', 'ph', 'p', '&', '[?]', '[?]', 'St', 'st', 'W', 'w', 'Q', 'q', 'Sp', 'sp', 'Sh', 'sh', 'F', 'f', 'Kh', 'kh', 'H', 'h', 'G', 'g', 'CH', 'ch', 'Ti', 'ti', 'k', 'r', 'c', 'j', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier title.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier administrator/templates/atum/html/layouts/chromes/title.php

Espaces de nommage

Joomla\Administrator

Variables

$module = $displayData['module']
if ((string) $module->content==='')

Documentation des variables

◆ $module

$module = $displayData['module']

◆ if

if((string) $module->content==='')


Joomla CMS: Référence du fichier SubformRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier SubformRule.php

Structures de données

class SubformRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier result.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • helpers
  • indexer
Espaces de nommage
Référence du fichier result.php

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier template.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • helpers
Structures de données | Espaces de nommage
Référence du fichier template.php

Structures de données

class TemplateHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier textarea.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • textarea
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/textarea/tmpl/textarea.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if ( $value=='')

Documentation des variables

◆ $value

$value = $field->value

◆ if

if($value=='')


Joomla CMS: Référence du fichier range.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier range.php

Espaces de nommage

Joomla\Site

Variables

$attributes
$value = is_numeric($value) ? (float) $value : $min

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
$class ? 'class="form-range ' . $class . '"' : 'class="form-range"',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
!empty($onchange) ? 'onchange="' . $onchange . '"' : '',
!empty($max) ? 'max="' . $max . '"' : '',
!empty($step) ? 'step="' . $step . '"' : '',
!empty($min) ? 'min="' . $min . '"' : '',
$autofocus ? 'autofocus' : '',
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$onchange
$onchange
Definition: checkbox.php:59
$step
$step
Definition: links.php:29
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ $value

$value = is_numeric($value) ? (float) $value : $min


Joomla CMS: Référence du fichier StatusField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier StatusField.php

Structures de données

class StatusField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier TemplateAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier TemplateAdapter.php

Structures de données

class TemplateAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier tinymcebuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
  • field
Espaces de nommage | Variables
Référence du fichier tinymcebuilder.php

Espaces de nommage

Joomla\Plugin

Variables

$doc = Factory::getApplication()->getDocument()
$wa = $doc->getWebAssetManager()
foreach ( $setsNames as $num=> $title)
$presetButtonClasses
if(empty($value['toolbars'][$num]['menu']) &&empty($value['toolbars'][$num]['toolbar1']) &&empty($value['toolbars'][$num]['toolbar2'])) | $valMenu = empty($value['toolbars'][$num]['menu']) ? array() : $value['toolbars'][$num]['menu']
$valBar1 = empty($value['toolbars'][$num]['toolbar1']) ? array() : $value['toolbars'][$num]['toolbar1']
$valBar2 = empty($value['toolbars'][$num]['toolbar2']) ? array() : $value['toolbars'][$num]['toolbar2']
foreach | (array_keys($toolbarPreset) as $presetName) ( $presetButtonClasses[ $presetName]) ? 'btn-primary'
endforeach

Documentation des variables

◆ $doc

$doc = Factory::getApplication()->getDocument()

◆ $presetButtonClasses

$presetButtonClasses
Valeur initiale :
= [
'simple' => 'btn-success'

◆ $valBar1

$valBar1 = empty($value['toolbars'][$num]['toolbar1']) ? array() : $value['toolbars'][$num]['toolbar1']

◆ $valBar2

$valBar2 = empty($value['toolbars'][$num]['toolbar2']) ? array() : $value['toolbars'][$num]['toolbar2']

◆ $valMenu

if (empty( $value[ 'toolbars'][ $num][ 'menu']) &&empty( $value[ 'toolbars'][ $num][ 'toolbar1']) &&empty( $value[ 'toolbars'][ $num][ 'toolbar2'])) $valMenu = empty($value['toolbars'][$num]['menu']) ? array() : $value['toolbars'][$num]['menu']

◆ $wa

$wa = $doc->getWebAssetManager()

◆ (array_keys($toolbarPreset) as $presetName)

foreach (array_keys( $toolbarPreset) as $presetName)($presetButtonClasses[$presetName]) ? 'btn-primary'

◆ endforeach

endforeach

◆ foreach

foreach($setsNames as $num=> $title)


Joomla CMS: Référence du fichier x066.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x066.php

Variables

return ['Yun ', 'Bei ', 'Ang ', 'Ze ', 'Ban ', 'Jie ', 'Kun ', 'Sheng ', 'Hu ', 'Fang ', 'Hao ', 'Gui ', 'Chang ', 'Xuan ', 'Ming ', 'Hun ', 'Fen ', 'Qin ', 'Hu ', 'Yi ', 'Xi ', 'Xin ', 'Yan ', 'Ze ', 'Fang ', 'Tan ', 'Shen ', 'Ju ', 'Yang ', 'Zan ', 'Bing ', 'Xing ', 'Ying ', 'Xuan ', 'Pei ', 'Zhen ', 'Ling ', 'Chun ', 'Hao ', 'Mei ', 'Zuo ', 'Mo ', 'Bian ', 'Xu ', 'Hun ', 'Zhao ', 'Zong ', 'Shi ', 'Shi ', 'Yu ', 'Fei ', 'Die ', 'Mao ', 'Ni ', 'Chang ', 'Wen ', 'Dong ', 'Ai ', 'Bing ', 'Ang ', 'Zhou ', 'Long ', 'Xian ', 'Kuang ', 'Tiao ', 'Chao ', 'Shi ', 'Huang ', 'Huang ', 'Xuan ', 'Kui ', 'Xu ', 'Jiao ', 'Jin ', 'Zhi ', 'Jin ', 'Shang ', 'Tong ', 'Hong ', 'Yan ', 'Gai ', 'Xiang ', 'Shai ', 'Xiao ', 'Ye ', 'Yun ', 'Hui ', 'Han ', 'Han ', 'Jun ', 'Wan ', 'Xian ', 'Kun ', 'Zhou ', 'Xi ', 'Cheng ', 'Sheng ', 'Bu ', 'Zhe ', 'Zhe ', 'Wu ', 'Han ', 'Hui ', 'Hao ', 'Chen ', 'Wan ', 'Tian ', 'Zhuo ', 'Zui ', 'Zhou ', 'Pu ', 'Jing ', 'Xi ', 'Shan ', 'Yi ', 'Xi ', 'Qing ', 'Qi ', 'Jing ', 'Gui ', 'Zhen ', 'Yi ', 'Zhi ', 'An ', 'Wan ', 'Lin ', 'Liang ', 'Chang ', 'Wang ', 'Xiao ', 'Zan ', 'Hi ', 'Xuan ', 'Xuan ', 'Yi ', 'Xia ', 'Yun ', 'Hui ', 'Fu ', 'Min ', 'Kui ', 'He ', 'Ying ', 'Du ', 'Wei ', 'Shu ', 'Qing ', 'Mao ', 'Nan ', 'Jian ', 'Nuan ', 'An ', 'Yang ', 'Chun ', 'Yao ', 'Suo ', 'Jin ', 'Ming ', 'Jiao ', 'Kai ', 'Gao ', 'Weng ', 'Chang ', 'Qi ', 'Hao ', 'Yan ', 'Li ', 'Ai ', 'Ji ', 'Gui ', 'Men ', 'Zan ', 'Xie ', 'Hao ', 'Mu ', 'Mo ', 'Cong ', 'Ni ', 'Zhang ', 'Hui ', 'Bao ', 'Han ', 'Xuan ', 'Chuan ', 'Liao ', 'Xian ', 'Dan ', 'Jing ', 'Pie ', 'Lin ', 'Tun ', 'Xi ', 'Yi ', 'Ji ', 'Huang ', 'Tai ', 'Ye ', 'Ye ', 'Li ', 'Tan ', 'Tong ', 'Xiao ', 'Fei ', 'Qin ', 'Zhao ', 'Hao ', 'Yi ', 'Xiang ', 'Xing ', 'Sen ', 'Jiao ', 'Bao ', 'Jing ', 'Yian ', 'Ai ', 'Ye ', 'Ru ', 'Shu ', 'Meng ', 'Xun ', 'Yao ', 'Pu ', 'Li ', 'Chen ', 'Kuang ', 'Die ', '[?] ', 'Yan ', 'Huo ', 'Lu ', 'Xi ', 'Rong ', 'Long ', 'Nang ', 'Luo ', 'Luan ', 'Shai ', 'Tang ', 'Yan ', 'Chu ', 'Yue ', 'Yue ', 'Qu ', 'Yi ', 'Geng ', 'Ye ', 'Hu ', 'He ', 'Shu ', 'Cao ', 'Cao ', 'Noboru ', 'Man ', 'Ceng ', 'Ceng ', 'Ti ']

Documentation des variables

◆ return

return[ 'Yun ', 'Bei ', 'Ang ', 'Ze ', 'Ban ', 'Jie ', 'Kun ', 'Sheng ', 'Hu ', 'Fang ', 'Hao ', 'Gui ', 'Chang ', 'Xuan ', 'Ming ', 'Hun ', 'Fen ', 'Qin ', 'Hu ', 'Yi ', 'Xi ', 'Xin ', 'Yan ', 'Ze ', 'Fang ', 'Tan ', 'Shen ', 'Ju ', 'Yang ', 'Zan ', 'Bing ', 'Xing ', 'Ying ', 'Xuan ', 'Pei ', 'Zhen ', 'Ling ', 'Chun ', 'Hao ', 'Mei ', 'Zuo ', 'Mo ', 'Bian ', 'Xu ', 'Hun ', 'Zhao ', 'Zong ', 'Shi ', 'Shi ', 'Yu ', 'Fei ', 'Die ', 'Mao ', 'Ni ', 'Chang ', 'Wen ', 'Dong ', 'Ai ', 'Bing ', 'Ang ', 'Zhou ', 'Long ', 'Xian ', 'Kuang ', 'Tiao ', 'Chao ', 'Shi ', 'Huang ', 'Huang ', 'Xuan ', 'Kui ', 'Xu ', 'Jiao ', 'Jin ', 'Zhi ', 'Jin ', 'Shang ', 'Tong ', 'Hong ', 'Yan ', 'Gai ', 'Xiang ', 'Shai ', 'Xiao ', 'Ye ', 'Yun ', 'Hui ', 'Han ', 'Han ', 'Jun ', 'Wan ', 'Xian ', 'Kun ', 'Zhou ', 'Xi ', 'Cheng ', 'Sheng ', 'Bu ', 'Zhe ', 'Zhe ', 'Wu ', 'Han ', 'Hui ', 'Hao ', 'Chen ', 'Wan ', 'Tian ', 'Zhuo ', 'Zui ', 'Zhou ', 'Pu ', 'Jing ', 'Xi ', 'Shan ', 'Yi ', 'Xi ', 'Qing ', 'Qi ', 'Jing ', 'Gui ', 'Zhen ', 'Yi ', 'Zhi ', 'An ', 'Wan ', 'Lin ', 'Liang ', 'Chang ', 'Wang ', 'Xiao ', 'Zan ', 'Hi ', 'Xuan ', 'Xuan ', 'Yi ', 'Xia ', 'Yun ', 'Hui ', 'Fu ', 'Min ', 'Kui ', 'He ', 'Ying ', 'Du ', 'Wei ', 'Shu ', 'Qing ', 'Mao ', 'Nan ', 'Jian ', 'Nuan ', 'An ', 'Yang ', 'Chun ', 'Yao ', 'Suo ', 'Jin ', 'Ming ', 'Jiao ', 'Kai ', 'Gao ', 'Weng ', 'Chang ', 'Qi ', 'Hao ', 'Yan ', 'Li ', 'Ai ', 'Ji ', 'Gui ', 'Men ', 'Zan ', 'Xie ', 'Hao ', 'Mu ', 'Mo ', 'Cong ', 'Ni ', 'Zhang ', 'Hui ', 'Bao ', 'Han ', 'Xuan ', 'Chuan ', 'Liao ', 'Xian ', 'Dan ', 'Jing ', 'Pie ', 'Lin ', 'Tun ', 'Xi ', 'Yi ', 'Ji ', 'Huang ', 'Tai ', 'Ye ', 'Ye ', 'Li ', 'Tan ', 'Tong ', 'Xiao ', 'Fei ', 'Qin ', 'Zhao ', 'Hao ', 'Yi ', 'Xiang ', 'Xing ', 'Sen ', 'Jiao ', 'Bao ', 'Jing ', 'Yian ', 'Ai ', 'Ye ', 'Ru ', 'Shu ', 'Meng ', 'Xun ', 'Yao ', 'Pu ', 'Li ', 'Chen ', 'Kuang ', 'Die ', '[?] ', 'Yan ', 'Huo ', 'Lu ', 'Xi ', 'Rong ', 'Long ', 'Nang ', 'Luo ', 'Luan ', 'Shai ', 'Tang ', 'Yan ', 'Chu ', 'Yue ', 'Yue ', 'Qu ', 'Yi ', 'Geng ', 'Ye ', 'Hu ', 'He ', 'Shu ', 'Cao ', 'Cao ', 'Noboru ', 'Man ', 'Ceng ', 'Ceng ', 'Ti ']


Joomla CMS: Référence du fichier table.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • chromes
Espaces de nommage | Variables
Référence du fichier table.php

Espaces de nommage

Joomla\Site

Variables

$module = $displayData['module']
$params = $displayData['params']
if((bool) $module->showtitle) endif

Documentation des variables

◆ $module

$module = $displayData['module']

◆ $params

$params = $displayData['params']

◆ endif

if ((bool) $module->showtitle) endif


Joomla CMS: Référence du fichier TagsSimilarHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_tags_similar
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TagsSimilarHelper.php

Structures de données

class TagsSimilarHelper

Espaces de nommage

Joomla\Site
Joomla\Module\TagsSimilar\Site\Helper


Joomla CMS: Référence du fichier StatementInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier StatementInterface.php

Structures de données

interface StatementInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier SeparatorButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier SeparatorButton.php

Structures de données

class SeparatorButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier StringsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StringsModel.php

Structures de données

class StringsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Référence du fichier X25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/X25519.php

Structures de données

class ParagonIE_Sodium_Core_X25519


Joomla CMS: example.com

example.com

DKIM signing domain name.

'


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Stream.php

Structures de données

class Stream

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier Patcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/Patcher.php

Structures de données

class Patcher

Espaces de nommage

Joomla\CMS\Filesystem


Joomla CMS: Référence du fichier TypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier com_installer/src/Field/TypeField.php

Structures de données

class TypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Field


Joomla CMS: Référence du fichier UsersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/UsersController.php

Structures de données

class UsersController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier StreamFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier StreamFactoryInterface.php

Structures de données

interface StreamFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier PrivacyPlugin.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier PrivacyPlugin.php

Structures de données

class PrivacyPlugin

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Plugin


Joomla CMS: Référence du fichier PublicKeyCredentialLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialLoader.php

Structures de données

class PublicKeyCredentialLoader

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier TransitionsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TransitionsController.php

Structures de données

class TransitionsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/task/sitestatus/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SearchTools.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier SearchTools.php

Structures de données

class SearchTools

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier x00c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x00c.php

Variables

return ['[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'lll', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', 'rr', 'l', 'll', '[?]', 'v', 'sh', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'RR', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'lll', '[?]', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier VarDumperTestTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Test
Espaces de nommage | Fonctions | Variables
Référence du fichier VarDumperTestTrait.php

Espaces de nommage

Symfony\Component\VarDumper\Test

Fonctions

trait setUpVarDumper (array $casters, int $flags=null)
tearDownVarDumper ()
assertDumpEquals ($expected, $data, int $filter=0, string $message='')
assertDumpMatchesFormat ($expected, $data, int $filter=0, string $message='')
getDump ($data, $key=null, int $filter=0)
prepareExpectation ($expected, int $filter)

Variables

trait VarDumperTestTrait


Joomla CMS: Référence du fichier x0b6.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b6.php

Variables

return ['ddyels', 'ddyelt', 'ddyelp', 'ddyelh', 'ddyem', 'ddyeb', 'ddyebs', 'ddyes', 'ddyess', 'ddyeng', 'ddyej', 'ddyec', 'ddyek', 'ddyet', 'ddyep', 'ddyeh', 'ddo', 'ddog', 'ddogg', 'ddogs', 'ddon', 'ddonj', 'ddonh', 'ddod', 'ddol', 'ddolg', 'ddolm', 'ddolb', 'ddols', 'ddolt', 'ddolp', 'ddolh', 'ddom', 'ddob', 'ddobs', 'ddos', 'ddoss', 'ddong', 'ddoj', 'ddoc', 'ddok', 'ddot', 'ddop', 'ddoh', 'ddwa', 'ddwag', 'ddwagg', 'ddwags', 'ddwan', 'ddwanj', 'ddwanh', 'ddwad', 'ddwal', 'ddwalg', 'ddwalm', 'ddwalb', 'ddwals', 'ddwalt', 'ddwalp', 'ddwalh', 'ddwam', 'ddwab', 'ddwabs', 'ddwas', 'ddwass', 'ddwang', 'ddwaj', 'ddwac', 'ddwak', 'ddwat', 'ddwap', 'ddwah', 'ddwae', 'ddwaeg', 'ddwaegg', 'ddwaegs', 'ddwaen', 'ddwaenj', 'ddwaenh', 'ddwaed', 'ddwael', 'ddwaelg', 'ddwaelm', 'ddwaelb', 'ddwaels', 'ddwaelt', 'ddwaelp', 'ddwaelh', 'ddwaem', 'ddwaeb', 'ddwaebs', 'ddwaes', 'ddwaess', 'ddwaeng', 'ddwaej', 'ddwaec', 'ddwaek', 'ddwaet', 'ddwaep', 'ddwaeh', 'ddoe', 'ddoeg', 'ddoegg', 'ddoegs', 'ddoen', 'ddoenj', 'ddoenh', 'ddoed', 'ddoel', 'ddoelg', 'ddoelm', 'ddoelb', 'ddoels', 'ddoelt', 'ddoelp', 'ddoelh', 'ddoem', 'ddoeb', 'ddoebs', 'ddoes', 'ddoess', 'ddoeng', 'ddoej', 'ddoec', 'ddoek', 'ddoet', 'ddoep', 'ddoeh', 'ddyo', 'ddyog', 'ddyogg', 'ddyogs', 'ddyon', 'ddyonj', 'ddyonh', 'ddyod', 'ddyol', 'ddyolg', 'ddyolm', 'ddyolb', 'ddyols', 'ddyolt', 'ddyolp', 'ddyolh', 'ddyom', 'ddyob', 'ddyobs', 'ddyos', 'ddyoss', 'ddyong', 'ddyoj', 'ddyoc', 'ddyok', 'ddyot', 'ddyop', 'ddyoh', 'ddu', 'ddug', 'ddugg', 'ddugs', 'ddun', 'ddunj', 'ddunh', 'ddud', 'ddul', 'ddulg', 'ddulm', 'ddulb', 'dduls', 'ddult', 'ddulp', 'ddulh', 'ddum', 'ddub', 'ddubs', 'ddus', 'dduss', 'ddung', 'dduj', 'dduc', 'dduk', 'ddut', 'ddup', 'dduh', 'ddweo', 'ddweog', 'ddweogg', 'ddweogs', 'ddweon', 'ddweonj', 'ddweonh', 'ddweod', 'ddweol', 'ddweolg', 'ddweolm', 'ddweolb', 'ddweols', 'ddweolt', 'ddweolp', 'ddweolh', 'ddweom', 'ddweob', 'ddweobs', 'ddweos', 'ddweoss', 'ddweong', 'ddweoj', 'ddweoc', 'ddweok', 'ddweot', 'ddweop', 'ddweoh', 'ddwe', 'ddweg', 'ddwegg', 'ddwegs', 'ddwen', 'ddwenj', 'ddwenh', 'ddwed', 'ddwel', 'ddwelg', 'ddwelm', 'ddwelb', 'ddwels', 'ddwelt', 'ddwelp', 'ddwelh', 'ddwem', 'ddweb', 'ddwebs', 'ddwes', 'ddwess', 'ddweng', 'ddwej', 'ddwec', 'ddwek', 'ddwet', 'ddwep', 'ddweh', 'ddwi', 'ddwig', 'ddwigg', 'ddwigs', 'ddwin', 'ddwinj', 'ddwinh', 'ddwid', 'ddwil', 'ddwilg', 'ddwilm', 'ddwilb', 'ddwils', 'ddwilt', 'ddwilp', 'ddwilh']

Documentation des variables

◆ return

return[ 'ddyels', 'ddyelt', 'ddyelp', 'ddyelh', 'ddyem', 'ddyeb', 'ddyebs', 'ddyes', 'ddyess', 'ddyeng', 'ddyej', 'ddyec', 'ddyek', 'ddyet', 'ddyep', 'ddyeh', 'ddo', 'ddog', 'ddogg', 'ddogs', 'ddon', 'ddonj', 'ddonh', 'ddod', 'ddol', 'ddolg', 'ddolm', 'ddolb', 'ddols', 'ddolt', 'ddolp', 'ddolh', 'ddom', 'ddob', 'ddobs', 'ddos', 'ddoss', 'ddong', 'ddoj', 'ddoc', 'ddok', 'ddot', 'ddop', 'ddoh', 'ddwa', 'ddwag', 'ddwagg', 'ddwags', 'ddwan', 'ddwanj', 'ddwanh', 'ddwad', 'ddwal', 'ddwalg', 'ddwalm', 'ddwalb', 'ddwals', 'ddwalt', 'ddwalp', 'ddwalh', 'ddwam', 'ddwab', 'ddwabs', 'ddwas', 'ddwass', 'ddwang', 'ddwaj', 'ddwac', 'ddwak', 'ddwat', 'ddwap', 'ddwah', 'ddwae', 'ddwaeg', 'ddwaegg', 'ddwaegs', 'ddwaen', 'ddwaenj', 'ddwaenh', 'ddwaed', 'ddwael', 'ddwaelg', 'ddwaelm', 'ddwaelb', 'ddwaels', 'ddwaelt', 'ddwaelp', 'ddwaelh', 'ddwaem', 'ddwaeb', 'ddwaebs', 'ddwaes', 'ddwaess', 'ddwaeng', 'ddwaej', 'ddwaec', 'ddwaek', 'ddwaet', 'ddwaep', 'ddwaeh', 'ddoe', 'ddoeg', 'ddoegg', 'ddoegs', 'ddoen', 'ddoenj', 'ddoenh', 'ddoed', 'ddoel', 'ddoelg', 'ddoelm', 'ddoelb', 'ddoels', 'ddoelt', 'ddoelp', 'ddoelh', 'ddoem', 'ddoeb', 'ddoebs', 'ddoes', 'ddoess', 'ddoeng', 'ddoej', 'ddoec', 'ddoek', 'ddoet', 'ddoep', 'ddoeh', 'ddyo', 'ddyog', 'ddyogg', 'ddyogs', 'ddyon', 'ddyonj', 'ddyonh', 'ddyod', 'ddyol', 'ddyolg', 'ddyolm', 'ddyolb', 'ddyols', 'ddyolt', 'ddyolp', 'ddyolh', 'ddyom', 'ddyob', 'ddyobs', 'ddyos', 'ddyoss', 'ddyong', 'ddyoj', 'ddyoc', 'ddyok', 'ddyot', 'ddyop', 'ddyoh', 'ddu', 'ddug', 'ddugg', 'ddugs', 'ddun', 'ddunj', 'ddunh', 'ddud', 'ddul', 'ddulg', 'ddulm', 'ddulb', 'dduls', 'ddult', 'ddulp', 'ddulh', 'ddum', 'ddub', 'ddubs', 'ddus', 'dduss', 'ddung', 'dduj', 'dduc', 'dduk', 'ddut', 'ddup', 'dduh', 'ddweo', 'ddweog', 'ddweogg', 'ddweogs', 'ddweon', 'ddweonj', 'ddweonh', 'ddweod', 'ddweol', 'ddweolg', 'ddweolm', 'ddweolb', 'ddweols', 'ddweolt', 'ddweolp', 'ddweolh', 'ddweom', 'ddweob', 'ddweobs', 'ddweos', 'ddweoss', 'ddweong', 'ddweoj', 'ddweoc', 'ddweok', 'ddweot', 'ddweop', 'ddweoh', 'ddwe', 'ddweg', 'ddwegg', 'ddwegs', 'ddwen', 'ddwenj', 'ddwenh', 'ddwed', 'ddwel', 'ddwelg', 'ddwelm', 'ddwelb', 'ddwels', 'ddwelt', 'ddwelp', 'ddwelh', 'ddwem', 'ddweb', 'ddwebs', 'ddwes', 'ddwess', 'ddweng', 'ddwej', 'ddwec', 'ddwek', 'ddwet', 'ddwep', 'ddweh', 'ddwi', 'ddwig', 'ddwigg', 'ddwigs', 'ddwin', 'ddwinj', 'ddwinh', 'ddwid', 'ddwil', 'ddwilg', 'ddwilm', 'ddwilb', 'ddwils', 'ddwilt', 'ddwilp', 'ddwilh']


Joomla CMS: Référence du fichier PublicKeyCredentialDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialDescriptor.php

Structures de données

class PublicKeyCredentialDescriptor

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier StringsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_languages/src/Controller/StringsController.php

Structures de données

class StringsController

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\Controller


Joomla CMS: Référence du fichier ResultAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

addResult ($data)
setResult (array $value)

Variables

trait ResultAware


Joomla CMS: Référence du fichier remember.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • remember
Structures de données | Espaces de nommage
Référence du fichier remember.php

Structures de données

class PlgSystemRemember

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ToIdn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
Structures de données | Espaces de nommage
Référence du fichier ToIdn.php

Structures de données

class ToIdn

Espaces de nommage

Algo26\IdnaConvert


Joomla CMS: Référence du fichier sect571k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect571k1.php

Structures de données

class sect571k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x09a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09a.php

Variables

return ['E ', 'Cheng ', 'Xin ', 'Ai ', 'Lu ', 'Zhui ', 'Zhou ', 'She ', 'Pian ', 'Kun ', 'Tao ', 'Lai ', 'Zong ', 'Ke ', 'Qi ', 'Qi ', 'Yan ', 'Fei ', 'Sao ', 'Yan ', 'Jie ', 'Yao ', 'Wu ', 'Pian ', 'Cong ', 'Pian ', 'Qian ', 'Fei ', 'Huang ', 'Jian ', 'Huo ', 'Yu ', 'Ti ', 'Quan ', 'Xia ', 'Zong ', 'Kui ', 'Rou ', 'Si ', 'Gua ', 'Tuo ', 'Kui ', 'Sou ', 'Qian ', 'Cheng ', 'Zhi ', 'Liu ', 'Pang ', 'Teng ', 'Xi ', 'Cao ', 'Du ', 'Yan ', 'Yuan ', 'Zou ', 'Sao ', 'Shan ', 'Li ', 'Zhi ', 'Shuang ', 'Lu ', 'Xi ', 'Luo ', 'Zhang ', 'Mo ', 'Ao ', 'Can ', 'Piao ', 'Cong ', 'Qu ', 'Bi ', 'Zhi ', 'Yu ', 'Xu ', 'Hua ', 'Bo ', 'Su ', 'Xiao ', 'Lin ', 'Chan ', 'Dun ', 'Liu ', 'Tuo ', 'Zeng ', 'Tan ', 'Jiao ', 'Tie ', 'Yan ', 'Luo ', 'Zhan ', 'Jing ', 'Yi ', 'Ye ', 'Tuo ', 'Bin ', 'Zou ', 'Yan ', 'Peng ', 'Lu ', 'Teng ', 'Xiang ', 'Ji ', 'Shuang ', 'Ju ', 'Xi ', 'Huan ', 'Li ', 'Biao ', 'Ma ', 'Yu ', 'Tuo ', 'Xun ', 'Chi ', 'Qu ', 'Ri ', 'Bo ', 'Lu ', 'Zang ', 'Shi ', 'Si ', 'Fu ', 'Ju ', 'Zou ', 'Zhu ', 'Tuo ', 'Nu ', 'Jia ', 'Yi ', 'Tai ', 'Xiao ', 'Ma ', 'Yin ', 'Jiao ', 'Hua ', 'Luo ', 'Hai ', 'Pian ', 'Biao ', 'Li ', 'Cheng ', 'Yan ', 'Xin ', 'Qin ', 'Jun ', 'Qi ', 'Qi ', 'Ke ', 'Zhui ', 'Zong ', 'Su ', 'Can ', 'Pian ', 'Zhi ', 'Kui ', 'Sao ', 'Wu ', 'Ao ', 'Liu ', 'Qian ', 'Shan ', 'Piao ', 'Luo ', 'Cong ', 'Chan ', 'Zou ', 'Ji ', 'Shuang ', 'Xiang ', 'Gu ', 'Wei ', 'Wei ', 'Wei ', 'Yu ', 'Gan ', 'Yi ', 'Ang ', 'Tou ', 'Xie ', 'Bao ', 'Bi ', 'Chi ', 'Ti ', 'Di ', 'Ku ', 'Hai ', 'Qiao ', 'Gou ', 'Kua ', 'Ge ', 'Tui ', 'Geng ', 'Pian ', 'Bi ', 'Ke ', 'Ka ', 'Yu ', 'Sui ', 'Lou ', 'Bo ', 'Xiao ', 'Pang ', 'Bo ', 'Ci ', 'Kuan ', 'Bin ', 'Mo ', 'Liao ', 'Lou ', 'Nao ', 'Du ', 'Zang ', 'Sui ', 'Ti ', 'Bin ', 'Kuan ', 'Lu ', 'Gao ', 'Gao ', 'Qiao ', 'Kao ', 'Qiao ', 'Lao ', 'Zao ', 'Biao ', 'Kun ', 'Kun ', 'Ti ', 'Fang ', 'Xiu ', 'Ran ', 'Mao ', 'Dan ', 'Kun ', 'Bin ', 'Fa ', 'Tiao ', 'Peng ', 'Zi ', 'Fa ', 'Ran ', 'Ti ', 'Pao ', 'Pi ', 'Mao ', 'Fu ', 'Er ', 'Rong ', 'Qu ', 'Gong ', 'Xiu ', 'Gua ', 'Ji ', 'Peng ', 'Zhua ', 'Shao ', 'Sha ']

Documentation des variables

◆ return

return[ 'E ', 'Cheng ', 'Xin ', 'Ai ', 'Lu ', 'Zhui ', 'Zhou ', 'She ', 'Pian ', 'Kun ', 'Tao ', 'Lai ', 'Zong ', 'Ke ', 'Qi ', 'Qi ', 'Yan ', 'Fei ', 'Sao ', 'Yan ', 'Jie ', 'Yao ', 'Wu ', 'Pian ', 'Cong ', 'Pian ', 'Qian ', 'Fei ', 'Huang ', 'Jian ', 'Huo ', 'Yu ', 'Ti ', 'Quan ', 'Xia ', 'Zong ', 'Kui ', 'Rou ', 'Si ', 'Gua ', 'Tuo ', 'Kui ', 'Sou ', 'Qian ', 'Cheng ', 'Zhi ', 'Liu ', 'Pang ', 'Teng ', 'Xi ', 'Cao ', 'Du ', 'Yan ', 'Yuan ', 'Zou ', 'Sao ', 'Shan ', 'Li ', 'Zhi ', 'Shuang ', 'Lu ', 'Xi ', 'Luo ', 'Zhang ', 'Mo ', 'Ao ', 'Can ', 'Piao ', 'Cong ', 'Qu ', 'Bi ', 'Zhi ', 'Yu ', 'Xu ', 'Hua ', 'Bo ', 'Su ', 'Xiao ', 'Lin ', 'Chan ', 'Dun ', 'Liu ', 'Tuo ', 'Zeng ', 'Tan ', 'Jiao ', 'Tie ', 'Yan ', 'Luo ', 'Zhan ', 'Jing ', 'Yi ', 'Ye ', 'Tuo ', 'Bin ', 'Zou ', 'Yan ', 'Peng ', 'Lu ', 'Teng ', 'Xiang ', 'Ji ', 'Shuang ', 'Ju ', 'Xi ', 'Huan ', 'Li ', 'Biao ', 'Ma ', 'Yu ', 'Tuo ', 'Xun ', 'Chi ', 'Qu ', 'Ri ', 'Bo ', 'Lu ', 'Zang ', 'Shi ', 'Si ', 'Fu ', 'Ju ', 'Zou ', 'Zhu ', 'Tuo ', 'Nu ', 'Jia ', 'Yi ', 'Tai ', 'Xiao ', 'Ma ', 'Yin ', 'Jiao ', 'Hua ', 'Luo ', 'Hai ', 'Pian ', 'Biao ', 'Li ', 'Cheng ', 'Yan ', 'Xin ', 'Qin ', 'Jun ', 'Qi ', 'Qi ', 'Ke ', 'Zhui ', 'Zong ', 'Su ', 'Can ', 'Pian ', 'Zhi ', 'Kui ', 'Sao ', 'Wu ', 'Ao ', 'Liu ', 'Qian ', 'Shan ', 'Piao ', 'Luo ', 'Cong ', 'Chan ', 'Zou ', 'Ji ', 'Shuang ', 'Xiang ', 'Gu ', 'Wei ', 'Wei ', 'Wei ', 'Yu ', 'Gan ', 'Yi ', 'Ang ', 'Tou ', 'Xie ', 'Bao ', 'Bi ', 'Chi ', 'Ti ', 'Di ', 'Ku ', 'Hai ', 'Qiao ', 'Gou ', 'Kua ', 'Ge ', 'Tui ', 'Geng ', 'Pian ', 'Bi ', 'Ke ', 'Ka ', 'Yu ', 'Sui ', 'Lou ', 'Bo ', 'Xiao ', 'Pang ', 'Bo ', 'Ci ', 'Kuan ', 'Bin ', 'Mo ', 'Liao ', 'Lou ', 'Nao ', 'Du ', 'Zang ', 'Sui ', 'Ti ', 'Bin ', 'Kuan ', 'Lu ', 'Gao ', 'Gao ', 'Qiao ', 'Kao ', 'Qiao ', 'Lao ', 'Zao ', 'Biao ', 'Kun ', 'Kun ', 'Ti ', 'Fang ', 'Xiu ', 'Ran ', 'Mao ', 'Dan ', 'Kun ', 'Bin ', 'Fa ', 'Tiao ', 'Peng ', 'Zi ', 'Fa ', 'Ran ', 'Ti ', 'Pao ', 'Pi ', 'Mao ', 'Fu ', 'Er ', 'Rong ', 'Qu ', 'Gong ', 'Xiu ', 'Gua ', 'Ji ', 'Peng ', 'Zhua ', 'Shao ', 'Sha ']


Joomla CMS: Référence du fichier Terminal.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier Terminal.php

Structures de données

class Terminal

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Service/Provider/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier x06f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06f.php

Variables

return ['Qing ', 'Yu ', 'Piao ', 'Ji ', 'Ya ', 'Jiao ', 'Qi ', 'Xi ', 'Ji ', 'Lu ', 'Lu ', 'Long ', 'Jin ', 'Guo ', 'Cong ', 'Lou ', 'Zhi ', 'Gai ', 'Qiang ', 'Li ', 'Yan ', 'Cao ', 'Jiao ', 'Cong ', 'Qun ', 'Tuan ', 'Ou ', 'Teng ', 'Ye ', 'Xi ', 'Mi ', 'Tang ', 'Mo ', 'Shang ', 'Han ', 'Lian ', 'Lan ', 'Wa ', 'Li ', 'Qian ', 'Feng ', 'Xuan ', 'Yi ', 'Man ', 'Zi ', 'Mang ', 'Kang ', 'Lei ', 'Peng ', 'Shu ', 'Zhang ', 'Zhang ', 'Chong ', 'Xu ', 'Huan ', 'Kuo ', 'Jian ', 'Yan ', 'Chuang ', 'Liao ', 'Cui ', 'Ti ', 'Yang ', 'Jiang ', 'Cong ', 'Ying ', 'Hong ', 'Xun ', 'Shu ', 'Guan ', 'Ying ', 'Xiao ', '[?] ', '[?] ', 'Xu ', 'Lian ', 'Zhi ', 'Wei ', 'Pi ', 'Jue ', 'Jiao ', 'Po ', 'Dang ', 'Hui ', 'Jie ', 'Wu ', 'Pa ', 'Ji ', 'Pan ', 'Gui ', 'Xiao ', 'Qian ', 'Qian ', 'Xi ', 'Lu ', 'Xi ', 'Xuan ', 'Dun ', 'Huang ', 'Min ', 'Run ', 'Su ', 'Liao ', 'Zhen ', 'Zhong ', 'Yi ', 'Di ', 'Wan ', 'Dan ', 'Tan ', 'Chao ', 'Xun ', 'Kui ', 'Yie ', 'Shao ', 'Tu ', 'Zhu ', 'San ', 'Hei ', 'Bi ', 'Shan ', 'Chan ', 'Chan ', 'Shu ', 'Tong ', 'Pu ', 'Lin ', 'Wei ', 'Se ', 'Se ', 'Cheng ', 'Jiong ', 'Cheng ', 'Hua ', 'Jiao ', 'Lao ', 'Che ', 'Gan ', 'Cun ', 'Heng ', 'Si ', 'Shu ', 'Peng ', 'Han ', 'Yun ', 'Liu ', 'Hong ', 'Fu ', 'Hao ', 'He ', 'Xian ', 'Jian ', 'Shan ', 'Xi ', 'Oki ', '[?] ', 'Lan ', '[?] ', 'Yu ', 'Lin ', 'Min ', 'Zao ', 'Dang ', 'Wan ', 'Ze ', 'Xie ', 'Yu ', 'Li ', 'Shi ', 'Xue ', 'Ling ', 'Man ', 'Zi ', 'Yong ', 'Kuai ', 'Can ', 'Lian ', 'Dian ', 'Ye ', 'Ao ', 'Huan ', 'Zhen ', 'Chan ', 'Man ', 'Dan ', 'Dan ', 'Yi ', 'Sui ', 'Pi ', 'Ju ', 'Ta ', 'Qin ', 'Ji ', 'Zhuo ', 'Lian ', 'Nong ', 'Guo ', 'Jin ', 'Fen ', 'Se ', 'Ji ', 'Sui ', 'Hui ', 'Chu ', 'Ta ', 'Song ', 'Ding ', '[?] ', 'Zhu ', 'Lai ', 'Bin ', 'Lian ', 'Mi ', 'Shi ', 'Shu ', 'Mi ', 'Ning ', 'Ying ', 'Ying ', 'Meng ', 'Jin ', 'Qi ', 'Pi ', 'Ji ', 'Hao ', 'Ru ', 'Zui ', 'Wo ', 'Tao ', 'Yin ', 'Yin ', 'Dui ', 'Ci ', 'Huo ', 'Jing ', 'Lan ', 'Jun ', 'Ai ', 'Pu ', 'Zhuo ', 'Wei ', 'Bin ', 'Gu ', 'Qian ', 'Xing ', 'Hama ', 'Kuo ', 'Fei ', '[?] ', 'Boku ', 'Jian ', 'Wei ', 'Luo ', 'Zan ', 'Lu ', 'Li ']

Documentation des variables

◆ return

return[ 'Qing ', 'Yu ', 'Piao ', 'Ji ', 'Ya ', 'Jiao ', 'Qi ', 'Xi ', 'Ji ', 'Lu ', 'Lu ', 'Long ', 'Jin ', 'Guo ', 'Cong ', 'Lou ', 'Zhi ', 'Gai ', 'Qiang ', 'Li ', 'Yan ', 'Cao ', 'Jiao ', 'Cong ', 'Qun ', 'Tuan ', 'Ou ', 'Teng ', 'Ye ', 'Xi ', 'Mi ', 'Tang ', 'Mo ', 'Shang ', 'Han ', 'Lian ', 'Lan ', 'Wa ', 'Li ', 'Qian ', 'Feng ', 'Xuan ', 'Yi ', 'Man ', 'Zi ', 'Mang ', 'Kang ', 'Lei ', 'Peng ', 'Shu ', 'Zhang ', 'Zhang ', 'Chong ', 'Xu ', 'Huan ', 'Kuo ', 'Jian ', 'Yan ', 'Chuang ', 'Liao ', 'Cui ', 'Ti ', 'Yang ', 'Jiang ', 'Cong ', 'Ying ', 'Hong ', 'Xun ', 'Shu ', 'Guan ', 'Ying ', 'Xiao ', '[?] ', '[?] ', 'Xu ', 'Lian ', 'Zhi ', 'Wei ', 'Pi ', 'Jue ', 'Jiao ', 'Po ', 'Dang ', 'Hui ', 'Jie ', 'Wu ', 'Pa ', 'Ji ', 'Pan ', 'Gui ', 'Xiao ', 'Qian ', 'Qian ', 'Xi ', 'Lu ', 'Xi ', 'Xuan ', 'Dun ', 'Huang ', 'Min ', 'Run ', 'Su ', 'Liao ', 'Zhen ', 'Zhong ', 'Yi ', 'Di ', 'Wan ', 'Dan ', 'Tan ', 'Chao ', 'Xun ', 'Kui ', 'Yie ', 'Shao ', 'Tu ', 'Zhu ', 'San ', 'Hei ', 'Bi ', 'Shan ', 'Chan ', 'Chan ', 'Shu ', 'Tong ', 'Pu ', 'Lin ', 'Wei ', 'Se ', 'Se ', 'Cheng ', 'Jiong ', 'Cheng ', 'Hua ', 'Jiao ', 'Lao ', 'Che ', 'Gan ', 'Cun ', 'Heng ', 'Si ', 'Shu ', 'Peng ', 'Han ', 'Yun ', 'Liu ', 'Hong ', 'Fu ', 'Hao ', 'He ', 'Xian ', 'Jian ', 'Shan ', 'Xi ', 'Oki ', '[?] ', 'Lan ', '[?] ', 'Yu ', 'Lin ', 'Min ', 'Zao ', 'Dang ', 'Wan ', 'Ze ', 'Xie ', 'Yu ', 'Li ', 'Shi ', 'Xue ', 'Ling ', 'Man ', 'Zi ', 'Yong ', 'Kuai ', 'Can ', 'Lian ', 'Dian ', 'Ye ', 'Ao ', 'Huan ', 'Zhen ', 'Chan ', 'Man ', 'Dan ', 'Dan ', 'Yi ', 'Sui ', 'Pi ', 'Ju ', 'Ta ', 'Qin ', 'Ji ', 'Zhuo ', 'Lian ', 'Nong ', 'Guo ', 'Jin ', 'Fen ', 'Se ', 'Ji ', 'Sui ', 'Hui ', 'Chu ', 'Ta ', 'Song ', 'Ding ', '[?] ', 'Zhu ', 'Lai ', 'Bin ', 'Lian ', 'Mi ', 'Shi ', 'Shu ', 'Mi ', 'Ning ', 'Ying ', 'Ying ', 'Meng ', 'Jin ', 'Qi ', 'Pi ', 'Ji ', 'Hao ', 'Ru ', 'Zui ', 'Wo ', 'Tao ', 'Yin ', 'Yin ', 'Dui ', 'Ci ', 'Huo ', 'Jing ', 'Lan ', 'Jun ', 'Ai ', 'Pu ', 'Zhuo ', 'Wei ', 'Bin ', 'Gu ', 'Qian ', 'Xing ', 'Hama ', 'Kuo ', 'Fei ', '[?] ', 'Boku ', 'Jian ', 'Wei ', 'Luo ', 'Zan ', 'Lu ', 'Li ']


Joomla CMS: Référence du fichier WebAssetRegistryAssetChanged.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetRegistryAssetChanged.php

Structures de données

class WebAssetRegistryAssetChanged

Espaces de nommage

Joomla\CMS\Event\WebAsset


Joomla CMS: Référence du fichier x0f9.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0f9.php

Variables

return ['Kay ', 'Kayng ', 'Ke ', 'Ko ', 'Kol ', 'Koc ', 'Kwi ', 'Kwi ', 'Kyun ', 'Kul ', 'Kum ', 'Na ', 'Na ', 'Na ', 'La ', 'Na ', 'Na ', 'Na ', 'Na ', 'Na ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nam ', 'Nam ', 'Nam ', 'Nam ', 'Nap ', 'Nap ', 'Nap ', 'Nang ', 'Nang ', 'Nang ', 'Nang ', 'Nang ', 'Nay ', 'Nayng ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Non ', 'Nong ', 'Nong ', 'Nong ', 'Nong ', 'Noy ', 'Noy ', 'Noy ', 'Noy ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nuk ', 'Nuk ', 'Num ', 'Nung ', 'Nung ', 'Nung ', 'Nung ', 'Nung ', 'Twu ', 'La ', 'Lak ', 'Lak ', 'Lan ', 'Lyeng ', 'Lo ', 'Lyul ', 'Li ', 'Pey ', 'Pen ', 'Pyen ', 'Pwu ', 'Pwul ', 'Pi ', 'Sak ', 'Sak ', 'Sam ', 'Sayk ', 'Sayng ', 'Sep ', 'Sey ', 'Sway ', 'Sin ', 'Sim ', 'Sip ', 'Ya ', 'Yak ', 'Yak ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Yek ', 'Yek ', 'Yek ', 'Yek ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yem ', 'Yem ', 'Yem ', 'Yem ', 'Yem ', 'Yep ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yey ', 'Yey ', 'Yey ', 'Yey ', 'O ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yong ', 'Wun ', 'Wen ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yuk ', 'Yuk ', 'Yuk ', 'Yun ', 'Yun ', 'Yun ', 'Yun ', 'Yul ', 'Yul ', 'Yul ', 'Yul ', 'Yung ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'Ik ', 'Ik ', 'In ', 'In ', 'In ', 'In ', 'In ', 'In ', 'In ', 'Im ', 'Im ', 'Im ', 'Ip ', 'Ip ', 'Ip ', 'Cang ', 'Cek ', 'Ci ', 'Cip ', 'Cha ', 'Chek ']

Documentation des variables

◆ return

return[ 'Kay ', 'Kayng ', 'Ke ', 'Ko ', 'Kol ', 'Koc ', 'Kwi ', 'Kwi ', 'Kyun ', 'Kul ', 'Kum ', 'Na ', 'Na ', 'Na ', 'La ', 'Na ', 'Na ', 'Na ', 'Na ', 'Na ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nak ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nan ', 'Nam ', 'Nam ', 'Nam ', 'Nam ', 'Nap ', 'Nap ', 'Nap ', 'Nang ', 'Nang ', 'Nang ', 'Nang ', 'Nang ', 'Nay ', 'Nayng ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'No ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Nok ', 'Non ', 'Nong ', 'Nong ', 'Nong ', 'Nong ', 'Noy ', 'Noy ', 'Noy ', 'Noy ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nwu ', 'Nuk ', 'Nuk ', 'Num ', 'Nung ', 'Nung ', 'Nung ', 'Nung ', 'Nung ', 'Twu ', 'La ', 'Lak ', 'Lak ', 'Lan ', 'Lyeng ', 'Lo ', 'Lyul ', 'Li ', 'Pey ', 'Pen ', 'Pyen ', 'Pwu ', 'Pwul ', 'Pi ', 'Sak ', 'Sak ', 'Sam ', 'Sayk ', 'Sayng ', 'Sep ', 'Sey ', 'Sway ', 'Sin ', 'Sim ', 'Sip ', 'Ya ', 'Yak ', 'Yak ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Yang ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Ye ', 'Yek ', 'Yek ', 'Yek ', 'Yek ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yen ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yel ', 'Yem ', 'Yem ', 'Yem ', 'Yem ', 'Yem ', 'Yep ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yeng ', 'Yey ', 'Yey ', 'Yey ', 'Yey ', 'O ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yo ', 'Yong ', 'Wun ', 'Wen ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yu ', 'Yuk ', 'Yuk ', 'Yuk ', 'Yun ', 'Yun ', 'Yun ', 'Yun ', 'Yul ', 'Yul ', 'Yul ', 'Yul ', 'Yung ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'I ', 'Ik ', 'Ik ', 'In ', 'In ', 'In ', 'In ', 'In ', 'In ', 'In ', 'Im ', 'Im ', 'Im ', 'Ip ', 'Ip ', 'Ip ', 'Cang ', 'Cek ', 'Ci ', 'Cip ', 'Cha ', 'Chek ']


Joomla CMS: Référence du fichier PostgresqlChangeItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
  • ChangeItem
Structures de données | Espaces de nommage
Référence du fichier PostgresqlChangeItem.php

Structures de données

class PostgresqlChangeItem

Espaces de nommage

Joomla\CMS\Schema\ChangeItem


Joomla CMS: Référence du fichier Table.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier vendor/symfony/console/Helper/Table.php

Structures de données

class Table

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier x0fb.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0fb.php

Variables

return ['ff', 'fi', 'fl', 'ffi', 'ffl', 'st', 'st', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'mn', 'me', 'mi', 'vn', 'mkh', '[?]', '[?]', '[?]', '[?]', '[?]', 'yi', '', 'ay', '`', '', 'd', 'h', 'k', 'l', 'm', 'm', 't', '+', 'sh', 's', 'sh', 's', 'a', 'a', '', 'b', 'g', 'd', 'h', 'v', 'z', '[?]', 't', 'y', 'k', 'k', 'l', '[?]', 'l', '[?]', 'n', 'n', '[?]', 'p', 'p', '[?]', 'ts', 'ts', 'r', 'sh', 't', 'vo', 'b', 'k', 'p', 'l', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return[ 'ff', 'fi', 'fl', 'ffi', 'ffl', 'st', 'st', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'mn', 'me', 'mi', 'vn', 'mkh', '[?]', '[?]', '[?]', '[?]', '[?]', 'yi', '', 'ay', '`', '', 'd', 'h', 'k', 'l', 'm', 'm', 't', '+', 'sh', 's', 'sh', 's', 'a', 'a', '', 'b', 'g', 'd', 'h', 'v', 'z', '[?]', 't', 'y', 'k', 'k', 'l', '[?]', 'l', '[?]', 'n', 'n', '[?]', 'p', 'p', '[?]', 'ts', 'ts', 'r', 'sh', 't', 'vo', 'b', 'k', 'p', 'l', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier setaccess.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
  • field
  • tinymcebuilder
Espaces de nommage
Référence du fichier setaccess.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier WebAssetAttachBehaviorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetAttachBehaviorInterface.php

Structures de données

interface WebAssetAttachBehaviorInterface

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier vote.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • vote
  • tmpl
Espaces de nommage | Variables
Référence du fichier tmpl/vote.php

Espaces de nommage

Joomla\Plugin

Variables

$uri = clone Uri::getInstance()
$options = array()
for ( $i=1;$i< 6;$i++)

Documentation des variables

◆ $options

$options = array()

◆ $uri

$uri = clone Uri::getInstance()

◆ for

for($i=1; $i< 6; $i++)


Joomla CMS: Référence du fichier UploadedFileFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier UploadedFileFactory.php

Structures de données

class UploadedFileFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier Signature.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Espaces de nommage
Référence du fichier lcobucci/jwt/src/Token/Signature.php

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier UnsignedIntegerObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier UnsignedIntegerObject.php

Structures de données

class UnsignedIntegerObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier StreamableInputInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier StreamableInputInterface.php

Structures de données

interface StreamableInputInterface

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier Txt.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Parser
Structures de données | Espaces de nommage
Référence du fichier Txt.php

Structures de données

class Txt

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer\Parser


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/X509/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

FG\X509


Joomla CMS: Référence du fichier x072.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x072.php

Variables

return ['He ', 'Lan ', 'Biao ', 'Rong ', 'Li ', 'Mo ', 'Bao ', 'Ruo ', 'Lu ', 'La ', 'Ao ', 'Xun ', 'Kuang ', 'Shuo ', '[?] ', 'Li ', 'Lu ', 'Jue ', 'Liao ', 'Yan ', 'Xi ', 'Xie ', 'Long ', 'Ye ', '[?] ', 'Rang ', 'Yue ', 'Lan ', 'Cong ', 'Jue ', 'Tong ', 'Guan ', '[?] ', 'Che ', 'Mi ', 'Tang ', 'Lan ', 'Zhu ', '[?] ', 'Ling ', 'Cuan ', 'Yu ', 'Zhua ', 'Tsumekanmuri ', 'Pa ', 'Zheng ', 'Pao ', 'Cheng ', 'Yuan ', 'Ai ', 'Wei ', '[?] ', 'Jue ', 'Jue ', 'Fu ', 'Ye ', 'Ba ', 'Die ', 'Ye ', 'Yao ', 'Zu ', 'Shuang ', 'Er ', 'Qiang ', 'Chuang ', 'Ge ', 'Zang ', 'Die ', 'Qiang ', 'Yong ', 'Qiang ', 'Pian ', 'Ban ', 'Pan ', 'Shao ', 'Jian ', 'Pai ', 'Du ', 'Chuang ', 'Tou ', 'Zha ', 'Bian ', 'Die ', 'Bang ', 'Bo ', 'Chuang ', 'You ', '[?] ', 'Du ', 'Ya ', 'Cheng ', 'Niu ', 'Ushihen ', 'Pin ', 'Jiu ', 'Mou ', 'Tuo ', 'Mu ', 'Lao ', 'Ren ', 'Mang ', 'Fang ', 'Mao ', 'Mu ', 'Gang ', 'Wu ', 'Yan ', 'Ge ', 'Bei ', 'Si ', 'Jian ', 'Gu ', 'You ', 'Ge ', 'Sheng ', 'Mu ', 'Di ', 'Qian ', 'Quan ', 'Quan ', 'Zi ', 'Te ', 'Xi ', 'Mang ', 'Keng ', 'Qian ', 'Wu ', 'Gu ', 'Xi ', 'Li ', 'Li ', 'Pou ', 'Ji ', 'Gang ', 'Zhi ', 'Ben ', 'Quan ', 'Run ', 'Du ', 'Ju ', 'Jia ', 'Jian ', 'Feng ', 'Pian ', 'Ke ', 'Ju ', 'Kao ', 'Chu ', 'Xi ', 'Bei ', 'Luo ', 'Jie ', 'Ma ', 'San ', 'Wei ', 'Li ', 'Dun ', 'Tong ', '[?] ', 'Jiang ', 'Ikenie ', 'Li ', 'Du ', 'Lie ', 'Pi ', 'Piao ', 'Bao ', 'Xi ', 'Chou ', 'Wei ', 'Kui ', 'Chou ', 'Quan ', 'Fan ', 'Ba ', 'Fan ', 'Qiu ', 'Ji ', 'Cai ', 'Chuo ', 'An ', 'Jie ', 'Zhuang ', 'Guang ', 'Ma ', 'You ', 'Kang ', 'Bo ', 'Hou ', 'Ya ', 'Yin ', 'Huan ', 'Zhuang ', 'Yun ', 'Kuang ', 'Niu ', 'Di ', 'Qing ', 'Zhong ', 'Mu ', 'Bei ', 'Pi ', 'Ju ', 'Ni ', 'Sheng ', 'Pao ', 'Xia ', 'Tuo ', 'Hu ', 'Ling ', 'Fei ', 'Pi ', 'Ni ', 'Ao ', 'You ', 'Gou ', 'Yue ', 'Ju ', 'Dan ', 'Po ', 'Gu ', 'Xian ', 'Ning ', 'Huan ', 'Hen ', 'Jiao ', 'He ', 'Zhao ', 'Ji ', 'Xun ', 'Shan ', 'Ta ', 'Rong ', 'Shou ', 'Tong ', 'Lao ', 'Du ', 'Xia ', 'Shi ', 'Hua ', 'Zheng ', 'Yu ', 'Sun ', 'Yu ', 'Bi ', 'Mang ', 'Xi ', 'Juan ', 'Li ', 'Xia ', 'Yin ', 'Suan ', 'Lang ', 'Bei ', 'Zhi ', 'Yan ']

Documentation des variables

◆ return

return[ 'He ', 'Lan ', 'Biao ', 'Rong ', 'Li ', 'Mo ', 'Bao ', 'Ruo ', 'Lu ', 'La ', 'Ao ', 'Xun ', 'Kuang ', 'Shuo ', '[?] ', 'Li ', 'Lu ', 'Jue ', 'Liao ', 'Yan ', 'Xi ', 'Xie ', 'Long ', 'Ye ', '[?] ', 'Rang ', 'Yue ', 'Lan ', 'Cong ', 'Jue ', 'Tong ', 'Guan ', '[?] ', 'Che ', 'Mi ', 'Tang ', 'Lan ', 'Zhu ', '[?] ', 'Ling ', 'Cuan ', 'Yu ', 'Zhua ', 'Tsumekanmuri ', 'Pa ', 'Zheng ', 'Pao ', 'Cheng ', 'Yuan ', 'Ai ', 'Wei ', '[?] ', 'Jue ', 'Jue ', 'Fu ', 'Ye ', 'Ba ', 'Die ', 'Ye ', 'Yao ', 'Zu ', 'Shuang ', 'Er ', 'Qiang ', 'Chuang ', 'Ge ', 'Zang ', 'Die ', 'Qiang ', 'Yong ', 'Qiang ', 'Pian ', 'Ban ', 'Pan ', 'Shao ', 'Jian ', 'Pai ', 'Du ', 'Chuang ', 'Tou ', 'Zha ', 'Bian ', 'Die ', 'Bang ', 'Bo ', 'Chuang ', 'You ', '[?] ', 'Du ', 'Ya ', 'Cheng ', 'Niu ', 'Ushihen ', 'Pin ', 'Jiu ', 'Mou ', 'Tuo ', 'Mu ', 'Lao ', 'Ren ', 'Mang ', 'Fang ', 'Mao ', 'Mu ', 'Gang ', 'Wu ', 'Yan ', 'Ge ', 'Bei ', 'Si ', 'Jian ', 'Gu ', 'You ', 'Ge ', 'Sheng ', 'Mu ', 'Di ', 'Qian ', 'Quan ', 'Quan ', 'Zi ', 'Te ', 'Xi ', 'Mang ', 'Keng ', 'Qian ', 'Wu ', 'Gu ', 'Xi ', 'Li ', 'Li ', 'Pou ', 'Ji ', 'Gang ', 'Zhi ', 'Ben ', 'Quan ', 'Run ', 'Du ', 'Ju ', 'Jia ', 'Jian ', 'Feng ', 'Pian ', 'Ke ', 'Ju ', 'Kao ', 'Chu ', 'Xi ', 'Bei ', 'Luo ', 'Jie ', 'Ma ', 'San ', 'Wei ', 'Li ', 'Dun ', 'Tong ', '[?] ', 'Jiang ', 'Ikenie ', 'Li ', 'Du ', 'Lie ', 'Pi ', 'Piao ', 'Bao ', 'Xi ', 'Chou ', 'Wei ', 'Kui ', 'Chou ', 'Quan ', 'Fan ', 'Ba ', 'Fan ', 'Qiu ', 'Ji ', 'Cai ', 'Chuo ', 'An ', 'Jie ', 'Zhuang ', 'Guang ', 'Ma ', 'You ', 'Kang ', 'Bo ', 'Hou ', 'Ya ', 'Yin ', 'Huan ', 'Zhuang ', 'Yun ', 'Kuang ', 'Niu ', 'Di ', 'Qing ', 'Zhong ', 'Mu ', 'Bei ', 'Pi ', 'Ju ', 'Ni ', 'Sheng ', 'Pao ', 'Xia ', 'Tuo ', 'Hu ', 'Ling ', 'Fei ', 'Pi ', 'Ni ', 'Ao ', 'You ', 'Gou ', 'Yue ', 'Ju ', 'Dan ', 'Po ', 'Gu ', 'Xian ', 'Ning ', 'Huan ', 'Hen ', 'Jiao ', 'He ', 'Zhao ', 'Ji ', 'Xun ', 'Shan ', 'Ta ', 'Rong ', 'Shou ', 'Tong ', 'Lao ', 'Du ', 'Xia ', 'Shi ', 'Hua ', 'Zheng ', 'Yu ', 'Sun ', 'Yu ', 'Bi ', 'Mang ', 'Xi ', 'Juan ', 'Li ', 'Xia ', 'Yin ', 'Suan ', 'Lang ', 'Bei ', 'Zhi ', 'Yan ']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • demotasks
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/task/demotasks/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x074.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x074.php

Variables

return ['Han ', 'Xuan ', 'Yan ', 'Qiu ', 'Quan ', 'Lang ', 'Li ', 'Xiu ', 'Fu ', 'Liu ', 'Ye ', 'Xi ', 'Ling ', 'Li ', 'Jin ', 'Lian ', 'Suo ', 'Chiisai ', '[?] ', 'Wan ', 'Dian ', 'Pin ', 'Zhan ', 'Cui ', 'Min ', 'Yu ', 'Ju ', 'Chen ', 'Lai ', 'Wen ', 'Sheng ', 'Wei ', 'Dian ', 'Chu ', 'Zhuo ', 'Pei ', 'Cheng ', 'Hu ', 'Qi ', 'E ', 'Kun ', 'Chang ', 'Qi ', 'Beng ', 'Wan ', 'Lu ', 'Cong ', 'Guan ', 'Yan ', 'Diao ', 'Bei ', 'Lin ', 'Qin ', 'Pi ', 'Pa ', 'Que ', 'Zhuo ', 'Qin ', 'Fa ', '[?] ', 'Qiong ', 'Du ', 'Jie ', 'Hun ', 'Yu ', 'Mao ', 'Mei ', 'Chun ', 'Xuan ', 'Ti ', 'Xing ', 'Dai ', 'Rou ', 'Min ', 'Zhen ', 'Wei ', 'Ruan ', 'Huan ', 'Jie ', 'Chuan ', 'Jian ', 'Zhuan ', 'Yang ', 'Lian ', 'Quan ', 'Xia ', 'Duan ', 'Yuan ', 'Ye ', 'Nao ', 'Hu ', 'Ying ', 'Yu ', 'Huang ', 'Rui ', 'Se ', 'Liu ', 'Shi ', 'Rong ', 'Suo ', 'Yao ', 'Wen ', 'Wu ', 'Jin ', 'Jin ', 'Ying ', 'Ma ', 'Tao ', 'Liu ', 'Tang ', 'Li ', 'Lang ', 'Gui ', 'Zhen ', 'Qiang ', 'Cuo ', 'Jue ', 'Zhao ', 'Yao ', 'Ai ', 'Bin ', 'Tu ', 'Chang ', 'Kun ', 'Zhuan ', 'Cong ', 'Jin ', 'Yi ', 'Cui ', 'Cong ', 'Qi ', 'Li ', 'Ying ', 'Suo ', 'Qiu ', 'Xuan ', 'Ao ', 'Lian ', 'Man ', 'Zhang ', 'Yin ', '[?] ', 'Ying ', 'Zhi ', 'Lu ', 'Wu ', 'Deng ', 'Xiou ', 'Zeng ', 'Xun ', 'Qu ', 'Dang ', 'Lin ', 'Liao ', 'Qiong ', 'Su ', 'Huang ', 'Gui ', 'Pu ', 'Jing ', 'Fan ', 'Jin ', 'Liu ', 'Ji ', '[?] ', 'Jing ', 'Ai ', 'Bi ', 'Can ', 'Qu ', 'Zao ', 'Dang ', 'Jiao ', 'Gun ', 'Tan ', 'Hui ', 'Huan ', 'Se ', 'Sui ', 'Tian ', '[?] ', 'Yu ', 'Jin ', 'Lu ', 'Bin ', 'Shou ', 'Wen ', 'Zui ', 'Lan ', 'Xi ', 'Ji ', 'Xuan ', 'Ruan ', 'Huo ', 'Gai ', 'Lei ', 'Du ', 'Li ', 'Zhi ', 'Rou ', 'Li ', 'Zan ', 'Qiong ', 'Zhe ', 'Gui ', 'Sui ', 'La ', 'Long ', 'Lu ', 'Li ', 'Zan ', 'Lan ', 'Ying ', 'Mi ', 'Xiang ', 'Xi ', 'Guan ', 'Dao ', 'Zan ', 'Huan ', 'Gua ', 'Bo ', 'Die ', 'Bao ', 'Hu ', 'Zhi ', 'Piao ', 'Ban ', 'Rang ', 'Li ', 'Wa ', 'Dekaguramu ', 'Jiang ', 'Qian ', 'Fan ', 'Pen ', 'Fang ', 'Dan ', 'Weng ', 'Ou ', 'Deshiguramu ', 'Miriguramu ', 'Thon ', 'Hu ', 'Ling ', 'Yi ', 'Ping ', 'Ci ', 'Hekutogura ', 'Juan ', 'Chang ', 'Chi ', 'Sarake ', 'Dang ', 'Meng ', 'Pou ']

Documentation des variables

◆ return

return[ 'Han ', 'Xuan ', 'Yan ', 'Qiu ', 'Quan ', 'Lang ', 'Li ', 'Xiu ', 'Fu ', 'Liu ', 'Ye ', 'Xi ', 'Ling ', 'Li ', 'Jin ', 'Lian ', 'Suo ', 'Chiisai ', '[?] ', 'Wan ', 'Dian ', 'Pin ', 'Zhan ', 'Cui ', 'Min ', 'Yu ', 'Ju ', 'Chen ', 'Lai ', 'Wen ', 'Sheng ', 'Wei ', 'Dian ', 'Chu ', 'Zhuo ', 'Pei ', 'Cheng ', 'Hu ', 'Qi ', 'E ', 'Kun ', 'Chang ', 'Qi ', 'Beng ', 'Wan ', 'Lu ', 'Cong ', 'Guan ', 'Yan ', 'Diao ', 'Bei ', 'Lin ', 'Qin ', 'Pi ', 'Pa ', 'Que ', 'Zhuo ', 'Qin ', 'Fa ', '[?] ', 'Qiong ', 'Du ', 'Jie ', 'Hun ', 'Yu ', 'Mao ', 'Mei ', 'Chun ', 'Xuan ', 'Ti ', 'Xing ', 'Dai ', 'Rou ', 'Min ', 'Zhen ', 'Wei ', 'Ruan ', 'Huan ', 'Jie ', 'Chuan ', 'Jian ', 'Zhuan ', 'Yang ', 'Lian ', 'Quan ', 'Xia ', 'Duan ', 'Yuan ', 'Ye ', 'Nao ', 'Hu ', 'Ying ', 'Yu ', 'Huang ', 'Rui ', 'Se ', 'Liu ', 'Shi ', 'Rong ', 'Suo ', 'Yao ', 'Wen ', 'Wu ', 'Jin ', 'Jin ', 'Ying ', 'Ma ', 'Tao ', 'Liu ', 'Tang ', 'Li ', 'Lang ', 'Gui ', 'Zhen ', 'Qiang ', 'Cuo ', 'Jue ', 'Zhao ', 'Yao ', 'Ai ', 'Bin ', 'Tu ', 'Chang ', 'Kun ', 'Zhuan ', 'Cong ', 'Jin ', 'Yi ', 'Cui ', 'Cong ', 'Qi ', 'Li ', 'Ying ', 'Suo ', 'Qiu ', 'Xuan ', 'Ao ', 'Lian ', 'Man ', 'Zhang ', 'Yin ', '[?] ', 'Ying ', 'Zhi ', 'Lu ', 'Wu ', 'Deng ', 'Xiou ', 'Zeng ', 'Xun ', 'Qu ', 'Dang ', 'Lin ', 'Liao ', 'Qiong ', 'Su ', 'Huang ', 'Gui ', 'Pu ', 'Jing ', 'Fan ', 'Jin ', 'Liu ', 'Ji ', '[?] ', 'Jing ', 'Ai ', 'Bi ', 'Can ', 'Qu ', 'Zao ', 'Dang ', 'Jiao ', 'Gun ', 'Tan ', 'Hui ', 'Huan ', 'Se ', 'Sui ', 'Tian ', '[?] ', 'Yu ', 'Jin ', 'Lu ', 'Bin ', 'Shou ', 'Wen ', 'Zui ', 'Lan ', 'Xi ', 'Ji ', 'Xuan ', 'Ruan ', 'Huo ', 'Gai ', 'Lei ', 'Du ', 'Li ', 'Zhi ', 'Rou ', 'Li ', 'Zan ', 'Qiong ', 'Zhe ', 'Gui ', 'Sui ', 'La ', 'Long ', 'Lu ', 'Li ', 'Zan ', 'Lan ', 'Ying ', 'Mi ', 'Xiang ', 'Xi ', 'Guan ', 'Dao ', 'Zan ', 'Huan ', 'Gua ', 'Bo ', 'Die ', 'Bao ', 'Hu ', 'Zhi ', 'Piao ', 'Ban ', 'Rang ', 'Li ', 'Wa ', 'Dekaguramu ', 'Jiang ', 'Qian ', 'Fan ', 'Pen ', 'Fang ', 'Dan ', 'Weng ', 'Ou ', 'Deshiguramu ', 'Miriguramu ', 'Thon ', 'Hu ', 'Ling ', 'Yi ', 'Ping ', 'Ci ', 'Hekutogura ', 'Juan ', 'Chang ', 'Chi ', 'Sarake ', 'Dang ', 'Meng ', 'Pou ']


Joomla CMS: Référence du fichier render.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • layouts
  • field
Espaces de nommage | Variables
Référence du fichier com_contact/layouts/field/render.php

Espaces de nommage

Joomla\Site

Variables

if(!array_key_exists('field', $displayData)) | $field = $displayData['field']
$label = Text::_($field->label)
$value = $field->value
$class = $field->params->get('render_class')
$showLabel = $field->params->get('showlabel')
$labelClass = $field->params->get('label_render_class')
if($field->context=='com_contact.mail') | if (!strlen( $value))
endif

Documentation des variables

◆ $class

$class = $field->params->get('render_class')

◆ $field

if (!array_key_exists( 'field', $displayData)) $field = $displayData['field']

◆ $label

$label = Text::_($field->label)

Référencé par LinkStub\__construct(), FormField\__get(), ActionsDropdown\addCustomItem(), Sidebar\addFilter(), TimeDataCollector\addMeasure(), ProfileCollector\addMeasure(), MessagesCollector\addMessage(), ExceptionCaster\castTraceStub(), ProfileCollector\collect(), ToUnicode\convert(), ToIdn\convert(), ModulesModel\createOptionGroup(), ModulesHelper\createOptionGroup(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), ContenthistoryHelper\getFormValues(), MenuField\getGroups(), GroupedlistField\getGroups(), PositionsModel\getItems(), TosField\getLabel(), SpacerField\getLabel(), ContenthistoryField\getLayoutData(), FormField\getLayoutData(), Select\groupedlist(), Profiler\mark(), TimeDataCollector\measure(), ProfileCollector\measure(), Select\options(), TimeDataCollector\startMeasure(), ProfileCollector\startMeasure(), et HtmlDumper\style().

◆ $labelClass

$labelClass = $field->params->get('label_render_class')

◆ $showLabel

$showLabel = $field->params->get('showlabel')

◆ $value

string $value = $field->value
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php, C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php, et C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php.

Référencé par Language\_(), Assertion\__callStatic(), OutputFormatter\__clone(), AcceptLanguage\__construct(), Accept\__construct(), ClassNotFoundError\__construct(), UndefinedFunctionError\__construct(), UndefinedMethodError\__construct(), RDNString\__construct(), RelativeDistinguishedName\__construct(), FatalError\__construct(), AttributeTypeAndValue\__construct(), AbstractQuery\__construct(), MapItem\__construct(), InvalidArgumentException\__construct(), BaseAccept\__construct(), ConfigPostProcessor\__construct(), CacheController\__construct(), Cache\__construct(), ComponentRecord\__construct(), ContainerResource\__construct(), AbstractEvent\__construct(), InstallerAdapter\__construct(), AssertionChain\__construct(), MenuItem\__construct(), Date\__get(), ConfigPostProcessor\__invoke(), ModuleorderField\__set(), PluginsField\__set(), CaptchaField\__set(), ModulesModuleField\__set(), ModulesPositionField\__set(), ModulepositionField\__set(), OrderingField\__set(), ChromestyleField\__set(), FeedEntry\__set(), TimeField\__set(), TimezoneField\__set(), FileField\__set(), ModulesPositioneditField\__set(), Feed\__set(), CheckboxField\__set(), TemplatestyleField\__set(), ConsentBoxField\__set(), CheckboxesField\__set(), DataObject\__set(), SqlField\__set(), AccessiblemediaField\__set(), MenuitemField\__set(), MeterField\__set(), TextareaField\__set(), RulesField\__set(), MenuItemByTypeField\__set(), NumberField\__set(), ComponentRecord\__set(), SubformField\__set(), DataShapeObject\__set(), MenuField\__set(), FolderlistField\__set(), LegacyInstallerScript\__set(), FilelistField\__set(), CategoryeditField\__set(), PasswordField\__set(), TextField\__set(), CalendarField\__set(), EditorField\__set(), DataSet\__set(), ColorField\__set(), MediaField\__set(), Result\__set(), TraceablePDO\__set(), FormField\__set(), SqliteQuery\__toString(), ByteStringObject\__toString(), Data\__toString(), Pagination\_buildDataObject(), MapObject\add(), Event\addArgument(), ArrayInput\addArgument(), OnGetApiAttributes\addAttribute(), OnGetApiAttributes\addAttributes(), ArrayHelper\addColumn(), Stream\addContextEntry(), PHPMailer\addCustomHeader(), TraceableTwigEnvironment\addGlobal(), Tobscure\JsonApi\addLink(), JsonapiDocument\addLink(), ArrayInput\addLongOption(), ArgvInput\addLongOption(), Tobscure\JsonApi\addMeta(), JsonapiDocument\addMeta(), Form\addNode(), ListField\addOption(), ArrayInput\addShortOption(), ArgvInput\addShortOption(), ActionButton\addState(), Users\admin_language(), Assert\alnum(), Assertion\alnum(), Assert\alpha(), InfiniteMapObject\append(), SSH2\array_intersect_first(), ArrayHelper\arraySearch(), ASN1\asn1map(), HeaderSecurity\assertValid(), QuestionHelper\autocomplete(), Assertion\base64(), Client\baseString(), AdminModel\batchAccess(), ItemModel\batchCopy(), ModuleModel\batchCopy(), AdminModel\batchCopy(), CategoryModel\batchCopy(), FieldModel\batchCopy(), AdminModel\batchLanguage(), ArticleModel\batchMove(), ModuleModel\batchMove(), ItemModel\batchMove(), AdminModel\batchMove(), CategoryModel\batchMove(), FieldModel\batchMove(), UserModel\batchReset(), AdminModel\batchTag(), ContactModel\batchUser(), Joomla\CMS\MVC\Model\batchWorkflowStage(), Assertion\between(), Assertion\betweenExclusive(), Assertion\betweenLength(), DataObject\bind(), DatabaseQuery\bind(), TraceablePDOStatement\bindValue(), MysqliStatement\bindValues(), Utils\binToBigInteger(), Utils\binToInt(), Calculator\bitwise(), UserModel\block(), Assert\boolean(), Assertion\boolean(), DatabaseExporter\buildXmlData(), PlgUserProfile\calendar(), HTMLHelper\calendar(), Joomla\Database\Query\castAs(), SqlsrvQuery\castAs(), DatabaseQuery\castAs(), PdoQuery\castAsChar(), PgsqlQuery\castAsChar(), DatabaseQuery\castAsChar(), RdKafkaCaster\castConf(), SplCaster\castFileObject(), RdKafkaCaster\castTopicConf(), Adapter\categoryStateChange(), Adapter\change(), UsersController\changeBlock(), SetConfigurationCommand\checkDb(), PlgFieldsMedia\checkValue(), Assertion\choice(), Assert\classExists(), Assertion\classExists(), InputFilter\clean(), MemcachedStorage\clean(), AssociationsModel\clean(), MailHelper\cleanLine(), SysinfoModel\cleanSectionPrivateData(), MailHelper\cleanText(), Parser\cleanup(), Collection\cleanupAttributes(), SessionCollector\collect(), LdapClient\compare(), Builder\configureClaim(), PdoDriver\connect(), MysqlDriver\connect(), Connection\connect(), Assert\contains(), RSAKey\convertBase64StringToBigInteger(), AbstractField\convertLiterals(), Builder\convertToDate(), SinglePrecisionFloatObject\create(), DoublePrecisionFloatObject\create(), HalfPrecisionFloatObject\create(), SimpleObject\create(), SignedIntegerObject\create(), UnsignedIntegerObject\create(), Factory\create(), Factory\createBasic(), Factory\createDbo(), Factory\createEqualsTo(), Assertion\createException(), MetadataStatement\createFromArray(), SignedIntegerObject\createFromGmpValue(), UnsignedIntegerObject\createFromGmpValue(), UnsignedIntegerObject\createFromHex(), SignedIntegerObject\createFromString(), UnsignedIntegerObject\createFromString(), Factory\createGreaterOrEqualsTo(), Client\createHeader(), PrivacyPlugin\createItemFromArray(), Factory\createLesserOrEqualsTo(), ContenthistoryHelper\createObjectArray(), ModulesModel\createOption(), ModulesHelper\createOption(), Client\createUrl(), Assertion\date(), InvalidTokenStructure\dateIsNotParseable(), Base128\decode(), ContenthistoryHelper\decodeFields(), XML\decodeValue(), CMSObject\def(), Registry\def(), Input\def(), OptionConfigurator\default(), SSH2\define_array(), SymfonyStyle\definitionList(), User\defParam(), TextDescriptor\describeInputOption(), WebClient\detectHeaders(), Assertion\digit(), Assert\digits(), Assert\directory(), Assertion\directory(), MemcachedCaster\discoverDefaultOptions(), HtmlView\display(), JsonapiView\displayList(), PHPMailer\DKIM_HeaderC(), PlgUserProfile\dob(), WebApplication\doExecute(), GetConfigurationCommand\doExecute(), NativeCalculator\doMul(), Parser\doParse(), Dumper\dump(), Inline\dump(), Inline\dumpArray(), DataObject\dumpProperty(), CliDumper\dumpScalar(), Assertion\e164(), Users\editor(), Assert\email(), Assertion\email(), Base128\encode(), PasswordHash\encode64(), ASN1\encode_der(), ASN1\encodeOID(), Assert\endsWith(), PlgWorkflowFeaturing\enhanceItemForm(), PlgWorkflowPublishing\enhanceItemForm(), Assertion\eq(), Assert\eq(), Assertion\eqArraySubset(), Adapter\escape(), LdapClient\escape(), ActionlogsHelper\escapeCsvFormula(), Escaper\escapeWithDoubleQuotes(), Escaper\escapeWithSingleQuotes(), Inline\evaluateScalar(), MysqliStatement\execute(), Assertion\extensionLoaded(), X509\extensions(), AmqpCaster\extractFlags(), ConfigPostProcessor\fallbackReplacement(), Assert\false(), Assertion\false(), AdministratorService\featured(), ContactModel\featured(), ArticleModel\featured(), Assert\file(), Assertion\file(), Assert\fileExists(), Table\fillNextRows(), RawFilter\filter(), RulesFilter\filter(), TelFilter\filter(), IntarrayFilter\filter(), SafehtmlFilter\filter(), UrlFilter\filter(), HeaderSecurity\filter(), RedisStorage\filter(), FileStorage\filter(), MemcachedStorage\filter(), CalendarField\filter(), SubformField\filter(), FormField\filter(), Laminas\Diactoros\filterHeaderValue(), LanguagesHelper\filterKey(), Uri\filterQuery(), Uri\filterQueryOrFragment(), LanguagesHelper\filterText(), PdoStorage\find(), Joomla\Database\Query\findInSet(), FlattenException\flattenArgs(), Assert\float(), Assertion\float(), QuestionHelper\formatChoiceQuestionChoices(), GetConfigurationCommand\formatConfigValue(), TextDescriptor\formatDefaultValue(), Php\formatValue(), OptionsResolver\formatValue(), OptionsResolver\formatValues(), Builder\forwardCallToCorrectClaimMethod(), SplFixedArray\fromArray(), RsaKey\fromBase64ToInteger(), RSAKey\fromBase64ToInteger(), SSH2\get_channel_packet(), Php80\get_debug_type(), AbstractEvent\getArgument(), Form\getAttribute(), X509\getChain(), Token\getClaim(), Token\getClaims(), OtherObjectManager\getClassForValue(), TagObjectManager\getClassForValue(), FlattenException\getClassNameFromIncomplete(), MediaHelper\getCleanMediaFieldValue(), UpdateModel\getCollectionDetailsUrls(), Workflow\getConditionName(), DatabaseHelper\getDbo(), ChoiceQuestion\getDefaultValidator(), TemplateModel\getDirectoryTree(), X509\getDN(), InstallerHelper\getDownloadKey(), CaBundle\getEnvVariable(), X509\getExtensionHelper(), Form\getField(), FieldsHelper\getFields(), Form\getFieldsets(), ArrayInput\getFirstArgument(), Laminas\Diactoros\getHeaderLine(), Token\getHeaders(), AbstractWebApplication\getHeaders(), QuestionHelper\getHiddenResponse(), AbstractWebApplication\getHttpStatusValue(), ActionlogsHelper\getHumanReadableLogMessage(), Query\getIncludedTermIds(), AssociationField\getInput(), FieldLayoutField\getInput(), MenutypeField\getInput(), ModulelayoutField\getInput(), ComponentlayoutField\getInput(), TagField\getInput(), NumberField\getInput(), TextField\getInput(), Form\getInput(), LanguagesModel\getInstalledlangs(), PlgSampledataMultilang\getInstalledlangs(), FormModel\getItem(), LanguageModel\getItem(), MenuModel\getItem(), PositionsModel\getItems(), ArticlesModel\getItems(), Data\getIterator(), LanguagesModel\getLanguages(), UserField\getLayoutData(), CheckboxField\getLayoutData(), Parser\getLineTag(), SyndicateHelper\getLink(), MenusHelper\getLinkKey(), ContenthistoryHelper\getLookupValue(), MemcachedCaster\getNonDefaultOptions(), ByteStringObject\getNormalizedData(), Input\getOption(), MemcachedCaster\getOptionConstants(), LimitboxField\getOptions(), ListField\getOptions(), WorkflowconditionField\getOptions(), PredefinedlistField\getOptions(), RedirectField\getOptions(), SqlField\getOptions(), ArgvInput\getParameterOption(), Installer\getParams(), ModulesModel\getPositions(), CMSObject\getProperties(), Query\getRequiredTermIds(), CMSHelper\getRowData(), ContentHistory\getSha1(), ActionButton\getState(), Propel2Collector\getStatements(), InputDefinition\getSynopsis(), HelpModel\getToc(), MapItem\getValue(), ByteStringObject\getValue(), InvalidArgumentException\getValue(), BaseAccept\getValue(), RulesRule\getValueActions(), Ini\getValueAsIni(), Xml\getValueFromNode(), Assertion\greaterOrEqualThan(), Assert\greaterThan(), Assertion\greaterThan(), Assert\greaterThanEq(), ArgvInput\hasParameterOption(), Sanitizer\hasRemoteReference(), PHPMailer\headerLine(), Utils\hexToBigInteger(), Utils\hexToInt(), Utils\hexToString(), HTMLHelper\image(), Assert\implementsInterface(), Assert\inArray(), Assertion\inArray(), Assert\integer(), Assertion\integer(), Assert\integerish(), Assertion\integerish(), Assert\interfaceExists(), Assertion\interfaceExists(), Utils\intToHex(), Assert\ip(), Assertion\ip(), Assert\ipv4(), Assertion\ipv4(), Assert\ipv6(), Assertion\ipv6(), PhpToken\is(), Assert\isAnyOf(), Assert\isAOf(), Assert\isArray(), Assertion\isArray(), Assert\isArrayAccessible(), Assertion\isArrayAccessible(), Inline\isBinaryString(), Assert\isCallable(), Assertion\isCallable(), Assert\isCountable(), Assertion\isCountable(), Assert\isEmpty(), Inline\isHash(), Sanitizer\isHrefSafeValue(), AbstractField\isIncrementsOfRanges(), AbstractField\isInIncrementsOfRanges(), AbstractField\isInRange(), Assert\isInstanceOf(), Assertion\isInstanceOf(), Assert\isInstanceOfAny(), Assert\isIterable(), Assertion\isJsonString(), Assert\isNotA(), Assertion\isObject(), AbstractField\isRange(), Assertion\isResource(), AbstractField\isSatisfied(), MinutesField\isSatisfiedBy(), MonthField\isSatisfiedBy(), HoursField\isSatisfiedBy(), DayOfWeekField\isSatisfiedBy(), DayOfMonthField\isSatisfiedBy(), UpdateModel\isTemplateActive(), Token\isTokenEnabledForUser(), Assert\isTraversable(), Assertion\isTraversable(), HeaderSecurity\isValid(), Adapter\itemStateChange(), ProgressBar\iterate(), SSH2\keyboard_interactive_process(), Assertion\keyExists(), Assertion\keyIsset(), Assertion\keyNotExists(), Users\language(), SqlsrvQuery\length(), Assertion\length(), Assert\length(), DatabaseQuery\length(), Assert\lengthBetween(), Assertion\lessOrEqualThan(), Assert\lessThan(), Assertion\lessThan(), Assert\lessThanEq(), Parser\lexInlineQuotedString(), Parser\lexInlineStructure(), PreloadManager\link(), AuthenticationExtensionsClientOutputsLoader\load(), XML\load(), Table\load(), DatabaseDriver\loadAssocList(), ManageModel\loadChangelog(), Form\loadField(), PackageManifest\loadManifestFromData(), SubformField\loadSubFormData(), Assert\lower(), Cache\makeId(), X509\mapInAttributes(), X509\mapInDNs(), X509\mapInExtensions(), X509\mapOutDNs(), X509\mapOutExtensions(), Laminas\Diactoros\marshalHeadersFromSapi(), Laminas\Diactoros\marshalUriFromSapi(), BigNumber\max(), Assertion\max(), Assertion\maxLength(), Assert\maxLength(), ConfigPostProcessor\merge(), ContenthistoryHelper\mergeLabels(), Form\mergeNode(), Form\mergeNodes(), ArrayHelper\mergeRecursive(), Assertion\methodExists(), BigNumber\min(), Assertion\min(), Assertion\minLength(), Assert\minLength(), LocalAdapter\moveFolder(), Assert\natural(), SFTP\nlist_helper(), Assertion\noContent(), ConfigPostProcessor\noopReplacement(), Laminas\Diactoros\normalizeUploadedFiles(), Assertion\notBlank(), Assert\notContains(), Assert\notEmpty(), Assertion\notEmpty(), Assertion\notEmptyKey(), Assert\notEndsWith(), Assert\notEq(), Assert\notFalse(), Assertion\notInArray(), Assert\notInstanceOf(), Assertion\notIsInstanceOf(), Assert\notNull(), Assertion\notNull(), Assertion\notRegex(), Assert\notRegex(), Assert\notSame(), Assert\notStartsWith(), Assert\notWhitespaceOnly(), Assert\null(), Assertion\null(), Assert\numeric(), Assertion\numeric(), Assert\object(), Assertion\objectOrClass(), Ini\objectToString(), BigNumber\of(), BigRational\of(), OptionsResolver\offsetGet(), ParagonIE_Sodium_Core_Curve25519_Fe\offsetSet(), ParagonIE_Sodium_Core_ChaCha20_Ctx\offsetSet(), ParagonIE_Sodium_Core32_ChaCha20_Ctx\offsetSet(), Construct\offsetSet(), ParagonIE_Sodium_Core32_Curve25519_Fe\offsetSet(), Collection\offsetSet(), Event\offsetSet(), DataShapeObject\offsetSet(), Feed\offsetSet(), Registry\offsetSet(), PlgContentFinder\onCategoryChangeState(), PlgContentJoomla\onContentBeforeChangeState(), PlgContentFinder\onContentChangeState(), Joomla\onContentChangeState(), PlgContentJoomla\onContentChangeState(), PlgFieldsCheckboxes\onCustomFieldsBeforePrepareField(), FieldsListPlugin\onCustomFieldsPrepareDom(), Assert\oneOf(), PlgFinderContacts\onFinderCategoryChangeState(), PlgFinderNewsfeeds\onFinderCategoryChangeState(), PlgFinderContent\onFinderCategoryChangeState(), PlgFinderTags\onFinderChangeState(), PlgFinderCategories\onFinderChangeState(), PlgFinderNewsfeeds\onFinderChangeState(), PlgFinderContacts\onFinderChangeState(), PlgFinderContent\onFinderChangeState(), PlgWorkflowFeaturing\onWorkflowAfterTransition(), PlgWorkflowPublishing\onWorkflowAfterTransition(), PlgWorkflowFeaturing\onWorkflowBeforeTransition(), PlgWorkflowPublishing\onWorkflowBeforeTransition(), Parser\parse(), Inline\parse(), ArrayInput\parse(), AbstractUri\parse(), Cli\parseArguments(), SFTP\parseAttributes(), TemplateParser\parseBinary(), ArgvInput\parseLongOption(), Inline\parseMapping(), Inline\parseSequence(), Inline\parseTag(), Parser\parseValue(), TemplatesHelper\parseXMLTemplateFile(), PluginsHelper\parseXMLTemplateFile(), SFTP\partial_init_sftp_connection(), Banner\pinned(), ArrayHelper\pivot(), ArticlesModel\populateState(), DebuggroupModel\populateState(), DebuguserModel\populateState(), CategoryModel\populateState(), ListModel\populateState(), AdminModel\populateState(), Assert\positiveInteger(), FormField\postProcess(), SqlsrvStatement\prepare(), TemplateModel\prepareCoreFiles(), GetConfigurationCommand\processGroupOptions(), SqlField\processQuery(), GetConfigurationCommand\processSingleOption(), Query\processString(), Assertion\propertiesExist(), Assertion\propertyExists(), Container\protect(), UpdatesitesModel\publish(), TemplateController\publish(), ManageModel\publish(), ItemsController\publish(), AdminController\publish(), MessageModel\publish(), TemplateModel\publish(), MapsModel\publish(), StageModel\publish(), NewsfeedModel\publish(), ArticleModel\publish(), WorkflowModel\publish(), IndexModel\publish(), CategoryModel\publish(), AdminModel\publish(), ItemModel\publish(), Redirect\published(), Stem\r2(), Assert\range(), Assertion\range(), SFTP\rawlist(), Assert\readable(), Assertion\readable(), SMTP\recipient(), Assertion\regex(), Assert\regex(), Joomla\Database\Query\regexp(), DatabaseQuery\regexp(), Database\register(), MemcachedStorage\remove(), X509\removeExtensionHelper(), Sanitizer\removeNonPrintableCharacters(), ActionButton\removeState(), PublishedButton\render(), TransitionButton\render(), FeaturedButton\render(), ActionButton\render(), FieldsHelper\render(), PlgSystemActionLogs\renderActionlogsNotify(), ScriptsRenderer\renderAttributes(), StylesRenderer\renderAttributes(), ErrorHandler\renderException(), TextView\renderSection(), HtmlDescriptor\renderTags(), Replacements\replace(), ConfigPostProcessor\replace(), ConfigPostProcessor\replaceExactValue(), ConfigPostProcessor\replacementRuleMatch(), MailTemplate\replaceTags(), Curl\request(), Stream\request(), CurlTransport\request(), Socket\request(), StreamTransport\request(), SocketTransport\request(), Escaper\requiresDoubleQuoting(), Escaper\requiresSingleQuoting(), OptionsResolver\resolve(), Reader\resolveFourByteLittleEndian(), Reader\resolveTwoByteBigEndian(), Assert\resource(), Session\restart(), SetConfigurationCommand\retrieveOptionsFromInput(), SiteApplication\route(), CMSApplication\route(), Stem\rx(), Assertion\same(), Assert\same(), Backgroundfill\sanitizeColor(), SetConfigurationCommand\sanitizeOptions(), Assertion\satisfy(), ApplicationModel\save(), Assert\scalar(), Assertion\scalar(), Email\sendCode(), HttpHeaderSerializer\serialize(), JSONGeneralSerializer\serialize(), AbstractSerializer\serializeHeaders(), Cookie\set(), CMSObject\set(), AbstractApplication\set(), JoomlaStorage\set(), Session\set(), BaseLayout\set(), Input\set(), RuntimeStorage\set(), NativeStorage\set(), Builder\set(), Task\set(), Container\set(), Stream\set(), PHPMailer\set(), Pagination\setAdditionalUrlParam(), Event\setArgument(), Input\setArgument(), AbstractEvent\setArgument(), Entry\setAttribute(), TraceablePDO\setAttribute(), WebAssetItem\setAttribute(), X509\setAttribute(), Validate\setCode(), GetIconEvent\setContext(), WorkflowsController\setDefault(), ItemsController\setDefault(), StagesController\setDefault(), OptionsResolver\setDefault(), WorkflowModel\setDefault(), StageModel\setDefault(), OptionsResolver\setDefaults(), AfterMoveEvent\setDelta(), BeforeMoveEvent\setDelta(), X509\setDN(), Result\setElement(), CronExpression\setExpression(), X509\setExtension(), X509\setExtensionHelper(), CaptiveRenderOptions\setField_type(), SetupRenderOptions\setField_type(), Form\setFieldAttribute(), OnGetApiFields\setFields(), FieldModel\setFieldValue(), ZIPExtraction\setFilename(), Builder\setHeader(), AbstractWebApplication\setHeader(), PhpHttpDriver\setHeaders(), JoomlaHttpDriver\setHeaders(), Nyholm\Psr7\setHeaders(), Laminas\Diactoros\setHeaders(), ItemModel\setHome(), BeforeBindEvent\setIgnore(), SaveSetup\setInput(), CaptiveRenderOptions\setInput_attributes(), SetupRenderOptions\setInput_attributes(), X509\setKeyIdentifier(), HtmlView\setLayoutExt(), Callback\setMethod(), Http\setOption(), Connection\setOption(), Input\setOption(), WebAssetItem\setOption(), ActionButton\setOption(), ToolbarButton\setOption(), PdoDriver\setOption(), Client\setOption(), NativeStorage\setOptions(), User\setParam(), InstallerScript\setParams(), CronExpression\setPart(), Installer\setPath(), DataObject\setProperty(), LanguagesModel\setPublished(), BeforeReorderEvent\setQuery(), BeforePublishEvent\setQuery(), BeforeMoveEvent\setQuery(), GetSetup\setRecord(), Captive\setRecord(), Validate\setRecord(), SaveSetup\setRecord(), Builder\setRegisteredClaim(), OnGetApiFields\setRelations(), SetNewTagsEvent\setReplaceTags(), BeforeLoadEvent\setReset(), AfterStoreEvent\setResult(), AfterLoadEvent\setResult(), Joomla\CMS\Event\Result\setResult(), X509\setRevokedCertificateExtension(), AfterMoveEvent\setRow(), AfterLoadEvent\setRow(), FixedTimeProvider\setSec(), PhpHttpDriver\setSessionValue(), JoomlaHttpDriver\setSessionValue(), BeforeBindEvent\setSrc(), Joomla\CMS\MVC\Model\setState(), BeforePublishEvent\setState(), PlgSystemHttpHeaders\setStaticHeaders(), WorkflowTransitionEvent\setStopTransition(), AbstractEvent\setSubject(), WebAssetRegistryAssetChanged\setSubject(), Client\setToken(), OnGetApiFields\setType(), TemplatesListField\setup(), UploaddirsField\setup(), TypeField\setup(), SectionField\setup(), VoteradioField\setup(), VotelistField\setup(), LanguageField\setup(), AssocField\setup(), JoomlatokenField\setup(), UsergrouplistField\setup(), TransitionField\setup(), WorkflowstageField\setup(), WorkflowconditionField\setup(), UserField\setup(), CategoryeditField\setup(), PredefinedlistField\setup(), IntervalField\setup(), ModuleorderField\setup(), PluginsField\setup(), CaptchaField\setup(), ModulesModuleField\setup(), ModulesPositionField\setup(), ModulepositionField\setup(), OrderingField\setup(), ChromestyleField\setup(), TimezoneField\setup(), FileField\setup(), ModulesPositioneditField\setup(), CheckboxField\setup(), TemplatestyleField\setup(), TimeField\setup(), SubfieldsField\setup(), CronField\setup(), ConsentBoxField\setup(), SqlField\setup(), CheckboxesField\setup(), AccessiblemediaField\setup(), RulesField\setup(), NumberField\setup(), TextareaField\setup(), MenuitemField\setup(), MeterField\setup(), MenuField\setup(), MenuItemByTypeField\setup(), FolderlistField\setup(), FilelistField\setup(), PasswordField\setup(), TextField\setup(), CalendarField\setup(), SubformField\setup(), ColorField\setup(), EditorField\setup(), MediaField\setup(), FormField\setup(), BeforeStoreEvent\setUpdateNulls(), FetchMediaItemUrlEvent\setUrl(), FixedTimeProvider\setUsec(), WorkflowFunctionalityUsedEvent\setUsed(), BeforeDisplayMethods\setUser(), Validate\setUser(), BeforeCheckoutEvent\setUserId(), BeforePublishEvent\setUserId(), CMSApplication\setUserState(), FormField\setValue(), Form\setValue(), Uri\setVar(), Router\setVar(), PharInvocation\setVariable(), AfterReorderEvent\setWhere(), BeforeReorderEvent\setWhere(), BeforeMoveEvent\setWhere(), AfterMoveEvent\setWhere(), SSH2\setWindowColumns(), SSH2\setWindowRows(), Container\share(), Uri\splitQueryValue(), AbstractSerializer\splitStream(), Assert\startsWith(), Assert\startsWithLetter(), Updatesites\state(), Manage\state(), Modules\state(), Messages\status(), PharStreamWrapper\stream_metadata(), Assert\string(), Assertion\string(), Assertion\stringify(), Assert\stringNotEmpty(), Ini\stringToObject(), Assert\strlen(), CliDumper\style(), HtmlDumper\style(), Assertion\subclassOf(), Assert\subclassOf(), CompletionSuggestions\suggestValue(), CompletionSuggestions\suggestValues(), Users\templatestyle(), UsernameRule\test(), NumberRule\test(), ColorRule\test(), TelRule\test(), CssIdentifierRule\test(), CssIdentifierSubstringRule\test(), ContactEmailRule\test(), ContactEmailSubjectRule\test(), FolderPathExistsRule\test(), FilePathRule\test(), OptionsRule\test(), SubformRule\test(), RulesRule\test(), ContactEmailMessageRule\test(), CaptchaRule\test(), CalendarRule\test(), EqualsRule\test(), NotequalsRule\test(), ExistsRule\test(), TimeRule\test(), UrlRule\test(), UserIdRule\test(), PasswordRule\test(), ExecutionRulesRule\test(), EmailRule\test(), FormRule\test(), PHPMailer\textLine(), Assert\that(), LazyAssertion\that(), Assert\thatNullOr(), IntegerOverflowException\toIntOverflow(), PlgUserProfile\tos(), InstallerModel\translate(), Parser\trimTag(), Assert\true(), Assertion\true(), Assert\typeToString(), Unescaper\unescapeCharacter(), Unescaper\unescapeDoubleQuotedString(), Unescaper\unescapeSingleQuotedString(), Assert\unicodeLetters(), Assertion\uniqueValues(), BigRational\unserialize(), SFTP\update_stat_cache(), Assert\upper(), PlgUserProfile\url(), Assertion\url(), RequestDataCollector\useHtmlVarDumper(), ConfigCollector\useHtmlVarDumper(), ExceptionsCollector\useHtmlVarDumper(), MessagesCollector\useHtmlVarDumper(), Assert\uuid(), Assertion\uuid(), Assert\validArrayKey(), TemplateParser\validate(), DayOfMonthField\validate(), DayOfWeekField\validate(), AbstractField\validate(), FormField\validate(), ExecutionRulesRule\validateField(), SetConfigurationCommand\validateOptions(), X509\validateURL(), Configuration\value(), Users\value(), Assert\valueToString(), OptionsResolver\verifyTypes(), Builder\with(), Nyholm\Psr7\withAddedHeader(), Laminas\Diactoros\withAddedHeader(), Link\withAttribute(), ServerRequest\withAttribute(), Builder\withClaim(), Nyholm\Psr7\withHeader(), Laminas\Diactoros\withHeader(), Builder\withHeader(), Assert\writable(), Assertion\writeable(), et SymfonyQuestionHelper\writePrompt().

◆ endif

endif

◆ if

if($showLabel==1) ( ! strlen$value )


Joomla CMS: Référence du fichier sect113r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect113r2.php

Structures de données

class sect113r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x0af.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0af.php

Variables

return ['ggyeols', 'ggyeolt', 'ggyeolp', 'ggyeolh', 'ggyeom', 'ggyeob', 'ggyeobs', 'ggyeos', 'ggyeoss', 'ggyeong', 'ggyeoj', 'ggyeoc', 'ggyeok', 'ggyeot', 'ggyeop', 'ggyeoh', 'ggye', 'ggyeg', 'ggyegg', 'ggyegs', 'ggyen', 'ggyenj', 'ggyenh', 'ggyed', 'ggyel', 'ggyelg', 'ggyelm', 'ggyelb', 'ggyels', 'ggyelt', 'ggyelp', 'ggyelh', 'ggyem', 'ggyeb', 'ggyebs', 'ggyes', 'ggyess', 'ggyeng', 'ggyej', 'ggyec', 'ggyek', 'ggyet', 'ggyep', 'ggyeh', 'ggo', 'ggog', 'ggogg', 'ggogs', 'ggon', 'ggonj', 'ggonh', 'ggod', 'ggol', 'ggolg', 'ggolm', 'ggolb', 'ggols', 'ggolt', 'ggolp', 'ggolh', 'ggom', 'ggob', 'ggobs', 'ggos', 'ggoss', 'ggong', 'ggoj', 'ggoc', 'ggok', 'ggot', 'ggop', 'ggoh', 'ggwa', 'ggwag', 'ggwagg', 'ggwags', 'ggwan', 'ggwanj', 'ggwanh', 'ggwad', 'ggwal', 'ggwalg', 'ggwalm', 'ggwalb', 'ggwals', 'ggwalt', 'ggwalp', 'ggwalh', 'ggwam', 'ggwab', 'ggwabs', 'ggwas', 'ggwass', 'ggwang', 'ggwaj', 'ggwac', 'ggwak', 'ggwat', 'ggwap', 'ggwah', 'ggwae', 'ggwaeg', 'ggwaegg', 'ggwaegs', 'ggwaen', 'ggwaenj', 'ggwaenh', 'ggwaed', 'ggwael', 'ggwaelg', 'ggwaelm', 'ggwaelb', 'ggwaels', 'ggwaelt', 'ggwaelp', 'ggwaelh', 'ggwaem', 'ggwaeb', 'ggwaebs', 'ggwaes', 'ggwaess', 'ggwaeng', 'ggwaej', 'ggwaec', 'ggwaek', 'ggwaet', 'ggwaep', 'ggwaeh', 'ggoe', 'ggoeg', 'ggoegg', 'ggoegs', 'ggoen', 'ggoenj', 'ggoenh', 'ggoed', 'ggoel', 'ggoelg', 'ggoelm', 'ggoelb', 'ggoels', 'ggoelt', 'ggoelp', 'ggoelh', 'ggoem', 'ggoeb', 'ggoebs', 'ggoes', 'ggoess', 'ggoeng', 'ggoej', 'ggoec', 'ggoek', 'ggoet', 'ggoep', 'ggoeh', 'ggyo', 'ggyog', 'ggyogg', 'ggyogs', 'ggyon', 'ggyonj', 'ggyonh', 'ggyod', 'ggyol', 'ggyolg', 'ggyolm', 'ggyolb', 'ggyols', 'ggyolt', 'ggyolp', 'ggyolh', 'ggyom', 'ggyob', 'ggyobs', 'ggyos', 'ggyoss', 'ggyong', 'ggyoj', 'ggyoc', 'ggyok', 'ggyot', 'ggyop', 'ggyoh', 'ggu', 'ggug', 'ggugg', 'ggugs', 'ggun', 'ggunj', 'ggunh', 'ggud', 'ggul', 'ggulg', 'ggulm', 'ggulb', 'gguls', 'ggult', 'ggulp', 'ggulh', 'ggum', 'ggub', 'ggubs', 'ggus', 'gguss', 'ggung', 'gguj', 'gguc', 'gguk', 'ggut', 'ggup', 'gguh', 'ggweo', 'ggweog', 'ggweogg', 'ggweogs', 'ggweon', 'ggweonj', 'ggweonh', 'ggweod', 'ggweol', 'ggweolg', 'ggweolm', 'ggweolb', 'ggweols', 'ggweolt', 'ggweolp', 'ggweolh', 'ggweom', 'ggweob', 'ggweobs', 'ggweos', 'ggweoss', 'ggweong', 'ggweoj', 'ggweoc', 'ggweok', 'ggweot', 'ggweop', 'ggweoh', 'ggwe', 'ggweg', 'ggwegg', 'ggwegs', 'ggwen', 'ggwenj', 'ggwenh', 'ggwed', 'ggwel', 'ggwelg', 'ggwelm', 'ggwelb', 'ggwels', 'ggwelt', 'ggwelp', 'ggwelh']

Documentation des variables

◆ return

return[ 'ggyeols', 'ggyeolt', 'ggyeolp', 'ggyeolh', 'ggyeom', 'ggyeob', 'ggyeobs', 'ggyeos', 'ggyeoss', 'ggyeong', 'ggyeoj', 'ggyeoc', 'ggyeok', 'ggyeot', 'ggyeop', 'ggyeoh', 'ggye', 'ggyeg', 'ggyegg', 'ggyegs', 'ggyen', 'ggyenj', 'ggyenh', 'ggyed', 'ggyel', 'ggyelg', 'ggyelm', 'ggyelb', 'ggyels', 'ggyelt', 'ggyelp', 'ggyelh', 'ggyem', 'ggyeb', 'ggyebs', 'ggyes', 'ggyess', 'ggyeng', 'ggyej', 'ggyec', 'ggyek', 'ggyet', 'ggyep', 'ggyeh', 'ggo', 'ggog', 'ggogg', 'ggogs', 'ggon', 'ggonj', 'ggonh', 'ggod', 'ggol', 'ggolg', 'ggolm', 'ggolb', 'ggols', 'ggolt', 'ggolp', 'ggolh', 'ggom', 'ggob', 'ggobs', 'ggos', 'ggoss', 'ggong', 'ggoj', 'ggoc', 'ggok', 'ggot', 'ggop', 'ggoh', 'ggwa', 'ggwag', 'ggwagg', 'ggwags', 'ggwan', 'ggwanj', 'ggwanh', 'ggwad', 'ggwal', 'ggwalg', 'ggwalm', 'ggwalb', 'ggwals', 'ggwalt', 'ggwalp', 'ggwalh', 'ggwam', 'ggwab', 'ggwabs', 'ggwas', 'ggwass', 'ggwang', 'ggwaj', 'ggwac', 'ggwak', 'ggwat', 'ggwap', 'ggwah', 'ggwae', 'ggwaeg', 'ggwaegg', 'ggwaegs', 'ggwaen', 'ggwaenj', 'ggwaenh', 'ggwaed', 'ggwael', 'ggwaelg', 'ggwaelm', 'ggwaelb', 'ggwaels', 'ggwaelt', 'ggwaelp', 'ggwaelh', 'ggwaem', 'ggwaeb', 'ggwaebs', 'ggwaes', 'ggwaess', 'ggwaeng', 'ggwaej', 'ggwaec', 'ggwaek', 'ggwaet', 'ggwaep', 'ggwaeh', 'ggoe', 'ggoeg', 'ggoegg', 'ggoegs', 'ggoen', 'ggoenj', 'ggoenh', 'ggoed', 'ggoel', 'ggoelg', 'ggoelm', 'ggoelb', 'ggoels', 'ggoelt', 'ggoelp', 'ggoelh', 'ggoem', 'ggoeb', 'ggoebs', 'ggoes', 'ggoess', 'ggoeng', 'ggoej', 'ggoec', 'ggoek', 'ggoet', 'ggoep', 'ggoeh', 'ggyo', 'ggyog', 'ggyogg', 'ggyogs', 'ggyon', 'ggyonj', 'ggyonh', 'ggyod', 'ggyol', 'ggyolg', 'ggyolm', 'ggyolb', 'ggyols', 'ggyolt', 'ggyolp', 'ggyolh', 'ggyom', 'ggyob', 'ggyobs', 'ggyos', 'ggyoss', 'ggyong', 'ggyoj', 'ggyoc', 'ggyok', 'ggyot', 'ggyop', 'ggyoh', 'ggu', 'ggug', 'ggugg', 'ggugs', 'ggun', 'ggunj', 'ggunh', 'ggud', 'ggul', 'ggulg', 'ggulm', 'ggulb', 'gguls', 'ggult', 'ggulp', 'ggulh', 'ggum', 'ggub', 'ggubs', 'ggus', 'gguss', 'ggung', 'gguj', 'gguc', 'gguk', 'ggut', 'ggup', 'gguh', 'ggweo', 'ggweog', 'ggweogg', 'ggweogs', 'ggweon', 'ggweonj', 'ggweonh', 'ggweod', 'ggweol', 'ggweolg', 'ggweolm', 'ggweolb', 'ggweols', 'ggweolt', 'ggweolp', 'ggweolh', 'ggweom', 'ggweob', 'ggweobs', 'ggweos', 'ggweoss', 'ggweong', 'ggweoj', 'ggweoc', 'ggweok', 'ggweot', 'ggweop', 'ggweoh', 'ggwe', 'ggweg', 'ggwegg', 'ggwegs', 'ggwen', 'ggwenj', 'ggwenh', 'ggwed', 'ggwel', 'ggwelg', 'ggwelm', 'ggwelb', 'ggwels', 'ggwelt', 'ggwelp', 'ggwelh']


Joomla CMS: Référence du fichier PDOCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
  • PDO
Structures de données | Espaces de nommage
Référence du fichier PDOCollector.php

Structures de données

class PDOCollector

Espaces de nommage

DebugBar\DataCollector\PDO


Joomla CMS: Référence du fichier user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/user.php

Espaces de nommage

Joomla\Site

Variables

$modalHTML = ''
$uri = new Uri('index.php?option=com_users&view=users&layout=modal&tmpl=component&required=0')
if($required) if(!empty($groups)) if(!empty($excluded)) if($this->escape($userName)===Text::_('JLIB_FORM_SELECT_USER')) | $inputAttributes
if($class) if($size) if($required) if(! $readonly) if(! $readonly)< joomla-field-user class="field-user-wrapper" url="<?php echo (string) $uri; ?> | modal
endif
if (! $readonly)

Documentation des variables

◆ $inputAttributes

if ( $required) if (!empty( $groups)) if (!empty( $excluded)) if ( $this->escape( $userName)===Text::_( 'JLIB_FORM_SELECT_USER')) $inputAttributes
Valeur initiale :
= array(
'type' => 'text', 'id' => $id, 'class' => 'form-control field-user-input-name', 'value' => $this->escape($userName)
)
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93

◆ $modalHTML

$modalHTML = ''

◆ $uri

$uri = new Uri('index.php?option=com_users&view=users&layout=modal&tmpl=component&required=0')

◆ endif

endif

◆ if

if(! $readonly)

◆ modal

if ( $class) if ( $size) if ( $required) if (! $readonly) if (! $readonly)<joomla-field-user class="field-user-wrapper" url="<?php echo (string) $uri; ?> modal
Valeur initiale :
=".modal"
modal-width="100%"
modal-height="400px"
input=".field-user-input"
input-name=".field-user-input-name"
button-select=".button-select">
<div class="input-group">
<input <?php echo ArrayHelper::toString($inputAttributes), $dataAttribute
$dataAttribute
$dataAttribute
Definition: advanced.php:80
name
$this name
Definition: default_cache.php:16
width
$wa usePreset('template.atum.' .($this->direction==='rtl' ? 'rtl' :'ltr')) -> useStyle('template.active.language') ->useStyle('template.user') ->addInlineStyle(':root template active template active template atum rtl rtl ltr viewport width
Definition: error_full.php:73
$inputAttributes
if($required) if(!empty($groups)) if(!empty($excluded)) if($this->escape($userName)===Text::_('JLIB_FORM_SELECT_USER')) $inputAttributes
Definition: layouts/joomla/form/field/user.php:75
modal
if($class) if($size) if($required) if(! $readonly) if(! $readonly)< joomla-field-user class="field-user-wrapper" url="<?php echo (string) $uri; ?> modal
Definition: layouts/joomla/form/field/user.php:114


Joomla CMS: Référence du fichier UnsupportedFormatException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedFormatException.php

Structures de données

class UnsupportedFormatException

Espaces de nommage

UnsupportedFormatException
phpseclib3\Exception


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/totp/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PopupButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier PopupButton.php

Structures de données

class PopupButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier ThrowingCasterException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ThrowingCasterException.php

Structures de données

class ThrowingCasterException

Espaces de nommage

Symfony\Component\VarDumper\Exception


Joomla CMS: Référence du fichier x021.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x021.php

Variables

return [' a/c ', ' a/s ', 'C', '', '', ' c/o ', ' c/u ', '', '', '', 'g', 'H', 'H', 'H', 'h', '', 'I', 'I', 'L', 'l', '', 'N', 'No. ', '', '', 'P', 'Q', 'R', 'R', 'R', '', '', '(sm)', 'TEL', '(tm)', '', 'Z', '', '', '', 'Z', '', 'K', 'A', 'B', 'C', 'e', 'e', 'E', 'F', 'F', 'M', 'o', '', '', '', '', 'i', '', 'FAX', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', 'D', 'd', 'e', 'i', 'j', '[?]', '[?]', '[?]', '[?]', 'F', '[?]', ' 1/7 ', ' 1/9 ', ' 1/10 ', ' 1/3 ', ' 2/3 ', ' 1/5 ', ' 2/5 ', ' 3/5 ', ' 4/5 ', ' 1/6 ', ' 5/6 ', ' 1/8 ', ' 3/8 ', ' 5/8 ', ' 7/8 ', ' 1/', 'I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'L', 'C', 'D', 'M', 'i', 'ii', 'iii', 'iv', 'v', 'vi', 'vii', 'viii', 'ix', 'x', 'xi', 'xii', 'l', 'c', 'd', 'm', '(D', 'D)', '((|))', ')', '[?]', '[?]', '[?]', '[?]', '[?]', ' 0/3 ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '-', '|', '-', '|', '-', '|', '\\', '/', '\\', '/', '-', '-', '~', '~', '-', '|', '-', '|', '-', '-', '-', '|', '-', '|', '|', '-', '-', '-', '-', '-', '-', '|', '|', '|', '|', '|', '|', '|', '^', 'V', '\\', '=', 'V', '^', '-', '-', '|', '|', '-', '-', '|', '|', '=', '|', '=', '=', '|', '=', '|', '=', '=', '=', '=', '=', '=', '|', '=', '|', '=', '|', '\\', '/', '\\', '/', '=', '=', '~', '~', '|', '|', '-', '|', '-', '|', '-', '-', '-', '|', '-', '|', '|', '|', '|', '|', '|', '|', '-', '\\', '\\', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[' a/c ', ' a/s ', 'C', '', '', ' c/o ', ' c/u ', '', '', '', 'g', 'H', 'H', 'H', 'h', '', 'I', 'I', 'L', 'l', '', 'N', 'No. ', '', '', 'P', 'Q', 'R', 'R', 'R', '', '', '(sm)', 'TEL', '(tm)', '', 'Z', '', '', '', 'Z', '', 'K', 'A', 'B', 'C', 'e', 'e', 'E', 'F', 'F', 'M', 'o', '', '', '', '', 'i', '', 'FAX', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', 'D', 'd', 'e', 'i', 'j', '[?]', '[?]', '[?]', '[?]', 'F', '[?]', ' 1/7 ', ' 1/9 ', ' 1/10 ', ' 1/3 ', ' 2/3 ', ' 1/5 ', ' 2/5 ', ' 3/5 ', ' 4/5 ', ' 1/6 ', ' 5/6 ', ' 1/8 ', ' 3/8 ', ' 5/8 ', ' 7/8 ', ' 1/', 'I', 'II', 'III', 'IV', 'V', 'VI', 'VII', 'VIII', 'IX', 'X', 'XI', 'XII', 'L', 'C', 'D', 'M', 'i', 'ii', 'iii', 'iv', 'v', 'vi', 'vii', 'viii', 'ix', 'x', 'xi', 'xii', 'l', 'c', 'd', 'm', '(D', 'D)', '((|))', ')', '[?]', '[?]', '[?]', '[?]', '[?]', ' 0/3 ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '-', '|', '-', '|', '-', '|', '\\', '/', '\\', '/', '-', '-', '~', '~', '-', '|', '-', '|', '-', '-', '-', '|', '-', '|', '|', '-', '-', '-', '-', '-', '-', '|', '|', '|', '|', '|', '|', '|', '^', 'V', '\\', '=', 'V', '^', '-', '-', '|', '|', '-', '-', '|', '|', '=', '|', '=', '=', '|', '=', '|', '=', '=', '=', '=', '=', '=', '|', '=', '|', '=', '|', '\\', '/', '\\', '/', '=', '=', '~', '~', '|', '|', '-', '|', '-', '|', '-', '-', '-', '|', '-', '|', '|', '|', '|', '|', '|', '|', '-', '\\', '\\', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier TelephoneField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TelephoneField.php

Structures de données

class TelephoneField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier UpdatesitesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier UpdatesitesController.php

Structures de données

class UpdatesitesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier Sodium.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Cipher
Structures de données | Espaces de nommage
Référence du fichier Sodium.php

Structures de données

class Sodium

Espaces de nommage

Joomla\Crypt\Cipher


Joomla CMS: of

of

registry file:

{ "title" : "Example", "name" : "com_example", "author": "Joomla! CMS", "assets": [ { "name": "library1", "version": "3.5.0", "type": "script", "uri": "com_example/library1.min.js" }, { "name": "library2", "version": "3.5.0", "type": "script", "uri": "com_example/library2.min.js", "dependencies": [ "core", "library1" ], "attribute": { "attr-name": "attr value" "defer": true } }, { "name": "library1", "version": "3.5.0", "type": "style", "uri": "com_example/library1.min.css" "attribute": { "media": "all" } }, { "name": "library1", "type": "preset", "dependencies": { "library1#style", "library1#script" } }, ] }

Depuis
4.0.0


Joomla CMS: Référence du fichier StringInput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Input
Structures de données | Espaces de nommage
Référence du fichier StringInput.php

Structures de données

class StringInput

Espaces de nommage

Symfony\Component\Console\Input


Joomla CMS: Référence du fichier x056.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x056.php

Variables

return ['Di ', 'Qi ', 'Jiao ', 'Chong ', 'Jiao ', 'Kai ', 'Tan ', 'San ', 'Cao ', 'Jia ', 'Ai ', 'Xiao ', 'Piao ', 'Lou ', 'Ga ', 'Gu ', 'Xiao ', 'Hu ', 'Hui ', 'Guo ', 'Ou ', 'Xian ', 'Ze ', 'Chang ', 'Xu ', 'Po ', 'De ', 'Ma ', 'Ma ', 'Hu ', 'Lei ', 'Du ', 'Ga ', 'Tang ', 'Ye ', 'Beng ', 'Ying ', 'Saai ', 'Jiao ', 'Mi ', 'Xiao ', 'Hua ', 'Mai ', 'Ran ', 'Zuo ', 'Peng ', 'Lao ', 'Xiao ', 'Ji ', 'Zhu ', 'Chao ', 'Kui ', 'Zui ', 'Xiao ', 'Si ', 'Hao ', 'Fu ', 'Liao ', 'Qiao ', 'Xi ', 'Xiu ', 'Tan ', 'Tan ', 'Mo ', 'Xun ', 'E ', 'Zun ', 'Fan ', 'Chi ', 'Hui ', 'Zan ', 'Chuang ', 'Cu ', 'Dan ', 'Yu ', 'Tun ', 'Cheng ', 'Jiao ', 'Ye ', 'Xi ', 'Qi ', 'Hao ', 'Lian ', 'Xu ', 'Deng ', 'Hui ', 'Yin ', 'Pu ', 'Jue ', 'Qin ', 'Xun ', 'Nie ', 'Lu ', 'Si ', 'Yan ', 'Ying ', 'Da ', 'Dan ', 'Yu ', 'Zhou ', 'Jin ', 'Nong ', 'Yue ', 'Hui ', 'Qi ', 'E ', 'Zao ', 'Yi ', 'Shi ', 'Jiao ', 'Yuan ', 'Ai ', 'Yong ', 'Jue ', 'Kuai ', 'Yu ', 'Pen ', 'Dao ', 'Ge ', 'Xin ', 'Dun ', 'Dang ', 'Sin ', 'Sai ', 'Pi ', 'Pi ', 'Yin ', 'Zui ', 'Ning ', 'Di ', 'Lan ', 'Ta ', 'Huo ', 'Ru ', 'Hao ', 'Xia ', 'Ya ', 'Duo ', 'Xi ', 'Chou ', 'Ji ', 'Jin ', 'Hao ', 'Ti ', 'Chang ', '[?] ', '[?] ', 'Ca ', 'Ti ', 'Lu ', 'Hui ', 'Bo ', 'You ', 'Nie ', 'Yin ', 'Hu ', 'Mo ', 'Huang ', 'Zhe ', 'Li ', 'Liu ', 'Haai ', 'Nang ', 'Xiao ', 'Mo ', 'Yan ', 'Li ', 'Lu ', 'Long ', 'Fu ', 'Dan ', 'Chen ', 'Pin ', 'Pi ', 'Xiang ', 'Huo ', 'Mo ', 'Xi ', 'Duo ', 'Ku ', 'Yan ', 'Chan ', 'Ying ', 'Rang ', 'Dian ', 'La ', 'Ta ', 'Xiao ', 'Jiao ', 'Chuo ', 'Huan ', 'Huo ', 'Zhuan ', 'Nie ', 'Xiao ', 'Ca ', 'Li ', 'Chan ', 'Chai ', 'Li ', 'Yi ', 'Luo ', 'Nang ', 'Zan ', 'Su ', 'Xi ', 'So ', 'Jian ', 'Za ', 'Zhu ', 'Lan ', 'Nie ', 'Nang ', '[?] ', '[?] ', 'Wei ', 'Hui ', 'Yin ', 'Qiu ', 'Si ', 'Nin ', 'Jian ', 'Hui ', 'Xin ', 'Yin ', 'Nan ', 'Tuan ', 'Tuan ', 'Dun ', 'Kang ', 'Yuan ', 'Jiong ', 'Pian ', 'Yun ', 'Cong ', 'Hu ', 'Hui ', 'Yuan ', 'You ', 'Guo ', 'Kun ', 'Cong ', 'Wei ', 'Tu ', 'Wei ', 'Lun ', 'Guo ', 'Qun ', 'Ri ', 'Ling ', 'Gu ', 'Guo ', 'Tai ', 'Guo ', 'Tu ', 'You ']

Documentation des variables

◆ return

return[ 'Di ', 'Qi ', 'Jiao ', 'Chong ', 'Jiao ', 'Kai ', 'Tan ', 'San ', 'Cao ', 'Jia ', 'Ai ', 'Xiao ', 'Piao ', 'Lou ', 'Ga ', 'Gu ', 'Xiao ', 'Hu ', 'Hui ', 'Guo ', 'Ou ', 'Xian ', 'Ze ', 'Chang ', 'Xu ', 'Po ', 'De ', 'Ma ', 'Ma ', 'Hu ', 'Lei ', 'Du ', 'Ga ', 'Tang ', 'Ye ', 'Beng ', 'Ying ', 'Saai ', 'Jiao ', 'Mi ', 'Xiao ', 'Hua ', 'Mai ', 'Ran ', 'Zuo ', 'Peng ', 'Lao ', 'Xiao ', 'Ji ', 'Zhu ', 'Chao ', 'Kui ', 'Zui ', 'Xiao ', 'Si ', 'Hao ', 'Fu ', 'Liao ', 'Qiao ', 'Xi ', 'Xiu ', 'Tan ', 'Tan ', 'Mo ', 'Xun ', 'E ', 'Zun ', 'Fan ', 'Chi ', 'Hui ', 'Zan ', 'Chuang ', 'Cu ', 'Dan ', 'Yu ', 'Tun ', 'Cheng ', 'Jiao ', 'Ye ', 'Xi ', 'Qi ', 'Hao ', 'Lian ', 'Xu ', 'Deng ', 'Hui ', 'Yin ', 'Pu ', 'Jue ', 'Qin ', 'Xun ', 'Nie ', 'Lu ', 'Si ', 'Yan ', 'Ying ', 'Da ', 'Dan ', 'Yu ', 'Zhou ', 'Jin ', 'Nong ', 'Yue ', 'Hui ', 'Qi ', 'E ', 'Zao ', 'Yi ', 'Shi ', 'Jiao ', 'Yuan ', 'Ai ', 'Yong ', 'Jue ', 'Kuai ', 'Yu ', 'Pen ', 'Dao ', 'Ge ', 'Xin ', 'Dun ', 'Dang ', 'Sin ', 'Sai ', 'Pi ', 'Pi ', 'Yin ', 'Zui ', 'Ning ', 'Di ', 'Lan ', 'Ta ', 'Huo ', 'Ru ', 'Hao ', 'Xia ', 'Ya ', 'Duo ', 'Xi ', 'Chou ', 'Ji ', 'Jin ', 'Hao ', 'Ti ', 'Chang ', '[?] ', '[?] ', 'Ca ', 'Ti ', 'Lu ', 'Hui ', 'Bo ', 'You ', 'Nie ', 'Yin ', 'Hu ', 'Mo ', 'Huang ', 'Zhe ', 'Li ', 'Liu ', 'Haai ', 'Nang ', 'Xiao ', 'Mo ', 'Yan ', 'Li ', 'Lu ', 'Long ', 'Fu ', 'Dan ', 'Chen ', 'Pin ', 'Pi ', 'Xiang ', 'Huo ', 'Mo ', 'Xi ', 'Duo ', 'Ku ', 'Yan ', 'Chan ', 'Ying ', 'Rang ', 'Dian ', 'La ', 'Ta ', 'Xiao ', 'Jiao ', 'Chuo ', 'Huan ', 'Huo ', 'Zhuan ', 'Nie ', 'Xiao ', 'Ca ', 'Li ', 'Chan ', 'Chai ', 'Li ', 'Yi ', 'Luo ', 'Nang ', 'Zan ', 'Su ', 'Xi ', 'So ', 'Jian ', 'Za ', 'Zhu ', 'Lan ', 'Nie ', 'Nang ', '[?] ', '[?] ', 'Wei ', 'Hui ', 'Yin ', 'Qiu ', 'Si ', 'Nin ', 'Jian ', 'Hui ', 'Xin ', 'Yin ', 'Nan ', 'Tuan ', 'Tuan ', 'Dun ', 'Kang ', 'Yuan ', 'Jiong ', 'Pian ', 'Yun ', 'Cong ', 'Hu ', 'Hui ', 'Yuan ', 'You ', 'Guo ', 'Kun ', 'Cong ', 'Wei ', 'Tu ', 'Wei ', 'Lun ', 'Guo ', 'Qun ', 'Ri ', 'Ling ', 'Gu ', 'Guo ', 'Tai ', 'Guo ', 'Tu ', 'You ']


Joomla CMS: Référence du fichier StreamTransport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
  • Transport
Structures de données | Espaces de nommage
Référence du fichier StreamTransport.php

Structures de données

class StreamTransport

Espaces de nommage

Joomla\CMS\Http\Transport


Joomla CMS: Référence du fichier TagsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/Model/TagsModel.php

Structures de données

class TagsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Model


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Helper


Joomla CMS: Référence du fichier TableCell.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TableCell.php

Structures de données

class TableCell

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier Transformations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Transformations.php

Structures de données

class Transformations

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier UndefinedObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier UndefinedObject.php

Structures de données

class UndefinedObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier QueryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier symfony/ldap/Adapter/QueryInterface.php

Structures de données

interface QueryInterface

Espaces de nommage

Symfony\Component\Ldap\Adapter


Joomla CMS: Référence du fichier TaggedValue.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
  • Tag
Structures de données | Espaces de nommage
Référence du fichier TaggedValue.php

Structures de données

class TaggedValue

Espaces de nommage

Symfony\Component\Yaml\Tag


Joomla CMS: Référence du fichier sect283r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect283r1.php

Structures de données

class sect283r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier UserMessagesField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_messages
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier UserMessagesField.php

Structures de données

class UserMessagesField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Messages\Administrator\Field


Joomla CMS: Référence du fichier sect409r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect409r1.php

Structures de données

class sect409r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x04d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x04d.php

Variables

return ['[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier PrimeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
Structures de données | Espaces de nommage
Référence du fichier PrimeField.php

Structures de données

class PrimeField

Espaces de nommage

BigInteger
phpseclib3\Math
Math


Joomla CMS: Référence du fichier UndefinedOptionsException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • options-resolver
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UndefinedOptionsException.php

Structures de données

class UndefinedOptionsException

Espaces de nommage

Symfony\Component\OptionsResolver\Exception


Joomla CMS: Référence du fichier UsersController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_users/src/Controller/UsersController.php

Structures de données

class UsersController

Espaces de nommage

Joomla\API
Joomla\Component\Users\Api\Controller


Joomla CMS: Référence du fichier PluginModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier PluginModel.php

Structures de données

class PluginModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Model


Joomla CMS: Référence du fichier statscollection.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier statscollection.php

Espaces de nommage

Joomla\Administrator

Fonctions

admin_postinstall_statscollection_condition ()

Documentation des fonctions

◆ admin_postinstall_statscollection_condition()

admin_postinstall_statscollection_condition ( )

Alerts the user we are collecting anonymous data as of Joomla 3.5.0.

Renvoie
boolean
Depuis
3.5


Joomla CMS: Référence du fichier sodium_compat.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Espaces de nommage
Référence du fichier sodium_compat.php

Espaces de nommage

Sodium


Joomla CMS: Référence du fichier UserNotice.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier UserNotice.php

Structures de données

class UserNotice

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier TimeProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
Structures de données | Espaces de nommage
Référence du fichier TimeProviderInterface.php

Structures de données

interface TimeProviderInterface

Espaces de nommage

Ramsey\Uuid\Provider


Joomla CMS: Référence du fichier packageinstaller.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • packageinstaller
Structures de données | Espaces de nommage
Référence du fichier packageinstaller.php

Structures de données

class PlgInstallerPackageInstaller

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier TinymcebuilderField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TinymcebuilderField.php

Structures de données

class TinymcebuilderField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\Field


Joomla CMS: Référence du fichier Path.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Path.php

Structures de données

class Path

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier RSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/RSA.php

Structures de données

class RSA

Espaces de nommage

RSA
phpseclib3\Crypt


Joomla CMS: Référence du fichier Twofish.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier Twofish.php

Structures de données

class Twofish

Espaces de nommage

Twofish
phpseclib3\Crypt


Joomla CMS: Référence du fichier Xml.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
Structures de données | Espaces de nommage
Référence du fichier src/Application/CLI/Output/Xml.php

Structures de données

class Xml

Espaces de nommage

Joomla\CMS\Application\CLI\Output


Joomla CMS: Référence du fichier Stdout.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Application
  • CLI
  • Output
Structures de données | Espaces de nommage
Référence du fichier Stdout.php

Structures de données

class Stdout

Espaces de nommage

Joomla\CMS\Application\CLI\Output


Joomla CMS: Référence du fichier SignalableCommandInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Command
Structures de données | Espaces de nommage
Référence du fichier SignalableCommandInterface.php

Structures de données

interface SignalableCommandInterface

Espaces de nommage

Symfony\Component\Console\Command


Joomla CMS: Référence du fichier x027.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x027.php


Joomla CMS: Référence du fichier TaskModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier TaskModel.php

Structures de données

class TaskModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Model


Joomla CMS: Référence du fichier PKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/PKCS1.php

Structures de données

class PKCS1

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys
RSA


Joomla CMS: Référence du fichier StringHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier src/HTML/Helpers/StringHelper.php

Structures de données

class StringHelper

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier RedisStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Storage
Structures de données | Espaces de nommage
Référence du fichier src/Cache/Storage/RedisStorage.php

Structures de données

class RedisStorage

Espaces de nommage

Joomla\CMS\Cache\Storage


Joomla CMS: Référence du fichier TaskOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Task
Structures de données | Espaces de nommage
Référence du fichier TaskOptions.php

Structures de données

class TaskOptions

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Task


Joomla CMS: Référence du fichier XML.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Keys/XML.php

Structures de données

class XML

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier UserProfileFields.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage | Fonctions | Variables
Référence du fichier UserProfileFields.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits

Fonctions

getUserFromData ($data)
canEditUser (?User $user=null)

Variables

trait UserProfileFields


Joomla CMS: Référence du fichier x098.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x098.php

Variables

return ['Hu ', 'Ye ', 'Ding ', 'Qing ', 'Pan ', 'Xiang ', 'Shun ', 'Han ', 'Xu ', 'Yi ', 'Xu ', 'Gu ', 'Song ', 'Kui ', 'Qi ', 'Hang ', 'Yu ', 'Wan ', 'Ban ', 'Dun ', 'Di ', 'Dan ', 'Pan ', 'Po ', 'Ling ', 'Ce ', 'Jing ', 'Lei ', 'He ', 'Qiao ', 'E ', 'E ', 'Wei ', 'Jie ', 'Gua ', 'Shen ', 'Yi ', 'Shen ', 'Hai ', 'Dui ', 'Pian ', 'Ping ', 'Lei ', 'Fu ', 'Jia ', 'Tou ', 'Hui ', 'Kui ', 'Jia ', 'Le ', 'Tian ', 'Cheng ', 'Ying ', 'Jun ', 'Hu ', 'Han ', 'Jing ', 'Tui ', 'Tui ', 'Pin ', 'Lai ', 'Tui ', 'Zi ', 'Zi ', 'Chui ', 'Ding ', 'Lai ', 'Yan ', 'Han ', 'Jian ', 'Ke ', 'Cui ', 'Jiong ', 'Qin ', 'Yi ', 'Sai ', 'Ti ', 'E ', 'E ', 'Yan ', 'Hun ', 'Kan ', 'Yong ', 'Zhuan ', 'Yan ', 'Xian ', 'Xin ', 'Yi ', 'Yuan ', 'Sang ', 'Dian ', 'Dian ', 'Jiang ', 'Ku ', 'Lei ', 'Liao ', 'Piao ', 'Yi ', 'Man ', 'Qi ', 'Rao ', 'Hao ', 'Qiao ', 'Gu ', 'Xun ', 'Qian ', 'Hui ', 'Zhan ', 'Ru ', 'Hong ', 'Bin ', 'Xian ', 'Pin ', 'Lu ', 'Lan ', 'Nie ', 'Quan ', 'Ye ', 'Ding ', 'Qing ', 'Han ', 'Xiang ', 'Shun ', 'Xu ', 'Xu ', 'Wan ', 'Gu ', 'Dun ', 'Qi ', 'Ban ', 'Song ', 'Hang ', 'Yu ', 'Lu ', 'Ling ', 'Po ', 'Jing ', 'Jie ', 'Jia ', 'Tian ', 'Han ', 'Ying ', 'Jiong ', 'Hai ', 'Yi ', 'Pin ', 'Hui ', 'Tui ', 'Han ', 'Ying ', 'Ying ', 'Ke ', 'Ti ', 'Yong ', 'E ', 'Zhuan ', 'Yan ', 'E ', 'Nie ', 'Man ', 'Dian ', 'Sang ', 'Hao ', 'Lei ', 'Zhan ', 'Ru ', 'Pin ', 'Quan ', 'Feng ', 'Biao ', 'Oroshi ', 'Fu ', 'Xia ', 'Zhan ', 'Biao ', 'Sa ', 'Ba ', 'Tai ', 'Lie ', 'Gua ', 'Xuan ', 'Shao ', 'Ju ', 'Bi ', 'Si ', 'Wei ', 'Yang ', 'Yao ', 'Sou ', 'Kai ', 'Sao ', 'Fan ', 'Liu ', 'Xi ', 'Liao ', 'Piao ', 'Piao ', 'Liu ', 'Biao ', 'Biao ', 'Biao ', 'Liao ', '[?] ', 'Se ', 'Feng ', 'Biao ', 'Feng ', 'Yang ', 'Zhan ', 'Biao ', 'Sa ', 'Ju ', 'Si ', 'Sou ', 'Yao ', 'Liu ', 'Piao ', 'Biao ', 'Biao ', 'Fei ', 'Fan ', 'Fei ', 'Fei ', 'Shi ', 'Shi ', 'Can ', 'Ji ', 'Ding ', 'Si ', 'Tuo ', 'Zhan ', 'Sun ', 'Xiang ', 'Tun ', 'Ren ', 'Yu ', 'Juan ', 'Chi ', 'Yin ', 'Fan ', 'Fan ', 'Sun ', 'Yin ', 'Zhu ', 'Yi ', 'Zhai ', 'Bi ', 'Jie ', 'Tao ', 'Liu ', 'Ci ', 'Tie ', 'Si ', 'Bao ', 'Shi ', 'Duo ']

Documentation des variables

◆ return

return[ 'Hu ', 'Ye ', 'Ding ', 'Qing ', 'Pan ', 'Xiang ', 'Shun ', 'Han ', 'Xu ', 'Yi ', 'Xu ', 'Gu ', 'Song ', 'Kui ', 'Qi ', 'Hang ', 'Yu ', 'Wan ', 'Ban ', 'Dun ', 'Di ', 'Dan ', 'Pan ', 'Po ', 'Ling ', 'Ce ', 'Jing ', 'Lei ', 'He ', 'Qiao ', 'E ', 'E ', 'Wei ', 'Jie ', 'Gua ', 'Shen ', 'Yi ', 'Shen ', 'Hai ', 'Dui ', 'Pian ', 'Ping ', 'Lei ', 'Fu ', 'Jia ', 'Tou ', 'Hui ', 'Kui ', 'Jia ', 'Le ', 'Tian ', 'Cheng ', 'Ying ', 'Jun ', 'Hu ', 'Han ', 'Jing ', 'Tui ', 'Tui ', 'Pin ', 'Lai ', 'Tui ', 'Zi ', 'Zi ', 'Chui ', 'Ding ', 'Lai ', 'Yan ', 'Han ', 'Jian ', 'Ke ', 'Cui ', 'Jiong ', 'Qin ', 'Yi ', 'Sai ', 'Ti ', 'E ', 'E ', 'Yan ', 'Hun ', 'Kan ', 'Yong ', 'Zhuan ', 'Yan ', 'Xian ', 'Xin ', 'Yi ', 'Yuan ', 'Sang ', 'Dian ', 'Dian ', 'Jiang ', 'Ku ', 'Lei ', 'Liao ', 'Piao ', 'Yi ', 'Man ', 'Qi ', 'Rao ', 'Hao ', 'Qiao ', 'Gu ', 'Xun ', 'Qian ', 'Hui ', 'Zhan ', 'Ru ', 'Hong ', 'Bin ', 'Xian ', 'Pin ', 'Lu ', 'Lan ', 'Nie ', 'Quan ', 'Ye ', 'Ding ', 'Qing ', 'Han ', 'Xiang ', 'Shun ', 'Xu ', 'Xu ', 'Wan ', 'Gu ', 'Dun ', 'Qi ', 'Ban ', 'Song ', 'Hang ', 'Yu ', 'Lu ', 'Ling ', 'Po ', 'Jing ', 'Jie ', 'Jia ', 'Tian ', 'Han ', 'Ying ', 'Jiong ', 'Hai ', 'Yi ', 'Pin ', 'Hui ', 'Tui ', 'Han ', 'Ying ', 'Ying ', 'Ke ', 'Ti ', 'Yong ', 'E ', 'Zhuan ', 'Yan ', 'E ', 'Nie ', 'Man ', 'Dian ', 'Sang ', 'Hao ', 'Lei ', 'Zhan ', 'Ru ', 'Pin ', 'Quan ', 'Feng ', 'Biao ', 'Oroshi ', 'Fu ', 'Xia ', 'Zhan ', 'Biao ', 'Sa ', 'Ba ', 'Tai ', 'Lie ', 'Gua ', 'Xuan ', 'Shao ', 'Ju ', 'Bi ', 'Si ', 'Wei ', 'Yang ', 'Yao ', 'Sou ', 'Kai ', 'Sao ', 'Fan ', 'Liu ', 'Xi ', 'Liao ', 'Piao ', 'Piao ', 'Liu ', 'Biao ', 'Biao ', 'Biao ', 'Liao ', '[?] ', 'Se ', 'Feng ', 'Biao ', 'Feng ', 'Yang ', 'Zhan ', 'Biao ', 'Sa ', 'Ju ', 'Si ', 'Sou ', 'Yao ', 'Liu ', 'Piao ', 'Biao ', 'Biao ', 'Fei ', 'Fan ', 'Fei ', 'Fei ', 'Shi ', 'Shi ', 'Can ', 'Ji ', 'Ding ', 'Si ', 'Tuo ', 'Zhan ', 'Sun ', 'Xiang ', 'Tun ', 'Ren ', 'Yu ', 'Juan ', 'Chi ', 'Yin ', 'Fan ', 'Fan ', 'Sun ', 'Yin ', 'Zhu ', 'Yi ', 'Zhai ', 'Bi ', 'Jie ', 'Tao ', 'Liu ', 'Ci ', 'Tie ', 'Si ', 'Bao ', 'Shi ', 'Duo ']


Joomla CMS: Référence du fichier x051.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x051.php

Variables

return ['Yi ', 'Jun ', 'Nong ', 'Chan ', 'Yi ', 'Dang ', 'Jing ', 'Xuan ', 'Kuai ', 'Jian ', 'Chu ', 'Dan ', 'Jiao ', 'Sha ', 'Zai ', '[?] ', 'Bin ', 'An ', 'Ru ', 'Tai ', 'Chou ', 'Chai ', 'Lan ', 'Ni ', 'Jin ', 'Qian ', 'Meng ', 'Wu ', 'Ning ', 'Qiong ', 'Ni ', 'Chang ', 'Lie ', 'Lei ', 'Lu ', 'Kuang ', 'Bao ', 'Du ', 'Biao ', 'Zan ', 'Zhi ', 'Si ', 'You ', 'Hao ', 'Chen ', 'Chen ', 'Li ', 'Teng ', 'Wei ', 'Long ', 'Chu ', 'Chan ', 'Rang ', 'Shu ', 'Hui ', 'Li ', 'Luo ', 'Zan ', 'Nuo ', 'Tang ', 'Yan ', 'Lei ', 'Nang ', 'Er ', 'Wu ', 'Yun ', 'Zan ', 'Yuan ', 'Xiong ', 'Chong ', 'Zhao ', 'Xiong ', 'Xian ', 'Guang ', 'Dui ', 'Ke ', 'Dui ', 'Mian ', 'Tu ', 'Chang ', 'Er ', 'Dui ', 'Er ', 'Xin ', 'Tu ', 'Si ', 'Yan ', 'Yan ', 'Shi ', 'Shi ', 'Dang ', 'Qian ', 'Dou ', 'Fen ', 'Mao ', 'Shen ', 'Dou ', 'Bai ', 'Jing ', 'Li ', 'Huang ', 'Ru ', 'Wang ', 'Nei ', 'Quan ', 'Liang ', 'Yu ', 'Ba ', 'Gong ', 'Liu ', 'Xi ', '[?] ', 'Lan ', 'Gong ', 'Tian ', 'Guan ', 'Xing ', 'Bing ', 'Qi ', 'Ju ', 'Dian ', 'Zi ', 'Ppwun ', 'Yang ', 'Jian ', 'Shou ', 'Ji ', 'Yi ', 'Ji ', 'Chan ', 'Jiong ', 'Mao ', 'Ran ', 'Nei ', 'Yuan ', 'Mao ', 'Gang ', 'Ran ', 'Ce ', 'Jiong ', 'Ce ', 'Zai ', 'Gua ', 'Jiong ', 'Mao ', 'Zhou ', 'Mou ', 'Gou ', 'Xu ', 'Mian ', 'Mi ', 'Rong ', 'Yin ', 'Xie ', 'Kan ', 'Jun ', 'Nong ', 'Yi ', 'Mi ', 'Shi ', 'Guan ', 'Meng ', 'Zhong ', 'Ju ', 'Yuan ', 'Ming ', 'Kou ', 'Lam ', 'Fu ', 'Xie ', 'Mi ', 'Bing ', 'Dong ', 'Tai ', 'Gang ', 'Feng ', 'Bing ', 'Hu ', 'Chong ', 'Jue ', 'Hu ', 'Kuang ', 'Ye ', 'Leng ', 'Pan ', 'Fu ', 'Min ', 'Dong ', 'Xian ', 'Lie ', 'Xia ', 'Jian ', 'Jing ', 'Shu ', 'Mei ', 'Tu ', 'Qi ', 'Gu ', 'Zhun ', 'Song ', 'Jing ', 'Liang ', 'Qing ', 'Diao ', 'Ling ', 'Dong ', 'Gan ', 'Jian ', 'Yin ', 'Cou ', 'Yi ', 'Li ', 'Cang ', 'Ming ', 'Zhuen ', 'Cui ', 'Si ', 'Duo ', 'Jin ', 'Lin ', 'Lin ', 'Ning ', 'Xi ', 'Du ', 'Ji ', 'Fan ', 'Fan ', 'Fan ', 'Feng ', 'Ju ', 'Chu ', 'Tako ', 'Feng ', 'Mok ', 'Ci ', 'Fu ', 'Feng ', 'Ping ', 'Feng ', 'Kai ', 'Huang ', 'Kai ', 'Gan ', 'Deng ', 'Ping ', 'Qu ', 'Xiong ', 'Kuai ', 'Tu ', 'Ao ', 'Chu ', 'Ji ', 'Dang ', 'Han ', 'Han ', 'Zao ']

Documentation des variables

◆ return

return[ 'Yi ', 'Jun ', 'Nong ', 'Chan ', 'Yi ', 'Dang ', 'Jing ', 'Xuan ', 'Kuai ', 'Jian ', 'Chu ', 'Dan ', 'Jiao ', 'Sha ', 'Zai ', '[?] ', 'Bin ', 'An ', 'Ru ', 'Tai ', 'Chou ', 'Chai ', 'Lan ', 'Ni ', 'Jin ', 'Qian ', 'Meng ', 'Wu ', 'Ning ', 'Qiong ', 'Ni ', 'Chang ', 'Lie ', 'Lei ', 'Lu ', 'Kuang ', 'Bao ', 'Du ', 'Biao ', 'Zan ', 'Zhi ', 'Si ', 'You ', 'Hao ', 'Chen ', 'Chen ', 'Li ', 'Teng ', 'Wei ', 'Long ', 'Chu ', 'Chan ', 'Rang ', 'Shu ', 'Hui ', 'Li ', 'Luo ', 'Zan ', 'Nuo ', 'Tang ', 'Yan ', 'Lei ', 'Nang ', 'Er ', 'Wu ', 'Yun ', 'Zan ', 'Yuan ', 'Xiong ', 'Chong ', 'Zhao ', 'Xiong ', 'Xian ', 'Guang ', 'Dui ', 'Ke ', 'Dui ', 'Mian ', 'Tu ', 'Chang ', 'Er ', 'Dui ', 'Er ', 'Xin ', 'Tu ', 'Si ', 'Yan ', 'Yan ', 'Shi ', 'Shi ', 'Dang ', 'Qian ', 'Dou ', 'Fen ', 'Mao ', 'Shen ', 'Dou ', 'Bai ', 'Jing ', 'Li ', 'Huang ', 'Ru ', 'Wang ', 'Nei ', 'Quan ', 'Liang ', 'Yu ', 'Ba ', 'Gong ', 'Liu ', 'Xi ', '[?] ', 'Lan ', 'Gong ', 'Tian ', 'Guan ', 'Xing ', 'Bing ', 'Qi ', 'Ju ', 'Dian ', 'Zi ', 'Ppwun ', 'Yang ', 'Jian ', 'Shou ', 'Ji ', 'Yi ', 'Ji ', 'Chan ', 'Jiong ', 'Mao ', 'Ran ', 'Nei ', 'Yuan ', 'Mao ', 'Gang ', 'Ran ', 'Ce ', 'Jiong ', 'Ce ', 'Zai ', 'Gua ', 'Jiong ', 'Mao ', 'Zhou ', 'Mou ', 'Gou ', 'Xu ', 'Mian ', 'Mi ', 'Rong ', 'Yin ', 'Xie ', 'Kan ', 'Jun ', 'Nong ', 'Yi ', 'Mi ', 'Shi ', 'Guan ', 'Meng ', 'Zhong ', 'Ju ', 'Yuan ', 'Ming ', 'Kou ', 'Lam ', 'Fu ', 'Xie ', 'Mi ', 'Bing ', 'Dong ', 'Tai ', 'Gang ', 'Feng ', 'Bing ', 'Hu ', 'Chong ', 'Jue ', 'Hu ', 'Kuang ', 'Ye ', 'Leng ', 'Pan ', 'Fu ', 'Min ', 'Dong ', 'Xian ', 'Lie ', 'Xia ', 'Jian ', 'Jing ', 'Shu ', 'Mei ', 'Tu ', 'Qi ', 'Gu ', 'Zhun ', 'Song ', 'Jing ', 'Liang ', 'Qing ', 'Diao ', 'Ling ', 'Dong ', 'Gan ', 'Jian ', 'Yin ', 'Cou ', 'Yi ', 'Li ', 'Cang ', 'Ming ', 'Zhuen ', 'Cui ', 'Si ', 'Duo ', 'Jin ', 'Lin ', 'Lin ', 'Ning ', 'Xi ', 'Du ', 'Ji ', 'Fan ', 'Fan ', 'Fan ', 'Feng ', 'Ju ', 'Chu ', 'Tako ', 'Feng ', 'Mok ', 'Ci ', 'Fu ', 'Feng ', 'Ping ', 'Feng ', 'Kai ', 'Huang ', 'Kai ', 'Gan ', 'Deng ', 'Ping ', 'Qu ', 'Xiong ', 'Kuai ', 'Tu ', 'Ao ', 'Chu ', 'Ji ', 'Dang ', 'Han ', 'Han ', 'Zao ']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier ToUnicode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
Structures de données | Espaces de nommage
Référence du fichier ToUnicode.php

Structures de données

class ToUnicode

Espaces de nommage

Algo26\IdnaConvert


Joomla CMS: Référence du fichier PKCS8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/PKCS8.php

Structures de données

class PKCS8

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys


Joomla CMS: Référence du fichier PublishedButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Button
Structures de données | Espaces de nommage
Référence du fichier PublishedButton.php

Structures de données

class PublishedButton

Espaces de nommage

Joomla\CMS\Button


Joomla CMS: Référence du fichier Parameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/Parameters.php

Structures de données

class Parameters

Espaces de nommage

EC
phpseclib3\Crypt\EC


Joomla CMS: Référence du fichier Verifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier Verifier.php

Structures de données

class Verifier

Espaces de nommage

Cose


Joomla CMS: Référence du fichier Question.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Question
Structures de données | Espaces de nommage
Référence du fichier Question.php

Structures de données

class Question

Espaces de nommage

Symfony\Component\Console\Question


Joomla CMS: Référence du fichier ReasonFlags.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier ReasonFlags.php

Structures de données

class ReasonFlags

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier WarningsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier WarningsModel.php

Structures de données

class WarningsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier RequestTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier RequestTable.php

Structures de données

class RequestTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Table


Joomla CMS: Référence du fichier x022.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x022.php

Variables

return ['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '-', '[?]', '[?]', '/', '\\', ' *', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ':', '[?]', '[?]', '[?]', '[?]', '[?]', '~', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '<=', '>=', '<=', '>=', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '-', '[?]', '[?]', '/', '\\', ' *', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '|', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ':', '[?]', '[?]', '[?]', '[?]', '[?]', '~', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '<=', '>=', '<=', '>=', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier WorkflowBehaviorTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Espaces de nommage | Fonctions | Variables
Référence du fichier WorkflowBehaviorTrait.php

Espaces de nommage

Joomla\CMS\MVC\Model

Fonctions

setUpWorkflow ($extension)
enableWorkflowBatch ()
workflowPreprocessForm (Form $form, $data)
workflowBeforeStageChange ()
workflowBeforeSave ()
workflowAfterSave ($data)
batchWorkflowStage (int $value, array $pks, array $contexts)
workflowCleanupBatchMove ($oldId, $newId)
executeTransition (array $pks, int $transitionId)
importWorkflowPlugins ()
addTransitionField (Form $form, $data)
getStageForNewItem (Form $form, $data)

Variables

trait WorkflowBehaviorTrait
$section = ''
$workflowEnabled = false
$workflow


Joomla CMS: Référence du fichier publish_date.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
  • info_block
Espaces de nommage
Référence du fichier publish_date.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier x0b7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b7.php

Variables

return ['ddwim', 'ddwib', 'ddwibs', 'ddwis', 'ddwiss', 'ddwing', 'ddwij', 'ddwic', 'ddwik', 'ddwit', 'ddwip', 'ddwih', 'ddyu', 'ddyug', 'ddyugg', 'ddyugs', 'ddyun', 'ddyunj', 'ddyunh', 'ddyud', 'ddyul', 'ddyulg', 'ddyulm', 'ddyulb', 'ddyuls', 'ddyult', 'ddyulp', 'ddyulh', 'ddyum', 'ddyub', 'ddyubs', 'ddyus', 'ddyuss', 'ddyung', 'ddyuj', 'ddyuc', 'ddyuk', 'ddyut', 'ddyup', 'ddyuh', 'ddeu', 'ddeug', 'ddeugg', 'ddeugs', 'ddeun', 'ddeunj', 'ddeunh', 'ddeud', 'ddeul', 'ddeulg', 'ddeulm', 'ddeulb', 'ddeuls', 'ddeult', 'ddeulp', 'ddeulh', 'ddeum', 'ddeub', 'ddeubs', 'ddeus', 'ddeuss', 'ddeung', 'ddeuj', 'ddeuc', 'ddeuk', 'ddeut', 'ddeup', 'ddeuh', 'ddyi', 'ddyig', 'ddyigg', 'ddyigs', 'ddyin', 'ddyinj', 'ddyinh', 'ddyid', 'ddyil', 'ddyilg', 'ddyilm', 'ddyilb', 'ddyils', 'ddyilt', 'ddyilp', 'ddyilh', 'ddyim', 'ddyib', 'ddyibs', 'ddyis', 'ddyiss', 'ddying', 'ddyij', 'ddyic', 'ddyik', 'ddyit', 'ddyip', 'ddyih', 'ddi', 'ddig', 'ddigg', 'ddigs', 'ddin', 'ddinj', 'ddinh', 'ddid', 'ddil', 'ddilg', 'ddilm', 'ddilb', 'ddils', 'ddilt', 'ddilp', 'ddilh', 'ddim', 'ddib', 'ddibs', 'ddis', 'ddiss', 'dding', 'ddij', 'ddic', 'ddik', 'ddit', 'ddip', 'ddih', 'ra', 'rag', 'ragg', 'rags', 'ran', 'ranj', 'ranh', 'rad', 'ral', 'ralg', 'ralm', 'ralb', 'rals', 'ralt', 'ralp', 'ralh', 'ram', 'rab', 'rabs', 'ras', 'rass', 'rang', 'raj', 'rac', 'rak', 'rat', 'rap', 'rah', 'rae', 'raeg', 'raegg', 'raegs', 'raen', 'raenj', 'raenh', 'raed', 'rael', 'raelg', 'raelm', 'raelb', 'raels', 'raelt', 'raelp', 'raelh', 'raem', 'raeb', 'raebs', 'raes', 'raess', 'raeng', 'raej', 'raec', 'raek', 'raet', 'raep', 'raeh', 'rya', 'ryag', 'ryagg', 'ryags', 'ryan', 'ryanj', 'ryanh', 'ryad', 'ryal', 'ryalg', 'ryalm', 'ryalb', 'ryals', 'ryalt', 'ryalp', 'ryalh', 'ryam', 'ryab', 'ryabs', 'ryas', 'ryass', 'ryang', 'ryaj', 'ryac', 'ryak', 'ryat', 'ryap', 'ryah', 'ryae', 'ryaeg', 'ryaegg', 'ryaegs', 'ryaen', 'ryaenj', 'ryaenh', 'ryaed', 'ryael', 'ryaelg', 'ryaelm', 'ryaelb', 'ryaels', 'ryaelt', 'ryaelp', 'ryaelh', 'ryaem', 'ryaeb', 'ryaebs', 'ryaes', 'ryaess', 'ryaeng', 'ryaej', 'ryaec', 'ryaek', 'ryaet', 'ryaep', 'ryaeh', 'reo', 'reog', 'reogg', 'reogs', 'reon', 'reonj', 'reonh', 'reod', 'reol', 'reolg', 'reolm', 'reolb', 'reols', 'reolt', 'reolp', 'reolh', 'reom', 'reob', 'reobs', 'reos']

Documentation des variables

◆ return

return[ 'ddwim', 'ddwib', 'ddwibs', 'ddwis', 'ddwiss', 'ddwing', 'ddwij', 'ddwic', 'ddwik', 'ddwit', 'ddwip', 'ddwih', 'ddyu', 'ddyug', 'ddyugg', 'ddyugs', 'ddyun', 'ddyunj', 'ddyunh', 'ddyud', 'ddyul', 'ddyulg', 'ddyulm', 'ddyulb', 'ddyuls', 'ddyult', 'ddyulp', 'ddyulh', 'ddyum', 'ddyub', 'ddyubs', 'ddyus', 'ddyuss', 'ddyung', 'ddyuj', 'ddyuc', 'ddyuk', 'ddyut', 'ddyup', 'ddyuh', 'ddeu', 'ddeug', 'ddeugg', 'ddeugs', 'ddeun', 'ddeunj', 'ddeunh', 'ddeud', 'ddeul', 'ddeulg', 'ddeulm', 'ddeulb', 'ddeuls', 'ddeult', 'ddeulp', 'ddeulh', 'ddeum', 'ddeub', 'ddeubs', 'ddeus', 'ddeuss', 'ddeung', 'ddeuj', 'ddeuc', 'ddeuk', 'ddeut', 'ddeup', 'ddeuh', 'ddyi', 'ddyig', 'ddyigg', 'ddyigs', 'ddyin', 'ddyinj', 'ddyinh', 'ddyid', 'ddyil', 'ddyilg', 'ddyilm', 'ddyilb', 'ddyils', 'ddyilt', 'ddyilp', 'ddyilh', 'ddyim', 'ddyib', 'ddyibs', 'ddyis', 'ddyiss', 'ddying', 'ddyij', 'ddyic', 'ddyik', 'ddyit', 'ddyip', 'ddyih', 'ddi', 'ddig', 'ddigg', 'ddigs', 'ddin', 'ddinj', 'ddinh', 'ddid', 'ddil', 'ddilg', 'ddilm', 'ddilb', 'ddils', 'ddilt', 'ddilp', 'ddilh', 'ddim', 'ddib', 'ddibs', 'ddis', 'ddiss', 'dding', 'ddij', 'ddic', 'ddik', 'ddit', 'ddip', 'ddih', 'ra', 'rag', 'ragg', 'rags', 'ran', 'ranj', 'ranh', 'rad', 'ral', 'ralg', 'ralm', 'ralb', 'rals', 'ralt', 'ralp', 'ralh', 'ram', 'rab', 'rabs', 'ras', 'rass', 'rang', 'raj', 'rac', 'rak', 'rat', 'rap', 'rah', 'rae', 'raeg', 'raegg', 'raegs', 'raen', 'raenj', 'raenh', 'raed', 'rael', 'raelg', 'raelm', 'raelb', 'raels', 'raelt', 'raelp', 'raelh', 'raem', 'raeb', 'raebs', 'raes', 'raess', 'raeng', 'raej', 'raec', 'raek', 'raet', 'raep', 'raeh', 'rya', 'ryag', 'ryagg', 'ryags', 'ryan', 'ryanj', 'ryanh', 'ryad', 'ryal', 'ryalg', 'ryalm', 'ryalb', 'ryals', 'ryalt', 'ryalp', 'ryalh', 'ryam', 'ryab', 'ryabs', 'ryas', 'ryass', 'ryang', 'ryaj', 'ryac', 'ryak', 'ryat', 'ryap', 'ryah', 'ryae', 'ryaeg', 'ryaegg', 'ryaegs', 'ryaen', 'ryaenj', 'ryaenh', 'ryaed', 'ryael', 'ryaelg', 'ryaelm', 'ryaelb', 'ryaels', 'ryaelt', 'ryaelp', 'ryaelh', 'ryaem', 'ryaeb', 'ryaebs', 'ryaes', 'ryaess', 'ryaeng', 'ryaej', 'ryaec', 'ryaek', 'ryaet', 'ryaep', 'ryaeh', 'reo', 'reog', 'reogg', 'reogs', 'reon', 'reonj', 'reonh', 'reod', 'reol', 'reolg', 'reolm', 'reolb', 'reols', 'reolt', 'reolp', 'reolh', 'reom', 'reob', 'reobs', 'reos']


Joomla CMS: Référence du fichier ResultTypeObjectAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeObjectAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeObjectAware
$resultAcceptableClasses = []


Joomla CMS: Référence du fichier Users.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Users.php

Structures de données

class Users

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Service\HTML


Joomla CMS: Référence du fichier tag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier form/field/tag.php

Espaces de nommage

Joomla\Site

Variables

$html = array()
$attr = ''
if($readonly|| $disabled) | $attr2 = ''
if($allowCustom) if($remoteSearch) if($required) if($readonly) | else

Documentation des variables

◆ $attr

$attr = ''

◆ $attr2

$attr2 = ''

◆ $html

$html = array()

◆ else

if ( $allowCustom) if ( $remoteSearch) if ( $required) if ( $readonly) else
Valeur initiale :
{
$html[] = HTMLHelper::_('select.genericlist', $options, $name, trim($attr), 'value', 'text', $value, $id)
$attr
$attr
Definition: form/field/tag.php:58
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$html
$html
Definition: form/field/tag.php:57
$value
$value
Definition: com_contact/layouts/field/render.php:21
trim
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$options
$options
Definition: administrator/components/com_associations/tmpl/association/edit.php:27


Joomla CMS: Référence du fichier x05e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05e.php

Variables

return ['Za ', 'Bi ', 'Shi ', 'Bu ', 'Ding ', 'Shuai ', 'Fan ', 'Nie ', 'Shi ', 'Fen ', 'Pa ', 'Zhi ', 'Xi ', 'Hu ', 'Dan ', 'Wei ', 'Zhang ', 'Tang ', 'Dai ', 'Ma ', 'Pei ', 'Pa ', 'Tie ', 'Fu ', 'Lian ', 'Zhi ', 'Zhou ', 'Bo ', 'Zhi ', 'Di ', 'Mo ', 'Yi ', 'Yi ', 'Ping ', 'Qia ', 'Juan ', 'Ru ', 'Shuai ', 'Dai ', 'Zheng ', 'Shui ', 'Qiao ', 'Zhen ', 'Shi ', 'Qun ', 'Xi ', 'Bang ', 'Dai ', 'Gui ', 'Chou ', 'Ping ', 'Zhang ', 'Sha ', 'Wan ', 'Dai ', 'Wei ', 'Chang ', 'Sha ', 'Qi ', 'Ze ', 'Guo ', 'Mao ', 'Du ', 'Hou ', 'Zheng ', 'Xu ', 'Mi ', 'Wei ', 'Wo ', 'Fu ', 'Yi ', 'Bang ', 'Ping ', 'Tazuna ', 'Gong ', 'Pan ', 'Huang ', 'Dao ', 'Mi ', 'Jia ', 'Teng ', 'Hui ', 'Zhong ', 'Shan ', 'Man ', 'Mu ', 'Biao ', 'Guo ', 'Ze ', 'Mu ', 'Bang ', 'Zhang ', 'Jiong ', 'Chan ', 'Fu ', 'Zhi ', 'Hu ', 'Fan ', 'Chuang ', 'Bi ', 'Hei ', '[?] ', 'Mi ', 'Qiao ', 'Chan ', 'Fen ', 'Meng ', 'Bang ', 'Chou ', 'Mie ', 'Chu ', 'Jie ', 'Xian ', 'Lan ', 'Gan ', 'Ping ', 'Nian ', 'Qian ', 'Bing ', 'Bing ', 'Xing ', 'Gan ', 'Yao ', 'Huan ', 'You ', 'You ', 'Ji ', 'Yan ', 'Pi ', 'Ting ', 'Ze ', 'Guang ', 'Zhuang ', 'Mo ', 'Qing ', 'Bi ', 'Qin ', 'Dun ', 'Chuang ', 'Gui ', 'Ya ', 'Bai ', 'Jie ', 'Xu ', 'Lu ', 'Wu ', '[?] ', 'Ku ', 'Ying ', 'Di ', 'Pao ', 'Dian ', 'Ya ', 'Miao ', 'Geng ', 'Ci ', 'Fu ', 'Tong ', 'Pang ', 'Fei ', 'Xiang ', 'Yi ', 'Zhi ', 'Tiao ', 'Zhi ', 'Xiu ', 'Du ', 'Zuo ', 'Xiao ', 'Tu ', 'Gui ', 'Ku ', 'Pang ', 'Ting ', 'You ', 'Bu ', 'Ding ', 'Cheng ', 'Lai ', 'Bei ', 'Ji ', 'An ', 'Shu ', 'Kang ', 'Yong ', 'Tuo ', 'Song ', 'Shu ', 'Qing ', 'Yu ', 'Yu ', 'Miao ', 'Sou ', 'Ce ', 'Xiang ', 'Fei ', 'Jiu ', 'He ', 'Hui ', 'Liu ', 'Sha ', 'Lian ', 'Lang ', 'Sou ', 'Jian ', 'Pou ', 'Qing ', 'Jiu ', 'Jiu ', 'Qin ', 'Ao ', 'Kuo ', 'Lou ', 'Yin ', 'Liao ', 'Dai ', 'Lu ', 'Yi ', 'Chu ', 'Chan ', 'Tu ', 'Si ', 'Xin ', 'Miao ', 'Chang ', 'Wu ', 'Fei ', 'Guang ', 'Koc ', 'Kuai ', 'Bi ', 'Qiang ', 'Xie ', 'Lin ', 'Lin ', 'Liao ', 'Lu ', '[?] ', 'Ying ', 'Xian ', 'Ting ', 'Yong ', 'Li ', 'Ting ', 'Yin ', 'Xun ', 'Yan ', 'Ting ', 'Di ', 'Po ', 'Jian ', 'Hui ', 'Nai ', 'Hui ', 'Gong ', 'Nian ']

Documentation des variables

◆ return

return[ 'Za ', 'Bi ', 'Shi ', 'Bu ', 'Ding ', 'Shuai ', 'Fan ', 'Nie ', 'Shi ', 'Fen ', 'Pa ', 'Zhi ', 'Xi ', 'Hu ', 'Dan ', 'Wei ', 'Zhang ', 'Tang ', 'Dai ', 'Ma ', 'Pei ', 'Pa ', 'Tie ', 'Fu ', 'Lian ', 'Zhi ', 'Zhou ', 'Bo ', 'Zhi ', 'Di ', 'Mo ', 'Yi ', 'Yi ', 'Ping ', 'Qia ', 'Juan ', 'Ru ', 'Shuai ', 'Dai ', 'Zheng ', 'Shui ', 'Qiao ', 'Zhen ', 'Shi ', 'Qun ', 'Xi ', 'Bang ', 'Dai ', 'Gui ', 'Chou ', 'Ping ', 'Zhang ', 'Sha ', 'Wan ', 'Dai ', 'Wei ', 'Chang ', 'Sha ', 'Qi ', 'Ze ', 'Guo ', 'Mao ', 'Du ', 'Hou ', 'Zheng ', 'Xu ', 'Mi ', 'Wei ', 'Wo ', 'Fu ', 'Yi ', 'Bang ', 'Ping ', 'Tazuna ', 'Gong ', 'Pan ', 'Huang ', 'Dao ', 'Mi ', 'Jia ', 'Teng ', 'Hui ', 'Zhong ', 'Shan ', 'Man ', 'Mu ', 'Biao ', 'Guo ', 'Ze ', 'Mu ', 'Bang ', 'Zhang ', 'Jiong ', 'Chan ', 'Fu ', 'Zhi ', 'Hu ', 'Fan ', 'Chuang ', 'Bi ', 'Hei ', '[?] ', 'Mi ', 'Qiao ', 'Chan ', 'Fen ', 'Meng ', 'Bang ', 'Chou ', 'Mie ', 'Chu ', 'Jie ', 'Xian ', 'Lan ', 'Gan ', 'Ping ', 'Nian ', 'Qian ', 'Bing ', 'Bing ', 'Xing ', 'Gan ', 'Yao ', 'Huan ', 'You ', 'You ', 'Ji ', 'Yan ', 'Pi ', 'Ting ', 'Ze ', 'Guang ', 'Zhuang ', 'Mo ', 'Qing ', 'Bi ', 'Qin ', 'Dun ', 'Chuang ', 'Gui ', 'Ya ', 'Bai ', 'Jie ', 'Xu ', 'Lu ', 'Wu ', '[?] ', 'Ku ', 'Ying ', 'Di ', 'Pao ', 'Dian ', 'Ya ', 'Miao ', 'Geng ', 'Ci ', 'Fu ', 'Tong ', 'Pang ', 'Fei ', 'Xiang ', 'Yi ', 'Zhi ', 'Tiao ', 'Zhi ', 'Xiu ', 'Du ', 'Zuo ', 'Xiao ', 'Tu ', 'Gui ', 'Ku ', 'Pang ', 'Ting ', 'You ', 'Bu ', 'Ding ', 'Cheng ', 'Lai ', 'Bei ', 'Ji ', 'An ', 'Shu ', 'Kang ', 'Yong ', 'Tuo ', 'Song ', 'Shu ', 'Qing ', 'Yu ', 'Yu ', 'Miao ', 'Sou ', 'Ce ', 'Xiang ', 'Fei ', 'Jiu ', 'He ', 'Hui ', 'Liu ', 'Sha ', 'Lian ', 'Lang ', 'Sou ', 'Jian ', 'Pou ', 'Qing ', 'Jiu ', 'Jiu ', 'Qin ', 'Ao ', 'Kuo ', 'Lou ', 'Yin ', 'Liao ', 'Dai ', 'Lu ', 'Yi ', 'Chu ', 'Chan ', 'Tu ', 'Si ', 'Xin ', 'Miao ', 'Chang ', 'Wu ', 'Fei ', 'Guang ', 'Koc ', 'Kuai ', 'Bi ', 'Qiang ', 'Xie ', 'Lin ', 'Lin ', 'Liao ', 'Lu ', '[?] ', 'Ying ', 'Xian ', 'Ting ', 'Yong ', 'Li ', 'Ting ', 'Yin ', 'Xun ', 'Yan ', 'Ting ', 'Di ', 'Po ', 'Jian ', 'Hui ', 'Nai ', 'Hui ', 'Gong ', 'Nian ']


Joomla CMS: Référence du fichier RedirectController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_redirect
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier RedirectController.php

Structures de données

class RedirectController

Espaces de nommage

Joomla\API
Joomla\Component\Redirect\Api\Controller


Joomla CMS: Référence du fichier RevokedCertificate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RevokedCertificate.php

Structures de données

class RevokedCertificate

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SessionhandlerField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier SessionhandlerField.php

Structures de données

class SessionhandlerField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier PharInvocation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Resolver
Structures de données | Espaces de nommage
Référence du fichier PharInvocation.php

Structures de données

class PharInvocation

Espaces de nommage

TYPO3\PharStreamWrapper\Resolver


Joomla CMS: Référence du fichier SerializationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier SerializationException.php

Structures de données

class SerializationException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier RandValInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Structures de données | Espaces de nommage
Référence du fichier RandValInterface.php

Structures de données

interface RandValInterface

Espaces de nommage

Joomla\CMS\Encrypt


Joomla CMS: Référence du fichier x0cb.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0cb.php

Variables

return ['jjwaels', 'jjwaelt', 'jjwaelp', 'jjwaelh', 'jjwaem', 'jjwaeb', 'jjwaebs', 'jjwaes', 'jjwaess', 'jjwaeng', 'jjwaej', 'jjwaec', 'jjwaek', 'jjwaet', 'jjwaep', 'jjwaeh', 'jjoe', 'jjoeg', 'jjoegg', 'jjoegs', 'jjoen', 'jjoenj', 'jjoenh', 'jjoed', 'jjoel', 'jjoelg', 'jjoelm', 'jjoelb', 'jjoels', 'jjoelt', 'jjoelp', 'jjoelh', 'jjoem', 'jjoeb', 'jjoebs', 'jjoes', 'jjoess', 'jjoeng', 'jjoej', 'jjoec', 'jjoek', 'jjoet', 'jjoep', 'jjoeh', 'jjyo', 'jjyog', 'jjyogg', 'jjyogs', 'jjyon', 'jjyonj', 'jjyonh', 'jjyod', 'jjyol', 'jjyolg', 'jjyolm', 'jjyolb', 'jjyols', 'jjyolt', 'jjyolp', 'jjyolh', 'jjyom', 'jjyob', 'jjyobs', 'jjyos', 'jjyoss', 'jjyong', 'jjyoj', 'jjyoc', 'jjyok', 'jjyot', 'jjyop', 'jjyoh', 'jju', 'jjug', 'jjugg', 'jjugs', 'jjun', 'jjunj', 'jjunh', 'jjud', 'jjul', 'jjulg', 'jjulm', 'jjulb', 'jjuls', 'jjult', 'jjulp', 'jjulh', 'jjum', 'jjub', 'jjubs', 'jjus', 'jjuss', 'jjung', 'jjuj', 'jjuc', 'jjuk', 'jjut', 'jjup', 'jjuh', 'jjweo', 'jjweog', 'jjweogg', 'jjweogs', 'jjweon', 'jjweonj', 'jjweonh', 'jjweod', 'jjweol', 'jjweolg', 'jjweolm', 'jjweolb', 'jjweols', 'jjweolt', 'jjweolp', 'jjweolh', 'jjweom', 'jjweob', 'jjweobs', 'jjweos', 'jjweoss', 'jjweong', 'jjweoj', 'jjweoc', 'jjweok', 'jjweot', 'jjweop', 'jjweoh', 'jjwe', 'jjweg', 'jjwegg', 'jjwegs', 'jjwen', 'jjwenj', 'jjwenh', 'jjwed', 'jjwel', 'jjwelg', 'jjwelm', 'jjwelb', 'jjwels', 'jjwelt', 'jjwelp', 'jjwelh', 'jjwem', 'jjweb', 'jjwebs', 'jjwes', 'jjwess', 'jjweng', 'jjwej', 'jjwec', 'jjwek', 'jjwet', 'jjwep', 'jjweh', 'jjwi', 'jjwig', 'jjwigg', 'jjwigs', 'jjwin', 'jjwinj', 'jjwinh', 'jjwid', 'jjwil', 'jjwilg', 'jjwilm', 'jjwilb', 'jjwils', 'jjwilt', 'jjwilp', 'jjwilh', 'jjwim', 'jjwib', 'jjwibs', 'jjwis', 'jjwiss', 'jjwing', 'jjwij', 'jjwic', 'jjwik', 'jjwit', 'jjwip', 'jjwih', 'jjyu', 'jjyug', 'jjyugg', 'jjyugs', 'jjyun', 'jjyunj', 'jjyunh', 'jjyud', 'jjyul', 'jjyulg', 'jjyulm', 'jjyulb', 'jjyuls', 'jjyult', 'jjyulp', 'jjyulh', 'jjyum', 'jjyub', 'jjyubs', 'jjyus', 'jjyuss', 'jjyung', 'jjyuj', 'jjyuc', 'jjyuk', 'jjyut', 'jjyup', 'jjyuh', 'jjeu', 'jjeug', 'jjeugg', 'jjeugs', 'jjeun', 'jjeunj', 'jjeunh', 'jjeud', 'jjeul', 'jjeulg', 'jjeulm', 'jjeulb', 'jjeuls', 'jjeult', 'jjeulp', 'jjeulh', 'jjeum', 'jjeub', 'jjeubs', 'jjeus', 'jjeuss', 'jjeung', 'jjeuj', 'jjeuc', 'jjeuk', 'jjeut', 'jjeup', 'jjeuh', 'jjyi', 'jjyig', 'jjyigg', 'jjyigs', 'jjyin', 'jjyinj', 'jjyinh', 'jjyid', 'jjyil', 'jjyilg', 'jjyilm', 'jjyilb', 'jjyils', 'jjyilt', 'jjyilp', 'jjyilh']

Documentation des variables

◆ return

return[ 'jjwaels', 'jjwaelt', 'jjwaelp', 'jjwaelh', 'jjwaem', 'jjwaeb', 'jjwaebs', 'jjwaes', 'jjwaess', 'jjwaeng', 'jjwaej', 'jjwaec', 'jjwaek', 'jjwaet', 'jjwaep', 'jjwaeh', 'jjoe', 'jjoeg', 'jjoegg', 'jjoegs', 'jjoen', 'jjoenj', 'jjoenh', 'jjoed', 'jjoel', 'jjoelg', 'jjoelm', 'jjoelb', 'jjoels', 'jjoelt', 'jjoelp', 'jjoelh', 'jjoem', 'jjoeb', 'jjoebs', 'jjoes', 'jjoess', 'jjoeng', 'jjoej', 'jjoec', 'jjoek', 'jjoet', 'jjoep', 'jjoeh', 'jjyo', 'jjyog', 'jjyogg', 'jjyogs', 'jjyon', 'jjyonj', 'jjyonh', 'jjyod', 'jjyol', 'jjyolg', 'jjyolm', 'jjyolb', 'jjyols', 'jjyolt', 'jjyolp', 'jjyolh', 'jjyom', 'jjyob', 'jjyobs', 'jjyos', 'jjyoss', 'jjyong', 'jjyoj', 'jjyoc', 'jjyok', 'jjyot', 'jjyop', 'jjyoh', 'jju', 'jjug', 'jjugg', 'jjugs', 'jjun', 'jjunj', 'jjunh', 'jjud', 'jjul', 'jjulg', 'jjulm', 'jjulb', 'jjuls', 'jjult', 'jjulp', 'jjulh', 'jjum', 'jjub', 'jjubs', 'jjus', 'jjuss', 'jjung', 'jjuj', 'jjuc', 'jjuk', 'jjut', 'jjup', 'jjuh', 'jjweo', 'jjweog', 'jjweogg', 'jjweogs', 'jjweon', 'jjweonj', 'jjweonh', 'jjweod', 'jjweol', 'jjweolg', 'jjweolm', 'jjweolb', 'jjweols', 'jjweolt', 'jjweolp', 'jjweolh', 'jjweom', 'jjweob', 'jjweobs', 'jjweos', 'jjweoss', 'jjweong', 'jjweoj', 'jjweoc', 'jjweok', 'jjweot', 'jjweop', 'jjweoh', 'jjwe', 'jjweg', 'jjwegg', 'jjwegs', 'jjwen', 'jjwenj', 'jjwenh', 'jjwed', 'jjwel', 'jjwelg', 'jjwelm', 'jjwelb', 'jjwels', 'jjwelt', 'jjwelp', 'jjwelh', 'jjwem', 'jjweb', 'jjwebs', 'jjwes', 'jjwess', 'jjweng', 'jjwej', 'jjwec', 'jjwek', 'jjwet', 'jjwep', 'jjweh', 'jjwi', 'jjwig', 'jjwigg', 'jjwigs', 'jjwin', 'jjwinj', 'jjwinh', 'jjwid', 'jjwil', 'jjwilg', 'jjwilm', 'jjwilb', 'jjwils', 'jjwilt', 'jjwilp', 'jjwilh', 'jjwim', 'jjwib', 'jjwibs', 'jjwis', 'jjwiss', 'jjwing', 'jjwij', 'jjwic', 'jjwik', 'jjwit', 'jjwip', 'jjwih', 'jjyu', 'jjyug', 'jjyugg', 'jjyugs', 'jjyun', 'jjyunj', 'jjyunh', 'jjyud', 'jjyul', 'jjyulg', 'jjyulm', 'jjyulb', 'jjyuls', 'jjyult', 'jjyulp', 'jjyulh', 'jjyum', 'jjyub', 'jjyubs', 'jjyus', 'jjyuss', 'jjyung', 'jjyuj', 'jjyuc', 'jjyuk', 'jjyut', 'jjyup', 'jjyuh', 'jjeu', 'jjeug', 'jjeugg', 'jjeugs', 'jjeun', 'jjeunj', 'jjeunh', 'jjeud', 'jjeul', 'jjeulg', 'jjeulm', 'jjeulb', 'jjeuls', 'jjeult', 'jjeulp', 'jjeulh', 'jjeum', 'jjeub', 'jjeubs', 'jjeus', 'jjeuss', 'jjeung', 'jjeuj', 'jjeuc', 'jjeuk', 'jjeut', 'jjeup', 'jjeuh', 'jjyi', 'jjyig', 'jjyigg', 'jjyigs', 'jjyin', 'jjyinj', 'jjyinh', 'jjyid', 'jjyil', 'jjyilg', 'jjyilm', 'jjyilb', 'jjyils', 'jjyilt', 'jjyilp', 'jjyilh']


Joomla CMS: Référence du fichier RssParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Feed
  • Parser
Structures de données | Espaces de nommage
Référence du fichier RssParser.php

Structures de données

class RssParser

Espaces de nommage

Joomla\CMS\Feed\Parser


Joomla CMS: Référence du fichier secp521r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp521r1.php

Structures de données

class secp521r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x0b3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b3.php

Variables

return ['dae', 'daeg', 'daegg', 'daegs', 'daen', 'daenj', 'daenh', 'daed', 'dael', 'daelg', 'daelm', 'daelb', 'daels', 'daelt', 'daelp', 'daelh', 'daem', 'daeb', 'daebs', 'daes', 'daess', 'daeng', 'daej', 'daec', 'daek', 'daet', 'daep', 'daeh', 'dya', 'dyag', 'dyagg', 'dyags', 'dyan', 'dyanj', 'dyanh', 'dyad', 'dyal', 'dyalg', 'dyalm', 'dyalb', 'dyals', 'dyalt', 'dyalp', 'dyalh', 'dyam', 'dyab', 'dyabs', 'dyas', 'dyass', 'dyang', 'dyaj', 'dyac', 'dyak', 'dyat', 'dyap', 'dyah', 'dyae', 'dyaeg', 'dyaegg', 'dyaegs', 'dyaen', 'dyaenj', 'dyaenh', 'dyaed', 'dyael', 'dyaelg', 'dyaelm', 'dyaelb', 'dyaels', 'dyaelt', 'dyaelp', 'dyaelh', 'dyaem', 'dyaeb', 'dyaebs', 'dyaes', 'dyaess', 'dyaeng', 'dyaej', 'dyaec', 'dyaek', 'dyaet', 'dyaep', 'dyaeh', 'deo', 'deog', 'deogg', 'deogs', 'deon', 'deonj', 'deonh', 'deod', 'deol', 'deolg', 'deolm', 'deolb', 'deols', 'deolt', 'deolp', 'deolh', 'deom', 'deob', 'deobs', 'deos', 'deoss', 'deong', 'deoj', 'deoc', 'deok', 'deot', 'deop', 'deoh', 'de', 'deg', 'degg', 'degs', 'den', 'denj', 'denh', 'ded', 'del', 'delg', 'delm', 'delb', 'dels', 'delt', 'delp', 'delh', 'dem', 'deb', 'debs', 'des', 'dess', 'deng', 'dej', 'dec', 'dek', 'det', 'dep', 'deh', 'dyeo', 'dyeog', 'dyeogg', 'dyeogs', 'dyeon', 'dyeonj', 'dyeonh', 'dyeod', 'dyeol', 'dyeolg', 'dyeolm', 'dyeolb', 'dyeols', 'dyeolt', 'dyeolp', 'dyeolh', 'dyeom', 'dyeob', 'dyeobs', 'dyeos', 'dyeoss', 'dyeong', 'dyeoj', 'dyeoc', 'dyeok', 'dyeot', 'dyeop', 'dyeoh', 'dye', 'dyeg', 'dyegg', 'dyegs', 'dyen', 'dyenj', 'dyenh', 'dyed', 'dyel', 'dyelg', 'dyelm', 'dyelb', 'dyels', 'dyelt', 'dyelp', 'dyelh', 'dyem', 'dyeb', 'dyebs', 'dyes', 'dyess', 'dyeng', 'dyej', 'dyec', 'dyek', 'dyet', 'dyep', 'dyeh', 'do', 'dog', 'dogg', 'dogs', 'don', 'donj', 'donh', 'dod', 'dol', 'dolg', 'dolm', 'dolb', 'dols', 'dolt', 'dolp', 'dolh', 'dom', 'dob', 'dobs', 'dos', 'doss', 'dong', 'doj', 'doc', 'dok', 'dot', 'dop', 'doh', 'dwa', 'dwag', 'dwagg', 'dwags', 'dwan', 'dwanj', 'dwanh', 'dwad', 'dwal', 'dwalg', 'dwalm', 'dwalb', 'dwals', 'dwalt', 'dwalp', 'dwalh', 'dwam', 'dwab', 'dwabs', 'dwas', 'dwass', 'dwang', 'dwaj', 'dwac', 'dwak', 'dwat', 'dwap', 'dwah', 'dwae', 'dwaeg', 'dwaegg', 'dwaegs']

Documentation des variables

◆ return

return[ 'dae', 'daeg', 'daegg', 'daegs', 'daen', 'daenj', 'daenh', 'daed', 'dael', 'daelg', 'daelm', 'daelb', 'daels', 'daelt', 'daelp', 'daelh', 'daem', 'daeb', 'daebs', 'daes', 'daess', 'daeng', 'daej', 'daec', 'daek', 'daet', 'daep', 'daeh', 'dya', 'dyag', 'dyagg', 'dyags', 'dyan', 'dyanj', 'dyanh', 'dyad', 'dyal', 'dyalg', 'dyalm', 'dyalb', 'dyals', 'dyalt', 'dyalp', 'dyalh', 'dyam', 'dyab', 'dyabs', 'dyas', 'dyass', 'dyang', 'dyaj', 'dyac', 'dyak', 'dyat', 'dyap', 'dyah', 'dyae', 'dyaeg', 'dyaegg', 'dyaegs', 'dyaen', 'dyaenj', 'dyaenh', 'dyaed', 'dyael', 'dyaelg', 'dyaelm', 'dyaelb', 'dyaels', 'dyaelt', 'dyaelp', 'dyaelh', 'dyaem', 'dyaeb', 'dyaebs', 'dyaes', 'dyaess', 'dyaeng', 'dyaej', 'dyaec', 'dyaek', 'dyaet', 'dyaep', 'dyaeh', 'deo', 'deog', 'deogg', 'deogs', 'deon', 'deonj', 'deonh', 'deod', 'deol', 'deolg', 'deolm', 'deolb', 'deols', 'deolt', 'deolp', 'deolh', 'deom', 'deob', 'deobs', 'deos', 'deoss', 'deong', 'deoj', 'deoc', 'deok', 'deot', 'deop', 'deoh', 'de', 'deg', 'degg', 'degs', 'den', 'denj', 'denh', 'ded', 'del', 'delg', 'delm', 'delb', 'dels', 'delt', 'delp', 'delh', 'dem', 'deb', 'debs', 'des', 'dess', 'deng', 'dej', 'dec', 'dek', 'det', 'dep', 'deh', 'dyeo', 'dyeog', 'dyeogg', 'dyeogs', 'dyeon', 'dyeonj', 'dyeonh', 'dyeod', 'dyeol', 'dyeolg', 'dyeolm', 'dyeolb', 'dyeols', 'dyeolt', 'dyeolp', 'dyeolh', 'dyeom', 'dyeob', 'dyeobs', 'dyeos', 'dyeoss', 'dyeong', 'dyeoj', 'dyeoc', 'dyeok', 'dyeot', 'dyeop', 'dyeoh', 'dye', 'dyeg', 'dyegg', 'dyegs', 'dyen', 'dyenj', 'dyenh', 'dyed', 'dyel', 'dyelg', 'dyelm', 'dyelb', 'dyels', 'dyelt', 'dyelp', 'dyelh', 'dyem', 'dyeb', 'dyebs', 'dyes', 'dyess', 'dyeng', 'dyej', 'dyec', 'dyek', 'dyet', 'dyep', 'dyeh', 'do', 'dog', 'dogg', 'dogs', 'don', 'donj', 'donh', 'dod', 'dol', 'dolg', 'dolm', 'dolb', 'dols', 'dolt', 'dolp', 'dolh', 'dom', 'dob', 'dobs', 'dos', 'doss', 'dong', 'doj', 'doc', 'dok', 'dot', 'dop', 'doh', 'dwa', 'dwag', 'dwagg', 'dwags', 'dwan', 'dwanj', 'dwanh', 'dwad', 'dwal', 'dwalg', 'dwalm', 'dwalb', 'dwals', 'dwalt', 'dwalp', 'dwalh', 'dwam', 'dwab', 'dwabs', 'dwas', 'dwass', 'dwang', 'dwaj', 'dwac', 'dwak', 'dwat', 'dwap', 'dwah', 'dwae', 'dwaeg', 'dwaegg', 'dwaegs']


Joomla CMS: Référence du fichier sect131r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect131r1.php

Structures de données

class sect131r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Select.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier Select.php

Structures de données

class Select

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier RSAKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-core
  • Util
Structures de données | Espaces de nommage
Référence du fichier RSAKey.php

Structures de données

class RSAKey

Espaces de nommage

Jose\Component\Core\Util


Joomla CMS: Référence du fichier ResultTypeMixedAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage
Référence du fichier ResultTypeMixedAware.php

Espaces de nommage

Joomla\CMS\Event\Result


Joomla CMS: Référence du fichier Toolbar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/Toolbar.php

Structures de données

class Toolbar

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier SetupRenderOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • DataShape
Structures de données | Espaces de nommage
Référence du fichier SetupRenderOptions.php

Structures de données

class SetupRenderOptions

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\DataShape


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/api-authentication/token/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Helper


Joomla CMS: Référence du fichier VersionableControllerTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Versioning
Espaces de nommage
Référence du fichier VersionableControllerTrait.php

Espaces de nommage

Joomla\CMS\Versioning


Joomla CMS: Référence du fichier x0b4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b4.php

Variables

return ['dwaen', 'dwaenj', 'dwaenh', 'dwaed', 'dwael', 'dwaelg', 'dwaelm', 'dwaelb', 'dwaels', 'dwaelt', 'dwaelp', 'dwaelh', 'dwaem', 'dwaeb', 'dwaebs', 'dwaes', 'dwaess', 'dwaeng', 'dwaej', 'dwaec', 'dwaek', 'dwaet', 'dwaep', 'dwaeh', 'doe', 'doeg', 'doegg', 'doegs', 'doen', 'doenj', 'doenh', 'doed', 'doel', 'doelg', 'doelm', 'doelb', 'doels', 'doelt', 'doelp', 'doelh', 'doem', 'doeb', 'doebs', 'does', 'doess', 'doeng', 'doej', 'doec', 'doek', 'doet', 'doep', 'doeh', 'dyo', 'dyog', 'dyogg', 'dyogs', 'dyon', 'dyonj', 'dyonh', 'dyod', 'dyol', 'dyolg', 'dyolm', 'dyolb', 'dyols', 'dyolt', 'dyolp', 'dyolh', 'dyom', 'dyob', 'dyobs', 'dyos', 'dyoss', 'dyong', 'dyoj', 'dyoc', 'dyok', 'dyot', 'dyop', 'dyoh', 'du', 'dug', 'dugg', 'dugs', 'dun', 'dunj', 'dunh', 'dud', 'dul', 'dulg', 'dulm', 'dulb', 'duls', 'dult', 'dulp', 'dulh', 'dum', 'dub', 'dubs', 'dus', 'duss', 'dung', 'duj', 'duc', 'duk', 'dut', 'dup', 'duh', 'dweo', 'dweog', 'dweogg', 'dweogs', 'dweon', 'dweonj', 'dweonh', 'dweod', 'dweol', 'dweolg', 'dweolm', 'dweolb', 'dweols', 'dweolt', 'dweolp', 'dweolh', 'dweom', 'dweob', 'dweobs', 'dweos', 'dweoss', 'dweong', 'dweoj', 'dweoc', 'dweok', 'dweot', 'dweop', 'dweoh', 'dwe', 'dweg', 'dwegg', 'dwegs', 'dwen', 'dwenj', 'dwenh', 'dwed', 'dwel', 'dwelg', 'dwelm', 'dwelb', 'dwels', 'dwelt', 'dwelp', 'dwelh', 'dwem', 'dweb', 'dwebs', 'dwes', 'dwess', 'dweng', 'dwej', 'dwec', 'dwek', 'dwet', 'dwep', 'dweh', 'dwi', 'dwig', 'dwigg', 'dwigs', 'dwin', 'dwinj', 'dwinh', 'dwid', 'dwil', 'dwilg', 'dwilm', 'dwilb', 'dwils', 'dwilt', 'dwilp', 'dwilh', 'dwim', 'dwib', 'dwibs', 'dwis', 'dwiss', 'dwing', 'dwij', 'dwic', 'dwik', 'dwit', 'dwip', 'dwih', 'dyu', 'dyug', 'dyugg', 'dyugs', 'dyun', 'dyunj', 'dyunh', 'dyud', 'dyul', 'dyulg', 'dyulm', 'dyulb', 'dyuls', 'dyult', 'dyulp', 'dyulh', 'dyum', 'dyub', 'dyubs', 'dyus', 'dyuss', 'dyung', 'dyuj', 'dyuc', 'dyuk', 'dyut', 'dyup', 'dyuh', 'deu', 'deug', 'deugg', 'deugs', 'deun', 'deunj', 'deunh', 'deud', 'deul', 'deulg', 'deulm', 'deulb', 'deuls', 'deult', 'deulp', 'deulh', 'deum', 'deub', 'deubs', 'deus', 'deuss', 'deung', 'deuj', 'deuc', 'deuk', 'deut', 'deup', 'deuh', 'dyi', 'dyig', 'dyigg', 'dyigs', 'dyin', 'dyinj', 'dyinh', 'dyid']

Documentation des variables

◆ return

return[ 'dwaen', 'dwaenj', 'dwaenh', 'dwaed', 'dwael', 'dwaelg', 'dwaelm', 'dwaelb', 'dwaels', 'dwaelt', 'dwaelp', 'dwaelh', 'dwaem', 'dwaeb', 'dwaebs', 'dwaes', 'dwaess', 'dwaeng', 'dwaej', 'dwaec', 'dwaek', 'dwaet', 'dwaep', 'dwaeh', 'doe', 'doeg', 'doegg', 'doegs', 'doen', 'doenj', 'doenh', 'doed', 'doel', 'doelg', 'doelm', 'doelb', 'doels', 'doelt', 'doelp', 'doelh', 'doem', 'doeb', 'doebs', 'does', 'doess', 'doeng', 'doej', 'doec', 'doek', 'doet', 'doep', 'doeh', 'dyo', 'dyog', 'dyogg', 'dyogs', 'dyon', 'dyonj', 'dyonh', 'dyod', 'dyol', 'dyolg', 'dyolm', 'dyolb', 'dyols', 'dyolt', 'dyolp', 'dyolh', 'dyom', 'dyob', 'dyobs', 'dyos', 'dyoss', 'dyong', 'dyoj', 'dyoc', 'dyok', 'dyot', 'dyop', 'dyoh', 'du', 'dug', 'dugg', 'dugs', 'dun', 'dunj', 'dunh', 'dud', 'dul', 'dulg', 'dulm', 'dulb', 'duls', 'dult', 'dulp', 'dulh', 'dum', 'dub', 'dubs', 'dus', 'duss', 'dung', 'duj', 'duc', 'duk', 'dut', 'dup', 'duh', 'dweo', 'dweog', 'dweogg', 'dweogs', 'dweon', 'dweonj', 'dweonh', 'dweod', 'dweol', 'dweolg', 'dweolm', 'dweolb', 'dweols', 'dweolt', 'dweolp', 'dweolh', 'dweom', 'dweob', 'dweobs', 'dweos', 'dweoss', 'dweong', 'dweoj', 'dweoc', 'dweok', 'dweot', 'dweop', 'dweoh', 'dwe', 'dweg', 'dwegg', 'dwegs', 'dwen', 'dwenj', 'dwenh', 'dwed', 'dwel', 'dwelg', 'dwelm', 'dwelb', 'dwels', 'dwelt', 'dwelp', 'dwelh', 'dwem', 'dweb', 'dwebs', 'dwes', 'dwess', 'dweng', 'dwej', 'dwec', 'dwek', 'dwet', 'dwep', 'dweh', 'dwi', 'dwig', 'dwigg', 'dwigs', 'dwin', 'dwinj', 'dwinh', 'dwid', 'dwil', 'dwilg', 'dwilm', 'dwilb', 'dwils', 'dwilt', 'dwilp', 'dwilh', 'dwim', 'dwib', 'dwibs', 'dwis', 'dwiss', 'dwing', 'dwij', 'dwic', 'dwik', 'dwit', 'dwip', 'dwih', 'dyu', 'dyug', 'dyugg', 'dyugs', 'dyun', 'dyunj', 'dyunh', 'dyud', 'dyul', 'dyulg', 'dyulm', 'dyulb', 'dyuls', 'dyult', 'dyulp', 'dyulh', 'dyum', 'dyub', 'dyubs', 'dyus', 'dyuss', 'dyung', 'dyuj', 'dyuc', 'dyuk', 'dyut', 'dyup', 'dyuh', 'deu', 'deug', 'deugg', 'deugs', 'deun', 'deunj', 'deunh', 'deud', 'deul', 'deulg', 'deulm', 'deulb', 'deuls', 'deult', 'deulp', 'deulh', 'deum', 'deub', 'deubs', 'deus', 'deuss', 'deung', 'deuj', 'deuc', 'deuk', 'deut', 'deup', 'deuh', 'dyi', 'dyig', 'dyigg', 'dyigs', 'dyin', 'dyinj', 'dyinh', 'dyid']


Joomla CMS: Référence du fichier RedirectHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier RedirectHelper.php

Structures de données

class RedirectHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Helper


Joomla CMS: Référence du fichier TimeConverterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Converter
Structures de données | Espaces de nommage
Référence du fichier TimeConverterInterface.php

Structures de données

interface TimeConverterInterface

Espaces de nommage

Ramsey\Uuid\Converter


Joomla CMS: Référence du fichier UndefinedFunctionError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Structures de données | Espaces de nommage
Référence du fichier UndefinedFunctionError.php

Structures de données

class UndefinedFunctionError

Espaces de nommage

Symfony\Component\ErrorHandler\Error


Joomla CMS: Référence du fichier workflowstage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage | Variables
Référence du fichier workflowstage.php

Espaces de nommage

Joomla\Site

Variables

$attr
$groups = HTMLHelper::_('workflowstage.existing', array('title' => Text::_('JLIB_HTML_BATCH_WORKFLOW_STAGE_NOCHANGE')))

Documentation des variables

◆ $attr

$attr
Valeur initiale :
= array(
'id' => 'batch-workflowstage-id',
'group.label' => 'text',
'group.items' => null,
'list.attr' => [
'class' => 'form-select'
]
)
null
! $readonly null
Definition: layouts/joomla/form/field/calendar.php:80

◆ $groups

$groups = HTMLHelper::_('workflowstage.existing', array('title' => Text::_('JLIB_HTML_BATCH_WORKFLOW_STAGE_NOCHANGE')))


Joomla CMS: Référence du fichier x007.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x007.php


Joomla CMS: Référence du fichier QuestionHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier QuestionHelper.php

Structures de données

class QuestionHelper

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • yubikey
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/yubikey/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • X509
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/X509/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

FG\X509


Joomla CMS: Référence du fichier x0c5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c5.php

Variables

return ['sseum', 'sseub', 'sseubs', 'sseus', 'sseuss', 'sseung', 'sseuj', 'sseuc', 'sseuk', 'sseut', 'sseup', 'sseuh', 'ssyi', 'ssyig', 'ssyigg', 'ssyigs', 'ssyin', 'ssyinj', 'ssyinh', 'ssyid', 'ssyil', 'ssyilg', 'ssyilm', 'ssyilb', 'ssyils', 'ssyilt', 'ssyilp', 'ssyilh', 'ssyim', 'ssyib', 'ssyibs', 'ssyis', 'ssyiss', 'ssying', 'ssyij', 'ssyic', 'ssyik', 'ssyit', 'ssyip', 'ssyih', 'ssi', 'ssig', 'ssigg', 'ssigs', 'ssin', 'ssinj', 'ssinh', 'ssid', 'ssil', 'ssilg', 'ssilm', 'ssilb', 'ssils', 'ssilt', 'ssilp', 'ssilh', 'ssim', 'ssib', 'ssibs', 'ssis', 'ssiss', 'ssing', 'ssij', 'ssic', 'ssik', 'ssit', 'ssip', 'ssih', 'a', 'ag', 'agg', 'ags', 'an', 'anj', 'anh', 'ad', 'al', 'alg', 'alm', 'alb', 'als', 'alt', 'alp', 'alh', 'am', 'ab', 'abs', 'as', 'ass', 'ang', 'aj', 'ac', 'ak', 'at', 'ap', 'ah', 'ae', 'aeg', 'aegg', 'aegs', 'aen', 'aenj', 'aenh', 'aed', 'ael', 'aelg', 'aelm', 'aelb', 'aels', 'aelt', 'aelp', 'aelh', 'aem', 'aeb', 'aebs', 'aes', 'aess', 'aeng', 'aej', 'aec', 'aek', 'aet', 'aep', 'aeh', 'ya', 'yag', 'yagg', 'yags', 'yan', 'yanj', 'yanh', 'yad', 'yal', 'yalg', 'yalm', 'yalb', 'yals', 'yalt', 'yalp', 'yalh', 'yam', 'yab', 'yabs', 'yas', 'yass', 'yang', 'yaj', 'yac', 'yak', 'yat', 'yap', 'yah', 'yae', 'yaeg', 'yaegg', 'yaegs', 'yaen', 'yaenj', 'yaenh', 'yaed', 'yael', 'yaelg', 'yaelm', 'yaelb', 'yaels', 'yaelt', 'yaelp', 'yaelh', 'yaem', 'yaeb', 'yaebs', 'yaes', 'yaess', 'yaeng', 'yaej', 'yaec', 'yaek', 'yaet', 'yaep', 'yaeh', 'eo', 'eog', 'eogg', 'eogs', 'eon', 'eonj', 'eonh', 'eod', 'eol', 'eolg', 'eolm', 'eolb', 'eols', 'eolt', 'eolp', 'eolh', 'eom', 'eob', 'eobs', 'eos', 'eoss', 'eong', 'eoj', 'eoc', 'eok', 'eot', 'eop', 'eoh', 'e', 'eg', 'egg', 'egs', 'en', 'enj', 'enh', 'ed', 'el', 'elg', 'elm', 'elb', 'els', 'elt', 'elp', 'elh', 'em', 'eb', 'ebs', 'es', 'ess', 'eng', 'ej', 'ec', 'ek', 'et', 'ep', 'eh', 'yeo', 'yeog', 'yeogg', 'yeogs', 'yeon', 'yeonj', 'yeonh', 'yeod', 'yeol', 'yeolg', 'yeolm', 'yeolb', 'yeols', 'yeolt', 'yeolp', 'yeolh', 'yeom', 'yeob', 'yeobs', 'yeos']

Documentation des variables

◆ return

return[ 'sseum', 'sseub', 'sseubs', 'sseus', 'sseuss', 'sseung', 'sseuj', 'sseuc', 'sseuk', 'sseut', 'sseup', 'sseuh', 'ssyi', 'ssyig', 'ssyigg', 'ssyigs', 'ssyin', 'ssyinj', 'ssyinh', 'ssyid', 'ssyil', 'ssyilg', 'ssyilm', 'ssyilb', 'ssyils', 'ssyilt', 'ssyilp', 'ssyilh', 'ssyim', 'ssyib', 'ssyibs', 'ssyis', 'ssyiss', 'ssying', 'ssyij', 'ssyic', 'ssyik', 'ssyit', 'ssyip', 'ssyih', 'ssi', 'ssig', 'ssigg', 'ssigs', 'ssin', 'ssinj', 'ssinh', 'ssid', 'ssil', 'ssilg', 'ssilm', 'ssilb', 'ssils', 'ssilt', 'ssilp', 'ssilh', 'ssim', 'ssib', 'ssibs', 'ssis', 'ssiss', 'ssing', 'ssij', 'ssic', 'ssik', 'ssit', 'ssip', 'ssih', 'a', 'ag', 'agg', 'ags', 'an', 'anj', 'anh', 'ad', 'al', 'alg', 'alm', 'alb', 'als', 'alt', 'alp', 'alh', 'am', 'ab', 'abs', 'as', 'ass', 'ang', 'aj', 'ac', 'ak', 'at', 'ap', 'ah', 'ae', 'aeg', 'aegg', 'aegs', 'aen', 'aenj', 'aenh', 'aed', 'ael', 'aelg', 'aelm', 'aelb', 'aels', 'aelt', 'aelp', 'aelh', 'aem', 'aeb', 'aebs', 'aes', 'aess', 'aeng', 'aej', 'aec', 'aek', 'aet', 'aep', 'aeh', 'ya', 'yag', 'yagg', 'yags', 'yan', 'yanj', 'yanh', 'yad', 'yal', 'yalg', 'yalm', 'yalb', 'yals', 'yalt', 'yalp', 'yalh', 'yam', 'yab', 'yabs', 'yas', 'yass', 'yang', 'yaj', 'yac', 'yak', 'yat', 'yap', 'yah', 'yae', 'yaeg', 'yaegg', 'yaegs', 'yaen', 'yaenj', 'yaenh', 'yaed', 'yael', 'yaelg', 'yaelm', 'yaelb', 'yaels', 'yaelt', 'yaelp', 'yaelh', 'yaem', 'yaeb', 'yaebs', 'yaes', 'yaess', 'yaeng', 'yaej', 'yaec', 'yaek', 'yaet', 'yaep', 'yaeh', 'eo', 'eog', 'eogg', 'eogs', 'eon', 'eonj', 'eonh', 'eod', 'eol', 'eolg', 'eolm', 'eolb', 'eols', 'eolt', 'eolp', 'eolh', 'eom', 'eob', 'eobs', 'eos', 'eoss', 'eong', 'eoj', 'eoc', 'eok', 'eot', 'eop', 'eoh', 'e', 'eg', 'egg', 'egs', 'en', 'enj', 'enh', 'ed', 'el', 'elg', 'elm', 'elb', 'els', 'elt', 'elp', 'elh', 'em', 'eb', 'ebs', 'es', 'ess', 'eng', 'ej', 'ec', 'ek', 'et', 'ep', 'eh', 'yeo', 'yeog', 'yeogg', 'yeogs', 'yeon', 'yeonj', 'yeonh', 'yeod', 'yeol', 'yeolg', 'yeolm', 'yeolb', 'yeols', 'yeolt', 'yeolp', 'yeolh', 'yeom', 'yeob', 'yeobs', 'yeos']


Joomla CMS: Référence du fichier VoteradioField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_content
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier VoteradioField.php

Structures de données

class VoteradioField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Content\Administrator\Field


Joomla CMS: Référence du fichier X25519.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/X25519.php

Structures de données

class ParagonIE_Sodium_Core32_X25519


Joomla CMS: Référence du fichier PolicyQualifierId.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PolicyQualifierId.php

Structures de données

class PolicyQualifierId

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier sect113r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect113r1.php

Structures de données

class sect113r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x0cc.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0cc.php

Variables

return ['jjyim', 'jjyib', 'jjyibs', 'jjyis', 'jjyiss', 'jjying', 'jjyij', 'jjyic', 'jjyik', 'jjyit', 'jjyip', 'jjyih', 'jji', 'jjig', 'jjigg', 'jjigs', 'jjin', 'jjinj', 'jjinh', 'jjid', 'jjil', 'jjilg', 'jjilm', 'jjilb', 'jjils', 'jjilt', 'jjilp', 'jjilh', 'jjim', 'jjib', 'jjibs', 'jjis', 'jjiss', 'jjing', 'jjij', 'jjic', 'jjik', 'jjit', 'jjip', 'jjih', 'ca', 'cag', 'cagg', 'cags', 'can', 'canj', 'canh', 'cad', 'cal', 'calg', 'calm', 'calb', 'cals', 'calt', 'calp', 'calh', 'cam', 'cab', 'cabs', 'cas', 'cass', 'cang', 'caj', 'cac', 'cak', 'cat', 'cap', 'cah', 'cae', 'caeg', 'caegg', 'caegs', 'caen', 'caenj', 'caenh', 'caed', 'cael', 'caelg', 'caelm', 'caelb', 'caels', 'caelt', 'caelp', 'caelh', 'caem', 'caeb', 'caebs', 'caes', 'caess', 'caeng', 'caej', 'caec', 'caek', 'caet', 'caep', 'caeh', 'cya', 'cyag', 'cyagg', 'cyags', 'cyan', 'cyanj', 'cyanh', 'cyad', 'cyal', 'cyalg', 'cyalm', 'cyalb', 'cyals', 'cyalt', 'cyalp', 'cyalh', 'cyam', 'cyab', 'cyabs', 'cyas', 'cyass', 'cyang', 'cyaj', 'cyac', 'cyak', 'cyat', 'cyap', 'cyah', 'cyae', 'cyaeg', 'cyaegg', 'cyaegs', 'cyaen', 'cyaenj', 'cyaenh', 'cyaed', 'cyael', 'cyaelg', 'cyaelm', 'cyaelb', 'cyaels', 'cyaelt', 'cyaelp', 'cyaelh', 'cyaem', 'cyaeb', 'cyaebs', 'cyaes', 'cyaess', 'cyaeng', 'cyaej', 'cyaec', 'cyaek', 'cyaet', 'cyaep', 'cyaeh', 'ceo', 'ceog', 'ceogg', 'ceogs', 'ceon', 'ceonj', 'ceonh', 'ceod', 'ceol', 'ceolg', 'ceolm', 'ceolb', 'ceols', 'ceolt', 'ceolp', 'ceolh', 'ceom', 'ceob', 'ceobs', 'ceos', 'ceoss', 'ceong', 'ceoj', 'ceoc', 'ceok', 'ceot', 'ceop', 'ceoh', 'ce', 'ceg', 'cegg', 'cegs', 'cen', 'cenj', 'cenh', 'ced', 'cel', 'celg', 'celm', 'celb', 'cels', 'celt', 'celp', 'celh', 'cem', 'ceb', 'cebs', 'ces', 'cess', 'ceng', 'cej', 'cec', 'cek', 'cet', 'cep', 'ceh', 'cyeo', 'cyeog', 'cyeogg', 'cyeogs', 'cyeon', 'cyeonj', 'cyeonh', 'cyeod', 'cyeol', 'cyeolg', 'cyeolm', 'cyeolb', 'cyeols', 'cyeolt', 'cyeolp', 'cyeolh', 'cyeom', 'cyeob', 'cyeobs', 'cyeos', 'cyeoss', 'cyeong', 'cyeoj', 'cyeoc', 'cyeok', 'cyeot', 'cyeop', 'cyeoh', 'cye', 'cyeg', 'cyegg', 'cyegs', 'cyen', 'cyenj', 'cyenh', 'cyed', 'cyel', 'cyelg', 'cyelm', 'cyelb', 'cyels', 'cyelt', 'cyelp', 'cyelh', 'cyem', 'cyeb', 'cyebs', 'cyes']

Documentation des variables

◆ return

return[ 'jjyim', 'jjyib', 'jjyibs', 'jjyis', 'jjyiss', 'jjying', 'jjyij', 'jjyic', 'jjyik', 'jjyit', 'jjyip', 'jjyih', 'jji', 'jjig', 'jjigg', 'jjigs', 'jjin', 'jjinj', 'jjinh', 'jjid', 'jjil', 'jjilg', 'jjilm', 'jjilb', 'jjils', 'jjilt', 'jjilp', 'jjilh', 'jjim', 'jjib', 'jjibs', 'jjis', 'jjiss', 'jjing', 'jjij', 'jjic', 'jjik', 'jjit', 'jjip', 'jjih', 'ca', 'cag', 'cagg', 'cags', 'can', 'canj', 'canh', 'cad', 'cal', 'calg', 'calm', 'calb', 'cals', 'calt', 'calp', 'calh', 'cam', 'cab', 'cabs', 'cas', 'cass', 'cang', 'caj', 'cac', 'cak', 'cat', 'cap', 'cah', 'cae', 'caeg', 'caegg', 'caegs', 'caen', 'caenj', 'caenh', 'caed', 'cael', 'caelg', 'caelm', 'caelb', 'caels', 'caelt', 'caelp', 'caelh', 'caem', 'caeb', 'caebs', 'caes', 'caess', 'caeng', 'caej', 'caec', 'caek', 'caet', 'caep', 'caeh', 'cya', 'cyag', 'cyagg', 'cyags', 'cyan', 'cyanj', 'cyanh', 'cyad', 'cyal', 'cyalg', 'cyalm', 'cyalb', 'cyals', 'cyalt', 'cyalp', 'cyalh', 'cyam', 'cyab', 'cyabs', 'cyas', 'cyass', 'cyang', 'cyaj', 'cyac', 'cyak', 'cyat', 'cyap', 'cyah', 'cyae', 'cyaeg', 'cyaegg', 'cyaegs', 'cyaen', 'cyaenj', 'cyaenh', 'cyaed', 'cyael', 'cyaelg', 'cyaelm', 'cyaelb', 'cyaels', 'cyaelt', 'cyaelp', 'cyaelh', 'cyaem', 'cyaeb', 'cyaebs', 'cyaes', 'cyaess', 'cyaeng', 'cyaej', 'cyaec', 'cyaek', 'cyaet', 'cyaep', 'cyaeh', 'ceo', 'ceog', 'ceogg', 'ceogs', 'ceon', 'ceonj', 'ceonh', 'ceod', 'ceol', 'ceolg', 'ceolm', 'ceolb', 'ceols', 'ceolt', 'ceolp', 'ceolh', 'ceom', 'ceob', 'ceobs', 'ceos', 'ceoss', 'ceong', 'ceoj', 'ceoc', 'ceok', 'ceot', 'ceop', 'ceoh', 'ce', 'ceg', 'cegg', 'cegs', 'cen', 'cenj', 'cenh', 'ced', 'cel', 'celg', 'celm', 'celb', 'cels', 'celt', 'celp', 'celh', 'cem', 'ceb', 'cebs', 'ces', 'cess', 'ceng', 'cej', 'cec', 'cek', 'cet', 'cep', 'ceh', 'cyeo', 'cyeog', 'cyeogg', 'cyeogs', 'cyeon', 'cyeonj', 'cyeonh', 'cyeod', 'cyeol', 'cyeolg', 'cyeolm', 'cyeolb', 'cyeols', 'cyeolt', 'cyeolp', 'cyeolh', 'cyeom', 'cyeob', 'cyeobs', 'cyeos', 'cyeoss', 'cyeong', 'cyeoj', 'cyeoc', 'cyeok', 'cyeot', 'cyeop', 'cyeoh', 'cye', 'cyeg', 'cyegg', 'cyegs', 'cyen', 'cyenj', 'cyenh', 'cyed', 'cyel', 'cyelg', 'cyelm', 'cyelb', 'cyels', 'cyelt', 'cyelp', 'cyelh', 'cyem', 'cyeb', 'cyebs', 'cyes']


Joomla CMS: Référence du fichier SelectModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_scheduler/src/Model/SelectModel.php

Structures de données

class SelectModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Model


Joomla CMS: Référence du fichier StringHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/string/src/StringHelper.php

Structures de données

class StringHelper

Espaces de nommage

Joomla\String


Joomla CMS: Référence du fichier WrappableOutputFormatterInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Formatter
Structures de données | Espaces de nommage
Référence du fichier WrappableOutputFormatterInterface.php

Structures de données

interface WrappableOutputFormatterInterface

Espaces de nommage

Symfony\Component\Console\Formatter


Joomla CMS: Référence du fichier x09c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09c.php

Variables

return ['Huan ', 'Quan ', 'Ze ', 'Wei ', 'Wei ', 'Yu ', 'Qun ', 'Rou ', 'Die ', 'Huang ', 'Lian ', 'Yan ', 'Qiu ', 'Qiu ', 'Jian ', 'Bi ', 'E ', 'Yang ', 'Fu ', 'Sai ', 'Jian ', 'Xia ', 'Tuo ', 'Hu ', 'Muroaji ', 'Ruo ', 'Haraka ', 'Wen ', 'Jian ', 'Hao ', 'Wu ', 'Fang ', 'Sao ', 'Liu ', 'Ma ', 'Shi ', 'Shi ', 'Yin ', 'Z ', 'Teng ', 'Ta ', 'Yao ', 'Ge ', 'Rong ', 'Qian ', 'Qi ', 'Wen ', 'Ruo ', 'Hatahata ', 'Lian ', 'Ao ', 'Le ', 'Hui ', 'Min ', 'Ji ', 'Tiao ', 'Qu ', 'Jian ', 'Sao ', 'Man ', 'Xi ', 'Qiu ', 'Biao ', 'Ji ', 'Ji ', 'Zhu ', 'Jiang ', 'Qiu ', 'Zhuan ', 'Yong ', 'Zhang ', 'Kang ', 'Xue ', 'Bie ', 'Jue ', 'Qu ', 'Xiang ', 'Bo ', 'Jiao ', 'Xun ', 'Su ', 'Huang ', 'Zun ', 'Shan ', 'Shan ', 'Fan ', 'Jue ', 'Lin ', 'Xun ', 'Miao ', 'Xi ', 'Eso ', 'Kyou ', 'Fen ', 'Guan ', 'Hou ', 'Kuai ', 'Zei ', 'Sao ', 'Zhan ', 'Gan ', 'Gui ', 'Sheng ', 'Li ', 'Chang ', 'Hatahata ', 'Shiira ', 'Mutsu ', 'Ru ', 'Ji ', 'Xu ', 'Huo ', 'Shiira ', 'Li ', 'Lie ', 'Li ', 'Mie ', 'Zhen ', 'Xiang ', 'E ', 'Lu ', 'Guan ', 'Li ', 'Xian ', 'Yu ', 'Dao ', 'Ji ', 'You ', 'Tun ', 'Lu ', 'Fang ', 'Ba ', 'He ', 'Bo ', 'Ping ', 'Nian ', 'Lu ', 'You ', 'Zha ', 'Fu ', 'Bo ', 'Bao ', 'Hou ', 'Pi ', 'Tai ', 'Gui ', 'Jie ', 'Kao ', 'Wei ', 'Er ', 'Tong ', 'Ze ', 'Hou ', 'Kuai ', 'Ji ', 'Jiao ', 'Xian ', 'Za ', 'Xiang ', 'Xun ', 'Geng ', 'Li ', 'Lian ', 'Jian ', 'Li ', 'Shi ', 'Tiao ', 'Gun ', 'Sha ', 'Wan ', 'Jun ', 'Ji ', 'Yong ', 'Qing ', 'Ling ', 'Qi ', 'Zou ', 'Fei ', 'Kun ', 'Chang ', 'Gu ', 'Ni ', 'Nian ', 'Diao ', 'Jing ', 'Shen ', 'Shi ', 'Zi ', 'Fen ', 'Die ', 'Bi ', 'Chang ', 'Shi ', 'Wen ', 'Wei ', 'Sai ', 'E ', 'Qiu ', 'Fu ', 'Huang ', 'Quan ', 'Jiang ', 'Bian ', 'Sao ', 'Ao ', 'Qi ', 'Ta ', 'Yin ', 'Yao ', 'Fang ', 'Jian ', 'Le ', 'Biao ', 'Xue ', 'Bie ', 'Man ', 'Min ', 'Yong ', 'Wei ', 'Xi ', 'Jue ', 'Shan ', 'Lin ', 'Zun ', 'Huo ', 'Gan ', 'Li ', 'Zhan ', 'Guan ', 'Niao ', 'Yi ', 'Fu ', 'Li ', 'Jiu ', 'Bu ', 'Yan ', 'Fu ', 'Diao ', 'Ji ', 'Feng ', 'Nio ', 'Gan ', 'Shi ', 'Feng ', 'Ming ', 'Bao ', 'Yuan ', 'Zhi ', 'Hu ', 'Qin ', 'Fu ', 'Fen ', 'Wen ', 'Jian ', 'Shi ', 'Yu ']

Documentation des variables

◆ return

return[ 'Huan ', 'Quan ', 'Ze ', 'Wei ', 'Wei ', 'Yu ', 'Qun ', 'Rou ', 'Die ', 'Huang ', 'Lian ', 'Yan ', 'Qiu ', 'Qiu ', 'Jian ', 'Bi ', 'E ', 'Yang ', 'Fu ', 'Sai ', 'Jian ', 'Xia ', 'Tuo ', 'Hu ', 'Muroaji ', 'Ruo ', 'Haraka ', 'Wen ', 'Jian ', 'Hao ', 'Wu ', 'Fang ', 'Sao ', 'Liu ', 'Ma ', 'Shi ', 'Shi ', 'Yin ', 'Z ', 'Teng ', 'Ta ', 'Yao ', 'Ge ', 'Rong ', 'Qian ', 'Qi ', 'Wen ', 'Ruo ', 'Hatahata ', 'Lian ', 'Ao ', 'Le ', 'Hui ', 'Min ', 'Ji ', 'Tiao ', 'Qu ', 'Jian ', 'Sao ', 'Man ', 'Xi ', 'Qiu ', 'Biao ', 'Ji ', 'Ji ', 'Zhu ', 'Jiang ', 'Qiu ', 'Zhuan ', 'Yong ', 'Zhang ', 'Kang ', 'Xue ', 'Bie ', 'Jue ', 'Qu ', 'Xiang ', 'Bo ', 'Jiao ', 'Xun ', 'Su ', 'Huang ', 'Zun ', 'Shan ', 'Shan ', 'Fan ', 'Jue ', 'Lin ', 'Xun ', 'Miao ', 'Xi ', 'Eso ', 'Kyou ', 'Fen ', 'Guan ', 'Hou ', 'Kuai ', 'Zei ', 'Sao ', 'Zhan ', 'Gan ', 'Gui ', 'Sheng ', 'Li ', 'Chang ', 'Hatahata ', 'Shiira ', 'Mutsu ', 'Ru ', 'Ji ', 'Xu ', 'Huo ', 'Shiira ', 'Li ', 'Lie ', 'Li ', 'Mie ', 'Zhen ', 'Xiang ', 'E ', 'Lu ', 'Guan ', 'Li ', 'Xian ', 'Yu ', 'Dao ', 'Ji ', 'You ', 'Tun ', 'Lu ', 'Fang ', 'Ba ', 'He ', 'Bo ', 'Ping ', 'Nian ', 'Lu ', 'You ', 'Zha ', 'Fu ', 'Bo ', 'Bao ', 'Hou ', 'Pi ', 'Tai ', 'Gui ', 'Jie ', 'Kao ', 'Wei ', 'Er ', 'Tong ', 'Ze ', 'Hou ', 'Kuai ', 'Ji ', 'Jiao ', 'Xian ', 'Za ', 'Xiang ', 'Xun ', 'Geng ', 'Li ', 'Lian ', 'Jian ', 'Li ', 'Shi ', 'Tiao ', 'Gun ', 'Sha ', 'Wan ', 'Jun ', 'Ji ', 'Yong ', 'Qing ', 'Ling ', 'Qi ', 'Zou ', 'Fei ', 'Kun ', 'Chang ', 'Gu ', 'Ni ', 'Nian ', 'Diao ', 'Jing ', 'Shen ', 'Shi ', 'Zi ', 'Fen ', 'Die ', 'Bi ', 'Chang ', 'Shi ', 'Wen ', 'Wei ', 'Sai ', 'E ', 'Qiu ', 'Fu ', 'Huang ', 'Quan ', 'Jiang ', 'Bian ', 'Sao ', 'Ao ', 'Qi ', 'Ta ', 'Yin ', 'Yao ', 'Fang ', 'Jian ', 'Le ', 'Biao ', 'Xue ', 'Bie ', 'Man ', 'Min ', 'Yong ', 'Wei ', 'Xi ', 'Jue ', 'Shan ', 'Lin ', 'Zun ', 'Huo ', 'Gan ', 'Li ', 'Zhan ', 'Guan ', 'Niao ', 'Yi ', 'Fu ', 'Li ', 'Jiu ', 'Bu ', 'Yan ', 'Fu ', 'Diao ', 'Ji ', 'Feng ', 'Nio ', 'Gan ', 'Shi ', 'Feng ', 'Ming ', 'Bao ', 'Yuan ', 'Zhi ', 'Hu ', 'Qin ', 'Fu ', 'Fen ', 'Wen ', 'Jian ', 'Shi ', 'Yu ']


Joomla CMS: Référence du fichier x02f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x02f.php

Variables

return ['[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?] ', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier XmlDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Descriptor
Structures de données | Espaces de nommage
Référence du fichier XmlDescriptor.php

Structures de données

class XmlDescriptor

Espaces de nommage

Symfony\Component\Console\Descriptor


Joomla CMS: Référence du fichier ServiceLocatorTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Espaces de nommage | Fonctions | Variables
Référence du fichier ServiceLocatorTrait.php

Espaces de nommage

Symfony\Contracts\Service

Fonctions

__construct (array $factories)
has (string $id)
get (string $id)
getProvidedServices ()
createNotFoundException (string $id)
createCircularReferenceException (string $id, array $path)

Variables

trait ServiceLocatorTrait
$loading = []
$providedTypes


Joomla CMS: Référence du fichier TranscodeUnicodeInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • TranscodeUnicode
Structures de données | Espaces de nommage
Référence du fichier TranscodeUnicodeInterface.php

Structures de données

interface TranscodeUnicodeInterface

Espaces de nommage

Algo26\IdnaConvert\TranscodeUnicode


Joomla CMS: Référence du fichier ProgressIndicator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier ProgressIndicator.php

Structures de données

class ProgressIndicator

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier SchedulerHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier SchedulerHelper.php

Structures de données

class SchedulerHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Helper


Joomla CMS: Référence du fichier PositionsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier PositionsModel.php

Structures de données

class PositionsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Model


Joomla CMS: Référence du fichier Parser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/lcobucci/jwt/src/Parser.php

Structures de données

class Parser

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier SiteMenu.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Menu
Structures de données | Espaces de nommage
Référence du fichier SiteMenu.php

Structures de données

class SiteMenu

Espaces de nommage

Joomla\CMS\Menu


Joomla CMS: Référence du fichier privacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • privacy
Structures de données | Espaces de nommage
Référence du fichier privacy.php

Structures de données

class PlgWebservicesPrivacy

Espaces de nommage

Joomla\Privacy


Joomla CMS: Référence du fichier parse_cookie_header.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • functions
Espaces de nommage | Fonctions
Référence du fichier parse_cookie_header.php

Espaces de nommage

Laminas\Diactoros

Fonctions

parseCookieHeader ($cookieHeader)


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Helper


Joomla CMS: Référence du fichier PluginController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_media/src/Controller/PluginController.php

Structures de données

class PluginController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Controller


Joomla CMS: Référence du fichier Sha512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier Ecdsa/Sha512.php

Structures de données

class Sha512

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier PKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DH/Formats/Keys/PKCS1.php

Structures de données

class PKCS1

Espaces de nommage

DH
phpseclib3\Crypt\DH\Formats\Keys


Joomla CMS: Référence du fichier Validator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier Validator.php

Structures de données

interface Validator

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier RulesInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
  • Rules
Structures de données | Espaces de nommage
Référence du fichier RulesInterface.php

Structures de données

interface RulesInterface

Espaces de nommage

Joomla\CMS\Component\Router\Rules


Joomla CMS: Référence du fichier x099.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x099.php

Variables

return ['Hai ', 'Ren ', 'Tian ', 'Jiao ', 'Jia ', 'Bing ', 'Yao ', 'Tong ', 'Ci ', 'Xiang ', 'Yang ', 'Yang ', 'Er ', 'Yan ', 'Le ', 'Yi ', 'Can ', 'Bo ', 'Nei ', 'E ', 'Bu ', 'Jun ', 'Dou ', 'Su ', 'Yu ', 'Shi ', 'Yao ', 'Hun ', 'Guo ', 'Shi ', 'Jian ', 'Zhui ', 'Bing ', 'Xian ', 'Bu ', 'Ye ', 'Tan ', 'Fei ', 'Zhang ', 'Wei ', 'Guan ', 'E ', 'Nuan ', 'Hun ', 'Hu ', 'Huang ', 'Tie ', 'Hui ', 'Jian ', 'Hou ', 'He ', 'Xing ', 'Fen ', 'Wei ', 'Gu ', 'Cha ', 'Song ', 'Tang ', 'Bo ', 'Gao ', 'Xi ', 'Kui ', 'Liu ', 'Sou ', 'Tao ', 'Ye ', 'Yun ', 'Mo ', 'Tang ', 'Man ', 'Bi ', 'Yu ', 'Xiu ', 'Jin ', 'San ', 'Kui ', 'Zhuan ', 'Shan ', 'Chi ', 'Dan ', 'Yi ', 'Ji ', 'Rao ', 'Cheng ', 'Yong ', 'Tao ', 'Hui ', 'Xiang ', 'Zhan ', 'Fen ', 'Hai ', 'Meng ', 'Yan ', 'Mo ', 'Chan ', 'Xiang ', 'Luo ', 'Zuan ', 'Nang ', 'Shi ', 'Ding ', 'Ji ', 'Tuo ', 'Xing ', 'Tun ', 'Xi ', 'Ren ', 'Yu ', 'Chi ', 'Fan ', 'Yin ', 'Jian ', 'Shi ', 'Bao ', 'Si ', 'Duo ', 'Yi ', 'Er ', 'Rao ', 'Xiang ', 'Jia ', 'Le ', 'Jiao ', 'Yi ', 'Bing ', 'Bo ', 'Dou ', 'E ', 'Yu ', 'Nei ', 'Jun ', 'Guo ', 'Hun ', 'Xian ', 'Guan ', 'Cha ', 'Kui ', 'Gu ', 'Sou ', 'Chan ', 'Ye ', 'Mo ', 'Bo ', 'Liu ', 'Xiu ', 'Jin ', 'Man ', 'San ', 'Zhuan ', 'Nang ', 'Shou ', 'Kui ', 'Guo ', 'Xiang ', 'Fen ', 'Ba ', 'Ni ', 'Bi ', 'Bo ', 'Tu ', 'Han ', 'Fei ', 'Jian ', 'An ', 'Ai ', 'Fu ', 'Xian ', 'Wen ', 'Xin ', 'Fen ', 'Bin ', 'Xing ', 'Ma ', 'Yu ', 'Feng ', 'Han ', 'Di ', 'Tuo ', 'Tuo ', 'Chi ', 'Xun ', 'Zhu ', 'Zhi ', 'Pei ', 'Xin ', 'Ri ', 'Sa ', 'Yin ', 'Wen ', 'Zhi ', 'Dan ', 'Lu ', 'You ', 'Bo ', 'Bao ', 'Kuai ', 'Tuo ', 'Yi ', 'Qu ', '[?] ', 'Qu ', 'Jiong ', 'Bo ', 'Zhao ', 'Yuan ', 'Peng ', 'Zhou ', 'Ju ', 'Zhu ', 'Nu ', 'Ju ', 'Pi ', 'Zang ', 'Jia ', 'Ling ', 'Zhen ', 'Tai ', 'Fu ', 'Yang ', 'Shi ', 'Bi ', 'Tuo ', 'Tuo ', 'Si ', 'Liu ', 'Ma ', 'Pian ', 'Tao ', 'Zhi ', 'Rong ', 'Teng ', 'Dong ', 'Xun ', 'Quan ', 'Shen ', 'Jiong ', 'Er ', 'Hai ', 'Bo ', 'Zhu ', 'Yin ', 'Luo ', 'Shuu ', 'Dan ', 'Xie ', 'Liu ', 'Ju ', 'Song ', 'Qin ', 'Mang ', 'Liang ', 'Han ', 'Tu ', 'Xuan ', 'Tui ', 'Jun ']

Documentation des variables

◆ return

return[ 'Hai ', 'Ren ', 'Tian ', 'Jiao ', 'Jia ', 'Bing ', 'Yao ', 'Tong ', 'Ci ', 'Xiang ', 'Yang ', 'Yang ', 'Er ', 'Yan ', 'Le ', 'Yi ', 'Can ', 'Bo ', 'Nei ', 'E ', 'Bu ', 'Jun ', 'Dou ', 'Su ', 'Yu ', 'Shi ', 'Yao ', 'Hun ', 'Guo ', 'Shi ', 'Jian ', 'Zhui ', 'Bing ', 'Xian ', 'Bu ', 'Ye ', 'Tan ', 'Fei ', 'Zhang ', 'Wei ', 'Guan ', 'E ', 'Nuan ', 'Hun ', 'Hu ', 'Huang ', 'Tie ', 'Hui ', 'Jian ', 'Hou ', 'He ', 'Xing ', 'Fen ', 'Wei ', 'Gu ', 'Cha ', 'Song ', 'Tang ', 'Bo ', 'Gao ', 'Xi ', 'Kui ', 'Liu ', 'Sou ', 'Tao ', 'Ye ', 'Yun ', 'Mo ', 'Tang ', 'Man ', 'Bi ', 'Yu ', 'Xiu ', 'Jin ', 'San ', 'Kui ', 'Zhuan ', 'Shan ', 'Chi ', 'Dan ', 'Yi ', 'Ji ', 'Rao ', 'Cheng ', 'Yong ', 'Tao ', 'Hui ', 'Xiang ', 'Zhan ', 'Fen ', 'Hai ', 'Meng ', 'Yan ', 'Mo ', 'Chan ', 'Xiang ', 'Luo ', 'Zuan ', 'Nang ', 'Shi ', 'Ding ', 'Ji ', 'Tuo ', 'Xing ', 'Tun ', 'Xi ', 'Ren ', 'Yu ', 'Chi ', 'Fan ', 'Yin ', 'Jian ', 'Shi ', 'Bao ', 'Si ', 'Duo ', 'Yi ', 'Er ', 'Rao ', 'Xiang ', 'Jia ', 'Le ', 'Jiao ', 'Yi ', 'Bing ', 'Bo ', 'Dou ', 'E ', 'Yu ', 'Nei ', 'Jun ', 'Guo ', 'Hun ', 'Xian ', 'Guan ', 'Cha ', 'Kui ', 'Gu ', 'Sou ', 'Chan ', 'Ye ', 'Mo ', 'Bo ', 'Liu ', 'Xiu ', 'Jin ', 'Man ', 'San ', 'Zhuan ', 'Nang ', 'Shou ', 'Kui ', 'Guo ', 'Xiang ', 'Fen ', 'Ba ', 'Ni ', 'Bi ', 'Bo ', 'Tu ', 'Han ', 'Fei ', 'Jian ', 'An ', 'Ai ', 'Fu ', 'Xian ', 'Wen ', 'Xin ', 'Fen ', 'Bin ', 'Xing ', 'Ma ', 'Yu ', 'Feng ', 'Han ', 'Di ', 'Tuo ', 'Tuo ', 'Chi ', 'Xun ', 'Zhu ', 'Zhi ', 'Pei ', 'Xin ', 'Ri ', 'Sa ', 'Yin ', 'Wen ', 'Zhi ', 'Dan ', 'Lu ', 'You ', 'Bo ', 'Bao ', 'Kuai ', 'Tuo ', 'Yi ', 'Qu ', '[?] ', 'Qu ', 'Jiong ', 'Bo ', 'Zhao ', 'Yuan ', 'Peng ', 'Zhou ', 'Ju ', 'Zhu ', 'Nu ', 'Ju ', 'Pi ', 'Zang ', 'Jia ', 'Ling ', 'Zhen ', 'Tai ', 'Fu ', 'Yang ', 'Shi ', 'Bi ', 'Tuo ', 'Tuo ', 'Si ', 'Liu ', 'Ma ', 'Pian ', 'Tao ', 'Zhi ', 'Rong ', 'Teng ', 'Dong ', 'Xun ', 'Quan ', 'Shen ', 'Jiong ', 'Er ', 'Hai ', 'Bo ', 'Zhu ', 'Yin ', 'Luo ', 'Shuu ', 'Dan ', 'Xie ', 'Liu ', 'Ju ', 'Song ', 'Qin ', 'Mang ', 'Liang ', 'Han ', 'Tu ', 'Xuan ', 'Tui ', 'Jun ']


Joomla CMS: Référence du fichier SodiumException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
Référence du fichier SodiumException.php


Joomla CMS: Référence du fichier sect233k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect233k1.php

Structures de données

class sect233k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier StandardDebugBar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier StandardDebugBar.php

Structures de données

class StandardDebugBar

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier TransitionsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier TransitionsModel.php

Structures de données

class TransitionsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier SqlField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier SqlField.php

Structures de données

class SqlField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Resolver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • ElementReference
Structures de données | Espaces de nommage
Référence du fichier Resolver.php

Structures de données

class Resolver

Espaces de nommage

enshrined\svgSanitize\ElementReference


Joomla CMS: Référence du fichier x077.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x077.php

Variables

return ['Ming ', 'Sheng ', 'Shi ', 'Yun ', 'Mian ', 'Pan ', 'Fang ', 'Miao ', 'Dan ', 'Mei ', 'Mao ', 'Kan ', 'Xian ', 'Ou ', 'Shi ', 'Yang ', 'Zheng ', 'Yao ', 'Shen ', 'Huo ', 'Da ', 'Zhen ', 'Kuang ', 'Ju ', 'Shen ', 'Chi ', 'Sheng ', 'Mei ', 'Mo ', 'Zhu ', 'Zhen ', 'Zhen ', 'Mian ', 'Di ', 'Yuan ', 'Die ', 'Yi ', 'Zi ', 'Zi ', 'Chao ', 'Zha ', 'Xuan ', 'Bing ', 'Mi ', 'Long ', 'Sui ', 'Dong ', 'Mi ', 'Die ', 'Yi ', 'Er ', 'Ming ', 'Xuan ', 'Chi ', 'Kuang ', 'Juan ', 'Mou ', 'Zhen ', 'Tiao ', 'Yang ', 'Yan ', 'Mo ', 'Zhong ', 'Mai ', 'Zhao ', 'Zheng ', 'Mei ', 'Jun ', 'Shao ', 'Han ', 'Huan ', 'Di ', 'Cheng ', 'Cuo ', 'Juan ', 'E ', 'Wan ', 'Xian ', 'Xi ', 'Kun ', 'Lai ', 'Jian ', 'Shan ', 'Tian ', 'Hun ', 'Wan ', 'Ling ', 'Shi ', 'Qiong ', 'Lie ', 'Yai ', 'Jing ', 'Zheng ', 'Li ', 'Lai ', 'Sui ', 'Juan ', 'Shui ', 'Sui ', 'Du ', 'Bi ', 'Bi ', 'Mu ', 'Hun ', 'Ni ', 'Lu ', 'Yi ', 'Jie ', 'Cai ', 'Zhou ', 'Yu ', 'Hun ', 'Ma ', 'Xia ', 'Xing ', 'Xi ', 'Gun ', 'Cai ', 'Chun ', 'Jian ', 'Mei ', 'Du ', 'Hou ', 'Xuan ', 'Ti ', 'Kui ', 'Gao ', 'Rui ', 'Mou ', 'Xu ', 'Fa ', 'Wen ', 'Miao ', 'Chou ', 'Kui ', 'Mi ', 'Weng ', 'Kou ', 'Dang ', 'Chen ', 'Ke ', 'Sou ', 'Xia ', 'Qiong ', 'Mao ', 'Ming ', 'Man ', 'Shui ', 'Ze ', 'Zhang ', 'Yi ', 'Diao ', 'Ou ', 'Mo ', 'Shun ', 'Cong ', 'Lou ', 'Chi ', 'Man ', 'Piao ', 'Cheng ', 'Ji ', 'Meng ', '[?] ', 'Run ', 'Pie ', 'Xi ', 'Qiao ', 'Pu ', 'Zhu ', 'Deng ', 'Shen ', 'Shun ', 'Liao ', 'Che ', 'Xian ', 'Kan ', 'Ye ', 'Xu ', 'Tong ', 'Mou ', 'Lin ', 'Kui ', 'Xian ', 'Ye ', 'Ai ', 'Hui ', 'Zhan ', 'Jian ', 'Gu ', 'Zhao ', 'Qu ', 'Wei ', 'Chou ', 'Sao ', 'Ning ', 'Xun ', 'Yao ', 'Huo ', 'Meng ', 'Mian ', 'Bin ', 'Mian ', 'Li ', 'Kuang ', 'Jue ', 'Xuan ', 'Mian ', 'Huo ', 'Lu ', 'Meng ', 'Long ', 'Guan ', 'Man ', 'Xi ', 'Chu ', 'Tang ', 'Kan ', 'Zhu ', 'Mao ', 'Jin ', 'Lin ', 'Yu ', 'Shuo ', 'Ce ', 'Jue ', 'Shi ', 'Yi ', 'Shen ', 'Zhi ', 'Hou ', 'Shen ', 'Ying ', 'Ju ', 'Zhou ', 'Jiao ', 'Cuo ', 'Duan ', 'Ai ', 'Jiao ', 'Zeng ', 'Huo ', 'Bai ', 'Shi ', 'Ding ', 'Qi ', 'Ji ', 'Zi ', 'Gan ', 'Wu ', 'Tuo ', 'Ku ', 'Qiang ', 'Xi ', 'Fan ', 'Kuang ']

Documentation des variables

◆ return

return[ 'Ming ', 'Sheng ', 'Shi ', 'Yun ', 'Mian ', 'Pan ', 'Fang ', 'Miao ', 'Dan ', 'Mei ', 'Mao ', 'Kan ', 'Xian ', 'Ou ', 'Shi ', 'Yang ', 'Zheng ', 'Yao ', 'Shen ', 'Huo ', 'Da ', 'Zhen ', 'Kuang ', 'Ju ', 'Shen ', 'Chi ', 'Sheng ', 'Mei ', 'Mo ', 'Zhu ', 'Zhen ', 'Zhen ', 'Mian ', 'Di ', 'Yuan ', 'Die ', 'Yi ', 'Zi ', 'Zi ', 'Chao ', 'Zha ', 'Xuan ', 'Bing ', 'Mi ', 'Long ', 'Sui ', 'Dong ', 'Mi ', 'Die ', 'Yi ', 'Er ', 'Ming ', 'Xuan ', 'Chi ', 'Kuang ', 'Juan ', 'Mou ', 'Zhen ', 'Tiao ', 'Yang ', 'Yan ', 'Mo ', 'Zhong ', 'Mai ', 'Zhao ', 'Zheng ', 'Mei ', 'Jun ', 'Shao ', 'Han ', 'Huan ', 'Di ', 'Cheng ', 'Cuo ', 'Juan ', 'E ', 'Wan ', 'Xian ', 'Xi ', 'Kun ', 'Lai ', 'Jian ', 'Shan ', 'Tian ', 'Hun ', 'Wan ', 'Ling ', 'Shi ', 'Qiong ', 'Lie ', 'Yai ', 'Jing ', 'Zheng ', 'Li ', 'Lai ', 'Sui ', 'Juan ', 'Shui ', 'Sui ', 'Du ', 'Bi ', 'Bi ', 'Mu ', 'Hun ', 'Ni ', 'Lu ', 'Yi ', 'Jie ', 'Cai ', 'Zhou ', 'Yu ', 'Hun ', 'Ma ', 'Xia ', 'Xing ', 'Xi ', 'Gun ', 'Cai ', 'Chun ', 'Jian ', 'Mei ', 'Du ', 'Hou ', 'Xuan ', 'Ti ', 'Kui ', 'Gao ', 'Rui ', 'Mou ', 'Xu ', 'Fa ', 'Wen ', 'Miao ', 'Chou ', 'Kui ', 'Mi ', 'Weng ', 'Kou ', 'Dang ', 'Chen ', 'Ke ', 'Sou ', 'Xia ', 'Qiong ', 'Mao ', 'Ming ', 'Man ', 'Shui ', 'Ze ', 'Zhang ', 'Yi ', 'Diao ', 'Ou ', 'Mo ', 'Shun ', 'Cong ', 'Lou ', 'Chi ', 'Man ', 'Piao ', 'Cheng ', 'Ji ', 'Meng ', '[?] ', 'Run ', 'Pie ', 'Xi ', 'Qiao ', 'Pu ', 'Zhu ', 'Deng ', 'Shen ', 'Shun ', 'Liao ', 'Che ', 'Xian ', 'Kan ', 'Ye ', 'Xu ', 'Tong ', 'Mou ', 'Lin ', 'Kui ', 'Xian ', 'Ye ', 'Ai ', 'Hui ', 'Zhan ', 'Jian ', 'Gu ', 'Zhao ', 'Qu ', 'Wei ', 'Chou ', 'Sao ', 'Ning ', 'Xun ', 'Yao ', 'Huo ', 'Meng ', 'Mian ', 'Bin ', 'Mian ', 'Li ', 'Kuang ', 'Jue ', 'Xuan ', 'Mian ', 'Huo ', 'Lu ', 'Meng ', 'Long ', 'Guan ', 'Man ', 'Xi ', 'Chu ', 'Tang ', 'Kan ', 'Zhu ', 'Mao ', 'Jin ', 'Lin ', 'Yu ', 'Shuo ', 'Ce ', 'Jue ', 'Shi ', 'Yi ', 'Shen ', 'Zhi ', 'Hou ', 'Shen ', 'Ying ', 'Ju ', 'Zhou ', 'Jiao ', 'Cuo ', 'Duan ', 'Ai ', 'Jiao ', 'Zeng ', 'Huo ', 'Bai ', 'Shi ', 'Ding ', 'Qi ', 'Ji ', 'Zi ', 'Gan ', 'Wu ', 'Tuo ', 'Ku ', 'Qiang ', 'Xi ', 'Fan ', 'Kuang ']


Joomla CMS: Référence du fichier Util.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core32/Util.php

Structures de données

class ParagonIE_Sodium_Core32_Util


Joomla CMS: Référence du fichier RandomGeneratorFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier RandomGeneratorFactory.php

Structures de données

class RandomGeneratorFactory

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier x0a4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0a4.php

Variables

return ['qiet', 'qiex', 'qie', 'qiep', 'quot', 'quox', 'quo', 'quop', 'qot', 'qox', 'qo', 'qop', 'qut', 'qux', 'qu', 'qup', 'qurx', 'qur', 'qyt', 'qyx', 'qy', 'qyp', 'qyrx', 'qyr', 'jjit', 'jjix', 'jji', 'jjip', 'jjiet', 'jjiex', 'jjie', 'jjiep', 'jjuox', 'jjuo', 'jjuop', 'jjot', 'jjox', 'jjo', 'jjop', 'jjut', 'jjux', 'jju', 'jjup', 'jjurx', 'jjur', 'jjyt', 'jjyx', 'jjy', 'jjyp', 'njit', 'njix', 'nji', 'njip', 'njiet', 'njiex', 'njie', 'njiep', 'njuox', 'njuo', 'njot', 'njox', 'njo', 'njop', 'njux', 'nju', 'njup', 'njurx', 'njur', 'njyt', 'njyx', 'njy', 'njyp', 'njyrx', 'njyr', 'nyit', 'nyix', 'nyi', 'nyip', 'nyiet', 'nyiex', 'nyie', 'nyiep', 'nyuox', 'nyuo', 'nyuop', 'nyot', 'nyox', 'nyo', 'nyop', 'nyut', 'nyux', 'nyu', 'nyup', 'xit', 'xix', 'xi', 'xip', 'xiet', 'xiex', 'xie', 'xiep', 'xuox', 'xuo', 'xot', 'xox', 'xo', 'xop', 'xyt', 'xyx', 'xy', 'xyp', 'xyrx', 'xyr', 'yit', 'yix', 'yi', 'yip', 'yiet', 'yiex', 'yie', 'yiep', 'yuot', 'yuox', 'yuo', 'yuop', 'yot', 'yox', 'yo', 'yop', 'yut', 'yux', 'yu', 'yup', 'yurx', 'yur', 'yyt', 'yyx', 'yy', 'yyp', 'yyrx', 'yyr', '[?]', '[?]', '[?]', 'Qot', 'Li', 'Kit', 'Nyip', 'Cyp', 'Ssi', 'Ggop', 'Gep', 'Mi', 'Hxit', 'Lyr', 'Bbut', 'Mop', 'Yo', 'Put', 'Hxuo', 'Tat', 'Ga', '[?]', '[?]', 'Ddur', 'Bur', 'Gguo', 'Nyop', 'Tu', 'Op', 'Jjut', 'Zot', 'Pyt', 'Hmo', 'Yit', 'Vur', 'Shy', 'Vep', 'Za', 'Jo', '[?]', 'Jjy', 'Got', 'Jjie', 'Wo', 'Du', 'Shur', 'Lie', 'Cy', 'Cuop', 'Cip', 'Hxop', 'Shat', '[?]', 'Shop', 'Che', 'Zziet', '[?]', 'Ke', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'qiet', 'qiex', 'qie', 'qiep', 'quot', 'quox', 'quo', 'quop', 'qot', 'qox', 'qo', 'qop', 'qut', 'qux', 'qu', 'qup', 'qurx', 'qur', 'qyt', 'qyx', 'qy', 'qyp', 'qyrx', 'qyr', 'jjit', 'jjix', 'jji', 'jjip', 'jjiet', 'jjiex', 'jjie', 'jjiep', 'jjuox', 'jjuo', 'jjuop', 'jjot', 'jjox', 'jjo', 'jjop', 'jjut', 'jjux', 'jju', 'jjup', 'jjurx', 'jjur', 'jjyt', 'jjyx', 'jjy', 'jjyp', 'njit', 'njix', 'nji', 'njip', 'njiet', 'njiex', 'njie', 'njiep', 'njuox', 'njuo', 'njot', 'njox', 'njo', 'njop', 'njux', 'nju', 'njup', 'njurx', 'njur', 'njyt', 'njyx', 'njy', 'njyp', 'njyrx', 'njyr', 'nyit', 'nyix', 'nyi', 'nyip', 'nyiet', 'nyiex', 'nyie', 'nyiep', 'nyuox', 'nyuo', 'nyuop', 'nyot', 'nyox', 'nyo', 'nyop', 'nyut', 'nyux', 'nyu', 'nyup', 'xit', 'xix', 'xi', 'xip', 'xiet', 'xiex', 'xie', 'xiep', 'xuox', 'xuo', 'xot', 'xox', 'xo', 'xop', 'xyt', 'xyx', 'xy', 'xyp', 'xyrx', 'xyr', 'yit', 'yix', 'yi', 'yip', 'yiet', 'yiex', 'yie', 'yiep', 'yuot', 'yuox', 'yuo', 'yuop', 'yot', 'yox', 'yo', 'yop', 'yut', 'yux', 'yu', 'yup', 'yurx', 'yur', 'yyt', 'yyx', 'yy', 'yyp', 'yyrx', 'yyr', '[?]', '[?]', '[?]', 'Qot', 'Li', 'Kit', 'Nyip', 'Cyp', 'Ssi', 'Ggop', 'Gep', 'Mi', 'Hxit', 'Lyr', 'Bbut', 'Mop', 'Yo', 'Put', 'Hxuo', 'Tat', 'Ga', '[?]', '[?]', 'Ddur', 'Bur', 'Gguo', 'Nyop', 'Tu', 'Op', 'Jjut', 'Zot', 'Pyt', 'Hmo', 'Yit', 'Vur', 'Shy', 'Vep', 'Za', 'Jo', '[?]', 'Jjy', 'Got', 'Jjie', 'Wo', 'Du', 'Shur', 'Lie', 'Cy', 'Cuop', 'Cip', 'Hxop', 'Shat', '[?]', 'Shop', 'Che', 'Zziet', '[?]', 'Ke', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier Parameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier tobscure/json-api/src/Parameters.php

Structures de données

class Parameters

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier TwigCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • Twig
Structures de données | Espaces de nommage
Référence du fichier TwigCollector.php

Structures de données

class TwigCollector

Espaces de nommage

DebugBar\Bridge\Twig


Joomla CMS: Référence du fichier RegistrationModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier RegistrationModel.php

Structures de données

class RegistrationModel

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier PluginInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier PluginInterface.php

Structures de données

interface PluginInterface

Espaces de nommage

Joomla\CMS\Extension


Joomla CMS: Référence du fichier x09e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09e.php

Variables

return ['Shu ', 'Luo ', 'Qi ', 'Yi ', 'Ji ', 'Zhe ', 'Yu ', 'Zhan ', 'Ye ', 'Yang ', 'Pi ', 'Ning ', 'Huo ', 'Mi ', 'Ying ', 'Meng ', 'Di ', 'Yue ', 'Yu ', 'Lei ', 'Bao ', 'Lu ', 'He ', 'Long ', 'Shuang ', 'Yue ', 'Ying ', 'Guan ', 'Qu ', 'Li ', 'Luan ', 'Niao ', 'Jiu ', 'Ji ', 'Yuan ', 'Ming ', 'Shi ', 'Ou ', 'Ya ', 'Cang ', 'Bao ', 'Zhen ', 'Gu ', 'Dong ', 'Lu ', 'Ya ', 'Xiao ', 'Yang ', 'Ling ', 'Zhi ', 'Qu ', 'Yuan ', 'Xue ', 'Tuo ', 'Si ', 'Zhi ', 'Er ', 'Gua ', 'Xiu ', 'Heng ', 'Zhou ', 'Ge ', 'Luan ', 'Hong ', 'Wu ', 'Bo ', 'Li ', 'Juan ', 'Hu ', 'E ', 'Yu ', 'Xian ', 'Ti ', 'Wu ', 'Que ', 'Miao ', 'An ', 'Kun ', 'Bei ', 'Peng ', 'Qian ', 'Chun ', 'Geng ', 'Yuan ', 'Su ', 'Hu ', 'He ', 'E ', 'Gu ', 'Qiu ', 'Zi ', 'Mei ', 'Mu ', 'Ni ', 'Yao ', 'Weng ', 'Liu ', 'Ji ', 'Ni ', 'Jian ', 'He ', 'Yi ', 'Ying ', 'Zhe ', 'Liao ', 'Liao ', 'Jiao ', 'Jiu ', 'Yu ', 'Lu ', 'Xuan ', 'Zhan ', 'Ying ', 'Huo ', 'Meng ', 'Guan ', 'Shuang ', 'Lu ', 'Jin ', 'Ling ', 'Jian ', 'Xian ', 'Cuo ', 'Jian ', 'Jian ', 'Yan ', 'Cuo ', 'Lu ', 'You ', 'Cu ', 'Ji ', 'Biao ', 'Cu ', 'Biao ', 'Zhu ', 'Jun ', 'Zhu ', 'Jian ', 'Mi ', 'Mi ', 'Wu ', 'Liu ', 'Chen ', 'Jun ', 'Lin ', 'Ni ', 'Qi ', 'Lu ', 'Jiu ', 'Jun ', 'Jing ', 'Li ', 'Xiang ', 'Yan ', 'Jia ', 'Mi ', 'Li ', 'She ', 'Zhang ', 'Lin ', 'Jing ', 'Ji ', 'Ling ', 'Yan ', 'Cu ', 'Mai ', 'Mai ', 'Ge ', 'Chao ', 'Fu ', 'Mian ', 'Mian ', 'Fu ', 'Pao ', 'Qu ', 'Qu ', 'Mou ', 'Fu ', 'Xian ', 'Lai ', 'Qu ', 'Mian ', '[?] ', 'Feng ', 'Fu ', 'Qu ', 'Mian ', 'Ma ', 'Mo ', 'Mo ', 'Hui ', 'Ma ', 'Zou ', 'Nen ', 'Fen ', 'Huang ', 'Huang ', 'Jin ', 'Guang ', 'Tian ', 'Tou ', 'Heng ', 'Xi ', 'Kuang ', 'Heng ', 'Shu ', 'Li ', 'Nian ', 'Chi ', 'Hei ', 'Hei ', 'Yi ', 'Qian ', 'Dan ', 'Xi ', 'Tuan ', 'Mo ', 'Mo ', 'Qian ', 'Dai ', 'Chu ', 'You ', 'Dian ', 'Yi ', 'Xia ', 'Yan ', 'Qu ', 'Mei ', 'Yan ', 'Jing ', 'Yu ', 'Li ', 'Dang ', 'Du ', 'Can ', 'Yin ', 'An ', 'Yan ', 'Tan ', 'An ', 'Zhen ', 'Dai ', 'Can ', 'Yi ', 'Mei ', 'Dan ', 'Yan ', 'Du ', 'Lu ', 'Zhi ', 'Fen ', 'Fu ', 'Fu ', 'Min ', 'Min ', 'Yuan ']

Documentation des variables

◆ return

return[ 'Shu ', 'Luo ', 'Qi ', 'Yi ', 'Ji ', 'Zhe ', 'Yu ', 'Zhan ', 'Ye ', 'Yang ', 'Pi ', 'Ning ', 'Huo ', 'Mi ', 'Ying ', 'Meng ', 'Di ', 'Yue ', 'Yu ', 'Lei ', 'Bao ', 'Lu ', 'He ', 'Long ', 'Shuang ', 'Yue ', 'Ying ', 'Guan ', 'Qu ', 'Li ', 'Luan ', 'Niao ', 'Jiu ', 'Ji ', 'Yuan ', 'Ming ', 'Shi ', 'Ou ', 'Ya ', 'Cang ', 'Bao ', 'Zhen ', 'Gu ', 'Dong ', 'Lu ', 'Ya ', 'Xiao ', 'Yang ', 'Ling ', 'Zhi ', 'Qu ', 'Yuan ', 'Xue ', 'Tuo ', 'Si ', 'Zhi ', 'Er ', 'Gua ', 'Xiu ', 'Heng ', 'Zhou ', 'Ge ', 'Luan ', 'Hong ', 'Wu ', 'Bo ', 'Li ', 'Juan ', 'Hu ', 'E ', 'Yu ', 'Xian ', 'Ti ', 'Wu ', 'Que ', 'Miao ', 'An ', 'Kun ', 'Bei ', 'Peng ', 'Qian ', 'Chun ', 'Geng ', 'Yuan ', 'Su ', 'Hu ', 'He ', 'E ', 'Gu ', 'Qiu ', 'Zi ', 'Mei ', 'Mu ', 'Ni ', 'Yao ', 'Weng ', 'Liu ', 'Ji ', 'Ni ', 'Jian ', 'He ', 'Yi ', 'Ying ', 'Zhe ', 'Liao ', 'Liao ', 'Jiao ', 'Jiu ', 'Yu ', 'Lu ', 'Xuan ', 'Zhan ', 'Ying ', 'Huo ', 'Meng ', 'Guan ', 'Shuang ', 'Lu ', 'Jin ', 'Ling ', 'Jian ', 'Xian ', 'Cuo ', 'Jian ', 'Jian ', 'Yan ', 'Cuo ', 'Lu ', 'You ', 'Cu ', 'Ji ', 'Biao ', 'Cu ', 'Biao ', 'Zhu ', 'Jun ', 'Zhu ', 'Jian ', 'Mi ', 'Mi ', 'Wu ', 'Liu ', 'Chen ', 'Jun ', 'Lin ', 'Ni ', 'Qi ', 'Lu ', 'Jiu ', 'Jun ', 'Jing ', 'Li ', 'Xiang ', 'Yan ', 'Jia ', 'Mi ', 'Li ', 'She ', 'Zhang ', 'Lin ', 'Jing ', 'Ji ', 'Ling ', 'Yan ', 'Cu ', 'Mai ', 'Mai ', 'Ge ', 'Chao ', 'Fu ', 'Mian ', 'Mian ', 'Fu ', 'Pao ', 'Qu ', 'Qu ', 'Mou ', 'Fu ', 'Xian ', 'Lai ', 'Qu ', 'Mian ', '[?] ', 'Feng ', 'Fu ', 'Qu ', 'Mian ', 'Ma ', 'Mo ', 'Mo ', 'Hui ', 'Ma ', 'Zou ', 'Nen ', 'Fen ', 'Huang ', 'Huang ', 'Jin ', 'Guang ', 'Tian ', 'Tou ', 'Heng ', 'Xi ', 'Kuang ', 'Heng ', 'Shu ', 'Li ', 'Nian ', 'Chi ', 'Hei ', 'Hei ', 'Yi ', 'Qian ', 'Dan ', 'Xi ', 'Tuan ', 'Mo ', 'Mo ', 'Qian ', 'Dai ', 'Chu ', 'You ', 'Dian ', 'Yi ', 'Xia ', 'Yan ', 'Qu ', 'Mei ', 'Yan ', 'Jing ', 'Yu ', 'Li ', 'Dang ', 'Du ', 'Can ', 'Yin ', 'An ', 'Yan ', 'Tan ', 'An ', 'Zhen ', 'Dai ', 'Can ', 'Yi ', 'Mei ', 'Dan ', 'Yan ', 'Du ', 'Lu ', 'Zhi ', 'Fen ', 'Fu ', 'Fu ', 'Min ', 'Min ', 'Yuan ']


Joomla CMS: Référence du fichier StylesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_templates
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_templates/src/Controller/StylesController.php

Structures de données

class StylesController

Espaces de nommage

Joomla\API
Joomla\Component\Templates\Api\Controller


Joomla CMS: Référence du fichier x094.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x094.php

Variables

return ['Kui ', 'Si ', 'Liu ', 'Nao ', 'Heng ', 'Pie ', 'Sui ', 'Fan ', 'Qiao ', 'Quan ', 'Yang ', 'Tang ', 'Xiang ', 'Jue ', 'Jiao ', 'Zun ', 'Liao ', 'Jie ', 'Lao ', 'Dui ', 'Tan ', 'Zan ', 'Ji ', 'Jian ', 'Zhong ', 'Deng ', 'Ya ', 'Ying ', 'Dui ', 'Jue ', 'Nou ', 'Ti ', 'Pu ', 'Tie ', '[?] ', '[?] ', 'Ding ', 'Shan ', 'Kai ', 'Jian ', 'Fei ', 'Sui ', 'Lu ', 'Juan ', 'Hui ', 'Yu ', 'Lian ', 'Zhuo ', 'Qiao ', 'Qian ', 'Zhuo ', 'Lei ', 'Bi ', 'Tie ', 'Huan ', 'Ye ', 'Duo ', 'Guo ', 'Dang ', 'Ju ', 'Fen ', 'Da ', 'Bei ', 'Yi ', 'Ai ', 'Zong ', 'Xun ', 'Diao ', 'Zhu ', 'Heng ', 'Zhui ', 'Ji ', 'Nie ', 'Ta ', 'Huo ', 'Qing ', 'Bin ', 'Ying ', 'Kui ', 'Ning ', 'Xu ', 'Jian ', 'Jian ', 'Yari ', 'Cha ', 'Zhi ', 'Mie ', 'Li ', 'Lei ', 'Ji ', 'Zuan ', 'Kuang ', 'Shang ', 'Peng ', 'La ', 'Du ', 'Shuo ', 'Chuo ', 'Lu ', 'Biao ', 'Bao ', 'Lu ', '[?] ', '[?] ', 'Long ', 'E ', 'Lu ', 'Xin ', 'Jian ', 'Lan ', 'Bo ', 'Jian ', 'Yao ', 'Chan ', 'Xiang ', 'Jian ', 'Xi ', 'Guan ', 'Cang ', 'Nie ', 'Lei ', 'Cuan ', 'Qu ', 'Pan ', 'Luo ', 'Zuan ', 'Luan ', 'Zao ', 'Nie ', 'Jue ', 'Tang ', 'Shu ', 'Lan ', 'Jin ', 'Qiu ', 'Yi ', 'Zhen ', 'Ding ', 'Zhao ', 'Po ', 'Diao ', 'Tu ', 'Qian ', 'Chuan ', 'Shan ', 'Ji ', 'Fan ', 'Diao ', 'Men ', 'Nu ', 'Xi ', 'Chai ', 'Xing ', 'Gai ', 'Bu ', 'Tai ', 'Ju ', 'Dun ', 'Chao ', 'Zhong ', 'Na ', 'Bei ', 'Gang ', 'Ban ', 'Qian ', 'Yao ', 'Qin ', 'Jun ', 'Wu ', 'Gou ', 'Kang ', 'Fang ', 'Huo ', 'Tou ', 'Niu ', 'Ba ', 'Yu ', 'Qian ', 'Zheng ', 'Qian ', 'Gu ', 'Bo ', 'E ', 'Po ', 'Bu ', 'Ba ', 'Yue ', 'Zuan ', 'Mu ', 'Dan ', 'Jia ', 'Dian ', 'You ', 'Tie ', 'Bo ', 'Ling ', 'Shuo ', 'Qian ', 'Liu ', 'Bao ', 'Shi ', 'Xuan ', 'She ', 'Bi ', 'Ni ', 'Pi ', 'Duo ', 'Xing ', 'Kao ', 'Lao ', 'Er ', 'Mang ', 'Ya ', 'You ', 'Cheng ', 'Jia ', 'Ye ', 'Nao ', 'Zhi ', 'Dang ', 'Tong ', 'Lu ', 'Diao ', 'Yin ', 'Kai ', 'Zha ', 'Zhu ', 'Xian ', 'Ting ', 'Diu ', 'Xian ', 'Hua ', 'Quan ', 'Sha ', 'Jia ', 'Yao ', 'Ge ', 'Ming ', 'Zheng ', 'Se ', 'Jiao ', 'Yi ', 'Chan ', 'Chong ', 'Tang ', 'An ', 'Yin ', 'Ru ', 'Zhu ', 'Lao ', 'Pu ', 'Wu ', 'Lai ', 'Te ', 'Lian ', 'Keng ']

Documentation des variables

◆ return

return[ 'Kui ', 'Si ', 'Liu ', 'Nao ', 'Heng ', 'Pie ', 'Sui ', 'Fan ', 'Qiao ', 'Quan ', 'Yang ', 'Tang ', 'Xiang ', 'Jue ', 'Jiao ', 'Zun ', 'Liao ', 'Jie ', 'Lao ', 'Dui ', 'Tan ', 'Zan ', 'Ji ', 'Jian ', 'Zhong ', 'Deng ', 'Ya ', 'Ying ', 'Dui ', 'Jue ', 'Nou ', 'Ti ', 'Pu ', 'Tie ', '[?] ', '[?] ', 'Ding ', 'Shan ', 'Kai ', 'Jian ', 'Fei ', 'Sui ', 'Lu ', 'Juan ', 'Hui ', 'Yu ', 'Lian ', 'Zhuo ', 'Qiao ', 'Qian ', 'Zhuo ', 'Lei ', 'Bi ', 'Tie ', 'Huan ', 'Ye ', 'Duo ', 'Guo ', 'Dang ', 'Ju ', 'Fen ', 'Da ', 'Bei ', 'Yi ', 'Ai ', 'Zong ', 'Xun ', 'Diao ', 'Zhu ', 'Heng ', 'Zhui ', 'Ji ', 'Nie ', 'Ta ', 'Huo ', 'Qing ', 'Bin ', 'Ying ', 'Kui ', 'Ning ', 'Xu ', 'Jian ', 'Jian ', 'Yari ', 'Cha ', 'Zhi ', 'Mie ', 'Li ', 'Lei ', 'Ji ', 'Zuan ', 'Kuang ', 'Shang ', 'Peng ', 'La ', 'Du ', 'Shuo ', 'Chuo ', 'Lu ', 'Biao ', 'Bao ', 'Lu ', '[?] ', '[?] ', 'Long ', 'E ', 'Lu ', 'Xin ', 'Jian ', 'Lan ', 'Bo ', 'Jian ', 'Yao ', 'Chan ', 'Xiang ', 'Jian ', 'Xi ', 'Guan ', 'Cang ', 'Nie ', 'Lei ', 'Cuan ', 'Qu ', 'Pan ', 'Luo ', 'Zuan ', 'Luan ', 'Zao ', 'Nie ', 'Jue ', 'Tang ', 'Shu ', 'Lan ', 'Jin ', 'Qiu ', 'Yi ', 'Zhen ', 'Ding ', 'Zhao ', 'Po ', 'Diao ', 'Tu ', 'Qian ', 'Chuan ', 'Shan ', 'Ji ', 'Fan ', 'Diao ', 'Men ', 'Nu ', 'Xi ', 'Chai ', 'Xing ', 'Gai ', 'Bu ', 'Tai ', 'Ju ', 'Dun ', 'Chao ', 'Zhong ', 'Na ', 'Bei ', 'Gang ', 'Ban ', 'Qian ', 'Yao ', 'Qin ', 'Jun ', 'Wu ', 'Gou ', 'Kang ', 'Fang ', 'Huo ', 'Tou ', 'Niu ', 'Ba ', 'Yu ', 'Qian ', 'Zheng ', 'Qian ', 'Gu ', 'Bo ', 'E ', 'Po ', 'Bu ', 'Ba ', 'Yue ', 'Zuan ', 'Mu ', 'Dan ', 'Jia ', 'Dian ', 'You ', 'Tie ', 'Bo ', 'Ling ', 'Shuo ', 'Qian ', 'Liu ', 'Bao ', 'Shi ', 'Xuan ', 'She ', 'Bi ', 'Ni ', 'Pi ', 'Duo ', 'Xing ', 'Kao ', 'Lao ', 'Er ', 'Mang ', 'Ya ', 'You ', 'Cheng ', 'Jia ', 'Ye ', 'Nao ', 'Zhi ', 'Dang ', 'Tong ', 'Lu ', 'Diao ', 'Yin ', 'Kai ', 'Zha ', 'Zhu ', 'Xian ', 'Ting ', 'Diu ', 'Xian ', 'Hua ', 'Quan ', 'Sha ', 'Jia ', 'Yao ', 'Ge ', 'Ming ', 'Zheng ', 'Se ', 'Jiao ', 'Yi ', 'Chan ', 'Chong ', 'Tang ', 'An ', 'Yin ', 'Ru ', 'Zhu ', 'Lao ', 'Pu ', 'Wu ', 'Lai ', 'Te ', 'Lian ', 'Keng ']


Joomla CMS: Référence du fichier Xml.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/registry/src/Format/Xml.php

Structures de données

class Xml

Espaces de nommage

Joomla\Registry\Format


Joomla CMS: Référence du fichier RequestTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier nyholm/psr7/src/RequestTrait.php

Espaces de nommage

Nyholm\Psr7

Fonctions

getRequestTarget ()
withRequestTarget ($requestTarget)
getMethod ()
withMethod ($method)
getUri ()
withUri (UriInterface $uri, $preserveHost=false)
updateHostFromUri ()

Variables

trait RequestTrait
$requestTarget
$uri


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/RSA/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

RSA
phpseclib3\Crypt\RSA


Joomla CMS: Référence du fichier StatefulModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier StatefulModelInterface.php

Structures de données

interface StatefulModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier TimestampFirstCombCodec.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier TimestampFirstCombCodec.php

Structures de données

class TimestampFirstCombCodec

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier Prime_p.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Prime_p.php

Structures de données

class Prime_p

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x06e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06e.php

Variables

return ['Ben ', 'Yuan ', 'Wen ', 'Re ', 'Fei ', 'Qing ', 'Yuan ', 'Ke ', 'Ji ', 'She ', 'Yuan ', 'Shibui ', 'Lu ', 'Zi ', 'Du ', '[?] ', 'Jian ', 'Min ', 'Pi ', 'Tani ', 'Yu ', 'Yuan ', 'Shen ', 'Shen ', 'Rou ', 'Huan ', 'Zhu ', 'Jian ', 'Nuan ', 'Yu ', 'Qiu ', 'Ting ', 'Qu ', 'Du ', 'Feng ', 'Zha ', 'Bo ', 'Wo ', 'Wo ', 'Di ', 'Wei ', 'Wen ', 'Ru ', 'Xie ', 'Ce ', 'Wei ', 'Ge ', 'Gang ', 'Yan ', 'Hong ', 'Xuan ', 'Mi ', 'Ke ', 'Mao ', 'Ying ', 'Yan ', 'You ', 'Hong ', 'Miao ', 'Xing ', 'Mei ', 'Zai ', 'Hun ', 'Nai ', 'Kui ', 'Shi ', 'E ', 'Pai ', 'Mei ', 'Lian ', 'Qi ', 'Qi ', 'Mei ', 'Tian ', 'Cou ', 'Wei ', 'Can ', 'Tuan ', 'Mian ', 'Hui ', 'Mo ', 'Xu ', 'Ji ', 'Pen ', 'Jian ', 'Jian ', 'Hu ', 'Feng ', 'Xiang ', 'Yi ', 'Yin ', 'Zhan ', 'Shi ', 'Jie ', 'Cheng ', 'Huang ', 'Tan ', 'Yu ', 'Bi ', 'Min ', 'Shi ', 'Tu ', 'Sheng ', 'Yong ', 'Qu ', 'Zhong ', 'Suei ', 'Jiu ', 'Jiao ', 'Qiou ', 'Yin ', 'Tang ', 'Long ', 'Huo ', 'Yuan ', 'Nan ', 'Ban ', 'You ', 'Quan ', 'Chui ', 'Liang ', 'Chan ', 'Yan ', 'Chun ', 'Nie ', 'Zi ', 'Wan ', 'Shi ', 'Man ', 'Ying ', 'Ratsu ', 'Kui ', '[?] ', 'Jian ', 'Xu ', 'Lu ', 'Gui ', 'Gai ', '[?] ', '[?] ', 'Po ', 'Jin ', 'Gui ', 'Tang ', 'Yuan ', 'Suo ', 'Yuan ', 'Lian ', 'Yao ', 'Meng ', 'Zhun ', 'Sheng ', 'Ke ', 'Tai ', 'Da ', 'Wa ', 'Liu ', 'Gou ', 'Sao ', 'Ming ', 'Zha ', 'Shi ', 'Yi ', 'Lun ', 'Ma ', 'Pu ', 'Wei ', 'Li ', 'Cai ', 'Wu ', 'Xi ', 'Wen ', 'Qiang ', 'Ze ', 'Shi ', 'Su ', 'Yi ', 'Zhen ', 'Sou ', 'Yun ', 'Xiu ', 'Yin ', 'Rong ', 'Hun ', 'Su ', 'Su ', 'Ni ', 'Ta ', 'Shi ', 'Ru ', 'Wei ', 'Pan ', 'Chu ', 'Chu ', 'Pang ', 'Weng ', 'Cang ', 'Mie ', 'He ', 'Dian ', 'Hao ', 'Huang ', 'Xi ', 'Zi ', 'Di ', 'Zhi ', 'Ying ', 'Fu ', 'Jie ', 'Hua ', 'Ge ', 'Zi ', 'Tao ', 'Teng ', 'Sui ', 'Bi ', 'Jiao ', 'Hui ', 'Gun ', 'Yin ', 'Gao ', 'Long ', 'Zhi ', 'Yan ', 'She ', 'Man ', 'Ying ', 'Chun ', 'Lu ', 'Lan ', 'Luan ', '[?] ', 'Bin ', 'Tan ', 'Yu ', 'Sou ', 'Hu ', 'Bi ', 'Biao ', 'Zhi ', 'Jiang ', 'Kou ', 'Shen ', 'Shang ', 'Di ', 'Mi ', 'Ao ', 'Lu ', 'Hu ', 'Hu ', 'You ', 'Chan ', 'Fan ', 'Yong ', 'Gun ', 'Man ']

Documentation des variables

◆ return

return[ 'Ben ', 'Yuan ', 'Wen ', 'Re ', 'Fei ', 'Qing ', 'Yuan ', 'Ke ', 'Ji ', 'She ', 'Yuan ', 'Shibui ', 'Lu ', 'Zi ', 'Du ', '[?] ', 'Jian ', 'Min ', 'Pi ', 'Tani ', 'Yu ', 'Yuan ', 'Shen ', 'Shen ', 'Rou ', 'Huan ', 'Zhu ', 'Jian ', 'Nuan ', 'Yu ', 'Qiu ', 'Ting ', 'Qu ', 'Du ', 'Feng ', 'Zha ', 'Bo ', 'Wo ', 'Wo ', 'Di ', 'Wei ', 'Wen ', 'Ru ', 'Xie ', 'Ce ', 'Wei ', 'Ge ', 'Gang ', 'Yan ', 'Hong ', 'Xuan ', 'Mi ', 'Ke ', 'Mao ', 'Ying ', 'Yan ', 'You ', 'Hong ', 'Miao ', 'Xing ', 'Mei ', 'Zai ', 'Hun ', 'Nai ', 'Kui ', 'Shi ', 'E ', 'Pai ', 'Mei ', 'Lian ', 'Qi ', 'Qi ', 'Mei ', 'Tian ', 'Cou ', 'Wei ', 'Can ', 'Tuan ', 'Mian ', 'Hui ', 'Mo ', 'Xu ', 'Ji ', 'Pen ', 'Jian ', 'Jian ', 'Hu ', 'Feng ', 'Xiang ', 'Yi ', 'Yin ', 'Zhan ', 'Shi ', 'Jie ', 'Cheng ', 'Huang ', 'Tan ', 'Yu ', 'Bi ', 'Min ', 'Shi ', 'Tu ', 'Sheng ', 'Yong ', 'Qu ', 'Zhong ', 'Suei ', 'Jiu ', 'Jiao ', 'Qiou ', 'Yin ', 'Tang ', 'Long ', 'Huo ', 'Yuan ', 'Nan ', 'Ban ', 'You ', 'Quan ', 'Chui ', 'Liang ', 'Chan ', 'Yan ', 'Chun ', 'Nie ', 'Zi ', 'Wan ', 'Shi ', 'Man ', 'Ying ', 'Ratsu ', 'Kui ', '[?] ', 'Jian ', 'Xu ', 'Lu ', 'Gui ', 'Gai ', '[?] ', '[?] ', 'Po ', 'Jin ', 'Gui ', 'Tang ', 'Yuan ', 'Suo ', 'Yuan ', 'Lian ', 'Yao ', 'Meng ', 'Zhun ', 'Sheng ', 'Ke ', 'Tai ', 'Da ', 'Wa ', 'Liu ', 'Gou ', 'Sao ', 'Ming ', 'Zha ', 'Shi ', 'Yi ', 'Lun ', 'Ma ', 'Pu ', 'Wei ', 'Li ', 'Cai ', 'Wu ', 'Xi ', 'Wen ', 'Qiang ', 'Ze ', 'Shi ', 'Su ', 'Yi ', 'Zhen ', 'Sou ', 'Yun ', 'Xiu ', 'Yin ', 'Rong ', 'Hun ', 'Su ', 'Su ', 'Ni ', 'Ta ', 'Shi ', 'Ru ', 'Wei ', 'Pan ', 'Chu ', 'Chu ', 'Pang ', 'Weng ', 'Cang ', 'Mie ', 'He ', 'Dian ', 'Hao ', 'Huang ', 'Xi ', 'Zi ', 'Di ', 'Zhi ', 'Ying ', 'Fu ', 'Jie ', 'Hua ', 'Ge ', 'Zi ', 'Tao ', 'Teng ', 'Sui ', 'Bi ', 'Jiao ', 'Hui ', 'Gun ', 'Yin ', 'Gao ', 'Long ', 'Zhi ', 'Yan ', 'She ', 'Man ', 'Ying ', 'Chun ', 'Lu ', 'Lan ', 'Luan ', '[?] ', 'Bin ', 'Tan ', 'Yu ', 'Sou ', 'Hu ', 'Bi ', 'Biao ', 'Zhi ', 'Jiang ', 'Kou ', 'Shen ', 'Shang ', 'Di ', 'Mi ', 'Ao ', 'Lu ', 'Hu ', 'Hu ', 'You ', 'Chan ', 'Fan ', 'Yong ', 'Gun ', 'Man ']


Joomla CMS: Référence du fichier rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier rules.php

Espaces de nommage

Joomla\Site

Variables

$document = Factory::getDocument()
$ajaxUri = Route::_('index.php?option=com_config&task=application.store&format=json&' . Session::getFormToken() . '=1')
< details >< summary class="rule-notes"> if($section==='component'||! $section) | else
$isSuperUserGroup = Access::checkGroup($group->value, 'core.admin')
if (!empty( $action->description))
endif
$assetRule = $newItem === false ? $assetRules->allow($action->name, $group->value) : null
< option value=""<?php echo( $assetRule===null ? ' selected="selected"' :'');?> | $result = array()
$inheritedGroupRule = Access::checkGroup((int) $group->value, $action->name, $assetId)
$inheritedGroupParentAssetRule = !empty($parentAssetId) ? Access::checkGroup($group->value, $action->name, $parentAssetId) : null
$inheritedParentGroupRule = !empty($group->parent_id) ? Access::checkGroup($group->parent_id, $action->name, $assetId) : null
endforeach

Documentation des variables

◆ $ajaxUri

$ajaxUri = Route::_('index.php?option=com_config&task=application.store&format=json&' . Session::getFormToken() . '=1')

◆ $assetRule

$assetRule = $newItem === false ? $assetRules->allow($action->name, $group->value) : null

Possible values: null = not set means inherited false = denied true = allowed

◆ $document

$document = Factory::getDocument()

◆ $inheritedGroupParentAssetRule

$inheritedGroupParentAssetRule = !empty($parentAssetId) ? Access::checkGroup($group->value, $action->name, $parentAssetId) : null

◆ $inheritedGroupRule

$inheritedGroupRule = Access::checkGroup((int) $group->value, $action->name, $assetId)

◆ $inheritedParentGroupRule

$inheritedParentGroupRule = !empty($group->parent_id) ? Access::checkGroup($group->parent_id, $action->name, $assetId) : null

◆ $isSuperUserGroup

$isSuperUserGroup = Access::checkGroup($group->value, 'core.admin')

◆ $result

return $result = array()
Exemples:
C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php.

Référencé par StringStream\__construct(), Editor\__construct(), Engine\__debugInfo(), Query\__destruct(), OtherObject\__toString(), ByteStringWithChunkObject\__toString(), TextStringWithChunkObject\__toString(), SignedIntegerObject\__toString(), UnsignedIntegerObject\__toString(), TagObject\__toString(), InfiniteListObject\__toString(), InfiniteMapObject\__toString(), ByteStringObject\__toString(), TextStringObject\__toString(), MapObject\__toString(), ListObject\__toString(), CSR\__toString(), PlgContentJoomla\_canDeleteCategories(), PlgContentJoomla\_canDeleteStage(), Module\_getAssetParentId(), Category\_getAssetParentId(), Content\_getAssetParentId(), WorkflowTable\_getAssetParentId(), InstallerModel\_getList(), PluginsModel\_getList(), ModulesModel\_getList(), UpdateModel\_getList(), GroupsModel\_getList(), FieldsModel\_getList(), Categories\_load(), Stream\_stream_read(), Stream\_stream_write(), UserModel\activate(), ModuleController\add(), NativeCalculator\add(), ItemController\add(), Mail\addAttachment(), ArrayHelper\addColumn(), Users\admin_language(), InstallController\ajax_upload(), Rule\allow(), Registry\append(), FtpClient\append(), ArrayHelper\arrayFromObject(), POP3\authorise(), AdminModel\batch(), Calculator\bitwise(), Engine\bitwise_leftRotate(), UserModel\block(), NomenuRules\build(), MysqlChangeItem\buildCheckQuery(), PostgresqlChangeItem\buildCheckQuery(), SqlsrvChangeItem\buildCheckQuery(), UserController\cancel(), TaskController\cancel(), ModuleController\cancel(), CategoryController\cancel(), ItemController\cancel(), ContactController\cancel(), MediaHelper\canUpload(), PgSqlCaster\castResult(), Captcha\checkAnswer(), CertificateToolbox\checkChain(), FieldModel\checkDefaultValue(), BaseController\checkEditId(), ResetModel\checkResetLimit(), TemplateModel\child(), InputFilter\clean(), InputFilter\cleanCmd(), InputFilter\cleanTrim(), SMTP\client_send(), StringStream\close(), Calculator\cmp(), SFTP\comparator(), PHP\compareHelper(), Query\controlPagedResultResponse(), PHP\convertToObj(), ComponentAdapter\copyBaseFiles(), HtmlDocument\countModules(), ECKey\createECKeyUsingOpenSSL(), ApiModel\createFile(), ApiModel\createFolder(), PHPMailer\createHeader(), ContenthistoryHelper\createObjectArray(), ConfigurationModel\createRootUser(), TagsHelper\createTagsFromField(), UpdateModel\createUpdateFile(), ParagonIE_Sodium_Compat\crypto_generichash_final(), SMTP\data(), Files\decodeData(), InputFilter\decodeFileData(), Normalizer\decompose(), RC2\decrypt(), DisplayController\delete(), MapsModel\delete(), IndexModel\delete(), StyleModel\delete(), MfaTable\delete(), MenuModel\delete(), ApiModel\delete(), ModuleModel\delete(), User\delete(), AdminModel\delete(), SFTP\delete(), ContentHistory\deleteOldVersions(), Manifest\deserializeMetaData(), SessionManager\destroySessions(), Stream\detach(), WebClient\detectEngine(), PlgSystemStats\disablePlugin(), DiscoverModel\discover(), DiscoverModel\discover_install(), Installer\discover_install(), FeedView\display(), JsonView\display(), HtmlView\display(), Captcha\display(), PHP\divide_digit(), BigDecimal\dividedBy(), BigInteger\dividedBy(), NativeCalculator\doAdd(), InstallerAdapter\doDatabaseTransactions(), DeleteUserCommand\doExecute(), AddUserToGroupCommand\doExecute(), RemoveUserFromGroupCommand\doExecute(), ExtensionInstallCommand\doExecute(), ExtensionDiscoverInstallCommand\doExecute(), NativeCalculator\doMul(), NativeCalculator\doSub(), OpenSSL\doVerify(), UpdateModel\downloadPackage(), ArrayHelper\dropColumn(), AbstractDumper\dump(), HtmlDumper\dump(), DebugBarVarDumper\dump(), StyleModel\duplicate(), ItemController\edit(), ArticleController\edit(), XML\encodeXMLParameters(), RC2\encrypt(), SymmetricKey\encrypt(), MysqliDriver\escape(), MysqlDriver\escape(), TraceablePDOStatement\execute(), Joomla\CMS\MVC\Model\executeTransition(), Archive\extract(), DatabaseModel\fetchSchemaCache(), SFTP\file_exists(), TelFilter\filter(), UpdateModel\finaliseUpgrade(), PlgInstallerOverride\finalize(), SqlsrvChangeItem\fixInteger(), MysqlChangeItem\fixInteger(), PostgresqlChangeItem\fixInteger(), TemplateModel\fixTemplateName(), ArrayHelper\flatten(), FlattenException\flattenArgs(), BigNumber\floatToString(), Session\fork(), BCMath\format(), HtmlErrorRenderer\formatArgs(), Calculator\fromArbitraryBase(), BigInteger\fromBase(), FileStorage\gc(), EvalBarrett\generateCustomReduction(), EvalBarrett\generateInlineAdd(), EvalBarrett\generateInlineSubtract1(), EvalBarrett\generateInlineSubtract2(), SSH2\get_channel_packet(), SFTP\get_xstat_cache_prop(), ContentHelper\getActions(), ConfigHelper\getAllComponents(), FieldTable\getAssetId(), Access\getAssetRules(), UserModel\getAssignedGroups(), CategoriesHelper\getAssociations(), ASNObject\getBinary(), PHPMailer\getBoundary(), Editor\getButtons(), ComponentHelper\getComponent(), ComponentModel\getComponent(), ConfigHelper\getComponentsWithConfig(), MemcachedStorage\getConnection(), Stream\getContents(), ContentType\getContentTable(), Joomlaupdate\getCoreUpdateNotification(), ChoiceQuestion\getDefaultValidator(), TemplateModel\getDirectoryTree(), X509\getDN(), X509\getDNProp(), OctetString\getEncodedValue(), Construct\getEncodedValue(), FieldsHelper\getFieldsPluginId(), TemplateModel\getFiles(), ContenthistoryHelper\getFormFile(), ContenthistoryHelper\getFormValues(), RemoveUserFromGroupCommand\getGroups(), Access\getGroupsByUser(), ChecksModel\getIniParserAvailability(), UpdateModel\getIniParserAvailability(), PlugininfoField\getInput(), MessagesModel\getItem(), NoteModel\getItem(), OverrideModel\getItem(), TagModel\getItem(), LevelModel\getItem(), AbstractMenu\getItem(), CategoryModel\getItem(), FieldModel\getItem(), ItemModel\getItem(), FetchMediaItemsEvent\getItems(), SearchModel\getItems(), AssociationsHelper\getLanguagefilterPluginId(), DataField\getLayoutData(), LibraryHelper\getLibrary(), TagsSimilarHelper\getList(), LoggedHelper\getList(), LoginModel\getLoginModule(), ContenthistoryHelper\getLookupValue(), PHPMailer\getMailMIME(), TemplateModel\getMediaFiles(), Document\getMetaData(), LanguageHelper\getMetadata(), ModuleHelper\getModule(), ModuleHelper\getModuleById(), ModuleHelper\getModules(), MenusModel\getModules(), MenuModel\getModules(), ItemModel\getModules(), CronExpression\getMultipleRunDates(), Base64EncodingTag\getNormalizedData(), InfiniteMapObject\getNormalizedData(), TextStringWithChunkObject\getNormalizedData(), ByteStringWithChunkObject\getNormalizedData(), MapObject\getNormalizedData(), SignedIntegerObject\getNormalizedData(), WhosonlineHelper\getOnlineCount(), PlgFieldsSubform\getOptionsFromField(), PlgQuickiconOverrideCheck\getOverridePluginId(), TemplateModel\getOverridesList(), RouterView\getPath(), ChecksModel\getPhpOptionsSufficient(), PluginHelper\getPlugin(), TemplateModel\getPreview(), MediaModel\getProviders(), DisplayController\getQuickiconContent(), PluginsController\getQuickiconContent(), CategoriesController\getQuickiconContent(), ItemsController\getQuickiconContent(), TagsController\getQuickiconContent(), ModulesController\getQuickiconContent(), ArticlesController\getQuickiconContent(), UsersController\getQuickiconContent(), RedirectHelper\getRedirectPluginId(), MethodModel\getRenderOptions(), Nested\getRootId(), ChangeSet\getSchema(), HistoryModel\getSha1Hash(), ChangeSet\getStatus(), PlgFieldsSubform\getSubfieldsFromField(), AssociationsHelper\getSupportedExtension(), PgsqlDriver\getTableColumns(), MysqlDriver\getTableColumns(), MysqliDriver\getTableColumns(), MysqlDriver\getTableCreate(), MysqliDriver\getTableCreate(), TemplateModel\getTemplate(), PlgInstallerOverride\getUpdatedFiles(), ChangeSet\getUpdateQueries(), Updater\getUpdateSites(), UpdateModel\getUpdateSitesInfo(), UsersModel\getUserDisplayedGroups(), Access\getUsersByGroup(), TextStringWithChunkObject\getValue(), ByteStringWithChunkObject\getValue(), ArrayHelper\getValue(), Router\getVar(), ItemModel\getViewLevels(), NamePrep\hangulCompose(), NamePrep\hangulDecompose(), Session\hasToken(), LengthCalculator\hex2bin(), ECSignature\hex2bin(), SignedIntegerObject\hex2bin(), UnsignedIntegerObject\hex2bin(), MessagesModel\hideMessages(), Iconv\iconv(), Iconv\iconv_mime_decode(), Bootup\initAll(), InstallModel\install(), UpdateModel\install(), Installer\install(), PharStreamWrapper\invokeInternalStreamWrapper(), SFTP\is_dir(), SFTP\is_file(), SFTP\is_link(), ParagonIE_Sodium_Core_Ristretto255\is_valid_point(), PlgSystemJooa11y\isAuthorisedDisplayChecker(), PlgSystemDebug\isAuthorisedDisplayDebug(), BackupcodesModel\isBackupCode(), ModuleHelper\isEnabled(), PluginHelper\isEnabled(), SymmetricKey\isValidEngineHelper(), CliDumper\isWindowsTrueColor(), AttestedCredentialData\jsonSerialize(), Engine\jsonSerialize(), BigInteger\jsonSerialize(), Users\language(), X509\listRevoked(), SSH2\load(), PuTTY\load(), PKCS8\load(), PSS\load(), MfaTable\load(), Language\load(), Table\load(), CaptiveModel\loadCaptiveRenderOptions(), ClassLoader\loadClass(), XML\loadCurveByParam(), XML\loadCurveByParamRFC4050(), Language\loadLanguage(), MenusHelper\loadXml(), AdministratorApplication\login(), DisplayController\logout(), SFTP\lstat(), PHPMailer\mailPassthru(), PHPMailer\mailSend(), Iconv\mapFromUtf8(), Iconv\mapToUtf8(), Mbstring\mb_encode_numericentity(), Mbstring\mb_str_split(), TimeDataCollector\measure(), ProfileCollector\measure(), ContenthistoryHelper\mergeLabels(), ArrayHelper\mergeRecursive(), DatabaseModel\mergeSchemaCache(), SFTP\mkdir(), GmpCalculator\modInverse(), Montgomery\modInverse67108864(), BigInteger\modPow(), NativeCalculator\mul(), BCMath\mul(), SFTP\nlist_helper(), GMP\normalize(), BCMath\normalize(), PHP\normalize(), DatabaseQuery\nullDate(), PlgSystemPrivacyconsent\onAfterRender(), PlgSystemActionLogs\onAfterRespond(), PlgSystemDebug\onAjaxDebug(), PlgContentJoomla\onContentBeforeChangeState(), PlgEditorCodemirror\onDisplay(), Joomla\onExtensionAfterUninstall(), PlgInstallerOverride\onExtensionAfterUpdate(), PlgInstallerOverride\onInstallerAfterInstaller(), PlgInstallerOverride\onJoomlaAfterUpdate(), MessagesModel\onProcessList(), PlgUserToken\onUserAfterSave(), PlgUserProfile\onUserAfterSave(), PlgAuthenticationJoomla\onUserAuthenticate(), Basic\onUserAuthenticate(), PlgAuthenticationCookie\onUserAuthenticate(), PlgUserJoomla\onUserLogin(), PlgWorkflowPublishing\onWorkflowBeforeTransition(), SuggestionsController\opensearchsuggest(), Strings\packSSH2(), Inline\parse(), NomenuRules\parse(), UriHelper\parse_url(), SFTP\parseAttributes(), InstallerAdapter\parseQueries(), ArrayHelper\pivot(), TagsHelper\postStoreProcess(), NativeCalculator\pow(), OpenSSL\powModHelper(), FormModel\preprocessForm(), Query\processDynamicTaxonomy(), ExtensionInstallCommand\processPathInstallation(), Query\processStaticTaxonomy(), ExtensionInstallCommand\processUrlInstallation(), PackedAttestationStatementSupport\processWithCertificate(), TPMAttestationStatementSupport\processWithCertificate(), TraceablePDO\profileCall(), UpdatesitesModel\publish(), ManageModel\publish(), TemplateModel\publish(), MapsModel\publish(), NewsfeedModel\publish(), IndexModel\publish(), AdminModel\publish(), SFTP\put(), XML\query(), Stream\read(), LdapClient\read(), Normalizer\recompose(), SSH2\reconnect(), PowerOfTwo\reduce(), Montgomery\reduce(), Barrett\reduce(), ManageModel\refresh(), Installer\refreshManifestCache(), CMSPlugin\registerLegacyListener(), Barrett\regularBarrett(), Integer\regularPolynomialMultiply(), ManageModel\remove(), Registry\remove(), X509\removeAttribute(), X509\removeExtensionHelper(), ApplicationModel\removeroot(), AdminModel\reorder(), UnicodeString\replace(), ConfigPostProcessor\replacementRuleMatch(), MessagesModel\resetMessages(), Joomla\Component\Media\Administrator\Provider\resolveAdapterAndPath(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_elligator(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_frombytes(), ParagonIE_Sodium_Core_Ristretto255\ristretto255_p3_tobytes(), SiteApplication\route(), CMSApplication\route(), WorkflowModel\save(), UserController\save(), CategoryController\save(), UpdatesiteModel\save(), ComponentModel\save(), LanguageModel\save(), MenuModel\save(), ApplicationModel\save(), TemplateModel\save(), ArticleController\save(), StyleModel\save(), CategoryModel\save(), User\save(), ModuleModel\save(), AdminModel\save(), ItemModel\save(), LibraryHelper\saveParams(), PlgSystemStats\saveParams(), ParagonIE_Sodium_Core_Ristretto255\scalarmult_ristretto255(), LdapClient\search(), LocalAdapter\search(), PlgAuthenticationLdap\searchByString(), Stream\seek(), JWKSet\selectKey(), Mail\Send(), PHPMailer\serverHostname(), Pagination\setAdditionalUrlParam(), MethodsModel\setFlag(), FetchMediaItemsEvent\setItems(), Mail\setSender(), SFTP\setstat(), WorkflowstageField\setup(), TransitionField\setup(), ModulesPositionField\setup(), CaptchaField\setup(), ModulesModuleField\setup(), OrderingField\setup(), ModulepositionField\setup(), ChromestyleField\setup(), ModulesPositioneditField\setup(), TemplatestyleField\setup(), MenuitemField\setup(), MenuItemByTypeField\setup(), TextField\setup(), EditorField\setup(), MediaField\setup(), Captcha\setupField(), MysqliDriver\setUtf(), RSA\sign(), ECDSA\sign(), RSAPKCS1\sign(), PrivateKey\sign(), X509\sign(), X509\signCRL(), X509\signCSR(), X509\signSPKAC(), LdapClient\simple_search(), Montgomery\slidingWindow(), Engine\slidingWindow(), JWS\split(), BCMath\sqrt(), SFTP\stat(), OutputController\store(), Versioning\store(), MfaTable\store(), PageController\store(), ViewController\store(), CallbackController\store(), FileStorage\store(), Usergroup\store(), CoreContent\store(), User\store(), Nested\store(), FtpClient\store(), Taxonomy\storeNode(), StringWrapper\stream_read(), StreamString\stream_read(), Random\string(), Assertion\stringify(), ContactController\submit(), TagsHelper\tagItem(), Stream\tell(), Crypt\timingSafeCompare(), timingSafeEquals(), Calculator\toArbitraryBase(), Calculator\toBinary(), Engine\toBits(), PHP\toBytes(), Calculator\toDecimal(), HTMLHelper\tooltipText(), RSAKey\toPEM(), PHP\toString(), Joomla\CMS\Application\triggerEvent(), StringHelper\truncate(), Installer\uninstall(), Strings\unpackSSH2(), UpdateModel\update(), Installer\update(), JoomlaInstallerScript\updateDatabaseMysql(), ApiModel\updateFile(), UpdateCoreCommand\updateJoomlaCore(), UpdateModel\upload(), utf8_bad_replace(), utf8_bad_strip(), utf8_byte_position(), utf8_from_unicode(), utf8_strip_ascii_ctrl(), utf8_strip_non_ascii(), utf8_strip_non_ascii_ctrl(), SplFixedArray\valid(), PublicKey\verify(), Stream\write(), FtpClient\write(), et Stream\writeFile().

◆ else

if ( $isSuperUserGroup) else
Valeur initiale :
{
echo Text::alt('JLIB_RULES_SETTING_NOTES_ITEM', $component . '_' . $section)
$section
$section
Definition: administrator/components/com_categories/tmpl/categories/default.php:35
$component
$component
Definition: administrator/components/com_categories/tmpl/categories/default.php:34

◆ endforeach

endforeach

◆ endif

endif

◆ if

if(!empty($action->description))


Joomla CMS: Référence du fichier Php.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Structures de données | Espaces de nommage
Référence du fichier Php.php

Structures de données

class Php

Espaces de nommage

Joomla\Registry\Format


Joomla CMS: Référence du fichier x053.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x053.php

Variables

return ['Yun ', 'Mwun ', 'Nay ', 'Gai ', 'Gai ', 'Bao ', 'Cong ', '[?] ', 'Xiong ', 'Peng ', 'Ju ', 'Tao ', 'Ge ', 'Pu ', 'An ', 'Pao ', 'Fu ', 'Gong ', 'Da ', 'Jiu ', 'Qiong ', 'Bi ', 'Hua ', 'Bei ', 'Nao ', 'Chi ', 'Fang ', 'Jiu ', 'Yi ', 'Za ', 'Jiang ', 'Kang ', 'Jiang ', 'Kuang ', 'Hu ', 'Xia ', 'Qu ', 'Bian ', 'Gui ', 'Qie ', 'Zang ', 'Kuang ', 'Fei ', 'Hu ', 'Tou ', 'Gui ', 'Gui ', 'Hui ', 'Dan ', 'Gui ', 'Lian ', 'Lian ', 'Suan ', 'Du ', 'Jiu ', 'Qu ', 'Xi ', 'Pi ', 'Qu ', 'Yi ', 'Qia ', 'Yan ', 'Bian ', 'Ni ', 'Qu ', 'Shi ', 'Xin ', 'Qian ', 'Nian ', 'Sa ', 'Zu ', 'Sheng ', 'Wu ', 'Hui ', 'Ban ', 'Shi ', 'Xi ', 'Wan ', 'Hua ', 'Xie ', 'Wan ', 'Bei ', 'Zu ', 'Zhuo ', 'Xie ', 'Dan ', 'Mai ', 'Nan ', 'Dan ', 'Ji ', 'Bo ', 'Shuai ', 'Bu ', 'Kuang ', 'Bian ', 'Bu ', 'Zhan ', 'Qia ', 'Lu ', 'You ', 'Lu ', 'Xi ', 'Gua ', 'Wo ', 'Xie ', 'Jie ', 'Jie ', 'Wei ', 'Ang ', 'Qiong ', 'Zhi ', 'Mao ', 'Yin ', 'Wei ', 'Shao ', 'Ji ', 'Que ', 'Luan ', 'Shi ', 'Juan ', 'Xie ', 'Xu ', 'Jin ', 'Que ', 'Wu ', 'Ji ', 'E ', 'Qing ', 'Xi ', '[?] ', 'Han ', 'Zhan ', 'E ', 'Ting ', 'Li ', 'Zhe ', 'Han ', 'Li ', 'Ya ', 'Ya ', 'Yan ', 'She ', 'Zhi ', 'Zha ', 'Pang ', '[?] ', 'He ', 'Ya ', 'Zhi ', 'Ce ', 'Pang ', 'Ti ', 'Li ', 'She ', 'Hou ', 'Ting ', 'Zui ', 'Cuo ', 'Fei ', 'Yuan ', 'Ce ', 'Yuan ', 'Xiang ', 'Yan ', 'Li ', 'Jue ', 'Sha ', 'Dian ', 'Chu ', 'Jiu ', 'Qin ', 'Ao ', 'Gui ', 'Yan ', 'Si ', 'Li ', 'Chang ', 'Lan ', 'Li ', 'Yan ', 'Yan ', 'Yuan ', 'Si ', 'Gong ', 'Lin ', 'Qiu ', 'Qu ', 'Qu ', 'Uk ', 'Lei ', 'Du ', 'Xian ', 'Zhuan ', 'San ', 'Can ', 'Can ', 'Can ', 'Can ', 'Ai ', 'Dai ', 'You ', 'Cha ', 'Ji ', 'You ', 'Shuang ', 'Fan ', 'Shou ', 'Guai ', 'Ba ', 'Fa ', 'Ruo ', 'Shi ', 'Shu ', 'Zhuo ', 'Qu ', 'Shou ', 'Bian ', 'Xu ', 'Jia ', 'Pan ', 'Sou ', 'Gao ', 'Wei ', 'Sou ', 'Die ', 'Rui ', 'Cong ', 'Kou ', 'Gu ', 'Ju ', 'Ling ', 'Gua ', 'Tao ', 'Kou ', 'Zhi ', 'Jiao ', 'Zhao ', 'Ba ', 'Ding ', 'Ke ', 'Tai ', 'Chi ', 'Shi ', 'You ', 'Qiu ', 'Po ', 'Xie ', 'Hao ', 'Si ', 'Tan ', 'Chi ', 'Le ', 'Diao ', 'Ji ', '[?] ', 'Hong ']

Documentation des variables

◆ return

return[ 'Yun ', 'Mwun ', 'Nay ', 'Gai ', 'Gai ', 'Bao ', 'Cong ', '[?] ', 'Xiong ', 'Peng ', 'Ju ', 'Tao ', 'Ge ', 'Pu ', 'An ', 'Pao ', 'Fu ', 'Gong ', 'Da ', 'Jiu ', 'Qiong ', 'Bi ', 'Hua ', 'Bei ', 'Nao ', 'Chi ', 'Fang ', 'Jiu ', 'Yi ', 'Za ', 'Jiang ', 'Kang ', 'Jiang ', 'Kuang ', 'Hu ', 'Xia ', 'Qu ', 'Bian ', 'Gui ', 'Qie ', 'Zang ', 'Kuang ', 'Fei ', 'Hu ', 'Tou ', 'Gui ', 'Gui ', 'Hui ', 'Dan ', 'Gui ', 'Lian ', 'Lian ', 'Suan ', 'Du ', 'Jiu ', 'Qu ', 'Xi ', 'Pi ', 'Qu ', 'Yi ', 'Qia ', 'Yan ', 'Bian ', 'Ni ', 'Qu ', 'Shi ', 'Xin ', 'Qian ', 'Nian ', 'Sa ', 'Zu ', 'Sheng ', 'Wu ', 'Hui ', 'Ban ', 'Shi ', 'Xi ', 'Wan ', 'Hua ', 'Xie ', 'Wan ', 'Bei ', 'Zu ', 'Zhuo ', 'Xie ', 'Dan ', 'Mai ', 'Nan ', 'Dan ', 'Ji ', 'Bo ', 'Shuai ', 'Bu ', 'Kuang ', 'Bian ', 'Bu ', 'Zhan ', 'Qia ', 'Lu ', 'You ', 'Lu ', 'Xi ', 'Gua ', 'Wo ', 'Xie ', 'Jie ', 'Jie ', 'Wei ', 'Ang ', 'Qiong ', 'Zhi ', 'Mao ', 'Yin ', 'Wei ', 'Shao ', 'Ji ', 'Que ', 'Luan ', 'Shi ', 'Juan ', 'Xie ', 'Xu ', 'Jin ', 'Que ', 'Wu ', 'Ji ', 'E ', 'Qing ', 'Xi ', '[?] ', 'Han ', 'Zhan ', 'E ', 'Ting ', 'Li ', 'Zhe ', 'Han ', 'Li ', 'Ya ', 'Ya ', 'Yan ', 'She ', 'Zhi ', 'Zha ', 'Pang ', '[?] ', 'He ', 'Ya ', 'Zhi ', 'Ce ', 'Pang ', 'Ti ', 'Li ', 'She ', 'Hou ', 'Ting ', 'Zui ', 'Cuo ', 'Fei ', 'Yuan ', 'Ce ', 'Yuan ', 'Xiang ', 'Yan ', 'Li ', 'Jue ', 'Sha ', 'Dian ', 'Chu ', 'Jiu ', 'Qin ', 'Ao ', 'Gui ', 'Yan ', 'Si ', 'Li ', 'Chang ', 'Lan ', 'Li ', 'Yan ', 'Yan ', 'Yuan ', 'Si ', 'Gong ', 'Lin ', 'Qiu ', 'Qu ', 'Qu ', 'Uk ', 'Lei ', 'Du ', 'Xian ', 'Zhuan ', 'San ', 'Can ', 'Can ', 'Can ', 'Can ', 'Ai ', 'Dai ', 'You ', 'Cha ', 'Ji ', 'You ', 'Shuang ', 'Fan ', 'Shou ', 'Guai ', 'Ba ', 'Fa ', 'Ruo ', 'Shi ', 'Shu ', 'Zhuo ', 'Qu ', 'Shou ', 'Bian ', 'Xu ', 'Jia ', 'Pan ', 'Sou ', 'Gao ', 'Wei ', 'Sou ', 'Die ', 'Rui ', 'Cong ', 'Kou ', 'Gu ', 'Ju ', 'Ling ', 'Gua ', 'Tao ', 'Kou ', 'Zhi ', 'Jiao ', 'Zhao ', 'Ba ', 'Ding ', 'Ke ', 'Tai ', 'Chi ', 'Shi ', 'You ', 'Qiu ', 'Po ', 'Xie ', 'Hao ', 'Si ', 'Tan ', 'Chi ', 'Le ', 'Diao ', 'Ji ', '[?] ', 'Hong ']


Joomla CMS: Référence du fichier SqlsrvStatement.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlsrv
Structures de données | Espaces de nommage
Référence du fichier SqlsrvStatement.php

Structures de données

class SqlsrvStatement

Espaces de nommage

Joomla\Database\Sqlsrv


Joomla CMS: Référence du fichier preupdatecheck.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage | Variables
Référence du fichier preupdatecheck.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$compatibilityTypes
$latestJoomlaVersion = $this->updateInfo['latest']
$currentJoomlaVersion = isset($this->updateInfo['installed']) ? $this->updateInfo['installed'] : JVERSION
$updatePossible = true
if (version_compare( $this->updateInfo[ 'latest'], Version::MAJOR_VERSION+1, '>=') &&$this->isDefaultBackendTemplate===false)
$labelClass = 'success'
break
endif
endforeach
foreach ( $this->phpSettings as $setting)
if | (!empty($this->nonCoreExtensions)) ( $compatibilityTypes as $compatibilityType=> $data)
if | ($data['group']==0) ( $this->nonCoreExtensions as $extension)
else __pad0__

Documentation des variables

◆ $compatibilityTypes

$compatibilityTypes

◆ $currentJoomlaVersion

$currentJoomlaVersion = isset($this->updateInfo['installed']) ? $this->updateInfo['installed'] : JVERSION

◆ $labelClass

$labelClass = 'success'

Référencé par AssociationsHelper\getAssociationHtmlList().

◆ $latestJoomlaVersion

$latestJoomlaVersion = $this->updateInfo['latest']

◆ $updatePossible

foreach ($this->phpOptions as $option) (! $option->state) $updatePossible = true

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ (!empty($this->nonCoreExtensions))

if (!empty( $this->nonCoreExtensions))($compatibilityTypes as $compatibilityType=> $data)

◆ ($data['group']==0)

if ( $data[ 'group']==0)($this->nonCoreExtensions as $extension)

◆ __pad0__

else __pad0__

◆ break

foreach ($this->phpSettings as $setting) ( $setting->state !==$setting->recommended) break

Référencé par CutStub\__construct().

◆ endforeach

endforeach

◆ endif

endif

◆ foreach

foreach($this->phpSettings as $setting)

◆ if

if(version_compare($this->updateInfo['latest'], Version::MAJOR_VERSION+1, '>=') && $this->isDefaultBackendTemplate===false)


Joomla CMS: Référence du fichier x07c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07c.php

Variables

return ['Ze ', 'Xi ', 'Guo ', 'Yi ', 'Hu ', 'Chan ', 'Kou ', 'Cu ', 'Ping ', 'Chou ', 'Ji ', 'Gui ', 'Su ', 'Lou ', 'Zha ', 'Lu ', 'Nian ', 'Suo ', 'Cuan ', 'Sasara ', 'Suo ', 'Le ', 'Duan ', 'Yana ', 'Xiao ', 'Bo ', 'Mi ', 'Si ', 'Dang ', 'Liao ', 'Dan ', 'Dian ', 'Fu ', 'Jian ', 'Min ', 'Kui ', 'Dai ', 'Qiao ', 'Deng ', 'Huang ', 'Sun ', 'Lao ', 'Zan ', 'Xiao ', 'Du ', 'Shi ', 'Zan ', '[?] ', 'Pai ', 'Hata ', 'Pai ', 'Gan ', 'Ju ', 'Du ', 'Lu ', 'Yan ', 'Bo ', 'Dang ', 'Sai ', 'Ke ', 'Long ', 'Qian ', 'Lian ', 'Bo ', 'Zhou ', 'Lai ', '[?] ', 'Lan ', 'Kui ', 'Yu ', 'Yue ', 'Hao ', 'Zhen ', 'Tai ', 'Ti ', 'Mi ', 'Chou ', 'Ji ', '[?] ', 'Hata ', 'Teng ', 'Zhuan ', 'Zhou ', 'Fan ', 'Sou ', 'Zhou ', 'Kuji ', 'Zhuo ', 'Teng ', 'Lu ', 'Lu ', 'Jian ', 'Tuo ', 'Ying ', 'Yu ', 'Lai ', 'Long ', 'Shinshi ', 'Lian ', 'Lan ', 'Qian ', 'Yue ', 'Zhong ', 'Qu ', 'Lian ', 'Bian ', 'Duan ', 'Zuan ', 'Li ', 'Si ', 'Luo ', 'Ying ', 'Yue ', 'Zhuo ', 'Xu ', 'Mi ', 'Di ', 'Fan ', 'Shen ', 'Zhe ', 'Shen ', 'Nu ', 'Xie ', 'Lei ', 'Xian ', 'Zi ', 'Ni ', 'Cun ', '[?] ', 'Qian ', 'Kume ', 'Bi ', 'Ban ', 'Wu ', 'Sha ', 'Kang ', 'Rou ', 'Fen ', 'Bi ', 'Cui ', '[?] ', 'Li ', 'Chi ', 'Nukamiso ', 'Ro ', 'Ba ', 'Li ', 'Gan ', 'Ju ', 'Po ', 'Mo ', 'Cu ', 'Nian ', 'Zhou ', 'Li ', 'Su ', 'Tiao ', 'Li ', 'Qi ', 'Su ', 'Hong ', 'Tong ', 'Zi ', 'Ce ', 'Yue ', 'Zhou ', 'Lin ', 'Zhuang ', 'Bai ', '[?] ', 'Fen ', 'Ji ', '[?] ', 'Sukumo ', 'Liang ', 'Xian ', 'Fu ', 'Liang ', 'Can ', 'Geng ', 'Li ', 'Yue ', 'Lu ', 'Ju ', 'Qi ', 'Cui ', 'Bai ', 'Zhang ', 'Lin ', 'Zong ', 'Jing ', 'Guo ', 'Kouji ', 'San ', 'San ', 'Tang ', 'Bian ', 'Rou ', 'Mian ', 'Hou ', 'Xu ', 'Zong ', 'Hu ', 'Jian ', 'Zan ', 'Ci ', 'Li ', 'Xie ', 'Fu ', 'Ni ', 'Bei ', 'Gu ', 'Xiu ', 'Gao ', 'Tang ', 'Qiu ', 'Sukumo ', 'Cao ', 'Zhuang ', 'Tang ', 'Mi ', 'San ', 'Fen ', 'Zao ', 'Kang ', 'Jiang ', 'Mo ', 'San ', 'San ', 'Nuo ', 'Xi ', 'Liang ', 'Jiang ', 'Kuai ', 'Bo ', 'Huan ', '[?] ', 'Zong ', 'Xian ', 'Nuo ', 'Tuan ', 'Nie ', 'Li ', 'Zuo ', 'Di ', 'Nie ', 'Tiao ', 'Lan ', 'Mi ', 'Jiao ', 'Jiu ', 'Xi ', 'Gong ', 'Zheng ', 'Jiu ', 'You ']

Documentation des variables

◆ return

return[ 'Ze ', 'Xi ', 'Guo ', 'Yi ', 'Hu ', 'Chan ', 'Kou ', 'Cu ', 'Ping ', 'Chou ', 'Ji ', 'Gui ', 'Su ', 'Lou ', 'Zha ', 'Lu ', 'Nian ', 'Suo ', 'Cuan ', 'Sasara ', 'Suo ', 'Le ', 'Duan ', 'Yana ', 'Xiao ', 'Bo ', 'Mi ', 'Si ', 'Dang ', 'Liao ', 'Dan ', 'Dian ', 'Fu ', 'Jian ', 'Min ', 'Kui ', 'Dai ', 'Qiao ', 'Deng ', 'Huang ', 'Sun ', 'Lao ', 'Zan ', 'Xiao ', 'Du ', 'Shi ', 'Zan ', '[?] ', 'Pai ', 'Hata ', 'Pai ', 'Gan ', 'Ju ', 'Du ', 'Lu ', 'Yan ', 'Bo ', 'Dang ', 'Sai ', 'Ke ', 'Long ', 'Qian ', 'Lian ', 'Bo ', 'Zhou ', 'Lai ', '[?] ', 'Lan ', 'Kui ', 'Yu ', 'Yue ', 'Hao ', 'Zhen ', 'Tai ', 'Ti ', 'Mi ', 'Chou ', 'Ji ', '[?] ', 'Hata ', 'Teng ', 'Zhuan ', 'Zhou ', 'Fan ', 'Sou ', 'Zhou ', 'Kuji ', 'Zhuo ', 'Teng ', 'Lu ', 'Lu ', 'Jian ', 'Tuo ', 'Ying ', 'Yu ', 'Lai ', 'Long ', 'Shinshi ', 'Lian ', 'Lan ', 'Qian ', 'Yue ', 'Zhong ', 'Qu ', 'Lian ', 'Bian ', 'Duan ', 'Zuan ', 'Li ', 'Si ', 'Luo ', 'Ying ', 'Yue ', 'Zhuo ', 'Xu ', 'Mi ', 'Di ', 'Fan ', 'Shen ', 'Zhe ', 'Shen ', 'Nu ', 'Xie ', 'Lei ', 'Xian ', 'Zi ', 'Ni ', 'Cun ', '[?] ', 'Qian ', 'Kume ', 'Bi ', 'Ban ', 'Wu ', 'Sha ', 'Kang ', 'Rou ', 'Fen ', 'Bi ', 'Cui ', '[?] ', 'Li ', 'Chi ', 'Nukamiso ', 'Ro ', 'Ba ', 'Li ', 'Gan ', 'Ju ', 'Po ', 'Mo ', 'Cu ', 'Nian ', 'Zhou ', 'Li ', 'Su ', 'Tiao ', 'Li ', 'Qi ', 'Su ', 'Hong ', 'Tong ', 'Zi ', 'Ce ', 'Yue ', 'Zhou ', 'Lin ', 'Zhuang ', 'Bai ', '[?] ', 'Fen ', 'Ji ', '[?] ', 'Sukumo ', 'Liang ', 'Xian ', 'Fu ', 'Liang ', 'Can ', 'Geng ', 'Li ', 'Yue ', 'Lu ', 'Ju ', 'Qi ', 'Cui ', 'Bai ', 'Zhang ', 'Lin ', 'Zong ', 'Jing ', 'Guo ', 'Kouji ', 'San ', 'San ', 'Tang ', 'Bian ', 'Rou ', 'Mian ', 'Hou ', 'Xu ', 'Zong ', 'Hu ', 'Jian ', 'Zan ', 'Ci ', 'Li ', 'Xie ', 'Fu ', 'Ni ', 'Bei ', 'Gu ', 'Xiu ', 'Gao ', 'Tang ', 'Qiu ', 'Sukumo ', 'Cao ', 'Zhuang ', 'Tang ', 'Mi ', 'San ', 'Fen ', 'Zao ', 'Kang ', 'Jiang ', 'Mo ', 'San ', 'San ', 'Nuo ', 'Xi ', 'Liang ', 'Jiang ', 'Kuai ', 'Bo ', 'Huan ', '[?] ', 'Zong ', 'Xian ', 'Nuo ', 'Tuan ', 'Nie ', 'Li ', 'Zuo ', 'Di ', 'Nie ', 'Tiao ', 'Lan ', 'Mi ', 'Jiao ', 'Jiu ', 'Xi ', 'Gong ', 'Zheng ', 'Jiu ', 'You ']


Joomla CMS: Référence du fichier Sha512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Hmac
Structures de données | Espaces de nommage
Référence du fichier Hmac/Sha512.php

Structures de données

class Sha512

Espaces de nommage

Lcobucci\JWT\Signer\Hmac


Joomla CMS: Référence du fichier Stub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier symfony/var-dumper/Cloner/Stub.php

Structures de données

class Stub

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier User.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Service
  • Provider
Structures de données | Espaces de nommage
Référence du fichier Service/Provider/User.php

Structures de données

class User

Espaces de nommage

Joomla\CMS\Service\Provider


Joomla CMS: Référence du fichier SingleCommandApplication.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
Structures de données | Espaces de nommage
Référence du fichier SingleCommandApplication.php

Structures de données

class SingleCommandApplication

Espaces de nommage

Symfony\Component\Console


Joomla CMS: Référence du fichier SingleMetadata.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier SingleMetadata.php

Structures de données

class SingleMetadata

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier x06a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06a.php

Variables

return ['Di ', 'Zhuang ', 'Le ', 'Lang ', 'Chen ', 'Cong ', 'Li ', 'Xiu ', 'Qing ', 'Shuang ', 'Fan ', 'Tong ', 'Guan ', 'Ji ', 'Suo ', 'Lei ', 'Lu ', 'Liang ', 'Mi ', 'Lou ', 'Chao ', 'Su ', 'Ke ', 'Shu ', 'Tang ', 'Biao ', 'Lu ', 'Jiu ', 'Shu ', 'Zha ', 'Shu ', 'Zhang ', 'Men ', 'Mo ', 'Niao ', 'Yang ', 'Tiao ', 'Peng ', 'Zhu ', 'Sha ', 'Xi ', 'Quan ', 'Heng ', 'Jian ', 'Cong ', '[?] ', 'Hokuso ', 'Qiang ', 'Tara ', 'Ying ', 'Er ', 'Xin ', 'Zhi ', 'Qiao ', 'Zui ', 'Cong ', 'Pu ', 'Shu ', 'Hua ', 'Kui ', 'Zhen ', 'Zun ', 'Yue ', 'Zhan ', 'Xi ', 'Xun ', 'Dian ', 'Fa ', 'Gan ', 'Mo ', 'Wu ', 'Qiao ', 'Nao ', 'Lin ', 'Liu ', 'Qiao ', 'Xian ', 'Run ', 'Fan ', 'Zhan ', 'Tuo ', 'Lao ', 'Yun ', 'Shun ', 'Tui ', 'Cheng ', 'Tang ', 'Meng ', 'Ju ', 'Cheng ', 'Su ', 'Jue ', 'Jue ', 'Tan ', 'Hui ', 'Ji ', 'Nuo ', 'Xiang ', 'Tuo ', 'Ning ', 'Rui ', 'Zhu ', 'Chuang ', 'Zeng ', 'Fen ', 'Qiong ', 'Ran ', 'Heng ', 'Cen ', 'Gu ', 'Liu ', 'Lao ', 'Gao ', 'Chu ', 'Zusa ', 'Nude ', 'Ca ', 'San ', 'Ji ', 'Dou ', 'Shou ', 'Lu ', '[?] ', '[?] ', 'Yuan ', 'Ta ', 'Shu ', 'Jiang ', 'Tan ', 'Lin ', 'Nong ', 'Yin ', 'Xi ', 'Sui ', 'Shan ', 'Zui ', 'Xuan ', 'Cheng ', 'Gan ', 'Ju ', 'Zui ', 'Yi ', 'Qin ', 'Pu ', 'Yan ', 'Lei ', 'Feng ', 'Hui ', 'Dang ', 'Ji ', 'Sui ', 'Bo ', 'Bi ', 'Ding ', 'Chu ', 'Zhua ', 'Kuai ', 'Ji ', 'Jie ', 'Jia ', 'Qing ', 'Zhe ', 'Jian ', 'Qiang ', 'Dao ', 'Yi ', 'Biao ', 'Song ', 'She ', 'Lin ', 'Kunugi ', 'Cha ', 'Meng ', 'Yin ', 'Tao ', 'Tai ', 'Mian ', 'Qi ', 'Toan ', 'Bin ', 'Huo ', 'Ji ', 'Qian ', 'Mi ', 'Ning ', 'Yi ', 'Gao ', 'Jian ', 'Yin ', 'Er ', 'Qing ', 'Yan ', 'Qi ', 'Mi ', 'Zhao ', 'Gui ', 'Chun ', 'Ji ', 'Kui ', 'Po ', 'Deng ', 'Chu ', '[?] ', 'Mian ', 'You ', 'Zhi ', 'Guang ', 'Qian ', 'Lei ', 'Lei ', 'Sa ', 'Lu ', 'Li ', 'Cuan ', 'Lu ', 'Mie ', 'Hui ', 'Ou ', 'Lu ', 'Jie ', 'Gao ', 'Du ', 'Yuan ', 'Li ', 'Fei ', 'Zhuo ', 'Sou ', 'Lian ', 'Tamo ', 'Chu ', '[?] ', 'Zhu ', 'Lu ', 'Yan ', 'Li ', 'Zhu ', 'Chen ', 'Jie ', 'E ', 'Su ', 'Huai ', 'Nie ', 'Yu ', 'Long ', 'Lai ', '[?] ', 'Xian ', 'Kwi ', 'Ju ', 'Xiao ', 'Ling ', 'Ying ', 'Jian ', 'Yin ', 'You ', 'Ying ']

Documentation des variables

◆ return

return[ 'Di ', 'Zhuang ', 'Le ', 'Lang ', 'Chen ', 'Cong ', 'Li ', 'Xiu ', 'Qing ', 'Shuang ', 'Fan ', 'Tong ', 'Guan ', 'Ji ', 'Suo ', 'Lei ', 'Lu ', 'Liang ', 'Mi ', 'Lou ', 'Chao ', 'Su ', 'Ke ', 'Shu ', 'Tang ', 'Biao ', 'Lu ', 'Jiu ', 'Shu ', 'Zha ', 'Shu ', 'Zhang ', 'Men ', 'Mo ', 'Niao ', 'Yang ', 'Tiao ', 'Peng ', 'Zhu ', 'Sha ', 'Xi ', 'Quan ', 'Heng ', 'Jian ', 'Cong ', '[?] ', 'Hokuso ', 'Qiang ', 'Tara ', 'Ying ', 'Er ', 'Xin ', 'Zhi ', 'Qiao ', 'Zui ', 'Cong ', 'Pu ', 'Shu ', 'Hua ', 'Kui ', 'Zhen ', 'Zun ', 'Yue ', 'Zhan ', 'Xi ', 'Xun ', 'Dian ', 'Fa ', 'Gan ', 'Mo ', 'Wu ', 'Qiao ', 'Nao ', 'Lin ', 'Liu ', 'Qiao ', 'Xian ', 'Run ', 'Fan ', 'Zhan ', 'Tuo ', 'Lao ', 'Yun ', 'Shun ', 'Tui ', 'Cheng ', 'Tang ', 'Meng ', 'Ju ', 'Cheng ', 'Su ', 'Jue ', 'Jue ', 'Tan ', 'Hui ', 'Ji ', 'Nuo ', 'Xiang ', 'Tuo ', 'Ning ', 'Rui ', 'Zhu ', 'Chuang ', 'Zeng ', 'Fen ', 'Qiong ', 'Ran ', 'Heng ', 'Cen ', 'Gu ', 'Liu ', 'Lao ', 'Gao ', 'Chu ', 'Zusa ', 'Nude ', 'Ca ', 'San ', 'Ji ', 'Dou ', 'Shou ', 'Lu ', '[?] ', '[?] ', 'Yuan ', 'Ta ', 'Shu ', 'Jiang ', 'Tan ', 'Lin ', 'Nong ', 'Yin ', 'Xi ', 'Sui ', 'Shan ', 'Zui ', 'Xuan ', 'Cheng ', 'Gan ', 'Ju ', 'Zui ', 'Yi ', 'Qin ', 'Pu ', 'Yan ', 'Lei ', 'Feng ', 'Hui ', 'Dang ', 'Ji ', 'Sui ', 'Bo ', 'Bi ', 'Ding ', 'Chu ', 'Zhua ', 'Kuai ', 'Ji ', 'Jie ', 'Jia ', 'Qing ', 'Zhe ', 'Jian ', 'Qiang ', 'Dao ', 'Yi ', 'Biao ', 'Song ', 'She ', 'Lin ', 'Kunugi ', 'Cha ', 'Meng ', 'Yin ', 'Tao ', 'Tai ', 'Mian ', 'Qi ', 'Toan ', 'Bin ', 'Huo ', 'Ji ', 'Qian ', 'Mi ', 'Ning ', 'Yi ', 'Gao ', 'Jian ', 'Yin ', 'Er ', 'Qing ', 'Yan ', 'Qi ', 'Mi ', 'Zhao ', 'Gui ', 'Chun ', 'Ji ', 'Kui ', 'Po ', 'Deng ', 'Chu ', '[?] ', 'Mian ', 'You ', 'Zhi ', 'Guang ', 'Qian ', 'Lei ', 'Lei ', 'Sa ', 'Lu ', 'Li ', 'Cuan ', 'Lu ', 'Mie ', 'Hui ', 'Ou ', 'Lu ', 'Jie ', 'Gao ', 'Du ', 'Yuan ', 'Li ', 'Fei ', 'Zhuo ', 'Sou ', 'Lian ', 'Tamo ', 'Chu ', '[?] ', 'Zhu ', 'Lu ', 'Yan ', 'Li ', 'Zhu ', 'Chen ', 'Jie ', 'E ', 'Su ', 'Huai ', 'Nie ', 'Yu ', 'Long ', 'Lai ', '[?] ', 'Xian ', 'Kwi ', 'Ju ', 'Xiao ', 'Ling ', 'Ying ', 'Jian ', 'Yin ', 'You ', 'Ying ']


Joomla CMS: Référence du fichier x0c1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c1.php

Variables

return ['syae', 'syaeg', 'syaegg', 'syaegs', 'syaen', 'syaenj', 'syaenh', 'syaed', 'syael', 'syaelg', 'syaelm', 'syaelb', 'syaels', 'syaelt', 'syaelp', 'syaelh', 'syaem', 'syaeb', 'syaebs', 'syaes', 'syaess', 'syaeng', 'syaej', 'syaec', 'syaek', 'syaet', 'syaep', 'syaeh', 'seo', 'seog', 'seogg', 'seogs', 'seon', 'seonj', 'seonh', 'seod', 'seol', 'seolg', 'seolm', 'seolb', 'seols', 'seolt', 'seolp', 'seolh', 'seom', 'seob', 'seobs', 'seos', 'seoss', 'seong', 'seoj', 'seoc', 'seok', 'seot', 'seop', 'seoh', 'se', 'seg', 'segg', 'segs', 'sen', 'senj', 'senh', 'sed', 'sel', 'selg', 'selm', 'selb', 'sels', 'selt', 'selp', 'selh', 'sem', 'seb', 'sebs', 'ses', 'sess', 'seng', 'sej', 'sec', 'sek', 'set', 'sep', 'seh', 'syeo', 'syeog', 'syeogg', 'syeogs', 'syeon', 'syeonj', 'syeonh', 'syeod', 'syeol', 'syeolg', 'syeolm', 'syeolb', 'syeols', 'syeolt', 'syeolp', 'syeolh', 'syeom', 'syeob', 'syeobs', 'syeos', 'syeoss', 'syeong', 'syeoj', 'syeoc', 'syeok', 'syeot', 'syeop', 'syeoh', 'sye', 'syeg', 'syegg', 'syegs', 'syen', 'syenj', 'syenh', 'syed', 'syel', 'syelg', 'syelm', 'syelb', 'syels', 'syelt', 'syelp', 'syelh', 'syem', 'syeb', 'syebs', 'syes', 'syess', 'syeng', 'syej', 'syec', 'syek', 'syet', 'syep', 'syeh', 'so', 'sog', 'sogg', 'sogs', 'son', 'sonj', 'sonh', 'sod', 'sol', 'solg', 'solm', 'solb', 'sols', 'solt', 'solp', 'solh', 'som', 'sob', 'sobs', 'sos', 'soss', 'song', 'soj', 'soc', 'sok', 'sot', 'sop', 'soh', 'swa', 'swag', 'swagg', 'swags', 'swan', 'swanj', 'swanh', 'swad', 'swal', 'swalg', 'swalm', 'swalb', 'swals', 'swalt', 'swalp', 'swalh', 'swam', 'swab', 'swabs', 'swas', 'swass', 'swang', 'swaj', 'swac', 'swak', 'swat', 'swap', 'swah', 'swae', 'swaeg', 'swaegg', 'swaegs', 'swaen', 'swaenj', 'swaenh', 'swaed', 'swael', 'swaelg', 'swaelm', 'swaelb', 'swaels', 'swaelt', 'swaelp', 'swaelh', 'swaem', 'swaeb', 'swaebs', 'swaes', 'swaess', 'swaeng', 'swaej', 'swaec', 'swaek', 'swaet', 'swaep', 'swaeh', 'soe', 'soeg', 'soegg', 'soegs', 'soen', 'soenj', 'soenh', 'soed', 'soel', 'soelg', 'soelm', 'soelb', 'soels', 'soelt', 'soelp', 'soelh', 'soem', 'soeb', 'soebs', 'soes', 'soess', 'soeng', 'soej', 'soec', 'soek', 'soet', 'soep', 'soeh', 'syo', 'syog', 'syogg', 'syogs']

Documentation des variables

◆ return

return[ 'syae', 'syaeg', 'syaegg', 'syaegs', 'syaen', 'syaenj', 'syaenh', 'syaed', 'syael', 'syaelg', 'syaelm', 'syaelb', 'syaels', 'syaelt', 'syaelp', 'syaelh', 'syaem', 'syaeb', 'syaebs', 'syaes', 'syaess', 'syaeng', 'syaej', 'syaec', 'syaek', 'syaet', 'syaep', 'syaeh', 'seo', 'seog', 'seogg', 'seogs', 'seon', 'seonj', 'seonh', 'seod', 'seol', 'seolg', 'seolm', 'seolb', 'seols', 'seolt', 'seolp', 'seolh', 'seom', 'seob', 'seobs', 'seos', 'seoss', 'seong', 'seoj', 'seoc', 'seok', 'seot', 'seop', 'seoh', 'se', 'seg', 'segg', 'segs', 'sen', 'senj', 'senh', 'sed', 'sel', 'selg', 'selm', 'selb', 'sels', 'selt', 'selp', 'selh', 'sem', 'seb', 'sebs', 'ses', 'sess', 'seng', 'sej', 'sec', 'sek', 'set', 'sep', 'seh', 'syeo', 'syeog', 'syeogg', 'syeogs', 'syeon', 'syeonj', 'syeonh', 'syeod', 'syeol', 'syeolg', 'syeolm', 'syeolb', 'syeols', 'syeolt', 'syeolp', 'syeolh', 'syeom', 'syeob', 'syeobs', 'syeos', 'syeoss', 'syeong', 'syeoj', 'syeoc', 'syeok', 'syeot', 'syeop', 'syeoh', 'sye', 'syeg', 'syegg', 'syegs', 'syen', 'syenj', 'syenh', 'syed', 'syel', 'syelg', 'syelm', 'syelb', 'syels', 'syelt', 'syelp', 'syelh', 'syem', 'syeb', 'syebs', 'syes', 'syess', 'syeng', 'syej', 'syec', 'syek', 'syet', 'syep', 'syeh', 'so', 'sog', 'sogg', 'sogs', 'son', 'sonj', 'sonh', 'sod', 'sol', 'solg', 'solm', 'solb', 'sols', 'solt', 'solp', 'solh', 'som', 'sob', 'sobs', 'sos', 'soss', 'song', 'soj', 'soc', 'sok', 'sot', 'sop', 'soh', 'swa', 'swag', 'swagg', 'swags', 'swan', 'swanj', 'swanh', 'swad', 'swal', 'swalg', 'swalm', 'swalb', 'swals', 'swalt', 'swalp', 'swalh', 'swam', 'swab', 'swabs', 'swas', 'swass', 'swang', 'swaj', 'swac', 'swak', 'swat', 'swap', 'swah', 'swae', 'swaeg', 'swaegg', 'swaegs', 'swaen', 'swaenj', 'swaenh', 'swaed', 'swael', 'swaelg', 'swaelm', 'swaelb', 'swaels', 'swaelt', 'swaelp', 'swaelh', 'swaem', 'swaeb', 'swaebs', 'swaes', 'swaess', 'swaeng', 'swaej', 'swaec', 'swaek', 'swaet', 'swaep', 'swaeh', 'soe', 'soeg', 'soegg', 'soegs', 'soen', 'soenj', 'soenh', 'soed', 'soel', 'soelg', 'soelm', 'soelb', 'soels', 'soelt', 'soelp', 'soelh', 'soem', 'soeb', 'soebs', 'soes', 'soess', 'soeng', 'soej', 'soec', 'soek', 'soet', 'soep', 'soeh', 'syo', 'syog', 'syogg', 'syogs']


Joomla CMS: Référence du fichier UnsupportedDatabaseDriverException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedDatabaseDriverException.php

Structures de données

class UnsupportedDatabaseDriverException

Espaces de nommage

Joomla\Session\Exception


Joomla CMS: Référence du fichier x01e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x01e.php

Variables

return ['A', 'a', 'B', 'b', 'B', 'b', 'B', 'b', 'C', 'c', 'D', 'd', 'D', 'd', 'D', 'd', 'D', 'd', 'D', 'd', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'F', 'f', 'G', 'g', 'H', 'h', 'H', 'h', 'H', 'h', 'H', 'h', 'H', 'h', 'I', 'i', 'I', 'i', 'K', 'k', 'K', 'k', 'K', 'k', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'M', 'm', 'M', 'm', 'M', 'm', 'N', 'n', 'N', 'n', 'N', 'n', 'N', 'n', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'P', 'p', 'P', 'p', 'R', 'r', 'R', 'r', 'R', 'r', 'R', 'r', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'T', 't', 'T', 't', 'T', 't', 'T', 't', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'V', 'v', 'V', 'v', 'W', 'w', 'W', 'w', 'W', 'w', 'W', 'w', 'W', 'w', 'X', 'x', 'X', 'x', 'Y', 'y', 'Z', 'z', 'Z', 'z', 'Z', 'z', 'h', 't', 'w', 'y', 'a', 's', 's', 's', 'Ss', 'd', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'Y', 'y', 'Y', 'y', 'Y', 'y', 'Y', 'y', 'LL', 'll', 'V', 'v', 'Y', 'y']

Documentation des variables

◆ return

return[ 'A', 'a', 'B', 'b', 'B', 'b', 'B', 'b', 'C', 'c', 'D', 'd', 'D', 'd', 'D', 'd', 'D', 'd', 'D', 'd', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'F', 'f', 'G', 'g', 'H', 'h', 'H', 'h', 'H', 'h', 'H', 'h', 'H', 'h', 'I', 'i', 'I', 'i', 'K', 'k', 'K', 'k', 'K', 'k', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'M', 'm', 'M', 'm', 'M', 'm', 'N', 'n', 'N', 'n', 'N', 'n', 'N', 'n', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'P', 'p', 'P', 'p', 'R', 'r', 'R', 'r', 'R', 'r', 'R', 'r', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'T', 't', 'T', 't', 'T', 't', 'T', 't', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'V', 'v', 'V', 'v', 'W', 'w', 'W', 'w', 'W', 'w', 'W', 'w', 'W', 'w', 'X', 'x', 'X', 'x', 'Y', 'y', 'Z', 'z', 'Z', 'z', 'Z', 'z', 'h', 't', 'w', 'y', 'a', 's', 's', 's', 'Ss', 'd', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'A', 'a', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'Y', 'y', 'Y', 'y', 'Y', 'y', 'Y', 'y', 'LL', 'll', 'V', 'v', 'Y', 'y']


Joomla CMS: Référence du fichier StorageInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Storage
Structures de données | Espaces de nommage
Référence du fichier maximebf/debugbar/src/DebugBar/Storage/StorageInterface.php

Structures de données

interface StorageInterface

Espaces de nommage

DebugBar\Storage


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • joomlaupdate
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/quickicon/joomlaupdate/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ServerRequestFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier ServerRequestFactoryInterface.php

Structures de données

interface ServerRequestFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier x001.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x001.php

Variables

return ['A', 'a', 'A', 'a', 'A', 'a', 'C', 'c', 'C', 'c', 'C', 'c', 'C', 'c', 'D', 'd', 'D', 'd', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'G', 'g', 'G', 'g', 'G', 'g', 'G', 'g', 'H', 'h', 'H', 'h', 'I', 'i', 'I', 'i', 'I', 'i', 'I', 'i', 'I', 'i', 'IJ', 'ij', 'J', 'j', 'K', 'k', 'k', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'N', 'n', 'N', 'n', 'N', 'n', '\ 'n', 'ng', 'NG', 'O', 'o', 'O', 'o', 'O', 'o', 'OE', 'oe', 'R', 'r', 'R', 'r', 'R', 'r', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'T', 't', 'T', 't', 'T', 't', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'W', 'w', 'Y', 'y', 'Y', 'Z', 'z', 'Z', 'z', 'Z', 'z', 's', 'b', 'B', 'B', 'b', '6', '6', 'O', 'C', 'c', 'D', 'D', 'D', 'd', 'd', '3', '@', 'E', 'F', 'f', 'G', 'G', 'hv', 'I', 'I', 'K', 'k', 'l', 'l', 'W', 'N', 'n', 'O', 'O', 'o', 'OI', 'oi', 'P', 'p', 'YR', '2', '2', 'SH', 'sh', 't', 'T', 't', 'T', 'U', 'u', 'Y', 'V', 'Y', 'y', 'Z', 'z', 'ZH', 'ZH', 'zh', 'zh', '2', '5', '5', 'ts', 'w', '|', '||', '|=', '!', 'DZ', 'Dz', 'dz', 'LJ', 'Lj', 'lj', 'NJ', 'Nj', 'nj', 'A', 'a', 'I', 'i', 'O', 'o', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', '@', 'A', 'a', 'A', 'a', 'AE', 'ae', 'G', 'g', 'G', 'g', 'K', 'k', 'O', 'o', 'O', 'o', 'ZH', 'zh', 'j', 'DZ', 'Dz', 'dz', 'G', 'g', 'HV', 'W', 'N', 'n', 'A', 'a', 'AE', 'ae', 'O', 'o']

Documentation des variables

◆ return

return[ 'A', 'a', 'A', 'a', 'A', 'a', 'C', 'c', 'C', 'c', 'C', 'c', 'C', 'c', 'D', 'd', 'D', 'd', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'E', 'e', 'G', 'g', 'G', 'g', 'G', 'g', 'G', 'g', 'H', 'h', 'H', 'h', 'I', 'i', 'I', 'i', 'I', 'i', 'I', 'i', 'I', 'i', 'IJ', 'ij', 'J', 'j', 'K', 'k', 'k', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'L', 'l', 'N', 'n', 'N', 'n', 'N', 'n', '\ 'n', 'ng', 'NG', 'O', 'o', 'O', 'o', 'O', 'o', 'OE', 'oe', 'R', 'r', 'R', 'r', 'R', 'r', 'S', 's', 'S', 's', 'S', 's', 'S', 's', 'T', 't', 'T', 't', 'T', 't', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'W', 'w', 'Y', 'y', 'Y', 'Z', 'z', 'Z', 'z', 'Z', 'z', 's', 'b', 'B', 'B', 'b', '6', '6', 'O', 'C', 'c', 'D', 'D', 'D', 'd', 'd', '3', '@', 'E', 'F', 'f', 'G', 'G', 'hv', 'I', 'I', 'K', 'k', 'l', 'l', 'W', 'N', 'n', 'O', 'O', 'o', 'OI', 'oi', 'P', 'p', 'YR', '2', '2', 'SH', 'sh', 't', 'T', 't', 'T', 'U', 'u', 'Y', 'V', 'Y', 'y', 'Z', 'z', 'ZH', 'ZH', 'zh', 'zh', '2', '5', '5', 'ts', 'w', '|', '||', '|=', '!', 'DZ', 'Dz', 'dz', 'LJ', 'Lj', 'lj', 'NJ', 'Nj', 'nj', 'A', 'a', 'I', 'i', 'O', 'o', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', 'U', 'u', '@', 'A', 'a', 'A', 'a', 'AE', 'ae', 'G', 'g', 'G', 'g', 'K', 'k', 'O', 'o', 'O', 'o', 'ZH', 'zh', 'j', 'DZ', 'Dz', 'dz', 'G', 'g', 'HV', 'W', 'N', 'n', 'A', 'a', 'AE', 'ae', 'O', 'o']


Joomla CMS: Référence du fichier RequestFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier RequestFactoryInterface.php

Structures de données

interface RequestFactoryInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier SiteStatus.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • sitestatus
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier SiteStatus.php

Structures de données

class SiteStatus

Espaces de nommage

Joomla\Plugins
Joomla\Plugin\Task\SiteStatus\Extension


Joomla CMS: Référence du fichier Webauthn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier system/webauthn/src/Extension/Webauthn.php

Structures de données

class Webauthn

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\Extension


Joomla CMS: Référence du fichier Serializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature
  • Serializer
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature/Serializer/Serializer.php

Structures de données

class Serializer

Espaces de nommage

Jose\Component\Signature\Serializer


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • task
  • checkfiles
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/task/checkfiles/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SearchModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier SearchModel.php

Structures de données

class SearchModel

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Model


Joomla CMS: Référence du fichier RSASSA_PSS_params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RSASSA_PSS_params.php

Structures de données

class RSASSA_PSS_params

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_banners
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_banners/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Banners\Site\Service


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • versionable
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/behaviour/versionable/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier prime239v2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime239v2.php

Structures de données

class prime239v2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier Russian.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Russian.php

Structures de données

class Russian

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier TextResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier TextResponse.php

Structures de données

class TextResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier PluginController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_plugins/src/Controller/PluginController.php

Structures de données

class PluginController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Controller


Joomla CMS: Référence du fichier TypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier com_fields/src/Field/TypeField.php

Structures de données

class TypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier UpdateOperation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Adapter
  • ExtLdap
Structures de données | Espaces de nommage
Référence du fichier UpdateOperation.php

Structures de données

class UpdateOperation

Espaces de nommage

Symfony\Component\Ldap\Adapter\ExtLdap


Joomla CMS: Référence du fichier PluginsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PluginsHelper.php

Structures de données

class PluginsHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Helper


Joomla CMS: Référence du fichier TwigProfileCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier TwigProfileCollector.php

Structures de données

class TwigProfileCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier x0fe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0fe.php

Variables

return ['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '~', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '..', '--', '-', '_', '_', '(', ') ', '{', '} ', '[', '] ', '[(', ')] ', '<<', '>> ', '<', '> ', '[', '] ', '{', '}', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', ',', ',', '.', '', ';', ':', '?', '!', '-', '(', ')', '{', '}', '{', '}', '#', '&', ' *', '+', '-', '<', '>', '=', '', '\\', '$', '%', '@', '[?]', '[?]', '[?]', '[?]', '', '', '', '[?]', '', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '~', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '..', '--', '-', '_', '_', '(', ') ', '{', '} ', '[', '] ', '[(', ')] ', '<<', '>> ', '<', '> ', '[', '] ', '{', '}', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', ',', ',', '.', '', ';', ':', '?', '!', '-', '(', ')', '{', '}', '{', '}', '#', '&', ' *', '+', '-', '<', '>', '=', '', '\\', '$', '%', '@', '[?]', '[?]', '[?]', '[?]', '', '', '', '[?]', '', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '']


Joomla CMS: Référence du fichier WebAssetItemInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAssetItemInterface.php

Structures de données

interface WebAssetItemInterface

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • helpers
Structures de données | Espaces de nommage
Référence du fichier com_finder/helpers/route.php

Structures de données

class FinderHelperRoute

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier TimeDataCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier TimeDataCollector.php

Structures de données

class TimeDataCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier x0c4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c4.php

Variables

return ['sswals', 'sswalt', 'sswalp', 'sswalh', 'sswam', 'sswab', 'sswabs', 'sswas', 'sswass', 'sswang', 'sswaj', 'sswac', 'sswak', 'sswat', 'sswap', 'sswah', 'sswae', 'sswaeg', 'sswaegg', 'sswaegs', 'sswaen', 'sswaenj', 'sswaenh', 'sswaed', 'sswael', 'sswaelg', 'sswaelm', 'sswaelb', 'sswaels', 'sswaelt', 'sswaelp', 'sswaelh', 'sswaem', 'sswaeb', 'sswaebs', 'sswaes', 'sswaess', 'sswaeng', 'sswaej', 'sswaec', 'sswaek', 'sswaet', 'sswaep', 'sswaeh', 'ssoe', 'ssoeg', 'ssoegg', 'ssoegs', 'ssoen', 'ssoenj', 'ssoenh', 'ssoed', 'ssoel', 'ssoelg', 'ssoelm', 'ssoelb', 'ssoels', 'ssoelt', 'ssoelp', 'ssoelh', 'ssoem', 'ssoeb', 'ssoebs', 'ssoes', 'ssoess', 'ssoeng', 'ssoej', 'ssoec', 'ssoek', 'ssoet', 'ssoep', 'ssoeh', 'ssyo', 'ssyog', 'ssyogg', 'ssyogs', 'ssyon', 'ssyonj', 'ssyonh', 'ssyod', 'ssyol', 'ssyolg', 'ssyolm', 'ssyolb', 'ssyols', 'ssyolt', 'ssyolp', 'ssyolh', 'ssyom', 'ssyob', 'ssyobs', 'ssyos', 'ssyoss', 'ssyong', 'ssyoj', 'ssyoc', 'ssyok', 'ssyot', 'ssyop', 'ssyoh', 'ssu', 'ssug', 'ssugg', 'ssugs', 'ssun', 'ssunj', 'ssunh', 'ssud', 'ssul', 'ssulg', 'ssulm', 'ssulb', 'ssuls', 'ssult', 'ssulp', 'ssulh', 'ssum', 'ssub', 'ssubs', 'ssus', 'ssuss', 'ssung', 'ssuj', 'ssuc', 'ssuk', 'ssut', 'ssup', 'ssuh', 'ssweo', 'ssweog', 'ssweogg', 'ssweogs', 'ssweon', 'ssweonj', 'ssweonh', 'ssweod', 'ssweol', 'ssweolg', 'ssweolm', 'ssweolb', 'ssweols', 'ssweolt', 'ssweolp', 'ssweolh', 'ssweom', 'ssweob', 'ssweobs', 'ssweos', 'ssweoss', 'ssweong', 'ssweoj', 'ssweoc', 'ssweok', 'ssweot', 'ssweop', 'ssweoh', 'sswe', 'ssweg', 'sswegg', 'sswegs', 'sswen', 'sswenj', 'sswenh', 'sswed', 'sswel', 'sswelg', 'sswelm', 'sswelb', 'sswels', 'sswelt', 'sswelp', 'sswelh', 'sswem', 'ssweb', 'sswebs', 'sswes', 'sswess', 'ssweng', 'sswej', 'sswec', 'sswek', 'sswet', 'sswep', 'ssweh', 'sswi', 'sswig', 'sswigg', 'sswigs', 'sswin', 'sswinj', 'sswinh', 'sswid', 'sswil', 'sswilg', 'sswilm', 'sswilb', 'sswils', 'sswilt', 'sswilp', 'sswilh', 'sswim', 'sswib', 'sswibs', 'sswis', 'sswiss', 'sswing', 'sswij', 'sswic', 'sswik', 'sswit', 'sswip', 'sswih', 'ssyu', 'ssyug', 'ssyugg', 'ssyugs', 'ssyun', 'ssyunj', 'ssyunh', 'ssyud', 'ssyul', 'ssyulg', 'ssyulm', 'ssyulb', 'ssyuls', 'ssyult', 'ssyulp', 'ssyulh', 'ssyum', 'ssyub', 'ssyubs', 'ssyus', 'ssyuss', 'ssyung', 'ssyuj', 'ssyuc', 'ssyuk', 'ssyut', 'ssyup', 'ssyuh', 'sseu', 'sseug', 'sseugg', 'sseugs', 'sseun', 'sseunj', 'sseunh', 'sseud', 'sseul', 'sseulg', 'sseulm', 'sseulb', 'sseuls', 'sseult', 'sseulp', 'sseulh']

Documentation des variables

◆ return

return[ 'sswals', 'sswalt', 'sswalp', 'sswalh', 'sswam', 'sswab', 'sswabs', 'sswas', 'sswass', 'sswang', 'sswaj', 'sswac', 'sswak', 'sswat', 'sswap', 'sswah', 'sswae', 'sswaeg', 'sswaegg', 'sswaegs', 'sswaen', 'sswaenj', 'sswaenh', 'sswaed', 'sswael', 'sswaelg', 'sswaelm', 'sswaelb', 'sswaels', 'sswaelt', 'sswaelp', 'sswaelh', 'sswaem', 'sswaeb', 'sswaebs', 'sswaes', 'sswaess', 'sswaeng', 'sswaej', 'sswaec', 'sswaek', 'sswaet', 'sswaep', 'sswaeh', 'ssoe', 'ssoeg', 'ssoegg', 'ssoegs', 'ssoen', 'ssoenj', 'ssoenh', 'ssoed', 'ssoel', 'ssoelg', 'ssoelm', 'ssoelb', 'ssoels', 'ssoelt', 'ssoelp', 'ssoelh', 'ssoem', 'ssoeb', 'ssoebs', 'ssoes', 'ssoess', 'ssoeng', 'ssoej', 'ssoec', 'ssoek', 'ssoet', 'ssoep', 'ssoeh', 'ssyo', 'ssyog', 'ssyogg', 'ssyogs', 'ssyon', 'ssyonj', 'ssyonh', 'ssyod', 'ssyol', 'ssyolg', 'ssyolm', 'ssyolb', 'ssyols', 'ssyolt', 'ssyolp', 'ssyolh', 'ssyom', 'ssyob', 'ssyobs', 'ssyos', 'ssyoss', 'ssyong', 'ssyoj', 'ssyoc', 'ssyok', 'ssyot', 'ssyop', 'ssyoh', 'ssu', 'ssug', 'ssugg', 'ssugs', 'ssun', 'ssunj', 'ssunh', 'ssud', 'ssul', 'ssulg', 'ssulm', 'ssulb', 'ssuls', 'ssult', 'ssulp', 'ssulh', 'ssum', 'ssub', 'ssubs', 'ssus', 'ssuss', 'ssung', 'ssuj', 'ssuc', 'ssuk', 'ssut', 'ssup', 'ssuh', 'ssweo', 'ssweog', 'ssweogg', 'ssweogs', 'ssweon', 'ssweonj', 'ssweonh', 'ssweod', 'ssweol', 'ssweolg', 'ssweolm', 'ssweolb', 'ssweols', 'ssweolt', 'ssweolp', 'ssweolh', 'ssweom', 'ssweob', 'ssweobs', 'ssweos', 'ssweoss', 'ssweong', 'ssweoj', 'ssweoc', 'ssweok', 'ssweot', 'ssweop', 'ssweoh', 'sswe', 'ssweg', 'sswegg', 'sswegs', 'sswen', 'sswenj', 'sswenh', 'sswed', 'sswel', 'sswelg', 'sswelm', 'sswelb', 'sswels', 'sswelt', 'sswelp', 'sswelh', 'sswem', 'ssweb', 'sswebs', 'sswes', 'sswess', 'ssweng', 'sswej', 'sswec', 'sswek', 'sswet', 'sswep', 'ssweh', 'sswi', 'sswig', 'sswigg', 'sswigs', 'sswin', 'sswinj', 'sswinh', 'sswid', 'sswil', 'sswilg', 'sswilm', 'sswilb', 'sswils', 'sswilt', 'sswilp', 'sswilh', 'sswim', 'sswib', 'sswibs', 'sswis', 'sswiss', 'sswing', 'sswij', 'sswic', 'sswik', 'sswit', 'sswip', 'sswih', 'ssyu', 'ssyug', 'ssyugg', 'ssyugs', 'ssyun', 'ssyunj', 'ssyunh', 'ssyud', 'ssyul', 'ssyulg', 'ssyulm', 'ssyulb', 'ssyuls', 'ssyult', 'ssyulp', 'ssyulh', 'ssyum', 'ssyub', 'ssyubs', 'ssyus', 'ssyuss', 'ssyung', 'ssyuj', 'ssyuc', 'ssyuk', 'ssyut', 'ssyup', 'ssyuh', 'sseu', 'sseug', 'sseugg', 'sseugs', 'sseun', 'sseunj', 'sseunh', 'sseud', 'sseul', 'sseulg', 'sseulm', 'sseulb', 'sseuls', 'sseult', 'sseulp', 'sseulh']


Joomla CMS: Référence du fichier P1p1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core32/Curve25519/Ge/P1p1.php

Structures de données

class ParagonIE_Sodium_Core32_Curve25519_Ge_P1p1


Joomla CMS: Référence du fichier PgSqlCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier PgSqlCaster.php

Structures de données

class PgSqlCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier TimeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TimeField.php

Structures de données

class TimeField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier UnsupportedArchiveException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • archive
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedArchiveException.php

Structures de données

class UnsupportedArchiveException

Espaces de nommage

Joomla\Archive\Exception


Joomla CMS: Référence du fichier PolicyQualifierInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PolicyQualifierInfo.php

Structures de données

class PolicyQualifierInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier ValidatorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier ValidatorInterface.php

Structures de données

interface ValidatorInterface

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_modules/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Precomp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core/Curve25519/Ge/Precomp.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Ge_Precomp


Joomla CMS: Référence du fichier StyleModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StyleModel.php

Structures de données

class StyleModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Model


Joomla CMS: Référence du fichier x00b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x00b.php

Variables

return ['[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', '[?]', 'e', 'ai', '[?]', '[?]', 'o', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', '[?]', 'l', 'll', '[?]', '', 'sh', 'ss', 's', 'h', '[?]', '[?]', '\'', '\'', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', '[?]', '[?]', 'e', 'ai', '[?]', '[?]', 'o', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', 'rr', 'rh', '[?]', 'yy', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', '[?]', '[?]', '[?]', 'ng', 'c', '[?]', 'j', '[?]', 'ny', 'tt', '[?]', '[?]', '[?]', 'nn', 't', '[?]', '[?]', '[?]', 'n', 'nnn', 'p', '[?]', '[?]', '[?]', 'm', 'y', 'r', 'rr', 'l', 'll', 'lll', 'v', '[?]', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '+10+', '+100+', '+1000+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', 'N', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', 'R', 'L', '[?]', '[?]', 'e', 'ai', '[?]', '[?]', 'o', 'au', 'k', 'kh', 'g', 'gh', 'ng', 'c', 'ch', 'j', 'jh', 'ny', 'tt', 'tth', 'dd', 'ddh', 'nn', 't', 'th', 'd', 'dh', 'n', '[?]', 'p', 'ph', 'b', 'bh', 'm', 'y', 'r', '[?]', 'l', 'll', '[?]', '', 'sh', 'ss', 's', 'h', '[?]', '[?]', '\'', '\'', 'aa', 'i', 'ii', 'u', 'uu', 'R', '[?]', '[?]', '[?]', 'e', 'ai', '[?]', '[?]', 'o', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '+', '[?]', '[?]', '[?]', '[?]', 'rr', 'rh', '[?]', 'yy', 'RR', 'LL', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', 'N', 'H', '[?]', 'a', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', 'k', '[?]', '[?]', '[?]', 'ng', 'c', '[?]', 'j', '[?]', 'ny', 'tt', '[?]', '[?]', '[?]', 'nn', 't', '[?]', '[?]', '[?]', 'n', 'nnn', 'p', '[?]', '[?]', '[?]', 'm', 'y', 'r', 'rr', 'l', 'll', 'lll', 'v', '[?]', 'ss', 's', 'h', '[?]', '[?]', '[?]', '[?]', 'aa', 'i', 'ii', 'u', 'uu', '[?]', '[?]', '[?]', 'e', 'ee', 'ai', '[?]', 'o', 'oo', 'au', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '+10+', '+100+', '+1000+', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier Pagination.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Pagination
Structures de données | Espaces de nommage
Référence du fichier Pagination.php

Structures de données

class Pagination

Espaces de nommage

Joomla\CMS\Pagination


Joomla CMS: Référence du fichier RequestInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier RequestInterface.php

Structures de données

interface RequestInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier TBSCertList.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier TBSCertList.php

Structures de données

class TBSCertList

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier secp224k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp224k1.php

Structures de données

class secp224k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier SubjectDirectoryAttributes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier SubjectDirectoryAttributes.php

Structures de données

class SubjectDirectoryAttributes

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier pagebreak.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagebreak
Structures de données | Espaces de nommage
Référence du fichier plugins/content/pagebreak/pagebreak.php

Structures de données

class PlgContentPagebreak

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/File/ASN1/Maps/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier RuntimeStorage.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Storage
Structures de données | Espaces de nommage
Référence du fichier RuntimeStorage.php

Structures de données

class RuntimeStorage

Espaces de nommage

Joomla\Session\Storage


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Http/Response.php

Structures de données

class Response

Espaces de nommage

Joomla\CMS\Http


Joomla CMS: Référence du fichier x0d7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d7.php

Variables

return ['hwen', 'hwenj', 'hwenh', 'hwed', 'hwel', 'hwelg', 'hwelm', 'hwelb', 'hwels', 'hwelt', 'hwelp', 'hwelh', 'hwem', 'hweb', 'hwebs', 'hwes', 'hwess', 'hweng', 'hwej', 'hwec', 'hwek', 'hwet', 'hwep', 'hweh', 'hwi', 'hwig', 'hwigg', 'hwigs', 'hwin', 'hwinj', 'hwinh', 'hwid', 'hwil', 'hwilg', 'hwilm', 'hwilb', 'hwils', 'hwilt', 'hwilp', 'hwilh', 'hwim', 'hwib', 'hwibs', 'hwis', 'hwiss', 'hwing', 'hwij', 'hwic', 'hwik', 'hwit', 'hwip', 'hwih', 'hyu', 'hyug', 'hyugg', 'hyugs', 'hyun', 'hyunj', 'hyunh', 'hyud', 'hyul', 'hyulg', 'hyulm', 'hyulb', 'hyuls', 'hyult', 'hyulp', 'hyulh', 'hyum', 'hyub', 'hyubs', 'hyus', 'hyuss', 'hyung', 'hyuj', 'hyuc', 'hyuk', 'hyut', 'hyup', 'hyuh', 'heu', 'heug', 'heugg', 'heugs', 'heun', 'heunj', 'heunh', 'heud', 'heul', 'heulg', 'heulm', 'heulb', 'heuls', 'heult', 'heulp', 'heulh', 'heum', 'heub', 'heubs', 'heus', 'heuss', 'heung', 'heuj', 'heuc', 'heuk', 'heut', 'heup', 'heuh', 'hyi', 'hyig', 'hyigg', 'hyigs', 'hyin', 'hyinj', 'hyinh', 'hyid', 'hyil', 'hyilg', 'hyilm', 'hyilb', 'hyils', 'hyilt', 'hyilp', 'hyilh', 'hyim', 'hyib', 'hyibs', 'hyis', 'hyiss', 'hying', 'hyij', 'hyic', 'hyik', 'hyit', 'hyip', 'hyih', 'hi', 'hig', 'higg', 'higs', 'hin', 'hinj', 'hinh', 'hid', 'hil', 'hilg', 'hilm', 'hilb', 'hils', 'hilt', 'hilp', 'hilh', 'him', 'hib', 'hibs', 'his', 'hiss', 'hing', 'hij', 'hic', 'hik', 'hit', 'hip', 'hih', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'hwen', 'hwenj', 'hwenh', 'hwed', 'hwel', 'hwelg', 'hwelm', 'hwelb', 'hwels', 'hwelt', 'hwelp', 'hwelh', 'hwem', 'hweb', 'hwebs', 'hwes', 'hwess', 'hweng', 'hwej', 'hwec', 'hwek', 'hwet', 'hwep', 'hweh', 'hwi', 'hwig', 'hwigg', 'hwigs', 'hwin', 'hwinj', 'hwinh', 'hwid', 'hwil', 'hwilg', 'hwilm', 'hwilb', 'hwils', 'hwilt', 'hwilp', 'hwilh', 'hwim', 'hwib', 'hwibs', 'hwis', 'hwiss', 'hwing', 'hwij', 'hwic', 'hwik', 'hwit', 'hwip', 'hwih', 'hyu', 'hyug', 'hyugg', 'hyugs', 'hyun', 'hyunj', 'hyunh', 'hyud', 'hyul', 'hyulg', 'hyulm', 'hyulb', 'hyuls', 'hyult', 'hyulp', 'hyulh', 'hyum', 'hyub', 'hyubs', 'hyus', 'hyuss', 'hyung', 'hyuj', 'hyuc', 'hyuk', 'hyut', 'hyup', 'hyuh', 'heu', 'heug', 'heugg', 'heugs', 'heun', 'heunj', 'heunh', 'heud', 'heul', 'heulg', 'heulm', 'heulb', 'heuls', 'heult', 'heulp', 'heulh', 'heum', 'heub', 'heubs', 'heus', 'heuss', 'heung', 'heuj', 'heuc', 'heuk', 'heut', 'heup', 'heuh', 'hyi', 'hyig', 'hyigg', 'hyigs', 'hyin', 'hyinj', 'hyinh', 'hyid', 'hyil', 'hyilg', 'hyilm', 'hyilb', 'hyils', 'hyilt', 'hyilp', 'hyilh', 'hyim', 'hyib', 'hyibs', 'hyis', 'hyiss', 'hying', 'hyij', 'hyic', 'hyik', 'hyit', 'hyip', 'hyih', 'hi', 'hig', 'higg', 'higs', 'hin', 'hinj', 'hinh', 'hid', 'hil', 'hilg', 'hilm', 'hilb', 'hils', 'hilt', 'hilp', 'hilh', 'him', 'hib', 'hibs', 'his', 'hiss', 'hing', 'hij', 'hic', 'hik', 'hit', 'hip', 'hih', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier Replacements.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Structures de données | Espaces de nommage
Référence du fichier Replacements.php

Structures de données

class Replacements

Espaces de nommage

Laminas\ZendFrameworkBridge


Joomla CMS: Référence du fichier StylesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StylesModel.php

Structures de données

class StylesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Model


Joomla CMS: Référence du fichier SiteRouterAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier SiteRouterAwareInterface.php

Structures de données

interface SiteRouterAwareInterface

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Service


Joomla CMS: Référence du fichier RegistrationController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier RegistrationController.php

Structures de données

class RegistrationController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier SessionEvents.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier SessionEvents.php

Structures de données

class SessionEvents

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier transliterator_list.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier transliterator_list.php

Variables

return [0=> 'ASCII-Latin', 1=> 'Accents-Any', 2=> 'Amharic-Latin/BGN', 3=> 'Any-Accents', 4=> 'Any-Publishing', 5=> 'Arab-Latn', 6=> 'Arabic-Latin', 7=> 'Arabic-Latin/BGN', 8=> 'Armenian-Latin', 9=> 'Armenian-Latin/BGN', 10=> 'Armn-Latn', 11=> 'Azerbaijani-Latin/BGN', 12=> 'Belarusian-Latin/BGN', 13=> 'Beng-Arab', 14=> 'Beng-Deva', 15=> 'Beng-Gujr', 16=> 'Beng-Guru', 17=> 'Beng-Knda', 18=> 'Beng-Latn', 19=> 'Beng-Mlym', 20=> 'Beng-Orya', 21=> 'Beng-Taml', 22=> 'Beng-Telu', 23=> 'Beng-ur', 24=> 'Bengali-Arabic', 25=> 'Bengali-Devanagari', 26=> 'Bengali-Gujarati', 27=> 'Bengali-Gurmukhi', 28=> 'Bengali-Kannada', 29=> 'Bengali-Latin', 30=> 'Bengali-Malayalam', 31=> 'Bengali-Oriya', 32=> 'Bengali-Tamil', 33=> 'Bengali-Telugu', 34=> 'Bopo-Latn', 35=> 'Bopomofo-Latin', 36=> 'Bulgarian-Latin/BGN', 37=> 'Cyrillic-Latin', 38=> 'Cyrl-Latn', 39=> 'Deva-Arab', 40=> 'Deva-Beng', 41=> 'Deva-Gujr', 42=> 'Deva-Guru', 43=> 'Deva-Knda', 44=> 'Deva-Latn', 45=> 'Deva-Mlym', 46=> 'Deva-Orya', 47=> 'Deva-Taml', 48=> 'Deva-Telu', 49=> 'Deva-ur', 50=> 'Devanagari-Arabic', 51=> 'Devanagari-Bengali', 52=> 'Devanagari-Gujarati', 53=> 'Devanagari-Gurmukhi', 54=> 'Devanagari-Kannada', 55=> 'Devanagari-Latin', 56=> 'Devanagari-Malayalam', 57=> 'Devanagari-Oriya', 58=> 'Devanagari-Tamil', 59=> 'Devanagari-Telugu', 60=> 'Digit-Tone', 61=> 'Fullwidth-Halfwidth', 62=> 'Geor-Latn', 63=> 'Georgian-Latin', 64=> 'Georgian-Latin/BGN', 65=> 'Greek-Latin', 66=> 'Greek-Latin/BGN', 67=> 'Greek-Latin/UNGEGN', 68=> 'Grek-Latn', 69=> 'Grek-Latn/UNGEGN', 70=> 'Gujarati-Arabic', 71=> 'Gujarati-Bengali', 72=> 'Gujarati-Devanagari', 73=> 'Gujarati-Gurmukhi', 74=> 'Gujarati-Kannada', 75=> 'Gujarati-Latin', 76=> 'Gujarati-Malayalam', 77=> 'Gujarati-Oriya', 78=> 'Gujarati-Tamil', 79=> 'Gujarati-Telugu', 80=> 'Gujr-Arab', 81=> 'Gujr-Beng', 82=> 'Gujr-Deva', 83=> 'Gujr-Guru', 84=> 'Gujr-Knda', 85=> 'Gujr-Latn', 86=> 'Gujr-Mlym', 87=> 'Gujr-Orya', 88=> 'Gujr-Taml', 89=> 'Gujr-Telu', 90=> 'Gujr-ur', 91=> 'Gurmukhi-Arabic', 92=> 'Gurmukhi-Bengali', 93=> 'Gurmukhi-Devanagari', 94=> 'Gurmukhi-Gujarati', 95=> 'Gurmukhi-Kannada', 96=> 'Gurmukhi-Latin', 97=> 'Gurmukhi-Malayalam', 98=> 'Gurmukhi-Oriya', 99=> 'Gurmukhi-Tamil', 100=> 'Gurmukhi-Telugu', 101=> 'Guru-Arab', 102=> 'Guru-Beng', 103=> 'Guru-Deva', 104=> 'Guru-Gujr', 105=> 'Guru-Knda', 106=> 'Guru-Latn', 107=> 'Guru-Mlym', 108=> 'Guru-Orya', 109=> 'Guru-Taml', 110=> 'Guru-Telu', 111=> 'Guru-ur', 112=> 'Halfwidth-Fullwidth', 113=> 'Han-Latin', 114=> 'Han-Latin/Names', 115=> 'Hang-Latn', 116=> 'Hangul-Latin', 117=> 'Hani-Latn', 118=> 'Hans-Hant', 119=> 'Hant-Hans', 120=> 'Hebr-Latn', 121=> 'Hebrew-Latin', 122=> 'Hebrew-Latin/BGN', 123=> 'Hira-Kana', 124=> 'Hira-Latn', 125=> 'Hiragana-Katakana', 126=> 'Hiragana-Latin', 127=> 'IPA-XSampa', 128=> 'Jamo-Latin', 129=> 'Jamo-Latn', 130=> 'Kana-Hira', 131=> 'Kana-Latn', 132=> 'Kannada-Arabic', 133=> 'Kannada-Bengali', 134=> 'Kannada-Devanagari', 135=> 'Kannada-Gujarati', 136=> 'Kannada-Gurmukhi', 137=> 'Kannada-Latin', 138=> 'Kannada-Malayalam', 139=> 'Kannada-Oriya', 140=> 'Kannada-Tamil', 141=> 'Kannada-Telugu', 142=> 'Katakana-Hiragana', 143=> 'Katakana-Latin', 144=> 'Katakana-Latin/BGN', 145=> 'Kazakh-Latin/BGN', 146=> 'Kirghiz-Latin/BGN', 147=> 'Knda-Arab', 148=> 'Knda-Beng', 149=> 'Knda-Deva', 150=> 'Knda-Gujr', 151=> 'Knda-Guru', 152=> 'Knda-Latn', 153=> 'Knda-Mlym', 154=> 'Knda-Orya', 155=> 'Knda-Taml', 156=> 'Knda-Telu', 157=> 'Knda-ur', 158=> 'Korean-Latin/BGN', 159=> 'Latin-ASCII', 160=> 'Latin-Arabic', 161=> 'Latin-Armenian', 162=> 'Latin-Bengali', 163=> 'Latin-Bopomofo', 164=> 'Latin-Cyrillic', 165=> 'Latin-Devanagari', 166=> 'Latin-Georgian', 167=> 'Latin-Greek', 168=> 'Latin-Greek/UNGEGN', 169=> 'Latin-Gujarati', 170=> 'Latin-Gurmukhi', 171=> 'Latin-Hangul', 172=> 'Latin-Hebrew', 173=> 'Latin-Hiragana', 174=> 'Latin-Jamo', 175=> 'Latin-Kannada', 176=> 'Latin-Katakana', 177=> 'Latin-Malayalam', 178=> 'Latin-NumericPinyin', 179=> 'Latin-Oriya', 180=> 'Latin-Russian/BGN', 181=> 'Latin-Syriac', 182=> 'Latin-Tamil', 183=> 'Latin-Telugu', 184=> 'Latin-Thaana', 185=> 'Latin-Thai', 186=> 'Latn-Arab', 187=> 'Latn-Armn', 188=> 'Latn-Beng', 189=> 'Latn-Bopo', 190=> 'Latn-Cyrl', 191=> 'Latn-Deva', 192=> 'Latn-Geor', 193=> 'Latn-Grek', 194=> 'Latn-Grek/UNGEGN', 195=> 'Latn-Gujr', 196=> 'Latn-Guru', 197=> 'Latn-Hang', 198=> 'Latn-Hebr', 199=> 'Latn-Hira', 200=> 'Latn-Jamo', 201=> 'Latn-Kana', 202=> 'Latn-Knda', 203=> 'Latn-Mlym', 204=> 'Latn-Orya', 205=> 'Latn-Syrc', 206=> 'Latn-Taml', 207=> 'Latn-Telu', 208=> 'Latn-Thaa', 209=> 'Latn-Thai', 210=> 'Macedonian-Latin/BGN', 211=> 'Malayalam-Arabic', 212=> 'Malayalam-Bengali', 213=> 'Malayalam-Devanagari', 214=> 'Malayalam-Gujarati', 215=> 'Malayalam-Gurmukhi', 216=> 'Malayalam-Kannada', 217=> 'Malayalam-Latin', 218=> 'Malayalam-Oriya', 219=> 'Malayalam-Tamil', 220=> 'Malayalam-Telugu', 221=> 'Maldivian-Latin/BGN', 222=> 'Mlym-Arab', 223=> 'Mlym-Beng', 224=> 'Mlym-Deva', 225=> 'Mlym-Gujr', 226=> 'Mlym-Guru', 227=> 'Mlym-Knda', 228=> 'Mlym-Latn', 229=> 'Mlym-Orya', 230=> 'Mlym-Taml', 231=> 'Mlym-Telu', 232=> 'Mlym-ur', 233=> 'Mongolian-Latin/BGN', 234=> 'NumericPinyin-Latin', 235=> 'NumericPinyin-Pinyin', 236=> 'Oriya-Arabic', 237=> 'Oriya-Bengali', 238=> 'Oriya-Devanagari', 239=> 'Oriya-Gujarati', 240=> 'Oriya-Gurmukhi', 241=> 'Oriya-Kannada', 242=> 'Oriya-Latin', 243=> 'Oriya-Malayalam', 244=> 'Oriya-Tamil', 245=> 'Oriya-Telugu', 246=> 'Orya-Arab', 247=> 'Orya-Beng', 248=> 'Orya-Deva', 249=> 'Orya-Gujr', 250=> 'Orya-Guru', 251=> 'Orya-Knda', 252=> 'Orya-Latn', 253=> 'Orya-Mlym', 254=> 'Orya-Taml', 255=> 'Orya-Telu', 256=> 'Orya-ur', 257=> 'Pashto-Latin/BGN', 258=> 'Persian-Latin/BGN', 259=> 'Pinyin-NumericPinyin', 260=> 'Publishing-Any', 261=> 'Russian-Latin/BGN', 262=> 'Serbian-Latin/BGN', 263=> 'Simplified-Traditional', 264=> 'Syrc-Latn', 265=> 'Syriac-Latin', 266=> 'Tamil-Arabic', 267=> 'Tamil-Bengali', 268=> 'Tamil-Devanagari', 269=> 'Tamil-Gujarati', 270=> 'Tamil-Gurmukhi', 271=> 'Tamil-Kannada', 272=> 'Tamil-Latin', 273=> 'Tamil-Malayalam', 274=> 'Tamil-Oriya', 275=> 'Tamil-Telugu', 276=> 'Taml-Arab', 277=> 'Taml-Beng', 278=> 'Taml-Deva', 279=> 'Taml-Gujr', 280=> 'Taml-Guru', 281=> 'Taml-Knda', 282=> 'Taml-Latn', 283=> 'Taml-Mlym', 284=> 'Taml-Orya', 285=> 'Taml-Telu', 286=> 'Taml-ur', 287=> 'Telu-Arab', 288=> 'Telu-Beng', 289=> 'Telu-Deva', 290=> 'Telu-Gujr', 291=> 'Telu-Guru', 292=> 'Telu-Knda', 293=> 'Telu-Latn', 294=> 'Telu-Mlym', 295=> 'Telu-Orya', 296=> 'Telu-Taml', 297=> 'Telu-ur', 298=> 'Telugu-Arabic', 299=> 'Telugu-Bengali', 300=> 'Telugu-Devanagari', 301=> 'Telugu-Gujarati', 302=> 'Telugu-Gurmukhi', 303=> 'Telugu-Kannada', 304=> 'Telugu-Latin', 305=> 'Telugu-Malayalam', 306=> 'Telugu-Oriya', 307=> 'Telugu-Tamil', 308=> 'Thaa-Latn', 309=> 'Thaana-Latin', 310=> 'Thai-Latin', 311=> 'Thai-Latn', 312=> 'Tone-Digit', 313=> 'Traditional-Simplified', 314=> 'Turkmen-Latin/BGN', 315=> 'Ukrainian-Latin/BGN', 316=> 'Uzbek-Latin/BGN', 317=> 'XSampa-IPA', 318=> 'Zawgyi-my', 319=> 'am-am_FONIPA', 320=> 'am-am_Latn/BGN', 321=> 'am-ar', 322=> 'am-chr', 323=> 'am-fa', 324=> 'am_FONIPA-am', 325=> 'ar-ar_Latn/BGN', 326=> 'az-Lower', 327=> 'az-Title', 328=> 'az-Upper', 329=> 'az_Cyrl-az/BGN', 330=> 'be-be_Latn/BGN', 331=> 'bg-bg_Latn/BGN', 332=> 'blt-blt_FONIPA', 333=> 'ch-am', 334=> 'ch-ar', 335=> 'ch-ch_FONIPA', 336=> 'ch-chr', 337=> 'ch-fa', 338=> 'chr-chr_FONIPA', 339=> 'cs-am', 340=> 'cs-ar', 341=> 'cs-chr', 342=> 'cs-cs_FONIPA', 343=> 'cs-fa', 344=> 'cs-ja', 345=> 'cs-ko', 346=> 'cs_FONIPA-ja', 347=> 'cs_FONIPA-ko', 348=> 'cy-cy_FONIPA', 349=> 'de-ASCII', 350=> 'dsb-dsb_FONIPA', 351=> 'dv-dv_Latn/BGN', 352=> 'el-Lower', 353=> 'el-Title', 354=> 'el-Upper', 355=> 'el-el_Latn/BGN', 356=> 'eo-am', 357=> 'eo-ar', 358=> 'eo-chr', 359=> 'eo-eo_FONIPA', 360=> 'eo-fa', 361=> 'es-am', 362=> 'es-ar', 363=> 'es-chr', 364=> 'es-es_FONIPA', 365=> 'es-fa', 366=> 'es-ja', 367=> 'es-zh', 368=> 'es_419-am', 369=> 'es_419-ar', 370=> 'es_419-chr', 371=> 'es_419-fa', 372=> 'es_419-ja', 373=> 'es_419-zh', 374=> 'es_FONIPA-am', 375=> 'es_FONIPA-es_419_FONIPA', 376=> 'es_FONIPA-ja', 377=> 'es_FONIPA-zh', 378=> 'fa-fa_FONIPA', 379=> 'fa-fa_Latn/BGN', 380=> 'ha-ha_NE', 381=> 'he-he_Latn/BGN', 382=> 'hy-am', 383=> 'hy-ar', 384=> 'hy-chr', 385=> 'hy-fa', 386=> 'hy-hy_FONIPA', 387=> 'hy-hy_Latn/BGN', 388=> 'hy_AREVMDA-am', 389=> 'hy_AREVMDA-ar', 390=> 'hy_AREVMDA-chr', 391=> 'hy_AREVMDA-fa', 392=> 'hy_AREVMDA-hy_AREVMDA_FONIPA', 393=> 'ia-am', 394=> 'ia-ar', 395=> 'ia-chr', 396=> 'ia-fa', 397=> 'ia-ia_FONIPA', 398=> 'it-am', 399=> 'it-ja', 400=> 'ja_Hrkt-ja_Latn/BGN', 401=> 'ja_Latn-ko', 402=> 'ja_Latn-ru', 403=> 'ka-ka_Latn/BGN', 404=> 'ka-ka_Latn/BGN_1981', 405=> 'kk-am', 406=> 'kk-ar', 407=> 'kk-chr', 408=> 'kk-fa', 409=> 'kk-kk_FONIPA', 410=> 'kk-kk_Latn/BGN', 411=> 'ko-ko_Latn/BGN', 412=> 'ky-am', 413=> 'ky-ar', 414=> 'ky-chr', 415=> 'ky-fa', 416=> 'ky-ky_FONIPA', 417=> 'ky-ky_Latn/BGN', 418=> 'la-la_FONIPA', 419=> 'lt-Lower', 420=> 'lt-Title', 421=> 'lt-Upper', 422=> 'mk-mk_Latn/BGN', 423=> 'mn-mn_Latn/BGN', 424=> 'mn-mn_Latn/MNS', 425=> 'my-Zawgyi', 426=> 'my-am', 427=> 'my-ar', 428=> 'my-chr', 429=> 'my-fa', 430=> 'my-my_FONIPA', 431=> 'nl-Title', 432=> 'nv-nv_FONIPA', 433=> 'pl-am', 434=> 'pl-ar', 435=> 'pl-chr', 436=> 'pl-fa', 437=> 'pl-ja', 438=> 'pl-pl_FONIPA', 439=> 'pl_FONIPA-ja', 440=> 'ps-ps_Latn/BGN', 441=> 'rm_SURSILV-am', 442=> 'rm_SURSILV-ar', 443=> 'rm_SURSILV-chr', 444=> 'rm_SURSILV-fa', 445=> 'rm_SURSILV-rm_FONIPA_SURSILV', 446=> 'ro-am', 447=> 'ro-ar', 448=> 'ro-chr', 449=> 'ro-fa', 450=> 'ro-ja', 451=> 'ro-ro_FONIPA', 452=> 'ro_FONIPA-ja', 453=> 'ru-ja', 454=> 'ru-ru_Latn/BGN', 455=> 'ru-zh', 456=> 'ru_Latn-ru/BGN', 457=> 'sat-am', 458=> 'sat-ar', 459=> 'sat-chr', 460=> 'sat-fa', 461=> 'sat_Olck-sat_FONIPA', 462=> 'si-am', 463=> 'si-ar', 464=> 'si-chr', 465=> 'si-fa', 466=> 'si-si_FONIPA', 467=> 'si-si_Latn', 468=> 'sk-am', 469=> 'sk-ar', 470=> 'sk-chr', 471=> 'sk-fa', 472=> 'sk-ja', 473=> 'sk-sk_FONIPA', 474=> 'sk_FONIPA-ja', 475=> 'sr-sr_Latn/BGN', 476=> 'ta-ta_FONIPA', 477=> 'tk_Cyrl-tk/BGN', 478=> 'tlh-am', 479=> 'tlh-ar', 480=> 'tlh-chr', 481=> 'tlh-fa', 482=> 'tlh-tlh_FONIPA', 483=> 'tr-Lower', 484=> 'tr-Title', 485=> 'tr-Upper', 486=> 'ug-ug_FONIPA', 487=> 'uk-uk_Latn/BGN', 488=> 'und_FONIPA-ar', 489=> 'und_FONIPA-chr', 490=> 'und_FONIPA-fa', 491=> 'und_FONIPA-und_FONXSAMP', 492=> 'und_FONXSAMP-und_FONIPA', 493=> 'uz_Cyrl-uz/BGN', 494=> 'uz_Cyrl-uz_Latn', 495=> 'uz_Latn-uz_Cyrl', 496=> 'vec-vec_FONIPA', 497=> 'xh-am', 498=> 'xh-ar', 499=> 'xh-chr', 500=> 'xh-fa', 501=> 'xh-xh_FONIPA', 502=> 'yo-yo_BJ', 503=> 'zh_Latn_PINYIN-ru', 504=> 'zu-am', 505=> 'zu-ar', 506=> 'zu-chr', 507=> 'zu-fa', 508=> 'zu-zu_FONIPA', 509=> 'Any-Null', 510=> 'Any-Lower', 511=> 'Any-Upper', 512=> 'Any-Title', 513=> 'Any-Name', 514=> 'Name-Any', 515=> 'Any-Remove', 516=> 'Any-Hex/Unicode', 517=> 'Any-Hex/Java', 518=> 'Any-Hex/C', 519=> 'Any-Hex/XML', 520=> 'Any-Hex/XML10', 521=> 'Any-Hex/Perl', 522=> 'Any-Hex', 523=> 'Hex-Any/Unicode', 524=> 'Hex-Any/Java', 525=> 'Hex-Any/C', 526=> 'Hex-Any/XML', 527=> 'Hex-Any/XML10', 528=> 'Hex-Any/Perl', 529=> 'Hex-Any', 530=> 'Any-NFC', 531=> 'Any-NFKC', 532=> 'Any-NFD', 533=> 'Any-NFKD', 534=> 'Any-FCD', 535=> 'Any-FCC', 536=> 'Any-fa', 537=> 'Any-ar', 538=> 'Any-chr', 539=> 'Any-rm_FONIPA_SURSILV', 540=> 'Any-am', 541=> 'Any-Latn', 542=> 'Any-dv_Latn/BGN', 543=> 'Any-ro_FONIPA', 544=> 'Any-dsb_FONIPA', 545=> 'Any-Latin', 546=> 'Any-he_Latn/BGN', 547=> 'Any-el_Latn/BGN', 548=> 'Any-eo_FONIPA', 549=> 'Any-si_Latn', 550=> 'Any-si_FONIPA', 551=> 'Any-zh', 552=> 'Any-es_FONIPA', 553=> 'Any-sk_FONIPA', 554=> 'Any-und_FONIPA', 555=> 'Any-und_FONXSAMP', 556=> 'Any-az/BGN', 557=> 'Any-Deva', 558=> 'Any-Arab', 559=> 'Any-Telu', 560=> 'Any-Beng', 561=> 'Any-ur', 562=> 'Any-Orya', 563=> 'Any-Guru', 564=> 'Any-Taml', 565=> 'Any-Gujr', 566=> 'Any-Knda', 567=> 'Any-Armenian', 568=> 'Any-Thaana', 569=> 'Any-Hiragana', 570=> 'Any-Syriac', 571=> 'Any-Jamo', 572=> 'Any-Hangul', 573=> 'Any-Kannada', 574=> 'Any-Georgian', 575=> 'Any-Telugu', 576=> 'Any-Cyrillic', 577=> 'Any-Thai', 578=> 'Any-Oriya', 579=> 'Any-Bopomofo', 580=> 'Any-Malayalam', 581=> 'Any-Gurmukhi', 582=> 'Any-Gujarati', 583=> 'Any-Tamil', 584=> 'Any-Katakana', 585=> 'Any-Hebrew', 586=> 'Any-Bengali', 587=> 'Any-Arabic', 588=> 'Any-Greek', 589=> 'Any-Greek/UNGEGN', 590=> 'Any-Devanagari', 591=> 'Any-fa_FONIPA', 592=> 'Any-fa_Latn/BGN', 593=> 'Any-ta_FONIPA', 594=> 'Any-Mlym', 595=> 'Any-Any', 596=> 'Any-Hant', 597=> 'Any-Hans', 598=> 'Any-uz_Cyrl', 599=> 'Any-blt_FONIPA', 600=> 'Any-ug_FONIPA', 601=> 'Any-uk_Latn/BGN', 602=> 'Any-ha_NE', 603=> 'Any-hy_AREVMDA_FONIPA', 604=> 'Any-hy_FONIPA', 605=> 'Any-hy_Latn/BGN', 606=> 'Any-ia_FONIPA', 607=> 'Any-uz/BGN', 608=> 'Any-uz_Latn', 609=> 'Any-vec_FONIPA', 610=> 'Any-xh_FONIPA', 611=> 'Any-ka_Latn/BGN', 612=> 'Any-ka_Latn/BGN_1981', 613=> 'Any-kk_FONIPA', 614=> 'Any-kk_Latn/BGN', 615=> 'Any-yo_BJ', 616=> 'Any-ky_FONIPA', 617=> 'Any-ky_Latn/BGN', 618=> 'Any-la_FONIPA', 619=> 'Any-ru_Latn/BGN', 620=> 'Any-chr_FONIPA', 621=> 'Any-zu_FONIPA', 622=> 'Any-ru', 623=> 'Any-Geor', 624=> 'Any-Cyrl', 625=> 'Any-Armn', 626=> 'Any-Thaa', 627=> 'Any-Hebr', 628=> 'Any-Grek', 629=> 'Any-Grek/UNGEGN', 630=> 'Any-Syrc', 631=> 'Any-Hira', 632=> 'Any-Hang', 633=> 'Any-Kana', 634=> 'Any-Bopo', 635=> 'Any-mn_Latn/BGN', 636=> 'Any-mn_Latn/MNS', 637=> 'Any-my_FONIPA', 638=> 'Any-sr_Latn/BGN', 639=> 'Any-nv_FONIPA', 640=> 'Any-sat_FONIPA', 641=> 'Any-my', 642=> 'Any-am_FONIPA', 643=> 'Any-am_Latn/BGN', 644=> 'Any-ar_Latn/BGN', 645=> 'Any-mk_Latn/BGN', 646=> 'Any-be_Latn/BGN', 647=> 'Any-bg_Latn/BGN', 648=> 'Any-es_419_FONIPA', 649=> 'Any-pl_FONIPA', 650=> 'Any-ps_Latn/BGN', 651=> 'Any-tk/BGN', 652=> 'Any-ch_FONIPA', 653=> 'Any-cs_FONIPA', 654=> 'Any-cy_FONIPA',]

Documentation des variables

◆ return

return[ 0=> 'ASCII-Latin', 1=> 'Accents-Any', 2=> 'Amharic-Latin/BGN', 3=> 'Any-Accents', 4=> 'Any-Publishing', 5=> 'Arab-Latn', 6=> 'Arabic-Latin', 7=> 'Arabic-Latin/BGN', 8=> 'Armenian-Latin', 9=> 'Armenian-Latin/BGN', 10=> 'Armn-Latn', 11=> 'Azerbaijani-Latin/BGN', 12=> 'Belarusian-Latin/BGN', 13=> 'Beng-Arab', 14=> 'Beng-Deva', 15=> 'Beng-Gujr', 16=> 'Beng-Guru', 17=> 'Beng-Knda', 18=> 'Beng-Latn', 19=> 'Beng-Mlym', 20=> 'Beng-Orya', 21=> 'Beng-Taml', 22=> 'Beng-Telu', 23=> 'Beng-ur', 24=> 'Bengali-Arabic', 25=> 'Bengali-Devanagari', 26=> 'Bengali-Gujarati', 27=> 'Bengali-Gurmukhi', 28=> 'Bengali-Kannada', 29=> 'Bengali-Latin', 30=> 'Bengali-Malayalam', 31=> 'Bengali-Oriya', 32=> 'Bengali-Tamil', 33=> 'Bengali-Telugu', 34=> 'Bopo-Latn', 35=> 'Bopomofo-Latin', 36=> 'Bulgarian-Latin/BGN', 37=> 'Cyrillic-Latin', 38=> 'Cyrl-Latn', 39=> 'Deva-Arab', 40=> 'Deva-Beng', 41=> 'Deva-Gujr', 42=> 'Deva-Guru', 43=> 'Deva-Knda', 44=> 'Deva-Latn', 45=> 'Deva-Mlym', 46=> 'Deva-Orya', 47=> 'Deva-Taml', 48=> 'Deva-Telu', 49=> 'Deva-ur', 50=> 'Devanagari-Arabic', 51=> 'Devanagari-Bengali', 52=> 'Devanagari-Gujarati', 53=> 'Devanagari-Gurmukhi', 54=> 'Devanagari-Kannada', 55=> 'Devanagari-Latin', 56=> 'Devanagari-Malayalam', 57=> 'Devanagari-Oriya', 58=> 'Devanagari-Tamil', 59=> 'Devanagari-Telugu', 60=> 'Digit-Tone', 61=> 'Fullwidth-Halfwidth', 62=> 'Geor-Latn', 63=> 'Georgian-Latin', 64=> 'Georgian-Latin/BGN', 65=> 'Greek-Latin', 66=> 'Greek-Latin/BGN', 67=> 'Greek-Latin/UNGEGN', 68=> 'Grek-Latn', 69=> 'Grek-Latn/UNGEGN', 70=> 'Gujarati-Arabic', 71=> 'Gujarati-Bengali', 72=> 'Gujarati-Devanagari', 73=> 'Gujarati-Gurmukhi', 74=> 'Gujarati-Kannada', 75=> 'Gujarati-Latin', 76=> 'Gujarati-Malayalam', 77=> 'Gujarati-Oriya', 78=> 'Gujarati-Tamil', 79=> 'Gujarati-Telugu', 80=> 'Gujr-Arab', 81=> 'Gujr-Beng', 82=> 'Gujr-Deva', 83=> 'Gujr-Guru', 84=> 'Gujr-Knda', 85=> 'Gujr-Latn', 86=> 'Gujr-Mlym', 87=> 'Gujr-Orya', 88=> 'Gujr-Taml', 89=> 'Gujr-Telu', 90=> 'Gujr-ur', 91=> 'Gurmukhi-Arabic', 92=> 'Gurmukhi-Bengali', 93=> 'Gurmukhi-Devanagari', 94=> 'Gurmukhi-Gujarati', 95=> 'Gurmukhi-Kannada', 96=> 'Gurmukhi-Latin', 97=> 'Gurmukhi-Malayalam', 98=> 'Gurmukhi-Oriya', 99=> 'Gurmukhi-Tamil', 100=> 'Gurmukhi-Telugu', 101=> 'Guru-Arab', 102=> 'Guru-Beng', 103=> 'Guru-Deva', 104=> 'Guru-Gujr', 105=> 'Guru-Knda', 106=> 'Guru-Latn', 107=> 'Guru-Mlym', 108=> 'Guru-Orya', 109=> 'Guru-Taml', 110=> 'Guru-Telu', 111=> 'Guru-ur', 112=> 'Halfwidth-Fullwidth', 113=> 'Han-Latin', 114=> 'Han-Latin/Names', 115=> 'Hang-Latn', 116=> 'Hangul-Latin', 117=> 'Hani-Latn', 118=> 'Hans-Hant', 119=> 'Hant-Hans', 120=> 'Hebr-Latn', 121=> 'Hebrew-Latin', 122=> 'Hebrew-Latin/BGN', 123=> 'Hira-Kana', 124=> 'Hira-Latn', 125=> 'Hiragana-Katakana', 126=> 'Hiragana-Latin', 127=> 'IPA-XSampa', 128=> 'Jamo-Latin', 129=> 'Jamo-Latn', 130=> 'Kana-Hira', 131=> 'Kana-Latn', 132=> 'Kannada-Arabic', 133=> 'Kannada-Bengali', 134=> 'Kannada-Devanagari', 135=> 'Kannada-Gujarati', 136=> 'Kannada-Gurmukhi', 137=> 'Kannada-Latin', 138=> 'Kannada-Malayalam', 139=> 'Kannada-Oriya', 140=> 'Kannada-Tamil', 141=> 'Kannada-Telugu', 142=> 'Katakana-Hiragana', 143=> 'Katakana-Latin', 144=> 'Katakana-Latin/BGN', 145=> 'Kazakh-Latin/BGN', 146=> 'Kirghiz-Latin/BGN', 147=> 'Knda-Arab', 148=> 'Knda-Beng', 149=> 'Knda-Deva', 150=> 'Knda-Gujr', 151=> 'Knda-Guru', 152=> 'Knda-Latn', 153=> 'Knda-Mlym', 154=> 'Knda-Orya', 155=> 'Knda-Taml', 156=> 'Knda-Telu', 157=> 'Knda-ur', 158=> 'Korean-Latin/BGN', 159=> 'Latin-ASCII', 160=> 'Latin-Arabic', 161=> 'Latin-Armenian', 162=> 'Latin-Bengali', 163=> 'Latin-Bopomofo', 164=> 'Latin-Cyrillic', 165=> 'Latin-Devanagari', 166=> 'Latin-Georgian', 167=> 'Latin-Greek', 168=> 'Latin-Greek/UNGEGN', 169=> 'Latin-Gujarati', 170=> 'Latin-Gurmukhi', 171=> 'Latin-Hangul', 172=> 'Latin-Hebrew', 173=> 'Latin-Hiragana', 174=> 'Latin-Jamo', 175=> 'Latin-Kannada', 176=> 'Latin-Katakana', 177=> 'Latin-Malayalam', 178=> 'Latin-NumericPinyin', 179=> 'Latin-Oriya', 180=> 'Latin-Russian/BGN', 181=> 'Latin-Syriac', 182=> 'Latin-Tamil', 183=> 'Latin-Telugu', 184=> 'Latin-Thaana', 185=> 'Latin-Thai', 186=> 'Latn-Arab', 187=> 'Latn-Armn', 188=> 'Latn-Beng', 189=> 'Latn-Bopo', 190=> 'Latn-Cyrl', 191=> 'Latn-Deva', 192=> 'Latn-Geor', 193=> 'Latn-Grek', 194=> 'Latn-Grek/UNGEGN', 195=> 'Latn-Gujr', 196=> 'Latn-Guru', 197=> 'Latn-Hang', 198=> 'Latn-Hebr', 199=> 'Latn-Hira', 200=> 'Latn-Jamo', 201=> 'Latn-Kana', 202=> 'Latn-Knda', 203=> 'Latn-Mlym', 204=> 'Latn-Orya', 205=> 'Latn-Syrc', 206=> 'Latn-Taml', 207=> 'Latn-Telu', 208=> 'Latn-Thaa', 209=> 'Latn-Thai', 210=> 'Macedonian-Latin/BGN', 211=> 'Malayalam-Arabic', 212=> 'Malayalam-Bengali', 213=> 'Malayalam-Devanagari', 214=> 'Malayalam-Gujarati', 215=> 'Malayalam-Gurmukhi', 216=> 'Malayalam-Kannada', 217=> 'Malayalam-Latin', 218=> 'Malayalam-Oriya', 219=> 'Malayalam-Tamil', 220=> 'Malayalam-Telugu', 221=> 'Maldivian-Latin/BGN', 222=> 'Mlym-Arab', 223=> 'Mlym-Beng', 224=> 'Mlym-Deva', 225=> 'Mlym-Gujr', 226=> 'Mlym-Guru', 227=> 'Mlym-Knda', 228=> 'Mlym-Latn', 229=> 'Mlym-Orya', 230=> 'Mlym-Taml', 231=> 'Mlym-Telu', 232=> 'Mlym-ur', 233=> 'Mongolian-Latin/BGN', 234=> 'NumericPinyin-Latin', 235=> 'NumericPinyin-Pinyin', 236=> 'Oriya-Arabic', 237=> 'Oriya-Bengali', 238=> 'Oriya-Devanagari', 239=> 'Oriya-Gujarati', 240=> 'Oriya-Gurmukhi', 241=> 'Oriya-Kannada', 242=> 'Oriya-Latin', 243=> 'Oriya-Malayalam', 244=> 'Oriya-Tamil', 245=> 'Oriya-Telugu', 246=> 'Orya-Arab', 247=> 'Orya-Beng', 248=> 'Orya-Deva', 249=> 'Orya-Gujr', 250=> 'Orya-Guru', 251=> 'Orya-Knda', 252=> 'Orya-Latn', 253=> 'Orya-Mlym', 254=> 'Orya-Taml', 255=> 'Orya-Telu', 256=> 'Orya-ur', 257=> 'Pashto-Latin/BGN', 258=> 'Persian-Latin/BGN', 259=> 'Pinyin-NumericPinyin', 260=> 'Publishing-Any', 261=> 'Russian-Latin/BGN', 262=> 'Serbian-Latin/BGN', 263=> 'Simplified-Traditional', 264=> 'Syrc-Latn', 265=> 'Syriac-Latin', 266=> 'Tamil-Arabic', 267=> 'Tamil-Bengali', 268=> 'Tamil-Devanagari', 269=> 'Tamil-Gujarati', 270=> 'Tamil-Gurmukhi', 271=> 'Tamil-Kannada', 272=> 'Tamil-Latin', 273=> 'Tamil-Malayalam', 274=> 'Tamil-Oriya', 275=> 'Tamil-Telugu', 276=> 'Taml-Arab', 277=> 'Taml-Beng', 278=> 'Taml-Deva', 279=> 'Taml-Gujr', 280=> 'Taml-Guru', 281=> 'Taml-Knda', 282=> 'Taml-Latn', 283=> 'Taml-Mlym', 284=> 'Taml-Orya', 285=> 'Taml-Telu', 286=> 'Taml-ur', 287=> 'Telu-Arab', 288=> 'Telu-Beng', 289=> 'Telu-Deva', 290=> 'Telu-Gujr', 291=> 'Telu-Guru', 292=> 'Telu-Knda', 293=> 'Telu-Latn', 294=> 'Telu-Mlym', 295=> 'Telu-Orya', 296=> 'Telu-Taml', 297=> 'Telu-ur', 298=> 'Telugu-Arabic', 299=> 'Telugu-Bengali', 300=> 'Telugu-Devanagari', 301=> 'Telugu-Gujarati', 302=> 'Telugu-Gurmukhi', 303=> 'Telugu-Kannada', 304=> 'Telugu-Latin', 305=> 'Telugu-Malayalam', 306=> 'Telugu-Oriya', 307=> 'Telugu-Tamil', 308=> 'Thaa-Latn', 309=> 'Thaana-Latin', 310=> 'Thai-Latin', 311=> 'Thai-Latn', 312=> 'Tone-Digit', 313=> 'Traditional-Simplified', 314=> 'Turkmen-Latin/BGN', 315=> 'Ukrainian-Latin/BGN', 316=> 'Uzbek-Latin/BGN', 317=> 'XSampa-IPA', 318=> 'Zawgyi-my', 319=> 'am-am_FONIPA', 320=> 'am-am_Latn/BGN', 321=> 'am-ar', 322=> 'am-chr', 323=> 'am-fa', 324=> 'am_FONIPA-am', 325=> 'ar-ar_Latn/BGN', 326=> 'az-Lower', 327=> 'az-Title', 328=> 'az-Upper', 329=> 'az_Cyrl-az/BGN', 330=> 'be-be_Latn/BGN', 331=> 'bg-bg_Latn/BGN', 332=> 'blt-blt_FONIPA', 333=> 'ch-am', 334=> 'ch-ar', 335=> 'ch-ch_FONIPA', 336=> 'ch-chr', 337=> 'ch-fa', 338=> 'chr-chr_FONIPA', 339=> 'cs-am', 340=> 'cs-ar', 341=> 'cs-chr', 342=> 'cs-cs_FONIPA', 343=> 'cs-fa', 344=> 'cs-ja', 345=> 'cs-ko', 346=> 'cs_FONIPA-ja', 347=> 'cs_FONIPA-ko', 348=> 'cy-cy_FONIPA', 349=> 'de-ASCII', 350=> 'dsb-dsb_FONIPA', 351=> 'dv-dv_Latn/BGN', 352=> 'el-Lower', 353=> 'el-Title', 354=> 'el-Upper', 355=> 'el-el_Latn/BGN', 356=> 'eo-am', 357=> 'eo-ar', 358=> 'eo-chr', 359=> 'eo-eo_FONIPA', 360=> 'eo-fa', 361=> 'es-am', 362=> 'es-ar', 363=> 'es-chr', 364=> 'es-es_FONIPA', 365=> 'es-fa', 366=> 'es-ja', 367=> 'es-zh', 368=> 'es_419-am', 369=> 'es_419-ar', 370=> 'es_419-chr', 371=> 'es_419-fa', 372=> 'es_419-ja', 373=> 'es_419-zh', 374=> 'es_FONIPA-am', 375=> 'es_FONIPA-es_419_FONIPA', 376=> 'es_FONIPA-ja', 377=> 'es_FONIPA-zh', 378=> 'fa-fa_FONIPA', 379=> 'fa-fa_Latn/BGN', 380=> 'ha-ha_NE', 381=> 'he-he_Latn/BGN', 382=> 'hy-am', 383=> 'hy-ar', 384=> 'hy-chr', 385=> 'hy-fa', 386=> 'hy-hy_FONIPA', 387=> 'hy-hy_Latn/BGN', 388=> 'hy_AREVMDA-am', 389=> 'hy_AREVMDA-ar', 390=> 'hy_AREVMDA-chr', 391=> 'hy_AREVMDA-fa', 392=> 'hy_AREVMDA-hy_AREVMDA_FONIPA', 393=> 'ia-am', 394=> 'ia-ar', 395=> 'ia-chr', 396=> 'ia-fa', 397=> 'ia-ia_FONIPA', 398=> 'it-am', 399=> 'it-ja', 400=> 'ja_Hrkt-ja_Latn/BGN', 401=> 'ja_Latn-ko', 402=> 'ja_Latn-ru', 403=> 'ka-ka_Latn/BGN', 404=> 'ka-ka_Latn/BGN_1981', 405=> 'kk-am', 406=> 'kk-ar', 407=> 'kk-chr', 408=> 'kk-fa', 409=> 'kk-kk_FONIPA', 410=> 'kk-kk_Latn/BGN', 411=> 'ko-ko_Latn/BGN', 412=> 'ky-am', 413=> 'ky-ar', 414=> 'ky-chr', 415=> 'ky-fa', 416=> 'ky-ky_FONIPA', 417=> 'ky-ky_Latn/BGN', 418=> 'la-la_FONIPA', 419=> 'lt-Lower', 420=> 'lt-Title', 421=> 'lt-Upper', 422=> 'mk-mk_Latn/BGN', 423=> 'mn-mn_Latn/BGN', 424=> 'mn-mn_Latn/MNS', 425=> 'my-Zawgyi', 426=> 'my-am', 427=> 'my-ar', 428=> 'my-chr', 429=> 'my-fa', 430=> 'my-my_FONIPA', 431=> 'nl-Title', 432=> 'nv-nv_FONIPA', 433=> 'pl-am', 434=> 'pl-ar', 435=> 'pl-chr', 436=> 'pl-fa', 437=> 'pl-ja', 438=> 'pl-pl_FONIPA', 439=> 'pl_FONIPA-ja', 440=> 'ps-ps_Latn/BGN', 441=> 'rm_SURSILV-am', 442=> 'rm_SURSILV-ar', 443=> 'rm_SURSILV-chr', 444=> 'rm_SURSILV-fa', 445=> 'rm_SURSILV-rm_FONIPA_SURSILV', 446=> 'ro-am', 447=> 'ro-ar', 448=> 'ro-chr', 449=> 'ro-fa', 450=> 'ro-ja', 451=> 'ro-ro_FONIPA', 452=> 'ro_FONIPA-ja', 453=> 'ru-ja', 454=> 'ru-ru_Latn/BGN', 455=> 'ru-zh', 456=> 'ru_Latn-ru/BGN', 457=> 'sat-am', 458=> 'sat-ar', 459=> 'sat-chr', 460=> 'sat-fa', 461=> 'sat_Olck-sat_FONIPA', 462=> 'si-am', 463=> 'si-ar', 464=> 'si-chr', 465=> 'si-fa', 466=> 'si-si_FONIPA', 467=> 'si-si_Latn', 468=> 'sk-am', 469=> 'sk-ar', 470=> 'sk-chr', 471=> 'sk-fa', 472=> 'sk-ja', 473=> 'sk-sk_FONIPA', 474=> 'sk_FONIPA-ja', 475=> 'sr-sr_Latn/BGN', 476=> 'ta-ta_FONIPA', 477=> 'tk_Cyrl-tk/BGN', 478=> 'tlh-am', 479=> 'tlh-ar', 480=> 'tlh-chr', 481=> 'tlh-fa', 482=> 'tlh-tlh_FONIPA', 483=> 'tr-Lower', 484=> 'tr-Title', 485=> 'tr-Upper', 486=> 'ug-ug_FONIPA', 487=> 'uk-uk_Latn/BGN', 488=> 'und_FONIPA-ar', 489=> 'und_FONIPA-chr', 490=> 'und_FONIPA-fa', 491=> 'und_FONIPA-und_FONXSAMP', 492=> 'und_FONXSAMP-und_FONIPA', 493=> 'uz_Cyrl-uz/BGN', 494=> 'uz_Cyrl-uz_Latn', 495=> 'uz_Latn-uz_Cyrl', 496=> 'vec-vec_FONIPA', 497=> 'xh-am', 498=> 'xh-ar', 499=> 'xh-chr', 500=> 'xh-fa', 501=> 'xh-xh_FONIPA', 502=> 'yo-yo_BJ', 503=> 'zh_Latn_PINYIN-ru', 504=> 'zu-am', 505=> 'zu-ar', 506=> 'zu-chr', 507=> 'zu-fa', 508=> 'zu-zu_FONIPA', 509=> 'Any-Null', 510=> 'Any-Lower', 511=> 'Any-Upper', 512=> 'Any-Title', 513=> 'Any-Name', 514=> 'Name-Any', 515=> 'Any-Remove', 516=> 'Any-Hex/Unicode', 517=> 'Any-Hex/Java', 518=> 'Any-Hex/C', 519=> 'Any-Hex/XML', 520=> 'Any-Hex/XML10', 521=> 'Any-Hex/Perl', 522=> 'Any-Hex', 523=> 'Hex-Any/Unicode', 524=> 'Hex-Any/Java', 525=> 'Hex-Any/C', 526=> 'Hex-Any/XML', 527=> 'Hex-Any/XML10', 528=> 'Hex-Any/Perl', 529=> 'Hex-Any', 530=> 'Any-NFC', 531=> 'Any-NFKC', 532=> 'Any-NFD', 533=> 'Any-NFKD', 534=> 'Any-FCD', 535=> 'Any-FCC', 536=> 'Any-fa', 537=> 'Any-ar', 538=> 'Any-chr', 539=> 'Any-rm_FONIPA_SURSILV', 540=> 'Any-am', 541=> 'Any-Latn', 542=> 'Any-dv_Latn/BGN', 543=> 'Any-ro_FONIPA', 544=> 'Any-dsb_FONIPA', 545=> 'Any-Latin', 546=> 'Any-he_Latn/BGN', 547=> 'Any-el_Latn/BGN', 548=> 'Any-eo_FONIPA', 549=> 'Any-si_Latn', 550=> 'Any-si_FONIPA', 551=> 'Any-zh', 552=> 'Any-es_FONIPA', 553=> 'Any-sk_FONIPA', 554=> 'Any-und_FONIPA', 555=> 'Any-und_FONXSAMP', 556=> 'Any-az/BGN', 557=> 'Any-Deva', 558=> 'Any-Arab', 559=> 'Any-Telu', 560=> 'Any-Beng', 561=> 'Any-ur', 562=> 'Any-Orya', 563=> 'Any-Guru', 564=> 'Any-Taml', 565=> 'Any-Gujr', 566=> 'Any-Knda', 567=> 'Any-Armenian', 568=> 'Any-Thaana', 569=> 'Any-Hiragana', 570=> 'Any-Syriac', 571=> 'Any-Jamo', 572=> 'Any-Hangul', 573=> 'Any-Kannada', 574=> 'Any-Georgian', 575=> 'Any-Telugu', 576=> 'Any-Cyrillic', 577=> 'Any-Thai', 578=> 'Any-Oriya', 579=> 'Any-Bopomofo', 580=> 'Any-Malayalam', 581=> 'Any-Gurmukhi', 582=> 'Any-Gujarati', 583=> 'Any-Tamil', 584=> 'Any-Katakana', 585=> 'Any-Hebrew', 586=> 'Any-Bengali', 587=> 'Any-Arabic', 588=> 'Any-Greek', 589=> 'Any-Greek/UNGEGN', 590=> 'Any-Devanagari', 591=> 'Any-fa_FONIPA', 592=> 'Any-fa_Latn/BGN', 593=> 'Any-ta_FONIPA', 594=> 'Any-Mlym', 595=> 'Any-Any', 596=> 'Any-Hant', 597=> 'Any-Hans', 598=> 'Any-uz_Cyrl', 599=> 'Any-blt_FONIPA', 600=> 'Any-ug_FONIPA', 601=> 'Any-uk_Latn/BGN', 602=> 'Any-ha_NE', 603=> 'Any-hy_AREVMDA_FONIPA', 604=> 'Any-hy_FONIPA', 605=> 'Any-hy_Latn/BGN', 606=> 'Any-ia_FONIPA', 607=> 'Any-uz/BGN', 608=> 'Any-uz_Latn', 609=> 'Any-vec_FONIPA', 610=> 'Any-xh_FONIPA', 611=> 'Any-ka_Latn/BGN', 612=> 'Any-ka_Latn/BGN_1981', 613=> 'Any-kk_FONIPA', 614=> 'Any-kk_Latn/BGN', 615=> 'Any-yo_BJ', 616=> 'Any-ky_FONIPA', 617=> 'Any-ky_Latn/BGN', 618=> 'Any-la_FONIPA', 619=> 'Any-ru_Latn/BGN', 620=> 'Any-chr_FONIPA', 621=> 'Any-zu_FONIPA', 622=> 'Any-ru', 623=> 'Any-Geor', 624=> 'Any-Cyrl', 625=> 'Any-Armn', 626=> 'Any-Thaa', 627=> 'Any-Hebr', 628=> 'Any-Grek', 629=> 'Any-Grek/UNGEGN', 630=> 'Any-Syrc', 631=> 'Any-Hira', 632=> 'Any-Hang', 633=> 'Any-Kana', 634=> 'Any-Bopo', 635=> 'Any-mn_Latn/BGN', 636=> 'Any-mn_Latn/MNS', 637=> 'Any-my_FONIPA', 638=> 'Any-sr_Latn/BGN', 639=> 'Any-nv_FONIPA', 640=> 'Any-sat_FONIPA', 641=> 'Any-my', 642=> 'Any-am_FONIPA', 643=> 'Any-am_Latn/BGN', 644=> 'Any-ar_Latn/BGN', 645=> 'Any-mk_Latn/BGN', 646=> 'Any-be_Latn/BGN', 647=> 'Any-bg_Latn/BGN', 648=> 'Any-es_419_FONIPA', 649=> 'Any-pl_FONIPA', 650=> 'Any-ps_Latn/BGN', 651=> 'Any-tk/BGN', 652=> 'Any-ch_FONIPA', 653=> 'Any-cs_FONIPA', 654=> 'Any-cy_FONIPA',]


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier Ruleset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Ruleset.php

Structures de données

class Ruleset

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier PrivacyHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PrivacyHelper.php

Structures de données

class PrivacyHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Helper


Joomla CMS: Référence du fichier TagsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Model/TagsModel.php

Structures de données

class TagsModel

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Model


Joomla CMS: Référence du fichier TagObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier TagObject.php

Structures de données

class TagObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier x07d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07d.php

Variables

return ['Ji ', 'Cha ', 'Zhou ', 'Xun ', 'Yue ', 'Hong ', 'Yu ', 'He ', 'Wan ', 'Ren ', 'Wen ', 'Wen ', 'Qiu ', 'Na ', 'Zi ', 'Tou ', 'Niu ', 'Fou ', 'Jie ', 'Shu ', 'Chun ', 'Pi ', 'Yin ', 'Sha ', 'Hong ', 'Zhi ', 'Ji ', 'Fen ', 'Yun ', 'Ren ', 'Dan ', 'Jin ', 'Su ', 'Fang ', 'Suo ', 'Cui ', 'Jiu ', 'Zha ', 'Kinu ', 'Jin ', 'Fu ', 'Zhi ', 'Ci ', 'Zi ', 'Chou ', 'Hong ', 'Zha ', 'Lei ', 'Xi ', 'Fu ', 'Xie ', 'Shen ', 'Bei ', 'Zhu ', 'Qu ', 'Ling ', 'Zhu ', 'Shao ', 'Gan ', 'Yang ', 'Fu ', 'Tuo ', 'Zhen ', 'Dai ', 'Zhuo ', 'Shi ', 'Zhong ', 'Xian ', 'Zu ', 'Jiong ', 'Ban ', 'Ju ', 'Mo ', 'Shu ', 'Zui ', 'Wata ', 'Jing ', 'Ren ', 'Heng ', 'Xie ', 'Jie ', 'Zhu ', 'Chou ', 'Gua ', 'Bai ', 'Jue ', 'Kuang ', 'Hu ', 'Ci ', 'Geng ', 'Geng ', 'Tao ', 'Xie ', 'Ku ', 'Jiao ', 'Quan ', 'Gai ', 'Luo ', 'Xuan ', 'Bing ', 'Xian ', 'Fu ', 'Gei ', 'Tong ', 'Rong ', 'Tiao ', 'Yin ', 'Lei ', 'Xie ', 'Quan ', 'Xu ', 'Lun ', 'Die ', 'Tong ', 'Si ', 'Jiang ', 'Xiang ', 'Hui ', 'Jue ', 'Zhi ', 'Jian ', 'Juan ', 'Chi ', 'Mian ', 'Zhen ', 'Lu ', 'Cheng ', 'Qiu ', 'Shu ', 'Bang ', 'Tong ', 'Xiao ', 'Wan ', 'Qin ', 'Geng ', 'Xiu ', 'Ti ', 'Xiu ', 'Xie ', 'Hong ', 'Xi ', 'Fu ', 'Ting ', 'Sui ', 'Dui ', 'Kun ', 'Fu ', 'Jing ', 'Hu ', 'Zhi ', 'Yan ', 'Jiong ', 'Feng ', 'Ji ', 'Sok ', 'Kase ', 'Zong ', 'Lin ', 'Duo ', 'Li ', 'Lu ', 'Liang ', 'Chou ', 'Quan ', 'Shao ', 'Qi ', 'Qi ', 'Zhun ', 'Qi ', 'Wan ', 'Qian ', 'Xian ', 'Shou ', 'Wei ', 'Qi ', 'Tao ', 'Wan ', 'Gang ', 'Wang ', 'Beng ', 'Zhui ', 'Cai ', 'Guo ', 'Cui ', 'Lun ', 'Liu ', 'Qi ', 'Zhan ', 'Bei ', 'Chuo ', 'Ling ', 'Mian ', 'Qi ', 'Qie ', 'Tan ', 'Zong ', 'Gun ', 'Zou ', 'Yi ', 'Zi ', 'Xing ', 'Liang ', 'Jin ', 'Fei ', 'Rui ', 'Min ', 'Yu ', 'Zong ', 'Fan ', 'Lu ', 'Xu ', 'Yingl ', 'Zhang ', 'Kasuri ', 'Xu ', 'Xiang ', 'Jian ', 'Ke ', 'Xian ', 'Ruan ', 'Mian ', 'Qi ', 'Duan ', 'Zhong ', 'Di ', 'Min ', 'Miao ', 'Yuan ', 'Xie ', 'Bao ', 'Si ', 'Qiu ', 'Bian ', 'Huan ', 'Geng ', 'Cong ', 'Mian ', 'Wei ', 'Fu ', 'Wei ', 'Yu ', 'Gou ', 'Miao ', 'Xie ', 'Lian ', 'Zong ', 'Bian ', 'Yun ', 'Yin ', 'Ti ', 'Gua ', 'Zhi ', 'Yun ', 'Cheng ', 'Chan ', 'Dai ']

Documentation des variables

◆ return

return[ 'Ji ', 'Cha ', 'Zhou ', 'Xun ', 'Yue ', 'Hong ', 'Yu ', 'He ', 'Wan ', 'Ren ', 'Wen ', 'Wen ', 'Qiu ', 'Na ', 'Zi ', 'Tou ', 'Niu ', 'Fou ', 'Jie ', 'Shu ', 'Chun ', 'Pi ', 'Yin ', 'Sha ', 'Hong ', 'Zhi ', 'Ji ', 'Fen ', 'Yun ', 'Ren ', 'Dan ', 'Jin ', 'Su ', 'Fang ', 'Suo ', 'Cui ', 'Jiu ', 'Zha ', 'Kinu ', 'Jin ', 'Fu ', 'Zhi ', 'Ci ', 'Zi ', 'Chou ', 'Hong ', 'Zha ', 'Lei ', 'Xi ', 'Fu ', 'Xie ', 'Shen ', 'Bei ', 'Zhu ', 'Qu ', 'Ling ', 'Zhu ', 'Shao ', 'Gan ', 'Yang ', 'Fu ', 'Tuo ', 'Zhen ', 'Dai ', 'Zhuo ', 'Shi ', 'Zhong ', 'Xian ', 'Zu ', 'Jiong ', 'Ban ', 'Ju ', 'Mo ', 'Shu ', 'Zui ', 'Wata ', 'Jing ', 'Ren ', 'Heng ', 'Xie ', 'Jie ', 'Zhu ', 'Chou ', 'Gua ', 'Bai ', 'Jue ', 'Kuang ', 'Hu ', 'Ci ', 'Geng ', 'Geng ', 'Tao ', 'Xie ', 'Ku ', 'Jiao ', 'Quan ', 'Gai ', 'Luo ', 'Xuan ', 'Bing ', 'Xian ', 'Fu ', 'Gei ', 'Tong ', 'Rong ', 'Tiao ', 'Yin ', 'Lei ', 'Xie ', 'Quan ', 'Xu ', 'Lun ', 'Die ', 'Tong ', 'Si ', 'Jiang ', 'Xiang ', 'Hui ', 'Jue ', 'Zhi ', 'Jian ', 'Juan ', 'Chi ', 'Mian ', 'Zhen ', 'Lu ', 'Cheng ', 'Qiu ', 'Shu ', 'Bang ', 'Tong ', 'Xiao ', 'Wan ', 'Qin ', 'Geng ', 'Xiu ', 'Ti ', 'Xiu ', 'Xie ', 'Hong ', 'Xi ', 'Fu ', 'Ting ', 'Sui ', 'Dui ', 'Kun ', 'Fu ', 'Jing ', 'Hu ', 'Zhi ', 'Yan ', 'Jiong ', 'Feng ', 'Ji ', 'Sok ', 'Kase ', 'Zong ', 'Lin ', 'Duo ', 'Li ', 'Lu ', 'Liang ', 'Chou ', 'Quan ', 'Shao ', 'Qi ', 'Qi ', 'Zhun ', 'Qi ', 'Wan ', 'Qian ', 'Xian ', 'Shou ', 'Wei ', 'Qi ', 'Tao ', 'Wan ', 'Gang ', 'Wang ', 'Beng ', 'Zhui ', 'Cai ', 'Guo ', 'Cui ', 'Lun ', 'Liu ', 'Qi ', 'Zhan ', 'Bei ', 'Chuo ', 'Ling ', 'Mian ', 'Qi ', 'Qie ', 'Tan ', 'Zong ', 'Gun ', 'Zou ', 'Yi ', 'Zi ', 'Xing ', 'Liang ', 'Jin ', 'Fei ', 'Rui ', 'Min ', 'Yu ', 'Zong ', 'Fan ', 'Lu ', 'Xu ', 'Yingl ', 'Zhang ', 'Kasuri ', 'Xu ', 'Xiang ', 'Jian ', 'Ke ', 'Xian ', 'Ruan ', 'Mian ', 'Qi ', 'Duan ', 'Zhong ', 'Di ', 'Min ', 'Miao ', 'Yuan ', 'Xie ', 'Bao ', 'Si ', 'Qiu ', 'Bian ', 'Huan ', 'Geng ', 'Cong ', 'Mian ', 'Wei ', 'Fu ', 'Wei ', 'Yu ', 'Gou ', 'Miao ', 'Xie ', 'Lian ', 'Zong ', 'Bian ', 'Yun ', 'Yin ', 'Ti ', 'Gua ', 'Zhi ', 'Yun ', 'Cheng ', 'Chan ', 'Dai ']


Joomla CMS: Référence du fichier TagsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_tags/src/Controller/TagsController.php

Structures de données

class TagsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Controller


Joomla CMS: Référence du fichier UserFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Structures de données | Espaces de nommage
Référence du fichier UserFactory.php

Structures de données

class UserFactory

Espaces de nommage

Joomla\CMS\User


Joomla CMS: Référence du fichier XmlReaderCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier XmlReaderCaster.php

Structures de données

class XmlReaderCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier SessionMetadataGcCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier SessionMetadataGcCommand.php

Structures de données

class SessionMetadataGcCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier update.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage | Variables
Référence du fichier update.php

Espaces de nommage

Joomla\Administrator

Variables

$wa = $this->document->getWebAssetManager()
$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'
$displayData
endif
$classVisibility = $this->noBackupCheck ? 'd-none' : ''
$checked = $this->noBackupCheck ? 'checked' : ''
$displayData ['content']

Documentation des variables

◆ $checked

$checked = $this->noBackupCheck ? 'checked' : ''

Référencé par CheckboxField\__get(), Access\actions(), ListField\getOptions(), CheckboxField\setup(), Filter\slider(), et Access\usergroups().

◆ $classVisibility

$classVisibility = $this->noBackupCheck ? 'd-none' : ''

◆ $displayData [1/2]

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_JOOMLAUPDATE_UPDATE'

◆ $displayData [2/2]

$displayData[ 'content']
Valeur initiale :
= '<div class="form-check d-flex justify-content-center ' . $classVisibility . '">
<input class="form-check-input me-2" type="checkbox" value="" id="joomlaupdate-confirm-backup" ' . $checked . '>
<label class="form-check-label" for="joomlaupdate-confirm-backup">
' . Text::_('COM_JOOMLAUPDATE_UPDATE_CONFIRM_BACKUP') . '
</label>
</div>'
$checked
$checked
Definition: update.php:53
$classVisibility
$classVisibility
Definition: update.php:52

◆ $uploadLink

$uploadLink = 'index.php?option=com_joomlaupdate&view=upload'

◆ $wa

$wa = $this->document->getWebAssetManager()

◆ endif

endif


Joomla CMS: Référence du fichier x07f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07f.php

Variables

return ['Zhui ', 'Zi ', 'Ke ', 'Xiang ', 'Jian ', 'Mian ', 'Lan ', 'Ti ', 'Miao ', 'Qi ', 'Yun ', 'Hui ', 'Si ', 'Duo ', 'Duan ', 'Bian ', 'Xian ', 'Gou ', 'Zhui ', 'Huan ', 'Di ', 'Lu ', 'Bian ', 'Min ', 'Yuan ', 'Jin ', 'Fu ', 'Ru ', 'Zhen ', 'Feng ', 'Shuai ', 'Gao ', 'Chan ', 'Li ', 'Yi ', 'Jian ', 'Bin ', 'Piao ', 'Man ', 'Lei ', 'Ying ', 'Suo ', 'Mou ', 'Sao ', 'Xie ', 'Liao ', 'Shan ', 'Zeng ', 'Jiang ', 'Qian ', 'Zao ', 'Huan ', 'Jiao ', 'Zuan ', 'Fou ', 'Xie ', 'Gang ', 'Fou ', 'Que ', 'Fou ', 'Kaakeru ', 'Bo ', 'Ping ', 'Hou ', '[?] ', 'Gang ', 'Ying ', 'Ying ', 'Qing ', 'Xia ', 'Guan ', 'Zun ', 'Tan ', 'Chang ', 'Qi ', 'Weng ', 'Ying ', 'Lei ', 'Tan ', 'Lu ', 'Guan ', 'Wang ', 'Wang ', 'Gang ', 'Wang ', 'Han ', '[?] ', 'Luo ', 'Fu ', 'Mi ', 'Fa ', 'Gu ', 'Zhu ', 'Ju ', 'Mao ', 'Gu ', 'Min ', 'Gang ', 'Ba ', 'Gua ', 'Ti ', 'Juan ', 'Fu ', 'Lin ', 'Yan ', 'Zhao ', 'Zui ', 'Gua ', 'Zhuo ', 'Yu ', 'Zhi ', 'An ', 'Fa ', 'Nan ', 'Shu ', 'Si ', 'Pi ', 'Ma ', 'Liu ', 'Ba ', 'Fa ', 'Li ', 'Chao ', 'Wei ', 'Bi ', 'Ji ', 'Zeng ', 'Tong ', 'Liu ', 'Ji ', 'Juan ', 'Mi ', 'Zhao ', 'Luo ', 'Pi ', 'Ji ', 'Ji ', 'Luan ', 'Yang ', 'Mie ', 'Qiang ', 'Ta ', 'Mei ', 'Yang ', 'You ', 'You ', 'Fen ', 'Ba ', 'Gao ', 'Yang ', 'Gu ', 'Qiang ', 'Zang ', 'Gao ', 'Ling ', 'Yi ', 'Zhu ', 'Di ', 'Xiu ', 'Qian ', 'Yi ', 'Xian ', 'Rong ', 'Qun ', 'Qun ', 'Qian ', 'Huan ', 'Zui ', 'Xian ', 'Yi ', 'Yashinau ', 'Qiang ', 'Xian ', 'Yu ', 'Geng ', 'Jie ', 'Tang ', 'Yuan ', 'Xi ', 'Fan ', 'Shan ', 'Fen ', 'Shan ', 'Lian ', 'Lei ', 'Geng ', 'Nou ', 'Qiang ', 'Chan ', 'Yu ', 'Gong ', 'Yi ', 'Chong ', 'Weng ', 'Fen ', 'Hong ', 'Chi ', 'Chi ', 'Cui ', 'Fu ', 'Xia ', 'Pen ', 'Yi ', 'La ', 'Yi ', 'Pi ', 'Ling ', 'Liu ', 'Zhi ', 'Qu ', 'Xi ', 'Xie ', 'Xiang ', 'Xi ', 'Xi ', 'Qi ', 'Qiao ', 'Hui ', 'Hui ', 'Xiao ', 'Se ', 'Hong ', 'Jiang ', 'Di ', 'Cui ', 'Fei ', 'Tao ', 'Sha ', 'Chi ', 'Zhu ', 'Jian ', 'Xuan ', 'Shi ', 'Pian ', 'Zong ', 'Wan ', 'Hui ', 'Hou ', 'He ', 'He ', 'Han ', 'Ao ', 'Piao ', 'Yi ', 'Lian ', 'Qu ', '[?] ', 'Lin ', 'Pen ', 'Qiao ', 'Ao ', 'Fan ', 'Yi ', 'Hui ', 'Xuan ', 'Dao ']

Documentation des variables

◆ return

return[ 'Zhui ', 'Zi ', 'Ke ', 'Xiang ', 'Jian ', 'Mian ', 'Lan ', 'Ti ', 'Miao ', 'Qi ', 'Yun ', 'Hui ', 'Si ', 'Duo ', 'Duan ', 'Bian ', 'Xian ', 'Gou ', 'Zhui ', 'Huan ', 'Di ', 'Lu ', 'Bian ', 'Min ', 'Yuan ', 'Jin ', 'Fu ', 'Ru ', 'Zhen ', 'Feng ', 'Shuai ', 'Gao ', 'Chan ', 'Li ', 'Yi ', 'Jian ', 'Bin ', 'Piao ', 'Man ', 'Lei ', 'Ying ', 'Suo ', 'Mou ', 'Sao ', 'Xie ', 'Liao ', 'Shan ', 'Zeng ', 'Jiang ', 'Qian ', 'Zao ', 'Huan ', 'Jiao ', 'Zuan ', 'Fou ', 'Xie ', 'Gang ', 'Fou ', 'Que ', 'Fou ', 'Kaakeru ', 'Bo ', 'Ping ', 'Hou ', '[?] ', 'Gang ', 'Ying ', 'Ying ', 'Qing ', 'Xia ', 'Guan ', 'Zun ', 'Tan ', 'Chang ', 'Qi ', 'Weng ', 'Ying ', 'Lei ', 'Tan ', 'Lu ', 'Guan ', 'Wang ', 'Wang ', 'Gang ', 'Wang ', 'Han ', '[?] ', 'Luo ', 'Fu ', 'Mi ', 'Fa ', 'Gu ', 'Zhu ', 'Ju ', 'Mao ', 'Gu ', 'Min ', 'Gang ', 'Ba ', 'Gua ', 'Ti ', 'Juan ', 'Fu ', 'Lin ', 'Yan ', 'Zhao ', 'Zui ', 'Gua ', 'Zhuo ', 'Yu ', 'Zhi ', 'An ', 'Fa ', 'Nan ', 'Shu ', 'Si ', 'Pi ', 'Ma ', 'Liu ', 'Ba ', 'Fa ', 'Li ', 'Chao ', 'Wei ', 'Bi ', 'Ji ', 'Zeng ', 'Tong ', 'Liu ', 'Ji ', 'Juan ', 'Mi ', 'Zhao ', 'Luo ', 'Pi ', 'Ji ', 'Ji ', 'Luan ', 'Yang ', 'Mie ', 'Qiang ', 'Ta ', 'Mei ', 'Yang ', 'You ', 'You ', 'Fen ', 'Ba ', 'Gao ', 'Yang ', 'Gu ', 'Qiang ', 'Zang ', 'Gao ', 'Ling ', 'Yi ', 'Zhu ', 'Di ', 'Xiu ', 'Qian ', 'Yi ', 'Xian ', 'Rong ', 'Qun ', 'Qun ', 'Qian ', 'Huan ', 'Zui ', 'Xian ', 'Yi ', 'Yashinau ', 'Qiang ', 'Xian ', 'Yu ', 'Geng ', 'Jie ', 'Tang ', 'Yuan ', 'Xi ', 'Fan ', 'Shan ', 'Fen ', 'Shan ', 'Lian ', 'Lei ', 'Geng ', 'Nou ', 'Qiang ', 'Chan ', 'Yu ', 'Gong ', 'Yi ', 'Chong ', 'Weng ', 'Fen ', 'Hong ', 'Chi ', 'Chi ', 'Cui ', 'Fu ', 'Xia ', 'Pen ', 'Yi ', 'La ', 'Yi ', 'Pi ', 'Ling ', 'Liu ', 'Zhi ', 'Qu ', 'Xi ', 'Xie ', 'Xiang ', 'Xi ', 'Xi ', 'Qi ', 'Qiao ', 'Hui ', 'Hui ', 'Xiao ', 'Se ', 'Hong ', 'Jiang ', 'Di ', 'Cui ', 'Fei ', 'Tao ', 'Sha ', 'Chi ', 'Zhu ', 'Jian ', 'Xuan ', 'Shi ', 'Pian ', 'Zong ', 'Wan ', 'Hui ', 'Hou ', 'He ', 'He ', 'Han ', 'Ao ', 'Piao ', 'Yi ', 'Lian ', 'Qu ', '[?] ', 'Lin ', 'Pen ', 'Qiao ', 'Ao ', 'Fan ', 'Yi ', 'Hui ', 'Xuan ', 'Dao ']


Joomla CMS: Référence du fichier templates.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/helpers/templates.php

Structures de données

class TemplatesHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_content
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_content/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Content\Site\Service


Joomla CMS: Référence du fichier Shortcut.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Shortcut.php

Structures de données

class Shortcut

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Shortcut\Extension


Joomla CMS: Référence du fichier SampledataHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_sampledata
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier SampledataHelper.php

Structures de données

class SampledataHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Sampledata\Administrator\Helper


Joomla CMS: Référence du fichier PuTTY.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Keys/PuTTY.php

Structures de données

class PuTTY

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier TransitionController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TransitionController.php

Structures de données

class TransitionController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier x0fc.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0fc.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier Parser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Indexer/Parser.php

Structures de données

class Parser

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/EC/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

EC
phpseclib3\Crypt\EC


Joomla CMS: Référence du fichier QueryMonitorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
Structures de données | Espaces de nommage
Référence du fichier QueryMonitorInterface.php

Structures de données

interface QueryMonitorInterface

Espaces de nommage

Joomla\Database


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/google/recaptcha/src/ReCaptcha/Response.php

Structures de données

class Response

Espaces de nommage

ReCaptcha


Joomla CMS: Référence du fichier Renderable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier Renderable.php

Structures de données

interface Renderable

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • NorwegianBokmal
Structures de données | Espaces de nommage
Référence du fichier NorwegianBokmal/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\NorwegianBokmal


Joomla CMS: Référence du fichier section.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable
Espaces de nommage | Variables
Référence du fichier section.php

Espaces de nommage

Joomla\Site

Variables

endif
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier XChaCha20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier src/Core/XChaCha20.php

Structures de données

class ParagonIE_Sodium_Core_XChaCha20


Joomla CMS: Référence du fichier TemplatesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_config
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_config/src/Model/TemplatesModel.php

Structures de données

class TemplatesModel

Espaces de nommage

Joomla\Site
Joomla\Component\Config\Site\Model


Joomla CMS: Référence du fichier RC2CBCParameter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RC2CBCParameter.php

Structures de données

class RC2CBCParameter

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x06c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06c.php

Variables

return ['Lu ', 'Mu ', 'Li ', 'Tong ', 'Rong ', 'Chang ', 'Pu ', 'Luo ', 'Zhan ', 'Sao ', 'Zhan ', 'Meng ', 'Luo ', 'Qu ', 'Die ', 'Shi ', 'Di ', 'Min ', 'Jue ', 'Mang ', 'Qi ', 'Pie ', 'Nai ', 'Qi ', 'Dao ', 'Xian ', 'Chuan ', 'Fen ', 'Ri ', 'Nei ', '[?] ', 'Fu ', 'Shen ', 'Dong ', 'Qing ', 'Qi ', 'Yin ', 'Xi ', 'Hai ', 'Yang ', 'An ', 'Ya ', 'Ke ', 'Qing ', 'Ya ', 'Dong ', 'Dan ', 'Lu ', 'Qing ', 'Yang ', 'Yun ', 'Yun ', 'Shui ', 'San ', 'Zheng ', 'Bing ', 'Yong ', 'Dang ', 'Shitamizu ', 'Le ', 'Ni ', 'Tun ', 'Fan ', 'Gui ', 'Ting ', 'Zhi ', 'Qiu ', 'Bin ', 'Ze ', 'Mian ', 'Cuan ', 'Hui ', 'Diao ', 'Yi ', 'Cha ', 'Zhuo ', 'Chuan ', 'Wan ', 'Fan ', 'Dai ', 'Xi ', 'Tuo ', 'Mang ', 'Qiu ', 'Qi ', 'Shan ', 'Pai ', 'Han ', 'Qian ', 'Wu ', 'Wu ', 'Xun ', 'Si ', 'Ru ', 'Gong ', 'Jiang ', 'Chi ', 'Wu ', 'Tsuchi ', '[?] ', 'Tang ', 'Zhi ', 'Chi ', 'Qian ', 'Mi ', 'Yu ', 'Wang ', 'Qing ', 'Jing ', 'Rui ', 'Jun ', 'Hong ', 'Tai ', 'Quan ', 'Ji ', 'Bian ', 'Bian ', 'Gan ', 'Wen ', 'Zhong ', 'Fang ', 'Xiong ', 'Jue ', 'Hang ', 'Niou ', 'Qi ', 'Fen ', 'Xu ', 'Xu ', 'Qin ', 'Yi ', 'Wo ', 'Yun ', 'Yuan ', 'Hang ', 'Yan ', 'Chen ', 'Chen ', 'Dan ', 'You ', 'Dun ', 'Hu ', 'Huo ', 'Qie ', 'Mu ', 'Rou ', 'Mei ', 'Ta ', 'Mian ', 'Wu ', 'Chong ', 'Tian ', 'Bi ', 'Sha ', 'Zhi ', 'Pei ', 'Pan ', 'Zhui ', 'Za ', 'Gou ', 'Liu ', 'Mei ', 'Ze ', 'Feng ', 'Ou ', 'Li ', 'Lun ', 'Cang ', 'Feng ', 'Wei ', 'Hu ', 'Mo ', 'Mei ', 'Shu ', 'Ju ', 'Zan ', 'Tuo ', 'Tuo ', 'Tuo ', 'He ', 'Li ', 'Mi ', 'Yi ', 'Fa ', 'Fei ', 'You ', 'Tian ', 'Zhi ', 'Zhao ', 'Gu ', 'Zhan ', 'Yan ', 'Si ', 'Kuang ', 'Jiong ', 'Ju ', 'Xie ', 'Qiu ', 'Yi ', 'Jia ', 'Zhong ', 'Quan ', 'Bo ', 'Hui ', 'Mi ', 'Ben ', 'Zhuo ', 'Chu ', 'Le ', 'You ', 'Gu ', 'Hong ', 'Gan ', 'Fa ', 'Mao ', 'Si ', 'Hu ', 'Ping ', 'Ci ', 'Fan ', 'Chi ', 'Su ', 'Ning ', 'Cheng ', 'Ling ', 'Pao ', 'Bo ', 'Qi ', 'Si ', 'Ni ', 'Ju ', 'Yue ', 'Zhu ', 'Sheng ', 'Lei ', 'Xuan ', 'Xue ', 'Fu ', 'Pan ', 'Min ', 'Tai ', 'Yang ', 'Ji ', 'Yong ', 'Guan ', 'Beng ', 'Xue ', 'Long ', 'Lu ', '[?] ', 'Bo ', 'Xie ', 'Po ', 'Ze ', 'Jing ', 'Yin ']

Documentation des variables

◆ return

return[ 'Lu ', 'Mu ', 'Li ', 'Tong ', 'Rong ', 'Chang ', 'Pu ', 'Luo ', 'Zhan ', 'Sao ', 'Zhan ', 'Meng ', 'Luo ', 'Qu ', 'Die ', 'Shi ', 'Di ', 'Min ', 'Jue ', 'Mang ', 'Qi ', 'Pie ', 'Nai ', 'Qi ', 'Dao ', 'Xian ', 'Chuan ', 'Fen ', 'Ri ', 'Nei ', '[?] ', 'Fu ', 'Shen ', 'Dong ', 'Qing ', 'Qi ', 'Yin ', 'Xi ', 'Hai ', 'Yang ', 'An ', 'Ya ', 'Ke ', 'Qing ', 'Ya ', 'Dong ', 'Dan ', 'Lu ', 'Qing ', 'Yang ', 'Yun ', 'Yun ', 'Shui ', 'San ', 'Zheng ', 'Bing ', 'Yong ', 'Dang ', 'Shitamizu ', 'Le ', 'Ni ', 'Tun ', 'Fan ', 'Gui ', 'Ting ', 'Zhi ', 'Qiu ', 'Bin ', 'Ze ', 'Mian ', 'Cuan ', 'Hui ', 'Diao ', 'Yi ', 'Cha ', 'Zhuo ', 'Chuan ', 'Wan ', 'Fan ', 'Dai ', 'Xi ', 'Tuo ', 'Mang ', 'Qiu ', 'Qi ', 'Shan ', 'Pai ', 'Han ', 'Qian ', 'Wu ', 'Wu ', 'Xun ', 'Si ', 'Ru ', 'Gong ', 'Jiang ', 'Chi ', 'Wu ', 'Tsuchi ', '[?] ', 'Tang ', 'Zhi ', 'Chi ', 'Qian ', 'Mi ', 'Yu ', 'Wang ', 'Qing ', 'Jing ', 'Rui ', 'Jun ', 'Hong ', 'Tai ', 'Quan ', 'Ji ', 'Bian ', 'Bian ', 'Gan ', 'Wen ', 'Zhong ', 'Fang ', 'Xiong ', 'Jue ', 'Hang ', 'Niou ', 'Qi ', 'Fen ', 'Xu ', 'Xu ', 'Qin ', 'Yi ', 'Wo ', 'Yun ', 'Yuan ', 'Hang ', 'Yan ', 'Chen ', 'Chen ', 'Dan ', 'You ', 'Dun ', 'Hu ', 'Huo ', 'Qie ', 'Mu ', 'Rou ', 'Mei ', 'Ta ', 'Mian ', 'Wu ', 'Chong ', 'Tian ', 'Bi ', 'Sha ', 'Zhi ', 'Pei ', 'Pan ', 'Zhui ', 'Za ', 'Gou ', 'Liu ', 'Mei ', 'Ze ', 'Feng ', 'Ou ', 'Li ', 'Lun ', 'Cang ', 'Feng ', 'Wei ', 'Hu ', 'Mo ', 'Mei ', 'Shu ', 'Ju ', 'Zan ', 'Tuo ', 'Tuo ', 'Tuo ', 'He ', 'Li ', 'Mi ', 'Yi ', 'Fa ', 'Fei ', 'You ', 'Tian ', 'Zhi ', 'Zhao ', 'Gu ', 'Zhan ', 'Yan ', 'Si ', 'Kuang ', 'Jiong ', 'Ju ', 'Xie ', 'Qiu ', 'Yi ', 'Jia ', 'Zhong ', 'Quan ', 'Bo ', 'Hui ', 'Mi ', 'Ben ', 'Zhuo ', 'Chu ', 'Le ', 'You ', 'Gu ', 'Hong ', 'Gan ', 'Fa ', 'Mao ', 'Si ', 'Hu ', 'Ping ', 'Ci ', 'Fan ', 'Chi ', 'Su ', 'Ning ', 'Cheng ', 'Ling ', 'Pao ', 'Bo ', 'Qi ', 'Si ', 'Ni ', 'Ju ', 'Yue ', 'Zhu ', 'Sheng ', 'Lei ', 'Xuan ', 'Xue ', 'Fu ', 'Pan ', 'Min ', 'Tai ', 'Yang ', 'Ji ', 'Yong ', 'Guan ', 'Beng ', 'Xue ', 'Long ', 'Lu ', '[?] ', 'Bo ', 'Xie ', 'Po ', 'Ze ', 'Jing ', 'Yin ']


Joomla CMS: Référence du fichier traces_text.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier traces_text.html.php

Variables

if ( $numExceptions > 1) = ($parts = explode('\\', $exception['class'])) ? end($parts) : ''

Documentation des variables

◆ if

if($numExceptions > 1) = ($parts = explode('\\', $exception['class'])) ? end($parts) : ''


Joomla CMS: Référence du fichier PhpHttpDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
Structures de données | Espaces de nommage
Référence du fichier PhpHttpDriver.php

Structures de données

class PhpHttpDriver

Espaces de nommage

DebugBar


Joomla CMS: Référence du fichier prime192v3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime192v3.php

Structures de données

class prime192v3

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier SignedWith.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier SignedWith.php

Structures de données

class SignedWith

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier RelativeStream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier RelativeStream.php

Structures de données

class RelativeStream

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier platform_check.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • composer
Variables
Référence du fichier platform_check.php

Variables

$issues = array()

Documentation des variables

◆ $issues

$issues = array()


Joomla CMS: Référence du fichier UseractiveField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier UseractiveField.php

Structures de données

class UseractiveField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ResultTypeStringAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeStringAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeStringAware


Joomla CMS: Référence du fichier publishing.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • workflow
  • publishing
Structures de données | Espaces de nommage
Référence du fichier publishing.php

Structures de données

class PlgWorkflowPublishing

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PluginTypeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PluginTypeField.php

Structures de données

class PluginTypeField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Field


Joomla CMS: Référence du fichier terms.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • terms
Structures de données | Espaces de nommage
Référence du fichier terms.php

Structures de données

class PlgUserTerms

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PhpInputStream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier PhpInputStream.php

Structures de données

class PhpInputStream

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier x006.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x006.php

Variables

return ['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ',', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ';', '[?]', '[?]', '[?]', '?', '[?]', '', 'a', 'a', 'w\'', '', 'y\'', '', 'b', '@', 't', 'th', 'j', 'H', 'kh', 'd', 'dh', 'r', 'z', 's', 'sh', 'S', 'D', 'T', 'Z', '`', 'G', '[?]', '[?]', '[?]', '[?]', '[?]', '', 'f', 'q', 'k', 'l', 'm', 'n', 'h', 'w', '~', 'y', 'an', 'un', 'in', 'a', 'u', 'i', 'W', '', '', '\'', '\'', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '%', '.', ',', ' *', '[?]', '[?]', '', '\'', '\'', '\'', '', '\'', '\ 'w', '\ 'u', '\ 'y', 'tt', 'tth', 'b', 't', 'T', 'p', 'th', 'bh', '\ 'h', 'H', 'ny', 'dy', 'H', 'ch', 'cch', 'dd', 'D', 'D', 'Dt', 'dh', 'ddh', 'd', 'D', 'D', 'rr', 'R', 'R', 'R', 'R', 'R', 'R', 'j', 'R', 'S', 'S', 'S', 'S', 'S', 'T', 'GH', 'F', 'F', 'F', 'v', 'f', 'ph', 'Q', 'Q', 'kh', 'k', 'K', 'K', 'ng', 'K', 'g', 'G', 'N', 'G', 'G', 'G', 'L', 'L', 'L', 'L', 'N', 'N', 'N', 'N', 'N', 'h', 'Ch', 'hy', 'h', 'H', '@', 'W', 'oe', 'oe', 'u', 'yu', 'yu', 'W', 'v', 'y', 'Y', 'Y', 'W', '', '', 'y', 'y\'', '.', 'ae', '', '', '', '', '', '', '', '@', '#', '', '', '', '', '', '', '', '', '', '', '^', '', '', '', '', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'Sh', 'D', 'Gh', '&', '+m', 'h']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ',', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ';', '[?]', '[?]', '[?]', '?', '[?]', '', 'a', 'a', 'w\'', '', 'y\'', '', 'b', '@', 't', 'th', 'j', 'H', 'kh', 'd', 'dh', 'r', 'z', 's', 'sh', 'S', 'D', 'T', 'Z', '`', 'G', '[?]', '[?]', '[?]', '[?]', '[?]', '', 'f', 'q', 'k', 'l', 'm', 'n', 'h', 'w', '~', 'y', 'an', 'un', 'in', 'a', 'u', 'i', 'W', '', '', '\'', '\'', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', '%', '.', ',', ' *', '[?]', '[?]', '', '\'', '\'', '\'', '', '\'', '\ 'w', '\ 'u', '\ 'y', 'tt', 'tth', 'b', 't', 'T', 'p', 'th', 'bh', '\ 'h', 'H', 'ny', 'dy', 'H', 'ch', 'cch', 'dd', 'D', 'D', 'Dt', 'dh', 'ddh', 'd', 'D', 'D', 'rr', 'R', 'R', 'R', 'R', 'R', 'R', 'j', 'R', 'S', 'S', 'S', 'S', 'S', 'T', 'GH', 'F', 'F', 'F', 'v', 'f', 'ph', 'Q', 'Q', 'kh', 'k', 'K', 'K', 'ng', 'K', 'g', 'G', 'N', 'G', 'G', 'G', 'L', 'L', 'L', 'L', 'N', 'N', 'N', 'N', 'N', 'h', 'Ch', 'hy', 'h', 'H', '@', 'W', 'oe', 'oe', 'u', 'yu', 'yu', 'W', 'v', 'y', 'Y', 'Y', 'W', '', '', 'y', 'y\'', '.', 'ae', '', '', '', '', '', '', '', '@', '#', '', '', '', '', '', '', '', '', '', '', '^', '', '', '', '', '[?]', '[?]', '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'Sh', 'D', 'Gh', '&', '+m', 'h']


Joomla CMS: Référence du fichier Uri.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Uri
Structures de données | Espaces de nommage
Référence du fichier src/Uri/Uri.php

Structures de données

class Uri

Espaces de nommage

Joomla\CMS\Uri


Joomla CMS: Référence du fichier PKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Keys/PKCS1.php

Structures de données

class PKCS1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier PluginsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier PluginsModel.php

Structures de données

class PluginsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Model


Joomla CMS: Référence du fichier RSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/RSA.php

Structures de données

class RSA

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier RemindModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_users/src/Model/RemindModel.php

Structures de données

class RemindModel

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier UpdateController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_installer/src/Controller/UpdateController.php

Structures de données

class UpdateController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier x07b.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07b.php

Variables

return ['Mang ', 'Zhu ', 'Utsubo ', 'Du ', 'Ji ', 'Xiao ', 'Ba ', 'Suan ', 'Ji ', 'Zhen ', 'Zhao ', 'Sun ', 'Ya ', 'Zhui ', 'Yuan ', 'Hu ', 'Gang ', 'Xiao ', 'Cen ', 'Pi ', 'Bi ', 'Jian ', 'Yi ', 'Dong ', 'Shan ', 'Sheng ', 'Xia ', 'Di ', 'Zhu ', 'Na ', 'Chi ', 'Gu ', 'Li ', 'Qie ', 'Min ', 'Bao ', 'Tiao ', 'Si ', 'Fu ', 'Ce ', 'Ben ', 'Pei ', 'Da ', 'Zi ', 'Di ', 'Ling ', 'Ze ', 'Nu ', 'Fu ', 'Gou ', 'Fan ', 'Jia ', 'Ge ', 'Fan ', 'Shi ', 'Mao ', 'Po ', 'Sey ', 'Jian ', 'Qiong ', 'Long ', 'Souke ', 'Bian ', 'Luo ', 'Gui ', 'Qu ', 'Chi ', 'Yin ', 'Yao ', 'Xian ', 'Bi ', 'Qiong ', 'Gua ', 'Deng ', 'Jiao ', 'Jin ', 'Quan ', 'Sun ', 'Ru ', 'Fa ', 'Kuang ', 'Zhu ', 'Tong ', 'Ji ', 'Da ', 'Xing ', 'Ce ', 'Zhong ', 'Kou ', 'Lai ', 'Bi ', 'Shai ', 'Dang ', 'Zheng ', 'Ce ', 'Fu ', 'Yun ', 'Tu ', 'Pa ', 'Li ', 'Lang ', 'Ju ', 'Guan ', 'Jian ', 'Han ', 'Tong ', 'Xia ', 'Zhi ', 'Cheng ', 'Suan ', 'Shi ', 'Zhu ', 'Zuo ', 'Xiao ', 'Shao ', 'Ting ', 'Ce ', 'Yan ', 'Gao ', 'Kuai ', 'Gan ', 'Chou ', 'Kago ', 'Gang ', 'Yun ', 'O ', 'Qian ', 'Xiao ', 'Jian ', 'Pu ', 'Lai ', 'Zou ', 'Bi ', 'Bi ', 'Bi ', 'Ge ', 'Chi ', 'Guai ', 'Yu ', 'Jian ', 'Zhao ', 'Gu ', 'Chi ', 'Zheng ', 'Jing ', 'Sha ', 'Zhou ', 'Lu ', 'Bo ', 'Ji ', 'Lin ', 'Suan ', 'Jun ', 'Fu ', 'Zha ', 'Gu ', 'Kong ', 'Qian ', 'Quan ', 'Jun ', 'Chui ', 'Guan ', 'Yuan ', 'Ce ', 'Ju ', 'Bo ', 'Ze ', 'Qie ', 'Tuo ', 'Luo ', 'Dan ', 'Xiao ', 'Ruo ', 'Jian ', 'Xuan ', 'Bian ', 'Sun ', 'Xiang ', 'Xian ', 'Ping ', 'Zhen ', 'Sheng ', 'Hu ', 'Shi ', 'Zhu ', 'Yue ', 'Chun ', 'Lu ', 'Wu ', 'Dong ', 'Xiao ', 'Ji ', 'Jie ', 'Huang ', 'Xing ', 'Mei ', 'Fan ', 'Chui ', 'Zhuan ', 'Pian ', 'Feng ', 'Zhu ', 'Hong ', 'Qie ', 'Hou ', 'Qiu ', 'Miao ', 'Qian ', '[?] ', 'Kui ', 'Sik ', 'Lou ', 'Yun ', 'He ', 'Tang ', 'Yue ', 'Chou ', 'Gao ', 'Fei ', 'Ruo ', 'Zheng ', 'Gou ', 'Nie ', 'Qian ', 'Xiao ', 'Cuan ', 'Gong ', 'Pang ', 'Du ', 'Li ', 'Bi ', 'Zhuo ', 'Chu ', 'Shai ', 'Chi ', 'Zhu ', 'Qiang ', 'Long ', 'Lan ', 'Jian ', 'Bu ', 'Li ', 'Hui ', 'Bi ', 'Di ', 'Cong ', 'Yan ', 'Peng ', 'Sen ', 'Zhuan ', 'Pai ', 'Piao ', 'Dou ', 'Yu ', 'Mie ', 'Zhuan ']

Documentation des variables

◆ return

return[ 'Mang ', 'Zhu ', 'Utsubo ', 'Du ', 'Ji ', 'Xiao ', 'Ba ', 'Suan ', 'Ji ', 'Zhen ', 'Zhao ', 'Sun ', 'Ya ', 'Zhui ', 'Yuan ', 'Hu ', 'Gang ', 'Xiao ', 'Cen ', 'Pi ', 'Bi ', 'Jian ', 'Yi ', 'Dong ', 'Shan ', 'Sheng ', 'Xia ', 'Di ', 'Zhu ', 'Na ', 'Chi ', 'Gu ', 'Li ', 'Qie ', 'Min ', 'Bao ', 'Tiao ', 'Si ', 'Fu ', 'Ce ', 'Ben ', 'Pei ', 'Da ', 'Zi ', 'Di ', 'Ling ', 'Ze ', 'Nu ', 'Fu ', 'Gou ', 'Fan ', 'Jia ', 'Ge ', 'Fan ', 'Shi ', 'Mao ', 'Po ', 'Sey ', 'Jian ', 'Qiong ', 'Long ', 'Souke ', 'Bian ', 'Luo ', 'Gui ', 'Qu ', 'Chi ', 'Yin ', 'Yao ', 'Xian ', 'Bi ', 'Qiong ', 'Gua ', 'Deng ', 'Jiao ', 'Jin ', 'Quan ', 'Sun ', 'Ru ', 'Fa ', 'Kuang ', 'Zhu ', 'Tong ', 'Ji ', 'Da ', 'Xing ', 'Ce ', 'Zhong ', 'Kou ', 'Lai ', 'Bi ', 'Shai ', 'Dang ', 'Zheng ', 'Ce ', 'Fu ', 'Yun ', 'Tu ', 'Pa ', 'Li ', 'Lang ', 'Ju ', 'Guan ', 'Jian ', 'Han ', 'Tong ', 'Xia ', 'Zhi ', 'Cheng ', 'Suan ', 'Shi ', 'Zhu ', 'Zuo ', 'Xiao ', 'Shao ', 'Ting ', 'Ce ', 'Yan ', 'Gao ', 'Kuai ', 'Gan ', 'Chou ', 'Kago ', 'Gang ', 'Yun ', 'O ', 'Qian ', 'Xiao ', 'Jian ', 'Pu ', 'Lai ', 'Zou ', 'Bi ', 'Bi ', 'Bi ', 'Ge ', 'Chi ', 'Guai ', 'Yu ', 'Jian ', 'Zhao ', 'Gu ', 'Chi ', 'Zheng ', 'Jing ', 'Sha ', 'Zhou ', 'Lu ', 'Bo ', 'Ji ', 'Lin ', 'Suan ', 'Jun ', 'Fu ', 'Zha ', 'Gu ', 'Kong ', 'Qian ', 'Quan ', 'Jun ', 'Chui ', 'Guan ', 'Yuan ', 'Ce ', 'Ju ', 'Bo ', 'Ze ', 'Qie ', 'Tuo ', 'Luo ', 'Dan ', 'Xiao ', 'Ruo ', 'Jian ', 'Xuan ', 'Bian ', 'Sun ', 'Xiang ', 'Xian ', 'Ping ', 'Zhen ', 'Sheng ', 'Hu ', 'Shi ', 'Zhu ', 'Yue ', 'Chun ', 'Lu ', 'Wu ', 'Dong ', 'Xiao ', 'Ji ', 'Jie ', 'Huang ', 'Xing ', 'Mei ', 'Fan ', 'Chui ', 'Zhuan ', 'Pian ', 'Feng ', 'Zhu ', 'Hong ', 'Qie ', 'Hou ', 'Qiu ', 'Miao ', 'Qian ', '[?] ', 'Kui ', 'Sik ', 'Lou ', 'Yun ', 'He ', 'Tang ', 'Yue ', 'Chou ', 'Gao ', 'Fei ', 'Ruo ', 'Zheng ', 'Gou ', 'Nie ', 'Qian ', 'Xiao ', 'Cuan ', 'Gong ', 'Pang ', 'Du ', 'Li ', 'Bi ', 'Zhuo ', 'Chu ', 'Shai ', 'Chi ', 'Zhu ', 'Qiang ', 'Long ', 'Lan ', 'Jian ', 'Bu ', 'Li ', 'Hui ', 'Bi ', 'Di ', 'Cong ', 'Yan ', 'Peng ', 'Sen ', 'Zhuan ', 'Pai ', 'Piao ', 'Dou ', 'Yu ', 'Mie ', 'Zhuan ']


Joomla CMS: Référence du fichier phpversioncheck.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • quickicon
  • phpversioncheck
Structures de données | Espaces de nommage
Référence du fichier phpversioncheck.php

Structures de données

class PlgQuickiconPhpVersionCheck

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier SelectModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_modules
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_modules/src/Model/SelectModel.php

Structures de données

class SelectModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Modules\Administrator\Model


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Router/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier StandardButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
  • Button
Structures de données | Espaces de nommage
Référence du fichier StandardButton.php

Structures de données

class StandardButton

Espaces de nommage

Joomla\CMS\Toolbar\Button


Joomla CMS: Référence du fichier RS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/RS384.php

Structures de données

class RS384

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_users/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Service


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_fields/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x01f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x01f.php

Variables

return ['a', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'e', 'e', 'e', 'e', 'e', 'e', '[?]', '[?]', 'E', 'E', 'E', 'E', 'E', 'E', '[?]', '[?]', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'i', 'i', 'i', 'i', 'i', 'i', 'i', 'i', 'I', 'I', 'I', 'I', 'I', 'I', 'I', 'I', 'o', 'o', 'o', 'o', 'o', 'o', '[?]', '[?]', 'O', 'O', 'O', 'O', 'O', 'O', '[?]', '[?]', 'u', 'u', 'u', 'u', 'u', 'u', 'u', 'u', '[?]', 'U', '[?]', 'U', '[?]', 'U', '[?]', 'U', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'a', 'a', 'e', 'e', 'e', 'e', 'i', 'i', 'o', 'o', 'u', 'u', 'o', 'o', '[?]', '[?]', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'a', 'a', 'a', 'a', 'a', '[?]', 'a', 'a', 'A', 'A', 'A', 'A', 'A', '\'', 'i', '\'', '~', '"~', 'e', 'e', 'e', '[?]', 'e', 'e', 'E', 'E', 'E', 'E', 'E', '\', '\', '\', 'i', 'i', 'i', 'i', '[?]', '[?]', 'i', 'i', 'I', 'I', 'I', 'I', '[?]', '`\, '`\, '`~', 'u', 'u', 'u', 'u', 'R', 'R', 'u', 'u', 'U', 'U', 'U', 'U', 'R', '"`', '"\, '`', '[?]', '[?]', 'o', 'o', 'o', '[?]', 'o', 'o', 'O', 'O', 'O', 'O', 'O', '\, '`', '[?]']

Documentation des variables

◆ return

return[ 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'e', 'e', 'e', 'e', 'e', 'e', '[?]', '[?]', 'E', 'E', 'E', 'E', 'E', 'E', '[?]', '[?]', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'i', 'i', 'i', 'i', 'i', 'i', 'i', 'i', 'I', 'I', 'I', 'I', 'I', 'I', 'I', 'I', 'o', 'o', 'o', 'o', 'o', 'o', '[?]', '[?]', 'O', 'O', 'O', 'O', 'O', 'O', '[?]', '[?]', 'u', 'u', 'u', 'u', 'u', 'u', 'u', 'u', '[?]', 'U', '[?]', 'U', '[?]', 'U', '[?]', 'U', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'a', 'a', 'e', 'e', 'e', 'e', 'i', 'i', 'o', 'o', 'u', 'u', 'o', 'o', '[?]', '[?]', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'a', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'A', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'e', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'E', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'o', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'O', 'a', 'a', 'a', 'a', 'a', '[?]', 'a', 'a', 'A', 'A', 'A', 'A', 'A', '\'', 'i', '\'', '~', '"~', 'e', 'e', 'e', '[?]', 'e', 'e', 'E', 'E', 'E', 'E', 'E', '\`', '\\', '\~', 'i', 'i', 'i', 'i', '[?]', '[?]', 'i', 'i', 'I', 'I', 'I', 'I', '[?]', '`\', '`\', '`~', 'u', 'u', 'u', 'u', 'R', 'R', 'u', 'u', 'U', 'U', 'U', 'U', 'R', '"`', '"\', '`', '[?]', '[?]', 'o', 'o', 'o', '[?]', 'o', 'o', 'O', 'O', 'O', 'O', 'O', '\', '`', '[?]']


Joomla CMS: Référence du fichier ToolbarButton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Structures de données | Espaces de nommage
Référence du fichier ToolbarButton.php

Structures de données

class ToolbarButton

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier WebauthnField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier WebauthnField.php

Structures de données

class WebauthnField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\Field


Joomla CMS: Référence du fichier RequestsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier RequestsModel.php

Structures de données

class RequestsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier x04f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x04f.php

Variables

return ['Zhong ', 'Qi ', 'Pei ', 'Yu ', 'Diao ', 'Dun ', 'Wen ', 'Yi ', 'Xin ', 'Kang ', 'Yi ', 'Ji ', 'Ai ', 'Wu ', 'Ji ', 'Fu ', 'Fa ', 'Xiu ', 'Jin ', 'Bei ', 'Dan ', 'Fu ', 'Tang ', 'Zhong ', 'You ', 'Huo ', 'Hui ', 'Yu ', 'Cui ', 'Chuan ', 'San ', 'Wei ', 'Chuan ', 'Che ', 'Ya ', 'Xian ', 'Shang ', 'Chang ', 'Lun ', 'Cang ', 'Xun ', 'Xin ', 'Wei ', 'Zhu ', '[?] ', 'Xuan ', 'Nu ', 'Bo ', 'Gu ', 'Ni ', 'Ni ', 'Xie ', 'Ban ', 'Xu ', 'Ling ', 'Zhou ', 'Shen ', 'Qu ', 'Si ', 'Beng ', 'Si ', 'Jia ', 'Pi ', 'Yi ', 'Si ', 'Ai ', 'Zheng ', 'Dian ', 'Han ', 'Mai ', 'Dan ', 'Zhu ', 'Bu ', 'Qu ', 'Bi ', 'Shao ', 'Ci ', 'Wei ', 'Di ', 'Zhu ', 'Zuo ', 'You ', 'Yang ', 'Ti ', 'Zhan ', 'He ', 'Bi ', 'Tuo ', 'She ', 'Yu ', 'Yi ', 'Fo ', 'Zuo ', 'Kou ', 'Ning ', 'Tong ', 'Ni ', 'Xuan ', 'Qu ', 'Yong ', 'Wa ', 'Qian ', '[?] ', 'Ka ', '[?] ', 'Pei ', 'Huai ', 'He ', 'Lao ', 'Xiang ', 'Ge ', 'Yang ', 'Bai ', 'Fa ', 'Ming ', 'Jia ', 'Er ', 'Bing ', 'Ji ', 'Hen ', 'Huo ', 'Gui ', 'Quan ', 'Tiao ', 'Jiao ', 'Ci ', 'Yi ', 'Shi ', 'Xing ', 'Shen ', 'Tuo ', 'Kan ', 'Zhi ', 'Gai ', 'Lai ', 'Yi ', 'Chi ', 'Kua ', 'Guang ', 'Li ', 'Yin ', 'Shi ', 'Mi ', 'Zhu ', 'Xu ', 'You ', 'An ', 'Lu ', 'Mou ', 'Er ', 'Lun ', 'Tong ', 'Cha ', 'Chi ', 'Xun ', 'Gong ', 'Zhou ', 'Yi ', 'Ru ', 'Jian ', 'Xia ', 'Jia ', 'Zai ', 'Lu ', 'Ko ', 'Jiao ', 'Zhen ', 'Ce ', 'Qiao ', 'Kuai ', 'Chai ', 'Ning ', 'Nong ', 'Jin ', 'Wu ', 'Hou ', 'Jiong ', 'Cheng ', 'Zhen ', 'Zuo ', 'Chou ', 'Qin ', 'Lu ', 'Ju ', 'Shu ', 'Ting ', 'Shen ', 'Tuo ', 'Bo ', 'Nan ', 'Hao ', 'Bian ', 'Tui ', 'Yu ', 'Xi ', 'Cu ', 'E ', 'Qiu ', 'Xu ', 'Kuang ', 'Ku ', 'Wu ', 'Jun ', 'Yi ', 'Fu ', 'Lang ', 'Zu ', 'Qiao ', 'Li ', 'Yong ', 'Hun ', 'Jing ', 'Xian ', 'San ', 'Pai ', 'Su ', 'Fu ', 'Xi ', 'Li ', 'Fu ', 'Ping ', 'Bao ', 'Yu ', 'Si ', 'Xia ', 'Xin ', 'Xiu ', 'Yu ', 'Ti ', 'Che ', 'Chou ', '[?] ', 'Yan ', 'Lia ', 'Li ', 'Lai ', '[?] ', 'Jian ', 'Xiu ', 'Fu ', 'He ', 'Ju ', 'Xiao ', 'Pai ', 'Jian ', 'Biao ', 'Chu ', 'Fei ', 'Feng ', 'Ya ', 'An ', 'Bei ', 'Yu ', 'Xin ', 'Bi ', 'Jian ']

Documentation des variables

◆ return

return[ 'Zhong ', 'Qi ', 'Pei ', 'Yu ', 'Diao ', 'Dun ', 'Wen ', 'Yi ', 'Xin ', 'Kang ', 'Yi ', 'Ji ', 'Ai ', 'Wu ', 'Ji ', 'Fu ', 'Fa ', 'Xiu ', 'Jin ', 'Bei ', 'Dan ', 'Fu ', 'Tang ', 'Zhong ', 'You ', 'Huo ', 'Hui ', 'Yu ', 'Cui ', 'Chuan ', 'San ', 'Wei ', 'Chuan ', 'Che ', 'Ya ', 'Xian ', 'Shang ', 'Chang ', 'Lun ', 'Cang ', 'Xun ', 'Xin ', 'Wei ', 'Zhu ', '[?] ', 'Xuan ', 'Nu ', 'Bo ', 'Gu ', 'Ni ', 'Ni ', 'Xie ', 'Ban ', 'Xu ', 'Ling ', 'Zhou ', 'Shen ', 'Qu ', 'Si ', 'Beng ', 'Si ', 'Jia ', 'Pi ', 'Yi ', 'Si ', 'Ai ', 'Zheng ', 'Dian ', 'Han ', 'Mai ', 'Dan ', 'Zhu ', 'Bu ', 'Qu ', 'Bi ', 'Shao ', 'Ci ', 'Wei ', 'Di ', 'Zhu ', 'Zuo ', 'You ', 'Yang ', 'Ti ', 'Zhan ', 'He ', 'Bi ', 'Tuo ', 'She ', 'Yu ', 'Yi ', 'Fo ', 'Zuo ', 'Kou ', 'Ning ', 'Tong ', 'Ni ', 'Xuan ', 'Qu ', 'Yong ', 'Wa ', 'Qian ', '[?] ', 'Ka ', '[?] ', 'Pei ', 'Huai ', 'He ', 'Lao ', 'Xiang ', 'Ge ', 'Yang ', 'Bai ', 'Fa ', 'Ming ', 'Jia ', 'Er ', 'Bing ', 'Ji ', 'Hen ', 'Huo ', 'Gui ', 'Quan ', 'Tiao ', 'Jiao ', 'Ci ', 'Yi ', 'Shi ', 'Xing ', 'Shen ', 'Tuo ', 'Kan ', 'Zhi ', 'Gai ', 'Lai ', 'Yi ', 'Chi ', 'Kua ', 'Guang ', 'Li ', 'Yin ', 'Shi ', 'Mi ', 'Zhu ', 'Xu ', 'You ', 'An ', 'Lu ', 'Mou ', 'Er ', 'Lun ', 'Tong ', 'Cha ', 'Chi ', 'Xun ', 'Gong ', 'Zhou ', 'Yi ', 'Ru ', 'Jian ', 'Xia ', 'Jia ', 'Zai ', 'Lu ', 'Ko ', 'Jiao ', 'Zhen ', 'Ce ', 'Qiao ', 'Kuai ', 'Chai ', 'Ning ', 'Nong ', 'Jin ', 'Wu ', 'Hou ', 'Jiong ', 'Cheng ', 'Zhen ', 'Zuo ', 'Chou ', 'Qin ', 'Lu ', 'Ju ', 'Shu ', 'Ting ', 'Shen ', 'Tuo ', 'Bo ', 'Nan ', 'Hao ', 'Bian ', 'Tui ', 'Yu ', 'Xi ', 'Cu ', 'E ', 'Qiu ', 'Xu ', 'Kuang ', 'Ku ', 'Wu ', 'Jun ', 'Yi ', 'Fu ', 'Lang ', 'Zu ', 'Qiao ', 'Li ', 'Yong ', 'Hun ', 'Jing ', 'Xian ', 'San ', 'Pai ', 'Su ', 'Fu ', 'Xi ', 'Li ', 'Fu ', 'Ping ', 'Bao ', 'Yu ', 'Si ', 'Xia ', 'Xin ', 'Xiu ', 'Yu ', 'Ti ', 'Che ', 'Chou ', '[?] ', 'Yan ', 'Lia ', 'Li ', 'Lai ', '[?] ', 'Jian ', 'Xiu ', 'Fu ', 'He ', 'Ju ', 'Xiao ', 'Pai ', 'Jian ', 'Biao ', 'Chu ', 'Fei ', 'Feng ', 'Ya ', 'An ', 'Bei ', 'Yu ', 'Xin ', 'Bi ', 'Jian ']


Joomla CMS: Référence du fichier RelatedItemsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_related_items
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier RelatedItemsHelper.php

Structures de données

class RelatedItemsHelper

Espaces de nommage

Joomla\Site
Joomla\Module\RelatedItems\Site\Helper


Joomla CMS: Référence du fichier x0ac.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ac.php

Variables

return ['ga', 'gag', 'gagg', 'gags', 'gan', 'ganj', 'ganh', 'gad', 'gal', 'galg', 'galm', 'galb', 'gals', 'galt', 'galp', 'galh', 'gam', 'gab', 'gabs', 'gas', 'gass', 'gang', 'gaj', 'gac', 'gak', 'gat', 'gap', 'gah', 'gae', 'gaeg', 'gaegg', 'gaegs', 'gaen', 'gaenj', 'gaenh', 'gaed', 'gael', 'gaelg', 'gaelm', 'gaelb', 'gaels', 'gaelt', 'gaelp', 'gaelh', 'gaem', 'gaeb', 'gaebs', 'gaes', 'gaess', 'gaeng', 'gaej', 'gaec', 'gaek', 'gaet', 'gaep', 'gaeh', 'gya', 'gyag', 'gyagg', 'gyags', 'gyan', 'gyanj', 'gyanh', 'gyad', 'gyal', 'gyalg', 'gyalm', 'gyalb', 'gyals', 'gyalt', 'gyalp', 'gyalh', 'gyam', 'gyab', 'gyabs', 'gyas', 'gyass', 'gyang', 'gyaj', 'gyac', 'gyak', 'gyat', 'gyap', 'gyah', 'gyae', 'gyaeg', 'gyaegg', 'gyaegs', 'gyaen', 'gyaenj', 'gyaenh', 'gyaed', 'gyael', 'gyaelg', 'gyaelm', 'gyaelb', 'gyaels', 'gyaelt', 'gyaelp', 'gyaelh', 'gyaem', 'gyaeb', 'gyaebs', 'gyaes', 'gyaess', 'gyaeng', 'gyaej', 'gyaec', 'gyaek', 'gyaet', 'gyaep', 'gyaeh', 'geo', 'geog', 'geogg', 'geogs', 'geon', 'geonj', 'geonh', 'geod', 'geol', 'geolg', 'geolm', 'geolb', 'geols', 'geolt', 'geolp', 'geolh', 'geom', 'geob', 'geobs', 'geos', 'geoss', 'geong', 'geoj', 'geoc', 'geok', 'geot', 'geop', 'geoh', 'ge', 'geg', 'gegg', 'gegs', 'gen', 'genj', 'genh', 'ged', 'gel', 'gelg', 'gelm', 'gelb', 'gels', 'gelt', 'gelp', 'gelh', 'gem', 'geb', 'gebs', 'ges', 'gess', 'geng', 'gej', 'gec', 'gek', 'get', 'gep', 'geh', 'gyeo', 'gyeog', 'gyeogg', 'gyeogs', 'gyeon', 'gyeonj', 'gyeonh', 'gyeod', 'gyeol', 'gyeolg', 'gyeolm', 'gyeolb', 'gyeols', 'gyeolt', 'gyeolp', 'gyeolh', 'gyeom', 'gyeob', 'gyeobs', 'gyeos', 'gyeoss', 'gyeong', 'gyeoj', 'gyeoc', 'gyeok', 'gyeot', 'gyeop', 'gyeoh', 'gye', 'gyeg', 'gyegg', 'gyegs', 'gyen', 'gyenj', 'gyenh', 'gyed', 'gyel', 'gyelg', 'gyelm', 'gyelb', 'gyels', 'gyelt', 'gyelp', 'gyelh', 'gyem', 'gyeb', 'gyebs', 'gyes', 'gyess', 'gyeng', 'gyej', 'gyec', 'gyek', 'gyet', 'gyep', 'gyeh', 'go', 'gog', 'gogg', 'gogs', 'gon', 'gonj', 'gonh', 'god', 'gol', 'golg', 'golm', 'golb', 'gols', 'golt', 'golp', 'golh', 'gom', 'gob', 'gobs', 'gos', 'goss', 'gong', 'goj', 'goc', 'gok', 'got', 'gop', 'goh', 'gwa', 'gwag', 'gwagg', 'gwags']

Documentation des variables

◆ return

return[ 'ga', 'gag', 'gagg', 'gags', 'gan', 'ganj', 'ganh', 'gad', 'gal', 'galg', 'galm', 'galb', 'gals', 'galt', 'galp', 'galh', 'gam', 'gab', 'gabs', 'gas', 'gass', 'gang', 'gaj', 'gac', 'gak', 'gat', 'gap', 'gah', 'gae', 'gaeg', 'gaegg', 'gaegs', 'gaen', 'gaenj', 'gaenh', 'gaed', 'gael', 'gaelg', 'gaelm', 'gaelb', 'gaels', 'gaelt', 'gaelp', 'gaelh', 'gaem', 'gaeb', 'gaebs', 'gaes', 'gaess', 'gaeng', 'gaej', 'gaec', 'gaek', 'gaet', 'gaep', 'gaeh', 'gya', 'gyag', 'gyagg', 'gyags', 'gyan', 'gyanj', 'gyanh', 'gyad', 'gyal', 'gyalg', 'gyalm', 'gyalb', 'gyals', 'gyalt', 'gyalp', 'gyalh', 'gyam', 'gyab', 'gyabs', 'gyas', 'gyass', 'gyang', 'gyaj', 'gyac', 'gyak', 'gyat', 'gyap', 'gyah', 'gyae', 'gyaeg', 'gyaegg', 'gyaegs', 'gyaen', 'gyaenj', 'gyaenh', 'gyaed', 'gyael', 'gyaelg', 'gyaelm', 'gyaelb', 'gyaels', 'gyaelt', 'gyaelp', 'gyaelh', 'gyaem', 'gyaeb', 'gyaebs', 'gyaes', 'gyaess', 'gyaeng', 'gyaej', 'gyaec', 'gyaek', 'gyaet', 'gyaep', 'gyaeh', 'geo', 'geog', 'geogg', 'geogs', 'geon', 'geonj', 'geonh', 'geod', 'geol', 'geolg', 'geolm', 'geolb', 'geols', 'geolt', 'geolp', 'geolh', 'geom', 'geob', 'geobs', 'geos', 'geoss', 'geong', 'geoj', 'geoc', 'geok', 'geot', 'geop', 'geoh', 'ge', 'geg', 'gegg', 'gegs', 'gen', 'genj', 'genh', 'ged', 'gel', 'gelg', 'gelm', 'gelb', 'gels', 'gelt', 'gelp', 'gelh', 'gem', 'geb', 'gebs', 'ges', 'gess', 'geng', 'gej', 'gec', 'gek', 'get', 'gep', 'geh', 'gyeo', 'gyeog', 'gyeogg', 'gyeogs', 'gyeon', 'gyeonj', 'gyeonh', 'gyeod', 'gyeol', 'gyeolg', 'gyeolm', 'gyeolb', 'gyeols', 'gyeolt', 'gyeolp', 'gyeolh', 'gyeom', 'gyeob', 'gyeobs', 'gyeos', 'gyeoss', 'gyeong', 'gyeoj', 'gyeoc', 'gyeok', 'gyeot', 'gyeop', 'gyeoh', 'gye', 'gyeg', 'gyegg', 'gyegs', 'gyen', 'gyenj', 'gyenh', 'gyed', 'gyel', 'gyelg', 'gyelm', 'gyelb', 'gyels', 'gyelt', 'gyelp', 'gyelh', 'gyem', 'gyeb', 'gyebs', 'gyes', 'gyess', 'gyeng', 'gyej', 'gyec', 'gyek', 'gyet', 'gyep', 'gyeh', 'go', 'gog', 'gogg', 'gogs', 'gon', 'gonj', 'gonh', 'god', 'gol', 'golg', 'golm', 'golb', 'gols', 'golt', 'golp', 'golh', 'gom', 'gob', 'gobs', 'gos', 'goss', 'gong', 'goj', 'goc', 'gok', 'got', 'gop', 'goh', 'gwa', 'gwag', 'gwagg', 'gwags']


Joomla CMS: Référence du fichier x0d6.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d6.php

Variables

return ['hyeo', 'hyeog', 'hyeogg', 'hyeogs', 'hyeon', 'hyeonj', 'hyeonh', 'hyeod', 'hyeol', 'hyeolg', 'hyeolm', 'hyeolb', 'hyeols', 'hyeolt', 'hyeolp', 'hyeolh', 'hyeom', 'hyeob', 'hyeobs', 'hyeos', 'hyeoss', 'hyeong', 'hyeoj', 'hyeoc', 'hyeok', 'hyeot', 'hyeop', 'hyeoh', 'hye', 'hyeg', 'hyegg', 'hyegs', 'hyen', 'hyenj', 'hyenh', 'hyed', 'hyel', 'hyelg', 'hyelm', 'hyelb', 'hyels', 'hyelt', 'hyelp', 'hyelh', 'hyem', 'hyeb', 'hyebs', 'hyes', 'hyess', 'hyeng', 'hyej', 'hyec', 'hyek', 'hyet', 'hyep', 'hyeh', 'ho', 'hog', 'hogg', 'hogs', 'hon', 'honj', 'honh', 'hod', 'hol', 'holg', 'holm', 'holb', 'hols', 'holt', 'holp', 'holh', 'hom', 'hob', 'hobs', 'hos', 'hoss', 'hong', 'hoj', 'hoc', 'hok', 'hot', 'hop', 'hoh', 'hwa', 'hwag', 'hwagg', 'hwags', 'hwan', 'hwanj', 'hwanh', 'hwad', 'hwal', 'hwalg', 'hwalm', 'hwalb', 'hwals', 'hwalt', 'hwalp', 'hwalh', 'hwam', 'hwab', 'hwabs', 'hwas', 'hwass', 'hwang', 'hwaj', 'hwac', 'hwak', 'hwat', 'hwap', 'hwah', 'hwae', 'hwaeg', 'hwaegg', 'hwaegs', 'hwaen', 'hwaenj', 'hwaenh', 'hwaed', 'hwael', 'hwaelg', 'hwaelm', 'hwaelb', 'hwaels', 'hwaelt', 'hwaelp', 'hwaelh', 'hwaem', 'hwaeb', 'hwaebs', 'hwaes', 'hwaess', 'hwaeng', 'hwaej', 'hwaec', 'hwaek', 'hwaet', 'hwaep', 'hwaeh', 'hoe', 'hoeg', 'hoegg', 'hoegs', 'hoen', 'hoenj', 'hoenh', 'hoed', 'hoel', 'hoelg', 'hoelm', 'hoelb', 'hoels', 'hoelt', 'hoelp', 'hoelh', 'hoem', 'hoeb', 'hoebs', 'hoes', 'hoess', 'hoeng', 'hoej', 'hoec', 'hoek', 'hoet', 'hoep', 'hoeh', 'hyo', 'hyog', 'hyogg', 'hyogs', 'hyon', 'hyonj', 'hyonh', 'hyod', 'hyol', 'hyolg', 'hyolm', 'hyolb', 'hyols', 'hyolt', 'hyolp', 'hyolh', 'hyom', 'hyob', 'hyobs', 'hyos', 'hyoss', 'hyong', 'hyoj', 'hyoc', 'hyok', 'hyot', 'hyop', 'hyoh', 'hu', 'hug', 'hugg', 'hugs', 'hun', 'hunj', 'hunh', 'hud', 'hul', 'hulg', 'hulm', 'hulb', 'huls', 'hult', 'hulp', 'hulh', 'hum', 'hub', 'hubs', 'hus', 'huss', 'hung', 'huj', 'huc', 'huk', 'hut', 'hup', 'huh', 'hweo', 'hweog', 'hweogg', 'hweogs', 'hweon', 'hweonj', 'hweonh', 'hweod', 'hweol', 'hweolg', 'hweolm', 'hweolb', 'hweols', 'hweolt', 'hweolp', 'hweolh', 'hweom', 'hweob', 'hweobs', 'hweos', 'hweoss', 'hweong', 'hweoj', 'hweoc', 'hweok', 'hweot', 'hweop', 'hweoh', 'hwe', 'hweg', 'hwegg', 'hwegs']

Documentation des variables

◆ return

return[ 'hyeo', 'hyeog', 'hyeogg', 'hyeogs', 'hyeon', 'hyeonj', 'hyeonh', 'hyeod', 'hyeol', 'hyeolg', 'hyeolm', 'hyeolb', 'hyeols', 'hyeolt', 'hyeolp', 'hyeolh', 'hyeom', 'hyeob', 'hyeobs', 'hyeos', 'hyeoss', 'hyeong', 'hyeoj', 'hyeoc', 'hyeok', 'hyeot', 'hyeop', 'hyeoh', 'hye', 'hyeg', 'hyegg', 'hyegs', 'hyen', 'hyenj', 'hyenh', 'hyed', 'hyel', 'hyelg', 'hyelm', 'hyelb', 'hyels', 'hyelt', 'hyelp', 'hyelh', 'hyem', 'hyeb', 'hyebs', 'hyes', 'hyess', 'hyeng', 'hyej', 'hyec', 'hyek', 'hyet', 'hyep', 'hyeh', 'ho', 'hog', 'hogg', 'hogs', 'hon', 'honj', 'honh', 'hod', 'hol', 'holg', 'holm', 'holb', 'hols', 'holt', 'holp', 'holh', 'hom', 'hob', 'hobs', 'hos', 'hoss', 'hong', 'hoj', 'hoc', 'hok', 'hot', 'hop', 'hoh', 'hwa', 'hwag', 'hwagg', 'hwags', 'hwan', 'hwanj', 'hwanh', 'hwad', 'hwal', 'hwalg', 'hwalm', 'hwalb', 'hwals', 'hwalt', 'hwalp', 'hwalh', 'hwam', 'hwab', 'hwabs', 'hwas', 'hwass', 'hwang', 'hwaj', 'hwac', 'hwak', 'hwat', 'hwap', 'hwah', 'hwae', 'hwaeg', 'hwaegg', 'hwaegs', 'hwaen', 'hwaenj', 'hwaenh', 'hwaed', 'hwael', 'hwaelg', 'hwaelm', 'hwaelb', 'hwaels', 'hwaelt', 'hwaelp', 'hwaelh', 'hwaem', 'hwaeb', 'hwaebs', 'hwaes', 'hwaess', 'hwaeng', 'hwaej', 'hwaec', 'hwaek', 'hwaet', 'hwaep', 'hwaeh', 'hoe', 'hoeg', 'hoegg', 'hoegs', 'hoen', 'hoenj', 'hoenh', 'hoed', 'hoel', 'hoelg', 'hoelm', 'hoelb', 'hoels', 'hoelt', 'hoelp', 'hoelh', 'hoem', 'hoeb', 'hoebs', 'hoes', 'hoess', 'hoeng', 'hoej', 'hoec', 'hoek', 'hoet', 'hoep', 'hoeh', 'hyo', 'hyog', 'hyogg', 'hyogs', 'hyon', 'hyonj', 'hyonh', 'hyod', 'hyol', 'hyolg', 'hyolm', 'hyolb', 'hyols', 'hyolt', 'hyolp', 'hyolh', 'hyom', 'hyob', 'hyobs', 'hyos', 'hyoss', 'hyong', 'hyoj', 'hyoc', 'hyok', 'hyot', 'hyop', 'hyoh', 'hu', 'hug', 'hugg', 'hugs', 'hun', 'hunj', 'hunh', 'hud', 'hul', 'hulg', 'hulm', 'hulb', 'huls', 'hult', 'hulp', 'hulh', 'hum', 'hub', 'hubs', 'hus', 'huss', 'hung', 'huj', 'huc', 'huk', 'hut', 'hup', 'huh', 'hweo', 'hweog', 'hweogg', 'hweogs', 'hweon', 'hweonj', 'hweonh', 'hweod', 'hweol', 'hweolg', 'hweolm', 'hweolb', 'hweols', 'hweolt', 'hweolp', 'hweolh', 'hweom', 'hweob', 'hweobs', 'hweos', 'hweoss', 'hweong', 'hweoj', 'hweoc', 'hweok', 'hweot', 'hweop', 'hweoh', 'hwe', 'hweg', 'hwegg', 'hwegs']


Joomla CMS: Référence du fichier OverridesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_languages/src/Controller/OverridesController.php

Structures de données

class OverridesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Controller


Joomla CMS: Référence du fichier TemplatedHrefTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fig
  • link-util
  • src
Espaces de nommage
Référence du fichier TemplatedHrefTrait.php

Espaces de nommage

Fig\Link


Joomla CMS: Référence du fichier replacements.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • config
Variables
Référence du fichier replacements.php

Variables

return ['zendframework/zendframework'=> 'zendframework/zendframework', 'zend-developer-tools/toolbar/bjy'=> 'zend-developer-tools/toolbar/bjy', 'zend-developer-tools/toolbar/doctrine'=> 'zend-developer-tools/toolbar/doctrine', 'Zend\\AuraDi\\Config'=> 'Laminas\\AuraDi\\Config', 'Zend\\Authentication'=> 'Laminas\\Authentication', 'Zend\\Barcode'=> 'Laminas\\Barcode', 'Zend\\Cache'=> 'Laminas\\Cache', 'Zend\\Captcha'=> 'Laminas\\Captcha', 'Zend\\Code'=> 'Laminas\\Code', 'ZendCodingStandard\\Sniffs'=> 'LaminasCodingStandard\\Sniffs', 'ZendCodingStandard\\Utils'=> 'LaminasCodingStandard\\Utils', 'Zend\\ComponentInstaller'=> 'Laminas\\ComponentInstaller', 'Zend\\Config'=> 'Laminas\\Config', 'Zend\\ConfigAggregator'=> 'Laminas\\ConfigAggregator', 'Zend\\ConfigAggregatorModuleManager'=> 'Laminas\\ConfigAggregatorModuleManager', 'Zend\\ConfigAggregatorParameters'=> 'Laminas\\ConfigAggregatorParameters', 'Zend\\Console'=> 'Laminas\\Console', 'Zend\\ContainerConfigTest'=> 'Laminas\\ContainerConfigTest', 'Zend\\Crypt'=> 'Laminas\\Crypt', 'Zend\\Db'=> 'Laminas\\Db', 'ZendDeveloperTools'=> 'Laminas\\DeveloperTools', 'Zend\\Di'=> 'Laminas\\Di', 'Zend\\Diactoros'=> 'Laminas\\Diactoros', 'ZendDiagnostics\\Check'=> 'Laminas\\Diagnostics\\Check', 'ZendDiagnostics\\Result'=> 'Laminas\\Diagnostics\\Result', 'ZendDiagnostics\\Runner'=> 'Laminas\\Diagnostics\\Runner', 'Zend\\Dom'=> 'Laminas\\Dom', 'Zend\\Escaper'=> 'Laminas\\Escaper', 'Zend\\EventManager'=> 'Laminas\\EventManager', 'Zend\\Feed'=> 'Laminas\\Feed', 'Zend\\File'=> 'Laminas\\File', 'Zend\\Filter'=> 'Laminas\\Filter', 'Zend\\Form'=> 'Laminas\\Form', 'Zend\\Http'=> 'Laminas\\Http', 'Zend\\HttpHandlerRunner'=> 'Laminas\\HttpHandlerRunner', 'Zend\\Hydrator'=> 'Laminas\\Hydrator', 'Zend\\I18n'=> 'Laminas\\I18n', 'Zend\\InputFilter'=> 'Laminas\\InputFilter', 'Zend\\Json'=> 'Laminas\\Json', 'Zend\\Ldap'=> 'Laminas\\Ldap', 'Zend\\Loader'=> 'Laminas\\Loader', 'Zend\\Log'=> 'Laminas\\Log', 'Zend\\Mail'=> 'Laminas\\Mail', 'Zend\\Math'=> 'Laminas\\Math', 'Zend\\Memory'=> 'Laminas\\Memory', 'Zend\\Mime'=> 'Laminas\\Mime', 'Zend\\ModuleManager'=> 'Laminas\\ModuleManager', 'Zend\\Mvc'=> 'Laminas\\Mvc', 'Zend\\Navigation'=> 'Laminas\\Navigation', 'Zend\\Paginator'=> 'Laminas\\Paginator', 'Zend\\Permissions'=> 'Laminas\\Permissions', 'Zend\\Pimple\\Config'=> 'Laminas\\Pimple\\Config', 'Zend\\ProblemDetails'=> 'Mezzio\\ProblemDetails', 'Zend\\ProgressBar'=> 'Laminas\\ProgressBar', 'Zend\\Psr7Bridge'=> 'Laminas\\Psr7Bridge', 'Zend\\Router'=> 'Laminas\\Router', 'Zend\\Serializer'=> 'Laminas\\Serializer', 'Zend\\Server'=> 'Laminas\\Server', 'Zend\\ServiceManager'=> 'Laminas\\ServiceManager', 'ZendService\\ReCaptcha'=> 'Laminas\\ReCaptcha', 'ZendService\\Twitter'=> 'Laminas\\Twitter', 'Zend\\Session'=> 'Laminas\\Session', 'Zend\\SkeletonInstaller'=> 'Laminas\\SkeletonInstaller', 'Zend\\Soap'=> 'Laminas\\Soap', 'Zend\\Stdlib'=> 'Laminas\\Stdlib', 'Zend\\Stratigility'=> 'Laminas\\Stratigility', 'Zend\\Tag'=> 'Laminas\\Tag', 'Zend\\Test'=> 'Laminas\\Test', 'Zend\\Text'=> 'Laminas\\Text', 'Zend\\Uri'=> 'Laminas\\Uri', 'Zend\\Validator'=> 'Laminas\\Validator', 'Zend\\View'=> 'Laminas\\View', 'ZendXml'=> 'Laminas\\Xml', 'Zend\\Xml2Json'=> 'Laminas\\Xml2Json', 'Zend\\XmlRpc'=> 'Laminas\\XmlRpc', 'ZendOAuth'=> 'Laminas\\OAuth', 'ZendAcl'=> 'LaminasAcl', 'Zend\\Expressive\\Authorization\\Acl\\ZendAcl'=> 'Mezzio\\Authorization\\Acl\\LaminasAcl', 'ZendHttp'=> 'LaminasHttp', 'ZendModule'=> 'LaminasModule', 'ZendRbac'=> 'LaminasRbac', 'Zend\\Expressive\\Authorization\\Rbac\\ZendRbac'=> 'Mezzio\\Authorization\\Rbac\\LaminasRbac', 'ZendRouter'=> 'LaminasRouter', 'Zend\\Expressive\\Router\\ZendRouter'=> 'Mezzio\\Router\\LaminasRouter', 'ZendViewRenderer'=> 'LaminasViewRenderer', 'Zend\\Expressive\\ZendView\\ZendViewRenderer'=> 'Mezzio\\LaminasView\\LaminasViewRenderer', 'a\\Zend'=> 'a\\Zend', 'b\\Zend'=> 'b\\Zend', 'c\\Zend'=> 'c\\Zend', 'd\\Zend'=> 'd\\Zend', 'e\\Zend'=> 'e\\Zend', 'f\\Zend'=> 'f\\Zend', 'g\\Zend'=> 'g\\Zend', 'h\\Zend'=> 'h\\Zend', 'i\\Zend'=> 'i\\Zend', 'j\\Zend'=> 'j\\Zend', 'k\\Zend'=> 'k\\Zend', 'l\\Zend'=> 'l\\Zend', 'm\\Zend'=> 'm\\Zend', 'n\\Zend'=> 'n\\Zend', 'o\\Zend'=> 'o\\Zend', 'p\\Zend'=> 'p\\Zend', 'q\\Zend'=> 'q\\Zend', 'r\\Zend'=> 'r\\Zend', 's\\Zend'=> 's\\Zend', 't\\Zend'=> 't\\Zend', 'u\\Zend'=> 'u\\Zend', 'v\\Zend'=> 'v\\Zend', 'w\\Zend'=> 'w\\Zend', 'x\\Zend'=> 'x\\Zend', 'y\\Zend'=> 'y\\Zend', 'z\\Zend'=> 'z\\Zend', 'Zend\\Expressive'=> 'Mezzio', 'ZendAuthentication'=> 'LaminasAuthentication', 'ZendAcl'=> 'LaminasAcl', 'ZendRbac'=> 'LaminasRbac', 'ZendRouter'=> 'LaminasRouter', 'ExpressiveUrlGenerator'=> 'MezzioUrlGenerator', 'ExpressiveInstaller'=> 'MezzioInstaller', 'ZF\\Apigility'=> 'Laminas\\ApiTools', 'ZF\\ApiProblem'=> 'Laminas\\ApiTools\\ApiProblem', 'ZF\\AssetManager'=> 'Laminas\\ApiTools\\AssetManager', 'ZF\\ComposerAutoloading'=> 'Laminas\\ComposerAutoloading', 'ZF\\Configuration'=> 'Laminas\\ApiTools\\Configuration', 'ZF\\ContentNegotiation'=> 'Laminas\\ApiTools\\ContentNegotiation', 'ZF\\ContentValidation'=> 'Laminas\\ApiTools\\ContentValidation', 'ZF\\DevelopmentMode'=> 'Laminas\\DevelopmentMode', 'ZF\\Doctrine\\QueryBuilder'=> 'Laminas\\ApiTools\\Doctrine\\QueryBuilder', 'ZF\\Hal'=> 'Laminas\\ApiTools\\Hal', 'ZF\\HttpCache'=> 'Laminas\\ApiTools\\HttpCache', 'ZF\\MvcAuth'=> 'Laminas\\ApiTools\\MvcAuth', 'ZF\\OAuth2'=> 'Laminas\\ApiTools\\OAuth2', 'ZF\\Rest'=> 'Laminas\\ApiTools\\Rest', 'ZF\\Rpc'=> 'Laminas\\ApiTools\\Rpc', 'ZF\\Versioning'=> 'Laminas\\ApiTools\\Versioning', 'a\\ZF'=> 'a\\ZF', 'b\\ZF'=> 'b\\ZF', 'c\\ZF'=> 'c\\ZF', 'd\\ZF'=> 'd\\ZF', 'e\\ZF'=> 'e\\ZF', 'f\\ZF'=> 'f\\ZF', 'g\\ZF'=> 'g\\ZF', 'h\\ZF'=> 'h\\ZF', 'i\\ZF'=> 'i\\ZF', 'j\\ZF'=> 'j\\ZF', 'k\\ZF'=> 'k\\ZF', 'l\\ZF'=> 'l\\ZF', 'm\\ZF'=> 'm\\ZF', 'n\\ZF'=> 'n\\ZF', 'o\\ZF'=> 'o\\ZF', 'p\\ZF'=> 'p\\ZF', 'q\\ZF'=> 'q\\ZF', 'r\\ZF'=> 'r\\ZF', 's\\ZF'=> 's\\ZF', 't\\ZF'=> 't\\ZF', 'u\\ZF'=> 'u\\ZF', 'v\\ZF'=> 'v\\ZF', 'w\\ZF'=> 'w\\ZF', 'x\\ZF'=> 'x\\ZF', 'y\\ZF'=> 'y\\ZF', 'z\\ZF'=> 'z\\ZF', 'ApigilityModuleInterface'=> 'ApiToolsModuleInterface', 'ApigilityProviderInterface'=> 'ApiToolsProviderInterface', 'ApigilityVersionController'=> 'ApiToolsVersionController', 'zendframework/skeleton-application'=> 'laminas/skeleton-application', 'zendframework/zend-auradi-config'=> 'laminas/laminas-auradi-config', 'zendframework/zend-authentication'=> 'laminas/laminas-authentication', 'zendframework/zend-barcode'=> 'laminas/laminas-barcode', 'zendframework/zend-cache'=> 'laminas/laminas-cache', 'zendframework/zend-captcha'=> 'laminas/laminas-captcha', 'zendframework/zend-code'=> 'laminas/laminas-code', 'zendframework/zend-coding-standard'=> 'laminas/laminas-coding-standard', 'zendframework/zend-component-installer'=> 'laminas/laminas-component-installer', 'zendframework/zend-composer-autoloading'=> 'laminas/laminas-composer-autoloading', 'zendframework/zend-config-aggregator'=> 'laminas/laminas-config-aggregator', 'zendframework/zend-config'=> 'laminas/laminas-config', 'zendframework/zend-console'=> 'laminas/laminas-console', 'zendframework/zend-container-config-test'=> 'laminas/laminas-container-config-test', 'zendframework/zend-crypt'=> 'laminas/laminas-crypt', 'zendframework/zend-db'=> 'laminas/laminas-db', 'zendframework/zend-developer-tools'=> 'laminas/laminas-developer-tools', 'zendframework/zend-diactoros'=> 'laminas/laminas-diactoros', 'zendframework/zenddiagnostics'=> 'laminas/laminas-diagnostics', 'zendframework/zend-di'=> 'laminas/laminas-di', 'zendframework/zend-dom'=> 'laminas/laminas-dom', 'zendframework/zend-escaper'=> 'laminas/laminas-escaper', 'zendframework/zend-eventmanager'=> 'laminas/laminas-eventmanager', 'zendframework/zend-feed'=> 'laminas/laminas-feed', 'zendframework/zend-file'=> 'laminas/laminas-file', 'zendframework/zend-filter'=> 'laminas/laminas-filter', 'zendframework/zend-form'=> 'laminas/laminas-form', 'zendframework/zend-httphandlerrunner'=> 'laminas/laminas-httphandlerrunner', 'zendframework/zend-http'=> 'laminas/laminas-http', 'zendframework/zend-hydrator'=> 'laminas/laminas-hydrator', 'zendframework/zend-i18n'=> 'laminas/laminas-i18n', 'zendframework/zend-i18n-resources'=> 'laminas/laminas-i18n-resources', 'zendframework/zend-inputfilter'=> 'laminas/laminas-inputfilter', 'zendframework/zend-json'=> 'laminas/laminas-json', 'zendframework/zend-json-server'=> 'laminas/laminas-json-server', 'zendframework/zend-ldap'=> 'laminas/laminas-ldap', 'zendframework/zend-loader'=> 'laminas/laminas-loader', 'zendframework/zend-log'=> 'laminas/laminas-log', 'zendframework/zend-mail'=> 'laminas/laminas-mail', 'zendframework/zend-math'=> 'laminas/laminas-math', 'zendframework/zend-memory'=> 'laminas/laminas-memory', 'zendframework/zend-mime'=> 'laminas/laminas-mime', 'zendframework/zend-modulemanager'=> 'laminas/laminas-modulemanager', 'zendframework/zend-mvc'=> 'laminas/laminas-mvc', 'zendframework/zend-navigation'=> 'laminas/laminas-navigation', 'zendframework/zend-oauth'=> 'laminas/laminas-oauth', 'zendframework/zend-paginator'=> 'laminas/laminas-paginator', 'zendframework/zend-permissions-acl'=> 'laminas/laminas-permissions-acl', 'zendframework/zend-permissions-rbac'=> 'laminas/laminas-permissions-rbac', 'zendframework/zend-pimple-config'=> 'laminas/laminas-pimple-config', 'zendframework/zend-progressbar'=> 'laminas/laminas-progressbar', 'zendframework/zend-psr7bridge'=> 'laminas/laminas-psr7bridge', 'zendframework/zend-recaptcha'=> 'laminas/laminas-recaptcha', 'zendframework/zend-router'=> 'laminas/laminas-router', 'zendframework/zend-serializer'=> 'laminas/laminas-serializer', 'zendframework/zend-server'=> 'laminas/laminas-server', 'zendframework/zend-servicemanager'=> 'laminas/laminas-servicemanager', 'zendframework/zendservice-recaptcha'=> 'laminas/laminas-recaptcha', 'zendframework/zendservice-twitter'=> 'laminas/laminas-twitter', 'zendframework/zend-session'=> 'laminas/laminas-session', 'zendframework/zend-skeleton-installer'=> 'laminas/laminas-skeleton-installer', 'zendframework/zend-soap'=> 'laminas/laminas-soap', 'zendframework/zend-stdlib'=> 'laminas/laminas-stdlib', 'zendframework/zend-stratigility'=> 'laminas/laminas-stratigility', 'zendframework/zend-tag'=> 'laminas/laminas-tag', 'zendframework/zend-test'=> 'laminas/laminas-test', 'zendframework/zend-text'=> 'laminas/laminas-text', 'zendframework/zend-uri'=> 'laminas/laminas-uri', 'zendframework/zend-validator'=> 'laminas/laminas-validator', 'zendframework/zend-view'=> 'laminas/laminas-view', 'zendframework/zend-xml2json'=> 'laminas/laminas-xml2json', 'zendframework/zend-xml'=> 'laminas/laminas-xml', 'zendframework/zend-xmlrpc'=> 'laminas/laminas-xmlrpc', 'zendframework/zend-expressive'=> 'mezzio/mezzio', 'zendframework/zend-expressive-zendrouter'=> 'mezzio/mezzio-laminasrouter', 'zendframework/zend-problem-details'=> 'mezzio/mezzio-problem-details', 'zendframework/zend-expressive-zendviewrenderer'=> 'mezzio/mezzio-laminasviewrenderer', 'zfcampus/apigility-documentation'=> 'laminas-api-tools/documentation', 'zfcampus/statuslib-example'=> 'laminas-api-tools/statuslib-example', 'zfcampus/zf-apigility'=> 'laminas-api-tools/api-tools', 'zfcampus/zf-api-problem'=> 'laminas-api-tools/api-tools-api-problem', 'zfcampus/zf-asset-manager'=> 'laminas-api-tools/api-tools-asset-manager', 'zfcampus/zf-configuration'=> 'laminas-api-tools/api-tools-configuration', 'zfcampus/zf-content-negotiation'=> 'laminas-api-tools/api-tools-content-negotiation', 'zfcampus/zf-content-validation'=> 'laminas-api-tools/api-tools-content-validation', 'zfcampus/zf-development-mode'=> 'laminas/laminas-development-mode', 'zfcampus/zf-doctrine-querybuilder'=> 'laminas-api-tools/api-tools-doctrine-querybuilder', 'zfcampus/zf-hal'=> 'laminas-api-tools/api-tools-hal', 'zfcampus/zf-http-cache'=> 'laminas-api-tools/api-tools-http-cache', 'zfcampus/zf-mvc-auth'=> 'laminas-api-tools/api-tools-mvc-auth', 'zfcampus/zf-oauth2'=> 'laminas-api-tools/api-tools-oauth2', 'zfcampus/zf-rest'=> 'laminas-api-tools/api-tools-rest', 'zfcampus/zf-rpc'=> 'laminas-api-tools/api-tools-rpc', 'zfcampus/zf-versioning'=> 'laminas-api-tools/api-tools-versioning', '::fromZend'=> '::fromLaminas', '::toZend'=> '::toLaminas', 'use_zend_loader'=> 'use_laminas_loader', 'zend-config'=> 'laminas-config', 'zend-developer-tools/'=> 'laminas-developer-tools/', 'zend-tag-cloud'=> 'laminas-tag-cloud', 'zenddevelopertools'=> 'laminas-developer-tools', 'zendbarcode'=> 'laminasbarcode', 'ZendBarcode'=> 'LaminasBarcode', 'zendcache'=> 'laminascache', 'ZendCache'=> 'LaminasCache', 'zendconfig'=> 'laminasconfig', 'ZendConfig'=> 'LaminasConfig', 'zendfeed'=> 'laminasfeed', 'ZendFeed'=> 'LaminasFeed', 'zendfilter'=> 'laminasfilter', 'ZendFilter'=> 'LaminasFilter', 'zendform'=> 'laminasform', 'ZendForm'=> 'LaminasForm', 'zendi18n'=> 'laminasi18n', 'ZendI18n'=> 'LaminasI18n', 'zendinputfilter'=> 'laminasinputfilter', 'ZendInputFilter'=> 'LaminasInputFilter', 'zendlog'=> 'laminaslog', 'ZendLog'=> 'LaminasLog', 'zendmail'=> 'laminasmail', 'ZendMail'=> 'LaminasMail', 'zendmvc'=> 'laminasmvc', 'ZendMvc'=> 'LaminasMvc', 'zendpaginator'=> 'laminaspaginator', 'ZendPaginator'=> 'LaminasPaginator', 'zendserializer'=> 'laminasserializer', 'ZendSerializer'=> 'LaminasSerializer', 'zendtag'=> 'laminastag', 'ZendTag'=> 'LaminasTag', 'zendtext'=> 'laminastext', 'ZendText'=> 'LaminasText', 'zendvalidator'=> 'laminasvalidator', 'ZendValidator'=> 'LaminasValidator', 'zendview'=> 'laminasview', 'ZendView'=> 'LaminasView', 'zend-framework.flf'=> 'laminas-project.flf', "'zend-expressive'"=> "'mezzio'", '"zend-expressive"'=> '"mezzio"', 'zend-expressive.'=> 'mezzio.', 'zend-expressive-authorization'=> 'mezzio-authorization', 'zend-expressive-hal'=> 'mezzio-hal', 'zend-expressive-session'=> 'mezzio-session', 'zend-expressive-swoole'=> 'mezzio-swoole', 'zend-expressive-tooling'=> 'mezzio-tooling', "'zf-apigility'"=> "'api-tools'", '"zf-apigility"'=> '"api-tools"', 'zf-apigility/'=> 'api-tools/', 'zf-apigility-admin'=> 'api-tools-admin', 'zf-content-negotiation'=> 'api-tools-content-negotiation', 'zf-hal'=> 'api-tools-hal', 'zf-rest'=> 'api-tools-rest', 'zf-rpc'=> 'api-tools-rpc', 'zf-content-validation'=> 'api-tools-content-validation', 'zf-apigility-ui'=> 'api-tools-ui', 'zf-apigility-documentation-blueprint'=> 'api-tools-documentation-blueprint', 'zf-apigility-documentation-swagger'=> 'api-tools-documentation-swagger', 'zf-apigility-welcome'=> 'api-tools-welcome', 'zf-api-problem'=> 'api-tools-api-problem', 'zf-configuration'=> 'api-tools-configuration', 'zf-http-cache'=> 'api-tools-http-cache', 'zf-mvc-auth'=> 'api-tools-mvc-auth', 'zf-oauth2'=> 'api-tools-oauth2', 'zf-versioning'=> 'api-tools-versioning', 'ZfApigilityDoctrineQueryProviderManager'=> 'LaminasApiToolsDoctrineQueryProviderManager', 'ZfApigilityDoctrineQueryCreateFilterManager'=> 'LaminasApiToolsDoctrineQueryCreateFilterManager', 'zf-apigility-doctrine'=> 'api-tools-doctrine', 'zf-development-mode'=> 'laminas-development-mode', 'zf-doctrine-querybuilder'=> 'api-tools-doctrine-querybuilder', 'api-skeletons/zf-'=> 'api-skeletons/zf-', 'zf-oauth2-'=> 'zf-oauth2-', 'ZF\\OAuth2\\Client'=> 'ZF\\OAuth2\\Client', 'ZF\\OAuth2\\Doctrine'=> 'ZF\\OAuth2\\Doctrine',]

Documentation des variables

◆ return

return[ 'zendframework/zendframework'=> 'zendframework/zendframework', 'zend-developer-tools/toolbar/bjy'=> 'zend-developer-tools/toolbar/bjy', 'zend-developer-tools/toolbar/doctrine'=> 'zend-developer-tools/toolbar/doctrine', 'Zend\\AuraDi\\Config'=> 'Laminas\\AuraDi\\Config', 'Zend\\Authentication'=> 'Laminas\\Authentication', 'Zend\\Barcode'=> 'Laminas\\Barcode', 'Zend\\Cache'=> 'Laminas\\Cache', 'Zend\\Captcha'=> 'Laminas\\Captcha', 'Zend\\Code'=> 'Laminas\\Code', 'ZendCodingStandard\\Sniffs'=> 'LaminasCodingStandard\\Sniffs', 'ZendCodingStandard\\Utils'=> 'LaminasCodingStandard\\Utils', 'Zend\\ComponentInstaller'=> 'Laminas\\ComponentInstaller', 'Zend\\Config'=> 'Laminas\\Config', 'Zend\\ConfigAggregator'=> 'Laminas\\ConfigAggregator', 'Zend\\ConfigAggregatorModuleManager'=> 'Laminas\\ConfigAggregatorModuleManager', 'Zend\\ConfigAggregatorParameters'=> 'Laminas\\ConfigAggregatorParameters', 'Zend\\Console'=> 'Laminas\\Console', 'Zend\\ContainerConfigTest'=> 'Laminas\\ContainerConfigTest', 'Zend\\Crypt'=> 'Laminas\\Crypt', 'Zend\\Db'=> 'Laminas\\Db', 'ZendDeveloperTools'=> 'Laminas\\DeveloperTools', 'Zend\\Di'=> 'Laminas\\Di', 'Zend\\Diactoros'=> 'Laminas\\Diactoros', 'ZendDiagnostics\\Check'=> 'Laminas\\Diagnostics\\Check', 'ZendDiagnostics\\Result'=> 'Laminas\\Diagnostics\\Result', 'ZendDiagnostics\\Runner'=> 'Laminas\\Diagnostics\\Runner', 'Zend\\Dom'=> 'Laminas\\Dom', 'Zend\\Escaper'=> 'Laminas\\Escaper', 'Zend\\EventManager'=> 'Laminas\\EventManager', 'Zend\\Feed'=> 'Laminas\\Feed', 'Zend\\File'=> 'Laminas\\File', 'Zend\\Filter'=> 'Laminas\\Filter', 'Zend\\Form'=> 'Laminas\\Form', 'Zend\\Http'=> 'Laminas\\Http', 'Zend\\HttpHandlerRunner'=> 'Laminas\\HttpHandlerRunner', 'Zend\\Hydrator'=> 'Laminas\\Hydrator', 'Zend\\I18n'=> 'Laminas\\I18n', 'Zend\\InputFilter'=> 'Laminas\\InputFilter', 'Zend\\Json'=> 'Laminas\\Json', 'Zend\\Ldap'=> 'Laminas\\Ldap', 'Zend\\Loader'=> 'Laminas\\Loader', 'Zend\\Log'=> 'Laminas\\Log', 'Zend\\Mail'=> 'Laminas\\Mail', 'Zend\\Math'=> 'Laminas\\Math', 'Zend\\Memory'=> 'Laminas\\Memory', 'Zend\\Mime'=> 'Laminas\\Mime', 'Zend\\ModuleManager'=> 'Laminas\\ModuleManager', 'Zend\\Mvc'=> 'Laminas\\Mvc', 'Zend\\Navigation'=> 'Laminas\\Navigation', 'Zend\\Paginator'=> 'Laminas\\Paginator', 'Zend\\Permissions'=> 'Laminas\\Permissions', 'Zend\\Pimple\\Config'=> 'Laminas\\Pimple\\Config', 'Zend\\ProblemDetails'=> 'Mezzio\\ProblemDetails', 'Zend\\ProgressBar'=> 'Laminas\\ProgressBar', 'Zend\\Psr7Bridge'=> 'Laminas\\Psr7Bridge', 'Zend\\Router'=> 'Laminas\\Router', 'Zend\\Serializer'=> 'Laminas\\Serializer', 'Zend\\Server'=> 'Laminas\\Server', 'Zend\\ServiceManager'=> 'Laminas\\ServiceManager', 'ZendService\\ReCaptcha'=> 'Laminas\\ReCaptcha', 'ZendService\\Twitter'=> 'Laminas\\Twitter', 'Zend\\Session'=> 'Laminas\\Session', 'Zend\\SkeletonInstaller'=> 'Laminas\\SkeletonInstaller', 'Zend\\Soap'=> 'Laminas\\Soap', 'Zend\\Stdlib'=> 'Laminas\\Stdlib', 'Zend\\Stratigility'=> 'Laminas\\Stratigility', 'Zend\\Tag'=> 'Laminas\\Tag', 'Zend\\Test'=> 'Laminas\\Test', 'Zend\\Text'=> 'Laminas\\Text', 'Zend\\Uri'=> 'Laminas\\Uri', 'Zend\\Validator'=> 'Laminas\\Validator', 'Zend\\View'=> 'Laminas\\View', 'ZendXml'=> 'Laminas\\Xml', 'Zend\\Xml2Json'=> 'Laminas\\Xml2Json', 'Zend\\XmlRpc'=> 'Laminas\\XmlRpc', 'ZendOAuth'=> 'Laminas\\OAuth', 'ZendAcl'=> 'LaminasAcl', 'Zend\\Expressive\\Authorization\\Acl\\ZendAcl'=> 'Mezzio\\Authorization\\Acl\\LaminasAcl', 'ZendHttp'=> 'LaminasHttp', 'ZendModule'=> 'LaminasModule', 'ZendRbac'=> 'LaminasRbac', 'Zend\\Expressive\\Authorization\\Rbac\\ZendRbac'=> 'Mezzio\\Authorization\\Rbac\\LaminasRbac', 'ZendRouter'=> 'LaminasRouter', 'Zend\\Expressive\\Router\\ZendRouter'=> 'Mezzio\\Router\\LaminasRouter', 'ZendViewRenderer'=> 'LaminasViewRenderer', 'Zend\\Expressive\\ZendView\\ZendViewRenderer'=> 'Mezzio\\LaminasView\\LaminasViewRenderer', 'a\\Zend'=> 'a\\Zend', 'b\\Zend'=> 'b\\Zend', 'c\\Zend'=> 'c\\Zend', 'd\\Zend'=> 'd\\Zend', 'e\\Zend'=> 'e\\Zend', 'f\\Zend'=> 'f\\Zend', 'g\\Zend'=> 'g\\Zend', 'h\\Zend'=> 'h\\Zend', 'i\\Zend'=> 'i\\Zend', 'j\\Zend'=> 'j\\Zend', 'k\\Zend'=> 'k\\Zend', 'l\\Zend'=> 'l\\Zend', 'm\\Zend'=> 'm\\Zend', 'n\\Zend'=> 'n\\Zend', 'o\\Zend'=> 'o\\Zend', 'p\\Zend'=> 'p\\Zend', 'q\\Zend'=> 'q\\Zend', 'r\\Zend'=> 'r\\Zend', 's\\Zend'=> 's\\Zend', 't\\Zend'=> 't\\Zend', 'u\\Zend'=> 'u\\Zend', 'v\\Zend'=> 'v\\Zend', 'w\\Zend'=> 'w\\Zend', 'x\\Zend'=> 'x\\Zend', 'y\\Zend'=> 'y\\Zend', 'z\\Zend'=> 'z\\Zend', 'Zend\\Expressive'=> 'Mezzio', 'ZendAuthentication'=> 'LaminasAuthentication', 'ZendAcl'=> 'LaminasAcl', 'ZendRbac'=> 'LaminasRbac', 'ZendRouter'=> 'LaminasRouter', 'ExpressiveUrlGenerator'=> 'MezzioUrlGenerator', 'ExpressiveInstaller'=> 'MezzioInstaller', 'ZF\\Apigility'=> 'Laminas\\ApiTools', 'ZF\\ApiProblem'=> 'Laminas\\ApiTools\\ApiProblem', 'ZF\\AssetManager'=> 'Laminas\\ApiTools\\AssetManager', 'ZF\\ComposerAutoloading'=> 'Laminas\\ComposerAutoloading', 'ZF\\Configuration'=> 'Laminas\\ApiTools\\Configuration', 'ZF\\ContentNegotiation'=> 'Laminas\\ApiTools\\ContentNegotiation', 'ZF\\ContentValidation'=> 'Laminas\\ApiTools\\ContentValidation', 'ZF\\DevelopmentMode'=> 'Laminas\\DevelopmentMode', 'ZF\\Doctrine\\QueryBuilder'=> 'Laminas\\ApiTools\\Doctrine\\QueryBuilder', 'ZF\\Hal'=> 'Laminas\\ApiTools\\Hal', 'ZF\\HttpCache'=> 'Laminas\\ApiTools\\HttpCache', 'ZF\\MvcAuth'=> 'Laminas\\ApiTools\\MvcAuth', 'ZF\\OAuth2'=> 'Laminas\\ApiTools\\OAuth2', 'ZF\\Rest'=> 'Laminas\\ApiTools\\Rest', 'ZF\\Rpc'=> 'Laminas\\ApiTools\\Rpc', 'ZF\\Versioning'=> 'Laminas\\ApiTools\\Versioning', 'a\\ZF'=> 'a\\ZF', 'b\\ZF'=> 'b\\ZF', 'c\\ZF'=> 'c\\ZF', 'd\\ZF'=> 'd\\ZF', 'e\\ZF'=> 'e\\ZF', 'f\\ZF'=> 'f\\ZF', 'g\\ZF'=> 'g\\ZF', 'h\\ZF'=> 'h\\ZF', 'i\\ZF'=> 'i\\ZF', 'j\\ZF'=> 'j\\ZF', 'k\\ZF'=> 'k\\ZF', 'l\\ZF'=> 'l\\ZF', 'm\\ZF'=> 'm\\ZF', 'n\\ZF'=> 'n\\ZF', 'o\\ZF'=> 'o\\ZF', 'p\\ZF'=> 'p\\ZF', 'q\\ZF'=> 'q\\ZF', 'r\\ZF'=> 'r\\ZF', 's\\ZF'=> 's\\ZF', 't\\ZF'=> 't\\ZF', 'u\\ZF'=> 'u\\ZF', 'v\\ZF'=> 'v\\ZF', 'w\\ZF'=> 'w\\ZF', 'x\\ZF'=> 'x\\ZF', 'y\\ZF'=> 'y\\ZF', 'z\\ZF'=> 'z\\ZF', 'ApigilityModuleInterface'=> 'ApiToolsModuleInterface', 'ApigilityProviderInterface'=> 'ApiToolsProviderInterface', 'ApigilityVersionController'=> 'ApiToolsVersionController', 'zendframework/skeleton-application'=> 'laminas/skeleton-application', 'zendframework/zend-auradi-config'=> 'laminas/laminas-auradi-config', 'zendframework/zend-authentication'=> 'laminas/laminas-authentication', 'zendframework/zend-barcode'=> 'laminas/laminas-barcode', 'zendframework/zend-cache'=> 'laminas/laminas-cache', 'zendframework/zend-captcha'=> 'laminas/laminas-captcha', 'zendframework/zend-code'=> 'laminas/laminas-code', 'zendframework/zend-coding-standard'=> 'laminas/laminas-coding-standard', 'zendframework/zend-component-installer'=> 'laminas/laminas-component-installer', 'zendframework/zend-composer-autoloading'=> 'laminas/laminas-composer-autoloading', 'zendframework/zend-config-aggregator'=> 'laminas/laminas-config-aggregator', 'zendframework/zend-config'=> 'laminas/laminas-config', 'zendframework/zend-console'=> 'laminas/laminas-console', 'zendframework/zend-container-config-test'=> 'laminas/laminas-container-config-test', 'zendframework/zend-crypt'=> 'laminas/laminas-crypt', 'zendframework/zend-db'=> 'laminas/laminas-db', 'zendframework/zend-developer-tools'=> 'laminas/laminas-developer-tools', 'zendframework/zend-diactoros'=> 'laminas/laminas-diactoros', 'zendframework/zenddiagnostics'=> 'laminas/laminas-diagnostics', 'zendframework/zend-di'=> 'laminas/laminas-di', 'zendframework/zend-dom'=> 'laminas/laminas-dom', 'zendframework/zend-escaper'=> 'laminas/laminas-escaper', 'zendframework/zend-eventmanager'=> 'laminas/laminas-eventmanager', 'zendframework/zend-feed'=> 'laminas/laminas-feed', 'zendframework/zend-file'=> 'laminas/laminas-file', 'zendframework/zend-filter'=> 'laminas/laminas-filter', 'zendframework/zend-form'=> 'laminas/laminas-form', 'zendframework/zend-httphandlerrunner'=> 'laminas/laminas-httphandlerrunner', 'zendframework/zend-http'=> 'laminas/laminas-http', 'zendframework/zend-hydrator'=> 'laminas/laminas-hydrator', 'zendframework/zend-i18n'=> 'laminas/laminas-i18n', 'zendframework/zend-i18n-resources'=> 'laminas/laminas-i18n-resources', 'zendframework/zend-inputfilter'=> 'laminas/laminas-inputfilter', 'zendframework/zend-json'=> 'laminas/laminas-json', 'zendframework/zend-json-server'=> 'laminas/laminas-json-server', 'zendframework/zend-ldap'=> 'laminas/laminas-ldap', 'zendframework/zend-loader'=> 'laminas/laminas-loader', 'zendframework/zend-log'=> 'laminas/laminas-log', 'zendframework/zend-mail'=> 'laminas/laminas-mail', 'zendframework/zend-math'=> 'laminas/laminas-math', 'zendframework/zend-memory'=> 'laminas/laminas-memory', 'zendframework/zend-mime'=> 'laminas/laminas-mime', 'zendframework/zend-modulemanager'=> 'laminas/laminas-modulemanager', 'zendframework/zend-mvc'=> 'laminas/laminas-mvc', 'zendframework/zend-navigation'=> 'laminas/laminas-navigation', 'zendframework/zend-oauth'=> 'laminas/laminas-oauth', 'zendframework/zend-paginator'=> 'laminas/laminas-paginator', 'zendframework/zend-permissions-acl'=> 'laminas/laminas-permissions-acl', 'zendframework/zend-permissions-rbac'=> 'laminas/laminas-permissions-rbac', 'zendframework/zend-pimple-config'=> 'laminas/laminas-pimple-config', 'zendframework/zend-progressbar'=> 'laminas/laminas-progressbar', 'zendframework/zend-psr7bridge'=> 'laminas/laminas-psr7bridge', 'zendframework/zend-recaptcha'=> 'laminas/laminas-recaptcha', 'zendframework/zend-router'=> 'laminas/laminas-router', 'zendframework/zend-serializer'=> 'laminas/laminas-serializer', 'zendframework/zend-server'=> 'laminas/laminas-server', 'zendframework/zend-servicemanager'=> 'laminas/laminas-servicemanager', 'zendframework/zendservice-recaptcha'=> 'laminas/laminas-recaptcha', 'zendframework/zendservice-twitter'=> 'laminas/laminas-twitter', 'zendframework/zend-session'=> 'laminas/laminas-session', 'zendframework/zend-skeleton-installer'=> 'laminas/laminas-skeleton-installer', 'zendframework/zend-soap'=> 'laminas/laminas-soap', 'zendframework/zend-stdlib'=> 'laminas/laminas-stdlib', 'zendframework/zend-stratigility'=> 'laminas/laminas-stratigility', 'zendframework/zend-tag'=> 'laminas/laminas-tag', 'zendframework/zend-test'=> 'laminas/laminas-test', 'zendframework/zend-text'=> 'laminas/laminas-text', 'zendframework/zend-uri'=> 'laminas/laminas-uri', 'zendframework/zend-validator'=> 'laminas/laminas-validator', 'zendframework/zend-view'=> 'laminas/laminas-view', 'zendframework/zend-xml2json'=> 'laminas/laminas-xml2json', 'zendframework/zend-xml'=> 'laminas/laminas-xml', 'zendframework/zend-xmlrpc'=> 'laminas/laminas-xmlrpc', 'zendframework/zend-expressive'=> 'mezzio/mezzio', 'zendframework/zend-expressive-zendrouter'=> 'mezzio/mezzio-laminasrouter', 'zendframework/zend-problem-details'=> 'mezzio/mezzio-problem-details', 'zendframework/zend-expressive-zendviewrenderer'=> 'mezzio/mezzio-laminasviewrenderer', 'zfcampus/apigility-documentation'=> 'laminas-api-tools/documentation', 'zfcampus/statuslib-example'=> 'laminas-api-tools/statuslib-example', 'zfcampus/zf-apigility'=> 'laminas-api-tools/api-tools', 'zfcampus/zf-api-problem'=> 'laminas-api-tools/api-tools-api-problem', 'zfcampus/zf-asset-manager'=> 'laminas-api-tools/api-tools-asset-manager', 'zfcampus/zf-configuration'=> 'laminas-api-tools/api-tools-configuration', 'zfcampus/zf-content-negotiation'=> 'laminas-api-tools/api-tools-content-negotiation', 'zfcampus/zf-content-validation'=> 'laminas-api-tools/api-tools-content-validation', 'zfcampus/zf-development-mode'=> 'laminas/laminas-development-mode', 'zfcampus/zf-doctrine-querybuilder'=> 'laminas-api-tools/api-tools-doctrine-querybuilder', 'zfcampus/zf-hal'=> 'laminas-api-tools/api-tools-hal', 'zfcampus/zf-http-cache'=> 'laminas-api-tools/api-tools-http-cache', 'zfcampus/zf-mvc-auth'=> 'laminas-api-tools/api-tools-mvc-auth', 'zfcampus/zf-oauth2'=> 'laminas-api-tools/api-tools-oauth2', 'zfcampus/zf-rest'=> 'laminas-api-tools/api-tools-rest', 'zfcampus/zf-rpc'=> 'laminas-api-tools/api-tools-rpc', 'zfcampus/zf-versioning'=> 'laminas-api-tools/api-tools-versioning', '::fromZend'=> '::fromLaminas', '::toZend'=> '::toLaminas', 'use_zend_loader'=> 'use_laminas_loader', 'zend-config'=> 'laminas-config', 'zend-developer-tools/'=> 'laminas-developer-tools/', 'zend-tag-cloud'=> 'laminas-tag-cloud', 'zenddevelopertools'=> 'laminas-developer-tools', 'zendbarcode'=> 'laminasbarcode', 'ZendBarcode'=> 'LaminasBarcode', 'zendcache'=> 'laminascache', 'ZendCache'=> 'LaminasCache', 'zendconfig'=> 'laminasconfig', 'ZendConfig'=> 'LaminasConfig', 'zendfeed'=> 'laminasfeed', 'ZendFeed'=> 'LaminasFeed', 'zendfilter'=> 'laminasfilter', 'ZendFilter'=> 'LaminasFilter', 'zendform'=> 'laminasform', 'ZendForm'=> 'LaminasForm', 'zendi18n'=> 'laminasi18n', 'ZendI18n'=> 'LaminasI18n', 'zendinputfilter'=> 'laminasinputfilter', 'ZendInputFilter'=> 'LaminasInputFilter', 'zendlog'=> 'laminaslog', 'ZendLog'=> 'LaminasLog', 'zendmail'=> 'laminasmail', 'ZendMail'=> 'LaminasMail', 'zendmvc'=> 'laminasmvc', 'ZendMvc'=> 'LaminasMvc', 'zendpaginator'=> 'laminaspaginator', 'ZendPaginator'=> 'LaminasPaginator', 'zendserializer'=> 'laminasserializer', 'ZendSerializer'=> 'LaminasSerializer', 'zendtag'=> 'laminastag', 'ZendTag'=> 'LaminasTag', 'zendtext'=> 'laminastext', 'ZendText'=> 'LaminasText', 'zendvalidator'=> 'laminasvalidator', 'ZendValidator'=> 'LaminasValidator', 'zendview'=> 'laminasview', 'ZendView'=> 'LaminasView', 'zend-framework.flf'=> 'laminas-project.flf', "'zend-expressive'"=> "'mezzio'", '"zend-expressive"'=> '"mezzio"', 'zend-expressive.'=> 'mezzio.', 'zend-expressive-authorization'=> 'mezzio-authorization', 'zend-expressive-hal'=> 'mezzio-hal', 'zend-expressive-session'=> 'mezzio-session', 'zend-expressive-swoole'=> 'mezzio-swoole', 'zend-expressive-tooling'=> 'mezzio-tooling', "'zf-apigility'"=> "'api-tools'", '"zf-apigility"'=> '"api-tools"', 'zf-apigility/'=> 'api-tools/', 'zf-apigility-admin'=> 'api-tools-admin', 'zf-content-negotiation'=> 'api-tools-content-negotiation', 'zf-hal'=> 'api-tools-hal', 'zf-rest'=> 'api-tools-rest', 'zf-rpc'=> 'api-tools-rpc', 'zf-content-validation'=> 'api-tools-content-validation', 'zf-apigility-ui'=> 'api-tools-ui', 'zf-apigility-documentation-blueprint'=> 'api-tools-documentation-blueprint', 'zf-apigility-documentation-swagger'=> 'api-tools-documentation-swagger', 'zf-apigility-welcome'=> 'api-tools-welcome', 'zf-api-problem'=> 'api-tools-api-problem', 'zf-configuration'=> 'api-tools-configuration', 'zf-http-cache'=> 'api-tools-http-cache', 'zf-mvc-auth'=> 'api-tools-mvc-auth', 'zf-oauth2'=> 'api-tools-oauth2', 'zf-versioning'=> 'api-tools-versioning', 'ZfApigilityDoctrineQueryProviderManager'=> 'LaminasApiToolsDoctrineQueryProviderManager', 'ZfApigilityDoctrineQueryCreateFilterManager'=> 'LaminasApiToolsDoctrineQueryCreateFilterManager', 'zf-apigility-doctrine'=> 'api-tools-doctrine', 'zf-development-mode'=> 'laminas-development-mode', 'zf-doctrine-querybuilder'=> 'api-tools-doctrine-querybuilder', 'api-skeletons/zf-'=> 'api-skeletons/zf-', 'zf-oauth2-'=> 'zf-oauth2-', 'ZF\\OAuth2\\Client'=> 'ZF\\OAuth2\\Client', 'ZF\\OAuth2\\Doctrine'=> 'ZF\\OAuth2\\Doctrine',]


Joomla CMS: Référence du fichier TagsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TagsHelper.php

Structures de données

class TagsHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier TaskStateField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TaskStateField.php

Structures de données

class TaskStateField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Field


Joomla CMS: Référence du fichier UnexpectedResponseException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnexpectedResponseException.php

Structures de données

class UnexpectedResponseException

Espaces de nommage

Joomla\Http\Exception


Joomla CMS: Référence du fichier Pattern.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Pattern.php

Structures de données

class Pattern

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/joomla/router/src/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Router


Joomla CMS: Référence du fichier RandomBytesGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier RandomBytesGenerator.php

Structures de données

class RandomBytesGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier WritableLoaderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
  • Loader
Structures de données | Espaces de nommage
Référence du fichier WritableLoaderInterface.php

Structures de données

interface WritableLoaderInterface

Espaces de nommage

Joomla\CMS\Console\Loader


Joomla CMS: Référence du fichier Redirect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_redirect
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Redirect.php

Structures de données

class Redirect

Espaces de nommage

Joomla\Administrator
Joomla\Component\Redirect\Administrator\Service\HTML


Joomla CMS: Référence du fichier PredefinedlistField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier PredefinedlistField.php

Structures de données

class PredefinedlistField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier TaskPluginTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Traits
Espaces de nommage | Fonctions | Variables
Référence du fichier TaskPluginTrait.php

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Traits

Fonctions

startRoutine (ExecuteTaskEvent $event)
endRoutine (ExecuteTaskEvent $event, int $exitCode)
advertiseRoutines (EventInterface $event)
getRoutineId (Form $form, $data)
logTask (string $message, string $priority='info')
standardRoutineHandler (ExecuteTaskEvent $event)

Variables

trait TaskPluginTrait


Joomla CMS: Référence du fichier UsernameRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Form/Rule/UsernameRule.php

Structures de données

class UsernameRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier vertical.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_news
  • tmpl
Espaces de nommage | Variables
Référence du fichier vertical.php

Espaces de nommage

Joomla\Site

Variables

$wa = $app->getDocument()->getWebAssetManager()
if(! $list) | for ( $i=0, $n=count( $list);$i< $n;$i++)
if($n > 1 &&(($i< $n - 1)|| $params->get('showLastSeparator'))) | endfor

Documentation des variables

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()

◆ endfor

if ( $n > 1 &&(( $i< $n - 1)||$params->get( 'showLastSeparator'))) endfor

◆ for

string $for The id of the input this label is for


Joomla CMS: Référence du fichier status.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • templates
  • atum
  • html
  • layouts
Espaces de nommage | Variables
Référence du fichier status.php

Espaces de nommage

Joomla\Administrator

Variables

$modulePosition = $displayData['modules']
$renderer = Factory::getDocument()->loadRenderer('module')
$modules = ModuleHelper::getModules($modulePosition)
$moduleHtml = []
$moduleCollapsedHtml = []
foreach($modules as $key=> $mod) foreach ( $moduleHtml as $mod)

Documentation des variables

◆ $moduleCollapsedHtml

$moduleCollapsedHtml = []

◆ $moduleHtml

$moduleHtml = []

Référencé par ModulesRenderer\render().

◆ $modulePosition

$modulePosition = $displayData['modules']

◆ $modules

$modules = ModuleHelper::getModules($modulePosition)

◆ $renderer

$renderer = Factory::getDocument()->loadRenderer('module')

Référencé par PlgContentLoadmodule\_load(), PlgContentLoadmodule\_loadid(), PlgContentLoadmodule\_loadmod(), HtmlDocument\countModules(), ModulesPositioneditField\getInput(), SubformField\getInput(), CategoryeditField\getInput(), FormField\getLayoutPaths(), PlgSystemStats\getRenderer(), FormField\getRenderer(), ModulesRenderer\render(), FeedDocument\render(), et ErrorHandler\renderException().

◆ foreach

foreach ( $modules as $key=> $mod) foreach($moduleHtml as $mod)


Joomla CMS: Référence du fichier Yaml.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • registry
  • src
  • Format
Structures de données | Espaces de nommage
Référence du fichier joomla/registry/src/Format/Yaml.php

Structures de données

class Yaml

Espaces de nommage

Joomla\Registry\Format


Joomla CMS: Référence du fichier RS512.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/RS512.php

Structures de données

class RS512

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier Webauthn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier multifactorauth/webauthn/src/Extension/Webauthn.php

Structures de données

class Webauthn

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn\Extension


Joomla CMS: Référence du fichier substr_replace.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier substr_replace.php

Espaces de nommage

utf8

Fonctions

utf8_substr_replace ($str, $repl, $start, $length=NULL)

Documentation des fonctions

◆ utf8_substr_replace()

utf8_substr_replace | ( | $str,
 |  | $repl,
 |  | $start,
 |  | $length = NULL
 | ) |

UTF-8 aware substr_replace. Note: requires utf8_substr to be loaded

Voir également
http://www.php.net/substr_replace
utf8_strlen
utf8_substr

Références $start, et utf8_strlen().

Référencé par StringHelper\substr_replace(), et utf8_ucwords_callback().


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_postinstall
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_postinstall/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier php72compat.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • lib
Variables
Référence du fichier php72compat.php

Variables

foreach(array('BASE64_VARIANT_ORIGINAL', 'BASE64_VARIANT_ORIGINAL_NO_PADDING', 'BASE64_VARIANT_URLSAFE', 'BASE64_VARIANT_URLSAFE_NO_PADDING', 'CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_ABYTES', 'CRYPTO_AEAD_AES256GCM_KEYBYTES', 'CRYPTO_AEAD_AES256GCM_NSECBYTES', 'CRYPTO_AEAD_AES256GCM_NPUBBYTES', 'CRYPTO_AEAD_AES256GCM_ABYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES', 'CRYPTO_AUTH_BYTES', 'CRYPTO_AUTH_KEYBYTES', 'CRYPTO_BOX_SEALBYTES', 'CRYPTO_BOX_SECRETKEYBYTES', 'CRYPTO_BOX_PUBLICKEYBYTES', 'CRYPTO_BOX_KEYPAIRBYTES', 'CRYPTO_BOX_MACBYTES', 'CRYPTO_BOX_NONCEBYTES', 'CRYPTO_BOX_SEEDBYTES', 'CRYPTO_KDF_BYTES_MIN', 'CRYPTO_KDF_BYTES_MAX', 'CRYPTO_KDF_CONTEXTBYTES', 'CRYPTO_KDF_KEYBYTES', 'CRYPTO_KX_BYTES', 'CRYPTO_KX_KEYPAIRBYTES', 'CRYPTO_KX_PRIMITIVE', 'CRYPTO_KX_SEEDBYTES', 'CRYPTO_KX_PUBLICKEYBYTES', 'CRYPTO_KX_SECRETKEYBYTES', 'CRYPTO_KX_SESSIONKEYBYTES', 'CRYPTO_GENERICHASH_BYTES', 'CRYPTO_GENERICHASH_BYTES_MIN', 'CRYPTO_GENERICHASH_BYTES_MAX', 'CRYPTO_GENERICHASH_KEYBYTES', 'CRYPTO_GENERICHASH_KEYBYTES_MIN', 'CRYPTO_GENERICHASH_KEYBYTES_MAX', 'CRYPTO_PWHASH_SALTBYTES', 'CRYPTO_PWHASH_STRPREFIX', 'CRYPTO_PWHASH_ALG_ARGON2I13', 'CRYPTO_PWHASH_ALG_ARGON2ID13', 'CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_MEMLIMIT_MODERATE', 'CRYPTO_PWHASH_OPSLIMIT_MODERATE', 'CRYPTO_PWHASH_MEMLIMIT_SENSITIVE', 'CRYPTO_PWHASH_OPSLIMIT_SENSITIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE', 'CRYPTO_SCALARMULT_BYTES', 'CRYPTO_SCALARMULT_SCALARBYTES', 'CRYPTO_SHORTHASH_BYTES', 'CRYPTO_SHORTHASH_KEYBYTES', 'CRYPTO_SECRETBOX_KEYBYTES', 'CRYPTO_SECRETBOX_MACBYTES', 'CRYPTO_SECRETBOX_NONCEBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX', 'CRYPTO_SIGN_BYTES', 'CRYPTO_SIGN_SEEDBYTES', 'CRYPTO_SIGN_PUBLICKEYBYTES', 'CRYPTO_SIGN_SECRETKEYBYTES', 'CRYPTO_SIGN_KEYPAIRBYTES', 'CRYPTO_STREAM_KEYBYTES', 'CRYPTO_STREAM_NONCEBYTES', 'CRYPTO_STREAM_XCHACHA20_KEYBYTES', 'CRYPTO_STREAM_XCHACHA20_NONCEBYTES', 'LIBRARY_MAJOR_VERSION', 'LIBRARY_MINOR_VERSION', 'LIBRARY_VERSION_MAJOR', 'LIBRARY_VERSION_MINOR', 'VERSION_STRING') as $constant) if(!is_callable('sodium_add')) if(!is_callable('sodium_base642bin')) if(!is_callable('sodium_bin2base64')) if(!is_callable('sodium_bin2hex')) if(!is_callable('sodium_compare')) if(!is_callable('sodium_crypto_aead_aes256gcm_decrypt')) if(!is_callable('sodium_crypto_aead_aes256gcm_encrypt')) if(!is_callable('sodium_crypto_aead_aes256gcm_is_available')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_decrypt')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_encrypt')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_keygen')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_ietf_decrypt')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_ietf_encrypt')) if(!is_callable('sodium_crypto_aead_chacha20poly1305_ietf_keygen')) if(!is_callable('sodium_crypto_aead_xchacha20poly1305_ietf_decrypt')) if(!is_callable('sodium_crypto_aead_xchacha20poly1305_ietf_encrypt')) if(!is_callable('sodium_crypto_aead_xchacha20poly1305_ietf_keygen')) if(!is_callable('sodium_crypto_auth')) if(!is_callable('sodium_crypto_auth_keygen')) if(!is_callable('sodium_crypto_auth_verify')) if(!is_callable('sodium_crypto_box')) if(!is_callable('sodium_crypto_box_keypair')) if(!is_callable('sodium_crypto_box_keypair_from_secretkey_and_publickey')) if(!is_callable('sodium_crypto_box_open')) if(!is_callable('sodium_crypto_box_publickey')) if(!is_callable('sodium_crypto_box_publickey_from_secretkey')) if(!is_callable('sodium_crypto_box_seal')) if(!is_callable('sodium_crypto_box_seal_open')) if(!is_callable('sodium_crypto_box_secretkey')) if(!is_callable('sodium_crypto_box_seed_keypair')) if(!is_callable('sodium_crypto_generichash')) if(!is_callable('sodium_crypto_generichash_final')) if(!is_callable('sodium_crypto_generichash_init')) if(!is_callable('sodium_crypto_generichash_keygen')) if(!is_callable('sodium_crypto_generichash_update')) if(!is_callable('sodium_crypto_kdf_keygen')) if(!is_callable('sodium_crypto_kdf_derive_from_key')) if(!is_callable('sodium_crypto_kx')) if(!is_callable('sodium_crypto_kx_seed_keypair')) if(!is_callable('sodium_crypto_kx_keypair')) if(!is_callable('sodium_crypto_kx_client_session_keys')) if(!is_callable('sodium_crypto_kx_server_session_keys')) if(!is_callable('sodium_crypto_kx_secretkey')) if(!is_callable('sodium_crypto_kx_publickey')) if(!is_callable('sodium_crypto_pwhash')) if(!is_callable('sodium_crypto_pwhash_str')) if(!is_callable('sodium_crypto_pwhash_str_needs_rehash')) if(!is_callable('sodium_crypto_pwhash_str_verify')) if(!is_callable('sodium_crypto_pwhash_scryptsalsa208sha256')) if(!is_callable('sodium_crypto_pwhash_scryptsalsa208sha256_str')) if(!is_callable('sodium_crypto_pwhash_scryptsalsa208sha256_str_verify')) if(!is_callable('sodium_crypto_scalarmult')) if(!is_callable('sodium_crypto_scalarmult_base')) if(!is_callable('sodium_crypto_secretbox')) if(!is_callable('sodium_crypto_secretbox_keygen')) if(!is_callable('sodium_crypto_secretbox_open')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_init_push')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_push')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_init_pull')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_pull')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_rekey')) if(!is_callable('sodium_crypto_secretstream_xchacha20poly1305_keygen')) if(!is_callable('sodium_crypto_shorthash')) if(!is_callable('sodium_crypto_shorthash_keygen')) if(!is_callable('sodium_crypto_sign')) if(!is_callable('sodium_crypto_sign_detached')) if(!is_callable('sodium_crypto_sign_keypair_from_secretkey_and_publickey')) if(!is_callable('sodium_crypto_sign_keypair')) if(!is_callable('sodium_crypto_sign_open')) if(!is_callable('sodium_crypto_sign_publickey')) if(!is_callable('sodium_crypto_sign_publickey_from_secretkey')) if(!is_callable('sodium_crypto_sign_secretkey')) if(!is_callable('sodium_crypto_sign_seed_keypair')) if(!is_callable('sodium_crypto_sign_verify_detached')) if(!is_callable('sodium_crypto_sign_ed25519_pk_to_curve25519')) if(!is_callable('sodium_crypto_sign_ed25519_sk_to_curve25519')) if(!is_callable('sodium_crypto_stream')) if(!is_callable('sodium_crypto_stream_keygen')) if (!is_callable( 'sodium_crypto_stream_xor'))

Documentation des variables

◆ if

foreach (array( 'BASE64_VARIANT_ORIGINAL', 'BASE64_VARIANT_ORIGINAL_NO_PADDING', 'BASE64_VARIANT_URLSAFE', 'BASE64_VARIANT_URLSAFE_NO_PADDING', 'CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_ABYTES', 'CRYPTO_AEAD_AES256GCM_KEYBYTES', 'CRYPTO_AEAD_AES256GCM_NSECBYTES', 'CRYPTO_AEAD_AES256GCM_NPUBBYTES', 'CRYPTO_AEAD_AES256GCM_ABYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES', 'CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES', 'CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES', 'CRYPTO_AUTH_BYTES', 'CRYPTO_AUTH_KEYBYTES', 'CRYPTO_BOX_SEALBYTES', 'CRYPTO_BOX_SECRETKEYBYTES', 'CRYPTO_BOX_PUBLICKEYBYTES', 'CRYPTO_BOX_KEYPAIRBYTES', 'CRYPTO_BOX_MACBYTES', 'CRYPTO_BOX_NONCEBYTES', 'CRYPTO_BOX_SEEDBYTES', 'CRYPTO_KDF_BYTES_MIN', 'CRYPTO_KDF_BYTES_MAX', 'CRYPTO_KDF_CONTEXTBYTES', 'CRYPTO_KDF_KEYBYTES', 'CRYPTO_KX_BYTES', 'CRYPTO_KX_KEYPAIRBYTES', 'CRYPTO_KX_PRIMITIVE', 'CRYPTO_KX_SEEDBYTES', 'CRYPTO_KX_PUBLICKEYBYTES', 'CRYPTO_KX_SECRETKEYBYTES', 'CRYPTO_KX_SESSIONKEYBYTES', 'CRYPTO_GENERICHASH_BYTES', 'CRYPTO_GENERICHASH_BYTES_MIN', 'CRYPTO_GENERICHASH_BYTES_MAX', 'CRYPTO_GENERICHASH_KEYBYTES', 'CRYPTO_GENERICHASH_KEYBYTES_MIN', 'CRYPTO_GENERICHASH_KEYBYTES_MAX', 'CRYPTO_PWHASH_SALTBYTES', 'CRYPTO_PWHASH_STRPREFIX', 'CRYPTO_PWHASH_ALG_ARGON2I13', 'CRYPTO_PWHASH_ALG_ARGON2ID13', 'CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_MEMLIMIT_MODERATE', 'CRYPTO_PWHASH_OPSLIMIT_MODERATE', 'CRYPTO_PWHASH_MEMLIMIT_SENSITIVE', 'CRYPTO_PWHASH_OPSLIMIT_SENSITIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE', 'CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE', 'CRYPTO_SCALARMULT_BYTES', 'CRYPTO_SCALARMULT_SCALARBYTES', 'CRYPTO_SHORTHASH_BYTES', 'CRYPTO_SHORTHASH_KEYBYTES', 'CRYPTO_SECRETBOX_KEYBYTES', 'CRYPTO_SECRETBOX_MACBYTES', 'CRYPTO_SECRETBOX_NONCEBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PULL', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL', 'CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX', 'CRYPTO_SIGN_BYTES', 'CRYPTO_SIGN_SEEDBYTES', 'CRYPTO_SIGN_PUBLICKEYBYTES', 'CRYPTO_SIGN_SECRETKEYBYTES', 'CRYPTO_SIGN_KEYPAIRBYTES', 'CRYPTO_STREAM_KEYBYTES', 'CRYPTO_STREAM_NONCEBYTES', 'CRYPTO_STREAM_XCHACHA20_KEYBYTES', 'CRYPTO_STREAM_XCHACHA20_NONCEBYTES', 'LIBRARY_MAJOR_VERSION', 'LIBRARY_MINOR_VERSION', 'LIBRARY_VERSION_MAJOR', 'LIBRARY_VERSION_MINOR', 'VERSION_STRING') as $constant) if (!is_callable( 'sodium_add')) if (!is_callable( 'sodium_base642bin')) if (!is_callable( 'sodium_bin2base64')) if (!is_callable( 'sodium_bin2hex')) if (!is_callable( 'sodium_compare')) if (!is_callable( 'sodium_crypto_aead_aes256gcm_decrypt')) if (!is_callable( 'sodium_crypto_aead_aes256gcm_encrypt')) if (!is_callable( 'sodium_crypto_aead_aes256gcm_is_available')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_decrypt')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_encrypt')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_keygen')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_ietf_decrypt')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_ietf_encrypt')) if (!is_callable( 'sodium_crypto_aead_chacha20poly1305_ietf_keygen')) if (!is_callable( 'sodium_crypto_aead_xchacha20poly1305_ietf_decrypt')) if (!is_callable( 'sodium_crypto_aead_xchacha20poly1305_ietf_encrypt')) if (!is_callable( 'sodium_crypto_aead_xchacha20poly1305_ietf_keygen')) if (!is_callable( 'sodium_crypto_auth')) if (!is_callable( 'sodium_crypto_auth_keygen')) if (!is_callable( 'sodium_crypto_auth_verify')) if (!is_callable( 'sodium_crypto_box')) if (!is_callable( 'sodium_crypto_box_keypair')) if (!is_callable( 'sodium_crypto_box_keypair_from_secretkey_and_publickey')) if (!is_callable( 'sodium_crypto_box_open')) if (!is_callable( 'sodium_crypto_box_publickey')) if (!is_callable( 'sodium_crypto_box_publickey_from_secretkey')) if (!is_callable( 'sodium_crypto_box_seal')) if (!is_callable( 'sodium_crypto_box_seal_open')) if (!is_callable( 'sodium_crypto_box_secretkey')) if (!is_callable( 'sodium_crypto_box_seed_keypair')) if (!is_callable( 'sodium_crypto_generichash')) if (!is_callable( 'sodium_crypto_generichash_final')) if (!is_callable( 'sodium_crypto_generichash_init')) if (!is_callable( 'sodium_crypto_generichash_keygen')) if (!is_callable( 'sodium_crypto_generichash_update')) if (!is_callable( 'sodium_crypto_kdf_keygen')) if (!is_callable( 'sodium_crypto_kdf_derive_from_key')) if (!is_callable( 'sodium_crypto_kx')) if (!is_callable( 'sodium_crypto_kx_seed_keypair')) if (!is_callable( 'sodium_crypto_kx_keypair')) if (!is_callable( 'sodium_crypto_kx_client_session_keys')) if (!is_callable( 'sodium_crypto_kx_server_session_keys')) if (!is_callable( 'sodium_crypto_kx_secretkey')) if (!is_callable( 'sodium_crypto_kx_publickey')) if (!is_callable( 'sodium_crypto_pwhash')) if (!is_callable( 'sodium_crypto_pwhash_str')) if (!is_callable( 'sodium_crypto_pwhash_str_needs_rehash')) if (!is_callable( 'sodium_crypto_pwhash_str_verify')) if (!is_callable( 'sodium_crypto_pwhash_scryptsalsa208sha256')) if (!is_callable( 'sodium_crypto_pwhash_scryptsalsa208sha256_str')) if (!is_callable( 'sodium_crypto_pwhash_scryptsalsa208sha256_str_verify')) if (!is_callable( 'sodium_crypto_scalarmult')) if (!is_callable( 'sodium_crypto_scalarmult_base')) if (!is_callable( 'sodium_crypto_secretbox')) if (!is_callable( 'sodium_crypto_secretbox_keygen')) if (!is_callable( 'sodium_crypto_secretbox_open')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_init_push')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_push')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_init_pull')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_pull')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_rekey')) if (!is_callable( 'sodium_crypto_secretstream_xchacha20poly1305_keygen')) if (!is_callable( 'sodium_crypto_shorthash')) if (!is_callable( 'sodium_crypto_shorthash_keygen')) if (!is_callable( 'sodium_crypto_sign')) if (!is_callable( 'sodium_crypto_sign_detached')) if (!is_callable( 'sodium_crypto_sign_keypair_from_secretkey_and_publickey')) if (!is_callable( 'sodium_crypto_sign_keypair')) if (!is_callable( 'sodium_crypto_sign_open')) if (!is_callable( 'sodium_crypto_sign_publickey')) if (!is_callable( 'sodium_crypto_sign_publickey_from_secretkey')) if (!is_callable( 'sodium_crypto_sign_secretkey')) if (!is_callable( 'sodium_crypto_sign_seed_keypair')) if (!is_callable( 'sodium_crypto_sign_verify_detached')) if (!is_callable( 'sodium_crypto_sign_ed25519_pk_to_curve25519')) if (!is_callable( 'sodium_crypto_sign_ed25519_sk_to_curve25519')) if (!is_callable( 'sodium_crypto_stream')) if (!is_callable( 'sodium_crypto_stream_keygen')) if(!is_callable('sodium_crypto_stream_xor'))

This file will monkey patch the pure-PHP implementation in place of the PECL functions and constants, but only if they do not already exist.

Thus, the functions or constants just proxy to the appropriate ParagonIE_Sodium_Compat method or class constant, respectively.

Voir également
ParagonIE_Sodium_Compat::add()
Paramètres
string | $val
string | $addv
Renvoie
void
Exceptions
SodiumException
Voir également
ParagonIE_Sodium_Compat::bin2base64()
Paramètres
string | $string
int | $variant
string | $ignore
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::bin2base64()
Paramètres
string | $string
int | $variant
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::hex2bin()
Paramètres
string $string
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::compare()
Paramètres
string | $a
string | $b
Renvoie
int
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_aead_aes256gcm_decrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_aead_aes256gcm_encrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_aead_aes256gcm_is_available()
Renvoie
bool
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_decrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_encrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_ietf_decrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_ietf_encrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_aead_chacha20poly1305_ietf_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_aead_xchacha20poly1305_ietf_decrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_aead_xchacha20poly1305_ietf_encrypt()
Paramètres
string | $message
string | $assocData
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_aead_xchacha20poly1305_ietf_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_auth()
Paramètres
string | $message
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_auth_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_auth_verify()
Paramètres
string | $mac
string | $message
string | $key
Renvoie
bool
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box()
Paramètres
string | $message
string | $nonce
string | $kp
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_keypair()
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_keypair_from_secretkey_and_publickey()
Paramètres
string | $sk
string | $pk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_open()
Paramètres
string | $message
string | $nonce
string | $kp
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_box_publickey()
Paramètres
string $keypair
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_publickey_from_secretkey()
Paramètres
string $sk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_seal()
Paramètres
string | $message
string | $publicKey
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_seal_open()
Paramètres
string | $message
string | $kp
Renvoie
string|bool
Exceptions
SodiumException
Voir également
ParagonIE_Sodium_Compat::crypto_box_secretkey()
Paramètres
string $keypair
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_box_seed_keypair()
Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_generichash()
Paramètres
string | $message
string | null | $key
int | $outLen
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_generichash_final()
Paramètres
string | null | $ctx
int | $outputLength
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_generichash_init()
Paramètres
string | null | $key
int | $outLen
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_generichash_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_generichash_update()
Paramètres
string | null | $ctx
string | $message
Renvoie
void
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_kdf_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_kdf_derive_from_key()
Paramètres
int | $subkey_len
int | $subkey_id
string | $context
string | $key
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_kx()
Paramètres
string | $my_secret
string | $their_public
string | $client_public
string | $server_public
Renvoie
string
Exceptions
SodiumException
TypeError
Paramètres
string $seed
Renvoie
string
Exceptions
Exception
Renvoie
string
Exceptions
Exception
Paramètres
string | $keypair
string | $serverPublicKey
Renvoie
array{0: string, 1: string}
Exceptions
SodiumException
Paramètres
string | $keypair
string | $clientPublicKey
Renvoie
array{0: string, 1: string}
Exceptions
SodiumException
Paramètres
string $keypair
Renvoie
string
Exceptions
Exception
Paramètres
string $keypair
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash()
Paramètres
int | $outlen
string | $passwd
string | $salt
int | $opslimit
int | $memlimit
int | null | $algo
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_str()
Paramètres
string | $passwd
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_str_needs_rehash()
Paramètres
string | $hash
int | $opslimit
int | $memlimit
Renvoie
bool
Exceptions
SodiumException
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_str_verify()
Paramètres
string | $passwd
string | $hash
Renvoie
bool
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_scryptsalsa208sha256()
Paramètres
int | $outlen
string | $passwd
string | $salt
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_scryptsalsa208sha256_str()
Paramètres
string | $passwd
int | $opslimit
int | $memlimit
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_pwhash_scryptsalsa208sha256_str_verify()
Paramètres
string | $passwd
string | $hash
Renvoie
bool
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_scalarmult()
Paramètres
string | $n
string | $p
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_scalarmult_base()
Paramètres
string $n
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_secretbox()
Paramètres
string | $message
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_secretbox_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_secretbox_open()
Paramètres
string | $message
string | $nonce
string | $key
Renvoie
string|bool
Paramètres
string $key
Renvoie
array<int, string>
Exceptions
SodiumException
Paramètres
string | $state
string | $msg
string | $aad
int | $tag
Renvoie
string
Exceptions
SodiumException
Paramètres
string | $header
string | $key
Renvoie
string
Exceptions
Exception
Paramètres
string | $state
string | $cipher
string | $aad
Renvoie
bool|array{0: string, 1: int}
Exceptions
SodiumException
Paramètres
string $state
Renvoie
void
Exceptions
SodiumException
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_shorthash()
Paramètres
string | $message
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_shorthash_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_sign()
Paramètres
string | $message
string | $sk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_detached()
Paramètres
string | $message
string | $sk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_keypair_from_secretkey_and_publickey()
Paramètres
string | $sk
string | $pk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_keypair()
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_open()
Paramètres
string | $signedMessage
string | $pk
Renvoie
string|bool
Voir également
ParagonIE_Sodium_Compat::crypto_sign_publickey()
Paramètres
string $keypair
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_publickey_from_secretkey()
Paramètres
string $sk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_secretkey()
Paramètres
string $keypair
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_seed_keypair()
Paramètres
string $seed
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_verify_detached()
Paramètres
string | $signature
string | $message
string | $pk
Renvoie
bool
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_ed25519_pk_to_curve25519()
Paramètres
string $pk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_sign_ed25519_sk_to_curve25519()
Paramètres
string $sk
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_stream()
Paramètres
int | $len
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError
Voir également
ParagonIE_Sodium_Compat::crypto_stream_keygen()
Renvoie
string
Exceptions
Exception
Voir également
ParagonIE_Sodium_Compat::crypto_stream_xor()
Paramètres
string | $message
string | $nonce
string | $key
Renvoie
string
Exceptions
SodiumException
TypeError


Joomla CMS: Référence du fichier RDNSequence.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier RDNSequence.php

Structures de données

class RDNSequence

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier SiteUpCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier SiteUpCommand.php

Structures de données

class SiteUpCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier PuTTY.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier Common/Formats/Keys/PuTTY.php

Structures de données

class PuTTY

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Keys


Joomla CMS: Référence du fichier x00f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x00f.php


Joomla CMS: Référence du fichier x09d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09d.php

Variables

return ['Fou ', 'Yiao ', 'Jue ', 'Jue ', 'Pi ', 'Huan ', 'Zhen ', 'Bao ', 'Yan ', 'Ya ', 'Zheng ', 'Fang ', 'Feng ', 'Wen ', 'Ou ', 'Te ', 'Jia ', 'Nu ', 'Ling ', 'Mie ', 'Fu ', 'Tuo ', 'Wen ', 'Li ', 'Bian ', 'Zhi ', 'Ge ', 'Yuan ', 'Zi ', 'Qu ', 'Xiao ', 'Zhi ', 'Dan ', 'Ju ', 'You ', 'Gu ', 'Zhong ', 'Yu ', 'Yang ', 'Rong ', 'Ya ', 'Tie ', 'Yu ', 'Shigi ', 'Ying ', 'Zhui ', 'Wu ', 'Er ', 'Gua ', 'Ai ', 'Zhi ', 'Yan ', 'Heng ', 'Jiao ', 'Ji ', 'Lie ', 'Zhu ', 'Ren ', 'Yi ', 'Hong ', 'Luo ', 'Ru ', 'Mou ', 'Ge ', 'Ren ', 'Jiao ', 'Xiu ', 'Zhou ', 'Zhi ', 'Luo ', 'Chidori ', 'Toki ', 'Ten ', 'Luan ', 'Jia ', 'Ji ', 'Yu ', 'Huan ', 'Tuo ', 'Bu ', 'Wu ', 'Juan ', 'Yu ', 'Bo ', 'Xun ', 'Xun ', 'Bi ', 'Xi ', 'Jun ', 'Ju ', 'Tu ', 'Jing ', 'Ti ', 'E ', 'E ', 'Kuang ', 'Hu ', 'Wu ', 'Shen ', 'Lai ', 'Ikaruga ', 'Kakesu ', 'Lu ', 'Ping ', 'Shu ', 'Fu ', 'An ', 'Zhao ', 'Peng ', 'Qin ', 'Qian ', 'Bei ', 'Diao ', 'Lu ', 'Que ', 'Jian ', 'Ju ', 'Tu ', 'Ya ', 'Yuan ', 'Qi ', 'Li ', 'Ye ', 'Zhui ', 'Kong ', 'Zhui ', 'Kun ', 'Sheng ', 'Qi ', 'Jing ', 'Yi ', 'Yi ', 'Jing ', 'Zi ', 'Lai ', 'Dong ', 'Qi ', 'Chun ', 'Geng ', 'Ju ', 'Qu ', 'Isuka ', 'Kikuitadaki ', 'Ji ', 'Shu ', '[?] ', 'Chi ', 'Miao ', 'Rou ', 'An ', 'Qiu ', 'Ti ', 'Hu ', 'Ti ', 'E ', 'Jie ', 'Mao ', 'Fu ', 'Chun ', 'Tu ', 'Yan ', 'He ', 'Yuan ', 'Pian ', 'Yun ', 'Mei ', 'Hu ', 'Ying ', 'Dun ', 'Mu ', 'Ju ', 'Tsugumi ', 'Cang ', 'Fang ', 'Gu ', 'Ying ', 'Yuan ', 'Xuan ', 'Weng ', 'Shi ', 'He ', 'Chu ', 'Tang ', 'Xia ', 'Ruo ', 'Liu ', 'Ji ', 'Gu ', 'Jian ', 'Zhun ', 'Han ', 'Zi ', 'Zi ', 'Ni ', 'Yao ', 'Yan ', 'Ji ', 'Li ', 'Tian ', 'Kou ', 'Ti ', 'Ti ', 'Ni ', 'Tu ', 'Ma ', 'Jiao ', 'Gao ', 'Tian ', 'Chen ', 'Li ', 'Zhuan ', 'Zhe ', 'Ao ', 'Yao ', 'Yi ', 'Ou ', 'Chi ', 'Zhi ', 'Liao ', 'Rong ', 'Lou ', 'Bi ', 'Shuang ', 'Zhuo ', 'Yu ', 'Wu ', 'Jue ', 'Yin ', 'Quan ', 'Si ', 'Jiao ', 'Yi ', 'Hua ', 'Bi ', 'Ying ', 'Su ', 'Huang ', 'Fan ', 'Jiao ', 'Liao ', 'Yan ', 'Kao ', 'Jiu ', 'Xian ', 'Xian ', 'Tu ', 'Mai ', 'Zun ', 'Yu ', 'Ying ', 'Lu ', 'Tuan ', 'Xian ', 'Xue ', 'Yi ', 'Pi ']

Documentation des variables

◆ return

return[ 'Fou ', 'Yiao ', 'Jue ', 'Jue ', 'Pi ', 'Huan ', 'Zhen ', 'Bao ', 'Yan ', 'Ya ', 'Zheng ', 'Fang ', 'Feng ', 'Wen ', 'Ou ', 'Te ', 'Jia ', 'Nu ', 'Ling ', 'Mie ', 'Fu ', 'Tuo ', 'Wen ', 'Li ', 'Bian ', 'Zhi ', 'Ge ', 'Yuan ', 'Zi ', 'Qu ', 'Xiao ', 'Zhi ', 'Dan ', 'Ju ', 'You ', 'Gu ', 'Zhong ', 'Yu ', 'Yang ', 'Rong ', 'Ya ', 'Tie ', 'Yu ', 'Shigi ', 'Ying ', 'Zhui ', 'Wu ', 'Er ', 'Gua ', 'Ai ', 'Zhi ', 'Yan ', 'Heng ', 'Jiao ', 'Ji ', 'Lie ', 'Zhu ', 'Ren ', 'Yi ', 'Hong ', 'Luo ', 'Ru ', 'Mou ', 'Ge ', 'Ren ', 'Jiao ', 'Xiu ', 'Zhou ', 'Zhi ', 'Luo ', 'Chidori ', 'Toki ', 'Ten ', 'Luan ', 'Jia ', 'Ji ', 'Yu ', 'Huan ', 'Tuo ', 'Bu ', 'Wu ', 'Juan ', 'Yu ', 'Bo ', 'Xun ', 'Xun ', 'Bi ', 'Xi ', 'Jun ', 'Ju ', 'Tu ', 'Jing ', 'Ti ', 'E ', 'E ', 'Kuang ', 'Hu ', 'Wu ', 'Shen ', 'Lai ', 'Ikaruga ', 'Kakesu ', 'Lu ', 'Ping ', 'Shu ', 'Fu ', 'An ', 'Zhao ', 'Peng ', 'Qin ', 'Qian ', 'Bei ', 'Diao ', 'Lu ', 'Que ', 'Jian ', 'Ju ', 'Tu ', 'Ya ', 'Yuan ', 'Qi ', 'Li ', 'Ye ', 'Zhui ', 'Kong ', 'Zhui ', 'Kun ', 'Sheng ', 'Qi ', 'Jing ', 'Yi ', 'Yi ', 'Jing ', 'Zi ', 'Lai ', 'Dong ', 'Qi ', 'Chun ', 'Geng ', 'Ju ', 'Qu ', 'Isuka ', 'Kikuitadaki ', 'Ji ', 'Shu ', '[?] ', 'Chi ', 'Miao ', 'Rou ', 'An ', 'Qiu ', 'Ti ', 'Hu ', 'Ti ', 'E ', 'Jie ', 'Mao ', 'Fu ', 'Chun ', 'Tu ', 'Yan ', 'He ', 'Yuan ', 'Pian ', 'Yun ', 'Mei ', 'Hu ', 'Ying ', 'Dun ', 'Mu ', 'Ju ', 'Tsugumi ', 'Cang ', 'Fang ', 'Gu ', 'Ying ', 'Yuan ', 'Xuan ', 'Weng ', 'Shi ', 'He ', 'Chu ', 'Tang ', 'Xia ', 'Ruo ', 'Liu ', 'Ji ', 'Gu ', 'Jian ', 'Zhun ', 'Han ', 'Zi ', 'Zi ', 'Ni ', 'Yao ', 'Yan ', 'Ji ', 'Li ', 'Tian ', 'Kou ', 'Ti ', 'Ti ', 'Ni ', 'Tu ', 'Ma ', 'Jiao ', 'Gao ', 'Tian ', 'Chen ', 'Li ', 'Zhuan ', 'Zhe ', 'Ao ', 'Yao ', 'Yi ', 'Ou ', 'Chi ', 'Zhi ', 'Liao ', 'Rong ', 'Lou ', 'Bi ', 'Shuang ', 'Zhuo ', 'Yu ', 'Wu ', 'Jue ', 'Yin ', 'Quan ', 'Si ', 'Jiao ', 'Yi ', 'Hua ', 'Bi ', 'Ying ', 'Su ', 'Huang ', 'Fan ', 'Jiao ', 'Liao ', 'Yan ', 'Kao ', 'Jiu ', 'Xian ', 'Xian ', 'Tu ', 'Mai ', 'Zun ', 'Yu ', 'Ying ', 'Lu ', 'Tuan ', 'Xian ', 'Xue ', 'Yi ', 'Pi ']


Joomla CMS: Référence du fichier ResourceNotFoundExceptionHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • JsonApi
Structures de données | Espaces de nommage
Référence du fichier ResourceNotFoundExceptionHandler.php

Structures de données

class ResourceNotFoundExceptionHandler

Espaces de nommage

Joomla\CMS\Error\JsonApi


Joomla CMS: Référence du fichier x055.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x055.php

Variables

return ['You ', 'Yan ', 'Gu ', 'Gu ', 'Bai ', 'Han ', 'Suo ', 'Chun ', 'Yi ', 'Ai ', 'Jia ', 'Tu ', 'Xian ', 'Huan ', 'Li ', 'Xi ', 'Tang ', 'Zuo ', 'Qiu ', 'Che ', 'Wu ', 'Zao ', 'Ya ', 'Dou ', 'Qi ', 'Di ', 'Qin ', 'Ma ', 'Mal ', 'Hong ', 'Dou ', 'Kes ', 'Lao ', 'Liang ', 'Suo ', 'Zao ', 'Huan ', 'Lang ', 'Sha ', 'Ji ', 'Zuo ', 'Wo ', 'Feng ', 'Yin ', 'Hu ', 'Qi ', 'Shou ', 'Wei ', 'Shua ', 'Chang ', 'Er ', 'Li ', 'Qiang ', 'An ', 'Jie ', 'Yo ', 'Nian ', 'Yu ', 'Tian ', 'Lai ', 'Sha ', 'Xi ', 'Tuo ', 'Hu ', 'Ai ', 'Zhou ', 'Nou ', 'Ken ', 'Zhuo ', 'Zhuo ', 'Shang ', 'Di ', 'Heng ', 'Lan ', 'A ', 'Xiao ', 'Xiang ', 'Tun ', 'Wu ', 'Wen ', 'Cui ', 'Sha ', 'Hu ', 'Qi ', 'Qi ', 'Tao ', 'Dan ', 'Dan ', 'Ye ', 'Zi ', 'Bi ', 'Cui ', 'Chuo ', 'He ', 'Ya ', 'Qi ', 'Zhe ', 'Pei ', 'Liang ', 'Xian ', 'Pi ', 'Sha ', 'La ', 'Ze ', 'Qing ', 'Gua ', 'Pa ', 'Zhe ', 'Se ', 'Zhuan ', 'Nie ', 'Guo ', 'Luo ', 'Yan ', 'Di ', 'Quan ', 'Tan ', 'Bo ', 'Ding ', 'Lang ', 'Xiao ', '[?] ', 'Tang ', 'Chi ', 'Ti ', 'An ', 'Jiu ', 'Dan ', 'Ke ', 'Yong ', 'Wei ', 'Nan ', 'Shan ', 'Yu ', 'Zhe ', 'La ', 'Jie ', 'Hou ', 'Han ', 'Die ', 'Zhou ', 'Chai ', 'Wai ', 'Re ', 'Yu ', 'Yin ', 'Zan ', 'Yao ', 'Wo ', 'Mian ', 'Hu ', 'Yun ', 'Chuan ', 'Hui ', 'Huan ', 'Huan ', 'Xi ', 'He ', 'Ji ', 'Kui ', 'Zhong ', 'Wei ', 'Sha ', 'Xu ', 'Huang ', 'Du ', 'Nie ', 'Xuan ', 'Liang ', 'Yu ', 'Sang ', 'Chi ', 'Qiao ', 'Yan ', 'Dan ', 'Pen ', 'Can ', 'Li ', 'Yo ', 'Zha ', 'Wei ', 'Miao ', 'Ying ', 'Pen ', 'Phos ', 'Kui ', 'Xi ', 'Yu ', 'Jie ', 'Lou ', 'Ku ', 'Sao ', 'Huo ', 'Ti ', 'Yao ', 'He ', 'A ', 'Xiu ', 'Qiang ', 'Se ', 'Yong ', 'Su ', 'Hong ', 'Xie ', 'Yi ', 'Suo ', 'Ma ', 'Cha ', 'Hai ', 'Ke ', 'Ta ', 'Sang ', 'Tian ', 'Ru ', 'Sou ', 'Wa ', 'Ji ', 'Pang ', 'Wu ', 'Xian ', 'Shi ', 'Ge ', 'Zi ', 'Jie ', 'Luo ', 'Weng ', 'Wa ', 'Si ', 'Chi ', 'Hao ', 'Suo ', 'Jia ', 'Hai ', 'Suo ', 'Qin ', 'Nie ', 'He ', 'Cis ', 'Sai ', 'Ng ', 'Ge ', 'Na ', 'Dia ', 'Ai ', '[?] ', 'Tong ', 'Bi ', 'Ao ', 'Ao ', 'Lian ', 'Cui ', 'Zhe ', 'Mo ', 'Sou ', 'Sou ', 'Tan ']

Documentation des variables

◆ return

return[ 'You ', 'Yan ', 'Gu ', 'Gu ', 'Bai ', 'Han ', 'Suo ', 'Chun ', 'Yi ', 'Ai ', 'Jia ', 'Tu ', 'Xian ', 'Huan ', 'Li ', 'Xi ', 'Tang ', 'Zuo ', 'Qiu ', 'Che ', 'Wu ', 'Zao ', 'Ya ', 'Dou ', 'Qi ', 'Di ', 'Qin ', 'Ma ', 'Mal ', 'Hong ', 'Dou ', 'Kes ', 'Lao ', 'Liang ', 'Suo ', 'Zao ', 'Huan ', 'Lang ', 'Sha ', 'Ji ', 'Zuo ', 'Wo ', 'Feng ', 'Yin ', 'Hu ', 'Qi ', 'Shou ', 'Wei ', 'Shua ', 'Chang ', 'Er ', 'Li ', 'Qiang ', 'An ', 'Jie ', 'Yo ', 'Nian ', 'Yu ', 'Tian ', 'Lai ', 'Sha ', 'Xi ', 'Tuo ', 'Hu ', 'Ai ', 'Zhou ', 'Nou ', 'Ken ', 'Zhuo ', 'Zhuo ', 'Shang ', 'Di ', 'Heng ', 'Lan ', 'A ', 'Xiao ', 'Xiang ', 'Tun ', 'Wu ', 'Wen ', 'Cui ', 'Sha ', 'Hu ', 'Qi ', 'Qi ', 'Tao ', 'Dan ', 'Dan ', 'Ye ', 'Zi ', 'Bi ', 'Cui ', 'Chuo ', 'He ', 'Ya ', 'Qi ', 'Zhe ', 'Pei ', 'Liang ', 'Xian ', 'Pi ', 'Sha ', 'La ', 'Ze ', 'Qing ', 'Gua ', 'Pa ', 'Zhe ', 'Se ', 'Zhuan ', 'Nie ', 'Guo ', 'Luo ', 'Yan ', 'Di ', 'Quan ', 'Tan ', 'Bo ', 'Ding ', 'Lang ', 'Xiao ', '[?] ', 'Tang ', 'Chi ', 'Ti ', 'An ', 'Jiu ', 'Dan ', 'Ke ', 'Yong ', 'Wei ', 'Nan ', 'Shan ', 'Yu ', 'Zhe ', 'La ', 'Jie ', 'Hou ', 'Han ', 'Die ', 'Zhou ', 'Chai ', 'Wai ', 'Re ', 'Yu ', 'Yin ', 'Zan ', 'Yao ', 'Wo ', 'Mian ', 'Hu ', 'Yun ', 'Chuan ', 'Hui ', 'Huan ', 'Huan ', 'Xi ', 'He ', 'Ji ', 'Kui ', 'Zhong ', 'Wei ', 'Sha ', 'Xu ', 'Huang ', 'Du ', 'Nie ', 'Xuan ', 'Liang ', 'Yu ', 'Sang ', 'Chi ', 'Qiao ', 'Yan ', 'Dan ', 'Pen ', 'Can ', 'Li ', 'Yo ', 'Zha ', 'Wei ', 'Miao ', 'Ying ', 'Pen ', 'Phos ', 'Kui ', 'Xi ', 'Yu ', 'Jie ', 'Lou ', 'Ku ', 'Sao ', 'Huo ', 'Ti ', 'Yao ', 'He ', 'A ', 'Xiu ', 'Qiang ', 'Se ', 'Yong ', 'Su ', 'Hong ', 'Xie ', 'Yi ', 'Suo ', 'Ma ', 'Cha ', 'Hai ', 'Ke ', 'Ta ', 'Sang ', 'Tian ', 'Ru ', 'Sou ', 'Wa ', 'Ji ', 'Pang ', 'Wu ', 'Xian ', 'Shi ', 'Ge ', 'Zi ', 'Jie ', 'Luo ', 'Weng ', 'Wa ', 'Si ', 'Chi ', 'Hao ', 'Suo ', 'Jia ', 'Hai ', 'Suo ', 'Qin ', 'Nie ', 'He ', 'Cis ', 'Sai ', 'Ng ', 'Ge ', 'Na ', 'Dia ', 'Ai ', '[?] ', 'Tong ', 'Bi ', 'Ao ', 'Ao ', 'Lian ', 'Cui ', 'Zhe ', 'Mo ', 'Sou ', 'Sou ', 'Tan ']


Joomla CMS: Référence du fichier upperCase.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-mbstring
  • Resources
  • unidata
Référence du fichier upperCase.php


Joomla CMS: Référence du fichier updatecachetime.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • updatenotification
  • postinstall
Espaces de nommage | Fonctions
Référence du fichier updatecachetime.php

Espaces de nommage

Joomla\Plugin

Fonctions

updatecachetime_postinstall_condition ()
updatecachetime_postinstall_action ()

Documentation des fonctions

◆ updatecachetime_postinstall_action()

updatecachetime_postinstall_action ( )

Sets the cachetimeout back to the default (6 hours)

Renvoie
void
Depuis
3.6.3

Références Factory\getApplication(), et Table\getInstance().

◆ updatecachetime_postinstall_condition()

updatecachetime_postinstall_condition ( )

Checks if the com_installer config for the cache Hours are eq 0 and the updatenotification Plugin is enabled

Renvoie
boolean
Depuis
3.6.3


Joomla CMS: Référence du fichier url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/url.php

Espaces de nommage

Joomla\Site

Variables

$attributes
if ( $value !==null)

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= array(
!empty($size) ? ' size="' . $size . '"' : '',
!empty($description) ? ' aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? ' disabled' : '',
$readonly ? ' readonly' : '',
strlen($hint) ? ' placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$autofocus ? ' autofocus' : '',
$spellcheck ? '' : ' spellcheck="false"',
$onchange ? ' onchange="' . $onchange . '"' : '',
!empty($maxLength) ? $maxLength : '',
$required ? ' required' : '',
$dataAttribute,
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$size
$size
Definition: slider.php:67
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54

◆ if

if($value !==null)


Joomla CMS: Référence du fichier SysinfoModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier SysinfoModel.php

Structures de données

class SysinfoModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Model


Joomla CMS: C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php

C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/functions.php

Start validation on a value, returns AssertionChain.

The invocation of this method starts an assertion chain that is happening on the passed value.

Paramètres
mixed | $value
string | callable | null | $defaultMessage
string | $defaultPropertyPath

($value)->notEmpty()->integer(); ($value)->nullOr()->string()->startsWith("Foo");

The assertion chain can be stateful, that means be careful when you reuse it. You should never pass around the chain.

<?php
namespace Assert;
function that($value, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
return Assert::that($value, $defaultMessage, $defaultPropertyPath);
}
function thatAll($values, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
return Assert::thatAll($values, $defaultMessage, $defaultPropertyPath);
}
function thatNullOr($value, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
return Assert::thatNullOr($value, $defaultMessage, $defaultPropertyPath);
}
function lazy(): LazyAssertion
{
return Assert::lazy();
}


Joomla CMS: Référence du fichier XmlRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Error
  • Renderer
Structures de données | Espaces de nommage
Référence du fichier XmlRenderer.php

Structures de données

class XmlRenderer

Espaces de nommage

Joomla\CMS\Error\Renderer


Joomla CMS: Référence du fichier ProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Provider
Structures de données | Espaces de nommage
Référence du fichier ProviderInterface.php

Structures de données

interface ProviderInterface

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Provider


Joomla CMS: Référence du fichier x063.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x063.php

Variables

return ['Bo ', 'Chi ', 'Gua ', 'Zhi ', 'Kuo ', 'Duo ', 'Duo ', 'Zhi ', 'Qie ', 'An ', 'Nong ', 'Zhen ', 'Ge ', 'Jiao ', 'Ku ', 'Dong ', 'Ru ', 'Tiao ', 'Lie ', 'Zha ', 'Lu ', 'Die ', 'Wa ', 'Jue ', 'Mushiru ', 'Ju ', 'Zhi ', 'Luan ', 'Ya ', 'Zhua ', 'Ta ', 'Xie ', 'Nao ', 'Dang ', 'Jiao ', 'Zheng ', 'Ji ', 'Hui ', 'Xun ', 'Ku ', 'Ai ', 'Tuo ', 'Nuo ', 'Cuo ', 'Bo ', 'Geng ', 'Ti ', 'Zhen ', 'Cheng ', 'Suo ', 'Suo ', 'Keng ', 'Mei ', 'Long ', 'Ju ', 'Peng ', 'Jian ', 'Yi ', 'Ting ', 'Shan ', 'Nuo ', 'Wan ', 'Xie ', 'Cha ', 'Feng ', 'Jiao ', 'Wu ', 'Jun ', 'Jiu ', 'Tong ', 'Kun ', 'Huo ', 'Tu ', 'Zhuo ', 'Pou ', 'Le ', 'Ba ', 'Han ', 'Shao ', 'Nie ', 'Juan ', 'Ze ', 'Song ', 'Ye ', 'Jue ', 'Bu ', 'Huan ', 'Bu ', 'Zun ', 'Yi ', 'Zhai ', 'Lu ', 'Sou ', 'Tuo ', 'Lao ', 'Sun ', 'Bang ', 'Jian ', 'Huan ', 'Dao ', '[?] ', 'Wan ', 'Qin ', 'Peng ', 'She ', 'Lie ', 'Min ', 'Men ', 'Fu ', 'Bai ', 'Ju ', 'Dao ', 'Wo ', 'Ai ', 'Juan ', 'Yue ', 'Zong ', 'Chen ', 'Chui ', 'Jie ', 'Tu ', 'Ben ', 'Na ', 'Nian ', 'Nuo ', 'Zu ', 'Wo ', 'Xi ', 'Xian ', 'Cheng ', 'Dian ', 'Sao ', 'Lun ', 'Qing ', 'Gang ', 'Duo ', 'Shou ', 'Diao ', 'Pou ', 'Di ', 'Zhang ', 'Gun ', 'Ji ', 'Tao ', 'Qia ', 'Qi ', 'Pai ', 'Shu ', 'Qian ', 'Ling ', 'Yi ', 'Ya ', 'Jue ', 'Zheng ', 'Liang ', 'Gua ', 'Yi ', 'Huo ', 'Shan ', 'Zheng ', 'Lue ', 'Cai ', 'Tan ', 'Che ', 'Bing ', 'Jie ', 'Ti ', 'Kong ', 'Tui ', 'Yan ', 'Cuo ', 'Zou ', 'Ju ', 'Tian ', 'Qian ', 'Ken ', 'Bai ', 'Shou ', 'Jie ', 'Lu ', 'Guo ', 'Haba ', '[?] ', 'Zhi ', 'Dan ', 'Mang ', 'Xian ', 'Sao ', 'Guan ', 'Peng ', 'Yuan ', 'Nuo ', 'Jian ', 'Zhen ', 'Jiu ', 'Jian ', 'Yu ', 'Yan ', 'Kui ', 'Nan ', 'Hong ', 'Rou ', 'Pi ', 'Wei ', 'Sai ', 'Zou ', 'Xuan ', 'Miao ', 'Ti ', 'Nie ', 'Cha ', 'Shi ', 'Zong ', 'Zhen ', 'Yi ', 'Shun ', 'Heng ', 'Bian ', 'Yang ', 'Huan ', 'Yan ', 'Zuan ', 'An ', 'Xu ', 'Ya ', 'Wo ', 'Ke ', 'Chuai ', 'Ji ', 'Ti ', 'La ', 'La ', 'Cheng ', 'Kai ', 'Jiu ', 'Jiu ', 'Tu ', 'Jie ', 'Hui ', 'Geng ', 'Chong ', 'Shuo ', 'She ', 'Xie ', 'Yuan ', 'Qian ', 'Ye ', 'Cha ', 'Zha ', 'Bei ', 'Yao ', '[?] ', '[?] ', 'Lan ', 'Wen ', 'Qin ']

Documentation des variables

◆ return

return[ 'Bo ', 'Chi ', 'Gua ', 'Zhi ', 'Kuo ', 'Duo ', 'Duo ', 'Zhi ', 'Qie ', 'An ', 'Nong ', 'Zhen ', 'Ge ', 'Jiao ', 'Ku ', 'Dong ', 'Ru ', 'Tiao ', 'Lie ', 'Zha ', 'Lu ', 'Die ', 'Wa ', 'Jue ', 'Mushiru ', 'Ju ', 'Zhi ', 'Luan ', 'Ya ', 'Zhua ', 'Ta ', 'Xie ', 'Nao ', 'Dang ', 'Jiao ', 'Zheng ', 'Ji ', 'Hui ', 'Xun ', 'Ku ', 'Ai ', 'Tuo ', 'Nuo ', 'Cuo ', 'Bo ', 'Geng ', 'Ti ', 'Zhen ', 'Cheng ', 'Suo ', 'Suo ', 'Keng ', 'Mei ', 'Long ', 'Ju ', 'Peng ', 'Jian ', 'Yi ', 'Ting ', 'Shan ', 'Nuo ', 'Wan ', 'Xie ', 'Cha ', 'Feng ', 'Jiao ', 'Wu ', 'Jun ', 'Jiu ', 'Tong ', 'Kun ', 'Huo ', 'Tu ', 'Zhuo ', 'Pou ', 'Le ', 'Ba ', 'Han ', 'Shao ', 'Nie ', 'Juan ', 'Ze ', 'Song ', 'Ye ', 'Jue ', 'Bu ', 'Huan ', 'Bu ', 'Zun ', 'Yi ', 'Zhai ', 'Lu ', 'Sou ', 'Tuo ', 'Lao ', 'Sun ', 'Bang ', 'Jian ', 'Huan ', 'Dao ', '[?] ', 'Wan ', 'Qin ', 'Peng ', 'She ', 'Lie ', 'Min ', 'Men ', 'Fu ', 'Bai ', 'Ju ', 'Dao ', 'Wo ', 'Ai ', 'Juan ', 'Yue ', 'Zong ', 'Chen ', 'Chui ', 'Jie ', 'Tu ', 'Ben ', 'Na ', 'Nian ', 'Nuo ', 'Zu ', 'Wo ', 'Xi ', 'Xian ', 'Cheng ', 'Dian ', 'Sao ', 'Lun ', 'Qing ', 'Gang ', 'Duo ', 'Shou ', 'Diao ', 'Pou ', 'Di ', 'Zhang ', 'Gun ', 'Ji ', 'Tao ', 'Qia ', 'Qi ', 'Pai ', 'Shu ', 'Qian ', 'Ling ', 'Yi ', 'Ya ', 'Jue ', 'Zheng ', 'Liang ', 'Gua ', 'Yi ', 'Huo ', 'Shan ', 'Zheng ', 'Lue ', 'Cai ', 'Tan ', 'Che ', 'Bing ', 'Jie ', 'Ti ', 'Kong ', 'Tui ', 'Yan ', 'Cuo ', 'Zou ', 'Ju ', 'Tian ', 'Qian ', 'Ken ', 'Bai ', 'Shou ', 'Jie ', 'Lu ', 'Guo ', 'Haba ', '[?] ', 'Zhi ', 'Dan ', 'Mang ', 'Xian ', 'Sao ', 'Guan ', 'Peng ', 'Yuan ', 'Nuo ', 'Jian ', 'Zhen ', 'Jiu ', 'Jian ', 'Yu ', 'Yan ', 'Kui ', 'Nan ', 'Hong ', 'Rou ', 'Pi ', 'Wei ', 'Sai ', 'Zou ', 'Xuan ', 'Miao ', 'Ti ', 'Nie ', 'Cha ', 'Shi ', 'Zong ', 'Zhen ', 'Yi ', 'Shun ', 'Heng ', 'Bian ', 'Yang ', 'Huan ', 'Yan ', 'Zuan ', 'An ', 'Xu ', 'Ya ', 'Wo ', 'Ke ', 'Chuai ', 'Ji ', 'Ti ', 'La ', 'La ', 'Cheng ', 'Kai ', 'Jiu ', 'Jiu ', 'Tu ', 'Jie ', 'Hui ', 'Geng ', 'Chong ', 'Shuo ', 'She ', 'Xie ', 'Yuan ', 'Qian ', 'Ye ', 'Cha ', 'Zha ', 'Bei ', 'Yao ', '[?] ', '[?] ', 'Lan ', 'Wen ', 'Qin ']


Joomla CMS: Référence du fichier PublicKeyInfo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PublicKeyInfo.php

Structures de données

class PublicKeyInfo

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier TimestampLastCombCodec.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Codec
Structures de données | Espaces de nommage
Référence du fichier TimestampLastCombCodec.php

Structures de données

class TimestampLastCombCodec

Espaces de nommage

Ramsey\Uuid\Codec


Joomla CMS: Référence du fichier XSalsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
Structures de données
Référence du fichier XSalsa20.php

Structures de données

class ParagonIE_Sodium_Core_XSalsa20


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier TemplateController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_templates/src/Controller/TemplateController.php

Structures de données

class TemplateController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Controller


Joomla CMS: Référence du fichier W3cLogger.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Log
  • Logger
Structures de données | Espaces de nommage
Référence du fichier W3cLogger.php

Structures de données

class W3cLogger

Espaces de nommage

Joomla\CMS\Log\Logger


Joomla CMS: Référence du fichier User.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier Table/User.php

Structures de données

class User

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier VarCloner.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Cloner
Structures de données | Espaces de nommage
Référence du fichier VarCloner.php

Structures de données

class VarCloner

Espaces de nommage

Symfony\Component\VarDumper\Cloner


Joomla CMS: Référence du fichier Post.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Structures de données | Espaces de nommage
Référence du fichier Post.php

Structures de données

class Post

Espaces de nommage

ReCaptcha\RequestMethod


Joomla CMS: Référence du fichier UnreadableStreamException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnreadableStreamException.php

Structures de données

class UnreadableStreamException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier x0fd.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0fd.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '{Salla}', '{Qala}', 'Allah', 'Akbar', 'Mohammed', 'SL`M', 'Rasul', '{Alayhi}', '{WaSallam}', '{Salla}', '{Salla Llahu Alayhi WaSallam}', '{Jalla Jalalahu}', 'Rial ', '{Bismillah Ar-Rahman Ar-Rahimi}', '[?]', '[?]']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '{Salla}', '{Qala}', 'Allah', 'Akbar', 'Mohammed', 'SL`M', 'Rasul', '{Alayhi}', '{WaSallam}', '{Salla}', '{Salla Llahu Alayhi WaSallam}', '{Jalla Jalalahu}', 'Rial ', '{Bismillah Ar-Rahman Ar-Rahimi}', '[?]', '[?]']


Joomla CMS: Référence du fichier Parser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • yaml
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/symfony/yaml/Parser.php

Structures de données

class Parser

Espaces de nommage

Symfony\Component\Yaml


Joomla CMS: Référence du fichier StemmerManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
Structures de données | Espaces de nommage
Référence du fichier StemmerManager.php

Structures de données

class StemmerManager

Espaces de nommage

Wamania\Snowball


Joomla CMS: Référence du fichier XML.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/XML.php

Structures de données

class XML

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys


Joomla CMS: Référence du fichier Salsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier paragonie/sodium_compat/src/Core32/Salsa20.php

Structures de données

class ParagonIE_Sodium_Core32_Salsa20


Joomla CMS: Référence du fichier x09f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x09f.php

Variables

return ['Cu ', 'Qu ', 'Chao ', 'Wa ', 'Zhu ', 'Zhi ', 'Mang ', 'Ao ', 'Bie ', 'Tuo ', 'Bi ', 'Yuan ', 'Chao ', 'Tuo ', 'Ding ', 'Mi ', 'Nai ', 'Ding ', 'Zi ', 'Gu ', 'Gu ', 'Dong ', 'Fen ', 'Tao ', 'Yuan ', 'Pi ', 'Chang ', 'Gao ', 'Qi ', 'Yuan ', 'Tang ', 'Teng ', 'Shu ', 'Shu ', 'Fen ', 'Fei ', 'Wen ', 'Ba ', 'Diao ', 'Tuo ', 'Tong ', 'Qu ', 'Sheng ', 'Shi ', 'You ', 'Shi ', 'Ting ', 'Wu ', 'Nian ', 'Jing ', 'Hun ', 'Ju ', 'Yan ', 'Tu ', 'Ti ', 'Xi ', 'Xian ', 'Yan ', 'Lei ', 'Bi ', 'Yao ', 'Qiu ', 'Han ', 'Wu ', 'Wu ', 'Hou ', 'Xi ', 'Ge ', 'Zha ', 'Xiu ', 'Weng ', 'Zha ', 'Nong ', 'Nang ', 'Qi ', 'Zhai ', 'Ji ', 'Zi ', 'Ji ', 'Ji ', 'Qi ', 'Ji ', 'Chi ', 'Chen ', 'Chen ', 'He ', 'Ya ', 'Ken ', 'Xie ', 'Pao ', 'Cuo ', 'Shi ', 'Zi ', 'Chi ', 'Nian ', 'Ju ', 'Tiao ', 'Ling ', 'Ling ', 'Chu ', 'Quan ', 'Xie ', 'Ken ', 'Nie ', 'Jiu ', 'Yao ', 'Chuo ', 'Kun ', 'Yu ', 'Chu ', 'Yi ', 'Ni ', 'Cuo ', 'Zou ', 'Qu ', 'Nen ', 'Xian ', 'Ou ', 'E ', 'Wo ', 'Yi ', 'Chuo ', 'Zou ', 'Dian ', 'Chu ', 'Jin ', 'Ya ', 'Chi ', 'Chen ', 'He ', 'Ken ', 'Ju ', 'Ling ', 'Pao ', 'Tiao ', 'Zi ', 'Ken ', 'Yu ', 'Chuo ', 'Qu ', 'Wo ', 'Long ', 'Pang ', 'Gong ', 'Pang ', 'Yan ', 'Long ', 'Long ', 'Gong ', 'Kan ', 'Ta ', 'Ling ', 'Ta ', 'Long ', 'Gong ', 'Kan ', 'Gui ', 'Qiu ', 'Bie ', 'Gui ', 'Yue ', 'Chui ', 'He ', 'Jue ', 'Xie ', 'Yu ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'Cu ', 'Qu ', 'Chao ', 'Wa ', 'Zhu ', 'Zhi ', 'Mang ', 'Ao ', 'Bie ', 'Tuo ', 'Bi ', 'Yuan ', 'Chao ', 'Tuo ', 'Ding ', 'Mi ', 'Nai ', 'Ding ', 'Zi ', 'Gu ', 'Gu ', 'Dong ', 'Fen ', 'Tao ', 'Yuan ', 'Pi ', 'Chang ', 'Gao ', 'Qi ', 'Yuan ', 'Tang ', 'Teng ', 'Shu ', 'Shu ', 'Fen ', 'Fei ', 'Wen ', 'Ba ', 'Diao ', 'Tuo ', 'Tong ', 'Qu ', 'Sheng ', 'Shi ', 'You ', 'Shi ', 'Ting ', 'Wu ', 'Nian ', 'Jing ', 'Hun ', 'Ju ', 'Yan ', 'Tu ', 'Ti ', 'Xi ', 'Xian ', 'Yan ', 'Lei ', 'Bi ', 'Yao ', 'Qiu ', 'Han ', 'Wu ', 'Wu ', 'Hou ', 'Xi ', 'Ge ', 'Zha ', 'Xiu ', 'Weng ', 'Zha ', 'Nong ', 'Nang ', 'Qi ', 'Zhai ', 'Ji ', 'Zi ', 'Ji ', 'Ji ', 'Qi ', 'Ji ', 'Chi ', 'Chen ', 'Chen ', 'He ', 'Ya ', 'Ken ', 'Xie ', 'Pao ', 'Cuo ', 'Shi ', 'Zi ', 'Chi ', 'Nian ', 'Ju ', 'Tiao ', 'Ling ', 'Ling ', 'Chu ', 'Quan ', 'Xie ', 'Ken ', 'Nie ', 'Jiu ', 'Yao ', 'Chuo ', 'Kun ', 'Yu ', 'Chu ', 'Yi ', 'Ni ', 'Cuo ', 'Zou ', 'Qu ', 'Nen ', 'Xian ', 'Ou ', 'E ', 'Wo ', 'Yi ', 'Chuo ', 'Zou ', 'Dian ', 'Chu ', 'Jin ', 'Ya ', 'Chi ', 'Chen ', 'He ', 'Ken ', 'Ju ', 'Ling ', 'Pao ', 'Tiao ', 'Zi ', 'Ken ', 'Yu ', 'Chuo ', 'Qu ', 'Wo ', 'Long ', 'Pang ', 'Gong ', 'Pang ', 'Yan ', 'Long ', 'Long ', 'Gong ', 'Kan ', 'Ta ', 'Ling ', 'Ta ', 'Long ', 'Gong ', 'Kan ', 'Gui ', 'Qiu ', 'Bie ', 'Gui ', 'Yue ', 'Chui ', 'He ', 'Jue ', 'Xie ', 'Yu ', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier PublicKeyCredentialOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialOptions.php

Structures de données

class PublicKeyCredentialOptions

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier RedisHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier RedisHandler.php

Structures de données

class RedisHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier Scheduler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Scheduler
Structures de données | Espaces de nommage
Référence du fichier Scheduler.php

Structures de données

class Scheduler

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Scheduler


Joomla CMS: Référence du fichier templates.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • templates
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/templates/templates.php

Structures de données

class PlgWebservicesTemplates

Espaces de nommage

Joomla\Templates


Joomla CMS: Référence du fichier PHP.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
Structures de données | Espaces de nommage
Référence du fichier PHP.php

Structures de données

class PHP

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines
PHP


Joomla CMS: Référence du fichier PreviewController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier PreviewController.php

Structures de données

class PreviewController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Contenthistory\Administrator\Controller


Joomla CMS: Référence du fichier secp192k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp192k1.php

Structures de données

class secp192k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier section.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • subform
  • repeatable-table
Espaces de nommage | Variables
Référence du fichier table/section.php

Espaces de nommage

Joomla\Site

Variables

endforeach
endif

Documentation des variables

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier RemoveModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier RemoveModel.php

Structures de données

class RemoveModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Model


Joomla CMS: Référence du fichier SearchesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier SearchesModel.php

Structures de données

class SearchesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier UnknownAssetException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnknownAssetException.php

Structures de données

class UnknownAssetException

Espaces de nommage

Joomla\CMS\WebAsset\Exception


Joomla CMS: Référence du fichier Plain.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Espaces de nommage
Référence du fichier Plain.php

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier tags.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • finder
  • tags
Structures de données | Espaces de nommage
Référence du fichier plugins/finder/tags/tags.php

Structures de données

class PlgFinderTags

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier State.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
  • Poly1305
Structures de données
Référence du fichier src/Core32/Poly1305/State.php

Structures de données

class ParagonIE_Sodium_Core32_Poly1305_State


Joomla CMS: Référence du fichier x0bd.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0bd.php

Variables

return ['bols', 'bolt', 'bolp', 'bolh', 'bom', 'bob', 'bobs', 'bos', 'boss', 'bong', 'boj', 'boc', 'bok', 'bot', 'bop', 'boh', 'bwa', 'bwag', 'bwagg', 'bwags', 'bwan', 'bwanj', 'bwanh', 'bwad', 'bwal', 'bwalg', 'bwalm', 'bwalb', 'bwals', 'bwalt', 'bwalp', 'bwalh', 'bwam', 'bwab', 'bwabs', 'bwas', 'bwass', 'bwang', 'bwaj', 'bwac', 'bwak', 'bwat', 'bwap', 'bwah', 'bwae', 'bwaeg', 'bwaegg', 'bwaegs', 'bwaen', 'bwaenj', 'bwaenh', 'bwaed', 'bwael', 'bwaelg', 'bwaelm', 'bwaelb', 'bwaels', 'bwaelt', 'bwaelp', 'bwaelh', 'bwaem', 'bwaeb', 'bwaebs', 'bwaes', 'bwaess', 'bwaeng', 'bwaej', 'bwaec', 'bwaek', 'bwaet', 'bwaep', 'bwaeh', 'boe', 'boeg', 'boegg', 'boegs', 'boen', 'boenj', 'boenh', 'boed', 'boel', 'boelg', 'boelm', 'boelb', 'boels', 'boelt', 'boelp', 'boelh', 'boem', 'boeb', 'boebs', 'boes', 'boess', 'boeng', 'boej', 'boec', 'boek', 'boet', 'boep', 'boeh', 'byo', 'byog', 'byogg', 'byogs', 'byon', 'byonj', 'byonh', 'byod', 'byol', 'byolg', 'byolm', 'byolb', 'byols', 'byolt', 'byolp', 'byolh', 'byom', 'byob', 'byobs', 'byos', 'byoss', 'byong', 'byoj', 'byoc', 'byok', 'byot', 'byop', 'byoh', 'bu', 'bug', 'bugg', 'bugs', 'bun', 'bunj', 'bunh', 'bud', 'bul', 'bulg', 'bulm', 'bulb', 'buls', 'bult', 'bulp', 'bulh', 'bum', 'bub', 'bubs', 'bus', 'buss', 'bung', 'buj', 'buc', 'buk', 'but', 'bup', 'buh', 'bweo', 'bweog', 'bweogg', 'bweogs', 'bweon', 'bweonj', 'bweonh', 'bweod', 'bweol', 'bweolg', 'bweolm', 'bweolb', 'bweols', 'bweolt', 'bweolp', 'bweolh', 'bweom', 'bweob', 'bweobs', 'bweos', 'bweoss', 'bweong', 'bweoj', 'bweoc', 'bweok', 'bweot', 'bweop', 'bweoh', 'bwe', 'bweg', 'bwegg', 'bwegs', 'bwen', 'bwenj', 'bwenh', 'bwed', 'bwel', 'bwelg', 'bwelm', 'bwelb', 'bwels', 'bwelt', 'bwelp', 'bwelh', 'bwem', 'bweb', 'bwebs', 'bwes', 'bwess', 'bweng', 'bwej', 'bwec', 'bwek', 'bwet', 'bwep', 'bweh', 'bwi', 'bwig', 'bwigg', 'bwigs', 'bwin', 'bwinj', 'bwinh', 'bwid', 'bwil', 'bwilg', 'bwilm', 'bwilb', 'bwils', 'bwilt', 'bwilp', 'bwilh', 'bwim', 'bwib', 'bwibs', 'bwis', 'bwiss', 'bwing', 'bwij', 'bwic', 'bwik', 'bwit', 'bwip', 'bwih', 'byu', 'byug', 'byugg', 'byugs', 'byun', 'byunj', 'byunh', 'byud', 'byul', 'byulg', 'byulm', 'byulb', 'byuls', 'byult', 'byulp', 'byulh']

Documentation des variables

◆ return

return[ 'bols', 'bolt', 'bolp', 'bolh', 'bom', 'bob', 'bobs', 'bos', 'boss', 'bong', 'boj', 'boc', 'bok', 'bot', 'bop', 'boh', 'bwa', 'bwag', 'bwagg', 'bwags', 'bwan', 'bwanj', 'bwanh', 'bwad', 'bwal', 'bwalg', 'bwalm', 'bwalb', 'bwals', 'bwalt', 'bwalp', 'bwalh', 'bwam', 'bwab', 'bwabs', 'bwas', 'bwass', 'bwang', 'bwaj', 'bwac', 'bwak', 'bwat', 'bwap', 'bwah', 'bwae', 'bwaeg', 'bwaegg', 'bwaegs', 'bwaen', 'bwaenj', 'bwaenh', 'bwaed', 'bwael', 'bwaelg', 'bwaelm', 'bwaelb', 'bwaels', 'bwaelt', 'bwaelp', 'bwaelh', 'bwaem', 'bwaeb', 'bwaebs', 'bwaes', 'bwaess', 'bwaeng', 'bwaej', 'bwaec', 'bwaek', 'bwaet', 'bwaep', 'bwaeh', 'boe', 'boeg', 'boegg', 'boegs', 'boen', 'boenj', 'boenh', 'boed', 'boel', 'boelg', 'boelm', 'boelb', 'boels', 'boelt', 'boelp', 'boelh', 'boem', 'boeb', 'boebs', 'boes', 'boess', 'boeng', 'boej', 'boec', 'boek', 'boet', 'boep', 'boeh', 'byo', 'byog', 'byogg', 'byogs', 'byon', 'byonj', 'byonh', 'byod', 'byol', 'byolg', 'byolm', 'byolb', 'byols', 'byolt', 'byolp', 'byolh', 'byom', 'byob', 'byobs', 'byos', 'byoss', 'byong', 'byoj', 'byoc', 'byok', 'byot', 'byop', 'byoh', 'bu', 'bug', 'bugg', 'bugs', 'bun', 'bunj', 'bunh', 'bud', 'bul', 'bulg', 'bulm', 'bulb', 'buls', 'bult', 'bulp', 'bulh', 'bum', 'bub', 'bubs', 'bus', 'buss', 'bung', 'buj', 'buc', 'buk', 'but', 'bup', 'buh', 'bweo', 'bweog', 'bweogg', 'bweogs', 'bweon', 'bweonj', 'bweonh', 'bweod', 'bweol', 'bweolg', 'bweolm', 'bweolb', 'bweols', 'bweolt', 'bweolp', 'bweolh', 'bweom', 'bweob', 'bweobs', 'bweos', 'bweoss', 'bweong', 'bweoj', 'bweoc', 'bweok', 'bweot', 'bweop', 'bweoh', 'bwe', 'bweg', 'bwegg', 'bwegs', 'bwen', 'bwenj', 'bwenh', 'bwed', 'bwel', 'bwelg', 'bwelm', 'bwelb', 'bwels', 'bwelt', 'bwelp', 'bwelh', 'bwem', 'bweb', 'bwebs', 'bwes', 'bwess', 'bweng', 'bwej', 'bwec', 'bwek', 'bwet', 'bwep', 'bweh', 'bwi', 'bwig', 'bwigg', 'bwigs', 'bwin', 'bwinj', 'bwinh', 'bwid', 'bwil', 'bwilg', 'bwilm', 'bwilb', 'bwils', 'bwilt', 'bwilp', 'bwilh', 'bwim', 'bwib', 'bwibs', 'bwis', 'bwiss', 'bwing', 'bwij', 'bwic', 'bwik', 'bwit', 'bwip', 'bwih', 'byu', 'byug', 'byugg', 'byugs', 'byun', 'byunj', 'byunh', 'byud', 'byul', 'byulg', 'byulm', 'byulb', 'byuls', 'byult', 'byulp', 'byulh']


Joomla CMS: Référence du fichier Rtf.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Parser
Structures de données | Espaces de nommage
Référence du fichier Rtf.php

Structures de données

class Rtf

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer\Parser


Joomla CMS: Référence du fichier x1d4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x1d4.php

Variables

return ['A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 26=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 52=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 78=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 104=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 130=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 156=> 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 181=> 'Z', 182=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 208=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 234=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z']

Documentation des variables

◆ return

return[ 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 26=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 52=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 78=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 104=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 130=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 156=> 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 181=> 'Z', 182=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 208=> 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 234=> 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z']


Joomla CMS: Référence du fichier Sha384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Rsa
Structures de données | Espaces de nommage
Référence du fichier Rsa/Sha384.php

Structures de données

class Sha384

Espaces de nommage

Lcobucci\JWT\Signer\Rsa


Joomla CMS: Référence du fichier PgsqlImporter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Pgsql
Structures de données | Espaces de nommage
Référence du fichier PgsqlImporter.php

Structures de données

class PgsqlImporter

Espaces de nommage

Joomla\Database\Pgsql


Joomla CMS: Référence du fichier RssRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
  • Renderer
  • Feed
Structures de données | Espaces de nommage
Référence du fichier RssRenderer.php

Structures de données

class RssRenderer

Espaces de nommage

Joomla\CMS\Document\Renderer\Feed


Joomla CMS: Référence du fichier title_alias.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • edit
Espaces de nommage | Variables
Référence du fichier title_alias.php

Espaces de nommage

Joomla\Site

Variables

$form = $displayData->getForm()
$title = $form->getField('title') ? 'title' : ($form->getField('name') ? 'name' : '')

Documentation des variables

◆ $form

$form = $displayData->getForm()

◆ $title

$title = $form->getField('title') ? 'title' : ($form->getField('name') ? 'name' : '')


Joomla CMS: Référence du fichier StageTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier StageTable.php

Structures de données

class StageTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Table


Joomla CMS: Référence du fichier Response.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/nyholm/psr7/src/Response.php

Structures de données

class Response

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier SwiftMailCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • SwiftMailer
Structures de données | Espaces de nommage
Référence du fichier SwiftMailCollector.php

Structures de données

class SwiftMailCollector

Espaces de nommage

DebugBar\Bridge\SwiftMailer


Joomla CMS: Référence du fichier redirect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • redirect
Structures de données | Espaces de nommage
Référence du fichier plugins/system/redirect/redirect.php

Structures de données

class PlgSystemRedirect

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier TasksListCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier TasksListCommand.php

Structures de données

class TasksListCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier PluginAdapter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Adapter
Structures de données | Espaces de nommage
Référence du fichier PluginAdapter.php

Structures de données

class PluginAdapter

Espaces de nommage

Joomla\CMS\Installer\Adapter


Joomla CMS: Référence du fichier switcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • radio
Espaces de nommage | Variables
Référence du fichier switcher.php

Espaces de nommage

Joomla\Site

Variables

$input = '<input type="radio" id="%1$s" name="%2$s" value="%3$s" %4$s>'
$attr = 'id="' . $id . '"'
foreach( $options as $i=> $option)(empty($value) && $option->value=='0') $optionValue = (string) $option->value
$optionId = $id . $i
$attributes = $optionValue == $value ? 'checked class="active ' . $class . '"' : ($class ? 'class="' . $class . '"' : '')
endforeach

Documentation des variables

◆ $attr

$attr = 'id="' . $id . '"'

◆ $attributes

$attributes = $optionValue == $value ? 'checked class="active ' . $class . '"' : ($class ? 'class="' . $class . '"' : '')

◆ $input

$input = '<input type="radio" id="%1$s" name="%2$s" value="%3$s" %4$s>'

The format of the input tag to be filled in using sprintf. %1 - id %2 - name %3 - value %4 = any other attributes

◆ $optionId

$optionId = $id . $i

◆ $optionValue

foreach ($options as $i => $option) (empty( $value) &&$option->value=='0') $optionValue = (string) $option->value

Référencé par CompletionInput\bind().

◆ endforeach

endforeach


Joomla CMS: Référence du fichier TasksController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TasksController.php

Structures de données

class TasksController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Controller


Joomla CMS: Référence du fichier PS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/PS384.php

Structures de données

class PS384

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage | Variables
Référence du fichier layouts/joomla/html/batch/user.php

Espaces de nommage

Joomla\Site

Variables

$optionNo = ''
if ( $noUser)

Documentation des variables

◆ $optionNo

$optionNo = ''

◆ if

if($noUser)


Joomla CMS: Référence du fichier Session.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Session
Structures de données | Espaces de nommage
Référence du fichier src/Session/Session.php

Structures de données

class Session

Espaces de nommage

Joomla\CMS\Session


Joomla CMS: Référence du fichier selector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • searchtools
  • default
Espaces de nommage | Variables
Référence du fichier selector.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData

Documentation des variables

◆ $data

$data = $displayData


Joomla CMS: Référence du fichier PluginsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier PluginsField.php

Structures de données

class PluginsField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier secp192r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp192r1.php

Structures de données

class secp192r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier SessionCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier SessionCollector.php

Structures de données

class SessionCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier x0c7.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c7.php

Variables

return ['wek', 'wet', 'wep', 'weh', 'wi', 'wig', 'wigg', 'wigs', 'win', 'winj', 'winh', 'wid', 'wil', 'wilg', 'wilm', 'wilb', 'wils', 'wilt', 'wilp', 'wilh', 'wim', 'wib', 'wibs', 'wis', 'wiss', 'wing', 'wij', 'wic', 'wik', 'wit', 'wip', 'wih', 'yu', 'yug', 'yugg', 'yugs', 'yun', 'yunj', 'yunh', 'yud', 'yul', 'yulg', 'yulm', 'yulb', 'yuls', 'yult', 'yulp', 'yulh', 'yum', 'yub', 'yubs', 'yus', 'yuss', 'yung', 'yuj', 'yuc', 'yuk', 'yut', 'yup', 'yuh', 'eu', 'eug', 'eugg', 'eugs', 'eun', 'eunj', 'eunh', 'eud', 'eul', 'eulg', 'eulm', 'eulb', 'euls', 'eult', 'eulp', 'eulh', 'eum', 'eub', 'eubs', 'eus', 'euss', 'eung', 'euj', 'euc', 'euk', 'eut', 'eup', 'euh', 'yi', 'yig', 'yigg', 'yigs', 'yin', 'yinj', 'yinh', 'yid', 'yil', 'yilg', 'yilm', 'yilb', 'yils', 'yilt', 'yilp', 'yilh', 'yim', 'yib', 'yibs', 'yis', 'yiss', 'ying', 'yij', 'yic', 'yik', 'yit', 'yip', 'yih', 'i', 'ig', 'igg', 'igs', 'in', 'inj', 'inh', 'id', 'il', 'ilg', 'ilm', 'ilb', 'ils', 'ilt', 'ilp', 'ilh', 'im', 'ib', 'ibs', 'is', 'iss', 'ing', 'ij', 'ic', 'ik', 'it', 'ip', 'ih', 'ja', 'jag', 'jagg', 'jags', 'jan', 'janj', 'janh', 'jad', 'jal', 'jalg', 'jalm', 'jalb', 'jals', 'jalt', 'jalp', 'jalh', 'jam', 'jab', 'jabs', 'jas', 'jass', 'jang', 'jaj', 'jac', 'jak', 'jat', 'jap', 'jah', 'jae', 'jaeg', 'jaegg', 'jaegs', 'jaen', 'jaenj', 'jaenh', 'jaed', 'jael', 'jaelg', 'jaelm', 'jaelb', 'jaels', 'jaelt', 'jaelp', 'jaelh', 'jaem', 'jaeb', 'jaebs', 'jaes', 'jaess', 'jaeng', 'jaej', 'jaec', 'jaek', 'jaet', 'jaep', 'jaeh', 'jya', 'jyag', 'jyagg', 'jyags', 'jyan', 'jyanj', 'jyanh', 'jyad', 'jyal', 'jyalg', 'jyalm', 'jyalb', 'jyals', 'jyalt', 'jyalp', 'jyalh', 'jyam', 'jyab', 'jyabs', 'jyas', 'jyass', 'jyang', 'jyaj', 'jyac', 'jyak', 'jyat', 'jyap', 'jyah', 'jyae', 'jyaeg', 'jyaegg', 'jyaegs', 'jyaen', 'jyaenj', 'jyaenh', 'jyaed', 'jyael', 'jyaelg', 'jyaelm', 'jyaelb', 'jyaels', 'jyaelt', 'jyaelp', 'jyaelh', 'jyaem', 'jyaeb', 'jyaebs', 'jyaes', 'jyaess', 'jyaeng', 'jyaej', 'jyaec', 'jyaek', 'jyaet', 'jyaep', 'jyaeh']

Documentation des variables

◆ return

return[ 'wek', 'wet', 'wep', 'weh', 'wi', 'wig', 'wigg', 'wigs', 'win', 'winj', 'winh', 'wid', 'wil', 'wilg', 'wilm', 'wilb', 'wils', 'wilt', 'wilp', 'wilh', 'wim', 'wib', 'wibs', 'wis', 'wiss', 'wing', 'wij', 'wic', 'wik', 'wit', 'wip', 'wih', 'yu', 'yug', 'yugg', 'yugs', 'yun', 'yunj', 'yunh', 'yud', 'yul', 'yulg', 'yulm', 'yulb', 'yuls', 'yult', 'yulp', 'yulh', 'yum', 'yub', 'yubs', 'yus', 'yuss', 'yung', 'yuj', 'yuc', 'yuk', 'yut', 'yup', 'yuh', 'eu', 'eug', 'eugg', 'eugs', 'eun', 'eunj', 'eunh', 'eud', 'eul', 'eulg', 'eulm', 'eulb', 'euls', 'eult', 'eulp', 'eulh', 'eum', 'eub', 'eubs', 'eus', 'euss', 'eung', 'euj', 'euc', 'euk', 'eut', 'eup', 'euh', 'yi', 'yig', 'yigg', 'yigs', 'yin', 'yinj', 'yinh', 'yid', 'yil', 'yilg', 'yilm', 'yilb', 'yils', 'yilt', 'yilp', 'yilh', 'yim', 'yib', 'yibs', 'yis', 'yiss', 'ying', 'yij', 'yic', 'yik', 'yit', 'yip', 'yih', 'i', 'ig', 'igg', 'igs', 'in', 'inj', 'inh', 'id', 'il', 'ilg', 'ilm', 'ilb', 'ils', 'ilt', 'ilp', 'ilh', 'im', 'ib', 'ibs', 'is', 'iss', 'ing', 'ij', 'ic', 'ik', 'it', 'ip', 'ih', 'ja', 'jag', 'jagg', 'jags', 'jan', 'janj', 'janh', 'jad', 'jal', 'jalg', 'jalm', 'jalb', 'jals', 'jalt', 'jalp', 'jalh', 'jam', 'jab', 'jabs', 'jas', 'jass', 'jang', 'jaj', 'jac', 'jak', 'jat', 'jap', 'jah', 'jae', 'jaeg', 'jaegg', 'jaegs', 'jaen', 'jaenj', 'jaenh', 'jaed', 'jael', 'jaelg', 'jaelm', 'jaelb', 'jaels', 'jaelt', 'jaelp', 'jaelh', 'jaem', 'jaeb', 'jaebs', 'jaes', 'jaess', 'jaeng', 'jaej', 'jaec', 'jaek', 'jaet', 'jaep', 'jaeh', 'jya', 'jyag', 'jyagg', 'jyags', 'jyan', 'jyanj', 'jyanh', 'jyad', 'jyal', 'jyalg', 'jyalm', 'jyalb', 'jyals', 'jyalt', 'jyalp', 'jyalh', 'jyam', 'jyab', 'jyabs', 'jyas', 'jyass', 'jyang', 'jyaj', 'jyac', 'jyak', 'jyat', 'jyap', 'jyah', 'jyae', 'jyaeg', 'jyaegg', 'jyaegs', 'jyaen', 'jyaenj', 'jyaenh', 'jyaed', 'jyael', 'jyaelg', 'jyaelm', 'jyaelb', 'jyaels', 'jyaelt', 'jyaelp', 'jyaelh', 'jyaem', 'jyaeb', 'jyaebs', 'jyaes', 'jyaess', 'jyaeng', 'jyaej', 'jyaec', 'jyaek', 'jyaet', 'jyaep', 'jyaeh']


Joomla CMS: Référence du fichier PackageManifest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Installer
  • Manifest
Structures de données | Espaces de nommage
Référence du fichier PackageManifest.php

Structures de données

class PackageManifest

Espaces de nommage

Joomla\CMS\Installer\Manifest


Joomla CMS: Référence du fichier Relationship.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier Relationship.php

Structures de données

class Relationship

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier Reader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Phar
Structures de données | Espaces de nommage
Référence du fichier Reader.php

Structures de données

class Reader

Espaces de nommage

TYPO3\PharStreamWrapper\Phar


Joomla CMS: Référence du fichier State.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Poly1305
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Poly1305/State.php

Structures de données

class State

Espaces de nommage

ParagonIE\Sodium\Core\Poly1305


Joomla CMS: Référence du fichier token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • token
Structures de données | Espaces de nommage
Référence du fichier plugins/user/token/token.php

Structures de données

class PlgUserToken

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier stats.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
Espaces de nommage | Variables
Référence du fichier layouts/stats.php

Espaces de nommage

Joomla\Plugin

Variables

$versionFields = array('php_version', 'db_version', 'cms_version')
endforeach

Documentation des variables

◆ $versionFields

$versionFields = array('php_version', 'db_version', 'cms_version')

◆ endforeach

endforeach


Joomla CMS: Référence du fichier UnrewindableStreamException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnrewindableStreamException.php

Structures de données

class UnrewindableStreamException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier x0c0.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c0.php

Variables

return ['bbweok', 'bbweot', 'bbweop', 'bbweoh', 'bbwe', 'bbweg', 'bbwegg', 'bbwegs', 'bbwen', 'bbwenj', 'bbwenh', 'bbwed', 'bbwel', 'bbwelg', 'bbwelm', 'bbwelb', 'bbwels', 'bbwelt', 'bbwelp', 'bbwelh', 'bbwem', 'bbweb', 'bbwebs', 'bbwes', 'bbwess', 'bbweng', 'bbwej', 'bbwec', 'bbwek', 'bbwet', 'bbwep', 'bbweh', 'bbwi', 'bbwig', 'bbwigg', 'bbwigs', 'bbwin', 'bbwinj', 'bbwinh', 'bbwid', 'bbwil', 'bbwilg', 'bbwilm', 'bbwilb', 'bbwils', 'bbwilt', 'bbwilp', 'bbwilh', 'bbwim', 'bbwib', 'bbwibs', 'bbwis', 'bbwiss', 'bbwing', 'bbwij', 'bbwic', 'bbwik', 'bbwit', 'bbwip', 'bbwih', 'bbyu', 'bbyug', 'bbyugg', 'bbyugs', 'bbyun', 'bbyunj', 'bbyunh', 'bbyud', 'bbyul', 'bbyulg', 'bbyulm', 'bbyulb', 'bbyuls', 'bbyult', 'bbyulp', 'bbyulh', 'bbyum', 'bbyub', 'bbyubs', 'bbyus', 'bbyuss', 'bbyung', 'bbyuj', 'bbyuc', 'bbyuk', 'bbyut', 'bbyup', 'bbyuh', 'bbeu', 'bbeug', 'bbeugg', 'bbeugs', 'bbeun', 'bbeunj', 'bbeunh', 'bbeud', 'bbeul', 'bbeulg', 'bbeulm', 'bbeulb', 'bbeuls', 'bbeult', 'bbeulp', 'bbeulh', 'bbeum', 'bbeub', 'bbeubs', 'bbeus', 'bbeuss', 'bbeung', 'bbeuj', 'bbeuc', 'bbeuk', 'bbeut', 'bbeup', 'bbeuh', 'bbyi', 'bbyig', 'bbyigg', 'bbyigs', 'bbyin', 'bbyinj', 'bbyinh', 'bbyid', 'bbyil', 'bbyilg', 'bbyilm', 'bbyilb', 'bbyils', 'bbyilt', 'bbyilp', 'bbyilh', 'bbyim', 'bbyib', 'bbyibs', 'bbyis', 'bbyiss', 'bbying', 'bbyij', 'bbyic', 'bbyik', 'bbyit', 'bbyip', 'bbyih', 'bbi', 'bbig', 'bbigg', 'bbigs', 'bbin', 'bbinj', 'bbinh', 'bbid', 'bbil', 'bbilg', 'bbilm', 'bbilb', 'bbils', 'bbilt', 'bbilp', 'bbilh', 'bbim', 'bbib', 'bbibs', 'bbis', 'bbiss', 'bbing', 'bbij', 'bbic', 'bbik', 'bbit', 'bbip', 'bbih', 'sa', 'sag', 'sagg', 'sags', 'san', 'sanj', 'sanh', 'sad', 'sal', 'salg', 'salm', 'salb', 'sals', 'salt', 'salp', 'salh', 'sam', 'sab', 'sabs', 'sas', 'sass', 'sang', 'saj', 'sac', 'sak', 'sat', 'sap', 'sah', 'sae', 'saeg', 'saegg', 'saegs', 'saen', 'saenj', 'saenh', 'saed', 'sael', 'saelg', 'saelm', 'saelb', 'saels', 'saelt', 'saelp', 'saelh', 'saem', 'saeb', 'saebs', 'saes', 'saess', 'saeng', 'saej', 'saec', 'saek', 'saet', 'saep', 'saeh', 'sya', 'syag', 'syagg', 'syags', 'syan', 'syanj', 'syanh', 'syad', 'syal', 'syalg', 'syalm', 'syalb', 'syals', 'syalt', 'syalp', 'syalh', 'syam', 'syab', 'syabs', 'syas', 'syass', 'syang', 'syaj', 'syac', 'syak', 'syat', 'syap', 'syah']

Documentation des variables

◆ return

return[ 'bbweok', 'bbweot', 'bbweop', 'bbweoh', 'bbwe', 'bbweg', 'bbwegg', 'bbwegs', 'bbwen', 'bbwenj', 'bbwenh', 'bbwed', 'bbwel', 'bbwelg', 'bbwelm', 'bbwelb', 'bbwels', 'bbwelt', 'bbwelp', 'bbwelh', 'bbwem', 'bbweb', 'bbwebs', 'bbwes', 'bbwess', 'bbweng', 'bbwej', 'bbwec', 'bbwek', 'bbwet', 'bbwep', 'bbweh', 'bbwi', 'bbwig', 'bbwigg', 'bbwigs', 'bbwin', 'bbwinj', 'bbwinh', 'bbwid', 'bbwil', 'bbwilg', 'bbwilm', 'bbwilb', 'bbwils', 'bbwilt', 'bbwilp', 'bbwilh', 'bbwim', 'bbwib', 'bbwibs', 'bbwis', 'bbwiss', 'bbwing', 'bbwij', 'bbwic', 'bbwik', 'bbwit', 'bbwip', 'bbwih', 'bbyu', 'bbyug', 'bbyugg', 'bbyugs', 'bbyun', 'bbyunj', 'bbyunh', 'bbyud', 'bbyul', 'bbyulg', 'bbyulm', 'bbyulb', 'bbyuls', 'bbyult', 'bbyulp', 'bbyulh', 'bbyum', 'bbyub', 'bbyubs', 'bbyus', 'bbyuss', 'bbyung', 'bbyuj', 'bbyuc', 'bbyuk', 'bbyut', 'bbyup', 'bbyuh', 'bbeu', 'bbeug', 'bbeugg', 'bbeugs', 'bbeun', 'bbeunj', 'bbeunh', 'bbeud', 'bbeul', 'bbeulg', 'bbeulm', 'bbeulb', 'bbeuls', 'bbeult', 'bbeulp', 'bbeulh', 'bbeum', 'bbeub', 'bbeubs', 'bbeus', 'bbeuss', 'bbeung', 'bbeuj', 'bbeuc', 'bbeuk', 'bbeut', 'bbeup', 'bbeuh', 'bbyi', 'bbyig', 'bbyigg', 'bbyigs', 'bbyin', 'bbyinj', 'bbyinh', 'bbyid', 'bbyil', 'bbyilg', 'bbyilm', 'bbyilb', 'bbyils', 'bbyilt', 'bbyilp', 'bbyilh', 'bbyim', 'bbyib', 'bbyibs', 'bbyis', 'bbyiss', 'bbying', 'bbyij', 'bbyic', 'bbyik', 'bbyit', 'bbyip', 'bbyih', 'bbi', 'bbig', 'bbigg', 'bbigs', 'bbin', 'bbinj', 'bbinh', 'bbid', 'bbil', 'bbilg', 'bbilm', 'bbilb', 'bbils', 'bbilt', 'bbilp', 'bbilh', 'bbim', 'bbib', 'bbibs', 'bbis', 'bbiss', 'bbing', 'bbij', 'bbic', 'bbik', 'bbit', 'bbip', 'bbih', 'sa', 'sag', 'sagg', 'sags', 'san', 'sanj', 'sanh', 'sad', 'sal', 'salg', 'salm', 'salb', 'sals', 'salt', 'salp', 'salh', 'sam', 'sab', 'sabs', 'sas', 'sass', 'sang', 'saj', 'sac', 'sak', 'sat', 'sap', 'sah', 'sae', 'saeg', 'saegg', 'saegs', 'saen', 'saenj', 'saenh', 'saed', 'sael', 'saelg', 'saelm', 'saelb', 'saels', 'saelt', 'saelp', 'saelh', 'saem', 'saeb', 'saebs', 'saes', 'saess', 'saeng', 'saej', 'saec', 'saek', 'saet', 'saep', 'saeh', 'sya', 'syag', 'syagg', 'syags', 'syan', 'syanj', 'syanh', 'syad', 'syal', 'syalg', 'syalm', 'syalb', 'syals', 'syalt', 'syalp', 'syalh', 'syam', 'syab', 'syabs', 'syas', 'syass', 'syang', 'syaj', 'syac', 'syak', 'syat', 'syap', 'syah']


Joomla CMS: Référence du fichier time.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier time.php

Espaces de nommage

Joomla\Site

Variables

$attributes

Documentation des variables

◆ $attributes

$attributes
Valeur initiale :
= [
!empty($class) ? 'class="form-control ' . $class . '"' : 'class="form-control"',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
!empty($onchange) ? 'onchange="' . $onchange . '"' : '',
isset($max) ? 'max="' . $max . '"' : '',
isset($step) ? 'step="' . $step . '"' : '',
isset($min) ? 'min="' . $min . '"' : '',
$required ? 'required' : '',
$autofocus ? 'autofocus' : '',
$dataAttribute,
]
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$step
$step
Definition: links.php:29
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17


Joomla CMS: Référence du fichier UserFactoryInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Structures de données | Espaces de nommage
Référence du fichier UserFactoryInterface.php

Structures de données

interface UserFactoryInterface

Espaces de nommage

Joomla\CMS\User


Joomla CMS: Référence du fichier XPath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Structures de données | Espaces de nommage
Référence du fichier XPath.php

Structures de données

class XPath

Espaces de nommage

enshrined\svgSanitize\data


Joomla CMS: Référence du fichier RadioField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RadioField.php

Structures de données

class RadioField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier PS256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/PS256.php

Structures de données

class PS256

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier RouterView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterView.php

Structures de données

class RouterView

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier UrlFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier UrlFilter.php

Structures de données

class UrlFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier PrivateKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DH/PrivateKey.php

Structures de données

class PrivateKey

Espaces de nommage

DH
phpseclib3\Crypt\DH


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_installer/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier x0d1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d1.php

Variables

return ['tyal', 'tyalg', 'tyalm', 'tyalb', 'tyals', 'tyalt', 'tyalp', 'tyalh', 'tyam', 'tyab', 'tyabs', 'tyas', 'tyass', 'tyang', 'tyaj', 'tyac', 'tyak', 'tyat', 'tyap', 'tyah', 'tyae', 'tyaeg', 'tyaegg', 'tyaegs', 'tyaen', 'tyaenj', 'tyaenh', 'tyaed', 'tyael', 'tyaelg', 'tyaelm', 'tyaelb', 'tyaels', 'tyaelt', 'tyaelp', 'tyaelh', 'tyaem', 'tyaeb', 'tyaebs', 'tyaes', 'tyaess', 'tyaeng', 'tyaej', 'tyaec', 'tyaek', 'tyaet', 'tyaep', 'tyaeh', 'teo', 'teog', 'teogg', 'teogs', 'teon', 'teonj', 'teonh', 'teod', 'teol', 'teolg', 'teolm', 'teolb', 'teols', 'teolt', 'teolp', 'teolh', 'teom', 'teob', 'teobs', 'teos', 'teoss', 'teong', 'teoj', 'teoc', 'teok', 'teot', 'teop', 'teoh', 'te', 'teg', 'tegg', 'tegs', 'ten', 'tenj', 'tenh', 'ted', 'tel', 'telg', 'telm', 'telb', 'tels', 'telt', 'telp', 'telh', 'tem', 'teb', 'tebs', 'tes', 'tess', 'teng', 'tej', 'tec', 'tek', 'tet', 'tep', 'teh', 'tyeo', 'tyeog', 'tyeogg', 'tyeogs', 'tyeon', 'tyeonj', 'tyeonh', 'tyeod', 'tyeol', 'tyeolg', 'tyeolm', 'tyeolb', 'tyeols', 'tyeolt', 'tyeolp', 'tyeolh', 'tyeom', 'tyeob', 'tyeobs', 'tyeos', 'tyeoss', 'tyeong', 'tyeoj', 'tyeoc', 'tyeok', 'tyeot', 'tyeop', 'tyeoh', 'tye', 'tyeg', 'tyegg', 'tyegs', 'tyen', 'tyenj', 'tyenh', 'tyed', 'tyel', 'tyelg', 'tyelm', 'tyelb', 'tyels', 'tyelt', 'tyelp', 'tyelh', 'tyem', 'tyeb', 'tyebs', 'tyes', 'tyess', 'tyeng', 'tyej', 'tyec', 'tyek', 'tyet', 'tyep', 'tyeh', 'to', 'tog', 'togg', 'togs', 'ton', 'tonj', 'tonh', 'tod', 'tol', 'tolg', 'tolm', 'tolb', 'tols', 'tolt', 'tolp', 'tolh', 'tom', 'tob', 'tobs', 'tos', 'toss', 'tong', 'toj', 'toc', 'tok', 'tot', 'top', 'toh', 'twa', 'twag', 'twagg', 'twags', 'twan', 'twanj', 'twanh', 'twad', 'twal', 'twalg', 'twalm', 'twalb', 'twals', 'twalt', 'twalp', 'twalh', 'twam', 'twab', 'twabs', 'twas', 'twass', 'twang', 'twaj', 'twac', 'twak', 'twat', 'twap', 'twah', 'twae', 'twaeg', 'twaegg', 'twaegs', 'twaen', 'twaenj', 'twaenh', 'twaed', 'twael', 'twaelg', 'twaelm', 'twaelb', 'twaels', 'twaelt', 'twaelp', 'twaelh', 'twaem', 'twaeb', 'twaebs', 'twaes', 'twaess', 'twaeng', 'twaej', 'twaec', 'twaek', 'twaet', 'twaep', 'twaeh', 'toe', 'toeg', 'toegg', 'toegs', 'toen', 'toenj', 'toenh', 'toed', 'toel', 'toelg', 'toelm', 'toelb']

Documentation des variables

◆ return

return[ 'tyal', 'tyalg', 'tyalm', 'tyalb', 'tyals', 'tyalt', 'tyalp', 'tyalh', 'tyam', 'tyab', 'tyabs', 'tyas', 'tyass', 'tyang', 'tyaj', 'tyac', 'tyak', 'tyat', 'tyap', 'tyah', 'tyae', 'tyaeg', 'tyaegg', 'tyaegs', 'tyaen', 'tyaenj', 'tyaenh', 'tyaed', 'tyael', 'tyaelg', 'tyaelm', 'tyaelb', 'tyaels', 'tyaelt', 'tyaelp', 'tyaelh', 'tyaem', 'tyaeb', 'tyaebs', 'tyaes', 'tyaess', 'tyaeng', 'tyaej', 'tyaec', 'tyaek', 'tyaet', 'tyaep', 'tyaeh', 'teo', 'teog', 'teogg', 'teogs', 'teon', 'teonj', 'teonh', 'teod', 'teol', 'teolg', 'teolm', 'teolb', 'teols', 'teolt', 'teolp', 'teolh', 'teom', 'teob', 'teobs', 'teos', 'teoss', 'teong', 'teoj', 'teoc', 'teok', 'teot', 'teop', 'teoh', 'te', 'teg', 'tegg', 'tegs', 'ten', 'tenj', 'tenh', 'ted', 'tel', 'telg', 'telm', 'telb', 'tels', 'telt', 'telp', 'telh', 'tem', 'teb', 'tebs', 'tes', 'tess', 'teng', 'tej', 'tec', 'tek', 'tet', 'tep', 'teh', 'tyeo', 'tyeog', 'tyeogg', 'tyeogs', 'tyeon', 'tyeonj', 'tyeonh', 'tyeod', 'tyeol', 'tyeolg', 'tyeolm', 'tyeolb', 'tyeols', 'tyeolt', 'tyeolp', 'tyeolh', 'tyeom', 'tyeob', 'tyeobs', 'tyeos', 'tyeoss', 'tyeong', 'tyeoj', 'tyeoc', 'tyeok', 'tyeot', 'tyeop', 'tyeoh', 'tye', 'tyeg', 'tyegg', 'tyegs', 'tyen', 'tyenj', 'tyenh', 'tyed', 'tyel', 'tyelg', 'tyelm', 'tyelb', 'tyels', 'tyelt', 'tyelp', 'tyelh', 'tyem', 'tyeb', 'tyebs', 'tyes', 'tyess', 'tyeng', 'tyej', 'tyec', 'tyek', 'tyet', 'tyep', 'tyeh', 'to', 'tog', 'togg', 'togs', 'ton', 'tonj', 'tonh', 'tod', 'tol', 'tolg', 'tolm', 'tolb', 'tols', 'tolt', 'tolp', 'tolh', 'tom', 'tob', 'tobs', 'tos', 'toss', 'tong', 'toj', 'toc', 'tok', 'tot', 'top', 'toh', 'twa', 'twag', 'twagg', 'twags', 'twan', 'twanj', 'twanh', 'twad', 'twal', 'twalg', 'twalm', 'twalb', 'twals', 'twalt', 'twalp', 'twalh', 'twam', 'twab', 'twabs', 'twas', 'twass', 'twang', 'twaj', 'twac', 'twak', 'twat', 'twap', 'twah', 'twae', 'twaeg', 'twaegg', 'twaegs', 'twaen', 'twaenj', 'twaenh', 'twaed', 'twael', 'twaelg', 'twaelm', 'twaelb', 'twaels', 'twaelt', 'twaelp', 'twaelh', 'twaem', 'twaeb', 'twaebs', 'twaes', 'twaess', 'twaeng', 'twaej', 'twaec', 'twaek', 'twaet', 'twaep', 'twaeh', 'toe', 'toeg', 'toegg', 'toegs', 'toen', 'toenj', 'toenh', 'toed', 'toel', 'toelg', 'toelm', 'toelb']


Joomla CMS: Référence du fichier TracksController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TracksController.php

Structures de données

class TracksController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Banners\Administrator\Controller


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_newsfeeds
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_newsfeeds/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier PluginorderingField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PluginorderingField.php

Structures de données

class PluginorderingField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Field


Joomla CMS: Référence du fichier RC4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier RC4.php

Structures de données

class RC4

Espaces de nommage

RC4
phpseclib3\Crypt


Joomla CMS: Référence du fichier Validity.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Validity.php

Structures de données

class Validity

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Rule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Access
Structures de données | Espaces de nommage
Référence du fichier Rule.php

Structures de données

class Rule

Espaces de nommage

Joomla\CMS\Access


Joomla CMS: Référence du fichier x0b5.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b5.php

Variables

return ['dyil', 'dyilg', 'dyilm', 'dyilb', 'dyils', 'dyilt', 'dyilp', 'dyilh', 'dyim', 'dyib', 'dyibs', 'dyis', 'dyiss', 'dying', 'dyij', 'dyic', 'dyik', 'dyit', 'dyip', 'dyih', 'di', 'dig', 'digg', 'digs', 'din', 'dinj', 'dinh', 'did', 'dil', 'dilg', 'dilm', 'dilb', 'dils', 'dilt', 'dilp', 'dilh', 'dim', 'dib', 'dibs', 'dis', 'diss', 'ding', 'dij', 'dic', 'dik', 'dit', 'dip', 'dih', 'dda', 'ddag', 'ddagg', 'ddags', 'ddan', 'ddanj', 'ddanh', 'ddad', 'ddal', 'ddalg', 'ddalm', 'ddalb', 'ddals', 'ddalt', 'ddalp', 'ddalh', 'ddam', 'ddab', 'ddabs', 'ddas', 'ddass', 'ddang', 'ddaj', 'ddac', 'ddak', 'ddat', 'ddap', 'ddah', 'ddae', 'ddaeg', 'ddaegg', 'ddaegs', 'ddaen', 'ddaenj', 'ddaenh', 'ddaed', 'ddael', 'ddaelg', 'ddaelm', 'ddaelb', 'ddaels', 'ddaelt', 'ddaelp', 'ddaelh', 'ddaem', 'ddaeb', 'ddaebs', 'ddaes', 'ddaess', 'ddaeng', 'ddaej', 'ddaec', 'ddaek', 'ddaet', 'ddaep', 'ddaeh', 'ddya', 'ddyag', 'ddyagg', 'ddyags', 'ddyan', 'ddyanj', 'ddyanh', 'ddyad', 'ddyal', 'ddyalg', 'ddyalm', 'ddyalb', 'ddyals', 'ddyalt', 'ddyalp', 'ddyalh', 'ddyam', 'ddyab', 'ddyabs', 'ddyas', 'ddyass', 'ddyang', 'ddyaj', 'ddyac', 'ddyak', 'ddyat', 'ddyap', 'ddyah', 'ddyae', 'ddyaeg', 'ddyaegg', 'ddyaegs', 'ddyaen', 'ddyaenj', 'ddyaenh', 'ddyaed', 'ddyael', 'ddyaelg', 'ddyaelm', 'ddyaelb', 'ddyaels', 'ddyaelt', 'ddyaelp', 'ddyaelh', 'ddyaem', 'ddyaeb', 'ddyaebs', 'ddyaes', 'ddyaess', 'ddyaeng', 'ddyaej', 'ddyaec', 'ddyaek', 'ddyaet', 'ddyaep', 'ddyaeh', 'ddeo', 'ddeog', 'ddeogg', 'ddeogs', 'ddeon', 'ddeonj', 'ddeonh', 'ddeod', 'ddeol', 'ddeolg', 'ddeolm', 'ddeolb', 'ddeols', 'ddeolt', 'ddeolp', 'ddeolh', 'ddeom', 'ddeob', 'ddeobs', 'ddeos', 'ddeoss', 'ddeong', 'ddeoj', 'ddeoc', 'ddeok', 'ddeot', 'ddeop', 'ddeoh', 'dde', 'ddeg', 'ddegg', 'ddegs', 'dden', 'ddenj', 'ddenh', 'dded', 'ddel', 'ddelg', 'ddelm', 'ddelb', 'ddels', 'ddelt', 'ddelp', 'ddelh', 'ddem', 'ddeb', 'ddebs', 'ddes', 'ddess', 'ddeng', 'ddej', 'ddec', 'ddek', 'ddet', 'ddep', 'ddeh', 'ddyeo', 'ddyeog', 'ddyeogg', 'ddyeogs', 'ddyeon', 'ddyeonj', 'ddyeonh', 'ddyeod', 'ddyeol', 'ddyeolg', 'ddyeolm', 'ddyeolb', 'ddyeols', 'ddyeolt', 'ddyeolp', 'ddyeolh', 'ddyeom', 'ddyeob', 'ddyeobs', 'ddyeos', 'ddyeoss', 'ddyeong', 'ddyeoj', 'ddyeoc', 'ddyeok', 'ddyeot', 'ddyeop', 'ddyeoh', 'ddye', 'ddyeg', 'ddyegg', 'ddyegs', 'ddyen', 'ddyenj', 'ddyenh', 'ddyed', 'ddyel', 'ddyelg', 'ddyelm', 'ddyelb']

Documentation des variables

◆ return

return[ 'dyil', 'dyilg', 'dyilm', 'dyilb', 'dyils', 'dyilt', 'dyilp', 'dyilh', 'dyim', 'dyib', 'dyibs', 'dyis', 'dyiss', 'dying', 'dyij', 'dyic', 'dyik', 'dyit', 'dyip', 'dyih', 'di', 'dig', 'digg', 'digs', 'din', 'dinj', 'dinh', 'did', 'dil', 'dilg', 'dilm', 'dilb', 'dils', 'dilt', 'dilp', 'dilh', 'dim', 'dib', 'dibs', 'dis', 'diss', 'ding', 'dij', 'dic', 'dik', 'dit', 'dip', 'dih', 'dda', 'ddag', 'ddagg', 'ddags', 'ddan', 'ddanj', 'ddanh', 'ddad', 'ddal', 'ddalg', 'ddalm', 'ddalb', 'ddals', 'ddalt', 'ddalp', 'ddalh', 'ddam', 'ddab', 'ddabs', 'ddas', 'ddass', 'ddang', 'ddaj', 'ddac', 'ddak', 'ddat', 'ddap', 'ddah', 'ddae', 'ddaeg', 'ddaegg', 'ddaegs', 'ddaen', 'ddaenj', 'ddaenh', 'ddaed', 'ddael', 'ddaelg', 'ddaelm', 'ddaelb', 'ddaels', 'ddaelt', 'ddaelp', 'ddaelh', 'ddaem', 'ddaeb', 'ddaebs', 'ddaes', 'ddaess', 'ddaeng', 'ddaej', 'ddaec', 'ddaek', 'ddaet', 'ddaep', 'ddaeh', 'ddya', 'ddyag', 'ddyagg', 'ddyags', 'ddyan', 'ddyanj', 'ddyanh', 'ddyad', 'ddyal', 'ddyalg', 'ddyalm', 'ddyalb', 'ddyals', 'ddyalt', 'ddyalp', 'ddyalh', 'ddyam', 'ddyab', 'ddyabs', 'ddyas', 'ddyass', 'ddyang', 'ddyaj', 'ddyac', 'ddyak', 'ddyat', 'ddyap', 'ddyah', 'ddyae', 'ddyaeg', 'ddyaegg', 'ddyaegs', 'ddyaen', 'ddyaenj', 'ddyaenh', 'ddyaed', 'ddyael', 'ddyaelg', 'ddyaelm', 'ddyaelb', 'ddyaels', 'ddyaelt', 'ddyaelp', 'ddyaelh', 'ddyaem', 'ddyaeb', 'ddyaebs', 'ddyaes', 'ddyaess', 'ddyaeng', 'ddyaej', 'ddyaec', 'ddyaek', 'ddyaet', 'ddyaep', 'ddyaeh', 'ddeo', 'ddeog', 'ddeogg', 'ddeogs', 'ddeon', 'ddeonj', 'ddeonh', 'ddeod', 'ddeol', 'ddeolg', 'ddeolm', 'ddeolb', 'ddeols', 'ddeolt', 'ddeolp', 'ddeolh', 'ddeom', 'ddeob', 'ddeobs', 'ddeos', 'ddeoss', 'ddeong', 'ddeoj', 'ddeoc', 'ddeok', 'ddeot', 'ddeop', 'ddeoh', 'dde', 'ddeg', 'ddegg', 'ddegs', 'dden', 'ddenj', 'ddenh', 'dded', 'ddel', 'ddelg', 'ddelm', 'ddelb', 'ddels', 'ddelt', 'ddelp', 'ddelh', 'ddem', 'ddeb', 'ddebs', 'ddes', 'ddess', 'ddeng', 'ddej', 'ddec', 'ddek', 'ddet', 'ddep', 'ddeh', 'ddyeo', 'ddyeog', 'ddyeogg', 'ddyeogs', 'ddyeon', 'ddyeonj', 'ddyeonh', 'ddyeod', 'ddyeol', 'ddyeolg', 'ddyeolm', 'ddyeolb', 'ddyeols', 'ddyeolt', 'ddyeolp', 'ddyeolh', 'ddyeom', 'ddyeob', 'ddyeobs', 'ddyeos', 'ddyeoss', 'ddyeong', 'ddyeoj', 'ddyeoc', 'ddyeok', 'ddyeot', 'ddyeop', 'ddyeoh', 'ddye', 'ddyeg', 'ddyegg', 'ddyegs', 'ddyen', 'ddyenj', 'ddyenh', 'ddyed', 'ddyel', 'ddyelg', 'ddyelm', 'ddyelb']


Joomla CMS: Référence du fichier x028.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x028.php

Variables

return [' ', 'a', '1', 'b', '\'', 'k', '2', 'l', '@', 'c', 'i', 'f', '/', 'm', 's', 'p', '"', 'e', '3', 'h', '9', 'o', '6', 'r', '^', 'd', 'j', 'g', '>', 'n', 't', 'q', ',', '*', '5', '<', '-', 'u', '8', 'v', '.', '%', '[', '$', '+', 'x', '!', '&', ';', ':', '4', '\, '0', 'z', '7', '(', '_', '?', 'w', ']', '#', 'y', ')', '=', '[d7]', '[d17]', '[d27]', '[d127]', '[d37]', '[d137]', '[d237]', '[d1237]', '[d47]', '[d147]', '[d247]', '[d1247]', '[d347]', '[d1347]', '[d2347]', '[d12347]', '[d57]', '[d157]', '[d257]', '[d1257]', '[d357]', '[d1357]', '[d2357]', '[d12357]', '[d457]', '[d1457]', '[d2457]', '[d12457]', '[d3457]', '[d13457]', '[d23457]', '[d123457]', '[d67]', '[d167]', '[d267]', '[d1267]', '[d367]', '[d1367]', '[d2367]', '[d12367]', '[d467]', '[d1467]', '[d2467]', '[d12467]', '[d3467]', '[d13467]', '[d23467]', '[d123467]', '[d567]', '[d1567]', '[d2567]', '[d12567]', '[d3567]', '[d13567]', '[d23567]', '[d123567]', '[d4567]', '[d14567]', '[d24567]', '[d124567]', '[d34567]', '[d134567]', '[d234567]', '[d1234567]', '[d8]', '[d18]', '[d28]', '[d128]', '[d38]', '[d138]', '[d238]', '[d1238]', '[d48]', '[d148]', '[d248]', '[d1248]', '[d348]', '[d1348]', '[d2348]', '[d12348]', '[d58]', '[d158]', '[d258]', '[d1258]', '[d358]', '[d1358]', '[d2358]', '[d12358]', '[d458]', '[d1458]', '[d2458]', '[d12458]', '[d3458]', '[d13458]', '[d23458]', '[d123458]', '[d68]', '[d168]', '[d268]', '[d1268]', '[d368]', '[d1368]', '[d2368]', '[d12368]', '[d468]', '[d1468]', '[d2468]', '[d12468]', '[d3468]', '[d13468]', '[d23468]', '[d123468]', '[d568]', '[d1568]', '[d2568]', '[d12568]', '[d3568]', '[d13568]', '[d23568]', '[d123568]', '[d4568]', '[d14568]', '[d24568]', '[d124568]', '[d34568]', '[d134568]', '[d234568]', '[d1234568]', '[d78]', '[d178]', '[d278]', '[d1278]', '[d378]', '[d1378]', '[d2378]', '[d12378]', '[d478]', '[d1478]', '[d2478]', '[d12478]', '[d3478]', '[d13478]', '[d23478]', '[d123478]', '[d578]', '[d1578]', '[d2578]', '[d12578]', '[d3578]', '[d13578]', '[d23578]', '[d123578]', '[d4578]', '[d14578]', '[d24578]', '[d124578]', '[d34578]', '[d134578]', '[d234578]', '[d1234578]', '[d678]', '[d1678]', '[d2678]', '[d12678]', '[d3678]', '[d13678]', '[d23678]', '[d123678]', '[d4678]', '[d14678]', '[d24678]', '[d124678]', '[d34678]', '[d134678]', '[d234678]', '[d1234678]', '[d5678]', '[d15678]', '[d25678]', '[d125678]', '[d35678]', '[d135678]', '[d235678]', '[d1235678]', '[d45678]', '[d145678]', '[d245678]', '[d1245678]', '[d345678]', '[d1345678]', '[d2345678]', '[d12345678]']

Documentation des variables

◆ return

return[' ', 'a', '1', 'b', '\'', 'k', '2', 'l', '@', 'c', 'i', 'f', '/', 'm', 's', 'p', '"', 'e', '3', 'h', '9', 'o', '6', 'r', '^', 'd', 'j', 'g', '>', 'n', 't', 'q', ',', '*', '5', '<', '-', 'u', '8', 'v', '.', '%', '[', '$', '+', 'x', '!', '&', ';', ':', '4', '\', '0', 'z', '7', '(', '_', '?', 'w', ']', '#', 'y', ')', '=', '[d7]', '[d17]', '[d27]', '[d127]', '[d37]', '[d137]', '[d237]', '[d1237]', '[d47]', '[d147]', '[d247]', '[d1247]', '[d347]', '[d1347]', '[d2347]', '[d12347]', '[d57]', '[d157]', '[d257]', '[d1257]', '[d357]', '[d1357]', '[d2357]', '[d12357]', '[d457]', '[d1457]', '[d2457]', '[d12457]', '[d3457]', '[d13457]', '[d23457]', '[d123457]', '[d67]', '[d167]', '[d267]', '[d1267]', '[d367]', '[d1367]', '[d2367]', '[d12367]', '[d467]', '[d1467]', '[d2467]', '[d12467]', '[d3467]', '[d13467]', '[d23467]', '[d123467]', '[d567]', '[d1567]', '[d2567]', '[d12567]', '[d3567]', '[d13567]', '[d23567]', '[d123567]', '[d4567]', '[d14567]', '[d24567]', '[d124567]', '[d34567]', '[d134567]', '[d234567]', '[d1234567]', '[d8]', '[d18]', '[d28]', '[d128]', '[d38]', '[d138]', '[d238]', '[d1238]', '[d48]', '[d148]', '[d248]', '[d1248]', '[d348]', '[d1348]', '[d2348]', '[d12348]', '[d58]', '[d158]', '[d258]', '[d1258]', '[d358]', '[d1358]', '[d2358]', '[d12358]', '[d458]', '[d1458]', '[d2458]', '[d12458]', '[d3458]', '[d13458]', '[d23458]', '[d123458]', '[d68]', '[d168]', '[d268]', '[d1268]', '[d368]', '[d1368]', '[d2368]', '[d12368]', '[d468]', '[d1468]', '[d2468]', '[d12468]', '[d3468]', '[d13468]', '[d23468]', '[d123468]', '[d568]', '[d1568]', '[d2568]', '[d12568]', '[d3568]', '[d13568]', '[d23568]', '[d123568]', '[d4568]', '[d14568]', '[d24568]', '[d124568]', '[d34568]', '[d134568]', '[d234568]', '[d1234568]', '[d78]', '[d178]', '[d278]', '[d1278]', '[d378]', '[d1378]', '[d2378]', '[d12378]', '[d478]', '[d1478]', '[d2478]', '[d12478]', '[d3478]', '[d13478]', '[d23478]', '[d123478]', '[d578]', '[d1578]', '[d2578]', '[d12578]', '[d3578]', '[d13578]', '[d23578]', '[d123578]', '[d4578]', '[d14578]', '[d24578]', '[d124578]', '[d34578]', '[d134578]', '[d234578]', '[d1234578]', '[d678]', '[d1678]', '[d2678]', '[d12678]', '[d3678]', '[d13678]', '[d23678]', '[d123678]', '[d4678]', '[d14678]', '[d24678]', '[d124678]', '[d34678]', '[d134678]', '[d234678]', '[d1234678]', '[d5678]', '[d15678]', '[d25678]', '[d125678]', '[d35678]', '[d135678]', '[d235678]', '[d1235678]', '[d45678]', '[d145678]', '[d245678]', '[d1245678]', '[d345678]', '[d1345678]', '[d2345678]', '[d12345678]']


Joomla CMS: Référence du fichier QuickIconHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_quickicon
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier QuickIconHelper.php

Structures de données

class QuickIconHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\Quickicon\Administrator\Helper


Joomla CMS: Référence du fichier RegistrationdaterangeField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RegistrationdaterangeField.php

Structures de données

class RegistrationdaterangeField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier RSAPSS.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier RSAPSS.php

Structures de données

class RSAPSS

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier TagsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_tags/src/Controller/TagsController.php

Structures de données

class TagsController

Espaces de nommage

Joomla\API
Joomla\Component\Tags\Api\Controller


Joomla CMS: Référence du fichier SodiumCipher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Crypt
  • Cipher
Structures de données | Espaces de nommage
Référence du fichier SodiumCipher.php

Structures de données

class SodiumCipher

Espaces de nommage

Joomla\CMS\Crypt\Cipher


Joomla CMS: Référence du fichier PluginHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Plugin
Structures de données | Espaces de nommage
Référence du fichier PluginHelper.php

Structures de données

class PluginHelper

Espaces de nommage

Joomla\CMS\Plugin


Joomla CMS: Référence du fichier UTF8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
Espaces de nommage
Référence du fichier UTF8.php

Espaces de nommage

voku\helper


Joomla CMS: Référence du fichier ServiceSubscriberTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Espaces de nommage | Fonctions | Variables
Référence du fichier ServiceSubscriberTrait.php

Espaces de nommage

Symfony\Contracts\Service

Fonctions

static getSubscribedServices ()
setContainer (ContainerInterface $container)

Variables

trait ServiceSubscriberTrait


Joomla CMS: Référence du fichier webcron_link.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • layouts
  • form
  • field
Espaces de nommage | Variables
Référence du fichier webcron_link.php

Espaces de nommage

Joomla\Administrator

Variables

$app = Factory::getApplication()
$wa = $app->getDocument()->getWebAssetManager()

Documentation des variables

◆ $app

$app = Factory::getApplication()

◆ $wa

$wa = $app->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier x073.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x073.php

Variables

return ['Sha ', 'Li ', 'Han ', 'Xian ', 'Jing ', 'Pai ', 'Fei ', 'Yao ', 'Ba ', 'Qi ', 'Ni ', 'Biao ', 'Yin ', 'Lai ', 'Xi ', 'Jian ', 'Qiang ', 'Kun ', 'Yan ', 'Guo ', 'Zong ', 'Mi ', 'Chang ', 'Yi ', 'Zhi ', 'Zheng ', 'Ya ', 'Meng ', 'Cai ', 'Cu ', 'She ', 'Kari ', 'Cen ', 'Luo ', 'Hu ', 'Zong ', 'Ji ', 'Wei ', 'Feng ', 'Wo ', 'Yuan ', 'Xing ', 'Zhu ', 'Mao ', 'Wei ', 'Yuan ', 'Xian ', 'Tuan ', 'Ya ', 'Nao ', 'Xie ', 'Jia ', 'Hou ', 'Bian ', 'You ', 'You ', 'Mei ', 'Zha ', 'Yao ', 'Sun ', 'Bo ', 'Ming ', 'Hua ', 'Yuan ', 'Sou ', 'Ma ', 'Yuan ', 'Dai ', 'Yu ', 'Shi ', 'Hao ', '[?] ', 'Yi ', 'Zhen ', 'Chuang ', 'Hao ', 'Man ', 'Jing ', 'Jiang ', 'Mu ', 'Zhang ', 'Chan ', 'Ao ', 'Ao ', 'Hao ', 'Cui ', 'Fen ', 'Jue ', 'Bi ', 'Bi ', 'Huang ', 'Pu ', 'Lin ', 'Yu ', 'Tong ', 'Yao ', 'Liao ', 'Shuo ', 'Xiao ', 'Swu ', 'Ton ', 'Xi ', 'Ge ', 'Juan ', 'Du ', 'Hui ', 'Kuai ', 'Xian ', 'Xie ', 'Ta ', 'Xian ', 'Xun ', 'Ning ', 'Pin ', 'Huo ', 'Nou ', 'Meng ', 'Lie ', 'Nao ', 'Guang ', 'Shou ', 'Lu ', 'Ta ', 'Xian ', 'Mi ', 'Rang ', 'Huan ', 'Nao ', 'Luo ', 'Xian ', 'Qi ', 'Jue ', 'Xuan ', 'Miao ', 'Zi ', 'Lu ', 'Lu ', 'Yu ', 'Su ', 'Wang ', 'Qiu ', 'Ga ', 'Ding ', 'Le ', 'Ba ', 'Ji ', 'Hong ', 'Di ', 'Quan ', 'Gan ', 'Jiu ', 'Yu ', 'Ji ', 'Yu ', 'Yang ', 'Ma ', 'Gong ', 'Wu ', 'Fu ', 'Wen ', 'Jie ', 'Ya ', 'Fen ', 'Bian ', 'Beng ', 'Yue ', 'Jue ', 'Yun ', 'Jue ', 'Wan ', 'Jian ', 'Mei ', 'Dan ', 'Pi ', 'Wei ', 'Huan ', 'Xian ', 'Qiang ', 'Ling ', 'Dai ', 'Yi ', 'An ', 'Ping ', 'Dian ', 'Fu ', 'Xuan ', 'Xi ', 'Bo ', 'Ci ', 'Gou ', 'Jia ', 'Shao ', 'Po ', 'Ci ', 'Ke ', 'Ran ', 'Sheng ', 'Shen ', 'Yi ', 'Zu ', 'Jia ', 'Min ', 'Shan ', 'Liu ', 'Bi ', 'Zhen ', 'Zhen ', 'Jue ', 'Fa ', 'Long ', 'Jin ', 'Jiao ', 'Jian ', 'Li ', 'Guang ', 'Xian ', 'Zhou ', 'Gong ', 'Yan ', 'Xiu ', 'Yang ', 'Xu ', 'Luo ', 'Su ', 'Zhu ', 'Qin ', 'Ken ', 'Xun ', 'Bao ', 'Er ', 'Xiang ', 'Yao ', 'Xia ', 'Heng ', 'Gui ', 'Chong ', 'Xu ', 'Ban ', 'Pei ', '[?] ', 'Dang ', 'Ei ', 'Hun ', 'Wen ', 'E ', 'Cheng ', 'Ti ', 'Wu ', 'Wu ', 'Cheng ', 'Jun ', 'Mei ', 'Bei ', 'Ting ', 'Xian ', 'Chuo ']

Documentation des variables

◆ return

return[ 'Sha ', 'Li ', 'Han ', 'Xian ', 'Jing ', 'Pai ', 'Fei ', 'Yao ', 'Ba ', 'Qi ', 'Ni ', 'Biao ', 'Yin ', 'Lai ', 'Xi ', 'Jian ', 'Qiang ', 'Kun ', 'Yan ', 'Guo ', 'Zong ', 'Mi ', 'Chang ', 'Yi ', 'Zhi ', 'Zheng ', 'Ya ', 'Meng ', 'Cai ', 'Cu ', 'She ', 'Kari ', 'Cen ', 'Luo ', 'Hu ', 'Zong ', 'Ji ', 'Wei ', 'Feng ', 'Wo ', 'Yuan ', 'Xing ', 'Zhu ', 'Mao ', 'Wei ', 'Yuan ', 'Xian ', 'Tuan ', 'Ya ', 'Nao ', 'Xie ', 'Jia ', 'Hou ', 'Bian ', 'You ', 'You ', 'Mei ', 'Zha ', 'Yao ', 'Sun ', 'Bo ', 'Ming ', 'Hua ', 'Yuan ', 'Sou ', 'Ma ', 'Yuan ', 'Dai ', 'Yu ', 'Shi ', 'Hao ', '[?] ', 'Yi ', 'Zhen ', 'Chuang ', 'Hao ', 'Man ', 'Jing ', 'Jiang ', 'Mu ', 'Zhang ', 'Chan ', 'Ao ', 'Ao ', 'Hao ', 'Cui ', 'Fen ', 'Jue ', 'Bi ', 'Bi ', 'Huang ', 'Pu ', 'Lin ', 'Yu ', 'Tong ', 'Yao ', 'Liao ', 'Shuo ', 'Xiao ', 'Swu ', 'Ton ', 'Xi ', 'Ge ', 'Juan ', 'Du ', 'Hui ', 'Kuai ', 'Xian ', 'Xie ', 'Ta ', 'Xian ', 'Xun ', 'Ning ', 'Pin ', 'Huo ', 'Nou ', 'Meng ', 'Lie ', 'Nao ', 'Guang ', 'Shou ', 'Lu ', 'Ta ', 'Xian ', 'Mi ', 'Rang ', 'Huan ', 'Nao ', 'Luo ', 'Xian ', 'Qi ', 'Jue ', 'Xuan ', 'Miao ', 'Zi ', 'Lu ', 'Lu ', 'Yu ', 'Su ', 'Wang ', 'Qiu ', 'Ga ', 'Ding ', 'Le ', 'Ba ', 'Ji ', 'Hong ', 'Di ', 'Quan ', 'Gan ', 'Jiu ', 'Yu ', 'Ji ', 'Yu ', 'Yang ', 'Ma ', 'Gong ', 'Wu ', 'Fu ', 'Wen ', 'Jie ', 'Ya ', 'Fen ', 'Bian ', 'Beng ', 'Yue ', 'Jue ', 'Yun ', 'Jue ', 'Wan ', 'Jian ', 'Mei ', 'Dan ', 'Pi ', 'Wei ', 'Huan ', 'Xian ', 'Qiang ', 'Ling ', 'Dai ', 'Yi ', 'An ', 'Ping ', 'Dian ', 'Fu ', 'Xuan ', 'Xi ', 'Bo ', 'Ci ', 'Gou ', 'Jia ', 'Shao ', 'Po ', 'Ci ', 'Ke ', 'Ran ', 'Sheng ', 'Shen ', 'Yi ', 'Zu ', 'Jia ', 'Min ', 'Shan ', 'Liu ', 'Bi ', 'Zhen ', 'Zhen ', 'Jue ', 'Fa ', 'Long ', 'Jin ', 'Jiao ', 'Jian ', 'Li ', 'Guang ', 'Xian ', 'Zhou ', 'Gong ', 'Yan ', 'Xiu ', 'Yang ', 'Xu ', 'Luo ', 'Su ', 'Zhu ', 'Qin ', 'Ken ', 'Xun ', 'Bao ', 'Er ', 'Xiang ', 'Yao ', 'Xia ', 'Heng ', 'Gui ', 'Chong ', 'Xu ', 'Ban ', 'Pei ', '[?] ', 'Dang ', 'Ei ', 'Hun ', 'Wen ', 'E ', 'Cheng ', 'Ti ', 'Wu ', 'Wu ', 'Cheng ', 'Jun ', 'Mei ', 'Bei ', 'Ting ', 'Xian ', 'Chuo ']


Joomla CMS: Référence du fichier ServerRequest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • nyholm
  • psr7
  • src
Structures de données | Espaces de nommage
Référence du fichier nyholm/psr7/src/ServerRequest.php

Structures de données

class ServerRequest

Espaces de nommage

Nyholm\Psr7


Joomla CMS: Référence du fichier RequestController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/Controller/RequestController.php

Structures de données

class RequestController

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Controller


Joomla CMS: Référence du fichier simple.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • color
Espaces de nommage | Variables
Référence du fichier simple.php

Espaces de nommage

Joomla\Site

Variables

$class = ' class="form-select ' . trim($class) . '"'
$disabled = $disabled ? ' disabled' : ''
$readonly = $readonly ? ' readonly' : ''
endforeach

Documentation des variables

◆ $class

$class = ' class="form-select ' . trim($class) . '"'

◆ $disabled

$disabled = $disabled ? ' disabled' : ''

◆ $readonly

$readonly = $readonly ? ' readonly' : ''

◆ endforeach

endforeach


Joomla CMS: Référence du fichier SessionInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier SessionInterface.php

Structures de données

interface SessionInterface

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier x088.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x088.php

Variables

return ['Ci ', 'Xiang ', 'She ', 'Luo ', 'Qin ', 'Ying ', 'Chai ', 'Li ', 'Ze ', 'Xuan ', 'Lian ', 'Zhu ', 'Ze ', 'Xie ', 'Mang ', 'Xie ', 'Qi ', 'Rong ', 'Jian ', 'Meng ', 'Hao ', 'Ruan ', 'Huo ', 'Zhuo ', 'Jie ', 'Bin ', 'He ', 'Mie ', 'Fan ', 'Lei ', 'Jie ', 'La ', 'Mi ', 'Li ', 'Chun ', 'Li ', 'Qiu ', 'Nie ', 'Lu ', 'Du ', 'Xiao ', 'Zhu ', 'Long ', 'Li ', 'Long ', 'Feng ', 'Ye ', 'Beng ', 'Shang ', 'Gu ', 'Juan ', 'Ying ', '[?] ', 'Xi ', 'Can ', 'Qu ', 'Quan ', 'Du ', 'Can ', 'Man ', 'Jue ', 'Jie ', 'Zhu ', 'Zha ', 'Xie ', 'Huang ', 'Niu ', 'Pei ', 'Nu ', 'Xin ', 'Zhong ', 'Mo ', 'Er ', 'Ke ', 'Mie ', 'Xi ', 'Xing ', 'Yan ', 'Kan ', 'Yuan ', '[?] ', 'Ling ', 'Xuan ', 'Shu ', 'Xian ', 'Tong ', 'Long ', 'Jie ', 'Xian ', 'Ya ', 'Hu ', 'Wei ', 'Dao ', 'Chong ', 'Wei ', 'Dao ', 'Zhun ', 'Heng ', 'Qu ', 'Yi ', 'Yi ', 'Bu ', 'Gan ', 'Yu ', 'Biao ', 'Cha ', 'Yi ', 'Shan ', 'Chen ', 'Fu ', 'Gun ', 'Fen ', 'Shuai ', 'Jie ', 'Na ', 'Zhong ', 'Dan ', 'Ri ', 'Zhong ', 'Zhong ', 'Xie ', 'Qi ', 'Xie ', 'Ran ', 'Zhi ', 'Ren ', 'Qin ', 'Jin ', 'Jun ', 'Yuan ', 'Mei ', 'Chai ', 'Ao ', 'Niao ', 'Hui ', 'Ran ', 'Jia ', 'Tuo ', 'Ling ', 'Dai ', 'Bao ', 'Pao ', 'Yao ', 'Zuo ', 'Bi ', 'Shao ', 'Tan ', 'Ju ', 'He ', 'Shu ', 'Xiu ', 'Zhen ', 'Yi ', 'Pa ', 'Bo ', 'Di ', 'Wa ', 'Fu ', 'Gun ', 'Zhi ', 'Zhi ', 'Ran ', 'Pan ', 'Yi ', 'Mao ', 'Tuo ', 'Na ', 'Kou ', 'Xian ', 'Chan ', 'Qu ', 'Bei ', 'Gun ', 'Xi ', 'Ne ', 'Bo ', 'Horo ', 'Fu ', 'Yi ', 'Chi ', 'Ku ', 'Ren ', 'Jiang ', 'Jia ', 'Cun ', 'Mo ', 'Jie ', 'Er ', 'Luo ', 'Ru ', 'Zhu ', 'Gui ', 'Yin ', 'Cai ', 'Lie ', 'Kamishimo ', 'Yuki ', 'Zhuang ', 'Dang ', '[?] ', 'Kun ', 'Ken ', 'Niao ', 'Shu ', 'Jia ', 'Kun ', 'Cheng ', 'Li ', 'Juan ', 'Shen ', 'Pou ', 'Ge ', 'Yi ', 'Yu ', 'Zhen ', 'Liu ', 'Qiu ', 'Qun ', 'Ji ', 'Yi ', 'Bu ', 'Zhuang ', 'Shui ', 'Sha ', 'Qun ', 'Li ', 'Lian ', 'Lian ', 'Ku ', 'Jian ', 'Fou ', 'Chan ', 'Bi ', 'Gun ', 'Tao ', 'Yuan ', 'Ling ', 'Chi ', 'Chang ', 'Chou ', 'Duo ', 'Biao ', 'Liang ', 'Chang ', 'Pei ', 'Pei ', 'Fei ', 'Yuan ', 'Luo ', 'Guo ', 'Yan ', 'Du ', 'Xi ', 'Zhi ', 'Ju ', 'Qi ']

Documentation des variables

◆ return

return[ 'Ci ', 'Xiang ', 'She ', 'Luo ', 'Qin ', 'Ying ', 'Chai ', 'Li ', 'Ze ', 'Xuan ', 'Lian ', 'Zhu ', 'Ze ', 'Xie ', 'Mang ', 'Xie ', 'Qi ', 'Rong ', 'Jian ', 'Meng ', 'Hao ', 'Ruan ', 'Huo ', 'Zhuo ', 'Jie ', 'Bin ', 'He ', 'Mie ', 'Fan ', 'Lei ', 'Jie ', 'La ', 'Mi ', 'Li ', 'Chun ', 'Li ', 'Qiu ', 'Nie ', 'Lu ', 'Du ', 'Xiao ', 'Zhu ', 'Long ', 'Li ', 'Long ', 'Feng ', 'Ye ', 'Beng ', 'Shang ', 'Gu ', 'Juan ', 'Ying ', '[?] ', 'Xi ', 'Can ', 'Qu ', 'Quan ', 'Du ', 'Can ', 'Man ', 'Jue ', 'Jie ', 'Zhu ', 'Zha ', 'Xie ', 'Huang ', 'Niu ', 'Pei ', 'Nu ', 'Xin ', 'Zhong ', 'Mo ', 'Er ', 'Ke ', 'Mie ', 'Xi ', 'Xing ', 'Yan ', 'Kan ', 'Yuan ', '[?] ', 'Ling ', 'Xuan ', 'Shu ', 'Xian ', 'Tong ', 'Long ', 'Jie ', 'Xian ', 'Ya ', 'Hu ', 'Wei ', 'Dao ', 'Chong ', 'Wei ', 'Dao ', 'Zhun ', 'Heng ', 'Qu ', 'Yi ', 'Yi ', 'Bu ', 'Gan ', 'Yu ', 'Biao ', 'Cha ', 'Yi ', 'Shan ', 'Chen ', 'Fu ', 'Gun ', 'Fen ', 'Shuai ', 'Jie ', 'Na ', 'Zhong ', 'Dan ', 'Ri ', 'Zhong ', 'Zhong ', 'Xie ', 'Qi ', 'Xie ', 'Ran ', 'Zhi ', 'Ren ', 'Qin ', 'Jin ', 'Jun ', 'Yuan ', 'Mei ', 'Chai ', 'Ao ', 'Niao ', 'Hui ', 'Ran ', 'Jia ', 'Tuo ', 'Ling ', 'Dai ', 'Bao ', 'Pao ', 'Yao ', 'Zuo ', 'Bi ', 'Shao ', 'Tan ', 'Ju ', 'He ', 'Shu ', 'Xiu ', 'Zhen ', 'Yi ', 'Pa ', 'Bo ', 'Di ', 'Wa ', 'Fu ', 'Gun ', 'Zhi ', 'Zhi ', 'Ran ', 'Pan ', 'Yi ', 'Mao ', 'Tuo ', 'Na ', 'Kou ', 'Xian ', 'Chan ', 'Qu ', 'Bei ', 'Gun ', 'Xi ', 'Ne ', 'Bo ', 'Horo ', 'Fu ', 'Yi ', 'Chi ', 'Ku ', 'Ren ', 'Jiang ', 'Jia ', 'Cun ', 'Mo ', 'Jie ', 'Er ', 'Luo ', 'Ru ', 'Zhu ', 'Gui ', 'Yin ', 'Cai ', 'Lie ', 'Kamishimo ', 'Yuki ', 'Zhuang ', 'Dang ', '[?] ', 'Kun ', 'Ken ', 'Niao ', 'Shu ', 'Jia ', 'Kun ', 'Cheng ', 'Li ', 'Juan ', 'Shen ', 'Pou ', 'Ge ', 'Yi ', 'Yu ', 'Zhen ', 'Liu ', 'Qiu ', 'Qun ', 'Ji ', 'Yi ', 'Bu ', 'Zhuang ', 'Shui ', 'Sha ', 'Qun ', 'Li ', 'Lian ', 'Lian ', 'Ku ', 'Jian ', 'Fou ', 'Chan ', 'Bi ', 'Gun ', 'Tao ', 'Yuan ', 'Ling ', 'Chi ', 'Chang ', 'Chou ', 'Duo ', 'Biao ', 'Liang ', 'Chang ', 'Pei ', 'Pei ', 'Fei ', 'Yuan ', 'Luo ', 'Guo ', 'Yan ', 'Du ', 'Xi ', 'Zhi ', 'Ju ', 'Qi ']


Joomla CMS: Référence du fichier TerminalIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier TerminalIdentifier.php

Structures de données

class TerminalIdentifier

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x0c3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c3.php

Variables

return ['ssal', 'ssalg', 'ssalm', 'ssalb', 'ssals', 'ssalt', 'ssalp', 'ssalh', 'ssam', 'ssab', 'ssabs', 'ssas', 'ssass', 'ssang', 'ssaj', 'ssac', 'ssak', 'ssat', 'ssap', 'ssah', 'ssae', 'ssaeg', 'ssaegg', 'ssaegs', 'ssaen', 'ssaenj', 'ssaenh', 'ssaed', 'ssael', 'ssaelg', 'ssaelm', 'ssaelb', 'ssaels', 'ssaelt', 'ssaelp', 'ssaelh', 'ssaem', 'ssaeb', 'ssaebs', 'ssaes', 'ssaess', 'ssaeng', 'ssaej', 'ssaec', 'ssaek', 'ssaet', 'ssaep', 'ssaeh', 'ssya', 'ssyag', 'ssyagg', 'ssyags', 'ssyan', 'ssyanj', 'ssyanh', 'ssyad', 'ssyal', 'ssyalg', 'ssyalm', 'ssyalb', 'ssyals', 'ssyalt', 'ssyalp', 'ssyalh', 'ssyam', 'ssyab', 'ssyabs', 'ssyas', 'ssyass', 'ssyang', 'ssyaj', 'ssyac', 'ssyak', 'ssyat', 'ssyap', 'ssyah', 'ssyae', 'ssyaeg', 'ssyaegg', 'ssyaegs', 'ssyaen', 'ssyaenj', 'ssyaenh', 'ssyaed', 'ssyael', 'ssyaelg', 'ssyaelm', 'ssyaelb', 'ssyaels', 'ssyaelt', 'ssyaelp', 'ssyaelh', 'ssyaem', 'ssyaeb', 'ssyaebs', 'ssyaes', 'ssyaess', 'ssyaeng', 'ssyaej', 'ssyaec', 'ssyaek', 'ssyaet', 'ssyaep', 'ssyaeh', 'sseo', 'sseog', 'sseogg', 'sseogs', 'sseon', 'sseonj', 'sseonh', 'sseod', 'sseol', 'sseolg', 'sseolm', 'sseolb', 'sseols', 'sseolt', 'sseolp', 'sseolh', 'sseom', 'sseob', 'sseobs', 'sseos', 'sseoss', 'sseong', 'sseoj', 'sseoc', 'sseok', 'sseot', 'sseop', 'sseoh', 'sse', 'sseg', 'ssegg', 'ssegs', 'ssen', 'ssenj', 'ssenh', 'ssed', 'ssel', 'sselg', 'sselm', 'sselb', 'ssels', 'sselt', 'sselp', 'sselh', 'ssem', 'sseb', 'ssebs', 'sses', 'ssess', 'sseng', 'ssej', 'ssec', 'ssek', 'sset', 'ssep', 'sseh', 'ssyeo', 'ssyeog', 'ssyeogg', 'ssyeogs', 'ssyeon', 'ssyeonj', 'ssyeonh', 'ssyeod', 'ssyeol', 'ssyeolg', 'ssyeolm', 'ssyeolb', 'ssyeols', 'ssyeolt', 'ssyeolp', 'ssyeolh', 'ssyeom', 'ssyeob', 'ssyeobs', 'ssyeos', 'ssyeoss', 'ssyeong', 'ssyeoj', 'ssyeoc', 'ssyeok', 'ssyeot', 'ssyeop', 'ssyeoh', 'ssye', 'ssyeg', 'ssyegg', 'ssyegs', 'ssyen', 'ssyenj', 'ssyenh', 'ssyed', 'ssyel', 'ssyelg', 'ssyelm', 'ssyelb', 'ssyels', 'ssyelt', 'ssyelp', 'ssyelh', 'ssyem', 'ssyeb', 'ssyebs', 'ssyes', 'ssyess', 'ssyeng', 'ssyej', 'ssyec', 'ssyek', 'ssyet', 'ssyep', 'ssyeh', 'sso', 'ssog', 'ssogg', 'ssogs', 'sson', 'ssonj', 'ssonh', 'ssod', 'ssol', 'ssolg', 'ssolm', 'ssolb', 'ssols', 'ssolt', 'ssolp', 'ssolh', 'ssom', 'ssob', 'ssobs', 'ssos', 'ssoss', 'ssong', 'ssoj', 'ssoc', 'ssok', 'ssot', 'ssop', 'ssoh', 'sswa', 'sswag', 'sswagg', 'sswags', 'sswan', 'sswanj', 'sswanh', 'sswad', 'sswal', 'sswalg', 'sswalm', 'sswalb']

Documentation des variables

◆ return

return[ 'ssal', 'ssalg', 'ssalm', 'ssalb', 'ssals', 'ssalt', 'ssalp', 'ssalh', 'ssam', 'ssab', 'ssabs', 'ssas', 'ssass', 'ssang', 'ssaj', 'ssac', 'ssak', 'ssat', 'ssap', 'ssah', 'ssae', 'ssaeg', 'ssaegg', 'ssaegs', 'ssaen', 'ssaenj', 'ssaenh', 'ssaed', 'ssael', 'ssaelg', 'ssaelm', 'ssaelb', 'ssaels', 'ssaelt', 'ssaelp', 'ssaelh', 'ssaem', 'ssaeb', 'ssaebs', 'ssaes', 'ssaess', 'ssaeng', 'ssaej', 'ssaec', 'ssaek', 'ssaet', 'ssaep', 'ssaeh', 'ssya', 'ssyag', 'ssyagg', 'ssyags', 'ssyan', 'ssyanj', 'ssyanh', 'ssyad', 'ssyal', 'ssyalg', 'ssyalm', 'ssyalb', 'ssyals', 'ssyalt', 'ssyalp', 'ssyalh', 'ssyam', 'ssyab', 'ssyabs', 'ssyas', 'ssyass', 'ssyang', 'ssyaj', 'ssyac', 'ssyak', 'ssyat', 'ssyap', 'ssyah', 'ssyae', 'ssyaeg', 'ssyaegg', 'ssyaegs', 'ssyaen', 'ssyaenj', 'ssyaenh', 'ssyaed', 'ssyael', 'ssyaelg', 'ssyaelm', 'ssyaelb', 'ssyaels', 'ssyaelt', 'ssyaelp', 'ssyaelh', 'ssyaem', 'ssyaeb', 'ssyaebs', 'ssyaes', 'ssyaess', 'ssyaeng', 'ssyaej', 'ssyaec', 'ssyaek', 'ssyaet', 'ssyaep', 'ssyaeh', 'sseo', 'sseog', 'sseogg', 'sseogs', 'sseon', 'sseonj', 'sseonh', 'sseod', 'sseol', 'sseolg', 'sseolm', 'sseolb', 'sseols', 'sseolt', 'sseolp', 'sseolh', 'sseom', 'sseob', 'sseobs', 'sseos', 'sseoss', 'sseong', 'sseoj', 'sseoc', 'sseok', 'sseot', 'sseop', 'sseoh', 'sse', 'sseg', 'ssegg', 'ssegs', 'ssen', 'ssenj', 'ssenh', 'ssed', 'ssel', 'sselg', 'sselm', 'sselb', 'ssels', 'sselt', 'sselp', 'sselh', 'ssem', 'sseb', 'ssebs', 'sses', 'ssess', 'sseng', 'ssej', 'ssec', 'ssek', 'sset', 'ssep', 'sseh', 'ssyeo', 'ssyeog', 'ssyeogg', 'ssyeogs', 'ssyeon', 'ssyeonj', 'ssyeonh', 'ssyeod', 'ssyeol', 'ssyeolg', 'ssyeolm', 'ssyeolb', 'ssyeols', 'ssyeolt', 'ssyeolp', 'ssyeolh', 'ssyeom', 'ssyeob', 'ssyeobs', 'ssyeos', 'ssyeoss', 'ssyeong', 'ssyeoj', 'ssyeoc', 'ssyeok', 'ssyeot', 'ssyeop', 'ssyeoh', 'ssye', 'ssyeg', 'ssyegg', 'ssyegs', 'ssyen', 'ssyenj', 'ssyenh', 'ssyed', 'ssyel', 'ssyelg', 'ssyelm', 'ssyelb', 'ssyels', 'ssyelt', 'ssyelp', 'ssyelh', 'ssyem', 'ssyeb', 'ssyebs', 'ssyes', 'ssyess', 'ssyeng', 'ssyej', 'ssyec', 'ssyek', 'ssyet', 'ssyep', 'ssyeh', 'sso', 'ssog', 'ssogg', 'ssogs', 'sson', 'ssonj', 'ssonh', 'ssod', 'ssol', 'ssolg', 'ssolm', 'ssolb', 'ssols', 'ssolt', 'ssolp', 'ssolh', 'ssom', 'ssob', 'ssobs', 'ssos', 'ssoss', 'ssong', 'ssoj', 'ssoc', 'ssok', 'ssot', 'ssop', 'ssoh', 'sswa', 'sswag', 'sswagg', 'sswags', 'sswan', 'sswanj', 'sswanh', 'sswad', 'sswal', 'sswalg', 'sswalm', 'sswalb']


Joomla CMS: Référence du fichier Strings.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Common
  • Functions
Structures de données | Espaces de nommage
Référence du fichier Strings.php

Structures de données

class Strings

Espaces de nommage

Functions
phpseclib3\Common\Functions


Joomla CMS: Référence du fichier TimestampTag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier TimestampTag.php

Structures de données

class TimestampTag

Espaces de nommage

CBOR\Tag


Joomla CMS: Référence du fichier x08f.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08f.php

Variables

return ['Er ', 'Qiong ', 'Ju ', 'Jiao ', 'Guang ', 'Lu ', 'Kai ', 'Quan ', 'Zhou ', 'Zai ', 'Zhi ', 'She ', 'Liang ', 'Yu ', 'Shao ', 'You ', 'Huan ', 'Yun ', 'Zhe ', 'Wan ', 'Fu ', 'Qing ', 'Zhou ', 'Ni ', 'Ling ', 'Zhe ', 'Zhan ', 'Liang ', 'Zi ', 'Hui ', 'Wang ', 'Chuo ', 'Guo ', 'Kan ', 'Yi ', 'Peng ', 'Qian ', 'Gun ', 'Nian ', 'Pian ', 'Guan ', 'Bei ', 'Lun ', 'Pai ', 'Liang ', 'Ruan ', 'Rou ', 'Ji ', 'Yang ', 'Xian ', 'Chuan ', 'Cou ', 'Qun ', 'Ge ', 'You ', 'Hong ', 'Shu ', 'Fu ', 'Zi ', 'Fu ', 'Wen ', 'Ben ', 'Zhan ', 'Yu ', 'Wen ', 'Tao ', 'Gu ', 'Zhen ', 'Xia ', 'Yuan ', 'Lu ', 'Jiu ', 'Chao ', 'Zhuan ', 'Wei ', 'Hun ', 'Sori ', 'Che ', 'Jiao ', 'Zhan ', 'Pu ', 'Lao ', 'Fen ', 'Fan ', 'Lin ', 'Ge ', 'Se ', 'Kan ', 'Huan ', 'Yi ', 'Ji ', 'Dui ', 'Er ', 'Yu ', 'Xian ', 'Hong ', 'Lei ', 'Pei ', 'Li ', 'Li ', 'Lu ', 'Lin ', 'Che ', 'Ya ', 'Gui ', 'Xuan ', 'Di ', 'Ren ', 'Zhuan ', 'E ', 'Lun ', 'Ruan ', 'Hong ', 'Ku ', 'Ke ', 'Lu ', 'Zhou ', 'Zhi ', 'Yi ', 'Hu ', 'Zhen ', 'Li ', 'Yao ', 'Qing ', 'Shi ', 'Zai ', 'Zhi ', 'Jiao ', 'Zhou ', 'Quan ', 'Lu ', 'Jiao ', 'Zhe ', 'Fu ', 'Liang ', 'Nian ', 'Bei ', 'Hui ', 'Gun ', 'Wang ', 'Liang ', 'Chuo ', 'Zi ', 'Cou ', 'Fu ', 'Ji ', 'Wen ', 'Shu ', 'Pei ', 'Yuan ', 'Xia ', 'Zhan ', 'Lu ', 'Che ', 'Lin ', 'Xin ', 'Gu ', 'Ci ', 'Ci ', 'Pi ', 'Zui ', 'Bian ', 'La ', 'La ', 'Ci ', 'Xue ', 'Ban ', 'Bian ', 'Bian ', 'Bian ', '[?] ', 'Bian ', 'Ban ', 'Ci ', 'Bian ', 'Bian ', 'Chen ', 'Ru ', 'Nong ', 'Nong ', 'Zhen ', 'Chuo ', 'Chuo ', 'Suberu ', 'Reng ', 'Bian ', 'Bian ', 'Sip ', 'Ip ', 'Liao ', 'Da ', 'Chan ', 'Gan ', 'Qian ', 'Yu ', 'Yu ', 'Qi ', 'Xun ', 'Yi ', 'Guo ', 'Mai ', 'Qi ', 'Za ', 'Wang ', 'Jia ', 'Zhun ', 'Ying ', 'Ti ', 'Yun ', 'Jin ', 'Hang ', 'Ya ', 'Fan ', 'Wu ', 'Da ', 'E ', 'Huan ', 'Zhe ', 'Totemo ', 'Jin ', 'Yuan ', 'Wei ', 'Lian ', 'Chi ', 'Che ', 'Ni ', 'Tiao ', 'Zhi ', 'Yi ', 'Jiong ', 'Jia ', 'Chen ', 'Dai ', 'Er ', 'Di ', 'Po ', 'Wang ', 'Die ', 'Ze ', 'Tao ', 'Shu ', 'Tuo ', 'Kep ', 'Jing ', 'Hui ', 'Tong ', 'You ', 'Mi ', 'Beng ', 'Ji ', 'Nai ', 'Yi ', 'Jie ', 'Zhui ', 'Lie ', 'Xun ']

Documentation des variables

◆ return

return[ 'Er ', 'Qiong ', 'Ju ', 'Jiao ', 'Guang ', 'Lu ', 'Kai ', 'Quan ', 'Zhou ', 'Zai ', 'Zhi ', 'She ', 'Liang ', 'Yu ', 'Shao ', 'You ', 'Huan ', 'Yun ', 'Zhe ', 'Wan ', 'Fu ', 'Qing ', 'Zhou ', 'Ni ', 'Ling ', 'Zhe ', 'Zhan ', 'Liang ', 'Zi ', 'Hui ', 'Wang ', 'Chuo ', 'Guo ', 'Kan ', 'Yi ', 'Peng ', 'Qian ', 'Gun ', 'Nian ', 'Pian ', 'Guan ', 'Bei ', 'Lun ', 'Pai ', 'Liang ', 'Ruan ', 'Rou ', 'Ji ', 'Yang ', 'Xian ', 'Chuan ', 'Cou ', 'Qun ', 'Ge ', 'You ', 'Hong ', 'Shu ', 'Fu ', 'Zi ', 'Fu ', 'Wen ', 'Ben ', 'Zhan ', 'Yu ', 'Wen ', 'Tao ', 'Gu ', 'Zhen ', 'Xia ', 'Yuan ', 'Lu ', 'Jiu ', 'Chao ', 'Zhuan ', 'Wei ', 'Hun ', 'Sori ', 'Che ', 'Jiao ', 'Zhan ', 'Pu ', 'Lao ', 'Fen ', 'Fan ', 'Lin ', 'Ge ', 'Se ', 'Kan ', 'Huan ', 'Yi ', 'Ji ', 'Dui ', 'Er ', 'Yu ', 'Xian ', 'Hong ', 'Lei ', 'Pei ', 'Li ', 'Li ', 'Lu ', 'Lin ', 'Che ', 'Ya ', 'Gui ', 'Xuan ', 'Di ', 'Ren ', 'Zhuan ', 'E ', 'Lun ', 'Ruan ', 'Hong ', 'Ku ', 'Ke ', 'Lu ', 'Zhou ', 'Zhi ', 'Yi ', 'Hu ', 'Zhen ', 'Li ', 'Yao ', 'Qing ', 'Shi ', 'Zai ', 'Zhi ', 'Jiao ', 'Zhou ', 'Quan ', 'Lu ', 'Jiao ', 'Zhe ', 'Fu ', 'Liang ', 'Nian ', 'Bei ', 'Hui ', 'Gun ', 'Wang ', 'Liang ', 'Chuo ', 'Zi ', 'Cou ', 'Fu ', 'Ji ', 'Wen ', 'Shu ', 'Pei ', 'Yuan ', 'Xia ', 'Zhan ', 'Lu ', 'Che ', 'Lin ', 'Xin ', 'Gu ', 'Ci ', 'Ci ', 'Pi ', 'Zui ', 'Bian ', 'La ', 'La ', 'Ci ', 'Xue ', 'Ban ', 'Bian ', 'Bian ', 'Bian ', '[?] ', 'Bian ', 'Ban ', 'Ci ', 'Bian ', 'Bian ', 'Chen ', 'Ru ', 'Nong ', 'Nong ', 'Zhen ', 'Chuo ', 'Chuo ', 'Suberu ', 'Reng ', 'Bian ', 'Bian ', 'Sip ', 'Ip ', 'Liao ', 'Da ', 'Chan ', 'Gan ', 'Qian ', 'Yu ', 'Yu ', 'Qi ', 'Xun ', 'Yi ', 'Guo ', 'Mai ', 'Qi ', 'Za ', 'Wang ', 'Jia ', 'Zhun ', 'Ying ', 'Ti ', 'Yun ', 'Jin ', 'Hang ', 'Ya ', 'Fan ', 'Wu ', 'Da ', 'E ', 'Huan ', 'Zhe ', 'Totemo ', 'Jin ', 'Yuan ', 'Wei ', 'Lian ', 'Chi ', 'Che ', 'Ni ', 'Tiao ', 'Zhi ', 'Yi ', 'Jiong ', 'Jia ', 'Chen ', 'Dai ', 'Er ', 'Di ', 'Po ', 'Wang ', 'Die ', 'Ze ', 'Tao ', 'Shu ', 'Tuo ', 'Kep ', 'Jing ', 'Hui ', 'Tong ', 'You ', 'Mi ', 'Beng ', 'Ji ', 'Nai ', 'Yi ', 'Jie ', 'Zhui ', 'Lie ', 'Xun ']


Joomla CMS: Référence du fichier x057.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x057.php

Variables

return ['Guo ', 'Yin ', 'Hun ', 'Pu ', 'Yu ', 'Han ', 'Yuan ', 'Lun ', 'Quan ', 'Yu ', 'Qing ', 'Guo ', 'Chuan ', 'Wei ', 'Yuan ', 'Quan ', 'Ku ', 'Fu ', 'Yuan ', 'Yuan ', 'E ', 'Tu ', 'Tu ', 'Tu ', 'Tuan ', 'Lue ', 'Hui ', 'Yi ', 'Yuan ', 'Luan ', 'Luan ', 'Tu ', 'Ya ', 'Tu ', 'Ting ', 'Sheng ', 'Pu ', 'Lu ', 'Iri ', 'Ya ', 'Zai ', 'Wei ', 'Ge ', 'Yu ', 'Wu ', 'Gui ', 'Pi ', 'Yi ', 'Di ', 'Qian ', 'Qian ', 'Zhen ', 'Zhuo ', 'Dang ', 'Qia ', 'Akutsu ', 'Yama ', 'Kuang ', 'Chang ', 'Qi ', 'Nie ', 'Mo ', 'Ji ', 'Jia ', 'Zhi ', 'Zhi ', 'Ban ', 'Xun ', 'Tou ', 'Qin ', 'Fen ', 'Jun ', 'Keng ', 'Tun ', 'Fang ', 'Fen ', 'Ben ', 'Tan ', 'Kan ', 'Pi ', 'Zuo ', 'Keng ', 'Bi ', 'Xing ', 'Di ', 'Jing ', 'Ji ', 'Kuai ', 'Di ', 'Jing ', 'Jian ', 'Tan ', 'Li ', 'Ba ', 'Wu ', 'Fen ', 'Zhui ', 'Po ', 'Pan ', 'Tang ', 'Kun ', 'Qu ', 'Tan ', 'Zhi ', 'Tuo ', 'Gan ', 'Ping ', 'Dian ', 'Gua ', 'Ni ', 'Tai ', 'Pi ', 'Jiong ', 'Yang ', 'Fo ', 'Ao ', 'Liu ', 'Qiu ', 'Mu ', 'Ke ', 'Gou ', 'Xue ', 'Ba ', 'Chi ', 'Che ', 'Ling ', 'Zhu ', 'Fu ', 'Hu ', 'Zhi ', 'Chui ', 'La ', 'Long ', 'Long ', 'Lu ', 'Ao ', 'Tay ', 'Pao ', '[?] ', 'Xing ', 'Dong ', 'Ji ', 'Ke ', 'Lu ', 'Ci ', 'Chi ', 'Lei ', 'Gai ', 'Yin ', 'Hou ', 'Dui ', 'Zhao ', 'Fu ', 'Guang ', 'Yao ', 'Duo ', 'Duo ', 'Gui ', 'Cha ', 'Yang ', 'Yin ', 'Fa ', 'Gou ', 'Yuan ', 'Die ', 'Xie ', 'Ken ', 'Jiong ', 'Shou ', 'E ', 'Ha ', 'Dian ', 'Hong ', 'Wu ', 'Kua ', '[?] ', 'Tao ', 'Dang ', 'Kai ', 'Gake ', 'Nao ', 'An ', 'Xing ', 'Xian ', 'Huan ', 'Bang ', 'Pei ', 'Ba ', 'Yi ', 'Yin ', 'Han ', 'Xu ', 'Chui ', 'Cen ', 'Geng ', 'Ai ', 'Peng ', 'Fang ', 'Que ', 'Yong ', 'Xun ', 'Jia ', 'Di ', 'Mai ', 'Lang ', 'Xuan ', 'Cheng ', 'Yan ', 'Jin ', 'Zhe ', 'Lei ', 'Lie ', 'Bu ', 'Cheng ', 'Gomi ', 'Bu ', 'Shi ', 'Xun ', 'Guo ', 'Jiong ', 'Ye ', 'Nian ', 'Di ', 'Yu ', 'Bu ', 'Ya ', 'Juan ', 'Sui ', 'Pi ', 'Cheng ', 'Wan ', 'Ju ', 'Lun ', 'Zheng ', 'Kong ', 'Chong ', 'Dong ', 'Dai ', 'Tan ', 'An ', 'Cai ', 'Shu ', 'Beng ', 'Kan ', 'Zhi ', 'Duo ', 'Yi ', 'Zhi ', 'Yi ', 'Pei ', 'Ji ', 'Zhun ', 'Qi ', 'Sao ', 'Ju ', 'Ni ']

Documentation des variables

◆ return

return[ 'Guo ', 'Yin ', 'Hun ', 'Pu ', 'Yu ', 'Han ', 'Yuan ', 'Lun ', 'Quan ', 'Yu ', 'Qing ', 'Guo ', 'Chuan ', 'Wei ', 'Yuan ', 'Quan ', 'Ku ', 'Fu ', 'Yuan ', 'Yuan ', 'E ', 'Tu ', 'Tu ', 'Tu ', 'Tuan ', 'Lue ', 'Hui ', 'Yi ', 'Yuan ', 'Luan ', 'Luan ', 'Tu ', 'Ya ', 'Tu ', 'Ting ', 'Sheng ', 'Pu ', 'Lu ', 'Iri ', 'Ya ', 'Zai ', 'Wei ', 'Ge ', 'Yu ', 'Wu ', 'Gui ', 'Pi ', 'Yi ', 'Di ', 'Qian ', 'Qian ', 'Zhen ', 'Zhuo ', 'Dang ', 'Qia ', 'Akutsu ', 'Yama ', 'Kuang ', 'Chang ', 'Qi ', 'Nie ', 'Mo ', 'Ji ', 'Jia ', 'Zhi ', 'Zhi ', 'Ban ', 'Xun ', 'Tou ', 'Qin ', 'Fen ', 'Jun ', 'Keng ', 'Tun ', 'Fang ', 'Fen ', 'Ben ', 'Tan ', 'Kan ', 'Pi ', 'Zuo ', 'Keng ', 'Bi ', 'Xing ', 'Di ', 'Jing ', 'Ji ', 'Kuai ', 'Di ', 'Jing ', 'Jian ', 'Tan ', 'Li ', 'Ba ', 'Wu ', 'Fen ', 'Zhui ', 'Po ', 'Pan ', 'Tang ', 'Kun ', 'Qu ', 'Tan ', 'Zhi ', 'Tuo ', 'Gan ', 'Ping ', 'Dian ', 'Gua ', 'Ni ', 'Tai ', 'Pi ', 'Jiong ', 'Yang ', 'Fo ', 'Ao ', 'Liu ', 'Qiu ', 'Mu ', 'Ke ', 'Gou ', 'Xue ', 'Ba ', 'Chi ', 'Che ', 'Ling ', 'Zhu ', 'Fu ', 'Hu ', 'Zhi ', 'Chui ', 'La ', 'Long ', 'Long ', 'Lu ', 'Ao ', 'Tay ', 'Pao ', '[?] ', 'Xing ', 'Dong ', 'Ji ', 'Ke ', 'Lu ', 'Ci ', 'Chi ', 'Lei ', 'Gai ', 'Yin ', 'Hou ', 'Dui ', 'Zhao ', 'Fu ', 'Guang ', 'Yao ', 'Duo ', 'Duo ', 'Gui ', 'Cha ', 'Yang ', 'Yin ', 'Fa ', 'Gou ', 'Yuan ', 'Die ', 'Xie ', 'Ken ', 'Jiong ', 'Shou ', 'E ', 'Ha ', 'Dian ', 'Hong ', 'Wu ', 'Kua ', '[?] ', 'Tao ', 'Dang ', 'Kai ', 'Gake ', 'Nao ', 'An ', 'Xing ', 'Xian ', 'Huan ', 'Bang ', 'Pei ', 'Ba ', 'Yi ', 'Yin ', 'Han ', 'Xu ', 'Chui ', 'Cen ', 'Geng ', 'Ai ', 'Peng ', 'Fang ', 'Que ', 'Yong ', 'Xun ', 'Jia ', 'Di ', 'Mai ', 'Lang ', 'Xuan ', 'Cheng ', 'Yan ', 'Jin ', 'Zhe ', 'Lei ', 'Lie ', 'Bu ', 'Cheng ', 'Gomi ', 'Bu ', 'Shi ', 'Xun ', 'Guo ', 'Jiong ', 'Ye ', 'Nian ', 'Di ', 'Yu ', 'Bu ', 'Ya ', 'Juan ', 'Sui ', 'Pi ', 'Cheng ', 'Wan ', 'Ju ', 'Lun ', 'Zheng ', 'Kong ', 'Chong ', 'Dong ', 'Dai ', 'Tan ', 'An ', 'Cai ', 'Shu ', 'Beng ', 'Kan ', 'Zhi ', 'Duo ', 'Yi ', 'Zhi ', 'Yi ', 'Pei ', 'Ji ', 'Zhun ', 'Qi ', 'Sao ', 'Ju ', 'Ni ']


Joomla CMS: Référence du fichier PatternAccuracyDescriptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier PatternAccuracyDescriptor.php

Structures de données

class PatternAccuracyDescriptor

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier TagTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier TagTable.php

Structures de données

class TagTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Table


Joomla CMS: Référence du fichier RouteNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • router
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/router/src/Exception/RouteNotFoundException.php

Structures de données

class RouteNotFoundException

Espaces de nommage

Joomla\Router\Exception


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_login
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_login/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier P2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Ge/P2.php

Structures de données

class P2

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519\Ge


Joomla CMS: Référence du fichier PrivacyComponent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier PrivacyComponent.php

Structures de données

class PrivacyComponent

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Extension


Joomla CMS: Référence du fichier Serializer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Request
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Request/Serializer.php

Structures de données

class Serializer

Espaces de nommage

Laminas\Diactoros\Request


Joomla CMS: Référence du fichier PublicKeyCredentialCreationOptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialCreationOptions.php

Structures de données

class PublicKeyCredentialCreationOptions

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier OverridesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_languages
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_languages/src/Controller/OverridesController.php

Structures de données

class OverridesController

Espaces de nommage

Joomla\API
Joomla\Component\Languages\Api\Controller


Joomla CMS: Référence du fichier render.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_fields
  • layouts
  • field
Espaces de nommage | Variables
Référence du fichier com_fields/layouts/field/render.php

Espaces de nommage

Joomla\Site

Variables

if(!array_key_exists('field', $displayData)) | $field = $displayData['field']
$label = Text::_($field->label)
$value = $field->value
$showLabel = $field->params->get('showlabel')
$prefix = Text::plural($field->params->get('prefix'), $value)
$suffix = Text::plural($field->params->get('suffix'), $value)
$labelClass = $field->params->get('label_render_class')
$valueClass = $field->params->get('value_render_class')
if($value=='') | if ( $showLabel==1)
endif

Documentation des variables

◆ $field

if (!array_key_exists( 'field', $displayData)) $field = $displayData['field']

◆ $label

$label = Text::_($field->label)

◆ $labelClass

$labelClass = $field->params->get('label_render_class')

◆ $prefix

$prefix = Text::plural($field->params->get('prefix'), $value)

◆ $showLabel

$showLabel = $field->params->get('showlabel')

◆ $suffix

$suffix = Text::plural($field->params->get('suffix'), $value)

Référencé par CodePointString\append(), UnicodeString\append(), ByteString\append(), Number\bytes(), CodePointString\endsWith(), UnicodeString\endsWith(), ByteString\endsWith(), AbstractString\endsWith(), Assert\endsWith(), AbstractString\ensureEnd(), JavascriptRenderer\getAddDatasetCode(), MVCFactory\getClassName(), InstallerHelper\getDownloadKey(), FileLayout\getPath(), Propel2Collector\getStatements(), Version\getUserAgent(), Assert\notEndsWith(), SiteRouter\parseFormat(), Text\plural(), EnglishInflector\pluralize(), Query\processString(), JavascriptRenderer\render(), HtmlDumper\setDumpBoundaries(), EnglishInflector\singularize(), El\stem(), AbstractUnicodeString\trimSuffix(), AbstractString\trimSuffix(), et FormatterHelper\truncate().

◆ $value

$value = $field->value

◆ $valueClass

$valueClass = $field->params->get('value_render_class')

◆ endif

endif

◆ if

if ( $value=='') if($showLabel==1)


Joomla CMS: Référence du fichier TraceStub.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier TraceStub.php

Structures de données

class TraceStub

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Sequence.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier Sequence.php

Structures de données

class Sequence

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier rating.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • vote
  • tmpl
Espaces de nommage | Variables
Référence du fichier rating.php

Espaces de nommage

Joomla\Plugin

Variables

$wa = $this->app->getDocument()->getWebAssetManager()
if($context==='com_content.categories') | $iconStar = HTMLHelper::_('image', 'plg_content_vote/vote-star.svg', '', '', true, true)
$iconHalfstar = HTMLHelper::_('image', 'plg_content_vote/vote-star-half.svg', '', '', true, true)
if($iconStar===null|| $iconHalfstar===null) | $pathStar = JPATH_ROOT . substr($iconStar, strlen(Uri::root(true)))
$pathHalfstar = JPATH_ROOT . substr($iconHalfstar, strlen(Uri::root(true)))
$star = file_exists($pathStar) ? file_get_contents($pathStar) : ''
$halfstar = file_exists($pathHalfstar) ? file_get_contents($pathHalfstar) : ''
$rating = (float) $row->rating
$rcount = (int) $row->rating_count
$stars = $rating
$img = ''
for($i=0; $i< floor($stars); $i++) if(($stars - floor($stars)) >=0.5) | for ( $i=$stars;$i< 5;$i++)
endif

Documentation des variables

◆ $halfstar

$halfstar = file_exists($pathHalfstar) ? file_get_contents($pathHalfstar) : ''

◆ $iconHalfstar

$iconHalfstar = HTMLHelper::_('image', 'plg_content_vote/vote-star-half.svg', '', '', true, true)

◆ $iconStar

if ( $context==='com_content.categories') $iconStar = HTMLHelper::_('image', 'plg_content_vote/vote-star.svg', '', '', true, true)

◆ $img

$img = ''

◆ $pathHalfstar

$pathHalfstar = JPATH_ROOT . substr($iconHalfstar, strlen(Uri::root(true)))

◆ $pathStar

if ( $iconStar===null||$iconHalfstar===null) $pathStar = JPATH_ROOT . substr($iconStar, strlen(Uri::root(true)))

◆ $rating

$rating = (float) $row->rating

Référencé par ArticleModel\storeVote().

◆ $rcount

$rcount = (int) $row->rating_count

◆ $star

$star = file_exists($pathStar) ? file_get_contents($pathStar) : ''

Référencé par MenuType\delete().

◆ $stars

$stars = $rating

◆ $wa

$wa = $this->app->getDocument()->getWebAssetManager()

◆ endif

endif

◆ for

for ( $i=0;$i< floor( $stars);$i++) if (( $stars - floor( $stars)) >=0.5) for($i=$stars; $i< 5; $i++)


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Service


Joomla CMS: Référence du fichier WebAssetRegistry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • WebAsset
Structures de données | Espaces de nommage
Référence du fichier WebAsset/WebAssetRegistry.php

Structures de données

class WebAssetRegistry

Espaces de nommage

Joomla\CMS\WebAsset


Joomla CMS: Référence du fichier select.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • tmpl
  • captive
Espaces de nommage | Variables
Référence du fichier administrator/components/com_users/tmpl/captive/select.php

Espaces de nommage

Joomla\Administrator

Variables

$shownMethods = []
foreach( $this->records as $record)(!array_key_exists($record->method, $this->mfaMethods) &&($record->method !='backupcodes')) | $allowEntryBatching = isset($this->mfaMethods[$record->method]) ? $this->mfaMethods[$record->method]['allowEntryBatching'] : false
if($this->allowEntryBatching) | $methodName = $this->getModel()->translateMethodName($record->method)

Documentation des variables

◆ $allowEntryBatching

foreach ($this->records as $record) (!array_key_exists( $record->method, $this->mfaMethods) &&( $record->method !='backupcodes')) $allowEntryBatching = isset($this->mfaMethods[$record->method]) ? $this->mfaMethods[$record->method]['allowEntryBatching'] : false

◆ $methodName

if ( $this->allowEntryBatching) $methodName = $this->getModel()->translateMethodName($record->method)

Référencé par AssertionChain\__call(), DataShapeObject\__get(), DataShapeObject\__isset(), DataShapeObject\__set(), TranscodeUnicode\convert(), UndefinedMethodErrorEnhancer\enhance(), AbstractEvent\getArgument(), SysinfoModel\getSafeData(), CMSPlugin\registerLegacyListener(), CMSPlugin\registerListener(), ApplicationModel\sendTestMail(), AbstractEvent\setArgument(), et Joomla\Component\Scheduler\Administrator\Traits\standardRoutineHandler().

◆ $shownMethods

$shownMethods = []


Joomla CMS: Référence du fichier TextView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • View
  • Sysinfo
Structures de données | Espaces de nommage
Référence du fichier TextView.php

Structures de données

class TextView

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\View\Sysinfo


Joomla CMS: Référence du fichier SipHash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/SipHash.php

Structures de données

class SipHash

Espaces de nommage

ParagonIE\Sodium\Core


Joomla CMS: Référence du fichier VcfView.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • View
  • Contact
Structures de données | Espaces de nommage
Référence du fichier VcfView.php

Structures de données

class VcfView

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\View\Contact


Joomla CMS: Référence du fichier SuggestionsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier SuggestionsModel.php

Structures de données

class SuggestionsModel

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Model


Joomla CMS: Référence du fichier TraceableTwigTemplate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • Twig
Structures de données | Espaces de nommage
Référence du fichier TraceableTwigTemplate.php

Structures de données

class TraceableTwigTemplate

Espaces de nommage

DebugBar\Bridge\Twig


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier UpdateController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier com_joomlaupdate/src/Controller/UpdateController.php

Structures de données

class UpdateController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\Controller


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_cache
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_cache/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier TermsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • terms
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TermsField.php

Structures de données

class TermsField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\User\Terms\Field


Joomla CMS: Référence du fichier selfupdate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • tmpl
  • joomlaupdate
Espaces de nommage | Variables
Référence du fichier selfupdate.php

Espaces de nommage

Joomla\Administrator

Variables

$displayData

Documentation des variables

◆ $displayData

$displayData
Valeur initiale :
= [
'textPrefix' => 'COM_JOOMLAUPDATE_SELF'


Joomla CMS: Référence du fichier RequestsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_privacy/src/Controller/RequestsController.php

Structures de données

class RequestsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Controller


Joomla CMS: Référence du fichier x083.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x083.php

Variables

return ['Fu ', 'Zhuo ', 'Mao ', 'Fan ', 'Qie ', 'Mao ', 'Mao ', 'Ba ', 'Zi ', 'Mo ', 'Zi ', 'Di ', 'Chi ', 'Ji ', 'Jing ', 'Long ', '[?] ', 'Niao ', '[?] ', 'Xue ', 'Ying ', 'Qiong ', 'Ge ', 'Ming ', 'Li ', 'Rong ', 'Yin ', 'Gen ', 'Qian ', 'Chai ', 'Chen ', 'Yu ', 'Xiu ', 'Zi ', 'Lie ', 'Wu ', 'Ji ', 'Kui ', 'Ce ', 'Chong ', 'Ci ', 'Gou ', 'Guang ', 'Mang ', 'Chi ', 'Jiao ', 'Jiao ', 'Fu ', 'Yu ', 'Zhu ', 'Zi ', 'Jiang ', 'Hui ', 'Yin ', 'Cha ', 'Fa ', 'Rong ', 'Ru ', 'Chong ', 'Mang ', 'Tong ', 'Zhong ', '[?] ', 'Zhu ', 'Xun ', 'Huan ', 'Kua ', 'Quan ', 'Gai ', 'Da ', 'Jing ', 'Xing ', 'Quan ', 'Cao ', 'Jing ', 'Er ', 'An ', 'Shou ', 'Chi ', 'Ren ', 'Jian ', 'Ti ', 'Huang ', 'Ping ', 'Li ', 'Jin ', 'Lao ', 'Shu ', 'Zhuang ', 'Da ', 'Jia ', 'Rao ', 'Bi ', 'Ze ', 'Qiao ', 'Hui ', 'Qi ', 'Dang ', '[?] ', 'Rong ', 'Hun ', 'Ying ', 'Luo ', 'Ying ', 'Xun ', 'Jin ', 'Sun ', 'Yin ', 'Mai ', 'Hong ', 'Zhou ', 'Yao ', 'Du ', 'Wei ', 'Chu ', 'Dou ', 'Fu ', 'Ren ', 'Yin ', 'He ', 'Bi ', 'Bu ', 'Yun ', 'Di ', 'Tu ', 'Sui ', 'Sui ', 'Cheng ', 'Chen ', 'Wu ', 'Bie ', 'Xi ', 'Geng ', 'Li ', 'Fu ', 'Zhu ', 'Mo ', 'Li ', 'Zhuang ', 'Ji ', 'Duo ', 'Qiu ', 'Sha ', 'Suo ', 'Chen ', 'Feng ', 'Ju ', 'Mei ', 'Meng ', 'Xing ', 'Jing ', 'Che ', 'Xin ', 'Jun ', 'Yan ', 'Ting ', 'Diao ', 'Cuo ', 'Wan ', 'Han ', 'You ', 'Cuo ', 'Jia ', 'Wang ', 'You ', 'Niu ', 'Shao ', 'Xian ', 'Lang ', 'Fu ', 'E ', 'Mo ', 'Wen ', 'Jie ', 'Nan ', 'Mu ', 'Kan ', 'Lai ', 'Lian ', 'Shi ', 'Wo ', 'Usagi ', 'Lian ', 'Huo ', 'You ', 'Ying ', 'Ying ', 'Nuc ', 'Chun ', 'Mang ', 'Mang ', 'Ci ', 'Wan ', 'Jing ', 'Di ', 'Qu ', 'Dong ', 'Jian ', 'Zou ', 'Gu ', 'La ', 'Lu ', 'Ju ', 'Wei ', 'Jun ', 'Nie ', 'Kun ', 'He ', 'Pu ', 'Zi ', 'Gao ', 'Guo ', 'Fu ', 'Lun ', 'Chang ', 'Chou ', 'Song ', 'Chui ', 'Zhan ', 'Men ', 'Cai ', 'Ba ', 'Li ', 'Tu ', 'Bo ', 'Han ', 'Bao ', 'Qin ', 'Juan ', 'Xi ', 'Qin ', 'Di ', 'Jie ', 'Pu ', 'Dang ', 'Jin ', 'Zhao ', 'Tai ', 'Geng ', 'Hua ', 'Gu ', 'Ling ', 'Fei ', 'Jin ', 'An ', 'Wang ', 'Beng ', 'Zhou ', 'Yan ', 'Ju ', 'Jian ', 'Lin ', 'Tan ', 'Shu ', 'Tian ', 'Dao ']

Documentation des variables

◆ return

return[ 'Fu ', 'Zhuo ', 'Mao ', 'Fan ', 'Qie ', 'Mao ', 'Mao ', 'Ba ', 'Zi ', 'Mo ', 'Zi ', 'Di ', 'Chi ', 'Ji ', 'Jing ', 'Long ', '[?] ', 'Niao ', '[?] ', 'Xue ', 'Ying ', 'Qiong ', 'Ge ', 'Ming ', 'Li ', 'Rong ', 'Yin ', 'Gen ', 'Qian ', 'Chai ', 'Chen ', 'Yu ', 'Xiu ', 'Zi ', 'Lie ', 'Wu ', 'Ji ', 'Kui ', 'Ce ', 'Chong ', 'Ci ', 'Gou ', 'Guang ', 'Mang ', 'Chi ', 'Jiao ', 'Jiao ', 'Fu ', 'Yu ', 'Zhu ', 'Zi ', 'Jiang ', 'Hui ', 'Yin ', 'Cha ', 'Fa ', 'Rong ', 'Ru ', 'Chong ', 'Mang ', 'Tong ', 'Zhong ', '[?] ', 'Zhu ', 'Xun ', 'Huan ', 'Kua ', 'Quan ', 'Gai ', 'Da ', 'Jing ', 'Xing ', 'Quan ', 'Cao ', 'Jing ', 'Er ', 'An ', 'Shou ', 'Chi ', 'Ren ', 'Jian ', 'Ti ', 'Huang ', 'Ping ', 'Li ', 'Jin ', 'Lao ', 'Shu ', 'Zhuang ', 'Da ', 'Jia ', 'Rao ', 'Bi ', 'Ze ', 'Qiao ', 'Hui ', 'Qi ', 'Dang ', '[?] ', 'Rong ', 'Hun ', 'Ying ', 'Luo ', 'Ying ', 'Xun ', 'Jin ', 'Sun ', 'Yin ', 'Mai ', 'Hong ', 'Zhou ', 'Yao ', 'Du ', 'Wei ', 'Chu ', 'Dou ', 'Fu ', 'Ren ', 'Yin ', 'He ', 'Bi ', 'Bu ', 'Yun ', 'Di ', 'Tu ', 'Sui ', 'Sui ', 'Cheng ', 'Chen ', 'Wu ', 'Bie ', 'Xi ', 'Geng ', 'Li ', 'Fu ', 'Zhu ', 'Mo ', 'Li ', 'Zhuang ', 'Ji ', 'Duo ', 'Qiu ', 'Sha ', 'Suo ', 'Chen ', 'Feng ', 'Ju ', 'Mei ', 'Meng ', 'Xing ', 'Jing ', 'Che ', 'Xin ', 'Jun ', 'Yan ', 'Ting ', 'Diao ', 'Cuo ', 'Wan ', 'Han ', 'You ', 'Cuo ', 'Jia ', 'Wang ', 'You ', 'Niu ', 'Shao ', 'Xian ', 'Lang ', 'Fu ', 'E ', 'Mo ', 'Wen ', 'Jie ', 'Nan ', 'Mu ', 'Kan ', 'Lai ', 'Lian ', 'Shi ', 'Wo ', 'Usagi ', 'Lian ', 'Huo ', 'You ', 'Ying ', 'Ying ', 'Nuc ', 'Chun ', 'Mang ', 'Mang ', 'Ci ', 'Wan ', 'Jing ', 'Di ', 'Qu ', 'Dong ', 'Jian ', 'Zou ', 'Gu ', 'La ', 'Lu ', 'Ju ', 'Wei ', 'Jun ', 'Nie ', 'Kun ', 'He ', 'Pu ', 'Zi ', 'Gao ', 'Guo ', 'Fu ', 'Lun ', 'Chang ', 'Chou ', 'Song ', 'Chui ', 'Zhan ', 'Men ', 'Cai ', 'Ba ', 'Li ', 'Tu ', 'Bo ', 'Han ', 'Bao ', 'Qin ', 'Juan ', 'Xi ', 'Qin ', 'Di ', 'Jie ', 'Pu ', 'Dang ', 'Jin ', 'Zhao ', 'Tai ', 'Geng ', 'Hua ', 'Gu ', 'Ling ', 'Fei ', 'Jin ', 'An ', 'Wang ', 'Beng ', 'Zhou ', 'Yan ', 'Ju ', 'Jian ', 'Lin ', 'Tan ', 'Shu ', 'Tian ', 'Dao ']


Joomla CMS: Référence du fichier TimezoneField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier TimezoneField.php

Structures de données

class TimezoneField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier ProtectedKeyException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • di
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ProtectedKeyException.php

Structures de données

class ProtectedKeyException

Espaces de nommage

Joomla\DI\Exception


Joomla CMS: Référence du fichier secp160r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp160r1.php

Structures de données

class secp160r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier PackageField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PackageField.php

Structures de données

class PackageField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Field


Joomla CMS: Référence du fichier TransportInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Http
Structures de données | Espaces de nommage
Référence du fichier src/Http/TransportInterface.php

Structures de données

interface TransportInterface

Espaces de nommage

Joomla\CMS\Http


Joomla CMS: Référence du fichier Socket.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
  • RequestMethod
Structures de données | Espaces de nommage
Référence du fichier google/recaptcha/src/ReCaptcha/RequestMethod/Socket.php

Structures de données

class Socket

Espaces de nommage

ReCaptcha\RequestMethod


Joomla CMS: Référence du fichier SqlsrvDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlsrv
Espaces de nommage
Référence du fichier SqlsrvDriver.php

Espaces de nommage

Joomla\Database\Sqlsrv


Joomla CMS: Référence du fichier readmore.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors-xtd
  • readmore
Structures de données | Espaces de nommage
Référence du fichier plugins/editors-xtd/readmore/readmore.php

Structures de données

class PlgButtonReadmore

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier VerificationMethodANDCombinations.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier VerificationMethodANDCombinations.php

Structures de données

class VerificationMethodANDCombinations

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier x00e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Référence du fichier x00e.php


Joomla CMS: Référence du fichier Raw.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/Raw.php

Structures de données

class Raw

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier validation.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions
Référence du fichier validation.php

Espaces de nommage

utf8

Fonctions

utf8_is_valid ($str)
utf8_compliant ($str)

Documentation des fonctions

◆ utf8_compliant()

utf8_compliant ( $str )

Référencé par StringHelper\compliant().

◆ utf8_is_valid()

utf8_is_valid ( $str )

End of the multi-octet sequence. mUcs4 now contains the final Unicode codepoint to be output

((0xC0 & (*in) != 0x80) && (mState != 0)) Incomplete multi-octet sequence.

Références $i, et $tmp.

Référencé par StringHelper\valid().


Joomla CMS: Référence du fichier render.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • layouts
  • fields
Espaces de nommage | Variables
Référence du fichier com_contact/layouts/fields/render.php

Espaces de nommage

Joomla\Site

Variables

if(!array_key_exists('item', $displayData)||!array_key_exists('context', $displayData)) | $item = $displayData['item']
if(! $item) | $context = $displayData['context']
if(! $context) | $parts = explode('.', $context)
$component = $parts[0]
$fields = null
if(array_key_exists('fields', $displayData)) | else
if(! $fields) | $isMail = (reset($fields)->context == 'com_contact.mail')

Documentation des variables

◆ $component

$component = $parts[0]

◆ $context

if (! $item) $context = $displayData['context']

◆ $fields

$fields = null

◆ $isMail

if (! $fields) $isMail = (reset($fields)->context == 'com_contact.mail')

◆ $item

if (!array_key_exists( 'item', $displayData)||!array_key_exists( 'context', $displayData)) $item = $displayData['item']

◆ $parts

if (! $context) $parts = explode('.', $context)

◆ else

if (array_key_exists( 'fields', $displayData)) else
Valeur initiale :
{
$fields = $item->jcfields ?: FieldsHelper::getFields($context, $item, true)
$fields
$fields
Definition: com_contact/layouts/fields/render.php:35
$item
if(!array_key_exists('item', $displayData)||!array_key_exists('context', $displayData)) $item
Definition: com_contact/layouts/fields/render.php:21
Joomla\Component\Fields\Administrator\Helper\FieldsHelper\getFields
static getFields( $context, $item=null, $prepareValue=false, array $valuesToOverride=null, bool $includeSubformFields=false)
Definition: FieldsHelper.php:101
$context
if(! $item) $context
Definition: com_contact/layouts/fields/render.php:27


Joomla CMS: Référence du fichier WorkflowTransitionEvent.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier WorkflowTransitionEvent.php

Structures de données

class WorkflowTransitionEvent

Espaces de nommage

Joomla\CMS\Event\Workflow


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_workflow/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier TagInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • data
Structures de données | Espaces de nommage
Référence du fichier TagInterface.php

Structures de données

interface TagInterface

Espaces de nommage

enshrined\svgSanitize\data
enshrined


Joomla CMS: Référence du fichier Sha384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Hmac
Structures de données | Espaces de nommage
Référence du fichier Hmac/Sha384.php

Structures de données

class Sha384

Espaces de nommage

Lcobucci\JWT\Signer\Hmac


Joomla CMS: Référence du fichier PunycodeInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • algo26-matthias
  • idna-convert
  • src
  • Punycode
Structures de données | Espaces de nommage
Référence du fichier PunycodeInterface.php

Structures de données

interface PunycodeInterface

Espaces de nommage

Algo26\IdnaConvert\Punycode


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • cache
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/system/cache/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RequestParameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
Structures de données | Espaces de nommage
Référence du fichier RequestParameters.php

Structures de données

class RequestParameters

Espaces de nommage

ReCaptcha


Joomla CMS: Référence du fichier script.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
Structures de données | Espaces de nommage
Référence du fichier script.php

Structures de données

class JoomlaInstallerScript

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier PageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Controller
Structures de données | Espaces de nommage
Référence du fichier PageController.php

Structures de données

class PageController

Espaces de nommage

Joomla\CMS\Cache\Controller


Joomla CMS: Référence du fichier readmore.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • content
Espaces de nommage | Variables
Référence du fichier layouts/joomla/content/readmore.php

Espaces de nommage

Joomla\Site

Variables

$params = $displayData['params']
$item = $displayData['item']
$direction = Factory::getLanguage()->isRtl() ? 'left' : 'right'
if (! $params->get( 'access-view'))
elseif ( $readmore=$item->alternative_readmore)
endif
else __pad7__

Documentation des variables

◆ $direction

$direction = Factory::getLanguage()->isRtl() ? 'left' : 'right'

◆ $item

$item = $displayData['item']

◆ $params

$params = $displayData['params']

◆ __pad7__

else __pad7__

◆ elseif

elseif($params->get('show_readmore_title', 0)==0) ( $readmore = $item->alternative_readmore )

◆ endif

endif

◆ if

if(! $params->get('access-view'))


Joomla CMS: Référence du fichier Precomp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • namespaced
  • Core
  • Curve25519
  • Ge
Structures de données | Espaces de nommage
Référence du fichier namespaced/Core/Curve25519/Ge/Precomp.php

Structures de données

class Precomp

Espaces de nommage

ParagonIE\Sodium\Core\Curve25519\Ge


Joomla CMS: Référence du fichier SiteTemplateTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • View
Espaces de nommage
Référence du fichier SiteTemplateTrait.php

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\View


Joomla CMS: Référence du fichier UniqueidField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier UniqueidField.php

Structures de données

class UniqueidField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Stats\Field


Joomla CMS: Référence du fichier UsersLatestHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_users_latest
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier UsersLatestHelper.php

Structures de données

class UsersLatestHelper

Espaces de nommage

Joomla\Site
Joomla\Module\UsersLatest\Site\Helper


Joomla CMS: Référence du fichier Server.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/system/webauthn/src/Hotfix/Server.php

Structures de données

class Server

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\Hotfix


Joomla CMS: Référence du fichier SubscribedService.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
  • Attribute
Structures de données | Espaces de nommage
Référence du fichier SubscribedService.php

Structures de données

class SubscribedService

Espaces de nommage

Symfony\Contracts\Service\Attribute


Joomla CMS: Référence du fichier Random.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier Random.php

Structures de données

class Random

Espaces de nommage

Random
phpseclib3\Crypt


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/Common/PublicKey.php

Structures de données

interface PublicKey

Espaces de nommage

Common
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier SqliteDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlite
Structures de données | Espaces de nommage
Référence du fichier SqliteDriver.php

Structures de données

class SqliteDriver

Espaces de nommage

Joomla\Database\Sqlite


Joomla CMS: Référence du fichier PropelCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
Structures de données | Espaces de nommage
Référence du fichier PropelCollector.php

Structures de données

class PropelCollector

Espaces de nommage

DebugBar\Bridge


Joomla CMS: Référence du fichier TrimmedBufferOutput.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Output
Structures de données | Espaces de nommage
Référence du fichier TrimmedBufferOutput.php

Structures de données

class TrimmedBufferOutput

Espaces de nommage

Symfony\Component\Console\Output


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • actionlog
  • joomla
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/actionlog/joomla/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • French
Structures de données | Espaces de nommage
Référence du fichier French/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\French


Joomla CMS: Référence du fichier RewriteRules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-zendframework-bridge
  • src
Structures de données | Espaces de nommage
Référence du fichier RewriteRules.php

Structures de données

class RewriteRules

Espaces de nommage

Laminas\ZendFrameworkBridge


Joomla CMS: Référence du fichier users.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • helpers
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/helpers/users.php

Structures de données

class UsersHelper

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier UndefinedMethodError.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Error
Structures de données | Espaces de nommage
Référence du fichier UndefinedMethodError.php

Structures de données

class UndefinedMethodError

Espaces de nommage

Symfony\Component\ErrorHandler\Error


Joomla CMS: Référence du fichier WorkflowsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier WorkflowsController.php

Structures de données

class WorkflowsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier SqlsrvChangeItem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Schema
  • ChangeItem
Structures de données | Espaces de nommage
Référence du fichier SqlsrvChangeItem.php

Structures de données

class SqlsrvChangeItem

Espaces de nommage

Joomla\CMS\Schema\ChangeItem


Joomla CMS: Référence du fichier x08c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08c.php

Variables

return ['Yu ', 'Shui ', 'Shen ', 'Diao ', 'Chan ', 'Liang ', 'Zhun ', 'Sui ', 'Tan ', 'Shen ', 'Yi ', 'Mou ', 'Chen ', 'Die ', 'Huang ', 'Jian ', 'Xie ', 'Nue ', 'Ye ', 'Wei ', 'E ', 'Yu ', 'Xuan ', 'Chan ', 'Zi ', 'An ', 'Yan ', 'Di ', 'Mi ', 'Pian ', 'Xu ', 'Mo ', 'Dang ', 'Su ', 'Xie ', 'Yao ', 'Bang ', 'Shi ', 'Qian ', 'Mi ', 'Jin ', 'Man ', 'Zhe ', 'Jian ', 'Miu ', 'Tan ', 'Zen ', 'Qiao ', 'Lan ', 'Pu ', 'Jue ', 'Yan ', 'Qian ', 'Zhan ', 'Chen ', 'Gu ', 'Qian ', 'Hong ', 'Xia ', 'Jue ', 'Hong ', 'Han ', 'Hong ', 'Xi ', 'Xi ', 'Huo ', 'Liao ', 'Han ', 'Du ', 'Long ', 'Dou ', 'Jiang ', 'Qi ', 'Shi ', 'Li ', 'Deng ', 'Wan ', 'Bi ', 'Shu ', 'Xian ', 'Feng ', 'Zhi ', 'Zhi ', 'Yan ', 'Yan ', 'Shi ', 'Chu ', 'Hui ', 'Tun ', 'Yi ', 'Tun ', 'Yi ', 'Jian ', 'Ba ', 'Hou ', 'E ', 'Cu ', 'Xiang ', 'Huan ', 'Jian ', 'Ken ', 'Gai ', 'Qu ', 'Fu ', 'Xi ', 'Bin ', 'Hao ', 'Yu ', 'Zhu ', 'Jia ', '[?] ', 'Xi ', 'Bo ', 'Wen ', 'Huan ', 'Bin ', 'Di ', 'Zong ', 'Fen ', 'Yi ', 'Zhi ', 'Bao ', 'Chai ', 'Han ', 'Pi ', 'Na ', 'Pi ', 'Gou ', 'Na ', 'You ', 'Diao ', 'Mo ', 'Si ', 'Xiu ', 'Huan ', 'Kun ', 'He ', 'He ', 'Mo ', 'Han ', 'Mao ', 'Li ', 'Ni ', 'Bi ', 'Yu ', 'Jia ', 'Tuan ', 'Mao ', 'Pi ', 'Xi ', 'E ', 'Ju ', 'Mo ', 'Chu ', 'Tan ', 'Huan ', 'Jue ', 'Bei ', 'Zhen ', 'Yuan ', 'Fu ', 'Cai ', 'Gong ', 'Te ', 'Yi ', 'Hang ', 'Wan ', 'Pin ', 'Huo ', 'Fan ', 'Tan ', 'Guan ', 'Ze ', 'Zhi ', 'Er ', 'Zhu ', 'Shi ', 'Bi ', 'Zi ', 'Er ', 'Gui ', 'Pian ', 'Bian ', 'Mai ', 'Dai ', 'Sheng ', 'Kuang ', 'Fei ', 'Tie ', 'Yi ', 'Chi ', 'Mao ', 'He ', 'Bi ', 'Lu ', 'Ren ', 'Hui ', 'Gai ', 'Pian ', 'Zi ', 'Jia ', 'Xu ', 'Zei ', 'Jiao ', 'Gai ', 'Zang ', 'Jian ', 'Ying ', 'Xun ', 'Zhen ', 'She ', 'Bin ', 'Bin ', 'Qiu ', 'She ', 'Chuan ', 'Zang ', 'Zhou ', 'Lai ', 'Zan ', 'Si ', 'Chen ', 'Shang ', 'Tian ', 'Pei ', 'Geng ', 'Xian ', 'Mai ', 'Jian ', 'Sui ', 'Fu ', 'Tan ', 'Cong ', 'Cong ', 'Zhi ', 'Ji ', 'Zhang ', 'Du ', 'Jin ', 'Xiong ', 'Shun ', 'Yun ', 'Bao ', 'Zai ', 'Lai ', 'Feng ', 'Cang ', 'Ji ', 'Sheng ', 'Ai ', 'Zhuan ', 'Fu ', 'Gou ', 'Sai ', 'Ze ', 'Liao ']

Documentation des variables

◆ return

return[ 'Yu ', 'Shui ', 'Shen ', 'Diao ', 'Chan ', 'Liang ', 'Zhun ', 'Sui ', 'Tan ', 'Shen ', 'Yi ', 'Mou ', 'Chen ', 'Die ', 'Huang ', 'Jian ', 'Xie ', 'Nue ', 'Ye ', 'Wei ', 'E ', 'Yu ', 'Xuan ', 'Chan ', 'Zi ', 'An ', 'Yan ', 'Di ', 'Mi ', 'Pian ', 'Xu ', 'Mo ', 'Dang ', 'Su ', 'Xie ', 'Yao ', 'Bang ', 'Shi ', 'Qian ', 'Mi ', 'Jin ', 'Man ', 'Zhe ', 'Jian ', 'Miu ', 'Tan ', 'Zen ', 'Qiao ', 'Lan ', 'Pu ', 'Jue ', 'Yan ', 'Qian ', 'Zhan ', 'Chen ', 'Gu ', 'Qian ', 'Hong ', 'Xia ', 'Jue ', 'Hong ', 'Han ', 'Hong ', 'Xi ', 'Xi ', 'Huo ', 'Liao ', 'Han ', 'Du ', 'Long ', 'Dou ', 'Jiang ', 'Qi ', 'Shi ', 'Li ', 'Deng ', 'Wan ', 'Bi ', 'Shu ', 'Xian ', 'Feng ', 'Zhi ', 'Zhi ', 'Yan ', 'Yan ', 'Shi ', 'Chu ', 'Hui ', 'Tun ', 'Yi ', 'Tun ', 'Yi ', 'Jian ', 'Ba ', 'Hou ', 'E ', 'Cu ', 'Xiang ', 'Huan ', 'Jian ', 'Ken ', 'Gai ', 'Qu ', 'Fu ', 'Xi ', 'Bin ', 'Hao ', 'Yu ', 'Zhu ', 'Jia ', '[?] ', 'Xi ', 'Bo ', 'Wen ', 'Huan ', 'Bin ', 'Di ', 'Zong ', 'Fen ', 'Yi ', 'Zhi ', 'Bao ', 'Chai ', 'Han ', 'Pi ', 'Na ', 'Pi ', 'Gou ', 'Na ', 'You ', 'Diao ', 'Mo ', 'Si ', 'Xiu ', 'Huan ', 'Kun ', 'He ', 'He ', 'Mo ', 'Han ', 'Mao ', 'Li ', 'Ni ', 'Bi ', 'Yu ', 'Jia ', 'Tuan ', 'Mao ', 'Pi ', 'Xi ', 'E ', 'Ju ', 'Mo ', 'Chu ', 'Tan ', 'Huan ', 'Jue ', 'Bei ', 'Zhen ', 'Yuan ', 'Fu ', 'Cai ', 'Gong ', 'Te ', 'Yi ', 'Hang ', 'Wan ', 'Pin ', 'Huo ', 'Fan ', 'Tan ', 'Guan ', 'Ze ', 'Zhi ', 'Er ', 'Zhu ', 'Shi ', 'Bi ', 'Zi ', 'Er ', 'Gui ', 'Pian ', 'Bian ', 'Mai ', 'Dai ', 'Sheng ', 'Kuang ', 'Fei ', 'Tie ', 'Yi ', 'Chi ', 'Mao ', 'He ', 'Bi ', 'Lu ', 'Ren ', 'Hui ', 'Gai ', 'Pian ', 'Zi ', 'Jia ', 'Xu ', 'Zei ', 'Jiao ', 'Gai ', 'Zang ', 'Jian ', 'Ying ', 'Xun ', 'Zhen ', 'She ', 'Bin ', 'Bin ', 'Qiu ', 'She ', 'Chuan ', 'Zang ', 'Zhou ', 'Lai ', 'Zan ', 'Si ', 'Chen ', 'Shang ', 'Tian ', 'Pei ', 'Geng ', 'Xian ', 'Mai ', 'Jian ', 'Sui ', 'Fu ', 'Tan ', 'Cong ', 'Cong ', 'Zhi ', 'Ji ', 'Zhang ', 'Du ', 'Jin ', 'Xiong ', 'Shun ', 'Yun ', 'Bao ', 'Zai ', 'Lai ', 'Feng ', 'Cang ', 'Ji ', 'Sheng ', 'Ai ', 'Zhuan ', 'Fu ', 'Gou ', 'Sai ', 'Ze ', 'Liao ']


Joomla CMS: Référence du fichier TentativeTypes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Internal
Structures de données | Espaces de nommage
Référence du fichier TentativeTypes.php

Structures de données

class TentativeTypes

Espaces de nommage

Symfony\Component\ErrorHandler\Internal


Joomla CMS: Référence du fichier WincacheHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
  • Handler
Structures de données | Espaces de nommage
Référence du fichier WincacheHandler.php

Structures de données

class WincacheHandler

Espaces de nommage

Joomla\Session\Handler


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • shortcut
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/system/shortcut/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier OverridesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_languages
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier OverridesModel.php

Structures de données

class OverridesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Languages\Administrator\Model


Joomla CMS: Référence du fichier sect193r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect193r2.php

Structures de données

class sect193r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier TagServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier TagServiceInterface.php

Structures de données

interface TagServiceInterface

Espaces de nommage

Joomla\CMS\Tag


Joomla CMS: Référence du fichier x05c.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05c.php

Variables

return ['Po ', 'Feng ', 'Zhuan ', 'Fu ', 'She ', 'Ke ', 'Jiang ', 'Jiang ', 'Zhuan ', 'Wei ', 'Zun ', 'Xun ', 'Shu ', 'Dui ', 'Dao ', 'Xiao ', 'Ji ', 'Shao ', 'Er ', 'Er ', 'Er ', 'Ga ', 'Jian ', 'Shu ', 'Chen ', 'Shang ', 'Shang ', 'Mo ', 'Ga ', 'Chang ', 'Liao ', 'Xian ', 'Xian ', '[?] ', 'Wang ', 'Wang ', 'You ', 'Liao ', 'Liao ', 'Yao ', 'Mang ', 'Wang ', 'Wang ', 'Wang ', 'Ga ', 'Yao ', 'Duo ', 'Kui ', 'Zhong ', 'Jiu ', 'Gan ', 'Gu ', 'Gan ', 'Tui ', 'Gan ', 'Gan ', 'Shi ', 'Yin ', 'Chi ', 'Kao ', 'Ni ', 'Jin ', 'Wei ', 'Niao ', 'Ju ', 'Pi ', 'Ceng ', 'Xi ', 'Bi ', 'Ju ', 'Jie ', 'Tian ', 'Qu ', 'Ti ', 'Jie ', 'Wu ', 'Diao ', 'Shi ', 'Shi ', 'Ping ', 'Ji ', 'Xie ', 'Chen ', 'Xi ', 'Ni ', 'Zhan ', 'Xi ', '[?] ', 'Man ', 'E ', 'Lou ', 'Ping ', 'Ti ', 'Fei ', 'Shu ', 'Xie ', 'Tu ', 'Lu ', 'Lu ', 'Xi ', 'Ceng ', 'Lu ', 'Ju ', 'Xie ', 'Ju ', 'Jue ', 'Liao ', 'Jue ', 'Shu ', 'Xi ', 'Che ', 'Tun ', 'Ni ', 'Shan ', '[?] ', 'Xian ', 'Li ', 'Xue ', 'Nata ', '[?] ', 'Long ', 'Yi ', 'Qi ', 'Ren ', 'Wu ', 'Han ', 'Shen ', 'Yu ', 'Chu ', 'Sui ', 'Qi ', '[?] ', 'Yue ', 'Ban ', 'Yao ', 'Ang ', 'Ya ', 'Wu ', 'Jie ', 'E ', 'Ji ', 'Qian ', 'Fen ', 'Yuan ', 'Qi ', 'Cen ', 'Qian ', 'Qi ', 'Cha ', 'Jie ', 'Qu ', 'Gang ', 'Xian ', 'Ao ', 'Lan ', 'Dao ', 'Ba ', 'Zuo ', 'Zuo ', 'Yang ', 'Ju ', 'Gang ', 'Ke ', 'Gou ', 'Xue ', 'Bei ', 'Li ', 'Tiao ', 'Ju ', 'Yan ', 'Fu ', 'Xiu ', 'Jia ', 'Ling ', 'Tuo ', 'Pei ', 'You ', 'Dai ', 'Kuang ', 'Yue ', 'Qu ', 'Hu ', 'Po ', 'Min ', 'An ', 'Tiao ', 'Ling ', 'Chi ', 'Yuri ', 'Dong ', 'Cem ', 'Kui ', 'Xiu ', 'Mao ', 'Tong ', 'Xue ', 'Yi ', 'Kura ', 'He ', 'Ke ', 'Luo ', 'E ', 'Fu ', 'Xun ', 'Die ', 'Lu ', 'An ', 'Er ', 'Gai ', 'Quan ', 'Tong ', 'Yi ', 'Mu ', 'Shi ', 'An ', 'Wei ', 'Hu ', 'Zhi ', 'Mi ', 'Li ', 'Ji ', 'Tong ', 'Wei ', 'You ', 'Sang ', 'Xia ', 'Li ', 'Yao ', 'Jiao ', 'Zheng ', 'Luan ', 'Jiao ', 'E ', 'E ', 'Yu ', 'Ye ', 'Bu ', 'Qiao ', 'Qun ', 'Feng ', 'Feng ', 'Nao ', 'Li ', 'You ', 'Xian ', 'Hong ', 'Dao ', 'Shen ', 'Cheng ', 'Tu ', 'Geng ', 'Jun ', 'Hao ', 'Xia ', 'Yin ', 'Yu ']

Documentation des variables

◆ return

return[ 'Po ', 'Feng ', 'Zhuan ', 'Fu ', 'She ', 'Ke ', 'Jiang ', 'Jiang ', 'Zhuan ', 'Wei ', 'Zun ', 'Xun ', 'Shu ', 'Dui ', 'Dao ', 'Xiao ', 'Ji ', 'Shao ', 'Er ', 'Er ', 'Er ', 'Ga ', 'Jian ', 'Shu ', 'Chen ', 'Shang ', 'Shang ', 'Mo ', 'Ga ', 'Chang ', 'Liao ', 'Xian ', 'Xian ', '[?] ', 'Wang ', 'Wang ', 'You ', 'Liao ', 'Liao ', 'Yao ', 'Mang ', 'Wang ', 'Wang ', 'Wang ', 'Ga ', 'Yao ', 'Duo ', 'Kui ', 'Zhong ', 'Jiu ', 'Gan ', 'Gu ', 'Gan ', 'Tui ', 'Gan ', 'Gan ', 'Shi ', 'Yin ', 'Chi ', 'Kao ', 'Ni ', 'Jin ', 'Wei ', 'Niao ', 'Ju ', 'Pi ', 'Ceng ', 'Xi ', 'Bi ', 'Ju ', 'Jie ', 'Tian ', 'Qu ', 'Ti ', 'Jie ', 'Wu ', 'Diao ', 'Shi ', 'Shi ', 'Ping ', 'Ji ', 'Xie ', 'Chen ', 'Xi ', 'Ni ', 'Zhan ', 'Xi ', '[?] ', 'Man ', 'E ', 'Lou ', 'Ping ', 'Ti ', 'Fei ', 'Shu ', 'Xie ', 'Tu ', 'Lu ', 'Lu ', 'Xi ', 'Ceng ', 'Lu ', 'Ju ', 'Xie ', 'Ju ', 'Jue ', 'Liao ', 'Jue ', 'Shu ', 'Xi ', 'Che ', 'Tun ', 'Ni ', 'Shan ', '[?] ', 'Xian ', 'Li ', 'Xue ', 'Nata ', '[?] ', 'Long ', 'Yi ', 'Qi ', 'Ren ', 'Wu ', 'Han ', 'Shen ', 'Yu ', 'Chu ', 'Sui ', 'Qi ', '[?] ', 'Yue ', 'Ban ', 'Yao ', 'Ang ', 'Ya ', 'Wu ', 'Jie ', 'E ', 'Ji ', 'Qian ', 'Fen ', 'Yuan ', 'Qi ', 'Cen ', 'Qian ', 'Qi ', 'Cha ', 'Jie ', 'Qu ', 'Gang ', 'Xian ', 'Ao ', 'Lan ', 'Dao ', 'Ba ', 'Zuo ', 'Zuo ', 'Yang ', 'Ju ', 'Gang ', 'Ke ', 'Gou ', 'Xue ', 'Bei ', 'Li ', 'Tiao ', 'Ju ', 'Yan ', 'Fu ', 'Xiu ', 'Jia ', 'Ling ', 'Tuo ', 'Pei ', 'You ', 'Dai ', 'Kuang ', 'Yue ', 'Qu ', 'Hu ', 'Po ', 'Min ', 'An ', 'Tiao ', 'Ling ', 'Chi ', 'Yuri ', 'Dong ', 'Cem ', 'Kui ', 'Xiu ', 'Mao ', 'Tong ', 'Xue ', 'Yi ', 'Kura ', 'He ', 'Ke ', 'Luo ', 'E ', 'Fu ', 'Xun ', 'Die ', 'Lu ', 'An ', 'Er ', 'Gai ', 'Quan ', 'Tong ', 'Yi ', 'Mu ', 'Shi ', 'An ', 'Wei ', 'Hu ', 'Zhi ', 'Mi ', 'Li ', 'Ji ', 'Tong ', 'Wei ', 'You ', 'Sang ', 'Xia ', 'Li ', 'Yao ', 'Jiao ', 'Zheng ', 'Luan ', 'Jiao ', 'E ', 'E ', 'Yu ', 'Ye ', 'Bu ', 'Qiao ', 'Qun ', 'Feng ', 'Feng ', 'Nao ', 'Li ', 'You ', 'Xian ', 'Hong ', 'Dao ', 'Shen ', 'Cheng ', 'Tu ', 'Geng ', 'Jun ', 'Hao ', 'Xia ', 'Yin ', 'Yu ']


Joomla CMS: Référence du fichier PBMAC1params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PBMAC1params.php

Structures de données

class PBMAC1params

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier Query.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_finder/src/Service/HTML/Query.php

Structures de données

class Query

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Service\HTML


Joomla CMS: Référence du fichier WebClient.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Web
Structures de données | Espaces de nommage
Référence du fichier WebClient.php

Structures de données

class WebClient

Espaces de nommage

Joomla\Application\Web


Joomla CMS: Référence du fichier Raw.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/Raw.php

Structures de données

class Raw

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys


Joomla CMS: Référence du fichier strcspn.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier strcspn.php

Espaces de nommage

utf8

Fonctions

utf8_strcspn ($str, $mask, $start=NULL, $length=NULL)

Documentation des fonctions

◆ utf8_strcspn()

utf8_strcspn | ( | $str,
 |  | $mask,
 |  | $start = NULL,
 |  | $length = NULL
 | ) |

Références $start, utf8_strlen(), et utf8_substr().

Référencé par StringHelper\strcspn().


Joomla CMS: Référence du fichier redirect.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • redirect
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/redirect/redirect.php

Structures de données

class PlgWebservicesRedirect

Espaces de nommage

Joomla\Redirect


Joomla CMS: Référence du fichier RelativeObjectIdentifier.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier RelativeObjectIdentifier.php

Structures de données

class RelativeObjectIdentifier

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier x068.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x068.php

Variables

return ['Zhi ', 'Liu ', 'Mei ', 'Hoy ', 'Rong ', 'Zha ', '[?] ', 'Biao ', 'Zhan ', 'Jie ', 'Long ', 'Dong ', 'Lu ', 'Sayng ', 'Li ', 'Lan ', 'Yong ', 'Shu ', 'Xun ', 'Shuan ', 'Qi ', 'Zhen ', 'Qi ', 'Li ', 'Yi ', 'Xiang ', 'Zhen ', 'Li ', 'Su ', 'Gua ', 'Kan ', 'Bing ', 'Ren ', 'Xiao ', 'Bo ', 'Ren ', 'Bing ', 'Zi ', 'Chou ', 'Yi ', 'Jie ', 'Xu ', 'Zhu ', 'Jian ', 'Zui ', 'Er ', 'Er ', 'You ', 'Fa ', 'Gong ', 'Kao ', 'Lao ', 'Zhan ', 'Li ', 'Yin ', 'Yang ', 'He ', 'Gen ', 'Zhi ', 'Chi ', 'Ge ', 'Zai ', 'Luan ', 'Fu ', 'Jie ', 'Hang ', 'Gui ', 'Tao ', 'Guang ', 'Wei ', 'Kuang ', 'Ru ', 'An ', 'An ', 'Juan ', 'Yi ', 'Zhuo ', 'Ku ', 'Zhi ', 'Qiong ', 'Tong ', 'Sang ', 'Sang ', 'Huan ', 'Jie ', 'Jiu ', 'Xue ', 'Duo ', 'Zhui ', 'Yu ', 'Zan ', 'Kasei ', 'Ying ', 'Masu ', '[?] ', 'Zhan ', 'Ya ', 'Nao ', 'Zhen ', 'Dang ', 'Qi ', 'Qiao ', 'Hua ', 'Kuai ', 'Jiang ', 'Zhuang ', 'Xun ', 'Suo ', 'Sha ', 'Zhen ', 'Bei ', 'Ting ', 'Gua ', 'Jing ', 'Bo ', 'Ben ', 'Fu ', 'Rui ', 'Tong ', 'Jue ', 'Xi ', 'Lang ', 'Liu ', 'Feng ', 'Qi ', 'Wen ', 'Jun ', 'Gan ', 'Cu ', 'Liang ', 'Qiu ', 'Ting ', 'You ', 'Mei ', 'Bang ', 'Long ', 'Peng ', 'Zhuang ', 'Di ', 'Xuan ', 'Tu ', 'Zao ', 'Ao ', 'Gu ', 'Bi ', 'Di ', 'Han ', 'Zi ', 'Zhi ', 'Ren ', 'Bei ', 'Geng ', 'Jian ', 'Huan ', 'Wan ', 'Nuo ', 'Jia ', 'Tiao ', 'Ji ', 'Xiao ', 'Lu ', 'Huan ', 'Shao ', 'Cen ', 'Fen ', 'Song ', 'Meng ', 'Wu ', 'Li ', 'Li ', 'Dou ', 'Cen ', 'Ying ', 'Suo ', 'Ju ', 'Ti ', 'Jie ', 'Kun ', 'Zhuo ', 'Shu ', 'Chan ', 'Fan ', 'Wei ', 'Jing ', 'Li ', 'Bing ', 'Fumoto ', 'Shikimi ', 'Tao ', 'Zhi ', 'Lai ', 'Lian ', 'Jian ', 'Zhuo ', 'Ling ', 'Li ', 'Qi ', 'Bing ', 'Zhun ', 'Cong ', 'Qian ', 'Mian ', 'Qi ', 'Qi ', 'Cai ', 'Gun ', 'Chan ', 'Te ', 'Fei ', 'Pai ', 'Bang ', 'Pou ', 'Hun ', 'Zong ', 'Cheng ', 'Zao ', 'Ji ', 'Li ', 'Peng ', 'Yu ', 'Yu ', 'Gu ', 'Hun ', 'Dong ', 'Tang ', 'Gang ', 'Wang ', 'Di ', 'Xi ', 'Fan ', 'Cheng ', 'Zhan ', 'Qi ', 'Yuan ', 'Yan ', 'Yu ', 'Quan ', 'Yi ', 'Sen ', 'Ren ', 'Chui ', 'Leng ', 'Qi ', 'Zhuo ', 'Fu ', 'Ke ', 'Lai ', 'Zou ', 'Zou ', 'Zhuo ', 'Guan ', 'Fen ', 'Fen ', 'Chen ', 'Qiong ', 'Nie ']

Documentation des variables

◆ return

return[ 'Zhi ', 'Liu ', 'Mei ', 'Hoy ', 'Rong ', 'Zha ', '[?] ', 'Biao ', 'Zhan ', 'Jie ', 'Long ', 'Dong ', 'Lu ', 'Sayng ', 'Li ', 'Lan ', 'Yong ', 'Shu ', 'Xun ', 'Shuan ', 'Qi ', 'Zhen ', 'Qi ', 'Li ', 'Yi ', 'Xiang ', 'Zhen ', 'Li ', 'Su ', 'Gua ', 'Kan ', 'Bing ', 'Ren ', 'Xiao ', 'Bo ', 'Ren ', 'Bing ', 'Zi ', 'Chou ', 'Yi ', 'Jie ', 'Xu ', 'Zhu ', 'Jian ', 'Zui ', 'Er ', 'Er ', 'You ', 'Fa ', 'Gong ', 'Kao ', 'Lao ', 'Zhan ', 'Li ', 'Yin ', 'Yang ', 'He ', 'Gen ', 'Zhi ', 'Chi ', 'Ge ', 'Zai ', 'Luan ', 'Fu ', 'Jie ', 'Hang ', 'Gui ', 'Tao ', 'Guang ', 'Wei ', 'Kuang ', 'Ru ', 'An ', 'An ', 'Juan ', 'Yi ', 'Zhuo ', 'Ku ', 'Zhi ', 'Qiong ', 'Tong ', 'Sang ', 'Sang ', 'Huan ', 'Jie ', 'Jiu ', 'Xue ', 'Duo ', 'Zhui ', 'Yu ', 'Zan ', 'Kasei ', 'Ying ', 'Masu ', '[?] ', 'Zhan ', 'Ya ', 'Nao ', 'Zhen ', 'Dang ', 'Qi ', 'Qiao ', 'Hua ', 'Kuai ', 'Jiang ', 'Zhuang ', 'Xun ', 'Suo ', 'Sha ', 'Zhen ', 'Bei ', 'Ting ', 'Gua ', 'Jing ', 'Bo ', 'Ben ', 'Fu ', 'Rui ', 'Tong ', 'Jue ', 'Xi ', 'Lang ', 'Liu ', 'Feng ', 'Qi ', 'Wen ', 'Jun ', 'Gan ', 'Cu ', 'Liang ', 'Qiu ', 'Ting ', 'You ', 'Mei ', 'Bang ', 'Long ', 'Peng ', 'Zhuang ', 'Di ', 'Xuan ', 'Tu ', 'Zao ', 'Ao ', 'Gu ', 'Bi ', 'Di ', 'Han ', 'Zi ', 'Zhi ', 'Ren ', 'Bei ', 'Geng ', 'Jian ', 'Huan ', 'Wan ', 'Nuo ', 'Jia ', 'Tiao ', 'Ji ', 'Xiao ', 'Lu ', 'Huan ', 'Shao ', 'Cen ', 'Fen ', 'Song ', 'Meng ', 'Wu ', 'Li ', 'Li ', 'Dou ', 'Cen ', 'Ying ', 'Suo ', 'Ju ', 'Ti ', 'Jie ', 'Kun ', 'Zhuo ', 'Shu ', 'Chan ', 'Fan ', 'Wei ', 'Jing ', 'Li ', 'Bing ', 'Fumoto ', 'Shikimi ', 'Tao ', 'Zhi ', 'Lai ', 'Lian ', 'Jian ', 'Zhuo ', 'Ling ', 'Li ', 'Qi ', 'Bing ', 'Zhun ', 'Cong ', 'Qian ', 'Mian ', 'Qi ', 'Qi ', 'Cai ', 'Gun ', 'Chan ', 'Te ', 'Fei ', 'Pai ', 'Bang ', 'Pou ', 'Hun ', 'Zong ', 'Cheng ', 'Zao ', 'Ji ', 'Li ', 'Peng ', 'Yu ', 'Yu ', 'Gu ', 'Hun ', 'Dong ', 'Tang ', 'Gang ', 'Wang ', 'Di ', 'Xi ', 'Fan ', 'Cheng ', 'Zhan ', 'Qi ', 'Yuan ', 'Yan ', 'Yu ', 'Quan ', 'Yi ', 'Sen ', 'Ren ', 'Chui ', 'Leng ', 'Qi ', 'Zhuo ', 'Fu ', 'Ke ', 'Lai ', 'Zou ', 'Zou ', 'Zhuo ', 'Guan ', 'Fen ', 'Fen ', 'Chen ', 'Qiong ', 'Nie ']


Joomla CMS: Référence du fichier PrintableString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Universal
Structures de données | Espaces de nommage
Référence du fichier PrintableString.php

Structures de données

class PrintableString

Espaces de nommage

FG\ASN1\Universal


Joomla CMS: Référence du fichier PasswordField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier PasswordField.php

Structures de données

class PasswordField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier x08a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08a.php

Variables

return ['Yan ', 'Yan ', 'Ding ', 'Fu ', 'Qiu ', 'Qiu ', 'Jiao ', 'Hong ', 'Ji ', 'Fan ', 'Xun ', 'Diao ', 'Hong ', 'Cha ', 'Tao ', 'Xu ', 'Jie ', 'Yi ', 'Ren ', 'Xun ', 'Yin ', 'Shan ', 'Qi ', 'Tuo ', 'Ji ', 'Xun ', 'Yin ', 'E ', 'Fen ', 'Ya ', 'Yao ', 'Song ', 'Shen ', 'Yin ', 'Xin ', 'Jue ', 'Xiao ', 'Ne ', 'Chen ', 'You ', 'Zhi ', 'Xiong ', 'Fang ', 'Xin ', 'Chao ', 'She ', 'Xian ', 'Sha ', 'Tun ', 'Xu ', 'Yi ', 'Yi ', 'Su ', 'Chi ', 'He ', 'Shen ', 'He ', 'Xu ', 'Zhen ', 'Zhu ', 'Zheng ', 'Gou ', 'Zi ', 'Zi ', 'Zhan ', 'Gu ', 'Fu ', 'Quan ', 'Die ', 'Ling ', 'Di ', 'Yang ', 'Li ', 'Nao ', 'Pan ', 'Zhou ', 'Gan ', 'Yi ', 'Ju ', 'Ao ', 'Zha ', 'Tuo ', 'Yi ', 'Qu ', 'Zhao ', 'Ping ', 'Bi ', 'Xiong ', 'Qu ', 'Ba ', 'Da ', 'Zu ', 'Tao ', 'Zhu ', 'Ci ', 'Zhe ', 'Yong ', 'Xu ', 'Xun ', 'Yi ', 'Huang ', 'He ', 'Shi ', 'Cha ', 'Jiao ', 'Shi ', 'Hen ', 'Cha ', 'Gou ', 'Gui ', 'Quan ', 'Hui ', 'Jie ', 'Hua ', 'Gai ', 'Xiang ', 'Wei ', 'Shen ', 'Chou ', 'Tong ', 'Mi ', 'Zhan ', 'Ming ', 'E ', 'Hui ', 'Yan ', 'Xiong ', 'Gua ', 'Er ', 'Beng ', 'Tiao ', 'Chi ', 'Lei ', 'Zhu ', 'Kuang ', 'Kua ', 'Wu ', 'Yu ', 'Teng ', 'Ji ', 'Zhi ', 'Ren ', 'Su ', 'Lang ', 'E ', 'Kuang ', 'E ', 'Shi ', 'Ting ', 'Dan ', 'Bo ', 'Chan ', 'You ', 'Heng ', 'Qiao ', 'Qin ', 'Shua ', 'An ', 'Yu ', 'Xiao ', 'Cheng ', 'Jie ', 'Xian ', 'Wu ', 'Wu ', 'Gao ', 'Song ', 'Pu ', 'Hui ', 'Jing ', 'Shuo ', 'Zhen ', 'Shuo ', 'Du ', 'Yasashi ', 'Chang ', 'Shui ', 'Jie ', 'Ke ', 'Qu ', 'Cong ', 'Xiao ', 'Sui ', 'Wang ', 'Xuan ', 'Fei ', 'Chi ', 'Ta ', 'Yi ', 'Na ', 'Yin ', 'Diao ', 'Pi ', 'Chuo ', 'Chan ', 'Chen ', 'Zhun ', 'Ji ', 'Qi ', 'Tan ', 'Zhui ', 'Wei ', 'Ju ', 'Qing ', 'Jian ', 'Zheng ', 'Ze ', 'Zou ', 'Qian ', 'Zhuo ', 'Liang ', 'Jian ', 'Zhu ', 'Hao ', 'Lun ', 'Shen ', 'Biao ', 'Huai ', 'Pian ', 'Yu ', 'Die ', 'Xu ', 'Pian ', 'Shi ', 'Xuan ', 'Shi ', 'Hun ', 'Hua ', 'E ', 'Zhong ', 'Di ', 'Xie ', 'Fu ', 'Pu ', 'Ting ', 'Jian ', 'Qi ', 'Yu ', 'Zi ', 'Chuan ', 'Xi ', 'Hui ', 'Yin ', 'An ', 'Xian ', 'Nan ', 'Chen ', 'Feng ', 'Zhu ', 'Yang ', 'Yan ', 'Heng ', 'Xuan ', 'Ge ', 'Nuo ', 'Qi ']

Documentation des variables

◆ return

return[ 'Yan ', 'Yan ', 'Ding ', 'Fu ', 'Qiu ', 'Qiu ', 'Jiao ', 'Hong ', 'Ji ', 'Fan ', 'Xun ', 'Diao ', 'Hong ', 'Cha ', 'Tao ', 'Xu ', 'Jie ', 'Yi ', 'Ren ', 'Xun ', 'Yin ', 'Shan ', 'Qi ', 'Tuo ', 'Ji ', 'Xun ', 'Yin ', 'E ', 'Fen ', 'Ya ', 'Yao ', 'Song ', 'Shen ', 'Yin ', 'Xin ', 'Jue ', 'Xiao ', 'Ne ', 'Chen ', 'You ', 'Zhi ', 'Xiong ', 'Fang ', 'Xin ', 'Chao ', 'She ', 'Xian ', 'Sha ', 'Tun ', 'Xu ', 'Yi ', 'Yi ', 'Su ', 'Chi ', 'He ', 'Shen ', 'He ', 'Xu ', 'Zhen ', 'Zhu ', 'Zheng ', 'Gou ', 'Zi ', 'Zi ', 'Zhan ', 'Gu ', 'Fu ', 'Quan ', 'Die ', 'Ling ', 'Di ', 'Yang ', 'Li ', 'Nao ', 'Pan ', 'Zhou ', 'Gan ', 'Yi ', 'Ju ', 'Ao ', 'Zha ', 'Tuo ', 'Yi ', 'Qu ', 'Zhao ', 'Ping ', 'Bi ', 'Xiong ', 'Qu ', 'Ba ', 'Da ', 'Zu ', 'Tao ', 'Zhu ', 'Ci ', 'Zhe ', 'Yong ', 'Xu ', 'Xun ', 'Yi ', 'Huang ', 'He ', 'Shi ', 'Cha ', 'Jiao ', 'Shi ', 'Hen ', 'Cha ', 'Gou ', 'Gui ', 'Quan ', 'Hui ', 'Jie ', 'Hua ', 'Gai ', 'Xiang ', 'Wei ', 'Shen ', 'Chou ', 'Tong ', 'Mi ', 'Zhan ', 'Ming ', 'E ', 'Hui ', 'Yan ', 'Xiong ', 'Gua ', 'Er ', 'Beng ', 'Tiao ', 'Chi ', 'Lei ', 'Zhu ', 'Kuang ', 'Kua ', 'Wu ', 'Yu ', 'Teng ', 'Ji ', 'Zhi ', 'Ren ', 'Su ', 'Lang ', 'E ', 'Kuang ', 'E ', 'Shi ', 'Ting ', 'Dan ', 'Bo ', 'Chan ', 'You ', 'Heng ', 'Qiao ', 'Qin ', 'Shua ', 'An ', 'Yu ', 'Xiao ', 'Cheng ', 'Jie ', 'Xian ', 'Wu ', 'Wu ', 'Gao ', 'Song ', 'Pu ', 'Hui ', 'Jing ', 'Shuo ', 'Zhen ', 'Shuo ', 'Du ', 'Yasashi ', 'Chang ', 'Shui ', 'Jie ', 'Ke ', 'Qu ', 'Cong ', 'Xiao ', 'Sui ', 'Wang ', 'Xuan ', 'Fei ', 'Chi ', 'Ta ', 'Yi ', 'Na ', 'Yin ', 'Diao ', 'Pi ', 'Chuo ', 'Chan ', 'Chen ', 'Zhun ', 'Ji ', 'Qi ', 'Tan ', 'Zhui ', 'Wei ', 'Ju ', 'Qing ', 'Jian ', 'Zheng ', 'Ze ', 'Zou ', 'Qian ', 'Zhuo ', 'Liang ', 'Jian ', 'Zhu ', 'Hao ', 'Lun ', 'Shen ', 'Biao ', 'Huai ', 'Pian ', 'Yu ', 'Die ', 'Xu ', 'Pian ', 'Shi ', 'Xuan ', 'Shi ', 'Hun ', 'Hua ', 'E ', 'Zhong ', 'Di ', 'Xie ', 'Fu ', 'Pu ', 'Ting ', 'Jian ', 'Qi ', 'Yu ', 'Zi ', 'Chuan ', 'Xi ', 'Hui ', 'Yin ', 'An ', 'Xian ', 'Nan ', 'Chen ', 'Feng ', 'Zhu ', 'Yang ', 'Yan ', 'Heng ', 'Xuan ', 'Ge ', 'Nuo ', 'Qi ']


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_joomlaupdate/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier P3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core/Curve25519/Ge/P3.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Ge_P3


Joomla CMS: Référence du fichier StemmerFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
Structures de données | Espaces de nommage
Référence du fichier StemmerFactory.php

Structures de données

class StemmerFactory

Espaces de nommage

Wamania\Snowball


Joomla CMS: Référence du fichier UnableToWriteBody.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnableToWriteBody.php

Structures de données

class UnableToWriteBody

Espaces de nommage

Joomla\Application\Exception


Joomla CMS: Référence du fichier UserDeletion.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • webauthn
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier UserDeletion.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Webauthn\PluginTraits


Joomla CMS: Référence du fichier SSH2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier Crypt/DSA/Formats/Signature/SSH2.php

Structures de données

class SSH2

Espaces de nommage

Common
phpseclib3\Crypt\DSA\Formats\Signature


Joomla CMS: Référence du fichier subform.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • subform
Structures de données | Espaces de nommage
Référence du fichier subform.php

Structures de données

class PlgFieldsSubform

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier TrueObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
  • OtherObject
Structures de données | Espaces de nommage
Référence du fichier TrueObject.php

Structures de données

class TrueObject

Espaces de nommage

CBOR\OtherObject


Joomla CMS: Référence du fichier XTDButtons.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage
Référence du fichier XTDButtons.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits


Joomla CMS: Référence du fichier recaptcha_invisible.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • captcha
  • recaptcha_invisible
Structures de données | Espaces de nommage
Référence du fichier recaptcha_invisible.php

Structures de données

class PlgCaptchaRecaptcha_Invisible

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier UpdateCoreCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier UpdateCoreCommand.php

Structures de données

class UpdateCoreCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier SqlazureDriver.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Sqlazure
Structures de données | Espaces de nommage
Référence du fichier SqlazureDriver.php

Structures de données

class SqlazureDriver

Espaces de nommage

Joomla\Database\Sqlazure


Joomla CMS: Référence du fichier RandomGeneratorInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier RandomGeneratorInterface.php

Structures de données

interface RandomGeneratorInterface

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier secp256r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp256r1.php

Structures de données

class secp256r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier TableSeparator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TableSeparator.php

Structures de données

class TableSeparator

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier textarea.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • textarea
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/textarea/textarea.php

Structures de données

class PlgFieldsTextarea

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ReadBytes.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • System
  • SSH
  • Common
  • Traits
Espaces de nommage
Référence du fichier ReadBytes.php

Espaces de nommage

SSH
phpseclib3\System\SSH\Common\Traits


Joomla CMS: Référence du fichier Rijndael.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier Rijndael.php

Structures de données

class Rijndael

Espaces de nommage

phpseclib3\Crypt
Rijndael


Joomla CMS: Référence du fichier TaskController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TaskController.php

Structures de données

class TaskController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Controller


Joomla CMS: Référence du fichier RequestFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/RequestFactory.php

Structures de données

class RequestFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_banners
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_banners/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier Taxonomy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
Structures de données | Espaces de nommage
Référence du fichier Taxonomy.php

Structures de données

class Taxonomy

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer


Joomla CMS: Référence du fichier Rules.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • English
Structures de données | Espaces de nommage
Référence du fichier vendor/doctrine/inflector/lib/Doctrine/Inflector/Rules/English/Rules.php

Structures de données

class Rules

Espaces de nommage

Doctrine\Inflector\Rules\English


Joomla CMS: Référence du fichier SourceContextProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Dumper
  • ContextProvider
Structures de données | Espaces de nommage
Référence du fichier SourceContextProvider.php

Structures de données

class SourceContextProvider

Espaces de nommage

Symfony\Component\VarDumper\Dumper\ContextProvider


Joomla CMS: Référence du fichier RedirectStatusField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier RedirectStatusField.php

Structures de données

class RedirectStatusField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier RogueListEntry.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • metadata-service
  • src
Structures de données | Espaces de nommage
Référence du fichier RogueListEntry.php

Structures de données

class RogueListEntry

Espaces de nommage

Webauthn\MetadataService


Joomla CMS: Référence du fichier WorkflowHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier WorkflowHelper.php

Structures de données

class WorkflowHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Helper


Joomla CMS: Référence du fichier ServerRequestFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier ServerRequestFactory.php

Structures de données

class ServerRequestFactory

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier x0c8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c8.php

Variables

return ['jeo', 'jeog', 'jeogg', 'jeogs', 'jeon', 'jeonj', 'jeonh', 'jeod', 'jeol', 'jeolg', 'jeolm', 'jeolb', 'jeols', 'jeolt', 'jeolp', 'jeolh', 'jeom', 'jeob', 'jeobs', 'jeos', 'jeoss', 'jeong', 'jeoj', 'jeoc', 'jeok', 'jeot', 'jeop', 'jeoh', 'je', 'jeg', 'jegg', 'jegs', 'jen', 'jenj', 'jenh', 'jed', 'jel', 'jelg', 'jelm', 'jelb', 'jels', 'jelt', 'jelp', 'jelh', 'jem', 'jeb', 'jebs', 'jes', 'jess', 'jeng', 'jej', 'jec', 'jek', 'jet', 'jep', 'jeh', 'jyeo', 'jyeog', 'jyeogg', 'jyeogs', 'jyeon', 'jyeonj', 'jyeonh', 'jyeod', 'jyeol', 'jyeolg', 'jyeolm', 'jyeolb', 'jyeols', 'jyeolt', 'jyeolp', 'jyeolh', 'jyeom', 'jyeob', 'jyeobs', 'jyeos', 'jyeoss', 'jyeong', 'jyeoj', 'jyeoc', 'jyeok', 'jyeot', 'jyeop', 'jyeoh', 'jye', 'jyeg', 'jyegg', 'jyegs', 'jyen', 'jyenj', 'jyenh', 'jyed', 'jyel', 'jyelg', 'jyelm', 'jyelb', 'jyels', 'jyelt', 'jyelp', 'jyelh', 'jyem', 'jyeb', 'jyebs', 'jyes', 'jyess', 'jyeng', 'jyej', 'jyec', 'jyek', 'jyet', 'jyep', 'jyeh', 'jo', 'jog', 'jogg', 'jogs', 'jon', 'jonj', 'jonh', 'jod', 'jol', 'jolg', 'jolm', 'jolb', 'jols', 'jolt', 'jolp', 'jolh', 'jom', 'job', 'jobs', 'jos', 'joss', 'jong', 'joj', 'joc', 'jok', 'jot', 'jop', 'joh', 'jwa', 'jwag', 'jwagg', 'jwags', 'jwan', 'jwanj', 'jwanh', 'jwad', 'jwal', 'jwalg', 'jwalm', 'jwalb', 'jwals', 'jwalt', 'jwalp', 'jwalh', 'jwam', 'jwab', 'jwabs', 'jwas', 'jwass', 'jwang', 'jwaj', 'jwac', 'jwak', 'jwat', 'jwap', 'jwah', 'jwae', 'jwaeg', 'jwaegg', 'jwaegs', 'jwaen', 'jwaenj', 'jwaenh', 'jwaed', 'jwael', 'jwaelg', 'jwaelm', 'jwaelb', 'jwaels', 'jwaelt', 'jwaelp', 'jwaelh', 'jwaem', 'jwaeb', 'jwaebs', 'jwaes', 'jwaess', 'jwaeng', 'jwaej', 'jwaec', 'jwaek', 'jwaet', 'jwaep', 'jwaeh', 'joe', 'joeg', 'joegg', 'joegs', 'joen', 'joenj', 'joenh', 'joed', 'joel', 'joelg', 'joelm', 'joelb', 'joels', 'joelt', 'joelp', 'joelh', 'joem', 'joeb', 'joebs', 'joes', 'joess', 'joeng', 'joej', 'joec', 'joek', 'joet', 'joep', 'joeh', 'jyo', 'jyog', 'jyogg', 'jyogs', 'jyon', 'jyonj', 'jyonh', 'jyod', 'jyol', 'jyolg', 'jyolm', 'jyolb', 'jyols', 'jyolt', 'jyolp', 'jyolh', 'jyom', 'jyob', 'jyobs', 'jyos', 'jyoss', 'jyong', 'jyoj', 'jyoc', 'jyok', 'jyot', 'jyop', 'jyoh', 'ju', 'jug', 'jugg', 'jugs']

Documentation des variables

◆ return

return[ 'jeo', 'jeog', 'jeogg', 'jeogs', 'jeon', 'jeonj', 'jeonh', 'jeod', 'jeol', 'jeolg', 'jeolm', 'jeolb', 'jeols', 'jeolt', 'jeolp', 'jeolh', 'jeom', 'jeob', 'jeobs', 'jeos', 'jeoss', 'jeong', 'jeoj', 'jeoc', 'jeok', 'jeot', 'jeop', 'jeoh', 'je', 'jeg', 'jegg', 'jegs', 'jen', 'jenj', 'jenh', 'jed', 'jel', 'jelg', 'jelm', 'jelb', 'jels', 'jelt', 'jelp', 'jelh', 'jem', 'jeb', 'jebs', 'jes', 'jess', 'jeng', 'jej', 'jec', 'jek', 'jet', 'jep', 'jeh', 'jyeo', 'jyeog', 'jyeogg', 'jyeogs', 'jyeon', 'jyeonj', 'jyeonh', 'jyeod', 'jyeol', 'jyeolg', 'jyeolm', 'jyeolb', 'jyeols', 'jyeolt', 'jyeolp', 'jyeolh', 'jyeom', 'jyeob', 'jyeobs', 'jyeos', 'jyeoss', 'jyeong', 'jyeoj', 'jyeoc', 'jyeok', 'jyeot', 'jyeop', 'jyeoh', 'jye', 'jyeg', 'jyegg', 'jyegs', 'jyen', 'jyenj', 'jyenh', 'jyed', 'jyel', 'jyelg', 'jyelm', 'jyelb', 'jyels', 'jyelt', 'jyelp', 'jyelh', 'jyem', 'jyeb', 'jyebs', 'jyes', 'jyess', 'jyeng', 'jyej', 'jyec', 'jyek', 'jyet', 'jyep', 'jyeh', 'jo', 'jog', 'jogg', 'jogs', 'jon', 'jonj', 'jonh', 'jod', 'jol', 'jolg', 'jolm', 'jolb', 'jols', 'jolt', 'jolp', 'jolh', 'jom', 'job', 'jobs', 'jos', 'joss', 'jong', 'joj', 'joc', 'jok', 'jot', 'jop', 'joh', 'jwa', 'jwag', 'jwagg', 'jwags', 'jwan', 'jwanj', 'jwanh', 'jwad', 'jwal', 'jwalg', 'jwalm', 'jwalb', 'jwals', 'jwalt', 'jwalp', 'jwalh', 'jwam', 'jwab', 'jwabs', 'jwas', 'jwass', 'jwang', 'jwaj', 'jwac', 'jwak', 'jwat', 'jwap', 'jwah', 'jwae', 'jwaeg', 'jwaegg', 'jwaegs', 'jwaen', 'jwaenj', 'jwaenh', 'jwaed', 'jwael', 'jwaelg', 'jwaelm', 'jwaelb', 'jwaels', 'jwaelt', 'jwaelp', 'jwaelh', 'jwaem', 'jwaeb', 'jwaebs', 'jwaes', 'jwaess', 'jwaeng', 'jwaej', 'jwaec', 'jwaek', 'jwaet', 'jwaep', 'jwaeh', 'joe', 'joeg', 'joegg', 'joegs', 'joen', 'joenj', 'joenh', 'joed', 'joel', 'joelg', 'joelm', 'joelb', 'joels', 'joelt', 'joelp', 'joelh', 'joem', 'joeb', 'joebs', 'joes', 'joess', 'joeng', 'joej', 'joec', 'joek', 'joet', 'joep', 'joeh', 'jyo', 'jyog', 'jyogg', 'jyogs', 'jyon', 'jyonj', 'jyonh', 'jyod', 'jyol', 'jyolg', 'jyolm', 'jyolb', 'jyols', 'jyolt', 'jyolp', 'jyolh', 'jyom', 'jyob', 'jyobs', 'jyos', 'jyoss', 'jyong', 'jyoj', 'jyoc', 'jyok', 'jyot', 'jyop', 'jyoh', 'ju', 'jug', 'jugg', 'jugs']


Joomla CMS: Référence du fichier PKCS8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier EC/Formats/Keys/PKCS8.php

Structures de données

class PKCS8

Espaces de nommage

EC
phpseclib3\Crypt\EC\Formats\Keys


Joomla CMS: Référence du fichier PrefixRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier PrefixRule.php

Structures de données

class PrefixRule

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Form\Rule


Joomla CMS: Référence du fichier P2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core/Curve25519/Ge/P2.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Ge_P2


Joomla CMS: Référence du fichier StringStream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier web-auth/webauthn-lib/src/StringStream.php

Structures de données

class StringStream

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier WordInflector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
Structures de données | Espaces de nommage
Référence du fichier WordInflector.php

Structures de données

interface WordInflector

Espaces de nommage

Doctrine\Inflector


Joomla CMS: Référence du fichier prime192v2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime192v2.php

Structures de données

class prime192v2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier WorkflowsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier WorkflowsModel.php

Structures de données

class WorkflowsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Model


Joomla CMS: Référence du fichier TableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier TableInterface.php

Structures de données

interface TableInterface

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier TransitionTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier TransitionTable.php

Structures de données

class TransitionTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Table


Joomla CMS: Référence du fichier UsersModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier UsersModel.php

Structures de données

class UsersModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Turkish
Structures de données | Espaces de nommage
Référence du fichier Turkish/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\Turkish


Joomla CMS: Référence du fichier XmlDocument.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Document
Structures de données | Espaces de nommage
Référence du fichier XmlDocument.php

Structures de données

class XmlDocument

Espaces de nommage

Joomla\CMS\Document


Joomla CMS: Référence du fichier RequestDataCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier RequestDataCollector.php

Structures de données

class RequestDataCollector

Espaces de nommage

DebugBar\DataCollector


Joomla CMS: Référence du fichier TasksStateCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier TasksStateCommand.php

Structures de données

class TasksStateCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier TextStringObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier TextStringObject.php

Structures de données

class TextStringObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier TrustPath.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • TrustPath
Structures de données | Espaces de nommage
Référence du fichier TrustPath.php

Structures de données

interface TrustPath

Espaces de nommage

Webauthn\TrustPath


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_newsfeeds/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Newsfeeds\Site\Service


Joomla CMS: Référence du fichier preview.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_contenthistory
  • tmpl
  • preview
Espaces de nommage | Variables
Référence du fichier preview.php

Espaces de nommage

Joomla\Administrator

Variables

endif
endforeach
else __pad2__

Documentation des variables

◆ __pad2__

else __pad2__

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier RSA.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/RSA.php

Structures de données

class RSA

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier Route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier src/Router/Route.php

Structures de données

class Route

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier ViewController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Cache
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ViewController.php

Structures de données

class ViewController

Espaces de nommage

Joomla\CMS\Cache\Controller


Joomla CMS: Référence du fichier PBKDF2params.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PBKDF2params.php

Structures de données

class PBKDF2params

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier strcasecmp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier strcasecmp.php

Espaces de nommage

utf8

Fonctions

utf8_strcasecmp ($strX, $strY)

Documentation des fonctions

◆ utf8_strcasecmp()

utf8_strcasecmp | ( | $strX,
 |  | $strY
 | ) |

Références utf8_strtolower().

Référencé par StringHelper\strcasecmp().


Joomla CMS: Référence du fichier ucwords.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier ucwords.php

Espaces de nommage

utf8

Fonctions

utf8_ucwords ($str)
utf8_ucwords_callback ($matches)

Documentation des fonctions

◆ utf8_ucwords()

utf8_ucwords ( $str )

Référencé par StringHelper\ucwords().

◆ utf8_ucwords_callback()

utf8_ucwords_callback ( $matches )

Références utf8_strtoupper(), et utf8_substr_replace().


Joomla CMS: Référence du fichier str_split.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier str_split.php

Espaces de nommage

utf8

Fonctions

utf8_str_split ($str, $split_len=1)

Documentation des fonctions

◆ utf8_str_split()

utf8_str_split | ( | $str,
 |  | $split_len = 1
 | ) |

Références utf8_strlen().

Référencé par StringHelper\str_split().


Joomla CMS: Référence du fichier RouterServiceTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Espaces de nommage | Fonctions | Variables
Référence du fichier RouterServiceTrait.php

Espaces de nommage

Joomla\CMS\Component\Router

Fonctions

createRouter (CMSApplicationInterface $application, AbstractMenu $menu)
setRouterFactory (RouterFactoryInterface $routerFactory)

Variables

trait RouterServiceTrait


Joomla CMS: Référence du fichier PermittedFor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier PermittedFor.php

Structures de données

class PermittedFor

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier x1d6.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x1d6.php

Variables

return ['s', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'i', 'j', '', '', 'Alpha', 'Beta', 'Gamma', 'Delta', 'Epsilon', 'Zeta', 'Eta', 'Theta', 'Iota', 'Kappa', 'Lamda', 'Mu', 'Nu', 'Xi', 'Omicron', 'Pi', 'Rho', 'Theta', 'Sigma', 'Tau', 'Upsilon', 'Phi', 'Chi', 'Psi', 'Omega', 'nabla', 'alpha', 'beta', 'gamma', 'delta', 'epsilon', 'zeta', 'eta', 'theta', 'iota', 'kappa', 'lamda', 'mu', 'nu', 'xi', 'omicron', 'pi', 'rho', 'sigma', 'sigma', 'tai', 'upsilon', 'phi', 'chi', 'psi', 'omega', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return[ 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'i', 'j', '', '', 'Alpha', 'Beta', 'Gamma', 'Delta', 'Epsilon', 'Zeta', 'Eta', 'Theta', 'Iota', 'Kappa', 'Lamda', 'Mu', 'Nu', 'Xi', 'Omicron', 'Pi', 'Rho', 'Theta', 'Sigma', 'Tau', 'Upsilon', 'Phi', 'Chi', 'Psi', 'Omega', 'nabla', 'alpha', 'beta', 'gamma', 'delta', 'epsilon', 'zeta', 'eta', 'theta', 'iota', 'kappa', 'lamda', 'mu', 'nu', 'xi', 'omicron', 'pi', 'rho', 'sigma', 'sigma', 'tai', 'upsilon', 'phi', 'chi', 'psi', 'omega', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier UnicodeString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • string
Structures de données | Espaces de nommage
Référence du fichier UnicodeString.php

Structures de données

class UnicodeString

Espaces de nommage

Symfony\Component\String


Joomla CMS: Référence du fichier Word.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
Structures de données | Espaces de nommage
Référence du fichier Word.php

Structures de données

class Word

Espaces de nommage

Doctrine\Inflector\Rules


Joomla CMS: Référence du fichier UnsupportedAdapterException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedAdapterException.php

Structures de données

class UnsupportedAdapterException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_wrapper
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_wrapper/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Wrapper\Site\Service


Joomla CMS: Référence du fichier Resolvable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier Resolvable.php

Structures de données

interface Resolvable

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier select.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • tmpl
  • captive
Espaces de nommage | Variables
Référence du fichier components/com_users/tmpl/captive/select.php

Espaces de nommage

Joomla\Site

Variables

$shownMethods = []
foreach( $this->records as $record)(!array_key_exists($record->method, $this->mfaMethods) &&($record->method !='backupcodes')) | $allowEntryBatching = isset($this->mfaMethods[$record->method]) ? $this->mfaMethods[$record->method]['allowEntryBatching'] : false
if($this->allowEntryBatching) | $methodName = $this->getModel()->translateMethodName($record->method)

Documentation des variables

◆ $allowEntryBatching

foreach ($this->records as $record) (!array_key_exists( $record->method, $this->mfaMethods) &&( $record->method !='backupcodes')) $allowEntryBatching = isset($this->mfaMethods[$record->method]) ? $this->mfaMethods[$record->method]['allowEntryBatching'] : false

◆ $methodName

if ( $this->allowEntryBatching) $methodName = $this->getModel()->translateMethodName($record->method)

◆ $shownMethods

$shownMethods = []


Joomla CMS: Référence du fichier ucfirst.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier ucfirst.php

Espaces de nommage

utf8

Fonctions

utf8_ucfirst ($str)

Documentation des fonctions

◆ utf8_ucfirst()

utf8_ucfirst ( $str )

Références utf8_strlen(), et utf8_strtoupper().

Référencé par StringHelper\ucfirst().


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Portuguese
Structures de données | Espaces de nommage
Référence du fichier Portuguese/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\Portuguese


Joomla CMS: Référence du fichier TasksModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier TasksModel.php

Structures de données

class TasksModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Model


Joomla CMS: Référence du fichier UpdateModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_installer/src/Model/UpdateModel.php

Structures de données

class UpdateModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Model


Joomla CMS: Référence du fichier P1p1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Curve25519
  • Ge
Structures de données
Référence du fichier src/Core/Curve25519/Ge/P1p1.php

Structures de données

class ParagonIE_Sodium_Core_Curve25519_Ge_P1p1


Joomla CMS: Référence du fichier UrlSafe.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core
  • Base64
Structures de données
Référence du fichier UrlSafe.php

Structures de données

class ParagonIE_Sodium_Core_Base64_UrlSafe


Joomla CMS: Référence du fichier Taggable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier Taggable.php

Structures de données

class Taggable

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Behaviour\Taggable\Extension


Joomla CMS: Référence du fichier RouterServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Component
  • Router
Structures de données | Espaces de nommage
Référence du fichier RouterServiceInterface.php

Structures de données

interface RouterServiceInterface

Espaces de nommage

Joomla\CMS\Component\Router


Joomla CMS: Référence du fichier SafehtmlFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier SafehtmlFilter.php

Structures de données

class SafehtmlFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier ResolveFiles.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • PluginTraits
Espaces de nommage | Fonctions | Variables
Référence du fichier ResolveFiles.php

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\PluginTraits

Fonctions

includeRelativeFiles ($folder, $file)
static resolveFileUrl ($path='')

Variables

trait ResolveFiles


Joomla CMS: Référence du fichier Uninflected.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • doctrine
  • inflector
  • lib
  • Doctrine
  • Inflector
  • Rules
  • Spanish
Structures de données | Espaces de nommage
Référence du fichier Spanish/Uninflected.php

Structures de données

class Uninflected

Espaces de nommage

Doctrine\Inflector\Rules\Spanish


Joomla CMS: Référence du fichier PharStreamWrapper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
Structures de données | Espaces de nommage
Référence du fichier PharStreamWrapper.php

Structures de données

class PharStreamWrapper

Espaces de nommage

TYPO3\PharStreamWrapper


Joomla CMS: Référence du fichier StageHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier StageHelper.php

Structures de données

class StageHelper

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Helper


Joomla CMS: Référence du fichier SSH2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Formats
  • Signature
Structures de données | Espaces de nommage
Référence du fichier Crypt/EC/Formats/Signature/SSH2.php

Structures de données

class SSH2

Espaces de nommage

Common
phpseclib3\Crypt\EC\Formats\Signature


Joomla CMS: Référence du fichier PublicKeyLoader.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier PublicKeyLoader.php

Structures de données

class PublicKeyLoader

Espaces de nommage

PublicKeyLoader
phpseclib3\Crypt
Common


Joomla CMS: Référence du fichier Subject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • enshrined
  • svg-sanitize
  • src
  • ElementReference
Structures de données | Espaces de nommage
Référence du fichier Subject.php

Structures de données

class Subject

Espaces de nommage

enshrined\svgSanitize\ElementReference


Joomla CMS: Référence du fichier UCM.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • UCM
Structures de données | Espaces de nommage
Référence du fichier UCM.php

Structures de données

interface UCM

Espaces de nommage

Joomla\CMS\UCM


Joomla CMS: Référence du fichier StreamInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier StreamInterface.php

Structures de données

interface StreamInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier TosField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • profile
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier TosField.php

Structures de données

class TosField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\User\Profile\Field


Joomla CMS: Référence du fichier UnparsableImageException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Image
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnparsableImageException.php

Structures de données

class UnparsableImageException

Espaces de nommage

Joomla\CMS\Image\Exception


Joomla CMS: Référence du fichier UriHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • uri
  • src
Structures de données | Espaces de nommage
Référence du fichier UriHelper.php

Structures de données

class UriHelper

Espaces de nommage

Joomla\Uri


Joomla CMS: Référence du fichier PrivacyStatusHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • modules
  • mod_privacy_status
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier PrivacyStatusHelper.php

Structures de données

class PrivacyStatusHelper

Espaces de nommage

Joomla\Administrator
Joomla\Module\PrivacyStatus\Administrator\Helper


Joomla CMS: Référence du fichier tags.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • tags
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/tags/tags.php

Structures de données

class PlgWebservicesTags

Espaces de nommage

Joomla\Tags


Joomla CMS: Référence du fichier x002.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x002.php

Variables

return [ 'A', 'a', 'A', 'a', 'E', 'e', 'E', 'e', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'R', 'r', 'R', 'r', 'U', 'u', 'U', 'u', 'S', 's', 'T', 't', 'Y', 'y', 'H', 'h', 'N', 'd', 'OU', 'ou', 'Z', 'z', 'A', 'a', 'E', 'e', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'Y', 'y', 'l', 'n', 't', 'j', 'db', 'qp', 'A', 'C', 'c', 'L', 'T', 's', 'z', '[?]', '[?]', 'B', 'U', '^', 'E', 'e', 'J', 'j', 'q', 'q', 'R', 'r', 'Y', 'y', 'a', 'a', 'a', 'b', 'o', 'c', 'd', 'd', 'e', '@', '@', 'e', 'e', 'e', 'e', 'j', 'g', 'g', 'g', 'g', 'u', 'Y', 'h', 'h', 'i', 'i', 'I', 'l', 'l', 'l', 'lZ', 'W', 'W', 'm', 'n', 'n', 'n', 'o', 'OE', 'O', 'F', 'r', 'r', 'r', 'r', 'r', 'r', 'r', 'R', 'R', 's', 'S', 'j', 'S', 'S', 't', 't', 'u', 'U', 'v', '^', 'w', 'y', 'Y', 'z', 'z', 'Z', 'Z', '?', '?', '?', 'C', '@', 'B', 'E', 'G', 'H', 'j', 'k', 'L', 'q', '?', '?', 'dz', 'dZ', 'dz', 'ts', 'tS', 'tC', 'fN', 'ls', 'lz', 'WW', '] h h h h j r r r r w y

Documentation des variables

◆ y

return ['A', 'a', 'A', 'a', 'E', 'e', 'E', 'e', 'I', 'i', 'I', 'i', 'O', 'o', 'O', 'o', 'R', 'r', 'R', 'r', 'U', 'u', 'U', 'u', 'S', 's', 'T', 't', 'Y', 'y', 'H', 'h', 'N', 'd', 'OU', 'ou', 'Z', 'z', 'A', 'a', 'E', 'e', 'O', 'o', 'O', 'o', 'O', 'o', 'O', 'o', 'Y', 'y', 'l', 'n', 't', 'j', 'db', 'qp', 'A', 'C', 'c', 'L', 'T', 's', 'z', '[?]', '[?]', 'B', 'U', '^', 'E', 'e', 'J', 'j', 'q', 'q', 'R', 'r', 'Y', 'y', 'a', 'a', 'a', 'b', 'o', 'c', 'd', 'd', 'e', '@', '@', 'e', 'e', 'e', 'e', 'j', 'g', 'g', 'g', 'g', 'u', 'Y', 'h', 'h', 'i', 'i', 'I', 'l', 'l', 'l', 'lZ', 'W', 'W', 'm', 'n', 'n', 'n', 'o', 'OE', 'O', 'F', 'r', 'r', 'r', 'r', 'r', 'r', 'r', 'R', 'R', 's', 'S', 'j', 'S', 'S', 't', 't', 'u', 'U', 'v', '^', 'w', 'y', 'Y', 'z', 'z', 'Z', 'Z', '?', '?', '?', 'C', '@', 'B', 'E', 'G', 'H', 'j', 'k', 'L', 'q', '?', '?', 'dz', 'dZ', 'dz', 'ts', 'tS', 'tC', 'fN', 'ls', 'lz', 'WW', '] h h h h j r r r r w y

Référencé par ANSI\appendString(), PrivateKey\getPublicKey(), ANSI\newLine(), ANSI\setDimensions(), PublicKey\toString(), PrivateKey\toString(), et PublicKey\verify().


Joomla CMS: Référence du fichier UploadedFile.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/UploadedFile.php

Structures de données

class UploadedFile

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier x04e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x04e.php

Variables

return ['Yi ', 'Ding ', 'Kao ', 'Qi ', 'Shang ', 'Xia ', '[?] ', 'Mo ', 'Zhang ', 'San ', 'Shang ', 'Xia ', 'Ji ', 'Bu ', 'Yu ', 'Mian ', 'Gai ', 'Chou ', 'Chou ', 'Zhuan ', 'Qie ', 'Pi ', 'Shi ', 'Shi ', 'Qiu ', 'Bing ', 'Ye ', 'Cong ', 'Dong ', 'Si ', 'Cheng ', 'Diu ', 'Qiu ', 'Liang ', 'Diu ', 'You ', 'Liang ', 'Yan ', 'Bing ', 'Sang ', 'Gun ', 'Jiu ', 'Ge ', 'Ya ', 'Qiang ', 'Zhong ', 'Ji ', 'Jie ', 'Feng ', 'Guan ', 'Chuan ', 'Chan ', 'Lin ', 'Zhuo ', 'Zhu ', 'Ha ', 'Wan ', 'Dan ', 'Wei ', 'Zhu ', 'Jing ', 'Li ', 'Ju ', 'Pie ', 'Fu ', 'Yi ', 'Yi ', 'Nai ', 'Shime ', 'Jiu ', 'Jiu ', 'Zhe ', 'Yao ', 'Yi ', '[?] ', 'Zhi ', 'Wu ', 'Zha ', 'Hu ', 'Fa ', 'Le ', 'Zhong ', 'Ping ', 'Pang ', 'Qiao ', 'Hu ', 'Guai ', 'Cheng ', 'Cheng ', 'Yi ', 'Yin ', '[?] ', 'Mie ', 'Jiu ', 'Qi ', 'Ye ', 'Xi ', 'Xiang ', 'Gai ', 'Diu ', 'Hal ', '[?] ', 'Shu ', 'Twul ', 'Shi ', 'Ji ', 'Nang ', 'Jia ', 'Kel ', 'Shi ', '[?] ', 'Ol ', 'Mai ', 'Luan ', 'Cal ', 'Ru ', 'Xue ', 'Yan ', 'Fu ', 'Sha ', 'Na ', 'Gan ', 'Sol ', 'El ', 'Cwul ', '[?] ', 'Gan ', 'Chi ', 'Gui ', 'Gan ', 'Luan ', 'Lin ', 'Yi ', 'Jue ', 'Liao ', 'Ma ', 'Yu ', 'Zheng ', 'Shi ', 'Shi ', 'Er ', 'Chu ', 'Yu ', 'Yu ', 'Yu ', 'Yun ', 'Hu ', 'Qi ', 'Wu ', 'Jing ', 'Si ', 'Sui ', 'Gen ', 'Gen ', 'Ya ', 'Xie ', 'Ya ', 'Qi ', 'Ya ', 'Ji ', 'Tou ', 'Wang ', 'Kang ', 'Ta ', 'Jiao ', 'Hai ', 'Yi ', 'Chan ', 'Heng ', 'Mu ', '[?] ', 'Xiang ', 'Jing ', 'Ting ', 'Liang ', 'Xiang ', 'Jing ', 'Ye ', 'Qin ', 'Bo ', 'You ', 'Xie ', 'Dan ', 'Lian ', 'Duo ', 'Wei ', 'Ren ', 'Ren ', 'Ji ', 'La ', 'Wang ', 'Yi ', 'Shi ', 'Ren ', 'Le ', 'Ding ', 'Ze ', 'Jin ', 'Pu ', 'Chou ', 'Ba ', 'Zhang ', 'Jin ', 'Jie ', 'Bing ', 'Reng ', 'Cong ', 'Fo ', 'San ', 'Lun ', 'Sya ', 'Cang ', 'Zi ', 'Shi ', 'Ta ', 'Zhang ', 'Fu ', 'Xian ', 'Xian ', 'Tuo ', 'Hong ', 'Tong ', 'Ren ', 'Qian ', 'Gan ', 'Yi ', 'Di ', 'Dai ', 'Ling ', 'Yi ', 'Chao ', 'Chang ', 'Sa ', '[?] ', 'Yi ', 'Mu ', 'Men ', 'Ren ', 'Jia ', 'Chao ', 'Yang ', 'Qian ', 'Zhong ', 'Pi ', 'Wan ', 'Wu ', 'Jian ', 'Jie ', 'Yao ', 'Feng ', 'Cang ', 'Ren ', 'Wang ', 'Fen ', 'Di ', 'Fang ']

Documentation des variables

◆ return

return[ 'Yi ', 'Ding ', 'Kao ', 'Qi ', 'Shang ', 'Xia ', '[?] ', 'Mo ', 'Zhang ', 'San ', 'Shang ', 'Xia ', 'Ji ', 'Bu ', 'Yu ', 'Mian ', 'Gai ', 'Chou ', 'Chou ', 'Zhuan ', 'Qie ', 'Pi ', 'Shi ', 'Shi ', 'Qiu ', 'Bing ', 'Ye ', 'Cong ', 'Dong ', 'Si ', 'Cheng ', 'Diu ', 'Qiu ', 'Liang ', 'Diu ', 'You ', 'Liang ', 'Yan ', 'Bing ', 'Sang ', 'Gun ', 'Jiu ', 'Ge ', 'Ya ', 'Qiang ', 'Zhong ', 'Ji ', 'Jie ', 'Feng ', 'Guan ', 'Chuan ', 'Chan ', 'Lin ', 'Zhuo ', 'Zhu ', 'Ha ', 'Wan ', 'Dan ', 'Wei ', 'Zhu ', 'Jing ', 'Li ', 'Ju ', 'Pie ', 'Fu ', 'Yi ', 'Yi ', 'Nai ', 'Shime ', 'Jiu ', 'Jiu ', 'Zhe ', 'Yao ', 'Yi ', '[?] ', 'Zhi ', 'Wu ', 'Zha ', 'Hu ', 'Fa ', 'Le ', 'Zhong ', 'Ping ', 'Pang ', 'Qiao ', 'Hu ', 'Guai ', 'Cheng ', 'Cheng ', 'Yi ', 'Yin ', '[?] ', 'Mie ', 'Jiu ', 'Qi ', 'Ye ', 'Xi ', 'Xiang ', 'Gai ', 'Diu ', 'Hal ', '[?] ', 'Shu ', 'Twul ', 'Shi ', 'Ji ', 'Nang ', 'Jia ', 'Kel ', 'Shi ', '[?] ', 'Ol ', 'Mai ', 'Luan ', 'Cal ', 'Ru ', 'Xue ', 'Yan ', 'Fu ', 'Sha ', 'Na ', 'Gan ', 'Sol ', 'El ', 'Cwul ', '[?] ', 'Gan ', 'Chi ', 'Gui ', 'Gan ', 'Luan ', 'Lin ', 'Yi ', 'Jue ', 'Liao ', 'Ma ', 'Yu ', 'Zheng ', 'Shi ', 'Shi ', 'Er ', 'Chu ', 'Yu ', 'Yu ', 'Yu ', 'Yun ', 'Hu ', 'Qi ', 'Wu ', 'Jing ', 'Si ', 'Sui ', 'Gen ', 'Gen ', 'Ya ', 'Xie ', 'Ya ', 'Qi ', 'Ya ', 'Ji ', 'Tou ', 'Wang ', 'Kang ', 'Ta ', 'Jiao ', 'Hai ', 'Yi ', 'Chan ', 'Heng ', 'Mu ', '[?] ', 'Xiang ', 'Jing ', 'Ting ', 'Liang ', 'Xiang ', 'Jing ', 'Ye ', 'Qin ', 'Bo ', 'You ', 'Xie ', 'Dan ', 'Lian ', 'Duo ', 'Wei ', 'Ren ', 'Ren ', 'Ji ', 'La ', 'Wang ', 'Yi ', 'Shi ', 'Ren ', 'Le ', 'Ding ', 'Ze ', 'Jin ', 'Pu ', 'Chou ', 'Ba ', 'Zhang ', 'Jin ', 'Jie ', 'Bing ', 'Reng ', 'Cong ', 'Fo ', 'San ', 'Lun ', 'Sya ', 'Cang ', 'Zi ', 'Shi ', 'Ta ', 'Zhang ', 'Fu ', 'Xian ', 'Xian ', 'Tuo ', 'Hong ', 'Tong ', 'Ren ', 'Qian ', 'Gan ', 'Yi ', 'Di ', 'Dai ', 'Ling ', 'Yi ', 'Chao ', 'Chang ', 'Sa ', '[?] ', 'Yi ', 'Mu ', 'Men ', 'Ren ', 'Jia ', 'Chao ', 'Yang ', 'Qian ', 'Zhong ', 'Pi ', 'Wan ', 'Wu ', 'Jian ', 'Jie ', 'Yao ', 'Feng ', 'Cang ', 'Ren ', 'Wang ', 'Fen ', 'Di ', 'Fang ']


Joomla CMS: Référence du fichier UploaddirsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • editors
  • tinymce
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier UploaddirsField.php

Structures de données

class UploaddirsField

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Editors\TinyMCE\Field


Joomla CMS: Référence du fichier SiteRouterAwareTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Espaces de nommage | Fonctions | Variables
Référence du fichier SiteRouterAwareTrait.php

Espaces de nommage

Joomla\CMS\Router

Fonctions

getSiteRouter ()
setSiteRouter (SiteRouter $router)

Variables

trait SiteRouterAwareTrait


Joomla CMS: Référence du fichier x0ae.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ae.php

Variables

return ['geul', 'geulg', 'geulm', 'geulb', 'geuls', 'geult', 'geulp', 'geulh', 'geum', 'geub', 'geubs', 'geus', 'geuss', 'geung', 'geuj', 'geuc', 'geuk', 'geut', 'geup', 'geuh', 'gyi', 'gyig', 'gyigg', 'gyigs', 'gyin', 'gyinj', 'gyinh', 'gyid', 'gyil', 'gyilg', 'gyilm', 'gyilb', 'gyils', 'gyilt', 'gyilp', 'gyilh', 'gyim', 'gyib', 'gyibs', 'gyis', 'gyiss', 'gying', 'gyij', 'gyic', 'gyik', 'gyit', 'gyip', 'gyih', 'gi', 'gig', 'gigg', 'gigs', 'gin', 'ginj', 'ginh', 'gid', 'gil', 'gilg', 'gilm', 'gilb', 'gils', 'gilt', 'gilp', 'gilh', 'gim', 'gib', 'gibs', 'gis', 'giss', 'ging', 'gij', 'gic', 'gik', 'git', 'gip', 'gih', 'gga', 'ggag', 'ggagg', 'ggags', 'ggan', 'gganj', 'gganh', 'ggad', 'ggal', 'ggalg', 'ggalm', 'ggalb', 'ggals', 'ggalt', 'ggalp', 'ggalh', 'ggam', 'ggab', 'ggabs', 'ggas', 'ggass', 'ggang', 'ggaj', 'ggac', 'ggak', 'ggat', 'ggap', 'ggah', 'ggae', 'ggaeg', 'ggaegg', 'ggaegs', 'ggaen', 'ggaenj', 'ggaenh', 'ggaed', 'ggael', 'ggaelg', 'ggaelm', 'ggaelb', 'ggaels', 'ggaelt', 'ggaelp', 'ggaelh', 'ggaem', 'ggaeb', 'ggaebs', 'ggaes', 'ggaess', 'ggaeng', 'ggaej', 'ggaec', 'ggaek', 'ggaet', 'ggaep', 'ggaeh', 'ggya', 'ggyag', 'ggyagg', 'ggyags', 'ggyan', 'ggyanj', 'ggyanh', 'ggyad', 'ggyal', 'ggyalg', 'ggyalm', 'ggyalb', 'ggyals', 'ggyalt', 'ggyalp', 'ggyalh', 'ggyam', 'ggyab', 'ggyabs', 'ggyas', 'ggyass', 'ggyang', 'ggyaj', 'ggyac', 'ggyak', 'ggyat', 'ggyap', 'ggyah', 'ggyae', 'ggyaeg', 'ggyaegg', 'ggyaegs', 'ggyaen', 'ggyaenj', 'ggyaenh', 'ggyaed', 'ggyael', 'ggyaelg', 'ggyaelm', 'ggyaelb', 'ggyaels', 'ggyaelt', 'ggyaelp', 'ggyaelh', 'ggyaem', 'ggyaeb', 'ggyaebs', 'ggyaes', 'ggyaess', 'ggyaeng', 'ggyaej', 'ggyaec', 'ggyaek', 'ggyaet', 'ggyaep', 'ggyaeh', 'ggeo', 'ggeog', 'ggeogg', 'ggeogs', 'ggeon', 'ggeonj', 'ggeonh', 'ggeod', 'ggeol', 'ggeolg', 'ggeolm', 'ggeolb', 'ggeols', 'ggeolt', 'ggeolp', 'ggeolh', 'ggeom', 'ggeob', 'ggeobs', 'ggeos', 'ggeoss', 'ggeong', 'ggeoj', 'ggeoc', 'ggeok', 'ggeot', 'ggeop', 'ggeoh', 'gge', 'ggeg', 'ggegg', 'ggegs', 'ggen', 'ggenj', 'ggenh', 'gged', 'ggel', 'ggelg', 'ggelm', 'ggelb', 'ggels', 'ggelt', 'ggelp', 'ggelh', 'ggem', 'ggeb', 'ggebs', 'gges', 'ggess', 'ggeng', 'ggej', 'ggec', 'ggek', 'gget', 'ggep', 'ggeh', 'ggyeo', 'ggyeog', 'ggyeogg', 'ggyeogs', 'ggyeon', 'ggyeonj', 'ggyeonh', 'ggyeod', 'ggyeol', 'ggyeolg', 'ggyeolm', 'ggyeolb']

Documentation des variables

◆ return

return[ 'geul', 'geulg', 'geulm', 'geulb', 'geuls', 'geult', 'geulp', 'geulh', 'geum', 'geub', 'geubs', 'geus', 'geuss', 'geung', 'geuj', 'geuc', 'geuk', 'geut', 'geup', 'geuh', 'gyi', 'gyig', 'gyigg', 'gyigs', 'gyin', 'gyinj', 'gyinh', 'gyid', 'gyil', 'gyilg', 'gyilm', 'gyilb', 'gyils', 'gyilt', 'gyilp', 'gyilh', 'gyim', 'gyib', 'gyibs', 'gyis', 'gyiss', 'gying', 'gyij', 'gyic', 'gyik', 'gyit', 'gyip', 'gyih', 'gi', 'gig', 'gigg', 'gigs', 'gin', 'ginj', 'ginh', 'gid', 'gil', 'gilg', 'gilm', 'gilb', 'gils', 'gilt', 'gilp', 'gilh', 'gim', 'gib', 'gibs', 'gis', 'giss', 'ging', 'gij', 'gic', 'gik', 'git', 'gip', 'gih', 'gga', 'ggag', 'ggagg', 'ggags', 'ggan', 'gganj', 'gganh', 'ggad', 'ggal', 'ggalg', 'ggalm', 'ggalb', 'ggals', 'ggalt', 'ggalp', 'ggalh', 'ggam', 'ggab', 'ggabs', 'ggas', 'ggass', 'ggang', 'ggaj', 'ggac', 'ggak', 'ggat', 'ggap', 'ggah', 'ggae', 'ggaeg', 'ggaegg', 'ggaegs', 'ggaen', 'ggaenj', 'ggaenh', 'ggaed', 'ggael', 'ggaelg', 'ggaelm', 'ggaelb', 'ggaels', 'ggaelt', 'ggaelp', 'ggaelh', 'ggaem', 'ggaeb', 'ggaebs', 'ggaes', 'ggaess', 'ggaeng', 'ggaej', 'ggaec', 'ggaek', 'ggaet', 'ggaep', 'ggaeh', 'ggya', 'ggyag', 'ggyagg', 'ggyags', 'ggyan', 'ggyanj', 'ggyanh', 'ggyad', 'ggyal', 'ggyalg', 'ggyalm', 'ggyalb', 'ggyals', 'ggyalt', 'ggyalp', 'ggyalh', 'ggyam', 'ggyab', 'ggyabs', 'ggyas', 'ggyass', 'ggyang', 'ggyaj', 'ggyac', 'ggyak', 'ggyat', 'ggyap', 'ggyah', 'ggyae', 'ggyaeg', 'ggyaegg', 'ggyaegs', 'ggyaen', 'ggyaenj', 'ggyaenh', 'ggyaed', 'ggyael', 'ggyaelg', 'ggyaelm', 'ggyaelb', 'ggyaels', 'ggyaelt', 'ggyaelp', 'ggyaelh', 'ggyaem', 'ggyaeb', 'ggyaebs', 'ggyaes', 'ggyaess', 'ggyaeng', 'ggyaej', 'ggyaec', 'ggyaek', 'ggyaet', 'ggyaep', 'ggyaeh', 'ggeo', 'ggeog', 'ggeogg', 'ggeogs', 'ggeon', 'ggeonj', 'ggeonh', 'ggeod', 'ggeol', 'ggeolg', 'ggeolm', 'ggeolb', 'ggeols', 'ggeolt', 'ggeolp', 'ggeolh', 'ggeom', 'ggeob', 'ggeobs', 'ggeos', 'ggeoss', 'ggeong', 'ggeoj', 'ggeoc', 'ggeok', 'ggeot', 'ggeop', 'ggeoh', 'gge', 'ggeg', 'ggegg', 'ggegs', 'ggen', 'ggenj', 'ggenh', 'gged', 'ggel', 'ggelg', 'ggelm', 'ggelb', 'ggels', 'ggelt', 'ggelp', 'ggelh', 'ggem', 'ggeb', 'ggebs', 'gges', 'ggess', 'ggeng', 'ggej', 'ggec', 'ggek', 'gget', 'ggep', 'ggeh', 'ggyeo', 'ggyeog', 'ggyeogg', 'ggyeogs', 'ggyeon', 'ggyeonj', 'ggyeonh', 'ggyeod', 'ggyeol', 'ggyeolg', 'ggyeolm', 'ggyeolb']


Joomla CMS: Référence du fichier sect163k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect163k1.php

Structures de données

class sect163k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier UserModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier UserModel.php

Structures de données

class UserModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Model


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • http
  • src
  • Transport
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/http/src/Transport/Stream.php

Structures de données

class Stream

Espaces de nommage

Joomla\Http\Transport


Joomla CMS: Référence du fichier Table.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier src/Table/Table.php

Structures de données

class Table

Espaces de nommage

Joomla\CMS\Table


Joomla CMS: Référence du fichier x091.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x091.php

Variables

return ['Ruo ', 'Bei ', 'E ', 'Yu ', 'Juan ', 'Yu ', 'Yun ', 'Hou ', 'Kui ', 'Xiang ', 'Xiang ', 'Sou ', 'Tang ', 'Ming ', 'Xi ', 'Ru ', 'Chu ', 'Zi ', 'Zou ', 'Ju ', 'Wu ', 'Xiang ', 'Yun ', 'Hao ', 'Yong ', 'Bi ', 'Mo ', 'Chao ', 'Fu ', 'Liao ', 'Yin ', 'Zhuan ', 'Hu ', 'Qiao ', 'Yan ', 'Zhang ', 'Fan ', 'Qiao ', 'Xu ', 'Deng ', 'Bi ', 'Xin ', 'Bi ', 'Ceng ', 'Wei ', 'Zheng ', 'Mao ', 'Shan ', 'Lin ', 'Po ', 'Dan ', 'Meng ', 'Ye ', 'Cao ', 'Kuai ', 'Feng ', 'Meng ', 'Zou ', 'Kuang ', 'Lian ', 'Zan ', 'Chan ', 'You ', 'Qi ', 'Yan ', 'Chan ', 'Zan ', 'Ling ', 'Huan ', 'Xi ', 'Feng ', 'Zan ', 'Li ', 'You ', 'Ding ', 'Qiu ', 'Zhuo ', 'Pei ', 'Zhou ', 'Yi ', 'Hang ', 'Yu ', 'Jiu ', 'Yan ', 'Zui ', 'Mao ', 'Dan ', 'Xu ', 'Tou ', 'Zhen ', 'Fen ', 'Sakenomoto ', '[?] ', 'Yun ', 'Tai ', 'Tian ', 'Qia ', 'Tuo ', 'Zuo ', 'Han ', 'Gu ', 'Su ', 'Po ', 'Chou ', 'Zai ', 'Ming ', 'Luo ', 'Chuo ', 'Chou ', 'You ', 'Tong ', 'Zhi ', 'Xian ', 'Jiang ', 'Cheng ', 'Yin ', 'Tu ', 'Xiao ', 'Mei ', 'Ku ', 'Suan ', 'Lei ', 'Pu ', 'Zui ', 'Hai ', 'Yan ', 'Xi ', 'Niang ', 'Wei ', 'Lu ', 'Lan ', 'Yan ', 'Tao ', 'Pei ', 'Zhan ', 'Chun ', 'Tan ', 'Zui ', 'Chuo ', 'Cu ', 'Kun ', 'Ti ', 'Mian ', 'Du ', 'Hu ', 'Xu ', 'Xing ', 'Tan ', 'Jiu ', 'Chun ', 'Yun ', 'Po ', 'Ke ', 'Sou ', 'Mi ', 'Quan ', 'Chou ', 'Cuo ', 'Yun ', 'Yong ', 'Ang ', 'Zha ', 'Hai ', 'Tang ', 'Jiang ', 'Piao ', 'Shan ', 'Yu ', 'Li ', 'Zao ', 'Lao ', 'Yi ', 'Jiang ', 'Pu ', 'Jiao ', 'Xi ', 'Tan ', 'Po ', 'Nong ', 'Yi ', 'Li ', 'Ju ', 'Jiao ', 'Yi ', 'Niang ', 'Ru ', 'Xun ', 'Chou ', 'Yan ', 'Ling ', 'Mi ', 'Mi ', 'Niang ', 'Xin ', 'Jiao ', 'Xi ', 'Mi ', 'Yan ', 'Bian ', 'Cai ', 'Shi ', 'You ', 'Shi ', 'Shi ', 'Li ', 'Zhong ', 'Ye ', 'Liang ', 'Li ', 'Jin ', 'Jin ', 'Qiu ', 'Yi ', 'Diao ', 'Dao ', 'Zhao ', 'Ding ', 'Po ', 'Qiu ', 'He ', 'Fu ', 'Zhen ', 'Zhi ', 'Ba ', 'Luan ', 'Fu ', 'Nai ', 'Diao ', 'Shan ', 'Qiao ', 'Kou ', 'Chuan ', 'Zi ', 'Fan ', 'Yu ', 'Hua ', 'Han ', 'Gong ', 'Qi ', 'Mang ', 'Ri ', 'Di ', 'Si ', 'Xi ', 'Yi ', 'Chai ', 'Shi ', 'Tu ', 'Xi ', 'Nu ', 'Qian ', 'Ishiyumi ', 'Jian ', 'Pi ', 'Ye ', 'Yin ']

Documentation des variables

◆ return

return[ 'Ruo ', 'Bei ', 'E ', 'Yu ', 'Juan ', 'Yu ', 'Yun ', 'Hou ', 'Kui ', 'Xiang ', 'Xiang ', 'Sou ', 'Tang ', 'Ming ', 'Xi ', 'Ru ', 'Chu ', 'Zi ', 'Zou ', 'Ju ', 'Wu ', 'Xiang ', 'Yun ', 'Hao ', 'Yong ', 'Bi ', 'Mo ', 'Chao ', 'Fu ', 'Liao ', 'Yin ', 'Zhuan ', 'Hu ', 'Qiao ', 'Yan ', 'Zhang ', 'Fan ', 'Qiao ', 'Xu ', 'Deng ', 'Bi ', 'Xin ', 'Bi ', 'Ceng ', 'Wei ', 'Zheng ', 'Mao ', 'Shan ', 'Lin ', 'Po ', 'Dan ', 'Meng ', 'Ye ', 'Cao ', 'Kuai ', 'Feng ', 'Meng ', 'Zou ', 'Kuang ', 'Lian ', 'Zan ', 'Chan ', 'You ', 'Qi ', 'Yan ', 'Chan ', 'Zan ', 'Ling ', 'Huan ', 'Xi ', 'Feng ', 'Zan ', 'Li ', 'You ', 'Ding ', 'Qiu ', 'Zhuo ', 'Pei ', 'Zhou ', 'Yi ', 'Hang ', 'Yu ', 'Jiu ', 'Yan ', 'Zui ', 'Mao ', 'Dan ', 'Xu ', 'Tou ', 'Zhen ', 'Fen ', 'Sakenomoto ', '[?] ', 'Yun ', 'Tai ', 'Tian ', 'Qia ', 'Tuo ', 'Zuo ', 'Han ', 'Gu ', 'Su ', 'Po ', 'Chou ', 'Zai ', 'Ming ', 'Luo ', 'Chuo ', 'Chou ', 'You ', 'Tong ', 'Zhi ', 'Xian ', 'Jiang ', 'Cheng ', 'Yin ', 'Tu ', 'Xiao ', 'Mei ', 'Ku ', 'Suan ', 'Lei ', 'Pu ', 'Zui ', 'Hai ', 'Yan ', 'Xi ', 'Niang ', 'Wei ', 'Lu ', 'Lan ', 'Yan ', 'Tao ', 'Pei ', 'Zhan ', 'Chun ', 'Tan ', 'Zui ', 'Chuo ', 'Cu ', 'Kun ', 'Ti ', 'Mian ', 'Du ', 'Hu ', 'Xu ', 'Xing ', 'Tan ', 'Jiu ', 'Chun ', 'Yun ', 'Po ', 'Ke ', 'Sou ', 'Mi ', 'Quan ', 'Chou ', 'Cuo ', 'Yun ', 'Yong ', 'Ang ', 'Zha ', 'Hai ', 'Tang ', 'Jiang ', 'Piao ', 'Shan ', 'Yu ', 'Li ', 'Zao ', 'Lao ', 'Yi ', 'Jiang ', 'Pu ', 'Jiao ', 'Xi ', 'Tan ', 'Po ', 'Nong ', 'Yi ', 'Li ', 'Ju ', 'Jiao ', 'Yi ', 'Niang ', 'Ru ', 'Xun ', 'Chou ', 'Yan ', 'Ling ', 'Mi ', 'Mi ', 'Niang ', 'Xin ', 'Jiao ', 'Xi ', 'Mi ', 'Yan ', 'Bian ', 'Cai ', 'Shi ', 'You ', 'Shi ', 'Shi ', 'Li ', 'Zhong ', 'Ye ', 'Liang ', 'Li ', 'Jin ', 'Jin ', 'Qiu ', 'Yi ', 'Diao ', 'Dao ', 'Zhao ', 'Ding ', 'Po ', 'Qiu ', 'He ', 'Fu ', 'Zhen ', 'Zhi ', 'Ba ', 'Luan ', 'Fu ', 'Nai ', 'Diao ', 'Shan ', 'Qiao ', 'Kou ', 'Chuan ', 'Zi ', 'Fan ', 'Yu ', 'Hua ', 'Han ', 'Gong ', 'Qi ', 'Mang ', 'Ri ', 'Di ', 'Si ', 'Xi ', 'Yi ', 'Chai ', 'Shi ', 'Tu ', 'Xi ', 'Nu ', 'Qian ', 'Ishiyumi ', 'Jian ', 'Pi ', 'Ye ', 'Yin ']


Joomla CMS: Référence du fichier Stem.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • wamania
  • php-stemmer
  • src
  • Stemmer
Structures de données | Espaces de nommage
Référence du fichier Stem.php

Structures de données

class Stem

Espaces de nommage

Wamania\Snowball\Stemmer


Joomla CMS: Référence du fichier UploadedFileAlreadyMovedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UploadedFileAlreadyMovedException.php

Structures de données

class UploadedFileAlreadyMovedException

Espaces de nommage

Laminas\Diactoros\Exception


Joomla CMS: Référence du fichier TagModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Model/TagModel.php

Structures de données

class TagModel

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Model


Joomla CMS: Référence du fichier sect571r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect571r1.php

Structures de données

class sect571r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier PharExtensionInterceptor.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • typo3
  • phar-stream-wrapper
  • src
  • Interceptor
Structures de données | Espaces de nommage
Référence du fichier PharExtensionInterceptor.php

Structures de données

class PharExtensionInterceptor

Espaces de nommage

TYPO3\PharStreamWrapper\Interceptor


Joomla CMS: Référence du fichier x060.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x060.php

Variables

return ['Huai ', 'Tai ', 'Song ', 'Wu ', 'Ou ', 'Chang ', 'Chuang ', 'Ju ', 'Yi ', 'Bao ', 'Chao ', 'Min ', 'Pei ', 'Zuo ', 'Zen ', 'Yang ', 'Kou ', 'Ban ', 'Nu ', 'Nao ', 'Zheng ', 'Pa ', 'Bu ', 'Tie ', 'Gu ', 'Hu ', 'Ju ', 'Da ', 'Lian ', 'Si ', 'Chou ', 'Di ', 'Dai ', 'Yi ', 'Tu ', 'You ', 'Fu ', 'Ji ', 'Peng ', 'Xing ', 'Yuan ', 'Ni ', 'Guai ', 'Fu ', 'Xi ', 'Bi ', 'You ', 'Qie ', 'Xuan ', 'Cong ', 'Bing ', 'Huang ', 'Xu ', 'Chu ', 'Pi ', 'Xi ', 'Xi ', 'Tan ', 'Koraeru ', 'Zong ', 'Dui ', '[?] ', 'Ki ', 'Yi ', 'Chi ', 'Ren ', 'Xun ', 'Shi ', 'Xi ', 'Lao ', 'Heng ', 'Kuang ', 'Mu ', 'Zhi ', 'Xie ', 'Lian ', 'Tiao ', 'Huang ', 'Die ', 'Hao ', 'Kong ', 'Gui ', 'Heng ', 'Xi ', 'Xiao ', 'Shu ', 'S ', 'Kua ', 'Qiu ', 'Yang ', 'Hui ', 'Hui ', 'Chi ', 'Jia ', 'Yi ', 'Xiong ', 'Guai ', 'Lin ', 'Hui ', 'Zi ', 'Xu ', 'Chi ', 'Xiang ', 'Nu ', 'Hen ', 'En ', 'Ke ', 'Tong ', 'Tian ', 'Gong ', 'Quan ', 'Xi ', 'Qia ', 'Yue ', 'Peng ', 'Ken ', 'De ', 'Hui ', 'E ', 'Kyuu ', 'Tong ', 'Yan ', 'Kai ', 'Ce ', 'Nao ', 'Yun ', 'Mang ', 'Yong ', 'Yong ', 'Yuan ', 'Pi ', 'Kun ', 'Qiao ', 'Yue ', 'Yu ', 'Yu ', 'Jie ', 'Xi ', 'Zhe ', 'Lin ', 'Ti ', 'Han ', 'Hao ', 'Qie ', 'Ti ', 'Bu ', 'Yi ', 'Qian ', 'Hui ', 'Xi ', 'Bei ', 'Man ', 'Yi ', 'Heng ', 'Song ', 'Quan ', 'Cheng ', 'Hui ', 'Wu ', 'Wu ', 'You ', 'Li ', 'Liang ', 'Huan ', 'Cong ', 'Yi ', 'Yue ', 'Li ', 'Nin ', 'Nao ', 'E ', 'Que ', 'Xuan ', 'Qian ', 'Wu ', 'Min ', 'Cong ', 'Fei ', 'Bei ', 'Duo ', 'Cui ', 'Chang ', 'Men ', 'Li ', 'Ji ', 'Guan ', 'Guan ', 'Xing ', 'Dao ', 'Qi ', 'Kong ', 'Tian ', 'Lun ', 'Xi ', 'Kan ', 'Kun ', 'Ni ', 'Qing ', 'Chou ', 'Dun ', 'Guo ', 'Chan ', 'Liang ', 'Wan ', 'Yuan ', 'Jin ', 'Ji ', 'Lin ', 'Yu ', 'Huo ', 'He ', 'Quan ', 'Tan ', 'Ti ', 'Ti ', 'Nie ', 'Wang ', 'Chuo ', 'Bu ', 'Hun ', 'Xi ', 'Tang ', 'Xin ', 'Wei ', 'Hui ', 'E ', 'Rui ', 'Zong ', 'Jian ', 'Yong ', 'Dian ', 'Ju ', 'Can ', 'Cheng ', 'De ', 'Bei ', 'Qie ', 'Can ', 'Dan ', 'Guan ', 'Duo ', 'Nao ', 'Yun ', 'Xiang ', 'Zhui ', 'Die ', 'Huang ', 'Chun ', 'Qiong ', 'Re ', 'Xing ', 'Ce ', 'Bian ', 'Hun ', 'Zong ', 'Ti ']

Documentation des variables

◆ return

return[ 'Huai ', 'Tai ', 'Song ', 'Wu ', 'Ou ', 'Chang ', 'Chuang ', 'Ju ', 'Yi ', 'Bao ', 'Chao ', 'Min ', 'Pei ', 'Zuo ', 'Zen ', 'Yang ', 'Kou ', 'Ban ', 'Nu ', 'Nao ', 'Zheng ', 'Pa ', 'Bu ', 'Tie ', 'Gu ', 'Hu ', 'Ju ', 'Da ', 'Lian ', 'Si ', 'Chou ', 'Di ', 'Dai ', 'Yi ', 'Tu ', 'You ', 'Fu ', 'Ji ', 'Peng ', 'Xing ', 'Yuan ', 'Ni ', 'Guai ', 'Fu ', 'Xi ', 'Bi ', 'You ', 'Qie ', 'Xuan ', 'Cong ', 'Bing ', 'Huang ', 'Xu ', 'Chu ', 'Pi ', 'Xi ', 'Xi ', 'Tan ', 'Koraeru ', 'Zong ', 'Dui ', '[?] ', 'Ki ', 'Yi ', 'Chi ', 'Ren ', 'Xun ', 'Shi ', 'Xi ', 'Lao ', 'Heng ', 'Kuang ', 'Mu ', 'Zhi ', 'Xie ', 'Lian ', 'Tiao ', 'Huang ', 'Die ', 'Hao ', 'Kong ', 'Gui ', 'Heng ', 'Xi ', 'Xiao ', 'Shu ', 'S ', 'Kua ', 'Qiu ', 'Yang ', 'Hui ', 'Hui ', 'Chi ', 'Jia ', 'Yi ', 'Xiong ', 'Guai ', 'Lin ', 'Hui ', 'Zi ', 'Xu ', 'Chi ', 'Xiang ', 'Nu ', 'Hen ', 'En ', 'Ke ', 'Tong ', 'Tian ', 'Gong ', 'Quan ', 'Xi ', 'Qia ', 'Yue ', 'Peng ', 'Ken ', 'De ', 'Hui ', 'E ', 'Kyuu ', 'Tong ', 'Yan ', 'Kai ', 'Ce ', 'Nao ', 'Yun ', 'Mang ', 'Yong ', 'Yong ', 'Yuan ', 'Pi ', 'Kun ', 'Qiao ', 'Yue ', 'Yu ', 'Yu ', 'Jie ', 'Xi ', 'Zhe ', 'Lin ', 'Ti ', 'Han ', 'Hao ', 'Qie ', 'Ti ', 'Bu ', 'Yi ', 'Qian ', 'Hui ', 'Xi ', 'Bei ', 'Man ', 'Yi ', 'Heng ', 'Song ', 'Quan ', 'Cheng ', 'Hui ', 'Wu ', 'Wu ', 'You ', 'Li ', 'Liang ', 'Huan ', 'Cong ', 'Yi ', 'Yue ', 'Li ', 'Nin ', 'Nao ', 'E ', 'Que ', 'Xuan ', 'Qian ', 'Wu ', 'Min ', 'Cong ', 'Fei ', 'Bei ', 'Duo ', 'Cui ', 'Chang ', 'Men ', 'Li ', 'Ji ', 'Guan ', 'Guan ', 'Xing ', 'Dao ', 'Qi ', 'Kong ', 'Tian ', 'Lun ', 'Xi ', 'Kan ', 'Kun ', 'Ni ', 'Qing ', 'Chou ', 'Dun ', 'Guo ', 'Chan ', 'Liang ', 'Wan ', 'Yuan ', 'Jin ', 'Ji ', 'Lin ', 'Yu ', 'Huo ', 'He ', 'Quan ', 'Tan ', 'Ti ', 'Ti ', 'Nie ', 'Wang ', 'Chuo ', 'Bu ', 'Hun ', 'Xi ', 'Tang ', 'Xin ', 'Wei ', 'Hui ', 'E ', 'Rui ', 'Zong ', 'Jian ', 'Yong ', 'Dian ', 'Ju ', 'Can ', 'Cheng ', 'De ', 'Bei ', 'Qie ', 'Can ', 'Dan ', 'Guan ', 'Duo ', 'Nao ', 'Yun ', 'Xiang ', 'Zhui ', 'Die ', 'Huang ', 'Chun ', 'Qiong ', 'Re ', 'Xing ', 'Ce ', 'Bian ', 'Hun ', 'Zong ', 'Ti ']


Joomla CMS: Référence du fichier user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • user
Structures de données | Espaces de nommage
Référence du fichier plugins/fields/user/user.php

Structures de données

class PlgFieldsUser

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RawFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier RawFilter.php

Structures de données

class RawFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier StringController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Filesystem
  • Support
Structures de données | Espaces de nommage
Référence du fichier src/Filesystem/Support/StringController.php

Structures de données

class StringController

Espaces de nommage

Joomla\CMS\Filesystem\Support


Joomla CMS: Référence du fichier UCMType.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • UCM
Structures de données | Espaces de nommage
Référence du fichier UCMType.php

Structures de données

class UCMType

Espaces de nommage

Joomla\CMS\UCM


Joomla CMS: Référence du fichier UserstateField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier UserstateField.php

Structures de données

class UserstateField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier XML.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/XML.php

Structures de données

class XML

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier Zh.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Indexer
  • Language
Structures de données | Espaces de nommage
Référence du fichier Zh.php

Structures de données

class Zh

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Indexer\Language


Joomla CMS: Référence du fichier x012.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x012.php

Variables

return ['ha', 'hu', 'hi', 'haa', 'hee', 'he', 'ho', '[?]', 'la', 'lu', 'li', 'laa', 'lee', 'le', 'lo', 'lwa', 'hha', 'hhu', 'hhi', 'hhaa', 'hhee', 'hhe', 'hho', 'hhwa', 'ma', 'mu', 'mi', 'maa', 'mee', 'me', 'mo', 'mwa', 'sza', 'szu', 'szi', 'szaa', 'szee', 'sze', 'szo', 'szwa', 'ra', 'ru', 'ri', 'raa', 'ree', 're', 'ro', 'rwa', 'sa', 'su', 'si', 'saa', 'see', 'se', 'so', 'swa', 'sha', 'shu', 'shi', 'shaa', 'shee', 'she', 'sho', 'shwa', 'qa', 'qu', 'qi', 'qaa', 'qee', 'qe', 'qo', '[?]', 'qwa', '[?]', 'qwi', 'qwaa', 'qwee', 'qwe', '[?]', '[?]', 'qha', 'qhu', 'qhi', 'qhaa', 'qhee', 'qhe', 'qho', '[?]', 'qhwa', '[?]', 'qhwi', 'qhwaa', 'qhwee', 'qhwe', '[?]', '[?]', 'ba', 'bu', 'bi', 'baa', 'bee', 'be', 'bo', 'bwa', 'va', 'vu', 'vi', 'vaa', 'vee', 've', 'vo', 'vwa', 'ta', 'tu', 'ti', 'taa', 'tee', 'te', 'to', 'twa', 'ca', 'cu', 'ci', 'caa', 'cee', 'ce', 'co', 'cwa', 'xa', 'xu', 'xi', 'xaa', 'xee', 'xe', 'xo', '[?]', 'xwa', '[?]', 'xwi', 'xwaa', 'xwee', 'xwe', '[?]', '[?]', 'na', 'nu', 'ni', 'naa', 'nee', 'ne', 'no', 'nwa', 'nya', 'nyu', 'nyi', 'nyaa', 'nyee', 'nye', 'nyo', 'nywa', '\ 'a', '\ 'u', '[?]', '\ 'aa', '\ 'ee', '\ 'e', '\ 'o', '\ 'wa', 'ka', 'ku', 'ki', 'kaa', 'kee', 'ke', 'ko', '[?]', 'kwa', '[?]', 'kwi', 'kwaa', 'kwee', 'kwe', '[?]', '[?]', 'kxa', 'kxu', 'kxi', 'kxaa', 'kxee', 'kxe', 'kxo', '[?]', 'kxwa', '[?]', 'kxwi', 'kxwaa', 'kxwee', 'kxwe', '[?]', '[?]', 'wa', 'wu', 'wi', 'waa', 'wee', 'we', 'wo', '[?]', '`a', '`u', '`i', '`aa', '`ee', '`e', '`o', '[?]', 'za', 'zu', 'zi', 'zaa', 'zee', 'ze', 'zo', 'zwa', 'zha', 'zhu', 'zhi', 'zhaa', 'zhee', 'zhe', 'zho', 'zhwa', 'ya', 'yu', 'yi', 'yaa', 'yee', 'ye', 'yo', '[?]', 'da', 'du', 'di', 'daa', 'dee', 'de', 'do', 'dwa', 'dda', 'ddu', 'ddi', 'ddaa', 'ddee', 'dde', 'ddo', 'ddwa']

Documentation des variables

◆ return

return[ 'ha', 'hu', 'hi', 'haa', 'hee', 'he', 'ho', '[?]', 'la', 'lu', 'li', 'laa', 'lee', 'le', 'lo', 'lwa', 'hha', 'hhu', 'hhi', 'hhaa', 'hhee', 'hhe', 'hho', 'hhwa', 'ma', 'mu', 'mi', 'maa', 'mee', 'me', 'mo', 'mwa', 'sza', 'szu', 'szi', 'szaa', 'szee', 'sze', 'szo', 'szwa', 'ra', 'ru', 'ri', 'raa', 'ree', 're', 'ro', 'rwa', 'sa', 'su', 'si', 'saa', 'see', 'se', 'so', 'swa', 'sha', 'shu', 'shi', 'shaa', 'shee', 'she', 'sho', 'shwa', 'qa', 'qu', 'qi', 'qaa', 'qee', 'qe', 'qo', '[?]', 'qwa', '[?]', 'qwi', 'qwaa', 'qwee', 'qwe', '[?]', '[?]', 'qha', 'qhu', 'qhi', 'qhaa', 'qhee', 'qhe', 'qho', '[?]', 'qhwa', '[?]', 'qhwi', 'qhwaa', 'qhwee', 'qhwe', '[?]', '[?]', 'ba', 'bu', 'bi', 'baa', 'bee', 'be', 'bo', 'bwa', 'va', 'vu', 'vi', 'vaa', 'vee', 've', 'vo', 'vwa', 'ta', 'tu', 'ti', 'taa', 'tee', 'te', 'to', 'twa', 'ca', 'cu', 'ci', 'caa', 'cee', 'ce', 'co', 'cwa', 'xa', 'xu', 'xi', 'xaa', 'xee', 'xe', 'xo', '[?]', 'xwa', '[?]', 'xwi', 'xwaa', 'xwee', 'xwe', '[?]', '[?]', 'na', 'nu', 'ni', 'naa', 'nee', 'ne', 'no', 'nwa', 'nya', 'nyu', 'nyi', 'nyaa', 'nyee', 'nye', 'nyo', 'nywa', '\ 'a', '\ 'u', '[?]', '\ 'aa', '\ 'ee', '\ 'e', '\ 'o', '\ 'wa', 'ka', 'ku', 'ki', 'kaa', 'kee', 'ke', 'ko', '[?]', 'kwa', '[?]', 'kwi', 'kwaa', 'kwee', 'kwe', '[?]', '[?]', 'kxa', 'kxu', 'kxi', 'kxaa', 'kxee', 'kxe', 'kxo', '[?]', 'kxwa', '[?]', 'kxwi', 'kxwaa', 'kxwee', 'kxwe', '[?]', '[?]', 'wa', 'wu', 'wi', 'waa', 'wee', 'we', 'wo', '[?]', '`a', '`u', '`i', '`aa', '`ee', '`e', '`o', '[?]', 'za', 'zu', 'zi', 'zaa', 'zee', 'ze', 'zo', 'zwa', 'zha', 'zhu', 'zhi', 'zhaa', 'zhee', 'zhe', 'zho', 'zhwa', 'ya', 'yu', 'yi', 'yaa', 'yee', 'ye', 'yo', '[?]', 'da', 'du', 'di', 'daa', 'dee', 'de', 'do', 'dwa', 'dda', 'ddu', 'ddi', 'ddaa', 'ddee', 'dde', 'ddo', 'ddwa']


Joomla CMS: Référence du fichier user.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • user
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/user/tmpl/user.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
$texts = array()
foreach ( $value as $userId)

Documentation des variables

◆ $texts

$texts = array()

◆ $value

if ( $value=='') $value = $field->value

◆ foreach

foreach($value as $userId)


Joomla CMS: Référence du fichier Poly1305.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/Poly1305.php

Structures de données

class ParagonIE_Sodium_Core32_Poly1305


Joomla CMS: Référence du fichier Validate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier Validate.php

Structures de données

class Validate

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier SessionAwareWebApplicationTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • application
  • src
Espaces de nommage | Fonctions | Variables
Référence du fichier SessionAwareWebApplicationTrait.php

Espaces de nommage

Joomla\Application

Fonctions

getInput ()
getSession ()
setSession (SessionInterface $session)
checkToken ($method='post')
getFormToken ($forceNew=false)

Variables

trait SessionAwareWebApplicationTrait


Joomla CMS: Référence du fichier ServiceSubscriberInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Structures de données | Espaces de nommage
Référence du fichier ServiceSubscriberInterface.php

Structures de données

interface ServiceSubscriberInterface

Espaces de nommage

Symfony\Contracts\Service


Joomla CMS: Référence du fichier PostgresqlQueryBuilder.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Query
Espaces de nommage | Fonctions | Variables
Référence du fichier PostgresqlQueryBuilder.php

Espaces de nommage

Joomla\Database\Query

Fonctions

__toString ()
clear ($clause=null)
castAs (string $type, string $value, ?string $length=null)
concatenate ($values, $separator=null)
currentTimestamp ()
forUpdate ($tableName, $glue=',')
forShare ($tableName, $glue=',')
groupConcat ($expression, $separator=',')
year ($date)
month ($date)
day ($date)
hour ($date)
minute ($date)
second ($date)
noWait ()
limit ($limit=0)
offset ($offset=0)
returning ($pkCol)
processLimit ($query, $limit, $offset=0)
dateAdd ($date, $interval, $datePart)
regexp ($value)
rand ()
findInSet ($value, $set)

Variables

trait PostgresqlQueryBuilder
$forShare
$noWait
$limit
$offset
$returning


Joomla CMS: Référence du fichier StatisticsModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_finder
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier StatisticsModel.php

Structures de données

class StatisticsModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Finder\Administrator\Model


Joomla CMS: Référence du fichier System.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_admin
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier System.php

Structures de données

class System

Espaces de nommage

Joomla\Administrator
Joomla\Component\Admin\Administrator\Service\HTML


Joomla CMS: Référence du fichier UiTab.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier UiTab.php

Structures de données

class UiTab

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier PuTTY.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier DSA/Formats/Keys/PuTTY.php

Structures de données

class PuTTY

Espaces de nommage

DSA
phpseclib3\Crypt\DSA\Formats\Keys


Joomla CMS: Référence du fichier x07e.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x07e.php

Variables

return ['Xia ', 'Yuan ', 'Zong ', 'Xu ', 'Nawa ', 'Odoshi ', 'Geng ', 'Sen ', 'Ying ', 'Jin ', 'Yi ', 'Zhui ', 'Ni ', 'Bang ', 'Gu ', 'Pan ', 'Zhou ', 'Jian ', 'Cuo ', 'Quan ', 'Shuang ', 'Yun ', 'Xia ', 'Shuai ', 'Xi ', 'Rong ', 'Tao ', 'Fu ', 'Yun ', 'Zhen ', 'Gao ', 'Ru ', 'Hu ', 'Zai ', 'Teng ', 'Xian ', 'Su ', 'Zhen ', 'Zong ', 'Tao ', 'Horo ', 'Cai ', 'Bi ', 'Feng ', 'Cu ', 'Li ', 'Suo ', 'Yin ', 'Xi ', 'Zong ', 'Lei ', 'Zhuan ', 'Qian ', 'Man ', 'Zhi ', 'Lu ', 'Mo ', 'Piao ', 'Lian ', 'Mi ', 'Xuan ', 'Zong ', 'Ji ', 'Shan ', 'Sui ', 'Fan ', 'Shuai ', 'Beng ', 'Yi ', 'Sao ', 'Mou ', 'Zhou ', 'Qiang ', 'Hun ', 'Sem ', 'Xi ', 'Jung ', 'Xiu ', 'Ran ', 'Xuan ', 'Hui ', 'Qiao ', 'Zeng ', 'Zuo ', 'Zhi ', 'Shan ', 'San ', 'Lin ', 'Yu ', 'Fan ', 'Liao ', 'Chuo ', 'Zun ', 'Jian ', 'Rao ', 'Chan ', 'Rui ', 'Xiu ', 'Hui ', 'Hua ', 'Zuan ', 'Xi ', 'Qiang ', 'Un ', 'Da ', 'Sheng ', 'Hui ', 'Xi ', 'Se ', 'Jian ', 'Jiang ', 'Huan ', 'Zao ', 'Cong ', 'Jie ', 'Jiao ', 'Bo ', 'Chan ', 'Yi ', 'Nao ', 'Sui ', 'Yi ', 'Shai ', 'Xu ', 'Ji ', 'Bin ', 'Qian ', 'Lan ', 'Pu ', 'Xun ', 'Zuan ', 'Qi ', 'Peng ', 'Li ', 'Mo ', 'Lei ', 'Xie ', 'Zuan ', 'Kuang ', 'You ', 'Xu ', 'Lei ', 'Xian ', 'Chan ', 'Kou ', 'Lu ', 'Chan ', 'Ying ', 'Cai ', 'Xiang ', 'Xian ', 'Zui ', 'Zuan ', 'Luo ', 'Xi ', 'Dao ', 'Lan ', 'Lei ', 'Lian ', 'Si ', 'Jiu ', 'Yu ', 'Hong ', 'Zhou ', 'Xian ', 'He ', 'Yue ', 'Ji ', 'Wan ', 'Kuang ', 'Ji ', 'Ren ', 'Wei ', 'Yun ', 'Hong ', 'Chun ', 'Pi ', 'Sha ', 'Gang ', 'Na ', 'Ren ', 'Zong ', 'Lun ', 'Fen ', 'Zhi ', 'Wen ', 'Fang ', 'Zhu ', 'Yin ', 'Niu ', 'Shu ', 'Xian ', 'Gan ', 'Xie ', 'Fu ', 'Lian ', 'Zu ', 'Shen ', 'Xi ', 'Zhi ', 'Zhong ', 'Zhou ', 'Ban ', 'Fu ', 'Zhuo ', 'Shao ', 'Yi ', 'Jing ', 'Dai ', 'Bang ', 'Rong ', 'Jie ', 'Ku ', 'Rao ', 'Die ', 'Heng ', 'Hui ', 'Gei ', 'Xuan ', 'Jiang ', 'Luo ', 'Jue ', 'Jiao ', 'Tong ', 'Geng ', 'Xiao ', 'Juan ', 'Xiu ', 'Xi ', 'Sui ', 'Tao ', 'Ji ', 'Ti ', 'Ji ', 'Xu ', 'Ling ', '[?] ', 'Xu ', 'Qi ', 'Fei ', 'Chuo ', 'Zhang ', 'Gun ', 'Sheng ', 'Wei ', 'Mian ', 'Shou ', 'Beng ', 'Chou ', 'Tao ', 'Liu ', 'Quan ', 'Zong ', 'Zhan ', 'Wan ', 'Lu ']

Documentation des variables

◆ return

return[ 'Xia ', 'Yuan ', 'Zong ', 'Xu ', 'Nawa ', 'Odoshi ', 'Geng ', 'Sen ', 'Ying ', 'Jin ', 'Yi ', 'Zhui ', 'Ni ', 'Bang ', 'Gu ', 'Pan ', 'Zhou ', 'Jian ', 'Cuo ', 'Quan ', 'Shuang ', 'Yun ', 'Xia ', 'Shuai ', 'Xi ', 'Rong ', 'Tao ', 'Fu ', 'Yun ', 'Zhen ', 'Gao ', 'Ru ', 'Hu ', 'Zai ', 'Teng ', 'Xian ', 'Su ', 'Zhen ', 'Zong ', 'Tao ', 'Horo ', 'Cai ', 'Bi ', 'Feng ', 'Cu ', 'Li ', 'Suo ', 'Yin ', 'Xi ', 'Zong ', 'Lei ', 'Zhuan ', 'Qian ', 'Man ', 'Zhi ', 'Lu ', 'Mo ', 'Piao ', 'Lian ', 'Mi ', 'Xuan ', 'Zong ', 'Ji ', 'Shan ', 'Sui ', 'Fan ', 'Shuai ', 'Beng ', 'Yi ', 'Sao ', 'Mou ', 'Zhou ', 'Qiang ', 'Hun ', 'Sem ', 'Xi ', 'Jung ', 'Xiu ', 'Ran ', 'Xuan ', 'Hui ', 'Qiao ', 'Zeng ', 'Zuo ', 'Zhi ', 'Shan ', 'San ', 'Lin ', 'Yu ', 'Fan ', 'Liao ', 'Chuo ', 'Zun ', 'Jian ', 'Rao ', 'Chan ', 'Rui ', 'Xiu ', 'Hui ', 'Hua ', 'Zuan ', 'Xi ', 'Qiang ', 'Un ', 'Da ', 'Sheng ', 'Hui ', 'Xi ', 'Se ', 'Jian ', 'Jiang ', 'Huan ', 'Zao ', 'Cong ', 'Jie ', 'Jiao ', 'Bo ', 'Chan ', 'Yi ', 'Nao ', 'Sui ', 'Yi ', 'Shai ', 'Xu ', 'Ji ', 'Bin ', 'Qian ', 'Lan ', 'Pu ', 'Xun ', 'Zuan ', 'Qi ', 'Peng ', 'Li ', 'Mo ', 'Lei ', 'Xie ', 'Zuan ', 'Kuang ', 'You ', 'Xu ', 'Lei ', 'Xian ', 'Chan ', 'Kou ', 'Lu ', 'Chan ', 'Ying ', 'Cai ', 'Xiang ', 'Xian ', 'Zui ', 'Zuan ', 'Luo ', 'Xi ', 'Dao ', 'Lan ', 'Lei ', 'Lian ', 'Si ', 'Jiu ', 'Yu ', 'Hong ', 'Zhou ', 'Xian ', 'He ', 'Yue ', 'Ji ', 'Wan ', 'Kuang ', 'Ji ', 'Ren ', 'Wei ', 'Yun ', 'Hong ', 'Chun ', 'Pi ', 'Sha ', 'Gang ', 'Na ', 'Ren ', 'Zong ', 'Lun ', 'Fen ', 'Zhi ', 'Wen ', 'Fang ', 'Zhu ', 'Yin ', 'Niu ', 'Shu ', 'Xian ', 'Gan ', 'Xie ', 'Fu ', 'Lian ', 'Zu ', 'Shen ', 'Xi ', 'Zhi ', 'Zhong ', 'Zhou ', 'Ban ', 'Fu ', 'Zhuo ', 'Shao ', 'Yi ', 'Jing ', 'Dai ', 'Bang ', 'Rong ', 'Jie ', 'Ku ', 'Rao ', 'Die ', 'Heng ', 'Hui ', 'Gei ', 'Xuan ', 'Jiang ', 'Luo ', 'Jue ', 'Jiao ', 'Tong ', 'Geng ', 'Xiao ', 'Juan ', 'Xiu ', 'Xi ', 'Sui ', 'Tao ', 'Ji ', 'Ti ', 'Ji ', 'Xu ', 'Ling ', '[?] ', 'Xu ', 'Qi ', 'Fei ', 'Chuo ', 'Zhang ', 'Gun ', 'Sheng ', 'Wei ', 'Mian ', 'Shou ', 'Beng ', 'Chou ', 'Tao ', 'Liu ', 'Quan ', 'Zong ', 'Zhan ', 'Wan ', 'Lu ']


Joomla CMS: Référence du fichier SaveSetup.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • MultiFactor
Structures de données | Espaces de nommage
Référence du fichier SaveSetup.php

Structures de données

class SaveSetup

Espaces de nommage

Joomla\CMS\Event\MultiFactor


Joomla CMS: Référence du fichier TraceableTwigEnvironment.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • maximebf
  • debugbar
  • src
  • DebugBar
  • Bridge
  • Twig
Structures de données | Espaces de nommage
Référence du fichier TraceableTwigEnvironment.php

Structures de données

class TraceableTwigEnvironment

Espaces de nommage

DebugBar\Bridge\Twig


Joomla CMS: Référence du fichier x090.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x090.php

Variables

return ['Tui ', 'Song ', 'Gua ', 'Tao ', 'Pang ', 'Hou ', 'Ni ', 'Dun ', 'Jiong ', 'Xuan ', 'Xun ', 'Bu ', 'You ', 'Xiao ', 'Qiu ', 'Tou ', 'Zhu ', 'Qiu ', 'Di ', 'Di ', 'Tu ', 'Jing ', 'Ti ', 'Dou ', 'Yi ', 'Zhe ', 'Tong ', 'Guang ', 'Wu ', 'Shi ', 'Cheng ', 'Su ', 'Zao ', 'Qun ', 'Feng ', 'Lian ', 'Suo ', 'Hui ', 'Li ', 'Sako ', 'Lai ', 'Ben ', 'Cuo ', 'Jue ', 'Beng ', 'Huan ', 'Dai ', 'Lu ', 'You ', 'Zhou ', 'Jin ', 'Yu ', 'Chuo ', 'Kui ', 'Wei ', 'Ti ', 'Yi ', 'Da ', 'Yuan ', 'Luo ', 'Bi ', 'Nuo ', 'Yu ', 'Dang ', 'Sui ', 'Dun ', 'Sui ', 'Yan ', 'Chuan ', 'Chi ', 'Ti ', 'Yu ', 'Shi ', 'Zhen ', 'You ', 'Yun ', 'E ', 'Bian ', 'Guo ', 'E ', 'Xia ', 'Huang ', 'Qiu ', 'Dao ', 'Da ', 'Wei ', 'Appare ', 'Yi ', 'Gou ', 'Yao ', 'Chu ', 'Liu ', 'Xun ', 'Ta ', 'Di ', 'Chi ', 'Yuan ', 'Su ', 'Ta ', 'Qian ', '[?] ', 'Yao ', 'Guan ', 'Zhang ', 'Ao ', 'Shi ', 'Ce ', 'Chi ', 'Su ', 'Zao ', 'Zhe ', 'Dun ', 'Di ', 'Lou ', 'Chi ', 'Cuo ', 'Lin ', 'Zun ', 'Rao ', 'Qian ', 'Xuan ', 'Yu ', 'Yi ', 'Wu ', 'Liao ', 'Ju ', 'Shi ', 'Bi ', 'Yao ', 'Mai ', 'Xie ', 'Sui ', 'Huan ', 'Zhan ', 'Teng ', 'Er ', 'Miao ', 'Bian ', 'Bian ', 'La ', 'Li ', 'Yuan ', 'Yao ', 'Luo ', 'Li ', 'Yi ', 'Ting ', 'Deng ', 'Qi ', 'Yong ', 'Shan ', 'Han ', 'Yu ', 'Mang ', 'Ru ', 'Qiong ', '[?] ', 'Kuang ', 'Fu ', 'Kang ', 'Bin ', 'Fang ', 'Xing ', 'Na ', 'Xin ', 'Shen ', 'Bang ', 'Yuan ', 'Cun ', 'Huo ', 'Xie ', 'Bang ', 'Wu ', 'Ju ', 'You ', 'Han ', 'Tai ', 'Qiu ', 'Bi ', 'Pei ', 'Bing ', 'Shao ', 'Bei ', 'Wa ', 'Di ', 'Zou ', 'Ye ', 'Lin ', 'Kuang ', 'Gui ', 'Zhu ', 'Shi ', 'Ku ', 'Yu ', 'Gai ', 'Ge ', 'Xi ', 'Zhi ', 'Ji ', 'Xun ', 'Hou ', 'Xing ', 'Jiao ', 'Xi ', 'Gui ', 'Nuo ', 'Lang ', 'Jia ', 'Kuai ', 'Zheng ', 'Otoko ', 'Yun ', 'Yan ', 'Cheng ', 'Dou ', 'Chi ', 'Lu ', 'Fu ', 'Wu ', 'Fu ', 'Gao ', 'Hao ', 'Lang ', 'Jia ', 'Geng ', 'Jun ', 'Ying ', 'Bo ', 'Xi ', 'Bei ', 'Li ', 'Yun ', 'Bu ', 'Xiao ', 'Qi ', 'Pi ', 'Qing ', 'Guo ', 'Zhou ', 'Tan ', 'Zou ', 'Ping ', 'Lai ', 'Ni ', 'Chen ', 'You ', 'Bu ', 'Xiang ', 'Dan ', 'Ju ', 'Yong ', 'Qiao ', 'Yi ', 'Du ', 'Yan ', 'Mei ']

Documentation des variables

◆ return

return[ 'Tui ', 'Song ', 'Gua ', 'Tao ', 'Pang ', 'Hou ', 'Ni ', 'Dun ', 'Jiong ', 'Xuan ', 'Xun ', 'Bu ', 'You ', 'Xiao ', 'Qiu ', 'Tou ', 'Zhu ', 'Qiu ', 'Di ', 'Di ', 'Tu ', 'Jing ', 'Ti ', 'Dou ', 'Yi ', 'Zhe ', 'Tong ', 'Guang ', 'Wu ', 'Shi ', 'Cheng ', 'Su ', 'Zao ', 'Qun ', 'Feng ', 'Lian ', 'Suo ', 'Hui ', 'Li ', 'Sako ', 'Lai ', 'Ben ', 'Cuo ', 'Jue ', 'Beng ', 'Huan ', 'Dai ', 'Lu ', 'You ', 'Zhou ', 'Jin ', 'Yu ', 'Chuo ', 'Kui ', 'Wei ', 'Ti ', 'Yi ', 'Da ', 'Yuan ', 'Luo ', 'Bi ', 'Nuo ', 'Yu ', 'Dang ', 'Sui ', 'Dun ', 'Sui ', 'Yan ', 'Chuan ', 'Chi ', 'Ti ', 'Yu ', 'Shi ', 'Zhen ', 'You ', 'Yun ', 'E ', 'Bian ', 'Guo ', 'E ', 'Xia ', 'Huang ', 'Qiu ', 'Dao ', 'Da ', 'Wei ', 'Appare ', 'Yi ', 'Gou ', 'Yao ', 'Chu ', 'Liu ', 'Xun ', 'Ta ', 'Di ', 'Chi ', 'Yuan ', 'Su ', 'Ta ', 'Qian ', '[?] ', 'Yao ', 'Guan ', 'Zhang ', 'Ao ', 'Shi ', 'Ce ', 'Chi ', 'Su ', 'Zao ', 'Zhe ', 'Dun ', 'Di ', 'Lou ', 'Chi ', 'Cuo ', 'Lin ', 'Zun ', 'Rao ', 'Qian ', 'Xuan ', 'Yu ', 'Yi ', 'Wu ', 'Liao ', 'Ju ', 'Shi ', 'Bi ', 'Yao ', 'Mai ', 'Xie ', 'Sui ', 'Huan ', 'Zhan ', 'Teng ', 'Er ', 'Miao ', 'Bian ', 'Bian ', 'La ', 'Li ', 'Yuan ', 'Yao ', 'Luo ', 'Li ', 'Yi ', 'Ting ', 'Deng ', 'Qi ', 'Yong ', 'Shan ', 'Han ', 'Yu ', 'Mang ', 'Ru ', 'Qiong ', '[?] ', 'Kuang ', 'Fu ', 'Kang ', 'Bin ', 'Fang ', 'Xing ', 'Na ', 'Xin ', 'Shen ', 'Bang ', 'Yuan ', 'Cun ', 'Huo ', 'Xie ', 'Bang ', 'Wu ', 'Ju ', 'You ', 'Han ', 'Tai ', 'Qiu ', 'Bi ', 'Pei ', 'Bing ', 'Shao ', 'Bei ', 'Wa ', 'Di ', 'Zou ', 'Ye ', 'Lin ', 'Kuang ', 'Gui ', 'Zhu ', 'Shi ', 'Ku ', 'Yu ', 'Gai ', 'Ge ', 'Xi ', 'Zhi ', 'Ji ', 'Xun ', 'Hou ', 'Xing ', 'Jiao ', 'Xi ', 'Gui ', 'Nuo ', 'Lang ', 'Jia ', 'Kuai ', 'Zheng ', 'Otoko ', 'Yun ', 'Yan ', 'Cheng ', 'Dou ', 'Chi ', 'Lu ', 'Fu ', 'Wu ', 'Fu ', 'Gao ', 'Hao ', 'Lang ', 'Jia ', 'Geng ', 'Jun ', 'Ying ', 'Bo ', 'Xi ', 'Bei ', 'Li ', 'Yun ', 'Bu ', 'Xiao ', 'Qi ', 'Pi ', 'Qing ', 'Guo ', 'Zhou ', 'Tan ', 'Zou ', 'Ping ', 'Lai ', 'Ni ', 'Chen ', 'You ', 'Bu ', 'Xiang ', 'Dan ', 'Ju ', 'Yong ', 'Qiao ', 'Yi ', 'Du ', 'Yan ', 'Mei ']


Joomla CMS: Référence du fichier X509.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
Structures de données | Espaces de nommage
Référence du fichier X509.php

Structures de données

class X509

Espaces de nommage

X509
phpseclib3\File


Joomla CMS: Référence du fichier RuntimeTests.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • defuse
  • php-encryption
  • src
Structures de données | Espaces de nommage
Référence du fichier RuntimeTests.php

Structures de données

class RuntimeTests

Espaces de nommage

Defuse\Crypto


Joomla CMS: Référence du fichier recaptcha.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • captcha
  • recaptcha
Structures de données | Espaces de nommage
Référence du fichier recaptcha.php

Structures de données

class PlgCaptchaRecaptcha

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier PrefixField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • installation
  • src
  • Form
  • Field
  • Installation
Structures de données | Espaces de nommage
Référence du fichier PrefixField.php

Structures de données

class PrefixField

Espaces de nommage

Joomla\Installation
Joomla\CMS\Installation\Form\Field\Installation


Joomla CMS: Référence du fichier StageController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier StageController.php

Structures de données

class StageController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier RouteHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Helper/RouteHelper.php

Structures de données

class RouteHelper

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Helper


Joomla CMS: Référence du fichier setoptions.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • editors
  • tinymce
  • field
  • tinymcebuilder
Espaces de nommage | Variables
Référence du fichier setoptions.php

Espaces de nommage

Joomla\Plugin

Variables

endforeach

Documentation des variables

◆ endforeach

endforeach


Joomla CMS: Référence du fichier unicode.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
  • utils
Espaces de nommage | Fonctions
Référence du fichier unicode.php

Espaces de nommage

utf8

Fonctions

utf8_to_unicode ($str)
utf8_from_unicode ($arr)

Documentation des fonctions

◆ utf8_from_unicode()

utf8_from_unicode ( $arr )

Références $result.

Référencé par utf8_specials_pattern(), utf8_strtolower(), et utf8_strtoupper().

◆ utf8_to_unicode()

utf8_to_unicode ( $str )

End of the multi-octet sequence. mUcs4 now contains the final Unicode codepoint to be output

((0xC0 & (*in) != 0x80) && (mState != 0)) Incomplete multi-octet sequence.

Références $i, et $tmp.

Référencé par utf8_strtolower(), et utf8_strtoupper().


Joomla CMS: Référence du fichier profile.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • user
  • profile
Structures de données | Espaces de nommage
Référence du fichier profile.php

Structures de données

class PlgUserProfile

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x062.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x062.php

Variables

return ['Lian ', 'Nan ', 'Mi ', 'Tang ', 'Jue ', 'Gang ', 'Gang ', 'Gang ', 'Ge ', 'Yue ', 'Wu ', 'Jian ', 'Xu ', 'Shu ', 'Rong ', 'Xi ', 'Cheng ', 'Wo ', 'Jie ', 'Ge ', 'Jian ', 'Qiang ', 'Huo ', 'Qiang ', 'Zhan ', 'Dong ', 'Qi ', 'Jia ', 'Die ', 'Zei ', 'Jia ', 'Ji ', 'Shi ', 'Kan ', 'Ji ', 'Kui ', 'Gai ', 'Deng ', 'Zhan ', 'Chuang ', 'Ge ', 'Jian ', 'Jie ', 'Yu ', 'Jian ', 'Yan ', 'Lu ', 'Xi ', 'Zhan ', 'Xi ', 'Xi ', 'Chuo ', 'Dai ', 'Qu ', 'Hu ', 'Hu ', 'Hu ', 'E ', 'Shi ', 'Li ', 'Mao ', 'Hu ', 'Li ', 'Fang ', 'Suo ', 'Bian ', 'Dian ', 'Jiong ', 'Shang ', 'Yi ', 'Yi ', 'Shan ', 'Hu ', 'Fei ', 'Yan ', 'Shou ', 'T ', 'Cai ', 'Zha ', 'Qiu ', 'Le ', 'Bu ', 'Ba ', 'Da ', 'Reng ', 'Fu ', 'Hameru ', 'Zai ', 'Tuo ', 'Zhang ', 'Diao ', 'Kang ', 'Yu ', 'Ku ', 'Han ', 'Shen ', 'Cha ', 'Yi ', 'Gu ', 'Kou ', 'Wu ', 'Tuo ', 'Qian ', 'Zhi ', 'Ren ', 'Kuo ', 'Men ', 'Sao ', 'Yang ', 'Niu ', 'Ban ', 'Che ', 'Rao ', 'Xi ', 'Qian ', 'Ban ', 'Jia ', 'Yu ', 'Fu ', 'Ao ', 'Xi ', 'Pi ', 'Zhi ', 'Zi ', 'E ', 'Dun ', 'Zhao ', 'Cheng ', 'Ji ', 'Yan ', 'Kuang ', 'Bian ', 'Chao ', 'Ju ', 'Wen ', 'Hu ', 'Yue ', 'Jue ', 'Ba ', 'Qin ', 'Zhen ', 'Zheng ', 'Yun ', 'Wan ', 'Nu ', 'Yi ', 'Shu ', 'Zhua ', 'Pou ', 'Tou ', 'Dou ', 'Kang ', 'Zhe ', 'Pou ', 'Fu ', 'Pao ', 'Ba ', 'Ao ', 'Ze ', 'Tuan ', 'Kou ', 'Lun ', 'Qiang ', '[?] ', 'Hu ', 'Bao ', 'Bing ', 'Zhi ', 'Peng ', 'Tan ', 'Pu ', 'Pi ', 'Tai ', 'Yao ', 'Zhen ', 'Zha ', 'Yang ', 'Bao ', 'He ', 'Ni ', 'Yi ', 'Di ', 'Chi ', 'Pi ', 'Za ', 'Mo ', 'Mo ', 'Shen ', 'Ya ', 'Chou ', 'Qu ', 'Min ', 'Chu ', 'Jia ', 'Fu ', 'Zhan ', 'Zhu ', 'Dan ', 'Chai ', 'Mu ', 'Nian ', 'La ', 'Fu ', 'Pao ', 'Ban ', 'Pai ', 'Ling ', 'Na ', 'Guai ', 'Qian ', 'Ju ', 'Tuo ', 'Ba ', 'Tuo ', 'Tuo ', 'Ao ', 'Ju ', 'Zhuo ', 'Pan ', 'Zhao ', 'Bai ', 'Bai ', 'Di ', 'Ni ', 'Ju ', 'Kuo ', 'Long ', 'Jian ', '[?] ', 'Yong ', 'Lan ', 'Ning ', 'Bo ', 'Ze ', 'Qian ', 'Hen ', 'Gua ', 'Shi ', 'Jie ', 'Zheng ', 'Nin ', 'Gong ', 'Gong ', 'Quan ', 'Shuan ', 'Cun ', 'Zan ', 'Kao ', 'Chi ', 'Xie ', 'Ce ', 'Hui ', 'Pin ', 'Zhuai ', 'Shi ', 'Na ']

Documentation des variables

◆ return

return[ 'Lian ', 'Nan ', 'Mi ', 'Tang ', 'Jue ', 'Gang ', 'Gang ', 'Gang ', 'Ge ', 'Yue ', 'Wu ', 'Jian ', 'Xu ', 'Shu ', 'Rong ', 'Xi ', 'Cheng ', 'Wo ', 'Jie ', 'Ge ', 'Jian ', 'Qiang ', 'Huo ', 'Qiang ', 'Zhan ', 'Dong ', 'Qi ', 'Jia ', 'Die ', 'Zei ', 'Jia ', 'Ji ', 'Shi ', 'Kan ', 'Ji ', 'Kui ', 'Gai ', 'Deng ', 'Zhan ', 'Chuang ', 'Ge ', 'Jian ', 'Jie ', 'Yu ', 'Jian ', 'Yan ', 'Lu ', 'Xi ', 'Zhan ', 'Xi ', 'Xi ', 'Chuo ', 'Dai ', 'Qu ', 'Hu ', 'Hu ', 'Hu ', 'E ', 'Shi ', 'Li ', 'Mao ', 'Hu ', 'Li ', 'Fang ', 'Suo ', 'Bian ', 'Dian ', 'Jiong ', 'Shang ', 'Yi ', 'Yi ', 'Shan ', 'Hu ', 'Fei ', 'Yan ', 'Shou ', 'T ', 'Cai ', 'Zha ', 'Qiu ', 'Le ', 'Bu ', 'Ba ', 'Da ', 'Reng ', 'Fu ', 'Hameru ', 'Zai ', 'Tuo ', 'Zhang ', 'Diao ', 'Kang ', 'Yu ', 'Ku ', 'Han ', 'Shen ', 'Cha ', 'Yi ', 'Gu ', 'Kou ', 'Wu ', 'Tuo ', 'Qian ', 'Zhi ', 'Ren ', 'Kuo ', 'Men ', 'Sao ', 'Yang ', 'Niu ', 'Ban ', 'Che ', 'Rao ', 'Xi ', 'Qian ', 'Ban ', 'Jia ', 'Yu ', 'Fu ', 'Ao ', 'Xi ', 'Pi ', 'Zhi ', 'Zi ', 'E ', 'Dun ', 'Zhao ', 'Cheng ', 'Ji ', 'Yan ', 'Kuang ', 'Bian ', 'Chao ', 'Ju ', 'Wen ', 'Hu ', 'Yue ', 'Jue ', 'Ba ', 'Qin ', 'Zhen ', 'Zheng ', 'Yun ', 'Wan ', 'Nu ', 'Yi ', 'Shu ', 'Zhua ', 'Pou ', 'Tou ', 'Dou ', 'Kang ', 'Zhe ', 'Pou ', 'Fu ', 'Pao ', 'Ba ', 'Ao ', 'Ze ', 'Tuan ', 'Kou ', 'Lun ', 'Qiang ', '[?] ', 'Hu ', 'Bao ', 'Bing ', 'Zhi ', 'Peng ', 'Tan ', 'Pu ', 'Pi ', 'Tai ', 'Yao ', 'Zhen ', 'Zha ', 'Yang ', 'Bao ', 'He ', 'Ni ', 'Yi ', 'Di ', 'Chi ', 'Pi ', 'Za ', 'Mo ', 'Mo ', 'Shen ', 'Ya ', 'Chou ', 'Qu ', 'Min ', 'Chu ', 'Jia ', 'Fu ', 'Zhan ', 'Zhu ', 'Dan ', 'Chai ', 'Mu ', 'Nian ', 'La ', 'Fu ', 'Pao ', 'Ban ', 'Pai ', 'Ling ', 'Na ', 'Guai ', 'Qian ', 'Ju ', 'Tuo ', 'Ba ', 'Tuo ', 'Tuo ', 'Ao ', 'Ju ', 'Zhuo ', 'Pan ', 'Zhao ', 'Bai ', 'Bai ', 'Di ', 'Ni ', 'Ju ', 'Kuo ', 'Long ', 'Jian ', '[?] ', 'Yong ', 'Lan ', 'Ning ', 'Bo ', 'Ze ', 'Qian ', 'Hen ', 'Gua ', 'Shi ', 'Jie ', 'Zheng ', 'Nin ', 'Gong ', 'Gong ', 'Quan ', 'Shuan ', 'Cun ', 'Zan ', 'Kao ', 'Chi ', 'Xie ', 'Ce ', 'Hui ', 'Pin ', 'Zhuai ', 'Shi ', 'Na ']


Joomla CMS: Référence du fichier TelFilter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Filter
Structures de données | Espaces de nommage
Référence du fichier TelFilter.php

Structures de données

class TelFilter

Espaces de nommage

Joomla\CMS\Form\Filter


Joomla CMS: Référence du fichier x0a3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0a3.php

Variables

return ['nzup', 'nzurx', 'nzur', 'nzyt', 'nzyx', 'nzy', 'nzyp', 'nzyrx', 'nzyr', 'sit', 'six', 'si', 'sip', 'siex', 'sie', 'siep', 'sat', 'sax', 'sa', 'sap', 'suox', 'suo', 'suop', 'sot', 'sox', 'so', 'sop', 'sex', 'se', 'sep', 'sut', 'sux', 'su', 'sup', 'surx', 'sur', 'syt', 'syx', 'sy', 'syp', 'syrx', 'syr', 'ssit', 'ssix', 'ssi', 'ssip', 'ssiex', 'ssie', 'ssiep', 'ssat', 'ssax', 'ssa', 'ssap', 'ssot', 'ssox', 'sso', 'ssop', 'ssex', 'sse', 'ssep', 'ssut', 'ssux', 'ssu', 'ssup', 'ssyt', 'ssyx', 'ssy', 'ssyp', 'ssyrx', 'ssyr', 'zhat', 'zhax', 'zha', 'zhap', 'zhuox', 'zhuo', 'zhuop', 'zhot', 'zhox', 'zho', 'zhop', 'zhet', 'zhex', 'zhe', 'zhep', 'zhut', 'zhux', 'zhu', 'zhup', 'zhurx', 'zhur', 'zhyt', 'zhyx', 'zhy', 'zhyp', 'zhyrx', 'zhyr', 'chat', 'chax', 'cha', 'chap', 'chuot', 'chuox', 'chuo', 'chuop', 'chot', 'chox', 'cho', 'chop', 'chet', 'chex', 'che', 'chep', 'chux', 'chu', 'chup', 'churx', 'chur', 'chyt', 'chyx', 'chy', 'chyp', 'chyrx', 'chyr', 'rrax', 'rra', 'rruox', 'rruo', 'rrot', 'rrox', 'rro', 'rrop', 'rret', 'rrex', 'rre', 'rrep', 'rrut', 'rrux', 'rru', 'rrup', 'rrurx', 'rrur', 'rryt', 'rryx', 'rry', 'rryp', 'rryrx', 'rryr', 'nrat', 'nrax', 'nra', 'nrap', 'nrox', 'nro', 'nrop', 'nret', 'nrex', 'nre', 'nrep', 'nrut', 'nrux', 'nru', 'nrup', 'nrurx', 'nrur', 'nryt', 'nryx', 'nry', 'nryp', 'nryrx', 'nryr', 'shat', 'shax', 'sha', 'shap', 'shuox', 'shuo', 'shuop', 'shot', 'shox', 'sho', 'shop', 'shet', 'shex', 'she', 'shep', 'shut', 'shux', 'shu', 'shup', 'shurx', 'shur', 'shyt', 'shyx', 'shy', 'shyp', 'shyrx', 'shyr', 'rat', 'rax', 'ra', 'rap', 'ruox', 'ruo', 'ruop', 'rot', 'rox', 'ro', 'rop', 'rex', 're', 'rep', 'rut', 'rux', 'ru', 'rup', 'rurx', 'rur', 'ryt', 'ryx', 'ry', 'ryp', 'ryrx', 'ryr', 'jit', 'jix', 'ji', 'jip', 'jiet', 'jiex', 'jie', 'jiep', 'juot', 'juox', 'juo', 'juop', 'jot', 'jox', 'jo', 'jop', 'jut', 'jux', 'ju', 'jup', 'jurx', 'jur', 'jyt', 'jyx', 'jy', 'jyp', 'jyrx', 'jyr', 'qit', 'qix', 'qi', 'qip']

Documentation des variables

◆ return

return[ 'nzup', 'nzurx', 'nzur', 'nzyt', 'nzyx', 'nzy', 'nzyp', 'nzyrx', 'nzyr', 'sit', 'six', 'si', 'sip', 'siex', 'sie', 'siep', 'sat', 'sax', 'sa', 'sap', 'suox', 'suo', 'suop', 'sot', 'sox', 'so', 'sop', 'sex', 'se', 'sep', 'sut', 'sux', 'su', 'sup', 'surx', 'sur', 'syt', 'syx', 'sy', 'syp', 'syrx', 'syr', 'ssit', 'ssix', 'ssi', 'ssip', 'ssiex', 'ssie', 'ssiep', 'ssat', 'ssax', 'ssa', 'ssap', 'ssot', 'ssox', 'sso', 'ssop', 'ssex', 'sse', 'ssep', 'ssut', 'ssux', 'ssu', 'ssup', 'ssyt', 'ssyx', 'ssy', 'ssyp', 'ssyrx', 'ssyr', 'zhat', 'zhax', 'zha', 'zhap', 'zhuox', 'zhuo', 'zhuop', 'zhot', 'zhox', 'zho', 'zhop', 'zhet', 'zhex', 'zhe', 'zhep', 'zhut', 'zhux', 'zhu', 'zhup', 'zhurx', 'zhur', 'zhyt', 'zhyx', 'zhy', 'zhyp', 'zhyrx', 'zhyr', 'chat', 'chax', 'cha', 'chap', 'chuot', 'chuox', 'chuo', 'chuop', 'chot', 'chox', 'cho', 'chop', 'chet', 'chex', 'che', 'chep', 'chux', 'chu', 'chup', 'churx', 'chur', 'chyt', 'chyx', 'chy', 'chyp', 'chyrx', 'chyr', 'rrax', 'rra', 'rruox', 'rruo', 'rrot', 'rrox', 'rro', 'rrop', 'rret', 'rrex', 'rre', 'rrep', 'rrut', 'rrux', 'rru', 'rrup', 'rrurx', 'rrur', 'rryt', 'rryx', 'rry', 'rryp', 'rryrx', 'rryr', 'nrat', 'nrax', 'nra', 'nrap', 'nrox', 'nro', 'nrop', 'nret', 'nrex', 'nre', 'nrep', 'nrut', 'nrux', 'nru', 'nrup', 'nrurx', 'nrur', 'nryt', 'nryx', 'nry', 'nryp', 'nryrx', 'nryr', 'shat', 'shax', 'sha', 'shap', 'shuox', 'shuo', 'shuop', 'shot', 'shox', 'sho', 'shop', 'shet', 'shex', 'she', 'shep', 'shut', 'shux', 'shu', 'shup', 'shurx', 'shur', 'shyt', 'shyx', 'shy', 'shyp', 'shyrx', 'shyr', 'rat', 'rax', 'ra', 'rap', 'ruox', 'ruo', 'ruop', 'rot', 'rox', 'ro', 'rop', 'rex', 're', 'rep', 'rut', 'rux', 'ru', 'rup', 'rurx', 'rur', 'ryt', 'ryx', 'ry', 'ryp', 'ryrx', 'ryr', 'jit', 'jix', 'ji', 'jip', 'jiet', 'jiex', 'jie', 'jiep', 'juot', 'juox', 'juo', 'juop', 'jot', 'jox', 'jo', 'jop', 'jut', 'jux', 'ju', 'jup', 'jurx', 'jur', 'jyt', 'jyx', 'jy', 'jyp', 'jyrx', 'jyr', 'qit', 'qix', 'qi', 'qip']


Joomla CMS: Référence du fichier UpdateOperationException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • ldap
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UpdateOperationException.php

Structures de données

class UpdateOperationException

Espaces de nommage

Symfony\Component\Ldap\Exception


Joomla CMS: Référence du fichier RelatedTo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
  • Constraint
Structures de données | Espaces de nommage
Référence du fichier RelatedTo.php

Structures de données

class RelatedTo

Espaces de nommage

Lcobucci\JWT\Validation\Constraint


Joomla CMS: Référence du fichier x0c6.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c6.php

Variables

return ['yeoss', 'yeong', 'yeoj', 'yeoc', 'yeok', 'yeot', 'yeop', 'yeoh', 'ye', 'yeg', 'yegg', 'yegs', 'yen', 'yenj', 'yenh', 'yed', 'yel', 'yelg', 'yelm', 'yelb', 'yels', 'yelt', 'yelp', 'yelh', 'yem', 'yeb', 'yebs', 'yes', 'yess', 'yeng', 'yej', 'yec', 'yek', 'yet', 'yep', 'yeh', 'o', 'og', 'ogg', 'ogs', 'on', 'onj', 'onh', 'od', 'ol', 'olg', 'olm', 'olb', 'ols', 'olt', 'olp', 'olh', 'om', 'ob', 'obs', 'os', 'oss', 'ong', 'oj', 'oc', 'ok', 'ot', 'op', 'oh', 'wa', 'wag', 'wagg', 'wags', 'wan', 'wanj', 'wanh', 'wad', 'wal', 'walg', 'walm', 'walb', 'wals', 'walt', 'walp', 'walh', 'wam', 'wab', 'wabs', 'was', 'wass', 'wang', 'waj', 'wac', 'wak', 'wat', 'wap', 'wah', 'wae', 'waeg', 'waegg', 'waegs', 'waen', 'waenj', 'waenh', 'waed', 'wael', 'waelg', 'waelm', 'waelb', 'waels', 'waelt', 'waelp', 'waelh', 'waem', 'waeb', 'waebs', 'waes', 'waess', 'waeng', 'waej', 'waec', 'waek', 'waet', 'waep', 'waeh', 'oe', 'oeg', 'oegg', 'oegs', 'oen', 'oenj', 'oenh', 'oed', 'oel', 'oelg', 'oelm', 'oelb', 'oels', 'oelt', 'oelp', 'oelh', 'oem', 'oeb', 'oebs', 'oes', 'oess', 'oeng', 'oej', 'oec', 'oek', 'oet', 'oep', 'oeh', 'yo', 'yog', 'yogg', 'yogs', 'yon', 'yonj', 'yonh', 'yod', 'yol', 'yolg', 'yolm', 'yolb', 'yols', 'yolt', 'yolp', 'yolh', 'yom', 'yob', 'yobs', 'yos', 'yoss', 'yong', 'yoj', 'yoc', 'yok', 'yot', 'yop', 'yoh', 'u', 'ug', 'ugg', 'ugs', 'un', 'unj', 'unh', 'ud', 'ul', 'ulg', 'ulm', 'ulb', 'uls', 'ult', 'ulp', 'ulh', 'um', 'ub', 'ubs', 'us', 'uss', 'ung', 'uj', 'uc', 'uk', 'ut', 'up', 'uh', 'weo', 'weog', 'weogg', 'weogs', 'weon', 'weonj', 'weonh', 'weod', 'weol', 'weolg', 'weolm', 'weolb', 'weols', 'weolt', 'weolp', 'weolh', 'weom', 'weob', 'weobs', 'weos', 'weoss', 'weong', 'weoj', 'weoc', 'weok', 'weot', 'weop', 'weoh', 'we', 'weg', 'wegg', 'wegs', 'wen', 'wenj', 'wenh', 'wed', 'wel', 'welg', 'welm', 'welb', 'wels', 'welt', 'welp', 'welh', 'wem', 'web', 'webs', 'wes', 'wess', 'weng', 'wej', 'wec']

Documentation des variables

◆ return

return[ 'yeoss', 'yeong', 'yeoj', 'yeoc', 'yeok', 'yeot', 'yeop', 'yeoh', 'ye', 'yeg', 'yegg', 'yegs', 'yen', 'yenj', 'yenh', 'yed', 'yel', 'yelg', 'yelm', 'yelb', 'yels', 'yelt', 'yelp', 'yelh', 'yem', 'yeb', 'yebs', 'yes', 'yess', 'yeng', 'yej', 'yec', 'yek', 'yet', 'yep', 'yeh', 'o', 'og', 'ogg', 'ogs', 'on', 'onj', 'onh', 'od', 'ol', 'olg', 'olm', 'olb', 'ols', 'olt', 'olp', 'olh', 'om', 'ob', 'obs', 'os', 'oss', 'ong', 'oj', 'oc', 'ok', 'ot', 'op', 'oh', 'wa', 'wag', 'wagg', 'wags', 'wan', 'wanj', 'wanh', 'wad', 'wal', 'walg', 'walm', 'walb', 'wals', 'walt', 'walp', 'walh', 'wam', 'wab', 'wabs', 'was', 'wass', 'wang', 'waj', 'wac', 'wak', 'wat', 'wap', 'wah', 'wae', 'waeg', 'waegg', 'waegs', 'waen', 'waenj', 'waenh', 'waed', 'wael', 'waelg', 'waelm', 'waelb', 'waels', 'waelt', 'waelp', 'waelh', 'waem', 'waeb', 'waebs', 'waes', 'waess', 'waeng', 'waej', 'waec', 'waek', 'waet', 'waep', 'waeh', 'oe', 'oeg', 'oegg', 'oegs', 'oen', 'oenj', 'oenh', 'oed', 'oel', 'oelg', 'oelm', 'oelb', 'oels', 'oelt', 'oelp', 'oelh', 'oem', 'oeb', 'oebs', 'oes', 'oess', 'oeng', 'oej', 'oec', 'oek', 'oet', 'oep', 'oeh', 'yo', 'yog', 'yogg', 'yogs', 'yon', 'yonj', 'yonh', 'yod', 'yol', 'yolg', 'yolm', 'yolb', 'yols', 'yolt', 'yolp', 'yolh', 'yom', 'yob', 'yobs', 'yos', 'yoss', 'yong', 'yoj', 'yoc', 'yok', 'yot', 'yop', 'yoh', 'u', 'ug', 'ugg', 'ugs', 'un', 'unj', 'unh', 'ud', 'ul', 'ulg', 'ulm', 'ulb', 'uls', 'ult', 'ulp', 'ulh', 'um', 'ub', 'ubs', 'us', 'uss', 'ung', 'uj', 'uc', 'uk', 'ut', 'up', 'uh', 'weo', 'weog', 'weogg', 'weogs', 'weon', 'weonj', 'weonh', 'weod', 'weol', 'weolg', 'weolm', 'weolb', 'weols', 'weolt', 'weolp', 'weolh', 'weom', 'weob', 'weobs', 'weos', 'weoss', 'weong', 'weoj', 'weoc', 'weok', 'weot', 'weop', 'weoh', 'we', 'weg', 'wegg', 'wegs', 'wen', 'wenj', 'wenh', 'wed', 'wel', 'welg', 'welm', 'welb', 'wels', 'welt', 'welp', 'welh', 'wem', 'web', 'webs', 'wes', 'wess', 'weng', 'wej', 'wec']


Joomla CMS: Référence du fichier x01d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x01d.php

Variables

return ['A', 'AE', 'ae', 'B', 'C', 'D', 'D', 'E', 'e', 'i', 'J', 'K', 'L', 'M', 'N', 'O', '', 'O', '', 'O', 'Oe', 'Ou', '', '', 'P', 'R', 'R', 'T', 'U', 'u', 'u', 'm', 'V', 'W', 'Z', '', '', '', '', '', '', '', '', '', 'A', 'AE', 'B', 'B', 'D', 'E', 'E', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'N', 'O', 'Ou', 'P', 'R', 'T', 'U', 'W', 'a', 'a', 'a', 'ae', 'b', 'd', 'e', '', 'e', 'e', 'g', 'i', 'k', 'm', '', 'o', '', '', '', 'p', 't', 'u', 'u', 'm', 'v', '', 'b', 'g', 'd', 'f', '', 'i', 'r', 'u', 'v', 'b', 'g', 'r', 'f', '', '', 'b', 'd', 'f', 'm', 'n', 'p', 'r', 'r', 's', 't', 'z', 'g', '', '', '', '', '', 'p', '', '', 'b', 'd', 'f', 'g', 'k', 'l', 'm', 'n', 'p', 'r', 's', '', 'v', 'x', 'z', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return[ 'A', 'AE', 'ae', 'B', 'C', 'D', 'D', 'E', 'e', 'i', 'J', 'K', 'L', 'M', 'N', 'O', '', 'O', '', 'O', 'Oe', 'Ou', '', '', 'P', 'R', 'R', 'T', 'U', 'u', 'u', 'm', 'V', 'W', 'Z', '', '', '', '', '', '', '', '', '', 'A', 'AE', 'B', 'B', 'D', 'E', 'E', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'N', 'O', 'Ou', 'P', 'R', 'T', 'U', 'W', 'a', 'a', 'a', 'ae', 'b', 'd', 'e', '', 'e', 'e', 'g', 'i', 'k', 'm', '', 'o', '', '', '', 'p', 't', 'u', 'u', 'm', 'v', '', 'b', 'g', 'd', 'f', '', 'i', 'r', 'u', 'v', 'b', 'g', 'r', 'f', '', '', 'b', 'd', 'f', 'm', 'n', 'p', 'r', 'r', 's', 't', 'z', 'g', '', '', '', '', '', 'p', '', '', 'b', 'd', 'f', 'g', 'k', 'l', 'm', 'n', 'p', 'r', 's', '', 'v', 'x', 'z', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier Profiler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Profiler
Structures de données | Espaces de nommage
Référence du fichier Profiler.php

Structures de données

class Profiler

Espaces de nommage

Joomla\CMS\Profiler


Joomla CMS: Référence du fichier UnableToConnectException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnableToConnectException.php

Structures de données

class UnableToConnectException

Espaces de nommage

UnableToConnectException
phpseclib3\Exception


Joomla CMS: Référence du fichier ProfileController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier ProfileController.php

Structures de données

class ProfileController

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Controller


Joomla CMS: Référence du fichier StyleInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Style
Structures de données | Espaces de nommage
Référence du fichier StyleInterface.php

Structures de données

interface StyleInterface

Espaces de nommage

Symfony\Component\Console\Style


Joomla CMS: Référence du fichier x0d3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d3.php

Variables

return ['tim', 'tib', 'tibs', 'tis', 'tiss', 'ting', 'tij', 'tic', 'tik', 'tit', 'tip', 'tih', 'pa', 'pag', 'pagg', 'pags', 'pan', 'panj', 'panh', 'pad', 'pal', 'palg', 'palm', 'palb', 'pals', 'palt', 'palp', 'palh', 'pam', 'pab', 'pabs', 'pas', 'pass', 'pang', 'paj', 'pac', 'pak', 'pat', 'pap', 'pah', 'pae', 'paeg', 'paegg', 'paegs', 'paen', 'paenj', 'paenh', 'paed', 'pael', 'paelg', 'paelm', 'paelb', 'paels', 'paelt', 'paelp', 'paelh', 'paem', 'paeb', 'paebs', 'paes', 'paess', 'paeng', 'paej', 'paec', 'paek', 'paet', 'paep', 'paeh', 'pya', 'pyag', 'pyagg', 'pyags', 'pyan', 'pyanj', 'pyanh', 'pyad', 'pyal', 'pyalg', 'pyalm', 'pyalb', 'pyals', 'pyalt', 'pyalp', 'pyalh', 'pyam', 'pyab', 'pyabs', 'pyas', 'pyass', 'pyang', 'pyaj', 'pyac', 'pyak', 'pyat', 'pyap', 'pyah', 'pyae', 'pyaeg', 'pyaegg', 'pyaegs', 'pyaen', 'pyaenj', 'pyaenh', 'pyaed', 'pyael', 'pyaelg', 'pyaelm', 'pyaelb', 'pyaels', 'pyaelt', 'pyaelp', 'pyaelh', 'pyaem', 'pyaeb', 'pyaebs', 'pyaes', 'pyaess', 'pyaeng', 'pyaej', 'pyaec', 'pyaek', 'pyaet', 'pyaep', 'pyaeh', 'peo', 'peog', 'peogg', 'peogs', 'peon', 'peonj', 'peonh', 'peod', 'peol', 'peolg', 'peolm', 'peolb', 'peols', 'peolt', 'peolp', 'peolh', 'peom', 'peob', 'peobs', 'peos', 'peoss', 'peong', 'peoj', 'peoc', 'peok', 'peot', 'peop', 'peoh', 'pe', 'peg', 'pegg', 'pegs', 'pen', 'penj', 'penh', 'ped', 'pel', 'pelg', 'pelm', 'pelb', 'pels', 'pelt', 'pelp', 'pelh', 'pem', 'peb', 'pebs', 'pes', 'pess', 'peng', 'pej', 'pec', 'pek', 'pet', 'pep', 'peh', 'pyeo', 'pyeog', 'pyeogg', 'pyeogs', 'pyeon', 'pyeonj', 'pyeonh', 'pyeod', 'pyeol', 'pyeolg', 'pyeolm', 'pyeolb', 'pyeols', 'pyeolt', 'pyeolp', 'pyeolh', 'pyeom', 'pyeob', 'pyeobs', 'pyeos', 'pyeoss', 'pyeong', 'pyeoj', 'pyeoc', 'pyeok', 'pyeot', 'pyeop', 'pyeoh', 'pye', 'pyeg', 'pyegg', 'pyegs', 'pyen', 'pyenj', 'pyenh', 'pyed', 'pyel', 'pyelg', 'pyelm', 'pyelb', 'pyels', 'pyelt', 'pyelp', 'pyelh', 'pyem', 'pyeb', 'pyebs', 'pyes', 'pyess', 'pyeng', 'pyej', 'pyec', 'pyek', 'pyet', 'pyep', 'pyeh', 'po', 'pog', 'pogg', 'pogs', 'pon', 'ponj', 'ponh', 'pod', 'pol', 'polg', 'polm', 'polb', 'pols', 'polt', 'polp', 'polh', 'pom', 'pob', 'pobs', 'pos']

Documentation des variables

◆ return

return[ 'tim', 'tib', 'tibs', 'tis', 'tiss', 'ting', 'tij', 'tic', 'tik', 'tit', 'tip', 'tih', 'pa', 'pag', 'pagg', 'pags', 'pan', 'panj', 'panh', 'pad', 'pal', 'palg', 'palm', 'palb', 'pals', 'palt', 'palp', 'palh', 'pam', 'pab', 'pabs', 'pas', 'pass', 'pang', 'paj', 'pac', 'pak', 'pat', 'pap', 'pah', 'pae', 'paeg', 'paegg', 'paegs', 'paen', 'paenj', 'paenh', 'paed', 'pael', 'paelg', 'paelm', 'paelb', 'paels', 'paelt', 'paelp', 'paelh', 'paem', 'paeb', 'paebs', 'paes', 'paess', 'paeng', 'paej', 'paec', 'paek', 'paet', 'paep', 'paeh', 'pya', 'pyag', 'pyagg', 'pyags', 'pyan', 'pyanj', 'pyanh', 'pyad', 'pyal', 'pyalg', 'pyalm', 'pyalb', 'pyals', 'pyalt', 'pyalp', 'pyalh', 'pyam', 'pyab', 'pyabs', 'pyas', 'pyass', 'pyang', 'pyaj', 'pyac', 'pyak', 'pyat', 'pyap', 'pyah', 'pyae', 'pyaeg', 'pyaegg', 'pyaegs', 'pyaen', 'pyaenj', 'pyaenh', 'pyaed', 'pyael', 'pyaelg', 'pyaelm', 'pyaelb', 'pyaels', 'pyaelt', 'pyaelp', 'pyaelh', 'pyaem', 'pyaeb', 'pyaebs', 'pyaes', 'pyaess', 'pyaeng', 'pyaej', 'pyaec', 'pyaek', 'pyaet', 'pyaep', 'pyaeh', 'peo', 'peog', 'peogg', 'peogs', 'peon', 'peonj', 'peonh', 'peod', 'peol', 'peolg', 'peolm', 'peolb', 'peols', 'peolt', 'peolp', 'peolh', 'peom', 'peob', 'peobs', 'peos', 'peoss', 'peong', 'peoj', 'peoc', 'peok', 'peot', 'peop', 'peoh', 'pe', 'peg', 'pegg', 'pegs', 'pen', 'penj', 'penh', 'ped', 'pel', 'pelg', 'pelm', 'pelb', 'pels', 'pelt', 'pelp', 'pelh', 'pem', 'peb', 'pebs', 'pes', 'pess', 'peng', 'pej', 'pec', 'pek', 'pet', 'pep', 'peh', 'pyeo', 'pyeog', 'pyeogg', 'pyeogs', 'pyeon', 'pyeonj', 'pyeonh', 'pyeod', 'pyeol', 'pyeolg', 'pyeolm', 'pyeolb', 'pyeols', 'pyeolt', 'pyeolp', 'pyeolh', 'pyeom', 'pyeob', 'pyeobs', 'pyeos', 'pyeoss', 'pyeong', 'pyeoj', 'pyeoc', 'pyeok', 'pyeot', 'pyeop', 'pyeoh', 'pye', 'pyeg', 'pyegg', 'pyegs', 'pyen', 'pyenj', 'pyenh', 'pyed', 'pyel', 'pyelg', 'pyelm', 'pyelb', 'pyels', 'pyelt', 'pyelp', 'pyelh', 'pyem', 'pyeb', 'pyebs', 'pyes', 'pyess', 'pyeng', 'pyej', 'pyec', 'pyek', 'pyet', 'pyep', 'pyeh', 'po', 'pog', 'pogg', 'pogs', 'pon', 'ponj', 'ponh', 'pod', 'pol', 'polg', 'polm', 'polb', 'pols', 'polt', 'polp', 'polh', 'pom', 'pob', 'pobs', 'pos']


Joomla CMS: Référence du fichier RDNString.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Composite
Structures de données | Espaces de nommage
Référence du fichier RDNString.php

Structures de données

class RDNString

Espaces de nommage

FG\ASN1\Composite


Joomla CMS: Référence du fichier token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • plugins
  • user
  • token
Espaces de nommage
Référence du fichier layouts/plugins/user/token/token.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier UserField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier UserField.php

Structures de données

class UserField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: Référence du fichier Totp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • totp
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/totp/src/Extension/Totp.php

Structures de données

class Totp

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Totp\Extension


Joomla CMS: Référence du fichier QueryTypeAlreadyDefinedException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • database
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier QueryTypeAlreadyDefinedException.php

Structures de données

class QueryTypeAlreadyDefinedException

Espaces de nommage

Joomla\Database\Exception


Joomla CMS: Référence du fichier RequestFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier php-http/message-factory/src/RequestFactory.php

Structures de données

interface RequestFactory

Espaces de nommage

Http\Message


Joomla CMS: Référence du fichier prime239v3.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime239v3.php

Structures de données

class prime239v3

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier StorageInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier joomla/session/src/StorageInterface.php

Structures de données

interface StorageInterface

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier PuTTY.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier RSA/Formats/Keys/PuTTY.php

Structures de données

class PuTTY

Espaces de nommage

RSA
phpseclib3\Crypt\RSA\Formats\Keys


Joomla CMS: Référence du fichier Totp.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Structures de données | Espaces de nommage
Référence du fichier libraries/src/Encrypt/Totp.php

Structures de données

class Totp

Espaces de nommage

Joomla\CMS\Encrypt


Joomla CMS: Référence du fichier TagsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier components/com_tags/src/Controller/TagsController.php

Structures de données

class TagsController

Espaces de nommage

Joomla\Site
Joomla\Component\Tags\Site\Controller


Joomla CMS: Référence du fichier renderfield.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
Espaces de nommage | Variables
Référence du fichier renderfield.php

Espaces de nommage

Joomla\Site

Variables

if(!empty($options['showonEnabled'])) | $class = empty($options['class']) ? '' : ' ' . $options['class']
$rel = empty($options['rel']) ? '' : ' ' . $options['rel']
$id = ($id ?? $name) . '-desc'
$hideLabel = !empty($options['hiddenLabel'])
$hideDescription = empty($options['hiddenDescription']) ? false : $options['hiddenDescription']
$descClass = ($options['descClass'] ?? '') ?: (!empty($options['inlineHelp']) ? 'hide-aware-inline-help d-none' : '')
if (!empty( $parentclass))
if($hideLabel) | else
endif

Documentation des variables

◆ $class

if (!empty( $options[ 'showonEnabled'])) $class = empty($options['class']) ? '' : ' ' . $options['class']

◆ $descClass

$descClass = ($options['descClass'] ?? '') ?: (!empty($options['inlineHelp']) ? 'hide-aware-inline-help d-none' : '')

◆ $hideDescription

$hideDescription = empty($options['hiddenDescription']) ? false : $options['hiddenDescription']

◆ $hideLabel

$hideLabel = !empty($options['hiddenLabel'])

◆ $id

$id = ($id ?? $name) . '-desc'

◆ $rel

$rel = empty($options['rel']) ? '' : ' ' . $options['rel']

Référencé par AtomParser\bestLinkForUri(), HtmlErrorRenderer\formatFile(), GenericLinkProvider\getLinksByRel(), PreloadManager\link(), et Access\usergroups().

◆ else

if ( $hideLabel) else

◆ endif

endif

◆ if

if(!empty($parentclass))


Joomla CMS: Référence du fichier webinstaller.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • installer
  • webinstaller
Structures de données | Espaces de nommage
Référence du fichier webinstaller.php

Structures de données

class PlgInstallerWebinstaller

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier RemoveUserFromGroupCommand.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Console
Structures de données | Espaces de nommage
Référence du fichier RemoveUserFromGroupCommand.php

Structures de données

class RemoveUserFromGroupCommand

Espaces de nommage

Joomla\CMS\Console


Joomla CMS: Référence du fichier TableStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TableStyle.php

Structures de données

class TableStyle

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier x095.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x095.php

Variables

return ['Xiao ', 'Suo ', 'Li ', 'Zheng ', 'Chu ', 'Guo ', 'Gao ', 'Tie ', 'Xiu ', 'Cuo ', 'Lue ', 'Feng ', 'Xin ', 'Liu ', 'Kai ', 'Jian ', 'Rui ', 'Ti ', 'Lang ', 'Qian ', 'Ju ', 'A ', 'Qiang ', 'Duo ', 'Tian ', 'Cuo ', 'Mao ', 'Ben ', 'Qi ', 'De ', 'Kua ', 'Kun ', 'Chang ', 'Xi ', 'Gu ', 'Luo ', 'Chui ', 'Zhui ', 'Jin ', 'Zhi ', 'Xian ', 'Juan ', 'Huo ', 'Pou ', 'Tan ', 'Ding ', 'Jian ', 'Ju ', 'Meng ', 'Zi ', 'Qie ', 'Ying ', 'Kai ', 'Qiang ', 'Song ', 'E ', 'Cha ', 'Qiao ', 'Zhong ', 'Duan ', 'Sou ', 'Huang ', 'Huan ', 'Ai ', 'Du ', 'Mei ', 'Lou ', 'Zi ', 'Fei ', 'Mei ', 'Mo ', 'Zhen ', 'Bo ', 'Ge ', 'Nie ', 'Tang ', 'Juan ', 'Nie ', 'Na ', 'Liu ', 'Hao ', 'Bang ', 'Yi ', 'Jia ', 'Bin ', 'Rong ', 'Biao ', 'Tang ', 'Man ', 'Luo ', 'Beng ', 'Yong ', 'Jing ', 'Di ', 'Zu ', 'Xuan ', 'Liu ', 'Tan ', 'Jue ', 'Liao ', 'Pu ', 'Lu ', 'Dui ', 'Lan ', 'Pu ', 'Cuan ', 'Qiang ', 'Deng ', 'Huo ', 'Lei ', 'Huan ', 'Zhuo ', 'Lian ', 'Yi ', 'Cha ', 'Biao ', 'La ', 'Chan ', 'Xiang ', 'Chang ', 'Chang ', 'Jiu ', 'Ao ', 'Die ', 'Qu ', 'Liao ', 'Mi ', 'Chang ', 'Men ', 'Ma ', 'Shuan ', 'Shan ', 'Huo ', 'Men ', 'Yan ', 'Bi ', 'Han ', 'Bi ', 'San ', 'Kai ', 'Kang ', 'Beng ', 'Hong ', 'Run ', 'San ', 'Xian ', 'Xian ', 'Jian ', 'Min ', 'Xia ', 'Yuru ', 'Dou ', 'Zha ', 'Nao ', 'Jian ', 'Peng ', 'Xia ', 'Ling ', 'Bian ', 'Bi ', 'Run ', 'He ', 'Guan ', 'Ge ', 'Ge ', 'Fa ', 'Chu ', 'Hong ', 'Gui ', 'Min ', 'Se ', 'Kun ', 'Lang ', 'Lu ', 'Ting ', 'Sha ', 'Ju ', 'Yue ', 'Yue ', 'Chan ', 'Qu ', 'Lin ', 'Chang ', 'Shai ', 'Kun ', 'Yan ', 'Min ', 'Yan ', 'E ', 'Hun ', 'Yu ', 'Wen ', 'Xiang ', 'Bao ', 'Xiang ', 'Qu ', 'Yao ', 'Wen ', 'Ban ', 'An ', 'Wei ', 'Yin ', 'Kuo ', 'Que ', 'Lan ', 'Du ', '[?] ', 'Phwung ', 'Tian ', 'Nie ', 'Ta ', 'Kai ', 'He ', 'Que ', 'Chuang ', 'Guan ', 'Dou ', 'Qi ', 'Kui ', 'Tang ', 'Guan ', 'Piao ', 'Kan ', 'Xi ', 'Hui ', 'Chan ', 'Pi ', 'Dang ', 'Huan ', 'Ta ', 'Wen ', '[?] ', 'Men ', 'Shuan ', 'Shan ', 'Yan ', 'Han ', 'Bi ', 'Wen ', 'Chuang ', 'Run ', 'Wei ', 'Xian ', 'Hong ', 'Jian ', 'Min ', 'Kang ', 'Men ', 'Zha ', 'Nao ', 'Gui ', 'Wen ', 'Ta ', 'Min ', 'Lu ', 'Kai ']

Documentation des variables

◆ return

return[ 'Xiao ', 'Suo ', 'Li ', 'Zheng ', 'Chu ', 'Guo ', 'Gao ', 'Tie ', 'Xiu ', 'Cuo ', 'Lue ', 'Feng ', 'Xin ', 'Liu ', 'Kai ', 'Jian ', 'Rui ', 'Ti ', 'Lang ', 'Qian ', 'Ju ', 'A ', 'Qiang ', 'Duo ', 'Tian ', 'Cuo ', 'Mao ', 'Ben ', 'Qi ', 'De ', 'Kua ', 'Kun ', 'Chang ', 'Xi ', 'Gu ', 'Luo ', 'Chui ', 'Zhui ', 'Jin ', 'Zhi ', 'Xian ', 'Juan ', 'Huo ', 'Pou ', 'Tan ', 'Ding ', 'Jian ', 'Ju ', 'Meng ', 'Zi ', 'Qie ', 'Ying ', 'Kai ', 'Qiang ', 'Song ', 'E ', 'Cha ', 'Qiao ', 'Zhong ', 'Duan ', 'Sou ', 'Huang ', 'Huan ', 'Ai ', 'Du ', 'Mei ', 'Lou ', 'Zi ', 'Fei ', 'Mei ', 'Mo ', 'Zhen ', 'Bo ', 'Ge ', 'Nie ', 'Tang ', 'Juan ', 'Nie ', 'Na ', 'Liu ', 'Hao ', 'Bang ', 'Yi ', 'Jia ', 'Bin ', 'Rong ', 'Biao ', 'Tang ', 'Man ', 'Luo ', 'Beng ', 'Yong ', 'Jing ', 'Di ', 'Zu ', 'Xuan ', 'Liu ', 'Tan ', 'Jue ', 'Liao ', 'Pu ', 'Lu ', 'Dui ', 'Lan ', 'Pu ', 'Cuan ', 'Qiang ', 'Deng ', 'Huo ', 'Lei ', 'Huan ', 'Zhuo ', 'Lian ', 'Yi ', 'Cha ', 'Biao ', 'La ', 'Chan ', 'Xiang ', 'Chang ', 'Chang ', 'Jiu ', 'Ao ', 'Die ', 'Qu ', 'Liao ', 'Mi ', 'Chang ', 'Men ', 'Ma ', 'Shuan ', 'Shan ', 'Huo ', 'Men ', 'Yan ', 'Bi ', 'Han ', 'Bi ', 'San ', 'Kai ', 'Kang ', 'Beng ', 'Hong ', 'Run ', 'San ', 'Xian ', 'Xian ', 'Jian ', 'Min ', 'Xia ', 'Yuru ', 'Dou ', 'Zha ', 'Nao ', 'Jian ', 'Peng ', 'Xia ', 'Ling ', 'Bian ', 'Bi ', 'Run ', 'He ', 'Guan ', 'Ge ', 'Ge ', 'Fa ', 'Chu ', 'Hong ', 'Gui ', 'Min ', 'Se ', 'Kun ', 'Lang ', 'Lu ', 'Ting ', 'Sha ', 'Ju ', 'Yue ', 'Yue ', 'Chan ', 'Qu ', 'Lin ', 'Chang ', 'Shai ', 'Kun ', 'Yan ', 'Min ', 'Yan ', 'E ', 'Hun ', 'Yu ', 'Wen ', 'Xiang ', 'Bao ', 'Xiang ', 'Qu ', 'Yao ', 'Wen ', 'Ban ', 'An ', 'Wei ', 'Yin ', 'Kuo ', 'Que ', 'Lan ', 'Du ', '[?] ', 'Phwung ', 'Tian ', 'Nie ', 'Ta ', 'Kai ', 'He ', 'Que ', 'Chuang ', 'Guan ', 'Dou ', 'Qi ', 'Kui ', 'Tang ', 'Guan ', 'Piao ', 'Kan ', 'Xi ', 'Hui ', 'Chan ', 'Pi ', 'Dang ', 'Huan ', 'Ta ', 'Wen ', '[?] ', 'Men ', 'Shuan ', 'Shan ', 'Yan ', 'Han ', 'Bi ', 'Wen ', 'Chuang ', 'Run ', 'Wei ', 'Xian ', 'Hong ', 'Jian ', 'Min ', 'Kang ', 'Men ', 'Zha ', 'Nao ', 'Gui ', 'Wen ', 'Ta ', 'Min ', 'Lu ', 'Kai ']


Joomla CMS: Référence du fichier x031.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x031.php

Variables

return ['[?]', '[?]', '[?]', '[?]', '[?]', 'B', 'P', 'M', 'F', 'D', 'T', 'N', 'L', 'G', 'K', 'H', 'J', 'Q', 'X', 'ZH', 'CH', 'SH', 'R', 'Z', 'C', 'S', 'A', 'O', 'E', 'EH', 'AI', 'EI', 'AU', 'OU', 'AN', 'EN', 'ANG', 'ENG', 'ER', 'I', 'U', 'IU', 'V', 'NG', 'GN', '[?]', '[?]', '[?]', '[?]', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'dd', 'r', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'rh', 'm', 'b', 'bb', 'bs', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', 'a', 'ae', 'ya', 'yae', 'eo', 'e', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', 'yo', 'u', 'weo', 'we', 'wi', 'yu', 'eu', 'yi', 'i', '', 'nn', 'nd', 'ns', 'nZ', 'lgs', 'ld', 'lbs', 'lZ', 'lQ', 'mb', 'ms', 'mZ', 'mN', 'bg', '', 'bsg', 'bst', 'bj', 'bt', 'bN', 'bbN', 'sg', 'sn', 'sd', 'sb', 'sj', 'Z', '', 'N', 'Ns', 'NZ', 'pN', 'hh', 'Q', 'yo-ya', 'yo-yae', 'yo-i', 'yu-yeo', 'yu-ye', 'yu-i', 'U', 'U-i', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 'BU', 'ZI', 'JI', 'GU', 'EE', 'ENN', 'OO', 'ONN', 'IR', 'ANN', 'INN', 'UNN', 'IM', 'NGG', 'AINN', 'AUNN', 'AM', 'OM', 'ONG', 'INNN', 'P', 'T', 'K', 'H', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return['[?]', '[?]', '[?]', '[?]', '[?]', 'B', 'P', 'M', 'F', 'D', 'T', 'N', 'L', 'G', 'K', 'H', 'J', 'Q', 'X', 'ZH', 'CH', 'SH', 'R', 'Z', 'C', 'S', 'A', 'O', 'E', 'EH', 'AI', 'EI', 'AU', 'OU', 'AN', 'EN', 'ANG', 'ENG', 'ER', 'I', 'U', 'IU', 'V', 'NG', 'GN', '[?]', '[?]', '[?]', '[?]', 'g', 'gg', 'gs', 'n', 'nj', 'nh', 'd', 'dd', 'r', 'lg', 'lm', 'lb', 'ls', 'lt', 'lp', 'rh', 'm', 'b', 'bb', 'bs', 's', 'ss', '', 'j', 'jj', 'c', 'k', 't', 'p', 'h', 'a', 'ae', 'ya', 'yae', 'eo', 'e', 'yeo', 'ye', 'o', 'wa', 'wae', 'oe', 'yo', 'u', 'weo', 'we', 'wi', 'yu', 'eu', 'yi', 'i', '', 'nn', 'nd', 'ns', 'nZ', 'lgs', 'ld', 'lbs', 'lZ', 'lQ', 'mb', 'ms', 'mZ', 'mN', 'bg', '', 'bsg', 'bst', 'bj', 'bt', 'bN', 'bbN', 'sg', 'sn', 'sd', 'sb', 'sj', 'Z', '', 'N', 'Ns', 'NZ', 'pN', 'hh', 'Q', 'yo-ya', 'yo-yae', 'yo-i', 'yu-yeo', 'yu-ye', 'yu-i', 'U', 'U-i', '[?]', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 'BU', 'ZI', 'JI', 'GU', 'EE', 'ENN', 'OO', 'ONN', 'IR', 'ANN', 'INN', 'UNN', 'IM', 'NGG', 'AINN', 'AUNN', 'AM', 'OM', 'ONG', 'INNN', 'P', 'T', 'K', 'H', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier x0d4.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0d4.php

Variables

return ['poss', 'pong', 'poj', 'poc', 'pok', 'pot', 'pop', 'poh', 'pwa', 'pwag', 'pwagg', 'pwags', 'pwan', 'pwanj', 'pwanh', 'pwad', 'pwal', 'pwalg', 'pwalm', 'pwalb', 'pwals', 'pwalt', 'pwalp', 'pwalh', 'pwam', 'pwab', 'pwabs', 'pwas', 'pwass', 'pwang', 'pwaj', 'pwac', 'pwak', 'pwat', 'pwap', 'pwah', 'pwae', 'pwaeg', 'pwaegg', 'pwaegs', 'pwaen', 'pwaenj', 'pwaenh', 'pwaed', 'pwael', 'pwaelg', 'pwaelm', 'pwaelb', 'pwaels', 'pwaelt', 'pwaelp', 'pwaelh', 'pwaem', 'pwaeb', 'pwaebs', 'pwaes', 'pwaess', 'pwaeng', 'pwaej', 'pwaec', 'pwaek', 'pwaet', 'pwaep', 'pwaeh', 'poe', 'poeg', 'poegg', 'poegs', 'poen', 'poenj', 'poenh', 'poed', 'poel', 'poelg', 'poelm', 'poelb', 'poels', 'poelt', 'poelp', 'poelh', 'poem', 'poeb', 'poebs', 'poes', 'poess', 'poeng', 'poej', 'poec', 'poek', 'poet', 'poep', 'poeh', 'pyo', 'pyog', 'pyogg', 'pyogs', 'pyon', 'pyonj', 'pyonh', 'pyod', 'pyol', 'pyolg', 'pyolm', 'pyolb', 'pyols', 'pyolt', 'pyolp', 'pyolh', 'pyom', 'pyob', 'pyobs', 'pyos', 'pyoss', 'pyong', 'pyoj', 'pyoc', 'pyok', 'pyot', 'pyop', 'pyoh', 'pu', 'pug', 'pugg', 'pugs', 'pun', 'punj', 'punh', 'pud', 'pul', 'pulg', 'pulm', 'pulb', 'puls', 'pult', 'pulp', 'pulh', 'pum', 'pub', 'pubs', 'pus', 'puss', 'pung', 'puj', 'puc', 'puk', 'put', 'pup', 'puh', 'pweo', 'pweog', 'pweogg', 'pweogs', 'pweon', 'pweonj', 'pweonh', 'pweod', 'pweol', 'pweolg', 'pweolm', 'pweolb', 'pweols', 'pweolt', 'pweolp', 'pweolh', 'pweom', 'pweob', 'pweobs', 'pweos', 'pweoss', 'pweong', 'pweoj', 'pweoc', 'pweok', 'pweot', 'pweop', 'pweoh', 'pwe', 'pweg', 'pwegg', 'pwegs', 'pwen', 'pwenj', 'pwenh', 'pwed', 'pwel', 'pwelg', 'pwelm', 'pwelb', 'pwels', 'pwelt', 'pwelp', 'pwelh', 'pwem', 'pweb', 'pwebs', 'pwes', 'pwess', 'pweng', 'pwej', 'pwec', 'pwek', 'pwet', 'pwep', 'pweh', 'pwi', 'pwig', 'pwigg', 'pwigs', 'pwin', 'pwinj', 'pwinh', 'pwid', 'pwil', 'pwilg', 'pwilm', 'pwilb', 'pwils', 'pwilt', 'pwilp', 'pwilh', 'pwim', 'pwib', 'pwibs', 'pwis', 'pwiss', 'pwing', 'pwij', 'pwic', 'pwik', 'pwit', 'pwip', 'pwih', 'pyu', 'pyug', 'pyugg', 'pyugs', 'pyun', 'pyunj', 'pyunh', 'pyud', 'pyul', 'pyulg', 'pyulm', 'pyulb', 'pyuls', 'pyult', 'pyulp', 'pyulh', 'pyum', 'pyub', 'pyubs', 'pyus', 'pyuss', 'pyung', 'pyuj', 'pyuc']

Documentation des variables

◆ return

return[ 'poss', 'pong', 'poj', 'poc', 'pok', 'pot', 'pop', 'poh', 'pwa', 'pwag', 'pwagg', 'pwags', 'pwan', 'pwanj', 'pwanh', 'pwad', 'pwal', 'pwalg', 'pwalm', 'pwalb', 'pwals', 'pwalt', 'pwalp', 'pwalh', 'pwam', 'pwab', 'pwabs', 'pwas', 'pwass', 'pwang', 'pwaj', 'pwac', 'pwak', 'pwat', 'pwap', 'pwah', 'pwae', 'pwaeg', 'pwaegg', 'pwaegs', 'pwaen', 'pwaenj', 'pwaenh', 'pwaed', 'pwael', 'pwaelg', 'pwaelm', 'pwaelb', 'pwaels', 'pwaelt', 'pwaelp', 'pwaelh', 'pwaem', 'pwaeb', 'pwaebs', 'pwaes', 'pwaess', 'pwaeng', 'pwaej', 'pwaec', 'pwaek', 'pwaet', 'pwaep', 'pwaeh', 'poe', 'poeg', 'poegg', 'poegs', 'poen', 'poenj', 'poenh', 'poed', 'poel', 'poelg', 'poelm', 'poelb', 'poels', 'poelt', 'poelp', 'poelh', 'poem', 'poeb', 'poebs', 'poes', 'poess', 'poeng', 'poej', 'poec', 'poek', 'poet', 'poep', 'poeh', 'pyo', 'pyog', 'pyogg', 'pyogs', 'pyon', 'pyonj', 'pyonh', 'pyod', 'pyol', 'pyolg', 'pyolm', 'pyolb', 'pyols', 'pyolt', 'pyolp', 'pyolh', 'pyom', 'pyob', 'pyobs', 'pyos', 'pyoss', 'pyong', 'pyoj', 'pyoc', 'pyok', 'pyot', 'pyop', 'pyoh', 'pu', 'pug', 'pugg', 'pugs', 'pun', 'punj', 'punh', 'pud', 'pul', 'pulg', 'pulm', 'pulb', 'puls', 'pult', 'pulp', 'pulh', 'pum', 'pub', 'pubs', 'pus', 'puss', 'pung', 'puj', 'puc', 'puk', 'put', 'pup', 'puh', 'pweo', 'pweog', 'pweogg', 'pweogs', 'pweon', 'pweonj', 'pweonh', 'pweod', 'pweol', 'pweolg', 'pweolm', 'pweolb', 'pweols', 'pweolt', 'pweolp', 'pweolh', 'pweom', 'pweob', 'pweobs', 'pweos', 'pweoss', 'pweong', 'pweoj', 'pweoc', 'pweok', 'pweot', 'pweop', 'pweoh', 'pwe', 'pweg', 'pwegg', 'pwegs', 'pwen', 'pwenj', 'pwenh', 'pwed', 'pwel', 'pwelg', 'pwelm', 'pwelb', 'pwels', 'pwelt', 'pwelp', 'pwelh', 'pwem', 'pweb', 'pwebs', 'pwes', 'pwess', 'pweng', 'pwej', 'pwec', 'pwek', 'pwet', 'pwep', 'pweh', 'pwi', 'pwig', 'pwigg', 'pwigs', 'pwin', 'pwinj', 'pwinh', 'pwid', 'pwil', 'pwilg', 'pwilm', 'pwilb', 'pwils', 'pwilt', 'pwilp', 'pwilh', 'pwim', 'pwib', 'pwibs', 'pwis', 'pwiss', 'pwing', 'pwij', 'pwic', 'pwik', 'pwit', 'pwip', 'pwih', 'pyu', 'pyug', 'pyugg', 'pyugs', 'pyun', 'pyunj', 'pyunh', 'pyud', 'pyul', 'pyulg', 'pyulm', 'pyulb', 'pyuls', 'pyult', 'pyulp', 'pyulh', 'pyum', 'pyub', 'pyubs', 'pyus', 'pyuss', 'pyung', 'pyuj', 'pyuc']


Joomla CMS: Référence du fichier RedirectResponse.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
  • Response
Structures de données | Espaces de nommage
Référence du fichier RedirectResponse.php

Structures de données

class RedirectResponse

Espaces de nommage

Laminas\Diactoros\Response


Joomla CMS: Référence du fichier TemplateParser.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
Structures de données | Espaces de nommage
Référence du fichier TemplateParser.php

Structures de données

class TemplateParser

Espaces de nommage

FG\ASN1


Joomla CMS: Référence du fichier Util.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier tobscure/json-api/src/Util.php

Structures de données

class Util

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier RequestsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • api
  • components
  • com_privacy
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier api/components/com_privacy/src/Controller/RequestsController.php

Structures de données

class RequestsController

Espaces de nommage

Joomla\API
Joomla\Component\Privacy\Api\Controller


Joomla CMS: Référence du fichier Priority.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • event
  • src
Structures de données | Espaces de nommage
Référence du fichier Priority.php

Structures de données

class Priority

Espaces de nommage

Joomla\Event


Joomla CMS: Référence du fichier UserController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_users
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_users/src/Controller/UserController.php

Structures de données

class UserController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Users\Administrator\Controller


Joomla CMS: Référence du fichier Resource.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • tobscure
  • json-api
  • src
Structures de données | Espaces de nommage
Référence du fichier Resource.php

Structures de données

class Resource

Espaces de nommage

Tobscure\JsonApi


Joomla CMS: Référence du fichier WrapperHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_wrapper
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier WrapperHelper.php

Structures de données

class WrapperHelper

Espaces de nommage

Joomla\Site
Joomla\Module\Wrapper\Site\Helper


Joomla CMS: Référence du fichier SerializerErrorRenderer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorRenderer
Structures de données | Espaces de nommage
Référence du fichier SerializerErrorRenderer.php

Structures de données

class SerializerErrorRenderer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorRenderer


Joomla CMS: Référence du fichier ResourceNotFound.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Controller
  • Exception
Structures de données | Espaces de nommage
Référence du fichier ResourceNotFound.php

Structures de données

class ResourceNotFound

Espaces de nommage

Joomla\CMS\MVC\Controller\Exception


Joomla CMS: Référence du fichier Toolbar.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Toolbar
Structures de données | Espaces de nommage
Référence du fichier Toolbar/Toolbar.php

Structures de données

class Toolbar

Espaces de nommage

Joomla\CMS\Toolbar


Joomla CMS: Référence du fichier RelativeDistinguishedName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • fgrosse
  • phpasn1
  • lib
  • ASN1
  • Composite
Structures de données | Espaces de nommage
Référence du fichier fgrosse/phpasn1/lib/ASN1/Composite/RelativeDistinguishedName.php

Structures de données

class RelativeDistinguishedName

Espaces de nommage

FG\ASN1\Composite


Joomla CMS: Référence du fichier StateBehaviorTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Espaces de nommage | Fonctions | Variables
Référence du fichier StateBehaviorTrait.php

Espaces de nommage

Joomla\CMS\MVC\Model

Fonctions

getState ($property=null, $default=null)
setState ($property, $value=null)
populateState ()

Variables

trait StateBehaviorTrait
$state = null


Joomla CMS: Référence du fichier Token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
Structures de données | Espaces de nommage
Référence du fichier libraries/vendor/lcobucci/jwt/src/Token.php

Structures de données

class Token

Espaces de nommage

Lcobucci\JWT


Joomla CMS: Référence du fichier x052.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x052.php

Variables

return ['Dao ', 'Diao ', 'Dao ', 'Ren ', 'Ren ', 'Chuang ', 'Fen ', 'Qie ', 'Yi ', 'Ji ', 'Kan ', 'Qian ', 'Cun ', 'Chu ', 'Wen ', 'Ji ', 'Dan ', 'Xing ', 'Hua ', 'Wan ', 'Jue ', 'Li ', 'Yue ', 'Lie ', 'Liu ', 'Ze ', 'Gang ', 'Chuang ', 'Fu ', 'Chu ', 'Qu ', 'Ju ', 'Shan ', 'Min ', 'Ling ', 'Zhong ', 'Pan ', 'Bie ', 'Jie ', 'Jie ', 'Bao ', 'Li ', 'Shan ', 'Bie ', 'Chan ', 'Jing ', 'Gua ', 'Gen ', 'Dao ', 'Chuang ', 'Kui ', 'Ku ', 'Duo ', 'Er ', 'Zhi ', 'Shua ', 'Quan ', 'Cha ', 'Ci ', 'Ke ', 'Jie ', 'Gui ', 'Ci ', 'Gui ', 'Kai ', 'Duo ', 'Ji ', 'Ti ', 'Jing ', 'Lou ', 'Gen ', 'Ze ', 'Yuan ', 'Cuo ', 'Xue ', 'Ke ', 'La ', 'Qian ', 'Cha ', 'Chuang ', 'Gua ', 'Jian ', 'Cuo ', 'Li ', 'Ti ', 'Fei ', 'Pou ', 'Chan ', 'Qi ', 'Chuang ', 'Zi ', 'Gang ', 'Wan ', 'Bo ', 'Ji ', 'Duo ', 'Qing ', 'Yan ', 'Zhuo ', 'Jian ', 'Ji ', 'Bo ', 'Yan ', 'Ju ', 'Huo ', 'Sheng ', 'Jian ', 'Duo ', 'Duan ', 'Wu ', 'Gua ', 'Fu ', 'Sheng ', 'Jian ', 'Ge ', 'Zha ', 'Kai ', 'Chuang ', 'Juan ', 'Chan ', 'Tuan ', 'Lu ', 'Li ', 'Fou ', 'Shan ', 'Piao ', 'Kou ', 'Jiao ', 'Gua ', 'Qiao ', 'Jue ', 'Hua ', 'Zha ', 'Zhuo ', 'Lian ', 'Ju ', 'Pi ', 'Liu ', 'Gui ', 'Jiao ', 'Gui ', 'Jian ', 'Jian ', 'Tang ', 'Huo ', 'Ji ', 'Jian ', 'Yi ', 'Jian ', 'Zhi ', 'Chan ', 'Cuan ', 'Mo ', 'Li ', 'Zhu ', 'Li ', 'Ya ', 'Quan ', 'Ban ', 'Gong ', 'Jia ', 'Wu ', 'Mai ', 'Lie ', 'Jin ', 'Keng ', 'Xie ', 'Zhi ', 'Dong ', 'Zhu ', 'Nu ', 'Jie ', 'Qu ', 'Shao ', 'Yi ', 'Zhu ', 'Miao ', 'Li ', 'Jing ', 'Lao ', 'Lao ', 'Juan ', 'Kou ', 'Yang ', 'Wa ', 'Xiao ', 'Mou ', 'Kuang ', 'Jie ', 'Lie ', 'He ', 'Shi ', 'Ke ', 'Jing ', 'Hao ', 'Bo ', 'Min ', 'Chi ', 'Lang ', 'Yong ', 'Yong ', 'Mian ', 'Ke ', 'Xun ', 'Juan ', 'Qing ', 'Lu ', 'Pou ', 'Meng ', 'Lai ', 'Le ', 'Kai ', 'Mian ', 'Dong ', 'Xu ', 'Xu ', 'Kan ', 'Wu ', 'Yi ', 'Xun ', 'Weng ', 'Sheng ', 'Lao ', 'Mu ', 'Lu ', 'Piao ', 'Shi ', 'Ji ', 'Qin ', 'Qiang ', 'Jiao ', 'Quan ', 'Yang ', 'Yi ', 'Jue ', 'Fan ', 'Juan ', 'Tong ', 'Ju ', 'Dan ', 'Xie ', 'Mai ', 'Xun ', 'Xun ', 'Lu ', 'Li ', 'Che ', 'Rang ', 'Quan ', 'Bao ', 'Shao ', 'Yun ', 'Jiu ', 'Bao ', 'Gou ', 'Wu ']

Documentation des variables

◆ return

return[ 'Dao ', 'Diao ', 'Dao ', 'Ren ', 'Ren ', 'Chuang ', 'Fen ', 'Qie ', 'Yi ', 'Ji ', 'Kan ', 'Qian ', 'Cun ', 'Chu ', 'Wen ', 'Ji ', 'Dan ', 'Xing ', 'Hua ', 'Wan ', 'Jue ', 'Li ', 'Yue ', 'Lie ', 'Liu ', 'Ze ', 'Gang ', 'Chuang ', 'Fu ', 'Chu ', 'Qu ', 'Ju ', 'Shan ', 'Min ', 'Ling ', 'Zhong ', 'Pan ', 'Bie ', 'Jie ', 'Jie ', 'Bao ', 'Li ', 'Shan ', 'Bie ', 'Chan ', 'Jing ', 'Gua ', 'Gen ', 'Dao ', 'Chuang ', 'Kui ', 'Ku ', 'Duo ', 'Er ', 'Zhi ', 'Shua ', 'Quan ', 'Cha ', 'Ci ', 'Ke ', 'Jie ', 'Gui ', 'Ci ', 'Gui ', 'Kai ', 'Duo ', 'Ji ', 'Ti ', 'Jing ', 'Lou ', 'Gen ', 'Ze ', 'Yuan ', 'Cuo ', 'Xue ', 'Ke ', 'La ', 'Qian ', 'Cha ', 'Chuang ', 'Gua ', 'Jian ', 'Cuo ', 'Li ', 'Ti ', 'Fei ', 'Pou ', 'Chan ', 'Qi ', 'Chuang ', 'Zi ', 'Gang ', 'Wan ', 'Bo ', 'Ji ', 'Duo ', 'Qing ', 'Yan ', 'Zhuo ', 'Jian ', 'Ji ', 'Bo ', 'Yan ', 'Ju ', 'Huo ', 'Sheng ', 'Jian ', 'Duo ', 'Duan ', 'Wu ', 'Gua ', 'Fu ', 'Sheng ', 'Jian ', 'Ge ', 'Zha ', 'Kai ', 'Chuang ', 'Juan ', 'Chan ', 'Tuan ', 'Lu ', 'Li ', 'Fou ', 'Shan ', 'Piao ', 'Kou ', 'Jiao ', 'Gua ', 'Qiao ', 'Jue ', 'Hua ', 'Zha ', 'Zhuo ', 'Lian ', 'Ju ', 'Pi ', 'Liu ', 'Gui ', 'Jiao ', 'Gui ', 'Jian ', 'Jian ', 'Tang ', 'Huo ', 'Ji ', 'Jian ', 'Yi ', 'Jian ', 'Zhi ', 'Chan ', 'Cuan ', 'Mo ', 'Li ', 'Zhu ', 'Li ', 'Ya ', 'Quan ', 'Ban ', 'Gong ', 'Jia ', 'Wu ', 'Mai ', 'Lie ', 'Jin ', 'Keng ', 'Xie ', 'Zhi ', 'Dong ', 'Zhu ', 'Nu ', 'Jie ', 'Qu ', 'Shao ', 'Yi ', 'Zhu ', 'Miao ', 'Li ', 'Jing ', 'Lao ', 'Lao ', 'Juan ', 'Kou ', 'Yang ', 'Wa ', 'Xiao ', 'Mou ', 'Kuang ', 'Jie ', 'Lie ', 'He ', 'Shi ', 'Ke ', 'Jing ', 'Hao ', 'Bo ', 'Min ', 'Chi ', 'Lang ', 'Yong ', 'Yong ', 'Mian ', 'Ke ', 'Xun ', 'Juan ', 'Qing ', 'Lu ', 'Pou ', 'Meng ', 'Lai ', 'Le ', 'Kai ', 'Mian ', 'Dong ', 'Xu ', 'Xu ', 'Kan ', 'Wu ', 'Yi ', 'Xun ', 'Weng ', 'Sheng ', 'Lao ', 'Mu ', 'Lu ', 'Piao ', 'Shi ', 'Ji ', 'Qin ', 'Qiang ', 'Jiao ', 'Quan ', 'Yang ', 'Yi ', 'Jue ', 'Fan ', 'Juan ', 'Tong ', 'Ju ', 'Dan ', 'Xie ', 'Mai ', 'Xun ', 'Xun ', 'Lu ', 'Li ', 'Che ', 'Rang ', 'Quan ', 'Bao ', 'Shao ', 'Yun ', 'Jiu ', 'Bao ', 'Gou ', 'Wu ']


Joomla CMS: Référence du fichier UrlField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Field
Structures de données | Espaces de nommage
Référence du fichier UrlField.php

Structures de données

class UrlField

Espaces de nommage

Joomla\CMS\Form\Field


Joomla CMS: C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php

C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/vendor/beberlei/assert/lib/Assert/Assert.php

Start validation on a value, returns AssertionChain.

The invocation of this method starts an assertion chain that is happening on the passed value.

Paramètres
mixed | $value
string | callable | null | $defaultMessage

Assert::that($value)->notEmpty()->integer(); Assert::that($value)->nullOr()->string()->startsWith("Foo");

The assertion chain can be stateful, that means be careful when you reuse it. You should never pass around the chain.

<?php
namespace Assert;
abstract class Assert
{
protected static $lazyAssertionExceptionClass = LazyAssertionException::class;
protected static $assertionClass = Assertion::class;
public static function that($value, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
$assertionChain = new AssertionChain($value, $defaultMessage, $defaultPropertyPath);
return $assertionChain->setAssertionClassName(static::$assertionClass);
}
public static function thatAll($values, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
return static::that($values, $defaultMessage, $defaultPropertyPath)->all();
}
public static function thatNullOr($value, $defaultMessage = null, string $defaultPropertyPath = null): AssertionChain
{
return static::that($value, $defaultMessage, $defaultPropertyPath)->nullOr();
}
public static function lazy(): LazyAssertion
{
$lazyAssertion = new LazyAssertion();
return $lazyAssertion
->setAssertClass(\get_called_class())
->setExceptionClass(static::$lazyAssertionExceptionClass);
}
}


Joomla CMS: Référence du fichier x016.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x016.php

Variables

return ['kka', 'kk', 'nu', 'no', 'ne', 'nee', 'ni', 'na', 'mu', 'mo', 'me', 'mee', 'mi', 'ma', 'yu', 'yo', 'ye', 'yee', 'yi', 'ya', 'ju', 'ju', 'jo', 'je', 'jee', 'ji', 'ji', 'ja', 'jju', 'jjo', 'jje', 'jjee', 'jji', 'jja', 'lu', 'lo', 'le', 'lee', 'li', 'la', 'dlu', 'dlo', 'dle', 'dlee', 'dli', 'dla', 'lhu', 'lho', 'lhe', 'lhee', 'lhi', 'lha', 'tlhu', 'tlho', 'tlhe', 'tlhee', 'tlhi', 'tlha', 'tlu', 'tlo', 'tle', 'tlee', 'tli', 'tla', 'zu', 'zo', 'ze', 'zee', 'zi', 'za', 'z', 'z', 'dzu', 'dzo', 'dze', 'dzee', 'dzi', 'dza', 'su', 'so', 'se', 'see', 'si', 'sa', 'shu', 'sho', 'she', 'shee', 'shi', 'sha', 'sh', 'tsu', 'tso', 'tse', 'tsee', 'tsi', 'tsa', 'chu', 'cho', 'che', 'chee', 'chi', 'cha', 'ttsu', 'ttso', 'ttse', 'ttsee', 'ttsi', 'ttsa', 'X', '.', 'qai', 'ngai', 'nngi', 'nngii', 'nngo', 'nngoo', 'nnga', 'nngaa', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ' ', 'b', 'l', 'f', 's', 'n', 'h', 'd', 't', 'c', 'q', 'm', 'g', 'ng', 'z', 'r', 'a', 'o', 'u', 'e', 'i', 'ch', 'th', 'ph', 'p', 'x', 'p', '<', '>', '[?]', '[?]', '[?]', 'f', 'v', 'u', 'yr', 'y', 'w', 'th', 'th', 'a', 'o', 'ac', 'ae', 'o', 'o', 'o', 'oe', 'on', 'r', 'k', 'c', 'k', 'g', 'ng', 'g', 'g', 'w', 'h', 'h', 'h', 'h', 'n', 'n', 'n', 'i', 'e', 'j', 'g', 'ae', 'a', 'eo', 'p', 'z', 's', 's', 's', 'c', 'z', 't', 't', 'd', 'b', 'b', 'p', 'p', 'e', 'm', 'm', 'm', 'l', 'l', 'ng', 'ng', 'd', 'o', 'ear', 'ior', 'qu', 'qu', 'qu', 's', 'yr', 'yr', 'yr', 'q', 'x', '.', ':', '+', '17', '18', '19', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']

Documentation des variables

◆ return

return[ 'kka', 'kk', 'nu', 'no', 'ne', 'nee', 'ni', 'na', 'mu', 'mo', 'me', 'mee', 'mi', 'ma', 'yu', 'yo', 'ye', 'yee', 'yi', 'ya', 'ju', 'ju', 'jo', 'je', 'jee', 'ji', 'ji', 'ja', 'jju', 'jjo', 'jje', 'jjee', 'jji', 'jja', 'lu', 'lo', 'le', 'lee', 'li', 'la', 'dlu', 'dlo', 'dle', 'dlee', 'dli', 'dla', 'lhu', 'lho', 'lhe', 'lhee', 'lhi', 'lha', 'tlhu', 'tlho', 'tlhe', 'tlhee', 'tlhi', 'tlha', 'tlu', 'tlo', 'tle', 'tlee', 'tli', 'tla', 'zu', 'zo', 'ze', 'zee', 'zi', 'za', 'z', 'z', 'dzu', 'dzo', 'dze', 'dzee', 'dzi', 'dza', 'su', 'so', 'se', 'see', 'si', 'sa', 'shu', 'sho', 'she', 'shee', 'shi', 'sha', 'sh', 'tsu', 'tso', 'tse', 'tsee', 'tsi', 'tsa', 'chu', 'cho', 'che', 'chee', 'chi', 'cha', 'ttsu', 'ttso', 'ttse', 'ttsee', 'ttsi', 'ttsa', 'X', '.', 'qai', 'ngai', 'nngi', 'nngii', 'nngo', 'nngoo', 'nnga', 'nngaa', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', ' ', 'b', 'l', 'f', 's', 'n', 'h', 'd', 't', 'c', 'q', 'm', 'g', 'ng', 'z', 'r', 'a', 'o', 'u', 'e', 'i', 'ch', 'th', 'ph', 'p', 'x', 'p', '<', '>', '[?]', '[?]', '[?]', 'f', 'v', 'u', 'yr', 'y', 'w', 'th', 'th', 'a', 'o', 'ac', 'ae', 'o', 'o', 'o', 'oe', 'on', 'r', 'k', 'c', 'k', 'g', 'ng', 'g', 'g', 'w', 'h', 'h', 'h', 'h', 'n', 'n', 'n', 'i', 'e', 'j', 'g', 'ae', 'a', 'eo', 'p', 'z', 's', 's', 's', 'c', 'z', 't', 't', 'd', 'b', 'b', 'p', 'p', 'e', 'm', 'm', 'm', 'l', 'l', 'ng', 'ng', 'd', 'o', 'ear', 'ior', 'qu', 'qu', 'qu', 's', 'yr', 'yr', 'yr', 'q', 'x', '.', ':', '+', '17', '18', '19', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]', '[?]']


Joomla CMS: Référence du fichier PluginsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_plugins/src/Controller/PluginsController.php

Structures de données

class PluginsController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Controller


Joomla CMS: Référence du fichier WorkflowModelInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • MVC
  • Model
Structures de données | Espaces de nommage
Référence du fichier WorkflowModelInterface.php

Structures de données

interface WorkflowModelInterface

Espaces de nommage

Joomla\CMS\MVC\Model


Joomla CMS: Référence du fichier SipHash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • paragonie
  • sodium_compat
  • src
  • Core32
Structures de données
Référence du fichier src/Core32/SipHash.php

Structures de données

class ParagonIE_Sodium_Core32_SipHash


Joomla CMS: Référence du fichier ServerRequest.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/ServerRequest.php

Structures de données

class ServerRequest

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier VersionableModelTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Versioning
Espaces de nommage
Référence du fichier VersionableModelTrait.php

Espaces de nommage

Joomla\CMS\Versioning


Joomla CMS: Référence du fichier PersonalName.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PersonalName.php

Structures de données

class PersonalName

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier TagController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_tags
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier TagController.php

Structures de données

class TagController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Tags\Administrator\Controller


Joomla CMS: Référence du fichier RequestMethod.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
Structures de données | Espaces de nommage
Référence du fichier RequestMethod.php

Structures de données

interface RequestMethod

Espaces de nommage

ReCaptcha


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_checkin
  • services
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_checkin/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier RS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • cose-lib
  • src
  • Algorithm
  • Signature
  • RSA
Structures de données | Espaces de nommage
Référence du fichier web-auth/cose-lib/src/Algorithm/Signature/RSA/RS1.php

Structures de données

class RS1

Espaces de nommage

Cose\Algorithm\Signature\RSA


Joomla CMS: Référence du fichier x0a0.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0a0.php

Variables

return ['it', 'ix', 'i', 'ip', 'iet', 'iex', 'ie', 'iep', 'at', 'ax', 'a', 'ap', 'uox', 'uo', 'uop', 'ot', 'ox', 'o', 'op', 'ex', 'e', 'wu', 'bit', 'bix', 'bi', 'bip', 'biet', 'biex', 'bie', 'biep', 'bat', 'bax', 'ba', 'bap', 'buox', 'buo', 'buop', 'bot', 'box', 'bo', 'bop', 'bex', 'be', 'bep', 'but', 'bux', 'bu', 'bup', 'burx', 'bur', 'byt', 'byx', 'by', 'byp', 'byrx', 'byr', 'pit', 'pix', 'pi', 'pip', 'piex', 'pie', 'piep', 'pat', 'pax', 'pa', 'pap', 'puox', 'puo', 'puop', 'pot', 'pox', 'po', 'pop', 'put', 'pux', 'pu', 'pup', 'purx', 'pur', 'pyt', 'pyx', 'py', 'pyp', 'pyrx', 'pyr', 'bbit', 'bbix', 'bbi', 'bbip', 'bbiet', 'bbiex', 'bbie', 'bbiep', 'bbat', 'bbax', 'bba', 'bbap', 'bbuox', 'bbuo', 'bbuop', 'bbot', 'bbox', 'bbo', 'bbop', 'bbex', 'bbe', 'bbep', 'bbut', 'bbux', 'bbu', 'bbup', 'bburx', 'bbur', 'bbyt', 'bbyx', 'bby', 'bbyp', 'nbit', 'nbix', 'nbi', 'nbip', 'nbiex', 'nbie', 'nbiep', 'nbat', 'nbax', 'nba', 'nbap', 'nbot', 'nbox', 'nbo', 'nbop', 'nbut', 'nbux', 'nbu', 'nbup', 'nburx', 'nbur', 'nbyt', 'nbyx', 'nby', 'nbyp', 'nbyrx', 'nbyr', 'hmit', 'hmix', 'hmi', 'hmip', 'hmiex', 'hmie', 'hmiep', 'hmat', 'hmax', 'hma', 'hmap', 'hmuox', 'hmuo', 'hmuop', 'hmot', 'hmox', 'hmo', 'hmop', 'hmut', 'hmux', 'hmu', 'hmup', 'hmurx', 'hmur', 'hmyx', 'hmy', 'hmyp', 'hmyrx', 'hmyr', 'mit', 'mix', 'mi', 'mip', 'miex', 'mie', 'miep', 'mat', 'max', 'ma', 'map', 'muot', 'muox', 'muo', 'muop', 'mot', 'mox', 'mo', 'mop', 'mex', 'me', 'mut', 'mux', 'mu', 'mup', 'murx', 'mur', 'myt', 'myx', 'my', 'myp', 'fit', 'fix', 'fi', 'fip', 'fat', 'fax', 'fa', 'fap', 'fox', 'fo', 'fop', 'fut', 'fux', 'fu', 'fup', 'furx', 'fur', 'fyt', 'fyx', 'fy', 'fyp', 'vit', 'vix', 'vi', 'vip', 'viet', 'viex', 'vie', 'viep', 'vat', 'vax', 'va', 'vap', 'vot', 'vox', 'vo', 'vop', 'vex', 'vep', 'vut', 'vux', 'vu', 'vup', 'vurx', 'vur', 'vyt', 'vyx', 'vy', 'vyp', 'vyrx', 'vyr']

Documentation des variables

◆ return

return[ 'it', 'ix', 'i', 'ip', 'iet', 'iex', 'ie', 'iep', 'at', 'ax', 'a', 'ap', 'uox', 'uo', 'uop', 'ot', 'ox', 'o', 'op', 'ex', 'e', 'wu', 'bit', 'bix', 'bi', 'bip', 'biet', 'biex', 'bie', 'biep', 'bat', 'bax', 'ba', 'bap', 'buox', 'buo', 'buop', 'bot', 'box', 'bo', 'bop', 'bex', 'be', 'bep', 'but', 'bux', 'bu', 'bup', 'burx', 'bur', 'byt', 'byx', 'by', 'byp', 'byrx', 'byr', 'pit', 'pix', 'pi', 'pip', 'piex', 'pie', 'piep', 'pat', 'pax', 'pa', 'pap', 'puox', 'puo', 'puop', 'pot', 'pox', 'po', 'pop', 'put', 'pux', 'pu', 'pup', 'purx', 'pur', 'pyt', 'pyx', 'py', 'pyp', 'pyrx', 'pyr', 'bbit', 'bbix', 'bbi', 'bbip', 'bbiet', 'bbiex', 'bbie', 'bbiep', 'bbat', 'bbax', 'bba', 'bbap', 'bbuox', 'bbuo', 'bbuop', 'bbot', 'bbox', 'bbo', 'bbop', 'bbex', 'bbe', 'bbep', 'bbut', 'bbux', 'bbu', 'bbup', 'bburx', 'bbur', 'bbyt', 'bbyx', 'bby', 'bbyp', 'nbit', 'nbix', 'nbi', 'nbip', 'nbiex', 'nbie', 'nbiep', 'nbat', 'nbax', 'nba', 'nbap', 'nbot', 'nbox', 'nbo', 'nbop', 'nbut', 'nbux', 'nbu', 'nbup', 'nburx', 'nbur', 'nbyt', 'nbyx', 'nby', 'nbyp', 'nbyrx', 'nbyr', 'hmit', 'hmix', 'hmi', 'hmip', 'hmiex', 'hmie', 'hmiep', 'hmat', 'hmax', 'hma', 'hmap', 'hmuox', 'hmuo', 'hmuop', 'hmot', 'hmox', 'hmo', 'hmop', 'hmut', 'hmux', 'hmu', 'hmup', 'hmurx', 'hmur', 'hmyx', 'hmy', 'hmyp', 'hmyrx', 'hmyr', 'mit', 'mix', 'mi', 'mip', 'miex', 'mie', 'miep', 'mat', 'max', 'ma', 'map', 'muot', 'muox', 'muo', 'muop', 'mot', 'mox', 'mo', 'mop', 'mex', 'me', 'mut', 'mux', 'mu', 'mup', 'murx', 'mur', 'myt', 'myx', 'my', 'myp', 'fit', 'fix', 'fi', 'fip', 'fat', 'fax', 'fa', 'fap', 'fox', 'fo', 'fop', 'fut', 'fux', 'fu', 'fup', 'furx', 'fur', 'fyt', 'fyx', 'fy', 'fyp', 'vit', 'vix', 'vi', 'vip', 'viet', 'viex', 'vie', 'viep', 'vat', 'vax', 'va', 'vap', 'vot', 'vox', 'vo', 'vop', 'vex', 'vep', 'vut', 'vux', 'vu', 'vup', 'vurx', 'vur', 'vyt', 'vyx', 'vy', 'vyp', 'vyrx', 'vyr']


Joomla CMS: Référence du fichier Php72.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php72
Structures de données | Espaces de nommage
Référence du fichier Php72.php

Structures de données

class Php72

Espaces de nommage

Symfony\Polyfill\Php72


Joomla CMS: Référence du fichier ResultTypeArrayAware.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Espaces de nommage | Fonctions | Variables
Référence du fichier ResultTypeArrayAware.php

Espaces de nommage

Joomla\CMS\Event\Result

Fonctions

typeCheckResult ($data)

Variables

trait ResultTypeArrayAware
$resultIsFalseable = false


Joomla CMS: Référence du fichier Session.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • session
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/session/src/Session.php

Structures de données

class Session

Espaces de nommage

Joomla\Session


Joomla CMS: Référence du fichier PHPassHandler.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
  • Password
Structures de données | Espaces de nommage
Référence du fichier PHPassHandler.php

Structures de données

class PHPassHandler

Espaces de nommage

Joomla\CMS\Authentication\Password


Joomla CMS: Référence du fichier stats.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
Structures de données | Espaces de nommage
Référence du fichier stats.php

Structures de données

class PlgSystemStats

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x065.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x065.php

Variables

return ['Pan ', 'Yang ', 'Lei ', 'Sa ', 'Shu ', 'Zan ', 'Nian ', 'Xian ', 'Jun ', 'Huo ', 'Li ', 'La ', 'Han ', 'Ying ', 'Lu ', 'Long ', 'Qian ', 'Qian ', 'Zan ', 'Qian ', 'Lan ', 'San ', 'Ying ', 'Mei ', 'Rang ', 'Chan ', '[?] ', 'Cuan ', 'Xi ', 'She ', 'Luo ', 'Jun ', 'Mi ', 'Li ', 'Zan ', 'Luan ', 'Tan ', 'Zuan ', 'Li ', 'Dian ', 'Wa ', 'Dang ', 'Jiao ', 'Jue ', 'Lan ', 'Li ', 'Nang ', 'Zhi ', 'Gui ', 'Gui ', 'Qi ', 'Xin ', 'Pu ', 'Sui ', 'Shou ', 'Kao ', 'You ', 'Gai ', 'Yi ', 'Gong ', 'Gan ', 'Ban ', 'Fang ', 'Zheng ', 'Bo ', 'Dian ', 'Kou ', 'Min ', 'Wu ', 'Gu ', 'He ', 'Ce ', 'Xiao ', 'Mi ', 'Chu ', 'Ge ', 'Di ', 'Xu ', 'Jiao ', 'Min ', 'Chen ', 'Jiu ', 'Zhen ', 'Duo ', 'Yu ', 'Chi ', 'Ao ', 'Bai ', 'Xu ', 'Jiao ', 'Duo ', 'Lian ', 'Nie ', 'Bi ', 'Chang ', 'Dian ', 'Duo ', 'Yi ', 'Gan ', 'San ', 'Ke ', 'Yan ', 'Dun ', 'Qi ', 'Dou ', 'Xiao ', 'Duo ', 'Jiao ', 'Jing ', 'Yang ', 'Xia ', 'Min ', 'Shu ', 'Ai ', 'Qiao ', 'Ai ', 'Zheng ', 'Di ', 'Zhen ', 'Fu ', 'Shu ', 'Liao ', 'Qu ', 'Xiong ', 'Xi ', 'Jiao ', 'Sen ', 'Jiao ', 'Zhuo ', 'Yi ', 'Lian ', 'Bi ', 'Li ', 'Xiao ', 'Xiao ', 'Wen ', 'Xue ', 'Qi ', 'Qi ', 'Zhai ', 'Bin ', 'Jue ', 'Zhai ', '[?] ', 'Fei ', 'Ban ', 'Ban ', 'Lan ', 'Yu ', 'Lan ', 'Wei ', 'Dou ', 'Sheng ', 'Liao ', 'Jia ', 'Hu ', 'Xie ', 'Jia ', 'Yu ', 'Zhen ', 'Jiao ', 'Wo ', 'Tou ', 'Chu ', 'Jin ', 'Chi ', 'Yin ', 'Fu ', 'Qiang ', 'Zhan ', 'Qu ', 'Zhuo ', 'Zhan ', 'Duan ', 'Zhuo ', 'Si ', 'Xin ', 'Zhuo ', 'Zhuo ', 'Qin ', 'Lin ', 'Zhuo ', 'Chu ', 'Duan ', 'Zhu ', 'Fang ', 'Xie ', 'Hang ', 'Yu ', 'Shi ', 'Pei ', 'You ', 'Mye ', 'Pang ', 'Qi ', 'Zhan ', 'Mao ', 'Lu ', 'Pei ', 'Pi ', 'Liu ', 'Fu ', 'Fang ', 'Xuan ', 'Jing ', 'Jing ', 'Ni ', 'Zu ', 'Zhao ', 'Yi ', 'Liu ', 'Shao ', 'Jian ', 'Es ', 'Yi ', 'Qi ', 'Zhi ', 'Fan ', 'Piao ', 'Fan ', 'Zhan ', 'Guai ', 'Sui ', 'Yu ', 'Wu ', 'Ji ', 'Ji ', 'Ji ', 'Huo ', 'Ri ', 'Dan ', 'Jiu ', 'Zhi ', 'Zao ', 'Xie ', 'Tiao ', 'Xun ', 'Xu ', 'Xu ', 'Xu ', 'Gan ', 'Han ', 'Tai ', 'Di ', 'Xu ', 'Chan ', 'Shi ', 'Kuang ', 'Yang ', 'Shi ', 'Wang ', 'Min ', 'Min ', 'Tun ', 'Chun ', 'Wu ']

Documentation des variables

◆ return

return[ 'Pan ', 'Yang ', 'Lei ', 'Sa ', 'Shu ', 'Zan ', 'Nian ', 'Xian ', 'Jun ', 'Huo ', 'Li ', 'La ', 'Han ', 'Ying ', 'Lu ', 'Long ', 'Qian ', 'Qian ', 'Zan ', 'Qian ', 'Lan ', 'San ', 'Ying ', 'Mei ', 'Rang ', 'Chan ', '[?] ', 'Cuan ', 'Xi ', 'She ', 'Luo ', 'Jun ', 'Mi ', 'Li ', 'Zan ', 'Luan ', 'Tan ', 'Zuan ', 'Li ', 'Dian ', 'Wa ', 'Dang ', 'Jiao ', 'Jue ', 'Lan ', 'Li ', 'Nang ', 'Zhi ', 'Gui ', 'Gui ', 'Qi ', 'Xin ', 'Pu ', 'Sui ', 'Shou ', 'Kao ', 'You ', 'Gai ', 'Yi ', 'Gong ', 'Gan ', 'Ban ', 'Fang ', 'Zheng ', 'Bo ', 'Dian ', 'Kou ', 'Min ', 'Wu ', 'Gu ', 'He ', 'Ce ', 'Xiao ', 'Mi ', 'Chu ', 'Ge ', 'Di ', 'Xu ', 'Jiao ', 'Min ', 'Chen ', 'Jiu ', 'Zhen ', 'Duo ', 'Yu ', 'Chi ', 'Ao ', 'Bai ', 'Xu ', 'Jiao ', 'Duo ', 'Lian ', 'Nie ', 'Bi ', 'Chang ', 'Dian ', 'Duo ', 'Yi ', 'Gan ', 'San ', 'Ke ', 'Yan ', 'Dun ', 'Qi ', 'Dou ', 'Xiao ', 'Duo ', 'Jiao ', 'Jing ', 'Yang ', 'Xia ', 'Min ', 'Shu ', 'Ai ', 'Qiao ', 'Ai ', 'Zheng ', 'Di ', 'Zhen ', 'Fu ', 'Shu ', 'Liao ', 'Qu ', 'Xiong ', 'Xi ', 'Jiao ', 'Sen ', 'Jiao ', 'Zhuo ', 'Yi ', 'Lian ', 'Bi ', 'Li ', 'Xiao ', 'Xiao ', 'Wen ', 'Xue ', 'Qi ', 'Qi ', 'Zhai ', 'Bin ', 'Jue ', 'Zhai ', '[?] ', 'Fei ', 'Ban ', 'Ban ', 'Lan ', 'Yu ', 'Lan ', 'Wei ', 'Dou ', 'Sheng ', 'Liao ', 'Jia ', 'Hu ', 'Xie ', 'Jia ', 'Yu ', 'Zhen ', 'Jiao ', 'Wo ', 'Tou ', 'Chu ', 'Jin ', 'Chi ', 'Yin ', 'Fu ', 'Qiang ', 'Zhan ', 'Qu ', 'Zhuo ', 'Zhan ', 'Duan ', 'Zhuo ', 'Si ', 'Xin ', 'Zhuo ', 'Zhuo ', 'Qin ', 'Lin ', 'Zhuo ', 'Chu ', 'Duan ', 'Zhu ', 'Fang ', 'Xie ', 'Hang ', 'Yu ', 'Shi ', 'Pei ', 'You ', 'Mye ', 'Pang ', 'Qi ', 'Zhan ', 'Mao ', 'Lu ', 'Pei ', 'Pi ', 'Liu ', 'Fu ', 'Fang ', 'Xuan ', 'Jing ', 'Jing ', 'Ni ', 'Zu ', 'Zhao ', 'Yi ', 'Liu ', 'Shao ', 'Jian ', 'Es ', 'Yi ', 'Qi ', 'Zhi ', 'Fan ', 'Piao ', 'Fan ', 'Zhan ', 'Guai ', 'Sui ', 'Yu ', 'Wu ', 'Ji ', 'Ji ', 'Ji ', 'Huo ', 'Ri ', 'Dan ', 'Jiu ', 'Zhi ', 'Zao ', 'Xie ', 'Tiao ', 'Xun ', 'Xu ', 'Xu ', 'Xu ', 'Gan ', 'Han ', 'Tai ', 'Di ', 'Xu ', 'Chan ', 'Shi ', 'Kuang ', 'Yang ', 'Shi ', 'Wang ', 'Min ', 'Min ', 'Tun ', 'Chun ', 'Wu ']


Joomla CMS: Référence du fichier prime192v1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime192v1.php

Structures de données

class prime192v1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier TaggableTableInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Structures de données | Espaces de nommage
Référence du fichier TaggableTableInterface.php

Structures de données

interface TaggableTableInterface

Espaces de nommage

Joomla\CMS\Tag


Joomla CMS: Référence du fichier secp384r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp384r1.php

Structures de données

class secp384r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier x08d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x08d.php

Variables

return ['Wei ', 'Bai ', 'Chen ', 'Zhuan ', 'Zhi ', 'Zhui ', 'Biao ', 'Yun ', 'Zeng ', 'Tan ', 'Zan ', 'Yan ', '[?] ', 'Shan ', 'Wan ', 'Ying ', 'Jin ', 'Gan ', 'Xian ', 'Zang ', 'Bi ', 'Du ', 'Shu ', 'Yan ', '[?] ', 'Xuan ', 'Long ', 'Gan ', 'Zang ', 'Bei ', 'Zhen ', 'Fu ', 'Yuan ', 'Gong ', 'Cai ', 'Ze ', 'Xian ', 'Bai ', 'Zhang ', 'Huo ', 'Zhi ', 'Fan ', 'Tan ', 'Pin ', 'Bian ', 'Gou ', 'Zhu ', 'Guan ', 'Er ', 'Jian ', 'Bi ', 'Shi ', 'Tie ', 'Gui ', 'Kuang ', 'Dai ', 'Mao ', 'Fei ', 'He ', 'Yi ', 'Zei ', 'Zhi ', 'Jia ', 'Hui ', 'Zi ', 'Ren ', 'Lu ', 'Zang ', 'Zi ', 'Gai ', 'Jin ', 'Qiu ', 'Zhen ', 'Lai ', 'She ', 'Fu ', 'Du ', 'Ji ', 'Shu ', 'Shang ', 'Si ', 'Bi ', 'Zhou ', 'Geng ', 'Pei ', 'Tan ', 'Lai ', 'Feng ', 'Zhui ', 'Fu ', 'Zhuan ', 'Sai ', 'Ze ', 'Yan ', 'Zan ', 'Yun ', 'Zeng ', 'Shan ', 'Ying ', 'Gan ', 'Chi ', 'Xi ', 'She ', 'Nan ', 'Xiong ', 'Xi ', 'Cheng ', 'He ', 'Cheng ', 'Zhe ', 'Xia ', 'Tang ', 'Zou ', 'Zou ', 'Li ', 'Jiu ', 'Fu ', 'Zhao ', 'Gan ', 'Qi ', 'Shan ', 'Qiong ', 'Qin ', 'Xian ', 'Ci ', 'Jue ', 'Qin ', 'Chi ', 'Ci ', 'Chen ', 'Chen ', 'Die ', 'Ju ', 'Chao ', 'Di ', 'Se ', 'Zhan ', 'Zhu ', 'Yue ', 'Qu ', 'Jie ', 'Chi ', 'Chu ', 'Gua ', 'Xue ', 'Ci ', 'Tiao ', 'Duo ', 'Lie ', 'Gan ', 'Suo ', 'Cu ', 'Xi ', 'Zhao ', 'Su ', 'Yin ', 'Ju ', 'Jian ', 'Que ', 'Tang ', 'Chuo ', 'Cui ', 'Lu ', 'Qu ', 'Dang ', 'Qiu ', 'Zi ', 'Ti ', 'Qu ', 'Chi ', 'Huang ', 'Qiao ', 'Qiao ', 'Yao ', 'Zao ', 'Ti ', '[?] ', 'Zan ', 'Zan ', 'Zu ', 'Pa ', 'Bao ', 'Ku ', 'Ke ', 'Dun ', 'Jue ', 'Fu ', 'Chen ', 'Jian ', 'Fang ', 'Zhi ', 'Sa ', 'Yue ', 'Pa ', 'Qi ', 'Yue ', 'Qiang ', 'Tuo ', 'Tai ', 'Yi ', 'Nian ', 'Ling ', 'Mei ', 'Ba ', 'Die ', 'Ku ', 'Tuo ', 'Jia ', 'Ci ', 'Pao ', 'Qia ', 'Zhu ', 'Ju ', 'Die ', 'Zhi ', 'Fu ', 'Pan ', 'Ju ', 'Shan ', 'Bo ', 'Ni ', 'Ju ', 'Li ', 'Gen ', 'Yi ', 'Ji ', 'Dai ', 'Xian ', 'Jiao ', 'Duo ', 'Zhu ', 'Zhuan ', 'Kua ', 'Zhuai ', 'Gui ', 'Qiong ', 'Kui ', 'Xiang ', 'Chi ', 'Lu ', 'Beng ', 'Zhi ', 'Jia ', 'Tiao ', 'Cai ', 'Jian ', 'Ta ', 'Qiao ', 'Bi ', 'Xian ', 'Duo ', 'Ji ', 'Ju ', 'Ji ', 'Shu ', 'Tu ']

Documentation des variables

◆ return

return[ 'Wei ', 'Bai ', 'Chen ', 'Zhuan ', 'Zhi ', 'Zhui ', 'Biao ', 'Yun ', 'Zeng ', 'Tan ', 'Zan ', 'Yan ', '[?] ', 'Shan ', 'Wan ', 'Ying ', 'Jin ', 'Gan ', 'Xian ', 'Zang ', 'Bi ', 'Du ', 'Shu ', 'Yan ', '[?] ', 'Xuan ', 'Long ', 'Gan ', 'Zang ', 'Bei ', 'Zhen ', 'Fu ', 'Yuan ', 'Gong ', 'Cai ', 'Ze ', 'Xian ', 'Bai ', 'Zhang ', 'Huo ', 'Zhi ', 'Fan ', 'Tan ', 'Pin ', 'Bian ', 'Gou ', 'Zhu ', 'Guan ', 'Er ', 'Jian ', 'Bi ', 'Shi ', 'Tie ', 'Gui ', 'Kuang ', 'Dai ', 'Mao ', 'Fei ', 'He ', 'Yi ', 'Zei ', 'Zhi ', 'Jia ', 'Hui ', 'Zi ', 'Ren ', 'Lu ', 'Zang ', 'Zi ', 'Gai ', 'Jin ', 'Qiu ', 'Zhen ', 'Lai ', 'She ', 'Fu ', 'Du ', 'Ji ', 'Shu ', 'Shang ', 'Si ', 'Bi ', 'Zhou ', 'Geng ', 'Pei ', 'Tan ', 'Lai ', 'Feng ', 'Zhui ', 'Fu ', 'Zhuan ', 'Sai ', 'Ze ', 'Yan ', 'Zan ', 'Yun ', 'Zeng ', 'Shan ', 'Ying ', 'Gan ', 'Chi ', 'Xi ', 'She ', 'Nan ', 'Xiong ', 'Xi ', 'Cheng ', 'He ', 'Cheng ', 'Zhe ', 'Xia ', 'Tang ', 'Zou ', 'Zou ', 'Li ', 'Jiu ', 'Fu ', 'Zhao ', 'Gan ', 'Qi ', 'Shan ', 'Qiong ', 'Qin ', 'Xian ', 'Ci ', 'Jue ', 'Qin ', 'Chi ', 'Ci ', 'Chen ', 'Chen ', 'Die ', 'Ju ', 'Chao ', 'Di ', 'Se ', 'Zhan ', 'Zhu ', 'Yue ', 'Qu ', 'Jie ', 'Chi ', 'Chu ', 'Gua ', 'Xue ', 'Ci ', 'Tiao ', 'Duo ', 'Lie ', 'Gan ', 'Suo ', 'Cu ', 'Xi ', 'Zhao ', 'Su ', 'Yin ', 'Ju ', 'Jian ', 'Que ', 'Tang ', 'Chuo ', 'Cui ', 'Lu ', 'Qu ', 'Dang ', 'Qiu ', 'Zi ', 'Ti ', 'Qu ', 'Chi ', 'Huang ', 'Qiao ', 'Qiao ', 'Yao ', 'Zao ', 'Ti ', '[?] ', 'Zan ', 'Zan ', 'Zu ', 'Pa ', 'Bao ', 'Ku ', 'Ke ', 'Dun ', 'Jue ', 'Fu ', 'Chen ', 'Jian ', 'Fang ', 'Zhi ', 'Sa ', 'Yue ', 'Pa ', 'Qi ', 'Yue ', 'Qiang ', 'Tuo ', 'Tai ', 'Yi ', 'Nian ', 'Ling ', 'Mei ', 'Ba ', 'Die ', 'Ku ', 'Tuo ', 'Jia ', 'Ci ', 'Pao ', 'Qia ', 'Zhu ', 'Ju ', 'Die ', 'Zhi ', 'Fu ', 'Pan ', 'Ju ', 'Shan ', 'Bo ', 'Ni ', 'Ju ', 'Li ', 'Gen ', 'Yi ', 'Ji ', 'Dai ', 'Xian ', 'Jiao ', 'Duo ', 'Zhu ', 'Zhuan ', 'Kua ', 'Zhuai ', 'Gui ', 'Qiong ', 'Kui ', 'Xiang ', 'Chi ', 'Lu ', 'Beng ', 'Zhi ', 'Jia ', 'Tiao ', 'Cai ', 'Jian ', 'Ta ', 'Qiao ', 'Bi ', 'Xian ', 'Duo ', 'Ji ', 'Ju ', 'Ji ', 'Shu ', 'Tu ']


Joomla CMS: Référence du fichier SFTP.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Net
Structures de données | Espaces de nommage
Référence du fichier SFTP.php

Structures de données

class SFTP

Espaces de nommage

SFTP
phpseclib3\Net


Joomla CMS: C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php

C:/laragon/www/_install/Joomla_422-Stable-Full_Package_French_v1/libraries/src/HTML/HTMLHelper.php

Gets a URL, cleans the Joomla specific params and returns an object

Paramètres
string $url The relative or absolute URL to use for the src attribute.
Renvoie
object
        url: 'string',
        attributes: [
          width:  integer,
          height: integer,
        ]
      }
Depuis
4.0.0
<?php
namespace Joomla\CMS\HTML;
use Joomla\CMS\Environment\Browser;
use Joomla\CMS\Factory;
use Joomla\CMS\Filesystem\File;
use Joomla\CMS\Filesystem\Path;
use Joomla\CMS\Language\Text;
use Joomla\CMS\Layout\LayoutHelper;
use Joomla\CMS\Uri\Uri;
use Joomla\Utilities\ArrayHelper;
// phpcs:disable PSR1.Files.SideEffects
\defined('JPATH_PLATFORM') or die;
// phpcs:enable PSR1.Files.SideEffects
abstract class HTMLHelper
{
public static $formatOptions = array('format.depth' => 0, 'format.eol' => "\n", 'format.indent' => "\t");
protected static $includePaths = array();
protected static $registry = array();
protected static $serviceRegistry;
protected static function extract($key)
{
$key = preg_replace('#[^A-Z0-9_\.]#i', '', $key);
// Check to see whether we need to load a helper file
$parts = explode('.', $key);
if (\count($parts) === 3) {
@trigger_error(
'Support for a three segment service key is deprecated and will be removed in Joomla 5.0, use the service registry instead',
E_USER_DEPRECATED
);
}
$prefix = \count($parts) === 3 ? array_shift($parts) : 'JHtml';
$file = \count($parts) === 2 ? array_shift($parts) : '';
$func = array_shift($parts);
return array(strtolower($prefix . '.' . $file . '.' . $func), $prefix, $file, $func);
}
final public static function _(string $key, ...$methodArgs)
{
list($key, $prefix, $file, $func) = static::extract($key);
if (\array_key_exists($key, static::$registry)) {
$function = static::$registry[$key];
return static::call($function, $methodArgs);
}
/*
* Support fetching services from the registry if a custom class prefix was not given (a three segment key),
* the service comes from a class other than this one, and a service has been registered for the file.
*/
if ($prefix === 'JHtml' && $file !== '' && static::getServiceRegistry()->hasService($file)) {
$service = static::getServiceRegistry()->getService($file);
$toCall = array($service, $func);
if (!\is_callable($toCall)) {
throw new \InvalidArgumentException(sprintf('%s::%s not found.', $file, $func), 500);
}
static::register($key, $toCall);
return static::call($toCall, $methodArgs);
}
$className = $prefix . ucfirst($file);
if (!class_exists($className)) {
$path = Path::find(static::$includePaths, strtolower($file) . '.php');
if (!$path) {
throw new \InvalidArgumentException(sprintf('%s %s not found.', $prefix, $file), 500);
}
\JLoader::register($className, $path);
if (!class_exists($className)) {
throw new \InvalidArgumentException(sprintf('%s not found.', $className), 500);
}
}
// If calling a method from this class, do not allow access to internal methods
if ($className === __CLASS__) {
if (!((new \ReflectionMethod($className, $func))->isPublic())) {
throw new \InvalidArgumentException('Access to internal class methods is not allowed.');
}
}
$toCall = array($className, $func);
if (!\is_callable($toCall)) {
throw new \InvalidArgumentException(sprintf('%s::%s not found.', $className, $func), 500);
}
static::register($key, $toCall);
return static::call($toCall, $methodArgs);
}
public static function register($key, callable $function)
{
@trigger_error(
'Support for registering functions is deprecated and will be removed in Joomla 5.0, use the service registry instead',
E_USER_DEPRECATED
);
list($key) = static::extract($key);
static::$registry[$key] = $function;
return true;
}
public static function unregister($key)
{
@trigger_error(
'Support for registering functions is deprecated and will be removed in Joomla 5.0, use the service registry instead',
E_USER_DEPRECATED
);
list($key) = static::extract($key);
if (isset(static::$registry[$key])) {
unset(static::$registry[$key]);
return true;
}
return false;
}
public static function isRegistered($key)
{
list($key) = static::extract($key);
return isset(static::$registry[$key]);
}
public static function getServiceRegistry(): Registry
{
if (!static::$serviceRegistry) {
static::$serviceRegistry = Factory::getContainer()->get(Registry::class);
}
return static::$serviceRegistry;
}
protected static function call(callable $function, $args)
{
// Workaround to allow calling helper methods have arguments passed by reference
$temp = [];
foreach ($args as &$arg) {
$temp[] = &$arg;
}
return \call_user_func_array($function, $temp);
}
public static function link($url, $text, $attribs = null)
{
if (\is_array($attribs)) {
$attribs = ArrayHelper::toString($attribs);
}
return '<a href="' . $url . '" ' . $attribs . '>' . $text . '</a>';
}
public static function iframe($url, $name, $attribs = null, $noFrames = '')
{
if (\is_array($attribs)) {
$attribs = ArrayHelper::toString($attribs);
}
return '<iframe src="' . $url . '" ' . $attribs . ' name="' . $name . '">' . $noFrames . '</iframe>';
}
protected static function includeRelativeFiles($folder, $file, $relative, $detectBrowser, $detectDebug)
{
// Set debug flag
$debugMode = false;
// Detect debug mode
if ($detectDebug && JDEBUG) {
$debugMode = true;
}
// If http is present in filename
if (strpos($file, 'http') === 0 || strpos($file, '//') === 0) {
$includes = [$file];
} else {
// Extract extension and strip the file
$strip = File::stripExt($file);
$ext = File::getExt($file);
// Prepare array of files
$includes = [];
// Detect browser and compute potential files
if ($detectBrowser) {
$navigator = Browser::getInstance();
$browser = $navigator->getBrowser();
$major = $navigator->getMajor();
$minor = $navigator->getMinor();
$minExt = '';
if (\strlen($strip) > 4 && preg_match('#\.min$#', $strip)) {
$minExt = '.min';
$strip = preg_replace('#\.min$#', '', $strip);
}
// Try to include files named filename.ext, filename_browser.ext, filename_browser_major.ext, filename_browser_major_minor.ext
// where major and minor are the browser version names
$potential = [
$strip . $minExt,
$strip . '_' . $browser . $minExt,
$strip . '_' . $browser . '_' . $major . $minExt,
$strip . '_' . $browser . '_' . $major . '_' . $minor . $minExt,
];
} else {
$potential = [$strip];
}
// If relative search in template directory or media directory
if ($relative) {
$app = Factory::getApplication();
$template = $app->getTemplate(true);
$templaPath = JPATH_THEMES;
if ($template->inheritable || !empty($template->parent)) {
$client = $app->isClient('administrator') === true ? 'administrator' : 'site';
$templaPath = JPATH_ROOT . "/media/templates/$client";
}
// For each potential files
foreach ($potential as $strip) {
$files = [];
$files[] = $strip . '.' . $ext;
foreach ($files as $file) {
if (!empty($template->parent)) {
$found = static::addFileToBuffer("$templaPath/$template->template/$folder/$file", $ext, $debugMode);
if (empty($found)) {
$found = static::addFileToBuffer("$templaPath/$template->parent/$folder/$file", $ext, $debugMode);
}
} else {
$found = static::addFileToBuffer("$templaPath/$template->template/$folder/$file", $ext, $debugMode);
}
if (!empty($found)) {
$includes[] = $found;
break;
} else {
// If the file contains any /: it can be in a media extension subfolder
if (strpos($file, '/')) {
// Divide the file extracting the extension as the first part before /
list($extension, $file) = explode('/', $file, 2);
// If the file yet contains any /: it can be a plugin
if (strpos($file, '/')) {
// Divide the file extracting the element as the first part before /
list($element, $file) = explode('/', $file, 2);
// Try to deal with plugins group in the media folder
$found = static::addFileToBuffer(JPATH_ROOT . "/media/$extension/$element/$folder/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
// Try to deal with classical file in a media subfolder called element
$found = static::addFileToBuffer(JPATH_ROOT . "/media/$extension/$folder/$element/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
// Try to deal with system files in the template folder
if (!empty($template->parent)) {
$found = static::addFileToBuffer("$templaPath/$template->template/$folder/system/$element/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
$found = static::addFileToBuffer("$templaPath/$template->parent/$folder/system/$element/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
} else {
// Try to deal with system files in the media folder
$found = static::addFileToBuffer(JPATH_ROOT . "/media/system/$folder/$element/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
}
} else {
// Try to deal with files in the extension's media folder
$found = static::addFileToBuffer(JPATH_ROOT . "/media/$extension/$folder/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
// Try to deal with system files in the template folder
if (!empty($template->parent)) {
$found = static::addFileToBuffer("$templaPath/$template->template/$folder/system/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
$found = static::addFileToBuffer("$templaPath/$template->parent/$folder/system/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
} else {
// Try to deal with system files in the template folder
$found = static::addFileToBuffer("$templaPath/$template->template/$folder/system/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
}
// Try to deal with system files in the media folder
$found = static::addFileToBuffer(JPATH_ROOT . "/media/system/$folder/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
}
} else {
// Try to deal with system files in the media folder
$found = static::addFileToBuffer(JPATH_ROOT . "/media/system/$folder/$file", $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
}
}
}
}
} else {
// If not relative and http is not present in filename
foreach ($potential as $strip) {
$files = [];
$files[] = $strip . '.' . $ext;
foreach ($files as $file) {
$path = JPATH_ROOT . "/$file";
$found = static::addFileToBuffer($path, $ext, $debugMode);
if (!empty($found)) {
$includes[] = $found;
break;
}
}
}
}
}
return $includes;
}
public static function cleanImageURL($url)
{
$obj = new \stdClass();
$obj->attributes = [
'width' => 0,
'height' => 0,
];
if ($url === null) {
$url = '';
}
if (!strpos($url, '?')) {
$obj->url = $url;
return $obj;
}
$mediaUri = new Uri($url);
// Old image URL format
if ($mediaUri->hasVar('joomla_image_height')) {
$height = (int) $mediaUri->getVar('joomla_image_height');
$width = (int) $mediaUri->getVar('joomla_image_width');
$mediaUri->delVar('joomla_image_height');
$mediaUri->delVar('joomla_image_width');
} else {
// New Image URL format
$fragmentUri = new Uri($mediaUri->getFragment());
$width = (int) $fragmentUri->getVar('width', 0);
$height = (int) $fragmentUri->getVar('height', 0);
}
if ($width > 0) {
$obj->attributes['width'] = $width;
}
if ($height > 0) {
$obj->attributes['height'] = $height;
}
$mediaUri->setFragment('');
$obj->url = $mediaUri->toString();
return $obj;
}
public static function image($file, $alt, $attribs = null, $relative = false, $returnPath = 0)
{
// Ensure is an integer
$returnPath = (int) $returnPath;
// The path of the file
$path = $file;
// The arguments of the file path
$arguments = '';
// Get the arguments positions
$pos1 = strpos($file, '?');
$pos2 = strpos($file, '#');
// Check if there are arguments
if ($pos1 !== false || $pos2 !== false) {
// Get the path only
$path = substr($file, 0, min($pos1, $pos2));
// Determine the arguments is mostly the part behind the #
$arguments = str_replace($path, '', $file);
}
// Get the relative file name when requested
if ($returnPath !== -1) {
// Search for relative file names
$includes = static::includeRelativeFiles('images', $path, $relative, false, false);
// Grab the first found path and if none exists default to null
$path = \count($includes) ? $includes[0] : null;
}
// Compile the file name
$file = ($path === null ? null : $path . $arguments);
// If only the file is required, return here
if ($returnPath === 1) {
return $file;
}
// Ensure we have a valid default for concatenating
if ($attribs === null || $attribs === false) {
$attribs = [];
}
// When it is a string, we need convert it to an array
if (is_string($attribs)) {
$attributes = [];
// Go through each argument
foreach (explode(' ', $attribs) as $attribute) {
// When an argument without a value, default to an empty string
if (strpos($attribute, '=') === false) {
$attributes[$attribute] = '';
continue;
}
// Set the attribute
list($key, $value) = explode('=', $attribute);
$attributes[$key] = trim($value, '"');
}
// Add the attributes from the string to the original attributes
$attribs = $attributes;
}
// Fill the attributes with the file and alt text
$attribs['src'] = $file;
$attribs['alt'] = $alt;
// Render the layout with the attributes
return LayoutHelper::render('joomla.html.image', $attribs);
}
public static function stylesheet($file, $options = array(), $attribs = array())
{
$options['relative'] = $options['relative'] ?? false;
$options['pathOnly'] = $options['pathOnly'] ?? false;
$options['detectBrowser'] = $options['detectBrowser'] ?? false;
$options['detectDebug'] = $options['detectDebug'] ?? true;
$includes = static::includeRelativeFiles('css', $file, $options['relative'], $options['detectBrowser'], $options['detectDebug']);
// If only path is required
if ($options['pathOnly']) {
if (\count($includes) === 0) {
return;
}
if (\count($includes) === 1) {
return $includes[0];
}
return $includes;
}
// If inclusion is required
$document = Factory::getApplication()->getDocument();
foreach ($includes as $include) {
// If there is already a version hash in the script reference (by using deprecated MD5SUM).
if ($pos = strpos($include, '?') !== false) {
$options['version'] = substr($include, $pos + 1);
}
$document->addStyleSheet($include, $options, $attribs);
}
}
public static function script($file, $options = array(), $attribs = array())
{
$options['relative'] = $options['relative'] ?? false;
$options['pathOnly'] = $options['pathOnly'] ?? false;
$options['detectBrowser'] = $options['detectBrowser'] ?? false;
$options['detectDebug'] = $options['detectDebug'] ?? true;
$includes = static::includeRelativeFiles('js', $file, $options['relative'], $options['detectBrowser'], $options['detectDebug']);
// If only path is required
if ($options['pathOnly']) {
if (\count($includes) === 0) {
return;
}
if (\count($includes) === 1) {
return $includes[0];
}
return $includes;
}
// If inclusion is required
$document = Factory::getApplication()->getDocument();
foreach ($includes as $include) {
// If there is already a version hash in the script reference (by using deprecated MD5SUM).
if ($pos = strpos($include, '?') !== false) {
$options['version'] = substr($include, $pos + 1);
}
$document->addScript($include, $options, $attribs);
}
}
public static function setFormatOptions($options)
{
foreach ($options as $key => $val) {
if (isset(static::$formatOptions[$key])) {
static::$formatOptions[$key] = $val;
}
}
}
public static function date($input = 'now', $format = null, $tz = true, $gregorian = false)
{
$app = Factory::getApplication();
// UTC date converted to user time zone.
if ($tz === true) {
// Get a date object based on UTC.
$date = Factory::getDate($input, 'UTC');
// Set the correct time zone based on the user configuration.
$date->setTimezone($app->getIdentity()->getTimezone());
} elseif ($tz === false) {
// UTC date converted to server time zone.
// Get a date object based on UTC.
$date = Factory::getDate($input, 'UTC');
// Set the correct time zone based on the server configuration.
$date->setTimezone(new \DateTimeZone($app->get('offset')));
} elseif ($tz === null) {
// No date conversion.
$date = Factory::getDate($input);
} else {
// UTC date converted to given time zone.
// Get a date object based on UTC.
$date = Factory::getDate($input, 'UTC');
// Set the correct time zone based on the server configuration.
$date->setTimezone(new \DateTimeZone($tz));
}
// If no format is given use the default locale based format.
if (!$format) {
$format = Text::_('DATE_FORMAT_LC1');
} elseif (Factory::getLanguage()->hasKey($format)) {
// $format is an existing language key
$format = Text::_($format);
}
if ($gregorian) {
return $date->format($format, true);
}
return $date->calendar($format, true);
}
public static function tooltip($tooltip, $title = '', $image = 'tooltip.png', $text = '', $href = '', $alt = 'Tooltip', $class = 'hasTooltip')
{
if (\is_array($title)) {
foreach (array('image', 'text', 'href', 'alt', 'class') as $param) {
if (isset($title[$param])) {
$$param = $title[$param];
}
}
if (isset($title['title'])) {
$title = $title['title'];
} else {
$title = '';
}
}
if (!$text) {
$alt = htmlspecialchars($alt, ENT_COMPAT, 'UTF-8');
$text = static::image($image, $alt, null, true);
}
if ($href) {
$tip = '<a href="' . $href . '">' . $text . '</a>';
} else {
$tip = $text;
}
if ($class === 'hasTip') {
// Still using MooTools tooltips!
$tooltip = htmlspecialchars($tooltip, ENT_COMPAT, 'UTF-8');
if ($title) {
$title = htmlspecialchars($title, ENT_COMPAT, 'UTF-8');
$tooltip = $title . '::' . $tooltip;
}
} else {
$tooltip = self::tooltipText($title, $tooltip, 0);
}
return '<span class="' . $class . '" title="' . $tooltip . '">' . $tip . '</span>';
}
public static function tooltipText($title = '', $content = '', $translate = true, $escape = true)
{
// Initialise return value.
$result = '';
// Don't process empty strings
if ($content !== '' || $title !== '') {
// Split title into title and content if the title contains '::' (old Mootools format).
if ($content === '' && !(strpos($title, '::') === false)) {
list($title, $content) = explode('::', $title, 2);
}
// Pass texts through Text if required.
if ($translate) {
$title = Text::_($title);
$content = Text::_($content);
}
// Use only the content if no title is given.
if ($title === '') {
$result = $content;
} elseif ($title === $content) {
// Use only the title, if title and text are the same.
$result = '<strong>' . $title . '</strong>';
} elseif ($content !== '') {
// Use a formatted string combining the title and content.
$result = '<strong>' . $title . '</strong><br>' . $content;
} else {
$result = $title;
}
// Escape everything, if required.
if ($escape) {
$result = htmlspecialchars($result);
}
}
return $result;
}
public static function calendar($value, $name, $id, $format = '%Y-%m-%d', $attribs = array())
{
$app = Factory::getApplication();
$lang = $app->getLanguage();
$tag = $lang->getTag();
$calendar = $lang->getCalendar();
$direction = strtolower($app->getDocument()->getDirection());
// Get the appropriate file for the current language date helper
$helperPath = 'system/fields/calendar-locales/date/gregorian/date-helper.min.js';
if ($calendar && is_dir(JPATH_ROOT . '/media/system/js/fields/calendar-locales/date/' . strtolower($calendar))) {
$helperPath = 'system/fields/calendar-locales/date/' . strtolower($calendar) . '/date-helper.min.js';
}
$readonly = isset($attribs['readonly']) && $attribs['readonly'] === 'readonly';
$disabled = isset($attribs['disabled']) && $attribs['disabled'] === 'disabled';
$autocomplete = isset($attribs['autocomplete']) && $attribs['autocomplete'] === '';
$autofocus = isset($attribs['autofocus']) && $attribs['autofocus'] === '';
$required = isset($attribs['required']) && $attribs['required'] === '';
$filter = isset($attribs['filter']) && $attribs['filter'] === '';
$todayBtn = $attribs['todayBtn'] ?? true;
$weekNumbers = $attribs['weekNumbers'] ?? true;
$showTime = $attribs['showTime'] ?? false;
$fillTable = $attribs['fillTable'] ?? true;
$timeFormat = $attribs['timeFormat'] ?? 24;
$singleHeader = $attribs['singleHeader'] ?? false;
$hint = $attribs['placeholder'] ?? '';
$class = $attribs['class'] ?? '';
$onchange = $attribs['onChange'] ?? '';
$minYear = $attribs['minYear'] ?? null;
$maxYear = $attribs['maxYear'] ?? null;
$showTime = ($showTime) ? "1" : "0";
$todayBtn = ($todayBtn) ? "1" : "0";
$weekNumbers = ($weekNumbers) ? "1" : "0";
$fillTable = ($fillTable) ? "1" : "0";
$singleHeader = ($singleHeader) ? "1" : "0";
// Format value when not nulldate ('0000-00-00 00:00:00'), otherwise blank it as it would result in 1970-01-01.
if ($value && $value !== Factory::getDbo()->getNullDate() && strtotime($value) !== false) {
$tz = date_default_timezone_get();
date_default_timezone_set('UTC');
$inputvalue = strftime($format, strtotime($value));
date_default_timezone_set($tz);
} else {
$inputvalue = '';
}
$data = array(
'id' => $id,
'name' => $name,
'class' => $class,
'value' => $inputvalue,
'format' => $format,
'filter' => $filter,
'required' => $required,
'readonly' => $readonly,
'disabled' => $disabled,
'hint' => $hint,
'autofocus' => $autofocus,
'autocomplete' => $autocomplete,
'todaybutton' => $todayBtn,
'weeknumbers' => $weekNumbers,
'showtime' => $showTime,
'filltable' => $fillTable,
'timeformat' => $timeFormat,
'singleheader' => $singleHeader,
'tag' => $tag,
'helperPath' => $helperPath,
'direction' => $direction,
'onchange' => $onchange,
'minYear' => $minYear,
'maxYear' => $maxYear,
'dataAttribute' => '',
'dataAttributes' => '',
'calendar' => $calendar,
'firstday' => $lang->getFirstDay(),
'weekend' => explode(',', $lang->getWeekEnd()),
);
return LayoutHelper::render('joomla.form.field.calendar', $data, null, null);
}
public static function addIncludePath($path = '')
{
@trigger_error(
'Support for registering lookup paths is deprecated and will be removed in Joomla 5.0, use the service registry instead',
E_USER_DEPRECATED
);
// Loop through the path directories
foreach ((array) $path as $dir) {
if (!empty($dir) && !\in_array($dir, static::$includePaths)) {
array_unshift(static::$includePaths, Path::clean($dir));
}
}
return static::$includePaths;
}
protected static function addFileToBuffer($path = '', $ext = '', $debugMode = false)
{
$position = strrpos($path, '.min.');
// We are handling a name.min.ext file:
if ($position !== false) {
$minifiedPath = $path;
$nonMinifiedPath = substr_replace($path, '', $position, 4);
if ($debugMode) {
return self::checkFileOrder($minifiedPath, $nonMinifiedPath);
}
return self::checkFileOrder($nonMinifiedPath, $minifiedPath);
}
$minifiedPath = pathinfo($path, PATHINFO_DIRNAME) . '/' . pathinfo($path, PATHINFO_FILENAME) . '.min.' . $ext;
if ($debugMode) {
return self::checkFileOrder($minifiedPath, $path);
}
return self::checkFileOrder($path, $minifiedPath);
}
protected static function convertToRelativePath($path)
{
$relativeFilePath = Uri::root(true) . str_replace(JPATH_ROOT, '', $path);
// On windows devices we need to replace "\" with "/" otherwise some browsers will not load the asset
return str_replace(DIRECTORY_SEPARATOR, '/', $relativeFilePath);
}
private static function checkFileOrder($first, $second)
{
if (is_file($second)) {
return static::convertToRelativePath($second);
}
if (is_file($first)) {
return static::convertToRelativePath($first);
}
return '';
}
}


Joomla CMS: Référence du fichier WorkflowServiceInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Workflow
Structures de données | Espaces de nommage
Référence du fichier WorkflowServiceInterface.php

Structures de données

interface WorkflowServiceInterface

Espaces de nommage

Joomla\CMS\Workflow


Joomla CMS: Référence du fichier SectionNotFoundException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Categories
Structures de données | Espaces de nommage
Référence du fichier SectionNotFoundException.php

Structures de données

class SectionNotFoundException

Espaces de nommage

Joomla\CMS\Categories


Joomla CMS: Référence du fichier x029.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x029.php

Variables

return ['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '{', '} ', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']

Documentation des variables

◆ return

return['', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '{', '} ', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '']


Joomla CMS: Référence du fichier trace.html.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • Resources
  • views
Variables
Référence du fichier trace.html.php

Variables

if($trace['file']) if('compact' !==$style && $trace['']) if ($trace['file']) = 'expanded' === $style ? 'display' : ''

Documentation des variables

◆ if

if ( $trace[ 'file']) if ( 'compact' !==$style &&$trace[ '']) if( $trace[ 'file']) = 'expanded' === $style ? 'display' : ''


Joomla CMS: Référence du fichier RandomImageHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_random_image
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier RandomImageHelper.php

Structures de données

class RandomImageHelper

Espaces de nommage

Joomla\Site
Joomla\Module\RandomImage\Site\Helper


Joomla CMS: Référence du fichier ServiceProviderInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • service-contracts
Structures de données | Espaces de nommage
Référence du fichier symfony/service-contracts/ServiceProviderInterface.php

Structures de données

interface ServiceProviderInterface

Espaces de nommage

Symfony\Contracts\Service


Joomla CMS: Référence du fichier x0bb.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0bb.php

Variables

return ['moen', 'moenj', 'moenh', 'moed', 'moel', 'moelg', 'moelm', 'moelb', 'moels', 'moelt', 'moelp', 'moelh', 'moem', 'moeb', 'moebs', 'moes', 'moess', 'moeng', 'moej', 'moec', 'moek', 'moet', 'moep', 'moeh', 'myo', 'myog', 'myogg', 'myogs', 'myon', 'myonj', 'myonh', 'myod', 'myol', 'myolg', 'myolm', 'myolb', 'myols', 'myolt', 'myolp', 'myolh', 'myom', 'myob', 'myobs', 'myos', 'myoss', 'myong', 'myoj', 'myoc', 'myok', 'myot', 'myop', 'myoh', 'mu', 'mug', 'mugg', 'mugs', 'mun', 'munj', 'munh', 'mud', 'mul', 'mulg', 'mulm', 'mulb', 'muls', 'mult', 'mulp', 'mulh', 'mum', 'mub', 'mubs', 'mus', 'muss', 'mung', 'muj', 'muc', 'muk', 'mut', 'mup', 'muh', 'mweo', 'mweog', 'mweogg', 'mweogs', 'mweon', 'mweonj', 'mweonh', 'mweod', 'mweol', 'mweolg', 'mweolm', 'mweolb', 'mweols', 'mweolt', 'mweolp', 'mweolh', 'mweom', 'mweob', 'mweobs', 'mweos', 'mweoss', 'mweong', 'mweoj', 'mweoc', 'mweok', 'mweot', 'mweop', 'mweoh', 'mwe', 'mweg', 'mwegg', 'mwegs', 'mwen', 'mwenj', 'mwenh', 'mwed', 'mwel', 'mwelg', 'mwelm', 'mwelb', 'mwels', 'mwelt', 'mwelp', 'mwelh', 'mwem', 'mweb', 'mwebs', 'mwes', 'mwess', 'mweng', 'mwej', 'mwec', 'mwek', 'mwet', 'mwep', 'mweh', 'mwi', 'mwig', 'mwigg', 'mwigs', 'mwin', 'mwinj', 'mwinh', 'mwid', 'mwil', 'mwilg', 'mwilm', 'mwilb', 'mwils', 'mwilt', 'mwilp', 'mwilh', 'mwim', 'mwib', 'mwibs', 'mwis', 'mwiss', 'mwing', 'mwij', 'mwic', 'mwik', 'mwit', 'mwip', 'mwih', 'myu', 'myug', 'myugg', 'myugs', 'myun', 'myunj', 'myunh', 'myud', 'myul', 'myulg', 'myulm', 'myulb', 'myuls', 'myult', 'myulp', 'myulh', 'myum', 'myub', 'myubs', 'myus', 'myuss', 'myung', 'myuj', 'myuc', 'myuk', 'myut', 'myup', 'myuh', 'meu', 'meug', 'meugg', 'meugs', 'meun', 'meunj', 'meunh', 'meud', 'meul', 'meulg', 'meulm', 'meulb', 'meuls', 'meult', 'meulp', 'meulh', 'meum', 'meub', 'meubs', 'meus', 'meuss', 'meung', 'meuj', 'meuc', 'meuk', 'meut', 'meup', 'meuh', 'myi', 'myig', 'myigg', 'myigs', 'myin', 'myinj', 'myinh', 'myid', 'myil', 'myilg', 'myilm', 'myilb', 'myils', 'myilt', 'myilp', 'myilh', 'myim', 'myib', 'myibs', 'myis', 'myiss', 'mying', 'myij', 'myic', 'myik', 'myit', 'myip', 'myih', 'mi', 'mig', 'migg', 'migs', 'min', 'minj', 'minh', 'mid']

Documentation des variables

◆ return

return[ 'moen', 'moenj', 'moenh', 'moed', 'moel', 'moelg', 'moelm', 'moelb', 'moels', 'moelt', 'moelp', 'moelh', 'moem', 'moeb', 'moebs', 'moes', 'moess', 'moeng', 'moej', 'moec', 'moek', 'moet', 'moep', 'moeh', 'myo', 'myog', 'myogg', 'myogs', 'myon', 'myonj', 'myonh', 'myod', 'myol', 'myolg', 'myolm', 'myolb', 'myols', 'myolt', 'myolp', 'myolh', 'myom', 'myob', 'myobs', 'myos', 'myoss', 'myong', 'myoj', 'myoc', 'myok', 'myot', 'myop', 'myoh', 'mu', 'mug', 'mugg', 'mugs', 'mun', 'munj', 'munh', 'mud', 'mul', 'mulg', 'mulm', 'mulb', 'muls', 'mult', 'mulp', 'mulh', 'mum', 'mub', 'mubs', 'mus', 'muss', 'mung', 'muj', 'muc', 'muk', 'mut', 'mup', 'muh', 'mweo', 'mweog', 'mweogg', 'mweogs', 'mweon', 'mweonj', 'mweonh', 'mweod', 'mweol', 'mweolg', 'mweolm', 'mweolb', 'mweols', 'mweolt', 'mweolp', 'mweolh', 'mweom', 'mweob', 'mweobs', 'mweos', 'mweoss', 'mweong', 'mweoj', 'mweoc', 'mweok', 'mweot', 'mweop', 'mweoh', 'mwe', 'mweg', 'mwegg', 'mwegs', 'mwen', 'mwenj', 'mwenh', 'mwed', 'mwel', 'mwelg', 'mwelm', 'mwelb', 'mwels', 'mwelt', 'mwelp', 'mwelh', 'mwem', 'mweb', 'mwebs', 'mwes', 'mwess', 'mweng', 'mwej', 'mwec', 'mwek', 'mwet', 'mwep', 'mweh', 'mwi', 'mwig', 'mwigg', 'mwigs', 'mwin', 'mwinj', 'mwinh', 'mwid', 'mwil', 'mwilg', 'mwilm', 'mwilb', 'mwils', 'mwilt', 'mwilp', 'mwilh', 'mwim', 'mwib', 'mwibs', 'mwis', 'mwiss', 'mwing', 'mwij', 'mwic', 'mwik', 'mwit', 'mwip', 'mwih', 'myu', 'myug', 'myugg', 'myugs', 'myun', 'myunj', 'myunh', 'myud', 'myul', 'myulg', 'myulm', 'myulb', 'myuls', 'myult', 'myulp', 'myulh', 'myum', 'myub', 'myubs', 'myus', 'myuss', 'myung', 'myuj', 'myuc', 'myuk', 'myut', 'myup', 'myuh', 'meu', 'meug', 'meugg', 'meugs', 'meun', 'meunj', 'meunh', 'meud', 'meul', 'meulg', 'meulm', 'meulb', 'meuls', 'meult', 'meulp', 'meulh', 'meum', 'meub', 'meubs', 'meus', 'meuss', 'meung', 'meuj', 'meuc', 'meuk', 'meut', 'meup', 'meuh', 'myi', 'myig', 'myigg', 'myigs', 'myin', 'myinj', 'myinh', 'myid', 'myil', 'myilg', 'myilm', 'myilb', 'myils', 'myilt', 'myilp', 'myilh', 'myim', 'myib', 'myibs', 'myis', 'myiss', 'mying', 'myij', 'myic', 'myik', 'myit', 'myip', 'myih', 'mi', 'mig', 'migg', 'migs', 'min', 'minj', 'minh', 'mid']


Joomla CMS: Référence du fichier slider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
  • color
Espaces de nommage | Variables
Référence du fichier slider.php

Espaces de nommage

Joomla\Site

Variables

if($color==='none'||is_null($color)) $alpha = $format === 'hsla' || $format === 'rgba' || $format === 'alpha'
$autocomplete = !empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : ''
$autofocus = $autofocus ? ' autofocus' : ''
$color = ' data-color="' . $color . '"'
$class = $class ? ' class="' . $class . '"' : ''
$default = $default ? ' data-default="' . $default . '"' : ''
$disabled = $disabled ? ' disabled' : ''
$format = $format ? ' data-format="' . $format . '"' : ''
$hint = strlen($hint) ? ' placeholder="' . $this->escape($hint) . '"' : ''
$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''
$onclick = $onclick ? ' onclick="' . $onclick . '"' : ''
$preview = $preview ? ' data-preview="' . $preview . '"' : ''
$readonly = $readonly ? ' readonly' : ''
$saveFormat = $saveFormat ? ' data-format="' . $saveFormat . '"' : ''
$size = $size ? ' size="' . $size . '"' : ''
$validate = $validate ? ' data-validate="' . $validate . '"' : ''
$displayValues = explode(',', $display)
$allSliders = $display === 'full' || empty($display)
$wa = Factory::getApplication()->getDocument()->getWebAssetManager()
$dataAttribute
$required
$position

Documentation des variables

◆ $allSliders

$allSliders = $display === 'full' || empty($display)

◆ $alpha

if ( $color==='none'||is_null( $color)) $alpha = $format === 'hsla' || $format === 'rgba' || $format === 'alpha'

◆ $autocomplete

$autocomplete = !empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : ''

◆ $autofocus

$autofocus = $autofocus ? ' autofocus' : ''

◆ $class

$class = $class ? ' class="' . $class . '"' : ''

◆ $color

$color = ' data-color="' . $color . '"'

Référencé par Color\convertHexColorToAnsi(), Image\crop(), Backgroundfill\execute(), ColorField\getLayoutData(), Color\parseColor(), et Image\resize().

◆ $dataAttribute

$dataAttribute

◆ $default

$default = $default ? ' data-default="' . $default . '"' : ''

◆ $disabled

$disabled = $disabled ? ' disabled' : ''

◆ $displayValues

$displayValues = explode(',', $display)

◆ $format

$format = $format ? ' data-format="' . $format . '"' : ''

◆ $hint

$hint = strlen($hint) ? ' placeholder="' . $this->escape($hint) . '"' : ''

◆ $onchange

$onchange = $onchange ? ' onchange="' . $onchange . '"' : ''

◆ $onclick

$onclick = $onclick ? ' onclick="' . $onclick . '"' : ''

◆ $position

$position

◆ $preview

$preview = $preview ? ' data-preview="' . $preview . '"' : ''

Référencé par MediaField\getLayoutData(), et Templates\thumbModal().

◆ $readonly

$readonly = $readonly ? ' readonly' : ''

◆ $required

$required

◆ $saveFormat

$saveFormat = $saveFormat ? ' data-format="' . $saveFormat . '"' : ''

◆ $size

$size = $size ? ' size="' . $size . '"' : ''

Référencé par ImgStub\__construct(), PHP\addHelper(), FtpClient\append(), ASN1\asn1map(), BinaryField\base2ToBase256(), PHP\compareHelper(), TemplateModel\createOverride(), UploadedFileFactory\createUploadedFile(), Psr17Factory\createUploadedFile(), X509\decodeNameConstraintIP(), ASN1\encode_der(), SymmetricKey\encrypt(), SqlsrvQuery\fixGroupColumns(), SqlsrvQuery\fixSelectAliases(), DataFormatter\formatBytes(), DataCollector\formatBytes(), Image\generateThumbs(), Credentials\getAvatar(), Authentication\getAvatar(), PrefixField\getInput(), MenutypeField\getInput(), DisplayController\getQuickiconContent(), RandomImageHelper\getRandomImage(), POP3\getResponse(), TemplateModel\getSafeName(), Grapheme\grapheme_extract(), X509\mapOutAttributes(), X509\mapOutDNs(), X509\mapOutExtensions(), FilesystemHelper\parseSize(), SFTP\put(), BigInteger\random(), BigInteger\randomPrime(), Engine\randomRangeHelper(), Integer\regularPolynomialMultiply(), X509\removeDNProp(), AbstractAES\resizeKey(), ProgressBar\setBarWidth(), FtpClient\size(), et CacheStorageHelper\updateSize().

◆ $validate

$validate = $validate ? ' data-validate="' . $validate . '"' : ''

◆ $wa

$wa = Factory::getApplication()->getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier UpdateModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_joomlaupdate
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier com_joomlaupdate/src/Model/UpdateModel.php

Structures de données

class UpdateModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Joomlaupdate\Administrator\Model


Joomla CMS: Référence du fichier RulesRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier RulesRule.php

Structures de données

class RulesRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier route.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_newsfeeds
  • helpers
Structures de données | Espaces de nommage
Référence du fichier com_newsfeeds/helpers/route.php

Structures de données

class NewsfeedsHelperRoute

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier TableCellStyle.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • console
  • Helper
Structures de données | Espaces de nommage
Référence du fichier TableCellStyle.php

Structures de données

class TableCellStyle

Espaces de nommage

Symfony\Component\Console\Helper


Joomla CMS: Référence du fichier textarea.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • tinymce
Espaces de nommage | Variables
Référence du fichier layouts/joomla/tinymce/textarea.php

Espaces de nommage

Joomla\Site

Variables

$data = $displayData
$wa = Factory::getDocument()->getWebAssetManager()

Documentation des variables

◆ $data

$data = $displayData

◆ $wa

$wa = Factory::getDocument()->getWebAssetManager()


Joomla CMS: Référence du fichier PublicKeyCredentialSource.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
Structures de données | Espaces de nommage
Référence du fichier PublicKeyCredentialSource.php

Structures de données

class PublicKeyCredentialSource

Espaces de nommage

Webauthn


Joomla CMS: Référence du fichier PS384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-token
  • jwt-signature-algorithm-rsa
Structures de données | Espaces de nommage
Référence du fichier web-token/jwt-signature-algorithm-rsa/PS384.php

Structures de données

class PS384

Espaces de nommage

Jose\Component\Signature\Algorithm


Joomla CMS: Référence du fichier UploadedFileInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier UploadedFileInterface.php

Structures de données

interface UploadedFileInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier SubfieldsField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier SubfieldsField.php

Structures de données

class SubfieldsField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier ResponseFactory.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • php-http
  • message-factory
  • src
Structures de données | Espaces de nommage
Référence du fichier php-http/message-factory/src/ResponseFactory.php

Structures de données

interface ResponseFactory

Espaces de nommage

Http\Message


Joomla CMS: Référence du fichier x0b9.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b9.php

Variables

return ['ruk', 'rut', 'rup', 'ruh', 'rweo', 'rweog', 'rweogg', 'rweogs', 'rweon', 'rweonj', 'rweonh', 'rweod', 'rweol', 'rweolg', 'rweolm', 'rweolb', 'rweols', 'rweolt', 'rweolp', 'rweolh', 'rweom', 'rweob', 'rweobs', 'rweos', 'rweoss', 'rweong', 'rweoj', 'rweoc', 'rweok', 'rweot', 'rweop', 'rweoh', 'rwe', 'rweg', 'rwegg', 'rwegs', 'rwen', 'rwenj', 'rwenh', 'rwed', 'rwel', 'rwelg', 'rwelm', 'rwelb', 'rwels', 'rwelt', 'rwelp', 'rwelh', 'rwem', 'rweb', 'rwebs', 'rwes', 'rwess', 'rweng', 'rwej', 'rwec', 'rwek', 'rwet', 'rwep', 'rweh', 'rwi', 'rwig', 'rwigg', 'rwigs', 'rwin', 'rwinj', 'rwinh', 'rwid', 'rwil', 'rwilg', 'rwilm', 'rwilb', 'rwils', 'rwilt', 'rwilp', 'rwilh', 'rwim', 'rwib', 'rwibs', 'rwis', 'rwiss', 'rwing', 'rwij', 'rwic', 'rwik', 'rwit', 'rwip', 'rwih', 'ryu', 'ryug', 'ryugg', 'ryugs', 'ryun', 'ryunj', 'ryunh', 'ryud', 'ryul', 'ryulg', 'ryulm', 'ryulb', 'ryuls', 'ryult', 'ryulp', 'ryulh', 'ryum', 'ryub', 'ryubs', 'ryus', 'ryuss', 'ryung', 'ryuj', 'ryuc', 'ryuk', 'ryut', 'ryup', 'ryuh', 'reu', 'reug', 'reugg', 'reugs', 'reun', 'reunj', 'reunh', 'reud', 'reul', 'reulg', 'reulm', 'reulb', 'reuls', 'reult', 'reulp', 'reulh', 'reum', 'reub', 'reubs', 'reus', 'reuss', 'reung', 'reuj', 'reuc', 'reuk', 'reut', 'reup', 'reuh', 'ryi', 'ryig', 'ryigg', 'ryigs', 'ryin', 'ryinj', 'ryinh', 'ryid', 'ryil', 'ryilg', 'ryilm', 'ryilb', 'ryils', 'ryilt', 'ryilp', 'ryilh', 'ryim', 'ryib', 'ryibs', 'ryis', 'ryiss', 'rying', 'ryij', 'ryic', 'ryik', 'ryit', 'ryip', 'ryih', 'ri', 'rig', 'rigg', 'rigs', 'rin', 'rinj', 'rinh', 'rid', 'ril', 'rilg', 'rilm', 'rilb', 'rils', 'rilt', 'rilp', 'rilh', 'rim', 'rib', 'ribs', 'ris', 'riss', 'ring', 'rij', 'ric', 'rik', 'rit', 'rip', 'rih', 'ma', 'mag', 'magg', 'mags', 'man', 'manj', 'manh', 'mad', 'mal', 'malg', 'malm', 'malb', 'mals', 'malt', 'malp', 'malh', 'mam', 'mab', 'mabs', 'mas', 'mass', 'mang', 'maj', 'mac', 'mak', 'mat', 'map', 'mah', 'mae', 'maeg', 'maegg', 'maegs', 'maen', 'maenj', 'maenh', 'maed', 'mael', 'maelg', 'maelm', 'maelb', 'maels', 'maelt', 'maelp', 'maelh', 'maem', 'maeb', 'maebs', 'maes', 'maess', 'maeng', 'maej', 'maec', 'maek', 'maet', 'maep', 'maeh']

Documentation des variables

◆ return

return[ 'ruk', 'rut', 'rup', 'ruh', 'rweo', 'rweog', 'rweogg', 'rweogs', 'rweon', 'rweonj', 'rweonh', 'rweod', 'rweol', 'rweolg', 'rweolm', 'rweolb', 'rweols', 'rweolt', 'rweolp', 'rweolh', 'rweom', 'rweob', 'rweobs', 'rweos', 'rweoss', 'rweong', 'rweoj', 'rweoc', 'rweok', 'rweot', 'rweop', 'rweoh', 'rwe', 'rweg', 'rwegg', 'rwegs', 'rwen', 'rwenj', 'rwenh', 'rwed', 'rwel', 'rwelg', 'rwelm', 'rwelb', 'rwels', 'rwelt', 'rwelp', 'rwelh', 'rwem', 'rweb', 'rwebs', 'rwes', 'rwess', 'rweng', 'rwej', 'rwec', 'rwek', 'rwet', 'rwep', 'rweh', 'rwi', 'rwig', 'rwigg', 'rwigs', 'rwin', 'rwinj', 'rwinh', 'rwid', 'rwil', 'rwilg', 'rwilm', 'rwilb', 'rwils', 'rwilt', 'rwilp', 'rwilh', 'rwim', 'rwib', 'rwibs', 'rwis', 'rwiss', 'rwing', 'rwij', 'rwic', 'rwik', 'rwit', 'rwip', 'rwih', 'ryu', 'ryug', 'ryugg', 'ryugs', 'ryun', 'ryunj', 'ryunh', 'ryud', 'ryul', 'ryulg', 'ryulm', 'ryulb', 'ryuls', 'ryult', 'ryulp', 'ryulh', 'ryum', 'ryub', 'ryubs', 'ryus', 'ryuss', 'ryung', 'ryuj', 'ryuc', 'ryuk', 'ryut', 'ryup', 'ryuh', 'reu', 'reug', 'reugg', 'reugs', 'reun', 'reunj', 'reunh', 'reud', 'reul', 'reulg', 'reulm', 'reulb', 'reuls', 'reult', 'reulp', 'reulh', 'reum', 'reub', 'reubs', 'reus', 'reuss', 'reung', 'reuj', 'reuc', 'reuk', 'reut', 'reup', 'reuh', 'ryi', 'ryig', 'ryigg', 'ryigs', 'ryin', 'ryinj', 'ryinh', 'ryid', 'ryil', 'ryilg', 'ryilm', 'ryilb', 'ryils', 'ryilt', 'ryilp', 'ryilh', 'ryim', 'ryib', 'ryibs', 'ryis', 'ryiss', 'rying', 'ryij', 'ryic', 'ryik', 'ryit', 'ryip', 'ryih', 'ri', 'rig', 'rigg', 'rigs', 'rin', 'rinj', 'rinh', 'rid', 'ril', 'rilg', 'rilm', 'rilb', 'rils', 'rilt', 'rilp', 'rilh', 'rim', 'rib', 'ribs', 'ris', 'riss', 'ring', 'rij', 'ric', 'rik', 'rit', 'rip', 'rih', 'ma', 'mag', 'magg', 'mags', 'man', 'manj', 'manh', 'mad', 'mal', 'malg', 'malm', 'malb', 'mals', 'malt', 'malp', 'malh', 'mam', 'mab', 'mabs', 'mas', 'mass', 'mang', 'maj', 'mac', 'mak', 'mat', 'map', 'mah', 'mae', 'maeg', 'maegg', 'maegs', 'maen', 'maenj', 'maenh', 'maed', 'mael', 'maelg', 'maelm', 'maelb', 'maels', 'maelt', 'maelp', 'maelh', 'maem', 'maeb', 'maebs', 'maes', 'maess', 'maeng', 'maej', 'maec', 'maek', 'maet', 'maep', 'maeh']


Joomla CMS: Référence du fichier PeclUuidRandomGenerator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Generator
Structures de données | Espaces de nommage
Référence du fichier PeclUuidRandomGenerator.php

Structures de données

class PeclUuidRandomGenerator

Espaces de nommage

Ramsey\Uuid\Generator


Joomla CMS: Référence du fichier ReCaptcha.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • google
  • recaptcha
  • src
  • ReCaptcha
Structures de données | Espaces de nommage
Référence du fichier ReCaptcha.php

Structures de données

class ReCaptcha

Espaces de nommage

ReCaptcha


Joomla CMS: Référence du fichier prime256v1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime256v1.php

Structures de données

class prime256v1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: List-Unsubscribe

List-Unsubscribe

DKIM Extra signing headers.

', 'List-Help']


Joomla CMS: Référence du fichier x0c9.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0c9.php

Variables

return ['jun', 'junj', 'junh', 'jud', 'jul', 'julg', 'julm', 'julb', 'juls', 'jult', 'julp', 'julh', 'jum', 'jub', 'jubs', 'jus', 'juss', 'jung', 'juj', 'juc', 'juk', 'jut', 'jup', 'juh', 'jweo', 'jweog', 'jweogg', 'jweogs', 'jweon', 'jweonj', 'jweonh', 'jweod', 'jweol', 'jweolg', 'jweolm', 'jweolb', 'jweols', 'jweolt', 'jweolp', 'jweolh', 'jweom', 'jweob', 'jweobs', 'jweos', 'jweoss', 'jweong', 'jweoj', 'jweoc', 'jweok', 'jweot', 'jweop', 'jweoh', 'jwe', 'jweg', 'jwegg', 'jwegs', 'jwen', 'jwenj', 'jwenh', 'jwed', 'jwel', 'jwelg', 'jwelm', 'jwelb', 'jwels', 'jwelt', 'jwelp', 'jwelh', 'jwem', 'jweb', 'jwebs', 'jwes', 'jwess', 'jweng', 'jwej', 'jwec', 'jwek', 'jwet', 'jwep', 'jweh', 'jwi', 'jwig', 'jwigg', 'jwigs', 'jwin', 'jwinj', 'jwinh', 'jwid', 'jwil', 'jwilg', 'jwilm', 'jwilb', 'jwils', 'jwilt', 'jwilp', 'jwilh', 'jwim', 'jwib', 'jwibs', 'jwis', 'jwiss', 'jwing', 'jwij', 'jwic', 'jwik', 'jwit', 'jwip', 'jwih', 'jyu', 'jyug', 'jyugg', 'jyugs', 'jyun', 'jyunj', 'jyunh', 'jyud', 'jyul', 'jyulg', 'jyulm', 'jyulb', 'jyuls', 'jyult', 'jyulp', 'jyulh', 'jyum', 'jyub', 'jyubs', 'jyus', 'jyuss', 'jyung', 'jyuj', 'jyuc', 'jyuk', 'jyut', 'jyup', 'jyuh', 'jeu', 'jeug', 'jeugg', 'jeugs', 'jeun', 'jeunj', 'jeunh', 'jeud', 'jeul', 'jeulg', 'jeulm', 'jeulb', 'jeuls', 'jeult', 'jeulp', 'jeulh', 'jeum', 'jeub', 'jeubs', 'jeus', 'jeuss', 'jeung', 'jeuj', 'jeuc', 'jeuk', 'jeut', 'jeup', 'jeuh', 'jyi', 'jyig', 'jyigg', 'jyigs', 'jyin', 'jyinj', 'jyinh', 'jyid', 'jyil', 'jyilg', 'jyilm', 'jyilb', 'jyils', 'jyilt', 'jyilp', 'jyilh', 'jyim', 'jyib', 'jyibs', 'jyis', 'jyiss', 'jying', 'jyij', 'jyic', 'jyik', 'jyit', 'jyip', 'jyih', 'ji', 'jig', 'jigg', 'jigs', 'jin', 'jinj', 'jinh', 'jid', 'jil', 'jilg', 'jilm', 'jilb', 'jils', 'jilt', 'jilp', 'jilh', 'jim', 'jib', 'jibs', 'jis', 'jiss', 'jing', 'jij', 'jic', 'jik', 'jit', 'jip', 'jih', 'jja', 'jjag', 'jjagg', 'jjags', 'jjan', 'jjanj', 'jjanh', 'jjad', 'jjal', 'jjalg', 'jjalm', 'jjalb', 'jjals', 'jjalt', 'jjalp', 'jjalh', 'jjam', 'jjab', 'jjabs', 'jjas', 'jjass', 'jjang', 'jjaj', 'jjac', 'jjak', 'jjat', 'jjap', 'jjah', 'jjae', 'jjaeg', 'jjaegg', 'jjaegs', 'jjaen', 'jjaenj', 'jjaenh', 'jjaed']

Documentation des variables

◆ return

return[ 'jun', 'junj', 'junh', 'jud', 'jul', 'julg', 'julm', 'julb', 'juls', 'jult', 'julp', 'julh', 'jum', 'jub', 'jubs', 'jus', 'juss', 'jung', 'juj', 'juc', 'juk', 'jut', 'jup', 'juh', 'jweo', 'jweog', 'jweogg', 'jweogs', 'jweon', 'jweonj', 'jweonh', 'jweod', 'jweol', 'jweolg', 'jweolm', 'jweolb', 'jweols', 'jweolt', 'jweolp', 'jweolh', 'jweom', 'jweob', 'jweobs', 'jweos', 'jweoss', 'jweong', 'jweoj', 'jweoc', 'jweok', 'jweot', 'jweop', 'jweoh', 'jwe', 'jweg', 'jwegg', 'jwegs', 'jwen', 'jwenj', 'jwenh', 'jwed', 'jwel', 'jwelg', 'jwelm', 'jwelb', 'jwels', 'jwelt', 'jwelp', 'jwelh', 'jwem', 'jweb', 'jwebs', 'jwes', 'jwess', 'jweng', 'jwej', 'jwec', 'jwek', 'jwet', 'jwep', 'jweh', 'jwi', 'jwig', 'jwigg', 'jwigs', 'jwin', 'jwinj', 'jwinh', 'jwid', 'jwil', 'jwilg', 'jwilm', 'jwilb', 'jwils', 'jwilt', 'jwilp', 'jwilh', 'jwim', 'jwib', 'jwibs', 'jwis', 'jwiss', 'jwing', 'jwij', 'jwic', 'jwik', 'jwit', 'jwip', 'jwih', 'jyu', 'jyug', 'jyugg', 'jyugs', 'jyun', 'jyunj', 'jyunh', 'jyud', 'jyul', 'jyulg', 'jyulm', 'jyulb', 'jyuls', 'jyult', 'jyulp', 'jyulh', 'jyum', 'jyub', 'jyubs', 'jyus', 'jyuss', 'jyung', 'jyuj', 'jyuc', 'jyuk', 'jyut', 'jyup', 'jyuh', 'jeu', 'jeug', 'jeugg', 'jeugs', 'jeun', 'jeunj', 'jeunh', 'jeud', 'jeul', 'jeulg', 'jeulm', 'jeulb', 'jeuls', 'jeult', 'jeulp', 'jeulh', 'jeum', 'jeub', 'jeubs', 'jeus', 'jeuss', 'jeung', 'jeuj', 'jeuc', 'jeuk', 'jeut', 'jeup', 'jeuh', 'jyi', 'jyig', 'jyigg', 'jyigs', 'jyin', 'jyinj', 'jyinh', 'jyid', 'jyil', 'jyilg', 'jyilm', 'jyilb', 'jyils', 'jyilt', 'jyilp', 'jyilh', 'jyim', 'jyib', 'jyibs', 'jyis', 'jyiss', 'jying', 'jyij', 'jyic', 'jyik', 'jyit', 'jyip', 'jyih', 'ji', 'jig', 'jigg', 'jigs', 'jin', 'jinj', 'jinh', 'jid', 'jil', 'jilg', 'jilm', 'jilb', 'jils', 'jilt', 'jilp', 'jilh', 'jim', 'jib', 'jibs', 'jis', 'jiss', 'jing', 'jij', 'jic', 'jik', 'jit', 'jip', 'jih', 'jja', 'jjag', 'jjagg', 'jjags', 'jjan', 'jjanj', 'jjanh', 'jjad', 'jjal', 'jjalg', 'jjalm', 'jjalb', 'jjals', 'jjalt', 'jjalp', 'jjalh', 'jjam', 'jjab', 'jjabs', 'jjas', 'jjass', 'jjang', 'jjaj', 'jjac', 'jjak', 'jjat', 'jjap', 'jjah', 'jjae', 'jjaeg', 'jjaegg', 'jjaegs', 'jjaen', 'jjaenj', 'jjaenh', 'jjaed']


Joomla CMS: Référence du fichier secp256k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier secp256k1.php

Structures de données

class secp256k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier prime239v1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier prime239v1.php

Structures de données

class prime239v1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier PBEParameter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PBEParameter.php

Structures de données

class PBEParameter

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier UnsupportedCipherException.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • crypt
  • src
  • Exception
Structures de données | Espaces de nommage
Référence du fichier UnsupportedCipherException.php

Structures de données

class UnsupportedCipherException

Espaces de nommage

Joomla\Crypt\Exception


Joomla CMS: Référence du fichier QueryCollector.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • debug
  • src
  • DataCollector
Structures de données | Espaces de nommage
Référence du fichier QueryCollector.php

Structures de données

class QueryCollector

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\System\Debug\DataCollector


Joomla CMS: Référence du fichier TelRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier TelRule.php

Structures de données

class TelRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier Salsa20.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/Salsa20.php

Structures de données

class Salsa20

Espaces de nommage

Salsa20
phpseclib3\Crypt


Joomla CMS: Référence du fichier UriInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • psr
  • http-message
  • src
Structures de données | Espaces de nommage
Référence du fichier psr/http-message/src/UriInterface.php

Structures de données

interface UriInterface

Espaces de nommage

Psr\Http\Message


Joomla CMS: Référence du fichier TemplateTable.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_mails
  • src
  • Table
Structures de données | Espaces de nommage
Référence du fichier TemplateTable.php

Structures de données

class TemplateTable

Espaces de nommage

Joomla\Administrator
Joomla\Component\Mails\Administrator\Table


Joomla CMS: Référence du fichier Status.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_scheduler
  • src
  • Task
Structures de données | Espaces de nommage
Référence du fichier com_scheduler/src/Task/Status.php

Structures de données

class Status

Espaces de nommage

Joomla\Administrator
Joomla\Component\Scheduler\Administrator\Task


Joomla CMS: Référence du fichier sect409k1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect409k1.php

Structures de données

class sect409k1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier UserGroupsHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Helper
Structures de données | Espaces de nommage
Référence du fichier UserGroupsHelper.php

Structures de données

class UserGroupsHelper

Espaces de nommage

Joomla\CMS\Helper


Joomla CMS: Référence du fichier Request.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • laminas
  • laminas-diactoros
  • src
Structures de données | Espaces de nommage
Référence du fichier laminas/laminas-diactoros/src/Request.php

Structures de données

class Request

Espaces de nommage

Laminas\Diactoros


Joomla CMS: Référence du fichier RedisCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier RedisCaster.php

Structures de données

class RedisCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster


Joomla CMS: Référence du fichier Time.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier Time.php

Structures de données

class Time

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier url.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • url
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/url/tmpl/url.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') $attributes = ''
if(!Uri::isInternal($value)) else
if ( $fieldParams->get( 'show_url', 0))

Documentation des variables

◆ $attributes

if ( $value=='') $attributes = ''

◆ $value

$value = $field->value

◆ else

if (!Uri::isInternal( $value)) else
Valeur initiale :
{
$text = Text::_('JVISIT_LINK')
$text
$text
Definition: cancelselect.php:15

◆ if

if($fieldParams->get('show_url', 0))


Joomla CMS: Référence du fichier RequeststatusField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier RequeststatusField.php

Structures de données

class RequeststatusField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Field


Joomla CMS: see

see

Class RelativeStream

Wrapper for default Stream class, representing subpart (starting from given offset) of initial stream. It can be used to avoid copying full stream, conserving memory. Laminas::splitStream()


Joomla CMS: Référence du fichier TBSCertificate.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier TBSCertificate.php

Structures de données

class TBSCertificate

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier x050.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x050.php

Variables

return ['Chang ', 'Chi ', 'Bing ', 'Zan ', 'Yao ', 'Cui ', 'Lia ', 'Wan ', 'Lai ', 'Cang ', 'Zong ', 'Ge ', 'Guan ', 'Bei ', 'Tian ', 'Shu ', 'Shu ', 'Men ', 'Dao ', 'Tan ', 'Jue ', 'Chui ', 'Xing ', 'Peng ', 'Tang ', 'Hou ', 'Yi ', 'Qi ', 'Ti ', 'Gan ', 'Jing ', 'Jie ', 'Sui ', 'Chang ', 'Jie ', 'Fang ', 'Zhi ', 'Kong ', 'Juan ', 'Zong ', 'Ju ', 'Qian ', 'Ni ', 'Lun ', 'Zhuo ', 'Wei ', 'Luo ', 'Song ', 'Leng ', 'Hun ', 'Dong ', 'Zi ', 'Ben ', 'Wu ', 'Ju ', 'Nai ', 'Cai ', 'Jian ', 'Zhai ', 'Ye ', 'Zhi ', 'Sha ', 'Qing ', '[?] ', 'Ying ', 'Cheng ', 'Jian ', 'Yan ', 'Nuan ', 'Zhong ', 'Chun ', 'Jia ', 'Jie ', 'Wei ', 'Yu ', 'Bing ', 'Ruo ', 'Ti ', 'Wei ', 'Pian ', 'Yan ', 'Feng ', 'Tang ', 'Wo ', 'E ', 'Xie ', 'Che ', 'Sheng ', 'Kan ', 'Di ', 'Zuo ', 'Cha ', 'Ting ', 'Bei ', 'Ye ', 'Huang ', 'Yao ', 'Zhan ', 'Chou ', 'Yan ', 'You ', 'Jian ', 'Xu ', 'Zha ', 'Ci ', 'Fu ', 'Bi ', 'Zhi ', 'Zong ', 'Mian ', 'Ji ', 'Yi ', 'Xie ', 'Xun ', 'Si ', 'Duan ', 'Ce ', 'Zhen ', 'Ou ', 'Tou ', 'Tou ', 'Bei ', 'Za ', 'Lu ', 'Jie ', 'Wei ', 'Fen ', 'Chang ', 'Gui ', 'Sou ', 'Zhi ', 'Su ', 'Xia ', 'Fu ', 'Yuan ', 'Rong ', 'Li ', 'Ru ', 'Yun ', 'Gou ', 'Ma ', 'Bang ', 'Dian ', 'Tang ', 'Hao ', 'Jie ', 'Xi ', 'Shan ', 'Qian ', 'Jue ', 'Cang ', 'Chu ', 'San ', 'Bei ', 'Xiao ', 'Yong ', 'Yao ', 'Tan ', 'Suo ', 'Yang ', 'Fa ', 'Bing ', 'Jia ', 'Dai ', 'Zai ', 'Tang ', '[?] ', 'Bin ', 'Chu ', 'Nuo ', 'Can ', 'Lei ', 'Cui ', 'Yong ', 'Zao ', 'Zong ', 'Peng ', 'Song ', 'Ao ', 'Chuan ', 'Yu ', 'Zhai ', 'Cou ', 'Shang ', 'Qiang ', 'Jing ', 'Chi ', 'Sha ', 'Han ', 'Zhang ', 'Qing ', 'Yan ', 'Di ', 'Xi ', 'Lu ', 'Bei ', 'Piao ', 'Jin ', 'Lian ', 'Lu ', 'Man ', 'Qian ', 'Xian ', 'Tan ', 'Ying ', 'Dong ', 'Zhuan ', 'Xiang ', 'Shan ', 'Qiao ', 'Jiong ', 'Tui ', 'Zun ', 'Pu ', 'Xi ', 'Lao ', 'Chang ', 'Guang ', 'Liao ', 'Qi ', 'Deng ', 'Chan ', 'Wei ', 'Ji ', 'Fan ', 'Hui ', 'Chuan ', 'Jian ', 'Dan ', 'Jiao ', 'Jiu ', 'Seng ', 'Fen ', 'Xian ', 'Jue ', 'E ', 'Jiao ', 'Jian ', 'Tong ', 'Lin ', 'Bo ', 'Gu ', '[?] ', 'Su ', 'Xian ', 'Jiang ', 'Min ', 'Ye ', 'Jin ', 'Jia ', 'Qiao ', 'Pi ', 'Feng ', 'Zhou ', 'Ai ', 'Sai ']

Documentation des variables

◆ return

return[ 'Chang ', 'Chi ', 'Bing ', 'Zan ', 'Yao ', 'Cui ', 'Lia ', 'Wan ', 'Lai ', 'Cang ', 'Zong ', 'Ge ', 'Guan ', 'Bei ', 'Tian ', 'Shu ', 'Shu ', 'Men ', 'Dao ', 'Tan ', 'Jue ', 'Chui ', 'Xing ', 'Peng ', 'Tang ', 'Hou ', 'Yi ', 'Qi ', 'Ti ', 'Gan ', 'Jing ', 'Jie ', 'Sui ', 'Chang ', 'Jie ', 'Fang ', 'Zhi ', 'Kong ', 'Juan ', 'Zong ', 'Ju ', 'Qian ', 'Ni ', 'Lun ', 'Zhuo ', 'Wei ', 'Luo ', 'Song ', 'Leng ', 'Hun ', 'Dong ', 'Zi ', 'Ben ', 'Wu ', 'Ju ', 'Nai ', 'Cai ', 'Jian ', 'Zhai ', 'Ye ', 'Zhi ', 'Sha ', 'Qing ', '[?] ', 'Ying ', 'Cheng ', 'Jian ', 'Yan ', 'Nuan ', 'Zhong ', 'Chun ', 'Jia ', 'Jie ', 'Wei ', 'Yu ', 'Bing ', 'Ruo ', 'Ti ', 'Wei ', 'Pian ', 'Yan ', 'Feng ', 'Tang ', 'Wo ', 'E ', 'Xie ', 'Che ', 'Sheng ', 'Kan ', 'Di ', 'Zuo ', 'Cha ', 'Ting ', 'Bei ', 'Ye ', 'Huang ', 'Yao ', 'Zhan ', 'Chou ', 'Yan ', 'You ', 'Jian ', 'Xu ', 'Zha ', 'Ci ', 'Fu ', 'Bi ', 'Zhi ', 'Zong ', 'Mian ', 'Ji ', 'Yi ', 'Xie ', 'Xun ', 'Si ', 'Duan ', 'Ce ', 'Zhen ', 'Ou ', 'Tou ', 'Tou ', 'Bei ', 'Za ', 'Lu ', 'Jie ', 'Wei ', 'Fen ', 'Chang ', 'Gui ', 'Sou ', 'Zhi ', 'Su ', 'Xia ', 'Fu ', 'Yuan ', 'Rong ', 'Li ', 'Ru ', 'Yun ', 'Gou ', 'Ma ', 'Bang ', 'Dian ', 'Tang ', 'Hao ', 'Jie ', 'Xi ', 'Shan ', 'Qian ', 'Jue ', 'Cang ', 'Chu ', 'San ', 'Bei ', 'Xiao ', 'Yong ', 'Yao ', 'Tan ', 'Suo ', 'Yang ', 'Fa ', 'Bing ', 'Jia ', 'Dai ', 'Zai ', 'Tang ', '[?] ', 'Bin ', 'Chu ', 'Nuo ', 'Can ', 'Lei ', 'Cui ', 'Yong ', 'Zao ', 'Zong ', 'Peng ', 'Song ', 'Ao ', 'Chuan ', 'Yu ', 'Zhai ', 'Cou ', 'Shang ', 'Qiang ', 'Jing ', 'Chi ', 'Sha ', 'Han ', 'Zhang ', 'Qing ', 'Yan ', 'Di ', 'Xi ', 'Lu ', 'Bei ', 'Piao ', 'Jin ', 'Lian ', 'Lu ', 'Man ', 'Qian ', 'Xian ', 'Tan ', 'Ying ', 'Dong ', 'Zhuan ', 'Xiang ', 'Shan ', 'Qiao ', 'Jiong ', 'Tui ', 'Zun ', 'Pu ', 'Xi ', 'Lao ', 'Chang ', 'Guang ', 'Liao ', 'Qi ', 'Deng ', 'Chan ', 'Wei ', 'Ji ', 'Fan ', 'Hui ', 'Chuan ', 'Jian ', 'Dan ', 'Jiao ', 'Jiu ', 'Seng ', 'Fen ', 'Xian ', 'Jue ', 'E ', 'Jiao ', 'Jian ', 'Tong ', 'Lin ', 'Bo ', 'Gu ', '[?] ', 'Su ', 'Xian ', 'Jiang ', 'Min ', 'Ye ', 'Jin ', 'Jia ', 'Qiao ', 'Pi ', 'Feng ', 'Zhou ', 'Ai ', 'Sai ']


Joomla CMS: Référence du fichier ProfileModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ProfileModel.php

Structures de données

class ProfileModel

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier Patcher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • filesystem
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/joomla/filesystem/src/Patcher.php

Structures de données

class Patcher

Espaces de nommage

Joomla\Filesystem


Joomla CMS: Référence du fichier PhpToken.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • polyfill-php80
Structures de données | Espaces de nommage
Référence du fichier PhpToken.php

Structures de données

class PhpToken

Espaces de nommage

Symfony\Polyfill\Php80


Joomla CMS: Référence du fichier UndefinedFunctionErrorEnhancer.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • error-handler
  • ErrorEnhancer
Structures de données | Espaces de nommage
Référence du fichier UndefinedFunctionErrorEnhancer.php

Structures de données

class UndefinedFunctionErrorEnhancer

Espaces de nommage

Symfony\Component\ErrorHandler\ErrorEnhancer


Joomla CMS: Référence du fichier uniqueid.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • system
  • stats
  • layouts
  • field
Espaces de nommage
Référence du fichier uniqueid.php

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier ProviderAwareAuthenticationPluginInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Authentication
Structures de données | Espaces de nommage
Référence du fichier ProviderAwareAuthenticationPluginInterface.php

Structures de données

interface ProviderAwareAuthenticationPluginInterface

Espaces de nommage

Joomla\CMS\Authentication


Joomla CMS: Référence du fichier x092.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x092.php

Variables

return ['Ba ', 'Fang ', 'Chen ', 'Xing ', 'Tou ', 'Yue ', 'Yan ', 'Fu ', 'Pi ', 'Na ', 'Xin ', 'E ', 'Jue ', 'Dun ', 'Gou ', 'Yin ', 'Qian ', 'Ban ', 'Ji ', 'Ren ', 'Chao ', 'Niu ', 'Fen ', 'Yun ', 'Ji ', 'Qin ', 'Pi ', 'Guo ', 'Hong ', 'Yin ', 'Jun ', 'Shi ', 'Yi ', 'Zhong ', 'Nie ', 'Gai ', 'Ri ', 'Huo ', 'Tai ', 'Kang ', 'Habaki ', 'Irori ', 'Ngaak ', '[?] ', 'Duo ', 'Zi ', 'Ni ', 'Tu ', 'Shi ', 'Min ', 'Gu ', 'E ', 'Ling ', 'Bing ', 'Yi ', 'Gu ', 'Ba ', 'Pi ', 'Yu ', 'Si ', 'Zuo ', 'Bu ', 'You ', 'Dian ', 'Jia ', 'Zhen ', 'Shi ', 'Shi ', 'Tie ', 'Ju ', 'Zhan ', 'Shi ', 'She ', 'Xuan ', 'Zhao ', 'Bao ', 'He ', 'Bi ', 'Sheng ', 'Chu ', 'Shi ', 'Bo ', 'Zhu ', 'Chi ', 'Za ', 'Po ', 'Tong ', 'Qian ', 'Fu ', 'Zhai ', 'Liu ', 'Qian ', 'Fu ', 'Li ', 'Yue ', 'Pi ', 'Yang ', 'Ban ', 'Bo ', 'Jie ', 'Gou ', 'Shu ', 'Zheng ', 'Mu ', 'Ni ', 'Nie ', 'Di ', 'Jia ', 'Mu ', 'Dan ', 'Shen ', 'Yi ', 'Si ', 'Kuang ', 'Ka ', 'Bei ', 'Jian ', 'Tong ', 'Xing ', 'Hong ', 'Jiao ', 'Chi ', 'Er ', 'Ge ', 'Bing ', 'Shi ', 'Mou ', 'Jia ', 'Yin ', 'Jun ', 'Zhou ', 'Chong ', 'Shang ', 'Tong ', 'Mo ', 'Lei ', 'Ji ', 'Yu ', 'Xu ', 'Ren ', 'Zun ', 'Zhi ', 'Qiong ', 'Shan ', 'Chi ', 'Xian ', 'Xing ', 'Quan ', 'Pi ', 'Tie ', 'Zhu ', 'Hou ', 'Ming ', 'Kua ', 'Yao ', 'Xian ', 'Xian ', 'Xiu ', 'Jun ', 'Cha ', 'Lao ', 'Ji ', 'Pi ', 'Ru ', 'Mi ', 'Yi ', 'Yin ', 'Guang ', 'An ', 'Diou ', 'You ', 'Se ', 'Kao ', 'Qian ', 'Luan ', 'Kasugai ', 'Ai ', 'Diao ', 'Han ', 'Rui ', 'Shi ', 'Keng ', 'Qiu ', 'Xiao ', 'Zhe ', 'Xiu ', 'Zang ', 'Ti ', 'Cuo ', 'Gua ', 'Gong ', 'Zhong ', 'Dou ', 'Lu ', 'Mei ', 'Lang ', 'Wan ', 'Xin ', 'Yun ', 'Bei ', 'Wu ', 'Su ', 'Yu ', 'Chan ', 'Ting ', 'Bo ', 'Han ', 'Jia ', 'Hong ', 'Cuan ', 'Feng ', 'Chan ', 'Wan ', 'Zhi ', 'Si ', 'Xuan ', 'Wu ', 'Wu ', 'Tiao ', 'Gong ', 'Zhuo ', 'Lue ', 'Xing ', 'Qian ', 'Shen ', 'Han ', 'Lue ', 'Xie ', 'Chu ', 'Zheng ', 'Ju ', 'Xian ', 'Tie ', 'Mang ', 'Pu ', 'Li ', 'Pan ', 'Rui ', 'Cheng ', 'Gao ', 'Li ', 'Te ', 'Pyeng ', 'Zhu ', '[?] ', 'Tu ', 'Liu ', 'Zui ', 'Ju ', 'Chang ', 'Yuan ', 'Jian ', 'Gang ', 'Diao ', 'Tao ', 'Chang ']

Documentation des variables

◆ return

return[ 'Ba ', 'Fang ', 'Chen ', 'Xing ', 'Tou ', 'Yue ', 'Yan ', 'Fu ', 'Pi ', 'Na ', 'Xin ', 'E ', 'Jue ', 'Dun ', 'Gou ', 'Yin ', 'Qian ', 'Ban ', 'Ji ', 'Ren ', 'Chao ', 'Niu ', 'Fen ', 'Yun ', 'Ji ', 'Qin ', 'Pi ', 'Guo ', 'Hong ', 'Yin ', 'Jun ', 'Shi ', 'Yi ', 'Zhong ', 'Nie ', 'Gai ', 'Ri ', 'Huo ', 'Tai ', 'Kang ', 'Habaki ', 'Irori ', 'Ngaak ', '[?] ', 'Duo ', 'Zi ', 'Ni ', 'Tu ', 'Shi ', 'Min ', 'Gu ', 'E ', 'Ling ', 'Bing ', 'Yi ', 'Gu ', 'Ba ', 'Pi ', 'Yu ', 'Si ', 'Zuo ', 'Bu ', 'You ', 'Dian ', 'Jia ', 'Zhen ', 'Shi ', 'Shi ', 'Tie ', 'Ju ', 'Zhan ', 'Shi ', 'She ', 'Xuan ', 'Zhao ', 'Bao ', 'He ', 'Bi ', 'Sheng ', 'Chu ', 'Shi ', 'Bo ', 'Zhu ', 'Chi ', 'Za ', 'Po ', 'Tong ', 'Qian ', 'Fu ', 'Zhai ', 'Liu ', 'Qian ', 'Fu ', 'Li ', 'Yue ', 'Pi ', 'Yang ', 'Ban ', 'Bo ', 'Jie ', 'Gou ', 'Shu ', 'Zheng ', 'Mu ', 'Ni ', 'Nie ', 'Di ', 'Jia ', 'Mu ', 'Dan ', 'Shen ', 'Yi ', 'Si ', 'Kuang ', 'Ka ', 'Bei ', 'Jian ', 'Tong ', 'Xing ', 'Hong ', 'Jiao ', 'Chi ', 'Er ', 'Ge ', 'Bing ', 'Shi ', 'Mou ', 'Jia ', 'Yin ', 'Jun ', 'Zhou ', 'Chong ', 'Shang ', 'Tong ', 'Mo ', 'Lei ', 'Ji ', 'Yu ', 'Xu ', 'Ren ', 'Zun ', 'Zhi ', 'Qiong ', 'Shan ', 'Chi ', 'Xian ', 'Xing ', 'Quan ', 'Pi ', 'Tie ', 'Zhu ', 'Hou ', 'Ming ', 'Kua ', 'Yao ', 'Xian ', 'Xian ', 'Xiu ', 'Jun ', 'Cha ', 'Lao ', 'Ji ', 'Pi ', 'Ru ', 'Mi ', 'Yi ', 'Yin ', 'Guang ', 'An ', 'Diou ', 'You ', 'Se ', 'Kao ', 'Qian ', 'Luan ', 'Kasugai ', 'Ai ', 'Diao ', 'Han ', 'Rui ', 'Shi ', 'Keng ', 'Qiu ', 'Xiao ', 'Zhe ', 'Xiu ', 'Zang ', 'Ti ', 'Cuo ', 'Gua ', 'Gong ', 'Zhong ', 'Dou ', 'Lu ', 'Mei ', 'Lang ', 'Wan ', 'Xin ', 'Yun ', 'Bei ', 'Wu ', 'Su ', 'Yu ', 'Chan ', 'Ting ', 'Bo ', 'Han ', 'Jia ', 'Hong ', 'Cuan ', 'Feng ', 'Chan ', 'Wan ', 'Zhi ', 'Si ', 'Xuan ', 'Wu ', 'Wu ', 'Tiao ', 'Gong ', 'Zhuo ', 'Lue ', 'Xing ', 'Qian ', 'Shen ', 'Han ', 'Lue ', 'Xie ', 'Chu ', 'Zheng ', 'Ju ', 'Xian ', 'Tie ', 'Mang ', 'Pu ', 'Li ', 'Pan ', 'Rui ', 'Cheng ', 'Gao ', 'Li ', 'Te ', 'Pyeng ', 'Zhu ', '[?] ', 'Tu ', 'Liu ', 'Zui ', 'Ju ', 'Chang ', 'Yuan ', 'Jian ', 'Gang ', 'Diao ', 'Tao ', 'Chang ']


Joomla CMS: Référence du fichier Privacy.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_privacy
  • src
  • Service
  • HTML
Structures de données | Espaces de nommage
Référence du fichier Privacy.php

Structures de données

class Privacy

Espaces de nommage

Joomla\Administrator
Joomla\Component\Privacy\Administrator\Service\HTML


Joomla CMS: Référence du fichier x06d.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x06d.php

Variables

return ['Zhou ', 'Ji ', 'Yi ', 'Hui ', 'Hui ', 'Zui ', 'Cheng ', 'Yin ', 'Wei ', 'Hou ', 'Jian ', 'Yang ', 'Lie ', 'Si ', 'Ji ', 'Er ', 'Xing ', 'Fu ', 'Sa ', 'Suo ', 'Zhi ', 'Yin ', 'Wu ', 'Xi ', 'Kao ', 'Zhu ', 'Jiang ', 'Luo ', '[?] ', 'An ', 'Dong ', 'Yi ', 'Mou ', 'Lei ', 'Yi ', 'Mi ', 'Quan ', 'Jin ', 'Mo ', 'Wei ', 'Xiao ', 'Xie ', 'Hong ', 'Xu ', 'Shuo ', 'Kuang ', 'Tao ', 'Qie ', 'Ju ', 'Er ', 'Zhou ', 'Ru ', 'Ping ', 'Xun ', 'Xiong ', 'Zhi ', 'Guang ', 'Huan ', 'Ming ', 'Huo ', 'Wa ', 'Qia ', 'Pai ', 'Wu ', 'Qu ', 'Liu ', 'Yi ', 'Jia ', 'Jing ', 'Qian ', 'Jiang ', 'Jiao ', 'Cheng ', 'Shi ', 'Zhuo ', 'Ce ', 'Pal ', 'Kuai ', 'Ji ', 'Liu ', 'Chan ', 'Hun ', 'Hu ', 'Nong ', 'Xun ', 'Jin ', 'Lie ', 'Qiu ', 'Wei ', 'Zhe ', 'Jun ', 'Han ', 'Bang ', 'Mang ', 'Zhuo ', 'You ', 'Xi ', 'Bo ', 'Dou ', 'Wan ', 'Hong ', 'Yi ', 'Pu ', 'Ying ', 'Lan ', 'Hao ', 'Lang ', 'Han ', 'Li ', 'Geng ', 'Fu ', 'Wu ', 'Lian ', 'Chun ', 'Feng ', 'Yi ', 'Yu ', 'Tong ', 'Lao ', 'Hai ', 'Jin ', 'Jia ', 'Chong ', 'Weng ', 'Mei ', 'Sui ', 'Cheng ', 'Pei ', 'Xian ', 'Shen ', 'Tu ', 'Kun ', 'Pin ', 'Nie ', 'Han ', 'Jing ', 'Xiao ', 'She ', 'Nian ', 'Tu ', 'Yong ', 'Xiao ', 'Xian ', 'Ting ', 'E ', 'Su ', 'Tun ', 'Juan ', 'Cen ', 'Ti ', 'Li ', 'Shui ', 'Si ', 'Lei ', 'Shui ', 'Tao ', 'Du ', 'Lao ', 'Lai ', 'Lian ', 'Wei ', 'Wo ', 'Yun ', 'Huan ', 'Di ', '[?] ', 'Run ', 'Jian ', 'Zhang ', 'Se ', 'Fu ', 'Guan ', 'Xing ', 'Shou ', 'Shuan ', 'Ya ', 'Chuo ', 'Zhang ', 'Ye ', 'Kong ', 'Wo ', 'Han ', 'Tuo ', 'Dong ', 'He ', 'Wo ', 'Ju ', 'Gan ', 'Liang ', 'Hun ', 'Ta ', 'Zhuo ', 'Dian ', 'Qie ', 'De ', 'Juan ', 'Zi ', 'Xi ', 'Yao ', 'Qi ', 'Gu ', 'Guo ', 'Han ', 'Lin ', 'Tang ', 'Zhou ', 'Peng ', 'Hao ', 'Chang ', 'Shu ', 'Qi ', 'Fang ', 'Chi ', 'Lu ', 'Nao ', 'Ju ', 'Tao ', 'Cong ', 'Lei ', 'Zhi ', 'Peng ', 'Fei ', 'Song ', 'Tian ', 'Pi ', 'Dan ', 'Yu ', 'Ni ', 'Yu ', 'Lu ', 'Gan ', 'Mi ', 'Jing ', 'Ling ', 'Lun ', 'Yin ', 'Cui ', 'Qu ', 'Huai ', 'Yu ', 'Nian ', 'Shen ', 'Piao ', 'Chun ', 'Wa ', 'Yuan ', 'Lai ', 'Hun ', 'Qing ', 'Yan ', 'Qian ', 'Tian ', 'Miao ', 'Zhi ', 'Yin ', 'Mi ']

Documentation des variables

◆ return

return[ 'Zhou ', 'Ji ', 'Yi ', 'Hui ', 'Hui ', 'Zui ', 'Cheng ', 'Yin ', 'Wei ', 'Hou ', 'Jian ', 'Yang ', 'Lie ', 'Si ', 'Ji ', 'Er ', 'Xing ', 'Fu ', 'Sa ', 'Suo ', 'Zhi ', 'Yin ', 'Wu ', 'Xi ', 'Kao ', 'Zhu ', 'Jiang ', 'Luo ', '[?] ', 'An ', 'Dong ', 'Yi ', 'Mou ', 'Lei ', 'Yi ', 'Mi ', 'Quan ', 'Jin ', 'Mo ', 'Wei ', 'Xiao ', 'Xie ', 'Hong ', 'Xu ', 'Shuo ', 'Kuang ', 'Tao ', 'Qie ', 'Ju ', 'Er ', 'Zhou ', 'Ru ', 'Ping ', 'Xun ', 'Xiong ', 'Zhi ', 'Guang ', 'Huan ', 'Ming ', 'Huo ', 'Wa ', 'Qia ', 'Pai ', 'Wu ', 'Qu ', 'Liu ', 'Yi ', 'Jia ', 'Jing ', 'Qian ', 'Jiang ', 'Jiao ', 'Cheng ', 'Shi ', 'Zhuo ', 'Ce ', 'Pal ', 'Kuai ', 'Ji ', 'Liu ', 'Chan ', 'Hun ', 'Hu ', 'Nong ', 'Xun ', 'Jin ', 'Lie ', 'Qiu ', 'Wei ', 'Zhe ', 'Jun ', 'Han ', 'Bang ', 'Mang ', 'Zhuo ', 'You ', 'Xi ', 'Bo ', 'Dou ', 'Wan ', 'Hong ', 'Yi ', 'Pu ', 'Ying ', 'Lan ', 'Hao ', 'Lang ', 'Han ', 'Li ', 'Geng ', 'Fu ', 'Wu ', 'Lian ', 'Chun ', 'Feng ', 'Yi ', 'Yu ', 'Tong ', 'Lao ', 'Hai ', 'Jin ', 'Jia ', 'Chong ', 'Weng ', 'Mei ', 'Sui ', 'Cheng ', 'Pei ', 'Xian ', 'Shen ', 'Tu ', 'Kun ', 'Pin ', 'Nie ', 'Han ', 'Jing ', 'Xiao ', 'She ', 'Nian ', 'Tu ', 'Yong ', 'Xiao ', 'Xian ', 'Ting ', 'E ', 'Su ', 'Tun ', 'Juan ', 'Cen ', 'Ti ', 'Li ', 'Shui ', 'Si ', 'Lei ', 'Shui ', 'Tao ', 'Du ', 'Lao ', 'Lai ', 'Lian ', 'Wei ', 'Wo ', 'Yun ', 'Huan ', 'Di ', '[?] ', 'Run ', 'Jian ', 'Zhang ', 'Se ', 'Fu ', 'Guan ', 'Xing ', 'Shou ', 'Shuan ', 'Ya ', 'Chuo ', 'Zhang ', 'Ye ', 'Kong ', 'Wo ', 'Han ', 'Tuo ', 'Dong ', 'He ', 'Wo ', 'Ju ', 'Gan ', 'Liang ', 'Hun ', 'Ta ', 'Zhuo ', 'Dian ', 'Qie ', 'De ', 'Juan ', 'Zi ', 'Xi ', 'Yao ', 'Qi ', 'Gu ', 'Guo ', 'Han ', 'Lin ', 'Tang ', 'Zhou ', 'Peng ', 'Hao ', 'Chang ', 'Shu ', 'Qi ', 'Fang ', 'Chi ', 'Lu ', 'Nao ', 'Ju ', 'Tao ', 'Cong ', 'Lei ', 'Zhi ', 'Peng ', 'Fei ', 'Song ', 'Tian ', 'Pi ', 'Dan ', 'Yu ', 'Ni ', 'Yu ', 'Lu ', 'Gan ', 'Mi ', 'Jing ', 'Ling ', 'Lun ', 'Yin ', 'Cui ', 'Qu ', 'Huai ', 'Yu ', 'Nian ', 'Shen ', 'Piao ', 'Chun ', 'Wa ', 'Yuan ', 'Lai ', 'Hun ', 'Qing ', 'Yan ', 'Qian ', 'Tian ', 'Miao ', 'Zhi ', 'Yin ', 'Mi ']


Joomla CMS: Référence du fichier ResultAwareInterface.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Event
  • Result
Structures de données | Espaces de nommage
Référence du fichier ResultAwareInterface.php

Structures de données

interface ResultAwareInterface

Espaces de nommage

Joomla\CMS\Event\Result


Joomla CMS: Référence du fichier Sha256.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier Ecdsa/Sha256.php

Structures de données

class Sha256

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier utf8_fix.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-utf8
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier utf8_fix.php

Variables

return ['â€š'=> '‚', 'â€ž'=> '„', 'â€¦'=> '…', 'â€¡'=> '‡', 'â€°'=> '‰', 'â€¹'=> '‹', 'â€˜'=> '‘', 'â€™'=> '’', 'â€œ'=> '“', 'â€¢'=> '•', 'â€“'=> '–', 'â€”'=> '—', 'â„¢'=> '™', 'â€º'=> '›', 'â‚¬'=> '€', "\2\0"=> "\2\2\c", "\2\2"=> "\2\0\a", "\2\3"=> "\6\2", "\2\4"=> "\2\0\e", "\2\5"=> "\2\0\6", "\2\6"=> "\2\0\0", "\2\7"=> "\2\0\1", "\2\8"=> "\b\6", "\2\9"=> "\2\0\0", "\2\a"=> "\5\0", "\2\b"=> "\2\0\9", "\2\c"=> "\5\2", "\2\e"=> "\5\d", "\2\1"=> "\2\0\8", "\2\2"=> "\2\0\9", "\2\3"=> "\2\0\c", "\2\4"=> "\2\0\d", "\2\5"=> "\2\0\2", "\2\6"=> "\2\0\3", "\2\7"=> "\2\0\4", "\2\8"=> "\b\c", 'Ã‚'=> 'Â', 'Æ’'=> 'ƒ', 'Ãƒ'=> 'Ã', 'Ã„'=> 'Ä', 'Ã…'=> 'Å', 'Ã†'=> 'Æ', 'Ã‡'=> 'Ç', 'Ë†'=> 'ˆ', 'Ãˆ'=> 'È', 'Ã‰'=> 'É', 'ÃŠ'=> 'Ê', 'Ã‹'=> 'Ë', 'Å’'=> 'Œ', 'ÃŒ'=> 'Ì', 'Å½'=> 'Ž', 'ÃŽ'=> 'Î', 'Ã‘'=> 'Ñ', 'Ã’'=> 'Ò', 'Ã“'=> 'Ó', 'â€'=> '”', 'Ã”'=> 'Ô', 'Ã•'=> 'Õ', 'Ã–'=> 'Ö', 'Ã—'=> '×', 'Ëœ'=> '˜', 'Ã˜'=> 'Ø', 'Ã™'=> 'Ù', 'Å¡'=> 'š', 'Ãš'=> 'Ú', 'Ã›'=> 'Û', 'Å“'=> 'œ', 'Ãœ'=> 'Ü', 'Å¾'=> 'ž', 'Ãž'=> 'Þ', 'Å¸'=> 'Ÿ', 'ÃŸ'=> 'ß', 'Â¡'=> '¡', 'Ã¡'=> 'á', 'Â¢'=> '¢', 'Ã¢'=> 'â', 'Â£'=> '£', 'Ã£'=> 'ã', 'Â¤'=> '¤', 'Ã¤'=> 'ä', 'Â¥'=> '¥', 'Ã¥'=> 'å', 'Â¦'=> '¦', 'Ã¦'=> 'æ', 'Â§'=> '§', 'Ã§'=> 'ç', 'Â¨'=> '¨', 'Ã¨'=> 'è', 'Â©'=> '©', 'Ã©'=> 'é', 'Âª'=> 'ª', 'Ãª'=> 'ê', 'Â«'=> '«', 'Ã«'=> 'ë', 'Â¬'=> '¬', 'Ã¬'=> 'ì', 'Â®'=> '®', 'Ã®'=> 'î', 'Â¯'=> '¯', 'Ã¯'=> 'ï', 'Â°'=> '°', 'Ã°'=> 'ð', 'Â±'=> '±', 'Ã±'=> 'ñ', 'Â²'=> '²', 'Ã²'=> 'ò', 'Â³'=> '³', 'Ã³'=> 'ó', 'Â´'=> '´', 'Ã´'=> 'ô', 'Âµ'=> 'µ', 'Ãµ'=> 'õ', 'Â¶'=> '¶', 'Ã¶'=> 'ö', 'Â·'=> '·', 'Ã·'=> '÷', 'Â¸'=> '¸', 'Ã¸'=> 'ø', 'Â¹'=> '¹', 'Ã¹'=> 'ù', 'Âº'=> 'º', 'Ãº'=> 'ú', 'Â»'=> '»', 'Ã»'=> 'û', 'Â¼'=> '¼', 'Ã¼'=> 'ü', 'Â½'=> '½', 'Ã½'=> 'ý', 'Â¾'=> '¾', 'Ã¾'=> 'þ', 'Â¿'=> '¿', 'Ã¿'=> 'ÿ', 'Ã€'=> 'À',]

Documentation des variables

◆ return

return[ 'â€š'=> '‚', 'â€ž'=> '„', 'â€¦'=> '…', 'â€¡'=> '‡', 'â€°'=> '‰', 'â€¹'=> '‹', 'â€˜'=> '‘', 'â€™'=> '’', 'â€œ'=> '“', 'â€¢'=> '•', 'â€“'=> '–', 'â€”'=> '—', 'â„¢'=> '™', 'â€º'=> '›', 'â‚¬'=> '€', "\c2\80"=> "\e2\82\ac", "\c2\82"=> "\e2\80\9a", "\c2\83"=> "\c6\92", "\c2\84"=> "\e2\80\9e", "\c2\85"=> "\e2\80\a6", "\c2\86"=> "\e2\80\a0", "\c2\87"=> "\e2\80\a1", "\c2\88"=> "\cb\86", "\c2\89"=> "\e2\80\b0", "\c2\8a"=> "\c5\a0", "\c2\8b"=> "\e2\80\b9", "\c2\8c"=> "\c5\92", "\c2\8e"=> "\c5\bd", "\c2\91"=> "\e2\80\98", "\c2\92"=> "\e2\80\99", "\c2\93"=> "\e2\80\9c", "\c2\94"=> "\e2\80\9d", "\c2\95"=> "\e2\80\a2", "\c2\96"=> "\e2\80\93", "\c2\97"=> "\e2\80\94", "\c2\98"=> "\cb\9c", 'Ã‚'=> 'Â', 'Æ’'=> 'ƒ', 'Ãƒ'=> 'Ã', 'Ã„'=> 'Ä', 'Ã…'=> 'Å', 'Ã†'=> 'Æ', 'Ã‡'=> 'Ç', 'Ë†'=> 'ˆ', 'Ãˆ'=> 'È', 'Ã‰'=> 'É', 'ÃŠ'=> 'Ê', 'Ã‹'=> 'Ë', 'Å’'=> 'Œ', 'ÃŒ'=> 'Ì', 'Å½'=> 'Ž', 'ÃŽ'=> 'Î', 'Ã‘'=> 'Ñ', 'Ã’'=> 'Ò', 'Ã“'=> 'Ó', 'â€'=> '”', 'Ã”'=> 'Ô', 'Ã•'=> 'Õ', 'Ã–'=> 'Ö', 'Ã—'=> '×', 'Ëœ'=> '˜', 'Ã˜'=> 'Ø', 'Ã™'=> 'Ù', 'Å¡'=> 'š', 'Ãš'=> 'Ú', 'Ã›'=> 'Û', 'Å“'=> 'œ', 'Ãœ'=> 'Ü', 'Å¾'=> 'ž', 'Ãž'=> 'Þ', 'Å¸'=> 'Ÿ', 'ÃŸ'=> 'ß', 'Â¡'=> '¡', 'Ã¡'=> 'á', 'Â¢'=> '¢', 'Ã¢'=> 'â', 'Â£'=> '£', 'Ã£'=> 'ã', 'Â¤'=> '¤', 'Ã¤'=> 'ä', 'Â¥'=> '¥', 'Ã¥'=> 'å', 'Â¦'=> '¦', 'Ã¦'=> 'æ', 'Â§'=> '§', 'Ã§'=> 'ç', 'Â¨'=> '¨', 'Ã¨'=> 'è', 'Â©'=> '©', 'Ã©'=> 'é', 'Âª'=> 'ª', 'Ãª'=> 'ê', 'Â«'=> '«', 'Ã«'=> 'ë', 'Â¬'=> '¬', 'Ã¬'=> 'ì', 'Â®'=> '®', 'Ã®'=> 'î', 'Â¯'=> '¯', 'Ã¯'=> 'ï', 'Â°'=> '°', 'Ã°'=> 'ð', 'Â±'=> '±', 'Ã±'=> 'ñ', 'Â²'=> '²', 'Ã²'=> 'ò', 'Â³'=> '³', 'Ã³'=> 'ó', 'Â´'=> '´', 'Ã´'=> 'ô', 'Âµ'=> 'µ', 'Ãµ'=> 'õ', 'Â¶'=> '¶', 'Ã¶'=> 'ö', 'Â·'=> '·', 'Ã·'=> '÷', 'Â¸'=> '¸', 'Ã¸'=> 'ø', 'Â¹'=> '¹', 'Ã¹'=> 'ù', 'Âº'=> 'º', 'Ãº'=> 'ú', 'Â»'=> '»', 'Ã»'=> 'û', 'Â¼'=> '¼', 'Ã¼'=> 'ü', 'Â½'=> '½', 'Ã½'=> 'ý', 'Â¾'=> '¾', 'Ã¾'=> 'þ', 'Â¿'=> '¿', 'Ã¿'=> 'ÿ', 'Ã€'=> 'À',]


Joomla CMS: Référence du fichier PackedAttestationStatementSupport.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • web-auth
  • webauthn-lib
  • src
  • AttestationStatement
Structures de données | Espaces de nommage
Référence du fichier PackedAttestationStatementSupport.php

Structures de données

class PackedAttestationStatementSupport

Espaces de nommage

Webauthn\AttestationStatement


Joomla CMS: Référence du fichier TagApiSerializerTrait.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Tag
Espaces de nommage
Référence du fichier TagApiSerializerTrait.php

Espaces de nommage

Joomla\CMS\Tag


Joomla CMS: Référence du fichier TextStringWithChunkObject.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier TextStringWithChunkObject.php

Structures de données

class TextStringWithChunkObject

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier PunycodeHelper.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • String
Structures de données | Espaces de nommage
Référence du fichier PunycodeHelper.php

Structures de données

class PunycodeHelper

Espaces de nommage

Joomla\CMS\String


Joomla CMS: Référence du fichier x0ce.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ce.php

Variables

return ['cwik', 'cwit', 'cwip', 'cwih', 'cyu', 'cyug', 'cyugg', 'cyugs', 'cyun', 'cyunj', 'cyunh', 'cyud', 'cyul', 'cyulg', 'cyulm', 'cyulb', 'cyuls', 'cyult', 'cyulp', 'cyulh', 'cyum', 'cyub', 'cyubs', 'cyus', 'cyuss', 'cyung', 'cyuj', 'cyuc', 'cyuk', 'cyut', 'cyup', 'cyuh', 'ceu', 'ceug', 'ceugg', 'ceugs', 'ceun', 'ceunj', 'ceunh', 'ceud', 'ceul', 'ceulg', 'ceulm', 'ceulb', 'ceuls', 'ceult', 'ceulp', 'ceulh', 'ceum', 'ceub', 'ceubs', 'ceus', 'ceuss', 'ceung', 'ceuj', 'ceuc', 'ceuk', 'ceut', 'ceup', 'ceuh', 'cyi', 'cyig', 'cyigg', 'cyigs', 'cyin', 'cyinj', 'cyinh', 'cyid', 'cyil', 'cyilg', 'cyilm', 'cyilb', 'cyils', 'cyilt', 'cyilp', 'cyilh', 'cyim', 'cyib', 'cyibs', 'cyis', 'cyiss', 'cying', 'cyij', 'cyic', 'cyik', 'cyit', 'cyip', 'cyih', 'ci', 'cig', 'cigg', 'cigs', 'cin', 'cinj', 'cinh', 'cid', 'cil', 'cilg', 'cilm', 'cilb', 'cils', 'cilt', 'cilp', 'cilh', 'cim', 'cib', 'cibs', 'cis', 'ciss', 'cing', 'cij', 'cic', 'cik', 'cit', 'cip', 'cih', 'ka', 'kag', 'kagg', 'kags', 'kan', 'kanj', 'kanh', 'kad', 'kal', 'kalg', 'kalm', 'kalb', 'kals', 'kalt', 'kalp', 'kalh', 'kam', 'kab', 'kabs', 'kas', 'kass', 'kang', 'kaj', 'kac', 'kak', 'kat', 'kap', 'kah', 'kae', 'kaeg', 'kaegg', 'kaegs', 'kaen', 'kaenj', 'kaenh', 'kaed', 'kael', 'kaelg', 'kaelm', 'kaelb', 'kaels', 'kaelt', 'kaelp', 'kaelh', 'kaem', 'kaeb', 'kaebs', 'kaes', 'kaess', 'kaeng', 'kaej', 'kaec', 'kaek', 'kaet', 'kaep', 'kaeh', 'kya', 'kyag', 'kyagg', 'kyags', 'kyan', 'kyanj', 'kyanh', 'kyad', 'kyal', 'kyalg', 'kyalm', 'kyalb', 'kyals', 'kyalt', 'kyalp', 'kyalh', 'kyam', 'kyab', 'kyabs', 'kyas', 'kyass', 'kyang', 'kyaj', 'kyac', 'kyak', 'kyat', 'kyap', 'kyah', 'kyae', 'kyaeg', 'kyaegg', 'kyaegs', 'kyaen', 'kyaenj', 'kyaenh', 'kyaed', 'kyael', 'kyaelg', 'kyaelm', 'kyaelb', 'kyaels', 'kyaelt', 'kyaelp', 'kyaelh', 'kyaem', 'kyaeb', 'kyaebs', 'kyaes', 'kyaess', 'kyaeng', 'kyaej', 'kyaec', 'kyaek', 'kyaet', 'kyaep', 'kyaeh', 'keo', 'keog', 'keogg', 'keogs', 'keon', 'keonj', 'keonh', 'keod', 'keol', 'keolg', 'keolm', 'keolb', 'keols', 'keolt', 'keolp', 'keolh', 'keom', 'keob', 'keobs', 'keos', 'keoss', 'keong', 'keoj', 'keoc', 'keok', 'keot', 'keop', 'keoh']

Documentation des variables

◆ return

return[ 'cwik', 'cwit', 'cwip', 'cwih', 'cyu', 'cyug', 'cyugg', 'cyugs', 'cyun', 'cyunj', 'cyunh', 'cyud', 'cyul', 'cyulg', 'cyulm', 'cyulb', 'cyuls', 'cyult', 'cyulp', 'cyulh', 'cyum', 'cyub', 'cyubs', 'cyus', 'cyuss', 'cyung', 'cyuj', 'cyuc', 'cyuk', 'cyut', 'cyup', 'cyuh', 'ceu', 'ceug', 'ceugg', 'ceugs', 'ceun', 'ceunj', 'ceunh', 'ceud', 'ceul', 'ceulg', 'ceulm', 'ceulb', 'ceuls', 'ceult', 'ceulp', 'ceulh', 'ceum', 'ceub', 'ceubs', 'ceus', 'ceuss', 'ceung', 'ceuj', 'ceuc', 'ceuk', 'ceut', 'ceup', 'ceuh', 'cyi', 'cyig', 'cyigg', 'cyigs', 'cyin', 'cyinj', 'cyinh', 'cyid', 'cyil', 'cyilg', 'cyilm', 'cyilb', 'cyils', 'cyilt', 'cyilp', 'cyilh', 'cyim', 'cyib', 'cyibs', 'cyis', 'cyiss', 'cying', 'cyij', 'cyic', 'cyik', 'cyit', 'cyip', 'cyih', 'ci', 'cig', 'cigg', 'cigs', 'cin', 'cinj', 'cinh', 'cid', 'cil', 'cilg', 'cilm', 'cilb', 'cils', 'cilt', 'cilp', 'cilh', 'cim', 'cib', 'cibs', 'cis', 'ciss', 'cing', 'cij', 'cic', 'cik', 'cit', 'cip', 'cih', 'ka', 'kag', 'kagg', 'kags', 'kan', 'kanj', 'kanh', 'kad', 'kal', 'kalg', 'kalm', 'kalb', 'kals', 'kalt', 'kalp', 'kalh', 'kam', 'kab', 'kabs', 'kas', 'kass', 'kang', 'kaj', 'kac', 'kak', 'kat', 'kap', 'kah', 'kae', 'kaeg', 'kaegg', 'kaegs', 'kaen', 'kaenj', 'kaenh', 'kaed', 'kael', 'kaelg', 'kaelm', 'kaelb', 'kaels', 'kaelt', 'kaelp', 'kaelh', 'kaem', 'kaeb', 'kaebs', 'kaes', 'kaess', 'kaeng', 'kaej', 'kaec', 'kaek', 'kaet', 'kaep', 'kaeh', 'kya', 'kyag', 'kyagg', 'kyags', 'kyan', 'kyanj', 'kyanh', 'kyad', 'kyal', 'kyalg', 'kyalm', 'kyalb', 'kyals', 'kyalt', 'kyalp', 'kyalh', 'kyam', 'kyab', 'kyabs', 'kyas', 'kyass', 'kyang', 'kyaj', 'kyac', 'kyak', 'kyat', 'kyap', 'kyah', 'kyae', 'kyaeg', 'kyaegg', 'kyaegs', 'kyaen', 'kyaenj', 'kyaenh', 'kyaed', 'kyael', 'kyaelg', 'kyaelm', 'kyaelb', 'kyaels', 'kyaelt', 'kyaelp', 'kyaelh', 'kyaem', 'kyaeb', 'kyaebs', 'kyaes', 'kyaess', 'kyaeng', 'kyaej', 'kyaec', 'kyaek', 'kyaet', 'kyaep', 'kyaeh', 'keo', 'keog', 'keogg', 'keogs', 'keon', 'keonj', 'keonh', 'keod', 'keol', 'keolg', 'keolm', 'keolb', 'keols', 'keolt', 'keolp', 'keolh', 'keom', 'keob', 'keobs', 'keos', 'keoss', 'keong', 'keoj', 'keoc', 'keok', 'keot', 'keop', 'keoh']


Joomla CMS: Référence du fichier PowerOfTwo.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Math
  • BigInteger
  • Engines
  • PHP
  • Reductions
Structures de données | Espaces de nommage
Référence du fichier PowerOfTwo.php

Structures de données

class PowerOfTwo

Espaces de nommage

BigInteger
phpseclib3\Math\BigInteger\Engines\PHP\Reductions
PHP


Joomla CMS: Référence du fichier str_ireplace.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier str_ireplace.php

Espaces de nommage

utf8

Fonctions

utf8_ireplace ($search, $replace, $str, $count=NULL)

Documentation des fonctions

◆ utf8_ireplace()

utf8_ireplace | ( | $search,
 |  | $replace,
 |  | $str,
 |  | $count = NULL
 | ) |

Références $count, $i, et utf8_strtolower().

Référencé par StringHelper\str_ireplace().


Joomla CMS: Référence du fichier ProviderManager.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_media
  • src
  • Provider
Structures de données | Espaces de nommage
Référence du fichier ProviderManager.php

Structures de données

class ProviderManager

Espaces de nommage

Joomla\Administrator
Joomla\Component\Media\Administrator\Provider


Joomla CMS: Référence du fichier Token.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • api-authentication
  • token
  • src
  • Extension
Structures de données | Espaces de nommage
Référence du fichier plugins/api-authentication/token/src/Extension/Token.php

Structures de données

class Token

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\ApiAuthentication\Token\Extension


Joomla CMS: Référence du fichier Stream.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • spomky-labs
  • cbor-php
  • src
Structures de données | Espaces de nommage
Référence du fichier vendor/spomky-labs/cbor-php/src/Stream.php

Structures de données

interface Stream

Espaces de nommage

CBOR


Joomla CMS: Référence du fichier RegisteredClaims.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Structures de données | Espaces de nommage
Référence du fichier RegisteredClaims.php

Structures de données

interface RegisteredClaims

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier sect131r2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect131r2.php

Structures de données

class sect131r2

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier SuggestionsController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_finder
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier SuggestionsController.php

Structures de données

class SuggestionsController

Espaces de nommage

Joomla\Site
Joomla\Component\Finder\Site\Controller


Joomla CMS: Référence du fichier x0ad.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0ad.php

Variables

return ['gwan', 'gwanj', 'gwanh', 'gwad', 'gwal', 'gwalg', 'gwalm', 'gwalb', 'gwals', 'gwalt', 'gwalp', 'gwalh', 'gwam', 'gwab', 'gwabs', 'gwas', 'gwass', 'gwang', 'gwaj', 'gwac', 'gwak', 'gwat', 'gwap', 'gwah', 'gwae', 'gwaeg', 'gwaegg', 'gwaegs', 'gwaen', 'gwaenj', 'gwaenh', 'gwaed', 'gwael', 'gwaelg', 'gwaelm', 'gwaelb', 'gwaels', 'gwaelt', 'gwaelp', 'gwaelh', 'gwaem', 'gwaeb', 'gwaebs', 'gwaes', 'gwaess', 'gwaeng', 'gwaej', 'gwaec', 'gwaek', 'gwaet', 'gwaep', 'gwaeh', 'goe', 'goeg', 'goegg', 'goegs', 'goen', 'goenj', 'goenh', 'goed', 'goel', 'goelg', 'goelm', 'goelb', 'goels', 'goelt', 'goelp', 'goelh', 'goem', 'goeb', 'goebs', 'goes', 'goess', 'goeng', 'goej', 'goec', 'goek', 'goet', 'goep', 'goeh', 'gyo', 'gyog', 'gyogg', 'gyogs', 'gyon', 'gyonj', 'gyonh', 'gyod', 'gyol', 'gyolg', 'gyolm', 'gyolb', 'gyols', 'gyolt', 'gyolp', 'gyolh', 'gyom', 'gyob', 'gyobs', 'gyos', 'gyoss', 'gyong', 'gyoj', 'gyoc', 'gyok', 'gyot', 'gyop', 'gyoh', 'gu', 'gug', 'gugg', 'gugs', 'gun', 'gunj', 'gunh', 'gud', 'gul', 'gulg', 'gulm', 'gulb', 'guls', 'gult', 'gulp', 'gulh', 'gum', 'gub', 'gubs', 'gus', 'guss', 'gung', 'guj', 'guc', 'guk', 'gut', 'gup', 'guh', 'gweo', 'gweog', 'gweogg', 'gweogs', 'gweon', 'gweonj', 'gweonh', 'gweod', 'gweol', 'gweolg', 'gweolm', 'gweolb', 'gweols', 'gweolt', 'gweolp', 'gweolh', 'gweom', 'gweob', 'gweobs', 'gweos', 'gweoss', 'gweong', 'gweoj', 'gweoc', 'gweok', 'gweot', 'gweop', 'gweoh', 'gwe', 'gweg', 'gwegg', 'gwegs', 'gwen', 'gwenj', 'gwenh', 'gwed', 'gwel', 'gwelg', 'gwelm', 'gwelb', 'gwels', 'gwelt', 'gwelp', 'gwelh', 'gwem', 'gweb', 'gwebs', 'gwes', 'gwess', 'gweng', 'gwej', 'gwec', 'gwek', 'gwet', 'gwep', 'gweh', 'gwi', 'gwig', 'gwigg', 'gwigs', 'gwin', 'gwinj', 'gwinh', 'gwid', 'gwil', 'gwilg', 'gwilm', 'gwilb', 'gwils', 'gwilt', 'gwilp', 'gwilh', 'gwim', 'gwib', 'gwibs', 'gwis', 'gwiss', 'gwing', 'gwij', 'gwic', 'gwik', 'gwit', 'gwip', 'gwih', 'gyu', 'gyug', 'gyugg', 'gyugs', 'gyun', 'gyunj', 'gyunh', 'gyud', 'gyul', 'gyulg', 'gyulm', 'gyulb', 'gyuls', 'gyult', 'gyulp', 'gyulh', 'gyum', 'gyub', 'gyubs', 'gyus', 'gyuss', 'gyung', 'gyuj', 'gyuc', 'gyuk', 'gyut', 'gyup', 'gyuh', 'geu', 'geug', 'geugg', 'geugs', 'geun', 'geunj', 'geunh', 'geud']

Documentation des variables

◆ return

return[ 'gwan', 'gwanj', 'gwanh', 'gwad', 'gwal', 'gwalg', 'gwalm', 'gwalb', 'gwals', 'gwalt', 'gwalp', 'gwalh', 'gwam', 'gwab', 'gwabs', 'gwas', 'gwass', 'gwang', 'gwaj', 'gwac', 'gwak', 'gwat', 'gwap', 'gwah', 'gwae', 'gwaeg', 'gwaegg', 'gwaegs', 'gwaen', 'gwaenj', 'gwaenh', 'gwaed', 'gwael', 'gwaelg', 'gwaelm', 'gwaelb', 'gwaels', 'gwaelt', 'gwaelp', 'gwaelh', 'gwaem', 'gwaeb', 'gwaebs', 'gwaes', 'gwaess', 'gwaeng', 'gwaej', 'gwaec', 'gwaek', 'gwaet', 'gwaep', 'gwaeh', 'goe', 'goeg', 'goegg', 'goegs', 'goen', 'goenj', 'goenh', 'goed', 'goel', 'goelg', 'goelm', 'goelb', 'goels', 'goelt', 'goelp', 'goelh', 'goem', 'goeb', 'goebs', 'goes', 'goess', 'goeng', 'goej', 'goec', 'goek', 'goet', 'goep', 'goeh', 'gyo', 'gyog', 'gyogg', 'gyogs', 'gyon', 'gyonj', 'gyonh', 'gyod', 'gyol', 'gyolg', 'gyolm', 'gyolb', 'gyols', 'gyolt', 'gyolp', 'gyolh', 'gyom', 'gyob', 'gyobs', 'gyos', 'gyoss', 'gyong', 'gyoj', 'gyoc', 'gyok', 'gyot', 'gyop', 'gyoh', 'gu', 'gug', 'gugg', 'gugs', 'gun', 'gunj', 'gunh', 'gud', 'gul', 'gulg', 'gulm', 'gulb', 'guls', 'gult', 'gulp', 'gulh', 'gum', 'gub', 'gubs', 'gus', 'guss', 'gung', 'guj', 'guc', 'guk', 'gut', 'gup', 'guh', 'gweo', 'gweog', 'gweogg', 'gweogs', 'gweon', 'gweonj', 'gweonh', 'gweod', 'gweol', 'gweolg', 'gweolm', 'gweolb', 'gweols', 'gweolt', 'gweolp', 'gweolh', 'gweom', 'gweob', 'gweobs', 'gweos', 'gweoss', 'gweong', 'gweoj', 'gweoc', 'gweok', 'gweot', 'gweop', 'gweoh', 'gwe', 'gweg', 'gwegg', 'gwegs', 'gwen', 'gwenj', 'gwenh', 'gwed', 'gwel', 'gwelg', 'gwelm', 'gwelb', 'gwels', 'gwelt', 'gwelp', 'gwelh', 'gwem', 'gweb', 'gwebs', 'gwes', 'gwess', 'gweng', 'gwej', 'gwec', 'gwek', 'gwet', 'gwep', 'gweh', 'gwi', 'gwig', 'gwigg', 'gwigs', 'gwin', 'gwinj', 'gwinh', 'gwid', 'gwil', 'gwilg', 'gwilm', 'gwilb', 'gwils', 'gwilt', 'gwilp', 'gwilh', 'gwim', 'gwib', 'gwibs', 'gwis', 'gwiss', 'gwing', 'gwij', 'gwic', 'gwik', 'gwit', 'gwip', 'gwih', 'gyu', 'gyug', 'gyugg', 'gyugs', 'gyun', 'gyunj', 'gyunh', 'gyud', 'gyul', 'gyulg', 'gyulm', 'gyulb', 'gyuls', 'gyult', 'gyulp', 'gyulh', 'gyum', 'gyub', 'gyubs', 'gyus', 'gyuss', 'gyung', 'gyuj', 'gyuc', 'gyuk', 'gyut', 'gyup', 'gyuh', 'geu', 'geug', 'geugg', 'geugs', 'geun', 'geunj', 'geunh', 'geud']


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DSA
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DSA/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

DSA
phpseclib3\Crypt\DSA


Joomla CMS: Référence du fichier SortableList.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • HTML
  • Helpers
Structures de données | Espaces de nommage
Référence du fichier SortableList.php

Structures de données

class SortableList

Espaces de nommage

Joomla\CMS\HTML\Helpers


Joomla CMS: Référence du fichier Sha384.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Signer
  • Ecdsa
Structures de données | Espaces de nommage
Référence du fichier Ecdsa/Sha384.php

Structures de données

class Sha384

Espaces de nommage

Lcobucci\JWT\Signer\Ecdsa


Joomla CMS: Référence du fichier x059.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x059.php

Variables

return ['Shou ', 'Yi ', 'Zhi ', 'Gu ', 'Chu ', 'Jiang ', 'Feng ', 'Bei ', 'Cay ', 'Bian ', 'Sui ', 'Qun ', 'Ling ', 'Fu ', 'Zuo ', 'Xia ', 'Xiong ', '[?] ', 'Nao ', 'Xia ', 'Kui ', 'Xi ', 'Wai ', 'Yuan ', 'Mao ', 'Su ', 'Duo ', 'Duo ', 'Ye ', 'Qing ', 'Uys ', 'Gou ', 'Gou ', 'Qi ', 'Meng ', 'Meng ', 'Yin ', 'Huo ', 'Chen ', 'Da ', 'Ze ', 'Tian ', 'Tai ', 'Fu ', 'Guai ', 'Yao ', 'Yang ', 'Hang ', 'Gao ', 'Shi ', 'Ben ', 'Tai ', 'Tou ', 'Yan ', 'Bi ', 'Yi ', 'Kua ', 'Jia ', 'Duo ', 'Kwu ', 'Kuang ', 'Yun ', 'Jia ', 'Pa ', 'En ', 'Lian ', 'Huan ', 'Di ', 'Yan ', 'Pao ', 'Quan ', 'Qi ', 'Nai ', 'Feng ', 'Xie ', 'Fen ', 'Dian ', '[?] ', 'Kui ', 'Zou ', 'Huan ', 'Qi ', 'Kai ', 'Zha ', 'Ben ', 'Yi ', 'Jiang ', 'Tao ', 'Zang ', 'Ben ', 'Xi ', 'Xiang ', 'Fei ', 'Diao ', 'Xun ', 'Keng ', 'Dian ', 'Ao ', 'She ', 'Weng ', 'Pan ', 'Ao ', 'Wu ', 'Ao ', 'Jiang ', 'Lian ', 'Duo ', 'Yun ', 'Jiang ', 'Shi ', 'Fen ', 'Huo ', 'Bi ', 'Lian ', 'Duo ', 'Nu ', 'Nu ', 'Ding ', 'Nai ', 'Qian ', 'Jian ', 'Ta ', 'Jiu ', 'Nan ', 'Cha ', 'Hao ', 'Xian ', 'Fan ', 'Ji ', 'Shuo ', 'Ru ', 'Fei ', 'Wang ', 'Hong ', 'Zhuang ', 'Fu ', 'Ma ', 'Dan ', 'Ren ', 'Fu ', 'Jing ', 'Yan ', 'Xie ', 'Wen ', 'Zhong ', 'Pa ', 'Du ', 'Ji ', 'Keng ', 'Zhong ', 'Yao ', 'Jin ', 'Yun ', 'Miao ', 'Pei ', 'Shi ', 'Yue ', 'Zhuang ', 'Niu ', 'Yan ', 'Na ', 'Xin ', 'Fen ', 'Bi ', 'Yu ', 'Tuo ', 'Feng ', 'Yuan ', 'Fang ', 'Wu ', 'Yu ', 'Gui ', 'Du ', 'Ba ', 'Ni ', 'Zhou ', 'Zhuo ', 'Zhao ', 'Da ', 'Nai ', 'Yuan ', 'Tou ', 'Xuan ', 'Zhi ', 'E ', 'Mei ', 'Mo ', 'Qi ', 'Bi ', 'Shen ', 'Qie ', 'E ', 'He ', 'Xu ', 'Fa ', 'Zheng ', 'Min ', 'Ban ', 'Mu ', 'Fu ', 'Ling ', 'Zi ', 'Zi ', 'Shi ', 'Ran ', 'Shan ', 'Yang ', 'Man ', 'Jie ', 'Gu ', 'Si ', 'Xing ', 'Wei ', 'Zi ', 'Ju ', 'Shan ', 'Pin ', 'Ren ', 'Yao ', 'Tong ', 'Jiang ', 'Shu ', 'Ji ', 'Gai ', 'Shang ', 'Kuo ', 'Juan ', 'Jiao ', 'Gou ', 'Mu ', 'Jian ', 'Jian ', 'Yi ', 'Nian ', 'Zhi ', 'Ji ', 'Ji ', 'Xian ', 'Heng ', 'Guang ', 'Jun ', 'Kua ', 'Yan ', 'Ming ', 'Lie ', 'Pei ', 'Yan ', 'You ', 'Yan ', 'Cha ', 'Shen ', 'Yin ', 'Chi ', 'Gui ', 'Quan ', 'Zi ']

Documentation des variables

◆ return

return[ 'Shou ', 'Yi ', 'Zhi ', 'Gu ', 'Chu ', 'Jiang ', 'Feng ', 'Bei ', 'Cay ', 'Bian ', 'Sui ', 'Qun ', 'Ling ', 'Fu ', 'Zuo ', 'Xia ', 'Xiong ', '[?] ', 'Nao ', 'Xia ', 'Kui ', 'Xi ', 'Wai ', 'Yuan ', 'Mao ', 'Su ', 'Duo ', 'Duo ', 'Ye ', 'Qing ', 'Uys ', 'Gou ', 'Gou ', 'Qi ', 'Meng ', 'Meng ', 'Yin ', 'Huo ', 'Chen ', 'Da ', 'Ze ', 'Tian ', 'Tai ', 'Fu ', 'Guai ', 'Yao ', 'Yang ', 'Hang ', 'Gao ', 'Shi ', 'Ben ', 'Tai ', 'Tou ', 'Yan ', 'Bi ', 'Yi ', 'Kua ', 'Jia ', 'Duo ', 'Kwu ', 'Kuang ', 'Yun ', 'Jia ', 'Pa ', 'En ', 'Lian ', 'Huan ', 'Di ', 'Yan ', 'Pao ', 'Quan ', 'Qi ', 'Nai ', 'Feng ', 'Xie ', 'Fen ', 'Dian ', '[?] ', 'Kui ', 'Zou ', 'Huan ', 'Qi ', 'Kai ', 'Zha ', 'Ben ', 'Yi ', 'Jiang ', 'Tao ', 'Zang ', 'Ben ', 'Xi ', 'Xiang ', 'Fei ', 'Diao ', 'Xun ', 'Keng ', 'Dian ', 'Ao ', 'She ', 'Weng ', 'Pan ', 'Ao ', 'Wu ', 'Ao ', 'Jiang ', 'Lian ', 'Duo ', 'Yun ', 'Jiang ', 'Shi ', 'Fen ', 'Huo ', 'Bi ', 'Lian ', 'Duo ', 'Nu ', 'Nu ', 'Ding ', 'Nai ', 'Qian ', 'Jian ', 'Ta ', 'Jiu ', 'Nan ', 'Cha ', 'Hao ', 'Xian ', 'Fan ', 'Ji ', 'Shuo ', 'Ru ', 'Fei ', 'Wang ', 'Hong ', 'Zhuang ', 'Fu ', 'Ma ', 'Dan ', 'Ren ', 'Fu ', 'Jing ', 'Yan ', 'Xie ', 'Wen ', 'Zhong ', 'Pa ', 'Du ', 'Ji ', 'Keng ', 'Zhong ', 'Yao ', 'Jin ', 'Yun ', 'Miao ', 'Pei ', 'Shi ', 'Yue ', 'Zhuang ', 'Niu ', 'Yan ', 'Na ', 'Xin ', 'Fen ', 'Bi ', 'Yu ', 'Tuo ', 'Feng ', 'Yuan ', 'Fang ', 'Wu ', 'Yu ', 'Gui ', 'Du ', 'Ba ', 'Ni ', 'Zhou ', 'Zhuo ', 'Zhao ', 'Da ', 'Nai ', 'Yuan ', 'Tou ', 'Xuan ', 'Zhi ', 'E ', 'Mei ', 'Mo ', 'Qi ', 'Bi ', 'Shen ', 'Qie ', 'E ', 'He ', 'Xu ', 'Fa ', 'Zheng ', 'Min ', 'Ban ', 'Mu ', 'Fu ', 'Ling ', 'Zi ', 'Zi ', 'Shi ', 'Ran ', 'Shan ', 'Yang ', 'Man ', 'Jie ', 'Gu ', 'Si ', 'Xing ', 'Wei ', 'Zi ', 'Ju ', 'Shan ', 'Pin ', 'Ren ', 'Yao ', 'Tong ', 'Jiang ', 'Shu ', 'Ji ', 'Gai ', 'Shang ', 'Kuo ', 'Juan ', 'Jiao ', 'Gou ', 'Mu ', 'Jian ', 'Jian ', 'Yi ', 'Nian ', 'Zhi ', 'Ji ', 'Ji ', 'Xian ', 'Heng ', 'Guang ', 'Jun ', 'Kua ', 'Yan ', 'Ming ', 'Lie ', 'Pei ', 'Yan ', 'You ', 'Yan ', 'Cha ', 'Shen ', 'Yin ', 'Chi ', 'Gui ', 'Quan ', 'Zi ']


Joomla CMS: Référence du fichier PrivateKeyUsagePeriod.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • File
  • ASN1
  • Maps
Structures de données | Espaces de nommage
Référence du fichier PrivateKeyUsagePeriod.php

Structures de données

class PrivateKeyUsagePeriod

Espaces de nommage

ASN1
phpseclib3\File\ASN1\Maps


Joomla CMS: Référence du fichier text.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • text
  • tmpl
Espaces de nommage | Variables
Référence du fichier plugins/fields/text/tmpl/text.php

Espaces de nommage

Joomla\Plugin

Variables

$value = $field->value
if($value=='') if (is_array( $value))

Documentation des variables

◆ $value

$value = $field->value

◆ if

if ( $value=='') if(is_array($value))


Joomla CMS: Référence du fichier SiteRouter.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Router
Structures de données | Espaces de nommage
Référence du fichier SiteRouter.php

Structures de données

class SiteRouter

Espaces de nommage

Joomla\CMS\Router


Joomla CMS: Référence du fichier x0be.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0be.php

Variables

return ['byum', 'byub', 'byubs', 'byus', 'byuss', 'byung', 'byuj', 'byuc', 'byuk', 'byut', 'byup', 'byuh', 'beu', 'beug', 'beugg', 'beugs', 'beun', 'beunj', 'beunh', 'beud', 'beul', 'beulg', 'beulm', 'beulb', 'beuls', 'beult', 'beulp', 'beulh', 'beum', 'beub', 'beubs', 'beus', 'beuss', 'beung', 'beuj', 'beuc', 'beuk', 'beut', 'beup', 'beuh', 'byi', 'byig', 'byigg', 'byigs', 'byin', 'byinj', 'byinh', 'byid', 'byil', 'byilg', 'byilm', 'byilb', 'byils', 'byilt', 'byilp', 'byilh', 'byim', 'byib', 'byibs', 'byis', 'byiss', 'bying', 'byij', 'byic', 'byik', 'byit', 'byip', 'byih', 'bi', 'big', 'bigg', 'bigs', 'bin', 'binj', 'binh', 'bid', 'bil', 'bilg', 'bilm', 'bilb', 'bils', 'bilt', 'bilp', 'bilh', 'bim', 'bib', 'bibs', 'bis', 'biss', 'bing', 'bij', 'bic', 'bik', 'bit', 'bip', 'bih', 'bba', 'bbag', 'bbagg', 'bbags', 'bban', 'bbanj', 'bbanh', 'bbad', 'bbal', 'bbalg', 'bbalm', 'bbalb', 'bbals', 'bbalt', 'bbalp', 'bbalh', 'bbam', 'bbab', 'bbabs', 'bbas', 'bbass', 'bbang', 'bbaj', 'bbac', 'bbak', 'bbat', 'bbap', 'bbah', 'bbae', 'bbaeg', 'bbaegg', 'bbaegs', 'bbaen', 'bbaenj', 'bbaenh', 'bbaed', 'bbael', 'bbaelg', 'bbaelm', 'bbaelb', 'bbaels', 'bbaelt', 'bbaelp', 'bbaelh', 'bbaem', 'bbaeb', 'bbaebs', 'bbaes', 'bbaess', 'bbaeng', 'bbaej', 'bbaec', 'bbaek', 'bbaet', 'bbaep', 'bbaeh', 'bbya', 'bbyag', 'bbyagg', 'bbyags', 'bbyan', 'bbyanj', 'bbyanh', 'bbyad', 'bbyal', 'bbyalg', 'bbyalm', 'bbyalb', 'bbyals', 'bbyalt', 'bbyalp', 'bbyalh', 'bbyam', 'bbyab', 'bbyabs', 'bbyas', 'bbyass', 'bbyang', 'bbyaj', 'bbyac', 'bbyak', 'bbyat', 'bbyap', 'bbyah', 'bbyae', 'bbyaeg', 'bbyaegg', 'bbyaegs', 'bbyaen', 'bbyaenj', 'bbyaenh', 'bbyaed', 'bbyael', 'bbyaelg', 'bbyaelm', 'bbyaelb', 'bbyaels', 'bbyaelt', 'bbyaelp', 'bbyaelh', 'bbyaem', 'bbyaeb', 'bbyaebs', 'bbyaes', 'bbyaess', 'bbyaeng', 'bbyaej', 'bbyaec', 'bbyaek', 'bbyaet', 'bbyaep', 'bbyaeh', 'bbeo', 'bbeog', 'bbeogg', 'bbeogs', 'bbeon', 'bbeonj', 'bbeonh', 'bbeod', 'bbeol', 'bbeolg', 'bbeolm', 'bbeolb', 'bbeols', 'bbeolt', 'bbeolp', 'bbeolh', 'bbeom', 'bbeob', 'bbeobs', 'bbeos', 'bbeoss', 'bbeong', 'bbeoj', 'bbeoc', 'bbeok', 'bbeot', 'bbeop', 'bbeoh', 'bbe', 'bbeg', 'bbegg', 'bbegs', 'bben', 'bbenj', 'bbenh', 'bbed', 'bbel', 'bbelg', 'bbelm', 'bbelb', 'bbels', 'bbelt', 'bbelp', 'bbelh', 'bbem', 'bbeb', 'bbebs', 'bbes']

Documentation des variables

◆ return

return[ 'byum', 'byub', 'byubs', 'byus', 'byuss', 'byung', 'byuj', 'byuc', 'byuk', 'byut', 'byup', 'byuh', 'beu', 'beug', 'beugg', 'beugs', 'beun', 'beunj', 'beunh', 'beud', 'beul', 'beulg', 'beulm', 'beulb', 'beuls', 'beult', 'beulp', 'beulh', 'beum', 'beub', 'beubs', 'beus', 'beuss', 'beung', 'beuj', 'beuc', 'beuk', 'beut', 'beup', 'beuh', 'byi', 'byig', 'byigg', 'byigs', 'byin', 'byinj', 'byinh', 'byid', 'byil', 'byilg', 'byilm', 'byilb', 'byils', 'byilt', 'byilp', 'byilh', 'byim', 'byib', 'byibs', 'byis', 'byiss', 'bying', 'byij', 'byic', 'byik', 'byit', 'byip', 'byih', 'bi', 'big', 'bigg', 'bigs', 'bin', 'binj', 'binh', 'bid', 'bil', 'bilg', 'bilm', 'bilb', 'bils', 'bilt', 'bilp', 'bilh', 'bim', 'bib', 'bibs', 'bis', 'biss', 'bing', 'bij', 'bic', 'bik', 'bit', 'bip', 'bih', 'bba', 'bbag', 'bbagg', 'bbags', 'bban', 'bbanj', 'bbanh', 'bbad', 'bbal', 'bbalg', 'bbalm', 'bbalb', 'bbals', 'bbalt', 'bbalp', 'bbalh', 'bbam', 'bbab', 'bbabs', 'bbas', 'bbass', 'bbang', 'bbaj', 'bbac', 'bbak', 'bbat', 'bbap', 'bbah', 'bbae', 'bbaeg', 'bbaegg', 'bbaegs', 'bbaen', 'bbaenj', 'bbaenh', 'bbaed', 'bbael', 'bbaelg', 'bbaelm', 'bbaelb', 'bbaels', 'bbaelt', 'bbaelp', 'bbaelh', 'bbaem', 'bbaeb', 'bbaebs', 'bbaes', 'bbaess', 'bbaeng', 'bbaej', 'bbaec', 'bbaek', 'bbaet', 'bbaep', 'bbaeh', 'bbya', 'bbyag', 'bbyagg', 'bbyags', 'bbyan', 'bbyanj', 'bbyanh', 'bbyad', 'bbyal', 'bbyalg', 'bbyalm', 'bbyalb', 'bbyals', 'bbyalt', 'bbyalp', 'bbyalh', 'bbyam', 'bbyab', 'bbyabs', 'bbyas', 'bbyass', 'bbyang', 'bbyaj', 'bbyac', 'bbyak', 'bbyat', 'bbyap', 'bbyah', 'bbyae', 'bbyaeg', 'bbyaegg', 'bbyaegs', 'bbyaen', 'bbyaenj', 'bbyaenh', 'bbyaed', 'bbyael', 'bbyaelg', 'bbyaelm', 'bbyaelb', 'bbyaels', 'bbyaelt', 'bbyaelp', 'bbyaelh', 'bbyaem', 'bbyaeb', 'bbyaebs', 'bbyaes', 'bbyaess', 'bbyaeng', 'bbyaej', 'bbyaec', 'bbyaek', 'bbyaet', 'bbyaep', 'bbyaeh', 'bbeo', 'bbeog', 'bbeogg', 'bbeogs', 'bbeon', 'bbeonj', 'bbeonh', 'bbeod', 'bbeol', 'bbeolg', 'bbeolm', 'bbeolb', 'bbeols', 'bbeolt', 'bbeolp', 'bbeolh', 'bbeom', 'bbeob', 'bbeobs', 'bbeos', 'bbeoss', 'bbeong', 'bbeoj', 'bbeoc', 'bbeok', 'bbeot', 'bbeop', 'bbeoh', 'bbe', 'bbeg', 'bbegg', 'bbegs', 'bben', 'bbenj', 'bbenh', 'bbed', 'bbel', 'bbelg', 'bbelm', 'bbelb', 'bbels', 'bbelt', 'bbelp', 'bbelh', 'bbem', 'bbeb', 'bbebs', 'bbes']


Joomla CMS: Référence du fichier WorkflowController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_workflow
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier WorkflowController.php

Structures de données

class WorkflowController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Workflow\Administrator\Controller


Joomla CMS: Référence du fichier PasswordHash.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • phpass
Structures de données
Référence du fichier PasswordHash.php

Structures de données

class PasswordHash


Joomla CMS: Référence du fichier toc.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • content
  • pagebreak
  • tmpl
Espaces de nommage | Variables
Référence du fichier toc.php

Espaces de nommage

Joomla\Plugin

Variables

if($headingtext) endif
foreach ( $list as $listItem)
endforeach

Documentation des variables

◆ endforeach

endforeach

◆ endif

if ( $headingtext) endif

◆ foreach

foreach($list as $listItem)


Joomla CMS: Référence du fichier StyleController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier StyleController.php

Structures de données

class StyleController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Controller


Joomla CMS: Référence du fichier tag.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • html
  • batch
Espaces de nommage
Référence du fichier html/batch/tag.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier Server.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • multifactorauth
  • webauthn
  • src
  • Hotfix
Structures de données | Espaces de nommage
Référence du fichier plugins/multifactorauth/webauthn/src/Hotfix/Server.php

Structures de données

class Server

Espaces de nommage

Joomla\Plugin
Joomla\Plugin\Multifactorauth\Webauthn\Hotfix


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • modules
  • mod_articles_latest
  • services
Structures de données | Espaces de nommage
Référence du fichier modules/mod_articles_latest/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Administrator


Joomla CMS: Référence du fichier ResetModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_users
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier ResetModel.php

Structures de données

class ResetModel

Espaces de nommage

Joomla\Site
Joomla\Component\Users\Site\Model


Joomla CMS: Référence du fichier sql.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • fields
  • sql
Structures de données | Espaces de nommage
Référence du fichier sql.php

Structures de données

class PlgFieldsSql

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x0b2.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b2.php

Variables

return ['nyok', 'nyot', 'nyop', 'nyoh', 'nu', 'nug', 'nugg', 'nugs', 'nun', 'nunj', 'nunh', 'nud', 'nul', 'nulg', 'nulm', 'nulb', 'nuls', 'nult', 'nulp', 'nulh', 'num', 'nub', 'nubs', 'nus', 'nuss', 'nung', 'nuj', 'nuc', 'nuk', 'nut', 'nup', 'nuh', 'nweo', 'nweog', 'nweogg', 'nweogs', 'nweon', 'nweonj', 'nweonh', 'nweod', 'nweol', 'nweolg', 'nweolm', 'nweolb', 'nweols', 'nweolt', 'nweolp', 'nweolh', 'nweom', 'nweob', 'nweobs', 'nweos', 'nweoss', 'nweong', 'nweoj', 'nweoc', 'nweok', 'nweot', 'nweop', 'nweoh', 'nwe', 'nweg', 'nwegg', 'nwegs', 'nwen', 'nwenj', 'nwenh', 'nwed', 'nwel', 'nwelg', 'nwelm', 'nwelb', 'nwels', 'nwelt', 'nwelp', 'nwelh', 'nwem', 'nweb', 'nwebs', 'nwes', 'nwess', 'nweng', 'nwej', 'nwec', 'nwek', 'nwet', 'nwep', 'nweh', 'nwi', 'nwig', 'nwigg', 'nwigs', 'nwin', 'nwinj', 'nwinh', 'nwid', 'nwil', 'nwilg', 'nwilm', 'nwilb', 'nwils', 'nwilt', 'nwilp', 'nwilh', 'nwim', 'nwib', 'nwibs', 'nwis', 'nwiss', 'nwing', 'nwij', 'nwic', 'nwik', 'nwit', 'nwip', 'nwih', 'nyu', 'nyug', 'nyugg', 'nyugs', 'nyun', 'nyunj', 'nyunh', 'nyud', 'nyul', 'nyulg', 'nyulm', 'nyulb', 'nyuls', 'nyult', 'nyulp', 'nyulh', 'nyum', 'nyub', 'nyubs', 'nyus', 'nyuss', 'nyung', 'nyuj', 'nyuc', 'nyuk', 'nyut', 'nyup', 'nyuh', 'neu', 'neug', 'neugg', 'neugs', 'neun', 'neunj', 'neunh', 'neud', 'neul', 'neulg', 'neulm', 'neulb', 'neuls', 'neult', 'neulp', 'neulh', 'neum', 'neub', 'neubs', 'neus', 'neuss', 'neung', 'neuj', 'neuc', 'neuk', 'neut', 'neup', 'neuh', 'nyi', 'nyig', 'nyigg', 'nyigs', 'nyin', 'nyinj', 'nyinh', 'nyid', 'nyil', 'nyilg', 'nyilm', 'nyilb', 'nyils', 'nyilt', 'nyilp', 'nyilh', 'nyim', 'nyib', 'nyibs', 'nyis', 'nyiss', 'nying', 'nyij', 'nyic', 'nyik', 'nyit', 'nyip', 'nyih', 'ni', 'nig', 'nigg', 'nigs', 'nin', 'ninj', 'ninh', 'nid', 'nil', 'nilg', 'nilm', 'nilb', 'nils', 'nilt', 'nilp', 'nilh', 'nim', 'nib', 'nibs', 'nis', 'niss', 'ning', 'nij', 'nic', 'nik', 'nit', 'nip', 'nih', 'da', 'dag', 'dagg', 'dags', 'dan', 'danj', 'danh', 'dad', 'dal', 'dalg', 'dalm', 'dalb', 'dals', 'dalt', 'dalp', 'dalh', 'dam', 'dab', 'dabs', 'das', 'dass', 'dang', 'daj', 'dac', 'dak', 'dat', 'dap', 'dah']

Documentation des variables

◆ return

return[ 'nyok', 'nyot', 'nyop', 'nyoh', 'nu', 'nug', 'nugg', 'nugs', 'nun', 'nunj', 'nunh', 'nud', 'nul', 'nulg', 'nulm', 'nulb', 'nuls', 'nult', 'nulp', 'nulh', 'num', 'nub', 'nubs', 'nus', 'nuss', 'nung', 'nuj', 'nuc', 'nuk', 'nut', 'nup', 'nuh', 'nweo', 'nweog', 'nweogg', 'nweogs', 'nweon', 'nweonj', 'nweonh', 'nweod', 'nweol', 'nweolg', 'nweolm', 'nweolb', 'nweols', 'nweolt', 'nweolp', 'nweolh', 'nweom', 'nweob', 'nweobs', 'nweos', 'nweoss', 'nweong', 'nweoj', 'nweoc', 'nweok', 'nweot', 'nweop', 'nweoh', 'nwe', 'nweg', 'nwegg', 'nwegs', 'nwen', 'nwenj', 'nwenh', 'nwed', 'nwel', 'nwelg', 'nwelm', 'nwelb', 'nwels', 'nwelt', 'nwelp', 'nwelh', 'nwem', 'nweb', 'nwebs', 'nwes', 'nwess', 'nweng', 'nwej', 'nwec', 'nwek', 'nwet', 'nwep', 'nweh', 'nwi', 'nwig', 'nwigg', 'nwigs', 'nwin', 'nwinj', 'nwinh', 'nwid', 'nwil', 'nwilg', 'nwilm', 'nwilb', 'nwils', 'nwilt', 'nwilp', 'nwilh', 'nwim', 'nwib', 'nwibs', 'nwis', 'nwiss', 'nwing', 'nwij', 'nwic', 'nwik', 'nwit', 'nwip', 'nwih', 'nyu', 'nyug', 'nyugg', 'nyugs', 'nyun', 'nyunj', 'nyunh', 'nyud', 'nyul', 'nyulg', 'nyulm', 'nyulb', 'nyuls', 'nyult', 'nyulp', 'nyulh', 'nyum', 'nyub', 'nyubs', 'nyus', 'nyuss', 'nyung', 'nyuj', 'nyuc', 'nyuk', 'nyut', 'nyup', 'nyuh', 'neu', 'neug', 'neugg', 'neugs', 'neun', 'neunj', 'neunh', 'neud', 'neul', 'neulg', 'neulm', 'neulb', 'neuls', 'neult', 'neulp', 'neulh', 'neum', 'neub', 'neubs', 'neus', 'neuss', 'neung', 'neuj', 'neuc', 'neuk', 'neut', 'neup', 'neuh', 'nyi', 'nyig', 'nyigg', 'nyigs', 'nyin', 'nyinj', 'nyinh', 'nyid', 'nyil', 'nyilg', 'nyilm', 'nyilb', 'nyils', 'nyilt', 'nyilp', 'nyilh', 'nyim', 'nyib', 'nyibs', 'nyis', 'nyiss', 'nying', 'nyij', 'nyic', 'nyik', 'nyit', 'nyip', 'nyih', 'ni', 'nig', 'nigg', 'nigs', 'nin', 'ninj', 'ninh', 'nid', 'nil', 'nilg', 'nilm', 'nilb', 'nils', 'nilt', 'nilp', 'nilh', 'nim', 'nib', 'nibs', 'nis', 'niss', 'ning', 'nij', 'nic', 'nik', 'nit', 'nip', 'nih', 'da', 'dag', 'dagg', 'dags', 'dan', 'danj', 'danh', 'dad', 'dal', 'dalg', 'dalm', 'dalb', 'dals', 'dalt', 'dalp', 'dalh', 'dam', 'dab', 'dabs', 'das', 'dass', 'dang', 'daj', 'dac', 'dak', 'dat', 'dap', 'dah']


Joomla CMS: Référence du fichier StylesController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/Controller/StylesController.php

Structures de données

class StylesController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Controller


Joomla CMS: Référence du fichier strrev.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • joomla
  • string
  • src
  • phputf8
Espaces de nommage | Fonctions
Référence du fichier strrev.php

Espaces de nommage

utf8

Fonctions

utf8_strrev ($str)

Documentation des fonctions

◆ utf8_strrev()

utf8_strrev ( $str )

Référencé par StringHelper\strrev().


Joomla CMS: Référence du fichier users.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • webservices
  • users
Structures de données | Espaces de nommage
Référence du fichier plugins/webservices/users/users.php

Structures de données

class PlgWebservicesUsers

Espaces de nommage

Joomla\Users


Joomla CMS: Référence du fichier starttabset.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • libraries
  • html
  • bootstrap
  • tab
Espaces de nommage | Variables
Référence du fichier starttabset.php

Espaces de nommage

Joomla\Site

Variables

$selector = empty($displayData['selector']) ? '' : $displayData['selector']

Documentation des variables

◆ $selector

$selector = empty($displayData['selector']) ? '' : $displayData['selector']

Référencé par Bootstrap\addSlide(), UiTab\addTab(), Bootstrap\addTab(), FormBehavior\ajaxchosen(), Tag\ajaxfield(), Bootstrap\alert(), Bootstrap\button(), Bootstrap\carousel(), Bootstrap\collapse(), Bootstrap\dropdown(), SearchTools\form(), Bootstrap\modal(), Bootstrap\offcanvas(), Bootstrap\popover(), PopupButton\renderButton(), Bootstrap\renderModal(), Bootstrap\scrollspy(), Bootstrap\startAccordion(), UiTab\startTabSet(), Bootstrap\startTabSet(), Bootstrap\tab(), Bootstrap\toast(), et Bootstrap\tooltip().


Joomla CMS: Référence du fichier sect233r1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • EC
  • Curves
Structures de données | Espaces de nommage
Référence du fichier sect233r1.php

Structures de données

class sect233r1

Espaces de nommage

EC
phpseclib3\Crypt\EC\Curves


Joomla CMS: Référence du fichier User.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • User
Structures de données | Espaces de nommage
Référence du fichier User/User.php

Structures de données

class User

Espaces de nommage

Joomla\CMS\User


Joomla CMS: Référence du fichier text.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • form
  • field
Espaces de nommage | Variables
Référence du fichier layouts/joomla/form/field/text.php

Espaces de nommage

Joomla\Site

Variables

$list = ''
if($options) | $attributes
$addonBeforeHtml = '<span class="input-group-text">' . Text::_($addonBefore) . '</span>'
$addonAfterHtml = '<span class="input-group-text">' . Text::_($addonAfter) . '</span>'
if(!empty($addonBefore)||!empty($addonAfter)) if(!empty($addonBefore)) | endif
endforeach

Documentation des variables

◆ $addonAfterHtml

$addonAfterHtml = '<span class="input-group-text">' . Text::_($addonAfter) . '</span>'

◆ $addonBeforeHtml

$addonBeforeHtml = '<span class="input-group-text">' . Text::_($addonBefore) . '</span>'

◆ $attributes

if ( $options) $attributes
Valeur initiale :
= array(
!empty($class) ? 'class="form-control ' . $class . '"' : 'class="form-control"',
!empty($size) ? 'size="' . $size . '"' : '',
!empty($description) ? 'aria-describedby="' . ($id ?: $name) . '-desc"' : '',
$disabled ? 'disabled' : '',
$readonly ? 'readonly' : '',
$dataAttribute,
$list,
strlen($hint) ? 'placeholder="' . htmlspecialchars($hint, ENT_COMPAT, 'UTF-8') . '"' : '',
$onchange ? ' onchange="' . $onchange . '"' : '',
!empty($maxLength) ? $maxLength : '',
$required ? 'required' : '',
!empty($autocomplete) ? 'autocomplete="' . $autocomplete . '"' : '',
$autofocus ? ' autofocus' : '',
$spellcheck ? '' : 'spellcheck="false"',
!empty($inputmode) ? $inputmode : '',
!empty($pattern) ? 'pattern="' . $pattern . '"' : '',
!empty($validationtext) ? 'data-validation-text="' . $validationtext . '"' : '',
)
$dataAttribute
$dataAttribute
Definition: advanced.php:80
$required
$required
Definition: checkbox.php:53
$id
$id
Definition: com_modules/tmpl/module/edit_assignment.php:93
$disabled
$disabled
Definition: action-button.php:29
$hint
$hint
Definition: advanced.php:68
$onchange
$onchange
Definition: checkbox.php:59
$size
$size
Definition: slider.php:67
$name
$name
Definition: administrator/components/com_modules/tmpl/select/default.php:64
$autocomplete
$autocomplete
Definition: advanced.php:70
strlen
$description
$description
Definition: administrator/components/com_templates/tmpl/style/edit.php:52
ENT_COMPAT
else ENT_COMPAT
Definition: components/com_newsfeeds/tmpl/category/default_items.php:28
$readonly
empty($onchange) ? null if($required) if(strtoupper($value)==='NOW') $readonly
Definition: layouts/joomla/form/field/calendar.php:93
$list
$list
Definition: layouts/joomla/form/field/text.php:55
$autofocus
$autofocus
Definition: checkbox.php:54
$class
$class
Definition: administrator/modules/mod_menu/tmpl/default.php:17

◆ $list

$list = ''

◆ endforeach

endforeach

◆ endif

endif


Joomla CMS: Référence du fichier provider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • plugins
  • behaviour
  • taggable
  • services
Structures de données | Espaces de nommage
Référence du fichier plugins/behaviour/taggable/services/provider.php

Structures de données

class ServiceProviderInterface

Espaces de nommage

Joomla\Plugin


Joomla CMS: Référence du fichier x05a.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x05a.php

Variables

return ['Song ', 'Wei ', 'Hong ', 'Wa ', 'Lou ', 'Ya ', 'Rao ', 'Jiao ', 'Luan ', 'Ping ', 'Xian ', 'Shao ', 'Li ', 'Cheng ', 'Xiao ', 'Mang ', 'Fu ', 'Suo ', 'Wu ', 'Wei ', 'Ke ', 'Lai ', 'Chuo ', 'Ding ', 'Niang ', 'Xing ', 'Nan ', 'Yu ', 'Nuo ', 'Pei ', 'Nei ', 'Juan ', 'Shen ', 'Zhi ', 'Han ', 'Di ', 'Zhuang ', 'E ', 'Pin ', 'Tui ', 'Han ', 'Mian ', 'Wu ', 'Yan ', 'Wu ', 'Xi ', 'Yan ', 'Yu ', 'Si ', 'Yu ', 'Wa ', '[?] ', 'Xian ', 'Ju ', 'Qu ', 'Shui ', 'Qi ', 'Xian ', 'Zhui ', 'Dong ', 'Chang ', 'Lu ', 'Ai ', 'E ', 'E ', 'Lou ', 'Mian ', 'Cong ', 'Pou ', 'Ju ', 'Po ', 'Cai ', 'Ding ', 'Wan ', 'Biao ', 'Xiao ', 'Shu ', 'Qi ', 'Hui ', 'Fu ', 'E ', 'Wo ', 'Tan ', 'Fei ', 'Wei ', 'Jie ', 'Tian ', 'Ni ', 'Quan ', 'Jing ', 'Hun ', 'Jing ', 'Qian ', 'Dian ', 'Xing ', 'Hu ', 'Wa ', 'Lai ', 'Bi ', 'Yin ', 'Chou ', 'Chuo ', 'Fu ', 'Jing ', 'Lun ', 'Yan ', 'Lan ', 'Kun ', 'Yin ', 'Ya ', 'Ju ', 'Li ', 'Dian ', 'Xian ', 'Hwa ', 'Hua ', 'Ying ', 'Chan ', 'Shen ', 'Ting ', 'Dang ', 'Yao ', 'Wu ', 'Nan ', 'Ruo ', 'Jia ', 'Tou ', 'Xu ', 'Yu ', 'Wei ', 'Ti ', 'Rou ', 'Mei ', 'Dan ', 'Ruan ', 'Qin ', 'Hui ', 'Wu ', 'Qian ', 'Chun ', 'Mao ', 'Fu ', 'Jie ', 'Duan ', 'Xi ', 'Zhong ', 'Mei ', 'Huang ', 'Mian ', 'An ', 'Ying ', 'Xuan ', 'Jie ', 'Wei ', 'Mei ', 'Yuan ', 'Zhen ', 'Qiu ', 'Ti ', 'Xie ', 'Tuo ', 'Lian ', 'Mao ', 'Ran ', 'Si ', 'Pian ', 'Wei ', 'Wa ', 'Jiu ', 'Hu ', 'Ao ', '[?] ', 'Bou ', 'Xu ', 'Tou ', 'Gui ', 'Zou ', 'Yao ', 'Pi ', 'Xi ', 'Yuan ', 'Ying ', 'Rong ', 'Ru ', 'Chi ', 'Liu ', 'Mei ', 'Pan ', 'Ao ', 'Ma ', 'Gou ', 'Kui ', 'Qin ', 'Jia ', 'Sao ', 'Zhen ', 'Yuan ', 'Cha ', 'Yong ', 'Ming ', 'Ying ', 'Ji ', 'Su ', 'Niao ', 'Xian ', 'Tao ', 'Pang ', 'Lang ', 'Nao ', 'Bao ', 'Ai ', 'Pi ', 'Pin ', 'Yi ', 'Piao ', 'Yu ', 'Lei ', 'Xuan ', 'Man ', 'Yi ', 'Zhang ', 'Kang ', 'Yong ', 'Ni ', 'Li ', 'Di ', 'Gui ', 'Yan ', 'Jin ', 'Zhuan ', 'Chang ', 'Ce ', 'Han ', 'Nen ', 'Lao ', 'Mo ', 'Zhe ', 'Hu ', 'Hu ', 'Ao ', 'Nen ', 'Qiang ', 'Ma ', 'Pie ', 'Gu ', 'Wu ', 'Jiao ', 'Tuo ', 'Zhan ', 'Mao ', 'Xian ', 'Xian ', 'Mo ', 'Liao ', 'Lian ', 'Hua ']

Documentation des variables

◆ return

return[ 'Song ', 'Wei ', 'Hong ', 'Wa ', 'Lou ', 'Ya ', 'Rao ', 'Jiao ', 'Luan ', 'Ping ', 'Xian ', 'Shao ', 'Li ', 'Cheng ', 'Xiao ', 'Mang ', 'Fu ', 'Suo ', 'Wu ', 'Wei ', 'Ke ', 'Lai ', 'Chuo ', 'Ding ', 'Niang ', 'Xing ', 'Nan ', 'Yu ', 'Nuo ', 'Pei ', 'Nei ', 'Juan ', 'Shen ', 'Zhi ', 'Han ', 'Di ', 'Zhuang ', 'E ', 'Pin ', 'Tui ', 'Han ', 'Mian ', 'Wu ', 'Yan ', 'Wu ', 'Xi ', 'Yan ', 'Yu ', 'Si ', 'Yu ', 'Wa ', '[?] ', 'Xian ', 'Ju ', 'Qu ', 'Shui ', 'Qi ', 'Xian ', 'Zhui ', 'Dong ', 'Chang ', 'Lu ', 'Ai ', 'E ', 'E ', 'Lou ', 'Mian ', 'Cong ', 'Pou ', 'Ju ', 'Po ', 'Cai ', 'Ding ', 'Wan ', 'Biao ', 'Xiao ', 'Shu ', 'Qi ', 'Hui ', 'Fu ', 'E ', 'Wo ', 'Tan ', 'Fei ', 'Wei ', 'Jie ', 'Tian ', 'Ni ', 'Quan ', 'Jing ', 'Hun ', 'Jing ', 'Qian ', 'Dian ', 'Xing ', 'Hu ', 'Wa ', 'Lai ', 'Bi ', 'Yin ', 'Chou ', 'Chuo ', 'Fu ', 'Jing ', 'Lun ', 'Yan ', 'Lan ', 'Kun ', 'Yin ', 'Ya ', 'Ju ', 'Li ', 'Dian ', 'Xian ', 'Hwa ', 'Hua ', 'Ying ', 'Chan ', 'Shen ', 'Ting ', 'Dang ', 'Yao ', 'Wu ', 'Nan ', 'Ruo ', 'Jia ', 'Tou ', 'Xu ', 'Yu ', 'Wei ', 'Ti ', 'Rou ', 'Mei ', 'Dan ', 'Ruan ', 'Qin ', 'Hui ', 'Wu ', 'Qian ', 'Chun ', 'Mao ', 'Fu ', 'Jie ', 'Duan ', 'Xi ', 'Zhong ', 'Mei ', 'Huang ', 'Mian ', 'An ', 'Ying ', 'Xuan ', 'Jie ', 'Wei ', 'Mei ', 'Yuan ', 'Zhen ', 'Qiu ', 'Ti ', 'Xie ', 'Tuo ', 'Lian ', 'Mao ', 'Ran ', 'Si ', 'Pian ', 'Wei ', 'Wa ', 'Jiu ', 'Hu ', 'Ao ', '[?] ', 'Bou ', 'Xu ', 'Tou ', 'Gui ', 'Zou ', 'Yao ', 'Pi ', 'Xi ', 'Yuan ', 'Ying ', 'Rong ', 'Ru ', 'Chi ', 'Liu ', 'Mei ', 'Pan ', 'Ao ', 'Ma ', 'Gou ', 'Kui ', 'Qin ', 'Jia ', 'Sao ', 'Zhen ', 'Yuan ', 'Cha ', 'Yong ', 'Ming ', 'Ying ', 'Ji ', 'Su ', 'Niao ', 'Xian ', 'Tao ', 'Pang ', 'Lang ', 'Nao ', 'Bao ', 'Ai ', 'Pi ', 'Pin ', 'Yi ', 'Piao ', 'Yu ', 'Lei ', 'Xuan ', 'Man ', 'Yi ', 'Zhang ', 'Kang ', 'Yong ', 'Ni ', 'Li ', 'Di ', 'Gui ', 'Yan ', 'Jin ', 'Zhuan ', 'Chang ', 'Ce ', 'Han ', 'Nen ', 'Lao ', 'Mo ', 'Zhe ', 'Hu ', 'Hu ', 'Ao ', 'Nen ', 'Qiang ', 'Ma ', 'Pie ', 'Gu ', 'Wu ', 'Jiao ', 'Tuo ', 'Zhan ', 'Mao ', 'Xian ', 'Xian ', 'Mo ', 'Liao ', 'Lian ', 'Hua ']


Joomla CMS: Référence du fichier StreamCipher.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
Structures de données | Espaces de nommage
Référence du fichier StreamCipher.php

Structures de données

class StreamCipher

Espaces de nommage

StreamCipher
phpseclib3\Crypt\Common


Joomla CMS: Référence du fichier Parameters.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • DH
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/DH/Parameters.php

Structures de données

class Parameters

Espaces de nommage

DH
phpseclib3\Crypt\DH


Joomla CMS: Référence du fichier UpdatesiteController.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_installer
  • src
  • Controller
Structures de données | Espaces de nommage
Référence du fichier UpdatesiteController.php

Structures de données

class UpdatesiteController

Espaces de nommage

Joomla\Administrator
Joomla\Component\Installer\Administrator\Controller


Joomla CMS: Référence du fichier RequestModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_privacy
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier components/com_privacy/src/Model/RequestModel.php

Structures de données

class RequestModel

Espaces de nommage

Joomla\Site
Joomla\Component\Privacy\Site\Model


Joomla CMS: Référence du fichier PKCS1.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • Common
  • Formats
  • Keys
Structures de données | Espaces de nommage
Référence du fichier Common/Formats/Keys/PKCS1.php

Structures de données

class PKCS1

Espaces de nommage

Common
phpseclib3\Crypt\Common\Formats\Keys
RSA


Joomla CMS: Référence du fichier PublicKey.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • phpseclib
  • phpseclib
  • phpseclib
  • Crypt
  • RSA
Structures de données | Espaces de nommage
Référence du fichier phpseclib/phpseclib/phpseclib/Crypt/RSA/PublicKey.php

Structures de données

class PublicKey

Espaces de nommage

RSA
phpseclib3\Crypt\RSA


Joomla CMS: Référence du fichier Randval.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Encrypt
Structures de données | Espaces de nommage
Référence du fichier Randval.php

Structures de données

class Randval

Espaces de nommage

Joomla\CMS\Encrypt


Joomla CMS: Référence du fichier Uuid.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
Structures de données | Espaces de nommage
Référence du fichier Uuid.php

Structures de données

class Uuid

Espaces de nommage

Ramsey\Uuid


Joomla CMS: Référence du fichier TemplatesModel.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_templates
  • src
  • Model
Structures de données | Espaces de nommage
Référence du fichier administrator/components/com_templates/src/Model/TemplatesModel.php

Structures de données

class TemplatesModel

Espaces de nommage

Joomla\Administrator
Joomla\Component\Templates\Administrator\Model


Joomla CMS: Référence du fichier SectionField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_fields
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier SectionField.php

Structures de données

class SectionField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Fields\Administrator\Field


Joomla CMS: Référence du fichier x0b8.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • voku
  • portable-ascii
  • src
  • voku
  • helper
  • data
Variables
Référence du fichier x0b8.php

Variables

return ['reoss', 'reong', 'reoj', 'reoc', 'reok', 'reot', 'reop', 'reoh', 're', 'reg', 'regg', 'regs', 'ren', 'renj', 'renh', 'red', 'rel', 'relg', 'relm', 'relb', 'rels', 'relt', 'relp', 'relh', 'rem', 'reb', 'rebs', 'res', 'ress', 'reng', 'rej', 'rec', 'rek', 'ret', 'rep', 'reh', 'ryeo', 'ryeog', 'ryeogg', 'ryeogs', 'ryeon', 'ryeonj', 'ryeonh', 'ryeod', 'ryeol', 'ryeolg', 'ryeolm', 'ryeolb', 'ryeols', 'ryeolt', 'ryeolp', 'ryeolh', 'ryeom', 'ryeob', 'ryeobs', 'ryeos', 'ryeoss', 'ryeong', 'ryeoj', 'ryeoc', 'ryeok', 'ryeot', 'ryeop', 'ryeoh', 'rye', 'ryeg', 'ryegg', 'ryegs', 'ryen', 'ryenj', 'ryenh', 'ryed', 'ryel', 'ryelg', 'ryelm', 'ryelb', 'ryels', 'ryelt', 'ryelp', 'ryelh', 'ryem', 'ryeb', 'ryebs', 'ryes', 'ryess', 'ryeng', 'ryej', 'ryec', 'ryek', 'ryet', 'ryep', 'ryeh', 'ro', 'rog', 'rogg', 'rogs', 'ron', 'ronj', 'ronh', 'rod', 'rol', 'rolg', 'rolm', 'rolb', 'rols', 'rolt', 'rolp', 'rolh', 'rom', 'rob', 'robs', 'ros', 'ross', 'rong', 'roj', 'roc', 'rok', 'rot', 'rop', 'roh', 'rwa', 'rwag', 'rwagg', 'rwags', 'rwan', 'rwanj', 'rwanh', 'rwad', 'rwal', 'rwalg', 'rwalm', 'rwalb', 'rwals', 'rwalt', 'rwalp', 'rwalh', 'rwam', 'rwab', 'rwabs', 'rwas', 'rwass', 'rwang', 'rwaj', 'rwac', 'rwak', 'rwat', 'rwap', 'rwah', 'rwae', 'rwaeg', 'rwaegg', 'rwaegs', 'rwaen', 'rwaenj', 'rwaenh', 'rwaed', 'rwael', 'rwaelg', 'rwaelm', 'rwaelb', 'rwaels', 'rwaelt', 'rwaelp', 'rwaelh', 'rwaem', 'rwaeb', 'rwaebs', 'rwaes', 'rwaess', 'rwaeng', 'rwaej', 'rwaec', 'rwaek', 'rwaet', 'rwaep', 'rwaeh', 'roe', 'roeg', 'roegg', 'roegs', 'roen', 'roenj', 'roenh', 'roed', 'roel', 'roelg', 'roelm', 'roelb', 'roels', 'roelt', 'roelp', 'roelh', 'roem', 'roeb', 'roebs', 'roes', 'roess', 'roeng', 'roej', 'roec', 'roek', 'roet', 'roep', 'roeh', 'ryo', 'ryog', 'ryogg', 'ryogs', 'ryon', 'ryonj', 'ryonh', 'ryod', 'ryol', 'ryolg', 'ryolm', 'ryolb', 'ryols', 'ryolt', 'ryolp', 'ryolh', 'ryom', 'ryob', 'ryobs', 'ryos', 'ryoss', 'ryong', 'ryoj', 'ryoc', 'ryok', 'ryot', 'ryop', 'ryoh', 'ru', 'rug', 'rugg', 'rugs', 'run', 'runj', 'runh', 'rud', 'rul', 'rulg', 'rulm', 'rulb', 'ruls', 'rult', 'rulp', 'rulh', 'rum', 'rub', 'rubs', 'rus', 'russ', 'rung', 'ruj', 'ruc']

Documentation des variables

◆ return

return[ 'reoss', 'reong', 'reoj', 'reoc', 'reok', 'reot', 'reop', 'reoh', 're', 'reg', 'regg', 'regs', 'ren', 'renj', 'renh', 'red', 'rel', 'relg', 'relm', 'relb', 'rels', 'relt', 'relp', 'relh', 'rem', 'reb', 'rebs', 'res', 'ress', 'reng', 'rej', 'rec', 'rek', 'ret', 'rep', 'reh', 'ryeo', 'ryeog', 'ryeogg', 'ryeogs', 'ryeon', 'ryeonj', 'ryeonh', 'ryeod', 'ryeol', 'ryeolg', 'ryeolm', 'ryeolb', 'ryeols', 'ryeolt', 'ryeolp', 'ryeolh', 'ryeom', 'ryeob', 'ryeobs', 'ryeos', 'ryeoss', 'ryeong', 'ryeoj', 'ryeoc', 'ryeok', 'ryeot', 'ryeop', 'ryeoh', 'rye', 'ryeg', 'ryegg', 'ryegs', 'ryen', 'ryenj', 'ryenh', 'ryed', 'ryel', 'ryelg', 'ryelm', 'ryelb', 'ryels', 'ryelt', 'ryelp', 'ryelh', 'ryem', 'ryeb', 'ryebs', 'ryes', 'ryess', 'ryeng', 'ryej', 'ryec', 'ryek', 'ryet', 'ryep', 'ryeh', 'ro', 'rog', 'rogg', 'rogs', 'ron', 'ronj', 'ronh', 'rod', 'rol', 'rolg', 'rolm', 'rolb', 'rols', 'rolt', 'rolp', 'rolh', 'rom', 'rob', 'robs', 'ros', 'ross', 'rong', 'roj', 'roc', 'rok', 'rot', 'rop', 'roh', 'rwa', 'rwag', 'rwagg', 'rwags', 'rwan', 'rwanj', 'rwanh', 'rwad', 'rwal', 'rwalg', 'rwalm', 'rwalb', 'rwals', 'rwalt', 'rwalp', 'rwalh', 'rwam', 'rwab', 'rwabs', 'rwas', 'rwass', 'rwang', 'rwaj', 'rwac', 'rwak', 'rwat', 'rwap', 'rwah', 'rwae', 'rwaeg', 'rwaegg', 'rwaegs', 'rwaen', 'rwaenj', 'rwaenh', 'rwaed', 'rwael', 'rwaelg', 'rwaelm', 'rwaelb', 'rwaels', 'rwaelt', 'rwaelp', 'rwaelh', 'rwaem', 'rwaeb', 'rwaebs', 'rwaes', 'rwaess', 'rwaeng', 'rwaej', 'rwaec', 'rwaek', 'rwaet', 'rwaep', 'rwaeh', 'roe', 'roeg', 'roegg', 'roegs', 'roen', 'roenj', 'roenh', 'roed', 'roel', 'roelg', 'roelm', 'roelb', 'roels', 'roelt', 'roelp', 'roelh', 'roem', 'roeb', 'roebs', 'roes', 'roess', 'roeng', 'roej', 'roec', 'roek', 'roet', 'roep', 'roeh', 'ryo', 'ryog', 'ryogg', 'ryogs', 'ryon', 'ryonj', 'ryonh', 'ryod', 'ryol', 'ryolg', 'ryolm', 'ryolb', 'ryols', 'ryolt', 'ryolp', 'ryolh', 'ryom', 'ryob', 'ryobs', 'ryos', 'ryoss', 'ryong', 'ryoj', 'ryoc', 'ryok', 'ryot', 'ryop', 'ryoh', 'ru', 'rug', 'rugg', 'rugs', 'run', 'runj', 'runh', 'rud', 'rul', 'rulg', 'rulm', 'rulb', 'ruls', 'rult', 'rulp', 'rulh', 'rum', 'rub', 'rubs', 'rus', 'russ', 'rung', 'ruj', 'ruc']


Joomla CMS: Référence du fichier SystemNodeProvider.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • ramsey
  • uuid
  • src
  • Provider
  • Node
Structures de données | Espaces de nommage
Référence du fichier SystemNodeProvider.php

Structures de données

class SystemNodeProvider

Espaces de nommage

Ramsey\Uuid\Provider\Node


Joomla CMS: Référence du fichier Router.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • components
  • com_contact
  • src
  • Service
Structures de données | Espaces de nommage
Référence du fichier components/com_contact/src/Service/Router.php

Structures de données

class Router

Espaces de nommage

Joomla\Site
Joomla\Component\Contact\Site\Service


Joomla CMS: Référence du fichier PasswordRule.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • src
  • Form
  • Rule
Structures de données | Espaces de nommage
Référence du fichier PasswordRule.php

Structures de données

class PasswordRule

Espaces de nommage

Joomla\CMS\Form\Rule


Joomla CMS: Référence du fichier UnsupportedHeaderFound.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Token
Structures de données | Espaces de nommage
Référence du fichier UnsupportedHeaderFound.php

Structures de données

class UnsupportedHeaderFound

Espaces de nommage

Lcobucci\JWT\Token


Joomla CMS: Référence du fichier Validator.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • lcobucci
  • jwt
  • src
  • Validation
Structures de données | Espaces de nommage
Référence du fichier Validation/Validator.php

Structures de données

class Validator

Espaces de nommage

Lcobucci\JWT\Validation


Joomla CMS: Référence du fichier PluginElementField.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • administrator
  • components
  • com_plugins
  • src
  • Field
Structures de données | Espaces de nommage
Référence du fichier PluginElementField.php

Structures de données

class PluginElementField

Espaces de nommage

Joomla\Administrator
Joomla\Component\Plugins\Administrator\Field


Joomla CMS: Référence du fichier togglebutton.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • layouts
  • joomla
  • tinymce
Espaces de nommage
Référence du fichier togglebutton.php

Espaces de nommage

Joomla\Site


Joomla CMS: Référence du fichier UuidCaster.php

  • C:
  • laragon
  • www
  • _install
  • Joomla_422-Stable-Full_Package_French_v1
  • libraries
  • vendor
  • symfony
  • var-dumper
  • Caster
Structures de données | Espaces de nommage
Référence du fichier UuidCaster.php

Structures de données

class UuidCaster

Espaces de nommage

Symfony\Component\VarDumper\Caster